Quran Index

Bukhari :: Muslim :: Malik :: Dawud Hadith Collection

This EBook is 4 Hadith collections in one and contains over 18,000 Hadith from the following:
  • Complete Sahih Bukhari
  • Complete Sahih Muslim
  • Complete Malik's Muwatta
  • Partial Abu Dawud

It features full text search, bookmarks, and easy to use navigation. Now you can search for a topic and cross-reference between all four collections!

Inshallah there are no mistakes, but if you do find any, please report them to imaanstar@earthlink.net

You can download our latest releases of ebooks and software at http://www.imaanstar.com

*Source material for are from the University of Southern California MSA site


Bukhari :: Revelation :: [1.1.1]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 1

Narrated 'Umar bin Al-Khattab:

I heard Allah's Apostle saying, "The reward of deeds depends upon the intentions and every person will get the reward according to what he has intended. So whoever emigrated for worldly benefits or for a woman to marry, his emigration was for what he emigrated for."


Bukhari :: Revelation :: [1.1.2]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 2

Narrated 'Aisha:

(the mother of the faithful believers) Al-Harith bin Hisham asked Allah's Apostle "O Allah's Apostle! How is the Divine Inspiration revealed to you?" Allah's Apostle replied, "Sometimes it is (revealed) like the ringing of a bell, this form of Inspiration is the hardest of all and then this state passes ' off after I have grasped what is inspired. Sometimes the Angel comes in the form of a man and talks to me and I grasp whatever he says." 'Aisha added: Verily I saw the Prophet being inspired Divinely on a very cold day and noticed the Sweat dropping from his forehead (as the Inspiration was over).


Bukhari :: Revelation :: [1.1.3]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 3

Narrated 'Aisha:

(the mother of the faithful believers) The commencement of the Divine Inspiration to Allah's Apostle was in the form of good dreams which came true like bright day light, and then the love of seclusion was bestowed upon him. He used to go in seclusion in the cave of Hira where he used to worship (Allah alone) continuously for many days before his desire to see his family. He used to take with him the journey food for the stay and then come back to (his wife) Khadija to take his food like-wise again till suddenly the Truth descended upon him while he was in the cave of Hira. The angel came to him and asked him to read. The Prophet replied, "I do not know how to read.

The Prophet added, "The angel caught me (forcefully) and pressed me so hard that I could not bear it any more. He then released me and again asked me to read and I replied, 'I do not know how to read.' Thereupon he caught me again and pressed me a second time till I could not bear it any more. He then released me and again asked me to read but again I replied, 'I do not know how to read (or what shall I read)?' Thereupon he caught me for the third time and pressed me, and then released me and said, 'Read in the name of your Lord, who has created (all that exists) has created man from a clot. Read! And your Lord is the Most Generous." (96.1, 96.2, 96.3) Then Allah's Apostle returned with the Inspiration and with his heart beating severely. Then he went to Khadija bint Khuwailid and said, "Cover me! Cover me!" They covered him till his fear was over and after that he told her everything that had happened and said, "I fear that something may happen to me." Khadija replied, "Never! By Allah, Allah will never disgrace you. You keep good relations with your Kith and kin, help the poor and the destitute, serve your guests generously and assist the deserving calamity-afflicted ones."

Khadija then accompanied him to her cousin Waraqa bin Naufal bin Asad bin 'Abdul 'Uzza, who, during the PreIslamic Period became a Christian and used to write the writing with Hebrew letters. He would write from the Gospel in Hebrew as much as Allah wished him to write. He was an old man and had lost his eyesight. Khadija said to Waraqa, "Listen to the story of your nephew, O my cousin!" Waraqa asked, "O my nephew! What have you seen?" Allah's Apostle described whatever he had seen. Waraqa said, "This is the same one who keeps the secrets (angel Gabriel) whom Allah had sent to Moses. I wish I were young and could live up to the time when your people would turn you out." Allah's Apostle asked, "Will they drive me out?" Waraqa replied in the affirmative and said, "Anyone (man) who came with something similar to what you have brought was treated with hostility; and if I should remain alive till the day when you will be turned out then I would support you strongly." But after a few days Waraqa died and the Divine Inspiration was also paused for a while.

Narrated Jabir bin 'Abdullah Al-Ansari while talking about the period of pause in revelation reporting the speech of the Prophet "While I was walking, all of a sudden I heard a voice from the sky. I looked up and saw the same angel who had visited me at the cave of Hira' sitting on a chair between the sky and the earth. I got afraid of him and came back home and said, 'Wrap me (in blankets).' And then Allah revealed the following Holy Verses (of Quran):

'O you (i.e. Muhammad)! wrapped up in garments!' Arise and warn (the people against Allah's Punishment),... up to 'and desert the idols.' (74.1-5) After this the revelation started coming strongly, frequently and regularly."


Bukhari :: Revelation :: [1.1.4]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 4

Narrated Said bin Jubair:

Ibn 'Abbas in the explanation of the Statement of Allah. 'Move not your tongue concerning (the Quran) to make haste therewith." (75.16) Said "Allah's Apostle used to bear the revelation with great trouble and used to move his lips (quickly) with the Inspiration." Ibn 'Abbas moved his lips saying, "I am moving my lips in front of you as Allah's Apostle used to move his." Said moved his lips saying: "I am moving my lips, as I saw Ibn 'Abbas moving his." Ibn 'Abbas added, "So Allah revealed 'Move not your tongue concerning (the Qur'an) to make haste therewith. It is for us to collect it and to give you (O Muhammad) the ability to recite it (the Qur'an) (75.16-17) which means that Allah will make him (the Prophet ) remember the portion of the Qur'an which was revealed at that time by heart and recite it. The Statement of Allah: And 'When we have recited it to you (O Muhammad through Gabriel) then you follow its (Qur'an) recital' (75.18) means 'listen to it and be silent.' Then it is for Us (Allah) to make It clear to you' (75.19) means 'Then it is (for Allah) to make you recite it (and its meaning will be clear by itself through your tongue). Afterwards, Allah's Apostle used to listen to Gabriel whenever he came and after his departure he used to recite it as Gabriel had recited it."


Bukhari :: Revelation :: [1.1.5]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 5

Narrated Ibn 'Abbas:

Allah's Apostle was the most generous of all the people, and he used to reach the peak in generosity in the month of Ramadan when Gabriel met him. Gabriel used to meet him every night of Ramadan to teach him the Qur'an. Allah's Apostle was the most generous person, even more generous than the strong uncontrollable wind (in readiness and haste to do charitable deeds).


Bukhari :: Revelation :: [1.1.6]

Revelation

Bukhari :: Book 1 :: Volume 1 :: Hadith 6

Narrated 'Abdullah bin 'Abbas:

Abu Sufyan bin Harb informed me that Heraclius had sent a messenger to him while he had been accompanying a caravan from Quraish. They were merchants doing business in Sham (Syria, Palestine, Lebanon and Jordan), at the time when Allah's Apostle had truce with Abu Sufyan and Quraish infidels. So Abu Sufyan and his companions went to Heraclius at Ilya (Jerusalem). Heraclius called them in the court and he had all the senior Roman dignitaries around him. He called for his translator who, translating Heraclius's question said to them, "Who amongst you is closely related to that man who claims to be a Prophet?" Abu Sufyan replied, "I am the nearest relative to him (amongst the group)."

Heraclius said, "Bring him (Abu Sufyan) close to me and make his companions stand behind him." Abu Sufyan added, Heraclius told his translator to tell my companions that he wanted to put some questions to me regarding that man (The Prophet) and that if I told a lie they (my companions) should contradict me." Abu Sufyan added, "By Allah! Had I not been afraid of my companions labeling me a liar, I would not have spoken the truth about the Prophet. The first question he asked me about him was:

'What is his family status amongst you?'

I replied, 'He belongs to a good (noble) family amongst us.'

Heraclius further asked, 'Has anybody amongst you ever claimed the same (i.e. to be a Prophet) before him?'

I replied, 'No.'

He said, 'Was anybody amongst his ancestors a king?'

I replied, 'No.'

Heraclius asked, 'Do the nobles or the poor follow him?'

I replied, 'It is the poor who follow him.'

He said, 'Are his followers increasing decreasing (day by day)?'

I replied, 'They are increasing.'

He then asked, 'Does anybody amongst those who embrace his religion become displeased and renounce the religion afterwards?'

I replied, 'No.'

Heraclius said, 'Have you ever accused him of telling lies before his claim (to be a Prophet)?'

I replied, 'No. '

Heraclius said, 'Does he break his promises?'

I replied, 'No. We are at truce with him but we do not know what he will do in it.' I could not find opportunity to say anything against him except that.

Heraclius asked, 'Have you ever had a war with him?'

I replied, 'Yes.'

Then he said, 'What was the outcome of the battles?'

I replied, 'Sometimes he was victorious and sometimes we.'

Heraclius said, 'What does he order you to do?'

I said, 'He tells us to worship Allah and Allah alone and not to worship anything along with Him, and to renounce all that our ancestors had said. He orders us to pray, to speak the truth, to be chaste and to keep good relations with our Kith and kin.'

Heraclius asked the translator to convey to me the following, I asked you about his family and your reply was that he belonged to a very noble family. In fact all the Apostles come from noble families amongst their respective peoples. I questioned you whether anybody else amongst you claimed such a thing, your reply was in the negative. If the answer had been in the affirmative, I would have thought that this man was following the previous man's statement. Then I asked you whether anyone of his ancestors was a king. Your reply was in the negative, and if it had been in the affirmative, I would have thought that this man wanted to take back his ancestral kingdom.

I further asked whether he was ever accused of telling lies before he said what he said, and your reply was in the negative. So I wondered how a person who does not tell a lie about others could ever tell a lie about Allah. I, then asked you whether the rich people followed him or the poor. You replied that it was the poor who followed him. And in fact all the Apostle have been followed by this very class of people. Then I asked you whether his followers were increasing or decreasing. You replied that they were increasing, and in fact this is the way of true faith, till it is complete in all respects. I further asked you whether there was anybody, who, after embracing his religion, became displeased and discarded his religion. Your reply was in the negative, and in fact this is (the sign of) true faith, when its delight enters the hearts and mixes with them completely. I asked you whether he had ever betrayed. You replied in the negative and likewise the Apostles never betray. Then I asked you what he ordered you to do. You replied that he ordered you to worship Allah and Allah alone and not to worship any thing along with Him and forbade you to worship idols and ordered you to pray, to speak the truth and to be chaste. If what you have said is true, he will very soon occupy this place underneath my feet and I knew it (from the scriptures) that he was going to appear but I did not know that he would be from you, and if I could reach him definitely, I would go immediately to meet him and if I were with him, I would certainly wash his feet.' Heraclius then asked for the letter addressed by Allah's Apostle

which was delivered by Dihya to the Governor of Busra, who forwarded it to Heraclius to read. The contents of the letter were as follows: "In the name of Allah the Beneficent, the Merciful (This letter is) from Muhammad the slave of Allah and His Apostle to Heraclius the ruler of Byzantine. Peace be upon him, who follows the right path. Furthermore I invite you to Islam, and if you become a Muslim you will be safe, and Allah will double your reward, and if you reject this invitation of Islam you will be committing a sin by misguiding your Arisiyin (peasants). (And I recite to you Allah's Statement:)

'O people of the scripture! Come to a word common to you and us that we worship none but Allah and that we associate nothing in worship with Him, and that none of us shall take others as Lords beside Allah. Then, if they turn away, say: Bear witness that we are Muslims (those who have surrendered to Allah).' (3:64).

Abu Sufyan then added, "When Heraclius had finished his speech and had read the letter, there was a great hue and cry in the Royal Court. So we were turned out of the court. I told my companions that the question of Ibn-Abi-Kabsha) (the Prophet Muhammad) has become so prominent that even the King of Bani Al-Asfar (Byzantine) is afraid of him. Then I started to become sure that he (the Prophet) would be the conqueror in the near future till I embraced Islam (i.e. Allah guided me to it)."

The sub narrator adds, "Ibn An-Natur was the Governor of llya' (Jerusalem) and Heraclius was the head of the Christians of Sham. Ibn An-Natur narrates that once while Heraclius was visiting ilya' (Jerusalem), he got up in the morning with a sad mood. Some of his priests asked him why he was in that mood? Heraclius was a foreteller and an astrologer. He replied, 'At night when I looked at the stars, I saw that the leader of those who practice circumcision had appeared (become the conqueror). Who are they who practice circumcision?' The people replied, 'Except the Jews nobody practices circumcision, so you should not be afraid of them (Jews).

'Just Issue orders to kill every Jew present in the country.'

While they were discussing it, a messenger sent by the king of Ghassan to convey the news of Allah's Apostle to Heraclius was brought in. Having heard the news, he (Heraclius) ordered the people to go and see whether the messenger of Ghassan was circumcised. The people, after seeing him, told Heraclius that he was circumcised. Heraclius then asked him about the Arabs. The messenger replied, 'Arabs also practice circumcision.'

(After hearing that) Heraclius remarked that sovereignty of the 'Arabs had appeared. Heraclius then wrote a letter to his friend in Rome who was as good as Heraclius in knowledge. Heraclius then left for Homs. (a town in Syrian and stayed there till he received the reply of his letter from his friend who agreed with him in his opinion about the emergence of the Prophet and the fact that he was a Prophet. On that Heraclius invited all the heads of the Byzantines to assemble in his palace at Homs. When they assembled, he ordered that all the doors of his palace be closed. Then he came out and said, 'O Byzantines! If success is your desire and if you seek right guidance and want your empire to remain then give a pledge of allegiance to this Prophet (i.e. embrace Islam).'

(On hearing the views of Heraclius) the people ran towards the gates of the palace like onagers but found the doors closed. Heraclius realized their hatred towards Islam and when he lost the hope of their embracing Islam, he ordered that they should be brought back in audience.

(When they returned) he said, 'What already said was just to test the strength of your conviction and I have seen it.' The people prostrated before him and became pleased with him, and this was the end of Heraclius's story (in connection with his faith).


Bukhari :: Belief :: [1.2.7]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 7

Narrated Ibn 'Umar:

Allah's Apostle said: Islam is based on (the following) five (principles):

1. To testify that none has the right to be worshipped but Allah and Muhammad is Allah's Apostle.

2. To offer the (compulsory congregational) prayers dutifully and perfectly.

3. To pay Zakat (i.e. obligatory charity) .

4. To perform Hajj. (i.e. Pilgrimage to Mecca)

5. To observe fast during the month of Ramadan.


Bukhari :: Belief :: [1.2.8]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 8

Narrated Abu Huraira:

The Prophet said, "Faith (Belief) consists of more than sixty branches (i.e. parts). And Haya (This term "Haya" covers a large number of concepts which are to be taken together; amongst them are self respect, modesty, bashfulness, and scruple, etc.) is a part of faith."


Bukhari :: Belief :: [1.2.9]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 9

Narrated 'Abdullah bin 'Amr:

The Prophet said, "A Muslim is the one who avoids harming Muslims with his tongue and hands. And a Muhajir (emigrant) is the one who gives up (abandons) all what Allah has forbidden."


Bukhari :: Belief :: [1.2.10]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 10

Narrated Abu Musa:

Some people asked Allah's Apostle, "Whose Islam is the best? i.e. (Who is a very good Muslim)?" He replied, "One who avoids harming the Muslims with his tongue and hands."


Bukhari :: Belief :: [1.2.11]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 11

Narrated 'Abdullah bin 'Amr:

A man asked the Prophet , "What sort of deeds or (what qualities of) Islam are good?" The Prophet replied, 'To feed (the poor) and greet those whom you know and those whom you do not Know (See Hadith No. 27).


Bukhari :: Belief :: [1.2.12]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 12

Narrated Anas:

The Prophet said, "None of you will have faith till he wishes for his (Muslim) brother what he likes for himself."


Bukhari :: Belief :: [1.2.13]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 13

Narrated Abu Huraira:

"Allah's Apostle said, "By Him in Whose Hands my life is, none of you will have faith till he loves me more than his father and his children."


Bukhari :: Belief :: [1.2.14]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 14

Narrated Anas:

The Prophet said "None of you will have faith till he loves me more than his father, his children and all mankind."


Bukhari :: Belief :: [1.2.15]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 15

Narrated Anas:

The Prophet said, "Whoever possesses the following three qualities will have the sweetness (delight) of faith:

1. The one to whom Allah and His Apostle becomes dearer than anything else.

2. Who loves a person and he loves him only for Allah's sake.

3. Who hates to revert to Atheism (disbelief) as he hates to be thrown into the fire."


Bukhari :: Belief :: [1.2.16]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 16

Narrated Anas:

The Prophet said, "Love for the Ansar is a sign of faith and hatred for the Ansar is a sign of hypocrisy."


Bukhari :: Belief :: [1.2.17]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 17

Narrated 'Ubada bin As-Samit:

who took part in the battle of Badr and was a Naqib (a person heading a group of six persons), on the night of Al-'Aqaba pledge: Allah's Apostle said while a group of his companions were around him, "Swear allegiance to me for:

1. Not to join anything in worship along with Allah.

2. Not to steal.

3. Not to commit illegal sexual intercourse.

4. Not to kill your children.

5. Not to accuse an innocent person (to spread such an accusation among people).

6. Not to be disobedient (when ordered) to do good deed."

The Prophet added: "Whoever among you fulfills his pledge will be rewarded by Allah. And whoever indulges in any one of them (except the ascription of partners to Allah) and gets the punishment in this world, that punishment will be an expiation for that sin. And if one indulges in any of them, and Allah conceals his sin, it is up to Him to forgive or punish him (in the Hereafter)." 'Ubada bin As-Samit added: "So we swore allegiance for these." (points to Allah's Apostle)


Bukhari :: Belief :: [1.2.18]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 18

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "A time will come that the best property of a Muslim will be sheep which he will take on the top of mountains and the places of rainfall (valleys) so as to flee with his religion from afflictions."


Bukhari :: Belief :: [1.2.19]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 19

Narrated 'Aisha:

Whenever Allah's Apostle ordered the Muslims to do something, he used to order them deeds which were easy for them to do, (according to their strength endurance). They said, "O Allah's Apostle! We are not like you. Allah has forgiven your past and future sins." So Allah's Apostle became angry and it was apparent on his face. He said, "I am the most Allah fearing, and know Allah better than all of you do."


Bukhari :: Belief :: [1.2.20]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 20

Narrated Anas:

The Prophet said, "Whoever possesses the following three qualities will taste the sweetness of faith:

1. The one to whom Allah and His Apostle become dearer than anything else.

2. Who loves a person and he loves him only for Allah's sake.

3. Who hates to revert to disbelief (Atheism) after Allah has brought (saved) him out from it, as he hates to be thrown in fire."


Bukhari :: Belief :: [1.2.21]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 21

Narrated Abu Said Al-Khudri:

The Prophet said, "When the people of Paradise will enter Paradise and the people of Hell will go to Hell, Allah will order those who have had faith equal to the weight of a grain of mustard seed to be taken out from Hell. So they will be taken out but (by then) they will be blackened (charred). Then they will be put in the river of Haya' (rain) or Hayat (life) (the Narrator is in doubt as to which is the right term), and they will revive like a grain that grows near the bank of a flood channel. Don't you see that it comes out yellow and twisted"


Bukhari :: Belief :: [1.2.22]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 22

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "While I was sleeping I saw (in a dream) some people wearing shirts of which some were reaching up to the breasts only while others were even shorter than that. Umar bin Al-Khattab was shown wearing a shirt that he was dragging." The people asked, "How did you interpret it? (What is its interpretation) O Allah's Apostle?" He (the Prophet ) replied, "It is the Religion."


Bukhari :: Belief :: [1.2.23]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 23

Narrated 'Abdullah (bin 'Umar):

Once Allah's Apostle passed by an Ansari (man) who was admonishing to his brother regarding Haya'. On that Allah's Apostle said, "Leave him as Haya' is a part of faith." (See Hadith No. 8)


Bukhari :: Belief :: [1.2.24]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 24

Narrated Ibn 'Umar:

Allah's Apostle said: "I have been ordered (by Allah) to fight against the people until they testify that none has the right to be worshipped but Allah and that Muhammad is Allah's Apostle, and offer the prayers perfectly and give the obligatory charity, so if they perform a that, then they save their lives an property from me except for Islamic laws and then their reckoning (accounts) will be done by Allah."


Bukhari :: Belief :: [1.2.25]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 25

Narrated Abu Huraira:

Allah's Apostle was asked, "What is the best deed?" He replied, "To believe in Allah and His Apostle (Muhammad). The questioner then asked, "What is the next (in goodness)? He replied, "To participate in Jihad (religious fighting) in Allah's Cause." The questioner again asked, "What is the next (in goodness)?" He replied, "To perform Hajj (Pilgrim age to Mecca) 'Mubrur, (which is accepted by Allah and is performed with the intention of seeking Allah's pleasure only and not to show off and without committing a sin and in accordance with the traditions of the Prophet)."


Bukhari :: Belief :: [1.2.26]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 26

Narrated Sa'd:

Allah's Apostle distributed (Zakat) amongst (a group of) people while I was sitting there but Allah's Apostle left a man whom I thought the best of the lot. I asked, "O Allah's Apostle! Why have you left that person? By Allah I regard him as a faithful believer." The Prophet commented: "Or merely a Muslim." I remained quiet for a while, but could not help repeating my question because of what I knew about him. And then asked Allah's Apostle, "Why have you left so and so? By Allah! He is a faithful believer." The Prophet again said, "Or merely a Muslim." And I could not help repeating my question because of what I knew about him. Then the Prophet said, "O Sa'd! I give to a person while another is dearer to me, for fear that he might be thrown on his face in the Fire by Allah."


Bukhari :: Belief :: [1.2.27]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 27

Narrated 'Abdullah bin 'Amr:

A person asked Allah's Apostle . "What (sort of) deeds in or (what qualities of) Islam are good?" He replied, "To feed (the poor) and greet those whom you know and those whom you don't know."


Bukhari :: Belief :: [1.2.28]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 28

Narrated Ibn 'Abbas:

The Prophet said: "I was shown the Hell-fire and that the majority of its dwellers were women who were ungrateful." It was asked, "Do they disbelieve in Allah?" (or are they ungrateful to Allah?) He replied, "They are ungrateful to their husbands and are ungrateful for the favors and the good (charitable deeds) done to them. If you have always been good (benevolent) to one of them and then she sees something in you (not of her liking), she will say, 'I have never received any good from you."


Bukhari :: Belief :: [1.2.29]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 29

Narrated Al-Ma'rur:

At Ar-Rabadha I met Abu Dhar who was wearing a cloak, and his slave, too, was wearing a similar one. I asked about the reason for it. He replied, "I abused a person by calling his mother with bad names." The Prophet said to me, 'O Abu Dhar! Did you abuse him by calling his mother with bad names You still have some characteristics of ignorance. Your slaves are your brothers and Allah has put them under your command. So whoever has a brother under his command should feed him of what he eats and dress him of what he wears. Do not ask them (slaves) to do things beyond their capacity (power) and if you do so, then help them.' "


Bukhari :: Belief :: [1.2.30]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 30

Narrated Al-Ahnaf bin Qais:

While I was going to help this man ('Ali Ibn Abi Talib), Abu Bakra met me and asked, "Where are you going?" I replied, "I am going to help that person." He said, "Go back for I have heard Allah's Apostle saying, 'When two Muslims fight (meet) each other with their swords, both the murderer as well as the murdered will go to the Hell-fire.' I said, 'O Allah's Apostle! It is all right for the murderer but what about the murdered one?' Allah's Apostle replied, "He surely had the intention to kill his companion."


Bukhari :: Belief :: [1.2.31]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 31

Narrated 'Abdullah:

When the following Verse was revealed: "It is those who believe and confuse not their belief with wrong (worshipping others besides Allah.)" (6:83), the companions of Allah's Apostle asked, "Who is amongst us who had not done injustice (wrong)?" Allah revealed: "No doubt, joining others in worship with Allah is a great injustice (wrong) indeed." (31.13)


Bukhari :: Belief :: [1.2.32]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 32

Narrated Abu Huraira:

The Prophet said, "The signs of a hypocrite are three:

1. Whenever he speaks, he tells a lie.

2. Whenever he promises, he always breaks it (his promise ).

3. If you trust him, he proves to be dishonest. (If you keep something as a trust with him, he will not return it.)"


Bukhari :: Belief :: [1.2.33]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 33

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Whoever has the following four (characteristics) will be a pure hypocrite and whoever has one of the following four characteristics will have one characteristic of hypocrisy unless and until he gives it up.

1. Whenever he is entrusted, he betrays.

2. Whenever he speaks, he tells a lie.

3. Whenever he makes a covenant, he proves treacherous.

4. Whenever he quarrels, he behaves in a very imprudent, evil and insulting manner."


Bukhari :: Belief :: [1.2.34]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 34

Narrated Abu Huraira:

Allah's Apostle said, "Whoever establishes the prayers on the night of Qadr out of sincere faith and hoping to attain Allah's rewards (not to show off) then all his past sins will be forgiven."


Bukhari :: Belief :: [1.2.35]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 35

Narrated Abu Huraira:

The Prophet said, "The person who participates in (Holy battles) in Allah's cause and nothing compels him to do so except belief in Allah and His Apostles, will be recompensed by Allah either with a reward, or booty (if he survives) or will be admitted to Paradise (if he is killed in the battle as a martyr). Had I not found it difficult for my followers, then I would not remain behind any sariya going for Jihad and I would have loved to be martyred in Allah's cause and then made alive, and then martyred and then made alive, and then again martyred in His cause."


Bukhari :: Belief :: [1.2.36]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 36

Narrated Abu Huraira:

Allah's Apostle said: "Whoever establishes prayers during the nights of Ramadan faithfully out of sincere faith and hoping to attain Allah's rewards (not for showing off), all his past sins will be forgiven."


Bukhari :: Belief :: [1.2.37]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 37

Narrated Abu Huraira:

Allah's Apostle said, "Whoever observes fasts during the month of Ramadan out of sincere faith, and hoping to attain Allah's rewards, then all his past sins will be forgiven."


Bukhari :: Belief :: [1.2.38]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 38

Narrated Abu Huraira:

The Prophet said, "Religion is very easy and whoever overburdens himself in his religion will not be able to continue in that way. So you should not be extremists, but try to be near to perfection and receive the good tidings that you will be rewarded; and gain strength by worshipping in the mornings, the nights." (See Fath-ul-Bari, Page 102, Vol 1).


Bukhari :: Belief :: [1.2.39]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 39

Narrated Al-Bara' (bin 'Azib):

When the Prophet came to Medina, he stayed first with his grandfathers or maternal uncles from Ansar. He offered his prayers facing Baitul-Maqdis (Jerusalem) for sixteen or seventeen months, but he wished that he could pray facing the Ka'ba (at Mecca). The first prayer which he offered facing the Ka'ba was the 'Asr prayer in the company of some people. Then one of those who had offered that prayer with him came out and passed by some people in a mosque who were bowing during their prayers (facing Jerusalem). He said addressing them, "By Allah, I testify that I have prayed with Allah's Apostle facing Mecca (Ka'ba).' Hearing that, those people changed their direction towards the Ka'ba immediately. Jews and the people of the scriptures used to be pleased to see the Prophet facing Jerusalem in prayers but when he changed his direction towards the Ka'ba, during the prayers, they disapproved of it.

Al-Bara' added, "Before we changed our direction towards the Ka'ba (Mecca) in prayers, some Muslims had died or had been killed and we did not know what to say about them (regarding their prayers.) Allah then revealed: And Allah would never make your faith (prayers) to be lost (i.e. the prayers of those Muslims were valid).' " (2:143).


Bukhari :: Belief :: [1.2.40]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 40

Narrated Abu Huraira:

Allah's Apostle said, "If any one of you improve (follows strictly) his Islamic religion then his good deeds will be rewarded ten times to seven hundred times for each good deed and a bad deed will be recorded as it is."


Bukhari :: Belief :: [1.2.41]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 41

Narrated 'Aisha:

Once the Prophet came while a woman was sitting with me. He said, "Who is she?" I replied, "She is so and so," and told him about her (excessive) praying. He said disapprovingly, "Do (good) deeds which is within your capacity (without being overtaxed) as Allah does not get tired (of giving rewards) but (surely) you will get tired and the best deed (act of Worship) in the sight of Allah is that which is done regularly."


Bukhari :: Belief :: [1.2.42]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 42

Narrated Anas:

The Prophet said, "Whoever said "None has the right to be worshipped but Allah and has in his heart good (faith) equal to the weight of a barley grain will be taken out of Hell. And whoever said: "None has the right to be worshipped but Allah and has in his heart good (faith) equal to the weight of a wheat grain will be taken out of Hell. And whoever said, "None has the right to be worshipped but Allah and has in his heart good (faith) equal to the weight of an atom will be taken out of Hell."


Bukhari :: Belief :: [1.2.43]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 43

Narrated 'Umar bin Al-Khattab:

Once a Jew said to me, "O the chief of believers! There is a verse in your Holy Book Which is read by all of you (Muslims), and had it been revealed to us, we would have taken that day (on which it was revealed as a day of celebration." 'Umar bin Al-Khattab asked, "Which is that verse?" The Jew replied, "This day I have perfected your religion For you, completed My favor upon you, And have chosen for you Islam as your religion." (5:3) 'Umar replied,"No doubt, we know when and where this verse was revealed to the Prophet. It was Friday and the Prophet was standing at 'Arafat (i.e. the Day of Hajj)"


Bukhari :: Belief :: [1.2.44]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 44

Narrated Talha bin 'Ubaidullah:

A man from Najd with unkempt hair came to Allah's Apostle and we heard his loud voice but could not understand what he was saying, till he came near and then we came to know that he was asking about Islam. Allah's Apostle said, "You have to offer prayers perfectly five times in a day and night (24 hours)." The man asked, "Is there any more (praying)?" Allah's Apostle replied, "No, but if you want to offer the Nawafil prayers (you can)." Allah's Apostle further said to him: "You have to observe fasts during the month of Ramad, an." The man asked, "Is there any more fasting?" Allah's Apostle replied, "No, but if you want to observe the Nawafil fasts (you can.)" Then Allah's Apostle further said to him, "You have to pay the Zakat (obligatory charity)." The man asked, "Is there any thing other than the Zakat for me to pay?" Allah's Apostle replied, "No, unless you want to give alms of your own." And then that man retreated saying, "By Allah! I will neither do less nor more than this." Allah's Apostle said, "If what he said is true, then he will be successful (i.e. he will be granted Paradise)."


Bukhari :: Belief :: [1.2.45]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 45

Narrated Abu Huraira:

Allah's Apostle said, "(A believer) who accompanies the funeral procession of a Muslim out of sincere faith and hoping to attain Allah's reward and remains with it till the funeral prayer is offered and the burial ceremonies are over, he will return with a reward of two Qirats. Each Qirat is like the size of the (Mount) Uhud. He who offers the funeral prayer only and returns before the burial, will return with the reward of one Qirat only."


Bukhari :: Belief :: [1.2.46]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 46

Narrated 'Abdullah:

The Prophet said, "Abusing a Muslim is Fusuq (an evil doing) and killing him is Kufr (disbelief)." Narrated 'Ubada bin As-Samit: "Allah's Apostle went out to inform the people about the (date of the) night of decree (Al-Qadr) but there happened a quarrel between two Muslim men. The Prophet said, "I came out to inform you about (the date of) the night of Al-Qadr, but as so and so and so and so quarrelled, its knowledge was taken away (I forgot it) and maybe it was better for you. Now look for it in the 7th, the 9th and the 5th (of the last 10 nights of the month of Ramadan)."


Bukhari :: Belief :: [1.2.47]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 47

Narrated Abu Huraira:

One day while the Prophet was sitting in the company of some people, (The angel) Gabriel came and asked, "What is faith?" Allah's Apostle replied, 'Faith is to believe in Allah, His angels, (the) meeting with Him, His Apostles, and to believe in Resurrection." Then he further asked, "What is Islam?" Allah's Apostle replied, "To worship Allah Alone and none else, to offer prayers perfectly to pay the compulsory charity (Zakat) and to observe fasts during the month of Ramadan." Then he further asked, "What is Ihsan (perfection)?" Allah's Apostle replied, "To worship Allah as if you see Him, and if you cannot achieve this state of devotion then you must consider that He is looking at you." Then he further asked, "When will the Hour be established?" Allah's Apostle replied, "The answerer has no better knowledge than the questioner. But I will inform you about its portents.

1. When a slave (lady) gives birth to her master.

2. When the shepherds of black camels start boasting and competing with others in the construction of higher buildings. And the Hour is one of five things which nobody knows except Allah.

The Prophet then recited: "Verily, with Allah (Alone) is the knowledge of the Hour--." (31. 34) Then that man (Gabriel) left and the Prophet asked his companions to call him back, but they could not see him. Then the Prophet said, "That was Gabriel who came to teach the people their religion." Abu 'Abdullah said: He (the Prophet) considered all that as a part of faith.


Bukhari :: Belief :: [1.2.48]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 48

Narrated 'Abdullah bin 'Abbas:

I was informed by Abu Sufyan that Heraclius said to him, "I asked you whether they (followers of Muhammad) were increasing or decreasing. You replied that they were increasing. And in fact, this is the way of true Faith till it is complete in all respects. I further asked you whether there was anybody, who, after embracing his (the Prophets) religion (Islam) became displeased and discarded it. You replied in the negative, and in fact, this is (a sign of) true faith. When its delight enters the heart and mixes with them completely, nobody can be displeased with it."


Bukhari :: Belief :: [1.2.49]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 49

Narrated An-Nu'man bin Bashir:

I heard Allah's Apostle saying, 'Both legal and illegal things are evident but in between them there are doubtful (suspicious) things and most of the people have no knowledge about them. So whoever saves himself from these suspicious things saves his religion and his honor. And whoever indulges in these suspicious things is like a shepherd who grazes (his animals) near the Hima (private pasture) of someone else and at any moment he is liable to get in it. (O people!) Beware! Every king has a Hima and the Hima of Allah on the earth is His illegal (forbidden) things. Beware! There is a piece of flesh in the body if it becomes good (reformed) the whole body becomes good but if it gets spoilt the whole body gets spoilt and that is the heart.


Bukhari :: Belief :: [1.2.50]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 50

Narrated Abu Jamra:

I used to sit with Ibn 'Abbas and he made me sit on his sitting place. He requested me to stay with him in order that he might give me a share from his property. So I stayed with him for two months. Once he told (me) that when the delegation of the tribe of 'Abdul Qais came to the Prophet, the Prophet asked them, "Who are the people (i.e. you)? (Or) who are the delegate?" They replied, "We are from the tribe of Rabi'a." Then the Prophet said to them, "Welcome! O people (or O delegation of 'Abdul Qais)! Neither will you have disgrace nor will you regret." They said, "O Allah's Apostle! We cannot come to you except in the sacred month and there is the infidel tribe of Mudar intervening between you and us. So please order us to do something good (religious deeds) so that we may inform our people whom we have left behind (at home), and that we may enter Paradise (by acting on them)." Then they asked about drinks (what is legal and what is illegal). The Prophet ordered them to do four things and forbade them from four things. He ordered them to believe in Allah Alone and asked them, "Do you know what is meant by believing in Allah Alone?" They replied, "Allah and His Apostle know better." Thereupon the Prophet said, "It means:

1. To testify that none has the right to be worshipped but Allah and Muhammad is Allah's Apostle.

2. To offer prayers perfectly

3. To pay the Zakat (obligatory charity)

4. To observe fast during the month of Ramadan.

5. And to pay Al-Khumus (one fifth of the booty to be given in Allah's Cause).

Then he forbade them four things, namely, Hantam, Dubba,' Naqir Ann Muzaffat or Muqaiyar; (These were the names of pots in which Alcoholic drinks were prepared) (The Prophet mentioned the container of wine and he meant the wine itself). The Prophet further said (to them): "Memorize them (these instructions) and convey them to the people whom you have left behind."


Bukhari :: Belief :: [1.2.51]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 51

Narrated 'Umar bin Al-Khattab:

Allah's Apostle said, "The reward of deeds depends upon the intention and every person will get the reward according to what he has intended. So whoever emigrated for Allah and His Apostle, then his emigration was for Allah and His Apostle. And whoever emigrated for worldly benefits or for a woman to marry, his emigration was for what he emigrated for."


Bukhari :: Belief :: [1.2.52]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 52

Narrated Abu Mas'ud:

The Prophet said, "If a man spends on his family (with the intention of having a reward from Allah) sincerely for Allah's sake then it is a (kind of) alms-giving in reward for him.


Bukhari :: Belief :: [1.2.53]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 53

Narrated Sa'd bin Abi Waqqas:

Allah's Apostle said, "You will be rewarded for whatever you spend for Allah's sake even if it were a morsel which you put in your wife's mouth."


Bukhari :: Belief :: [1.2.54]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 54

Narrated Jarir bin Abdullah:

I gave the pledge of allegiance to Allah's Apostle for the following:

1. offer prayers perfectly

2. pay the Zakat (obligatory charity)

3. and be sincere and true to every Muslim.


Bukhari :: Belief :: [1.2.55]

Belief

Bukhari :: Book 1 :: Volume 2 :: Hadith 55

Narrated Ziyad bin'Ilaqa:

I heard Jarir bin 'Abdullah (Praising Allah). On the day when Al-Mughira bin Shu'ba died, he (Jarir) got up (on the pulpit) and thanked and praised Allah and said, "Be afraid of Allah alone Who has none along with Him to be worshipped.(You should) be calm and quiet till the (new) chief comes to you and he will come to you soon. Ask Allah's forgiveness for your (late) chief because he himself loved to forgive others." Jarir added, "Amma badu (now then), I went to the Prophet and said, 'I give my pledge of allegiance to you for Islam." The Prophet conditioned (my pledge) for me to be sincere and true to every Muslim so I gave my pledge to him for this. By the Lord of this mosque! I am sincere and true to you (Muslims). Then Jarir asked for Allah's forgiveness and came down (from the pulpit).


Bukhari :: Knowledge :: [1.3.56]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 56

Narrated Abu Huraira:

While the Prophet was saying something in a gathering, a Bedouin came and asked him, "When would the Hour (Doomsday) take place?" Allah's Apostle continued his talk, so some people said that Allah's Apostle had heard the question, but did not like what that Bedouin had asked. Some of them said that Alllah's Apostle had not heard it. When the Prophet finished his speech, he said, "Where is the questioner, who enquired about the Hour (Doomsday)?" The Bedouin said, "I am here, O Allah's Apostle ." Then the Prophet said, "When honesty is lost, then wait for the Hour (Doomsday)." The Bedouin said, "How will that be lost?" The Prophet said, "When the power or authority comes in the hands of unfit persons, then wait for the Hour (Doomsday.)"


Bukhari :: Knowledge :: [1.3.57]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 57

Narrated 'Abdullah bin 'Amr:

Once the Prophet remained behind us in a journey. He joined us while we were performing ablution for the prayer which was over-due. We were just passing wet hands over our feet (and not washing them properly) so the Prophet addressed us in a loud voice and said twice or thrice: "Save your heels from the fire."


Bukhari :: Knowledge :: [1.3.58]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 58

Narrated Ibn 'Umar:

Allah's Apostle said, "Amongst the trees, there is a tree, the leaves of which do not fall and is like a Muslim. Tell me the name of that tree." Everybody started thinking about the trees of the desert areas. And I thought of the date-palm tree but felt shy to answer the others then asked, "What is that tree, O Allah's Apostle ?" He replied, "It is the date-palm tree."


Bukhari :: Knowledge :: [1.3.59]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 59

Narrated Ibn 'Umar:

The Prophet said, "Amongst the trees, there is a tree, the leaves of which do not fall and is like a Muslim. Tell me the name of that tree." Everybody started thinking about the trees of the desert areas. And I thought of the date-palm tree. The others then asked, "Please inform us what is that tree, O Allah's Apostle?" He replied, "It is the date-palm tree."


Bukhari :: Knowledge :: [1.3.60]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 60

Narrated Ibn Umar:

same as above Hadith 59.


Bukhari :: Knowledge :: [1.3.61]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 61

Narrated Ibn Umar:

same as above Hadith 59.


Bukhari :: Knowledge :: [1.3.62]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 62

Narrated Ibn Umar:

same as above Hadith 59.


Bukhari :: Knowledge :: [1.3.63]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 63

Narrated Anas bin Malik:

While we were sitting with the Prophet in the mosque, a man came riding on a camel. He made his camel kneel down in the mosque, tied its foreleg and then said: "Who amongst you is Muhammad?" At that time the Prophet was sitting amongst us (his companions) leaning on his arm. We replied, "This white man reclining on his arm." The an then addressed him, "O Son of 'Abdul Muttalib."

The Prophet said, "I am here to answer your questions." The man said to the Prophet, "I want to ask you something and will be hard in questioning. So do not get angry." The Prophet said, "Ask whatever you want." The man said, "I ask you by your Lord, and the Lord of those who were before you, has Allah sent you as an Apostle to all the mankind?" The Prophet replied, "By Allah, yes." The man further said, "I ask you by Allah. Has Allah ordered you to offer five prayers in a day and night (24 hours).? He replied, "By Allah, Yes." The man further said, "I ask you by Allah! Has Allah ordered you to observe fasts during this month of the year (i.e. Ramadan)?" He replied, "By Allah, Yes." The man further said, "I ask you by Allah. Has Allah ordered you to take Zakat (obligatory charity) from our rich people and distribute it amongst our poor people?" The Prophet replied, "By Allah, yes." Thereupon that man said, "I have believed in all that with which you have been sent, and I have been sent by my people as a messenger, and I am Dimam bin Tha'laba from the brothers of Bani Sa'd bin Bakr."


Bukhari :: Knowledge :: [1.3.64]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 64

Narrated 'Abdullah bin Abbas:

Once Allah's Apostle gave a letter to a person and ordered him to go and deliver it to the Governor of Bahrain. (He did so) and the Governor of Bahrain sent it to Chousroes, who read that letter and then tore it to pieces. (The sub-narrator (Ibn Shihab) thinks that Ibn Al-Musaiyab said that Allah's Apostle invoked Allah against them (saying), "May Allah tear them into pieces, and disperse them all totally.)"


Bukhari :: Knowledge :: [1.3.65]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 65

Narrated Anas bin Malik:

Once the Prophet wrote a letter or had an idea of writing a letter. The Prophet was told that they (rulers) would not read letters unless they were sealed. So the Prophet got a silver ring made with "Muhammad Allah's Apostle" engraved on it. As if I were just observing its white glitter in the hand of the Prophet


Bukhari :: Knowledge :: [1.3.66]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 66

Narrated Abu Waqid Al-Laithi:

While Allah's Apostle was sitting in the mosque with some people, three men came. Two of them came in front of Allah's Apostle and the third one went away. The two persons kept on standing before Allah's Apostle for a while and then one of them found a place in the circle and sat there while the other sat behind the gathering, and the third one went away. When Allah's Apostle finished his preaching, he said, "Shall I tell you about these three persons? One of them be-took himself to Allah, so Allah took him into His grace and mercy and accommodated him, the second felt shy from Allah, so Allah sheltered Him in His mercy (and did not punish him), while the third turned his face from Allah and went away, so Allah turned His face from him likewise. "


Bukhari :: Knowledge :: [1.3.67]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 67

Narrated 'Abdur Rahman bin Abi Bakra's father:

Once the Prophet was riding his camel and a man was holding its rein. The Prophet asked, "What is the day today?" We kept quiet, thinking that he might give that day another name. He said, "Isn't it the day of Nahr (slaughtering of the animals of sacrifice)" We replied, "Yes." He further asked, "Which month is this?" We again kept quiet, thinking that he might give it another name. Then he said, "Isn't it the month of Dhul-Hijja?" We replied, "Yes." He said, "Verily! Your blood, property and honor are sacred to one another (i.e. Muslims) like the sanctity of this day of yours, in this month of yours and in this city of yours. It is incumbent upon those who are present to inform those who are absent because those who are absent might comprehend (what I have said) better than the present audience."


Bukhari :: Knowledge :: [1.3.68]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 68

Narrated Ibn Mas'ud:

The Prophet used to take care of us in preaching by selecting a suitable time, so that we might not get bored. (He abstained from pestering us with sermons and knowledge all the time).


Bukhari :: Knowledge :: [1.3.69]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 69

Narrated Anas bin Malik:

The Prophet said, "Facilitate things to people (concerning religious matters), and do not make it hard for them and give them good tidings and do not make them run away (from Islam)."


Bukhari :: Knowledge :: [1.3.70]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 70

Narrated Abu Wail:

'Abdullah used to give a religious talk to the people on every Thursday. Once a man said, "O Aba 'Abdur-Rahman! (By Allah) I wish if you could preach us daily." He replied, "The only thing which prevents me from doing so, is that I hate to bore you, and no doubt I take care of you in preaching by selecting a suitable time just as the Prophet used to do with us, for fear of making us bored."


Bukhari :: Knowledge :: [1.3.71]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 71

Narrated Muawiya:

I heard Allah's Apostle saying, "If Allah wants to do good to a person, He makes him comprehend the religion. I am just a distributor, but the grant is from Allah. (And remember) that this nation (true Muslims) will keep on following Allah's teachings strictly and they will not be harmed by any one going on a different path till Allah's order (Day of Judgment) is established."


Bukhari :: Knowledge :: [1.3.72]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 72

Narrated Ibn 'Umar:

We were with the Prophet and a spadix of date-palm tree was brought to him. On that he said, "Amongst the trees, there is a tree which resembles a Muslim." I wanted to say that it was the date-palm tree but as I was the youngest of all (of them) I kept quiet. And then the Prophet said, "It is the date-palm tree."


Bukhari :: Knowledge :: [1.3.73]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 73

Narrated 'Abdullah bin Mas'ud:

The Prophet said, "Do not wish to be like anyone except in two cases. (The first is) A person, whom Allah has given wealth and he spends it righteously; (the second is) the one whom Allah has given wisdom (the Holy Qur'an) and he acts according to it and teaches it to others." (Fateh-al-Bari page 177 Vol. 1)


Bukhari :: Knowledge :: [1.3.74]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 74

Narrated Ibn 'Abbas:

That he differed with Hur bin Qais bin Hisn Al-Fazari regarding the companion of (the Prophet) Moses. Ibn 'Abbas said that he was Khadir. Meanwhile, Ubai bin Ka'b passed by them and Ibn 'Abbas called him, saying "My friend (Hur) and I have differed regarding Moses' companion whom Moses, asked the way to meet. Have you heard the Prophet mentioning something about him? He said, "Yes. I heard Allah's Apostle saying, "While Moses was sitting in the company of some Israelites, a man came and asked him. "Do you know anyone who is more learned than you? Moses replied: "No." So Allah sent the Divine Inspiration to Moses: 'Yes, Our slave Khadir (is more learned than you.)' Moses asked (Allah) how to meet him (Khadir). So Allah made the fish as a sign for him and he was told that when the fish was lost, he should return (to the place where he had lost it) and there he would meet him (Al-Khadir). So Moses went on looking for the sign of the fish in the sea. The servant-boy of Moses said to him: Do you remember when we betook ourselves to the rock, I indeed forgot the fish, none but Satan made me forget to remember it. On that Moses said: 'That is what we have been seeking? (18.64) So they went back retracing their foot-steps, and found Khadir. (And) what happened further to them is narrated in the Holy Qur'an by Allah. (18.54 up to 18.82)


Bukhari :: Knowledge :: [1.3.75]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 75

Narrated Ibn 'Abbas:

Once the Prophet embraced me and said, "O Allah! Bestow on him the knowledge of the Book (Qur'an)."


Bukhari :: Knowledge :: [1.3.76]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 76

Narrated Ibn 'Abbas:

Once I came riding a she-ass and had (just) attained the age of puberty. Allah's Apostle was offering the prayer at Mina. There was no wall in front of him and I passed in front of some of the row while they were offering their prayers. There I let the she-ass loose to graze and entered the row, and nobody objected to it.


Bukhari :: Knowledge :: [1.3.77]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 77

Narrated Mahmud bin Rabi'a:

When I was a boy of five, I remember, the Prophet took water from a bucket (used far getting water out of a well) with his mouth and threw it on my face.


Bukhari :: Knowledge :: [1.3.78]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 78

Narrated Ibn 'Abbas:

that he differed with Hur bin Qais bin Hisn Al-Fazari regarding the companion of the Prophet Moses. Meanwhile, Ubai bin Ka'b passed by them and Ibn 'Abbas called him saying, "My friend (Hur) and I have differed regarding Moses' companion whom Moses asked the way to meet. Have you heard Allah's Apostle mentioning something about him? Ubai bin Ka'b said: "Yes, I heard the Prophet mentioning something about him (saying) while Moses was sitting in the company of some Israelites, a man came and asked him: "Do you know anyone who is more learned than you? Moses replied: "No." So Allah sent the Divine Inspiration to Moses: '--Yes, Our slave Khadir is more learned than you. Moses asked Allah how to meet him (Al-Khadir). So Allah made the fish a sign for him and he was told when the fish was lost, he should return (to the place where he had lost it) and there he would meet him (Al-Khadir). So Moses went on looking for the sign of the fish in the sea. The servant-boy of Moses said: 'Do you remember when we betook ourselves to the rock, I indeed forgot the fish, none but Satan made me forget to remember it. On that Moses said, 'That is what we have been seeking.' So they went back retracing their footsteps, and found Kha,dir. (and) what happened further about them is narrated in the Holy Qur'an by Allah." (18.54 up to 18.82)


Bukhari :: Knowledge :: [1.3.79]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 79

Narrated Abu Musa:

The Prophet said, "The example of guidance and knowledge with which Allah has sent me is like abundant rain falling on the earth, some of which was fertile soil that absorbed rain water and brought forth vegetation and grass in abundance. (And) another portion of it was hard and held the rain water and Allah benefited the people with it and they utilized it for drinking, making their animals drink from it and for irrigation of the land for cultivation. (And) a portion of it was barren which could neither hold the water nor bring forth vegetation (then that land gave no benefits). The first is the example of the person who comprehends Allah's religion and gets benefit (from the knowledge) which Allah has revealed through me (the Prophets and learns and then teaches others. The last example is that of a person who does not care for it and does not take Allah's guidance revealed through me (He is like that barren land.)"


Bukhari :: Knowledge :: [1.3.80]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 80

Narrated Anas:

Allah's Apostle said, "From among the portents of the Hour are (the following):

1. Religious knowledge will be taken away (by the death of Religious learned men).

2. (Religious) ignorance will prevail.

3. Drinking of Alcoholic drinks (will be very common).

4. There will be prevalence of open illegal sexual intercourse.


Bukhari :: Knowledge :: [1.3.81]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 81

Narrated Anas:

I will narrate to you a Hadith and none other than I will tell you about after it. I heard Allah's Apostle saying: From among the portents of the Hour are (the following):

1. Religious knowledge will decrease (by the death of religious learned men).

2. Religious ignorance will prevail.

3. There will be prevalence of open illegal sexual intercourse.

4. Women will increase in number and men will decrease in number so much so that fifty women will be looked after by one man.


Bukhari :: Knowledge :: [1.3.82]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 82

Narrated Ibn 'Umar:

Allah's Apostle said, "While I was sleeping, I saw that a cup full of milk was brought to me and I drank my fill till I noticed (the milk) its wetness coming out of my nails. Then I gave the remaining milk to 'Umar Ibn Al-Khattab" The companions of the Prophet asked, "What have you interpreted (about this dream)? "O Allah's Apostle ,!" he replied, "(It is religious) knowledge."


Bukhari :: Knowledge :: [1.3.83]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 83

Narrated 'Abdullah bin Amr bin Al 'Aas:

Allah's Apostle stopped (for a while near the Jimar) at Mina during his last Hajj for the people and they were asking him questions. A man came and said, "I forgot and got my head shaved before slaughtering the Hadi (sacrificing animal)." The Prophet said, "There is no harm, go and do the slaughtering now." Then another person came and said, "I forgot and slaughtered (the camel) before Rami (throwing of the pebbles) at the Jamra." The Prophet said, "Do the Rami now and there is no harm."

The narrator added: So on that day, when the Prophet was asked about anything (as regards the ceremonies of Hajj) performed before or after its due time, his reply was: "Do it (now) and there is no harm."


Bukhari :: Knowledge :: [1.3.84]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 84

Narrated Ibn 'Abbas:

Somebody said to the Prophet (during his last Hajj), "I did the slaughtering before doing the Rami.' The Prophet beckoned with his hand and said, "There is no harm in that." Then another person said. "I got my head shaved before offering the sacrifice." The Prophet beckoned with his hand saying, "There is no harm in that."


Bukhari :: Knowledge :: [1.3.85]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 85

Narrated Abu Huraira:

The Prophet said, "(Religious) knowledge will be taken away (by the death of religious scholars) ignorance (in religion) and afflictions will appear; and Harj will increase." It was asked, "What is Harj, O Allah's Apostle?" He replied by beckoning with his hand indicating "killing." (Fateh-al-Bari Page 192, Vol. 1)


Bukhari :: Knowledge :: [1.3.86]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 86

Narrated Asma:

I came to 'Aisha while she was praying, and said to her, "What has happened to the people?" She pointed out towards the sky. (I looked towards the mosque), and saw the people offering the prayer. Aisha said, "Subhan Allah." I said to her, "Is there a sign?" She nodded with her head meaning, "Yes." I, too, then stood (for the prayer of eclipse) till I became (nearly) unconscious and later on I poured water on my head. After the prayer, the Prophet praised and glorified Allah and then said,

"Just now at this place I have seen what I have never seen before, including Paradise and Hell. No doubt it has been inspired to me that you will be put to trials in your graves and these trials will be like the trials of Masiah-ad-Dajjal or nearly like it (the sub narrator is not sure which expression Asma' used). You will be asked, 'What do you know about this man (the Prophet Muhammad)?' Then the faithful believer (or Asma' said a similar word) will reply, 'He is Muhammad Allah's Apostle who had come to us with clear evidences and guidance and so we accepted his teachings and followed him. And he is Muhammad.' And he will repeat it thrice. Then the angels will say to him, 'Sleep in peace as we have come to know that you were a faithful believer.' On the other hand, a hypocrite or a doubtful person will reply, 'I do not know, but I heard the people saying something and so I said it.' (the same). "


Bukhari :: Knowledge :: [1.3.87]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 87

Narrated Abu Jamra:

I was an interpreter between the people and Ibn 'Abbas. Once Ibn 'Abbas said that a delegation of the tribe of'Abdul Qais came to the Prophet who asked them, "Who are the people (i.e. you)? (Or) who are the delegates?" They replied, "We are from the tribe of Rabi'a." Then the Prophet said to them, "Welcome, O people (or said, "O delegation (of 'Abdul Qais).") Neither will you have disgrace nor will you regret." They said, "We have come to you from a distant place and there is the tribe of the infidels of Mudar intervening between you and us and we cannot come to you except in the sacred month. So please order us to do something good (religious deeds) and that we may also inform our people whom we have left behind (at home) and that we may enter Paradise (by acting on them.)" The Prophet ordered them to do four things, and forbade them from four things. He ordered them to believe in Allah Alone, the Honorable the Majestic and said to them, "Do you know what is meant by believing in Allah Alone?" They replied, "Allah and His Apostle know better." Thereupon the Prophet said, "(That means to testify that none has the right to be worshipped but Allah and that Muhammad is His Apostle, to offer prayers perfectly, to pay Zakat, to observe fasts during the month of Ramadan, (and) to pay Al-Khumus (one fifth of the booty to be given in Allah's cause)." Then he forbade them four things, namely Ad-Dubba.' Hantam, Muzaffat (and) An-Naqir or Muqaiyar(These were the names of pots in which alcoholic drinks used to be prepared). The Prophet further said, "Memorize them (these instructions) and tell them to the people whom you have left behind."


Bukhari :: Knowledge :: [1.3.88]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 88

Narrated 'Abdullah bin Abi Mulaika:

'Uqba bin Al-Harith said that he had married the daughter of Abi Ihab bin 'Aziz. Later on a woman came to him and said, "I have suckled (nursed) Uqba and the woman whom he married (his wife) at my breast." 'Uqba said to her, "Neither I knew that you have suckled (nursed) me nor did you tell me." Then he rode over to see Allah's Apostle at Medina, and asked him about it. Allah's Apostle said, "How can you keep her as a wife when it has been said (that she is your foster-sister)?" Then Uqba divorced her, and she married another man.


Bukhari :: Knowledge :: [1.3.89]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 89

Narrated 'Umar:

My Ansari neighbor from Bani Umaiya bin Zaid who used to live at 'Awali Al-Medina and used to visit the Prophet by turns. He used to go one day and I another day. When I went I used to bring the news of that day regarding the Divine Inspiration and other things, and when he went, he used to do the same for me. Once my Ansari friend, in his turn (on returning from the Prophet), knocked violently at my door and asked if I was there." I became horrified and came out to him. He said, "Today a great thing has happened." I then went to Hafsa and saw her weeping. I asked her, "Did Allah's Apostle divorce you all?" She replied, "I do not know." Then, I entered upon the Prophet and said while standing, "Have you divorced your wives?" The Prophet replied in the negative. On what I said, "Allahu-Akbar (Allah is Greater)." (See Hadith No. 119, Vol. 3 for details)


Bukhari :: Knowledge :: [1.3.90]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 90

Narrated Abu Mas'ud Al-Ansari:

Once a man said to Allah's Apostle "O Allah's Apostle! I may not attend the (compulsory congregational) prayer because so and so (the Imam) prolongs the prayer when he leads us for it. The narrator added: "I never saw the Prophet more furious in giving advice than he was on that day. The Prophet said, "O people! Some of you make others dislike good deeds (the prayers). So whoever leads the people in prayer should shorten it because among them there are the sick the weak and the needy (having some jobs to do)."


Bukhari :: Knowledge :: [1.3.91]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 91

Narrated Zaid bin Khalid Al-Juhani:

A man asked the Prophet about the picking up of a "Luqata" (fallen lost thing). The Prophet replied, "Recognize and remember its tying material and its container, and make public announcement (about it) for one year, then utilize it but give it to its owner if he comes." Then the person asked about the lost camel. On that, the Prophet got angry and his cheeks or his Face became red and he said, "You have no concern with it as it has its water container, and its feet and it will reach water, and eat (the leaves) of trees till its owner finds it." The man then asked about the lost sheep. The Prophet replied, "It is either for you, for your brother (another person) or for the wolf."


Bukhari :: Knowledge :: [1.3.92]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 92

Narrated Abu Musa:

The Prophet was asked about things which he did not like, but when the questioners insisted, the Prophet got angry. He then said to the people, "Ask me anything you like." A man asked, "Who is my father?" The Prophet replied, "Your father is Hudhafa." Then another man got up and said, "Who is my father, O Allah's Apostle ?" He replied, "Your father is Salim, Maula (the freed slave) of Shaiba." So when 'Umar saw that (the anger) on the face of the Prophet he said, "O Allah's Apostle! We repent to Allah (Our offending you)."


Bukhari :: Knowledge :: [1.3.93]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 93

Narrated Anas bin Malik:

One day Allah's Apostle came out (before the people) and 'Abdullah bin Hudhafa stood up and asked (him) "Who is my father?" The Prophet replied, "Your father is Hudhafa." The Prophet told them repeatedly (in anger) to ask him anything they liked. 'Umar knelt down before the Prophet and said thrice, "We accept Allah as (our) Lord and Islam as (our) religion and Muhammad as (our) Prophet." After that the Prophet became silent.


Bukhari :: Knowledge :: [1.3.94]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 94

Narrated Anas:

Whenever the Prophet asked permission to enter, he knocked the door thrice with greeting and whenever he spoke a sentence (said a thing) he used to repeat it thrice. (See Hadith No. 261, Vol. 8).


Bukhari :: Knowledge :: [1.3.95]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 95

Narrated Anas:

Whenever the Prophet spoke a sentence (said a thing), he used to repeat it thrice so that the people could understand it properly from him and whenever he asked permission to enter, (he knocked the door) thrice with greeting.


Bukhari :: Knowledge :: [1.3.96]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 96

Narrated 'Abdullah bin 'Amr:

Once Allah's Apostle remained behind us in a journey. He joined us while we were performing ablution for the 'Asr prayer which was over-due. We were just passing wet hands over our feet (not washing them properly) so the Prophet addressed us in a loud voice and said twice or thrice, "Save your heels from the fire."


Bukhari :: Knowledge :: [1.3.97]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 97

Narrated Ibn 'Abbas:

Once Allah's Apostle came out while Bilal was accompanying him. He went towards the women thinking that they had not heard him (i.e. his sermon). So he preached them and ordered them to pay alms. (Hearing that) the women started giving alms; some donated their ear-rings, some gave their rings and Bilal was collecting them in the corner of his garment.


Bukhari :: Knowledge :: [1.3.98]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 98

Narrated Abu Huraira:

I said: "O Allah's Apostle! Who will be the luckiest person, who will gain your intercession on the Day of Resurrection?" Allah's Apostle said: O Abu Huraira! "I have thought that none will ask me about it before you as I know your longing for the (learning of) Hadiths. The luckiest person who will have my intercession on the Day of Resurrection will be the one who said sincerely from the bottom of his heart "None has the right to be worshipped but Allah."

And 'Umar bin 'Abdul 'Aziz wrote to Abu Bakr bin Hazm, "Look for the knowledge of Hadith and get it written, as I am afraid that religious knowledge will vanish and the religious learned men will pass away (die). Do not accept anything save the Hadiths of the Prophet. Circulate knowledge and teach the ignorant, for knowledge does not vanish except when it is kept secretly (to oneself)."


Bukhari :: Knowledge :: [1.3.99]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 99

Narrated Abdullah Ibn Dinar:

also narrates the same (above-mentioned statement) as has been narrated by 'Umar bin 'Abdul 'Aziz up to "The religious scholar (learned men) will pass away (die)."


Bukhari :: Knowledge :: [1.3.100]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 100

Narrated 'Abdullah bin 'Amr bin Al' As:

I heard Allah's Apostle saying, "Allah does not take away the knowledge, by taking it away from (the hearts of) the people, but takes it away by the death of the religious learned men till when none of the (religious learned men) remains, people will take as their leaders ignorant persons who when consulted will give their verdict without knowledge. So they will go astray and will lead the people astray."


Bukhari :: Knowledge :: [1.3.101]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 101

Narrated Abu Said Al-Khudri:

Some women requested the Prophet to fix a day for them as the men were taking all his time. On that he promised them one day for religious lessons and commandments. Once during such a lesson the Prophet said, "A woman whose three children die will be shielded by them from the Hell fire." On that a woman asked, "If only two die?" He replied, "Even two (will shield her from the Hell-fire)."


Bukhari :: Knowledge :: [1.3.102]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 102

Narrated Abu Said Al-Khudri:

as above (the sub narrators are different). Abu Huraira qualified the three children referred to in the above mentioned Hadith as not having reached the age of committing sins (i.e. age of puberty) .


Bukhari :: Knowledge :: [1.3.103]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 103

Narrated Ibn Abu Mulaika:

Whenever 'Aisha (the wife of the Prophet) heard anything which she did not understand, she used to ask again till she understood it completely. Aisha said: "Once the Prophet said, "Whoever will be called to account (about his deeds on the Day of Resurrection) will surely be punished." I said, "Doesn't Allah say: "He surely will receive an easy reckoning." (84.8) The Prophet replied, "This means only the presentation of the accounts but whoever will be argued about his account, will certainly be ruined."


Bukhari :: Knowledge :: [1.3.104]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 104

Narrated Said:

Abu Shuraih said, "When 'Amr bin Said was sending the troops to Mecca (to fight 'Abdullah bin Az-Zubair) I said to him, 'O chief! Allow me to tell you what the Prophet said on the day following the conquests of Mecca. My ears heard and my heart comprehended, and I saw him with my own eyes, when he said it. He glorified and praised Allah and then said, "Allah and not the people has made Mecca a sanctuary. So anybody who has belief in Allah and the Last Day (i.e. a Muslim) should neither shed blood in it nor cut down its trees. If anybody argues that fighting is allowed in Mecca as Allah's Apostle did fight (in Mecca), tell him that Allah gave permission to His Apostle, but He did not give it to you. The Prophet added: Allah allowed me only for a few hours on that day (of the conquest) and today (now) its sanctity is the same (valid) as it was before. So it is incumbent upon those who are present to convey it (this information) to those who are absent." Abu- Shuraih was asked, "What did 'Amr reply?" He said 'Amr said, "O Abu Shuraih! I know better than you (in this respect). Mecca does not give protection to one who disobeys (Allah) or runs after committing murder, or theft (and takes refuge in Mecca).


Bukhari :: Knowledge :: [1.3.105]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 105

Narrated Abu Bakra:

The Prophet said. No doubt your blood, property, the sub-narrator Muhammad thought that Abu Bakra had also mentioned and your honor (chastity), are sacred to one another as is the sanctity of this day of yours in this month of yours. It is incumbent on those who are present to inform those who are absent." (Muhammad the Subnarrator used to say, "Allah's Apostle told the truth.") The Prophet repeated twice: "No doubt! Haven't I conveyed Allah's message to you.


Bukhari :: Knowledge :: [1.3.106]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 106

Narrated 'Ali:

The Prophet said, "Do not tell a lie against me for whoever tells a lie against me (intentionally) then he will surely enter the Hell-fire."


Bukhari :: Knowledge :: [1.3.107]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 107

Narrated 'Abdullah bin Az-Zubair:

I said to my father, 'I do not hear from you any narration (Hadith) of Allah s Apostle as I hear (his narrations) from so and so?" Az-Zubair replied. l was always with him (the Prophet) and I heard him saying "Whoever tells a lie against me (intentionally) then (surely) let him occupy, his seat in Hell-fire.


Bukhari :: Knowledge :: [1.3.108]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 108

Narrated Anas:

The fact which stops me from narrating a great number of Hadiths to you is that the Prophet said: "Whoever tells a lie against me intentionally, then (surely) let him occupy his seat in Hell-fire."


Bukhari :: Knowledge :: [1.3.109]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 109

Narrated Salama:

I heard the Prophet saying, "Whoever (intentionally) ascribes to me what I have not said then (surely) let him occupy his seat in Hell-fire."


Bukhari :: Knowledge :: [1.3.110]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 110

Narrated Abu Huraira:

The Prophet said, "Name yourselves with my name (use my name) but do not name yourselves with my Kunya name (i.e. Abu-l Qasim). And whoever sees me in a dream then surely he has seen me for Satan cannot impersonate me. And whoever tells a lie against me (intentionally), then (surely) let him occupy his seat in Hell-fire."


Bukhari :: Knowledge :: [1.3.111]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 111

Narrated Ash-Sha'bi:

Abu Juhaifa said, "I asked Ali, 'Have you got any book (which has been revealed to the Prophet apart from the Qur'an)?' 'Ali replied, 'No, except Allah's Book or the power of understanding which has been bestowed (by Allah) upon a Muslim or what is (written) in this sheet of paper (with me).' Abu Juhaifa said, "I asked, 'What is (written) in this sheet of paper?' Ali replied, it deals with The Diyya (compensation (blood money) paid by the killer to the relatives of the victim), the ransom for the releasing of the captives from the hands of the enemies, and the law that no Muslim should be killed in Qisas (equality in punishment) for the killing of (a disbeliever).


Bukhari :: Knowledge :: [1.3.112]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 112

Narrated Abu Huraira:

In the year of the Conquest of Mecca, the tribe of Khuza'a killed a man from the tribe of Bani Laith in revenge for a killed person, belonging to them. They informed the Prophet about it. So he rode his Rahila (she-camel for riding) and addressed the people saying, "Allah held back the killing from Mecca. (The sub-narrator is in doubt whether the Prophet said "elephant or killing," as the Arabic words standing for these words have great similarity in shape), but He (Allah) let His Apostle and the believers over power the infidels of Mecca. Beware! (Mecca is a sanctuary) Verily! Fighting in Mecca was not permitted for anyone before me nor will it be permitted for anyone after me. It (war) in it was made legal for me for few hours or so on that day. No doubt it is at this moment a sanctuary, it is not allowed to uproot its thorny shrubs or to uproot its trees or to pick up its Luqatt (fallen things) except by a person who will look for its owner (announce it publicly). And if somebody is killed, then his closest relative has the right to choose one of the two-- the blood money (Diyya) or retaliation having the killer killed. In the meantime a man from Yemen came and said, "O Allah's Apostle! Get that written for me." The Prophet ordered his companions to write that for him. Then a man from Quraish said, "Except Al-Iqhkhir (a type of grass that has good smell) O Allah's Apostle, as we use it in our houses and graves." The Prophet said, "Except Al-Idhkhiri.e. Al-Idhkhir is allowed to be plucked."


Bukhari :: Knowledge :: [1.3.113]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 113

Narrated Abu Huraira:

There is none among the companions of the Prophet who has narrated more Hadiths than I except 'Abdallah bin Amr (bin Al-'As) who used to write them and I never did the same.


Bukhari :: Knowledge :: [1.3.114]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 114

Narrated 'Ubaidullah bin 'Abdullah:

Ibn 'Abbas said, "When the ailment of the Prophet became worse, he said, 'Bring for me (writing) paper and I will write for you a statement after which you will not go astray.' But 'Umar said, 'The Prophet is seriously ill, and we have got Allah's Book with us and that is sufficient for us.' But the companions of the Prophet differed about this and there was a hue and cry. On that the Prophet said to them, 'Go away (and leave me alone). It is not right that you should quarrel in front of me." Ibn 'Abbas came out saying, "It was most unfortunate (a great disaster) that Allah's Apostle was prevented from writing that statement for them because of their disagreement and noise. (Note: It is apparent from this Hadith that Ibn 'Abbes had witnessed the event and came out saying this statement. The truth is not so, for Ibn 'Abbas used to say this statement on narrating the Hadith and he had not witnessed the event personally. See Fath Al-Bari Vol. 1, p.220 footnote.) (See Hadith No. 228, Vol. 4).


Bukhari :: Knowledge :: [1.3.115]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 115

Narrated Um Salama:

One night Allah's Apostle got up and said, "Subhan Allah! How many afflictions have been descended tonight and how many treasures have been disclosed! Go and wake the sleeping lady occupants of these dwellings (his wives) up (for prayers). A well-dressed (soul) in this world may be naked in the Hereafter. "


Bukhari :: Knowledge :: [1.3.116]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 116

Narrated 'Abdullah bin 'Umar:

Once the Prophet led us in the 'Isha' prayer during the last days of his life and after finishing it (the prayer) (with Taslim) he said: "Do you realize (the importance of) this night?" Nobody present on the surface of the earth tonight will be living after the completion of one hundred years from this night."


Bukhari :: Knowledge :: [1.3.117]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 117

Narrated Ibn 'Abbas:

I stayed overnight in the house of my aunt Maimuna bint Al-Harith (the wife of the Prophet ) while the Prophet was there with her during her night turn. The Prophet offered the 'Isha' prayer (in the mosque), returned home and after having prayed four Rakat, he slept. Later on he got up at night and then asked whether the boy (or he used a similar word) had slept? Then he got up for the prayer and I stood up by his left side but he made me stand to his right and offered five Rakat followed by two more Rakat. Then he slept and I heard him snoring and then (after a while) he left for the (Fajr) prayer.


Bukhari :: Knowledge :: [1.3.118]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 118

Narrated Abu Huraira:

People say that I have narrated many Hadiths (The Prophet's narrations). Had it not been for two verses in the Qur'an, I would not have narrated a single Hadith, and the verses are:

"Verily those who conceal the clear sign and the guidance which We have sent down . . . (up to) Most Merciful." (2:159-160). And no doubt our Muhajir (emigrant) brothers used to be busy in the market with their business (bargains) and our Ansari brothers used to be busy with their property (agriculture). But I (Abu Huraira) used to stick to Allah's Apostle contented with what will fill my stomach and I used to attend that which they used not to attend and I used to memorize that which they used not to memorize.


Bukhari :: Knowledge :: [1.3.119]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 119

Narrated Abu Huraira:

I said to Allah's Apostle "I hear many narrations (Hadiths) from you but I forget them." Allah's Apostle said, "Spread your Rida' (garment)." I did accordingly and then he moved his hands as if filling them with something (and emptied them in my Rida') and then said, "Take and wrap this sheet over your body." I did it and after that I never forgot any thing.


Bukhari :: Knowledge :: [1.3.120]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 120

Narrated Ibrahim bin Al-Mundhir:

Ibn Abi Fudaik narrated the same as above (Hadith...119) but added that the Prophet had moved his hands as if filling them with something and then he emptied them in the Rida' of Abu Huraira.


Bukhari :: Knowledge :: [1.3.121]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 121

Narrated Abu Huraira:

I have memorized two kinds of knowledge from Allah's Apostle . I have propagated one of them to you and if I propagated the second, then my pharynx (throat) would be cut (i.e. killed).


Bukhari :: Knowledge :: [1.3.122]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 122

Narrated Jarir:

The Prophet said to me during Hajjat-al-Wida': Let the people keep quiet and listen. Then he said (addressing the people), "Do not (become infidels) revert to disbelief after me by striking the necks (cutting the throats) of one another (killing each other)."


Bukhari :: Knowledge :: [1.3.123]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 123

Narrated Said bin Jubair:

I said to Ibn 'Abbas, "Nauf-Al-Bakali claims that Moses (the companion of Khadir) was not the Moses of Bani Israel but he was another Moses." Ibn 'Abbas remarked that the enemy of Allah (Nauf) was a liar.


Bukhari :: Knowledge :: [1.3.124]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 124

Narrated Ubai bin Ka'b:

The Prophet said, "Once the Prophet Moses stood up and addressed Bani Israel. He was asked, "Who is the most learned man amongst the people. He said, "I am the most learned." Allah admonished Moses as he did not attribute absolute knowledge to Him (Allah). So Allah inspired to him "At the junction of the two seas there is a slave amongst my slaves who is more learned than you." Moses said, "O my Lord! How can I meet him?" Allah said: Take a fish in a large basket (and proceed) and you will find him at the place where you will lose the fish. So Moses set out along with his (servant) boy, Yusha' bin Nuin and carried a fish in a large basket till they reached a rock, where they laid their heads (i.e. lay down) and slept. The fish came out of the basket and it took its way into the sea as in a tunnel. So it was an amazing thing for both Moses and his (servant) boy. They proceeded for the rest of that night and the following day. When the day broke, Moses said to his (servant) boy: "Bring us our early meal. No doubt, we have suffered much fatigue in this journey." Moses did not get tired till he passed the place about which he was told. There the (servant) boy told Moses, "Do you remember when we betook ourselves to the rock, I indeed forgot the fish." Moses remarked, "That is what we have been seeking. So they went back retracing their foot-steps, till they reached the rock. There they saw a man covered with a garment (or covering himself with his own garment). Moses greeted him. Al-Khadir replied saying, "How do people greet each other in your land?" Moses said, "I am Moses." He asked, "The Moses of Bani Israel?" Moses replied in the affirmative and added, "May I follow you so that you teach me of that knowledge which you have been taught." Al-Khadir replied, "Verily! You will not be able to remain patient with me, O Moses! I have some of the knowledge of Allah which He has taught me and which you do not know, while you have some knowledge which Allah has taught you which I do not know." Moses said, "Allah willing, you will find me patient and I will not disobey you in aught. So both of them set out walking along the sea-shore, as they did not have a boat. In the meantime a boat passed by them and they requested the crew of the boat to take them on board. The crew recognized Al-Khadir and took them on board without fare. Then a sparrow came and stood on the edge of the boat and dipped its beak once or twice in the sea. Al-Khadir said: "O Moses! My knowledge and your knowledge have not decreased Allah's knowledge except as much as this sparrow has decreased the water of the sea with its beak." Al-Khadir went to one of the planks of the boat and plucked it out. Moses said, "These people gave us a free lift but you have broken their boat and scuttled it so as to drown its people." Al-Khadir replied, "Didn't I tell you that you will not be able to remain patient with me." Moses said, "Call me not to account for what I forgot." The first (excuse) of Moses was that he had forgotten. Then they proceeded further and found a boy playing with other boys. Al-Khadir took hold of the boy's head from the top and plucked it out with his hands (i.e. killed him). Moses said, "Have you killed an innocent soul who has killed none." Al-Kha,dir replied, "Did I not tell you that you cannot remain patient with me?" Then they both proceeded till when they came to the people of a town, they asked them for food, but they refused to entertain them. Then they found there a wall on the point of collapsing. Al-Khadir repaired it with his own hands. Moses said, "If you had wished, surely you could have taken wages for it." Al-Khadir replied, "This is the parting between you and me." The Prophet added, "May Allah be Merciful to Moses! Would that he could have been more patient to learn more about his story with Al-Khadir. "


Bukhari :: Knowledge :: [1.3.125]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 125

Narrated Abu Musa:

A man came to the Prophet and asked, "O Allah's Apostle! What kind of fighting is in Allah's cause? (I ask this), for some of us fight because of being enraged and angry and some for the sake of his pride and haughtiness." The Prophet raised his head (as the questioner was standing) and said, "He who fights so that Allah's Word (Islam) should be superior, then he fights in Allah's cause."


Bukhari :: Knowledge :: [1.3.126]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 126

Narrated 'Abdullah bin 'Amar:

I saw the Prophet near the Jamra and the people were asking him questions (about religious problems). A man asked, "O Allah's Apostle! I have slaughtered the Hadi (animal) before doing the Rami." The Prophet replied, "Do the Rami (now) and there is no harm." Another person asked, "O Allah's Apostle! I got my head shaved before slaughtering the animal." The Prophet replied, "Do the slaughtering (now) and there is no harm." So on that day, when the Prophet was asked about anything as regards the ceremonies of Hajj performed before or after its due time his reply was, "Do it (now) and there is no harm."


Bukhari :: Knowledge :: [1.3.127]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 127

Narrated 'Abdullah:

While I was going with the Prophet through the ruins of Medina and he was reclining on a date-palm leaf stalk, some Jews passed by. Some of them said to the others: Ask him (the Prophet) about the spirit. Some of them said that they should not ask him that question as he might give a reply which would displease them. But some of them insisted on asking, and so one of them stood up and asked, "O Aba-l-Qasim ! What is the spirit?" The Prophet remained quiet. I thought he was being inspired Divinely. So I stayed till that state of the Prophet (while being inspired) was over. The Prophet then said, "And they ask you (O Muhammad) concerning the spirit --Say: The spirit -- its knowledge is with my Lord. And of knowledge you (mankind) have been given only a little)." (17.85)


Bukhari :: Knowledge :: [1.3.128]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 128

Narrated Aswad:

Ibn Az-Zubair said to me, "Aisha used to tell you secretly a number of things. What did she tell you about the Ka'ba?" I replied, "She told me that once the Prophet said, 'O 'Aisha! Had not your people been still close to the pre-Islamic period of ignorance (infidelity)! I would have dismantled the Ka'ba and would have made two doors in it; one for entrance and the other for exit." Later on Ibn Az-Zubair did the same.


Bukhari :: Knowledge :: [1.3.129]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 129

Narrated Abu At-Tufail:

the above mentioned Statement of 'Ali.


Bukhari :: Knowledge :: [1.3.130]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 130

Narrated Anas bin Malik:

"Once Mu'adh was along with Allah's Apostle as a companion rider. Allah's Apostle said, "O Mu'adh bin Jabal." Mu'adh replied, "Labbaik and Sa'daik. O Allah's Apostle!" Again the Prophet said, "O Mu'adh!" Mu'adh said thrice, "Labbaik and Sa'daik, O Allah's Apostle!" Allah's Apostle said, "There is none who testifies sincerely that none has the right to be worshipped but Allah and Muhammad is his Apostle, except that Allah, will save him from the Hell-fire." Mu'adh said, "O Allah's Apostle ! Should I not inform the people about it so that they may have glad tidings?" He replied, "When the people hear about it, they will solely depend on it." Then Mu'adh narrated the above-mentioned Hadith just before his death, being afraid of committing sin (by not telling the knowledge).


Bukhari :: Knowledge :: [1.3.131]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 131

Narrated Anas:

I was informed that the Prophet had said to Mu'adh, "Whosoever will meet Allah without associating anything in worship with Him will go to Paradise." Mu'adh asked the Prophet, "Should I not inform the people of this good news?" The Prophet replied, "No, I am afraid, lest they should depend upon it (absolutely)."


Bukhari :: Knowledge :: [1.3.132]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 132

Narrated Um Salama:

Um-Sulaim came to Allah's Apostle and said, "Verily, Allah is not shy of (telling you) the truth. Is it necessary for a woman to take a bath after she has a wet dream (nocturnal sexual discharge?) The Prophet replied, "Yes, if she notices a discharge." Um Salama, then covered her face and asked, "O Allah's Apostle! Does a woman get a discharge?" He replied, "Yes, let your right hand be in dust (An Arabic expression you say to a person when you contradict his statement meaning "you will not achieve goodness"), and that is why the son resembles his mother."


Bukhari :: Knowledge :: [1.3.133]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 133

Narrated 'Abdullah bin 'Umar:

Once Allah's Apostle said, "Amongst the trees there is a tree, the leaves of which do not fall and is like a Muslim, tell me the name of that tree." Everybody started thinking about the trees of the desert areas and I thought of the date-palm tree but felt shy (to answer). The others asked, "O Allah's Apostle! inform us of it." He replied, "it is the date-palm tree." I told my father what had come to my mind and on that he said, "Had you said it I would have preferred it to such and such a thing that I might possess."


Bukhari :: Knowledge :: [1.3.134]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 134

Narrated 'Ali:

I used to get the emotional urethral discharge frequently so I requested Al-Miqdad to ask the Prophet about it. Al-Miqdad asked him and he replied, "One has to perform ablution (after it)." (See Hadith No. 269).


Bukhari :: Knowledge :: [1.3.135]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 135

Narrated Nafi:

'Abdullah bin 'Umar said: "A man got up in the mosque and said: O Allah's Apostle 'At which place you order us that we should assume the Ihram?' Allah's Apostle replied, 'The residents of Medina should assure the Ihram from Dhil-Hulaifa, the people of Syria from Al-Ju,hfa and the people of Najd from Qarn." Ibn 'Umar further said, "The people consider that Allah's Apostle had also said, 'The residents of Yemen should assume Ihram from Yalamlam.' " Ibn 'Umar used to say, "I do not: remember whether Allah's Apostle had said the last statement or not?"


Bukhari :: Knowledge :: [1.3.136]

Knowledge

Bukhari :: Book 1 :: Volume 3 :: Hadith 136

Narrated Ibn 'Umar:

A man asked the Prophet : "What (kinds of clothes) should a Muhrim (a Muslim intending to perform 'Umra or Hajj) wear? He replied, "He should not wear a shirt, a turban, trousers, a head cloak or garment scented with saffron or Wars (kinds of perfumes). And if he has n slippers, then he can use Khuffs (leather socks) but the socks should be cut short so as to make the ankles bare." (See Hadith No. 615, Vol. 2).


Bukhari :: Ablutions (Wudu') :: [1.4.137]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 137

Narrated Abu Huraira:

Allah's Apostle said, "The prayer of a person who does ,Hadath (passes, urine, stool or wind) is not accepted till he performs (repeats) the ablution." A person from Hadaramout asked Abu Huraira, "What is 'Hadath'?" Abu Huraira replied, " 'Hadath' means the passing of wind from the anus."


Bukhari :: Ablutions (Wudu') :: [1.4.138]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 138

Narrated Nu'am Al-Mujmir:

Once I went up the roof of the mosque, along with Abu Huraira. He perform ablution and said, "I heard the Prophet saying, "On the Day of Resurrection, my followers will be called "Al-Ghurr-ul-Muhajjalun" from the trace of ablution and whoever can increase the area of his radiance should do so (i.e. by performing ablution regularly).' "


Bukhari :: Ablutions (Wudu') :: [1.4.139]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 139

Narrated 'Abbas bin Tamim:

My uncle asked Allah's Apostle about a person who imagined to have passed wind during the prayer. Allah' Apostle replied: "He should not leave his prayers unless he hears sound or smells something."


Bukhari :: Ablutions (Wudu') :: [1.4.140]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 140

Narrated Kuraib:

Ibn 'Abbas said, "The Prophet slept till he snored and then prayed (or probably lay till his breath sounds were heard and then got up and prayed)." Ibn 'Abbas added: "I stayed overnight in the house of my aunt, Maimuna, the Prophet slept for a part of the night, (See Fateh-al-Bari page 249, Vol. 1), and late in the night, he got up and performed ablution from a hanging water skin, a light (perfect) ablution and stood up for the prayer. I, too, performed a similar ablution, then I went and stood on his left. He drew me to his right and prayed as much as Allah wished, and again lay and slept till his breath sounds were heard. Later on the Mua'dhdhin (callmaker for the prayer) came to him and informed him that it was time for Prayer. The Prophet went with him for the prayer without performing a new ablution." (Sufyan said to 'Amr that some people said, "The eyes of Allah's Apostle sleep but his heart does not sleep." 'Amr replied, "I heard 'Ubaid bin 'Umar saying that the dreams of Prophets were Divine Inspiration, and then he recited the verse: 'I (Abraham) see in a dream, (O my son) that I offer you in sacrifice (to Allah)." (37.102) (See Hadith No. 183)


Bukhari :: Ablutions (Wudu') :: [1.4.141]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 141

Narrated Usama bin Zaid:

Allah's Apostle proceeded from 'Arafat till when he reached the mountain pass, he dismounted, urinated and then performed ablution but not a perfect one. I said to him, ("Is it the time for) the prayer, O Allah's Apostle?" He said, "The (place of) prayer is ahead of you." He rode till when he reached Al-Muzdalifa, he dismounted and performed ablution and a perfect one, The (call for) Iqama was pronounced and he led the Maghrib prayer. Then everybody made his camel kneel down at its place. Then the Iqama was pronounced for the 'Isha' prayer which the Prophet led and no prayer was offered in between the two . prayers ('Isha' and Maghrib).


Bukhari :: Ablutions (Wudu') :: [1.4.142]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 142

Narrated 'Ata' bin Yasar:

Ibn 'Abbas performed ablution and washed his face (in the following way): He ladled out a handful of water, rinsed his mouth and washed his nose with it by putting in water and then blowing it out. He then, took another handful (of water) and did like this (gesturing) joining both hands, and washed his face, took another handful of water and washed his right forearm. He again took another handful of water and washed his left forearm, and passed wet hands over his head and took another handful of water and poured it over his right foot (up to his ankles) and washed it thoroughly and similarly took another handful of water and washed thoroughly his left foot (up to the ankles) and said, "I saw Allah's Apostle performing ablution in this way."


Bukhari :: Ablutions (Wudu') :: [1.4.143]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 143

Narrated Ibn 'Abbas:

The Prophet said, "If anyone of you on having sexual relations with his wife said (and he must say it before starting) 'In the name of Allah. O Allah! Protect us from Satan and also protect what you bestow upon us (i.e. the coming offspring) from Satan, and if it is destined that they should have a child then, Satan will never be able to harm that offspring."


Bukhari :: Ablutions (Wudu') :: [1.4.144]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 144

Narrated Anas:

Whenever the Prophet went to answer the call of nature, he used to say, "Allah-umma inni a'udhu bika minal khubuthi wal khaba'ith i.e. O Allah, I seek Refuge with You from all offensive and wicked things (evil deeds and evil spirits)."


Bukhari :: Ablutions (Wudu') :: [1.4.145]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 145

Narrated Ibn 'Abbas:

Once the Prophet entered a lavatory and I placed water for his ablution. He asked, "Who placed it?" He was informed accordingly and so he said, "O Allah! Make him (Ibn 'Abbas) a learned scholar in religion (Islam)."


Bukhari :: Ablutions (Wudu') :: [1.4.146]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 146

Narrated Abu Aiyub Al-Ansari:

Allah's Apostle said, "If anyone of you goes to an open space for answering the call of nature he should neither face nor turn his back towards the Qibla; he should either face the east or the west."


Bukhari :: Ablutions (Wudu') :: [1.4.147]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 147

Narrated 'Abdullah bin 'Umar:

People say, "Whenever you sit for answering the call of nature, you should not face the Qibla or Bait-ulMaqdis (Jerusalem)." I told them. "Once I went up the roof of our house and I saw Allah's Apostle answering the call of nature while sitting on two bricks facing Bait-ul-Maqdis (Jerusalem) (but there was a screen covering him. ' (FatehAl-Bari, Page 258, Vol. 1).


Bukhari :: Ablutions (Wudu') :: [1.4.148]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 148

Narrated 'Aisha:

The wives of the Prophet used to go to Al-Manasi, a vast open place (near Baqia at Medina) to answer the call of nature at night. 'Umar used to say to the Prophet "Let your wives be veiled," but Allah's Apostle did not do so. One night Sauda bint Zam'a the wife of the Prophet went out at 'Isha' time and she was a tall lady. 'Umar addressed her and said, "I have recognized you, O Sauda." He said so, as he desired eagerly that the verses of Al-Hijab (the observing of veils by the Muslim women) may be revealed. So Allah revealed the verses of "Al-Hijab" (A complete body cover excluding the eyes).


Bukhari :: Ablutions (Wudu') :: [1.4.149]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 149

Narrated 'Aisha:

The Prophet said to his wives, "You are allowed to go out to answer the call of nature. "


Bukhari :: Ablutions (Wudu') :: [1.4.150]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 150

Narrated 'Abdullah bin 'Umar:

I went up to the roof of Hafsa's house for some job and I saw Allah's Apostle answering the call of nature facing Sham (Syria, Jordan, Palestine and Lebanon regarded as one country) with his back towards the Qibla. (See Hadith No. 147).


Bukhari :: Ablutions (Wudu') :: [1.4.151]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 151

Narrated 'Abdullah bin 'Umar:

Once I went up the roof of our house and saw Allah's Apostle answering the call of nature while sitting over two bricks facing Bait-ul-Maqdis (Jerusalem). (See Hadith No. 147).


Bukhari :: Ablutions (Wudu') :: [1.4.152]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 152

Narrated Anas bin Malik:

Whenever Allah's Apostle went to answer the call of nature, I along with another boy used to accompany him with a tumbler full of water. (Hisham commented, "So that he might wash his private parts with it.)"


Bukhari :: Ablutions (Wudu') :: [1.4.153]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 153

Narrated Anas:

Whenever Allah's Apostle went to answer the call of nature, I along with another boy from us used to go behind him with a tumbler full of water.


Bukhari :: Ablutions (Wudu') :: [1.4.154]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 154

Narrated Anas bin Malik:

Whenever Allah's Apostle went to answer the call of nature, I along with another boy used to carry a tumbler full of water (for cleaning the private parts) and an 'Anza (spear-headed stuck).


Bukhari :: Ablutions (Wudu') :: [1.4.155]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 155

Narrated Abu Qatada:

Allah's Apostle said, "Whenever anyone of you drinks water, he should not breathe in the drinking utensil, and whenever anyone of you goes to a lavatory, he should neither touch his penis nor clean his private parts with his right hand."


Bukhari :: Ablutions (Wudu') :: [1.4.156]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 156

Narrated Abu Qatada:

The Prophet said, "Whenever anyone of you makes water he should not hold his penis or clean his private parts with his right hand. (And while drinking) one should not breathe in the drinking utensil ."


Bukhari :: Ablutions (Wudu') :: [1.4.157]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 157

Narrated Abu Huraira:

I followed the Prophet while he was going out to answer the call of nature. He used not to look this way or that. So, when I approached near him he said to me, "Fetch for me some stones for ' cleaning the privates parts (or said something similar), and do not bring a bone or a piece of dung." So I brought the stones in the corner of my garment and placed them by his side and I then went away from him. When he finished (from answering the call of nature) he used, them .


Bukhari :: Ablutions (Wudu') :: [1.4.158]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 158

Narrated 'Abdullah:

The Prophet went out to answer the call of nature and asked me to bring three stones. I found two stones and searched for the third but could not find it. So took a dried piece of dung and brought it to him. He took the two stones and threw away the dung and said, "This is a filthy thing."


Bukhari :: Ablutions (Wudu') :: [1.4.159]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 159

Narrated Ibn 'Abbas:

The Prophet performed ablution by washing the body parts only once.


Bukhari :: Ablutions (Wudu') :: [1.4.160]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 160

Narrated 'Abdullah bin Zaid:

The Prophet performed ablution by washing the body parts twice.


Bukhari :: Ablutions (Wudu') :: [1.4.161]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 161

Narrated Humran:

(the slave of 'Uthman) I saw 'Uthman bin 'Affan asking for a tumbler of water (and when it was brought) he poured water over his hands and washed them thrice and then put his right hand in the water container and rinsed his mouth, washed his nose by putting water in it and then blowing it out. then he washed his face and forearrlns up to the elbows thrice, passed his wet hands over his head and washed his feet up to the ankles thrice. Then he said, "Allah's Apostle said 'If anyone Performs ablution like that of mine and offers a two-rak'at prayer during which he does not think of anything else (not related to the present prayer) then his past sins will be forgiven.' " After performing the ablution 'Uthman said, "I am going to tell you a Hadith which I would not have told you, had I not been compelled by a certain Holy Verse (the sub narrator 'Urwa said: This verse is: "Verily, those who conceal the clear signs and the guidance which we have sent down...)" (2:159). I heard the Prophet saying, 'If a man performs ablution perfectly and then offers the compulsory congregational prayer, Allah will forgive his sins committed between that (prayer) and the (next) prayer till he offers it.


Bukhari :: Ablutions (Wudu') :: [1.4.162]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 162

Narrated Abu Huraira:

The Prophet said, "Whoever performs ablution should clean his nose with water by putting the water in it and then blowing it out, and whoever cleans his private parts with stones should do it with odd number of stones."


Bukhari :: Ablutions (Wudu') :: [1.4.163]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 163

Narrated Abu Huraira:

Allah's Apostle said, "If anyone of you performs ablution he should put water in his nose and then blow it out and whoever cleans his private parts with stones should do so with odd numbers. And whoever wakes up from his sleep should wash his hands before putting them in the water for ablution, because nobody knows where his hands were during sleep."


Bukhari :: Ablutions (Wudu') :: [1.4.164]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 164

Narrated 'Abdullah bin 'Amr:

The Prophet remained behind us on a journey. He joined us while we were performing ablution for the 'Asr prayer which was over-due and we were just passing wet hands over our feet (not washing them thoroughly) so he addressed us in a loud voice saying twice orthriae, "Save your heels from the fire."


Bukhari :: Ablutions (Wudu') :: [1.4.165]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 165

Narrated Humran:

(the freed slave of 'Uthman bin 'Affan) I saw 'Uthman bin 'Affan asking (for a tumbler of water) to perform ablution (and when it was brought) he poured water from it over his hands and washed them thrice and then put his right hand in the water container and rinsed his mouth and washed his nose by putting water in it and then blowing it out. Then he washed his face thrice and (then) forearms up to the elbows thrice, then passed his wet hands over his head and then washed each foot thrice. After that 'Uthman said, "I saw the Prophet performing ablution like this of mine, and he said, 'If anyone performs ablution like that of mine and offers a two-rak'at prayer during which he does not think of anything else (not related to the present prayer) then his past sins will be forgiven. '


Bukhari :: Ablutions (Wudu') :: [1.4.166]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 166

Narrated Muhammad Ibn Ziyad:

I heard Abu Huraira saying as he passed by us while the people were performing ablution from a utensil containing water, "Perform ablution perfectly and thoroughly for Abul-Qasim (the Prophet) said, 'Save your heels from the Hell-fire.' "


Bukhari :: Ablutions (Wudu') :: [1.4.167]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 167

Narrated 'Ubaid Ibn Juraij:

I asked 'Abdullah bin 'Umar, "O Abu 'Abdur-Rahman! I saw you doing four things which I never saw being done by anyone of you companions?" 'Abdullah bin 'Umar said, "What are those, O Ibn Juraij?" I said, "I never saw you touching any corner of the Ka'ba except these (two) facing south (Yemen) and I saw you wearing shoes made of tanned leather and dyeing your hair with Hinna; (a kind of dye). I also noticed that whenever you were in Mecca, the people assume l,hram on seeing the new moon crescent (1st of Dhul-Hijja) while you did not assume the Ihlal (Ihram)--(Ihram is also called Ihlal which means 'Loud calling' because a Muhrim has to recite Talbiya aloud when assuming the state of Ihram)--till the 8th of Dhul-Hijja (Day of Tarwiya). 'Abdullah replied, "Regarding the corners of Ka'ba, I never saw Allah's Apostle touching except those facing south (Yemen) and regarding the tanned leather shoes, no doubt I saw Allah's Apostle wearing non-hairy shoes and he used to perform ablution while wearing the shoes (i.e. wash his feet and then put on the shoes). So I love to wear similar shoes. And about the dyeing of hair with Hinna; no doubt I saw Allah's Apostle dyeing his hair with it and that is why I like to dye (my hair with it). Regarding Ihlal, I did not see Allah's Apostle assuming Ihlal till he set out for Hajj (on the 8th of Dhul-Hijja)."


Bukhari :: Ablutions (Wudu') :: [1.4.168]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 168

Narrated Um-'Atiya:

that the Prophet at the time of washing his deceased daughter had said to them, "Start from the right side beginning with those parts which are washed in ablution."


Bukhari :: Ablutions (Wudu') :: [1.4.169]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 169

Narrated 'Aisha:

The Prophet used to like to start from the right side on wearing shoes, combing his hair and cleaning or washing himself and on doing anything else.


Bukhari :: Ablutions (Wudu') :: [1.4.170]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 170

Narrated Anas bin Malik:

saw Allah's Apostle when the 'Asr prayer was due and the people searched for water to perform ablution but they could not find it. Later on (a pot full of) water for ablution was brought to Allah's Apostle . He put his hand in that pot and ordered the people to perform ablution from it. I saw the water springing out from underneath his fingers till all of them performed the ablution (it was one of the miracles of the Prophet).


Bukhari :: Ablutions (Wudu') :: [1.4.171]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 171

Narrated Ibn Sirrn:

I said to 'Ablda, "I have some of the hair of the Prophet which I got from Anas or from his family." 'Abida replied. "No doubt if I had a single hair of that it would have been dearer to me than the whole world and whatever is in it."


Bukhari :: Ablutions (Wudu') :: [1.4.172]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 172

Narrated Anas:

When Allah's Apostle got his head shaved, Abu- Talha was the first to take some of his hair.


Bukhari :: Ablutions (Wudu') :: [1.4.173]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 173

Narrated Abu Huraira:

Allah's Apostle said, "If a dog drinks from the utensil of anyone of you it is essential to wash it seven times."


Bukhari :: Ablutions (Wudu') :: [1.4.174]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 174

Narrated Abu Huraira:

The Prophet said, "A man saw a dog eating mud from (the severity of) thirst. So, that man took a shoe (and filled it) with water and kept on pouring the water for the dog till it quenched its thirst. So Allah approved of his deed and made him to enter Paradise." And narrated Hamza bin 'Abdullah: My father said. "During the lifetime of Allah's Apostle, the dogs used to urinate, and pass through the mosques (come and go), nevertheless they never used to sprinkle water on it (urine of the dog.)"


Bukhari :: Ablutions (Wudu') :: [1.4.175]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 175

Narrated 'Adi bin Hatim:

I asked the Prophet (about the hunting dogs) and he replied, "If you let loose (with Allah's name) your tamed dog after a game and it hunts it, you may eat it, but if the dog eats of (that game) then do not eat it because the dog has hunted it for itself." I further said, "Sometimes I send my dog for hunting and find another dog with it. He said, "Do not eat the game for you have mentioned Allah's name only on sending your dog and not the other dog."


Bukhari :: Ablutions (Wudu') :: [1.4.176]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 176

Narrated Abu Huraira:

Allah's Apostle said, "A person is considered in prayer as long as he is waiting for the prayer in the mosque as long as he does not do Hadath." A non-Arab man asked, "O Abii Huraira! What is Hadath?" I replied, "It is the passing of wind (from the anus) (that is one of the types of Hadath)."


Bukhari :: Ablutions (Wudu') :: [1.4.177]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 177

Narrated 'Abbas bin Tamim:

My uncle said: The Prophet said, "One should not leave his prayer unless he hears sound or smells something."


Bukhari :: Ablutions (Wudu') :: [1.4.178]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 178

Narrated 'Ali:

I used to get emotional urethral discharges frequently and felt shy to ask Allah's Apostle about it. So I requested Al-Miqdad bin Al-Aswad to ask (the Prophet ) about it. Al-Miqdad asked him and he replied, "On has to perform ablution (after it)."


Bukhari :: Ablutions (Wudu') :: [1.4.179]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 179

Narrated Zaid bin Khalid:

I asked 'Uthman bin 'Affan about a person who engaged in intercourse but did no discharge. 'Uthman replied, "He should perform ablution like the one for ar ordinary prayer but he must wash his penis." 'Uthman added, "I heard it from Allah's Apostle." I asked 'Ali Az-Zubair, Talha and Ubai bin Ka'b about it and they, too, gave the same reply. (This order was cancelled later on and taking a bath became necessary for such cases).


Bukhari :: Ablutions (Wudu') :: [1.4.180]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 180

Narrated Abu Said Al-Khud:

Allah's Apostle sent for a Ansari man who came with water dropping from his head. The Prophet said, "Perhaps we have forced you to hurry up, haven't we?" The Ansari replied, "Yes." Allah's Apostle further said, "If you are forced to hurry up (during intercourse) or you do not discharge then ablution is due on you (This order was cancelled later on, i.e. one has to take a bath).


Bukhari :: Ablutions (Wudu') :: [1.4.181]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 181

Narrated Usama bin Zaid:

"When Allah's Apostle departed from 'Arafat, he turned towards a mountain pass where he answered the call of nature. (After he had finished) I poured water and he performed ablution and then I said to him, "O Allah's Apostle! Will you offer the prayer?" He replied, "The Musalla (place of the prayer) is ahead of you (in Al-Muzdalifa)."


Bukhari :: Ablutions (Wudu') :: [1.4.182]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 182

Narrated Al-Mughira bin Shu'ba:

I was in the company of Allah's Apostle on one of the journeys and he went out to answer the call of nature (and after he finished) I poured water and he performed ablution; he washed his face, forearms and passed his wet hand over his head and over the two Khuff, (leather socks).


Bukhari :: Ablutions (Wudu') :: [1.4.183]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 183

Narrated 'Abdullah bin 'Abbas:

that he stayed overnight in the house of Maimuna the wife of the Prophet, his aunt. He added : I lay on the bed (cushion transversally) while Allah's Apostle and his wife lay in the length-wise direction of the cushion. Allah's Apostle slept till the middle of the night, either a bit before or a bit after it and then woke up, rubbing the traces of sleep off his face with his hands. He then, recited the last ten verses of Sura Al-Imran, got up and went to a hanging water-skin. He then Performed the ablution from it and it was a perfect ablution, and then stood up to offer the prayer. I, too, got up and did as the Prophet had done. Then I went and stood by his side. He placed his right hand on my head and caught my right ear and twisted it. He prayed two Rakat then two Rakat and two Rakat and then two Rakat and then two Rakat and then two Rakat (separately six times), and finally one Rak'a (the Witr). Then he lay down again in the bed till the Mu'adhdhin came to him where upon the Prophet got up, offered a two light Rakat prayer and went out and led the Fajr prayer


Bukhari :: Ablutions (Wudu') :: [1.4.184]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 184

Narrated Asma' bint Abu Bakr:

I came to 'Aisha the wife of the Prophet during the solar eclipse. The people were standing and offering the prayer and she was also praying. I asked her, "What is wrong with the people?" She beckoned with her hand towards the sky and said, "Subhan Allah." I asked her, "Is there a sign?" She pointed out, "Yes." So I, too, stood for the prayer till I fell unconscious and later on I poured water on my head. After the prayer, Allah's Apostle praised and glorified Allah and said, "Just now I have seen something which I never saw before at this place of mine, including Paradise and Hell. I have been inspired (and have understood) that you will be put to trials in your graves and these trials will be like the trials of Ad-Dajjal, or nearly like it (the sub narrator is not sure of what Asma' said). Angels will come to every one of you and ask, 'What do you know about this man?' A believer will reply, 'He is Muhammad, Allah's Apostle , and he came to us with self-evident truth and guidance. So we accepted his teaching, believed and followed him.' Then the angels will say to him to sleep in peace as they have come to know that he was a believer. On the other hand a hypocrite or a doubtful person will reply, 'I do not know but heard the people saying something and so I said the same.' "


Bukhari :: Ablutions (Wudu') :: [1.4.185]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 185

Narrated Yahya Al-Mazini:

A person asked 'Abdullah bin Zaid who was the grandfather of 'Amr bin Yahya, "Can you show me how Allah's Apostle used to perform ablution?" 'Abdullah bin Zaid replied in the affirmative and asked for water. He poured it on his hands and washed them twice, then he rinsed his mouth thrice and washed his nose with water thrice by putting water in it and blowing it out. He washed his face thrice and after that he washed his forearms up to the elbows twice and then passed his wet hands over his head from its front to its back and vice versa (beginning from the front and taking them to the back of his head up to the nape of the neck and then brought them to the front again from where he had started) and washed his feet (up to the ankles).


Bukhari :: Ablutions (Wudu') :: [1.4.186]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 186

Narrated 'Amr:

My father saw 'Amr bin Abi Hasan asking 'Abdullah bin Zaid about the ablution of the Prophet. 'Abdullah bin Zaid asked for earthen-ware pot containing water and in front of them performed ablution like that of the Prophet . He poured water from the pot over his hand and washed his hands thrice and then he put his hands in the pot and rinsed his mouth and washed his nose by putting water in it and then blowing it out with three handfuls of water. Again he put his hand in the water and washed his face thrice and washed his forearms up to the elbows twice; and then put his hands in the water and then passed them over his head by bringing them to the front and then to the rear of the head once, and then he washed his feet up to the ankles.


Bukhari :: Ablutions (Wudu') :: [1.4.187]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 187

Narrated Abu Juhaifa:

Allah's Apostle came to us at noon and water for ablution was brought to him. After he had performed ablution, the remaining water was taken by the people and they started smearing their bodies with it (as a blessed thing). The Prophet offered two Rakat of the Zuhr prayer and then two Rakat of the 'Asr prayer while an 'Anza (spear-headed stick) was there (as a Sutra) in front of him. Abu Musa said: The Prophet asked for a tumbler containing water and washed both his hands and face in it and then threw a mouthful of water in the tumbler and said to both of us (Abu Musa and Bilal), "Drink from the tumbler and pour some of its water on your faces and chests."


Bukhari :: Ablutions (Wudu') :: [1.4.188]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 188

Narrated Ibn Shihab:

Mahmud bin Ar-Rabi' who was the person on whose face the Prophet had ejected a mouthful of water from his family's well while he was a boy, and 'Urwa (on the authority of Al-Miswar and others) who testified each other, said, "Whenever the Prophet , performed ablution, his companions were nearly fighting for the remains of the water."


Bukhari :: Ablutions (Wudu') :: [1.4.189]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 189

Narrated As-Sa'ib bin Yazid:

My aunt took me to the Prophet and said, "O Allah's Apostle! This son of my sister has got a disease in his legs." So he passed his hands on my head and prayed for Allah's blessings for me; then he performed ablution and I drank from the remaining water. I stood behind him and saw the seal of Prophethood between his shoulders, and it was like the "Zir-al-Hijla" (means the button of a small tent, but some said 'egg of a partridge.' etc.)


Bukhari :: Ablutions (Wudu') :: [1.4.190]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 190

Narrated 'Amr bin Yahya:

(on the authority of his father) 'Abdullah bin Zaid poured water on his hands from a utensil containing water and washed them and then with one handful of water he rinsed his mouth and cleaned his nose by putting water in it and then blowing it out. He repeated it thrice. He, then, washed his hands and forearms up to the elbows twice and passed wet hands over his head, both forwards and backwards, and washed his feet up to the ankles and said, "This is the ablution of Allah's Apostle."


Bukhari :: Ablutions (Wudu') :: [1.4.191]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 191

Narrated Amr bin Yahya:

My father said, "I saw Amr bin Abi Hasan asking 'Abdullah bin Zaid about the ablution of the Prophet. Abdullah bin Zaid asked for an earthenware pot containing water and performed ablution in front of them. He poured water over his hands and washed them thrice. Then he put his (right) hand in the pot and rinsed his mouth and washed his nose by putting water in it and then blowing it out thrice with three handfuls of water Again he put his hand in the water and washed his face thrice. After that he put his hand in the pot and washed his forearms up to the elbows twice and then again put his hand in the water and passed wet hands over his head by bringing them to the front and then to the back and once more he put his hand in the pot and washed his feet (up to the ankles.)"


Bukhari :: Ablutions (Wudu') :: [1.4.192]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 192

Narrated Wuhaib: that he (the Prophet in narration 191 above) had passed his wet hands


Bukhari :: Ablutions (Wudu') :: [1.4.193]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 193

Narrated Jabir:

Allah's Apostle came to visit me while I was sick and unconscious. He performed ablution and sprinkled the remaining water on me and I became conscious and said, "O Allah's Apostle! To whom will my inheritance go as I have neither ascendants nor descendants?" Then the Divine verses regarding Fara'id (inheritance) were revealed.


Bukhari :: Ablutions (Wudu') :: [1.4.194]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 194

Narrated Anas:

It was the time for prayer, and those whose houses were near got up and went to their people (to perform ablution), and there remained some people (sitting). Then a painted stove pot (Mikhdab) containing water was brought to Allah's Apostles The pot was small, not broad enough for one to spread one's hand in; yet all the people performed ablution. (The sub narrator said, "We asked Anas, 'How many persons were you?' Anas replied 'We were eighty or more"). (It was one of the miracles of Allah's Apostle).


Bukhari :: Ablutions (Wudu') :: [1.4.195]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 195

Narrated Abu Musa:

Once the Prophet asked for a tumbler containing water. He washed his hands and face in it and also threw a mouthful of water in it.


Bukhari :: Ablutions (Wudu') :: [1.4.196]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 196

Narrated 'Abdullah bin Zaid:

Once Allah's Apostle came to us and we brought out water for him in a brass pot. He performed ablution thus: He washed his face thrice, and his forearms to the elbows twice, then passed his wet hands lightly over the head from front to rear and brought them to front again and washed his feet (up to the ankles).


Bukhari :: Ablutions (Wudu') :: [1.4.197]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 197

Narrated 'Aisha:

When the ailment of the Prophet became aggravated and his disease became severe, he asked his wives to permit him to be nursed (treated) in my house. So they gave him the permission. Then the Prophet came (to my house) with the support of two men, and his legs were dragging on the ground, between 'Abbas, and another man." 'Ubaid-Ullah (the sub narrator) said, "I informed 'Abdullah bin 'Abbas of what'Aisha said. Ibn 'Abbas said: 'Do you know who was the other man?' I replied in the negative. Ibn 'Abbas said, 'He was 'Ali (bin Abi Talib)." 'Aisha further said, "When the Prophet came to my house and his sickness became aggravated he ordered us to pour seven skins full of water on him, so that he might give some advice to the people. So he was seated in a Mikhdab (brass tub) belonging to Hafsa, the wife of the Prophet. Then, all of us started pouring water on him from the water skins till he beckoned to us to stop and that we have done (what he wanted us to do). After that he went out to the people."


Bukhari :: Ablutions (Wudu') :: [1.4.198]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 198

Narrated 'Amr bin Yahya:

(on the authority of his father) My uncle used to perform ablution extravagantly and once he asked 'Abdullah bin Zaid to tell him how he had seen the Prophet performing ablution. He asked for an earthen-ware pot containing water, and poured water from it on his hands and washed them thrice, and then put his hand in the earthen-ware pot and rinsed his mouth and washed his nose by putting water in it and then blowing it Out thrice with one handful of water; he again put his hand in the water and took a handful of water and washed his face thrice, then washed his hands up to the elbows twice, and took water with his hand, and passed it over his head from front to back and then from back to front, and then washed his feet (up to the ankles) and said, "I saw the Prophet performing ablution in that way."


Bukhari :: Ablutions (Wudu') :: [1.4.199]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 199

Narrated Thabit:

Anas said, "The Prophet asked for water and a tumbler with a broad base and no so deep, containing a small quantity of water, was brought to him whereby he put his fingers in it." Anas further said, ' noticed the water springing out from amongst his fingers." Anas added, ' estimated that the people who performed ablution with it numbered between seventy to eighty."


Bukhari :: Ablutions (Wudu') :: [1.4.200]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 200

Narrated Anas:

The Prophet used to take a bath with one Saor up to five Mudds (1 Sa'= Mudds) of water and used to perform ablution with one Mudd of water.


Bukhari :: Ablutions (Wudu') :: [1.4.201]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 201

Narrated 'Abdullah bin 'Umar:

Sa'd bin Abi Waqqas said, "The Prophet passed wet hands over his Khuffs." 'Abdullah bin 'Umar asked Umar about it. 'Umar replied in the affirmative and added, "Whenever Sa'd narrates a Hadith from the Prophet, there is no need to ask anyone else about it."


Bukhari :: Ablutions (Wudu') :: [1.4.202]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 202

Narrated Al-Mughlra bin Shu'ba:

Once Allah's Apostle went out to answer the call of nature and I followed him with a tumbler containing water, and when he finished, I poured water and he performed ablution and passed wet hands over his Khuffs.


Bukhari :: Ablutions (Wudu') :: [1.4.203]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 203

Narrated Ja'far bin 'Amr bin Umaiya Ad-Damri:

My father said, "I saw the Prophet passing wet hands over his Khuffs."


Bukhari :: Ablutions (Wudu') :: [1.4.204]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 204

Narrated Ja'far bin 'Amr:

My father said, "I saw the Prophet passing wet hands over his turban and Khuffs (leather socks)."


Bukhari :: Ablutions (Wudu') :: [1.4.205]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 205

Narrated 'Urwa bin Al-Mughira:

My father said, "Once I was in the company of the Prophet on a journey and I dashed to take off his Khuffs. He ordered me to leave them as he had put them after performing ablution. So he passed wet hands or them.


Bukhari :: Ablutions (Wudu') :: [1.4.206]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 206

Narrated 'Abdullah bin 'Abbas:

Allah's Apostle ate a piece of cooked mutton from the shoulder region and prayed without repeating ablution.


Bukhari :: Ablutions (Wudu') :: [1.4.207]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 207

Narrated Ja'far bin 'Amr bin Umaiya:

My father said, "I saw Allah's Apostle taking a piece of (cooked) mutton from the shoulder region and then he was called for prayer. He put his knife down and prayed without repeating ablution."


Bukhari :: Ablutions (Wudu') :: [1.4.208]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 208

Narrated Suwaid bin Al-Nu'man:

In the year of the conquest of Khaibar I went with Allah's Apostle till we reached Sahba,' a place near Khaibar, where Allah's Apostle offered the 'Asr prayer and asked for food. Nothing but Sawrq was brought. He ordered it to be moistened with water. He and all of us ate it and the Prophet got up for the evening prayer (Maghrib prayer), rinsed his mouth with water and we did the same, and he then prayed without repeating the ablution.


Bukhari :: Ablutions (Wudu') :: [1.4.209]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 209

Narrated Maimuna:

The Prophet ate (a piece of) mutton from the shoulder region and then prayed without repeating the ablution.


Bukhari :: Ablutions (Wudu') :: [1.4.210]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 210

Narrated Ibn 'Abbas:

Allah's Apostle drank milk, rinsed his mouth and said, "It has fat."


Bukhari :: Ablutions (Wudu') :: [1.4.211]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 211

Narrated 'Aisha:

Allah's Apostle said, "If anyone of you feels drowsy while praying he should go to bed (sleep) till his slumber is over because in praying while drowsy one does not know whether one is asking for forgiveness or for a bad thing for oneself."


Bukhari :: Ablutions (Wudu') :: [1.4.212]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 212

Narrated Anas:

The Prophet said, "If anyone of you feels drowsy while praying, he should sleep till he understands what he is saying (reciting)."


Bukhari :: Ablutions (Wudu') :: [1.4.213]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 213

Narrated 'Amr bin 'Amir:

Anas said, "The Prophet used to perform ablution for every prayer." I asked Anas, "What you used to do?' Anas replied, "We used to pray with the same ablution until we break it with Hadath."


Bukhari :: Ablutions (Wudu') :: [1.4.214]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 214

Narrated Suwaid bin Nu'man:

In the year of the conquest of Khaibar I went with Allah's Apostle till we reached As-Sahba' where Allah's Apostle led the 'Asr prayer and asked for the food. Nothing but Sawiq was brought and we ate it and drank (water). The Prophet got up for the (Maghrib) Prayer, rinsed his mouth with water and then led the prayer without repeating the ablution.


Bukhari :: Ablutions (Wudu') :: [1.4.215]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 215

Narrated Ibn 'Abbas:

Once the Prophet, while passing through one of the grave-yards of Medina or Mecca heard the voices of two persons who were being tortured in their graves. The Prophet said, "These two persons are being tortured not for a major sin (to avoid)." The Prophet then added, "Yes! (they are being tortured for a major sin). Indeed, one of them never saved himself from being soiled with his urine while the other used to go about with calumnies (to make enmiy between friends). The Prophet then asked for a green leaf of a date-palm tree, broke it into two pieces and put one on each grave. On being asked why he had done so, he replied, "I hope that their torture might be lessened, till these get dried."


Bukhari :: Ablutions (Wudu') :: [1.4.216]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 216

Narrated Anas bin Malik:

Whenever the Prophet went to answer the call of nature, I used to bring water with which he used to clean his private parts.


Bukhari :: Ablutions (Wudu') :: [1.4.217]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 217

Narrated Ibn 'Abbas:

The Prophet once passed by two graves and said, "These two persons are being tortured not for a major sin (to avoid). One of them never saved himself from being soiled with his urine, while the other used to go about with calumnies(to make enmity between friends)." The Prophet then took a green leaf of a date-palm tree, split it into (pieces) and fixed one on each grave. They said, "O Allah's Apostle! Why have you done so?" He replied, "I hope that their punishment might be lessened till these (the pieces of the leaf) become dry." (See the foot-note of Hadith 215).


Bukhari :: Ablutions (Wudu') :: [1.4.218]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 218

Narrated Anas bin Malik:

The Prophet saw a Bedouin making water in the mosque and told the people not to disturb him. When he finished, the Prophet asked for some water and poured it over (the urine).


Bukhari :: Ablutions (Wudu') :: [1.4.219]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 219

Narrated Abu Huraira:

A Bedouin stood up and started making water in the mosque. The people caught him but the Prophet ordered them to leave him and to pour a bucket or a tumbler of water over the place where he had passed the urine. The Prophet then said, "You have been sent to make things easy and not to make them difficult."


Bukhari :: Ablutions (Wudu') :: [1.4.220]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 220

Narrated Anas bin Malik:

The Prophet said as above (219).


Bukhari :: Ablutions (Wudu') :: [1.4.221]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 221

Narrated Anas bin Malik:

A Bedouin came and passed urine in one corner of the mosque. The people shouted at him but the Prophet stopped them till he finished urinating. The Prophet ordered them to spill a bucket of water over that place and they did so.


Bukhari :: Ablutions (Wudu') :: [1.4.222]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 222

Narrated 'Aisha:

(the mother of faithful believers) A child was brought to Allah's Apostle and it urinated on the garment of the Prophet. The Prophet asked for water and poured it over the soiled place.


Bukhari :: Ablutions (Wudu') :: [1.4.223]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 223

Narrated Um Qais bint Mihsin:

I brought my young son, who had not started eating (ordinary food) to Allah's Apostle who took him and made him sit in his lap. The child urinated on the garment of the Prophet, so he asked for water and poured it over the soiled (area) and did not wash it.


Bukhari :: Ablutions (Wudu') :: [1.4.224]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 224

Narrated Hudhaifa:

Once the Prophet went to the dumps of some people and passed urine while standing. He then asked for water and so I brought it to him and he performed ablution.


Bukhari :: Ablutions (Wudu') :: [1.4.225]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 225

Narrated Hudhaifa':

The Prophet and I walked till we reached the dumps of some people. He stood, as any one of you stands, behind a wall and urinated. I went away, but he beckoned me to come. So I approached him and stood near his back till he finished.


Bukhari :: Ablutions (Wudu') :: [1.4.226]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 226

Narrated Abu Wail:

Abu Musa Al-Ash'ari used to lay great stress on the question of urination and he used to say, "If anyone from Bani Israel happened to soil his clothes with urine, he used to cut that portion away." Hearing that, Hudhaifa said to Abu Wail, "I wish he (Abu Musa) didn't (lay great stress on that matter)." Hudhaifa added, "Allah's Apostle went to the dumps of some people and urinated while standing."


Bukhari :: Ablutions (Wudu') :: [1.4.227]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 227

Narrated Asma':

A woman came to the Prophet and said, "If anyone of us gets menses in her clothes then what should she do?" He replied, "She should (take hold of the soiled place), rub it and put it in the water and rub it in order to remove the traces of blood and then pour water over it. Then she can pray in it."


Bukhari :: Ablutions (Wudu') :: [1.4.228]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 228

Narrated 'Aisha:

Fatima bint Abi Hubaish came to the Prophet and said, "O Allah's Apostle I get persistent bleeding from the uterus and do not become clean. Shall I give up my prayers?" Allah's Apostle replied, "No, because it is from a blood vessel and not the menses. So when your real menses begins give up your prayers and when it has finished wash off the blood (take a bath) and offer your prayers." Hisham (the sub narrator) narrated that his father had also said, (the Prophet told her): "Perform ablution for every prayer till the time of the next period comes."


Bukhari :: Ablutions (Wudu') :: [1.4.229]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 229

Narrated 'Aisha:

I used to wash the traces of Janaba (semen) from the clothes of the Prophet and he used to go for prayers while traces of water were still on it (water spots were still visible).


Bukhari :: Ablutions (Wudu') :: [1.4.230]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 230

Narrated 'Aisha:

as above (229).


Bukhari :: Ablutions (Wudu') :: [1.4.231]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 231

Narrated Sulaiman bin Yasar:

I asked 'Aisha about the clothes soiled with semen. She replied, "I used to wash it off the clothes of Allah's Apostle and he would go for the prayer while water spots were still visible. "


Bukhari :: Ablutions (Wudu') :: [1.4.232]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 232

Narrated 'Amr bin Maimun:

I heard Sulaiman bin Yasar talking about the clothes soiled with semen. He said that 'Aisha had said, "I used to wash it off the clothes of Allah's Apostle and he would go for the prayers while water spots were still visible on them.


Bukhari :: Ablutions (Wudu') :: [1.4.233]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 233

Narrated 'Aisha:

I used to wash the semen off the clothes of the Prophet and even then I used to notice one or more spots on them.


Bukhari :: Ablutions (Wudu') :: [1.4.234]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 234

Narrated Abu Qilaba:

Anas said, "Some people of 'Ukl or 'Uraina tribe came to Medina and its climate did not suit them. So the Prophet ordered them to go to the herd of (Milch) camels and to drink their milk and urine (as a medicine). So they went as directed and after they became healthy, they killed the shepherd of the Prophet and drove away all the camels. The news reached the Prophet early in the morning and he sent (men) in their pursuit and they were captured and brought at noon. He then ordered to cut their hands and feet (and it was done), and their eyes were branded with heated pieces of iron, They were put in 'Al-Harra' and when they asked for water, no water was given to them." Abu Qilaba said, "Those people committed theft and murder, became infidels after embracing Islam and fought against Allah and His Apostle ."


Bukhari :: Ablutions (Wudu') :: [1.4.235]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 235

Narrated Anas:

Prior to the construction of the mosque, the Prophet offered the prayers at sheep-folds.


Bukhari :: Ablutions (Wudu') :: [1.4.236]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 236

Narrated Maimuna:

Allah's Apostle was asked regarding ghee (cooking butter) in which a mouse had fallen. He said, "Take out the mouse and throw away the ghee around it and use the rest."


Bukhari :: Ablutions (Wudu') :: [1.4.237]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 237

Narrated Maimuna:

The Prophet was asked regarding ghee in which a mouse had fallen. He said, "Take out the mouse and throw away the ghee around it (and use the rest.)"


Bukhari :: Ablutions (Wudu') :: [1.4.238]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 238

Narrated Abu Huraira:

The Prophet said, "A wound which a Muslim receives in Allah's cause will appear on the Day of Resurrection as it was at the time of infliction; blood will be flowing from the wound and its color will be that of the blood but will smell like musk."


Bukhari :: Ablutions (Wudu') :: [1.4.239]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 239

Narrated Abu Huraira:

Allah's Apostle said, "We (Muslims) are the last (people to come in the world) but (will be) the foremost (on the Day of Resurrection)." The same narrator told that the Prophet had said, "You should not pass urine in stagnant water which is not flowing then (you may need to) wash in it."


Bukhari :: Ablutions (Wudu') :: [1.4.240]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 240

Narrated 'Abdullah:

While Allah's Apostle was prostrating (as stated below).


Bukhari :: Ablutions (Wudu') :: [1.4.241]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 241

Narrated 'Abdullah bin Mas'ud:

Once the Prophet was offering prayers at the Ka'ba. Abu Jahl was sitting with some of his companions. One of them said to the others, "Who amongst you will bring the abdominal contents (intestines, etc.) of a camel of Bani so and so and put it on the back of Muhammad, when he prostrates?" The most unfortunate of them got up and brought it. He waited till the Prophet prostrated and then placed it on his back between his shoulders. I was watching but could not do any thing. I wish I had some people with me to hold out against them. They started laughing and falling on one another. Allah's Apostle was in prostration and he did not lift his head up till Fatima (Prophet's daughter) came and threw that (camel's abdominal contents) away from his back. He raised his head and said thrice, "O Allah! Punish Quraish." So it was hard for Abu Jahl and his companions when the Prophet invoked Allah against them as they had a conviction that the prayers and invocations were accepted in this city (Mecca). The Prophet said, "O Allah! Punish Abu Jahl, 'Utba bin Rabi'a, Shaiba bin Rabi'a, Al-Walid bin 'Utba, Umaiya bin Khalaf, and 'Uqba bin Al Mu'it (and he mentioned the seventh whose name I cannot recall). By Allah in Whose Hands my life is, I saw the dead bodies of those persons who were counted by Allah's Apostle in the Qalib (one of the wells) of Badr.


Bukhari :: Ablutions (Wudu') :: [1.4.242]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 242

Narrated Anas:

The Prophet once spat in his clothes.


Bukhari :: Ablutions (Wudu') :: [1.4.243]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 243

Narrated Aisha:

The Prophet said, "All drinks that produce intoxication are Haram (forbidden to drink).


Bukhari :: Ablutions (Wudu') :: [1.4.244]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 244

Narrated Abu Hazim:

Sahl bin Sa'd As-Sa'idi, was asked by the people, "With what was the wound of the Prophet treated? Sahl replied, "None remains among the people living who knows that better than I. 'Ah used to bring water in his shield and Fatima used to wash the blood off his face. Then straw mat was burnt and the wound was filled with it."


Bukhari :: Ablutions (Wudu') :: [1.4.245]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 245

Narrated Abu Burda:

My father said, "I came to the Prophet and saw him carrying a Siwak in his hand and cleansing his teeth, saying, 'U' U'," as if he was retching while the Siwak was in his mouth."


Bukhari :: Ablutions (Wudu') :: [1.4.246]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 246

Narrated Hudhaifa:

Whenever the Prophet got up at night, he used to clean his mouth with Siwak.


Bukhari :: Ablutions (Wudu') :: [1.4.247]

Ablutions (Wudu')

Bukhari :: Book 1 :: Volume 4 :: Hadith 247

Narrated Al-Bara 'bin 'Azib:

The Prophet said to me, "Whenever you go to bed perform ablution like that for the prayer, lie or your right side and say, "Allahumma aslamtu wajhi ilaika, wa fauwadtu amri ilaika, wa alja'tu Zahri ilaika raghbatan wa rahbatan ilaika. La Malja' wa la manja minka illa ilaika. Allahumma amantu bikitabika-l-ladhi anzalta wa bina-biyika-l ladhi arsalta" (O Allah! I surrender to You and entrust all my affairs to You and depend upon You for Your Blessings both with hope and fear of You. There is no fleeing from You, and there is no place of protection and safety except with You O Allah! I believe in Your Book (the Qur'an) which You have revealed and in Your Prophet (Muhammad) whom You have sent). Then if you die on that very night, you will die with faith (i.e. or the religion of Islam). Let the aforesaid words be your last utterance (before sleep)." I repeated it before the Prophet and when I reached "Allahumma amantu bikitabika-l-ladhi anzalta (O Allah I believe in Your Book which You have revealed)." I said, "Wa-rasulika (and your Apostle)." The Prophet said, "No, (but say): 'Wanabiyika-l-ladhi arsalta (Your Prophet whom You have sent), instead."


Bukhari :: Bathing (Ghusl) :: [1.5.248]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 248

Narrated 'Aisha:

Whenever the Prophet took a bath after Janaba he started by washing his hands and then performed ablution like that for the prayer. After that he would put his fingers in water and move the roots of his hair with them, and then pour three handfuls of water over his head and then pour water all over his body.


Bukhari :: Bathing (Ghusl) :: [1.5.249]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 249

Narrated Maimuna:

(the wife of the Prophet) Allah's Apostle performed ablution like that for the prayer but did not wash his feet. He washed off the discharge from his private parts and then poured water over his body. He withdrew his feet from that place (the place where he took the bath) and then washed them. And that was his way of taking the bath of Janaba.


Bukhari :: Bathing (Ghusl) :: [1.5.250]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 250

Narrated 'Aisha:

The Prophet and I used to take a bath from a single pot called 'Faraq'.


Bukhari :: Bathing (Ghusl) :: [1.5.251]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 251

Narrated Abu Salama:

'Aisha's brother and I went to 'Aisha and he asked her about the bath of the Prophet. She brought a pot containing about a Sa' of water and took a bath and poured it over her head and at what time there was a screen between her and us.


Bukhari :: Bathing (Ghusl) :: [1.5.252]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 252

Narrated Abu Ja'far:

While I and my father were with Jabir bin 'Abdullah, some People asked him about taking a bath He replied, "A Sa' of water is sufficient for you." A man said, "A Sa' is not sufficient for me." Jabir said, "A Sa was sufficient for one who had more hair than you and was better than you (meaning the Prophet)." And then Jabir (put on) his garment and led the prayer.


Bukhari :: Bathing (Ghusl) :: [1.5.253]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 253

Narrated Ibn 'Abbas:

The Prophet and Maimuna used to take a bath from a single pot.


Bukhari :: Bathing (Ghusl) :: [1.5.254]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 254

Narrated Jubair bin Mutim:

Allah's Apostle said, "As for me, I pour water three times on my head." And he pointed with both his hands.


Bukhari :: Bathing (Ghusl) :: [1.5.255]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 255

Narrated Jabir bin 'Abdullah:

The Prophet used to pour water three times on his head.


Bukhari :: Bathing (Ghusl) :: [1.5.256]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 256

Narrated Abu Ja'far:

Jabir bin Abdullah said to me, "Your cousin (Hasan bin Muhammad bin Al-Hanafiya) came to me and asked about the bath of Janaba. I replied, 'The Prophet uses to take three handfuls of water, pour them on his head and then pour more water over his body.' Al-Hasan said to me, 'I am a hairy man.' I replied, 'The Prophet had more hair than you'. "


Bukhari :: Bathing (Ghusl) :: [1.5.257]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 257

Narrated Maimuna:

I placed water for the bath of the Prophet. He washed his hands twice or thrice and then poured water on his left hand and washed his private parts. He rubbed his hands over the earth (and cleaned them), rinsed his mouth, washed his nose by putting water in it and blowing it out, washed his face and both forearms and then poured water over his body. Then he withdrew from that place and washed his feet.


Bukhari :: Bathing (Ghusl) :: [1.5.258]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 258

Narrated 'Aisha:

Whenever the Prophet took the bath of Janaba (sexual relation or wet dream) he asked for the Hilab or some other scent. He used to take it in his hand, rub it first over the right side of his head and then over the left and then rub the middle of his head with both hands.


Bukhari :: Bathing (Ghusl) :: [1.5.259]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 259

Narrated Maimuna:

I placed water for the bath of the Prophet and he poured water with his right hand on his left and washed them. Then he washed his private parts and rubbed his hands on the ground, washed them with water, rinsed his mouth and washed his nose by putting water in it and blowing it out, washed his face and poured water on his head. He withdrew from that place and washed his feet. A piece of cloth (towel) was given to him but he did not use it.


Bukhari :: Bathing (Ghusl) :: [1.5.260]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 260

Narrated Maimuna:

The Prophet took the bath of Janaba. (sexual relation or wet dream). He first cleaned his private parts with his hand, and then rubbed it(that hand) on the wall (earth) and washed it. Then he performed ablution like that for the prayer, and after the bath he washed his feet.


Bukhari :: Bathing (Ghusl) :: [1.5.261]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 261

Narrated Aisha:

The Prophet and I used to take a bath from a single pot of water and our hands used to go in the pot after each other in turn.


Bukhari :: Bathing (Ghusl) :: [1.5.262]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 262

Narrated 'Aisha:

Whenever Allah's Apostle took a bath of Janaba, he washed his hands first.


Bukhari :: Bathing (Ghusl) :: [1.5.263]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 263

Narrated 'Aisha:

The Prophet and I used to take a bath from a single pot of water after Janaba.


Bukhari :: Bathing (Ghusl) :: [1.5.264]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 264

Narrated Anas bin Malik:

the Prophet and one of his wives used to take a bath from a single pot of water. (Shu'ba added to Anas's Statement "After the Janaba")


Bukhari :: Bathing (Ghusl) :: [1.5.265]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 265

Narrated Maimuna:

I placed water for the bath of Allah's Apostle and he poured water over his hands and washed them twice or thrice; then he poured water with his right hand over his left and washed his private parts (with his left hand). He rubbed his hand over the earth and rinsed his mouth and washed his nose by putting water in it and blowing it out. After that he washed his face, both fore arms and head thrice and then poured water over his body. He withdrew from that place and washed his feet.


Bukhari :: Bathing (Ghusl) :: [1.5.266]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 266

Narrated Maimuna bint Al-Harith:

I placed water for the bath of Allah's Apostle and put a screen. He poured water over his hands, and washed them once or twice. (The subnarrator added that he did not remember if she had said thrice or not). Then he poured water with his right hand over his left one and washed his private parts. He rubbed his hand over the earth or the wall and washed it. He rinsed his mouth and washed his nose by putting water in it and blowing it out. He washed his face, forearms and head. He poured water over his body and then withdrew from that place and washed his feet. I presented him a piece of cloth (towel) and he pointed with his hand (that he does not want it) and did not take it.


Bukhari :: Bathing (Ghusl) :: [1.5.267]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 267

Narrated Muhammad bin Al-Muntathir:

on the authority of his father that he had asked 'Aisha (about the Hadith of Ibn 'Umar). She said, "May Allah be Merciful to Abu 'Abdur-Rahman. I used to put scent on Allah's Apostle and he used to go round his wives, and in the morning he assumed the Ihram, and the fragrance of scent was still coming out from his body."


Bukhari :: Bathing (Ghusl) :: [1.5.268]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 268

Narrated Qatada:

Anas bin Malik said, "The Prophet used to visit all his wives in a round, during the day and night and they were eleven in number." I asked Anas, "Had the Prophet the strength for it?" Anas replied, "We used to say that the Prophet was given the strength of thirty (men)." And Sa'id said on the authority of Qatada that Anas had told him about nine wives only (not eleven).


Bukhari :: Bathing (Ghusl) :: [1.5.269]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 269

Narrated 'Ali:

I used to get emotional urethral discharge frequently. Being the son-in-law of the Prophet I requested a man to ask him about it. So the man asked the Prophet about it. The Prophet replied, "Perform ablution after washing your organ (penis)."


Bukhari :: Bathing (Ghusl) :: [1.5.270]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 270

Narrated Muhammad bin Al-Muntathir:

on the authority of his father that he had asked 'Aisha about the saying of Ibn 'Umar(i.e. he did not like to be a Muhrim while the smell of scent was still coming from his body). 'Aisha said, "I scented Allah's Apostle and he went round (had sexual intercourse with) all his wives, and in the morning he was Muhrim (after taking a bath)."


Bukhari :: Bathing (Ghusl) :: [1.5.271]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 271

Narrated 'Aisha:

It is as if I am just looking at the glitter of scent in the parting of the Prophet's head hair while he was a Muhrim.


Bukhari :: Bathing (Ghusl) :: [1.5.272]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 272

Narrated Hisham bin 'Urwa:

(on the authority of his father) 'Aisha said, "Whenever Allah's Apostle took the bath of Janaba, he cleaned his hands and performed ablution like that for prayer and then took a bath and rubbed his hair, till he felt that the whole skin of the head had become wet, then he would pour water thrice and wash the rest of the body." 'Aisha further said, "I and Allah's Apostle used to take a bath from a single water container, from which we took water simultaneously."


Bukhari :: Bathing (Ghusl) :: [1.5.273]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 273

Narrated Maimuna:

Water was placed for the ablution of Allah's Apostle after Janaba. He poured water with his right hand over his left twice or thrice and then washed his private parts and rubbed his hand on the earth or on a wall twice or thrice and then rinsed his mouth, washed his nose by putting water in it and then blowing it out arid then washed his face and forearms and poured water over his head and washed his body. Then he shifted from that place and washed his feet. I brought a piece of cloth, but he did not take it and removed the traces of water from his body with his hand."


Bukhari :: Bathing (Ghusl) :: [1.5.274]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 274

Narrated Abu Huraira:

Once the call (Iqama) for the prayer was announced and the rows were straightened. Allah's Apostle came out; and when he stood up at his Musalla, he remembered that he was Junub. Then he ordered us to stay at our places and went to take a bath and then returned with water dropping from his head. He said, "Allahu-Akbar", and we all offered the prayer with him.


Bukhari :: Bathing (Ghusl) :: [1.5.275]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 275

Narrated Maimuna:

I placed water for the bath of the Prophet and screened him with a garment. He poured water over his hands and washed them. After that he poured water with his right hand over his left and washed his private parts, rubbed his hands with earth and washed them, rinsed his mouth, washed his nose by putting water in it and then blowing it out and then washed his face and forearms. He poured water over his head and body. He then shifted from that place and washed his feet. I gave him a piece of cloth but he did not take it and came out removing the water (from his body) with both his hands.


Bukhari :: Bathing (Ghusl) :: [1.5.276]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 276

Narrated Aisha:

Whenever any one of us was Junub, she poured water over her head thrice with both her hands and then rubbed the right side of her head with one hand and rubbed the left side of the head with the other hand.


Bukhari :: Bathing (Ghusl) :: [1.5.277]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 277

Narrated Abu Huraira:

The Prophet said, 'The (people of) Bani Israel used to take bath naked (all together) looking at each other. The Prophet Moses used to take a bath alone. They said, 'By Allah! Nothing prevents Moses from taking a bath with us except that he has a scrotal hernia.' So once Moses went out to take a bath and put his clothes over a stone and then that stone ran away with his clothes. Moses followed that stone saying, "My clothes, O stone! My clothes, O stone! till the people of Bani Israel saw him and said, 'By Allah, Moses has got no defect in his body. Moses took his clothes and began to beat the stone." Abu Huraira added, "By Allah! There are still six or seven marks present on the stone from that excessive beating."

Narrated Abu Huraira: The Prophet said, "When the Prophet Job (Aiyub) was taking a bath naked, golden locusts began to fall on him. Job started collecting them in his clothes. His Lord addressed him, 'O Job! Haven't I given you enough so that you are not in need of them.' Job replied, 'Yes!' By Your Honor (power)! But I cannot dispense with Your Blessings.' "


Bukhari :: Bathing (Ghusl) :: [1.5.278]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 278

Narrated Um Hani bint Abi Talib:

I went to Allah's Apostle in the year of the conquest of Mecca and found him taking a bath while Fatima was screening him. The Prophet asked, "Who is it?" I replied, "I am Um-Hani."


Bukhari :: Bathing (Ghusl) :: [1.5.279]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 279

Narrated Maimuna:

I screened the Prophet while he was taking a bath of Janaba. He washed his hands, poured water from his right hand over his left and washed his private parts. Then he rubbed his hand over a wall or the earth, and performed ablution similar to that for the prayer but did not wash his feet. Then he poured water over his body, shifted from that place, and washed his feet.


Bukhari :: Bathing (Ghusl) :: [1.5.280]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 280

Narrated Um-Salama:

(the mother of the believers) Um Sulaim, the wife of Abu Talha, came to Allah's Apostle and said, "O Allah's Apostle! Verily Allah is not shy of (telling you) the truth. Is it necessary for a woman to take a bath after she has a wet dream (nocturnal sexual discharge)?" Allah's Apostle replied, "Yes, if she notices a discharge."


Bukhari :: Bathing (Ghusl) :: [1.5.281]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 281

Narrated Abu Huraira:

The Prophet came across me in one of the streets of Medina and at that time I was Junub. So I slipped away from him and went to take a bath. On my return the Prophet said, "O Abu Huraira! Where have you been?" I replied, "I was Junub, so I disliked to sit in your company." The Prophet said, "Subhan Allah! A believer never becomes impure."


Bukhari :: Bathing (Ghusl) :: [1.5.282]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 282

Narrated Anas bin Malik:

The Prophet used to visit all his wives in one night and he had nine wives at that time.


Bukhari :: Bathing (Ghusl) :: [1.5.283]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 283

Narrated Abu Huraira:

Allah's Apostle came across me and I was Junub He took my hand and I went along with him till he sat down I slipped away, went home and took a bath. When I came back. he was still sitting there. He then said to me, "O AbuHuraira! Where have you been?' I told him about it The Prophet said, "Subhan Allah! O Abu Huraira! A believer never becomes impure."


Bukhari :: Bathing (Ghusl) :: [1.5.284]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 284

Narrated Abu Salama :

I asked 'Aisha "Did the Prophet use to sleep while he was Junub?" She replied, "Yes, but he used to perform ablution (before going to bed).


Bukhari :: Bathing (Ghusl) :: [1.5.285]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 285

Narrated 'Umar bin Al-Khattab:

I asked Allah's Apostle "Can any one of us sleep while he is Junub?" He replied, "Yes, if he performs ablution, he can sleep while he is Junub."


Bukhari :: Bathing (Ghusl) :: [1.5.286]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 286

Narrated 'Aisha:

Whenever the Prophet intended to sleep while he was Junub, he used to wash his private parts and perform ablution like that for the prayer.


Bukhari :: Bathing (Ghusl) :: [1.5.287]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 287

Narrated 'Abdullah:

'Umar asked the Prophet "Can anyone of us sleep while he is Junub?" He replied, "Yes, if he performs ablution."


Bukhari :: Bathing (Ghusl) :: [1.5.288]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 288

Narrated 'Abdullah bin 'Umar:

Umar bin Al-Khattab told Allah's Apostle, "I became Junub at night." Allah's Apostle replied, "Perform ablution after washing your private parts and then sleep."


Bukhari :: Bathing (Ghusl) :: [1.5.289]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 289

Narrated Hisham:

as the following Hadith 290.


Bukhari :: Bathing (Ghusl) :: [1.5.290]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 290

Narrated Abu Huraira:

The Prophet said, "When a man sits in between the four parts of a woman and did the sexual intercourse with her, bath becomes compulsory."


Bukhari :: Bathing (Ghusl) :: [1.5.291]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 291

Narrated Zaid bin Khalid AjJuhani:

I asked 'Uthman bin 'Affan about a man who engaged in the sexual intercourse with his wife but did not discharge. 'Uthman replied, "He should perform ablution like that for the prayer after washing his private parts." 'Uthman added, "I heard that from Allah's Apostle." I asked 'Ali bin Abi Talib, Az-Zubair bin Al-'Awwam, Talha bin 'Ubaidullah and Ubai bin Ka'b and a gave the same reply. (Abu Aiylub said that he had heard that from Allah's Apostle ) (This order was cancelled later on so one has to take a bath. See, Hadith No. 180).


Bukhari :: Bathing (Ghusl) :: [1.5.292]

Bathing (Ghusl)

Bukhari :: Book 1 :: Volume 5 :: Hadith 292

Narrated Ubai bin Ka'b:

I asked Allah's Apostle about a man who engages in sexual intercourse with his wife but does not discharge. He replied, "He should wash the parts which comes in contact with the private parts of the woman, perform ablution and then pray." (Abu 'Abdullah said, "Taking a bath is safer and is the last order.")


Bukhari :: Menstrual Periods :: [1.6.293]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 293

Narrated Al-Qasim:

'Aisha said, "We set out with the sole intention of performing Hajj and when we reached Sarif, (a place six miles from Mecca) I got my menses. Allah's Apostle came to me while I was weeping. He said 'What is the matter with you? Have you got your menses?' I replied, 'Yes.' He said, 'This is a thing which Allah has ordained for the daughters of Adam. So do what all the pilgrims do with the exception of the Taw-af (Circumambulation) round the Ka'ba." 'Aisha added, "Allah's Apostle sacrificed cows on behalf of his wives."


Bukhari :: Menstrual Periods :: [1.6.294]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 294

Narrated 'Aisha:

While in menses, I used to comb the hair of Allah's Apostle .


Bukhari :: Menstrual Periods :: [1.6.295]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 295

Narrated 'Urwa:

A person asked me, "Can a woman in menses serve me? And can a Junub woman come close to me?" I replied, "All this is easy for me. All of them can serve me, and there is no harm for any other person to do the same. 'Aisha told me that she used to comb the hair of Allah's Apostle while she was in her menses, and he was in Itikaf (in the mosque). He would bring his head near her in her room and she would comb his hair, while she used to be in her menses."


Bukhari :: Menstrual Periods :: [1.6.296]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 296

Narrated 'Aisha:

The Prophet used to lean on my lap and recite Qur'an while I was in menses.


Bukhari :: Menstrual Periods :: [1.6.297]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 297

Narrated Um Salama:

While I was laying with the Prophet under a single woolen sheet, I got the menses. I slipped away and put on the clothes for menses. He said, "Have you got "Nifas" (menses)?" I replied, "Yes." He then called me and made me lie with him under the same sheet.


Bukhari :: Menstrual Periods :: [1.6.298]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 298

Narrated 'Aisha:

The Prophet and I used to take a bath from a single pot while we were Junub. During the menses, he used to order me to put on an Izar (dress worn below the waist) and used to fondle me. While in Itikaf, he used to bring his head near me and I would wash it while I used to be in my periods (menses).


Bukhari :: Menstrual Periods :: [1.6.299]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 299

Narrated 'Abdur-Rahman bin Al-Aswad:

(on the authority of his father) 'Aisha said: "Whenever Allah's Apostle wanted to fondle anyone of us during her periods (menses), he used to order her to put on an Izar and start fondling her." 'Aisha added, "None of you could control his sexual desires as the Prophet could."


Bukhari :: Menstrual Periods :: [1.6.300]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 300

Narrated Maimuna:

When ever Allah's Apostle wanted to fondle any of his wives during the periods (menses), he used to ask her to wear an Izar.


Bukhari :: Menstrual Periods :: [1.6.301]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 301

Narrated Abu Said Al-Khudri:

Once Allah's Apostle went out to the Musalla (to offer the prayer) o 'Id-al-Adha or Al-Fitr prayer. Then he passed by the women and said, "O women! Give alms, as I have seen that the majority of the dwellers of Hell-fire were you (women)." They asked, "Why is it so, O Allah's Apostle ?" He replied, "You curse frequently and are ungrateful to your husbands. I have not seen anyone more deficient in intelligence and religion than you. A cautious sensible man could be led astray by some of you." The women asked, "O Allah's Apostle! What is deficient in our intelligence and religion?" He said, "Is not the evidence of two women equal to the witness of one man?" They replied in the affirmative. He said, "This is the deficiency in her intelligence. Isn't it true that a woman can neither pray nor fast during her menses?" The women replied in the affirmative. He said, "This is the deficiency in her religion."


Bukhari :: Menstrual Periods :: [1.6.302]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 302

Narrated 'Aisha:

We set out with the Prophet for Hajj and when we reached Sarif I got my menses. When the Prophet came to me, I was weeping. He asked, "Why are you weeping?" I said, "I wish if I had not performed Hajj this year." He asked, "May be that you got your menses?" I replied, "Yes." He then said, "This is the thing which Allah has ordained for all the daughters of Adam. So do what all the pilgrims do except that you do not perform the Tawaf round the Ka'ba till you are clean."


Bukhari :: Menstrual Periods :: [1.6.303]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 303

Narrated 'Aisha:

Fatima bint Abi Hubaish said to Allah's Apostle, "O Allah's Apostle! I do not become clean (from bleeding). Shall I give up my prayers?" Allah's Apostle replied: "No, because it is from a blood vessel and not the menses. So when the real menses begins give up your prayers and when it (the period) has finished wash the blood off your body (take a bath) and offer your prayers."


Bukhari :: Menstrual Periods :: [1.6.304]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 304

Narrated Asma' bint Abi Bakr:

A woman asked Allah's Apostle, "O Allah's Apostle! What should we do, if the blood of menses falls on our clothes?" Allah's Apostle replied, "If the blood of menses falls on the garment of anyone of you, she must take hold of the blood spot, rub it, and wash it with water and then pray in (with it)."


Bukhari :: Menstrual Periods :: [1.6.305]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 305

Narrated 'Aisha:

Whenever anyone of us got her menses, she, on becoming clean, used to take hold of the blood spot and rub the blood off her garment, and pour water over it and wash that portion thoroughly and sprinkle water over the rest of the garment. After that she would pray in (with) it.


Bukhari :: Menstrual Periods :: [1.6.306]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 306

Narrated 'Aisha:

Once one of the wives of the Prophet did Itikaf along with him and she was getting bleeding in between her periods. She used to see the blood (from her private parts) and she would perhaps put a dish under her for the blood. (The sub-narrator 'Ikrima added, 'Aisha once saw the liquid of safflower and said, "It looks like what so and so used to have.")


Bukhari :: Menstrual Periods :: [1.6.307]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 307

Narrated 'Aisha:

"One of the wives of Allah's Apostle joined him in l'tikaf and she noticed blood and yellowish discharge (from her private parts) and put a dish under her when she prayed."


Bukhari :: Menstrual Periods :: [1.6.308]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 308

Narrated 'Aisha:

One of the mothers of the faithful believers (i.e. the wives of the Prophet ) did l'tikaf while she was having bleeding in between her periods.


Bukhari :: Menstrual Periods :: [1.6.309]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 309

Narrated 'Aisha:

None of us had more than a single garment and we used to have our menses while wearing it. Whenever it got soiled with blood of menses we used to apply saliva to the blood spot and rub off the blood with our nails.


Bukhari :: Menstrual Periods :: [1.6.310]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 310

Narrated Um-'Atiya:

We were forbidden to mourn for a dead person for more than three days except in the case of a husband for whom mourning was allowed for four months and ten days. (During that time) we were not allowed to put ko,hl (Antimony eye power) in our eyes or to use perfumes or to put on colored clothes except a dress made of 'Asb (a kind of Yemen cloth, very coarse and rough). We were allowed very light perfumes at the time of taking a bath after menses and also we were forbidden to go with the funeral procession .


Bukhari :: Menstrual Periods :: [1.6.311]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 311

Narrated 'Aisha:

A woman asked the Prophet about the bath which is take after finishing from the menses. The Prophet told her what to do and said, "Purify yourself with a piece of cloth scented with musk." The woman asked, "How shall I purify myself with it" He said, "Subhan Allah! Purify yourself (with it)." I pulled her to myself and said, "Rub the place soiled with blood with it."


Bukhari :: Menstrual Periods :: [1.6.312]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 312

Narrated 'Aisha:

An Ansari woman asked the Prophet how to take a bath after finishing from the menses. He replied, "Take a piece a cloth perfumed with musk and clean the private parts with it thrice." The Prophet felt shy and turned his face. So pulled her to me and told her what the Prophet meant.


Bukhari :: Menstrual Periods :: [1.6.313]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 313

Narrated 'Aisha:

In the last Hajj of Allah's Apostle I assume the Ihram for Hajj along with Allah Apostle. I was one of those who intended Tamattu' (to perform Hajj an 'Umra) and did not take the Hadi (animal for sacrifice) with me. I got my menses and was not clean till the night of 'Arafa I said, "O Allah's Apostle! It is the night of the day of 'Arafat and I intended to perform the Hajj Tamattu' with 'Umra Allah's Apostle told me to undo my hair and comb it and to postpone the 'Umra. I did the same and completed the Hajj. On the night of Al-Hasba (i.e. place outside Mecca where the pilgrims go after finishing all the ceremonies Hajj at Mina) he (the Prophet ordered 'Abdur Rahman ('Aisha's brother) to take me to At-Tan'im to assume the lhram for'Umra in lieu of that of Hajj-atTamattu' which I had intended to perform.


Bukhari :: Menstrual Periods :: [1.6.314]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 314

Narrated 'Aisha:

On the 1st of Dhul-Hijja we set out with the intention of performing Hajj. Allah's Apostle said, "Any one who likes to assume the Ihram for 'Umra he can do so. Had I not brought the Hadi with me, I would have assumed the Ihram for 'Umra. "Some of us assumed the Ihram for 'Umra while the others assumed the Ihram for Hajj. I was one of those who assumed the Ihram for 'Umra. I got menses and kept on menstruating until the day of 'Arafat and complained of that to the Prophet . He told me to postpone my 'Umra, undo and comb my hair, and to assure the Ihram of Hajj and I did so. On the right of Hasba, he sent my brother 'Abdur-Rahman bin Abi Bakr with me to At-Tah'im, where I assumed the Ihram for'Umra in lieu of the previous one. Hisham said, "For that ('Umra) no Hadi, fasting or alms were required.


Bukhari :: Menstrual Periods :: [1.6.315]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 315

Narrated Anas bin Malik:

The Prophet said, "At every womb Allah appoints an angel who says, 'O Lord! A drop of semen, O Lord! A clot. O Lord! A little lump of flesh." Then if Allah wishes (to complete) its creation, the angel asks, (O Lord!) Will it be a male or female, a wretched or a blessed, and how much will his provision be? And what will his age be?' So all that is written while the child is still in the mother's womb."


Bukhari :: Menstrual Periods :: [1.6.316]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 316

Narrated 'Urwa:

'Aisha said, "We set out with the Prophet in his last Hajj. Some of us intended to perform 'Umra while others Hajj. When we reached Mecca, Allah's Apostle said, 'Those who had assumed the lhram for'Umra and had not brought the Hadi should finish his lhram and whoever had assumed the Ihram for 'Umra and brought the Hadi should not finish the Ihram till he has slaughtered his Hadi and whoever had assumed the lhram for Hajj should complete his Hajj." 'Aisha further said, "I got my periods (menses) and kept on menstruating till the day of 'Arafat, and I had assumed the Ihram for 'Umra only (Tamattu'). The Prophet ordered me to undo and comb my head hair and assume the lhram for Hajj only and leave the 'Umra. I did the same till I completed the Hajj. Then the Prophet sent 'Abdur Rahman bin Abi Bakr with me and ordered me to perform 'Umra from At-Tan'im in lieu of the missed 'Umra."


Bukhari :: Menstrual Periods :: [1.6.317]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 317

Narrated 'Aisha:

Fatima bint Abi Hubaish used to have bleeding in between the periods, so she asked the Prophet about it . He replied, "The bleeding is from a blood vessel and not the menses. So give up the prayers when the (real) menses begin and when it has finished, take a bath and start praying."


Bukhari :: Menstrual Periods :: [1.6.318]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 318

Narrated Mu'adha:

A woman asked 'Aisha, "Should I offer the prayers that which I did not offer because of menses" 'Aisha said, "Are you from the Huraura' (a town in Iraq?) We were with the Prophet and used to get our periods but he never ordered us to offer them (the Prayers missed during menses)." 'Aisha perhaps said, "We did not offer them."


Bukhari :: Menstrual Periods :: [1.6.319]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 319

Narrated Zainab bint Abi Salama:

Um-Salama said, "I got my menses while I was lying with the Prophet under a woolen sheet. So I slipped away, took the clothes for menses and put them on. Allah's Apostle said, 'Have you got your menses?' I replied, 'Yes.' Then he called me and took me with him under the woolen sheet." Um Salama further said, "The Prophet used to kiss me while he was fasting. The Prophet and I used to take the bath of Janaba from a single pot."


Bukhari :: Menstrual Periods :: [1.6.320]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 320

Narrated Um Salama:

While I was lying with the Prophet under a woolen sheet, I got my menses. I slipped away and put on the clothes for menses. The Prophet said, "Have you got your menses?" I replied, "Yes." He called me and I slept with him under the woolen sheet.


Bukhari :: Menstrual Periods :: [1.6.321]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 321

Narrated Aiyub:

Hafsa said, 'We used to forbid our young women to go out for the two 'Id prayers. A woman came and stayed at the palace of Bani Khalaf and she narrated about her sister whose husband took part in twelve holy battles along with the Prophet and her sister was with her husband in six (out of these twelve). She (the woman's sister) said, "We used to treat the wounded, look after the patients and once I asked the Prophet, 'Is there any harm for any of us to stay at home if she doesn't have a veil?' He said, 'She should cover herself with the veil of her companion and should participate in the good deeds and in the religious gathering of the Muslims.' When Um 'Atiya came I asked her whether she had heard it from the Prophet. She replied, "Yes. May my father be sacrificed for him (the Prophet)! (Whenever she mentioned the Prophet she used to say, 'May my father be sacrificed for him) I have heard the Prophet saying, 'The unmarried young virgins and the mature girl who stay often screened or the young unmarried virgins who often stay screened and the menstruating women should come out and participate in the good deeds as well as the religious gathering of the faithful believers but the menstruating women should keep away from the Musalla (praying place).' " Hafsa asked Um 'Atiya surprisingly, "Do you say the menstruating women?" She replied, "Doesn't a menstruating woman attend 'Arafat (Hajj) and such and such (other deeds)?"


Bukhari :: Menstrual Periods :: [1.6.322]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 322

Narrated 'Aisha:

Fatima bint Abi Hubaish asked the Prophet, "I got persistent bleeding (in between the periods) and do not become clean. Shall I give up prayers?" He replied, "No, this is from a blood vessel. Give up the prayers only for the days on which you usually get the menses and then take a bath and offer your prayers."


Bukhari :: Menstrual Periods :: [1.6.323]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 323

Narrated Um 'Atiya:

We never considered yellowish discharge as a thing of importance (as menses).


Bukhari :: Menstrual Periods :: [1.6.324]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 324

Narrated 'Aisha:

(the wife of the Prophet) Um Habiba got bleeding in between the periods for seven years. She asked Allah's Apostle about it. He ordered her to take a bath (after the termination of actual periods) and added that it was (from) a blood vessel. So she used to take a bath for every prayer.


Bukhari :: Menstrual Periods :: [1.6.325]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 325

Narrated 'Aisha:

(the wife of the Prophet) I told Allah's Apostle that Safiya bint Huyai had got her menses. He said, "She will probably delay us. Did she perform Tawaf (Al-Ifada) with you?" We replied, "Yes." On that the Prophet told her to depart.


Bukhari :: Menstrual Periods :: [1.6.326]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 326

Narrated Ibn 'Abbas:

A woman is al lowed to leave (go back home) if she gets menses (after Tawaf-AlIfada). Ibn 'Umar formerly used to say that she should not leave but later on I heard him saying, "She may leave, since Allah's Apostle gave them the permission to leave (after Tawaf-AlIfada."


Bukhari :: Menstrual Periods :: [1.6.327]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 327

Narrated 'Aisha:

The Prophet said to me, "Give up the prayer when your menses begin and when it has finished, wash the blood off your body (take a bath) and start praying."


Bukhari :: Menstrual Periods :: [1.6.328]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 328

Narrated Samura bin Jundab:

The Prophet offered the funeral prayer for the dead body of a woman who died of (during) delivery (i.e. child birth) and he stood by the middle of her body.


Bukhari :: Menstrual Periods :: [1.6.329]

Menstrual Periods

Bukhari :: Book 1 :: Volume 6 :: Hadith 329

Narrated Maimuna:

(the wife of the Prophet) During my menses, I never prayed, but used to sit on the mat beside the mosque of Allah's Apostle. He used to offer the prayer on his sheet and in prostration some of his clothes used to touch me."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.330]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 330

Narrated 'Aisha:

(the wife of the Prophet) We set out with Allahs Apostle on one of his journeys till we reached Al-Baida' or Dhatul-Jaish, a necklace of mine was broken (and lost). Allah's Apostle stayed there to search for it, and so did the people along with him. There was no water at that place, so the people went to Abu- Bakr As-Siddiq and said, "Don't you see what 'Aisha has done? She has made Allah's Apostle and the people stay where there is no water and they have no water with them." Abu Bakr came while Allah's Apostle was sleeping with his head on my thigh, He said, to me: "You have detained Allah's Apostle and the people where there is no water and they have no water with them.

So he admonished me and said what Allah wished him to say and hit me on my flank with his hand. Nothing prevented me from moving (because of pain) but the position of Allah's Apostle on my thigh. Allah's Apostle got up when dawn broke and there was no water. So Allah revealed the Divine Verses of Tayammum. So they all performed Tayammum. Usaid bin Hudair said, "O the family of Abu Bakr! This is not the first blessing of yours." Then the camel on which I was riding was caused to move from its place and the necklace was found beneath it.


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.331]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 331

Narrated Jabir bin 'Abdullah:

The Prophet said, "I have been given five things which were not given to any one else before me.

1. Allah made me victorious by awe, (by His frightening my enemies) for a distance of one month's journey.

2. The earth has been made for me (and for my followers) a place for praying and a thing to perform Tayammum, therefore anyone of my followers can pray wherever the time of a prayer is due.

3. The booty has been made Halal (lawful) for me yet it was not lawful for anyone else before me.

4. I have been given the right of intercession (on the Day of Resurrection).

5. Every Prophet used to be sent to his nation only but I have been sent to all mankind.


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.332]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 332

Narrated 'Urwa's father:

Aisha said, "I borrowed a necklace from Asma' and it was lost. So Allah's Apostle sent a man to search for it and he found it. Then the time of the prayer became due and there was no water. They prayed (without ablution) and informed Allah's Apostle about it, so the verse of Tayammum was revealed." Usaid bin Hudair said to 'Aisha, "May Allah reward you. By Allah, whenever anything happened which you did not like, Allah brought good for you and for the Muslims in that."

Al-Jurf and the time for the 'Asr prayer became due while he was at Marbad-AnNa'am (sheep-fold), so he (performed Tayammum) and prayed there and then entered Medina when the sun was still high but he did not repeat that prayer.


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.333]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 333

Narrated Abu Juhaim Al-Ansari:

The Prophet came from the direction of Bir Jamal. A man met him and greeted him. But he did not return back the greeting till he went to a (mud) wall and smeared his hands and his face with its dust (performed Tayammum) and then returned back the greeting.


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.334]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 334

Narrated 'Abdur Rahman bin Abza:

A man came to 'Umar bin Al-Khattab and said, "I became Junub but no water was available." 'Ammar bin Yasir said to 'Umar, "Do you remember that you and I (became Junub while both of us) were together on a journey and you didn't pray but I rolled myself on the ground and prayed? I informed the Prophet about it and he said, 'It would have been sufficient for you to do like this.' The Prophet then stroked lightly the earth with his hands and then blew off the dust and passed his hands over his face and hands."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.335]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 335

Narrated Said bin 'Abdur Rahman bin Abza:

(on the authority of his father who said) 'Ammar said so (the above Statement). And Shu'ba stroked lightly the earth with his hands and brought them close to his mouth (blew off the dust) and passed them over his face and then the backs of his hands. 'Ammar said, "Ablution (meaning Tayammum here) is sufficient for a Muslim if water is not available."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.336]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 336

Narrated 'Abdur Rahman bin Abza:

that while he was in the company of 'Umar, 'Ammar said to 'Umar, "We were in a detachment and became Junub and I blew the dust off my hands (performed the rolling over the earth and prayed.)"


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.337]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 337

Narrated 'Abdur Rahman bin Abza:

'Ammar said to 'Umar "I rolled myself in the dust and came to the Prophet who said, 'Passing dusted hands over the face and the backs of the hands is sufficient for you.' "


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.338]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 338

Narrated 'Ammar:

as above.


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.339]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 339

Narrated 'Ammar:

The Prophet stroked the earth with his hands and then passed them over his face and the backs of his hands (while demonstrating Tayammum).


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.340]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 340

Narrated 'Imran:

Once we were traveling with the Prophet and we carried on traveling till the last part of the night and then we (halted at a place) and slept (deeply). There is nothing sweeter than sleep for a traveler in the last part of the night. So it was only the heat of the sun that made us to wake up and the first to wake up was so and so, then so and so and then so and so (the narrator 'Auf said that Abu Raja' had told him their names but he had forgotten them) and the fourth person to wake up was 'Umar bin Al-Khattab. And whenever the Prophet used to sleep, nobody would wake up him till he himself used to get up as we did not know what was happening (being revealed) to him in his sleep. So, 'Umar got up and saw the condition of the people, and he was a strict man, so he said, "Allahu Akbar" and raised his voice with Takbir, and kept on saying loudly till the Prophet got up because of it. When he got up, the people informed him about what had happened to them. He said, "There is no harm (or it will not be harmful). Depart!" So they departed from that place, and after covering some distance the Prophet stopped and asked for some water to perform the ablution. So he performed the ablution and the call for the prayer was pronounced and he led the people in prayer. After he finished from the prayer, he saw a man sitting aloof who had not prayed with the people. He asked, "O so and so! What has prevented you from praying with us?" He replied, "I am Junub and there is no water. " The Prophet said, "Perform Tayammum with (clean) earth and that is sufficient for you."

Then the Prophet proceeded on and the people complained to him of thirst. Thereupon he got down and called a person (the narrator 'Auf added that Abu Raja' had named him but he had forgotten) and 'Ali, and ordered them to go and bring water. So they went in search of water and met a woman who was sitting on her camel between two bags of water. They asked, "Where can we find water?" She replied, "I was there (at the place of water) this hour yesterday and my people are behind me." They requested her to accompany them. She asked, "Where?" They said, "To Allah's Apostle ." She said, "Do you mean the man who is called the Sabi, (with a new religion)?" They replied, "Yes, the same person. So come along." They brought her to the Prophet and narrated the whole story. He said, "Help her to dismount." The Prophet asked for a pot, then he opened the mouths of the bags and poured some water into the pot. Then he closed the big openings of the bags and opened the small ones and the people were called upon to drink and water their animals. So they all watered their animals and they (too) all quenched their thirst and also gave water to others and last of all the Prophet gave a pot full of water to the person who was Junub and told him to pour it over his body. The woman was standing and watching all that which they were doing with her water. By Allah, when her water bags were returned the looked like as if they were more full (of water) than they had been before (Miracle of Allah's Apostle) Then the Prophet ordered us to collect something for her; so dates, flour and Sawiq were collected which amounted to a good meal that was put in a piece of cloth. She was helped to ride on her camel and that cloth full of food-stuff was also placed in front of her and then the Prophet said to her, "We have not taken your water but Allah has given water to us." She returned home late. Her relatives asked her: "O so and so what has delayed you?" She said, "A strange thing! Two men met me and took me to the man who is called the Sabi' and he did such and such a thing. By Allah, he is either the greatest magician between this and this (gesturing with her index and middle fingers raising them towards the sky indicating the heaven and the earth) or he is Allah's true Apostle."

Afterwards the Muslims used to attack the pagans around her abode but never touched her village. One day she said to her people, "I think that these people leave you purposely. Have you got any inclination to Islam?" They obeyed her and all of them embraced Islam.

Abu 'Abdultah said: The word Saba'a means "The one who has deserted his old religion and embraced a new religion." Abul 'Ailya said, "The Sabis are a sect of people of the Scripture who recite the Book of Psalms."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.341]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 341

Narrated Abu Wail:

Abu Muisa said to'Abdullah bin Mas'ud, "If one does not find water (for ablution) can he give up the prayer?" Abdullah replied, "If you give the permission to perform Tayammum they will perform Tayammum even if water was available if one of them found it cold." Abu Musa said, "What about the statement of 'Ammar to 'Umar?" 'Abdullah replied, "Umar was not satisfied by his statement."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.342]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 342

Narrated Shaqiq bin Salama:

I was with 'Abdullah and Abu Musa; the latter asked the former, "O Abu AbdurRahman! What is your opinion if somebody becomes Junub and no water is available?" 'Abdullah replied, "Do not pray till water is found." Abu Musa said, "What do you say about the statement of 'Ammar (who was ordered by the Prophet to perform Tayammum). The Prophet said to him: "Perform Tayammum and that would be sufficient." 'Abdullah replied, "Don't you see that 'Umar was not satisfied by 'Ammar's statement?" Abu- Musa said, "All right, leave 'Ammalr's statement, but what will you say about this verse (of Tayammum)?" 'Abqiullah kept quiet and then said, "If we allowed it, then they would probably perform Tayammum even if water was available, if one of them found it (water) cold." The narrator added, "I said to Shaqrq, "Then did 'Abdullah dislike to perform Tayammum because of this?" He replied, "Yes."


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.343]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 343

Narrated Al-A'mash:

Shaqiq said, "While I was sitting with 'Abdullah and Abu Musa Al-Ash-'ari, the latter asked the former, 'If a person becomes Junub and does not find water for one month, can he perform Tayammum and offer his prayer?' (He applied in the negative). Abu Musa said, 'What do you say about this verse from Surat "Al-Ma'ida": When you do not find water then perform Tayammum with clean earth? 'Abdullah replied, 'If we allowed it then they would probably perform Tayammum with clean earth even if water were available but cold.' I said to Shaqiq, 'You then disliked to perform Tayammum because of this?' Shaqiq said,'Yes.' (Shaqiq added), "Abu Musa said, 'Haven't you heard the statement of 'Ammar to 'Umar? He said: I was sent out by Allah's Apostle for some job and I became Junub and could not find water so I rolled myself over the dust (clean earth) like an animal does, and when I told the Prophet of that he said, 'Like this would have been sufficient.' The Prophet (saying so) lightly stroked the earth with his hand once and blew it off, then passed his (left) hand over the back of his right hand or his (right) hand over the back of his left hand and then passed them over his face.' So 'Abdullah said to Abu- Musa, 'Don't you know that 'Umar was not satisfied with 'Ammar's statement?' "

Narrated Shaqiq: While I was with 'Abdullah and Abu Musa, the latter said to the former, "Haven't you heard the statement of 'Ammar to 'Umar? He said, "Allah's Apostle sent you and me out and I became Junub and rolled myself in the dust (clean earth) (for Tayammum). When we came to Allah's Apostle I told him about it and he said, 'This would have been sufficient,' passing his hands over his face and the backs of his hands once only.' "


Bukhari :: Rubbing hands and feet with dust (Tayammum) :: [1.7.344]

Rubbing hands and feet with dust (Tayammum)

Bukhari :: Book 1 :: Volume 7 :: Hadith 344

Narrated 'Imran bin Husain Al-Khuza'i:

Allah's Apostle saw a person sitting aloof and not praying with the people. He asked him, "O so and so! What prevented you from offering the prayer with the people?" He replied, "O Allah's Apostle! I am Junub and there is no water." The Prophet said, "Perform Tayammum with clean earth and that will be sufficient for you."


Bukhari :: Prayers (Salat) :: [1.8.345]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 345

Narrated Abu Dhar:

Allah's Apostle said, "While I was at Mecca the roof of my house was opened and Gabriel descended, opened my chest, and washed it with Zam-zam water. Then he brought a golden tray full of wisdom and faith and having poured its contents into my chest, he closed it. Then he took my hand and ascended with me to the nearest heaven, when I reached the nearest heaven, Gabriel said to the gatekeeper of the heaven, 'Open (the gate).' The gatekeeper asked, 'Who is it?' Gabriel answered: 'Gabriel.' He asked, 'Is there anyone with you?' Gabriel replied, 'Yes, Muhammad I is with me.' He asked, 'Has he been called?' Gabriel said, 'Yes.' So the gate was opened and we went over the nearest heaven and there we saw a man sitting with some people on his right and some on his left. When he looked towards his right, he laughed and when he looked toward his left he wept. Then he said, 'Welcome! O pious Prophet and pious son.' I asked Gabriel, 'Who is he?' He replied, 'He is Adam and the people on his right and left are the souls of his offspring. Those on his right are the people of Paradise and those on his left are the people of Hell and when he looks towards his right he laughs and when he looks towards his left he weeps.'

Then he ascended with me till he reached the second heaven and he (Gabriel) said to its gatekeeper, 'Open (the gate).' The gatekeeper said to him the same as the gatekeeper of the first heaven had said and he opened the gate. Anas said: "Abu Dhar added that the Prophet met Adam, Idris, Moses, Jesus and Abraham, he (Abu Dhar) did not mention on which heaven they were but he mentioned that he (the Prophet ) met Adarn on the nearest heaven and Abraham on the sixth heaven. Anas said, "When Gabriel along with the Prophet passed by Idris, the latter said, 'Welcome! O pious Prophet and pious brother.' The Prophet asked, 'Who is he?' Gabriel replied, 'He is Idris." The Prophet added, "I passed by Moses and he said, 'Welcome! O pious Prophet and pious brother.' I asked Gabriel, 'Who is he?' Gabriel replied, 'He is Moses.' Then I passed by Jesus and he said, 'Welcome! O pious brother and pious Prophet.' I asked, 'Who is he?' Gabriel replied, 'He is Jesus.

Then I passed by Abraham and he said, 'Welcome! O pious Prophet and pious son.' I asked Gabriel, 'Who is he?' Gabriel replied, 'He is Abraham. The Prophet added, 'Then Gabriel ascended with me to a place where I heard the creaking of the pens." Ibn Hazm and Anas bin Malik said: The Prophet said, "Then Allah enjoined fifty prayers on my followers when I returned with this order of Allah, I passed by Moses who asked me, 'What has Allah enjoined on your followers?' I replied, 'He has enjoined fifty prayers on them.' Moses said, 'Go back to your Lord (and appeal for reduction) for your followers will not be able to bear it.' (So I went back to Allah and requested for reduction) and He reduced it to half. When I passed by Moses again and informed him about it, he said, 'Go back to your Lord as your followers will not be able to bear it.' So I returned to Allah and requested for further reduction and half of it was reduced. I again passed by Moses and he said to me: 'Return to your Lord, for your followers will not be able to bear it. So I returned to Allah and He said, 'These are five prayers and they are all (equal to) fifty (in reward) for My Word does not change.' I returned to Moses and he told me to go back once again. I replied, 'Now I feel shy of asking my Lord again.' Then Gabriel took me till we '' reached Sidrat-il-Muntaha (Lote tree of; the utmost boundry) which was shrouded in colors, indescribable. Then I was admitted into Paradise where I found small (tents or) walls (made) of pearls and its earth was of musk."


Bukhari :: Prayers (Salat) :: [1.8.346]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 346

Narrated 'Aisha:

the mother of believers: Allah enjoined the prayer when He enjoined it, it was two Rakat only (in every prayer) both when in residence or on journey. Then the prayers offered on journey remained the same, but (the Rakat of) the prayers for non-travellers were increased.


Bukhari :: Prayers (Salat) :: [1.8.347]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 347

Narrated Um 'Atiya:

We were ordered to bring out our menstruating women and veiled women in the religious gatherings and invocation of Muslims on the two 'Id festivals. These menstruating women were to keep away from their Musalla. A woman asked, "O Allah's Apostle ' What about one who does not have a veil?" He said, "Let her share the veil of her companion."


Bukhari :: Prayers (Salat) :: [1.8.348]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 348

Narrated Muhammad bin Al-Munkadir:

Once Jabir prayed with his Izar tied to his back while his clothes were Lying beside him on a wooden peg. Somebody asked him, "Do you offer your prayer in a single Izar?" He replied, "I did so to show it to a fool like you. Had anyone of us two garments in the life-time of the Prophet?"


Bukhari :: Prayers (Salat) :: [1.8.349]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 349

Narrated Muhammad bin Al Munkadir:

I saw Jabir bin 'Abdullah praying in a single garment and he said that he had seen the Prophet praying in a single garment.


Bukhari :: Prayers (Salat) :: [1.8.350]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 350

Narrated 'Umar bin Abi Salama:

The Prophet prayed in one garment and crossed its ends.


Bukhari :: Prayers (Salat) :: [1.8.351]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 351

Narrated 'Umar bin Abi Salama:

I saw the Prophet offering prayers in a single garment in the house of Um-Salama and he had crossed its ends around his shoulders.


Bukhari :: Prayers (Salat) :: [1.8.352]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 352

Narrated 'Umar bin Abi Salama:

In the house of Um-Salama I saw Allah's Apostle offering prayers, wrapped in a single garment around his body with its ends crossed round his shoulders.


Bukhari :: Prayers (Salat) :: [1.8.353]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 353

Narrated Abu Murra:

(the freed slave of Um Hani) Um Hani, the daughter of Abi Talib said, "I went to Allah's Apostle in the year of the conquest of Mecca and found him taking a bath and his daughter Fatima was screening him. I greeted him. He asked, 'Who is she?' I replied, 'I am Um Hani bint Abi Talib.' He said, 'Welcome! O Um Hani.' When he finished his bath he stood up and prayed eight Rak at while wearing a single garment wrapped round his body and when he finished I said, 'O Allah's Apostle ! My brother has told me that he will kill a person whom I gave shelter and that person is so and so the son of Hubaira.' The Prophet said, 'We shelter the person whom you have sheltered.' " Um Ham added, "And that was before noon (Duha)."


Bukhari :: Prayers (Salat) :: [1.8.354]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 354

Narrated Abu Huraira:

A person asked Allah's Apostle about the offering of the prayer in a single garment. Allah's Apostle replied, "Has every one of you got two garments?"


Bukhari :: Prayers (Salat) :: [1.8.355]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 355

Narrated Abu Huraira:

The Prophet said, "None of you should offer prayer in a single garment that does not cover the shoulders."


Bukhari :: Prayers (Salat) :: [1.8.356]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 356

Narrated Abu Huraira:

Allah's Apostle said, "Whoever prays in a single garment must cross its ends (over the shoulders)."


Bukhari :: Prayers (Salat) :: [1.8.357]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 357

Narrated Said bin Al-Harith:

I asked Jabir bin 'Abdullah about praying in a single garment. He said, "I travelled with the Prophet during some of his journeys, and I came to him at night for some purpose and I found him praying. At that time, I was wearing a single garment with which I covered my shoulders and prayed by his side. When he finished the prayer, he asked, 'O Jabir! What has brought you here?' I told him what I wanted. When I finished, he asked, 'O Jabir! What is this garment which I have seen and with which you covered your shoulders?' I replied, 'It is a (tight) garment.' He said, 'If the garment is large enough, wrap it round the body (covering the shoulders) and if it is tight (too short) then use it as an Izar (tie it around your waist only.)' "


Bukhari :: Prayers (Salat) :: [1.8.358]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 358

Narrated Sahl:

The men used to pray with the Prophet with their Izars tied around their necks as boys used to do; therefore the Prophet told the women not to raise their heads till the men sat down straight (while praying).


Bukhari :: Prayers (Salat) :: [1.8.359]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 359

Narrated Mughira bin Shu'ba:

Once I was traveling with the Prophet and he said, "O Mughira! take this container of water." I took it and Allah's Apostle went far away till he disappeared. He answered the call of nature and was wearing a Syrian cloak. He tried to take out his hands from its sleeve but it was very tight so he took out his hands from under it. I poured water and he performed ablution like that for prayers and passed his wet hands over his Khuff (leather socks) and then prayed .


Bukhari :: Prayers (Salat) :: [1.8.360]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 360

Narrated Jabir bin 'Abdullah:

While Allah's Apostle was carrying stones (along) with the people of Mecca for (the building of) the Ka'ba wearing an Izar (waist-sheet cover), his uncle Al-'Abbas said to him, "O my nephew! (It would be better) if you take off your Izar and put it over your shoulders underneath the stones." So he took off his Izar and put it over his shoulders, but he fell unconscious and since then he had never been seen naked.


Bukhari :: Prayers (Salat) :: [1.8.361]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 361

Narrated Abu Huraira:

A man stood up and asked the Prophet about praying in a single garment. The Prophet said, "Has every one of you two garments?" A man put a similar question to 'Umar on which he replied, "When Allah makes you wealthier then you should clothe yourself properly during prayers. Otherwise one can pray with an Izar and a Rida' (a sheet covering the upper part of the body.) Izar and a shirt, Izar and a Qaba', trousers and a Rida, trousers and a shirt or trousers and a Qaba', Tubban and a Qaba' or Tubban and a shirt." (The narrator added, "I think that he also said a Tubban and a Rida. ")


Bukhari :: Prayers (Salat) :: [1.8.362]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 362

Narrated Ibn 'Umar:

A person asked Allah's Apostle, "What should a Muhrim wear?" He replied, "He should not wear shirts, trousers, a burnus (a hooded cloak), or clothes which are stained with saffron or Wars (a kind of perfume). Whoever does not find a sandal to wear can wear Khuffs, but these should be cut short so as not to cover the ankles.


Bukhari :: Prayers (Salat) :: [1.8.363]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 363

Narrated Abu Said Al-Khudri

Allah's Apostle forbade Ishtimal-As-Samma' (wrapping one's body with a garment so that one cannot raise its end or take one's hand out of it). He also forbade Al-Ihtiba' (sitting on buttocks with knees close to abdomen and feet apart with the hands circling the knees) while wrapping oneself with a single garment, without having a part of it over the private parts.


Bukhari :: Prayers (Salat) :: [1.8.364]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 364

Narrated Abu Huraira:

The Prophet forbade two kinds of sales i.e. Al-Limais and An-Nibadh (the former is a kind of sale in which the deal is completed if the buyer touches a thing, without seeing or checking it properly and the latter is a kind of a sale in which the deal is completed when the seller throws a thing towards the buyer giving him no opportunity to see, touch or check it) and (the Prophet forbade) also Ishtimal-As-Samma' and Al-Ihtiba' in a single garment.


Bukhari :: Prayers (Salat) :: [1.8.365]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 365

Narrated Abu Huraira:

On the Day of Nahr (10th of Dhul-Hijja, in the year prior to the last Hajj of the Prophet when Abu Bakr was the leader of the pilgrims in that Hajj) Abu Bakr sent me along with other announcers to Mina to make a public announcement: "No pagan is allowed to perform Hajj after this year and no naked person is allowed to perform the Tawaf around the Ka'ba. Then Allah's Apostle sent 'All to read out the Surat Bara'a (At-Tauba) to the people; so he made the announcement along with us on the day of Nahr in Mina: "No pagan is allowed to perform Hajj after this year and no naked person is allowed to perform the Tawaf around the Ka'ba."


Bukhari :: Prayers (Salat) :: [1.8.366]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 366

Narrated Muhammad bin Al-Munkadir:

I went to Jabir bin 'Abdullah and he was praying wrapped in a garment and his Rida was Lying beside him. When he finished the prayers, I said "O 'Abdullah! You pray (in a single garment) while your Rida' is lying beside you." He replied, "Yes, I did it intentionally so that the ignorant ones like you might see me. I saw the Prophet praying like this. "


Bukhari :: Prayers (Salat) :: [1.8.367]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 367

Narrated 'Abdul 'Aziz:

Anas said, 'When Allah's Apostle invaded Khaibar, we offered the Fajr prayer there yearly in the morning) when it was still dark. The Prophet rode and Abu Talha rode too and I was riding behind Abu Talha. The Prophet passed through the lane of Khaibar quickly and my knee was touching the thigh of the Prophet . He uncovered his thigh and I saw the whiteness of the thigh of the Prophet. When he entered the town, he said, 'Allahu Akbar! Khaibar is ruined. Whenever we approach near a (hostile) nation (to fight) then evil will be the morning of those who have been warned.' He repeated this thrice. The people came out for their jobs and some of them said, 'Muhammad (has come).' (Some of our companions added, "With his army.") We conquered Khaibar, took the captives, and the booty was collected. Dihya came and said, 'O Allah's Prophet! Give me a slave girl from the captives.' The Prophet said, 'Go and take any slave girl.' He took Safiya bint Huyai. A man came to the Prophet and said, 'O Allah's Apostles! You gave Safiya bint Huyai to Dihya and she is the chief mistress of the tribes of Quraiza and An-Nadir and she befits none but you.' So the Prophet said, 'Bring him along with her.' So Dihya came with her and when the Prophet saw her, he said to Dihya, 'Take any slave girl other than her from the captives.' Anas added: The Prophet then manumitted her and married her."

Thabit asked Anas, "O Abu Hamza! What did the Prophet pay her (as Mahr)?" He said, "Her self was her Mahr for he manumitted her and then married her." Anas added, "While on the way, Um Sulaim dressed her for marriage (ceremony) and at night she sent her as a bride to the Prophet . So the Prophet was a bridegroom and he said, 'Whoever has anything (food) should bring it.' He spread out a leather sheet (for the food) and some brought dates and others cooking butter. (I think he (Anas) mentioned As-SawTq). So they prepared a dish of Hais (a kind of meal). And that was Walrma (the marriage banquet) of Allah's Apostle ."


Bukhari :: Prayers (Salat) :: [1.8.368]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 368

Narrated 'Aisha:

Allah's Apostle used to offer the Fajr prayer and some believing women covered with their veiling sheets used to attend the Fajr prayer with him and then they would return to their homes unrecognized .


Bukhari :: Prayers (Salat) :: [1.8.369]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 369

Narrated 'Aisha:

the Prophet prayed in a Khamisa (a square garment) having marks. During the prayer, he looked at its marks. So when he finished the prayer he said, "Take this Khamisa of mine to Abu Jahm and get me his Inbijaniya (a woolen garment without marks) as it (the Khamisa) has diverted my attention from the prayer."


Bukhari :: Prayers (Salat) :: [1.8.370]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 370

Narrated 'Aisha:

The Prophet said, 'I was looking at its (Khamisa's) marks during the prayers and I was afraid that it may put me in trial (by taking away my attention).


Bukhari :: Prayers (Salat) :: [1.8.371]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 371

Narrated Anas:

'Aisha had a Qiram (a thin marked woolen curtain) with which he had screened one side of her home. The Prophet said, "Take away this Qiram of yours, as its pictures are still displayed in front of me during my prayer (i.e. they divert my attention from the prayer)."


Bukhari :: Prayers (Salat) :: [1.8.372]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 372

Narrated 'Uqba bin 'Amir:

The Prophet was given a silken Farruj as a present. He wore it while praying. When he had finished his prayer, he took it off violently as if with a strong aversion to it and said, "It is not the dress of Allah-fearing pious people."


Bukhari :: Prayers (Salat) :: [1.8.373]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 373

Narrated Abu Juhaifa:

I saw Allah's Apostle in a red leather tent and I saw Bilal taking the remaining water with which the Prophet had performed ablution. I saw the people taking the utilized water impatiently and whoever got some of it rubbed it on his body and those who could not get any took the moisture from the others' hands. Then I saw Bilal carrying an 'Anza (a spear-headed stick) which he planted in the ground. The Prophet came out tucking up his red cloak, and led the people in prayer and offered two Rakat (facing the Ka'ba) taking 'Anza as a Sutra for his prayer. I saw the people and animals passing in front of him beyond the 'Anza.


Bukhari :: Prayers (Salat) :: [1.8.374]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 374

Narrated Abu Hazim:

Sahl bin Sa'd was asked about the (Prophet's) pulpit as to what thing it was made of? Sahl replied: "None remains alive amongst the people, who knows about it better than I. It was made of tamarisk (wood) of the forest. So and so, the slave of so and so prepared it for Allah's Apostle . When it was constructed and place (in the Mosque), Allah's Apostle stood on it facing the Qibla and said 'Allahu Akbar', and the people stood behind him (and led the people in prayer). He recited and bowed and the people bowed behind him. Then he raised his head and stepped back, got down and prostrated on the ground and then he again ascended the pulpit, recited, bowed, raised his head and stepped back, got down and prostrate on the ground. So, this is what I know about the pulpit."

Ahmad bin Hanbal said, "As the Prophet was at a higher level than the people, there is no harm according to the above-mentioned Hadith if the Imam is at a higher level than his followers during the prayers."


Bukhari :: Prayers (Salat) :: [1.8.375]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 375

Narrated Anas bin Malik:

Once Allah's Apostle fell off a horse and his leg or shoulder got injured. He swore that he would not go to his wives for one month and he stayed in a Mashruba (attic room) having stairs made of date palm trunks. So his companions came to visit him, and he led them in prayer sitting, whereas his companions were standing. When he finished the prayer, he said, "Imam is meant to be followed, so when he says 'Allahu Akbar,' say 'Allahu Akbar' and when he bows, bow and when he prostrates, prostrate and if he prays standing pray, standing. After the 29th day the Prophet came down (from the attic room) and the people asked him, "O Allah's Apostle! You swore that you will not go to your wives for one month." He said, "The month is 29 days."


Bukhari :: Prayers (Salat) :: [1.8.376]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 376

Narrates 'Abdullah bin Shaddad:

Maimuna said, "Allah's Apostle was praying while I was in my menses, sitting beside him and sometimes his clothes would touch me during his prostration." Maimuna added, "He prayed on a Khumra (a small mat sufficient just for the face and the hands while prostrating during prayers).


Bukhari :: Prayers (Salat) :: [1.8.377]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 377

Narrated Ishaq:

Anas bin Malik said, "My grand-mother Mulaika invited Allah's Apostle for a meal which she herself had prepared. He ate from it and said, 'Get up! I will lead you in the prayer.' " Anas added, "I took my Hasir, washed it with water as it had become dark because of long use and Allah's Apostle stood on it. The orphan (Damira or Ruh) and I aligned behind him and the old lady (Mulaika) stood behind us. Allah's Apostle led us in the prayer and offered two Rak'at and then left."


Bukhari :: Prayers (Salat) :: [1.8.378]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 378

Narrated Maimuna:

Allah's Apostle used to pray on Khumra.


Bukhari :: Prayers (Salat) :: [1.8.379]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 379

Narrated Abu Salama:

'Aisha the wife of the Prophet said, "I used to sleep in front of Allah's Apostle and my legs were opposite his Qibla and in prostration he pushed my legs and I withdrew then and when he stood, I stretched them.' 'Aisha added, "In those days the houses were without lights."


Bukhari :: Prayers (Salat) :: [1.8.380]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 380

Narrated 'Aisha:

Allah Apostle prayed while I was lying like a dead body on his family bed between him and his Qibla.


Bukhari :: Prayers (Salat) :: [1.8.381]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 381

Narrated 'Urwa:

The Prophet prayed while 'Aisha was lying between him and his Qibla on the bed on which they used to sleep.


Bukhari :: Prayers (Salat) :: [1.8.382]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 382

Narrated Anas bin Malik:

We used to pray with the Prophet and some of us used to place the ends of their clothes at the place of prostration because of scorching heat.


Bukhari :: Prayers (Salat) :: [1.8.383]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 383

Narrated Abu Maslama:

Said bin Yazid Al-Azdi: I asked Anas bin Malik whether the Prophet had ever, prayed with his shoes on. He replied "Yes."


Bukhari :: Prayers (Salat) :: [1.8.384]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 384

Narrated Ibrahim:

Hammam bin Al-Harith said, "I saw Jarir bin 'Abdullah urinating. Then he performed ablution and passed his (wet) hands over his Khuffs, stood up and prayed. He was asked about it. He replied that he had seen the Prophet doing the same." They approved of this narration as Jarir was one of those who embraced Islam very late.


Bukhari :: Prayers (Salat) :: [1.8.385]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 385

Narrated 'Abdullah bin Malik:

Ibn Buhaina, "When the Prophet prayed, he used to separate his arms from his body so widely that the whiteness of his armpits was visible."


Bukhari :: Prayers (Salat) :: [1.8.386]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 386

Narrated Anas bin Malik:

Allah's Apostle said, "Whoever prays like us and faces our Quibla and eats our slaughtered animals is a Muslim and is under Allah's and His Apostle's protection. So do not betray Allah by betraying those who are in His protection."


Bukhari :: Prayers (Salat) :: [1.8.387]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 387

Narrated Anas bin Malik:

Allah's Apostle said, "I have been ordered to fight the people till they say: 'None has the right to be worshipped but Allah.' And if they say so, pray like our prayers, face our Qibla and slaughter as we slaughter, then their blood and property will be sacred to us and we will not interfere with them except legally and their reckoning will be with Allah." Narrated Maimun ibn Siyah that he asked Anas bin Malik, "O Abu Hamza! What makes the life and property of a person sacred?" He replied, "Whoever says, 'None has the right to be worshipped but Allah', faces our Qibla during the prayers, prays like us and eats our slaughtered animal, then he is a Muslim, and has got the same rights and obligations as other Muslims have."


Bukhari :: Prayers (Salat) :: [1.8.388]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 388

Narrated Abu Aiyub Al-Ansari:

The Prophet said, "While defecating, neither face nor turn your back to the Qibla but face either east or west." Abu Aiyub added. "When we arrived in Sham we came across some lavatories facing the Qibla; therefore we turned ourselves while using them and asked for Allah's forgiveness."


Bukhari :: Prayers (Salat) :: [1.8.389]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 389

Narrated 'Amr bin Dmar:

I asked Ibn 'Umar, "Can a person who has performed the Tawaf around the Ka'ba for 'Umra but has not performed the (Sa'i) Tawaf of Safa and Marwa, have a sexual relation with his wife?" Ibn 'Umar replied "When the Prophet reached Mecca he performed the Tawaf around the Ka'ba (circumambulated it seven times) and offered a two-Rak'at prayer (at the place) behind the station (of Abraham) and then performed the Tawaf (Sa'i) of Safa and Marwa, and verily in Allah's Apostle you have a good example." Then we put the same question to Jabir bin 'Abdullah and he too replied, "He should not go near his wife (for sexual relation) till he has finished the Tawaf of Safa and Marwa."


Bukhari :: Prayers (Salat) :: [1.8.390]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 390

Narrated Mujahid:

Someone came to Ibn 'Umar and said, "Here is Allah's Apostle entering the Ka'ba." Ibn 'Umar said, "I went there but the Prophet had come out of the Ka'ba and I found Bilal standing between its two doors. I asked Bilal, 'Did the Prophet pray in the Ka'ba?' Bilal replied, 'Yes, he prayed two Rakat between the two pillars which are to your left on entering the Ka'ba. Then Allah's Apostle came out and offered a two-Rak'at prayer facing the Ka'ba.' "


Bukhari :: Prayers (Salat) :: [1.8.391]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 391

Narrated Ibn Abbas:

When the Prophet entered the Ka'ba, he invoked Allah in each and every side of it and did not pray till he came out of it, and offered a two-Rak'at prayer facing the Ka'ba and said, "This is the Qibla."


Bukhari :: Prayers (Salat) :: [1.8.392]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 392

Narrated Bara' bin 'Azib:

Allah's Apostle prayed facing Baitul-Maqdis for sixteen or seventeen months but he loved to face the Ka'ba (at Mecca) so Allah revealed: "Verily, We have seen the turning of your face to the heaven!" (2:144) So the Prophet faced the Ka'ba and the fools amongst the people namely "the Jews" said, "What has turned them from their Qibla (Bait-ul-Maqdis) which they formerly observed"" (Allah revealed): "Say: 'To Allah belongs the East and the West. He guides whom he will to a straight path'." (2:142) A man prayed with the Prophet (facing the Ka'ba) and went out. He saw some of the Ansar praying the 'Asr prayer with their faces towards Bait-ul-Maqdis, he said, "I bear witness that I prayed with Allah's Apostle facing the Ka'ba." So all the people turned their faces towards the Ka'ba.


Bukhari :: Prayers (Salat) :: [1.8.393]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 393

Narrated Jabir:

Allah's Apostle used to pray (optional, non-obligatory prayer) while riding on his mount (Rahila) wherever it turned, and whenever he wanted to pray the compulsory prayer he dismounted and prayed facing the Qibla.


Bukhari :: Prayers (Salat) :: [1.8.394]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 394

Narrated 'Abdullah:

The Prophet prayed (and the subnarrator Ibrahim said, "I do not know whether he prayed more or less than usual"), and when he had finished the prayers he was asked, "O Allah's Apostle! Has there been any change in the prayers?" He said, "What is it?' The people said, "You have prayed so much and so much." So the Prophet bent his legs, faced the Qibla and performed two prostrations (of Sahu) and finished his prayers with Tasiim (by turning his face to right and left saying: 'As-Salamu'Alaikum-Warahmat-ullah'). When he turned his face to us he said, "If there had been anything changed in the prayer, surely I would have informed you but I am a human being like you and liable to forget like you. So if I forget remind me and if anyone of you is doubtful about his prayer, he should follow what he thinks to be correct and complete his prayer accordingly and finish it and do two prostrations (of Sahu)."


Bukhari :: Prayers (Salat) :: [1.8.395]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 395

Narrated 'Umar (bin Al-Khattab):

My Lord agreed with me in three things:

1. I said,"O Allah's Apostle, I wish we took the station of Abraham as our praying place (for some of our prayers). So came the Divine Inspiration: And take you (people) the station of Abraham as a place of prayer (for some of your prayers e.g. two Rakat of Tawaf of Ka'ba)". (2.125)

2. And as regards the (verse of) the veiling of the women, I said, 'O Allah's Apostle! I wish you ordered your wives to cover themselves from the men because good and bad ones talk to them.' So the verse of the veiling of the women was revealed.

3. Once the wives of the Prophet made a united front against the Prophet and I said to them, 'It may be if he (the Prophet) divorced you, (all) that his Lord (Allah) will give him instead of you wives better than you.' So this verse (the same as I had said) was revealed." (66.5).


Bukhari :: Prayers (Salat) :: [1.8.396]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 396

Narrated Anas:

as above (395).


Bukhari :: Prayers (Salat) :: [1.8.397]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 397

Narrated 'Abdullah bin 'Umar:

While the people were offering the Fajr prayer at Quba (near Medina), someone came to them and said: "It has been revealed to Allah's Apostle tonight, and he has been ordered to pray facing the Ka'ba." So turn your faces to the Ka'ba. Those people were facing Sham (Jerusalem) so they turned their faces towards Ka'ba (at Mecca).


Bukhari :: Prayers (Salat) :: [1.8.398]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 398

Narrated 'Abdullah:

"Once the Prophet offered five Rakat in Zuhr prayer. He was asked, "Is there an increase in the prayer?" The Prophet said, "And what is it?" They said, "You have prayed five Rakat.' So he bent his legs and performed two prostrations (of Sahu).


Bukhari :: Prayers (Salat) :: [1.8.399]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 399

Narrated Anas bin Malik:

The Prophet saw some sputum in the direction of the Qibla (on the wall of the mosque) and he disliked that and the sign of disgust was apparent from his face. So he got up and scraped it off with his hand and said, "Whenever anyone of you stands for the prayer, he is speaking in private to his Lord or his Lord is between him and his Qibla. So, none of you should spit in the direction of the Qibla but one can spit to the left or under his foot." The Prophet then took the corner of his sheet and spat in it and folded it and said, "Or you can do like this. "


Bukhari :: Prayers (Salat) :: [1.8.400]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 400

Narrated 'Abdullah bin 'Umar: Allah's Apostle saw sputum on the wall of the mosque in the direction of the Qibla and scraped it off. He faced the people and said, "Whenever any one of you is praying, he should not spit in front of him because in the prayer Allah is in front of him."


Bukhari :: Prayers (Salat) :: [1.8.401]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 401

Narrated 'Aisha:

(the mother of faithful believers) Allah's Apostle saw some nasal secretions, expectoration or sputum on the wall of the mosque in the direction of the Qibla and scraped it off.


Bukhari :: Prayers (Salat) :: [1.8.402]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 402

Narrated Abd Huraira and Abu Said:

Allah's Apostle saw some expectoration on the wall of the mosque; he took gravel and scraped it off and said, "If anyone of you wanted to spit he should neither spit in front of him nor on his right but he could spit either on his left or under his left foot."


Bukhari :: Prayers (Salat) :: [1.8.403]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 403

Narrated Abd Huraira and Abu Sa'id:

Allah's Apostle saw some expectoration on the wall of the mosque; he took gravel and scraped it off and said, "If anyone of you wanted to spit, he should neither spit in front of him nor on his right but could spit either on his left or under his left foot."


Bukhari :: Prayers (Salat) :: [1.8.404]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 404

Narrated Anas:

The Prophet said, "None of you should spit in front or on his right but he could spit either on his left or under his foot."


Bukhari :: Prayers (Salat) :: [1.8.405]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 405

Narrated Anas bin Malik:

The Prophet said, "A faithful believer while in prayer is speaking in private to his Lord, so he should neither spit in front of him nor to his right side but he could spit either on his left or under his foot."


Bukhari :: Prayers (Salat) :: [1.8.406]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 406

Narrated Abu Said:

The Prophet saw sputum on (the wall of) the mosque in the direction of the Qibla and scraped it off with gravel. Then he forbade Spitting in front or on the right, but allowed it on one's left or under one's left foot.


Bukhari :: Prayers (Salat) :: [1.8.407]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 407

Narrated Anas bin Malik:

The Prophet said, "Spitting in the mosque is a sin and its expiation is to bury it."


Bukhari :: Prayers (Salat) :: [1.8.408]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 408

Narrated Abu Huraira:

Prophet said, "If anyone of you stands for prayer, he should not spit in front of him because in prayer he is speaking in private to Allah and he should not spit on his right as there is an angel, but he can spit either on his left or under his left foot and bury it (i.e. expectoration)."


Bukhari :: Prayers (Salat) :: [1.8.409]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 409

Narrated Anas:

The Prophet saw expectoration (on the wall of the mosque) in the direction of the Qibla and scraped it off with his hand. It seemed that he disliked it and the sign of disgust was apparent from his face. He said, "If anyone of you stands for the prayer, he is speaking in private to his Lord, (or) his Lord is between him and his Qibla, therefore he should not spit towards his Qibla, but he could spit either on his left or under his foot." Then he took the corner of his sheet and spat in it, folded it and said, "Or do like this."


Bukhari :: Prayers (Salat) :: [1.8.410]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 410

Narrated Abu Huraira:

Allah's Apostle said, "Do you consider or see that my face is towards the Qibla? By Allah, neither your submissiveness nor your bowing is hidden from me, surely I see you from my back."


Bukhari :: Prayers (Salat) :: [1.8.411]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 411

Narrated Anas bin Malik:

The Prophet led us in a prayer and then got up on the pulpit and said, "In your prayer and bowing, I certainly see you from my back as I see you (while looking at you.)"


Bukhari :: Prayers (Salat) :: [1.8.412]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 412

Narrated 'Abdullah bin 'Umar:

Allah's Apostle ordered for a horse race; the trained horses were to run from a place called Al-Hafya' to Thaniyat Al-Wada' and the horses which were not trained were to run from Al-Thaniya to the Masjid (mosque of) Bani Zuraiq. The sub narrator added: Ibn Umar was one of those who took part in the race.


Bukhari :: Prayers (Salat) :: [1.8.413]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 413

Narrated Anas:

Some goods came to Allah's Apostle from Bahrain. The Prophet ordered the people to spread them in the mosque --it was the biggest amount of goods Allah's Apostle had ever received. He left for prayer and did not even look at it. After finishing the prayer, he sat by those goods and gave from those to everybody he saw. Al-'Abbas came to him and said, "O Allah's Apostle! give me (something) too, because I gave ransom for myself and 'Aqil" Allah's Apostle told him to take. So he stuffed his garment with it and tried to carry it away but he failed to do so. He said, "O Allah's Apostle! Order someone to help me in lifting it." The Prophet refused. He then said to the Prophet: Will you please help me to lift it?" Allah's Apostle refused. Then Al-'Abbas threw some of it and tried to lift it (but failed). He again said, "O Allah's Apostle Order someone to help me to lift it." He refused. Al-'Abbas then said to the Prophet: "Will you please help me to lift it?" He again refused. Then Al-'Abbas threw some of it, and lifted it on his shoulders and went away. Allah's Apostle kept on watching him till he disappeared from his sight and was astonished at his greediness. Allah's Apostle did not get up till the last coin was distributed.


Bukhari :: Prayers (Salat) :: [1.8.414]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 414

Narrated Anas:

I found the Prophet in the mosque along with some people. He said to me, "Did Abu Talha send you?" I said, "Yes". He said, "For a meal?" I said, "Yes." Then he said to his companions, "Get up." They set out and I was ahead of them.


Bukhari :: Prayers (Salat) :: [1.8.415]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 415

Narrated Sahl bin Sa'd:

A man said, "O Allah's Apostle! If a man finds another man with his wife, (committing adultery) should the husband kill him?" Later on I saw them (the man and his wife) doing Lian in the mosque.


Bukhari :: Prayers (Salat) :: [1.8.416]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 416

Narrated 'Itban bin Malik:

The Prophet came to my house and said, "Where do you like me to pray?" I pointed to a place. The Prophet then said, "Allahu Akbar", and we aligned behind him and he offered a two-Rak'at prayer.


Bukhari :: Prayers (Salat) :: [1.8.417]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 417

Narrated 'Itban bin Malik:

who was one of the companions of Allah's Apostle and one of the Ansar's who took part in the battle of Badr: I came to Allah's Apostle and said, "O Allah's Apostle I have weak eyesight and I lead my people in prayers. When it rains the water flows in the valley between me and my people so I cannot go to their mosque to lead them in prayer. O Allah's Apostle! I wish you would come to my house and pray in it so that I could take that place as a Musalla. Allah's Apostle said. "Allah willing, I will do so." Next day after the sun rose high, Allah's Apostle and Abu Bakr came and Allah's Apostle asked for permission to enter. I gave him permission and he did not sit on entering the house but said to me, "Where do you like me to pray?" I pointed to a place in my house. So Allah's Apostle stood there and said, 'Allahu Akbar', and we all got up and aligned behind him and offered a two-Rak'at prayer and ended it with Taslim. We requested him to stay for a meal called "Khazira" which we had prepared for him. Many members of our family gathered in the house and one of them said, "Where is Malik bin Al-Dukhaishin or Ibn Al-Dukhshun?" One of them replied, "He is a hypocrite and does not love Allah and His Apostle." Hearing that, Allah's Apostle said, "Do not say so. Haven't you seen that he said, 'None has the right to be worshipped but Allah' for Allah's sake only?" He said, "Allah and His Apostle know better. We have seen him helping and advising hypocrites."

Allah's Apostle said, "Allah has forbidden the (Hell) fire for those who say, 'None has the right to be worshipped but Allah' for Allah's sake only."


Bukhari :: Prayers (Salat) :: [1.8.418]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 418

Narrated 'Aisha:

The Prophet used to start every thing from the right (for good things) whenever it was possible in all his affairs; for example: in washing, combing or wearing shoes.


Bukhari :: Prayers (Salat) :: [1.8.419]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 419

Narrated 'Aisha:

Um Habiba and Um Salama mentioned about a church they had seen in Ethiopia in which there were pictures. They told the Prophet about it, on which he said, "If any religious man dies amongst those people they would build a place of worship at his grave and make these pictures in it. They will be the worst creature in the sight of Allah on the Day of Resurrection."


Bukhari :: Prayers (Salat) :: [1.8.420]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 420

Narrated Anas:

When the Prophet arrived Medina he dismounted at 'Awali-i-Medina amongst a tribe called Banu 'Amr bin 'Auf. He stayed there For fourteen nights. Then he sent for Bani An-Najjar and they came armed with their swords. As if I am looking (just now) as the Prophet was sitting over his Rahila (Mount) with Abu Bakr riding behind him and all Banu An-Najjar around him till he dismounted at the courtyard of Abu Aiyub's house. The Prophet loved to pray wherever the time for the prayer was due even at sheep-folds. Later on he ordered that a mosque should be built and sent for some people of Banu-An-Najjar and said, "O Banu An-Najjar! Suggest to me the price of this (walled) piece of land of yours." They replied, "No! By Allah! We do not demand its price except from Allah." Anas added: There were graves of pagans in it and some of it was unleveled and there were some date-palm trees in it. The Prophet ordered that the graves of the pagans be dug out and the unleveled land be level led and the date-palm trees be cut down . (So all that was done). They aligned these cut date-palm trees towards the Qibla of the mosque (as a wall) and they also built two stone side-walls (of the mosque). His companions brought the stones while reciting some poetic verses. The Prophet was with them and he kept on saying, "There is no goodness except that of the Hereafter, O Allah! So please forgive the Ansars and the emigrants. "


Bukhari :: Prayers (Salat) :: [1.8.421]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 421

Narrated Abu Al-Taiyah:

Anas said, "The Prophet prayed in the sheep fold." Later on I heard him saying, "He prayed in the sheep folds before the construction of the, mosque."


Bukhari :: Prayers (Salat) :: [1.8.422]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 422

Narrated Nafi:

"I saw Ibn 'Umar praying while taking his camel as a Sutra in front of him and he said, "I saw the Prophet doing the same."


Bukhari :: Prayers (Salat) :: [1.8.423]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 423

Narrated 'Abdullah bin 'Abbas:

The sun eclipsed and Allah's Apostle offered the eclipse prayer and said, "I have been shown the Hellfire (now) and I never saw a worse and horrible sight than the sight I have seen today."


Bukhari :: Prayers (Salat) :: [1.8.424]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 424

Narrated Ibn 'Umar:

The Prophet had said, "Offer some of your prayers (Nawafil) at home, and do not take your houses as graves."


Bukhari :: Prayers (Salat) :: [1.8.425]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 425

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Do not enter (the places) of these people where Allah's punishment had fallen unless you do so weeping. If you do not weep, do not enter (the places of these people) because Allah's curse and punishment which fell upon them may fall upon you."


Bukhari :: Prayers (Salat) :: [1.8.426]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 426

Narrated 'Aisha:

Um Salama told Allah's Apostle about a church which she had seen in Ethiopia and which was called Mariya. She told him about the pictures which she had seen in it. Allah's Apostle said, "If any righteous pious man dies amongst them, they would build a place of worship at his grave and make these pictures in it; they are the worst creatures in the sight of Allah."


Bukhari :: Prayers (Salat) :: [1.8.427]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 427

Narrated 'Aisha and 'Abdullah bin 'Abbas:

When the last moment of the life of Allah's Apostle came he started putting his 'Khamisa' on his face and when he felt hot and short of breath he took it off his face and said, "May Allah curse the Jews and Christians for they built the places of worship at the graves of their Prophets." The Prophet was warning (Muslims) of what those had done.


Bukhari :: Prayers (Salat) :: [1.8.428]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 428

Narrated Abu Huraira:

Allah's Apostle said, "May Allah's curse be on the Jews for they built the places of worship at the graves of their Prophets."


Bukhari :: Prayers (Salat) :: [1.8.429]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 429

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "I have been given five things which were not given to any amongst the Prophets before me. These are:

1. Allah made me victorious by awe (by His frightening my enemies) for a distance of one month's journey.

2. The earth has been made for me (and for my followers) a place for praying and a thing to perform Tayammum. Therefore my followers can pray wherever the time of a prayer is due.

3. The booty has been made Halal (lawful) for me (and was not made so for anyone else).

4. Every Prophet used to be sent to his nation exclusively but I have been sent 1o all mankind.

5. I have been given the right of intercession (on the Day of Resurrection.)


Bukhari :: Prayers (Salat) :: [1.8.430]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 430

Narrated 'Aisha:

There was a black slave girl belonging to an 'Arab tribe and they manumitted her but she remained with them. The slave girl said, "Once one of their girls (of that tribe) came out wearing a red leather scarf decorated with precious stones. It fell from her or she placed it somewhere. A kite passed by that place, saw it Lying there and mistaking it for a piece of meat, flew away with it. Those people searched for it but they did not find it. So they accused me of stealing it and started searching me and even searched my private parts." The slave girl further said, "By Allah! while I was standing (in that state) with those people, the same kite passed by them and dropped the red scarf and it fell amongst them. I told them, 'This is what you accused me of and I was innocent and now this is it.' " 'Aisha added: That slave girl came to Allah's Apostle and embraced Islam. She had a tent or a small room with a low roof in the mosque. Whenever she called on me, she had a talk with me and whenever she sat with me, she would recite the following: "The day of the scarf (band) was one of the wonders of our Lord, verily He rescued me from the disbelievers' town. 'Aisha added: "Once I asked her, 'What is the matter with you? Whenever you sit with me, you always recite these poetic verses.' On that she told me the whole story. "


Bukhari :: Prayers (Salat) :: [1.8.431]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 431

Narrated Naf'a:

'Abdullah bin 'Umar said: I used to sleep in the mosque of the Prophet while I was young and unmarried.


Bukhari :: Prayers (Salat) :: [1.8.432]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 432

Narrated Sahl bin Sa'd:

Allah's Apostle went to Fatima's house but did not find 'Ali there. So he asked, "Where is your cousin?" She replied, "There was something between us and he got angry with me and went out. He did not sleep (mid-day nap) in the house." Allah's Apostle asked a person to look for him. That person came and said, "O Allah's Apostle! He (Ali) is sleeping in the mosque." Allah's Apostle went there and 'Ali was lying. His upper body cover had fallen down to one side of his body and he was covered with dust. Allah's Apostle started cleaning the dust from him saying: "Get up! O Aba Turab. Get up! O Aba Turab (literally means: O father of dust).


Bukhari :: Prayers (Salat) :: [1.8.433]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 433

Narrated Abu Huraira:

I saw seventy of As-Suffa men and none of them had a Rida' (a garment covering the upper part of the body). They had either Izars (only) or sheets which they tied round their necks. Some of these sheets reached the middle of their legs and some reached their heels and they used to gather them with their hands lest their private parts should become naked.


Bukhari :: Prayers (Salat) :: [1.8.434]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 434

Narrated Jabir bin 'Abdullah:

I went to the Prophet in the mosque (the sub-narrator Mas'ar thought that Jabir had said, "In the forenoon.") He ordered me to pray two Rakat. He owed me some money and he repaid it to me and gave more than what was due to me.


Bukhari :: Prayers (Salat) :: [1.8.435]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 435

Narrated Abu Qatada Al-Aslami:

Allah's Apostle said, "If anyone of you enters a mosque, he should pray two Rakat before sitting."


Bukhari :: Prayers (Salat) :: [1.8.436]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 436

Narrated Abu Huraira:

Allah's Apostle said, "The angels keep on asking Allah's forgiveness for anyone of you, as long as he is at his Mu,salla (praying place) and he does not pass wind (Hadath). They say, 'O Allah! Forgive him, O Allah! be Merciful to him."


Bukhari :: Prayers (Salat) :: [1.8.437]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 437

Narrated 'Abdullah bin 'Umar:

In the life-time of Allah's Apostle the mosque was built of adobes, its roof of the leaves of date-palms and its pillars of the stems of date-palms. Abu Bakr did not alter it. 'Umar expanded it on the same pattern as it was in the lifetime of Allah's Apostle by using adobes, leaves of date-palms and changing the pillars into wooden ones. 'Uthman changed it by expanding it to a great extent and built its walls with engraved stones and lime and made its pillars of engraved stones and its roof of teak wood.


Bukhari :: Prayers (Salat) :: [1.8.438]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 438

Narrated 'Ikrima:

Ibn 'Abbas said to me and to his son 'Ali, "Go to Abu Sa'id and listen to what he narrates." So we went and found him in a garden looking after it. He picked up his Rida', wore it and sat down and started narrating till the topic of the construction of the mosque reached. He said, "We were carrying one adobe at a time while 'Ammar was carrying two. The Prophet saw him and started removing the dust from his body and said, "May Allah be Merciful to 'Ammar. He will be inviting them (i.e. his murderers, the rebellious group) to Paradise and they will invite him to Hell-fire." 'Ammar said, "I seek refuge with Allah from affliction."


Bukhari :: Prayers (Salat) :: [1.8.439]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 439

Narrated Sahl:

Allah's Apostle sent someone to a woman telling her to "Order her slave, carpenter, to prepare a wooden pulpit for him to sit on."


Bukhari :: Prayers (Salat) :: [1.8.440]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 440

Narrated Jabir:

A woman said, "O Allah's Apostle! Shall I get something constructed for you to sit on as I have a slave who is a carpenter?" He replied, "Yes, if you like." So she had that pulpit constructed.


Bukhari :: Prayers (Salat) :: [1.8.441]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 441

Narrated 'Ubdaidullah Al-Khaulani:

I heard 'Uthman bin 'Affan saying, when people argued too much about his intention to reconstruct the mosque of Allah's Apostle, "You have talked too much. I heard the Prophet saying, 'Whoever built a mosque, (Bukair thought that 'Asim, another subnarrator, added, "Intending Allah's Pleasure"), Allah would build for him a similar place in Paradise.' "


Bukhari :: Prayers (Salat) :: [1.8.442]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 442

Narrated 'Amr:

I heard Jabir bin 'Abdullah saying, "A man passed through the mosque carrying arrows. Allah's Apostle said to him, 'Hold them by their heads.' "


Bukhari :: Prayers (Salat) :: [1.8.443]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 443

Narrated Abu Burda bin 'Abdulla:

(on the authority of his father) The Prophet said, "Whoever passes through our mosques or markets with arrows should hold them by their heads lest he should injure a Muslim."


Bukhari :: Prayers (Salat) :: [1.8.444]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 444

Narrated Hassan bin Thabit Al-Ansari:

I asked Abu Huraira "By Allah! Tell me the truth whether you heard the Prophet saying, 'O Hassan! Reply on behalf of Allah's Apostle. O Allah! Help him with the Holy Spirit." Abu Huraira said, "Yes . "


Bukhari :: Prayers (Salat) :: [1.8.445]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 445

Narrated 'Aisha:

Once I saw Allah's Apostle at the door of my house while some Ethiopians were playing in the mosque (displaying their skill with spears). Allah's Apostle was screening me with his Rida' so as to enable me to see their display. ('Urwa said that 'Aisha said, "I saw the Prophet and the Ethiopians were playing with their spears.")


Bukhari :: Prayers (Salat) :: [1.8.446]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 446

Narrated 'Aisha:

Barira came to seek my help regarding her manumission. I told herself you like I would pay your price to your masters but your Al-Wala(1) would be for me." Her masters said, "If you like, you can pay what remains (of the price of her manumission), (Sufyan the sub-narrator once said), or if you like you can manumit her, but her (inheritance) Al-Wala would be for us. "When Allah's Apostle came, I spoke to him about it. He said, "Buy her and manumit her. No doubt Al-Wala(1) is for the manumitted." Then Allah's Apostle stood on the pulpit (or Allah's Apostle ascended the pulpit as Sufyan once said), and said, "What about some people who impose conditions which are not present in Allah's Book (Laws)? Whoever imposes conditions which are not in Allah's Book (Laws), his conditions will be invalid even if he imposed them a hundred times."


Bukhari :: Prayers (Salat) :: [1.8.447]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 447

Narrated Ka'b:

In the mosque l asked Ibn Abi Hadrad to pay the debts which he owed to me and our voices grew louder. Allah's Apostle heard that while he was in his house. So he came to us raising the curtain of his room and said, "O Ka'b!" I replied, "Labaik, O Allah's Apostle!" He said, "O Ka'b! reduce your debt to one half," gesturing with his hand. I said, "O Allah's Apostle! I have done so." Then Allah's Apostle said (to Ibn Abi Hadrad), "Get up and pay the debt to him."


Bukhari :: Prayers (Salat) :: [1.8.448]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 448

Narrated Abu Huraira:

A black man or a black woman used to sweep the mosque and he or she died. The Prophet asked about her (or him). He was told that she (or he) had died. He said, "Why did you not inform me? Show me his grave (or her grave)." So he went to her (his) grave and offered her (his) funeral prayer."


Bukhari :: Prayers (Salat) :: [1.8.449]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 449

Narrated 'Aisha:

When the verses of Surat "Al-Baqara"' about the usury Riba were revealed, the Prophet went to the mosque and recited them in front of the people and then banned the trade of alcohol.


Bukhari :: Prayers (Salat) :: [1.8.450]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 450

Narrated Abu Huraira:

"The Prophet said, "Last night a big demon (afreet) from the Jinns came to me and wanted to interrupt my prayers (or said something similar) but Allah enabled me to overpower him. I wanted to fasten him to one of the pillars of the mosque so that all of you could See him in the morning but I remembered the statement of my brother Solomon (as stated in Quran): My Lord! Forgive me and bestow on me a kingdom such as shall not belong to anybody after me (38.35)." The sub narrator Rauh said, "He (the demon) was dismissed humiliated."


Bukhari :: Prayers (Salat) :: [1.8.451]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 451

Narrated Abu Huraira:

The Prophet sent some horsemen to Najd and they brought a man called Thumama bin Uthal from Bani Hanifa. They fastened him to one of the pillars of the mosque. The Prophet came and ordered them to release him. He went to a (garden of) date-palms near the mosque, took a bath and entered the, mosque again and said, "None has the right to be worshipped but Allah an Muhammad is His Apostle (i.e. he embraced Islam)."


Bukhari :: Prayers (Salat) :: [1.8.452]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 452

Narrated 'Aisha:

On the day of Al-Khandaq (battle of the Trench' the medial arm vein of Sa'd bin Mu'ad was injured and the Prophet pitched a tent in the mosque to look after him. There was another tent for Banu Ghaffar in the mosque and the blood started flowing from Sa'd's tent to the tent of Bani Ghaffar. They shouted, "O occupants of the tent! What is coming from you to us?" They found that Sa'd' wound was bleeding profusely and Sa'd died in his tent.


Bukhari :: Prayers (Salat) :: [1.8.453]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 453

Narrated Um Salama:

I complained to Allah's Apostle that I was sick. He told me to perform the Tawaf behind the people while riding. So I did so and Allah's Apostle was praying beside the Ka'ba and reciting the Sura starting with "Wat-tur-wa-Kitabinmastur."


Bukhari :: Prayers (Salat) :: [1.8.454]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 454

Narrated Anas bin Malik:

Two of the companions of the Prophet departed from him on a dark night and were led by two lights like lamps (going in front of them from Allah as a miracle) lighting the way in front of them, and when they parted, each of them was accompanied by one of these lights till he reached their (respective) houses.


Bukhari :: Prayers (Salat) :: [1.8.455]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 455

Narrated Abu Said Al-Khudri:

The Prophet delivered a sermon and said, "Allah gave a choice to one of (His) slaves either to choose this world or what is with Him in the Hereafter. He chose the latter." Abu Bakr wept. I said lo myself, "Why is this Sheikh weeping, if Allah gave choice to one (of His) slaves either to choose this world or what is with Him in the Here after and he chose the latter?" And that slave was Allah's Apostle himself. Abu Bakr knew more than us. The Prophet said, "O Abu Bakr! Don't weep. The Prophet added: Abu- Bakr has favored me much with his property and company. If I were to take a Khalil from mankind I would certainly have taken Abu Bakr but the Islamic brotherhood and friendship is sufficient. Close all the gates in the mosque except that of Abu Bakr.


Bukhari :: Prayers (Salat) :: [1.8.456]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 456

Narrated Ibn 'Abbas:

"Allah's Apostle in his fatal illness came out with a piece of cloth tied round his head and sat on the pulpit. After thanking and praising Allah he said, "There is no one who had done more favor to me with life and property than Abu Bakr bin Abi Quhafa. If I were to take a Khalil, I would certainly have taken Abu- Bakr but the Islamic brotherhood is superior. Close all the small doors in this mosque except that of Abu Bakr."


Bukhari :: Prayers (Salat) :: [1.8.457]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 457

Narrated Nafi:

Ibn 'Umar said, "The Prophet arrived at Mecca and sent for 'Uthman bin Talha. He opened the gate of the Ka'ba and the Prophet, Bilal, Usama bin Zaid and 'Uthman bin Talha entered the Ka'ba and then they closed its door (from inside). They stayed there for an hour, and then came out." Ibn 'Umar added, "I quickly went to Bilal and asked him (whether the Prophet had prayed). Bilal replied, 'He prayed in it.' I asked, 'Where?' He replied, 'Between the two pillars.' "Ibn 'Umar added, "I forgot to ask how many Rakat he (the Prophet) had prayed in the Ka'ba."


Bukhari :: Prayers (Salat) :: [1.8.458]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 458

Narrated Abu Huraira:

Allah's Apostle sent some horse men to Najd and they brought a man called Thumama bin Uthal from Bani Hanifa. They fastened him to one of the pillars of the mosque.


Bukhari :: Prayers (Salat) :: [1.8.459]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 459

Narrated Al-Sa'ib bin Yazid:

I was standing in the mosque and somebody threw a gravel at me. I looked and found that he was 'Umar bin Al-Khattab. He said to me, "Fetch those two men to me." When I did, he said to them, "Who are you? (Or) where do you come from?" They replied, "We are from Ta'if." 'Umar said, "Were you from this city (Medina) I would have punished you for raising your voices in the mosque of Allah's Apostle


Bukhari :: Prayers (Salat) :: [1.8.460]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 460

Narrated 'Kab bin Malik:

During the life-time of Allah's Apostle I asked Ibn Abi Hadrad in the mosque to pay the debts which he owed to me and our voices grew so loud that Allah's Apostle heard them while he was in his house. So he came to us after raising the curtain of his room. The Prophet said, "O Ka'b bin Malik!" I replied, "Labaik, O Allah's Apostle." He gestured with his hand to me to reduce the debt to one half. I said, "O Allah's Apostle have done it." Allah's Apostle said (to Ibn Hadrad), "Get up and pay it."


Bukhari :: Prayers (Salat) :: [1.8.461]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 461

Narrated Nafi':

Ibn 'Umar said, "While the Prophet was on the pulpit, a man asked him how to offer the night prayers. He replied, 'Pray two Rakat at a time and then two and then two and so on, and if you are afraid of the dawn (the approach of the time of the Fajr prayer) pray one Rak'a and that will be the witr for all the Rakat which you have offered." Ibn 'Umar said, "The last Rakat of the night prayer should be odd for the Prophet ordered it to be so.


Bukhari :: Prayers (Salat) :: [1.8.462]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 462

Narrated Ibn 'Umar:

A man came to the Prophet while he was delivering the sermon and asked him how to offer the night prayers. The Prophet replied, 'Pray two Rakat at a time and then two and then two and so on and if you are afraid of dawn (the approach of the time of the Fajr prayer) pray one Rak'a and that will be the with for all the Rakat which you have prayed." Narrated 'Ubaidullah bin 'Abdullah bin 'Umar: A man called the Prophet while he was in the mosque.


Bukhari :: Prayers (Salat) :: [1.8.463]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 463

Narrated Abu Waqid al-Laithi:

While Allah's Apostle was sitting in the mosque (with some people) three men came, two of them came in front of Allah's Apostle and the third one went away, and then one of them found a place in the circle and sat there while the second man sat behind the gathering, and the third one went away. When Allah's Apostle finished his preaching, he said, "Shall I tell you about these three persons? One of them betook himself to Allah and so Allah accepted him and accommodated him; the second felt shy before Allah so Allah did the same for him and sheltered him in His Mercy (and did not punish him), while the third turned his face from Allah, and went away, so Allah turned His face from him likewise.


Bukhari :: Prayers (Salat) :: [1.8.464]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 464

Narrated 'Abbad bin Tamim:

that his uncle said, "I saw Allah's Apostle lying flat (on his back) in the mosque with one leg on the other." Narrated Said bin Al-Musaiyab that 'Umar and 'Uthman used to do the same.


Bukhari :: Prayers (Salat) :: [1.8.465]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 465

Narrated 'Aisha:

(the wife of the Prophet) I had seen my parents following Islam since I attained the age of puberty. Not a day passed but the Prophet visited us, both in the mornings and evenings. My father Abii Bakr thought of building a mosque in the courtyard of his house and he did so. He used to pray and recite the Qur'an in it. The pagan women and their children used to stand by him and look at him with surprise. Abu Bakr was a Softhearted person and could not help weeping while reciting the Quran. The chiefs of the Quraish pagans became afraid of that (i.e. that their children and women might be affected by the recitation of Quran)."


Bukhari :: Prayers (Salat) :: [1.8.466]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 466

Narrated Abu Huraira:

The Prophet said, "The prayer offered in congregation is twenty five times more superior (in reward) to the prayer offered alone in one's house or in a business center, because if one performs ablution and does it perfectly, and then proceeds to the mosque with the sole intention of praying, then for each step which he takes towards the mosque, Allah upgrades him a degree in reward and (forgives) crosses out one sin till he enters the mosque. When he enters the mosque he is considered in prayer as long as he is waiting for the prayer and the angels keep on asking for Allah's forgiveness for him and they keep on saying: 'O Allah! Be Merciful to him, O Allah! Forgive him, as long as he keeps on sitting at his praying place and does not pass wind. (See Hadith No. 620).


Bukhari :: Prayers (Salat) :: [1.8.467]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 467

Narrated Ibn 'Umar or Ibn 'Amr:

The Prophet clasped his hands, by interlacing his fingers. Narrated 'Abdullah that Allah's Apostle said, "O 'Abdullah bin 'Amr! What will be your condition when you will be left with the sediments of (worst) people?" (They will be in conflict with each other).


Bukhari :: Prayers (Salat) :: [1.8.468]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 468

Narrated Abu Musa:

The Prophet said, "A faithful believer to a faithful believer is like the bricks of a wall, enforcing each other." While (saying that) the Prophet clasped his hands, by interlacing his fingers.


Bukhari :: Prayers (Salat) :: [1.8.469]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 469

Narrates Ibn Sirin:

Abu Huraira said, "Allah's Apostle led us in one of the two 'Isha' prayers (Abu Huraira named that prayer but I forgot it)." Abu Huraira added, "He prayed two Rakat and then finished the prayer with Tasllm. He stood up near a piece of wood Lying across the mosque and leaned on it in such a way as if he was angry. Then he put his right hand over the left and clasped his hands by interlacing his fingers and then put his J right cheek on the back of his left hand. The people who were in haste left the mosque through its gates. They wondered whether the prayer was reduced. And amongst them were Abu Bakr and 'Umar but they hesitated to ask the Prophet. A long-handed man called Dhul-Yadain asked the Prophet, 'O Allah's Apostle! Have you; forgotten or has the prayer been reduced?' The Prophet replied, 'I have neither forgotten nor has the prayer been reduced' The Prophet added, 'Is what Dhul Yadain has said true?' They (the people) said, 'Yes, it is true.' The Prophet stood up again and led the prayer, completing the remaining prayer, forgotten by him, and performed Talsrm, and then said, 'Allahu Akbar.' And then he did a prostration as he used to prostrate or longer than that. He then raised his head saying, 'Allahu Akbar; he then again said, 'Allahu Akbar', and prostrated as he used to prostrate or longer than that. Then he raised his head and said, 'Allahu Akbar.' " (The subnarrator added, "I think that they asked (Ibn Sirin) whether the Prophet completed the prayer with Taslim. He replied, "I heard that 'Imran bin Husain had said, 'Then he (the Prophet) did Taslim.")


Bukhari :: Prayers (Salat) :: [1.8.470]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 470

Narrated Fudail bin Sulaiman:

Musa bin 'Uqba said, "I saw Salim bin 'Abdullah looking for some places on the way and prayed there. He narrated that his father used to pray there, and had seen the Prophet praying at those very places."

Narrated Nafi' on the authority of Ibn 'Umar who said, "I used to pray at those places." Musa the narrator added, "I asked Salim on which he said, 'I agree with Nafi' concerning those places, except the mosque situated at the place called Sharaf Ar-Rawha."


Bukhari :: Prayers (Salat) :: [1.8.471]

Prayers (Salat)

Bukhari :: Book 1 :: Volume 8 :: Hadith 471

Narrated Hadith is about the various places on the way from Medina to Mecca where the Prophet prayed and their In locations impossible to translate.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.472]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 472

Narrated Ibn 'Abbas:

Once I came riding a she-ass when I had just attained the age of puberty. Allah's Apostle was offering the prayer at Mina with no wall in front of him and I passed in front of some of the row. There I dismounted and let my she-ass loose to graze and entered the row and nobody objected to me about it.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.473]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 473

Narrated Ibn 'Umar:

Whenever Allah's Apostle came out on 'Id day, he used to order that a Harba (a short spear) to be planted in front of him (as a Sutra for his prayer) and then he used to pray facing it with the people behind him and used to do the same while on a journey. After the Prophet , this practice was adopted by the Muslim rulers (who followed his traditions).


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.474]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 474

Narrated 'Aun bin Abi Juhaifa:

I heard my father saying, "The Prophet led us, and prayed a two-Rak'at Zuhr prayer and then a two-Rak'at 'Asr prayer at Al-Batha' with an 'Anza (planted) in front of him (as a Sutra) while women and donkeys were passing in front of him (beyond that 'Anza)."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.475]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 475

Narrated Sahl (bin Sa'd):

The distance between the Musalla of Allah's Apostle and the wall was just sufficient for a sheep to pass through .


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.476]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 476

Narrated Salama:

The distance between the wall of the mosque and the pulpit was hardly enough for a sheep to pass through.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.477]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 477

Narrated 'Abdullah:

The Prophet used to get a Harba planted in front of him (as a Sutra) and pray behind it.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.478]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 478

Narrated 'Aun bin Abi Juhaifa:

that he had heard his father saying, "Allah's Apostle came to us at mid-day and water was brought for his ablution. He performed ablution and led us in Zuhr and 'Asr prayers with an 'Anza planted in front of him (as a Sutra), while women and donkeys were passing beyond it."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.479]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 479

Narrated Anas Ibn Malik:

Whenever the Prophet went for answering the call of nature, I and another boy used to go after him with a staff, a stick or an 'Anza and a tumbler of water and when he finished from answering the call of nature we would hand that tumbler of water to him.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.480]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 480

Narrated Abu Juhaifa:

Allah's Apostle came out at midday and offered a two-Rak'at Zuhr and 'Asr prayers at Al-Batha and an 'Anza was planted in front of him (as a Sutra). He performed ablution and the people took the remaining water left after his ablution and rubbed their bodies with it.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.481]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 481

Narrated Yazid bin Al 'Ubaid:

I used to accompany Salama bin Al-Akwa' and he used to pray behind the pillar which was near the place where the Quran's were kept I said, "O Abu Muslim! I see you always seeking to pray behind this pillar." He replied, "I saw Allah's Apostle always seeking to pray near that pillar."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.482]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 482

Narrated Anas:

I saw the most famous people amongst the companions of the Prophet hurrying towards the pillars at the Maghrib prayer before the Prophet came for the prayer.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.483]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 483

Narrated Ibn 'Umar:

The Prophet entered the Ka'ba along with Usama bin Zaid, 'Uthman bin Talha and Bilal and remained there for a long time. When they came out, I was the first man to enter the Ka'ba. I asked Bilal "Where did the Prophet pray?" Bilal replied, "Between the two front Pillars."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.484]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 484

Narrated Nafi':

'Abdullah bin 'Umar said, "Allah's Apostle entered the Ka'ba along with Usama bin Zaid, Bilal and 'Uthman bin Talha Al-Hajabi and closed the door and stayed there for some time. I asked Bilal when he came out, 'What did the Prophet do?' He replied, 'He offered prayer with one pillar to his left and one to his right and three behind.' In those days the Ka'ba was supported by six pillars." Malik said: "There were two pillars on his (the Prophet's) right side."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.485]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 485

Narrated Nafi:

"The Prophet used to make his she-camel sit across and he would pray facing it (as a Sutra)." I asked, "What would the Prophet do if the she-camel was provoked and moved?" He said, "He would take its camel-saddle and put it in front of him and pray facing its back part (as a Sutra). And Ibn 'Umar used to do the same." (This indicates that one should not pray except behind a Sutra).


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.486]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 486

Narrated 'Aisha:

Do you make us (women) equal to dogs and donkeys? While I used to lie in my bed, the Prophet would come and pray facing the middle of the bed. I used to consider it not good to stand in front of him in his prayers. So I used to slip away slowly and quietly from the foot of the bed till I got out of my guilt.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.487]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 487

Narrated Abu Sa'id:

The Prophet said, (what is ascribed to him in the following Hadith 488):


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.488]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 488

Narrated Abu Salih As-Samman:

I saw Abu Said Al-Khudri praying on a Friday, behind something which acted as a Sutra. A young man from Bani Abi Mu'ait, wanted to pass in front of him, but Abu Said repulsed him with a push on his chest. Finding no alternative he again tried to pass but Abu Said pushed him with a greater force. The young man abused Abu Said and went to Marwan and lodged a complaint against Abu Said and Abu Said followed the young man to Marwan who asked him, "O Abu Said! What has happened between you and the son of your brother?" Abu Sa'id said to him, "I heard the Prophet saying, 'If anybody amongst you is praying behind something as a Sutra and somebody tries to pass in front of him, then he should repulse him and if he refuses, he should use force against him for he is a satan.' "


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.489]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 489

Narrated Busr bin Said:

that Zaid bin Khalid sent him to Abi Juhaim to ask him what he had heard from Allah's Apostle about a person passing in front of another person who was praying. Abu Juhaim replied, "Allah's Apostle said, 'If the person who passes in front of another person in prayer knew the magnitude of his sin he would prefer to wait for 40 (days, months or years) rather than to pass in front of him." Abu An-Nadr said, "I do not remember exactly whether he said 40 days, months or years."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.490]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 490

Narrated 'Aisha:

The things which annul the prayers were mentioned before me. They said, "Prayer is annulled by a dog, a donkey and a woman (if they pass in front of the praying people)." I said, "You have made us (i.e. women) dogs. I saw the Prophet praying while I used to lie in my bed between him and the Qibla. Whenever I was in need of something, I would slip away. for I disliked to face him."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.491]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 491

Narrated 'Aisha:

The Prophet used to pray while I was sleeping across in his bed in front of him. Whenever he wanted to pray Witr, he would wake me up and I would pray Witr.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.492]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 492

Narrated 'Aisha:

the wife of the Prophet, "I used to sleep in front of Allah's Apostle with my legs opposite his Qibla (facing him); and whenever he prostrated, he pushed my feet and I withdrew them and whenever he stood, I stretched them." 'Aisha added, "In those days there were no lamps in the houses."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.493]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 493

Narrated 'Aisha:

The things which annual prayer were mentioned before me (and those were): a dog, a donkey and a woman. I said, "You have compared us (women) to donkeys and dogs. By Allah! I saw the Prophet praying while I used to lie in (my) bed between him and the Qibla. Whenever I was in need of something, I disliked to sit and trouble the Prophet. So, I would slip away by the side of his feet."


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.494]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 494

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle used to get up at night and pray while I used to lie across between him and the Qibla on his family's bed.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.495]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 495

Narrated Abu Qatada Al-Ansari:

Allah's Apostle was praying and he was carrying Umama the daughters of Zainab, the daughter of Allah's Apostle and she was the daughter of 'As bin Rabi'a bin 'AbduShams. When he prostrated, he put her down and when he stood, he carried her (on his neck).


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.496]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 496

Narrated Maimuna bint Al-Harith:

My bed was beside the praying place (Musalla) of the Prophet and sometimes his garment fell on me while I used to lie in my bed.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.497]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 497

Narrated Maimuna:

The Prophet used to pray while I used to sleep beside him during my periods (menses) and in prostrations his garment used to touch me.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.498]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 498

Narrated 'Aisha:

It is not good that you people have made us (women) equal to dogs and donkeys. No doubt I saw Allah's Apostle praying while I used to lie between him and the Qibla and when he wanted to prostrate, he pushed my legs and I withdrew them.


Bukhari :: Virtues of the Prayer Hall (Sutra of the Musalla) :: [1.9.499]

Virtues of the Prayer Hall (Sutra of the Musalla)

Bukhari :: Book 1 :: Volume 9 :: Hadith 499

Narrated 'Amr bin Maimuin:

'Abdullah bin Mas'ud said, "While Allah's Apostle was praying beside the Ka'ba, there were some Quraish people sitting in a gathering. One of them said, 'Don't you see this (who does deeds just to show off)? Who amongst you can go and bring the dung, blood and the abdominal contents (intestines, etc). of the slaughtered camels of the family of so and so and then wait till he prostrates and put that in between his shoulders?' The most unfortunate amongst them ('Uqba bin Abi Mu'ait) went (and brought them) and when Allah's Apostle prostrated, he put them between his shoulders. The Prophet remained in prostration and they laughed so much so that they fell on each other. A passerby went to Fatima, who was a young girl in those days. She came running and the Prophet was still in prostration. She removed them and cursed upon the Quraish on their faces. When Allah's Apostle completed his prayer, he said, 'O Allah! Take revenge on Quraish.' He said so thrice and added, 'O Allah! take revenge on 'Amr bin Hisham, 'Utba bin Rabia, Shaiba bin Rabi'a, Al-Walid bin'Utba, Umaiya bin Khalaf, 'Uqba bin Abi Mu'ait and 'Umar a bin Al-Walid." Abdullah added, "By Allah! I saw all of them dead in the battle field on the day of Badr and they were dragged and thrown in the Qalib (a well) at Badr: Allah's Apostle then said, 'Allah's curse has descended upon the people of the Qalib (well).


Bukhari :: Times of the Prayers :: [1.10.500]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 500

Narrated Ibn Shihab:

Once'Umar bin 'Abdul 'Aziz delayed the prayer and 'Urwa bin Az-Zubair went to him and said, "Once in 'Iraq, Al-MughTra bin Shu'ba delayed his prayers and Abi Mas'ud Al-Ansari went to him and said, 'O Mughira! What is this? Don't you know that once Gabriel came and offered the prayer (Fajr prayer) and Allah's Apostle prayed too, then he prayed again (Zuhr prayer) and so did Allah's Apostle and again he prayed ('Asr prayers and Allah's Apostle did the same; again he prayed (Maghrib-prayer) and so did Allah's Apostle and again prayed ('Isha prayer) and so did Allah's Apostle and (Gabriel) said, 'I was ordered to do so (to demonstrate the prayers prescribed to you)?'" 'Umar (bin 'Abdul 'AzTz) said to 'Urwa, "Be sure of what you Say. Did Gabriel lead Allah's Apostle at the stated times of the prayers?" 'Urwa replied, "Bashir bin Abi Mas'ud narrated like this on the authority of his father." Urwa added, "Aisha told me that Allah's Apostle used to pray 'Asr prayer when the sun-shine was still inside her residence (during the early time of 'Asr)."


Bukhari :: Times of the Prayers :: [1.10.501]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 501

Narrated Ibn 'Abbas:

"Once a delegation of 'Abdul Qais came to Allah's Apostle and said, "We belong to such and such branch of the tribe of Rab'a and we can only come to you in the sacred months. Order us to do something good so that we may (carry out) take it from you and also invite to it our people whom we have left behind (at home)." The Prophet said, " I order you to do four things and forbid you from four things. (The first four are as follows):

1. To believe in Allah. (And then he: explained it to them i.e.) to testify that none has the right to be worshipped but Allah and (Muhammad) am Allah's Apostle

2. To offer prayers perfectly (at the stated times):

3. To pay Zakat (obligatory charity)

4. To give me Khumus

(The other four things which are forbidden are as follows):

1. Dubba

2. Hantam

3. Muqaiyat

4. Naqir (all these are utensils used for the preparation of alcoholic drinks)."


Bukhari :: Times of the Prayers :: [1.10.502]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 502

Narrated Jarir bin 'Abdullah:

I gave the pledge of allegiance to Allah's Apostle for to offer prayers perfectly, to pay Zakat regularly, and to give good advice to every Muslim.


Bukhari :: Times of the Prayers :: [1.10.503]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 503

Narrated Shaqiq:

that he had heard Hudhaifa saying, "Once I was sitting with 'Umar and he said, 'Who amongst you remembers the statement of Allah's Apostle about the afflictions?' I said, 'I know it as the Prophet had said it.' 'Umar said, 'No doubt you are bold.' I said, 'The afflictions caused for a man by his wife, money, children and neighbor are expiated by his prayers, fasting, charity and by enjoining (what is good) and forbidding (what is evil).' 'Umar said, 'I did not mean that but I asked about that affliction which will spread like the waves of the sea.' I (Hudhaifa) said, 'O leader of the faithful believers! You need not be afraid of it as there is a closed door between you and it.' 'Umar asked, Will the door be broken or opened?' I replied, 'It will be broken.' 'Umar said, 'Then it will never be closed again.' I was asked whether 'Umar knew that door. I replied that he knew it as one knows that there will be night before the tomorrow morning. I narrated a Hadith that was free from any mis-statement" The subnarrator added that they deputed Masruq to ask Hudhaifa (about the door). Hudhaifa said, "The door was 'Umar himself."


Bukhari :: Times of the Prayers :: [1.10.504]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 504

Narrated Ibn Mas'ud:

A man kissed a woman (unlawfully) and then went to the Prophet and informed him. Allah revealed:

And offer prayers perfectly At the two ends of the day And in some hours of the night (i.e. the five compulsory prayers). Verily! good deeds remove (annul) the evil deeds (small sins) (11.114). The man asked Allah's Apostle, "Is it for me?" He said, "It is for all my followers."


Bukhari :: Times of the Prayers :: [1.10.505]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 505

Narrated 'Abdullah:

I asked the Prophet "Which deed is the dearest to Allah?" He replied, "To offer the prayers at their early stated fixed times." I asked, "What is the next (in goodness)?" He replied, "To be good and dutiful to your parents" I again asked, "What is the next (in goodness)?" He replied, 'To participate in Jihad (religious fighting) in Allah's cause." 'Abdullah added, "I asked only that much and if I had asked more, the Prophet would have told me more."


Bukhari :: Times of the Prayers :: [1.10.506]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 506

Narrated Abu Huraira:

I heard Allah's Apostle saying, "If there was a river at the door of anyone of you and he took a bath in it five times a day would you notice any dirt on him?" They said, "Not a trace of dirt would be left." The Prophet added, "That is the example of the five prayers with which Allah blots out (annuls) evil deeds."


Bukhari :: Times of the Prayers :: [1.10.507]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 507

Narrated Ghailan:

Anas said, "I do not find (now-a-days) things as they were (practiced) at the time of the Prophet." Somebody said "The prayer (is as it was.)" Anas said, "Have you not done in the prayer what you have done?

Narrated Az-Zuhri that he visited Anas bin Malik at Damascus and found him weeping and asked him why he was weeping. He replied, "I do not know anything which I used to know during the life-time of Allah's Apostle except this prayer which is being lost (not offered as it should be)."


Bukhari :: Times of the Prayers :: [1.10.508]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 508

Narrated Anas:

The Prophet said, "Whenever anyone of you offers his prayer he is speaking in private to his Lord. So he should not spit to his right but under his left foot." Qatada said, "He should not spit in front of him but to his left or under his feet." And Shu'ba said, "He should not spit in front of him, nor to his right but to his left or under his foot." Anas said: The Prophet said, "He should neither spit in the direction of his Qibla nor to his right but to his left or under his foot."


Bukhari :: Times of the Prayers :: [1.10.509]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 509

Narrated Anas:

The Prophet said, "Do the prostration properly and do not put your fore-arms flat with elbows touching the ground like a dog. And if you want to spit, do not spit in front, nor to the right for the person in prayer is speaking in private to his Lord."


Bukhari :: Times of the Prayers :: [1.10.510]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 510

Narrated Abu Huraira and 'Abdullah bin 'Umar:

Allah's Apostle said, "If it is very hot, then pray the Zuhr prayer when it becomes (a bit) cooler, as the severity of the heat is from the raging of the Hell-fire."


Bukhari :: Times of the Prayers :: [1.10.511]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 511

Narrated Abu Dhar:

The Muadhdhin (call-maker) of the Prophet pronounced the Adhan (call) for the Zuhr prayer but the Prophet said, "Let it be cooler, let it be cooler." Or said, 'Wait, wait, because the severity of heat is from the raging of the Hell-fire. In severe hot weather, pray when it becomes (a bit) cooler and the shadows of hillocks appear."


Bukhari :: Times of the Prayers :: [1.10.512]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 512

Narrated Abu Huraira:

The Prophet said, "In very hot weather delay the Zuhr prayer till it becomes (a bit) cooler because the severity of heat is from the raging of Hell-fire. The Hell-fire of Hell complained to its Lord saying: O Lord! My parts are eating (destroying) one another. So Allah allowed it to take two breaths, one in the winter and the other in the summer. The breath in the summer is at the time when you feel the severest heat and the breath in the winter is at the time when you feel the severest cold."


Bukhari :: Times of the Prayers :: [1.10.513]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 513

Narrated Abu Sa'id:

that Allah's Apostle said, "Pray Zuhr prayer when it becomes (a bit) cooler as the severity of heat is from the raging of the Hell-fire."


Bukhari :: Times of the Prayers :: [1.10.514]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 514

Narrated Abu Dhar Al-Ghifar:

We were with the Prophet on a journey and the Mu'adhdhin (call maker for the prayer) wanted to pronounce the Adhan (call) for the Zuhr prayer. The Prophet said, 'Let it become cooler." He again (after a while) wanted to pronounce the Adhan but the Prophet said to him, "Let it become cooler till we see the shadows of hillocks." The Prophet added, "The severity of heat is from the raging of the Hell-fire, and in very hot weather pray (Zuhr) when it becomes cooler."


Bukhari :: Times of the Prayers :: [1.10.515]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 515

Narrated Anas bin Malik:

Allah's Apostle came out as the sun declined at mid-day and offered the Zuhr prayer. He then stood on the pulpit and spoke about the Hour (Day of Judgment) and said that in it there would be tremendous things. He then said, "Whoever likes to ask me about anything he can do so and I shall reply as long as I am at this place of mine. Most of the people wept and the Prophet said repeatedly, "Ask me." Abdullah bin Hudhafa As-Sahmi stood up and said, "Who is my father?" The Prophet said, "Your father is Hudhafa." The Prophet repeatedly said, "Ask me." Then Umar knelt before him and said, "We are pleased with Allah as our Lord, Islam as our religion, and Muhammad as our Prophet." The Prophet then became quiet and said, "Paradise and Hell-fire were displayed in front of me on this wall just now and I have never seen a better thing (than the former) and a worse thing (than the latter)."


Bukhari :: Times of the Prayers :: [1.10.516]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 516

Narrated Abu Al-Minhal:

Abu Barza said, "The Prophet used to offer the Fajr (prayer) when one could recognize the person sitting by him (after the prayer) and he used to recite between 60 to 100 Ayat (verses) of the Qur'an. He used to offer the Zuhr prayer as soon as the sun declined (at noon) and the 'Asr at a time when a man might go and return from the farthest place in Medina and find the sun still hot. (The sub-narrator forgot what was said about the Maghrib). He did not mind delaying the 'Isha prayer to one third of the night or the middle of the night."


Bukhari :: Times of the Prayers :: [1.10.517]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 517

Narrated Anas bin Malik:

When we offered the Zuhr prayers behind Allah's Apostle we used to prostrate on our clothes to protect ourselves from the heat.


Bukhari :: Times of the Prayers :: [1.10.518]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 518

Narrated Ibn 'Abbas:

"The Prophet prayed eight Rakat for the Zuhr and 'Asr, and seven for the Maghrib and 'Isha prayers in Medina." Aiyub said, "Perhaps those were rainy nights." Anas said, "May be."


Bukhari :: Times of the Prayers :: [1.10.519]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 519

Narrated Aisha:

Allah's Apostle used to offer the 'Asr prayer when the sunshine had not disappeared from my chamber.


Bukhari :: Times of the Prayers :: [1.10.520]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 520

Narrated 'Aisha:

Allah's Apostle used to offer the 'Asr prayers at a time when the sunshine was still inside my chamber and no shadow had yet appeared in it.


Bukhari :: Times of the Prayers :: [1.10.521]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 521

Narrated Aisha:

The Prophet used to pray the 'Asr prayers at a time when the sunshine was still inside my chamber and no shadow had yet appeared in it.


Bukhari :: Times of the Prayers :: [1.10.522]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 522

Narrated Saiyar bin Salama:

I along with my father went to Abu- Barza Al-Aslarrni and my father asked him, "How Allah's Apostle used to offer the five compulsory congregational prayers?" Abu- Barza said, "The Prophet used to pray the Zuhr prayer which you (people) call the first one at mid-day when the sun had just declined The Asr prayer at a time when after the prayer, a man could go to the house at the farthest place in Medina (and arrive) while the sun was still hot. (I forgot about the Maghrib prayer). The Prophet Loved to delay the 'Isha which you call Al- Atama and he disliked sleeping before it and speaking after it. After the Fajr prayer he used to leave when a man could recognize the one sitting beside him and he used to recite between 60 to 100 Ayat (in the Fajr prayer) .


Bukhari :: Times of the Prayers :: [1.10.523]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 523

Narrated Anas bin Malik:

We used to pray the Asr prayer and after that if someone happened to go to the tribe of Bani Amr bin Auf, he would find them still praying the Asr (prayer).


Bukhari :: Times of the Prayers :: [1.10.524]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 524

Narrated Abu Bakr bin Uthman bin Sahl bin Hunaif:

that he heard Abu Umama saying: We prayed the Zuhr prayer with 'Umar bin Abdul Aziz and then went to Anas bin Malik and found him offering the Asr prayer. I asked him, "O uncle! Which prayer have you offered?" He said 'The Asr and this is (the time of) the prayer of Allah s Apostle which we used to pray with him."


Bukhari :: Times of the Prayers :: [1.10.525]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 525

Narrated Anas bin Malik:

Allah's Apostle used to offer the 'Asr prayer at a time when the sun was still hot and high and if a person went to Al-'Awali (a place) of Medina, he would reach there when the sun was still high. Some of Al-'Awali of Medina were about four miles or so from the town.


Bukhari :: Times of the Prayers :: [1.10.526]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 526

Narrated Anas bin Malik:

We used to pray the 'Asr and after that if one of US went to Quba'he would arrive there while the sun was still high.


Bukhari :: Times of the Prayers :: [1.10.527]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 527

Narrated Ibn 'Umar:

Allah's Apostle said, "Whoever misses the 'Asr prayer (intentionally) then it is as if he lost his family and property."


Bukhari :: Times of the Prayers :: [1.10.528]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 528

Narrated Abu Al-Mahh:

We were with Buraida in a battle on a cloudy day and he said, "Offer the 'Asr prayer early as the Prophet said, "Whoever leaves the 'Asr prayer, all his (good) deeds will be annulled."


Bukhari :: Times of the Prayers :: [1.10.529]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 529

Narrated Qais:

Jarir said, "We were with the Prophet and he looked at the moon--full-moon--and said, 'Certainly you will see your Lord as you see this moon and you will have no trouble in seeing Him. So if you can avoid missing (through sleep or business, etc.) a prayer before the sun-rise (Fajr) and a prayer before sunset ('Asr), you must do so.' He then recited Allah's Statement:

And celebrate the praises Of your Lord before The rising of the sun And before (its) setting." (50.39) Isma'il said, "Offer those prayers and do not miss them."


Bukhari :: Times of the Prayers :: [1.10.530]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 530

Narrated Abu Huraira:

Allah's Apostle said, "Angels come to you in succession by night and day and all of them get together at the time of the Fajr and 'Asr prayers. Those who have passed the night with you (or stayed with you) ascend (to the Heaven) and Allah asks them, though He knows everything about you, well, "In what state did you leave my slaves?" The angels reply: "When we left them they were praying and when we reached them, they were praying."


Bukhari :: Times of the Prayers :: [1.10.531]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 531

Narrated Abu Huraira:

Allah's Apostle said, "If anyone of you can get one Rak'a of the 'Asr prayer before sunset, he should complete his prayer. If any of you can get one Rak'a of the Fajr prayer before sunrise, he should complete his prayer."


Bukhari :: Times of the Prayers :: [1.10.532]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 532

Narrated Salim bin 'Abdullah:

My father said, "I heard Allah's Apostle saying, 'The period of your stay as compared to the previous nations is like the period equal to the time between the 'Asr prayer and sunset. The people of the Torah were given the Torah and they acted (upon it) till mid-day then they were exhausted and were given one Qirat (of gold) each. And then the people of the Gospel were given the Gospel and they acted (upon it) till the 'Asr prayer then they were exhausted and were! given one Qirat each. And then we were given the Qur'an and we acted (upon it) till sunset and we were given two Qirats each. On that the people of both the scriptures said, 'O our Lord! You have given them two Qirats and given us one Qirat, though we have worked more than they.' Allah said, 'Have I usurped some of your right?' They said, 'No.' Allah said: "That is my blessing I bestow upon whomsoever I wish."


Bukhari :: Times of the Prayers :: [1.10.533]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 533

Narrated Abu Musa:

The Prophet said, "The example of Muslims, Jews and Christians is like the example of a man who employed laborers to work for him from morning till night. They worked till mid-day and they said, 'We are not in need of your reward.' SO the man employed another batch and said to them, 'Complete the rest of the day and yours will be the wages I had fixed (for the first batch). They worked Up till the time of the 'Asr prayer and said, 'Whatever we have done is for you.' He employed another batch. They worked for the rest of the day till sunset, and they received the wages of the two former batches."


Bukhari :: Times of the Prayers :: [1.10.534]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 534

Narrated Rafi' bin Khadij:

We used to offer the Maghrib prayer with the Prophet and after finishing the prayer one of us may go away and could still see as Par as the spots where one's arrow might reach when shot by a bow.


Bukhari :: Times of the Prayers :: [1.10.535]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 535

Narrated Jabir bin 'Abdullah:

The Prophet used to pray the Zuhr at mid-day, and the 'Asr at a time when the sun was still bright, the Maghrib after sunset (at its stated time) and the Isha at a variable time. Whenever he saw the people assembled (for Isha' prayer) he would pray earlier and if the people delayed, he would delay the prayer. And they or the Prophet used to offer the Fajr Prayers when it still dark.


Bukhari :: Times of the Prayers :: [1.10.536]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 536

Narrated Salama:

We used to pray the Maghrib prayer with the Prophet when the sun disappeared from the horizon.


Bukhari :: Times of the Prayers :: [1.10.537]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 537

Narrated Ibn 'Abbas:

The Prophet prayed seven Rakat together and eight Rakat together.


Bukhari :: Times of the Prayers :: [1.10.538]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 538

Narrated 'Abdullah Al-Muzani:

The Prophet said, "Do not be influenced by bedouins regarding the name of your Maghrib prayer which is called 'Isha' by them."


Bukhari :: Times of the Prayers :: [1.10.539]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 539

Narrated Abdullah:

"One night Allah's Apostle led us in the 'Isha' prayer and that is the one called Al-'Atma by the people. After the completion of the prayer, he faced us and said, "Do you know the importance of this night? Nobody present on the surface of the earth to-night will be living after one hundred years from this night." (See Hadith No. 575).


Bukhari :: Times of the Prayers :: [1.10.540]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 540

Narrated Muhammad bin 'Amr:

We asked Jabir bin 'Abdullah about the prayers of the Prophet . He said, "He used to pray Zuhr prayer at mid-day, the 'Asr when the sun was still hot, and the Maghrib after sunset (at its stated time). The 'Isha was offered early if the people gathered, and used to be delayed if their number was less; and the morning prayer was offered when it was still dark. "


Bukhari :: Times of the Prayers :: [1.10.541]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 541

Narrated 'Aisha:

Allah's Apostle once delayed the 'Isha' prayer and that was during the days when Islam still had not spread. The Prophet did not come out till 'Umar informed him that the women and children had slept. Then he came out and said to the people of the mosque:"None amongst the dwellers of the earth has been waiting for it ('Isha prayer) except you."


Bukhari :: Times of the Prayers :: [1.10.542]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 542

Narrated Abu Musa:

My companions, who came with me in the boat and I landed at a place called Baqi Buthan. The Prophet was in Medina at that time. One of us used to go to the Prophet by turns every night at the time of the Isha prayer. Once I along with my companions went to the Prophet and he was busy in some of his affairs, so the 'Isha' prayer was delayed to the middle of the night He then came out and led the people (in prayer). After finishing from the prayer, he addressed the people present there saying, "Be patient! Don't go away. Have the glad tiding. It is from the blessing of Allah upon you that none amongst mankind has prayed at this time save you." Or said, "None except you has prayed at this time." Abu Muisa added, 'So we returned happily after what we heard from Alllah's Apostle ."


Bukhari :: Times of the Prayers :: [1.10.543]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 543

Narrated Abu Barza:

Allah's Apostle disliked to sleep before the 'Isha' prayer and to talk after it.


Bukhari :: Times of the Prayers :: [1.10.544]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 544

Narrated Ibn Shihab from 'Urwa:

'Aisha said, "Once Allah's Apostle delayed the 'Isha' prayer till 'Umar reminded him by saying, "The prayer!" The women and children have slept. Then the Prophet came out and said, 'None amongst the dwellers of the earth has been waiting for it (the prayer) except you." Urwa said, "Nowhere except in Medina the prayer used to be offered (in those days)." He further said, "The Prophet used to offer the 'Isha' prayer in the period between the disappearance of the twilight and the end of the first third of the night."


Bukhari :: Times of the Prayers :: [1.10.545]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 545

Narrated Ibn Juraij from Nafi:

'Abdullah bin 'Umar said, "Once Allah's Apostle was busy (at the time of the 'Isha'), so the prayer was delayed so much so that we slept and woke up and slept and woke up again. The Prophet came out and said, 'None amongst the dwellers of the earth but you have been waiting for the prayer." Ibn 'Umar did not find any harm in praying it earlier or in delaying it unless he was afraid that sleep might overwhelm him and he might miss the prayer, and sometimes he used to sleep before the 'Isha' prayer. Ibn Juraij said, "I said to 'Ata', 'I heard Ibn 'Abbas saying: Once Allah's Apostle delayed the 'Isha' prayer to such an extent that the people slept and got up and slept again and got up again. Then 'Umar bin Al-Khattab I, stood up and reminded the Prophet I of the prayer.' 'Ata' said, 'Ibn 'Abbas said: The Prophet came out as if I was looking at him at this time, and water was trickling from his head and he was putting his hand on his head and then said, 'Hadn't I thought it hard for my followers, I would have ordered them to pray ('Isha' prayer) at this time.' I asked 'Ata' for further information, how the Prophet had kept his hand on his head as he was told by Ibn 'Abbas. 'Ata' separated his fingers slightly and put their tips on the side of the head, brought the fingers downwards approximating them till the thumb touched the lobe of the ear at the side of the temple and the beard on the face. He neither slowed nor hurried in this action but he acted like that. The Prophet said: "Hadn't I thought it hard for my followers I would have ordered them to pray at this time."


Bukhari :: Times of the Prayers :: [1.10.546]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 546

Narrated Anas:

The Prophet delayed the'lsha' prayer till midnight and then he offered the prayer and said, "The people prayed and slept but you have been in prayer as long as you have been waiting for it (the prayer)." Anas added: As if I am looking now at the glitter of the ring of the Prophet on that night.


Bukhari :: Times of the Prayers :: [1.10.547]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 547

Narrated Jarir bin 'Abdullah:

We were with the Prophet on a full moon night. He looked at the moon and said, "You will certainly see your Lord as you see this moon, and there will be no trouble in seeing Him. So if you can avoid missing (through sleep, business, etc.) a prayer before the rising of the sun (Fajr) and before its setting ('Asr) you must do so. He (the Prophet ) then recited the following verse:

And celebrate the praises Of Your Lord before The rising of the sun And before (its) setting." (50.39)


Bukhari :: Times of the Prayers :: [1.10.548]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 548

Narrated Abu Bakr bin Abi Musa:

My father said, "Allah's Apostle said, 'Whoever prays the two cool prayers ('Asr and Fajr) will go to Paradise.' "


Bukhari :: Times of the Prayers :: [1.10.549]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 549

Narrated Anas:

Zaid bin Thabit said, "We took the "Suhur" (the meal taken before dawn while fasting is observed) with the Prophet and then stood up for the (morning) prayer." I asked him how long the interval between the two (Suhur and prayer) was. He replied, 'The interval between the two was just sufficient to recite fifty to Sixth 'Ayat."


Bukhari :: Times of the Prayers :: [1.10.550]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 550

Narrated Qatada:

Anas bin Malik said, "The Prophet and Zaid bin Thabit took the 'Suhur' together and after finishing the meal, the Prophet stood up and prayed (Fajr prayer)." I asked Anas, "How long was the interval between finishing their 'Suhur' and starting the prayer?" He replied, "The interval between the two was just sufficient to recite fifty 'Ayat." (Verses of the Quran)."


Bukhari :: Times of the Prayers :: [1.10.551]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 551

Narrated Sahl bin Sa'd:

I used to take the "Suhur" meal with my family and hasten so as to catch the Fajr (morning prayer) with Allah's Apostle


Bukhari :: Times of the Prayers :: [1.10.552]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 552

Narrated 'Aisha:

The believing women covered with their veiling sheets used to attend the Fajr prayer with Allah's Apostle, and after finishing the prayer they would return to their home and nobody could recognize them because of darkness.


Bukhari :: Times of the Prayers :: [1.10.553]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 553

Narrated Abu Huraira:

Allah's Apostle said, "Whoever could get one Rak'a (of the Fajr prayer) before sunrise, he has got the (morning) prayer and whoever could get one Rak'a of the'Asr prayer before sunset, he has got the ('Asr) prayer."


Bukhari :: Times of the Prayers :: [1.10.554]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 554

Narrated Abu Huraira:

Allah's Apostle said, "Whoever could get one Rak'a of a prayer, (in its proper time) he has got the prayer."


Bukhari :: Times of the Prayers :: [1.10.555]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 555

Narrated 'Umar:

"The Prophet forbade praying after the Fajr prayer till the sun rises and after the 'Asr prayer till the sun sets."


Bukhari :: Times of the Prayers :: [1.10.556]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 556

Narrated Ibn 'Abbas:

Some people told me the same narration (as above).


Bukhari :: Times of the Prayers :: [1.10.557]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 557

Narrated Hisham's father:

Ibn 'Umar said, "Allah's Apostle said, 'Do not pray at the time of sunrise and at the time of sunset.' " Ibn 'Umar said, "Allah's Apostle said, 'If the edge of the sun appears (above the horizon) delay the prayer till it becomes high, and if the edge of the sun disappears, delay the prayer till it sets (disappears completely).' "


Bukhari :: Times of the Prayers :: [1.10.558]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 558

Narrated Abu Huraira:

Allah's Apostle forbade two kinds of sales, two kinds of dresses, and two prayers. He forbade offering prayers after the Fajr prayer till the rising of the sun and after the 'Asr prayer till its setting. He also forbade "Ishtimal-Assama" and "al-Ihtiba" in one garment in such a way that one's private parts are exposed towards the sky. He also forbade the sales called "Munabadha" and "Mulamasa." (See Hadith No. 354 and 355 Vol. 3).


Bukhari :: Times of the Prayers :: [1.10.559]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 559

Narrated Ibn 'Umar:

Allah's Apostle said, "None of you should try to pray at sunrise or sunset."


Bukhari :: Times of the Prayers :: [1.10.560]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 560

Narrated Abu Sa'id Al-Khudri:

I heard Allah's Apostle saying, "There is no prayer after the morning prayer till the sun rises, and there is no prayer after the Asr prayer till the sun sets."


Bukhari :: Times of the Prayers :: [1.10.561]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 561

Narrated Muawiya:

You offer a prayer which I did not see being offered by Allah's Apostle when we were in his company and he certainly had forbidden it (i.e. two Rakat after the Asr prayer).


Bukhari :: Times of the Prayers :: [1.10.562]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 562

Narrated Abu Huraira:

Allah's Apostle forbade the offering of two prayers:

1. after the morning prayer till the sunrises.

2. after the 'Asr prayer till the sun sets.


Bukhari :: Times of the Prayers :: [1.10.563]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 563

Narrated Ibn 'Umar:

I pray as I saw my companions praying. I do not forbid praying at any time during the day or night except at sunset and sunrise.


Bukhari :: Times of the Prayers :: [1.10.564]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 564

Narrated 'Aisha:

By Allah, Who took away the Prophet. The Prophet never missed them (two Rakat) after the 'Asr prayer till he met Allah and he did not meet Allah till it became heavy for him to pray while standing so he used to offer most of the prayers while sitting. (She meant the two Rakat after Asr) He used to pray them in the house and never prayed them in the mosque lest it might be hard for his followers and he loved what was easy for them .


Bukhari :: Times of the Prayers :: [1.10.565]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 565

Narrated Hisham's father:

'Aisha (addressing me) said, "O son of my sister! The Prophet never missed two prostrations (i.e. Rakat) after the 'Asr prayer in my house."


Bukhari :: Times of the Prayers :: [1.10.566]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 566

Narrated 'Aisha:

Allah's Apostle never missed two Rakat before the Fajr prayer and after the Asr prayer openly and secretly.


Bukhari :: Times of the Prayers :: [1.10.567]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 567

Narrated 'Aisha:

Whenever the Prophet come to me after the 'Asr prayer, he always prayed two Rakat.


Bukhari :: Times of the Prayers :: [1.10.568]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 568

Narrated Ibn Abu Malih:

I was with Buraida on a cloudy day and he said, "Offer the 'Asr prayer earlier as the Prophet said, 'Whoever leaves the 'Asr prayer will have all his (good) deeds annulled." (See Hadith No. 527 and 528)


Bukhari :: Times of the Prayers :: [1.10.569]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 569

Narrated 'Abdullah bin Abi Qatada:

My father said, "One night we were traveling with the Prophet and some people said, 'We wish that Allah's Apostle would take a rest along with us during the last hours of the night.' He said, 'I am afraid that you will sleep and miss the (Fajr) prayer.' Bilal said, 'I will make you get up.' So all slept and Bilal rested his back against his Rahila and he too was overwhelmed (by sleep) and slept. The Prophet got up when the edge of the sun had risen and said, 'O Bilal! What about your statement?' He replied, 'I have never slept such a sleep.' The Prophet said, 'Allah captured your souls when He wished, and released them when He wished. O Bilal! Get up and pronounce the Adhan for the prayer.' The Prophet performed ablution and when the sun came up and became bright, he stood up and prayed."


Bukhari :: Times of the Prayers :: [1.10.570]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 570

Narrated Jabir bin 'Abdullah:

On the day of Al-Khandaq (the battle of trench.) 'Umar bin Al-Khattab came cursing the disbelievers of Quraish after the sun had set and said, "O Allah's Apostle I could not offer the 'Asr prayer till the sun had set." The Prophet said, "By Allah! I, too, have not prayed." So we turned towards Buthan, and the Prophet performed ablution and we too performed ablution and offered the 'Asr prayer after the sun had set, and then he offered the Maghrib prayer.


Bukhari :: Times of the Prayers :: [1.10.571]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 571

Narrated Anas:

The Prophet said, "If anyone forgets a prayer he should pray that prayer when he remembers it. There is no expiation except to pray the same." Then he recited: "Establish prayer for My (i.e. Allah's) remembrance." (20.14).


Bukhari :: Times of the Prayers :: [1.10.572]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 572

Narrated Jabir:

Umar came cursing the disbelievers (of Quraish) on the day of Al-Khandaq (the battle of Trench) and said, "I could not offer the 'Asr prayer till the sun had set. Then we went to Buthan and he offered the ('Asr) prayer after sunset and then he offered the Maghrib prayer.


Bukhari :: Times of the Prayers :: [1.10.573]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 573

Narrated Abu-l-Minhal:

My father and I went to Abi Barza Al-Aslami and my father said to him, "Tell us how Allah's Apostle used to offer the compulsory congregational prayers." He said, "He used to pray the Zuhr prayer, which you call the first prayer, as the sun declined at noon, the 'Asr at a time when one of US could go to his family at the farthest place in Medina while the sun was still hot. (The narrator forgot what Abu Barza had said about the Maghrib prayer), and the Prophet preferred to pray the 'Isha' late and disliked to sleep before it or talk after it. And he used to return after finishing the morning prayer at such a time when it was possible for one to recognize the person sitting by his side and he (the Prophet) used to recite 60 to 100 'Ayat' (verses) of the Qur'an in it."


Bukhari :: Times of the Prayers :: [1.10.574]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 574

Narrated Qurra bin Khalid:

Once he waited for Al-Hasan and he did not show up till it was about the usual time for him to start his speech; then he came and apologized saying, "Our neighbors invited us." Then he added, "Narrated Anas, 'Once we waited for the Prophet till it was midnight or about midnight. He came and led the prayer, and after finishing it, he addressed us and said, 'All the people prayed and then slept and you had been in prayer as long as you were waiting for it." Al-Hasan said, "The people are regarded as performing good deeds as long as they are waiting for doing good deeds." Al-Hasan's statement is a portion of Anas's Hadith from the Prophet .


Bukhari :: Times of the Prayers :: [1.10.575]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 575

Narrated 'Abdullah bin 'Umar:

The Prophet prayed one of the'lsha' prayer in his last days and after finishing it with Taslim, he stood up and said, "Do you realize (the importance of) this night? Nobody present on the

surface of the earth to-night would be living after the completion of one hundred years from this night."

The people made a mistake in grasping the meaning of this statement of Allah's Apostle and they indulged in those things which are said about these narrators (i.e. some said that the Day of Resurrection will be established after 100 years etc.) But the Prophet said, "Nobody present on the surface of earth tonight would be living after the completion of 100 years from this night"; he meant "When that century (people of that century) would pass away."


Bukhari :: Times of the Prayers :: [1.10.576]

Times of the Prayers

Bukhari :: Book 1 :: Volume 10 :: Hadith 576

Narrated Abu 'Uthman:

'Abdur Rahman bin Abi Bakr said, "The Suffa Companions were poor people and the Prophet said, 'Whoever has food for two persons should take a third one from them (Suffa companions). And whosoever has food for four persons he should take one or two from them' Abu Bakr took three men and the Prophet took ten of them."

'Abdur Rahman added, my father my mother and I were there (in the house). (The sub-narrator is in doubt whether 'Abdur Rahman also said, 'My wife and our servant who was common for both my house and Abu Bakr's house). Abu Bakr took his supper with the Prophet and remained there till the 'Isha' prayer was offered. Abu Bakr went back and stayed with the Prophet till the Prophet took his meal and then Abu Bakr returned to his house after a long portion of the night had passed. Abu Bakr's wife said, 'What detained you from your guests (or guest)?' He said, 'Have you not served them yet?' She said, 'They refused to eat until you come. The food was served for them but they refused." 'Abdur Rahman added, "I went away and hid myself (being afraid of Abu Bakr) and in the meantime he (Abu Bakr) called me, 'O Ghunthar (a harsh word)!' and also called me bad names and abused me and then said (to his family), 'Eat. No welcome for you.' Then (the supper was served). Abu Bakr took an oath that he would not eat that food. The narrator added: By Allah, whenever any one of us (myself and the guests of Suffa companions) took anything from the food, it increased from underneath. We all ate to our fill and the food was more than it was before its serving.

Abu Bakr looked at it (the food) and found it as it was before serving or even more than that. He addressed his wife (saying) 'O the sister of Bani Firas! What is this?' She said, 'O the pleasure of my eyes! The food is now three times more than it was before.' Abu Bakr ate from it, and said, 'That (oath) was from Satan' meaning his oath (not to eat). Then he again took a morsel (mouthful) from it and then took the rest of it to the Prophet. So that meal was with the Prophet. There was a treaty between us and some people, and when the period of that treaty had elapsed the Prophet divided us into twelve (groups) (the Prophet's companions) each being headed by a man. Allah knows how many men were under the command of each (leader). So all of them (12 groups of men) ate of that meal."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.577]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 577

Narrated Anas:

The people mentioned the fire and the bell (they suggested those as signals to indicate the starting of prayers), and by that they mentioned the Jews and the Christians. Then Bilal was ordered to pronounce Adhan for the prayer by saying its wordings twice, and for the Iqama (the call for the actual standing for the prayers in rows) by saying its wordings once. (Iqama is pronounced when the people are ready for the prayer).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.578]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 578

Narrated Ibn 'Umar:

When the Muslims arrived at Medina, they used to assemble for the prayer, and used to guess the time for it. During those days, the practice of Adhan for the prayers had not been introduced yet. Once they discussed this problem regarding the call for prayer. Some people suggested the use of a bell like the Christians, others proposed a trumpet like the horn used by the Jews, but 'Umar was the first to suggest that a man should call (the people) for the prayer; so Allah's Apostle ordered Bilal to get up and pronounce the Adhan for prayers.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.579]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 579

Narrated Anas:

Bilal was ordered to repeat the wording of the Adhan for prayers twice, and to pronounce the wording of the Iqamas once except "Qad-qamat-is-Salat".


Bukhari :: Call to Prayers (Adhaan) :: [1.11.580]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 580

Narrated Anas bin Malik:

When the number of Muslims increased they discussed the question as to how to know the time for the prayer by some familiar means. Some suggested that a fire be lit (at the time of the prayer) and others put forward the proposal to ring the bell. Bilal was ordered to pronounce the wording of Adhan twice and of the Iqama once only.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.581]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 581

Narrated Abu Qilaba:

Anas said, "Bilal was ordered to pronounce the wording of Adhan twice and of Iqama once only." The sub narrator Isma'li said, "I mentioned that to Aiyub and he added (to that), "Except Iqama (i.e. Qad-Qamatis-Salat which should be said twice)."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.582]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 582

Narrated Abu Huraira:

Allah's Apostle said, "When the Adhan is pronounced Satan takes to his heels and passes wind with noise during his flight in order not to hear the Adhan. When the Adhan is completed he comes back and again takes to his heels when the Iqama is pronounced and after its completion he returns again till he whispers into the heart of the person (to divert his attention from his prayer) and makes him remember things which he does not recall to his mind before the prayer and that causes him to forget how much he has prayed."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.583]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 583

Narrated 'Abdul Rahman:

Abu Sa'id Al-Khudri told my father, "I see you liking sheep and the wilderness. So whenever you are with your sheep or in the wilderness and you want to pronounce Adhan for the prayer raise your voice in doing so, for whoever hears the Adhan, whether a human being, a jinn or any other creature, will be a witness for you on the Day of Resurrection." Abu Said added, "I heard it (this narration) from Allah's Apostle."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.584]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 584

Narrated Humaid:

Anas bin Malik said, "Whenever the Prophet went out with us to fight (in Allah's cause) against any nation, he never allowed us to attack till morning and he would wait and see: if he heard Adhan he would postpone the attack and if he did not hear Adhan he would attack them." Anas added, "We reached Khaibar at night and in the morning when he did not hear the Adhan for the prayer, he (the Prophet ) rode and I rode behind Abi Talha and my foot was touching that of the Prophet.

The inhabitants of Khaibar came out with their baskets and spades and when they saw the Prophet they shouted 'Muhammad! By Allah, Muhammad and his army.' When Allah's Apostle saw them, he said, "Allahu-Akbar! Allahu-Akbar! Khaibar is ruined. Whenever we approach a (hostile) nation (to fight), then evil will be the morning of those who have been warned."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.585]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 585

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Whenever you hear the Adhan, say what the Mu'adhdhin is saying.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.586]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 586

Narrated 'Isa bin Talha:

that he had heard Muawiya repeating the words of Adhan up to "Wa ash-hadu Anna Muhammadan Rasulul-lah (and I testify that Muhammad is Allah's Apostle.)"


Bukhari :: Call to Prayers (Adhaan) :: [1.11.587]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 587

Narrated Yahya as above (586) and added:

"Some of my companions told me that Hisham had said, "When the Mu'adhdhin said, "Haiya alas-sala(t) (come for the prayer)." Muawiya said, "La hawla wala quwata illa billah (There is neither might nor any power except with Allah)" and added, "We heard your Prophet saying the same."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.588]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 588

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "Whoever after listening to the Adhan says, 'Allahumma Rabba hadhihi-d-da' watit-tammati was-salatil qa'imati, ati Muhammadan al-wasilata wal-fadilata, wab' athhu maqaman mahmudan-il-ladhi wa' adtahu (O Allah! Lord of this perfect call (of not ascribing partners to You) and of the regular prayer which is going to be established! Kindly give Muhammad the right of intercession and superiority and send him (on the Day of Judgment) to the best and the highest place in Paradise which You promised him)', then intercession for me will be permitted for him on the Day of Resurrection").


Bukhari :: Call to Prayers (Adhaan) :: [1.11.589]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 589

Narrated Abu Huraira:

Allah's Apostle said, "If the people knew the reward for pronouncing the Adhan and for standing in the first row (in congregational prayers) and found no other way to get that except by drawing lots they would draw lots, and if they knew the reward of the Zuhr prayer (in the early moments of its stated time) they would race for it (go early) and if they knew the reward of 'Isha' and Fajr (morning) prayers in congregation, they would come to offer them even if they had to crawl."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.590]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 590

Narrated 'Abdullah bin Al-Harith:

Once on a rainy muddy day, Ibn 'Abbas delivered a sermon in our presence and when the Mu'adhdhin pronounced the Adhan and said, "Haiya ala-s-sala(t) (come for the prayer)" Ibn 'Abbas ordered him to say 'Pray at your homes.' The people began to look at each other (surprisingly). Ibn 'Abbas said. "It was done by one who was much better than I (i.e. the Prophet or his Mu'adhdhin), and it is a license.'


Bukhari :: Call to Prayers (Adhaan) :: [1.11.591]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 591

Narrated Salim bin Abdullah:

My father said that Allah s Apostle said, "Bilal pronounces 'Adhan at night, so keep on eating and drinking (Suhur) till Ibn Um Maktum pronounces Adhan." Salim added, "He was a blind man who would not pronounce the Adhan unless he was told that the day had dawned."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.592]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 592

Narrated Hafsa:

When the Muadh-dhin pronounced the Adhan for Fajr prayer and the dawn became evident the Prophet ordered a two Rakat light prayer (Sunna) before the Iqama of the compulsory (congregational) prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.593]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 593

Narrated 'Aisha:

The Prophet used to offer two light Rakat between the Adhan and the Iqama of the Fajr prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.594]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 594

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Bilal pronounces the Adhan at night, so keep on eating and drinking (Suhur) till Ibn Um Maktum pronounces the Adhan."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.595]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 595

Narrated 'Abdullah bin Mas'ud:

The Prophet said, "The Adhan pronounced by Bilal should not stop you from taking Suhur, for he pronounces the Adhan at night, so that the one offering the late night prayer (Tahajjud) from among you might hurry up and the sleeping from among you might wake up. It does not mean that dawn or morning has started." Then he (the Prophet) pointed with his fingers and raised them up (towards the sky) and then lowered them (towards the earth) like this (Ibn Mas'ud imitated the gesture of the Prophet). Az-Zuhri gestured with his two index fingers which he put on each other and then stretched them to the right and left. These gestures illustrate the way real dawn appears. It spreads left and right horizontally. The dawn that appears in the high sky and lowers down is not the real dawn) .


Bukhari :: Call to Prayers (Adhaan) :: [1.11.596]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 596

Narrated 'Aisha:

The Prophet said, "Bilal pronounces the Adhan at night, so eat and drink (Suhur) till Ibn Um Maktum pronounces the Adhan."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.597]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 597

Narrated 'Abdullah bin Mughaffal Al-Muzani:

Allah's Apostle said thrice, "There is a prayer between the two Adhans (Adhan and Iqama)," and added, "For the one who wants to pray."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.598]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 598

Narrated Anas bin Malik:

"When the Mu'adhdhin pronounced the Adhan, some of the companions of the Prophet would proceed to the pillars of the mosque (for the prayer) till the Prophet arrived and in this way they used to pray two Rakat before the Maghrib prayer. There used to be a little time between the Adhan and the Iqama." Shu'ba said, "There used to be a very short interval between the two (Adhan and Iqama)."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.599]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 599

Narrated 'Aisha:

Allah's Apostle used to pray two light Rakat before the morning (compulsory) prayer after the day dawned and the Mu'adhdhin had finished his Adhan. He then would lie on his right side till the Mu'adhdhin came to pronounce the Iqama.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.600]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 600

Narrated 'Abdullah bin Mughaffal:

The prophet said, "There is a prayer between the two Adhans (Adhan and Iqama), there is a prayer between the two Adhans." And then while saying it the third time he added, "For the one who wants to (pray)."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.601]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 601

Narrated Malik bin Huwairth:

I came to the Prophet with some men from my tribe and stayed with him for twenty nights. He was kind and merciful to us. When he realized our longing for our families, he said to us, "Go back and stay with your families and teach them the religion, and offer the prayer and one of you should pronounce the Adhan for the prayer when its time is due and the oldest one amongst you should lead the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.602]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 602

Narrated Abu Dhar:

We were in the company of the Prophet on a journey and the Mu'adhdhin wanted to pronounce the Adhan for the (Zuhr) prayer. The Prophet said to him, "Let it become cooler." Then he again wanted to pronounce the Adhan but the Prophet; said to him, "Let it become cooler." The Mu'adh-dhin again wanted to pronounce the Adhan for the prayer but the Prophet said, "Let it become cooler," till the shadows of the hillocks become equal to their sizes. The Prophet added, "The severity of the heat is from the raging of Hell."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.603]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 603

Narrated Malik bin Huwairth:

Two men came to the Prophet with the intention of a journey. The Prophet said, "When (both of) you set out, pronounce Adhan and then Iqama and the oldest of you should lead the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.604]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 604

Narrated Malik:

We came to the Prophet and stayed with him for twenty days and nights. We were all young and of about the same age. The Prophet was very kind and merciful. When he realized our longing for our families, he asked about our homes and the people there and we told him. Then he asked us to go back to our families and stay with them and teach them (the religion) and to order them to do good things. He also mentioned some other things which I have (remembered or) forgotten. The Prophet then added, "Pray as you have seen me praying and when it is the time for the prayer one of you should pronounce the Adhan and the oldest of you should lead the prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.605]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 605

Narrated Nafi:

Once in a cold night, Ibn 'Umar pronounced the Adhan for the prayer at ,Dajnan (the name of a mountain) and then said, "Pray at your homes", and informed us that Allah's Apostle used to tell the Mu'adhdin to pronounce Adhan and say, "Pray at your homes" at the end of the Adhan on a rainy or a very cold night during the journey."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.606]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 606

Narrated 'Aun bin Abi Juhaifa:

My father said, "I saw Allah's Apostle at a place called Al-Abtah. Bilal came and informed him about the prayer and then came out with an Anza and planted it in front of Allah's Apostle at Al-Abtah and pronounced the Iqama."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.607]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 607

Narrated 'Aun bin Abi Juhaifa:

My father said, "I saw Bilal turning his face from side to side while pronouncing the Adhan for the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.608]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 608

Narrated 'Abdullah bin Abi Qatada:

My father said, "While we were praying with the Prophet he heard the noise of some people. After the prayer he said, 'What is the matter?' They replied 'We were hurrying for the prayer.' He said, 'Do not make haste for the prayer, and whenever you come for the prayer, you should come with calmness, and pray whatever you get (with the people) and complete the rest which you have missed."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.609]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 609

Narrated Abu Huraira:

The Prophet said, "When you hear the Iqama, proceed to offer the prayer with calmness and solemnity and do not make haste. And pray whatever you are able to pray and complete whatever you have missed.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.610]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 610

Narrated 'Abdullah bin Abi Qatada:

My father said. "Allah's Apostle said, 'If the Iqama is pronounced then do not stand for the prayer till you see me (in front of you).' "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.611]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 611

Narrated 'Abdullah bin Abi:

Qatada, My father said, "Allah's Apostle said, 'If the Iqama is pronounced, then do not stand for the prayer till you see me (in front of you) and do it calmly.' "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.612]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 612

Narrated Abu Huraira:

Allah's Apostle went out (of the mosque) when the Iqama had been pronounced and the rows straightened. The Prophet stood at his Musalla (praying place) and we waited for the Prophet to begin the prayer with Takbir. He left and asked us to remain in our places. We kept on standing till the Prophet returned and the water was trickling from his head for he had taken a bath (of Janaba).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.613]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 613

Narrated Abu Huraira:

Once iqama was pronounced and the people had straightened the rows, Allah's Apostle went forward (to lead the prayer) but he was Junub, so he said, "Remain in your places." And he went out, took a bath and returned with water trickling from his head. Then he led the prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.614]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 614

Narrated Jabir bin 'Abdullah:

On the day of Al-Khandaq (the trench), 'Umar bin Al-Khattab went to the Prophet and said, "O Allah's Apostle! By Allah, I could not pray (the 'Asr) till the sun had set." 'Umar told this to the Prophet at the time when a fasting person had done Iftar (taken his meals). The Prophet then went to Buthan and I was with him. He performed ablution and offered the 'Asr prayer after the sun had set and then the Maghrib prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.615]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 615

Narrated Anas:

Once the Iqama was pronounced and the Prophet was talking to a man (in a low voice) in a corner of the mosque and he did not lead the prayer till (some of) the people had slept (dozed in a sitting posture) .


Bukhari :: Call to Prayers (Adhaan) :: [1.11.616]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 616

Narrated Anas bin Malik:

Once Iqama was pronounced a man came to the Prophet and detained him (from the prayer).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.617]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 617

Narrated Abu Huraira:

Allah's Apostle said, "By Him in Whose Hand my soul is I was about to order for collecting fire-wood (fuel) and then order Someone to pronounce the Adhan for the prayer and then order someone to lead the prayer then I would go from behind and burn the houses of men who did not present themselves for the (compulsory congregational) prayer. By Him, in Whose Hands my soul is, if anyone of them had known that he would get a bone covered with good meat or two (small) pieces of meat present in between two ribs, he would have turned up for the 'Isha' prayer.'


Bukhari :: Call to Prayers (Adhaan) :: [1.11.618]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 618

Narrated 'Abdullah bin Umar:

Allah's Apostle said, "The prayer in congregation is twenty seven times superior to the prayer offered by person alone."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.619]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 619

Narrated Abu Said Al-Khudri:

The Prophet said, "The prayer in congregation is twenty five times superior to the prayer offered by person alone."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.620]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 620

Narrated Abu Huraira:

Allah's Apostle said, "The reward of the prayer offered by a person in congregation is twenty five times greater than that of the prayer offered in one's house or in the market (alone). And this is because if he performs ablution and does it perfectly and then proceeds to the mosque with the sole intention of praying, then for every step he takes towards the mosque, he is upgraded one degree in reward and his one sin is taken off (crossed out) from his accounts (of deeds). When he offers his prayer, the angels keep on asking Allah's Blessings and Allah's forgiveness for him as long as he is (staying) at his Musalla. They say, 'O Allah! Bestow Your blessings upon him, be Merciful and kind to him.' And one is regarded in prayer as long as one is waiting for the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.621]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 621

Narrated Abu Salama bin 'Abdur Rahman:

Abu Huraira said, "I heard Allah's Apostle saying, 'The reward of a prayer in congregation is twenty five times greater than that of a prayer offered by a person alone. The angels of the night and the angels of the day gather at the time of Fajr prayer.' " Abu Huraira then added, "Recite the Holy Book if you wish, for "Indeed, the recitation of the Qur'an in the early dawn (Fajr prayer) is ever witnessed." (17.18).

Narrated 'Abdullah bin 'Umar: The reward of the congregational prayer is twenty seven times greater (than that of the prayer offered by a person alone).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.622]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 622

Narrated Salim:

I heard Um Ad-Darda' saying, "Abu Ad-Darda' entered the house in an angry mood. I said to him. 'What makes you angry?' He replied, 'By Allah! I do not find the followers of Muhammad doing those good things (which they used to do before) except the offering of congregational prayer." (This happened in the last days of Abu Ad-Darda' during the rule of 'Uthman) .


Bukhari :: Call to Prayers (Adhaan) :: [1.11.623]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 623

Narrated Abu Musa:

The Prophet said, "The people who get tremendous reward for the prayer are those who are farthest away (from the mosque) and then those who are next farthest and so on. Similarly one who waits to pray with the Imam has greater reward than one who prays and goes to bed. "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.624]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 624

Narrated Abu Huraira:

Allah's Apostle said, "While a man was going on a way, he saw a thorny branch and removed it from the way and Allah became pleased by his action and forgave him for that." Then the Prophet said, "Five are martyrs: One who dies of plague, one who dies of an abdominal disease, one who dies of drowning, one who is buried alive (and) dies and one who is killed in Allah's cause." (The Prophet further said, "If the people knew the reward for pronouncing the Adhan and for standing in the first row (in the congregational prayer) and found no other way to get it except by drawing lots they would do so, and if they knew the reward of offering the Zuhr prayer early (in its stated time), they would race for it and they knew the reward for 'Isha' and Fajr prayers in congregation, they would attend them even if they were to crawl')


Bukhari :: Call to Prayers (Adhaan) :: [1.11.625]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 625

Narrated Humaid:

Anas said, "The Prophet said, 'O Bani Salima! Don't you think that for every step of yours (that you take towards the mosque) there is a reward (while coming for prayer)?" Mujahid said: "Regarding Allah's Statement: "We record that which they have sent before (them), and their traces" (36.12). 'Their traces' means 'their steps.' " And Anas said that the people of Bani Salima wanted to shift to a place near the Prophet but Allah's Apostle disliked the idea of leaving their houses uninhabited and said, "Don't you think that you will get the reward for your footprints." Mujahid said, "Their foot prints mean their foot steps and their going on foot."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.626]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 626

Narrated Abu Huraira:

The Prophet said, "No prayer is harder for the hypocrites than the Fajr and the 'Isha' prayers and if they knew the reward for these prayers at their respective times, they would certainly present themselves (in the mosques) even if they had to c awl." The Prophet added, "Certainly I decided to order the Mu'adh-dhin (call-maker) to pronounce Iqama and order a man to lead the prayer and then take a fire flame to burn all those who had not left their houses so far for the prayer along with their houses."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.627]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 627

Narrated Malik bin Huwairith:

Prophet said (to two persons), "Whenever the prayer time becomes due, you should pronounce Adhan and then Iqama and the older of you should lead the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.628]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 628

Narrated Abu Huraira:

Allah's Apostle said, "The angels keep on asking for Allah's Blessing and Forgiveness for anyone of you as long as he is at his Musalla (praying place) and does not do Hadath (passes wind). The angels say, 'O Allah! Forgive him and be Merciful to him.' Each one of you is in the prayer as long as he is waiting for the prayer and nothing but the prayer detains him from going to his family."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.629]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 629

Narrated Abu Huraira:

The Prophet said, "Allah will give shade, to seven, on the Day when there will be no shade but His. (These seven persons are) a just ruler, a youth who has been brought up in the worship of Allah (i.e. worships Allah sincerely from childhood), a man whose heart is attached to the mosques (i.e. to pray the compulsory prayers in the mosque in congregation), two persons who love each other only for Allah's sake and they meet and part in Allah's cause only, a man who refuses the call of a charming woman of noble birth for illicit intercourse with her and says: I am afraid of Allah, a man who gives charitable gifts so secretly that his left hand does not know what his right hand has given (i.e. nobody knows how much he has given in charity), and a person who remembers Allah in seclusion and his eyes are then flooded with tears."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.630]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 630

Narrated Humaid:

Anas was asked, "Did Allah's Apostle wear a ring?" He said, "Yes. Once he delayed the 'Isha' prayer till mid-night and after the prayer, he faced us and said, 'The people prayed and have slept and you remained in prayer as long as you waited for it.' " Anas added, "As if I were just now observing the glitter of his ring."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.631]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 631

Narrated Abu Huraira:

The Prophet said, "Allah will prepare for him who goes to the mosque (every) morning and in the afternoon (for the congregational prayer) an honorable place in Paradise with good hospitality for (what he has done) every morning and afternoon goings.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.632]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 632

Narrated Malik Ibn Buhaina:

Allah's Apostle passed by a man praying two Rakat after the Iqama (had been pronounced). When Allah's Apostle completed the prayer, the people gathered around him (the Prophet) or that man and Allah's Apostle said to him (protesting), Are there four Rakat in Fajr prayer? Are there four Rakat in Fajr prayer?"


Bukhari :: Call to Prayers (Adhaan) :: [1.11.633]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 633

Narrated Al-Aswad:

"We were with 'Aisha discussing the regularity of offering the prayer and dignifying it. She said, 'When Allah's Apostle fell sick with the fatal illness and when the time of prayer became due and Adhan was pronounced, he said, 'Tell Abu Bakr to lead the people in prayer.' He was told that Abu Bakr was a soft-hearted man and would not be able to lead the prayer in his place. The Prophet gave the same order again but he was given the same reply. He gave the order for the third time and said, 'You (women) are the companions of Joseph. Tell Abu Bakr to lead the prayer.' So Abu Bakr came out to lead the prayer. In the meantime the condition of the Prophet improved a bit and he came out with the help of two men one on each side. As if I was observing his legs dragging on the ground owing to the disease. Abu Bakr wanted to retreat but the Prophet beckoned him to remain at his place and the Prophet was brought till he sat beside Abu Bakr." Al-A'mash was asked, "Was the Prophet praying and Abu Bakr following him, and were the people following Abu Bakr in that prayer?" Al-A'mash replied in the affirmative with a nod of his head. Abu Muawiya said, "The Prophet was sitting on the left side of Abu Bakr who was praying while standing."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.634]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 634

Narrated 'Aisha:

"When the Prophet became seriously ill and his disease became aggravated he asked for permission from his wives to be nursed in my house and he was allowed. He came out with the help of two men and his legs were dragging on the ground. He was between Al-Abbas and another man."

'Ubaid Ullah said, "I told Ibn 'Abbas what 'Aisha had narrated and he said, 'Do you know who was the (second) man whose name 'Aisha did not mention'" I said, 'No.' Ibn 'Abbas said, 'He was 'Ali Ibn Abi Talib.' "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.635]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 635

Narrated Nafi':

Once on a very cold and stormy night, Ibn 'Umar pronounced the Adhan for the prayer and then said, "Pray in your homes." He (Ibn 'Umar) added. "On very cold and rainy nights Allah's Apostle used to order the Mu'adhdhin to say, 'Pray in your homes.' "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.636]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 636

Narrated Mahmuid bin Rabi' Al-Ansari:

'Itban bin Malik used to lead his people (tribe) in prayer and was a blind man, he said to Allah's Apostle , "O Allah's Apostle! At times it is dark and flood water is flowing (in the valley) and I am blind man, so please pray at a place in my house so that I can take it as a Musalla (praying place)." So Allah's Apostle went to his house and said, "Where do you like me to pray?" 'Itban pointed to a place in his house and Allah's Apostle, offered the prayer there.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.637]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 637

Narrated 'Abdullah bin Al-Harith:

Ibn Abbas addressed us on a (rainy and) muddy day and when the Mu'adh-dhin said, "Come for the prayer" Ibn 'Abbas ordered him to say, "Pray in your homes." The people began to look at one another with surprise as if they did not like it. Ibn 'Abbas said, "It seems that you thought ill of it but no doubt it was done by one who was better than I (i.e. the Prophet). It (the prayer) is a strict order and I disliked to bring you out."

Ibn 'Abbas narrated the same as above but he said, "I did not like you to make you sinful (in refraining from coming to the mosque) and to come (to the mosque) covered with mud up to the knees."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.638]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 638

Narrated Abu Sa'id Al-Khudri:

A cloud came and it rained till the roof started leaking and in those days the roof used to be of the branches of date-palms. Iqama was pronounced and I saw Allah's Apostles prostrating in water and mud and even I saw the mark of mud on his forehead.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.639]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 639

Narrated Anas bin Sirin:

I heard Anas saying, "A man from Ansar said to the Prophet, 'I cannot pray with you (in congregation).' He was a very fat man and he prepared a meal for the Prophet and invited him to his house. He spread out a mat for the Prophet, and washed one of its sides with water, and the Prophet prayed two Rakat on it." A man from the family of Al-Jaruid asked, "Did the Prophet used to pray the Duha (forenoon) prayer?" Anas said, "I did not see him praying the Duha prayer except on that day."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.640]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 640

Narrated 'Aisha:

The Prophet said, "If supper is served, and Iqama is pronounced one should start with the supper."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.641]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 641

Narrated Anas bin Malik:

Allah's Apostle said, "If the supper is served start having it before praying the Maghrib prayer and do not be hasty in finishing it."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.642]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 642

Narrated Nafi':

Ibn 'Umar said, "Allah's Apostle said, 'If the supper is served for anyone of you and the Iqama is pronounced, start with the supper and don't be in haste (and carry on eating) till you finish it." If food was served for Ibn 'Umar and Iqama was pronounced, he never came to the prayer till he finished it (i.e. food) in spite of the fact that he heard the recitation (of the Qur'an) by the Imam (in the prayer). Narrated Ibn 'Umar: The Prophet said, "If anyone of you is having his meals, he should not hurry up till he is; satisfied even if the prayer has been started."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.643]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 643

Narrated Ja'far bin 'Amr bin Umaiya:

My father said, "I saw Allah's Apostle eating a piece of meat from the shoulder of a sheep and he was called for the prayer. He stood up, put down the knife and prayed but did not perform ablutilon.''


Bukhari :: Call to Prayers (Adhaan) :: [1.11.644]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 644

Narrated Al-Aswad:

That he asked 'Aisha "What did the Prophet use to do in his house?" She replied, "He used to keep himself busy serving his family and when it was the time for prayer he would go for it."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.645]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 645

Narrated Aiyub:

Abu Qilaba said, "Malik bin Huwairith came to this Mosque of ours and said, 'I pray in front of you and my aim is not to lead the prayer but to show you the way in which the Prophet used to pray.' " I asked Abu Qilaba,"How did he use to pray?' " He replied, "(The Prophet used to pray) like this Sheikh of ours and the Sheikh used to sit for a while after the prostration, before getting up after the first Rak'a. "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.646]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 646

Narrated Abu Musa:

"The Prophet became sick and when his disease became aggravated, he said, "Tell Abu Bakr to lead the prayer." 'Aisha said, "He is a soft-hearted man and would not be able to lead the prayer in your place." The Prophet said again, "Tell Abu Bakr to lead the people in prayer." She repeated the same reply but he said, "Tell Abu Bakr to lead the people in prayer. You are the companions of Joseph." So the messenger went to Abu Bakr (with that order) and he led the people in prayer in the lifetime of the Prophet.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.647]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 647

Narrated 'Aisha:

the mother of the believers: Allah's Apostle in his illness said, "Tell Abu Bakr to lead the people in prayer." I said to him, "If Abu Bakr stands in your place, the people would not hear him owing to his (excessive) weeping. So please order 'Umar to lead the prayer." 'Aisha added I said to Hafsa, "Say to him: If Abu Bakr should lead the people in the prayer in your place, the people would not be able to hear him owing to his weeping; so please, order 'Umar to lead the prayer." Hafsa did so but Allah's Apostle said, "Keep quiet! You are verily the Companions of Joseph. Tell Abu Bakr to lead the people in the prayer. " Hafsa said to 'Aisha, "I never got anything good from you."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.648]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 648

Narrated Az-Zuhn:

Anas bin Malik Al-Ansari, told me, "Abu Bakr used to lead the people in prayer during the fatal illness of the Prophet till it was Monday. When the people aligned (in rows) for the prayer the Prophet lifted the curtain of his house and started looking at us and was standing at that time. His face was (glittering) like a page of the Qur'an and he smiled cheerfully. We were about to be put to trial for the pleasure of seeing the Prophet, Abu Bakr retreated to join the row as he thought that the Prophet would lead the prayer. The Prophet beckoned us to complete the prayer and he let the curtain fall. On the same day he died."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.649]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 649

Narrated Anas:

The Prophet did not come out for three days. The people stood for the prayer and Abu Bakr went ahead to lead the prayer. (In the meantime) the Prophet caught hold of the curtain and lifted it. When the face of the Prophet appeared we had never seen a scene more pleasing than the face of the Prophet as it appeared then. The Prophet beckoned to Abu Bakr to lead the people in the prayer and then let the curtain fall. We did not see him (again) till he died.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.650]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 650

Narrated Hamza bin 'Abdullah:

My father said, "When Allah's Apostle became seriously ill, he was told about the prayer. He said, 'Tell Abu Bakr to lead the people in the prayer.' 'Aisha said, 'Abu Bakr is a soft-hearted man and he would be over-powered by his weeping if he recited the Qur'an.' He said to them, 'Tell him (Abu Bakr) to lead the prayer. The same reply was given to him. He said again, 'Tell him to lead the prayer. You (women) are the companions of Joseph."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.651]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 651

Narrated 'Urwa's father:

'Aisha said, "Allah's Apostle ordered Abu Bakr to lead the people in the prayer during his illness and so he led them in prayer." 'Urwa, a sub narrator, added, "Allah's Apostle felt a bit relieved and came out and Abu Bakr was leading the people. When Abu Bakr saw the Prophet he retreated but the Prophet beckoned him to remain there. Allah's Apostle sat beside Abu Bakr. Abu Bakr was following the prayer of Allah's Apostle and the people were following the prayer of Abu Bakr."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.652]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 652

Narrated Sahl bin Sa'd As-Sa'idi:

Allah's Apostle went to establish peace among Bani 'Amr bin 'Auf. In the meantime the time of prayer was due and the Mu'adh-dhin went to Abu Bakr and said, "Will you lead the prayer, so that I may pronounce the Iqama?" Abu Bakr replied in the affirmative and led the prayer. Allah's Apostle came while the people were still praying and he entered the rows of the praying people till he stood in the (first row). The people clapped their hands. Abu Bakr never glanced sideways in his prayer but when the people continued clapping, Abu Bakr looked and saw Allah's Apostle. Allah's Apostle beckoned him to stay at his place. Abu Bakr raised his hands and thanked Allah for that order of Allah's Apostle and then he retreated till he reached the first row. Allah's Apostle went forward and led the prayer. When Allah's Apostle finished the prayer, he said, "O Abu Bakr! What prevented you from staying when I ordered you to do so?"

Abu Bakr replied, "How can Ibn Abi Quhafa (Abu Bakr) dare to lead the prayer in the presence of Allah's Apostle?" Then Allah's Apostle said, "Why did you clap so much? If something happens to anyone during his prayer he should say Subhan Allah. If he says so he will be attended to, for clapping is for women."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.653]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 653

Narrated Malik bin Huwairth:

We went to the Prophet and we were all young men and stayed with him for about twenty nights. The Prophet was very merciful. He said, "When you return home, impart religious teachings to your families and tell them to offer perfectly such and such a prayer at such and such a time and such and such a prayer at such and such a time. And al the time of the prayer one of you should pronounce the Adhan and the oldest of you should lead the prayer."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.654]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 654

Narrated Itban bin Malik Al-Ansari:

The Prophet (came to my house and) asked permission for entering and I allowed him. He asked, "Where do you like me to pray in your house?" I pointed to a place which I liked. He stood up for prayer and we aligned behind him and he finished the prayer with Taslim and we did the same.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.655]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 655

Narrated 'Ubaid-Ullah Ibn 'Abdullah bin 'Utba:

I went to 'Aisha and asked her to describe to me the illness of Allah's Apostle. 'Aisha said, "Yes. The Prophet became seriously ill and asked whether the people had prayed. We replied, 'No. O Allah's Apostle! They are waiting for you.' He added, 'Put water for me in a trough." 'Aisha added, "We did so. He took a bath and tried to get up but fainted. When he recovered, he again asked whether the people had prayed. We said, 'No, they are waiting for you. O Allah's Apostle,' He again said, 'Put water in a trough for me.' He sat down and took a bath and tried to get up but fainted again. Then he recovered and said, 'Have the people prayed?' We replied, 'No, they are waiting for you. O Allah's Apostle.' He said, 'Put water for me in the trough.' Then he sat down and washed himself and tried to get up but he fainted. When he recovered, he asked, 'Have the people prayed?' We said, 'No, they are waiting for you. O Allah's Apostle! The people were in the mosque waiting for the Prophet for the 'Isha prayer. The Prophet sent for Abu Bakr to lead the people in the prayer. The messenger went to Abu Bakr and said, 'Allah's Apostle orders you to lead the people in the prayer.' Abu Bakr was a soft-hearted man, so he asked 'Umar to lead the prayer but 'Umar replied, 'You are more rightful.' So Abu Bakr led the prayer in those days. When the Prophet felt a bit better, he came out for the Zuhr prayer with the help of two persons one of whom was Al-'Abbas. while Abu Bakr was leading the people in the prayer. When Abu Bakr saw him he wanted to retreat but the Prophet beckoned him not to do so and asked them to make him sit beside Abu Bakr and they did so. Abu Bakr was following the Prophet (in the prayer) and the people were following Abu Bakr. The Prophet (prayed) sitting."

'Ubaid-Ullah added "I went to 'Abdullah bin 'Abbas and asked him, Shall I tell you what Aisha has told me about the fatal illness of the Prophet?' Ibn 'Abbas said, 'Go ahead. I told him her narration and he did not deny anything of it but asked whether 'Aisha told me the name of the second person (who helped the Prophet ) along with Al-Abbas. I said. 'No.' He said, 'He was 'Ali (Ibn Abi Talib).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.656]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 656

Narrated Aisha:

the mother of the believers: Allah's Apostle during his illness prayed at his house while sitting whereas some people prayed behind him standing. The Prophet beckoned them to sit down. On completion of the prayer, he said, 'The Imam is to be followed: bow when he bows, raise up your heads (stand erect) when he raises his head and when he says, 'Sami a-l-lahu liman-hamida ' (Allah heard those who sent praises to Him) say then 'Rabbana wa laka-l-hamd' (O our Lord! All the praises are for You), and if he prays sitting then pray sitting."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.657]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 657

Narrated Anas bin Malik:

Once Allah's Apostle rode a horse and fell down and the right side (of his body) was injured. He offered one of the prayers while sitting and we also prayed behind him sitting. When he completed the prayer, he said, "The Imam is to be followed. Pray standing if he prays standing and bow when he bows; rise when he rises; and if he says, 'Sami a-l-lahu-liman hamida, say then, 'Rabbana wa Lakal-hamd' and pray standing if he prays standing and pray sitting (all of you) if he prays sitting."

Humaid said: The saying of the Prophet "Pray sitting, if he (Imam) prays sitting" was said in his former illness (during his early life) but the Prophet prayed sitting afterwards (in the last illness) and the people were praying standing behind him and the Prophet did not order them to sit. We should follow the latest actions of the Prophet.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.658]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 658

Narrated Al-Bara:

(and he was not a liar) When Allah's Apostle said, "Sami a-l-lahu Liman hamida " none of us bent his back (for prostrations) till the Prophet prostrated and then we would prostrate after him.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.659]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 659

Narrated Abu Ishaq:

as above.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.660]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 660

Narrated Abu Huraira:

The Prophet said, "Isn't he who raises his head before the Imam afraid that Allah may transform his head into that of a donkey or his figure (face) into that of a donkey?"


Bukhari :: Call to Prayers (Adhaan) :: [1.11.661]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 661

Narrated Ibn 'Umar:

When the earliest emigrants came to Al-'Usba a place in Quba', before the arrival of the Prophet- Salim, the slave of Abu Hudhaifa, who knew the Qur'an more than the others used to lead them in prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.662]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 662

Narrated Anas:

The Prophet said, "Listen and obey (your chief) even if an Ethiopian whose head is like a raisin were made your chief."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.663]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 663

Narrated Abu Huraira:

Allah's Apostle said, "If the Imam leads the prayer correctly then he and you will receive the rewards but if he makes a mistake (in the prayer) then you will receive the reward for the prayer and the sin will be his."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.664]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 664

Narrated Anas bin Malik:

The Prophet said to Abu-Dhar, "Listen and obey (your chief) even if he is an Ethiopian with a head like a raisin."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.665]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 665

Narrated Ibn 'Abbas:

Once I passed the night in the house of my aunt Maimuna. Allah's Apostle offered the 'Isha' prayer and then came to the house and offered four Rakat an slept. Later on, he woke up and stood for the prayer and I stood on his left side. He drew me to his right and prayed five Rakat and then two. He then slept till I heard him snoring (or heard his breath sounds). Afterwards he went out for the morning prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.666]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 666

Narrated Ibn 'Abbas:

One night I slept at the house of (my aunt) Maimuna and the Prophet was there on that night. He performed ablution and stood up for the prayer. I joined him and stood on his left side but he drew me to his right and prayed thirteen Rakat and then slept till I heard his breath sounds. And whenever he slept, he used to breathe with audible sounds. The Mu'adhdhin came to the Prophet and he went out and prayed the morning prayer) without repeating the ablution.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.667]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 667

Narrated Ibn 'Abbas:

Once I passed the night in the house of my aunt Maimuna. The Prophet stood for the night prayer and I joined him and stood on his left side but he drew me to his right by holding me by the head.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.668]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 668

Narrated Mu'adh bin Jabal:

I used to pray the 'Isha prayer with the Prophet and then go to lead my people in the prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.669]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 669

Narrated 'Amr:

Jabir bin 'Abdullah said, "Mu'adh bin Jabal used to pray with the Prophet and then go to lead his people in prayer Once he led the 'Isha' prayer and recited Surat "Al-Baqra." Somebody left the prayer and Mu'adh criticized him. The news reached the Prophet and he said to Mu'adh, 'You are putting the people to trial,' and repeated it thrice (or said something similar) and ordered him to recite two medium Suras of Mufassal." ('Amr said that he had forgotten the names of those Suras).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.670]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 670

Narrated Abu Mas'ud:

A man came and said, "O Allah's Apostle! By Allah, I keep away from the morning prayer only because So and so prolongs the prayer when he leads us in it." The narrator said, "I never saw Allah's Apostle more furious in giving advice than he was at that time. He then said, "Some of you make people dislike good deeds (the prayer). So whoever among you leads the people in prayer should shorten it because among them are the weak, the old and the needy."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.671]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 671

Narrated Abu Huraira:

Allah's Apostle said, "If anyone of you leads the people in the prayer, he should shorten it for amongst them are the weak, the sick and the old; and if anyone among your prays alone then he may prolong (the prayer) as much as he wishes. "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.672]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 672

Narrated Abu Mas'ud:

A man came and said, "O Allah's Apostle! I keep away from the morning prayer because so-and-so (Imam) prolongs it too much." Allah's Apostle became furious and I had never seen him more furious than he was on that day. The Prophet said, "O people! Some of you make others dislike the prayer, so whoever becomes an Imam he should shorten the prayer, as behind him are the weak, the old and the needy.''


Bukhari :: Call to Prayers (Adhaan) :: [1.11.673]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 673

Narrated Jabir bin 'Abdullah Al-Ansari:

Once a man was driving two Nadihas (camels used for agricultural purposes) and night had fallen. He found Mu'adh praying so he made his camel kneel and joined Mu'adh in the prayer. The latter recited Surat 'AlBaqara" or Surat "An-Nisa", (so) the man left the prayer and went away. When he came to know that Mu'adh had criticized him, he went to the Prophet, and complained against Mu'adh. The Prophet said thrice, "O Mu'adh ! Are you putting the people to trial?" It would have been better if you had recited "Sabbih Isma Rabbika-l-a-la (87)", Wash-Shamsi wadu-haha (91)", or "Wal-laili Idha yaghsha (92)", for the old, the weak and the needy pray behind you." Jabir said that Mu'adh recited Sura Al-Baqara in the 'Isha' prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.674]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 674

Narrated Anas:

The Prophet used to pray a short prayer (in congregation) but used to offer it in a perfect manner.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.675]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 675

Narrated 'Abdullah bin 'Abi Qatada:

My father said, "The Prophet said, 'When I stand for prayer, I intend to prolong it but on hearing the cries of a child, I cut it short, as I dislike to trouble the child's mother.' "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.676]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 676

Narrated Anas bin Malik:

I never prayed behind any Imam a prayer lighter and more perfect than that behind the Prophet and he used to cut short the prayer whenever he heard the cries of a child lest he should put the child's mother to trial.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.677]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 677

Narrated Anas bin Malik:

The Prophet said, "When I start the prayer I intend to prolong it, but on hearing the cries of a child, I cut short the prayer because I know that the cries of the child will incite its mother's passions."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.678]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 678

Narrated Anas bin Malik:

The Prophet, said, "Whenever I start the prayer I intend to prolong it, but on hearing the cries of a child, I cut short the prayer because I know that the cries of the child will incite its mother's passions."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.679]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 679

Narrated Jabir bin 'Abdullah:

Mu'adh used to pray with the Prophet and then go and lead his people (tribe) in the prayer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.680]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 680

Narrated 'Aisha:

When the Prophet, became ill in his fatal illness, Someone came to inform him about the prayer, and the Prophet told him to tell Abu Bakr to lead the people in the prayer. I said, "Abu Bakr is a soft-hearted man and if he stands for the prayer in your place, he would weep and would not be able to recite the Qur'an." The Prophet said, "Tell Abu Bakr to lead the prayer." I said the same as before. He (repeated the same order and) on the third or the fourth time he said, "You are the companions of Joseph. Tell Abu Bakr to lead the prayer." So Abu Bakr led the prayer and meanwhile the Prophet felt better and came out with the help of two men; as if I see him just now dragging his feet on the ground. When Abu Bakr saw him, he tried to retreat but the Prophet beckoned him to carry on. Abu Bakr retreated a bit and the Prophet sat on his (left) side. Abu Bakr was repeating the Takbir (Allahu Akbar) of Allah's Apostle for the people to hear.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.681]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 681

Narrated 'Aisha:

When Allah's Apostle became seriously ill, Bilal came to him for the prayer. He said, "Tell Abu Bakr to lead the people in the prayer." I said, "O Allah's Apostle! Abu Bakr is a soft-hearted man and if he stands in your place, he would not be able to make the people hear him. Will you order 'Umar (to lead the prayer)?" The Prophet said, "Tell Abu Bakr to lead the people in the prayer." Then I said to Hafsa, "Tell him, Abu i Bakr is a soft-hearted man and if he stands in his place, he would not be able to make the people hear him. Would you order 'Umar to lead the prayer?' " Hafsa did so. The Prophet said, "Verily you are the companions of Joseph. Tell Abu Bakr to lead the people in the prayer." So Abu- Bakr stood for the prayer. In the meantime Allah's Apostle felt better and came out with the help of two persons and both of his legs were dragging on the ground till he entered the mosque. When Abu Bakr heard him coming, he tried to retreat but Allah's Apostle beckoned him to carry on. The Prophet sat on his left side. Abu Bakr was praying while standing and Allah's Apostle was leading the prayer while sitting. Abu Bakr was following the Prophet and the people were following Abu Bakr (in the prayer).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.682]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 682

Narrated Abu Huraira:

Once Allah's Apostle prayed two Rakat (instead of four) and finished his prayer. Dhu-l-yadain asked him whether the prayer had been reduced or whether he had forgotten. Allah's Apostle asked the people whether Dhu-l-yadain was telling the truth. The people replied in the affirmative. Then Allah's Apostle stood up, offered the remaining two Rakat and then finished his prayer with Taslim and then said, "Allahu Akbar." He followed it with two prostrations like ordinary prostrations or a bit longer.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.683]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 683

Narrated Abu Huraira:

The Prophet prayed two Rakat of Zuhr prayer (instead of four) and he was told that he had prayed two Rakat only. Then he prayed two more Rakat and finished them with the Taslim followed by two prostrations.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.684]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 684

Narrated 'Aisha:

the mother of the faithful believers: Allah's Apostle in his last illness said, "Tell Abu Bakr to lead the people in the prayer." I said, "If Abu Bakr stood in your place, he would not be able to make the people hear him owing to his weeping. So please order 'Umar to lead the prayer." He said, "Tell Abu Bakr to lead the people in the prayer." I said to Hafsa, "Say to him, 'Abu Bakr is a softhearted man and if he stood in your place he would not be able to make the people hear him owing to his weeping. So order 'Umar to lead the people in the prayer.' " Hafsa did so but Allah's Apostle said, "Keep quiet. Verily you are the companions of (Prophet) Joseph. Tell Abu Bakr to lead the people in the prayer." Hafsa said to me, "I never got any good from you."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.685]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 685

Narrated An-Nu'man bin 'Bashir:

The Prophet said, "Straighten your rows or Allah will alter your faces."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.686]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 686

Narrated Anas:

The Prophet said, "Straighten your rows, for I see you from behind my back.'


Bukhari :: Call to Prayers (Adhaan) :: [1.11.687]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 687

Narrated Anas bin Malik:

Once the Iqama was pronounced and Allah's Apostle faced us and said, "Straighten your rows and stand closer together, for I see you from behind my back.'


Bukhari :: Call to Prayers (Adhaan) :: [1.11.688]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 688

Narrated Abu Huraira:

The Prophet said, "Martyrs are those who die because of drowning, plague, an abdominal disease, or of being buried alive by a falling building." And then he added, "If the people knew the Reward for the Zuhr prayer in its early time, they would race for it. If they knew the reward for the 'Isha' and the Fajr prayers in congregation, they would join them even if they had to crawl. If they knew the reward for the first row, they would draw lots for it."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.689]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 689

Narrated Abu Huraira:

The Prophet said, "The Imam is (appointed) to be followed. So do not differ from him, bow when he bows, and say, "Rabbana-lakal hamd" if he says "Sami'a-l-lahu Liman hamida"; and if he prostrates, prostrate (after him), and if he prays sitting, pray sitting all together, and straighten the rows for the prayer, as the straightening of the rows is amongst those things which make your prayer a correct and perfect one. (See Hadith No. 657).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.690]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 690

Narrated Anas bin Malik:

The Prophet said, "Straighten your rows as the straightening of rows is essential for a perfect and correct prayer. "


Bukhari :: Call to Prayers (Adhaan) :: [1.11.691]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 691

Narrated Anas bin Malik:

I arrived at Medina and was asked whether I found any change since the days of Allah's Apostle. I said, "I have not found any change except that you do not stand in alignment in your prayers."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.692]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 692

Narrated Anas bin Malik:

The Prophet said, "Straighten your rows for I see you from behind my back." Anas added, "Everyone of us used to put his shoulder with the shoulder of his companion and his foot with the foot of his companion."


Bukhari :: Call to Prayers (Adhaan) :: [1.11.693]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 693

Narrated Ibn 'Abbas:

I prayed with the Prophet one night and stood on his left side. Allah's Apostle caught hold of my head from behind and drew me to his right and then offered the prayer and slept. Later the Mu'adh-dhin came and the Prophet stood up for prayer without performing ablution.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.694]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 694

Narrated Anas bin Malik:

One night an orphan and I offered the prayers behind the Prophet in my house and my mother (Um Sulaim) was standing behind us (by herself forming a row).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.695]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 695

Narrated Ibn 'Abbas:

One night I stood to the left of the Prophet in the prayer but he caught hold of me by the hand or by the shoulder (arm) till he made me stand on his right and beckoned with his hand (for me) to go from behind (him). (Al-Kashmaihani-Fateh al-Bari).


Bukhari :: Call to Prayers (Adhaan) :: [1.11.696]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 696

Narrated 'Aisha:

Allah's Apostle used to pray in his room at night. As the wall of the room was LOW, the people saw him and some of them stood up to follow him in the prayer. In the morning they spread the news. The following night the Prophet stood for the prayer and the people followed him. This went on for two or three nights. Thereupon Allah's Apostle did not stand for the prayer the following night, and did not come out. In the morning, the people asked him about it. He replied, that he way afraid that the night prayer might become compulsory.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.697]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 697

Narrated 'Aisha:

The Prophet had a mat which he used to spread during the day and use as a curtain at night. So a number of people gathered at night facing it and prayed behind him.


Bukhari :: Call to Prayers (Adhaan) :: [1.11.698]

Call to Prayers (Adhaan)

Bukhari :: Book 1 :: Volume 11 :: Hadith 698

Narrated Zaid bin Thabit:

Allah's Apostle made a small room in the month of Ramadan (Sa'id said, "I think that Zaid bin Thabit said that it was made of a mat") and he prayed there for a few nights, and so some of his companions prayed behind him. When he came to know about it, he kept on sitting. In the morning, he went out to them and said, "I have seen and understood what you did. You should pray in your houses, for the best prayer of a person is that which he prays in his house except the compulsory prayers."


Bukhari :: Characteristics of Prayer :: [1.12.699]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 699

Narrated Anas bin Malik Al-Ansari:

Allah's Apostle rode a horse and fell down and the right side of his body was injured. On that day he prayed one of the prayers sitting and we also prayed behind him sitting. When the Prophet finished the prayer with Taslim, he said, "The Imam is to be followed and if he prays standing then pray standing, and bow when he bows, and raise your heads when he raises his head; prostrate when he prostrates; and if he says "Sami'a-l-lahu Liman hamida", you should say, "Rabbana wa-laka-l hamd.:


Bukhari :: Characteristics of Prayer :: [1.12.700]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 700

Narrated Anas bin Malik:

Allah's Apostle fell from a horse and got injured so he led the prayer sitting and we also prayed sitting. When he completed the prayer he said, "The Imam is to be followed; if he says Takbir then say Takbir, bow if he bows; raise your heads when he raises his head, when he says, 'Sami' a-l-lahu Liman hamida say, 'Rabbana laka-l-hamd', and prostrate when he prostrates."


Bukhari :: Characteristics of Prayer :: [1.12.701]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 701

Narrated Abu Huraira:

The Prophet said, "The Imam is to be followed. Say the Takbir when he says it; bow if he bows; if he says 'Sami a-l-lahu Liman hamida', say, ' Rabbana wa-laka-l-hamd', prostrate if he prostrates and pray sitting altogether if he prays sitting."


Bukhari :: Characteristics of Prayer :: [1.12.702]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 702

Narrated Salim bin 'Abdullah:

My father said, "Allah's Apostle used to raise both his hands up to the level of his shoulders when opening the prayer; and on saying the Takbir for bowing. And on raising his head from bowing he used to do the same and then say "Sami a-l-lahu Liman hamida, Rabbana walaka-l-hamd." And he did not do that (i.e. raising his hands) in prostrations.


Bukhari :: Characteristics of Prayer :: [1.12.703]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 703

Narrated 'Abdullah bin 'Umar:

I saw that whenever Allah's Apostle stood for the prayer, he used to raise both his hands up to the shoulders, and used to do the same on saying the Takbir for bowing and on raising his head from it and used to say, "Sami a-l-lahu Liman hamida". But he did not do that (i.e. raising his hands) in prostrations.


Bukhari :: Characteristics of Prayer :: [1.12.704]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 704

Narrated Abu Qilaba:

I saw Malik bin Huwairith saying Takbir and raising both his hands (on starting the prayers and raising his hands on bowing and also on raising his head after bowing. Malik bin Huwairith said, "Allah's Apostle did the same."


Bukhari :: Characteristics of Prayer :: [1.12.705]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 705

Narrated 'Abdullah bin 'Umar:

I saw Allah's Apostle opening the prayer with the Takbir and raising his hands to the level of his shoulders at the time of saying the Takbir, and on saying the Takbir for bowing he did the same; and when he said, "Sami a-l-lahu Liman hamida ", he did the same and then said, "Rabbana wa laka-l-hamd." But he did not do the same on prostrating and on lifting the head from it."


Bukhari :: Characteristics of Prayer :: [1.12.706]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 706

Narrated Nafi':

Whenever Ibn 'Umar started the prayer with Takbir, he used to raise his hands: whenever he bowed, he used to raise his hands (before bowing) and also used to raise his hands on saying, "Sami a-l-lahu Liman hamida", and he used to do the same on rising from the second Rak'a (for the 3rd Rak'a). Ibn 'Umar said: "The Prophet used to do the same."


Bukhari :: Characteristics of Prayer :: [1.12.707]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 707

Narrated Sahl bin Sa'd:

The people were ordered to place the right hand on the left forearm in the prayer. Abu Hazim said, "I knew that the order was from the Prophet ."


Bukhari :: Characteristics of Prayer :: [1.12.708]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 708

Narrated Abu Huraira:

Allah's Apostle said, "You see me facing the Qibla; but, by Allah, nothing is hidden from me regarding your bowing and submissiveness and I see you from behind my back."


Bukhari :: Characteristics of Prayer :: [1.12.709]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 709

Narrated Anas bin Malik:

The Prophet said, "Perform the bowing and the prostrations properly. By Allah, I see you from behind me (or from behind my back) when you bow or prostrate."


Bukhari :: Characteristics of Prayer :: [1.12.710]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 710

Narrated Anas bin Malik:

The Prophet, Abu Bakr and 'Umar used to start the prayer with "Al-hamdu lil-lahi Rabbil-'ala-min (All praises are for Allah the Lord of the Worlds)."


Bukhari :: Characteristics of Prayer :: [1.12.711]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 711

Narrated Abu Huraira:

Allah's Apostle used to keep silent between the Takbir and the recitation of Qur'an and that interval of silence used to be a short one. I said to the Prophet "May my parents be sacrificed for you! What do you say in the pause between Takbir and recitation?" The Prophet said, "I say, 'Allahumma, ba'id baini wa baina khatayaya kama ba'adta baina-l-mashriqi wa-l-maghrib. Allahumma, naqqim min khatayaya kama yunaqqa-ththawbu-l-abyadu mina-ddanas. Allahumma, ighsil khatayaya bil-ma'i wa-th-thalji wal-barad (O Allah! Set me apart from my sins (faults) as the East and West are set apart from each other and clean me from sins as a white garment is cleaned of dirt (after thorough washing). O Allah! Wash off my sins with water, snow and hail.)"


Bukhari :: Characteristics of Prayer :: [1.12.712]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 712

Narrated Asma' bint Abi Bakr:

The Prophet once offered the eclipse prayer. He stood for a long time and then did a prolonged bowing. He stood up straight again and kept on standing for a long time, then bowed a long bowing and then stood up straight and then prostrated a prolonged prostration and then lifted his head and prostrated a prolonged prostration. And then he stood up for a long time and then did a prolonged bowing and then stood up straight again and kept on standing for a long time. Then he bowed a long bowing and then stood up straight and then prostrated a prolonged prostration and then lifted his head and went for a prolonged prostration. On completion o the prayer, he said, "Paradise became s near to me that if I had dared, I would have plucked one of its bunches for you and Hell became so near to me that said, 'O my Lord will I be among those people?' Then suddenly I saw a woman and a cat was lacerating her with it claws. On inquiring, it was said that the woman had imprisoned the cat till it died of starvation and she neither fed it no freed it so that it could feed itself."


Bukhari :: Characteristics of Prayer :: [1.12.713]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 713

Narrated Abu Ma'mar:

We asked Khabbab whether Allah's Apostle used to recite (the Qur'an) in the Zuhr and the 'Asr prayers. He replied in the affirmative. We said, "How did you come to know about it?" He said, "By the movement of his beard."


Bukhari :: Characteristics of Prayer :: [1.12.714]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 714

Narrated Al-Bara:

(And Al-Bara was not a liar) Whenever we offered prayer with the Prophet and he raised his head from the bowing, we used to remain standing till we saw him prostrating .


Bukhari :: Characteristics of Prayer :: [1.12.715]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 715

Narrated 'Abdullah bin 'Abbas:

Once solar eclipse occurred during the lifetime of Allah's Apostle. He offered the eclipse prayer. His companions asked, "O Allah's Apostle! We saw you trying to take something while standing at your place and then we saw you retreating." The Prophet said, "I was shown Paradise and wanted to have a bunch of fruit from it. Had I taken it, you would have eaten from it as long as the world remains."


Bukhari :: Characteristics of Prayer :: [1.12.716]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 716

Narrated Anas bin Malik:

The Prophet led us in prayer and then went up to the pulpit and beckoned with both hands towards the Qibla of the mosque and then said, "When I started leading you in prayer, I saw the display of Paradise and Hell on the wall of the mosque (facing the Qibla). I never saw good and bad as I have seen today." He repeated the last statement thrice.


Bukhari :: Characteristics of Prayer :: [1.12.717]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 717

Narrated Anas bin Malik:

The Prophet said, "What is wrong with those people who look towards the sky during the prayer?" His talk grew stern while delivering this speech and he said, "They should stop (looking towards the sky during the prayer); otherwise their eye-sight would be taken away."


Bukhari :: Characteristics of Prayer :: [1.12.718]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 718

Narrated 'Aisha:

I asked Allah's Apostle about looking hither and thither in prayer. He replied, "It is a way of stealing by which Satan takes away (a portion) from the prayer of a person."


Bukhari :: Characteristics of Prayer :: [1.12.719]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 719

Narrated 'Aisha:

Once the Prophet prayed on a Khamisa with marks on it and said, "The marks on it diverted my attention, take this Khamisa to Abu Jahm and bring an Inbijaniya (from him.)"


Bukhari :: Characteristics of Prayer :: [1.12.720]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 720

Narrated Ibn 'Umar:

The Prophet saw expectoration in the direction of the Qibla of the mosque while he was leading the prayer, and scratched it off. After finishing the prayer, he said, "Whenever any of you is in prayer he should know that Allah is in front of him. So none should spit in front of him in the prayer."


Bukhari :: Characteristics of Prayer :: [1.12.721]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 721

Narrated Anas:

While the Muslims were offering the Fajr prayer, Al lah's Apostle suddenly appeared before them by living the curtain of the dwelling place of 'Aisha, looked towards the Muslims who were standing in rows. He smiled with pleasure. Abu Bakr started retreating to join the row on the assumption that the Prophet wanted to come out for the prayer. The Muslims intended to leave the prayer (and were on the verge of being put to trial), but the Prophet beckoned them to complete their prayer and then he let the curtain fall. He died in the last hours of that day.


Bukhari :: Characteristics of Prayer :: [1.12.722]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 722

Narrated Jabir bin Samura:

The People of Kufa complained against Sa'd to 'Umar and the latter dismissed him and appointed 'Ammar as their chief . They lodged many complaints against Sa'd and even they alleged that he did not pray properly. 'Umar sent for him and said, "O Aba Ishaq! These people claim that you do not pray properly." Abu Ishaq said, "By Allah, I used to pray with them a prayer similar to that of Allah's Apostle and I never reduced anything of it. I used to prolong the first two Rakat of 'Isha prayer and shorten the last two Rakat." 'Umar said, "O Aba Ishaq, this was what I thought about you." And then he sent one or more persons with him to Kufa so as to ask the people about him. So they went there and did not leave any mosque without asking about him. All the people praised him till they came to the mosque of the tribe of Bani 'Abs; one of the men called Usama bin Qatada with a surname of Aba Sa'da stood up and said, "As you have put us under an oath; I am bound to tell you that Sa'd never went himself with the army and never distributed (the war booty) equally and never did justice in legal verdicts." (On hearing it) Sa'd said, "I pray to Allah for three things: O Allah! If this slave of yours is a liar and got up for showing off, give him a long life, increase his poverty and put him to trials." (And so it happened). Later on when that person was asked how he was, he used to reply that he was an old man in trial as the result of Sa'd's curse. 'Abdul Malik, the sub narrator, said that he had seen him afterwards and his eyebrows were over-hanging his eyes owing to old age and he used to tease and assault the small girls in the way.


Bukhari :: Characteristics of Prayer :: [1.12.723]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 723

Narrated 'Ubada bin As-Samit:

Allah's Apostle said, "Whoever does not recite Al-Fatiha in his prayer, his prayer is invalid."


Bukhari :: Characteristics of Prayer :: [1.12.724]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 724

Narrated Abu Huraira:

Allah's Apostle entered the mosque and a person followed him. The man prayed and went to the Prophet and greeted him. The Prophet returned the greeting and said to him, "Go back and pray, for you have not prayed." The man went back prayed in the same way as before, returned and greeted the Prophet who said, "Go back and pray, for you have not prayed." This happened thrice. The man said, "By Him Who sent you with the Truth, I cannot offer the prayer in a better way than this. Please, teach me how to pray." The Prophet said, "When you stand for Prayer say Takbir and then recite from the Holy Qur'an (of what you know by heart) and then bow till you feel at ease. Then raise your head and stand up straight, then prostrate till you feel at ease during your prostration, then sit with calmness till you feel at ease (do not hurry) and do the same in all your prayers


Bukhari :: Characteristics of Prayer :: [1.12.725]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 725

Narrated Jabir bin Samura:

Sa'd said, "I used to pray with them a prayer similar to that of Allah's Apostle (the prayer of Zuhr and 'Asr) reducing nothing from them. I used to prolong the first two Rakat and shorten the last two Rak'at." 'Umar said to Sa'd "This was what we thought about you."


Bukhari :: Characteristics of Prayer :: [1.12.726]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 726

Narrated 'Abdullah bin Abi Qatada:

My father said, "The Prophet in Zuhr prayers used to recite Al-Fatiha along with two other Suras in the first two Rakat: a long one in the first Rak'a and a shorter (Sura) in the second, and at times the verses were audible. In the 'Asr prayer the Prophet used to recite Al-Fatiha and two more Suras in the first two Rakat and used to prolong the first Rak'a. And he used to prolong the first Rak'a of the Fajr prayer and shorten the second.


Bukhari :: Characteristics of Prayer :: [1.12.727]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 727

Narrated Abu Ma'mar:

I asked Khabbab whether the Prophet used to recite the Qur'an in the Zuhr and the 'Asr prayers. He replied in the affirmative. We said, "How did you come to know that?" He said, "From the movement of his beard."


Bukhari :: Characteristics of Prayer :: [1.12.728]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 728

Narrated Abu Ma'mar:

I asked Khabbab bin Al-Art whether the Prophet used to recite the Qur'an in the Zuhr and the 'Asr prayers. He replied in the affirmative. I said, "How did you come to know that?" He replied, "From the movement of his beard."


Bukhari :: Characteristics of Prayer :: [1.12.729]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 729

Narrated 'Abdullah bin Abi Qatada:

My father said, "The Prophet used to recite Al-Fatiha along with another Sura in the first two Rakat of the Zuhr and the 'Asr prayers and at times a t verse or so was audible to us."


Bukhari :: Characteristics of Prayer :: [1.12.730]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 730

Narrated Ibn 'Abbas:

(My mother) Umu-l-Fadl heard me reciting "Wal Mursalati 'Urfan" (77) and said, "O my son! By Allah, your recitation made me remember that it was the last Sura I heard from Allah's Apostle. He recited it in the Maghrib prayer. "


Bukhari :: Characteristics of Prayer :: [1.12.731]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 731

Narrated Marwan bin Al-Hakam:

Zaid bin Thabit said to me, "Why do you recite very short S&ras in the Maghrib prayer while I heard the Prophet reciting the longer of the two long Suras?"


Bukhari :: Characteristics of Prayer :: [1.12.732]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 732

Narrated Jubair bin Mut'im:

My father said, "I heard Allah's Apostle reciting "At-Tur" (52) in the Maghrib prayer."


Bukhari :: Characteristics of Prayer :: [1.12.733]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 733

Narrated Abu Rafi:

I offered the 'Isha' prayer behind Abu Huraira and he recited, "Idha-s-Sama'u-n-Shaqqat" (84) and prostrated. On my inquiring, he said, "I prostrated behind Abu-l-Qasim (the Prophet) (when he recited that Sura) and I will go on doing it till I meet him."


Bukhari :: Characteristics of Prayer :: [1.12.734]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 734

Narrated Al-Bara:

The Prophet was on a journey and recited in one of the first two Rakat of the 'Isha' prayer "Wat-tini waz-zaituni." (95)


Bukhari :: Characteristics of Prayer :: [1.12.735]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 735

Narrated Abu Rafi':

Once I prayed the 'Isha' prayer with Abu Huraira and he recited, "Idha-s-Sama' u-nShaqqat" (84) and prostrated. I said, "What is that?" He said, "I prostrated behind Abu-l-Qasim, (the Prophet) (when he recited that Sura) and I will go on doing it till I meet him."


Bukhari :: Characteristics of Prayer :: [1.12.736]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 736

Narrated Al-Bara:

I heard the Prophet reciting wat-tini wazzaituni" (95) in the 'Isha' prayer, and I never heard a sweeter voice or a better way of recitation than that of the Prophet.


Bukhari :: Characteristics of Prayer :: [1.12.737]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 737

Narrated Jabir bin Samura:

'Umar said to Sa'd, "The people complained against you in everything, even in prayer." Sa'd replied, "Really I used to prolong the first two Rakat and shorten the last two and I will never shorten the prayer in which I follow Allah's Apostle." 'Umar said, "You are telling the truth and that is what I think a tout you."


Bukhari :: Characteristics of Prayer :: [1.12.738]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 738

Narrated Saiyar bin Salama:

My father and I went to Abu Barza-al-Aslami to ask him about the stated times for the prayers. He replied, "The Prophet used to offer the Zuhr prayer when the sun just declined from its highest position at noon; the 'Asr at a time when if a man went to the farthest place in Medina (after praying) he would find the sun still hot (bright). (The sub narrator said: I have forgotten what Abu Barza said about the Maghrib prayer). The Prophet never found any harm in delaying the 'Isha' prayer to the first third of the night and he never liked to sleep before it and to talk after it. He used to offer the morning prayer at a time when after finishing it one could recognize the person sitting beside him and used to recite between 60 to 100 verses in one or both the Rakat."


Bukhari :: Characteristics of Prayer :: [1.12.739]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 739

Narrated Abu Huraira:

The Qur'an is recited in every prayer and in those prayers in which Allah's Apostle recited aloud for us, we recite aloud in the same prayers for you; and the prayers in which the Prophet recited quietly, we recite quietly. If you recite "Al-Fatiha" only it is sufficient but if you recite something else in addition, it is better.


Bukhari :: Characteristics of Prayer :: [1.12.740]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 740

Narrated Ibn 'Abbas:

The Prophet set out with the intention of going to Suq 'Ukaz (market of 'Ukaz) along with some of his companions. At the same time, a barrier was put between the devils and the news of heaven. Fire commenced to be thrown at them. The Devils went to their people, who asked them, "What is wrong with you?" They said, "A barrier has been placed between us and the news of heaven. And fire has been thrown at us." They said, "The thing which has put a barrier between you and the news of heaven must be something which has happened recently. Go eastward and westward and see what has put a barrier between you and the news of heaven." Those who went towards Tuhama came across the Prophet at a place called Nakhla and it was on the way to Suq 'Ukaz and the Prophet was offering the Fajr prayer with his companions. When they heard the Qur'an they listened to it and said, "By Allah, this is the thing which has put a barrier between us and the news of heaven." They went to their people and said, "O our people; verily we have heard a wonderful recital (Qur'an) which shows the true path; we believed in it and would not ascribe partners to our Lord." Allah revealed the following verses to his Prophet (Sura 'Jinn') (72): "Say: It has been revealed to me." And what was revealed to him was the conversation of the Jinns.


Bukhari :: Characteristics of Prayer :: [1.12.741]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 741

Narrated Ibn 'Abbas:

The Prophet recited aloud in the prayers in which he was ordered to do so and quietly in the prayers in which he was ordered to do so. "And your Lord is not forgetful." "Verily there was a good example for you in the ways of the Prophet."


Bukhari :: Characteristics of Prayer :: [1.12.742]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 742

Narrated Abu Wa'il:

A man came to Ibn Mas'ud and said, "I recited the Mufassal (Suras) at night in one Rak'a." Ibn Mas'ud said, "This recitation is (too quick) like the recitation of poetry. I know the identical Suras which the Prophet used to recite in pairs." Ibn Mas'ud then mentioned 20 Mufassal Suras including two Suras from the family of (i.e. those verses which begin with) AL, HA, MIM (which the Prophet used to recite) in each Rak'a.


Bukhari :: Characteristics of Prayer :: [1.12.743]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 743

Narrated 'Abdullah bin Abi Qatada:

My father said, "The Prophet uses to recite Al-Fatiha followed by another Sura in the first two Rakat of the prayer and used to recite only Al-Fatiha in the last two Rakat of the Zuhr prayer. Sometimes a verse or so was audible and he used to prolong the first Rak'a more than the second and used to do the same in the 'Asr and Fajr prayers."


Bukhari :: Characteristics of Prayer :: [1.12.744]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 744

Narrated Abu Ma'mar:

We said to Khabbab "Did Allah's Apostle used to recite in Zuhr and 'Asr prayers?" He replied in the affirmative. We said, "How did you come to know about it?" He said, "By the movement of his beard."


Bukhari :: Characteristics of Prayer :: [1.12.745]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 745

Narrated 'Abdullah bin Abi Qatada:

My father said, "The Prophet used to recite Al-Fatiha along with another Sura in the first two Rakat of the Zuhr and 'Asr prayers. A verse or so was audible at times and he used to prolong the first Rak'a."


Bukhari :: Characteristics of Prayer :: [1.12.746]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 746

Narrated 'Abdullah bin Abi Qatada:

My father said, "The Prophet used to prolong the first Rak'a of the Zuhr prayer and shorten the second one and used to do the same in the Fajr prayer."


Bukhari :: Characteristics of Prayer :: [1.12.747]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 747

Narrated Abu Huraira:

The Prophet said, "Say Amin" when the Imam says it and if the Amin of any one of you coincides with that of the angels then all his past sins will be forgiven." Ibn Shihab said, "Allah's Apostle used to Say "Amin."


Bukhari :: Characteristics of Prayer :: [1.12.748]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 748

Narrated Abu Huraira:

Allah's Apostle said, "If any one of you says, "Amin" and the angels in the heavens say "Amin" and the former coincides with the latter, all his past sins will be forgiven."


Bukhari :: Characteristics of Prayer :: [1.12.749]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 749

Narrated Abu Huraira:

Allah's Apostle said, "Say Amen' when the Imam says "Ghair-il-maghdubi 'alaihim wala-ddal-lin; not the path of those who earn Your Anger (such as Jews) nor of those who go astray (such as Christians); all the past sins of the person whose saying (of Amin) coincides with that of the angels, will be forgiven.


Bukhari :: Characteristics of Prayer :: [1.12.750]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 750

Narrated Abu Bakra:

I reached the Prophet in the mosque while he was bowing in prayer and I too bowed before joining the row mentioned it to the Prophet and he said to me, "May Allah increase your love for the good. But do not repeat it again (bowing in that way)."


Bukhari :: Characteristics of Prayer :: [1.12.751]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 751

Narrated Imran bin Husain:

I offered the prayer with 'Ali in Basra and he made us remember the prayer which we used to pray with Allah's Apostle. 'Ali said Takbir on each rising and bowing.


Bukhari :: Characteristics of Prayer :: [1.12.752]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 752

Narrated Abu Salama:

When Abu Huraira led us in prayer he used to say Takbir on each bowing and rising. On the completion of the prayer he used to say, "My prayer is more similar to the prayer of Allah's Apostle than that of anyone of you."


Bukhari :: Characteristics of Prayer :: [1.12.753]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 753

Narrated Mutarrif bin 'Abdullah:

'Imran bin Husain and I offered the prayer behind Ali bin Abi Talib. When 'Ali prostrated, he said the Takbir, when he raised his head, he said the Takbir and when he got up for the third Rak'a he said the Takbir. On completion of the prayer Imran took my hand and said, "This (i.e. 'Ali) made me remember the prayer of Muhammad" Or he said, "He led us in a prayer like that of Muhammad."


Bukhari :: Characteristics of Prayer :: [1.12.754]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 754

Narrated 'Ikrima:

I saw a person praying at Muqam-lbrahim (the place of Abraham by the Ka'ba) and he was saying Takbir on every bowing, rising, standing and sitting. I asked Ibn 'Abbas (about this prayer). He admonished me saying: "Isn't that the prayer of the Prophet?"


Bukhari :: Characteristics of Prayer :: [1.12.755]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 755

Narrated 'Ikrima:

I prayed behind a Sheikh at Mecca and he said twenty two Takbirs (during the prayer). I told Ibn 'Abbas that he (i.e. that Sheikh) was foolish. Ibn 'Abbas admonished me and said, "This is the tradition of Abu-l-Qasim." And narrated Abu Huraira: Whenever Allah's Apostle stood for the prayer, he said Takbir on starting the prayer and then on bowing. On rising from bowing he said, "Sami' a-l-lahu liman hamida," and then while standing straight he used to say, "Rabbana laka-l hamd" (Al-Laith said, "(The Prophet said), 'Walaka-l-hamd'." He used to say Takbir on prostrating and on raising his head from prostration; again he would Say Takbir on prostrating and raising his head. He would then do the same in the whole of the prayer till it was completed. On rising from the second Rak'a (after sitting for At-Tahiyyat), he used to say Takbir.


Bukhari :: Characteristics of Prayer :: [1.12.756]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 756

Narrated Mus'ab bin Sa'd:

I offered prayer beside my father and approximated both my hands and placed them in between the knees. My father told me not to do so and said, "We used to do the same but we were forbidden (by the Prophet) to do it and were ordered to place the hands on the knees."


Bukhari :: Characteristics of Prayer :: [1.12.757]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 757

Narrated Zaid binWahb:

Hudhaifa saw a person who was not performing the bowing and prostrations perfectly. He said to him, "You have not prayed and if you should die you would die on a religion other than that of Muhammad."


Bukhari :: Characteristics of Prayer :: [1.12.758]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 758

Narrated Al-Bara:

The bowing, the prostration the sitting in between the two prostrations and the standing after the bowing of the Prophet but not Qiyam (standing in the prayer) and Qu'ud (sitting in the prayer) used to be approximately equal (in duration).


Bukhari :: Characteristics of Prayer :: [1.12.759]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 759

Narrated Abu Huraira:

Once the Prophet entered the mosque, a man came in, offered the prayer and greeted the Prophet. The Prophet returned his greeting and said to him, "Go back and pray again for you have not prayed." The man offered the prayer again, came back and greeted the Prophet. He said to him thrice, "Go back and pray again for you have not prayed." The man said, "By Him Who has sent you with the truth! I do not know a better way of praying. Kindly teach Me how to pray." He said, "When you stand for the prayer, say Takbir and then recite from the Qur'an what you know and then bow with calmness till you feel at ease, then rise from bowing till you stand straight. Afterwards prostrate calmly till you feel at ease and then raise (your head) and sit with Calmness till you feel at ease and then prostrate with calmness till you feel at ease in prostration and do the same in the whole of your prayer."


Bukhari :: Characteristics of Prayer :: [1.12.760]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 760

Narrated 'Aisha:

The Prophet used to say in his bowing and prostrations, "Subhanaka-Allahumma Rabbana wa-bihamdika Allahumma-ighfirli.' (I honor Allah from all what (unsuitable things) is ascribed to Him. O Allah Our Lord! And all the praises are for You. O Allah! Forgive me)."


Bukhari :: Characteristics of Prayer :: [1.12.761]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 761

Narrated Abu Huraira:

When the Prophet said, "Sami' a-l-lahu Liman hamida," (Allah heard those who sent praises to Him), he would say, "Rabbana wa-laka-l-hamd." On bowing and raising his head from it the Prophet used to say Takbir. He also used to say Takbir on rising after the two prostrations. (See Hadith No. 656).


Bukhari :: Characteristics of Prayer :: [1.12.762]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 762

Narrated Abu Huraira:

Allah's Apostle said, "When the Imam says, "Sami' a-l-lahu Liman hamida," you should say, "Allahumma Rabbana laka-l-hamd." And if the saying of any one of you coincides with that of the angels, all his past sins will be forgiven."


Bukhari :: Characteristics of Prayer :: [1.12.763]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 763

Narrated Anas:

The Qunut used to be recited in the Maghrib and the Fajr prayers.


Bukhari :: Characteristics of Prayer :: [1.12.764]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 764

Narrated Rifa'a bin Rafi AzZuraqi:

One day we were praying behind the Prophet. When he raised his head from bowing, he said, "Sami'a-l-lahu Liman hamida." A man behind him said, "Rabbana walaka-l hamd hamdan Kathiran taiyiban mubarakan fihi" (O our Lord! All the praises are for You, many good and blessed praises). When the Prophet completed the prayer, he asked, "Who has said these words?" The man replied, "I." The Prophet said, "I saw over thirty angels competing to write it first." Prophet rose (from bowing) and stood straight till all the vertebrae of his spinal column came to a natural position.


Bukhari :: Characteristics of Prayer :: [1.12.765]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 765

Narrated Thabit:

Anas used to demonstrate to us the prayer of the Prophet and while demonstrating, he used to raise his head from bowing and stand so long that we would say that he had forgotten (the prostration).


Bukhari :: Characteristics of Prayer :: [1.12.766]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 766

Narrated Al-Bara':

The bowing, the prostrations, the period of standing after bowing and the interval between the two prostrations of the Prophet used to be equal in duration .


Bukhari :: Characteristics of Prayer :: [1.12.767]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 767

Narrated Aiyub:

Abu Qilaba said, "Malik bin Huwairith used to demonstrate to us the prayer of the Prophet at times other than that of the compulsory prayers. So (once) he stood up for prayer and performed a perfect Qiyam (standing and reciting from the Holy Qur'an) and then bowed and performed bowing perfectly; then he raised his head and stood straight for a while." Abu Qilaba added, "Malik bin Huwairith in that demonstration prayed like this Sheikh of ours, Abu Yazid." Abu, Yazid used to sit (for a while) on raising his head from the second prostration before getting up.


Bukhari :: Characteristics of Prayer :: [1.12.768]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 768

Narrated Abu Bakr bin 'Abdur Rahman Ibn Harith bin Hisham and Abu Salama bin 'Abdur Rahman:

Abu Huraira used to say Takbir in all the prayers, compulsory and optional -- in the month of Ramadan or other months. He used to say Takbir on standing for prayer and on bowing; then he would say, "Salmi'a-l-lahu Liman hamida," and before prostrating he would say "Rabbana walaka-l-hamd." Then he would say Takbir on prostrating and on raising his head from the prostration, then another Takbir on prostrating (for the second time), and on raising his head from the prostration. He also would say the Takbir on standing from the second Rak'a. He used to do the same in every Rak'a till he completed the prayer. On completion of the prayer, he would say, "By Him in Whose Hands my soul is! No doubt my prayer is closer to that of Allah's Apostle than yours, and this was His prayer till he left this world." And Abu Huraira said, "When Allah's Apostle raised his head from (bowing) he used to say "Sami' a-l-lahu Liman hamida, Rabbana walakal-hamd." He Would invoke Allah for some people by naming them: "O Allah! Save Al-Walid bin Al-Walid and Salama bin Hisham and 'Aiyash bin Abi Rabi'a and the weak and the helpless people among the faithful believers O Allah! Be hard on the tribe of Mudar and let them suffer from famine years like that of the time of Joseph." In those days the Eastern section of the tribe of Mudar was against the Prophet.


Bukhari :: Characteristics of Prayer :: [1.12.769]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 769

Narrated Anas bin Malik:

Allah's Apostle fell from a horse and the right side of his body was injured. We went to enquire about his health meanwhile it was time for the prayer and he led the prayer sitting and we also prayed while sitting. On completion of the prayer he said, "The Imam is to be followed; say Takbir when he says it; bow when he bows; rise when he rises and when he says "Sami'a-l-lahu Liman hamida," say, "Rabbana walaka-lhamd", and prostrate if he prostrates." Sufyan narrated the same from Ma'mar. Ibn Juraij said that his (the Prophet's) right leg had been injured.


Bukhari :: Characteristics of Prayer :: [1.12.770]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 770

Narrated Abu Huraira:

The people said, "O Allah's Apostle! Shall we see our Lord on the Day of Resurrection?" He replied, "Do you have any doubt in seeing the full moon on a clear (not cloudy) night?" They replied, "No, O Allah's Apostle!" He said, "Do you have any doubt in seeing the sun when there are no clouds?" They replied in the negative. He said, "You will see Allah (your Lord) in the same way. On the Day of Resurrection, people will be gathered and He will order the people to follow what they used to worship. So some of them will follow the sun, some will follow the moon, and some will follow other deities; and only this nation (Muslims) will be left with its hypocrites. Allah will come to them and say, 'I am Your Lord.' They will say, 'We shall stay in this place till our Lord comes to us and when our Lord will come, we will recognize Him. Then Allah will come to them again and say, 'I am your Lord.' They will say, 'You are our Lord.' Allah will call them, and As-Sirat (a bridge) will be laid across Hell and I (Muhammad) shall be the first amongst the Apostles to cross it with my followers. Nobody except the Apostles will then be able to speak and they will be saying then, 'O Allah! Save us. O Allah Save us.'

There will be hooks like the thorns of Sa'dan in Hell. Have you seen the thorns of Sa'dan?" The people said, "Yes." He said, "These hooks will be like the thorns of Sa'dan but nobody except Allah knows their greatness in size and these will entangle the people according to their deeds; some of them will fall and stay in Hell forever; others will receive punishment (torn into small pieces) and will get out of Hell, till when Allah intends mercy on whomever He likes amongst the people of Hell, He will order the angels to take out of Hell those who worshipped none but Him alone. The angels will take them out by recognizing them from the traces of prostrations, for Allah has forbidden the (Hell) fire to eat away those traces. So they will come out of the Fire, it will eat away from the whole of the human body except the marks of the prostrations. At that time they will come out of the Fire as mere skeletons. The Water of Life will be poured on them and as a result they will grow like the seeds growing on the bank of flowing water. Then when Allah had finished from the Judgments amongst his creations, one man will be left between Hell and Paradise and he will be the last man from the people of Hell to enter paradise. He will be facing Hell, and will say, 'O Allah! Turn my face from the fire as its wind has dried me and its steam has burnt me.' Allah will ask him, "Will you ask for anything more in case this favor is granted to you?' He will say, "No by Your (Honor) Power!" And he will give to his Lord (Allah) what he will of the pledges and the covenants. Allah will then turn his face from the Fire. When he will face Paradise and will see its charm, he will remain quiet as long as Allah will. He then will say, 'O my Lord! Let me go to the gate of Paradise.' Allah will ask him, 'Didn't you give pledges and make covenants (to the effect) that you would not ask for anything more than what you requested at first?' He will say, 'O my Lord! Do not make me the most wretched, amongst Your creatures.' Allah will say, 'If this request is granted, will you then ask for anything else?' He will say, 'No! By Your Power! I shall not ask for anything else.' Then he will give to his Lord what He will of the pledges and the covenants. Allah will then let him go to the gate of Paradise. On reaching then and seeing its life, charm, and pleasure, he will remain quiet as long as Allah wills and then will say, 'O my Lord ! Let me enter Paradise.' Allah will say, May Allah be merciful unto you, O son of Adam! How treacherous you are! Haven't you made covenants and given pledges that you will not ask for anything more that what you have been given?' He will say, 'O my Lord! Do not make me the most wretched amongst Your creatures.' So Allah will laugh and allow him to enter Paradise and will ask him to request as much as he likes. He will do so till all his desires have been fulfilled . Then Allah will say, 'Request more of such and such things.' Allah will remind him and when all his desires and wishes; have been fulfilled, Allah will say "All this is granted to you and a similar amount besides." Abu Said Al-Khudri, said to Abu Huraira, 'Allah's Apostle said, "Allah said, 'That is for you and ten times more like it.' "Abu Huraira said, "I do not remember from Allah's Apostle except (his saying), 'All this is granted to you and a similar amount besides." Abu Sahd said, "I heard him saying, 'That is for you and ten times more the like of it."


Bukhari :: Characteristics of Prayer :: [1.12.771]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 771

Narrated 'Abdullah bin Malik bin Buhaina:

Whenever the Prophet used to offer prayer he used to keep arms away (from the body) so that the whiteness of his armpits was visible.


Bukhari :: Characteristics of Prayer :: [1.12.772]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 772

Narrated Abu Wail:

Hudhaifa said, "I saw a person not performing his bowing and prostrations perfectly. When he completed the prayer, I told him that he had not prayed." I think that Hudhaifa added (i.e. said to the man), "Had you died, you would have died on a tradition other than that of the Prophet Muhammad."


Bukhari :: Characteristics of Prayer :: [1.12.773]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 773

Narrated Ibn 'Abbas:

The Prophet was ordered (by Allah) to prostrate on seven parts and not to tuck up the clothes or hair (while praying). Those parts are: the forehead (along with the tip of nose), both hands, both knees, and (toes of) both feet.


Bukhari :: Characteristics of Prayer :: [1.12.774]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 774

Narrated Ibn 'Abbas:

The Prophet said, "We have been ordered to prostrates on seven bones and not to tuck up the clothes or hair."


Bukhari :: Characteristics of Prayer :: [1.12.775]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 775

Narrated Al-Bara' bin 'Azib:

(and he was not a liar) We used to pray behind the Prophet and when he said, "Sami' a-l-lahu Liman hamida", none of us would bend his back (to go for prostration) till the Prophet had placed his, forehead on the ground.


Bukhari :: Characteristics of Prayer :: [1.12.776]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 776

Narrated Ibn 'Abbas:

The Prophet said, "I have been ordered to prostrate on seven bones i.e. on the forehead along with the tip of the nose and the Prophet pointed towards his nose, both hands, both knees and the toes of both feet and not to gather the clothes or the hair."


Bukhari :: Characteristics of Prayer :: [1.12.777]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 777

Narrated Abu Salama:

Once I went to Abu- Sa'id Al-Khudri and asked him, "Won't you come with us to the date-palm trees to have a talk?" So Abu Said went out and I asked him, "Tell me what you heard from the Prophet about the Night of Qadr." Abu Said replied, "Once Allah's Apostle performed I'tikaf (seclusion) on the first ten days of the month of Ramadan and we did the same with him. Gabriel came to him and said, 'The night you are looking for is ahead of you.' So the Prophet performed the I'tikaf in the middle (second) ten days of the month of Ramadan and we too performed I'tikaf with him. Gabriel came to him and said, 'The night which you are looking for is ahead of you.' In the morning of the 20th of Ramadan the Prophet delivered a sermon saying, 'Whoever has performed I'tikaf with me should continue it. I have been shown the Night of "Qadr", but have forgotten its date, but it is in the odd nights of the last ten nights. I saw in my dream that I was prostrating in mud and water.' In those days the roof of the mosque was made of branches of date-palm trees. At that time the sky was clear and no cloud was visible, but suddenly a cloud came and it rained. The Prophet led us in the prayer and I saw the traces of mud on the forehead and on the nose of Allah's Apostle. So it was the confirmation of that dream."


Bukhari :: Characteristics of Prayer :: [1.12.778]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 778

Narrated Sahl bin Sa'd:

The people used to pray with the Prophet tying their Izars around their necks because of their small sizes and the women were directed that they should not raise their heads from the prostrations till the men had sat straight.


Bukhari :: Characteristics of Prayer :: [1.12.779]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 779

Narrated Ibn 'Abbas:

The Prophet was ordered to prostrate on seven bony parts and not to tuck up his clothes or hair.


Bukhari :: Characteristics of Prayer :: [1.12.780]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 780

Narrated Ibn 'Abbas:

The Prophet said, "I have been ordered to prostrate on seven (bones) and not to tuck up the hair or garment."


Bukhari :: Characteristics of Prayer :: [1.12.781]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 781

Narrated 'Aisha:

The Prophet used to say frequently in his bowing and prostrations "Subhanaka-Allahumma Rabbana Wabihamdika, Allahumma Ighfir-li" (I honor Allah from all what (unsuitable things) is ascribed to Him, O Allah! Our Lord! All praises are for You. O Allah! Forgive me). In this way he was acting on what was explained to him in the Holy Qur'an.


Bukhari :: Characteristics of Prayer :: [1.12.782]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 782

Narrated Abu Qilaba:

Once Malik bin Huwairith said to his friends, "Shall I show you how Allah's Apostle used to offer his prayers?" And it was not the time for any of the compulsory congregational prayers. So he stood up (for the prayer) bowed and said the Takbir, then he raised his head and remained standing for a while and then prostrated and raised his head for a while (sat up for a while). He prayed like our Sheikh 'Amr Ibn Salama. (Aiyub said, "The latter used to do a thing which I did not see the people doing i.e. he used to sit between the third and the fourth Rak'a). IMalik bin Huwairith said, "We came to the Prophet (after embracing Islam) and stayed with him. He said to us, 'When you go back to your families, pray such and such a prayer at such and such a time, pray such and such a prayer at such and such a time, and when there is the time for the prayer then only of you should pronounce the Adhan for the prayer and the oldest of you should lead the prayer."


Bukhari :: Characteristics of Prayer :: [1.12.783]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 783

Narrated Al-Bara':

The time taken by the Prophet in prostrations, bowing, and the sitting interval between the two prostrations was about the same.


Bukhari :: Characteristics of Prayer :: [1.12.784]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 784

Narrated Thabit:

Anas said, "I will leave no stone unturned in making you offer the prayer as I have seen the Prophet making us offer it." Anas used to do a thing which I have not seen you doing. He used to stand after the bowing for such a long time that one would think that he had forgotten (the prostrations) and he used to sit in-between the prostrations so long that one would think that he had forgotten the second prostration.


Bukhari :: Characteristics of Prayer :: [1.12.785]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 785

Narrated Anas bin Malik:

The Prophet said, "Be straight in the prostrations and none of you should put his forearms on the ground (in the prostration) like a dog."


Bukhari :: Characteristics of Prayer :: [1.12.786]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 786

Narrated Malik bin Huwairith Al-Laithi:

I saw the Prophet praying and in the odd Rakat, he used to sit for a moment before getting up.


Bukhari :: Characteristics of Prayer :: [1.12.787]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 787

Narrated Aiyub:

Abu Qilaba said, "Malik bin Huwairith came to us and led us in the prayer in this mosque of ours and said, 'I lead you in prayer but I do not want to offer the prayer but just to show you how Allah's Apostle performed his prayers." I asked Abu Qilaba, "How was the prayer of Malik bin Huwairith?" He replied, "Like the prayer of this Sheikh of ours-- i.e. 'Amr bin Salima." That Sheikh used to pronounce the Takbir perfectly and when he raised his head from the second prostration he would sit for a while and then support himself on the ground and get up.


Bukhari :: Characteristics of Prayer :: [1.12.788]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 788

Narrated Said bin Al-Harith:

Abu Said led us in the prayer and said the Takbir aloud on arising from the prostration, and on prostrating, on rising again, and on getting up from the second Rak'a. Abu Said said, "I saw the Prophet doing the same."


Bukhari :: Characteristics of Prayer :: [1.12.789]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 789

Narrated Mutarrif:

'Imran and I prayed behind 'Ali bin Abi Talib and he said Takbir on prostrating, on rising and on getting up after the two Rakat (i.e. after the second Rak'a). When the prayer was finished, 'Imran took me by the hand and said, "He ('Ali) has prayed the prayer of Muhammad" (or said, "He made us remember the prayer of Muhammad)."


Bukhari :: Characteristics of Prayer :: [1.12.790]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 790

Narrated 'Abdullah bin 'Abdullah:

I saw 'Abdullah bin 'Umar crossing his legs while sitting in the prayer and I, a mere youngster in those days, did the same. Ibn 'Umar forbade me to do so, and said, "The proper way is to keep the right foot propped up and bend the left in the prayer." I said questioningly, "But you are doing so (crossing the legs)." He said, "My feet cannot bear my weight."


Bukhari :: Characteristics of Prayer :: [1.12.791]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 791

Narrated Muhammad bin 'Amr bin 'Ata':

I was sitting with some of the companions of Allah's Apostle and we were discussing about the way of praying of the Prophet. Abu Humaid As-Saidi said, "I remember the prayer of Allah's Apostle better than any one of you. I saw him raising both his hands up to the level of the shoulders on saying the Takbir; and on bowing he placed his hands on both knees and bent his back straight, then he stood up straight from bowing till all the vertebrate took their normal positions. In prostrations, he placed both his hands on the ground with the forearms away from the ground and away from his body, and his toes were facing the Qibla. On sitting In the second Rak'a he sat on his left foot and propped up the right one; and in the last Rak'a he pushed his left foot forward and kept the other foot propped up and sat over the buttocks "


Bukhari :: Characteristics of Prayer :: [1.12.792]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 792

Narrated 'Abdullah bin Buhaina:

(he was from the tribe of Uzd Shan'u'a and was the ally of the tribe of 'Abdul-Manaf and was one of the companions of the Prophet): Once the Prophet led us in the Zuhr prayer and stood up after the second Rak'a and did not sit down. The people stood up with him. When the prayer was about to end and the people were waiting for him to say the Taslim, he said Takbir while sitting and prostrated twice before saying the Taslim and then he said the Taslim."


Bukhari :: Characteristics of Prayer :: [1.12.793]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 793

Narrated 'Abdullah bin Malik bin Buhaina:

Once Allah's Apostle led us in the Zuhr prayer and got up (after the prostrations of the second Rak'a) although he should have sat (for the Tashah-hud). So at the end of the prayer, he prostrated twice while sitting (prostrations of Sahu).


Bukhari :: Characteristics of Prayer :: [1.12.794]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 794

Narrated Shaqlq bin Salama:

'Abdullah said, "Whenever we prayed behind the Prophet we used to recite (in sitting) 'Peace be on Gabriel, Michael, peace be on so and so. Once Allah's Apostle looked back at us and said, 'Allah Himself is As-Salam (Peace), and if anyone of you prays then he should say, At-Tahiyatu lil-lahi wassalawatu wat-taiyibatu. AsSalamu 'alalika aiyuha-n-Nabiyu wa rahmatu-l-lahi wa barakatuhu. As-Salam alaina wa ala ibadil-lah is-salihin. (All the compliments, prayers and good things are due to Allah: peace be on you, O Prophet and Allah's mercy and blessings be on you. Peace be on us an on the true pious slaves of Allah). (If you say that, it will be for all the slaves in the heaven and the earth). Ash-hadu an la-ilaha illa-l-lahu wa ash-hadu anna Muhammadan 'abduhu wa Rasuluhu. (I testify that none has the right to be worshipped but Allah and I also testify that Muhammad is His slave and His Apostle)."


Bukhari :: Characteristics of Prayer :: [1.12.795]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 795

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle used to invoke Allah in the prayer saying "Allahumma inni a'udhu bika min adhabil-qabri, wa a'udhu bika min fitnatil-masihid-dajjal, wa a'udhu bika min fitnatil-mahya wa fitnatil-mamati. Allahumma inni a'udhu bika minal-ma thami wal-maghrami. (O Allah, I seek refuge with You from the punishment of the grave and from the afflictions of Masi,h Ad-Dajjal and from the afflictions of life and death. O Allah, I seek refuge with You from the sins and from being in debt)." Somebody said to him, "Why do you so frequently seek refuge with Allah from being in debt?" The Prophet replied, "A person in debt tells lies whenever he speaks, and breaks promises whenever he makes (them)." 'Aisha also narrated: I heard Allah's Apostle in his prayer seeking refuge with Allah from the afflictions of Ad-dajjal.


Bukhari :: Characteristics of Prayer :: [1.12.796]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 796

Narrated Abu Bakr As-Siddiq:

I asked Allah's Apostle to teach me an invocation so that I may invoke Allah with it in my prayer. He told me to say, "Allahumma inni zalumtu nafsi zulman kathiran, Wala yaghfirudhdhunuba illa anta faghfirli maghfiratan min 'Indika, war-hamni innaka antal-ghafururrahim (O Allah! I have done great injustice to myself and none except You forgives sins, so please forgive me and be Merciful to me as You are the Forgiver, the Merciful)."


Bukhari :: Characteristics of Prayer :: [1.12.797]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 797

Narrated 'Abdullah:

When we prayed with the Prophet we used to say, "Peace be on Allah from His slaves and peace be on so and so." The Prophet said, "Don't say As-Salam be on Allah, for He Himself is As-Salam, but say, 'At-tahiyatu lil-lahi was-salawatu wat-taiyibatu. As-salamu 'Alaika aiyuhan-Nabiyu warahmatu-l-lahi wa barakatuhu. As-salamu 'alaina wa 'ala ibadillahis-salihin. (If you say this then it will be for all the slaves in heaven or between heaven and earth). Ashhadu an la-ilaha illallahu wa ashhadu anna Muhammadan 'Abduhu wa Rasuluhu.' Then select the invocation you like best and recite it." (See Hadith No. 794, 795 & 796).


Bukhari :: Characteristics of Prayer :: [1.12.798]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 798

Narrated Abu Said Al-Khudri:

I saw Allah's Apostle prostrating in mud and water and saw the mark of mud on his forehead.


Bukhari :: Characteristics of Prayer :: [1.12.799]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 799

Narrated Um Salama:

Whenever Allah's Apostle finished his prayers with Taslim, the women would get up and he would stay on for a while in his place before getting up. Ibn Shihab said, "I think (and Allah knows better), that the purpose of his stay was that the women might leave before the men who had finished their prayer. "


Bukhari :: Characteristics of Prayer :: [1.12.800]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 800

Narrated 'Itban bin Malik:

We prayed with the Prophet and used to finish our prayer with the Taslim along with him.


Bukhari :: Characteristics of Prayer :: [1.12.801]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 801

Narrated Mahmud bin Ar-Rabi':

I remember Allah's Apostle and also the mouthful of water which he took from a bucket in our house and ejected (on me). I heard from ltban bin Malik Al-Ansari, who was one from Bani Salim, saying, "I used to lead my tribe of Bani Salim in prayer. Once I went to the Prophet and said to him, 'I have weak eye-sight and at times the rainwater flood intervenes between me and the mosque of my tribe and I wish that you would come to my house and pray at some place so that I could take that place as a place for praying (mosque). He said, "Allah willing, I shall do that." Next day Allah's Apostle along with Abu Bakr, came to my house after the sun had risen high and he asked permission to enter. I gave him permission, but he didn't sit till he said to me, "Where do you want me to pray in your house?" I pointed to a place in the house where I wanted him to pray. So he stood up for the prayer and we aligned behind him. He completed the prayer with Taslim and we did the same simultaneously."


Bukhari :: Characteristics of Prayer :: [1.12.802]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 802

Narrated Abu Ma'bad:

(the freed slave of Ibn 'Abbas) Ibn 'Abbas told me, "In the lifetime of the Prophet it was the custom to celebrate Allah's praises aloud after the compulsory congregational prayers." Ibn 'Abbas further said, "When I heard the Dhikr, I would learn that the compulsory congregational prayer had ended."


Bukhari :: Characteristics of Prayer :: [1.12.803]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 803

Narrated Ibn 'Abbas:

I used to recognize the completion of the prayer of the Prophet by hearing Takbir.


Bukhari :: Characteristics of Prayer :: [1.12.804]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 804

Narrated Abu Huraira:

Some poor people came to the Prophet and said, "The wealthy people will get higher grades and will have permanent enjoyment and they pray like us and fast as we do. They have more money by which they perform the Hajj, and 'Umra; fight and struggle in Allah's Cause and give in charity." The Prophet said, "Shall I not tell you a thing upon which if you acted you would catch up with those who have surpassed you? Nobody would overtake you and you would be better than the people amongst whom you live except those who would do the same. Say "Sub-han-al-lah", "Alhamdu-lillah" and "Allahu Akbar" thirty three times each after every (compulsory) prayer." We differed and some of us said that we should say, "Subhan-al-lah" thirty three times and "Alhamdu lillah" thirty three times and "Allahu Akbar" thirty four times. I went to the Prophet who said, "Say, "Subhan-al-lah" and "Alhamdu lillah" and "Allahu Akbar" all together for thirty three times."


Bukhari :: Characteristics of Prayer :: [1.12.805]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 805

Narrated Warrad:

(the clerk of Al-Mughira bin Shu'ba) Once Al-Mughira dictated to me in a letter addressed to Mu'awiya that the Prophet used to say after every compulsory prayer, "La ilaha ilallah wahdahu la sharika lahu, lahul-mulku wa-lahul-hamdu, wahuwa ala kulli shai in qadir. Allahumma la mani 'a lima a'taita, wa la mu'tiya lima mana'ta, wa la yanfa'u dhal-jaddi minka-l-jadd. (None has the right to be worshipped but Allah and He has no partner in Lordship or in worship or in the Names and the Qualities, and for Him is the Kingdom and all the praises are for Him and He is omnipotent. O Allah! Nobody can hold back what you give and nobody can give what You hold back. Hard (efforts by anyone for anything cannot benefit one against Your Will)." And Al-Hasan said, "Al-jadd' means prosperity."


Bukhari :: Characteristics of Prayer :: [1.12.806]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 806

Narrated Samura bin Jundab:

The Prophet used to face us on completion of the prayer.


Bukhari :: Characteristics of Prayer :: [1.12.807]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 807

Narrated Zaid bin Khalid Al-Juhani:

The Prophet led us in the Fajr prayer at Hudaibiya after a rainy night. On completion of the prayer, he faced the people and said, "Do you know what your Lord has said (revealed)?" The people replied, "Allah and His Apostle know better." He said, "Allah has said, 'In this morning some of my slaves remained as true believers and some became non-believers; whoever said that the rain was due to the Blessings and the Mercy of Allah had belief in Me and he disbelieves in the stars, and whoever said that it rained because of a particular star had no belief in Me but believes in that star.' "


Bukhari :: Characteristics of Prayer :: [1.12.808]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 808

Narrated Anas bin Malik:

Once the Prophet delayed the 'Isha' prayer until midnight and then came to us. Having prayed he faced us and said, "The people had prayed and slept but you were in the prayer as long as you were waiting for it."


Bukhari :: Characteristics of Prayer :: [1.12.809]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 809

Narrated Um Salama:

"The Prophet after finishing the prayer with Taslim used to stay at his place for a while." Ibn Shihab said, "I think (and Allah knows better), that he used to wait for the departure of the women who had prayed." Ibn Shihab wrote that he had heard it from Hind bint Al-Harith Al-Firasiya from Um Salama, the wife of the Prophet (Hind was from the companions of Um Salama) who said, "When the Prophet finished the prayer with Taslim, the women would depart and enter their houses before Allah's Apostle departed."


Bukhari :: Characteristics of Prayer :: [1.12.810]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 810

Narrated 'Uqba:

I offered the 'Asr prayer behind the Prophet at Medina. When he had finished the prayer with Taslim, he got up hurriedly and went out by crossing the rows of the people to one of the dwellings of his wives. The people got scared at his speed . The Prophet came back and found the people surprised at his haste and said to them, "I remembered a piece of gold Lying in my house and I did not like it to divert my attention from Allah's worship, so I have ordered it to be distributed (in charity)."


Bukhari :: Characteristics of Prayer :: [1.12.811]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 811

Narrated 'Abdullah:

You should not give away a part of your prayer to Satan by thinking that it is necessary to depart (after finishing the prayer) from one's right side only; I have seen the Prophet often leave from the left side.


Bukhari :: Characteristics of Prayer :: [1.12.812]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 812

Narrated Ibn 'Umar:

During the holy battle of Khaibar the Prophet said, "Whoever ate from this plant (i.e. garlic) should not enter our mosque."


Bukhari :: Characteristics of Prayer :: [1.12.813]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 813

Narrated 'Ata':

I heard Jabir bin 'Abdullah saying, "The Prophet said, 'Whoever eats (from) this plant (he meant garlic) should keep away from our mosque." I said, "What does he mean by that?" He replied, "I think he means only raw garlic."


Bukhari :: Characteristics of Prayer :: [1.12.814]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 814

Narrated Jabir bin 'Abdullah:

The Prophet said, "Whoever eats garlic or onion should keep away from our mosque or should remain in his house." (Jabir bin 'Abdullah, in another narration said, "Once a big pot containing cooked vegetables was brought. On finding unpleasant smell coming from it, the Prophet asked, 'What is in it?' He was told all the names of the vegetables that were in it. The Prophet ordered that it should be brought near to some of his companions who were with him. When the Prophet saw it he disliked to eat it and said, 'Eat. (I don't eat) for I converse with those whom you don't converse with (i.e. the angels)."


Bukhari :: Characteristics of Prayer :: [1.12.815]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 815

Narrated 'Abdul 'Aziz:

A man asked Anas, "What did you hear from the Prophet about garlic?" He said, "The Prophet said, 'Whoever has eaten this plant should neither come near us nor pray with us."


Bukhari :: Characteristics of Prayer :: [1.12.816]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 816

Narrated Sulaiman Ash-Shaibam:

I heard Ash-Sha'bi saying, "A person who was accompanying the Prophet passed by a grave that was separated from the other graves told me that the Prophet once led the people in the (funeral) prayer and the people had aligned behind him. I said, "O Aba 'Amr! Who told you about it?" He said, "Ibn Abbas."


Bukhari :: Characteristics of Prayer :: [1.12.817]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 817

Narrated Abu Said Al-Khudri:

The Prophet said, "Ghusl (taking a bath) on Friday is compulsory for every Muslim reaching the age of puberty."


Bukhari :: Characteristics of Prayer :: [1.12.818]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 818

Narrated Ibn 'Abbas:

One night I slept at the house of my aunt Maimuna and the Prophet slept (too). He got up (for prayer) in the last hours of the night and performed a light ablution from a hanging leather skin. ('Amr, the sub-narrator described that the ablution was very light). Then he stood up for prayer and I got up too and performed the ablution in the same way and joined him on his left side. He pulled me to the right and prayed as much as Allah will. Then he lay down and slept and I heard his breath sounds till the Mu'adh-dhin came to him to inform him about the (Fajr) prayer. He left with him for the prayer and prayed without repeating the ablution. (Sufyan the subnarrator said: We said to 'Amr, "Some people say, 'The eyes of the Prophet sleep but his heart never sleeps.' " 'Amr said, "'Ubai bin 'Umar said, 'The dreams of the Prophets are Divine Inspirations. Then he recited, '(O my son), I have seen in dream that I was slaughtering you (offering you in sacrifice).") (37.102)


Bukhari :: Characteristics of Prayer :: [1.12.819]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 819

Narrated Anas bin Malik:

My grandmother Mulaika invited Allah's Apostle for a meal which she had prepared specially for him. He ate some of it and said, "Get up. I shall lead you in the prayer." I brought a mat that had become black owing to excessive use and I sprinkled water on it. Allah's Apostle stood on it and prayed two Rakat; and the orphan was with me (in the first row), and the old lady stood behind us.


Bukhari :: Characteristics of Prayer :: [1.12.820]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 820

Narrated Ibn 'Abbas:

Once I came riding a she-ass and I, then, had just attained the age of puberty. Allah's Apostle was leading the people in prayer at Mina facing no wall. I passed in front of the row and let loose the she-ass for grazing and joined the row and no one objected to my deed.


Bukhari :: Characteristics of Prayer :: [1.12.821]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 821

Narrated 'Aisha:

Once Allah's Apostle delayed the 'Isha' prayer till 'Umar informed him that the women and children had slept. Then Allah's Apostle came out and said: "None from amongst the dwellers of earth have prayed this prayer except you." In those days none but the people of Medina prayed.


Bukhari :: Characteristics of Prayer :: [1.12.822]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 822

Narrated 'Abdur Rahman bin 'Abis:

A person asked Ibn Abbas, "Have you ever presented yourself at the ('Id) prayer with Allah's Apostle?" He replied, "Yes." And had it not been for my kinship (position) with the Prophet it would not have been possible for me to do so (for he was too young). The Prophet went to the mark near the house of Kathir bin As-Salt and delivered a sermon. He then went towards the women. He advised and reminded them and asked them to give alms. So the woman would bring her hand near her neck and take off her necklace and put it in the garment of Bilal. Then the Prophet and Bilal came to the house."


Bukhari :: Characteristics of Prayer :: [1.12.823]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 823

Narrated 'Aisha:

Once Allah's Apostle delayed the 'Isha' prayer till 'Umar informed him that the women and children had slept. The Prophet came out and said, "None except you from amongst the dwellers of earth is waiting for this prayer." In those days, there was no prayer except in Medina and they used to pray the 'Isha' prayer between the disappearance of the twilight and the first third of the night.


Bukhari :: Characteristics of Prayer :: [1.12.824]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 824

Narrated Ibn 'Umar:

The Prophet said, "If your women ask permission to go to the mosque at night, allow them."


Bukhari :: Characteristics of Prayer :: [1.12.825]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 825

Narrated Um Salama:

(the wife of the Prophet) In the lifetime of Allah's Apostle the women used to get up when they finished their compulsory prayers with Taslim. The Prophet and the men would stay on at their places as long as Allah will. When the Prophet got up, the men would then get up.


Bukhari :: Characteristics of Prayer :: [1.12.826]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 826

Narrated 'Aisha:

When Allah's Apostle finished the Fajr prayer, the women would leave covered in their sheets and were not recognized owing to the darkness.


Bukhari :: Characteristics of Prayer :: [1.12.827]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 827

Narrated 'Abdullah bin Abi Qatada Al-Ansari:

My father said, "Allah's Apostle said, "Whenever I stand for prayer, I want to prolong it but on hearing the cries of a child, I would shorten it as I dislike to put its mother in trouble."


Bukhari :: Characteristics of Prayer :: [1.12.828]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 828

Narrated 'Aisha:

Had Allah's Apostle known what the women were doing, he would have forbidden them from going to the mosque as the women of Bani Israel had been forbidden. Yahya bin Said (a sub-narrator) asked 'Amra (another sub-narrator), "Were the women of Bani Israel forbidden?" She replied "Yes."


Bukhari :: Characteristics of Prayer :: [1.12.829]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 829

Narrated Um Salama:

Whenever Allah's Apostle completed the prayer with Taslim, the women used to get up immediately and Allah's Apostle would remain at his place for someone before getting up. (The sub-narrator (Az-Zuhri) said, "We think, and Allah knows better, that he did so, so that the women might leave before men could get in touch with them)."


Bukhari :: Characteristics of Prayer :: [1.12.830]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 830

Narrated Anas:

The Prophet prayed in the house of Um Sulaim; and I, along with an orphan stood behind him while Um Sulaim (stood) behind us.


Bukhari :: Characteristics of Prayer :: [1.12.831]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 831

Narrated 'Aisha:

Allah's Apostle used to offer the Fajr prayer when it was still dark and the believing women used to return (after finishing their prayer) and nobody could recognize them owing to darkness, or they could not recognize one another.


Bukhari :: Characteristics of Prayer :: [1.12.832]

Characteristics of Prayer

Bukhari :: Book 1 :: Volume 12 :: Hadith 832

Narrated Salim bin 'Abdullah:

My father said, "The Prophet said, 'If the wife of any one of you asks permission (to go to the mosque) do not forbid her."


Bukhari :: Friday Prayer :: [2.13.1]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 1

Narrated Abu Huraira:

I heard Allah's Apostle (p.b.u.h) saying, "We (Muslims) are the last (to come) but (will be) the foremost on the Day of Resurrection though the former nations were given the Holy Scriptures before us. And this was their day (Friday) the celebration of which was made compulsory for them but they differed about it. So Allah gave us the guidance for it (Friday) and all the other people are behind us in this respect: the Jews' (holy day is) tomorrow (i.e. Saturday) and the Christians' (is) the day after tomorrow (i.e. Sunday)."


Bukhari :: Friday Prayer :: [2.13.2]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 2

Narrated 'Abdullah bin Umar:

Allah's Apostle (p.b.u.h) said, "Anyone of you attending the Friday (prayers) should take a bath."


Bukhari :: Friday Prayer :: [2.13.3]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 3

Narrated Ibn 'Umar:

While Umar bin Al-Khattab was standing and delivering the sermon on a Friday, one of the companions of the Prophet, who was one of the foremost Muhajirs (emigrants) came. 'Umar said to him, "What is the time now?" He replied, "I was busy and could not go back to my house till I heard the Adhan. I did not perform more than the ablution." Thereupon 'Umar said to him, "Did you perform only the ablution although you know that Allah's Apostle (p.b.u.h) used to order us to take a bath (on Fridays)?"


Bukhari :: Friday Prayer :: [2.13.4]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 4

Narrated Abu Said Al-Khudri:

Allah's Apostle (p.b.u.h) said, "The taking of a bath on Friday is compulsory for every male (Muslim) who has attained the age of puberty."


Bukhari :: Friday Prayer :: [2.13.5]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 5

Narrated Abu Said:

I testify that Allah's Apostle said, "The taking of a bath on Friday is compulsory for every male Muslim who has attained the age of puberty and (also) the cleaning of his teeth with Siwak, and the using of perfume if it is available." Amr (a sub-narrator) said, "I confirm that the taking of a bath is compulsory, but as for the Siwak and the using of perfume, Allah knows better whether it is obligatory or not, but according to the Hadith it is as above.")


Bukhari :: Friday Prayer :: [2.13.6]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 6

Narrated Abu Huraira:

Allah's Apostle (p.b.u.h) said, "Any person who takes a bath on Friday like the bath of Janaba and then goes for the prayer (in the first hour i.e. early), it is as if he had sacrificed a camel (in Allah's cause); and whoever goes in the second hour it is as if he had sacrificed a cow; and whoever goes in the third hour, then it is as if he had sacrificed a horned ram; and if one goes in the fourth hour, then it is as if he had sacrificed a hen; and whoever goes in the fifth hour then it is as if he had offered an egg. When the Imam comes out (i.e. starts delivering the Khutba), the angels present themselves to listen to the Khutba."


Bukhari :: Friday Prayer :: [2.13.7]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 7

Narrated Abu Huraira:

While 'Umar (bin Al-Khattab) was delivering the Khutba on a Friday, a man entered (the mosque). 'Umar asked him, "What has detained you from the prayer?" The man said, "It was only that when I heard the Adhan I performed ablution (for the prayer)." On that 'Umar said, "Did you not hear the Prophet saying: 'Anyone of you going out for the Jumua prayer should take a bath'?".


Bukhari :: Friday Prayer :: [2.13.8]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 8

Narrated Salman-Al-Farsi:

The Prophet (p.b.u.h) said, "Whoever takes a bath on Friday, purifies himself as much as he can, then uses his (hair) oil or perfumes himself with the scent of his house, then proceeds (for the Jumua prayer) and does not separate two persons sitting together (in the mosque), then prays as much as (Allah has) written for him and then remains silent while the Imam is delivering the Khutba, his sins in-between the present and the last Friday would be forgiven."


Bukhari :: Friday Prayer :: [2.13.9]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 9

Narrated Tawus:

I said to Ibn 'Abbas, "The people are narrating that the Prophet said, 'Take a bath on Friday and wash your heads (i.e. take a thorough bath) even though you were not Junub and use perfume'." On that Ibn 'Abbas replied, "I know about the bath, (i.e. it is essential) but I do not know about the perfume (i.e. whether it is essential or not.)~


Bukhari :: Friday Prayer :: [2.13.10]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 10

Narrated Tawus:

Ibn 'Abbas mentioned the statement of the Prophet regarding the taking of a bath on Friday and then I asked him whether the Prophet (p.b.u.h) had ordered perfume or (hair) oil to be used if they could be found in one's house. He (Ibn 'Abbas) replied that he did not know about it.


Bukhari :: Friday Prayer :: [2.13.11]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 11

Narrated 'Abdullah bin 'Umar:

Umar bin Al-Khattab saw a silken cloak (being sold) at the gate of the Mosque and said to Allah's Apostle, "I wish you would buy this to wear on Fridays and also on occasions of the arrivals of the delegations." Allah's Apostle replied, "This will be worn by a person who will have no share (reward) in the Hereafter." Later on similar cloaks were given to Allah's Apostle and he gave one of them to 'Umar bin Al-Khattab. On that 'Umar said, "O Allah's Apostle! You have given me this cloak although on the cloak of Atarid (a cloak merchant who was selling that silken cloak at the gate of the mosque) you passed such and such a remark." Allah's Apostle replied, "I have not given you this to wear". And so 'Umar bin Al-Khattab gave it to his pagan brother in Mecca to wear.


Bukhari :: Friday Prayer :: [2.13.12]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 12

Narrated Abu Huraira:

Allah's Apostle said, "If I had not found it hard for my followers or the people, I would have ordered them to clean their teeth with Siwak for every prayer."


Bukhari :: Friday Prayer :: [2.13.13]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 13

Narrated Anas:

Allah's Apostle I said, "I have told you repeatedly to (use) the Siwak. (The Prophet put emphasis on the use of the Siwak.)


Bukhari :: Friday Prayer :: [2.13.14]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 14

Narrated Hudhaifa:

When the Prophet (p.b.u.h) got up at night (for the night prayer), he used to clean his mouth .


Bukhari :: Friday Prayer :: [2.13.15]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 15

Narrated 'Aisha:

AbdurRahman bin Abi Bakr came holding a Siwak with which he was cleaning his teeth. Allah's Apostle looked at him. I requested Abdur-Rahman to give the Siwak to me and after he gave it to me I divided it, chewed it and gave it to Allah's Apostle. Then he cleaned his teeth with it and (at that time) he was resting against my chest.


Bukhari :: Friday Prayer :: [2.13.16]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 16

Narrated Abu Huraira:

The Prophet used to recite the following in the Fajr prayer of Friday, "Alif, Lam, Mim, Tanzil" (Surat-as-Sajda #32) and "Hal-ata-ala-l-Insani" (i.e. Surah-Ad-Dahr #76).


Bukhari :: Friday Prayer :: [2.13.17]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 17

Narrated Ibn 'Abbas:

The first Jumua prayer which was offered after a Jumua prayer offered at the mosque of Allah's Apostle took place in the mosque of the tribe of 'Abdul Qais at Jawathi in Bahrain.


Bukhari :: Friday Prayer :: [2.13.18]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 18

Narrated Ibn Umar:

I heard Allah's Apostle saying, "All of you are Guardians." Yunis said: Ruzaiq bin Hukaim wrote to Ibn Shihab while I was with him at Wadi-al-Qura saying, "Shall I lead the Jumua prayer?" Ruzaiq was working on the land (i.e farming) and there was a group of Sudanese people and some others with him; Ruzaiq was then the Governor of Aila. Ibn Shihab wrote (to Ruzaiq) ordering him to lead the Jumua prayer and telling him that Salim told him that 'Abdullah bin 'Umar had said, "I heard Allah's Apostle saying, 'All of you are guardians and responsible for your wards and the things under your care. The Imam (i.e. ruler) is the guardian of his subjects and is responsible for them and a man is the guardian of his family and is responsible for them. A woman is the guardian of her husband's house and is responsible for it. A servant is the guardian of his master's belongings and is responsible for them.' I thought that he also said, 'A man is the guardian of his father's property and is responsible for it. All of you are guardians and responsible for your wards and the things under your care."


Bukhari :: Friday Prayer :: [2.13.19]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 19

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "Anyone of you coming for the Jumua prayer should take a bath."


Bukhari :: Friday Prayer :: [2.13.20]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 20

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "The taking of a bath on Friday is compulsory for every Muslim who has attained the age of puberty."


Bukhari :: Friday Prayer :: [2.13.21]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 21

Narrated Abu Huraira:

Allah's Apostle said "We are the last (to come amongst the nations) but (will be) the foremost on the Day of Resurrection. They were given the Holy Scripture before us and we were given the Quran after them. And this was the day (Friday) about which they differed and Allah gave us the guidance (for that). So tomorrow (i.e. Saturday) is the Jews' (day), and the day after tomorrow (i.e. Sunday) is the Christians'." The Prophet (p.b.u.h) remained silent (for a while) and then said, "It is obligatory for every Muslim that he should take a bath once in seven days, when he should wash his head and body."

Narrated Abu Huraira through different narrators that the Prophet said, "It is Allah's right on every Muslim that he should take a bath (at least) once in seven days."


Bukhari :: Friday Prayer :: [2.13.22]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 22

Narrated Ibn Umar:

The Prophet (p.b.u.h) said, "Allow women to go to the Mosques at night."


Bukhari :: Friday Prayer :: [2.13.23]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 23

Narrated Ibn Umar:

One of the wives of Umar (bin Al-Khattab) used to offer the Fajr and the 'Isha' prayer in congregation in the Mosque. She was asked why she had come out for the prayer as she knew that Umar disliked it, and he has great ghaira (self-respect). She replied, "What prevents him from stopping me from this act?" The other replied, "The statement of Allah's Apostle (p.b.u.h) : 'Do not stop Allah's women-slave from going to Allah s Mosques' prevents him."


Bukhari :: Friday Prayer :: [2.13.24]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 24

Narrated Muhammad bin Sirin:

On a rainy day Ibn Abbas said to his Muadh-dhin, "After saying, 'Ash-hadu anna Muhammadan Rasulullah' (I testify that Muhammad is Allah's Apostle), do not say 'Haiya 'Alas-Salat' (come for the prayer) but say 'Pray in your houses'." (The man did so). But the people disliked it. Ibn Abbas said, "It was done by one who was much better than I (i.e. the Prophet (p.b.u.h) ). No doubt, the Jumua prayer is compulsory but I dislike to put you to task by bringing you out walking in mud and slush."


Bukhari :: Friday Prayer :: [2.13.25]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 25

Narrated Aisha:

(the wife of the Prophet) The people used to come from their abodes and from Al-'Awali (i.e. outskirts of Medina up to a distance of four miles or more from Medina). They used to pass through dust and used to be drenched with sweat and covered with dust; so sweat used to trickle from them. One of them came to Allah's Apostle who was in my house. The Prophet said to him, "I wish that you keep yourself clean on this day of yours (i.e. take a bath)."


Bukhari :: Friday Prayer :: [2.13.26]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 26

Narrated Yahya bin Said:

I asked 'Amra about taking a bath on Fridays. She replied, " Aisha said, 'The people used to work (for their livelihood) and whenever they went for the Jumua prayer, they used to go to the mosque in the same shape as they had been in work. So they were asked to take a bath on Friday.' "


Bukhari :: Friday Prayer :: [2.13.27]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 27

Narrated Anas bin Malik:

The Prophet used to offer the Jumua prayer immediately after mid-day.


Bukhari :: Friday Prayer :: [2.13.28]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 28

Narrated Anas bin Malik:

We used to offer the Jumua prayer early and then have an afternoon nap.


Bukhari :: Friday Prayer :: [2.13.29]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 29

Narrated Anas bin Malik:

The Prophet used to offer the prayer earlier if it was very cold; and if it was very hot he used to delay the prayer, i.e. the Jumua prayer.


Bukhari :: Friday Prayer :: [2.13.30]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 30

Narrated Abu 'Abs:

I heard the Prophet saying, "Anyone whose feet are covered with dust in Allah's cause, shall be saved by Allah from the Hell-Fire."


Bukhari :: Friday Prayer :: [2.13.31]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 31

Narrated Abu Huraira:

heard Allah's Apostles (p.b.u.h) saying, "If the prayer is started do not run for it but just walk for it calmly and pray whatever you get, and complete whatever is missed. "


Bukhari :: Friday Prayer :: [2.13.32]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 32

Narrated 'Abdullah bin Abi Qatada on the authority of his father:

The Prophet (p.b.u.h) said, "Do not stand up (for prayer) unless you see me, and observe calmness and solemnity".


Bukhari :: Friday Prayer :: [2.13.33]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 33

Narrated Salman Al-Farsi:

Allah's Apostle (p.b.u.h) said, "Anyone who takes a bath on Friday and cleans himself as much as he can and puts oil (on his hair) or scents himself; and then proceeds for the prayer and does not force his way between two persons (assembled in the mosque for the Friday prayer), and prays as much as is written for him and remains quiet when the Imam delivers the Khutba, all his sins in between the present and the last Friday will be forgiven."


Bukhari :: Friday Prayer :: [2.13.34]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 34

Narrated Ibn Juraij:

I heard Nazi' saying, "Ibn Umar, said, 'The Prophet forbade that a man should make another man to get up to sit in his place' ". I said to Nafi', 'Is it for Jumua prayer only?' He replied, "For Jumua prayer and any other (prayer)."


Bukhari :: Friday Prayer :: [2.13.35]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 35

Narrated As-Saib bin Yazid:

In the life-time of the Prophet, Abu Bakr and Umar, the Adhan for the Jumua prayer used to be pronounced when the Imam sat on the pulpit. But during the Caliphate of 'Uthman when the Muslims increased in number, a third Adhan at Az-Zaura' was added. Abu 'Abdullah said, "Az-Zaura' is a place in the market of Medina."


Bukhari :: Friday Prayer :: [2.13.36]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 36

Narrated As-Saib bin Yazid:

The person who increased the number of Adhans for the Jumua prayers to three was Uthman bin Affan and it was when the number of the (Muslim) people of Medina had increased. In the life-time of the Prophet there was only one Muadh-dhin and the Adhan used to be pronounced only after the Imam had taken his seat (i.e. on the pulpit).


Bukhari :: Friday Prayer :: [2.13.37]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 37

Narrated Abu Umama bin Sahl bin Hunaif:

I heard Muawiya bin Abi Sufyan (repeating the statements of the Adhan) while he was sitting on the pulpit. When the Muadh-dhin pronounced the Adhan saying, "Allahu-Akbar, Allahu Akbar", Muawiya said: "Allah Akbar, Allahu Akbar." And when the Muadh-dhin said, "Ash-hadu an la ilaha illal-lah (I testify that none has the right to be worshipped but Allah)", Muawiya said, "And (so do) I". When he said, "Ash-hadu anna Muhammadan Rasulullah" (I testify that Muhammad is Allah's Apostle), Muawiya said, "And (so do) I". When the Adhan was finished, Muawiya said, "O people, when the Muadh-dhin pronounced the Adhan I heard Allah's Apostle on this very pulpit saying what you have just heard me saying".


Bukhari :: Friday Prayer :: [2.13.38]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 38

Narrated As-Sa'ib bin Yazid I :

'Uthman bin 'Affan introduced the second Adhan on Fridays when the number of the people in the mosque increased. Previously the Adhan on Fridays used to be pronounced only after the Imam had taken his seat (on the pulpit).


Bukhari :: Friday Prayer :: [2.13.39]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 39

Narrated Az-Zuhri:

I heard As-Saib bin Yazid, saying, "In the life-time of Allah's Apostle, and Abu Bakr and Umar, the Adhan for the Jumua prayer used to be pronounced after the Imam had taken his seat on the pulpit. But when the people increased in number during the caliphate of 'Uthman, he introduced a third Adhan (on Friday for the Jumua prayer) and it was pronounced at Az-Zaura' and that new state of affairs remained so in the succeeding years.


Bukhari :: Friday Prayer :: [2.13.40]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 40

Narrated Abu Hazim bin Dinar:

Some people went to Sahl bin Sad As-Sa'idi and told him that they had different opinions regarding the wood of the pulpit. They asked him about it and he said, "By Allah, I know of what wood the pulpit was made, and no doubt I saw it on thy very first day when Allah's Apostle I took his seat on it. Allah's Apostle sent for such and such an Ansari woman (and Sahl mentioned her name) and said to her, 'Order your slave-carpenter to prepare for me some pieces of wood (i.e. pulpit) on which I may sit at the time of addressing the people.' So she ordered her slave-carpenter and he made it from the tamarisk of the forest and brought it (to the woman). The woman sent that (pulpit) to Allah's Apostle who ordered it to be placed here. Then I saw Allah's Apostle praying on it and then bowed on it. Then he stepped back, got down and prostrated on the ground near the foot of the pulpit and again ascended the pulpit. After finishing the prayer he faced the people and said, 'I have done this so that you may follow me and learn the way I pray.' "


Bukhari :: Friday Prayer :: [2.13.41]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 41

Narrated Jabir bin 'Abdullah:

The Prophet used to stand by a stem of a date-palm tree (while delivering a sermon). When the pulpit was placed for him we heard that stem crying like a pregnant she-camel till the Prophet got down from the pulpit and placed his hand over it.


Bukhari :: Friday Prayer :: [2.13.42]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 42

Narrated Salim:

My father said , "I heard the Prophet delivering the Khutba on the pulpit and he said, 'Whoever comes for the Jumua prayer should take a bath (before coming).' "


Bukhari :: Friday Prayer :: [2.13.43]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 43

Narrated Ibn Umar:

The Prophet (p.b.u.h) used to deliver the Khutba while standing and then he would sit, then stand again as you do now-a-days.


Bukhari :: Friday Prayer :: [2.13.44]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 44

Narrated Abu Said Al-Khudri:

One day the Prophet sat on the pulpit and we sat around him.


Bukhari :: Friday Prayer :: [2.13.45]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 45

Narrated 'Amr bin Taghlib:

Some property or something was brought to Allah's Apostle and he distributed it. He gave to some men and ignored the others. Later he got the news of his being admonished by those whom he had ignored. So he glorified and praised Allah and said, "Amma ba'du. By Allah, I may give to a man and ignore another, although the one whom I ignore is more beloved to me than the one whom I give. But I give to some people as I feel that they have no patience and no contentment in their hearts and I leave those who are patient and self-contented with the goodness and wealth which Allah has put into their hearts and 'Amr bin Taghlib is one of them." Amr added, By Allah! Those words of Allah's Apostle are more beloved to me than the best red camels.


Bukhari :: Friday Prayer :: [2.13.46]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 46

Narrated Aisha:

Once in the middle of the night Allah's Apostle (p.b.u.h) went out and prayed in the mosque and some men prayed with him. The next morning the people spoke about it and so more people gathered and prayed with him (in the second night). They circulated the news in the morning, and so, on the third night the number of people increased greatly. Allah's Apostle (p.b.u.h) came out and they prayed behind him. On the fourth night the mosque was overwhelmed by the people till it could not accommodate them. Allah's Apostle came out only for the Fajr prayer and when he finished the prayer, he faced the people and recited "Tashah-hud" (I testify that none has the right to be worshipped but Allah and that Muhammad is His Apostle), and then said, "Amma ba'du. Verily your presence (in the mosque at night) was not hidden from me, but I was afraid that this prayer (Prayer of Tahajjud) might be made compulsory and you might not be able to carry it out."


Bukhari :: Friday Prayer :: [2.13.47]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 47

Narrated Abu Hummaid As-Sa'idi

One night Allah's Apostle (p.b.u.h) stood up after the prayer and recited "Tashah-hud" and then praised Allah as He deserved and said, "Amma ba'du."


Bukhari :: Friday Prayer :: [2.13.48]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 48

Narrated Al-Miswar bin Makhrama:

Once Allah's Apostle got up for delivering the Khutba and I heard him after "Tashah-hud" saying "Amma ba'du."


Bukhari :: Friday Prayer :: [2.13.49]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 49

Narrated Ibn Abbas:

Once the Prophet ascended the pulpit and it was the last gathering in which he took part. He was covering his shoulder with a big cloak and binding his head with an oily bandage. He glorified and praised Allah and said, "O people! Come to me." So the people came and gathered around him and he then said, "Amma ba'du." "From now onward the Ansar will decrease and other people will increase. So anybody who becomes a ruler of the followers of Muhammad and has the power to harm or benefit people then he should accept the good from the benevolent amongst them (Ansar) and overlook the faults of their wrong-doers."


Bukhari :: Friday Prayer :: [2.13.50]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 50

Narrated 'Abdullah Ibn Umar:

The Prophet used to deliver two Khutbas and sit in between them


Bukhari :: Friday Prayer :: [2.13.51]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 51

Narrated Abu Huraira:

The Prophet said, "When it is a Friday, the angels stand at the gate of the mosque and keep on writing the names of the persons coming to the mosque in succession according to their arrivals. The example of the one who enters the mosque in the earliest hour is that of one offering a camel (in sacrifice). The one coming next is like one offering a cow and then a ram and then a chicken and then an egg respectively. When the Imam comes out (for Jumua prayer) they (i.e. angels) fold their papers and listen to the Khutba."


Bukhari :: Friday Prayer :: [2.13.52]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 52

Narrated Jabir bin 'Abdullah:

A person entered the mosque while the Prophet was delivering the Khutba on a Friday. The Prophet said to him, "Have you prayed?" The man replied in the negative. The Prophet said, "Get up and pray two Rakat."


Bukhari :: Friday Prayer :: [2.13.53]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 53

Narrated Jabir:

A man entered the Mosque while the Prophet was delivering the Khutba. The Prophet said to him, "Have you prayed?" The man replied in the negative. The Prophet said, "Pray two Rakat."


Bukhari :: Friday Prayer :: [2.13.54]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 54

Narrated Anas:

While the Prophet was delivering the Khutba on a Friday, a man stood up and said, "O, Allah's Apostle! The livestock and the sheep are dying, so pray to Allah for rain." So he (the Prophet) raised both his hands and invoked Allah (for it).


Bukhari :: Friday Prayer :: [2.13.55]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 55

Narrated Anas bin Malik:

Once in the lifetime of the Prophet (p.b.u.h) the people were afflicted with drought (famine). While the Prophet was delivering the Khutba on a Friday, a Bedouin stood up and said, "O, Allah's Apostle! Our possessions are being destroyed and the children are hungry; Please invoke Allah (for rain)". So the Prophet raised his hands. At that time there was not a trace of cloud in the sky. By Him in Whose Hands my soul is as soon as he lowered his hands, clouds gathered like mountains, and before he got down from the pulpit, I saw the rain falling on the beard of the Prophet. It rained that day, the next day, the third day, the fourth day till the next Friday. The same Bedouin or another man stood up and said, "O Allah's Apostle! The houses have collapsed, our possessions and livestock have been drowned; Please invoke Allah (to protect us)". So the Prophet I raised both his hands and said, "O Allah! Round about us and not on us". So, in whatever direction he pointed with his hands, the clouds dispersed and cleared away, and Medina's (sky) became clear as a hole in between the clouds. The valley of Qanat remained flooded, for one month, none came from outside but talked about the abundant rain.


Bukhari :: Friday Prayer :: [2.13.56]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 56

Narrated Abu Huraira:

Allah's Apostle (p.b.u.h) said, "When the Imam is delivering the Khutba, and you ask your companion to keep quiet and listen, then no doubt you have done an evil act."


Bukhari :: Friday Prayer :: [2.13.57]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 57

Narrated Abu Huraira:

Allah's Apostle (p.b.u.h) talked about Friday and said, "There is an hour (opportune time) on Friday and if a Muslim gets it while praying and asks something from Allah, then Allah will definitely meet his demand." And he (the Prophet) pointed out the shortness of that time with his hands.


Bukhari :: Friday Prayer :: [2.13.58]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 58

Narrated Jabir bin 'Abdullah:

While we were praying (Jumua Khutba & prayer) with the Prophet (p.b.u.h), some camels loaded with food, arrived (from Sham.~ The people diverted their attention towards the camels (and left the mosque), and only twelve persons remained with the Prophet. So this verse was revealed: "But when they see Some bargain or some amusement, They disperse headlong to it, And leave you standing." (62.11)


Bukhari :: Friday Prayer :: [2.13.59]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 59

Narrated 'Abdullah bin Umar:

Allah's Apostle used to pray two Rakat before the Zuhr prayer and two Rakat after it. He also used to pray two Rakat after the Maghrib prayer in his house, and two Rakat after the 'Isha' prayer. He never prayed after Jumua prayer till he departed (from the Mosque), and then he would pray two Rakat at home.


Bukhari :: Friday Prayer :: [2.13.60]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 60

Narrated Sahl bin Sad:

There was a woman amongst us who had a farm and she used to sow Silq (a kind of vegetable) on the edges of streams in her farm. On Fridays she used to pull out the Silq from its roots and put the roots in a utensil. Then she would put a handful of powdered barley over it and cook it. The roots of the Silq were a substitute for meat. After finishing the Jumua prayer we used to greet her and she would give us that food which we would eat with our hands, and because of that meal, we used to look forward to Friday.


Bukhari :: Friday Prayer :: [2.13.61]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 61

Narrated Sahl:

As above with the addition: We never had an afternoon nap nor meals except after offering the Jumua prayer.


Bukhari :: Friday Prayer :: [2.13.62]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 62

Narrated Anas:

We used to offer the Jumua prayer early and then have the afternoon nap.


Bukhari :: Friday Prayer :: [2.13.63]

Friday Prayer

Bukhari :: Book 2 :: Volume 13 :: Hadith 63

Narrated Sahl:

We used to offer the Jumua prayer with the Prophet and then take the afternoon nap.


Bukhari :: Fear Prayer :: [2.14.64]

Fear Prayer

Bukhari :: Book 2 :: Volume 14 :: Hadith 64

Narrated Shu'aib:

I asked Az-Zuhri, "Did the Prophet ever offer the Fear Prayer?" Az-Zuhri said, "I was told by Salim that 'Abdullah bin Umar I had said, 'I took part in a holy battle with Allah's Apostle I in Najd. We faced the enemy and arranged ourselves in rows. Then Allah's Apostle (p.b.u.h) stood up to lead the prayer and one party stood to pray with him while the other faced the enemy. Allah's Apostle (p.b.u.h) and the former party bowed and performed two prostrations. Then that party left and took the place of those who had not prayed. Allah's Apostle prayed one Raka (with the latter) and performed two prostrations and finished his prayer with Taslim. Then everyone of them bowed once and performed two prostrations individually.' "


Bukhari :: Fear Prayer :: [2.14.65]

Fear Prayer

Bukhari :: Book 2 :: Volume 14 :: Hadith 65

Narrated Nafi':

Ibn Umar said something similar to Mujahid's saying: Whenever (Muslims and non-Muslims) stand face to face in battle, the Muslims can pray while standing. Ibn Umar added, "The Prophet said, 'If the number of the enemy is greater than the Muslims, they can pray while standing or riding (individually).' "


Bukhari :: Fear Prayer :: [2.14.66]

Fear Prayer

Bukhari :: Book 2 :: Volume 14 :: Hadith 66

Narrated Ibn Abbas:

Once the Prophet (p.b.u.h) led the fear prayer and the people stood behind him. He said Takbir (Allahu-Akbar) and the people said the same. He bowed and some of them bowed. Then he prostrated and they also prostrated. Then he stood for the second Raka and those who had prayed the first Raka left and guarded their brothers. The second party joined him and performed bowing and prostration with him. All the people were in prayer but they were guarding one another during the prayer.


Bukhari :: Fear Prayer :: [2.14.67]

Fear Prayer

Bukhari :: Book 2 :: Volume 14 :: Hadith 67

Narrated Jabir bin 'Abdullah:

On the day of the Khandaq Umar came, cursing the disbelievers of Quraish and said, "O Allah's Apostle! I have not offered the 'Asr prayer and the sun has set." The Prophet replied, "By Allah! I too, have not offered the prayer yet. "The Prophet then went to Buthan, performed ablution and performed the 'Asr prayer after the sun had set and then offered the Maghrib prayer after it."


Bukhari :: Fear Prayer :: [2.14.68]

Fear Prayer

Bukhari :: Book 2 :: Volume 14 :: Hadith 68

Narrated Anas bin Malik:

Allah's Apostle (p.b.u.h) offered the Fajr prayer when it was still dark, then he rode and said, 'Allah Akbar! Khaibar is ruined. When we approach near to a nation, the most unfortunate is the morning of those who have been warned." The people came out into the streets saying, "Muhammad and his army." Allah's Apostle vanquished them by force and their warriors were killed; the children and women were taken as captives. Safiya was taken by Dihya Al-Kalbi and later she belonged to Allah's Apostle go who married her and her Mahr was her manumission.


Bukhari :: The Two Festivals (Eids) :: [2.15.69]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 69

Narrated 'Abdullah bin Umar:

Umar bought a silk cloak from the market, took it to Allah's Apostle and said, "O Allah's Apostle! Take it and adorn yourself with it during the 'Id and when the delegations visit you." Allah's Apostle (p.b.u.h) replied, "This dress is for those who have no share (in the Hereafter)." After a long period Allah's Apostle (p.b.u.h) sent to Umar a cloak of silk brocade. Umar came to Allah's Apostle (p.b.u.h) with the cloak and said, "O Allah's Apostle! You said that this dress was for those who had no share (in the Hereafter); yet you have sent me this cloak." Allah's Apostle said to him, "Sell it and fulfill your needs by it."


Bukhari :: The Two Festivals (Eids) :: [2.15.70]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 70

Narrated Aisha:

Allah's Apostle (p.b.u.h) came to my house while two girls were singing beside me the songs of Buath (a story about the war between the two tribes of the Ansar, the Khazraj and the Aus, before Islam). The Prophet (p.b.u.h) lay down and turned his face to the other side. Then Abu Bakr came and spoke to me harshly saying, "Musical instruments of Satan near the Prophet (p.b.u.h) ?" Allah's Apostle (p.b.u.h) turned his face towards him and said, "Leave them." When Abu Bakr became inattentive, I signalled to those girls to go out and they left. It was the day of 'Id, and the Black people were playing with shields and spears; so either I requested the Prophet (p.b.u.h) or he asked me whether I would like to see the display. I replied in the affirmative. Then the Prophet (p.b.u.h) made me stand behind him and my cheek was touching his cheek and he was saying, "Carry on! O Bani Arfida," till I got tired. The Prophet (p.b.u.h) asked me, "Are you satisfied (Is that sufficient for you)?" I replied in the affirmative and he told me to leave.


Bukhari :: The Two Festivals (Eids) :: [2.15.71]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 71

Narrated Al-Bara':

I heard the Prophet (p.b.u.h) delivering a Khutba saying, "The first thing to be done on this day (first day of 'Id ul Adha) is to pray; and after returning from the prayer we slaughter our sacrifices (in the name of Allah) and whoever does so, he acted according to our Sunna (traditions)."


Bukhari :: The Two Festivals (Eids) :: [2.15.72]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 72

Narrated Aisha:

Abu Bakr came to my house while two small Ansari girls were singing beside me the stories of the Ansar concerning the Day of Buath. And they were not singers. Abu Bakr said protestingly, "Musical instruments of Satan in the house of Allah's Apostle !" It happened on the 'Id day and Allah's Apostle said, "O Abu Bakr! There is an 'Id for every nation and this is our 'Id."


Bukhari :: The Two Festivals (Eids) :: [2.15.73]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 73

Narrated Anas bin Malik,:

Allah's Apostle never proceeded (for the prayer) on the Day of 'Id-ul-Fitr unless he had eaten some dates. Anas also narrated: The Prophet used to eat odd number of dates.


Bukhari :: The Two Festivals (Eids) :: [2.15.74]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 74

Narrated Anas:

The Prophet said, "Whoever slaughtered (his sacrifice) before the 'Id prayer, should slaughter again." A man stood up and said, "This is the day on which one has desire for meat," and he mentioned something about his neighbors. It seemed that the Prophet I believed him. Then the same man added, "I have a young she-goat which is dearer to me than the meat of two sheep." The Prophet permitted him to slaughter it as a sacrifice. I do not know whether that permission was valid only for him or for others as well.


Bukhari :: The Two Festivals (Eids) :: [2.15.75]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 75

Narrated Al-Bara' bin 'Azib:

The Prophet delivered the Khutba after offering the prayer on the Day of Nahr and said, "Whoever offers the prayer like us and slaughters like us then his Nusuk (sacrifice) will be accepted by Allah. And whoever slaughters his sacrifice before the 'Id prayer then he has not done the sacrifice." Abi Burda bin Niyar, the uncle of Al-Bara' said, "O Allah's Apostle! I have slaughtered my sheep before the 'Id prayer and I thought today as a day of eating and drinking (not alcoholic drinks), and I liked that my sheep should be the first to be slaughtered in my house. So slaughtered my sheep and took my food before coming for the prayer." The Prophet said, "The sheep which you have slaughtered is just mutton (not a Nusuk)." He (Abu Burda) said, "O Allah's Apostle! I have a young she-goat which is dearer to me than two sheep. Will that be sufficient as a Nusuk on my behalf? "The Prophet (p.b.u.h) said, "Yes, it will be sufficient for you but it will not be sufficient (as a Nusuk) for anyone else after you."


Bukhari :: The Two Festivals (Eids) :: [2.15.76]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 76

Narrated Abu Sa'id Al-Khudri:

The Prophet used to proceed to the Musalla on the days of Id-ul-Fitr and Id-ul-Adha; the first thing to begin with was the prayer and after that he would stand in front of the people and the people would keep sitting in their rows. Then he would preach to them, advise them and give them orders, (i.e. Khutba). And after that if he wished to send an army for an expedition, he would do so; or if he wanted to give and order, he would do so, and then depart. The people followed this tradition till I went out with Marwan, the Governor of Medina, for the prayer of Id-ul-Adha or Id-ul-Fitr.

When we reached the Musalla, there was a pulpit made by Kathir bin As-Salt. Marwan wanted to get up on that pulpit before the prayer. I got hold of his clothes but he pulled them and ascended the pulpit and delivered the Khutba before the prayer. I said to him, "By Allah, you have changed (the Prophet's tradition)." He replied, "O Abu Sa'id! Gone is that which you know." I said, "By Allah! What I know is better than what I do not know." Marwan said, "People do not sit to listen to our Khutba after the prayer, so I delivered the Khutba before the prayer."


Bukhari :: The Two Festivals (Eids) :: [2.15.77]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 77

Narrated 'Abdullah bin Umar:

Allah's Apostle used to offer the prayer of 'Id-ul-Adha and 'Id-ul-Fitr and then deliver the Khutba after the prayer.


Bukhari :: The Two Festivals (Eids) :: [2.15.78]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 78

Narrated Ibn Juraij:

'Ata' said, "Jabir bin 'Abdullah said, 'The Prophet went out on the Day of 'Id-ul-Fitr and offered the prayer before delivering the Khutba, Ata told me that during the early days of IbnAz-Zubair, Ibn Abbas had sent a message to him telling him that the Adhan for the 'Id Prayer was never pronounced (in the life time of Allah's Apostle) and the Khutba used to be delivered after the prayer. Ata told me that Ibn Abbas and Jabir bin 'Abdullah, had said, �- where was no Adhan for the prayer of '7d-ul-Fitr and 'Id-ul-Aqha." 'At a' said, "I heard Jabir bin 'Abdullah saying, 'The Prophet stood up and started with the prayer, and after it he delivered the Khutba. When the Prophet of Allah (p.b.u.h) finished (the Khutba), he went to the women and preached to them, while he was leaning on Bilal's hand. Bilal was spreading his garment and the ladies were putting alms in it.' " I said to Ata, "Do you think it incumbent upon an Imam to go to the women and preach to them after finishing the prayer and Khutba?" 'Ata' said, "No doubt it is incumbent on Imams to do so, and why should they not do so?"


Bukhari :: The Two Festivals (Eids) :: [2.15.79]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 79

Narrated Ibn Abbas:

I offered the 'Id prayer with Allah's Apostle, Abu Bakr, Umar and 'Uthman and all of them offered the prayer before delivering the Khutba.


Bukhari :: The Two Festivals (Eids) :: [2.15.80]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 80

Narrated Ibn Umar:

Allah's Apostle, Abu Bakr and Umar! used to offer the two 'Id prayers before delivering the Khutba.


Bukhari :: The Two Festivals (Eids) :: [2.15.81]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 81

Narrated Ibn Abbas:

The Prophet offered a two Rakat prayer on the Day of Id ul Fitr and he did not pray before or after it. Then he went towards women along with Bilal and ordered them to pay alms and so they started giving their earrings and necklaces (in charity).


Bukhari :: The Two Festivals (Eids) :: [2.15.82]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 82

Narrated Al-Bara' bin 'Azib:

The Prophet (p.b.u.h) said, "The first thing that we should do on this day of ours is to pray and then return to slaughter the sacrifice. So anyone who does so, he acted according to our Sunna (tradition), and whoever slaughtered the sacrifice before the prayer, it was just meat which he presented to his family and would not be considered as Nusuk." A person from the Ansar named Abu Burda bin Niyyar said, "O Allah's Apostle! I slaughtered the Nusuk (before the prayer) but I have a young she-goat which is better than an older sheep." The Prophet I said, "Sacrifice it in lieu of the first, but it will be not sufficient (as a sacrifice) for anybody else after you."


Bukhari :: The Two Festivals (Eids) :: [2.15.83]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 83

Narrated Said bin Jubair:

I was with Ibn Umar when a spear head pierced the sole of his foot and his foot stuck to the paddle of the saddle and I got down and pulled his foot out, and that happened in Mina. Al-Hajjaj got the news and came to enquire about his health and said, "Alas! If we could only know the man who wounded you!" Ibn Umar said, "You are the one who wounded me." Al-Hajjaj said, "How is that?" Ibn Umar said, "You have allowed the arms to be carried on a day on which nobody used to carry them and you allowed arms to be carried in the Haram even though it was not allowed before."


Bukhari :: The Two Festivals (Eids) :: [2.15.84]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 84

Narrated Said bin 'Amr bin Said bin Al-'Aas:

Al-Hajjaj went to Ibn Umar while I was present there. Al-Hajjaj asked Ibn Umar, "How are you?" Ibn Umar replied, "I am all right," Al-Hajjaj asked, "Who wounded you?" Ibn Umar replied, "The person who allowed arms to be carried on the day on which it was forbidden to carry them (he meant Al-Hajjaj)"


Bukhari :: The Two Festivals (Eids) :: [2.15.85]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 85

Narrated Al-Bara':

The Prophet delivered the Khutba on the day of Nahr ('Id-ul-Adha) and said, "The first thing we should do on this day of ours is to pray and then return and slaughter (our sacrifices). So anyone who does so he acted according to our Sunna; and whoever slaughtered before the prayer then it was just meat that he offered to his family and would not be considered as a sacrifice in any way. My uncle Abu Burda bin Niyyar got up and said, "O, Allah's Apostle! I slaughtered the sacrifice before the prayer but I have a young she-goat which is better than an older sheep." The Prophet said, "Slaughter it in lieu of the first and such a goat will not be considered as a sacrifice for anybody else after you."


Bukhari :: The Two Festivals (Eids) :: [2.15.86]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 86

Narrated Ibn Abbas:

The Prophet said, "No good deeds done on other days are superior to those done on these (first ten days of Dhul Hijja)." Then some companions of the Prophet said, "Not even Jihad?" He replied, "Not even Jihad, except that of a man who does it by putting himself and his property in danger (for Allah's sake) and does not return with any of those things."


Bukhari :: The Two Festivals (Eids) :: [2.15.87]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 87

Narrated Muhammad bin Abi Bakr Al-Thaqafi:

While we were going from Mina to 'Arafat, I asked Anas bin Malik, about Talbiya, "How did you use to say Talbiya in the company of the Prophet?" Anas said: "People used to say Talbiya and their saying was not objected to and they used to say Takbir and that was not objected to either. "


Bukhari :: The Two Festivals (Eids) :: [2.15.88]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 88

Narrated Um 'Atiya:

We used to be ordered to come out on the Day of 'Id and even bring out the virgin girls from their houses and menstruating women so that they might stand behind the men and say Takbir along with them and invoke Allah along with them and hope for the blessings of that day and for purification from sins.


Bukhari :: The Two Festivals (Eids) :: [2.15.89]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 89

Narrated Ibn Umar: On the day of 'Id-ul-Fitr and 'Id-ul-Adha a spear used to be planted in front of the Prophet I (as a Sutra for the prayer) and then he would pray.


Bukhari :: The Two Festivals (Eids) :: [2.15.90]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 90

Narrated Ibn Umar:

The Prophet used to proceed to the Musalla and an 'Anaza used to be carried before him and planted in the Musalla in front of him and he would pray facing it (as a Sutra).


Bukhari :: The Two Festivals (Eids) :: [2.15.91]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 91

Narrated Muhammad:

Um 'Atiyya said: "Our Prophet ordered us to come out (on 'Id day) with the mature girls and the virgins staying in seclusion." Hafsa narrated the above mentioned Hadith and added, "The mature girls or virgins staying in seclusion but the menstruating women had to keep away from the Musalla."


Bukhari :: The Two Festivals (Eids) :: [2.15.92]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 92

Narrated Ibn Abbas:

I (in my boyhood) went out with the Prophet on the day of 'Id ul Fitr or Id-ul-Adha. The Prophet prayed and then delivered the Khutba and then went towards the women, preached and advised them and ordered them to give alms.


Bukhari :: The Two Festivals (Eids) :: [2.15.93]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 93

Narrated Al-Bara':

The Prophet went towards Al-Baqi (the grave-yard at Medina) on the day of Id-ul-Adha and offered a two-Rakat prayer (of 'Id-ul-Adha) and then faced us and said, "On this day of ours, our first act of worship is the offering of prayer and then we will return and slaughter the sacrifice, and whoever does this concords with our Sunna; and whoever slaughtered his sacrifice before that (i.e. before the prayer) then that was a thing which he prepared earlier for his family and it would not be considered as a Nusuk (sacrifice.)" A man stood up and said, "O, Allah's Apostle! I slaughtered (the animal before the prayer) but I have a young she-goat which is better than an older sheep." The Prophet (p.b.u.h) said to him, "Slaughter it. But a similar sacrifice will not be sufficient for anybody else after you."


Bukhari :: The Two Festivals (Eids) :: [2.15.94]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 94

Narrated 'Abdur Rahman bin 'Abis:

Ibn Abbas was asked whether he had joined the Prophet in the 'Id prayer. He said, "Yes. And I could not have joined him had I not been young. (The Prophet came out) till he reached the mark which was near the house of Kathir bin As-Salt, offered the prayer, delivered the Khutba and then went towards the women. Bilal was accompanying him. He preached to them and advised them and ordered them to give alms. I saw the women putting their ornaments with their outstretched hands into Bilal's garment. Then the Prophet along with Bilal returned home.


Bukhari :: The Two Festivals (Eids) :: [2.15.95]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 95

Narrated Ibn Juraij:

'Ata' told me that he had heard Jabir bin 'Abdullah saying, "The Prophet stood up to offer the prayer of the 'Id ul Fitr. He first offered the prayer and then delivered the Khutba. After finishing it he got down (from the pulpit) and went towards the women and advised them while he was leaning on Bilal's hand. Bilal was spreading out his garment where the women were putting their alms." I asked 'Ata' whether it was the Zakat of 'Id ul Fitr. He said, "No, it was just alms given at that time. Some lady put her finger ring and the others would do the same." I said, (to 'Ata'), "Do you think that it is incumbent upon the Imam to give advice to the women (on 'Id day)?" He said, "No doubt, it is incumbent upon the Imams to do so and why should they not do so?" Al-Hasan bin Muslim told me that Ibn Abbas had said, "I join the Prophet, Abu Bakr, Umar and 'Uthman in the 'Id ul Fitr prayers. They used to offer the prayer before the Khutba and then they used to deliver the Khutba afterwards. Once the Prophet I came out (for the 'Id prayer) as if I were just observing him waving to the people to sit down. He, then accompanied by Bilal, came crossing the rows till he reached the women. He recited the following verse: 'O Prophet! When the believing women come to you to take the oath of fealty to you . . . (to the end of the verse) (60.12).' After finishing the recitation he said, "O ladies! Are you fulfilling your covenant?" None except one woman said, "Yes." Hasan did not know who was that woman. The Prophet said, "Then give alms." Bilal spread his garment and said, "Keep on giving alms. Let my father and mother sacrifice their lives for you (ladies)." So the ladies kept on putting their Fatkhs (big rings) and other kinds of rings in Bilal's garment." Abdur-Razaq said, " 'Fatkhs' is a big ring which used to be worn in the (Pre-lslamic) period of ignorance.


Bukhari :: The Two Festivals (Eids) :: [2.15.96]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 96

Narrated Aiyub:

Hafsa bint Sirin said, "On Id we used to forbid our girls to go out for 'Id prayer. A lady came and stayed at the palace of Bani Khalaf and I went to her. She said, 'The husband of my sister took part in twelve holy battles along with the Prophet and my sister was with her husband in six of them. My sister said that they used to nurse the sick and treat the wounded. Once she asked, 'O Allah's Apostle! If a woman has no veil, is there any harm if she does not come out (on 'Id day)?' The Prophet said, 'Her companion should let her share her veil with her, and the women should participate in the good deeds and in the religious gatherings of the believers.' " Hafsa added, "When Um-'Atiya came, I went to her and asked her, 'Did you hear anything about so-and-so?' Um-'Atlya said, 'Yes, let my father be sacrificed for the Prophet (p.b.u.h). (And whenever she mentioned the name of the Prophet she always used to say, 'Let my father be' sacrificed for him). He said, 'Virgin mature girls staying often screened (or said, 'Mature girls and virgins staying often screened--Aiyub is not sure as which was right) and menstruating women should come out (on the 'Id day). But the menstruating women should keep away from the Musalla. And all the women should participate in the good deeds and in the religious gatherings of the believers'." Hafsa said, "On that I said to Um-'Atiya, 'Also those who are menstruating?' " Um-'Atiya replied, "Yes. Do they not present themselves at 'Arafat and elsewhere?".


Bukhari :: The Two Festivals (Eids) :: [2.15.97]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 97

Narrated Um-'Atiya:

We were ordered to go out (for 'Id) and also to take along with us the menstruating women, mature girls and virgins staying in seclusion. (Ibn 'Aun said, "Or mature virgins staying in seclusion)." The menstruating women could present themselves at the religious gathering and invocation of Muslims but should keep away from their Musalla.


Bukhari :: The Two Festivals (Eids) :: [2.15.98]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 98

Narrated Ibn 'Umar:

The Prophet (p.b.u.h) used to Nahr or slaughter sacrifices at the Musalla (on 'Id-ul-Adha).


Bukhari :: The Two Festivals (Eids) :: [2.15.99]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 99

Narrated Al-Bara' bin 'Azib:

On the day of Nahr Allah's Apostle delivered the Khutba after the 'Id prayer and said, "Anyone who prayed like us and slaughtered the sacrifice like we did then he acted according to our (Nusuk) tradition of sacrificing, and whoever slaughtered the sacrifice before the prayer, then that was just mutton (i.e. not sacrifice)." Abu Burda bin Naiyar stood up and said, "O Allah's Apostle! By Allah, I slaughtered my sacrifice before I offered the (Id) prayer and thought that today was the day of eating and drinking (non-alcoholic drinks) and so I made haste (in slaughtering) and ate and also fed my family and neighbors." Allah's Apostle said, "That was just mutton (not a sacrifice)." Then Abu Burda said, "I have a young she-goat and no doubt, it is better than two sheep. Will that be sufficient as a sacrifice for me?" The Prophet replied, "Yes. But it will not be sufficient for anyone else (as a sacrifice), after you."


Bukhari :: The Two Festivals (Eids) :: [2.15.100]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 100

Narrated Anas bin Malik:

Allah's Apostle .~ offered the prayer on the day of Nahr and then delivered the Khutba and ordered that whoever had slaughtered his sacrifice before the prayer should repeat it, that is, should slaughter another sacrifice. Then a person from the Ansar stood up and said, "O Allah's Apostle! because of my neighbors (he described them as being very needy or poor) I slaughtered before the prayer. I have a young she-goat which, in my opinion, is better than two sheep." The Prophet gave him the permission for slaughtering it as a sacrifice.


Bukhari :: The Two Festivals (Eids) :: [2.15.101]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 101

Narrated Jundab:

On the day of Nahr the Prophet offered the prayer and delivered the Khutba and then slaughtered the sacrifice and said, "Anybody who slaughtered (his sacrifice) before the prayer should slaughter another animal in lieu of it, and the one who has not yet slaughtered should slaughter the sacrifice mentioning Allah's name on it."


Bukhari :: The Two Festivals (Eids) :: [2.15.102]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 102

Narrated Jabir bin 'Abdullah:

On the Day of 'Id the Prophet used to return (after offering the 'Id prayer) through a way different from that by which he went.


Bukhari :: The Two Festivals (Eids) :: [2.15.103]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 103

Narrated 'Urwa on the authority of 'Aisha:

On the days of Mina, (11th, 12th, and 13th of Dhul-Hijjah) Abu Bakr came to her while two young girls were beating the tambourine and the Prophet was lying covered with his clothes. Abu Bakr scolded them and the Prophet uncovered his face and said to Abu Bakr, "Leave them, for these days are the days of 'Id and the days of Mina." 'Aisha further said, "Once the Prophet was screening me and I was watching the display of black slaves in the Mosque and ('Umar) scolded them. The Prophet said, 'Leave them. O Bani Arfida! (carry on), you are safe (protected)'."


Bukhari :: The Two Festivals (Eids) :: [2.15.104]

The Two Festivals (Eids)

Bukhari :: Book 2 :: Volume 15 :: Hadith 104

Narrated Ibn 'Abbas:

The Prophet went out and offered a two Rakat prayer on the Day of 'Id ul Fitr and did not offer any other prayer before or after it and at that time Bilal was accompanying him.


Bukhari :: Witr Prayer :: [2.16.105]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 105

Narrated Ibn Umar:

Once a person asked Allah's Apostle about the night prayer. Allah's Apostle replied, "The night prayer is offered as two Rakat followed by two Rakat and so on and if anyone is afraid of the approaching dawn (Fajr prayer) he should pray one Raka and this will be a Witr for all the Rakat which he has prayed before." Nafi' told that 'Abdullah bin 'Umar used to say Taslim between (the first) two Rakat and (the third) odd one in the Witr prayer, when he wanted to attend to a certain matter (during that interval between the Rakat).


Bukhari :: Witr Prayer :: [2.16.106]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 106

Narrated Ibn 'Abbas:

Once I passed the night in the house of Maimuna (his aunt). I slept across the bed while Allah's Apostle and his wife slept length-wise. The Prophet slept till midnight or nearly so and woke up rubbing his face and recited ten verses from Surat "Aal-Imran." Allah's Apostle went towards a leather skin and performed ablution in the most perfect way and then stood for the prayer. I did the same and stood beside him. The Prophet put his right hand on my head, twisted my ear and then prayed two Rakat five times and then ended his prayer with Witr. He laid down till the Muadh-dhin came then he stood up and offered two Rakat (Sunna of Fajr prayer) and then went out and offered the Fajr prayer.

(See Hadith No. 183, Vol. 1)


Bukhari :: Witr Prayer :: [2.16.107]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 107

Narrated 'Abdullah bin 'Umar :

The Prophet said, "Night prayer is offered as two Rakat followed by two Rakat and so on, and if you want to finish it, pray only one Raka which will be Witr for all the previous Rakat." Al-Qasim said, "Since we attained the age of puberty we have seen some people offering a three-Rakat prayer as Witr and all that is permissible. I hope there will be no harm in it."


Bukhari :: Witr Prayer :: [2.16.108]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 108

Narrated 'Aisha:

Allah's Apostle used to pray eleven Rakat at night and that was his night prayer and each of his prostrations lasted for a period enough for one of you to recite fifty verses before Allah's Apostle raised his head. He also used to pray two Rakat (Sunna) before the (compulsory) Fajr prayer and then lie down on his right side till the Muadh-dhin came to him for the prayer.


Bukhari :: Witr Prayer :: [2.16.109]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 109

Narrated Anas bin Sirin:

I asked Ibn 'Umar, "What is your opinion about the two Rakat before the Fajr (compulsory) prayer, as to prolonging the recitation in them?" He said, "The Prophet (p.b.u.h) used to pray at night two Rakat followed by two and so on, and end the prayer by one Raka Witr. He used to offer two Rakat before the Fajr prayer immediately after the Adhan." (Hammad, the sub-narrator said, "That meant (that he prayed) quickly.)"


Bukhari :: Witr Prayer :: [2.16.110]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 110

Narrated 'Aisha:

Allah's Apostle offered Witr prayer at different nights at various hours extending (from the 'Isha' prayer) up to the last hour of the night.


Bukhari :: Witr Prayer :: [2.16.111]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 111

Narrated 'Aisha :

The Prophet (p.b.u.h) used to offer his night prayer while I was sleeping across in his bed. Whenever he intended to offer the Witr prayer, he used to wake me up and I would offer the Witr prayer too.


Bukhari :: Witr Prayer :: [2.16.112]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 112

Narrated 'Abdullah bin 'Umar:

The Prophet (p.b.u.h) said, "Make s your last prayer at night."


Bukhari :: Witr Prayer :: [2.16.113]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 113

Narrated Said bin Yasar:

I was going to Mecca in the company of 'Abdullah bin 'Umar and when I apprehended the approaching dawn, I dismounted and offered the Witr prayer and then joined him. 'Abdullah bin 'Umar said, "Where have you been?" I replied, "I apprehended the approaching dawn so I dismounted and prayed the Witr prayer." 'Abdullah said, "Isn't it sufficient for you to follow the good example of Allah's Apostle?" I replied, "Yes, by Allah." He said, "Allah's Apostle used to pray Witr on the back of the camel (while on a journey)."


Bukhari :: Witr Prayer :: [2.16.114]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 114

Narrated Ibn 'Umar:

The Prophet used to offer (Nawafil) prayers on his Rahila (mount) facing its direction by signals, but not the compulsory prayer. He also used to pray Witr on his (mount) Rahila.


Bukhari :: Witr Prayer :: [2.16.115]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 115

Narrated Muhammad bin Sirin:

Anas was asked, "Did the Prophet recite Qunut in the Fajr prayer?" Anas replied in the affirmative. He was further asked, "Did he recite Qunut before bowing?" Anas replied, "He recited Qunut after bowing for some time (for one month)."


Bukhari :: Witr Prayer :: [2.16.116]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 116

Narrated 'Asim:

I asked Anas bin Malik about the Qunut. Anas replied, "Definitely it was (recited)". I asked, "Before bowing or after it?" Anas replied, "Before bowing." I added, "So and so has told me that you had informed him that it had been after bowing." Anas said, "He told an untruth (i.e. "was mistaken," according to the Hijazi dialect). Allah's Apostle recited Qunut after bowing for a period of one month." Anas added, "The Prophet sent about seventy men (who knew the Quran by heart) towards the pagans (of Najd) who were less than they in number and there was a peace treaty between them and Allah's Apostles (but the Pagans broke the treaty and killed the seventy men). So Allah's Apostle recited Qunut for a period of one month asking Allah to punish them."


Bukhari :: Witr Prayer :: [2.16.117]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 117

Narrated Anas bin Malik:

The Prophet recited Qunut for one month (in the Fajr prayer) asking Allah to punish the tribes of Ral and Dhakwan.


Bukhari :: Witr Prayer :: [2.16.118]

Witr Prayer

Bukhari :: Book 2 :: Volume 16 :: Hadith 118

Narrated Anas:

The Qunut used to be recited in the Maghrib and the Fajr prayers.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.119]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 119

Narrated 'Abbas bin Tamim's uncle:

The Prophet (p.b.u.h) went out to offer the Istisqa' prayer and turned (and put on) his cloak inside out.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.120]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 120

Narrated Abu Huraira;

Whenever the Prophet (p.b.u.h) lifted his head from the bowing in the last Raka he used to say: "O Allah! Save 'Aiyash bin Abi Rabi'a. O Allah! Save Salama bin Hisham. O Allah! Save Walid bin Walid. O Allah! Save the weak faithful believers. O Allah! Be hard on the tribes of Mudar and send (famine) years on them like the famine years of (Prophet) Joseph ." The Prophet further said, "Allah forgive the tribes of Ghifar and save the tribes of Aslam." Abu Az-Zinad (a sub-narrator) said, "The Qunut used to be recited by the Prophet in the Fajr prayer."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.121]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 121

Narrated Masruq:

We were with 'Abdullah and he said, "When the Prophet saw the refusal of the people to accept Islam he said, "O Allah! Send (famine) years on them for (seven years) like the seven years (of famine during the time) of (Prophet) Joseph." So famine overtook them for one year and destroyed every kind of life to such an extent that the people started eating hides, carcasses and rotten dead animals. Whenever one of them looked towards the sky, he would (imagine himself to) see smoke because of hunger. So Abu Sufyan went to the Prophet and said, "O Muhammad! You order people to obey Allah and to keep good relations with kith and kin. No doubt the people of your tribe are dying, so please pray to Allah for them." So Allah revealed: "Then watch you For the day that The sky will bring forth a kind Of smoke Plainly visible ... Verily! You will return (to disbelief) On the day when We shall seize You with a mighty grasp. (44.10-16) Ibn Masud added, "Al-Batsha (i.e. grasp) happened in the battle of Badr and no doubt smoke, Al-Batsha, Al-Lizam, and the verse of Surat Ar-Rum have all passed .


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.122]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 122

Narrated 'Abdullah bin Dinar:

My father said, "I heard Ibn 'Umar reciting the poetic verses of Abu Talib: And a white (person) (i.e. the Prophet) who is requested to pray for rain and who takes care of the orphans and is the guardian of widows." Salim's father (Ibn 'Umar) said, "The following poetic verse occurred to my mind while I was looking at the face of the Prophet (p.b.u.h) while he was praying for rain. He did not get down till the rain water flowed profusely from every roof-g utter: And a white (person) who is requested to pray for rain and who takes care of the orphans and is the guardian of widows . . . And these were the words of Abu Talib."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.123]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 123

Narrated Anas:

Whenever drought threatened them, 'Umar bin Al-Khattab, used to ask Al-Abbas bin 'Abdul Muttalib to invoke Allah for rain. He used to say, "O Allah! We used to ask our Prophet to invoke You for rain, and You would bless us with rain, and now we ask his uncle to invoke You for rain. O Allah ! Bless us with rain."(1) And so it would rain.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.124]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 124

Narrated 'Abdullah bin Zaid:

The Prophet turned his cloak inside out on Istisqa.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.125]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 125

Narrated 'Abdullah bin Zaid

The Prophet went towards the Musalla and invoked Allah for rain. He faced the Qibla and wore his cloak inside out, and offered two Rakat.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.126]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 126

Narrated Sharik bin 'Abdullah bin Abi Namir:

I heard Anas bin Malik saying, "On a Friday a person entered the main Mosque through the gate facing the pulpit while Allah's Apostle was delivering the Khutba. The man stood in front of Allah's Apostle and said, 'O Allah's Apostle! The livestock are dying and the roads are cut off; so please pray to Allah for rain.' " Anas added, "Allah's Apostle (p.b.u.h) raised both his hands and said, 'O Allah! Bless us with rain! O Allah! Bless us with rain! O Allah! Bless us with rain!' " Anas added, "By Allah, we could not see any trace of cloud in the sky and there was no building or a house between us and (the mountains of) Sila." Anas added, "A heavy cloud like a shield appeared from behind it (i.e. Sila' Mountain). When it came in the middle of the sky, it spread and then rained." Anas further said, "By Allah! We could not see the sun for a week. Next Friday a person entered through the same gate and at that time Allah's Apostle was delivering the Friday's Khutba. The man stood in front of him and said, 'O Allah's Apostle! The livestock are dying and the roads are cut off, please pray to Allah to with-hold rain.' " Anas added, "Allah's Apostle I raised both his hands and said, 'O Allah! Round about us and not on us. O Allah! On the plateaus, on the mountains, on the hills, in the valleys and on the places where trees grow.' So the rain stopped and we came out walking in the sun." Sharik asked Anas whether it was the same person who had asked for the rain (the last Friday). Anas replied that he did not know.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.127]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 127

Narrated Sharik:

Anas bin Malik said, "A person entered the Mosque on a Friday through the gate facing the Daril-Qada' and Allah's Apostle was standing delivering the Khutba (sermon). The man stood in front of Allah's Apostle and said, 'O Allah's Apostle, livestock are dying and the roads are cut off; please pray to Allah for rain.' So Allah's Apostle (p.b.u.h) raised both his hands and said, 'O Allah! Bless us with rain. O Allah! Bless us with rain. O Allah! Bless us with rain!" Anas added, "By Allah, there were no clouds in the sky and there was no house or building between us and the mountain of Silas'. Then a big cloud like a shield appeared from behind it (i.e. Silas Mountain) and when it came in the middle of the sky, it spread and then rained. By Allah! We could not see the sun for a week. The next Friday, a person entered through the same gate and Allah's Apostle was delivering the Friday Khutba and the man stood in front of him and said, 'O Allah's Apostle! The livestock are dying and the roads are cut off; Please pray to Allah to withhold rain.' " Anas added, "Allah's Apostle raised both his hands and said, 'O Allah! Round about us and not on us. O Allah!' On the plateaus, on the mountains, on the hills, in the valleys and on the places where trees grow.' " Anas added, "The rain stopped and we came out, walking in the sun." Sharik asked Anas whether it was the same person who had asked for rain the previous Friday. Anas replied that he did not know.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.128]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 128

Narrated Qatada:

Anas I said, "While Allah's Apostle (p.b.u.h) was delivering the Friday Khutba (sermon) a man came and said, 'O Allah's Apostle! Rain is scarce; please ask Allah to bless us with rain.' So he invoked Allah for it, and it rained so much that we could hardly reach our homes and it continued raining till the next Friday." Anas further said, "Then the same or some other person stood up and said, 'O Allah's Apostle! Invoke Allah to withhold the rain.' On that, Allah's Apostle I said, 'O Allah! Round about us and not on us.' " Anas added, "I saw the clouds dispersing right and left and it continued to rain but not over Medina."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.129]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 129

Narrated Anas:

A man came to the Prophet (p.b.u.h) and said, "Livestock are destroyed and the roads are cut off." So Allah's Apostle invoked Allah for rain and it rained from that Friday till the next Friday. The same person came again and said, "Houses have collapsed, roads are cut off, and the livestock are destroyed. Please pray to Allah to withhold the rain." Allah's Apostle (stood up and) said, "O Allah! (Let it rain) on the plateaus, on the hills, in the valleys and over the places where trees grow." So the clouds cleared away from Medina as clothes are taken off .


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.130]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 130

Narrated Anas bin Malik:

A man came to Allah's Apostle and said, "O Allah's Apostle! Livestock are destroyed and the roads are cut off. So please invoke Allah." So Allah's Apostle prayed and it rained from that Friday to the next Friday. Then he came to Allah's Apostle I and said, "O Allah's Apostle! Houses have collapsed, roads are cut off and the livestock are destroyed." So Allah's Apostle (p.b.u.h) prayed, "O Allah! (Let it rain) on the tops of mountains, on the plateaus, in the valleys and over the places where trees grow." So the clouds cleared away from Medina as clothes are taken off.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.131]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 131

Narrated Anas bin Malik

I p man complained to the Prophet about the destruction of livestock and property and the hunger of the offspring. So he invoked (Allah for rain. The narrator (Anas) did not mention that the Prophet had worn his cloak inside out or faced the Qibla.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.132]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 132

Narrated Anas bin Malik

A man came to Allah's Apostle and said, "O Allah's Apostle! Livestock are destroyed and the roads are cut off; so please invoke Allah." So Allah's Apostle prayed for rain and it rained from that Friday till the next Friday. Then a man came to the Prophet (p.b.u.h) and said, "O Allah's Apostle! The houses have collapsed, roads are cut off and the livestock are destroyed." So Allah's Apostle said, "O Allah ! (Let it rain) on the tops of the mountains, on the plateaus, in the valleys and over the places where trees grow." So the clouds cleared away from Medina as clothes are taken off.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.133]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 133

Narrated Masruq:

One day I went to Ibn Masud who said, "When Quraish delayed in embracing Islam, the Prophet I invoked Allah to curse them, so they were afflicted with a (famine) year because of which many of them died and they ate the carcasses and Abu Sufyan came to the Prophet and said, 'O Muhammad! You came to order people to keep good relation with kith and kin and your nation is being destroyed, so invoke Allah I ? So the Prophet I recited the Holy verses of Sirat-Ad-Dukhan: 'Then watch you For the day that The sky will Bring forth a kind Of smoke Plainly visible.' (44.10) When the famine was taken off, the people renegade once again as nonbelievers. The statement of Allah, (in Sura "Ad-Dukhan"-44) refers to that: 'On the day when We shall seize You with a mighty grasp.' (44.16) And that was what happened on the day of the battle of Badr." Asbath added on the authority of Mansur, "Allah's Apostle prayed for them and it rained heavily for seven days. So the people complained of the excessive rain. The Prophet said, 'O Allah! (Let it rain) around us and not on us.' So the clouds dispersed over his head and it rained over the surroundings."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.134]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 134

Narrated Anas:

Allah's Apostle I was delivering the Khutba (sermon) on a Friday when the people stood up, shouted and said, "O Allah's Apostle! There is no rain (drought), the trees have dried and the livestock are destroyed; Please pray to Allah for rain." So Allah's Apostle said twice, "O Allah! Bless us with rain." By Allah, there was no trace of cloud in the sky and suddenly the sky became overcast with clouds and it started raining. The Prophet came down the pulpit and offered the prayer. When he came back from the prayer (to his house) it was raining and it rained continuously till the next Friday. When the Prophet started delivering the Friday Khutba (sermon), the people started shouting and said to him, "The houses have collapsed and the roads are cut off; so please pray to Allah to withhold the rain." So the Prophet smiled and said, "O Allah! Round about us and not on us." So the sky became clear over Medina but it kept on raining over the outskirts (of Medina) and not a single drop of rain fell over Median. I looked towards the sky which was as bright and clear as a crown.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.135]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 135

Narrated Abbas bin Tamim

that his uncle (who was one of the companions of the Prophet) had told him, "The Prophet went out with the people to invoke Allah for rain for them. He stood up and invoked Allah for rain, then faced the Qibla and turned his cloak (inside out) and it rained."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.136]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 136

Narrated Abbas bin Tamim

from his uncle who said, "The Prophet went out to invoke Allah for rain. He faced the Qibla invoking Allah. He turned over his cloak (inside out) and then offered two Rakat and recited the Quran aloud in them."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.137]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 137

Narrated Abbas bin Tamim from his uncle,

"I saw the Prophet on the day when he went out to offer the Istisqa' prayer. He turned his back towards the people and faced the Qibla and asked Allah for rain. Then he turned his cloak inside out and led us in a two Rakat prayer and recited the Qur'an aloud in them."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.138]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 138

Narrated Abbas bin Tamlm from his uncle who said,

"The Prophet invoked Allah for rain and offered a two Rakat prayer and he put his cloak inside out."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.139]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 139

Narrated Abbas bin Tamim from his uncle who said,

"The Prophet went out to the Musalla to offer the Istisqa' prayer, faced the Qibla and offered a two-Rakat prayer and turned his cloak inside out." Narrated Abu Bakr, "The Prophet put the right side of his cloak on his left side."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.140]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 140

Narrated 'Abdullah bin Zaid Al-Ansari:

The Prophet went out towards the Musalla in order to offer the Istisqa' prayer and when he intended to invoke (Allah) or started invoking, he faced the Qibla and turned his cloak inside out.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.141]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 141

Narrated Anas bin Malik

The Prophet never raised his hands for any invocation except for that of Istisqa' and he used to raise them so much that the whiteness of his armpits became visible. (Note: It may be that Anas did not see the Prophet raising his hands, but it is narrated that the Prophet used to raise his hands for invocations other than Istisqa. See Hadith No. 807 & 808 and also see Hadith No. 612, Vol. 5).


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.142]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 142

Narrated Aisha:

Whenever Allah's Apostle saw the rain, he used to say, "O Allah! Let it be a strong fruitful rain."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.143]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 143

Narrated Anas bin Malik:

In the life-time of Allah's Apostle (p.b.u.h) the people were afflicted with a (famine) year. While the Prophet was delivering the Khutba (sermon) on the pulpit on a Friday, a Bedouin stood up and said, "O Allah's Apostle! The livestock are dying and the families (offspring) are hungry: please pray to Allah to bless us with rain." Allah's Apostle raised both his hands towards the sky and at that time there was not a trace of cloud in they sky. Then the clouds started gathering like mountains. Before he got down from the pulpit I saw rain-water trickling down his beard. It rained that day, the next day, the third day, the fourth day and till the next Friday, when the same Bedouin or some other person stood up (during the Friday Khutba) and said, "O Allah's Apostle! The houses have collapsed and the livestock are drowned. Please invoke Allah for us." So Allah's Apostle raised both his hands and said, "O Allah! Around us and not on us." Whichever side the Prophet directed his hand, the clouds dispersed from there till a hole (in the clouds) was formed over Medina. The valley of Qanat remained flowing (with water) for one month and none, came from outside who didn't talk about the abundant rain.


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.144]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 144

Narrated Anas:

Whenever a strong wind blew, anxiety appeared on the face of the Prophet (fearing that wind might be a sign of Allah's wrath).


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.145]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 145

Narrated Ibn Abbas:

The Prophet said, "I was granted victory with As-Saba and the nation of 'Ad was destroyed by Ad-Dabur (westerly wind) .


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.146]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 146

Narrated Abu Huraira:

The Prophet said, "The Hour (Last Day) will not be established until (religious) knowledge will be taken away (by the death of religious learned men), earthquakes will be very frequent, time will pass quickly, afflictions will appear, murders will increase and money will overflow amongst you." (See Hadith No. 85 Vol 1).


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.147]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 147

Narrated Ibn 'Umar:

(The Prophet) said, "O Allah! Bless our Sham and our Yemen." People said, "Our Najd as well." The Prophet again said, "O Allah! Bless our Sham and Yemen." They said again, "Our Najd as well." On that the Prophet said, "There will appear earthquakes and afflictions, and from there will come out the side of the head of Satan."


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.148]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 148

Narrated Zaid bin Khalid Al-Juhani:

Allah's Apostle led the morning prayer in Al-Hudaibiya and it had rained the previous night. When the Prophet (p.b.u.h) had finished the prayer he faced the people and said, "Do you know what your Lord has said?" They replied, "Allah and His Apostle know better." (The Prophet said), "Allah says, 'In this morning some of My worshipers remained as true believers and some became non-believers; he who said that it had rained with the blessing and mercy of Allah is the one who believes in Me and does not believe in star, but he who said it had rained because of such and such (star) is a disbeliever in Me and is a believer in star.' "


Bukhari :: Invoking Allah for Rain (Istisqaa) :: [2.17.149]

Invoking Allah for Rain (Istisqaa)

Bukhari :: Book 2 :: Volume 17 :: Hadith 149

Narrated Ibn 'Umar:

Allah's Apostle (p.b.u.h) said, "Keys of the unseen knowledge are five which nobody knows but Allah . . . nobody knows what will happen tomorrow; nobody knows what is in the womb; nobody knows what he will gain tomorrow; nobody knows at what place he will die; and nobody knows when it will rain."


Bukhari :: Eclipses :: [2.18.150]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 150

Narrated Abu Bakra:

We were with Allah's Apostle when the sun eclipsed. Allah's Apostle stood up dragging his cloak till he entered the Mosque. He led us in a two-Rakat prayer till the sun (eclipse) had cleared. Then the Prophet (p.b.u.h) said, "The sun and the moon do not eclipse because of someone's death. So whenever you see these eclipses pray and invoke (Allah) till the eclipse is over."


Bukhari :: Eclipses :: [2.18.151]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 151

Narrated Abu Masud:

The Prophet said, "The sun and the moon do not eclipse because of the death of someone from the people but they are two signs amongst the signs of Allah. When you see them stand up and pray."


Bukhari :: Eclipses :: [2.18.152]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 152

Narrated Ibn 'Umar:

The Prophet said, "The sun and the moon do not eclipse because of the death or life (i.e. birth) of someone but they are two signs amongst the signs of Allah. When you see them offer the prayer."


Bukhari :: Eclipses :: [2.18.153]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 153

Narrated Al-Mughira bin Shu'ba:

"The sun eclipsed in the life-time of Allah's Apostle on the day when (his son) Ibrahim died. So the people said that the sun had eclipsed because of the death of Ibrahim. Allah's Apostle said, "The sun and the moon do not eclipse because of the death or life (i.e. birth) of some-one. When you see the eclipse pray and invoke Allah."


Bukhari :: Eclipses :: [2.18.154]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 154

Narrated 'Aisha :

In the life-time of Allah's Apostle (p.b.u.h) the sun eclipsed, so he led the people in prayer, and stood up and performed a long Qiyam, then bowed for a long while. He stood up again and performed a long Qiyam but this time the period of standing was shorter than the first. He bowed again for a long time but shorter than the first one, then he prostrated and prolonged the prostration. He did the same in the second Raka as he did in the first and then finished the prayer; by then the sun (eclipse) had cleared. He delivered the Khutba (sermon) and after praising and glorifying Allah he said, "The sun and the moon are two signs against the signs of Allah; they do not eclipse on the death or life of anyone. So when you see the eclipse, remember Allah and say Takbir, pray and give Sadaqa." The Prophet then said, "O followers of Muhammad! By Allah! There is none who has more ghaira (self-respect) than Allah as He has forbidden that His slaves, male or female commit adultery (illegal sexual intercourse). O followers of Muhammad! By Allah! If you knew that which I know you would laugh little and weep much.


Bukhari :: Eclipses :: [2.18.155]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 155

Narrated 'Abdullah bin 'Amr :

"When the sun eclipsed in the life-time of Allah's Apostle an announcement was made that a prayer was to be offered in congregation."


Bukhari :: Eclipses :: [2.18.156]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 156

Narrated 'Aisha:

(the wife of the Prophet (p.b.u.h) In the lifetime of the Prophet the sun eclipsed and he went to the Mosque and the people aligned behind him. He said the Takbir (starting the prayer) and prolonged the recitation (from the Quran) and then said Takbir and performed a prolonged bowing; then he (lifted his head and) said, "Sami allahu liman hamidah" (Allah heard him who sent his praises to Him). He then did not prostrate but stood up and recited a prolonged recitation which was shorter than the first recitation. He again said Takbir and then bowed a prolonged bowing but shorter than the first one and then said, "Sami 'a-l-lahu Lyman hamidah Rabbana walak-lhamd, (Allah heard him who sent his praises to Him. O our Sustainer! All the praises are for You)" and then prostrated and did the same in the second Raka; thus he completed four bowing and four prostrations. The sun (eclipse) had cleared before he finished the prayer. (After the prayer) he stood up, glorified and praised Allah as He deserved and then said, "The sun and the moon are two of the signs of Allah. They do not eclipse because of the death or the life (i.e. birth) of someone. When you see them make haste for the prayer." Narrated Az-Zuhri: I said to 'Ursa, "When the sun eclipsed at Medina your brother ('Abdullah bin Az-Zubair) offered only a two-Rakat prayer like that of the morning (Fajr) prayer." 'Ursa replied, "Yes, for he missed the Prophet's tradition (concerning this matter)."


Bukhari :: Eclipses :: [2.18.157]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 157

Narrated Aisha:

(the wife of the Prophet) On the day when the sun Khasafat (eclipsed) Allah's Apostle prayed; he stood up and said Takbir and recited a prolonged recitation, then he performed a prolonged bowing, then he raised his head and said, "Sami'a-l-lahu Lyman Hamidah," and then remained standing and recited a prolonged recitation which was shorter than the first. Then he performed a prolonged bowing which was shorter than the first. Then he prostrated and prolonged the prostration and he did the same in the second Raka as in the first and then finished the prayer with Taslim. By that time the sun (eclipse) had cleared He addressed the people and said, "The sun and the moon are two of the signs of Allah; they do not eclipse (Yakhsifan) because of the death or the life (i.e. birth) of someone. So when you see them make haste for the prayer."


Bukhari :: Eclipses :: [2.18.158]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 158

Narrated Abu Bakra:

Allah's Apostle said: "The sun and the moon are two signs amongst the signs of Allah and they do not eclipse because of the death of someone but Allah frightens His devotees with them."


Bukhari :: Eclipses :: [2.18.159]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 159

Narrated 'Amra bint 'AbdurRahman:

A Jewess came to ask 'Aisha (the wife of the Prophet) about something. She said to her, "May Allah give you refuge from the punishment of the grave." So 'Aisha ' asked Allah's Apostle "Would the people be punished in their graves?" Allah's Apostle after seeking refuge with Allah from the punishment of the grave (and thus replied in the affirmative). Then one day, Allah's Apostle rode to go to some place but the sun eclipsed. He returned in the forenoon and passed through the rear of the dwellings (of his wives) and stood for the (eclipse) prayer, and the people stood behind him. He stood up for a long period and then performed a prolonged bowing which was shorter than the first bowing. Then he raised his head and prostrated. Then he stood up (for the second Raka) for a long while but the standing was shorter than that of the first Raka. Then he performed a prolonged bowing which was shorter than the first one. Then he raised his head and prostrated. Then he stood up for a long time but shorter than the first. Then he performed a prolonged bowing but shorter than the first. Then he raised his head and prostrated and finished the prayer and (then delivered the sermon and) said as much as Allah wished. And then he ordered the people to seek refuge with Allah from the punishment of the grave.


Bukhari :: Eclipses :: [2.18.160]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 160

Narrated 'Abdullah bin 'Amr

When the sun eclipsed in the lifetime of Allah's Apostle and an announcement was made that the prayer was to be held in congregation. The Prophet performed two bowing in one Raka. Then he stood up and performed two bowing in one Raka. Then he sat down and finished the prayer; and by then the (eclipse) had cleared 'Aisha said, "I had never performed such a long prostration."


Bukhari :: Eclipses :: [2.18.161]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 161

Narrated 'Abdullah bin Abbas:

The sun eclipsed in the life-time of the Prophet (p.b.u.h) . Allah's Apostle offered the eclipse prayer and stood for a long period equal to the period in which one could recite Surat-al-Baqara. Then he bowed for a long time and then stood up for a long period which was shorter than that of the first standing, then bowed again for a long time but for a shorter period than the first; then he prostrated twice and then stood up for a long period which was shorter than that of the first standing; then he bowed for a long time which was shorter than the previous one, and then he raised his head and stood up for a long period which was shorter than the first standing, then he bowed for a long time which was shorter than the first bowing, and then prostrated (twice) and finished the prayer. By then, the sun (eclipse) had cleared. The Prophet then said, "The sun and the moon are two of the signs of Allah. They eclipse neither because of the death of somebody nor because of his life (i.e. birth). So when you see them, remember Allah." The people say, "O Allah's Apostle! We saw you taking something from your place and then we saw you retreating." The Prophet replied, "I saw Paradise and stretched my hands towards a bunch (of its fruits) and had I taken it, you would have eaten from it as long as the world remains. I also saw the Hell-fire and I had never seen such a horrible sight. I saw that most of the inhabitants were women." The people asked, "O Allah's Apostle! Why is it so?" The Prophet replied, "Because of their ungratefulness." It was asked whether they are ungrateful to Allah. The Prophet said, "They are ungrateful to their companions of life (husbands) and ungrateful to good deeds. If you are benevolent to one of them throughout the life and if she sees anything (undesirable) in you, she will say, 'I have never had any good from you.' "


Bukhari :: Eclipses :: [2.18.162]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 162

Narrated Fatima bint Al-Mundhir:

Asma' bint Al Bakr said, "I came to 'Aisha the wife of the Prophet (p.b.u.h) during the solar eclipse. The people were standing and offering the prayer and she was also praying too. I asked her, 'What has happened to the people?' She pointed out with her hand towards the sky and said, 'Subhan-Allah'. I said, 'Is there a sign?' She pointed out in the affirmative." Asma' further said, "I too then stood up for the prayer till I fainted and then poured water on my head. When Allah's Apostle had finished his prayer, he thanked and praised Allah and said, 'I have seen at this place of mine what I have never seen even Paradise and Hell. No doubt, it has been inspired to me that you will be put to trial in the graves like or nearly like the trial of (Masih) Ad-Dajjal. (I do not know which one of the two Asma' said.) (The angels) will come to everyone of you and will ask what do you know about this man (i.e. Muhammad). The believer or a firm believer (I do not know which word Asma' said) will reply, 'He is Muhammad, Allah's Apostle (p.b.u.h) who came to us with clear evidences and guidance, so we accepted his teachings, believed and followed him.' The angels will then say to him, 'Sleep peacefully as we knew surely that you were a firm believer.' The hypocrite or doubtful person (I do not know which word Asma' said) will say, 'I do not know. I heard the people saying something so I said it (the same).' "


Bukhari :: Eclipses :: [2.18.163]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 163

Narrated Asma:

No doubt the Prophet ordered people to manumit slaves during the solar eclipse.


Bukhari :: Eclipses :: [2.18.164]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 164

Narrated 'Amra bint 'AbdurRahman:

A Jewess came to 'Aisha to ask her about something and then she said, "May Allah give you refuge from the punishment of the grave." So 'Aisha asked Allah's Apostle, "Would the people be punished in their graves?" Allah's Apostle asked Allah's refuge from the punishment of the grave (indicating an affirmative reply). Then one day Allah's Apostle rode (to leave for some place) but the sun eclipsed. He returned on the forenoon and passed through the rear of the dwellings (of his wives) and stood up and started offering the (eclipse) prayer and the people stood behind him. He stood for a long period and then performed a long bowing and then stood straight for a long period which was shorter than that of the first standing, then he performed a prolonged bowing which was shorter than the first bowing, then he raised his head and prostrated for a long time and then stood up (for the second Raka) for a long while, but the standing was shorter than the standing of the first Raka. Then he performed a prolonged bowing which was shorter than that of the first one. He then stood up for a long time but shorter than the first, then again performed a long bowing which was shorter than the first and then prostrated for a shorter while than that of the first prostration. Then he finished the prayer and delivered the sermon and) said what Allah wished; and ordered the people to seek refuge with Allah from the punishment of the grave.


Bukhari :: Eclipses :: [2.18.165]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 165

Narrated Abu Masud:

Allah's Apostle said, "The sun and the moon do not eclipse because of someone's death or life but they are two signs amongst the signs of Allah, so pray whenever you see them."


Bukhari :: Eclipses :: [2.18.166]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 166

Narrated 'Aisha:

In the lifetime of the Prophet the sun eclipsed and the Prophet (p.b.u.h) stood up to offer the prayer with the people and recited a long recitation, then he performed a prolonged bowing, and then lifted his head and recited a prolonged recitation which was shorter than the first. Then he performed a prolonged bowing which was shorter than the first and then lifted his head and performed two prostrations. He then stood up for the second Raka and offered it like the first. Then he stood up and said, "The sun and the moon do not eclipse because of someone's life or death but they are two signs amongst the signs of Allah which He shows to His worshipers. So whenever you see them, make haste for the prayer."


Bukhari :: Eclipses :: [2.18.167]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 167

Narrated Abu Musa:

The sun eclipsed and the Prophet got up, being afraid that it might be the Hour (i.e. Day of Judgment). He went to the Mosque and offered the prayer with the longest Qiyam, bowing and prostration that I had ever seen him doing. Then he said, "These signs which Allah sends do not occur because of the life or death of somebody, but Allah makes His worshipers afraid by them. So when you see anything thereof, proceed to remember Allah, invoke Him and ask for His forgiveness."


Bukhari :: Eclipses :: [2.18.168]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 168

Narrated Al-Mughira bin Shu'ba :

On the day of Ibrahim's death, the sun eclipsed and the people said that the eclipse was due to the death of Ibrahim (the son of the Prophet). Allah's Apostle said, "The sun and the moon are two signs amongst the signs of Allah. They do not eclipse because of someone's death or life. So when you see them, invoke Allah and pray till the eclipse is clear."


Bukhari :: Eclipses :: [2.18.169]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 169

Narrated Abu Bakra:

In the life-time of the Prophet the sun eclipsed and then he offered a two Rakat prayer.


Bukhari :: Eclipses :: [2.18.170]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 170

Narrated Abu Bakra:

In the life-time of the Allah's Apostle (p.b.u.h) the sun eclipsed and he went out dragging his clothes till he reached the Mosque. The people gathered around him and he led them and offered two Rakat. When the sun (eclipse) cleared, he said, "The sun and the moon are two signs amongst the signs of Allah; they do not eclipse because of the death of someone, and so when an eclipse occurs, pray and invoke Allah till the eclipse is over." It happened that a son of the Prophet called Ibrahim died on that day and the people were talking about that (saying that the eclipse was caused by his death).


Bukhari :: Eclipses :: [2.18.171]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 171

Narrated Aisha:

The Prophet led us and performed four bowing in two Rakat during the solar eclipse and the first Raka was longer.


Bukhari :: Eclipses :: [2.18.172]

Eclipses

Bukhari :: Book 2 :: Volume 18 :: Hadith 172

Narrated 'Aisha:

The Prophet (p.b.u.h) recited (the Quran) aloud during the eclipse prayer and when he had finished the eclipse prayer he said the Takbir and bowed. When he stood straight from bowing he would say "Sami 'al-l-ahu Lyman hamidah Rabbana walaka-l-hamd." And he would again start reciting. In the eclipse prayer there are four bowing and four prostrations in two Rakat. Al-Auza'i and others said that they had heard Az-Zuhi from 'Ursa from 'Aisha saying, "In the life-time of Allah's Apostle the sun eclipsed, and he made a person to announce: 'Prayer in congregation.' He led the prayer and performed four bowing and four prostrations in two Rakat." Narrated Al-Walid that 'Abdur-Rahman bin Namir had informed him that he had heard the same. Ibn Shihab heard the same. Az-Zuhrl said, "I asked ('Ursa), 'What did your brother 'Abdullah bin AzZubair do? He prayed two Rakat (of the eclipse prayer) like the morning prayer, when he offered the (eclipse) prayer in Median.' 'Ursa replied that he had missed (i.e. did not pray according to) the Prophet's tradition." Sulaiman bin Kathir and Sufyan bin Husain narrated from Az-Zuhri that the prayer for the eclipse used to be offered with loud recitation.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.173]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 173

Narrated 'Abdullah bin Masud :

The Prophet recited Suratan-Najm (103) at Mecca and prostrated while reciting it and those who were with him did the same except an old man who took a handful of small stones or earth and lifted it to his forehead and said, "This is sufficient for me." Later on, I saw him killed as a non-believer.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.174]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 174

Narrated Abu Huraira:

On Fridays the Prophet used to recite Alf Lam Mim Tanzil-As-Sajda (in the first Raka) and Hal ata'alal-lnsani i.e. Suratad-Dahr (LXXVI) (in the second Raka), in the Fajr prayer.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.175]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 175

Narrated Ibn Abbas:

The prostration of Sad is not a compulsory one but I saw the Prophet prostrating while reciting it.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.176]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 176

Narrated 'Abdullah bin Masud:

The Prophet recited Surat-an-Najm (53) and prostrated while reciting it and all the people prostrated and a man amongst the people took a handful of stones or earth and raised it to his face and said, "This is sufficient for me." Later on I saw him killed as a non-believer.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.177]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 177

Narrated Ibn Abbas:

The Prophet I prostrated while reciting An-Najm and with him prostrated the Muslims, the pagans, the jinns, and all human beings.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.178]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 178

Narrated 'Ata' bin Yasar:

I asked Zaid bin Thabit about prostration on which he said that he had recited An-Najm before the Prophet, yet he (the Prophet) had not performed a prostration.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.179]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 179

Narrated Zaid bin Thabit:

I recited An-Najm before the Prophet, yet he did not perform a prostration.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.180]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 180

Narrated Abu Salma:

I saw Abu Huraira reciting Idha-Sama' un-Shaqqat and he prostrated during its recitation. I asked Abu Huraira, "Didn't I see you prostrating?" Abu Huraira said, "Had I not seen the Prophet prostrating, I would not have prostrated."


Bukhari :: Prostration During Recital of Qur'an :: [2.19.181]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 181

Narrated Ibn Umar:

When the Prophet recited a Sura that contained the prostration he would prostrate and we would do the same and some of us (because of the heavy rush) could not find a place for prostration.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.182]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 182

Narrated Ibn 'Umar,

When the Prophet recited Surat As-Sajda and we were with him, he would prostrate and we also would prostrate with him and some of us (because of the heavy rush) would not find a place (for our foreheads) to prostrate on.


Bukhari :: Prostration During Recital of Qur'an :: [2.19.183]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 183

Narrated Rabi'a:

'Umar bin Al-Khattab recited Surat-an-Nahl on a Friday on the pulpit and when he reached the verse of Sajda he got down from the pulpit and prostrated and the people also prostrated. The next Friday 'Umar bin Al-Khattab recited the same Sura and when he reached the verse of Sajda he said, "O people! When we recite the verses of Sajda (during the sermon) whoever prostrates does the right thing, yet it is no sin for the one who does not prostrate." And 'Umar did not prostrate (that day). Added Ibn 'Umar "Allah has not made the prostration of recitation compulsory but if we wish we can do it."


Bukhari :: Prostration During Recital of Qur'an :: [2.19.184]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 184

Narrated Abu Rafi:

I offered the 'Isha' prayer behind Abu Huraira and he recited Idhas-Sama' Un-Shaqqat, and prostrated. I said, "What is this?" Abu Huraira said, "I prostrated behind Abu-l-Qasim and I will do the same till I meet him."


Bukhari :: Prostration During Recital of Qur'an :: [2.19.185]

Prostration During Recital of Qur'an

Bukhari :: Book 2 :: Volume 19 :: Hadith 185

Narrated Ibn 'Umar.

Whenever the Prophet recited the Sura which contained the prostration of recitation he used to prostrate and then, we, too, would prostrate and some of us did not find a place for prostration.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.186]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 186

Narrated Ibn Abbas :

The Prophet once stayed for nineteen days and prayed shortened prayers. So when we travel led (and stayed) for nineteen days, we used to shorten the prayer but if we travelled (and stayed) for a longer period we used to offer the full prayer.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.187]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 187

Narrated Yahya bin Ishaq:

I heard Anas saying, "We travelled with the Prophet from Medina to Mecca and offered two Rakat (for every prayer) till we returned to Medina." I said, "Did you stay for a while in Mecca?" He replied, "We stayed in Mecca for ten days."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.188]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 188

Narrated 'Abdullah bin 'Umar:

I offered the prayer with the Prophet, Abu Bakr and 'Umar at Mina and it was of two Rakat. 'Uthman in the early days of his caliphate did the same, but later on he started praying the full prayer.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.189]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 189

Narrated Haritha bin Wahab:

The Prophet I led us in the prayer at Mina during the peace period by offering two Rakat.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.190]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 190

Narrated 'Abdur Rahman bin Yazid:

We offered a four Rakat prayer at Mina behind Ibn 'Affan . 'Abdullah bin Masud was informed about it. He said sadly, "Truly to Allah we belong and truly to Him we shall return." And added, "I prayed two Rakat with Allah's Apostle at Mina and similarly with Abu Bakr and with 'Umar (during their caliphates)." He further said, "May I be lucky enough to have two of the four Rakat accepted (by Allah)."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.191]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 191

Narrated Ibn Abbas:

The Prophet and his companions reached Mecca in the morning of the 4th Dhul-Hijja reciting Talbiya (O Allah! We are obedient to your orders, we respond 4 to your call) . . . intending to perform Hajj. The Prophet ordered his companions to assume the lhram for Umra instead of Hajj, excepting those who had Hadi (sacrifice) with them.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.192]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 192

Narrated Ibn 'Umar:

The Prophet said, "A woman should not travel for more than three days except with a Dhi-Mahram (i.e. a male with whom she cannot marry at all, e.g. her brother, father, grandfather, etc.) or her own husband.)"


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.193]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 193

Narrated Ibn'Umar:

The Prophet said, "A woman should not travel for more than three days except with a Dhi-Mahram."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.194]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 194

Narrated Abu Huraira:

The Prophet (p.b.u.h) said, "It is not permissible for a woman who believes in Allah and the Last Day to travel for one day and night except with a Mahram."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.195]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 195

Narrated Anas bin Malik :

offered four Rakat of Zuhr prayer with the Prophet (p.b.u.h) at Medina and two Rakat at Dhul-Hulaifa. (i.e. shortened the 'Asr prayer).


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.196]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 196

Narrated 'Aisha:

"When the prayers were first enjoined they were of two Rakat each. Later the prayer in a journey was kept as it was but the prayers for non-travellers were completed." Az-Zuhri said, "I asked 'Urwa what made Aisha pray the full prayers (in journey)." He replied, "She did the same as 'Uthman did."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.197]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 197

Narrated 'Abdullah bin 'Umar:

"I saw Allah's Apostle delaying the Maghrib prayer till he offered it along with the 'Isha' prayer whenever he was in a hurry during the journey." Salim narrated, "Ibn 'Umar used to do the same whenever he was in a hurry during the journey." And Salim added, "Ibn 'Umar used to pray the Maghrib and 'Isha' prayers together in Al-Muzdalifa." Salim said, "Ibn 'Umar delayed the Maghrib prayer because at that time he heard the news of the death of his wife Safiya bint Abi 'Ubaid. I said to him, 'The prayer (is due).' He said, 'Go on.' Again I said, 'The prayer (is due).' He said, 'Go on,' till we covered two or three miles. Then he got down, prayed and said, 'I saw the Prophet praying in this way, whenever he was in a hurry during the journey.' 'Abdullah (bin 'Umar) added, "Whenever the Prophet was in a hurry, he used to delay the Maghrib prayer and then offer three Rakat (of the Maghrib) and perform Taslim, and after waiting for a short while, Iqama used to be pronounced for the 'Isha' prayer when he would offer two Rakat and perform Taslim. He would never offer any optional prayer till the middle of the night (when he used to pray the Tahajjud)."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.198]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 198

Narrated 'Abdullah bin 'Amir from his father who said:

I saw the Prophet (p.b.u.h) offering the prayer on his mount (Rahila) whatever direction it took.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.199]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 199

Narrated Jabir bin 'Abdullah,

The Prophet used to offer the Nawafil, while riding, facing a direction other than that of the Qibla.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.200]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 200

Narrated Nafi:

Ibn 'Umar (while on a journey) used to offer the prayer and the Witr on his mount (Rahila). He said that the Prophet used to do so.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.201]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 201

Narrated 'Abdullah bin Dinar:

On traveling, 'Abdullah bin 'Umar used to offer the prayer on his Mount by signs whatever direction it took. 'Abdullah said that the Prophet used to do so.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.202]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 202

Narrated 'Amir bin Rabi'a,

I saw the Prophet on his Mount praying Nawafil by nodding his head, whatever direction he faced, but Allah's Apostle never did the same in offering the compulsory prayers. Narrated Salim: At night'Abdullah bin 'Umar used to offer the prayer on the back of his animal during the journey and never cared about the direction he faced. Ibn 'Umar said, "Allah's Apostle used to offer the optional prayer on the back of his Mount facing any direction and also used to pray the Witr on it but never offered the compulsory prayer on it."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.203]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 203

Narrated Jabir bin 'Abdullah

The Prophet used to pray (the Nawafil) on his Mount facing east and whenever he wanted to offer the compulsory prayer, he used to dismount and face the Qibla.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.204]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 204

Narrated Anas bin Sirin:

We went to receive Anas bin Malik when he returned from Sham and met him at a place called 'Ain-at-Tamr. I saw him praying riding the donkey, with his face to this direction, i.e. to the left of the Qibla. I said to him, "I have seen you offering the prayer in a direction other than that of the Qibla." He replied, "If I had not seen Allah's Apostle doing it, I would not have done it."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.205]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 205

Narrated Hafs bin 'Asim:

Ibn 'Umar went on a journey and said, "I accompanied the Prophet and he did not offer optional prayers during the journey, and Allah says: 'Verily! In Allah's Apostle you have a good example to follow.' " (33.21)


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.206]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 206

Narrated Ibn 'Umar :

I accompanied Allah's Apostle and he never offered more than two Rakat during the journey. Abu Bakr, 'Umar and 'Uthman used to do the same.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.207]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 207

Narrated Ibn Abu Laila:

Only Um Hani told us that she had seen the Prophet (p.b.u.h) offering the Duha (forenoon prayer). She said, "On the day of the conquest of Mecca, the Prophet took a bath in my house and offered eight Rakat. I never saw him praying such a light prayer but he performed perfect prostration and bowing. Narrated 'Abdullah bin amir that his father had told him that he had seen the Prophet (p.b.u.h) praying Nawafil at night on the back of his Mount on a journey, facing whatever direction it took.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.208]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 208

Narrated Salim bin Abdullah:

Ibn 'Umar said, "Allah's Apostle used to pray the Nawafil on the back of his Mount (carriage) by signs facing any direction." Ibn 'Umar used to do the same.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.209]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 209

Narrated Salim's father:

The Prophet used to offer the Maghrib and Isha' prayers together whenever he was in a hurry on a journey.

Narrated Ibn Abbas: Allah's Apostle used to offer the Zuhr and 'Asr prayers together on journeys, and also used to offer the Maghrib and 'Isha' prayers together.

Narrated Anas bin Malik: The Prophet used to offer the Maghrib and the 'Isha' prayers together on journeys.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.210]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 210

Narrated Az-Zuhri:

Salim told me, "'Abdullah bin 'Umar said, 'I saw Allah's Apostle delaying the Maghrib prayer till he offered it along with the Isha prayer whenever he was in a hurry during the journey.' " Salim said, "Abdullah bin Umar used to do the same whenever he was in a hurry during the journey. After making the call for Iqama, for the Maghrib prayer he used to offer three Rakat and then perform Tasllm. After waiting for a short while, he would pronounce the Iqama for the 'Isha' prayer and offer two Rakat and perform Taslim. He never prayed any Nawafil in between the two prayers or after the 'Isha' prayers till he got up in the middle of the night (for Tahajjud prayer)."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.211]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 211

Narrated Anas:

Allah's Apostle used to offer these two prayers together on journeys i.e. the Maghrib and the 'Isha'.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.212]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 212

Narrated Anas bin Malik:

Whenever the Prophet started a journey before noon, he used to delay the Zuhr prayer till the time of 'Asr and then offer them together; and if the sun declined (at noon) he used to offer the Zuhr prayer and then ride (for the journey).


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.213]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 213

Narrated Anas bin Malik:

Whenever the Prophet started the journey before noon, he used to delay the Zuhr prayer till the time for the 'Asr prayer and then he would dismount and pray them together; and whenever the sun declined before he started the journey he used to offer the Zuhr prayer and then ride (for the journey).


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.214]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 214

Narrated 'Aisha:

Allah's Apostle prayed in his house while sitting during his illness and the people prayed behind him standing and he pointed to them to sit down. When he had finished the prayer, he said, "The Imam is to be followed and so when he bows you should bow; and when he lifts his head you should also do the same."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.215]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 215

Narrated Anas bin Malik:

Allah's Apostle (p.b.u.h) fell down from a horse and his right side was either injured or scratched, so we went to inquire about his health. The time for the prayer became due and he offered the prayer while sitting and we prayed while standing. He said, "The Imam is to be followed; so if he says Takbir, you should also say Takbir, and if he bows you should also bow; and when he lifts his head you should also do the same and if he says: Sami'a-l-lahu Liman Hamidah (Allah hears whoever sends his praises to Him) you should say: Rabbana walakal-Hamd (O our Lord! All the praises are for You.") (See Hadith No. 656 Vol. 1).


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.216]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 216

Narrated 'Imran bin Husain:

(who had piles) I asked Allah's Apostle about the praying of a man while sitting. He said, "If he prays while standing it is better and he who prays while sitting gets half the reward of that who prays standing; and whoever prays while Lying gets half the reward of that who prays while sitting."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.217]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 217

Narrated'Abdullah bin Buraida:

'Imran bin Husain had piles. Once Abu Ma mar narrated from 'Imran bin Husain had said, "I asked the Prophet (p.b.u.h) about the prayer of a person while sitting. He said, 'It is better for one to pray standing; and whoever prays sitting gets half the reward of that who prays while standing; and whoever prays while Lying gets half the reward of that who prays while sitting.' "


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.218]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 218

Narrated 'Imran bin Husain:

had piles, so I asked the Prophet about the prayer. He said, "Pray while standing and if you can't, pray while sitting and if you cannot do even that, then pray Lying on your side."


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.219]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 219

Narrated Aisha:

(the mother of the faithful believers) I never saw Allah's Apostle offering the night prayer while sitting except in his old age and then he used to recite while sitting and whenever he wanted to bow he would get up and recite thirty or forty verses (while standing) and then bow.


Bukhari :: Shortening the Prayers (At-Taqseer) :: [2.20.220]

Shortening the Prayers (At-Taqseer)

Bukhari :: Book 2 :: Volume 20 :: Hadith 220

Narrated 'Aisha:

(the mother of the faithful believers) Allah's Apostle (in his last days) used to pray sitting. He would recite while sitting, and when thirty or forty verses remained from the recitation he would get up and recite them while standing and then he would bow and prostrate. He used to do the same in the second Raka. After finishing the Prayer he used to look at me and if I was awake he would talk to me and if I was asleep, he would lie down.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.221]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 221

Narrated Ibn Abbas:

When the Prophet got up at night to offer the Tahajjud prayer, he used to say: Allahumma lakal-hamd. Anta qaiyimus-samawati wal-ard wa man fihinna. Walakal-hamd, Laka mulkus-samawati wal-ard wa man fihinna. Walakal-hamd, anta nurus-samawati wal-ard. Walakalhamd, anta-l-haq wa wa'duka-l-haq, wa liqa'uka Haq, wa qualuka Haq, wal-jannatu Han wan-naru Haq wannabiyuna Haq. Wa Muhammadun, sallal-lahu'alaihi wasallam, Haq, was-sa'atu Haq. Allahumma aslamtu Laka wabika amantu, wa 'Alaika tawakkaltu, wa ilaika anabtu wa bika khasamtu, wa ilaika hakamtu faghfir li ma qaddamtu wama akh-khartu wama as-rartu wama'a lantu, anta-l-muqaddim wa anta-l-mu akh-khir, la ilaha illa anta (or la ilaha ghairuka). (O Allah! All the praises are for you, You are the Holder of the Heavens and the Earth, And whatever is in them. All the praises are for You; You have the possession of the Heavens and the Earth And whatever is in them. All the praises are for You; You are the Light of the Heavens and the Earth And all the praises are for You; You are the King of the Heavens and the Earth; And all the praises are for You; You are the Truth and Your Promise is the truth, And to meet You is true, Your Word is the truth And Paradise is true And Hell is true And all the Prophets (Peace be upon them) are true; And Muhammad is true, And the Day of Resurrection is true. O Allah ! I surrender (my will) to You; I believe in You and depend on You. And repent to You, And with Your help I argue (with my opponents, the non-believers) And I take You as a judge (to judge between us). Please forgive me my previous And future sins; And whatever I concealed or revealed And You are the One who make (some people) forward And (some) backward. There is none to be worshipped but you . Sufyan said that 'Abdul Karim Abu Umaiya added to the above, 'Wala haula Wala quwata illa billah' (There is neither might nor power except with Allah).


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.222]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 222

Narrated Salim's father:

In the life-time of the Prophet whosoever saw a dream would narrate it to Allah's Apostle. I had a wish of seeing a dream to narrate it to Allah's Apostle (p.b.u.h) I was a grown up boy and used to sleep in the Mosque in the life-time of the Prophet. I saw in the dream that two angels caught hold of me and took me to the Fire which was built all round like a built well and had two poles in it and the people in it were known to me. I started saying, "I seek refuge with Allah from the Fire." Then I met another angel who told me not to be afraid. I narrated the dream to Hafsa who told it to Allah's Apostle. The Prophet said, "Abdullah is a good man. I wish he prayed Tahajjud." After that 'Abdullah (i.e. Salim's father) used to sleep but a little at night.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.223]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 223

Narrated 'Aisha:

Allah's Apostle used to offer eleven Rakat and that was his prayer. He used to prolong the prostration to such an extent that one could recite fifty verses (of the Quran) before he would lift his head. He used to pray two Rakat (Sunna) before the Fajr prayer and then used to lie down on his right side till the call-maker came and informed him about the prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.224]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 224

Narrated Jundab:

The Prophet became sick and did not get up (for Tahajjud prayer) for a night or two.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.225]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 225

Narrated Jundab bin 'Abdullah :

Gabriel did not come to the Prophet (for some time) and so one of the Quraish women said, "His Satan has deserted him." So came the Divine Revelation: "By the forenoon And by the night When it is still! Your Lord (O Muhammad) has neither Forsaken you Nor hated you." (93.1-3)


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.226]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 226

Narrated Um Salama:

One night the Prophet got up and said, "Subhan Allah! How many afflictions Allah has revealed tonight and how many treasures have been sent down (disclosed). Go and wake the sleeping lady occupants of these dwellings up (for prayers), perhaps a well-dressed in this world may be naked in the Hereafter."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.227]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 227

Narrated 'Ali bin Abi Talib

One night Allah's Apostle came to me and Fatima, the daughter of the Prophet and asked, "Won't you pray (at night)?" I said, "O Allah's Apostle! Our souls are in the hands of Allah and if He wants us to get up He will make us get up." When I said that, he left us without saying anything and I heard that he was hitting his thigh and saying, "But man is more quarrelsome than anything." (18.54)


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.228]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 228

Narrated 'Aisha:

Allah's Apostle used to give up a good deed, although he loved to do it, for fear that people might act on it and it might be made compulsory for them. The Prophet never prayed the Duha prayer, but I offer it.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.229]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 229

Narrated 'Aisha, the mother of the faithful believers:

One night Allah's Apostle offered the prayer in the Mosque and the people followed him. The next night he also offered the prayer and too many people gathered. On the third and the fourth nights more people gathered, but Allah's Apostle did not come out to them. In the morning he said, "I saw what you were doing and nothing but the fear that it (i.e. the prayer) might be enjoined on you, stopped me from coming to you." And that happened in the month of Ramadan.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.230]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 230

Narrated Al-Mughira:

The Prophet used to stand (in the prayer) or pray till both his feet or legs swelled. He was asked why (he offered such an unbearable prayer) and he said, "should I not be a thankful slave."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.231]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 231

Narrated Abdullah bin 'Amr bin Al-'As:

Allah's Apostle told me, "The most beloved prayer to Allah is that of David and the most beloved fasts to Allah are those of David. He used to sleep for half of the night and then pray for one third of the night and again sleep for its sixth part and used to fast on alternate days."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.232]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 232

Narrated Masruq:

I asked 'Aisha which deed was most loved by the Prophet. She said, "A deed done continuously." I further asked, "When did he used to get up (in the night for the prayer)." She said, "He used to get up on hearing the crowing of a cock."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.233]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 233

Narrated Al-Ashath:

He (the Prophet (p.b.u.h) ) used to get up for the prayer on hearing the crowing of a cock.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.234]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 234

Narrated 'Aisha:

In my house he (Prophet (p.b.u.h) ) never passed the last hours of the night but sleeping.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.235]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 235

Narrated Qatada:

Anas bin Malik said, "The Prophet (p.b.u.h) and Zaid bin Thabit took their Suhur together. When they finished it, the Prophet stood for the (Fajr) prayer and offered it." We asked Anas, "What was the interval between their finishing the Suhur and the starting of the morning prayer?" Anas replied, "It was equal to the time taken by a person in reciting fifty verses of the Quran."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.236]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 236

Narrated Abu-Wa il:

'Abdullah said, "One night I offered the Tahajjud prayer with the Prophet and he kept on standing till an ill-thought came to me." We said, "What was the ill-thought?" He said, "It was to sit down and leave the Prophet (standing)."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.237]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 237

Narrated Hudhaifa :

Whenever the Prophet got up for Tahajjud prayer he used to clean his mouth (and teeth) with Siwak.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.238]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 238

Narrated 'Abdullah bin 'Umar :

A man said, "O Allah's Apostle! How is the prayer of the night?" He said, "Two Rakat followed by two Rakat and so on, and when you apprehend the approaching dawn, offer one Raka as Witr."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.239]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 239

Narrated Ibn Abbas:

The prayer of the Prophet used to be of thirteen Rakat, i.e. of the night prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.240]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 240

Narrated Masruq:

I asked Aisha about the night prayer of Allah's Apostle and she said, "It was seven, nine or eleven Rakat besides the two Rakat of the Fajr prayer (i.e. Sunna). "


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.241]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 241

Narrated 'Aisha,

The Prophet (p.b.u.h) used to offer thirteen Rakat of the night prayer and that included the Witr and two Rakat (Sunna) of the Fajr prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.242]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 242

Narrated Anas bin Malik

Sometimes Allah's Apostle would not fast (for so many days) that we thought that he would not fast that month and he sometimes used to fast (for so many days) that we thought he would not leave fasting through-out that month and (as regards his prayer and sleep at night), if you wanted to see him praying at night, you could see him praying and if you wanted to see him sleeping, you could see him sleeping.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.243]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 243

Narrated Abu Huraira

Allah's Apostle said, "Satan puts three knots at the back of the head of any of you if he is asleep. On every knot he reads and exhales the following words, 'The night is long, so stay asleep.' When one wakes up and remembers Allah, one knot is undone; and when one performs ablution, the second knot is undone, and when one prays the third knot is undone and one gets up energetic with a good heart in the morning; otherwise one gets up lazy and with a mischievous heart."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.244]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 244

Narrated Samura bin Jundab:

The Prophet said in his narration of a dream that he saw, "He whose head was being crushed with a stone was one who learnt the Quran but never acted on it, and slept ignoring the compulsory prayers."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.245]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 245

Narrated 'Abdullah :

A person was mentioned before the Prophet (p.b.u.h) and he was told that he had kept on sleeping till morning and had not got up for the prayer. The Prophet said, "Satan urinated in his ears."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.246]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 246

Narrated Abu Huraira:

Allah's Apostle (p.b.u.h) said, "Our Lord, the Blessed, the Superior, comes every night down on the nearest Heaven to us when the last third of the night remains, saying: "Is there anyone to invoke Me, so that I may respond to invocation? Is there anyone to ask Me, so that I may grant him his request? Is there anyone seeking My forgiveness, so that I may forgive him?"


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.247]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 247

Narrated Al-Aswad:

I asked 'Aisha "How is the night prayer of the Prophet?" She replied, "He used to sleep early at night, and get up in its last part to pray, and then return to his bed. When the Muadh-dhin pronounced the Adhan, he would get up. If he was in need of a bath he would take it; otherwise he would perform ablution and then go out (for the prayer)."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.248]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 248

Narrated Abu Salma bin 'Abdur Rahman:

I asked 'Aisha, "How is the prayer of Allah's Apostle during the month of Ramadan." She said, "Allah's Apostle never exceeded eleven Rakat in Ramadan or in other months; he used to offer four Rakat-- do not ask me about their beauty and length, then four Rakat, do not ask me about their beauty and length, and then three Rakat." Aisha further said, "I said, 'O Allah's Apostle! Do you sleep before offering the Witr prayer?' He replied, 'O 'Aisha! My eyes sleep but my heart remains awake'!"


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.249]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 249

Narrated 'Aisha:

I did not see the Prophet reciting (the Quran) in the night prayer while sitting except when he became old; when he used to recite while sitting, and when thirty or forty verses remained from the Sura, he would get up and recite them and then bow.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.250]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 250

Narrated Abu Huraira:

At the time of the Fajr prayer the Prophet asked Bilal, "Tell me of the best deed you did after embracing Islam, for I heard your footsteps in front of me in Paradise." Bilal replied, "I did not do anything worth mentioning except that whenever I performed ablution during the day or night, I prayed after that ablution as much as was written for me."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.251]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 251

Narrated 'Aisha:

A woman from the tribe of Bani Asad was sitting with me and Allah's Apostle (p.b.u.h) came to my house and said, "Who is this?" I said, "(She is) So and so. She does not sleep at night because she is engaged in prayer." The Prophet said disapprovingly: Do (good) deeds which is within your capacity as Allah never gets tired of giving rewards till you get tired of doing good deeds."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.252]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 252

Narrated 'Abdullah bin 'Amr bin Al-'As:

Allah's Apostle said to me, "O 'Abdullah! Do not be like so and so who used to pray at night and then stopped the night prayer."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.253]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 253

Narrated 'Ubada bin As-Samit:

The Prophet "Whoever gets up at night and says: -- 'La ilaha il-lallah Wahdahu la Sharika lahu Lahu-l-mulk, waLahu-l-hamd wahuwa 'ala kullishai'in Qadir. Alhamdu lil-lahi wa subhanal-lahi wa la-ilaha il-lal-lah wa-l-lahu akbar wa la hawla Wala Quwata il-la-bil-lah.' (None has the right to be worshipped but Allah. He is the Only One and has no partners . For Him is the Kingdom and all the praises are due for Him. He is Omnipotent. All the praises are for Allah. All the glories are for Allah. And none has the right to be worshipped but Allah, And Allah is Great And there is neither Might nor Power Except with Allah). And then says: -- Allahumma, Ighfir li(O Allah! Forgive me). Or invokes (Allah), he will be responded to and if he performs ablution (and prays), his prayer will be accepted."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.254]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 254

Narrated Abu Huraira

That once Allah's Apostle (p.b.u.h) said, "Your brother, i.e. 'Abdullah bin Rawaha does not say obscene (referring to his verses): Amongst us is Allah's Apostle, who recites His Book when it dawns. He showed us the guidance, after we were blind. We believe that whatever he says will come true. And he spends his nights in such a way as his sides do not touch his bed. While the pagans were deeply asleep."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.255]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 255

Narrated Nafi:

Ibn 'Umar said, "In the life-time of the Prophet I dreamt that a piece of silk cloth was in my hand and it flew with me to whichever part of Paradise I wanted. I also saw as if two persons (i.e. angels) came to me and wanted to take me to Hell. Then an angel met us and told me not to be afraid. He then told them to leave me. Hafsa narrated one of my dreams to the Prophet and the Prophet said, "Abdullah is a good man. Would that he offer the night prayer (Tahajjud)!" So after that day 'Abdullah (bin 'Umar) started offering Tahajjud. The companions of the Prophet (p.b.u.h) used to tell him their dreams that (Laila-tul-Qadr) was on the 27th of the month of Ramadan. The Prophet said, "I see that your dreams agree on the last ten nights of Ramadan and so whoever is in search of it should seek it in the last ten nights of Ramadan."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.256]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 256

Narrated 'Aisha;

Allah's Apostle offered the 'Isha' prayer (and then got up at the Tahajjud time) and offered eight Rakat and then offered two Rakat while sitting. He then offered two Rakat in between the Adhan and Iqama (of the Fajr prayer) and he never missed them.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.257]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 257

Narrated 'Aisha:

The Prophet used to lie down on his right side, after offering two Rakat (Sunna) of the Fajr prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.258]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 258

Narrated 'Aisha :

After offering the Sunna of the Fajr prayer, the Prophet used to talk to me, if I happen to be awake; otherwise he would lie down till the Iqama call was proclaimed (for the Fajr prayer).


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.259]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 259

Narrated 'Aisha:

After offering the two Rakat (Sunna) the Prophet (p.b.u.h) used to talk to me, if I happen to be awake; otherwise he would lie down.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.260]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 260

Narrated 'Aisha:

The Prophet was never more regular and particular in offering any Nawafil than the two Rakat (Sunna) of the Fajr prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.261]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 261

Narrated 'Aisha:

Allah's Apostle used to offer thirteen Rakat in the night prayer and on hearing the Adhan for the morning prayer, he used to offer two light Rakat.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.262]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 262

Narrated 'Aisha:

The Prophet (p.b.u.h) used to make the two Rakat before the Fajr prayer so light that I would wonder whether he recited Al-Fatiha (or not).


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.263]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 263

Narrated Jabir bin 'Abdullah :

The Prophet (p.b.u.h) used to teach us the way of doing Istikhara (Istikhara means to ask Allah to guide one to the right sort of action concerning any job or a deed), in all matters as he taught us the Suras of the Quran. He said, "If anyone of you thinks of doing any job he should offer a two Rakat prayer other than the compulsory ones and say (after the prayer): -- 'Allahumma inni astakhiruka bi'ilmika, Wa astaqdiruka bi-qudratika, Wa as'alaka min fadlika al-'azlm Fa-innaka taqdiru Wala aqdiru, Wa ta'lamu Wala a'lamu, Wa anta 'allamu l-ghuyub. Allahumma, in kunta ta'lam anna hadha-l-amra Khairun li fi dini wa ma'ashi wa'aqibati amri (or 'ajili amri wa'ajilihi) Faqdirhu wa yas-sirhu li thumma barik li Fihi, Wa in kunta ta'lamu anna hadha-lamra shar-run li fi dini wa ma'ashi wa'aqibati amri (or fi'ajili amri wa ajilihi) Fasrifhu anni was-rifni anhu. Waqdir li al-khaira haithu kana Thumma ardini bihi.' (O Allah! I ask guidance from Your knowledge, And Power from Your Might and I ask for Your great blessings. You are capable and I am not. You know and I do not and You know the unseen. O Allah! If You know that this job is good for my religion and my subsistence and in my Hereafter--(or said: If it is better for my present and later needs)--Then You ordain it for me and make it easy for me to get, And then bless me in it, and if You know that this job is harmful to me In my religion and subsistence and in the Hereafter--(or said: If it is worse for my present and later needs)--Then keep it away from me and let me be away from it. And ordain for me whatever is good for me, And make me satisfied with it). The Prophet added that then the person should name (mention) his need.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.264]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 264

Narrated Abu Qatada bin Rabi Al-Ansari;

The Prophet said, "If anyone of you enters a Mosque, he should not sit until he has offered a two-Rakat prayer."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.265]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 265

Narrated Anas bin Malik

Allah's Apostle led us and offered a two Rakat prayer and then went away.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.266]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 266

Narrated 'Abdullah bin 'Umar Abu,

I offered with Allah's Apostle a two Rakat prayer before the Zuhr prayer and two Rakat after the Zuhr prayer, two Rakat after Jumua, Maghrib and 'Isha' prayers.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.267]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 267

Narrated Jabir bin 'Abdullah :

While delivering a sermon, Allah's Apostle said, "If anyone of you comes while the Imam is delivering the sermon or has come out for it, he should offer a two Rakat prayer."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.268]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 268

Narrated Mujahid:

Somebody came to the house of Ibn 'Umar and told him that Allah's Apostles had entered the Ka'ba. Ibn 'Umar said, "I went in front of the Ka'ba and found that Allah's Apostle had come out of the Ka'ba and I saw Bilal standing by the side of the gate of the Ka'ba. I said, 'O Bilal! Has Allah's Apostle (p.b.u.h) prayed inside the Ka'ba?' Bilal replied in the affirmative. I said, 'Where (did he pray)?' He replied, '(He prayed) Between these two pillars and then he came out and offered a two Rakat prayer in front of the Ka'ba.' " Abu 'Abdullah said: Abu Huraira said, "The Prophet (p.b.u.h) advised me to offer two Rakat of Duha prayer (prayer to be offered after sunrise and before midday). " Itban (bin Malik) said, "Allah's Apostle

(p.b.u.h) and Abu Bakr, came to me after sunrise and we aligned behind the Prophet (p.b.u.h) and offered two Rakat."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.269]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 269

Narrated Ibn 'Umar:

I offered with the Prophet two Rakat before the Zuhr and two Rakat after the Zuhr prayer; two Rakat after Maghrib, Isha' and the Jumua prayers. Those of the Maghrib and 'Isha' were offered in his house. My sister Hafsa told me that the Prophet used to offer two light Rakat after dawn and it was the time when I never went to the Prophet."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.270]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 270

Narrated 'Amr:

I heard Abu Ash-sha'tha' Jabir saying, "I heard Ibn Abbas saying, 'I offered with Allah's Apostle eight Rakat (of Zuhr and 'Asr prayers) together and seven Rakat (the Maghrib and the 'Isha' prayers) together.' " I said, "O Abu Ash-shatha! I think he must have prayed the Zuhr late and the 'Asr early; the 'Isha early and the Maghrib late." Abu Ash-sha'tha' said, "I also think so." (See Hadith No. 518 Vol. 1).


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.271]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 271

Narrated Muwarriq:

I asked Ibn 'Umar "Do you offer the Duha prayer?" He replied in the negative. I further asked, "Did 'Umar use to pray it?" He (Ibn 'Umar) replied in the negative. I again asked, "Did Abu Bakr use to pray it?" He replied in the negative. I again asked, "Did the Prophet use to pray it?" Ibn 'Umar replied, "I don't think he did."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.272]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 272

Narrated 'Abdur Rahman bin Abi Laila:

Only Um Hani narrated to me that she had seen the Prophet offering the Duha prayer. She said, "On the day of the conquest of Mecca, the Prophet entered my house, took a bath and offered eight Rakat (of Duha prayers. I had never seen the Prophet offering such a light prayer but he performed bowing and prostrations perfectly .


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.273]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 273

Narrated 'Aisha:

I never saw the Prophet offering the Duha prayer but I always offer it.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.274]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 274

Narrated Abu Huraira:

My friend (the Prophet) advised me to do three things and I shall not leave them till I die, these are: To fast three days every month, to offer the Duha prayer, and to offer Witr before sleeping.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.275]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 275

Narrated Ibn 'Umar:

I remember ten Rakat of Nawafil from the Prophet, two Rakat before the Zuhr prayer and two after it; two Rakat after Maghrib prayer in his house, and two Rakat after 'Isha' prayer in his

house, and two Rakat before the Fajr prayer and at that time nobody would enter the house of the Prophet Hafsa told me that the Prophet used to offer two Rakat after the call maker had made the Adhan and the day had dawned.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.276]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 276

Narrated Aisha:

The Prophet never missed four Rakat before the Zuhr prayer and two Rakat before the Fajr prayer.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.277]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 277

Narrated 'Abdullah Al-Muzni:

The Prophet said, "Pray before the Maghrib (compulsory) prayer." He (said it thrice) and in the third time, he said, "Whoever wants to offer it can do so." He said so because he did not like the people to take it as a tradition.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.278]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 278

Narrated Marthad bin 'Abdullah Al-Yazani:

I went to 'Uqba bin 'Amir Al-Juhani and said, "Is it not surprising that Abi Tamim offers two Rakat before the Maghrib prayer?" 'Uqba said, "We used to do so in the life-time of Allah's Apostle." I asked him, "What prevents you from offering it now?" He replied, "Business."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.279]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 279

Narrated Mahmud bin Ar-rabi' Al-Ansari,

that he remembered Allah's Apostle and he also remembered a mouthful of water which he had thrown on his face, after taking it from a well that was in their house. Mahmud said that he had heard Itban bin Malik, who was present with Allah's Apostle in the battle of Badr saying, "I used to lead my people at Bani Salim in the prayer and there was a valley between me and those people. Whenever it rained it used to be difficult for me to cross it to go to their mosque. So I went to Allah's Apostle and said, 'I have weak eye-sight and the valley between me and my people flows during the rainy season and it becomes difficult for me to cross it; I wish you would come to my house and pray at a place so that I could take that place as a praying place.' Allah's Apostle said, 'I will do so.' So Allah's Apostle and Abu Bakr came to my house in the (next) morning after the sun had risen high. Allah's Apostle asked my permission to let him in and I admitted him. He did not sit before saying, 'Where do you want us to offer the prayer in your house?' I pointed to the place where I wanted him to pray. So Allah's Apostle stood up for the prayer and started the prayer with Takbir and we aligned in rows behind him; and he offered two Rakat, and finished them with Taslim, and we also performed Taslim with him. I detained him for a meal called "Khazir" which I had prepared for him.--("Khazir" is a special type of dish prepared from barley flour and meat soup)--

When the neighbors got the news that Allah's Apostle was in my house, they poured it till there were a great number of men in the house. One of them said, 'What is wrong with Malik, for I do not see him?' One of them replied, 'He is a hypocrite and does not love Allah and His Apostle.' On that Allah's Apostle said, 'Don't say this. Haven't you seen that he said, 'None has the right to be worshipped but Allah for Allah's sake only.' The man replied, 'Allah and His Apostle know better; but by Allah, we never saw him but helping and talking with the hypocrites.' Allah's Apostle replied, 'No doubt, whoever says. None has the right to be worshipped but Allah, and by that he wants the pleasures of Allah, then Allah will save him from Hell." Mahmud added, "I told the above narration to some people, one of whom was Ab-u Aiyub, the companion of Allah's Apostle in the battle in which he (Ab-u Aiyub) died and Yazid bin Mu'aw7ya was their leader in Roman Territory. Abu Aiyub denounced the narration and said, 'I doubt that Allah's Apostle ever said what you have said.' I felt that too much, and I vowed to Allah that if I remained alive in that holy battle, I would (go to Medina and) ask Itban bin Malik if he was still living in the mosque of his people. So when he returned, I assumed Ihram for Hajj or 'Umra and then I proceeded on till I reached Medina. I went to Bani Salim and Itban bin Malik, who was by then an old blind man, was leading his people in the prayer. When he finished the prayer, I greeted him and introduced myself to him and then asked him about that narration. He told that narration again in the same manner as he had narrated it the first time."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.280]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 280

Narrated Ibn 'Umar,

Allah's Apostle said, "Offer some of your prayers in your houses and do not make them graves."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.281]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 281

Narrated Quza'a:

I heard Abu Said saying four words. He said, "I heard the Prophet (saying the following narrative)." He had participated in twelve holy battles with the Prophet.

Narrated Abu Huraira: The Prophet said, "Do not set out on a journey except for three Mosques i.e. Al-Masjid-AI-Haram, the Mosque of Allah's Apostle , and the Mosque of Al-Aqsa, (Mosque of Jerusalem)."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.282]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 282

Narrated Abu Huraira

Allah's Apostle said, "One prayer in my Mosque is better than one thousand prayers in any other mosque excepting Al-Masjid-AI-Haram."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.283]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 283

Narrated Nafi':

Ibn 'Umar never offered the Duha prayer except on two occasions:

(1) Whenever he reached Mecca; and he always used to reach Mecca in the forenoon. He would perform Tawaf round the Ka'ba and then offer two Rakat at the rear of Maqam Ibrahim.

(2) Whenever he visited Quba, for he used to visit it every Saturday. When he entered the Mosque, he disliked to leave it without offering a prayer. Ibn 'Umar narrated that Allah's Apostle used to visit the Mosque of Quba (sometime) walking and (sometime) riding. And he (i.e. Ibn 'Umar) used to say, "I do only what my companions used to do and I don't forbid anybody to pray at any time during the day or night except that one should not intend to pray at sunrise or sunset."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.284]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 284

Narrated 'Abdullah bin Dinar:

Ibn 'Umar said, "The Prophet used to go to the Mosque of Quba every Saturday (sometimes) walking and (sometimes) riding." 'Abdullah (Ibn 'Umar) used to do the same.


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.285]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 285

Narrated Ibn 'Umar:

The Prophet used to go to the Mosque of Quba (sometimes) walking and sometimes riding. Added Nafi (in another narration), "He then would offer two Rakat (in the Mosque of Quba)."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.286]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 286

Narrated 'Abdullah bin Zaid Al-Mazini:

Allah's Apostle said, "Between my house and the pulpit there is a garden of the gardens of Paradise."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.287]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 287

Narrated Abu Huraira:

The Prophet said, "Between my house and my pulpit there is a garden of the gardens of Paradise, and my pulpit is on my fountain tank (i.e. Al-Kauthar)."


Bukhari :: Prayer at Night (Tahajjud) :: [2.21.288]

Prayer at Night (Tahajjud)

Bukhari :: Book 2 :: Volume 21 :: Hadith 288

Narrated Qaza'a Maula:

(freed slave of) Ziyad: I heard Abu Said Al-khudri narrating four things from the Prophet and I appreciated them very much. He said, conveying the words of the Prophet.

(1) "A woman should not go on a two day journey except with her husband or a Dhi-Mahram.

(2) No fasting is permissible on two days: 'Id-ul-Fitr and 'Id-ul-Adha.

(3) No prayer after two prayers, i.e. after the Fajr prayer till the sunrises and after the 'Asr prayer till the sun sets.

(4) Do not prepare yourself for a journey except to three Mosques, i.e. Al-Masjid-AI-Haram, the Mosque of Aqsa (Jerusalem) and my Mosque."


Bukhari :: Actions while Praying :: [2.22.289]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 289

Narrated Kuraib Maula Ibn Abbas:

'Abdullah bin Abbas said that he had passed a night in the house of Maimuna the mother of the faithful believers , who was his aunt. He said, "I slept across the bed, and Allah's Apostle along with his wife slept lengthwise. Allah's Apostle slept till mid-night or slightly before or after it. Then Allah's Apostle woke up, sat, and removed the traces of sleep by rubbing his hands over his face. Then he recited the last ten verses of Surat-Al Imran (2). Then he went towards a hanging leather water-container and performed a perfect ablution and then stood up for prayer." 'Abdullah bin Abbas added, "I got up and did the same as Allah's Apostle had done and then went and stood by his side. Allah's Apostle then put his right hand over my head and caught my right ear and twisted it. He offered two Rakat, then two Rakat, then two Rakat, then two Rakat, then two Rakat, then two Rakat and then offered one Raka Witr. Then he lay down till the Muadh-dhin came and then he prayed two light Rakat and went out and offered the early morning (Fajr) prayer."


Bukhari :: Actions while Praying :: [2.22.290]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 290

Narrated 'Abdullah:

We used to greet the Prophet while he was praying and he used to answer our greetings. When we returned from AnNajashi (the ruler of Ethiopia), we greeted him, but he did not answer us (during the prayer) and (after finishing the prayer) he said, "In the prayer one is occupied (with a more serious matter)."


Bukhari :: Actions while Praying :: [2.22.291]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 291

Narrated 'Abdullah

the same as No. 290. from the Prophet


Bukhari :: Actions while Praying :: [2.22.292]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 292

Narrated Zaid bin Arqam:

In the life-time of the Prophet we used to speak while praying, and one of us would tell his needs to his companions, till the verse, 'Guard strictly your prayers (2.238) was revealed. After that we were ordered to remain silent while praying.


Bukhari :: Actions while Praying :: [2.22.293]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 293

Narrated Sahl bin Sad:

The Prophet went out to affect a reconciliation between the tribes of Bani 'Amr bin 'Auf and the time of the prayer became due; Bilal went to Abu Bakr and said, "The Prophet is detained. Will you lead the people in the prayer?" Abu Bakr replied, "Yes, if you wish." So Bilal pronounced the Iqama and Abu Bakr led the prayer. In the meantime the Prophet came crossing the rows (of the praying people) till he stood in the first row and the people started clapping. Abu Bakr never looked hither and thither during the prayer but when the people clapped too much, he looked back and saw the Prophet in the (first) row. The Prophet waved him to remain at his place, but Abu Bakr raised both his hands and sent praises to Allah and then retreated and the Prophet went forward and led the prayer. (See Hadith No. 295 & 296)


Bukhari :: Actions while Praying :: [2.22.294]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 294

Narrated 'Abdullah bin Masud:

We used to say the greeting, name and greet each other in the prayer. Allah's Apostle heard it and said:--"Say, 'At-tahiyyatu lil-lahi was-salawatu wat-taiyibatu . Assalamu 'Alaika aiyuha-n-Nabiyu wa-rahmatu-l-lahi wa-barakatuhu. _ Assalamu alaina wa-'ala 'ibadi-l-lahi as-salihin.. Ashhadu an la ilaha illa-l-lah wa ashhadu anna Muhammadan 'abdu hu wa Rasuluh. (All the compliments are for Allah and all the prayers and all the good things (are for Allah). Peace be on you, O Prophet, and Allah's mercy and blessings (are on you). And peace be on us and on the good (pious) worshipers of Allah. I testify that none has the right to be worshipped but Allah and that Muhammad is His slave and Apostle.) So, when you have said this, then you have surely sent the greetings to every good (pious) worship per of Allah, whether he be in the Heaven or on the Earth . "


Bukhari :: Actions while Praying :: [2.22.295]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 295

Narrated Abu Huraira :

The Prophet said, "The saying 'Sub Han Allah' is for men and clapping is for women." (If something happens in the prayer, the men can invite the attention of the Imam by saying "Sub Han Allah". And women, by clapping their hands).


Bukhari :: Actions while Praying :: [2.22.296]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 296

Narrated Sahl bin Sad,

The Prophet said, "The saying 'Sub Han Allah' is for men and clapping is for women.


Bukhari :: Actions while Praying :: [2.22.297]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 297

Narrated Abu Huraira:

Allah's Apostle said, "A woman called her son while he was in his hermitage and said, 'O Juraij' He said, 'O Allah, my mother (is calling me) and (I am offering) my prayer (what shall I do)?' She again said, 'O Juraij!' He said again, 'O Allah ! My mother (is calling me) and (I am offering) my prayer (what shall I do)?' She again said, 'O Juraij' He again said, 'O Allah! My mother (is calling me) and (I am offering) my prayer. (What shall I do?)' She said, 'O Allah! Do not let Juraij die till he sees the faces of prostitutes.' A shepherdess used to come by his hermitage for grazing her sheep and she gave birth to a child. She was asked whose child that was, and she replied that it was from Juraij and that he had come out from his hermitage. Juraij said, 'Where is that woman who claims that her child is from me?' (When she was brought to him along with the child), Juraij asked the child, 'O Babus, who is your father?' The child replied, 'The shepherd.' " (See Hadith No 662. Vol 3).


Bukhari :: Actions while Praying :: [2.22.298]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 298

Narrated Mu'aiqib:

The Prophet talked about a man leveling the earth on prostrating, and said, "If you have to do so, then do it once."


Bukhari :: Actions while Praying :: [2.22.299]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 299

Narrated Anas bin Malik:

We used to pray with the Prophet in scorching heat, and if someone of us could not put his face on the earth (because of the heat) then he would spread his clothes and prostrate over them.


Bukhari :: Actions while Praying :: [2.22.300]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 300

Narrated Aisha:

I used to stretch my legs towards the Qibla of the Prophet while he was praying; whenever he prostrated he touched me, and I would withdraw my legs, and whenever he stood up, I would restretch my legs.


Bukhari :: Actions while Praying :: [2.22.301]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 301

Narrated Abu Huraira:

The Prophet once offered the prayer and said, "Satan came in front of me and tried to interrupt my prayer, but Allah gave me an upper hand on him and I choked him. No doubt, I thought of tying him to one of the pillars of the mosque till you get up in the morning and see him. Then I remembered the statement of Prophet Solomon, 'My Lord ! Bestow on me a kingdom such as shall not belong to any other after me.' Then Allah made him (Satan) return with his head down (humiliated)."


Bukhari :: Actions while Praying :: [2.22.302]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 302

Narrated Al-Azraq bin Qais:

We were at Al-Ahwaz fighting the AlHaruriya (tribe). While I was at the bank of a river a man was praying and the reins of his animal were in his hands and the animal was struggling and he was following the animal. (Shu'ba, a sub-narrator, said that man was Abu Barza al-Aslaml). A man from the Khawarij said, "O Allah! Be harsh to this sheik." And when the sheik (Abu Barza) finished his prayer, he said, "I heard your remark. No doubt, I participated with Allah's Apostle in six or seven or eight holy battles and saw his leniency, and no doubt, I would rather retain my animal than let it return to its stable, as it would cause me much trouble. "


Bukhari :: Actions while Praying :: [2.22.303]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 303

Narrated 'Aisha:

Once the sun eclipsed and Allah's Apostle stood up for the prayer and recited a very long Sura and when bowed for a long while and then raised his head and started reciting another Sura. Then he bowed, and after finishing, he prostrated and did the same in the second Raka and then said, "These (lunar and solar eclipses) are two of the signs of Allah and if you see them, pray till the eclipse is over. No doubt, while standing at this place I saw everything promised to me by Allah and I saw (Paradise) and I wanted to pluck a bunch (of grapes) therefrom, at the time when you saw me stepping forward. No doubt, I saw Hell with its different parts destroying each other when you saw me retreating and in it I saw 'Amr bin Luhai who started the tradition of freeing animals (set them free) in the name of idols."


Bukhari :: Actions while Praying :: [2.22.304]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 304

Narrated Ibn'Umar:

The Prophet saw some sputum on the wall facing the Qibla of the mosque and became furious with the people of the mosque and said, "During the prayer, Allah is in front of everyone of you and so he should not spit (or said, 'He should not expectorate')." Then he got down and scratched the sputum with his hand. Ibn 'Umar said (after narrating), "If anyone of you has to spit during the prayer, he should spit to his left."


Bukhari :: Actions while Praying :: [2.22.305]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 305

Narrated Anas:

The Prophet said, "Whenever anyone of you is in prayer, he is speaking in private to his Lord and so he should neither spit in front of him nor on his right side but to his left side under his left foot."


Bukhari :: Actions while Praying :: [2.22.306]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 306

Narrated Sahl bin Sad:

The people used to offer the prayer with the Prophet with their waist-sheets tied round their necks because of the shortness of the sheets and the women were ordered not to lift their heads till the men had sat straight.


Bukhari :: Actions while Praying :: [2.22.307]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 307

Narrated'Abdullah:

I used to greet the Prophet while he was in prayer and he would return my greeting, but when we returned (from Ethiopia) I greeted the Prophet (while he was praying) but he did not return the greeting, and (after finishing the prayer) he said, "In the prayer one is occupied (with a more serious matter)."


Bukhari :: Actions while Praying :: [2.22.308]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 308

Narrated Jabir bin 'Abdullah:

Allah's Apostle sent me for some job and when I had finished it I returned and came to the Prophet and greeted him but he did not return my greeting. So I felt so sorry that only Allah knows it and I said to myself,, 'Perhaps Allah's Apostle is angry because I did not come quickly, then again I greeted him but he did not reply. I felt even more sorry than I did the first time. Again I greeted him and he returned the greeting and said, "The thing which prevented me from returning the greeting was that I was praying." And at that time he was on his Rahila and his face was not towards the Qibla.


Bukhari :: Actions while Praying :: [2.22.309]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 309

Narrated Sahl bin Sad:

The news about the differences amongst the people of Bani 'Amr bin 'Auf at Quba reached Allah's Apostle and so he went to them along with some of his companions to affect a reconciliation. Allah's Apostle was delayed there and the time for the prayer became due. Bilal came to Abu Bakr! and said, "O Abu Bakr! Allah's Apostle is detained (there) and the time for the prayer is due. Will you lead the people in prayer?" Abu Bakr replied, "Yes, if you wish." So Bilal pronounced the Iqama and Abu Bakr went forward and the people said Takbir. In the meantime, Allah's Apostle came piercing through the rows till he stood in the (first) row and the people started clapping. Abu Bakr, would never look hither and thither during the prayer but when the people clapped much he looked back and saw Allah's Apostle. The Prophet beckoned him to carry on. Abu Bakr raised both his hands, praised Allah and retreated till he stood in the row and Allah's Apostle went forward and led the people in the prayer. When he had finished the prayer, he addressed the people and said, "O people! Why did you start clapping when something happened to you in the prayer? Clapping is for women. Whenever one is confronted with something unusual in the prayer one should say, 'Sub Han Allah'." Then the Prophet looked towards Abu Bakr and asked, "What prevented you from leading the prayer when I beckoned you to carry on?" Abu Bakr replied, "It does not befit the son of Al Quhafa to lead the prayer in the presence of Allah's Apostle


Bukhari :: Actions while Praying :: [2.22.310]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 310

Narrated Abu Huraira:

It was forbidden to keep the hands on the hips during the prayer. (This is narrated by Abu Huraira from the Prophet.)


Bukhari :: Actions while Praying :: [2.22.311]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 311

Narrated Abu Huraira:

It was forbidden to pray with the hands over one's hips.


Bukhari :: Actions while Praying :: [2.22.312]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 312

Narrated 'Uqba bin Al-Harith:

I offered the 'Asr prayer with the Prophet and after finishing the prayer with Taslim he got up quickly and went to some of his wives and then came out. He noticed the signs of astonishment on the faces of the people caused by his speed. He then said, "I remembered while I was in my prayer that a piece of gold was Lying in my house and I disliked that it should remain with us throughout the night, and so I have ordered it to be distributed."


Bukhari :: Actions while Praying :: [2.22.313]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 313

Narrated Abu Huraira,

Allah's Apostle said, "When the Adhan for the prayer is pronounced, then Satan takes to his heels passing wind so that he may not hear the Adhan and when the Muadh-dhin finishes, he comes back; and when the Iqama is pronounced he again takes to his heels and when it is finished, he again comes back and continues reminding the praying person of things that he used not to remember when not in prayer till he forgets how much he has prayed." Abu Salama bin 'Abdur-Rahman said, "If anyone of you has such a thing (forgetting the number of Rakat he has prayed) he should perform two prostrations of Sahu (i.e. forgetfulness) while sitting." Abu Salama narrates this from Abu Huraira.


Bukhari :: Actions while Praying :: [2.22.314]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 314

Narrated Abu Huraira:

People say that I narrate too many narrations of the Prophet; once I met a man (during the life-time of the Prophet) and asked him, "Which Sura did Allah's Apostle s recite yesterday in the 'Isha' prayer?" He said, "I do not know." I said, "Did you not attend the prayer?" He said, "Yes, (I did)." I said, "I know. He recited such and such Sura."


Bukhari :: Actions while Praying :: [2.22.315]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 315

Narrated 'Abdullah bin Buhaina :

Allah's Apostle once led us in a prayer and offered two Rakat and got up (for the third Raka) without sitting (after the second Raka). The people also got up with him, and when he was about to finish his prayer, we waited for him to finish the prayer with Taslim but he said Takbir before Taslim and performed two prostrations while sitting and then finished the prayer with Taslim.


Bukhari :: Actions while Praying :: [2.22.316]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 316

Narrated 'Abdullah bin Buhaina :

Allah's Apostle got up after the second Raka of the Zuhr prayer without sitting in between (the second and the third Rakat). When he finished the prayer he performed two prostrations (of Sahu) and then finished the prayer with Tasllm.


Bukhari :: Actions while Praying :: [2.22.317]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 317

Narrated' Abdullah:

Once Allah's Apostle offered five Rakat in the Zuhr prayer, and somebody asked him whether there was some increase in the prayer. Allah's Apostle said, "What is that?" He said, "You have offered five Rakat." So Allah's Apostle performed two prostrations of Sahu after Taslim.


Bukhari :: Actions while Praying :: [2.22.318]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 318

Narrated Abu Huraira:

The Prophet led us in the 'Asr or the Zuhr prayer and finished it with Taslim. Dhul-Yadain said to him, "O Allah's Apostle! Has the prayer been reduced?" The Prophet asked his companions in the affirmative. So Allah's Apostle I offered two more Rakat and then performed two prostrations (of Sahu). Sad said, "I saw that 'Ursa bin Az-Zubair had offered two Rakat in the Maghrib prayer and finished it with Taslim. He then talked (and when he was informed about it) he completed the rest of his prayer and performed two prostrations, and said, 'The Prophet prayed like this.' "


Bukhari :: Actions while Praying :: [2.22.319]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 319

Narrated Abu Huraira.

Once Allah's Apostle offered two Rakat and finished his prayer. So Dhul-Yadain asked him, "Has the prayer been reduced or have you forgotten?" Allah's Apostle said, "Has DhulYadain spoken the truth?" The people replied in the affirmative. Then Allah's Apostle stood up and offered the remaining two Rakat and performed Taslim, and then said Takbir and performed two prostrations like his usual prostrations, or a bit longer, and then got up.


Bukhari :: Actions while Praying :: [2.22.320]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 320

Narrated Salama bin 'Alqama:

I asked Muhammad (bin Sirin) whether Tashah-hud should be recited after the two prostrations of Sahu. He replied, "It is not (mentioned) in Abu Huraira's narration . "


Bukhari :: Actions while Praying :: [2.22.321]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 321

Narrated Abu Huraira:

The Prophet offered one of the evening prayers (the sub-narrator Muhammad said, "I think that it was most probably the 'Asr prayer") and he finished it after offering two Rakat only. He then stood near a price of wood in front of the Mosque and put his hand over it. Abu Bakr and 'Umar were amongst those who were present, but they dared not talk to him about that (because of excessive respect for him), and those who were in a hurry went out. They said, "Has the prayer been reduced?" A man who was called DhulYadain by the Prophet said (to the Prophet), "Has the prayer been reduced or have you forgotten?" He said, "Neither have I forgotten, nor has the prayer been reduced." He said, "Certainly you have forgotten." So the Prophet offered two more Rakat and performed Tashm and then said Takbir and performed a prostration of Sahu like his ordinary prostration or a bit longer and then raised his head and said Takbir and then put his head down and performed a prostration like his ordinary prostration or a bit longer, and then raised his head and said Takbir.


Bukhari :: Actions while Praying :: [2.22.322]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 322

Narrated 'Abdullah bin Buhaina Al-Asdi:

(the ally of Bani 'Abdul Muttalib) Allah's Apostle stood up for the Zuhr prayer and he should have sat (after the second Raka but he stood up for the third Raka without sitting for Tashah-hud) and when he finished the prayer he performed two prostrations and said Takbir on each prostration while sitting, before ending (the prayer) with Taslim; and the people too performed the two prostrations with him instead of the sitting he forgot.


Bukhari :: Actions while Praying :: [2.22.323]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 323

Narrated Abu Huraira:

Allah's Apostle said, "When the call for prayer is made, Satan takes to his heels passing wind so that he may not hear the Adhan and when the call is finished he comes back, and when the Iqama is pronounced, Satan again takes to his heels, and when the Iqama is finished he comes back again and tries to interfere with the person and his thoughts and say, "Remember this and that (which he has not thought of before the prayer)", till the praying person forgets how much he has prayed. If anyone of you does not remember whether he has offered three or four Rakat then he should perform two prostrations of Sahu while sitting.


Bukhari :: Actions while Praying :: [2.22.324]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 324

Narrated Abu Huraira:

Allah's Apostle said, "When anyone of you stands for the prayers, Satan comes and puts him in doubts till he forgets how many Rakat he has prayed. So if this happens to anyone of you, he should perform two prostrations of Sahu while sitting.


Bukhari :: Actions while Praying :: [2.22.325]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 325

Narrated Kuraib:

I was sent to Aisha by Ibn Abbas, Al-Miswar bin Makhrama and 'Abdur-Rahman bin Azhar . They told me to greet her on their behalf and to ask her about the offering of the two Rakat after the 'Asr prayer and to say to her, "We were informed that you offer those two Rakat and we were told that the Prophet had forbidden offering them." Ibn Abbas said, "I along with 'Umar bin Al-Khattab used to beat the people whenever they offered them." I went to Aisha and told her that message. 'Aisha said, "Go and ask Um Salama about them." So I returned and informed them about her statement. They then told me to go to Um Salama with the same question with which t sent me to 'Aisha. Um Salama replied, "I heard the Prophet forbidding them. Later I saw him offering them immediately after he prayed the 'Asr prayer. He then entered my house at a time when some of the Ansari women from the tribe of Bani Haram were sitting with me, so I sent my slave girl to him having said to her, 'Stand beside him and tell him that Um Salama says to you, "O Allah's Apostle! I have heard you forbidding the offering of these (two Rakat after the 'Asr prayer) but I have seen you offering them." If he waves his hand then wait for him.' The slave girl did that. The Prophet beckoned her with his hand and she waited for him. When he had finished the prayer he said, "O daughter of Bani Umaiya! You have asked me about the two Rakat after the 'Asr prayer. The people of the tribe of 'Abdul-Qais came to me and made me busy and I could not offer the two Rakat after the Zuhr prayer. These (two Rakat that I have just prayed) are for those (missed) ones.


Bukhari :: Actions while Praying :: [2.22.326]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 326

Narrated Sahl bin Sad As-Sa'idi :

The news about the differences amongst the people of Bani'Amr bin 'Auf reached Allah's Apostle and so he went to them along with some of his companions to affect a reconciliation between them. Allah's Apostle was delayed there, and the time of the prayer was due. Bilal went to Abu Bakr and said to him, "Allah's Apostle has been delayed (there) and the time of prayer is due. So will you lead the people in prayer?" Abu Bakr said, "Yes, if you wish." Bilal pronounced the Iqama and Abu Bakr, went forward and said Takbir for the people. In the mean-time Allah's Apostle came crossing the rows (of the praying people) and stood in the (first) row and the people started clapping. Abu Bakr, would never glance side-ways in his prayer but when the people clapped much he looked back and (saw) Allah's Apostle . Allah's Apostle beckoned him to carry on the prayer. Abu Bakr raised his hands and thanked Allah, and retreated till he reached the (first) row. Allah's Apostle went forward and led the people in the prayer. When he completed the prayer he faced the people and said, "O people! Why did you start clapping when something unusual happened to you in the prayer? Clapping is only for women. So whoever amongst you comes across something in the prayer should say, 'Subhan-Allah' for there is none who will not turn round on hearing him saying Subhan-Allah. O Ab-u Bakr! What prevented you from leading the people in the prayer when I beckoned you to do so?" Abu Bakr replied, "How dare the son of Abu Quhafa lead the prayer in the presence of Allah's Apostle ?"


Bukhari :: Actions while Praying :: [2.22.327]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 327

Narrated Asma':

I went to 'Aisha and she was standing praying and the people, too, were standing (praying). So I said, "What is the matter with the people?" She beckoned with her head towards the sky.

I said, "(Is there) a sign?" She nodded intending to say, "Yes."


Bukhari :: Actions while Praying :: [2.22.328]

Actions while Praying

Bukhari :: Book 2 :: Volume 22 :: Hadith 328

Narrated 'Aisha the wife of the Prophet:

Allah's Apostle during his illness prayed in his house sitting, whereas some people followed him standing, but the Prophet beckoned them to sit down. On completion of the prayer he said, "The Imam is to be followed. So, bow when he bows, and raise your head when he raises his head." (See Hadith No. 657 Vol 1 for taking the verdict).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.329]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 329

Narrated Abu Dhar:

Allah's Apostle said, "Someone came to me from my Lord and gave me the news (or good tidings) that if any of my followers dies worshipping none (in any way) along with Allah, he will enter Paradise." I asked, "Even if he committed illegal sexual intercourse (adultery) and theft?" He replied, "Even if he committed illegal sexual intercourse (adultery) and theft."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.330]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 330

Narrated 'Abdullah:

Allah's Apostle said, "Anyone who dies worshipping others along with Allah will definitely enter the Fire." I said, "Anyone who dies worshipping none along with Allah will definitely enter Paradise."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.331]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 331

Narrated Al-Bara' bin 'Azib:

Allah's Apostle ordered us to do seven things and forbade us to do other seven. He ordered us:

to follow the funeral procession. to visit the sick, to accept invitations, to help the oppressed, to fulfill the oaths, to return the greeting and to reply to the sneezer: (saying, "May Allah be merciful on you," provided the sneezer says, "All the praises are for Allah,"). He forbade us to use silver utensils and dishes and to wear golden rings, silk (clothes), Dibaj (pure silk cloth), Qissi and Istabraq (two kinds of silk cloths).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.332]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 332

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The rights of a Muslim on the Muslims are to follow the funeral processions, to accept invitation and to reply the sneezer. (see Hadith No 331)


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.333]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 333

Narrated 'Aisha :

Abu Bakr came riding his horse from his dwelling place in As-Sunh. He got down from it, entered the Mosque and did not speak with anybody till he came to me and went direct to the Prophet, who was covered with a marked blanket. Abu Bakr uncovered his face. He knelt down and kissed him and then started weeping and said, "My father and my mother be sacrificed for you, O Allah's Prophet! Allah will not combine two deaths on you. You have died the death which was written for you."

Narrated Abu Salama from Ibn Abbas : Abu Bakr came out and 'Umar , was addressing the people, and Abu Bakr told him to sit down but 'Umar refused. Abu Bakr again told him to sit down but 'Umar again refused. Then Abu Bakr recited the Tashah-hud (i.e. none has the right to be worshipped but Allah and Muhammad is Allah's Apostle) and the people attended to Abu Bakr and left 'Umar. Abu Bakr said, "Amma ba'du, whoever amongst you worshipped Muhammad, then Muhammad is dead, but whoever worshipped Allah, Allah is alive and will never die. Allah said: 'Muhammad is no more than an Apostle and indeed (many) Apostles have passed away before him ..(up to the) grateful.' " (3.144) (The narrator added, "By Allah, it was as if the people never knew that Allah had revealed this verse before till Abu Bakr recited it and then whoever heard it, started reciting it ")


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.334]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 334

Narrated Kharija bin Zaid bin Thabit:

Um Al-'Ala', an Ansari woman who gave the pledge of allegiance to the Prophet said to me, "The emigrants were distributed amongst us by drawing lots and we got in our share 'Uthman bin Maz'un. We made him stay with us in our house. Then he suffered from a disease which proved fatal when he died and was given a bath and was shrouded in his clothes, Allah's Apostle came I said, 'May Allah be merciful to you, O Abu As-Sa'ib! I testify that Allah has honored you'. The Prophet said, 'How do you know that Allah has honored him?' I replied, 'O Allah's Apostle! Let my father be sacrificed for you! On whom else shall Allah bestow His honor?' The Prophet said, 'No doubt, death came to him. By Allah, I too wish him good, but by Allah, I do not know what Allah will do with me though I am Al lah's Apostle. ' By Allah, I never attested the piety of anyone after that."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.335]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 335

Narrated Al-Laith as above.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.336]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 336

Narrated Jabir bin 'Abdullah :

When my father was martyred, I lifted the sheet from his face and wept and the people forbade me to do so but the Prophet did not forbid me. Then my aunt Fatima began weeping and the Prophet said, "It is all the same whether you weep or not. The angels were shading him continuously with their wings till you shifted him (from the field). "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.337]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 337

Narrated Abu Huraira,

Allah's Apostle informed (the people) about the death of An-Najashi on the very day he died. He went towards the Musalla (praying place) and the people stood behind him in rows. He said four Takbirs (i.e. offered the Funeral prayer).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.338]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 338

Narrated Anas bin Malik:

The Prophet said, "Zaid took over the flag and was martyred. Then it was taken by Jafar who was martyred as well. Then 'Abdullah bin Rawaha took the flag but he too was martyred and at that time the eyes of Allah's Apostle were full of tears. Then Khalid bin Al-Walid took the flag without being nominated as a chief (before hand) and was blessed with victory."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.339]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 339

Narrated Ibn Abbas.

A person died and Allah's Apostle used to visit him. He died at night and (the people) buried him at night. In the morning they informed the Prophet (about his death). He said, "What prevented you from informing me?" They replied, "It was night and it was a dark night and so we disliked to trouble you." The Prophet went to his grave and offered the (funeral) prayer.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.340]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 340

Narrated Anas:

The Prophet said, "A Muslim whose three children die before the age of puberty will be granted Paradise by Allah due to his mercy for them."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.341]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 341

Narrated Abu Sa'id:

The women requested the Prophet, "Please fix a day for us." So the Prophet preached to them and said, "A woman whose three children died would be screened from the Hell Fire by them," Hearing that, a woman asked, "If two died?" The Prophet replied, "Even two (would screen her from the (Hell) Fire. " And Abu Huraira added, "Those children should be below the age of puberty. "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.342]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 342

Narrated Abu Huraira:

The Prophet said, "No Muslim whose three children died will go to the Fire except for Allah's oath (i.e. everyone has to pass over the bridge above the lake of fire)."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.343]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 343

Narrated Anas bin Malik:

The Prophet passed by a woman who was sitting and weeping beside a grave and said to her, "Fear Allah and be patient."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.344]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 344

Narrated Um 'Atiyya al-Ansariya:

Allah's Apostle came to us when his daughter died and said, "Wash her thrice or five times or more, if you see it necessary, with water and Sidr and then apply camphor or some camphor at the end; and when you finish, notify me." So when we finished it, we informed him and he gave us his waist-sheet and told us to shroud the dead body in it.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.345]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 345

Narrated Um 'Atiyya

Allah's Apostle came to us and we were giving a bath to his (dead) daughter and said, "Wash her three, five or more times with water and Sidr and sprinkle camphor on her at the end; and when you finish, notify me." So when we finished, we informed him and he gave us his waist-sheet and told us to shroud her in it. Aiyub said that Hafsa narrated to him a narration similar to that of Muhammad in which it was said that the bath was to be given for an odd number of times, and the numbers 3, 5 or 7 were mentioned. It was also said that they were to start with the right side and with the parts which were washed in ablution, and that Um 'Atiyya also mentioned, "We combed her hair and divided them in three braids."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.346]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 346

Narrated Um 'Atiyya:

Allah's Apostle , concerning his (dead) daughter's bath, said, "Start with the right side, and the parts which are washed in ablution."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.347]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 347

Narrated Um 'Atiyya :

When we washed the deceased daughter of the Prophet, he said to us, while we were washing her, "Start the bath from the right side and from the parts which are washed in ablution."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.348]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 348

Narrated Um 'Atiyya:

The daughter of the Prophet expired, and he said to us, "Wash her three or five times, or more if you see it necessary, and when you finish, notify me." So, (when we finished) we informed him and he unfastened his waist-sheet and told us to shroud her in it.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.349]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 349

Narrated Muhammad:

Um 'Atiyya said, "One of the daughters of the Prophet died and he came out and said, 'Wash her three or five times or more, if you think it necessary, with water and Sidr, and last of all put camphor (or some camphor) and when you finish, inform me.' " Um Atiyya added, "When we finished we informed him and he gave us his waist-sheet and said, 'Shroud her in it.' " And Um 'Atiyya (in another narration) added, "The Prophet said, 'Wash her three, five or seven times or more, if you think it necessary.' " Hafsa said that Um 'Atiyya had also said, "We entwined her hair into three braids."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.350]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 350

Narrated Hafsa bint Sirin:

Um 'Atiyya said that they had entwined the hair of the daughter of Allah's Apostle in three braids. They first undid her hair, washed and then entwined it in three braids."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.351]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 351

Narrated Ibn Sirin:

Um 'Atiyya (an Ansari woman who gave the pledge of allegiance to the Prophet ) came to Basra to visit her son, but she could not find him. She narrated to us, "The Prophet came to us while we were giving bath to his (dead) daughter, he said: 'Wash her three times, five times or more, if you think it necessary, with water and Sidr, and last of all put camphor, and when you finish, notify me.' " Um 'Atiyya added, "After finishing, we informed him and he gave us his waist sheet and told us to shroud her in it and did not say more than that."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.352]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 352

Narrated Um 'Atiyya:

We entwined the hair of the dead daughter of the Prophet into three braids. Waki said that Sufyan said, "One braid was entwined in front and the other two were entwined on the sides of the head."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.353]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 353

Narrated Um 'Atiyya:

One of the daughters of the Prophet expired and he came to us and said, "Wash her with Sidr (water) for odd number of times, i.e. three, five or more, if you think it necessary, and in the last, put camphor or (some camphor on her), and when you finish, notify me." So when we finished we informed him. He gave his waist-sheet to us (to shroud her). We entwined the hair (of the deceased girl) in three braids and made them fall at her back.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.354]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 354

Narrated 'Aisha:

Allah's Apostle was shrouded in three Yemenite white Suhuliya (pieces of cloth) of cotton, and in them there was neither a shirt nor a turban."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.355]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 355

Narrated Ibn Abbas:

While a man was riding (his Mount) in 'Arafat, he fell down from it (his Mount) and broke his neck (and died). The Prophet said, "Wash him with water and Sidr and shroud him in two pieces of cloth, and neither perfume him, nor cover his head, for he will be resurrected on the Day of Resurrection saying, 'Labbaik,' (i.e. like a pilgrim)."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.356]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 356

Narrated Ibn Abbas:

While a man was at 'Arafat (for Hajj) with Allah's Apostle the fell down from his Mount and broke his neck (and died). So Allah's Apostle said, "Wash him with water and Sidr and shroud him in two pieces of cloth and neither perfume him nor cover his head, for Allah will resurrect him on the Day of Resurrection and he will be saying 'Labbaik."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.357]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 357

Narrated Ibn Abbas:

A man was killed by his camel while we were with the Prophet and he was a Muhrim. So the Prophet said, "Wash him with water and Sidr and shroud him in two pieces of cloth and neither perfume him nor cover his head, for Allah will resurrect him on the Day of Resurrection and he will be saying 'Labbaik' . "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.358]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 358

Narrated Ibn Abbas:

A man fell from his Mount and died while he was with the Prophet at 'Arafat. The Prophet said, "Wash him with water and Sidr and shroud him in two pieces of cloth and neither perfume him nor cover his head, for he will be resurrected on the Day of Resurrection saying, 'Labbaik'."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.359]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 359

Narrated Ibn 'Umar:

When 'Abdullah bin Ubai (the chief of hypocrites) died, his son came to the Prophet and said, "O Allah's Apostle! Please give me your shirt to shroud him in it, offer his funeral prayer and ask for Allah's forgiveness for him." So Allah's Apostle (p.b.u.h) gave his shirt to him and said, "Inform me (When the funeral is ready) so that I may offer the funeral prayer." So, he informed him and when the Prophet intended to offer the funeral prayer, 'Umar took hold of his hand and said, "Has Allah not forbidden you to offer the funeral prayer for the hypocrites? The Prophet said, "I have been given the choice for Allah says: '(It does not avail) Whether you (O Muhammad) ask forgiveness for them (hypocrites), or do not ask for forgiveness for them. Even though you ask for their forgiveness seventy times, Allah will not forgive them. (9.80)" So the Prophet offered the funeral prayer and on that the revelation came: "And never (O Muhammad) pray (funeral prayer) for any of them (i.e. hypocrites) that dies." (9. 84)


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.360]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 360

Narrated Jabir:

The Prophet came to (the grave of) 'Abdullah bin Ubai after his body was buried. The body was brought out and then the Prophet put his saliva over the body and clothed it in his shirt.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.361]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 361

Narrated 'Aisha:

The Prophet was shrouded in three pieces of cloth which were made of Suhul (a type of cotton), and neither a shirt nor a turban were used.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.362]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 362

Narrated 'Aisha:

Allah's Apostle was shrouded in three pieces of cloth and neither a shirt nor a turban were used.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.363]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 363

Narrated Aisha:

Allah's Apostle was shrouded in three pieces of cloth which were made of white Suhul and neither a shirt nor a turban were used.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.364]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 364

Narrated Sad from his father:

Once the meal of 'Abdur-Rahman bin 'Auf was brought in front of him, and he said, "Mustab bin 'Umar was martyred and he was better than I, and he had nothing except his Burd (a black square narrow dress) to be shrouded in. Hamza or another person was martyred and he was also better than I and he had nothing to be shrouded in except his Burd. No doubt, I fear that the rewards of my deeds might have been given early in this world." Then he started weeping.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.365]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 365

Narrated Ibrahim:

Once a meal was brought to 'Abdur-Rahman bin 'Auf and he was fasting. He said, "Mustab bin 'Umar was martyred and he was better than I and was shrouded in his Burd and when his head was covered with it, his legs became bare, and when his legs were covered his head got uncovered. Hamza was martyred and was better than I. Now the worldly wealth have been bestowed upon us (or said a similar thing). No doubt, I fear that the rewards of my deeds might have been given earlier in this world." Then he started weeping and left his food.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.366]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 366

Narrated Khabbab:

We emigrated with the Prophet (p.b.u.h) in Allah's cause, and so our reward was then surely incumbent on Allah. Some of us died and they did not take anything from their rewards in this world, and amongst them was Mustab bin 'Umar; and the others were those who got their rewards. Mustab bin 'Umar was martyred on the day of the Battle of Uhud and we could get nothing except his Burd to shroud him in. And when we covered his head his feet became bare and vice versa. So the Prophet ordered us to cover his head only and to put idhkhir (a kind of shrub) over his feet.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.367]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 367

Narrated Sahl:

A woman brought a woven Burda (sheet) having edging (border) to the Prophet, Then Sahl asked them whether they knew what is Burda, they said that Burda is a cloak and Sahl confirmed their reply. Then the woman said, "I have woven it with my own hands and I have brought it so that you may wear it." The Prophet accepted it, and at that time he was in need of it. So he came out wearing it as his waist-sheet. A man praised it and said, "Will you give it to me? How nice it is!" The other people said, "You have not done the right thing as the Prophet is in need of it and you have asked for it when you know that he never turns down anybody's request." The man replied, "By Allah, I have not asked for it to wear it but to make it my shroud." Later it was his shroud.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.368]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 368

Narrated Um 'Atiyya:

We were forbidden to accompany funeral processions but not strictly.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.369]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 369

Narrated Muhammad bin Sirin:

One of the sons of Um 'Atiyya died, and when it was the third day she asked for a yellow perfume and put it over her body, and said, "We were forbidden to mourn for more than three days except for our husbands."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.370]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 370

Narrated Zainab bint Abi Salama:

When the news of the death of Abu Sufyan reached from Sham, Um Habiba on the third day, asked for a yellow perfume and scented her cheeks and forearms and said, "No doubt, I would not have been in need of this, had I not heard the Prophet saying: "It is not legal for a woman who believes in Allah and the Last Day to mourn for more than three days for any dead person except her husband, for whom she should mourn for four months and ten days."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.371]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 371

Narrated Zainab bint Abi Salama :

I went to Um Habiba, the wife of Prophet, who said, "I heard the Prophets saying, 'It is not legal for a woman who believes in Allah and the Last Day to mourn for any dead person for more than three days except for her husband, (for whom she should mourn) for four months and ten days'." Later I went to Zainab bint Jahsh when her brother died; she asked for some scent, and after using it she said, "I am not in need of scent but I heard Allah's Apostle saying, 'It is not legal for a woman who believes in Allah and the Last Day to mourn for more than three days for any dead person except her husband, (for whom she should mourn) for four months and ten days.' "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.372]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 372

Narrated Anas bin Malik:

The Prophet passed by a woman who was weeping beside a grave. He told her to fear Allah and be patient. She said to him, "Go away, for you have not been afflicted with a calamity like mine." And she did not recognize him. Then she was informed that he was the Prophet . so she went to the house of the Prophet and there she did not find any guard. Then she said to him, "I did not recognize you." He said, "Verily, the patience is at the first stroke of a calamity."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.373]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 373

Narrated Usama bin Zaid:

The daughter of the Prophet (p.b.u.h) sent (a messenger) to the Prophet requesting him to come as her child was dying (or was gasping), but the Prophet returned the messenger and told him to convey his greeting to her and say: "Whatever Allah takes is for Him and whatever He gives, is for Him, and everything with Him has a limited fixed term (in this world) and so she should be patient and hope for Allah's reward." She again sent for him, swearing that he should come. The Prophet got up, and so did Sad bin 'Ubada, Muadh bin Jabal, Ubai bin Ka'b, Zaid bin Thabit and some other men. The child was brought to Allah's Apostle while his breath was disturbed in his chest (the sub-narrator thinks that Usama added: ) as if it was a leather water-skin. On that the eyes of the Prophet (p.b.u.h) started shedding tears. Sad said, "O Allah's Apostle! What is this?" He replied, "It is mercy which Allah has lodged in the hearts of His slaves, and Allah is merciful only to those of His slaves who are merciful (to others).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.374]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 374

Narrated Anas bin Malik:

We were (in the funeral procession) of one of the daughters of the Prophet and he was sitting by the side of the grave. I saw his eyes shedding tears. He said, "Is there anyone among you who did not have sexual relations with his wife last night?" Abu Talha replied in the affirmative. And so the Prophet told him to get down in the grave. And so he got down in her grave.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.375]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 375

Narrated 'Abdullah bin 'Ubaidullah bin Abi Mulaika:

One of the daughters of 'Uthman died at Mecca. We went to attend her funeral procession. Ibn 'Umar and Ibn Abbas were also present. I sat in between them (or said, I sat beside one of them. Then a man came and sat beside me.) 'Abdullah bin 'Umar said to 'Amr bin 'Uthman, "Will you not prohibit crying as Allah's Apostle has said, 'The dead person is tortured by the crying of his relatives.?" Ibn Abbas said, "Umar used to say so." Then he added narrating, "I accompanied Umar on a journey from Mecca till we reached Al-Baida. There he saw some travelers in the shade of a Samura (A kind of forest tree). He said (to me), "Go and see who those travelers are." So I went and saw that one of them was Suhaib. I told this to 'Umar who then asked me to call him. So I went back to Suhaib and said to him, "Depart and follow the chief of the faithful believers." Later, when 'Umar was stabbed, Suhaib came in weeping and saying, "O my brother, O my friend!" (on this 'Umar said to him, "O Suhaib! Are you weeping for me while the Prophet said, "The dead person is punished by some of the weeping of his relatives?" Ibn Abbas added, "When 'Umar died I told all this to Aisha and she said, 'May Allah be merciful to Umar. By Allah, Allah's Apostle did not say that a believer is punished by the weeping of his relatives. But he said, Allah increases the punishment of a non-believer because of the weeping of his relatives." Aisha further added, "The Quran is sufficient for you (to clear up this point) as Allah has stated: 'No burdened soul will bear another's burden.' " (35.18). Ibn Abbas then said, "Only Allah makes one laugh or cry." Ibn Umar did not say anything after that.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.376]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 376

Narrated 'Aisha:

(the wife of the Prophet) Once Allah's Apostle passed by (the grave of) a Jewess whose relatives were weeping over her. He said, "They are weeping over her and she is being tortured in her grave."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.377]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 377

Narrated Abu Burda:

That his father said, "When Umar was stabbed, Suhaib started crying: O my brother! 'Umar said, 'Don't you know that the Prophet said: The deceased is tortured for the weeping of the living'?"


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.378]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 378

Narrated Al-Mughira:

I heard the Prophet saying, "Ascribing false things to me is not like ascribing false things to anyone else. Whosoever tells a lie against me intentionally then surely let him occupy his seat in Hell-Fire." I heard the Prophet saying, "The deceased who is wailed over is tortured for that wailing."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.379]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 379

Narrated Ibn 'Umar from his father:

The Prophet said, "The deceased is tortured in his grave for the wailing done over him."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.380]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 380

Narrated Shu'ba:

The deceased is tortured for the wailing of the living ones over him .


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.381]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 381

Narrated Jabir bin 'Abdullah :

On the day of the Battle of Uhud, my father was brought and he had been mayhemed and was placed in front of Allah's Apostle and a sheet was over him. I went intending to uncover my father but my people forbade me; again I wanted to uncover him but my people forbade me. Allah's Apostle gave his order and he was shifted away. At that time he heard the voice of a crying woman and asked, "Who is this?" They said, "It is the daughter or the sister of Amr." He said, "Why does she weep? (or let her stop weeping), for the angels had been shading him with their wings till he (i.e. the body of the martyr) was shifted away."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.382]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 382

Narrated 'Abdullah:

the Prophet said, "He who slaps his cheeks, tears his clothes and follows the ways and traditions of the Days of Ignorance is not one of us."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.383]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 383

Narrated 'Amir bin Sad bin Abi Waqqas:

That his father said, "In the year of the last Hajj of the Prophet I became seriously ill and the Prophet used to visit me inquiring about my health. I told him, 'I am reduced to this state because of illness and I am wealthy and have no inheritors except a daughter, (In this narration the name of 'Amir bin Sad is mentioned and in fact it is a mistake; the narrator is 'Aisha bint Sad bin Abi Waqqas). Should I give two-thirds of my property in charity?' He said, 'No.' I asked, 'Half?' He said, 'No.' then he added, 'One-third, and even one-third is much. You'd better leave your inheritors wealthy rather than leaving them poor, begging others. You will get a reward for whatever you spend for Allah's sake, even for what you put in your wife's mouth.' I said, 'O Allah's Apostle! Will I be left alone after my companions have gone?' He said, 'If you are left behind, whatever good deeds you will do will up-grade you and raise you high. And perhaps you will have a long life so that some people will be benefited by you while others will be harmed by you. O Allah! Complete the emigration of my companions and do not turn them renegades.' But Allah's Apostle felt sorry for poor Sad bin Khaula as he died in Mecca." (but Sad bin Abi Waqqas lived long after the Prophet (p.b.u.h).)


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.384]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 384

Narrated 'Abdullah:

The Prophet said, "He who slaps the cheeks, tears the clothes and follows the tradition of the Days of Ignorance is not from us."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.385]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 385

Narrated 'Abdullah:

The Prophet said, "He who slaps the cheeks, tears the clothes and follows the traditions of the Days of Ignorance is not from us."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.386]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 386

Narrated 'Aisha:

When the Prophet got the news of the death of Ibn Haritha, Ja'far and Ibn Rawaha he sat down and looked sad and I was looking at him through the chink of the door. A man came and told him about the crying of the women of Ja'far. The Prophet ordered him to forbid them. The man went and came back saying that he had told them but they did not listen to him. The Prophet (p.b.u.h) said, "Forbid them." So again he went and came back for the third time and said, "O Allah's Apostle! By Allah, they did not listen to us at all." ('Aisha added): Allah's Apostle ordered him to go and put dust in their mouths. I said, (to that man) "May Allah stick your nose in the dust (i.e. humiliate you)! You could neither (persuade the women to) fulfill the order of Allah's Apostle nor did you relieve Allah's Apostle from fatigue. "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.387]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 387

Narrated Anas:

When the reciters of Quran were martyred, Allah's Apostle recited Qunut for one month and I never saw him (i.e. Allah's Apostle) so sad as he was on that day.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.388]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 388

Narrated Anas bin Malik:

One of the sons of Abu Talha became sick and died and Abu Talha at that time was not at home. When his wife saw that he was dead, she prepared him (washed and shrouded him) and placed him somewhere in the house. When Abu Talha came, he asked, "How is the boy?" She said, "The child is quiet and I hope he is in peace." Abu Talha thought that she had spoken the truth. Abu Talha passed the night and in the morning took a bath and when he intended to go out, she told him that his son had died, Abu Talha offered the (morning) prayer with the Prophet and informed the Prophet of what happened to them. Allah's Apostle said, "May Allah bless you concerning your night. (That is, may Allah bless you with good offspring)." Sufyan said, "One of the Ansar said, 'They (i.e. Abu Talha and his wife) had nine sons and all of them became reciters of the Quran (by heart).' "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.389]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 389

Narrated Anas:

The Prophet said, "The real patience is at the first stroke of a calamity."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.390]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 390

Narrated Anas bin Malik:

We went with Allah's Apostle (p.b.u.h) to the blacksmith Abu Saif, and he was the husband of the wet-nurse of Ibrahim (the son of the Prophet). Allah's Apostle took Ibrahim and kissed him and smelled him and later we entered Abu Saif's house and at that time Ibrahim was in his last breaths, and the eyes of Allah's Apostle (p.b.u.h) started shedding tears. 'Abdur Rahman bin 'Auf said, "O Allah's Apostle, even you are weeping!" He said, "O Ibn 'Auf, this is mercy." Then he wept more and said, "The eyes are shedding tears and the heart is grieved, and we will not say except what pleases our Lord, O Ibrahim ! Indeed we are grieved by your separation."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.391]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 391

Narrated 'Abdullah bin 'Umar :

Sad bin 'Ubada became sick and the Prophet along with 'Abdur Rahman bin 'Auf, Sad bin Abi Waqqas and 'Abdullah bin Masud visited him to enquire about his health. When he came to him, he found him surrounded by his household and he asked, "Has he died?" They said, "No, O Allah's Apostle." The Prophet wept and when the people saw the weeping of Allah's Apostle (p.b.u.h) they all wept. He said, "Will you listen? Allah does not punish for shedding tears, nor for the grief of the heart but he punishes or bestows His Mercy because of this." He pointed to his tongue and added, "The deceased is punished for the wailing of his relatives over him." 'Umar used to beat with a stick and throw stones and put dust over the faces (of those who used to wail over the dead).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.392]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 392

Narrated Aisha:

When the news of the martyrdom of Zaid bin Haritha, Ja'far and 'Abdullah bin Rawaha came, the Prophet sat down looking sad, and I was looking through the chink of the door. A man came and said, "O Allah's Apostle! The women of Ja'far," and then he mentioned their crying . The Prophet (p.b.u.h) ordered h im to stop them from crying. The man went and came back and said, "I tried to stop them but they disobeyed." The Prophet (p.b.u.h) ordered him for the second time to forbid them. He went again and came back and said, "They did not listen to me, (or "us": the sub-narrator Muhammad bin Haushab is in doubt as to which is right). " ('Aisha added: The Prophet said, "Put dust in their mouths." I said (to that man), "May Allah stick your nose in the dust (i.e. humiliate you)." By Allah, you could not (stop the women from crying) to fulfill the order, besides you did not relieve Allah's Apostle from fatigue."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.393]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 393

Narrated Um 'Atiyya:

At the time of giving the pledge of allegiance to the Prophet one of the conditions was that we would not wail, but it was not fulfilled except by five women and they are Um Sulaim, Um Al-'Ala', the daughter of Abi Sabra (the wife of Muadh), and two other women; or the daughter of Abi Sabra and the wife of Muadh and another woman.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.394]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 394

Narrated 'Amir bin Rabi'a:,

The Prophet said, "Whenever you see a funeral procession, stand up till the procession goes ahead of you." Al-Humaidi added, "Till the coffin leaves you behind or is put down."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.395]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 395

Narrated 'Amir bin Rabi'a:

The Prophet said, "If any one of you see a funeral procession and he is not going along with it, then he should stand and remain standing till he gets behind it, or it leaves him behind, or the coffin is put down before it goes ahead of him . "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.396]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 396

Narrated Said Al-Maqburi:

That his father said, "While we were accompanying a funeral procession, Abu Huraira got hold of the hand of Marwan and they sat down before the coffin was put down. Then Abu Said came and took hold of Marwan's hand and said, "Get up. By Allah, no doubt this (i.e. Abu Huraira) knows that the Prophet forbade us to do that." Abu Huraira said, "He (Abu Said) has spoken the truth."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.397]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 397

Narrated Abu Said Al-Khudri

The Prophet said, "When you see a funeral procession, you should stand up, and whoever accompanies it should not sit till the coffin is put down."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.398]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 398

Narrated Jabir bin 'Abdullah :

A funeral procession passed in front of us and the Prophet stood up and we too stood up. We said, 'O Allah's Apostle! This is the funeral procession of a Jew." He said, "Whenever you see a funeral procession, you should stand up."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.399]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 399

Narrated 'Abdur Rahman bin Abi Laila:

Sahl bin Hunaif and Qais bin Sad were sitting in the city of Al-Qadisiya. A funeral procession passed in front of them and they stood up. They were told that funeral procession was of one of the inhabitants of the land i.e. of a non-believer, under the protection of Muslims. They said, "A funeral procession passed in front of the Prophet and he stood up. When he was told that it was the coffin of a Jew, he said, "Is it not a living being (soul)?"


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.400]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 400

Narrated Abu Sa'id Al-Khudri :

Allah's Apostle said, When the funeral is ready and the men carry it on their shoulders, if the deceased was righteous it will say, 'Present me (hurriedly),' and if he was not righteous, it will say, 'Woe to it (me)! Where are they taking it (me)?' Its voice is heard by everything except man and if he heard it he would fall unconscious."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.401]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 401

Narrated Abu Huraira:

The Prophet said, "Hurry up with the dead body for if it was righteous, you are forwarding it to welfare; and if it was otherwise, then you are putting off an evil thing down your necks."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.402]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 402

Narrated Abu Sa'id Al-Khudri

The Prophet said, "When a funeral is ready and the men carry the deceased on their necks (shoulders), if it was pious then it will say, 'Present me quickly', and if it was not pious, then it will say, 'Woe to it (me), where are they taking it (me)?' And its voice is heard by everything except mankind and if he heard it he would fall unconscious."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.403]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 403

Narrated Jabir bin 'Abdullah:

Allah's Apostle offered the funeral prayer for An-Najashi and I was in the second or third row.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.404]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 404

Narrated Abu Huraira:

The Prophet (p.b.u.h) informed his companions about the death of AnNajashi and then he went ahead (to lead the prayer) and the people lined up behind him in rows and he said four Takbir.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.405]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 405

Narrated Ash-Shaibani:

Ash Sha'bi said, "I was informed by a man who had seen the Prophet going to a grave that was separate from the other graves and he aligned the people in rows and said four Takbir." I said, "O Abu 'Amr! who narrated (that) to you"? He said, "Ibn Abbas. "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.406]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 406

Narrated Jabir bin 'Abdullah :

The Prophet said, "Today a pious man from Ethiopia (i.e. An Najashi) has expired, come on to offer the funeral prayer." (Jabir said): We lined up in rows and after that the Prophet led the prayer and we were in rows. Jabir added, I was in the second row."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.407]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 407

Narrated Ibn Abbas:

Allah's Apostle passed by a grave of a deceased who had been buried at night. He said, "When was this (deceased) buried?" The people said, "Yesterday." He said, "Why did you not inform me?" They said, "We buried him when it was dark and so we disliked to wake you up." He stood up and we lined up behind him. (Ibn Abbas said): I was one of them, and the Prophet offered the funeral prayer.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.408]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 408

Narrated Ash-Shaibani:

Ash-Sha'bi said, "Somebody who passed along with your Prophet (p.b.u.h) by a grave that was separate from the other graves informed me (saying), "The Prophet

led us (in the prayer) and we aligned behind him." We said, "O Abu 'Amr! Who told you this narration?" He replied, "Ibn Abbas."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.409]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 409

Narrated Nafi:

Ibn Umar was told that Abu Huraira said, "Whoever accompanies the funeral procession will have a reward equal to one Qirat." Ibn 'Umar said, "Abu Huraira talks of a too enormous reward." Aisha attested Abu Huraira's narration and said, "I heard Allah's Apostle saying like that." Ibn Umar said, "We have lost numerous Qirats."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.410]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 410

Narrated Abu Huraira:

that Allah's Apostle (p.b.u.h) said, "Whoever attends the funeral procession till he offers the funeral prayer for it, will get a reward equal to one Qirat, and whoever accompanies it till burial, will get a reward equal to two Qirats." It was asked, "What are two Qirats?" He replied, "Like two huge mountains."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.411]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 411

Narrated 'Amir:

Ibn Abbas (who was at that time a boy) said, "Allah's Apostle came to a grave and the people said, 'He or she was buried yesterday.' " Ibn Abbas added, "We aligned behind the Prophet and he led the funeral prayer of the deceased."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.412]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 412

Narrated Abu Huraira:

Allah's Apostle informed about the news of the death of An-Najash (King of Ethiopia) on the day he expired. He said, "Ask Allah's forgiveness for your brother. " Narrated Abu Huraira: The Prophet made them align in rows at the Musalla and said four Takbir.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.413]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 413

Narrated 'Abdullah bin 'Umar :

The Jew brought to the Prophet a man and a woman from amongst them who have committed (adultery) illegal sexual intercourse. He ordered both of them to be stoned (to death), near the place of offering the funeral prayers beside the mosque."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.414]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 414

Narrated 'Urwa:

Aisha said, "The Prophet in his fatal illness said, 'Allah cursed the Jews and the Christians because they took the graves of their Prophets as places for praying."' Aisha added, "Had it not been for that the grave of the Prophet (p.b.u.h)

would have been made prominent but I am afraid it might be taken (as a) place for praying.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.415]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 415

Narrated Samura bin Jundab:

I offered the funeral prayer behind the Prophet for a woman who had died during child-birth and he stood up by the middle of the coffin.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.416]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 416

Narrated Samura bin Jundab

I offered the funeral prayer behind the Prophet for a woman who had died during child-birth and he stood up by the middle of the coffin.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.417]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 417

Narrated Abu Huraira:

Allah's Apostle informed about the news of the death of An-Najash on the day he died. He went out with us to the Musalla and we aligned in rows and he said four Takbirs for An-Najashi's funeral prayer.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.418]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 418

Narrated Jabir:

The Prophet offered the funeral prayer of As-Hama An-Najash and said four Takbir.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.419]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 419

Narrated Talha bin 'Abdullah bin 'Auf:

I offered the funeral prayer behind Ibn Abbas and he recited Al-Fatiha and said, "You should know that it (i.e. recitation of Al-Fatiha) is the tradition of the Prophet Muhammad.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.420]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 420

Narrated Sulaiman Ash-Shaibani:

I heard Ash-Sha'bi saying, "I was told by a man who had passed with the Prophet (p.b.u.h) by a grave that was separate from the other graves that he (the Prophet ) led them in the prayer and they prayed behind him." I said, "O Abu 'Amr! Who narrated that to you?" He replied, "Ibn Abbas."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.421]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 421

Narrated Abu Huraira:

A black person, a male or a female used to clean the Mosque and then died. The Prophet (p.b.u.h) did not know about it . One day the Prophet remembered him and said, "What happened to that person?" The people replied, "O Allah's Apostle! He died." He said, "Why did you not inform me?" They said, "His story was so and so (i.e. regarded him as insignificant)." He said, "Show me his grave." He then went to his grave and offered the funeral prayer.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.422]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 422

Narrated Anas:

The Prophet said, "When a human being is laid in his grave and his companions return and he even hears their foot steps, two angels come to him and make him sit and ask him: What did you use to say about this man, Muhammad ? He will say: I testify that he is Allah's slave and His Apostle. Then it will be said to him, 'Look at your place in the Hell-Fire. Allah has given you a place in Paradise instead of it.' " The Prophet added, "The dead person will see both his places. But a non-believer or a hypocrite will say to the angels, 'I do not know, but I used to say what the people used to say! It will be said to him, 'Neither did you know nor did you take the guidance (by reciting the Quran).' Then he will be hit with an iron hammer between his two ears, and he will cry and that cry will be heard by whatever approaches him except human beings and jinns."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.423]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 423

Narrated Abu Huraira:

The angel of death was sent to Moses and when he went to him, Moses slapped him severely, spoiling one of his eyes. The angel went back to his Lord, and said, "You sent me to a slave who does not want to die." Allah restored his eye and said, "Go back and tell him (i.e. Moses) to place his hand over the back of an ox, for he will be allowed to live for a number of years equal to the number of hairs coming under his hand." (So the angel came to him and told him the same). Then Moses asked, "O my Lord! What will be then?" He said, "Death will be then." He said, "(Let it be) now." He asked Allah that He bring him near the Sacred Land at a distance of a stone's throw. Allah's Apostle (p.b.u.h) said, "Were I there I would show you the grave of Moses by the way near the red sand hill."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.424]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 424

Narrated Ibn Abbas:

The Prophet (p.b.u.h) offered the funeral prayer of a man one night after he was buried, he and his companions stood up (for the Prayer). He had asked them about him before standing, saying, "Who is this?" They said, "He is so and so and was buried last night." So all of them offered the funeral prayer.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.425]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 425

Narrated 'Aisha:

When the Prophet became ill, some of his wives talked about a church which they had seen in Ethiopia and it was called Mariya. Um Salma and Um Habiba had been to Ethiopia, and both of them narrated its (the Church's) beauty and the pictures it contained. The Prophet raised his head and said, "Those are the people who, whenever a pious man dies amongst them, make a place of worship at his grave and then they make those pictures in it. Those are the worst creatures in the Sight of Allah."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.426]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 426

Narrated Anas:

We were in the funeral procession of the daughter of Allah's Apostle and Allah's Apostle was sitting near the grave and I saw his eyes full of tears. He said, "Is there anyone amongst you who did not have sexual relations with his wife last night?" Abu Talha replied in the affirmative. And so Allah's Apostle told him to get down in her grave and he got down in her grave and buried her.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.427]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 427

Narrated Jabir bin Abdullah:

The Prophet collected every two martyrs of Uhud in one piece of cloth, then he would ask, "Which of them had (knew) more of the Quran?" When one of them was pointed out for him, he would put that one first in the grave and say, "I will be a witness on these on the Day of Resurrection." He ordered them to be buried with their blood on their bodies and they were neither washed nor was a funeral prayer offered for them.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.428]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 428

Narrated 'Uqba bin 'Amir:

One day the Prophet went out and offered the funeral prayers of the martyrs of Uhud and then went up the pulpit and said, "I will pave the way for you as your predecessor and will be a witness on you. By Allah! I see my Fount (Kauthar) just now and I have been given the keys of all the treasures of the earth (or the keys of the earth). By Allah! I am not afraid that you will worship others along with Allah after my death, but I am afraid that you will fight with one another for the worldly things."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.429]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 429

Narrated Jabir bin 'Abdullah :

The Prophet buried every two martyrs in of Uhud in one grave.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.430]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 430

Narrated Jabir:

The Prophet said, "Bury them (i.e. martyrs) with their blood." (that was) On the day of the Battle of Uhud. He did not get them washed.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.431]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 431

Narrated Jabir bin 'Abdullah :

Allah's Apostle shrouded every two martyrs of Uhud in one piece of cloth and then he would ask, "Which of them knew more Quran?" When one of them was pointed out he would put him first in the grave. He said, "I am a witness on these." Then he ordered them to be buried with blood on their bodies. Neither did he offer their funeral prayer nor did he get them washed. (Jabir bin Abdullah added): Allah's Apostle used to ask about the martyrs of Uhud as to which of them knew more of the Quran." And when one of them was pointed out as having more of it he would put him first in the grave and then his companions. (Jabir added): My father and my uncle were shrouded in one sheet.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.432]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 432

Narrated Ibn Abbas:

The Prophet said, "Allah has made Mecca a sanctuary (sacred place) and it was a sanctuary before me and will be so after me. It was made legal for me (to fight in it) for a few hours of the day. None is allowed to uproot its thorny shrubs or to cut its trees or to chase its game or to pick up its fallen things except by a person who announces it publicly." On that Al-Abbas said (to the Prophet), "Except Al-Idhkhir for our goldsmiths and for our graves." And so the Prophet added, "Except Al-Idhkhir. " And Abu Huraira narrated that the Prophet said, "Except Al-Idhkhir for our graves and houses." And Ibn Abbas said, "For their goldsmiths and houses."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.433]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 433

Narrated Jabir bin 'Abdullah:

Allah's Apostle came to Abdullah bin Ubai (a hypocrite) after his death and he has been laid in his pit (grave). He ordered (that he be taken out of the grave) and he was taken out. Then he placed him on his knees and threw some of his saliva on him and clothed him in his (the Prophet's) own shirt. Allah knows better (why he did so). 'Abdullah bin Ubai had given his shirt to Al-Abbas to wear. Abu Harun said, "Allah's Apostle at that time had two shirts and the son of 'Abdullah bin Ubai said to him, 'O Allah's Apostle! Clothe my father in your shirt which has been in contact with your skin.' ' Sufyan added, "Thus people think that the Prophet clothed 'Abdullah bin Tubal in his shirt in lieu of what he (Abdullah) had done (for Al Abbas, the Prophet's uncle.)"


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.434]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 434

Narrated Jabir:

When the time of the Battle of Uhud approached, my father called me at night and said, "I think that I will be the first amongst the companions of the Prophet to be martyred. I do not leave anyone after me dearer to me than you, except Allah's Apostle's soul and I owe some debt and you should repay it and treat your sisters favorably (nicely and politely)." So in the morning he was the first to be martyred and was buried along with another (martyr). I did not like to leave him with the other (martyr) so I took him out of the grave after six months of his burial and he was in the same condition as he was on the day of burial, except a slight change near his ear.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.435]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 435

Narrated Jabir:

A man was buried along with my father and I did not like it till I took him (i.e. my father) out and buried him in a separate grave.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.436]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 436

Narrated Jabir bin 'Abdullah:

The Prophet collected every two martyrs of Uhud (in one grave) and then he would ask, "Which of them knew the Quran more?" And if one of them was pointed out for him as having more knowledge, he would put him first in the Lahd. The Prophet said, "I will be a witness on these on the Day of Resurrection." Then he ordered them to be buried with their blood on their bodies and he did not have them washed.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.437]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 437

Narrated Ibn 'Umar:

'Umar set out along with the Prophet (p.b.u.h) with a group of people to Ibn Saiyad till they saw him playing with the boys near the hillocks of Bani Mughala. Ibn Saiyad at that time was nearing his puberty and did not notice (us) until the Prophet stroked him with his hand and said to him, "Do you testify that I am Allah's Apostle?" Ibn Saiyad looked at him and said, "I testify that you are the Messenger of illiterates." Then Ibn Saiyad asked the Prophet (p.b.u.h), "Do you testify that I am Allah's Apostle?" The Prophet (p.b.u.h) refuted it and said, "I believe in Allah and His Apostles." Then he said (to Ibn Saiyad), "What do you think?" Ibn Saiyad answered, "True people and liars visit me." The Prophet said, "You have been confused as to this matter." Then the Prophet said to him, "I have kept something (in my mind) for you, (can you tell me that?)" Ibn Saiyad said, "It is Al-Dukh (the smoke)." (2) The Prophet said, "Let you be in ignominy. You cannot cross your limits." On that 'Umar, said, "O Allah's Apostle! Allow me to chop his head off." The Prophet (p.b.u.h) said, "If he is he (i.e. Dajjal), then you cannot over-power him, and if he is not, then there is no use of murdering him." (Ibn 'Umar added): Later on Allah's Apostle (p.b.u.h) once again went along with Ubai bin Ka'b to the date-palm trees (garden) where Ibn Saiyad was staying. The Prophet (p.b.u.h) wanted to hear something from Ibn Saiyad before Ibn Saiyad could see him, and the Prophet (p.b.u.h) saw him lying covered with a sheet and from where his murmurs were heard. Ibn Saiyad's mother saw Allah's Apostle while he was hiding himself behind the trunks of the date-palm trees. She addressed Ibn Saiyad, "O Saf ! (and this was the name of Ibn Saiyad) Here is Muhammad." And with that Ibn Saiyad got up. The Prophet said, "Had this woman left him (Had she not disturbed him), then Ibn Saiyad would have revealed the reality of his case.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.438]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 438

Narrated Anas:

A young Jewish boy used to serve the Prophet and he became sick. So the Prophet went to visit him. He sat near his head and asked him to embrace Islam. The boy looked at his father, who was sitting there; the latter told him to obey Abu-l-Qasim and the boy embraced Islam. The Prophet came out saying: "Praises be to Allah Who saved the boy from the Hell-fire."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.439]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 439

Narrated Ibn Abbas:

My mother and I were among the weak and oppressed. I from among the children, and my mother from among the women.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.440]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 440

Narrated Ibn Shihab:

The funeral prayer should be offered for every child even if he were the son of a prostitute as he was born with a true faith of Islam (i.e. to worship none but Allah Alone). If his parents are Muslims, particularly the father, even if his mother were a non-Muslim, and if he after the delivery cries (even once) before his death (i.e. born alive) then the funeral prayer must be offered. And if the child does not cry after his delivery (i.e. born dead) then his funeral prayer should not be offered, and he will be considered as a miscarriage. Abu Huraira, narrated that the Prophet said, "Every child is born with a true faith (i.e. to worship none but Allah Alone) but his parents convert him to Judaism or to Christianity or to Magainism, as an animal delivers a perfect baby animal. Do you find it mutilated?" Then Abu Huraira recited the holy verses: 'The pure Allah's Islamic nature (true faith i.e. to worship none but Allah Alone), with which He has created human beings.' " (30.30).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.441]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 441

Narrated Abu Huraira :

Allah's Apostle said, "Every child is born with a true faith of Islam (i.e. to worship none but Allah Alone) but his parents convert him to Judaism, Christianity or Magainism, as an animal delivers a perfect baby animal. Do you find it mutilated?" Then Abu Huraira recited the holy verses: "The pure Allah's Islamic nature (true faith of Islam) (i.e. worshipping none but Allah) with which He has created human beings. No change let there be in the religion of Allah (i.e. joining none in worship with Allah). That is the straight religion (Islam) but most of men know, not." (30.30)


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.442]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 442

Narrated Said bin Al-Musaiyab from his father:

When the time of the death of Abu Talib approached, Allah's Apostle went to him and found Abu Jahl bin Hisham and 'Abdullah bin Abi Umaiya bin Al-Mughira by his side. Allah's Apostle said to Abu Talib, "O uncle! Say: None has the right to be worshipped but Allah, a sentence with which I shall be a witness (i.e. argue) for you before Allah. Abu Jahl and 'Abdullah bin Abi Umaiya said, "O Abu Talib! Are you going to denounce the religion of Abdul Muttalib?" Allah's Apostle kept on inviting Abu Talib to say it (i.e. 'None has the right to be worshipped but Allah') while they (Abu Jahl and Abdullah) kept on repeating their statement till Abu Talib said as his last statement that he was on the religion of Abdul Muttalib and refused to say, 'None has the right to be worshipped but Allah.' (Then Allah's Apostle said, "I will keep on asking Allah's forgiveness for you unless I am forbidden (by Allah) to do so." So Allah revealed (the verse) concerning him (i.e. It is not fitting for the Prophet and those who believe that they should invoke (Allah) for forgiveness for pagans even though they be of kin, after it has become clear to them that they are companions of the fire (9.113).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.443]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 443

Narrated Ibn Abbas:

The Prophet once passed by two graves, and those two persons (in the graves) were being tortured. He said, "They are being tortured not for a great thing (to avoid). One of them never saved himself from being soiled with his urine, while the other was going about with calumnies (to make enmity between friends). He then took a green leaf of a date-palm tree split it into two pieces and fixed one on each grave. The people said, "O Allah's Apostle! Why have you done so?" He replied, "I hope that their punishment may be lessened till they (the leaf) become dry."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.444]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 444

Narrated 'Ali:

" We were accompanying a funeral procession in Baqi-I-Gharqad. The Prophet came to us and sat and we sat around him. He had a small stick in his hand then he bent his head and started scraping the ground with it. He then said, "There is none among you, and not a created soul, but has place either in Paradise or in Hell assigned for him and it is also determined for him whether he will be among the blessed or wretched." A man said, "O Allah's Apostle! Should we not depend on what has been written for us and leave the deeds as whoever amongst us is blessed will do the deeds of a blessed person and whoever amongst us will be wretched, will do the deeds of a wretched person?" The Prophet said, "The good deeds are made easy for the blessed, and bad deeds are made easy for the wretched." Then he recited the Verses:-- "As for him who gives (in charity) and is Allah-fearing And believes in the Best reward from Allah. " (92.5-6)


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.445]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 445

Narrated Thabit bin Ad-Dahhak:

The Prophet (p.b.u.h) said, "Whoever intentionally swears falsely by a religion other than Islam, then he is what he has said, (e.g. if he says, 'If such thing is not true then I am a Jew,' he is really a Jew). And whoever commits suicide with piece of iron will be punished with the same piece of iron in the Hell Fire." Narrated Jundab the Prophet said, "A man was inflicted with wounds and he committed suicide, and so Allah said: My slave has caused death on himself hurriedly, so I forbid Paradise for him."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.446]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 446

Narrated Abu Huraira-:

The Prophet said, "He who commits suicide by throttling shall keep on throttling himself in the Hell Fire (forever) and he who commits suicide by stabbing himself shall keep on stabbing himself in the Hell-Fire."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.447]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 447

Narrated 'Umar bin Al-Khattab :

When 'Abdullah bin Ubai bin Salul died, Allah's Apostle (p.b.u.h) was called upon to offer his funeral prayer. When Allah's Apostle stood up to offer the prayer, I got up quickly and said, "O Allah's Apostle! Are you going to pray for Ibn Ubai and he said so and so on such and such occasions?" And started mentioning all that he had said. Allah's Apostle smiled and said, "O 'Umar! Go away from me." When I talked too much he said, "I have been given the choice and so I have chosen (to offer the prayer). Had I known that he would be forgiven by asking for Allah's forgiveness for more than seventy times, surely I would have done so." ('Umar added): Allah's Apostle offered his funeral prayer and returned and after a short while the two verses of Surat Bara' were revealed: i.e. "And never (O Muhammad) pray for any of them who dies . . . (to the end of the verse) rebellion (9.84)" -- ('Umar added), "Later I astonished at my daring before Allah's Apostle on that day. And Allah and His Apostle know better."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.448]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 448

Narrated Anas bin Malik, :

A funeral procession passed and the people praised the deceased. The Prophet said, "It has been affirmed to him." Then another funeral procession passed and the people spoke badly of the deceased. The Prophet said, "It has been affirmed to him". 'Umar bin Al-Khattab asked (Allah's Apostle (p.b.u.h) ), "What has been affirmed?" He replied, "You praised this, so Paradise has been affirmed to him; and you spoke badly of this, so Hell has been affirmed to him. You people are Allah's witnesses on earth."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.449]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 449

Narrated Abu Al-Aswad:

I came to Medina when an epidemic had broken out. While I was sitting with 'Umar bin Al-Khattab a funeral procession passed by and the people praised the deceased. 'Umar said, "It has been affirmed to him." And another funeral procession passed by and the people praised the deceased. 'Umar said, "It has been affirmed to him." A third (funeral procession) passed by and the people spoke badly of the deceased. He said, "It has been affirmed to him." I (Abu Al-Aswad) asked, "O chief of the believers! What has been affirmed?" He replied, "I said the same as the Prophet had said, that is: if four persons testify the piety of a Muslim, Allah will grant him Paradise." We asked, "If three persons testify his piety?" He (the Prophet) replied, "Even three." Then we asked, "If two?" He replied, "Even two." We did not ask him regarding one witness.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.450]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 450

Narrated Al-Bara' bin 'Azib :

The Prophet (p.b.u.h) said, "When a faithful believer is made to sit in his grave, then (the angels) come to him and he testifies that none has the right to be worshipped but Allah and Muhammad is Allah's Apostle. And that corresponds to Allah's statement: Allah will keep firm those who believe with the word that stands firm . . . (14.27).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.451]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 451

Narrated Shu'ba:

Same as above and added, "Allah will keep firm those who believe . . . (14.27) was revealed concerning the punishment of the grave."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.452]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 452

Narrated Ibn 'Umar:

The Prophet looked at the people of the well (the well in which the bodies of the pagans killed in the Battle of Badr were thrown) and said, "Have you found true what your Lord promised you?" Somebody said to him, "You are addressing dead people." He replied, "You do not hear better than they but they cannot reply."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.453]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 453

Narrated 'Aisha:

The Prophet said, "They now realize that what I used to tell them was the truth. "And Allah said, 'Verily! You cannot make the dead to hear (i.e. benefit them, and similarly the disbelievers) nor can you make the deaf hear. (27.80).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.454]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 454

Narrated Masruq:

'Aisha said that a Jewess came to her and mentioned the punishment in the grave, saying to her, "May Allah protect you from the punishment of the grave." 'Aisha then asked Allah's Apostle about the punishment of the grave. He said, "Yes, (there is) punishment in the grave." 'Aisha added, "After that I never saw Allah's Apostle but seeking refuge with Allah from the punishment in the grave in every prayer he prayed."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.455]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 455

Narrated Asma' bint Abi Bakr :

Allah's Apostle once stood up delivering a sermon and mentioned the trial which people will face in the grave. When he mentioned that, the Muslims started shouting loudly.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.456]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 456

Narrated Anas bin Malik:

Allah's Apostle said, "When (Allah's) slave is put in his grave and his companions return and he even hears their footsteps, two angels come to him and make him sit and ask, 'What did you use to say about this man (i.e. Muhammad)?' The faithful Believer will say, 'I testify that he is Allah's slave and His Apostle.' Then they will say to him, 'Look at your place in the Hell Fire; Allah has given you a place in Paradise instead of it.' So he will see both his places." (Qatada said, "We were informed that his grave would be made spacious." Then Qatada went back to the narration of Anas who said;) Whereas a hypocrite or a non-believer will be asked, "What did you use to say about this man." He will reply, "I do not know; but I used to say what the people used to say." So they will say to him, "Neither did you know nor did you take the guidance (by reciting the Quran)." Then he will be hit with iron hammers once, that he will send such a cry as everything near to him will hear, except Jinns and human beings. (See Hadith No. 422).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.457]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 457

Narrated Abi Aiyub:

Once the Prophet went out after sunset and heard a dreadful voice, and said, "The Jews are being punished in their graves."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.458]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 458

Narrated Musa bin 'Uqba:

(From the daughter of Khalid bin Sa id bin Al-'Asi) who said that she had heard the Prophet seeking refuge with Allah from the punishment in the grave.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.459]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 459

Narrated Abu Huraira :

Allah's Apostle used to invoke (Allah): "Allahumma ini a'udhu bika min 'adhabi-l-Qabr, wa min 'adhabi-nnar, wa min fitnati-l-mahya wa-lmamat, wa min fitnati-l-masih ad-dajjal. (O Allah! I seek refuge with you from the punishment in the grave and from the punishment in the Hell fire and from the afflictions of life and death, and the afflictions of Al-Masih Ad-Dajjal."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.460]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 460

Narrated Ibn Abbas:

The Prophet once passed by two graves and said, "They (the deceased persons in those graves) are being tortured not for a great thing to avoid." And then added, "Yes, (they are being punished for a big sin), for one of them used to go about with calumnies while the other never saved himself from being soiled with his urine." (Ibn Abbas added): Then he took a green leaf of a date-palm) and split it into two pieces and fixed one piece on each grave and said, "May their punishment be abated till these (two pieces) get dry."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.461]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 461

Narrated 'Abdullah bin 'Umar :

Allah's Apostle said, "When anyone of you dies, he is shown his place both in the morning and in the evening. If he is one of the people of Paradise; he is shown his place in it, and if he is from the people of the Hell-Fire; he is shown his place there-in. Then it is said to him, 'This is your place till Allah resurrect you on the Day of Resurrection."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.462]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 462

Narrated Abu Sa'id Al-Khudri :

Allah's Apostle said, "When the funeral is ready (for its burial) and the people lift it on their shoulders, then if the deceased is a righteous person he says, 'Take me ahead,' and if he is not a righteous one then he says, 'Woe to it (me)! Where are you taking it (me)?' And his voice is audible to everything except human beings; and if they heard it they would fall down unconscious . "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.463]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 463

Narrated Anas bin Malik

Allah's Apostle (p.b.u.h) said, "Any Muslim whose three children died before the age of puberty will be granted Paradise by Allah because of His mercy to them."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.464]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 464

Narrated Al-Bara':

When Ibrahim (the son of Prophet) expired, Allah's Apostle said, "There is a wet-nurse for him in Paradise."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.465]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 465

Narrated Ibn Abbas:

Allah's Apostle (p.b.u.h) was asked about the children of (Mushrikeen) pagans. The Prophet replied, "Since Allah created them, He knows what sort of deeds they would have done."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.466]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 466

Narrated Abu Huraira:

The Prophet was asked about the offspring of pagans (Mushrakeen); so he said, "Allah knows what sort of deeds they would have done."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.467]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 467

Narrated Abu Huraira:

The Prophet said, "Every child is born with a true faith of Islam (i.e. to worship none but Allah Alone) and his parents convert him to Judaism or Christianity or Magianism, as an animal delivers a perfect baby animal. Do you find it mutilated?"


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.468]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 468

Narrated Samura bin Jundab:

Whenever the Prophet finished the (morning) prayer, he would face us and ask, "Who amongst you had a dream last night?" So if anyone had seen a dream he would narrate it. The Prophet would say: "Ma sha'a-llah" (An Arabic maxim meaning literally, 'What Allah wished,' and it indicates a good omen.) One day, he asked us whether anyone of us had seen a dream. We replied in the negative. The Prophet said, "But I had seen (a dream) last night that two men came to me, caught hold of my hands, and took me to the Sacred Land (Jerusalem). There, I saw a person sitting and another standing with an iron hook in his hand pushing it inside the mouth of the former till it reached the jaw-bone, and then tore off one side of his cheek, and then did the same with the other side; in the mean-time the first side of his cheek became normal again and then he repeated the same operation again. I said, 'What is this?' They told me to proceed on and we went on till we came to a man Lying flat on his back, and another man standing at his head carrying a stone or a piece of rock, and crushing the head of the Lying man, with that stone. Whenever he struck him, the stone rolled away.

The man went to pick it up and by the time he returned to him, the crushed head had returned to its normal state and the man came back and struck him again (and so on). I said, 'Who is this?' They told me to proceed on; so we proceeded on and passed by a hole like an oven; with a narrow top and wide bottom, and the fire was kindling underneath that hole. Whenever the fire-flame went up, the people were lifted up to such an extent that they about to get out of it, and whenever the fire got quieter, the people went down into it, and there were naked men and women in it. I said, 'Who is this?' They told me to proceed on. So we proceeded on till we reached a river of blood and a man was in it, and another man was standing at its bank with stones in front of him, facing the man standing in the river. Whenever the man in the river wanted to come out, the other one threw a stone in his mouth and caused him to retreat to his original position; and so whenever he wanted to come out the other would throw a stone in his mouth, and he would retreat to his original position. I asked, 'What is this?' They told me to proceed on and we did so till we reached a well-flourished green garden having a huge tree and near its root was sitting an old man with some children. (I saw) Another man near the tree with fire in front of him and he was kindling it up. Then they (i.e. my two companions) made me climb up the tree and made me enter a house, better than which I have ever seen. In it were some old men and young men, women and children.

Then they took me out of this house and made me climb up the tree and made me enter another house that was better and superior (to the first) containing old and young people. I said to them (i.e. my two companions), 'You have made me ramble all the night. Tell me all about that I have seen.' They said, 'Yes. As for the one whose cheek you saw being torn away, he was a liar and he used to tell lies, and the people would report those lies on his authority till they spread all over the world. So, he will be punished like that till the Day of Resurrection.

The one whose head you saw being crushed is the one whom Allah had given the knowledge of Quran (i.e. knowing it by heart) but he used to sleep at night (i.e. he did not recite it then) and did not use to act upon it (i.e. upon its orders etc.) by day; and so this punishment will go on till the Day of Resurrection. And those you saw in the hole (like oven) were adulterers (those men and women who commit illegal sexual intercourse). And those you saw in the river of blood were those dealing in Riba (usury). And the old man who was sitting at the base of the tree was Abraham and the little children around him were the offspring of the people. And the one who was kindling the fire was Malik, the gate-keeper of the Hell-fire. And the first house in which you have gone was the house of the common believers, and the second house was of the martyrs. I am Gabriel and this is Michael. Raise your head.' I raised my head and saw a thing like a cloud over me. They said, 'That is your place.' I said, 'Let me enter my place.' They said, 'You still have some life which you have not yet completed, and when you complete (that remaining portion of your life) you will then enter your place.' "


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.469]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 469

Narrated Hisham's father:

Aisha said, "I went to Abu Bakr (during his fatal illness) and he asked me, 'In how many garments was the Prophet shrouded?' She replied, 'In three Sahuliya pieces of white cloth of cotton, and there was neither a shirt nor a turban among them.' Abu Bakr further asked her, 'On which day did the Prophet die?' She replied, 'He died on Monday.' He asked, 'What is today?' She replied, 'Today is Monday.' He added, 'I hope I shall die sometime between this morning and tonight.' Then he looked at a garment that he was wearing during his illness and it had some stains of saffron. Then he said, 'Wash this garment of mine and add two more garments and shroud me in them.' I said, 'This is worn out.' He said, 'A living person has more right to wear new clothes than a dead one; the shroud is only for the body's pus.' He did not die till it was the night of Tuesday and was buried before the morning."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.470]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 470

Narrated Aisha:

A man said to the Prophet (p.b.u.h), "My mother died suddenly and I thought that if she had lived she would have given alms. So, if I give alms now on her behalf, will she get the reward?" The Prophet replied in the affirmative.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.471]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 471

Narrated 'Aisha:

During his sickness, Allah's Apostle was asking repeatedly, "Where am I today? Where will I be tomorrow?" And I was waiting for the day of my turn (impatiently). Then, when my turn came, Allah took his soul away (in my lap) between my chest and arms and he was buried in my house.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.472]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 472

Narrated 'Aisha:

Allah's Apostle in his fatal illness said, "Allah cursed the Jews and the Christians, for they built the places of worship at the graves of their prophets." And if that had not been the case, then the Prophet's grave would have been made prominent before the people. So (the Prophet ) was afraid, or the people were afraid that his grave might be taken as a place for worship.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.473]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 473

Narrated Abu Bakr bin 'Aiyash :

Sufyan At-Tammar told me that he had seen the grave of the Prophet elevated and convex.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.474]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 474

Narrated 'Urwa:

When the wall fell on them (i.e. graves) during the caliphate of Al-Walid bin 'Abdul Malik, the people started repairing it, and a foot appeared to them. The people got scared and thought that it was the foot of the Prophet. No-one could be found who could tell them about it till I ('Urwa) said to them, "By Allah, this is not the foot of the Prophet but it is the foot of Umar." Aisha narrated that she made a will to 'Abdullah bin Zubair, "Do not bury me with them (the Prophet and his two companions) but bury me with my companions (wives of the Prophet (p.b.u.h) ) in Al-Baqi as I would not like to be looked upon as better than I really am (by being buried near the Prophet)."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.475]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 475

Narrated 'Amr bin Maimun Al-Audi:

I saw 'Umar bin Al-Khattab (when he was stabbed) saying, "O 'Abdullah bin 'Umar! Go to the mother of the believers Aisha and say, 'Umar bin Al-Khattab sends his greetings to you,' and request her to allow me to be buried with my companions." (So, Ibn 'Umar conveyed the message to 'Aisha.) She said, "I had the idea of having this place for myself but today I prefer him ('Umar) to myself (and allow him to be buried there)." When 'Abdullah bin 'Umar returned, 'Umar asked him, "What (news) do you have?" He replied, "O chief of the believers! She has allowed you (to be buried there)." On that 'Umar said, "Nothing was more important to me than to be buried in that (sacred) place. So, when I expire, carry me there and pay my greetings to her ('Aisha ) and say, 'Umar bin Al-Khattab asks permission; and if she gives permission, then bury me (there) and if she does not, then take me to the grave-yard of the Muslims. I do not think any person has more right for the caliphate than those with whom Allah's Apostle (p.b.u.h) was always pleased till his death. And whoever is chosen by the people after me will be the caliph, and you people must listen to him and obey him," and then he mentioned the name of 'Uthman, 'Ali, Talha, Az-Zubair, 'Abdur-Rahman bin 'Auf and Sad bin Abi Waqqas.

By this time a young man from Ansar came and said, "O chief of the believers! Be happy with Allah's glad tidings. The grade which you have in Islam is known to you, then you became the caliph and you ruled with justice and then you have been awarded martyrdom after all this." 'Umar replied, "O son of my brother! Would that all that privileges will counterbalance (my short comings), so that I neither lose nor gain anything. I recommend my successor to be good to the early emigrants and realize their rights and to protect their honor and sacred things. And I also recommend him to be good to the Ansar who before them, had homes (in Medina) and had adopted the Faith. He should accept the good of the righteous among them and should excuse their wrongdoers. I recommend him to abide by the rules and regulations concerning the Dhimmis (protectees) of Allah and His Apostle, to fulfill their contracts completely and fight for them and not to tax (overburden) them beyond their capabilities."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.476]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 476

Narrated 'Aisha :

The Prophet (p.b.u.h) said, "Don't abuse the dead, because they have reached the result of what they forwarded."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.477]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 477

Narrated Ibn Abbas.:

Abu Lahab, may Allah curse him, once said to the Prophet (p.b.u.h), "Perish you all the day."

Then the Divine Inspiration came: "Perish the hands of Abi Lahab! And perish he!" (111.1).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.478]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 478

Narrated Ibn Abbas:

Thy Prophet sent Muadh to Yemen and said, "Invite the people to testify that none has the right to be worshipped but Allah and I am Allah's Apostle, and if they obey you to do so, then teach them that Allah has enjoined on them five prayers in every day and night (in twenty-four hours), and if they obey you to do so, then teach them that Allah has made it obligatory for them to pay the Zakat from their property and it is to be taken from the wealthy among them and given to the poor."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.479]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 479

Narrated Abu Aiyub:

A man said to the Prophet "Tell me of such a deed as will make me enter Paradise." The people said, "What is the matter with him? What is the matter with him?" The Prophet said, "He has something to ask. (What he needs greatly) The Prophet said: (In order to enter Paradise) you should worship Allah and do not ascribe any partners to Him, offer prayer perfectly, pay the Zakat and keep good relations with your Kith and kin." (See Hadith No. 12, Vol 8).


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.480]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 480

Narrated Abu Huraira:

A Bedouin came to the Prophet and said, "Tell me of such a deed as will make me enter Paradise, if I do it." The Prophet (p.b.u.h) said, "Worship Allah, and worship none along with Him, offer the (five) prescribed compulsory prayers perfectly, pay the compulsory Zakat, and fast the month of Ramadan." The Bedouin said, "By Him, in Whose Hands my life is, I will not do more than this." When he (the Bedouin) left, the Prophet said, "Whoever likes to see a man of Paradise, then he may look at this man."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.481]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 481

Narrated Abu Zur'a:

from the Prophet the same as above.


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.482]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 482

Narrated Ibn Abbas:

A delegation of the tribe of 'Abdul Qais came to the Prophet and said, "O Allah's Apostle! We are from the tribe of Rabi'a, and the infidels of the tribe of Mudar stands between us and you; so we cannot come to you except during the Sacred Months. Please order us to do something (religious deeds) which we may carry out and also invite to it our people whom we have left behind." The Prophet said, "I order you to do four things and forbid you four others: (I order you) to have faith in Allah, and confess that none has the right to be worshipped but Allah, (and the Prophet gestured with his hand like this (i.e. one knot) and to offer prayers perfectly and to pay the Zakat, and to pay one-fifth of the booty in Allah's Cause. And I forbid you to use Dubba', Hantam, Naqir and Muzaffat (all these are the names of utensils used for preparing alcoholic drinks)."


Bukhari :: Funerals (Al-Janaa'iz) :: [2.23.483]

Funerals (Al-Janaa'iz)

Bukhari :: Book 2 :: Volume 23 :: Hadith 483

Narrated Abu Huraira:

When Allah's Apostle died and Abu Bakr became the caliph some Arabs renegade (reverted to disbelief) (Abu Bakr decided to declare war against them), 'Umar, said to Abu Bakr, "How can you fight with these people although Allah's Apostle said, 'I have been ordered (by Allah) to fight the people till they say: "None has the right to be worshipped but Allah, and whoever said it then he will save his life and property from me except on trespassing the law (rights and conditions for which he will be punished justly), and his accounts will be with Allah.' " Abu Bakr said, "By Allah! I will fight those who differentiate between the prayer and the Zakat as Zakat is the compulsory right to be taken from the property (according to Allah's orders) By Allah! If they refuse to pay me even a she-kid which they used to pay at the time of Allah's Apostle . I would fight with them for withholding it" Then 'Umar said, "By Allah, it was nothing, but Allah opened Abu Bakr's chest towards the decision (to fight) and I came to know that his decision was right."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.484]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 484

Narrated Jarir bin 'Abdullah ,

I gave the pledge of allegiance to the Prophet for offering prayer perfectly giving Zakat and giving good advice to every Muslim.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.485]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 485

Narrated Abu Huraira:

The Prophet said, "(On the Day of Resurrection) camels will come to their owner in the best state of health they have ever had (in the world), and if he had not paid their Zakat (in the world) then they would tread him with their feet; and similarly, sheep will come to their owner in the best state of health they have ever had in the world, and if he had not paid their Zakat, then they would tread him with their hooves and would butt him with their horns." The Prophet added, "One of their rights is that they should be milked while water is kept in front of them." The Prophet added, "I do not want anyone of you to come to me on the Day of Resurrection, carrying over his neck a sheep that will be bleating. Such a person will (then) say, 'O Muhammad! (please intercede for me,) I will say to him. 'I can't help you, for I conveyed Allah's Message to you.' Similarly, I do not want anyone of you to come to me carrying over his neck a camel that will be grunting. Such a person (then) will say "O Muhammad! (please intercede for me)." I will say to him, "I can't help you for I conveyed Allah's message to you."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.486]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 486

Narrated Abu Huraira:

Allah's Apostle said, "Whoever is made wealthy by Allah and does not pay the Zakat of his wealth, then on the Day of Resurrection his wealth will be made like a bald-headed poisonous male snake with two black spots over the eyes. The snake will encircle his neck and bite his cheeks and say, 'I am your wealth, I am your treasure.' " Then the Prophet recited the holy verses:-- 'Let not those who withhold . . .' (to the end of the verse). (3.180).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.487]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 487

Narrated Abu Said:

Allah's Apostle (p.b.u.h) said, "No Zakat is due on property mounting to less than five Uqiyas (of silver), and no Zakat is due on less than five camels, and there is no Zakat on less than five Wasqs." (A Wasqs equals 60 Sa's) & (1 Sa=3 K gms App.)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.488]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 488

Narrated Zaid bin Wahab:

I passed by a place called Ar-Rabadha and by chance I met Abu Dhar and asked him, "What has brought you to this place?" He said, "I was in Sham and differed with Muawiya on the meaning of (the following verses of the Quran): 'They who hoard up gold and silver and spend them not in the way of Allah.' (9.34). Muawiya said, 'This verse is revealed regarding the people of the scriptures." I said, It was revealed regarding us and also the people of the scriptures." So we had a quarrel and Mu'awiya sent a complaint against me to 'Uthman. 'Uthman wrote to me to come to Medina, and I came to Medina. Many people came to me as if they had not seen me before. So I told this to 'Uthman who said to me, "You may depart and live nearby if you wish." That was the reason for my being here for even if an Ethiopian had been nominated as my ruler, I would have obeyed him .


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.489]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 489

Narrated Al-Ahnaf bin Qais:

While I was sitting with some people from Quraish, a man with very rough hair, clothes, and appearance came and stood in front of us, greeted us and said, "Inform those who hoard wealth, that a stone will be heated in the Hell-fire and will be put on the nipples of their breasts till it comes out from the bones of their shoulders and then put on the bones of their shoulders till it comes through the nipples of their breasts the stone will be moving and hitting." After saying that, the person retreated and sat by the side of the pillar, I followed him and sat beside him, and I did not know who he was. I said to him, "I think the people disliked what you had said." He said, "These people do not understand anything, although my friend told me." I asked, "Who is your friend?" He said, "The Prophet said (to me), 'O Abu Dhar! Do you see the mountain of Uhud?' And on that I (Abu Dhar) started looking towards the sun to judge how much remained of the day as I thought that Allah's Apostle wanted to send me to do something for him and I said, 'Yes!' He said, 'I do not love to have gold equal to the mountain of Uhud unless I spend it all (in Allah's cause) except three Dinars (pounds). These people do not understand and collect worldly wealth. No, by Allah, Neither I ask them for worldly benefits nor am I in need of their religious advice till I meet Allah, The Honorable, The Majestic." '


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.490]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 490

Narrated Ibn Masud:

I heard the Prophet saying, "There is no envy except in two: a person whom Allah has given wealth and he spends it in the right way, and a person whom Allah has given wisdom (i.e. religious knowledge) and he gives his decisions accordingly and teaches it to the others."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.491]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 491

Narrated Abu Huraira

Allah's Apostle said, "If one give in charity what equals one date-fruit fro the honestly-earned money and Allah accepts only the honestly earned money --Allah takes it in His right (hand) ar then enlarges its reward for that person (who has given it), as anyone of you brings up his baby horse, so much s that it becomes as big as a mountain


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.492]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 492

Narrated Haritha bin Wahab :

I heard the Prophet saying, "O people! Give in charity as a time will come upon you when a person will wander about with his object of charity and will not find anybody to accept it, and one (who will be requested to take it) will say, "If you had brought it yesterday, would have taken it, but to-day I am not in need of it."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.493]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 493

Narrated Abu Huraira:

The Prophet said, "The Hour (Day of Judgment) will not be established till your wealth increases so much so that one will be worried, for no one will accept his Zakat and the person to whom he will give it will reply, 'I am not in need of it.' "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.494]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 494

Narrated 'Adi bin Hatim:

While I was sitting with Allah's Apostle (p.b.u.h) two person came to him; one of them complained about his poverty and the other complained about the prevalence of robberies. Allah's Apostle said, "As regards stealing and robberies, there will shortly come a time when a caravan will go to Mecca (from Medina) without any guard. And regarding poverty, The Hour (Day of Judgment) will not be established till one of you wanders about with his object of charity and will not find anybody to accept it And (no doubt) each one of you will stand in front of Allah and there will be neither a curtain nor an interpreter between him and Allah, and Allah will ask him, 'Did not I give you wealth?' He will reply in the affirmative. Allah will further ask, 'Didn't I send a messenger to you?' And again that person will reply in the affirmative Then he will look to his right and he will see nothing but Hell-fire, and then he will look to his left and will see nothing but Hell-fire. And so, any (each one) of you should save himself from the fire even by giving half of a date-fruit (in charity). And if you do not find a half date-fruit, then (you can do it through saying) a good pleasant word (to your brethren). (See Hadith No. 793 Vol. 4).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.495]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 495

Narrated Abu Musa:

Thy Prophet (p.b.u.h) said, "A time will come upon the people when a person will wander about with gold as Zakat and will not find anybody to accept it, and one man will be seen followed by forty women to be their guardian because of scarcity of men and great number of women. "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.496]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 496

Narrated Abu Masud:

When the verses of charity were revealed, we used to work as porters. A man came and distributed objects of charity in abundance. And they (the people) said, "He is showing off." And another man came and gave a sa (a small measure of food grains); they said, "Allah is not in need of this small amount of charity." And then the Divine Inspiration came: "Those who criticize such of the believers who give in charity voluntarily and those who could not find to give in charity except what is available to them." (9.79).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.497]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 497

Narrated Abu Masud Al-Ansar:

Whenever Allah's Apostle (p.b.u.h) ordered us to give in charity, we used to go to the market and work as porters and get a Mudd (a special measure of grain) and then give it in charity. (Those were the days of poverty) and to-day some of us have one hundred thousand.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.498]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 498

Narrated 'Adi bin Hatim heard the Prophet saying:

"Save yourself from Hell-fire even by giving half a date-fruit in charity."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.499]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 499

Narrated Aisha:

A lady along with her two daughters came to me asking (for some alms), but she found nothing with me except one date which I gave to her and she divided it between her two daughters, and did not eat anything herself, and then she got up and went away. Then the Prophet came in and I informed him about this story. He said, "Whoever is put to trial by these daughters and he treats them generously (with benevolence) then these daughters will act as a shield for him from Hell-Fire." (See Hadith No. 24, Vol. 8).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.500]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 500

Narrated Abu Huraira:

A man came to the Prophet and asked, "O Allah's Apostle! Which charity is the most superior in reward?" He replied, "The charity which you practice while you are healthy, niggardly and afraid of poverty and wish to become wealthy. Do not delay it to the time of approaching death and then say, 'Give so much to such and such, and so much to such and such.' And it has already belonged to such and such (as it is too late)."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.501]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 501

Narrated 'Aisha:

Some of the wives of the Prophet asked him, "Who amongst us will be the first to follow you (i.e. die after you)?" He said, "Whoever has the longest hand." So they started measuring their hands with a stick and Sauda's hand turned out to be the longest. (When Zainab bint Jahsh died first of all in the caliphate of 'Umar), we came to know that the long hand was a symbol of practicing charity, so she was the first to follow the Prophet and she used to love to practice charity. (Sauda died later in the caliphate of Muawiya).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.502]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 502

Narrated Abu Huraira:

Allah's Apostle (p.b.u.h) said, "A man said that he would give something in charity. He went out with his object of charity and unknowingly gave it to a thief. Next morning the people said that he had given his object of charity to a thief. (On hearing that) he said, "O Allah! All the praises are for you. I will give alms again." And so he again went out with his alms and (unknowingly) gave it to an adulteress. Next morning the people said that he had given his alms to an adulteress last night. The man said, "O Allah! All the praises are for you. (I gave my alms) to an adulteress. I will give alms again." So he went out with his alms again and (unknowingly) gave it to a rich person. (The people) next morning said that he had given his alms to a wealthy person. He said, "O Allah! All the praises are for you. (I had given alms) to a thief, to an adulteress and to a wealthy man." Then someone came and said to him, "The alms which you gave to the thief, might make him abstain from stealing, and that given to the adulteress might make her abstain from illegal sexual intercourse (adultery), and that given to the wealthy man might make him take a lesson from it and spend his wealth which Allah has given him, in Allah's cause."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.503]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 503

Narrated Ma'n bin Yazid:

My grandfather, my father and I gave the pledge of allegiance to Allah's Apostle. The Prophet got me engaged and then got me married. One day I went to the Prophet with a complaint. My father Yazid had taken some gold coins for charity and kept them with a man in the mosque (to give them to the poor) But I went and took them and brought them to him (my father). My father said, "By Allah! I did not intend to give them to you. " I took (the case) to Allah's Apostle . On that Allah's Apostle said, "O Yazid! You will be rewarded for what you intended. O Man! Whatever you have taken is yours."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.504]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 504

Narrated Abu Huraira:

The Prophet (p.b.u.h) said, "Seven people will be shaded by Allah under His shade on the day when there will be no shade except His. They are:

(1) a just ruler;

(2) a young man who has been brought up in the worship of Allah, (i.e. worship Allah (Alone) sincerely from his childhood),

(3) a man whose heart is attached to the mosque (who offers the five compulsory congregational prayers in the mosque);

(4) two persons who love each other only for Allah's sake and they meet and part in Allah's cause only;

(5) a man who refuses the call of a charming woman of noble birth for an illegal sexual intercourse with her and says: I am afraid of Allah;

(6) a person who practices charity so secretly that his left hand does not know what his right hand has given (i.e. nobody knows how much he has given in charity).

(7) a person who remembers Allah in seclusion and his eyes get flooded with tears."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.505]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 505

Narrated Haritha bin Wahab Al-Khuza'i:

I heard the Prophet (p.b.u.h) saying, "(O people!) Give in charity (for Allah's cause) because a time will come when a person will carry his object of charity from place to place (and he will not find any person to take it) and any person whom he shall request to take it, I will reply, 'If you had brought it yesterday I would have taken it, but today I am not

in need of it."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.506]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 506

Narrated 'Aisha:

Allah's Apostle said, "When a woman gives in charity some of the foodstuff (which she has in her house) without spoiling it, she will receive the reward for what she has spent, and her husband will receive the reward because of his earning, and the storekeeper will also have a reward similar to it. The reward of one will not decrease the reward of the others . "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.507]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 507

Narrated Abu Huraira :

The Prophet (p.b.u.h) said, "The best charity is that which is practiced by a wealthy person. And start giving first to your dependents."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.508]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 508

Narrated Hakim bin Hizam

The Prophet said, "The upper hand is better than the lower hand (i.e. he who gives in charity is better than him who takes it). One should start giving first to his dependents. And the best object of charity is that which is given by a wealthy person (from the money which is left after his expenses). And whoever abstains from asking others for some financial help, Allah will give him and save him from asking others, Allah will make him self-sufficient."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.509]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 509

Narrated Ibn 'Umar:

I heard Allah's Apostle (p.b.u.h) while he was on the pulpit speaking about charity, to abstain from asking others for some financial help and about begging others, saying, "The upper hand is better than the lower hand. The upper hand is that of the giver and the lower (hand) is that of the beggar."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.510]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 510

Narrated 'Uqba bin Al-Harith:

Once the Prophet offered the 'Asr prayer and then hurriedly went to his house and returned immediately. I (or somebody else) asked him (as to what was the matter) and he said, "I left at home a piece of gold which was from the charity and I disliked to let it remain a night in my house, so I got it distributed . "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.511]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 511

Narrated Ibn Abbas:

The Prophet went out for the 'Id prayer on the 'Id day and offered a two Rakat prayer; and he neither offered a prayer before it or after it. Then he went towards the women along with Bilal. He preached them and ordered them to give in charity. And some (amongst the women) started giving their fore-arm bangles and ear-rings.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.512]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 512

Narrated Abu Burda bin Abu Musa:

that his father said, "Whenever a beggar came to Allah's Apostle or he was asked for something, he used to say (to his companions), "Help and recommend him and you will receive the reward for it; and Allah will bring about what He will through His Prophet's tongue."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.513]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 513

Narrated Asma:

The Prophet said to me, "Do not withhold your money, (for if you did so) Allah would with-hold His blessings from you."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.514]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 514

Narrated 'Abda:

T he Prophet said, "Do not with-hold your money by counting it (i.e. hoarding it), (for if you did so), Allah would also with-hold His blessings from you."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.515]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 515

Narrated Asma' bint Abu Bakr:

that she had gone to the Prophet and he said, "Do not shut your money bag; otherwise Allah too will with-hold His blessings from you. Spend (in Allah's Cause) as much as you can afford. "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.516]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 516

Narrated Abu Wail:

Hudhaifa said, "'Umar said, 'Who amongst you remembers the statement of Allah's Apostle (p.b.u.h) about afflictions'?' I said, 'I know it as the Prophet had said it.' 'Umar said, 'No doubt, you are bold. How did he say it?' I said, 'A man's afflictions (wrong deeds) concerning his wife, children and neighbors are expiated by (his) prayers, charity, and enjoining good.' (The sub-narrator Sulaiman added that he said, 'The prayer, charity, enjoining good and forbidding evil.') 'Umar said, 'I did not mean that, but I ask about that affliction which will spread like the waves of the sea.' I said, 'O chief of the believers! You need not be afraid of it as there is a closed door between you and it.' He asked, 'Will the door be broken or opened?' I replied, 'No, it will be broken.' He said, 'Then, if it is broken, it will never be closed again?' I replied, 'Yes.' " Then we were afraid to ask what that door was, so we asked Masruq to inquire, and he asked Hudhaifa regarding it. Hudhaifa said, "The door was 'Umar. "We further asked Hudhaifa whether 'Umar knew what that door meant. Hudhaifa replied in the affirmative and added, "He knew it as one knows that there will be a night before the tomorrow morning."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.517]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 517

Narrated Hakim bin Hizam:

I said to Allah's Apostle, "Before embracing Islam I used to do good deeds like giving in charity, slave-manumitting, and the keeping of good relations with Kith and kin. Shall I be rewarded for those deeds?" The Prophet replied, "You became Muslim with all those good deeds (Without losing their reward)."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.518]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 518

Narrated 'Aisha:

Allah's Apostle said, "When a woman gives in charity from her husband's meals without wasting the property of her husband, she will get a reward for it, and her husband too will get a reward for what he earned and the store-keeper will have the reward likewise."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.519]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 519

Narrated Abu Musa :

The Prophet said, "An honest Muslim store-keeper who carries out the orders of his master and pays fully what he has been ordered to give with a good heart and pays to that person to whom he was ordered to pay, is regarded as one of the two charitable persons."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.520]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 520

Narrate Aisha :

The Prophet said, "If a woman gives in charity from her husband's house .." The Prophet (p.b.u.h) also said, "If a lady gives meals (in charity) from her husband's house without spoiling her husband's property, she will get a reward and her husband will also get a reward likewise. The husband will get a reward because of his earnings and the woman because of her spending."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.521]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 521

Narrated 'Aisha:

The Prophet said, "When a woman gives in charity from her house meals in Allah's Cause without spoiling her husband's property, she will get a reward for it, and her husband will also get the reward for his earnings and the storekeeper will get a reward likewise."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.522]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 522

Narrated Abu Huraira :

The Prophet said, "Every day two angels come down from Heaven and one of them says, 'O Allah! Compensate every person who spends in Your Cause,' and the other (angel) says, 'O Allah! Destroy every miser.' "


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.523]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 523

Narrated Abu Huraira :

The Prophet said, "The example of a miser and an alms-giver is like the example of two persons wearing iron cloaks." Allah's Apostle also said, "The example of an alms-giver and a miser is like the example of two persons who have two iron cloaks on them from their breasts to their collar bones, and when the alms-giver wants to give in charity, the cloak becomes capacious till it covers his whole body to such an extent that it hides his fingertips and covers his footprints (obliterates his tracks). (1) And when the miser wants to spend, it (the iron cloak) sticks and every ring gets stuck to its place and he tries to widen it, but it did not become wide.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.524]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 524

Narrated Abu Burda:

from his father from his grandfather that the Prophet said, "Every Muslim has to give in charity." The people asked, "O Allah's Prophet! If someone has nothing to give, what will he do?" He said, "He should work with his hands and benefit himself and also give in charity (from what he earns)." The people further asked, "If he cannot find even that?" He replied, "He should help the needy who appeal for help." Then the people asked, "If he cannot do that?" He replied, "Then he should perform good deeds and keep away from evil deeds and this will be regarded as charitable deeds."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.525]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 525

Narrated Um 'Atiyya:

A sheep was sent to me (Nusaiba Al-Ansariya) (in charity) and I sent some of it to 'Aisha. The Prophet asked 'Aisha for something to eat. 'Aisha replied that there was nothing except what Nusaiba Al-Ansariya had sent of that sheep. The Prophet said to her, "Bring it as it has reached its place."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.526]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 526

Narrated Abu Sa'id Al-Khudri :

Allah's Apostle said, "There is no Zakat on less than five camels and also there is no Zakat on less than five Awaq (of silver). (5 Awaq = 22 Fransa Riyals of Yamen or 200 Dirhams.) And there is no Zakat on less than five Awsuq. (A special measure of food-grains, and one Wasq equals 60 Sa's.) (For gold 20, Dinars i.e. equal to 12 Guinea English. No Zakat for less than 12 Guinea (English) of gold or for silver less than 22 Fransa Riyals of Yamen.)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.527]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 527

Narrated Abi Sa'id Al-Khudri :

I heard the Prophet saying (as above--No. 526 ..)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.528]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 528

Narrated Anas:

Abu Bakr wrote to me what Allah had instructed His Apostle (p.b.u.h) to do regarding the one who had to pay one Bint Makhad (i.e. one year-old she-camel) as Zakat, and he did not have it but had got Bint Labun (two year old she-camel). (He wrote that) it could be accepted from him as Zakat, and the collector of Zakat would return him 20 Dirhams or two sheep; and if the Zakat payer had not a Bint Makhad, but he had Ibn Labun (a two year old he-camel) then it could be accepted as his Zakat, but he would not be paid anything .


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.529]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 529

Narrated Ibn Abbas :

I am a witness that Allah's Apostle offered the Id prayer before delivering the sermon and then he thought that the women would not be able to hear him (because of the distance), so he went to them along with Bilal who was spreading his garment. The Prophet advised and ordered them to give in charity. So the women started giving their ornaments (in charity). (The sub-narrator Aiyub pointed towards his ears and neck meaning that they gave ornaments from those places such as ear-rings and necklaces.)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.530]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 530

Narrated Anas:

Abu Bakr wrote to me what was made compulsory by Allah's Apostle and that was (regarding the payments of Zakat): Neither the property of different people may be taken together nor the joint property may be split for fear of (paying more, or receiving less) Zakat. (1)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.531]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 531

Narrated Anas:

Abu Bakr wrote to me what Allah's Apostle has made compulsory (regarding Zakat) and this was mentioned in it: If a property is equally owned by two partners, they should pay the combined Zakat and it will be considered that both of them have paid their Zakat equally.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.532]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 532

Narrated Abu Said Al-Khudri:

A Bedouin asked Allah's Apostle about the emigration. The Prophet (p.b.u.h) said, "May Allah have mercy on you! The matter of emigration is very hard. Have you got camels? Do you pay their Zakat?" The Bedouin said, "Yes, I have camels and I pay their Zakat." The Prophet said, Work beyond the seas and Allah will not decrease (waste) any of your good deeds." (See Hadith No. 260 Vol. 5).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.533]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 533

Narrated Anas:

Abu Bakr , wrote to me about the Zakat which Allah had ordered His Apostle to observe: Whoever had to pay Jahda (Jahda means a four-year-old she-camel) as Zakat from his herd of camels and he had not got one, and he had Hiqqa (three-year-old she-camel), that Hiqqa should be accepted from him along with two sheep if they were available or twenty Dirhams (one Durham equals about 1/4 Saudi Riyal) and whoever had to pay Hiqqa as Zakat and he had no Hiqqa but had a Jadha, the Jadha should be accepted from him, and the Zakat collector should repay him twenty Dirhams or two sheep; and whoever had to pay Hiqqa as Zakat and he had not got one, but had a Bint Labun (two-year-old she-camel), it should be accepted from him along with two sheep or twenty Dirhams; and whoever had to pay Bint Labun and had a Hiqqa, that Hiqqa should be accepted from him and the Zakat collector should repay him twenty Dirhams or two sheep; and whoever had to pay Bint Labun and he had not got one but had a Bint Makhad (one-year-old she camel), that Bint Makhad should be accepted from him along with twenty Dirhams or two sheep.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.534]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 534

Narrated Anas:

When Abu Bakr; sent me to (collect the Zakat from) Bahrein, he wrote to me the following:-- (In the name of Allah, the Beneficent, the Merciful). These are the orders for compulsory charity (Zakat) which Allah's Apostle had made obligatory for every Muslim, and which Allah had ordered His Apostle to observe: Whoever amongst the Muslims is asked to pay Zakat accordingly, he should pay it (to the Zakat collector) and whoever is asked more than that (what is specified in this script) he should not pay it; for twenty-four camels or less, sheep are to be paid as Zakat; for every five camels one sheep is to be paid, and if there are between twenty-five to thirty-five camels, one Bint Makhad is to be paid; and if they are between thirty-six to forty-five (camels), one Bint Labun is to be paid; and if they are between forty-six to sixty (camels), one Hiqqa is to be paid; and if the number is between sixty-one to seventy-five (camels), one Jadh'a is to be paid; and if the number is between seventy-six to ninety (camels), two Bint Labuns are to be paid; and if they are from ninety-one to one-hundred-and twenty (camels), two Hiqqas are to be paid; and if they are over one-hundred and-twenty (camels), for every forty (over one-hundred-and-twenty) one Bint Labun is to be paid, and for every fifty camels (over one-hundred-and-twenty) one Hiqqa is to be paid; and who ever has got only four camels, has to pay nothing as Zakat, but if the owner of these four camels wants to give something, he can. If the number of camels increases to five, the owner has to pay one sheep as Zakat. As regards the Zakat for the (flock) of sheep; if they are between forty and one-hundred-and-twenty sheep, one sheep is to be paid; and if they are between one-hundred-and-twenty to two hundred (sheep), two sheep are to be paid; and if they are between two-hundred to three-hundred (sheep), three sheep are to be paid; and for over three-hundred sheep, for every extra hundred sheep, one sheep is to be paid as Zakat. And if somebody has got less than forty sheep, no Zakat is required, but if he wants to give, he can. For silver the Zakat is one-fortieth of the lot (i.e. 2.5%), and if its value is less than two-hundred Dirhams, Zakat is not required, but if the owner wants to pay he can.'


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.535]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 535

Narrated Anas:

Abu Bakr wrote to me what Allah had ordered His Apostle (about Zakat) which goes: Neither an old nor a defected animal, nor a male-goat may be taken as Zakat except if the Zakat collector wishes (to take it).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.536]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 536

Narrated Abu Huraira:

Abu Bakr said, "By Allah! If they (pay me the Zakat and) with-hold even a she-kid which they used to pay during the life-time of Allah's Apostle, I will fight with them for it." 'Umar said, "It was nothing but Allah Who opened Abu Bakr's chest towards the decision to fight, and I came to know that his decision was right."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.537]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 537

Narrated Ibn Abbas:

When Allah's Apostle (p.b.u.h) sent Muadh to Yemen, he said (to him), "YOU are going to people of a (Divine) Book. First of all invite them to worship Allah (alone) and when they come to know Allah, inform them that Allah has enjoined on them, five prayers in every day and night; and if they start offering these prayers, inform them that Allah has enjoined on them, the Zakat. And it is to be taken from the rich amongst them and given to the poor amongst them; and if they obey you in that, take Zakat from them and avoid (don't take) the best property of the people as Zakat."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.538]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 538

Narrated Abu Said Al-Khudri :

Allah's Apostle said, "No Zakat is imposed on less than five Awsuq of dates; no Zakat is imposed on less than five Awaq of silver, and no Zakat is imposed on less than five camels."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.539]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 539

Narrated Abu Dhar:

Once I went to him (the Prophet ) and he said, "By Allah in Whose Hands my life is (or probably said, 'By Allah, except Whom none has the right to be worshipped) whoever had camels or cows or sheep and did not pay their Zakat, those animals will be brought on the Day of Resurrection far bigger and fatter than before and they will tread him under their hooves, and will butt him with their horns, and (those animals will come in circle): When the last does its turn, the first will start again, and this punishment will go on till Allah has finished the judgments amongst the people."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.540]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 540

Narrated Ishaq bin 'Abdullah bin Al Talha:

I heard Anas bin Malik saying, "Abu Talha had more property of date-palm trees gardens than any other amongst the Ansar in Medina and the most beloved of them to him was Bairuha garden, and it was in front of the Mosque of the Prophet . Allah's Apostle used to go there and used to drink its nice water." Anas added, "When these verses were revealed:--'By no means shall you Attain righteousness unless You spend (in charity) of that Which you love. ' (3.92) Abu Talha said to Allah's Apostle 'O Allah's Apostle! Allah, the Blessed, the Superior says: By no means shall you attain righteousness, unless you spend (in charity) of that which you love. And no doubt, Bairuha' garden is the most beloved of all my property to me. So I want to give it in charity in Allah's Cause. I expect its reward from Allah. O Allah's Apostle! Spend it where Allah makes you think it feasible.' On that Allah's Apostle said, 'Bravo! It is useful property. I have heard what you have said (O Abu Talha), and I think it would be proper if you gave it to your Kith and kin.' Abu Talha said, I will do so, O Allah's Apostle.' Then Abu Talha distributed that garden amongst his relatives and his cousins."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.541]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 541

Narrated Abu Said Al-Khudri

On 'Id ul Fitr or 'Id ul Adha Allah's Apostle (p.b.u.h) went out to the Musalla. After finishing the prayer, he delivered the sermon and ordered the people to give alms. He said, "O people! Give alms." Then he went towards the women and said. "O women! Give alms, for I have seen that the majority of the dwellers of Hell-Fire were you (women)." The women asked, "O Allah's Apostle! What is the reason for it?" He replied, "O women! You curse frequently, and are ungrateful to your husbands. I have not seen anyone more deficient in intelligence and religion than you. O women, some of you can lead a cautious wise man astray." Then he left. And when he reached his house, Zainab, the wife of Ibn Masud, came and asked permission to enter It was said, "O Allah's Apostle! It is Zainab." He asked, 'Which Zainab?" The reply was that she was the wife of Ibn Mas'ub. He said, "Yes, allow her to enter." And she was admitted. Then she said, "O Prophet of Allah! Today you ordered people to give alms and I had an ornament and intended to give it as alms, but Ibn Masud said that he and his children deserved it more than anybody else." The Prophet replied, "Ibn Masud had spoken the truth. Your husband and your children had more right to it than anybody else."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.542]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 542

Narrated Abu Huraira:

Allah's Apostle said, "There is no Zakat either on a horse or a slave belonging to a Muslim"


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.543]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 543

Narrated Abu Huraira :-

The Prophet said,"There is no Zakat either on a slave or on a horse belonging to a Muslim.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.544]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 544

Narrated Abu Said Al-Khudri :

Once the Prophet sat on a pulpit and we sat around him. Then he said, "The things I am afraid of most for your sake (concerning what will befall you after me) is the pleasures and splendors of the world and its beauties which will be disclosed to you." Somebody said, "O Allah's Apostle! Can the good bring forth evil?" The Prophet remained silent for a while. It was said to that person, "What is wrong with you? You are talking to the Prophet (p.b.u.h) while he is not talking to you." Then we noticed that he was being inspired divinely. Then the Prophet wiped off his sweat and said, "Where is the questioner?" It seemed as if the Prophet liked his question. Then he said, "Good never brings forth evil. Indeed it is like what grows on the banks of a water-stream which either kill or make the animals sick, except if an animal eats its fill the Khadira (a kind of vegetable) and then faces the sun, and then defecates and urinates and grazes again. No doubt this wealth is sweet and green. Blessed is the wealth of a Muslim from which he gives to the poor, the orphans and to needy travelers. (Or the Prophet said something similar to it) No doubt, whoever takes it illegally will be like the one who eats but is never satisfied, and his wealth will be a witness against him on the Day of Resurrection."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.545]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 545

Narrated 'Amr bin Al-Harith:

Zainab, the wife of 'Abdullah said, "I was in the Mosque and saw the Prophet (p.b.u.h) saying, 'O women ! Give alms even from your ornaments.' " Zainab used to provide for 'Abdullah and those orphans who were under her protection. So she said to 'Abdullah, "Will you ask Allah's Apostle whether it will be sufficient for me to spend part of the Zakat on you and the orphans who are under my protection?" He replied "Will you yourself ask Allah's Apostle ?" (Zainab added): So I went to the Prophet and I saw there an Ansari woman who was standing at the door (of the Prophet ) with a similar problem as mine. Bilal passed by us and we asked him, 'Ask the Prophet whether it is permissible for me to spend (the Zakat) on my husband and the orphans under my protection.' And we requested Bilal not to inform the Prophet about us. So Bilal went inside and asked the Prophet regarding our problem. The Prophet (p.b.u.h) asked, "Who are those two?" Bilal replied that she was Zainab. The Prophet said, "Which Zainab?" Bilal said, "The wife of 'Adullah (bin Masud)." The Prophet said, "Yes, (it is sufficient for her) and she will receive a double rewards (for that): One for helping relatives, and the other for giving Zakat."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.546]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 546

Narrated Zainab,:

(the daughter of Um Salama) My mother said, "O Allah's Apostle! Shall I receive a reward if I spend for the sustenance of Abu Salama's offspring, and in fact they are also my sons?" The Prophet replied, "Spend on them and you will get a reward for what you spend on them."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.547]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 547

Narrated Abu Huraira

Allah's Apostle (p.b.u.h) ordered (a person) to collect Zakat, and that person returned and told him that Ibn Jamil, Khalid bin Al-Walid, and Abbas bin 'Abdul Muttalib had refused to give Zakat." The Prophet said, "What made Ibn Jamll refuse to give Zakat though he was a poor man, and was made wealthy by Allah and His Apostle ? But you are unfair in asking Zakat from Khalid as he is keeping his armor for Allah's Cause (for Jihad). As for Abbas bin 'Abdul Muttalib, he is the uncle of Allah's Apostle (p.b.u.h) and Zakat is compulsory on him and he should pay it double."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.548]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 548

Narrated Abu Said Al-Khudri:

Some Ansari persons asked for (something) from Allah's Apostle (p.b.u.h) and he gave them. They again asked him for (something) and he again gave them. And then they asked him and he gave them again till all that was with him finished. And then he said "If I had anything. I would not keep it away from you. (Remember) Whoever abstains from asking others, Allah will make him contented, and whoever tries to make himself self-sufficient, Allah will make him self-sufficient. And whoever remains patient, Allah will make him patient. Nobody can be given a blessing better and greater than patience."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.549]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 549

Narrated Abu Huraira :

Allah's Apostle said, "By Him in Whose Hand my life is, it is better for anyone of you to take a rope and cut the wood (from the forest) and carry it over his back and sell it (as a means of earning his living) rather than to ask a person for something and that person may give him or not."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.550]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 550

Narrated Az-Zubair bin Al'Awwam:

The Prophet (p.b.u.h) said, "It is better for anyone of you to take a rope (and cut) and bring a bundle of wood (from the forest) over his back and sell it and Allah will save his face (from the Hell-Fire) because of that, rather than to ask the people who may give him or not."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.551]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 551

Narrated 'Urwa bin Az-Zubair and Said bin Al-Musaiyab:

Haklm bin Hizam said, "(Once) I asked Allah's Apostle (for something) and he gave it to me. Again I asked and he gave (it to me). Again I asked and he gave (it to me). And then he said, "O Hakim! This property is like a sweet fresh fruit; whoever takes it without greediness, he is blessed in it, and whoever takes it with greediness, he is not blessed in it, and he is like a person who eats but is never satisfied; and the upper (giving) hand is better than the lower (receiving) hand." Hakim added, "I said to Allah's Apostle , 'By Him (Allah) Who sent you with the Truth, I shall never accept anything from anybody after you, till I leave this world.' " Then Abu Bakr (during his caliphate) called Hakim to give him his share from the war booty (like the other companions of the Prophet ), he refused to accept anything. Then 'Umar (during his caliphate) called him to give him his share but he refused. On that 'Umar said, "O Muslims! I would like you to witness that I offered Hakim his share from this booty and he refused to take it." So Hakim never took anything from anybody after the Prophet till he died.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.552]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 552

Narrated 'Umar:

Allah's Apostle used to give me something but I would say to him, "would you give it to a poorer and more needy one than l?" The Prophet (p.b.u.h) said to me, "Take it. If you are given something from this property, without asking for it or having greed for it take it; and if not given, do not run for it."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.553]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 553

Narrated 'Abdullah bin 'Umar

The Prophet said, "A man keeps on asking others for something till he comes on the Day of Resurrection without any piece of flesh on his face." The Prophet added, "On the Day of Resurrection, the Sun will come near (to, the people) to such an extent that the sweat will reach up to the middle of the ears, so, when all the people are in that state, they will ask Adam for help, and then Moses, and then Muhammad (p.b.u.h) ." The sub-narrator added "Muhammad will intercede with Allah to judge amongst the people. He will proceed on till he will hold the ring of the door (of Paradise) and then Allah will exalt him to Maqam Mahmud (the privilege of intercession, etc.). And all the people of the gathering will send their praises to Allah.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.554]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 554

Narrated Abu Huraira:

The Prophet said, "The poor person is not the one who asks a morsel or two (of meals) from the others, but the poor is the one who has nothing and is ashamed to beg from others."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.555]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 555

Narrated Ash-sha'bi:

The clerk of Al-Mughira bin Shu'ba narrated, "Muawiya wrote to Al-Mughira bin Shu'ba: Write to me something which you have heard from the Prophet (p.b.u.h) ." So Al-Mughira wrote: I heard the Prophet saying, "Allah has hated for you three things:

1. Vain talks, (useless talk) that you talk too much or about others.

2. Wasting of wealth (by extravagance)

3. And asking too many questions (in disputed religious matters) or asking others for something (except in great need). (See Hadith No. 591, Vol. Ill)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.556]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 556

Narrated Sad (bin Abi Waqqas) :

Allah's Apostle distributed something (from the resources of Zakat) amongst a group of people while I was sitting amongst them, but he left a man whom I considered the best of the lot. So, I went up to Allah's Apostle and asked him secretly, "Why have you left that person? By Allah! I consider him a believer." The Prophet said, "Or merely a Muslim (Who surrender to Allah)." I remained quiet for a while but could not help repeating my question because of what I knew about him. I said, "O Allah's Apostle! Why have you left that person? By Allah! I consider him a believer. " The Prophet said, "Or merely a Muslim." I remained quiet for a while but could not help repeating my question because of what I knew about him. I said, "O Allah's Apostle! Why have you left that person? By Allah! I consider him a believer." The Prophet said, "Or merely a Muslim." Then Allah's Apostle (p.b.u.h) said, "I give to a person while another is dearer to me, for fear that he may be thrown in the Hell-fire on his face (by renegating from Islam)."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.557]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 557

Narrated Abu Huraira

Allah's Apostle said, "The poor person is not the one who goes round the people and ask them for a mouthful or two (of meals) or a date or two but the poor is that who has not enough (money) to satisfy his needs and whose condition is not known to others, that others may give him something in charity, and who does not beg of people."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.558]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 558

Narrated Abu Huraira

The Prophet said, "No doubt, it is better for a person to take a rope and proceed in the morning to the mountains and cut the wood and then sell it, and eat from this income and give alms from it than to ask others for something."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.559]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 559

Narrated Abu Humaid As-Sa'idi

We took part in the holy battle of Tabuk in the company of the Prophet and when we arrived at the Wadi-al-Qura, there was a woman in her garden. The Prophet asked his companions to estimate the amount of the fruits in the garden, and Allah's Apostle estimated it at ten Awsuq (One Wasaq = 60 Sa's) and 1 Sa'= 3 kg. approximately). The Prophet said to that lady, "Check what your garden will yield." When we reached Tabuk, the Prophet said, "There will be a strong wind to-night and so no one should stand and whoever has a camel, should fasten it." So we fastened our camels. A strong wind blew at night and a man stood up and he was blown away to a mountain called Taiy, The King of Aila sent a white mule and a sheet for wearing to the Prophet as a present, and wrote to the Prophet that his people would stay in their place (and will pay Jizya taxation.) (1) When the Prophet reached Wadi-al-Qura he asked that woman how much her garden had yielded. She said, "Ten Awsuq," and that was what Allah's Apostle had estimated. Then the Prophet said, "I want to reach Medina quickly, and whoever among you wants to accompany me, should hurry up." The sub-narrator Ibn Bakkar said something which meant: When the Prophet (p.b.u.h) saw Medina he said, "This is Taba." And when he saw the mountain of Uhud, he said, "This mountain loves us and we love it. Shall I tell you of the best amongst the Ansar?" They replied in the affirmative. He said, "The family of Bani-n-Najjar, and then the family of Bani Sa'ida or Bani Al-Harith bin Al-Khazraj. (The above-mentioned are the best) but there is goodness in all the families of Ansar."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.560]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 560

Narrated Salim bin 'Abdullah from his father:

The Prophet said, "On a land irrigated by rain water or by natural water channels or if the land is wet due to a near by water channel Ushr (i.e. one-tenth) is compulsory (as Zakat); and on the land irrigated by the well, half of an Ushr (i.e. one-twentieth) is compulsory (as Zakat on the yield of the land)."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.561]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 561

Narrated Abu Said Al-Khudri :

The Prophet said, "There is no Zakat on less than five Awsuq (of dates), or on less than five camels, or on less than five Awaq of silver." (22 Yameni Riyals Faransa).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.562]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 562

Narrated Abu Huraira :

Dates used to be brought to Allah's Apostle immediately after being plucked. Different persons would bring their dates till a big heap collected (in front of the Prophet). Once Al-Hasan and Al-Husain were playing with these dates. One of them took a date and put it in his mouth. Allah's Apostle looked at him and took it out from his mouth and said, "Don't you know that Muhammad's offspring do not eat what is given in charity?"


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.563]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 563

Narrated Ibn 'Umar:

The Prophet had forbidden the sale of dates till they were good (ripe), and when it was asked what it meant, the Prophet said, "Till there is no danger of blight."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.564]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 564

Narrated Jabir bin 'Abdullah :

The Prophet had forbidden the sale of fruits till they were ripe (free from blight).


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.565]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 565

Narrated Anas bin Malik:

Allah's Apostle forbade the selling of fruits until they were ripe. The Prophet (p.b.u.h) added, "It means that they become red ."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.566]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 566

Narrated 'Abdullah bin 'Umar:

Umar bin Al-Khattab gave a horse in charity in Allah's Cause and later he saw it being sold in the market and intended to purchase it. Then he went to the Prophet and asked his permission. The Prophet said, "Do not take back what you have given in charity." For this reason, Ibn 'Umar never purchased the things which he had given in charity, and in case he had purchased something (unknowingly) he would give it in charity again.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.567]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 567

Narrated 'Umar:

Once I gave a horse in Allah's Cause (in charity) but that person did not take care of it. I intended to buy it, as I thought he would sell it at a low price. So, I asked the Prophet (p.b.u.h) about it. He said, "Neither buy, nor take back your alms which you have given, even if the seller were willing to sell it for one Dirham, for he who takes back his alms is like the one who swallows his own vomit."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.568]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 568

Narrated Abu Huraira :

Al-Hasan bin 'Ali took a date from the dates given in charity and put it in his mouth. The Prophet said, "Expel it from your mouth. Don't you know that we do not eat a thing which is given in charity?"


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.569]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 569

Narrated Ibn Abbas :

The Prophet saw a dead sheep which had been given in charity to a freed slavegirl of Maimuna, the wife of the Prophet . The Prophet said, "Why don't you get the benefit of its hide?" They said, "It is dead." He replied, "Only to eat (its meat) is illegal."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.570]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 570

Narrated Al-Aswad:

'Aisha intended to buy Barira (a slave-girl) in order to manumit her and her masters intended to put the condition that her Al-wala would be for them. 'Aisha mentioned that to the Prophet who said to her, "Buy her, as the "Wala" is for the manumitted." Once some meat was presented to the Prophet and 'Aisha said to him, "This (meat) was given in charity to Barira." He said, "It is an object of charity for Barira but a gift for us."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.571]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 571

Narrated Um 'Atiyya Al-Ansariya :

The Prophet went to 'Aisha and asked her whether she had something (to eat). She replied that she had nothing except the mutton (piece) which Nusaiba (Um 'Atiyya) had sent to us (Buraira) in charity." The Prophet said, "It has reached its place and now it is not a thing of charity but a gift for us."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.572]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 572

Narrated Anas:

Some meat was presented to the Prophet (p.b.u.h) and it had been given to Barira (the freed slave-girl of Aisha) in charity. He said, "This meat is a thing of charity for Barira but it is a gift for us."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.573]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 573

Narrated Abu Ma'bad,:

(the slave of Ibn Abbas) Allah's Apostle said to Muadh when he sent him to Yemen, "You will go to the people of the Scripture. So, when you reach there, invite them to testify that none has the right to be worshipped but Allah, and that Muhammad is His Apostle. And if they obey you in that, tell them that Allah has enjoined on them five prayers in each day and night. And if they obey you in that tell them that Allah has made it obligatory on them to pay the Zakat which will be taken from the rich among them and given to the poor among them. If they obey you in that, then avoid taking the best of their possessions, and be afraid of the curse of an oppressed person because there is no screen between his invocation and Allah."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.574]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 574

Narrated Abu Huraira

The Prophet said, "A man from Bani Israel asked someone from Bani Israel to give him a loan of one thousand Dinars and the later gave it to him. The debtor went on a voyage (when the time for the payment of the debt became due) but he did not find a boat, so he took a piece of wood and bored it and put 1000 diners in it and threw it into the sea. The creditor went out and took the piece of wood to his family to be used as fire-wood." (See Hadith No. 488 B, Vol. 3). And the Prophet narrated the narration (and said), "When he sawed the wood, he found his money."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.575]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 575

Narrated Abu Huraira

Allah's Apostle said, "There is no compensation for one killed or wounded by an animal or by falling in a well, or because of working in mines; but Khumus is compulsory on Rikaz."


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.576]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 576

Narrated Abu Humaid Al-Sa'idi:

Allah's Apostle (p.b.u.h) appointed a man called Ibn Al-Lutbiya, from the tribe of Al-Asd to collect Zakat from Bani Sulaim. When he returned, (after collecting the Zakat) the Prophet checked the account with him.


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.577]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 577

Narrated Anas:

Some people from 'Uraina tribe came to Medina and its climate did not suit them, so Allah's Apostle (p.b.u.h) allowed them to go to the herd of camels (given as Zakat) and they drank their milk and urine (as medicine) but they killed the shepherd and drove away all the camels. So Allah's Apostle sent (men) in their pursuit to catch them, and they were brought, and he had their hands and feet cut, and their eyes were branded with heated pieces of iron and they were left in the Harra (a stony place at Medina) biting the stones. (See Hadith No. 234, Vol. 1)


Bukhari :: Obligatory Charity Tax (Zakat) :: [2.24.578]

Obligatory Charity Tax (Zakat)

Bukhari :: Book 2 :: Volume 24 :: Hadith 578

Narrated Anas bin Malik

took 'Abdullah bin Abu Talha to Allah's Apostle to perform Tahnik for him. (Tahnik was a custom among the Muslims that whenever a child was born they used to take it to the Prophet who would chew a piece of date and put a part of its juice in the child's mouth). I saw the Prophet and he had an instrument for branding in his hands and was branding the camels of Zakat.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.579]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 579

Narrated Ibn Umar:

Allah's Apostle enjoined the payment of one Sa' of dates or one Sa' of barley as Zakat-ul-Fitr on every Muslim slave or free, male or female, young or old, and he ordered that it be paid before the people went out to offer the 'Id prayer. (One Sa' = 3 Kilograms approx.)


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.580]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 580

Narrated Ibn 'Umar:

Allah's Apostle made it incumbent on all the slave or free Muslims, male or female, to pay one Sa' of dates or barley as Zakat-ul-Fitr.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.581]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 581

Narrated Abu Said:

We used to give one Sa' of barley as Sadaqatul-Fitr (per head).


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.582]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 582

Narrated Abu Said Al-Khudri:

We used to give one Sa' of meal or one Sa' of barley or one Sa' of dates, or one Sa' of cottage cheese or one Sa' of Raisins (dried grapes) as Zakat-ul-Fitr.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.583]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 583

Narrated 'Abdullah bin 'Umar

The Prophet ordered (Muslims) to give one Sa' of dates or one Sa' of barley as Zakat-ul-Fitr. The people rewarded two Mudds of wheat as equal to that.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.584]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 584

Narrated Abu Sa'id Al-Khudri:

In the life-time of the Prophet we used to give one Sa' of food or one Sa' of dates or one Sa' of barley or one Sa' of Raisins (dried grapes) as Sadaqat-ul-Fitr. And when Muawiya became the Caliph and the wheat was (available in abundance) he said, "I think (observe) that one Mudd (of wheat) equals two Mudds (of any of the above mentioned things).


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.585]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 585

Narrated Ibn 'Umar:

The Prophet ordered the people to pay Zakat-ul-Fitr before going to the 'Id prayer.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.586]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 586

Narrated Abu Said Al-Khudri:

In the life-time of Allah's Apostle , we used to give one Sa' of food (edible things) as Sadaqat-ul-Fit,r (to the poor). Our food used to be either of barley, raisins (dried grapes), cottage cheese or dates.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.587]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 587

Narrated Nafi':

Ibn 'Umar said, "The Prophet made incumbent on every male or female, free man or slave, the payment of one Sa' of dates or barley as Sadaqat-ul-Fitr (or said Sadaqa-Ramadan)." The people then substituted half Sa' of wheat for that. Ibn 'Umar used to give dates (as Sadaqat-ulFitr). Once there was scarcity of dates in Medina and Ibn 'Umar gave barley. 'And Ibn 'Umar used to give Sadaqat-ul-Fitr for every young and old person. He even used to give on behalf of my children. Ibn 'Umar used to give Sadaqatul-Fitr to those who had been officially appointed for its collection. People used to give Sadaqat-ul-Fitr (even) a day or two before the 'Id.


Bukhari :: Obligatory Charity Tax After Ramadaan (Zakat ul Fitr) :: [2.25.588]

Obligatory Charity Tax After Ramadaan (Zakat ul Fitr)

Bukhari :: Book 2 :: Volume 25 :: Hadith 588

Narrated Ibn 'Umar:

Allah's Apostle has made Sadaqatul-Fitr obligatory, (and it was), either one Sa' of barley or one Sa' of dates (and its payment was obligatory) on young and old people, and on free men as well as on slaves.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.589]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 589

Narrated 'Abdullah bin Abbas :

Al-Fadl (his brother) was riding behind Allah's Apostle and a woman from the tribe of Khath'am came and Al-Fadl started looking at her and she started looking at him. The Prophet turned Al-Fadl's face to the other side. The woman said, "O Allah's Apostle! The obligation of Hajj enjoined by Allah on His devotees has become due on my father and he is old and weak, and he cannot sit firm on the Mount; may I perform Hajj on his behalf?" The Prophet replied, "Yes, you may." That happened during the Hajj-al-Wida (of the Prophet ).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.590]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 590

Narrated Ibn 'Umar:

I saw that Allah's Apostle used to ride on his Mount at Dhul Hulaifa and used to start saying, "Labbaik" when the Mount stood upright.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.591]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 591

Narrated Jabir bin 'Abdullah :

that Allah's Apostle started saying, "Labbaik" from Dhul-Hulaifa when his Mount stood upright carrying him .


Bukhari :: Pilgrimmage (Hajj) :: [2.26.592]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 592

Narrated Thumama bin 'Abdullah bin Anas:

Anas performed the Hajj on a pack-saddle and he was not a miser. Anas said, "Allah's Apostle

performed Hajj on a pack-saddle and the same Mount was carrying his baggage too."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.593]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 593

Narrated Al-Qasim bin Muhammad:

'Aisha said, "O Allah's Apostle! You performed 'Umra but I did not." He said, "O 'Abdur-Rahman! Go along with your sister and let her perform 'Umra from Tan'im." 'Abdur-Rahman made her ride over the pack-saddle of a she-camel and she performed 'Umra.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.594]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 594

Narrated Abu Huraira:

The Prophet was asked, "Which is the best deed?" He said, "To believe in Allah and His Apostle." He was then asked, "Which is the next (in goodness)?" He said, "To participate in Jihad in Allah's Cause." He was then asked, "Which is the next?" He said, "To perform Hajj-Mabrur. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.595]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 595

Narrated 'Aisha:

(the mother of the faithful believers) I said, "O Allah's Apostle! We consider Jihad as the best deed." The Prophet said, "The best Jihad (for women) is Hajj Mabrur. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.596]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 596

Narrated Abu Huraira:

The Prophet (p.b.u.h) said, "Whoever performs Hajj for Allah's pleasure and does not have sexual relations with his wife, and does not do evil or sins then he will return (after Hajj free from all sins) as if he were born anew."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.597]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 597

Narrated Zaid bin Jubair:

I went to visit 'Abdullah bin 'Umar at his house which contained many tents made of cotton cloth and these were encircled with Suradik (part of the tent). I asked him from where, should one assume Ihram for Umra. He said, "Allah's Apostle had fixed as Miqat (singular of Mawaqit) Qarn for the people of Najd, Dhul-Hulaifa for the people of Medina, and Al-Juhfa for the people of Sham."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.598]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 598

Narrated Ibn Abbas:

The people of Yemen used to come for Hajj and used not to bring enough provisions with them and used to say that they depend on Allah. On their arrival in Medina they used to beg the people, and so Allah revealed, "And take a provision (with you) for the journey, but the best provision is the fear of Allah." (2.197).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.599]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 599

Narrated Ibn Abbas:

Allah's Apostle (p.b.u.h) made Dhul-Huiaifa as the Miqat for the people of Medina; Al-Juhfa for the people of Sham; Qarn-al-Manazil for the people of Najd; and Yalamlam for the people of Yemen; and these Mawaqit are for the people at those very places, and besides them for those who come thorough those places with the intention of performing Hajj and 'Umra; and whoever is living within these boundaries can assume lhram from the place he starts, and the people of Mecca can assume Ihram from Mecca.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.600]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 600

Narrated Nafi':

'Abdullah bin 'Umar said, "Allah's Apostle said, 'The people of Medina should assume lhram from Dhul-Hulaifa; the people of Sham from Al-Juhfa; and the people of Najd from Qarn." And 'Abdullah added, "I was informed that Allah's Apostle had said, 'The people of Yemen should assume Ihram from Yalamlam.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.601]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 601

Narrated Ibn Abbas :

Allah's Apostle had fixed Dhul Hulaifa as the Mlqat for the people of Medina; Al-Juhfa for the people of Sham; and Qarn Ul-Manazil for the people of Najd; and Yalamlam for the people of Yemen. So, these (above mentioned) are the Mawaqit for all those living at those places, and besides them for those who come through those places with the intention of performing Hajj and 'Umra and whoever lives within these places should assume Ihram from his dwelling place, and similarly the people of Mecca can assume lhram from Mecca.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.602]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 602

Narrated Salim from his father who said,:

"The Prophet had fixed the Mawaqit as follows: (No. 603)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.603]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 603

Narrated Salim bin 'Abdullah from his father:

I heard Allah's Apostle saying, "The Miqat for the people of Medina is Dhul-Hulaifa; for the people of Sham is Mahita; (i.e. Al-Juhfa); and for the people of Najd is Qarn. And said Ibn 'Umar, "They claim, but I did not hear personally, that the Prophet said, "The Miqat for the people of Yemen is Yalamlam."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.604]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 604

Narrated Ibn Abbas:

The Prophet fixed Dhul-Hulaifa as the Miqat for the people of Medina, Al-Juhfa, for the people of Sham, Yalamlam for the people of Yemen, and Qarn for the people of Najd. And these Mawaqlt are for those living at those very places, and besides them for those who come through those places with the intention of performing Hajj and Umra; and whoever is living inside these places can assume lhram from his own dwelling place, and the people of Mecca can assume lhram from Mecca.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.605]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 605

Narrated Ibn Abbas:

The Prophet (p.b.u.h) fixed Dhul-Hulaifa as the Miqat for the people of Medina, Al-Juhfa for the people of Sham, Qarn-ul-Manazil for the people of Najd, and Yalamlam for the people of Yemen; and these Mawaqit are for those living at those very places, and besides them for those whom come through them with the intention of performing Hajj and Umra; and whoever is living within these Mawaqit should assume lhram from where he starts, and the people of Mecca can assume Ihram from Mecca.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.606]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 606

Narrated Ibn Umar:

When these two towns (Basra and Kufa) were captured, the people went to 'Umar and said, "O the Chief of the faithful believers! The Prophet fixed Qarn as the Miqat for the people of Najd, it is beyond our way and it is difficult for us to pass through it." He said, "Take as your Miqat a place situated opposite to Qarn on your usual way. So, he fixed Dhatu-Irq (as their Miqat)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.607]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 607

Narrated Nafi :

'Abdullah bin 'Umar' said, "Allah's Apostle made his camel sit (i.e. he dismounted) at Al-Batha' in Dhul-Hulaifa and offered the prayer." 'Abdullah bin 'Umar used to do the same.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.608]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 608

Narrated Ibn 'Umar :

Allah's Apostle used to go (for Hajj) via Ash-Shajara way and return via Muarras way; and no doubt, whenever Allah's Apostle went to Mecca, he used to offer the prayer in the Mosque of Ash-Shajara; and on his return, he used to offer the prayer at Dhul-Hulaifa in the middle of the valley, and pass the night there till morning.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.609]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 609

Narrated 'Umar:

In the valley of Al-'Aqiq I heard Allah's Apostle saying, "To night a messenger came to me from my Lord and asked me to pray in this blessed valley and to assume Ihram for Hajj and 'Umra together. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.610]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 610

Narrated Musa bin 'Uqba:

Salim bin 'Abdullah's father said, "The Prophet said that while resting in the bottom of the valley at Mu'arras in Dhul-Hulaifa, he had been addressed in a dream: 'You are verily in a blessed valley.' " Salim made us to dismount from our camels at the place where 'Abdullah used to dismount, aiming at the place where Allah's Apostle had rested and it was below the Mosque situated in the middle of the valley in between them (the residence) and the road.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.611]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 611

Narrated Said bin Jubair:

Ibn 'Umar used to oil his hair. I told that to Ibrahim who said, "What do you think about this statement: Narrated Aswad from 'Aisha: As if I were now observing the glitter of the scent in the parting of the hair of the Prophet while he was Muhrim?"


Bukhari :: Pilgrimmage (Hajj) :: [2.26.612]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 612

Narrated 'Aisha:

(the wife of the Prophet (p.b.u.h) I used to scent Allah's Apostle when he wanted to assume Ihram and also on finishing Ihram before the Tawaf round the Ka'ba (Tawaf-al-ifada).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.613]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 613

Narrated Salim from his father:

I heard that Allah's Apostle assumed Ihram with his hair matted together.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.614]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 614

Narrated Salim bin 'Abdullah :

I heard my father saying, "Never did Allah's Apostle assume Ihram except at the Mosque, that is, at the Mosque of Dhul-Hulaifa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.615]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 615

Narrated 'Abdullah bin 'Umar:

A man asked, "O Allah's Apostle! What kind of clothes should a Muhrim wear?" Allah's Apostle replied, "He should not wear a shirt, a turban, trousers, a headcloak or leather socks except if he can find no slippers, he then may wear leather socks after cutting off what might cover the ankles. And he should not wear clothes which are scented with saffron or Wars (kinds of Perfumes) . "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.616]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 616

Narrated 'Ubaidullah bin 'Abdullah:

Ibn Abbas' said, "Usama rode behind Allah's Apostle from 'Arafat to Al-Muzdalifa; and then Al-Fadl rode behind Allah's Apostle from Al-Muzdalifa to Mina." Ibn Abbas added, "Both of them said, 'The Prophet kept on reciting Talbiya till he did the Rami of Jamrat-al-'Aqaba.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.617]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 617

Narrated 'Abdullah bin Abbas:

The Prophet with his companions started from Medina after combing and oiling his hair and putting on two sheets of lhram (upper body cover and waist cover). He did not forbid anyone to wear any kind of sheets except the ones colored with saffron because they may leave the scent on the skin. And so in the early morning, the Prophet mounted his Mount while in Dhul-Hulaifa and set out till they reached Baida', where he and his companions recited Talbiya, and then they did the ceremony of Taqlid (which means to put the colored garlands around the necks of the Budn (camels for sacrifice). And all that happened on the 25th of Dhul-Qa'da. And when he reached Mecca on the 4th of Dhul-Hijja he performed the Tawaf round the Ka'ba and performed the Tawaf between Safa and Marwa. And as he had a Badana and had garlanded it, he did not finish his Ihram. He proceeded towards the highest places of Mecca near Al-Hujun and he was assuming the Ihram for Hajj and did not go near the Ka'ba after he performed Tawaf (round it) till he returned from 'Arafat. Then he ordered his companions to perform the Tawaf round the Ka'ba and then the Tawaf of Safa and Marwa, and to cut short the hair of their heads and to finish their Ihram. And that was only for those people who had not garlanded Budn. Those who had their wives with them were permitted to contact them (have sexual intercourse), and similarly perfume and (ordinary) clothes were permissible for them.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.618]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 618

Narrated Anas bin Malik:

The Prophet offered four Rakat in Medina and then two Rakat at DhulI lulaifa and then passed the night at Dhul-Hulaifa till it was morning and when he mounted his Mount and it stood up, he started to recite Talbiya.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.619]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 619

Narrated Abu Qilaba:

Anas bin Malik said, "The Prophet offered four Rakat of the Zuhr prayer in Medina and two Rakat of 'Asr prayer at Dhul-Hulaifa." I think that the Prophet passed the night there till morning.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.620]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 620

Narrated Anas:

The Prophet offered four Rakat of the Zuhr prayer in Medina and two Rakat of the 'Asr prayer in Dhul-Hulaifa and I heard them (the companions of the Prophet) reciting Talbiya together loudly to the extent of shouting.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.621]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 621

Narrated 'Abdullah bin 'Umar :

The Talbiya of Allah's Apostle was : 'Labbaika Allahumma labbaik, Labbaika la sharika Laka labbaik, Inna-l-hamda wan-ni'mata Laka walmu Lk, La sharika Laka' (I respond to Your call O Allah, I respond to Your call, and I am obedient to Your orders, You have no partner, I respond to Your call All the praises and blessings are for You, All the sovereignty is for You, And You have no partners with you.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.622]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 622

Narrated 'Aisha:

I know how the Prophet used to say (Talbiya) and it was: 'Labbaika Allahumma Labbaik, Labbaika la sharika Laka labbaik, Inna-l-hamda wan-ni'mata Laka walmu Lk, La sharika Laka'.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.623]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 623

Narrated Anas bin Malik:

Allah's Apostle offered four Rakat of Zuhr prayer at Medina and we were in his company, and two Rakat of the Asr prayer at Dhul-Hulaifa and then passed the night there till it was dawn; then he rode, and when he reached Al-Baida', he praised and glorified Allah and said Takbir (i.e. Alhamdu-lillah and Subhanallah(1) and Allahu-Akbar). Then he and the people along with him recited Talbiya with the intention of performing Hajj and Umra. When we reached (Mecca) he ordered us to finish the lhram (after performing the Umra) (only those who had no Hadi (animal for sacrifice) with them were asked to do so) till the day of Tarwiya that is 8th Dhul-Hijja when they assumed Ihram for Hajj. The Prophet sacrificed many camels (slaughtering them) with his own hands while standing. While Allah's Apostle was in Medina he sacrificed two horned rams black and white in color in the Name of Allah."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.624]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 624

Narrated Ibn Umar:

The Prophet (p.b.u.h) recited Talbiya when he had mounted his Mount and was ready to set out.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.625]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 625

Narrated Nafi':

Whenever Ibn 'Umar intended to go to Mecca he used to oil himself with a sort of oil that had no pleasant smell, then he would go to the Mosque of Al-Hulaita and offer the prayer, and then ride. When he mounted well on his Mount and the Mount stood up straight, he would proclaim the intention of assuming Ihram, and he used to say that he had seen the Prophet doing the same.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.626]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 626

Narrated Mujahid:

I was in the company of Ibn Abbas and the people talked about Ad-Dajjal and said, "Ad-Dajjal will come with the word Kafir (non-believer) written in between his eyes." On that Ibn Abbas said, "I have not heard this from the Prophet but I heard him saying, 'As if I saw Moses just now entering the valley reciting Talbyia. ' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.627]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 627

Narrated Aisha:

(the wife of the Prophet (p.b.u.h) We set out with the Prophet in his last Hajj and we assumed Ihram for Umra. The Prophet then said, "Whoever has the Hadi with him should assume Ihram for Hajj along with 'Umra and should not finish the Ihram till he finishes both." I was menstruating when I reached Mecca, and so I neither did Tawaf round the Ka'ba nor Tawaf between Safa and Marwa. I complained about that to the Prophet on which he replied, "Undo and comb your head hair, and assume Ihram for Hajj (only) and leave the Umra." So, I did so. When we had performed the Hajj, the Prophet sent me with my brother 'Abdur-Rahman bin Abu Bakr to Tan'im. So I performed the 'Umra. The Prophet said to me, "This 'Umra is instead of your missed one." Those who had assumed Ihram for 'Umra (Hajj-atTamattu) performed Tawaf round the Ka'ba and between Safa and Marwa and then finished their Ihram. After returning from Mina, they performed another Tawaf (between Safa and Marwa). Those who had assumed Ihram for Hajj and 'Umra together (Hajj-al-Qiran) performed only one Tawaf (between Safa and Marwa).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.628]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 628

Narrated Ata:

Jabir said, "The Prophet ordered Ali to keep on assuming his Ihram." The narrator then informed about the narration of Suraqa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.629]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 629

Narrated Anas bin Malik:

Ali came to the Prophet (p.b.u.h) from Yemen (to Mecca). The Prophet asked Ali, "With what intention have you assumed Ihram?" Ali replied, "I have assumed Ihram with the same intention as that of the Prophet." The Prophet said, "If I had not the Hadi with me I would have finished the Ihram." Muhammad bin Bakr narrated extra from Ibn Juraij, "The Prophet said to Ali, "With what intention have you assumed the Ihram, O Ali?" He replied, "With the same (intention) as that of the Prophet." The Prophet said, "Have a Hadi and keep your Ihram as it is."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.630]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 630

Narrated Abu Musa:

The Prophet sent me to some people in Yemen and when I returned, I found him at Al-Batha. He asked me, "With what intention have you assumed Ihram (i.e. for Hajj or for Umra or for both?") I replied, "I have assumed Ihram with an intention like that of the Prophet." He asked, "Have you a Hadi with you?" I replied in the negative. He ordered me to perform Tawaf round the Ka'ba and between Safa and Marwa and then to finish my Ihram. I did so and went to a woman from my tribe who combed my hair or washed my head. Then, when Umar came (i.e. became Caliph) he said, "If we follow Allah's Book, it orders us to complete Hajj and Umra; as Allah says: "Perform the Hajj and Umra for Allah." (2.196). And if we follow the tradition of the Prophet who did not finish his Ihram till he sacrificed his Hadi."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.631]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 631

Narrated Al-Qasim bin Muhammad:

' Aisha said, "We set out with Allah's Apostles in the months of Hajj, and (in) the nights of Hajj, and at the time and places of Hajj and in a state of Hajj. We dismounted at Sarif (a village six miles from Mecca). The Prophet then addressed his companions and said, "Anyone who has not got the Hadi and likes to do Umra instead of Hajj may do so (i.e. Hajj-al-Tamattu) and anyone who has got the Hadi should not finish the Ihram after performing ' Umra). (i.e. Hajj-al-Qiran). Aisha added, "The companions of the Prophet obeyed the above (order) and some of them (i.e. who did not have Hadi) finished their Ihram after Umra." Allah's Apostle and some of his companions were resourceful and had the Hadi with them, they could not perform Umra (alone) (but had to perform both Hajj and Umra with one Ihram). Aisha added, "Allah's Apostle came to me and saw me weeping and said, "What makes you weep, O Hantah?" I replied, "I have heard your conversation with your companions and I cannot perform the Umra." He asked, "What is wrong with you?' I replied, ' I do not offer the prayers (i.e. I have my menses).' He said, ' It will not harm you for you are one of the daughters of Adam, and Allah has written for you (this state) as He has written it for them. Keep on with your intentions for Hajj and Allah may reward you that." Aisha further added, "Then we proceeded for Hajj till we reached Mina and I became clean from my menses. Then I went out from Mina and performed Tawaf round the Ka'ba." Aisha added, "I went along with the Prophet in his final departure (from Hajj) till he dismounted at Al-Muhassab (a valley outside Mecca), and we too, dismounted with him." He called ' Abdur-Rahman bin Abu Bakr and said to him, ' Take your sister outside the sanctuary of Mecca and let her assume Ihram for ' Umra, and when you had finished ' Umra, return to this place and I will wait for you both till you both return to me.' " ' Aisha added, ' ' So we went out of the sanctuary of Mecca and after finishing from the ' Umra and the Tawaf we returned to the Prophet at dawn. He said, 'Have you performed the ' Umra?' We replied in the affirmative. So he announced the departure amongst his companions and the people set out for the journey, and the Prophet: too left for Medina.''


Bukhari :: Pilgrimmage (Hajj) :: [2.26.632]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 632

Narrated Al-Aswad:

' Aisha said, We went out with the Prophet (from Medina) with the intention of performing Hajj only and when we reached Mecca we performed Tawaf round the Kaba and then the Prophet ordered those who had not driven the Hadi along with them to finish their Ihram. So the people who had not driven the Hadi along with them finished their Ihram. The Prophet's wives, too, had not driven the Hadi with them, so they too, finished their Ihram." 'Aisha added, "I got my menses and could not perform Tawaf round the Ka'ba." So when it was the night of Hasba (i.e. when we stopped at Al-Muhassab), I said, 'O Allah's Apostle! Everyone is returning after performing Hajj and 'Umra but I am returning after performing Hajj only.' He said, 'Didn't you perform Tawaf round the Ka'ba the night we reached Mecca?' I replied in the negative. He said, 'Go with your brother to Tan'im and assume the Ihram for'Umra, (and after performing it) come back to such and such a place.' On that Safiya said, 'I feel that I will detain you all.' The Prophet said, 'O 'Aqra Halqa! Didn't you perform Tawaf of the Ka'ba on the day of sacrifice? (i.e. Tawaf-al-ifada) Safiya replied in the affirmative. He said, (to Safiya). 'There is no harm for you to proceed on with us.' " 'Aisha added, "(after returning from 'Umra), the Prophet met me while he was ascending (from Mecca) and I was descending to it, or I was ascending and he was descending."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.633]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 633

Narrated 'Aisha:

We set out with Allah's Apostles (to Mecca) in the year of the Prophet's Last Hajj. Some of us had assumed Ihram for 'Umra only, some for both Hajj and 'Umra, and others for Hajj only. Allah's Apostle assumed Ihram for Hajj. So whoever had assumed Ihram for Hajj or for both Hajj and 'Umra did not finish the Ihram till the day of sacrifice. (See Hadith No. 631, 636, and 639).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.634]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 634

Narrated Marwan bin Al-Hakam:

I saw 'Uthman and 'Ali. 'Uthman used to forbid people to perform Hajj-at-Tamattu' and Hajj-al-Qiran (Hajj and 'Umra together), and when 'Ali saw (this act of 'Uthman), he assumed Ihram for Hajj and 'Umra together saying, "Lubbaik for 'Umra and Hajj," and said, "I will not leave the tradition of the Prophet on the saying of somebody."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.635]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 635

Narrated Ibn Abbas:

The people (of the Pre-lslamic Period) used to think that to perform 'Umra during the months of Hajj was one of the major sins on earth. And also used to consider the month of Safar as a forbidden (i.e. sacred) month and they used to say, "When the wounds of the camel's back heal up (after they return from Hajj) and the signs of those wounds vanish and the month of Safar passes away then (at that time) 'Umra is permissible for the one who wishes to perform it." In the morning of the 4th of Dhul-Hijja, the Prophet and his companions reached Mecca, assuming Ihram for Hajj and he ordered his companions to make their intentions of the Ihram for'Umra only (instead of Hajj) so they considered his order as something great and were puzzled, and said, "O Allah's Apostle! What kind (of finishing) of Ihram is allowed?" The Prophet replied, "Finish the Ihram completely like a non-Muhrim (you are allowed everything)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.636]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 636

Narrated Abu Musa:

came to the Prophet (from Yemen and was assuming Ihram for Hajj) and he ordered me to finish the Ihram (after performing the 'Umra).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.637]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 637

Narrated Ibn 'Umar:

Hafsa the wife of the Prophet said, "O Allah's Apostle! Why have the people finished their Ihram after performing 'Umra but you have not finished your Ihram after performing 'Umra?" He replied, "I have matted my hair and garlanded my Hadi. So I will not finish my Ihram till I have slaughtered (my Hadi). "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.638]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 638

Narrated Shu'ba:

Abu Jamra Nasr bin 'Imran Ad-Duba'i said, "I intended to perform Hajj-at-Tamattu' and the people advised me not to do so. I asked Ibn Abbas regarding it and he ordered me to perform Hajj-at-Tammatu'. Later I saw in a dream someone saying to me, 'Hajj-Mabrur (Hajj performed in accordance with the Prophet's tradition without committing sins and accepted by Allah) and an accepted 'Umra.' So I told that dream to Ibn Abbas. He said, 'This is the tradition of Abu-l-Qasim.' Then he said to me, 'Stay with me and I shall give you a portion of my property.' " I (Shu'ba) asked, "Why (did he invite you)?" He (Abu Jamra) said, "Because of the dream which I had seen."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.639]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 639

Narrated Abu Shihab:

I left for Mecca for Hajj-at-Tamattu' assuming Ihram for 'Umra. I reached Mecca three days before the day of Tarwiya (8th Dhul-Hijja). Some people of Mecca said to me, "Your Hajj will be like the Hajj performed by the people of Mecca (i.e. you will lose the superiority of assuming Ihram from the Miqat). So I went to 'Ata' asking him his view about it. He said, "Jabir bin 'Abdullah narrated to me, 'I performed Hajj with Allah's Apostle on the day when he drove camels with him. The people had assumed Ihram for Hajj-al-Ifrad. The Prophet ordered them to finish their Ihram after Tawaf round the Ka'ba, and between Safa and Marwa and to cut short their hair and then to stay there (in Mecca) as non-Muhrims till the day of Tarwiya (i.e. 8th of Dhul-Hijja) when they would assume Ihram for Hajj and they were ordered to make the Ihram with which they had come as for 'Umra only. They asked, 'How can we make it 'Umra (Tamattu') as we have intended to perform Hajj?' The Prophet said, 'Do what I have ordered you. Had I not brought the Hadi with me, I would have done the same, but I cannot finish my Ihram till the Hadi reaches its destination (i.e. is slaughtered).' So, they did (what he ordered them to do)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.640]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 640

Narrated Said bin Al-Musaiyab:

'Ali and 'Uthman differed regarding Hajj-at-Tamattu' while they were at 'Usfan (a familiar place near Mecca). 'Ali said, "I see you want to forbid people to do a thing that the Prophet did?" When 'Ali saw that, he assumed Ihram for both Hajj and 'Umra.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.641]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 641

Narrated Jabir bin 'Abdullah :

We came with Allah's Apostle (to Mecca) and we were saying: 'Labbaika Allahumma Labbaik' for Hajj. Allah's Apostle ordered us to perform 'Umra with that Ihram (instead of Hajj).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.642]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 642

Narrated 'Imran:

We performed Hajj-at-Tamattu' in the lifetime of Allah's Apostle and then the Quran was revealed (regarding Hajj-at-Tamattu') and somebody said what he wished (regarding Hajj-at-Tamattu') according his own opinion.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.643]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 643

Narrated Nafi:

On reaching the sanctuary of Mecca, Ibn 'Umar used to stop, reciting Talbiya and then he would pass the night at Dhi-Tuwa and then offer the Fajr prayer and take a bath. He used to say that the Prophet used to do the same.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.644]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 644

Narrated Nafi:

' Ibn 'Umar said, "The Prophet passed the night at Dhi-Tuwa till it was dawn and then he entered Mecca." Ibn 'Umar used to do the same.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.645]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 645

Narrated Ibn 'Umar:

Allah's Apostle used to enter Mecca from the high Thaniya and used to leave Mecca from the low Thaniya.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.646]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 646

Narrated Ibn 'Umar:

Allah's Apostle entered Mecca from Kada' from the highest Thaniya which is at Al-Batha' and used to leave Mecca from the low Thaniya.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.647]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 647

Narrated 'Aisha:

When the Prophet came to Mecca he entered from its higher side and left from its lower side.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.648]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 648

Narrated 'Aisha':

In the year of the conquest of Mecca, the Prophet entered Mecca from Kada' and left Mecca from Kuda, from the higher part of Mecca.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.649]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 649

Narrated 'Aisha:

In the year of the conquest of Mecca, the Prophet entered Mecca from Kada' at the higher place of Mecca. (Hisham, a sub-narrator said, " 'Urwa used to enter (Mecca) from both Kada' and Kuda and he often entered through Kada' which was nearer to his dwelling place.)"


Bukhari :: Pilgrimmage (Hajj) :: [2.26.650]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 650

Narrated Hisham:

'Urwa said, "The Prophet entered Mecca in the year of the conquest of Mecca from the side of Kada' which is at the higher part of Mecca." 'Urwa often entered from Kada' which was nearer of the two to his dwelling place.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.651]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 651

Narrated Hisham from his father :

In the year of the conquest of Mecca, the Prophet entered Mecca from the side of Kada. Urwa used to enter through both places and he often entered through Kada' which was nearer of the two to his dwelling place.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.652]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 652

Narrated Jabir bin 'Abdullah:

When the Ka'ba was built, the Prophet and Abbas went to bring stones (for its construction). Al Abbas said to the Prophet, "Take off your waist sheet and put it on your neck." (When the Prophet took it off) he fell on the ground with his eyes open towards the sky and said, "Give me my waist sheet." And he covered himself with it.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.653]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 653

Narrated 'Aisha:

(the wife of the Prophet) that Allah's Apostle said to her, "Do you know that when your people (Quraish) rebuilt the Ka'ba, they decreased it from its original foundation laid by Abraham?" I said, "O Allah's Apostle! Why don't you rebuild it on its original foundation laid by Abraham?" He replied, "Were it not for the fact that your people are close to the pre-lslamic Period of ignorance (i.e. they have recently become Muslims) I would have done so." The sub-narrator, 'Abdullah (bin 'Umar ) stated: 'Aisha 'must have heard this from Allah's Apostle for in my opinion Allah's Apostle had not placed his hand over the two corners of the Ka'ba opposite Al-Hijr only because the Ka'ba was not rebuilt on its original foundations laid by Abraham.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.654]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 654

Narrated 'Aisha:

I asked the Prophet whether the round wall (near Ka'ba) was part of the Ka'ba. The Prophet replied in the affirmative. I further said, "What is wrong with them, why have they not included it in the building of the Ka'ba?" He said, "Don't you see that your people (Quraish) ran short of money (so they could not include it inside the building of Ka'ba)?" I asked, "What about its gate? Why is it so high?" He replied, "Your people did this so as to admit into it whomever they liked and prevent whomever they liked. Were your people not close to the Pre-lslamic Period of ignorance (i.e. they have recently embraced Islam) and were I not afraid that they would dislike it, surely I would have included the (area of the) wall inside the building of the Ka'ba and I would have lowered its gate to the level of the ground."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.655]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 655

Narrated 'Aisha:

Allah's Apostle said to me, "Were your people not close to the Pre-lslamic period of ignorance, I would have demolished the Ka'ba and would have rebuilt it on its original foundations laid by Abraham (for Quraish had curtailed its building), and I would have built a back door (too)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.656]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 656

Narrated Yazid bin Ruman from 'Urwa:

'Aisha said that the Prophet said to her, "O Aisha! Were your nation not close to the Pre-lslamic Period of Ignorance, I would have had the Ka'ba demolished and would have included in it the portion which had been left, and would have made it at a level with the ground and would have made two doors for it, one towards the east and the other towards the west, and then by doing this it would have been built on the foundations laid by Abraham." That was what urged Ibn-Az-Zubair to demolish the Ka'ba. Jazz said, "I saw Ibn-Az-Zubair when he demolished and rebuilt the Ka'ba and included in it a portion of Al-Hijr (the unroofed portion of Ka'ba which is at present in the form of a compound towards the north-west of the Ka'ba). I saw the original foundations of Abraham which were of stones resembling the humps of camels." So Jarir asked Yazid, "Where was the place of those stones?" Jazz said, "I will just now show it to you." So Jarir accompanied Yazid and entered Al-Hijr, and Jazz pointed to a place and said, "Here it is." Jarir said, "It appeared to me about six cubits from Al-Hijr or so."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.657]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 657

Narrated Ibn Abbas:

On the Day of the Conquest of Mecca, Allah's Apostle said, "Allah has made this town a sanctuary. Its thorny bushes should not be cut, its game should not be chased, and its fallen things should not be picked up except by one who would announce it publicly."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.658]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 658

Narrated 'Usama bin Zaid:

I asked, "O Allah's Apostle! Where will you stay in Mecca? Will you stay in your house in Mecca?" He replied, "Has 'Aqil left any property or house?" Aqil along with Talib had inherited the property of Abu Talib. Jafar and Ali did not inherit anything as they were Muslims and the other two were non-believers. 'Umar bin Al-Khattab used to say, "A believer cannot inherit (anything from an) infidel." Ibn Shihab, (a sub-narrator) said, "They (Umar and others) derived the above verdict from Allah's Statement: "Verily! those who believed and Emigrated and strove with their life And property in Allah's Cause, And those who helped (the emigrants) And gave them their places to live in, These are (all) allies to one another." (8.72)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.659]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 659

Narrated Abu Huraira:

When Allah's Apostle intended to enter Mecca he said, "Our destination tomorrow, if Allah wished, will be Khaif Bani Kinana where (the pagans) had taken the oath of Kufr." (Against the Prophet i.e. to be loyal to heathenism by boycotting Bani Ha shim, the Prophets folk) (See Hadith No. 221 Vol. 5)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.660]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 660

Narrated Abu Huraira:

On the Day of Nahr at Mina, the Prophet said, "Tomorrow we shall stay at Khaif Bani Kinana where the pagans had taken the oath of Kufr (heathenism)." He meant (by that place) Al-Muhassab where the Quraish tribe and Bani Kinana concluded a contract against Bani Hashim and Bani 'Abdul-Muttalib or Bani Al-Muttalib that they would not intermarry with them or deal with them in business until they handed over the Prophet to them.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.661]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 661

Narrated Abu Huraira:

The Prophet;; said, "Dhus-Suwaiqa-tain (literally: One with two lean legs) from Ethiopia will demolish the Ka'ba."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.662]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 662

Narrated 'Aisha:

The people used to fast on 'Ashura (the tenth day of the month of Muharram) before the fasting of Ramadan was made obligatory. And on that day the Ka'ba used to be covered with a cover. When Allah made the fasting of the month of Ramadan compulsory, Allah's Apostle said, "Whoever wishes to fast (on the day of 'Ashura') may do so; and whoever wishes to leave it can do so."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.663]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 663

Narrated Abu Said Al-Khudri:

The Prophet said "The people will continue performing the Hajj and 'Umra to the Ka'ba even after the appearance of Gog and Magog."

Narrated Shu'ba extra:

The Hour (Day of Judgment) will not be established till the Hajj (to the Ka'ba) is abandoned.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.664]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 664

Narrated Abu Wail:

(One day) I sat along with Shaiba on the chair inside the Ka'ba. He (Shaiba) said, "No doubt, Umar sat at this place and said, 'I intended not to leave any yellow (i.e. gold) or white (i.e. silver) (inside the Ka'ba) undistributed.' I said (to 'Umar), 'But your two companions (i.e. The Prophet and Abu Bakr) did not do so.' 'Umar said, They are the two persons whom I always follow.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.665]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 665

Narrated Ibn Abbas:

The Prophet said, "As if I were looking at him, a black person with thin legs plucking the stones of the Ka'ba one after another. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.666]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 666

Narrated Abu Huraira:

Allah's Apostle said, "DhusSuwaiqatain (the thin legged man) from Ethiopia will demolish the Ka'ba."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.667]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 667

Narrated 'Abis bin Rabia:

'Umar came near the Black Stone and kissed it and said "No doubt, I know that you are a stone and can neither benefit anyone nor harm anyone. Had I not seen Allah's Apostle kissing you I would not have kissed you."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.668]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 668

Narrated Salim that his father said,

"Allah's Apostle, Usama bin Zaid, Bilal, and 'Uthman bin abu Talha entered the Ka'ba and then closed its door. When they opened the door I was the first person to enter (the Ka'ba). I met Bilal and asked him, "Did Allah's Apostle offer a prayer inside (the Ka'ba)?" Bilal replied in the affirmative and said, "(The Prophet offered the prayer) in between the two right pillars."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.669]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 669

Narrated Nafi':

Whenever Ibn 'Umar entered the Ka'ba he used to walk straight keeping the door at his back on entering, and used to proceed on till about three cubits from the wall in front of him, and then he would offer the prayer there aiming at the place where Allah's Apostle prayed, as Bilal had told him. There is no harm for any person to offer the prayer at any place inside the Ka'ba.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.670]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 670

Narrated Isma'li bin Abu Khalid:

'Abdullah bin Abu Aufa said, "Allah's Apostle performed the 'Umra. He performed Tawaf of the Ka'ba and offered two Rakat behind the Maqam (Abraham's place) and was accompanied by those who were screening him from the people." Somebody asked 'Abdullah, "Did Allah's Apostle enter the Ka'ba?" 'Abdullah replied in the negative.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.671]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 671

Narrated Ibn Abbas:

When Allah's Apostle came to Mecca, he refused to enter the Ka'ba with idols in it. He ordered (idols to be taken out). So they were taken out. The people took out the pictures of Abraham and Ishmael holding Azlams in their hands. Allah's Apostle said, "May Allah curse these people. By Allah, both Abraham and Ishmael never did the game of chance with Azlams." Then he entered the Ka'ba and said Takbir at its corners but did not offer the prayer in it.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.672]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 672

Narrated Ibn Abbas:

When Allah's Apostle and his companions came to Mecca, the pagans circulated the news that a group of people were coming to them and they had been weakened by the Fever of Yathrib (Medina). So the Prophet ordered his companions to do Ramal in the first three rounds of Tawaf of the Ka'ba and to walk between the two corners (The Black Stone and Yemenite corner). The Prophet did not order them to do Ramal in all the rounds of Tawaf out of pity for them.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.673]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 673

Narrated Salim that his father said:

I saw Allah's Apostle arriving at Mecca; he kissed the Black Stone Corner first while doing Tawaf and did ramal in the first three rounds of the seven rounds (of Tawaf).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.674]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 674

Narrated Abdullah bin Umar :

The Prophet did Ramal in (first) three rounds (of Tawaf), and walked in the remaining four, in Hajj and Umra.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.675]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 675

Narrated Zaid bin Aslam from his father who said:

"Umar bin Al-Khattab addressed the Corner (Black Stone) saying, 'By Allah! I know that you are a stone and can neither benefit nor harm. Had I not seen the Prophet touching (and kissing) you, I would never have touched (and kissed) you.' Then he kissed it and said, 'There is no reason for us to do Ramal (in Tawaf) except that we wanted to show off before the pagans, and now Allah has destroyed them.' 'Umar added, '(Nevertheless), the Prophet did that and we do not want to leave it (i.e. Ramal).'


Bukhari :: Pilgrimmage (Hajj) :: [2.26.676]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 676

Narrated Nafi':

Ibn 'Umar. said, "I have never missed the touching of these two stones of Ka'ba (the Black Stone and the Yemenite Corner) both in the presence and the absence of crowds, since I saw the Prophet touching them." I asked Nafi': "Did Ibn 'Umar use to walk between the two Corners?" Nafi' replied, "He used to walk in order that it might be easy for him to touch it (the Corner Stone)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.677]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 677

Narrated Ibn Abbas.:

In his Last Hajj the Prophet performed Tawaf of the Ka'ba riding a camel and pointed a bent-headed stick towards the Corner (Black Stone).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.678]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 678

Narrated Salim bin 'Abdullah that his father said:

"I have not seen the Prophet touching except the two Yemenite Corners (i.e. the ones facing Yemen)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.679]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 679

Narrated Zaid bin Aslam that his father said:

"I saw 'Umar bin Al-Khattab kissing the Black Stone and he then said, (to it) 'Had I not seen Allah's Apostle kissing you, (stone) I would not have kissed you.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.680]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 680

Narrated Az-Zubair bin 'Arabi:

A man asked Ibn 'Umar about the touching of the Black Stone. Ibn 'Umar said, "I saw Allah's Apostle touching and kissing it." The questioner said, "But if there were a throng (much rush) round the Ka'ba and the people overpowered me, (what would I do?)" He replied angrily, "Stay in Yemen (as that man was from Yemen). I saw Allah's Apostle touching and kissing it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.681]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 681

Narrated Ibn Abbas:

The Prophet performed Tawaf of the Ka'ba while riding a camel, and whenever he came in front of the Corner, he pointed towards it (with something).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.682]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 682

Narrated Ibn Abbas

The Prophet performed Tawaf of the Ka'ba riding a camel, and every time he came in front of the Corner (having the Black Stone), he pointed towards it with something he had with him and said Takbir.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.683]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 683

Narrated 'Urwa:

'Aisha said, "The first thing the Prophet did on reaching Mecca, was the ablution and then he performed Tawaf of the Ka'ba and that was not 'Umra (alone), (but Hajj-al-Qiran). 'Urwa added: Later Abu Bakr and 'Umar did the same in their Hajj." And I performed the Hajj with my father Az-Zubair, and the first thing he did was Tawaf of the Ka'ba. Later I saw the Muhajirin (Emigrants) and the Ansar doing the same. My mother (Asma') told me that she, her sister ('Aisha), Az-Zubair and such and such persons assumed Ihram for 'Umra, and after they passed their hands over the Black Stone Corner (of the Ka'ba) they finished the Ihram. (i.e. After doing Tawaf of the Ka'ba and Sa'i between Safa-Marwa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.684]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 684

Narrated 'Abdullah bin 'Umar :

When Allah's Apostle performed Tawaf of the Ka'ba for Hajj or 'Umra, he used to do Ramal during the first three rounds, and in the last four rounds he used to walk; then after the Tawaf he used to offer two Rakat and then performed Tawaf between Safa and Marwa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.685]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 685

Narrated Ibn 'Umar:

When the Prophet performed the Tawaf of the Ka'ba, he did Ramal during the first three rounds and in the last four rounds he used to walk and while doing Tawaf between Safa and Marwa, he used to run in the midst of the rain water passage.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.686]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 686

Narrated Um Salama:

(the wife of the Prophet) I informed Allah's Apostle that I was ill. So he said, "Perform the Tawaf while riding behind the people." I did so, and at that time the Prophet was praying beside the Ka'ba and reciting Surat-at-Tur.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.687]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 687

Narrated Ibn Abbas:

While the Prophet was performing Tawaf of the Kaba, he passed by a person who had tied his hands to another person with a rope or string or something like that. The Prophet cut it with his own hands and said, "Lead him by the hand."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.688]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 688

Narrated Ibn Abbas:

The Prophet saw a man performing Tawaf of the Kaba tied with a string or something else. So the Prophet cut that string.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.689]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 689

Narrated Abu Huraira:

In the year prior to the last Hajj of the Prophet when Allahs Apostle made Abu Bakr the leader of the pilgrims, the latter (Abu Bakr) sent me in the company of a group of people to make a public announcement: 'No pagan is allowed to perform Hajj after this year, and no naked person is allowed to perform Tawaf of the Kaba.' (See Hadith No. 365 Vol. 1)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.690]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 690

Narrated Amr:

We asked Ibn Umar: "May a man have sexual relations with his wife during the Umra before performing Tawaf between Safa and Marwa?" He said, "Allah's Apostle arrived (in Mecca) and circumambulated the Kaba seven times, then offered two Rakat behind Maqam Ibrahim (the station of Abraham), then performed Tawaf between Safa and Marwa." Ibn Umar added, "Verily! In Allah's Apostle you have a good example." And I asked Jabir bin Abdullah (the same question), and he replied, "You should not go near your wives (have sexual relations) till you have finished Tawaf between Safa and Marwa. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.691]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 691

Narrated Ibn Abbas:

The Prophet arrived at Mecca and performed Tawaf of the Kaba and Sa'i between Safa and Marwa, but he did not go near the Kaba after his Tawaf till he returned from Arafat.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.692]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 692

Narrated Um Salama:

(the wife of the Prophet) I informed Allah's Apostle (about my illness). (Through other sub-narrators, Um Salama narrated that when Allah's Apostle was at Mecca and had just decided to leave (Mecca) while she had not yet done Tawaf of the Kaba (and after listening to her). The Prophet said, "When the morning prayer is established, perform the Tawaf on your camel while the people are in prayer." So she did the same and did not offer the two Rakat of Tawaf until she came out of the Mosque.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.693]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 693

Narrated Ibn Umar:

The Prophet reached Mecca, circumambulated the Kaba seven times and then offered a two Rakat prayer behind Maqam ibrahim. Then he went towards the Safa. Allah has said, "Verily, in Allah's Apostle you have a good example."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.694]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 694

Narrated Urwa from Aisha:

Some people performed Tawaf (of the Kaba) after the morning prayer and then sat to listen to a preacher till sunrise, and then they stood up for the prayer. Then Aisha commented, "Those people kept on sitting till it was the time in which the prayer is disliked and after that they stood up for the prayer."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.695]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 695

Narrated Abdullah:

heard the Prophet forbidding the offering of prayers at the time of sunrise and sunset.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.696]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 696

Narrated Abida bin Humaid:

Abdul, Aziz bin Rufai Said, "I saw Abdullah bin Az-Zubair performing Tawaf of the Kaba after the morning prayer then offering the two Rakat prayer." Abdul Aziz added, "I saw Abdullah bin Az-Zubair offering a two Rakat prayer after the Asr prayer." He informed me that Aisha told him that the Prophet used to offer those two Rakat whenever he entered her house."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.697]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 697

Narrated Ibn Abbas:

Allah's Apostle performed Tawaf (of the Kaba) ending a camel (at that time the Prophet had foot injury). Whenever he came to the Corner (having the Black Stone) he would point out towards it with a thing in his hand and say, "Allahu-Akbar."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.698]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 698

Narrated Um Salama:

I informed Allah's Apostle that I was sick. He said, "Perform Tawaf (of the Kaba) while riding behind the people." So, I performed the Tawaf while Allah's Apostle was offering the prayer beside the Kaba and was reciting Surat-at-Tur.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.699]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 699

Narrated Ibn Umar:

Al Abbas bin Abdul-Muttalib asked the permission of Allahs Apostle to let him stay in Mecca during the nights of Mina in order to provide the pilgrims with water to drink, so the Prophet permitted him.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.700]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 700

Narrated Ibn Abbas:

Allah's Apostle came to the drinking place and asked for water. Al-Abbas said, "O Fadl! Go to your mother and bring water from her for Allah's Apostle ." Allah's Apostle said, "Give me water to drink." Al-Abbas said, "O Allahs Apostle! The people put their hands in it." Allah's Apostle again said, 'Give me water to drink. So, he drank from that water and then went to the Zam-zam (well) and there the people were offering water to the others and working at it (drawing water from the well). The Prophet then said to them, "Carry on! You are doing a good deed." Then he said, "Were I not afraid that other people would compete with you (in drawing water from Zam-zam), I would certainly take the rope and put it over this (i.e. his shoulder) (to draw water)." On saying that the Prophet pointed to his shoulder.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.701]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 701

Narrated Ibn Abbas:

I gave Zam-zam water to Allah's Apostle and he drank it while standing. 'Asia (a sub-narrator) said that 'Ikrima took the oath that on that day the Prophet had not been standing but riding a camel.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.702]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 702

Narrated 'Aisha:

We set out with Allah's Apostle in the year of his Last Hajj and we mended (the Ihram) for 'Umra. Then the Prophet said, "Whoever has a Hadi with him should assume Ihram for both Hajj and 'Umra, and should not finish it till he performs both of the them (Hajj and 'Umra)." When we reached Mecca, I had my menses. When we had performed our Hajj, the Prophet sent me with 'Abdur-Rahman to Tan'im and I performed the 'Umra. The Prophet said, "This is in lieu of your missed 'Umra." Those who had assumed Ihram for 'Umra performed Tawaf (between Safa and Marwa) and then finished their Ihram. And then they performed another Tawaf (between Safa and Marwa) after returning from Mina. And those who had assumed lhram for Hajj and 'Umra to get her ( Hajj-Qiran ) performed only one Tawaf (between Safa and Marwa).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.703]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 703

Narrated Nafi':

'Abdullah bin 'Abdullah bin 'Umar and his riding animal entered the house of Ibn 'Umar. He (the son of Ibn 'Umar) said, "I fear that this year a battle might take place between the people and you might be prevented from going to the Ka'ba. I suggest that you should stay here." Ibn Umar said, "Once Allah's Apostle set out for the pilgrimage, and the pagans of Quraish intervened between him and the Ka'ba. So, if the people intervened between me and the Ka'ba, I would do the same as Allah's Apostle had done . . . "Verily, in Allah's Apostle you have a good example." Then he added, "I make you a witness that I have intended to perform Hajj along with 'Umra." After arriving at Mecca, Ibn 'Umar performed one Tawaf only (between Safa and Marwa).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.704]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 704

Narrated Nafi':

Ibn 'Umar intended to perform Hajj in the year when Al-Hajjaj attacked Ibn Az-Zubair. Somebody said to Ibn 'Umar, "There is a danger of an impending war between them." Ibn 'Umar said, "Verily, in Allah's Apostle you have a good example. (And if it happened as you say) then I would do the same as Allah's Apostle had done. I make you witness that I have decided to perform 'Umra." Then he set out and when he reached Al-Baida', he said, "The ceremonies of both Hajj and 'Umra are similar. I make you witness that I have made Hajj compulsory for me along with 'Umra." He drove (to Mecca) a Hadi which he had bought from (a place called) Qudaid and did not do more than that. He did not slaughter the Hadi or finish his Ihram, or shave or cut short his hair till the day of slaughtering the sacrifices (10th Dhul-Hijja). Then he slaughtered his Hadi and shaved his head and considered the first Tawaf (of Safa and Marwa) as sufficient for Hajj and 'Umra. Ibn 'Umar said, "Allah's Apostle did the same."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.705]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 705

Narrated Muhammad bin 'AbdurRahman bin Nawfal Al-Qurashi:

I asked 'Urwa bin Az-Zubair (regarding the Hajj of the Prophet ). 'Urwa replied, "Aisha narrated, 'When the Prophet reached Mecca, the first thing he started with was the ablution, then he performed Tawaf of the Ka'ba and his intention was not 'Umra alone (but Hajj and 'Umra together).' " Later Abu Bakr I performed the Hajj and the first thing he started with was Tawaf of the Ka'ba and it was not 'Umra alone (but Hajj and 'Umra together). And then 'Umar did the same. Then 'Uthman performed the Hajj and the first thing he started with was Tawaf of the Ka'ba and it was not 'Umra alone. And then Muawiya and 'Abdullah bin 'Umar did the same. I performed Hajj with Ibn Az-Zubair and the first thing he started with was Tawaf of the Ka'ba and it was not 'Umra alone, (but Hajj and 'Umra together). Then I saw the Muhajirin (Emigrants) and Ansar doing the same and it was not 'Umra alone. And the last person I saw doing the same was Ibn 'Umar, and he did not do another 'Umra after finishing the first. Now here is Ibn 'Umar present amongst the people! They neither ask him nor anyone of the previous ones. And all these people, on entering Mecca, would not start with anything unless they had performed Tawaf of the Ka'ba, and would not finish their Ihram. And no doubt, I saw my mother and my aunt, on entering Mecca doing nothing before performing Tawaf of the Ka'ba, and they would not finish their lhram. And my mother informed me that she, her sister, Az-Zubair and such and such persons had assumed lhram for 'Umra and after passing their hands over the Corner (the Black Stone) (i.e. finishing their Umra) they finished their Ihram."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.706]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 706

Narrated 'Urwa:

I asked 'Aisha : "How do you interpret the statement of Allah,. : Verily! (the mountains) As-Safa and Al-Marwa are among the symbols of Allah, and whoever performs the Hajj to the Ka'ba or performs 'Umra, it is not harmful for him to perform Tawaf between them (Safa and Marwa.) (2.158). By Allah! (it is evident from this revelation) there is no harm if one does not perform Tawaf between Safa and Marwa." 'Aisha said, "O, my nephew! Your interpretation is not true. Had this interpretation of yours been correct, the statement of Allah should have been, 'It is not harmful for him if he does not perform Tawaf between them.' But in fact, this divine inspiration was revealed concerning the Ansar who used to assume lhram for worship ping an idol called "Manat" which they used to worship at a place called Al-Mushallal before they embraced Islam, and whoever assumed Ihram (for the idol), would consider it not right to perform Tawaf between Safa and Marwa.

When they embraced Islam, they asked Allah's Apostle (p.b.u.h) regarding it, saying, "O Allah's Apostle! We used to refrain from Tawaf between Safa and Marwa." So Allah revealed: 'Verily; (the mountains) As-Safa and Al-Marwa are among the symbols of Allah.' " Aisha added, "Surely, Allah's Apostle set the tradition of Tawaf between Safa and Marwa, so nobody is allowed to omit the Tawaf between them." Later on I ('Urwa) told Abu Bakr bin 'Abdur-Rahman (of 'Aisha's narration) and he said, 'i have not heard of such information, but I heard learned men saying that all the people, except those whom 'Aisha mentioned and who used to assume lhram for the sake of Manat, used to perform Tawaf between Safa and Marwa.

When Allah referred to the Tawaf of the Ka'ba and did not mention Safa and Marwa in the Quran, the people asked, 'O Allah's Apostle! We used to perform Tawaf between Safa and Marwa and Allah has revealed (the verses concerning) Tawaf of the Ka'ba and has not mentioned Safa and Marwa. Is there any harm if we perform Tawaf between Safa and Marwa?' So Allah revealed: "Verily As-Safa and Al-Marwa are among the symbols of Allah." Abu Bakr said, "It seems that this verse was revealed concerning the two groups, those who used to refrain from Tawaf between Safa and Marwa in the Pre-lslamic Period of ignorance and those who used to perform the Tawaf then, and after embracing Islam they refrained from the Tawaf between them as Allah had enjoined Tawaf of the Ka'ba and did not mention Tawaf (of Safa and Marwa) till later after mentioning the Tawaf of the Ka'ba.'


Bukhari :: Pilgrimmage (Hajj) :: [2.26.707]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 707

Narrated Nafi':

Ibn 'Umar said, "When Allah's Apostle performed the first Tawaf he did Ramal in the first three rounds and then walked in the remaining four rounds (of Tawaf of the Ka'ba), where as in performing Tawaf between Safa and Marwa he used to run in the midst of the rain-water passage," I asked Nafi', "Did 'Abdullah (bin 'Umar) use to walk steadily on reaching the Yemenite Corner?" He replied, "No, unless people were crowded at the Corner; otherwise he would not leave it without touching it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.708]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 708

Narrated 'Amr bin Dinar:

We asked Ibn 'Umar whether a man who, while performing 'Umra, had performed Tawaf of the Ka'ba; and had not yet performed Tawaf between Safa and Marwa, could have sexual relation with his wife, Ibn 'Umar replied "The Prophet (p.b.u.h) reached Mecca and performed the seven rounds (of Tawaf) of the Ka'ba and then offered a two-Rakat prayer behind Maqam ibrahim and then performed the seven rounds (of Tawaf) between Safa and Marwa." He added, "Verily! In Allah's Apostle (p.b.u.h) you have a good example." We asked Jabir bin 'Abdullah (the same question) and he said, "He (that man) should not come near (his wife) till he has completed Tawaf between Safa and Marwa."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.709]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 709

Narrated 'Amr bin Dinar:

I heard Ibn 'Umar saying, "The Prophet arrived at Mecca and performed Tawaf of the Ka'ba and then offered a two-Rakat prayer and then performed Tawaf between Safa and Marwa." Ibn 'Umar then recited (the verse): "Verily! In Allah's Apostle (p.b.u.h) you have a good example. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.710]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 710

Narrated 'Asim:

I asked Anas bin Malik: "Did you use to dislike to perform Tawaf between Safa and Marwa?" He said, "Yes, as it was of the ceremonies of the days of the Pre-lslamic period of ignorance, till Allah revealed: 'Verily! (The two mountains) As-Safa and Al-Marwa are among the symbols of Allah. It is therefore no sin for him who performs the pilgrimage to the Ka'ba, or performs 'Umra, to perform Tawaf between them.' " (2.158)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.711]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 711

Narrated Ibn Abbas:

Allah's Apostle performed Tawaf of the Ka'ba and the Sa'i of Safa and Marwa so as to show his strength to the pagans.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.712]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 712

Narrated 'Aisha:

I was menstruating when I reached Mecca. So, I neither performed Tawaf of the Ka'ba, nor the Tawaf between Safa and Marwa. Then I informed Allah's Apostle about it. He replied, "Perform all the ceremonies of Hajj like the other pilgrims, but do not perform Tawaf of the Ka'ba till you get clean (from your menses)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.713]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 713

Narrated Jabir bin 'Abdullah:

The Prophet and his companions assumed Ihram for Hajj and none except the Prophet (p.b.u.h) and Talha had the Hadi (sacrifice) with them. 'Ali arrived from Yemen and had a Hadi with him. 'Ali said, "I have assumed Ihram for what the Prophet has done." The Prophet ordered his companions to perform the 'Umra with the lhram which they had assumed, and after finishing Tawaf (of Ka'ba, Safa and Marwa) to cut short their hair, and to finish their lhram except those who had Hadi with them. They (the people) said, "How can we proceed to Mina (for Hajj) after having sexual relations with our wives?" When that news reached the Prophet he said, "If I had formerly known what I came to know lately, I would not have brought the Hadi with me. Had there been no Hadi with me, I would have finished the state of lhram." 'Aisha got her menses, so she performed all the ceremonies of Hajj except Tawaf of the Ka'ba, and when she got clean (from her menses), she performed Tawaf of the Ka'ba. She said, "O Allah's Apostle! (All of you) are returning with the Hajj and 'Umra, but I am returning after performing Hajj only." So the Prophet ordered 'Abdur-Rahman bin Abu Bakr to accompany her to Tan'im and thus she performed the 'Umra after the Hajj.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.714]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 714

Narrated Hafsa:

(On 'Id) We used to forbid our virgins to go out (for 'Id prayer). A lady came and stayed at the Palace of Bani Khalaf. She mentioned that her sister was married to one of the companions of Allah's Apostle who participated in twelve Ghazawats along with Allah's Apostle and her sister was with him in six of them. She said, "We used to dress the wounded and look after the patients." She (her sister) asked Allah's Apostle , "Is there any harm for a woman to stay at home if she doesn't have a veil?" He said, "She should cover herself with the veil of her companion and she should take part in the good deeds and in the religious gatherings of the believers." When Um 'Atiyya came, I asked her. "Did you hear anything about that?" Um 'Atiyya said, "Bi Abi" and she never mentioned the name of Allah's Apostle without saying "Bi Abi" (i.e. 'Let my father be sacrificed for you'). We asked her, "Have you heard Allah's Apostle saying so and so (about women)?" She replied in the affirmative and said, "Let my father be sacrificed for him. He told us that unmarried mature virgins who stay often screened or unmarried young virgins and mature girls who stay often screened should come out and take part in the good deeds and in the religious gatherings of the believers. But the menstruating women should keep away from the Musalla (praying place)." I asked her, "The menstruating women?" She replied, "Don't they present themselves at 'Arafat and at such and such places?"


Bukhari :: Pilgrimmage (Hajj) :: [2.26.715]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 715

Narrated 'Abdul 'Aziz bin Rufai:

I asked Anas bin Malik, "Tell me what you remember from Allah's Apostle (regarding these questions): Where did he offer the Zuhr and 'Asr prayers on the day of Tarwiya (8th day of Dhul-Hajja)?" He relied, "(He offered these prayers) at Mina." I asked, "Where did he offer the 'Asr prayer on the day of Nafr (i.e. departure from Mina on the 12th or 13th of Dhul-Hijja)?" He replied, "At Al-Abtah," and then added, "You should do as your chiefs do."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.716]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 716

Narrated 'Abdul 'Aziz:

I went out to Mina on the day of Tarwiya and met Anas going on a donkey. I asked him, "Where did the Prophet offer the Zuhr prayer on this day?" Anas replied, "See where your chiefs pray and pray similarly."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.717]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 717

Narrated 'Abdullah bin 'Umar :

Allah's Apostle offered a two-Rakat prayer at Mina. Abu Bakr, 'Umar and 'Uthman, (during the early years of his caliphate) followed the same practice.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.718]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 718

Narrated Haritha bin Wahab Al-Khuza'i:

The Prophet led us in a two-Rakat prayer at Mina although our number was more than ever and we were in better security than ever.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.719]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 719

Narrated 'Abdullah bin Masud:

I offered (only a) two Rakat prayer with the Prophet (at Mina), and similarly with Abu Bakr and with 'Umar, and then you d offered in opinions. Wish that I would be lucky enough to have two of the four Rakat accepted (by Allah).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.720]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 720

Narrated Um Al-Fadl:

The people doubted whether the Prophet was observing the fast on the Day of 'Arafat, so I sent something for him to drink and he drank it.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.721]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 721

Narrated Muhammad bin Abu Bakr Al-Thaqafi:

I asked Anas bin Malik while we were proceeding from Mina to 'Arafat, "What do you use to do on this day when you were with Allah's Apostle ?" Anas said, "Some of us used to recite Talbiya and nobody objected to that, and others used to recite Takbir and nobody objected to that."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.722]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 722

Narrated Salim:

'Abdul Malik wrote to Al-Hajjaj that he should not differ from Ibn 'Umar during Hajj. On the Day of 'Arafat, when the sun declined at midday, Ibn 'Umar came along with me and shouted near Al-Hajjaj's cotton (cloth) tent. Al-Hajjaj came Out, wrapping himself with a waist-sheet dyed with safflower, and said, "O Abu Abdur-Rahman! What is the matter?" He said, If you want to follow the Sunna (the tradition of the Prophet (p.b.u.h) ) then proceed (to 'Arafat)." Al-Hajjaj asked, "At this very hour?" Ibn 'Umar said, "Yes." He replied, "Please wait for me till I pour some water over my head (i.e. take a bath) and come out." Then Ibn 'Umar dismounted and waited till Al-Hajjaj came out. So, he (Al-Hajjaj) walked in between me and my father (Ibn 'Umar). I said to him, "If you want to follow the Sunna then deliver a brief sermon and hurry up for the stay at 'Arafat." He started looking at 'Abdullah (Ibn 'Umar) (inquiringly), and when 'Abdullah noticed that, he said that he had told the truth.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.723]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 723

Narrated Um Al-Fadl bint Al Harith:

On the day of 'Arafat, some people who were with me, differed about the fasting of the Prophet (p.b.u.h) some said that he was fasting while others said that he was not fasting. So I sent a bowl full of milk to him while he was riding his camel, and he drank that milk.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.724]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 724

Narrated Salim bin 'Abdullah bin 'Umar:

'Abdul-Malik bin Marwan wrote to Al-Hajjaj that he should follow 'Abdullah bin 'Umar in all the ceremonies of Hajj. So when it was the Day of 'Arafat (9th of Dhul-Hajja), and after the sun has deviated or has declined from the middle of the sky, I and Ibn 'Umar came and he shouted near the cotton (cloth) tent of Al-Hajjaj, "Where is he?" Al-Hajjaj came out. Ibn 'Umar said, "Let us proceed (to 'Arafat)." Al-Hajjaj asked, "Just now?" Ibn 'Umar replied, "Yes." Al-Hajjaj said, "Wait for me till I pour water on me (i.e. take a bath)." So, Ibn 'Umar dismounted (and waited) till Al-Hajjaj came out. He was walking between me and my father. I informed Al-Hajjaj, "If you want to follow the Sunna today, then you should shorten the sermon and then hurry up for the stay (at 'Arafat)." Ibn 'Umar said, "He (Salim) has spoken the truth."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.725]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 725

Narrated Muhammad bin Jubair bin Mut'im:

My father said, "(Before Islam) I was looking for my camel .." The same narration is told by a different sub-narrator. Jubair bin Mut'im said, "My camel was lost and I went out in search of it on the day of 'Arafat, and I saw the Prophet standing in 'Arafat. I said to myself: By Allah he is from the Hums (literally: strictly religious, Quraish were called so, as they used to say, 'We are the people of Allah we shall not go out of the sanctuary). What has brought him here?"


Bukhari :: Pilgrimmage (Hajj) :: [2.26.726]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 726

Narrated 'Urwa:

During the pre-lslamic period of Ignorance, the people used to perform Tawaf of the Ka'ba naked except the Hums; and the Hums were Quraish and their offspring. The Hums used to give clothes to the men who would perform the Tawaf wearing them; and women (of the Hums) used to give clothes to the women who would perform the Tawaf wearing them. Those to whom the Hums did not give clothes would perform Tawaf round the Ka'ba naked. Most of the people used to go away (disperse) directly from 'Arafat but they (Hums) used to depart after staying at Al-Muzdalifa. 'Urwa added, "My father narrated that 'Aisha had said, 'The following verses were revealed about the Hums: Then depart from the place whence all the people depart--(2.199) 'Urwa added, "They (the Hums) used to stay at Al-Muzdalifa and used to depart from there (to Mina) and so they were sent to 'Arafat (by Allah's order)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.727]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 727

Narrated 'Urwa:

Usama was asked in my presence, "How was the speed of (the camel of) Allah's Apostle while departing from 'Arafat during the Hajjatul Wada?" Usama replied, "The Prophet proceeded on with a modest pace, and when there was enough space he would (make his camel) go very fast."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.728]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 728

Narrated Usama bin Zaid:

As soon as the Prophet departed from 'Arafat, he went towards the mountain pass, and there he answered the call of) the prayer is ahead of you (i.e. at asked, "O Allah's Apostle! Will you offer the prayer here?" He replied, "(The place of) the prayer is ahead of you (i.e. at Al-Muzdalifa)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.729]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 729

Narrated Nafi':

'Abdullah bin 'Umar used to offer the Maghrib and 'Isha' prayers together at Jam' (Al-Muzdalifa). But he used to pass by that mountain pass where Allah's Apostle went, and he would enter it and answer the call of nature and perform ablution, and would not offer any prayer till he had prayed at Jam.'


Bukhari :: Pilgrimmage (Hajj) :: [2.26.730]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 730

Narrated Usama bin Zaid

rode behind Allah's Apostle from 'Arafat and when Allah's Apostle reached the mountain pass on the left side which is before Al-Muzdalifa he made his camel kneel and then urinated, and then I poured water for his ablution. He performed light ablution and then I said to him: (Is it the time for) the prayer, O Allah's Apostle!" He replied, "The (place of) prayer is ahead of you (i.e. at Al-Muzdalifa)." So Allah's Apostle rode till he reached Al-Muzdalifa and then he offered the prayer (there) . Then in the morning (10th Dhul-Hijja) Al-Faql (bin Abbas) rode behind Allah's Apostle. Kuraib, (a sub-narrator) said that 'Abdullah bin Abbas narrated from Al-Fadl, "Allah's Apostle (p.b.u.h) kept on reciting Talbiya (during the journey) till he reached the Jamra." (Jamrat-al-Aqaba)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.731]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 731

Narrated Ibn Abbas. :

I proceeded along with the Prophet on the day of 'Arafat (9th Dhul-Hijja). The Prophet heard a great hue and cry and the beating of camels behind him. So he beckoned to the people with his lash, "O people! Be quiet. Hastening is not a sign of righteousness."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.732]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 732

Narrated Usama bin Zaid:

Allah's Apostle proceeded from 'Arafat and dismounted at the mountainous pass and then urinated and performed a light ablution. I said to him, "(Shall we offer) the prayer?" He replied, "The prayer is ahead of you (i.e. at Al-Muzdalifa)." When he came to Al-Muzdalifa, he performed a perfect ablution. Then Iqama for the prayer was pronounced and he offended the Maghrib prayer and then every person made his camel kneel at his place; and then Iqama for the prayer was pronounced and he offered the ('Isha') prayer and he did not offer any prayer in between them (i.e. Maghrib and 'Isha' prayers).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.733]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 733

Narrated Ibn 'Umar:

The Prophet offered the Maghrib and 'Isha' prayers together at Jam' (i.e. Al-Muzdalifa) with a separate Iqama for each of them and did not offer any optional prayer in between them or after each of them.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.734]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 734

Narrated Abu Aiyub Al-Ansari :

Allah's Apostle coffered the Maghrib and 'Isha' prayers together at Al-Muzdalifa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.735]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 735

Narrated 'Abdur-Rahman bin Yazid:

'Abdullah;- performed the Hajj and we reached Al-Muzdalifa at or about the time of the 'Isha' prayer. He ordered a man to pronounce the Adhan and Iqama and then he offered the Maghrib prayer and offered two Rakat after it. Then he asked for his supper and took it, and then, I think, he ordered a man to pronounce the Adhan and Iqama (for the 'isha' prayer). ('Amr, a sub-narrator said: The intervening statement 'I think', was said by the sub-narrator Zuhair) (i.e. not by 'Abdu-Rahman). Then 'Abdullah offered two Rakat of 'Isha' prayer. When the day dawned, 'Abdullah said, "The Prophet never offered any prayer at this hour except this prayer at this time and at this place and on this day." 'Abdullah added, "These two prayers are shifted from their actual times -- the Maghrib prayer (is offered) when the people reached Al-Muzdalifa and the Fajr (morning) prayer at the early dawn." 'Abdullah added, "I saw the Prophet doing that."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.736]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 736

Narrated Salim:

'Abdullah bin 'Umar used to send the weak among his family early to Mina. So they used to depart from Al-Mash'ar Al-Haram (that is Al-Muzdalifa) at night (when the moon had set) and invoke Allah as much as they could, and then they would return (to Mina) before the Imam had started from Al-Muzdalifa to Mina. So some of them would reach Mina at the time of the Fajr prayer and some of them would come later. When they reached Mina they would throw pebbles on the Jamra (Jamrat-al-Aqaba) Ibn 'Umar used to say, "Allah's Apostle gave the permission to them (weak people) to do so."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.737]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 737

Narrated Ibn Abbas :

Allah's Apostle had sent me from Jam' (i.e. Al-Muzdalifa) at night.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.738]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 738

Narrated Ibn Abbas:

I as among those whom the Prophet sent on the night of Al-Muzdalifa early being among the weak members of his family.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.739]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 739

Narrated 'Abdullah:

(the slave of Asma') During the night of Jam', Asma' got down at Al-Muzdalifa and stood up for (offering) the prayer and offered the prayer for some time and then asked, "O my son! Has the moon set?" I replied in the negative and she again prayed for another period and then asked, "Has the moon set?" I replied, "Yes." So she said that we should set out (for Mina), and we departed and went on till she threw pebbles at the Jamra (Jamrat-al-Aqaba) and then she returned to her dwelling place and offered the morning prayer. I asked her, "O you! I think we have come (to Mina) early in the night." She replied, "O my son! Allah's Apostle gave permission to the women to do so."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.740]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 740

Narrated 'Aisha :

Sauda asked the permission of the Prophet to leave earlier at the night of Jam', and she was a fat and very slow woman. The Prophet gave her permission.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.741]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 741

Narrated 'Aisha:

We got down at Al-Muzdalifa and Sauda asked the permission of the Prophet to leave (early) before the rush of the people. She was a slow woman and he gave her permission, so she departed (from Al-Muzdalifa) before the rush of the people. We kept on staying at Al-Muzdalifa till dawn, and set out with the Prophet but (I suffered so much that) I wished I had taken the permission of Allah's Apostle as Sauda had done, and that would have been dearer to me than any other happiness.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.742]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 742

Narrated Abdullah:

I never saw the Prophet offering any prayer not at its stated time except two; he prayed the Maghrib and the 'Isha' together and he offered the morning prayer before its usual time.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.743]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 743

Narrated 'Abdur-Rahman bin Yazid

I went out with 'Abdullah , to Mecca and when we proceeded to am' he offered the two prayers (the Maghrib and the 'Isha') together, making the Adhan and Iqama separately for each prayer. He took his supper in between the two prayers. He offered the Fajr prayer as soon as the day dawned. Some people said, "The day had dawned (at the time of the prayer)," and others said, "The day had not dawned." 'Abdullah then said, "Allah's Apostle said, 'These two prayers have been shifted from their stated times at this place only (at Al-Muzdalifa); first: The Maghrib and the 'Isha'. So the people should not arrive at Al-Muzdalifa till the time of the 'Isha' prayer has become due. The second prayer is the morning prayer which is offered at this hour.' " Then 'Abdullah stayed there till it became a bit brighter. He then said, "If the chief of the believers hastened onwards to Mina just now, then he had indeed followed the Sunna." I do not know which proceeded the other, his ('Abdullah's) statement or the departure of 'Uthman . Abdullah was reciting Talbiya till he threw pebbles at the Jamrat-al-'Aqaba on the Day of Nahr (slaughtering) (that is the 10th of Dhul-Hijja).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.744]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 744

Narrated 'Amr bin Maimun:

I saw 'Umar, offering the Fajr (morning) prayer at Jam'; then he got up and said, "The pagans did not use to depart (from Jam') till the sun had risen, and they used to say, 'Let the sun shine on Thabir (a mountain).' But the Prophet contradicted them and departed from Jam' before sunrise."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.745]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 745

Narrated Ibn Abbas:

The Prophet made Al-Faql ride behind him, and Al-Fadl informed that he (the Prophet ) kept on reciting Talbiya till he did the Rami of the Jamra. (Jamrat-al-Aqaba.)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.746]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 746

Narrated 'Ubaidullah bin 'Abdullah:

Ibn Abbas said, "Usama bin Zaid rode behind the Prophet from 'Arafat to Al-Muzdalifa; and then from Al-Muzdalifa to Mina, Al-Fadl rode behind him." He added, "Both of them (Usama and Al-Fadl) said, 'The Prophet was constantly reciting Talbiya till he did Rami of the Jamarat-al-'Aqaba."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.747]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 747

Narrated Abu Jamra:

I asked Ibn Abbas about Hajj-at-Tamattu'. He ordered me to perform it. I asked him about the Hadi (sacrifice). He said, "You have to slaughter a camel, a cow or a sheep, or you may share the Hadi with the others." It seemed that some people disliked it (Hajj-at-Tamattu). I slept and dreamt as if a person was announcing: "Hajj Mabrur and accepted Mut'ah (Hajj-At-Tamattu')" I went to Ibn Abbas and narrated it to him. He said, "Allah is Greater. (That was) the tradition of Abu Al-Qasim (i.e. Prophet). Narrated Shu'ba that the call in the dream was. "An accepted 'Umra and Hajj-Mabrur. "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.748]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 748

Narrated Abu Huraira' :

Allah's Apostle (p.b.u.h) saw a man driving his Badana (sacrificial camel). He said, "Ride on it." The man said, "It is a Badana." The Prophet said, "Ride on it." He (the man) said, "It is a Badana." The Prophet said, "Ride on it." And on the second or the third time he (the Prophet ) added, "Woe to you."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.749]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 749

Narrated Anas:

The Prophet saw a man driving a Badana. He said, "Ride on it." The man replied, "It is a Badana." The Prophet said (again), "Ride on it." He (the man) said, "It is a Badana." The Prophet said thrice, "Ride on it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.750]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 750

Narrated Ibn 'Umar:

During the last Hajj (Hajj-al-Wada') of Allah's Apostle he performed 'Umra and Hajj. He drove a Hadi along with him from Dhul-Hulaifa. Allah's Apostle started by assuming Ihram for'Umra and Hajj. And the people, too, performed the 'Umra and Hajj along with the Prophet. Some of them brought the Hadi and drove it along with them, while the others did not. So, when the Prophet arrived at Mecca. he said to the people, "Whoever among you has driven the Hadi, should not finish his Ihram till he completes his Hajj. And whoever among you has not (driven) the Hadi with him, should perform Tawaf of the Ka'ba and the Tawaf between Safa and Marwa, then cut short his hair and finish his Ihram, and should later assume Ihram for Hajj; but he must offer a Hadi (sacrifice); and if anyone cannot afford a Hadi, he should fast for three days during the Hajj and seven days when he returns home. The Prophet performed Tawaf of the Ka'ba on his arrival (at Mecca); he touched the (Black Stone) corner first of all and then did Ramal (fast walking with moving of the shoulders) during the first three rounds round the Ka'ba, and during the last four rounds he walked. After finishing Tawaf of the Ka'ba, he offered a two Rakat prayer at Maqam Ibrahim, and after finishing the prayer he went to Safa and Marwa and performed seven rounds of Tawaf between them and did not do any deed forbidden because of Ihram, till he finished all the ceremonies of his Hajj and sacrificed his Hadi on the day of Nahr (10th day of Dhul-Hijja). He then hastened onwards (to Mecca) and performed Tawaf of the Ka'ba and then everything that was forbidden because of Ihram became permissible. Those who took and drove the Hadi with them did the same as Allah's Apostle did.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.751]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 751

Narrated Nafi':

'Abdullah (bin 'Abdullah) bin 'Umar said to his father, "Stay here, for I am afraid that it (affliction between Ibn Zubair and Al-Hajjaj) might prevent you from reaching the Ka'ba." Ibn 'Umar said, "(In this case) I would do the same as Allah's Apostle did, and Allah has said, 'Verily, in Allah's Apostle, you have a good example (to follow).' So, I make you, people, witness that I have made 'Umra compulsory for me." So he assumed lhram for'Umra. Then he went out and when he reached Al-Baida', he assumed Ihram for Hajj and 'Umra (together) and said, "The conditions (requisites) of Hajj and 'Umra are the same." He, then brought a Hadi from Qudaid. Then he arrived (at Mecca) and performed Tawaf (between Safa and Marwa) once for both Hajj and 'Umra and did not finish the lhram till he had finished both Hajj and 'Umra.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.752]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 752

Narrated Al-Miswar bin Makhrama and Marwan:

The Prophet set out from Medina with over one thousand of his companions (at the time of the Treaty of Hudaibiya) and when they reached Dhul-Hulaifa, the Prophet garlanded his Hadi and marked it and assumed Ihram for'Umra.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.753]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 753

Narrated 'Aisha:

I twisted with my own hands the garlands for the Budn of the Prophet who garlanded and marked them, and then made them proceed to Mecca; Yet no permissible thing was regarded as illegal for him then.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.754]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 754

Narrated Hafsa:

I said, "O Allah's Apostle! What is wrong with the people, they have finished their Ihram but you have not?" He said, "I matted my hair and I have garlanded my Hadi, so I will not finish my Ihram till I finished my Hajj ."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.755]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 755

Narrated 'Aisha:

Allah's Apostle used to send the Hadi from Medina and I used to twist the garlands for his Hadi and he did not keep away from any of these things which a Muhrim keeps away from.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.756]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 756

Narrated 'Aisha:

I twisted the garlands for the Hadis of the Prophet and then he marked and garlanded them (or I garlanded them) and then made them proceed to the Ka'ba but he remained in Medina and no permissible thing was regarded as illegal for him then .


Bukhari :: Pilgrimmage (Hajj) :: [2.26.757]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 757

Narrated 'Abdullah bin Abu Bakr bin 'Amr bin Hazm

that 'Amra bint 'Abdur-Rahman had told him, "Zaid bin Abu Sufyan wrote to 'Aisha that 'Abdullah bin Abbas had stated, 'Whoever sends his Hadi (to the Ka'ba), all the things which are illegal for a (pilgrim) become illegal for that person till he slaughters it (i.e. till the 10th of Dhul-Hijja).' " 'Amra added, 'Aisha said, 'It is not like what Ibn Abbas had said: I twisted the garlands of the Hadis of Allah's Apostle with my own hands. Then Allah's Apostle put them round their necks with his own hands, sending them with my father; Yet nothing permitted by Allah was considered illegal for Allah's Apostle till he slaughtered the Hadis.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.758]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 758

Narrated 'Aisha:

Once the Prophet sent sheep as Hadi.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.759]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 759

Narrated 'Aisha:

I used to make the garlands for (the Hadis of) the Prophet and he would garland the sheep (with them) and would stay with his family as a non-Muhrim.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.760]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 760

Narrated Aisha:

I used to twist the garlands for the sheep of the Prophet and he would send them (to the Ka'ba), and stay as a non-Muhrim.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.761]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 761

Narrated 'Aisha:

I twisted (the garlands) for the Hadis of the Prophet before he assumed Ihram.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.762]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 762

Narrated 'Aisha:

I twisted the garlands of the Hadis from the wool which was with me.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.763]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 763

Narrated 'Ikrima:

Abu Huraira said, "The Prophet saw a man driving a Badana (sacrificial camel). The Prophet (p.b.u.h) said (to him), 'Ride on it.' He replied, 'It is a Badana.' The Prophet again said, 'Ride on it!' Abu Huraira added, 'Then I saw that man riding it, showing obedience to the Prophet (p.b.u.h), and a shoe was (hanging) from its neck.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.764]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 764

Narrated Abu Huraira:

From the Prophet: (as above).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.765]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 765

Narrated 'Ali:

Allah's Apostle ordered me to give in charity the skin and the coverings of the Budn which I had slaughtered.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.766]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 766

Narrated Nafi':

Ibn 'Umar intended to perform Hajj in the year of the Hajj of Al-Harawriya during the rule of Ibn Az-Zubair. Some people said to him, "It is very likely that there will be a fight among the people, and we are afraid that they might prevent you (from performing Hajj)." He replied, "Verily, in Allah's Apostle there is a good example for you (to follow). In this case I would do the same as he had done. I make you witness that I have intended to perform 'Umra." When he reached Al-Baida', he said, "The conditions for both Hajj and 'Umra are the same. I make you witness that I have intended to perform Hajj along with 'Umra." After that he took a garlanded Hadi (to Mecca) which he bought (on the way). When he reached (Mecca), he performed Tawaf of the Ka'ba and of Safa (and Marwa) and did not do more than that. He did not make legal for himself the things which were illegal for a Muhrim till it was the Day of Nahr (sacrifice), when he had his head shaved and slaughtered (the sacrifice) and considered sufficient his first Tawaf (between Safa and Marwa), as a (Sa'i) for his Hajj and 'Umra both. He then said, "The Prophet used to do like that."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.767]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 767

Narrated 'Amra bint 'AbdurRahman:

I heard 'Aisha saying, "Five days before the end of Dhul-Qa'ada we set out from Medina in the company of Allah's Apostle with the intention of performing Hajj only. When we approached Mecca, Allah's Apostle ordered those who had no Hadi with them to finish their lhram after performing Tawaf of the Ka'ba and (Sa'i) and between Safa and Marwa." 'Aisha added, "On the day of Nahr (slaughtering of sacrifice) beef was brought to us. I asked, 'What is this?' The reply was, 'Allah's Apostle (p.b.u.h) has slaughtered (sacrifices) on behalf of his wives.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.768]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 768

Narrated Nafi':

'Abdullah (bin 'Umar), used to slaughter (his sacrifice) at the Manhar. ('Ubaidullah, a sub-narrator said, "The Manhar of Allah's Apostle.")


Bukhari :: Pilgrimmage (Hajj) :: [2.26.769]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 769

Narrated Nafi':

Ibn 'Umar used to send his Hadi from Jam' (to Mina) in the last third of the night with the pilgrims amongst whom there were free men and slaves, till it was taken into the Manhar (slaughtering place) of the Prophet .


Bukhari :: Pilgrimmage (Hajj) :: [2.26.770]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 770

Narrated Sahl bin Bakkar:

The narration of Anas abridged, saying, "The Prophet slaughtered seven Budn (camels) while standing, with his own hands. On the day of 'Id-ul-Adha he slaughtered (sacrificed) two horned rams, black and white in color.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.771]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 771

Narrated Zaid bin Jubair:

I saw Ibn 'Umar passing by a man who had made his Badana sit to slaughter it. Ibn 'Umar said, "Slaughter it while it is standing with one leg tied up as is the tradition of Muhammad."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.772]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 772

Narrated Anas :

The Prophet offered four Rakat of Zuhr prayer at Medina; and two Rakat of 'Asr prayer at Dhul-hulaifa and spent the night there and when (the day) dawned, he mounted his Mount and started saying, "None has the right to be worshipped but Allah, and Glorified be Allah." When he reached Al-Baida' he recited Talbiya for both Hajj and 'Umra. And when he arrived at Mecca, he ordered them (his companions) to finish their Ihram. The Prophet slaughtered seven Budn (camel) with his own hands while the camels were standing He also sacrificed two horned rams (black and white in color) at Medina.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.773]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 773

Narrated Anas bin Malik:

The Prophet (p.b.u.h) offered four Rakat of Zuhr prayer at Medina and two Rakat of 'Asr prayer at Dhul-Hulaifa. Narrated Aiyub: "A man said: Anas said, "Then he (the Prophet passed the night there till dawn and then he offered the morning (Fajr) prayer, and mounted his Mount and when it arrived at Al-Baida' he assumed Ihram for both 'Umra and Hajj."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.774]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 774

Narrated 'Ali:

The Prophet sent me to supervise the (slaughtering of) Budn (Hadi camels) and ordered me to distribute their meat, and then he ordered me to distribute their covering sheets and skins. 'All added, "The Prophet ordered me to supervise the slaughtering (of the Budn) and not to give anything (of their bodies) to the butcher as wages for slaughtering."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.775]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 775

Narrated 'Ali:

The Prophet ordered me to supervise the (slaughtering) of Budn (Hadi camel) and to distribute their meat, skins and covering sheets in charity and not to give anything (of their bodies) to the butcher as wages for slaughtering.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.776]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 776

Narrated 'Ali:

The Prophet offered one hundred Budn as Hadi and ordered me to distribute their meat (in charity) and I did so. Then he ordered me to distribute their covering sheets in charity and I did so. Then he ordered me to distribute their skins in charity and I did so.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.777]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 777

Narrated Ibn Juraij:

'Ata' said, "I heard Jabir bin 'Abdullah saying, 'We never ate the meat of the Budn for more than three days of Mina. Later, the Prophet gave us permission by saying: 'Eat and take (meat) with you. So we ate (some) and took (some) with us.' " I asked 'Ata', "Did Jabir say (that they went on eating the meat) till they reached Medina?" 'Ata' replied, "No."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.778]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 778

Narrated 'Amra:

I heard 'Aisha saying, "We set out (from Medina) along with Allah's Apostle five days before the end of Dhul-Qa'da with the intention of performing Hajj only. When we approached Mecca, Allah's Apostle ordered those who had no Hadi along with them to finish the lhram after performing Tawaf of the Ka'ba, (Safa and Marwa). 'Aisha added, "Beef was brought to us on the Day of Nahr and I said, 'What is this?' Somebody said, 'The Prophet has slaughtered (cows) on behalf of his wives.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.779]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 779

Narrated Ibn Abbas:

The Prophet was asked about a person who had his head shaved before slaughtering (his Hadi) (or other similar ceremonies of Hajj). He replied, "There is no harm, there is no harm."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.780]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 780

Narrated Ibn Abbas:

A man said to the Prophet "I performed the Tawaf-al-Ifada before the Rami (throwing pebbles at the Jamra)." The Prophet replied, "There is no harm." The man said, "I had my head shaved before slaughtering." The Prophet replied, "There is no harm." He said, "I have slaughtered the Hadi before the Rami." The Prophet replied, "There is no harm."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.781]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 781

Narrated Ibn Abbas:

The Prophet was asked by a man who said, "I have done the Rami in the evening." The Prophet replied, "There is no harm in it." Another man asked, "I had my head shaved before the slaughtering." The Prophet replied, "There is no harm in it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.782]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 782

Narrated Abu Musa:

came upon Allah's Apostle when he was at Al-Bat-ha. He asked me, "Have you intended to perform the Hajj?" I replied in the affirmative. He asked, "For what have you assumed lhram?" I replied," I have assumed Ihram with the same intention as that of the Prophet ." The Prophet said, "You have done well! Go and perform Tawaf round the Ka'ba and between Safa and Marwa." Then I went to one of the women of Bani Qais and she took out lice from my head. Later, I assumed the Ihram for Hajj. So, I used to give this verdict to the people till the caliphate of 'Umar. When I told him about it, he said, "If we take (follow) the Holy Book, then it orders us to complete Hajj and 'Umra (Hajj-at-Tamattu') and if we follow the tradition of Allah's Apostle then Allah's Apostle did not finish his lhram till the Hadi had reached its destination (had been slaughtered). (i.e. Hajj-al-Qiran). (See Hadith No. 630)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.783]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 783

Narrated Ibn 'Umar:

Hafsa said, "O Allah's Apostle! What is wrong with the people; they finished their Ihram after performing 'Umra, but you have not finished it after your 'Umra?" He replied, "I matted my hair and have garlanded my Hadi. So, I cannot finish my Ihram till I slaughter (my Hadi). "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.784]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 784

Narrated Ibn 'Umar:

Allah's Apostle (p.b.u.h) (got) his head shaved after performing his Hajj.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.785]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 785

Narrated Abdullah bin Umar:

Allah's Apostle said, "O Allah! Be merciful to those who have their head shaved." The people said, "O Allah's Apostle! And (invoke Allah for) those who get their hair cut short." The Prophet said, "O Allah! Be merciful to those who have their head shaved." The people said, "O Allah's Apostle! And those who get their hair cut short." The Prophet said (the third time), "And to those who get their hair cut short." Nafi' said that the Prophet had said once or twice, "O Allah! Be merciful to those who get their head shaved," and on the fourth time he added, "And to those who have their hair cut short."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.786]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 786

Narrated Abu Huraira:

Allah's Apostle said, "O Allah! Forgive those who get their heads shaved." The people asked. "Also those who get their hair cut short?" The Prophet said, "O Allah! Forgive those who have their heads shaved." The people said, "Also those who get their hair cut short?" The Prophet (invoke Allah for those who have their heads shaved and) at the third time said, "also (forgive) those who get their hair cut short."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.787]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 787

Narrated 'Abdullah:

The Prophet and some of his companions got their heads shaved and some others got their hair cut short. Narrated Muawiya: I cut short the hair of Allah's Apostle with a long blade.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.788]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 788

Narrated Ibn Abbas:

When the Prophet came to Mecca, he ordered his Companions to perform Tawaf round the Ka'ba and between Safa and Marwa, to finish their Ihram and get their hair shaved off or cut short.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.789]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 789

Narrated 'Aisha:

We performed Hajj with the Prophet and performed Tawaf-al-ifada on the Day of Nahr (slaughtering). Safiya got her menses and the Prophets desired from her what a husband desires from his wife. I said to him, "O Allah's Apostle! She is having her menses." He said, "Is she going to detain us?" We informed him that she had performed Tawaf-al-Ifada on the Day of Nahr. He said, "(Then you can) depart."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.790]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 790

Narrated Ibn Abbas:

The Prophet was asked about the slaughtering, shaving (of the head), and the doing of Rami before or after the due times. He said, "There is no harm in that."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.791]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 791

Narrated Ibn Abbas:

The Prophet was asked (as regards the ceremonies of Hajj) at Mina on the Day of Nahr and he replied that there was no harm. Then a man said to him, "I got my head shaved before slaughtering." He replied, "Slaughter (now) and there is no harm in it." (Another) man said, "I did the Rami (of the Jimar) after midday." The Prophet replied, "There was no harm in it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.792]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 792

Narrated 'Abdullah bin 'Amr :

Allah's Apostle stopped (for a while near the Jimar at Mina) during his last Hajj and the people started asking him questions. A man said, "Ignorantly I got my head shaved before slaughtering." The Prophet replied, "Slaughter (now) and there is no harm in it." Another man said, "Unknowingly I slaughtered the Hadi before doing the Rami." The Prophet said, "Do Rami now and there is no harm in it." So, on that day, when the Prophet was asked about anything (about the ceremonies of Hajj) done before or after (its stated time) his reply was, "Do it (now) and there is no harm."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.793]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 793

Narrated 'Abdullah bin 'Amr bin Al-'As:

I witnessed the Prophet when he was delivering the sermon on the Day of Nahr. A man stood up and said, "I thought that such and such was to be done before such and such. I got my hair shaved before slaughtering." (Another said), "I slaughtered the Hadi before doing the Rami." So, the people asked about many similar things. The Prophet said, "Do it (now) and there is no harm in all these cases." Whenever the Prophet was asked about anything on that day, he replied, "Do it (now) and there is no harm in it."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.794]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 794

Narrated 'Abdullah bin 'Amr bin Al-'As:

Allah's Apostle stopped while on his she-camel (the subnarrator then narrated the Hadith as above, i.e. 793).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.795]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 795

Narrated 'Ikrima:

Ibn Abbas said: "Allah's Apostle delivered a sermon on the Day of Nahr, and said, 'O people! (Tell me) what is the day today?' The people replied, 'It is the forbidden (sacred) day.' He asked again, 'What town is this?' They replied, 'It is the forbidden (Sacred) town.' He asked, 'Which month is this?' They replied, 'It is the forbidden (Sacred) month.' He said, 'No doubt! Your blood, your properties, and your honor are sacred to one another like the sanctity of this day of yours, in this (sacred) town (Mecca) of yours, in this month of yours.' The Prophet repeated his statement again and again. After that he raised his head and said, 'O Allah! Haven't conveyed (Your Message) to them'. Haven't I conveyed Your Message to them?' " Ibn Abbas added, "By Him in Whose Hand my soul is, the following was his will (Prophet's will) to his followers:--It is incumbent upon those who are present to convey this information to those who are absent Beware don't renegade (as) disbelievers (turn into infidels) after me, Striking the necks (cutting the throats) of one another.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.796]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 796

Narrated Ibn Abbas:

I heard the Prophet delivering a sermon at 'Arafat.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.797]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 797

Narrated Abu Bakra:

The Prophet delivered to us a sermon on the Day of Nahr. He said, "Do you know what is the day today?" We said, "Allah and His Apostle know better." He remained silent till we thought that he might give that day another name. He said, "Isn't it the Day of Nahr?" We said, "It is." He further asked, "Which month is this?" We said, "Allah and His Apostle know better." He remained silent till we thought that he might give it another name. He then said, "Isn't it the month of Dhul-Hijja?" We replied: "Yes! It is." He further asked, "What town is this?" We replied, "Allah and His Apostle know it better." He remained silent till we thought that he might give it another name. He then said, "Isn't it the forbidden (Sacred) town (of Mecca)?" We said, "Yes. It is." He said, "No doubt, your blood and your properties are sacred to one another like the sanctity of this day of yours, in this month of yours, in this town of yours, till the day you meet your Lord. No doubt! Haven't I conveyed Allah's message to you? They said, "Yes." He said, "O Allah! Be witness. So it is incumbent upon those who are present to convey it (this information) to those who are absent because the informed one might comprehend it (what I have said) better than the present audience, who will convey it to him. Beware! Do not renegade (as) disbelievers after me by striking the necks (cutting the throats) of one another."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.798]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 798

Narrated Ibn 'Umar:

At Mina, the Prophet (p.b.u.h) said, "Do you know what is the day today?" The people replied, "Allah and His Apostle know it better." He said, "It is the forbidden (sacred) day. And do you know what town is this?" They replied, "Allah and His Apostle know it better." He said, "This is the forbidden (Sacred) town (Mecca). And do you know which month is this?" The people replied, "Allah and His Apostle know it better." He said, "This is the forbidden (sacred) month." The Prophet added, "No doubt, Allah made your blood, your properties, and your honor sacred to one another like the sanctity of this day of yours in this month of yours in this town of yours." Narrated Ibn 'Umar: On the Day of Nahr (10th of Dhul-Hijja), the Prophet stood in between the Jamrat during his Hajj which he performed (as in the previous Hadith) and said, "This is the greatest Day (i.e. 10th of Dhul-Hijjah)." The Prophet started saying repeatedly, "O Allah! Be Witness (I have conveyed Your Message)." He then bade the people farewell. The people said, "This is Hajjat-al-Wada)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.799]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 799

Narrated Ibn 'Umar:

The Prophet permitted (them).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.800]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 800

Narrated Ibn 'Umar

That the Prophet allowed (as above).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.801]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 801

Narrated Ibn 'Umar:

Al-Abbas asked the permission from the Prophet to stay at Mecca during the nights of Mina in order to provide water to the people, so the Prophet allowed him.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.802]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 802

Narrated Wabra:

I asked Ibn 'Umar, "When should I do the Rami of the Jimar?" He replied, "When your leader does that." I asked him again the same question. He replied, "We used to wait till the sun declined and then we would do the Rami (i.e. on the 11th and 12th of Dhul-Hijja)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.803]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 803

Narrated 'Abdur-Rahman bin Yazid:

'Abdullah, did the Rami from the middle of the valley. So, I said, "O, Abu 'Abdur-Rahman! Some people do the Rami (of the Jamra) from above it (i.e. from the top of the valley)." He said, "By Him except whom none has the right to be worshipped, this is the place from where the one on whom Surat-al-Baqara was revealed (i.e. Allah's Apostle) did the Rami."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.804]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 804

Narrated 'Abdur-Rahman bin Yazid:

When 'Abdullah, reached the big Jamra (i.e. Jamrat-ul-Aqaba) he kept the Ka'ba on the left side and Mina on his right side and threw seven pebbles (at the Jamra) and said, "The one on whom Surat-al-Baqara was revealed (i.e. the Prophet) had done the Rami similarly."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.805]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 805

Narrated 'Abdur-Rahman bin Yazid:

I performed Hajj with Ibn Masud , and saw him doing Rami of the big Jamra (Jamrat-ul-Aqaba) with seven small pebbles, keeping the Ka'ba on his left side and Mina on his right. He then said, "This is the place where the one on whom Surat-al-Baqara was revealed (i.e. Allah's Apostle ) stood."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.806]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 806

Narrated Al-Amash:

I heard Al-Hajjaj saying on the pulpit, "The Sura in which Al-Baqara (the cow) is mentioned and the Sura in which the family of 'Imran is mentioned and the Sura in which the women (An-Nisa) is mentioned." I mentioned this to Ibrahim, and he said, 'Abdur-Rahman bin Yazid told me, 'I was with Ibn Masud, when he did the Rami of the Jamrat-ul-Aqaba. He went down the middle of the valley, and when he came near the tree (which was near the Jamra) he stood opposite to it and threw seven small pebbles and said: 'Allahu-Akbar' on throwing every pebble.' Then he said, 'By Him, except Whom none has the right to be worshipped, here (at this place) stood the one on whom Surat-al-Baqra was revealed (i.e. Allah's Apostle).' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.807]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 807

Narrated Salim:

Ibn 'Umar used to do Rami of the Jamrat-ud-Dunya (the Jamra near to the Khaif mosque) with seven small stones and used to recite Takbir on throwing every pebble. He then would go ahead till he reached the level ground where he would stand facing the Qibla for a long time to invoke (Allah) while raising his hands (while invoking). Then he would do Rami of the Jamrat-ul-Wusta (middle Jamra) and then he would go to the left towards the middle ground, where he would stand facing the Qibla. He would remain standing there for a long period to invoke (Allah) while raising his hands, and would stand there for a long period. Then he would do Rami of the Jamrat-ul-Aqaba from the middle of the valley, but he would not stay by it, and then he would leave and say, "I saw the Prophet doing like this."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.808]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 808

Narrated Salim bin Abdullah:

'Abdullah bin 'Umar used to do Rami of the Jamrat-ud-Dunya with seven small pebbles and used to recite Takbir on throwing each stone. He, then, would proceed further till he reached the level ground, where he would stay for a long time, facing the Qibla to invoke (Allah) while raising his hands. Then he would do Rami of the Jamrat-ul-Wusta similarly and would go to the left towards the level ground, where he would stand for a long time facing the Qibla to invoke (Allah) while raising his hands. Then he would do Rami of the Jamrat-ul-'Aqaba from the middle of the valley, but he would not stay by it. Ibn 'Umar used to say, "I saw Allah's Apostle doing like that."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.809]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 809

Narrated 'Abdur-Rahman bin Al-Qasim:

I heard my father who was the best man of his age, saying, "I heard 'Aisha saying, 'I perfumed Allah's Apostle with my own hands before finishing his Ihram while yet he has not performed Tawaf-al-Ifada.' She spread her hands (while saying so.)"


Bukhari :: Pilgrimmage (Hajj) :: [2.26.810]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 810

Narrated Ibn Abbas:

The people were ordered to perform the Tawaf of the Ka'ba (Tawaf-al-Wada') as the lastly thing, before leaving (Mecca), except the menstruating women who were excused.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.811]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 811

Narrated Anas bin Malik:

The Prophet offered the Zuhr, 'Asr, Maghrib and the 'Isha' prayers and slept for a while at a place called Al-Mahassab and then rode to the Ka'ba and performed Tawaf round it .


Bukhari :: Pilgrimmage (Hajj) :: [2.26.812]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 812

Narrated 'Aisha:

Safiya bint Huyay, the wife of the Prophet got her menses, and Allah's Apostle was informed of that. He said, "Would she delay us?" The people said, "She has already performed Tawaf-al-Ifada." He said, "Therefore she will not (delay us)."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.813]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 813

Narrated 'Ikrima:

The people of Medina asked Ibn Abbas about a woman who got her menses after performing Tawaf-al-Ifada. He said, "She could depart (from Mecca)." They said, "We will not act on your verdict and ignore the verdict of Zaid." Ibn Abbas said, "When you reach Medina, inquire about it." So, when they reached Medina they asked (about that). One of those whom they asked was Um Sulaim. She told them the narration of Safiya (812).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.814]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 814

Narrated Ibn Abbas:

A menstruating woman was allowed to leave Mecca if she had done Tawaf-al-Ifada. Tawus (a sub-narrator) said from his father, "I heard Ibn 'Umar saying that she would not depart. Then later I heard him saying that the Prophet had allowed them (menstruating women) to depart."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.815]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 815

Narrated 'Aisha:

We set out with the Prophet with the intention of performing Hajj only. The Prophet reached Mecca and performed Tawaf of the Ka'ba and between Safa and Marwa and did not finish the Ihram, because he had the Hadi with him. His companions and his wives performed Tawaf (of the Ka'ba and between Safa and Marwa), and those who had no Hadi with them finished their Ihram. I got the menses and performed all the ceremonies of Hajj. So, when the Night of Hasba (night of departure) came, I said, "O Allah's Apostle! All your companions are returning with Hajj and 'Umra except me." He asked me, "Didn't you perform Tawaf of the Ka'ba (Umra) when you reached Mecca?" I said, "No." He said, "Go to Tan'im with your brother 'Abdur-Rahman, and assume Ihram for 'Umra and I will wait for you at such and such a place." So I went with 'Abdur-Rahman to Tan'im and assumed Ihram for 'Umra. Then Safiya bint Huyay got menses. The Prophet said, " 'Aqra Halqa! You will detain us! Didn't you perform Tawaf-al-Ifada on the Day of Nahr (slaughtering)?" She said, "Yes, I did." He said, "Then there is no harm, depart." So I met the Prophet when he was ascending the heights towards Mecca and I was descending, or vice-versa.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.816]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 816

Narrated 'Abdul-Aziz bin Rufai:

I asked Anas bin Malik, "Tell me something you have observed about the Prophet concerning where he offered the Zuhr prayer on the Day of Tarwiya (8th Dhul-Hijja)." Anas replied, "He offered it at Mina." I said, "Where did he offer the Asr prayer on the Day of Nafr (day of departure from Mina)?" He replied, "At Al-Abtah," and added, "You should do as your leaders do."


Bukhari :: Pilgrimmage (Hajj) :: [2.26.817]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 817

Narrated Anas bin Malik:

The Prophet offered the Zuhr, 'Asr, Maghrib and 'Isha' prayers and slept for a while at a place called Al-Mahassab and then he rode towards the Ka'ba and performed Tawaf (al-Wada').


Bukhari :: Pilgrimmage (Hajj) :: [2.26.818]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 818

Narrated 'Aisha:

It (i.e. Al-Abtah) was a place where the Prophet used to camp so that it might be easier for him to depart.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.819]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 819

Narrated Ibn Abbas:

Staying at Al-Mahassab is not one of the ceremonies (of Hajj), but Al-Mahassab is a place where Allah's Apostle camped (during his Hajjat-ul-wida).


Bukhari :: Pilgrimmage (Hajj) :: [2.26.820]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 820

Narrated Nafi:

Ibn 'Umar used to spend the night at Dhi-Tuwa in between the two Thaniyas and then he would enter Mecca through the Thaniya which is at the higher region of Mecca, and whenever he came to Mecca for Hajj or 'Umra, he never made his she camel kneel down except near the gate of the Masjid (Sacred Mosque) and then he would enter (it) and go to the Black (stone) Corner and start from there circumambulating the Ka'ba seven times: hastening in the first three rounds (Ramal) and walking in the last four. On finishing, he would offer two Rakat prayer and set out to perform Tawaf between Safa and Marwa before returning to his dwelling place. On returning (to Medina) from Hajj or 'Umra, he used to make his camel kneel down at Al-Batha which is at Dhu-l-Hulaifa, the place where the Prophet used to make his camel kneel down.


Bukhari :: Pilgrimmage (Hajj) :: [2.26.821]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 821

Narrated Khalid bin Al-Harith:

'Ubaidullah was asked about Al Mahassab. 'Ubaidullah narrated: Nafi' said, 'Allah's Apostles, 'Umar and Ibn 'Umar camped there." Nafi' added, "Ibn 'Umar used to offer the Zuhr and 'Asr prayers at it (i.e. Al-Mahassab)." I think he mentioned the Maghrib prayer also. I said, "I don't doubt about 'Isha' (i.e. he used to offer it there also), and he used to sleep there for a while. He used to say, 'The Prophet used to do the same.' "


Bukhari :: Pilgrimmage (Hajj) :: [2.26.822]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 822

Narrated Ibn ' Abbas :

Dhul-Majaz and 'Ukaz were the markets of the people during the pre-lslamic period of ignorance. When the people embraced Islam, they disliked to do bargaining there till the following Holy Verses were revealed:-- There is no harm for you If you seek of the bounty Of your Lord (during Hajj by trading, etc.) (2.198)


Bukhari :: Pilgrimmage (Hajj) :: [2.26.823]

Pilgrimmage (Hajj)

Bukhari :: Book 2 :: Volume 26 :: Hadith 823

Narrated ' Aisha:

Safiya got her menses on the night of Nafr (departure from Hajj), and she said, "I see that I will detain you." The Prophet said, "Aqra Halqa! Did she perform the Tawaf on the Day of Nahr (slaughtering)?" Somebody replied in the affirmative. He said, "Then depart." (Different narrators mentioned that) 'Aisha said, "We set out with Allah's Apostle (from Medina) with the intention of performing Hajj only. When we reached Mecca, he ordered us to finish the Ihram. When it was the night of Nafr (departure), Safiya bint Huyay got her menses. The Prophet said, "Halqa Aqra! I think that she will detain you," and added, "Did you perform the Tawaf (Al-Ifada) on the Day of Nahr (slaughtering)?" She replied, "Yes." He said, "Then depart." I said, "O Allah's Apostle! I have not (done the Umra)." He replied, "Perform 'Umra from Tan'im." My brother went with me and we came across the Prophet in the last part of the night. He said, "Wait at such and such a place."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.1]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 1

Narrated Abu Huraira:

Allah's Apostle said, "(The performance of) 'Umra is an expiation for the sins committed (between it and the previous one). And the reward of Hajj Mabrur (the one accepted by Allah) is nothing except Paradise."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.2]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 2

Narrated Ibn Juraij:

Ikrima bin Khalid asked Ibn 'Umar about performing 'Umra before Hajj. Ibn 'Umar replied, "There is no harm in it." 'Ikrima said, "Ibn 'Umar also said, 'The Prophet had performed 'Umra before performing Hajj.'"


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.3]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 3

Narrated 'Ikrima bin Khalid:

"I asked Ibn 'Umar the same (as above)."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.4]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 4

Narrated Mujahid:

Ursa bin AzZubair and I entered the Mosque (of the Prophet) and saw 'Abdullah bin Umar sitting near the dwelling place of Aisha and some people were offering the Duha prayer. We asked him about their prayer and he replied that it was a heresy. He (Ursa) then asked him how many times the Prophet had performed 'Umra. He replied, 'Four times; one of them was in the month of Rajab." We disliked to contradict him. Then we heard 'Aisha, the Mother of faithful believers cleaning her teeth with Siwak in the dwelling place. 'Ursa said, "O Mother! O Mother of the believers! Don't you hear what Abu 'Abdur Rahman is saying?" She said, "What does he say?" 'Ursa said, "He says that Allah's Apostle performed four 'Umra and one of them was in the month of Rajab." 'Aisha said, "May Allah be merciful to Abu 'Abdur Rahman! The Prophet did not perform any 'Umra except that he was with him, and he never performed any 'Umra in Rajab."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.5]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 5

Narrated 'Ursa bin Az-Zubair:

I asked 'Aisha (whether the Prophet had performed 'Umra in Rajab). She replied, "Allah's Apostle never performed any 'Umra in Rajab."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.6]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 6

Narrated Qatada:

I asked Anas how many times the Prophet had performed 'Umra. He replied, "Four times. 1. 'Umra of Hudaibiya in Dhi-l-Qa'da when the pagans hindered him; 2. 'Umra in the following year in Dhi-l-Qa'da after the peace treaty with them (the pagans); 3. 'Umra from Al-Jr'rana where he distributed the war booty." I think he meant the booty (of the battle) of Hunain. I asked, "How many times did he perform Hajj?" He (Anas) replied, "Once. "


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.7]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 7

Narrated Qatada:

I asked Anas (about the Prophet's 'Umra) and he replied, "The Prophet performed 'Umra when the pagans made him return, and Umra of al-Hudaibiya (the next year), and another 'Umra in Dhi-l-Qa'da, and another 'Umra in combination with his Hajj."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.8]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 8

Narrated Hammam:

The Prophet performed four 'Umra (three) in Dhi-l-Qa'da except the (one) 'Umra which he performed with his Hajj: His 'Umra from Al-hudaibiya, and the one of the following year, and the one from Al-Jr'rana where he distributed the booty (of the battle) of Hunain, and another 'Umra with his Hajj.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.9]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 9

Narrated Abu Ishaq:

I asked Masruq, 'Ata' and Mujahid (about the 'Umra of Allah's Apostle). They said, "Allah's Apostle had performed 'Umra in Dhi-l-Qa'da before he performed Hajj." I heard Al-Bara' bin 'Azib saying, "Allah's Apostle had performed 'Umra in Dhi-l-Qa'da twice before he performed Hajj."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.10]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 10

Narrated Ata:

I heard Ibn 'Abbas saying, "Allah's Apostle asked an Ansari woman (Ibn 'Abbas named her but 'Ata' forgot her name), 'What prevented you from performing Hajj with us?' She replied, 'We have a camel and the father of so-and-so and his son (i.e. her husband and her son) rode it and left one camel for us to use for irrigation.' He said (to her), 'Perform 'Umra when Ramadan comes, for 'Umra in Ramadan is equal to Hajj (in reward),' or said something similar."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.11]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 11

Narrated Aisha:

We set out along with Allah's Apostle shortly before the appearance of the new moon (crescent) of the month of Dhi-l-Hijja and he said to us, "Whoever wants to assume Ihram for Hajj may do so; and whoever wants to assume Ihram for 'Umra may do so. Hadn't I brought the Hadi (animal for sacrificing) (with me), I would have assumed Ihram for 'Umra." ('Aisha added,): So some of us assumed Ihram for 'Umra while the others for Hajj. I was amongst those who assumed Ihram for 'Umra. The day of 'Arafat approached and I was still menstruating. I complained to the Prophet (about that) and he said, "Abandon your 'Umra, undo and comb your hair, and assume Ihram for Hajj;." When it was the night of Hasba, he sent 'Abdur Rahman with me to At-Tan'im and I assumed Ihram for 'Umra (and performed it) in lieu of my missed 'Umra.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.12]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 12

Narrated 'Amr bin Aus:

Abdul Rahman bin Abu Bakr told me that the Prophet had ordered him to let 'Aisha ride behind him and to make he perform 'Umra from At-Tan'im.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.13]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 13

Narrated Jabir bin 'Abdullah:

The Prophet and his companions assumed Ihram for Hajj and none except the Prophet and Talha had the Hadi with them. 'Ali had come from Yemen and he had the Hadi with him. He ('Ali) said, "I have assumed Ihram with an intention like that of Allah's Apostle has assumed it." The Prophet ordered his companions to intend the Ihram with which they had come for 'Umra, to perform the Tawaf of the Ka'ba (and between Safa and Marwa), to get their hair cut short and then to finish their Ihram with the exception of those who had the Hadi with them. They asked, "Shall we go to Mina and the private organs of some of us are dribbling (if we finish Ihram and have sexual relations with our wives)?" The Prophet heard that and said, "Had I known what I know now, I would not have brought the Hadi. If I did not have the Hadi with me I would have finished my Ihram." 'Aisha got her menses and performed all the ceremonies (of Hajj) except the Tawaf . So when she became clean from her menses, and she had performed the Tawaf of the Ka'ba, she said, "O Allah's Apostle! You (people) are returning with both Hajj and 'Umra and I am returning only with Hajj!" So, he ordered 'Abdur Rahman bin Abu Bakr to go with her to At-Tan'im. Thus she performed 'Umra after the Hajj in the month of Dhi-l-Hijja. Suraqa bin Malik bin Ju'sham met the Prophet at Al-'Aqaba (Jamrat-ul 'Aqaba) while the latter was stoning it and said, "O Allah's Apostle! Is this permissible only for you?" The Prophet replied, "No, it is for ever (i.e. it is permissible for all Muslims to perform 'Umra before Hajj."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.14]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 14

Narrated 'Aisha:

We set out with Allah's Apostle shortly before the appearance of the new moon of Dhi-l-Hiija and he said, "Whoever wants to assume Ihram for 'Umra may do so, and whoever wants to assume Ihram for Hajj may do so. Had not I brought the Hadi with me, I would have assumed Ihram for 'Umra." Some of the people assumed Ihram for 'Umra while others for Hajj. I was amongst those who had assumed Ihram for 'Umra. I got my menses before entering Mecca, and was menstruating till the day of 'Arafat. I complained to Allah's Apostle about it, he said, "Abandon your 'Umra, undo and comb your hair, and assume Ihram for Hajj." So, I did that accordingly. When it was the night of Hasba (day of departure from Mina), the Prophet sent 'Abdur Rahman with me to At-Tanim.

The sub-narrator adds: He ('AbdurRahman) let her ride behind him. And she assumed Ihram for 'Umra in lieu of the abandoned one. Aisha completed her Hajj and 'Umra, and no Hadi, Sadaqa (charity), or fasting was obligatory for her.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.15]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 15

Narrated Al-Aswad:

That 'Aisha said, "O Allah's Apostle! The people are returning after performing the two Nusuks (i.e. Hajj and 'Umra) but I am returning with one only?" He said, "Wait till you become clean from your menses and then go to At-Tan'im, assume Ihram (and after performing 'Umra) join us at such-and-such a place. But it (i.e. the reward if 'Umra) is according to your expenses or the hardship (which you will undergo while performing it)."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.16]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 16

Narrated 'Aisha:

We set out assuming the Ihram for Hajj in the months of Hajj towards the sacred precincts of Hajj. We dismounted at Sarif and the Prophet said to his companions, "Whoever has not got the Hadi with him and likes to make it as 'Umra, he should do it, but he who has got the Hadi with him should not do it." The Prophet and some of his wealthy companions had the Hadi with them, so they did not finish Ihram after performing the 'Umra. The Prophet came to me while I was weeping. He asked me the reason for it. I replied, "I have heard of what you have said to your companions and I cannot do the 'Umra." He asked me, "What is the matter with you?" I replied, "I am not praying." He said, "There is no harm in it as you are one of the daughters of Adam and the same is written for you as for others. So, you should perform Hajj and I hope that Allah will enable you to perform the 'Umra as well." So, I carried on till we departed from Mina and halted at Al-Mahassab. The Prophet called 'Abdur-Rahman and said, "Go out of the sanctuary with your sister and let her assume Ihram for 'Umra, and after both of you have finished the Tawaf I will be waiting for you at this place." We came back at mid-night and the Prophet asked us, "Have you finished?" I replied in the affirmative. He announced the departure and the people set out for the journey and some of them had performed the Tawaf of the Ka'ba before the morning prayer, and after that the Prophet set out for Medina.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.17]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 17

Narrated Safwan bin Ya'la bin Umaiya from his father who said:

"A man came to the Prophet while he was at Ji'rana. The man was wearing a cloak which had traces of Khaluq or Sufra (a kind of perfume). The man asked (the Prophet ), 'What do you order me to perform in my 'Umra?' So, Allah inspired the Prophet divinely and he was screened by a place of cloth. I wished to see the Prophet being divinely inspired. 'Umar said to me, 'Come! Will you be pleased to look at the Prophet while Allah is inspiring him?' I replied in the affirmative. 'Umar lifted one corner of the cloth and I looked at the Prophet who was snoring. (The sub-narrator thought that he said: The snoring was like that of a camel). When that state was over, the Prophet asked, "Where is the questioner who asked about 'Umra? Put off your cloak and wash away the traces of Khaluq from your body and clean the Sufra (yellow color) and perform in your Umra what you perform in your Hajj (i.e. the Tawaf round the Ka'ba and the Sa'i between Safa and Marwa). "


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.18]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 18

Narrated Hisham Ibn 'Urwa from his father who said:

While I was a youngster, I asked 'Aisha the wife of the Prophet. "What about the meaning of the Statement of Allah;

"Verily! (the mountains) As-Safa and Al Marwa, are among the symbols of Allah. So, it is not harmful if those who perform Hajj or 'Umra of the House (Ka'ba at Mecca) to perform the going (Tawaf) between them? (2.158) I understand (from that) that there is no harm if somebody does not perform the Tawaf between them." 'Aisha replied, "No, for if it were as you are saying, then the recitation would have been like this: 'It is not harmful not to perform Tawaf between them.' This verse was revealed in connection with the Ansar who used to assume the Ihram for the idol Manat which was put beside a place called Qudaid and those people thought it not right to perform the Tawaf of As-Safa and Al-Marwa. When Islam came, they asked Allah's Apostle about that, and Allah revealed:--

"Verily! (the mountains) As-Safa and Al-Marwa Are among the symbols of Allah. So, it is not harmful of those who perform Hajj or 'Umra of the House (Ka'ba at Mecca) to perform the going (Tawaf) between them." (2.158) Sufyan and Abu Muawiya added from Hisham (from 'Aisha): "The Hajj or 'Umra of the person who does not perform the going (Tawaf) between As-Safa and Al-Marwa is incomplete in Allah's sight.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.19]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 19

Narrated Isma'il:

Abdullah bin Abu Aufa said: "Allah's Apostle performed 'Umra and we too performed 'Umra along with him. When he entered Mecca he performed the Tawaf (of Ka'ba) and we too performed it along with him, and then he came to the As-Safa and Al-Marwa (i.e. performed the Sai) and we also came to them along with him. We were shielding him from the people of Mecca lest they may hit him with an arrow." A friend of his asked him (i.e. 'Abdullah bin Aufa), "Did the Prophet enter the Ka'ba (during that 'Umra)?" He replied in the negative. Then he said, "What did he (the Prophet ) say about Khadija?" He (Abdullah bin Aufa) said, "(He said) 'Give Khadija the good tidings that she will have a palace made of Qasab in Paradise and there will be neither noise nor any trouble in it."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.20]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 20

Narrated 'Amr bin Dinar:

We asked Ibn 'Umar whether a man who had performed the Tawaf of the Ka'ba but had not performed the Tawaf between As-Safa and Al-Marwa yet, was permitted to have sexual relation with his wife. He replied, "The Prophet arrived (at Mecca) and circumambulated the Ka'ba seven times and then offered a two Rak'at prayer behind Maqam-lbrahim and then performed the going (Tawaf) between As-Safa and Al-Marwa (seven times) (and verily, in Allah's Apostle you have a good example." And we asked Jabir bin 'Abdullah (the same question) and he replied, "He should not go near her till he has finished the going (Tawaf) between As-Safa and Al-Marwa."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.21]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 21

Narrated Abu Musa Al-Ashari:

I came to the Prophet at Al-Batha' while his camel was kneeling down and he asked me, "Have you intended to perform the Hajj?" I replied in the affirmative. He asked me, 'With what intention have you assumed Ihram?" I replied, "I have assumed Ihram with the same intention as that of the Prophet. He said, "You have done well. Perform the Tawaf of the Ka'ba and (the Sai) between As-safa and Al-Marwa and then finish the Ihram." So, I performed the Tawaf around the Ka'ba and the Sai) between As-Safa and Al-Marwa and then went to a woman of the tribe of Qais who cleaned my head from lice. Later I assumed the Ihram for Hajj. I used to give the verdict of doing the same till the caliphate of 'Umar who said, "If you follow the Holy Book then it orders you to remain in the state of Ihram till you finish from Hajj, if you follow the Prophet then he did not finish his Ihram till the Hadi (sacrifice) had reached its place of slaughtering (Hajj-al-Qiran)."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.22]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 22

Narrated Al-Aswad:

Abdullah the slave of Asma bint Abu Bakr, told me that he used to hear Asma', whenever she passed by Al-Hajun, saying, "May Allah bless His Apostle Muhammad. Once we dismounted here with him, and at that time we were traveling with light luggage; we had a few riding animals and a little food ration. I, my sister, 'Aisha, Az-Zubair and such and such persons performed 'Umra, and when we had passed our hands over the Ka'ba (i.e. performed Tawaf round the Ka'ba and between As-Safa and Al-Marwa) we finished our lhram. Later on we assumed Ihram for Hajj the same evening."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.23]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 23

Narrated 'Abdullah bin 'Umar:

Whenever Allah's Apostle returned from a Ghazwa, Hajj or 'Umra, he used to say Takbir thrice at every elevation of the ground and then would say, "None has the right to be worshipped but Allah; He is One and has no partner. All the kingdoms is for Him, and all the praises are for Him, and He is Omnipotent. We are returning with repentance, worshipping, prostrating, and praising our Lord. He has kept up His promise and made His slave victorious, and He Alone defeated all the clans of (non-believers)."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.24]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 24

Narrated Ibn Abbas:

When the Prophet arrived at Mecca, some boys of the tribe of Bani 'Abdul Muttalib went to receive him, and the Prophet made one of them ride in front of him and the other behind him.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.25]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 25

Narrated Ibn Umar:

Whenever Allah's Apostle left for Mecca, he used to pray in the mosque of Ash-Shajra, and when he returned (to Medina), he used to pray in the middle of the valley of Dhul-Hulaifa and used to pass the night there till morning.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.26]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 26

Narrated Anas: The Prophet never returned to his family from a journey at night. He


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.27]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 27

Narrated Jabir: The Prophet forbade going to one's family at night (on arrival from a


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.28]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 28

Narrated Humaid:

Anas said, "Whenever Allah's Apostle returned from a journey, he, on seeing the high places of Medina, would make his she-camel proceed faster; and if it were another animal, even then he used to make it proceed faster."

Narrated Humaid that the Prophet used to make it proceed faster out of his love for Medina.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.29]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 29

Narrated Anas:

As above, but mentioned "the walls of Medina" instead of "the high places of Medina. Al-Harith bin Umar agrees with Anas.


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.30]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 30

Narrated Abu Ishaq:

I heard Al-Bara' saying, "The above Verse was revealed regarding us, for the Ansar on returning from Hajj never entered their houses through the proper doors but from behind. One of the Ansar came and entered through the door and he was taunted for it. Therefore, the following was revealed: --

"It is not righteousness That you enter the houses from the back, But the righteous man is He who fears Allah, Obeys His order and keeps away from What He has forbidden So, enter houses through the proper doors." (2.189)


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.31]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 31

Narrated Abu Huraira:

The Prophet said, "Traveling is a kind of torture as it prevents one from eating, drinking and sleeping properly. So, when one's needs are fulfilled, one should return quickly to one's family."


Bukhari :: Minor Pilgrammage (Umra) :: [3.27.32]

Minor Pilgrammage (Umra)

Bukhari :: Book 3 :: Volume 27 :: Hadith 32

Narrated Zaid bin Aslam from his father:

I was with Ibn 'Umar on the way to Mecca, and he got the news that Safiya bint Abu Ubaid was seriously ill. So, he hastened his pace, and when the twilight disappeared, he dismounted and offered the Maghrib and 'Isha' prayers together. Then he said, "I saw that whenever the Prophet had to hasten when traveling, he would delay the Maghrib prayer and join them together (i.e. offer the Maghrib and the Isha prayers together)."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.33]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 33

Narrated Nafi:

When Abdullah bin Umar set out for Mecca intending to perform Umra, at the time of afflictions, he said, "If I should be prevented from reaching the Kaba, then I would do the same as Allah's Apostle did, so I assume the lhram for Umra as Allah's Apostle assumed the Ihram for Umra in the year of Hudaibiya."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.34]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 34

Narrated Nafi:

That Ubaidullah bin 'Abdullah and Salim bin 'Abdullah informed him that they told Ibn 'Umar when Ibn Az-Zubair was attacked by the army, saying "There is no harm for you if you did not perform Hajj this year. We are afraid that you may be prevented from reaching the Kaba." Ibn 'Umar said "We set out with Allah's Apostle and the non-believers of Quraish prevented us from reaching the Ka'ba, and so the Prophet slaughtered his Hadi and got his head shaved." Ibn 'Umar added, "I make you witnesses that I have made 'Umra obligatory for me. And, Allah willing, I will go and then if the way to Ka'ba is clear, I will perform the Tawaf, but if I am prevented from going to the Ka'ba then I will do the same as the Prophet did while I was in his company." Ibn 'Umar then assumed Ihram for Umra from Dhul-Hulaifa and proceeded for a while and said, "The conditions of 'Umra and Hajj are similar and I make you witnesses that I have made 'Umra and Hajj obligatory for myself." So, he did not finish the Ihram till the day of Nahr (slaughtering) came, and he slaughtered his Hadi. He used to say, "I will not finish the Ihram till I perform the Tawaf, one Tawaf on the day of entering Mecca (i.e. of Safa and Marwa for both 'Umra and Hajj)."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.35]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 35

Narrated Nafi: Some of the sons of 'Abdullah told him (i.e. 'Abdullah) if he had sta


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.36]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 36

Narrated Ibn 'Abbas:

Allah's Apostle was prevented from performing ('Umra) Therefore, he shaved his head and had sexual relations with his wives and slaughtered his Hadi and performed Umra in the following year.


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.37]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 37

Narrated Salim:

(Abdullah) bin 'Umar used to say, "Is not (the following of) the tradition of Allah's Apostle sufficient for you? If anyone of you is prevented from performing Hajj, he should perform the Tawaf of the Ka'ba and between As-Safa and Al-Marwa and then finish the Ihram and everything will become legal for him which was illegal for him (during the state of Ihram) and he can perform Hajj in a following year and he should slaughter a Hadi or fast in case he cannot afford the Hadi."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.38]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 38

Narrated Al-Miswar:

Allah's Apostle slaughtered (the Hadi) before he had his head shaved and then he ordered his Companions to do the same.


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.39]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 39

Narrated Nafi:

That Abdullah and Salim said to 'Abdullah bin 'Umar, "(You should not go for Hajj this year)." 'Abdullah bin 'Umar replied, "We set out with the Prophet (to Mecca for performing 'Umra) and e infidels of Quraish prevented us from reaching the Ka'ba. Allah's Apostle slaughtered his Budn (camels for sacrifice) and got his head shaved."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.40]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 40

Narrated Nafi:

When Abdullah bin 'Umar set out for Mecca with the intentions performing 'Umra in the period of afflictions, he said, "If I should be prevented from reaching the Ka'ba, then I would do the same as we did while in the company of Allah's Apostle ." So, he assumed the Ihram for 'Umra since the Prophet had assumed the Ihram for 'Umra in the year of Al-Hudaibiya. Then 'Abdullah bin 'Umar thought about it and said, "The conditions for both Hajj and 'Umra are similar." He then turned towards his companions and said, "The conditions of both Hajj and 'Umra are similar and I make you witnesses that I have made the performance of Hajj obligatory for myself along with 'Umra." He then performed one Tawaf (between As-Safa and Al-Marwa) for both of them (i.e. Hajj and ('Umra) and considered that to be sufficient for him and offered a Hadi.


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.41]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 41

Narrated 'Abdur-Rahman bin Abu Layla:

Ka'b bin 'Ujra said that Allah's Apostle said to him (Ka'b), "Perhaps your lice have troubled you?" Ka'b replied, "Yes! O Allah's Apostle." Allah's Apostle said, "Have your head shaved and then either fast three days or feed six poor persons or slaughter one sheep as a sacrifice."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.42]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 42

Narrated Ka'b bin 'Umra:

Allah's Apostle stood beside me at Al-Hudaibiya and the lice were falling from my head in great number. He asked me, "Have your lice troubled you?" I replied in the affirmative. He ordered me to get my head shaved. Ka'b added, "This Holy Verse:--'And if any of you is ill, or has ailment in his scalp (2.196), etc. was revealed regarding me. "The Prophet then ordered me either to fast three days, or to feed six poor persons with one Faraq (three Sas) (of dates), or to slaughter a sheep, etc (sacrifice) whatever was available.


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.43]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 43

Narrated 'Abdullah bin Ma'qal:

I sat with Ka'b bin 'Ujra and asked him about the Fidya. He replied, "This revelation was revealed concerning my case especially, but it is also for you in general. I was carried to Allah's Apostle and the lice were falling in great number on my face. The Prophet said, "I have never thought that your ailment (or struggle) has reached to such an extent as I see. Can you afford a sheep?" I replied in the negative. He then said, "Fast for three days, or feed six poor persons each with half a Sa of food." (1 Sa = 3 Kilograms approx.)


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.44]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 44

Narrated Abdur-Rahman bin Abu Layla:

(Reporting the speech of Ka'b bin Umra) Allah's Apostle saw him (i.e. Ka'b) while the lice were falling on his face. He asked (him), "Have your lice troubled you?" He replied in the affirmative. So, he ordered him to get his head shaved while he was at Al-Hudaibiya. At that time they were not permitted to finish their Ihram, and were still hoping to enter Mecca. So, Allah revealed the verses of Al-Fidya. Allah's Apostle ordered him to feed six poor persons with one Faraq of food or to slaughter one sheep (as a sacrifice) or to fast for three days.


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.45]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 45

Narrated Abu Huraira:

Allah's Apostle said, "Whoever performs Hajj to this House (Ka'ba) and does not approach his wife for sexual relations nor commits sins (while performing Hajj), he will come out as sinless as a newly-born child. (Just delivered by his mother)."


Bukhari :: Pilgrims Prevented from Completing the Pilgrimmage :: [3.28.46]

Pilgrims Prevented from Completing the Pilgrimmage

Bukhari :: Book 3 :: Volume 28 :: Hadith 46

Narrated Abu Huraira:

The Prophet said, "Whoever performs Hajj to this Ka'ba and does not approach his wife for sexual relations nor commit sins (while performing Hajj), he will come out as sinless as a new-born child, (just delivered by his mother)."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.47]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 47

Narrated 'Abdullah bin Abu Qatada:

My father set out (for Mecca) in the year of Al-Hudaibiya, and his companions assumed Ihram, but he did not. At that time the Prophet was informed that an enemy wanted to attack him, so the Prophet proceeded onwards. While my father was among his companions, some of them laughed among themselves. (My father said), "I looked up and saw an onager. I attacked, stabbed and caught it. I then sought my companions' help but they refused to help me. (Later) we all ate its meat. We were afraid that we might be left behind (separated) from the Prophet so I went in search of the Prophet and made my horse to run at a galloping speed at times and let it go slow at an ordinary speed at other times till I met a man from the tribe of Bani Ghifar at midnight. I asked him, "Where did you leave the Prophet ?" He replied, "I left him at Ta'hun and he had the intention of having the midday rest at As-Suqya. I followed the trace and joined the Prophet and said, 'O Allah's Apostle! Your people (companions) send you their compliments, and (ask for) Allah's Blessings upon you. They are afraid lest they may be left behind; so please wait for them.' I added, 'O Allah's Apostle! I hunted an onager and some of its meat is with me. The Prophet told the people to eat it though all of them were in the state of Ihram."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.48]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 48

Narrated 'Abdullah bin Abu Qatada:

That his father said "We proceeded with the Prophet in the year of Al-Hudaibiya and his companions assumed Ihram but I did not. We were informed that some enemies were at Ghaiqa and so we went on towards them. My companions saw an onager and some of them started laughing among themselves. I looked and saw it. I chased it with my horse and stabbed and caught it. I wanted some help from my companions but they refused. (I slaughtered it all alone). We all ate from it (i.e. its meat). Then I followed Allah's Apostle lest we should be left behind. At times I urged my horse to run at a galloping speed and at other times at an ordinary slow speed. On the way I met a man from the tribe of Bani Ghifar at midnight. I asked him where he had left Allah's Apostle . The man replied that he had left the Prophet at a place called Ta'hun and he had the intention of having the midday rest at As-Suqya. So, I followed Allah's Apostle till I reached him and said, "O Allah's Apostle! I have been sent by my companions who send you their greetings and compliments and ask for Allah's Mercy and Blessings upon you. They were afraid lest the enemy might intervene between you and them; so please wait for them." So he did. Then I said, "O Allah's Apostle! We have hunted an onager and have some of it (i.e. its meat) left over." Allah's Apostle told his companions to eat the meat although all of them were in a state of Ihram."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.49]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 49

Narrated Abu Qatada:

We were in the company of the Prophet at a place called Al-Qaha (which is at a distance of three stages of journey from Medina). Abu Qatada narrated through another group of narrators: We were in the company of the Prophet at a place called Al-Qaha and some of us had assumed Ihram while the others had not. I noticed that some of my companions were watching something, so I looked up and saw an onager. (I rode my horse and took the spear and whip) but my whip fell down (and I asked them to pick it up for me) but they said, "We will not help you by any means as we are in a state of Ihram." So, I picked up the whip myself and attacked the onager from behind a hillock and slaughtered it and brought it to my companions. Some of them said, "Eat it." While some others said, "Do not eat it." So, I went to the Prophet who was ahead of us and asked him about it, He replied, "Eat it as it is Halal (i.e. it is legal to eat it)."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.50]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 50

Narrated 'Abdullah bin Abu Qatada:

That his father had told him that Allah's Apostle set out for Hajj and so did his companions. He sent a batch of his companions by another route and Abu Qatada was one of them. The Prophet said to them, "Proceed along the sea-shore till we meet all together." So, they took the route of the sea-shore, and when they started all of them assumed Ihram except Abu Qatada. While they were proceeding on, his companions saw a group of onagers. Abu Qatada chased the onagers and attacked and wounded a she-onager. They got down and ate some of its meat and said to each other: "How do we eat the meat of the game while we are in a state of Ihram?" So, we (they) carried the rest of the she-onager's meat, and when they met Allah's Apostle they asked, saying, "O Allah's Apostle! We assumed Ihram with the exception of Abu Qatada and we saw (a group) of onagers. Abu Qatada attacked them and wounded a she-onager from them. Then we got down and ate from its meat. Later, we said, (to each other), 'How do we eat the meat of the game and we are in a state of Ihram?' So, we carried the rest of its meat. The Prophet asked, "Did anyone of you order Abu Qatada to attack it or point at it?" They replied in the negative. He said, "Then eat what is left of its meat."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.51]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 51

Narrated 'Abdullah bin 'Abbas:

From As-Sa'b bin Jath-thama Al-Laithi that the latter presented an onager to Allah's Apostle while he was at Al-Abwa' or at Waddan, and he refused it. On noticing the signs of some unpleasant feeling of disappointment on his (As-Sab's) face, the Prophet said to him, "I have only returned it because I am Muhrim."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.52]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 52

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "It is not sinful of a Muhrim to kill five kinds of animals."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.53]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 53

One of the wives of the Prophet narrated:

The Prophet said, "A Muhrim can kill (five kinds of animals.)"


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.54]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 54

Narrated Hafsa:

Allah's Apostle said, "It is not sinful (of a Muhrim) to kill five kinds of animals, namely: the crow, the kite, the mouse, the scorpion and the rabid dog."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.55]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 55

Narrated Aisha:

Allah's Apostle said, "Five kinds of animals are harmful and could be killed in the Haram (Sanctuary). These are: the crow, the kite, the scorpion, the mouse and the rabid dog."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.56]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 56

Narrated 'Abdullah:

While we were in the company of the Prophet in a cave at Mina, when Surat-wal-Mursalat were revealed and he recited it and I heard it (directly) from his mouth as soon as he recited its revelation. Suddenly a snake sprang at us and the Prophet said (ordered us): "Kill it." We ran to kill it but it escaped quickly. The Prophet said, "It has escaped your evil and you too have escaped its evil."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.57]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 57

Narrated 'Aisha the wife of the Prophet:

Allah's Apostle called the salamander a bad animal, but I did not hear him ordering it to be killed."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.58]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 58

Narrated Said bin Abu Said Al-Maqburi:

Abu Shuraih, Al-'Adawi said that he had said to 'Amr bin Sa'id when he was sending the troops to Mecca (to fight 'Abdullah bin Az-Zubair), "O Chief! Allow me to tell you what Allah's Apostle said on the day following the Conquest of Mecca. My ears heard that and my heart understood it thoroughly and I saw with my own eyes the Prophet when he, after Glorifying and Praising Allah, started saying, 'Allah, not the people, made Mecca a sanctuary, so anybody who has belief in Allah and the Last Day should neither shed blood in it, nor should he cut down its trees. If anybody tells (argues) that fighting in it is permissible on the basis that Allah's Apostle did fight in Mecca, say to him, 'Allah allowed His Apostle and did not allow you.' "Allah allowed me only for a few hours on that day (of the conquest) and today its sanctity is valid as it was before. So, those who are present should inform those who are absent (concerning this fact." Abu Shuraih was asked, "What did 'Amr reply?" He said, ('Amr said) 'O Abu Shuraih! I know better than you in this respect Mecca does not give protection to a sinner, a murderer or a thief."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.59]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 59

Narrated Ibn 'Abbas:

"The Prophet said, 'Allah has made Mecca, a sanctuary, so it was a sanctuary before me and will continue to be a sanctuary after me. It was made legal for me (i.e. I was allowed to fight in it) for a few hours of a day. It is not allowed to uproot its shrubs or to cut its trees, or to chase (or disturb) its game, or to pick up its luqata (fallen things) except by a person who would announce that (what he has found) publicly.' Al-'Abbas said, 'O Allah's Apostle! Except Al-ldhkhir (a kind of grass) (for it is used) by our goldsmiths and for our graves.' The Prophet then said, 'Except Al-idhkhir.' " 'Ikrima said, 'Do you know what "chasing or disturbing" the game means? It means driving it out of the shade to occupy its place."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.60]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 60

Narrated Ibn 'Abbas:

their blacksmiths and for their domestic purposes)." So, the Prophet s


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.61]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 61

Narrated Ibn Abbas:

Allah's Apostle was cupped while he was in a state of Ihram.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.62]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 62

Narrated Ibn Buhaina: The Prophet, while in the state of Ihram, was cupped at the middle of his head at Liha-Jamal.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.63]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 63

Narrated Ibn 'Abbas:

The Prophet married Maimuna while he was in the state of Ihram, (only the ceremonies of marriage were held).


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.64]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 64

Narrated 'Abdullah bin Umar:

A person stood up and asked, "O Allah's: Apostle! What clothes may be worn in the state of Ihram?" The Prophet replied, "Do not wear a shirt or trousers, or any headgear (e.g. a turban), or a hooded cloak; but if somebody has no shoes he can wear leather stockings provided they are cut short off the ankles, and also, do not wear anything perfumed with Wars or saffron, and the Muhrima (a woman in the state of Ihram) should not cover her face, or wear gloves."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.65]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 65

Narrated Ibn 'Abbas:

A man was crushed to death by his she-camel and was brought to Allah's Apostle who said, "Give him a bath and shroud him, but do not cover his head, and do not bring any perfume near to him, as he will be resurrected reciting Talbiya."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.66]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 66

Narrated 'Abdullah bin Hunain:

Abdullah bin Al-Abbas and Al-Miswar bin Makhrama differed at Al-Abwa'; Ibn 'Abbas said that a Muhrim could wash his head; while Al-Miswar maintained that he should not do so. 'Abdullah bin 'Abbas sent me to Abu Aiyub Al-Ansari and I found him bathing between the two wooden posts (of the well) and was screened with a sheet of cloth. I greeted him and he asked who I was. I replied, "I am 'Abdullah bin Hunain and I have been sent to you by Ibn 'Abbas to ask you how Allah's Apostle used to wash his head while in the state of lhram." Abu Aiyub Al-Ansarl caught hold of the sheet of cloth and lowered it till his head appeared before me, and then told somebody to pour water on his head. He poured water on his head, and he (Abu Aiyub) rubbed his head with his hands by bringing them from back to front and from front to back and said, "I saw the Prophet doing like this."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.67]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 67

Narrated Ibn 'Abbas:

I heard the Prophet delivering a sermon at 'Arafat saying, "If a Muhrim does not find slippers, he could wear Khuffs (but he has to cut short the Khuffs below the ankles), and if he does not find an Izar (a waist sheet for wrapping the lower half of the body) he could wear trousers."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.68]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 68

Narrated Abdullah:

Allah's Apostle was asked what sort of clothes a Muhrim should wear. He replied, "He should not wear a shirt, turbans, trousers, a hooded cloak, or a dress perfumed with saffron or Wars; and if slippers are not available he can wear Khuffs but he should cut them so that they reach below the ankles.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.69]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 69

Narrated Ibn Abbas:

The Prophet delivered a sermon at 'Arafat and said, "Whoever does not get an Izar can wear trousers, and whoever cannot get a pair of shoes can wear Khuffs."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.70]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 70

Narrated Al-Bara:

The Prophet assumed Ihram for Umra in the month of Dhul-Qa'da but the (pagan) people of Mecca refused to admit him into Mecca till he agreed on the condition that he would not bring into Mecca any arms but sheathed.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.71]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 71

Narrated Ibn 'Abbas:

The Prophet fixed Dhul-Hulaifa as the Miqat (the place for assuming Ihram) for the people of Medina, and Qaran-al-Manazil for the people of Najd, and Yalamlam for the people of Yemen. These Mawaqit are for those people and also for those who come through these Mawaqit (from places other than the above-mentioned) with the intention of (performing) Hajj and Umra. And those living inside these Mawaqit can assume Ihram from the place where they start; even the people of Mecca can assume Ihram from Mecca.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.72]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 72

Narrated Anas bin Malik:

Allah's Apostle entered Mecca in the year of its Conquest wearing an Arabian helmet on his head and when the Prophet took it off, a person came and said, "Ibn Khatal is holding the covering of the Ka'ba (taking refuge in the Ka'ba)." The Prophet said, "Kill him."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.73]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 73

Narrated Ya'li:

ame as you do in your Hajj." A man bit the hand of another man but in


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.74]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 74

Narrated Ibn 'Abbas:


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.75]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 75

Narrated Ibn 'Abbas:

While a man was standing with the Prophet at 'Arafat, he fell from his Mount and his neck was crushed by it. The Prophet said, "Wash the deceased with water and Sidr and shroud him in two pieces of cloth, and neither perfume him nor cover his head, for Allah will resurrect him on the Day of Resurrection and he will be reciting Talbiya."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.76]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 76

Narrated Ibn 'Abbas:

A man was in the company of the Prophet and his she-camel crushed his neck while he was in a state of Ihram and he died Allah's Apostle said, "Wash him with water and Sidr and shroud him in his two garments; neither perfume him nor cover his head, for he will be resurrected on the Day of Resurrection, reciting Talbiya."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.77]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 77

Narrated Ibn 'Abbas:

A woman from the tribe of Juhaina came to the Prophet and said, "My mother had vowed to perform Hajj but she died before performing it. May I perform Hajj on my mother's behalf?" The Prophet replied, "Perform Hajj on her behalf. Had there been a debt on your mother, would you have paid it or not? So, pay Allah's debt as He has more right to be paid."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.78]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 78

Narrated Ibn 'Abbas:

A woman from the tribe of Khath'am came in the year (of ,Hajjat-ul-wada' of the Prophet ) and said, "O Allah's Apostle! My father has come under Allah's obligation of performing Hajj but he is a very old man and cannot sit properly on his Mount. Will the obligation be fulfilled if I perform Hajj on his behalf?" The Prophet replied in the affirmative.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.79]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 79

Narrated 'Abdullah bin 'Abbas:

Al-Fadl was riding behind the Prophet and a woman from the tribe of Khath'am came up. Al-Fadl started looking at her and she looked at him. The Prophet turned Al-Fadl's face to the other side. She said, "My father has come under Allah's obligation of performing Hajj but he is a very old man and cannot sit properly on his Mount. Shall I perform Hajj on his behalf? The Prophet replied in the affirmative. That happened during Hajjat-ul-wada' of the Prophet .


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.80]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 80

Narrated Ibn 'Abbas:

The Prophet sent me (to Mina) with the luggage from Jam'(i.e. Al-Muzdalifa) at night.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.81]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 81

Narrated 'Abdullah bin 'Abbas:

I came riding on my she-ass and had (just) then attained the age of puberty. Allah's Apostle was praying at Mina. I passed in front of a part of the first row and then dismounted from it, and the animal started grazing. I aligned with the people behind Allah's Apostle (The sub-narrator added that happened in Mina during the Prophet's Hajjat-ul-wada.)


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.82]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 82

Narrated As-Sa'ib bin Yazid:

(While in the company of my parents) I was made to perform Hajj with Allah's Apostle and I was a seven-year-old boy then. (Fatch-Al-Bari, p.443, Vol.4)


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.83]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 83

Narrated Al-Ju'aid bin 'AbdurRahman:

I heard 'Umar bin 'Abdul Azlz telling about As-Sa'ib bin Yazid that he had performed Hajj (while carried) with the belongings of the Prophet


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.84]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 84

Narrated Aisha (mother of the faithful believers):

I said, "O Allah's Apostle! Shouldn't we participate in Holy battles and Jihad along with you?" He replied, "The best and the most superior Jihad (for women) is Hajj which is accepted by Allah." 'Aisha added: Ever since I heard that from Allah's Apostle I have determined not to miss Hajj.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.85]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 85

Narrated Ibn 'Abbas:

The Prophet said, "A woman should not travel except with a Dhu-Mahram (her husband or a man with whom that woman cannot marry at all according to the Islamic Jurisprudence), and no man may visit her except in the presence of a Dhu-Mahram." A man got up and said, "O Allah's Apostle! I intend to go to such and such an army and my wife wants to perform Hajj." The Prophet said (to him), "Go along with her (to Hajj)."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.86]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 86

Narrated Ibn 'Abbas:

When the Prophet returned after performing his Hajj, he asked Um Sinan Al-Ansari, "What did forbid you to perform Hajj?" She replied, "Father of so-and-so (i.e. her husband) had two camels and he performed Hajj on one of them, and the second is used for the irrigation of our land." The Prophet said (to her), "Perform 'Umra in the month of Ramadan, (as it is equivalent to Hajj or Hajj with me (in reward)."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.87]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 87

Narrated Qaza'a, the slave of Ziyad: Abu Said who participated in twelve Ghazawat with the Prophet said, "I heard four things from Allah's Apostle (or I narrate them from the Prophet ) which won my admiration and appreciation. They are:

1. "No lady should travel without her husband or without a Dhu-Mahram for a two-days' journey.

2. No fasting is permissible on two days of 'Id-al-Fitr, and 'Id-al-Adha.

3. No prayer (may be offered) after two prayers: after the 'Asr prayer till the sun set and after the morning prayer till the sun rises.

4. Not to travel (for visiting) except for three mosques: Masjid-al-Haram (in Mecca), my Mosque (in Medina), and Masjid-al-Aqsa (in Jerusalem)."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.88]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 88

Narrated Anas:

The Prophet saw an old man walking, supported by his two sons, and asked about him. The people informed him that he had vowed to go on foot (to the Ka'ba). He said, "Allah is not in need of this old man's torturing himself," and ordered him to ride.


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.89]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 89

Narrated 'Uqba bin 'Amir:

My sister vowed to go on foot to the Ka'ba, and she asked me to take the verdict of the Prophet about it. So, I did and the Prophet said, "She should walk and also should ride."


Bukhari :: Penalty of Hunting while on Pilgrimmage :: [3.29.90]

Penalty of Hunting while on Pilgrimmage

Bukhari :: Book 3 :: Volume 29 :: Hadith 90

Narrated Abu-l-Khair from 'Uqba as above.


Bukhari :: Virtues of Madinah :: [3.30.91]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 91

Narrated Anas:

The Prophet said, "Medina is a sanctuary from that place to that. Its trees should not be cut and no heresy should be innovated nor any sin should be committed in it, and whoever innovates in it an heresy or commits sins (bad deeds), then he will incur the curse of Allah, the angels, and all the people." (See Hadith No. 409, Vol 9).


Bukhari :: Virtues of Madinah :: [3.30.92]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 92

Narrated Anas:

The Prophet came to Medina and ordered a mosque to be built and said, "O Bani Najjar! Suggest to me the price (of your land)." They said, "We do not want its price except from Allah" (i.e. they wished for a reward from Allah for giving up their land freely). So, the Prophet ordered the graves of the pagans to be dug out and the land to be levelled, and the date-palm trees to be cut down. The cut date-palms were fixed in the direction of the Qibla of the mosque.


Bukhari :: Virtues of Madinah :: [3.30.93]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 93

Narrated Abu Huraira:

The Prophet said, "I have made Medina a sanctuary between its two (Harrat) mountains." The Prophet went to the tribe of Bani Haritha and said (to them), "I see that you have gone out of the sanctuary," but looking around, he added, "No, you are inside the sanctuary."


Bukhari :: Virtues of Madinah :: [3.30.94]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 94

Narrated 'Ali:

We have nothing except the Book of Allah and this written paper from the Prophet (where-in is written:) Medina is a sanctuary from the 'Air Mountain to such and such a place, and whoever innovates in it an heresy or commits a sin, or gives shelter to such an innovator in it will incur the curse of Allah, the angels, and all the people, none of his compulsory or optional good deeds of worship will be accepted. And the asylum (of protection) granted by any Muslim is to be secured (respected) by all the other Muslims; and whoever betrays a Muslim in this respect incurs the curse of Allah, the angels, and all the people, and none of his compulsory or optional good deeds of worship will be accepted, and whoever (freed slave) befriends (take as masters) other than his manumitters without their permission incurs the curse of Allah, the angels, and all the people, and none of his compulsory or optional good deeds of worship will be accepted.


Bukhari :: Virtues of Madinah :: [3.30.95]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 95

Narrated Abu Huraira:

Allah's Apostle said, "I was ordered to migrate to a town which will swallow (conquer) other towns and is called Yathrib and that is Medina, and it turns out (bad) persons as a furnace removes the impurities of iron.


Bukhari :: Virtues of Madinah :: [3.30.96]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 96

Narrated Abu Humaid:

We came with the Prophet from Tabuk, and when we reached near Medina, the Prophet said, "This is Tabah."


Bukhari :: Virtues of Madinah :: [3.30.97]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 97

Narrated Abu Huraira:

If I saw deers grazing in Medina, I would not chase them, for Allah's Apostle said, "(Medina) is a sanctuary between its two mountains."


Bukhari :: Virtues of Madinah :: [3.30.98]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 98

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The people will leave Medina in spite of the best state it will have, and none except the wild birds and the beasts of prey will live in it, and the last persons who will die will be two shepherds from the tribe of Muzaina, who will be driving their sheep towards Medina, but will find nobody in it, and when they reach the valley of Thaniyat-al-Wada', they will fall down on their faces dead."


Bukhari :: Virtues of Madinah :: [3.30.99]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 99

Narrated Abu Zuhair:

I heard Allah's Apostle saying, "Yemen will be conquered and some people will migrate (from Medina) and will urge their families, and those who will obey them to migrate (to Yemen) although Medina will be better for them; if they but knew. Sham will also be conquered and some people will migrate (from Medina) and will urge their families and those who will obey them, to migrate (to Sham) although Medina will be better for them; if they but knew. 'Iraq will be conquered and some people will migrate (from Medina) and will urge their families and those who will obey them to migrate (to 'Iraq) although Medina will be better for them; if they but knew."


Bukhari :: Virtues of Madinah :: [3.30.100]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 100

Narrated Abu Huraira:

Allah's Apostle said, "Verily, Belief returns and goes back to Medina as a snake returns and goes back to its hole (when in danger)."


Bukhari :: Virtues of Madinah :: [3.30.101]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 101

Narrated Sad:

I heard the Prophet saying, "None plots against the people of Medina but that he will be dissolved (destroyed) like the salt is dissolved in water."


Bukhari :: Virtues of Madinah :: [3.30.102]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 102

Narrated Usama:

Once the Prophet stood at the top of a (looked out from upon one) castle amongst the castles (or the high buildings) of Medina and said, "Do you see what I see? (No doubt) I see the spots where afflictions will take place among your houses (and these afflictions will be) as numerous as the spots where rain-drops fall."


Bukhari :: Virtues of Madinah :: [3.30.103]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 103

Narrated Abu Bakra:

The Prophet said, "The terror caused by Al-Masih Ad-Dajjal will not enter Medina and at that time Medina will have seven gates and there will be two angels at each gate guarding them."


Bukhari :: Virtues of Madinah :: [3.30.104]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 104

Narrated Abu Huraira:

Allah's Apostle said, "There are angels guarding the entrances (or roads) of Medina, neither plague nor Ad-Dajjal will be able to enter it."


Bukhari :: Virtues of Madinah :: [3.30.105]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 105

Narrated Anas bin Malik:

The Prophet said, "There will be no town which Ad-Dajjal will not enter except Mecca and Medina, and there will be no entrance (road) (of both Mecca and Medina) but the angels will be standing in rows guarding it against him, and then Medina will shake with its inhabitants thrice (i.e. three earth-quakes will take place) and Allah will expel all the nonbelievers and the hypocrites from it."


Bukhari :: Virtues of Madinah :: [3.30.106]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 106

Narrated Abu Said Al-Khudri:

Allah's Apostle told us a long narrative about Ad-Dajjal, and among the many things he mentioned, was his saying, "Ad-Dajjal will come and it will be forbidden for him to pass through the entrances of Medina. He will land in some of the salty barren areas (outside) Medina; on that day the best man or one of the best men will come up to him and say, 'I testify that you are the same Dajjal whose description was given to us by Allah's Apostle .' Ad-Dajjal will say to the people, 'If I kill this man and bring him back to life again, will you doubt my claim?' They will say, 'No.' Then Ad-Dajjal will kill that man and bring him back to life. That man will say, 'Now I know your reality better than before.' Ad-Dajjal will say, 'I want to kill him but I cannot.' "


Bukhari :: Virtues of Madinah :: [3.30.107]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 107

Narrated Jabir:

A bedouin came to the Prophet and gave a pledge of allegiance for embracing Islam. The next day he came with fever and said (to the Prophet ), "Please cancel my pledge (of embracing Islam and of emigrating to Medina)." The Prophet refused (that request) three times and said, "Medina is like a furnace, it expels out the impurities (bad persons) and selects the good ones and makes them perfect."


Bukhari :: Virtues of Madinah :: [3.30.108]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 108

Narrated Zaid bin Thabit:

When the Prophet went out for (the battle of) Uhud, some of his companions (hypocrites) returned (home). A party of the believers remarked that they would kill those (hypocrites) who had returned, but another party said that they would not kill them. So, this Divine Inspiration was revealed: "Then what is the matter with you that you are divided into two parties concerning the hypocrites." (4.88) The Prophet said, "Medina expels the bad persons from it, as fire expels the impurities of iron."


Bukhari :: Virtues of Madinah :: [3.30.109]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 109

Narrated Anas:

The Prophet said, "O Allah! Bestow on Medina twice the blessings You bestowed on Mecca."


Bukhari :: Virtues of Madinah :: [3.30.110]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 110

Narrated Anas:

Whenever the Prophet returned from a journey and observed the walls of Medina, he would make his Mount go fast, and if he was on an animal (i.e. a horse), he would make it gallop because of his love for Medina.


Bukhari :: Virtues of Madinah :: [3.30.111]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 111

Narrated Anas:

(The people of) Bani Salama intended to shift near the mosque (of the Prophet) but Allah's Apostle disliked to see Medina vacated and said, "O the people of Bani Salama! Don't you think that you will be rewarded for your footsteps which you take towards the mosque?" So, they stayed at their old places.


Bukhari :: Virtues of Madinah :: [3.30.112]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 112

Narrated Abu Huraira: The Prophet said, "There is a garden from the gardens of Paradise between my house and my pulpit, and my pulpit is on my Lake Fount (Al-Kauthar)."


Bukhari :: Virtues of Madinah :: [3.30.113]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 113

Narrated 'Aisha:

When Allah's Apostle reached Medina, Abu Bakr and Bilal became ill. When Abu Bakr's fever got worse, he would recite (this poetic verse): "Everybody is staying alive with his People, yet Death is nearer to him than His shoe laces." And Bilal, when his fever deserted him, would recite: "Would that I could stay overnight in A valley wherein I would be Surrounded by Idhkhir and Jalil (kinds of good-smelling grass). Would that one day I could Drink the water of the Majanna, and Would that (The two mountains) Shama and Tafil would appear to me!" The Prophet said, "O Allah! Curse Shaiba bin Rabi'a and 'Utba bin Rabi'a and Umaiya bin Khalaf as they turned us out of our land to the land of epidemics." Allah's Apostle then said, "O Allah! Make us love Medina as we love Mecca or even more than that. O Allah! Give blessings in our Sa and our Mudd (measures symbolizing food) and make the climate of Medina suitable for us, and divert its fever towards Aljuhfa." Aisha added: When we reached Medina, it was the most unhealthy of Allah's lands, and the valley of Bathan (the valley of Medina) used to flow with impure colored water.


Bukhari :: Virtues of Madinah :: [3.30.114]

Virtues of Madinah

Bukhari :: Book 3 :: Volume 30 :: Hadith 114

Narrated Zaid bin Aslam from his father:

Umar said, O Allah! Grant me martyrdom in Your cause, and let my death be in the city of Your Apostle."


Bukhari :: Fasting :: [3.31.115]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 115

Narrated Talha bin 'Ubaid-Ullah:

A bedouin with unkempt hair came to Allah's Apostle and said, "O Allah's Apostle! Inform me what Allah has made compulsory for me as regards the prayers." He replied: "You have to offer perfectly the five compulsory prayers in a day and night (24 hours), unless you want to pray Nawafil." The bedouin further asked, "Inform me what Allah has made compulsory for me as regards fasting." He replied, "You have to fast during the whole month of Ramadan, unless you want to fast more as Nawafil." The bedouin further asked, "Tell me how much Zakat Allah has enjoined on me." Thus, Allah's Apostle informed him about all the rules (i.e. fundamentals) of Islam. The bedouin then said, "By Him Who has honored you, I will neither perform any Nawafil nor will I decrease what Allah has enjoined on me. Allah's Apostle said, "If he is saying the truth, he will succeed (or he will be granted Paradise)."


Bukhari :: Fasting :: [3.31.116]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 116

Narrated Ibn 'Umar:

The Prophet observed the fast on the 10th of Muharram ('Ashura), and ordered (Muslims) to fast on that day, but when the fasting of the month of Ramadan was prescribed, the fasting of the 'Ashura' was abandoned. 'Abdullah did not use to fast on that day unless it coincided with his routine fasting by chance.


Bukhari :: Fasting :: [3.31.117]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 117

Narrated 'Aisha:

(The tribe of) Quraish used to fast on the day of Ashura' in the Pre-lslamic period, and then Allah's Apostle ordered (Muslims) to fast on it till the fasting in the month of Ramadan was prescribed; whereupon the Prophet said, "He who wants to fast (on 'Ashura') may fast, and he who does not want to fast may not fast."


Bukhari :: Fasting :: [3.31.118]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 118

Narrated Abu Huraira:

Allah's Apostle said, "Fasting is a shield (or a screen or a shelter). So, the person observing fasting should avoid sexual relation with his wife and should not behave foolishly and impudently, and if somebody fights with him or abuses him, he should tell him twice, 'I am fasting." The Prophet added, "By Him in Whose Hands my soul is, the smell coming out from the mouth of a fasting person is better in the sight of Allah than the smell of musk. (Allah says about the fasting person), 'He has left his food, drink and desires for My sake. The fast is for Me. So I will reward (the fasting person) for it and the reward of good deeds is multiplied ten times."


Bukhari :: Fasting :: [3.31.119]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 119

Narrated Abu Wail from Hudhaifa:

Umar asked the people, "Who remembers the narration of the Prophet about the affliction?" Hudhaifa said, "I heard the Prophet saying, 'The affliction of a person in his property, family and neighbors is expiated by his prayers, fasting, and giving in charity." 'Umar said, "I do not ask about that, but I ask about those afflictions which will spread like the waves of the sea." Hudhaifa replied, "There is a closed gate in front of those afflictions." 'Umar asked, "Will that gate be opened or broken?" He replied, "It will be broken." 'Umar said, "Then the gate will not be closed again till the Day of Resurrection." We said to Masruq, "Would you ask Hudhaifa whether 'Umar knew what that gate symbolized?" He asked him and he replied "He ('Umar) knew it as one knows that there will be night before tomorrow, morning.


Bukhari :: Fasting :: [3.31.120]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 120

Narrated Sahl:

The Prophet said, "There is a gate in Paradise called Ar-Raiyan, and those who observe fasts will enter through it on the Day of Resurrection and none except them will enter through it. It will be said, 'Where are those who used to observe fasts?' They will get up, and none except them will enter through it. After their entry the gate will be closed and nobody will enter through it."


Bukhari :: Fasting :: [3.31.121]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 121

'Narrated Abu Huraira:

Allah's Apostle said, "Whoever gives two kinds (of things or property) in charity for Allah's Cause, will be called from the gates of Paradise and will be addressed, 'O slaves of Allah! Here is prosperity.' So, whoever was amongst the people who used to offer their prayers, will be called from the gate of the prayer; and whoever was amongst the people who used to participate in Jihad, will be called from the gate of Jihad; and whoever was amongst those who used to observe fasts, will be called from the gate of Ar-Raiyan; whoever was amongst those who used to give in charity, will be called from the gate of charity." Abu Bakr said, "Let my parents be sacrificed for you, O Allah's Apostle! No distress or need will befall him who will be called from those gates. Will there be any one who will be called from all these gates?" The Prophet replied, "Yes, and I hope you will be one of them."


Bukhari :: Fasting :: [3.31.122]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 122

Narrated Abu Huraira:

Allah's Apostle said, "When Ramadan begins, the gates of Paradise are opened."


Bukhari :: Fasting :: [3.31.123]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 123

Narrated Abu Huraira:

Allah's Apostle said, "When the month of Ramadan starts, the gates of the heaven are opened and the gates of Hell are closed and the devils are chained."


Bukhari :: Fasting :: [3.31.124]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 124

Narrated Ibn Umar: I heard Allah's Apostle saying, "When you see the crescent (of the month of Ramadan), start fasting, and when you see the crescent (of the month of Shawwal), stop fasting; and if the sky is overcast (and you can't see It) then regard the crescent (month) of Ramadan (as of 30 days)".


Bukhari :: Fasting :: [3.31.125]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 125

Narrated Abu Huraira:

The Prophet said, "Whoever established prayers on the night of Qadr out of sincere faith and hoping for a reward from Allah, then all his previous sins will be forgiven; and whoever fasts in the month of Ramadan out of sincere faith, and hoping for a reward from Allah, then all his previous sins will be forgiven."


Bukhari :: Fasting :: [3.31.126]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 126

Narrated Ibn 'Abbas:

The Prophet was the most generous amongst the people, and he used to be more so in the month of Ramadan when Gabriel visited him, and Gabriel used to meet him on every night of Ramadan till the end of the month. The Prophet used to recite the Holy Qur'an to Gabriel, and when Gabriel met him, he used to be more generous than a fast wind (which causes rain and welfare).


Bukhari :: Fasting :: [3.31.127]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 127

Narrated Abu Huraira:

The Prophet said, "Whoever does not give up forged speech and evil actions, Allah is not in need of his leaving his food and drink (i.e. Allah will not accept his fasting.)"


Bukhari :: Fasting :: [3.31.128]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 128

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'All the deeds of Adam's sons (people) are for them, except fasting which is for Me, and I will give the reward for it.' Fasting is a shield or protection from the fire and from committing sins. If one of you is fasting, he should avoid sexual relation with his wife and quarreling, and if somebody should fight or quarrel with him, he should say, 'I am fasting.' By Him in Whose Hands my soul is' The unpleasant smell coming out from the mouth of a fasting person is better in the sight of Allah than the smell of musk. There are two pleasures for the fasting person, one at the time of breaking his fast, and the other at the time when he will meet his Lord; then he will be pleased because of his fasting."


Bukhari :: Fasting :: [3.31.129]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 129

Narrated 'Alqama: While I was walking with 'Abdullah he said, "We were in the company of the Prophet and he said, 'He who can afford to marry should marry, because it will help him refrain from looking at other women, and save his private parts from looking at other women, and save his private parts from committing illegal sexual relation; and he who cannot afford to marry is advised to fast, as fasting will diminish his sexual power."


Bukhari :: Fasting :: [3.31.130]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 130

Narrated Abdullah bin Umar:

Allah's Apostle mentioned Ramadan and said, "Do not fast unless you see the crescent (of Ramadan), and do not give up fasting till you see the crescent (of Shawwal), but if the sky is overcast (if you cannot see it), then act on estimation (i.e. count Sha'ban as 30 days)."


Bukhari :: Fasting :: [3.31.131]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 131

Narrated Abdullah bin Umar:

Allah's Apostle said, "The month (can be) 29 nights (i.e. days), and do not fast till you see the moon, and if the sky is overcast, then complete Sha'ban as thirty days."


Bukhari :: Fasting :: [3.31.132]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 132

Narrated Ibn 'Umar:

The Prophet said, "The month is like this and this," (at the same time he showed the fingers of both his hands thrice) and left out one thumb on the third time.


Bukhari :: Fasting :: [3.31.133]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 133

Narrated Abu Huraira:

The Prophet or Abu-l-Qasim said, "Start fasting on seeing the crescent (of Ramadan), and give up fasting on seeing the crescent (of Shawwal), and if the sky is overcast (and you cannot see it), complete thirty days of Sha'ban."


Bukhari :: Fasting :: [3.31.134]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 134

Narrated Um Salama:

The Prophet vowed to keep aloof from his wives for a period of one month, and after the completion of 29 days he went either in the morning or in the afternoon to his wives. Someone said to him "You vowed that you would not go to your wives for one month." He replied, "The month is of 29 days."


Bukhari :: Fasting :: [3.31.135]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 135

Narrated Anas:

Allah's Apostle vowed to keep aloof from his wives for one month, and he had dislocation of his leg. So, he stayed in a Mashruba for 29 nights and then came down. Some people said, "O Allah's Apostle! You vowed to stay aloof for one month," He replied, "The month is of 29 days."


Bukhari :: Fasting :: [3.31.136]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 136

Narrated Abu Bakra:

The Prophet said, "The two months of 'Id i.e. Ramadan and Dhul-Hijja, do not decrease (in superiority)."


Bukhari :: Fasting :: [3.31.137]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 137

Narrated Ibn 'Umar:

The Prophet said, "We are an illiterate nation; we neither write, nor know accounts. The month is like this and this, i.e. sometimes of 29 days and sometimes of thirty days."


Bukhari :: Fasting :: [3.31.138]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 138

Narrated Abu Huraira:

The Prophet said, "None of you should fast a day or two before the month of Ramadan unless he has the habit of fasting (Nawafil) (and if his fasting coincides with that day) then he can fast that day."


Bukhari :: Fasting :: [3.31.139]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 139

Narrated Al-Bara:

It was the custom among the companions of Muhammad that if any of them was fasting and the food was presented (for breaking his fast), but he slept before eating, he would not eat that night and the following day till sunset.

Qais bin Sirma-al-Ansari was fasting and came to his wife at the time of Iftar (breaking one's fast) and asked her whether she had anything to eat. She replied, "No, but I would go and bring some for you." He used to do hard work during the day, so he was overwhelmed by sleep and slept. When his wife came and saw him, she said, "Disappointment for you." When it was midday on the following day, he fainted and the Prophet was informed about the whole matter and the following verses were revealed: "You are permitted To go to your wives (for sexual relation) At the night of fasting." So, they were overjoyed by it. And then Allah also revealed: "And eat and drink Until the white thread Of dawn appears to you Distinct from the black thread (of the night)." (2.187)


Bukhari :: Fasting :: [3.31.140]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 140

Narrated 'Adi bin Hatim:

When the above verses were revealed: 'Until the white thread appears to you, distinct from the black thread,' I took two (hair) strings, one black and the other white, and kept them under my pillow and went on looking at them throughout the night but could not make anything out of it. So, the next morning I went to Allah's Apostle and told him the whole story. He explained to me, "That verse means the darkness of the night and the whiteness of the dawn."


Bukhari :: Fasting :: [3.31.141]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 141

Narrated Sahl bin Saud:

When the following verses were revealed: 'Eat and drink until the white thread appears to you, distinct from the black thread' and of dawn was not revealed, some people who intended to fast, tied black and white threads to their legs and went on eating till they differentiated between the two. Allah then revealed the words, 'of dawn', and it became clear that meant night and day.


Bukhari :: Fasting :: [3.31.142]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 142

Narrated 'Aisha:

Bilal used to pronounce the Adhan at night, so Allah's Apostle? said, "Carry on taking your meals (eat and drink) till Ibn Um Maktum pronounces the Adhan, for he does not pronounce it till it is dawn.


Bukhari :: Fasting :: [3.31.143]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 143

Narrated Sahl bin Sad:

I used to take my Suhur meals with my family and then hurry up for presenting myself for the (Fajr) prayer with Allah's Apostle.


Bukhari :: Fasting :: [3.31.144]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 144

Narrated Anas:

Zaid bin Thabit said, "We took the Suhur with the Prophet . Then he stood for the prayer." I asked, "What was the interval between the Suhur and the Adhan?" He replied, "The interval was sufficient to recite fifty verses of the Quran."


Bukhari :: Fasting :: [3.31.145]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 145

Narrated 'Abdullah:

The Prophet fasted for days continuously; the people also did the same but it was difficult for them. So, the Prophet forbade them (to fast continuously for more than one day). They slid, "But you fast without break (no food was taken in the evening or in the morning)." The Prophet replied, "I am not like you, for I am provided with food and drink (by Allah)."


Bukhari :: Fasting :: [3.31.146]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 146

Narrated Anas bin Malik:

The Prophet said, "Take Suhur as there is a blessing in it."


Bukhari :: Fasting :: [3.31.147]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 147

Narrated Salama bin Al-Akwa:

Once the Prophet ordered a person on 'Ashura' (the tenth of Muharram) to announce, "Whoever has eaten, should not eat any more, but fast, and who has not eaten should not eat, but complete his fast (till the end of the day).


Bukhari :: Fasting :: [3.31.148]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 148

Narrated 'Aisha and Um Salama:

At times Allah's Apostle used to get up in the morning in the state of Janaba after having sexual relations with his wives. He would then take a bath and fast.


Bukhari :: Fasting :: [3.31.149]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 149

Narrated 'Aisha:

The Prophet used to kiss and embrace (his wives) while he was fasting, and he had more power to control his desires than any of you. Said Jabir, "The person who gets discharge after casting a look (on his wife) should complete his fast."


Bukhari :: Fasting :: [3.31.150]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 150

Narrated Hisham's father:

Aisha said, "Allah's Apostle used to kiss some of his wives while he was fasting," and then she smiled.


Bukhari :: Fasting :: [3.31.151]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 151

Narrated Zainab:

(daughter of Um Salama) that her mother said, "While I was (lying) with Allah's Apostle underneath a woolen sheet, I got the menstruation, and then slipped away and put on the clothes (which I used to wear) in menses. He asked, "What is the matter? Did you get your menses?" I replied in the affirmative and then entered underneath that woolen sheet. I and Allah's Apostle used to take a bath from one water pot and he used to kiss me while he was fasting."


Bukhari :: Fasting :: [3.31.152]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 152

Narrated 'Aisha:

(At times) in Ramadan the Prophet used to take a bath in the morning not because of a wet dream and would continue his fast.


Bukhari :: Fasting :: [3.31.153]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 153

Narrated Abu Bakr bin 'Abdur-Rahman:

My father and I went to 'Aisha and she said, "I testify that Allah's Apostle at times used to get up in the morning in a state of Janaba from sexual intercourse, not from a wet dream and then he would fast that day." Then he went to Um Salama and she also narrated a similar thing.


Bukhari :: Fasting :: [3.31.154]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 154

Narrated Abu Huraira:

The Prophet said, "If somebody eats or drinks forgetfully then he should complete his fast, for what he has eaten or drunk, has been given to him by Allah." Narrated 'Amir bin Rabi'a, "I saw the Prophet cleaning his teeth with Siwak while he was fasting so many times as I can't count." And narrated Abu Huraira, "The Prophet said, 'But for my fear that it would be hard for my followers, I would have ordered them to clean their teeth with Siwak on every performance of ablution." The same is narrated by Jabir and Zaid bin Khalid from the Prophet who did not differentiate between a fasting and a nonfasting person in this respect (using Siwak).

Aisha said, "The Prophet said, "It (i.e. Siwak) is a purification for the mouth and it is a way of seeking Allah's pleasures." Ata' and Qatada said, "There is no harm in swallowing the resultant saliva."


Bukhari :: Fasting :: [3.31.155]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 155

Narrated Humran:

I saw 'Uthman performing ablution; he washed his hands thrice, rinsed his mouth and then washed his nose, by putting water in it and then blowing it out, and washed his face thrice, and then washed his right forearm up to the elbow thrice, and then the left-forearm up to the elbow thrice, then smeared his head with water, washed his right foot thrice, and then his left foot thrice and said, "I saw Allah's Apostle performing ablution similar to my present ablution, and then he said, 'Whoever performs ablution like my present ablution and then offers two Rakat in which he does not think of worldly things, all his previous sins will be forgiven."


Bukhari :: Fasting :: [3.31.156]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 156

Narrated 'Aisha:

A man came to the Prophet and said that he had been burnt (ruined). The Prophet asked him what was the matter. He replied, "I had sexual intercourse with my wife in Ramadan (while I was fasting)." Then a basket full of dates was brought to the Prophet and he asked, "Where is the burnt (ruined) man?" He replied, "I am present." The Prophet told him to give that basket in charity (as expiation).


Bukhari :: Fasting :: [3.31.157]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 157

Narrated Abu Huraira:

While we were sitting with the Prophet a man came and said, "O Allah's Apostle! I have been ruined." Allah's Apostle asked what was the matter with him. He replied "I had sexual intercourse with my wife while I was fasting." Allah's Apostle asked him, "Can you afford to manumit a slave?" He replied in the negative. Allah's Apostle asked him, "Can you fast for two successive months?" He replied in the negative. The Prophet asked him, "Can you afford to feed sixty poor persons?" He replied in the negative. The Prophet kept silent and while we were in that state, a big basket full of dates was brought to the Prophet . He asked, "Where is the questioner?" He replied, "I (am here)." The Prophet said (to him), "Take this (basket of dates) and give it in charity." The man said, "Should I give it to a person poorer than I? By Allah; there is no family between its (i.e. Medina's) two mountains who are poorer than I." The Prophet smiled till his pre-molar teeth became visible and then said, 'Feed your family with it."


Bukhari :: Fasting :: [3.31.158]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 158

Narrated Abu Huraira:

A man came to the Prophet and said, "I had sexual intercourse with my wife on Ramadan (while fasting)." The Prophet asked him, "Can you afford to manumit a slave?" He replied in the negative. The Prophet asked him, "Can you fast for two successive months?" He replied in the negative. He asked him, "Can you afford to feed sixty poor persons?" He replied in the negative. (Abu Huraira added): Then a basket full of dates was brought to the Prophet and he said (to that man), "Feed (poor people) with this by way of atonement." He said, "(Should I feed it) to poorer people than we? There is no poorer house than ours between its (Medina's) mountains." The Prophet said, "Then feed your family with it."


Bukhari :: Fasting :: [3.31.159]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 159

Narrated Ibn Abbas:

The Prophet was cupped while he was in the state of lhram, and also while he was observing a fast.


Bukhari :: Fasting :: [3.31.160]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 160

Narrated Ibn 'Abbas:

The Prophet was cupped while he was fasting.


Bukhari :: Fasting :: [3.31.161]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 161

Narrated Thabit Al-Bunani:

Anas bin Malik was asked whether they disliked the cupping for a fasting person. He replied in the negative and said, "Only if it causes weakness."


Bukhari :: Fasting :: [3.31.162]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 162

Narrated Ibn Abi Aufa:

We were in the company of Allah's Apostle on a journey. He said to a man, "Get down and mix Sawiq (powdered barley) with water for me." The man said, "The sun (has not set yet), O Allah's Apostle." The Prophet again said to him, "Get down and mix Sawiq with water for me." The man again said, "O Allah's Apostle! The sun!" The Prophet said to him (for the third time) "Get down and mix Sawiq with water for me." The man dismounted and mixed Sawiq with water for him. The Prophet drank it and then beckoned with his hand (towards the East) and said, "When you see the night falling from this side, then a fasting person should break his fast."


Bukhari :: Fasting :: [3.31.163]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 163

Narrated 'Aisha:

Hamza bin 'Amr Al-Aslami said, "O Allah's Apostle! I fast continuously."


Bukhari :: Fasting :: [3.31.164]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 164

Narrated 'Aisha:

(the wife of the Prophet) Hamza bin 'Amr Al-Aslami asked the Prophet, "Should I fast while traveling?" The Prophet replied, "You may fast if you wish, and you may not fast if you wish."


Bukhari :: Fasting :: [3.31.165]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 165

Narrated Ibn 'Abbas:

Allah's Apostle set out for Mecca in Ramadan and he fasted, and when he reached Al-Kadid, he broke his fast and the people (with him) broke their fast too. (Abu 'Abdullah said, "Al-Kadid is a land covered with water between Usfan and Qudaid.")


Bukhari :: Fasting :: [3.31.166]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 166

Narrated Abu Ad-Darda:

We set out with Allah's Apostle on one of his journeys on a very hot day, and it was so hot that one had to put his hand over his head because of the severity of heat. None of us was fasting except the Prophet and Ibn Rawaha.


Bukhari :: Fasting :: [3.31.167]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 167

Narrated Jabir bin 'Abdullah:

Allah's Apostle was on a journey and saw a crowd of people, and a man was being shaded (by them). He asked, "What is the matter?" They said, "He (the man) is fasting." The Prophet said, "It is not righteousness that you fast on a journey."


Bukhari :: Fasting :: [3.31.168]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 168

Narrated Anas bin Malik:

We used to travel with the Prophet and neither did the fasting persons criticize those who were not fasting, nor did those who were not fasting criticize the fasting ones.


Bukhari :: Fasting :: [3.31.169]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 169

Narrated Tawus:

Ibn 'Abbas said, "Allah's Apostle set out from Medina to Mecca and he fasted till he reached 'Usfan, where he asked for water and raised his hand to let the people see him, and then broke the fast, and did not fast after that till he reached Mecca, and that happened in Ramadan." Ibn 'Abbas used to say, "Allah's Apostle (sometimes) fasted and (sometimes) did not fast during the journeys so whoever wished to fast could fast, and whoever wished not to fast, could do so."


Bukhari :: Fasting :: [3.31.170]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 170

Narrated Nafi:

Ibn 'Umar recited the verse: "They had a choice either to fast or to feed a poor person for every day, and said that the order of this Verse was cancelled.


Bukhari :: Fasting :: [3.31.171]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 171

Narrated 'Aisha:

Sometimes I missed some days of Ramadan, but could not fast in lieu of them except in the month of Sha'ban." Said Yahya, a sub-narrator, "She used to be busy serving the Prophet ."


Bukhari :: Fasting :: [3.31.172]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 172

Narrated Abu Said:

The Prophet said, "Isn't it true that a woman does not pray and does not fast on menstruating? And that is the defect (a loss) in her religion."


Bukhari :: Fasting :: [3.31.173]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 173

Narrated 'Aisha:

Allah's Apostle said, "Whoever died and he ought to have fasted (the missed days of Ramadan) then his guardians must fast on his behalf."


Bukhari :: Fasting :: [3.31.174]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 174

Narrated Ibn Abbas:

A man came to the Prophet and said, "O Allah's Apostle! My mother died and she ought to have fasted one month (for her missed Ramadan). Shall I fast on her behalf?" The Prophet replied in the affirmative and said, "Allah's debts have more right to be paid." In another narration a woman is reported to have said, "My sister died..."

Narrated Ibn 'Abbas: A woman said to the Prophet "My mother died and she had vowed to fast but she didn't fast." In another narration Ibn 'Abbas is reported to have said, "A woman said to the Prophet, "My mother died while she ought to have fasted for fifteen days."


Bukhari :: Fasting :: [3.31.175]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 175

Narrated Umar bin Al-Khattab:

Allah's Apostle said, "When night falls from this side and the day vanishes from this side and the sun sets, then the fasting person should break his fast."


Bukhari :: Fasting :: [3.31.176]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 176

Narrated Abdullah bin Abi Aufa:

We were in the company of the Prophet on a journey and he was fasting, and when the sun set, he addressed somebody, "O so-and-so, get up and mix Sawiq with water for us." He replied, "O Allah's Apostle! (Will you wait) till it is evening?" The Prophet said, "Get down and mix Sawiq with water for us." He replied, "O Allah's Apostle! (If you wait) till it is evening." The Prophet said again, "Get down and mix Sawiq with water for us." He replied, "It is still daytime."(1) The Prophet said again, "Get down and mix Sawiq with water for us." He got down and mixed Sawiq for them. The Prophet drank it and then said, "When you see night falling from this side, the fasting person should break his fast."


Bukhari :: Fasting :: [3.31.177]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 177

Narrated 'Abdullah bin Abi Aufa"

We were traveling with Allah's Apostle and he was fasting, and when the sun set, he said to (someone), "Get down and mix Sawiq with water for us." He replied, "O Allah's Apostle! (Will you wait) till it is evening?" The Prophet again said, "Get down and mix Sawiq with water for us." He replied, "O Allah's Apostle! It is still daytime." The Prophet said again, "Get down and mix Sawiq with water for us." So, he got down and carried out that order. The Prophet then said, "When you see night falling from this side, the fasting person should break his fast," and he beckoned with his finger towards the east.


Bukhari :: Fasting :: [3.31.178]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 178

Narrated Sahl bin Sad:

Allah's Apostle said, "The people will remain on the right path as long as they hasten the breaking of the fast."


Bukhari :: Fasting :: [3.31.179]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 179

Narrated Ibn Abi Aufa:

I was with the Prophet on a journey, and he observed the fast till evening. The Prophet said to a man, "Get down and mix Sawiq with water for me." He replied, "Will you wait till it is evening?" The Prophet said, "Get down and mix Sawiq with water for me; when you see night falling from this side, the fasting person should break his fast."


Bukhari :: Fasting :: [3.31.180]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 180

Narrated Abu Usama from Hisham bin 'Ursa from Fatima:

Asma bint Abi Bakr said, "We broke our fast during the lifetime of the Prophet on a cloudy day and then the sun appeared." Hisham was asked, "Were they ordered to fast in lieu of that day?" He replied, "It had to be made up for." Ma'mar said, "I heard Hisham saying, "I don't know whether they fasted in lieu of that day or not."


Bukhari :: Fasting :: [3.31.181]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 181

Narrated Ar-Rubi' bint Mu'awadh:

"The Prophet sent a messenger to the village of the Ansar in the morning of the day of 'Ashura' (10th of Muharram) to announce: 'Whoever has eaten something should not eat but complete the fast, and whoever is observing the fast should complete it.' "She further said, "Since then we used to fast on that day regularly and also make our boys fast. We used to make toys of wool for the boys and if anyone of them cried for, he was given those toys till it was the time of the breaking of the fast."


Bukhari :: Fasting :: [3.31.182]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 182

Narrated Anas:

The Prophet said, "Do not practice Al-Wisal (fasting continuously without breaking one's fast in the evening or eating before the following dawn)." The people said to the Prophet, "But you practice Al-Wisal?" The Prophet replied, "I am not like any of you, for I am given food and drink (by Allah) during the night."


Bukhari :: Fasting :: [3.31.183]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 183

Narrated Abdullah bin Umar:

Allah's Apostle forbade Al-Wisal. The people said (to him), "But you practice it?" He said, "I am not like you, for I am given food and drink by Allah."


Bukhari :: Fasting :: [3.31.184]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 184

'Narrated Abu Sa'id:

That he had heard the Prophet saying, "Do not fast continuously (practise Al-Wisal), and if you intend to lengthen your fast, then carry it on only till the Suhur (before the following dawn)." The people said to him, "But you practice (Al-Wisal), O Allah's Apostle!" He replied, "I am not similar to you, for during my sleep I have One Who makes me eat and drink."


Bukhari :: Fasting :: [3.31.185]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 185

Narrated Aisha:

Allah's Apostle forbade Al-Wisal out of mercy to them. They said to him, "But you practice Al-Wisal?" He said, "I am not similar to you, for my Lord gives me food and drink. "


Bukhari :: Fasting :: [3.31.186]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 186

Narrated Abu Huraira:

Allah's Apostle forbade Al-Wisal in fasting. So, one of the Muslims said to him, "But you practice Al-Wisal. O Allah's Apostle!" The Prophet replied, "Who amongst you is similar to me? I am given food and drink during my sleep by my Lord." So, when the people refused to stop Al-Wisal (fasting continuously), the Prophet fasted day and night continuously along with them for a day and then another day and then they saw the crescent moon (of the month of Shawwal). The Prophet said to them (angrily), "If It (the crescent) had not appeared, I would have made you fast for a longer period." That was as a punishment for them when they refused to stop (practising Al-Wisal).


Bukhari :: Fasting :: [3.31.187]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 187

Narrated Abu Huraira:

The Prophet said twice, "(O you people) Be cautious! Do not practice Al-Wisal." The people said to him, "But you practice Al-Wisal?" The Prophet replied, "My Lord gives me food and drink during my sleep. Do that much of deeds which is within your ability."


Bukhari :: Fasting :: [3.31.188]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 188

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Do not fast continuously day and night (practise Al-Wisal) and if anyone of you intends to fast continuously day and night, he should continue till the Suhur time." They said, "But you practise Al-Wisal, O Allah's Apostle!" The Prophet said, "I am not similar to you;. during my sleep I have One Who makes me eat and drink."


Bukhari :: Fasting :: [3.31.189]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 189

Narrated Abu Juhaifa:

The Prophet made a bond of brotherhood between Salman and Abu Ad-Darda.' Salman paid a visit to Abu Ad-Darda' and found Um Ad-Darda' dressed in shabby clothes and asked her why she was in that state. She replied, "Your brother Abu Ad-Darda' is not interested in (the luxuries of) this world." In the meantime Abu Ad-Darda' came and prepared a meal for Salman. Salman requested Abu Ad-Darda' to eat (with him), but Abu Ad-Darda' said, "I am fasting." Salman said, "I am not going to eat unless you eat." So, Abu Ad-Darda' ate(with Salman). When it was night and (a part of the night passed), Abu Ad-Darda' got up (to offer the night prayer), but Salman told him to sleep and Abu Ad-Darda' slept. After sometime Abu Ad-Darda' again got up but Salman told him to sleep. When it was the last hours of the night, Salman told him to get up then, and both of them offered the prayer. Salman told Abu Ad-Darda', "Your Lord has a right on you, your soul has a right on you, and your family has a right on you; so you should give the rights of all those who has a right on you." Abu Ad-Darda' came to the Prophet and narrated the whole story. The Prophet said, "Salman has spoken the truth."


Bukhari :: Fasting :: [3.31.190]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 190

Narrated 'Aisha:

Allah's Apostle used to fast till one would say that he would never stop fasting, and he would abandon fasting till one would say that he would never fast. I never saw Allah's Apostle fasting for a whole month except the month of Ramadan, and did not see him fasting in any month more than in the month of Sha'ban.


Bukhari :: Fasting :: [3.31.191]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 191

Narrated 'Aisha:

The Prophet never fasted in any month more than in the month of Sha'ban. He used to say, "Do those deeds which you can do easily, as Allah will not get tired (of giving rewards) till you get bored and tired (of performing religious deeds)." The most beloved prayer to the Prophet was the one that was done regularly (throughout the life) even if it were little. And whenever the Prophet offered a prayer he used to offer it regularly .


Bukhari :: Fasting :: [3.31.192]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 192

Narrated Ibn 'Abbas:

The Prophet never fasted a full month except the month of Ramadan, and he used to fast till one could say, "By Allah, he will never stop fasting," and he would abandon fasting till one would say, "By Allah, he will never fast."


Bukhari :: Fasting :: [3.31.193]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 193

Narrated Anas:

Allah's Apostle used to leave fasting in a certain month till we thought that he would not fast in that month, and he used to fast in another month till we thought he would not stop fasting at all in that month. And if one wanted to see him praying at night, one could see him (in that condition), and if one wanted to see him sleeping at night, one could see him (in that condition) too.


Bukhari :: Fasting :: [3.31.194]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 194

Narrated Humaid:

I asked Anas about the fasting of the Prophet. He said "Whenever I liked to see the Prophet fasting in any month, I could see that, and whenever I liked to see him not fasting, I could see that too, and if I liked to see him praying in any night, I could see that, and if I liked to see him sleeping, I could see that, too." Anas further said, "I never touched silk or velvet softer than the hand of Allah's Apostle and never smelled musk or perfumed smoke more pleasant than the smell of Allah's Apostle."


Bukhari :: Fasting :: [3.31.195]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 195

Narrated 'Abdullah bin 'Amr bin Al-'As:

"Once Allah's Apostle came to me," and then he narrated the whole narration, i.e. your guest has a right on you, and your wife has a right on you. I then asked about the fasting of David. The Prophet replied, "Half of the year," (i.e. he used to fast on every alternate day).


Bukhari :: Fasting :: [3.31.196]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 196

Narrated 'Abdullah bin 'Amr bin Al-'As:

Allah's Apostle said to me, "O 'Abdullah! Have I not been informed that you fast during the day and offer prayers all the night." 'Abdullah replied, "Yes, O Allah's Apostle!" The Prophet said, "Don't do that; fast for few days and then give it up for few days, offer prayers and also sleep at night, as your body has a right on you, and your wife has a right on you, and your guest has a right on you. And it is sufficient for you to fast three days in a month, as the reward of a good deed is multiplied ten times, so it will be like fasting throughout the year." I insisted (on fasting) and so I was given a hard instruction. I said, "O Allah's Apostle! I have power." The Prophet said, "Fast like the fasting of the Prophet David and do not fast more than that." I said, "How was the fasting of the Prophet of Allah, David?" He said, "Half of the year," (i.e. he used to fast on every alternate day).

Afterwards when 'Abdullah became old, he used to say, "It would have been better for me if I had accepted the permission of the Prophet (which he gave me i.e. to fast only three days a month)."


Bukhari :: Fasting :: [3.31.197]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 197

Narrated 'Abdullah bin 'Amr:

Allah's Apostle was informed that I had taken an oath to fast daily and to pray (every night) all the night throughout my life (so Allah's Apostle came to me and asked whether it was correct): I replied, "Let my parents be sacrificed for you! I said so." The Prophet said, "You can not do that. So, fast for few days and give it up for few days, r ray and sleep. Fast three days a month as the reward of good deeds is multiplied ten times and that will be equal to one year of fasting." I replied, "I can do better than that." The Prophet said to me, "Fast one day and give up fasting for a day and that is the fasting of Prophet David and that is the best fasting." I said, "I have the power to fast better (more) than that." The Prophet said, "There is no better fasting than that."


Bukhari :: Fasting :: [3.31.198]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 198

Narrated 'Abdullah bin 'Amr:

The news of my daily fasting and praying every night throughout the night reached the Prophet. So he sent for me or I met him, and he said, "I have been informed that you fast everyday and pray every night (all the night). Fast (for some days) and give up fasting (for some days); pray and sleep, for your eyes have a right on you, and your body and your family (i.e. wife) have a right on you." I replied, "I have more power than that (fasting)." The Prophet said, "Then fast like the fasts of (the Prophet) David". I said, "How?" He replied, "He used to fast on alternate days, and he used not to flee on meeting the enemy." I said, "From where can I get that chance?" ('Ata' said, "I do not know how the expression of fasting daily throughout the life occurred.") So, the Prophet said, twice, "Whoever fasts daily throughout his life is just as the one who does not fast at all."


Bukhari :: Fasting :: [3.31.199]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 199

Narrated Mujahid from 'Abdullah bin 'Amr:

The Prophet said (to 'Abdullah), "Fast three days a month." 'Abdullah said, (to the Prophet) "I am able to fast more than that." They kept on arguing on this matter till the Prophet said, "Fast on alternate days, and recite the whole Qur'an once a month." 'Abdullah said, "I can recite more (in a month)," and the argument went on till the Prophet said, "Recite the Qur'an once each three days." (i.e. you must not recite the whole Qur'an in less than three days).


Bukhari :: Fasting :: [3.31.200]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 200

Narrated 'Abdullah bin 'Amr bin Al-'As:

The Prophet said to me, "You fast daily all the year and pray every night all the night?" I replied in the affirmative. The Prophet said, "If you keep on doing this, your eyes will become weak and your body will get tired. He who fasts all the year is as he who did not fast at all. The fasting of three days (a month) will be equal to the tasting of the whole year." I replied, "I have the power for more than this." The Prophet said, "Then fast like the fasting of David who used to fast on alternate days and would never flee from the battle field, on meeting the enemy.


Bukhari :: Fasting :: [3.31.201]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 201

Narrated 'Abdullah bin 'Amr:

Allah's Apostle was informed about my fasts, and he came to me and I spread for him a leather cushion stuffed with palm fires, but he sat on the ground and the cushion remained between me and him, and then he said, "Isn't it sufficient for you to fast three days a month?" I replied, "O Allah's Apostle! (I can fast more)." He said, "Five?" I replied, "O Allah's Apostle! (I can fast more)." He said, "Seven?" I replied, "O Allah's Apostle! (I can fast more)." He said, "Nine (days per month)?" I replied, "O Allah's Apostle! (I can fast more)" He said, "Eleven (days per month)?" And then the Prophet said, "There is no fast superior to that of the Prophet David it was for half of the year. So, fast on alternate days."


Bukhari :: Fasting :: [3.31.202]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 202

Narrated Abu Huraira:

My friend (the Prophet ) advised me to observe three things:

(1) to fast three days a month;

(2) to pray two Rakat of Duha prayer (fore-noon prayer); and

(3) to pray Witr before sleeping.


Bukhari :: Fasting :: [3.31.203]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 203

Narrated Anas:

The Prophet paid a visit to Um-Sulaim and she placed before him dates and ghee. The Prophet said, "Replace the ghee and dates in their respective containers for I am fasting." Then he stood somewhere in her house and offered an optional prayer and then he invoked good on Um-Sulaim and her family. Then Um-Sulaim said, "O Allah's Apostle! I have a special request (today)." He said, "What is it?" She replied, "(Please invoke for) your servant Anas." So Allah's Apostle did not leave anything good in the world or the Hereafter which he did not invoke (Allah to bestow) on me and said, "O Allah! Give him (i.e. Anas) property and children and bless him." Thus I am one of the richest among the Ansar and my daughter Umaina told me that when A-Hajjaj came to Basra, more than 120 of my offspring had been buried.


Bukhari :: Fasting :: [3.31.204]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 204

Narrated Mutarrif from 'Imran Ibn Husain:

That the Prophet asked him (Imran) or asked a man and Imran was listening, "O Abu so-and-so! Have you fasted the last days of this month?" (The narrator thought that he said, "the month of Ramadan"). The man replied, "No, O Allah's Apostle!" The Prophet said to him, "When you finish your fasting (of Ramadan) fast two days (in Shawwal)." Through another series of narrators 'Imran said, "The Prophet said, '(Have you fasted) the last days of Sha'ban?"


Bukhari :: Fasting :: [3.31.205]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 205

Narrated Muhammad bin 'Abbas:

I asked Jabir "Did the Prophet forbid fasting on Fridays?" He replied, "Yes." (Other narrators added, "If he intends to fast only that day.")


Bukhari :: Fasting :: [3.31.206]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 206

Narrated Abu Huraira:

I heard the Prophet saying, "None of you should fast on Friday unless he fasts a day before or after it."


Bukhari :: Fasting :: [3.31.207]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 207

Narrated Abu Aiyub from Juwairiya bint Al-Harith:

The Prophet visited her (Juwairiya) on a Friday and she was fasting. He asked her, "Did you fast yesterday?" She said, "No." He said, "Do you intend to fast tomorrow?" She said, "No." He said, "Then break your fast." Through another series of narrators, Abu Aiyub is reported to have said, "He ordered her and she broke her fast."


Bukhari :: Fasting :: [3.31.208]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 208

Narrated Alqama:

I asked 'Aisha "Did Allah s Apostle, use to choose some special days (for fasting)?" She replied, "No, but he used to be regular (constant) (in his service of worshipping). Who amongst you can endure what Allah's Apostle used to endure?"


Bukhari :: Fasting :: [3.31.209]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 209

Narrated Um Al-Fadl bint Al-Harith:

"While the people were with me on the day of 'Arafat they differed as to whether the Prophet was fasting or not; some said that he was fasting while others said that he was not fasting. So, I sent to him a bowl full of milk while he was riding over his camel and he drank it."


Bukhari :: Fasting :: [3.31.210]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 210

Narrated Maimuna:

The people doubted whether the Prophet was fasting on the day of 'Arafat or not, so I sent milk while he was standing at 'Arafat, he drank it and the people were looking at him.


Bukhari :: Fasting :: [3.31.211]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 211

Narrated Abu 'Ubaid:

(the slave of Ibn Azhar) I witnessed the 'Id with 'Umar bin Al-Kattab who said, Allah's Apostle has forbidden people to fast on the day on which you break fasting (the fasts of Ramadan) and the day on which you eat the meat of your sacrifices (the first day of 'Id ul Fitr and 'Id ul-Adha).


Bukhari :: Fasting :: [3.31.212]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 212

Narrated Abu Sa'id:

The Prophet forbade the fasting of 'Id-ul-Fitr and 'Id-ul-Adha (two feast days) and also the wearing of As-Samma' (a single garment covering the whole body), and sitting with one's leg drawn up while being wrapped in one garment. He also forbade the prayers after the Fajr (morning) and the 'Asr (afternoon) prayers.


Bukhari :: Fasting :: [3.31.213]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 213

Narrated Abu Huraira:

Two fasts and two kinds of sale are forbidden: fasting on the day of 'Id ul Fitr and 'Id-ul-Adha and the kinds of sale called Mulamasa and Munabadha. (These two kinds of sale used to be practiced in the days of Pre-lslamic period of ignorance; Mulamasa means when you touch something displayed for sale you have to buy it; Munabadha means when the seller throws something to you, you have to buy it.)


Bukhari :: Fasting :: [3.31.214]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 214

Narrated Ziyad bin Jubair:

A man went to Ibn 'Umar I. and said, "A man vowed to fast one day (the sub-narrator thinks that he said that the day was Monday), and that day happened to be 'Id day." Ibn 'Umar said, "Allah orders vows to be fulfilled and the Prophet forbade the fasting on this day (i.e. Id)."


Bukhari :: Fasting :: [3.31.215]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 215

Narrated Abu Said Al-Khudri:

(who fought in twelve Ghazawat in the company of the Prophet). I heard four things from the Prophet and they won my admiration. He said;

1. "No lady should travel on a journey of two days except with her husband or a Dhi-Mahram;

2. "No fasting is permissible on the two days of Id-ul-Fitr and 'Id-ul-Adha;

3. "No prayer (may be offered) after the morning compulsory prayer until the sun rises; and no prayer after the 'Asr prayer till the sun sets;

4. "One should travel only for visiting three Masajid (Mosques): Masjid-ul-Haram (Mecca), Masjid-ul-Aqsa (Jerusalem), and this (my) Mosque (at Medina)."


Bukhari :: Fasting :: [3.31.216]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 216

Narrated 'Aisha and Ibn 'Umar:

Nobody was allowed to fast on the days of Tashrlq except those who could not afford the Hadi (Sacrifice).


Bukhari :: Fasting :: [3.31.217]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 217

Narrated Ibn 'Umar:

Fasting for those who perform ,Hajj-at-Tamattu' (in lieu of the Hadi which they cannot afford) may be performed up to the day of 'Arafat. And if one does not get a Hadi and has not fasted (before the 'Id) then one should fast of the days of Mina. (11, 12 and 13th of Dhul Hajja).


Bukhari :: Fasting :: [3.31.218]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 218

Narrated Salim's father:

The Prophet said, "Whoever wishes may fast on the day of 'Ashura'."


Bukhari :: Fasting :: [3.31.219]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 219

Narrated 'Aisha:

Allah's Apostle ordered (the Muslims) to fast on the day of 'Ashura', and when fasting in the month of Ramadan was prescribed, it became optional for one to fast on that day ('Ashura') or not.


Bukhari :: Fasting :: [3.31.220]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 220

Narrated Aisha:

Quraish used to fast on the day of 'Ashura' in the Pre-lslamic period, and Allah's Apostle too, used to fast on that day. When he came to Medina, he fasted on that day and ordered others to fast, too. Later when the fasting of the month of Ramadan was prescribed, he gave up fasting on the day of 'Ashura' and it became optional for one to fast on it or not.


Bukhari :: Fasting :: [3.31.221]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 221

Narrated Humaid bin 'Abdur Rahman:

That he heard Muawiya bin Abi Sufyan on the day of 'Ashura' during the year he performed the Hajj, saying on the pulpit, "O the people of Medina! Where are your Religious Scholars? I heard Allah's Apostle saying, 'This is the day of 'Ashura'. Allah has not enjoined its fasting on you but I am fasting it. You have the choice either to fast or not to fast (on this day).' "


Bukhari :: Fasting :: [3.31.222]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 222

Narrated Ibn 'Abbas:

The Prophet came to Medina and saw the Jews fasting on the day of Ashura. He asked them about that. They replied, "This is a good day, the day on which Allah rescued Bani Israel from their enemy. So, Moses fasted this day." The Prophet said, "We have more claim over Moses than you." So, the Prophet fasted on that day and ordered (the Muslims) to fast (on that day).


Bukhari :: Fasting :: [3.31.223]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 223

Narrated Abu Musa:

The day of 'Ashura' was considered as 'Id day by the Jews. So the Prophet ordered, "I recommend you (Muslims) to fast on this day."


Bukhari :: Fasting :: [3.31.224]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 224

Narrated Ibn 'Abbas:

I never saw the Prophet seeking to fast on a day more (preferable to him) than this day, the day of 'Ashura', or this month, i.e. the month of Ramadan.


Bukhari :: Fasting :: [3.31.225]

Fasting

Bukhari :: Book 3 :: Volume 31 :: Hadith 225

Narrated Salama bin Al-Akwa:

The Prophet ordered a man from the tribe of Bani Aslam to announce amongst the people that whoever had eaten should fast the rest of the day, and whoever had not eaten should continue his fast, as that day was the day of 'Ashura' .


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.226]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 226

Narrated Abu Huraira:

I heard Allah's Apostle saying regarding Ramadan, "Whoever prayed at night in it (the month of Ramadan) out of sincere Faith and hoping for a reward from Allah, then all his previous sins will be forgiven."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.227]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 227

Narrated Abu Huraira:

Allah's Apostle said, "Whoever prayed at night the whole month of Ramadan out of sincere Faith and hoping for a reward from Allah, then all his previous sins will be forgiven." Ibn Shihab (a sub-narrator) said, "Allah's Apostle died and the people continued observing that (i.e. Nawafil offered individually, not in congregation), and it remained as it was during the Caliphate of Abu Bakr and in the early days of 'Umar's Caliphate." 'Abdur Rahman bin 'Abdul Qari said, "I went out in the company of 'Umar bin Al-Khattab one night in Ramadan to the mosque and found the people praying in different groups. A man praying alone or a man praying with a little group behind him. So, 'Umar said, 'In my opinion I would better collect these (people) under the leadership of one Qari (Reciter) (i.e. let them pray in congregation!)'. So, he made up his mind to congregate them behind Ubai bin Ka'b. Then on another night I went again in his company and the people were praying behind their reciter. On that, 'Umar remarked, 'What an excellent Bid'a (i.e. innovation in religion) this is; but the prayer which they do not perform, but sleep at its time is better than the one they are offering.' He meant the prayer in the last part of the night. (In those days) people used to pray in the early part of the night."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.228]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 228

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle used to pray (at night) in Ramadan.


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.229]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 229

Narrated 'Urwa:

That he was informed by 'Aisha, "Allah's Apostle went out in the middle of the night and prayed in the mosque and some men prayed behind him. In the morning, the people spoke about it and then a large number of them gathered and prayed behind him (on the second night). In the next morning the people again talked about it and on the third night the mosque was full with a large number of people. Allah's Apostle came out and the people prayed behind him. On the fourth night the Mosque was overwhelmed with people and could not accommodate them, but the Prophet came out (only) for the morning prayer. When the morning prayer was finished he recited Tashah-hud and (addressing the people) said, "Amma ba'du, your presence was not hidden from me but I was afraid lest the night prayer (Qiyam) should be enjoined on you and you might not be able to carry it on." So, Allah's Apostle died and the situation remained like that (i.e. people prayed individually). "


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.230]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 230

Narrated Abu Salama bin 'Abdur Rahman:

that he asked 'Aisha "How was the prayer of Allah's Apostle in Ramadan?" She replied, "He did not pray more than eleven Rakat in Ramadan or in any other month. He used to pray four Rakat ---- let alone their beauty and length----and then he would pray four ----let alone their beauty and length ----and then he would pray three Rakat (Witr)." She added, "I asked, 'O Allah's Apostle! Do you sleep before praying the Witr?' He replied, 'O 'Aisha! My eyes sleep but my heart does not sleep."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.231]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 231

Narrated Abu Huraira:

The Prophet said, "Whoever fasted the month of Ramadan out of sincere Faith (i.e. belief) and hoping for a reward from Allah, then all his past sins will be forgiven, and whoever stood for the prayers in the night of Qadr out of sincere Faith and hoping for a reward from Allah, then all his previous sins will be forgiven ."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.232]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 232

Narrated Ibn 'Umar:

Some men amongst the companions of the Prophet were shown in their dreams that the night of Qadr was in the last seven nights of Ramadan. Allah's Apostle said, "It seems that all your dreams agree that (the Night of Qadr) is in the last seven nights, and whoever wants to search for it (i.e. the Night of Qadr) should search in the last seven (nights of Ramadan)."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.233]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 233

Narrated Abu Salama:

I asked Abu Sa'id, and he was a friend of mine, (about the Night of Qadr) and he said, "We practiced Itikaf (seclusion in the mosque) in the middle third of the month of Ramadan with the Prophet . In the morning of the 20th of Ramadan, the Prophet came and addressed us and said, 'I was informed of (the date of the Night of Qadr) but I was caused to forget it; so search for it in the odd nights of the last ten nights of the month of Ramadan. (In the dream) I saw myself prostrating in mud and water (as a sign). So, whoever was in l'tikaf with me should return to it with me (for another 10-day's period)', and we returned. At that time there was no sign of clouds in the sky but suddenly a cloud came and it rained till rain-water started leaking through the roof of the mosque which was made of date-palm leaf stalks. Then the prayer was established and I saw Allah's Apostle prostrating in mud and water and I saw the traces of mud on his forehead."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.234]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 234

Narrated 'Aisha:

Allah's Apostle said, "Search for the Night of Qadr in the odd nights of the last ten days of Ramadan."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.235]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 235

Narrated Abu Said Al-Khudri:

Allah's Apostle used to practice Itikaf (in the mosque) in the middle third of Ramadan and after passing the twenty nights he used to go back to his house on the 21st, and the people who were in Itikaf with him also used to go back to their houses. Once in Ramadan, in which he practiced Itikaf, he established the night prayers at the night in which he used to return home, and then he addressed the people and ordered them whatever Allah wished him to order and said, "I used to practice Itikaf for these ten days (i.e. the middle 113rd but now I intend to stay in Itikaf for the last ten days (of the month); so whoever was in Itikaf with me should stay at his place of seclusion. I have verily been shown (the date of) this Night (of Qadr) but I have forgotten it. So search for it in the odd nights of the last ten days (of this month). I also saw myself (in the dream) prostrating in mud and water." On the night of the 21st, the sky was covered with clouds and it rained, and the rain-water started leaking through the roof of the mosque at the praying place of the Prophet . I saw with my own eyes the Prophet at the completion of the morning prayer leaving with his face covered with mud and water.


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.236]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 236

Narrated 'Aisha:

The Prophet said, "Look for (the Night of Qadr)."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.237]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 237

Narrated 'Aisha:

Allah's Apostle used to practice Itikaf in the last ten nights of Ramadan and used to say, "Look for the Night of Qadr in the last ten nights of the month of Ramadan ,"


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.238]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 238

Narrated Ibn Abbas:

The Prophet said, "Look for the Night of Qadr in the last ten nights of Ramadan ,' on the night when nine or seven or five nights remain out of the last ten nights of Ramadan (i.e. 21, 23, 25, respectively)."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.239]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 239

Narrated Ibn 'Abbas:

Allah's Apostle said, "The Night of Qadr is in the last ten nights of the month (Ramadan), either on the first nine or in the last (remaining) seven nights (of Ramadan)." Ibn 'Abbas added, "Search for it on the twenty-fourth (of Ramadan)."


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.240]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 240

Narrated 'Ubada bin As-Samit:

The Prophet came out to inform us about the Night of Qadr but two Muslims were quarreling with each other. So, the Prophet said, "I came out to inform you about the Night of Qadr but such-and-such persons were quarreling, so the news about it had been taken away; yet that might be for your own good, so search for it on the 29th, 27th and 25th (of Ramadan).


Bukhari :: Praying at Night in Ramadaan (Taraweeh) :: [3.32.241]

Praying at Night in Ramadaan (Taraweeh)

Bukhari :: Book 3 :: Volume 32 :: Hadith 241

Narrated Aisha:

With the start of the last ten days of Ramadan, the Prophet used to tighten his waist belt (i.e. work hard) and used to pray all the night, and used to keep his family awake for the prayers.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.242]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 242

Narrated Abdullah bin Umar:

Allah's Apostle used to practise Itikaf in the last ten days of the month of Ramadan.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.243]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 243

Narrated 'Aisha:

(the wife of the Prophet) The Prophet used to practice Itikaf in the last ten days of Ramadan till he died and then his wives used to practice Itikaf after him.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.244]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 244

Narrated Abu Said Al-Khudri:

Allah's Apostle used to practice Itikaf in the middle ten days of Ramadan and once he stayed in Itikaf till the night of the twenty-first and it was the night in the morning of which he used to come out of his Itikaf. The Prophet said, "Whoever was in Itikaf with me should stay in Itikaf for the last ten days, for I was informed (of the date) of the Night (of Qadr) but I have been caused to forget it. (In the dream) I saw myself prostrating in mud and water in the morning of that night. So, look for it in the last ten nights and in the odd ones of them." It rained that night and the roof of the mosque dribbled as it was made of leaf stalks of date-palms. I saw with my own eyes the mark of mud and water on the forehead of the Prophet (i.e. in the morning of the twenty-first).


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.245]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 245

Narrated 'Aisha:

The Prophet used to (put) bend his head (out) to me while he was in Itikaf in the mosque during my monthly periods and I would comb and oil his hair.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.246]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 246

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle used to let his head in (the house) while he was in the mosque and I would comb and oil his hair. When in Itikaf he used not to enter the house except for a need.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.247]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 247

Narrated 'Aisha:

The Prophet used to embrace me during my menses. He also used to put his head out of the mosque while he was in Itikaf, and I would wash it during my menses.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.248]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 248

Narrated Ibn 'Umar:

Umar asked the Prophet "I vowed in the Pre-lslamic period of ignorance to stay in Itikaf for one night in Al-Masjid al-Haram." The Prophet said to him, "Fulfill your vow."


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.249]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 249

Narrated 'Amra:

Aisha said, "the Prophet used to practice Itikaf in the last ten days of Ramadan and I used to pitch a tent for him, and after offering the morning prayer, he used to enter the tent." Hafsa asked the permission of 'Aisha to pitch a tent for her and she allowed her and she pitched her tent. When Zainab bint Jahsh saw it, she pitched another tent. In the morning the Prophet noticed the tents. He said, 'What is this?" He was told of the whole situation. Then the Prophet said, "Do you think that they intended to do righteousness by doing this?" He therefore abandoned the Itikaf in that month and practiced Itikaf for ten days in the month of Shawwal."


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.250]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 250

Narrated 'Aisha:

The Prophet intended to practice Itikaf and when he reached the place where he intended to perform Itikaf, he saw some tents, the tents of 'Aisha, Hafsa and Zainab. So, he said, "Do you consider that they intended to do righteousness by doing this?" And then he went away and did not perform Itikaf (in Ramadan) but performed it in the month of Shawwal for ten days.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.251]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 251

Narrated Ali bin Al-Husain:

Safiya, the wife of the Prophet told me that she went to Allah's Apostle to visit him in the mosque while he was in Itikaf in the last ten days of Ramadan. She had a talk with him for a while, then she got up in order to return home. The Prophet accompanied her. When they reached the gate of the mosque, opposite the door of Um-Salama, two Ansari men were passing by and they greeted Allah's Apostle . He told them: Do not run away! And said, "She is (my wife) Safiya bint Huyai." Both of them said, "Subhan Allah, (How dare we think of any evil) O Allah's Apostle!" And they felt it. The Prophet said (to them), "Satan reaches everywhere in the human body as blood reaches in it, (everywhere in one's body). I was afraid lest Satan might insert an evil thought in your minds."


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.252]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 252

Narrated Abu Salama bin 'Abdur-Rahman:

I asked Abu Said Al-Khudri, "Did you hear Allah's Apostle talking about the Night of Qadr?" He replied in the affirmative and said, "Once we were in Itikaf with Allah's Apostle in the middle ten days of (Ramadan) and we came out of it in the morning of the twentieth, and Allah's Apostle- delivered a sermon on the 20th (of Ramadan) and said, 'I was informed (of the date) of the Night of Qadr (in my dream) but had forgotten it. So, look for it in the odd nights of the last ten nights of the month of Ramadan. I saw myself prostrating in mud and water on that night (as a sign of the Night of Qadr). So, whoever had been in Itikaf with Allah's Apostle should return for it.' The people returned to the mosque (for Itikaf). There was no trace of clouds in the sky. But all of a sudden a cloud came and it rained. Then the prayer was established (they stood for the prayer) and Allah's Apostle prostrated in mud and water and I saw mud over the forehead and the nose of the Prophet.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.253]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 253

Narrated 'Aisha:

One of the wives of Allah's Apostle practiced Itikaf with him while she ad bleeding in between her periods and she would see red (blood) or yellowish traces, and sometimes we put a tray beneath her when she offered the prayer.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.254]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 254

Narrated 'Ali bin Al-Husain (from Safiya, the Prophet's wife):

The wives of the Prophet were with him in the mosque (while he was in Itikaf) and then they departed and the Prophet said to Safiya bint Huyai, "Don't hurry up, for I shall accompany you," (and her dwelling was in the house of Usama). The Prophet went out and in the meantime two Ansari men met him and they looked at the Prophet and passed by. The Prophet said to them, "Come here. She is (my wife) Safiya bint Huyai." They replied, "Subhan Allah, (How dare we think of evil) O Allah's Apostle! (we never expect anything bad from you)." The Prophet replied, "Satan circulates in the human being as blood circulates in the body, and I was afraid lest Satan might insert an evil thought in your minds."


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.255]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 255

Narrated 'Ali bin Al-Husain from Safiya:

Safiya went to the Prophet while he was in Itikaf. When she returned, the Prophet accompanied her walking. An Ansari man saw him. When the Prophet noticed him, he called him and said, "Come here. She is Safiya. (Sufyan a sub-narrator perhaps said that the Prophet had said, "This is Safiya"). And Satan circulates in the body of Adam's offspring as his blood circulates in it."

(A sub-narrator asked Sufyan, "Did Safiya visit him at night?" He said, "Of course, at night.")


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.256]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 256

Narrated Abu Said:

We practiced Itikaf with Allah's Apostle in the middle ten days (of Ramadan). In the morning of the twentieth (of Ramadan) we shifted our baggage, but Allah's Apostle came to us and said, "Whoever was m Itikaf should return to his place of Itikaf, for I saw (i.e. was informed about the date of) this Night (of Qadr) and saw myself prostrating in mud and water." When I returned to my place the sky was overcast with clouds and it rained. By Him Who sent Muhammad with the Truth, the sky was covered with clouds from the end of that day, and the mosque which was roofed with leaf-stalks of date palm trees (leaked with rain) and I saw the trace of mud and water over the nose of the Prophet and its tip.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.257]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 257

Narrated 'Amra bint 'Abdur-Rahman from 'Aisha:

Allah's Apostle used to practice Itikaf every year in the month of Ramadan. And after offering the morning prayer, he used to enter the place of his Itikaf. 'Aisha asked his permission to let her practice Itikaf and he allowed her, and so she pitched a tent in the mosque. When Hafsa heard of that, she also pitched a tent (for herself), and when Zainab heard of that, she too pitched another tent. When, in the morning, Allah's Apostle had finished the morning prayer, he saw four tents and asked, "What is this?" He was informed about it. He then said, "What made them do this? Is it righteousness? Remove the tents, for I do not want to see them." So, the tents were removed. The Prophet did not perform Itikaf that year in the month of Ramadan, but did it in the last ten days of Shawwal.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.258]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 258

Narrated Abdullah bin Umar:

'Umar bin Al-Khattab said, "O Allah's Apostle! I vowed in the Pre-lslamic period to perform Itikaf in Al-Masjid-al-Haram for one night." The Prophet said, "Fulfill your vow." So, he performed Itikaf for one night.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.259]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 259

Narrated Ibn 'Umar:

that 'Umar had vowed in the Pre-lslamic period to perform Itikaf in Al-Masjid-al-Haram. (A sub-narrator thinks that 'Umar vowed to perform Itikaf for one night.) Allah's Apostle said to 'Umar, "Fulfill your vow."


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.260]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 260

Narrated Abu Huraira:

The Prophet used to perform Itikaf every year in the month of Ramadan for ten days, and when it was the year of his death, he stayed in Itikaf for twenty days.


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.261]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 261

Narrated 'Amra bint 'AbdurRahman from 'Aisha: Allah's Apostle mentioned that he would practice Itikaf in the last ten days of Ramadan. 'Aisha asked his permission to perform Itikaf and he permitted her. Hafsa asked 'Aisha to take his permission for


Bukhari :: Retiring to a Mosque for Remembrance of Allah (I'tikaf) :: [3.33.262]

Retiring to a Mosque for Remembrance of Allah (I'tikaf)

Bukhari :: Book 3 :: Volume 33 :: Hadith 262

Narrated 'Urwa:

Aisha during her menses used to comb and oil the hair of the Prophet while he used to be in Itikaf in the mosque. He would stretch out his head towards her while she was in her chamber.


Bukhari :: Sales and Trade :: [3.34.263]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 263

Narrated Abu Huraira:

You people say that Abu Huraira tells many narrations from Allah's Apostle and you also wonder why the emigrants and Ansar do not narrate from Allah's Apostle as Abu Huraira does. My emigrant brothers were busy in the market while I used to stick to Allah's Apostle content with what fills my stomach; so I used to be present when they were absent and I used to remember when they used to forget, and my Ansari brothers used to be busy with their properties and I was one of the poor men of Suffa. I used to remember the narrations when they used to forget. No doubt, Allah's Apostle once said, "Whoever spreads his garment till I have finished my present speech and then gathers it to himself, will remember whatever I will say." So, I spread my colored garment which I was wearing till Allah's Apostle had finished his saying, and then I gathered it to my chest. So, I did not forget any of that narrations.


Bukhari :: Sales and Trade :: [3.34.264]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 264

Narrated Ibrahim bin Sad from his father from his grand-father:

Abdur Rahman bin Auf said, "When we came to Medina as emigrants, Allah's Apostle established a bond of brotherhood between me and Sad bin Ar-Rabi'. Sad bin Ar-Rabi' said (to me), 'I am the richest among the Ansar, so I will give you half of my wealth and you may look at my two wives and whichever of the two you may choose I will divorce her, and when she has completed the prescribed period (before marriage) you may marry her.' Abdur-Rahman replied, "I am not in need of all that. Is there any market-place where trade is practiced?' He replied, "The market of Qainuqa." Abdur-Rahman went to that market the following day and brought some dried butter-milk (yogurt) and butter, and then he continued going there regularly. Few days later, 'AbdurRahman came having traces of yellow (scent) on his body. Allah's Apostle asked him whether he had got married. He replied in the affirmative. The Prophet said, 'Whom have you married?' He replied, 'A woman from the Ansar.' Then the Prophet asked, 'How much did you pay her?' He replied, '(I gave her) a gold piece equal in weigh to a date stone (or a date stone of gold)! The Prophet said, 'Give a Walima (wedding banquet) even if with one sheep .' "


Bukhari :: Sales and Trade :: [3.34.265]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 265

Narrated Anas:

When Abdur-Rahman bin Auf came to Medina, the Prophet established a bond of brotherhood between him and Sad bin Ar-Rabi al-Ansari. Sad was a rich man, so he said to 'Abdur-Rahman, "I will give you half of my property and will help you marry." 'Abdur-Rahman said (to him), "May Allah bless you in your family and property. Show me the market." So 'Abdur-Rahman did not return from the market) till he gained some dried buttermilk (yoghurt) and butter (through trading). He brought that to his house-hold. We stayed for some-time (or as long as Allah wished), and then Abdur-Rahman came, scented with yellowish perfume. The Prophet said (to him) "What is this?" He replied, "I got married to an Ansari woman." The Prophet asked, "What did you pay her?" He replied, "A gold stone or gold equal to the weight of a date stone." The Prophet said (to him), "Give a wedding banquet even if with one sheep."


Bukhari :: Sales and Trade :: [3.34.266]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 266

Narrated Ibn 'Abbas:

'Ukaz, Majanna and Dhul-Majaz were market-places in the Pre-lslamic period of ignorance. When Islam came, Muslims felt that marketing there might be a sin. So, the Divine Inspiration came: "There is no harm for you to seek the bounty of your Lord (in the seasons of Hajj)." (2.198) Ibn 'Abbas recited the Verse in this way.


Bukhari :: Sales and Trade :: [3.34.267]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 267

Narrated An-Nu'man bin Bashir:

The Prophet said "Both legal and illegal things are obvious, and in between them are (suspicious) doubtful matters. So who-ever forsakes those doubtful things lest he may commit a sin, will definitely avoid what is clearly illegal; and who-ever indulges in these (suspicious) doubtful things bravely, is likely to commit what is clearly illegal. Sins are Allah's Hima (i.e. private pasture) and whoever pastures (his sheep) near it, is likely to get in it at any moment."


Bukhari :: Sales and Trade :: [3.34.268]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 268

Narrated Abdullah bin Abu Mulaika:

y the same woman)?" His wife was the daughter of Abu Ihab-al-Tamimi.


Bukhari :: Sales and Trade :: [3.34.269]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 269

Narrated Aisha:

Utba bin Abu Waqqas took a firm promise from his brother Sad bin Abu Waqqas to take the son of the slave-girl of Zam'a into his custody as he was his (i.e. 'Utba's) son. In the year of the Conquest (of Mecca) Sad bin Abu Waqqas took him, and said that he was his brother's son, and his brother took a promise from him to that effect. 'Abu bin Zam'a got up and said, "He is my brother and the son of the slave-girl of my father and was born on my father's bed." Then they both went to the Prophet Sad said, "O Allah's Apostle! He is the son of my brother and he has taken a promise from me that I will take him." 'Abu bin Zam'a said, "(He is) my brother and the son of my father's slave-girl and was born on my father's bed." Allah's Apostle said, "The boy is for you. O 'Abu bin Zam'a." Then the Prophet said, "The son is for the bed (i.e the man on whose bed he was born) and stones (disappointment and deprivation) for the one who has done illegal sexual intercourse." The Prophet told his wife Sauda bint Zam'a to screen herself from that boy as he noticed a similarity between the boy and 'Utba. So, the boy did not see her till he died.


Bukhari :: Sales and Trade :: [3.34.270]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 270

Narrated 'Adi bin Hatim:

I asked Allah's Apostle about Al Mirad (i.e. a sharp-edged piece of wood or a piece of wood provided with a piece of iron used for hunting). He replied, "If the game is hit by its sharp edge, eat it, and if it is hit by its broad side, do not eat it, for it has been beaten to death." I asked, "O Allah's Apostle! I release my dog by the name of Allah and find with it at the game, another dog on which I have not mentioned the name of Allah, and I do not know which one of them caught the game." Allah's Apostle said (to him), 'Don't eat it as you have mentioned the name of Allah on your dog and not on the other dog."


Bukhari :: Sales and Trade :: [3.34.271]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 271

Narrated Anas:

The Prophet passed by a fallen date and said, "Were it not for my doubt that this might have been given in charity, I would have eaten it." And narrated Abu Huraira the Prophet said, "I found a date-fruit fallen on my bed."


Bukhari :: Sales and Trade :: [3.34.272]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 272

Narrated 'Abbas bin Tamim:

that his uncle said: "The Prophet was asked: If a person feels something during his prayer; should one interrupt his prayer?" The Prophet said: No! You should not give it up unless you hear a sound or smell something." Narrated Ibn Abi Hafsa: Az-Zuhri said, "There is no need of repeating ablution unless you detect a smell or hear a sound."


Bukhari :: Sales and Trade :: [3.34.273]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 273

Narrated 'Aisha:

Some people said, "O Allah's Apostle! Meat is brought to us by some people and we are not sure whether the name of Allah has been mentioned on it or not (at the time of slaughtering the animals)." Allah's Apostle said (to them), "Mention the name of Allah and eat it."


Bukhari :: Sales and Trade :: [3.34.274]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 274

Narrated Jabir:

While we were offering the prayer with the Prophet a caravan carrying food came from Sham. The people looked towards the caravan (and went to it) and only twelve persons remained with the Prophet. So, the Divine Inspiration came; "But when they see some bargain or some amusement, they disperse headlong to it." (62.11)


Bukhari :: Sales and Trade :: [3.34.275]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 275

Narrated Abu Huraira:

The Prophet said, "A time will come when one will not care how one gains one's money, legally or illegally."


Bukhari :: Sales and Trade :: [3.34.276]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 276

Narrated Abu Al-Minhal:

I used to practice money exchange, and I asked Zaid bin 'Arqam about it, and he narrated what the Prophet said in the following: Abu Al-Minhal said, "I asked Al-Bara' bin 'Azib and Zaid bin Arqam about practicing money exchange. They replied, 'We were traders in the time of Allah's Apostle and I asked Allah's Apostle about money exchange. He replied, 'If it is from hand to hand, there is no harm in it; otherwise it is not permissible."


Bukhari :: Sales and Trade :: [3.34.277]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 277

Narrated 'Ubai bin 'Umar:

Abu Musa asked Umar to admit him but he was not admitted as 'Umar was busy, so Abu Musa went back. When 'Umar finished his job he said, "Didn't I hear the voice of 'Abdullah bin Qais? Let him come in." 'Umar was told that he had left. So, he sent for him and on his arrival, he (Abu Musa) said, "We were ordered to do so (i.e. to leave if not admitted after asking permission thrice). 'Umar told him, "Bring witness in proof of your statement." Abu Musa went to the Ansar's meeting places and asked them. They said, "None amongst us will give this witness except the youngest of us, Abu Said Al-Khudri. Abu Musa then took Abu Said Al-Khudri (to 'Umar) and 'Umar said, surprisingly, "Has this order of Allah's Apostle been hidden from me?" (Then he added), "I used to be busy trading in markets."


Bukhari :: Sales and Trade :: [3.34.278]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 278

Narrated Jabir:

A caravan arrived (at Medina) while we were offering the Jumua prayer with the Prophet. The people left out for the caravan, with the exception of twelve persons. Then this Verse was revealed: 'But when they see some bargain or some amusement, they disperse headlong to it and leave you standing." (62.11)


Bukhari :: Sales and Trade :: [3.34.279]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 279

Narrated 'Aisha:

The Prophet said, "If a woman gives in charity from her house meals without wasting (i.e. being extravagant), she will get the reward for her giving, and her husband will also get the reward for his earning and the storekeeper will also get a similar reward. The acquisition of the reward of none of them will reduce the reward of the others."


Bukhari :: Sales and Trade :: [3.34.280]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 280

Narrated Abu Huraira:

The Prophet said, "If a woman gives something (i.e. in charity) from her husband's earnings without his permission, she will get half his reward."


Bukhari :: Sales and Trade :: [3.34.281]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 281

Narrated Anas bin Malik:

I heard Allah's Apostle saying, "whoever desires an expansion in his sustenance and age, should keep good relations with his Kith and kin."


Bukhari :: Sales and Trade :: [3.34.282]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 282

Narrated 'Aisha:

The Prophet purchased food grains from a Jew on credit and mortgaged his iron armor to him.


Bukhari :: Sales and Trade :: [3.34.283]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 283

Narrated Qatada:

Anas went to the Prophet with barley bread having some dissolved fat on it. The Prophet had mortgaged his armor to a Jew in Medina and took from him some barley for his family. Anas heard him saying, "The household of Muhammad did not possess even a single Sa of wheat or food grains for the evening meal, although he has nine wives to look after." (See Hadith No. 685)


Bukhari :: Sales and Trade :: [3.34.284]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 284

Narrated 'Aisha:

When Abu Bakr As-Siddiq was chosen Caliph, he said, "My people know that my profession was not incapable of providing substance to my family. And as I will be busy serving the Muslim nation, my family will eat from the National Treasury of Muslims, and I will practise the profession of serving the Muslims."


Bukhari :: Sales and Trade :: [3.34.285]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 285

Narrated Aisha:

The companions of Allah's Apostle used to practise manual labor, so their sweat used to smell, and they were advised to take a bath.


Bukhari :: Sales and Trade :: [3.34.286]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 286

Narrated Al-Miqdam:

The Prophet said, "Nobody has ever eaten a better meal than that which one has earned by working with one's own hands. The Prophet of Allah, David used to eat from the earnings of his manual labor."


Bukhari :: Sales and Trade :: [3.34.287]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 287

Narrated Abu Huraira:

Allah's Apostle said, "The Prophet David used not to eat except from the earnings of his manual labor."


Bukhari :: Sales and Trade :: [3.34.288]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 288

Narrated Abu Huraira:

Allah's Apostle said, "One would rather cut and carry a bundle of wood on his back than ask somebody who may or may not live him."


Bukhari :: Sales and Trade :: [3.34.289]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 289

Narrated Az-Zubair bin Al-Awwam:

The Prophet said, "One would rather take a rope and cut wood and carry it than ask others)."


Bukhari :: Sales and Trade :: [3.34.290]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 290

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "May Allah's mercy be on him who is lenient in his buying, selling, and in demanding back his money."


Bukhari :: Sales and Trade :: [3.34.291]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 291

Narrated Hudhaifa:

The Prophet said, "Before your time the angels received the soul of a man and asked him, 'Did you do any good deeds (in your life)?' He replied, 'I used to order my employees to grant time to the rich person to pay his debts at his convenience.' So Allah said to the angels; "Excuse him." Rabi said that (the dead man said), 'I used to be easy to the rich and grant time to the poor.' Or, in another narration, 'grant time to the well-off and forgive the needy,' or, 'accept from the well-off and forgive the needy.'


Bukhari :: Sales and Trade :: [3.34.292]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 292

Narrated Abu Huraira:

The Prophet said, "There was a merchant who used to lend the people, and whenever his debtor was in straitened circumstances, he would say to his employees, 'Forgive him so that Allah may forgive us.' So, Allah forgave him."


Bukhari :: Sales and Trade :: [3.34.293]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 293

Narrated Hakim bin Hizam:

Allah's Apostle said, "The seller and the buyer have the right to keep or return goods as long as they have not parted or till they part; and if both the parties spoke the truth and described the defects and qualities (of the goods), then they would be blessed in their transaction, and if they told lies or hid something, then the blessings of their transaction would be lost."


Bukhari :: Sales and Trade :: [3.34.294]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 294

Narrated Abu Said:

We used to be given mixed dates (from the booty) and used to sell (barter) two Sas of those dates) for one Sa (of good dates). The Prophet said (to us), "No (bartering of) two Sas for one Sa nor two Dirhams for one Dirham is permissible", (as that is a kind of usury). (See Hadith No. 405).


Bukhari :: Sales and Trade :: [3.34.295]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 295

Narrated Abu Mas'ud:

An Ansari man, called Abu Shu'aib, came and told his butcher slave, "Prepare meals sufficient for five persons, for I want to invite the Prophet along with four other persons as I saw signs of hunger on his face." Abu Shu'aib invited them and another person came along with them. The Prophet said (to Abu Shu'aib), This man followed us, so if you allow him, he will join us, and if you want him to return, he will go back." Abu Shu'aib said, "No, I have allowed him (i.e. he, too, is welcomed to the meal)."


Bukhari :: Sales and Trade :: [3.34.296]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 296

Narrated Hakim bin Hizam:

The Prophet aid, "The buyer and the seller have the option to cancel or to confirm the deal, as long as they have not parted or till they part, and if they spoke the truth and told each other the defects of the things, then blessings would be in their deal, and if they hid something and told lies, the blessing of the deal would be lost."


Bukhari :: Sales and Trade :: [3.34.297]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 297

Narrated Aisha:

When the last Verses of Surat al- Baqara were revealed, the Prophet recited them in the mosque and proclaimed the trade of alcohol as illegal.


Bukhari :: Sales and Trade :: [3.34.298]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 298

Narrated Samura bin Jundab:

The Prophet said, "This night I dreamt that two men came and took me to a Holy land whence we proceeded on till we reached a river of blood, where a man was standing, and on its bank was standing another man with stones in his hands. The man in the middle of the river tried to come out, but the other threw a stone in his mouth and forced him to go back to his original place. So, whenever he tried to come out, the other man would throw a stone in his mouth and force him to go back to his former place. I asked, 'Who is this?' I was told, 'The person in the river was a Riba-eater."


Bukhari :: Sales and Trade :: [3.34.299]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 299

Narrated 'Aun bin Abu Juhaifa:

My father bought a slave who practiced the profession of cupping. (My father broke the slave's instruments of cupping). I asked my father why he had done so. He replied, "The Prophet forbade the acceptance of the price of a dog or blood, and also forbade the profession of tattooing, getting tattooed and receiving or giving Riba, (usury), and cursed the picture-makers."


Bukhari :: Sales and Trade :: [3.34.300]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 300

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The swearing (by the seller) may persuade the buyer to purchase the goods but that will be deprived of Allah's blessing."


Bukhari :: Sales and Trade :: [3.34.301]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 301

Narrated 'Abdullah bin Abu Aufa:

A man displayed some goods in the market and swore by Allah that he had been offered so much for that, that which was not offered, and he said so, so as to cheat a Muslim. On that occasion the following Verse was revealed: "Verily! Those who purchase a small gain at the cost of Allah's covenant and their oaths (They shall have no portion in the Hereafter ..etc.)' (3.77)


Bukhari :: Sales and Trade :: [3.34.302]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 302

Narrated 'Ali:

I got an old she-camel as my share from the booty, and the Prophet had given me another from Al-Khumus. And when I intended to marry Fatima (daughter of the Prophet), I arranged that a goldsmith from the tribe of Bani Qainuqa' would accompany me in order to bring Idhkhir and then sell it to the goldsmiths and use its price for my marriage banquet.


Bukhari :: Sales and Trade :: [3.34.303]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 303

Narrated Ibn 'Abbas:

Allah's Apostle said, "Allah made Mecca a sanctuary and it was neither permitted for anyone before, nor will it be permitted for anyone after me (to fight in it). And fighting in it was made legal for me for a few hours of a day only. None is allowed to uproot its thorny shrubs or to cut down its trees or to chase its game or to pick up its Luqata (fallen things) except by a person who would announce it publicly." 'Abbas bin 'Abdul-Muttlib requested the Prophet, "Except Al-Idhkhir, for our goldsmiths and for the roofs of our houses." The Prophet said, "Except Al-Idhkhir." 'Ikrima said, "Do you know what is meant by chasing its game? It is to drive it out of the shade and sit in its place." Khalid said, "('Abbas said: Al-Idhkhir) for our goldsmiths and our graves."


Bukhari :: Sales and Trade :: [3.34.304]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 304

Narrated Khabbab:

I was a blacksmith in the Pre-lslamic period, and 'Asi bin Wail owed me some money, so I went to him to demand it. He said (to me), "I will not pay you unless you disbelieve Muhammad." I said, "I will not disbelieve till Allah kills you and then you get resurrected." He said, "Leave me till I die and get resurrected, then I will be given wealth and children and I will pay you your debt." On that occasion it was revealed to the Prophet:

'Have you seen him who disbelieved in Our signs and says: Surely I will be given wealth and children? Has he known the unseen, or has he taken a covenant from the Beneficent (Allah)? (19.77-78)


Bukhari :: Sales and Trade :: [3.34.305]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 305

Narrated Ishaq bin 'Abdullah bin Abu Talha:

I heard Anas bin Malik saying, "A tailor invited Allah's Apostle to a meal which he had prepared. " Anas bin Malik said, "I accompanied Allah's Apostle to that meal. He served the Prophet with bread and soup made with gourd and dried meat. I saw the Prophet taking the pieces of gourd from the dish." Anas added, "Since that day I have continued to like gourd."


Bukhari :: Sales and Trade :: [3.34.306]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 306

Narrated Abu Hazim:

I heard Sahl bin Sad saying, "A woman brought a Burda (i.e. a square piece of cloth having edging). I asked, 'Do you know what a Burda is?' They replied in the affirmative and said, "It is a cloth sheet with woven margins." Sahl went on, "She addressed the Prophet and said, 'I have woven it with my hands for you to wear.' The Prophet took it as he was in need of it, and came to us wearing it as a waist sheet. One of us said, 'O Allah's Apostle! Give it to me to wear.' The Prophet agreed to give it to him. The Prophet sat with the people for a while and then returned (home), wrapped that waist sheet and sent it to him. The people said to that man, 'You haven't done well by asking him for it when you know that he never turns down anybody's request.' The man replied, 'By Allah, I have not asked him for it except to use it as my shroud when I die." Sahl added; "Later it (i.e. that sheet) was his shroud."


Bukhari :: Sales and Trade :: [3.34.307]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 307

Narrated Abu Hazim:

Some men came to Sahl bin Sad to ask him about the pulpit. He replied, "Allah's Apostle sent for a woman (Sahl named her) (this message): 'Order your slave carpenter to make pieces of wood (i.e. a pulpit) for me so that I may sit on it while addressing the people.' So, she ordered him to make it from the tamarisk of the forest. He brought it to her and she sent it to Allah's Apostle . Allah's Apostle ordered it to be placed in the mosque: so, it was put and he sat on it.


Bukhari :: Sales and Trade :: [3.34.308]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 308

Narrated Jabir bin Abdullah: An Ansari woman said to Allah's Apostle, "O Allah's Apostle! Shall I make something for you to sit on, as I have a slave who is a carpenter?" He replied, "If you wish." So, she got a pulpit made for him. When it was Friday


Bukhari :: Sales and Trade :: [3.34.309]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 309

Narrated 'Aisha:

Allah's Apostle bought food grains from a Jew on credit and mortgaged his armor to him.


Bukhari :: Sales and Trade :: [3.34.310]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 310

Narrated Jabir bin 'Abdullah:

I was with the Prophet in a Ghazwa (Military Expedition) and my camel was slow and exhausted. The Prophet came up to me and said, "O Jabir." I replied, "Yes?" He said, "What is the matter with you?" I replied, "My camel is slow and tired, so I am left behind." So, he got down and poked the camel with his stick and then ordered me to ride. I rode the camel and it became so fast that I had to hold it from going ahead of Allah's Apostle . He then asked me, have you got married?" I replied in the affirmative. He asked, "A virgin or a matron?" I replied, "I married a matron." The Prophet said, "Why have you not married a virgin, so that you may play with her and she may play with you?" Jabir replied, "I have sisters (young in age) so I liked to marry a matron who could collect them all and comb their hair and look after them." The Prophet said, "You will reach, so when you have arrived (at home), I advise you to associate with your wife (that you may have an intelligent son)." Then he asked me, "Would you like to sell your camel?" I replied in the affirmative and the Prophet purchased it for one Uqiya of gold. Allah's Apostle reached before me and I reached in the morning, and when I went to the mosque, I found him at the door of the mosque. He asked me, "Have you arrived just now?" I replied in the affirmative. He said, "Leave your camel and come into (the mosque) and pray two Rakat." I entered and offered the prayer. He told Bilal to weigh and give me one Uqiya of gold. So Bilal weighed for me fairly and I went away. The Prophet sent for me and I thought that he would return to me my camel which I hated more than anything else. But the Prophet said to me, "Take your camel as well as its price."


Bukhari :: Sales and Trade :: [3.34.311]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 311

Narrated Ibn 'Abbas:

'Ukaz, Majanna and Dhul-Majaz were markets in the Pre-lslamic period. When the people embraced Islam they considered it a sin to trade there. So, the following Holy Verse came:-- 'There is no harm for you if you seek of the bounty of your Lord (Allah) in the Hajj season." (2.198) Ibn 'Abbas recited it like this.


Bukhari :: Sales and Trade :: [3.34.312]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 312

Narrated 'Amr:

Here (i.e. in Mecca) there was a man called Nawwas and he had camels suffering from the disease of excessive and unquenchable thirst. Ibn 'Umar went to the partner of Nawwas and bought those camels. The man returned to Nawwas and told him that he had sold those camels. Nawwas asked him, "To whom have you sold them?" He replied, "To such and such Sheikh." Nawwas said, "Woe to you; By Allah, that Sheikh was Ibn 'Umar." Nawwas then went to Ibn 'Umar and said to him, "My partner sold you camels suffering from the disease of excessive thirst and he had not known you." Ibn 'Umar told him to take them back. When Nawwas went to take them, Ibn 'Umar said to him, "Leave them there as I am happy with the decision of Allah's Apostle that there is no oppression . "


Bukhari :: Sales and Trade :: [3.34.313]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 313

Narrated Abu Qatada:

We set out with Allah's Apostle in the year of Hunain, (the Prophet gave me an armor). I sold that armor and bought a garden in the region of the tribe of Bani Salama and that was the first property I got after embracing Islam.


Bukhari :: Sales and Trade :: [3.34.314]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 314

Narrated Abu Musa:

Allah's Apostle said, "The example of a good companion (who sits with you) in comparison with a bad one, is I like that of the musk seller and the blacksmith's bellows (or furnace); from the first you would either buy musk or enjoy its good smell while the bellows would either burn your clothes or your house, or you get a bad nasty smell thereof."


Bukhari :: Sales and Trade :: [3.34.315]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 315

Narrated Anas bin Malik:

Abu Taiba cupped Allah's Apostle so he ordered that he be paid one Sa of dates and ordered his masters to reduce his tax (as he was a slave and had to pay a tax to them).


Bukhari :: Sales and Trade :: [3.34.316]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 316

Narrated Ibn 'Abbas:

Once the Prophet got his blood out (medically) and paid that person who had done it. If it had been illegal, the Prophet would not have paid him.


Bukhari :: Sales and Trade :: [3.34.317]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 317

Narrated 'Abdullah bin Umar:

Once the Prophet sent to 'Umar a silken two-piece garment, and when he saw 'Umar wearing it, he said to him, "I have not sent it to you to wear. It is worn by him who has no share in the Hereafter, and I have sent it to you so that you could benefit by it (i.e. sell it)."


Bukhari :: Sales and Trade :: [3.34.318]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 318

Narrated Aisha:

(mother of the faithful believers) I bought a cushion with pictures on it. When Allah's Apostle saw it, he kept standing at the door and did not enter the house. I noticed the sign of disgust on his face, so I said, "O Allah's Apostle! I repent to Allah and H is Apostle . (Please let me know) what sin I have done." Allah's Apostle said, "What about this cushion?" I replied, "I bought it for you to sit and recline on." Allah's Apostle said, "The painters (i.e. owners) of these pictures will be punished on the Day of Resurrection. It will be said to them, 'Put life in what you have created (i.e. painted).' " The Prophet added, "The angels do not enter a house where there are pictures."


Bukhari :: Sales and Trade :: [3.34.319]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 319

Narrated Anas:

The Prophet said, "O Bani Najjar! Suggest a price for your garden." Part of it was a ruin and it contained some date palms.


Bukhari :: Sales and Trade :: [3.34.320]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 320

Narrated Ibn 'Umar:

The Prophet said, "The buyer and the seller have the option to cancel or confirm the bargain before they separate from each other or if the sale is optional." Nafi said, "Ibn 'Umar used to separate quickly from the seller if he had bought a thing which he liked."


Bukhari :: Sales and Trade :: [3.34.321]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 321

Narrated Haklm bin Hizam"

The Prophet said, "The buyer and the seller have the option of cancelling or confirming the deal unless they separate."


Bukhari :: Sales and Trade :: [3.34.322]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 322

Narrated Ibn 'Umar:

Allah's Apostle said, "The seller and the buyer have the option of cancelling or confirming the deal unless they separate, or one of them says to the other, 'Choose (i.e. decide to cancel or confirm the bargain now)." Perhaps he said, 'Or if it is an optional sale.' " Ibn Umar, Shuraih, Ash-Shabi, Tawus, Ata, and Ibn Abu Mulaika agree upon this judgment.


Bukhari :: Sales and Trade :: [3.34.323]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 323

Narrated Hakim bin Hizam:

The Prophet said, "The buyer and the seller have the option of cancelling or confirming the bargain unless they separate, and if they spoke the truth and made clear the defects of the goods, them they would be blessed in their bargain, and if they told lies and hid some facts, their bargain would be deprived of Allah's blessings."


Bukhari :: Sales and Trade :: [3.34.324]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 324

Narrated Abdullah bin Umar: Allah's Apostle said, "Both the buyer and the seller have the option of cancelling or confirming a bargain unless they separate, or the sale is optional." (See Hadith No.320).


Bukhari :: Sales and Trade :: [3.34.325]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 325

Narrated Ibn Umar: Allah's Apostle said, "Both the buyer and the seller have the option of cancelling or confirming the bargain, as long as they are still together, and unless they separate or one of them gives the other the option of keeping or re


Bukhari :: Sales and Trade :: [3.34.326]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 326

Narrated Ibn 'Umar:

The Prophet said, "No deal is settled and finalized unless the buyer and the seller separate, except if the deal is optional (whereby the validity of the bargain depends on the stipulations agreed upon)."


Bukhari :: Sales and Trade :: [3.34.327]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 327

Narrated Hakim bin Hizam:

The Prophet said, "Both the buyer and the seller have the option of cancelling or confirming the bargain unless they separate." The sub-narrator, Hammam said, "I found this in my book: 'Both the buyer and the seller give the option of either confirming or cancelling the bargain three times, and if they speak the truth and mention the defects, then their bargain will be blessed, and if they tell lies and conceal the defects, they might gain some financial gain but they will deprive their sale of (Allah's) blessings."


Bukhari :: Sales and Trade :: [3.34.328]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 328

Narrated Abdullah bin Umar:

A person came to the Prophet and told him that he was always betrayed in purchasing. The Prophet told him to say at the time of buying, "No cheating."


Bukhari :: Sales and Trade :: [3.34.329]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 329

Narrated 'Aisha:

Allah's Apostle said, "An army will invade the Ka'ba and when the invaders reach Al-Baida', all the ground will sink and swallow the whole army." I said, "O Allah's Apostle! How will they sink into the ground while amongst them will be their markets (the people who worked in business and not invaders) and the people not belonging to them?" The Prophet replied, "all of those people will sink but they will be resurrected and judged according to their intentions."


Bukhari :: Sales and Trade :: [3.34.330]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 330

Narrated Abu Huraira:

Allah's Apostle said, "The congregational prayer of anyone amongst you is more than twenty (five or twenty seven) times in reward than his prayer in the market or in his house, for if he performs ablution completely and then goes to the mosque with the sole intention of performing the prayer, and nothing urges him to proceed to the mosque except the prayer, then, on every step which he takes towards the mosque, he will be raised one degree or one of his sins will be forgiven. The angels will keep on asking Allah's forgiveness and blessings for everyone of you so long as he keeps sitting at his praying place. The angels will say, 'O Allah, bless him! O Allah, be merciful to him!' as long as he does not do Hadath or a thing which gives trouble to the other." The Prophet further said, "One is regarded in prayer so long as one is waiting for the prayer."


Bukhari :: Sales and Trade :: [3.34.331]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 331

Narrated Anas bin Malik:

While the Prophet was in the market, somebody, called, "O Abu-l-Qasim." The Prophet turned to him. The man said, "I have called to this (i.e. another man)." The Prophet said, "Name yourselves by my name but not by my Kuniya (name)." (In Arabic world it is the custom to call the man as the father of his eldest son, e.g. Abu-l-Qasim.)

(See Hadith No. 737, Vol. 4)


Bukhari :: Sales and Trade :: [3.34.332]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 332

Narrated Anas:

A man at Al-Baqi' called, "O Abu-l-Qasim!" The Prophet turned to him and the man said (to the Prophet ), "I did not intend to call you." The prophet said, "Name yourselves by my name but not by my kuniya (name)."


Bukhari :: Sales and Trade :: [3.34.333]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 333

Narrated Abu Huraira Ad-Dausi:

Once the Prophet went out during the day. Neither did he talk to me nor I to him till he reached the market of Bani Qainuqa and then he sat in the compound of Fatima's house and asked about the small boy (his grandson Al-Hasan) but Fatima kept the boy in for a while. I thought she was either changing his clothes or giving the boy a bath. After a while the boy came out running and the Prophet embraced and kissed him and then said, 'O Allah! Love him, and love whoever loves him.'


Bukhari :: Sales and Trade :: [3.34.334]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 334

Narrated Nafi:

Ibn 'Umar told us that the people used to buy food from the caravans in the lifetime of the Prophet. The Prophet used to forbid them to sell it at the very place where they had purchased it (but they were to wait) till they carried it to the market where foodstuff was sold. Ibn 'Umar said, 'The Prophet also forbade the reselling of foodstuff by somebody who had bought it unless he had received it with exact full measure'


Bukhari :: Sales and Trade :: [3.34.335]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 335

Narrated Ata bin Yasar:

I met Abdullah bin 'Amr bin Al-'As and asked him, "Tell me about the description of Allah's Apostle which is mentioned in Torah (i.e. Old Testament.") He replied, 'Yes. By Allah, he is described in Torah with some of the qualities attributed to him in the Quran as follows:

"O Prophet ! We have sent you as a witness (for Allah's True religion) And a giver of glad tidings (to the faithful believers), And a warner (to the unbelievers) And guardian of the illiterates. You are My slave and My messenger (i.e. Apostle). I have named you "Al-Mutawakkil" (who depends upon Allah). You are neither discourteous, harsh Nor a noise-maker in the markets And you do not do evil to those Who do evil to you, but you deal With them with forgiveness and kindness. Allah will not let him (the Prophet) Die till he makes straight the crooked people by making them say: "None has the right to be worshipped but Allah," With which will be opened blind eyes And deaf ears and enveloped hearts."


Bukhari :: Sales and Trade :: [3.34.336]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 336

Narrated Abdullah ibn Umar:

Allah's Apostle said, "He who buys foodstuff should not sell it till he is satisfied with the measure with which he has bought it.


Bukhari :: Sales and Trade :: [3.34.337]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 337

Narrated Jabir:

Abdullah bin 'Amr bin Haram died and was in debt to others. I asked the Prophet to intercede with his creditors for some reduction in the debts. The Prophet requested them (to reduce the debts) but they refused. The Prophet said to me, "Go and put your dates (In heaps) according to their different kinds. The Ajwa on one side, the cluster of Ibn Zaid on another side, etc.. Then call me." I did that and called the Prophet He came and sat at the head or in the middle of the heaps and ordered me. Measure (the dates) for the people (creditors)." I measured for them till I paid all the debts. My dates remained as it nothing had been taken from them. In other narrations, Jabir said; The Prophet said, "He (i.e. 'Abdullah) continued measuring for them till he paid all the debts." The Prophet said (to 'Abdullah), "Cut (clusters) for him (i.e. one of the creditors) and measure for him fully."


Bukhari :: Sales and Trade :: [3.34.338]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 338

Narrated Al-Miqdam bin Ma'diyakrib:

The Prophet said, "Measure your foodstuff and you will be blessed."


Bukhari :: Sales and Trade :: [3.34.339]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 339

Narrated 'Abdullah bin Zaid:

The Prophet said, "The Prophet Abraham made Mecca a sanctuary, and asked for Allah's blessing in it. I made Medina a sanctuary as Abraham made Mecca a sanctuary and I asked for Allah's Blessing in its measures the Mudd and the Sa as Abraham did for Mecca.


Bukhari :: Sales and Trade :: [3.34.340]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 340

Narrated Anas bin Malik:

Allah's Apostle said, "O Allah bestow your blessings on their measures, bless their Mudd and Sa." The Prophet meant the people of Medina.


Bukhari :: Sales and Trade :: [3.34.341]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 341

Narrated Salim:

that his father said. "I saw those, who used to buy foodstuff without measuring or weighing in the life time of the Prophet being punished if they sold it before carrying it to their own houses."


Bukhari :: Sales and Trade :: [3.34.342]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 342

Narrated Tawus:

Ibn 'Abbas said, "Allah's Apostle forbade the selling of foodstuff before its measuring and transferring into one's possession." I asked Ibn 'Abbas, "How is that?" Ibn 'Abbas replied, "It will be just like selling money for money, as the foodstuff has not been handed over to the first purchaser who is the present seller."


Bukhari :: Sales and Trade :: [3.34.343]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 343

Narrated Ibn Umar:

The Prophet said, "He who buys foodstuff should not sell it till he has received it."


Bukhari :: Sales and Trade :: [3.34.344]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 344

Narrated Az-Zuhri from Malik bin Aus:

that the latter said, "Who has change?" Talha said, "I (will have change) when our store-keeper comes from the forest."

Narrated 'Umar bin Al-Khattab: Allah's Apostle said, "The bartering of gold for silver is Riba, (usury), except if it is from hand to hand and equal in amount, and wheat grain for wheat grain is usury except if it is form hand to hand and equal in amount, and dates for dates is usury except if it is from hand to hand and equal in amount, and barley for barley is usury except if it is from hand to hand and equal in amount." (See Riba-Fadl in the glossary).


Bukhari :: Sales and Trade :: [3.34.345]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 345

Narrated Ibn 'Abbas:

The Prophet forbade the selling of foodstuff before receiving it. I consider that all types of sellings should be done similarly.


Bukhari :: Sales and Trade :: [3.34.346]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 346

Narrated Ibn 'Umar:

The Prophet said, "The buyer of foodstuff should not sell it before it has been measured for him." Isma'il narrated instead, "He should not sell it before receiving it."


Bukhari :: Sales and Trade :: [3.34.347]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 347

Narrated Ibn 'Umar:

I saw the people buy foodstuff randomly (i.e. blindly without measuring it) in the life-time of Allah's Apostle and they were punished (by beating), if they tried to sell it before carrying it to their own houses.


Bukhari :: Sales and Trade :: [3.34.348]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 348

Narrated Aisha:

Rarely did the Prophet fail to visit Abu Bakr's house everyday, either in the morning or in the evening. When the permission for migration to Medina was granted, all of a sudden the Prophet came to us at noon and Abu Bakr was informed, who said, "Certainly the Prophet has come for some urgent matter." The Prophet said to Abu Bark, when the latter entered "Let nobody stay in your home." Abu Bakr said, "O Allah's Apostle! There are only my two daughters (namely 'Aisha and Asma') present." The Prophet said, "I feel (am informed) that I have been granted the permission for migration." Abu Bakr said, "I will accompany you, O Allah's Apostle!" The Prophet said, "You will accompany me." Abu Bakr then said "O Allah's Apostle! I have two she-camels I have prepared specially for migration, so I offer you one of them. The Prophet said, "I have accepted it on the condition that I will pay its price."


Bukhari :: Sales and Trade :: [3.34.349]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 349

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Do not urge somebody to return what he has already bought (i.e. in optional sale) from another seller so as to sell him your own goods."


Bukhari :: Sales and Trade :: [3.34.350]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 350

Narrated Abu Huraira:

Allah's Apostle forbade the selling of things by a town dweller on behalf of a desert dweller; and similarly Najsh was forbidden. And one should not urge somebody to return the goods to the seller so as to sell him his own goods; nor should one demand the hand of a girl who has already been engaged to someone else; and a woman should not try to cause some other woman to be divorced in order to take her place.


Bukhari :: Sales and Trade :: [3.34.351]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 351

Narrated Jabir bin Abdullah:

A man decided that a slave of his would be manumitted after his death and later on he was in need of money, so the Prophet took the slave and said, "Who will buy this slave from me?" Nu'aim bin 'Abdullah bought him for such and such price and the Prophet gave him the slave.


Bukhari :: Sales and Trade :: [3.34.352]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 352

Narrated Ibn 'Umar:

Allah's Apostle forbade Najsh.


Bukhari :: Sales and Trade :: [3.34.353]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 353

Narrated 'Abdullah bin 'Umar:

Allah's Apostle forbade the sale called 'Habal-al-Habala which was a kind of sale practiced in the Pre-lslamic Period of ignorance. One would pay the price of a she-camel which was not born yet would be born by the immediate offspring of an extant she-camel.


Bukhari :: Sales and Trade :: [3.34.354]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 354

Narrated Abu Said:

Allah's Apostle forbade the selling by Munabadha, i.e. to sell one's garment by casting it to the buyer not allowing him to examine or see it. Similarly he forbade the selling by Mulamasa. Mulamasa is to buy a garment, for example, by merely touching it, not looking at it.


Bukhari :: Sales and Trade :: [3.34.355]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 355

Narrated Abu Huraira:

The Prophet forbade two kinds of dressing; (one of them) is to sit with one's legs drawn up while wrapped in one garment. (The other) is to lift that garment on one's shoulders. And also forbade two kinds of sale: Al-Limas and An-Nibadh.


Bukhari :: Sales and Trade :: [3.34.356]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 356

Narrated Abu Huraira :

Allah's Apostle forbade selling by Mulamasa and Munabadha.


Bukhari :: Sales and Trade :: [3.34.357]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 357

Narrated Abu Said:

The Prophet forbade two kinds of dresses and two kinds of sale, i.e., Mulamasa and Munabadha.


Bukhari :: Sales and Trade :: [3.34.358]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 358

Narrated Abu Huraira:

The Prophet said, "Don't keep camels and sheep unmilked for a long time, for whoever buys such an animal has the option to milk it and then either to keep it or return it to the owner along with one Sa of dates." Some narrated from Ibn Sirin (that the Prophet had said), "One Sa of wheat, and he has the option for three days." And some narrated from Ibn Sirin, " ... a Sa of dates," not mentioning the option for three days. But a Sa of dates is mentioned in most narrations.


Bukhari :: Sales and Trade :: [3.34.359]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 359

Narrated 'Abdullah bin Mas'ud:

Whoever buys a sheep which has not been milked for a long time, has the option of returning it along with one Sa of dates; and the Prophet forbade going to meet the seller on the way (as he has no knowledge of the market price and he may sell his goods at a low price).


Bukhari :: Sales and Trade :: [3.34.360]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 360

Narrated Abu Huraira:

Allah's Apostle said, "Do not go forward to meet the caravan (to buy from it on the way before it reaches the town). And do not urge buyers to cancel their purchases to sell them (your own goods) yourselves, and do not practice Najsh. A town dweller should not sell the goods for the desert dweller. Do not leave sheep unmilked for a long time, when they are on sale, and whoever buys such an animal has the option of returning it, after milking it, along with a Sa of dates or keeping it. it has been kept unmilked for a long period by the seller (to deceive others).


Bukhari :: Sales and Trade :: [3.34.361]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 361

Narrated Abu Huraira:

Allah's Apostle said, "Whoever buys a sheep which has been kept unmilked for a long period, and milks it, can keep it if he is satisfied, and if he is not satisfied, he can return it, but he should pay one Sa of dates for the milk."


Bukhari :: Sales and Trade :: [3.34.362]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 362

Narrated Abu Huraira:

The Prophet said, "If a slave-girl commits illegal sexual intercourse and it is proved beyond doubt, then her owner should lash her and should not blame her after the legal punishment. And then if she repeats the illegal sexual intercourse he should lash her again and should not blame her after the legal punishment, and if she commits it a third time, then he should sell her even for a hair rope."


Bukhari :: Sales and Trade :: [3.34.363]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 363

Narrated Abu Huraira and Zaid bin Khalid:

Allah's Apostle was asked about the slave-girl, if she was a virgin and committed illegal sexual intercourse. The Prophet said, "If she committed illegal sexual intercourse, lash her, and if she did it a second time, then lash her again, and if she repeated the third time, then sell her even for a hair rope." Ibn Shihab said, "I don't know whether to sell her after the third or fourth offense."


Bukhari :: Sales and Trade :: [3.34.364]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 364

Narrated 'Aisha:

Allah's Apostle came to me and I told him about the slave-girl (Buraira) Allah's Apostle said, "Buy and manumit her, for the Wala is for the one who manumits." In the evening the Prophet got up and glorified Allah as He deserved and then said, "Why do some people impose conditions which are not present in Allah's Book (Laws)? Whoever imposes such a condition as is not in Allah's Laws, then that condition is invalid even if he imposes one hundred conditions, for Allah's conditions are more binding and reliable."


Bukhari :: Sales and Trade :: [3.34.365]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 365

Narrated Abdullah bin Umar:

Aisha wanted to buy Buraira and he (the Prophet ) went out for the prayer. When he returned, she told him that they (her masters) refused to sell her except on the condition that her Wala' would go to them. The Prophet replied, 'The Wala' would go to him who manumits.' " Hammam asked Nafi' whether her (Buraira's) husband was a free man or a slave. He replied that he did not know.


Bukhari :: Sales and Trade :: [3.34.366]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 366

Narrated Jarir:

I have given a pledge of allegiance to Allah's Apostle for to testify that None has the right to be worshipped but Allah, and Muhammad is His Apostle, to offer prayers perfectly, to pay Zakat, to listen to and obey (Allah's and His Prophet's orders), and to give good advice to every Muslim.


Bukhari :: Sales and Trade :: [3.34.367]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 367

Narrated Tawus:

Ibn 'Abbas said, "Allah's Apostle said, 'Do not go to meet the caravans on the way (for buying their goods without letting them know the market price); a town dweller should not sell the goods of a desert dweller on behalf of the latter.' I asked Ibn 'Abbas, 'What does he mean by not selling the goods of a desert dweller by a town dweller?' He said, 'He should not become his broker.' "


Bukhari :: Sales and Trade :: [3.34.368]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 368

Narrated 'Abdullah bin Umar:

Allah's Apostle forbade the selling of the goods of a desert dweller by a town person.


Bukhari :: Sales and Trade :: [3.34.369]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 369

Narrated Abu Huraira:

Allah's Apostle said, "A buyer should not urge a seller to restore a purchase so as to buy it himself, and do not practice Najsh; and a town dweller should not sell goods of a desert dweller."


Bukhari :: Sales and Trade :: [3.34.370]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 370

Narrated Anas bin Malik:

We were forbidden that a town dweller should sell goods of a desert dweller.


Bukhari :: Sales and Trade :: [3.34.371]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 371

Narrated Abu Huraira:

The Prophet forbade the meeting (of caravans) on the way and the selling of goods by an inhabitant of the town on behalf of a desert dweller.


Bukhari :: Sales and Trade :: [3.34.372]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 372

Narrated Tawus:

I asked Ibn 'Abbas, "What is the meaning of, 'No town dweller should sell (or buy) for a desert dweller'?" Ibn 'Abbas said, "It means he should not become his broker."


Bukhari :: Sales and Trade :: [3.34.373]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 373

Narrated Abdullah:

Whoever buys an animal which has been kept unmilked for a long time, could return it, but has to pay a Sa of dates along with it. And the Prophet forbade meeting the owners of goods on the way away from the market.


Bukhari :: Sales and Trade :: [3.34.374]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 374

Narrated 'Abdullah bin Umar:

Allah's Apostle said, "You should not try to cancel the purchases of one another (to get a benefit thereof), and do not go ahead to meet the caravan (for buying the goods) (but wait) till it reaches the market."


Bukhari :: Sales and Trade :: [3.34.375]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 375

Narrated 'Abdullah:

We used to go ahead to meet the caravan and used to buy foodstuff from them. The Prophet forbade us to sell it till it was carried to the market.


Bukhari :: Sales and Trade :: [3.34.376]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 376

Narrated 'Abdullah:

Some people used to buy foodstuff at the head of the market and used to sell it on the spot. Allah's Apostle forbade them to sell it till they brought it to (their) places.


Bukhari :: Sales and Trade :: [3.34.377]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 377

Narrated 'Urwa:

Aisha said, "Buraira came to me and said, 'I have agreed with my masters to pay them nine Uqiyas (of gold) (in installments) one Uqiya per year; please help me.' I said, 'I am ready to pay the whole amount now provided your masters agree that your Wala will be for me.' So, Buraira went to her masters and told them about that offer but they refused to accept it. She returned, and at that time, Allah's Apostle was sitting (present). Buraira said, 'I told them of the offer but they did not accept it and insisted on having the Wala.'.' The Prophet heard that." 'Aisha narrated the whole story to the Prophet . He said to her, "Buy her and stipulate that her Wala' would be yours as the Wala' is for the manumitted." 'Aisha did so. Then Allah's Apostle stood up in front of the people, and after glorifying Allah he said, "Amma Badu (i.e. then after)! What about the people who impose conditions which are not in Allah's Book (Laws)? Any condition that is not in Allah's Book (Laws) is invalid even if they were one hundred conditions, for Allah's decisions are the right ones and His conditions are the strong ones (firmer) and the Wala' will be for the manumitted."


Bukhari :: Sales and Trade :: [3.34.378]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 378

Narrated 'Abdullah bin 'Umar:

Aisha, (mother of the faithful believers) wanted to buy a slave girl and manumit her, but her masters said that they would sell her only on the condition that her Wala' would be for them. 'Aisha told Allah's Apostle of that. He said, "What they stipulate should not hinder you from buying her, as the Wala' is for the manumitted."


Bukhari :: Sales and Trade :: [3.34.379]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 379

Narrated Ibn 'Umar:

The Prophet said, "The selling of wheat for wheat is Riba (usury) except if it is handed from hand to hand and equal in amount. Similarly the selling of barley for barley, is Riba except if it is from hand to hand and equal in amount, and dates for dates is usury except if it is from hand to hand and equal in amount. (See Riba-Fadl in the glossary).


Bukhari :: Sales and Trade :: [3.34.380]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 380

Narrated Ibn 'Umar:

Allah's Apostle forbade Muzabana; and Muzabana is the selling of fresh dates for dried old dates by measure, and the selling of fresh grapes for dried grapes by measure.


Bukhari :: Sales and Trade :: [3.34.381]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 381

Narrated Ibn 'Umar:

The Prophet forbade Muzabana; and Muzabana is the selling of fresh fruit (without measuring it) for something by measure on the basis that if that thing turns to be more than the fruit, the increase would be for the seller of the fruit, and if it turns to be less, that would be of his lot.

Narrated Ibn 'Umar from Zaid bin Thabit that the Prophet allowed the selling of the fruits on the trees after estimation (when they are ripe).


Bukhari :: Sales and Trade :: [3.34.382]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 382

Narrated Ibn Shihab:

that Malik bin Aus said, "I was in need of change for one-hundred Dinars. Talha bin 'Ubaid-Ullah called me and we discussed the matter, and he agreed to change (my Dinars). He took the gold pieces in his hands and fidgeted with them, and then said, "Wait till my storekeeper comes from the forest." 'Umar was listening to that and said, "By Allah! You should not separate from Talha till you get the money from him, for Allah's Apostle said, 'The selling of gold for gold is Riba (usury) except if the exchange is from hand to hand and equal in amount, and similarly, the selling of wheat for wheat is Riba (usury) unless it is from hand to hand and equal in amount, and the selling of barley for barley is usury unless it is from hand to hand and equal in amount, and dates for dates, is usury unless it is from hand to hand and equal in amount"


Bukhari :: Sales and Trade :: [3.34.383]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 383

Narrated Abu Bakra:

Allah's Apostle said, "Don't sell gold for gold unless equal in weight, nor silver for silver unless equal in weight, but you could sell gold for silver or silver for gold as you like."


Bukhari :: Sales and Trade :: [3.34.384]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 384

Narrated Abu Said:

(Concerning exchange) that he heard Allah's Apostle saying, "Do not sell gold for gold unless equal in weight, and do not sell silver unless equal in weight."


Bukhari :: Sales and Trade :: [3.34.385]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 385

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Do not sell gold for gold unless equivalent in weight, and do not sell less amount for greater amount or vice versa; and do not sell silver for silver unless equivalent in weight, and do not sell less amount for greater amount or vice versa and do not sell gold or silver that is not present at the moment of exchange for gold or silver that is present.


Bukhari :: Sales and Trade :: [3.34.386]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 386

Narrated Abu Salih Az-Zaiyat:

I heard Abu Said Al-Khudri saying, "The selling of a Dinar for a Dinar, and a Dirham for a Dirham (is permissible)." I said to him, "Ibn 'Abbas does not say the same." Abu Said replied, "I asked Ibn 'Abbas whether he had heard it from the Prophet s or seen it in the Holy Book. Ibn 'Abbas replied, "I do not claim that, and you know Allah's Apostle better than I, but Usama informed me that the Prophet had said, 'There is no Riba (in money exchange) except when it is not done from hand to hand (i.e. when there is delay in payment).' "


Bukhari :: Sales and Trade :: [3.34.387]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 387

Narrated Abu Al-Minhal:

I asked Al-Bara' bin 'Azib and Zaid bin Arqam about money exchanges. Each of them said, "This is better than I," and both of them said, "Allah's Apostle forbade the selling of silver for gold on credit. "


Bukhari :: Sales and Trade :: [3.34.388]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 388

Narrated Abdur-Rahman bin Abu Bakra:

that his father said, "The Prophet forbade the selling of gold for gold and silver for silver except if they are equivalent in weight, and allowed us to sell gold for silver and vice versa as we wished."


Bukhari :: Sales and Trade :: [3.34.389]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 389

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Do not sell fruits of dates until they become free from all the dangers of being spoilt or blighted; and do not sell fresh dates for dry dates."

Narrated Salim and 'Abdullah from Zaid bin Habit' "Later on Allah's Apostle permitted the selling of ripe fruits on trees for fresh dates or dried dates in Bai'-l-'Araya, and did not allow it for any other kind of sale."


Bukhari :: Sales and Trade :: [3.34.390]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 390

Narrated 'Abdullah bin 'Umar:

Allah's Apostle forbade Muzabana; and Muzabana means the selling of fresh dates (on the trees) for dried dates by measure and also the selling of fresh grapes for dried grapes by measure.


Bukhari :: Sales and Trade :: [3.34.391]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 391

Narrated Abu Sa'id Al-Khudri:

Allah's Apostle forbade Muzabana and Muhaqala; and Muzabana means the selling of ripe dates for dates still on the trees.


Bukhari :: Sales and Trade :: [3.34.392]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 392

Narrated Ibn 'Abbas:

The Prophet forbade Muzabana and Muhaqala.


Bukhari :: Sales and Trade :: [3.34.393]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 393

Narrated Zaid bin Thabit:

Allah's Apostle al lowed the owner of 'Araya to sell the fruits on the trees by means of estimation.


Bukhari :: Sales and Trade :: [3.34.394]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 394

Narrated Jabir:

The Prophet forbade the selling of fruits unless they get ripe, and none of them should be sold except for Dinar or Dirham (i.e. money), except the 'Araya trees (the dates of which could be sold for dates).


Bukhari :: Sales and Trade :: [3.34.395]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 395

Narrated Abu Huraira:

The Prophet allowed the sale of the dates of 'Araya provided they were about five Awsuq (singular: Wasaq which means sixty Sa's) or less (in amount).


Bukhari :: Sales and Trade :: [3.34.396]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 396

Narrated Sahl bin Abu Hathma:

Allah's Apostle forbade the selling of fruits (fresh dates) for dried dates but allowed the sale of fruits on the 'Araya by estimation and their new owners might eat their dates fresh. Sufyan (in another narration) said, "I told Yahya (a sub-narrator) when I was a mere boy, 'Meccans say that the Prophet allowed them the sale of the fruits on 'Araya by estimation.' Yahya asked, 'How do the Meccans know about it?' I replied, 'They narrated it (from the Prophet ) through Jabir.' On that, Yahya kept quiet." Sufyan said, "I meant that Jabir belonged to Medina." Sufyan was asked whether in Jabir's narration there was any prohibition of selling fruits before their benefit is evident (i.e. no dangers of being spoilt or blighted). He replied that there was none.


Bukhari :: Sales and Trade :: [3.34.397]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 397

Narrated Ibn 'Umar from Zaid bin Thabit:

Allah's Apostle allowed the sale of 'Araya by estimating the dates on them for measured amounts of dried dates. Musa bin 'Uqba said, "Al- 'Araya were distinguished date palms; one could come and buy them (i.e. their fruits)."


Bukhari :: Sales and Trade :: [3.34.398]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 398

Narrated Zaid:

Same as above (Hadith 397).


Bukhari :: Sales and Trade :: [3.34.399]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 399

Narrated 'Abdullah bin 'Umar:

Allah's Apostle forbade the sale of fruits till their benefit is evident. He forbade both the seller and the buyer (such sale).


Bukhari :: Sales and Trade :: [3.34.400]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 400

Narrated Anas:

Allah's Apostle forbade the sale of date fruits till they were ripe. Abu 'Abdullah (Al-Bukhari) said, "That means till they were red (can be eaten)."


Bukhari :: Sales and Trade :: [3.34.401]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 401

Narrated Jabir bin 'Abdullah:

The Prophet forbade the s of (date) fruits till they were red or yellow and fit for eating.


Bukhari :: Sales and Trade :: [3.34.402]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 402

Narrated Anas bin Malik:

The Prophet forbade the sale of fruits till their benefit is evident; and the sale of date palms till the dates are almost ripe. He was asked what 'are almost ripe' meant. He replied, "Got red and yellow."


Bukhari :: Sales and Trade :: [3.34.403]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 403

Narrated Anas bin Malik:

Allah's Apostle forbade the sale of fruits till they are almost ripe. He was asked what is meant by 'are almost ripe.' He replied, "Till they become red." Allah's Apostle further said, "If Allah spoiled the fruits, what right would one have to take the money of one's brother (i.e. other people)?"

Narrated Ibn Shihab: If somebody bought fruits before their benefit is evident and then the fruits were spoiled with blights, the loss would be suffered by the owner (not the buyer).

Narrated Salim bin 'Abdullah from Ibn Umar: Allah's Apostle said, "Do not sell or buy fruits before their benefit was evident and do not sell fresh fruits (dates) for dried dates."


Bukhari :: Sales and Trade :: [3.34.404]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 404

Narrated 'Aisha:

The Prophet bought some foodstuff from a Jew on credit and mortgaged his armor to him.


Bukhari :: Sales and Trade :: [3.34.405]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 405

Narrated Abu Said Al-Khudri and Abu Huraira:

Allah's Apostle appointed somebody as a governor of Khaibar. That governor brought to him an excellent kind of dates (from Khaibar). The Prophet asked, "Are all the dates of Khaibar like this?" He replied, "By Allah, no, O Allah's Apostle! But we barter one Sa of this (type of dates) for two Sas of dates of ours and two Sas of it for three of ours." Allah's Apostle said, "Do not do so (as that is a kind of usury) but sell the mixed dates (of inferior quality) for money, and then buy good dates with that money."


Bukhari :: Sales and Trade :: [3.34.406]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 406

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "If somebody sells pollinated date palms, the fruits will be for the seller unless the buyer stipulates that they will be for himself (and the seller agrees)."


Bukhari :: Sales and Trade :: [3.34.407]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 407

Narrated Ibn 'Umar:

Allah's Apostle forbade Al-Muzabana, i.e. to sell ungathered dates of one's garden for measured dried dates or fresh ungathered grapes for measured dried grapes; or standing crops for measured quantity of foodstuff. He forbade all such bargains.


Bukhari :: Sales and Trade :: [3.34.408]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 408

Narrated Ibn 'Umar:

The Prophet said, "Whoever pollinates date palms and then sells them, the fruits will belong to him unless the buyer stipulates that the fruits should belong to him (and the seller agrees)."


Bukhari :: Sales and Trade :: [3.34.409]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 409

Narrated Anas bin Malik:

Allah's Apostle forbade Muhaqala, Mukhadara, Mulamasa, Munabadha and Muzabana. (See glossary and previous Hadiths for the meanings of these terms.)


Bukhari :: Sales and Trade :: [3.34.410]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 410

Narrated Humaid:

Anas said, "The Prophet forbade the selling of dates till they were almost ripe." We asked Anas, "What does 'almost ripe' mean?" He replied, "They get red and yellow. The Prophet added, 'If Allah destroyed the fruits present on the trees, what right would the seller have to take the money of his brother (somebody else)?' "


Bukhari :: Sales and Trade :: [3.34.411]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 411

Narrated Ibn 'Umar:

I was with the Prophet while he was eating spadix. He said, "From the trees there is a tree which resembles a faithful believer." I wanted to say that it was the date palm, but I was the youngest among them (so I kept quiet). He added, "It is the date palm." Shuraih told the weavers, "You are permitted to follow your own conventions to solve your problems (it is legal for you to stick to your traditions in bargain) . "

Narrated 'Abdul Wahab: Aiyub said: Muhammad said, "There is no harm in selling for eleven what you buy for ten, and you are allowed to take a profit for expenses . "

The Prophet told Hind, "Take what is reasonable and sufficient for you and your sons." Allah says: Whoever is poor, can eat (from the orphan's property) reasonably (according to his labors).

Al-Hasan hired a donkey from 'Abdullah bin Mirdas and asked him about the hire. The latter replied that it was for two Daniqs (a Daniq equals 116th Dirham). So Al-Hasan rode away. Another time, Al-Hasan came to 'Abdullah bin Mirdas and asked him to hire the donkey to him and rode away without asking him about the hire, but he sent him half a Dirham.


Bukhari :: Sales and Trade :: [3.34.412]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 412

Narrated Anas bin Malik:

Abu Taiba cupped Allah's Apostle and so Allah's Apostle ordered that a Sa of dates be paid to him and ordered his masters (for he was a slave) to reduce his tax.


Bukhari :: Sales and Trade :: [3.34.413]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 413

Narrated 'Aisha:

Hind, the mother of Mu'awiya said to Allah's Apostle, "Abu Sufyan (her husband) is a miser. Am I allowed to take from his money secretly?" The Prophet said to her, "You and your sons may take what is sufficient reasonably and fairly."


Bukhari :: Sales and Trade :: [3.34.414]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 414

Narrated Hisham bin 'Urwa from his father:

who heard Aisha saying, "The Holy Verse; 'Whoever amongst the guardians is rich, he should take no wages (from the property of the orphans) but If he is poor, let him have for himself what is just and reasonable (according to his labors)' (4.6) was revealed concerning the guardian of the orphans who looks after them and manages favorably their financial affairs; If the guardian Is poor, he could have from It what Is just and reasonable, (according to his labors)."


Bukhari :: Sales and Trade :: [3.34.415]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 415

Narrated Jabir:

Allah's Apostle gave pre-emption (to the partner) in every joint property, but if the boundaries of the property were demarcated or the ways and streets were fixed, then there was no pre-emption.


Bukhari :: Sales and Trade :: [3.34.416]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 416

Narrated Jabir bin Abdullah:

Allah's Apostle decided the validity of pre-emption in every joint undivided property, but if the boundaries were well marked or the ways and streets were fixed, then there was no pre-emption.


Bukhari :: Sales and Trade :: [3.34.417]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 417

Narrated Mussaddad from 'Abdul Wahid:

the same as above but said, "... in every joint undivided thing..." Narrated Hisham from Ma'mar the same as above but said, " ... in every property... "


Bukhari :: Sales and Trade :: [3.34.418]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 418

Narrated Ibn 'Umar:

The Prophet said, "While three persons were walking, rain began to fall and they had to enter a cave in a mountain. A big rock rolled over and blocked the mouth of the cave. They said to each other, 'Invoke Allah with the best deed you have performed (so Allah might remove the rock)'. One of them said, 'O Allah! My parents were old and I used to go out for grazing (my animals). On my return I would milk (the animals) and take the milk in a vessel to my parents to drink. After they had drunk from it, I would give it to my children, family and wife. One day I was delayed and on my return I found my parents sleeping, and I disliked to wake them up. The children were crying at my feet (because of hunger). That state of affairs continued till it was dawn. O Allah! If You regard that I did it for Your sake, then please remove this rock so that we may see the sky.' So, the rock was moved a bit. The second said, 'O Allah! You know that I was in love with a cousin of mine, like the deepest love a man may have for a woman, and she told me that I would not get my desire fulfilled unless I paid her one-hundred Dinars (gold pieces). So, I struggled for it till I gathered the desired amount, and when I sat in between her legs, she told me to be afraid of Allah, and asked me not to deflower her except rightfully (by marriage). So, I got up and left her. O Allah! If You regard that I did if for Your sake, kindly remove this rock.' So, two-thirds of the rock was removed. Then the third man said, 'O Allah! No doubt You know that once I employed a worker for one Faraq (three Sa's) of millet, and when I wanted to pay him, he refused to take it, so I sowed it and from its yield I bought cows and a shepherd. After a time that man came and demanded his money. I said to him: Go to those cows and the shepherd and take them for they are for you. He asked me whether I was joking with him. I told him that I was not joking with him, and all that belonged to him. O Allah! If You regard that I did it sincerely for Your sake, then please remove the rock.' So, the rock was removed completely from the mouth of the cave."


Bukhari :: Sales and Trade :: [3.34.419]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 419

Narrated 'Abdur-Rahman bin Abu Bakr:

We were with the Prophet when a tall pagan with long matted unkempt hair came driving his sheep. The Prophet asked him, "Are those sheep for sale or for gifts?" The pagan replied, "They are for sale." The Prophet bought one sheep from him.


Bukhari :: Sales and Trade :: [3.34.420]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 420

Narrated Abu Huraira:

The Prophet said, "The Prophet Abraham emigrated with Sarah and entered a village where there was a king or a tyrant. (The king) was told that Abraham had entered (the village) accompanied by a woman who was one of the most charming women. So, the king sent for Abraham and asked, 'O Abraham! Who is this lady accompanying you?' Abraham replied, 'She is my sister (i.e. in religion).' Then Abraham returned to her and said, 'Do not contradict my statement, for I have informed them that you are my sister. By Allah, there are no true believers on this land except you and 1.' Then Abraham sent her to the king. When the king got to her, she got up and performed ablution, prayed and said, 'O Allah! If I have believed in You and Your Apostle, and have saved my private parts from everybody except my husband, then please do not let this pagan overpower me.' On that the king fell in a mood of agitation and started moving his legs. Seeing the condition of the king, Sarah said, 'O Allah! If he should die, the people will say that I have killed him.' The king regained his power, and proceeded towards her but she got up again and performed ablution, prayed and said, 'O Allah! If I have believed in You and Your Apostle and have kept my private parts safe from all except my husband, then please do not let this pagan overpower me.' The king again fell in a mood of agitation and started moving his legs. On seeing that state of the king, Sarah said, 'O Allah! If he should die, the people will say that I have killed him.' The king got either two or three attacks, and after recovering from the last attack he said, 'By Allah! You have sent a satan to me. Take her to Abraham and give her Ajar.' So she came back to Abraham and said, 'Allah humiliated the pagan and gave us a slavegirl for service."


Bukhari :: Sales and Trade :: [3.34.421]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 421

Narrated 'Aisha:

Sad bin Abi Waqqas and 'Abu bin Zam'a quarreled over a boy. Sad said, "O Allah's Apostle! This boy is the son of my brother ('Utba bin Abi Waqqas) who took a promise from me that I would take him as he was his (illegal) son. Look at him and see whom he resembles." 'Abu bin Zam'a said, "O Allah's Apostle! This is my brother and was born on my father's bed from his slave-girl." Allah's Apostle cast a look at the boy and found definite resemblance to 'Utba and then said, "The boy is for you, O 'Abu bin Zam'a. The child goes to the owner of the bed and the adulterer gets nothing but the stones (despair, i.e. to be stoned to death). Then the Prophet said, "O Sauda bint Zama! Screen yourself from this boy." So, Sauda never saw him again.


Bukhari :: Sales and Trade :: [3.34.422]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 422

Narrated Sad that his father said:

Abdur-Rahman bin Auf said to Suhaib, 'Fear Allah and do not ascribe yourself to somebody other than your father.' Suhaib replied, 'I would not like to say it even if I were given large amounts of money, but I say I was kidnapped in my childhood.' "


Bukhari :: Sales and Trade :: [3.34.423]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 423

Narrated 'Urwa bin Az-Zubair:

Hakim bin Hizam said, "O Allah's Apostle! I used to do good deeds in the Pre-lslamic period of Ignorance, e.g., keeping good relations with my Kith and kin, manumitting slaves and giving alms. Shall I receive a reward for all that?" Allah's Apostle replied, "You embraced Islam with all the good deeds which you did in the past."


Bukhari :: Sales and Trade :: [3.34.424]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 424

Narrated 'Abdullah bin 'Abbas:

Once Allah's Apostle passed by a dead sheep and said to the people, "Wouldn't you benefit by its skin?" The people replied that it was dead. The Prophet said, "But its eating only is illegal."


Bukhari :: Sales and Trade :: [3.34.425]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 425

Narrated Abu Huraira:

Allah's Apostle said, "By Him in Whose Hands my soul is, son of Mary (Jesus) will shortly descend amongst you people (Muslims) as a just ruler and will break the Cross and kill the pig and abolish the Jizya (a tax taken from the non-Muslims, who are in the protection, of the Muslim government). Then there will be abundance of money and no-body will accept charitable gifts.


Bukhari :: Sales and Trade :: [3.34.426]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 426

Narrated Ibn 'Abbas:

Once 'Umar was informed that a certain man sold alcohol. 'Umar said, "May Allah curse him! Doesn't he know that Allah's Apostle said, 'May Allah curse the Jews, for Allah had forbidden them to eat the fat of animals but they melted it and sold it."


Bukhari :: Sales and Trade :: [3.34.427]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 427

Narrated Abu Huraira:

Allah's Apostle said, "May Allah curse the Jews, because Allah made fat illegal for them but they sold it and ate its price. "


Bukhari :: Sales and Trade :: [3.34.428]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 428

Narrated Said bin Abu Al-Hasan:

While I was with Ibn 'Abbas a man came and said, "O father of 'Abbas! My sustenance is from my manual profession and I make these pictures." Ibn 'Abbas said, "I will tell you only what I heard from Allah's Apostle . I heard him saying, 'Whoever makes a picture will be punished by Allah till he puts life in it, and he will never be able to put life in it.' " Hearing this, that man heaved a sigh and his face turned pale. Ibn 'Abbas said to him, "What a pity! If you insist on making pictures I advise you to make pictures of trees and any other unanimated objects."


Bukhari :: Sales and Trade :: [3.34.429]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 429

Narrated 'Aisha:

When the last verses of Surat-al-Baqara were revealed, the Prophet went out (of his house to the Mosque) and said, "The trade of alcohol has become illegal."


Bukhari :: Sales and Trade :: [3.34.430]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 430

Narrated Abu Huraira:

The Prophet said, "Allah says, 'I will be against three persons on the Day of Resurrection:

1. One who makes a covenant in My Name, but he proves treacherous.

2. One who sells a free person (as a slave) and eats the price,

3. And one who employs a laborer and gets the full work done by him but does not pay him his wages.' "


Bukhari :: Sales and Trade :: [3.34.431]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 431

Narrated Anas:

Amongst the captives was Safiya. First she was given to Dihya Al-Kalbi and then to the Prophet.


Bukhari :: Sales and Trade :: [3.34.432]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 432

Narrated Abu Said Al-Khudri:

that while he was sitting with Allah's Apostle he said, "O Allah's Apostle! We get female captives as our share of booty, and we are interested in their prices, what is your opinion about coitus interrupt us?" The Prophet said, "Do you really do that? It is better for you not to do it. No soul that which Allah has destined to exist, but will surely come into existence.


Bukhari :: Sales and Trade :: [3.34.433]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 433

Narrated Jabir:

The Prophet sold a Mudabbar (on behalf of his master who was still living and in need of money).


Bukhari :: Sales and Trade :: [3.34.434]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 434

Narrated Jabir bin 'Abdullah:

Allah's Apostle sold a Mudabbar.


Bukhari :: Sales and Trade :: [3.34.435]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 435

Narrated Zaid bin Khalid and Abu Huraira:

that Allah's Apostle was asked about an unmarried slave-girl who committed illegal sexual intercourse. They heard him saying, "Flog her, and if she commits illegal sexual intercourse after that, flog her again, and on the third (or the fourth) offense, sell her."


Bukhari :: Sales and Trade :: [3.34.436]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 436

Narrated Abu Huraira:

I heard the Prophet saying, "If a slave-girl of yours commits illegal sexual intercourse and her illegal sexual intercourse is proved, she should be lashed, and after that nobody should blame her, and if she commits illegal sexual intercourse the second time, she should be lashed and nobody should blame her after that, and if she does the offense for the third time and her illegal sexual intercourse is proved, she should be sold even for a hair rope."


Bukhari :: Sales and Trade :: [3.34.437]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 437

Narrated Anas bin Malik:

The Prophet came to Khaibar and when Allah made him victorious and he conquered the town by breaking the enemy's defense, the beauty of Safiya bint Huyai bin Akhtab was mentioned to him and her husband had been killed while she was a bride. Allah's Apostle selected her for himself and he set out in her company till he reached Sadd-ar-Rawha' where her menses were over and he married her. Then Hais (a kind of meal) was prepared and served on a small leather sheet (used for serving meals). Allah's Apostle then said to me, "Inform those who are around you (about the wedding banquet)." So that was the marriage banquet given by Allah's Apostle for (his marriage with) Safiya. After that we proceeded to Medina and I saw that Allah's Apostle was covering her with a cloak while she was behind him. Then he would sit beside his camel and let Safiya put her feet on his knees to ride (the camel).


Bukhari :: Sales and Trade :: [3.34.438]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 438

Narrated Jabir bin 'Abdullah:

I heard Allah's Apostle, in the year of the Conquest of Mecca, saying, "Allah and His Apostle made illegal the trade of alcohol, dead animals, pigs and idols." The people asked, "O Allah's Apostle! What about the fat of dead animals, for it was used for greasing the boats and the hides; and people use it for lights?" He said, "No, it is illegal." Allah's Apostle further said, "May Allah curse the Jews, for Allah made the fat (of animals) illegal for them, yet they melted the fat and sold it and ate its price."


Bukhari :: Sales and Trade :: [3.34.439]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 439

Narrated Abu Mas'ud Al-Ansari:

Allah's Apostle forbade taking the price of a dog, money earned by prostitution and the earnings of a soothsayer.


Bukhari :: Sales and Trade :: [3.34.440]

Sales and Trade

Bukhari :: Book 3 :: Volume 34 :: Hadith 440

Narrated Aun bin Abu Juhaifa:

I saw my father buying a slave whose profession was cupping, and ordered that his instruments (of cupping) be broken. I asked him the reason for doing so. He replied, "Allah's Apostle prohibited taking money for blood, the price of a dog, and the earnings of a slave-girl by prostitution; he cursed her who tattoos and her who gets tattooed, the eater of Riba (usury), and the maker of pictures."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.441]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 441

Narrated Ibn Abbas:

Allah's Apostle came to Medina and the people used to pay in advance the price of fruits to be delivered within one or two years. (The sub-narrator is in doubt whether it was one to two years or two to three years.) The Prophet said, "Whoever pays money in advance for dates (to be delivered later) should pay it for known specified weight and measure (of the dates)."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.442]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 442

Narrated Ibn Abi Najih:

as above, mentioning only specific measure.


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.443]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 443

Narrated Ibn 'Abbas:

The Prophet came to Medina and the people used to pay in advance the price of dates to be delivered within two or three years. He said (to them), "Whoever pays in advance the price of a thing to be delivered later should pay it for a specified measure at specified weight for a specified period."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.444]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 444

Narrated Ibn Abi Najih:

as above, saying, "He should pay the price in advance for a specified measure and for a specified period."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.445]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 445

Narrated Ibn 'Abbas:

The Prophet came (to Medina) and he told the people (regarding the payment of money in advance that they should pay it) for a known specified measure and a known specified weight and a known specified period.


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.446]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 446

Narrated Shu'ba:

Muhammad or 'Abdullah bin Abu Al-Mujalid said, "Abdullah bin Shaddad and Abu Burda differed regarding As-Salam, so they sent me to Ibn Abi Aufa and I asked him about it. He replied, 'In the life-time of Allah's Apostle, Abu Bakr and 'Umar, we used to pay in advance the prices of wheat, barley, dried grapes and dates to be delivered later. I also asked Ibn Abza and he, too, replied as above.' "


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.447]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 447

Narrated Muhammad bin Al-Majalid:

Abdullah bin Shaddad and Abu Burda sent me to 'Abdullah bin Abi Aufa and told me to ask 'Abdullah whether the people in the life-time of the Prophet used to pay in advance for wheat (to be delivered later). Abdullah replied, "We used to pay in advance to the peasants of Sham for wheat, barley and olive oil of a known specified measure to be delivered in a specified period." I asked (him), "Was the price paid (in advance) to those who had the things to be delivered later?" Abdullah bin Aufa replied, "We did not use to ask them about that." Then they sent me to 'Abdur Rahman bin Abza and I asked him. He replied, "The companions of the Prophet used to practice Salam in the life-time of the Prophet; and we did not use to ask them whether they had standing crops or not."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.448]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 448

Narrated Muhammad bin Abi Al-Mujalid:

as above (446) and said, "We used to pay them in advance for wheat and barley (to be delivered later). Narrated Ash-Shaibani--"And also for oil."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.449]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 449

Narrated Ash-Shaibani:

who said "We used to pay in advance for wheat barley and dried grapes."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.450]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 450

Narrated Abu Bakhtari At-Tai:

I asked Ibn 'Abbas about Salam for (the fruits of) date-palms. He replied "The Prophet forbade the sale a dates on the trees till they became fit for eating and could be weighed." A man asked what to be weighed (as the dates were still on the trees). Another man sitting beside Ibn 'Abbas replied, "Till they are cut and stored." Narrated Abu Al-Bakhtari: I heard Ibn Abbas (saying) that the Prophet forbade ... etc. as above.


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.451]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 451

Narrated Abu Al-Bakhtari:

I asked Ibn Umar about Salam (the fruits of) date-palms. He replied, "The Prophet forbade the sale of dates till their benefit becomes evident and fit for eating and also the sale of silver (for gold) on credit." I asked Ibn 'Abbas about Salam for dates and he replied, "The Prophet forbade the sale of dates till they were fit for eating and could be estimated."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.452]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 452

Narrated Abu Al-Bakhtari:

I asked Ibn 'Umar about Salam for dates. Ibn 'Umar replied, "The Prophet forbade the sale (the fruits) of datepalms until they were fit for eating and also forbade the sale of silver for gold on credit." I also asked Ibn 'Abbas about it. Ibn 'Abbas replied, "The Prophet forbade the sale of dates till they were fit for eating, and could be weighed." I asked him, "What is to be weighed (as the dates are on the trees)?" A man sitting by Ibn 'Abbas said, "It means till they are cut and stored."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.453]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 453

Narrated 'Aisha:

Allah's Apostle bought some foodstuff (barley) from a Jew on credit and mortgaged his iron armor to him (the armor stands for a guarantor).


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.454]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 454

Narrated Al-A'mash:

We argued at Ibrahim's dwelling place about mortgaging in Salam. He said, "Aisha said, 'The Prophet bought some foodstuff from a Jew on credit and the payment was to be made by a definite period, and he mortgaged his iron armor to him."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.455]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 455

Narrated Ibn 'Abbas:

The Prophet came to Medina and the people used to pay in advance the prices of fruits to be delivered within two to three years. The Prophet said (to them), "Buy fruits by paying their prices in advance on condition that the fruits are to be delivered to you according to a fixed specified measure within a fixed specified period." Ibn Najih said, " ... by specified measure and specified weight."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.456]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 456

Narrated Muhammad bin Abi Al-Mujalid:

Abu Burda and 'Abdullah bin Shaddad sent me to 'Abdur Rahman bin Abza and 'Abdullah bin Abi Aufa to ask them about the Salaf (Salam). They said, "We used to get war booty while we were with Allah's Apostle and when the peasants of Sham came to us we used to pay them in advance for wheat, barley, and oil to be delivered within a fixed period." I asked them, "Did the peasants own standing crops or not?" They replied, "We never asked them about it."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.457]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 457

Narrated 'Abdullah:

The people used to sell camels on the basis of Habal-al-Habala. The Prophet forbade such sale. Nafi' explained Habalal-Habala by saying. "The camel is to be delivered to the buyer after the she-camel gives birth."


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.458]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 458

Narrated Jabir bin 'Abdullah:

Allah's Apostle gave a verdict regarding Shuf'a in every undivided joint thing (property). But if the limits are defined (or demarcated) or the ways and streets are fixed, then there is no pre-emption.


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.459]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 459

Narrated 'Amr bin Ash-Sharid:

While I was standing with Sad bin Abi Waqqas, Al-Miswar bin Makhrama came and put his hand on my shoulder. Meanwhile Abu Rafi', the freed slave of the Prophet came and asked Sad to buy from him the (two) dwellings which were in his house. Sad said, "By Allah I will not buy them." Al-Miswar said, "By Allah, you shall buy them." Sad replied, "By Allah, I will not pay more than four thousand (Dirhams) by installments." Abu Rafi' said, "I have been offered five hundred Dinars (for it) and had I not heard the Prophet saying, 'The neighbor has more right than anyone else because of his nearness, I would not give them to you for four-thousand (Dirhams) while I am offered five-hundred Dinars (one Dinar equals ten Dirhams) for them." So, he sold it to Sad.


Bukhari :: Sales in which a Price is paid for Goods to be Delivered Later (As-Salam) :: [3.35.460]

Sales in which a Price is paid for Goods to be Delivered Later (As-Salam)

Bukhari :: Book 3 :: Volume 35 :: Hadith 460

Narrated Aisha:

I said, "O Allah's Apostle! I have two neighbors and would like to know to which of them I should give presents." He replied, "To the one whose door is nearer to you."


Bukhari :: Hiring :: [3.36.461]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 461

Narrated Abu Musa Al-Ashari:

The Prophet said, "The honest treasurer who gives willingly what he is ordered to give, is one of the two charitable persons, (the second being the owner)."


Bukhari :: Hiring :: [3.36.462]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 462

Narrated Abu Musa:

I went to the Prophet with two men from Ash-ari tribe. I said (to the Prophet), "I do not know that they want employment." The Prophet said, "No, we do not appoint for our jobs anybody who demands it earnestly."


Bukhari :: Hiring :: [3.36.463]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 463

Narrated Abu Huraira:

The Prophet said, "Allah did not send any prophet but shepherded sheep." His companions asked him, "Did you do the same?" The Prophet replied, "Yes, I used to shepherd the sheep of the people of Mecca for some Qirats."


Bukhari :: Hiring :: [3.36.464]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 464

Narrated 'Aisha:

The Prophet and Abu Bakr employed a (pagan) man from the tribe of Bani Ad-Dail and the tribe of Bani 'Abu bin 'Adi as a guide. He was an expert guide and he broke the oath contract which he had to abide by with the tribe of Al-'Asi bin Wail and he was on the religion of Quraish pagans. The Prophet and Abu Bakr had confidence in him and gave him their riding camels and told him to bring them to the Cave of Thaur after three days. So, he brought them their two riding camels after three days and both of them (The Prophet and Abu Bakr) set out accompanied by 'Amir bin Fuhaira and the Dili guide who guided them below Mecca along the road leading to the sea-shore.


Bukhari :: Hiring :: [3.36.465]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 465

Narrated Aisha:

(the wife of the Prophet) Allah's Apostle and Abu Bakr hired a man from the tribe of Bani-Ad-Dil as an expert guide who was a pagan (follower of the religion of the pagans of Quraish). The Prophet and Abu Bakr gave him their two riding camels and took a promise from him to bring their riding camels in the morning of the third day to the Cave of Thaur.


Bukhari :: Hiring :: [3.36.466]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 466

Narrated Ya'la bin Umaya:

I fought in Jaish-al-Usra (Ghazwa of Tabuk) along with the Prophet and in my opinion that was the best of my deeds. Then I had an employee, who quarrel led with someone and one of the them bit and cut the other's finger and caused his own tooth to fall out. He then went to the Prophet (with a complaint) but the Prophet cancelled the suit and said to the complainant, "Did you expect him to let his finger in your mouth so that you might snap and cut it (as does a stallion camel)?"

Narrated Ibn Juraij from Abdullah bin Abu Mulaika from his grandfather a similar story: A man bit the hand of another man and caused his own tooth to fall out, but Abu Bakr judged that he had no right for compensation (for the broken tooth).


Bukhari :: Hiring :: [3.36.467]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 467

Narrated Ubai bin Ka'b:

Allah's Apostle said, "Both of them (Moses and Al-Khadir) proceeded on till they reached a wall which was about to fall." Sa'd said, "(Al-Khadir pointed) with his hands (towards the wall) and then raised his hands and the wall became straightened up." Ya'la said, "I think Said said, 'He (Khadir) passed his hand over it and it was straightened up." (Moses said to him), "if you had wanted, you could have taken wages for it." Said said, "Wages with which to buy food . "


Bukhari :: Hiring :: [3.36.468]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 468

Narrated Ibn 'Umar:

The Prophet said, "Your example and the example of the people of the two Scriptures (i.e. Jews and Christians) is like the example of a man who employed some laborers and asked them, 'Who will work for me from morning till midday for one Qirat?' The Jews accepted and carried out the work. He then asked, Who will work for me from midday up to the 'Asr prayer for one Qirat?' The Christians accepted and fulfilled the work. He then said, 'Who will work for me from the 'Asr till sunset for two Qirats?' You, Muslims have accepted the offer. The Jews and the Christians got angry and said, 'Why should we work more and get lesser wages?' (Allah) said, 'Have I with-held part of your right?' They replied in the negative. He said, 'It is My Blessing, I bestow upon whomever I wish .'


Bukhari :: Hiring :: [3.36.469]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 469

Narrated 'Abdullah bin 'Umar bin Al-Khattab:

Allah's Apostle said, "Your example and the example of Jews and Christians is like the example of a man who employed some laborers to whom he said, 'Who will work for me up to midday for one Qirat each?' The Jews carried out the work for one Qirat each; and then the Christians carried out the work up to the 'Asr prayer for one Qirat each; and now you Muslims are working from the 'Asr prayer up to sunset for two Qirats each. The Jews and Christians got angry and said, 'We work more and are paid less.' The employer (Allah) asked them, 'Have I usurped some of your right?' They replied in the negative. He said, 'That is My Blessing, I bestow upon whomever I wish.' "


Bukhari :: Hiring :: [3.36.470]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 470

Narrated Abu Huraira:

The Prophet said, "Allah said, 'I will be an opponent to three types of people on the Day of Resurrection:

1. One who makes a covenant in My Name, but proves treacherous;

2. One who sells a free person and eats his price; and

3. One who employs a laborer and takes full work from him but does not pay him for his lab our.' "


Bukhari :: Hiring :: [3.36.471]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 471

Narrated Abu Musa:

The Prophet said, "The example of Muslims, Jews and Christians is like the example of a man who employed laborers to work for him from morning till night for specific wages. They worked till midday and then said, 'We do not need your money which you have fixed for us and let whatever we have done be annulled.' The man said to them, 'Don't quit the work, but complete the rest of it and take your full wages.' But they refused and went away. The man employed another batch after them and said to them, 'Complete the rest of the day and yours will be the wages I had fixed for the first batch.' So, they worked till the time of 'Asr prayer. Then they said, "Let what we have done be annulled and keep the wages you have promised us for yourself.' The man said to them, 'Complete the rest of the work, as only a little of the day remains,' but they refused. Thereafter he employed another batch to work for the rest of the day and they worked for the rest of the day till the sunset, and they received the wages of the two former batches. So, that was the example of those people (Muslims) and the example of this light (guidance) which they have accepted willingly.


Bukhari :: Hiring :: [3.36.472]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 472

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "Three men from among those who were before you, set out together till they reached a cave at night and entered it. A big rock rolled down the mountain and closed the mouth of the cave. They said (to each other), Nothing could save you Tom this rock but to invoke Allah by giving referenda to the righteous deed which you have done (for Allah's sake only).' So, one of them said, 'O Allah! I had old parents and I never provided my family (wife, children etc.) with milk before them. One day, by chance I was delayed, and I came late (at night) while they had slept. I milked the sheep for them and took the milk to them, but I found them sleeping. I disliked to provide my family with the milk before them. I waited for them and the bowl of milk was in my hand and I kept on waiting for them to get up till the day dawned. Then they got up and drank the milk. O Allah! If I did that for Your Sake only, please relieve us from our critical situation caused by this rock.' So, the rock shifted a little but they could not get out."

The Prophet added, "The second man said, 'O Allah! I had a cousin who was the dearest of all people to me and I wanted to have sexual relations with her but she refused. Later she had a hard time in a famine year and she came to me and I gave her one-hundred-and-twenty Dinars on the condition that she would not resist my desire, and she agreed. When I was about to fulfill my desire, she said: It is illegal for you to outrage my chastity except by legitimate marriage. So, I thought it a sin to have sexual intercourse with her and left her though she was the dearest of all the people to me, and also I left the gold I had given her. O Allah! If I did that for Your Sake only, please relieve us from the present calamity.' So, the rock shifted a little more but still they could not get out from there."

The Prophet added, "Then the third man said, 'O Allah! I employed few laborers and I paid them their wages with the exception of one man who did not take his wages and went away. I invested his wages and I got much property thereby. (Then after some time) he came and said to me: O Allah's slave! Pay me my wages. I said to him: All the camels, cows, sheep and slaves you see, are yours. He said: O Allah's slave! Don't mock at me. I said: I am not mocking at you. So, he took all the herd and drove them away and left nothing. O Allah! If I did that for Your Sake only, please relieve us from the present suffering.' So, that rock shifted completely and they got out walking.


Bukhari :: Hiring :: [3.36.473]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 473

Narrated Abu May' id Al-Ansari:

Whenever Allah's Apostle ordered us to give in charity we would go to the market and work as porters to earn a Mudd (two hand-fulls) (of foodstuff) but now some of us have one-hundred thousand Dirhams or Diners. (The sub-narrator) Shaqiq said, "I think Abu Mas'ud meant himself by saying (some of us) .


Bukhari :: Hiring :: [3.36.474]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 474

Narrated Tawus:

Ibn 'Abbas said, "The Prophet forbade the meeting of caravans (on the way) and ordained that no townsman is permitted to sell things on behalf of a bedouin." I asked Ibn 'Abbas, "What is the meaning of his saying, 'No townsman is permitted to sell things on behalf of a bedouin.' " He replied, "He should not work as a broker for him."


Bukhari :: Hiring :: [3.36.475]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 475

Narrated Khabbab:

I was a blacksmith and did some work for Al-'As bin Wail. When he owed me some money for my work, I went to him to ask for that amount. He said, "I will not pay you unless you disbelieve in Muhammad." I said, "By Allah! I will never do that till you die and be resurrected." He said, "Will I be dead and then resurrected after my death?" I said, "Yes." He said, "There I will have property and offspring and then I will pay you your due." Then Allah revealed. 'Have you seen him who disbelieved in Our signs, and yet says: I will be given property and offspring?' (19.77)


Bukhari :: Hiring :: [3.36.476]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 476

Narrated Abu Said:

Some of the companions of the Prophet went on a journey till they reached some of the 'Arab tribes (at night). They asked the latter to treat them as their guests but they refused. The chief of that tribe was then bitten by a snake (or stung by a scorpion) and they tried their best to cure him but in vain. Some of them said (to the others), "Nothing has benefited him, will you go to the people who resided here at night, it may be that some of them might possess something (as treatment)," They went to the group of the companions (of the Prophet ) and said, "Our chief has been bitten by a snake (or stung by a scorpion) and we have tried everything but he has not benefitted. Have you got anything (useful)?" One of them replied, "Yes, by Allah! I can recite a Ruqya, but as you have refused to accept us as your guests, I will not recite the Ruqya for you unless you fix for us some wages for it." They agrees to pay them a flock of sheep. One of them then went and recited (Suratul-Fatiha): 'All the praises are for the Lord of the Worlds' and puffed over the chief who became all right as if he was released from a chain, and got up and started walking, showing no signs of sickness.

They paid them what they agreed to pay. Some of them (i.e. the companions) then suggested to divide their earnings among themselves, but the one who performed the recitation said, "Do not divide them till we go to the Prophet and narrate the whole story to him, and wait for his order." So, they went to Allah's Apostle and narrated the story. Allah's Apostle asked, "How did you come to know that Surat-ul-Fatiha was recited as Ruqya?" Then he added, "You have done the right thing. Divide (what you have earned) and assign a share for me as well." The Prophet smiled thereupon.


Bukhari :: Hiring :: [3.36.477]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 477

Narrated Anas bin Malik:

When Abu Taiba cupped the Prophet and the Prophet ordered that he be paid one or two Sas of foodstuff and he interceded with his masters to reduce his taxes.


Bukhari :: Hiring :: [3.36.478]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 478

Narrated Ibn 'Abbas:

When the Prophet was cupped, he paid the man who cupped him his wages.


Bukhari :: Hiring :: [3.36.479]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 479

Narrated Ibn 'Abbas:

When the Prophet was cupped, he paid the man who cupped him his wages. If it had been undesirable he would not have paid him.


Bukhari :: Hiring :: [3.36.480]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 480

Narrated Anas:

The Prophet used to get cupped and would never withhold the wages of any person .


Bukhari :: Hiring :: [3.36.481]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 481

Narrated Anas bin Malik:

The Prophet sent for a slave who had the profession of cupping, and he cupped him. The Prophet ordered that he be paid one or two Sas, or one or two Mudds of foodstuff, and appealed to his masters to reduce his taxes:


Bukhari :: Hiring :: [3.36.482]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 482

Narrated Abu Masud Al-Ansari:

Allah's Apostle regarded illegal the price of a dog, the earnings of a prostitute, and the charges taken by a soothsayer.


Bukhari :: Hiring :: [3.36.483]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 483

Narrated Abu Huraira: The Prophet prohibited the earnings of slave girls (through prostitution).


Bukhari :: Hiring :: [3.36.484]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 484

Narrated Ibn 'Umar:

The Prophet forbade taking a price for animal copulation.


Bukhari :: Hiring :: [3.36.485]

Hiring

Bukhari :: Book 3 :: Volume 36 :: Hadith 485

Narrated Abdullah bin Umar:

"Allah's Apostle gave the land of Khaibar to the Jews to work on and cultivate and take half of its yield. Ibn 'Umar added, "The land used to be rented for a certain portion (of its yield)." Nafi mentioned the amount of the portion but I forgot it. Rafi' bin Khadij said, "The Prophet forbade renting farms." Narrated 'Ubaid-Ullah Nafi' said: Ibn 'Umar said: (The contract of Khaibar continued) till 'Umar evacuated the Jews (from Khaibar).


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.486]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 486

Narrated Abu Huraira:

The Prophet said, "Procrastination (delay) in paying debts by a wealthy man is injustice. So, if your debt is transferred from your debtor to a rich debtor, you should agree."


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.487]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 487

Narrated Abu Huraira:

The Prophet said, "Procrastination (delay) in paying debts by a wealthy person is injustice. So, if your debt is transferred from your debtor to a rich debtor, you should agree."


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.488]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 488

Narrated Abu Huraira:

The Prophet said, "An Israeli man asked another Israeli to lend him one thousand Dinars. The second man required witnesses. The former replied, 'Allah is sufficient as a witness.' The second said, 'I want a surety.' The former replied, 'Allah is sufficient as a surety.' The second said, 'You are right,' and lent him the money for a certain period. The debtor went across the sea. When he finished his job, he searched for a conveyance so that he might reach in time for the repayment of the debt, but he could not find any. So, he took a piece of wood and made a hole in it, inserted in it one thousand Dinars and a letter to the lender and then closed (i.e. sealed) the hole tightly. He took the piece of wood to the sea and said. 'O Allah! You know well that I took a loan of one thousand Dinars from so-and-so. He demanded a surety from me but I told him that Allah's Guarantee was sufficient and he accepted Your guarantee. He then asked for a witness and I told him that Allah was sufficient as a Witness, and he accepted You as a Witness. No doubt, I tried hard to find a conveyance so that I could pay his money but could not find, so I hand over this money to You.' Saying that, he threw the piece of wood into the sea till it went out far into it, and then he went away. Meanwhile he started searching for a conveyance in order to reach the creditor's country.

One day the lender came out of his house to see whether a ship had arrived bringing his money, and all of a sudden he saw the piece of wood in which his money had been deposited. He took it home to use for fire. When he sawed it, he found his money and the letter inside it. Shortly after that, the debtor came bringing one thousand Dinars to him and said, 'By Allah, I had been trying hard to get a boat so that I could bring you your money, but failed to get one before the one I have come by.' The lender asked, 'Have you sent something to me?' The debtor replied, 'I have told you I could not get a boat other than the one I have come by.' The lender said, 'Allah has delivered on your behalf the money you sent in the piece of wood. So, you may keep your one thousand Dinars and depart guided on the right path.' "


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.489]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 489

Narrated Said bin Jubair:

Ibn Abbas said, "In the verse: To every one We have appointed ' (Muwaliya Mawaliya means one's) heirs (4.33).' (And regarding the verse) 'And those with whom your right hands have made a pledge.' Ibn 'Abbas said, "When the emigrants came to the Prophet in Medina, the emigrant would inherit the Ansari while the latter's relatives would not inherit him because of the bond of brotherhood which the Prophet established between them (i.e. the emigrants and the Ansar). When the verse: 'And to everyone We have appointed heirs' (4.33) was revealed, it cancelled (the bond (the pledge) of brotherhood regarding inheritance)." Then he said, "The verse: To those also to whom your right hands have pledged, remained valid regarding co-operation and mutual advice, while the matter of inheritance was excluded and it became permissible to assign something in one's testament to the person who had the right of inheriting before.


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.490]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 490

Narrated Anas:

Abdur-Rahman bin 'Auf came to us and Allah's Apostle established a bond of brotherhood between him and Sad bin Rabi'a.


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.491]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 491

Narrated Asim:

I heard Anas bin Malik, "Have you ever heard that the Prophet said, 'There is no alliance in Islam?' " He replied, "The Prophet made alliance between Quarish and the Ansar in my house."


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.492]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 492

Narrated Salama bin Al-Akwa:

A dead person was brought to the Prophet so that he might lead the funeral prayer for him. He asked, "Is he in debt?" When the people replied in the negative, he led the funeral prayer. Another dead person was brought and he asked, "Is he in debt?" They said, "Yes." He (refused to lead the prayer and) said, "Lead the prayer of your friend." Abu Qatada said, "O Allah's Apostle! I undertake to pay his debt." Allah's Apostle then led his funeral prayer.


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.493]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 493

Narrated Jabir bin 'Abdullah:

Once the Prophet said (to me), "If the money of Bahrain comes, I will give you a certain amount of it." The Prophet had breathed his last before the money of Bahrain arrived. When the money of Bahrain reached, Abu Bakr announced, "Whoever was promised by the Prophet should come to us." I went to Abu Bakr and said, "The Prophet promised me so and so." Abu Bakr gave me a handful of coins and when I counted them, they were five-hundred in number. Abu Bakr then said, "Take twice the amount you have taken (besides)."


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.494]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 494

Narrated Aisha:

(wife of the Prophet) Since I reached the age when I could remember things, I have seen my parents worshipping according to the right faith of Islam. Not a single day passed but Allah's Apostle visited us both in the morning and in the evening. When the Muslims were persecuted, Abu Bakr set out for Ethiopia as an emigrant. When he reached a place called Bark-al-Ghimad, he met Ibn Ad-Daghna, the chief of the Qara tribe, who asked Abu Bakr, "Where are you going?" Abu Bakr said, "My people have turned me out of the country and I would like to tour the world and worship my Lord." Ibn Ad-Daghna said, "A man like you will not go out, nor will he be turned out as you help the poor earn their living, keep good relation with your Kith and kin, help the disabled (or the dependents), provide guests with food and shelter, and help people during their troubles. I am your protector. So, go back and worship your Lord at your home." Ibn Ad-Daghna went along with Abu Bakr and took him to the chiefs of Quraish saying to them, "A man like Abu Bakr will not go out, nor will he be turned out. Do you turn out a man who helps the poor earn their living, keeps good relations with Kith and kin, helps the disabled, provides guests with food and shelter, and helps the people during their troubles?"

So, Quraish allowed Ibn Ad-Daghna's guarantee of protection and told Abu- Bakr that he was secure, and said to Ibn Ad-Daghna, "Advise Abu Bakr to worship his Lord in his house and to pray and read what he liked and not to hurt us and not to do these things publicly, for we fear that our sons and women may follow him." Ibn Ad-Daghna told Abu Bakr of all that, so Abu- Bakr continued worshipping his Lord in his house and did not pray or recite Qur'an aloud except in his house. Later on Abu Bakr had an idea of building a mosque in the court yard of his house. He fulfilled that idea and started praying and reciting Qur'an there publicly. The women and the offspring of the pagans started gathering around him and looking at him astonishingly. Abu Bakr was a softhearted person and could not help weeping while reciting Qur'an. This horrified the pagan chiefs of Quraish. They sent for Ibn Ad-Daghna and when he came, they said, "We have given Abu Bakr protection on condition that he will worship his Lord in his house, but he has transgressed that condition and has built a mosque in the court yard of his house and offered his prayer and recited Qur'an in public. We are afraid lest he mislead our women and offspring. So, go to him and tell him that if he wishes he can worship his Lord in his house only, and if not, then tell him to return your pledge of protection as we do not like to betray you by revoking your pledge, nor can we tolerate Abu Bakr's public declaration of Islam (his worshipping)."

'Aisha added: Ibn Ad-Daghna came to Abu Bakr and said, "You know the conditions on which I gave you protection, so you should either abide by those conditions or revoke my protection, as I do not like to hear the 'Arabs saying that Ibn Ad-Daghna gave the pledge of protection to a person and his people did not respect it." Abu Bakr said, "I revoke your pledge of protection and am satisfied with Allah's protection." At that time Allah's Apostle was still in Mecca and he said to his companions, "Your place of emigration has been shown to me. I have seen salty land, planted with date-palms and situated between two mountains which are the two ,Harras." So, when the Prophet told it, some of the companions migrated to Medina, and some of those who had migrated to Ethiopia returned to Medina. When Abu Bakr prepared for emigration, Allah's Apostle said to him, "Wait, for I expect to be permitted to emigrate." Abu Bakr asked, "May my father be sacrificed for your sake, do you really expect that?" Allah's Apostle replied in the affirmative. So, Abu Bakr postponed his departure in order to accompany Allah's Apostle and fed two camels which he had, with the leaves of Samor trees for four months.


Bukhari :: Transferance of a Debt from One Person to Another (Al-Hawaala) :: [3.37.495]

Transferance of a Debt from One Person to Another (Al-Hawaala)

Bukhari :: Book 3 :: Volume 37 :: Hadith 495

Narrated Abu Huraira:

Whenever a dead man in debt was brought to Allah's Apostle he would ask, "Has he left anything to repay his debt?" If he was informed that he had left something to repay his debts, he would offer his funeral prayer, otherwise he would tell the Muslims to offer their friend's funeral prayer. When Allah made the Prophet wealthy through conquests, he said, "I am more rightful than other believers to be the guardian of the believers, so if a Muslim dies while in debt, I am responsible for the repayment of his debt, and whoever leaves wealth (after his death) it will belong to his heirs. "


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.496]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 496

Narrated 'Ali: Allah's Apostle ordered me to distribute the saddles and skins of the Budn which had slaughtered.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.497]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 497

Narrated 'Uqba bin Amir:

that the Prophet had given him sheep to distribute among his companions and a male kid was left (after the distribution). When he informed the Prophet of it, he said (to him), "Offer it as a sacrifice on your behalf."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.498]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 498

Narrated 'Abdur-Rahman bin 'Auf:

I got an agreement written between me and Umaiya bin Khalaf that Umaiya would look after my property (or family) in Mecca and I would look after his in Medina. When I mentioned the word 'Ar-Rahman' in the documents, Umaiya said, "I do not know 'Ar-Rahman.' Write down to me your name, (with which you called yourself) in the Pre-lslamic Period of Ignorance." So, I wrote my name ' 'Abdu 'Amr'. On the day (of the battle) of Badr, when all the people went to sleep, I went up the hill to protect him. Bilal(1) saw him (i.e. Umaiya) and went to a gathering of Ansar and said, "(Here is) Umaiya bin Khalaf! Woe to me if he escapes!" So, a group of Ansar went out with Bilal to follow us ('Abdur-Rahman and Umaiya). Being afraid that they would catch us, I left Umaiya's son for them to keep them busy but the Ansar killed the son and insisted on following us. Umaiya was a fat man, and when they approached us, I told him to kneel down, and he knelt, and I laid myself on him to protect him, but the Ansar killed him by passing their swords underneath me, and one of them injured my foot with his sword. (The sub narrator said, " 'Abdur-Rahman used to show us the trace of the wound on the back of his foot.")


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.499]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 499

Narrated Abu Said Al-Khudri and Abu Huraira:

Allah's Apostle employed someone as a governor at Khaibar. When the man came to Medina, he brought with him dates called Janib. The Prophet asked him, "Are all the dates of Khaibar of this kind?" The man replied, "(No), we exchange two Sa's of bad dates for one Sa of this kind of dates (i.e. Janib), or exchange three Sa's for two." On that, the Prophet said, "Don't do so, as it is a kind of usury (Riba) but sell the dates of inferior quality for money, and then buy Janib with the money". The Prophet said the same thing about dates sold by weight. (See Hadith No. 506).


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.500]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 500

Narrated Ibn Ka'b bin Malik from his father:

We had some sheep which used to graze at Sala'. One of our slavegirls saw a sheep dying and she broke a stone and slaughtered the sheep with it. My father said to the people, "Don't eat it till I ask the Prophet about it (or till I send somebody to ask the Prophet)." So, he asked or sent somebody to ask the Prophet, and the Prophet permitted him to eat it. 'Ubaidullah (a sub-narrator) said, "I admire that girl, for though she was a slave-girl, she dared to slaughter the sheep . "


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.501]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 501

Narrated Abu Huraira:

The Prophet owed somebody a camel of a certain age. When he came to demand it back, the Prophet said (to some people), "Give him (his due)." When the people searched for a camel of that age, they found none, but found a camel one year older. The Prophet said, "Give (it to) him." On that, the man remarked, "You have given me my right in full. May Allah give you in full." The Prophet said, "The best amongst you is the one who pays the rights of others generously."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.502]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 502

Narrated Abu Huraira:

A man came to the Prophet demanding his debts and behaved rudely. The companions of the Prophet intended to harm him, but Allah's Apostle said (to them), "Leave him, for the creditor (i.e. owner of a right) has the right to speak." Allah's Apostle then said, "Give him a camel of the same age as that of his." The people said, "O Allah's Apostle! There is only a camel that is older than his." Allah's Apostle said, "Give (it to) him, for the best amongst you is he who pays the rights of others handsomely."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.503]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 503

Narrated Marwan bin Al-Hakam and Al-Miswar bin Makhrama:

When the delegates of the tribe of Hawazin after embracing Islam, came to Allah's Apostle, he got up. They appealed to him to return their properties and their captives. Allah's Apostle said to them, "The most beloved statement to me is the true one. So, you have the option of restoring your properties or your captives, for I have delayed distributing them." The narrator added, Allah's Apostle c had been waiting for them for more than ten days on his return from Taif. When they realized that Allah's Apostle would return to them only one of two things, they said, "We choose our captives." So, Allah's Apostle got up in the gathering of the Muslims, praised Allah as He deserved, and said, "Then after! These brethren of yours have come to you with repentance and I see it proper to return their captives to them. So, whoever amongst you likes to do that as a favor, then he can do it, and whoever of you wants to stick to his share till we pay him from the very first booty which Allah will give us then he can do so." The people replied, "We agree to give up our shares willingly as a favor for Allah's Apostle." Then Allah's Apostle said, "We don't know who amongst you has agreed and who hasn't. Go back and your chiefs may tell us your opinion." So, all of them returned and their chiefs discussed the matter with them and then they (i.e. their chiefs) came to Allah's Apostle to tell him that they (i.e. the people) had given up their shares gladly and willingly.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.504]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 504

Narrated Jabir bin 'Abdullah:

I was accompanying the Prophet on a journey and was riding a slow camel that was lagging behind the others. The Prophet passed by me and asked, "Who is this?" I replied, "Jabir bin 'Abdullah." He asked, "What is the matter, (why are you late)?" I replied, "I am riding a slow camel." He asked, "Do you have a stick?" I replied in the affirmative. He said, "Give it to me." When I gave it to him, he beat the camel and rebuked it. Then that camel surpassed the others thenceforth. The Prophet said, "Sell it to me." I replied, "It is (a gift) for you, O Allah's Apostle." He said, "Sell it to me. I have bought it for four Dinars (gold pieces) and you can keep on riding it till Medina." When we approached Medina, I started going (towards my house). The Prophet said, "Where are you going?" I Sad, "I have married a widow." He said, "Why have you not married a virgin to fondle with each other?" I said, "My father died and left daughters, so I decided to marry a widow (an experienced woman) (to look after them)." He said, "Well done." When we reached Medina, Allah's Apostle said, "O Bilal, pay him (the price of the camel) and give him extra money." Bilal gave me four Dinars and one Qirat extra. (A sub-narrator said): Jabir added, "The extra Qirat of Allah's Apostle never parted from me." The Qirat was always in Jabir bin 'Abdullah's purse.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.505]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 505

Narrated Abu Huraira:

Allah's Apostle deputed me to keep Sadaqat (al-Fitr) of Ramadan. A comer came and started taking handfuls of the foodstuff (of the Sadaqa) (stealthily). I took hold of him and said, "By Allah, I will take you to Allah's Apostle ." He said, "I am needy and have many dependents, and I am in great need." I released him, and in the morning Allah's Apostle asked me, "What did your prisoner do yesterday?" I said, "O Allah's Apostle! The person complained of being needy and of having many dependents, so, I pitied him and let him go." Allah's Apostle said, "Indeed, he told you a lie and he will be coming again." I believed that he would show up again as Allah's Apostle had told me that he would return. So, I waited for him watchfully. When he (showed up and) started stealing handfuls of foodstuff, I caught hold of him again and said, "I will definitely take you to Allah's Apostle. He said, "Leave me, for I am very needy and have many dependents. I promise I will not come back again." I pitied him and let him go.

In the morning Allah's Apostle asked me, "What did your prisoner do." I replied, "O Allah's Apostle! He complained of his great need and of too many dependents, so I took pity on him and set him free." Allah's Apostle said, "Verily, he told you a lie and he will return." I waited for him attentively for the third time, and when he (came and) started stealing handfuls of the foodstuff, I caught hold of him and said, "I will surely take you to Allah's Apostle as it is the third time you promise not to return, yet you break your promise and come." He said, "(Forgive me and) I will teach you some words with which Allah will benefit you." I asked, "What are they?" He replied, "Whenever you go to bed, recite "Ayat-al-Kursi"-- 'Allahu la ilaha illa huwa-l-Haiy-ul Qaiyum' till you finish the whole verse. (If you do so), Allah will appoint a guard for you who will stay with you and no satan will come near you till morning. " So, I released him. In the morning, Allah's Apostle asked, "What did your prisoner do yesterday?" I replied, "He claimed that he would teach me some words by which Allah will benefit me, so I let him go." Allah's Apostle asked, "What are they?" I replied, "He said to me, 'Whenever you go to bed, recite Ayat-al-Kursi from the beginning to the end ---- Allahu la ilaha illa huwa-lHaiy-ul-Qaiyum----.' He further said to me, '(If you do so), Allah will appoint a guard for you who will stay with you, and no satan will come near you till morning.' (Abu Huraira or another sub-narrator) added that they (the companions) were very keen to do good deeds. The Prophet said, "He really spoke the truth, although he is an absolute liar. Do you know whom you were talking to, these three nights, O Abu Huraira?" Abu Huraira said, "No." He said, "It was Satan."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.506]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 506

Narrated Abu Said al-Khudri:

Once Bilal brought Barni (i.e. a kind of dates) to the Prophet and the Prophet asked him, "From where have you brought these?" Bilal replied, "I had some inferior type of dates and exchanged two Sas of it for one Sa of Barni dates in order to give it to the Prophet; to eat." Thereupon the Prophet said, "Beware! Beware! This is definitely Riba (usury)! This is definitely Riba (Usury)! Don't do so, but if you want to buy (a superior kind of dates) sell the inferior dates for money and then buy the superior kind of dates with that money."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.507]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 507

Narrated 'Amr:

Concerning the Waqf of 'Umar: It was not sinful of the trustee (of the Waqf) to eat or provide his friends from it, provided the trustee had no intention of collecting fortune (for himself). Ibn 'Umar was the manager of the trust of 'Umar and he used to give presents from it to those with whom he used to stay at Mecca.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.508]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 508

Narrated Zaid bin Khalid and Abu Huraira:

The Prophet said, "O Unais! Go to the wife of this (man) and if she confesses (that she has committed illegal sexual intercourse), then stone her to death."


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.509]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 509

Narrated 'Uqba bin Al-Harith:

When An-Nuaman or his son was brought in a state of drunkenness, Allah's Apostle ordered all those who were present in the house to beat him. I was one of those who beat him. We beat him with shoes and palm-leaf stalks.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.510]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 510

Narrated 'Aisha:

I twisted the garlands of the Hadis (i.e. animals for sacrifice) of Allah's Apostle with my own hands. Then Allah's Apostle put them around their necks with his own hands, and sent them with my father (to Mecca). Nothing legal was regarded illegal for Allah's Apostle till the animals were slaughtered.


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.511]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 511

Narrated Anas bin Malik:

Abu Talha was the richest man in Medina amongst the Ansar and Beeruha' (garden) was the most beloved of his property, and it was situated opposite the mosque (of the Prophet.). Allah's Apostle used to enter it and drink from its sweet water. When the following Divine Verse were revealed: 'you will not attain righteousness till you spend in charity of the things you love' (3.93), Abu Talha got up in front of Allah's Apostle and said, "O Allah's Apostle! Allah says in His Book, 'You will not attain righteousness unless you spend (in charity) that which you love,' and verily, the most beloved to me of my property is Beeruha (garden), so I give it in charity and hope for its reward from Allah. O Allah's Apostle! Spend it wherever you like." Allah's Apostle appreciated that and said, "That is perishable wealth, that is perishable wealth. I have heard what you have said; I suggest you to distribute it among your relatives." Abu Talha said, "I will do so, O Allah's Apostle." So, Abu Talha distributed it among his relatives and cousins. The sub-narrator (Malik) said: The Prophet said: "That is a profitable wealth," instead of "perishable wealth".


Bukhari :: Representation, Authorization, Business by Proxy :: [3.38.512]

Representation, Authorization, Business by Proxy

Bukhari :: Book 3 :: Volume 38 :: Hadith 512

Narrated Abu Musa:

The Prophet said, "An honest treasurer who gives what he is ordered to give fully, perfectly and willingly to the person to whom he is ordered to give, is regarded as one of the two charitable persons."


Bukhari :: Agriculture :: [3.39.513]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 513

Narrated Anas bin Malik:

Allah's Apostle said, "There is none amongst the Muslims who plants a tree or sows seeds, and then a bird, or a person or an animal eats from it, but is regarded as a charitable gift for him."


Bukhari :: Agriculture :: [3.39.514]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 514

Narrated Abu Umama al-Bahili:

I saw some agricultural equipments and said: "I heard the Prophet saying: "There is no house in which these equipment enters except that Allah will cause humiliation to enter it."


Bukhari :: Agriculture :: [3.39.515]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 515

Narrated Abu Huraira:

Allah's Apostle said, "Whoever keeps a dog, one Qirat of the reward of his good deeds is deducted daily, unless the dog is used for guarding a farm or cattle." Abu Huraira (in another narration) said from the Prophet, "unless it is used for guarding sheep or farms, or for hunting." Narrated Abu Hazim from Abu Huraira: The Prophet said, "A dog for guarding cattle or for hunting."


Bukhari :: Agriculture :: [3.39.516]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 516

Narrated As-Sa'ib bin Yazid:

Abu Sufyan bin Abu Zuhair, a man from Azd Shanu'a and one of the companions of the Prophet said, "I heard Allah's Apostle saying, 'If one keeps a dog which is meant for guarding neither a farm nor cattle, one Qirat of the reward of his good deeds is deducted daily." I said, "Did you hear this from Allah's Apostle?" He said, "Yes, by the Lord of this Mosque."


Bukhari :: Agriculture :: [3.39.517]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 517

Narrated Abu Huraira:

The Prophet said, "While a man was riding a cow, it turned towards him and said, 'I have not been created for this purpose (i.e. carrying), I have been created for sloughing." The Prophet added, "I, Abu Bakr and 'Umar believe in the story." The Prophet went on, "A wolf caught a sheep, and when the shepherd chased it, the wolf said, 'Who will be its guard on the day of wild beasts, when there will be no shepherd for it except me?' "After narrating it, the Prophet said, "I, Abu Bakr and 'Umar too believe it." Abu Salama (a sub-narrator) said, "Abu Bakr and 'Umar were not present then." (It has been written that a wolf also spoke to one of the companions of the Prophet near Medina as narrated in Fatah-al-Bari:

Narrated Unais bin 'Amr: Ahban bin Aus said, "I was amongst my sheep. Suddenly a wolf caught a sheep and I shouted at it. The wolf sat on its tail and addressed me, saying, 'Who will look after it (i.e. the sheep) when you will be busy and not able to look after it? Do you forbid me the provision which Allah has provided me?' " Ahban added, "I clapped my hands and said, 'By Allah, I have never seen anything more curious and wonderful than this!' On that the wolf said, 'There is something (more curious) and wonderful than this; that is, Allah's Apostle in those palm trees, inviting people to Allah (i.e. Islam).' "Unais bin 'Amr further said, "Then Ahban went to Allah's Apostle and informed him what happened and embraced Islam.)" palm trees or other trees and share the fruits with me."


Bukhari :: Agriculture :: [3.39.518]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 518

Narrated Abu Huraira:

The Ansar said to the Prophet "Distribute the date palm trees between us and our emigrant brothers." He replied, "No." The Ansar said (to the emigrants), "Look after the trees (water and watch them) and share the fruits with us." The emigrants said, "We listen and obey."


Bukhari :: Agriculture :: [3.39.519]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 519

Narrated 'Abdullah:

The Prophet got the date palm trees of the tribe of Bani-An-Nadir burnt and the trees cut down at a place called Al-Buwaira . Hassan bin Thabit said in a poetic verse: "The chiefs of Bani Lu'ai found it easy to watch fire spreading at Al-Buwaira."


Bukhari :: Agriculture :: [3.39.520]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 520

Narrated Rafi' bin Khadij:

We worked on farms more than anybody else in Medina. We used to rent the land at the yield of specific delimited portion of it to be given to the landlord. Sometimes the vegetation of that portion was affected by blights etc., while the rest remained safe and vice versa, so the Prophet forbade this practice. At that time gold or silver were not used (for renting the land). If they provided the seeds, they would get so-and-so much. Al-Hasan said, "There is no harm if the land belongs to one but both spend on it and the yield is divided between them." Az-Zuhri had the same opinion. Al-Hasan said, "There is no harm if cotton is picked on the condition of having half the yield." Ibrahim, Ibn Siain, 'Ata', Al-Hakam, Az-Zuhri and Qatada said, "There is no harm in giving the yarn to the weaver to weave into cloth on the basis that one-third or one-fourth (or any other portion) of the cloth is given to the weaver for his labor." Ma'am said, "There is no harm in hiring animals for a definite (fixed) period on the basis that one-third or one-fourth of the products carried by the animals is given to the owner of the animals."


Bukhari :: Agriculture :: [3.39.521]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 521

Narrated 'Abdullah bin 'Umar:

The Prophet concluded a contract with the people of Khaibar to utilize the land on the condition that half the products of fruits or vegetation would be their share. The Prophet used to give his wives one hundred Wasqs each, eighty Wasqs of dates and twenty Wasqs of barley. (When 'Umar became the Caliph) he gave the wives of the Prophet the option of either having the land and water as their shares, or carrying on the previous practice. Some of them chose the land and some chose the Wasqs, and 'Aisha chose the land.


Bukhari :: Agriculture :: [3.39.522]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 522

Narrated Ibn 'Umar:

The Prophet made a deal with the people of Khaibar that they would have half the fruits and vegetation of the land they cultivated.


Bukhari :: Agriculture :: [3.39.523]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 523

Narrated 'Amr:

I said to Tawus, "I wish you would give up Mukhabara (Share-cropping), for the people say that the Prophet forbade it." On that Tawus replied, "O 'Amr! I give the land to share-croppers and help them. No doubt; the most learned man, namely Ibn 'Abbas told me that the Prophet had not forbidden it but said, 'It is more beneficial for one to give his land free to one's brother than to charge him a fixed rental."


Bukhari :: Agriculture :: [3.39.524]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 524

Narrated Ibn 'Umar:

Allah's Apostle gave the land of Khaibar to the Jew's on the condition that they work on it and cultivate it, and be given half of its yield.


Bukhari :: Agriculture :: [3.39.525]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 525

Narrated Rafi:

We worked on farms more than anybody else in Medina. We used to rent the land and say to the owner, "The yield of this portion is for us and the yield of that portion is for you (as the rent)." One of those portions might yield something and the other might not. So, the Prophet forbade us to do so.


Bukhari :: Agriculture :: [3.39.526]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 526

Narrated 'Abdullah bin 'Umar:

The Prophet said, "While three men were walking, It started raining and they took shelter (refuge) in a cave in a mountain. A big rock rolled down from the mountain and closed the mouth of the cave. They said to each other, "Think of good deeds which you did for Allah's sake only, and invoke Allah by giving reference to those deeds so that He may remove this rock from you." One of them said, 'O Allah! I had old parents and small children and I used to graze the sheep for them. On my return to them in the evening, I used to milk (the sheep) and start providing my parents first of all before my children. One day I was delayed and came late at night and found my parents sleeping. I milked (the sheep) as usual and stood by their heads. I hated to wake them up and disliked to give milk to my children before them, although my children were weeping (because of hunger) at my feet till the day dawned. O Allah! If I did this for Your sake only, kindly remove the rock so that we could see the sky through it.' So, Allah removed the rock a little and they saw the sky. The second man said, 'O Allah! I was in love with a cousin of mine like the deepest love a man may have for a woman. I wanted to outrage her chastity but she refused unless I gave her one hundred Dinars. So, I struggled to collect that amount. And when I sat between her legs, she said, 'O Allah's slave! Be afraid of Allah and do not deflower me except rightfully (by marriage).' So, I got up. O Allah! If I did it for Your sake only, please remove the rock.' The rock shifted a little more. Then the third man said, 'O Allah! I employed a laborer for a Faraq of rice and when he finished his job and demanded his right, I presented it to him, but he refused to take it. So, I sowed the rice many time till I gathered cows and their shepherd (from the yield). (Then after some time) He came and said to me, 'Fear Allah (and give me my right)." I said, 'Go and take those cows and the shepherd.' He said, 'Be afraid of Allah! Don't mock at me.' I said, 'I am not mocking at you. Take (all that).' So, he took all that. O Allah! If I did that for Your sake only, please remove the rest of the rock.' So, Allah removed the rock."


Bukhari :: Agriculture :: [3.39.527]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 527

Narrated Zaid bin Aslam from his father:

Umar said, "But for the future Muslim generations, I would have distributed the land of the villages I conquer among the soldiers as the Prophet distributed the land of Khaibar."


Bukhari :: Agriculture :: [3.39.528]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 528

Narrated 'Aisha:

The Prophet said, "He who cultivates land that does not belong to anybody is more rightful (to own it)." 'Urwa said, "Umar gave the same verdict in his Caliphate."


Bukhari :: Agriculture :: [3.39.529]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 529

Narrated 'Abdullah bin 'Umar:

While the Prophet was passing the night at his place of rest in Dhul-Hulaifa in the bottom of the valley (of Aqiq), he saw a dream and it was said to him, "You are in a blessed valley." Musa said, "Salim let our camels kneel at the place where 'Abdullah used to make his camel kneel, seeking the place where Allah's Apostle used to take a rest, which is situated below the mosque which is in the bottom of the valley; it is midway between the mosque and the road."


Bukhari :: Agriculture :: [3.39.530]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 530

Narrated 'Umar:

While the Prophet was in Al-'Aqiq he said, "Someone (meaning Gabriel) came to me from my Lord tonight (in my dream) and said, 'Offer the prayer in this blessed valley and say (I intend to perform) Umra along with Hajj (together).' "


Bukhari :: Agriculture :: [3.39.531]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 531

Narrated Ibn 'Umar:

Umar expelled the Jews and the Christians from Hijaz. When Allah's Apostle had conquered Khaibar, he wanted to expel the Jews from it as its land became the property of Allah, His Apostle, and the Muslims. Allah's Apostle intended to expel the Jews but they requested him to let them stay there on the condition that they would do the labor and get half of the fruits. Allah's Apostle told them, "We will let you stay on thus condition, as long as we wish." So, they (i.e. Jews) kept on living there until 'Umar forced them to go towards Taima' and Ariha'.


Bukhari :: Agriculture :: [3.39.532]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 532

Narrated Rafi bin Khadij:

My uncle Zuhair said, "Allah's Apostle forbade us to do a thing which was a source of help to us." I said, "Whatever Allah's Apostle said was right." He said, "Allah's Apostle sent for me and asked, 'What are you doing with your farms?' I replied, 'We give our farms on rent on the basis that we get the yield produced at the banks of the water streams (rivers) for the rent, or rent it for some Wasqs of barley and dates.' Allah's Apostle said, 'Do not do so, but cultivate (the land) yourselves or let it be cultivated by others gratis, or keep it uncultivated.' I said, 'We hear and obey.'


Bukhari :: Agriculture :: [3.39.533]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 533

Narrated Jabir:

The people used to rent their land for cultivation for one-third, one-fourth or half its yield. The Prophet said, "Whoever has land should cultivate it himself or give it to his (Muslim) brother gratis; otherwise keep it uncultivated."

Narrated Abu Huraira: Allah's Apostle said, "Whoever has land should cultivate it himself or give it to his (Muslim) brother gratis; otherwise he should keep it uncultivated."


Bukhari :: Agriculture :: [3.39.534]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 534

Narrated 'Amr:

When I mentioned it (i.e. the narration of Rafi 'bin Khadij: no. 532) to Tawus, he said, "It is permissible to rent the land for cultivation, for Ibn 'Abbas said, 'The Prophet did not forbid that, but said: One had better give the land to one's brother gratis rather than charge a certain amount for it.' "


Bukhari :: Agriculture :: [3.39.535]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 535

Narrated Nafi:

Ibn 'Umar used to rent his farms in the time of Abu Bakr, 'Umar, 'Uthman, and in the early days of Muawiya. Then he was told the narration of Rafi 'bin Khadij that the Prophet had forbidden the renting of farms. Ibn 'Umar went to Rafi' and I accompanied him. He asked Rafi who replied that the Prophet had forbidden the renting of farms. Ibn 'Umar said, "You know that we used to rent our farms in the life-time of Allah's Apostle for the yield of the banks of the water streams (rivers) and for certain amount of figs.


Bukhari :: Agriculture :: [3.39.536]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 536

Narrated Salim:

Abdullah bin 'Umar said, "I knew that the land was rented for cultivation in the life-time of Allah's Apostle ." Later on Ibn 'Umar was afraid that the Prophet had forbidden it, and he had no knowledge of it, so he gave up renting his land.


Bukhari :: Agriculture :: [3.39.537]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 537

Narrated Hanzla bin Qais:

Rafi bin Khadij said, "My two uncles told me that they (i.e. the companions of the Prophet) used to rent the land in the life-time of the Prophet for the yield on the banks of water streams (rivers) or for a portion of the yield stipulated by the owner of the land. The Prophet forbade it." I said to Rafi, "What about renting the land for Dinars and Dirhams?" He replied, "There is no harm in renting for Dinars-Dirhams. Al-Laith said, "If those who have discernment for distinguishing what is legal from what is illegal looked into what has been forbidden concerning this matter they would not permit it, for it is surrounded with dangers."


Bukhari :: Agriculture :: [3.39.538]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 538

Narrated Abu Huraira:

Once the Prophet was narrating (a story), while a bedouin was sitting with him. "One of the inhabitants of Paradise will ask Allah to allow him to cultivate the land. Allah will ask him, 'Are you not living in the pleasures you like?' He will say, 'Yes, but I like to cultivate the land.' " The Prophet added, "When the man (will be permitted he) will sow the seeds and the plants will grow up and get ripe, ready for reaping and so on till it will be as huge as mountains within a wink. Allah will then say to him, 'O son of Adam! Take here you are, gather (the yield); nothing satisfies you.' " On that, the bedouin said, "The man must be either from Quraish (i.e. an emigrant) or an Ansari, for they are farmers, whereas we are not farmers." The Prophet smiled (at this).


Bukhari :: Agriculture :: [3.39.539]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 539

Narrated Sahl bin Sad:

We used to be very happy on Friday as an old lady used to cut some roots of the Silq, which we used to plant on the banks of our small water streams, and cook them in a pot of her's, adding to them, some grains of barley. (Ya'qub, the sub-narrator said, "I think the narrator mentioned that the food did not contain fat or melted fat (taken from meat).") When we offered the Friday prayer we would go to her and she would serve us with the dish. So, we used to be happy on Fridays because of that. We used not to take our meals or the midday nap except after the Jumua prayer (i.e. Friday prayer) .


Bukhari :: Agriculture :: [3.39.540]

Agriculture

Bukhari :: Book 3 :: Volume 39 :: Hadith 540

Narrated Abu Huraira:

The people say that Abu Huraira narrates too many narrations. In fact Allah knows whether I say the truth or not. They also ask, "Why do the emigrants and the Ansar not narrate as he does?" In fact, my emigrant brethren were busy trading in the markets, and my Ansar brethren were busy with their properties. I was a poor man keeping the company of Allah's Apostle and was satisfied with what filled my stomach. So, I used to be present while they (i.e. the emigrants and the Ansar) were absent, and I used to remember while they forgot (the Hadith). One day the Prophet said, "Whoever spreads his sheet till I finish this statement of mine and then gathers it on his chest, will never forget anything of my statement." So, I spread my covering sheet which was the only garment I had, till the Prophet finished his statement and then I gathered it over my chest. By Him Who had sent him (i.e. Allah's Apostle) with the truth, since then I did not forget even a single word of that statement of his, until this day of mine. By Allah, but for two verses in Allah's Book, I would never have related any narration (from the Prophet). (These two verses are): "Verily! Those who conceal the clear signs and the guidance which we have sent down .....(up to) the Merciful.' (2.159-160)


Bukhari :: Distribution of Water :: [3.40.541]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 541

Narrated Sahl bin Sad:

A tumbler (full of milk or water) was brought to the Prophet who drank from it, while on his right side there was sitting a boy who was the youngest of those who were present and on his left side there were old men. The Prophet asked, "O boy, will you allow me to give it (i.e. the rest of the drink) to the old men?" The boy said, "O Allah's Apostle! I will not give preference to anyone over me to drink the rest of it from which you have drunk." So, the Prophet gave it to him.


Bukhari :: Distribution of Water :: [3.40.542]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 542

Narrated Az-Zuhri:

Anas bin Malik said, that once a domestic sheep was milked for Allah's Apostle while he was in the house of Anas bin Malik. The milk was mixed with water drawn from the well in Anas's house. A tumbler of it was presented to Allah's Apostle who drank from it. Then Abu Bakr was sitting on his left side and a bedouin on his right side. When the Prophet removed the tumbler from his mouth, 'Umar was afraid that the Prophet might give it to the bedouin, so he said. "O Allah's Apostle! Give it to Abu Bakr who is sitting by your side." But the Prophet gave it to the bedouin, who was to his right and said, "You should start with the one on your right side."


Bukhari :: Distribution of Water :: [3.40.543]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 543

Narrated Abu Huraira:

Allah's Apostle said, "Do not withhold the superfluous water, for that will prevent people from grazing their cattle."


Bukhari :: Distribution of Water :: [3.40.544]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 544

Narrated Abu Huraira:

that Allah's Apostle said, "Do not withhold the superfluous water in order to withhold the superfluous grass."


Bukhari :: Distribution of Water :: [3.40.545]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 545

Narrated Abu Huraira:

Allah's Apostle said, "No bloodmoney will be charged if somebody dies in a mine or in a well or is killed by an animal; and if somebody finds a treasure in his land he has to give one-fifth of it to the Government."


Bukhari :: Distribution of Water :: [3.40.546]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 546

Narrated 'Abdullah (bin Mas'ud):

The Prophet said, "Whoever takes a false oath to deprive somebody of his property will meet Allah while He will be angry with him." Allah revealed: 'Verily those who purchase a little gain at the cost of Allah's covenant, and their oaths.' ........(3.77)

Al-Ash'ath came (to the place where 'Abdullah was narrating) and said, "What has Abu 'Abdur-Rahman (i.e. Abdullah) been telling you? This verse was revealed concerning me. I had a well in the land of a cousin of mine. The Prophet asked me to bring witnesses (to confirm my claim). I said, 'I don't have witnesses.' He said, 'Let the defendant take an oath then.' I said, 'O Allah's Apostle! He will take a (false) oath immediately.' Then the Prophet mentioned the above narration and Allah revealed the verse to confirm what he had said." (See Hadith No. 692)


Bukhari :: Distribution of Water :: [3.40.547]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 547

Narrated Abu Huraira:

Allah's Apostle said, "There are three persons whom Allah will not look at on the Day of Resurrection, nor will he purify them and theirs shall be a severe punishment. They are:

1. A man possessed superfluous water, on a way and he withheld it from travelers.

2. A man who gave a pledge of allegiance to a ruler and he gave it only for worldly benefits. If the ruler gives him something he gets satisfied, and if the ruler withholds something from him, he gets dissatisfied.

3. And man displayed his goods for sale after the 'Asr prayer and he said, 'By Allah, except Whom None has the right to be worshipped, I have been given so much for my goods,' and somebody believes him (and buys them)."

The Prophet then recited: "Verily! Those who purchase a little gain at the cost of Allah's Covenant and their oaths." (3.77)


Bukhari :: Distribution of Water :: [3.40.548]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 548

Narrated 'Abdullah bin Az-Zubair:

An Ansari man quarrelled with Az-Zubair in the presence of the Prophet about the Harra Canals which were used for irrigating the date-palms. The Ansari man said to Az-Zubair, "Let the water pass' but Az-Zubair refused to do so. So, the case was brought before the Prophet who said to Az-Zubair, "O Zubair! Irrigate (your land) and then let the water pass to your neighbor." On that the Ansari got angry and said to the Prophet, "Is it because he (i.e. Zubair) is your aunt's son?" On that the color of the face of Allah's Apostle changed (because of anger) and he said, "O Zubair! Irrigate (your land) and then withhold the water till it reaches the walls between the pits round the trees." Zubair said, "By Allah, I think that the following verse was revealed on this occasion": "But no, by your Lord They can have No faith Until they make you judge In all disputes between them." (4.65)


Bukhari :: Distribution of Water :: [3.40.549]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 549

Narrated 'Urwa:

When a man from the Ansar quarrelled with AzZubair, the Prophet said, "O Zubair! Irrigate (your land) first and then let the water flow (to the land of the others)." "On that the Ansari said, (to the Prophet), "It is because he is your aunt's son." On that the Prophet said, "O Zubair! Irrigate till the water reaches the walls between the pits around the trees and then stop (i.e. let the water go to the other's land)." I think the following verse was revealed concerning this event: "But no, by your Lord They can have No faith Until they make you judge In all disputes between them." (4.65)


Bukhari :: Distribution of Water :: [3.40.550]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 550

Narrated 'Urwa bin Az-Zubair:

An-Ansari man quarrelled with Az-Zubair about a canal in the Harra which was used for irrigating date-palms. Allah's Apostle, ordering Zubair to be moderate, said, "O Zubair! Irrigate (your land) first and then leave the water for your neighbor." The Ansari said, "Is it because he is your aunt's son?" On that the color of the face of Allah's Apostle changed and he said, "O Zubair! Irrigate (your land) and withhold the water till it reaches the walls that are between the pits around the trees." So, Allah's Apostle gave Zubair his full right. Zubair said, "By Allah, the following verse was revealed in that connection": "But no, by your Lord They can have No faith Until they make you judge In all disputes between them." (4.65)

(The sub-narrator,) Ibn Shihab said to Juraij (another sub-narrator), "The Ansar and the other people interpreted the saying of the Prophet, 'Irrigate (your land) and with-hold the water till it reaches the walls between the pits around the trees,' as meaning up to the ankles."


Bukhari :: Distribution of Water :: [3.40.551]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 551

Narrated Abu Huraira:

Allah's Apostle said, "While a man was walking he felt thirsty and went down a well and drank water from it. On coming out of it, he saw a dog panting and eating mud because of excessive thirst. The man said, 'This (dog) is suffering from the same problem as that of mine. So he (went down the well), filled his shoe with water, caught hold of it with his teeth and climbed up and watered the dog. Allah thanked him for his (good) deed and forgave him." The people asked, "O Allah's Apostle! Is there a reward for us in serving (the) animals?" He replied, "Yes, there is a reward for serving any animate."


Bukhari :: Distribution of Water :: [3.40.552]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 552

Narrated Asma' bint Abi Bakr:

The Prophet prayed the eclipse prayer, and then said, "Hell was displayed so close that I said, 'O my Lord ! Am I going to be one of its inhabitants?"' Suddenly he saw a woman. I think he said, who was being scratched by a cat. He said, "What is wrong with her?" He was told, "She had imprisoned it (i.e. the cat) till it died of hunger."


Bukhari :: Distribution of Water :: [3.40.553]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 553

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "A woman was tortured and was put in Hell because of a cat which she had kept locked till it died of hunger." Allah's Apostle further said, (Allah knows better) Allah said (to the woman), 'You neither fed it nor watered when you locked it up, nor did you set it free to eat the insects of the earth."


Bukhari :: Distribution of Water :: [3.40.554]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 554

Narrated Sahl bin Sad:

Once a tumbler (full of milk or water) was brought to Allah's Apostle who drank from it, while on his right side there was sitting a boy who was the youngest of those who were present, and on his left side there were old men. The Prophet asked, "O boy ! Do you allow me to give (the drink) to the elder people (first)?" The boy said, "I will not prefer anybody to have my share from you, O Allah's Apostle!" So, he gave it to the boy.


Bukhari :: Distribution of Water :: [3.40.555]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 555

Narrated Abu Huraira:

The Prophet said, "By Him in Whose Hands my soul is, I will drive some people out from my (sacred) Fount on the Day of Resurrection as strange camels are expelled from a private trough."


Bukhari :: Distribution of Water :: [3.40.556]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 556

Narrated Ibn 'Abbas:

The Prophet said, "May Allah be merciful to the mother of Ishmael! If she had left the water of Zam-Zam (fountain) as it was, (without constructing a basin for keeping the water), (or said, "If she had not taken handfuls of its water"), it would have been a flowing stream. Jurhum (an Arab tribe) came and asked her, 'May we settle at your dwelling?' She said, 'Yes, but you have no right to possess the water.' They agreed."


Bukhari :: Distribution of Water :: [3.40.557]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 557

Narrated Abu Huraira:

The Prophet said, "There are three types of people whom Allah will neither talk to, nor look at, on the Day of Resurrection. (They are):

1. A man who takes an oath falsely that he has been offered for his goods so much more than what he is given,

2. a man who takes a false oath after the 'Asr prayer in order to grab a Muslim's property, and

3. a man who with-holds his superfluous water. Allah will say to him, "Today I will with-hold My Grace from you as you with-held the superfluity of what you had not created."


Bukhari :: Distribution of Water :: [3.40.558]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 558

Narrated As-Sab bin Jaththama:

Allah's Apostle said, No Hima except for Allah and His Apostle. We have been told that Allah's Apostle made a place called An-Naqi' as Hima, and 'Umar made Ash-Sharaf and Ar-Rabadha Hima (for grazing the animals of Zakat).


Bukhari :: Distribution of Water :: [3.40.559]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 559

Narrated Abu Huraira:

Allah's Apostle said, "Keeping horses may be a source of reward to some (man), a shelter to another (i.e. means of earning one's living), or a burden to a third. He to whom the horse will be a source of reward is the one who keeps it in Allah's Cause (prepare it for holy battles) and ties it by a long rope in a pasture (or a garden). He will get a reward equal to what its long rope allows it to eat in the pasture or the garden, and if that horse breaks its rope and crosses one or two hills, then all its foot-steps and its dung will be counted as good deeds for its owner; and if it passes by a river and drinks from it, then that will also be regarded as a good deed for its owner even if he has had no intention of watering it then. Horses are a shelter from poverty to the second person who keeps horses for earning his living so as not to ask others, and at the same time he gives Allah's right (i.e. Rakat) (from the wealth he earns through using them in trading etc.,) and does not overburden them. He who keeps horses just out of pride and for showing off and as a means of harming the Muslims, his horses will be a source of sins to him." When Allah's Apostle was asked about donkeys, he replied, "Nothing particular was revealed to me regarding


Bukhari :: Distribution of Water :: [3.40.560]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 560

Narrated Zaid bin Khalid:

A man came to Allah's Apostle and asked about Al-Luqata (a fallen thing). The Prophet said, "Recognize its container and its tying material and then make a public announcement about it for one year and if its owner shows up, give it to him; otherwise use it as you like." The man said, "What about a lost sheep?" The Prophet said, "It is for you, your brother or the wolf." The man said "What about a lost camel?" The Prophet said, "Why should you take it as it has got its water-container (its stomach) and its hooves and it can reach the places of water and can eat the trees till its owner finds it?"


Bukhari :: Distribution of Water :: [3.40.561]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 561

Narrated Az-Zubair bin Al 'Awwam:

The Prophet said, "No doubt, one had better take a rope (and cut) and tie a bundle of wood and sell it whereby Allah will keep his face away (from Hell-fire) rather than ask others who may give him or not."


Bukhari :: Distribution of Water :: [3.40.562]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 562

Narrated Abu Huraira:

Allah's Apostle said, "No doubt, you had better gather a bundle of wood and carry it on your back (and earn your living thereby) rather than ask somebody who may give you or not."


Bukhari :: Distribution of Water :: [3.40.563]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 563

Narrated Husain bin Ali:

Ali bin Abi Talib said: "I got a she-camel as my share of the war booty on the day (of the battle) of Badr, and Allah's Apostle gave me another she-camel. I let both of them kneel at the door of one of the Ansar, intending to carry Idhkhir on them to sell it and use its price for my wedding banquet on marrying Fatima. A goldsmith from Bam Qainqa' was with me. Hamza bin 'Abdul-Muttalib was in that house drinking wine and a lady singer was reciting: "O Hamza! (Kill) the (two) fat old she camels (and serve them to your guests)."

So Hamza took his sword and went towards the two she-camels and cut off their humps and opened their flanks and took a part of their livers." (I said to Ibn Shihab, "Did he take part of the humps?" He replied, "He cut off their humps and carried them away.") 'Ali further said, "When I saw that dreadful sight, I went to the Prophet and told him the news. The Prophet came out in the company of Zaid bin Haritha who was with him then, and I too went with them. He went to Hamza and spoke harshly to him. Hamza looked up and said, 'Aren't you only the slaves of my forefathers?' The Prophet retreated and went out. This incident happened before the prohibition of drinking."


Bukhari :: Distribution of Water :: [3.40.564]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 564

Narrated Anas:

The Prophet decided to grant a portion of (the uncultivated land of) Bahrain to the Ansar. The Ansar said, "(We will not accept it) till you give a similar portion to our emigrant brothers (from Quraish)." He said, "(O Ansar!) You will soon see people giving preference to others, so remain patient till you meet me (on the Day of Resurrection).


Bukhari :: Distribution of Water :: [3.40.565]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 565

Narrated Abu Huraira: The Prophet said, "One of the rights of a she camel is that it should be milked at a place of water."


Bukhari :: Distribution of Water :: [3.40.566]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 566

Narrated Zaid bin Thabit:

The Prophet permitted selling the dates of the 'Araya for ready dates by estimating the amount of the former (as they are still on the trees).


Bukhari :: Distribution of Water :: [3.40.567]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 567

Narrated Jabir bin 'Abdullah:

The Prophet forbade the sales called Al-Mukhabara, Al-Muhaqala and Al-Muzabana and the selling of fruits till they are free from blights. He forbade the selling of the fruits except for money, except the 'Araya.


Bukhari :: Distribution of Water :: [3.40.568]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 568

Narrated Abu Huraira:

The Prophet allowed the sale of the dates of the 'Araya for ready dates by estimating the former which should be estimated as less than five Awsuq or five Awsuq. (Dawud, the sub-narrator is not sure as to the right amount.)


Bukhari :: Distribution of Water :: [3.40.569]

Distribution of Water

Bukhari :: Book 3 :: Volume 40 :: Hadith 569

Narrated Rafi 'bin Khadij and Sahl bin Al Hathma:

Allah's Apostle forbade the sale of Muzabana, i.e. selling of fruits for fruits, except in the case of 'Araya; he allowed the owners of 'Araya such kind of sale.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.570]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 570

Narrated Jabir bin 'Abdullah:

While I was in the company of the Prophet in one of his Ghazawat, he asked, "What is wrong with your camel? Will you sell it?" I replied in the affirmative and sold it to him. When he reached Medina, I took the camel to him in the morning and he paid me its price.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.571]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 571

Narrated Al-Amash:

When we were with Ibrahim, we talked about mortgaging in deals of Salam. Ibrahim narrated from Aswad that 'Aisha had said, "The Prophet bought some foodstuff on credit from a Jew and mortgaged an iron armor to him."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.572]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 572

Narrated Abu Huraira:

The Prophet said, "Whoever takes the money of the people with the intention of repaying it, Allah will repay it on his behalf, and whoever takes it in order to spoil it, then Allah will spoil him."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.573]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 573

Narrated Abu Dhar:

Once, while I was in the company of the Prophet, he saw the mountain of Uhud and said, "I would not like to have this mountain turned into gold for me unless nothing of it, not even a single Dinar remains of it with me for more than three days (i.e. I will spend all of it in Allah's Cause), except that Dinar which I will keep for repaying debts." Then he said, "Those who are rich in this world would have little reward in the Hereafter except those who spend their money here and there (in Allah's Cause), and they are few in number." Then he ordered me to stay at my place and went not far away. I heard a voice and intended to go to him but I remembered his order, "Stay at your place till I return." On his return I said, "O Allah's Apostle! (What was) that noise which I heard?" He said, "Did you hear anything?" I said, "Yes." He said, "Gabriel came and said to me, 'Whoever amongst your followers dies, worshipping none along with Allah, will enter Paradise.' " I said, "Even if he did such-and-such things (i.e. even if he stole or committed illegal sexual intercourse)" He said, "Yes."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.574]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 574

Narrated Abu Huraira:

Allah's Apostle said, "If I had gold equal to the mountain of Uhud, it would not please me that it should remain with me for more than three days, except an amount which I would keep for repaying debts."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.575]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 575

Narrated Abu Huraira:

A man demanded his debts from Allah's Apostle in such a rude manner that the companions of the Prophet intended to harm him, but the Prophet said, "Leave him, no doubt, for he (the creditor) has the right to demand it (harshly). Buy a camel and give it to him." They said, "The camel that is available is older than the camel he demands. "The Prophet said, "Buy it and give it to him, for the best among you are those who repay their debts handsomely. "


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.576]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 576

Narrated Hudhaifa:

I heard the Prophet saying, "Once a man died and was asked, 'What did you use to say (or do) (in your life time)?' He replied, 'I was a business-man and used to give time to the rich to repay his debt and (used to) deduct part of the debt of the poor.' So he was forgiven (his sins.)" Abu Masud said, "I heard the same (Hadith) from the Prophet."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.577]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 577

Narrated Abu Huraira:

A man came to the Prophet and demanded a camel (the Prophet owed him). Allah's Apostle told his companions to give him (a camel). They said, "We do not find except an older camel (than what he demands). (The Prophet ordered them to give him that camel). The man said, "You have paid me in full and may Allah also pay you in full." Allah's Apostle said, "Give him, for the best amongst the people is he who repays his debts in the most handsome manner."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.578]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 578

Narrated Abu Huraira:

The Prophet owed a camel of a certain age to a man who came to demand it back. The Prophet ordered his companions to give him. They looked for a camel of the same age but found nothing but a camel one year older. The Prophet told them to give it to him. The man said, "You have paid me in full, and may Allah pay you in full." The Prophet said, "The best amongst you is he who pays his debts in the most handsome manner."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.579]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 579

Narrated Jabir bin Abdullah:

I went to the Prophet while he was in the Mosque. (Mis'ar thinks, that Jabir went in the forenoon.) After the Prophet told me to pray two Rakat, he repayed me the debt he owed me and gave me an extra amount.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.580]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 580

Narrated Jabir bin 'Abdullah:

My father was martyred on the day (of the battle) of Uhud, and he was in debt. His creditors demanded their rights persistently. I went to the Prophet (and informed him about it). He told them to take the fruits of my garden and exempt my father from the debts but they refused to do so. So, the Prophet did not give them my garden and told me that he would come to me the next morning. He came to us early in the morning and wandered among the datepalms and invoked Allah to bless their fruits. I then plucked the dates and paid the creditors, and there remained some of the dates for us.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.581]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 581

Narrated Jabir bin 'Abdullah:

When my father died he owed a Jew thirty Awsuq (of dates). I requested him to give me respite for repaying but he refused. I requested Allah's Apostle to intercede with the Jew. Allah's Apostle went to the Jew and asked him to accept the fruits of my trees in place of the debt but the Jew refused. Allah's Apostle entered the garden of the date-palms, wandering among the trees and ordered me (saying), "Pluck (the fruits) and give him his due." So, I plucked the fruits for him after the departure of Allah's Apostle and gave his thirty Awsuq, and still had seventeen Awsuq extra for myself. Jabir said: I went to Allah's Apostle to inform of what had happened, but found him praying the 'Asr prayer. After the prayer I told him about the extra fruits which remained. Allah's Apostle told me to inform (Umar) Ibn Al-Khatab about it. When I went to 'Umar and told him about it, 'Umar said, "When Allah's Apostle walked in your garden, I was sure that Allah would definitely bless it."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.582]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 582

Narrated 'Aisha:

Allah's Apostle used to invoke Allah in the prayer saying, "O Allah, I seek refuge with you from all sins, and from being in debt." Someone said, O Allah's Apostle! (I see you) very often you seek refuge with Allah from being in debt. He replied, "If a person is in debt, he tells lies when he speaks, and breaks his promises when he promises."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.583]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 583

Narrated Abu Huraira:

The Prophet said, "If someone leaves some property, it will be for the inheritors, and if he leaves some weak offspring, it will be for us to support them."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.584]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 584

Narrated Abu Huraira:

The Prophet said, "I am closer to the believers than their selves in this world and in the Hereafter, and if you like, you can read Allah's Statement: "The Prophet is closer to the believers than their own selves." (33.6) So, if a true believer dies and leaves behind some property, it will be for his inheritors (from the father's side), and if he leaves behind some debt to be paid or needy offspring, then they should come to me as I am the guardian of the deceased."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.585]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 585

Narrated Abu Huraira:

Allah's Apostle said, "Procrastination (delay) in repaying debts by a wealthy person is injustice."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.586]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 586

Narrated Abu Huraira:

A man came to the Prophet and demanded his debts and used harsh words. The companions of the Prophet wanted to harm him, but the Prophet said, "Leave him, as the creditor (owner of the right) has the right to speak."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.587]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 587

Narrated Abu Huraira:

Allah's Apostle said, "If a man finds his very things with a bankrupt, he has more right to take them back than anyone else."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.588]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 588

Narrated Jabir bin 'Abdullah:

A man pledged that his slave would be manumitted after his death. The Prophet asked, "Who will buy the slave from me?" No'aim bin 'Abdullah bought the slave and the Prophet took its price and gave it to the owner.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.589]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 589

Narrated Jabir:

When 'Abdullah (my father) died, he left behind children and debts. I asked the lenders to put down some of his debt, but they refused, so I went to the Prophet to intercede with them, yet they refused. The Prophet said (to me), "Classify your dates into their different kinds: 'Adhq bin Zaid, Lean and 'Ajwa, each kind alone and call all the creditors and wait till I come to you." I did so and the Prophet came and sat beside the dates and started measuring to each his due till he paid them fully, and the amount of dates remained as it was before, as if he had not touched them.

(On another occasion) I took part in one of Ghazawat among with the Prophet and I was riding one of our camels. The camel got tired and was lagging behind the others. The Prophet hit it on its back. He said, "Sell it to me, and you have the right to ride it till Medina.'' When we approached Medina, I took the permission from the Prophet to go to my house, saying, "O Allah's Apostle! I have newly married." The Prophet asked, "Have you married a virgin or a matron (a widow or divorcee)?" I said, "I have married a matron, as 'Abdullah (my father) died and left behind daughters small in their ages, so I married a matron who may teach them and bring them up with good manners." The Prophet then said (to me), "Go to your family." When I went there and told my maternal uncle about the selling of the camel, he admonished me for it. On that I told him about its slowness and exhaustion and about what the Prophet had done to the camel and his hitting it. When the Prophet arrived, I went to him with the camel in the morning and he gave me its price, the camel itself, and my share from the war booty as he gave the other people.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.590]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 590

Narrated Ibn 'Umar:

A man came to the Prophet and said, "I am often betrayed in bargaining." The Prophet advised him, "When you buy something, say (to the seller), 'No deception." The man used to say so afterwards.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.591]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 591

Narrated Al-Mughira bin Shu'ba:

The Prophet said, "Allah has forbidden for you, (1) to be undutiful to your mothers, (2) to bury your daughters alive, (3) to not to pay the rights of the others (e.g. charity, etc.) and (4) to beg of men (begging). And Allah has hated for you (1) vain, useless talk, or that you talk too much about others, (2) to ask too many questions, (in disputed religious matters) and (3) to waste the wealth (by extravagance).


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.592]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 592

Narrated Abdullah bin 'Umar:

I heard Allah's Apostle saying, "Everyone of you is a guardian, and responsible for what is in his custody. The ruler is a guardian of his subjects and responsible for them; a husband is a guardian of his family and is responsible for it; a lady is a guardian of her husband's house and is responsible for it, and a servant is a guardian of his master's property and is responsible for it." I heard that from Allah's Apostle and I think that the Prophet also said, "A man is a guardian of is father's property and is responsible for it, so all of you are guardians and responsible for your wards and things under your care."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.593]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 593

Narrated 'Abdullah:

I heard a man reciting a verse (of the Holy Qur'an) but I had heard the Prophet reciting it differently. So, I caught hold of the man by the hand and took him to Allah's Apostle who said, "Both of you are right." Shu'ba, the sub-narrator said, "I think he said to them, "Don't differ, for the nations before you differed and perished (because of their differences). "


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.594]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 594

Narrated Abu Huraira:

Two persons, a Muslim and a Jew, quarrelled. The Muslim said, "By Him Who gave Muhammad superiority over all the people! The Jew said, "By Him Who gave Moses superiority over all the people!" At that the Muslim raised his hand and slapped the Jew on the face. The Jew went to the Prophet and informed him of what had happened between him and the Muslim. The Prophet sent for the Muslim and asked him about it. The Muslim informed him of the event. The Prophet said, "Do not give me superiority over Moses, for on the Day of Resurrection all the people will fall unconscious and I will be one of them, but I will. be the first to gain consciousness, and will see Moses standing and holding the side of the Throne (of Allah). I will not know whether (Moses) has also fallen unconscious and got up before me, or Allah has exempted him from that stroke."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.595]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 595

Narrated Abu Said Al-Khudri:

While Allah's Apostle was sitting, a Jew came and said, "O Abul Qasim! One of your companions has slapped me on my face." The Prophet asked who that was. He replied that he was one of the Ansar. The Prophet sent for him, and on his arrival, he asked him whether he had beaten the Jew. He (replied in the affirmative and) said, "I heard him taking an oath in the market saying, 'By Him Who gave Moses superiority over all the human beings.' I said, 'O wicked man! (Has Allah given Moses superiority) even over Muhammad I became furious

and slapped him over his face." The Prophet said, "Do not give a prophet superiority over another, for on the Day of Resurrection all the people will fall unconscious and I will be the first to emerge from the earth, and will see Moses standing and holding one of the legs of the Throne. I will not know whether Moses has fallen unconscious or the first unconsciousness was sufficient for him."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.596]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 596

Narrated Anas:

A Jew crushed the head of a girl between two stones. The girl was asked who had crushed her head, and some names were mentioned before her, and when the name of the Jew was mentioned, she nodded agreeing. The Jew was captured and when he confessed, the Prophet ordered that his head be crushed between two stones.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.597]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 597

Narrated Ibn 'Umar:

A man was often cheated in buying. The Prophet said to him, "When you buy something, say (to the seller), No cheating." The man used to say so thenceforward .


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.598]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 598

Narrated Jabir: A man manumitted a slave and he had no other property than that, so the Prophet cancelled the manumission (and sold the slave for him). No'aim bin Al-Nahham bought the slave from him.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.599]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 599

Narrated 'Abdullah bin Mas'ud:

Allah's Apostle said, "Whoever takes a false oath so as to take the property of a Muslim (illegally) will meet Allah while He will be angry with him." Al-Ash'ath said: By Allah, that saying concerned me. I had common land with a Jew, and the Jew later on denied my ownership, so I took him to the Prophet who asked me whether I had a proof of my ownership. When I replied in the negative, the Prophet asked the Jew to take an oath. I said, "O Allah's Apostle! He will take an oath and deprive me of my property." So, Allah revealed the following verse: "Verily! Those who purchase a little gain at the cost of Allah's covenant and their oaths." (3.77)


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.600]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 600

Narrated 'Abdullah bin Ka'b bin Malik:

Ka'b demanded his debt back from Ibn Abi Hadrad in the Mosque and their voices grew louder till Allah's Apostle heard them while he was in his house. He came out to them raising the curtain of his room and addressed Ka'b, "O Ka'b!" Ka'b replied, "Labaik, O Allah's Apostle." (He said to him), "Reduce your debt to one half," gesturing with his hand. Kab said, "I have done so, O Allah's Apostle!" On that the Prophet said to Ibn Abi Hadrad, "Get up and repay the debt, to him."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.601]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 601

Narrated 'Umar bin Al-Khattab:

I heard Hisham bin Hakim bin Hizam reciting Surat-al-Furqan in a way different to that of mine. Allah's Apostle had taught it to me (in a different way). So, I was about to quarrel with him (during the prayer) but I waited till he finished, then I tied his garment round his neck and seized him by it and brought him to Allah's Apostle and said, "I have heard him reciting Surat-al-Furqan in a way different to the way you taught it to me." The Prophet ordered me to release him and asked Hisham to recite it. When he recited it, Allah s Apostle said, "It was revealed in this way." He then asked me to recite it. When I recited it, he said, "It was revealed in this way. The Qur'an has been revealed in seven different ways, so recite it in the way that is easier for you."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.602]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 602

Narrated Abu Huraira:

The Prophet said, "No doubt, I intended to order somebody to pronounce the Iqama of the (compulsory congregational) prayer and then I would go to the houses of those who do not attend the prayer and burn their houses over them."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.603]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 603

Narrated Aisha:

Abu bin Zam'a and Sad bin Abi Waqqas carried the case of their claim of the (ownership) of the son of a slave-qirl of Zam'a before the Prophet. Sad said, "O Allah's Apostle! My brother, before his death, told me that when I would return (to Mecca), I should search for the son of the slave-girl of Zam'a and take him into my custody as he was his son." 'Abu bin Zam'a said, 'the is my brother and the son of the slave-girl of my father, and was born or my father's bed." The Prophet noticed a resemblance between Utba and the boy but he said, "O 'Abu bin Zam'a! You will get this boy, as the son goes to the owner of the bed. You, Sauda, screen yourself from the boy."


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.604]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 604

Narrated Abu Huraira:

Allah's Apostle sent horsemen to Najd and they arrested and brought a man called Thumama bin Uthal, the chief of Yamama, and they fastened him to one of the pillars of the Mosque. When Allah's Apostle came up to him; he asked, "What have you to say, O Thumama?" He replied, "I have good news, O Muhammad!" Abu Huraira narrated the whole narration which ended with the order of the Prophet "Release him!"


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.605]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 605

Narrated Abu Huraira:

The Prophet sent some horsemen to Najd and they arrested and brought a man called Thumama bin Uthal from the tribe of Bani Hanifa, and they fastened him to one of the pillars of the Mosque.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.606]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 606

Narrated 'Abdullah bin Ka'b bin Malik Al-Ansari from Ka'b bin Malik:

That 'Abdullah bin Abi Hadrad Al-Aslami owed him some debt. Ka'b met him and caught hold of him and they started talking and their voices grew loudest. The Prophet passed by them and addressed Ka'b, pointing out to him to reduce the debt to one half. So, Ka'b got one half of the debt and exempted the debtor from the other half.


Bukhari :: Loans, Payment of Loans, Freezing of Property, Bankruptcy :: [3.41.607]

Loans, Payment of Loans, Freezing of Property, Bankruptcy

Bukhari :: Book 3 :: Volume 41 :: Hadith 607

Narrated Khabbab:

I was a blacksmith In the Pre-lslamic period of ignorance, and 'Asi bin Wail owed me some money. I went to him to demand it, but he said to me, "I will not pay you unless you reject faith in Muhammad." I replied, "By Allah, I will never disbelieve Muhammad till Allah let you die and then resurrect you." He said, "Then wait till I die and come to life again, for then I will be given property and offspring and will pay your right." So, thus revelation came: "Have you seen him who disbelieved in Our signs and yet says, 'I will be given property and offspring?' " (19.77)


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.608]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 608

Narrated Ubai bin Ka'b:

I found a purse containing one hundred Diners. So I went to the Prophet (and informed him about it), he said, "Make public announcement about it for one year" I did so, but nobody turned up to claim it, so I again went to the Prophet who said, "Make public announcement for another year." I did, but none turned up to claim it. I went to him for the third time and he said, "Keep the container and the string which is used for its tying and count the money it contains and if its owner comes, give it to him; otherwise, utilize it."

The sub-narrator Salama said, "I met him (Suwaid, another sub-narrator) in Mecca and he said, 'I don't know whether Ubai made the announcement for three years or just one year.' "


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.609]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 609

Narrated Zaid bin Khalid Al-Juhani:

A bedouin went to the Prophet and asked him about picking up a lost thing. The Prophet said, "Make public announcement about it for one year. Remember the description of its container and the string with which it is tied; and if somebody comes and claims it and describes it correctly, (give it to him); otherwise, utilize it." He said, "O Allah's Apostle! What about a lost sheep?" The Prophet said, "It is for you, for your brother (i.e. its owner), or for the wolf." He further asked, "What about a lost camel?" On that the face of the Prophet became red (with anger) and said, "You have nothing to do with it, as it has its feet, its water reserve and can reach places of water and drink, and eat trees."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.610]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 610

Narrated Sulaiman bin Bilal from Yahya:

Yazid Maula Al-Munba'ith heard Zaid bin Khalid al-Juham saying, "The Prophet was asked about Luqata. He said, 'Remember the description of its container and the string it is tied with, and announce it publicly for one year.' " Yazid added, "If nobody claims then the person who has found it can spend it, and it is regarded as a trust entrusted to him." Yahya said, "I do not know whether the last sentences were said by the Prophet or by Yazid." Zaid further said, "The Prophet was asked, 'What about a lost sheep?' The Prophet said, 'Take it, for it is for you or for your brother (i.e. its owner) or for the wolf." Yazid added that it should also be announced publicly. The man then asked the Prophet about a lost camel. The Prophet said, "Leave it, as it has its feet, water container (reservoir), and it will reach a place of water and eat trees till its owner finds it."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.611]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 611

Narrated Zaid bin Khalid:

A man came and asked Allah's Apostle about picking a lost thing. The Prophet said, "Remember the description of its container and the string it is tied with, and make public announcement about it for one year. If the owner shows up, give it to him; otherwise, do whatever you like with it." He then asked, "What about a lost sheep?" The Prophet said, "It is for you, for your brother (i.e. its owner), or for the wolf." He further asked, "What about a lost camel?" The Prophet said, "It is none of your concern. It has its water-container (reservoir) and its feet, and it will reach water and drink it and eat the trees till its owner finds it."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.612]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 612

Narrated Anas:

The Prophet passed a date fallen on the way and said, "Were I not afraid that it may be from a Sadaqa (charitable gifts), I would have eaten it."

Narrated Abu Huraira: The Prophet said, "Sometimes when I return home and find a date fallen on my bed, I pick it up in order to eat it, but I fear that it might be from a Sadaqa, so I throw it."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.613]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 613

Narrated Abu Huraira:

When Allah gave victory to His Apostle over the people of Mecca, Allah's Apostle stood up among the people and after glorifying Allah, said, "Allah has prohibited fighting in Mecca and has given authority to His Apostle and the believers over it, so fighting was illegal for anyone before me, and was made legal for me for a part of a day, and it will not be legal for anyone after me. Its game should not be chased, its thorny bushes should not be uprooted, and picking up its fallen things is not allowed except for one who makes public announcement for it, and he whose relative is murdered has the option either to accept a compensation for it or to retaliate." Al-'Abbas said, "Except Al-ldhkhir, for we use it in our graves and houses." Allah's Apostle said, "Except Al-ldhkhir." Abu Shah, a Yemenite, stood up and said, "O Allah's Apostle! Get it written for me." Allah's Apostle said, "Write it for Abu Shah." (The sub-narrator asked Al-Auza'i): What did he mean by saying, "Get it written, O Allah's Apostle?" He replied, "The speech which he had heard from Allah's Apostle ."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.614]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 614

Narrated Ibn 'Umar:

Allah's Apostle said, "An animal should not be milked without the permission of its owner. Does any of you like that somebody comes to his store and breaks his container and takes away his food? The udders of the animals are the stores of their owners where their provision is kept, so nobody should milk the animals of somebody else, without the permission of its owner."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.615]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 615

Narrated Zaid bin Khalid Al-Juhani:

A man asked Allah's Apostle about the Luqata. He said, "Make public announcement of it for one year, then remember the description of its container and the string it is tied with, utilize the money, and if its owner comes back after that, give it to him." The people asked, "O Allah's Apostle! What about a lost sheep?" Allah's Apostle said, "Take it, for it is for you, for your brother, or for the wolf." The man asked, "O Allah's Apostle! What about a lost camel?" Allah's Apostle got angry and his cheeks or face became red, and said, "You have no concern with it as it has its feet, and its water-container, till its owner finds it."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.616]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 616

Narrated Suwaid bin Ghafala:

While I as in the company of Salman bin Rabi'a and Suhan, in one of the holy battles, I found a whip. One of them told me to drop it but I refused to do so and said that I would give it to its owner if I found him, otherwise I would utilize it. On our return we performed Hajj and on passing by Medina, I asked Ubai bin Ka'b about it. He said, "I found a bag containing a hundred Dinars in the lifetime of the Prophet and took it to the Prophet who said to me, 'Make public announcement about it for one year.' So, I announced it for one year and went to the Prophet who said, 'Announce it publicly for another year.' So, I announced it for another year. I went to him again and he said, "Announce for an other year." So I announced for still another year. I went to the Prophet for the fourth time, and he said, 'Remember the amount of money, the description of its container and the string it is tied with, and if the owner comes, give it to him; otherwise, utilize it.' "


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.617]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 617

Narrated Salama:

the above narration (Hadith 616) from Ubai bin Ka'b: adding, "I met the sub-narrator at Mecca later on, but he did not remember whether Ka'b had announced what he had found one year or three years."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.618]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 618

Narrated Zaid bin Khalid:

A bedouin asked the Prophet about the Luqata. The Prophet said, "Make public announcement about it for one year and if then somebody comes and describes the container of the Luqata and the string it was tied with, (give it to him); otherwise, spend it." He then asked the Prophet about a lost camel. The face of the Prophet become red and he said, "You have o concern with it as it has its water reservoir and feet and it will reach water and drink and eat trees. Leave it till its owner finds it." He then asked the Prophet about a lost sheep. The Prophet said, "It is for you, for your brother, or for the wolf."


Bukhari :: Lost Things Picked up by Someone (Luqaata) :: [3.42.619]

Lost Things Picked up by Someone (Luqaata)

Bukhari :: Book 3 :: Volume 42 :: Hadith 619

Narrated Abu Bakr:

While I was on my way, all of a sudden I saw a shepherd driving his sheep, I asked him whose servant he was. He replied that he was the servant of a man from Quraish, and then he mentioned his name and I recognized him. I asked, "Do your sheep have some milk?" He replied in the affirmative. I said, "Are you going to milk for me?" He replied in the affirmative. I ordered him and he tied the legs of one of the sheep. Then I told him to clean the udder (teats) of dust and to remove dust off his hands. He removed the dust off his hands by clapping his hands. He then milked a little milk. I put the milk for Allah's Apostle in a pot and closed its mouth with a piece of cloth and poured water over it till it became cold. I took it to the Prophet and said, "Drink, O Allah's Apostle!" He drank it till I was pleased.


Bukhari :: Oppressions :: [3.43.620]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 620

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "When the believers pass safely over (the bridge across) Hell, they will be stopped at a bridge in between Hell and Paradise where they will retaliate upon each other for the injustices done among them in the world, and when they get purified of all their sins, they will be admitted into Paradise. By Him in Whose Hands the life of Muhammad is everybody will recognize his dwelling in Paradise better than he recognizes his dwelling in this world."


Bukhari :: Oppressions :: [3.43.621]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 621

Narrated Safwan bin Muhriz Almazini:

While I was walking with Ibn 'Umar holding his hand, a man came in front of us and asked, "What have you heard from Allah's Apostle about An-Najwa?" Ibn 'Umar said, "I heard Allah's Apostle saying, 'Allah will bring a believer near Him and shelter him with His Screen and ask him: Did you commit such-and-such sins? He will say: Yes, my Lord. Allah will keep on asking him till he will confess all his sins and will think that he is ruined. Allah will say: 'I did screen your sins in the world and I forgive them for you today', and then he will be given the book of his good deeds. Regarding infidels and hypocrites (their evil acts will be exposed publicly) and the witnesses will say: These are the people who lied against their Lord. Behold! The Curse of Allah is upon the wrongdoers." (11.18)


Bukhari :: Oppressions :: [3.43.622]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 622

Narrated 'Abdullah bin Umar:

Allah's Apostle said, "A Muslim is a brother of another Muslim, so he should not oppress him, nor should he hand him over to an oppressor. Whoever fulfilled the needs of his brother, Allah will fulfill his needs; whoever brought his (Muslim) brother out of a discomfort, Allah will bring him out of the discomforts of the Day of Resurrection, and whoever screened a Muslim, Allah will screen him on the Day of Resurrection . "


Bukhari :: Oppressions :: [3.43.623]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 623

Narrated Anas bin Malik:

Allah's Apostle said, "Help your brother, whether he is an oppressor or he is an oppressed one."


Bukhari :: Oppressions :: [3.43.624]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 624

Narrated Anas:

Allah's Apostle said, "Help your brother, whether he is an oppressor or he is an oppressed one. People asked, "O Allah's Apostle! It is all right to help him if he is oppressed, but how should we help him if he is an oppressor?" The Prophet said, "By preventing him from oppressing others."


Bukhari :: Oppressions :: [3.43.625]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 625

Narrated Muawiya bin Suwald:

I heard Al-Bara' bin 'Azib saying, "The Prophet orders us to do seven things and prohibited us from doing seven other things." Then Al-Bara' mentioned the following:--

(1) To pay a visit to the sick (inquiring about his health),

(2) to follow funeral processions,

(3) to say to a sneezer, "May Allah be merciful to you" (if he says, "Praise be to Allah!"),

(4) to return greetings,

(5) to help the oppressed,

(6) to accept invitations,

(7) to help others to fulfill their oaths. (See Hadith No. 753, Vol. 7)


Bukhari :: Oppressions :: [3.43.626]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 626

Narrated Abu Musa:

The Prophet said, "A believer to another believer is like a building whose different parts enforce each other." The Prophet then clasped his hands with the fingers interlaced (while saying that).


Bukhari :: Oppressions :: [3.43.627]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 627

Narrated Ibn 'Umar:

The Prophet said, "Oppression will be a darkness on the Day of Resurrection."


Bukhari :: Oppressions :: [3.43.628]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 628

Narrated Ibn 'Abbas:

The Prophet sent Mu'adh to Yemen and said, "Be afraid, from the curse of the oppressed as there is no screen between his invocation and Allah."


Bukhari :: Oppressions :: [3.43.629]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 629

Narrated Abu Huraira:

Allah's Apostle said, "Whoever has oppressed another person concerning his reputation or anything else, he should beg him to forgive him before the Day of Resurrection when there will be no money (to compensate for wrong deeds), but if he has good deeds, those good deeds will be taken from him according to his oppression which he has done, and if he has no good deeds, the sins of the oppressed person will be loaded on him."


Bukhari :: Oppressions :: [3.43.630]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 630

Narrated Aisha:

Regarding the explanation of the following verse:-- "If a wife fears Cruelty or desertion On her husband's part." (4.128) A man may dislike his wife and intend to divorce her, so she says to him, "I give up my rights, so do not divorce me." The above verse was revealed concerning such a case.


Bukhari :: Oppressions :: [3.43.631]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 631

Narrated Sahl bin Sad As-Sa'idi:

A drink (milk mixed with water) was brought to Allah's Apostle who drank some of it. A boy was sitting to his right, and some old men to his left. Allah's Apostle said to the boy, "Do you allow me to give the rest of the drink to these people?" The boy said, "O Allah's Apostle! I will not give preference to anyone over me to drink the rest of it from which you have drunk." Allah's Apostle then handed the bowl (of drink) to the boy. (See Hadith No. 541).


Bukhari :: Oppressions :: [3.43.632]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 632

Narrated Said bin Zaid:

Allah's Apostle said, "Whoever usurps the land of somebody unjustly, his neck will be encircled with it down the seven earths (on the Day of Resurrection). "


Bukhari :: Oppressions :: [3.43.633]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 633

Narrated Abu Salama:

That there was a dispute between him and some people (about a piece of land). When he told 'Aisha about it, she said, "O Abu Salama! Avoid taking the land unjustly, for the Prophet said, 'Whoever usurps even one span of the land of somebody, his neck will be encircled with it down the seven earths."


Bukhari :: Oppressions :: [3.43.634]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 634

Narrated Salim's father (i.e. 'Abdullah):

The Prophet said, "Whoever takes a piece of the land of others unjustly, he will sink down the seven earths on the Day of Resurrection."


Bukhari :: Oppressions :: [3.43.635]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 635

Narrated Jabala:

"We were in Medina with some of the Iraqi people, and we were struck with famine and Ibn Az-Zubair used to give us dates. Ibn 'Umar used to pass by and say, "The Prophet forbade us to eat two dates at a time, unless one takes the permission of one's companions."


Bukhari :: Oppressions :: [3.43.636]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 636

Narrated Abu Mas'ud:

There was an Ansari man called Abu Shu'aib who had a slave butcher. Abu Shu'aib said to him, "Prepare a meal sufficient for five persons so that I might invite the Prophet besides other four persons." Abu Shu'aib had seen the signs of hunger on the face of the Prophet and so he invited him. Another man who was not invited, followed the Prophet. The Prophet said to Abu Shu'aib, "This man has followed us. Do you allow him to share the meal?" Abu Shu'aib said, "Yes."


Bukhari :: Oppressions :: [3.43.637]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 637

Narrated 'Aisha:

The Prophet said, "The most hated person in the sight of Allah is the most quarrelsome person."


Bukhari :: Oppressions :: [3.43.638]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 638

Narrated Um Salama:

(the wife of the Prophet) Allah's Apostle heard some people quarreling at the door of his dwelling. He came out and said, "I am only a human being, and opponents come to me (to settle their problems); maybe someone amongst you can present his case more eloquently than the other, whereby I may consider him true and give a verdict in his favor. So, If I give the right of a Muslim to another by mistake, then it is really a portion of (Hell) Fire, he has the option to take or give up (before the Day of Resurrection)."


Bukhari :: Oppressions :: [3.43.639]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 639

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Whoever has (the following) four characters will be a hypocrite, and whoever has one of the following four characteristics will have one characteristic of hypocrisy until he gives it up. These are: (1 ) Whenever he talks, he tells a lie; (2) whenever he makes a promise, he breaks it; (3) whenever he makes a covenant he proves treacherous; (4) and whenever he quarrels, he behaves impudently in an evil insulting manner." (See Hadith No. 33 Vol. 1)


Bukhari :: Oppressions :: [3.43.640]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 640

Narrated Aisha:

Hind bint 'Utba (Abu Sufyan's wife) came and said, "O Allah's Apostle! Abu Sufyan is a miser. Is there any harm if I spend something from his property for our children?" He said, there is no harm for you if you feed them from it justly and reasonably (with no extravagance)."


Bukhari :: Oppressions :: [3.43.641]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 641

Narrated 'Uqba bin 'Amir:

We staid to the Prophet, "You send us out and it happens that we have to stay with such people as do not entertain us. What do you think about it? He said to us, "If you stay with some people and they entertain you as they should for a guest, accept their hospitality, but If they don't do, take the right of the guest from them."


Bukhari :: Oppressions :: [3.43.642]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 642

Narrated 'Umar:

When Allah took away the soul of His Prophet at his death, the Ansar assembled In the shed of Bani Sa'ida. I said to Abu Bakr, "Let us go." So, we come to them (i.e. to Ansar) at the shed of Bani Sa'ida. (See Hadith No. 19, Vol. 5 for details)


Bukhari :: Oppressions :: [3.43.643]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 643

Narrated Al-Araj:

Abu Huraira said, "Allah's Apostle said, 'No-one should prevent his neighbor from fixing a wooden peg in his wall." Abu Huraira said (to his companions), "Why do I find you averse to it? By Allah, I certainly will narrate it to you."


Bukhari :: Oppressions :: [3.43.644]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 644

Narrated Anas:

I was the butler of the people in the house of Abu Talha, and in those days drinks were prepared from dates. Allah's Apostle ordered somebody to announce that alcoholic drinks had been prohibited. Abu Talha ordered me to go out and spill the wine. I went out and spilled it, and it flowed in the streets of Medina. Some people said, "Some people were killed and wine was still in their stomachs." On that the Divine revelation came:-- "On those who believe And do good deeds There is no blame For what they ate (in the past)." (5.93)


Bukhari :: Oppressions :: [3.43.645]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 645

Narrated Abu Said Al-Khudri:

The Prophet said, "Beware! Avoid sitting on he roads (ways)." The people said, "There is no way out of it as these are our sitting places where we have talks." The Prophet said, "If you must sit there, then observe the rights of the way." They asked, "What are the rights of the way?" He said, "They are the lowering of your gazes (on seeing what is illegal to look at), refraining from harming people, returning greetings, advocating good and forbidding evil."


Bukhari :: Oppressions :: [3.43.646]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 646

Narrated Abu Huraira:

The Prophet said, "A man felt very thirsty while he was on the way, there he came across a well. He went down the well, quenched his thirst and came out. Meanwhile he saw a dog panting and licking mud because of excessive thirst. He said to himself, "This dog is suffering from thirst as I did." So, he went down the well again and filled his shoe with water and watered it. Allah thanked him for that deed and forgave him. The people said, "O Allah's Apostle! Is there a reward for us in serving the animals?" He replied: "Yes, there is a reward for serving any animate (living being)." (See Hadith No. 551)


Bukhari :: Oppressions :: [3.43.647]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 647

Narrated Usama bin Zaid:

Once the Prophet stood at the top of one of the castles (or higher buildings) of Medina and said, "Do you see what I see? No doubt I am seeing the spots of afflictions amongst your houses as numerous as the spots where rain-drops fall (during a heavy rain). (See Hadith No. 102)


Bukhari :: Oppressions :: [3.43.648]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 648

Narrated 'Abdullah bin 'Abbas:

I had been eager to ask 'Umar about the two ladies from among the wives of the Prophet regarding whom Allah said (in the Qur'an saying): If you two (wives of the Prophet namely Aisha and Hafsa) turn in repentance to Allah your hearts are indeed so inclined (to oppose what the Prophet likes) (66.4), till performed the Hajj along with 'Umar (and on our way back from Hajj) he went aside (to answer the call of nature) and I also went aside along with him carrying a tumbler of water. When he had answered the call of nature and returned. I poured water on his hands from the tumbler and he performed ablution. I said, "O Chief of the believers! ' Who were the two ladies from among the wives of the Prophet to whom Allah said:

'If you two return in repentance (66.4)? He said, "I am astonished at your question, O Ibn 'Abbas. They were Aisha and Hafsa."

Then 'Umar went on relating the narration and said. "I and an Ansari neighbor of mine from Bani Umaiya bin Zaid who used to live in 'Awali Al-Medina, used to visit the Prophet in turns. He used to go one day, and I another day. When I went I would bring him the news of what had happened that day regarding the instructions and orders and when he went, he used to do the same for me. We, the people of Quraish, used to have authority over women, but when we came to live with the Ansar, we noticed that the Ansari women had the upper hand over their men, so our women started acquiring the habits of the Ansari women. Once I shouted at my wife and she paid me back in my coin and I disliked that she should answer me back. She said, 'Why do you take it ill that I retort upon you? By Allah, the wives of the Prophet retort upon him, and some of them may not speak with him for the whole day till night.' What she said scared me and I said to her, 'Whoever amongst them does so, will be a great loser.' Then I dressed myself and went to Hafsa and asked her, 'Does any of you keep Allah's Apostle angry all the day long till night?' She replied in the affirmative. I said, 'She is a ruined losing person (and will never have success)! Doesn't she fear that Allah may get angry for the anger of Allah's Apostle and thus she will be ruined? Don't ask Allah's Apostle too many things, and don't retort upon him in any case, and don't desert him. Demand from me whatever you like, and don't be tempted to imitate your neighbor (i.e. 'Aisha) in her behavior towards the Prophet), for she (i.e. Aisha) is more beautiful than you, and more beloved to Allah's Apostle.

In those days it was rumored that Ghassan, (a tribe living in Sham) was getting prepared their horses to invade us. My companion went (to the Prophet on the day of his turn, went and returned to us at night and knocked at my door violently, asking whether I was sleeping. I was scared (by the hard knocking) and came out to him. He said that a great thing had happened. I asked him: What is it? Have Ghassan come? He replied that it was worse and more serious than that, and added that Allah's Apostle had divorced all his wives. I said, Hafsa is a ruined loser! I expected that would happen some day.' So I dressed myself and offered the Fajr prayer with the Prophet. Then the Prophet entered an upper room and stayed there alone. I went to Hafsa and found her weeping. I asked her, 'Why are you weeping? Didn't I warn you? Have Allah's Apostle divorced you all?' She replied, 'I don't know. He is there in the upper room.' I then went out and came to the pulpit and found a group of people around it and some of them were weeping. Then I sat with them for some time, but could not endure the situation. So I went to the upper room where the Prophet was and requested to a black slave of his: "Will you get the permission of (Allah's Apostle) for Umar (to enter)? The slave went in, talked to the Prophet about it and came out saying, 'I mentioned you to him but he did not reply.' So, I went and sat with the people who were sitting by the pulpit, but I could not bear the situation, so I went to the slave again and said: "Will you get he permission for Umar? He went in and brought the same reply as before. When I was leaving, behold, the slave called me saying, "Allah's Apostle has granted you permission." So, I entered upon the Prophet and saw him lying on a mat without wedding on it, and the mat had left its mark on the body of the Prophet, and he was leaning on a leather pillow stuffed with palm fires. I greeted him and while still standing, I said: "Have you divorced your wives?' He raised his eyes to me and replied in the negative. And then while still standing, I said chatting: "Will you heed what I say, 'O Allah's Apostle! We, the people of Quraish used to have the upper hand over our women (wives), and when we came to the people whose women had the upper hand over them..."

'Umar told the whole story (about his wife). "On that the Prophet smiled." 'Umar further said, "I then said, 'I went to Hafsa and said to her: Do not be tempted to imitate your companion ('Aisha) for she is more beautiful than you and more beloved to the Prophet.' The Prophet smiled again. When I saw him smiling, I sat down and cast a glance at the room, and by Allah, I couldn't see anything of importance but three hides. I said (to Allah's Apostle) "Invoke Allah to make your followers prosperous for the Persians and the Byzantines have been made prosperous and given worldly luxuries, though they do not worship Allah?' The Prophet was leaning then (and on hearing my speech he sat straight) and said, 'O Ibn Al-Khatttab! Do you have any doubt (that the Hereafter is better than this world)? These people have been given rewards of their good deeds in this world only.' I asked the Prophet . 'Please ask Allah's forgiveness for me. The Prophet did not go to his wives because of the secret which Hafsa had disclosed to 'Aisha, and he said that he would not go to his wives for one month as he was angry with them when Allah admonished him (for his oath that he would not approach Maria). When twenty-nine days had passed, the Prophet went to Aisha first of all. She said to him, 'You took an oath that you would not come to us for one month, and today only twenty-nine days have passed, as I have been counting them day by day.' The Prophet said, 'The month is also of twenty-nine days.' That month consisted of twenty-nine days. 'Aisha said, 'When the Divine revelation of Choice was revealed, the Prophet started with me, saying to me, 'I am telling you something, but you needn't hurry to give the reply till you can consult your parents." 'Aisha knew that her parents would not advise her to part with the Prophet . The Prophet said that Allah had said:--

'O Prophet! Say To your wives; If you desire The life of this world And its glitter, ... then come! I will make a provision for you and set you free In a handsome manner. But if you seek Allah And His Apostle, and The Home of the Hereafter, then Verily, Allah has prepared For the good-doers amongst you A great reward.' (33.28) 'Aisha said, 'Am I to consult my parents about this? I indeed prefer Allah, His Apostle, and the Home of the Hereafter.' After that the Prophet gave the choice to his other wives and they also gave the same reply as 'Aisha did."


Bukhari :: Oppressions :: [3.43.649]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 649

Narrated Anas:

Allah's Apostle took an oath that he would not go to his wives for one month as his foot had been sprained. He stayed in an upper room when 'Umar went to him and said, "Have you divorced your wives?" He said, "No, but I have taken an oath that I would not go to them for one month." The Prophet stayed there for twenty-nine days, and then came down and went to his wives.


Bukhari :: Oppressions :: [3.43.650]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 650

Narrated Jabir:

The Prophet entered the Mosque, and I too went there after tying the camel at the pavement of the Mosque. I said (to the Prophet ), "This is your camel." He came out and started examining the camel and said, "Both the camel and its price are for you."


Bukhari :: Oppressions :: [3.43.651]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 651

Narrated Hudhaifa:

I saw Allah's Apostle coming (or the Prophet came) to the dumps of some people and urinated there while standing .


Bukhari :: Oppressions :: [3.43.652]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 652

Narrated Abu Huraira:

Allah's Apostle said, "While a man was on the way, he found a thorny branch of a tree there on the way and removed it. Allah thanked him for that deed and forgave him."


Bukhari :: Oppressions :: [3.43.653]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 653

Narrated Abu Huraira:

The Prophet judged that seven cubits should be left as a public way when there was a dispute about the land.


Bukhari :: Oppressions :: [3.43.654]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 654

Narrated 'Abdullah bin Yazid Al-Ansari:

The Prophet forbade robbery (taking away what belongs to others without their permission), and also forbade mutilation (or maiming) of bodies.


Bukhari :: Oppressions :: [3.43.655]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 655

Narrated Abu Huraira:

The Prophet said, "When an adulterer commits illegal sexual intercourse, then he is not a believer at the time, he is doing it, and when a drinker of an alcoholic liquor drinks it, then he is not a believer at the time of drinking it, and when a thief steals, then he is not a believer at the time of stealing, and when a robber robs, and the people look at him, then he is not a believer at the time of doing robbery.


Bukhari :: Oppressions :: [3.43.656]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 656

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established until the son of Mary (i.e. Jesus) descends amongst you as a just ruler, he will break the cross, kill the pigs, and abolish the Jizya tax. Money will be in abundance so that nobody will accept it (as charitable gifts).


Bukhari :: Oppressions :: [3.43.657]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 657

Narrated Salama bin Al-Akwa:

On the day of Khaibar the Prophet saw fires being lighted. He asked, "Why are these fires being lighted?" The people replied that they were cooking the meat of donkeys. He said, "Break the pots and throw away their contents." The people said, "Shall we throw away their contents and wash the pots (rather than break them)?" He said, "Wash them."


Bukhari :: Oppressions :: [3.43.658]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 658

Narrated 'Abdullah bin Masud:

The Prophet entered Mecca and (at that time) there were three hundred-and-sixty idols around the Ka'ba. He started stabbing the idols with a stick he had in his hand and reciting: "Truth (Islam) has come and Falsehood (disbelief) has vanished."


Bukhari :: Oppressions :: [3.43.659]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 659

Narrated Al-Qasim:

Aisha said that she hung a curtain decorated with pictures (of animates) on a cupboard. The Prophet tore that curtain and she turned it into two cushions which remained in the house for the Prophet to sit on.


Bukhari :: Oppressions :: [3.43.660]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 660

Narrated 'Abdullah bin 'Amr bin Al-'As:

I heard the Prophet saying, "Whoever is killed while protecting his property then he is a martyr."


Bukhari :: Oppressions :: [3.43.661]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 661

Narrated Anas:

While the Prophet was with one of his wives, one of the mothers of the believers (i.e. one of his wives) sent a wooden bowl containing food with a servant. The wife (in whose house he was sitting) stroke the bowl with her hand and broke it. The Prophet collected the shattered pieces and put the food back in it and said, "Eat." He kept the servant and the bowl till he had eaten the food. Then the Prophet gave another unbroken. bowl to the servant and kept the broken one.


Bukhari :: Oppressions :: [3.43.662]

Oppressions

Bukhari :: Book 3 :: Volume 43 :: Hadith 662

Narrated Abu Huraira:

Allah's Apostle said, "There was an Israeli man called Juraij, while he was praying, his mother came and called him, but he did not respond to her call. He said (to himself) whether he should continue the prayer or reply to his mother. She came to him the second time and called him and said, "O Allah! Do not let him die until he sees the faces of prostitutes." Juraij used to live in a hermitage. A woman said that she would entice Juraij, so she went to him and presented herself (for an evil act) but he refused. She then went to a shepherd and allowed him to commit an illegal sexual intercourse with her and later she gave birth to a boy. She alleged that the baby was from Juraij. The people went to Juraij and broke down his hermitage, pulled him out of it and abused him. He performed ablution and offered the prayer, then he went to the male (baby) and asked him; "O boy! Who is your father?" The baby replied that his father was the shepherd. The people said that they would build for him a hermitage of gold but Juraij asked them to make it of mud only."


Bukhari :: Partnership :: [3.44.663]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 663

Narrated Jabir bin 'Abdullah:

"Allah's Apostle sent an army towards the east coast and appointed Abu 'Ubaida bin Al-Jarrah as their chief, and the army consisted of three-hundred men including myself. We marched on till we reached a place where our food was about to finish. Abu- 'Ubaida ordered us to collect all the journey food and it was collected. My (our) journey food was dates. Abu 'Ubaida kept on giving us our daily ration in small amounts from it, till it was exhausted. The share of everyone of us used to be one date only." I said, "How could one date benefit you?" Jabir replied, "We came to know its value when even that too finished." Jabir added, "When we reached the sea-shore, we saw a huge fish which was like a small mountain. The army ate from it for eighteen days. Then Abu 'Ubaida ordered that two of its ribs be fixed and they were fixed in the ground. Then he ordered that a she-camel be ridden and it passed under the two ribs (forming an arch) without touching them."


Bukhari :: Partnership :: [3.44.664]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 664

Narrated Salama:

Once the journey food diminished and the people were reduced to poverty. They went to the Prophet and asked his permission to slaughter their camels, and he agreed. 'Umar met them and they told him about it, and he said, "How would you survive after slaughtering your camels?" Then he went to the Prophet and said, "O Allah's Apostle! How would they survive after slaughtering their camels?" Allah's Apostle ordered 'Umar, "Call upon the people to bring what has remained of their food." A leather sheet was spread and al I the journey food was collected and heaped over it. Allah's Apostle stood up and invoked Allah to bless it, and then directed all the people to come with their utensils, and they started taking from it till all of them got what was sufficient for them. Allah's Apostle then said, "I testify that None has the right to be worshipped but Allah, and I am His Apostle. "


Bukhari :: Partnership :: [3.44.665]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 665

Narrated Rafi bin Khadij:

We used to offer the 'Asr prayer with the Prophet and slaughter a camel, the meat of which would be divided in ten parts. We would eat the cooked meat before sunset.


Bukhari :: Partnership :: [3.44.666]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 666

Narrated Abu Musa:

The Prophet said, "When the people of Ash'ari tribe ran short of food during the holy battles, or the food of their families in Medina ran short, they would collect all their remaining food in one sheet and then distribute it among themselves equally by measuring it with a bowl. So, these people are from me, and I am from them."


Bukhari :: Partnership :: [3.44.667]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 667

Narrated Anas:

that Abu Bakr As-Siddiq wrote to him the law of Zakat which was made obligatory by Allah's Apostle. He wrote: 'Partners possessing joint property (sheep) have to pay its Zakat equally.


Bukhari :: Partnership :: [3.44.668]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 668

Narrated 'Abaya bin Rafa'a bin Raft' bin Khadij:

My grandfather said, "We were in the company of the Prophet at Dhul-Hulaifa. The people felt hungry and captured some camels and sheep (as booty). The Prophet was behind the people. They hurried and slaughtered the animals and put their meat in pots and started cooking it. (When the Prophet came) he ordered the pots to be upset and then he distributed the animals (of the booty), regarding ten sheep as equal to one camel. One of the camels fled and the people ran after it till they were exhausted. At that time there were few horses. A man threw an arrow at the camel, and Allah stopped the camel with it. The Prophet said, "Some of these animals are like wild animals, so if you lose control over one of these animals, treat it in this way (i.e. shoot it with an arrow)." Before distributing them among the soldiers my grandfather said, "We may meet the enemies in the future and have no knives; can we slaughter the animals with reeds?" The Prophet said, "Use whatever causes blood to flow, and eat the animals if the name of Allah has been mentioned on slaughtering them. Do not slaughter with teeth or fingernails and I will tell you why: It is because teeth are bones (i.e. cannot cut properly) and fingernails are the tools used by the Ethiopians (whom we should not imitate for they are infidels)."


Bukhari :: Partnership :: [3.44.669]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 669

Narrated Ibn 'Umar:

The Prophet decreed that one should not eat two dates together at a time unless he gets the permission from his companions (sharing the meal with him).


Bukhari :: Partnership :: [3.44.670]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 670

Narrated Jabala:

"While at Medina we were struck with famine. Ibn Az-Zubair used to provide us with dates as our food. Ibn 'Umar used to pass by us and say, "Don't eat two dates together at a time as the Prophet has forbidden eating two dates together at a time (in a gathering) unless one takes the permission of one's companion brother."


Bukhari :: Partnership :: [3.44.671]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 671

Narrated Nafi:

Ibn 'Umar said, "Allah's Apostle said, 'If one manumits his share of a jointly possessed slave, and can afford the price of the other shares according to the adequate price of the slave, the slave will be completely manumitted; otherwise he will be partially manumitted.' " (Aiyub, a sub-narrator is not sure whether the saying " ... otherwise he will be partially manumitted" was said by Nafi' or the Prophet.)


Bukhari :: Partnership :: [3.44.672]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 672

Narrated Abu Huraira:

The Prophet said, "Whoever manumits his share of a jointly possessed slave, it is imperative for him to get that slave manumitted completely by paying the remaining price, and if he does not have sufficient money to manumit him, then the price of the slave should be estimated justly, and he is to be allowed to work and earn the amount that will manumit him (without overburdening him)".


Bukhari :: Partnership :: [3.44.673]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 673

Narrated An-Nu'man bin Bashir:

The Prophet said, "The example of the person abiding by Allah's order and restrictions in comparison to those who violate them is like the example of those persons who drew lots for their seats in a boat. Some of them got seats in the upper part, and the others in the lower. When the latter needed water, they had to go up to bring water (and that troubled the others), so they said, 'Let us make a hole in our share of the ship (and get water) saving those who are above us from troubling them. So, if the people in the upper part left the others do what they had suggested, all the people of the ship would be destroyed, but if they prevented them, both parties would be safe."


Bukhari :: Partnership :: [3.44.674]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 674

Narrated 'Urwa bin Az-Zubair:

That he had asked 'Aisha about the meaning of the Statement of Allah: "If you fear that you shall not Be able to deal justly With the orphan girls, then Marry (Other) women of your choice Two or three or four." (4.3)

She said, "O my nephew! This is about the orphan girl who lives with her guardian and shares his property. Her wealth and beauty may tempt him to marry her without giving her an adequate Mahr (bridal-money) which might have been given by another suitor. So, such guardians were forbidden to marry such orphan girls unless they treated them justly and gave them the most suitable Mahr; otherwise they were ordered to marry any other woman." 'Aisha further said, "After that verse the people again asked the Prophet (about the marriage with orphan 'girls), so Allah revealed the following verses:-- 'They ask your instruction Concerning the women. Say: Allah Instructs you about them And about what is Recited unto you In the Book, concerning The orphan girls to whom You give not the prescribed portions and yet whom you Desire to marry..." (4.127)

What is meant by Allah's Saying:-- 'And about what is Recited unto you is the former verse which goes:-- 'If you fear that you shall not Be able to deal justly With the orphan girls, then Marry (other) women of your choice.' (4.3) 'Aisha said, "Allah's saying in the other verse:--'Yet whom you desire to marry' (4.127) means the desire of the guardian to marry an orphan girl under his supervision when she has not much property or beauty (in which case he should treat her justly). The guardians were forbidden to marry their orphan girls possessing property and beauty without being just to them, as they generally refrain from marrying them (when they are neither beautiful nor wealthy)."


Bukhari :: Partnership :: [3.44.675]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 675

Narrated Jabir bin 'Abdullah:

The Prophet established the right of Shu'fa (i.e. Pre-emption) in joint properties; but when the land is divided and the ways are demarcated, then there is no pre-emption.


Bukhari :: Partnership :: [3.44.676]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 676

Narrated Jabir bin 'Abdullah:

The Prophet said, "The right of pre-emption is valid in every joint property, but when the land is divided and the way is demarcated, then there is no right of pre-emption."


Bukhari :: Partnership :: [3.44.677]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 677

Narrated Sulaiman bin Abu Muslim:

I asked Abu Minhal about money exchange from hand to hand. He said, "I and a partner of mine bought something partly in cash and partly on credit." Al-Bara' bin 'Azib passed by us and we asked about it. He replied, "I and my partner Zaid bin Al-Arqam did the same and then went to the Prophet and asked him about it. He said, 'Take what was from hand to hand and leave what was on credit.' "


Bukhari :: Partnership :: [3.44.678]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 678

Narrated Abdullah:

Allah's Apostle rented the land of Khaibar to the Jews on the condition that they would work on it and cultivate it and take half of its yield.


Bukhari :: Partnership :: [3.44.679]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 679

Narrated 'Uqba bin 'Amir:

that Allah's Apostle gave him some sheep to distribute among his companions in order to sacrifice them and a kid was left. He told the Prophet about it and the Prophet said to him, "Sacrifice it on your behalf."


Bukhari :: Partnership :: [3.44.680]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 680

Narrated 'Abdullah bin Hisham:

that his mother Zainab bint Humaid took him to the Prophet and said, "O Allah's Apostle! Take the pledge of allegiance from him." But he said, "He is still too young for the pledge," and passed his hand on his (i.e. 'Abdullah's) head and invoked for Allah's blessing for him. Zuhra bin Ma'bad stated that he used to go with his grandfather, 'Abdullah bin Hisham, to the market to buy foodstuff. Ibn 'Umar and Ibn Az-Zubair would meet him and say to him, "Be our partner, as the Prophet invoked Allah to bless you." So, he would be their partner, and very often he would win a camel's load and send it home.


Bukhari :: Partnership :: [3.44.681]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 681

Narrated Ibn 'Umar:

The Prophet said, "Whoever manumits his share o a jointly possessed slave, it is imperative on him to manumit the slave completely if he has sufficient money to pay the rest of its price which is to be estimated justly. He should pay his partners their shares and release him (the freed one).


Bukhari :: Partnership :: [3.44.682]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 682

Narrated Abu Huraira:

The Prophet said, "Whoever manumits his share of a jointly possessed slave, it is essential for him to manumit the slave completely if he has sufficient money. Otherwise he should look for some work for the slave (to earn what would enable him to emancipate himself), without overburdening him with work."


Bukhari :: Partnership :: [3.44.683]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 683

Narrated Ibn 'Abbas:

The Prophet (along with his companions) reached Mecca in the morning of the fourth of Dhul-Hijja assuming Ihram for Hajj only. So when we arrived at Mecca, the Prophet ordered us to change our intentions of the Ihram for'Umra and that we could finish our Ihram after performing the 'Umra and could go to our wives (for sexual intercourse). The people began talking about that. Jabir said surprisingly, "Shall we go to Mina while semen is dribbling from our male organs?" Jabir moved his hand while saying so. When this news reached the Prophet he delivered a sermon and said, "I have been informed that some peoples were saying so and so; By Allah I fear Allah more than you do, and am more obedient to Him than you. If I had known what I know now, I would not have brought the Hadi (sacrifice) with me and had the Hadi not been with me, I would have finished the Ihram." At that Suraqa bin Malik stood up and asked "O Allah's Apostle! Is this permission for us only or is it forever?" The Prophet replied, "It is forever." In the meantime 'Ali bin Abu Talib came from Yemen and was saying Labbaik for what the Prophet has intended. (According to another man, 'Ali was saying Labbaik for Hajj similar to Allah's Apostle's). The Prophet told him to keep on the Ihram and let him share the Hadi with him.


Bukhari :: Partnership :: [3.44.684]

Partnership

Bukhari :: Book 3 :: Volume 44 :: Hadith 684

Narrated Abaya bin Rifaa:

My grandfather, Rafi bin Khadij said, "We were in the valley of Dhul-Hulaifa of Tuhama in the company of the Prophet and had some camels and sheep (of the booty). The people hurried (in slaughtering the animals) and put their meat in the pots and started cooking. Allah's Apostle came and ordered them to upset the pots, and distributed the booty considering one camel as equal to ten sheep. One of the camels fled and the people had only a few horses, so they got worried. (The camel was chased and) a man slopped the camel by throwing an arrow at it. Allah's Apostle said, 'Some of these animals are untamed like wild animals, so if anyone of them went out of your control, then you should treat it as you have done now.' " My grandfather said, "O Allah's Apostle! We fear that we may meet our enemy tomorrow and we have no knives, could we slaughter the animals with reeds?" The Prophet said, "Yes, or you can use what would make blood flow (slaughter) and you can eat what is slaughtered and the Name of Allah is mentioned at the time of slaughtering. But don't use teeth or fingernails (in slaughtering). I will tell you why, as for teeth, they are bones, and fingernails are used by Ethiopians for slaughtering. (See Hadith 668)


Bukhari :: Mortgaging :: [3.45.685]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 685

Narrated Anas:

No doubt, the Prophet mortgaged his armor for barley grams. Once I took barley bread with some dissolved fat on it to the Prophet and I heard him saying, "The household of Muhammad did not possess except a Sa (of food grain, barley, etc.) for both the morning and the evening meals although they were nine houses."


Bukhari :: Mortgaging :: [3.45.686]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 686

Narrated 'Aisha:

The Prophet bought some foodstuff on credit for a limited period and mortgaged his armor for it.


Bukhari :: Mortgaging :: [3.45.687]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 687

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "Who would kill Ka'b bin Al-Ashraf as he has harmed Allah and His Apostle ?" Muhammad bin Maslama (got up and) said, "I will kill him." So, Muhammad bin Maslama went to Ka'b and said, "I want a loan of one or two Wasqs of food grains." Ka'b said, "Mortgage your women to me." Muhammad bin Maslama said, "How can we mortgage our women, and you are the most handsome among the Arabs?" He said, "Then mortgage your sons to me." Muhammad said, "How can we mortgage our sons, as the people will abuse them for being mortgaged for one or two Wasqs of food grains? It is shameful for us. But we will mortgage our arms to you." So, Muhammad bin Maslama promised him that he would come to him next time. They (Muhammad bin Maslama and his companions came to him as promised and murdered him. Then they went to the Prophet and told him about it.


Bukhari :: Mortgaging :: [3.45.688]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 688

Narrated Abu Huraira:

The Prophet said, "One can ride the mortgaged animal because of what one spends on it, and one can drink the milk of a milch animal as long as it is mortgaged. "


Bukhari :: Mortgaging :: [3.45.689]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 689

Narrated Abu Huraira:

Allah's Apostle said, "The mortgaged animal can be used for riding as long as it is fed and the milk of the milch animal can be drunk according to what one spend on it. The one who rides the animal or drinks its milk should provide the expenditures."


Bukhari :: Mortgaging :: [3.45.690]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 690

Narrated 'Aisha:

Allah's Apostle bought some foodstuff from a Jew and mortgaged his armor to him.


Bukhari :: Mortgaging :: [3.45.691]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 691

Narrated Ibn Abu Mulaika:

I wrote a letter to Ibn 'Abbas and he wrote to me that the Prophet had given the verdict that the defendant had to take an oath.


Bukhari :: Mortgaging :: [3.45.692]

Mortgaging

Bukhari :: Book 3 :: Volume 45 :: Hadith 692

Narrated Abu Wail:

Abdullah (bin Mas'ud) said, "Whoever took a false oath in order to grab somebody's property will meet Allah while Allah will be angry with him." Allah revealed the following verse to confirm that:--"Verily! Those who purchase a small gain at the cost of Allah's covenant And their oaths...a painful torment." (3.77)

Al-Ash'ath bin Qais came to us and asked as to what Abu Abdur-Rehman (i.e. Ibn Mas'ud) was telling you." We related the story to him. On that he said, "He has told the truth. This verse was revealed about me. I had some dispute with another man regarding a well and we took the case before Allah's Apostle. Allah's Apostle said (to me), "Produce two witnesses (to support your claim); otherwise the defendant has the right to take an oath (to refute your claim).' I said, 'The defendant would not mind to take a false oath." Allah's Apostle then said, 'Whoever took a false oath in order to grab someone else's property will meet Allah, Allah will be angry with him.' Allah then revealed what Confirmed it." Al-Ash'ath then recited the following Verse:--"Verily! Those who purchase a small gain at the cost of Allah's covenant, And their oaths . . . (to) . . . they shall have a painful torment!' (3.77) (See Hadith No. 546)


Bukhari :: Manumission of Slaves :: [3.46.693]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 693

Narrated Abu Huraira:

The Prophet said, "Whoever frees a Muslim slave, Allah will save all the parts of his body from the (Hell) Fire as he has freed the body-parts of the slave." Said bin Marjana said that he narrated that Hadith to 'Ali bin Al-Husain and he freed his slave for whom 'Abdullah bin Ja'far had offered him ten thousand Dirhams or one-thousand Dinars.


Bukhari :: Manumission of Slaves :: [3.46.694]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 694

Narrated Abu Dhar:

I asked the Prophet, "What is the best deed?" He replied, "To believe in Allah and to fight for His Cause." I then asked, "What is the best kind of manumission (of slaves)?" He replied, "The manumission of the most expensive slave and the most beloved by his master." I said, "If I cannot afford to do that?" He said, "Help the weak or do good for a person who cannot work for himself." I said, "If I cannot do that?" He said, "Refrain from harming others for this will be regarded as a charitable deed for your own good."


Bukhari :: Manumission of Slaves :: [3.46.695]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 695

Narrated Asma' bint Abu Bakr:

The Prophet ordered us to free slaves at the time of solar eclipses.


Bukhari :: Manumission of Slaves :: [3.46.696]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 696

Narrated Asma' bint Abu Bakr:

We were ordered to free slaves at the time of lunar eclipses.


Bukhari :: Manumission of Slaves :: [3.46.697]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 697

Narrated Ibn 'Umar:

The Prophet said, "Whoever manumits a slave owned by two masters, should manumit him completely (not partially) if he is rich after having its price evaluated."


Bukhari :: Manumission of Slaves :: [3.46.698]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 698

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Whoever frees his share of a common slave and he has sufficient money to free him completely, should let its price be estimated by a just man and give his partners the price of their shares and manumit the slave; otherwise (i.e. if he has not sufficient money) he manumits the slave partially."


Bukhari :: Manumission of Slaves :: [3.46.699]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 699

Narrated Ibn 'Umar:

Allah's Apostle said, "Whoever manumits his share of a slave, then it is essential for him to get that slave manumitted' completely as long as he has the money to do so. If he has not sufficient money to pay the price of the other shares (after the price of the slave is evaluated justly), the manumitted manumits the slave partially in proportion to his share.


Bukhari :: Manumission of Slaves :: [3.46.700]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 700

Narrated 'Ubaidullah:

as above BRIEFLY.


Bukhari :: Manumission of Slaves :: [3.46.701]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 701

Narrated Ibn 'Umar:

The Prophet said, "He who manumits his share of a slave and has money sufficient to free the remaining portion of that slave's price (justly estimated) then he should manumit him (by giving the rest of his price to the other co-owners)." Nafi' added, "Otherwise the slave is partially free." Aiyub is not sure whether the last statement was said by Nafi' or it was a part of the Hadith.


Bukhari :: Manumission of Slaves :: [3.46.702]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 702

Narrated Ibn 'Umar:

That he used to give his verdict regarding the male or female slaves owned by more than one master, one of whom may manumit his share of the slave. Ibn 'Umar used to say in such a case, "The manumitted should manumit the slave completely if he has sufficient money to pay the rest of the price of that slave (which is to be justly estimated) and the other share-holders are to take the price of their shares and the slave is freed (released from slavery)." Ibn 'Umar narrated this verdict from the Prophet.


Bukhari :: Manumission of Slaves :: [3.46.703]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 703

Narrated Abu Huraira:

that the Prophet said, "Whoever frees his portion of a (common) slave."


Bukhari :: Manumission of Slaves :: [3.46.704]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 704

Narrated Abu Huraira:

The Prophet said, "Whoever frees his portion of a common slave should free the slave completely by paying the rest of his price from his money if he has enough money; otherwise the price of the slave is to be estimated and the slave is to be helped to work without hardship till he pays the rest of his price."


Bukhari :: Manumission of Slaves :: [3.46.705]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 705

Narrated Abu Huraira:

The Prophet said, "Allah has accepted my invocation to forgive what whispers in the hearts of my followers, unless they put it to action or utter it." (See Hadith No. 657 Vol. 8)


Bukhari :: Manumission of Slaves :: [3.46.706]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 706

Narrated 'Umar bin Al-Khattab:

The Prophet said, "The (reward of) deeds depend on intentions, and every person will get the reward according to what he intends. So, whoever migrated for Allah and His Apostle, then his migration will be for Allah and His Apostle, and whoever migrated for worldly benefits or for marrying a woman, then his migration will be for what he migrated for." (See Hadith No. 1, Vol. 1)


Bukhari :: Manumission of Slaves :: [3.46.707]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 707

Narrated Qais:

When Abu Huraira accompanied by his slave set out intending to embrace Islam they lost each other on the way. The slave then came while Abu Huraira was sitting with the Prophet. The Prophet said, "O Abu Huraira! Your slave has come back." Abu Huraira said, "Indeed, I would like you to witness that I have manumitted him." That happened at the time when Abu Huraira recited (the following poetic verse):-- 'What a long tedious tiresome night! Nevertheless, it has delivered us From the land of Kufr (disbelief).


Bukhari :: Manumission of Slaves :: [3.46.708]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 708

Narrated Abu Huraira:

On my way to the Prophet I was reciting:-- 'What a long tedious tiresome night! Nevertheless, it has saved us From the land of Kufr (disbelief).' I had a slave who ran away from me on the way. When I went to the Prophet and gave the pledge of allegiance for embracing Islam, the slave showed up while I was still with the Prophet who remarked, "O Abu Huraira! Here is your slave!" I said, "I manumit him for Allah's Sake," and so I freed him.


Bukhari :: Manumission of Slaves :: [3.46.709]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 709

Narrated Qais:

When Abu Huraira accompanied by his slave came intending to embrace Islam, they lost each other on the way. (When the slave showed up) Abu Huraira said (to the Prophet), "I make you witness that the slave is free for Allah's Cause."


Bukhari :: Manumission of Slaves :: [3.46.710]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 710

Narrated 'Aisha:

Utba bin Abi Waqqas authorized his brother Sad bin Abi Waqqas to take the son of the slave-girl of Zam'a into his custody, telling him that the boy was his own (illegal) son. When Allah's Apostle went (to Mecca) at the time of the Conquest, Sad took the son of the slavegirl of Zam'a to Allah's Apostle and also brought 'Abu bin Zam'a with him and said, "O Allah's Apostle! This is the son of my brother 'Utba who authorized me to take him into my custody." 'Abu bin Zam'a said, "O Allah's Apostle! He is my brother, the son of Zam'a' slave-girl and he was born on his bed." Allah's Apostle looked at the son of the slave-girl of Zam'a and noticed much resemblance (to 'Utba). Allah's Apostle said, "It is for you, O 'Abu bin Zam'a as he was born on the bed of your father." Allah's Apostle then told Sauda bint Zam'a to observe veil in the presence of the boy as he noticed the boy's resemblance to 'Utba and Sauda was the wife of the Prophet .


Bukhari :: Manumission of Slaves :: [3.46.711]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 711

Narrated Jabir bin 'Abdullah:

A man amongst us declared that his slave would be freed after his death. The Prophet called for that slave and sold him. The slave died the same year.


Bukhari :: Manumission of Slaves :: [3.46.712]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 712

Narrated Ibn 'Umar:

Allah's Apostle forbade the selling or donating the Wala' of a freed slave.


Bukhari :: Manumission of Slaves :: [3.46.713]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 713

Narrated 'Aisha:

I bought Buraira but her masters put the condition that her Wala' would be for them. I told the Prophet about it. He said (to me), "Manumit her as her Wala' will be for the one who pays the price." So, I manumitted her. The Prophet called Buraira and gave her the option of either staying with her husband or leaving him. She said, "Even if he gave me so much money, I would not stay with him," and so she preferred her freedom to her husband.


Bukhari :: Manumission of Slaves :: [3.46.714]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 714

Narrated Anas:

Some men of the Ansar asked for the permission of Allah's Apostle and said, "Allow us to give up the ransom from our nephew Al-'Abbas. The Prophet said (to them), "Do not leave (even) a Dirham (of his ransom)."


Bukhari :: Manumission of Slaves :: [3.46.715]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 715

Narrated Hisham:

My father told me that Hakim bin Hizam manumitted one-hundred slaves in the pre-lslamic period of ignorance and slaughtered one-hundred camels (and distributed them in charity). When he embraced Islam he again slaughtered one-hundred camels and manumitted one-hundred slaves. Hakim said, "I asked Allah's Apostle, 'O Allah's Apostle! What do you think about some good deeds I used to practice in the prelslamic period of ignorance regarding them as deeds of righteousness?' Allah's Apostle said, "You have embraced Islam along with all those good deeds you did."


Bukhari :: Manumission of Slaves :: [3.46.716]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 716

Narrated Marwan and Al-Miswar bin Makhrama:

When the delegates of the tribe of Hawazin came to the Prophet and they requested him to return their properties and captives. The Prophet stood up and said to them, "I have other people with me in this matter (as you see) and the most beloved statement to me is the true one; you may choose either the properties or the prisoners as I have delayed their distribution." The Prophet had waited for them for more than ten days since his arrival from Ta'if. So, when it became evident to them that the Prophet was not going to return them except one of the two, they said, "We choose our prisoners." The Prophet got up amongst the people and glorified and praised Allah as He deserved and said, "Then after, these brethren of yours have come to us with repentance, and I see it logical to return them the captives. So, whoever amongst you likes to do that as a favor, then he can do it, and whoever of you likes to stick to his share till we recompense him from the very first war booty which Allah will give us, then he can do so (i.e. give up the present captives)." The people unanimously said, "We do that (return the captives) willingly." The Prophet said, "We do not know which of you has agreed to it and which have not, so go back and let your leaders forward us your decision." So, all the people then went back and discussed the matter with their leaders who returned and informed the Prophet that all the people had willingly given their consent to return the captives. This is what has reached us about the captives of Hawazin. Narrated Anas that 'Abbas said to the Prophet, "I paid for my ransom and Aqil's ransom."


Bukhari :: Manumission of Slaves :: [3.46.717]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 717

Narrated Ibn Aun:

I wrote a letter to Nafi and Nafi wrote in reply to my letter that the Prophet had suddenly attacked Bani Mustaliq without warning while they were heedless and their cattle were being watered at the places of water. Their fighting men were killed and their women and children were taken as captives; the Prophet got Juwairiya on that day. Nafi said that Ibn 'Umar had told him the above narration and that Ibn 'Umar was in that army.


Bukhari :: Manumission of Slaves :: [3.46.718]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 718

Narrated Ibn Muhairiz:

I saw Abu Said and asked him about coitus interruptus. Abu Said said, "We went with Allah's Apostle, in the Ghazwa of Barli Al-Mustaliq and we captured some of the 'Arabs as captives, and the long separation from our wives was pressing us hard and we wanted to practice coitus interruptus. We asked Allah's Apostle (whether it was permissible). He said, "It is better for you not to do so. No soul, (that which Allah has) destined to exist, up to the Day of Resurrection, but will definitely come, into existence."


Bukhari :: Manumission of Slaves :: [3.46.719]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 719

Narrated Abu Huraira:

I have loved the people of the tribe of Bani Tamim ever since I heard, three things, Allah's Apostle said about them. I heard him saying, These people (of the tribe of Bani Tamim) would stand firm against Ad-Dajjal." When the Sadaqat (gifts of charity) from that tribe came, Allah's Apostle said, "These are the Sadaqat (i.e. charitable gifts) of our folk." 'Aisha had a slave-girl from that tribe, and the Prophet said to 'Aisha, "Manumit her as she is a descendant of Ishmael (the Prophet)."


Bukhari :: Manumission of Slaves :: [3.46.720]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 720

Narrated Abu Musa:

Allah's Apostle said, "He who has a slave-girl and educates and treats her nicely and then manumits and marries her, will get a double reward."


Bukhari :: Manumission of Slaves :: [3.46.721]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 721

Narrated Al-Ma'rur bin Suwaid:

I saw Abu Dhar Al-Ghifari wearing a cloak, and his slave, too, was wearing a cloak. We asked him about that (i.e. how both were wearing similar cloaks). He replied, "Once I abused a man and he complained of me to the Prophet . The Prophet asked me, 'Did you abuse him by slighting his mother?' He added, 'Your slaves are your brethren upon whom Allah has given you authority. So, if one has one's brethren under one's control, one should feed them with the like of what one eats and clothe them with the like of what one wears. You should not overburden them with what they cannot bear, and if you do so, help them (in their hard job)."


Bukhari :: Manumission of Slaves :: [3.46.722]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 722

Narrated Ibn 'Umar:

Allah's Apostle said, "If a slave is honest and faithful to his master and worships his Lord (Allah) in a perfect manner, he will get a double reward."


Bukhari :: Manumission of Slaves :: [3.46.723]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 723

Narrated Abu Musa Al-Ashari:

The Prophet said, "He who has a slave-girl and teaches her good manners and improves her education and then manumits and marries her, will get a double reward; and any slave who observes Allah's right and his master's right will get a double reward."


Bukhari :: Manumission of Slaves :: [3.46.724]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 724

Narrated Abu Huraira:

Allah's Apostle said, "A pious slave gets a double reward." Abu Huraira added: By Him in Whose Hands my soul is but for Jihad (i.e. holy battles), Hajj, and my duty to serve my mother, I would have loved to die as a slave.


Bukhari :: Manumission of Slaves :: [3.46.725]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 725

Narrated Abu Huraira:

The Prophet said, "Goodness and comfort are for him who worships his Lord in a perfect manner and serves his master sincerely."


Bukhari :: Manumission of Slaves :: [3.46.726]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 726

Narrated 'Abdullah:

The Prophet said, "If a slave serves his Saiyid (i.e. master) sincerely and worships his Lord (Allah) perfectly, he will get a double reward."


Bukhari :: Manumission of Slaves :: [3.46.727]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 727

Narrated Abu Musa:

The Prophet said, "The Mamluk (slave) who worships his Lord in a perfect manner, and is dutiful, sincere and obedient to his Saiyid (master), will get a double reward."


Bukhari :: Manumission of Slaves :: [3.46.728]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 728

Narrated Abu Huraira:

The Prophet said, "You should not say, 'Feed your lord (Rabbaka), help your lord in performing ablution, or give water to your lord, but should say, 'my master (e.g. Feed your master instead of lord etc.) (Saiyidi), or my guardian (Maulai), and one should not say, my slave (Abdi), or my girl-slave (Amati), but should say, my lad (Fatai), my lass (Fatati), and 'my boy (Ghulami)."


Bukhari :: Manumission of Slaves :: [3.46.729]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 729

Narrated Ibn 'Umar:

The Prophet said, "If one manumits his share of a common slave (Abd), and he has money sufficient to free the remaining portion of the price of the slave (justly estimated), then he should free the slave completely by paying the rest of his price; otherwise the slave is freed partly. "


Bukhari :: Manumission of Slaves :: [3.46.730]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 730

Narrated 'Abdullah:

Allah's Apostle said, "Everyone of you is a guardian and is responsible for his charges. The ruler who has authority over people, is a guardian and is responsible for them, a man is a guardian of his family and is responsible for them; a woman is a guardian of her husband's house and children and is responsible for them; a slave ('Abu) is a guardian of his master's property and is responsible for it; so all of you are guardians and are responsible for your charges."


Bukhari :: Manumission of Slaves :: [3.46.731]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 731

Narrated Abu Huraira and Zaid bin Khalid:

The Prophet said, "If a slave-girl (Ama) commits illegal sexual intercourse, scourge her; if she does it again, scourge her again; if she repeats it, scourge her again." The narrator added that on the third or the fourth offence, the Prophet said, "Sell her even for a hair rope."


Bukhari :: Manumission of Slaves :: [3.46.732]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 732

Narrated Abu Huraira:

The Prophet said, "When your servant brings your meals to you then if he does not let him sit and share the meals, then he should at least give him a mouthful or two mouthfuls of that meal or a meal or two meals, as he has prepared it."


Bukhari :: Manumission of Slaves :: [3.46.733]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 733

Narrated 'Abdullah bin 'Umar:

That he heard Allah's Apostle saying, "Everyone of you is a guardian and is responsible for his charge; the ruler is a guardian and is responsible for his subjects; the man is a guardian in his family and responsible for his charges; a woman is a guardian of her husband's house and responsible for her charges; and the servant is a guardian of his master's property and is responsible for his charge." I definitely heard the above from the Prophet and think that the Prophet also said, "A man is a guardian of his father's property and responsible for his charges; so everyone of you is a guardian and responsible for his charges."


Bukhari :: Manumission of Slaves :: [3.46.734]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 734

Narrated Abu Huraira:

The Prophet said, "If somebody fights (or beats somebody) then he should avoid the face."


Bukhari :: Manumission of Slaves :: [3.46.735]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 735

Narrated 'Urwa:

That 'Aisha told him that Buraira came to seek her help in her writing of emancipation (for a certain sum) and that time she had not paid anything of it. 'Aisha said to her, "Go back to your masters, and if they agree that I will pay the amount of your writing of emancipation and get your Wala', I will do so." Buraira informed her masters of that but they refused and said, "If she (i.e. 'Aisha) is seeking Allah's reward, then she can do so, but your Wala' will be for us." 'Aisha mentioned that to Allah's Apostle who said to her, "Buy and manumit her, as the Wala' is for the liberator." Allah's Apostle then got up and said, "What about the people who stipulate conditions which are not present in Allah's Laws? Whoever imposes conditions which are not present in Allah's Laws, then those conditions will be invalid, even if he imposed these conditions a hundred times. Allah's conditions (Laws) are the truth and are more solid."


Bukhari :: Manumission of Slaves :: [3.46.736]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 736

Narrated 'Abdullah bin 'Umar:

Aisha wanted to buy a slave-girl in order to manumit her. The girl's masters stipulated that her Wala' would be for them. Allah's Apostle said (to 'Aisha), "What they stipulate should not stop you, for the Wala' is for the liberator."


Bukhari :: Manumission of Slaves :: [3.46.737]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 737

Narrated Aisha:

Buraira came (to 'Aisha) and said, "I have made a contract of emancipation with my masters for nine Uqiyas (of gold) to be paid in yearly installments. Therefore, I seek your help." 'Aisha said, "If your masters agree, I will pay them the sum at once and free you on condition that your Wala' will be for me." Buraira went to her masters but they refused that offer. She (came back) and said, "I presented to them the offer but they refused, unless the Wala' was for them." Allah's Apostle heard of that and asked me about it, and I told him about it. On that he said, "Buy and manumit her and stipulate that the Wala' should be for you, as Wala' is for the liberator." 'Aisha added, "Allah's Apostle then got up amongst the people, Glorified and Praised Allah, and said, 'Then after: What about some people who impose conditions which are not present in Allah's Laws? So, any condition which is not present in Allah's Laws is invalid even if they were one-hundred conditions. Allah's ordinance is the truth, and Allah's condition is stronger and more solid. Why do some men from you say, O so-and-so! manumit the slave but the Wala will be for me? Verily, the Wala is for the liberator."


Bukhari :: Manumission of Slaves :: [3.46.738]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 738

Narrated Amra bint 'AbdurRahman:

Buraira went to Aisha, the mother of the faithful believers to seek her help in her emancipation Aisha said to her, "If your masters agree, I will pay them your price in a lump sum and manumit you." Buraira mentioned that offer to her masters but they refused to sell her unless the Wala' was for them. 'Aisha told Allah's Apostle about it. He said, "Buy and manumit her as the Wala' is for the liberator."


Bukhari :: Manumission of Slaves :: [3.46.739]

Manumission of Slaves

Bukhari :: Book 3 :: Volume 46 :: Hadith 739

Narrated 'Abdul Wahid bin Aiman:

I went to 'Aisha and said, "I was the slave of Utba bin Abu Lahab. "Utba died and his sons became my masters who sold me to Ibn Abu Amr who manumitted me. The sons of 'Utba stipulated that my Wala' should be for them." 'Aisha said, "Buraira came to me and she was given the writing of emancipation by her masters and she asked me to buy and manumit her. I agreed to it, but Buraira told me that her masters would not sell her unless her Wala' was for them." 'Aisha said, "I am not in need of that." When the Prophet heard that, or he was told about it, he asked 'Aisha about it. 'Aisha mentioned what Buraira had told her. The Prophet said, "Buy and manumit her and let them stipulate whatever they like." So, 'Aisha bought and manumitted her and her masters stipulated that her Wala' should be for them." The Prophet;, said, "The Wala' will be for the liberator even if they stipulated a hundred conditions."


Bukhari :: Gifts :: [3.47.740]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 740

Narrated Abu Huraira:

The Prophet said, "O Muslim women! None of you should look down upon the gift sent by her she-neighbour even if it were the trotters of the sheep (fleshless part of legs)."


Bukhari :: Gifts :: [3.47.741]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 741

Narrated Urwa:

Aisha said to me, "O my nephew! We used to see the crescent, and then the crescent and then the crescent in this way we saw three crescents in two months and no fire (for cooking) used to be made in the houses of Allah's Apostle. I said, "O my aunt! Then what use to sustain you?" 'Aisha said, "The two black things: dates and water, our neighbors from Ansar had some Manarh and they used to present Allah's Apostle some of their milk and he used to make us drink."


Bukhari :: Gifts :: [3.47.742]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 742

Narrated Abu Huraira:

The Prophet said, "I shall accept the invitation even if I were invited to a meal of a sheep's trotter, and I shall accept the gift even if it were an arm or a trotter of a sheep."


Bukhari :: Gifts :: [3.47.743]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 743

Narrated Sahl:

The Prophet sent for a woman from the emigrants and she had a slave who was a carpenter. The Prophet said to her "Order your slave to prepare the wood (pieces) for the pulpit." So, she ordered her slave who went and cut the wood from the tamarisk and prepared the pulpit, for the Prophet. When he finished the pulpit, the woman informed the Prophet that it had been finished. The Prophet asked her to send that pulpit to him, so they brought it. The Prophet lifted it and placed it at the place in which you see now."


Bukhari :: Gifts :: [3.47.744]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 744

Narrated 'Abdullah bin Abu Qatada Al-Aslami:

That his father said, "One day I was sitting with some of the Prophet's companions on the way to Mecca. Allah's Apostle was ahead of us. All of my companions were in the state of Ihram while I was a non-Muhrim. They saw an onager while I was busy repairing my shoes, so they did not tell me about it but they wished I had seen it. By chance I looked up and saw it. So, I turned to the horse, saddled it and rode on it, forgetting to take the spear and the whip. I asked them if they could hand over to me the whip and the spear but they said, 'No, by Allah, we shall not help you in that in any way.' I became angry and got down from the horse, picked up both the things and rode the horse again. I attacked the onager and slaughtered it, and brought it (after it had been dead). They took it (cooked some of it) and started eating it, but they doubted whether it was allowed for them to eat it or not, as they were in the state of Ihram. So, we proceeded and I hid with me one of its fore-legs. When we met Allah's Apostle and asked him about the case, he asked, 'Do you have a portion of it with you?' I replied in the affirmative and gave him that fleshy fore-leg which he ate completely while he was in the state of Ihram .


Bukhari :: Gifts :: [3.47.745]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 745

Narrated Anas:

Once Allah's Apostle visited us in this house of ours and asked for something to drink. We milked one of our sheep and mixed it with water from this well of ours and gave it to him. Abu Bakr was sitting on his left side and 'Umar in front of him and a bedouin on his right side. When Allah's Apostle finished, 'Umar said to Allah's Apostle "Here is Abu Bakr." But Allah's Apostle gave the remaining milk to the bedouin and said twice, "The (persons on the) right side! So, start from the right side." Anas added, "It is a Sunna (the Prophet's traditions)" and repeated it thrice.


Bukhari :: Gifts :: [3.47.746]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 746

Narrated Anas:

We chased a rabbit at Mar-al-Zahran and the people ran after it but were exhausted. I overpowered and caught it, and gave it to Abu Talha who slaughtered it and sent its hip or two thighs to Allah's Apostle. (The narrator confirms that he sent two thighs). The Prophet accepted that. (The sub-narrator asked Anas, "Did the Prophet; eat from it?" Anas replied, "He ate from it.")


Bukhari :: Gifts :: [3.47.747]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 747

Narrated As-Sa'b bin Jaththama:

An onager was presented to Allah's Apostle at the place called Al-Abwa' or Waddan, but Allah's Apostle rejected it. When the Prophet noticed the signs of sorrow on the giver's face he said, "We have not rejected your gift, but we are in the state of Ihram." (i.e. if we were not in a state of Ihram we would have accepted your gift, Fateh-al-Bari page 130, Vol. 6)


Bukhari :: Gifts :: [3.47.748]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 748

Narrated Aisha:

The people used to look forward for the days of my ('Aisha's) turn to send gifts to Allah's Apostle in order to please him.


Bukhari :: Gifts :: [3.47.749]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 749

Narrated Said bin Jubair:

Ibn Abbas said: Um Hufaid, Ibn 'Abbas's aunt sent some dried yogurt (butter free), ghee (butter) and a mastigar to the Prophet as a gift. The Prophet ate the dried yogurt and butter but left the mastigar because he disliked it. Ibn 'Abbas said, "The mastigar was eaten at the table of Allah's Apostle and if it had been illegal to eat, it could not have been eaten at the table of Allah's Apostle."


Bukhari :: Gifts :: [3.47.750]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 750

Narrated Abu Huraira:

Whenever a meal was brought to Allah's Apostle, he would ask whether it was a gift or Sadaqa (something given in charity). If he was told that it was Sadaqa, he would tell his companions to eat it, but if it was a gift, he would hurry to share it with them.


Bukhari :: Gifts :: [3.47.751]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 751

Narrated Anas bin Malik:

Some meat was brought to the Prophet and it was said that the meat had been given in charity to Buraira. He said, "It was Sadaqa for Buraira but a gift for us."


Bukhari :: Gifts :: [3.47.752]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 752

Narrated 'Aisha:

I intended to buy Buraira but her masters stipulated that her Wala should be for them. When the Prophet was told about it, he said to me, "Buy and manumit her, as the Wala' is for the liberator." Once Buraira was given some meat, and the Prophet asked, "What is this?" I said, "It has been given to Buraira in charity." He said, "It is sadaqa for her but a gift for us." Buraira was given the option (to stay with her husband or to part with him). AbdurRahman (a sub-narrator) wondered, "Was her husband a slave or a free man?" Shu'ba (another sub-narrator) said, "I asked 'Abdur-Rahman whether her husband was a slave or a free man. He replied that he did not know whether he was a slave or a free man."


Bukhari :: Gifts :: [3.47.753]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 753

Narrated Um 'Atiyya:

Once the Prophet went to 'Aisha and asked her whether she had something (to eat). She said that she had nothing except the mutton which Um 'Atiyya had sent to (Buraira) in charity. The Prophet said that it had reached its destination (i.e. it is no longer an object of charity.)


Bukhari :: Gifts :: [3.47.754]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 754

Narrated 'Aisha:

The people used to send gifts to the Prophet on the day of my turn. Um Salama said: "My companions (the wives of the Prophet Other than Aisha) gathered and they complained about it. So I informed the Prophet about it on their behalf, but he remained silent.


Bukhari :: Gifts :: [3.47.755]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 755

Narrated 'Urwa from 'Aisha:

The wives of Allah's Apostle were in two groups. One group consisted of 'Aisha, Hafsa, Safiyya and Sauda; and the other group consisted of Um Salama and the other wives of Allah's Apostle. The Muslims knew that Allah's Apostle loved 'Aisha, so if any of them had a gift and wished to give to Allah's Apostle, he would delay it, till Allah's Apostle had come to 'Aisha's home and then he would send his gift to Allah's Apostle in her home. The group of Um Salama discussed the matter together and decided that Um Salama should request Allah's Apostle to tell the people to send their gifts to him in whatever wife's house he was. Um Salama told Allah's Apostle of what they had said, but he did not reply. Then they (those wives) asked Um Salama about it. She said, "He did not say anything to me." They asked her to talk to him again. She talked to him again when she met him on her day, but he gave no reply. When they asked her, she replied that he had given no reply. They said to her, "Talk to him till he gives you a reply." When it was her turn, she talked to him again. He then said to her, "Do not hurt me regarding Aisha, as the Divine Inspirations do not come to me on any of the beds except that of Aisha." On that Um Salama said, "I repent to Allah for hurting you." Then the group of Um Salama called Fatima, the daughter of Allah's Apostle and sent her to Allah's Apostle to say to him, "Your wives request to treat them and the daughter of Abu Bakr on equal terms." Then Fatima conveyed the message to him. The Prophet said, "O my daughter! Don't you love whom I love?" She replied in the affirmative and returned and told them of the situation. They requested her to go to him again but she refused. They then sent Zainab bint Jahsh who went to him and used harsh words saying, "Your wives request you to treat them and the daughter of Ibn Abu Quhafa on equal terms." On that she raised her voice and abused 'Aisha to her face so much so that Allah's Apostle looked at 'Aisha to see whether she would retort. 'Aisha started replying to Zainab till she silenced her. The Prophet then looked at 'Aisha and said, "She is really the daughter of Abu Bakr."


Bukhari :: Gifts :: [3.47.756]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 756

Narrated 'Azra bin Thabit Al-Ansari:

When I went to Thumama bin 'Abdullah, he gave me some perfume and said that Anas would not reject the gifts of perfume. Anas said: The Prophet used not to reject the gifts of perfume.


Bukhari :: Gifts :: [3.47.757]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 757

Narrated Al-Miswar bin Makhrama and Marwan:

When the delegates of the tribe of Hawazin came to the Prophet he stood up amongst the people, Glorified and Praised Allah as He deserved, and said, "Then after: Your brethren have come to you with repentance and I see it logical to return to them their captives; so whoever amongst you likes to do that as a favor, then he can do it, and whoever of you like to stick to his share till we give him his right from the very first Fai (war booty) (1) which Allah will bestow on us, then (he can do so)." The people replied, "We do that (to return the captives) willingly as a favor for your sake."


Bukhari :: Gifts :: [3.47.758]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 758

Narrated 'Aisha:

Allah's Apostles used to accept gifts and used to give something in return.


Bukhari :: Gifts :: [3.47.759]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 759

Narrated An-Nu'man bin Bashir:

that his father took him to Allah's Apostle and said, "I have given this son of mine a slave." The Prophet asked, "Have you given all your sons the like?" He replied in the negative. The Prophet said, "Take back your gift then."


Bukhari :: Gifts :: [3.47.760]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 760

Narrated 'Amir:

I heard An-Nu'man bin Bashir on the pulpit saying, "My father gave me a gift but 'Amra bint Rawaha (my mother) said that she would not agree to it unless he made Allah's Apostle as a witness to it. So, my father went to Allah's Apostle and said, 'I have given a gift to my son from 'Amra bint Rawaha, but she ordered me to make you as a witness to it, O Allah's Apostle!' Allah's Apostle asked, 'Have you given (the like of it) to everyone of your sons?' He replied in the negative. Allah's Apostle said, 'Be afraid of Allah, and be just to your children.' My father then returned and took back his gift."


Bukhari :: Gifts :: [3.47.761]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 761

Narrated Az-Zuhari:

Ubaidullah bin 'Abdullah told me that 'Aisha had said, "When the Prophet became sick and his condition became serious, he requested his wives to allow him to be treated in my house, and they allowed him. He came out leaning on two men while his feet were dragging on the ground. He was walking between Al-'Abbas and another man." 'Ubaidullah said, "When I informed Ibn 'Abbas of what 'Aisha had said, he asked me whether I knew who was the second man whom 'Aisha had not named. I replied in the negative. He said, 'He was 'Ali bin Abi Talib."


Bukhari :: Gifts :: [3.47.762]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 762

Narrated Ibn 'Abbas: The Prophet said, "One who takes back his gift (which he has already given) is like a dog that swallows its vomit."


Bukhari :: Gifts :: [3.47.763]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 763

Narrated Asma:

Once I said, "O Allah's Apostle! I have no property except what has been given to me by Az-Zubair (i.e. her husband). May I give in charity?" The Prophet said, "Give in charity and do not withhold it; otherwise Allah will withhold it back from you . "


Bukhari :: Gifts :: [3.47.764]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 764

Narrated Asma:

Allah's Apostle said, "Give (in charity) and do not give reluctantly lest Allah should give you in a limited amount; and do not withhold your money lest Allah should withhold it from you."


Bukhari :: Gifts :: [3.47.765]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 765

Narrated Kurib:

the freed slave of Ibn 'Abbas, that Maimuna bint Al-Harith told him that she manumitted a slave-girl without taking the permission of the Prophet. On the day when it was her turn to be with the Prophet, she said, "Do you know, O Allah's Apostle, that I have manumitted my slave-girl?" He said, "Have you really?" She replied in the affirmative. He said, "You would have got more reward if you had given her (i.e. the slave-girl) to one of your maternal uncles."


Bukhari :: Gifts :: [3.47.766]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 766

Narrated Aisha:

Whenever Allah's Apostle wanted to go on a journey, he would draw lots as to which of his wives would accompany him. He would take her whose name came out. He used to fix for each of them a day and a night. But Sauda bint Zam'a gave up her (turn) day and night to 'Aisha, the wife of the Prophet in order to seek the pleasure of Allah's Apostle (by that action).


Bukhari :: Gifts :: [3.47.767]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 767

Narrated Aisha:

I said, "O Allah's Apostle! I have two neighbors; which of them should I give a gift to?" The Prophet said, "(Give) to the one whose door is nearer to you."


Bukhari :: Gifts :: [3.47.768]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 768

Narrated 'Abdullah bin 'Abbas:

That he heard As-Sa'b bin Jaththama Al-Laithi, who was one of the companions of the Prophet, saying that he gave the meat of an onager to Allah's Apostle while he was at a place called Al-Abwa' or Waddan, and was in a state of Ihram. The Prophet did not accept it. When the Prophet saw the signs of sorrow on As-Sa'b's face because of not accepting his present, he said (to him), "We are not returning your present, but we are in the state of Ihram." (See Hadith No. 747)


Bukhari :: Gifts :: [3.47.769]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 769

Narrated Abu Humaid Al-Sa'idi:

The Prophet appointed a man from the tribe of Al-Azd, called Ibn 'Utbiyya for collecting the Zakat. When he returned he said, "This (i.e. the Zakat) is for you and this has been given to my as a present." The Prophet said, "Why hadn't he stayed in his father's or mother's house to see whether he would be given presents or not? By Him in Whose Hands my life is, whoever takes something from the resources of the Zakat (unlawfully) will be carrying it on his neck on the Day of Resurrection; if it be a camel, it will be grunting; if a cow, it will be mooing; and if a sheep, it will be bleating." The Prophet then raised his hands till we saw the whiteness of his armpits, and he said thrice, "O Allah! Haven't I conveyed Your Message (to them)?"


Bukhari :: Gifts :: [3.47.770]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 770

Narrated Jabir:

The Prophet said to me, "I will give you so much (the Prophet pointed thrice with his hands) when funds of Bahrain will come to me." But the Prophet died before the money reached him. (When it came) Abu Bakr ordered an announcer to announce that whoever had a money claim on the Prophet or was promised to be given something, should come to Abu Bakr. I went to Abu Bakr and told him that the Prophet had promised to give me so much. On that Abu Bakr gave me three handfuls (of money).


Bukhari :: Gifts :: [3.47.771]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 771

Narrated Al-Miswar bin Makhrama:

Allah's Apostle distributed some cloaks but did not give anything thereof to Makhrama. Makhrama said (to me), "O son! accompany me to Allah's Apostle." When I went with him, he said, "Call him to me." I called him (i.e. the Prophet ) for my father. He came out wearing one of those cloaks and said, "We kept this (cloak) for you, (Makhrama)." Makhrama looked at the cloak and said, "Makhrama is pleased," (or the Prophet said), "Is Makhrama pleased?"


Bukhari :: Gifts :: [3.47.772]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 772

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "I am ruined." The Prophet asked, "What do you mean?" He said, "I had a sexual intercourse with my wife during Ramadan (while fasting)." The Prophet asked him, "Can you manumit a slave?" He replied in the negative. He then asked him, "Can you fast for two successive months continuously" He replied in the negative. The Prophet then asked him, "Can you feed sixty poor persons?" He replied in the negative. In the meantime an Ansari came with a basket full of dates. The Prophet said to the man, "Take it and give it in charity (as an expiation of your sin)." The man said "Should I give it to some people who are poorer than we O Allah's Apostle? By Him Who has sent you with the Truth, there is no family between Medina's two mountains poorer than we." Allah's Apostle told him to take it and provide his family with it."


Bukhari :: Gifts :: [3.47.773]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 773

Narrated Jabir bin 'Abdullah:

My father was martyred on the day (of the battle) of Uhud and his creditors demanded the debt back in a harsh manner. So I went to Allah's Apostle and informed him of that, he asked them to accept the fruits of my garden and excuse my father, but they refused. So, Allah's Apostle did not give them the fruits, nor did he cut them and distribute them among them, but said, "I will come to you tomorrow morning." So, he came to us the next morning and walked about in between the date-palms and invoked Allah to bless their fruits. I plucked the fruits and gave back all the rights of the creditors in full, and a lot of fruits were left for us. Then I went to Allah's Apostle, who was sitting, and informed him about what happened. Allah's Apostle told 'Umar, who was sitting there, to listen to the story. 'Umar said, "Don't we know that you are Allah's Apostle? By Allah! you are Allah's Apostle!"


Bukhari :: Gifts :: [3.47.774]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 774

Narrated Sahl bin Sad:

A drink (milk mixed with water) was brought to the Prophet who drank some of it while a boy was sitting on his right and old men on his left. The Prophet said to the boy, "If you permit me, I'll give (the rest of the drink to) these old men first." The boy said, "I will not give preference to any one over me as regards my share from you, O Allah's Apostle!" The Prophet then put that container in the boy's hand. (See Hadith No. 541).


Bukhari :: Gifts :: [3.47.775]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 775

Narrated Jabir bin 'Abdullah:

I sold a camel to the Prophet on one of the journeys. When we reached Medina, he ordered me to go to the Mosque and offer two Rakat. Then he weighed for me (the price of the camel in gold) and gave an extra amount over it. A part of it remained with me till it was taken by the army of Sham on the day of Harra."


Bukhari :: Gifts :: [3.47.776]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 776

Narrated Shal bin Sad:

A drink (of milk and water) was brought to Allah's Apostle while a boy was sitting on his right side and old men were sitting on his left side. He asked the boy, "Will you allow me to give it to these (people)?" The boy said, "No, by Allah, I will not allow anyone to take my right from you." Then the Prophet put the bowl in the boy's hand.


Bukhari :: Gifts :: [3.47.777]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 777

Narrated Abu Huraira:

Allah's Apostle owed a man some debt (and that man demanded it very harshly). The companions of the Prophet wanted to harm him, but the Prophet said to them, "Leave him, as the creditor has the right to speak harshly." He then added, "Buy (a camel) of the same age and give it to him." They said, "We cannot get except a camel of an older age than that of his." He said, "Buy it and give it to him, as the best amongst you is he who pays back his debt in the most handsome way.'


Bukhari :: Gifts :: [3.47.778]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 778

Narrated Marwan bin Al-Hakam and Al-Miswar bin Makhrama:

When the delegates of the tribe of Hawazin came to the Prophet they requested him to return their property and their captives. He said to them, "This concerns also other people along with me as you see, and the best statement to me is the true one, so you may choose one of two alternatives; either the captives or the property and (I have not distributed the booty for) I have been waiting for you."

When the Prophet had returned from Ta'if, he waited for them for more than ten nights. When they came to know that the Prophet would not return except one of the two, they chose their captives. The Prophet then stood up amongst the Muslims, Glorified and Praised Allah as He deserved, and then said, "Then after: These brothers of yours have come to you with repentance and I see it proper to return their captives, so whoever amongst you likes to do that as a favor, then he can do it, and whoever of you wants to stick to his share till we pay him from the very first Fai (i.e. war booty) which Allah will give us, then he can do so." The people said, "We return (the captives) to them willingly as a favor, O Allah's Apostle!" The Prophet said, "I do not know who of you has given his consent and who has not; so go back and your leaders may present your decision to me." The people went away, and their leaders discussed the matter with them, and then came to the Prophet to tell him that all of them had given their consent (to return the captives) willingly. (Az-Zuhn, the sub-narrator said, "This is what we know about the captives, of Hawazin.")


Bukhari :: Gifts :: [3.47.779]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 779

Narrated Ibn 'Abbas: That the people sitting with that person will be his co-owners. But this report is not confirmed by an authentic narration. (Refer to Hadith 778)


Bukhari :: Gifts :: [3.47.780]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 780

Narrated Abu Huraira:

The Prophet took a camel of special age from somebody on credit. Its owner came and demanded it back (harshly). The Prophet said, "No doubt, he who has a right, can demand it." Then the Prophet gave him an older camel than his camel and said, "The best amongst you is he who repays his debts in the most handsome way."


Bukhari :: Gifts :: [3.47.781]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 781

Narrated Ibn 'Umar:

That he was in the company of the Prophet on a journey, riding a troublesome camel belonging to 'Umar. The camel used to go ahead of the Prophet, so Ibn 'Umar's father would say, "O 'Abdullah! No one should go ahead of the Prophet." The Prophet said to him, "Sell it to me." 'Umar said to the Prophet "It is for you." So, he bought it and said, "O 'Abdullah! It is for you, and you can do with it what you like."


Bukhari :: Gifts :: [3.47.782]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 782

Narrated 'Abdullah bin Umar:

Umar bin Al-Khattab saw a silken dress (cloak) being sold at the gate of the Mosque and said, "O Allah's Apostle! Would that you buy it and wear it on Fridays and when the delegates come to you!" Allah's Apostle said, "This is worn by the one who will have no share in the Hereafter." Later on some silk dresses were brought and Allah's Apostle sent one of them to 'Umar. 'Umar said, "How do you give me this to wear while you said what you said about the dress of 'Utarid?" Allah's Apostle said, "I have not given it to you to wear." So, 'Umar gave it to a pagan brother of his in Mecca.


Bukhari :: Gifts :: [3.47.783]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 783

Narrated Ibn Umar:

Once the Prophet went to the house of Fatima but did not enter it. 'Ali came and she told him about that. When 'All asked the Prophet about it, he said, "I saw a (multi-colored) decorated curtain on her door. I am not interested in worldly things." 'Ali went to Fatima and told her about it. Fatima said, "I am ready to dispense with it in the way he suggests." The Prophet ordered her to send it to such-and-such needy people. "


Bukhari :: Gifts :: [3.47.784]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 784

Narrated 'Ali:

The Prophet gave me a silken dress as a gift and I wore it. When I saw the signs of anger on his face, I cut it into pieces and distributed it among my wives."


Bukhari :: Gifts :: [3.47.785]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 785

Narrated Anas:

A Jubba (i.e. cloak) made of thick silken cloth was presented to the Prophet. The Prophet used to forbid people to wear silk. So, the people were pleased to see it. The Prophet said, "By Him in Whose Hands Muhammad's soul is, the handkerchiefs of Sad bin Mu'adh in Paradise are better than this." Anas added, "The present was sent to the Prophet by Ukaidir (a Christian) from Dauma."


Bukhari :: Gifts :: [3.47.786]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 786

Narrated Anas bin Malik:

A Jewess brought a poisoned (cooked) sheep for the Prophet who ate from it. She was brought to the Prophet and he was asked, "Shall we kill her?" He said, "No." I continued to see the effect of the poison on the palate of the mouth of Allah's Apostle .


Bukhari :: Gifts :: [3.47.787]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 787

Narrated 'Abdur-Rahman bin Abu Bakr:

We were one-hundred and thirty persons accompanying the Prophet who asked us whether anyone of us had food. There was a man who had about a Sa of wheat which was mixed with water then. A very tall pagan came driving sheep. The Prophet asked him, "Will you sell us (a sheep) or give it as a present?" He said, "I will sell you (a sheep)." The Prophet bought a sheep and it was slaughtered. The Prophet ordered that its liver and other abdominal organs be roasted. By Allah, the Prophet gave every person of the one-hundred-and-thirty a piece of that; he gave all those of them who were present; and kept the shares of those who were absent.The Prophet then put its meat in two huge basins and all of them ate to their fill, and even then more food was left in the two basins which were carried on the camel (or said something like it).


Bukhari :: Gifts :: [3.47.788]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 788

Narrated Ibn 'Umar:

Umar saw a silken cloak over a man for sale and requested the Prophet to buy it in order to wear it on Fridays and while meeting delegates. The Prophet said, "This is worn by the one who will have no share in the Hereafter." Later on Allah's Apostle got some silken cloaks similar to that one, and he sent one to 'Umar. 'Umar said to the Prophet "How can I wear it, while you said about it what you said?" The Prophet said, "I have not given it to you to wear, but to sell or to give to someone else." So, 'Umar sent it to his brother at Mecca before he embraced Islam.


Bukhari :: Gifts :: [3.47.789]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 789

Narrated Asma' bint Abu Bakr:

My mother came to me during the lifetime of Allah's Apostle and she was a pagan. I said to Allah's Apostle (seeking his verdict), "My mother has come to me and she desires to receive a reward from me, shall I keep good relations with her?" The Prophet said, "Yes, keep good relation with her. "


Bukhari :: Gifts :: [3.47.790]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 790

Narrated Ibn 'Abbas:

The Prophet said, "He who takes back his present is like him who swallows his vomit."


Bukhari :: Gifts :: [3.47.791]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 791

Narrated Ibn 'Abbas:

The Prophet said, "The bad example is not for us. He who takes back his present is like a dog that swallows back its vomit."


Bukhari :: Gifts :: [3.47.792]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 792

Narrated 'Umar bin Al-Khattab:

I gave a horse in Allah's Cause. The person to whom it was given, did not look after it. I intended to buy it from him, thinking that he would sell it cheap. When I asked the Prophet he said, "Don't buy it, even if he gives it to you for one Dirham, as the person who takes back what he has given in charity, is like a dog that swallows back its vomit."


Bukhari :: Gifts :: [3.47.793]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 793

Narrated Jabir: The Prophet gave the verdict that 'Umra is for the one to whom it is presented.


Bukhari :: Gifts :: [3.47.794]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 794

Narrated Abu Huraira:

The Prophet said, "Umra is permissible." Ata said, "Jabir narrated the same to me from the Prophet."


Bukhari :: Gifts :: [3.47.795]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 795

Narrated Anas:

Once the people of Medina were frightened, so the Prophet borrowed a horse from Abu Talha called Al-Mandub, and rode it. When he came back he said, "We have not seen anything (to be afraid of), but the horse was very fast (having an energy as inexhaustible as the water of the sea)."


Bukhari :: Gifts :: [3.47.796]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 796

Narrated Aiman:

I went to 'Aisha and she was wearing a coarse dress costing five Dirhams. 'Aisha said, "Look up and see my slave-girl who refuses to wear it in the house though during the lifetime of Allah's Apostle I had a similar dress which no woman desiring to appear elegant (before her husband) failed to borrow from me."


Bukhari :: Gifts :: [3.47.797]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 797

Narrated Abu Huraira:

Allah's Apostle said, "What a good Maniha (the she-camel which has recently given birth and which gives profuse milk) is, and (what a good Maniha) (the sheep which gives profuse milk, a bowl in the morning and another in the evening) is!"


Bukhari :: Gifts :: [3.47.798]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 798

Narrated Malik:

Maniha is a good deed of charity.


Bukhari :: Gifts :: [3.47.799]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 799

Narrated Ibn Shihab Az-Zuhri:

Anas bin Malik said, "When the emigrants came Medina, they had nothing whereas the Ansar had land and property. The Ansar gave them their land on condition that the emigrants would give them half the yearly yield and work on the land and provide the necessaries for cultivation." His (i.e. Anas's mother who was also the mother of 'Abdullah bin Abu Talha, gave some date-palms to Allah' Apostle who gave them to his freed slave-girl (Um Aiman) who was also the mother of Usama bin Zaid. When the Prophet finished from the fighting against the people of Khaibar and returned to Medina, the emigrants returned to the Ansar the fruit gifts which the Ansar had given them. The Prophet also returned to Anas's mother the date-pallms. Allah's Apostle gave Um Aiman other trees from his garden in lieu of the old gift.


Bukhari :: Gifts :: [3.47.800]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 800

Narrated 'Abdullah bin 'Amr:

That Allah's Apostle said, "There are forty virtuous deeds and the best of them is the Maniha of a she-goat, and anyone who does one of these virtuous deeds hoping for Allah's reward with firm confidence that he will get it, then Allah will make him enter Paradise because of Hassan (a sub-narrator) said, "We tried to count those good deeds below the Maniha; we mentioned replying to the sneezer, removing harmful things from the road, etc., but we failed to count even fifteen."


Bukhari :: Gifts :: [3.47.801]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 801

Narrated Jabir:

Some men had superfluous land and they said that they would give it to others to cultivate on the condition that they would get one-third or one-fourth or one half of its yield. The Prophet said, "Whoever has land should cultivate it himself or give it to his brother or keep it uncultivated."

Narrated Abu Said: A bedouin came to the Prophet and asked him about emigration. The Prophet said to him, "May Allah be merciful to you. The matter of emigration is difficult. Have you got some camels?" He replied in the affirmative. The Prophet asked him, "Do you pay their Zakat?" He replied in the affirmative. He asked, "Do you lend them so that their milk may be utilized by others?" The bedouin said, "Yes." The Prophet asked, "Do you milk them on the day off watering them?" He replied, "Yes." The Prophet said, "Do good deeds beyond the merchants (or the sea) and Allah will never disregard any of your deeds." (See Hadith No. 260, Vol. 5)


Bukhari :: Gifts :: [3.47.802]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 802

Narrated Tawus:

That he was told by the most learned one amongst them (i.e. Ibn Abbas) that the Prophet went towards some land which was flourishing with vegetation and asked to whom it belonged. He was told that such and such a person took it on rent. The Prophet said, "It would have been better (for the owner) if he had given it to him gratis rather than charging him a fixed rent.


Bukhari :: Gifts :: [3.47.803]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 803

Narrated Abu Huraira:

Allah's Apostle said, "The Prophet Abraham migrated with Sarah. The people (of the town where they migrated) gave her Ajar (i.e. Hajar). Sarah returned and said to Abraham, "Do you know that Allah has humiliated that pagan and he has given a slave-girl for my service?"


Bukhari :: Gifts :: [3.47.804]

Gifts

Bukhari :: Book 3 :: Volume 47 :: Hadith 804

Narrated 'Umar bin Al-Khatab:

Once I gave a horse (for riding) in Allah's Cause. Later I saw it being sold. I asked Allah's Apostle (whether I could buy it). He said, "Don't buy it, for you should not get back what you have given in charity."


Bukhari :: Witnesses :: [3.48.805]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 805

Narrated Urwa bin Al-Musayyab, Alqama bin Waqqas and Ubaidullah bin Abdullah:

About the story of 'Aisha and their narrations were similar attesting each other, when the liars said what they invented about 'Aisha, and the Divine Inspiration was delayed, Allah's Apostle sent for 'Ali and Usama to consult them in divorcing his wife (i.e. 'Aisha). Usama said, "Keep your wife, as we know nothing about her except good." Buraira said, "I cannot accuse her of any defect except that she is still a young girl who sleeps, neglecting her family's dough which the domestic goats come to eat (i.e. she was too simpleminded to deceive her husband)." Allah's Apostle said, "Who can help me to take revenge over the man who has harmed me by defaming the reputation of my family? By Allah, I have not known about my family-anything except good, and they mentioned (i.e. accused) a man about whom I did not know anything except good."


Bukhari :: Witnesses :: [3.48.806]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 806

Narrated Abdullah bin Umar:

Allah's Apostle and Ubai bin Kab Al-Ansari went to the garden where Ibn Saiyad used to live. When Allah's Apostle entered (the garden), he (i.e. Allah's Apostle ) started hiding himself behind the datepalms as he wanted to hear secretly the talk of Ibn Saiyad before the latter saw him. Ibn Saiyad wrapped with a soft decorated sheet was lying on his bed murmuring. Ibn Saiyad's mother saw the Prophet hiding behind the stems of the date-palms. She addressed Ibn Saiyad saying, "O Saf, this is Muhammad." Hearing that Ibn Saiyad stopped murmuring (or got cautious), the Prophet said, "If she had left him undisturbed, he would have revealed his reality." (See Hadith No. 290, Vol 4 for details)


Bukhari :: Witnesses :: [3.48.807]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 807

Narrated Aisha:

The wife of Rifa'a Al-Qurazi came to the Prophet and said, "I was Rifa'a's wife, but he divorced me and it was a final irrevocable divorce. Then I married AbdurRahman bin Az-Zubair but he is impotent." The Prophet asked her 'Do you want to remarry Rifa'a? You cannot unless you had a complete sexual relation with your present husband." Abu Bakr was sitting with Allah's Apostle and Khalid bin Said bin Al-'As was at the door waiting to be admitted. He said, "O Abu Bakr! Do you hear what this (woman) is revealing frankly before the Prophet ?"


Bukhari :: Witnesses :: [3.48.808]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 808

Narrated Abdullah bin Abu Mulaika from 'Uqba bin Al-Harith:

Uqba married the daughter of Abu Ihab bin Aziz, and then a woman came and said, "I suckled 'Uqba and his wife." 'Uqba said to her, "I do not know that you have suckled me, and you did not inform me." He then sent someone to the house of Abu Ihab to enquire about that but they did not know that she had suckled their daughter. Then 'Uqba went to the Prophet in Medina and asked him about it. The Prophet said to him, "How (can you keep your wife) after it has been said (that both of you were suckled by the same woman)?" So, he divorced her and she was married to another (husband).


Bukhari :: Witnesses :: [3.48.809]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 809

Narrated 'Umar bin Al-Khattab:

People were (sometimes) judged by the revealing of a Divine Inspiration during the lifetime of Allah's Apostle but now there is no longer any more (new revelation). Now we judge you by the deeds you practice publicly, so we will trust and favor the one who does good deeds in front of us, and we will not call him to account about what he is really doing in secret, for Allah will judge him for that; but we will not trust or believe the one who presents to us with an evil deed even if he claims that his intentions were good.


Bukhari :: Witnesses :: [3.48.810]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 810

Narrated Anas:

A funeral procession passed in front of the Prophet and the people praised the deceased. The Prophet said, "It has been affirmed (Paradise)." Then another funeral procession passed by and the people talked badly of the deceased. The Prophet said, "It has been affirmed (Hell)." Allah's Apostle was asked, "O Allah's Apostle! You said it has been affirmed for both?" The Prophet said, "The testimony of the people (is accepted), (for) the believer are Allah's witnesses on the earth."


Bukhari :: Witnesses :: [3.48.811]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 811

Narrated Abu Al-Aswad:

Once I went to Medina where there was an outbreak of disease and the people were dying rapidly. I was sitting with 'Umar and a funeral procession passed by. The people praised the deceased. 'Umar said, "It has been affirmed" (Paradise). Then another funeral procession passed by. The people praised the deceased. 'Umar said, "It has been affirmed." (Paradise). Then another funeral procession passed by. The people praised the deceased. 'Umar said, "It has been affirmed (Paradise)." Then a third funeral procession passed by and the people talked badly of the deceased. 'Umar said, "It has been affirmed (Hell)." I asked Umar, "O chief of the believers! What has been affirmed?" He said, "I have said what the Prophet said. He said, 'Allah will admit into paradise any Muslim whose good character is attested by four persons.' We asked the Prophet, 'If there were three witnesses only?' He said, 'Even three.' We asked, 'If there were two only?' He said, 'Even two.' But we did not ask him about one witness."


Bukhari :: Witnesses :: [3.48.812]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 812

Narrated Aisha:

Aflah asked the permission to visit me but I did not allow him. He said, "Do you veil yourself before me although I am your uncle?" 'Aisha said, "How is that?" Aflah replied, "You were suckled by my brother's wife with my brother's milk." I asked Allah's Apostle about it, and he said, "Allah is right, so permit him to visit you."


Bukhari :: Witnesses :: [3.48.813]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 813

Narrated Ibn 'Abbas:

The Prophet said about Hamza's daughter, "I am not legally permitted to marry her, as foster relations are treated like blood relations (in marital affairs). She is the daughter of my foster brother."


Bukhari :: Witnesses :: [3.48.814]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 814

Narrated Amra bint 'Abdur-Rahman:

That 'Aisha the wife of the Prophet told her uncle that once, while the Prophet was in her house, she heard a man asking Hafsa's permission to enter her house. 'Aisha said, "I said, 'O Allah's Apostle! I think the man is Hafsa's foster uncle.' " 'Aisha added, "O Allah's Apostle! There is a man asking the permission to enter your house." Allah's Apostle replied, "I think the man is Hafsa's foster uncle." 'Aisha said, "If so-and-so were living (i.e. her foster uncle) would he be allowed to visit me?" Allah's Apostle said, "Yes, he would, as the foster relations are treated like blood relations (in marital affairs)."


Bukhari :: Witnesses :: [3.48.815]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 815

Narrated Aisha:

Once the Prophet came to me while a man was in my house. He said, "O 'Aisha! Who is this (man)?" I replied, "My foster brothers" He said, "O 'Aisha! Be sure about your foster brothers, as fostership is only valid if it takes place in the suckling period (before two years of age)."


Bukhari :: Witnesses :: [3.48.816]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 816

Narrated 'Urwa bin Az-Zubair:

A woman committed theft in the Ghazwa of the Conquest (of Mecca) and she was taken to the Prophet who ordered her hand to be cut off. 'Aisha said, "Her repentance was perfect and she was married (later) and used to come to me (after that) and I would present her needs to Allah's Apostle."


Bukhari :: Witnesses :: [3.48.817]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 817

Narrated Zaid bin Khalid:

Allah's Apostle ordered that an unmarried man who committed illegal sexual intercourse be scourged one hundred lashes and sent into exile for one year.


Bukhari :: Witnesses :: [3.48.818]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 818

Narrated An-Nu'man bin Bashir:

My mother asked my father to present me a gift from his property; and he gave it to me after some hesitation. My mother said that she would not be satisfied unless the Prophet was made a witness to it. I being a young boy, my father held me by the hand and took me to the Prophet . He said to the Prophet, "His mother, bint Rawaha, requested me to give this boy a gift." The Prophet said, "Do you have other sons besides him?" He said, "Yes." The Prophet said, "Do not make me a witness for injustice." Narrated Ash-Shabi that the Prophet said, "I will not become a witness for injustice."


Bukhari :: Witnesses :: [3.48.819]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 819

Narrated Zahdam bin Mudrab:

I heard Imran bin Husain saying, "The Prophet said, 'The best people are those living in my generation, then those coming after them, and then those coming after (the second generation)." Imran said "I do not know whether the Prophet mentioned two or three generations after your present generation. The Prophet added, 'There will be some people after you, who will be dishonest and will not be trustworthy and will give witness (evidences) without being asked to give witness, and will vow but will not fulfill their vows, and fatness will appear among them."


Bukhari :: Witnesses :: [3.48.820]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 820

Narrated Abdullah:

The Prophet said, "The people of my generation are the best, then those who follow them, and then whose who follow the latter. After that there will come some people whose witness will go ahead of their oaths, and their oaths will go ahead of their witness." Ibrahim (a sub-narrator) said, "We used to be beaten for taking oaths by saying, 'I bear witness by the Name of Allah or by the Covenant of Allah."


Bukhari :: Witnesses :: [3.48.821]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 821

Narrated Anas:

The Prophet was asked about the great sins He said, "They are:--

(1 ) To join others in worship with Allah,

(2) To be undutiful to one's parents.

(3) To kill a person (which Allah has forbidden to kill) (i.e. to commit the crime of murdering).

(4) And to give a false witness."


Bukhari :: Witnesses :: [3.48.822]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 822

Narrated Abu Bakra:

The Prophet said thrice, "Should I inform you out the greatest of the great sins?" They said, "Yes, O Allah's Apostle!" He said, "To join others in worship with Allah and to be undutiful to one's parents." The Prophet then sat up after he had been reclining (on a pillow) and said, "And I warn you against giving a false witness, and he kept on saying that warning till we thought he would not stop. (See Hadith No. 7, Vol. 8)


Bukhari :: Witnesses :: [3.48.823]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 823

Narrated 'Aisha:

The Prophet heard a man (reciting Quran) in the Mosque, and he said, "May Allah bestow His Mercy upon him. No doubt, he made me remember such-and such Verses of such-and-such Sura which I dropped (from my memory).

Narrated Aisha: The Prophet performed the Tahajjud prayer in my house, and then he heard the voice of 'Abbas who was praying in the Mosque, and said, "O 'Aisha! Is this 'Abbad's voice?" I said, "Yes." He said, "O Allah! Be merciful to 'Abbas!"


Bukhari :: Witnesses :: [3.48.824]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 824

Narrated Abdullah bin Umar:

The Prophet said, "Bilal pronounces the Adhan when it is still night (before dawn), so eat and drink till the next Adhan is pronounced (or till you hear Ibn Um Maktum's Adhan)." Ibn Um Maktum was a blind man who would not pronounce the Adhan till he was told that it was dawn.


Bukhari :: Witnesses :: [3.48.825]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 825

Narrated Al-Miswar bin Makhrama:

Some outer garments were received the Prophet and my father (Makhrama) said to me, "Let us go to the Prophet so that he may give us something from the garments." So, my father stood at the door and spoke. The Prophet recognized his voice and came out carrying a garment and telling Makhrama the good qualities of that garment, adding, "I have kept this for you, I have sent this for you."


Bukhari :: Witnesses :: [3.48.826]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 826

Narrated Abu Said Al-Khudri:

The Prophet said, "Isn't the witness of a woman equal to half of that of a man?" The women said, "Yes." He said, "This is because of the deficiency of a woman's mind."


Bukhari :: Witnesses :: [3.48.827]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 827

Narrated Uqba bin Al-Harith:

That he had married Um Yahya bint Abu Ihab. He said. "A black slave-lady came and said, 'I suckled you both.' I then mentioned that to the Prophet who turned his face aside." Uqba further said, "I went to the other side and told the Prophet about it. He said, 'How can you (keep her as your wife) when the lady has said that she suckled both of you (i.e. you and your wife?)" So, the Prophet ordered him to divorce her.


Bukhari :: Witnesses :: [3.48.828]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 828

Narrated 'Uqba bin Al-Harith:

I married a woman and later on a woman came and said, "I suckled you both." So, I went to the Prophet (to ask him about it). He said, "How can you (keep her as a wife) when it has been said (that you were foster brother and sister)? Leave (divorce) her.


Bukhari :: Witnesses :: [3.48.829]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 829

Narrated Aisha:

(the wife of the Prophet) "Whenever Allah's Apostle intended to go on a journey, he would draw lots amongst his wives and would take with him the one upon whom the lot fell. During a Ghazwa of his, he drew lots amongst us and the lot fell upon me, and I proceeded with him after Allah had decreed the use of the veil by women. I was carried in a Howdah (on the camel) and dismounted while still in it. When Allah's Apostle was through with his Ghazwa and returned home, and we approached the city of Medina, Allah's Apostle ordered us to proceed at night. When the order of setting off was given, I walked till I was past the army to answer the call of nature. After finishing I returned (to the camp) to depart (with the others) and suddenly realized that my necklace over my chest was missing. So, I returned to look for it and was delayed because of that. The people who used to carry me on the camel, came to my Howdah and put it on the back of the camel, thinking that I was in it, as, at that time, women were light in weight, and thin and lean, and did not use to eat much. So, those people did not feel the difference in the heaviness of the Howdah while lifting it, and they put it over the camel. At that time I was a young lady. They set the camel moving and proceeded on. I found my necklace after the army had gone, and came to their camp to find nobody. So, I went to the place where I used to stay, thinking that they would discover my absence and come back in my search. While in that state, I felt sleepy and slept.

Safwan bin Mu'attal As-Sulami Adh-Dhakwani was behind the army and reached my abode in the morning. When he saw a sleeping person, he came to me, and he used to see me before veiling. So, I got up when I heard him saying, "Inna lil-lah-wa inn a ilaihi rajiun (We are for Allah, and we will return to Him)." He made his camel knell down. He got down from his camel, and put his leg on the front legs of the camel and then I rode and sat over it. Safwan set out walking, leading the camel by the rope till we reached the army who had halted to take rest at midday. Then whoever was meant for destruction, fell into destruction, (some people accused me falsely) and the leader of the false accusers was 'Abdullah bin Ubai bin Salul. After that we returned to Medina, and I became ill for one month while the people were spreading the forged statements of the false accusers. I was feeling during my ailment as if I were not receiving the usual kindness from the Prophet which I used to receive from him when I got sick. But he would come, greet and say, 'How is that (girl)?' I did not know anything of what was going on till I recovered from my ailment and went out with Um Mistah to the Manasi where we used to answer the call of nature, and we used not to go to answer the call of nature except from night to night and that was before we had lavatories near to our houses. And this habit of ours was similar to the habit of the old 'Arabs in the open country (or away from houses). So. I and Um Mistah bint Ruhm went out walking. Um Mistah stumbled because of her long dress and on that she said, 'Let Mistah be ruined.' I said, 'You are saying a bad word. Why are you abusing a man who took part in (the battle of) Badr?' She said, 'O Hanata (you there) didn't you hear what they said?' Then she told me the rumors of the false accusers.

My sickness was aggravated, and when I returned home, Allah's Apostle came to me, and after greeting he said, 'How is that (girl)?' I requested him to allow me to go to my parents. I wanted then to be sure of the news through them I Allah's Apostle allowed me, and I went to my parents and asked my mother, 'What are the people talking about?' She said, 'O my daughter! Don't worry much about this matter. By Allah, never is there a charming woman loved by her husband who has other wives, but the women would forge false news about her.' I said, 'Glorified be Allah! Are the people really taking of this matter?' That night I kept on weeping and could not sleep till morning. In the morning Allah's Apostle called Ali bin Abu Talib and Usama bin Zaid when he saw the Divine Inspiration delayed, to consul them about divorcing his wife (i.e. 'Aisha). Usama bin Zaid said what he knew of the good reputation of his wives and added, 'O Allah's Apostle! Keep you wife, for, by Allah, we know nothing about her but good.' 'Ali bin Abu Talib said, 'O Allah's Apostle! Allah has no imposed restrictions on you, and there are many women other than she, yet you may ask the woman-servant who will tell you the truth.' On that Allah's Apostle called Buraira and said, 'O Burair. Did you ever see anything which roused your suspicions about her?' Buraira said, 'No, by Allah Who has sent you with the Truth, I have never seen in her anything faulty except that she is a girl of immature age, who sometimes sleeps and leaves the dough for the goats to eat.' On that day Allah's Apostle ascended the pulpit and requested that somebody support him in punishing 'Abdullah bin Ubai bin Salul. Allah's Apostle said, 'Who will support me to punish that person ('Abdullah bin Ubai bin Salul) who has hurt me by slandering the reputation of my family? By Allah, I know nothing about my family but good, and they have accused a person about whom I know nothing except good, and he never entered my house except in my company.'

Sad bin Mu'adh got up and said, 'O Allah's Apostle! by Allah, I will relieve you from him. If that man is from the tribe of the Aus, then we will chop his head off, and if he is from our brothers, the Khazraj, then order us, and we will fulfill your order.' On that Sad bin 'Ubada, the chief of the Khazraj and before this incident, he had been a pious man, got up, motivated by his zeal for his tribe and said, 'By Allah, you have told a lie; you cannot kill him, and you will never be able to kill him.' On that Usaid bin Al-Hadir got up and said (to Sad bin 'Ubada), 'By Allah! you are a liar. By Allah, we will kill him; and you are a hypocrite, defending the hypocrites.' On this the two tribes of Aus and Khazraj got excited and were about to fight each other, while Allah's Apostle was standing on the pulpit. He got down and quietened them till they became silent and he kept quiet. On that day I kept on weeping so much so that neither did my tears stop, nor could I sleep.

In the morning my parents were with me and I had wept for two nights and a day, till I thought my liver would burst from weeping. While they were sitting with me and I was weeping, an Ansari woman asked my permission to enter, and I allowed her to come in. She sat down and started weeping with me. While we were in this state, Allah's Apostle came and sat down and he had never sat with me since the day they forged the accusation. No revelation regarding my case came to him for a month. He recited Tashah-hud (i.e. None has the right to be worshipped but Allah and Muhammad is His Apostle) and then said, 'O 'Aisha! I have been informed such-and-such about you; if you are innocent, then Allah will soon reveal your innocence, and if you have committed a sin, then repent to Allah and ask Him to forgive you, for when a person confesses his sin and asks Allah for forgiveness, Allah accepts his repentance.' When Allah's Apostle finished his speech my tears ceased completely and there remained not even a single drop of it. I requested my father to reply to Allah's Apostle on my behalf. My father said, By Allah, I do not know what to say to Allah's Apostle.' I said to my mother, 'Talk to Allah's Apostle on my behalf.' She said, 'By Allah, I do not know what to say to Allah's Apostle.

I was a young girl and did not have much knowledge of the Quran. I said. 'I know, by Allah, that you have listened to what people are saying and that has been planted in your minds and you have taken it as a truth. Now, if I told you that I am innocent and Allah knows that I am innocent, you would not believe me and if I confessed to you falsely that I am guilty, and Allah knows that I am innocent you would believe me. By Allah, I don't compare my situation with you except to the situation of Joseph's father (i.e. Jacob) who said, 'So (for me) patience is most fitting against that which you assert and it is Allah (Alone) whose help can be sought.' Then I turned to the other side of my bed hoping that Allah would prove my innocence. By Allah I never thought that Allah would reveal Divine Inspiration in my case, as I considered myself too inferior to be talked of in the Holy Qur'an. I had hoped that Allah's Apostle might have a dream in which Allah would prove my innocence. By Allah, Allah's Apostle had not got up and nobody had left the house before the Divine Inspiration came to Allah's Apostle. So, there overtook him the same state which used to overtake him, (when he used to have, on being inspired divinely). He was sweating so much so that the drops of the sweat were dropping like pearls though it was a (cold) wintry day. When that state of Allah's Apostle was over, he was smiling and the first word he said, 'Aisha! Thank Allah, for Allah has declared your innocence.' My mother told me to go to Allah's Apostle . I replied, 'By Allah I will not go to him and will not thank but Allah.' So Allah revealed: "Verily! They who spread the slander are a gang among you . . ." (24.11)

When Allah gave the declaration of my Innocence, Abu Bakr, who used to provide for Mistah bin Uthatha for he was his relative, said, 'By Allah, I will never provide Mistah with anything because of what he said about Aisha.' But Allah later revealed: --

"And let not those who are good and wealthy among you swear not to help their kinsmen, those in need and those who left their homes in Allah's Cause. Let them forgive and overlook. Do you not wish that Allah should forgive you? Verily! Allah is Oft-forgiving, Most Merciful." (24.22) After that Abu Bakr said, 'Yes ! By Allah! I like that Allah should forgive me,' and resumed helping Mistah whom he used to help before.

Allah's Apostle also asked Zainab bint Jahsh (i.e. the Prophet's wife about me saying, 'What do you know and what did you see?' She replied, 'O Allah's Apostle! I refrain to claim hearing or seeing what I have not heard or seen. By Allah, I know nothing except goodness about Aisha." Aisha further added "Zainab was competing with me (in her beauty and the Prophet's love), yet Allah protected her (from being malicious), for she had piety."


Bukhari :: Witnesses :: [3.48.830]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 830

Narrated Abu Bakra:

A man praised another man in front of the Prophet . The Prophet said to him, "Woe to you, you have cut off your companion's neck, you have cut off your companion's neck," repeating it several times and then added, "Whoever amongst you has to praise his brother should say, 'I think that he is so and so, and Allah knows exactly the truth, and I do not confirm anybody's good conduct before Allah, but I think him so and so,' if he really knows what he says about him."


Bukhari :: Witnesses :: [3.48.831]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 831

Narrated Abu Musa Al-Ashari:

The Prophet heard someone praising another and exaggerating in his praise. The Prophet said, "You have ruined or cut the man's back (by praising him so much).


Bukhari :: Witnesses :: [3.48.832]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 832

Narrated Ibn 'Umar:

Allah's Apostle called me to present myself in front of him or the eve of the battle of Uhud, while I was fourteen years of age at that time, and he did not allow me to take part in that battle, but he called me in front of him on the eve of the battle of the Trench when I was fifteen years old, and he allowed me (to join the battle)." Nafi' said, "I went to 'Umar bin 'Abdul Aziz who was Caliph at that time and related the above narration to him, He said, "This age (fifteen) is the limit between childhood and manhood," and wrote to his governors to give salaries to those who reached the age of fifteen.


Bukhari :: Witnesses :: [3.48.833]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 833

Narrated Abu Said Al-Khudri:

The Prophet said, "Bath on Friday is compulsory for those who have attained the age of puberty."


Bukhari :: Witnesses :: [3.48.834]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 834

Narrated Abdullah:

Allah's Apostle said, "If somebody takes a false oath in order to get the property of a Muslim (unjustly) by that oath, then Allah will be angry with him when he will meet Him." Al-Ash'ath informed me, "By Allah! This was said regarding me. There was a dispute about a piece of land between me and a man from the Jews who denied my right. I took him to the Prophet. Allah's Apostle asked me, 'Do you have an evidence?' I replied in the negative. He said to the Jew, 'Take an oath.' I said, 'O Allah's Apostle! He will surely take an oath and take my property unjustly." So, Allah revealed: "Verily! Those who purchase a little gain at the cost of Allah's covenant and their oaths . . . " (3.77)


Bukhari :: Witnesses :: [3.48.835]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 835

Narrated Ibn Abu Mulaika:

Ibn 'Abbas wrote that the Prophet gave his verdict on the basis of the defendant's oath.


Bukhari :: Witnesses :: [3.48.836]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 836

Narrated Abu Wail:

Abdullah (bin Mas'ud) said, "Whoever takes a (false) oath in order to grab some property (unjustly), Allah will be angry with him when he will meet Him. Allah confirmed that through His Divine Revelation: "Verily! Those who purchase a little gain at the cost of Allah's covenant and their oaths . . . they will have a painful punishment." (3.77)

Al-Ash'ath bin Qais came to us and asked, 'What is Abu Abdur-Rahman (i.e. 'Abdullah) telling you? 'We told him what he was narrating to us. He said, 'He was telling the truth; this Divine Verse was revealed in connection with me. There was a dispute between me and another man about something and the case was filed before Allah's Apostle who said, 'Produce your two witnesses or else the defendant is to take an oath.' I said, The defendant will surely take a (false) oath caring for nothing.' The Prophet said, 'Whoever takes a false oath in order to grab (other's) property, then Allah will be angry with him when he will meet Him.' Then Allah revealed its confirmation. Al-Ashath then recited the above Divine Verse." (3.77)


Bukhari :: Witnesses :: [3.48.837]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 837

Narrated Ibn Abbas:

Hilal bin Umaiya accused his wife before the Prophet of committing illegal sexual intercourse with Sharik bin Sahma.' The Prophet said, "Produce a proof, or else you would get the legal punishment (by being lashed) on your back." Hilal said, "O Allah's Apostle! If anyone of us saw another man over his wife, would he go to search for a proof." The Prophet went on saying, "Produce a proof or else you would get the legal punishment (by being lashed) on your back." The Prophet then mentioned the narration of Lian (as in the Holy Book). (Surat-al-Nur: 24)


Bukhari :: Witnesses :: [3.48.838]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 838

Narrated Abu Huraira: Allah's Apostle said, "There are three persons whom Allah will neither talk to nor look at, nor purify from (the sins), and they will have a painful punishment. (They are):

(1) A man possessed superfluous water on a way and he withheld it from the travelers.

(2) a man who gives a pledge of allegiance to a Muslim ruler and gives it only for worldly gains. If the ruler gives him what he wants, he remains obedient to It, otherwise he does not abide by it, and

(3) a man bargains with another man after the Asr prayer and the latter takes a false oath in the Name of Allah) claiming that he has been offered so much for the thing and the former (believes him and) buys it."


Bukhari :: Witnesses :: [3.48.839]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 839

Narrated Ibn Mas'ud:

The Prophet said, "Whoever takes a (false) oath in order to grab (others) property, then Allah will be angry with him when he will meet Him."


Bukhari :: Witnesses :: [3.48.840]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 840

Narrated Abu Huraira:

The Prophet asked some people to take an oath, and they hurried for it. The Prophet ordered that lots should be drawn amongst them as to who would take an oath first.


Bukhari :: Witnesses :: [3.48.841]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 841

Narrated 'Abdullah bin Abu Aufa:

A man displayed some goods in the market and took a false oath that he had been offered so much for them though he was not offered that amount Then the following Divine Verse was revealed:-- "Verily! Those who purchase a little gain at the cost of Allah's covenant and their oaths . . . Will get painful punishment." (3.77) Ibn Abu Aufa added, "Such person as described above is a treacherous Riba-eater (i.e. eater of usury).


Bukhari :: Witnesses :: [3.48.842]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 842

Narrated Abu Wail from Abdullah:

The Prophet said, "Whoever takes a false oath in order to grab another man's (or his brother's) property, then Allah will be angry with him when he will meet him." Then Allah confirmed this by revealing the Divine Verse: "Verily! Those who purchase a little gain at the cost of Allah's Covenant and their oaths . . . Will get painful punishment." (3.77) Al-Ash'ath met me and asked, "What did 'Abdullah tell you today?" I said, "So and so." He said, "The Verse was revealed regarding my case."


Bukhari :: Witnesses :: [3.48.843]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 843

Narrated Talha bin 'Ubaidullah:

A man came to Allah's Apostle asking him about Islam, Allah's Apostle said, "You have to offer five compulsory prayers in a day and a night (24 hours)." The man asked, "Is there any more compulsory prayers for me?" Allah's Apostle said, "No, unless you like to offer Nawafil (i.e. optional prayers)." Allah's Apostle then added, "You have to observe fasts during the month of Ramadan." The man said, "Am I to fast any other days?' Allah's Apostle said, "No, unless you wish to observe the optional fast voluntarily." Then Allah's Apostle told him about the compulsory Zakat. The man asked, "Do I have to give anything besides?" Allah's Apostle said, "No, unless you wish to give in charity voluntarily." So, the man departed saying, "By Allah I will neither do more nor less than that." Allah's Apostle said, "If he has said the truth he will be successful."


Bukhari :: Witnesses :: [3.48.844]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 844

Narrated Abdullah:

The Prophet said, "Whoever has to take an oath should swear by Allah or remain silent." (i.e. He should not swear by other than Allah.)


Bukhari :: Witnesses :: [3.48.845]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 845

Narrated Um Salama:

Once Allah's Apostle said, "You people present your cases to me and some of you may be more eloquent and persuasive in presenting their argument. So, if I give some one's right to another (wrongly) because of the latter's (tricky) presentation of the case, I am really giving him a piece of fire; so he should not take it."


Bukhari :: Witnesses :: [3.48.846]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 846

Narrated Abdullah bin Abbas:

Abu Sufyan told me that Heraclius said to him, "When I enquired you what he (i.e. Muhammad) ordered you, you replied that he ordered you to establish the prayer, to speak the truth, to be chaste, to keep promises and to pay back trusts." Then Heraclius added, "These are really the qualities of a prophet."


Bukhari :: Witnesses :: [3.48.847]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 847

Narrated Abu Huraira:

Allah's Apostle said, "The signs of a hypocrite are three:

(1) whenever he speaks, he tells a lie,

(2) whenever he is entrusted, he proves to be dishonest,

(3) whenever he promises, he breaks his promise.


Bukhari :: Witnesses :: [3.48.848]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 848

Narrated Muhammad bin Ali:

Jabir bin Abdullah said, "When the Prophet died, Abu Bakr received some property from Al-Ala bin Al-Hadrami. Abu Bakr said to the people, "Whoever has a money claim on the Prophet, or was promised something by him, should come to us (so that we may pay him his right)." Jabir added, "I said (to Abu Bakr), Allah's Apostle promised me that he would give me this much, and this much, and this much (spreading his hands three times)." Jabir added, "Abu Bakr counted for me and handed me five-hundred (gold pieces), and then five-hundred, and then five-hundred."


Bukhari :: Witnesses :: [3.48.849]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 849

Narrated Said bin Jubair:

A Jew from Hira asked me which one of the two periods Musa (i.e. Prophet Moses) completed. I said, "I don't know, (but wait) till I see the most learned 'Arab and enquire him about it." So, I went to Ibn 'Abbas and asked him. He replied, "Moses completed the longer and better period." Ibn 'Abbas added, "No doubt, an apostle of Allah always does what he says."


Bukhari :: Witnesses :: [3.48.850]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 850

Narrated Ubaidullah bin Abdullah bin Utba:

Ibn Abbas said, "O Muslims? How do you ask the people of the Scriptures, though your Book (i.e. the Quran) which was revealed to His Prophet is the most recent information from Allah and you recite it, the Book that has not been distorted? Allah has revealed to you that the people of the scriptures have changed with their own hands what was revealed to them and they have said (as regards their changed Scriptures): This is from Allah, in order to get some worldly benefit thereby." Ibn Abbas added: "Isn't the knowledge revealed to you sufficient to prevent you from asking them? By Allah I have never seen any one of them asking (Muslims) about what has been revealed to you."


Bukhari :: Witnesses :: [3.48.851]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 851

Narrated An-Nu'man bin Bashir:

The Prophet said, "The example of the person abiding by Allah's orders and limits (or the one who abides by the limits and regulations prescribed by Allah) in comparison to the one who do wrong and violate Allah's limits and orders is like the example of people drawing lots for seats in a boat. Some of them got seats in the upper part while the others in the lower part ; those in the, lower part have to pass by those in the upper one to get water, and that troubled the latter. One of them (i.e. the people in the lower part) took an axe and started making a hole in the bottom of the boat. The people of the upper part came and asked him, (saying), 'What is wrong with you?' He replied, "You have been troubled much by my (coming up to you), and I have to get water.' Now if they prevent him from doing that they will save him and themselves, but if they leave him (to do what he wants), they will destroy him and themselves."


Bukhari :: Witnesses :: [3.48.852]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 852

Narrated Um Al-Ala:

That when the Ansar drew lots as to which of the emigrants should dwell with which of the Ansar, the name of Uthman bin Mazun came out (to be in their lot). Um Al-Ala further said, "Uthman stayed with us, and we nursed him when he got sick, but he died. We shrouded him in his clothes, and Allah's Apostle came to our house and I said, (addressing the dead 'Uthman), 'O Abu As-Sa'ib! May Allah be merciful to you. I testify that Allah has blessed you.' The Prophet said to me, "How do you know that Allah has blessed him?" I replied, 'I do not know O Allah's Apostle! May my parents be sacrificed for you.' Allah's Apostle said, 'As regards Uthman, by Allah he has died and I really wish him every good, yet, by Allah, although I am Allah's Apostle, I do not know what will be done to him.' Um Al-Ala added, 'By Allah I shall never attest the piety of anybody after him. And what Allah's Apostles said made me sad." Um Al-Ala further said, "Once I slept and saw in a dream, a flowing stream for Uthman. So I went to Allah's Apostle and told him about it, he said, 'That is (the symbol of) his deeds."


Bukhari :: Witnesses :: [3.48.853]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 853

Narrated Aisha:

Whenever Allah's Apostle intended to go on a journey, he used to draw lots among his wives and would take with him the one on whom the lot fell. He also used to fix for everyone of his wives a day and a night, but Sauda bint Zam'a gave her day and night to 'Aisha, the wife of the Prophet intending thereby to please Allah's Apostle.


Bukhari :: Witnesses :: [3.48.854]

Witnesses

Bukhari :: Book 3 :: Volume 48 :: Hadith 854

Narrated Abu Huraira:

Allah's Apostle said, "If the people knew what is the reward of making the call (for the prayer) and (of being in) the first row (in the prayer), and if they found no other way to get this privilege except by casting lots, they would certainly cast lots for it. If they knew the reward of the noon prayer, they would race for it, and if they knew the reward of the morning (i.e. Fajr) and Isha prayers, they would present themselves for the prayer even if they had to crawl to reach there.


Bukhari :: Peacemaking :: [3.49.855]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 855

Narrated Sahl bin Sad:

There was a dispute amongst the people of the tribe of Bani 'Amr bin 'Auf. The Prophet went to them along with some of his companions in order to make peace between them. The time for the prayer became due but the Prophet did not turn up; Bilal pronounced the Adhan (i.e. call) for the prayer but the Prophet did not turn up, so Bilal went to Abu Bakr and said, "The time for the prayer is due and the Prophet i detained, would you lead the people in the prayer?" Abu Bakr replied, "Yes, you wish." So, Bilal pronounced the Iqama of the prayer and Abu Bakr went ahead (to lead the prayer), but the Prophet came walking among the rows till he joined the first row. The people started clapping and they clapped too much, and Abu Bakr used not to look hither and thither in the prayer, but he turned round and saw the Prophet standing behind him. The Prophet beckoned him with his hand to keep on praying where he was. Abu Bakr raised his hand and praised Allah and then retreated till he came in the (first) row, and the Prophet went ahead and lead the people in the prayer. When the Prophet finished the prayer, he turned towards the people and said, "O people! When something happens to you during the prayer, you start clapping. Really clapping is (permissible) for women only. If something happens to one of you in his prayer, he should say: 'Subhan Allah', (Glorified be Allah), for whoever hears him (saying so) will direct his attention towards him. O Abu Bakr! What prevented you from leading the people in the prayer when I beckoned to you (to continue)?" Abu Bakr replied, "It did not befit the son of Abu Quhafa to lead the prayer in front of the Prophet.


Bukhari :: Peacemaking :: [3.49.856]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 856

Narrated Anas:

It was said to the Prophet "Would that you see Abdullah bin Ubai." So, the Prophet went to him, riding a donkey, and the Muslims accompanied him, walking on salty barren land. When the Prophet reached 'Abdullah bin Ubai, the latter said, "Keep away from me! By Allah, the bad smell of your donkey has harmed me." On that an Ansari man said (to 'Abdullah), "By Allah! The smell of the donkey of Allah's Apostle is better than your smell." On that a man from 'Abdullah's tribe got angry for 'Abdullah's sake, and the two men abused each other which caused the friends of the two men to get angry, and the two groups started fighting with sticks, shoes and hands. We were informed that the following Divine Verse was revealed (in this concern):-- "And if two groups of Believers fall to fighting then, make peace between them." (49.9)


Bukhari :: Peacemaking :: [3.49.857]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 857

Narrated Um Kulthum bint Uqba:

That she heard Allah's Apostle saying, "He who makes peace between the people by inventing good information or saying good things, is not a liar."


Bukhari :: Peacemaking :: [3.49.858]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 858

Narrated Sahl bin Sad:

Once the people of Quba fought with each other till they threw stones on each other. When Allah's Apostle was informed about it, he said, "Let us go to bring about a reconciliation between them."


Bukhari :: Peacemaking :: [3.49.859]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 859

Narrated Aisha:

The following Verse: If a woman fears cruelty or desertion on her husband's part (i.e. the husband notices something unpleasant about his wife, such as old age or the like, and wants to divorce her, but she asks him to keep her and provide for her as he wishes). (4.128) "There is no blame on them if they reconcile on such basis."


Bukhari :: Peacemaking :: [3.49.860]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 860

Narrated Abu Huraira and Zaid bin Khalid Al-Juhani:

A bedouin came and said, "O Allah's Apostle! Judge between us according to Allah's Laws." His opponent got up and said, "He is right. Judge between us according to Allah's Laws." The bedouin said, "My son was a laborer working for this man, and he committed illegal sexual intercourse with his wife. The people told me that my son should be stoned to death; so, in lieu of that, I paid a ransom of one hundred sheep and a slave girl to save my son. Then I asked the learned scholars who said, "Your son has to be lashed one-hundred lashes and has to be exiled for one year." The Prophet said, "No doubt I will judge between you according to Allah's Laws. The slave-girl and the sheep are to go back to you, and your son will get a hundred lashes and one year exile." He then addressed somebody, "O Unais! go to the wife of this (man) and stone her to death" So, Unais went and stoned her to death.


Bukhari :: Peacemaking :: [3.49.861]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 861

Narrated Aisha:

Allah's Apostle said, "If somebody innovates something which is not in harmony with the principles of our religion, that thing is rejected."


Bukhari :: Peacemaking :: [3.49.862]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 862

Narrated Al-Bara bin 'Azib:

When Allah's Apostle concluded a peace treaty with the people of Hudaibiya, Ali bin Abu Talib wrote the document and he mentioned in it, "Muhammad, Allah's Apostle ." The pagans said, "Don't write: 'Muhammad, Allah's Apostle', for if you were an apostle we would not fight with you." Allah's Apostle asked Ali to rub it out, but Ali said, "I will not be the person to rub it out." Allah's Apostle rubbed it out and made peace with them on the condition that the Prophet and his companions would enter Mecca and stay there for three days, and that they would enter with their weapons in cases.


Bukhari :: Peacemaking :: [3.49.863]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 863

Narrated Al-Bara:

When the Prophet intended to perform 'Umra in the month of Dhul-Qada, the people of Mecca did not let him enter Mecca till he settled the matter with them by promising to stay in it for three days only. When the document of treaty was written, the following was mentioned: 'These are the terms on which Muhammad, Allah's Apostle agreed (to make peace).' They said, "We will not agree to this, for if we believed that you are Allah's Apostle we would not prevent you, but you are Muhammad bin 'Abdullah." The Prophet said, "I am Allah's Apostle and also Muhammad bin 'Abdullah." Then he said to 'Ali, "Rub off (the words) 'Allah's Apostle' ", but 'Ali said, "No, by Allah, I will never rub off your name." So, Allah's Apostle took the document and wrote, 'This is what Muhammad bin 'Abdullah has agreed upon: No arms will be brought into Mecca except in their cases, and nobody from the people of Mecca will be allowed to go with him (i.e. the Prophet ) even if he wished to follow him and he (the Prophet ) will not prevent any of his companions from staying in Mecca if the latter wants to stay.' When the Prophet entered Mecca and the time limit passed, the Meccans went to 'Ali and said, "Tell your Friend (i.e. the Prophet ) to go out, as the period (agreed to) has passed." So, the Prophet went out of Mecca. The daughter of Hamza ran after them (i.e. the Prophet and his companions), calling, "O Uncle! O Uncle!" 'Ali received her and led her by the hand and said to Fatima, "Take your uncle's daughter." Zaid and Ja'far quarrel ed about her. 'Ali said, "I have more right to her as she is my uncle's daughter." Ja'far said, "She is my uncle's daughter, and her aunt is my wife." Zaid said, "She is my brother's daughter." The Prophet judged that she should be given to her aunt, and said that the aunt was like the mother. He then said to 'All, "You are from me and I am from you", and said to Ja'far, "You resemble me both in character and appearance", and said to Zaid, "You are our brother (in faith) and our freed slave."


Bukhari :: Peacemaking :: [3.49.864]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 864

Narrated Ibn 'Umar:

Allah's Apostle set out for the 'Umra but the pagans of Quraish prevented him from reaching the Ka'ba. So, he slaughtered his sacrifice and got his head shaved at Al-Hudaibiya, and agreed with them that he would perform 'Umra the following year and would not carry weapons except swords and would not stay in Mecca except for the period they al lowed. So, the Prophet performed the 'Umra in the following year and entered Mecca according to the treaty, and when he stayed for three days, the pagans ordered him to depart, and he departed.


Bukhari :: Peacemaking :: [3.49.865]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 865

Narrated Sahl bin Abu Hathma:

Abdullah bin Sahl and Muhaiyisa bin Mas'ud bin Zaid went to Khaibar when it had a peace treaty (with the Muslims).


Bukhari :: Peacemaking :: [3.49.866]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 866

Narrated Anas:

Ar-Rabi, the daughter of An-Nadr broke the tooth of a girl, and the relatives of Ar-Rabi' requested the girl's relatives to accept the Irsh (compensation for wounds etc.) and forgive (the offender), but they refused. So, they went to the Prophet who ordered them to bring about retaliation. Anas bin An-Nadr asked, "O Allah"; Apostle! Will the tooth of Ar-Rabi' be broken? No, by Him Who has sent you with the Truth, her tooth will not be broken." The Prophet said, "O Anas! Allah"; law ordains retaliation." Later the relatives of the girl agreed and forgave her. The Prophet said, "There are some of Allah's slaves who, if they take an oath by Allah, are responded to by Allah i.e. their oath is fulfilled). Anas added, "The people agreed and accepted the Irsh."


Bukhari :: Peacemaking :: [3.49.867]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 867

Narrated Al-Hasan Al-Basri:

By Allah, Al-Hasan bin Ali led large battalions like mountains against Muawiya. Amr bin Al-As said (to Muawiya), "I surely see battalions which will not turn back before killing their opponents." Muawiya who was really the best of the two men said to him, "O 'Amr! If these killed those and those killed these, who would be left with me for the jobs of the public, who would be left with me for their women, who would be left with me for their children?" Then Muawiya sent two Quraishi men from the tribe of 'Abd-i-Shams called 'Abdur Rahman bin Sumura and Abdullah bin 'Amir bin Kuraiz to Al-Hasan saying to them, "Go to this man (i.e. Al-Hasan) and negotiate peace with him and talk and appeal to him." So, they went to Al-Hasan and talked and appealed to him to accept peace. Al-Hasan said, "We, the offspring of 'Abdul Muttalib, have got wealth and people have indulged in killing and corruption (and money only will appease them)." They said to Al-Hasan, "Muawiya offers you so and so, and appeals to you and entreats you to accept peace." Al-Hasan said to them, "But who will be responsible for what you have said?" They said, "We will be responsible for it." So, what-ever Al-Hasan asked they said, "We will be responsible for it for you." So, Al-Hasan concluded a peace treaty with Muawiya. Al-Hasan (Al-Basri) said: I heard Abu Bakr saying, "I saw Allah's Apostle on the pulpit and Al-Hasan bin 'Ali was by his side. The Prophet was looking once at the people and once at Al-Hasan bin 'Ali saying, 'This son of mine is a Saiyid (i.e. a noble) and may Allah make peace between two big groups of Muslims through him."


Bukhari :: Peacemaking :: [3.49.868]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 868

Narrated Aisha:

Once Allah's Apostle heard the loud voices of some opponents quarreling at the door. One of them was appealing to the other to deduct his debt and asking him to be lenient but the other was saying, "By Allah I will not do so." Allah's Apostle went out to them and said, "Who is the one who was swearing by Allah that he would not do a favor?" That man said, "I am that person, O Allah's Apostle! I will give my opponent whatever he wishes."


Bukhari :: Peacemaking :: [3.49.869]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 869

Narrated Abdullah bin Kab bin Malik from Kab bin Malik:

Abdullah bin Abu Hadrad Al-Aslami owed Kab bin Malik some money. One day the latter met the former and demanded his right, and their voices grew very loud. The Prophet passed by them and said, "O Ka'b," beckoning with his hand as if intending to say, "Deduct half the debts." So, Kab took half what the other owed him and remitted the other half.


Bukhari :: Peacemaking :: [3.49.870]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 870

Narrated Abu Huraira:

Allah's Apostle said, "There is a Sadaqa to be given for every joint of the human body; and for every day on which the sun rises there is a reward of a Sadaqa (i.e. charitable gift) for the one who establishes justice among people."


Bukhari :: Peacemaking :: [3.49.871]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 871

Narrated Urwa bin Az-Zubair:

Az-Zubair told me that he quarrelled with an Ansari man who had participated in (the battle of) Badr in front of Allah's Apostle about a water stream which both of them used for irrigation. Allah's Apostle said to Az-Zubair, "O Zubair! Irrigate (your garden) first, and then let the water flow to your neighbor." The Ansari became angry and said, "O Allah's Apostle! Is it because he is your cousin?" On that the complexion of Allah's Apostle changed (because of anger) and said (to Az-Zubair), "I irrigate (your garden) and then with-hold the water till it reaches the walls (surrounding the palms)." So, Allah's Apostle gave Az-Zubair his full right. Before that Allah's Apostle had given a generous judgment beneficial for Az-Zubair and the Ansari, but when the Ansan irritated Allah's Apostle he gave Az-Zubair his full right according to the evident law. Az-Zubair said, "By Allah ! I think the following Verse was revealed concerning that case: "But no by your Lord They can have No faith Until they make you judge In all disputes between them." (4.65)


Bukhari :: Peacemaking :: [3.49.872]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 872

Narrated Jabir bin Abdullah:

My father died and was in debt. I suggested that his creditors take the fruits (i.e. dates) of my garden in lieu of the debt of my father, but they refused the offer, as they thought that it would not cover the full debt. So, I went to the Prophet and told him about it. He said (to me), "When you pluck the dates and collect them in the Mirbad (i.e. a place where dates are dried), call me (Allah's Apostle)." Finally he came accompanied by Abu Bakr and 'Umar and sat on the dates and invoked Allah to bless them. Then he said, "Call your creditors and give them their full rights." So, I paid all my father's creditors in full and yet thirteen extra Wasqs of dates remained, seven of which were 'Ajwa and six were Laun or six of which were Ajwa and seven were Laun. I met Allah's Apostle at sunset and informed him about it. On that he smiled and said, "Go to Abu Bakr and 'Umar and tell them about it." They said, "We perceived that was going to happen, as Allah's Apostle did what he did."


Bukhari :: Peacemaking :: [3.49.873]

Peacemaking

Bukhari :: Book 3 :: Volume 49 :: Hadith 873

Narrated Abdullah bin Kab:

That Ka'b bin Malik told him that in the lifetime of Allah's Apostle he demanded his debt from Ibn Abu Hadrad in the Mosque. Their voices grew louder till Allah's Apostle heard them while he was in his house. So he lifted the curtain of his room and called Ka'b bin Malik saying, "O Ka'b!" He replied, "Labbaik! O Allah's Apostle!" He beckoned to him with his hand suggesting that he deduct half the debt. Ka'b said, "I agree, O Allah's Apostle!" Allah's Apostle then said (to Ibn Abu Hadrad), "Get up and pay him the rest."


Bukhari :: Conditions :: [3.50.874]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 874

Narrated Marwan and al-Miswar bin Makhrama:

(from the companions of Allah's Apostle) When Suhail bin Amr agreed to the Treaty (of Hudaibiya), one of the things he stipulated then, was that the Prophet should return to them (i.e. the pagans) anyone coming to him from their side, even if he was a Muslim; and would not interfere between them and that person. The Muslims did not like this condition and got disgusted with it. Suhail did not agree except with that condition. So, the Prophet agreed to that condition and returned Abu Jandal to his father Suhail bin 'Amr. Thenceforward the Prophet returned everyone in that period (of truce) even if he was a Muslim. During that period some believing women emigrants including Um Kalthum bint Uqba bin Abu Muait who came to Allah's Apostle and she was a young lady then. Her relative came to the Prophet and asked him to return her, but the Prophet did not return her to them for Allah had revealed the following Verse regarding women:

"O you who believe! When the believing women come to you as emigrants. Examine them, Allah knows best as to their belief, then if you know them for true believers, Send them not back to the unbelievers, (for) they are not lawful (wives) for the disbelievers, Nor are the unbelievers lawful (husbands) for them (60.10)

Narrated 'Urwa: Aisha told me, "Allah's Apostle used to examine them according to this Verse: "O you who believe! When the believing women come to you, as emigrants test them . . . for Allah is Oft-Forgiving, Most Merciful." (60.10-12) Aisha said, "When any of them agreed to that condition Allah's Apostle would say to her, 'I have accepted your pledge of allegiance.' He would only say that, but, by Allah he never touched the hand of any women (i.e. never shook hands with them) while taking the pledge of allegiance and he never took their pledge of allegiance except by his words (only)."


Bukhari :: Conditions :: [3.50.875]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 875

Narrated Jarir:

When I gave the pledge of allegiance to Allah's Apostle and he stipulated that I should give good advice to every Muslim.


Bukhari :: Conditions :: [3.50.876]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 876

Narrated Jabir bin 'Abdullah:

I gave the pledge of allegiance to Allah's Apostle for offering the prayers perfectly paying the Zakat and giving good advice to every Muslim.


Bukhari :: Conditions :: [3.50.877]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 877

Narrated Abdullah bin Umar:

Allah's Apostle said, "If someone sells pollinated date-palms, their fruits will be for the seller, unless the buyer stipulates the contrary."


Bukhari :: Conditions :: [3.50.878]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 878

Narrated Urwa:

Aisha told me that Buraira came to seek her help in writing for emancipation and at that time she had not paid any part of her price. 'Aisha said to her, "Go to your masters and if they agree that I will pay your price (and free you) on condition that your Wala' will be for me, I will pay the money." Buraira told her masters about that, but they refused, and said, "If 'Aisha wants to do a favor she could, but your Wala will be for us." Aisha informed Allah's Apostle of that and he said to her, "Buy and manumit Buraira as the Wala' will go to the manumitted."


Bukhari :: Conditions :: [3.50.879]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 879

Narrated Jabir:

While I was riding a (slow) and tired camel, the Prophet passed by and beat it and prayed for Allah's Blessings for it. The camel became so fast as it had never been before. The Prophet then said, "Sell it to me for one Uqiyya (of gold)." I said, "No." He again said, "Sell it to me for one Uqiyya (of gold)." I sold it and stipulated that I should ride it to my house. When we reached (Medina) I took that camel to the Prophet and he gave me its price. I returned home but he sent for me (and when I went to him) he said, "I will not take your camel. Take your camel as a gift for you." (Various narrations are mentioned here with slight variations in expressions relating the condition that Jabir had the right to ride the sold camel up to Medina).


Bukhari :: Conditions :: [3.50.880]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 880

Narrated Abu Huraira:

The Ansar said to the Prophet, "Divide our date-palms between us and our emigrant brothers." The Prophet said, "No." The Ansar said to the emigrants, "You may do the labor (in our gardens) and we will share the fruits with you." The emigrants said, "We hear and obey."


Bukhari :: Conditions :: [3.50.881]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 881

Narrated Abdullah bin Umar:

Allah's Apostle gave the land of Khaibar to the Jews on the condition that they would work on it and cultivate it and they would get half of its yield.


Bukhari :: Conditions :: [3.50.882]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 882

Narrated Uqba bin Amir:

Allah's Apostle said, "From among all the conditions which you have to fulfill, the conditions which make it legal for you to have sexual relations (i.e. the marriage contract) have the greatest right to be fulfilled."


Bukhari :: Conditions :: [3.50.883]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 883

Narrated Rafi bin Khadij:

We used to work on the fields more than the other Ansar, and we used to rent the land (for the yield of a specific portion of it). But sometimes that portion or the rest of the land did not give any yield, so we were forbidden (by the Prophet ) to follow such a system, but we were allowed to rent the land for money.


Bukhari :: Conditions :: [3.50.884]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 884

Narrated Abu Huraira:

The Prophet said, "No town-dweller should sell for a bedouin. Do not practice Najsh (i.e. Do not offer a high price for a thing which you do not want to buy, in order to deceive the people). No Muslim should offer more for a thing already bought by his Muslim brother, nor should he demand the hand of a girl already engaged to another Muslim. A Muslim woman shall not try to bring about The divorce of her sister (i.e. another Muslim woman) in order to take her place herself."


Bukhari :: Conditions :: [3.50.885]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 885

Narrated Abu Huraira and Zaid bin Khalid Al-Juhani:

A bedouin came to Allah's Apostle and said, "O Allah's apostle! I ask you by Allah to judge My case according to Allah's Laws." His opponent, who was more learned than he, said, "Yes, judge between us according to Allah's Laws, and allow me to speak." Allah's Apostle said, "Speak." He (i .e. the bedouin or the other man) said, "My son was working as a laborer for this (man) and he committed illegal sexual intercourse with his wife. The people told me that it was obligatory that my son should be stoned to death, so in lieu of that I ransomed my son by paying one hundred sheep and a slave girl. Then I asked the religious scholars about it, and they informed me that my son must be lashed one hundred lashes, and be exiled for one year, and the wife of this (man) must be stoned to death." Allah's Apostle said, "By Him in Whose Hands my soul is, I will judge between you according to Allah's Laws. The slave-girl and the sheep are to be returned to you, your son is to receive a hundred lashes and be exiled for one year. You, Unais, go to the wife of this (man) and if she confesses her guilt, stone her to death." Unais went to that woman next morning and she confessed. Allah's Apostle ordered that she be stoned to death.


Bukhari :: Conditions :: [3.50.886]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 886

Narrated Aiman Al-Makki:

rs had stipulated that her Wala would be for them.' The Prophet said,


Bukhari :: Conditions :: [3.50.887]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 887

Narrated Abu Huraira:

Allah's Apostle forbade (1) the meeting of the caravan (of goods) on the way, (2) and that a residing person buys for a bedouin, (3) and that a woman stipulates the divorce of the wife of the would-be husband, (4) and that a man tries to cause the cancellation of a bargain concluded by another. He also forbade An-Najsh (see Hadith 824) and that one withholds the milk in the udder of the animal so that he may deceive people on selling it.


Bukhari :: Conditions :: [3.50.888]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 888

Narrated Ubai bin Kab:

Allah's Apostle said, "Moses the Apostle of Allah," and then he narrated the whole story about him. Al-Khadir said to Moses, "Did not I tell you that you can have no patience with me." (18.72). Moses then violated the agreement for the first time because of forgetfulness, then Moses promised that if he asked Al-Khadir about anything, the latter would have the right to desert him. Moses abided by that condition and on the third occasion he intentionally asked Al-Khadir and caused that condition to be applied. The three occasions referred to above are referred to by the following Verses:

"Call me not to account for forgetting And be not hard upon me." (18.73)

"Then they met a boy and Khadir killed him." (18.74)

"Then they proceeded and found a wall which was on the verge of falling and Khadir set it up straight." (18.77)


Bukhari :: Conditions :: [3.50.889]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 889

Narrated Urwa:

Aisha said, "Buraira came to me and said, 'My people (masters) have written the contract for my emancipation for nine Awaq ) of gold) to be paid in yearly installments, one Uqiyya per year; so help me." Aisha said (to her), "If your masters agree, I will pay them the whole sum provided the Wala will be for me." Buraira went to her masters and told them about it, but they refused the offer and she returned from them while Allah's Apostles was sitting. She said, "I presented the offer to them, but they refused unless the Wala' would be for them." When the Prophet heard that and 'Aisha told him about It, he said to her, "Buy Buraira and let them stipulate that her Wala' will be for them, as the Wala' is for the manumitted." 'Aisha did so. After that Allah's Apostle got up amidst the people, Glorified and Praised Allah and said, "What is wrong with some people who stipulate things which are not in Allah's Laws? Any condition which is not in Allah's Laws is invalid even if there were a hundred such conditions. Allah's Rules are the most valid and Allah's Conditions are the most solid. The Wala is for the manumitted."


Bukhari :: Conditions :: [3.50.890]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 890

Narrated Ibn Umar:

When the people of Khaibar dislocated Abdullah bin Umar's hands and feet, Umar got up delivering a sermon saying, "No doubt, Allah's Apostle made a contract with the Jews concerning their properties, and said to them, 'We allow you (to stand in your land) as long as Allah allows you.' Now Abdullah bin Umar went to his land and was attacked at night, and his hands and feet were dislocated, and as we have no enemies there except those Jews, they are our enemies and the only people whom we suspect, I have made up my mind to exile them." When Umar decided to carry out his decision, a son of Abu Al-Haqiq's came and addressed 'Umar, "O chief of the believers, will you exile us although Muhammad allowed us to stay at our places, and made a contract with us about our properties, and accepted the condition of our residence in our land?" 'Umar said, "Do you think that I have forgotten the statement of Allah's Apostle, i.e.: What will your condition be when you are expelled from Khaibar and your camel will be carrying you night after night?" The Jew replied, "That was joke from Abu-l-Qasim." 'Umar said, "O the enemy of Allah! You are telling a lie." 'Umar then drove them out and paid them the price of their properties in the form of fruits, money, camel saddles and ropes, etc."


Bukhari :: Conditions :: [3.50.891]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 891

Narrated Al-Miswar bin Makhrama and Marwan:

(whose narrations attest each other) Allah's Apostle set out at the time of Al-Hudaibiya (treaty), and when they proceeded for a distance, he said, "Khalid bin Al-Walid leading the cavalry of Quraish constituting the front of the army, is at a place called Al-Ghamim, so take the way on the right." By Allah, Khalid did not perceive the arrival of the Muslims till the dust arising from the march of the Muslim army reached him, and then he turned back hurriedly to inform Quraish. The Prophet went on advancing till he reached the Thaniyya (i.e. a mountainous way) through which one would go to them (i.e. people of Quraish). The she-camel of the Prophet sat down. The people tried their best to cause the she-camel to get up but in vain, so they said, "Al-Qaswa' (i.e. the she-camel's name) has become stubborn! Al-Qaswa' has become stubborn!" The Prophet said, "Al-Qaswa' has not become stubborn, for stubbornness is not her habit, but she was stopped by Him Who stopped the elephant." Then he said, "By the Name of Him in Whose Hands my soul is, if they (i.e. the Quraish infidels) ask me anything which will respect the ordinances of Allah, I will grant it to them."

The Prophet then rebuked the she-camel and she got up. The Prophet changed his way till he dismounted at the farthest end of Al-Hudaibiya at a pit (i.e. well) containing a little water which the people used in small amounts, and in a short while the people used up all its water and complained to Allah's Apostle; of thirst. The Prophet took an arrow out of his arrow-case and ordered them to put the arrow in that pit. By Allah, the water started and continued sprouting out till all the people quenched their thirst and returned with satisfaction. While they were still in that state, Budail bin Warqa-al-Khuza'i came with some persons from his tribe Khuza'a and they were the advisers of Allah's Apostle who would keep no secret from him and were from the people of Tihama. Budail said, "I left Kab bin Luai and 'Amir bin Luai residing at the profuse water of Al-Hudaibiya and they had milch camels (or their women and children) with them, and will wage war against you, and will prevent you from visiting the Kaba." Allah's Apostle said, "We have not come to fight anyone, but to perform the 'Umra. No doubt, the war has weakened Quraish and they have suffered great losses, so if they wish, I will conclude a truce with them, during which they should refrain from interfering between me and the people (i.e. the 'Arab infidels other than Quraish), and if I have victory over those infidels, Quraish will have the option to embrace Islam as the other people do, if they wish; they will at least get strong enough to fight. But if they do not accept the truce, by Allah in Whose Hands my life is, I will fight with them defending my Cause till I get killed, but (I am sure) Allah will definitely make His Cause victorious." Budail said, "I will inform them of what you have said." So, he set off till he reached Quraish and said, "We have come from that man (i.e. Muhammad) whom we heard saying something which we will disclose to you if you should like." Some of the fools among Quraish shouted that they were not in need of this information, but the wiser among them said, "Relate what you heard him saying." Budail said, "I heard him saying so-and-so," relating what the Prophet had told him.

Urwa bin Mas'ud got up and said, "O people! Aren't you the sons? They said, "Yes." He added, "Am I not the father?" They said, "Yes." He said, "Do you mistrust me?" They said, "No." He said, "Don't you know that I invited the people of 'Ukaz for your help, and when they refused I brought my relatives and children and those who obeyed me (to help you)?" They said, "Yes." He said, "Well, this man (i.e. the Prophet) has offered you a reasonable proposal, you'd better accept it and allow me to meet him." They said, "You may meet him." So, he went to the Prophet and started talking to him. The Prophet told him almost the same as he had told Budail. Then Urwa said, "O Muhammad! Won't you feel any scruple in extirpating your relations? Have you ever heard of anyone amongst the Arabs extirpating his relatives before you? On the other hand, if the reverse should happen, (nobody will aid you, for) by Allah, I do not see (with you) dignified people, but people from various tribes who would run away leaving you alone." Hearing that, Abu Bakr abused him and said, "Do you say we would run and leave the Prophet alone?" Urwa said, "Who is that man?" They said, "He is Abu Bakr." Urwa said to Abu Bakr, "By Him in Whose Hands my life is, were it not for the favor which you did to me and which I did not compensate, I would retort on you." Urwa kept on talking to the Prophet and seizing the Prophet's beard as he was talking while Al-Mughira bin Shu'ba was standing near the head of the Prophet, holding a sword and wearing a helmet. Whenever Urwa stretched his hand towards the beard of the Prophet, Al-Mughira would hit his hand with the handle of the sword and say (to Urwa), "Remove your hand from the beard of Allah's Apostle." Urwa raised his head and asked, "Who is that?" The people said, "He is Al-Mughira bin Shu'ba." Urwa said, "O treacherous! Am I not doing my best to prevent evil consequences of your treachery?"

Before embracing Islam Al-Mughira was in the company of some people. He killed them and took their property and came (to Medina) to embrace Islam. The Prophet said (to him, "As regards your Islam, I accept it, but as for the property I do not take anything of it. (As it was taken through treason). Urwa then started looking at the Companions of the Prophet. By Allah, whenever Allah's Apostle spat, the spittle would fall in the hand of one of them (i.e. the Prophet's companions) who would rub it on his face and skin; if he ordered them they would carry his orders immediately; if he performed ablution, they would struggle to take the remaining water; and when they spoke to him, they would lower their voices and would not look at his face constantly out of respect. Urwa returned to his people and said, "O people! By Allah, I have been to the kings and to Caesar, Khosrau and An-Najashi, yet I have never seen any of them respected by his courtiers as much as Muhammad is respected by his companions. By Allah, if he spat, the spittle would fall in the hand of one of them (i.e. the Prophet's companions) who would rub it on his face and skin; if he ordered them, they would carry out his order immediately; if he performed ablution, they would struggle to take the remaining water; and when they spoke, they would lower their voices and would not look at his face constantly out of respect." Urwa added, "No doubt, he has presented to you a good reasonable offer, so please accept it." A man from the tribe of Bani Kinana said, "Allow me to go to him," and they allowed him, and when he approached the Prophet and his companions, Allah's Ap le I said, "He is so-and-so who belongs to the tribe that respects the Budn (i.e. camels of the sacrifice). So, bring the Budn in front of him." So, the Budn were brought before him and the people received him while they were reciting Talbiya. When he saw that scene, he said, "Glorified be Allah! It is not fair to prevent these people from visiting the Ka'ba." When he returned to his people, he said, 'I saw the Budn garlanded (with colored knotted ropes) and marked (with stabs on their backs). I do not think it is advisable to prevent them from visiting the Ka'ba." Another person called Mikraz bin Hafs got up and sought their permission to go to Muhammad, and they allowed him, too. When he approached the Muslims, the Prophet said, "Here is Mikraz and he is a vicious man." Mikraz started talking to the Prophet and as he was talking, Suhail bin Amr came.

When Suhail bin Amr came, the Prophet said, "Now the matter has become easy." Suhail said to the Prophet "Please conclude a peace treaty with us." So, the Prophet called the clerk and said to him, "Write: By the Name of Allah, the most Beneficent, the most Merciful." Suhail said, "As for 'Beneficent,' by Allah, I do not know what it means. So write: By Your Name O Allah, as you used to write previously." The Muslims said, "By Allah, we will not write except: By the Name of Allah, the most Beneficent, the most Merciful." The Prophet said, "Write: By Your Name O Allah." Then he dictated, "This is the peace treaty which Muhammad, Allah's Apostle has concluded." Suhail said, "By Allah, if we knew that you are Allah's Apostle we would not prevent you from visiting the Kaba, and would not fight with you. So, write: "Muhammad bin Abdullah." The Prophet said, "By Allah! I am Apostle of Allah even if you people do not believe me. Write: Muhammad bin Abdullah." (Az-Zuhri said, "The Prophet accepted all those things, as he had already said that he would accept everything they would demand if it respects the ordinance of Allah, (i.e. by letting him and his companions perform 'Umra.)" The Prophet said to Suhail, "On the condition that you allow us to visit the House (i.e. Ka'ba) so that we may perform Tawaf around it." Suhail said, "By Allah, we will not (allow you this year) so as not to give chance to the 'Arabs to say that we have yielded to you, but we will allow you next year." So, the Prophet got that written.

Then Suhail said, "We also stipulate that you should return to us whoever comes to you from us, even if he embraced your religion." The Muslims said, "Glorified be Allah! How will such a person be returned to the pagans after he has become a Muslim? While they were in this state Abu- Jandal bin Suhail bin 'Amr came from the valley of Mecca staggering with his fetters and fell down amongst the Muslims. Suhail said, "O Muhammad! This is the very first term with which we make peace with you, i.e. you shall return Abu Jandal to me." The Prophet said, "The peace treaty has not been written yet." Suhail said, "I will never allow you to keep him." The Prophet said, "Yes, do." He said, "I won't do.: Mikraz said, "We allow you (to keep him)." Abu Jandal said, "O Muslims! Will I be returned to the pagans though I have come as a Muslim? Don't you see how much I have suffered?"

Abu Jandal had been tortured severely for the Cause of Allah. Umar bin Al-Khattab said, "I went to the Prophet and said, 'Aren't you truly the Apostle of Allah?' The Prophet said, 'Yes, indeed.' I said, 'Isn't our Cause just and the cause of the enemy unjust?' He said, 'Yes.' I said, 'Then why should we be humble in our religion?' He said, 'I am Allah's Apostle and I do not disobey Him, and He will make me victorious.' I said, 'Didn't you tell us that we would go to the Ka'ba and perform Tawaf around it?' He said, 'Yes, but did I tell you that we would visit the Ka'ba this year?' I said, 'No.' He said, 'So you will visit it and perform Tawaf around it?' " Umar further said, "I went to Abu Bakr and said, 'O Abu Bakr! Isn't he truly Allah's Prophet?' He replied, 'Yes.' I said, 'Then why should we be humble in our religion?' He said, 'Indeed, he is Allah's Apostle and he does not disobey his Lord, and He will make him victorious. Adhere to him as, by Allah, he is on the right.' I said, 'Was he not telling us that we would go to the Kaba and perform Tawaf around it?' He said, 'Yes, but did he tell you that you would go to the Ka'ba this year?' I said, 'No.' He said, "You will go to Ka'ba and perform Tawaf around it." (Az-Zuhri said, " 'Umar said, 'I performed many good deeds as expiation for the improper questions I asked them.' ")

When the writing of the peace treaty was concluded, Allah's Apostle said to his companions, "Get up and' slaughter your sacrifices and get your head shaved." By Allah none of them got up, and the Prophet repeated his order thrice. When none of them got up, he left them and went to Um Salama and told her of the people's attitudes towards him. Um Salama said, "O the Prophet of Allah! Do you want your order to be carried out? Go out and don't say a word to anybody till you have slaughtered your sacrifice and call your barber to shave your head." So, the Prophet went out and did not talk to anyone of them till he did that, i.e. slaughtered the sacrifice and called his barber who shaved his head. Seeing that, the companions of the Prophet got up, slaughtered their sacrifices, and started shaving the heads of one another, and there was so much rush that there was a danger of killing each other. Then some believing women came (to the Prophet ); and Allah revealed the following Divine Verses:--

"O you who believe, when the believing women come to you as emigrants examine them . . ." (60.10)

Umar then divorced two wives of his who were infidels. Later on Muawiya bin Abu Sufyan married one of them, and Safwan bin Umaya married the other. When the Prophet returned to Medina, Abu Basir, a new Muslim convert from Quraish came to him. The Infidels sent in his pursuit two men who said (to the Prophet ), "Abide by the promise you gave us." So, the Prophet handed him over to them. They took him out (of the City) till they reached Dhul-Hulaifa where they dismounted to eat some dates they had with them. Abu Basir said to one of them, "By Allah, O so-and-so, I see you have a fine sword." The other drew it out (of the scabbard) and said, "By Allah, it is very fine and I have tried it many times." Abu Bair said, "Let me have a look at it."

When the other gave it to him, he hit him with it till he died, and his companion ran away till he came to Medina and entered the Mosque running. When Allah's Apostle saw him he said, "This man appears to have been frightened." When he reached the Prophet he said, "My companion has been murdered and I would have been murdered too." Abu Basir came and said, "O Allah's Apostle, by Allah, Allah has made you fulfill your obligations by your returning me to them (i.e. the Infidels), but Allah has saved me from them." The Prophet said, "Woe to his mother! what excellent war kindler he would be, should he only have supporters." When Abu Basir heard that he understood that the Prophet would return him to them again, so he set off till he reached the seashore. Abu Jandal bin Suhail got himself released from them (i.e. infidels) and joined Abu Basir. So, whenever a man from Quraish embraced Islam he would follow Abu Basir till they formed a strong group. By Allah, whenever they heard about a caravan of Quraish heading towards Sham, they stopped it and attacked and killed them (i.e. infidels) and took their properties. The people of Quraish sent a message to the Prophet requesting him for the Sake of Allah and Kith and kin to send for (i.e. Abu Basir and his companions) promising that whoever (amongst them) came to the Prophet would be secure. So the Prophet sent for them (i.e. Abu Basir's companions) and Allah I revealed the following Divine Verses:

"And it is He Who Has withheld their hands from you and your hands From them in the midst of Mecca, After He made you the victorious over them. . . . the unbelievers had pride and haughtiness, in their hearts . . . the pride and haughtiness of the time of ignorance." (48.24-26) And their pride and haughtiness was that they did not confess (write in the treaty) that he (i.e. Muhammad) was the Prophet of Allah and refused to write: "In the Name of Allah, the most Beneficent, the Most Merciful," and prevented the Mushriks from visiting the Ka'ba.

Narrated Az-Zuhri: Urwa said, "Aisha told me that Allah's Apostle used to examine the women emigrants. We have been told also that when Allah revealed the order that the Muslims should return to the pagans what they had spent on their wives who emigrated (after embracing Islam) and that the Mushriks should not. keep unbelieving women as their wives, 'Umar divorced two of his wives, Qariba, the daughter of Abu Urhaiya and the daughter of Jarwal Al-Khuza'i. Later on Mu'awlya married Qariba and Abu Jahm married the other."

When the pagans refused to pay what the Muslims had spent on their wives, Allah revealed: "And if any of your wives have gone from you to the unbelievers and you have an accession (By the coming over of a woman from the other side) (Then pay to those whose wives have gone) The equivalent of what they had spent (On their Mahr)." (60.11)

So, Allah ordered that the Muslim whose wife, has gone, should be given, as a compensation of the Mahr he had given to his wife, from the Mahr of the wives of the pagans who had emigrated deserting their husbands.

We do not know any of the women emigrants who deserted Islam after embracing it. We have also been told that Abu Basir bin Asid Ath-Thaqafi came to the Prophet as a Muslim emigrant during the truce. Al-Akhnas bin Shariq wrote to the Prophet requesting him to return Abu Basir.


Bukhari :: Conditions :: [3.50.892]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 892

Narrated Abu Huraira:

Allah's Apostle mentioned a person who asked an Israeli man to lend him one-thousand Dinars, and the Israeli lent him the sum for a certain fixed period.


Bukhari :: Conditions :: [3.50.893]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 893

Narrated Amra:

Aisha said that Buraira came to seek her help in the writing of her emancipation. 'Aisha said to her, "If you wish, I will pay your masters (your price) and the wala' will be for me." When Allah's Apostle came, she told him about it. The Prophet said to her, "Buy her (i.e. Buraira) and manumit her, for the Wala is for the one who manumits." Then Allah's Apostle ascended the pulpit and said, "What about those people who stipulate conditions which are not in Allah's Laws? Whoever stipulates such conditions as are not in Allah's Laws, then those conditions are invalid even if he stipulated a hundred such conditions."


Bukhari :: Conditions :: [3.50.894]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 894

Narrated Abu Huraira:

Allah's Apostle said, "Allah has ninety-nine names, i.e. one-hundred minus one, and whoever knows them will go to Paradise." (Please see Hadith No. 419 Vol. 8)


Bukhari :: Conditions :: [3.50.895]

Conditions

Bukhari :: Book 3 :: Volume 50 :: Hadith 895

Narrated Ibn 'Umar:

Umar bin Khattab got some land in Khaibar and he went to the Prophet to consult him about it saying, "O Allah' Apostle got some land in Khaibar better than which I have never had, what do you suggest that I do with it?" The Prophet said, "If you like you can give the land as endowment and give its fruits in charity." So Umar gave it in charity as an endowment on the condition that would not be sold nor given to anybody as a present and not to be inherited, but its yield would be given in charity to the poor people, to the Kith and kin, for freeing slaves, for Allah's Cause, to the travelers and guests; and that there would be no harm if the guardian of the endowment ate from it according to his need with good intention, and fed others without storing it for the future."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.1]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 1

Narrated Abdullah bin Umar: Allah's Apostle said, "It is not permissible for any Muslim who has something to will to stay for two nights without having his last will and testament written and kept ready with him."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.2]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 2

Narrated Amr bin Al-Harith:

(The brother of the wife of Allah's Apostle. Juwaira bint Al-Harith) When Allah's Apostle died, he did not leave any Dirham or Dinar (i.e. money), a slave or a slave woman or anything else except his white mule, his arms and a piece of land which he had given in charity .


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.3]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 3

Narrated Talha bin Musarrif:

I asked 'Abdullah bin Abu Aufa "Did the Prophet make a will?" He replied, "No," I asked him, "How is it then that the making of a will has been enjoined on people, (or that they are ordered to make a will)?" He replied, "The Prophet bequeathed Allah's Book (i.e. Quran)."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.4]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 4

Narrated Al-Aswad:

In the presence of 'Aisha some people mentioned that the Prophet had appointed 'Ali by will as his successor. 'Aisha said, "When did he appoint him by will? Verily when he died he was resting against my chest (or said: in my lap) and he asked for a wash-basin and then collapsed while in that state, and I could not even perceive that he had died, so when did he appoint him by will?"


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.5]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 5

Narrated Sad bin Abu Waqqas:

The Prophet came visiting me while I was (sick) in Mecca, ('Amir the sub-narrator said, and he disliked to die in the land, whence he had already migrated). He (i.e. the Prophet) said, "May Allah bestow His Mercy on Ibn Afra (Sad bin Khaula)." I said, "O Allah's Apostle! May I will all my property (in charity)?" He said, "No." I said, "Then may I will half of it?" He said, "No". I said, "One third?" He said: "Yes, one third, yet even one third is too much. It is better for you to leave your inheritors wealthy than to leave them poor begging others, and whatever you spend for Allah's sake will be considered as a charitable deed even the handful of food you put in your wife's mouth. Allah may lengthen your age so that some people may benefit by you, and some others be harmed by you." At that time Sad had only one daughter.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.6]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 6

Narrated Ibn 'Abbas:

I recommend that people reduce the proportion of what they bequeath by will to the fourth (of the whole legacy), for Allah's Apostle said, "One-third, yet even one third is too much."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.7]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 7

Narrated Sad:

I fell sick and the Prophet paid me a visit. I said to him, "O Allah's Apostle! I invoke Allah that He may not let me expire in the land whence I migrated (i.e. Mecca)." He said, "May Allah give you health and let the people benefit by you." I said, "I want to will my property, and I have only one daughter and I want to will half of my property (to be given in charity)." He said," Half is too much." I said, "Then I will one third." He said, "One-third, yet even one-third is too much." (The narrator added, "So the people started to will one third of their property and that was Permitted for them.")


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.8]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 8

Narrated 'Aisha:

(the wife of the Prophet) Utba bin Abi Waqqas entrusted (his son) to his brother Sad bin Abi Waqqas saying, "The son of the slave-girl of Zam'a is my (illegal) son, take him into your custody." So during the year of the Conquest (of Mecca) Sad took the boy and said, "This is my brother's son whom my brother entrusted to me." 'Abu bin Zam's got up and said, "He is my brother and the son of the slave girl of my father and was born on my father's bed." Then both of them came to Allah's Apostle and Sad said, "O Allah's Apostle! This is my brother's son whom my brother entrusted to me."

Then 'Abu bin Zam'a got up and said, "This is my brother and the son of the slave-girl of my father." Allah's Apostle said, "O Abu bin Zam'a! This boy is for you as the boy belongs to the bed (where he was born), and for the adulterer is the stone (i.e. deprivation)." Then the Prophet said to his wife Sauda bint Zam'a, "Screen yourself from this boy," when he saw the boy's resemblance to 'Utba. Since then the boy did not see Sauda till he died.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.9]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 9

Narrated Anas:

A Jew crushed the head of a girl between two stones. She was asked, "Who has done so to you, so-and-so? So-and-so?" Till the name of the Jew was mentioned, whereupon she nodded (in agreement). So the Jew was brought and was questioned till he confessed. The Prophet then ordered that his head be crushed with stones.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.10]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 10

Narrated Ibn 'Abbas:

The custom (in old days) was that the property of the deceased would be inherited by his offspring; as for the parents (of the deceased), they would inherit by the will of the deceased. Then Allah cancelled from that custom whatever He wished and fixed for the male double the amount inherited by the female, and for each parent a sixth (of the whole legacy) and for the wife an eighth or a fourth and for the husband a half or a fourth.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.11]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 11

Narrated Abu Huraira:

A man asked the Prophet, "O Allah's Apostle! What kind of charity is the best?" He replied. "To give in charity when you are healthy and greedy hoping to be wealthy and afraid of becoming poor. Don't delay giving in charity till the time when you are on the death bed when you say, 'Give so much to so-and-so and so much to so-and so,' and at that time the property is not yours but it belongs to so-and-so (i.e. your inheritors)."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.12]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 12

Narrated Abu Huraira:

The Prophet said, "The signs of a hypocrite are three: Whenever he speaks he tells a lie; whenever he is entrusted he proves dishonest; whenever he promises he breaks his promise."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.13]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 13

Narrated 'Urwa bin Az-Zubair: Hakim bin Hizam said, "I asked Allah's Apostle for something, and he gave me, and I asked him again and he gave me and said, 'O Hakim! This wealth is green and sweet (i.e. as tempting as fruits), and whoever takes it with

The upper (i.e. giving) hand is better than the lower (i.e. taking) hand." Hakim added, "I said, O Allah's Apostle! By Him Who has sent you with the Truth I will never demand anything from anybody after you till I die." Afterwards Abu Bakr used to call Hakim to give him something but he refused to accept anything from him. Then 'Umar called him to give him (something) but he refused. Then 'Umar said, "O Muslims! I offered to him (i.e. Hakim) his share which Allah has ordained for him from this booty and he refuses to take it." Thus Hakim did not ask anybody for anything after the Prophet, till he died--may Allah bestow His mercy upon him.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.14]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 14

Narrated Ibn Umar:

I heard Allah's Apostle saying, "All of you are guardians and responsible for your charges: the Ruler (i.e. Imam) is a guardian and responsible for his subjects; and a man is a guardian of his family and is responsible for his charges; and a lady is a guardian in the house of her husband and is responsible for her charge; and a servant is a guardian of the property of his master and is responsible for his charge." I think he also said, "And a man is a guardian of the property of his father."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.15]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 15

Narrated Anas:

The Prophet said to Abu Talha, "I recommend that you divide (this garden) amongst your relatives." Abu Talha said, "O Allah's Apostle! I will do the same." So Abu Talha divided it among his relatives and cousins.

Ibn 'Abbes said, "When the Qur'anic Verse:

"Warn your nearest kinsmen." (26.214)

Was revealed, the Prophet started calling the various big families of Quraish, "O Bani Fihr! O Bani Adi!".

Abu Huraira said, "When the Verse: "Warn your nearest kinsmen" was revealed, the Prophet said (in a loud voice), "O people of Quraish!"


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.16]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 16

Narrated Abu Huraira:

When Allah revealed the Verse: "Warn your nearest kinsmen," Allah's Apostle got up and said, "O people of Quraish (or said similar words)! Buy (i.e. save) yourselves (from the Hellfire) as I cannot save you from Allah's Punishment; O Bani Abd Manaf! I cannot save you from Allah's Punishment, O Safiya, the Aunt of Allah's Apostle! I cannot save you from Allah's Punishment; O Fatima bint Muhammad! Ask me anything from my wealth, but I cannot save you from Allah's Punishment."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.17]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 17

Narrated Anas:

The Prophet saw a man driving a Badana (i.e. camel for sacrifice) and said to him, "Ride on it." The man said, "O Allah's Apostle! It is a Bandana." (The Prophet repeated his order) and on the third or fourth time he said, "Ride it, (woe to you" or said: "May Allah be merciful to you)."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.18]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 18

Narrated Abu Huraira:

Allah's Apostle saw a man driving a Badana and said to him, "Ride on it," and on the second or the third time he added, "Woe to you."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.19]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 19

Narrated Ibn 'Abbas:

The mother of Sad bin 'Ubada died in his absence. He said, "O Allah's Apostle! My mother died in my absence; will it be of any benefit for her if I give Sadaqa on her behalf?" The Prophet said, "Yes," Sad said, "I make you a witness that I gave my garden called Al Makhraf in charity on her behalf."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.20]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 20

Narrated Kab bin Malik:

I said, "O Allah's Apostle! For the acceptance of my repentance I wish to give all my property in charity for Allah's sake through His Apostle ." He said, "It is better for you to keep some of the property for yourself." I said, "Then I will keep my share in Khaibar."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.21]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 21

Narrated Ibn 'Abbas:

Some people claim that the order in the above Verse is cancelled, by Allah, it is not cancelled, but the people have stopped acting on it. There are two kinds of guardians (who are in charge of the inheritance): One is that who inherits; such a person should give (of what he inherits to the relatives, the orphans and the needy, etc.), the other is that who does not inherit (e.g. the guardian of the orphans): such a person should speak kindly and say (to those who are present at the time of distribution), "I can not give it to you (as the wealth belongs to the orphans)."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.22]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 22

Narrated 'Aisha:

A man said to the Prophet, "My mother died suddenly, and I think that if she could speak, she would have given in charity. May I give in charity on her behalf?" He said, "Yes! Give in charity on her behalf."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.23]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 23

Narrated Ibn 'Abbas:

Sad bin Ubada consulted Allah's Apostle saying, "My mother died and she had an unfulfilled vow." The Prophet said, "Fulfill it on her behalf."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.24]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 24

Narrated Ibn 'Abbas:

That the mother of Sad bin Ubada the brother of Bani Saida died in Sad's absence, so he came to the Prophet saying, "O Allah's Apostle! My mother died in my absence, will it benefit her if I give in charity on her behalf?" The Prophet said, "Yes." Sad said, "I take you as my witness that I give my garden Al-Makhraf in charity on her behalf."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.25]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 25

Narrated Az-Zuhri:

Urwa bin Az-Zubair said that he asked 'Aisha about the meaning of the Quranic Verse:--

"And if you fear that you will not deal fairly with the orphan girls then marry (other) women of your choice." (4.2-3)

Aisha said, "It is about a female orphan under the guardianship of her guardian who is inclined towards her because of her beauty and wealth, and likes to marry her with a Mahr less than what is given to women of her standard. So they (i.e. guardians) were forbidden to marry the orphans unless they paid them a full appropriate Mahr (otherwise) they were ordered to marry other women instead of them. Later on the people asked Allah's Apostle about it. So Allah revealed the following Verse:--

"They ask your instruction (O Muhammad!) regarding women. Say: Allah instructs you regarding them..." (4.127)

and in this Verse Allah indicated that if the orphan girl was beautiful and wealthy, her guardian would have the desire to marry her without giving her an appropriate Mahr equal to what her peers could get, but if she was undesirable for lack of beauty or wealth, then he would not marry her, but seek to marry some other woman instead of her. So, since he did not marry her when he had no inclination towards her, he had not the right to marry her when he had an interest in her, unless he treated her justly by giving her a full Mahr and securing all her rights.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.26]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 26

Narrated Ibn 'Umar:

In the lifetime of Allah's Apostle , Umar gave in charity some of his property, a garden of date-palms called Thamgh. 'Umar said, "O Allah's Apostle! I have some property which I prize highly and I want to give it in charity." The Prophet; said, "Give it in charity (i.e. as an endowment) with its land and trees on the condition that the land and trees will neither be sold nor given as a present, nor bequeathed, but the fruits are to be spent in charity." So 'Umar gave it in charity, and it was for Allah's Cause, the emancipation of slaves, for the poor, for guests, for travelers, and for kinsmen. The person acting as its administrator could eat from it reasonably and fairly, and could let a friend of his eat from it provided he had no intention of becoming wealthy by its means.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.27]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 27

Narrated 'Aisha:

The following Verse:--

"If a guardian is well-off, let him claim no remuneration (i.e. wages), but if he is poor, let him have for himself what is just and reasonable." (4.6)

was revealed in connection with the guardian of an orphan, and it means that if he is poor he can have for himself (from the orphan's wealth) what is just and reasonable according to the orphan's share of the inheritance.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.28]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 28

Narrated Abu Huraira:

The Prophet said, "Avoid the seven great destructive sins." The people enquire, "O Allah's Apostle! What are they? "He said, "To join others in worship along with Allah, to practice sorcery, to kill the life which Allah has forbidden except for a just cause, (according to Islamic law), to eat up Riba (usury), to eat up an orphan's wealth, to give back to the enemy and fleeing from the battlefield at the time of fighting, and to accuse, chaste women, who never even think of anything touching chastity and are good believers.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.29]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 29

Narrated Anas:

When Allah's Apostle came to Medina; he did not have any servant. Abu Talha (Anas' step-father) took me to Allah's Apostle and said, "O Allah's Apostle! Anas is a wise boy, so let him serve you." So, I served him at home and on journeys. If I did anything, he never asked me why I did it, and if I refrained from doing anything, he never asked me why I refrained from doing it.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.30]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 30

Narrated Anas bin Malik:

Abu Talha had the greatest wealth of date-palms amongst the Ansar in Medina, and he prized above all his wealth (his garden) Bairuha', which was situated opposite the Mosque (of the Prophet ). The Prophet used to enter It and drink from its fresh water. When the following Divine Verse came:--

"By no means shall you attain piety until you spend of what you love," (3.92)

Abu Talha got up saying. "O Allah's Apostle! Allah says, 'You will not attain piety until you spend of what you love,' and I prize above al I my wealth, Bairuha' which I want to give in charity for Allah's Sake, hoping for its reward from Allah. So you can use it as Allah directs you." On that the Prophet said, "Bravo! It is a profitable (or perishable) property. (Ibn Maslama is not sure as to which word is right, i.e. profitable or perishable.) I have heard what you have said, and I recommend that you distribute this amongst your relatives." On that Abu Talha said, "O Allah's Apostle! I will do (as you have suggested)." So, Abu Talha distributed that garden amongst his relatives and cousins.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.31]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 31

Narrated Ibn Abbas:

A man said to Allah's Apostle , "My mother died, will it benefit her if I give in charity on her behalf?" The Prophet replied in the affirmative. The man said, "I have a garden and I make you a witness that I give it in charity on her behalf."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.32]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 32

Narrated Anas:

When the Prophet ordered that the mosque be built, he said, "O Bani An-Najjar! Suggest to me a price for this garden of yours." They replied, "By Allah! We will demand its price from none but Allah."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.33]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 33

Narrated Ibn 'Umar:

When 'Umar got a piece of land in Khaibar, he came to the Prophet saying, "I have got a piece of land, better than which I have never got. So what do you advise me regarding it?" The Prophet said, "If you wish you can keep it as an endowment to be used for charitable purposes." So, 'Umar gave the land in charity (i.e. as an endowments on the condition that the land would neither be sold nor given as a present, nor bequeathed, (and its yield) would be used for the poor, the kinsmen, the emancipation of slaves, Jihad, and for guests and travelers; and its administrator could eat in a reasonable just manner, and he also could feed his friends without intending to be wealthy by its means."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.34]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 34

Narrated Ibn 'Umar:

Umar got some property in Khaibar and he came to the Prophet and informed him about it. The Prophet said to him, "If you wish you can give it in charity." So 'Umar gave it in charity (i.e. as an endowment) the yield of which was to be used for the good of the poor, the needy, the kinsmen and the guests.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.35]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 35

Narrated Anas bin Malik:

When Allah's Apostle came to Medina, he ordered that a mosque be built. He said, "O Bani An-Najjar! Suggest me a price for the garden of yours." They replied, "By Allah, we will not ask its price except from Allah."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.36]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 36

Narrated Ibn 'Umar:

Once 'Umar gave a horse in charity to be used in holy fighting. It had been given to him by Allah's Apostle . 'Umar gave it to another man to ride. Then 'Umar was informed that the man put the horse for sale, so he asked Allah's Apostle whether he could buy it. Allah's Apostle replied, "You should not buy it, for you should not take back what you have given in charity."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.37]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 37

Narrated Abu Huraira:

Allah's Apostle said, "My heirs will not inherit a Dinar or a Dirham (i.e. money), for whatever I leave (excluding the adequate support of my wives and the wages of my employees) is given in charity."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.38]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 38

Narrated Ibn 'Umar:

When 'Umar founded an endowment he stipulated that its administrator could eat from it and also feed his friend on the condition that he would not store anything for himself from it.


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.39]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 39

Narrated Anas:

The Prophet said (at the time of building the Mosque), "O Ban, An-Najjar! Suggest to me a price for your garden." They replied, "We do not ask its price except from Allah."


Bukhari :: Wills and Testaments (Wasaayaa) :: [4.51.40]

Wills and Testaments (Wasaayaa)

Bukhari :: Book 4 :: Volume 51 :: Hadith 40

Narrated Jabir bin 'Abdullah Al-Ansari:

My father was martyred on the day (of the Ghazwa) of Uhud and left six daughters and some debts to be paid. When the time of plucking the date-fruits came, I went to Allah's Apostle and said, "O Allah's Apostle! you know that my father was martyred on Uhud's day and owed much debt, and I wish that the creditors would see you." The Prophet said, "Go and collect the various kinds of dates and place them separately in heaps"' I did accordingly and called him. On seeing him, the creditors started claiming their rights pressingly at that time. When the Prophet saw how they behaved, he went round the biggest heap for three times and sat over it and said, "Call your companions (i.e. the creditors)." Then he kept on measuring and giving them, till Allah cleared all my father's debts. By Allah, it would have pleased me that Allah would clear the debts of my father even though I had not taken a single date to my sisters. But by Allah, all the heaps were complete, (as they were) and I looked at the heap where Allah's Apostle was sitting and noticed as if not a single date had been taken thereof.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.41]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 41

Narrated Abdullah bin Masud:

I asked Allah's Apostle, "O Allah's Apostle! What is the best deed?" He replied, "To offer the prayers at their early stated fixed times." I asked, "What is next in goodness?" He replied, "To be good and dutiful to your parents." I further asked, what is next in goodness?" He replied, "To participate in Jihad in Allah's Cause." I did not ask Allah's Apostle anymore and if I had asked him more, he would have told me more.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.42]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 42

Narrated Ibn 'Abbas:

Allah's Apostle said, "There is no Hijra (i.e. migration) (from Mecca to Medina) after the Conquest (of Mecca), but Jihad and good intention remain; and if you are called (by the Muslim ruler) for fighting, go forth immediately.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.43]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 43

Narrated 'Aisha:

(That she said), "O Allah's Apostle! We consider Jihad as the best deed. Should we not fight in Allah's Cause?" He said, "The best Jihad (for women) is Hajj-Mabrur (i.e. Hajj which is done according to the Prophet's tradition and is accepted by Allah)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.44]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 44

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "Instruct me as to such a deed as equals Jihad (in reward)." He replied, "I do not find such a deed." Then he added, "Can you, while the Muslim fighter is in the battle-field, enter your mosque to perform prayers without cease and fast and never break your fast?" The man said, "But who can do that?" Abu- Huraira added, "The Mujahid (i.e. Muslim fighter) is rewarded even for the footsteps of his horse while it wanders bout (for grazing) tied in a long rope."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.45]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 45

Narrated Abu Said Al-Khudri:

Somebody asked, "O Allah's Apostle! Who is the best among the people?" Allah's Apostle replied "A believer who strives his utmost in Allah's Cause with his life and property." They asked, "Who is next?" He replied, "A believer who stays in one of the mountain paths worshipping Allah and leaving the people secure from his mischief."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.46]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 46

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The example of a Mujahid in Allah's Cause-- and Allah knows better who really strives in His Cause----is like a person who fasts and prays continuously. Allah guarantees that He will admit the Mujahid in His Cause into Paradise if he is killed, otherwise He will return him to his home safely with rewards and war booty."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.47]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 47

Narrated Anas bin Malik:

Allah's Apostle used to visit Um Haran bint Milhan, who would offer him reals. Um-Haram was the wife of Ubada bin As-Samit. Allah's Apostle, once visited her and she provided him with food and started looking for lice in his head. Then Allah's Apostle slept, and afterwards woke up smiling. Um Haran asked, "What causes you to smile, O Allah's Apostle?" He said. "Some of my followers who (in a dream) were presented before me as fighters in Allah's Cause (on board a ship) amidst this sea cause me to smile; they were as kings on the thrones (or like kings on the thrones)." (Ishaq, a sub-narrator is not sure as to which expression the Prophet used.) Um-Haram said, "O Allah's Apostle! Invoke Allah that he makes me one of them. Allah's Apostle invoked Allah for her and slept again and woke up smiling. Once again Um Haram asked, "What makes you smile, O Allah's Apostle?" He replied, "Some of my followers were presented to me as fighters in Allah's Cause," repeating the same dream. Um-Haram said, "O Allah's Apostle! Invoke Allah that He makes me one of them." He said, "You are amongst the first ones." It happened that she sailed on the sea during the Caliphate of Mu'awlya bin Abi Sufyan, and after she disembarked, she fell down from her riding animal and died.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.48]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 48

Narrated Abu Huraira:

The Prophet said, "Whoever believes in Allah and His Apostle, offer prayer perfectly and fasts the month of Ramadan, will rightfully be granted Paradise by Allah, no matter whether he fights in Allah's Cause or remains in the land where he is born." The people said, "O Allah's Apostle ! Shall we acquaint the people with the is good news?" He said, "Paradise has one-hundred grades which Allah has reserved for the Mujahidin who fight in His Cause, and the distance between each of two grades is like the distance between the Heaven and the Earth. So, when you ask Allah (for something), ask for Al-firdaus which is the best and highest part of Paradise." (i.e. The sub-narrator added, "I think the Prophet also said, 'Above it (i.e. Al-Firdaus) is the Throne of Beneficent (i.e. Allah), and from it originate the rivers of Paradise.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.49]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 49

Narrated Samura:

The Prophet said, "Last night two men came to me (in a dream) and made me ascend a tree and then admitted me into a better and superior house, better of which I have never seen. One of them said, 'This house is the house of martyrs."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.50]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 50

Narrated Anas bin Malik:

The Prophet said, "A single endeavor (of fighting) in Allah's Cause in the forenoon or in the afternoon is better than the world and whatever is in it."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.51]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 51

Narrated Abu Huraira:

The Prophet said, "A place in Paradise as small as a bow is better than all that on which the sun rises and sets (i.e. all the world)." He also said, "A single endeavor in Allah's Cause in the afternoon or in the forenoon is better than all that on which the sun rises and sets."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.52]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 52

Narrated Sahl bin Sad:

The Prophet said, "A single endeavor in Allah's Cause in the afternoon and in the forenoon is better than the world and whatever is in it."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.53]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 53

Narrated Anas bin Malik:

The Prophet said, "Nobody who dies and finds good from Allah (in the Hereafter) would wish to come back to this world even if he were given the whole world and whatever is in it, except the martyr who, on seeing the superiority of martyrdom, would like to come back to the world and get killed again (in Allah's Cause)."

Narrated Anas: The Prophet said, "A single endeavor (of fighting) in Allah's Cause in the afternoon or in the forenoon is better than all the world and whatever is in it. A place in Paradise as small as the bow or lash of one of you is better than all the world and whatever is in it. And if a houri from Paradise appeared to the people of the earth, she would fill the space between Heaven and the Earth with light and pleasant scent and her head cover is better than the world and whatever is in it."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.54]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 54

Narrated Abu Huraira:

The Prophet said, "By Him in Whose Hands my life is! Were it not for some men amongst the believers who dislike to be left behind me and whom I cannot provide with means of conveyance, I would certainly never remain behind any Sariya' (army-unit) setting out in Allah's Cause. By Him in Whose Hands my life is! I would love to be martyred in Al1ah's Cause and then get resurrected and then get martyred, and then get resurrected again and then get martyred and then get resurrected again and then get martyred.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.55]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 55

Narrated Anas bin Malik:

The Prophet delivered a sermon and said, "Zaid took the flag and was martyred, and then Ja'far took the flag and was martyred, and then 'Abdullah bin Rawaha took the flag and was martyred too, and then Khalid bin Al-Walid took the flag though he was not appointed as a commander and Allah made him victorious." The Prophet further added, "It would not please us to have them with us." Aiyub, a sub-narrator, added, "Or the Prophet, shedding tears, said, 'It would not p ease them to be with us."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.56]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 56

Narrated Anas bin Malik:

Um Haram said, "Once the Prophet slept in my house near to me and got up smiling. I said, 'What makes you smile?' He replied, 'Some of my followers who (i.e. in a dream) were presented to me sailing on this green sea like kings on thrones.' I said, 'O Allah's Apostle! Invoke Allah to make me one of them." So the Prophet invoked Allah for her and went to sleep again. He did the same (i.e. got up and told his dream) and Um Haran repeated her question and he gave the same reply. She said, "Invoke Allah to make me one of them." He said, "You are among the first batch." Later on it happened that she went out in the company of her husband 'Ubada bin As-Samit who went for Jihad and it was the first time the Muslims undertook a naval expedition led by Mu awiya. When the expedition came to an end and they were returning to Sham, a riding animal was presented to her to ride, but the animal let her fall and thus she died.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.57]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 57

Narrated Anas:

The Prophet sent seventy men from the tribe of Bani Salim to the tribe of Bani Amir. When they reached there, my maternal uncle said to them, "I will go ahead of you, and if they allow me to convey the message of Allah's Apostle (it will be all right); otherwise you will remain close to me." So he went ahead of them and the pagans granted him security But while he was reporting the message of the Prophet , they beckoned to one of their men who stabbed him to death. My maternal uncle said, "Allah is Greater! By the Lord of the Kaba, I am successful." After that they attached the rest of the party and killed them all except a lame man who went up to the top of the mountain. (Hammam, a sub-narrator said, "I think another man was saved along with him)." Gabriel informed the Prophet that they (i.e the martyrs) met their Lord, and He was pleased with them and made them pleased. We used to recite, "Inform our people that we have met our Lord, He is pleased with us and He has made us pleased " Later on this Quranic Verse was cancelled. The Prophet invoked Allah for forty days to curse the murderers from the tribe of Ral, Dhakwan, Bani Lihyan and Bam Usaiya who disobeyed Allah and his Apostle


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.58]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 58

Narrated Jundab bin Sufyan:

In one of the holy Battles a finger of Allah's Apostle (got wounded and) bled. He said, "You are just a finger that bled, and what you got is in Allah's Cause."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.59]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 59

Narrated Abu Huraira:

Allah's Apostle said, "By Him in Whose Hands my soul is! Whoever is wounded in Allah's Cause....and Allah knows well who gets wounded in His Cause....will come on the Day of Resurrection with his wound having the color of blood but the scent of musk."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.60]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 60

Narrated Abdullah bin Abbas:

That Abu Sufyan told him that Heraclius said to him, "I asked you about the outcome of your battles with him (i.e. the Prophet ) and you told me that you fought each other with alternate success. So the Apostles are tested in this way but the ultimate victory is always theirs.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.61]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 61

Narrated Anas:

My uncle Anas bin An-Nadr was absent from the Battle of Badr. He said, "O Allah's Apostle! I was absent from the first battle you fought against the pagans. (By Allah) if Allah gives me a chance to fight the pagans, no doubt. Allah will see how (bravely) I will fight." On the day of Uhud when the Muslims turned their backs and fled, he said, "O Allah! I apologize to You for what these (i.e. his companions) have done, and I denounce what these (i.e. the pagans) have done." Then he advanced and Sad bin Muadh met him. He said "O Sad bin Muadh ! By the Lord of An-Nadr, Paradise! I am smelling its aroma coming from before (the mountain of) Uhud," Later on Sad said, "O Allah's Apostle! I cannot achieve or do what he (i.e. Anas bin An-Nadr) did. We found more than eighty wounds by swords and arrows on his body. We found him dead and his body was mutilated so badly that none except his sister could recognize him by his fingers." We used to think that the following Verse was revealed concerning him and other men of his sort: "Among the believers are men who have been true to their covenant with Allah.........." (33.23)

His sister Ar-Rubbaya' broke a front tooth of a woman and Allah's Apostle ordered for retaliation. On that Anas (bin An-Nadr) said, "O Allah's Apostle! By Him Who has sent you with the Truth, my sister's tooth shall not be broken." Then the opponents of Anas's sister accepted the compensation and gave up the claim of retaliation. So Allah's Apostle said, "There are some people amongst Allah's slaves whose oaths are fulfilled by Allah when they take them."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.62]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 62

Narrated Kharija bin Zaid:

Zaid bin Thabit said, "When the Quran was compiled from various written manuscripts, one of the Verses of Surat Al-Ahzab was missing which I used to hear Allah's Apostle reciting. I could not find it except with Khuzaima bin Thabjt Al-Ansari, whose witness Allah's Apostle regarded as equal to the witness of two men. And the Verse was:-- "Among the believers are men who have been true to what they covenanted with Allah." (33.23)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.63]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 63

Narrated Al-Bara:

A man whose face was covered with an iron mask (i.e. clad in armor) came to the Prophet and said, "O Allah's Apostle! Shall I fight or embrace Islam first? "The Prophet said, "Embrace Islam first and then fight." So he embraced Islam, and was martyred. Allah's Apostle said, A Little work, but a great reward. "(He did very little (after embracing Islam), but he will be rewarded in abundance)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.64]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 64

Narrated Anas bin Malik:

Um Ar-Rubai'bint Al-Bara', the mother of Hartha bin Suraqa came to the Prophet and said, "O Allah's Prophet! Will you tell me about Hartha?" Hartha has been killed (i.e. martyred) on the day of Badr with an arrow thrown by an unidentified person. She added, "If he is in Paradise, I will be patient; otherwise, I will weep bitterly for him." He said, "O mother of Hartha! There are Gardens in Paradise and your son got the Firdausal-ala (i.e. the best place in Paradise)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.65]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 65

Narrated Abu Musa:

A man came to the Prophet and asked, "A man fights for war booty; another fights for fame and a third fights for showing off; which of them fights in Allah's Cause?" The Prophet said, "He who fights that Allah's Word (i.e. Islam) should be superior, fights in Allah's Cause."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.66]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 66

Narrated Abu Abs:

(who is 'Abdur-Rahman bin Jabir) Allah's Apostle said," Anyone whose both feet get covered with dust in Allah's Cause will not be touched by the (Hell) fire."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.67]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 67

Narrated 'Ikrima:

that Ibn 'Abbas told him and 'Ali bin 'Abdullah to go to Abu Said and listen to some of his narrations; So they both went (and saw) Abu Said and his brother irrigating a garden belonging to them. When he saw them, he came up to them and sat down with his legs drawn up and wrapped in his garment and said, "(During the construction of the mosque of the Prophet) we carried the adobe of the mosque, one brick at a time while 'Ammar used to carry two at a time. The Prophet passed by 'Ammar and removed the dust off his head and said, "May Allah be merciful to 'Ammar. He will be killed by a rebellious aggressive group. 'Ammar will invite them to (obey) Allah and they will invite him to the (Hell) fire."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.68]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 68

Narrated 'Aisha:

When Allah's Apostle returned on the day (of the battle) of Al-Khandaq (i.e. Trench), he put down his arms and took a bath. Then Gabriel whose head was covered with dust, came to him saying, "You have put down your arms! By Allah, I have not put down my arms yet." Allah's Apostle said, "Where (to go now)?" Gabriel said, "This way," pointing towards the tribe of Bani Quraiza. So Allah's Apostle went out towards them .


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.69]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 69

Narrated Anas bin Malik:

For thirty days Allah's Apostle invoked Allah to curse those who had killed the companions of Bir-Mauna; he invoked evil upon the tribes of Ral, Dhakwan, and Usaiya who disobeyed Allah and His Apostle. There was reveled about those who were killed at Bir-Mauna a Quranic Verse we used to recite, but it was cancelled later on. The Verse was:

"Inform our people that we have met our Lord. He is pleased with us and He has made us pleased"


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.70]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 70

Narrated Jabir bin Abdullah:

"Some people drank alcohol in the morning of the day (of the battle) of Uhud and were martyred (on the same day)." Sufyan was asked, "(Were they martyred) in the last part of the day?)" He replied, "Such information does not occur in the narration."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.71]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 71

Narrated Jabir:

My father's mutilated body was brought to the Prophet and was placed in front of him. I went to uncover his face but my companions forbade me. Then mourning cries of a lady were heard, and it was said that she was either the daughter or the sister of Amr. The Prophet said, "Why is she crying?" Or said, "Do not cry, for the angels are still shading him with their wings." (Al-Bukhari asked Sadqa, a sub-narrator, "Does the narration include the expression: 'Till he was lifted?' " The latter replied, "Jabir may have said it.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.72]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 72

Narrated Anas bin Malik:

The Prophet said, "Nobody who enters Paradise likes to go back to the world even if he got everything on the earth, except a Mujahid who wishes to return to the world so that he may be martyred ten times because of the dignity he receives (from Allah)."

Narrated Al-Mughira bin Shu'ba: Our Prophet told us about the message of our Lord that "Whoever amongst us is killed will go to Paradise." Umar asked the Prophet, "Is it not true that our men who are killed will go to Paradise and their's (i.e. those of the Pagan's) will go to the (Hell) fire?" The Prophet said, "Yes."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.73]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 73

Narrated 'Abdullah bin Abi Aufa:

Allah's Apostle said, "Know that Paradise is under the shades of swords."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.74]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 74

Narrated Anas: The Prophet was the best, the bravest and the most generous of all the people. Once when the people of Medina got frightened, the Prophet rode a horse and went ahead of them and said, "We found this horse very fast."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.75]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 75

Narrated Muhammad bin Jubair:

Jubair bin Mut'im told me that while he was in the company of Allah's Apostle with the people returning from Hunain, some people (bedouins) caught hold of the Prophet and started begging of him so much so that he had to stand under a (kind of thorny tree (i.e. Samurah) and his cloak was snatched away. The Prophet stopped and said, "Give me my cloak. If I had as many camels as these thorny trees, I would have distributed them amongst you and you will not find me a miser or a liar or a coward."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.76]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 76

Narrated 'Amr bin Maimun Al-Audi:

Sad used to teach his sons the following words as a teacher teaches his students the skill of writing and used to say that Allah's Apostle used to seek Refuge with Allah from them (i.e. the evils) at the end of every prayer. The words are:

'O Allah! I seek refuge with You from cowardice, and seek refuge with You from being brought back to a bad stage of old life and seek refuge with You from the afflictions of the world, and seek refuge with You from the punishments in the grave.'


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.77]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 77

Narrated Anas bin Malik:

The Prophet used to say, "O Allah! I seek refuge with You from helplessness, laziness, cowardice and feeble old age; I seek refuge with You from afflictions of life and death and seek refuge with You from the punishment in the grave."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.78]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 78

Narrated As-Sa'-ib bin Yazid:

I was in the company of Talha bin 'Ubaidullah, Sad, Al-Miqdad bin Al-Aswad and 'Abdur Rahman bin 'Auf and I heard none of them narrating anything from Allah's Apostle but Talha was talking about the day (of the battle) of Uhud.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.79]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 79

Narrated Ibn 'Abbas:

On the day of the Conquest (of Mecca) the Prophet said, "There is no emigration after the Conquest but Jihad and intentions. When you are called (by the Muslim ruler) for fighting, go forth immediately." (See Hadith No. 42)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.80]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 80

Narrated Abu Huraira:

I went to Allah's Apostle while he was at Khaibar after it had fallen in the Muslims' hands. I said, "O Allah's Apostle! Give me a share (from the land of Khaibar)."

One of the sons of Sa'id bin Al-'As said, "O Allah's Apostle! Do not give him a share." I said, "This is the murderer of Ibn Qauqal." The son of Said bin Al-As said, "Strange! A Wabr (i.e. guinea pig) who has come down to us from the mountain of Qaduim (i.e. grazing place of sheep) blames me for killing a Muslim who was given superiority by Allah because of me, and Allah did not disgrace me at his hands (i.e. was not killed as an infidel)." (The sub-narrator said "I do not know whether the Prophet gave him a share or not.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.81]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 81

Narrated Anas bin Malik

In the life-time of the Prophet, Abu Talha did not fast because of the Jihad, but after the Prophet died I never saw him without fasting except on 'Id-ul-Fitr and 'Id-ul-Aclha.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.82]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 82

Narrated Abu Huraira:

Allah's Apostle said, "Five are regarded as martyrs: They are those who die because of plague, abdominal disease, drowning or a falling building etc., and the martyrs in Allah's Cause."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.83]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 83

Narrated Anas bin Malik:

The Prophet said, "Plauge is the cause of martyrdom of every Muslim (who dies because of it)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.84]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 84

Narrated Al-Bara:

When the Divine Inspiration: "Those of the believers who sit (at home), was revealed the Prophet sent for Zaid (bin Thabit) who came with a shoulder-blade and wrote on it. Ibn Um-Maktum complained about his blindness and on that the following revelation came: "Not equal are those believers who sit (at home) except those who are disabled (by injury, or are blind or lame etc.) and those who strive hard and fight in the Way of Allah with their wealth and lives)." (4.95)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.85]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 85

Narrated Sahl bin Sad As-Sa'idi:

I saw Marwan bin Al-Hakam sitting in the Mosque. So I came forward and sat by his side. He told us that Zaid bin Thabit had told him that Allah's Apostle had dictated to him the Divine Verse:

"Not equal are those believers who sit (at home) and those who strive hard and fight in the Cause of Allah with their wealth and lives.' (4.95)

Zaid said, "Ibn-Maktum came to the Prophet while he was dictating to me that very Verse. On that Ibn Um Maktum said, "O Allah's Apostle! If I had power, I would surely take part in Jihad." He was a blind man. So Allah sent down revelation to His Apostle while his thigh was on mine and it became so heavy for me that I feared that my thigh would be broken. Then that state of the Prophet was over after Allah revealed "...except those who are disabled (by injury or are blind or lame etc.) (4.95)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.86]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 86

Narrated Salim Abu-An-Nadr:

'Abdullah bin Abi Aufa wrote and I read what he wrote that Allah's Apostle said, "When you face them ( i.e. your enemy) then be patient."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.87]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 87

Narrated Anas:

Allah's Apostle went towards the Khandaq (i.e. Trench) and saw the Emigrants and the Ansar digging in a very cold morning as they did not have slaves to do that for them. When he noticed their fatigue and hunger he said, "O Allah! The real life is that of the Here-after, (so please) forgive the Ansar and the Emigrants." In its reply the Emigrants and the Ansar said, "We are those who have given a pledge of allegiance to Muhammad that we will carry on Jihad as long as we live."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.88]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 88

Narrated Anas:

The Emigrants and the Ansar started digging the trench around Medina carrying the earth on their backs and saying, "We are those who have given a pledge of allegiance to Muhammad that we will I carry on Jihad as long as we live." The Prophet kept on replying, "O Allah, there is no good except the good of the Hereafter; so confer Your Blessings on the Ansar and the Emigrants."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.89]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 89

Narrated Al-Bara:

The Prophet went on carrying (i.e. the earth) and saying, "Without You (O Allah!) we would have got no guidance."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.90]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 90

Narrated Al-Bara:

On the day (of the battle) of Al-Ahzab (i.e. clans) I saw the Prophet carrying earth, and the earth was covering the whiteness of his abdomen. And he was saying, "Without You (O Allah!) we would have got no guidance, nor given in charity, nor prayed. So please bless us with tranquility and make firm our feet when we meet our enemies.

Indeed (these) people have rebelled against (oppressed) us but never shall we yield if they try to bring affliction upon us."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.91]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 91

Narrated Anas:

We returned from the Ghazwa of Tabuk along with the Prophet. (See Hadith No. 92 below) .


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.92]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 92

Narrated Anas:

While the Prophet was in a Ghazwa he said, "Some people have remained behind us in Medina and we never crossed a mountain path or a valley, but they were with us (i.e. sharing the reward with us), as they have been held back by a (legal) excuse. "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.93]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 93

Narrated Abu Said:

I heard the Prophet saying, "Indeed, anyone who fasts for one day for Allah's Pleasure, Allah will keep his face away from the (Hell) fire for (a distance covered by a journey of) seventy years."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.94]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 94

Narrated Abu Huraira:

The Prophet said, "Whoever spends two things in Allah's Cause, will be called by all the gate-keepers of Paradise who will be saying, 'O so-and-so! Come here.' " Abu Bakr said, "O Allah's Apostle! Such persons will never be destroyed." The Prophet said, "I hope you will be one of them."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.95]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 95

Narrated Abu Said Al-Khudri:

Allah's Apostle ascended the pulpit and said, "Nothing worries me as to what will happen to you after me, except the temptation of worldly blessings which will be conferred on you." Then he mentioned the worldly pleasures. He started with the one (i.e. the blessings) and took up the other (i.e. the pleasures). A man got up saying, "O Allah's Apostle! Can the good bring about evil?" The Prophet remained silent and we thought that he was being inspired divinely, so all the people kept silent with awe. Then the Prophet wiped the sweat off his face and asked, "Where is the present questioner?" "Do you think wealth is good?" he repeated thrice, adding, "No doubt, good produces nothing but good. Indeed it is like what grows on the banks of a stream which either kills or nearly kills the grazing animals because of gluttony except the vegetation-eating animal which eats till both its flanks are full (i.e. till it gets satisfied) and then stands in the sun and defecates and urinates and again starts grazing. This worldly property is sweet vegetation. How excellent the wealth of the Muslim is, if it is collected through legal means and is spent in Allah's Cause and on orphans, poor people and travelers. But he who does not take it legally is like an eater who is never satisfied and his wealth will be a witness against him on the Day of Resurrection."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.96]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 96

Narrated Zaid bin Khalid:

Allah's Apostle said, " He who pre pares a Ghazi going in Allah's Cause is given a reward equal to that of) a Ghazi; and he who looks after properly the dependents of a Ghazi going in Allah's Cause is (given a reward equal to that of) Ghazi."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.97]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 97

Narrated Anas:

The Prophet used not to enter any house in Medina except the house of Um Sulaim besides those of his wives when he was asked why, he said, "I take pity on her as her brother was killed in my company. "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.98]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 98

Narrated Ibn Aun:

Once Musa bin Anas while describing the battle of Yamama, said, "Anas bin Malik went to Thabit bin Qais, who had lifted his clothes from his thighs and was applying Hunut to his body. Anas asked, 'O Uncle! What is holding you back (from the battle)?' He replied, 'O my nephew! I am coming just now,' and went on perfuming himself with Hunut, then he came and sat (in the row). Anas then mentioned that the people fled from the battle-field. On that Thabit said, 'Clear the way for me to fight the enemy. We would never do so (i.e. flee) in the company of Allah's Apostle. How bad the habits you have acquired from your enemies!"


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.99]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 99

Narrated Jabir:

The Prophet said, "Who will bring me the information about the enemy on the day (of the battle) of Al-Ahzab (i.e. Clans)?" Az-Zubair said, "I will." The Prophet said again, "Who will bring me the information about the enemy?" Az-Zubair said again, "I will." The Prophet said, "Every prophet had a disciple and my disciple is Az-Zubair. "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.100]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 100

Narrated Jabir bin 'Abdullah:

When the Prophet called the people (Sadqa, a sub-narrator, said, 'Most probably that happened on the day of Al-Khandaq) Az-Zubair responded to the call (i.e. to act as a reconnoiter). The Prophet) called the people again and Az-Zubair responded to the call. The Prophet then said, "Every prophet had a disciple and my disciple is Zubair bin Al-'Awwam."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.101]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 101

Narrated Malik bin Al-Huwairith:

On my departure from the Prophet he said to me and to a friend of mine, "You two, pronounce the Adhan and the Iqama for the prayer and let the elder of you lead the prayer."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.102]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 102

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Good will remain (as a permanent quality) in the foreheads of horses till the Day of Resurrection."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.103]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 103

Narrated Ursa bin ALGA:

The Prophet said, "Good will remain (as a permanent quality) in the foreheads of horses till the Day of Resurrection."

And narrated Anas bin Malik: Allah's Apostle said, "There is a blessing in the fore-heads of horses."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.104]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 104

Narrated 'Urwa Al-Bariqi:

The Prophet said, "Good will remain (as a permanent quality) in the foreheads of horses (for Jihad) till the Day of Resurrection, for they bring about either a reward (in the Hereafter) or booty (in this world."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.105]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 105

Narrated Abu Huraira:

The Prophet said, "If somebody keeps a horse in Allah's Cause motivated by his faith in Allah and his belief in His Promise, then he will be rewarded on the Day of Resurrection for what the horse has eaten or drunk and for its dung and urine."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.106]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 106

Narrated 'Abdullah bin Abi Qatada:

(from his father) Abu Qatada went out (on a journey) with Allah's Apostle but he was left behind with some of his companions who were in the state of Ihram. He himself was not in the state of Ihram. They saw an opener before he could see it. When they saw the opener, they did not speak anything till Abu Qatada saw it. So, he rode over his horse called Al-Jarada and requested them to give him his lash, but they refused. So, he himself took it and then attacked the opener and slaughtered it. He ate of its meat and his companions ate, too, but they regretted their eating. When they met the Prophet (they asked him about it) and he asked, "Have you some of its meat (left) with you?" Abu Qatada replied, "Yes, we have its leg with us." So, the Prophet took and ate it.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.107]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 107

Narrated Sahl:

In our garden there was a horse belonging to the Prophet called Al-Luhaif or Al-Lakhif.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.108]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 108

Narrated Mu'adh:

I was a companion rider of the Prophet on a donkey called 'Ufair. The Prophet asked, "O Mu'adh! Do you know what Allah's right on His slaves is, and what the right of His slaves on Him is?" I replied, "Allah and His Apostle know better." He said, "Allah's right on His slaves is that they should worship Him (Alone) and should not worship any besides Him. And slave's right on Allah is that He should not punish him who worships none besides Him." I said, "O Allah's Apostle! Should I not inform the people of this good news?" He said, "Do not inform them of it, lest they should depend on it (absolutely)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.109]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 109

Narrated Anas bin Malik:

Once there was a feeling of fright in Medina, so the Prophet borrowed a horse belonging to us called Mandub (and he rode away on it). (When the Prophet returned) he said, "I have not seen anything of fright and I found it (i.e. this horse) very fast."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.110]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 110

Narrated 'Abdullah bin 'Umar:

I heard the Prophet saying. "Evil omen is in three things: The horse, the woman and the house."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.111]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 111

Narrated Sahl bin Sad Saidi:

Allah's Apostle said "If there is any evil omen in anything, then it is in the woman, the horse and the house."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.112]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 112

Narrated Abu Huraira:

Allah's Apostle said, " Horses are kept for one of three purposes; for some people they are a source of reward, for some others they are a means of shelter and for some others they are a source of sins. The one for whom they are a source of reward, is he who keeps a horse for Allah's Cause (i.e. Jihad) tying it with a long tether on a meadow or in a garden with the result that whatever it eats from the area of the meadow or the garden where it is tied will be counted as good deeds for his benefit, and if it should break its rope and jump over one or two hillocks then all its dung and its foot marks will be written as good deeds for him; and if it passes by a river and drinks water from it even though he had no intention of watering it, even then he will get the reward for its drinking. As for the man for whom horses are a source of sins, he is the one who keeps a horse for the sake of pride and pretense and showing enmity for Muslims: such a horse will be a source of sins for him. When Allah's Apostle was asked about donkeys, he replied, "Nothing has been revealed to me about them except this unique, comprehensive Verse: "Then anyone who does an atom's (or a small ant's) weight of good shall see it; And anyone who does an atom's (or a small ant's) weight of evil, shall see it.' (101.7-8)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.113]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 113

Narrated Muslim from Abu Aqil from Abu Al-Mutawakkil An-Naji:

I called on Jabir bin 'Abdullah Al-Ansari and said to him, "Relate to me what you have heard from Allah's Apostle ." He said, "I accompanied him on one of the journeys." (Abu Aqil said, "I do not know whether that journey was for the purpose of Jihad or 'Umra.") "When we were returning," Jabir continued, "the Prophet said, 'Whoever wants to return earlier to his family, should hurry up.' We set off and I was on a black red tainted camel having no defect, and the people were behind me. While I was in that state the camel stopped suddenly (because of exhaustion). On that the Prophet said to me, 'O Jabir, wait!' Then he hit it once with his lash and it started moving on a fast pace. He then said, 'Will you sell the camel?' I replied in the affirmative when we reached Medina, and the Prophet went to the Mosque along with his companions. I, too, went to him after tying the camel on the pavement at the Mosque gate. Then I said to him, 'This is your camel.' He came out and started examining the camel and saying, 'The camel is ours.' Then the Prophet sent some Awaq (i.e. an amount) of gold saying, 'Give it to Jabir.' Then he asked, 'Have you taken the full price (of the camel)?' I replied in the affirmative. He said, 'Both the price and the camel are for you.' ''


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.114]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 114

Narrated Anas bin Malik:

There was a feeling of fright in Medina, so the Prophet borrowed a horse called Mandub belonging 'to Abu Talha and mounted it. (On his return), he said, "I did not see anything of fright and I found this horse very fast."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.115]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 115

Narrated Ibn 'Umar:

Allah's Apostle fixed two shares for the horse and one share for its rider (from the war booty).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.116]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 116

Narrated Abu Ishaq:

Somebody asked Al-Bar-a bin 'Azib, "Did you flee deserting Allah's Apostle during the battle of Hunain?" Al-Bara replied, "But Allah's Apostle did not flee. The people of the Tribe of Hawazin were good archers. When we met them, we attacked them, and they fled. When the Muslims started collecting the war booty, the pagans faced us with arrows, but Allah's Apostle did not flee. No doubt, I saw him on his white mule and Abu Sufyan was holding its reins and the Prophet was saying, 'I am the Prophet in truth: I am the son of 'Abdul Muttalib.' "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.117]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 117

Narrated Ibn'Umar:

When the Prophet put his feet in the stirrup and the she-camel got up carrying him he would start reciting Talbiya at the mosque of Dhul-Hulaifa.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.118]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 118

Narrated Anas:

The Prophet met them (i.e. the people) while he was riding an unsaddled horse with his sword slung over his shoulder.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.119]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 119

Narrated Anas bin Malik:

Once the people of Medina were frightened, so the Prophet rode a horse belonging to Abu Talha and it ran slowly, or was of narrow paces. When he returned, he said, "I found your (i.e. Abu Talha's) horse very fast. After that the horse could not be surpassed in running..'


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.120]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 120

Narrated ('Abdullah) bin 'Umar:

The Prophet arranged for a horse race amongst the horses that had been made lean to take place between Al-Hafya'' and Thaniyat Al-Wada' (i.e. names of two places) and the horses which had not been mad.? lean from Ath-Thaniyat to the mosque of Bani Zuraiq. I was also amongst those who took part in that horse race. Sufyan, a sub-narrator, said, "The distance between Al-Hafya and Thaniya Al-Wada' is five or six miles; and between Thaniya and the mosque of Bani Zuraiq is one mile."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.121]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 121

Narrated Abdullah:

The Prophet arranged for a horse race of the horses which had not been made lean; the area of the race was from Ath-Thaniya to the mosque of Bani Zuraiq. (The sub-narrator said, "'Abdullah bin 'Umar was amongst those who participated in that horse race.").


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.122]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 122

Narrated Abu Ishaq from Musa bin 'Uqba from Mafia from Ibn 'Umar who said:

"Allah's Apostle arranged a horse race amongst the horses that had been made lean, letting them start from Al-Hafya' and their limit (distance of running) was up to Thaniyat-al-Wada'. I asked Musa, 'What was the distance between the two places?' Musa replied, 'Six or seven miles. He arranged a race of the horses which had not been made lean sending them from Thaniyat-al-Wada', and their limit was up to the mosque of Bani Zuraiq.' I asked, 'What was the distance between those two places?' He replied 'One mile or so.' Ibn 'Umar was amongst those who participated in that horse race."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.123]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 123

Narrated Anas:

The she camel of the Prophet was called Al-Adba.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.124]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 124

Narrated Anas:

The Prophet had a she camel called Al Adba which could not be excelled in a race. (Humaid, a sub-narrator said, "Or could hardly be excelled.") Once a bedouin came riding a camel below six years of age which surpasses it (i.e. Al'Adba) in the race. The Muslims felt it so much that the Prophet noticed their distress. He then said, "It is Allah's Law that He brings down whatever rises high in the world."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.125]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 125

Narrated 'Amr bin Al-Harith:

The Prophet did not leave anything behind him after his death except a white mule, his arms and a piece of land which he left to be given in charity.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.126]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 126

Narrated Al-Bara:

that a man asked him. "O Abu 'Umara! Did you flee on the day (of the battle) of Hunain?" He replied, "No, by Allah, the Prophet did not flee but the hasty people fled and the people of the Tribe of Hawazin attacked them with arrows, while the Prophet was riding his white mule and Abu Sufyan bin Al-Harith was holding its reins, and the Prophet was saying, 'I am the Prophet in truth, I am the son of 'Abdul Muttalib.' "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.127]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 127

Narrated 'Aisha:

the mother of the faithful believers, I requested the Prophet permit me to participate in Jihad, but he said, "Your Jihad is the performance of Hajj."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.128]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 128

Narrated 'Aisha:

the mother of the faithful believers: The Prophet was asked by his wives about the Jihad and he replied, "The best Jihad (for you) is (the performance of) Hajj."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.129]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 129

Narrated Anas:

Allah's Apostle went to the daughter of Milhan and reclined there (and slept) and then (woke up) smiling. She asked, "O Allah's Apostle! What makes you smile?" He replied, (I dreamt that) some people amongst my followers were sailing on the green sea in Allah's Cause, resembling kings on thrones." She said, "O Allah's Apostle! Invoke Allah to make me one of them." He said, "O Allah! Let her be one of them." Then he (slept again and woke up and) smiled. She asked him the same question and he gave the same reply. She said, "Invoke Allah to make me one of them." He replied, ''You will be amongst the first group of them; you will not be amongst the last." Later on she married 'Ubada bin As-Samit and then she sailed on the sea with bint Qaraza, Mu'awiya's wife (for Jihad). On her return, she mounted her riding animal, which threw her down breaking her neck, and she died on falling down.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.130]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 130

Narrated 'Aisha:

Whenever the Prophet intended to proceed on a journey, he used to draw lots amongst his wives and would take the one upon whom the lot fell. Once, before setting out for Jihad, he drew lots amongst us and the lot came to me; so I went with the Prophet; and that happened after the revelation of the Verse Hijab (i.e. veiling).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.131]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 131

Narrated Anas:

On the day (of the battle) of Uhad when (some) people retreated and left the Prophet, I saw 'Aisha bint Abu Bakr and Um Sulaim, with their robes tucked up so that the bangles around their ankles were visible hurrying with their water skins (in another narration it is said, "carrying the water skins on their backs"). Then they would pour the water in the mouths of the people, and return to fill the water skins again and came back again to pour water in the mouths of the people.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.132]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 132

Narrated Tha'laba bin Abi Malik:

'Umar bin Al-Khattab distributed some garments amongst the women of Medina. One good garment remained, and one of those present with him said, "O chief of the believers! Give this garment to your wife, the (grand) daughter of Allah's Apostle." They meant Um Kulthum, the daughter of 'Ali. 'Umar said, Um Salit has more right (to have it)." Um Salit was amongst those Ansari women who had given the pledge of allegiance to Allah's Apostle.' 'Umar said, "She (i.e. Um Salit) used to carry the water skins for us on the day of Uhud."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.133]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 133

Narrated Ar-Rubayyi 'bint Mu'auwidh:

We were in the company of the Prophet providing the wounded with water and treating them and bringing the killed to Medina (from the battle field) .


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.134]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 134

Narrated Ar-Rabi'bint Mu'auwidh:

We used to take part in holy battles with the Prophet by providing the people with water and serving them and bringing the killed and the wounded back to Medina.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.135]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 135

Narrated Abu Musa:

Abu 'Amir was hit with an arrow in his knee, so I went to him and he asked me to remove the arrow. When I removed it, the water started dribbling from it. Then I went to the Prophet and told him about it. He said, "O Allah! Forgive 'Ubaid Abu 'Amir."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.136]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 136

Narrated 'Aisha:

The Prophet was vigilant one night and when he reached Medina, he said, "Would that a pious man from my companions guard me tonight!" Suddenly we heard the clatter of arms. He said, "Who is that? " He (The new comer) replied, " I am Sad bin Abi Waqqas and have come to guard you." So, the Prophet slept (that night).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.137]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 137

Narrated Abu Huraira:

The Prophet said, "Let the slave of Dinar and Dirham of Quantify and Khamisa (i.e. money and luxurious clothes) perish for he is pleased if these things are given to him, and if not, he is displeased!"

Narrated Abu Huraira: The Prophet said, " Let the slave of Dinar and Dirham, of Quantify and Khamisa perish as he is pleased if these things are given to him, and if not, he is displeased. Let such a person perish and relapse, and if he is pierced with a thorn, let him not find anyone to take it out for him. Paradise is for him who holds the reins of his horse to strive in Allah's Cause, with his hair unkempt and feet covered with dust: if he is appointed in the vanguard, he is perfectly satisfied with his post of guarding, and if he is appointed in the rearward, he accepts his post with satisfaction; (he is so simple and unambiguous that) if he asks for permission he is not permitted, and if he intercedes, his intercession is not accepted."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.138]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 138

Narrated Anas:

I was in the company of Jabir bin 'Abdullah on a journey and he used to serve me though he was older than I. Jarir said, "I saw the Ansar doing a thing (i.e. showing great reverence to the Prophet ) for which I have vowed that whenever I meet any of them, I will serve him."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.139]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 139

Narrated Anas bin Malik:

I went along with the Prophet to Khaibar so as to serve him. (Later on) when the Prophet returned he, on seeing the Uhud mountain, said, "This is a mountain that loves us andis loved by us." Then he pointed to Medina with his hand saying, "O Allah! I make the area which is in between Medina's two mountains a sanctuary, as Abraham made Mecca a sanctuary. O Allah! Bless us in our Sa and Mudd (i.e. units of measuring)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.140]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 140

Narrated Anas:

We were with the Prophet (on a journey) and the only shade one could have was the shade made by one's own garment. Those who fasted did not do any work and those who did not fast served the camels and brought the water on them and treated the sick and (wounded). So, the Prophet said, "Today, those who were not fasting took (all) the reward."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.141]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 141

Narrated Abu Huraira:

The Prophet said, "Charity is obligatory everyday on every joint of a human being. If one helps a person in matters concerning his riding animal by helping him to ride it or by lifting his luggage on to it, all this will be regarded charity. A good word, and every step one takes to offer the compulsory Congregational prayer, is regarded as charity; and guiding somebody on the road is regarded as charity."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.142]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 142

Narrated Sahl bin Sad As-Sa'di :

Allah's Apostle said, "To guard Muslims from infidels in Allah's Cause for one day is better than the world and whatever is on its surface, and a place in Paradise as small as that occupied by the whip of one of you is better than the world and whatever is on its surface; and a morning's or an evening's journey which a slave (person) travels in Allah's Cause is better than the world and whatever is on its surface."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.143]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 143

Narrated Anas bin Malik:

The Prophet said to Abu Talha, "Choose one of your boy servants to serve me in my expedition to Khaibar." So, Abu Talha took me letting me ride behind him while I was a boy nearing the age of puberty. I used to serve Allah's Apostle when he stopped to rest. I heard him saying repeatedly, "O Allah! I seek refuge with You from distress and sorrow, from helplessness and laziness, from miserliness and cowardice, from being heavily in debt and from being overcome by men." Then we reached Khaibar; and when Allah enabled him to conquer the Fort (of Khaibar), the beauty of Safiya bint Huyai bin Akhtab was described to him. Her husband had been killed while she was a bride. So Allah's Apostle selected her for himself and took her along with him till we reached a place called Sad-AsSahba,' where her menses were over and he took her for his wife. Haris (a kind of dish) was served on a small leather sheet. Then Allah's Apostle told me to call those who were around me. So, that was the marriage banquet of Allah's Apostle and Safiya. Then we left for Medina. I saw Allah's Apostle folding a cloak round the hump of the camel so as to make a wide space for Safiya (to sit on behind him) He sat beside his camel letting his knees for Safiya to put her feet on so as to mount the camel. Then, we proceeded till we approached Medina; he looked at Uhud (mountain) and said, "This is a mountain which loves us and is loved by us." Then he looked at Medina and said, "O Allah! I make the area between its (i.e. Medina's) two mountains a sanctuary as Abraham made Mecca a sanctuary. O Allah! Bless them (i.e. the people of Medina) in their Mudd and Sa (i.e. measures)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.144]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 144

Narrated Anas bin Malik:

Um Haram told me that the Prophet one day took a midday nap in her house. Then he woke up smiling. Um Haram asked, "O Allah's Apostle! What makes you smile?" He replied "I was astonished to see (in my dream) some people amongst my followers on a sea-voyage looking like kings on the thrones." She said, "O Allah's Apostle! Invoke Allah to make me one of them." He replied, "You are amongst them." He slept again and then woke up smiling and said the same as before twice or thrice. And she said, "O Allah's Apostle! Invoke Allah to make me one of them." And he said, "You are amongst the first batch." 'Ubada bin As-Samit married her (i.e. Um Haram) and then he took her for Jihad. When she returned, an animal was presented to her to ride, but she fell down and her neck was broken.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.145]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 145

Narrated Mus'ab bin Sad:

Once Sad (bin Abi Waqqas) thought that he was superior to those who were below him in rank. On that the Prophet said, "You gain no victory or livelihood except through (the blessings and invocations of) the poor amongst you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.146]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 146

Narrated Abu Said Al-Khudri

The Prophet said, "A time will come when groups of people will go for Jihad and it will be asked, 'Is there anyone amongst you who has enjoyed the company of the Prophet?' The answer will be, 'Yes.' Then they will be given victory (by Allah) (because of him). Then a time will come when it will be asked. 'Is there anyone amongst you who has enjoyed the company of the companions of the Prophet?' It will be said, 'Yes,' and they will be given victory (by Allah). Then a time will come when it will be said. 'Is there anyone amongst you who has enjoyed the company of the companions of the companions of the Prophet?' It will be said, 'Yes,' and they will be given victory (by Allah)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.147]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 147

Narrated Sahl bin Sad As-Sa'idi:

Allah's Apostle and the pagans faced each other and started fighting. When Allah's Apostle returned to his camp and when the pagans returned to their camp, somebody talked about a man amongst the companions of Allah's Apostle who would follow and kill with his sword any pagan going alone. He said, "Nobody did his job (i.e. fighting) so properly today as that man." Allah's Apostle said, "Indeed, he is amongst the people of the (Hell) Fire." A man amongst the people said, "I shall accompany him (to watch what he does)" Thus he accompanied him, and wherever he stood, he would stand with him, and wherever he ran, he would run with him.

Then the (brave) man got wounded seriously and he decided to bring about his death quickly. He planted the blade of the sword in the ground directing its sharp end towards his chest between his two breasts. Then he leaned on the sword and killed himself. The other man came to Allah's Apostle and said, "I testify that you are Allah's Apostle." The Prophet asked, "What has happened?" He replied, "(It is about) the man whom you had described as one of the people of the (Hell) Fire. The people were greatly surprised at what you said, and I said, 'I will find out his reality for you.' So, I came out seeking him. He got severely wounded, and hastened to die by slanting the blade of his sword in the ground directing its sharp end towards his chest between his two breasts. Then he eased on his sword and killed himself." when Allah's Apostle said, "A man may seem to the people as if he were practising the deeds of the people of Paradise while in fact he is from the people of the Hell) Fire, another may seem to the people as if he were practicing the deeds of the people of Hell (Fire), while in fact he is from the people of Paradise."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.148]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 148

Narrated Salama bin Al-Akwa:

The Prophet passed by some people of the tribe of Bani Aslam who were practicing archery. The Prophet said, "O Bani Ismail ! Practice archery as your father Isma'il was a great archer. Keep on throwing arrows and I am with Bani so-and-so." So one of the parties ceased throwing. Allah's Apostle said, "Why do you not throw?" They replied, "How should we throw while you are with them (i.e. on their side)?" On that the Prophet said, "Throw, and I am with all of you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.149]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 149

Narrated Abu Usaid:

On the day (of the battle) of Badr when we stood in rows against (the army of) Quraish and they stood in rows against us, the Prophet said, "When they do come near you, throw arrows at them."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.150]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 150

Narrated Abu Huraira:

While some Ethiopians were playing in the presence of the Prophet, 'Umar came in, picked up a stone and hit them with it. On that the Prophet said, "O 'Umar! Allow them (to play)." Ma'mar (the sub-narrator) added that they were playing in the Mosque.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.151]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 151

Narrated Anas bin Malik:

Abu Talha and the Prophet used to shield themselves with one shield. Abu Talha was a good archer, and when he threw (his arrows) the Prophet would look at the target of his arrows.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.152]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 152

Narrated Sahl:

When the helmet of the Prophet was smashed on his head and blood covered his face and one of his front teeth got broken, 'Ali brought the water in his shield and Fatima the Prophet's daughter) washed him. But when she saw that the bleeding increased more by the water, she took a mat, burnt it, and placed the ashes on the wound of the Prophet and so the blood stopped oozing out.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.153]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 153

Narrated 'Umar:

The properties of Bani An-Nadir which Allah had transferred to His Apostle as Fai Booty were not gained by the Muslims with their horses and camels. The properties therefore, belonged especially to Allah's Apostle who used to give his family their yearly expenditure and spend what remained thereof on arms and horses to be used in Allah's Cause.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.154]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 154

Narrated Ali:

I never saw the Prophet saying, "Let my parents sacrifice their lives for you," to any man after Sad. I heard him saying (to him), "Throw (the arrows)! Let my parents sacrifice their lives for you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.155]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 155

Narrated 'Aisha:

Allah's Apostle came to my house while two girls were singing beside me the songs of Bu'ath (a story about the war between the two tribes of the Ansar, i.e. Khazraj and Aus, before Islam.) The Prophet reclined on the bed and turned his face to the other side. Abu Bakr came and scolded me and said protestingly, "Instrument of Satan in the presence of Allah's Apostle?" Allah's Apostle turned his face towards him and said, "Leave them." When Abu Bakr became inattentive, I waved the two girls to go away and they left. It was the day of 'Id when negroes used to play with leather shields and spears. Either I requested Allah's Apostle or he himself asked me whether I would like to see the display. I replied in the affirmative. Then he let me stand behind him and my cheek was touching his cheek and he was saying, "Carry on, O Bani Arfida (i.e. negroes)!" When I got tired, he asked me if that was enough. I replied in the affirmative and he told me to leave.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.156]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 156

Narrated Anas:

The 'Prophet was the best and the bravest amongst the people. Once the people of Medina got terrified at night, so they went in the direction of the noise (that terrified them). The Prophet met them (on his way back) after he had found out the truth. He was riding an unsaddled horse belonging to Abu Talha and a sword was hanging by his neck, and he was saying, "Don't be afraid! Don't be afraid!" He further said, "I found it (i.e. the horse) very fast," or said, "This horse is very fast." (Qastala-ni)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.157]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 157

Narrated Abu Umama:

Some people conquered many countries and their swords were decorated neither with gold nor silver, but they were decorated with leather, lead and iron.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.158]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 158

Narrated Jabir bin Abdullah:

That he proceeded in the company of Allah's Apostle towards Najd to participate in a Ghazwa. (Holy-battle) When Allah's Apostle returned, he too returned with him. Midday came upon them while they were in a valley having many thorny trees. Allah's Apostle and the people dismounted and dispersed to rest in the shade of the trees. Allah's Apostle rested under a tree and hung his sword on it. We all took a nap and suddenly we heard Allah's Apostle calling us. (We woke up) to see a bedouin with him. The Prophet said, "This bedouin took out my sword while I was sleeping and when I woke up, I found the unsheathed sword in his hand and he challenged me saying, 'Who will save you from me?' I said thrice, 'Allah.' The Prophet did not punish him but sat down.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.159]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 159

Narrated Sahl:

That he was asked about the wound of the Prophet on the day (of the battle) of Uhud. He said, "The face of the Prophet as wounded and one of his front teeth as broken and the helmet over his head was smashed. Fatima washed of the blood while Ali held water. When she saw that bleeding was increasing continuously, she burnt a mat (of date-palm leaves) till it turned into ashes which she put over the wound and thus the bleeding ceased."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.160]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 160

Narrated 'Amr bin Al-Harith:

The Prophet did not leave behind him after his death, anything except his arms, his white mule, and a piece of land at Khaibar which he left to be given in charity .


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.161]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 161

Narrated Jabir:

as above (Hadith No. 158).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.162]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 162

Narrated Jabir bin 'Abdullah:

That he participated in a Ghazwa (Holy-Battle) in the company of Allah's Apostle. Midday came upon them while they were in a valley having many thorny trees. The people dispersed to rest in the shade of the trees. The Prophet rested under a tree, hung his sword on it, and then slept. Then he woke up to find near to him, a man whose presence he had not noticed before. The Prophet said, "This (man) took my sword (out of its scabbard) and said, 'Who will save you from me.' I replied, 'Allah.' So, he put the sword back into its scabbard, and you see him sitting here." Anyhow, the Prophet did not punish him. (See Hadith No. 158)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.163]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 163

Narrated Abu Qatada:

That he was in the company of Allah's Apostle and when they had covered a portion of the road to Mecca, he and some of the companions lagged behind. The latter were in a state of Ihram, while he was not. He saw an onager and rode his horse and requested his companions to give him his lash but they refused. Then he asked them to give him his spear but they refused, so he took it himself, attacked the onager, and killed it. Some of the companions of the Prophet ate of it while some others refused to eat. When they caught up with Allah's Apostle they asked him about that, and he said, "That was a meal Allah fed you with." (It is also said that Allah's Apostle asked, "Have you got something of its meat?")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.164]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 164

Narrated Ibn 'Abbas:

The Prophet , while in a tent (on the day of the battle of Badr) said, "O Allah! I ask you the fulfillment of Your Covenant and Promise. O Allah! If You wish (to destroy the believers) You will never be worshipped after today." Abu Bakr caught him by the hand and said, "This is sufficient, O Allah's Apostle! You have asked Allah pressingly." The Prophet was clad in his armor at that time. He went out, saying to me: "There multitude will be put to flight and they will show their backs. Nay, but the Hour is their appointed time (for their full recompense) and that Hour will be more grievous and more bitter (than their worldly failure)." (54.45-46) Khalid said that was on the day of the battle of Badr.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.165]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 165

Narrated 'Aisha:

Allah's Apostle died while his (iron) armor was mortgaged to a Jew for thirty Sas of barley.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.166]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 166

Narrated Abu Huraira:

The Prophet said, "The example of a miser and the one who gives in charity, is like the example of two men wearing iron cloaks so tightly that their arms are raised forcibly towards their collar-bones. So, whenever a charitable person wants to give in charity, his cloak spreads over his body so much so that it wipes out his traces, but whenever the miser wants to give in charity, the rings (of the iron cloak) come closer to each other and press over his body, and his hands gets connected to his collar-bones. Abu Huraira heard the Prophet saying. "The miser then tries to widen it but in vain."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.167]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 167

Narrated Al-Mughira bin Shu'ba:

Allah's Apostle went out to answer the call of nature and on his return I brought some water to him. He performed the ablution while he was wearing a Sha'mi cloak. He rinsed his mouth and washed his nose by putting water in it and then blowing it out, and washed his face. Then he tried to take out his hands through his sleeves but they were tight, so he took them out from underneath, washed them and passed wet hands over his head and over his leather socks.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.168]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 168

Narrated Anas:

The Prophet allowed 'Abdur-Rahman bin 'Auf and Az-Zubair to wear silken shirts because they had a skin disease causing itching.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.169]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 169

Narrated Anas:

as above.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.170]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 170

Narrated Anas:

Abdur Rahman bin 'Auf and Az-Zubair complained to the Prophet, i.e. about the lice (that caused itching) so he allowed them to wear silken clothes. I saw them wearing such clothes in a holy battle.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.171]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 171

Narrated Anas:

The Prophet allowed 'Abdur-Rahman bin 'Auf and Az-Zubair bin Al-'Awwam to wear silk.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.172]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 172

Narrated Anas:

(Wearing of silk) was allowed to them (i.e. 'AbdurRahman and Az-Zubair) because of the itching they suffered from.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.173]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 173

Narrated Umaiya Ad-Damri:

I saw the Prophet eating of a shoulder (of a sheep) by cutting from it and then he was called to prayer and he prayed without repeating his ablution.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.174]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 174

Narrated Az-Zuhri:

as above (Hadith No. 173...) and added that the Prophet put the knife down.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.175]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 175

Narrated Khalid bin Madan:

That 'Umair bin Al-Aswad Al-Anasi told him that he went to 'Ubada bin As-Samit while he was staying in his house at the sea-shore of Hims with (his wife) Um Haram. 'Umair said. Um Haram informed us that she heard the Prophet saying, "Paradise is granted to the first batch of my followers who will undertake a naval expedition." Um Haram added, I said, 'O Allah's Apostle! Will I be amongst them?' He replied, 'You are amongst them.' The Prophet then said, 'The first army amongst' my followers who will invade Caesar's City will be forgiven their sins.' I asked, 'Will I be one of them, O Allah's Apostle?' He replied in the negative."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.176]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 176

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "You (i.e. Muslims) will fight wi the Jews till some of them will hide behind stones. The stones will (betray them) saying, 'O 'Abdullah (i.e. slave of Allah)! There is a Jew hiding behind me; so kill him.' "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.177]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 177

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established until you fight with the Jews, and the stone behind which a Jew will be hiding will say. "O Muslim! There is a Jew hiding behind me, so kill him."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.178]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 178

Narrated 'Amr bin Taghlib:

The Prophet said, "One of the portents of the Hour is that you will fight with people wearing shoes made of hair; and one of the portents of the Hour is that you will fight with broad-faced people whose faces will look like shields coated with leather."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.179]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 179

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established until you fight with the Turks; people with small eyes, red faces, and flat noses. Their faces will look like shields coated with leather. The Hour will not be established till you fight with people whose shoes are made of hair."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.180]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 180

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till you fight with people wearing shoes made of hair. And the Hour will not be established till you fight with people whose faces look like shields coated with leather. " (Abu Huraira added, "They will be) small-eyed, flat nosed, and their faces will look like shields coated with leather.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.181]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 181

Narrated Abu Ishaq:

A man asked Al-Bara', "O Abu 'Umara! Did you all flee on the day (of the battle) of Hunain?" He replied, "No, by Allah! Allah's Apostle did not flee, but his young unarmed companions passed by the archers of the tribe of Hawazin and Bani Nasr whose arrows hardly missed a target, and they threw arrows at them hardly missing a shot. So the Muslims retreated towards the Prophet while he was riding his white mule which was being led by his cousin Abu Sufyan bin Al-Harith bin 'Abdul Muttalib. The Prophet dismounted and invoked Allah for victory; then he said, 'I am the Prophet, without a lie; I am the son of 'Abdul Muttalib, and then he arranged his companions in rows."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.182]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 182

Narrated 'Ali:

When it was the day of the battle of Al-Ahzab (i.e. the clans), Allah's Apostle said, "O Allah! Fill their (i.e. the infidels') houses and graves with fire as they busied us so much that we did not perform the prayer (i.e. 'Asr) till the sun set."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.183]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 183

Narrated Abu Huraira:

The Prophet used to recite the following invocations during Qunut: "O Allah! Save Salama bin Hisham. O Allah! Save Al-Walid bin Al-Walid. O Allah! Save 'Aiyash bin Rabi'a O Allah ! Save the weak Muslims. O Allah! Be very hard on Mudar tribe. O Allah! Afflict them with years (of famine) similar to the (famine) years of the time of Prophet Joseph."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.184]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 184

Narrated 'Abdullah bin Abi Aufa:

Allah's Apostle invoked evil upon the pagans on the ay (of the battle) of Al-Ahzab, saying, "O Allah! The Revealer of the Holy Book, the Swift-Taker of Accounts, O Allah, defeat Al-Ahzab (i.e. the clans), O Allah, defeat them and shake them."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.185]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 185

Narrated Abdullah:

Once the Prophet was offering the prayer in the shade of the Ka'ba. Abu Jahl and some Quraishi men sent somebody to bring the abdominal contents of a shecamel which had been slaughtered somewhere in Mecca, and when he brought them, they put them over the Prophet Then Fatima (i.e. the Prophet's daughter) came and threw them away from him, and he said, "O Allah! Destroy (the pagans of) Quraish; O Allah! Destroy Quraish; O Allah Destroy Quraish," naming especially Abu Jahl bin Hisham, 'Utba bin Rabi'a, Shaiba bin Rabi'a, Al Walid bin 'Utba, Ubai bin Khalaf and 'Uqba bin Abi Mitt. (The narrator, 'Abdullah added, "I saw them all killed and thrown in the Badr well).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.186]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 186

Narrated 'Aisha:

Once the Jews came to the Prophet and said, "Death be upon you." So I cursed them. The Prophet said, "What is the matter?" I said, "Have you not heard what they said?" The Prophet said, "Have you not heard what I replied (to them)? (I said), ('The same is upon you.')"


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.187]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 187

Narrated 'Abdullah bin Abbas:

Allah's Apostle wrote a letter to Caesar saying, "If you reject Islam, you will be responsible for the sins of the peasants (i.e. your people)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.188]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 188

Narrated Abu Huraira:

Tufail bin 'Amr Ad-Dausi and his companions came to the Prophet and said, "O Allah's Apostle! The people of the tribe of Daus disobeyed and refused to follow you; so invoke Allah against them." The people said, "The tribe of Daus is ruined." The Prophet said, "O Allah! Give guidance to the people of Daus, and let them embrace Islam."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.189]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 189

Narrated Anas:

When the Prophet intended to write a letter to the ruler of the Byzantines, he was told that those people did not read any letter unless it was stamped with a seal. So, the Prophet got a silver ring-- as if I were just looking at its white glitter on his hand ---- and stamped on it the expression "Muhammad, Apostle of Allah".


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.190]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 190

Narrated 'Abdullah bin 'Abbas:

Allah's Apostle sent his letter to Khusrau and ordered his messenger to hand it over to the Governor of Bahrain who was to hand it over to Khusrau. So, when Khusrau read the letter he tore it. Said bin Al-Musaiyab said, "The Prophet then invoked Allah to disperse them with full dispersion, (destroy them (i.e. Khusrau and his followers) severely)".


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.191]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 191

Narrated Abdullah bin Abbas:

Allah's Apostle wrote to Caesar and invited him to Islam and sent him his letter with Dihya Al-Kalbi whom Allah's Apostle ordered to hand it over to the Governor of Busra who would forward it to Caesar. Caesar as a sign of gratitude to Allah, had walked from Hims to Ilya (i.e. Jerusalem) when Allah had granted Him victory over the Persian forces. So, when the letter of Allah's Apostle reached Caesar, he said after reading t, 'Seek for me any one of his people! (Arabs of Quraish tribe) if present here, in order to ask him about Allah's Apostle. At that time Abu Sufyan bin Harb was in Sham with some men frown Quraish who had come (to Sham) as merchants during the truce that had been concluded between Allah's Apostle; and the infidels of Quraish. Abu Sufyan said, Caesar's messenger found us somewhere in Sham so he took me and my companions to Ilya and we were admitted into Ceasar's court to find him sitting in his royal court wearing a crown and surrounded by the senior dignitaries of the Byzantine. He said to his translator. 'Ask them who amongst them is a close relation to the man who claims to be a prophet." Abu Sufyan added, "I replied, 'I am the nearest relative to him.' He asked, 'What degree of relationship do you have with him?' I replied, 'He is my cousin,' and there was none of Bani Abu Manaf in the caravan except myself. Caesar said, 'Let him come nearer.' He then ordered that my companions stand behind me near my shoulder and said to his translator, 'Tell his companions that I am going to ask this man about the man who claims to be a prophet. If he tells a lie, they should contradict him immediately." Abu Sufyan added, "By Allah ! Had it not been shameful that my companions label me a liar, I would not have spoken the truth about him when he asked me. But I considered it shameful to be called a liar by my companions. So I told the truth. He then said to his translator, 'Ask him what kind of family does he belong to.' I replied, 'He belongs to a noble family amongst us.' He said, 'Have anybody else amongst you ever claimed the same before him? 'I replied, 'No.' He said, 'Had you ever blamed him for telling lies before he claimed what he claimed? ' I replied, 'No.' He said, 'Was anybody amongst his ancestors a king?' I replied, 'No.' He said, "Do the noble or the poor follow him?' I replied, 'It is the poor who follow him.' He said, 'Are they increasing or decreasing (day by day)?' I replied,' They are increasing.' He said, 'Does anybody amongst those who embrace his (the Prophet's) Religion become displeased and then discard his Religion?'. I replied, 'No. ' He said, 'Does he break his promises? I replied, 'No, but we are now at truce with him and we are afraid that he may betray us." Abu Sufyan added, "Other than the last sentence, I could not say anything against him. Caesar then asked, 'Have you ever had a war with him?' I replied, 'Yes.' He said, 'What was the outcome of your battles with him?' I replied, 'The result was unstable; sometimes he was victorious and sometimes we.' He said, 'What does he order you to do?' I said, 'He tells us to worship Allah alone, and not to worship others along with Him, and to leave all that our fore-fathers used to worship. He orders us to pray, give in charity, be chaste, keep promises and return what is entrusted to us.' When I had said that, Caesar said to his translator, 'Say to him: I ask you about his lineage and your reply was that he belonged to a noble family. In fact, all the apostles came from the noblest lineage of their nations. Then I questioned you whether anybody else amongst you had claimed such a thing, and your reply was in the negative. If the answer had been in the affirmative, I would have thought that this man was following a claim that had been said before him. When I asked you whether he was ever blamed for telling lies, your reply was in the negative, so I took it for granted that a person who did not tell a lie about (others) the people could never tell a lie about Allah. Then I asked you whether any of his ancestors was a king. Your reply was in the negative, and if it had been in the affirmative, I would have thought that this man wanted to take back his ancestral kingdom. When I asked you whether the rich or the poor people followed him, you replied that it was the poor who followed him. In fact, such are the followers of the apostles. Then I asked you whether his followers were increasing or decreasing. You replied that they were increasing. In fact, this is the result of true faith till it is complete (in all respects). I asked you whether there was anybody who, after embracing his religion, became displeased and discarded his religion; your reply was in the negative. In fact, this is the sign of true faith, for when its cheerfulness enters and mixes in the hearts completely, nobody will be displeased with it. I asked you whether he had ever broken his promise. You replied in the negative. And such are the apostles; they never break their promises. When I asked you whether you fought with him and he fought with you, you replied that he did, and that sometimes he was victorious and sometimes you. Indeed, such are the apostles; they are put to trials and the final victory is always theirs. Then I asked you what he ordered you. You replied that he ordered you to worship Allah alone and not to worship others along with Him, to leave all that your fore-fathers used to worship, to offer prayers, to speak the truth, to be chaste, to keep promises, and to return what is entrusted to you. These are really the qualities of a prophet who, I knew (from the previous Scriptures) would appear, but I did not know that he would be from amongst you. If what you say should be true, he will very soon occupy the earth under my feet, and if I knew that I would reach him definitely, I would go immediately to meet Him; and were I with him, then I would certainly wash his feet.' " Abu Sufyan added, "Caesar then asked for the letter of Allah's Apostle and it was read. Its contents were:--

"In the name of Allah, the most Beneficent, the most Merciful (This letter is) from Muhammad, the slave of Allah, and His Apostle, to Heraculius, the Ruler of the Byzantine. Peace be upon the followers of guidance. Now then, I invite you to Islam (i.e. surrender to Allah), embrace Islam and you will be safe; embrace Islam and Allah will bestow on you a double reward. But if you reject this invitation of Islam, you shall be responsible for misguiding the peasants (i.e. your nation). O people of the Scriptures! Come to a word common to you and us and you, that we worship. None but Allah, and that we associate nothing in worship with Him; and that none of us shall take others as Lords besides Allah. Then if they turn away, say: Bear witness that we are (they who have surrendered (unto Him)..(3.64)

Abu Sufyan added, "When Heraclius had finished his speech, there was a great hue and cry caused by the Byzantine Royalties surrounding him, and there was so much noise that I did not understand what they said. So, we were turned out of the court. When I went out with my companions and we were alone, I said to them, 'Verily, Ibn Abi Kabsha's (i.e. the Prophet's) affair has gained power. This is the King of Bani Al-Asfar fearing him." Abu Sufyan added, "By Allah, I remained low and was sure that his religion would be victorious till Allah converted me to Islam, though I disliked it "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.192]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 192

Narrated Sahl bin Sad:

That he heard the Prophet on the day (of the battle) of Khaibar saying, "I will give the flag to a person at whose hands Allah will grant victory." So, the companions of the Prophet got up, wishing eagerly to see to whom the flag will be given, and everyone of them wished to be given the flag. But the Prophet asked for 'Ali. Someone informed him that he was suffering from eye-trouble. So, he ordered them to bring 'Ali in front of him. Then the Prophet spat in his eyes and his eyes were cured immediately as if he had never any eye-trouble. 'Ali said, "We will fight with them (i.e. infidels) till they become like us (i.e. Muslims)." The Prophet said, "Be patient, till you face them and invite them to Islam and inform them of what Allah has enjoined upon them. By Allah! If a single person embraces Islam at your hands (i.e. through you), that will be better for you than the red camels."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.193]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 193

Narrated Anas:

Whenever Allah's Apostle attacked some people, he would never attack them till it was dawn. If he heard the Adhan (i.e. call for prayer) he would delay the fight, and if he did not hear the Adhan, he would attack them immediately after dawn. We reached Khaibar at night.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.194]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 194

Narrated Anas: as Hadith No. 193 above.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.195]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 195

Narrated Anas:

The Prophet set out for Khaibar and reached it at night. He used not to attack if he reached the people at night, till the day broke. So, when the day dawned, the Jews came out with their bags and spades. When they saw the Prophet; they said, "Muhammad and his army!" The Prophet said, Allahu--Akbar! (Allah is Greater) and Khaibar is ruined, for whenever we approach a nation (i.e. enemy to fight) then it will be a miserable morning for those who have been warned."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.196]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 196

Narrated Abu Huraira:

Allah 's Apostle said, " I have been ordered to fight with the people till they say, 'None has the right to be worshipped but Allah,' and whoever says, 'None has the right to be worshipped but Allah,' his life and property will be saved by me except for Islamic law, and his accounts will be with Allah, (either to punish him or to forgive him.)"


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.197]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 197

Narrated Ka'b bin Malik:

Whenever Allah's Apostle intended to lead a Ghazwa, he would use an equivocation from which one would understand that he was going to a different destination .


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.198]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 198

Narrated Ka'b bin Malik:

Whenever Allah's Apostle intended to carry out a Ghazwa, he would use an equivocation to conceal his real destination till it was the Ghazwa of Tabuk which Allah's Apostle carried out in very hot weather. As he was going to face a very long journey through a wasteland and was to meet and attack a large number of enemies. So, he made the situation clear to the Muslims so that they might prepare themselves accordingly and get ready to conquer their enemy. The Prophet informed them of the destination he was heading for (Ka'b bin Malik used to say, "Scarcely did Allah's Apostle set out for a journey on a day other than Thursday.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.199]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 199

Narrated Ka'b bin Malik:

The Prophet set out on Thursday for the Ghazwa of Tabuk and he used to prefer to set out (i.e. travel) on Thursdays.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.200]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 200

Narrated Anas:

The Prophet offered a four-Rak'at Zuhr prayer at Medina and then offered a two Rak'at 'Asr prayer at Dhul-Hulaifa and I heard the companions of the Prophet reciting Talbiya aloud (for Hajj and 'Umra) altogether.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.201]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 201

Narrated 'Aisha:

We set out in the company of Allah's Apostle five days before the end of Dhul Qa'da intending to perform Hajj only. When we approached Mecca Allah's Apostle ordered those who did not have the Hadi (i.e. an animal for sacrifice) with them, to perform the Tawaf around the Ka'ba, and between Safa and Marwa and then finish their Ihram. Beef was brought to us on the day of (i.e. the days of slaughtering) and I asked, "What is this?" Somebody said, Allah's Apostle has slaughtered (a cow) on behalf of his wives."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.202]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 202

Narrated Ibn 'Abbas:

Once the Prophet set out in the month of Ramadan. He observed fasting till he reached a place called Kadid where he broke his fast.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.203]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 203

Narrated Ibn 'Umar:

The 'Prophet said, "It is obligatory for one to listen to and obey (the ruler's orders) unless these orders involve one disobedience (to Allah); but if an act of disobedience (to Allah) is imposed, he should not listen to or obey it."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.204]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 204

Narrated Abu Huraira:

That heard Allah's Apostle saying, "We are the last but will be the foremost to enter Paradise)." The Prophet added, "He who obeys me, obeys Allah, and he who disobeys me, disobeys Allah. He who obeys the chief, obeys me, and he who disobeys the chief, disobeys me. The Imam is like a shelter for whose safety the Muslims should fight and where they should seek protection. If the Imam orders people with righteousness and rules justly, then he will be rewarded for that, and if he does the opposite, he will be responsible for that."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.205]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 205

Narrated Ibn 'Umar:

When we reached (Hudaibiya) in the next year (of the treaty of Hudaibiya), not even two men amongst us agreed unanimously as to which was the tree under which we had given the pledge of allegiance, and that was out of Allah's Mercy. (The sub narrator asked Naf'i, "For what did the Prophet take their pledge of allegiance, was it for death?" Naf'i replied "No, but he took their pledge of allegiance for patience.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.206]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 206

Narrated 'Abdullah bin Zaid:

that in the time (of the battle) of Al-Harra a person came to him and said, "Ibn Hanzala is taking the pledge of allegiance from the people for death." He said, "I will never give a pledge of allegiance for such a thing to anyone after Allah's Apostle."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.207]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 207

Narrated Yazid bin Ubaid:

Salama said, "I gave the Pledge of allegiance (Al-Ridwan) to Allah's Apostle and then I moved to the shade of a tree. When the number of people around the Prophet diminished, he said, 'O Ibn Al-Akwa ! Will you not give to me the pledge of Allegiance?' I replied, 'O Allah's Apostle! I have already given to you the pledge of Allegiance.' He said, 'Do it again.' So I gave the pledge of allegiance for the second time." I asked 'O Abu Muslim! For what did you give he pledge of Allegiance on that day?" He replied, "We gave the pledge of Allegiance for death."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.208]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 208

Narrated Anas:

On the day (of the battle) of the Trench, the Ansar were saying, "We are those who have sworn allegiance to Muhammad for Jihaid (for ever) as long as we live." The Prophet replied to them, "O Allah! There is no life except the life of the Hereafter. So honor the Ansar and emigrants with Your Generosity."

And Narrated Mujashi: My brother and I came to the Prophet and I requested him to take the pledge of allegiance from us for migration. He said, "Migration has passed away with its people." I asked, "For what will you take the pledge of allegiance from us then?" He said, "I will take (the pledge) for Islam and Jihad."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.209]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 209

Narrated Abdullah:

Today a man came to me and asked me a question which I did not know how to answer. He said, "Tell me, if a wealthy active man, well-equipped with arms, goes out on military expeditions with our chiefs, and orders us to do such things as we cannot do (should we obey him?)" I replied, "By Allah, I do not know what to reply you, except that we, were in the company of the Prophet and he used to order us to do a thing once only till we finished it. And no doubt, everyone among you will remain in a good state as long as he obeys Allah. If one is in doubt as to the legality of something, he should ask somebody who would satisfy him, but soon will come a time when you will not find such a man. By Him, except Whom none has the right to be worshipped. I see that the example of what has passed of this life (to what remains thereof) is like a pond whose fresh water has been used up and nothing remains but muddy water."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.210]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 210

Narrated Salim Abu An-Nadr:

The freed slave of 'Umar bin 'Ubaidullah who was 'Umar's clerk: 'Abdullah bin Abi Aufa wrote him (i.e. 'Umar) a letter that contained the following:--

"Once Allah's Apostle (during a holy battle), waited till the sun had declined and then he got up among the people and said, "O people! Do not wish to face the enemy (in a battle) and ask Allah to save you (from calamities) but if you should face the enemy, then be patient and let it be known to you that Paradise is under the shades of swords." He then said,, "O Allah! The Revealer of the (Holy) Book, the Mover of the clouds, and Defeater of Al-Ahzab (i.e. the clans of infidels), defeat them infidels and bestow victory upon us."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.211]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 211

Narrated Jabir bin 'Abdullah:

I participated in a Ghazwa along with Allah's Apostle The Prophet met me (on the way) while I was riding a camel of ours used for irrigation and it had got so tired that it could hardly walk. The Prophet asked me, "What is wrong with the camel?" I replied, "It has got tired." So. Allah's Apostle came from behind it and rebuked it and prayed for it so it started surpassing the other camels and going ahead of them. Then he asked me, "How do you find your camel (now)?" I replied, "I find it quite well, now as it has received your blessings." He said, "Will you sell it to me?" I felt shy (to refuse his offer) though it was the only camel for irrigation we had. So, I said, "Yes." He said, "Sell it to me then." I sold it to him on the condition that I should keep on riding it till I reached Medina. Then I said, "O Allah's Apostle! I am a bridegroom," and requested him to allow me to go home. He allowed me, and I set out for Medina before the people till I reached Medina, where I met my uncle, who asked me about the camel and I informed him all about it and he blamed me for that. When I took the permission of Allah's Apostle he asked me whether I had married a virgin or a matron and I replied that I had married a matron. He said, "Why hadn't you married a virgin who would have played with you, and you would have played with her?" I replied, "O Allah's Apostle! My father died (or was martyred) and I have some young sisters, so I felt it not proper that I should marry a young girl like them who would neither teach them manners nor serve them. So, I have married a matron so that she may serve them and teach them manners." When Allah's Apostle arrived in Medina, I took the camel to him the next morning and he gave me its price and gave me the camel itself as well.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.212]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 212

Narrated Anas bin Malik:

Once there was a feeling of fright at Medina, so Allah's Apostle rode a horse belonging to Abu Talha and (on his return) he said, "We have not seen anything (fearful), but we found this horse very fast."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.213]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 213

Narrated Anas bin Malik:

Once the people got frightened, so Allah's Apostle rode a slow horse belonging to Abu Talha, and he set out all alone, making the horse gallop. Then the people rode, making their horses gallop after him. On his return he said, "Don't be afraid (there is nothing to be afraid of) (and I have found) this horse a very fast one." That horse was never excelled in running hence forward. (Qastalani Vol. 5)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.214]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 214

Narrated 'Umar bin Al-Khattab:

I gave a horse to be used in Allah's Cause, but later on I saw it being sold. I asked the Prophet whether I could buy it. He said, "Don't buy it and don't take back your gift of charity."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.215]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 215

Narrated 'Abdullah bin 'Umar:

'Umar gave a horse to be used in Allah's Cause, but later on he found it being sold. So, he intended to buy it and asked Allah's Apostle who said, "Don't buy it and don't take back your gift of charity."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.216]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 216

Narrated Abu Huraira:

Allah's Apostle said, "Were it not for the fear that it would be difficult for my followers, I would not have remained behind any Sariya, (army-unit) but I don't have riding camels and have no other means of conveyance to carry them on, and it is hard for me that my companions should remain behind me. No doubt I wish I could fight in Allah's Cause and be martyred and come to life again to be martyred and come to life once more."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.217]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 217

Narrated Yali:

I participated in the Ghazwa of Tabuk along with Allah's Apostle and I gave a young camel to be ridden in Jihad and that was, to me, one of my best deeds. Then I employed a laborer who quarrelled with another person. One of them bit the hand of the other and the latter drew his hand from the mouth of the former pulling out his front tooth. Then the former instituted a suit against the latter before the Prophet who rejected that suit saying, "Do you expect him to put out his hand for you to snap as a male camel snaps (vegetation)?"


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.218]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 218

Narrated Tha'laba bin Abi Malik Al-Qurazi:

When Qais bin Sad Al-Ansari, who used to carry the flag of the Prophet, intended to perform Hajj, he combed his hair.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.219]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 219

Narrated Nafi bin Jubair:

I heard Al Abbas telling Az-Zubair, "The Prophet ordered you to fix the flag here."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.220]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 220

Narrated Abu Huraira:

Allah's Apostle said, "I have been sent with the shortest expressions bearing the widest meanings, and I have been made victorious with terror (cast in the hearts of the enemy), and while I was sleeping, the keys of the treasures of the world were brought to me and put in my hand." Abu Huraira added: Allah's Apostle has left the world and now you, people, are bringing out those treasures (i.e. the Prophet did not benefit by them).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.221]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 221

Narrated Ibn 'Abbas:

Abu Sufyan said, "Heraclius sent for me when I was in 'llya' (i.e. Jerusalem). Then he asked for the letter of Allah's Apostle and when he had finished its reading there was a great hue and cry around him and the voices grew louder and we were asked to quit the place. When we were turned out, I said to my companions, 'The cause of Ibn Abi Kabsha has become conspicuous as the King of Bani Al-Asfar is afraid of him.' "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.222]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 222

Narrated Asma:

I prepared the journey-food for Allah's Apostle in Abu Bakr's house when he intended to emigrate to Medina. I could not find anything to tie the food-container and the water skin with. So, I said to Abu Bakr, "By Allah, I do not find anything to tie (these things) with except my waist belt." He said, "Cut it into two pieces and tie the water-skin with one piece and the food-container with the other (the sub-narrator added, "She did accordingly and that was the reason for calling her Dhatun-Nitaqain (i.e. two-belted woman))."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.223]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 223

Narrated Jabir bin 'Abdullah:

During the life-time of the Prophet we used to take the meat of sacrificed animals (as journey food) to Medina. (See Hadith No. 474 Vol. 7)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.224]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 224

Narrated Suwaid bin An-Nu'man:

That he went out in the company o; the Prophet during the year of Khaibar (campaign till they reached a place called As-Sahba', the lower part of Khaibar. They offered the 'Asr prayer (there) and the Prophet asked for the food. Nothing but Sawiq was brought to the Prophet. So, they chewed it and ate it and drank water. After that the Prophet got up, washed his mouth, and they too washed their mouths and then offered the prayer.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.225]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 225

Narrated Salama:

Once the journey-food of the people ran short and they were in great need. So, they came to the Prophet to take his permission for slaughtering their camels, and he permitted them. Then 'Umar met them and they informed him about it. He said, "What will sustain you after your camels (are finished)?" Then 'Umar went to the Prophet and said, "O Allah's Apostle! What will sustain them after their camels (are finished)?" Allah's Apostle said, "Make an announcement amongst the people that they should bring all their remaining food (to me)." (They brought it and) the Prophet invoked Allah and asked for His Blessings for it. Then he asked them to bring their food utensils and the people started filling their food utensils with their hands till they were satisfied. Allah's Apostle then said, "I testify that None has the right to be worshipped but Allah, and I am His Apostle. "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.226]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 226

Narrated Wahb bin Kaisan:

Jabir bin 'Abdullah said, "We set out, and we were three-hundred men carrying our journey-food on our shoulders. Then we began to eat a single date each per day." A man asked (Jabir), "O Abu 'Abdullah! How could a person be satisfied with a single date?" Jabir replied, "We realized the value of that one date when we could not even have that much till we reached the sea-shore, when all of a sudden we saw a huge fish cast by the sea. So, we ate of it as much as we wished for eighteen days."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.227]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 227

Narrated Aisha:

That she said, "O Allah's Apostle! Your companions are returning with the reward of both Hajj and 'Umra, while I am returning with (the reward of) Hajj only." He said to her, "Go, and let 'Abdur-Rahman (i.e. your brother) make you sit behind him (on the animal)." So, he ordered 'AbdurRahman to let her perform 'Umra from Al-Tan'im. Then the Prophet waited for her at the higher region of Mecca till she returned.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.228]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 228

Narrated 'Abdur-Rahman bin Abi Bakr As-Siddiq:

The Prophet ordered me to let 'Aisha sit behind me (on the animal) and to let her perform 'Umra from At-Tan'im.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.229]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 229

Narrated Anas:

I was riding behind Abu Talha (on the same) riding animal) and (the Prophet's companions) were reciting Talbiya aloud for both Hajj and 'Umra.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.230]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 230

Narrated 'Urwa from Usama bin Zaid:

Allah's Apostle rode a donkey on which there was a saddle covered by a velvet sheet and let Usama ride behind him (on the donkey).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.231]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 231

Narrated Nafi from 'Abdullah:

Allah's Apostle came to Mecca through its higher region on the day of the Conquest (of Mecca) riding his she-camel on which Usama was riding behind him. Bilal and 'Uthman bin Talha, one of the servants of the Ka'ba, were also accompanying him till he made his camel kneel in the mosque and ordered the latter to bring the key of the Ka'ba. He opened the door of the Ka'ba and Allah's Apostle entered in the company of Usama, Bilal and 'Uthman, and stayed in it for a long period. When he came out, the people rushed to it, and 'Abdullah bin 'Umar was the first to enter it and found Bilal standing behind the door. He asked Bilal, "Where did the Prophet offer his prayer?" He pointed to the place where he had offered his prayer. 'Abdullah said, "I forgot to ask him how many Rakat he had performed."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.232]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 232

Narrated Abu Huraira:

Allah's Apostle said, "There is a (compulsory) Sadaqa (charity) to be given for every joint of the human body (as a sign of gratitude to Allah) everyday the sun rises. To judge justly between two persons is regarded as Sadaqa, and to help a man concerning his riding animal by helping him to ride it or by lifting his luggage on to it, is also regarded as Sadaqa, and (saying) a good word is also Sadaqa, and every step taken on one's way to offer the compulsory prayer (in the mosque) is also Sadaqa and to remove a harmful thing from the way is also Sadaqa."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.233]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 233

Narrated 'Abdullah bin 'Umar:

Allah's Apostle forbade the people to travel to a hostile country carrying (copies of) the Quran.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.234]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 234

Narrated Anas:

The Prophet reached Khaibar in the morning, while the people were coming out carrying their spades over their shoulders. When they saw him they said, "This is Muhammad and his army! Muhammad and his army!" So, they took refuge in the fort. The Prophet raised both his hands and said, "Allahu Akbar, Khaibar is ruined, for when we approach a nation (i.e. enemy to fight) then miserable is the morning of the warned ones." Then we found some donkeys which we (killed and) cooked: The announcer of the Prophet announced: "Allah and His Apostle forbid you to eat donkey's meat." So, all the pots including their contents were turned upside down.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.235]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 235

Narrated Abu Musa Al-Ashari:

We were in the company of Allah's Apostle (during Hajj). Whenever we went up a high place we used to say: "None has the right to be worshipped but Allah, and Allah is Greater," and our voices used to rise, so the Prophet said, "O people! Be merciful to yourselves (i.e. don't raise your voice), for you are not calling a deaf or an absent one, but One Who is with you, no doubt He is All-Hearer, ever Near (to all things)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.236]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 236

Narrated Jabir bin 'Abdullah:

Whenever we went up a place we would say, "Allahu--Akbar (i.e. Allah is Greater)", and whenever we went down a place we would say, "Subhan Allah."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.237]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 237

Narrated Jabir:

Whenever we went up a place we would say Takbir, and whenever we went down we would say, "Subhan Allah."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.238]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 238

Narrated Abdullah bin Umar:

Whenever the Prophet returned from the Hajj or the 'Umra or a Ghazwa, he would say Takbir thrice. Whenever he came upon a mountain path or wasteland, and then he would say, "None has the right to be worshipped but Allah, Alone Who has no partner. All the Kingdom belongs to Him and all the praises are for Him and He is Omnipotent. We are returning with repentance, worshipping, prostrating ourselves and praising our Lord. Allah fulfilled His Promise, granted victory to His slave and He Alone defeated all the clans."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.239]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 239

Narrated Ibrahim Abu Isma'il As-Saksaki:

I heard Abu Burda who accompanied Yazid bin Abi Kabsha on a journey. Yazid used to observe fasting on journeys. Abu Burda said to him, "I heard Abu Musa several times saying that Allah's Apostle said, 'When a slave falls ill or travels, then he will get reward similar to that he gets for good deeds practiced at home when in good health."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.240]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 240

Narrated Jabir bin 'Abdullah:

On the day of the battle of the Trench, the Prophet wanted somebody from amongst the people to volunteer to be a reconnoitre. Az-Zubair volunteered. He demanded the same again and Az-Zubair volunteered again. Then he repeated the same demand (thrice) and AzZubair volunteered once more. The Prophet then said, " Every prophet has a disciple and my disciple is Az-Zubair."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.241]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 241

Narrated Ibn' Umar:

from the Prophet the following Hadith (No. 242).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.242]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 242

Narrated Ibn 'Umar:

The Prophet said, "If the people knew what I know about traveling alone, then nobody would travel alone at night."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.243]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 243

Narrated Hisham's father:

Usama bin Zaid was asked at what pace the Prophet rode during Hajjat-ul-Wada' "He rode at a medium pace, but when he came upon an open way he would go at full pace."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.244]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 244

Narrated Aslam:

While I was in the company of 'Abdullah bin 'Umar on the way to Mecca, he received the news of the severe illness of Safiya bint Abi Ubaid (i.e. his wife), so he proceeded at greater speed, and when the twilight disappeared, he dismounted and offered the Maghrib and 'Isha 'prayers together and said, " I saw the Prophet delaying the Maghrib prayer to offer it along with the 'Isha' when he was in a hurry on a journey."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.245]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 245

Narrated Abu Huraira:

Allah's Apostle said, "Journey is a piece of torture, for it disturbs one's sleep, eating and drinking. So, when you fulfill your job, you should hurry up to your family."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.246]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 246

Narrated 'Abdullah bin 'Umar:

Umar bin Al-Khattab gave a horse to be ridden in Allah's Cause and then he found it being sold. He intended to purchase it. So, he consulted Allah's Apostle who said, "Don't buy it and don't take back your gift of charity."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.247]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 247

Narrated Aslam:

I heard 'Umar bin Al-Khattab saying, "I gave a horse to be ridden in Allah's Cause and the person who got it intended to sell it or neglected it. So, I wanted to buy it as I thought he would sell it cheap. I consulted the Prophet who said, "Do not buy it even if for one Dirham, because he who takes back his gift is like a dog swallowing its vomit."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.248]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 248

Narrated 'Abdullah bin 'Amr:

A man came to the Prophet asking his permission to take part in Jihad. The Prophet asked him, "Are your parents alive?" He replied in the affirmative. The Prophet said to him, "Then exert yourself in their service."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.249]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 249

Narrated Abu Bashir Al-Ansari:

That he was in the company of Allah's Apostle on some of his journeys. (The sub-narrator 'Abdullah adds, "I think that Abu Bashir also said, 'And the people were at their sleeping places.") Allah's Apostle sent a messenger ordering: "There shall not remain any necklace of string or any other kind of necklace round the necks of camels except it is cut off."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.250]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 250

Narrated Ibn Abbas:

That he heard the Prophet saying, "It is not permissible for a man to be alone with a woman, and no lady should travel except with a Muhram (i.e. her husband or a person whom she cannot marry in any case for ever; e.g. her father, brother, etc.)." Then a man got up and said, "O Allah's Apostle! I have enlisted in the army for such-and-such Ghazwa and my wife is proceeding for Hajj." Allah's Apostle said, "Go, and perform the Hajj with your wife."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.251]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 251

Narrated 'Ubaidullah bin Abi Rafi:

I heard 'Ali saying, "Allah's Apostle sent me, Az-Zubair and Al-Miqdad somewhere saying, 'Proceed till you reach Rawdat Khakh. There you will find a lady with a letter. Take the letter from her.' " So, we set out and our horses ran at full pace till we got at Ar-Rawda where we found the lady and said (to her). "Take out the letter." She replied, "I have no letter with me." We said, "Either you take out the letter or else we will take off your clothes." So, she took it out of her braid. We brought the letter to Allah's Apostle and it contained a statement from Hatib bin Abi Balta a to some of the Meccan pagans informing them of some of the intentions of Allah's Apostle. Then Allah's Apostle said, "O Hatib! What is this?" Hatib replied, "O Allah's Apostle! Don't hasten to give your judgment about me. I was a man closely connected with the Quraish, but I did not belong to this tribe, while the other emigrants with you, had their relatives in Mecca who would protect their dependents and property . So, I wanted to recompense for my lacking blood relation to them by doing them a favor so that they might protect my dependents. I did this neither because of disbelief not apostasy nor out of preferring Kufr (disbelief) to Islam." Allah's Apostle, said, "Hatib has told you the truth." Umar said, O Allah's Apostle! Allow me to chop off the head of this hypocrite." Allah's Apostle said, "Hatib participated in the battle of Badr, and who knows, perhaps Allah has already looked at the Badr warriors and said, 'Do whatever you like, for I have forgiven you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.252]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 252

Narrated Jabir bin 'Abdullah:

When it was the day (of the battle) of Badr, prisoners of war were brought including Al-Abbas who was undressed. The Prophet looked for a shirt for him. It was found that the shirt of 'Abdullah bin Ubai would do, so the Prophet let him wear it. That was the reason why the Prophet took off and gave his own shirt to 'Abdullah. (The narrator adds, "He had done the Prophet some favor for which the Prophet liked to reward him.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.253]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 253

Narrated Sahl:

On the day (of the battle) of Khaibar the Prophet said, "Tomorrow I will give the flag to somebody who will be given victory (by Allah) and who loves Allah and His Apostle and is loved by Allah and His Apostle." So, the people wondered all that night as to who would receive the flag and in the morning everyone hoped that he would be that person. Allah's Apostle asked, "Where is 'Ali?" He was told that 'Ali was suffering from eye-trouble, so he applied saliva to his eyes and invoked Allah to cure him. He at once got cured as if he had no ailment. The Prophet gave him the flag. 'Ali said, "Should I fight them till they become like us (i.e. Muslim)?" The Prophet said, "Go to them patiently and calmly till you enter the land. Then, invite them to Islam, and inform them what is enjoined upon them, for, by Allah, if Allah gives guidance to somebody through you, it is better for you than possessing red camels."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.254]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 254

Narrated Abu Huraira:

The Prophet said, "Allah wonders at those people who will enter Paradise in chains."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.255]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 255

Narrated Abu Burda's father:

The Prophet said, "Three persons will get their reward twice. (One is) a person who has a slave girl and he educates her properly and teaches her good manners properly (without violence) and then manumits and marries her. Such a person will get a double reward. (Another is) a believer from the people of the scriptures who has been a true believer and then he believes in the Prophet (Muhammad). Such a person will get a double reward. (The third is) a slave who observes Allah's Rights and Obligations and is sincere to his master."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.256]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 256

Narrated As-Sab bin Jaththama:

The Prophet passed by me at a place called Al-Abwa or Waddan, and was asked whether it was permissible to attack the pagan warriors at night with the probability of exposing their women and children to danger. The Prophet replied, "They (i.e. women and children) are from them (i.e. pagans)." I also heard the Prophet saying, "The institution of Hima is invalid except for Allah and His Apostle."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.257]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 257

Narrated 'Abdullah:

During some of the Ghazawat of the Prophet a woman was found killed. Allah's Apostle disapproved the killing of women and children.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.258]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 258

Narrated Ibn 'Umar:

During some of the Ghazawat of Allah's Apostle a woman was found killed, so Allah's Apostle forbade the killing of women and children.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.259]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 259

Narrated Abu Huraira:

Allah's Apostle sent us in a mission (i.e. am army-unit) and said, "If you find so-and-so and so-and-so, burn both of them with fire." When we intended to depart, Allah's Apostle said, "I have ordered you to burn so-and-so and so-and-so, and it is none but Allah Who punishes with fire, so, if you find them, kill them."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.260]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 260

Narrated Ikrima:

Ali burnt some people and this news reached Ibn 'Abbas, who said, "Had I been in his place I would not have burnt them, as the Prophet said, 'Don't punish (anybody) with Allah's Punishment.' No doubt, I would have killed them, for the Prophet said, 'If somebody (a Muslim) discards his religion, kill him.' "


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.261]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 261

Narrated Anas bin Malik:

A group of eight men from the tribe of 'Ukil came to the Prophet and then they found the climate of Medina unsuitable for them. So, they said, "O Allah's Apostle! Provide us with some milk." Allah's Apostle said, "I recommend that you should join the herd of camels." So they went and drank the urine and the milk of the camels (as a medicine) till they became healthy and fat. Then they killed the shepherd and drove away the camels, and they became unbelievers after they were Muslims. When the Prophet was informed by a shouter for help, he sent some men in their pursuit, and before the sun rose high, they were brought, and he had their hands and feet cut off. Then he ordered for nails which were heated and passed over their eyes, and whey were left in the Harra (i.e. rocky land in Medina). They asked for water, and nobody provided them with water till they died (Abu Qilaba, a sub-narrator said, "They committed murder and theft and fought against Allah and His Apostle, and spread evil in the land.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.262]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 262

Narrated Jarir:

Allah's Apostles said to me, "Will you relieve me from Dhul-Khalasa? Dhul-Khalasa was a house (of an idol) belonging to the tribe of Khath'am called Al-Ka'ba Al-Yama-niya. So, I proceeded with one hundred and fifty cavalry men from the tribe of Ahmas, who were excellent knights. It happened that I could not sit firm on horses, so the Prophet , stroke me over my chest till I saw his finger-marks over my chest, he said, 'O Allah! Make him firm and make him a guiding and rightly guided man.' " Jarir proceeded towards that house, and dismantled and burnt it. Then he sent a messenger to Allah's Apostle informing him of that. Jarir's messenger said, "By Him Who has sent you with the Truth, I did not come to you till I had left it like an emancipated or gabby camel (i.e. completely marred and spoilt)." Jarir added, "The Prophet asked for Allah's Blessings for the horses and the men of Ahmas five times."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.263]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 263

Narrated Ibn 'Umar:

The Prophet burnt the date-palms of Bani An-Nadir.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.264]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 264

Narrated Al-Bara bin Azib:

Allah's Apostle sent a group of Ansari men to kill Abu-Rafi. One of them set out and entered their (i.e. the enemies) fort. That man said, "I hid myself in a stable for their animals. They closed the fort gate. Later they lost a donkey of theirs, so they went out in its search. I, too, went out along with them, pretending to look for it. They found the donkey and entered their fort. And I, too, entered along with them. They closed the gate of the fort at night, and kept its keys in a small window where I could see them. When those people slept, I took the keys and opened the gate of the fort and came upon Abu Rafi and said, 'O Abu Rafi. When he replied me, I proceeded towards the voice and hit him. He shouted and I came out to come back, pretending to be a helper. I said, 'O Abu Rafi, changing the tone of my voice. He asked me, 'What do you want; woe to your mother?' I asked him, 'What has happened to you?' He said, 'I don't know who came to me and hit me.' Then I drove my sword into his belly and pushed it forcibly till it touched the bone. Then I came out, filled with puzzlement and went towards a ladder of theirs in order to get down but I fell down and sprained my foot. I came to my companions and said, 'I will not leave till I hear the wailing of the women.' So, I did not leave till I heard the women bewailing Abu Rafi, the merchant pf Hijaz. Then I got up, feeling no ailment, (and we proceeded) till we came upon the Prophet and informed him."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.265]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 265

Narrated Al-Bara bin Azib:

Allah's Apostle sent a group of the Ansar to Abu Rafi. Abdullah bin Atik entered his house at night and killed him while he was sleeping.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.266]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 266

Narrated Abu Huraira:

The Prophet said: "Do not wish to meet the enemy, but when you meet face) the enemy, be patient."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.267]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 267

Narrated Abu Huraira:

The Prophet said, "Khosrau will be ruined, and there will be no Khosrau after him, and Caesar will surely be ruined and there will be no Caesar after him, and you will spend their treasures in Allah's Cause." He called, "War is deceit'.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.268]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 268

Narrated Abu Huraira:

Allah's Apostle called,: "War is deceit".


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.269]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 269

Narrated Jabir bin 'Abdullah:

The Prophet said, "War is deceit."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.270]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 270

Narrated Jabir bin 'Abdullah:

The Prophet said, "Who is ready to kill Ka'b bin Al-Ashraf who has really hurt Allah and His Apostle?" Muhammad bin Maslama said, "O Allah's Apostle! Do you like me to kill him?" He replied in the affirmative. So, Muhammad bin Maslama went to him (i.e. Ka'b) and said, "This person (i.e. the Prophet) has put us to task and asked us for charity." Ka'b replied, "By Allah, you will get tired of him." Muhammad said to him, "We have followed him, so we dislike to leave him till we see the end of his affair." Muhammad bin Maslama went on talking to him in this way till he got the chance to kill him.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.271]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 271

Narrated Jabir:

The Prophet said, "Who is ready to kill Ka'b bin Ashraf (i.e. a Jew)." Muhammad bin Maslama replied, "Do you like me to kill him?" The Prophet replied in the affirmative. Muhammad bin Maslama said, "Then allow me to say what I like." The Prophet replied, "I do (i.e. allow you)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.272]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 272

Narrated Al-Bara:

I saw Allah's Apostle on the day (of the battle) of the Trench carrying earth till the hair of his chest were covered with dust and he was a hairy man. He was reciting the following verses of 'Abdullah (bin Rawaha): "O Allah, were it not for You, We would not have been guided, Nor would we have given in charity, nor prayed. So, bestow on us calmness, and when we meet the enemy. Then make our feet firm, for indeed, Yet if they want to put us in affliction, (i.e. want to fight against us) we would not (flee but withstand them)." The Prophet used to raise his voice while reciting these verses. (See Hadith No. 432, Vol. 5).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.273]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 273

Narrated Jarir:

Allah's Apostle did not screen himself from me since my embracing Islam, and whenever he saw me he would receive me with a smile. Once I told him that I could not sit firm on horses. He stroke me on the chest with his hand and said, "O Allah! Make him firm and make him a guiding and a rightly-guided man."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.274]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 274

Narrated Abu Hazim:

The people asked Sahl bin Sad As-Sa' idi "With what thing (medicine) was the wound of Allah's Apostle treated?" He replied, "There is none left (living) amongst the people who knows it better than. 'Ali used to bring water in his shield and Fatima (i.e. the Prophet's daughter) used to wash the blood off his face. Then a mat (of palm leaves) was burnt and its ash was inserted in the wound of Allah's Apostle."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.275]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 275

Narrated Abu Burda:

That his father said, "The Prophet sent Mu'adh and Abu Musa to Yemen telling them. 'Treat the people with ease and don't be hard on them; give them glad tidings and don't fill them with aversion; and love each other, and don't differ."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.276]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 276

Narrated Al-Bara bin Azib:

The Prophet appointed 'Abdullah bin Jubair as the commander of the infantry men (archers) who were fifty on the day (of the battle) of Uhud. He instructed them, "Stick to your place, and don't leave it even if you see birds snatching us, till I send for you; and if you see that we have defeated the infidels and made them flee, even then you should not leave your place till I send for you." Then the infidels were defeated. By Allah, I saw the women fleeing lifting up their clothes revealing their leg-bangles and their legs. So, the companions of 'Abdullah bin Jubair said, "The booty! O people, the booty ! Your companions have become victorious, what are you waiting for now?" 'Abdullah bin Jubair said, "Have you forgotten what Allah's Apostle said to you?" They replied, "By Allah! We will go to the people (i.e. the enemy) and collect our share from the war booty." But when they went to them, they were forced to turn back defeated. At that time Allah's Apostle in their rear was calling them back. Only twelve men remained with the Prophet and the infidels martyred seventy men from us.

On the day (of the battle) of Badr, the Prophet and his companions had caused the 'Pagans to lose 140 men, seventy of whom were captured and seventy were killed. Then Abu Sufyan asked thrice, "Is Muhammad present amongst these people?" The Prophet ordered his companions not to answer him. Then he asked thrice, "Is the son of Abu Quhafa present amongst these people?" He asked again thrice, "Is the son of Al-Khattab present amongst these people?" He then returned to his companions and said, "As for these (men), they have been killed." 'Umar could not control himself and said (to Abu Sufyan), "You told a lie, by Allah! O enemy of Allah! All those you have mentioned are alive, and the thing which will make you unhappy is still there." Abu Sufyan said, "Our victory today is a counterbalance to yours in the battle of Badr, and in war (the victory) is always undecided and is shared in turns by the belligerents, and you will find some of your (killed) men mutilated, but I did not urge my men to do so, yet I do not feel sorry for their deed" After that he started reciting cheerfully, "O Hubal, be high! (1) On that the Prophet said (to his companions), "Why don't you answer him back?" They said, "O Allah's Apostle What shall we say?" He said, "Say, Allah is Higher and more Sublime." (Then) Abu Sufyan said, "We have the (idol) Al Uzza, and you have no Uzza." The Prophet said (to his companions), "Why don't you answer him back?" They asked, "O Allah's Apostle! What shall we say?" He said, "Says Allah is our Helper and you have no helper."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.277]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 277

Narrated Anas:

Allah's Apostle was the (most handsome), most generous and the bravest of all the people. Once the people of Medina got frightened having heard an uproar at night. So, the Prophet met the people while he was riding an unsaddled horse belonging to Abu Talha and carrying his sword (slung over his shoulder). He said (to them), "Don't get scared, don't get scared." Then he added, "I found it (i.e the horse) very fast."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.278]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 278

Narrated Salama:

I went out of Medina towards Al-Ghaba. When I reached the mountain path of Al-Ghaba, a slave of 'Abdur-Rahman bin 'Auf met me. I said to him, "Woe to you! What brought you here?" He replied, "The she-camels of the Prophet have been taken away." I said, "Who took them?" He said, "Ghatafan and Fazara." So, I sent three cries, "O Sabaha-h ! O Sabahah !" so loudly that made the people in between its (i.e. Medina's) two mountains hear me. Then I rushed till I met them after they had taken the camels away. I started throwing arrows at them saying, "I am the son of Al-Akwa"; and today perish the mean people!" So, I saved the she-camels from them before they (i.e. the robbers) could drink water. When I returned driving the camels, the Prophet met me, I said, "O Allah's Apostle Those people are thirsty and I have prevented them from drinking water, so send some people to chase them." The Prophet said, "O son of Al-Akwa', you have gained power (over your enemy), so forgive (them). (Besides) those people are now being entertained by their folk."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.279]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 279

Narrated Abu Ishaq:

A man asked Al-Bara "O Abu 'Umara! Did you flee on the day (of the battle) of Hunain?" Al-Bara replied while I was listening, "As for Allah's Apostle he did not flee on that day. Abu Sufyan bin Al-Harith was holding the reins of his mule and when the pagans attacked him, he dismounted and started saying, 'I am the Prophet, and there is no lie about it; I am the son of 'Abdul Muttalib.' On that day nobody was seen braver than the Prophet


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.280]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 280

Narrated Abu Sa'id Al-Khudri:

When the tribe of Bani Quraiza was ready to accept Sad's judgment, Allah's Apostle sent for Sad who was near to him. Sad came, riding a donkey and when he came near, Allah's Apostle said (to the Ansar), "Stand up for your leader." Then Sad came and sat beside Allah's Apostle who said to him. "These people are ready to accept your judgment." Sad said, "I give the judgment that their warriors should be killed and their children and women should be taken as prisoners." The Prophet then remarked, "O Sad! You have judged amongst them with (or similar to) the judgment of the King Allah."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.281]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 281

Narrated Abu Huraira:

Allah's Apostle sent a Sariya of ten men as spies under the leadership of 'Asim bin Thabit al-Ansari, the grandfather of 'Asim bin Umar Al-Khattab. They proceeded till they reached Hadaa, a place between 'Usfan, and Mecca, and their news reached a branch of the tribe of Hudhail called Bani Lihyan. About two-hundred men, who were all archers, hurried to follow their tracks till they found the place where they had eaten dates they had brought with them from Medina. They said, "These are the dates of Yathrib (i.e. Medina), "and continued following their tracks When 'Asim and his companions saw their pursuers, they went up a high place and the infidels circled them. The infidels said to them, "Come down and surrender, and we promise and guarantee you that we will not kill any one of you" 'Asim bin Thabit; the leader of the Sariya said, "By Allah! I will not come down to be under the protection of infidels. O Allah! Convey our news to Your Prophet. Then the infidels threw arrows at them till they martyred 'Asim along with six other men, and three men came down accepting their promise and convention, and they were Khubaib-al-Ansari and Ibn Dathina and another man So, when the infidels captured them, they undid the strings of their bows and tied them. Then the third (of the captives) said, "This is the first betrayal. By Allah! I will not go with you. No doubt these, namely the martyred, have set a good example to us." So, they dragged him and tried to compel him to accompany them, but as he refused, they killed him. They took Khubaid and Ibn Dathina with them and sold them (as slaves) in Mecca (and all that took place) after the battle of Badr. Khubaib was bought by the sons of Al-Harith bin 'Amir bin Naufal bin 'Abd Manaf. It was Khubaib who had killed Al-Harith bin 'Amir on the day (of the battle of) Badr. So, Khubaib remained a prisoner with those people.

Narrated Az-Zuhri: 'Ubaidullah bin 'Iyyad said that the daughter of Al-Harith had told him, "When those people gathered (to kill Khubaib) he borrowed a razor from me to shave his pubes and I gave it to him. Then he took a son of mine while I was unaware when he came upon him. I saw him placing my son on his thigh and the razor was in his hand. I got scared so much that Khubaib noticed the agitation on my face and said, 'Are you afraid that I will kill him? No, I will never do so.' By Allah, I never saw a prisoner better than Khubaib. By Allah, one day I saw him eating of a bunch of grapes in his hand while he was chained in irons, and there was no fruit at that time in Mecca." The daughter of Al-Harith used to say, "It was a boon Allah bestowed upon Khubaib." When they took him out of the Sanctuary (of Mecca) to kill him outside its boundaries, Khubaib requested them to let him offer two Rakat (prayer). They allowed him and he offered Two Rakat and then said, "Hadn't I been afraid that you would think that I was afraid (of being killed), I would have prolonged the prayer. O Allah, kill them all with no exception." (He then recited the poetic verse):-- "I being martyred as a Muslim, Do not mind how I am killed in Allah's Cause, For my killing is for Allah's Sake, And if Allah wishes, He will bless the amputated parts of a torn body" Then the son of Al Harith killed him. So, it was Khubaib who set the tradition for any Muslim sentenced to death in captivity, to offer a two-Rak'at prayer (before being killed). Allah fulfilled the invocation of Asim bin Thabit on that very day on which he was martyred. The Prophet informed his companions of their news and what had happened to them. Later on when some infidels from Quraish were informed that Asim had been killed, they sent some people to fetch a part of his body (i.e. his head) by which he would be recognized. (That was because) 'Asim had killed one of their chiefs on the day (of the battle) of Badr. So, a swarm of wasps, resembling a shady cloud, were sent to hover over Asim and protect him from their messenger and thus they could not cut off anything from his flesh.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.282]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 282

Narrated Abu Musa:

The Prophet said, "Free the captives, feed the hungry and pay a visit to the sick."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.283]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 283

Narrated Abu Juhaifa:

I asked Ali, "Do you have the knowledge of any Divine Inspiration besides what is in Allah's Book?" 'Ali replied, "No, by Him Who splits the grain of corn and creates the soul. I don't think we have such knowledge, but we have the ability of understanding which Allah may endow a person with, so that he may understand the Qur'an, and we have what is written in this paper as well." I asked, "What is written in this paper?" He replied, "(The regulations of) blood-money, the freeing of captives, and the judgment that no Muslim should be killed for killing an infidel."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.284]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 284

Narrated Anas bin Malik:

Some Ansari men asked permission from Allah's Apostle saying, "O Allah's Apostle! Allow us not to take the ransom of our nephew Al Abbas. The Prophet replied, "Do not leave a single Dirham thereof."

(In another narration) Anas said, "Some wealth was brought to the Prophet from Bahrain. Al Abbas came to him and said, 'O Allah's Apostle! Give me (some of it), as I have paid my and 'Aqil's ransom.' The Prophet said, 'Take,' and gave him in his garment."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.285]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 285

Narrated Jubair:

(who was among the captives of the Battle of Badr) I heard the Prophet reciting 'Surat-at-Tur' in the Maghrib prayer.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.286]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 286

Narrated Salama bin Al-Akwa:

"An infidel spy came to the Prophet while he was on a journey. The spy sat with the companions of the Prophet and started talking and then went away. The Prophet said (to his companions), 'Chase and kill him.' So, I killed him." The Prophet then gave him the belongings of the killed spy (in addition to his share of the war booty).


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.287]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 287

Narrated 'Amr bin Maimun:

Umar (after he was stabbed), instructed (his would-be-successor) saying, "I urge him (i.e. the new Caliph) to take care of those non-Muslims who are under the protection of Allah and His Apostle in that he should observe the convention agreed upon with them, and fight on their behalf (to secure their safety) and he should not over-tax them beyond their capability."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.288]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 288

Narrated Said bin Jubair:

Ibn 'Abbas said, "Thursday! What (great thing) took place on Thursday!" Then he started weeping till his tears wetted the gravels of the ground . Then he said, "On Thursday the illness of Allah's Apostle was aggravated and he said, "Fetch me writing materials so that I may have something written to you after which you will never go astray." The people (present there) differed in this matter and people should not differ before a prophet. They said, "Allah's Apostle is seriously sick.' The Prophet said, "Let me alone, as the state in which I am now, is better than what you are calling me for." The Prophet on his death-bed, gave three orders saying, "Expel the pagans from the Arabian Peninsula, respect and give gifts to the foreign delegates as you have seen me dealing with them." I forgot the third (order)" (Ya'qub bin Muhammad said, "I asked Al-Mughira bin 'Abdur-Rahman about the Arabian Peninsula and he said, 'It comprises Mecca, Medina, Al-Yama-ma and Yemen." Ya'qub added, "And Al-Arj, the beginning of Tihama.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.289]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 289

Narrated Ibn 'Umar:

'Umar saw a silken cloak being sold in the market and he brought it to Allah's Apostle and said, "O Allah's Apostle! Buy this cloak and adorn yourself with it on the 'Id festivals and on meeting the delegations." Allah's Apostle replied, "This is the dress for the one who will have no share in the Hereafter (or, this is worn by one who will have no share in the Hereafter)." After sometime had passed, Allah's Apostle sent a silken cloak to 'Umar. 'Umar took it and brought it to Allah's Apostle and said, "O Allah's Apostle! You have said that this is the dress of that who will have no share in the Hereafter (or, this is worn by one who will have no share in the Hereafter), yet you have sent me this!" The Prophet said," I have sent it) so that you may sell it or fulfill with it some of your needs."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.290]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 290

Narrated Ibn Umar:

(Later on) Allah's Apostle (once again) went along with Ubai bin Ka'b to the garden of date-palms where Ibn Saiyad was staying. When the Prophet entered the garden, he started hiding himself behind the trunks of the date-palms as he wanted to hear something from the Ibn Saiyad before the latter could see him. Ibn Saiyad was lying in his bed, covered with a velvet sheet from where his murmurs were heard. Ibn Saiyad's mother saw the Prophet while he was hiding himself behind the trunks of the date-palms. She addressed Ibn Saiyad, "O Saf!" (And this was his name). Ibn Saiyad got up. The Prophet said, "Had this woman let him to himself, he would have revealed the reality of his case." Then the Prophet got up amongst the people, glorifying Allah as He deserves, he mentioned Ad-Dajjal, saying, "I warn you about him (i.e. Ad-Dajjal) and there is no prophet who did not warn his nation about him, and Noah warned his nation about him, but I tell you a statement which no prophet informed his nation of. You should understand that he is a one-eyed man and Allah is not one-eyed."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.291]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 291

Narrated Usama bin Zaid:

I asked the Prophet during his Hajj, "O Allah's Apostle! Where will you stay tomorrow?" He said, "Has Aqil left for us any house?" He then added, "Tomorrow we will stay at Khaif Bani Kinana, i.e. Al-Muhassab, where (the Pagans of) Quraish took an oath of Kufr (i.e. to be loyal to heathenism) in that Bani Kinana got allied with Quraish against Bani Hashim on the terms that they would not deal with the members of the is tribe or give them shelter." (Az-Zuhri said, "Khaif means valley.") (See Hadith No. 659, Vol. 2)


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.292]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 292

Narrated Aslam:

Umar bin Al-Khattab appointed a freed slave of his, called Hunai, manager of the Hima (i.e. a pasture devoted for grazing the animals of the Zakat or other specified animals). He said to him, "O Hunai! Don't oppress the Muslims and ward off their curse (invocations against you) for the invocation of the oppressed is responded to (by Allah); and allow the shepherd having a few camels and those having a few sheep (to graze their animals), and take care not to allow the livestock of 'Abdur-Rahman bin 'Auf and the livestock of ('Uthman) bin 'Affan, for if their livestock should perish, then they have their farms and gardens, while those who own a few camels and those who own a few sheep, if their livestock should perish, would bring their dependents to me and appeal for help saying, 'O chief of the believers! O chief of the believers!' Would I then neglect them? (No, of course). So, I find it easier to let them have water and grass rather than to give them gold and silver (from the Muslims' treasury). By Allah, these people think that I have been unjust to them. This is their land, and during the pre-lslamic period, they fought for it and they embraced Islam (willingly) while it was in their possession. By Him in Whose Hand my life is! Were it not for the animals (in my custody) which I give to be ridden for striving in Allah's Cause, I would not have turned even a span of their land into a Hima."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.293]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 293

Narrated Hudhaifa:

The Prophet said (to us), " List the names of those people who have announced that they are Muslims." So, we listed one thousand and five hundred men. Then we wondered, "Should we be afraid (of infidels) although we are one thousand and five hundred in number?" No doubt, we witnessed ourselves being afflicted with such bad trials that one would have to offer the prayer alone in fear.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.294]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 294

Narrated Al-Amash:

"We (listed the Muslims and) found them five hundred." And Abu Muawiya said, "Between six-hundred to seven-hundred."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.295]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 295

Narrated Ibn 'Abbas:

A man came to the Prophet and said, "O Allah's Apostle! I have enlisted in the army for such-and-such Ghazwa, and my wife is leaving for Hajj." Allah's Apostle said, "Go back and perform Hajj with your wife."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.296]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 296

Narrated Az-Zuhri:

as follows in Hadith 297.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.297]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 297

Narrated Abu Huraira:

We were in the company of Allah's Apostle in a Ghazwa, and he remarked about a man who claimed to be a Muslim, saying, "This (man) is from the people of the (Hell) Fire." When the battle started, the man fought violently till he got wounded. Somebody said, "O Allah's Apostle! The man whom you described as being from the people of the (Hell) Fire fought violently today and died." The Prophet said, "He will go to the (Hell) Fire." Some people were on the point of doubting (the truth of what the Prophet had said) while they were in this state, suddenly someone said that he was still alive but severely wounded. When night fell, he lost patience and committed suicide. The Prophet was informed of that, and he said, "Allah is Greater! I testify that I am Allah's Slave and His Apostle." Then he ordered Bilal to announce amongst the people: 'None will enter Paradise but a Muslim, and Allah may support this religion (i.e. Islam) even with a disobedient man.'


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.298]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 298

Narrated Anas bin Malik:

Allah's Apostle delivered a sermon and said, "Zaid received the flag and was martyred, then Ja'far took it and was martyred, then 'Abdullah bin Rawaha took it and was martyred, and then Khalid bin Al-Walid took it without being appointed, and Allah gave him victory." The Prophet added, "I am not pleased (or they will not be pleased) that they should remain (alive) with us," while his eyes were shedding tears.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.299]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 299

Narrated Anas:

The people of the tribes of Ril, Dhakwan, 'Usiya and Bani Lihyan came to the Prophet and claimed that they had embraced Islam, and they requested him to support them with some men to fight their own people. The Prophet supported them with seventy men from the Ansar whom we used to call Al-Qurra'(i.e. Scholars) who (out of piety) used to cut wood during the day and pray all the night. So, those people took the (seventy) men till they reached a place called Bi'r-Ma'ana where they betrayed and martyred them. So, the Prophet invoked evil on the tribe of Ril, Dhakwan and Bani Lihyan for one month in the prayer.

Narrated Qatada: Anas told us that they (i.e. Muslims) used to recite a Quranic Verse concerning those martyrs which was:-- "O Allah! Let our people be informed on our behalf that we have met our Lord Who has got pleased with us and made us pleased." Then the Verse was cancelled.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.300]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 300

Narrated Abu Talha:

Whenever the Prophet conquered some people, he would stay in their town for three days.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.301]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 301

Narrated Anas:

The Prophet performed 'Umra, setting out from Al-Jarana where he distributed the war booty of Hunain.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.302]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 302

Narrated Nafi:

Once a slave of Ibn 'Umar fled and joined the Byzantine. Khalid bin Al-Walid got him back and returned him to 'Abdullah (bin 'Umar). Once a horse of Ibn 'Umar also ran away and followed the Byzantines, and he (i.e. Khalid) got it back and returned it to 'Abdullah.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.303]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 303

Narrated Ibn Umar:

That he was riding a horse on the day, the Muslims fought (against the Byzantines), and the commander of the Muslim army was Khalid bin Al-Walid who had been appointed by Abu Bakr. The enemy took the horse away, and when the enemy was defeated, Khalid returned the horse to him.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.304]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 304

Narrated Jabir bin Abdullah:

I said, "O Allah's Apostle! We have slaughtered a young sheep of ours and have ground one Sa of barley. So, I invite you along with some persons." So, the Prophet said in a loud voice, "O the people of the Trench! Jabir had prepared "Sur" so come along."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.305]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 305

Narrated Um Khalid:

(the daughter of Khalid bin Said) I went to Allah's Apostle with my father and I was Nearing a yellow shirt. Allah's Apostle said, "Sanah, Sanah!" ('Abdullah, the narrator, said that 'Sanah' meant 'good' in the Ethiopian language). I then started playing with the seal of Prophethood (in between the Prophet's shoulders) and my father rebuked me harshly for that. Allah's Apostle said. "Leave her," and then Allah's Apostle (invoked Allah to grant me a long life) by saying (thrice), "Wear this dress till it is worn out and then wear it till it is worn out, and then wear it till it is worn out." (The narrator adds, "It is said that she lived for a long period, wearing that (yellow) dress till its color became dark because of long wear.")


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.306]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 306

Narrated Abu Huraira:

Al-Hasan bin 'All took a date from the dates of the Sadaqa and put it in his mouth. The Prophet said (to him) in Persian, "Kakh, kakh! (i.e. Don't you know that we do not eat the Sadaqa (i.e. what is given in charity) (charity is the dirt of the people))."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.307]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 307

Narrated Abu Huraira:

The Prophet got up amongst us and mentioned Al Ghulul, emphasized its magnitude and declared that it was a great sin saying, "Don't commit Ghulul for I should not like to see anyone amongst you on the Day of Ressurection, carrying over his neck a sheep that will be bleating, or carrying over his neck a horse that will be neighing. Such a man will be saying: 'O Allah's Apostle! Intercede with Allah for me,' and I will reply, 'I can't help you, for I have conveyed Allah's Message to you Nor should I like to see a man carrying over his neck, a camel that will be grunting. Such a man will say, 'O Allah's Apostle! Intercede with Allah for me, and I will say, 'I can't help you for I have conveyed Allah's Message to you,' or one carrying over his neck gold and silver and saying, 'O Allah's Apostle! Intercede with Allah for me,' and I will say, 'I can't help you for I have conveyed Allah's Message to you,' or one carrying clothes that will be fluttering, and the man will say, 'O Allah's Apostle! Intercede with Allah for me.' And I will say, 'I can't help you, for I have conveyed Allah's Message to you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.308]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 308

Narrated 'Abdullah bin 'Amr:

There was a man who looked after the family and the belongings of the Prophet and he was called Karkara. The man died and Allah's Apostle said, "He is in the '(Hell) Fire." The people then went to look at him and found in his place, a cloak he had stolen from the war booty.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.309]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 309

Narrated Abaya bin Rifaa:

My grandfather, Rafi said, "We were in the company of the Prophet at DhulHulaifa, and the people suffered from hunger. We got some camels and sheep (as booty) and the Prophet was still behind the people. They hurried and put the cooking pots on the fire. (When he came) he ordered that the cooking pots should be upset and then he distributed the booty (amongst the people) regarding ten sheep as equal to one camel then a camel fled and the people chased it till they got tired, as they had a few horses (for chasing it). So a man threw an arrow at it and caused it to stop (with Allah's Permission). On that the Prophet said, 'Some of these animals behave like wild beasts, so, if any animal flee from you, deal with it in the same way." My grandfather asked (the Prophet ), "We hope (or are afraid) that we may meet the enemy tomorrow and we have no knives. Can we slaughter our animals with canes?" Allah's Apostle replied, "If the instrument used for killing causes the animal to bleed profusely and if Allah's Name is mentioned on killing it, then eat its meat (i.e. it is lawful) but won't use a tooth or a nail and I am telling you the reason: A tooth is a bone (and slaughtering with a bone is forbidden ), and a nail is the slaughtering instrument of the Ethiopians."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.310]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 310

Narrated Qais:

Jarir bin 'Abdullah said to me, "Allah's Apostle said to me, 'Won't you relieve me from Dhul-Khalasa?' Dhul-Khalasa was a house where the tribe of Khatham used to stay, and it used to be called Ka'bat-ul Yamaniya. So I proceeded with one hundred-and-fifty (men) from the tribe of Ahmas who were good cavalry. I informed the Prophet that I could not sit firm on horses, so he stroke me on the chest with his hand and I noticed his finger marks on my chest. He invoked, 'O Allah! Make him firm and a guiding and rightly-guided man." Jarir set out towards that place, dismantled and burnt it, and then sent the good news to Allah's Apostle . The messenger of Jarir said to Allah's Apostle. "O Allah's Apostle! By Him Who has sent you with the Truth, I did not come to you till it (i.e. the house) had been turned (black) like a scabby camel (covered with tar)." So the Prophet invokes Allah to Bless the horses of the men of Ahmas five times.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.311]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 311

Narrated Ibn 'Abbas:

The Prophet said, on the day of the Conquest of Mecca, "There is no migration (after the Conquest), but Jihad and good intentions, and when you are called for Jihad, you should immediately respond to the call."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.312]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 312

Narrated Abu Uthman An-Nahdi:

Mujashi (bin Mas'ud) took his brother Mujalid bin Musud to the Prophet and said, "This is Mujalid and he will give a pledge of allegiance to you for migration." The Prophet said, "There is no migration after the Conquest of Mecca, but I will take his pledge of allegiance for Islam."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.313]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 313

Narrated 'Ata':

I and 'Ubai bin 'Umar went to 'Aisha while she was staying near Thabir (i.e. a mountain). She said, "There is no Migration after Allah gave His Prophet victory over Mecca."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.314]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 314

Narrated Sad bin 'Ubaida:

Abu Abdur-Rahman who was one of the supporters of Uthman said to Abu Talha who was one of the supporters of Ali, "I perfectly know what encouraged your leader (i.e. 'Ali) to shed blood. I heard him saying: Once the Prophet sent me and Az-Zubair saying, 'Proceed to such-and-such Ar-Roudah (place) where you will find a lady whom Hatib has given a letter. So when we arrived at Ar-Roudah, we requested the lady to hand over the letter to us. She said, 'Hatib has not given me any letter.' We said to her. 'Take out the letter or else we will strip off your clothes.' So she took it out of her braid. So the Prophet sent for Hatib, (who came) and said, 'Don't hurry in judging me, for, by Allah, I have not become a disbeliever, and my love to Islam is increasing. (The reason for writing this letter was) that there is none of your companions but has relatives in Mecca who look after their families and property, while I have nobody there, so I wanted to do them some favor (so that they might look after my family and property).' The Prophet believed him. 'Umar said, 'Allow me to chop off his (i.e. Hatib's) neck as he has done hypocrisy.' The Prophet said, (to 'Umar), 'Who knows, perhaps Allah has looked at the warriors of Badr and said (to them), 'Do whatever you like, for I have forgiven you.' " 'Abdur-Rahman added, "So this is what encouraged him (i.e. Ali)."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.315]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 315

Narrated Ibn Abi Mulaika:

Ibn Az-Zubair said to Ibn Ja'far "Do you remember when I, you and Ibn 'Abbas went out to receive Allah's Apostle?" Ibn Ja'far replied in the affirmative. Ibn Az-Zubair added, "And Allah's Apostle made us (i.e. I and Ibn 'Abbas) ride along with him and left you."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.316]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 316

Narrated As-Sa'ib bin Yazid:

I along with some boys went out to receive Allah's Apostle at Thaniyatal-Wada'.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.317]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 317

Narrated Abdullah:

When the Prophet returned (from Jihad), he would say Takbir thrice and add, "We are returning, if Allah wishes, with repentance and worshipping and praising (our Lord) and prostrating ourselves before our Lord. Allah fulfilled His Promise and helped His Slave, and He Alone defeated the (infidel) clans."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.318]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 318

Narrated Anas bin Malik:

We were in the company of the Prophet while returning from 'Usfan, and Allah's Apostle was riding his she-camel keeping Safiya bint Huyay riding behind him. His she-camel slipped and both of them fell down. Abu Talha jumped from his camel and said, "O Allah's Apostle! May Allah sacrifice me for you." The Prophet said, "Take care of the lady." So, Abu Talha covered his face with a garment and went to Safiya and covered her with it, and then he set right the condition of their shecamel so that both of them rode, and we were encircling Allah's Apostle like a cover. When we approached Medina, the Prophet said, "We are returning with repentance and worshipping and praising our Lord." He kept on saying this till he entered Medina.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.319]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 319

Narrated Anas bin Malik:

That he and Abu Talha came in the company of the Prophet and Safiya was accompanying the Prophet, who let her ride behind him on his she-camel. During the journey, the she-camel slipped and both the Prophet and (his) wife fell down. Abu Talha (the sub-narrator thinks that Anas said that Abu Talha jumped from his camel quickly) said, "O Allah's Apostle! May Allah sacrifice me for your sake! Did you get hurt?" The Prophet replied,"No, but take care of the lady." Abu Talha covered his face with his garment and proceeded towards her and covered her with his garment, and she got up. He then set right the condition of their she-camel and both of them (i.e. the Prophet and his wife) rode and proceeded till they approached Medina. The Prophet said, "We are returning with repentance and worshipping and praising our Lord." The Prophet kept on saying this statement till he entered Medina.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.320]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 320

Narrated Jabir bin 'Abdullah:

I was on a journey in the company of the Prophet and when we reached Medina, he said to me, "Enter the Mosque and offer two Rakat."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.321]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 321

Narrated Ka'b:

Whenever the Prophet returned from a journey in the forenoon, he would enter the Mosque and offer two Rakat before sitting.


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.322]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 322

Narrated Muharib bin Dithar:

Jabir bin 'Abdullah said, "When Allah's Apostle arrived at Medina, he slaughtered a camel or a cow." Jabir added, "The Prophet bought a camel from me for two Uqiyas (of gold) and one or two Dirhams. When he reached Sirar, he ordered that a cow be slaughtered and they ate its meat. When he arrived at Medina, he ordered me to go to the Mosque and offer two Rakat, and weighed (and gave) me the price of the camel."


Bukhari :: Fighting for the Cause of Allah (Jihaad) :: [4.52.323]

Fighting for the Cause of Allah (Jihaad)

Bukhari :: Book 4 :: Volume 52 :: Hadith 323

Narrated Jabir:

Once I returned from a journey and the Prophet said (to me) "Offer two Rakat." (Sirar is a place near Medina).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.324]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 324

Narrated Ali:

I got a she-camel in my share of the war booty on the day (of the battle) of Badr, and the Prophet had given me a she-camel from the Khumus. When I intended to marry Fatima, the daughter of Allah's Apostle, I had an appointment with a goldsmith from the tribe of Bani Qainuqa' to go with me to bring Idhkhir (i.e. grass of pleasant smell) and sell it to the goldsmiths and spend its price on my wedding party. I was collecting for my she-camels equipment of saddles, sacks and ropes while my two she-camels were kneeling down beside the room of an Ansari man. I returned after collecting whatever I collected, to see the humps of my two she-camels cut off and their flanks cut open and some portion of their livers was taken out. When I saw that state of my two she-camels, I could not help weeping. I asked, "Who has done this?" The people replied, "Hamza bin Abdul Muttalib who is staying with some Ansari drunks in this house." I went away till I reached the Prophet and Zaid bin Haritha was with him. The Prophet noticed on my face the effect of what I had suffered, so the Prophet asked. "What is wrong with you." I replied, "O Allah's Apostle! I have never seen such a day as today. Hamza attacked my two she-camels, cut off their humps, and ripped open their flanks, and he is sitting there in a house in the company of some drunks." The Prophet then asked for his covering sheet, put it on, and set out walking followed by me and Zaid bin Haritha till he came to the house where Hamza was. He asked permission to enter, and they allowed him, and they were drunk. Allah's Apostle started rebuking Hamza for what he had done, but Hamza was drunk and his eyes were red. Hamza looked at Allah's Apostle and then he raised his eyes, looking at his knees, then he raised up his eyes looking at his umbilicus, and again he raised up his eyes look in at his face. Hamza then said, "Aren't you but the slaves of my father?" Allah's Apostle realized that he was drunk, so Allah's Apostle retreated, and we went out with him.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.325]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 325

Narrated 'Aisha:

(mother of the believers) After the death of Allah 's Apostle Fatima the daughter of Allah's Apostle asked Abu Bakr As-Siddiq to give her, her share of inheritance from what Allah's Apostle had left of the Fai (i.e. booty gained without fighting) which Allah had given him. Abu Bakr said to her, "Allah's Apostle said, 'Our property will not be inherited, whatever we (i.e. prophets) leave is Sadaqa (to be used for charity)." Fatima, the daughter of Allah's Apostle got angry and stopped speaking to Abu Bakr, and continued assuming that attitude till she died. Fatima remained alive for six months after the death of Allah's Apostle.

She used to ask Abu Bakr for her share from the property of Allah's Apostle which he left at Khaibar, and Fadak, and his property at Medina (devoted for charity). Abu Bakr refused to give her that property and said, "I will not leave anything Allah's Apostle used to do, because I am afraid that if I left something from the Prophet's tradition, then I would go astray." (Later on) Umar gave the Prophet's property (of Sadaqa) at Medina to 'Ali and 'Abbas, but he withheld the properties of Khaibar and Fadak in his custody and said, "These two properties are the Sadaqa which Allah's Apostle used to use for his expenditures and urgent needs. Now their management is to be entrusted to the ruler." (Az-Zuhrl said, "They have been managed in this way till today.")


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.326]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 326

Narrated Malik bin Aus:

While I was at home, the sun rose high and it got hot. Suddenly the messenger of 'Umar bin Al-Khattab came to me and said, "The chief of the believers has sent for you." So, I went along with him till I entered the place where 'Umar was sitting on a bedstead made of date-palm leaves and covered with no mattress, and he was leaning over a leather pillow. I greeted him and sat down. He said, "O Malik! Some persons of your people who have families came to me and I have ordered that a gift should be given to them, so take it and distribute it among them." I said, "O chief of the believers! I wish that you order someone else to do it." He said, "O man! Take it." While I was sitting there with him, his doorman Yarfa' came saying, "'Uthman, 'Abdur-Rahman bin 'Auf, Az-Zubair and Sad bin Abi Waqqas are asking your permission (to see you); may I admit them?" 'Umar said, "Yes", So they were admitted and they came in, greeted him, and sat down. After a while Yarfa' came again and said, "May I admit 'Ali and 'Abbas?" 'Umar said, "yes." So, they were admitted and they came in and greeted (him) and sat down. Then 'Abbas said, "O chief of the believers! Judge between me and this (i.e. 'Ali)." They had a dispute regarding the property of Bani An-Nadir which Allah had given to His Apostle as Fai. The group (i.e. 'Uthman and his companions) said, "O chief of the believers! Judge between them and relieve both of them front each other." 'Umar said, "Be patient! I beseech you by Allah by Whose Permission the Heaven and the Earth exist, do you know that Allah's Apostle said, 'Our (i.e. prophets') property will not be inherited, and whatever we leave, is Sadaqa (to be used for charity),' and Allah's Apostle meant himself (by saying "we'')?" The group said, "He said so." 'Umar then turned to 'Ali and 'Abbas and said, "I beseech you by Allah, do you know that Allah's Apostle said so?" They replied, " He said so." 'Umar then said, "So, I will talk to you about this matter. Allah bestowed on His Apostle with a special favor of something of this Fai (booty) which he gave to nobody else." 'Umar then recited the Holy Verses: "What Allah bestowed as (Fai) Booty on his Apostle (Muhammad) from them --- for this you made no expedition with either cavalry or camelry: But Allah gives power to His Apostles over whomever He will 'And Allah is able to do all things." 9:6)

'Umar added "So this property was especially given to Allah's Apostle, but, by Allah, neither did he take possession of it and leave your, nor did he favor himself with it to your exclusion, but he gave it to all of you and distributed it amongst you till this property remained out of it. Allah's Apostle used to spend the yearly expenses of his family out of this property and used to keep the rest of its revenue to be spent on Allah 's Cause. Allah 's Apostle kept on doing this during all his lifetime. I ask you by Allah do you know this?" They replies in the affirmative. 'Umar then said to 'Ali and 'Abbas. "I ask you by Allah, do you know this?" 'Umar added, "When Allah had taken His Prophet unto Him, 'Abu Bakr said, 'I am the successor of Allah's Apostle so, Abu Bakr took over that property and managed it in the same way as Allah's Apostle used to do, and Allah knows that he was true, pious and rightly-guided, and he was a follower of what was right. Then Allah took Abu Bakr unto Him and I became Abu Bakr's successor, and I kept that property in my possession for the first two years of my Caliphate, managing it in the same way as Allah's Apostle used to do and as Abu Bakr used to do, and Allah knows that I have been true, pious, rightly guided, and a follower of what is right. Now you both (i.e. 'Ah and 'Abbas) came to talk to me, bearing the same claim and presenting the same case; you, 'Abbas, came to me asking for your share from your nephew's property, and this man, i.e. 'Ali, came to me asking for his wife's share from her father's property. I told you both that Allah's Apostle said, 'Our (prophets') properties are not to be inherited, but what we leave is Sadaqa (to be used for charity).' When I thought it right that I should hand over this property to you, I said to you, 'I am ready to hand over this property to you if you wish, on the condition that you would take Allah's Pledge and Convention that you would manage it in the same way as Allah's Apostle used to, and as Abu Bakr used to do, and as I have done since I was in charge of it.' So, both of you said (to me), 'Hand it over to us,' and on that condition I handed it over to you. So, I ask you by Allah, did I hand it over to them on this condition?" The group aid, "Yes." Then 'Umar faced 'Ali and Abbas saying, "I ask you by Allah, did I hand it over to you on this condition?" They said, "Yes. " He said, " Do you want now to give a different decision? By Allah, by Whose Leave both the Heaven and the Earth exist, I will never give any decision other than that (I have already given). And if you are unable to manage it, then return it to me, and I will do the job on your behalf."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.327]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 327

Narrated Ibn 'Abbas:

The delegates of the tribe of 'Abdul-Qais came and said, "O Allah's Apostle! We are from the tribe of Rabi'a, and there is the infidels of the tribe of Mudar intervening between you and us, so we cannot come to you except in the Sacred Months. So please order us some instructions that we may apply it to ourselves and also invite our people whom we left behind us to observe as well." The Prophet said, "I order you (to do) four (things) and forbid you (to do) four: I order you to believe in Allah, that is, to testify that None has the right to be worshipped but Allah (the Prophet pointed with his hand); to offer prayers perfectly; to pay Zakat; to fast the month of Ramadan, and to pay the Khumus (i.e. one-fifth) of the war booty to Allah and I forbid you to use Ad-dubba', An-Naqir, Al-Hantam and Al-Muzaffat (i.e. utensils used for preparing alcoholic drinks)." (See Hadith No. 50, Vol. 1).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.328]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 328

Narrated Abu Huraira:

Allah's Apostle said, "My heirs should not take even a single Dinar (i.e. anything from my property), and whatever I leave, excluding the expenditure of my wives and my laborers, will be Sadaqa (i.e. be used for charity)."'


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.329]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 329

Narrated Aisha:

Allah's Apostle died, and there was nothing in my house that a living being could eat, except some barley Lying on a shelf. So, I ate of it for a long period and measured it, and (after a short period) it was consumed.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.330]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 330

Narrated 'Amr bin Al-Harith:

The Prophet did not leave anything (after his death) except his arms, a white mule, and a (piece of) land which he had given as Sadaqa.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.331]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 331

Narrated 'Aisha:

(the wife of the Prophet) When the sickness of Allah's Apostle got aggravated, he asked the permission of his wives that he should be treated in my house, and they permitted him.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.332]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 332

Narrated Ibn Abu Mulaika:

'Aisha said, "The Prophet died in my house on the day of my turn while he was leaning on my chest closer to my neck, and Allah made my saliva mix with his Saliva." 'Aisha added, "'AbdurRahman came with a Siwak and the Prophet was too weak to use it so I took it, chewed it and then (gave it to him and he) cleaned his teeth with it."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.333]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 333

Narrated Safiya:

(the wife of the Prophet) That she came to visit Allah's Apostle while he was in Itikaf(i.e. seclusion in the Mosque during the last ten days of Ramadan. When she got up to return, Allah's Apostle got up with her and accompanied her, and when he reached near the gate of the Mosque close to the door (of the house) of Um Salama, the wife of the Prophet, two Ansari men passed by them and greeted Allah's Apostle and then went away. Allah's Apostle addressed them saying, "Don't hurry! (She is my wife)," They said, "Glorified be Allah! O Allah's Apostle (You are far away from any suspicion)," and his saying was hard on them. Allah's Apostle said, "Satan circulates in the mind of a person as blood does (in his body). I was afraid that Satan might put some (evil) thoughts in your minds."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.334]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 334

Narrated 'Abdullah bin 'Umar:

Once I went upstairs in Hafsa's house and saw the Prophet answering the call of nature with his back towards the Qibla and facing Sham.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.335]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 335

Narrated Aisha:

That Allah's Apostle used to offer the 'Asr prayer while the sun was still shining in her Hujra (i.e. her dwelling place).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.336]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 336

Narrated 'Abdullah:

The Prophet stood up and delivered a sermon, and pointing to 'Aisha's house (i.e. eastwards), he said thrice, "Affliction (will appear from) here," and, "from where the side of the Satan's head comes out (i.e. from the East)."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.337]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 337

Narrated 'Amra bint Abdur-Rahman:

'Aisha, the wife of the Prophet told her that once Allah's Apostle was with her and she heard somebody asking permission to enter Hafsa's house. She said, "O Allah's Apostle! This man is asking permission to enter your house." Allah's Apostle replied, "I think he is so-and-so (meaning the foster uncle of Hafsa). What is rendered illegal because of blood relations, is also rendered illegal because of the corresponding foster-relations."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.338]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 338

Narrated Anas:

That when Abu Bakr became the Caliph, he sent him to Bahrain and wrote this letter for him, and stamped it with the Ring of the Prophet. Three lines were engraved on the Ring, (the word) 'Muhammad' was in a line, 'Apostle' was in another line, and 'Allah' in a third.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.339]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 339

Narrated 'Isa bin Tahman:

Anas brought out to us two worn out leather shoes without hair and with pieces of leather straps. Later on Thabit Al-Banani told me that Anas said that they were the shoes of the Prophet.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.340]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 340

Narrated Abu Burda:

'Aisha brought out to us a patched wool Len garment, and she said, "(It chanced that) the soul of Allah's Apostle was taken away while he was wearing this." Abu-Burda added, "Aisha brought out to us a thick waist sheet like the ones made by the Yemenites, and also a garment of the type called Al-Mulabbada."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.341]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 341

Narrated Anas bin Malik:

When the cup of Allah's Apostle got broken, he fixed it with a silver wire at the crack. (The sub-narrator, 'Asim said, "I saw the cup and drank (water) in it.")


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.342]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 342

Narrated 'Ali bin Al-Husain:

That when they reached Medina after returning from Yazid bin Mu'awaiya after the martyrdom of Husain bin 'Ali (may Allah bestow His Mercy upon him), Al-Miswar bin Makhrama met him and said to him, "Do you have any need you may order me to satisfy?" 'Ali said, "No." Al-Miswar said, Will you give me the sword of Allah's Apostle for I am afraid that people may take it from you by force? By Allah, if you give it to me, they will never be able to take it till I die." When Ali bin Abu Talib demanded the hand of the daughter of Abi Jahal to be his wife besides Fatima, I heard Allah's Apostle on his pulpit delivering a sermon in this connection before the people, and I had then attained my age of puberty. Allah's Apostle said, "Fatima is from me, and I am afraid she will be subjected to trials in her religion (because of jealousy)." The Prophet then mentioned one of his son-in-law who was from the tribe of 'Abu Shams, and he praised him as a good son-in-law, saying, "Whatever he said was the truth, and he promised me and fulfilled his promise. I do not make a legal thing illegal, nor do I make an illegal thing legal, but by Allah, the daughter of Allah's Apostle and the daughter of the enemy of Allah, (i.e. Abu Jahl) can never get together (as the wives of one man) (See Hadith No. 76, Vo. 5).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.343]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 343

Narrated Ibn Al-Hanafiya:

If Ali had spoken anything bad about 'Uthman then he would have mentioned the day when some persons came to him and complained about the Zakat officials of 'Uthman. 'Ali then said to me, "Go to 'Uthman and say to him, 'This document contains the regulations of spending the Sadaqa of Allah's Apostle so order your Zakat officials to act accordingly." I took the document to 'Uthman. 'Uthman said, "Take it away, for we are not in need of it." I returned to 'Ali with it and informed him of that. He said, "Put it whence you took it."

Narrated Muhammad bin Suqa: I heard Mundhir At-Tuzi reporting Ibn Hanafiya who said, "My father sent me saying, 'Take this letter to 'Uthman for it contains the orders of the Prophet concerning the Sadaqa.' "


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.344]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 344

Narrated 'Ali:

Fatima complained of what she suffered from the hand mill and from grinding, when she got the news that some slave girls of the booty had been brought to Allah's Apostle. She went to him to ask for a maid-servant, but she could not find him, and told 'Aisha of her need. When the Prophet came, Aisha informed him of that. The Prophet came to our house when we had gone to our beds. (On seeing the Prophet) we were going to get up, but he said, 'Keep at your places,' I felt the coolness of the Prophet's feet on my chest. Then he said, "Shall I tell you a thing which is better than what you asked me for? When you go to your beds, say: 'Allahu Akbar (i.e. Allah is Greater)' for 34 times, and 'Alhamdu Lillah (i.e. all the praises are for Allah)' for 33 times, and Subhan Allah (i.e. Glorified be Allah) for 33 times. This is better for you than what you have requested."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.345]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 345

Narrated Jabir bin 'Abdullah Al-Ansari:

A man amongst us begot a boy whom he named Al-Qasim. On that the Ansar said, (to the man), "We will never call you Abu-al-Qasim and will never please you with this blessed title." So, he went to the Prophet and said, "O Allah's Apostle! I have begotten a boy whom I named Al-Qasim and the Ansar said, 'We will never call you Abu-al-Qasim, nor will we please you with this title.' " The Prophet said, "The Ansar have done well. Name by my name, but do not name by my Kunya, for I am Qasim."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.346]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 346

Narrated Muawiya:

Allah's Apostle said, "If Allah wants to do good for somebody, he makes him comprehend the Religion (i.e. Islam), and Allah is the Giver and I am Al-Qasim (i.e. the distributor), and this (Muslim) nation will remain victorious over their opponents, till Allah's Order comes and they will still be victorious "

Narrated Abu Huraira: Allah's Apostle said, "Neither do I give you (anything) nor withhold (anything) from you, but I am just a distributor (i.e. Qasim), and I give as I am ordered."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.347]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 347

Narrated Khaula Al-Ansariya:

I heard Allah's Apostle saying, "Some people spend Allah's Wealth (i.e. Muslim's wealth) in an unjust manner; such people will be put in the (Hell) Fire on the Day of Resurrection."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.348]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 348

Narrated 'Urwa-al-Bariqi:

The Prophet said, "Horses are always the source of good, namely, rewards (in the Hereafter) and booty, till the Day of Resurrection."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.349]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 349

Narrated Abu Huraira:

Allah's Apostle said, "When Khosrau is ruined, there will be no Khosrau after him; and when Caesar is ruined, there will be no Caesar after him. By Him in Whose Hands my life is, you will spend their treasures in Allah's Cause."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.350]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 350

Narrated Jabir bin Samura:

Allah's Apostle said, "When Khosrau is ruined, there will be no Khosrau after him; and when Caesar is ruined, their will be no Caesar after him. By Him in Whose Hands my life is, you will spend their treasures in Allah's Cause."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.351]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 351

Narrated Jabir bin Abdullah:

Allah's Apostle said, "Booty has been made legal for me."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.352]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 352

Narrated Abu Huraira:

Allah's Apostle said, "Allah guarantees him who strives in His Cause and whose motivation for going out is nothing but Jihad in His Cause and belief in His Word, that He will admit him into Paradise (if martyred) or bring him back to his dwelling place, whence he has come out, with what he gains of reward and booty."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.353]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 353

Narrated Abu Huraira:

The Prophet said, "A prophet amongst the prophets carried out a holy military expedition, so he said to his followers, 'Anyone who has married a woman and wants to consummate the marriage, and has not done so yet, should not accompany me; nor should a man who has built a house but has not completed its roof; nor a man who has sheep or shecamels and is waiting for the birth of their young ones.' So, the prophet carried out the expedition and when he reached that town at the time or nearly at the time of the 'Asr prayer, he said to the sun, 'O sun! You are under Allah's Order and I am under Allah's Order O Allah! Stop it (i.e. the sun) from setting.' It was stopped till Allah made him victorious.

Then he collected the booty and the fire came to burn it, but it did not burn it. He said (to his men), 'Some of you have stolen something from the booty. So one man from every tribe should give me a pledge of allegiance by shaking hands with me.' (They did so and) the hand of a man got stuck over the hand of their prophet. Then that prophet said (to the man), 'The theft has been committed by your people. So all the persons of your tribe should give me the pledge of allegiance by shaking hands with me.' The hands of two or three men got stuck over the hand of their prophet and he said, "You have committed the theft.' Then they brought a head of gold like the head of a cow and put it there, and the fire came and consumed the booty. The Prophet added: Then Allah saw our weakness and disability, so he made booty legal for us."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.354]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 354

Narrated Aslam:

'Umar said, "Were it not for those Muslims who have not come to existence yet, I would have distributed (the land of) every town I conquer among the fighters as the Prophet distributed the land of Khaibar."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.355]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 355

Narrated Abu Musa Al-Ashari:

A bedouin asked the Prophet, "A man may fight for the sake of booty, and another may fight so that he may be mentioned by the people, and a third may fight to show his position (i.e. bravery); which of these regarded as fighting in Allah's Cause?" The Prophet said, "He who fights so that Allah's Word (i.e. Islam) should be superior, fights for Allah's Cause."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.356]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 356

Narrated 'Abdullah bin Abu Mulaika:

Some silken cloaks with golden buttons were presented to the Prophet. He distributed them amongst his companions and kept one for Makhrama, bin Naufal. Later on Makhrama came along with his son Al-Miswar bin Makhrama, and stood up at the gate and said (to his son). "Call him (i.e. the Prophet) to me." The Prophet heard his voice, took a silken cloak and brought it to him, placing those golden buttons in front of him saying, "O Abu-al-Miswar! I have kept this aside for you! O Abu-al Miswar! I have kept this aside for you!" Makhrama was a bad-tempered man.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.357]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 357

Narrated Anas bin Malik:

People used to give some of their datepalms to the Prophet (as a gift), till he conquered Bani Quraiza and Bani An-Nadir, whereupon he started returning their favors.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.358]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 358

Narrated 'Abdullah bin Az-Zubair:

When Az-Zubair got up during the battle of Al-Jamal, he called me and I stood up beside him, and he said to me, "O my son! Today one will be killed either as an oppressor or as an oppressed one. I see that I will be killed as an oppressed one. My biggest worry is my debts. Do you think, if we pay the debts, there will be something left for us from our money?" Az-Zubair added, "O my son! Sell our property and pay my debts." Az-Zubair then willed one-third of his property and willed one-third of that portion to his sons; namely, 'Abdullah's sons. He said, "One-third of the one third. If any property is left after the payment of the debts, one-third (of the one-third of what is left) is to be given to your sons." (Hisham, a sub-narrator added, "Some of the sons of 'Abdullah were equal in age to the sons of Az-Zubair e.g. Khubaib and 'Abbas. 'Abdullah had nine sons and nine daughters at that time." (The narrator 'Abdullah added:) My father (Az-Zubair) went on drawing my attention to his debts saying, "If you should fail to pay part of the debts, appeal to my Master to help you." By Allah! I could not understand what he meant till I asked, "O father! Who is your Master?" He replied, "Allah (is my Master)." By Allah, whenever I had any difficulty regarding his debts, I would say, "Master of Az-Zubair! Pay his debts on his behalf ." and Allah would (help me to) pay it. Az-Zubair was martyred leaving no Dinar or Dirham but two pieces of land, one of which was (called) Al-Ghaba, and eleven houses in Medina, two in Basra, one in Kufa and one in Egypt. In fact, the source of the debt which he owed was, that if somebody brought some money to deposit with him. Az Zubair would say, "No, (i won't keep it as a trust), but I take it as a debt, for I am afraid it might be lost." Az-Zubair was never appointed governor or collector of the tax of Kharaj or any other similar thing, but he collected his wealth (from the war booty he gained) during the holy battles he took part in, in the company of the Prophet, Abu Bakr, 'Umar, and 'Uthman. ('Abdullah bin Az-Zubair added:) When I counted his debt, it turned to be two million and two hundred thousand. (The sub-narrator added:) Hakim bin Hizam met Abdullah bin Zubair and asked, "O my nephew! How much is the debt of my brother?" 'Abdullah kept it as a secret and said, "One hundred thousand," Hakim said, "By Allah! I don't think your property will cover it." On that 'Abdullah said to him, "What if it is two million and two hundred thousand?" Hakim said, "I don't think you can pay it; so if you are unable to pay all of it, I will help you." Az-Zubair had already bought Al-Ghaba for one hundred and seventy thousand. 'Abdullah sold it for one million and six hundred thousand. Then he called the people saying, "Any person who has any money claim on Az-Zubair should come to us in Al-Ghaba." There came to him 'Abdullah bin Ja'far whom Az-Zubair owed four hundred thousand. He said to 'Abdullah bin Az-Zubair, "If you wish I will forgive you the debt." 'Abdullah (bin Az-Zubair) said, "No." Then Ibn Ja'far said, "If you wish you can defer the payment if you should defer the payment of any debt." Ibn Az-Zubair said, "No." 'Abdullah bin Ja'far said, "Give me a piece of the land." 'Abdullah bin AzZubair said (to him), "Yours is the land extending from this place to this place." So, 'Abdullah bin Az-Zubair sold some of the property (including the houses) and paid his debt perfectly, retaining four and a half shares from the land (i.e. Al-Ghaba). He then went to Mu'awlya while 'Amr bin 'Uthman, Al-Mundhir bin Az-Zubair and Ibn Zam'a were sitting with him. Mu'awiya asked, "At what price have you appraised Al-Ghaba?" He said, "One hundred thousand for each share," Muawiya asked, "How many shares have been left?" 'Abdullah replied, "Four and a half shares." Al-Mundhir bin Az-Zubair said, "I would like to buy one share for one hundred thousand." 'Amr bin 'Uthman said, "I would like to buy one share for one hundred thousand." Ibn Zam'a said, "I would like to buy one share for one hundred thousand." Muawiya said, "How much is left now?" 'Abdullah replied, "One share and a half." Muawiya said, "I would like to buy it for one hundred and fifty thousand." 'Abdullah also sold his part to Muawiya six hundred thousand. When Ibn AzZubair had paid all the debts. Az-Zubair's sons said to him, "Distribute our inheritance among us." He said, "No, by Allah, I will not distribute it among you till I announce in four successive Hajj seasons, 'Would those who have money claims on Az-Zubair come so that we may pay them their debt." So, he started to announce that in public in every Hajj season, and when four years had elapsed, he distributed the inheritance among the inheritors. Az-Zubair had four wives, and after the one-third of his property was excluded (according to the will), each of his wives received one million and two hundred thousand. So the total amount of his property was fifty million and two hundred thousand.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.359]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 359

Narrated Ibn 'Umar:

'Uthman did not join the Badr battle because he was married to one of the daughters of Allah's Apostle and she was ill. So, the Prophet said to him. "You will get a reward and a share (from the war booty) similar to the reward and the share of one who has taken part in the Badr battle."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.360]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 360

Narrated Marwan bin Al-Hakim and Miswar bin Makhrama:

When the Hawazin delegation came to Allah's Apostle after they had embraced Islam and requested him to return their properties and war prisoners to them, Allah's Apostle said, "To me the best talk is the truest, so you may choose either of two things; the war prisoners or the wealth, for I have delayed their distribution." Allah's Apostle had waited for them for over ten days when he returned from Ta'if. So, when those people came to know that Allah's Apostle was not going to return to them except one of the two things the said, "We choose our war Prisoners 'Allah's Apostle stood up amongst the Muslims, and after glorifying Allah as He deserved, he said, "Now then, these brothers of yours have come to us with repentance, and I see it logical that I should return their captives to them, so whoever of you likes to do that as a favor then he can do it, and whoever amongst you likes to stick to his share, let him give up his prisoners and we will compensate him from the very first Fai' (i.e. war booty received without fight) which Allah will give us." On that, all the people said. 'O Allah's Apostles We have agreed willingly to do so (return the captives)" Then Allah's Apostle said to them "I do not know who amongst you has agreed to this and who has not. You should return and let your leaders inform me of your agreement." The people returned and their leaders spoke to them, and then came to Allah's Apostle and said, "All the people have agreed willingly to do so and have given the permission to return the war prisoners (without Compensation)" (Az-Zuhri, the sub-narrator states) This is what has been related to us about the captives of Hawazin.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.361]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 361

Narrated Zahdam:

Once we were in the house of Abu Musa who presented a meal containing cooked chicken. A man from the tribe of Bani Taim Allah with red complexion as if he were from the Byzantine war prisoners, was present. Abu Musa invited him to share the meal but he (apologised) saying. "I saw chickens eating dirty things and so I have had a strong aversion to eating them, and have taken an oath that I will not eat chickens." Abu Musa said, "Come along, I will tell you about this matter (i.e. how to cancel one's oat ). I went to the Prophet in the company of a group of Al-Ashariyin, asked him to provide us with means of conveyance. He said, 'By Allah, I will not provide you with any means of conveyance and I have nothing to make you ride on.' Then some camels as booty were brought to Allah's Apostle and he asked for us saying. 'Where are the group of Al-Ash'ariyun?' Then he ordered that we should be given five camels with white humps. When we set out we said, 'What have we done? We will never be blessed (with what we have been given).' So, we returned to the Prophet and said, 'We asked you to provide us with means of conveyance, but you took an oath that you would not provide us with any means of conveyance. Did you forget (your oath when you gave us the camels)? He replied. 'I have not provided you with means of conveyance, but Allah has provided you with it, and by Allah, Allah willing, if ever I take an oath to do something, and later on I find that it is more beneficial to do something different, I will do the thing which is better, and give expiation for my oath."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.362]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 362

Narrated Nafi from Ibn Umar:

Allah's Apostle sent a Sariya towards Najd, and Abdullah bin 'Umar was in the Sariya. They gained a great number of camels as war booty. The share of each one of them was twelve or eleven camels, and they were given an extra camel each.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.363]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 363

Narrated Ibn 'Umar:

Allah's Apostle used to give extra share to some of the members of the Sariya he used to send, in addition to the shares they shared with the army in general.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.364]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 364

Narrated Abu Musa:

We got the news of the migration of the Prophet while we were in Yemen, so we set out migrating to him. We were, I and my two brothers, I being the youngest, and one of my brothers was Abu Burda and the other was Abu Ruhm. We were over fifty (or fifty-three or fifty two) men from our people. We got on board a ship which took us to An-Najashi in Ethiopia, and there we found Ja'far bin Abu Talib and his companions with An-Najaishi. Ja'far said (to us), "Allah's Apostle has sent us here and ordered us to stay here, so you too, stay with us." We stayed with him till we all left (Ethiopia) and met the Prophet at the time when he had conquered Khaibar. He gave us a share from its booty (or gave us from its booty). He gave only to those who had taken part in the Ghazwa with him. but he did not give any share to any person who had not participated in Khaibar's conquest except the people of our ship, besides Ja'far and his companions, whom he gave a share as he did them (i.e. the people of the ship).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.365]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 365

Narrated Jabir:

Allah's Apostle said (to me), "If the property of Bahrain had come to us, I would have given you so much and so much." But the Bahrain property did not come till the Prophet had died. When the Bahrain property came. Abu Bakr ordered somebody to announce, "Any person who has money claim on Allah's Apostle or whom Allah's Apostle had promised something, should come to us." So, I went to him and said, "Allah's Apostle had promised to give me so much an so much." Abu Bakr scooped up money with both hands thrice for me." (The sub-narrator Sufyan illustrated this action by scooping up with both hands and said, "Ibn Munkadir, another sub-narrator, used to illustrate it in this way.")

Narrated Jabir: Once I went to Abu Bakr and asked for the money but he did not give me, and I went to him again, but he did not give me, so I went to him for the third time and said, "I asked you, but you did not give me; then I asked you (for the second time) and you did not give me; then I asked you (for the third time) but you did not give me. You should either give me or allow yourself to be considered a miser regarding my case." Abu Bakr said, "You tell me that I am a miser with regard to you. But really, whenever I rejected your request, I had the inclination to give you."

(In another narration Jabir added:) So, Abu Bakr scooped up money with both hands for me and asked me to count it. I found out that It was five hundred. Abu Bakr told me to take twice that amount.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.366]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 366

Narrated Jabir bin Abdullah:

While Allah's Apostle was distributing the booty at Al-Ja'rana, somebody said to him "Be just (in your distribution)." The Prophet replied, "Verily I would be miserable if I did not act justly."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.367]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 367

Narrated Jubair bin Mutim:

The Prophet talked about war prisoners of Badr saying, "Had Al-Mutim bin Adi been alive and interceded with me for these mean people, I would have freed them for his sake."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.368]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 368

Narrated Jubair bin Mutim:

I and 'Uthman bin 'Affan went to Allah's Apostle and said, "O Allah's Apostle! You have given to Bani Al-Muttalib and left us although they and we are of the same kinship to you." Allah's Apostle said, "Bani Muttalib and Bani Hashim are one and the same." The Prophet did not give a share to Bani Abd Shams and Bani Naufai. (Ibn Ishaq said, "Abd Shams and Hashim and Al-Muttalib were maternal brothers and their mother was 'Atika bint Murra and Naufal was their paternal brother.)


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.369]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 369

Narrated 'Abdur-Rahman bin 'Auf:

While I was standing in the row on the day (of the battle) of Badr, I looked to my right and my left and saw two young Ansari boys, and I wished I had been stronger than they. One of them called my attention saying, "O Uncle! Do you know Abu Jahl?" I said, "Yes, What do you want from him, O my nephew?" He said, "I have been informed that he abuses Allah's Apostle. By Him in Whose Hands my life is, if I should see him, then my body will not leave his body till either of us meet his fate." I was astonished at that talk. Then the other boy called my attention saying the same as the other had said. After a while I saw Abu Jahl walking amongst the people. I said (to the boys), "Look! This is the man you asked me about." So, both of them attacked him with their swords and struck him to death and returned to Allah'S Apostle to inform him of that. Allah's Apostle asked, "Which of you has killed him?" Each of them said, "I Have killed him." Allah's Apostle asked, "Have you cleaned your swords?" They said, "No. " He then looked at their swords and said, "No doubt, you both have killed him and the spoils of the deceased will be given to Muadh bin Amr bin Al-Jamuh." The two boys were Muadh bin 'Afra and Muadh bin Amr bin Al-Jamuh.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.370]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 370

Narrated Abu Qatada:

We set out in the company of Allah's Apostle on the day (of the battle) of Hunain. When we faced the enemy, the Muslims retreated and I saw a pagan throwing himself over a Muslim. I turned around and came upon him from behind and hit him on the shoulder with the sword He (i.e. the pagan) came towards me and seized me so violently that I felt as if it were death itself, but death overtook him and he released me. I followed 'Umar bin Al Khattab and asked (him), "What is wrong with the people (fleeing)?" He replied, "This is the Will of Allah," After the people returned, the Prophet sat and said, "Anyone who has killed an enemy and has a proof of that, will posses his spoils." I got up and said, "Who will be a witness for me?" and then sat down. The Prophet again said, "Anyone who has killed an enemy and has proof of that, will possess his spoils." I (again) got up and said, "Who will be a witness for me?" and sat down. Then the Prophet said the same for the third time. I again got up, and Allah's Apostle said, "O Abu Qatada! What is your story?" Then I narrated the whole story to him. A man (got up and) said, "O Allah's Apostle! He is speaking the truth, and the spoils of the killed man are with me. So please compensate him on my behalf." On that Abu Bakr As-Siddiq said, "No, by Allah, he (i.e. Allah's Apostle ) will not agree to give you the spoils gained by one of Allah's Lions who fights on the behalf of Allah and His Apostle." The Prophet said, "Abu Bakr has spoken the truth." So, Allah's Apostle gave the spoils to me. I sold that armor (i.e. the spoils) and with its price I bought a garden at Bani Salima, and this was my first property which I gained after my conversion to Islam.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.371]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 371

Narrated Urwa bin Az-Zubair:

Hakim bin Hizam said, "I asked Allah's Apostle for something, and he gave me. I asked him again, and he gave me, and said to me. 'O Hakim! This wealth is like green sweet (i.e. fruit), and if one takes it without greed, then one is blessed in it, and if one takes it with greediness, then one is not blessed in it, and will be like the one who eats without satisfaction. And an upper (i.e. giving) hand is better than a lower (i.e. taking) hand,' I said, 'O Allah's Apostle! By Him Who has sent you with the Truth. I will not ask anyone for anything after you till I leave this world." So, when Abu Bakr during his Caliphate, called Hakim to give him (some money), Hakim refused to accept anything from him. Once 'Umar called him (during his Caliphate) in order to give him something, but Hakim refused to accept it, whereupon 'Umar said, "O Muslims! I give him (i.e. Haklm) his right which Allah has assigned to him) from this Fai '(booty), but he refuses to take it." So Haklm never took anything from anybody after the Prophet till he died.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.372]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 372

Narrated Nafi:

'Umar bin Al-Khattab said, "O Allah's Apostle! I vowed to observe Itikaf for one day during the Pre-lslamic period." The Prophet ordered him to fulfill his vow. 'Umar gained two lady captives from the war prisoners of Hunain and he left them in some of the houses at Mecca. When Allah's Apostle freed the captives of Hunain without ransom, they came out walking in the streets. 'Umar said (to his son), "O Abdullah! See what is the matter." 'Abdullah replied, "Allah's Apostle has freed the captives without ransom." He said (to him), "Go and set free those two slave girls." (Nafi added:) Allah's Apostle did not perform the 'Umra from Al-Jarana, and if he had performed the 'Umra, it would not have been hidden from 'Abdullah.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.373]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 373

Narrated 'Amr bin Taghlib:

Allah's Apostle gave (gifts) to some people to the exclusion of some others. The latter seemed to be displeased by that. The Prophet said, "I give to some people, lest they should deviate from True Faith or lose patience, while I refer other people to the goodness and contentment which Allah has put in their hearts, and 'Amr bin Taghlib is amongst them." 'Amr bin Taghlib said, "The statement of Allah's Apostle is dearer to me than red camels."

Narrated Al-Hasan: 'Amr bin Taghlib told us that Allah's Apostle got some property or some war prisoners and he distributed them in the above way (i.e. giving to some people to the exclusion of others) .


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.374]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 374

Narrated Anas:

The Prophet said, "I give to Quraish people in order to let them adhere to Islam, for they are near to their life of Ignorance (i.e. they have newly embraced Islam and it is still not strong in their hearts."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.375]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 375

Narrated Anas bin Malik:

When Allah favored His Apostle with the properties of Hawazin tribe as Fai (booty), he started giving to some Quarries men even up to one-hundred camels each, whereupon some Ansari men said about Allah's Apostle, "May Allah forgive His Apostle! He is giving to (men of) Quraish and leaves us, in spite of the fact that our swords are still dropping blood (of the infidels)" When Allah's Apostle was informed of what they had said, he called the Ansar and gathered them in a leather tent and did not call anybody else along, with them. When they gathered, Allah's Apostle came to them and said, "What is the statement which, I have been informed, and that which you have said?" The learned ones among them replied," O Allah's Apostle! The wise ones amongst us did not say anything, but the youngsters amongst us said, 'May Allah forgive His Apostle; he gives the Quarish and leaves the Ansar, in spite of the fact that our swords are still dribbling (wet) with the blood of the infidels.' " Allah's Apostle replied, I give to such people as are still close to the period of Infidelity (i.e. they have recently embraced Islam and Faith is still weak in their hearts). Won't you be pleased to see people go with fortune, while you return with Allah's Apostle to your houses? By Allah, what you will return with, is better than what they are returning with." The Ansar replied, "Yes, O Allah's Apostle, we are satisfied' Then the Prophet said to them." You will find after me, others being preferred to you. Then be patient till you meet Allah and meet His Apostle at Al-Kauthar (i.e. a fount in Paradise)." (Anas added:) But we did not remain patient.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.376]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 376

Narrated Jubair bin Mutim:

That while he was with Allah's Apostle who was accompanied by the people on their way back from Hunain, the bedouins started begging things of Allah's Apostle so much so that they forced him to go under a Samura tree where his loose outer garment was snatched away. On that, Allah's Apostle stood up and said to them, "Return my garment to me. If I had as many camels as these trees, I would have distributed them amongst you; and you will not find me a miser or a liar or a coward."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.377]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 377

Narrated Anas bin Malik:

While I was walking with the Prophet who was wearing a Najrani outer garment with a thick hem, a bedouin came upon the Prophet and pulled his garment so violently that I could recognize the impress of the hem of the garment on his shoulder, caused by the violence of his pull. Then the bedouin said, "Order for me something from Allah's Fortune which you have." The Prophet turned to him and smiled, and ordered that a gift be given to him.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.378]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 378

Narrated 'Abdullah:

On the day (of the battle) of Hunain, Allah's Apostle favored some people in the distribution of the booty (to the exclusion of others); he gave Al-Aqra' bin Habis one-hundred camels and he gave 'Uyaina the same amount, and also gave to some of the eminent Arabs, giving them preference in this regard. Then a person came and said, "By Allah, in this distribution justice has not been observed, nor has Allah's Pleasure been aimed at." I said (to him), "By Allah, I will inform the Prophet (of what you have said), "I went and informed him, and he said, "If Allah and His Apostle did not act justly, who else would act justly. May Allah be merciful to Moses, for he was harmed with more than this, yet he kept patient."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.379]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 379

Narrated Asma bint Abu Bakr:

I used to carry the date stones on my head from the land of Az-Zubair which Allah's Apostle had given to him, and it was at a distance of 2/3 of a Farsakh from my house.

Narrated Hisham's father: The Prophet (gave Az-Zubair a piece of land from the property of Bani An-Nadir (gained as war booty).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.380]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 380

Narrated Ibn 'Umar:

Umar bin Al-Khattab expelled all the Jews and Christians from the land of Hijaz. Allah's Apostle after conquering Khaibar, thought of expelling the Jews from the land which, after he conquered it belonged to Allah, Allah's Apostle and the Muslims. But the Jews requested Allah's Apostle to leave them there on the condition that they would do the labor and get half of the fruits (the land would yield). Allah's Apostle said, "We shall keep you on these terms as long as we wish." Thus they stayed till the time of 'Umar's Caliphate when he expelled them to Taima and Ariha.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.381]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 381

Narrated 'Abdullah bin Mughaffal:

While we were besieging the fort of Khaibar, a person threw a leather container containing fat, and I ran to take it, but when I turned I saw the Prophet (standing behind), so I felt embarrassed in front of him.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.382]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 382

Narrated Ibn Umar:

In our holy battles, we used to get honey and grapes, as war booty which we would eat and would not store.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.383]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 383

Narrated Ibn Abi Aufa:

We were afflicted with hunger during the besiege of Khaibar, and when it was the day of (the battle of) Khaibar, we slaughtered the donkeys and when the pots got boiling (with their meat). Allah's Apostle made an announcement that all the pots should be upset and that nobody should eat anything of the meat of the donkeys. We thought that the Prophet prohibited that because the Khumus had not been taken out of the booty (i.e. donkeys); other people said, "He prohibited eating them for ever." The sub-narrator added, "I asked Said bin Jubair who said, 'He has made the eating of donkeys' meat illegal for ever.")


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.384]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 384

Narrated 'Umar bin Dinar:

I was sitting with Jabir bin Zaid and 'Amr bin Aus, and Bjalla was narrating to them in 70 A.H. the year when Musab bin Az-Zubair was the leader of the pilgrims of Basra. We were sitting at the steps of Zam-zam well and Bajala said, "I was the clerk of Juz bin Muawiya, Al-Ahnaf's paternal uncle. A letter came from 'Umar bin Al-Khattab one year before his death; and it was read:-- "Cancel every marriage contracted among the Magians between relatives of close kinship (marriages that are regarded illegal in Islam: a relative of this sort being called Dhu-Mahram.)" 'Umar did not take the Jizya from the Magian infidels till 'Abdur-Rahman bin 'Auf testified that Allah's Apostle had taken the Jizya from the Magians of Hajar.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.385]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 385

Narrated 'Amr bin 'Auf Al-Ansari:

(who was an ally of Bam 'Amr bin Lu'ai and one of those who had taken part in (the Ghazwa of) Badr): Allah's Apostle sent Abu 'Ubaida bin Al-Jarreh to Bahrain to collect the Jizya. Allah's Apostle had established peace with the people of Bahrain and appointed Al-'Ala' bin Al-Hadrami as their governor. When Abu 'Ubaida came from Bahrain with the money, the Ansar heard of Abu 'Ubaida's arrival which coincided with the time of the morning prayer with the Prophet. When Allah's Apostle led them in the morning prayer and finished, the Ansar approached him, and he looked at them and smiled on seeing them and said, "I feel that you have heard that Abu. 'Ubaida has brought something?" They said, "Yes, O Allah's Apostle' He said, "Rejoice and hope for what will please you! By Allah, I am not afraid of your poverty but I am afraid that you will lead a life of luxury as past nations did, whereupon you will compete with each other for it, as they competed for it, and it will destroy you as it destroyed them."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.386]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 386

Narrated Jubair bin Haiya:

'Umar sent the Muslims to the great countries to fight the pagans. When Al-Hurmuzan embraced Islam, 'Umar said to him. "I would like to consult you regarding these countries which I intend to invade." Al-Hurmuzan said, "Yes, the example of these countries and their inhabitants who are the enemies. of the Muslims, is like a bird with a head, two wings and two legs; If one of its wings got broken, it would get up over its two legs, with one wing and the head; and if the other wing got broken, it would get up with two legs and a head, but if its head got destroyed, then the two legs, two wings and the head would become useless. The head stands for Khosrau, and one wing stands for Caesar and the other wing stands for Faris. So, order the Muslims to go towards Khosrau." So, 'Umar sent us (to Khosrau) appointing An-Numan bin Muqrin as our commander. When we reached the land of the enemy, the representative of Khosrau came out with forty-thousand warriors, and an interpreter got up saying, "Let one of you talk to me!" Al-Mughira replied, "Ask whatever you wish." The other asked, "Who are you?" Al-Mughira replied, "We are some people from the Arabs; we led a hard, miserable, disastrous life: we used to suck the hides and the date stones from hunger; we used to wear clothes made up of fur of camels and hair of goats, and to worship trees and stones. While we were in this state, the Lord of the Heavens and the Earths, Elevated is His Remembrance and Majestic is His Highness, sent to us from among ourselves a Prophet whose father and mother are known to us. Our Prophet, the Messenger of our Lord, has ordered us to fight you till you worship Allah Alone or give Jizya (i.e. tribute); and our Prophet has informed us that our Lord says:-- "Whoever amongst us is killed (i.e. martyred), shall go to Paradise to lead such a luxurious life as he has never seen, and whoever amongst us remain alive, shall become your master." (Al-Mughira, then blamed An-Numan for delaying the attack and) An-Nu' man said to Al-Mughira, "If you had participated in a similar battle, in the company of Allah's Apostle he would not have blamed you for waiting, nor would he have disgraced you. But I accompanied Allah's Apostle in many battles and it was his custom that if he did not fight early by daytime, he would wait till the wind had started blowing and the time for the prayer was due (i.e. after midday)."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.387]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 387

Narrated Abu Humaid As-Saidi:

We accompanied the Prophet in the Ghazwa of Tabuk and the king of 'Aila presented a white mule and a cloak as a gift to the Prophet. And the Prophet wrote to him a peace treaty allowing him to keep authority over his country.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.388]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 388

Narrated Juwairiya bin Qudama At-Tamimi:

We said to 'Umar bin Al-Khattab, Jo Chief of the believers! Advise us." He said, "I advise you to fulfill Allah's Convention (made with the Dhimmis) as it is the convention of your Prophet and the source of the livelihood of your dependents (i.e. the taxes from the Dhimmis.) "


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.389]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 389

Narrated Yahya bin Said:

Once the Prophet called the Ansar in order to grant them part of the land of Bahrain. On that they said, "No! By Allah, we will not accept it unless you grant a similar thing to our Quarries brothers as well." He said, "That will be their's if Allah wishes." But when the Ansar persisted in their request, he said, "After me you will see others given preference over you in this respect (in which case) you should be patient till you meet me at the Tank (of Al-Kauthar)."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.390]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 390

Narrated Jabir bin 'Abdullah:

Allah's Apostle once said to me, "If the revenue of Bahrain came, I would give you this much and this much." When Allah's Apostle had died, the revenue of Bahrain came, and Abu Bakr announced, " Let whoever was promised something by Allah's Apostle come to me." So, I went to Abu Bakr and said, "Allah's Apostle said to me, 'If the revenue of Bahrain came, I would give you this much and this. much." On that Abu Bakr said to me, "Scoop (money) with both your hands." I scooped money with both my hands and Abu Bakr asked me to count it. I counted it and it was five-hundred (gold pieces). The total amount he gave me was one thousand and five hundred (gold pieces.)

Narrated Anas: Money from Bahrain was brought to the Prophet . He said, "Spread it in the Mosque." It was the biggest amount that had ever been brought to Allah's Apostle . In the meantime Al-'Abbas came to him and said, "O Allah's Apostle! Give me, for I gave the ransom of myself and Aqil." The Prophet said (to him), "Take." He scooped money with both hands and poured it in his garment and tried to lift it, but he could not and appealed to the Prophet, "Will you order someone to help me in lifting it?" The Prophet said, "No." Then Al-'Abbas said, "Then will you yourself help me carry it?" The Prophet said, "No." Then Al 'Abbas threw away some of the money, but even then he was not able to lift it, and so he gain requested the Prophet "Will you order someone to help me carry it?" The Prophet said, "No." Then Al-'Abbas said, "Then will you yourself yelp me carry it?" The Prophet said, 'No." So, Al-'Abbas threw away some more money and lifted it on his shoulder and went away. The Prophet kept on looking at him with astonishment at his greediness till he went out of our sight. Allah's Apostle did not get up from there till not a single Dirham remained from that money.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.391]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 391

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Whoever killed a person having a treaty with the Muslims, shall not smell the smell of Paradise though its smell is perceived from a distance of forty years."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.392]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 392

Narrated Abu Huraira:

While we were in the Mosque, the Prophet came out and said, "Let us go to the Jews" We went out till we reached Bait-ul-Midras. He said to them, "If you embrace Islam, you will be safe. You should know that the earth belongs to Allah and His Apostle, and I want to expel you from this land. So, if anyone amongst you owns some property, he is permitted to sell it, otherwise you should know that the Earth belongs to Allah and His Apostle."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.393]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 393

Narrated Said bin Jubair:

that he heard Ibn 'Abbas saying, "Thursday! And you know not what Thursday is? After that Ibn 'Abbas wept till the stones on the ground were soaked with his tears. On that I asked Ibn 'Abbas, "What is (about) Thursday?" He said, "When the condition (i.e. health) of Allah's Apostle deteriorated, he said, 'Bring me a bone of scapula, so that I may write something for you after which you will never go astray.'The people differed in their opinions although it was improper to differ in front of a prophet, They said, 'What is wrong with him? Do you think he is delirious? Ask him (to understand). The Prophet replied, 'Leave me as I am in a better state than what you are asking me to do.' Then the Prophet ordered them to do three things saying, 'Turn out all the pagans from the Arabian Peninsula, show respect to all foreign delegates by giving them gifts as I used to do.' " The sub-narrator added, "The third order was something beneficial which either Ibn 'Abbas did not mention or he mentioned but I forgot.'


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.394]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 394

Narrated Abu Huraira:

When Khaibar was conquered, a roasted poisoned sheep was presented to the Prophets as a gift (by the Jews). The Prophet ordered, "Let all the Jews who have been here, be assembled before me." The Jews were collected and the Prophet said (to them), "I am going to ask you a question. Will you tell the truth?'' They said, "Yes.' The Prophet asked, "Who is your father?" They replied, "So-and-so." He said, "You have told a ie; your father is so-and-so." They said, "You are right." He siad, "Will you now tell me the truth, if I ask you about something?" They replied, "Yes, O AbuAl-Qasim; and if we should tell a lie, you can realize our lie as you have done regarding our father." On that he asked, "Who are the people of the (Hell) Fire?" They said, "We shall remain in the (Hell) Fire for a short period, and after that you will replace us." The Prophet said, "You may be cursed and humiliated in it! By Allah, we shall never replace you in it.'' Then he asked, "Will you now tell me the truth if I ask you a question?" They said, "Yes, O Ab Li-AI-Qasim." He asked, "Have you poisoned this sheep?" They said, "Yes." He asked, "What made you do so?" They said, "We wanted to know if you were a liar in which case we would get rid of you, and if you are a prophet then the poison would not harm you."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.395]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 395

Narrated 'Asim:

I asked Anas about the Qunut (i.e. invocation in the prayer). Anas said, "It should be recited before bowing." I said, "So-and-so claims that you say that it should be recited after bowing." He replied, "He is mistaken." Then Anas narrated to us that the Prophet invoked evil on the tribe of Bani-Sulaim for one month after bowing. ' Anas Further said, "The Prophet had sent 40 or 70 Qaris (i.e. men well versed in the knowledge of the Qur'an) to some pagans, but the latter struggled with them and martyred them, although there was a peace pact between them and the Prophet I had never seen the Prophet so sorry and worried about anybody as he was about them (i.e. the Qaris)."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.396]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 396

Narrated Um Hani:

the daughter of Abu Talib: I went to Allah's Apostle on the day of the conquest of Mecca and found him taking a bath, and his daughter Fatima was screening him. I greeted him and he asked, "Who is that?" I said, "I, Um Hani bint Abi Talib." He said, "Welcome, O Um Hani." When he had finished his bath, he stood up and offered eight Rakat while dressed in one garment. I said, "O Allah's Apostle! My brother 'Ali has declared that he will kill a man to whom I have granted asylum. The man is so and-so bin Hubaira." Allah's Apostle said, "O Um Hani! We will grant asylum to the one whom you have granted asylum." (Um Hani said, "That (visit) took place in the Duha (i.e. forenoon)).


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.397]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 397

Narrated Ibrahim At-Tamimi's father:

'Ali delivered a sermon saying, "We have no book to read except the Book of Allah and what is written in this paper which contains verdicts regarding (retaliation for) wounds, the ages of the camels (given as Zakat or as blood money) and the fact that Medina is a sanctuary in between Air mountain to so-and-so (mountain). So, whoever innovates in it an heresy or commits a sin or gives shelter in it, to such an innovator will incur the Curse of Allah, the angels and all the people, and none of his compulsory or optional good deeds of worship will be accepted. And whoever (freed slave) takes as his master (i.e. befriends) other than his real masters will incur the same (Curse). And the asylum granted by any Muslim is to be secured by all the other Muslims, and whoever betrays a Muslim in this respect will incur the same (Curse)."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.398]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 398

Narrated Sahl bin Abi Hathma:

'Abdullah bin Sahl and Muhaiyisa bin Mas'ud bin Zaid set out to Khaibar, the inhabitants of which had a peace treaty with the Muslims at that time. They parted and later on Muhaiyisa came upon 'Abdullah bin Sah! and found him murdered agitating in his blood. He buried him and returned to Medina. 'Abdur Rahman bin Sahl, Muhaiyisa and Huwaiuisa, the sons of Mas'ud came to the Prophet and 'Abdur Rahman intended to talk, but the Prophet said (to him), "Let the eldest of you speak." as 'Abdur-Rahman was the youngest:. 'Abdur-Rahman kept silent and the other two spoke. The Prophet said, "If you swear as to who has committed the murder, you will have the right to take your right from the murderer." They said, "How should we swear if we did not witness the murder or see the murderer?" The Prophet said, "Then the Jews can clear themselves from the charge by taking Alaska (an oath taken by men that it was not they who committed the murder)." The!y said, "How should we believe in the oaths of infidels?" So, the Prophet himself paid the blood money (of 'Abdullah). (See Hadith No. 36 Vol. 9.)


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.399]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 399

Narrated ' Abdullah bin 'Abbas:

That Abu Sufyan bin Harb Informed him that Heraclius called him and the members of a caravan from Quraish who had gone to Sham as traders, during the truce which Allah's Apostle had concluded with Abu Sufyan and the Quraish infidels.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.400]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 400

Narrated Aisha:

Once the Prophet was bewitched so that he began to imagine that he had done a thing which in fact he had not done.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.401]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 401

Narrated Auf bin Mali:

I went to the Prophet during the Ghazwa of Tabuk while he was sitting in a leather tent. He said, "Count six signs that indicate the approach of the Hour: my death, the conquest of Jerusalem, a plague that will afflict you (and kill you in great numbers) as the plague that afflicts sheep, the increase of wealth to such an extent that even if one is given one hundred Dinars, he will not be satisfied; then an affliction which no Arab house will escape, and then a truce between you and Bani Al-Asfar (i.e. the Byzantines) who will betray you and attack you under eighty flags. Under each flag will be twelve thousand soldiers.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.402]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 402

Narrated Abu Huraira:

Abu Bakr, on the day of Nahr (i.e. slaughtering of animals for sacrifice), sent me in the company of others to make this announcement: "After this year, no pagan will be allowed to perform the Hajj, and none will be allowed to perform the Tawaf of the Ka'ba undressed." And the day of Al-Hajj-ul-Akbar is the day of Nahr, and it called Al-Akbar because the people call the 'Umra Al-Hajj-ul-Asghar (i.e. the minor Hajj). Abu Bakr threw back the pagans' covenant that year, and therefore, no pagan performed the Hajj in the year of Hajj-ul-Wada' of the Prophets.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.403]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 403

Narrated 'Abdullah bin 'Amr:

Allah's Apostle said, "Whoever has (the following) four characteristics will be a pure hypocrite: "If he speaks, he tells a lie; if he gives a promise, he breaks it, if he makes a covenant he proves treacherous; and if he quarrels, he behaves in a very imprudent evil insulting manner (unjust). And whoever has one of these characteristics, has one characteristic of a hypocrite, unless he gives it us."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.404]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 404

Narrated Ali:

We did not, write anything from the Prophet except the Quran and what is written in this paper, (wherein) the Prophet said, "Medina is a sanctuary from (the mountain of) Air to so and-so, therefore, whoever innovates (in it) an heresy or commits a sin, or gives shelter to such an innovator, will incur the Curse of Allah. the angels and all the people; and none of his compulsory or optional good deeds of worship will be accepted And the asylum granted by any Muslim Is to be secured by all the Muslims even if it is granted by one of the lowest social status among them. And whoever betrays a Muslim in this respect will incur the Curse of Allah, the angels and all the people, and his compulsory and optional good deeds of worship will not be accepted. And any freed slave will take as masters (befriends) people other than his own real masters who freed him without taking the permission of the latter, will incur the Curse of Allah, the angels and all the people, and his compulsory and optional good deeds of worship will not be accepted."

Narrated Said: Abu Huraira once said (to the people), "What will your state be when you can get no Dinar or Dirhan (i.e. taxes from the Dhimmis)?" on that someone asked him, "What makes you know that this state will take place, O Abu- Hu raira?" He said, "By Him in Whose Hands Abu Huraira's life is, I know it through the statement of the true and truly inspired one (i.e. the Prophet)." The people asked, "What does the Statement say?" He replied, "Allah and His Apostle's asylum granted to Dhimmis, i.e. non-Muslims living in a Muslim territory) will be outraged, and so Allah will make the hearts of these Dhimmis so daring that they will refuse to pay the Jizya they will be supposed to pay."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.405]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 405

Narrated Al-Amash:

I asked Abu Wail, "Did you take part in the battle of Siffin?" He said, 'Yes, and I heard Sahl bin Hunaif (when he was blamed for lack of zeal for fighting) saying, "You'd better blame your wrong opinions. I wish you had seen me on the day of Abu Jandal. If I had the courage to disobey the Prophet's orders, I would have done so. We had kept out swords on our necks and shoulders, for a thing which frightened us. And we did so, we found it easier for us, except in the case of the above battle (of ours).' "


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.406]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 406

Narrated Abu Wail:

We were in Siffin and Sahl bin Hunaif got up and said, "O people! Blame yourselves! We were with the Prophet on the day of Hudaibiya, and if we had been called to fight, we would have fought. But 'Umar bin Al Khatab came and said, 'O Allah's Apostle! Aren't we in the right and our opponents in the wrongs' Allah's Apostle said, 'Yes.' 'Umar said, 'Aren't our killed persons in Paradise and their's in Hell?' He said, 'Yes.' 'Umar said, 'Then why should we accept hard terms in matters concerning our religion? Shall we return before Allah judges between us and them?' Allah's Apostle said, 'O Ibn Al-Khattab! I am the Apostle of Allah and Allah will never degrade me. Then 'Umar went to Abu Bakr and told him the same as he had told the Prophet.

On that Abu Bakr said (to 'Umar). 'He is the Apostle of Allah and Allah will never degrade him.' Then Surat-al-Fath (i.e. Victory) was revealed and Allah's Apostle recited it to the end in front of 'Umar. On that 'Umar asked, 'O Allah's Apostle! Was it (i.e. the Hudaibiya Treaty) a victory?' Allah's Apostle said, "Yes"


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.407]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 407

Narrated Asma 'bint Abi Bakr:

During the period of the peace treaty of Quraish with Allah's Apostle, my mother, accompanied by her father, came to visit me, and she was a pagan. I consulted Allah's Apostle, "O Allah's Apostle! My mother has come to me and she desires to receive a reward from me, shall I keep good relation with her?" He said, "Yes, keep good relation with her."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.408]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 408

Narrated Al-Bara:

When the Prophet intended to perform the 'Umra he sent a person to the people of Mecca asking their permission to enter Mecca. They stipulated that he would not stay for more than three days and would not enter it except with sheathed arms and would not preach (Islam) to any of them. So Ali bin Abi-Talib started writing the treaty between them. He wrote, "This is what Muhammad, Apostle of Allah has agreed to." The (Meccans) said, "If we knew that you (Muhammad) are the Apostle of Allah, then we would not have prevented you and would have followed you. But write, 'This is what Muhammad bin 'Abdullah has agreed to..' " On that Allah's Apostle said, "By Allah, I am Muhammad bin 'Abdullah, and, by Allah, I am Apostle of 'Allah." Allah's Apostle used not to write; so he asked 'Ali to erase the expression of Apostle of Allah. On that 'Ali said, "By Allah I will never erase it." Allah's Apostle said (to 'Ali), "Let me see the paper." When 'Ali showed him the paper, the Prophet erased the expression with his own hand. When Allah's Apostle had entered Mecca and three days had elapsed, the Meccans came to 'Ali and said, "Let your friend (i.e. the Prophet) quit Mecca." Ali informed Allah's Apostle about it and Allah's Apostle said, "Yes," and then he departed.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.409]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 409

Narrated 'Abdullah:

While the Prophet was in the state of prostration, surrounded by a group of people from Quraish pagans. 'Uqba bin Abi Mu'ait came and brought the intestines of a camel and threw them on the back of the Prophet . The Prophet did not raise his head from prostration till Fatima (i.e. his daughter) came and removed those intestines from his back, and invoked evil on whoever had done (the evil deed). The Prophet said, "O Allah! Destroy the chiefs of Quraish, O Allah! Destroy Abu Jahl bin Hisham, 'Utba bin Rabi'a, Shaiba bin Rabi'a. 'Uqba bin Abi Mu'ait 'Umaiya bin Khalaf (or Ubai bin Kalaf)." Later on I saw all of them killed during the battle of Badr and their bodies were thrown into a well except the body of Umaiya or Ubai, because he was a fat person, and when he was pulled, the parts of his body got separated before he was thrown into the well.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.410]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 410

Narrated Anas:

The Prophet said, ''Every betrayer will have a flag on the Day of Resurrection" One of the two sub-narrators said that the flag would be fixed, and the other said that it would be shown on the Day of Resurrection, so that the betrayer might be recognized by it.


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.411]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 411

Narrated Ibn Umar:

The Prophet said, "Every betrayer will have a flag which will be fixed on the Day of Resurrection, and the flag's prominence will be made in order to show the betrayal he committed."


Bukhari :: One-fifth of Booty to the Cause of Allah (Khumus) :: [4.53.412]

One-fifth of Booty to the Cause of Allah (Khumus)

Bukhari :: Book 4 :: Volume 53 :: Hadith 412

Narrated Ibn 'Abbas:

Allah's Apostle said on the day of the conquest of Mecca, "There is no migration now, but there is Jihad (i.e.. holy battle) and good intentions. And when you are called for Jihad, you should come out at once" Allah's Apostle also said, on the day of the conquest of Mecca, "Allah has made this town a sanctuary since the day He created the Heavens and the Earth. So, it is a sanctuary by Allah's Decree till the Day of Resurrection. Fighting in it was not legal for anyone before me, and it was made legal for me only for an hour by daytime. So, it (i.e. Mecca) is a sanctuary by Allah's Decree till the Day of Resurrection. Its thorny bushes should not be cut, and its game should not be chased, its fallen property (i.e. Luqata) should not be picked up except by one who will announce it publicly; and its grass should not be uprooted," On that Al-'Abbas said, "O Allah's Apostle! Except the Idhkhir, because it is used by the goldsmiths and by the people for their houses." On that the Prophet said, "Except the Idhkhir."


Bukhari :: Beginning of Creation :: [4.54.413]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 413

Narrated 'Imran bin Husain:

Some people of Bani Tamim came to the Prophet and he said (to them), "O Bani Tamim! rejoice with glad tidings." They said, "You have given us glad tidings, now give us something." On hearing that the color of his face changed then the people of Yemen came to him and he said, "O people of Yemen ! Accept the good tidings, as Bani Tamim has refused them." The Yemenites said, "We accept them. Then the Prophet started taking about the beginning of creation and about Allah's Throne. In the mean time a man came saying, "O 'Imran! Your she-camel has run away!'' (I got up and went away), but l wish I had not left that place (for I missed what Allah's Apostle had said).


Bukhari :: Beginning of Creation :: [4.54.414]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 414

Narrated Imran bin Husain:

I went to the Prophet and tied my she-camel at the gate. The people of Bani Tamim came to the Prophet who said "O Bani Tamim! Accept the good tidings." They said twice, 'You have given us the good tidings, now give us something" Then some Yemenites came to him and he said, "Accept the good tidings, O people of Yemem, for Bani Tamim refused them." They said, "We accept it, O Allah's Apostle! We have come to ask you about this matter (i.e. the start of creations)." He said, "First of all, there was nothing but Allah, and (then He created His Throne). His throne was over the water, and He wrote everything in the Book (in the Heaven) and created the Heavens and the Earth." Then a man shouted, "O Ibn Husain! Your she-camel has gone away!" So, I went away and could not see the she-camel because of the mirage. By Allah, I wished I had left that she-camel (but not that gathering).

Narrated 'Umar: One day the Prophet stood up amongst us for a long period and informed us about the beginning of creation (and talked about everything in detail) till he mentioned how the people of Paradise will enter their places and the people of Hell will enter their places. Some remembered what he had said, and some forgot it.


Bukhari :: Beginning of Creation :: [4.54.415]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 415

Narrated Abu Huraira:

Allah's Apostle said, "Allah the Most Superior said, "The son of Adam slights Me, and he should not slight Me, and he disbelieves in Me, and he ought not to do so. As for his slighting Me, it is that he says that I have a son; and his disbelief in Me is his statement that I shall not recreate him as I have created (him) before."


Bukhari :: Beginning of Creation :: [4.54.416]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 416

Narrated Abu Huraira:

Allah's Apostle said, "When Allah completed the creation, He wrote in His Book which is with Him on His Throne, "My Mercy overpowers My Anger."


Bukhari :: Beginning of Creation :: [4.54.417]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 417

Narrated Muhammad bin Ibrahim bin Al-Harith:

from Abu Salama bin 'Abdur-Rahman who had a dispute with some people on a piece of land, and so he went to 'Aisha and told her about it. She said, "O Abu Salama, avoid the land, for Allah's Apostle said, 'Any person who takes even a span of land unjustly, his neck shall be encircled with it down seven earths.' "


Bukhari :: Beginning of Creation :: [4.54.418]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 418

Narrated Salim's father:

The Prophet said, "Any person who takes a piece of land unjustly will sink down the seven earths on the Day of Resurrection."


Bukhari :: Beginning of Creation :: [4.54.419]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 419

Narrated Abu Bakra:

The Prophet said. "(The division of time has turned to its original form which was current when Allah created the Heavens and the Earths. The year is of twelve months, out of which four months are sacred: Three are in succession Dhul-Qa' da, Dhul-Hijja and Muharram, and (the fourth is) Rajab of (the tribe of) Mudar which comes between Jumadi-ath-Thaniyah and Sha ban."


Bukhari :: Beginning of Creation :: [4.54.420]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 420

Narrated Said bin Zaid bin Amr bin Nufail:

That Arwa sued him before Marwan for a right, which she claimed, he had deprived her of. On that Said said, "How should I deprive her of her right? I testify that I heard Allah's Apostle saying, 'If anyone takes a span of land unjustly, his neck will be encircled with it down seven earths on the Day of Resurrection."


Bukhari :: Beginning of Creation :: [4.54.421]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 421

Narrated Abu Dhar:

The Prophet asked me at sunset, "Do you know where the sun goes (at the time of sunset)?" I replied, "Allah and His Apostle know better." He said, "It goes (i.e. travels) till it prostrates Itself underneath the Throne and takes the permission to rise again, and it is permitted and then (a time will come when) it will be about to prostrate itself but its prostration will not be accepted, and it will ask permission to go on its course but it will not be permitted, but it will be ordered to return whence it has come and so it will rise in the west. And that is the interpretation of the Statement of Allah: "And the sun Runs its fixed course For a term (decreed). that is The Decree of (Allah) The Exalted in Might, The All-Knowing." (36.38)


Bukhari :: Beginning of Creation :: [4.54.422]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 422

Narrated Abu Huraira:

The Prophet said, "The sun and the moon will be folded up (deprived of their light) on the Day of Resurrection."


Bukhari :: Beginning of Creation :: [4.54.423]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 423

Narrated 'Abdullah bin 'Umar:

The Prophet said, "The sun and the moon do not eclipse because of someone's death or wife (i.e. birth), but they are two signs amongst the Signs of Allah. So, if you see them (i.e. eclipse) offer the Prayer (of eclipse)."


Bukhari :: Beginning of Creation :: [4.54.424]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 424

Narrated 'Abdullah bin 'Abbas:

The Prophet said, "The sun and the moon are two signs amongst the Signs of Allah. They do not eclipse because of someone's death or life. So, if you see them (i.e. eclipse), celebrate the Praises of Allah (i.e. pray)."


Bukhari :: Beginning of Creation :: [4.54.425]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 425

Narrated 'Aisha:

On the day of a solar eclipse, Allah's Apostle stood up (to offer the eclipse prayer). He recited Takbir, recited a long recitation (of Holy Verses), bowed a long bowing, and then he raised h is head saying. "Allah hears him who sends his praises to Him." Then he stayed standing, recited a long recitation again, but shorter than the former, bowed a long bowing, but shorter than the first, performed a long prostration and then performed the second Rak'a in the same way as he had done the first. By the time he had finished his prayer with Taslim, the solar eclipse had been over. Then he addressed the people referring to the solar and lunar eclipses saying, "These are two signs amongst the Signs of Allah, and they do not eclipse because of anyone's death or life. So, if you see them, hasten for the Prayer."


Bukhari :: Beginning of Creation :: [4.54.426]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 426

Narrated Abu Mas'ud:

The Prophet said, "the sun and the moon do not eclipse because of the death or life of someone, but they are two signs amongst the Signs of Allah. So, if you see them, offer the Prayer (of eclipse)."


Bukhari :: Beginning of Creation :: [4.54.427]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 427

Narrated Ibn 'Abbas:

The Prophet said, "I have been made victorious with the Saba (i.e. easterly wind) and the people of 'Ad were destroyed with the Dabur (i.e. westerly wind) ."


Bukhari :: Beginning of Creation :: [4.54.428]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 428

Narrated Ata:

'Aisha said If the Prophet saw a cloud In the sky, he would walk to and fro in agitation, go out and come in, and the color of his face would change, and if it rained, he would feel relaxed." So 'Aisha knew that state of his. So the Prophet said, I don't know (am afraid), it may be similar to what happened to some people referred to in the Holy Quran in the following Verse: -- "Then when they saw it as a dense cloud coming towards their valleys, they said, 'This is a cloud bringing us rain!' Nay, but, it is that (torment) which you were asking to be hastened a wind wherein is severe torment." (46.24)


Bukhari :: Beginning of Creation :: [4.54.429]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 429

Narrated Malik bin Sasaa:

The Prophet said, "While I was at the House in a state midway between sleep and wakefulness, (an angel recognized me) as the man lying between two men. A golden tray full of wisdom and belief was brought to me and my body was cut open from the throat to the lower part of the abdomen and then my abdomen was washed with Zam-zam water and (my heart was) filled with wisdom and belief. Al-Buraq, a white animal, smaller than a mule and bigger than a donkey was brought to me and I set out with Gabriel. When I reached the nearest heaven. Gabriel said to the heaven gate-keeper, 'Open the gate.' The gatekeeper asked, 'Who is it?' He said, 'Gabriel.' The gate-keeper,' Who is accompanying you?' Gabriel said, 'Muhammad.' The gate-keeper said, 'Has he been called?' Gabriel said, 'Yes.' Then it was said, 'He is welcomed. What a wonderful visit his is!' Then I met Adam and greeted him and he said, 'You are welcomed O son and a Prophet.' Then we ascended to the second heaven. It was asked, 'Who is it?' Gabriel said, 'Gabriel.' It was said, 'Who is with you?' He said, 'Muhammad' It was asked, 'Has he been sent for?' He said, 'Yes.' It was said, 'He is welcomed. What a wonderful visit his is!" Then I met Jesus and Yahya (John) who said, 'You are welcomed, O brother and a Prophet.' Then we ascended to the third heaven. It was asked, 'Who is it?' Gabriel said, 'Gabriel.' It was asked, 'Who is with you? Gabriel said, 'Muhammad.' It was asked, 'Has he been sent for?' 'Yes,' said Gabriel. 'He is welcomed. What a wonderful visit his is!' (The Prophet added:). There I met Joseph and greeted him, and he replied, 'You are welcomed, O brother and a Prophet!' Then we ascended to the 4th heaven and again the same questions and answers were exchanged as in the previous heavens. There I met Idris and greeted him. He said, 'You are welcomed O brother and Prophet.' Then we ascended to the 5th heaven and again the same questions and answers were exchanged as in previous heavens. there I met and greeted Aaron who said, 'You are welcomed O brother and a Prophet". Then we ascended to the 6th heaven and again the same questions and answers were exchanged as in the previous heavens. There I met and greeted Moses who said, 'You are welcomed O brother and. a Prophet.' When I proceeded on, he started weeping and on being asked why he was weeping, he said, 'O Lord! Followers of this youth who was sent after me will enter Paradise in greater number than my followers.' Then we ascended to the seventh heaven and again the same questions and answers were exchanged as in the previous heavens. There I met and greeted Abraham who said, 'You are welcomed o son and a Prophet.' Then I was shown Al-Bait-al-Ma'mur (i.e. Allah's House). I asked Gabriel about it and he said, This is Al Bait-ul-Ma'mur where 70,000 angels perform prayers daily and when they leave they never return to it (but always a fresh batch comes into it daily).' Then I was shown Sidrat-ul-Muntaha (i.e. a tree in the seventh heaven) and I saw its Nabk fruits which resembled the clay jugs of Hajr (i.e. a town in Arabia), and its leaves were like the ears of elephants, and four rivers originated at its root, two of them were apparent and two were hidden. I asked Gabriel about those rivers and he said, 'The two hidden rivers are in Paradise, and the apparent ones are the Nile and the Euphrates.' Then fifty prayers were enjoined on me. I descended till I met Moses who asked me, 'What have you done?' I said, 'Fifty prayers have been enjoined on me.' He said, 'I know the people better than you, because I had the hardest experience to bring Bani Israel to obedience. Your followers cannot put up with such obligation. So, return to your Lord and request Him (to reduce the number of prayers.' I returned and requested Allah (for reduction) and He made it forty. I returned and (met Moses) and had a similar discussion, and then returned again to Allah for reduction and He made it thirty, then twenty, then ten, and then I came to Moses who repeated the same advice. Ultimately Allah reduced it to five. When I came to Moses again, he said, 'What have you done?' I said, 'Allah has made it five only.' He repeated the same advice but I said that I surrendered (to Allah's Final Order)'" Allah's Apostle was addressed by Allah, "I have decreed My Obligation and have reduced the burden on My slaves, and I shall reward a single good deed as if it were ten good deeds."


Bukhari :: Beginning of Creation :: [4.54.430]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 430

Narrated 'Abdullah bin Mus'ud:

Allah's Apostle, the true and truly inspired said, "(The matter of the Creation of) a human being is put together in the womb of the mother in forty days, and then he becomes a clot of thick blood for a similar period, and then a piece of flesh for a similar period. Then Allah sends an angel who is ordered to write four things. He is ordered to write down his (i.e. the new creature's) deeds, his livelihood, his (date of) death, and whether he will be blessed or wretched (in religion). Then the soul is breathed into him. So, a man amongst you may do (good deeds till there is only a cubit between him and Paradise and then what has been written for him decides his behavior and he starts doing (evil) deeds characteristic of the people of the (Hell) Fire. And similarly a man amongst you may do (evil) deeds till there is only a cubit between him and the (Hell) Fire, and then what has been written for him decides his behavior, and he starts doing deeds characteristic of the people of Paradise."


Bukhari :: Beginning of Creation :: [4.54.431]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 431

Narrated Abu Huraira:

The Prophet said, "If Allah loves a person, He calls Gabriel saying, 'Allah loves so and-so; O Gabriel! Love him.' Gabriel would love him and make an announcement amongst the inhabitants of the Heaven. 'Allah loves so-and-so, therefore you should love him also,' and so all the inhabitants of the Heaven would love him, and then he is granted the pleasure of the people on the earth."


Bukhari :: Beginning of Creation :: [4.54.432]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 432

Narrated 'Aisha:

I heard Allah's Apostle saying, "The angels descend, the clouds and mention this or that matter decreed in the Heaven. The devils listen stealthily to such a matter, come down to inspire the soothsayers with it, and the latter would add to it one-hundred lies of their own."


Bukhari :: Beginning of Creation :: [4.54.433]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 433

Narrated Abu Huraira:

The Prophet said, "On every Friday the angels take heir stand at every gate of the mosques to write the names of the people chronologically (i.e. according to the time of their arrival for the Friday prayer and when the Imam sits (on the pulpit) they fold up their scrolls and get ready to listen to the sermon."


Bukhari :: Beginning of Creation :: [4.54.434]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 434

Narrated Sa'id bin Al-Musaiyab:

'Umar came to the Mosque while Hassan was reciting a poem. ('Umar disapproved of that). On that Hassan said, "I used to recite poetry in this very Mosque in the presence of one (i.e. the Prophet ) who was better than you." Then he turned towards Abu Huraira and said (to him), "I ask you by Allah, did you hear Allah's Apostle saying (to me), "Retort on my behalf. O Allah! Support him (i.e. Hassan) with the Holy Spirit?" Abu Huraira said, "Yes."


Bukhari :: Beginning of Creation :: [4.54.435]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 435

Narrated Al Bara:

The Prophet said to Hassan, "Lampoon them (i.e. the pagans) and Gabriel is with you."


Bukhari :: Beginning of Creation :: [4.54.436]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 436

Narrated Jarir:

as below (Hadith 437).


Bukhari :: Beginning of Creation :: [4.54.437]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 437

Narrated Humaid bin Hilal:

Anas bin Malik said, "As if I say a cloud of dust swirling up in the lane of Bani Ghanim." Musa added, "That was caused by the procession of Gabriel."


Bukhari :: Beginning of Creation :: [4.54.438]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 438

Narrated Aisha:

Al Harith bin Hisham asked the Prophet, "How does the divine inspiration come to you?" He replied, "In all these ways: The Angel sometimes comes to me with a voice which resembles the sound of a ringing bell, and when this state abandons me, I remember what the Angel has said, and this type of Divine Inspiration is the hardest on me; and sometimes the Angel comes to me in the shape of a man and talks to me, and I understand and remember what he says."


Bukhari :: Beginning of Creation :: [4.54.439]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 439

Narrated Abu Huraira:

I heard the Prophet saying, "Who ever spends a couple (of objects) in Allah's cause, will be called by the Gatekeepers of Paradise who will say, "O so-and-so, come on!" Abu Bakr said, "Such a person will never perish or be miserable' The Prophet said, "I hope you will be among such person."


Bukhari :: Beginning of Creation :: [4.54.440]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 440

Narrated Abu Salama:

'Aisha said that the Prophet said to her "O 'Aisha' This is Gabriel and he sends his (greetings) salutations to you." 'Aisha said, "Salutations (Greetings) to him, and Allah's Mercy and Blessings be on him," and addressing the Prophet she said, "You see what I don't see."


Bukhari :: Beginning of Creation :: [4.54.441]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 441

Narrated Ibn Abbas:

Allah's Apostle asked Gabriel, "Why don't you visit us more often than you do?" Then the following Holy Verse was revealed (in this respect):-- "And we (angels) descend not but by the order of your Lord. To Him belong what is before us and what is behind us, and what is between those two and your Lord was never forgetful." (19.64)


Bukhari :: Beginning of Creation :: [4.54.442]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 442

Narrated Ibn Abbas:

Allah's Apostle said, "Gabriel read the Qur'an to me in one way (i.e. dialect) and I continued asking him to read it in different ways till he read it in seven different ways."


Bukhari :: Beginning of Creation :: [4.54.443]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 443

Narrated Ibn 'Abbas:

Allah's Apostle was the most generous of all the people, and he used to be more generous in the month of Ramadan when Gabriel used to meet him. Gabriel used to meet him every night in Ramadan to study the Holy Quran carefully together. Allah's Apostle used to become more generous than the fast wind when he met Gabriel


Bukhari :: Beginning of Creation :: [4.54.444]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 444

Narrated Ibn Shihab:

Once Umar bin Abdul Aziz delayed the 'Asr prayer a little. 'Urwa said to him, "Gabriel descended and led the prayer in front of the Prophet " On that 'Umar said, "O Urwa! Be sure of what you say." "Urwa, "I heard Bashir bin Abi Masud narrating from Ibn Masud who heard Allah's Apostle saying, 'Gabriel descended and led me in prayer; and then prayed with him again, and then prayed with him again, and then prayed with him again, and then prayed with him again, counting with his fingers five prayers."


Bukhari :: Beginning of Creation :: [4.54.445]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 445

Narrated Abu Dhar:

The Prophet said, "Gabriel said to me, 'Whoever amongst your followers die without having worshipped others besides Allah, will enter Paradise (or will not enter the (Hell) Fire)." The Prophet asked. "Even if he has committed illegal sexual intercourse or theft?" He replied, "Even then."


Bukhari :: Beginning of Creation :: [4.54.446]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 446

Narrated Abu Huraira:

The Prophet said, "Angels keep on descending from and ascending to the Heaven in turn, some at night and some by daytime, and all of them assemble together at the time of the Fajr and 'Asr prayers. Then those who have stayed with you over-night, ascent unto Allah Who asks them, and He knows the answer better than they, "How have you left My slaves?" They reply, "We have left them praying as we found them praying." If anyone of you says "Amin" (during the Prayer at the end of the recitation of Surat-al-Faitiha), and the angels in Heaven say the same, and the two sayings coincide, all his past sins will be forgiven."


Bukhari :: Beginning of Creation :: [4.54.447]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 447

Narrated 'Aisha:

I stuffed for the Prophet a pillow decorated with pictures (of animals) which looked like a Namruqa (i.e. a small cushion). He came and stood among the people with excitement apparent on his face. I said, "O Allah's Apostle! What is wrong?" He said, "What is this pillow?" I said, "I have prepared this pillow for you, so that you may recline on it." He said, "Don't you know that angels do not enter a house wherein there are pictures; and whoever makes a picture will be punished on the Day of Resurrection and will be asked to give life to (what he has created)?"


Bukhari :: Beginning of Creation :: [4.54.448]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 448

Narrated Abu Talha:

I heard Allah's Apostle saying; "Angels (of Mercy) do not enter a house wherein there is a dog or a picture of a living creature (a human being or an animal)."


Bukhari :: Beginning of Creation :: [4.54.449]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 449

Narrated Busr bin Said:

That Zaid bin Khalid Al-Juhani narrated to him something in the presence of Said bin 'Ubaidullah Al-Khaulani who was brought up in the house of Maimuna the wife of the Prophet. Zaid narrated to them that Abu Talha said that the Prophet said, "The Angels (of Mercy) do not enter a house wherein there is a picture." Busr said, "Later on Zaid bin Khalid fell ill and we called on him. To our surprise we saw a curtain decorated with pictures in his house. I said to Ubaidullah Al-Khaulani, "Didn't he (i.e. Zaid) tell us about the (prohibition of) pictures?" He said, "But he excepted the embroidery on garments. Didn't you hear him?" I said, "No." He said, "Yes, he did."


Bukhari :: Beginning of Creation :: [4.54.450]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 450

Narrated Salim's father:

Once Gabriel promised the Prophet (that he would visit him, but Gabriel did not come) and later on he said, "We, angels, do not enter a house which contains a picture or a dog."


Bukhari :: Beginning of Creation :: [4.54.451]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 451

Narrated Abu Huraira:

Allah's Apostle said, "When the Imam, during the prayer, says, "Allah hears him who praises Him', say: 'O Allah! Our Lord! All the praises are for You/, for if the saying of anyone of you coincides with the saying of the angels, his past sins will be forgiven."


Bukhari :: Beginning of Creation :: [4.54.452]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 452

Narrated Abu Huraira:

The Prophet said, "As long as any-one of you is waiting for the prayer, he is considered to be praying actually, and the angels say, 'O Allah! Be merciful to him and forgive him', (and go on saying so) unless he leaves his place of praying or passes wind (i.e. breaks his ablution)."


Bukhari :: Beginning of Creation :: [4.54.453]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 453

Narrated Yali:

I heard the Prophet reciting the following Verse on the pulpit: "They will call: O Mali......' and Sufyan said that 'Abdullah recited it: 'They will call: O Mali..' (43.77)


Bukhari :: Beginning of Creation :: [4.54.454]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 454

Narrated 'Aisha:

That she asked the Prophet , 'Have you encountered a day harder than the day of the battle) of Uhud?" The Prophet replied, "Your tribes have troubled me a lot, and the worse trouble was the trouble on the day of 'Aqaba when I presented myself to Ibn 'Abd-Yalail bin 'Abd-Kulal and he did not respond to my demand. So I departed, overwhelmed with excessive sorrow, and proceeded on, and could not relax till I found myself at Qarnath-Tha-alib where I lifted my head towards the sky to see a cloud shading me unexpectedly. I looked up and saw Gabriel in it. He called me saying, 'Allah has heard your people's saying to you, and what they have replied back to you, Allah has sent the Angel of the Mountains to you so that you may order him to do whatever you wish to these people.' The Angel of the Mountains called and greeted me, and then said, "O Muhammad! Order what you wish. If you like, I will let Al-Akh-Shabain (i.e. two mountains) fall on them." The Prophet said, "No but I hope that Allah will let them beget children who will worship Allah Alone, and will worship None besides Him."


Bukhari :: Beginning of Creation :: [4.54.455]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 455

Narrated Abu Ishaq-Ash-Shaibani:

I asked Zir bin Hubaish regarding the Statement of Allah: "And was at a distance Of but two bow-lengths Or (even) nearer; So did (Allah) convey The Inspiration to His slave (Gabriel) and then he (Gabriel) Conveyed (that to Muhammad). (53.9-10) On that, Zir said, "Ibn Mas'ud informed us that the Prophet had seen Gabriel having 600 wings."


Bukhari :: Beginning of Creation :: [4.54.456]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 456

Narrated Abdullah:

Regarding the Verse: "Indeed he (Muhammad) did see. Of the Signs of his Lord, The Greatest!" (53.18) That the Prophet had seen a green carpet spread all over the horizon of the sky.


Bukhari :: Beginning of Creation :: [4.54.457]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 457

Narrated Aisha:

Whoever claimed that (the Prophet) Muhammad saw his Lord, is committing a great fault, for he only saw Gabriel in his genuine shape in which he was created covering the whole horizon.


Bukhari :: Beginning of Creation :: [4.54.458]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 458

Narrated Masruq:

I asked Aisha "What about His Statement:-- "Then he (Gabriel) approached And came closer, And was at a distance Of but two bow-lengths Or (even) nearer?" (53.8-9) She replied, "It was Gabriel who used to come to the Prophet in the figure of a man, but on that occasion, he came in his actual and real figure and (he was so huge) that he covered the whole horizon."


Bukhari :: Beginning of Creation :: [4.54.459]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 459

Narrated Samura:

The Prophet said, "Last night I saw (in a dream) two men coming to me. One of them said, "The person who kindles the fire is Malik, the gate-keeper of the (Hell) Fire, and I am Gabriel, and this is Michael."


Bukhari :: Beginning of Creation :: [4.54.460]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 460

Narrated Abu Huraira:

Allah's Apostle said, "If a husband calls his wife to his bed (i.e. to have sexual relation) and she refuses and causes him to sleep in anger, the angels will curse her till morning."


Bukhari :: Beginning of Creation :: [4.54.461]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 461

Narrated Jabir bin 'Abdullah:

that he heard the Prophet saying, "The Divine Inspiration was delayed for a short period but suddenly, as I was walking. I heard a voice in the sky, and when I looked up towards the sky, to my surprise, I saw the angel who had come to me in the Hira Cave, and he was sitting on a chair in between the sky and the earth. I was so frightened by him that I fell on the ground and came to my family and said (to them), 'Cover me! (with a blanket), cover me!' Then Allah sent the Revelation: "O, You wrapped up (In a blanket)! (Arise and warn! And your Lord magnify And keep pure your garments, And desert the idols." (74.1-5)


Bukhari :: Beginning of Creation :: [4.54.462]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 462

Narrated Ibn Abbas:

The Prophet said, "On the night of my Ascent to the Heaven, I saw Moses who was a tall brown curly-haired man as if he was one of the men of Shan'awa tribe, and I saw Jesus, a man of medium height and moderate complexion inclined to the red and white colors and of lank hair. I also saw Malik, the gate-keeper of the (Hell) Fire and Ad-Dajjal amongst the signs which Allah showed me." (The Prophet then recited the Holy Verse): "So be not you in doubt of meeting him' when you met Moses during the night of Mi'raj over the heavens" (32.23)

Narrated Anas and Abu Bakra: "The Prophet said, "The angels will guard Medina from Ad-Dajjal (who will not be able to enter the city of Medina)."


Bukhari :: Beginning of Creation :: [4.54.463]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 463

Narrated Abdullah bin 'Umar:

Allah's Apostle said, "When anyone of you dies, he will be shown his destination both in the morning and in the evening, and if he belongs to the people of Paradise, he will be shown his place in Paradise, and if he is from the people of Hell, he will be shown his place in Hell."


Bukhari :: Beginning of Creation :: [4.54.464]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 464

Narrated 'Imran bin Husain:

The Prophet said, "I looked at Paradise and found poor people forming the majority of its inhabitants; and I looked at Hell and saw that the majority of its inhabitants were women."


Bukhari :: Beginning of Creation :: [4.54.465]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 465

Narrated Abu Huraira:

While we were in the company of the Prophet, he said, "While I was asleep, I saw myself in Paradise and there I beheld a woman making ablution beside a palace, I asked, To whom does this palace belong? 'They said, To 'Umar bin Al-Khattab.' Then I remembered 'Umar's Ghaira (concerning women), and so I quickly went away from that palace." (When 'Umar heard this from the Prophet), he wept and said, "Do you think it is likely that I feel Ghaira because of you, O Allah's Apostle?"


Bukhari :: Beginning of Creation :: [4.54.466]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 466

Narrated 'Abdullah bin Qais Al-Ashari:

The Prophet said, "A tent (in Paradise) is like a hollow pearl which is thirty miles in height and on every corner of the tent the believer will have a family that cannot be seen by the others." (Narrated Abu Imran in another narration, "(The tent is) sixty miles (in height)")


Bukhari :: Beginning of Creation :: [4.54.467]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 467

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, "I have prepared for My Pious slaves things which have never been seen by an eye, or heard by an ear, or imagined by a human being." If you wish, you can recite this Verse from the Holy Quran:--"No soul knows what is kept hidden for them, of joy as a reward for what they used to do." (32.17)


Bukhari :: Beginning of Creation :: [4.54.468]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 468

Narrated Abu Huraira:

Allah's Apostle said, "The first group (of people) who will enter Paradise will be (glittering) like the moon when it is full. They will not spit or blow their noses or relieve nature. Their utensils will be of gold and their combs of gold and silver; in their centers the aloe wood will be used, and their sweat will smell like musk. Everyone of them will have two wives; the marrow of the bones of the wives' legs will be seen through the flesh out of excessive beauty. They ( i.e. the people of Paradise) will neither have differences nor hatred amongst themselves; their hearts will be as if one heart and they will be glorifying Allah in the morning and in the evening."


Bukhari :: Beginning of Creation :: [4.54.469]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 469

Narrated Abu Huraira:

Allah's Apostle said, "The first batch (of people) who will enter Paradise will be (glittering) like a full moon; and those who will enter next will be (glittering) like the brightest star. Their hearts will be as if the heart of a single man, for they will have no enmity amongst themselves, and everyone of them shall have two wives, each of whom will be so beautiful, pure and transparent that the marrow of the bones of their legs will be seen through the flesh. They will be glorifying Allah in the morning and evening, and will never fall ill, and they will neither blow their noses, nor spit. Their utensils will be of gold and silver, and their combs will be of gold, and the fuel used in their centers will be the aloes-wood, and their sweat will smell like musk."


Bukhari :: Beginning of Creation :: [4.54.470]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 470

Narrated Sahl bin Sad:

The Prophet said, "Verily! 70,000 or 700,000 of my followers will enter Paradise altogether; so that the first and the last amongst them will enter at the same time, and their faces will be glittering like the bright full moon."


Bukhari :: Beginning of Creation :: [4.54.471]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 471

Narrated Anas bin Malik:

A silken cloak was presented to the Prophet and he used to forbid the usage of silk (by men). When the people were fascinated by the cloak. he said, "By Allah in Whose Hands the life of Muhammad is, the handkerchiefs of Sad bin Mu'adh in Paradise are better than this."


Bukhari :: Beginning of Creation :: [4.54.472]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 472

Narrated Al-Bara bin Azib:

Allah's Apostle was given a silken garment, and its beauty and delicacy astonished the people. On that, Allah's Apostle said, "No doubt, the handkerchiefs of Sad bin Muadh in Paradise are better than this."


Bukhari :: Beginning of Creation :: [4.54.473]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 473

Narrated Sahl bin Sad Al-Saidi:

Allah's Apostle said, "A place in Paradise equal to the size of a lash is better than the whole world and whatever is in it."


Bukhari :: Beginning of Creation :: [4.54.474]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 474

Narrated Anas bin Malik:

The Prophet said, "There is a tree in Paradise (which is so big and huge that) if a rider travels in its shade for one hundred years, he would not be able to cross it."


Bukhari :: Beginning of Creation :: [4.54.475]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 475

Narrated Abu Huraira:

The Prophet said "There is a tree in Paradise (which is so big and huge that) a rider could travel in its shade for a hundred years. And if you wish, you can recite:--'In shade long extended..' (56. 30) and a place in Paradise equal to an arrow bow of one of you, is better than (the whole earth) on which the sun rises and sets."


Bukhari :: Beginning of Creation :: [4.54.476]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 476

Narrated Abu Huraira:

The Prophet said, "The first batch (of people) who will enter Paradise will be (glittering) like the full moon, and the batch next to them will be (glittering) like the most brilliant star in the sky. Their hearts will be as if the heart of a single man, for they will have neither enmity nor jealousy amongst themselves; everyone will have two wives from the houris, (who will be so beautiful, pure and transparent that) the marrow of the bones of their legs will be seen through the bones and the flesh."


Bukhari :: Beginning of Creation :: [4.54.477]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 477

Narrated Al-Bara (bin Azib):

The Prophet, after the death of his son Ibrahim, said, "There is a wet-nurse for him (i.e. Ibrahim) in Paradise."


Bukhari :: Beginning of Creation :: [4.54.478]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 478

Narrated Abu Said Al-Khudri:

The Prophet said, "The people of Paradise will look at the dwellers of the lofty mansions (i.e. a superior place in Paradise) in the same way as one looks at a brilliant star far away in the East or in the West on the horizon; all that is because of their superiority over one another (in rewards)." On that the people said, "O Allah's Apostle! Are these lofty mansions for the prophets which nobody else can reach? The Prophet replied," No! "By Allah in whose Hands my life is, these are for the men who believed in Allah and also believed in the Apostles."


Bukhari :: Beginning of Creation :: [4.54.479]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 479

Narrated Sahl bin Sad:

The Prophet said, "Paradise has eight gates, and one of them is called Ar-Raiyan through which none will enter but those who observe fasting." The Prophet also said, "If a person spends two different kinds of something (for Allah's Cause), he will be called from the gates of Paradise."


Bukhari :: Beginning of Creation :: [4.54.480]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 480

Narrated Abu Dhar:

While the Prophet was on a journey, he said (regarding the performance of the Zuhr prayer), "Wait till it (i.e. the weather) gets cooler." He said the same again till the shade of the hillocks extended. Then he said, "Delay the (Zuhr) Prayer till it gets cooler, for the severity of heat is from the increase in heat of Hell (fire)."


Bukhari :: Beginning of Creation :: [4.54.481]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 481

Narrated Abu Sad: The Prophet said, "Delay the (Zuhr) Prayer till it gets cooler, for t


Bukhari :: Beginning of Creation :: [4.54.482]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 482

Narrated Abu Huraira:

Allah's Apostle said, "The (Hell) Fire complained to its Lord saying, 'O my Lord! My different parts eat up each other.' So, He allowed it to take two breaths, one in the winter and the other in summer, and this is the reason for the severe heat and the bitter cold you find (in weather)."


Bukhari :: Beginning of Creation :: [4.54.483]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 483

Narrated Abu Jamra Ad-Dabi:

I used to sit with Ibn 'Abbas in Mecca. Once I had a fever and he said (to me), "Cool your fever with Zam-zam water, for Allah's Apostle said: 'It, (the Fever) is from the heat of the (Hell) Fire; so, cool it with water (or Zam-zam water)."


Bukhari :: Beginning of Creation :: [4.54.484]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 484

Narrated Rafi bin Khadij:

I heard the Prophet saying, "Fever is from the heat of the (Hell) Fire; so cool it with water."


Bukhari :: Beginning of Creation :: [4.54.485]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 485

Narrated Aisha:

The Prophet said, "Fever is from the heat of the (Hell) Fire, so cool it with water."


Bukhari :: Beginning of Creation :: [4.54.486]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 486

Narrated Ibn 'Umar:

The Prophet said, "Fever is from the heat of the (Hell) Fire; so abate fever with water."


Bukhari :: Beginning of Creation :: [4.54.487]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 487

Narrated Abu Huraira:

Allah's Apostle said, "Your (ordinary) fire is one of 70 parts of the (Hell) Fire." Someone asked, "O Allah's Apostle This (ordinary) fire would have been sufficient (to torture the unbelievers)," Allah's Apostle said, "The (Hell) Fire has 69 parts more than the ordinary (worldly) fire, each part is as hot as this (worldly) fire."


Bukhari :: Beginning of Creation :: [4.54.488]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 488

Narrated Yali:

That he heard the Prophet on the pulpit reciting:--

"They will cry: "O Malik!' (43.77) (Malik is the gate-keeper (angel) of the (Hell) Fire.)


Bukhari :: Beginning of Creation :: [4.54.489]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 489

Narrated Abu Wail:

Somebody said to Usama, "Will you go to so-and-so (i.e. 'Uthman) and talk to him (i.e. advise him regarding ruling the country)?" He said, "You see that I don't talk to him. Really I talk to (advise) him secretly without opening a gate (of affliction), for neither do I want to be the first to open it (i.e. rebellion), nor will I say to a man who is my ruler that he is the best of all the people after I have heard something from Allah s Apostle ." They said, What have you heard him saying? He said, "I have heard him saying, "A man will be brought on the Day of Resurrection and thrown in the (Hell) Fire, so that his intestines will come out, and he will go around like a donkey goes around a millstone. The people of (Hell) Fire will gather around him and say: O so-and-so! What is wrong with you? Didn't you use to order us to do good deeds and forbid us to do bad deeds? He will reply: Yes, I used to order you to do good deeds, but I did not do them myself, and I used to forbid you to do bad deeds, yet I used to do them myself."


Bukhari :: Beginning of Creation :: [4.54.490]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 490

Narrated 'Aisha:

Magic was worked on the Prophet so that he began to fancy that he was doing a thing which he was not actually doing. One day he invoked (Allah) for a long period and then said, "I feel that Allah has inspired me as how to cure myself. Two persons came to me (in my dream) and sat, one by my head and the other by my feet. One of them asked the other, "What is the ailment of this man?" The other replied, 'He has been bewitched" The first asked, 'Who has bewitched him?' The other replied, 'Lubaid bin Al-A'sam.' The first one asked, 'What material has he used?' The other replied, 'A comb, the hair gathered on it, and the outer skin of the pollen of the male date-palm.' The first asked, 'Where is that?' The other replied, 'It is in the well of Dharwan.' " So, the Prophet went out towards the well and then returned and said to me on his return, "Its date-palms (the date-palms near the well) are like the heads of the devils." I asked, "Did you take out those things with which the magic was worked?" He said, "No, for I have been cured by Allah and I am afraid that this action may spread evil amongst the people." Later on the well was filled up with earth.


Bukhari :: Beginning of Creation :: [4.54.491]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 491

Narrated Abu Huraira:

Allah's Apostle said, "During your sleep, Satan knots three knots at the back of the head of each of you, and he breathes the following words at each knot, 'The night is, long, so keep on sleeping,' If that person wakes up and celebrates the praises of Allah, then one knot is undone, and when he performs ablution the second knot is undone, and when he prays, all the knots are undone, and he gets up in the morning lively and gay, otherwise he gets up dull and gloomy. "


Bukhari :: Beginning of Creation :: [4.54.492]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 492

Narrated 'Abdullah:

It was mentioned before the Prophet that there was a man who slept the night till morning (after sunrise). The Prophet said, "He is a man in whose ears (or ear) Satan had urinated."


Bukhari :: Beginning of Creation :: [4.54.493]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 493

Narrated Ibn 'Abbas:

The Prophet said, "If anyone of you, when having sexual relation with his wife, say: 'In the name of Allah. O Allah! Protect us from Satan and prevent Satan from approaching our offspring you are going to give us,' and if he begets a child (as a result of that relation) Satan will not harm it."


Bukhari :: Beginning of Creation :: [4.54.494]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 494

Narrated Ibn Umar:

Allah's Apostle said, "When the (upper) edge of the sun appears (in the morning), don't perform a prayer till the sun appears in full, and when the lower edge of the sun sets, don't perform a prayer till it sets completely. And you should not seek to pray at sunrise or sunset for the sun rises between two sides of the head of the devil (or Satan)."


Bukhari :: Beginning of Creation :: [4.54.495]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 495

Narrated Abu Said Al-Khudri:

The Prophet said, "If while you are praying, somebody intends to pass in front of you, prevent him; and should he insist, prevent him again; and if he insists again, fight with him (i.e. prevent him violently e.g. pushing him violently), because such a person is (like) a devil."

Narrated Muhammad bin Sirin: Abu Huraira said, "Allah's Apostle put me in charge of the Zakat of Ramadan (i.e. Zakat-ul-Fitr). Someone came to me and started scooping some of the foodstuff of (Zakat) with both hands. I caught him and told him that I would take him to Allah's Apostle." Then Abu Huraira told the whole narration and added "He (i.e. the thief) said, 'Whenever you go to your bed, recite the Verse of "Al-Kursi" (2.255) for then a guardian from Allah will be guarding you, and Satan will not approach you till dawn.' " On that the Prophet said, "He told you the truth, though he is a liar, and he (the thief) himself was the Satan."


Bukhari :: Beginning of Creation :: [4.54.496]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 496

Narrated Abu Huraira:

Allah's Apostle said, "Satan comes to one of you and says, 'Who created so-and-so? 'till he says, 'Who has created your Lord?' So, when he inspires such a question, one should seek refuge with Allah and give up such thoughts."


Bukhari :: Beginning of Creation :: [4.54.497]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 497

Narrated Abu Huraira:

Allah's Apostle said, "When the month of Ramadan comes, the gates of Paradise are opened and the gates of the (Hell) Fire are closed, and the devils are chained."


Bukhari :: Beginning of Creation :: [4.54.498]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 498

Narrated Ubai bin Kab:

That he heard Allah's Apostle saying, "(The prophet) Moses said to his attendant, "Bring us our early meal' (18.62). The latter said, 'Did you remember when we betook ourselves to the rock? I indeed forgot the fish and none but Satan made me forget to remember it." (18.63) Moses did not feel tired till he had crossed the place which Allah ordered him to go to."


Bukhari :: Beginning of Creation :: [4.54.499]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 499

Narrated 'Abdullah bin 'Umar:

I saw Allah's Apostle pointing towards the east saying, "Lo! Afflictions will verily emerge hence; afflictions will verily emerge hence where the (side of the head of) Satan appears."


Bukhari :: Beginning of Creation :: [4.54.500]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 500

Narrated Jabir:

The Prophet said, "When nightfalls, then keep your children close to you, for the devil spread out then. An hour later you can let them free; and close the gates of your house (at night), and mention Allah's Name thereupon, and cover your utensils, and mention Allah's Name thereupon, (and if you don't have something to cover your utensil) you may put across it something (e.g. a piece of wood etc.)."


Bukhari :: Beginning of Creation :: [4.54.501]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 501

Narrated Safiya bint Huyay:

While Allah's Apostle was in Itikaf, I called on him at night and having had a talk with him, I got up to depart. He got up also to accompany me to my dwelling place, which was then in the house of Usama bin Zaid. Two Ansari men passed by, and when they saw the Prophet they hastened away. The Prophet said (to them). "Don't hurry! It is Safiya, the daughter of Huyay (i.e. my wife)." They said, "Glorified be Allah! O Allah's Apostle! (How dare we suspect you?)" He said, "Satan circulates in the human mind as blood circulates in it, and I was afraid that Satan might throw an evil thought (or something) into your hearts."


Bukhari :: Beginning of Creation :: [4.54.502]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 502

Narrated Sulaiman bin Surd:

While I was sitting in the company of the Prophet, two men abused each other and the face of one of them became red with anger, and his jugular veins swelled (i.e. he became furious). On that the Prophet said, "I know a word, the saying of which will cause him to relax, if he does say it. If he says: 'I seek Refuge with Allah from Satan.' then all is anger will go away." Some body said to him, "The Prophet has said, 'Seek refuge with Allah from Satan."' The angry man said, "Am I mad?"


Bukhari :: Beginning of Creation :: [4.54.503]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 503

Narrated Ibn 'Abbas:

The Prophet said, "If anyone of you, on having sexual relation with his wife, says: 'O Allah! Protect me from Satan, and prevent Satan from approaching the offspring you are going to give me,' and if it happens that the lady conceives a child, Satan will neither harm it nor be given power over it."


Bukhari :: Beginning of Creation :: [4.54.504]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 504

Narrated Abu Huraira:

The Prophet offered a prayer, and (after finishing) he said, "Satan came in front of me trying persistently to divert my attention from the prayer, but Allah gave me the strength to over-power him."


Bukhari :: Beginning of Creation :: [4.54.505]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 505

Narrated Abu Huraira:

The Prophet said, "When the call for the prayer is pronounced, Satan takes to his heels, passing wind with noise, When the call for the prayer is finished, he comes back. And when the Iqama is pronounced, he again takes to his heels, and after its completion, he returns again to interfere between the (praying) person and his heart, saying to him. 'Remember this or that thing.' till the person forgets whether he has offered three or four Rakat: so if one forgets whether he has prayed three or four Rak'a-t, he should perform two prostrations of Sahu (i.e. forgetfulness)."


Bukhari :: Beginning of Creation :: [4.54.506]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 506

Narrated Abu Huraira:

The Prophet said, "When any human being is born. Satan touches him at both sides of the body with his two fingers, except Jesus, the son of Mary, whom Satan tried to touch but failed, for he touched the placenta-cover instead."


Bukhari :: Beginning of Creation :: [4.54.507]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 507

Narrated Alqama:

I went to Sham (and asked. "Who is here?"), The people said, "Abu Ad-Darda." Abu Darda said, "Is the person whom Allah has protected against Satan, (as Allah's Apostle said) amongst you". The sub-narrator, Mughira said that the person who was given Allah's Refuge through the tongue of the Prophet was 'Ammar (bin Yasir).


Bukhari :: Beginning of Creation :: [4.54.508]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 508

Narrated 'Aisha:

The Prophet said, "While the angels talk amidst the clouds about things that are going to happen on earth, the devils hear a word of what they say and pour it in the ears of a soothsayer as one pours something in a bottle, and they add one hundred lies to that (one word)."


Bukhari :: Beginning of Creation :: [4.54.509]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 509

Narrated Abu Huraira:

The Prophet said, "Yawning is from Satan and if anyone of you yawns, he should check his yawning as much as possible, for if anyone of you (during the act of yawning) should say: 'Ha', Satan will laugh at him."


Bukhari :: Beginning of Creation :: [4.54.510]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 510

Narrated 'Aisha:

On the day (of the battle) of Uhud when the pagans were defeated, Satan shouted, "O slaves of Allah! Beware of the forces at your back," and on that the Muslims of the front files fought with the Muslims of the back files (thinking they were pagans). Hudhaifa looked back to see his father "Al-Yaman," (being attacked by the Muslims). He shouted, "O Allah's Slaves! My father! My father!" By Allah, they did not stop till they killed him. Hudhaifa said, "May Allah forgive you." 'Urwa said that Hudhaifa continued to do good (invoking Allah to forgive the killer of his father till he met Allah (i.e. died).


Bukhari :: Beginning of Creation :: [4.54.511]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 511

Narrated 'Aisha:

I asked the Prophet about one's looking here and there during the prayer. He replied, "It is what Satan steals from the prayer of any one of you."


Bukhari :: Beginning of Creation :: [4.54.512]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 512

Narrated Abu Qatada:

as below i.e. Hadith No. 513)


Bukhari :: Beginning of Creation :: [4.54.513]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 513

Narrated Abu Qatada:

The Prophet said, "A good dream is from Allah, and a bad or evil dream is from Satan; so if anyone of you has a bad dream of which he gets afraid, he should spit on his left side and should seek Refuge with Allah from its evil, for then it will not harm him."


Bukhari :: Beginning of Creation :: [4.54.514]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 514

Narrated Abu Huraira:

Allah's Apostle said, "If one says one-hundred times in one day: "None has the right to be worshipped but Allah, the Alone Who has no partners, to Him belongs Dominion and to Him belong all the Praises, and He has power over all things (i.e. Omnipotent)", one will get the reward of manumitting ten slaves, and one-hundred good deeds will be written in his account, and one-hundred bad deeds will be wiped off or erased from his account, and on that day he will be protected from the morning till evening from Satan, and nobody will be superior to him except one who has done more than that which he has done."


Bukhari :: Beginning of Creation :: [4.54.515]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 515

Narrated Sad bin Abi Waqqas:

Once Umar asked the leave to see Allah's Apostle in whose company there were some Quraishi women who were talking to him and asking him for more financial support raising their voices. When 'Umar asked permission to enter the women got up (quickly) hurrying to screen themselves. When Allah's Apostle admitted 'Umar, Allah's Apostle was smiling, 'Umar asked, "O Allah's Apostle! May Allah keep you gay always." Allah's Apostle said, "I am astonished at these women who were with me. As soon as they heard your voice, they hastened to screen themselves." 'Umar said, "O Allah's Apostle! You have more right to be feared by them." Then he addressed (those women) saying, "O enemies of your own souls! Do you fear me and not Allah's Apostle ?" They replied. "Yes, for you are a fearful and fierce man as compared with Allah's Apostle." On that Allah's Apostle said (to 'Umar), "By Him in Whose Hands my life is, whenever Satan sees you taking a path, he follows a path other than yours."


Bukhari :: Beginning of Creation :: [4.54.516]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 516

Narrated Abu Huraira:

The Prophet said, "If anyone of you rouses from sleep and performs the ablution, he should wash his nose by putting water in it and then blowing it out thrice, because Satan has stayed in the upper part of his nose all the night."


Bukhari :: Beginning of Creation :: [4.54.517]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 517

Narrated Abdur-Rahman bin Abdullah bin Abdur-Rahman bin Abi Sasaa Ansari:

That Abu Said Al-Khudri said to his father. "I see you are fond of sheep and the desert, so when you want to pronounce the Adhan, raise your voice with it for whoever will hear the Adhan whether a human being, or a Jinn, or anything else, will bear witness, in favor on the Day of Resurrection." Abu Said added, "I have heard this from Allah's Apostle ."


Bukhari :: Beginning of Creation :: [4.54.518]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 518

Narrated Ibn Umar:

That he heard the Prophet delivering a sermon on the pulpit saying, "Kill snakes and kill Dhu-at-Tufyatain (i.e. a snake with two white lines on its back) and ALBATROSS (i.e. a snake with short or mutilated tail) for they destroy the sight of one's eyes and bring about abortion." ('Abdullah bin 'Umar further added): Once while I was chasing a snake in order, to kill it, Abu Lubaba called me saying: "Don't kill it," I said. "Allah's Apostle ordered us to kill snakes." He said, "But later on he prohibited the killing of snakes living in the houses." (Az-Zubri said. "Such snakes are called Al-Awamir.")


Bukhari :: Beginning of Creation :: [4.54.519]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 519

Narrated Abu Said al-Khudri:

Allah's Apostle said, "There will come a time when the best property of a man will be sheep which he will graze on the tops of mountains and the places where rain falls (i.e. pastures) escaping to protect his religion from afflictions."


Bukhari :: Beginning of Creation :: [4.54.520]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 520

Narrated Abu Huraira:

Allah's Apostle said, "The main source of disbelief is in the east. Pride and arrogance are characteristics of the owners of horses and camels, and those bedouins who are busy with their camels and pay no attention to Religion; while modesty and gentleness are the characteristics of the owners of sheep."


Bukhari :: Beginning of Creation :: [4.54.521]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 521

Narrated 'Uqba bin 'Umar and Abu Mas'ud:

Allah's Apostle pointed with his hand towards Yemen and said, "True Belief is Yemenite yonder (i.e. the Yemenite, had True Belief and embraced Islam readily), but sternness and mercilessness are the qualities of those who are busy with their camels and pay no attention to the Religion where the two sides of the head of Satan will appear. Such qualities belong to the tribe of Rabi'a and Mudar."


Bukhari :: Beginning of Creation :: [4.54.522]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 522

Narrated Abu Huraira:

The Prophet said, "When you hear the crowing of cocks, ask for Allah's Blessings for (their crowing indicates that) they have seen an angel. And when you hear the braying of donkeys, seek Refuge with Allah from Satan for (their braying indicates) that they have seen a Satan."


Bukhari :: Beginning of Creation :: [4.54.523]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 523

Narrated Jabir bin Abdullah:


Bukhari :: Beginning of Creation :: [4.54.524]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 524

Narrated Abu Huraira:

The Prophet said, "A group of Israelites were lost. Nobody knows what they did. But I do not see them except that they were cursed and changed into rats, for if you put the milk of a she-camel in front of a rat, it will not drink it, but if the milk of a sheep is put in front of it, it will drink it." I told this to Ka'b who asked me, "Did you hear it from the Prophet ?" I said, "Yes." Ka'b asked me the same question several times.; I said to Ka'b. "Do I read the Torah? (i.e. I tell you this from the Prophet.)"


Bukhari :: Beginning of Creation :: [4.54.525]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 525

Narrated Aisha:

The Prophet called the Salamander, a mischief-doer. I have not heard him ordering that it should be killed. Sad bin Waqqas claims that the Prophet ordered that it should be killed.


Bukhari :: Beginning of Creation :: [4.54.526]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 526

Narrated Um Sharik:

That the Prophet ordered her to kill Salamanders.


Bukhari :: Beginning of Creation :: [4.54.527]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 527

Narrated 'Aisha:

The Prophet said, "Kill the snake with two white lines on its back, for it blinds the on-looker and causes abortion."


Bukhari :: Beginning of Creation :: [4.54.528]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 528

Narrated 'Aisha:

The Prophet ordered that a short-tailed or mutilated-tailed snake (i.e. Abtar) should be killed, for it blinds the on-looker and causes abortion."


Bukhari :: Beginning of Creation :: [4.54.529]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 529

Narrated Abu Mulaika:

Ibn Umar used to kill snakes, but afterwards he forbade their killing and said, "Once the Prophet pulled down a wall and saw a cast-off skin of a snake in it. He said, 'Look for the snake. 'They found it and the Prophet said, "Kill it." For this reason I used to kill snakes. Later on I met Abu Lubaba who told me the Prophet said, 'Do not kill snakes except the short-tailed or mutilated-tailed snake with two white lines on its back, for it causes abortion and makes one blind. So kill it.' "


Bukhari :: Beginning of Creation :: [4.54.530]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 530

Narrated Nafi:

Ibn 'Umar used to kill snakes but when Abu Lubaba informed him that the Prophet had forbidden the killing of snakes living in houses, he gave up killing them.


Bukhari :: Beginning of Creation :: [4.54.531]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 531

Narrated 'Aisha:

The Prophet said, "Five kinds of animals are mischief-doers and can be killed even in the Sanctuary: They are the rat the scorpion, the kite, the crow and the rabid dog."


Bukhari :: Beginning of Creation :: [4.54.532]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 532

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "It is not sinful of a person in the state of Ihram to kill any of these five animals: The scorpion, the rat, the rabid dog, the crow and the kite."


Bukhari :: Beginning of Creation :: [4.54.533]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 533

Narrated Jabir bin 'Abdullah:

The Prophet said, "Cover your utensils and tie your water skins, and close your doors and keep your children close to you at night, as the Jinns spread out at such time and snatch things away. When you go to bed, put out your lights, for the mischief-doer (i.e. the rat) may drag away the wick of the candle and burn the dwellers of the house." Ata said, "The devils." (instead of the Jinns).


Bukhari :: Beginning of Creation :: [4.54.534]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 534

Narrated 'Abdullah:

Once we were in the company of Allah's Apostle in a cave. Surat-al-Mursalat (77) was revealed there, and we were learning it from Allah's Apostle . Suddenly a snake came out of its hole and we rushed towards it to kill it, but it hastened and entered its hole before we were able to catch it. Allah's Apostle said," It has been saved from your evil and you have been saved from its evil."


Bukhari :: Beginning of Creation :: [4.54.535]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 535

Narrated Ibn 'Umar: The Prophet said, "A woman entered the (Hell) Fire because of a cat which she had tied, neither giving it food nor setting it free to eat from the vermin of the earth."


Bukhari :: Beginning of Creation :: [4.54.536]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 536

Narrated Abu Huraira:

Allah's Apostle said, "Once while a prophet amongst the prophets was taking a rest underneath a tree, an ant bit him. He, therefore, ordered that his luggage be taken away from underneath that tree and then ordered that the dwelling place of the ants should be set on fire. Allah sent him a revelation:-- "Wouldn't it have been sufficient to burn a single ant? (that bit you): (See Page 162, chapter No. 153).


Bukhari :: Beginning of Creation :: [4.54.537]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 537

Narrated Abu Huraira:

The Prophet said "If a house fly falls in the drink of anyone of you, he should dip it (in the drink), for one of its wings has a disease and the other has the cure for the disease."


Bukhari :: Beginning of Creation :: [4.54.538]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 538

Narrated Abu Huraira:

Allah's Apostle said, "A prostitute was forgiven by Allah, because, passing by a panting dog near a well and seeing that the dog was about to die of thirst, she took off her shoe, and tying it with her head-cover she drew out some water for it. So, Allah forgave her because of that."


Bukhari :: Beginning of Creation :: [4.54.539]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 539

Narrated Abu Talha:

The Prophet said, "Angels do not enter a house witch has either a dog or a picture in it."


Bukhari :: Beginning of Creation :: [4.54.540]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 540

Narrated 'Abdullah bin 'Umar:

Allah's Apostle ordered that the dogs should be killed.


Bukhari :: Beginning of Creation :: [4.54.541]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 541

Narrated Abu Huraira:

Allah's Apostle said, "If somebody keeps a dog, he loses one Qirat (of the reward) of his good deeds everyday, except if he keeps it for the purpose of agriculture or for the protection of livestock. "


Bukhari :: Beginning of Creation :: [4.54.542]

Beginning of Creation

Bukhari :: Book 4 :: Volume 54 :: Hadith 542

Narrated Sufyan bin Abi Zuhair Ash-Shani:

That he heard Allah's Apostle saying, "If somebody keeps a dog that is neither used for farm work nor for guarding the livestock, he will lose one Qirat (of the reward) of his good deeds everyday."


Bukhari :: Prophets :: [4.55.543]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 543

Narrated Abu Huraira:

The Prophet said, "Allah created Adam, making him 60 cubits tall. When He created him, He said to him, "Go and greet that group of angels, and listen to their reply, for it will be your greeting (salutation) and the greeting (salutations of your offspring." So, Adam said (to the angels), As-Salamu Alaikum (i.e. Peace be upon you). The angels said, "As-salamu Alaika wa Rahmatu-l-lahi" (i.e. Peace and Allah's Mercy be upon you). Thus the angels added to Adam's salutation the expression, 'Wa Rahmatu-l-lahi,' Any person who will enter Paradise will resemble Adam (in appearance and figure). People have been decreasing in stature since Adam's creation.


Bukhari :: Prophets :: [4.55.544]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 544

Narrated Abu Huraira:

Allah's Apostle said, "The first group of people who will enter Paradise, will be glittering like the full moon and those who will follow them, will glitter like the most brilliant star in the sky. They will not urinate, relieve nature, spit, or have any nasal secretions. Their combs will be of gold, and their sweat will smell like musk. The aloes-wood will be used in their centers. Their wives will be houris. All of them will look alike and will resemble their father Adam (in statute), sixty cubits tall."


Bukhari :: Prophets :: [4.55.545]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 545

Narrated Abu Salama:

Um Salama said, "Um Salaim said, 'O Allah's Apostle! Allah does not refrain from saying the truth! Is it obligatory for a woman to take a bath after she gets nocturnal discharge?' He said, 'Yes, if she notices the water (i.e. discharge).' Um Salama smiled and said, 'Does a woman get discharge?' Allah's Apostle said. 'Then why does a child resemble (its mother)?"


Bukhari :: Prophets :: [4.55.546]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 546

Narrated Anas:

When 'Abdullah bin Salam heard the arrival of the Prophet at Medina, he came to him and said, "I am going to ask you about three things which nobody knows except a prophet: What is the first portent of the Hour? What will be the first meal taken by the people of Paradise? Why does a child resemble its father, and why does it resemble its maternal uncle" Allah's Apostle said, "Gabriel has just now told me of their answers." 'Abdullah said, "He (i.e. Gabriel), from amongst all the angels, is the enemy of the Jews." Allah's Apostle said, "The first portent of the Hour will be a fire that will bring together the people from the east to the west; the first meal of the people of Paradise will be Extra-lobe (caudate lobe) of fish-liver. As for the resemblance of the child to its parents: If a man has sexual intercourse with his wife and gets discharge first, the child will resemble the father, and if the woman gets discharge first, the child will resemble her." On that 'Abdullah bin Salam said, "I testify that you are the Apostle of Allah." 'Abdullah bin Salam further said, "O Allah's Apostle! The Jews are liars, and if they should come to know about my conversion to Islam before you ask them (about me), they would tell a lie about me." The Jews came to Allah's Apostle and 'Abdullah went inside the house. Allah's Apostle asked (the Jews), "What kind of man is 'Abdullah bin Salam amongst you?" They replied, "He is the most learned person amongst us, and the best amongst us, and the son of the best amongst us." Allah's Apostle said, "What do you think if he embraces Islam (will you do as he does)?" The Jews said, "May Allah save him from it." Then 'Abdullah bin Salam came out in front of them saying, "I testify that None has the right to be worshipped but Allah and that Muhammad is the Apostle of Allah." Thereupon they said, "He is the evilest among us, and the son of the evilest amongst us," and continued talking badly of him.


Bukhari :: Prophets :: [4.55.547]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 547

Narrated Abu Huraira:

The Prophet said, "But for the Israelis, meat would not decay and but for Eve, wives would never betray their husbands."


Bukhari :: Prophets :: [4.55.548]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 548

Narrated Abu Huraira:

Allah 's Apostle said, "Treat women nicely, for a women is created from a rib, and the most curved portion of the rib is its upper portion, so, if you should try to straighten it, it will break, but if you leave it as it is, it will remain crooked. So treat women nicely."


Bukhari :: Prophets :: [4.55.549]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 549

Narrated Abdullah:

Allah's Apostle, the true and truly inspired said, "(as regards your creation), every one of you is collected in the womb of his mother for the first forty days, and then he becomes a clot for an other forty days, and then a piece of flesh for an other forty days. Then Allah sends an angel to write four words: He writes his deeds, time of his death, means of his livelihood, and whether he will be wretched or blessed (in religion). Then the soul is breathed into his body. So a man may do deeds characteristic of the people of the (Hell) Fire, so much so that there is only the distance of a cubit between him and it, and then what has been written (by the angel) surpasses, and so he starts doing deeds characteristic of the people of Paradise and enters Paradise. Similarly, a person may do deeds characteristic of the people of Paradise, so much so that there is only the distance of a cubit between him and it, and then what has been written (by the angel) surpasses, and he starts doing deeds of the people of the (Hell) Fire and enters the (Hell) Fire."


Bukhari :: Prophets :: [4.55.550]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 550

Narrated Anas bin Malik:

The Prophet said, "Allah has appointed an angel in the womb, and the angel says, 'O Lord! A drop of discharge (i.e. of semen), O Lord! a clot, O Lord! a piece of flesh.' And then, if Allah wishes to complete the child's creation, the angel will say. 'O Lord! A male or a female? O Lord! wretched or blessed (in religion)? What will his livelihood be? What will his age be?' The angel writes all this while the child is in the womb of its mother."


Bukhari :: Prophets :: [4.55.551]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 551

Narrated Anas:

The Prophet said, "Allah will say to that person of the (Hell) Fire who will receive the least punishment, 'If you had everything on the earth, would you give it as a ransom to free yourself (i.e. save yourself from this Fire)?' He will say, 'Yes.' Then Allah will say, 'While you were in the backbone of Adam, I asked you much less than this, i.e. not to worship others besides Me, but you insisted on worshipping others besides me.' "


Bukhari :: Prophets :: [4.55.552]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 552

Narrated Abdullah:

Allah's Apostle said, "Whenever a person is murdered unjustly, there is a share from the burden of the crime on the first son of Adam for he was the first to start the tradition of murdering."


Bukhari :: Prophets :: [4.55.553]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 553

Narrated Ibn Umar:

Once Allah's Apostle stood amongst the people, glorified and praised Allah as He deserved and then mentioned the Dajjal saying, "l warn you against him (i.e. the Dajjal) and there was no prophet but warned his nation against him. No doubt, Noah warned his nation against him but I tell you about him something of which no prophet told his nation before me. You should know that he is one-eyed, and Allah is not one-eyed."


Bukhari :: Prophets :: [4.55.554]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 554

Narrated Abu Huraira:

Allah's Apostle said, "Shall I not tell you about the Dajjal a story of which no prophet told his nation? The Dajjall is one-eyed and will bring with him what will resemble Hell and Paradise, and what he will call Paradise will be actually Hell; so I warn you (against him) as Noah warned his nation against him."


Bukhari :: Prophets :: [4.55.555]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 555

Narrated Abu Said:

Allah's Apostle said, "Noah and his nation will come (on the Day of Resurrection and Allah will ask (Noah), "Did you convey (the Message)?' He will reply, 'Yes, O my Lord!' Then Allah will ask Noah's nation, 'Did Noah convey My Message to you?' They will reply, 'No, no prophet came to us.' Then Allah will ask Noah, 'Who will stand a witness for you?' He will reply, 'Muhammad and his followers (will stand witness for me).' So, I and my followers will stand as witnesses for him (that he conveyed Allah's Message)." That is, (the interpretation) of the Statement of Allah: "Thus we have made you a just and the best nation that you might be witnesses Over mankind .." (2.143)


Bukhari :: Prophets :: [4.55.556]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 556

Narrated Abu Huraira:

We were in the company of the Prophet at a banquet and a cooked (mutton) forearm was set before him, and he used to like it. He ate a morsel of it and said, "I will be the chief of all the people on the Day of Resurrection. Do you know how Allah will gather all the first and the last (people) in one level place where an observer will be able to see (all) of them and they will be able to hear the announcer, and the sun will come near to them. Some People will say: Don't you see, in what condition you are and the state to which you have reached? Why don't you look for a person who can intercede for you with your Lord? Some people will say: Appeal to your father, Adam.' They will go to him and say: 'O Adam! You are the father of all mankind, and Allah created you with His Own Hands, and ordered the angels to prostrate for you, and made you live in Paradise. Will you not intercede for us with your Lord? Don't you see in what (miserable) state we are, and to what condition we have reached?' On that Adam will reply, 'My Lord is so angry as He has never been before and will never be in the future; (besides), He forbade me (to eat from) the tree, but I disobeyed (Him), (I am worried about) myself! Myself! Go to somebody else; go to Noah.' They will go to Noah and say; 'O Noah! You are the first amongst the messengers of Allah to the people of the earth, and Allah named you a thankful slave. Don't you see in what a (miserable) state we are and to what condition we have reached? Will you not intercede for us with your Lord? Noah will reply: 'Today my Lord has become so angry as he had never been before and will never be in the future Myself! Myself! Go to the Prophet (Muhammad). The people will come to me, and I will prostrate myself underneath Allah's Throne. Then I will be addressed: 'O Muhammad! Raise your head; intercede, for your intercession will be accepted, and ask (for anything). for you will be given. "


Bukhari :: Prophets :: [4.55.557]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 557

Narrated 'Abdullah:

Allah's Apostle recited the following Verse) in the usual tone: 'Fahal-Min-Muddalkir.' (54.15)


Bukhari :: Prophets :: [4.55.558]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 558

Narrated Ibn 'Abbas:

The Prophet said, "I have been made victorious with As-Saba (i.e. an easterly wind) and the people of 'Ad were destroyed by Ad-Dabur (i.e. a westerly wind)." Narrated Abu Said: Ali sent a piece of gold to the Prophet who distributed it among four persons: Al-Aqra' bin Habis Al-Hanzali from the tribe of Mujashi, 'Uyaina bin Badr Al-Fazari, Zaid At-Ta'i who belonged to (the tribe of) Bani Nahban, and 'Alqama bin Ulatha Al-'Amir who belonged to (the tribe of) Bani Kilab. So the Quraish and the Ansar became angry and said, "He (i.e. the Prophet, ) gives the chief of Najd and does not give us." The Prophet said, "I give them) so as to attract their hearts (to Islam)." Then a man with sunken eyes, prominent checks, a raised forehead, a thick beard and a shaven head, came (in front of the Prophet ) and said, "Be afraid of Allah, O Muhammad!" The Prophet ' said "Who would obey Allah if I disobeyed Him? (Is it fair that) Allah has trusted all the people of the earth to me while, you do not trust me?" Somebody who, I think was Khalid bin Al-Walid, requested the Prophet to let him chop that man's head off, but he prevented him. When the man left, the Prophet said, "Among the off-spring of this man will be some who will recite the Qur'an but the Qur'an will not reach beyond their throats (i.e. they will recite like parrots and will not understand it nor act on it), and they will renegade from the religion as an arrow goes through the game's body. They will kill the Muslims but will not disturb the idolaters. If I should live up to their time' I will kill them as the people of 'Ad were killed (i.e. I will kill all of them)."


Bukhari :: Prophets :: [4.55.559]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 559

Narrated 'Abdullah:

I heard the Prophet reciting: "Fahal Min Muddakir." (See Hadith No. 557)


Bukhari :: Prophets :: [4.55.560]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 560

Narrated Abdullah bin Zam'a:

I heard the Prophet while referring to the person who had cut the legs of the she-camel (of the Prophet Salih), saying, "The man who was appointed for doing this job, was a man of honor and power in his nation like Abu Zam'a,"


Bukhari :: Prophets :: [4.55.561]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 561

Narrated Ibn 'Umar:

When Allah's Apostle landed at Al-Hijr during the Ghazwa of Tabuk, he ordered his companions not to drink water from its well or reserve water from it. They said, "We have already kneaded the dough with its water. and also filled our bags with its water.'' On that, the Prophet ordered them to throw away the dough and pour out the water.


Bukhari :: Prophets :: [4.55.562]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 562

Narrated 'Abdullah bin 'Umar:

The people landed at the land of Thamud called Al-Hijr along with Allah's Apostle and they took water from its well for drinking and kneading the dough with it as well. (When Allah's Apostle heard about it) he ordered them to pour out the water they had taken from its wells and feed the camels with the dough, and ordered them to take water from the well whence the she-camel (of Prophet Salih) used to drink.


Bukhari :: Prophets :: [4.55.563]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 563

Narrated 'Abdullah bin 'Umar:

When the Prophet passed by (a place called) Al Hijr, he said, "Do not enter the house of those who were unjust to themselves, unless (you enter) weeping, lest you should suffer the same punishment as was inflicted upon them." After that he covered his face with his sheet cloth while he was on the camel-saddle.


Bukhari :: Prophets :: [4.55.564]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 564

Narrated Ibn 'Umar:

Allah's Apostle said, "Do not enter the ruined dwellings of those who were unjust to themselves unless (you enter) weeping, lest you should suffer the same punishment as was inflicted upon them."


Bukhari :: Prophets :: [4.55.565]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 565

Narrated Zainab bint Jahsh:

That the Prophet once came to her in a state of fear and said, "None has the right to be worshipped but Allah. Woe unto the Arabs from a danger that has come near. An opening has been made in the wall of Gog and Magog like this," making a circle with his thumb and index finger. Zainab bint Jahsh said, "O Allah's Apostle! Shall we be destroyed even though there are pious persons among us?" He said, "Yes, when the evil person will increase."


Bukhari :: Prophets :: [4.55.566]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 566

Narrated Abu Huraira:

The Prophet said, "Allah has made an opening in the wall of the Gog and Magog (people) like this, and he made with his hand (with the help of his fingers).


Bukhari :: Prophets :: [4.55.567]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 567

Narrated Abu Said Al-Khudri:

The Prophet said, "Allah will say (on the Day of Resurrection), 'O Adam.' Adam will reply, 'Labbaik wa Sa'daik', and all the good is in Your Hand.' Allah will say: 'Bring out the people of the fire.' Adam will say: 'O Allah! How many are the people of the Fire?' Allah will reply: 'From every one thousand, take out nine-hundred-and ninety-nine.' At that time children will become hoary headed, every pregnant female will have a miscarriage, and one will see mankind as drunken, yet they will not be drunken, but dreadful will be the Wrath of Allah." The companions of the Prophet asked, "O Allah's Apostle! Who is that (excepted) one?" He said, "Rejoice with glad tidings; one person will be from you and one-thousand will be from Gog and Magog."

The Prophet further said, "By Him in Whose Hands my life is, hope that you will be one-fourth of the people of Paradise." We shouted, "Allahu Akbar!" He added, "I hope that you will be one-third of the people of Paradise." We shouted, "Allahu Akbar!" He said, "I hope that you will be half of the people of Paradise." We shouted, "Allahu Akbar!" He further said, "You (Muslims) (compared with non Muslims) are like a black hair in the skin of a white ox or like a white hair in the skin of a black ox (i.e. your number is very small as compared with theirs)."


Bukhari :: Prophets :: [4.55.568]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 568

Narrated Ibn Abbas:

The Prophet said, "You will be gathered (on the Day of Judgment), bare-footed, naked and not circumcised." He then recited:--'As We began the first creation, We, shall repeat it: A Promise We have undertaken: Truly we shall do it.' (21.104) He added, "The first to be dressed on the Day of Resurrection, will be Abraham, and some of my companions will be taken towards the left side (i.e. to the (Hell) Fire), and I will say: 'My companions! My companions!' It will be said: 'They renegade from Islam after you left them.' Then I will say as the Pious slave of Allah (i.e. Jesus) said. 'And I was a witness Over them while I dwelt amongst them. When You took me up You were the Watcher over them, And You are a witness to all things. If You punish them. They are Your slaves And if You forgive them, Verily you, only You are the All-Mighty, the All-Wise." (5.120-121)


Bukhari :: Prophets :: [4.55.569]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 569

Narrated Abu Huraira:

The Prophet said, "On the Day of Resurrection Abraham will meet his father Azar whose face will be dark and covered with dust.(The Prophet Abraham will say to him): 'Didn't I tell you not to disobey me?' His father will reply: 'Today I will not disobey you.' 'Abraham will say: 'O Lord! You promised me not to disgrace me on the Day of Resurrection; and what will be more disgraceful to me than cursing and dishonoring my father?' Then Allah will say (to him):' 'I have forbidden Paradise for the disbelievers." Then he will be addressed, 'O Abraham! Look! What is underneath your feet?' He will look and there he will see a Dhabh (an animal,) blood-stained, which will be caught by the legs and thrown in the (Hell) Fire."


Bukhari :: Prophets :: [4.55.570]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 570

Narrated Ibn Abbas:

The Prophet entered the Ka'ba and found in it the pictures of (Prophet) Abraham and Mary. On that he said' "What is the matter with them ( i.e. Quraish)? They have already heard that angels do not enter a house in which there are pictures; yet this is the picture of Abraham. And why is he depicted as practicing divination by arrows?"


Bukhari :: Prophets :: [4.55.571]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 571

Narrated Ibn Abbas:

When the Prophet saw pictures in the Ka'ba, he did not enter it till he ordered them to be erased. When he saw (the pictures of Abraham and Ishmael carrying the arrows of divination, he said, "May Allah curse them (i.e. the Quraish)! By Allah, neither Abraham nor Ishmael practiced divination by arrows."


Bukhari :: Prophets :: [4.55.572]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 572

Narrated Abu Huraira:

The people said, "O Allah's Apostle! Who is the most honorable amongst the people (in Allah's Sight)?" He said, "The most righteous amongst them." They said, "We do not ask you, about this. " He said, "Then Joseph, Allah's Prophet, the son of Allah's Prophet, The son of Allah's Prophet the son of Allah's Khalil (i.e. Abraham)." They said, "We do not want to ask about this," He said' "Then you want to ask about the descent of the Arabs. Those who were the best in the pre-lslamic period of ignorance will be the best in Islam provided they comprehend the religious knowledge."


Bukhari :: Prophets :: [4.55.573]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 573

Narrated Samura:

Allah's Apostle said, "Two persons came to me at night (in dream) (and took me along with them). We passed by a tall man who was so tall that I was not able to see his head and that person was Abraham."


Bukhari :: Prophets :: [4.55.574]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 574

Narrated Mujahid:

That when the people mentioned before Ibn 'Abbas that the Dajjal would have the word Kafir, (i.e. unbeliever) or the letters Kafir (the root of the Arabic verb 'disbelieve') written on his forehead, I heard Ibn 'Abbas saying, "I did not hear this, but the Prophet said, 'If you want to see Abraham, then look at your companion (i.e. the Prophet) but Moses was a curly-haired, brown man (who used to ride) a red camel, the reins of which was made of fires of date-palms. As if I were now looking down a valley."


Bukhari :: Prophets :: [4.55.575]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 575

Narrated Abu Huraira:

Allah's Apostle said, "Abraham did his circumcision with an adze at the age of eighty."


Bukhari :: Prophets :: [4.55.576]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 576

Narrated Abu Az-Zinad:

(as above in Hadith No. 575) With an adze.


Bukhari :: Prophets :: [4.55.577]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 577

Narrated Abu Huraira:

Allah's Apostle said, "Abraham did not tell a lie except on three occasions."


Bukhari :: Prophets :: [4.55.578]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 578

Narrated Abu Huraira:

Abraham did not tell a lie except on three occasion. Twice for the Sake of Allah when he said, "I am sick," and he said, "(I have not done this but) the big idol has done it." The (third was) that while Abraham and Sarah (his wife) were going (on a journey) they passed by (the territory of) a tyrant. Someone said to the tyrant, "This man (i.e. Abraham) is accompanied by a very charming lady." So, he sent for Abraham and asked him about Sarah saying, "Who is this lady?" Abraham said, "She is my sister." Abraham went to Sarah and said, "O Sarah! There are no believers on the surface of the earth except you and I. This man asked me about you and I have told him that you are my sister, so don't contradict my statement." The tyrant then called Sarah and when she went to him, he tried to take hold of her with his hand, but (his hand got stiff and) he was confounded. He asked Sarah. "Pray to Allah for me, and I shall not harm you." So Sarah asked Allah to cure him and he got cured. He tried to take hold of her for the second time, but (his hand got as stiff as or stiffer than before and) was more confounded. He again requested Sarah, "Pray to Allah for me, and I will not harm you." Sarah asked Allah again and he became alright. He then called one of his guards (who had brought her) and said, "You have not brought me a human being but have brought me a devil." The tyrant then gave Hajar as a girl-servant to Sarah. Sarah came back (to Abraham) while he was praying. Abraham, gesturing with his hand, asked, "What has happened?" She replied, "Allah has spoiled the evil plot of the infidel (or immoral person) and gave me Hajar for service." (Abu Huraira then addressed his listeners saying, "That (Hajar) was your mother, O Bani Ma-is-Sama (i.e. the Arabs, the descendants of Ishmael, Hajar's son)."


Bukhari :: Prophets :: [4.55.579]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 579

Narrated Um Sharik:

Allah's Apostle ordered that the salamander should be killed and said, "It (i.e. the salamander) blew (the fire) on Abraham."


Bukhari :: Prophets :: [4.55.580]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 580

Narrated Abdullah:

When the Verse:--"It is those who believe and do not confuse their belief with wrong ( i.e. joining others in worship with Allah" (6.83) was revealed, we said, "O Allah's Apostle! Who is there amongst us who has not done wrong to himself?" He replied, "It is not as you say, for 'wrong' in the Verse and 'do not confuse their belief, with wrong means 'SHIRK' (i.e. joining others in worship with Allah). Haven't you heard Luqman's saying to his son, 'O my son! Join not others in worship with Allah, verily joining others in worship with Allah is a great wrong indeed." (31.13)


Bukhari :: Prophets :: [4.55.581]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 581

Narrated Abu Huraira:

One day some meat was given to the Prophet and he said, "On the Day of Resurrection Allah will gather all the first and the last (people) in one plain, and the voice of the announcer will reach all of them, and one will be able to see them all, and the sun will come closer to them." (The narrator then mentioned the narration of intercession): "The people will go to Abraham and say: 'You are Allah's Prophet and His Khalil on the earth. Will you intercede for us with your Lord?' Abraham will then remember his lies and say: 'Myself! Myself! Go to Moses."


Bukhari :: Prophets :: [4.55.582]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 582

Narrated Ibn 'Abbas:

The Prophet said, "May Allah bestow His Mercy on the mother of Ishmael! Had she not hastened (to fill her water-skin with water from the Zam-zam well). Zam-zam would have been a stream flowing on the surface of the earth." Ibn 'Abbas further added, "(The Prophet) Abraham brought Ishmael and his mother (to Mecca) and she was suckling Ishmael and she had a water-skin with her.'


Bukhari :: Prophets :: [4.55.583]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 583

Narrated Ibn Abbas:

The first lady to use a girdle was the mother of Ishmael. She used a girdle so that she might hide her tracks from Sarah. Abraham brought her and her son Ishmael while she was suckling him, to a place near the Ka'ba under a tree on the spot of Zam-zam, at the highest place in the mosque. During those days there was nobody in Mecca, nor was there any water So he made them sit over there and placed near them a leather bag containing some dates, and a small water-skin containing some water, and set out homeward. Ishmael's mother followed him saying, "O Abraham! Where are you going, leaving us in this valley where there is no person whose company we may enjoy, nor is there anything (to enjoy)?" She repeated that to him many times, but he did not look back at her Then she asked him, "Has Allah ordered you to do so?" He said, "Yes." She said, "Then He will not neglect us," and returned while Abraham proceeded onwards, and on reaching the Thaniya where they could not see him, he faced the Ka'ba, and raising both hands, invoked Allah saying the following prayers:

'O our Lord! I have made some of my offspring dwell in a valley without cultivation, by Your Sacred House (Kaba at Mecca) in order, O our Lord, that they may offer prayer perfectly. So fill some hearts among men with love towards them, and (O Allah) provide them with fruits, so that they may give thanks.' (14.37) Ishmael's mother went on suckling Ishmael and drinking from the water (she had).

When the water in the water-skin had all been used up, she became thirsty and her child also became thirsty. She started looking at him (i.e. Ishmael) tossing in agony; She left him, for she could not endure looking at him, and found that the mountain of Safa was the nearest mountain to her on that land. She stood on it and started looking at the valley keenly so that she might see somebody, but she could not see anybody. Then she descended from Safa and when she reached the valley, she tucked up her robe and ran in the valley like a person in distress and trouble, till she crossed the valley and reached the Marwa mountain where she stood and started looking, expecting to see somebody, but she could not see anybody. She repeated that (running between Safa and Marwa) seven times."

The Prophet said, "This is the source of the tradition of the walking of people between them (i.e. Safa and Marwa). When she reached the Marwa (for the last time) she heard a voice and she asked herself to be quiet and listened attentively. She heard the voice again and said, 'O, (whoever you may be)! You have made me hear your voice; have you got something to help me?" And behold! She saw an angel at the place of Zam-zam, digging the earth with his heel (or his wing), till water flowed from that place. She started to make something like a basin around it, using her hand in this way, and started filling her water-skin with water with her hands, and the water was flowing out after she had scooped some of it."

The Prophet added, "May Allah bestow Mercy on Ishmael's mother! Had she let the Zam-zam (flow without trying to control it) (or had she not scooped from that water) (to fill her water-skin), Zam-zam would have been a stream flowing on the surface of the earth." The Prophet further added, "Then she drank (water) and suckled her child. The angel said to her, 'Don't be afraid of being neglected, for this is the House of Allah which will be built by this boy and his father, and Allah never neglects His people.' The House (i.e. Kaba) at that time was on a high place resembling a hillock, and when torrents came, they flowed to its right and left. She lived in that way till some people from the tribe of Jurhum or a family from Jurhum passed by her and her child, as they (i.e. the Jurhum people) were coming through the way of Kada'. They landed in the lower part of Mecca where they saw a bird that had the habit of flying around water and not leaving it. They said, 'This bird must be flying around water, though we know that there is no water in this valley.' They sent one or two messengers who discovered the source of water, and returned to inform them of the water. So, they all came (towards the water)." The Prophet added, "Ishmael's mother was sitting near the water. They asked her, 'Do you allow us to stay with you?" She replied, 'Yes, but you will have no right to possess the water.' They agreed to that." The Prophet further said, "Ishmael's mother was pleased with the whole situation as she used to love to enjoy the company of the people. So, they settled there, and later on they sent for their families who came and settled with them so that some families became permanent residents there. The child (i.e. Ishmael) grew up and learnt Arabic from them and (his virtues) caused them to love and admire him as he grew up, and when he reached the age of puberty they made him marry a woman from amongst them.

After Ishmael's mother had died, Abraham came after Ishmael's marriage in order to see his family that he had left before, but he did not find Ishmael there. When he asked Ishmael's wife about him, she replied, 'He has gone in search of our livelihood.' Then he asked her about their way of living and their condition, and she replied, 'We are living in misery; we are living in hardship and destitution,' complaining to him. He said, 'When your husband returns, convey my salutation to him and tell him to change the threshold of the gate (of his house).' When Ishmael came, he seemed to have felt something unusual, so he asked his wife, 'Has anyone visited you?' She replied, 'Yes, an old man of so-and-so description came and asked me about you and I informed him, and he asked about our state of living, and I told him that we were living in a hardship and poverty.' On that Ishmael said, 'Did he advise you anything?' She replied, 'Yes, he told me to convey his salutation to you and to tell you to change the threshold of your gate.' Ishmael said, 'It was my father, and he has ordered me to divorce you. Go back to your family.' So, Ishmael divorced her and married another woman from amongst them (i.e. Jurhum).

Then Abraham stayed away from them for a period as long as Allah wished and called on them again but did not find Ishmael. So he came to Ishmael's wife and asked her about Ishmael. She said, 'He has gone in search of our livelihood.' Abraham asked her, 'How are you getting on?' asking her about their sustenance and living. She replied, 'We are prosperous and well-off (i.e. we have everything in abundance).' Then she thanked Allah' Abraham said, 'What kind of food do you eat?' She said. 'Meat.' He said, 'What do you drink?' She said, 'Water." He said, "O Allah! Bless their meat and water." The Prophet added, "At that time they did not have grain, and if they had grain, he would have also invoked Allah to bless it." The Prophet added, "If somebody has only these two things as his sustenance, his health and disposition will be badly affected, unless he lives in Mecca." The Prophet added," Then Abraham said Ishmael's wife, "When your husband comes, give my regards to him and tell him that he should keep firm the threshold of his gate.' When Ishmael came back, he asked his wife, 'Did anyone call on you?' She replied, 'Yes, a good-looking old man came to me,' so she praised him and added. 'He asked about you, and I informed him, and he asked about our livelihood and I told him that we were in a good condition.' Ishmael asked her, 'Did he give you any piece of advice?' She said, 'Yes, he told me to give his regards to you and ordered that you should keep firm the threshold of your gate.' On that Ishmael said, 'It was my father, and you are the threshold (of the gate). He has ordered me to keep you with me.'

Then Abraham stayed away from them for a period as long as Allah wished, and called on them afterwards. He saw Ishmael under a tree near Zamzam, sharpening his arrows. When he saw Abraham, he rose up to welcome him (and they greeted each other as a father does with his son or a son does with his father). Abraham said, 'O Ishmael! Allah has given me an order.' Ishmael said, 'Do what your Lord has ordered you to do.' Abraham asked, 'Will you help me?' Ishmael said, 'I will help you.' Abraham said, Allah has ordered me to build a house here,' pointing to a hillock higher than the land surrounding it." The Prophet added, "Then they raised the foundations of the House (i.e. the Ka'ba). Ishmael brought the stones and Abraham was building, and when the walls became high, Ishmael brought this stone and put it for Abraham who stood over it and carried on building, while Ishmael was handing him the stones, and both of them were saying, 'O our Lord! Accept (this service) from us, Verily, You are the All-Hearing, the All-Knowing.' The Prophet added, "Then both of them went on building and going round the Ka'ba saying: O our Lord ! Accept (this service) from us, Verily, You are the All-Hearing, the All-Knowing." (2.127)


Bukhari :: Prophets :: [4.55.584]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 584

Narrated Ibn Abbas:

When Abraham had differences with his wife), (because of her jealousy of Hajar, Ishmael's mother), he took Ishmael and his mother and went away. They had a water-skin with them containing some water, Ishmael's mother used to drink water from the water-skin so that her milk would increase for her child. When Abraham reached Mecca, he made her sit under a tree and afterwards returned home. Ishmael's mother followed him, and when they reached Kada', she called him from behind, 'O Abraham! To whom are you leaving us?' He replied, '(I am leaving you) to Allah's (Care).' She said, 'I am satisfied to be with Allah.' She returned to her place and started drinking water from the water-skin, and her milk increased for her child. When the water had all been used up, she said to herself, 'I'd better go and look so that I may see somebody.' She ascended the Safa mountain and looked, hoping to see somebody, but in vain. When she came down to the valley, she ran till she reached the Marwa mountain. She ran to and fro (between the two mountains) many times. They she said to herself, 'i'd better go and see the state of the child,' she went and found it in a state of one on the point of dying. She could not endure to watch it dying and said (to herself), 'If I go and look, I may find somebody.' She went and ascended the Safa mountain and looked for a long while but could not find anybody. Thus she completed seven rounds (of running) between Safa and Marwa. Again she said (to herself), 'I'd better go back and see the state of the child.' But suddenly she heard a voice, and she said to that strange voice, 'Help us if you can offer any help.' Lo! It was Gabriel (who had made the voice). Gabriel hit the earth with his heel like this (Ibn 'Abbas hit the earth with his heel to Illustrate it), and so the water gushed out. Ishmael's mother was astonished and started digging. (Abu Al-Qasim) (i.e. the Prophet) said, "If she had left the water, (flow naturally without her intervention), it would have been flowing on the surface of the earth.") Ishmael's mother started drinking from the water and her milk increased for her child . Afterwards some people of the tribe of Jurhum, while passing through the bottom of the valley, saw some birds, and that astonished them, and they said, 'Birds can only be found at a place where there is water.' They sent a messenger who searched the place and found the water, and returned to inform them about it. Then they all went to her and said, 'O ishmael's mother! Will you allow us to be with you (or dwell with you)?' (And thus they stayed there.) Later on her boy reached the age of puberty and married a lady from them. Then an idea occurred to Abraham which he disclosed to his wife (Sarah), 'I want to call on my dependents I left (at Mecca).' When he went there, he greeted (Ishmael's wife) and said, 'Where is Ishmael?' She replied, 'He has gone out hunting.' Abraham said (to her), 'When he comes, tell him to change the threshold of his gate.' When he came, she told him the same whereupon Ishmael said to her, 'You are the threshold, so go to your family (i.e. you are divorced).' Again Abraham thought of visiting his dependents whom he had left (at Mecca), and he told his wife (Sarah) of his intentions. Abraham came to Ishmael's house and asked. "Where is Ishmael?" Ishmael's wife replied, "He has gone out hunting," and added, "Will you stay (for some time) and have something to eat and drink?' Abraham asked, 'What is your food and what is your drink?' She replied, 'Our food is meat and our drink is water.' He said, 'O Allah! Bless their meals and their drink." Abu Al-Qa-sim (i.e. Prophet) said, "Because of Abraham's invocation there are blessings (in Mecca)." Once more Abraham thought of visiting his family he had left (at Mecca), so he told his wife (Sarah) of his decision. He went and found Ishmael behind the Zam-zam well, mending his arrows. He said, "O Ishmael, Your Lord has ordered me to build a house for Him." Ishmael said, "Obey (the order of) your Lord." Abraham said, "Allah has also ordered me that you should help me therein." Ishmael said, "Then I will do." So, both of them rose and Abraham started building (the Ka'ba) while Ishmael went on handing him the stones, and both of them were saying, "O our Lord ! Accept (this service) from us, Verily, You are the All-Hearing, the All-Knowing." (2.127). When the building became high and the old man (i.e. Abraham) could no longer lift the stones (to such a high position), he stood over the stone of Al-Maqam and Ishmael carried on handing him the stones, and both of them were saying, 'O our Lord! Accept (this service) from us, Verily You are All-Hearing, All-Knowing." (2.127)


Bukhari :: Prophets :: [4.55.585]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 585

Narrated Abu Dhar:

I said, "O Allah's Apostle! Which mosque was first built on the surface of the earth?" He said, "Al-Masjid-ul-,Haram (in Mecca)." I said, "Which was built next?" He replied "The mosque of Al-Aqsa ( in Jerusalem) ." I said, "What was the period of construction between the two?" He said, "Forty years." He added, "Wherever (you may be, and) the prayer time becomes due, perform the prayer there, for the best thing is to do so (i.e. to offer the prayers in time)."


Bukhari :: Prophets :: [4.55.586]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 586

Narrated Anas bin Malik:

When the mountain of Uhud came in the sight of Allah's Apostle he said. "This is a mountain that loves us and is loved by us. O Allah! Abraham made Mecca a sanctuary, and I make (the area) in between these two mountains (of Medina) a sanctuary."


Bukhari :: Prophets :: [4.55.587]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 587

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle said (to her). "Don't you see that when your folk built the Ka'ba, they did not build it on all the foundations built by Abraham?" I said, "O Allah's Apostle! Why don't we rebuild it on the foundations of Abraham?" He said. "But for the fact that your folk have recently given up infidelity (I would have done so)."

Narrated Ibn Umar: Aisha must have heard this from Allah's Apostle for I see that Allah's Apostle used not to touch the two corners facing Al-Hijr only because the House had not been built on the foundations of Abraham''


Bukhari :: Prophets :: [4.55.588]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 588

Narrated Abu Humaid As-Sa'idi:

The people asked, "O Allah's Apostle! How shall we (ask Allah to) send blessings on you?" Allah's Apostle replied, "Say: O Allah! Send Your Mercy on Muhammad and on his wives and on his off spring, as You sent Your Mercy on Abraham's family; and send Your Blessings on Muhammad and on his offspring, as You sent Your Blessings on Abraham's family, for You are the Most Praise-worthy, the Most Glorious."


Bukhari :: Prophets :: [4.55.589]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 589

Narrated Abdur-Rahman bin Abi Laila:

Ka'b bin Ujrah met me and said, "Shall I not give you a present I got from the Prophet?" 'Abdur-Rahman said, "Yes, give it to me." I said, "We asked Allah's Apostle saying, 'O Allah's Apostle! How should one (ask Allah to) send blessings on you, the members of the family, for Allah has taught us how to salute you (in the prayer)?' He said, 'Say: O Allah! Send Your Mercy on Muhammad and on the family of Muhammad, as You sent Your Mercy on Abraham and on the family of Abraham, for You are the Most Praise-worthy, the Most Glorious. O Allah! Send Your Blessings on Muhammad and the family of Muhammad, as You sent your Blessings on Abraham and on the family of Abraham, for You are the Most Praise-worthy, the Most Glorious.' "


Bukhari :: Prophets :: [4.55.590]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 590

Narrated Ibn 'Abbas:

The Prophet used to seek Refuge with Allah for Al-Hasan and Al-Husain and say: "Your forefather (i.e. Abraham) used to seek Refuge with Allah for Ishmael and Isaac by reciting the following: 'O Allah! I seek Refuge with Your Perfect Words from every devil and from poisonous pests and from every evil, harmful, envious eye.' "


Bukhari :: Prophets :: [4.55.591]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 591

Narrated Abu Huraira:

Allah's Apostle said, "We are more liable to be in doubt than Abraham when he said, 'My Lord! Show me how You give life to the dead." . He (i.e. Allah) slid: 'Don't you believe then?' He (i.e. Abraham) said: "Yes, but (I ask) in order to be stronger in Faith." (2.260) And may Allah send His Mercy on Lot! He wished to have a powerful support. If I were to stay in prison for such a long time as Joseph did I would have accepted the offer (of freedom without insisting on having my guiltless less declared)."


Bukhari :: Prophets :: [4.55.592]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 592

Narrated Salama bin Al-Akwa:

The Prophet passed by some persons of the tribe of Aslam practicing archery (i.e. the throwing of arrows) Allah's Apostle said, "O offspring of Ishmael! Practice archery (i.e. arrow throwing) as your father was a great archer (i.e. arrow-thrower). I am with (on the side of) the son of so-and-so-." Hearing that, one of the two teams stopped throwing. Allah's Apostle asked them, ' Why are you not throwing?" They replied, "O Allah's Apostle! How shall we throw when you are with the opposite team?" He said, "Throw, for I am with you all."


Bukhari :: Prophets :: [4.55.593]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 593

Narrated Abu Huraira:

Some people asked the Prophet: "Who is the most honorable amongst the people?" He replied, "The most honorable among them is the one who is the most Allah-fearing." They said, "O Allah's Prophet! We do not ask about this." He said, "Then the most honorable person is Joseph, Allah's Prophet, the son of Allah's Prophet, the son of Allah's Prophet, the son of Allah's Khalil." They said, "We do not ask about this." He said, "Then you want to ask me about the Arabs' descent?" They said, "Yes." He said, "Those who were best in the pre-lslamic period, are the best in Islam, if they comprehend (the religious knowledge)."


Bukhari :: Prophets :: [4.55.594]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 594

Narrated Abu Huraira:

The Prophet said, "May Allah forgive Lot: He wanted to have a powerful support."


Bukhari :: Prophets :: [4.55.595]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 595

Narrated 'Abdullah:

The Prophet recited:-- 'Hal-min-Muddakir' (54.15) (Is there any that will remember) (and avoid evil).


Bukhari :: Prophets :: [4.55.596]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 596

Narrated Ibn Umar:

The Prophet said, "The honorable is the son of the honorable, the son the honorable, i.e. Joseph, the son of Jacob, the son of Isaac, the son of Abraham,


Bukhari :: Prophets :: [4.55.597]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 597

Narrated Abu Huraira:

Allah's Apostle was asked, "Who is the most honorable amongst the people?" He replied, "The most Allah fearing." The people said, "We do not want to ask you about this." He said, "The most honorable person is Joseph, Allah's Prophet, the son of Allah's Prophet, the son of Allah's Prophet, the son of Allah's Khalil" The people said, 'We do not want to ask you about this." He said," Then you want to ask me about the origins of the Arabs? People are of various origins. The best in the pre-lslamic period are the best in Islam, provided they comprehend (the religious knowledge)."


Bukhari :: Prophets :: [4.55.598]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 598

Narrated 'Aisha:

That the Prophet said (to her). "Order Abu Bakr to lead the people in prayer." She replied," Abu Bakr is a soft-hearted person and when he stands at your place, he will weep (so he will not be able to lead the prayer)." The Prophet repeated the same order and she gave the same reply. The narrator, Shuba said that the Prophet said on the third or fourth time. "You are (like) the female companions of Joseph. Order Abu Bakr to lead the prayer. "


Bukhari :: Prophets :: [4.55.599]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 599

Narrated Abu Musa:

When the Prophet fell ill, he said, "Order Abu Bakr to lead the people in prayer." 'Aisha said, "Abu Bakr is a soft-hearted person. The Prophet gave the same order again and she again gave the same reply. He again said, "Order Abu Bakr (to lead the prayer)! You are (like) the female companions of Joseph." Consequently Abu Bakr led the people in prayer in the life-time of the Prophet


Bukhari :: Prophets :: [4.55.600]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 600

Narrated Abu Huraira:

Allah's Apostle said, "O Allah! Save Aiyyash bin Abi Rabia (from the unjust treatment of the infidels). O Allah! Save Salama bin Hisham. O Allah! Send your Punishment on (the tribe of) Mudar. O Allah! Let them suffer from years (of drought) similar to that inflicted during the life-time of Joseph."


Bukhari :: Prophets :: [4.55.601]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 601

Narrated Abu Huraira:

Allah's Apostle said, "May Allah bestow His Mercy on Lot. He wanted to have a powerful support. If I were to stay in prison (for a period equal to) the stay of Joseph (prison) and then the offer of freedom came to me, then I would have accepted it." (See Hadith No. 591)


Bukhari :: Prophets :: [4.55.602]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 602

Narrated Masruq:

I asked Um Ruman, 'Aisha's mother about the accusation forged against 'Aisha. She said, "While I was sitting with 'Aisha, an Ansari woman came to us and said, 'Let Allah condemn such-and-such person.' I asked her, 'Why do you say so?' She replied, 'For he has spread the (slanderous) story.' 'Aisha said, 'What story?' The woman then told her the story. 'Aisha asked, 'Have Abu Bakr and Allah's Apostle heard about it ?' She said, 'Yes.' 'Aisha fell down senseless (on hearing that), and when she came to her senses, she got fever and shaking of the body. The Prophet came and asked, 'What is wrong with her?' I said, 'She has got fever because of a story which has been rumored.' 'Aisha got up and said, 'By Allah! Even if I took an oath, you would not believe me, and if I put forward an excuse, You would not excuse me. My example and your example is just like that example of Jacob and his sons. Against that which you assert, it is Allah (Alone) Whose Help can be sought.' (12.18) The Prophet left and then Allah revealed the Verses (concerning the matter), and on that 'Aisha said, 'Thanks to Allah (only) and not to anybody else."


Bukhari :: Prophets :: [4.55.603]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 603

Narrated 'Urwa:

I asked 'Aisha the wife of the Prophet about the meaning of the following Verse: -- "(Respite will be granted) 'Until when the apostles give up hope (of their people) and thought that they were denied (by their people)..............."(12.110) 'Aisha replied, "Really, their nations did not believe them." I said, "By Allah! They were definite that their nations treated them as liars and it was not a matter of suspecting." 'Aisha said, "O 'Uraiya (i.e. 'Urwa)! No doubt, they were quite sure about it."

I said, "May the Verse be read in such a way as to mean that the apostles thought that Allah did not help them?" Aisha said, "Allah forbid! (Impossible) The Apostles did not suspect their Lord of such a thing. But this Verse is concerned with the Apostles' followers who had faith in their Lord and believed in their apostles and their period of trials was long and Allah's Help was delayed till the apostles gave up hope for the conversion of the disbelievers amongst their nation and suspected that even their followers were shaken in their belief, Allah's Help then came to them." Narrated Ibn 'Umar: The Prophet said, "The honorable, the son of the honorable, the son of the honorable, (was) Joseph, the son of Jacob! the son of Isaac, the son of Abraham."


Bukhari :: Prophets :: [4.55.604]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 604

Narrated Abu Huraira:

The Prophet said, "While Job was naked, taking a bath, a swarm of gold locusts fell on him and he started collecting them in his garment. His Lord called him, 'O Job! Have I not made you rich enough to need what you see? He said, 'Yes, O Lord! But I cannot dispense with your Blessing."'


Bukhari :: Prophets :: [4.55.605]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 605

Narrated 'Aisha:

The Prophet returned to Khadija while his heart was beating rapidly. She took him to Waraqa bin Naufal who was a Christian convert and used to read the Gospels in Arabic Waraqa asked (the Prophet), "What do you see?" When he told him, Waraqa said, "That is the same angel whom Allah sent to the Prophet) Moses. Should I live till you receive the Divine Message, I will support you strongly."


Bukhari :: Prophets :: [4.55.606]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 606

Narrated Malik bin Sasaa:

Allah's Apostle talked to his companions about his Night Journey to the Heavens. When he reached the fifth Heaven, he met Aaron. (Gabriel said to the Prophet), "This is Aaron." The Prophet said, "Gabriel greeted and so did I, and he returned the greeting saying, 'Welcome, O Pious Brother and Pious Prophet."


Bukhari :: Prophets :: [4.55.607]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 607

Narrated Abu Huraira:

Allah's Apostle said, "On the night of my Ascension to Heaven, I saw (the prophet) Moses who was a thin person with lank hair, looking like one of the men of the tribe of Shanua; and I saw Jesus who was of average height with red face as if he had just come out of a bathroom. And I resemble prophet Abraham more than any of his offspring does. Then I was given two cups, one containing milk and the other wine. Gabriel said, 'Drink whichever you like.' I took the milk and drank it. Gabriel said, 'You have accepted what is natural, (True Religion i.e. Islam) and if you had taken the wine, your followers would have gone astray.' "


Bukhari :: Prophets :: [4.55.608]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 608

Narrated Ibn 'Abbas:

The Prophet said, "One should not say that I am better than Jonah (i.e. Yunus) bin Matta." So, he mentioned his father Matta. The Prophet mentioned the night of his Ascension and said, "The prophet Moses was brown, a tall person as if from the people of the tribe of Shanu'a. Jesus was a curly-haired man of moderate height." He also mentioned Malik, the gate-keeper of the (Hell) Fire, and Ad-Dajjal.


Bukhari :: Prophets :: [4.55.609]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 609

Narrated Ibn 'Abbas:

When the Prophet came to Medina, he found (the Jews) fasting on the day of 'Ashura' (i.e. 10th of Muharram). They used to say: "This is a great day on which Allah saved Moses and drowned the folk of Pharaoh. Moses observed the fast on this day, as a sign of gratitude to Allah." The Prophet said, "I am closer to Moses than they." So, he observed the fast (on that day) and ordered the Muslims to fast on it.


Bukhari :: Prophets :: [4.55.610]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 610

Narrated Abu Said:

The Prophet said, 'People will be struck unconscious on the Day of Resurrection and I will be the first to regain consciousness, and behold! There I will see Moses holding one of the pillars of Allah's Throne. I will wonder whether he has become conscious before me of he has been exempted, because of his unconsciousness at the Tur (mountain) which he received (on the earth)."


Bukhari :: Prophets :: [4.55.611]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 611

Narrated Abu Huraira:

The Prophet said, "Were it not for Bani Israel, meat would not decay; and were it not for Eve, no woman would ever betray her husband."


Bukhari :: Prophets :: [4.55.612]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 612

Narrated Ibn Abbas:

That he differed with Al-Hur bin Qais Al-Fazari regarding the companion of Moses. Ibn 'Abbas said that he was Al-Khadir. Meanwhile Ubai bin Ka'b passed by them and Ibn 'Abbas called him saying, "My friend and I have differed regarding Moses' companion whom Moses asked the way to meet. Have you heard Allah's Apostle mentioning something about him?" He said, "Yes, I heard Allah's Apostle saying, 'While Moses was sitting in the company of some Israelites, a man came and asked (him), 'Do you know anyone who is more learned than you?' Moses replied, 'No.' So, Allah sent the Divine Inspiration to Moses: 'Yes, Our slave, Khadir (is more learned than you).' Moses asked how to meet him (i.e. Khadir). So, the fish, was made, as a sign for him, and he was told that when the fish was lost, he should return and there he would meet him. So, Moses went on looking for the sign of the fish in the sea. The servant boy of Moses said to him, 'Do you know that when we were sitting by the side of the rock, I forgot the fish, and t was only Satan who made me forget to tell (you) about it.' Moses said, That was what we were seeking after,' and both of them returned, following their footmarks and found Khadir; and what happened further to them, is mentioned in Allah's Book."


Bukhari :: Prophets :: [4.55.613]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 613

Narrated Said bin Jubair:

I said to Ibn Abbas, "Nauf Al-Bukah claims that Moses, the companion of Al-Khadir was not Moses (the prophet) of the children of Israel, but some other Moses." Ibn 'Abbas said, "Allah's enemy (i.e. Nauf) has told a lie. Ubai bin Ka'b told us that the Prophet said, 'Once Moses stood up and addressed Bani Israel. He was asked who was the most learned man amongst the people. He said, 'I.' Allah admonished him as he did not attribute absolute knowledge to Him (Allah). So, Allah said to him, 'Yes, at the junction of the two seas there is a Slave of Mine who is more learned than you.' Moses said, 'O my Lord! How can I meet him?' Allah said, 'Take a fish and put it in a large basket and you will find him at the place where you will lose the fish.' Moses took a fish and put it in a basket and proceeded along with his (servant) boy, Yusha 'bin Nun, till they reached the rock where they laid their heads (i.e. lay down). Moses slept, and the fish, moving out of the basket, fell into the sea. It took its way into the sea (straight) as in a tunnel. Allah stopped the flow of water over the fish and it became like an arch (the Prophet pointed out this arch with his hands). They travelled the rest of the night, and the next day Moses said to his boy (servant), 'Give us our food, for indeed, we have suffered much fatigue in this journey of ours.' Moses did not feel tired till he crossed that place which Allah had ordered him to seek after. His boy (servant) said to him, 'Do you know that when we were sitting near that rock, I forgot the fish, and none but Satan caused me to forget to tell (you) about it, and it took its course into the sea in an amazing way?.' So there was a path for the fish and that astonished them. Moses said, 'That was what we were seeking after.' So, both of them retraced their footsteps till they reached the rock. There they saw a man Lying covered with a garment. Moses greeted him and he replied saying, 'How do people greet each other in your land?' Moses said, 'I am Moses.' The man asked, 'Moses of Bani Israel?' Moses said, 'Yes, I have come to you so that you may teach me from those things which Allah has taught you.' He said, 'O Moses! I have some of the Knowledge of Allah which Allah has taught me, and which you do not know, while you have some of the Knowledge of Allah which Allah has taught you and which I do not know.' Moses asked, 'May I follow you?' He said, 'But you will not be able to remain patient with me for how can you be patient about things which you will not be able to understand?' (Moses said, 'You will find me, if Allah so will, truly patient, and I will not disobey you in aught.') So, both of them set out walking along the sea-shore, a boat passed by them and they asked the crew of the boat to take them on board. The crew recognized Al-Khadir and so they took them on board without fare. When they were on board the boat, a sparrow came and stood on the edge of the boat and dipped its beak once or twice into the sea. Al-Khadir said to Moses, 'O Moses! My knowledge and your knowledge have not decreased Allah's Knowledge except as much as this sparrow has decreased the water of the sea with its beak.' Then suddenly Al-Khadir took an adze and plucked a plank, and Moses did not notice it till he had plucked a plank with the adze. Moses said to him, 'What have you done? They took us on board charging us nothing; yet you I have intentionally made a hole in their boat so as to drown its passengers. Verily, you have done a dreadful thing.' Al-Khadir replied, 'Did I not tell you that you would not be able to remain patient with me?' Moses replied, 'Do not blame me for what I have forgotten, and do not be hard upon me for my fault.' So the first excuse of Moses was that he had forgotten. When they had left the sea, they passed by a boy playing with other boys.

Al-Khadir took hold of the boys head and plucked it with his hand like this. (Sufyan, the sub narrator pointed with his fingertips as if he was plucking some fruit.) Moses said to him, "Have you killed an innocent person who has not killed any person? You have really done a horrible thing." Al-Khadir said, "Did I not tell you that you could not remain patient with me?' Moses said "If I ask you about anything after this, don't accompany me. You have received an excuse from me.' Then both of them went on till they came to some people of a village, and they asked its inhabitant for wood but they refused to entertain them as guests. Then they saw therein a wall which was just going to collapse (and Al Khadir repaired it just by touching it with his hands). (Sufyan, the sub-narrator, pointed with his hands, illustrating how Al-Khadir passed his hands over the wall upwards.) Moses said, "These are the people whom we have called on, but they neither gave us food, nor entertained us as guests, yet you have repaired their wall. If you had wished, you could have taken wages for it." Al-Khadir said, "This is the parting between you and me, and I shall tell you the explanation of those things on which you could not remain patient." The Prophet added, "We wished that Moses could have remained patient by virtue of which Allah might have told us more about their story. (Sufyan the sub-narrator said that the Prophet said, "May Allah bestow His Mercy on Moses! If he had remained patient, we would have been told further about their case.")


Bukhari :: Prophets :: [4.55.614]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 614

Narrated Abu Huraira:

The Prophet said, "Al-Khadir was named so because he sat over a barren white land, it turned green with plantation after (his sitting over it."


Bukhari :: Prophets :: [4.55.615]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 615

Narrated Abu Huraira:

Allah's Apostle said, "It was said to Bani Israel, Enter the gate (of the town) with humility (prostrating yourselves) and saying: "Repentance", but they changed the word and entered the town crawling on their buttocks and saying: "A wheat grain in the hair."


Bukhari :: Prophets :: [4.55.616]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 616

Narrated Abu Huraira:

Allah's Apostle said, "(The Prophet) Moses was a shy person and used to cover his body completely because of his extensive shyness. One of the children of Israel hurt him by saying, 'He covers his body in this way only because of some defect in his skin, either leprosy or scrotal hernia, or he has some other defect.' Allah wished to clear Moses of what they said about him, so one day while Moses was in seclusion, he took off his clothes and put them on a stone and started taking a bath. When he had finished the bath, he moved towards his clothes so as to take them, but the stone took his clothes and fled; Moses picked up his stick and ran after the stone saying, 'O stone! Give me my garment!' Till he reached a group of Bani Israel who saw him naked then, and found him the best of what Allah had created, and Allah cleared him of what they had accused him of. The stone stopped there and Moses took and put his garment on and started hitting the stone with his stick. By Allah, the stone still has some traces of the hitting, three, four or five marks. This was what Allah refers to in His Saying:-- "O you who believe! Be you not like those Who annoyed Moses, But Allah proved his innocence of that which they alleged, And he was honorable In Allah's Sight." (33.69)


Bukhari :: Prophets :: [4.55.617]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 617

Narrated Abdullah:

Once the Prophet distributed something (among his followers. A man said, "This distribution has not been done (with justice) seeking Allah's Countenance." I went to the Prophet and told him (of that). He became so angry that I saw the signs of anger oh his face. Then he said, "May Allah bestow His Mercy on Moses, for he was harmed more (in a worse manner) than this; yet he endured patiently."


Bukhari :: Prophets :: [4.55.618]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 618

Narrated Jabir bin 'Abdullah:

We were with Allah's Apostle picking the fruits of the 'Arak trees, and Allah's Apostle said, "Pick the black fruit, for it is the best." The companions asked, "Were you a shepherd?" He replied, "There was no prophet who was not a shepherd."


Bukhari :: Prophets :: [4.55.619]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 619

Narrated Abu Huraira:

The Angel of Death was sent to Moses when he came to Moses, Moses slapped him on the eye. The angel returned to his Lord and said, "You have sent me to a Slave who does not want to die." Allah said, "Return to him and tell him to put his hand on the back of an ox and for every hair that will come under it, he will be granted one year of life." Moses said, "O Lord! What will happen after that?" Allah replied, "Then death." Moses said, "Let it come now." Moses then requested Allah to let him die close to the Sacred Land so much so that he would be at a distance of a stone's throw from it." Abu Huraira added, "Allah's Apostle said, 'If I were there, I would show you his grave below the red sand hill on the side of the road."


Bukhari :: Prophets :: [4.55.620]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 620

Narrated Abu Huraira:

A Muslim and a Jew quarreled. The Muslim taking an oath, said, "By Him Who has preferred Muhammad over all people...!" The Jew said, "By Him Who has preferred Moses, over all people." The Muslim raised his hand and slapped the Jew who came to the Prophet to tell him what had happened between him and the Muslim. The Prophet said, "Don't give me superiority over Moses, for the people will become unconscious (on the Day of Resurrection) and I will be the first to gain consciousness to see Moses standing and holding a side of Allah's Throne. I will not know if he has been among those people who have become unconscious; and that he has gained consciousness before me, or he has been amongst those whom Allah has exempted."


Bukhari :: Prophets :: [4.55.621]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 621

Narrated Abu Huraira:

Allah's Apostle said, "Adam and Moses argued with each other. Moses said to Adam. 'You are Adam whose mistake expelled you from Paradise.' Adam said to him, 'You are Moses whom Allah selected as His Messenger and as the one to whom He spoke directly; yet you blame me for a thing which had already been written in my fate before my creation?"' Allah's Apostle said twice, "So, Adam overpowered Moses."


Bukhari :: Prophets :: [4.55.622]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 622

Narrated Ibn Abbas:

The Prophet once came to us and said, "All the nations were displayed in front of me, and I saw a large multitude of people covering the horizon. Somebody said, 'This is Moses and his followers.' "


Bukhari :: Prophets :: [4.55.623]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 623

Narrated Abu Musa:

Allah's Apostle said, "Many amongst men reached (the level of) perfection but none amongst the women reached this level except Asia, Pharaoh's wife, and Mary, the daughter of 'Imran. And no doubt, the superiority of 'Aisha to other women is like the superiority of Tharid (i.e. a meat and bread dish) to other meals."


Bukhari :: Prophets :: [4.55.624]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 624

Narrated 'Abdullah:

The Prophet said, "None of you should say that I am better than Yunus (i.e. Jonah)." Musadded added, "Jonah bin Matta."


Bukhari :: Prophets :: [4.55.625]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 625

Narrated Ibn 'Abbas:

The Prophet said, "No slave (of Allah) should say that I am better than Yunus bin Matta." So the Prophet mentioned his father's name with his name.


Bukhari :: Prophets :: [4.55.626]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 626

Narrated Abu Huraira:

Once while a Jew was selling something, he was offered a price that he was not pleased with. So, he said, "No, by Him Who gave Moses superiority over all human beings!" Hearing him, an Ansari man got up and slapped him on the face and said, "You say: By Him Who Gave Moses superiority over all human beings although the Prophet (Muhammad) is present amongst us!" The Jew went to the Prophet and said, "O Abu-l-Qasim! I am under the assurance and contract of security, so what right does so-and-so have to slap me?" The Prophet asked the other, "Why have you slapped". He told him the whole story. The Prophet became angry, till anger appeared on his face, and said, "Don't give superiority to any prophet amongst Allah's Prophets, for when the trumpet will be blown, everyone on the earth and in the heavens will become unconscious except those whom Allah will exempt. The trumpet will be blown for the second time and I will be the first to be resurrected to see Moses holding Allah's Throne. I will not know whether the unconsciousness which Moses received on the Day of Tur has been sufficient for him, or has he got up before me. And I do not say that there is anybody who is better than Yunus bin Matta."


Bukhari :: Prophets :: [4.55.627]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 627

Narrated Abu Huraira:

The Prophet said, "None should say that I am better than Yunus bin Matta."


Bukhari :: Prophets :: [4.55.628]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 628

Narrated Abu Huraira:

The Prophet said, "The reciting of the Zabur (i.e. Psalms) was made easy for David. He used to order that his riding animals be saddled, and would finish reciting the Zabur before they were saddled. And he would never eat except from the earnings of his manual work."


Bukhari :: Prophets :: [4.55.629]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 629

Narrated Abdullah bin Amr:

Allah's Apostle was informed that I have said: "By Allah, I will fast all the days and pray all the nights as long as I live." On that, Allah's Apostle asked me. "Are you the one who says: 'I will fast all the days and pray all the nights as long as I live?' " I said, "Yes, I have said it." He said, "You cannot do that. So fast (sometimes) and do not fast (sometimes). Pray and sleep. Fast for three days a month, for the reward of a good deed is multiplied by ten time, and so the fasting of three days a month equals the fasting of a year." I said, "O Allah's Apostle! I can do (fast) more than this." He said, "Fast on every third day. I said: I can do (fast) more than that, He said: "Fast on alternate days and this was the fasting of David which is the most moderate sort of fasting." I said, "O Allah's Apostle! I can do (fast) more than that." He said, "There is nothing better than that."


Bukhari :: Prophets :: [4.55.630]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 630

Narrated Abdullah bin Amr bin Al-As:

The Prophet said to me, "I have been informed that you pray all the nights and observe fast all the days; is this true?" I replied, "Yes." He said, "If you do so, your eyes will become weak and you will get bored. So fast three days a month, for this will be the fasting of a whole year, or equal to the fasting of a whole year." I said, "I find myself able to fast more." He said, "Then fast like the fasting of (the Prophet) David who used to fast on alternate days and would not flee on facing the enemy."


Bukhari :: Prophets :: [4.55.631]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 631

Narrated Abdullah bin Amr:

Allah's Apostle said to me, "The most beloved fasting to Allah was the fasting of (the Prophet) David who used to fast on alternate days. And the most beloved prayer to Allah was the prayer of David who used to sleep for (the first) half of the night and pray for 1/3 of it and (again) sleep for a sixth of it."


Bukhari :: Prophets :: [4.55.632]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 632

Narrated Mujahid:

I asked Ibn 'Abbas, "Should we perform a prostration on reciting Surat-Sad?" He recited (the Sura) including: 'And among his progeny, David, Solomon..(up to)...so follow their guidance (6.84-91) And then he said, "Your Prophet is amongst those people who have been ordered to follow them (i.e. the preceding apostles).


Bukhari :: Prophets :: [4.55.633]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 633

Narrated Ibn Abbas:

The prostration in Sura-Sad is not amongst the compulsory prostrations, though I saw the Prophet prostrating on reciting The Statement of Allah:--and to David We gave Solomon (for a son). How excellent (a) slave he was ever oft-returning in repentance (to us) (38.30) And His Statement:-- He said: My Lord Forgive me and grant me a kingdom such as shall not belong to any other after me.' (38.35) And His Statement:-- 'And they followed what the Devils gave out (falsely), of magic in the life-time of Solomon.' (2.102)


Bukhari :: Prophets :: [4.55.634]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 634

Narrated Abu Huraira:

The Prophet said, "A strong demon from the Jinns came to me yesterday suddenly, so as to spoil my prayer, but Allah enabled me to overpower him, and so I caught him and intended to tie him to one of the pillars of the Mosque so that all of you might see him, but I remembered the invocation of my brother Solomon: 'And grant me a kingdom such as shall not belong to any other after me.' (38.35) so I let him go cursed."


Bukhari :: Prophets :: [4.55.635]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 635

Narrated Abu Huraira:

The Prophet said, "Solomon (the son of) David said, 'Tonight I will sleep with seventy ladies each of whom will conceive a child who will be a knight fighting for "Allah's Cause.' His companion said, 'If Allah will.' But Solomon did not say so; therefore none of those women got pregnant except one who gave birth to a half child." The Prophet further said, "If the Prophet Solomon had said it (i.e. 'If Allah will') he would have begotten children who would have fought in Allah's Cause." Shuaib and Ibn Abi Az-Zinad said, "Ninety (women) is more correct (than seventy)."


Bukhari :: Prophets :: [4.55.636]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 636

Narrated Abu Dhaar:

I said, "O Allah's Apostle! Which mosque was built first?" He replied, "Al-Masjid-ul-Haram." I asked, "Which (was built) next?" He replied, "Al-Masjid-ul-Aqs-a (i.e. Jerusalem)." I asked, "What was the period in between them?" He replied, "Forty (years)." He then added, "Wherever the time for the prayer comes upon you, perform the prayer, for all the earth is a place of worshipping for you."


Bukhari :: Prophets :: [4.55.637]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 637

Narrated Abu Huraira:

Allah's Apostle said, "My example and the example o the people is like that of a person who lit a fire and let the moths, butterflies and these insects fall in it." He also said, "There were two women, each of whom had a child with her. A wolf came and took away the child of one of them, whereupon the other said, 'It has taken your child.' The first said, 'But it has taken your child.' So they both carried the case before David who judged that the living child be given to the elder lady. So both of them went to Solomon bin David and informed him (of the case). He said, 'Bring me a knife so as to cut the child into two pieces and distribute it between them.' The younger lady said, 'May Allah be merciful to you! Don't do that, for it is her (i.e. the other lady's) child.' So he gave the child to the younger lady."


Bukhari :: Prophets :: [4.55.638]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 638

Narrated 'Abdullah:

When the Verse:-- 'Those who believe and mix not their belief with wrong." was revealed, the companions of the Prophet said, "Who amongst us has not mixed his belief with wrong?" Then Allah revealed: "Join none in worship with Allah, Verily joining others in worship with Allah is a great wrong indeed."


Bukhari :: Prophets :: [4.55.639]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 639

Narrated 'Abdullah:

When the Verse:-- 'Those who believe and mix not their belief with wrong.' was revealed, the Muslims felt it very hard on them and said, "O Allah's Apostle! Who amongst us does not do wrong to himself?" He replied, "The Verse does not mean this. But that (wrong) means to associate others in worship to Allah: Don't you listen to what Luqman said to his son when he was advising him," O my son! Join not others in worship with Allah. Verily joining others in worship with Allah is a great wrong indeed." (31.13)


Bukhari :: Prophets :: [4.55.640]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 640

Narrated Malik bin Sasaa:

That the Prophet talked to them about the night of his Ascension to the Heavens. He said, "(Then Gabriel took me) and ascended up till he reached the second heaven where he asked for the gate to be opened, but it was asked, 'Who is it?' Gabriel replied, 'I am Gabriel.' It was asked, 'Who is accompanying you?' He replied, 'Muhammad.' It was asked, 'Has he been called?' He said, 'Yes.' When we reached over the second heaven, I saw Yahya (i.e. John) and Jesus who were cousins. Gabriel said, 'These are John (Yahya) and Jesus, so greet them.' I greeted them and they returned the greeting saying, 'Welcome, O Pious Brother and Pious Prophet!;' "


Bukhari :: Prophets :: [4.55.641]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 641

Narrated Said bin Al-Musaiyab:

Abu Huraira said, "I heard Allah's Apostle saying, 'There is none born among the off-spring of Adam, but Satan touches it. A child therefore, cries loudly at the time of birth because of the touch of Satan, except Mary and her child." Then Abu Huraira recited: "And I seek refuge with You for her and for her offspring from the outcast Satan" (3.36)


Bukhari :: Prophets :: [4.55.642]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 642

Narrated 'Ali:

I heard the Prophet saying, "Mary, the daughter of 'Imran, was the best among the women (of the world of her time) and Khadija is the best amongst the women. (of this nation)."


Bukhari :: Prophets :: [4.55.643]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 643

Narrated Abu Musa Al-Ashari:

The Prophet said, "The superiority of 'Aisha to other ladies is like the superiority of Tharid (i.e. meat and bread dish) to other meals. Many men reached the level of perfection, but no woman reached such a level except Mary, the daughter of Imran and Asia, the wife of Pharaoh."

Narrated Abu Huraira: I heard Allah's Apostle saying, "Amongst all those women who ride camels (i.e. Arabs), the ladies of Quraish are the best. They are merciful and kind to their off-spring and the best guardians of their husbands' properties.' Abu Huraira added, "Mary the daughter of Imran never rode a camel."


Bukhari :: Prophets :: [4.55.644]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 644

Narrated 'Ubada:

The Prophet said, "If anyone testifies that None has the right to be worshipped but Allah Alone Who has no partners, and that Muhammad is His Slave and His Apostle, and that Jesus is Allah's Slave and His Apostle and His Word which He bestowed on Mary and a Spirit created by Him, and that Paradise is true, and Hell is true, Allah will admit him into Paradise with the deeds which he had done even if those deeds were few." (Junada, the sub-narrator said, " 'Ubada added, 'Such a person can enter Paradise through any of its eight gates he likes.")


Bukhari :: Prophets :: [4.55.645]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 645

Narrated Abu Huraira:

The Prophet said, "None spoke in cradle but three: (The first was) Jesus, (the second was), there a man from Bani Israel called Juraij. While he was offering his prayers, his mother came and called him. He said (to himself), 'Shall I answer her or keep on praying?" (He went on praying) and did not answer her, his mother said, "O Allah! Do not let him die till he sees the faces of prostitutes." So while he was in his hermitage, a lady came and sought to seduce him, but he refused. So she went to a shepherd and presented herself to him to commit illegal sexual intercourse with her and then later she gave birth to a child and claimed that it belonged to Juraij. The people, therefore, came to him and dismantled his hermitage and expelled him out of it and abused him. Juraij performed the ablution and offered prayer, and then came to the child and said, 'O child! Who is your father?' The child replied, 'The shepherd.' (After hearing this) the people said, 'We shall rebuild your hermitage of gold,' but he said, 'No, of nothing but mud.'(The third was the hero of the following story) A lady from Bani Israel was nursing her child at her breast when a handsome rider passed by her. She said, 'O Allah ! Make my child like him.' On that the child left her breast, and facing the rider said, 'O Allah! Do not make me like him.' The child then started to suck her breast again. (Abu Huraira further said, "As if I were now looking at the Prophet sucking his finger (in way of demonstration.") After a while the people passed by, with a lady slave and she (i.e. the child's mother) said, 'O Allah! Do not make my child like this (slave girl)!, On that the child left her breast and said, 'O Allah! Make me like her.' When she asked why, the child replied, 'The rider is one of the tyrants while this slave girl is falsely accused of theft and illegal sexual intercourse."


Bukhari :: Prophets :: [4.55.646]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 646

Narrated Hisham:

from Ma'mar as below.


Bukhari :: Prophets :: [4.55.647]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 647

Narrated Abu Huraira:

The Prophet said, "I met Moses on the night of my Ascension to heaven." The Prophet then described him saying, as I think, "He was a tall person with lank hair as if he belonged to the people of the tribe of Shanu's.' The Prophet further said, "I met Jesus." The Prophet described him saying, "He was one of moderate height and was red-faced as if he had just come out of a bathroom. I saw Abraham whom I resembled more than any of his children did." The Prophet further said, "(That night) I was given two cups; one full of milk and the other full of wine. I was asked to take either of them which I liked, and I took the milk and drank it. On that it was said to me, 'You have taken the right path (religion). If you had taken the wine, your (Muslim) nation would have gone astray."


Bukhari :: Prophets :: [4.55.648]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 648

Narrated Ibn Umar:

The Prophet said, "I saw Moses, Jesus and Abraham (on the night of my Ascension to the heavens). Jesus was of red complexion, curly hair and a broad chest. Moses was of brown complexion, straight hair and tall stature as if he was from the people of Az-Zutt."


Bukhari :: Prophets :: [4.55.649]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 649

Narrated Abdullah:

The Prophet mentioned the Massiah Ad-Dajjal in front of the people saying, Allah is not one eyed while Messsiah, Ad-Dajjal is blind in the right eye and his eye looks like a bulging out grape. While sleeping near the Ka'ba last night, I saw in my dream a man of brown color the best one can see amongst brown color and his hair was long that it fell between his shoulders. His hair was lank and water was dribbling from his head and he was placing his hands on the shoulders of two men while circumambulating the Kaba. I asked, 'Who is this?' They replied, 'This is Jesus, son of Mary.' Behind him I saw a man who had very curly hair and was blind in the right eye, resembling Ibn Qatan (i.e. an infidel) in appearance. He was placing his hands on the shoulders of a person while performing Tawaf around the Ka'ba. I asked, 'Who is this? 'They replied, 'The Masih, Ad-Dajjal.' "


Bukhari :: Prophets :: [4.55.650]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 650

Narrated Salim from his father:

No, By Allah, the Prophet did not tell that Jesus was of red complexion but said, "While I was asleep circumambulating the Ka'ba (in my dream), suddenly I saw a man of brown complexion and lank hair walking between two men, and water was dropping from his head. I asked, 'Who is this?' The people said, 'He is the son of Mary.' Then I looked behind and I saw a red-complexioned, fat, curly-haired man, blind in the right eye which looked like a bulging out grape. I asked, 'Who is this?' They replied, 'He is Ad-Dajjal.' The one who resembled to him among the people, was Ibn Qatar." (Az-Zuhri said, "He (i.e. Ibn Qatan) was a man from the tribe Khuza'a who died in the pre-lslamic period.")


Bukhari :: Prophets :: [4.55.651]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 651

Narrated Abu Huraira:

I heard Allah's Apostle saying, "I am the nearest of all the people to the son of Mary, and all the prophets are paternal brothers, and there has been no prophet between me and him (i.e. Jesus)."


Bukhari :: Prophets :: [4.55.652]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 652

Narrated Abu Huraira:

Allah's Apostle said, "Both in this world and in the Hereafter, I am the nearest of all the people to Jesus, the son of Mary. The prophets are paternal brothers; their mothers are different, but their religion is one."


Bukhari :: Prophets :: [4.55.653]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 653

Narrated Abu Huraira:

The Prophet said, "Jesus, seeing a man stealing, asked him, 'Did you steal?, He said, 'No, by Allah, except Whom there is None who has the right to be worshipped' Jesus said, 'I believe in Allah and suspect my eyes."


Bukhari :: Prophets :: [4.55.654]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 654

Narrated 'Umar:

I heard the Prophet saying, "Do not exaggerate in praising me as the Christians praised the son of Mary, for I am only a Slave. So, call me the Slave of Allah and His Apostle."


Bukhari :: Prophets :: [4.55.655]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 655

Narrated Abu Musa Al-Ash'ari:

Allah's Apostle said, "If a person teaches his slave girl good manners properly, educates her properly, and then manumits and marries her, he will get a double reward. And if a man believes in Jesus and then believes in me, he will get a double reward. And if a slave fears his Lord (i.e. Allah) and obeys his masters, he too will get a double reward."


Bukhari :: Prophets :: [4.55.656]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 656

Narrted Ibn Abbas:

Allah's Apostle said, "You will be resurrected (and assembled) bare-footed, naked and uncircumcised." The Prophet then recited the Divine Verse:-- "As We began the first creation, We shall repeat it: A promise We have undertaken. Truly we shall do it." (21.104)

He added, "The first to be dressed will be Abraham. Then some of my companions will take to the right and to the left. I will say: 'My companions! 'It will be said, 'They had been renegades since you left them.' I will then say what the Pious Slave Jesus, the son of Mary said: 'And I was a witness over them while I dwelt amongst them; when You did take me up, You were the Watcher over them, and You are a Witness to all things. If You punish them, they are Your slaves, and if you forgive them, You, only You are the All-Mighty the All-Wise.' " (5.117-118) Narrated Quaggas, "Those were the apostates who renegade from Islam during the Caliphate of Abu Bakr who fought them".


Bukhari :: Prophets :: [4.55.657]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 657

Narrated Abu Huraira:

Allah's Apostle said, "By Him in Whose Hands my soul is, surely (Jesus,) the son of Mary will soon descend amongst you and will judge mankind justly (as a Just Ruler); he will break the Cross and kill the pigs and there will be no Jizya (i.e. taxation taken from non Muslims). Money will be in abundance so that nobody will accept it, and a single prostration to Allah (in prayer) will be better than the whole world and whatever is in it." Abu Huraira added "If you wish, you can recite (this verse of the Holy Book): -- 'And there is none Of the people of the Scriptures (Jews and Christians) But must believe in him (i.e Jesus as an Apostle of Allah and a human being) Before his death. And on the Day of Judgment He will be a witness Against them." (4.159) (See Fateh Al Bari, Page 302 Vol 7)


Bukhari :: Prophets :: [4.55.658]

Prophets

Bukhari :: Book 4 :: Volume 55 :: Hadith 658

Narrated Abu Huraira:

Allah's Apostle said "How will you be when the son of Mary (i.e. Jesus) descends amongst you and he will judge people by the Law of the Quran and not by the law of Gospel (Fateh-ul Bari page 304 and 305 Vol 7)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.659]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 659

Narrated Rabi bin Hirash:

'Uqba bin 'Amr said to Hudhaifa, "Won't you relate to us of what you have heard from Allah's Apostle ?" He said, "I heard him saying, "When Al-Dajjal appears, he will have fire and water along with him. What the people will consider as cold water, will be fire that will burn (things). So, if anyone of you comes across this, he should fall in the thing which will appear to him as fire, for in reality, it will be fresh cold water." Hudhaifa added, "I also heard him saying, 'From among the people preceding your generation, there was a man whom the angel of death visited to capture his soul. (So his soul was captured) and he was asked if he had done any good deed.' He replied, 'I don't remember any good deed.' He was asked to think it over. He said, 'I do not remember, except that I used to trade with the people in the world and I used to give a respite to the rich and forgive the poor (among my debtors). So Allah made him enter Paradise." Hudhaifa further said, "I also heard him saying, 'Once there was a man on his death-bed, who, losing every hope of surviving said to his family: When I die, gather for me a large heap of wood and make a fire (to burn me). When the fire eats my meat and reaches my bones, and when the bones burn, take and crush them into powder and wait for a windy day to throw it (i.e. the powder) over the sea. They did so, but Allah collected his particles and asked him:

Why did you do so? He replied: For fear of You. So Allah forgave him." 'Uqba bin 'Amr said, "I heard him saying that the Israeli used to dig the grave of the dead (to steal their shrouds)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.660]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 660

Narrated 'Aisha and Ibn 'Abbas:

On his death-bed Allah's Apostle put a sheet over his-face and when he felt hot, he would remove it from his face. When in that state (of putting and removing the sheet) he said, "May Allah's Curse be on the Jews and the Christians for they build places of worship at the graves of their prophets." (By that) he intended to warn (the Muslim) from what they (i.e. Jews and Christians) had done.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.661]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 661

Narrated Abu Huraira:

The Prophet said, "The Israelis used to be ruled and guided by prophets: Whenever a prophet died, another would take over his place. There will be no prophet after me, but there will be Caliphs who will increase in number." The people asked, "O Allah's Apostle! What do you order us (to do)?" He said, "Obey the one who will be given the pledge of allegiance first. Fulfil their (i.e. the Caliphs) rights, for Allah will ask them about (any shortcoming) in ruling those Allah has put under their guardianship."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.662]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 662

Narrated Abu Said:

The Prophet said, "You will follow the wrong ways, of your predecessors so completely and literally that if they should go into the hole of a mastigure, you too will go there." We said, "O Allah's Apostle! Do you mean the Jews and the Christians?" He replied, "Whom else?" (Meaning, of course, the Jews and the Christians.)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.663]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 663

Narrated Anas:

The people mentioned the fire and the bell (as means proposed for announcing the time of prayer) and by such a suggestion they referred to the Jews and the Christians. But Bilal was ordered, "Pronounce the words of the Adhan (i.e. call for the prayer) twice and the Iqama once only."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.664]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 664

Narrated 'Aisha:

That she used to hate that one should keep his hands on his flanks while praying. She said that the Jew used to do so.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.665]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 665

Narrated Ibn Umar:

Allah's Apostle said, "Your period (i.e. the Muslims' period) in comparison to the periods of the previous nations, is like the period between the 'Asr prayer and sunset. And your example in comparison to the Jews and the Christians is like the example of a person who employed some laborers and asked them, 'Who will work for me till midday for one Qirat each?' The Jews worked for half a day for one Qirat each. The person asked, 'Who will do the work for me from midday to the time of the 'Asr (prayer) for one Qirat each?' The Christians worked from midday till the 'Asr prayer for one Qirat. Then the person asked, 'Who will do the work for me from the 'Asr till sunset for two Qirats each?' " The Prophet added, "It is you (i.e. Muslims) who are doing the work from the Asr till sunset, so you will have a double reward. The Jews and the Christians got angry and said, 'We have done more work but got less wages.' Allah said, 'Have I been unjust to you as regards your rights?' They said, 'No.' So Allah said, 'Then it is My Blessing which I bestow on whomever I like. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.666]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 666

Narrated Ibn Abbas:

I heard 'Umar saying, "May Allah Curse so-and-so! Doesn't he know that the Prophet said, 'May Allah curse the Jews for, though they were forbidden (to eat) fat, they liquefied it and sold it. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.667]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 667

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Convey (my teachings) to the people even if it were a single sentence, and tell others the stories of Bani Israel (which have been taught to you), for it is not sinful to do so. And whoever tells a lie on me intentionally, will surely take his place in the (Hell) Fire."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.668]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 668

Narrated Abu Huraira:

Allah's Apostle said, "The Jews and the Christians do not dye (their grey hair), so you shall do the opposite of what they do (i.e. dye your grey hair and beards)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.669]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 669

Narrated Jundub:

Allah's Apostle said, "Amongst the nations before you there was a man who got a wound, and growing impatient (with its pain), he took a knife and cut his hand with it and the blood did not stop till he died. Allah said, 'My Slave hurried to bring death upon himself so I have forbidden him (to enter) Paradise.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.670]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 670

Narrated Abu Huraira:

that he heard Allah's Apostle saying, "Allah willed to test three Israelis who were a Leper, a blind man and a bald-headed man. So, he sent them an angel who came to the leper and said, 'What thing do you like most?' He replied, "Good color and good skin, for the people have a strong aversion to me.' The angel touched him and his illness was cured, and he was given a good color and beautiful skin. The angel asked him, 'What kind of property do you like best?' He replied, 'Camels (or cows).' (The narrator is in doubt, for either the leper or the bald-headed man demanded camels and the other demanded cows.) So he (i.e. the leper) was given a pregnant she-camei, and the angel said (to him), 'May Allah bless you in it.'

The angel then went to the bald-headed man and said, 'What thing do you like most?' He said, 'I like good hair and wish to be cured of this disease, for the people feel repulsion for me.' The angel touched him and his illness was cured, and he was given good hair. The angel asked (him), 'What kind of property do you like bests' He replied, 'Cows,' The angel gave him a pregnant cow and said, 'May Allah bless you in it.' The angel went to the blind man and asked, 'What thing do you like best?' He said, '(I like) that Allah may restore my eye-sight to me so that I may see the people.' The angel touched his eyes and Allah gave him back his eye-sight. The angel asked him, "What kind of property do you like best?' He replied, 'Sheep.' The angel gave him a pregnant sheep. Afterwards, all the three pregnant animals gave birth to young ones, and multiplied and brought forth so much that one of the (three) men had a herd of camels filling a valley, and one had a herd of cows filling a valley, and one had a flock of sheep filling a valley. Then the angel, disguised in the shape and appearance of a leper, went to the leper and said, I am a poor man, who has lost all means of livelihood while on a journey. So none will satisfy my need except Allah and then you. In the Name of Him Who has given you such nice color and beautiful skin, and so much property, I ask you to give me a camel so that I may reach my destination. The man replied, 'I have many obligations (so I cannot give you).' The angel said, 'I think I know you; were you not a leper to whom the people had a strong aversion? Weren't you a poor man, and then Allah gave you (all this property).' He replied, '(This is all wrong), I got this property through inheritance from my fore-fathers' The angel said, 'If you are telling a lie, then let Allah make you as you were before. '

Then the angel, disguised in the shape and appearance of a bald man, went to the bald man and said to him the same as he told the first one, and he too answered the same as the first one did. The angel said, 'If you are telling a lie, then let Allah make you as you were before.'

The angel, disguised in the shape of a blind man, went to the blind man and said, 'I am a poor man and a traveler, whose means of livelihood have been exhausted while on a journey. I have nobody to help me except Allah, and after Him, you yourself. I ask you in the Name of Him Who has given you back your eye-sight to give me a sheep, so that with its help, I may complete my journey' The man said, 'No doubt, I was blind and Allah gave me back my eye-sight; I was poor and Allah made me rich; so take anything you wish from my property. By Allah, I will not stop you for taking anything (you need) of my property which you may take for Allah's sake.' The angel replied, 'Keep your property with you. You (i.e 3 men) have been tested and Allah is pleased with you and is angry with your two companions."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.671]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 671

Narrated Ibn Umar:

Allah's Apostle said, "Once three persons (from the previous nations) were traveling, and suddenly it started raining and they took shelter in a cave. The entrance of the cave got closed while they were inside. They said to each other, 'O you! Nothing can save you except the truth, so each of you should ask Allah's Help by referring to such a deed as he thinks he did sincerely (i.e. just for gaining Allah's Pleasure).' So one of them said, 'O Allah! You know that I had a laborer who worked for me for one Faraq (i.e. three Sas) of rice, but he departed, leaving it (i.e. his wages). I sowed that Faraq of rice and with its yield I bought cows (for him). Later on when he came to me asking for his wages, I said (to him), 'Go to those cows and drive them away.' He said to me, 'But you have to pay me only a Faraq of rice,' I said to him, 'Go to those cows and take them, for they are the product of that Faraq (of rice).' So he drove them. O Allah! If you consider that I did that for fear of You, then please remove the rock.' The rock shifted a bit from the mouth of the cave. The second one said, 'O Allah, You know that I had old parents whom I used to provide with the milk of my sheep every night. One night I was delayed and when I came, they had slept, while my wife and children were crying with hunger. I used not to let them (i.e. my family) drink unless my parents had drunk first. So I disliked to wake them up and also disliked that they should sleep without drinking it, I kept on waiting (for them to wake) till it dawned. O Allah! If You consider that I did that for fear of you, then please remove the rock.' So the rock shifted and they could see the sky through it. The (third) one said, 'O Allah! You know that I had a cousin (i.e. my paternal uncle's daughter) who was most beloved to me and I sought to seduce her, but she refused, unless I paid her one-hundred Dinars (i.e. gold pieces). So I collected the amount and brought it to her, and she allowed me to sleep with her. But when I sat between her legs, she said, 'Be afraid of Allah, and do not deflower me but legally. 'I got up and left the hundred Dinars (for her). O Allah! If You consider that I did that for fear of you than please remove the rock. So Allah saved them and they came out (of the cave)." (This Hadith indicates that one can only ask Allah for help directly or through his performed good deeds. But to ask Allah through dead or absent prophets, saints, spirits, holy men, angels etc. is absolutely forbidden in Islam and it is a kind of disbelief.)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.672]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 672

Narrated Abu Huraira:

That he heard Allah's Apostle saying, "While a lady was nursing her child, a rider passed by and she said, 'O Allah! Don't let my child die till he becomes like this (rider).' The child said, 'O Allah! Don't make me like him,' and then returned to her breast (sucking it). (After a while) they passed by a lady who was being pulled and teased (by the people). The child's mother said, 'O Allah! Do not make my child like her.' The child said, 'O Allah! Make me like her.' Then he said, 'As for the rider, he is an infidel, while the lady is accused of illegal sexual intercourse (falsely) and she says: Allah is sufficient for me (He knows the truth)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.673]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 673

Narrated Abu Huraira:

The Prophet said, "While a dog was going round a well and was about to die of thirst, an Israeli prostitute saw it and took off her shoe and watered it. So Allah forgave her because of that good deed."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.674]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 674

Narrated Humaid bin 'Abdur-Rahman:

That he heard Muawiya bin Abi Sufyan (talking) on the pulpit in the year when he performed the Hajj. He took a tuft of hair that was in the hand of an orderly and said, "O people of Medina! Where are your learned men? I heard the Prophet forbidding such a thing as this (i.e. false hair) and he used to say, 'The Israelis were destroyed when their ladies practiced this habit (of using false hair to lengthen their locks)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.675]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 675

Narrated Abu Huraira:

The Prophet said, "Amongst the people preceding you there used to be 'Muhaddithun' (i.e. persons who can guess things that come true later on, as if those persons have been inspired by a divine power), and if there are any such persons amongst my followers, it is 'Umar bin Al-Khattab."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.676]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 676

Narrated Abu Said Al-Khudri:

The Prophet said, "Amongst the men of Bani Israel there was a man who had murdered ninety-nine persons. Then he set out asking (whether his repentance could be accepted or not). He came upon a monk and asked him if his repentance could be accepted. The monk replied in the negative and so the man killed him. He kept on asking till a man advised to go to such and such village. (So he left for it) but death overtook him on the way. While dying, he turned his chest towards that village (where he had hoped his repentance would be accepted), and so the angels of mercy and the angels of punishment quarrelled amongst themselves regarding him. Allah ordered the village (towards which he was going) to come closer to him, and ordered the village (whence he had come), to go far away, and then He ordered the angels to measure the distances between his body and the two villages. So he was found to be one span closer to the village (he was going to). So he was forgiven."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.677]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 677

Narrated Abu Huraira:

Once Allah's Apostle; offered the morning prayer and then faced the people and said, "While a man was driving a cow, he suddenly rode over it and beat it. The cow said, "We have not been created for this, but we have been created for sloughing." On that the people said astonishingly, "Glorified be Allah! A cow speaks!" The Prophet said, "I believe this, and Abu Bakr and 'Umar too, believe it, although neither of them was present there. While a person was amongst his sheep, a wolf attacked and took one of the sheep. The man chased the wolf till he saved it from the wolf, where upon the wolf said, 'You have saved it from me; but who will guard it on the day of the wild beasts when there will be no shepherd to guard them except me (because of riots and afflictions)? ' " The people said surprisingly, "Glorified be Allah! A wolf speaks!" The Prophet said, "But I believe this, and Abu Bakr and 'Umar too, believe this, although neither of them was present there." (See the Foot-note of page No. 10 Vol.5)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.678]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 678

Narrated Abu Huraira:

Allah's Apostle said, "A man bought a piece of and from another man, and the buyer found an earthenware jar filled with gold in the land. The buyer said to the seller. 'Take your gold, as I have bought only the land from you, but I have not bought the gold from you.' The (former) owner of the land said, "I have sold you the land with everything in it.' So both of them took their case before a man who asked, 'Do you have children?' One of them said, "I have a boy.' The other said, "I have a girl.' The man said, 'Marry the girl to the boy and spend the money on both of them and give the rest of it in charity.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.679]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 679

Narrated Usama bin Zaid:

Allah's Apostle said, "Plague was a means of torture sent on a group of Israelis (or on some people before you). So if you hear of its spread in a land, don't approach it, and if a plague should appear in a land where you are present, then don't leave that land in order to run away from it (i.e. plague)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.680]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 680

Narrated 'Aisha:

(the wife of the Prophet) I asked Allah's Apostle about the plague. He told me that it was a Punishment sent by Allah on whom he wished, and Allah made it a source of mercy for the believers, for if one in the time of an epidemic plague stays in his country patiently hoping for Allah's Reward and believing that nothing will befall him except what Allah has written for him, he will get the reward of a martyr."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.681]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 681

Narrated 'Aisha:

The people of Quraish worried about the lady from Bani Makhzum who had committed theft. They asked, "Who will intercede for her with Allah's Apostle?" Some said, "No one dare to do so except Usama bin Zaid the beloved one to Allah's Apostle ." When Usama spoke about that to Allah's Apostle Allah's Apostle said, (to him), "Do you try to intercede for somebody in a case connected with Allah's Prescribed Punishments?" Then he got up and delivered a sermon saying, "What destroyed the nations preceding you, was that if a noble amongst them stole, they would forgive him, and if a poor person amongst them stole, they would inflict Allah's Legal punishment on him. By Allah, if Fatima, the daughter of Muhammad stole, I would cut off her hand."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.682]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 682

Narrated Ibn Mas'ud:

I heard a person reciting a (Quranic) Verse in a certain way, and I had heard the Prophet reciting the same Verse in a different way. So I took him to the Prophet and informed him of that but I noticed the sign of disapproval on his face, and then he said, "Both of you are correct, so don't differ, for the nations before you differed, so they were destroyed."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.683]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 683

Narrated 'Abdullah:

As if I saw the Prophet talking about one of the prophets whose nation had beaten him and caused him to bleed, while he was cleaning the blood off his face and saying, "O Allah! Forgive my nation, for they have no knowledge."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.684]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 684

Narrated Abu Sa'id:

The Prophet said, "Amongst the people preceding your age, there was a man whom Allah had given a lot of money. While he was in his death-bed, he called his sons and said, 'What type of father have I been to you? They replied, 'You have been a good father.' He said, 'I have never done a single good deed; so when I die, burn me, crush my body, and scatter the resulting ashes on a windy day.' His sons did accordingly, but Allah gathered his particles and asked (him), 'What made you do so?' He replied, "Fear of you.' So Allah bestowed His Mercy upon him. (forgave him)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.685]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 685

Narrated Ribi bin Hirash:

'Uqba said to Hudhaifa, "Won't you narrate to us what you heard from Allah's Apostle ?" Hudhaifa said, "I heard him saying, 'Death approached a man and when he had no hope of surviving, he said to his family, 'When I die, gather for me much wood and build a fire (to burn me),. When the fire has eaten my flesh and reached my bones, take the bones and grind them and scatter the resulting powder in the sea on a hot (or windy) day.' (That was done.) But Allah collected his particles and asked (him), 'Why did you do so?' He replied, 'For fear of You.' So Allah forgave him."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.686]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 686

Narrated 'Abdu Malik:

as above, saying, "On a windy day."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.687]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 687

Narrated Abu Huraira:

Allah's Apostle said, "A man used to give loans to the people and used to say to his servant, 'If the debtor is poor, forgive him, so that Allah may forgive us.' So when he met Allah (after his death), Allah forgave him."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.688]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 688

Narrated Abu Huraira:

The Prophet said, "A man used to do sinful deeds, and when death came to him, he said to his sons, 'After my death, burn me and then crush me, and scatter the powder in the air, for by Allah, if Allah has control over me, He will give me such a punishment as He has never given to anyone else.' When he died, his sons did accordingly. Allah ordered the earth saying, 'Collect what you hold of his particles.' It did so, and behold! There he was (the man) standing. Allah asked (him), 'What made you do what you did?' He replied, 'O my Lord! I was afraid of You.' So Allah forgave him. " Another narrator said "The man said, Fear of You, O Lord!"


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.689]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 689

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "A lady was punished because of a cat which she had imprisoned till it died. She entered the (Hell) Fire because of it, for she neither gave it food nor water as she had imprisoned it, nor set it free to eat from the vermin of the earth."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.690]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 690

Narrated Abu Masud Uqba:

The Prophet said, "One of the sayings of the prophets which the people have got, is. 'If you do not feel ashamed, then do whatever you like."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.691]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 691

Narrated Abu Mus'ud:

The Prophet said, "One of the sayings of the prophets which the people have got is, 'If you do not feel ashamed, then do whatever you like."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.692]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 692

Narrated Ibn Umar:

The Prophet said, "While a man was walking, dragging his dress with pride, he was caused to be swallowed by the earth and will go on sinking in it till the Day of Resurrection."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.693]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 693

Narrated Abu Huraira:

The Prophet said, "We are the last (to come) but we will be the foremost on the Day of Resurrection, nations were given the Book (i.e. Scripture) before us, and we were given the Holy Book after them. This (i.e. Friday) is the day about which they differed. So the next day (i.e. Saturday) was prescribed for the Jews and the day after it (i.e. Sunday) for the Christians. It is incumbent on every Muslim to wash his head and body on a Day (i.e. Friday) (at least) in every seven days."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.694]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 694

Narrated Said bin Al-Musaiyab:

When Muawiya bin Abu Sufyan came to Medina for the last time, he delivered a sermon before us. He took out a tuft of hair and said, "I never thought that someone other than the Jews would do such a thing (i.e. use false hair). The Prophet named such a practice, 'Az-Zur' (i.e. falsehood)," meaning the use of false hair.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.695]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 695

Narrated Ibn Abbas:

Regarding the Verse: 'And (We) made you into Shu'ub and Qabail-- (49.13) that Shu'uib means the big Qabail (i.e. nations) while the Qabail (i.e. tribes) means the branch tribes.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.696]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 696

Narrated Abu Huraira:

Once Allah's Apostle was asked, "Who is the most honorable amongst the people?" He said, "The most righteous (i.e. Allah-fearing) amongst you." They said, "We do not ask you about this." He said, "Then Joseph, the prophet of Allah."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.697]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 697

Narrated Kulaib bin Wail:

I asked Zainab bint Abi Salama (i.e. daughter of the wife of the Prophet, "Tell me about the Prophet . Did he belong to the tribe of Mudar?" She replied, "Yes, he belonged to the tribe of Mudar and was from the offspring of An-Nadr bin Kinana."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.698]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 698

Narrated Kulaib:

I was told by the Rabiba (i.e. daughter of the wife of the Prophet) who, I think, was Zainab, that the Prophet (forbade the utensils (of wine called) Ad-Dubba, Al-Hantam, Al-Muqaiyar and Al-Muzaffat. I said to her, 'Tell me as to which tribe the Prophet belonged; was he from the tribe of Mudar?'' She replied, "He belonged to the tribe of Mudar and was from the offspring of An-Nadr bin Kinana. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.699]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 699

Narrated Abu Huraira:

Allah's Apostle said, "You see that the people are of different natures. Those who were the best in the pre-lslamic period, are also the best in Islam if they comprehend religious knowledge. You see that the best amongst the people in this respect (i.e. ambition of ruling) are those who hate it most. And you see that the worst among people is the double faced (person) who appears to these with one face and to the others with another face (i.e a hypocrite)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.700]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 700

Narrated Abu Huraira:

The Prophet said, "The tribe of Quraish has precedence over the people in this connection (i.e the right of ruling). The Muslims follow the Muslims amongst them, and the infidels follow the infidels amongst them. People are of different natures: The best amongst them in the pre-lslamic period are the best in Islam provided they comprehend the religious knowledge. You will find that the best amongst the people in this respect (i.e. of ruling) is he who hates it (i.e. the idea of ruling) most, till he is given the pledge of allegiance."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.701]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 701

Narrated Tawus:

Ibn 'Abbas recited the Quranic Verse:--'Except to be kind to me for my kin-ship to you--" (42.23) Said bin Jubair said, "(The Verse implies) the kinship of Muhammad." Ibn 'Abbas said, "There was not a single house (i.e. sub-tribe) of Quraish but had a kinship to the Prophet and so the above Verse was revealed in this connection, and its interpretation is: 'O Quraish! You should keep good relation between me (i.e. Muhammad) and you."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.702]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 702

Narrated Abi Mas'ud:

The Prophet said, "From this side from the east, afflictions will appear. Rudeness and lack of mercy are characteristics of the rural bedouins who are busy with their camels and cows (and pay no attention to religion). Such are the tribes of Rabi'a and Mudar."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.703]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 703

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Pride and arrogance are characteristics of the rural bedouins while calmness is found among the owners of sheep. Belief is Yemenite, and wisdom is also Yemenite i.e. the Yemenites are well-known for their true belief and wisdom)." Abu 'Abdullah (Al-Bukhari) said, "Yemen was called so because it is situated to the right of the Ka'ba, and Sham was called so because it is situated to the left of the Ka'ba."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.704]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 704

Narrated Muhammad bin Jubair bin Mut'im:

That while he was with a delegation from Quraish to Muawiya, the latter heard the news that 'Abdullah bin 'Amr bin Al-'As said that there would be a king from the tribe of Qahtan. On that Muawiya became angry, got up and then praised Allah as He deserved, and said, "Now then, I have heard that some men amongst you narrate things which are neither in the Holy Book, nor have been told by Allah's Apostle. Those men are the ignorant amongst you. Beware of such hopes as make the people go astray, for I heard Allah's Apostle saying, 'Authority of ruling will remain with Quraish, and whoever bears hostility to them, Allah will destroy him as long as they abide by the laws of the religion.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.705]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 705

Narrated Ibn Umar:

The Prophet said, "Authority of ruling will remain with Quraish, even if only two of them remained."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.706]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 706

Narrated Jubair bin Mut'im:

'Uthman bin Affan went (to the Prophet) and said, "O Allah's Apostle! You gave property to Bani Al-Muttalib and did not give us, although we and they are of the same degree of relationship to you." The Prophet said, "Only Bani Hashim and Bani Al Muttalib are one thing (as regards family status)."

Narrated Urwa bin Az-Zubair: 'Abdullah bin Az-Zubair went with some women of the tribe of Bani Zuhra to 'Aisha who used to treat them nicely because of their relation to Allah's Apostle.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.707]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 707

Narrated Abu Huraira:

Allah's Apostle said, "The tribe of Quraish, the Ansar, the (people of the tribe of) Julhaina, Muzaina, Aslam, Ashja', and Ghifar are my disciples and have no protectors except Allah and His Apostle."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.708]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 708

Narrated 'Urwa bin Az-Zubair:

'Abdullah bin Az-Zubair was the most beloved person to 'Aisha excluding the Prophet and Abu Bakr, and he in his turn, was the most devoted to her, 'Aisha used not to withhold the money given to her by Allah, but she used to spend it in charity. ('Abdullah) bin AzZubair said, " 'Aisha should be stopped from doing so." (When 'Aisha heard this), she said protestingly, "Shall I be stopped from doing so? I vow that I will never talk to 'Abdullah bin Az-Zubair." On that, Ibn Az-Zubair asked some people from Quraish and particularly the two uncles of Allah's Apostle to intercede with her, but she refused (to talk to him). Az-Zuhriyun, the uncles of the Prophet, including 'Abdur-Rahman bin Al-Aswad bin 'Abd Yaghuth and Al-Miswar bin Makhrama said to him, "When we ask for the permission to visit her, enter her house along with us (without taking her leave)." He did accordingly (and she accepted their intercession). He sent her ten slaves whom she manumitted as an expiation for (not keeping) her vow. 'Aisha manumitted more slaves for the same purpose till she manumitted forty slaves. She said, "I wish I had specified what I would have done in case of not fulfilling my vow when I made the vow, so that I might have done it easily."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.709]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 709

Narrated Anas:

Uthman called Zaid bin Thabit, Abdullah bin Az-Zubair, Said bin Al-'As and 'AbdurRahman bin Al-Harith bin Hisham, and then they wrote the manuscripts of the Holy Qur'an in the form of book in several copies. 'Uthman said to the three Quraishi persons. " If you differ with Zaid bin Thabit on any point of the Quran, then write it in the language of Quraish, as the Quran was revealed in their language." So they acted accordingly. (Said bin Thabit was an Ansari and not from Quraish ).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.710]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 710

Narrated Salama:

Allah's Apostle passed by some people from the tribe of Aslam practicing archery. He said, "O children of Ishmael! Throw (arrows), for your father was an archer. I am on the side of Bani so-and-so," meaning one of the two teams. The other team stopped throwing, whereupon the Prophet said, "What has happened to them?" They replied, "How shall we throw while you are with Bani so-and-so?" He said, "Throw for I am with all of you."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.711]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 711

Narrated Abu Dhar:

The Prophet said, "If somebody claims to be the son of any other than his real father knowingly, he but disbelieves in Allah, and if somebody claims to belong to some folk to whom he does not belong, let such a person take his place in the (Hell) Fire."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.712]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 712

Narrated Wathila bin Al-Asqa:

Allah's Apostle said, "Verily, one of the worst lies is to claim falsely to be the son of someone other than one's real father, or to claim to have had a dream one has not had, or to attribute to me what I have not said."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.713]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 713

Narrated Ibn Abbas:

The delegates of 'Abd-ul-Qais came to Allah's Apostle and said, "O Allah's Apostle! We are from the tribe of Rabi'a and the infidels of Mudar tribe stand between us and you, so that we cannot come to you except in the Sacred Months. Therefore we would like you to give us some instructions which we may follow and convey to our people staying behind us." The Prophet said, "I order you to observe four things and forbid you (to do) four things: (I order you) to believe in Allah testifying that None has the right to be worshipped except Allah; to offer the prayer perfectly; to pay the Zakat; and to give one-fifth of the war booty to Allah. And I forbid you to use Ad-Dubba, Al-Hantam, An-Naqir and Al-Muzaffat." (These are names of utensils in which alcoholic drinks were served.)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.714]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 714

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle on the pulpit saying, "Verily, afflictions (will start) from here," pointing towards the east, "whence the side of the head of Satan comes out."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.715]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 715

Narrated Abu Huraira: The Prophet said, "The tribes of Quraish, Al-Ansar, Juhaina, Muzaina, Aslam, Ghifar and Ashja' are my helpers, and they have no protector (i.e. Master) except Allah and His Apostle."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.716]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 716

Narrated Abdullah bin Umar:

While Allah's Apostle was on the pulpit, he said, "May Allah give the tribe of Ghifar! And may Allah save the tribe of Aslam! The tribe of 'Usaiya have disobeyed Allah and His Apostle."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.717]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 717

Narrated Abu Huraira:

The Prophet said, "May Allah save the tribe of Aslam, and may Allah forgive the tribe of Ghifar!"


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.718]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 718

Narrated Abu Bakra:

The Prophet said, "Do you think that the tribes of Juhaina, Muzaina, Aslam and Ghifar are better than the tribes of Bani Tamim, Bani Asad, Bam 'Abdullah bin Ghatafan and Bani Amir bin Sasaa?" A man said, "They were unsuccessful and losers." The Prophet added," (Yes), they are better than the tribes of Bani Tamim, Bani Asad, Bani Abdullah bin Ghatafan and Bani Amir bin Sasaa."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.719]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 719

Narrated Abu Bakra:

Al-Aqra' bin Habis said to the Prophet "Nobody gave you the pledge of allegiance but the robbers of the pilgrims (i.e. those who used to rob the pilgrims) from the tribes of Aslam, Ghifar, Muzaina." (Ibn Abi Ya'qub is in doubt whether Al-Aqra' added. 'And Juhaina.') The Prophet said, "Don't you think that the tribes of Aslam, Ghifar, Muzaina (and also perhaps) Juhaina are better than the tribes of Bani Tamim, Bani Amir, Asad, and Ghatafan?" Somebody said, "They were unsuccessful and losers!" The Prophet said, "Yes, by Him in Whose Hands my life is, they (i.e. the former) are better than they (i.e. the latter)."

Abu Huraira said, "(The Prophet said), '(The people of) Bani Aslam, Ghifar and some people of Muzaina (or some people of Juhaina or Muzaina) are better in Allah's Sight (or on the Day of Resurrection) than the tribes of Asad, Tamim, Hawazin and Ghatafan.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.720]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 720

Narrated Jabir:

We were in the company of the Prophet in a Ghazwa. A large number of emigrants joined him and among the emigrants there was a person who used to play jokes (or play with spears); so he (jokingly) stroked an Ansari man on the hip. The Ans-ari got so angry that both of them called their people. The Ansari said, "Help, O Ansar!" And the emigrant said "Help, O emigrants!" The Prophet came out and said, "What is wrong with the people (as they are calling) this call of the period of Ignorance? "Then he said, "What is the matter with them?" So he was told about the stroke of the emigrant to the Ansari. The Prophet said, "Stop this (i.e. appeal for help) for it is an evil call. "Abdullah bin Ubai bin Salul (a hypocrite) said, "The emigrants have called and (gathered against us); so when we return to Medina, surely, the more honorable people will expel therefrom the meaner," Upon that 'Umar said, "O Allah's Prophet! Shall we not kill this evil person (i.e. Abdullah bin Ubai bin Salul) ?" The Prophet) said, "(No), lest the people should say that Muhammad used to kill his companions."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.721]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 721

Narrated 'Abdullah (bin Mas'ud):

The Prophet said, "Who-ever slaps his face or tears the bosom of his dress, or calls the calls of the Period of Ignorance, is not from us."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.722]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 722

Narrated Abu Huraira:

Allah's Apostle said, "'Amr bin Luhai bin Qam'a bin Khindif was the father of Khuza'a.'


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.723]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 723

Narrated Said bin Al-Musaiyab:

Al-Bahira was an animal whose milk was spared for the idols and other dieties, and so nobody was allowed to milk it. As-Saiba was an animal which they (i.e infidels) used to set free in the names of their gods so that it would not be used for carrying anything. Abu Huraira said, "The Prophet said, 'I saw Amr bin 'Amir bin Luhai Al-Khuzai dragging his intestines in the (Hell) Fire, for he was the first man who started the custom of releasing animals (for the sake of false gods).' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.724]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 724

Narrated Ibn Abbas:

When the news of the advent of the Prophet reached Abu Dhar, he said to his brother, "Ride to this valley and bring me the news of this man (i.e. the Prophet ) who claims to be a Prophet receiving information from the Heaven. Listen to him and then come to me." His brother set out till he met the Prophet and listened to his speech and returned to Abu Dhar and said to him, "I have seen him exhorting people to virtues and his speech was not like poetry." Abu Dhar said, "You have not satisfied me as to what I wanted." So, he took his journey-food and a water-skin full of water and set out till he reached Mecca, where he went to the Mosque looking for the Prophet , whom he did not know, and he would not like to ask someone about him. So, a portion of the night had passed when 'Ali saw him and realized that he was a stranger. Abu Dhar followed him (to his house), but neither of them asked the other about anything till it was morning, when he carried his water-skin and food and went to the Mosque. He spent that day without being observed by the Prophet till it was night, when he returned to his sleeping place. 'Ali again passed by him and said, "Hasn't the man (i.e. Abu Dhar) recognized his dwelling place yet?" So, 'Ali let him get up and took him (to his house), but neither of them asked the other about anything, till it was the third day when 'Ali had the same experience with him and Abu Dhar again stayed with him. 'Ali then asked, "Won't you tell me what has brought you here?" He replied, "If you give me a promise and a convention that you will guide me, then I will tell you." When 'Ali did, Abu Dhar informed him (of his purpose). 'Ali said, "It is the Truth, and he (i.e. Muhammad) is the Apostle of Allah. So when the morning comes, follow me, and if I should perceive any danger threatening you, I will give you a hint by pretending to go to the watercloset. But if I carried on walking, follow me till you enter the place that I will enter." Abu Dhur agreed and followed 'Ali till he entered the place of the Prophet and Abu Dhur entered with him. He then listened to the speech of the Prophet and embraced Islam on that very spot. The Prophet said to him, "Go back to your people and inform them (of this religion) till you receive my (further) orders." Abu Dhur said, "By Him in Whose Hands my life is! I will proclaim my conversion to Islam publicly amongst them (i.e. infidels)." He went out till he reached the Mosque and announced as loudly as possible, "I testify that None has the right to be worshipped but Allah and that Muhammad is the Apostle of Allah." The people then got up and beat him till they knocked him down. Al-Abbas came and threw himself over him (to protect him) saying, Woe to you! Don't you know that he is from Ghifar and there is the route (road) to your merchants towards Sham (i.e. through the place where this tribe dwells)?" Thus he saved him from them. Abu Dhar did the same on the next day and the people beat him again and Al-'Abbas drew himself over him (to save him as before).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.725]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 725

Narrated Abu Jamra:

Ibn 'Abbas said to us, "Shall I tell you the story of Abu Dhar's conversion to Islam?" We said, "Yes." He said, "Abu Dhar said: I was a man from the tribe of Ghifar. We heard that a man had appeared in Mecca, claiming to be a Prophet. ! said to my brother, 'Go to that man and talk to him and bring me his news.' He set out, met him and returned. I asked him, 'What is the news with you?' He said, 'By Allah, I saw a man enjoining what is good and forbidding what is evil.' I said to him, 'You have not satisfied me with this little information.' So, I took a waterskin and a stick and proceeded towards Mecca. Neither did I know him (i.e. the Prophet ), nor did I like to ask anyone about him. I Kept on drinking Zam zam water and staying in the Mosque. Then 'Ali passed by me and said, 'It seems you are a stranger?' I said, 'Yes.' He proceeded to his house and I accompanied him. Neither did he ask me anything, nor did I tell him anything. Next morning I went to the Mosque to ask about the Prophet but no-one told me anything about him. Ali passed by me again and asked, 'Hasn't the man recognized his dwelling place yet' I said, 'No.' He said, 'Come along with me.' He asked me, 'What is your business? What has brought you to this town?' I said to him, 'If you keep my secret, I will tell you.' He said, 'I will do,' I said to him, 'We have heard that a person has appeared here, claiming to be a Prophet. I sent my brother to speak to him and when he returned, he did not bring a satisfactory report; so I thought of meeting him personally.' 'Ali said (to Abu Dhar), 'You have reached your goal; I am going to him just now, so follow me, and wherever I enter, enter after me. If I should see someone who may cause you trouble, I will stand near a wall pretending to mend my shoes (as a warning), and you should go away then.' 'Ali proceeded and I accompanied him till he entered a place, and I entered with him to the Prophet to whom I said, 'Present (the principles of) Islam to me.' When he did, I embraced Islam 'immediately. He said to me, 'O Abu Dhar! Keep your conversion as a secret and return to your town; and when you hear of our victory, return to us. ' I said, 'By H him Who has sent you with the Truth, I will announce my conversion to Islam publicly amongst them (i.e. the infidels),' Abu Dhar went to the Mosque, where some people from Quraish were present, and said, 'O folk of Quraish ! I testify that None has the right to be worshipped except Allah, and I (also) testify that Muhammad is Allah's Slave and His Apostle.' (Hearing that) the Quraishi men said, 'Get at this Sabi (i.e. Muslim) !' They got up and beat me nearly to death. Al 'Abbas saw me and threw himself over me to protect me. He then faced them and said, 'Woe to you! You want to kill a man from the tribe of Ghifar, although your trade and your communications are through the territory of Ghifar?' They therefore left me. The next morning I returned (to the Mosque) and said the same as I have said on the previous day. They again said, 'Get at this Sabi!' I was treated in the same way as on the previous day, and again Al-Abbas found me and threw himself over me to protect me and told them the same as he had said the day before.' So, that was the conversion of Abu Dhar (may Allah be Merciful to him) to Islam."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.726]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 726

Narrated Ibn 'Abbas:

If you wish to know about the ignorance of the Arabs, refer to Surat-al-Anam after Verse No. 130:--Indeed lost are those who have killed their children From folly without knowledge and have forbidden that which Allah has provided for them, inventing a lie against Allah. They have indeed gone astray and were not guided.' (6.14)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.727]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 727

Narrated Ibn Abbas:

When the Verse:-- 'And warn your tribe of near kindred.' (26.214) was revealed, the Prophet started calling (the 'Arab tribes), "O Bani Fihr, O Bani 'Adi" mentioning first the various branch tribes of Quraish.

Narrated Ibn 'Abbas: When the Verse:-- 'And warn your tribe of near kindred' (26.214). was revealed, the Prophet started calling every tribe by its name.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.728]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 728

Narrated Abu Huraira:

The Prophet said, "O Bani 'Abd Munaf! Buy yourselves from Allah; O Bani 'Abdul-Muttalib! Buy yourselves from Allah; O mother of Az-Zubair bin Al-Awwam, the aunt of Allah's Apostle, and O Fatima bint Muhammad! Buy yourselves from Allah, for I cannot defend you before Allah. You (both) can ask me from my property as much as you like. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.729]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 729

Narrated Anas:

The Prophet sent for the Ansar (and when they came), he asked, 'Is there any stranger amongst you?" They said, "No except the son of our sister." Allah's Apostle said, "The son of the sister of some people belongs to them."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.730]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 730

Narrated 'Aisha:

That during the Mina days, Abu Bakr came to her, while there where two girls with her, beating drums, and the Prophet was (lying) covering himself with his garment. Abu Bakr rebuked the two girls, but the Prophet uncovered his face and said, "O Abu Bakr! Leave them, for these are the days of Id (festival)." Those days were the days of Mina-. 'Aisha added, "I was being screened by the Prophet while I was watching the Ethiopians playing in the Mosque. 'Umar rebuked them, but the Prophet said, "Leave them, O Bani Arfida! Play. (for) you are safe."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.731]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 731

Narrated 'Aisha:

Once Hassan bin Thabit asked the permission of the Prophet to lampoon (i.e. compose satirical poetry defaming) the infidels. The Prophet said, "What about the fact that I have common descent with them?" Hassan replied, "I shall take you out of them as a hair is taken out of dough."

Narrated 'Urwa: I started abusing Hassan in front of 'Aisha, whereupon she said. "Don't abuse him, for he used to defend the Prophet (with his poetry)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.732]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 732

Narrated Jubair bin Mutim:

Allah's Apostle said, "I have five names: I am Muhammad and Ahmad; I am Al-Mahi through whom Allah will eliminate infidelity; I am Al-Hashir who will be the first to be resurrected, the people being resurrected there after; and I am also Al-'Aqib (i.e. There will be no prophet after me)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.733]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 733

Narrated Abu Huraira:

Allah's Apostle said, "Doesn't it astonish you how Allah protects me from the Quraish's abusing and cursing? They abuse Mudhammam and curse Mudhammam while I am Muhammad (and not Mudhammam)"


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.734]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 734

Narrated Jabir bin 'Abdullah:

The Prophet said, "My similitude in comparison with the other prophets is that of a man who has built a house completely and excellently except for a place of one brick. When the people enter the house, they admire its beauty and say: 'But for the place of this brick (how splendid the house will be)!"


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.735]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 735

Narrated Abu Huraira:

Allah's Apostle said, "My similitude in comparison with the other prophets before me, is that of a man who has built a house nicely and beautifully, except for a place of one brick in a corner. The people go about it and wonder at its beauty, but say: 'Would that this brick be put in its place!' So I am that brick, and I am the last of the Prophets."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.736]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 736

Narrated 'Aisha:

The Prophet died when he was sixty three years old.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.737]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 737

Narrated Anas:

While the Prophet was in the market, a man called (somebody), "O Abu-l-Qasim!' The Prophet turned to him and said "Name yourselves after me but do not call yourselves by my Kuniya."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.738]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 738

Narrated Jabir:

The Prophet said, "Name yourselves after me, but do not call yourselves by my Kuniya."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.739]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 739

Narrated Abu Huraira:

Abu-l-Qasim said, "Name yourselves after me, but do not call yourselves by my Kuniya."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.740]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 740

Narrated Al-Ju'aid bin 'Abdur Rahman:

I saw As-Sa'ib bin Yazid when he was ninety-four years old, quite strong and of straight figure. He said, "I know that I enjoyed my hearing and seeing powers only because of the invocation of Allah's Apostle . My aunt took me to him and said, 'O Allah's Apostle! My nephew is sick; will you invoke Allah for him?' So he invoked (Allah) for me."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.741]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 741

Narrated As- Scab bin Yazid:

My aunt took me to Allah's Apostle and said, "O Allah's Apostle! My nephew is sick"' The Prophet passed his hands over my head and blessed me. Then he performed ablution and I drank the remaining water, and standing behind him. A saw the seal in between his shoulders."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.742]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 742

Narrated 'Uqba bin Al-Harith:

(Once) Abu Bakr offered the 'Asr prayer and then went out walking and saw Al-Hasan playing with the boys. He lifted him on to his shoulders and said, " Let my parents be sacrificed for your sake! (You) resemble the Prophet and not 'Ali," while 'Ali was smiling.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.743]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 743

Narrated Abu Juhaifa:

I saw the Prophet, and Al-Hasan resembled him.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.744]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 744

Narrated Isma'il bin Abi Khalid:

I heard Abii Juhaifa saying, "I saw the Prophet, and Al-Hasan bin 'Ali resembled him." I said to Abu- Juhaifa, "Describe him for me." He said, "He was white and his beard was black with some white hair. He promised to give us 13 young she-camels, but he expired before we could get them."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.745]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 745

Narrated Wahb Abu Juhaifa As-Sawwai:

I saw the Prophet and saw some white hair below his lower lip above the chin.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.746]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 746

Narrated Hariz bin 'Uthman:

That he asked 'Abdullah bin Busr (i.e. the companion of the Prophet), "Did you see the Prophet when he was old?" He said, "He had a few white hairs between the lower lip and the chin."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.747]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 747

Narrated Rabia bin Abi Abdur-Rahman:

I heard Anas bin Malik describing the Prophet saying, "He was of medium height amongst the people, neither tall nor short; he had a rosy color, neither absolutely white nor deep brown; his hair was neither completely curly nor quite lank. Divine Inspiration was revealed to him when he was forty years old. He stayed ten years in Mecca receiving the Divine Inspiration, and stayed in Medina for ten more years. When he expired, he had scarcely twenty white hairs in his head and beard." Rabi'a said, "I saw some of his hairs and it was red. When I asked about that, I was told that it turned red because of scent. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.748]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 748

Narrated Anas:

Allah's Apostle was neither very tall nor short, neither absolutely white nor deep brown. His hair was neither curly nor lank. Allah sent him (as an Apostle) when he was forty years old. Afterwards he resided in Mecca for ten years and in Medina for ten more years. When Allah took him unto Him, there was scarcely twenty white hairs in his head and beard.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.749]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 749

Narrated Al-Bara:

Allah's Apostle was the handsomest of all the people, and had the best appearance. He was neither very tall nor short.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.750]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 750

Narrated Qatada:

I asked Anas, "Did the Prophet use to dye (his) hair?" He said, "No, for there were only a few white hairs on his temples."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.751]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 751

Narrated Al-Bara:

The Prophet was of moderate height having broad shoulders (long) hair reaching his ear-lobes. Once I saw him in a red cloak and I had never seen a more handsome than him."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.752]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 752

Narrated Abu Ishaq:

Al-Bara' was asked, "Was the face of the Prophet (as bright) as a sword?" He said, "No, but (as bright) as a moon."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.753]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 753

Narrated Abu Juhaifa:

Once Allah's Apostle went to Al-Batha' at noon, performed the ablution and offered' a two Rakat Zuhr prayer and a two-Rak'at 'Asr prayer while a spearheaded stick was planted before him and the passersby were passing in front of it. (After the prayer), the people got up and held the hands of the Prophet and passed them on their faces. I also took his hand and kept it on my face and noticed that it was colder than ice, and its smell was nicer than musk.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.754]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 754

Narrated Ibn Abbas:

The Prophet was the most generous of all the people, and he used to become more generous in Ramadan when Gabriel met him. Gabriel used to meet him every night during Ramadan to revise the Qur'an with him. Allah's Apostle then used to be more generous than the fast wind.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.755]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 755

Narrated 'Aisha:

That Allah's Apostle came to her in a happy mood with his features glittering with joy, and said, "Have you not heard what the Qaif has said about Zaid and Us-ama? He saw their feet and remarked. These belong to each other." (i.e. They are father and son.)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.756]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 756

Narrated 'Abdullah bin Ka'b:

I heard Ka'b bin Malik talking after his failure to join (the Ghazwa of) Tabuk. He said, "When I greeted Allah's Apostle whose face was glittering with happiness, for whenever Allah's Apostle was happy, his face used to glitter, as if it was a piece of the moon, and we used to recognize it (i.e. his happiness) from his face."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.757]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 757

Narrated Abu Huraira:

Allah's Apostle said, "I have been sent (as an Apostle) in the best of all the generations of Adam's offspring since their Creation."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.758]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 758

Narrated Ibn 'Abbas:

Allah's Apostle used to let his hair hang down while the infidels used to part their hair. The people of the Scriptures were used to letting their hair hang down and Allah's Apostle liked to follow the people of the Scriptures in the matters about which he was not instructed otherwise. Then Allah's Apostle parted his hair.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.759]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 759

Narrated 'Abdullah bin 'Amr:

The Prophet never used bad language neither a "Fahish nor a Mutafahish. He used to say "The best amongst you are those who have the best manners and character." (See Hadith No. 56 (B) Vol. 8)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.760]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 760

Narrated 'Aisha:

Whenever Allah's Apostle was given the choice of one of two matters, he would choose the easier of the two, as long as it was not sinful to do so, but if it was sinful to do so, he would not approach it. Allah's Apostle never took revenge (over anybody) for his own sake but (he did) only when Allah's Legal Bindings were outraged in which case he would take revenge for Allah's Sake.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.761]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 761

Narrated Anas:

I have never touched silk or Dibaj (i.e. thick silk) softer than the palm of the Prophet nor have I smelt a perfume nicer than the sweat of the Prophet


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.762]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 762

Narrated Abu Said Al-Khudri:

The Prophet was shier than a veined virgin girl.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.763]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 763

Narrated Shuba:

A similar Hadith (i e. No. 762) with this addition: And if he (i.e. the Prophet) disliked something, the sign of aversion would appear on his face.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.764]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 764

Narrated Abu Huraira:

The Prophet never criticized any food (presented him), but he would eat it if he liked it; otherwise, he would leave it (without expressing his dislike).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.765]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 765

Narrated 'Abdullah bin Malik bin Buhaina Al-Asdi:

When the Prophet prostrated, he used to keep his arms so widely apart that we used to see his armpits. (The sub-narrator, Ibn Bukair said, "The whiteness of his armpits.")


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.766]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 766

Narrated Anas:

Allah's Apostle did not use to raise his hands in his invocations except in the Istisqa (i.e. invoking Allah for the rain) in which he used to raise his hands so high that one could see the whiteness of his armpits. (Note: It may be that Anas did not see the prophet (as) raising his hands but it has been narrated that the Prophet (as) used to raise his hands for invocations other than Istisqa. See Hadith No. 612 Vol. 5. and Hadith No. 807 & 808 Vol 2.)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.767]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 767

Narrated Abu Juhaifa:

By chance I went to the Prophet at noon while he was at Al-Abtah (resting) in a tent. Bilal came out (of the tent) and pronounced the Adhan for the prayer, and entering again, he brought out the water which was left after Allah's Apostle had performed the ablution. The people rushed to take some of the water. Bilal again went in and brought out a spear-headed stick, and then Allah's Apostle came out. As if I were now looking at the whiteness of his leg. Bilal fixed the stick and the Prophet offered a two-Rakat Zuhr prayer and a two-Rak'at 'Asr prayer, while women and donkeys were passing in front of the Prophet (beyond the stick) .


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.768]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 768

Narrated 'Aisha:

The Prophet used to talk so clearly that if somebody wanted to count the number of his words, he could do so. Narrated Urwa bin Az-Zubair: 'Aisha said (to me), "Don't you wonder at Abu so-and-so who came and sat by my dwelling and started relating the traditions of Allah's Apostle intending to let me hear that, while I was performing an optional prayer. He left before I finished my optional prayer. Had I found him still there. I would have said to him, 'Allah's Apostle never talked so quickly and vaguely as you do.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.769]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 769

Narrated Abu Salama bin 'Abdur-Rahman:

That he asked 'Aisha "How was the prayer of Allah's Apostle in the month of Ramadan?" She replied, "He used not to pray more than eleven Rakat whether in Ramadan or in any other month. He used to offer four Rakat, let alone their beauty and length, and then four Rakat, let alone their beauty and length. Afterwards he would offer three Rakat. I said, 'O Allah's Apostle! Do you go to bed before offering the Witr prayer?' He said, 'My eyes sleep, but my heart does not sleep."'


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.770]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 770

Narrated Sharik bin 'Abdullah bin Abi Namr:

I heard Anas bin Malik telling us about the night when the Prophet was made to travel from the Ka'ba Mosque. Three persons (i.e. angels) came to the Prophet before he was divinely inspired was an Aspostle), while he was sleeping in Al Masjid-ul-Haram. The first (of the three angels) said, "Which of them is he?" The second said, "He is the best of them." That was all that happened then, and he did not see them till they came at another night and he perceived their presence with his heart, for the eyes of the Prophet were closed when he was asleep, but his heart was not asleep (not unconscious). This is characteristic of all the prophets: Their eyes sleep but their hearts do not sleep. Then Gabriel took charge of the Prophet and ascended along with him to the Heaven.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.771]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 771

Narrated Imran bin Husain:

That they were with the Prophet on a journey. They travelled the whole night, and when dawn approached, they took a rest and sleep overwhelmed them till the sun rose high in the sky. The first to get up was Abu Bakr. Allah's Apostles used not to be awakened from his sleep, but he would wake up by himself. 'Umar woke up and then Abu Bakr sat by the side of the Prophet's head and started saying: Allahu-Akbar raising his voice till the Prophet woke up, (and after traveling for a while) he dismounted and led us in the morning prayer. A man amongst the people failed to join us in the prayer. When the Prophet had finished the prayer, he asked (the man), "O so-and-so! What prevented you from offering the prayer with us?" He replied, "I am Junub," Alllah's Apostle ordered him to perform Tayammam with clean earth. The man then offered the prayer. Allah's Apostle ordered me and a few others to go ahead of him. We had become very thirsty. While we were on our way (looking for water), we came across a lady (riding an animal), hanging her legs between two water-skins. We asked her, "Where can we get water?" She replied, "Oh ! There is no water." We asked, "how far is your house from the water?" She replied, "A distance of a day and a night travel." We said, "Come on to Allah's Apostle, "She asked, "What is Allah's Apostle ?" So we brought her to Allah's Apostle against her will, and she told him what she had told us before and added that she was the mother of orphans. So the Prophet ordered that her two water-skins be brought and he rubbed the mouths of the water-skins. As we were thirsty, we drank till we quenched our thirst and we were forty men. We also filled all our waterskins and other utensils with water, but we did not water the camels. The waterskin was so full that it was almost about to burst. The Prophet then said, "Bring what (foodstuff) you have." So some dates and pieces of bread were collected for the lady, and when she went to her people, she said, "I have met either the greatest magician or a prophet as the people claim." So Allah guided the people of that village through that lady. She embraced Islam and they all embraced Islam.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.772]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 772

Narrated Anas:

A bowl of water was brought to the Prophet while he was at Az-Zawra. He placed his hand in it and the water started flowing among his fingers. All the people performed ablution (with that water). Qatada asked Anas, "How many people were you?" Anas replied, "Three hundred or nearly three-hundred."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.773]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 773

Narrated Anas bin Malik:

I saw Allah's Apostle at the 'time when the Asr prayer was due. Then the people were searching for water for ablution but they could not find any. Then some water was brought to Allah's Apostle and he placed his hand in the pot and ordered the people to perform the ablution with the water. I saw water flowing from underneath his fingers and the people started performing the ablution till all of them did it.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.774]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 774

Narrated Anas bin Malik:

The Prophet went out on one of his journeys with some of his companions. They went on walking till the time of the prayer became due. They could not find water to perform the ablution. One of them went away and brought a little amount of water in a pot. The Prophet took it and performed the ablution, and then stretched his four fingers on to the pot and said (to the people), "Get up to perform the ablution." They started performing the ablution till all of them did it, and they were seventy or so persons.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.775]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 775

Narrated Humaid:

Anas bin Malik said, "Once the time of the prayer became due and the people whose houses were close to the Mosque went to their houses to perform ablution, while the others remained (sitting there). A stone pot containing water was brought to the Prophet, who wanted to put his hand in it, but It was too small for him to spread his hand in it, and so he had to bring his fingers together before putting his hand in the pot. Then all the people performed the ablution (with that water)." I asked Anas, "How many persons were they." He replied, "There were eighty men."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.776]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 776

Narrated Salim bin Abi Aj-Jad:

Jabir bin 'Abdullah said, "The people became very thirsty on the day of Al-Hudaibiya (Treaty). A small pot containing some water was in front of the Prophet and when he had finished the ablution, the people rushed towards him. He asked, 'What is wrong with you?' They replied, 'We have no water either for performing ablution or for drinking except what is present in front of you.' So he placed his hand in that pot and the water started flowing among his fingers like springs. We all drank and performed ablution (from it)." I asked Jabir, "How many were you?" he replied, "Even if we had been one-hundred-thousand, it would have been sufficient for us, but we were fifteen-hundred."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.777]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 777

Narrated Al-Bara:

We were one-thousand-and-four-hundred persons on the day of Al-Hudaibiya (Treaty), and (at) Al-Hudaibiya (there) was a well. We drew out its water not leaving even a single drop. The Prophet sat at the edge of the well and asked for some water with which he rinsed his mouth and then he threw it out into the well. We stayed for a short while and then drew water from the well and quenched our thirst, and even our riding animals drank water to their satisfaction.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.778]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 778

Narrated Anas bin Malik:

Abu Talha said to Um Sulaim, "I have noticed feebleness in the voice of Allah's Apostle which I think, is caused by hunger. Have you got any food?" She said, "Yes." She brought out some loaves of barley and took out a veil belonging to her, and wrapped the bread in part of it and put it under my arm and wrapped part of the veil round me and sent me to Allah's Apostle. I went carrying it and found Allah's Apostle in the Mosque sitting with some people. When I stood there, Allah's Apostle asked, "Has Abu Talha sent you?" I said, "Yes". He asked, "With some food? I said, "Yes" Allah's Apostle then said to the men around him, "Get up!" He set out (accompanied by them) and I went ahead of them till I reached Abu Talha and told him (of the Prophet's visit). Abu Talha said, "O Um Sulaim! Allah's Apostle is coming with the people and we have no food to feed them." She said, "Allah and His Apostle know better." So Abu Talha went out to receive Allah's Apostle. Allah's Apostle came along with Abu Talha. Allah's Apostle said, "O Um Sulaim! Bring whatever you have." She brought the bread which Allah's Apostle ordered to be broken into pieces. Um Sulaim poured on them some butter from an oilskin. Then Allah's Apostle recited what Allah wished him to recite, and then said, "Let ten persons come (to share the meal)." Ten persons were admitted, ate their fill and went out. Then he again said, "Let another ten do the same." They were admitted, ate their fill and went out. Then he again said, '"'Let another ten persons (do the same.)" They were admitted, ate their fill and went out. Then he said, "Let another ten persons come." In short, all of them ate their fill, and they were seventy or eighty men.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.779]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 779

Narrated 'Abdullah:

We used to consider miracles as Allah's Blessings, but you people consider them to be a warning. Once we were with Allah's Apostle on a journey, and we ran short of water. He said, "Bring the water remaining with you." The people brought a utensil containing a little water. He placed his hand in it and said, "Come to the blessed water, and the Blessing is from Allah." I saw the water flowing from among the fingers of Allah's Apostle , and no doubt, we heard the meal glorifying Allah, when it was being eaten (by him).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.780]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 780

Narrated Jabir:

My father had died in debt. So I came to the Prophet and said, "My father (died) leaving unpaid debts, and I have nothing except the yield of his date palms; and their yield for many years will not cover his debts. So please come with me, so that the creditors may not misbehave with me." The Prophet went round one of the heaps of dates and invoked (Allah), and then did the same with another heap and sat on it and said, "Measure (for them)." He paid them their rights and what remained was as much as had been paid to them.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.781]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 781

Narrated Abdur-Rahman bin Abi Bakr:

The companions of Suffa were poor people. The Prophet once said, "Whoever has food enough for two persons, should take a third one (from among them), and whoever has food enough for four persons, should take a fifth or a sixth (or said something similar)." Abu Bakr brought three persons while the Prophet took ten. And Abu Bakr with his three family member (who were I, my father and my mother) (the sub-narrator is in doubt whether 'Abdur-Rahman said, "My wife and my servant who was common for both my house and Abu Bakr's house.") Abu Bakr took his supper with the Prophet and stayed there till he offered the 'Isha' prayers. He returned and stayed till Allah's Apostle took his supper. After a part of the night had passed, he returned to his house. His wife said to him, "What has detained you from your guests?" He said, "Have you served supper to them?" She said, "They refused to take supper) until you come. They (i.e. some members of the household) presented the meal to them but they refused (to eat)" I went to hide myself and he said, "O Ghunthar!" He invoked Allah to cause my ears to be cut and he rebuked me. He then said (to them): Please eat!" and added, I will never eat the meal." By Allah, whenever we took a handful of the meal, the meal grew from underneath more than that handful till everybody ate to his satisfaction; yet the remaining food was more than the original meal. Abu Bakr saw that the food was as much or more than the original amount. He called his wife, "O sister of Bani Firas!" She said, "O pleasure of my eyes. The food has been tripled in quantity." Abu Bakr then started eating thereof and said, "It (i.e. my oath not to eat) was because of Sa all." He took a handful from it, and carried the rest to the Prophet. SO that food was with the Prophet . There was a treaty between us and some people, and when the period of that treaty had elapsed, he divided US into twelve groups, each being headed by a man. Allah knows how many men were under the command of each leader. Anyhow, the Prophet surely sent a leader with each group. Then all of them ate of that meal.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.782]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 782

Narrated Anas:

Once during the lifetime of Allah's Apostle, the people of Medina suffered from drought. So while the Prophet was delivering a sermon on a Friday a man got up saying, "O Allah's Apostle! The horses and sheep have perished. Will you invoke Allah to bless us with rain?" The Prophet lifted both his hands and invoked. The sky at that time was as clear as glass. Suddenly a wind blew, raising clouds that gathered together, and it started raining heavily. We came out (of the Mosque) wading through the flowing water till we reached our homes. It went on raining till the next Friday, when the same man or some other man stood up and said, "O Allah's Apostle! The houses have collapsed; please invoke Allah to withhold the rain." On that the Prophet smiled and said, "O Allah, (let it rain) around us and not on us." I then looked at the clouds to see them separating forming a sort of a crown round Medina.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.783]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 783

Narrated Ibn Umar:

The Prophet used to deliver his sermons while standing beside a trunk of a datepalm. When he had the pulpit made, he used it instead. The trunk started crying and the Prophet went to it, rubbing his hand over it (to stop its crying).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.784]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 784

Narrated Jabir bin 'Abdullah:

The Prophet used to stand by a tree or a date-palm on Friday. Then an Ansari woman or man said. "O Allah's Apostle! Shall we make a pulpit for you?" He replied, "If you wish." So they made a pulpit for him and when it was Friday, he proceeded towards the pulpit (for delivering the sermon). The date-palm cried like a child! The Prophet descended (the pulpit) and embraced it while it continued moaning like a child being quietened. The Prophet said, "It was crying for (missing) what it used to hear of religious knowledge given near to it."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.785]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 785

Narrated Anas bin Malik:

That he heard Jabir bin 'Abdullah saying, "The roof of the Mosque was built over trunks of date-palms working as pillars. When the Prophet delivered a sermon, he used to stand by one of those trunks till the pulpit was made for him, and he used it instead. Then we heard the trunk sending a sound like of a pregnant she-camel till the Prophet came to it, and put his hand over it, then it became quiet."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.786]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 786

Narrated Hudhaifa:

Once 'Umar bin Al-Khattab said, said, "Who amongst you remembers the statement of Allah's Apostle regarding the afflictions?" Hudhaifa replied, "I remember what he said exactly." 'Umar said. "Tell (us), you are really a daring man!'' Hudhaifa said, "Allah's Apostle said, 'A man's afflictions (i.e. wrong deeds) concerning his relation to his family, his property and his neighbors are expiated by his prayers, giving in charity and enjoining what is good and forbidding what is evil.' " 'Umar said, "I don't mean these afflictions but the afflictions that will be heaving up and down like waves of the sea." Hudhaifa replied, "O chief of the believers! You need not fear those (afflictions) as there is a closed door between you and them." 'Umar asked, "Will that door be opened or broken?" Hudhaifa replied, "No, it will be broken." 'Umar said, "Then it is very likely that the door will not be closed again." Later on the people asked Hudhaifa, "Did 'Umar know what that door meant?" He said. "Yes, 'Umar knew it as everyone knows that there will be night before the tomorrow morning. I narrated to 'Umar an authentic narration, not lies." We dared not ask Hudhaifa; therefore we requested Masruq who asked him, "What does the door stand for?" He said, "Umar."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.787]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 787

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till you fight a nation wearing hairy shoes, and till you fight the Turks, who will have small eyes, red faces and flat noses; and their faces will be like flat shields. And you will find that the best people are those who hate responsibility of ruling most of all till they are chosen to be the rulers. And the people are of different natures: The best in the pre-lslamic period are the best in Islam. A time will come when any of you will love to see me rather than to have his family and property doubled."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.788]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 788

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till you fight with the Khudh and the Kirman from among the non-Arabs. They will be of red faces, flat noses and small eyes; their faces will look like flat shields, and their shoes will be of hair."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.789]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 789

Narrated Abu Huraira:

I enjoyed the company of Allah's Apostle for three years, and during the other years of my life, never was I so anxious to understand the (Prophet's) traditions as I was during those three years. I heard him saying, beckoning with his hand in this way, "Before the Hour you will fight with people who will have hairy shoes and live in Al-Bariz." (Sufyan, the sub-narrator once said, "And they are the people of Al-Bazir.")


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.790]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 790

Narrated 'Umar bin Taghlib:

I heard Allah's Apostle saying, "Near the Hour you will fight with people who will wear hairy shoes; and you will also fight people with flat faces like shields."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.791]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 791

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "The Jews will fight with you, and you will be given victory over them so that a stone will say, 'O Muslim! There is a Jew behind me; kill him!' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.792]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 792

Narrated Abu Said Al-Khudri:

The Prophet said, "A time will come when the people will wage holy war, and it will be asked, 'Is there any amongst you who has enjoyed the company of Allah's Apostle?' They will say: 'Yes.' And then victory will be bestowed upon them. They will wage holy war again, and it will be asked: 'Is there any among you who has enjoyed the company of the companions of Allah's Apostle ?' They will say: 'Yes.' And then victory will be bestowed on them."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.793]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 793

Narrated 'Adi bin Hatim:

While I was in the city of the Prophet, a man came and complained to him (the Prophet, ) of destitution and poverty. Then another man came and complained of robbery (by highwaymen). The Prophet said, "Adi! Have you been to Al-Hira?" I said, "I haven't been to it, but I was informed about it." He said, "If you should live for a long time, you will certainly see that a lady in a Howdah traveling from Al-Hira will (safely reach Mecca and) perform the Tawaf of the Ka'ba, fearing none but Allah." I said to myself, "What will happen to the robbers of the tribe of Tai who have spread evil through out the country?" The Prophet further said. "If you should live long, the treasures of Khosrau will be opened (and taken as spoils)." I asked, "You mean Khosrau, son of Hurmuz?" He said, "Khosrau, son of Hurmuz; and if you should live long, you will see that one will carry a handful of gold or silver and go out looking for a person to accept it from him, but will find none to accept it from him. And any of you, when meeting Allah, will meet Him without needing an interpreter between him and Allah to interpret for him, and Allah will say to him: 'Didn't I send a messenger to teach you?' He will say: 'Yes.' Allah will say: 'Didn't I give you wealth and do you favors?' He will say: 'Yes.' Then he will look to his right and see nothing but Hell, and look to his left and see nothing but Hell."

'Adi further said: I heard the Prophet saying, "Save yourself from the (Hell) Fire even with half a date (to be given in charity) and if you do not find a half date, then with a good pleasant word." 'Adi added: (later on) I saw a lady in a Howdah traveling from Al-Hira till she performed the Tawaf of the Ka'ba, fearing none but Allah. And I was one of those who opened (conquered) the treasures of Khosrau, son of Hurmuz. If you should live long, you will see what the Prophet Abu-l-Qasim had said: 'A person will come out with a handful. of gold...etc.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.794]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 794

Narrated 'Adi:

as above (i.e. Hadith No. 793).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.795]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 795

Narrated 'Uqba bin 'Amr:

The Prophet once came out and offered the funeral prayer for the martyrs of Uhud, and proceeded to the pulpit and said, "I shall be your predecessor and a witness on you, and I am really looking at my sacred Fount now, and no doubt, I have been given the keys of the treasures of the world. By Allah, I am not afraid that you will worship others along with Allah, but I am afraid that you will envy and fight one another for worldly fortunes."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.796]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 796

Narrated Usama:

Once the Prophet stood on one of the high buildings (of Medina) and said, "Do you see what I see? I see affliction pouring among your hours like raindrops."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.797]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 797

Narrated Zainab bint Jahsh:

That the Prophet came to her in a state of fear saying, "None has the right to be worshiped but Allah! Woe to the Arabs because of evil that has come near. Today a hole has been made in the wall of Gog and Magog as large as this." pointing with two of his fingers making a circle. Zainab said, "I said, 'O Allah's Apostle! Shall we be destroyed though amongst us there are pious people? ' He said, 'Yes, if evil increases."

Narrated Um Salama: The Prophet woke up and said, "Glorified be Allah: What great (how many) treasures have been sent down, and what great (how many ) afflictions have been sent down!"


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.798]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 798

Narrated Sasaa:

Abu Said Al-Khudr said to me, "I notice that you like sheep and you keep them; so take care of them and their food, for I have heard Allah's Apostle saying, 'A time will come upon the people when the best of a Muslim's property will be sheep, which he will take to the tops of mountains and to the places of rain-falls to run away with his religion in order to save it from afflictions.' "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.799]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 799

Narrated Abu Huraira:

Allah's Apostle said, "There will be afflictions (and at the time) the sitting person will be better than the standing one, and the standing one will be better than the walking, and the walking will be better than the running. And whoever will look towards those afflictions, they will overtake him, and whoever will find a refuge or a shelter, should take refuge in it." The same narration is reported by Abu Bakr, with the addition, "(The Prophet said), 'Among the prayers there is a prayer the missing of which will be to one like losing one's family and property."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.800]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 800

Narrated Ibn Mas'ud:

The Prophet said, "Soon others will be preferred to you, and there will be things which you will not like." The companions of the Prophet asked, "O Allah's Apostle! What do you order us to do (in this case)? " He said, "(I order you) to give the rights that are on you and to ask your rights from Allah."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.801]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 801

Narrated Abu Huraira:

Allah's Apostle said, "This branch from Quraish will ruin the people." The companions of the Prophet asked, "What do you order us to do (then)?" He said, "I would suggest that the people keep away from them.''


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.802]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 802

Narrated Said Al-Umawi:

I was with Marwan and Abu Huraira and heard Abu Huraira saying, "I heard the trustworthy, truly inspired one (i.e. the Prophet ) saying, 'The destruction of my followers will be brought about by the hands of some youngsters from Quraish." Marwan asked, "Youngsters?" Abu Huraira said, "If you wish, I would name them: They are the children of so-and-so and the children of so-and-so."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.803]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 803

Narrated Hudhaifa bin Al-Yaman:

The people used to ask Allah's Apostle about good, but I used to ask him about evil for fear that it might overtake me. Once I said, "O Allah's Apostle! We were in ignorance and in evil and Allah has bestowed upon us the present good; will there by any evil after this good?" He said, "Yes." I asked, "Will there be good after that evil?" He said, "Yes, but it would be tained with Dakhan (i.e. Little evil)." I asked, "What will its Dakhan be?" He said, "There will be some people who will lead (people) according to principles other than my tradition. You will see their actions and disapprove of them." I said, "Will there by any evil after that good?" He said, "Yes, there will be some people who will invite others to the doors of Hell, and whoever accepts their invitation to it will be thrown in it (by them)." I said, "O Allah's Apostle! Describe those people to us." He said, "They will belong to us and speak our language" I asked, "What do you order me to do if such a thing should take place in my life?" He said, "Adhere to the group of Muslims and their Chief." I asked, "If there is neither a group (of Muslims) nor a chief (what shall I do)?" He said, "Keep away from all those different sects, even if you had to bite (i.e. eat) the root of a tree, till you meet Allah while you are still in that state."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.804]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 804

Narrated Hudhaifa:

My companions learned (something about) good (through asking the Prophet while I learned (something about) evil.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.805]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 805

Narrated Abu Huraira:

Allah's Apostle said, "The Day of (Judgment) will not be established till there is a war between two groups whose claims (or religion) will be the same."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.806]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 806

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till there is a war between two groups among whom there will be a great number of casualties, though the claims (or religion) of both of them will be one and the same. And the Hour will not be established till there appear about thirty liars, all of whom will be claiming to be the messengers of Allah. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.807]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 807

Narrated Abu Said Al-Khudri:

While we were with Allah's Apostle who was distributing (i.e. some property), there came Dhu-l-Khuwaisira, a man from the tribe of Bani Tamim and said, "O Allah's Apostle! Do Justice." The Prophet said, "Woe to you! Who could do justice if I did not? I would be a desperate loser if I did not do justice." 'Umar said, "O Allah's Apostle! Allow me to chop his head off." The Prophet said, "Leave him, for he has companions who pray and fast in such a way that you will consider your fasting negligible in comparison to theirs. They recite Qur'an but it does not go beyond their throats (i.e. they do not act on it) and they will desert Islam as an arrow goes through a victim's body, so that the hunter, on looking at the arrow's blade, would see nothing on it; he would look at its Risaf and see nothing: he would look at its Na,di and see nothing, and he would look at its Qudhadh ( 1 ) and see nothing (neither meat nor blood), for the arrow has been too fast even for the blood and excretions to smear. The sign by which they will be recognized is that among them there will be a black man, one of whose arms will resemble a woman's breast or a lump of meat moving loosely. Those people will appear when there will be differences amongst the people." I testify that I heard this narration from Allah's Apostle and I testify that 'Ali bin Abi Talib fought with such people, and I was in his company. He ordered that the man (described by the Prophet ) should be looked for. The man was brought and I looked at him and noticed that he looked exactly as the Prophet had described him.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.808]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 808

Narrated 'Ali:

I relate the traditions of Allah's Apostle to you for I would rather fall from the sky than attribute something to him falsely. But when I tell you a thing which is between you and me, then no doubt, war is guile. I heard Allah's Apostle saying, "In the last days of this world there will appear some young foolish people who will use (in their claim) the best speech of all people (i.e. the Qur'an) and they will abandon Islam as an arrow going through the game. Their belief will not go beyond their throats (i.e. they will have practically no belief), so wherever you meet them, kill them, for he who kills them shall get a reward on the Day of Resurrection."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.809]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 809

Narrated Khabbab bin Al-Arat:

We complained to Allah's Apostle (of the persecution inflicted on us by the infidels) while he was sitting in the shade of the Ka'ba, leaning over his Burd (i.e. covering sheet). We said to him, "Would you seek help for us? Would you pray to Allah for us?" He said, "Among the nations before you a (believing) man would be put in a ditch that was dug for him, and a saw would be put over his head and he would be cut into two pieces; yet that (torture) would not make him give up his religion. His body would be combed with iron combs that would remove his flesh from the bones and nerves, yet that would not make him abandon his religion. By Allah, this religion (i.e. Islam) will prevail till a traveler from Sana (in Yemen) to Hadrarmaut will fear none but Allah, or a wolf as regards his sheep, but you (people) are hasty.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.810]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 810

Narrated Anas bin Malik:

The Prophet noticed the absence of Thabit bin Qais. A man said, "O Allah's Apostle! I shall bring you his news." So he went to him and saw him sitting in his house drooping his head (sadly). He asked Thabit, "What's the matter?" Thabit replied, "An evil situation: A man used to raise his voice over the voice of the Prophet and so all his good deeds have been annulled and he is from the people of Hell." The man went back and told the Prophet that Thabit had said so-and-so. (The sub-narrator, Musa bin Anas said, "The man went to Thabit again with glad tidings)." The Prophet said to him, "Go and say to Thabit: 'You are not from the people of Fire, but from the people of Paradise."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.811]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 811

Narrated Al-Bara' bin 'Azib:

A man recited Surat-al-Kahf (in his prayer) and in the house there was a (riding) animal which got frightened and started jumping. The man finished his prayer with Taslim, but behold! A mist or a cloud hovered over him. He informed the Prophet of that and the Prophet said, "O so-and-so! Recite, for this (mist or cloud) was a sign of peace descending for the recitation of Quran."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.812]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 812

Narrated Al-Bara' bin 'Azib:

Abu Bakr came to my father who was at home and purchased a saddle from him. He said to 'Azib. "Tell your son to carry it with me." So I carried it with him and my father followed us so as to take the price (of the saddle). My father said, "O Abu Bakr! Tell me what happened to you on your night journey with Allah's Apostle (during Migration)." He said, "Yes, we travelled the whole night and also the next day till midday. when nobody could be seen on the way ( because of the severe heat) . Then there appeared a long rock having shade beneath it, and the sunshine had not come to it yet. So we dismounted there and I levelled a place and covered it with an animal hide or dry grass for the Prophet to sleep on (for a while). I then said, 'Sleep, O Allah's Apostle, and I will guard you.' So he slept and I went out to guard him. Suddenly I saw a shepherd coming with his sheep to that rock with the same intention we had when we came to it. I asked (him). 'To whom do you belong, O boy?' He replied, 'I belong to a man from Medina or Mecca.' I said, 'Do your sheep have milk?' He said, 'Yes.' I said, 'Will you milk for us?' He said, 'Yes.' He caught hold of a sheep and I asked him to clean its teat from dust, hairs and dirt. (The sub-narrator said that he saw Al-Bara' striking one of his hands with the other, demonstrating how the shepherd removed the dust.) The shepherd milked a little milk in a wooden container and I had a leather container which I carried for the Prophet to drink and perform the ablution from. I went to the Prophet, hating to wake him up, but when I reached there, the Prophet had already awakened; so I poured water over the middle part of the milk container, till the milk was cold. Then I said, 'Drink, O Allah's Apostle!' He drank till I was pleased. Then he asked, 'Has the time for our departure come?' I said, 'Yes.' So we departed after midday. Suraqa bin Malik followed us and I said, 'We have been discovered, O Allah's Apostle!' He said, Don't grieve for Allah is with us.' The Prophet invoked evil on him (i.e. Suraqa) and so the legs of his horse sank into the earth up to its belly. (The subnarrator, Zuhair is not sure whether Abu Bakr said, "(It sank) into solid earth.") Suraqa said, 'I see that you have invoked evil on me. Please invoke good on me, and by Allah, I will cause those who are seeking after you to return.' The Prophet invoked good on him and he was saved. Then, whenever he met somebody on the way, he would say, 'I have looked for him here in vain.' So he caused whomever he met to return. Thus Suraqa fulfilled his promise."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.813]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 813

Narrated Ibn 'Abbas:

The Prophet paid a visit to a sick bedouin. The Prophet when visiting a patient used to say, "No harm will befall you! May Allah cure you! May Allah cure you!" So the Prophet said to the bedouin. "No harm will befall you. May Allah cure you!" The bedouin said, "You say, may Allah cure me? No, for it is a fever which boils in (the body of) an old man, and will lead him to the grave." The Prophet said, "Yes, then may it be as you say."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.814]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 814

Narrated Anas:

There was a Christian who embraced Islam and read Surat-al-Baqara and Al-Imran, and he used to write (the revelations) for the Prophet. Later on he returned to Christianity again and he used to say: "Muhammad knows nothing but what I have written for him." Then Allah caused him to die, and the people buried him, but in the morning they saw that the earth had thrown his body out. They said, "This is the act of Muhammad and his companions. They dug the grave of our companion and took his body out of it because he had run away from them." They again dug the grave deeply for him, but in the morning they again saw that the earth had thrown his body out. They said, "This is an act of Muhammad and his companions. They dug the grave of our companion and threw his body outside it, for he had run away from them." They dug the grave for him as deep as they could, but in the morning they again saw that the earth had thrown his body out. So they believed that what had befallen him was not done by human beings and had to leave him thrown (on the ground).


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.815]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 815

Narrated Abu Huraira:

Allah's Apostle said, "When Khosrau perishes, there will be no (more) Khosrau after him, and when Caesar perishes, there will be no more Caesar after him. By Him in Whose Hands Muhammad's life is, you will spend the treasures of both of them in Allah's Cause."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.816]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 816

Narrated Jabir bin Samura:

The Prophet said, "When Khosrau perishes, there will be no more Khosrau a after him, and when Caesar perishes, there will be no more Caesar after him," The Prophet also said, "You will spend the treasures of both of them in Allah's Cause."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.817]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 817

Narrated Ibn Abbas:

Musailama-al-Kadhdhab (i.e. the liar) came in the life-time of Allah's Apostle with many of his people (to Medina) and said, "If Muhammad makes me his successor, I will follow him." Allah's Apostle went up to him with Thabit bin Qais bin Shams; and Allah's Apostle was carrying a piece of a date-palm leaf in his hand. He stood before Musailama (and his companions) and said, "If you asked me even this piece (of a leaf), I would not give it to you. You cannot avoid the fate you are destined to, by Allah. If you reject Islam, Allah will destroy you. I think that you are most probably the same person whom I have seen in the dream." Abu Huraira told me that Allah's Apostle; said, "While I was sleeping, I saw (in a dream) two gold bracelets round my arm, and that worried me too much. Then I was instructed divinely in my dream, to blow them off and so I blew them off, and they flew away. I interpreted the two bracelets as symbols of two liars who would appear after me. And so one of them was Al-Ansi and the other was Musailama Al-Kadhdhab from Al-Yamama."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.818]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 818

Narrated Abu Musa:

The Prophet said, "In a dream I saw myself migrating from Mecca to a place having plenty of date trees. I thought that it was Al-Yamama or Hajar, but it came to be Medina i.e. Yathrib. In the same dream I saw myself moving a sword and its blade got broken. It came to symbolize the defeat which the Muslims suffered from, on the Day of Uhud. I moved the sword again, and it became normal as before, and that was the symbol of the victory Allah bestowed upon Muslims and their gathering together. I saw cows in my dream, and by Allah, that was a blessing, and they symbolized the believers on the Day of Uhud. And the blessing was the good Allah bestowed upon us and the reward of true belief which Allah gave us after the day of Badr.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.819]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 819

Narrated 'Aisha:

Once Fatima came walking and her gait resembled the gait of the Prophet . The Prophet said, "Welcome, O my daughter!" Then he made her sit on his right or on his left side, and then he told her a secret and she started weeping. I asked her, "Why are you weeping?" He again told her a secret and she started laughing. I said, "I never saw happiness so near to sadness as I saw today." I asked her what the Prophet had told her. She said, "I would never disclose the secret of Allah's Apostle ." When the Prophet died, I asked her about it. She replied. "The Prophet said.) 'Every year Gabriel used to revise the Qur'an with me once only, but this year he has done so twice. I think this portends my death, and you will be the first of my family to follow me.' So I started weeping. Then he said. 'Don't you like to be the mistress of all the ladies of Paradise or the mistress of all the lady believers? So I laughed for that."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.820]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 820

Narrated 'Aisha:

The Prophet in his fatal illness, called his daughter Fatima and told her a secret because of which she started weeping. Then he called her and told her another secret, and she started laughing. When I asked her about that, she replied, The Prophet told me that he would die in his fatal illness, and so I wept, but then he secretly told me that from amongst his family, I would be the first to join him, and so I laughed."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.821]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 821

Narrated Said bin Jubair:

About Ibn 'Abbas: 'Umar bin Al-Khattab used to treat Ibn 'Abbas very favorably 'Abdur Rahman bin 'Auf said to him. "We also have sons that are equal to him (but you are partial to him.)" Umar said, "It is because of his knowledge." Then 'Umar asked Ibn 'Abbas about the interpretation of the Verse:- 'When come the Help of Allah and the conquest (of Mecca) (110.1) Ibn 'Abbas said. "It portended the death of Allah's Apostle, which Allah had informed him of." 'Umar said, "I do not know from this Verse but what you know."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.822]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 822

Narrated Ibn 'Abbas:

Allah's Apostle in his fatal illness came out, wrapped with a sheet, and his head was wrapped with an oiled bandage. He sat on the pulpit, and praising and glorifying Allah, he said, "Now then, people will increase but the Ansar will decrease in number, so much so that they, compared with the people, will be just like the salt in the! meals. So, if any of you should take over the authority by which he can either benefit some people or harm some others, he should accept the goodness of their good people (i.e. Ansar) and excuse the faults of their wrong-doers." That was the last gathering which the Prophet attended.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.823]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 823

Narrated Abu Bakra:

Once the Prophet brought out Al-Hasan and took him up the pulpit along with him and said, "This son of mine is a Saiyid (i.e. chief) and I hope that Allah will help him bring about reconciliation between two Muslim groups."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.824]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 824

Narrated Anas bin Malik:

The Prophet had informed us of the death of Ja'far and Zaid before the news of their death reached us, and his eyes were shedding tears.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.825]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 825

Narrated Jabir:

(Once) the Prophet said, "Have you got carpets?" I replied, "Whence can we get carpets?" He said, "But you shall soon have carpets." I used to say to my wife, "Remove your carpets from my sight," but she would say, "Didn't the Prophet tell you that you would soon have carpets?" So I would give up my request.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.826]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 826

Narrated 'Abdullah bin Mas'ud:

Sa'd bin Mu'adh came to Mecca with the intention of performing 'Umra, and stayed at the house of Umaiya bin Khalaf Abi Safwan, for Umaiya himself used to stay at Sa'd's house when he passed by Medina on his way to Sham. Umaiya said to Sad, "Will you wait till midday when the people are (at their homes), then you may go and perform the Tawaf round the Ka'ba?" So, while Sad was going around the Ka'ba, Abu Jahl came and asked, "Who is that who is performing Tawaf?" Sad replied, "I am Sad." Abu Jahl said, "Are you circumambulating the Ka'ba safely although you have given refuge to Muhammad and his companions?" Sad said, "Yes," and they started quarreling. Umaiya said to Sad, "Don't shout at Abi-l-Hakam (i.e. Abu Jahl), for he is chief of the valley (of Mecca)." Sad then said (to Abu Jahl). 'By Allah, if you prevent me from performing the Tawaf of the Ka'ba, I will spoil your trade with Sham." Umaiya kept on saying to Sad, "Don't raise your voice." and kept on taking hold of him. Sad became furious and said, (to Umaiya), "Be away from me, for I have heard Muhammad saying that he will kill you." Umaiiya said, "Will he kill me?" Sad said, "Yes,." Umaiya said, "By Allah! When Muhammad says a thing, he never tells a lie." Umaiya went to his wife and said to her, "Do you know what my brother from Yathrib (i.e. Medina) has said to me?" She said, "What has he said?" He said, "He claims that he has heard Muhammad claiming that he will kill me."

She said, By Allah! Muhammad never tells a lie." So when the infidels started to proceed for Badr (Battle) and declared war (against the Muslims), his wife said to him, "Don't you remember what your brother from Yathrib told you?" Umaiya decided not to go but Abu Jahl said to him, "You are from the nobles of the valley of Mecca), so you should accompany us for a day or two." He went with them and thus Allah got him killed.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.827]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 827

Narrated Abu Uthman:

I got the news that Gabriel came to the Prophet while Um Salama was present. Gabriel started talking (to the Prophet and then left. The Prophet said to Um Salama, "(Do you know) who it was?" (or a similar question). She said, "It was Dihya (a handsome person amongst the companions of the Prophet )." Later on Um Salama said, "By Allah! I thought he was none but Dihya, till I heard the Prophet talking about Gabriel in his sermon." (The Sub-narrator asked Abu 'Uthman, "From where have you heard this narration?" He replied, "From Usama bin Zaid.")


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.828]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 828

Narrated 'Abdullah:

Allah's Apostle said, "I saw (in a dream) the people assembled in a gathering, and then Abu Bakr got up and drew one or two buckets of water (from a well) but there was weakness in his drawing. May Allah forgive him. Then 'Umar took the bucket and in his hands it turned into a very large bucket. I had never seen anyone amongst: the people who could draw the water as strongly as 'Umar till all the people drank their fill and watered their camels that knelt down there.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.829]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 829

Narrated 'Abdullah bin 'Umar:

The Jews came to Allah's Apostle and told him that a man and a woman from amongst them had committed illegal sexual intercourse. Allah's Apostle said to them, "What do you find in the Torah (old Testament) about the legal punishment of Ar-Rajm (stoning)?" They replied, (But) we announce their crime and lash them." Abdullah bin Salam said, "You are telling a lie; Torah contains the order of Rajm." They brought and opened the Torah and one of them solaced his hand on the Verse of Rajm and read the verses preceding and following it. Abdullah bin Salam said to him, "Lift your hand." When he lifted his hand, the Verse of Rajm was written there. They said, "Muhammad has told the truth; the Torah has the Verse of Rajm. The Prophet then gave the order that both of them should be stoned to death. ('Abdullah bin 'Umar said, "I saw the man leaning over the woman to shelter her from the stones."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.830]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 830

Narrated Abdullah bin Masud:

During the lifetime of the Prophet the moon was split into two parts and on that the Prophet said, "Bear witness (to thus)."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.831]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 831

Narrated Anas:

That the Meccan people requested Allah's Apostle to show them a miracle, and so he showed them the splitting of the moon.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.832]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 832

Narrated Ibn 'Abbas:

The moon was split into two parts during the lifetime of the Prophet.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.833]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 833

Narrated Anas:

Once two men from the companions of Allah's Apostle went out of the house of the Prophet on a very dark night. They were accompanied by two things that resembled two lamps lighting the way in front of them, and when they parted, each of them was accompanied by one of those two things (lamps) till they reached their homes.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.834]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 834

Narrated Al-Mughira bin Shu'ba:

The Prophet said, "Some of my followers will remain victorious (and on the right path) till the Last Day comes, and they will still be victorious."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.835]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 835

Narrated Muawiya:

I heard the Prophet saying, "A group of people amongst my followers will remain obedient to Allah's orders and they will not be harmed by anyone who will not help them or who will oppose them, till Allah's Order (the Last Day) comes upon them while they are still on the right path."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.836]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 836

Narrated 'Urwa:

That the Prophet gave him one Dinar so as to buy a sheep for him. 'Urwa bought two sheep for him with the money. Then he sold one of the sheep for one Dinar, and brought one Dinar and a sheep to the Prophet. On that, the Prophet invoked Allah to bless him in his deals. So 'Urwa used to gain (from any deal) even if he bought dust. (In another narration) 'Urwa said, "I heard Allah's Apostle saying, "There is always goodness in horses till the Day of Resurrection." (The subnarrator added, "I saw 70 horses in 'Urwa's house.') (Sufyan said, "The Prophet asked 'Urwa to buy a sheep for him as a sacrifice.")


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.837]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 837

Narrated Ibn Umar:

Allah's Apostle said, "There is always goodness in horses till the Day of Resurrection. "


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.838]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 838

Narrated Anas:

The Prophet said, "There is always goodness in horses.


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.839]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 839

Narrated Abu Huraira:

The Prophet said, "A horse may be kept for one of three purposes: for a man it may be a source of reward; for another it may be a means of living; and for a third it may be a burden (a source of committing sins). As for the one for whom it is a source of reward, he is the one who keeps his horse for the sake of Jihad in Allah's Cause; he ties it with a long rope on a pasture or in a garden. So whatever its rope allows it to eat, will be regarded as good rewardable deeds (for its owner). And if it breaks off its rope and jumps over one or two hillocks, even its dung will be considered amongst his good deeds. And if it passes by a river and drinks water from it, that will be considered as good deeds for his benefit) even if he has had no intention of watering it. A horse is a shelter for the one who keeps it so that he may earn his living honestly and takes it as a refuge to keep him from following illegal ways (of gaining money), and does not forget the rights of Allah (i.e. paying the Zakat and allowing others to use it for Allah's Sake). But a horse is a burden (and a source of committing sins for him who keeps it out of pride and pretense and with the intention of harming the Muslims."

The Prophet was asked about donkeys. He replied, "Nothing has been revealed to be concerning them except this comprehensive Verse (which covers everything) :--'Then whosoever has done good equal to the weight of an atom (or a small ant), Shall see it (its reward) And whosoever has done evil equal to the weight of an atom (or a small ) ant), Shall see it (Its punishment)." (99.7-8)


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.840]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 840

Narrated Anas bin Malik:

Allah's Apostle reached Khaibar in the early morning and the people of Khaibar came out with their spades, and when they saw the Prophet they said, "Muhammad and his army!" and returned hurriedly to take refuge in the fort. The Prophet raised his hands and said, "Allah is Greater! Khaibar is ruined ! If we approach a nation, then miserable is the morning of those who are warned."


Bukhari :: Virtues and Merits of the Prophet (pbuh) and his Companions :: [4.56.841]

Virtues and Merits of the Prophet (pbuh) and his Companions

Bukhari :: Book 4 :: Volume 56 :: Hadith 841

Narrated Abu Huraira:

I said, "O Allah's Apostle! I hear many narrations from you but I forget them." He said, "Spread your covering sheet." I spread my sheet and he moved both his hands as if scooping something and emptied them in the sheet and said, "Wrap it." I wrapped it round my body, and since then I have never forgotten a single Hadith.


Bukhari :: Companions of the Prophet :: [5.57.1]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 1

Narrated Abu Said Al-Khudri:

"Allah's Apostle said, "A time will come upon the people, when a group of people will wage a holy war and it will be said, 'Is there amongst you anyone who has accompanied Allah's Apostle?' They will say, 'Yes.' And so victory will be bestowed on them. Then a time will come upon the people when a group of people will wage a holy war, and it will be said, "Is there amongst you a none who has accompanied the companions of Allah's Apostle?' They will say, 'Yes.' And so victory will be bestowed on them. Then a time will come upon the people when a group of people will wage a holy war, and it will be said, "Is there amongst you anyone who has been in the company of the companions of the companions of Allah's Apostle ?' They will say, 'Yes.' And victory will be bestowed on them."


Bukhari :: Companions of the Prophet :: [5.57.2]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 2

Narrated Imran bin Husain:

"Allah's Apostle said, 'The best of my followers are those living in my generation (i.e. my contemporaries). and then those who will follow the latter" 'Imran added, "I do not remember whether he mentioned two or three generations after his generation, then the Prophet added, 'There will come after you, people who will bear witness without being asked to do so, and will be treacherous and untrustworthy, and they will vow and never fulfill their vows, and fatness will appear among them."


Bukhari :: Companions of the Prophet :: [5.57.3]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 3

Narrated Abdullah:

The Prophet said, "The best people are those living in my generation, and then those who will follow them, and then those who will follow the latter. Then there will come some people who will bear witness before taking oaths, and take oaths before bearing witness." (Ibrahim, a sub-narrator said, "They used to beat us for witnesses and covenants when we were still children.")


Bukhari :: Companions of the Prophet :: [5.57.4]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 4

Narrated Al-Bara:

Abu Bakr bought a (camel) saddle from 'Azib for thirteen Dirhams. Abu Bakr said to 'Azib, "Tell Al-Bara' to carry the saddle for me." 'Azib said, "No, unless you relate to me what happened to you and Allah 's Apostle when you left Mecca while the pagans were in search of you." Abu Bakr said, "We left Mecca and we travel led continuously for that night and the following day till it was midday. I looked (around) searching for shade to take as shelter, and suddenly I came across a rock, and found a little shade there. So I cleaned the place and spread a bed for the Prophet in the shade and said to him, 'Lie down, O Allah's Apostle.' So the Prophet lay down and I went out, looking around to see if there was any person pursuing us. Suddenly I saw a shepherd driving his sheep towards the rock, seeking what we had already sought from it. I asked him, 'To whom do you belong, O boy?' He said, 'I belong to a man from Quraish.' He named the man and I recognized him. I asked him, 'Is there any milk with your sheep?' He said, 'Yes.' I said, 'Will you then milk (some) for us?' He said, 'Yes.' Then I asked him to tie the legs of one of the sheep and clean its udder, and then ordered him to clean his hands from dust. Then the shepherd cleaned his hands by striking his hands against one another. After doing so, he milked a small amount of milk. I used to keep for Allah's Apostle a leather water-container, the mouth of which was covered with a piece of cloth. I poured water on the milk container till its lower part was cold. Then I took the milk to the Prophet whom I found awake. I said to him, 'Drink, O Allah's Apostle.' So he drank till I became pleased. Then I said, 'It is time for us to move, O Allahs Apostle!' He said, 'Yes.' So we set out while the people (i.e. Quraish pagans) were searching for us, but none found us except Suraiqa bin Malik bin Jushum who was riding his horse. I said, 'These are our pursuers who have found us. O Allah's Apostle!' He said, 'Do not grieve, for Allah is with us."


Bukhari :: Companions of the Prophet :: [5.57.5]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 5

Narrated Abu Bakr:

I said to the Prophet while I was in the Cave. "If any of them should look under his feet, he would see us." He said, "O Abu Bakr! What do you think of two (persons) the third of whom is Allah?"


Bukhari :: Companions of the Prophet :: [5.57.6]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 6

Narrated Abu Said Al-Khudri:

Allah's Apostle addressed the people saying, "Allah has given option to a slave to choose this world or what is with Him. The slave has chosen what is with Allah." Abu Bakr wept, and we were astonished at his weeping caused by what the Prophet mentioned as to a Slave ( of Allah) who had been offered a choice, (we learned later on) that Allah's Apostle himself was the person who was given the choice, and that Abu Bakr knew best of all of us. Allah's Apostle added, "The person who has favored me most of all both with his company and wealth, is Abu Bakr. If I were to take a Khalil other than my Lord, I would have taken Abu Bakr as such, but (what relates us) is the Islamic brotherhood and friendliness. All the gates of the Mosque should be closed except the gate of Abu Bakr."


Bukhari :: Companions of the Prophet :: [5.57.7]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 7

Narrated Ibn 'Umar:

We used to compare the people as to who was better during the lifetime of Allah's Apostle . We used to regard Abu Bakr as the best, then 'Umar, and then 'Uthman .


Bukhari :: Companions of the Prophet :: [5.57.8]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 8

Narrated Ibn 'Abbas:

The Prophet said, "If I were to take a Khalil, I would have taken Abu Bakr, but he is my brother and my companion (in Islam)."


Bukhari :: Companions of the Prophet :: [5.57.9]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 9

Narrated Aiyub:

The Prophet said, "If I were to take a Khalil, I would have taken him (i.e. Abu Bakr) as a Khalil, but the Islamic brotherhood is better."


Bukhari :: Companions of the Prophet :: [5.57.10]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 10

Narrated 'Abdullah bin Abi Mulaika:

The people of Kufa sent a letter to Ibn Az-Zubair, asking about (the inheritance of) (paternal) grandfather. He replied that the right of the inheritance of (paternal) grandfather is the same as that of father if the father is dead) and added, "Allah's Apostle said, ' If I were to take a Khalil from this nation, I would have taken him (i.e. Abu Bakr)."


Bukhari :: Companions of the Prophet :: [5.57.11]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 11

Narrated Jubair bin Mutim:

A woman came to the Prophet who ordered her to return to him again. She said, "What if I came and did not find you?" as if she wanted to say, "If I found you dead?" The Prophet said, "If you should not find me, go to Abu Bakr."


Bukhari :: Companions of the Prophet :: [5.57.12]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 12

Narrated 'Ammar:

I saw Allah's Apostle and there was none with him but five slaves, two women and Abu Bakr (i.e. those were the only converts to Islam then).


Bukhari :: Companions of the Prophet :: [5.57.13]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 13

Narrated Abu Ad-Darda:

While I was sitting with the Prophet, Abu Bakr came, lifting up one corner of h is garment uncovering h is knee. The Prophet said, "Your companion has had a quarrel." Abu Bakr greeted (the Prophet ) and said, "O Allah's Apostle! There was something (i.e. quarrel) between me and the Son of Al-Khattab. I talked to him harshly and then regretted that, and requested him to forgive me, but he refused. This is why I have come to you." The Prophet said thrice, "O Abu Bakr! May Allah forgive you." In the meanwhile, 'Umar regretted (his refusal of Abu Bakr's excuse) and went to Abu Bakr's house and asked if Abu Bakr was there. They replied in the negative. So he came to the Prophet and greeted him, but signs of displeasure appeared on the face of the Prophet till Abu Bakr pitied ('Umar), so he knelt and said twice, "O Allah's Apostle! By Allah! I was more unjust to him (than he to me)." The Prophet said, "Allah sent me (as a Prophet) to you (people) but you said (to me), 'You are telling a lie,' while Abu Bakr said, 'He has said the truth,' and consoled me with himself and his money." He then said twice, "Won't you then give up harming my companion?" After that nobody harmed Abu Bakr.


Bukhari :: Companions of the Prophet :: [5.57.14]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 14

Narrated 'Amr bin Al-As:

The Prophet deputed me to read the Army of Dhat-as-Salasil. I came to him and said, "Who is the most beloved person to you?" He said, " 'Aisha." I asked, "Among the men?" He said, "Her father." I said, "Who then?" He said, "Then 'Umar bin Al-Khattab." He then named other men.


Bukhari :: Companions of the Prophet :: [5.57.15]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 15

Narrated Abu Huraira:

I heard Allah's Apostle saying, "While a shepherd was amongst his sheep, a wolf attacked them and took away one sheep. When the shepherd chased the wolf, the wolf turned towards him and said, 'Who will be its guard on the day of wild animals when nobody except I will be its shepherd. And while a man was driving a cow with a load on it, it turned towards him and spoke to him saying, 'I have not been created for this purpose, but for ploughing." The people said, "Glorified be Allah." The Prophet said, "But I believe in it and so does Abu Bakr end 'Umar."


Bukhari :: Companions of the Prophet :: [5.57.16]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 16

Narrated Abu Huraira:

I heard Allah's Apostle saying, "While I was sleeping, I saw myself standing at a well, on it there was a bucket. I drew water from the well as much as Allah wished. Then Ibn Abi Quhafa (i.e. Abu Bakr) took the bucket from me and brought out one or two buckets (of water) and there was weakness in his drawing the water. May Allah forgive his weakness for him. Then the bucket turned into a very big one and Ibn Al-Khattab took it over and I had never seen such a mighty person amongst the people as him in performing such hard work, till the people drank to their satisfaction and watered their camels that knelt down there."


Bukhari :: Companions of the Prophet :: [5.57.17]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 17

Narrated Abdullah bin Umar:

That Allah's Apostle said, "Allah will not look on the Day of Judgment at him who drags his robe (behind him) out of pride." Abu Bakr said "One side of my robe slacks down unless I get very cautious about it." Allah's Apostle said, "But you do not do that with a pride."


Bukhari :: Companions of the Prophet :: [5.57.18]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 18

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Anybody who spends a pair of something in Allah's Cause will be called from all the gates of Paradise, "O Allah's slave! This is good.' He who is amongst those who pray will be called from the gate of the prayer (in Paradise) and he who is from the people of Jihad will be called from the gate of Jihad, and he who is from those' who give in charity (i.e. Zakat) will be called from the gate of charity, and he who is amongst those who observe fast will be called from the gate of fasting, the gate of Raiyan." Abu Bakr said, "He who is called from all those gates will need nothing," He added, "Will anyone be called from all those gates, O Allah's Apostle?" He said, "Yes, and I hope you will be among those, O Abu Bakr."


Bukhari :: Companions of the Prophet :: [5.57.19]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 19

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle died while Abu Bakr was at a place called As-Sunah (Al-'Aliya) 'Umar stood up and said, "By Allah! Allah's Apostle is not dead!" 'Umar (later on) said, "By Allah! Nothing occurred to my mind except that." He said, "Verily! Allah will resurrect him and he will cut the hands and legs of some men." Then Abu Bakr came and uncovered the face of Allah's Apostle, kissed him and said, "Let my mother and father be sacrificed for you, (O Allah's Apostle), you are good in life and in death. By Allah in Whose Hands my life is, Allah will never make you taste death twice." Then he went out and said, "O oath-taker! Don't be hasty." When Abu Bakr spoke, 'Umar sat down. Abu Bakr praised and glorified Allah and said, No doubt! Whoever worshipped Muhammad, then Muhammad is dead, but whoever worshipped Allah, then Allah is Alive and shall never die." Then he recited Allah's Statement.:-- "(O Muhammad) Verily you will die, and they also will die." (39.30) He also recited:--

"Muhammad is no more than an Apostle; and indeed many Apostles have passed away, before him, If he dies Or is killed, will you then Turn back on your heels? And he who turns back On his heels, not the least Harm will he do to Allah And Allah will give reward to those Who are grateful." (3.144)

The people wept loudly, and the Ansar were assembled with Sad bin 'Ubada in the shed of Bani Saida. They said (to the emigrants). "There should be one 'Amir from us and one from you." Then Abu Bakr, Umar bin Al-Khattab and Abu 'baida bin Al-Jarrah went to them. 'Umar wanted to speak but Abu Bakr stopped him. 'Umar later on used to say, "By Allah, I intended only to say something that appealed to me and I was afraid that Abu Bakr would not speak so well. Then Abu Bakr spoke and his speech was very eloquent. He said in his statement, "We are the rulers and you (Ansars) are the ministers (i.e. advisers)," Hubab bin Al-Mundhir said, "No, by Allah we won't accept this. But there must be a ruler from us and a ruler from you." Abu Bakr said, "No, we will be the rulers and you will be the ministers, for they (i.e. Quarish) are the best family amongst the 'Arabs and of best origin. So you should elect either 'Umar or Abu 'Ubaida bin Al-Jarrah as your ruler." 'Umar said (to Abu Bakr), "No but we elect you, for you are our chief and the best amongst us and the most beloved of all of us to Allah's Apostle." So 'Umar took Abu Bakr's hand and gave the pledge of allegiance and the people too gave the pledge of allegiance to Abu Bakr. Someone said, "You have killed Sad bin Ubada." 'Umar said, "Allah has killed him." 'Aisha said (in another narration), ("When the Prophet was on his death-bed) he looked up and said thrice, (Amongst) the Highest Companion (See Qur'an 4.69)' Aisha said, Allah benefited the people by their two speeches. 'Umar frightened the people some of whom were hypocrites whom Allah caused to abandon Islam because of 'Umar's speech. Then Abu Bakr led the people to True Guidance and acquainted them with the right path they were to follow so that they went out reciting:-- "Muhammad is no more than an Apostle and indeed many Apostles have passed away before him.." (3.144)


Bukhari :: Companions of the Prophet :: [5.57.20]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 20

Narrated Muhammad bin Al-Hanafiya:

I asked my father ('Ali bin Abi Talib), "Who are the best people after Allah's Apostle ?" He said, "Abu Bakr." I asked, "Who then?" He said, "Then 'Umar. " I was afraid he would say "Uthman, so I said, "Then you?" He said, "I am only an ordinary person.


Bukhari :: Companions of the Prophet :: [5.57.21]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 21

Narrated 'Aisha:

We went out with Allah's Apostle on one of his journeys till we reached Al-Baida or Dhatul-Jaish where my necklace got broken (and lost). Allah's Apostle stopped to search for it and the people too stopped with him. There was no water at that place and they had no water with them. So they went to Abu Bakr and said, "Don't you see what 'Aisha has done? She has made Allah's Apostle and the people stop where there is no water and they have no water with them. Abu Bakr came while Allah's Apostle was sleeping with his head on my thigh and said, "You detained Allah Apostle and the people where there is no water and they have no water." He then admonished me and said what Allah wished and pinched me at my flanks with his hands, but I did not move because the head of Allah's Apostle was on my thigh .

Allah's Apostle kept on sleeping till be got up in the morning and found no water. Then Allah revealed the Divine Verse of Tayammum, and the people performed Tayammum. Usaid bin AlHudair said. "O family of Abu Bakr! This is not the first blessings of yours." We urged the camel on which I was sitting to get up from its place and the necklace was found under it.


Bukhari :: Companions of the Prophet :: [5.57.22]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 22

Narrated Abu Said:

The Prophet said, "Do not abuse my companions for if any one of you spent gold equal to Uhud (in Allah's Cause) it would not be equal to a Mud or even a half Mud spent by one of them."


Bukhari :: Companions of the Prophet :: [5.57.23]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 23

Narrated Abu Musa Al-Ashari:

I performed ablution in my house and then went out and said, "Today I shall stick to Allah's Apostle and stay with him all this day of mine (in his service)." I went to the Mosque and asked about the Prophet . They said, "He had gone in this direction." So I followed his way, asking about him till he entered a place called Bir Aris. I sat at its gate that was made of date-palm leaves till the Prophet finished answering the call of nature and performed ablution. Then I went up to him to see him sitting at the well of Aris at the middle of its edge with his legs uncovered, hanging in the well. I greeted him and went back and sat at the gate. I said, "Today I will be the gatekeeper of the Prophet." Abu Bakr came and pushed the gate. I asked, "Who is it?" He said, "Abu Bakr." I told him to wait, went in and said, "O Allah's Apostle! Abu Bakr asks for permission to enter." He said, "Admit him and give him the glad tidings that he will be in Paradise." So I went out and said to Abu Bakr, "Come in, and Allah's Apostle gives you the glad tidings that you will be in Paradise" Abu Bakr entered and sat on the right side of Allah's Apostle on the built edge of the well and hung his legs n the well as the Prophet did and uncovered his legs. I then returned and sat (at the gate). I had left my brother performing ablution and he intended to follow me. So I said (to myself). "If Allah wants good for so-and-so (i.e. my brother) He will bring him here." Suddenly somebody moved the door. I asked, "Who is it?" He said, "'Umar bin Al-Khattab." I asked him to wait, went to Allah's Apostle, greeted him and said, 'Umar bin Al-Khattab asks the permission to enter." He said, "Admit him, and give him the glad tidings that he will be in Paradise." I went to "Umar and said "Come in, and Allah's Apostle, gives you the glad tidings that you will be in Paradise." So he entered and sat beside Allah's Apostle on the built edge of the well on the left side and hung his legs in the well. I returned and sat (at the gate) and said, (to myself), "If Allah wants good for so-and-so, He will bring him here." Somebody came and moved the door. I asked "Who is it?" He replied, "Uthman bin Affan." I asked him to wait and went to the Prophet and informed him. He said, "Admit him, and give him the glad tidings of entering Paradise, I asked him to wait and went to the Prophet and informed him. He said, "Admit him, and give him the glad tidings of entering Paradise after a calamity that will befall him." So I went up to him and said to him, "Come in; Allah's Apostle gives you the glad tidings of entering Paradise after a calamity that will befall you. "Uthman then came in and found that the built edge of the well was occupied, so he sat opposite to the Prophet on the other side. Said bin Al-Musaiyab said, "I interpret this (narration) in terms of their graves."


Bukhari :: Companions of the Prophet :: [5.57.24]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 24

Narrated Anas bin Malik:

The Prophet once climbed the mountain of Uhud with Abu Bakr, 'Umar and 'Uthman. The mountain shook with them. The Prophet said (to the mountain), "Be firm, O Uhud! For on you there are no more than a Prophet, a Siddiq and two martyrs.


Bukhari :: Companions of the Prophet :: [5.57.25]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 25

Narrated Abdullah bin Umar: Allah's Apostle said. "While (in a dream), I was standing by a well, drawing water from it. Abu Bakr and 'Umar came to me. Abu Bakr took the bucket (from me) and drew one or two buckets of water, and there was some weakness


Bukhari :: Companions of the Prophet :: [5.57.26]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 26

Narrated Ibn 'Abbas:

While I was standing amongst the people who were invoking Allah for Umar bin Al-Khattab who was lying (dead) on his bed, a man behind me rested his elbows on my shoulder and said, "(O 'Umar!) May Allah bestow His Mercy on you. I always hoped that Allah will keep you with your two companions, for I often heard Allah's Apostle saying, "I, Abu Bakr and 'Umar were (somewhere). I, Abu Bakr and 'Umar did (something). I, Abu Bakr and 'Umar set out.' So I hoped that Allah will keep you with both of them." I turned back to see that the speaker was Ali bin Abi Talib.


Bukhari :: Companions of the Prophet :: [5.57.27]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 27

Narrated 'Urwa bin Az-Zubair:

I asked 'Abdullah bin 'Amr, "What was the worst thing the pagans did to Allah's Apostle?" He said, "I saw 'Uqba bin Abi Mu'ait coming to the Prophet while he was praying.' Uqba put his sheet round the Prophet's neck and squeezed it very severely. Abu Bakr came and pulled 'Uqba away from the Prophet and said, "Do you intend to kill a man just because he says: 'My Lord is Allah, and he has brought forth to you the Evident Signs from your Lord?"


Bukhari :: Companions of the Prophet :: [5.57.28]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 28

Narrated Jabir bin Abdullah:

The Prophet said, "I saw myself (in a dream) entering Paradise, and behold! I saw Ar-Rumaisa', Abu Talha's wife. I heard footsteps. I asked, Who is it? Somebody said, 'It is Bilal ' Then I saw a palace and a lady sitting in its courtyard. I asked, 'For whom is this palace?' Somebody replied, 'It is for 'Umar.' I intended to enter it and see it, but I thought of your ('Umar's) Ghira (and gave up the attempt)." 'Umar said, "Let my parents be sacrificed for you, O Allah's Apostle! How dare I think of my Ghira (self-respect) being offended by you?


Bukhari :: Companions of the Prophet :: [5.57.29]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 29

Narrated Abu Huraira:

While we were with Allah's Apostle he said, "While I was sleeping, I saw myself in Paradise, and suddenly I saw a woman performing ablution beside a palace. I asked, 'For whom is this palace?' They replied, 'It is for 'Umar.' Then I remembered 'Umar's Ghira (self-respect) and went away quickly." Umar wept and Said, O Allah's Apostle! How dare I think of my ghira (self-respect) being offended by you?


Bukhari :: Companions of the Prophet :: [5.57.30]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 30

Narrated Hamza's father:

Allah's Apostle said, "While I was sleeping, I saw myself drinking (i.e. milk), and I was so contented that I saw the milk flowing through my nails. Then I gave (the milk) to 'Umar." They (i.e. the companions of the Prophet) asked, "What do you interpret it?" He said, "Knowledge."


Bukhari :: Companions of the Prophet :: [5.57.31]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 31

Narrated 'Abdullah bin 'Umar:

The Prophet said, "In a dream I saw myself drawing water from a well with a bucket. Abu Bakr came and drew a bucket or two weakly. May Allah forgive him. Then 'Umar bin Al-Khattab came and the bucket turned into a very large one in his hands. I had never seen such a mighty person as he in doing such hard work till all the people drank to their satisfaction and watered their camels that knelt down there.


Bukhari :: Companions of the Prophet :: [5.57.32]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 32

Narrated Sad bin Abi Waqqas:

Umar bin Al-Khattab asked the permission of Allah's Apostle to see him while some Quraishi women were sitting with him, talking to him and asking him for more expenses, raising their voices above the voice of Allah's Apostle.

When 'Umar asked for the permission to enter, the women quickly put on their veils. Allah'� Apostle allowed him to enter and 'Umar came in while Allah's Apostle was smiling, 'Umar said "O Allah's Apostle! May Allah always keep you smiling." The Prophet said, "These women who have been here, roused my wonder, for as soon as they heard your voice, they quickly put on their veils. "'Umar said, "O Allah's Apostle! You have more right to be feared by them than I." Then 'Umar addressed the women saying, "O enemies of yourselves! You fear me more than you do Allah's Apostle ?" They said, "Yes, for you are harsher and sterner than Allah's Apostle." Then Allah's Apostle said, "O Ibn Al-Khattab! By Him in Whose Hands my life is! Never does Satan find you going on a way, but he takes another way other than yours."


Bukhari :: Companions of the Prophet :: [5.57.33]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 33

Narrated Abdullah:

We have been powerful since 'Umar embraced Islam.


Bukhari :: Companions of the Prophet :: [5.57.34]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 34

Narrated Ibn Abbas:

When (the dead body of) 'Umar was put on his deathbed, the people gathered around him and invoked (Allah) and prayed for him before the body was taken away, and I was amongst them. Suddenly I felt somebody taking hold of my shoulder and found out that he was 'Ali bin Abi Talib. 'Ali invoked Allah's Mercy for 'Umar and said, "O 'Umar! You have not left behind you a person whose deeds I like to imitate and meet Allah with more than I like your deeds. By Allah! I always thought that Allah would keep you with your two companions, for very often I used to hear the Prophet saying, 'I, Abu Bakr and 'Umar went (somewhere); I, Abu Bakr and 'Umar entered (somewhere); and I, Abu Bakr and 'Umar went out."'


Bukhari :: Companions of the Prophet :: [5.57.35]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 35

Narrated Anas bin Malik:

The Prophet ascended the mountain of Uhud and he was accompanied by Abu Bakr, 'Umar and 'Uthman. The mountain shook beneath them. The Prophet hit it with his foot and said, "O Uhud ! Be firm, for on you there is none but a Prophet, a Siddiq and a martyr (i.e. and two martyrs).


Bukhari :: Companions of the Prophet :: [5.57.36]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 36

Narrated Aslam:

Ibn 'Umar asked me about some matters concerning 'Umar. He said, "Since Allah's Apostle died. I have never seen anybody more serious, hard working and generous than 'Umar bin Al-Khattab (till the end of his life."


Bukhari :: Companions of the Prophet :: [5.57.37]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 37

Narrated Anas:

A man asked the Prophet about the Hour (i.e. Day of Judgment) saying, "When will the Hour be?" The Prophet said, "What have you prepared for it?" The man said, "Nothing, except that I love Allah and His Apostle." The Prophet said, "You will be with those whom you love." We had never been so glad as we were on hearing that saying of the Prophet (i.e., "You will be with those whom you love.") Therefore, I love the Prophet, Abu Bakr and 'Umar, and I hope that I will be with them because of my love for them though my deeds are not similar to theirs.


Bukhari :: Companions of the Prophet :: [5.57.38]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 38

Narrated Abu Huraira:

Allah's Apostle said, "Among the nations before you there used to be people who were inspired (though they were not prophets). And if there is any of such a persons amongst my followers, it is 'Umar."

Narrated Abu Huraira: The Prophet said, "Among the nation of Bani Israel who lived before you, there were men who used to be inspired with guidance though they were not prophets, and if there is any of such persons amongst my followers, it is 'Umar."


Bukhari :: Companions of the Prophet :: [5.57.39]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 39

Narrated Abu Huraira:

Allah's Apostle said, "Whilst a shepherd was amongst his sheep, a wolf attacked them and took away a sheep. The shepherd chased it and got that sheep freed from the wolf. The wolf turned towards the shepherd and said, 'Who will guard the sheep on the day of wild animals when it will have no shepherd except myself?" The people said, "Glorified be Allah." The Prophet said, "But I believe in it and so do Abu Bakr and 'Umar although Abu Bakr and 'Umar were not present there (at the place of the event).


Bukhari :: Companions of the Prophet :: [5.57.40]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 40

Narrated Abu Said Al-Khudri:

I heard Allah's Apostle saying, "While I was sleeping, the people were presented to me (in a dream). They were wearing shirts, some of which were merely covering their (chests). and some were a bit longer. 'Umar was presented before me and his shirt was so long that he was dragging it." They asked, "How have you interpreted it, O Allah's Apostle?" He said, "Religion."


Bukhari :: Companions of the Prophet :: [5.57.41]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 41

Narrated Al-Miswar bin Makhrama:

When 'Umar was stabbed, he showed signs of agony. Ibn 'Abbas, as if intending to encourage 'Umar, said to him, "O Chief of the believers! Never mind what has happened to you, for you have been in the company of Allah's Apostle and you kept good relations with him and you parted with him while he was pleased with you. Then you were in the company of Abu Bakr and kept good relations with him and you parted with him (i.e. he died) while he was pleased with you. Then you were in the company of the Muslims, and you kept good relations with them, and if you leave them, you will leave them while they are pleased with you." 'Umar said, (to Ibn "Abbas), "As for what you have said about the company of Allah's Apostle and his being pleased with me, it is a favor, Allah did to me; and as for what you have said about the company of Abu Bakr and his being pleased with me, it is a favor Allah did to me; and concerning my impatience which you see, is because of you and your companions. By Allah! If (at all) I had gold equal to the earth, I would have ransomed myself with it from the Punishment of Allah before I meet Him."


Bukhari :: Companions of the Prophet :: [5.57.42]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 42

Narrated Abu Musa:

While I was with the Prophet in one of the gardens of Medina, a man came and asked me to open the gate. The Prophet said to me, "Open the gate for him and give him the glad tidings that he will enter Paradise." I opened (the gate) for him, and behold! It was Abu Bakr. I informed him of the glad tidings the Prophet had said, and he praised Allah. Then another man came and asked me to open the gate. The Prophet said to me "Open (the gate) and give him the glad tidings of entering Paradise." I opened (the gate) for him, and behold! It was 'Umar. I informed him of what the Prophet had said, and he praised Allah. Then another man came and asked me to open the gate. The Prophet said to me. "Open (the gate) for him and inform him of the glad tidings, of entering Paradise with a calamity which will befall him. " Behold ! It was 'Uthman, I informed him of what Allah's Apostle had said. He praised Allah and said, "I seek Allah's Aid."


Bukhari :: Companions of the Prophet :: [5.57.43]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 43

Narrated 'Abdullah bin Hisham:

We were with the Prophet while he was holding 'Umar bin Al-Khattab by the hand.


Bukhari :: Companions of the Prophet :: [5.57.44]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 44

Narrated Abu Musa:

The Prophet entered a garden and ordered me to guard its gate. A man came and asked permission to enter. The Prophet said, "Admit him and give him the glad tidings of entering Paradise." Behold! It was Abu Bakr. Another man came and asked the permission to enter. The Prophet said, "Admit him and give him the glad tidings of entering Paradise." Behold! It was 'Umar. Then another man came, asking the permission to enter. The Prophet kept silent for a short while and then said, "Admit him and give him the glad tidings of entering Paradise with a calamity which will befall him." Behold! It was 'Uthman bin 'Affan. 'Asim, in another narration, said that the Prophet was sitting in a place where there was water, and he was uncovering both his knees or his knee, and when 'Uthman entered, he covered them (or it).


Bukhari :: Companions of the Prophet :: [5.57.45]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 45

Narrated 'Ubaid-ullah bin 'Adi bin Al-Khiyar:

Al-Miswar bin Makhrama and 'Abdur-Rahman bin Al-Aswad bin 'Abu Yaghuth said (to me), "What forbids you to talk to 'Uthman about his brother Al-Walid because people have talked much about him?" So I went to 'Uthman and when he went out for prayer I said (to him), "I have something to say to you and it is a piece of advice for you " 'Uthman said, "O man, from you." (Umar said: I see that he said, "I seek Refuge with Allah from you.") So I left him and went to them. Then the messenger of Uthman came and I went to him (i.e. 'Uthman), 'Uthman asked, "What is your advice?" I replied, "Allah sent Muhammad with the Truth, and revealed the Divine Book (i.e. Quran) to him; and you were amongst those who followed Allah and His Apostle, and you participated in the two migrations (to Ethiopia and to Medina) and enjoyed the company of Allah's Apostle and saw his way. No doubt, the people are talking much about Al-Walid." 'Uthman said, "Did you receive your knowledge directly from Allah's Apostle ?" I said, "No, but his knowledge did reach me and it reached (even) to a virgin in her seclusion." 'Uthman said, "And then Allah sent Muhammad with the Truth and I was amongst those who followed Allah and His Apostle and I believed in what ever he (i.e. the Prophet) was sent with, and participated in two migrations, as you have said, and I enjoyed the company of Allah's Apostle and gave the pledge of allegiance him. By Allah! I never disobeyed him, nor did I cheat him till Allah took him unto Him. Then I treated Abu Bakr and then 'Umar similarly and then I was made Caliph. So, don't I have rights similar to theirs?" I said, "Yes." He said, "Then what are these talks reaching me from you people? Now, concerning what you mentioned about the question of Al-Walid, Allah willing, I shall deal with him according to what is right." Then he called 'Ali and ordered him to flog him, and 'Ali flogged him (i.e. Al-Walid) eighty lashes.


Bukhari :: Companions of the Prophet :: [5.57.46]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 46

Narrated Anas:

Allah's Apostle ascended the (mountain) of Uhud with Abu Bakr and 'Uthman and it shook. Allah's Apostle said, "Be calm, O Uhud!" I think he stroked it with his foot and added, "There is none on you but a Prophet, a Siddiq and two martyrs." (The two martyrs were Umar and Uthman) (See Hadith No. 24)


Bukhari :: Companions of the Prophet :: [5.57.47]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 47

Narrated Ibn 'Umar:

During the lifetime of the Prophet we considered Abu Bakr as peerless and then 'Umar and then 'Uthman (coming next to him in superiority) and then we used not to differentiate between the companions of the Prophet


Bukhari :: Companions of the Prophet :: [5.57.48]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 48

Narrated 'Uthman:

(the son of Muhib) An Egyptian who came and performed the Hajj to the Kaba saw some people sitting. He enquire, "Who are these people?" Somebody said, "They are the tribe of Quraish." He said, "Who is the old man sitting amongst them?" The people replied, "He is 'Abdullah bin 'Umar." He said, "O Ibn Umar! I want to ask you about something; please tell me about it. Do you know that 'Uthman fled away on the day (of the battle) of Uhud?" Ibn 'Umar said, "Yes." The (Egyptian) man said, "Do you know that 'Uthman was absent on the day (of the battle) of Badr and did not join it?" Ibn 'Umar said, "Yes." The man said, "Do you know that he failed to attend the Ar Ridwan pledge and did not witness it (i.e. Hudaibiya pledge of allegiance)?" Ibn 'Umar said, "Yes." The man said, "Allahu Akbar!" Ibn 'Umar said, "Let me explain to you (all these three things). As for his flight on the day of Uhud, I testify that Allah has excused him and forgiven him; and as for his absence from the battle of Badr, it was due to the fact that the daughter of Allah's Apostle was his wife and she was sick then. Allah's Apostle said to him, "You will receive the same reward and share (of the booty) as anyone of those who participated in the battle of Badr (if you stay with her).' As for his absence from the Ar-Ridwan pledge of allegiance, had there been any person in Mecca more respectable than 'Uthman (to be sent as a representative). Allah's Apostle would have sent him instead of him. No doubt, Allah's Apostle had sent him, and the incident of the Ar-Ridwan pledge of Allegiance happened after 'Uthman had gone to Mecca. Allah's Apostle held out his right hand saying, 'This is 'Uthman's hand.' He stroke his (other) hand with it saying, 'This (pledge of allegiance) is on the behalf of 'Uthman.' Then Ibn 'Umar said to the man, 'Bear (these) excuses in mind with you.'


Bukhari :: Companions of the Prophet :: [5.57.49]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 49

Narrated Anas:

The Prophet ascended the mountain of Uhud and Abu Bakr, 'Umar and 'Uthman were accompanying him. The mountain gave a shake (i.e. trembled underneath them) . The Prophet said, "O Uhud ! Be calm." I think that the Prophet hit it with his foot, adding, "For upon you there are none but a Prophet, a Siddiq and two martyrs."


Bukhari :: Companions of the Prophet :: [5.57.50]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 50

Narrated 'Amr bin Maimun:

I saw 'Umar bin Al-Khattab a few days before he was stabbed in Medina. He was standing with Hudhaifa bin Al-Yaman and 'Uthman bin Hunaif to whom he said, "What have you done? Do you think that you have imposed more taxation on the land (of As-Swad i.e. 'Iraq) than it can bear?" They replied, "We have imposed on it what it can bear because of its great yield." 'Umar again said, "Check whether you have imposed on the land what it can not bear." They said, "No, (we haven't)." 'Umar added, "If Allah should keep me alive I will let the widows of Iraq need no men to support them after me." But only four days had elapsed when he was stabbed (to death ). The day he was stabbed, I was standing and there was nobody between me and him (i.e. Umar) except Abdullah bin 'Abbas. Whenever Umar passed between the two rows, he would say, "Stand in straight lines."

When he saw no defect (in the rows), he would go forward and start the prayer with Takbir. He would recite Surat Yusuf or An-Nahl or the like in the first Rak'a so that the people may have the time to Join the prayer. As soon as he said Takbir, I heard him saying, "The dog has killed or eaten me," at the time he (i.e. the murderer) stabbed him. A non-Arab infidel proceeded on carrying a double-edged knife and stabbing all the persons he passed by on the right and left (till) he stabbed thirteen persons out of whom seven died. When one of the Muslims saw that, he threw a cloak on him. Realizing that he had been captured, the non-Arab infidel killed himself, 'Umar held the hand of 'Abdur-Rahman bin Auf and let him lead the prayer.

Those who were standing by the side of 'Umar saw what I saw, but the people who were in the other parts of the Mosque did not see anything, but they lost the voice of 'Umar and they were saying, "Subhan Allah! Subhan Allah! (i.e. Glorified be Allah)." Abdur-Rahman bin Auf led the people a short prayer. When they finished the prayer, 'Umar said, "O Ibn 'Abbas! Find out who attacked me." Ibn 'Abbas kept on looking here and there for a short time and came to say. "The slave of Al Mughira." On that 'Umar said, "The craftsman?" Ibn 'Abbas said, "Yes." 'Umar said, "May Allah curse him. I did not treat him unjustly. All the Praises are for Allah Who has not caused me to die at the hand of a man who claims himself to be a Muslim. No doubt, you and your father (Abbas) used to love to have more non-Arab infidels in Medina." Al-Abbas had the greatest number of slaves. Ibn 'Abbas said to 'Umar. "If you wish, we will do." He meant, "If you wish we will kill them." 'Umar said, "You are mistaken (for you can't kill them) after they have spoken your language, prayed towards your Qibla, and performed Hajj like yours."

Then Umar was carried to his house, and we went along with him, and the people were as if they had never suffered a calamity before. Some said, "Do not worry (he will be Alright soon)." Some said, "We are afraid (that he will die)." Then an infusion of dates was brought to him and he drank it but it came out (of the wound) of his belly. Then milk was brought to him and he drank it, and it also came out of his belly. The people realized that he would die. We went to him, and the people came, praising him. A young man came saying, "O chief of the believers! Receive the glad tidings from Allah to you due to your company with Allah's Apostle and your superiority in Islam which you know. Then you became the ruler (i.e. Caliph) and you ruled with justice and finally you have been martyred." 'Umar said, "I wish that all these privileges will counterbalance (my shortcomings) so that I will neither lose nor gain anything."

When the young man turned back to leave, his clothes seemed to be touching the ground. 'Umar said, "Call the young man back to me." (When he came back) 'Umar said, "O son of my brother! Lift your clothes, for this will keep your clothes clean and save you from the Punishment of your Lord." 'Umar further said, "O 'Abdullah bin 'Umar! See how much I am in debt to others." When the debt was checked, it amounted to approximately eighty-six thousand. 'Umar said, "If the property of 'Umar's family covers the debt, then pay the debt thereof; otherwise request it from Bani 'Adi bin Ka'b, and if that too is not sufficient, ask for it from Quraish tribe, and do not ask for it from any one else, and pay this debt on my behalf."

'Umar then said (to 'Abdullah), "Go to 'Aisha (the mother of the believers) and say: "Umar is paying his salutation to you. But don't say: 'The chief of the believers,' because today I am not the chief of the believers. And say: "Umar bin Al-Khattab asks the permission to be buried with his two companions (i.e. the Prophet, and Abu Bakr)." Abdullah greeted 'Aisha and asked for the permission for entering, and then entered to her and found her sitting and weeping. He said to her, "'Umar bin Al-Khattab is paying his salutations to you, and asks the permission to be buried with his two companions." She said, "I had the idea of having this place for myself, but today I prefer Umar to myself." When he returned it was said (to 'Umar), "'Abdullah bin 'Umar has come." 'Umar said, "Make me sit up." Somebody supported him against his body and 'Umar asked ('Abdullah), "What news do you have?" He said, "O chief of the believers! It is as you wish. She has given the permission." 'Umar said, "Praise be to Allah, there was nothing more important to me than this. So when I die, take me, and greet 'Aisha and say: "Umar bin Al-Khattab asks the permission (to be buried with the Prophet ), and if she gives the permission, bury me there, and if she refuses, then take me to the grave-yard of the Muslims."

Then Hafsa (the mother of the believers) came with many other women walking with her. When we saw her, we went away. She went in (to 'Umar) and wept there for sometime. When the men asked for permission to enter, she went into another place, and we heard her weeping inside. The people said (to 'Umar), "O chief of the believers! Appoint a successor." Umar said, "I do not find anyone more suitable for the job than the following persons or group whom Allah's Apostle had been pleased with before he died." Then 'Umar mentioned 'Ali, 'Uthman, AzZubair, Talha, Sad and 'Abdur-Rahman (bin Auf) and said, "Abdullah bin 'Umar will be a witness to you, but he will have no share in the rule. His being a witness will compensate him for not sharing the right of ruling. If Sad becomes the ruler, it will be alright: otherwise, whoever becomes the ruler should seek his help, as I have not dismissed him because of disability or dishonesty." 'Umar added, "I recommend that my successor takes care of the early emigrants; to know their rights and protect their honor and sacred things.

I also recommend that he be kind to the Ansar who had lived in Medina before the emigrants and Belief had entered their hearts before them. I recommend that the (ruler) should accept the good of the righteous among them and excuse their wrong-doers, and I recommend that he should do good to all the people of the towns (Al-Ansar), as they are the protectors of Islam and the source of wealth and the source of annoyance to the enemy. I also recommend that nothing be taken from them except from their surplus with their consent. I also recommend that he do good to the 'Arab bedouin, as they are the origin of the 'Arabs and the material of Islam. He should take from what is inferior, amongst their properties and distribute that to the poor amongst them. I also recommend him concerning Allah's and His Apostle's protectees (i.e. Dhimmis) to fulfill their contracts and to fight for them and not to overburden them with what is beyond their ability." So when 'Umar expired, we carried him out and set out walking. 'Abdullah bin 'Umar greeted ('Aisha) and said, "'Umar bin Al-Khattab asks for the permission." 'Aisha said, "Bring him in." He was brought in and buried beside his two companions.

When he was buried, the group (recommended by 'Umar) held a meeting. Then 'Abdur-Rahman said, " Reduce the candidates for rulership to three of you." Az-Zubair said, "I give up my right to Ali." Talha said, "I give up my right to 'Uthman," Sad, 'I give up my right to 'Abdur-Rahman bin 'Auf." 'Abdur-Rahman then said (to 'Uthman and 'Ali), "Now which of you is willing to give up his right of candidacy to that he may choose the better of the (remaining) two, bearing in mind that Allah and Islam will be his witnesses." So both the sheiks (i.e. 'Uthman and 'Ali) kept silent. 'Abdur-Rahman said, "Will you both leave this matter to me, and I take Allah as my Witness that I will not choose but the better of you?" They said, "Yes." So 'Abdur-Rahman took the hand of one of them (i.e. 'Ali) and said, "You are related to Allah's Apostle and one of the earliest Muslims as you know well. So I ask you by Allah to promise that if I select you as a ruler you will do justice, and if I select 'Uthman as a ruler you will listen to him and obey him." Then he took the other (i.e. 'Uthman) aside and said the same to him. When 'Abdur-Rahman secured (their agreement to) this covenant, he said, "O 'Uthman! Raise your hand." So he (i.e. 'Abdur-Rahman) gave him (i.e. 'Uthman) the solemn pledge, and then 'Ali gave him the pledge of allegiance and then all the (Medina) people gave him the pledge of allegiance.


Bukhari :: Companions of the Prophet :: [5.57.51]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 51

Narrated Sahl bin Sad:

Allah's Apostle said, "Tomorrow I will give the flag to a man with whose leadership Allah will grant (the Muslim) victory." So the people kept on thinking the whole night as to who would be given the flag. The next morning the people went to Allah's Apostle and every one of them hoped that he would be given the flag. The Prophet said, "Where is Ali bin Abi Talib?" The people replied, "He is suffering from eye trouble, O Allah's Apostle." He said, "Send for him and bring him to me." So when 'Ali came, the Prophet spat in his eyes and invoked good on him, and he became alright as if he had no ailment. The Prophet then gave him the flag. 'Ali said, "O Allah's Apostle! Shall I fight them (i.e. enemy) till they become like us?" The Prophet said, "Proceed to them steadily till you approach near to them and then invite them to Islam and inform them of their duties towards Allah which Islam prescribes for them, for by Allah, if one man is guided on the right path (i.e. converted to Islam) through you, it would be better for you than (a great number of) red camels."


Bukhari :: Companions of the Prophet :: [5.57.52]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 52

Narrated Salama:

Ali happened to stay behind the Prophet and (did not join him) during the battle of Khaibar for he was having eye trouble. Then he said, "How could I remain behind Allah's Apostle?" So 'Ali set out following the Prophet , When it was the eve of the day in the morning of which Allah helped (the Muslims) to conquer it, Allah's Apostle said, "I will give the flag (to a man), or tomorrow a man whom Allah and His Apostle love will take the flag," or said, "A man who loves Allah and His Apostle; and Allah will grant victory under his leadership." Suddenly came 'Ali whom we did not expect. The people said, "This is 'Ali." Allah's Apostle gave him the flag and Allah granted victory under his leadership.


Bukhari :: Companions of the Prophet :: [5.57.53]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 53

Narrated Abu Hazim:

A man came to Sahl bin Sad and said, "This is so-and-so," meaning the Governor of Medina, "He is calling 'Ali bad names near the pulpit." Sahl asked, "What is he saying?" He (i.e. the man) replied, "He calls him (i.e. 'Ali) Abu Turab." Sahl laughed and said, "By Allah, none but the Prophet called him by this name and no name was dearer to 'Ali than this." So I asked Sahl to tell me more, saying, "O Abu 'Abbas! How (was this name given to 'Ali)?" Sahl said, "'Ali went to Fatima and then came out and slept in the Mosque. The Prophet asked Fatima, "Where is your cousin?" She said, "In the Mosque." The Prophet went to him and found that his (i.e. Ali's) covering sheet had slipped of his back and dust had soiled his back. The Prophet started wiping the dust off his back and said twice, "Get up! O Abu Turab (i.e. O. man with the dust)."


Bukhari :: Companions of the Prophet :: [5.57.54]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 54

Narrated Sad bin 'Ubaida:

A man came to Ibn 'Umar and asked about 'Uthman and Ibn 'Umar mentioned his good deeds and said to the questioner. "Perhaps these facts annoy you?" The other said, "Yes." Ibn 'Umar said, "May Allah stick your nose in the dust (i.e. degrade you)!' Then the man asked him about 'Ali. Ibn 'Umar mentioned his good deeds and said, "It is all true, and that is his house in the midst of the houses of the Prophet. Perhaps these facts have hurt you?" The questioner said, "Yes." Ibn 'Umar said, "May Allah stick your nose in the dust (i.e. degrade you or make you do things which you hate) ! Go away and do whatever you can against me."


Bukhari :: Companions of the Prophet :: [5.57.55]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 55

Narrated 'Ali:

Fatima complained of the suffering caused to her by the hand mill. Some Captives were brought to the Prophet, she came to him but did not find him at home 'Aisha was present there to whom she told (of her desire for a servant). When the Prophet came, Aisha informed him about Fatima's visit. Ali added "So the Prophet came to us, while we had gone to our bed I wanted to get up but the Prophet said, "Remain at your place". Then he sat down between us till I found the coolness of his feet on my chest. Then he said, "Shall I teach you a thing which is better than what you have asked me? When you go to bed, say, 'Allahu-Akbar' thirty-four times, and 'Subhan Allah thirty-three times, and 'Alhamdu-lillah thirty-three times for that is better for you both than a servant."


Bukhari :: Companions of the Prophet :: [5.57.56]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 56

Narrated Ubaida:

Ali said (to the people of 'Iraq), "Judge as you used to judge, for I hate differences (and I do my best ) till the people unite as one group, or I die as my companions have died." And narrated Sad that the Prophet said to 'Ali, "Will you not be pleased from this that you are to me like Aaron was to Moses?"


Bukhari :: Companions of the Prophet :: [5.57.57]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 57

Narrated Abu Huraira:

The people used to say, "Abu Huraira narrates too many narrations." In fact I used to keep close to Allah's Apostle and was satisfied with what filled my stomach. I ate no leavened bread and dressed no decorated striped clothes, and never did a man or a woman serve me, and I often used to press my belly against gravel because of hunger, and I used to ask a man to recite a Quranic Verse to me although I knew it, so that he would take me to his home and feed me. And the most generous of all the people to the poor was Ja'far bin Abi Talib. He used to take us to his home and offer us what was available therein. He would even offer us an empty folded leather container (of butter) which we would split and lick whatever was in it.


Bukhari :: Companions of the Prophet :: [5.57.58]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 58

Narrated Ash-Sha'bi:

Whenever Ibn 'Umar greeted Ibn Jafar, he used to say: "As-salamu-'Alaika (i.e. Peace be on you) O son of Dhu-l-Janahain (son of the two-winged person)."


Bukhari :: Companions of the Prophet :: [5.57.59]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 59

Narrated Anas:

Whenever there was drought, 'Umar bin Al-Khattab used to ask Allah for rain through Al'Abbas bin 'Abdul Muttalib, saying, "O Allah! We used to request our Prophet to ask You for rain, and You would give us. Now we request the uncle of our Prophet to ask You for rain, so give us rain." And they would be given rain."


Bukhari :: Companions of the Prophet :: [5.57.60]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 60

Narrated 'Aisha:

Fatima sent somebody to Abu Bakr asking him to give her her inheritance from the Prophet from what Allah had given to His Apostle through Fai (i.e. booty gained without fighting). She asked for the Sadaqa (i.e. wealth assigned for charitable purposes) of the Prophet at Medina, and Fadak, and what remained of the Khumus (i.e., one-fifth) of the Khaibar booty. Abu Bakr said, "Allah's Apostle said, 'We (Prophets), our property is not inherited, and whatever we leave is Sadaqa, but Muhammad's Family can eat from this property, i.e. Allah's property, but they have no right to take more than the food they need.' By Allah! I will not bring any change in dealing with the Sadaqa of the Prophet (and will keep them) as they used to be observed in his (i.e. the Prophet's) life-time, and I will dispose with it as Allah's Apostle used to do," Then 'Ali said, "I testify that None has the right to be worshipped but Allah, and that Muhammad is His Apostle," and added, "O Abu Bakr! We acknowledge your superiority." Then he (i.e. 'Ali) mentioned their own relationship to Allah's Apostle and their right. Abu Bakr then spoke saying, "By Allah in Whose Hands my life is. I love to do good to the relatives of Allah's Apostle rather than to my own relatives" Abu Bark added: Look at Muhammad through his family (i.e. if you are no good to his family you are not good to him).


Bukhari :: Companions of the Prophet :: [5.57.61]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 61

Narrated Al-Miswar bin Makhrama:

Allah's Apostle said, "Fatima is a part of me, and he who makes her angry, makes me angry."


Bukhari :: Companions of the Prophet :: [5.57.62]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 62

Narrated 'Aisha:

The Prophet called his daughter Fatima during his illness in which he died, and told her a secret whereupon she wept. Then he called her again and told her a secret whereupon she laughed. When I asked her about that, she replied, "The Prophet spoke to me in secret and informed me that he would die in the course of the illness during which he died, so I wept. He again spoke to me in secret and informed me that I would be the first of his family to follow him (after his death) and on that I laughed."


Bukhari :: Companions of the Prophet :: [5.57.63]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 63

Narrated Marwan bin Al-Hakam:

'Uthman bin 'Affan was afflicted with severe nose-bleeding in the year when such illness was prevelant and that prevented him from performing Hajj, and (because of it) he made his will. A man from Quraish came to him and said, "Appoint your successor." 'Uthman asked, "Did the people name him? (i.e. the successor) the man said, "Yes." Uthman asked, "Who is that?" The man remained silent. Another man came to 'Uthman and I think it was Al-Harith. He also said, "Appoint your successor." 'Uthman asked, "Did the people name him?" The man replied "Yes." 'Uthman said, "Who is that?" The man remained silent. 'Uthman said, "Perhaps they have mentioned Az-Zubair?" The man said, "Yes." 'Uthman said, "By Him in Whose Hands my life is, he is the best of them as I know, and the dearest of them to Allah's Apostle ."


Bukhari :: Companions of the Prophet :: [5.57.64]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 64

Narrated Marwan bin Al-Hakam:

While I was with 'Uthman, a man came to him and said, "Appoint your successor." 'Uthman said, "Has such successor been named?" He replied, "Yes, Az-Zubair." 'Uthman said, thrice, "By Allah! Indeed you know that he is the best of you."


Bukhari :: Companions of the Prophet :: [5.57.65]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 65

Narrated Jabir:

The Prophet said, "Every prophet used to have a Hawari (i.e. disciple), and my Hawari is Az-Zubair bin Al-'Awwam."


Bukhari :: Companions of the Prophet :: [5.57.66]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 66

Narrated 'Abdullah bin Az-Zubair:

During the battle of Al-Ahzab, I and 'Umar bin Abi-Salama were kept behind with the women. Behold! I saw (my father) Az-Zubair riding his horse, going to and coming from Bani Quraiza twice or thrice. So when I came back I said, "O my father! I saw you going to and coming from Bani Quraiza?" He said, "Did you really see me, O my son?" I said, "Yes." He said, "Allah's Apostle said, 'Who will go to Bani Quraiza and bring me their news?' So I went, and when I came back, Allah's Apostle mentioned for me both his parents saying, "Let my father and mother be sacrificed for you."'


Bukhari :: Companions of the Prophet :: [5.57.67]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 67

Narrated 'Urwa:

On the day of the battle of Al-Yarmuk, the companions of the Prophet said to Az-Zubair, "Will you attack the enemy vigorously so that we may attack them along with you?" So Az-Zubair attacked them, and they inflicted two wounds over his shoulder, and in between these two wounds there was an old scar he had received on the day of the battle of Badr When I was a child, I used to insert my fingers into those scars in play.


Bukhari :: Companions of the Prophet :: [5.57.68]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 68

Narrated 'Umar:

"Before the Prophet died, he was pleased with him (Talha bin 'Ubaidullah)."


Bukhari :: Companions of the Prophet :: [5.57.69]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 69

Narrated Abu 'Uthman:

During one of the Ghazawat in which Allah's Apostle was fighting, none remained with the Prophet but Talha and Sad.


Bukhari :: Companions of the Prophet :: [5.57.70]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 70

Narrated Qais bin Abi Hazim:

I saw Talha's paralyzed hand with which he had protected the Prophet (from an arrow) .


Bukhari :: Companions of the Prophet :: [5.57.71]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 71

Narrated Sad: On the day of the battle of Uhud the Prophet mentioned for me both hi


Bukhari :: Companions of the Prophet :: [5.57.72]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 72

Narrated Sad:

No doubt, (for some time) I stood for one-third of the Muslims.


Bukhari :: Companions of the Prophet :: [5.57.73]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 73

Narrated Sad bin Abi Waqqas:

No man embraced Islam before the day on which I embraced Islam, and no doubt, I remained for seven days as one third of the then extant Muslims.


Bukhari :: Companions of the Prophet :: [5.57.74]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 74

Narrated Qais:

I heard Sad saying, "I was the first amongst the 'Arabs who shot an arrow for Allah's Cause. We used to fight along with the Prophets, while we had nothing to eat except the leaves of trees so that one's excrete would look like the excrete balls of camel or a sheep, containing nothing to mix them together. Today Banu Asad tribe blame me for not having understood Islam. I would be a loser if my deeds were in vain." Those people complained about Sad to 'Umar, claiming that he did not offer his prayers perfectly.


Bukhari :: Companions of the Prophet :: [5.57.75]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 75

Narrated about the sons-in-law of the Prophet and one of them is Abu Al-'As bin Ar-Rabi'.


Bukhari :: Companions of the Prophet :: [5.57.76]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 76

Narrated Al-Miswar bin Makhrama:

'Ali demanded the hand of the daughter of Abu Jahl. Fatima heard of this and went to Allah's Apostle saying, "Your people think that you do not become angry for the sake of your daughters as 'Ali is now going to marry the daughter of Abu Jahl. "On that Allah's Apostle got up and after his recitation of Tashah-hud. I heard him saying, "Then after! I married one of my daughters to Abu Al-'As bin Al-Rabi' (the husband of Zainab, the daughter of the Prophet ) before Islam and he proved truthful in whatever he said to me. No doubt, Fatima is a part of me, I hate to see her being troubled. By Allah, the daughter of Allah's Apostle and the daughter of Allah's Enemy cannot be the wives of one man." So 'Ali gave up that engagement.

'Al-Miswar further said: I heard the Prophet talking and he mentioned a son-in-law of his belonging to the tribe of Bani 'Abd-Shams. He highly praised him concerning that relationship and said (whenever) he spoke to me, he spoke the truth, and whenever he promised me, he fulfilled his promise."


Bukhari :: Companions of the Prophet :: [5.57.77]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 77

Narrated 'Abdullah bin 'Umar:

The Prophet sent an army under the command of Usama bin Zaid. When some people criticized his leadership, the Prophet said, "If you are criticizing Usama's leadership, you used to criticize his father's leadership before. By Allah! He was worthy of leadership and was one of the dearest persons to me, and (now) this (i.e. Usama) is one of the dearest to me after him (i.e. Zaid)."


Bukhari :: Companions of the Prophet :: [5.57.78]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 78

Narrated Urwa:

Aisha said, "A Qaif (i.e. one skilled in recognizing the lineage of a person through Physiognomy and through examining the body parts of an infant) came to me while the Prophet was present, and Usama bin Zaid and Zaid bin Haritha were Lying asleep. The Qa'if said. These feet (of Usama and his father) are of persons belonging to the same lineage.' " The Prophet was pleased with that saying which won his admiration, and he told 'Aisha of it.


Bukhari :: Companions of the Prophet :: [5.57.79]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 79

Narrated 'Aisha:

The people of the Quraish tribe were worried about the Makhzumiya woman. They said. "Nobody dare speak to him (i.e. the Prophet ) except Usama bin Zaid as he is the most beloved to Allah's Apostle." Aisha said, "A woman from Bani Makhzumiya committed a theft and the people said, 'Who can intercede with the Prophet for her?' So nobody dared speak to him (i.e. the Prophet) but Usama bin Zaid spoke to him. The Prophet said, 'If a reputable man amongst the children of Bani Israel committed a theft, they used to forgive him, but if a poor man committed a theft, they would cut his hand. But I would cut even the hand of Fatima (i.e. the daughter of the Prophet) if she committed a theft."


Bukhari :: Companions of the Prophet :: [5.57.80]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 80

Narrated 'Abdullah bin Dinar:

One day Ibn 'Umar, while in the Mosque, looked at a man who was dragging his clothes while walking in one of the corners of the Mosque He said, "See who is that. I wish he was near to me." Somebody then said (to Ibn 'Umar), "Don't you know him, O Abu 'Abdur-Rahman? He is Muhammad bin Usama." On that Ibn 'Umar bowed his head and dug the earth with his hands and then, said, "If Allah's Apostle saw him, he would have loved him."


Bukhari :: Companions of the Prophet :: [5.57.81]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 81

Narrated Usama bin Zaid:

That the Prophet used to take him (i.e. Usama) and Al-Hassan (in his lap) and say: "O Allah! Love them, as I love them." The freed slave of Usama bin Zaid said, "Al-Hajjaj bin Aiman bin Um Aiman and Aiman Ibn Um Aiman was Usama's brother from the maternal side, and he was one of the Ansar. He was seen by Ibn 'Umar not performing his bowing and prostrations in a perfect manner. So Ibn 'Umar told him to repeat his prayer. Harmala, the freed slave of Usama bin Zaid said that while he was in the company of 'Abdullah bin 'Umar, Al-Hajjaj bin Aiman came in and (while praying) he did not perform his bowing and prostrations properly. So Ibn 'Umar told him to repeat his prayer. When he went away, Ibn 'Umar asked me, "Who is he?" I said, "Al-Hajjaj bin Um Aiman." Ibn 'Umar said, "If Allah's Apostle saw him, he would have loved him." Then Ibn 'Umar mentioned the love of the Prophet for the children of Um Aimn. Sulaiman said that Um Aiman was one of the nurses of the Prophet.


Bukhari :: Companions of the Prophet :: [5.57.82]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 82

The merits of 'Abdullah bin Umar bin Al-Khattab.


Bukhari :: Companions of the Prophet :: [5.57.83]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 83

Narrated Ibn 'Umar:

If a man saw a dream during the lifetime of the Prophet he would narrate it to the Prophet. Once I wished to see a dream and narrate it to the Prophet I was young, unmarried, and used to sleep in the Mosque during the lifetime of the Prophet. I dreamt that two angels took me and went away with me towards the (Hell) Fire which looked like a well with the inside walls built up, and had two side-walls like those of a well. There I saw some people in it whom I knew. I started saying, "I seek Refuge with Allah from the (Hell) Fire, I seek Refuge with Allah from the (Hell) Fire." Then another angel met the other two and said to me, "Do not be afraid." I narrated my dream to Hafsa who, in her turn, narrated it to the Prophet. He said, "What an excellent man Abdullah is if he only observes the night prayer." (Salem, a sub-narrator said, "Abdullah used not to sleep at night but very little hence forward."


Bukhari :: Companions of the Prophet :: [5.57.84]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 84

Narrated Ibn 'Umar from Hafsa his sister:

That the Prophet had said to her, "'Abdullah is a pious man."


Bukhari :: Companions of the Prophet :: [5.57.85]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 85

Narrated 'Alqama:

I went to Sham and offered a two-Rak'at prayer and then said, "O Allah! Bless me with a good pious companion." So I went to some people and sat with them. An old man came and sat by my side. I asked, "Who is he?" They replied, "(He is) Abu-Ad-Darda.' I said (to him), "I prayed to Allah to bless me with a pious companion and He sent you to me." He asked me, "From where are you?" I replied, "From the people of Al-Kufa." He said, "Isn't there amongst you Ibn Um 'Abd, the one who used to carry the shoes, the cushion(or pillow) and the water for ablution? Is there amongst you the one whom Allah gave Refuge from Satan through the request of His Prophet. Is there amongst you the one who keeps the secrets of the Prophet which nobody knows except him?" Abu Darda further asked, "How does 'Abdullah (bin Mas'ud) recite the Sura starting with, 'By the Night as it conceals (the light)." (92.1) Then I recited before him:

'By the Night as it envelops: And by the Day as it appears in brightness; And by male and female.' (91.1-3) On this Abu Ad-Darda' said, "By Allah, the Prophet made me recite the Sura in this way while I was listening to him (reciting it)."


Bukhari :: Companions of the Prophet :: [5.57.86]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 86

Narrated Ibrahim: 'Alqama went to Sham and when he entered the mosque, he said, "O Allah ! Bless me with a pious companion." So he sat with Abu Ad-Darda. Abu Ad-Darda' asked him, "Where are you from?" 'Alqama replied, "From the people of Kufa." Abu Ad


Bukhari :: Companions of the Prophet :: [5.57.87]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 87

Narrated Anas bin Malik:

Allah's Apostle said, " Every nation has an extremely trustworthy man, and the trustworthy man of this (i.e. Muslim) nation is Abu 'Ubaida bin Al-Jarrah."


Bukhari :: Companions of the Prophet :: [5.57.88]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 88

Narrated Hudhaifa:

The Prophet said to the people of Nijran, "I will send you the most trustworthy man." (Every one of) the companions of the Prophet was looking forward (to be that person). He then sent Abu 'Ubaida.


Bukhari :: Companions of the Prophet :: [5.57.89]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 89

Narrated Abu Bakra:

I heard the Prophet talking at the pulpit while Al-Hasan was sitting beside him, and he (i.e. the Prophet ) was once looking at the people and at another time Al-Hasan, and saying, "This son of mine is a Saiyid (i.e. chief) and perhaps Allah will bring about an agreement between two sects of the Muslims through him."


Bukhari :: Companions of the Prophet :: [5.57.90]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 90

Narrated Usama bin Zaid:

That the Prophet used to take him and Al-Hasan, and used to say, "O Allah! I love them, so please love them," or said something similar.


Bukhari :: Companions of the Prophet :: [5.57.91]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 91

Narrated Muhammad:

Anas bin Malik said, "The head of Al-Husain was brought to 'Ubaidullah bin Ziyad and was put in a tray, and then Ibn Ziyad started playing with a stick at the nose and mouth of Al-Husain's head and saying something about his handsome features." Anas then said (to him), "Al-Husain resembled the Prophet more than the others did." Anas added, "His (i.e. Al-Husain's) hair was dyed with Wasma (i.e. a kind of plant used as a dye)."


Bukhari :: Companions of the Prophet :: [5.57.92]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 92

Narrated Al-Bara:

I saw the Prophet carrying Al-Hasan on his shoulder an saying, "O Allah! I love him, so please love him."


Bukhari :: Companions of the Prophet :: [5.57.93]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 93

Narrated 'Uqba bin Al-Harith:

I saw Abu Bakr carrying Al-Hasan and saying, "Let my father be sacrificed for you; you resemble the Prophet and not 'Ali," while 'Ali was laughing at this.


Bukhari :: Companions of the Prophet :: [5.57.94]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 94

Narrated Ibn 'Umar:

Abu Bakr used to say, "Please Muhammad (i.e. the Prophet) by doing good to his family."


Bukhari :: Companions of the Prophet :: [5.57.95]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 95

Narrated Anas:

None resembled the Prophet more than Al-Hasan bin 'Ali did.


Bukhari :: Companions of the Prophet :: [5.57.96]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 96

Narrated Ibn Abi Nu'm:

A person asked 'Abdullah bin 'Umar whether a Muslim could kill flies. I heard him saying (in reply). "The people of Iraq are asking about the killing of flies while they themselves murdered the son of the daughter of Allah's Apostle . The Prophet said, They (i.e. Hasan and Husain) are my two sweet basils in this world."


Bukhari :: Companions of the Prophet :: [5.57.97]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 97

Narrated the merits of Bilal bin Rabah the freed slave of Abu Bakr. The Prophet said (to Bilal), "I heard the sound of your shoes in Paradise just in front of me."


Bukhari :: Companions of the Prophet :: [5.57.98]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 98

Narrated Jabir bin 'Abdullah:

Umar used to say, "Abu Bakr is our chief, and he manumitted our chief," meaning Bilal.


Bukhari :: Companions of the Prophet :: [5.57.99]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 99

Narrated Qais:

Bilal said to Abu Bakr, "If you have bought me for yourself then keep me (for yourself), but if you have bought me for Allah's Sake, then leave me for Allah's Work."


Bukhari :: Companions of the Prophet :: [5.57.100]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 100

Narrated Ibn Abbas:

Once the Prophet embraced me (pressed me to his chest) and said, "O Allah, teach him wisdom (i.e. the understanding of the knowledge of Qur'an)."


Bukhari :: Companions of the Prophet :: [5.57.101]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 101

Narrated Khalid:

As above.


Bukhari :: Companions of the Prophet :: [5.57.102]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 102

Narrated Anas:

The Prophet had informed the people about the death of Zaid, Ja'far and Ibn Rawaha before the news of their death reached them. He said with his eyes flowing with tears, "Zaid took the flag and was martyred; then Ja'far took the flag and was martyred, and then Ibn Rawaha took the flag and was martyred. Finally the flag was taken by one of Allah's Swords (i.e. Khalid bin Al-Walid) and Allah gave them (i.e. the Muslims) victory."


Bukhari :: Companions of the Prophet :: [5.57.103]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 103

Narrated Masruq:

'Abdullah (bin Mas'ud) was mentioned before 'Abdullah bin 'Amr. The latter said, "That is a man I continue to love because I heard Allah's Apostle saying, ' Learn the recitation of the Qur'an from (any of these) four persons: 'Abdullah bin Masud, Salim the freed slave of Abu Hudhaifa, Ubai bin Kab, and Muadh bin Jabal." I do not remember whether he mentioned Ubai first or Muadh.


Bukhari :: Companions of the Prophet :: [5.57.104]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 104

Narrated 'Abdullah bin 'Amr:

Allah's Apostle neither talked in an insulting manner nor did he ever speak evil intentionally. He used to say, "The most beloved to me amongst you is the one who has the best character and manners." He added, " Learn the Qur'an from (any of these) four persons. 'Abdullah bin Mas'ud, Salim the freed slave of Abu Hudhaifa, Ubai bin Ka'b, and Mu'adh bin Jabal."


Bukhari :: Companions of the Prophet :: [5.57.105]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 105

Narrated Alqama:

I went to Sham and was offering a two-Rak'at prayer; I said, "O Allah! Bless me with a (pious) companion." Then I saw an old man coming towards me, and when he came near I said, (to myself), "I hope Allah has given me my request." The man asked (me), "Where are you from?" I replied, "I am from the people of Kufa." He said, "Weren't there amongst you the Carrier of the (Prophet's) shoes, Siwak and the ablution water container? Weren't there amongst you the man who was given Allah's Refuge from the Satan? And weren't there amongst you the man who used to keep the (Prophet's) secrets which nobody else knew? How did Ibn Um 'Abd (i.e. 'Abdullah bin Mas'ud) use to recite Surat-al-lail (the Night:92)?" I recited:--

"By the Night as it envelops By the Day as it appears in brightness. And by male and female." (92.1-3) On that, Abu Darda said, "By Allah, the Prophet made me read the Verse in this way after listening to him, but these people (of Sham) tried their best to let me say something different."


Bukhari :: Companions of the Prophet :: [5.57.106]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 106

Narrated 'Abdur-Rahman bin Yazid:

We asked Hudhaifa to tell us of a person resembling (to some extent) the Prophet in good appearance and straight forward behavior so that we may learn from him (good manners and acceptable conduct). Hudhaifa replied, "I do not know anybody resembling the Prophet (to some extent) in appearance and conduct more than Ibn Um 'Abd.


Bukhari :: Companions of the Prophet :: [5.57.107]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 107

Narrated Abu Musa Al-Ashari:

My brother and I came from Yemen, and for some time we continued to consider 'Abdullah bin Mas'ud as one of the members of the family of the Prophet because we used to see him and his mother going in the house of the Prophet very often.


Bukhari :: Companions of the Prophet :: [5.57.108]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 108

Narrated Ibn Abu Mulaika:

Muawiya offered one Rak'a Witr prayer after the 'Isha prayer, and at that time a freed slave of Ibn 'Abbas was present. He (i.e. the slave) went to Ibn 'Abbas (and told him that Muawiya offered one Rak'a Witr prayer). Ibn Abbas said, "Leave him, for he was in the company of Allah's Apostle."


Bukhari :: Companions of the Prophet :: [5.57.109]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 109

Narrated Ibn Abi Mulaika:

Somebody said to Ibn 'Abbas, "Can you speak to the chief of the believers Muwaiya, as he does not pray except one Rak'a as Witr?" Ibn 'Abbas replied, "He is a Faqih (i.e. a learned man who can give religious verdicts) ."


Bukhari :: Companions of the Prophet :: [5.57.110]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 110

Narrated Humran bin Abbas:

Muawiya said (to the people), "You offer a prayer which we, who were the companions of the Prophet never saw the Prophet offering, and he forbade its offering," i.e. the two Rakat after the compulsory 'Asr prayer.


Bukhari :: Companions of the Prophet :: [5.57.111]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 111

Narrated Al-Miswar bin Makhrama:

Allah's Apostle said, "Fatima is a part of me, and whoever makes her angry, makes me angry."


Bukhari :: Companions of the Prophet :: [5.57.112]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 112

Narrated Abu Salama:

'Aisha said, "Once Allah's Apostle said (to me), 'O Aish ('Aisha)! This is Gabriel greeting you.' I said, 'Peace and Allah's Mercy and Blessings be on him, you see what I don't see' " She was addressing Allah 's Apostle.


Bukhari :: Companions of the Prophet :: [5.57.113]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 113

Narrated Abu Musa Al-Ash'ari:

Allah's Apostle said, "Many amongst men attained perfection but amongst women none attained the perfection except Mary, the daughter of Imran and Asiya, the wife of Pharaoh. And the superiority of 'Aisha to other women is like the superiority of Tharid (i.e. an Arabic dish) to other meals."


Bukhari :: Companions of the Prophet :: [5.57.114]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 114

Narrated Anas bin Malik:

Allah's Apostle said, "The superiority of 'Aisha over other women is like the superiority of Tharid to other meals."


Bukhari :: Companions of the Prophet :: [5.57.115]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 115

Narrated Al-Qasim bin Muhammad:

Once 'Aisha became sick and Ibn 'Abbas went to see her and said, "O mother of the believers! You are leaving for truthful fore-runners i.e. for Allah's Apostle and Abu Bakr.


Bukhari :: Companions of the Prophet :: [5.57.116]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 116

Narrated Abu Wail:

When 'Ali sent 'Ammar and Al-Hasan to (the people of) Kufa to urge them to fight, 'Ammar addressed them saying, "I know that she (i.e. 'Aisha) is the wife of the Prophet in this world and in the Hereafter (world to come), but Allah has put you to test, whether you will follow Him (i.e. Allah) or her."


Bukhari :: Companions of the Prophet :: [5.57.117]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 117

Narrated 'Aisha:

That she borrowed a necklace from Asma' and it was lost. Allah's Apostle sent some of his companions to look for it. During their journey the time of prayer was due and they prayed without ablution. When they returned to the Prophet they complained about it. So the Divine Verse of Tayammum was revealed. Usaid bin Hudair said (to 'Aisha), "May Allah reward you handsomely. By Allah, whenever you have a difficulty, Allah took you out of it and brought with it, a Blessing for the Muslims."


Bukhari :: Companions of the Prophet :: [5.57.118]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 118

Narrated Hisham's father:

When Allah's Apostle was in his fatal illness, he started visiting his wives and saying, "Where will I be tomorrow?" He was anxious to be in 'Aisha's home. 'Aisha said, "So when it was my day, the Prophet became silent (no longer asked the question)."


Bukhari :: Companions of the Prophet :: [5.57.119]

Companions of the Prophet

Bukhari :: Book 5 :: Volume 57 :: Hadith 119

Narrated Hisham's father:

The people used to send presents to the Prophet on the day of 'Aisha's turn. 'Aisha said, "My companions (i.e. the other wives of the Prophet) gathered in the house of Um Salama and said, "0 Um Salama! By Allah, the people choose to send presents on the day of 'Aisha's turn and we too, love the good (i.e. presents etc.) as 'Aisha does. You should tell Allah's Apostle to tell the people to send their presents to him wherever he may be, or wherever his turn may be." Um Salama said that to the Prophet and he turned away from her, and when the Prophet returned to her (i.e. Um Salama), she repeated the same, and the Prophet again turned away, and when she told him the same for the third time, the Prophet said, "O Um Salama! Don't trouble me by harming 'Aisha, for by Allah, the Divine Inspiration never came to me while I was under the blanket of any woman amongst you except her."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.120]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 120

Narrated Ghailan bin Jarir:

I asked Anas, "Tell me about the name 'Al-Ansar.; Did you call yourselves by it or did Allah call you by it?" He said, "Allah called us by it." We used to visit Anas (at Basra) and he used to narrate to us the virtues and deeds of the Ansar, and he used to address me or a person from the tribe of Al-Azd and say, "Your tribe did so-and-so on such-and-such a day."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.121]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 121

Narrated 'Aisha:

The day of Bu'ath (i.e. Day of fighting between the two tribes of the Ansar, the Aus and Khazraj) was brought about by Allah for the good of His Apostle so that when Allah's Apostle reached (Medina), the tribes of Medina had already divided and their chiefs had been killed and wounded. So Allah had brought about the battle for the good of H is Apostle in order that they (i.e. the Ansar) might embrace Islam.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.122]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 122

Narrated Anas:

On the day of the Conquest of Mecca, when the Prophet had given (from the booty) the Quraish, the Ansar said, "By Allah, this is indeed very strange: While our swords are still dribbling with the blood of Quraish, our war booty are distributed amongst them." When this news reached the Prophet he called the Ansar and said, "What is this news that has reached me from you?" They used not to tell lies, so they replied, "What has reached you is true." He said, "Doesn't it please you that the people take the booty to their homes and you take Allah's Apostle to your homes? If the Ansar took their way through a valley or a mountain pass, I would take the Ansar's valley or a mountain pass."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.123]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 123

Narrated Abu Huraira:

The Prophet or Abul-Qasim said, "If the Ansar took their way through a valley or a mountain pass, I would take Ansar's valley. And but for the migration, I would have been one of the Ansar." Abu Huraira used to say, "The Prophet is not unjust (by saying so). May my parents be sacrificed for him, for the Ansar sheltered and helped him," or said a similar sentence.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.124]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 124

Narrated Sa'd's father:

When the emigrants reached Medina. Allah's Apostle established the bond of fraternity between 'Abdur-Rahman and Sad bin Ar-Rabi. Sad said to 'Abdur-Rahman, "I am the richest of all the Ansar, so I want to divide my property (between us), and I have two wives, so see which of the two you like and tell me, so that I may divorce her, and when she finishes her prescribed period (i.e. 'Idda) of divorce, then marry her." Abdur-Rahman said, "May Allah bless your family and property for you; where is your market?" So they showed him the Qainuqa' market. (He went there and) returned with a profit in the form of dried yogurt and butter. He continued going (to the market) till one day he came, bearing the traces of yellow scent. The Prophet asked, "What is this (scent)?" He replied, "I got married." The Prophet asked, "How much Mahr did you give her?" He replied, "I gave her a date-stone of gold or a gold piece equal to the weight of a date-stone." (The narrator, Ibrahim, is in doubt as to which is correct.)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.125]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 125

Narrated Anas:

When 'Abdur-Rahman bin 'Auf came to us, Allah's Apostle made a bond of fraternity between him and Sad bin Ar-Rabi' who was a rich man, Sad said, "The Ansar know that I am the richest of all of them, so I will divide my property into two parts between me and you, and I have two wives; see which of the two you like so that I may divorce her and you can marry her after she becomes lawful to you by her passing the prescribed period (i.e. 'Idda) of divorce. 'Abdur Rahman said, "May Allah bless you your family (i.e. wives) for you." (But 'Abdur-Rahman went to the market) and did not return on that day except with some gain of dried yogurt and butter. He went on trading just a few days till he came to Allah's Apostle bearing the traces of yellow scent over his clothes. Allah's Apostle asked him, "What is this scent?" He replied, "I have married a woman from the Ansar." Allah's Apostle asked, "How much Mahr have you given?" He said, "A date-stone weight of gold or a golden date-stone." The Prophet said, "Arrange a marriage banquet even with a sheep."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.126]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 126

Narrated Abu Huraira:

The Ansar said (to the Prophet ), "Please divide the date-palm trees between us and them (i.e. emigrants)." The Prophet said, "No." The Ansar said, "Let them (i.e. the emigrants) do the labor for us in the gardens and share the date-fruits with us." The emigrants said, "We accepted this."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.127]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 127

Narrated Al-Bara:

I heard the Prophet saying (or the Prophet said), "None loves the Ansar but a believer, and none hates them but a hypocrite. So Allah will love him who loves them, and He will hate him who hates them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.128]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 128

Narrated Anas bin Malik:

The Prophet said, "The sign of Belief is to love the Ansar, and the sign of hypocrisy is to hate the Ansar."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.129]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 129

Narrated Anas:

The Prophet saw the women and children (of the Ansar) coming forward. (The sub-narrator said, "I think that Anas said, 'They were returning from a wedding party.") The Prophet stood up and said thrice, "By Allah! You are from the most beloved people to me."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.130]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 130

Narrated Anas bin Malik:

Once an Ansari woman, accompanied by a son of hers, came to Allah's Apostle. Allah's Apostle spoke to her and said twice, "By Him in Whose Hand my life is, you are the most beloved people to me."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.131]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 131

Narrated Zaid bin Al-Arqam:

The Annwar said, "O Allah's Apostle! Every prophet has his own followers and we have followed you. So will you invoke Allah to let our followers be considered from us (as Ansar too)?" So he invoked Allah accordingly.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.132]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 132

Narrated Abu Hamza:

(A man from the Ansar) The Ansar said, "Every nation has followers and (O Prophet) we have followed you, so invoke Allah to let our followers be considered from us (as Ansar like ourselves)." So the Prophet said, "O Allah! Let their followers be considered as Ansar like themselves."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.133]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 133

Narrated Abu Usaid:

The Prophet said, "The best of the Ansar's families (homes) are those of Banu An-Najjar and then (those of) Banu 'Abdul Ash-hal, then (those of) Banu Al-Harith bin Al-Khazraj and then (those of) Banu Sa'ida; nevertheless, there is good in all the families (houses) of the Ansar." On this, Sad (bin Ubada) said, "I see that the Prophet has preferred some people to us." Somebody said (to him), "No, but he has given you superiority to many."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.134]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 134

Narrated Abu Usaid:

That he heard the Prophet saying, "The best of the Ansar, or the best of the Ansar families (homes) are Banu An-Najjar, Bani 'Abdul Ash-hal, Banu Al-Harith and Banu Sai'da."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.135]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 135

Narrated Abu Humaid:

The Prophet said, "The best of the Ansar families (homes) are the families (homes) of Banu An-Najjar, and then that of Banu 'Abdul Ash-hal, and then that of Banu Al-Harith, and then that of Banu Saida; and there is good in all the families (homes) of the Ansar." Sad bin 'Ubada followed us and said, "O Abu Usaid ! Don't you see that the Prophet compared the Ansar and made us the last of them in superiority?

Then Sad met the Prophet and said, "O Allah's Apostle! In comparing the Ansar's families (homes) as to the degree of superiority, you have made us the last of them." Allah's Apostle replied, "Isn't it sufficient that you are regarded amongst the best?"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.136]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 136

Narrated Usaid bin Hudair:

A man from the Ansar said, "O Allah's Apostle! Will you appoint me as you have appointed so-and-so?" The Prophet said, "After me you will see others given preference to you; so be patient till you meet me at the Tank (i.e. Lake of Kauthar). (on the Day of Resurrection)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.137]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 137

Narrated Anas bin Malik:

The Prophet said to the Ansar, "After me you will see others given preference to you; so be patient till you meet me, and your promised place (of meeting) will be the Tank (i.e. Lake of Kauthar)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.138]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 138

Narrated Yahya bin Said:

That he heard Anas bin Malik when he went with him to Al-Walid, saying, "Once the Prophet called the Ansar in order to give them the territory of Bahrain they said, 'No, unless you give to our emigrant brethren a similar share.' On that he said 'If you do not agree to it, then be patient till you meet me, for after me others will be given preference to you."'


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.139]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 139

Narrated Anas bin Malik:

Allah's Apostle said, "There is no life except the life of the Hereafter; so, O Allah! Improve the state of the Ansar and the Muhajirun." And Anas added that the Prophet also said, "O Allah! Forgive the Ansar."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.140]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 140

Narrated Anas bin Malik:

On the day of the battle of the Trench (i.e. Ghazwat-ul-Khandaq) the Ansar used to say, "We are those who have given the pledge of allegiance to Muhammad for Jihad (i.e. holy fighting) as long as we live." The Prophet , replied to them, "O Allah! There is no life except the life of the Hereafter; so please honor the Ansar and the Emigrants."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.141]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 141

Narrated Sahl:

Allah's Apostle came to us while we were digging the trench and carrying out the earth on our backs. Allah's Apostle then said, "O Allah ! There is no life except the life of the Hereafter, so please forgive the Emigrants and the Ansar."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.142]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 142

Narrated Abu Huraira:

A man came to the Prophet. The Prophet sent a messenger to his wives (to bring something for that man to eat) but they said that they had nothing except water. Then Allah's Apostle said, "Who will take this (person) or entertain him as a guest?" An Ansar man said, "I." So he took him to his wife and said to her, "Entertain generously the guest of Allah's Apostle " She said, "We have got nothing except the meals of my children." He said, "Prepare your meal, light your lamp and let your children sleep if they ask for supper." So she prepared her meal, lighted her lamp and made her children sleep, and then stood up pretending to mend her lamp, but she put it off. Then both of them pretended to be eating, but they really went to bed hungry. In the morning the Ansari went to Allah's Apostle who said, "Tonight Allah laughed or wondered at your action." Then Allah revealed:

"But give them (emigrants) preference over themselves even though they were in need of that And whosoever is saved from the covetousness Such are they who will be successful." (59.9)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.143]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 143

Narrated Anas bin Malik:

Abu Bakr and Al-'Abbas passed by one of the gatherings of the Ansar who were weeping then. He (i.e. Abu Bakr or Al-'Abbas) asked, "Why are you weeping?" They replied, "We are weeping because we remember the gathering of the Prophet with us." So Abu Bakr went to the Prophet and told him of that. The Prophet came out, tying his head with a piece of the hem of a sheet. He ascended the pulpit which he never ascended after that day. He glorified and praised Allah and then said, "I request you to take care of the Ansar as they are my near companions to whom I confided my private secrets. They have fulfilled their obligations and rights which were enjoined on them but there remains what is for them. So, accept the good of the good-doers amongst them and excuse the wrongdoers amongst them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.144]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 144

Narrated Ibn 'Abbas:

Allah's Apostle (in his fatal illness) came out wrapped in a sheet covering his shoulders and his head was tied with an oily tape of cloth till he sat on the pulpit, and after praising and glorifying Allah, he said, "Then-after, O people! The people will go on increasing, but the Ansar will go on decreasing till they become just like salt in a meal. So whoever amongst you will be the ruler and have the power to harm or benefit others, should accept the good of the good-doers amongst them and excuse the wrong-doers amongst them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.145]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 145

Narrated Anas bin Malik:

The Prophet said, "The Ansar are my near companions to whom I confided my private secrets, People will go on increasing but the Ansar will go on decreasing; so accept the good of the good-doers amongst them and excuse the wrong-doers amongst them. "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.146]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 146

Narrated Al-Bara:

A silken cloth was given as a present to the Prophet . His companions started touching it and admiring its softness. The Prophet said, "Are you admiring its softness? The handkerchiefs of Sad bin Muadh (in Paradise) are better and softer than it."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.147]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 147

Narrated Jabir:

I heard the Prophet saying, "The Throne (of Allah) shook at the death of Sad bin Muadh." Through another group of narrators, Jabir added, "I heard the Prophet : saying, 'The Throne of the Beneficent shook because of the death of Sad bin Muadh."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.148]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 148

Narrated Abu Said Al-Khudri:

Some people (i.e. the Jews of Bani bin Quraiza) agreed to accept the verdict of Sad bin Muadh so the Prophet sent for him (i.e. Sad bin Muadh). He came riding a donkey, and when he approached the Mosque, the Prophet said, "Get up for the best amongst you." or said, "Get up for your chief." Then the Prophet said, "O Sad! These people have agreed to accept your verdict." Sad said, "I judge that their warriors should be killed and their children and women should be taken as captives." The Prophet said, "You have given a judgment similar to Allah's Judgment (or the King's judgment)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.149]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 149

Narrated Anas:

Two men left the Prophet on a very dark night. Suddenly a light came in front of them, and when they separated, the light also separated along with them.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.150]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 150

Narrated 'Abdullah bin 'Amr:

I heard the Prophet saying, "Learn the recitation of Qur'an from four persons: Ibn Mas'ud, Salim, the freed slave of Abu Hudhaifa, Ubai and Muadh bin Jabal."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.151]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 151

Narrated the virtue of Sad bin Ubada:

Aisha said, "Before that, he (i.e. Sad) was a pious man."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.152]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 152

Narrated Abu Usaid:

Allah's Apostle said, "The best of the Ansar's houses are those of Bani An-Najjar, then those of Bani 'Abdul Ash-hal, then those of Bani Al-Harith bin Al-Khazraj, then those of Bani Saida; but there is goodness in all the houses of the Ansar." Sad bin Ubada who was one of those who embraced Islam early, said, "I see that Allah's Apostle is giving others superiority above us." Some people said to him, "But he has given you superiority above many other people."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.153]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 153

Narrated Masruq:

'Abdullah bin Masud was mentioned before Abdullah bin 'Amr who said, "That is a man I still love, as I heard the Prophet saying 'Learn the recitation of Quran from four from 'Abdullah bin Mas'ud --he started with him--Salim, the freed slave of Abu Hudaifa, Mu'adh bin Jabal and Ubai bin Ka'b."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.154]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 154

Narrated Anas bin Malik:

The Prophet said to Ubai, "Allah has ordered me to recite to you: 'Those who disbelieve (Surat-al-Bayina 98).' " Ubai said, "Has He mentioned my name?" The Prophet said, "Yes." On hearing this, Ubai started weeping.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.155]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 155

Narrated Qatada:

Anas said, "The Quran was collected in the lifetime of the Prophet by four (men), all of whom were from the Ansar: Ubai, Muadh bin Jabal, Abu Zaid and Zaid bin Thabit." I asked Anas, "Who is Abu Zaid?" He said, "One of my uncles."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.156]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 156

Narrated Anas:

On the day of the battle of Uhud, the people ran away, leaving the Prophet , but Abu- Talha was shielding the Prophet with his shield in front of him. Abu Talha was a strong, experienced archer who used to keep his arrow bow strong and well stretched. On that day he broke two or three arrow bows. If any man passed by carrying a quiver full of arrows, the Prophet would say to him, "Empty it in front of Abu Talha." When the Prophet stated looking at the enemy by raising his head, Abu Talha said, "O Allah's Prophet! Let my parents be sacrificed for your sake! Please don't raise your head and make it visible, lest an arrow of the enemy should hit you. Let my neck and chest be wounded instead of yours." (On that day) I saw 'Aisha, the daughter of Abu Bakr and Um Sulaim both lifting their dresses up so that I was able to see the ornaments of their legs, and they were carrying the water skins of their arms to pour the water into the mouths of the thirsty people and then go back and fill them and come to pour the water into the mouths of the people again. (On that day) Abu Talha's sword fell from his hand twice or thrice.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.157]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 157

Narrated Sad bin Abi Waqqas:

I have never heard the Prophet saying about anybody walking on the earth that he is from the people of Paradise except 'Abdullah bin Salam. The following Verse was revealed concerning him: "And a witness from the children of Israel testifies that this Qur'an is true" (46.10)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.158]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 158

Narrated Qais bin Ubad:

While I was sitting in the Mosque of Medina, there entered a man (Abdullah bin Salam) with signs of solemnity over his face. The people said, "He is one of the people of Paradise." He prayed two light Rakat and then left. I followed him and said, "When you entered the Mosque, the people said, 'He is one of the people of Paradise.' " He said, "By Allah, one ought not say what he does not know; and I will tell you why. In the lifetime of the Prophet I had a dream which I narrated to him. I saw as if I were in a garden." He then described its extension and greenery. He added: In its center there was an iron pillar whose lower end was fixed in the earth and the upper end was in the sky, and at its upper end there was a (ring-shaped) hand-hold. I was told to climb it. I said, "I can't." "Then a servant came to me and lifted my clothes from behind and I climbed till I reached the top (of the pillar). Then I got hold of the hand-hold, and I was told to hold it tightly, then I woke up and (the effect of) the hand-hold was in my hand. I narrated al I that to the Prophet who said, 'The garden is Islam, and the hand-hold is the Most Truth-worthy Hand-Hold. So you will remain as a Muslim till you die." The narrator added: "The man was 'Abdullah bin Salam."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.159]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 159

Narrated Abu Burda:

When I came to Medina. I met Abdullah bin Salam. He said, "Will you come to me so that I may serve you with Sawiq (i.e. powdered barley) and dates, and let you enter a (blessed) house that in which the Prophet entered?" Then he added, "You are In a country where the practice of Riba (i.e. usury) is prevalent; so if somebody owe you something and he sends you a present of a load of chopped straw or a load of barley or a load of provender then do not take it, as it is Riba."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.160]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 160

Narrated Jarir bin 'Abdullah:

Allah's Apostle has never refused to admit me since I embraced Islam, and whenever he saw me, he would smile. (In another narration) Jarir bin 'Abdullah narrated: There was a house called Dhul-Khalasa in the Pre-lslamic Period and it was also called Al-Ka'ba Al-Yamaniya or Al-Ka'ba Ash-Shamiya. Allah's Apostle said to me, "Will you relieve me from Dhul-Khalasa?" So I left for it with 150 cavalrymen from the tribe of Ahmas and then we destroyed it and killed whoever we found there. Then we came to the Prophet and informed him about it. He invoked good upon us and upon the tribe of Ahmas.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.161]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 161

Narrated 'Aisha:

On the day of the battle of Uhud the pagans were defeated completely. Then Satan shouted loudly, "O Allah's slaves! Beware the ones behind you!" So the front files attacked the back ones. Then Hudhaifa looked and saw his father, and said loudly, "O Allah's slaves! My father! My father!" By Allah, they did not stop till they killed him (i.e. Hudaifa's father). Hudhaifa said, "May Allah forgive you!" The sub-narrator said, "By Allah, because of what Hudhaifa said, he remained in a good state till he met Allah (i.e. died)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.162]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 162

Narrated 'Ali:

I heard Allah's Apostle saying (as below).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.163]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 163

Narrated 'Ali:

The Prophet said, "The best of the world's women is Mary (at her lifetime), and the best of the world's women is Khadija (at her lifetime)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.164]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 164

Narrated

'Aisha: I did not feel jealous of any of the wives of the Prophet as much as I did of Khadija (although) she died before he married me, for I often heard him mentioning her, and Allah had told him to give her the good tidings that she would have a palace of Qasab (i.e. pipes of precious stones and pearls in Paradise), and whenever he slaughtered a sheep, he would send her women-friends a good share of it.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.165]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 165

Narrated 'Aisha:

I did not feel jealous of any woman as much as I did of Khadija because Allah's Apostle used to mention her very often. He married me after three years of her death, and his Lord (or Gabriel) ordered him to give her the good news of having a palace of Qasab in Paradise.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.166]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 166

Narrated 'Aisha:

I did not feel jealous of any of the wives of the Prophet as much as I did of Khadija though I did not see her, but the Prophet used to mention her very often, and when ever he slaughtered a sheep, he would cut its parts and send them to the women friends of Khadija. When I sometimes said to him, "(You treat Khadija in such a way) as if there is no woman on earth except Khadija," he would say, "Khadija was such-and-such, and from her I had children."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.167]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 167

Narrated Ismail:

I asked 'Abdullah bin Abi Aufa, "Did the Prophet give glad tidings to Khadija?" He said, "Yes, of a palace of Qasab (in Paradise) where there will be neither any noise nor any fatigue."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.168]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 168

Narrated Abu Huraira:

Gabriel came to the Prophet and said, "O Allah's Apostle! This is Khadija coming to you with a dish having meat soup (or some food or drink). When she reaches you, greet her on behalf of her Lord (i.e. Allah) and on my behalf, and give her the glad tidings of having a Qasab palace in Paradise wherein there will be neither any noise nor any fatigue (trouble) . "

Narrated 'Aisha: Once Hala bint Khuwailid, Khadija's sister, asked the permission of the Prophet to enter. On that, the Prophet remembered the way Khadija used to ask permission, and that upset him. He said, "O Allah! Hala!" So I became jealous and said, "What makes you remember an old woman amongst the old women of Quraish an old woman (with a teethless mouth) of red gums who died long ago, and in whose place Allah has given you somebody better than her?"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.169]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 169

Narrated 'Abdullah bin 'Umar:

The Prophet met Zaid bin 'Amr bin Nufail in the bottom of (the valley of) Baldah before any Divine Inspiration came to the Prophet. A meal was presented to the Prophet but he refused to eat from it. (Then it was presented to Zaid) who said, "I do not eat anything which you slaughter in the name of your stone idols. I eat none but those things on which Allah's Name has been mentioned at the time of slaughtering." Zaid bin 'Amr used to criticize the way Quraish used to slaughter their animals, and used to say, "Allah has created the sheep and He has sent the water for it from the sky, and He has grown the grass for it from the earth; yet you slaughter it in other than the Name of Allah. He used to say so, for he rejected that practice and considered it as something abominable.

Narrated Ibn 'Umar: Zaid bin 'Amr bin Nufail went to Sham, inquiring about a true religion to follow. He met a Jewish religious scholar and asked him about their religion. He said, "I intend to embrace your religion, so tell me some thing about it." The Jew said, "You will not embrace our religion unless you receive your share of Allah's Anger." Zaid said, "'I do not run except from Allah's Anger, and I will never bear a bit of it if I have the power to avoid it. Can you tell me of some other religion?" He said, "I do not know any other religion except the Hanif." Zaid enquired, "What is Hanif?" He said, "Hanif is the religion of (the prophet) Abraham who was neither a Jew nor a Christian, and he used to worship None but Allah (Alone)" Then Zaid went out and met a Christian religious scholar and told him the same as before. The Christian said, "You will not embrace our religion unless you get a share of Allah's Curse." Zaid replied, "I do not run except from Allah's Curse, and I will never bear any of Allah's Curse and His Anger if I have the power to avoid them. Will you tell me of some other religion?" He replied, "I do not know any other religion except Hanif." Zaid enquired, "What is Hanif?" He replied, Hanif is the religion of (the prophet) Abraham who was neither a Jew nor a Christian and he used to worship None but Allah (Alone)" When Zaid heard their Statement about (the religion of) Abraham, he left that place, and when he came out, he raised both his hands and said, "O Allah! I make You my Witness that I am on the religion of Abraham."

Narrated Asma bint Abi Bakr: I saw Zaid bin Amr bin Nufail standing with his back against the Ka'ba and saying, "O people of Quraish! By Allah, none amongst you is on the religion of Abraham except me." He used to preserve the lives of little girls: If somebody wanted to kill his daughter he would say to him, "Do not kill her for I will feed her on your behalf." So he would take her, and when she grew up nicely, he would say to her father, "Now if you want her, I will give her to you, and if you wish, I will feed her on your behalf."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.170]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 170

Narrated Jabir bin 'Abdullah:

When the Ka'ba was rebuilt, the Prophet and 'Abbas went to carry stones. 'Abbas said to the Prophet "(Take off and) put your waist sheet over your neck so that the stones may not hurt you." (But as soon as he took off his waist sheet) he fell unconscious on the ground with both his eyes towards the sky. When he came to his senses, he said, "My waist sheet! My waist sheet!" Then he tied his waist sheet (round his waist).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.171]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 171

Narrated 'Amr bin Dinar and 'Ubaidullah bin Abi Yazid:

In the lifetime of the Prophet there was no wall around the Ka'ba and the people used to pray around the Ka'ba till 'Umar became the Caliph and he built the wall around it. 'Ubaidullah further said, "Its wall was low, so Ibn Az-Zubair built it."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.172]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 172

Narrated 'Aisha:

'Ashura' (i.e. the tenth of Muharram) was a day on which the tribe of Quraish used to fast in the pre-lslamic period of ignorance. The Prophet also used to fast on this day. So when he migrated to Medina, he fasted on it and ordered (the Muslims) to fast on it. When the fasting of Ramadan was enjoined, it became optional for the people to fast or not to fast on the day of Ashura.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.173]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 173

Narrated Ibn 'Abbas:

The people used to consider the performance of 'Umra in the months of Hajj an evil deed on the earth, and they used to call the month of Muharram as Safar and used to say, "When (the wounds over) the backs (of the camels) have healed and the foot-marks (of the camels) have vanished (after coming from Hajj), then 'Umra becomes legal for the one who wants to perform 'Umra." Allah's Apostle and his companions reached Mecca assuming Ihram for Hajj on the fourth of Dhul-Hijja. The Prophet ordered his companions to perform 'Umra (with that lhram instead of Hajj). They asked, "O Allah's Apostle! What kind of finishing of Ihram?" The Prophet said, "Finish the Ihram completely.'


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.174]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 174

Narrated Sa'id bin Al-Musaiyab's grand-father:

In the pre-lslamic period of ignorance a flood of rain came and filled the valley in between the two mountains (around the Ka'ba)......


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.175]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 175

Narrated Qais bin Abi Hazim:

Abu Bakr went to a lady from the Ahmas tribe called Zainab bint Al-Muhajir and found that she refused to speak. He asked, "Why does she not speak." The people said, "She has intended to perform Hajj without speaking." He said to her, "Speak, for it is illegal not to speak, as it is an action of the pre-islamic period of ignorance. So she spoke and said, "Who are you?" He said, "A man from the Emigrants." She asked, "Which Emigrants?" He replied, "From Quraish." She asked, "From what branch of Quraish are you?" He said, "You ask too many questions; I am Abu Bakr." She said, "How long shall we enjoy this good order (i.e. Islamic religion) which Allah has brought after the period of ignorance?" He said, "You will enjoy it as long as your Imams keep on abiding by its rules and regulations." She asked, "What are the Imams?" He said, "Were there not heads and chiefs of your nation who used to order the people and they used to obey them?" She said, "Yes." He said, "So they (i.e. the Imams) are those whom I meant."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.176]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 176

Narrated 'Aisha:

A black lady slave of some of the 'Arabs embraced Islam and she had a hut in the mosque. She used to visit us and talk to us, and when she finished her talk, she used to say: "The day of the scarf was one of our Lord's wonders: Verily! He has delivered me from the land of Kufr." When she said the above verse many times, I (i.e. 'Aisha) asked her, "What was the day of the scarf?" She replied, "Once the daughter of some of my masters went out and she was wearing a leather scarf (round her neck) and the leather scarf fell from her and a kite descended and picked it up, mistaking it for a piece of meat. They (i.e. my masters) accused me of stealing it and they tortured me to such an extent that they even looked for it in my private parts. So, while they all were around me, and I was in my great distress, suddenly the kite came over our heads and threw the scarf, and they took it. I said to them 'This is what you accused me of stealing, though I was innocent."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.177]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 177

Narrated 'Umar:

The Prophet said, "If anybody has to take an oath, he should swear only by Allah." The people of Quraish used to swear by their fathers, but the Prophet said, "Do not swear by your fathers. "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.178]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 178

Narrated 'Abdur-Rahman bin Al-Qasim:

Al-Qasim used to walk in front of the funeral procession. He used not to get up for the funeral procession (in case it passed by him). And he narrated from 'Aisha that she said, "The people of the pre-lslamic period of ignorance used to stand up for the funeral procession. When they saw it they used to say twice: 'You were noble in your family. What are you now?"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.179]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 179

Narrated 'Umar:

The pagans used not to leave Jam' (i.e. Muzdalifa) till the sun had risen on Thabir mountain. The Prophet contradicted them by leaving (Muzdalifa) before the sun rose.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.180]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 180

Narrated Husain:

That Ikrima said, "Kasan Dihaqa means glass full (of something) followed successively with other full glasses." Ibn 'Abbas said, "In the pre-lslamic period of ignorance I heard my father saying, "Provide us with Kasan Dihaqa."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.181]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 181

Narrated Abu Huraira:

The Prophet said, "The most true words said by a poet was the words of Labid." He said, Verily, Everything except Allah is perishable and Umaiya bin As-Salt was about to be a Muslim (but he did not embrace Islam).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.182]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 182

Narrated 'Aisha:

Abu Bakr had a slave who used to give him some of his earnings. Abu Bakr used to eat from it. One day he brought something and Abu Bakr ate from it. The slave said to him, "Do you know what this is?" Abu Bakr then enquired, "What is it?" The slave said, "Once, in the pre-Islamic period of ignorance I foretold somebody's future though I did not know this knowledge of foretelling but I, cheated him, and when he met me, he gave me something for that service, and that is what you have eaten from." Then Abu Bakr put his hand in his mouth and vomited whatever was present in his stomach.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.183]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 183

Narrated Ibn 'Umar:

In the pre-lslamic period of ignorance the people used to bargain with the meat of camels on the principle of Habal-al-Habala which meant the sale of a she-camel that would be born by a she-camel that had not yet been born. The Prophet forbade them such a transaction.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.184]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 184

Narrated Ghailan bin Jarir:

We used to visit Anas bin Malik and he used to talk to us about the Ansar, and used to say to me: "Your people did so-and-so on such-and-such a day, and your people did so-and-so on such-and-such a day."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.185]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 185

Narrated Ibn 'Abbas:

The first event of Qasama in the pre-lslamic period of ignorance was practiced by us (i.e. Banu Hashim). A man from Banu Hashim was employed by a Quraishi man from another branch-family. The (Hashimi) laborer set out with the Quraishi driving his camels. There passed by him another man from Banu Hashim. The leather rope of the latter's bag had broken so he said to the laborer, "Will you help me by giving me a rope in order to tie the handle of my bag lest the camels should run away from me?" The laborer gave him a rope and the latter tied his bag with it. When the caravan halted, all the camels' legs were tied with their fetters except one camel. The employer asked the laborer, "Why, from among all the camels has this camel not been fettered?" He replied, "There is no fetter for it." The Quraishi asked, "Where is its fetter?" and hit the laborer with a stick that caused his death (later on Just before his death) a man from Yemen passed by him. The laborer asked (him), "Will you go for the pilgrimage?" He replied, "I do not think I will attend it, but perhaps I will attend it." The (Hashimi) laborer said, "Will you please convey a message for me once in your life?" The other man said, "yes." The laborer wrote: 'When you attend the pilgrimage, call the family of Quraish, and if they respond to you, call the family of Banu Hashim, and if they respond to you, ask about Abu Talib and tell him that so-and-so has killed me for a fetter." Then the laborer expired. When the employer reached (Mecca), Abu Talib visited him and asked, "What has happened to our companion?" He said, "He became ill and I looked after him nicely (but he died) and I buried him." Then Abu Talib said, "The deceased deserved this from you." After some time, the messenger whom the laborer has asked to convey the message, reached during the pilgrimage season. He called, "O the family of Quraish!" The people replied, "This is Quraish." Then he called, "O the family of Banu Hashim!" Again the people replied, "This is Banu Hashim." He asked, "Who is Abu Talib?" The people replied, "This is Abu Talib." He said, "'So-and-so has asked me to convey a message to you that so-and-so has killed him for a fetter (of a camel)." Then Abu Talib went to the (Quraishi) killer and said to him, "Choose one of three alternatives: (i) If you wish, give us one-hundred camels because you have murdered our companion, (ii) or if you wish, fifty of your men should take an oath that you have not murdered our companion, and if you do not accept this, (iii) we will kill you in Qisas." The killer went to his people and they said, "We will take an oath." Then a woman from Banu Hashim who was married to one of them (i.e.the Quraishis) and had given birth to a child from him, came to Abu Talib and said, "O Abu Talib! I wish that my son from among the fifty men, should be excused from this oath, and that he should not take the oath where the oath-taking is carried on." Abu Talib excused him. Then another man from them came (to Abu Talib) and said, "O Abu Talib! You want fifty persons to take an oath instead of giving a hundred camels, and that means each man has to give two camels (in case he does not take an oath). So there are two camels I would like you to accept from me and excuse me from taking an oath where the oaths are taken. Abu Talib accepted them from him. Then 48 men came and took the oath. Ibn 'Abbas further said:) By Him in Whose Hand my life is, before the end of that year, none of those 48 persons remained alive.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.186]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 186

Narrated 'Aisha:

Allah caused the day of Buath to take place before Allah's Apostle was sent (as an Apostle) so that when Allah's Apostle reached Medina, those people had already divided (in different groups) and their chiefs had been killed or wounded. So Allah made that day precede Allah's Apostle so that they (i.e. the Ansar) might embrace Islam.

Narrated Ibn 'Abbas: To run along the valley between two green pillars of Safa and Marwa (mountains) was not Sunna, but the people in the pre-islamic period of ignorance used to run along it, and used to say: "We do not cross this rain stream except running strongly. "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.187]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 187

Narrated Abu As-Safar:

I heard Ibn 'Abbas saying, "O people! Listen to what I say to you, and let me hear whatever you say, and don't go (without understanding), and start saying, 'Ibn 'Abbas said so-and-so, Ibn 'Abbas said so-and-so, Ibn 'Abbas said so-and-so.' He who wants to perform the Tawaf around the Ka'ba should go behind Al-Hijr (i.e. a portion of the Ka'ba left out unroofed) and do not call it Al-Hatim, for in the pre-Islamic period of ignorance if any man took an oath, he used to throw his whip, shoes or bow in it.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.188]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 188

Narrated 'Amr bin Maimun:

During the pre-lslamic period of ignorance I saw a she-monkey surrounded by a number of monkeys. They were all stoning it, because it had committed illegal sexual intercourse. I too, stoned it along with them.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.189]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 189

Narrated Sufyan:

'Ubaidullah said: "I heard Ibn 'Abbas saying, "Following are some traits of the people of the pre-Islamic period of ignorance (i) to defame the ancestry of other families, (ii) and to wail over the dead." 'Ubaidullah forgot the third trait. Sufyan said, "They say it (i.e. the third trait) was to believe that rain was caused by the influence of stars (i.e. if a special star appears it will rain)."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.190]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 190

Narrated Ibn 'Abbas:

Allah's Apostle was inspired Divinely at the age of forty. Then he stayed in Mecca for thirteen years, and then was ordered to migrate, and he migrated to Medina and stayed there for ten years and then died.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.191]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 191

Narrated Khabbaba:

I came to the Prophet while he was leaning against his sheet cloak in the shade of the Ka'ba. We were suffering greatly from the pagans in those days. i said (to him). "Will you invoke Allah (to help us)?" He sat down with a red face and said, "(A believer among) those who were before you used to be combed with iron combs so that nothing of his flesh or nerves would remain on his bones; yet that would never make him desert his religion. A saw might be put over the parting of his head which would be split into two parts, yet all that would never make him abandon his religion. Allah will surely complete this religion (i.e. Islam) so that a traveler from Sana to Hadra-maut will not be afraid of anybody except Allah." (The sub-narrator, Baiyan added, "Or the wolf, lest it should harm his sheep.")


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.192]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 192

Narrated 'Abdullah:

The Prophet recited Surat An-Najam and prostrated, and there was nobody who did not prostrate then except a man whom I saw taking a handful of pebbles, lifting it, and prostrating on it. He then said, "This is sufficient for me." No doubt I saw him killed as a disbeliever afterwards.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.193]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 193

Narrated 'Abdullah:

While the Prophet was prostrating, surrounded by some of Quraish, 'Uqba bin Abi Mu'ait brought the intestines (i.e. abdominal contents) of a camel and put them over the back of the Prophet. The Prophet did not raise his head, (till) Fatima, came and took it off his back and cursed the one who had done the harm. The Prophet said, "O Allah! Destroy the chiefs of Quraish, Abu Jahl bin Hisham, 'Utba bin Rabi'al, Shaba bin Rabi'a, Umaiya bin Khalaf or Ubai bin Khalaf." (The sub-narrator Shu'ba, is not sure of the last name.) I saw these people killed on the day of Badr battle and thrown in the well except Umaiya or Ubai whose body parts were mutilated but he was not thrown in the well.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.194]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 194

Narrated Said bin Jubair:

'AbdurRahman bin Abza said, "Ask Ibn 'Abbas about these two Qur'anic Verses: 'Nor kill such life as Allah has made sacred, Except for just cause.' (25.168) "And whoever kills a believer intentionally, his recompense is Hell. (4.93)

So I asked Ibn 'Abbas who said, "When the Verse that is in Sura-al-Furqan was revealed, the pagans of Mecca said, 'But we have slain such life as Allah has made sacred, and we have invoked other gods along with Allah, and we have also committed fornication.' So Allah revealed:-- 'Except those who repent, believe, and do good-- (25.70)

So this Verse was concerned with those people. As for the Verse in Surat-an-Nisa (4-93), it means that if a man, after understanding Islam and its laws and obligations, murders somebody, then his punishment is to dwell in the (Hell) Fire forever." Then I mentioned this to Mujahid who said, "Except the one who regrets (one's crime) . "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.195]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 195

Narrated 'Urwa bin Az-Zubair:

I asked Ibn Amr bin Al-As, "Tell me of the worst thing which the pagans did to the Prophet." He said, "While the Prophet was praying in the Hijr of the Ka'ba; 'Uqba bin Abi Mu'ait came and put his garment around the Prophet's neck and throttled him violently. Abu Bakr came and caught him by his shoulder and pushed him away from the Prophet and said, "Do you want to kill a man just because he says, 'My Lord is Allah?' "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.196]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 196

Narrated 'Urwa:

As above (Hadith 195).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.197]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 197

Narrated 'Ammar bin Yasir:

I saw Allah's Apostle , and the only converts (to Islam) with him, were five slaves, two women and Abu Bakr.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.198]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 198

Narrated Abu Ishaq Saud bin Abi Waqqas:

None embraced Islam, except on the day I embraced it. And for seven days I was one of the three persons who were Muslims (one-third of Islam).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.199]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 199

Narrated 'Abdur-Rahman:

"I asked Masruq, 'Who informed the Prophet about the Jinns at the night when they heard the Qur'an?' He said, 'Your father 'Abdullah informed me that a tree informed the Prophet about them.' "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.200]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 200

Narrated Abu Huraira:

That once he was in the, company of the Prophet carrying a water pot for his ablution and for cleaning his private parts. While he was following him carrying it(i.e. the pot), the Prophet said, "Who is this?" He said, "I am Abu Huraira." The Prophet said, "Bring me stones in order to clean my private parts, and do not bring any bones or animal dung." Abu Huraira went on narrating: So I brought some stones, carrying them in the corner of my robe till I put them by his side and went away. When he finished, I walked with him and asked, "What about the bone and the animal dung?" He said, "They are of the food of Jinns. The delegate of Jinns of (the city of) Nasibin came to me--and how nice those Jinns were--and asked me for the remains of the human food. I invoked Allah for them that they would never pass by a bone or animal dung but find food on them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.201]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 201

Narrated Ibn 'Abbas:

When Abu Dhar received the news of the Advent of the Prophet he said to his brother, "Ride to this valley (of Mecca) and try to find out the truth of the person who claims to be a prophet who is informed of the news of Heaven. Listen to what he says and come back to me." So his brother set out and came to the Prophet and listened to some of his talks, and returned to Abu Dhar and said to him. "I have seen him enjoining virtuous behavior and saying something that is not poetry." Abu Dhar said, "You have not satisfied me as to what I wanted." He then took his journey-food and carried a water-skin of his, containing some water till be reached Mecca. He went to the Mosque and searched for the Prophet and though he did not know him, he hated to ask anybody about him. When a part of the night had passed away, 'Ali saw him and knew that he was a stranger. So when Abu Dhar saw 'Ali, he followed him, and none of them asked his companion about anything, and when it was dawn, Abu Dhar took his journey food and his water-skin to the Mosque and stayed there all the day long without being perceived by the Prophet, and when it was evening, he came back to his retiring place. 'Ali passed by him and said, "Has the man not known his dwelling place yet?" So 'Ali awakened him and took him with him and none of them spoke to the other about anything. When it was the third day. 'Ali did the same and Abu Dhar stayed with him. Then 'Ali said "Will you tell me what has brought you here?" Abu Dhar said, "If you give me a firm promise that you will guide me, then I will tell you." 'Ali promised him, and he informed 'Ali about the matter. 'Ali said, "It is true, and he is the Apostle of Allah. Next morning when you get up, accompany me, and if I see any danger for you, I will stop as if to pass water, but if I go on, follow me and enter the place which I will enter." Abu Dhar did so, and followed 'Ali till he entered the place of the Prophet, and Abu Dhar went in with him, Abu Dhar listened to some of the Prophet's talks and embraced Islam on the spot. The Prophet said to him, "Go back to your people and inform them (about it) till you receive my order." Abu Dhar said, "By Him in Whose Hand my life is, I will proclaim my conversion loudly amongst them (i.e. the pagans)." So he went out, and when he reached the Mosque, he said as loudly as possible, "I bear witness that None has the right to be worshipped except Allah, and Muhammad is the Apostle of Allah." The People got up and beat him painfully. Then Al-Abbas came and knelt over him ((to protect him) and said (to the people), "Woe to you! Don't you know that this man belongs to the tribe of Ghifar and your trade to Sha'm is through their way?" So he rescued him from them. Abu Dhar again did the same the next day. They beat him and took vengeance on him and again Al-Abbas knelt over him (to protect him).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.202]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 202

Narrated Qais:

I heard Said bin Zaid bin 'Amr bin Nufail saying in the mosque of Al-Kufa. "By Allah, I have seen myself tied and forced by 'Umar to leave Islam before 'Umar himself embraced Islam. And if the mountain of Uhud could move from its place for the evil which you people have done to 'Uthman, then it would have the right to move from its place."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.203]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 203

Narrated 'Abdullah bin Mus'ud:

We have been powerful since 'Umar embraced Islam.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.204]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 204

Narrated 'Abdullah bin Umar:

While 'Umar was at home in a state of fear, there came Al-'As bin Wail As-Sahmi Abu 'Amr, wearing an embroidered cloak and a shirt having silk hems. He was from the tribe of Bani Sahm who were our allies during the pre-Islamic period of ignorance. Al-'As said to 'Umar "What is wrong with you?" He said, "Your people claim that they would kill me if I become a Muslim." Al-'As said, "Nobody will harm you after I have given protection to you." So Al-'As went out and met the people streaming in the whole valley. He said, "Where are you going?" They said, "We want Ibn Al-Khattab who has embraced Islam." Al-'As said, "There is no way for anybody to touch him." So the people retreated.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.205]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 205

Narrated 'Abdullah bin 'Umar:

When 'Umar embraced Islam, all The (disbelieving) people gathered around his home and said, "'Umar has embraced Islam." At that time I was still a boy and was on the roof of my house. There came a man wearing a cloak of Dibaj (i.e. a kind of silk), and said, "Umar has embraced Islam. Nobody can harm him for I am his protector." I then saw the people going away from 'Umar and asked who the man was, and they said, "Al-'As bin Wail."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.206]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 206

Narrated 'Abdullah bin 'Umar:

I never heard 'Umar saying about something that he thought it would be so-and-so, but he was quite right. Once, while 'Umar was sitting, a handsome man passed by him, 'Umar said, "If I am not wrong, this person is still on his religion of the pre-lslamic period of ignorance or he was their foreteller. Call the man to me." When the man was called to him, he told him of his thought. The man said, "I have never seen such a day on which a Muslim is faced with such an accusation." 'Umar said, "I am determined that you should tell me the truth." He said, "I was a foreteller in the pre-lslamic period of ignorance." Then 'Umar said, "Tell me the most astonishing thing your female Jinn has told you of." He said, "One-day while I was in the market, she came to me scared and said, 'Haven't you seen the Jinns and their despair and they were overthrown after their defeat (and prevented from listening to the news of the heaven) so that they (stopped going to the sky and) kept following camel-riders (i.e. 'Arabs)?" 'Umar said, "He is right." and added, "One day while I was near their idols, there came a man with a calf and slaughtered it as a sacrifice (for the idols). An (unseen) creature shouted at him, and I have never heard harsher than his voice. He was crying, 'O you bold evil-doer! A matter of success! An eloquent man is saying: None has the right to be worshipped except you (O Allah).' On that the people fled, but I said, 'I shall not go away till I know what is behind this.' Then the cry came again: 'O you bold evil-doer! A matter of success! An eloquent man is saying: None has the right to be worshipped except Allah.' I then went away and a few days later it was said, "A prophet has appeared."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.207]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 207

Narrated Qais:

I heard Said bin Zaid saying to the people, "If you but saw me and 'Umar's sister tied and forced by 'Umar to leave Islam while he was not yet a Muslim. And if the mountain of Uhud could move from its place for the evil which you people have done to Uthman, it would have the right to do that."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.208]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 208

Narrated Anas bin Malik:

The people of Mecca asked Allah's Apostle to show them a miracle. So he showed them the moon split in two halves between which they saw the Hiram' mountain.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.209]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 209

Narrated 'Abdullah:

The moon was split ( into two pieces ) while we were with the Prophet in Mina. He said, "Be witnesses." Then a Piece of the moon went towards the mountain.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.210]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 210

Narrated 'Abdullah bin 'Abbas:

During the lifetime of Allah's Apostle the moon was split (into two places).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.211]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 211

Narrated 'Abdullah:

The moon was split (into two pieces).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.212]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 212

Narrated 'Ubaidullah bin 'Adi bin Al-Khiyar:

That Al-Miswar bin Makhrama and 'Abdur-Rahman bin Al-Aswad bin 'Abu Yaghuth had said to him, "What prevents you from speaking to your uncle 'Uthman regarding his brother Al-Walid bin 'Uqba?" The people were speaking against the latter for what he had done. 'Ubaidullah said, "So I kept waiting for 'Uthman, and when he went out for the prayer, I said to him, 'I have got something to say to you as a piece of advice.' 'Uthman said, 'O man! I seek Refuge with Allah from you. So I went away. When I finished my prayer, I sat with Al-Miswar and Ibn 'Abu Yaghuth and talked to both of them of what I had said to 'Uthman and what he had said to me. They said, 'You have done your duty.' So while I was sitting with them. 'Uthman's Messenger came to me. They said, 'Allah has put you to trial." I set out and when I reached 'Uthman, he said, 'What is your advice which you mentioned a while ago?' I recited Tashahhud and added, 'Allah has sent Muhammad and has revealed the Holy Book (i.e. Quran) to him. You (O Uthman!) were amongst those who responded to the call of Allah and His Apostle and had faith in him. And you took part in the first two migrations (to Ethiopia and to Medina), and you enjoyed the company of Allah's Apostle and learned his traditions and advice. Now the people are talking much about Al-Walid bin 'Uqba and so it is your duty to impose on him the legal punishment.' 'Uthman then said to me, 'O my nephew! Did you ever meet Allah's Apostle ?' I said, 'No, but his knowledge has reached me as it has reached the virgin in her seclusion.' 'Uthman then recited Tashahhud and said, 'No doubt, Allah has sent Muhammad with the Truth and has revealed to him His Holy Book (i.e. Quran) and I was amongst those who responded to the call of Allah and His Apostle and I had faith in Muhammad's Mission, and I had performed the first two migrations as you have said, and I enjoyed the company of Allah's Apostle and gave the pledge of allegiance to him. By Allah, I never disobeyed him and never cheated him till Allah caused him to die. Then Allah made Abu Bakr Caliph, and by Allah, I was never disobedient to him, nor did I cheat him. Then 'Umar became Caliph, and by Allah, I was never disobedient to him, nor did I cheat him. Then I became Caliph. Have I not then the same rights over you as they had over me?' I replied in the affirmative. 'Uthman further said, 'The what are these talks which are reaching me from you? As for what you ha mentioned about Al-Walid bin 'Uqb; Allah willing, I shall give him the leg; punishment justly. Then Uthman ordered that Al-Walid be flogged fort lashes. He ordered 'Ali to flog him an he himself flogged him as well."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.213]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 213

Narrated 'Aisha:

Um Habiba and Um Salama mentioned a church they had seen in Ethiopia and in the church there were pictures. When they told the Prophet of this, he said, "Those people are such that if a pious man amongst them died, they build a place of worship over his grave and paint these pictures in it. Those people will be Allah's worst creatures on the Day of Resurrection . "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.214]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 214

Narrated Um Khalid bint Khalid:

When I came from Ethiopia (to Medina), I was a young girl. Allah's Apostle made me wear a sheet having marks on it. Allah's Apostle was rubbing those marks with his hands saying, "Sanah! Sanah!" (i.e. good, good).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.215]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 215

Narrated 'Abdullah:

We used to greet the Prophet while he used to be in prayers, and he used to reply to our greetings. But when we came back from Najashi (the King of Ethiopia) we greeted him (while he was praying) and he did not reply to us. We said, "O Allah's Apostle! We used to greet you in the past and you used to reply to us." He said, "Verily The Mind is occupied and busy with more important matter during the prayer." (So one cannot return One's greetings.)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.216]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 216

Narrated Abu Musa:

We received the news of the departure of the Prophet (to Medina) while we were in Yemen. So we went on board a ship but our ship took us away to An-Najashi (the Negus) in Ethiopia. There we met Ja'far bin Abi Talib and stayed with him till we came (to Medina) by the time when the Prophet had conquered Khaibar. The Prophet said, "O you people of the ship! You will have (the reward of) two migrations."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.217]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 217

Narrated Jabir:

When Negus died, the Prophet said, "Today a pious man has died. So get up and offer the funeral prayer for your brother Ashama


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.218]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 218

Narrated Jabir bin 'Abdullah Al-Ansari:

Allah's Apostle led the funeral prayer for the Negus and made us stand in rows behind him and I was in the second or third row.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.219]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 219

Narrated Jabir bin 'Abdullah:

The Prophet offered the funeral prayer for Ashama, the Negus, with four Takbir.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.220]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 220

Narrated Abu Huraira:

that Allah's Apostle informed them (i.e. his companions) of the death of Negus, the king of Ethiopia, on the very day on which the latter died, and said, "Ask Allah's Forgiveness for your brother" Abu Huraira further said, "Allah's Apostle made them (i.e. the Muslims) stand in rows at the Musalla (i.e. praying place) and led the funeral prayer for the Negus and said four Takbir."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.221]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 221

Narrated Abu Huraira:

Allah's Apostle, while going out for the battle of Hunain, said, "Tomorrow Allah willing, we will encamp at Khaif Bani Kinana where the pagans(of Quraish) took the oath of Kufr (against the Prophet i.e. to be loyal to heathenism, by boycotting Banu Hashim, the Prophet's folk, See Hadith No. 659 Vol. 2) .


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.222]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 222

Narrated Al-Abbas bin 'Abdul Muttalib:

That he said to the Prophet "You have not been of any avail to your uncle (Abu Talib) (though) by Allah, he used to protect you and used to become angry on your behalf." The Prophet said, "He is in a shallow fire, and had It not been for me, he would have been in the bottom of the (Hell) Fire."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.223]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 223

Narrated Al-Musaiyab:

When Abu Talib was in his death bed, the Prophet went to him while Abu Jahl was sitting beside him. The Prophet said, "O my uncle! Say: None has the right to be worshipped except Allah, an expression I will defend your case with, before Allah." Abu Jahl and 'Abdullah bin Umaya said, "O Abu Talib! Will you leave the religion of 'Abdul Muttalib?" So they kept on saying this to him so that the last statement he said to them (before he died) was: "I am on the religion of 'Abdul Muttalib." Then the Prophet said, " I will keep on asking for Allah's Forgiveness for you unless I am forbidden to do so." Then the following Verse was revealed:--

"It is not fitting for the Prophet and the believers to ask Allah's Forgiveness for the pagans, even if they were their near relatives, after it has become clear to them that they are the dwellers of the (Hell) Fire." (9.113)

The other Verse was also revealed:-- "(O Prophet!) Verily, you guide not whom you like, but Allah guides whom He will ......." (28.56)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.224]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 224

Narrated Abu Said Al-Khudri:

That he heard the Prophet when somebody mentioned his uncle (i.e. Abu Talib), saying, "Perhaps my intercession will be helpful to him on the Day of Resurrection so that he may be put in a shallow fire reaching only up to his ankles. His brain will boil from it."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.225]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 225

Narrated Yazid:

(as above, Hadith 224) using the words: "will make his brain boil."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.226]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 226

Narrated Jabir bin 'Abdullah:

That he heard Allah's Apostle saying, "When the people of Quraish did not believe me (i.e. the story of my Night Journey), I stood up in Al-Hijr and Allah displayed Jerusalem in front of me, and I began describing it to them while I was looking at it."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.227]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 227

Narrated Abbas bin Malik:

Malik bin Sasaa said that Allah's Apostle described to them his Night Journey saying, "While I was lying in Al-Hatim or Al-Hijr, suddenly someone came to me and cut my body open from here to here." I asked Al-Jarud who was by my side, "What does he mean?" He said, "It means from his throat to his pubic area," or said, "From the top of the chest." The Prophet further said, "He then took out my heart. Then a gold tray of Belief was brought to me and my heart was washed and was filled (with Belief) and then returned to its original place. Then a white animal which was smaller than a mule and bigger than a donkey was brought to me." (On this Al-Jarud asked, "Was it the Buraq, O Abu Hamza?" I (i.e. Anas) replied in the affirmative). The Prophet said, "The animal's step (was so wide that it) reached the farthest point within the reach of the animal's sight. I was carried on it, and Gabriel set out with me till we reached the nearest heaven.

When he asked for the gate to be opened, it was asked, 'Who is it?' Gabriel answered, 'Gabriel.' It was asked, 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has Muhammad been called?' Gabriel replied in the affirmative. Then it was said, 'He is welcomed. What an excellent visit his is!' The gate was opened, and when I went over the first heaven, I saw Adam there. Gabriel said (to me). 'This is your father, Adam; pay him your greetings.' So I greeted him and he returned the greeting to me and said, 'You are welcomed, O pious son and pious Prophet.' Then Gabriel ascended with me till we reached the second heaven. Gabriel asked for the gate to be opened. It was asked, 'Who is it?' Gabriel answered, 'Gabriel.' It was asked, 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel answered in the affirmative. Then it was said, 'He is welcomed. What an excellent visit his is!' The gate was opened.

When I went over the second heaven, there I saw Yahya (i.e. John) and 'Isa (i.e. Jesus) who were cousins of each other. Gabriel said (to me), 'These are John and Jesus; pay them your greetings.' So I greeted them and both of them returned my greetings to me and said, 'You are welcomed, O pious brother and pious Prophet.' Then Gabriel ascended with me to the third heaven and asked for its gate to be opened. It was asked, 'Who is it?' Gabriel replied, 'Gabriel.' It was asked, 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel replied in the affirmative. Then it was said, 'He is welcomed, what an excellent visit his is!' The gate was opened, and when I went over the third heaven there I saw Joseph. Gabriel said (to me), 'This is Joseph; pay him your greetings.' So I greeted him and he returned the greeting to me and said, 'You are welcomed, O pious brother and pious Prophet.' Then Gabriel ascended with me to the fourth heaven and asked for its gate to be opened. It was asked, 'Who is it?' Gabriel replied, 'Gabriel' It was asked, 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel replied in the affirmative. Then it was said, 'He is welcomed, what an excel lent visit his is!'

The gate was opened, and when I went over the fourth heaven, there I saw Idris. Gabriel said (to me), 'This is Idris; pay him your greetings.' So I greeted him and he returned the greeting to me and said, 'You are welcomed, O pious brother and pious Prophet.' Then Gabriel ascended with me to the fifth heaven and asked for its gate to be opened. It was asked, 'Who is it?' Gabriel replied, 'Gabriel.' It was asked. 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel replied in the affirmative. Then it was said He is welcomed, what an excellent visit his is! So when I went over the fifth heaven, there I saw Harun (i.e. Aaron), Gabriel said, (to me). This is Aaron; pay him your greetings.' I greeted him and he returned the greeting to me and said, 'You are welcomed, O pious brother and pious Prophet.' Then Gabriel ascended with me to the sixth heaven and asked for its gate to be opened. It was asked. 'Who is it?' Gabriel replied, 'Gabriel.' It was asked, 'Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel replied in the affirmative. It was said, 'He is welcomed. What an excellent visit his is!'

When I went (over the sixth heaven), there I saw Moses. Gabriel said (to me),' This is Moses; pay him your greeting. So I greeted him and he returned the greetings to me and said, 'You are welcomed, O pious brother and pious Prophet.' When I left him (i.e. Moses) he wept. Someone asked him, 'What makes you weep?' Moses said, 'I weep because after me there has been sent (as Prophet) a young man whose followers will enter Paradise in greater numbers than my followers.' Then Gabriel ascended with me to the seventh heaven and asked for its gate to be opened. It was asked, 'Who is it?' Gabriel replied, 'Gabriel.' It was asked,' Who is accompanying you?' Gabriel replied, 'Muhammad.' It was asked, 'Has he been called?' Gabriel replied in the affirmative. Then it was said, 'He is welcomed. What an excellent visit his is!'

So when I went (over the seventh heaven), there I saw Abraham. Gabriel said (to me), 'This is your father; pay your greetings to him.' So I greeted him and he returned the greetings to me and said, 'You are welcomed, O pious son and pious Prophet.' Then I was made to ascend to Sidrat-ul-Muntaha (i.e. the Lote Tree of the utmost boundary) Behold! Its fruits were like the jars of Hajr (i.e. a place near Medina) and its leaves were as big as the ears of elephants. Gabriel said, 'This is the Lote Tree of the utmost boundary) . Behold ! There ran four rivers, two were hidden and two were visible, I asked, 'What are these two kinds of rivers, O Gabriel?' He replied,' As for the hidden rivers, they are two rivers in Paradise and the visible rivers are the Nile and the Euphrates.'

Then Al-Bait-ul-Ma'mur (i.e. the Sacred House) was shown to me and a container full of wine and another full of milk and a third full of honey were brought to me. I took the milk. Gabriel remarked, 'This is the Islamic religion which you and your followers are following.' Then the prayers were enjoined on me: They were fifty prayers a day. When I returned, I passed by Moses who asked (me), 'What have you been ordered to do?' I replied, 'I have been ordered to offer fifty prayers a day.' Moses said, 'Your followers cannot bear fifty prayers a day, and by Allah, I have tested people before you, and I have tried my level best with Bani Israel (in vain). Go back to your Lord and ask for reduction to lessen your followers' burden.' So I went back, and Allah reduced ten prayers for me. Then again I came to Moses, but he repeated the same as he had said before. Then again I went back to Allah and He reduced ten more prayers. When I came back to Moses he said the same, I went back to Allah and He ordered me to observe ten prayers a day. When I came back to Moses, he repeated the same advice, so I went back to Allah and was ordered to observe five prayers a day.

When I came back to Moses, he said, 'What have you been ordered?' I replied, 'I have been ordered to observe five prayers a day.' He said, 'Your followers cannot bear five prayers a day, and no doubt, I have got an experience of the people before you, and I have tried my level best with Bani Israel, so go back to your Lord and ask for reduction to lessen your follower's burden.' I said, 'I have requested so much of my Lord that I feel ashamed, but I am satisfied now and surrender to Allah's Order.' When I left, I heard a voice saying, 'I have passed My Order and have lessened the burden of My Worshipers."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.228]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 228

Narrated Ibn 'Abbas:

Regarding the Statement of Allah"

"And We granted the vision (Ascension to the heavens) which We made you see (as an actual eye witness) was only made as a trial for the people." (17.60)

Ibn Abbas added: The sights which Allah's Apostle was shown on the Night Journey when he was taken to Bait-ulMaqdis (i.e. Jerusalem) were actual sights, (not dreams). And the Cursed Tree (mentioned) in the Quran is the tree of Zaqqum (itself) .


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.229]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 229

Narrated 'Abdullah bin Ka'b:

Who was Kab's guide when Ka'b turned blind: I heard Ka'b bin Malik narrating: When he remained behind (i.e. did not Join) the Prophet in the Ghazwa of Tabuk. Ibn Bukair, in his narration stated that Ka'b said, " I witnessed the Al-'Aqaba pledge of allegiance at night with the Prophet when we jointly agreed to support Islam with all our efforts I would not like to have attended the Badr battle instead of that 'Aqaba pledge although Badr is more well-known than it, amongst the people."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.230]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 230

Narrated Jabir bin 'Abdullah:

I was present with my two maternal uncles at Al-'Aqaba (where the pledge of allegiance was given). (Ibn 'Uyaina said, "One of the two was Al-Bara' bin Marur.")


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.231]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 231

Narrated Jabir:

My father, my two maternal uncles and I were among those who took part in the 'Aqaba Pledge.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.232]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 232

Narrated 'Ubada bin As-Samit:

Who had taken part in the battle of Badr with Allah's Apostle and had been amongst his companions on the night of Al-'Aqaba Pledge: Allah's Apostle, surrounded by a group of his companions said, "Come along and give me the pledge of allegiance that you will not worship anything besides Allah, will not steal, will not commit illegal sexual intercourse will not kill your children, will not utter; slander, invented by yourself, and will not disobey me if I order you to do something good. Whoever among you will respect and fulfill this pledge, will be rewarded by Allah. And if one of you commits any of these sins and is punished in this world then that will be his expiation for it, and if one of you commits any of these sins and Allah screens his sin, then his matter, will rest with Allah: If He will, He will punish him and if He will,. He will excuse him." So I gave the pledge of allegiance to him for these conditions.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.233]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 233

Narrated 'Ubada bin As Samit:

I was one of the Naqibs who gave the ('Aqaba) Pledge of Allegiance to Allah's Apostle . We gave the pledge of allegiance to him that we would not worship anything other than Allah, would not steal, would not commit illegal sexual intercourse, would not kill a person whose killing Allah has made illegal except rightfully, would not rob each other, and we would not be promised Paradise jf we did the above sins, then if we committed one of the above sins, Allah will give His Judgment concerning it.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.234]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 234

Narrated Aisha:

The Prophet engaged me when I was a girl of six (years). We went to Medina and stayed at the home of Bani-al-Harith bin Khazraj. Then I got ill and my hair fell down. Later on my hair grew (again) and my mother, Um Ruman, came to me while I was playing in a swing with some of my girl friends. She called me, and I went to her, not knowing what she wanted to do to me. She caught me by the hand and made me stand at the door of the house. I was breathless then, and when my breathing became Allright, she took some water and rubbed my face and head with it. Then she took me into the house. There in the house I saw some Ansari women who said, "Best wishes and Allah's Blessing and a good luck." Then she entrusted me to them and they prepared me (for the marriage). Unexpectedly Allah's Apostle came to me in the forenoon and my mother handed me over to him, and at that time I was a girl of nine years of age.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.235]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 235

Narrated 'Aisha:

That the Prophet said to her, "You have been shown to me twice in my dream. I saw you pictured on a piece of silk and some-one said (to me). 'This is your wife.' When I uncovered the picture, I saw that it was yours. I said, 'If this is from Allah, it will be done."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.236]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 236

Narrated Hisham's father:

Khadija died three years before the Prophet departed to Medina. He stayed there for two years or so and then he married 'Aisha when she was a girl of six years of age, and he consumed that marriage when she was nine years old.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.237]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 237

Narrated Abu Wail:

We visited Khabbaba who said, "We migrated with the Prophet for Allah's Sake, so our reward became due and sure with Allah. Some of us passed away without taking anything of their rewards (in this world) and one of them was Mus'ab bin 'Umar who was martyred on the day (of the battle) of Uhud leaving a striped woolen cloak. When we covered his head with it, his feet became naked, and when covered his feet, his head became naked.

So Allah's Apostle ordered us to cover his head and put some Idhkhir (i.e. a special kind of grass) on his feet. (On the other hand) some of us have had their fruits ripened (in this world) and they are collecting them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.238]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 238

Narrated 'Umar:

I heard the Prophet saying, "The reward of deeds depends on the intentions, so whoever emigrated for the worldly benefits or to marry a woman, his emigration was for that for which he emigrated, but whoever emigrated for the Sake of Allah and His Apostle, his emigration is for Allah and His Apostle."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.239]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 239

Narrated Mujahid bin Jabir Al-Makki:

Abdullah bin 'Umar used to say, "There is no more Hijrah (i.e. migration) after the Conquest of Mecca."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.240]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 240

Narrated 'Ata bin Abi Rabah:

'Ubaid bin 'Umar Al-Laithi and I visited Aisha and asked her about the Hijra (i.e. migration), and she said, "Today there is no (Hijrah) emigration. A believer used to run away with his religion to Allah and His Apostle lest he should be put to trial because of his religion. Today Allah has made Islam triumphant, and today a believer can worship his Lord wherever he likes. But the deeds that are still rewardable (in place of emigration) are Jihad and good intentions." (See Hadith No. 42 Vol. 4).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.241]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 241

Narrated Aisha:

Sad said, "O Allah! You know that there is none against whom I am eager to fight more willingly for Your Cause than those people who disbelieved Your Apostle and drove him out (of his city). O Allah! I think that You have ended the fight between us and them."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.242]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 242

Narrated Ibn Abbas:

Allah's Apostle started receiving the Divine Inspiration at the age of forty. Then he stayed in Mecca for thirteen years, receiving the Divine Revelation. Then he was ordered to migrate and he lived as an Emigrant for ten years and then died at the age of sixty-three (years).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.243]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 243

Narrated Ibn Abbas:

Allah's Apostle stayed in Mecca for thirteen years (after receiving the first Divine Inspiration) and died at the age of sixty-three.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.244]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 244

Narrated Abu Said Al-Khudri:

Allah's Apostle sat on the pulpit and said, "Allah has given one of His Slaves the choice of receiving the splendor and luxury of the worldly life whatever he likes or to accept the good (of the Hereafter) which is with Allah. So he has chosen that good which is with Allah." On that Abu Bakr wept and said, "Our fathers and mothers be sacrificed for you." We became astonished at this. The people said, "Look at this old man! Allah's Apostle talks about a Slave of Allah to whom He has given the option to choose either the splendor of this worldly life or the good which is with Him, while he says. 'our fathers and mothers be sacrifice(i for you." But it was Allah's Apostle who had been given option, and Abu Bakr knew it better than we. Allah's Apostle added, "No doubt, I am indebted to Abu Bakr more than to anybody else regarding both his companionship and his wealth. And if I had to take a Khalil from my followers, I would certainly have taken Abu Bakr, but the fraternity of Islam is. sufficient. Let no door (i.e. Khoukha) of the Mosque remain open, except the door of Abu Bakr."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.245]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 245

Narrated 'Aisha:

(the wife of the Prophet) I never remembered my parents believing in any religion other than the true religion (i.e. Islam), and (I don't remember) a single day passing without our being visited by Allah's Apostle in the morning and in the evening. When the Muslims were put to test (i.e. troubled by the pagans), Abu Bakr set out migrating to the land of Ethiopia, and when he reached Bark-al-Ghimad, Ibn Ad-Daghina, the chief of the tribe of Qara, met him and said, "O Abu Bakr! Where are you going?" Abu Bakr replied, "My people have turned me out (of my country), so I want to wander on the earth and worship my Lord." Ibn Ad-Daghina said, "O Abu Bakr! A man like you should not leave his home-land, nor should he be driven out, because you help the destitute, earn their livings, and you keep good relations with your Kith and kin, help the weak and poor, entertain guests generously, and help the calamity-stricken persons. Therefore I am your protector. Go back and worship your Lord in your town."

So Abu Bakr returned and Ibn Ad-Daghina accompanied him. In the evening Ibn Ad-Daghina visited the nobles of Quraish and said to them. "A man like Abu Bakr should not leave his homeland, nor should he be driven out. Do you (i.e. Quraish) drive out a man who helps the destitute, earns their living, keeps good relations with his Kith and kin, helps the weak and poor, entertains guests generously and helps the calamity-stricken persons?" So the people of Quraish could not refuse Ibn Ad-Daghina's protection, and they said to Ibn Ad-Daghina, "Let Abu Bakr worship his Lord in his house. He can pray and recite there whatever he likes, but he should not hurt us with it, and should not do it publicly, because we are afraid that he may affect our women and children." Ibn Ad-Daghina told Abu Bakr of all that. Abu Bakr stayed in that state, worshipping his Lord in his house. He did not pray publicly, nor did he recite Quran outside his house.

Then a thought occurred to Abu Bakr to build a mosque in front of his house, and there he used to pray and recite the Quran. The women and children of the pagans began to gather around him in great number. They used to wonder at him and look at him. Abu Bakr was a man who used to weep too much, and he could not help weeping on reciting the Quran. That situation scared the nobles of the pagans of Quraish, so they sent for Ibn Ad-Daghina. When he came to them, they said, "We accepted your protection of Abu Bakr on condition that he should worship his Lord in his house, but he has violated the conditions and he has built a mosque in front of his house where he prays and recites the Quran publicly. We are now afraid that he may affect our women and children unfavorably. So, prevent him from that. If he likes to confine the worship of his Lord to his house, he may do so, but if he insists on doing that openly, ask him to release you from your obligation to protect him, for we dislike to break our pact with you, but we deny Abu Bakr the right to announce his act publicly." Ibn Ad-Daghina went to Abu- Bakr and said, ("O Abu Bakr!) You know well what contract I have made on your behalf; now, you are either to abide by it, or else release me from my obligation of protecting you, because I do not want the 'Arabs hear that my people have dishonored a contract I have made on behalf of another man." Abu Bakr replied, "I release you from your pact to protect me, and am pleased with the protection from Allah."

At that time the Prophet was in Mecca, and he said to the Muslims, "In a dream I have been shown your migration place, a land of date palm trees, between two mountains, the two stony tracts." So, some people migrated to Medina, and most of those people who had previously migrated to the land of Ethiopia, returned to Medina. Abu Bakr also prepared to leave for Medina, but Allah's Apostle said to him, "Wait for a while, because I hope that I will be allowed to migrate also." Abu Bakr said, "Do you indeed expect this? Let my father be sacrificed for you!" The Prophet said, "Yes." So Abu Bakr did not migrate for the sake of Allah's Apostle in order to accompany him. He fed two she-camels he possessed with the leaves of As-Samur tree that fell on being struck by a stick for four months.

One day, while we were sitting in Abu Bakr's house at noon, someone said to Abu Bakr, "This is Allah's Apostle with his head covered coming at a time at which he never used to visit us before." Abu Bakr said, "May my parents be sacrificed for him. By Allah, he has not come at this hour except for a great necessity." So Allah's Apostle came and asked permission to enter, and he was allowed to enter. When he entered, he said to Abu Bakr. "Tell everyone who is present with you to go away." Abu Bakr replied, "There are none but your family. May my father be sacrificed for you, O Allah's Apostle!" The Prophet said, "i have been given permission to migrate." Abu Bakr said, "Shall I accompany you? May my father be sacrificed for you, O Allah's Apostle!" Allah's Apostle said, "Yes." Abu Bakr said, "O Allah's Apostle! May my father be sacrificed for you, take one of these two she-camels of mine." Allah's Apostle replied, "(I will accept it) with payment." So we prepared the baggage quickly and put some journey food in a leather bag for them. Asma, Abu Bakr's daughter, cut a piece from her waist belt and tied the mouth of the leather bag with it, and for that reason she was named Dhat-un-Nitaqain (i.e. the owner of two belts).

Then Allah's Apostle and Abu Bakr reached a cave on the mountain of Thaur and stayed there for three nights. 'Abdullah bin Abi Bakr who was intelligent and a sagacious youth, used to stay (with them) aver night. He used to leave them before day break so that in the morning he would be with Quraish as if he had spent the night in Mecca. He would keep in mind any plot made against them, and when it became dark he would (go and) inform them of it. 'Amir bin Fuhaira, the freed slave of Abu Bakr, used to bring the milch sheep (of his master, Abu Bakr) to them a little while after nightfall in order to rest the sheep there. So they always had fresh milk at night, the milk of their sheep, and the milk which they warmed by throwing heated stones in it. 'Amir bin Fuhaira would then call the herd away when it was still dark (before daybreak). He did the same in each of those three nights. Allah's Apostle and Abu Bakr had hired a man from the tribe of Bani Ad-Dail from the family of Bani Abd bin Adi as an expert guide, and he was in alliance with the family of Al-'As bin Wail As-Sahmi and he was on the religion of the infidels of Quraish. The Prophet and Abu Bakr trusted him and gave him their two she-camels and took his promise to bring their two she camels to the cave of the mountain of Thaur in the morning after three nights later. And (when they set out), 'Amir bin Fuhaira and the guide went along with them and the guide led them along the sea-shore.

The nephew of Suraqa bin Ju'sham said that his father informed him that he heard Suraqa bin Ju'sham saying, "The messengers of the heathens of Quraish came to us declaring that they had assigned for the persons why would kill or arrest Allah's Apostle and Abu Bakr, a reward equal to their bloodmoney. While I was sitting in one of the gatherings of my tribe. Bani Mudlij, a man from them came to us and stood up while we were sitting, and said, "O Suraqa! No doubt, I have just seen some people far away on the seashore, and I think they are Muhammad and his companions." Suraqa added, "I too realized that it must have been they. But I said 'No, it is not they, but you have seen so-and-so, and so-and-so whom we saw set out.' I stayed in the gathering for a while and then got up and left for my home. and ordered my slave-girl to get my horse which was behind a hillock, and keep it ready for me.

Then I took my spear and left by the back door of my house dragging the lower end of the spear on the ground and keeping it low. Then I reached my horse, mounted it and made it gallop. When I approached them (i.e. Muhammad and Abu Bakr), my horse stumbled and I fell down from it, Then I stood up, got hold of my quiver and took out the divining arrows and drew lots as to whether I should harm them (i.e. the Prophet and Abu Bakr) or not, and the lot which I disliked came out. But I remounted my horse and let it gallop, giving no importance to the divining arrows. When I heard the recitation of the Quran by Allah's Apostle who did not look hither and thither while Abu Bakr was doing it often, suddenly the forelegs of my horse sank into the ground up to the knees, and I fell down from it. Then I rebuked it and it got up but could hardly take out its forelegs from the ground, and when it stood up straight again, its fore-legs caused dust to rise up in the sky like smoke. Then again I drew lots with the divining arrows, and the lot which I disliked, came out. So I called upon them to feel secure. They stopped, and I remounted my horse and went to them. When I saw how I had been hampered from harming them, it came to my mind that the cause of Allah's Apostle (i.e. Islam) will become victorious. So I said to him, "Your people have assigned a reward equal to the bloodmoney for your head." Then I told them all the plans the people of Mecca had made concerning them. Then I offered them some journey food and goods but they refused to take anything and did not ask for anything, but the Prophet said, "Do not tell others about us." Then I requested him to write for me a statement of security and peace. He ordered 'Amr bin Fuhaira who wrote it for me on a parchment, and then Allah's Apostle proceeded on his way.

Narrated 'Urwa bin Az-Zubair: Allah's Apostle met Az-Zubair in a caravan of Muslim merchants who were returning from Sham. Az-Zubair provided Allah's Apostle and Abu Bakr with white clothes to wear. When the Muslims of Medina heard the news of the departure of Allah's Apostle from Mecca (towards Medina), they started going to the Harra every morning . They would wait for him till the heat of the noon forced them to return. One day, after waiting for a long while, they returned home, and when they went into their houses, a Jew climbed up the roof of one of the forts of his people to look for some thing, and he saw Allah's Apostle and his companions dressed in white clothes, emerging out of the desert mirage.

The Jew could not help shouting at the top of his voice, "O you 'Arabs! Here is your great man whom you have been waiting for!" So all the Muslims rushed to their arms and received Allah's Apostle on the summit of Harra. The Prophet turned with them to the right and alighted at the quarters of Bani 'Amr bin 'Auf, and this was on Monday in the month of Rabi-ul-Awal. Abu Bakr stood up, receiving the people while Allah's Apostle sat down and kept silent. Some of the Ansar who came and had not seen Allah's Apostle before, began greeting Abu Bakr, but when the sunshine fell on Allah's Apostle and Abu Bakr came forward and shaded him with his sheet only then the people came to know Allah's Apostle. Allah's Apostle stayed with Bani 'Amr bin 'Auf for ten nights and established the mosque (mosque of Quba) which was founded on piety. Allah's Apostle prayed in it and then mounted his she-camel and proceeded on, accompanied by the people till his she-camel knelt down at (the place of) the Mosque of Allah's Apostle at Medina. Some Muslims used to pray there in those days, and that place was a yard for drying dates belonging to Suhail and Sahl, the orphan boys who were under the guardianship of 'Asad bin Zurara. When his she-camel knelt down, Allah's Apostle said, "This place, Allah willing, will be our abiding place." Allah's Apostle then called the two boys and told them to suggest a price for that yard so that he might take it as a mosque. The two boys said, "No, but we will give it as a gift, O Allah's Apostle!" Allah's Apostle then built a mosque there. The Prophet himself started carrying unburnt bricks for its building and while doing so, he was saying "This load is better than the load of Khaibar, for it is more pious in the Sight of Allah and purer and better rewardable." He was also saying, "O Allah! The actual reward is the reward in the Hereafter, so bestow Your Mercy on the Ansar and the Emigrants." Thus the Prophet recited (by way of proverb) the poem of some Muslim poet whose name is unknown to me.

(Ibn Shibab said, "In the Hadiths it does not occur that Allah's Apostle

recited a complete poetic verse other than this one.")


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.246]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 246

Narrated Asma:

I prepared the journey food for the Prophet and Abu Bakr when they wanted (to migrate to) Medina. I said to my father (Abu Bakr), "I do not have anything to tie the container of the journey food with except my waist belt." He said, "Divide it lengthwise into two." I did so, and for this reason I was named 'Dhat-un-Nitaqain' (i.e. the owner of two belts). (Ibn 'Abbas said, "Asma', Dhat-un-Nitaq.")


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.247]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 247

Narrated Al-Bara:

When the Prophet migrated to Medina, Suraqa bin Malik bin Ju'sham pursued him. The Prophet invoked evil on him, therefore the forelegs of his horse sank into the ground. Suraqa said (to the Prophet ), "Invoke Allah to rescue me, and I will not harm you. "The Prophet invoked Allah for him. Then Allah's Apostle felt thirsty and he passed by a shepherd. Abu Bakr said, "I took a bowl and milked a little milk in it and brought it to the Prophet and he drank till I was pleased."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.248]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 248

Narrated Asma:

That she conceived 'Abdullah bin Az-Zubair. She added, "I migrated to Medina while I was at full term of pregnancy and alighted at Quba where I gave birth to him. Then I brought him to the Prophet and put him in his lap. The Prophet asked for a date, chewed it, and put some of its juice in the child's mouth. So, the first thing that entered the child's stomach was the saliva of Allah's Apostle. Then the Prophet rubbed the child's palate with a date and invoked for Allah's Blessings on him, and he was the first child born amongst the Emigrants in the Islamic Land (i.e. Medina).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.249]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 249

Narrated Aisha:

The first child who was born in the Islamic Land (i.e. Medina) amongst the Emigrants, was 'Abdullah bin Az-Zubair. They brought him to the Prophet. The Prophet took a date, and after chewing it, put its juice in his mouth. So the first thing that went into the child's stomach, was the saliva of the Prophet


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.250]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 250

Narrated Anas bin Malik:

Allah's Apostle arrived at Medina with Abu Bakr, riding behind him on the same camel. Abu Bakr was an elderly man known to the people, while Allah's Apostle was a youth that was unknown. Thus, if a man met Abu Bakr, he would day, "O Abu Bakr! Who is this man in front of you?" Abu Bakr would say, "This man shows me the Way," One would think that Abu Bakr meant the road, while in fact, Abu Bakr meant the way of virtue and good. Then Abu Bakr looked behind and saw a horse-rider persuing them. He said, "O Allah's Apostle! This is a horse-rider persuing us." The Prophet looked behind and said, "O Allah! Cause him to fall down." So the horse threw him down and got up neighing. After that the rider, Suraqa said, "O Allah's Prophet! Order me whatever you want." The Prophet said, "Stay where you are and do not allow anybody to reach us." So, in the first part of the day Suraqa was an enemy of Allah's Prophet and in the last part of it, he was a protector. Then Allah's Apostle alighted by the side of the Al-Harra and sent a message to the Ansar, and they came to Allah's Prophet and Abu Bakr, and having greeted them, they said, "Ride (your she-camels) safe and obeyed." Allah's Apostle and Abu Bakr rode and the Ansar, carrying their arms, surrounded them. The news that Allah's Prophet had come circulated in Medina. The people came out and were eagerly looking and saying "Allah's Prophet has come! Allah's Prophet has come! So the Prophet went on till he alighted near the house of Abu Aiyub. While the Prophet was speaking with the family members of Abu Aiyub, 'Abdullah bin Salam heard the news of his arrival while he himself was picking the dates for his family from his family garden. He hurried to the Prophet carrying the dates which he had collected for his family from the garden. He listened to Allah's Prophet and then went home.

Then Allah's Prophet said, "Which is the nearest of the houses of our Kith and kin?" Abu Aiyub replied, "Mine, O Allah's Prophet! This is my house and this is my gate." The Prophet said, "Go and prepare a place for our midday rest." Abu Aiyub said, "Get up (both of you) with Allah's Blessings." So when Allah's Prophet went into the house, 'Abdullah bin Salaim came and said "I testify that you (i.e. Muhammad) are Apostle of Allah and that you have come with the Truth. The Jews know well that I am their chief and the son of their chief and the most learned amongst them and the son of the most learned amongst them. So send for them (i.e. Jews) and ask them about me before they know that I have embraced Islam, for if they know that they will say about me things which are not correct." So Allah's Apostle sent for them, and they came and entered. Allah's Apostle said to them, "O (the group of) Jews! Woe to you: be afraid of Allah. By Allah except Whom none has the right to be worshipped, you people know for certain, that I am Apostle of Allah and that I have come to you with the Truth, so embrace Islam." The Jews replied, "We do not know this." So they said this to the Prophet and he repeated it thrice. Then he said, "What sort of a man is 'Abdullah bin Salam amongst you?" They said, "He is our chief and the son of our chief and the most learned man, and the son of the most learned amongst us." He said, "What would you think if he should embrace Islam?" They said, "Allah forbid! He can not embrace Islam." He said, " What would you think if he should embrace Islam?" They said, "Allah forbid! He can not embrace Islam." He said, "What would you think if he should embrace Islam?" They said, "Allah forbid! He can not embrace Islam." He said, "O Ibn Salaim! Come out to them." He came out and said, "O (the group of) Jews! 8e afraid of Allah except Whom none has the right to be worshipped. You know for certain that he is Apostle of Allah and that he has brought a True Religion!' They said, "You tell a lie." On that Allah's Apostle turned them out.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.251]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 251

Narrated Ibn Umar:

Umar bin Al-Khattab fixed a grant of 4000 (Dirhams) for every Early Emigrant (i.e. Muhajir) and fixed a grant of 3500 (Dirhams) only for Ibn 'Umar. Somebody said to 'Umar, "Ibn 'Umar is also one of the Early Emigrants; why do you give him less than four-thousand?" 'Umar replied, "His parents took him with them when they migrated, so he was not like the one who had migrated by himself.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.252]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 252

Narrated Khabbab:

We migrated with Allah's Apostle (See Hadith No. 253 below).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.253]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 253

Narrated Khabbab:

We migrated with Allah's Apostle seeking Allah's Countenance, so our rewards became due and sure with Allah. Some of us passed away without eating anything of their rewards in this world. One of these was Mus'ab bin 'Umar who was martyred on the day of the battle of Uhud. We did not find anything to shroud his body with except a striped cloak. When we covered his head with it, his feet remained uncovered, and when we covered his feet with it, his head remained uncovered. So Allah's Apostle ordered us to cover his head with it and put some Idhkhir (i.e. a kind of grass) over his feet. And there are some amongst us whose fruits have ripened and they are collecting them (i.e. they have received their rewards in this world).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.254]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 254

Narrated Abu Burda Bin Abi Musa Al-Ashari:

'Abdullah bin 'Umar said to me, "Do you know what my father said to your father once?" I said, "No." He said, "My father said to your father, 'O Abu Musa, will it please you that we will be rewarded for our conversion to Islam with Allah's Apostle and our migration with him, and our Jihad with him and all our good deeds which we did, with him, and that all the deeds we did after his death will be disregarded whether good or bad?' Your father (i.e. Abu Musa) said, 'No, by Allah, we took part in Jihad after Allah's Apostle , prayed and did plenty of good deeds, and many people have embraced Islam at our hands, and no doubt, we expect rewards from Allah for these good deeds.' On that my father (i.e. 'Umar) said, 'As for myself, By Him in Whose Hand 'Umar's soul is, I wish that the deeds done by us at the time of the Prophet remain rewardable while whatsoever we did after the death of the Prophet be enough to save us from Punishment in that the good deeds compensate for the bad ones.' " On that I said (to Ibn 'Umar), "By Allah, your father was better than my father!"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.255]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 255

Narrated Abu 'Uthman:

I heard that Ibn 'Umar used to become angry if someone mentioned that he had migrated before his father ('Umar), and he used to say, " 'Umar and I came to Allah's Apostle and found him having his midday rest, so we returned home. Then 'Umar sent me again (to the Prophet ) and said, 'Go and see whether he is awake.' I went to him and entered his place and gave him the pledge of allegiance. Then I went back to 'Umar and informed him that the Prophet was awake. So we both went, running slowly, and when 'Umar entered his place, he gave him the pledge of allegiance and thereafter I too gave him the pledge of allegiance,"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.256]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 256

Narrated Al-Bara:

Abu Bakr bought a (camel's) saddle from 'Azib, and I carried it for him. 'Azib (i.e. my father) asked Abu Bakr regarding the journey of the migration of Allah's Apostle. Abu Bakr said, "Close observers were appointed by our enemies to watch us. So we went out at night and travelled throughout the night and the following day till it was noon, then we perceived a rock and went towards it, and there was some shade under it. I spread a cloak I had with me for Allah's Apostle and then the Prophet layed on it. I went out to guard him and all of a sudden I saw a shepherd coming with his sheep looking for the same, the shade of the rock as we did, I asked him, 'O boy, to whom do you belong?' He replied, 'I belong to so-and-so.' I asked him, 'Is there some milk in your sheep?' He replied in the affirmative. I asked him, 'Will you milk?' He replied in the affirmative. Then he got hold of one of his sheep. I said to him, 'Remove the dust from its udder.' Then he milked a little milk. I had a water-skin with me which was tied with a piece of cloth. I had prepared the water-skin for Allah's Apostle . So I poured some water over the milk (container) till its bottom became cold. Then I brought the milk to the Prophet and said, 'Drink, O Allah's Apostle.' Allah's Apostle drank till I became pleased. Then we departed and the pursuers were following us." Al-Bara added: I then went with Abu Bakr into his home (carrying that saddle) and there I saw his daughter 'Aisha Lying in a bed because of heavy fever and I saw her father Abu Bakr kissing her cheek and saying, "How are you, little daughter?"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.257]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 257

Narrated Anas:

(the servant of the Prophet) When the Prophet arrived (at Medina), there was not a single companion of the Prophet who had grey and black hair except Abu Bakr, and he dyed his hair with Henna' and Katam (i.e. plants used for dying hair). Through another group of narrators, Anas bin Malik said,. "When the Prophet arrived at Medina, the eldest amongst his companions was Abu Bakr. He dyed his hair with Hinna and Katam till it became of dark red color.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.258]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 258

Narrate Aisha:

Abu Bakr married a woman from the tribe of Bani Kalb, called Um Bakr. When Abu Bakr migrated to Medina, he divorced her and she was married by her cousin, the poet who said the following poem lamenting the infidels of Quraish:

"What is there kept in the well, The well of Badr, (The owners of) the trays of Roasted camel humps? What is there kept in the well, The well of Badr, (The owners of) lady singers And friends of the honorable companions; who used to drink (wine) together, Um Bakr greets us With the greeting of peace, But can I find peace After my people have gone? The Apostle tells us that We shall live again, But what sort of life will owls and skulls live?:


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.259]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 259

Narrated Abu Bakr:

I was with the Prophet in the Cave. When I raised my head, I saw the feet of the people. I said, "O Allah's Apostle! If some of them should look down, they will see us." The Prophet said, "O Abu Bakr, be quiet! (For we are) two and Allah is the Third of us."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.260]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 260

Narrated Abu Said:

Once a bedouin came to the Prophet and asked him about the migration. The Prophet said, "Mercy of Allah be on you! The migration is a quite difficult matter. Have you got some camels?" He replied in the affirmative. Then the Prophet said, "Do you give their Zakat?" He replied in the affirmative. The Prophet said, "Do you let others benefit by their milk gratis?" He replied in the affirmative. Then the Prophet asked, "Do you milk them on their watering days and give their milk to the poor and needy?" He replied in the affirmative. The Prophet, said, "Go on doing like this from beyond the seas, and there is no doubt that Allah will not overlook any of your good deeds."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.261]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 261

Narrated Al-Bara:

The first people who came to us (in Medina) were Mus'ab bin 'Umar and Ibn Um Maktum. Then came to us 'Ammar bin Yasir and Bilal.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.262]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 262

Narrated Al-Bara bin Azib:

The first people who came to us (in Medina) were Mus'ab bin 'Umar and Ibn Um Maktum who were teaching Qur'an to the people. Then their came Bilal. Sad and 'Ammar bin Yasir. After that 'Umar bin Al-Khattab came along with twenty other companions of the Prophet. Later on the Prophet himself (to Medina) and I had never seen the people of Medina so joyful as they were on the arrival of Allah's Apostle, for even the slave girls were saying, "Allah's Apostle has arrived!" And before his arrival I had read the Sura starting with:-- "Glorify the Name of your Lord, the Most High" (87.1) together with other Suras of Al-Mufassal.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.263]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 263

Narrated 'Aisha:

When Allah's Apostle came to Medina, Abu Bakr and Bilal got fever, and I went to both of them and said, "O my father, how do you feel? O Bilal, how do you feel?" Whenever Abu Bakr's fever got worse, he would say, "Every man will meet his death once in one morning while he will be among his family, for death is really nearer to him than his leather shoe laces (to his feet)." And whenever fever deserted Bilal, he would say aloud, "Would that I know whether I shall spend a night in the valley (of Mecca) with Idhkhir and Jalil (i.e. kinds of grass) around me, and whether I shall drink one day the water of Mijannah, and whether I shall see once again the hills of Shamah and Tafil?" Then I went to Allah's Apostle and told him of that. He said, "O Allah, make us love Medina as much as or more than we used to love Mecca, O Allah, make it healthy and bless its Sa' and Mud (i.e. measures), and take away its fever to Al-Juhfa."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.264]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 264

Narrated 'Ubaidullah bin Ad bin Khiyair:

I went to Uthman. After reciting Tashah-hud, he said,. "Then after no doubt, Allah sent Muhammad with the Truth, and I was amongst those who responded to the Call of Allah and His Prophet and believed in the message of Muhammad. Then took part in the two migrations. I became the son-in-law of Allah's Apostle and gave the pledge of allegiance to him By Allah, I never disobeyed him, nor did I deceive him till Allah took him unto Him."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.265]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 265

Narrated Ibn Abbas:

During the last Hajj led by 'Umar, 'Abdur-Rahman bin 'Auf returned to his family at Mina and met me there. 'AbdurRahman said (to 'Umar), "O chief of the believers! The season of Hajj is the season when there comes the scum of the people (besides the good amongst them), so I recommend that you should wait till you go back to Medina, for it is the place of Migration and Sunna (i.e. the Prophet's tradition), and there you will be able to refer the matter to the religious scholars and the nobles and the people of wise opinions." 'Umar said, "I will speak of it in Medina on my very first sermon I will deliver there."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.266]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 266

Narrated 'Um al-'Ala:

An Ansari woman who gave the pledge of allegiance to the Prophet that the Ansar drew lots concerning the dwelling of the Emigrants. 'Uthman bin Maz'un was decided to dwell with them (i.e. Um al-'Ala's family), 'Uthman fell ill and I nursed him till he died, and we covered him with his clothes. Then the Prophet came to us and I (addressing the dead body) said, "O Abu As-Sa'ib, may Allah's Mercy be on you! I bear witness that Allah has honored you." On that the Prophet said, "How do you know that Allah has honored him?" I replied, "I do not know. May my father and my mother be sacrificed for you, O Allah's Apostle! But who else is worthy of it (if not 'Uthman)?" He said, "As to him, by Allah, death has overtaken him, and I hope the best for him. By Allah, though I am the Apostle of Allah, yet I do not know what Allah will do to me," By Allah, I will never assert the piety of anyone after him. That made me sad, and when I slept I saw in a dream a flowing stream for 'Uthman bin Maz'un. I went to Allah's Apostle and told him of it. He remarked, "That symbolizes his (good) deeds."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.267]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 267

Narrated 'Aisha:

The day of Bu'ath was a day (i.e. battle) which Allah caused to take place just before the mission of His Apostle so that when Allah's Apostle came to Medina, they (the tribes) had divided (into hostile groups) and their nobles had been killed; and all that facilitated their conversion to Islam.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.268]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 268

Narrated Aisha:

That once Abu Bakr came to her on the day of 'Id-ul-Fitr or 'Id ul Adha while the Prophet was with her and there were two girl singers with her, singing songs of the Ansar about the day of Buath. Abu Bakr said twice. "Musical instrument of Satan!" But the Prophet said, "Leave them Abu Bakr, for every nation has an 'Id (i.e. festival) and this day is our 'Id."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.269]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 269

Narrated Anas bin Malik:

When Allah's Apostle arrived at Medina, he alighted at the upper part of Medina among the people called Bani 'Amr bin 'Auf and he stayed with them for fourteen nights. Then he sent for the chiefs of Bani An-Najjar, and they came, carrying their swords. As if I am just now looking at Allah's Apostle on his she-camel with Abu Bakr riding behind him (on the same camel) and the chiefs of Bani An-Najjar around him till he dismounted in the courtyard of Abu Aiyub's home. The Prophet used to offer the prayer wherever the prayer was due, and he would pray even in sheepfolds. Then he ordered that the mosque be built. He sent for the chiefs of Banu An-Najjar, and when they came, he said, "O Banu An-Najjar! Suggest to me the price of this garden of yours." They replied "No! By Allah, we do not demand its price except from Allah." In that garden there were the (following) things that I will tell you: Graves of pagans, unleveled land with holes and pits etc., and date-palm trees. Allah's Apostle ordered that the graves of the pagans be dug up and, the unleveled land be leveled and the date-palm trees be cut down. The trunks of the trees were arranged so as to form the wall facing the Qibla. The Stone pillars were built at the sides of its gate. The companions of the Prophet were carrying the stones and reciting some lyrics, and Allah's Apostle . . was with them and they were saying, "O Allah! There is no good Excel the good of the Hereafter, so bestow victory on the Ansar and the Emigrants. "


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.270]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 270

Narrated 'Abdur-Rahman bin Humaid Az-Zuhri:

I heard 'Umar bin 'Abdul-Aziz asking As-Sa'ib, the nephew of An-Nimr. "What have you heard about residing in Mecca?" The other said, "I heard Al-Ala bin Al-Hadrami saying, Allah's Apostle said: An Emigrant is allowed to stay in Mecca for three days after departing from Mina (i.e. after performing all the ceremonies of Hajj)"


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.271]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 271

Narrated Sahl bin Sad:

The Prophet's companions did not take as a starting date for the Muslim calendar, the day, the Prophet had been sent as an Apostle or the day of his death, but the day of his arrival at Medina.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.272]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 272

Narrated 'Aisha:

Originally, two Rakat were prescribed in every prayer. When the Prophet migrated (to Medina) four Rakat were enjoined, while the journey prayer remained unchanged(i.e. two Rakat).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.273]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 273

Narrated Sad bin Malik:

In the year of Hajjat-ul-Wada' the Prophet visited me when I fell ill and was about to die because of that illness. I said, "O Allah's Apostle! I am very ill as you see, and I am a rich man and have no heir except my only daughter. Shall I give 2/3 of my property in charity?" He said, "No." I said, "Shall I then give one half of it in charity?" He said, "O Sad! Give 1/3 (in charity) and even 1/3 is too much. No doubt, it is better to leave your children rich than to leave them poor, reduced to begging from others. And Allah will reward you for whatever you spend with the intention of gaining Allah's Pleasure even if it were a mouthful of food you put into your wives mouth." I said, "O Allah's Apostle! Am I to be left behind (in Mecca) after my companions have gone?" He said, "If you should be left behind, you will be upgraded and elevated for every deed you will do with a desire to achieve Allah's Pleasure. I hope that you will live long so that some people will benefit by you while others will be harmed. O Allah! Please fulfill the migration of my companions and do not make them turn back on their heels. But (we feel sorry for) the unlucky Sad bin Khaulah." Allah's Apostle lamented his death in Mecca.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.274]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 274

Narrated Anas:

When 'Abdur-Rahman bin Auf came to Medina and the Prophet established the bond of brotherhood between him and Sad bin Ar-Rabi-al-Ansari, Saud suggested that 'Abdur-Rahman should accept half of his property and family. 'Abdur Rahman said, "May Allah bless you in your family and property; guide me to the market." So 'Abdur-Rahman (while doing business in the market) made some profit of some condensed dry yoghurt and butter. After a few days the Prophet saw him wearing clothes stained with yellow perfume. The Prophet asked, "What is this, O 'Abdur-Rahman?" He said, "O Allah's Apostle! I have married an Ansar' woman." The Prophet asked, "What have you given her as Mahr?" He (i.e. 'Abdur-Rahman) said, "A piece of gold, about the weight of a date stone." Then the Prophet said, Give a banquet, even though of a sheep."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.275]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 275

Narrated Anas:

When the news of the arrival of the Prophet at Medina reached 'Abdullah bin Salam, he went to him to ask him about certain things, He said, "I am going to ask you about three things which only a Prophet can answer: What is the first sign of The Hour? What is the first food which the people of Paradise will eat? Why does a child attract the similarity to his father or to his mother?" The Prophet replied, "Gabriel has just now informed me of that." Ibn Salam said, "He (i.e. Gabriel) is the enemy of the Jews amongst the angels. The Prophet said, "As for the first sign of The Hour, it will be a fire that will collect the people from the East to the West. As for the first meal which the people of Paradise will eat, it will be the caudate (extra) lobe of the fish-liver. As for the child, if the man's discharge proceeds the woman's discharge, the child attracts the similarity to the man, and if the woman's discharge proceeds the man's, then the child attracts the similarity to the woman."

On this, 'Abdullah bin Salam said, "I testify that None has the right to be worshipped except Allah, and that you are the Apostle of Allah." and added, "O Allah's Apostle! Jews invent such lies as make one astonished, so please ask them about me before they know about my conversion to I slam . " The Jews came, and the Prophet said, "What kind of man is 'Abdullah bin Salam among you?" They replied, "The best of us and the son of the best of us and the most superior among us, and the son of the most superior among us. "The Prophet said, "What would you think if 'Abdullah bin Salam should embrace Islam?" They said, "May Allah protect him from that." The Prophet repeated his question and they gave the same answer. Then 'Abdullah came out to them and said, "I testify that None has the right to be worshipped except Allah and that Muhammad is the Apostle of Allah!" On this, the Jews said, "He is the most wicked among us and the son of the most wicked among us." So they degraded him. On this, he (i.e. 'Abdullah bin Salam) said, "It is this that I was afraid of, O Allah's Apostle.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.276]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 276

Narrated Abu Al-Minhal 'AbdurRahman bin Mut'im:

A partner of mine sold some Dirhams on credit in the market. I said, "Glorified be Allah! Is this legal?" He replied, "Glorified be Allah! By Allah, when I sold them in the market, nobody objected to it." Then I asked Al-Bara' bin 'Azib (about it) he said, "We used to make such a transaction when the Prophet came to Medina. So he said, 'There is no harm in it if it is done from hand to hand, but it is not allowed on credit.' Go to Zaid bin Al- Arqam and ask him about it for he was the greatest trader of all of us." So I asked Zaid bin Al-Arqam., and he said the same (as Al-Bara) did."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.277]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 277

Narrated Abu Huraira:

The Prophet said, "Had only ten Jews (amongst their chiefs) believe me, all the Jews would definitely have believed me."


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.278]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 278

Narrated Abu Musa:

When the Prophet arrived at Medina, he noticed that some people among the Jews used to respect Ashura' (i.e. 10th of Muharram) and fast on it. The Prophet then said, "We have more right to observe fast on this day." and ordered that fasting should be observed on it.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.279]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 279

Narrated Ibn 'Abbas:

When the Prophet arrived at Medina he found that the Jews observed fast on the day of 'Ashura'. They were asked the reason for the fast. They replied, "This is the day when Allah caused Moses and the children of Israel to have victory over Pharaoh, so we fast on this day as a sign of glorifying it." Allah's Apostle said, "We are closer to Moses than you." Then he ordered that fasting on this day should be observed.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.280]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 280

Narrated 'Abdullah bin Abbas:

The Prophet used to keep his hair falling loose while the pagans used to part their hair, and the People of the Scriptures used to keep their hair falling loose, and the Prophet liked to follow the People of the Scriptures in matters about which he had not been instructed differently, but later on the Prophet started parting his hair.


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.281]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 281

Narrated Ibn Abbas:

They, the people of the Scriptures, divided this Scripture into parts, believing in some portions of it and disbelieving the others. (See 15:91)


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.282]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 282

Narrated Salman Al-Farisi:

That he was sold (as a slave) by one master to another for more than ten times (i.e between 13 and 19).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.283]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 283

Narrated Salman:

I am from Ram-Hurmuz (i.e. a Persian town).


Bukhari :: Merits of the Helpers in Madinah (Ansaar) :: [5.58.284]

Merits of the Helpers in Madinah (Ansaar)

Bukhari :: Book 5 :: Volume 58 :: Hadith 284

Narrated Salman:

The interval between Jesus and Muhammad was six hundred years.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.285]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 285

Narrated Abu Ishaq:

Once, while I was sitting beside Zaid bin Al-Arqam, he was asked, "How many Ghazwat did the Prophet undertake?" Zaid replied, "Nineteen." They said, "In how many Ghazwat did you join him?" He replied, "Seventeen." I asked, "Which of these was the first?" He replied, "Al-'Ashira or Al-'Ashiru."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.286]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 286

Narrated 'Abdullah bin Mas'ud:

From Sad bin Mu'adh: Sad bin Mu'adh was an intimate friend of Umaiya bin Khalaf and whenever Umaiya passed through Medina, he used to stay with Sad, and whenever Sad went to Mecca, he used to stay with Umaiya. When Allah's Apostle arrived at Medina, Sa'd went to perform 'Umra and stayed at Umaiya's home in Mecca. He said to Umaiya, "Tell me of a time when (the Mosque) is empty so that I may be able to perform Tawaf around the Ka'ba." So Umaiya went with him about midday. Abu Jahl met them and said, "O Abu Safwan! Who is this man accompanying you?" He said, "He is Sad." Abu Jahl addressed Sad saying, "I see you wandering about safely in Mecca inspite of the fact that you have given shelter to the people who have changed their religion (i.e. became Muslims) and have claimed that you will help them and support them. By Allah, if you were not in the company of Abu Safwan, you would not be able to go your family safely." Sad, raising his voice, said to him, "By Allah, if you should stop me from doing this (i.e. performing Tawaf) I would certainly prevent you from something which is more valuable for you, that is, your passage through Medina." On this, Umaiya said to him, "O Sad do not raise your voice before Abu-l-Hakam, the chief of the people of the Valley (of Mecca)." Sad said, "O Umaiya, stop that! By Allah, I have heard Allah's Apostle predicting that the Muslim will kill you." Umaiya asked, "In Mecca?" Sad said, "I do not know." Umaiya was greatly scared by that news.

When Umaiya returned to his family, he said to his wife, "O Um Safwan! Don't you know what Sad told me? "She said, "What has he told you?" He replied, "He claims that Muhammad has informed them (i.e. companions that they will kill me. I asked him, 'In Mecca?' He replied, 'I do not know." Then Umaiya added, "By Allah, I will never go out of Mecca." But when the day of (the Ghazwa of) Badr came, Abu Jahl called the people to war, saying, "Go and protect your caravan." But Umaiya disliked to go out (of Mecca). Abu Jahl came to him and said, "O Abu Safwan! If the people see you staying behind though you are the chief of the people of the Valley, then they will remain behind with you." Abu Jahl kept on urging him to go until he (i.e. Umaiya) said, "As you have forced me to change my mind, by Allah, I will buy the best camel in Mecca. Then Umaiya said (to his wife). "O Um Safwan, prepare what I need (for the journey)." She said to him, "O Abu Safwan! Have you forgotten what your Yathribi brother told you?" He said, "No, but I do not want to go with them but for a short distance." So when Umaiya went out, he used to tie his camel wherever he camped. He kept on doing that till Allah caused him to be killed at Badr.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.287]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 287

Narrated Kab bin Malik:

I never failed to join Allah's Apostle in any of his Ghazawat except in the Ghazwa of Tabuk. However, I did not take part in the Ghazwa of Badr, but none who failed to take part in it, was blamed, for Allah's Apostle had gone out to meet the caravans of (Quraish, but Allah caused them (i.e. Muslims) to meet their enemy unexpectedly (with no previous intention) .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.288]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 288

Narrated Ibn Masud:

I witnessed Al-Miqdad bin Al-Aswad in a scene which would have been dearer to me than anything had I been the hero of that scene. He (i.e. Al-Miqdad) came to the Prophet while the Prophet was urging the Muslims to fight with the pagans. Al-Miqdad said, "We will not say as the People of Moses said: Go you and your Lord and fight you two. (5.27). But we shall fight on your right and on your left and in front of you and behind you." I saw the face of the Prophet getting bright with happiness, for that saying delighted him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.289]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 289

Narrated Ibn Abbas:

On the day of the battle of Badr, the Prophet said, "O Allah! I appeal to You (to fulfill) Your Covenant and Promise. O Allah! If Your Will is that none should worship You (then give victory to the pagans)." Then Abu Bakr took hold of him by the hand and said, "This is sufficient for you." The Prophet came out saying, "Their multitude will be put to flight and they will show their backs." (54.45)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.290]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 290

Narrated Ibn Abbas:

The believers who failed to join the Ghazwa of Badr and those who took part in it are not equal (in reward).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.291]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 291

Narrated Al-Bara:

I and Ibn 'Umar were considered too young to take part in the battle of Badr.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.292]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 292

Narrated Al-Bara:

I and Ibn 'Umar were considered too young (to take part) in the battle of Badr, and the number of the Emigrant warriors were over sixty (men) and the Ansar were over 249.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.293]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 293

Narrated Al-Bara:

The companions of (the Prophet) Muhammad who took part in Badr, told me that their number was that of Saul's (i.e. Talut's) companions who crossed the river (of Jordan) with him and they were over three-hundred-and-ten men. By Allah, none crossed the river with him but a believer. (See Qur'an 2:249)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.294]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 294

Narrated Al-Bara:

We, the Companions of Muhammad used to say that the number of the warriors of Badr was the same as the number of Saul's companions who crossed the river (of Jordan) with him, and none crossed the river with him but a believer, and the were over three-hundred-and-ten men.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.295]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 295

Narrated Al-Bara:

As below (Hadith 295).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.296]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 296

Narrated Al-Bara:

We used to say that the warriors of Badr were over three-hundred-and-ten, as many as the Companions of Saul who crossed the river with him; and none crossed the river with him but a believer.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.297]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 297

Narrated 'Abdullah bin Mas'ud:

The Prophet faced the Ka'ba and invoked evil on some people of Quraish, on Shaiba bin Rabi'a, 'Utba bin Rabi'a, Al-Walid bin 'Utba and Abu Jahl bin Hisham. I bear witness, by Allah, that I saw them all dead, putrefied by the sun as that day was a very hot day.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.298]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 298

Narrated Abdullah: That he came across Abu Jahl while he was on the point of death on the day of Badr. Abu Jahl said, "You should not be proud that you have killed me nor I am ashamed of being killed by my own folk."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.299]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 299

Narrated Anas:

As below (Hadith 300).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.300]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 300

Narrated Anas:

The Prophet said, "Who will go and see what has happened to Abu Jahl?" Ibn Mas'ud went and found that the two sons of 'Afra had struck him fatally (and he was in his last breaths). 'Abdullah bin Mas'ud said, "Are you Abu Jahl?" And took him by the beard. Abu Jahl said, "Can there be a man superior to one you have killed or one whom his own folk have killed?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.301]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 301

Narrated Anas:

On the day of Badr, the Prophet said, "Who will go and see what has happened to Abu Jahl?" Ibn Mas'ud went and found that the two sons of 'Afra had struck him fatally. 'Abdullah bin Mas'ud got hold of his beard and said, "'Are you Abu Jahl?" He replied, "Can there be a man more superior to one whom his own folk have killed (or you have killed)?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.302]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 302

Narrated Anas bin Malik:

(as above Hadith 301).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.303]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 303

Narrated 'Abdur-Rahman bin 'Auf:

(the grandfather of Salih bin Ibrahim) the story of Badr, namely, the narration regarding the sons of 'Afra'.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.304]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 304

Narrated Abu Mijlaz:

From Qais bin Ubad: 'Ali bin Abi Talib said, "I shall be the first man to kneel down before (Allah), the Beneficent to receive His judgment on the day of Resurrection (in my favor)." Qais bin Ubad also said, "The following Verse was revealed in their connection:--

"These two opponents believers and disbelievers) Dispute with each other About their Lord." (22.19) Qais said that they were those who fought on the day of Badr, namely, Hamza, 'Ali, 'Ubaida or Abu 'Ubaida bin Al-Harith, Shaiba bin Rabi'a, 'Utba and Al-Wahd bin Utba.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.305]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 305

Narrated Abu Dhar:

The following Holy Verse:--

"These two opponents (believers & disbelievers) dispute with each other about their Lord," (22.19) was revealed concerning six men from Quraish, namely, 'Ali, Hamza, 'Ubaida bin Al-Harith; Shaiba bin Rabi'a, 'Utba bin Rabi'a and Al-Walid bin 'Utba.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.306]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 306

Narrated 'Ali:

The following Holy Verse:-- "These two opponents (believers and disbelievers) dispute with each other about their Lord." (22.19) was revealed concerning us.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.307]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 307

Narrated Qais bin Ubad:

I heard Abu Dhar swearing that these Holy Verses were revealed in connection with those six persons on the day of Badr.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.308]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 308

Narrated Qais:

I heard Abu Dhar swearing that the following Holy verse:-- "These two opponents (believers and disbelievers) disputing with each other about their Lord," (22.19) was revealed concerning those men who fought on the day of Badr, namely, Hamza, 'Ali, Ubaida bin Al-Harith, Utba and Shaiba----the two sons of Rabi'a-- and Al-Walid bin 'Utba.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.309]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 309

Narrated Abu Ishaq:

A man asked Al-Bara' and I was listening, "Did 'Ali take part in (the battle of) Badr?" Al-Bara' said, "(Yes). he even met (his enemies) in a duel and was clad in two armors (one over the other),"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.310]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 310

Narrated 'Abdur-Rahman bin 'Auf:

"I had an agreement with Umaiya bin Khalaf (that he would look after my relatives and property in Mecca, and I would look after his relatives and property in Medina)." 'Abdur-Rahman then mentioned the killing of Umaiya and his son on the day of Badr, and Bilal said, "Woe to me if Umaiya remains safe (i.e. alive) . "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.311]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 311

Narrated 'Abdullah:

The Prophet recited Surat-an-Najm and then prostrated himself, and all who were with him prostrated too. But an old man took a handful of dust and touched his forehead with it saying, "This is sufficient for me." Later on I saw him killed as an infidel.

Narrated 'Urwa (the son of Az- Zubair): Az-Zubair had three scars caused by the sword, one of which was over his shoulder and I used to insert my fingers in it. He received two of those wounds on the day of Badr and one on the day of Al-Yarmuk. When 'Abdullah bin Zubair was killed, 'Abdul-Malik bin Marwan said to me, "O 'Urwa, do you recognize the sword of Az-Zubair?" I said, "Yes." He said, "What marks does it have?" I replied, "It has a dent in its sharp edge which was caused in it on the day of Badr." 'Abdul- Malik said, "You are right! (i.e. their swords) have dents because of clashing with the regiments of the enemies Then 'Abdul-Malik returned that sword to me (i.e. Urwa). (Hisham, 'Urwa's son said, "We estimated the price of the sword as three-thousand (Dinars) and after that it was taken by one of us (i.e. the inheritors) and I wish I could have had it.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.312]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 312

Narrated Hisham:

That his father said, "The sword of Az-Zubair was decorated with silver." Hisham added, "The sword of 'Urwa was (also) decorated with silver. "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.313]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 313

Narrated 'Urwa:

On the day of (the battle) of Al-Yarmuk, the companions of Allah's Apostle said to Az-Zubair, "Will you attack the enemy so that we shall attack them with you?" Az-Zubair replied, "If I attack them, you people would not support me." They said, "No, we will support you." So Az-Zubair attacked them (i.e. Byzantine) and pierced through their lines, and went beyond them and none of his companions was with him. Then he returned and the enemy got hold of the bridle of his (horse) and struck him two blows (with the sword) on his shoulder. Between these two wounds there was a scar caused by a blow, he had received on the day of Badr (battle). When I was a child I used to play with those scars by putting my fingers in them. On that day (my brother) "Abdullah bin Az-Zubair was also with him and he was ten years old. Az-Zubair had carried him on a horse and let him to the care of some men.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.314]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 314

Narrated Abu Talha:

On the day of Badr, the Prophet ordered that the corpses of twenty four leaders of Quraish should be thrown into one of the dirty dry wells of Badr. (It was a habit of the Prophet that whenever he conquered some people, he used to stay at the battle-field for three nights. So, on the third day of the battle of Badr, he ordered that his she-camel be saddled, then he set out, and his companions followed him saying among themselves." "Definitely he (i.e. the Prophet) is proceeding for some great purpose." When he halted at the edge of the well, he addressed the corpses of the Quraish infidels by their names and their fathers' names, "O so-and-so, son of so-and-so and O so-and-so, son of so-and-so! Would it have pleased you if you had obeyed Allah and His Apostle? We have found true what our Lord promised us. Have you too found true what your Lord promised you? "'Umar said, "O Allah's Apostle! You are speaking to bodies that have no souls!" Allah's Apostle said, "By Him in Whose Hand Muhammad's soul is, you do not hear, what I say better than they do." (Qatada said, "Allah brought them to life (again) to let them hear him, to reprimand them and slight them and take revenge over them and caused them to feel remorseful and regretful.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.315]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 315

Narrated Ibn 'Abbas:

regarding the Statement of Allah:--"Those who have changed Allah's Blessings for disbelief..." (14.28) The people meant here by Allah, are the infidels of Quraish. ('Amr, a sub-narrator said, "Those are (the infidels of) Quraish and Muhammad is Allah's Blessing. Regarding Allah's Statement:"..and have led their people Into the house of destruction? (14.29) Ibn 'Abbas said, "It means the Fire they will suffer from (after their death) on the day of Badr."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.316]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 316

Narrated Hisham's father:

It was mentioned before 'Aisha that Ibn 'Umar attributed the following statement to the Prophet "The dead person is punished in the grave because of the crying and lamentation Of his family." On that, 'Aisha said, "But Allah's Apostle said, 'The dead person is punished for his crimes and sins while his family cry over him then." She added, "And this is similar to the statement of Allah's Apostle when he stood by the (edge of the) well which contained the corpses of the pagans killed at Badr, 'They hear what I say.' She added, "But he said now they know very well what I used to tell them was the truth." 'Aisha then recited: 'You cannot make the dead hear.' (30.52) and 'You cannot make those who are in their Graves, hear you.' (35.22) that is, when they had taken their places in the (Hell) Fire.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.317]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 317

Narrated Ibn Umar:

The Prophet stood at the well of Badr (which contained the corpses of the pagans) and said, "Have you found true what your lord promised you?" Then he further said, "They now hear what I say." This was mentioned before 'Aisha and she said, "But the Prophet said, 'Now they know very well that what I used to tell them was the truth.' Then she recited (the Holy Verse):-- "You cannot make the dead hear... ...till the end of Verse)." (30.52)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.318]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 318

Narrated Anas:

Haritha was martyred on the day (of the battle) of Badr, and he was a young boy then. His mother came to the Prophet and said, "O Allah's Apostle! You know how dear Haritha is to me. If he is in Paradise, I shall remain patient, and hope for reward from Allah, but if it is not so, then you shall see what I do?" He said, "May Allah be merciful to you! Have you lost your senses? Do you think there is only one Paradise? There are many Paradises and your son is in the (most superior) Paradise of Al-Firdaus."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.319]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 319

Narrated 'Ali:

Allah's Apostle sent me, Abu Marthad and Az-Zubair, and all of us were riding horses, and said, "Go till you reach Raudat-Khakh where there is a pagan woman carrying a letter from Hatib bin Abi Balta' a to the pagans of Mecca." So we found her riding her camel at the place which Allah's Apostle had mentioned. We said (to her),"(Give us) the letter." She said, "I have no letter." Then we made her camel kneel down and we searched her, but we found no letter. Then we said, "Allah's Apostle had not told us a lie, certainly. Take out the letter, otherwise we will strip you naked." When she saw that we were determined, she put her hand below her waist belt, for she had tied her cloak round her waist, and she took out the letter, and we brought her to Allah's Apostle Then 'Umar said, "O Allah's Apostle! (This Hatib) has betrayed Allah, His Apostle and the believers! Let me cut off his neck!" The Prophet asked Hatib, "What made you do this?" Hatib said, "By Allah, I did not intend to give up my belief in Allah and His Apostle but I wanted to have some influence among the (Mecca) people so that through it, Allah might protect my family and property. There is none of your companions but has some of his relatives there through whom Allah protects his family and property." The Prophet said, "He has spoken the truth; do no say to him but good." 'Umar said, "He as betrayed Allah, His Apostle and the faithful believers. Let me cut off his neck!" The Prophet said, "Is he not one of the Badr warriors? May be Allah looked at the Badr warriors and said, 'Do whatever you like, as I have granted Paradise to you, or said, 'I have forgiven you."' On this, tears came out of Umar's eyes, and he said, "Allah and His Apostle know better."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.320]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 320

Narrated Usaid:

On the day of Badr, Allah's Apostle said to us, "When the enemy comes near to you, shoot at them but use your arrows sparingly (so that your arrows should not be wasted)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.321]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 321

Narrated Abu Usaid:

On the day of (the battle of) Badr, Allah's Apostle said to us, "When your enemy comes near to you (i.e. overcome you by sheer number), shoot at them but use your arrows sparingly."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.322]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 322

Narrated Al-Bara' bin 'Azib:

On the day of Uhud the Prophet appointed 'Abdullah bin Jubair as chief of the archers, and seventy among us were injured and martyred. On the day (of the battle) of Badr, the Prophet and his companions had inflicted 140 casualties on the pagans, 70 were taken prisoners, and 70 were killed. Abu Sufyan said, "This is a day of (revenge) for the day of Badr and the issue of war is undecided ."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.323]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 323

Narrated Abu Musa:

That the Prophet said, "The good is what Allah gave us later on (after Uhud), and the reward of truthfulness is what Allah gave us after the day (of the battle) of Badr."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.324]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 324

Narrated 'Abdur-Rahman bin 'Auf:

While I was fighting in the front file on the day (of the battle) of Badr, suddenly I looked behind and saw on my right and left two young boys and did not feel safe by standing between them. Then one of them asked me secretly so that his companion may not hear, "O Uncle! Show me Abu Jahl." I said, "O nephew! What will you do to him?" He said, "I have promised Allah that if I see him (i.e. Abu Jahl), I will either kill him or be killed before I kill him." Then the other said the same to me secretly so that his companion should not hear. I would not have been pleased to be in between two other men instead of them. Then I pointed him (i.e. Abu Jahl) out to them. Both of them attacked him like two hawks till they knocked him down. Those two boys were the sons of 'Afra' (i.e. an Ansari woman).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.325]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 325

Narrated Abu Huraira:

Allah's Apostle sent out ten spies under the command of 'Asim bin Thabit Al-Ansari, the grand-father of 'Asim bin 'Umar Al-Khattab. When they reached (a place called) Al-Hadah between 'Usfan and Mecca, their presence was made known to a sub-tribe of Hudhail called Banu Lihyan. So they sent about one hundred archers after them. The archers traced the footsteps (of the Muslims) till they found the traces of dates which they had eaten at one of their camping places. The archers said, "These dates are of Yathrib (i.e. Medina)," and went on tracing the Muslims' footsteps. When 'Asim and his companions became aware of them, they took refuge in a (high) place. But the enemy encircled them and said, "Come down and surrender. We give you a solemn promise and covenant that we will not kill anyone of you." 'Asim bin Thabit said, "O people! As for myself, I will never get down to be under the protection of an infidel. O Allah! Inform your Prophet about us." So the archers threw their arrows at them and martyred 'Asim. Three of them came down and surrendered to them, accepting their promise and covenant and they were Khubaib, Zaid bin Ad-Dathina and another man. When the archers got hold of them, they untied the strings of the arrow bows and tied their captives with them. The third man said, "This is the first proof of treachery! By Allah, I will not go with you for I follow the example of these." He meant the martyred companions. The archers dragged him and struggled with him (till they martyred him). Then Khubaib and Zaid bin Ad-Dathina were taken away by them and later on they sold them as slaves in Mecca after the event of the Badr battle.

The sons of Al-Harit bin 'Amr bin Naufal bought Khubaib for he was a person who had killed (their father) Al-Hari bin 'Amr on the day (of the battle) of Badr. Khubaib remained imprisoned by them till they decided unanimously to kill him. One day Khubaib borrowed from a daughter of Al-Harith, a razor for shaving his public hair, and she lent it to him. By chance, while she was inattentive, a little son of hers went to him (i.e. Khubaib) and she saw that Khubaib had seated him on his thigh while the razor was in his hand. She was so much terrified that Khubaib noticed her fear and said, "Are you afraid that I will kill him? Never would I do such a thing." Later on (while narrating the story) she said, "By Allah, I had never seen a better captive than Khubaib. By Allah, one day I saw him eating from a bunch of grapes in his hand while he was fettered with iron chains and (at that time) there was no fruit in Mecca." She used to say," It was food Allah had provided Khubaib with."

When they took him to Al-Hil out of Mecca sanctuary to martyr him, Khubaib requested them. "Allow me to offer a two-Rak'at prayer." They allowed him and he prayed two Rakat and then said, "By Allah! Had I not been afraid that you would think I was worried, I would have prayed more." Then he (invoked evil upon them) saying, "O Allah! Count them and kill them one by one, and do not leave anyone of them"' Then he recited: "As I am martyred as a Muslim, I do not care in what way I receive my death for Allah's Sake, for this is for the Cause of Allah. If He wishes, He will bless the cut limbs of my body." Then Abu Sarva, 'Ubqa bin Al-Harith went up to him and killed him. It was Khubaib who set the tradition of praying for any Muslim to be martyred in captivity (before he is executed). The Prophet told his companions of what had happened (to those ten spies) on the same day they were martyred. Some Quraish people, being informed of 'Asim bin Thabit's death, sent some messengers to bring a part of his body so that his death might be known for certain, for he had previously killed one of their leaders (in the battle of Badr). But Allah sent a swarm of wasps to protect the dead body of 'Asim, and they shielded him from the messengers who could not cut anything from his body.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.326]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 326

Narrated Nafi:

Ibn 'Umar was once told that Said bin Zaid bin 'Amr bin Nufail, one of the Badr warriors, had fallen ill on a Friday. Ibn 'Umar rode to him late in the forenoon. The time of the Friday prayer approached and Ibn 'Umar did not take part in the Friday prayer.

Narrated Subaia bint Al-Harith: That she was married to Sad bin Khaula who was from the tribe of Bani 'Amr bin Luai, and was one of those who fought the Badr battle. He died while she wa pregnant during Hajjat-ul-Wada.' Soon after his death, she gave birth to a child. When she completed the term of deliver (i.e. became clean), she prepared herself for suitors. Abu As-Sanabil bin Bu'kak, a man from the tribe of Bani Abd-ud-Dal called on her and said to her, "What! I see you dressed up for the people to ask you in marriage. Do you want to marry By Allah, you are not allowed to marry unless four months and ten days have elapsed (after your husband's death)." Subai'a in her narration said, "When he (i.e. Abu As-Sanabil) said this to me. I put on my dress in the evening and went to Allah's Apostle and asked him about this problem. He gave the verdict that I was free to marry as I had already given birth to my child and ordered me to marry if I wished."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.327]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 327

Narrated Rifaa:

(who was one of the Badr warriors) Gabriel came to the Prophet and said, "How do you look upon the warriors of Badr among yourselves?" The Prophet said, "As the best of the Muslims." or said a similar statement. On that, Gabriel said, "And so are the Angels who participated in the Badr (battle)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.328]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 328

Narrated Mu'adh bin Rifa'a bin Rafi:

Rifa'a was one of the warriors of Badr while (his father) Rafi' was one of the people of Al-'Aqaba (i.e. those who gave the pledge of allegiance at Al-'Aqaba). Rafi' used to say to his son, "I would not have been happier if I had taken part in the Badr battle instead of taking part in the 'Aqaba pledge."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.329]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 329

Narrated Mu'adh:

The one who asked (the Prophet) was Gabriel.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.330]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 330

Narrated Ibn 'Abbas:

The Prophet said on the day (of the battle) of Badr, "This is Gabriel holding the head of his horse and equipped with arms for the battle.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.331]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 331

Narrated Anas:

Abu Zaid died and did not leave any offspring, and he was one of the Badr warriors.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.332]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 332

Narrated Ibn Abbas:

Abu Said bin Malik Al-Khudri returned from a journey and his family offered him some meat of sacrifices offered at 'Id ul Adha. On that he said, "I will not eat it before asking (whether it is allowed)." He went to his maternal brother, Qatada bin N i 'man, who was one of the Badr warriors, and asked him about it. Qatada said, "After your departure, an order was issued by the Prophet cancelling the prohibition of eating sacrifices after three days."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.333]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 333

Narrated 'Urwa:

Az-Zubair said, "I met Ubaida bin Said bin Al-As on the day (of the battle) of Badr and he was covered with armor; so much that only his eyes were visible. He was surnamed Abu Dhat-al-Karish. He said (proudly), 'I am Abu-al-Karish.' I attacked him with the spear and pierced his eye and he died. I put my foot over his body to pull (that spear) out, but even then I had to use a great force to take it out as its both ends were bent." 'Urwa said, "Later on Allah's Apostle asked Az-Zubair for the spear and he gave it to him. When Allah's Apostle died, Az-Zubair took it back. After that Abu Bakr demanded it and he gave it to him, and when Abu Bakr died, Az-Zubair took it back. 'Umar then demanded it from him and he gave it to him. When 'Umar died, Az-Zubair took it back, and then 'Uthman demanded it from him and he gave it to him. When 'Uthman was martyred, the spear remained with Ali's offspring. Then 'Abdullah bin Az-Zubair demanded it back, and it remained with him till he was martyred.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.334]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 334

Narrated 'Ubada bin As-Samit:

(who was one of the Badr warriors) Allah's Apostle said, "Give me the pledge of allegiance."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.335]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 335

Narrated 'Aisha:

(the wife of the Prophet) Abu Hudhaifa, one of those who fought the battle of Badr, with Allah's Apostle adopted Salim as his son and married his niece Hind bint Al-Wahd bin 'Utba to him' and Salim was a freed slave of an Ansari woman. Allah's Apostle also adopted Zaid as his son. In the Pre-lslamic period of ignorance the custom was that, if one adopted a son, the people would call him by the name of the adopted-father whom he would inherit as well, till Allah revealed: "Call them (adopted sons) By (the names of) their fathers." (33.5)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.336]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 336

Narrated Ar-Rubai bint Muauwidh:

The Prophet came to me after consuming his marriage with me and sat down on my bed as you (the sub-narrator) are sitting now, and small girls were beating the tambourine and singing in lamentation of my father who had been killed on the day of the battle of Badr. Then one of the girls said, "There is a Prophet amongst us who knows what will happen tomorrow." The Prophet said (to her)," Do not say this, but go on saying what you have spoken before."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.337]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 337

Narrated Ibn 'Abbas:

As below (Hadith 338).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.338]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 338

Narrated Ibn Abbas:

Abu Talha, a companion of Allah's Apostle and one of those who fought at Badr together with Allah's Apostle told me that Allah's Apostle said. "Angels do not enter a house in which there is a dog or a picture" He meant the images of creatures that have souls.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.339]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 339

Narrated 'Ali:

as below (Hadith 340).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.340]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 340

Narrated 'Ali:

I had a she-camel which I got in my share from the booty of the battle of Badr, and the Prophet had given me another she camel from the Khumus which Allah had bestowed on him that day. And when I intended to celebrate my marriage to Fatima, the daughter of the Prophet, I made an arrangement with a goldsmith from Bani Qainuqa 'that he should go with me to bring Idhkhir (i.e. a kind of grass used by gold-smiths) which I intended to sell to gold-smiths in order to spend its price on the marriage banquet. While I was collecting ropes and sacks of pack saddles for my two she-camels which were kneeling down beside an Ansari's dwelling and after collecting what I needed, I suddenly found that the humps of the two she-camels had been cut off and their flanks had been cut open and portions of their livers had been taken out. On seeing that, I could not help weeping. I asked, "Who has done that?" They (i.e. the people) said, "Hamza bin 'Abdul Muttalib has done it. He is present in this house with some Ansari drinkers, a girl singer, and his friends. The singer said in her song, "O Hamza, get at the fat she-camels!" On hearing this, Hamza rushed to his sword and cut of the camels' humps and cut their flanks open and took out portions from their livers." Then I came to the Prophet, with whom Zaid bin Haritha was present. The Prophet noticed my state and asked, "What is the matter?" I said, "O Allah's Apostle, I have never experienced such a day as today! Hamza attacked my two she-camels, cut off their humps and cut their flanks open, and he is still present in a house along some drinkers." The Prophet asked for his cloak, put it on, and proceeded, followed by Zaid bin Haritha and myself, till he reached the house where Hamza was. He asked the permission to enter, and he was permitted. The Prophet started blaming Hamza for what he had done. Hamza was drunk and his eyes were red. He looked at the Prophet then raised his eyes to look at his knees and raised his eves more to look at his face and then said, "You are not but my father's slaves." When the Prophet understood that Hamza was drunk, he retreated, walking backwards went out and we left with him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.341]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 341

Narrated Ibn Maqal:

'Ali led the funeral prayer of Sahl bin Hunaif and said, "He was one of the warriors of Badr."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.342]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 342

Narrated 'Abdullah bin 'Umar:

Umar bin Al-Khattab said, "When (my daughter) Hafsa bint 'Umar lost her husband Khunais bin Hudhaifa As-Sahrni who was one of the companions of Allah's Apostle and had fought in the battle of Badr and had died in Medina, I met 'Uthman bin 'Affan and suggested that he should marry Hafsa saying, "If you wish, I will marry Hafsa bint 'Umar to you,' on that, he said, 'I will think it over.' I waited for a few days and then he said to me. 'I am of the opinion that I shall not marry at present.' Then I met Abu Bakr and said, 'if you wish, I will marry you, Hafsa bint 'Umar.' He kept quiet and did not give me any reply and I became more angry with him than I was with Uthman . Some days later, Allah's Apostle demanded her hand in marriage and I married her to him. Later on Abu Bakr met me and said, "Perhaps you were angry with me when you offered me Hafsa for marriage and I gave no reply to you?' I said, 'Yes.' Abu Bakr said, 'Nothing prevented me from accepting your offer except that I learnt that Allah's Apostle had referred to the issue of Hafsa and I did not want to disclose the secret of Allah's Apostle , but had he (i.e. the Prophet) given her up I would surely have accepted her."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.343]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 343

Narrated Abu Masud Al-Badri:

The Prophet said, "A man's spending on his family is a deed of charity."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.344]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 344

Narrated Az-Zuhri:

I heard 'Urwa bin Az-Zubair talking to 'Umar bin 'Abdul 'Aziz during the latter's Governorship (at Medina), he said, "Al-Mughira bin Shu'ba delayed the 'Asr prayer when he was the ruler of Al-Kufa. On that, Abu Mas'ud. 'Uqba bin 'Amr Al-Ansari, the grand-father of Zaid bin Hasan, who was one of the Badr warriors, came in and said, (to Al-Mughira), 'You know that Gabriel came down and offered the prayer and Allah's Apostle prayed five prescribed prayers, and Gabriel said (to the Prophet ), "I have been ordered to do so (i.e. offer these five prayers at these fixed stated hours of the day)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.345]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 345

Narrated Abu Masud Al-Badri:

Allah's Apostle said, "It is sufficient for one to recite the last two Verses of Surat-al-Baqara at night."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.346]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 346

Narrated Mahmud bin Ar-Rabi:

That 'Itban bin Malik who was one of the companions of the Prophet and one of the warriors of Badr, came to Allah's Apostle.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.347]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 347

Narrated Ibn Shihab:

I asked Al-Husain bin Muhammad who was one of the sons of Salim and one of the nobles amongst them, about the narration of Mahmud bin Ar-Rabi 'from 'Itban bin Malik, and he confirmed it.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.348]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 348

Narrated 'Abdullah bin 'Amr bin Rabi'a:

who was one of the leaders of Bani 'Adi and his father participated in the battle of Badr in the company of the Prophet. 'Umar appointed Qudama bin Maz'un as ruler of Bahrain, Qudama was one of the warriors of the battle of Badr and was the maternal uncle of Abdullah bin 'Umar and Hafsa.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.349]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 349

Narrated Az-Zuhri:

Salim bin 'Abdullah told me that Rafi' bin Khadij told 'Abdullah bin 'Umar that his two paternal uncles who had fought in the battle of Badr informed him that Allah's Apostle forbade the renting of fields. I said to Salim, "Do you rent your land?" He said, "Yes, for Rafi' is mistaken."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.350]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 350

Narrated 'Abdullah bin Shaddad bin Al-Had Al-Laithi:

I saw Rifa'a bin Rafi Al-Ansari who was a Badr warrior.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.351]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 351

Narrated Al-Miswar bin Makhrama:

That 'Amr bin Auf, who was an ally of Bani 'Amir bin Luai and one of those who fought at Badr in the company of the Prophet , said, "Allah's Apostle sent Abu 'Ubaida bin Al-Jarrah to Bahrain to bring the Jizya taxation from its people, for Allah's Apostle had made a peace treaty with the people of Bahrain and appointed Al-'Ala' bin Al-Hadrami as their ruler. So, Abu 'Ubaida arrived with the money from Bahrain. When the Ansar heard of the arrival of Abu 'Ubaida (on the next day) they offered the morning prayer with the Prophet and when the morning prayer had finished, they presented themselves before him. On seeing the Ansar, Allah's Apostle smiled and said, "I think you have heard that Abu 'Ubaida has brought something?" They replied, "Indeed, it is so, O Allah's Apostle!" He said, "Be happy, and hope for what will please you. By Allah, I am not afraid that you will be poor, but I fear that worldly wealth will be bestowed upon you as it was bestowed upon those who lived before you. So you will compete amongst yourselves for it, as they competed for it and it will destroy you as it did them."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.352]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 352

Narrated Nafi: Ibn 'Umar used to kill all kinds of snakes until Abu Lubaba Al-Badri told him that the Prophet had forbidden the killing of harmless snakes living in houses and called Jinan. So Ibn 'Umar gave up killing them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.353]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 353

Narrated Anas bin Malik:

Some men of the Ansar requested Allah's Apostle to allow them to see him, they said, "Allow us to forgive the ransom of our sister's son, 'Abbas." The Prophet said, "By Allah, you will not leave a single Dirham of it!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.354]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 354

Narrated 'Ubaidullah bin 'Adi bin Al-Khiyar:

That Al-Miqdad bin 'Amr Al-Kindi, who was an ally of Bani Zuhra and one of those who fought the battle of Badr together with Allah's Apostle told him that he said to Allah's Apostle, "Suppose I met one of the infidels and we fought, and he struck one of my hands with his sword and cut it off and then took refuge in a tree and said, "I surrender to Allah (i.e. I have become a Muslim),' could I kill him, O Allah's Apostle, after he had said this?" Allah's Apostle said, "You should not kill him." Al-Miqdad said, "O Allah's Apostle! But he had cut off one of my two hands, and then he had uttered those words?" Allah's Apostle replied, "You should not kill him, for if you kill him, he would be in your position where you had been before killing him, and you would be in his position where he had been before uttering those words."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.355]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 355

Narrated Anas:

Allah's Apostle said on the day of Badr, "Who will go and see what has happened to Abu Jahl?" Ibn Mas'ud went and saw him struck by the two sons of 'Afra and was on the point of death . Ibn Mas'ud said, "Are you Abu Jahl?" Abu Jahl replied, "Can there be a man more superior to the one whom you have killed (or as Sulaiman said, or his own folk have killed.)?" Abu Jahl added, "Would that I had been killed by other than a mere farmer. "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.356]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 356

Narrated Ibn Abbas:

'Umar said, "When the Prophet died I said to Abu Bakr, 'Let us go to our Ansari brethren.' We met two pious men from them, who had fought in the battle of Badr." When I mentioned this to Urwa bin Az-Zubair, he said, "Those two pious men were 'Uwaim bin Sa'ida and Manbin Adi."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.357]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 357

Narrated Qais:

The Badr warriors were given five thousand (Dirhams) each, yearly. 'Umar said, "I will surely give them more than what I will give to others."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.358]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 358

Narrated Jubair bin Mut'im:

I heard the Prophet reciting Surat-at-Tur in Maghrib prayer, and that was at a time when belief was first planted in my heart. The Prophet while speaking about the war prisoners of Badr, said, "Were Al-Mutim bin Adi alive and interceded with me for these filthy people, I would definitely forgive them for his sake."

Narrated Said bin Al-Musaiyab: When the first civil strife (in Islam) took place because of the murder of 'Uthman, it left none of the Badr warriors alive. When the second civil strife, that is the battle of Al-Harra, took place, it left none of the Hudaibiya treaty companions alive. Then the third civil strife took place and it did not subside till it had exhausted all the strength of the people.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.359]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 359

Narrated Yunus bin Yazid:

I heard Az-Zuhri saying, "I heard 'Urwa bin Az-Zubair. Said bin Al-Musaiyab, 'Alqama bin Waqqas and 'Ubaidullah bin 'Abdullah each narrating part of the narrative concerning 'Aisha the wife of the Prophet. 'Aisha said: When I and Um Mistah were returning, Um Mistah stumbled by treading on the end of her robe, and on that she said, 'May Mistah be ruined.' I said, 'You have said a bad thing, you curse a man who took part in the battle of Badr!." Az-Zuhri then narrated the narration of the Lie (forged against 'Aisha).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.360]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 360

Narrated Ibn Shihab:

These were the battles of Allah's Apostle (which he fought), and while mentioning (the Badr battle) he said, "While the corpses of the pagans were being thrown into the well, Allah's Apostle said (to them), 'Have you found what your Lord promised true?" 'Abdullah said, "Some of the Prophet's companions said, "O Allah's Apostle! You are addressing dead people.' Allah's Apostle replied, 'You do not hear what I am saying, better than they.' The total number of Muslim fighters from Quraish who fought in the battle of Badr and were given their share of the booty, were 81 men." Az-Zubair said, "When their shares were distributed, their number was 101 men. But Allah knows it better."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.361]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 361

Narrated Az-Zubair:

On the day of Badr, (Quraishi) Emigrants received 100 shares of the war booty."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.362]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 362

Narrated Ibn Umar:

Bani An-Nadir and Bani Quraiza fought (against the Prophet violating their peace treaty), so the Prophet exiled Bani An-Nadir and allowed Bani Quraiza to remain at their places (in Medina) taking nothing from them till they fought against the Prophet again) . He then killed their men and distributed their women, children and property among the Muslims, but some of them came to the Prophet and he granted them safety, and they embraced Islam. He exiled all the Jews from Medina. They were the Jews of Bani Qainuqa', the tribe of 'Abdullah bin Salam and the Jews of Bani Haritha and all the other Jews of Medina.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.363]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 363

Narrated Said bin Jubair:

I mentioned to Ibn 'Abbas Surat-Hashr. He said, "Call it Surat-an-Nadir."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.364]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 364

Narrated Anas bin Malik:

Some people used to allot some date palm trees to the Prophet as gift till he conquered Banu Quraiza and Bani An-Nadir, where upon he started returning their date palms to them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.365]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 365

Narrated Ibn Umar:

Allah's Apostle had the date-palm trees of Bani Al-Nadir burnt and cut down at a place called Al-Buwaira. Allah then revealed: "What you cut down of the date-palm trees (of the enemy) Or you left them standing on their stems. It was by Allah's Permission." (59.5)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.366]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 366

Narrated Ibn Umar:

The Prophet burnt the date-palm trees of Bani An-Nadir. Hassan bin Thabit said the following poetic Verses about this event:-- "the terrible burning of Al-Buwaira Has been received indifferently By the nobles of Bani Luai (The masters and nobles of Quraish)." Abu Sufyan bin Al-Harith (i.e. the Prophet's cousin who was still a disbeliever then) replied to Hassan, saying in poetic verses:-- "May Allah bless that burning And set all its (i.e. Medina's) Parts on burning fire. You will see who is far from it (i.e. Al-Buwaira) And which of our lands will be Harmed by it (i.e. the burning of Al-Buwaira)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.367]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 367

Narrated Malik bin Aus Al-Hadathan An-Nasri:

That once 'Umar bin Al-Khattab called him and while he was sitting with him, his gatekeeper, Yarfa came and said, "Will you admit 'Uthman, 'Abdur-Rahman bin Auf, AzZubair and Sad (bin Abi Waqqas) who are waiting for your permission?" 'Umar said, "Yes, let them come in." After a while, Yarfa- came again and said, "Will you admit 'Ali and 'Abbas who are asking your permission?" 'Umar said, "Yes." So, when the two entered, 'Abbas said, "O chief of the believers! Judge between me and this (i.e. 'Ali). "Both of them had a dispute regarding the property of Bani An-Nadir which Allah had given to His Apostle as Fai (i.e. booty gained without fighting), 'Ali and 'Abbas started reproaching each other. The (present) people (i.e. 'Uthman and his companions) said, "O chief of the believers! Give your verdict in their case and relieve each from) the other." 'Umar said, "Wait I beseech you, by Allah, by Whose Permission both the heaven and the earth stand fast! Do you know that Allah's Apostle said, 'We (Prophets) our properties are not to be inherited, and whatever we leave, is to be spent in charity,' and he said it about himself?" They (i.e. 'Uthman and his company) said, "He did say it. "'Umar then turned towards 'Ali and 'Abbas and said, "I beseech you both, by Allah! Do you know that Allah's Apostle said this?" They replied in the affirmative. He said, "Now I am talking to you about this matter. Allah the Glorified favored His Apostle with something of this Fai (i.e. booty won without fighting) which He did not give to anybody else. Allah said:--

"And what Allah gave to His Apostle ("Fai"" Booty) from them--For which you made no expedition With either Calvary or camelry. But Allah gives power to His Apostles Over whomsoever He will And Allah is able to do all things." (59.6)

So this property was especially granted to Allah's Apostle . But by Allah, the Prophet neither took it all for himself only, nor deprived you of it, but he gave it to all of you and distributed it amongst you till only this remained out of it. And from this Allah's Apostle used to spend the yearly maintenance for his family, and whatever used to remain, he used to spend it where Allah's Property is spent (i.e. in charity), Allah's Apostle kept on acting like that during all his life, Then he died, and Abu Bakr said, 'I am the successor of Allah's Apostle.' So he (i.e. Abu Bakr) took charge of this property and disposed of it in the same manner as Allah's Apostle used to do, and all of you (at that time) knew all about it." Then 'Umar turned towards 'Ali and 'Abbas and said, "You both remember that Abu Bakr disposed of it in the way you have described and Allah knows that, in that matter, he was sincere, pious, rightly guided and the follower of the right. Then Allah caused Abu Bakr to die and I said, 'I am the successor of Allah's Apostle and Abu Bakr.' So I kept this property in my possession for the first two years of my rule (i.e. Caliphate and I used to dispose of it in the same wa as Allah's Apostle and Abu Bakr used to do; and Allah knows that I have been sincere, pious, rightly guided an the follower of the right (in this matte Later on both of you (i.e. 'Ali and Abbas) came to me, and the claim of you both was one and the same, O 'Abbas! You also came to me. So I told you both that Allah's Apostle said, "Our property is not inherited, but whatever we leave is to be given in charity.' Then when I thought that I should better hand over this property to you both or the condition that you will promise and pledge before Allah that you will dispose it off in the same way as Allah's Apostle and Abu Bakr did and as I have done since the beginning of my caliphate or else you should not speak to me (about it).' So, both of you said to me, 'Hand it over to us on this condition.' And on this condition I handed it over to you. Do you want me now to give a decision other than that (decision)? By Allah, with Whose Permission both the sky and the earth stand fast, I will never give any decision other than that (decision) till the Last Hour is established. But if you are unable to manage it (i.e. that property), then return it to me, and I will manage on your behalf." The sub-narrator said, "I told 'Urwa bin Az-Zubair of this Hadith and he said, 'Malik bin Aus has told the truth" I heard 'Aisha, the wife of the Prophet saying, 'The wives of the Prophet sent 'Uthman to Abu Bakr demanding from him their 1/8 of the Fai which Allah had granted to his Apostle. But I used to oppose them and say to them: Will you not fear Allah? Don't you know that the Prophet used to say: Our property is not inherited, but whatever we leave is to be given in charity? The Prophet mentioned that regarding himself. He added: 'The family of Muhammad can take their sustenance from this property. So the wives of the Prophet stopped demanding it when I told them of that.' So, this property (of Sadaqa) was in the hands of Ali who withheld it from 'Abbas and overpowered him. Then it came in the hands of Hasan bin 'Ali, then in the hands of Husain bin 'Ali, and then in the hands of Ali bin Husain and Hasan bin Hasan, and each of the last two used to manage it in turn, then it came in the hands of Zaid bin Hasan, and it was truly the Sadaqa of Allah's Apostle ."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.368]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 368

Narrated 'Aisha:

Fatima and Al'Abbas came to Abu Bakr, claiming their inheritance of the Prophet's land of Fadak and his share from Khaibar. Abu Bakr said, "I heard the Prophet saying, 'Our property is not inherited, and whatever we leave is to be given in charity. But the family of Muhammad can take their sustenance from this property.' By Allah, I would love to do good to the Kith and kin of Allah's Apostle rather than to my own Kith and kin."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.369]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 369

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "Who is willing to kill Ka'b bin Al-Ashraf who has hurt Allah and His Apostle?" Thereupon Muhammad bin Maslama got up saying, "O Allah's Apostle! Would you like that I kill him?" The Prophet said, "Yes," Muhammad bin Maslama said, "Then allow me to say a (false) thing (i.e. to deceive Kab). "The Prophet said, "You may say it." Then Muhammad bin Maslama went to Kab and said, "That man (i.e. Muhammad demands Sadaqa (i.e. Zakat) from us, and he has troubled us, and I have come to borrow something from you." On that, Kab said, "By Allah, you will get tired of him!" Muhammad bin Maslama said, "Now as we have followed him, we do not want to leave him unless and until we see how his end is going to be. Now we want you to lend us a camel load or two of food." (Some difference between narrators about a camel load or two.) Kab said, "Yes, (I will lend you), but you should mortgage something to me." Muhammad bin Mas-lama and his companion said, "What do you want?" Ka'b replied, "Mortgage your women to me." They said, "How can we mortgage our women to you and you are the most handsome of the 'Arabs?" Ka'b said, "Then mortgage your sons to me." They said, "How can we mortgage our sons to you? Later they would be abused by the people's saying that so-and-so has been mortgaged for a camel load of food. That would cause us great disgrace, but we will mortgage our arms to you." Muhammad bin Maslama and his companion promised Kab that Muhammad would return to him. He came to Kab at night along with Kab's foster brother, Abu Na'ila. Kab invited them to come into his fort, and then he went down to them. His wife asked him, "Where are you going at this time?" Kab replied, "None but Muhammad bin Maslama and my (foster) brother Abu Na'ila have come." His wife said, "I hear a voice as if dropping blood is from him, Ka'b said. "They are none but my brother Muhammad bin Maslama and my foster brother Abu Naila. A generous man should respond to a call at night even if invited to be killed." Muhammad bin Maslama went with two men. (Some narrators mention the men as 'Abu bin Jabr. Al Harith bin Aus and Abbad bin Bishr). So Muhammad bin Maslama went in together with two men, and sail to them, "When Ka'b comes, I will touch his hair and smell it, and when you see that I have got hold of his head, strip him. I will let you smell his head." Kab bin Al-Ashraf came down to them wrapped in his clothes, and diffusing perfume. Muhammad bin Maslama said. " have never smelt a better scent than this. Ka'b replied. "I have got the best 'Arab women who know how to use the high class of perfume." Muhammad bin Maslama requested Ka'b "Will you allow me to smell your head?" Ka'b said, "Yes." Muhammad smelt it and made his companions smell it as well. Then he requested Ka'b again, "Will you let me (smell your head)?" Ka'b said, "Yes." When Muhammad got a strong hold of him, he said (to his companions), "Get at him!" So they killed him and went to the Prophet and informed him. (Abu Rafi) was killed after Ka'b bin Al-Ashraf."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.370]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 370

Narrated Al-Bara bin Azib:

Allah's Apostle sent a group of persons to Abu Rafi. Abdullah bin Atik entered his house at night, while he was sleeping, and killed him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.371]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 371

Narrated Al-Bara bin Azib:

Allah's Apostle sent some men from the Ansar to ((kill) Abu Rafi, the Jew, and appointed 'Abdullah bin Atik as their leader. Abu Rafi used to hurt Allah's Apostle and help his enemies against him. He lived in his castle in the land of Hijaz. When those men approached (the castle) after the sun had set and the people had brought back their livestock to their homes. Abdullah (bin Atik) said to his companions, "Sit down at your places. I am going, and I will try to play a trick on the gate-keeper so that I may enter (the castle)." So 'Abdullah proceeded towards the castle, and when he approached the gate, he covered himself with his clothes, pretending to answer the call of nature. The people had gone in, and the gate-keeper (considered 'Abdullah as one of the castle's servants) addressing him saying, "O Allah's Servant! Enter if you wish, for I want to close the gate." 'Abdullah added in his story, "So I went in (the castle) and hid myself. When the people got inside, the gate-keeper closed the gate and hung the keys on a fixed wooden peg. I got up and took the keys and opened the gate. Some people were staying late at night with Abu Rafi for a pleasant night chat in a room of his. When his companions of nightly entertainment went away, I ascended to him, and whenever I opened a door, I closed it from inside. I said to myself, 'Should these people discover my presence, they will not be able to catch me till I have killed him.' So I reached him and found him sleeping in a dark house amidst his family, I could not recognize his location in the house. So I shouted, 'O Abu Rafi!' Abu Rafi said, 'Who is it?' I proceeded towards the source of the voice and hit him with the sword, and because of my perplexity, I could not kill him. He cried loudly, and I came out of the house and waited for a while, and then went to him again and said, 'What is this voice, O Abu Rafi?' He said, 'Woe to your mother! A man in my house has hit me with a sword! I again hit him severely but I did not kill him. Then I drove the point of the sword into his belly (and pressed it through) till it touched his back, and I realized that I have killed him. I then opened the doors one by one till I reached the staircase, and thinking that I had reached the ground, I stepped out and fell down and got my leg broken in a moonlit night. I tied my leg with a turban and proceeded on till I sat at the gate, and said, 'I will not go out tonight till I know that I have killed him.' So, when (early in the morning) the cock crowed, the announcer of the casualty stood on the wall saying, 'I announce the death of Abu Rafi, the merchant of Hijaz. Thereupon I went to my companions and said, 'Let us save ourselves, for Allah has killed Abu Rafi,' So I (along with my companions proceeded and) went to the Prophet and described the whole story to him. "He said, 'Stretch out your (broken) leg. I stretched it out and he rubbed it and it became All right as if I had never had any ailment whatsoever."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.372]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 372

Narrated Al-Bara:

Allah's Apostle sent 'Abdullah bin 'Atik and 'Abdullah bin 'Utba with a group of men to Abu Rafi (to kill him). They proceeded till they approached his castle, whereupon 'Abdullah bin Atik said to them, "Wait (here), and in the meantime I will go and see." 'Abdullah said later on, "I played a trick in order to enter the castle. By chance, they lost a donkey of theirs and came out carrying a flaming light to search for it. I was afraid that they would recognize me, so I covered my head and legs and pretended to answer the call to nature. The gatekeeper called, 'Whoever wants to come in, should come in before I close the gate.' So I went in and hid myself in a stall of a donkey near the gate of the castle. They took their supper with Abu Rafi and had a chat till late at night. Then they went back to their homes. When the voices vanished and I no longer detected any movement, I came out. I had seen where the gate-keeper had kept the key of the castle in a hole in the wall. I took it and unlocked the gate of the castle, saying to myself, 'If these people should notice me, I will run away easily.' Then I locked all the doors of their houses from outside while they were inside, and ascended to Abu Rafi by a staircase. I saw the house in complete darkness with its light off, and I could not know where the man was. So I called, 'O Abu Rafi!' He replied, 'Who is it?' I proceeded towards the voice and hit him. He cried loudly but my blow was futile. Then I came to him, pretending to help him, saying with a different tone of my voice, ' What is wrong with you, O Abu Rafi?' He said, 'Are you not surprised? Woe on your mother! A man has come to me and hit me with a sword!' So again I aimed at him and hit him, but the blow proved futile again, and on that Abu Rafi cried loudly and his wife got up. I came again and changed my voice as if I were a helper, and found Abu Rafi lying straight on his back, so I drove the sword into his belly and bent on it till I heard the sound of a bone break. Then I came out, filled with astonishment and went to the staircase to descend, but I fell down from it and got my leg dislocated. I bandaged it and went to my companions limping. I said (to them), 'Go and tell Allah's Apostle of this good news, but I will not leave (this place) till I hear the news of his (i.e. Abu Rafi's) death.' When dawn broke, an announcer of death got over the wall and announced, 'I convey to you the news of Abu Rafi's death.' I got up and proceeded without feeling any pain till I caught up with my companions before they reached the Prophet to whom I conveyed the good news."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.373]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 373

Narrated Ibn Abbas:

On the day of Uhud. the Prophet said, "This is Gabriel holding the head of his horse and equipped with war material.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.374]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 374

Narrated Uqba bin Amir:

Allah's Apostle offered the funeral prayers of the martyrs of Uhud eight years after (their death), as if bidding farewell to the living and the dead, then he ascended the pulpit and said, "I am your predecessor before you, and I am a witness on you, and your promised place to meet me will be Al-Haud (i.e. the Tank) (on the Day of Resurrection), and I am (now) looking at it from this place of mine. I am not afraid that you will worship others besides Allah, but I am afraid that worldly life will tempt you and cause you to compete with each other for it." That was the last look which I cast on Allah's Apostle.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.375]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 375

Narrated Al-Bara:

We faced the pagans on that day (of the battle of Uhud) and the Prophet placed a batch of archers (at a special place) and appointed 'Abdullah (bin Jubair) as their commander and said, "Do not leave this place; and if you should see us conquering the enemy, do not leave this place, and if you should see them conquering us, do not (come to) help us," So, when we faced the enemy, they took to their heel till I saw their women running towards the mountain, lifting up their clothes from their legs, revealing their leg-bangles. The Muslims started saying, "The booty, the booty!" 'Abdullah bin Jubair said, "The Prophet had taken a firm promise from me not to leave this place." But his companions refused (to stay). So when they refused (to stay there), (Allah) confused them so that they could not know where to go, and they suffered seventy casualties. Abu Sufyan ascended a high place and said, "Is Muhammad present amongst the people?" The Prophet said, "Do not answer him." Abu Sufyan said, "Is the son of Abu Quhafa present among the people?" The Prophet said, "Do not answer him." Abd Sufyan said, "Is the son of Al-Khattab amongst the people?" He then added, "All these people have been killed, for, were they alive, they would have replied." On that, 'Umar could not help saying, "You are a liar, O enemy of Allah! Allah has kept what will make you unhappy." Abu Safyan said, "Superior may be Hubal!" On that the Prophet said (to his companions), "Reply to him." They asked, "What may we say?" He said, "Say: Allah is More Elevated and More Majestic!" Abu Sufyan said, "We have (the idol) Al-'Uzza, whereas you have no 'Uzza!" The Prophet said (to his companions), "Reply to him." They said, "What may we say?" The Prophet said, "Say: Allah is our Helper and you have no helper." Abu Sufyan said, "(This) day compensates for our loss at Badr and (in) the battle (the victory) is always undecided and shared in turns by the belligerents. You will see some of your dead men mutilated, but neither did I urge this action, nor am I sorry for it." Narrated Jabir: Some people took wine in the morning of the day of Uhud and were then killed as martyrs.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.376]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 376

Narrated Sad bin Ibrahim:

A meal was brought to 'Abdur-Rahman bin 'Auf while he was fasting. He said, "Musab bin 'Umar was martyred, and he was better than I, yet he was shrouded in a Burda (i.e. a sheet) so that, if his head was covered, his feet became naked, and if his feet were covered, his head became naked." 'Abdur-Rahman added, "Hamza was martyred and he was better than 1. Then worldly wealth was bestowed upon us and we were given thereof too much. We are afraid that the reward of our deeds have been given to us in this life." 'Abdur-Rahman then started weeping so much that he left the food.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.377]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 377

Narrated Jabir bin 'Abdullah:

On the day of the battle of Uhud, a man came to the Prophet and said, "Can you tell me where I will be if I should get martyred?" The Prophet replied, "In Paradise." The man threw away some dates he was carrying in his hand, and fought till he was martyred .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.378]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 378

Narrated Khabbab bin Al-Art:

We migrated in the company of Allah's Apostle, seeking Allah's Pleasure. So our reward became due and sure with Allah. Some of us have been dead without enjoying anything of their rewards (here), and one of them was Mus'ab bin 'Umar who was martyred on the day of the battle of Uhud, and did not leave anything except a Namira (i.e. a sheet in which he was shrouded). If we covered his head with it, his feet became naked, and if we covered his feet with it, his head became naked. So the Prophet said to us, "Cover his head with it and put some Idhkhir (i.e. a kind of grass) over his feet or throw Idhkhir over his feet." But some amongst us have got the fruits of their labor ripened, and they are collecting them.

Narrated Anas: His uncle (Anas bin An-Nadr) was absent from the battle of Badr and he said, "I was absent from the first battle of the Prophet (i.e. Badr battle), and if Allah should let me participate in (a battle) with the Prophet, Allah will see how strongly I will fight." So he encountered the day of Uhud battle. The Muslims fled and he said, "O Allah ! I appeal to You to excuse me for what these people (i.e. the Muslims) have done, and I am clear from what the pagans have done." Then he went forward with his sword and met Sad bin Mu'adh (fleeing), and asked him, "Where are you going, O Sad? I detect a smell of Paradise before Uhud." Then he proceeded on and was martyred. No-body was able to recognize him till his sister recognized him by a mole on his body or by the tips of his fingers. He had over 80 wounds caused by stabbing, striking or shooting with arrows.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.379]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 379

Narrated Zaid bin Thabit:

When we wrote the Holy Quran, I missed one of the Verses of Surat-al-Ahzab which I used to hear Allah's Apostle reciting. Then we searched for it and found it with Khuzaima bin Thabit Al-Ansari. The Verse was:--

'Among the Believers are men Who have been true to Their Covenant with Allah, Of them, some have fulfilled Their obligations to Allah (i.e. they have been Killed in Allah's Cause), And some of them are (still) waiting" (33.23) So we wrote this in its place in the Quran.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.380]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 380

Narrated Zaid bin Thabit:

When the Prophet set out for (the battle of) Uhud, some of those who had gone out with him, returned. The companions of the Prophet were divided into two groups. One group said, "We will fight them (i.e. the enemy)," and the other group said, "We will not fight them." So there came the Divine Revelation:-- '(O Muslims!) Then what is the matter within you that you are divided. Into two parties about the hypocrites? Allah has cast them back (to disbelief) Because of what they have earned.' (4.88) On that, the Prophet said, "That is Taiba (i.e. the city of Medina) which clears one from one's sins as the fire expels the impurities of silver."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.381]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 381

Narrated Jabir:

This Verse: "When two of your parties almost Decided to fall away..." was revealed in our connection, i.e. Bani Salama and Bani Haritha and I would not have liked that, if it was not revealed, for Allah said:-- But Allah was their Protector.....(3.122)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.382]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 382

Narrated Jabir:

"Allah's Apostle said to me, "Have you got married O Jabir?" I replied, "Yes." He asked "What, a virgin or a matron?" I replied, "Not a virgin but a matron." He said, "Why did you not marry a young girl who would have fondled with you?" I replied, "O Allah's Apostle! My father was martyred on the day of Uhud and left nine (orphan) daughters who are my nine sisters; so I disliked to have another young girl of their age, but (I sought) an (elderly) woman who could comb their hair and look after them." The Prophet said, "You have done the right thing."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.383]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 383

Narrated Jabir bin Abdullah:

That his father was martyred on the day of the battle of Uhud and was in debt and left six (orphan) daughters. Jabir, added, "When the season of plucking the dates came, I went to Allah's Apostle and said, "You know that my father was martyred on the day of Uhud, and he was heavily in debt, and I would like that the creditors should see you." The Prophet said, "Go and pile every kind of dates apart." I did so and called him (i.e. the Prophet ). When the creditors saw him, they started claiming their debts from me then in such a harsh manner (as they had never done before). So when he saw their attitude, he went round the biggest heap of dates thrice, and then sat over it and said, 'O Jabir), call your companions (i.e. the creditors).' Then he kept on measuring (and giving) to the creditors (their due) till Allah paid all the debt of my father. I would have been satisfied to retain nothing of those dates for my sisters after Allah had paid the debts of my father. But Allah saved all the heaps (of dates), so that when I looked at the heap where the Prophet had been sitting, it seemed as if a single date had not been taken away thereof."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.384]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 384

Narrated Sad bin Abi Waqqas:

I saw Allah's Apostle on the day of the battle of Uhud accompanied by two men fighting on his behalf. They were dressed in white and were fighting as bravely as possible. I had never seen them before, nor did I see them later on.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.385]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 385

Narrated Sad bin Abi Waqqas:

The Prophet took out a quiver (of arrows) for me on the day of Uhud and said, "Throw (arrows); let my father and mother be sacrificed for you."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.386]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 386

Narrated Sad:

Allah's Apostle mentioned both his father and mother for me on the day of the battle of Uhud.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.387]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 387

Narrated Ibn Al Musaiyab:

Sad bin Abi Waqqas said, "Allah's Apostle mentioned both his father and mother for me on the day of the battle of Uhud." He meant when the Prophet said (to Sad) while the latter was fighting. "Let my father and mother be sacrificed for you!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.388]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 388

Narrated 'Ali: I have never heard the Prophet mentioning both his father and mother for anybody other than Sad.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.389]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 389

Narrated 'Ali: I have never heard the Prophet mentioning his father and mother for anybody other than Sad bin Malik. I heard him saying on the day of Uhud, "O Sad throw (arrows)! Let my father and mother be sacrificed for you !"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.390]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 390

Narrated Mu'tamir's father:

'Uthman said that on the day of the battle of Uhud, none remained with the Prophet but Talha and Sad.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.391]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 391

Narrated As-Saib bin Yazid:

I have been in the company of 'AbdurRahman bin 'Auf, Talha bin 'Ubaidullah, Al-Miqdad and Sad, and I heard none of them narrating anything from the Prophet excepting the fact that I heard Talha narrating about the day of Uhud (battle) .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.392]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 392

Narrated Qais:

I saw Talha's paralyzed hand with which he had protected the Prophet on the day of Uhud.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.393]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 393

Narrated Anas:

When it was the day of Uhud, the people left the Prophet while Abu Talha was in front of the Prophet shielding him with his leather shield. Abu Talha was a skillful archer who used to shoot violently. He broke two or three arrow bows on that day. If a man carrying a quiver full of arrows passed by, the Prophet would say (to him), put (scatter) its contents for Abu Talha." The Prophet would raise his head to look at the enemy, whereupon Abu Talha would say, "Let my father and mother be sacrificed for you ! Do not raise your head, lest an arrow of the enemy should hit you. (Let) my neck (be struck) rather than your neck." I saw 'Aisha, the daughter of Abu Bakr, and Um Sulaim rolling up their dresses so that I saw their leg-bangles while they were carrying water skins on their backs and emptying them in the mouths of the (wounded) people. They would return to refill them and again empty them in the mouths of the (wounded) people. The sword fell from Abu Talha's hand twice or thrice (on that day).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.394]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 394

Narrated 'Aisha:

When it was the day of Uhud, the pagans were defeated. Then Satan, Allah's Curse be upon him, cried loudly, "O Allah's Worshippers, beware of what is behind!" On that, the front files of the (Muslim) forces turned their backs and started fighting with the back files. Hudhaifa looked, and on seeing his father Al-Yaman, he shouted, "O Allah's Worshippers, my father, my father!" But by Allah, they did not stop till they killed him. Hudhaifa said, "May Allah forgive you." (The sub-narrator, 'Urwa, said, "By Allah, Hudhaifa continued asking Allah's Forgiveness for the killers of his father till he departed to Allah (i.e. died).")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.395]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 395

Narrated 'Uthman bin Mauhab:

A man came to perform the Hajj to (Allah's) House. Seeing some people sitting, he said, "Who are these sitting people?" Somebody said, "They are the people of Quraish." He said, "Who is the old man?" They said, "Ibn 'Umar." He went to him and said, "I want to ask you about something; will you tell me about it? I ask you with the respect due to the sanctity of this (Sacred) House, do you know that 'Uthman bin 'Affan fled on the day of Uhud?" Ibn 'Umar said, "Yes." He said, "Do you know that he (i.e. 'Uthman) was absent from the Badr (battle) and did not join it?" Ibn 'Umar said, "Yes." He said, "Do you know that he failed to be present at the Ridwan Pledge of allegiance (i.e. Pledge of allegiance at Hudaibiya) and did not witness it?" Ibn 'Umar replied, "Yes," He then said, "Allahu-Akbar!" Ibn 'Umar said, "Come along; I will inform you and explain to you what you have asked. As for the flight (of 'Uthman) on the day of Uhud, I testify that Allah forgave him. As regards his absence from the Badr (battle), he was married to the daughter of Allah's Apostle and she was ill, so the Prophet said to him, 'You will have such reward as a man who has fought the Badr battle will get, and will also have the same share of the booty.' As for his absence from the Ridwan Pledge of allegiance if there had been anybody more respected by the Meccans than 'Uthman bin 'Affan, the Prophet would surely have sent that man instead of 'Uthman. So the Prophet sent him (i.e. 'Uthman to Mecca) and the Ridwan Pledge of allegiance took place after 'Uthman had gone to Mecca. The Prophet raised his right hand saying. 'This is the hand of 'Uthman,' and clapped it over his other hand and said, "This is for 'Uthman.'" Ibn 'Umar then said (to the man), "Go now, after taking this information."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.396]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 396

Narrated Al-Bara' bin 'Azib:

The Prophet appointed Abdullah bin Jubair as the commander of the cavalry archers on the day of the battle of Uhud. Then they returned defeated, and that what is referred to by Allah's Statement:-- "And the Apostle (Muhammad) in your rear was calling you." (3.153)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.397]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 397

Narrated Salim's father:

That he heard Allah's Apostle, when raising his head from bowing of the first Rak'a of the morning prayer, saying, "O Allah! Curse so-and-so and so-and-so" after he had said, "Allah hears him who sends his praises to Him. Our Lord, all the Praises are for you!" So Allah revealed:-- "Not for you (O Muhammad! )......(till the end of Verse) they are indeed wrong-doers." (3.128) Salim bin 'Abdullah said' "Allah's Apostle used to invoke evil upon Safwan bin Umaiya, Suhail bin 'Amr and Al-Harith bin Hisham. So the Verse was revealed:-- "Not for you (O Muhammad!)......(till the end of Verse) For they are indeed wrong-doers." (3.128)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.398]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 398

Narrated Tha'laba bin Abi Malik:

'Umar bin Al-Khattab distributed woolen clothes amongst some women of Medina, and a nice woolen garment remained. Some of those who were sitting with him, said, "O chief of the believers! Give it to the daughter of Allah's Apostle who is with you," and by that, they meant Um Kulthum, the daughter of 'Ali. Umar said, "Um Salit has got more right than she." Um Saht was amongst those Ansari women who had given the pledge of allegiance to Allah's Apostle . 'Umar added, "She (i.e. Um Salit) used to carry the filled water skins for us on the day of the battle of Uhud."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.399]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 399

Narrated Jafar bin 'Amr bin Umaiya:

I went out with 'Ubaidullah bin 'Adi Al-Khaiyar. When we reached Hims (i.e. a town in Syria), 'Ubaidullah bin 'Adi said (to me), "Would you like to see Wahshi so that we may ask him about the killing of Hamza?" I replied, "Yes." Wahshi used to live in Hims. We enquired about him and somebody said to us, "He is that in the shade of his palace, as if he were a full water skin." So we went up to him, and when we were at a short distance from him, we greeted him and he greeted us in return. 'Ubaidullah was wearing his turban and Wahshi could not see except his eyes and feet. 'Ubaidullah said, "O Wahshi! Do you know me?" Wahshi looked at him and then said, "No, by Allah! But I know that 'Adi bin Al-Khiyar married a woman called Um Qital, the daughter of Abu Al-Is, and she delivered a boy for him at Mecca, and I looked for a wet nurse for that child. (Once) I carried that child along with his mother and then I handed him over to her, and your feet resemble that child's feet." Then 'Ubaidullah uncovered his face and said (to Wahshi), "Will you tell us (the story of) the killing of Hamza?" Wahshi replied "Yes, Hamza killed Tuaima bin 'Adi bin Al-Khaiyar at Badr (battle) so my master, Jubair bin Mut'im said to me, 'If you kill Hamza in revenge for my uncle, then you will be set free." When the people set out (for the battle of Uhud) in the year of 'Ainain ..'Ainain is a mountain near the mountain of Uhud, and between it and Uhud there is a valley.. I went out with the people for the battle. When the army aligned for the fight, Siba' came out and said, 'Is there any (Muslim) to accept my challenge to a duel?' Hamza bin 'Abdul Muttalib came out and said, 'O Siba'. O Ibn Um Anmar, the one who circumcises other ladies! Do you challenge Allah and His Apostle?' Then Hamza attacked and killed him, causing him to be non-extant like the bygone yesterday. I hid myself under a rock, and when he (i.e. Hamza) came near me, I threw my spear at him, driving it into his umbilicus so that it came out through his buttocks, causing him to die. When all the people returned to Mecca, I too returned with them. I stayed in (Mecca) till Islam spread in it (i.e. Mecca). Then I left for Taif, and when the people (of Taif) sent their messengers to Allah's Apostle, I was told that the Prophet did not harm the messengers; So I too went out with them till I reached Allah's Apostle. When he saw me, he said, 'Are you Wahshi?' I said, 'Yes.' He said, 'Was it you who killed Hamza?' I replied, 'What happened is what you have been told of.' He said, 'Can you hide your face from me?' So I went out when Allah's Apostle died, and Musailamah Al-Kadhdhab appeared (claiming to be a prophet). I said, 'I will go out to Musailamah so that I may kill him, and make amends for killing Hamza. So I went out with the people (to fight Musailamah and his followers) and then famous events took place concerning that battle. Suddenly I saw a man (i.e. Musailamah) standing near a gap in a wall. He looked like an ash-colored camel and his hair was dishevelled. So I threw my spear at him, driving it into his chest in between his breasts till it passed out through his shoulders, and then an Ansari man attacked him and struck him on the head with a sword. 'Abdullah bin 'Umar said, 'A slave girl on the roof of a house said: Alas! The chief of the believers (i.e. Musailamah) has been killed by a black slave."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.400]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 400

Narrated Abu Huraira:

Allah's Apostle (pointing to his broken canine tooth) said, "Allah's Wrath has become severe on the people who harmed His Prophet. Allah's Wrath has become severe on the man who is killed by the Apostle of Allah in Allah's Cause."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.401]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 401

Narrated Ibn 'Abbas

Allah's Wrath became severe on him whom the Prophet had killed in Allah's Cause. Allah's Wrath became severe on the people who caused the face of Allah's Prophet to bleed.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.402]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 402

Narrated Abu Hazim:

That he heard Sahl bin Sad being asked about the wounds of Allah's Apostle saying, "By Allah, I know who washed the wounds of Allah's Apostle and who poured water (for washing them), and with what he was treated." Sahl added, "Fatima, the daughter of Allah's Apostle used to wash the wounds, and 'Ali bin Abi Talib used to pour water from a shield. When Fatima saw that the water aggravated the bleeding, she took a piece of a mat, burnt it, and inserted its ashes into the wound so that the blood was congealed (and bleeding stopped). His canine tooth got broken on that day, and face was wounded, and his helmet was broken on his head."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.403]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 403

Narrated Ibn Abbas:

Allah's Wrath gets severe on a person killed by a prophet, and Allah's Wrath became severe on him who had caused the face of Allah's Apostle to bleed


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.404]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 404

Narrated 'Aisha:

Regarding the Holy Verse: "Those who responded (To the call) of Allah And the Apostle (Muhammad), After being wounded, For those of them Who did good deeds And refrained from wrong, there is a great reward." (3.172)

She said to 'Urwa, "O my nephew! Your father, Az-Zubair and Abu Bakr were amongst them (i.e. those who responded to the call of Allah and the Apostle on the day (of the battle of Uhud). When Allah's Apostle, suffered what he suffered on the day of Uhud and the pagans left, the Prophet was afraid that they might return. So he said, 'Who will go on their (i.e. pagans') track?' He then selected seventy men from amongst them (for this purpose)." (The sub-narrator added, "Abu Bakr and Az-Zubair were amongst them.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.405]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 405

Narrated Qatada:

We do not know of any tribe amongst the 'Arab tribes who lost more martyrs than Al-Ansar, and they will have superiority on the Day of Resurrection. Anas bin Malik told us that seventy from the Ansar were martyred on the day of Uhud, and seventy on the day (of the battle of) Bir Ma'una, and seventy on the day of Al-Yamama. Anas added, "The battle of Bir Ma'una took place during the lifetime of Allah's Apostle and the battle of Al-Yamama, during the caliphate of Abu Bakr, and it was the day when Musailamah Al-Kadhdhab was killed."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.406]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 406

Narrated Jabir bin 'Abdullah

Allah's Apostle used to shroud two martyrs of Uhud in one sheet and then say, "Which of them knew Quran more?" When one of the two was pointed out, he would put him first in the grave. Then he said, "I will be a witness for them on the Day of Resurrection." He ordered them to be buried with their blood (on their bodies). Neither was the funeral prayer offered for them, nor were they washed. Jabir added, "When my father was martyred, I started weeping and uncovering his face. The companions of the Prophet stopped me from doing so but the Prophet did not stop me. Then the Prophet said, '(O Jabir.) don't weep over him, for the angels kept on covering him with their wings till his body was carried away (for burial)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.407]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 407

Narrated Abu Musa:

The Prophet said, "I saw in a dream that I moved a sword and its blade got broken, and that symbolized the casualties which the believers suffered on the day of Uhud. Then I moved it again, and it became as perfect as it had been, and that symbolized the Conquest (of Mecca) which Allah helped us to achieve, and the union of all the believers. I (also) saw cows in the dream, and what Allah does is always beneficial. Those cows appeared to symbolize the faithful believers (who were martyred) on the day of Uhud."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.408]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 408

Narrated Khabbab:

We migrated with the Prophet for Allah's Cause, so our reward became due with Allah. Some of us passed away (i.e. died) without enjoying anything from their reward, and one of them was Mus'ab bin 'Umar who was killed (i.e. martyred) on the day of Uhud. He did not leave behind except a sheet of striped woolen cloth. If we covered his head with it, his feet became naked, and if we covered his feet with it, his head became naked. The Prophet said to us, "Cover his head with it and put Idhkhir (i.e. a kind of grass) over his feet," or said, "Put some Idhkhir over his feet." But some of us have got their fruits ripened, and they are collecting them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.409]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 409

Narrated Anas:

The Prophet said, "This is a mountain that loves us and is loved by us."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.410]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 410

Narrated Anas bin Malik:

When the mountain of Uhud appeared before Allah's Apostle he said, "This IS a mountain that loves us and is loved by us. O, Allah! Abraham made Mecca a Sanctuary, and I have made Medina (i.e. the area between its two mountains) a Sanctuary as well."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.411]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 411

Narrated Uqba:

One day the Prophet went out and offered the (funeral) prayer for the people (i.e. martyrs) of Uhud as he used to offer a funeral prayer for any dead person, and then (after returning) he ascended the pulpit and said, "I am your predecessor before you, and I am a witness upon you, and I am looking at my Tank just now, and I have been given the keys of the treasures of the world (or the keys of the world). By Allah, I am not afraid that you will worship others besides Allah after me, but I am afraid that you will compete with each other for (the pleasures of) this world."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.412]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 412

Narrated Abu Huraira:

The Prophet sent a Sariya of spies and appointed 'Asim bin Thabit, the grandfather of 'Asim bin 'Umar bin Al-Khattab, as their leader. So they set out, and when they reached (a place) between 'Usfan and Mecca, they were mentioned to one of the branch tribes of Bani Hudhail called Lihyan. So, about one-hundred archers followed their traces till they (i.e. the archers) came to a journey station where they (i.e. 'Asim and his companions) had encamped and found stones of dates they had brought as journey food from Medina.

The archers said, "These are the dates of Medina," and followed their traces till they took them over. When 'Asim and his companions were not able to go ahead, they went up a high place, and their pursuers encircled them and said, "You have a covenant and a promise that if you come down to us, we will not kill anyone of you." 'Asim said, "As for me, I will never come down on the security of an infidel. O Allah! Inform Your Prophet about us." So they fought with them till they killed 'Asim along with seven of his companions with arrows, and there remained Khubaib, Zaid and another man to whom they gave a promise and a covenant. So when the infidels gave them the covenant and promise, they came down. When they captured them, they opened the strings of their arrow bows and tied them with it. The third man who was with them said, "This is the first breach in the covenant," and refused to accompany them. They dragged him and tried to make him accompany them, but he refused, and they killed him. Then they proceeded on taking Khubaib and Zaid till they sold them in Mecca. The sons of Al-Harith bin 'Amr bin Naufal bought Khubaib. It was Khubaib who had killed Al-Harith bin 'Amr on the day of Badr. Khubaib stayed with them for a while as a captive till they decided unanimously to kill him. (At that time) Khubaib borrowed a razor from one of the daughters of Al-Harith to shave his pubic hair. She gave it to him. She said later on, "I was heedless of a little baby of mine, who moved towards Khubaib, and when it reached him, he put it on his thigh.

When I saw it, I got scared so much that Khubaib noticed my distress while he was carrying the razor in his hand. He said 'Are you afraid that I will kill it? Allah willing, I will never do that,' " Later on she used to say, "I have never seen a captive better than Khubaib Once I saw him eating from a bunch of grapes although at that time no fruits were available at Mecca, and he was fettered with iron chains, and in fact, it was nothing but food bestowed upon him by Allah." So they took him out of the Sanctuary (of Mecca) to kill him. He said, "Allow me to offer a two-Rak'at prayer." Then he went to them and said, "Had I not been afraid that you would think I was afraid of death, I would have prayed for a longer time." So it was Khubaib who first set the tradition of praying two Rakat before being executed. He then said, "O Allah! Count them one by one," and added, 'When I am being martyred as a Muslim, I do not care in what way I receive my death for Allah's Sake, because this death is in Allah's Cause. If He wishes, He will bless the cut limbs." Then 'Uqba bin Al-Harith got up and martyred him. The narrator added: The Quraish (infidels) sent some people to 'Asim in order to bring a part of his body so that his death might be known for certain, for 'Asim had killed one of their chiefs on the day of Badr. But Allah sent a cloud of wasps which protected his body from their messengers who could not harm his body consequently.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.413]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 413

Narrated Jabir:

The person who killed Khubaib was Abu Sarua (i.e. 'Uqba bin Al-Harith).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.414]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 414

Narrated 'Abdul Aziz:

Anas said, "The Prophet sent seventy men, called Al-Qurra 'for some purpose. The two groups of Bani Sulaim called Ri'l and Dhakwan, appeared to them near a well called Bir Ma'una. The people (i.e. Al-Qurra) said, 'By Allah, we have not come to harm you, but we are passing by you on our way to do something for the Prophet.' But (the infidels) killed them. The Prophet therefore invoked evil upon them for a month during the morning prayer. That was the beginning of Al Qunut and we used not to say Qunut before that." A man asked Anas about Al-Qunut, "Is it to be said after the Bowing (in the prayer) or after finishing the Recitation (i.e. before Bowing)?" Anas replied, "No, but (it is to be said) after finishing the Recitation."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.415]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 415

Narrated Anas:

Allah's Apostle said Al-Qunut for one month after the posture of Bowing, invoking evil upon some 'Arab tribes.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.416]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 416

Narrated Anas bin Malik:

(The tribes of) Ril, Dhakwan, 'Usaiya and Bani Lihyan asked Allah's Apostle to provide them with some men to support them against their enemy. He therefore provided them with seventy men from the Ansar whom we used to call Al-Qurra' in their lifetime. They used to collect wood by daytime and pray at night. When they were at the well of Ma'una, the infidels killed them by betraying them. When this news reached the Prophet , he said Al-Qunut for one month In the morning prayer, invoking evil upon some of the 'Arab tribes, upon Ril, Dhakwan, 'Usaiya and Bani Libyan. We used to read a verse of the Qur'an revealed in their connection, but later the verse was cancelled. It was: "convey to our people on our behalf the information that we have met our Lord, and He is pleased with us, and has made us pleased." (Anas bin Malik added:) Allah's Prophet said Qunut for one month in the morning prayer, invoking evil upon some of the 'Arab tribes (namely), Ril, Dhakwan, Usaiya, and Bani Libyan. (Anas added:) Those seventy Ansari men were killed at the well of Mauna.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.417]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 417

Narrated Anas:

That the Prophet sent his uncle, the brother of Um Sulaim at the head of seventy riders. The chief of the pagans, 'Amir bin At-Tufail proposed three suggestions (to the Prophet ) saying, "Choose one of three alternatives: (1) that the bedouins will be under your command and the townspeople will be under my command; (2) or that I will be your successor, (3) or otherwise I will attack you with two thousand from Bani Ghatafan." But 'Amir was infected with plague in the House of Um so-and-so. He said, "Shall I stay in the house of a lady from the family of so-and-so after having a (swelled) gland like that she-camel? Get me my horse." So he died on the back of his horse. Then Haram, the brother of Um Sulaim and a lame man along with another man from so-and-so (tribe) went towards the pagans (i.e. the tribe of 'Amir). Haram said (to his companions), "Stay near to me, for I will go to them. If they (i.e. infidels) should give me protection, you will be near to me, and if they should kill me, then you should go back to your companions. Then Haram went to them and said, "Will you give me protection so as to convey the message of Allah's Apostle ?" So, he started talking to them' but they signalled to a man (to kill him) and he went behind him and stabbed him (with a spear). He (i.e. Haram) said, "Allahu Akbar! I have succeeded, by the Lord of the Ka'ba!" The companion of Haram was pursued by the infidels, and then they (i.e. Haram's companions) were all killed except the lame man who was at the top of a mountain. Then Allah revealed to us a verse that was among the cancelled ones later on. It was: 'We have met our Lord and He is pleased with us and has made us pleased.' (After this event) the Prophet invoked evil on the infidels every morning for 30 days. He invoked evil upon the (tribes of) Ril, Dhakwan, Bani Lihyan and Usaiya who disobeyed Allah and His Apostle


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.418]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 418

Narrated Anas bin Malik:

That when Haram bin Milhan, his uncle was stabbed on the day of Bir Ma'una he sprinkled his blood over his face and his head this way and then said, "I have succeeded, by the Lord of the Ka'ba.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.419]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 419

Narrated 'Aisha:

Abu Bakr asked the Prophet to allow him to go out (of Mecca) when he was greatly annoyed (by the infidels). But the Prophet said to him, ''Wait." Abu Bakr said, O Allah's Apostle! Do you hope that you will be allowed (to migrate)?" Allah's Apostle replied, "I hope so." So Abu Bakr waited for him till one day Allah's Apostle came at noon time and addressed him saying "Let whoever is present with you, now leave you." Abu Bakr said, "None is present but my two daughters." The Prophet said, "Have you noticed that I have been allowed to go out (to migrate)?" Abu Bakr said, "O Allah's Apostle, I would like to accompany you." The Prophet said, "You will accompany me." Abu Bakr said, "O Allah's Apostle! I have got two she-camels which I had prepared and kept ready for (our) going out." So he gave one of the two (she-camels) to the Prophet and it was Al-Jad'a . They both rode and proceeded till they reached the Cave at the mountain of Thaur where they hid themselves. Amir bin Fuhaira was the slave of 'Abdullah bin Al-Tufail bin Sakhbara 'Aisha's brother from her mother's side. Abu Bakr had a milch she-camel. Amir used to go with it (i.e. the milch she-camel) in the afternoon and come back to them before noon by setting out towards them in the early morning when it was still dark and then he would take it to the pasture so that none of the shepherds would be aware of his job. When the Prophet (and Abu Bakr) went away (from the Cave), he (i.e. 'Amir) too went along with them and they both used to make him ride at the back of their camels in turns till they reached Medina. 'Amir bin Fuhaira was martyred on the day of Bir Ma'una.

Narrated 'Urwa: When those (Muslims) at Bir Ma'una were martyred and 'Amr bin Umaiya Ad-Damri was taken prisoner, 'Amir bin At-Tufail, pointing at a killed person, asked Amr, "Who is this?" 'Amr bin Umaiya said to him, "He is 'Amir bin Fuhaira." 'Amir bin At-Tufail said, "I saw him lifted to the sky after he was killed till I saw the sky between him and the earth, and then he was brought down upon the earth. Then the news of the killed Muslims reached the Prophet and he announced the news of their death saying, "Your companions (of Bir Ma'una) have been killed, and they have asked their Lord saying, 'O our Lord! Inform our brothers about us as we are pleased with You and You are pleased with us." So Allah informed them (i.e. the Prophet and his companions) about them (i.e. martyrs of Bir Mauna).

On that day, 'Urwa bin Asma bin As-Salt who was one of them, was killed, and Urwa (bin Az-Zubair) was named after 'Urwa bin Asma and Mundhir (bin AzZubair) was named after Mundhir bin 'Amr (who had also been martyred on that day).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.420]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 420

Narrated Anas:

The Prophet said Al-Qunut after Bowing (i.e. Ar-Ruku') for one month, invoking evil upon (the tribes of) Ril and Dhakwan. He used to say, "Usaiya disobeyed Allah and His Apostle."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.421]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 421

Narrated Anas bin Malik :

The Prophet invoked evil upon those (people) who killed his companions at Bir Mauna for 30 days (in the morning prayer). He invoked evil upon (tribes of) Ril, Lihyan and Usaiya who disobeyed Allah and His Apostle. Allah revealed a Quranic Verse to His Prophet regarding those who had been killed, i.e. the Muslims killed at Bir Ma'una, and we recited the Verse till later it was cancelled. (The Verse was:) 'Inform our people that we have met our Lord, and He is pleased with us, and we are pleased with Him."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.422]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 422

Narrated Asim Al-Ahwal:

I asked Anas bin Malik regarding Al-Qunut during the prayer. Anas replied, "Yes (Al-Qunut was said by the Prophet in the prayer)." I said, "Is it before Bowing or after Bowing?" Anas replied, "(It was said) before (Bowing)." I said, "So-and-so informed me that you told him that it was said after Bowing." Anas replied, "He was mistaken, for Allah's Apostle said Al-Qunut after Bowing for one month. The Prophet had sent some people called Al-Qurra who were seventy in number, to some pagan people who had concluded a peace treaty with Allah's Apostle . But those who had concluded the treaty with Allah's Apostle violated the treaty (and martyred all the seventy men). So Allah's Apostle said Al-Qunut after Bowing (in the prayer) for one month, invoking evil upon them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.423]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 423

Narrated Ibn Umar:

That the Prophet inspected him on the day of Uhud while he was fourteen years old, and the Prophet did not allow him to take part in the battle. He was inspected again by the Prophet on the day of Al-Khandaq (i.e. battle of the Trench) while he was fifteen years old, and the Prophet allowed him to take Part in the battle.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.424]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 424

Narrated Sahl bin Sad:

We were with Allah's Apostle in the Trench, and some were digging the trench while we were carrying the earth on our shoulders. Allah's Apostle said, 'O Allah! There is no life except the life of the Hereafter, so please forgive the Emigrants and the Ansar."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.425]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 425

Narrated Anas:

Allah's Apostle went out towards the Khandaq (i.e. Trench) and saw the Emigrants and the Ansar digging the trench in the cold morning. They had no slaves to do that (work) for them. When the Prophet saw their hardship and hunger, he said, 'O Allah! The real life is the life of the Hereafter, so please forgive Ansar and the Emigrants." They said in reply to him, "We are those who have given the Pledge of allegiances to Muhammad for to observe Jihad as long as we live."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.426]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 426

Narrated Anas:

Al-Muhajirun (i.e. the Emigrants) and the Ansar were digging the trench around Medina and were carrying the earth on their backs while saying, "We are those who have given the pledge of allegiance to Muhammad for Islam as long as we live." The Prophet said in reply to their saying, "O Allah! There is no goodness except the goodness of the Hereafter; so please grant Your Blessing to the Ansar and the Emigrants." The people used to bring a handful of barley, and a meal used to be prepared thereof by cooking it with a cooking material (i.e. oil, fat and butter having a change in color and smell) and it used to be presented to the people (i.e. workers) who were hungry, and it used to stick to their throats and had a nasty smell.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.427]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 427

Narrated Jabir:

We were digging (the trench) on the day of (Al-Khandaq ( i.e. Trench )) and we came across a big solid rock. We went to the Prophet and said, "Here is a rock appearing across the trench." He said, "I am coming down." Then he got up, and a stone was tied to his belly for we had not eaten anything for three days. So the Prophet took the spade and struck the big solid rock and it became like sand. I said, "O Allah's Apostle! Allow me to go home." (When the Prophet allowed me) I said to my wife, "I saw the Prophet in a state that I cannot treat lightly. Have you got something (for him to eat?" She replied, "I have barley and a she goat." So I slaughtered the she-kid and she ground the barley; then we put the meat in the earthenware cooking pot. Then I came to the Prophet when the dough had become soft and fermented and (the meat in) the pot over the stone trivet had nearly been well-cooked, and said, "I have got a little food prepared, so get up O Allah's Apostle, you and one or two men along with you (for the food)." The Prophet asked, "How much is that food?" I told him about it. He said, "It is abundant and good. Tell your wife not to remove the earthenware pot from the fire and not to take out any bread from the oven till I reach there." Then he said (to all his companions), "Get up." So the Muhajirn (i.e. Emigrants) and the Ansar got up. When I came to my wife, I said, "Allah's Mercy be upon you! The Prophet came along with the Muhajirin and the Ansar and those who were present with them." She said, "Did the Prophet ask you (how much food you had)?" I replied, "Yes." Then the Prophet said, "Enter and do not throng." The Prophet started cutting the bread (into pieces) and put the cooked meat over it. He covered the earthenware pot and the oven whenever he took something out of them. He would give the food to his companions and take the meat out of the pot. He went on cutting the bread and scooping the meat (for his companions) till they all ate their fill, and even then, some food remained. Then the Prophet said (to my wife), "Eat and present to others as the people are struck with hunger."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.428]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 428

Narrated Jabir bin 'Abdullah:

When the Trench was dug, I saw the Prophet in the state of severe hunger. So I returned to my wife and said, "Have you got anything (to eat), for I have seen Allah's Apostle in a state of severe hunger." She brought out for me, a bag containing one Sa of barley, and we had a domestic she animal (i.e. a kid) which I slaughtered then, and my wife ground the barley and she finished at the time I finished my job (i.e. slaughtering the kid). Then I cut the meat into pieces and put it in an earthenware (cooking) pot, and returned to Allah's Apostle . My wife said, "Do not disgrace me in front of Allah's Apostle and those who are with him." So I went to him and said to him secretly, "O Allah's Apostle! I have slaughtered a she-animal (i.e. kid) of ours, and we have ground a Sa of barley which was with us. So please come, you and another person along with you." The Prophet raised his voice and said, "O people of Trench ! Jabir has prepared a meal so let us go." Allah's Apostle said to me, "Don't put down your earthenware meat pot (from the fireplace) or bake your dough till I come." So I came (to my house) and Allah's Apostle too, came, proceeding before the people. When I came to my wife, she said, "May Allah do so-and-so to you." I said, "I have told the Prophet of what you said." Then she brought out to him (i.e. the Prophet the dough, and he spat in it and invoked for Allah's Blessings in it. Then he proceeded towards our earthenware meat-pot and spat in it and invoked for Allah's Blessings in it. Then he said (to my wife). Call a lady-baker to bake along with you and keep on taking out scoops from your earthenware meat-pot, and do not put it down from its fireplace." They were one-thousand (who took their meals), and by Allah they all ate, and when they left the food and went away, our earthenware pot was still bubbling (full of meat) as if it had not decreased, and our dough was still being baked as if nothing had been taken from it.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.429]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 429

Narrated 'Aisha:

As regards the following Quranic Verse:-- "When they came on you from above and from below you (from east and west of the valley) and when the eyes grew wild and the hearts reached up to the throats....." (33.10) That happened on the day of Al-Khandaq (i.e. Trench).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.430]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 430

Narrated Al-Bara:

The Prophet was carrying earth on the day of Al-Khandaq till his abdomen was fully covered with dust, and he was saying, "By Allah, without Allah we would not have been guided, neither would we have given in charity, nor would we have prayed. So (O Allah), please send Sakina (i.e. calmness) upon us, and make our feet firm if we meet the enemy as the enemy have rebelled against us, and if they intended affliction, (i.e. want to frighten us and fight against us then we would not flee but withstand them)." The Prophet used to raise his voice saying, "Abaina! Abaina! (i.e. would not, we would not)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.431]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 431

Narrated Ibn Abbas:

The Prophet said, "I have been made victorious by As-Saba (i.e. an easterly wind) and the Ad nation was destroyed by Ad-Dabur (i.e. a westerly wind)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.432]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 432

Narrated Al-Bara:

When it was the day of Al-Ahzab (i.e. the clans) and Allah's Apostle dug the trench, I saw him carrying earth out of the trench till dust made the skin of his abdomen out of my sight and he was a hairy man. I heard him reciting the poetic verses composed by Ibn Rawaha while he was carrying the earth, "O Allah! Without You we would not have been guided, nor would we have given in charity, nor would we have prayed. So, (O Allah), please send Sakina (i.e. calmness) upon us and make our feet firm if we meet the enemy, as they have rebelled against us. And if they intend affliction (i.e. want to frighten us, and fight against us) then we would not (flee but withstand them)." The Prophet would then prolong his voice at the last words.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.433]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 433

Narrated Ibn Umar:

The first day (i.e. Ghazwa) I participated in, was the day of Al-Khandaq (i.e. Trench).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.434]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 434

Narrated Ikrima bin Khalid:

Ibn 'Umar said, "I went to Hafsa while water was dribbling from her twined braids. I said, 'The condition of the people is as you see, and no authority has been given to me.' Hafsa said, (to me), 'Go to them, and as they (i.e. the people) are waiting for you, and I am afraid your absence from them will produce division amongst them.' " So Hafsa did not leave Ibn 'Umar till we went to them. When the people differed. Muawiya addressed the people saying, "'If anybody wants to say anything in this matter of the Caliphate, he should show up and not conceal himself, for we are more rightful to be a Caliph than he and his father." On that, Habib bin Masalama said (to Ibn 'Umar), "Why don't you reply to him (i.e. Muawiya)?" 'Abdullah bin 'Umar said, "I untied my garment that was going round my back and legs while I was sitting and was about to say, 'He who fought against you and against your father for the sake of Islam, is more rightful to be a Caliph,' but I was afraid that my statement might produce differences amongst the people and cause bloodshed, and my statement might be interpreted not as I intended. (So I kept quiet) remembering what Allah has prepared in the Gardens of Paradise (for those who are patient and prefer the Hereafter to this worldly life)." Habib said, "You did what kept you safe and secure (i.e. you were wise in doing so)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.435]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 435

Narrated Sulaiman bin Surd:

On the day of Al-Ahzab (i.e. clans) the Prophet said, (After this battle) we will go to attack them(i.e. the infidels) and they will not come to attack us."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.436]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 436

Narrated Sulaiman bin Surd:

When the clans were driven away, I heard the Prophet saying, "From now onwards we will go to attack them (i.e. the infidels) and they will not come to attack us, but we will go to them."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.437]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 437

Narrated 'Ali:

On the day of Al-Khandaq (i.e. Trench), the Prophet said '(Let) Allah fill their (i.e. the infidels') houses and graves with fire just as they have prevented us from offering the Middle Prayer (i.e. 'Asr prayer) till the sun had set."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.438]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 438

Narrated Jabir bin 'Abdullah:

Umar bin Al-Khattab came on the day of Al-Khandaq after the sun had set and he was abusing the infidels of Quraish saying, "O Allah's Apostle! I was unable to offer the ('Asr) prayer till the sun was about to set." The Prophet said, "By Allah, I have not offered this (i.e. 'Asr) prayer." So we came down along with the Prophet to Buthan where he performed ablution for the prayer and then we performed the ablution for it. Then he offered the 'Asr prayer after the sun had set, and after it he offered the Maghrib prayer.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.439]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 439

Narrated Jabir:

On the day of Al-Ahzab (i.e. clans), Allah's Apostle said, 'Who will bring us the news of the people (i.e. the clans of Quraish infidels)?" Az-Zubair said, "I." The Prophet again said, "Who will bring us the news of the people?" AzZubair said, "I." The Prophet again said, "Who will bring us the news of the people?" Az-Zubair said, "I." The Prophet then said, "Every prophet has his Hawari (i.e. disciple-special helper); my disciple is Az-Zubair.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.440]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 440

Narrated Abu Huraira:

Allah's Apostle used to say, "None has the right to be worshipped except Allah Alone (Who) honored His Warriors and made His Slave victorious, and He (Alone) defeated the (infidel) clans; so there is nothing after Him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.441]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 441

Narrated 'Abdullah bin Abi 'Aufa:

Allah's Apostle invoked evil upon the clans saying, "Allah, the Revealer of the Holy Book (i.e. the Quran), the Quick Taker of the accounts! Please defeat the clans. O Allah! Defeat them and shake them."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.442]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 442

Narrated 'Abdullah:

Whenever Allah's Apostle returned from a Ghazwa, Hajj or 'Umra, he used to start (saying), "Allahu-Akbar," thrice and then he would say, "None has the right to be worshipped except Allah alone Who has no partners. To Him belongs the Kingdom, all praises are for Him, and He is able to do all things (i.e. Omnipotent). We are returning with repentance (to Allah) worshipping, prostrating, and praising our Lord. Allah has fulfilled His Promise, made His Slave victorious, and He (Alone) defeated the clans (of infidels) ."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.443]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 443

Narrated 'Aisha:

When the Prophet returned from Al-Khandaq (i.e. Trench) and laid down his arms and took a bath, Gabriel came and said (to the Prophet ), You have laid down your arms? By Allah, we angels have not laid them down yet. So set out for them." The Prophet said, "Where to go?" Gabriel said, "Towards this side," pointing towards Banu Quraiza. So the Prophet went out towards them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.444]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 444

Narrated Anas:

As if I am just now looking at the dust rising in the street of Banu Ghanm (in Medina) because of the marching of Gabriel's regiment when Allah's Apostle set out to Banu Quraiza (to attack them).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.445]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 445

Narrated Ibn Umar:

On the day of Al-Ahzab (i.e. Clans) the Prophet said, "None of you Muslims) should offer the 'Asr prayer but at Banu Quraiza's place." The 'Asr prayer became due for some of them on the way. Some of those said, "We will not offer it till we reach it, the place of Banu Quraiza," while some others said, "No, we will pray at this spot, for the Prophet did not mean that for us." Later on It was mentioned to the Prophet and he did not berate any of the two groups.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.446]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 446

Narrated Anas:

Some (of the Ansar) used to present date palm trees to the Prophet till Banu Quraiza and Banu An-Nadir were conquered (then he returned to the people their date palms). My people ordered me to ask the Prophet to return some or all the date palms they had given to him, but the Prophet had given those trees to Um Aiman. On that, Um Aiman came and put the garment around my neck and said, "No, by Him except Whom none has the right to be worshipped, he will not return those trees to you as he (i.e. the Prophet ) has given them to me." The Prophet go said (to her), "Return those trees and I will give you so much (instead of them)." But she kept on refusing, saying, "No, by Allah," till he gave her ten times the number of her date palms.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.447]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 447

Narrated Abu Said Al-Khudri:

The people of (Banu) Quraiza agreed to accept the verdict of Sad bin Mu'adh. So the Prophet sent for Sad, and the latter came (riding) a donkey and when he approached the Mosque, the Prophet said to the Ansar, "Get up for your chief or for the best among you." Then the Prophet said (to Sad)." These (i.e. Banu Quraiza) have agreed to accept your verdict." Sad said, "Kill their (men) warriors and take their offspring as captives, "On that the Prophet said, "You have judged according to Allah's Judgment," or said, "according to the King's judgment."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.448]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 448

Narrated 'Aisha:

Sad was wounded on the day of Khandaq (i.e. Trench) when a man from Quraish, called Hibban bin Al-'Araqa hit him (with an arrow). The man was Hibban bin Qais from (the tribe of) Bani Mais bin 'Amir bin Lu'ai who shot an arrow at Sad's medial arm vein (or main artery of the arm). The Prophet pitched a tent (for Sad) in the Mosque so that he might be near to the Prophet to visit. When the Prophet returned from the (battle) of Al-Khandaq (i.e. Trench) and laid down his arms and took a bath Gabriel came to him while he (i.e. Gabriel) was shaking the dust off his head, and said, "You have laid down the arms?" By Allah, I have not laid them down. Go out to them (to attack them)." The Prophet said, "Where?" Gabriel pointed towards Bani Quraiza. So Allah's Apostle went to them (i.e. Banu Quraiza) (i.e. besieged them). They then surrendered to the Prophet's judgment but he directed them to Sad to give his verdict concerning them. Sad said, "I give my judgment that their warriors should be killed, their women and children should be taken as captives, and their properties distributed."

Narrated Hisham: My father informed me that 'Aisha said, "Sad said, "O Allah! You know that there is nothing more beloved to me than to fight in Your Cause against those who disbelieved Your Apostle and turned him out (of Mecca). O Allah! I think you have put to an end the fight between us and them (i.e. Quraish infidels). And if there still remains any fight with the Quraish (infidels), then keep me alive till I fight against them for Your Sake. But if you have brought the war to an end, then let this wound burst and cause my death thereby.' So blood gushed from the wound. There was a tent in the Mosque belonging to Banu Ghifar who were surprised by the blood flowing towards them . They said, 'O people of the tent! What is this thing which is coming to us from your side?' Behold! Blood was flowing profusely out of Sad's wound. Sad then died because of that."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.449]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 449

Narrated Al-Bara:

The Prophet said to Hassan, "Abuse them (with your poems), and Gabriel is with you (i.e, supports you)." (Through another group of sub narrators) Al-Bara bin Azib said, "On the day of Quraiza's (besiege), Allah's Apostle said to Hassan bin Thabit, 'Abuse them (with your poems), and Gabriel is with you (i.e. supports you).' "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.450]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 450

Narrated Abu Burda:

Abu Musa said, "We went out in the company of the Prophet for a Ghazwa and we were six persons having one camel which we rode in rotation. So, (due to excessive walking) our feet became thin and my feet became thin and my nail dropped, and we used to wrap our feet with the pieces of cloth, and for this reason, the Ghazwa was named Dhat-ur-Riqa as we wrapped our feet with rags." When Abu- Musa narrated this (Hadith), he felt regretful to do so and said, as if he disliked to have disclosed a good deed of his.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.451]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 451

Narrated Salih bin Khawwat:

Concerning those who witnessed the Fear Prayer that was performed in the battle of Dhat-ur-Riqa' in the company of Allah's Apostle; One batch lined up behind him while another batch (lined up) facing the enemy. The Prophet led the batch that was with him in one Rak'a, and he stayed in the standing posture while that batch completed their (two Rakat) prayer by themselves and went away, lining in the face of the enemy, while the other batch came and he (i.e. the Prophet) offered his remaining Rak'a with them, and then, kept on sitting till they completed their prayer by themselves, and he then finished his prayer with Taslim along with them.

Narrated Ibn Az-Zubair: Jabir said, "We were with the Prophet at Nakhl," and then he mentioned the Fear prayer.

Narrated Al-Qasim bin Muhammad: The Prophet offered the Fear prayer in the Ghazwa of Banu Anmar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.452]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 452

Narrated Sahl bin Abi Hathma:

(describing the Fear prayer): The Imam stands up facing the Qibla and one batch of them (i.e. the army) (out of the two) prays along with him and the other batch faces the enemy. The Imam offers one Rak'a with the first batch they themselves stand up alone and offer one bowing and two prostrations while they are still in their place, and then go away to relieve the second batch, and the second batch comes (and takes the place of the first batch in the prayer behind the Imam) and he offers the second Rak'a with them. So he completes his two-Rak'at and then the second batch bows and prostrates two prostrations (i.e. complete their second Rak'a and thus all complete their prayer)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.453]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 453

Narrated Salih bin Hathma:

The Prophet said as above (Hadith 452).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.454]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 454

Narrated Salih bin Khawwat:

Sahl said as above (Hadith 452).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.455]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 455

Narrated Ibn 'Umar:

I took part in a Ghazwa towards Najd along with Allah's Apostle and we clashed with the enemy, and we lined up for them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.456]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 456

Narrated 'Abdullah bin 'Umar:

Allah's Apostle led the Fear-prayer with one of the two batches of the army while the other (batch) faced the enemy. Then the first batch went away and took places of their companions (i.e. second batch) and the second batch came and he led his second Rak'a with them. Then he (i.e. the Prophet: finished his prayer with Taslim and then each of the two batches got up and completed their remaining one Rak'a.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.457]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 457

Narrated Sinan and Abu Salama:

Jabir mentioned that he had participated in a Ghazwa towards Najd in the company of Allah's Apostle .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.458]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 458

Narrated Jabir bin 'Abdullah:

That he fought in a Ghazwa towards Najd along with Allah's Apostle and when Allah's Apostle returned, he too, returned along with him. The time of the afternoon nap overtook them when they were in a valley full of thorny trees. Allah's Apostle dismounted and the people dispersed amongst the thorny trees, seeking the shade of the trees. Allah's Apostle took shelter under a Samura tree and hung his sword on it. We slept for a while when Allah's Apostle suddenly called us, and we went to him, to find a bedouin sitting with him. Allah's Apostle said, "This (bedouin) took my sword out of its sheath while I was asleep. When I woke up, the naked sword was in his hand and he said to me, 'Who can save you from me?, I replied, 'Allah.' Now here he is sitting." Allah's Apostle did not punish him (for that).

Through another group of narrators, Jabir said, "We were in the company of the Prophet (during the battle of) Dhat-ur-Riqa', and we came across a shady tree and we left it for the Prophet (to take rest under its shade). A man from the pagans came while the Prophet's sword was hanging on the tree. He took it out of its sheath secretly and said (to the Prophet ), 'Are you afraid of me?' The Prophet said, 'No.' He said, 'Who can save you from me?' The Prophet said, Allah.' The companions of the Prophet threatened him, then the Iqama for the prayer was announced and the Prophet offered a two Rakat Fear prayer with one of the two batches, and that batch went aside and he offered two Rak'a-t with the other batch. So the Prophet offered four Rakat but the people offered two Rakat only." (The sub-narrator) Abu Bishr added, "The man was Ghaurath bin Al-Harith and the battle was waged against Muharib Khasafa." Jabir added, "We were with the Prophet at Nakhl and he offered the Fear prayer." Abu Huraira said, "I offered the Fear prayer with the Prophet during the Ghazwa (i.e. the battle) of Najd." Abu Huraira came to the Prophet during the day of Khaibar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.459]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 459

Narrated Ibn Muhairiz:

I entered the Mosque and saw Abu Said Al-Khudri and sat beside him and asked him about Al-Azl (i.e. coitus interruptus). Abu Said said, "We went out with Allah's Apostle for the Ghazwa of Banu Al-Mustaliq and we received captives from among the Arab captives and we desired women and celibacy became hard on us and we loved to do coitus interruptus. So when we intended to do coitus interrupt us, we said, 'How can we do coitus interruptus before asking Allah's Apostle who is present among us?" We asked (him) about it and he said, 'It is better for you not to do so, for if any soul (till the Day of Resurrection) is predestined to exist, it will exist."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.460]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 460

Narrated Jabir bin 'Abdullah:

We took part in the Ghazwa of Najd along with Allah's Apostle and when the time for the afternoon rest approached while he was in a valley with plenty of thorny trees, he dismounted under a tree and rested in its shade and hung his sword (on it). The people dispersed amongst the trees in order to have shade. While we were in this state, Allah's Apostle called us and we came and found a bedouin sitting in front of him. The Prophet said, "This (Bedouin) came to me while I was asleep, and he took my sword stealthily. I woke up while he was standing by my head, holding my sword without its sheath. He said, 'Who will save you from me?' I replied, 'Allah.' So he sheathed it (i.e. the sword) and sat down, and here he is." But Allah's Apostle did not punish him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.461]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 461

Narrated Jabir bin Abdullah Al-Ansari:

I saw the Prophet offering his Nawafil prayer on his Mount facing the East during the Ghazwa of Anmar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.462]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 462

Narrated 'Aisha:

Whenever Allah's Apostle intended to go on a journey, he used to draw lots amongst his wives, and Allah's Apostle used to take with him the one on whom lot fell. He drew lots amongst us during one of the Ghazwat which he fought. The lot fell on me and so I proceeded with Allah's Apostle after Allah's order of veiling (the women) had been revealed. I was carried (on the back of a camel) in my howdah and carried down while still in it (when we came to a halt). So we went on till Allah's Apostle had finished from that Ghazwa of his and returned.

When we approached the city of Medina he announced at night that it was time for departure. So when they announced the news of departure, I got up and went away from the army camps, and after finishing from the call of nature, I came back to my riding animal. I touched my chest to find that my necklace which was made of Zifar beads (i.e. Yemenite beads partly black and partly white) was missing. So I returned to look for my necklace and my search for it detained me. (In the meanwhile) the people who used to carry me on my camel, came and took my howdah and put it on the back of my camel on which I used to ride, as they considered that I was in it. In those days women were light in weight for they did not get fat, and flesh did not cover their bodies in abundance as they used to eat only a little food. Those people therefore, disregarded the lightness of the howdah while lifting and carrying it; and at that time I was still a young girl. They made the camel rise and all of them left (along with it). I found my necklace after the army had gone.

Then I came to their camping place to find no call maker of them, nor one who would respond to the call. So I intended to go to the place where I used to stay, thinking that they would miss me and come back to me (in my search). While I was sitting in my resting place, I was overwhelmed by sleep and slept. Safwan bin Al-Muattal As-Sulami Adh-Dhakwani was behind the army. When he reached my place in the morning, he saw the figure of a sleeping person and he recognized me on seeing me as he had seen me before the order of compulsory veiling (was prescribed). So I woke up when he recited Istirja' (i.e. "Inna lillahi wa inna llaihi raji'un") as soon as he recognized me. I veiled my face with my head cover at once, and by Allah, we did not speak a single word, and I did not hear him saying any word besides his Istirja'. He dismounted from his camel and made it kneel down, putting his leg on its front legs and then I got up and rode on it. Then he set out leading the camel that was carrying me till we overtook the army in the extreme heat of midday while they were at a halt (taking a rest). (Because of the event) some people brought destruction upon themselves and the one who spread the Ifk (i.e. slander) more, was 'Abdullah bin Ubai Ibn Salul."

(Urwa said, "The people propagated the slander and talked about it in his (i.e. 'Abdullah's) presence and he confirmed it and listened to it and asked about it to let it prevail." Urwa also added, "None was mentioned as members of the slanderous group besides ('Abdullah) except Hassan bin Thabit and Mistah bin Uthatha and Hamna bint Jahsh along with others about whom I have no knowledge, but they were a group as Allah said. It is said that the one who carried most of the slander was 'Abdullah bin Ubai bin Salul." Urwa added, "'Aisha disliked to have Hassan abused in her presence and she used to say, 'It was he who said: My father and his (i.e. my father's) father and my honor are all for the protection of Muhammad's honor from you.").

'Aisha added, "After we returned to Medina, I became ill for a month. The people were propagating the forged statements of the slanderers while I was unaware of anything of all that, but I felt that in my present ailment, I was not receiving the same kindness from Allah's Apostle as I used to receive when I got sick. (But now) Allah's Apostle would only come, greet me and say,' How is that (lady)?' and leave. That roused my doubts, but I did not discover the evil (i.e. slander) till I went out after my convalescence, I went out with Um Mistah to Al-Manasi' where we used to answer the call of nature and we used not to go out (to answer the call of nature) except at night, and that was before we had latrines near our houses. And this habit of our concerning evacuating the bowels, was similar to the habits of the old 'Arabs living in the deserts, for it would be troublesome for us to take latrines near our houses. So I and Um Mistah who was the daughter of Abu Ruhm bin Al-Muttalib bin Abd Manaf, whose mother was the daughter of Sakhr bin 'Amir and the aunt of Abu Bakr As-Siddiq and whose son was Mistah bin Uthatha bin 'Abbas bin Al-Muttalib, went out. I and Um Mistah returned to my house after we finished answering the call of nature. Um Mistah stumbled by getting her foot entangled in her covering sheet and on that she said, 'Let Mistah be ruined!' I said, 'What a hard word you have said. Do you abuse a man who took part in the battle of Badr?' On that she said, 'O you Hantah! Didn't you hear what he (i.e. Mistah) said? 'I said, 'What did he say?'

Then she told me the slander of the people of Ifk. So my ailment was aggravated, and when I reached my home, Allah's Apostle came to me, and after greeting me, said, 'How is that (lady)?' I said, 'Will you allow me to go to my parents?' as I wanted to be sure about the news through them. Allah's Apostle allowed me (and I went to my parents) and asked my mother, 'O mother! What are the people talking about?' She said, 'O my daughter! Don't worry, for scarcely is there a charming woman who is loved by her husband and whose husband has other wives besides herself that they (i.e. women) would find faults with her.' I said, 'Subhan-Allah! (I testify the uniqueness of Allah). Are the people really talking in this way?' I kept on weeping that night till dawn I could neither stop weeping nor sleep then in the morning again, I kept on weeping. When the Divine Inspiration was delayed.

Allah's Apostle called 'Ali bin Abi Talib and Usama bin Zaid to ask and consult them about divorcing me. Usama bin Zaid said what he knew of my innocence, and the respect he preserved in himself for me. Usama said, '(O Allah's Apostle!) She is your wife and we do not know anything except good about her.' 'Ali bin Abi Talib said, 'O Allah's Apostle! Allah does not put you in difficulty and there are plenty of women other than she, yet, ask the maid-servant who will tell you the truth.' On that Allah's Apostle called Barira (i.e. the maid-servant) and said, 'O Barira! Did you ever see anything which aroused your suspicion?' Barira said to him, 'By Him Who has sent you with the Truth. I have never seen anything in her (i.e. Aisha) which I would conceal, except that she is a young girl who sleeps leaving the dough of her family exposed so that the domestic goats come and eat it.'

So, on that day, Allah's Apostle got up on the pulpit and complained about 'Abdullah bin Ubai (bin Salul) before his companions, saying, 'O you Muslims! Who will relieve me from that man who has hurt me with his evil statement about my family? By Allah, I know nothing except good about my family and they have blamed a man about whom I know nothing except good and he used never to enter my home except with me.' Sad bin Mu'adh the brother of Banu 'Abd Al-Ashhal got up and said, 'O Allah's Apostle! I will relieve you from him; if he is from the tribe of Al-Aus, then I will chop his head off, and if he is from our brothers, i.e. Al-Khazraj, then order us, and we will fulfill your order.' On that, a man from Al-Khazraj got up. Um Hassan, his cousin, was from his branch tribe, and he was Sad bin Ubada, chief of Al-Khazraj. Before this incident, he was a pious man, but his love for his tribe goaded him into saying to Sad (bin Mu'adh). 'By Allah, you have told a lie; you shall not and cannot kill him. If he belonged to your people, you would not wish him to be killed.'

On that, Usaid bin Hudair who was the cousin of Sad (bin Mu'adh) got up and said to Sad bin 'Ubada, 'By Allah! You are a liar! We will surely kill him, and you are a hypocrite arguing on the behalf of hypocrites.' On this, the two tribes of Al-Aus and Al Khazraj got so much excited that they were about to fight while Allah's Apostle was standing on the pulpit. Allah's Apostle kept on quietening them till they became silent and so did he. All that day I kept on weeping with my tears never ceasing, and I could never sleep.

In the morning my parents were with me and I wept for two nights and a day with my tears never ceasing and I could never sleep till I thought that my liver would burst from weeping. So, while my parents were sitting with me and I was weeping, an Ansari woman asked me to grant her admittance. I allowed her to come in, and when she came in, she sat down and started weeping with me. While we were in this state, Allah's Apostle came, greeted us and sat down. He had never sat with me since that day of the slander. A month had elapsed and no Divine Inspiration came to him about my case. Allah's Apostle then recited Tashah-hud and then said, 'Amma Badu, O 'Aisha! I have been informed so-and-so about you; if you are innocent, then soon Allah will reveal your innocence, and if you have committed a sin, then repent to Allah and ask Him for forgiveness for when a slave confesses his sins and asks Allah for forgiveness, Allah accepts his repentance.'

When Allah's Apostle finished his speech, my tears ceased flowing completely that I no longer felt a single drop of tear flowing. I said to my father, 'Reply to Allah's Apostle on my behalf concerning what he has said.' My father said, 'By Allah, I do not know what to say to Allah's Apostle .' Then I said to my mother, 'Reply to Allah's Apostle on my behalf concerning what he has said.' She said, 'By Allah, I do not know what to say to Allah's Apostle.' In spite of the fact that I was a young girl and had a little knowledge of Quran, I said, 'By Allah, no doubt I know that you heard this (slanderous) speech so that it has been planted in your hearts (i.e. minds) and you have taken it as a truth. Now if I tell you that I am innocent, you will not believe me, and if confess to you about it, and Allah knows that I am innocent, you will surely believe me. By Allah, I find no similitude for me and you except that of Joseph's father when he said, '(For me) patience in the most fitting against that which you assert; it is Allah (Alone) Whose Help can be sought.' Then I turned to the other side and lay on my bed; and Allah knew then that I was innocent and hoped that Allah would reveal my innocence. But, by Allah, I never thought that Allah would reveal about my case, Divine Inspiration, that would be recited (forever) as I considered myself too unworthy to be talked of by Allah with something of my concern, but I hoped that Allah's Apostle might have a dream in which Allah would prove my innocence. But, by Allah, before Allah's Apostle left his seat and before any of the household left, the Divine inspiration came to Allah's Apostle.

So there overtook him the same hard condition which used to overtake him, (when he used to be inspired Divinely). The sweat was dropping from his body like pearls though it was a wintry day and that was because of the weighty statement which was being revealed to him. When that state of Allah's Apostle was over, he got up smiling, and the first word he said was, 'O 'Aisha! Allah has declared your innocence!' Then my Mother said to me, 'Get up and go to him (i.e. Allah's Apostle). I replied, 'By Allah, I will not go to him, and I praise none but Allah. So Allah revealed the ten Verses:-- "Verily! They who spread the slander Are a gang, among you............." (24.11-20)

Allah revealed those Quranic Verses to declare my innocence. Abu Bakr As-Siddiq who used to disburse money for Mistah bin Uthatha because of his relationship to him and his poverty, said, 'By Allah, I will never give to Mistah bin Uthatha anything after what he has said about Aisha.' Then Allah revealed:--

"And let not those among you who are good and wealthy swear not to give (any sort of help) to their kinsmen, those in need, and those who have left their homes for Allah's cause, let them pardon and forgive. Do you not love that Allah should forgive you? And Allah is oft-Forgiving Most Merciful." (24.22)

Abu Bakr As-Siddiq said, 'Yes, by Allah, I would like that Allah forgive me.' and went on giving Mistah the money he used to give him before. He also added, 'By Allah, I will never deprive him of it at all.'

Aisha further said:." Allah's Apostle also asked Zainab bint Jahsh (i.e. his wife) about my case. He said to Zainab, 'What do you know and what did you see?" She replied, "O Allah's Apostle! I refrain from claiming falsely that I have heard or seen anything. By Allah, I know nothing except good (about 'Aisha).' From amongst the wives of the Prophet Zainab was my peer (in beauty and in the love she received from the Prophet) but Allah saved her from that evil because of her piety. Her sister Hamna, started struggling on her behalf and she was destroyed along with those who were destroyed. The man who was blamed said, 'Subhan-Allah! By Him in Whose Hand my soul is, I have never uncovered the cover (i.e. veil) of any female.' Later on the man was martyred in Allah's Cause."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.463]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 463

Narrated Az-Zuhri:

Al-Walid bin 'Abdul Malik said to me, "Have you heard that 'Ali' was one of those who slandered 'Aisha?" I replied, "No, but two men from your people (named) Abu Salama bin 'Abdur-Rahman and Abu Bakr bin Abdur-Rahman bin Al-Harith have informed me that Aisha told them that 'Ali remained silent about her case."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.464]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 464

Narrated Masruq bin Al-Aida:

Um Ruman, the mother of 'Aisha said that while 'Aisha and she were sitting, an Ansari woman came and said, "May Allah harm such and-such a person!" Um Ruman said to her, What is the matter?" She replied, "My son was amongst those who talked of the story (of the Slander)." Um Ruman said, "What is that?" She said, "So-and-so...." and narrated the whole story. On that 'Aisha said, "Did Allah's Apostle hear about that?" She replies, "yes." 'Aisha further said, "And Abu Bakr too?" She replied, "Yes." On that, 'Aisha fell down fainting, and when she came to her senses, she had got fever with rigors. I put her clothes over her and covered her. The Prophet came and asked, "What is wrong with this (lady)?" Um Ruman replied, "O Allah's Apostle! She (i.e. 'Aisha) has got temperature with rigors." He said, "Perhaps it is because of the story that has been talked about?" She said, "Yes." 'Aisha sat up and said, "By Allah, if I took an oath (that I am innocent), you would not believe me, and if I said (that I am not innocent), you would not excuse me. My and your example is like that of Jacob and his sons (as Jacob said ): 'It is Allah (Alone) Whose Help can be sought against that you assert.' Um Ruman said, "The Prophet then went out saying nothing. Then Allah declared her innocence. On that, 'Aisha said (to the Prophet), "I thank Allah only; thank neither anybody else nor you."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.465]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 465

Narrated Ibn Abi Malaika:

'Aisha used to recite this Verse:-- 'Ida taliqunahu bi-alsinatikum' (24.15) "(As you tell lie with your tongues.)" and used to say "Al-Walaq" means "telling of a lie. "She knew this Verse more than anybody else as it was revealed about her.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.466]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 466

Narrated Hisham's father:

I started abusing Hassan in front of 'Aisha. She said, "Do not abuse him as he used to defend Allah's Apostle (against the infidels). 'Aisha added, "Once Hassan took the permission from the Prophet to say poetic verses against the infidels. On that the Prophet said, 'How will you exclude my forefathers (from that)? Hassan replied, 'I will take you out of them as one takes a hair out of the dough." Hisham's father added, "I abused Hassan as he was one of those who spoke against 'Aisha."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.467]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 467

Narrated Masruq:

We went to 'Aisha while Hassan bin Thabit was with her reciting poetry to her from some of his poetic verses, saying "A chaste wise lady about whom nobody can have suspicion. She gets up with an empty stomach because she never eats the flesh of indiscreet (ladies)." 'Aisha said to him, "But you are not like that." I said to her, "Why do you grant him admittance, though Allah said:-- "and as for him among them, who had the greater share therein, his will be a severe torment." (24.11)

On that, 'Aisha said, "And what punishment is more than blinding?" She, added, "Hassan used to defend or say poetry on behalf of Allah's Apostle (against the infidels)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.468]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 468

Narrated Zaid bin Khalid:

We went out with Allah's Apostle in the year of Al-Hudaibiya. One night it rained and Allah's Apostle led us in the Fajr prayer and (after finishing it), turned to us and said, " Do you know what your Lord has said?" We replied, "Allah and His Apostle know it better." He said, "Allah said:-- "(Some of) My slaves got up believing in Me, And (some of them) disbelieving in Me. The one who said: We have been given Rain through Allah's Mercy and Allah's Blessing and Allah's Bounty, Then he is a believer in Me, and is a Disbeliever in the star. And whoever said: We have been given rain because of such-and-such star, Then he is a believer in the star, and is a disbeliever in Me."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.469]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 469

Narrated Anas:

Allah's Apostle performed four 'Umras, all in the month of Dhul-Qa'da, except the one which he performed with his Hajj (i.e. in Dhul-Hijja). He performed one 'Umra from Al-Hudaibiya in Dhul-Qa'da, another 'Umra in the following year in Dhul Qa'da a third from Al-Jirana where he distributed the war booty of Hunain, in Dhul Qa'da, and the fourth 'Umra he performed was with his Hajj.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.470]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 470

Narrated Abu Qatada:

We set out with the Prophet in the year of Al-Hudaibiya, and all his companions assumed the state of Ihram but I did not.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.471]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 471

Narrated Al-Bara:

Do you (people) consider the conquest of Mecca, the Victory (referred to in the Qur'an 48:1). Was the conquest of Mecca a victory? We really consider that the actual Victory was the Ar-Ridwan Pledge of allegiance which we gave on the day of Al-Hudaibiya (to the Prophet) . On the day of Al-Hudaibiya we were fourteen hundred men along with the Prophet Al-Hudaibiya was a well, the water of which we used up leaving not a single drop of water in it. When the Prophet was informed of that, he came and sat on its edge. Then he asked for a utensil of water, performed ablution from it, rinsed (his mouth), invoked (Allah), and poured the remaining water into the well. We stayed there for a while and then the well brought forth what we required of water for ourselves and our riding animals.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.472]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 472

Narrated Al-Bara bin Azib:

That they were in the company of Allah's Apostle on the day of Al-Hudaibiya and their number was 1400 or more. They camped at a well and drew its water till it was dried. When they informed Allah's Apostle of that, he came and sat over its edge and said, "Bring me a bucket of its water." When it was brought, he spat and invoked (Allah) and said, "Leave it for a while." Then they quenched their thirst and watered their riding animals (from that well) till they departed.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.473]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 473

Narrated Salim:

Jabir said "On the day of Al-Hudaibiya, the people felt thirsty and Allah's Apostle had a utensil containing water. He performer ablution from it and then the people came towards him. Allah's Apostle said, 'What is wrong with you?' The people said, 'O Allah's Apostle! We haven't got any water to perform ablution with or to drink, except what you have in your utensil.' So the Prophet put his hand in the utensil and the water started spouting out between his fingers like springs. So we drank and performed ablution." I said to Jabir, "What was your number on that day?" He replied, "Even if we had been one hundred thousand, that water would have been sufficient for us. Anyhow, we were 1500.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.474]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 474

Narrated Qatada:

I said to Sa'id bin Al-Musaiyab, "I have been informed that Jabir bin 'Abdullah said that the number (of Al-Hudaibiya Muslim warriors) was 1400." Sa'id said to me, "Jabir narrated to me that they were 1500 who gave the Pledge of allegiance to the Prophet on the day of Al-Hudaibiya.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.475]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 475

Narrated Jabir bin 'Abdullah:

On the day of Al-Hudaibiya, Allah's Apostle said to us' "You are the best people on the earth!" We were 1400 then. If I could see now, I would have shown you the place of the Tree (beneath which the Pledge of allegiance was given by us)," Salim said, "Our number was 1400." 'Abdullah bin Abi Aufa said, "The people (who gave the Pledge of allegiance) under the Tree numbered 1300 and the number of Bani Aslam was 1/8 of the Emigrants."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.476]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 476

Narrated Mirdas Al-Aslami:

Who was among those (who had given the Pledge of allegiance) under the Tree: Pious people will die in succession, and there will remain the dregs of society who will be like the useless residues of dates and barley and Allah will pay no attention to them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.477]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 477

Narrated Marwan and Al-Miswar bin Makhrama:

The Prophet went out in the company of 1300 to 1500 of his companions in the year of Al-Hudaibiya, and when they reached Dhul-Hulaifa, he garlanded and marked his Hadi and assumed the state of Ihram.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.478]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 478

Narrated Kab bin Ujra:

That Allah's Apostle saw him with the lice falling (from his head) on his face. Allah's Apostle said, "Are your lice troubling you? Ka'b said, "Yes." Allah's Apostle thus ordered him to shave his head while he was at Al-Hudaibiya. Up to then there was no indication that all of them would finish their state of Ihram and they hoped that they would enter Mecca. Then the order of Al-Fidya was revealed, so Allah's Apostle ordered Kab to feed six poor persons with one Faraq of food or slaughter a sheep or fast for three days.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.479]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 479

Narrated Aslam:

Once I went with 'Umar bin Al-Khattab to the market. A young woman followed 'Umar and said, "O chief of the believers! My husband has died, leaving little children. By Allah, they have not even a sheep's trotter to cook; they have no farms or animals. I am afraid that they may die because of hunger, and I am the daughter of Khufaf bin Ima Al-Ghafari, and my father witnessed the Pledge of allegiance) of Al-Hudaibiya with the Prophet.' Umar stopped and did not proceed, and said, "I welcome my near relative." Then he went towards a strong camel which was tied in the house, and carried on to it, two sacks he had loaded with food grains and put between them money and clothes and gave her its rope to hold and said, "Lead it, and this provision will not finish till Allah gives you a good supply." A man said, "O chief of the believers! You have given her too much." "Umar said disapprovingly. "May your mother be bereaved of you! By Allah, I have seen her father and brother besieging a fort for a long time and conquering it, and then we were discussing what their shares they would have from that war booty."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.480]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 480

Narrated Said bin Al-Musaiyab:

That his father said, "I saw the Tree (of the Ar-Ridwan Pledge of allegiance and when I returned to it later, I was not able to recognize it. (The sub--narrator MahmiJd said, Al-Musaiyab said, 'Then; forgot it (i.e., the Tree).)"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.481]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 481

Narrated Tariq bin 'Abdur-Rahman:

When I set out for Hajj, I passed by some people offering a prayer, I asked, "What is this mosque?" They said, "This is the Tree where Allah's Apostle took the Ar-Ridwan Pledge of allegiance. Then I went to Sa'id bin Musaiyab and informed him about it. Said said, "My father said that he was amongst those who had given the Pledge of allegiance to Allah's Apostle beneath the Tree. He (i.e. my father) said, "When we set out the following year, we forgot the Tree and were unable to recognize it. "Then Said said (perhaps ironically) "The companions of the Prophet could not recognize it; nevertheless, you do recognize it; therefore you have a better knowledge."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.482]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 482

Narrated Said bin Al-Musaiyab:

That his father was amongst those who had given the Pledge of allegiance (to the Prophet ) beneath the Tree, and the next year when they went towards the Tree, they were not able to recognize it.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.483]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 483

Narrated Tariq:

(The tree where the Ridwan Pledge of allegiance was taken by the Prophet) was mentioned before Said bin Al-Musaiyab. On that he smiled and said, "My father informed me (about it) and he had witnessed it (i.e. the Pledge) ."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.484]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 484

Narrated Abdullah bin Abi Aufa:

(Who was one of those who had given the Pledge of allegiance to the Prophet beneath the Tree) When the people brought Sadaqa (i.e. Rakat) to the Prophet he used to say, "O Allah! Bless them with your Mercy." Once my father came with his Sadaqa to him whereupon he (i.e. the Prophet) said. "O Allah! Bless the family of Abu Aufa."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.485]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 485

Narrated 'Abbas bin Tamim:

When it was the day (of the battle) of Al-Harra the people were giving Pledge of allegiance to Abdullah bin Hanzala. Ibn Zaid said, "For what are the people giving Pledge of allegiance to Abdullah bin Hanzala?" It was said to him, "For death." Ibn Zaid said, "I will never give the Pledge of allegiance for that to anybody else after Allah's Apostle ." Ibn Zaid was one of those who had witnessed the day of Al-Hudaibiya with the Prophet.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.486]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 486

Narrated Iyas bin Salama bin Al-Akwa:

My father who was amongst those who had given the Pledge of allegiance to the Prophet beneath the Tree, said to me, "We used to offer the Jumua prayer with the Prophet and then depart at a time when the walls had no shade for us to take shelter in."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.487]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 487

Narrated Yazid bin Abi Ubaid:

I said to Salama bin Al-Akwa, "For what did you give the Pledge of allegiance to Allah's Apostle on the day of Al-Hudaibiya?" He replied, "For death (in the Cause of Islam.)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.488]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 488

Narrated Al-Musaiyab:

I met Al-Bara bin 'Azib and said (to him). "May you live prosperously! You enjoyed the company of the Prophet and gave him the Pledge of allegiance (of Al-Hudaibiya) under the Tree." On that, Al-Bara' said, "O my nephew! You do not know what we have done after him (i.e. his death)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.489]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 489

Narrated Abu Qilaba:

that Thabit bin Ad-Dahhak had informed him that he was one of those who had given the Pledge of allegiance (of Al-Hudaibiya) beneath the Tree.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.490]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 490

Narrated Anas bin Malik:

regarding Allah's Statement: "Verily! We have granted you (O, Muhammad) Manifest victory." (48.1) It refers to the Al-Hudaibiya Pledge. And the companions of the Prophet said (to the Prophet), "Congratulations and happiness for you; but what reward shall we get?" So Allah revealed:-- "That He may admit the believing men and women to gardens beneath which rivers flow." (48.5)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.491]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 491

Narrated Zahir Al-Aslami:

(who was one of those who had witnessed (the Pledge of allegiance beneath) the Tree) While I was making fire beneath the cooking pots containing donkey's meat, the announcer of Allah's Apostle announced, "Allah's Apostle forbids you to eat donkey's meat."

The same narration was told by Majzaa from a man called Uhban bin Aus who was one of those who had witnessed (the Pledge of allegiance beneath) the Tree., and who had some trouble in his knee so that while doing prostrations, he used to put a pillow underneath his knee.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.492]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 492

Narrated Suwaid bin An-Numan:

who was one of those who witnessed (the Pledge of allegiance beneath) the Tree: Allah's Apostle and his companions were given Sawiq and they chewed it.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.493]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 493

Narrated Abu Jamra:

I asked Aidh bin Amr, who was one of the companions of the Prophet one of those (who gave the allegiance to the Prophet the Tree: "Can the Witr prayer be repeated (in one night)?" He said, "If you have offered it in the first part of the night, you should not repeat it in the last part 'of the night." (See Fateh-al-Bari page 458 Vol 8th).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.494]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 494

Narrated Zaid bin Aslam:

My father said, "Allah's Apostle was proceeding at night on one of his journeys and 'Umar bin Al-Khattab was going along with him. 'Umar bin Al-Khattab asked him (about something) but Allah's Apostle did not answer him. 'Umar asked him again, but he did not answer him. He asked him again (for the third time) but he did not answer him. On that Umar bin Al-Khattab addressed himself saying, "May your mother be bereaved of you, O 'Umar, for you have asked Allah's Apostle thrice, yet he has not answered you." 'Umar said, "Then I made my camel run fast and took it in front of the other Muslims, and I was afraid that something might be revealed in my connection. I had hardly waited for a moment when I heard somebody calling me. I said, 'I was afraid that something might have been revealed about me.' Then I came to Allah's Apostle and greeted him. He (i.e. the Prophet) said, 'Tonight there has been revealed to me, a Sura which is dearer to me than (all the world) on which the sun rises,' and then he recited: 'Verily! We have granted you (O Muhammad) A manifest victory." (48.1)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.495]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 495

Narrated Al-Miswar bin Makhrama and Marwan bin Al-Hakam:

(one of them said more than his friend): The Prophet set out in the company of more than one-thousand of his companions in the year of Al-Hudaibiya, and when he reached Dhul-Hulaifa, he garlanded his Hadi (i.e. sacrificing animal), assumed the state of Ihram for 'Umra from that place and sent a spy of his from Khuzi'a (tribe). The Prophet proceeded on till he reached (a village called) Ghadir-al-Ashtat. There his spy came and said, "The Quraish (infidels) have collected a great number of people against you, and they have collected against you the Ethiopians, and they will fight with you, and will stop you from entering the Ka'ba and prevent you." The Prophet said, "O people! Give me your opinion. Do you recommend that I should destroy the families and offspring of those who want to stop us from the Ka'ba? If they should come to us (for peace) then Allah will destroy a spy from the pagans, or otherwise we will leave them in a miserable state." On that Abu Bakr said, "O Allah Apostle! You have come with the intention of visiting this House (i.e. Ka'ba) and you do not want to kill or fight anybody. So proceed to it, and whoever should stop us from it, we will fight him." On that the Prophet said, "Proceed on, in the Name of Allah !"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.496]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 496

Narrated Urwa bin Az-Zubair:

That he heard Marwan bin Al-Hakam and Al-Miswar bin Makhrama relating one of the events that happened to Allah's Apostle in the 'Umra of Al-Hudaibiya. They said, "When Allah's Apostle concluded the truce with Suhail bin 'Amr on the day of Al-Hudaibiya, one of the conditions which Suhail bin 'Amr stipulated, was his saying (to the Prophet), "If anyone from us (i.e. infidels) ever comes to you, though he has embraced your religion, you should return him to us, and should not interfere between us and him." Suhail refused to conclude the truce with Allah's Apostle except on this condition. The believers disliked this condition and got disgusted with it and argued about it. But when Suhail refused to conclude the truce with Allah's Apostle except on that condition, Allah's Apostle concluded it. Accordingly, Allah's Apostle then returned Abu Jandal bin Suhail to his father, Suhail bin 'Amr, and returned every man coming to him from them during that period even if he was a Muslim. The believing women Emigrants came (to Medina) and Um Kulthum, the daughter of 'Uqba bin Abi Mu'ait was one of those who came to Allah's Apostle and she was an adult at that time. Her relatives came, asking Allah's Apostle to return her to them, and in this connection, Allah revealed the Verses dealing with the believing (women). Aisha said, "Allah's Apostle used to test all the believing women who migrated to him, with the following Verse:-- "O Prophet! When the believing Women come to you, to give the pledge of allegiance to you." (60.12)

'Urwa's uncle said, "We were informed when Allah ordered His Apostle to return to the pagans what they had given to their wives who lately migrated (to Medina) and we were informed that Abu Basir..." relating the whole narration.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.497]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 497

Narrated Nafi:

Abdullah bin Umar set out for Umra during the period of afflictions, and he said, "If I should be stopped from visiting the Kaba, I will do what we did when we were with Allah's Apostle." He assumed Ihram for 'Umra in the year of Al-Hudaibiya.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.498]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 498

Narrated Nafi:

Ibn 'Umar assumed Ihram and said, "If something should intervene between me and the Ka'ba, then I will do what the Prophet did when the Quraish infidels intervened between him and (the Ka'ba). Then Ibn 'Umar recited: "You have indeed in Allah's Apostle A good example to follow." (33.21)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.499]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 499

Narrated Nafi:

One of 'Abdullah's sons said to 'Abdullah (bin Umar) "I wish you would stay this year (and not perform Hajj) as I am afraid that you will not be able to reach the Kaba." On that he (i.e. 'Abdullah bin Umar) said, "We went out with the Prophet (for 'Umra), and when the Quraish infidel intervened between us and the Ka'ba, the Prophet slaughtered his Hadi and shaved (his head), and his companions cut short their hair." Then 'Abdullah bin Umar said, "I make you witness that I have intended to perform 'Umra and if I am allowed to reach the Kaba, I will perform the Tawaf, and if something (i.e. obstacles) intervene between me and the Kaba, then I will do what Allah's Apostle did." Then after going for a while, he said, "I consider the ceremonies (of both 'Umra and Hajj as one and the same, so I would like you to witness that I have intended to perform Hajj along with my 'Umra." So he performed only one Tawaf and one Sai (between Safa and Marwa) and finished the Ihram of both Umra and Hajj).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.500]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 500

Narrated Nafi:

The people used to say that Ibn 'Umar had embraced Islam before 'Umar. This is not true. What happened is that 'Umar sent 'Abdullah to bring his horse from an Ansari man so as to fight on it. At that time the people were giving the Pledge of allegiance to Allah's Apostle near the Tree, and 'Umar was not aware of that. So Abdullah (bin Umar) gave the Pledge of Allegiance (to the Prophet) and went to take the horse and brought it to 'Umar. While 'Umar was putting on the armor to get ready for fighting, 'Abdullah informed him that the people were giving the Pledge of allegiance to Allah's Apostle beneath the Tree. So 'Umar set out and 'Abdullah accompanied him till he gave the Pledge of allegiance to Allah's Apostle, and it was this event that made people say that Ibn 'Umar had embraced Islam before 'Umar. "Abdullah bin 'Umar added, "The people were along with the Prophet on the day of Al-Hudaibiya spreading in the shade of the trees. Suddenly the people surrounded the Prophet and started looking at him." 'Umar said, "O 'Abdullah! Go and see why the people are encircling Allah's Apostle and looking at him." 'Abdullah bin Umar then saw the people giving the Pledge o allegiance to the Prophet. So he also gave the Pledge of allegiance and returned to 'Umar who went out in his turn and gave the Pledge of allegiance to the Prophet.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.501]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 501

Narrated 'Abdullah bin Abi Aufa:

We were in the company of the Prophet when he performed the 'Umra. He performed the Tawaf and we did the same; he offered the prayer and we also offered the prayer with him. Then he performed the Sai between Safa and Marwa and we were guarding him against the people of Mecca so that nobody should harm him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.502]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 502

Narrated Abu Wail:

When Sahl bin Hunaif returned from (the battle of) Siffin, we went to ask him (as to why he had come back). He replied, "(You should not consider me a coward) but blame your opinions. I saw myself on the day of Abu Jandal (inclined to fight), and if I had the power of refusing the order of Allah's Apostle then, I would have refused it (and fought the infidels bravely). Allah and His Apostle know (what is convenient) better. Whenever we put our swords on our shoulders for any matter that terrified us, our swords led us to an easy agreeable solution before the present situation (of disagreement and dispute between the Muslims). When we mend the breach in one side, it opened in another, and we do not know what to do about it."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.503]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 503

Narrated Kab bin Ujra:

The Prophet came to me at the time of Al-Hudaibiya Pledge while lice were falling on my face. He said, "Are the lice of your head troubling you?" I said, "Yes." He said, "Shave your head and fast for three days, or feed six poor persons, or slaughter a sheep as sacrifice." (The sub-narrator, Aiyub said, "I do not know with which of these three options he started.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.504]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 504

Narrated Ka'b bin Ujra:

We were in the company of Allah's Apostle at Al-Hudaibiya in the state of Ihram and the pagans did not allow us to proceed (to the Ka'ba). I had thick hair and lice started falling on my face. The Prophet passed by me and said, "Are the lice of your head troubling you?" I replied, Yes." (The sub-narrator added, "Then the following Divine Verse was revealed:-- "And if anyone of you is ill or has an ailment in his scalp, (necessitating shaving) must pay a ransom (Fida) of either fasting or feeding the poor, Or offering a sacrifice." (2.196)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.505]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 505

Narrated Anas:

Some people of the tribe of 'Ukl and 'Uraina arrived at Medina to meet the Prophet and embraced Islam and said, "O Allah's Prophet! We are the owners of milch livestock (i.e. bedouins) and not farmers (i.e. countrymen)." They found the climate of Medina unsuitable for them. So Allah's Apostle ordered that they should be provided with some milch camels and a shepherd and ordered them to go out of Medina and to drink the camels' milk and urine (as medicine) So they set out and when they reached Al-Harra, they reverted to Heathenism after embracing Islam, and killed the shepherd of the Prophet and drove away the camels. When this news reached the Prophet, he sent some people in pursuit of them. (So they were caught and brought back to the Prophet ). The Prophet gave his orders in their concern. So their eyes were branded with pieces of iron and their hands and legs were cut off and they were left away in Harra till they died in that state of theirs. (See Hadith 234 Vol 1)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.506]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 506

Narrated Abu Raja:

The freed slave of Abu Qilaba, who was with Abu Qilaba in Sham: 'Umar bin 'Abdul 'Aziz consulted the people saying, "What do you think of Qasama." They said, "'It is a right (judgment) which Allah's Apostle and the Caliphs before you acted on." Abu Qilaba was behind 'Umar's bed. 'Anbasa bin Said said, But what about the narration concerning the people of Uraina?" Abu Qilaba said, "Anas bin Malik narrated it to me," and then narrated the whole story.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.507]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 507

Narrated Salama bin Al-Akwa:

Once I went (from Medina) towards (Al-Ghaba) before the first Adhan of the Fajr Prayer. The she-camels of Allah's Apostle used to graze at a place called Dhi-Qarad. A slave of 'Abdur-Rahman bin 'Auf met me (on the way) and said, "The she-camels of Allah's Apostle had been taken away by force." I asked, "Who had taken them?" He replied "(The people of) Ghatafan." I made three loud cries (to the people of Medina) saying, "O Sabahah!" I made the people between the two mountains of Medina hear me. Then I rushed onward and caught up with the robbers while they were watering the camels. I started throwing arrows at them as I was a good archer and I was saying, "I am the son of Al-Akwa', and today will perish the wicked people." I kept on saying like that till I restored the she-camels (of the Prophet), I also snatched thirty Burda (i.e. garments) from them. Then the Prophet and the other people came there, and I said, "O Allah's Prophet! I have stopped the people (of Ghatafan) from taking water and they are thirsty now. So send (some people) after them now." On that the Prophet said, "O the son of Al-Akwa'! You have over-powered them, so forgive them." Then we all came back and Allah's Apostle seated me behind him on his she-camel till we entered Medina.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.508]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 508

Narrated Suwaid bin An-Numan:

I went out in the company of the Prophet in the year of Khaibar, and when we reached As Sahba' which is the lower part of Khaibar, the Prophet offered the Asr prayer and then asked the people to collect the journey food. Nothing was brought but Sawiq which the Prophet ordered to be moistened with water, and then he ate it and we also ate it. Then he got up to offer the Maghrib prayer. He washed his mouth, and we too washed our mouths, and then he offered the prayer without repeating his abulution.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.509]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 509

Narrated Salama bin Al-Akwa:

We went out to Khaibar in the company of the Prophet. While we were proceeding at night, a man from the group said to 'Amir, "O 'Amir! Won't you let us hear your poetry?" 'Amir was a poet, so he got down and started reciting for the people poetry that kept pace with the camels' footsteps, saying:-- "O Allah! Without You we Would not have been guided On the right path Neither would be have given In charity, nor would We have prayed. So please forgive us, what we have committed (i.e. our defects); let all of us Be sacrificed for Your Cause And send Sakina (i.e. calmness) Upon us to make our feet firm When we meet our enemy, and If they will call us towards An unjust thing, We will refuse. The infidels have made a hue and Cry to ask others' help Against us." The Prophet on that, asked, "Who is that (camel) driver (reciting poetry)?" The people said, "He is 'Amir bin Al-Akwa'."

Then the Prophet said, "May Allah bestow His Mercy on him." A man amongst the people said, "O Allah's Prophet! has (martyrdom) been granted to him. Would that you let us enjoy his company longer." Then we reached and besieged Khaibar till we were afflicted with severe hunger. Then Allah helped the Muslims conquer it (i.e. Khaibar). In the evening of the day of the conquest of the city, the Muslims made huge fires. The Prophet said, "What are these fires? For cooking what, are you making the fire?" The people replied, "(For cooking) meat." He asked, "What kind of meat?" They (i.e. people) said, "The meat of donkeys." The Prophet said, "Throw away the meat and break the pots!" Some man said, "O Allah's Apostle! Shall we throw away the meat and wash the pots instead?" He said, "(Yes, you can do) that too." So when the army files were arranged in rows (for the clash), 'Amir's sword was short and he aimed at the leg of a Jew to strike it, but the sharp blade of the sword returned to him and injured his own knee, and that caused him to die. When they returned from the battle, Allah's Apostle saw me (in a sad mood). He took my hand and said, "What is bothering you?" I replied, "Let my father and mother be sacrificed for you! The people say that the deeds of 'Amir are lost." The Prophet said, "Whoever says so, is mistaken, for 'Amir has got a double reward." The Prophet raised two fingers and added, "He (i.e. Amir) was a persevering struggler in the Cause of Allah and there are few 'Arabs who achieved the like of (good deeds) 'Amir had done."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.510]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 510

Narrated Anas:

Allah's Apostle reached Khaibar at night and it was his habit that, whenever he reached the enemy at night, he will not attack them till it was morning. When it was morning, the Jews came out with their spades and baskets, and when they saw him(i.e. the Prophet ), they said, "Muhammad! By Allah! Muhammad and his army!" The Prophet said, "Khaibar is destroyed, for whenever we approach a (hostile) nation (to fight), then evil will be the morning for those who have been warned."

Narrated Anas bin Malik: We reached Khaibar early in the morning and the inhabitants of Khaibar came out carrying their spades, and when they saw the Prophet they said, "Muhammad! By Allah! Muhammad and his army!" The Prophet said, "Allahu-Akbar! Khaibar is destroyed, for whenever we approach a (hostile) nation (to fight) then evil will be the morning for those who have been warned." We then got the meat of donkeys (and intended to eat it), but an announcement was made by the announcer of the Prophet, "Allah and His Apostle forbid you to eat the meat of donkeys as it is an impure thing."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.511]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 511

Narrated Anas bin Malik:

Someone came to Allah's Apostles and said, "The donkeys have been eaten (by the Muslims)." The Prophet kept quiet. Then the man came again and said, "The donkeys have been eaten." The Prophet kept quiet. The man came to him the third time and said, "The donkeys have been consumed." On that the Prophet ordered an announcer to announce to the people, "Allah and His Apostle forbid you to eat the meat of donkeys." Then the cooking pots were upset while the meat was still boiling in them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.512]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 512

Narrated Anas:

The Prophet offered the Fajr Prayer near Khaibar when it was still dark and then said, "Allahu-Akbar! Khaibar is destroyed, for whenever we approach a (hostile) nation (to fight), then evil will be the morning for those who have been warned." Then the inhabitants of Khaibar came out running on the roads. The Prophet had their warriors killed, their offspring and woman taken as captives. Safiya was amongst the captives, She first came in the share of Dahya Alkali but later on she belonged to the Prophet . The Prophet made her manumission as her 'Mahr'.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.513]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 513

Narrated 'Abdul 'Aziz bin Suhaib:

Anas bin Malik said, "The Prophet took Safiya as a captive. He manumitted her and married her." Thabit asked Anas, "What did he give her as Mahr (i.e. marriage gift)?" Anas replied. "Her Mahr was herself, for he manumitted her."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.514]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 514

Narrated Sahl bin Sad As Saidi:

Allah's Apostle (and his army) encountered the pagans and the two armies.,, fought and then Allah's Apostle returned to his army camps and the others (i.e. the enemy) returned to their army camps. Amongst the companions of the Prophet there was a man who could not help pursuing any single isolated pagan to strike him with his sword. Somebody said, "None has benefited the Muslims today more than so-and-so." On that Allah's Apostle said, "He is from the people of the Hell-Fire certainly." A man amongst the people (i.e. Muslims) said, "I will accompany him (to know the fact)." So he went along with him, and whenever he stopped he stopped with him, and whenever he hastened, he hastened with him. The (brave) man then got wounded severely, and seeking to die at once, he planted his sword into the ground and put its point against his chest in between his breasts, and then threw himself on it and committed suicide. On that the person (who was accompanying the deceased all the time) came to Allah's Apostle and said, "I testify that you are the Apostle of Allah." The Prophet said, "Why is that (what makes you say so)?" He said "It is concerning the man whom you have already mentioned as one of the dwellers of the Hell-Fire. The people were surprised by your statement, and I said to them, "I will try to find out the truth about him for you." So I went out after him and he was then inflicted with a severe wound and because of that, he hurried to bring death upon himself by planting the handle of his sword into the ground and directing its tip towards his chest between his breasts, and then he threw himself over it and committed suicide." Allah's Apostle then said, "A man may do what seem to the people as the deeds of the dwellers of Paradise but he is from the dwellers of the Hell-Fire and another may do what seem to the people as the deeds of the dwellers of the Hell-Fire, but he is from the dwellers of Paradise."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.515]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 515

Narrated Abu Huraira:

We witnessed (the battle of) Khaibar. Allah's Apostle said about one of those who were with him and who claimed to be a Muslim. "This (man) is from the dwellers of the Hell-Fire." When the battle started, that fellow fought so violently and bravely that he received plenty of wounds. Some of the people were about to doubt (the Prophet's statement), but the man, feeling the pain of his wounds, put his hand into his quiver and took out of it, some arrows with which he slaughtered himself (i.e. committed suicide). Then some men amongst the Muslims came hurriedly and said, "O Allah's Apostle! Allah has made your statement true so-and-so has committed suicide. "The Prophet said, "O so-and-so! Get up and make an announcement that none but a believer will enter Paradise and that Allah may support the religion with an unchaste (evil) wicked man.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.516]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 516

Narrated Abu Musa Al-Ashari:

When Allah's Apostle fought the battle of Khaibar, or when Allah's Apostle went towards it, (whenever) the people, (passed over a high place overlooking a valley, they raised their voices saying, "Allahu-Akbar! Allahu-Akbar! None has the right to be worshipped except Allah." On that Allah's Apostle said (to them), "Lower your voices, for you are not calling a deaf or an absent one, but you are calling a Hearer Who is near and is with you." I was behind the riding animal of Allah's Apostle and he heard me saying. "There Is neither might, nor power but with Allah," On that he said to me, "O Abdullah bin Qais!" I said, "Labbaik. O Allah's Apostle!" He said, "Shall I tell you a sentence which is one of the treasures of Paradise" I said, "Yes, O Allah's Apostle! Let my father and mother be sacrificed for your sake." He said, "It is: There is neither might nor power but with Allah."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.517]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 517

Narrated Yazid bin Abi Ubaid:

I saw the trace of a wound in Salama's leg. I said to him, "O Abu Muslim! What is this wound?" He said, "This was inflicted on me on the day of Khaibar and the people said, 'Salama has been wounded.' Then I went to the Prophet and he puffed his saliva in it (i.e. the wound) thrice., and since then I have not had any pain in it till this hour."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.518]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 518

Narrated Sahl:

During one of his Ghazawat, the Prophet encountered the pagans, and the two armies fought, and then each of them returned to their army camps. Amongst the (army of the) Muslims there was a man who would follow every pagan separated from the army and strike him with his sword. It was said, "O Allah's Apostle! None has fought so satisfactorily as so-and-so (namely, that brave Muslim). "The Prophet said, "He is from the dwellers of the Hell-Fire." The people said, "Who amongst us will be of the dwellers of Paradise if this (man) is from the dwellers of the Hell-Fire?" Then a man from amongst the people said, "I will follow him and accompany him in his fast and slow movements." The (brave) man got wounded, and wanting to die at once, he put the handle of his sword on the ground and its tip in between his breasts, and then threw himself over it, committing suicide. Then the man (who had watched the deceased) returned to the Prophet and said, "I testify that you are Apostle of Allah." The Prophet said, "What is this?" The man told him the whole story. The Prophet said, "A man may do what may seem to the people as the deeds of the dwellers of Paradise, but he is of the dwellers of the Hell-Fire and a man may do what may seem to the people as the deeds of the dwellers of the Hell-Fire, but he is from the dwellers of Paradise."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.519]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 519

Narrated Abu Imran:

Anas looked at the people wearing Tailsans (i.e. a special kind of head covering worn by Jews in old days). On that Anas said, "At this moment they (i.e. those people) look like the Jews of Khaibar."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.520]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 520

Narrated Salama:

Ali remained behind the Prophet during the Ghazwa of Khaibar as he was suffering from eye trouble. He then said, "(How can) I remain behind the Prophet ," and followed him. So when he slept on the night of the conquest of Khaibar, the Prophet said, "I will give the flag tomorrow, or tomorrow the flag will be taken by a man who is loved by Allah and His Apostle , and (Khaibar) will be conquered through him, (with Allah's help)" While every one of us was hopeful to have the flag, it was said, "Here is 'Ali" and the Prophet gave him the flag and Khaibar was conquered through him (with Allah's Help).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.521]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 521

Narrated Sahl bin Sad:

On the day of Khaibar, Allah's Apostle said, "Tomorrow I will give this flag to a man through whose hands Allah will give us victory. He loves Allah and His Apostle, and he is loved by Allah and His Apostle." The people remained that night, wondering as to who would be given it. In the morning the people went to Allah's Apostle and everyone of them was hopeful to receive it (i.e. the flag). The Prophet said, "Where is Ali bin Abi Talib?" It was said, "He is suffering from eye trouble O Allah's Apostle." He said, "Send for him." 'Ali was brought and Allah's Apostle spat in his eye and invoked good upon him. So 'Ali was cured as if he never had any trouble. Then the Prophet gave him the flag. 'Ali said "O Allah's Apostle! I will fight with them till they become like us." Allah's Apostle said, "Proceed and do not hurry. When you enter their territory, call them to embrace Islam and inform them of Allah's Rights which they should observe, for by Allah, even if a single man is led on the right path (of Islam) by Allah through you, then that will be better for you than the nice red camels.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.522]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 522

Narrated Anas bin Malik:

We arrived at Khaibar, and when Allah helped His Apostle to open the fort, the beauty of Safiya bint Huyai bin Akhtaq whose husband had been killed while she was a bride, was mentioned to Allah's Apostle. The Prophet selected her for himself, and set out with her, and when we reached a place called Sidd-as-Sahba,' Safiya became clean from her menses then Allah's Apostle married her. Hais (i.e. an 'Arabian dish) was prepared on a small leather mat. Then the Prophet said to me, "I invite the people around you." So that was the marriage banquet of the Prophet and Safiya. Then we proceeded towards Medina, and I saw the Prophet, making for her a kind of cushion with his cloak behind him (on his camel). He then sat beside his camel and put his knee for Safiya to put her foot on, in order to ride (on the camel).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.523]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 523

Narrated Anas bin Malik:

The Prophet stayed with Safiya bint Huyai for three days on the way of Khaibar where he consummated his marriage with her. Safiya was amongst those who were ordered to use a veil.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.524]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 524

Narrated Anas:

The Prophet stayed for three rights between Khaibar and Medina and was married to Safiya. I invited the Muslim to h s marriage banquet and there wa neither meat nor bread in that banquet but the Prophet ordered Bilal to spread the leather mats on which dates, dried yogurt and butter were put. The Muslims said amongst themselves, "Will she (i.e. Safiya) be one of the mothers of the believers, (i.e. one of the wives of the Prophet ) or just (a lady captive) of what his right-hand possesses" Some of them said, "If the Prophet makes her observe the veil, then she will be one of the mothers of the believers (i.e. one of the Prophet's wives), and if he does not make her observe the veil, then she will be his lady slave." So when he departed, he made a place for her behind him (on his and made her observe the veil.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.525]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 525

Narrated 'Abdullah bin Mughaffal:

While we were besieging Khaibar, a person threw a leather container containing some fat and I ran to take it. Suddenly I looked behind, and behold! The Prophet was there. So I felt shy (to take it then).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.526]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 526

Narrated Ibn Umar:

On the day of Khaiber, Allah's Apostle forbade the eating of garlic and the meat of donkeys.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.527]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 527

Narrated 'Ali bin Abi Talib:

On the day of Khaibar, Allah's Apostle forbade the Mut'a (i.e. temporary marriage) and the eating of donkey-meat.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.528]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 528

Narrated Ibn Umar:

On the day of Khaibar, Allah's Apostle forbade the eating of donkey meat.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.529]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 529

Narrated Ibn Umar:

Allah's Apostle forbade the eating of donkey-meat.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.530]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 530

Narrated Jabir bin Abdullah:

On the day of Khaibar, Allah's Apostle forbade the eating of donkey meat and allowed the eating of horse meat.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.531]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 531

Narrated Ibn Abi Aufa:

We where afflicted with severe hunger on the day of Khaibar. While the cooking pots were boiling and some of the food was well-cooked, the announcer of the Prophet came to say, "Do not eat anything the donkey-meat and upset the cooking pots." We then thought that the Prophet had prohibited such food because the Khumus had not been taken out of it. Some others said, "He prohibited the meat of donkeys from the point of view of principle, because donkeys used to eat dirty things."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.532]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 532

Narrated Al-Bara and 'Abdullah bin Abl Aufa:

That when they were in the company of the Prophet, they got some donkeys which they (slaughtered and) cooked. Then the announcer of the Prophet said, "Turn the cooking pots upside down (i.e. throw out the meat)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.533]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 533

Narrated Al-Bara' and Ibn Abi Aufa:

On the day of Khaibar when the cooking pots were put on the fire, the Prophet said, "Turn the cooking pots upside down."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.534]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 534

Narrated Al-Bara:

We took part in a Ghazwa with the Prophet (same as Hadith No. 533).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.535]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 535

Narrated Al-Bara Bin Azib:

During the Ghazwa of Khaibar, the Prophet ordered us to throw away the meat of the donkeys whether it was still raw or cooked. He did not allow us to eat it later on.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.536]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 536

Narrated Ibn Abbas:

I do not know whether the Prophet forbade the eating of donkey-meat (temporarily) because they were the beasts of burden for the people, and he disliked that their means of transportation should be lost, or he forbade it on the day of Khaibar permanently.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.537]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 537

Narrated Ibn 'Umar:

On the day of Khaibar, Allah's Apostle divided (the war booty of Khaibar) with the ratio of two shares for the horse and one-share for the foot soldier. (The sub-narrator, Nafi' explained this, saying, "If a man had a horse, he was given three shares and if he had no horse, then he was given one share.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.538]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 538

Narrated Jubair bin Mutim:

Uthman bin 'Affan and I went to the Prophet and said, "You had given Banu Al-Muttalib from the Khumus of Khaibar's booty and left us in spite of the fact that we and Banu Al-Muttalib are similarly related to you." The Prophet said, "Banu Hashim and Banu Al-Muttalib only are one and the same." So the Prophet did not give anything to Banu Abd Shams and Banu Nawfal.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.539]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 539

Narrated Abu Musa:

The news of the migration of the Prophet (from Mecca to Medina) reached us while we were in Yemen. So we set out as emigrants towards him. We were (three) I and my two brothers. I was the youngest of them, and one of the two was Abu Burda, and the other, Abu Ruhm, and our total number was either 53 or 52 men from my people. We got on board a boat and our boat took us to Negus in Ethiopia. There we met Ja'far bin Abi Talib and stayed with him. Then we all came (to Medina) and met the Prophet at the time of the conquest of Khaibar. Some of the people used to say to us, namely the people of the ship, "We have migrated before you." Asma' bint 'Umais who was one of those who had come with us, came as a visitor to Hafsa, the wife the Prophet . She had migrated along with those other Muslims who migrated to Negus. 'Umar came to Hafsa while Asma' bint 'Umais was with her. 'Umar, on seeing Asma,' said, "Who is this?" She said, "Asma' bint 'Umais," 'Umar said, "Is she the Ethiopian? Is she the sea-faring lady?" Asma' replied, "Yes." 'Umar said, "We have migrated before you (people of the boat), so we have got more right than you over Allah's Apostle " On that Asma' became angry and said, "No, by Allah, while you were with Allah's Apostle who was feeding the hungry ones amongst you, and advised the ignorant ones amongst you, we were in the far-off hated land of Ethiopia, and all that was for the sake of Allah's Apostle . By Allah, I will neither eat any food nor drink anything till I inform Allah's Apostle of all that you have said. There we were harmed and frightened. I will mention this to the Prophet and will not tell a lie or curtail your saying or add something to it." So when the Prophet came, she said, "O Allah's Prophet 'Umar has said so-and-so." He said (to Asma'), "What did you say to him?" Asma's aid, "I told him so-and-so." The Prophet said, "He (i.e. 'Umar) has not got more right than you people over me, as he and his companions have (the reward of) only one migration, and you, the people of the boat, have (the reward of) two migrations." Asma' later on said, "I saw Abu Musa and the other people of the boat coming to me in successive groups, asking me about this narration,, and to them nothing in the world was more cheerful and greater than what the Prophet had said about them."

Narrated Abu Burda: Asma' said, "I saw Abu Musa requesting me to repeat this narration again and again."

Narrated Abu Burda: Abu Musa said, "The Prophet said, "I recognize the voice of the group of Al-Ashariyun, when they recite the Qur'an, when they enter their homes at night, and I recognize their houses by (listening) to their voices when they are reciting the Qur'an at night although I have not seen their houses when they came to them during the day time. Amongst them is Hakim who, on meeting the cavalry or the enemy, used to say to them (i.e. the enemy). My companions order you to wait for them.' "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.540]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 540

Narrated Abu Musa:

We came upon the Prophet after he had conquered Khaibar. He then gave us a share (from the booty), but apart from us he did not give to anybody else who did not attend the Conquest.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.541]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 541

Narrated Abu Huraira:

When we conquered Khaibar, we gained neither gold nor silver as booty, but we gained cows, camels, goods and gardens. Then we departed with Allah's Apostle to the valley of Al-Qira, and at that time Allah's Apostle had a slave called Mid'am who had been presented to him by one of Banu Ad-Dibbab. While the slave was dismounting the saddle of Allah's Apostle an arrow the thrower of which was unknown, came and hit him. The people said, "Congratulations to him for the martyrdom." Allah's Apostle said, "No, by Him in Whose Hand my soul is, the sheet (of cloth) which he had taken (illegally) on the day of Khaibar from the booty before the distribution of the booty, has become a flame of Fire burning him." On hearing that, a man brought one or two leather straps of shoes to the Prophet and said, "These are things I took (illegally)." On that Allah's Apostle said, "This is a strap, or these are two straps of Fire."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.542]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 542

Narrated 'Umar bin Al-Khattab:

By Him in Whose Hand my soul is, were I not afraid that the other Muslims might be left in poverty, I would divide (the land of) whatever village I may conquer (among the fighters), as the Prophet divided the land of Khaibar. But I prefer to leave it as a (source of) a common treasury for them to distribute it revenue amongst themselves.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.543]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 543

Narrated 'Umar:

But for the other Muslims (i.e. coming generations) I would divide (the land of) whatever villages the Muslims might conquer (among the fighters), as the Prophet divided (the land of) Khaibar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.544]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 544

Narrated 'Anbasa bin Said:

Abu Huraira came to the Prophet and asked him (for a share from the Khaibar booty). On that, one of the sons of Said bin Al-'As said to him, "O Allah's Apostle! Do not give him." Abu Huraira then said (to the Prophet ) "This is the murderer of Ibn Qauqal." Sa'id's son said, "How strange! A guinea pig coming from Qadum Ad-Dan!"

Narrated Abu Huraira: Allah's Apostle sent Aban from Medina to Najd as the commander of a Sariya. Aban and his companions came to the Prophet at Khaibar after the Prophet had conquered it, and the reins of their horses were made of the fire of date palm trees. I said, "O Allah's Apostle! Do not give them a share of the booty." on, that, Aban said (to me), "Strange! You suggest such a thing though you are what you are, O guinea pig coming down from the top of Ad-Dal (a lotus tree)! "On that the Prophet said, "O Aban, sit down ! " and did not give them any share.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.545]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 545

Narrated Said:

Aban bin Said came to the Prophet and greeted him. Abu Huraira said, "O Allah's Apostle! This (Aban) is the murderer of the Ibn Qauqal." (On hearing that), Aban said to Abu Huraira, "How strange your saying is! You, a guinea pig, descending from Qadum Dan, blaming me for (killing) a person whom Allah favored (with martyrdom) with my hand, and whom He forbade to degrade me with his hand.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.546]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 546

Narrated 'Aisha:

Fatima the daughter of the Prophet sent someone to Abu Bakr (when he was a caliph), asking for her inheritance of what Allah's Apostle had left of the property bestowed on him by Allah from the Fai (i.e. booty gained without fighting) in Medina, and Fadak, and what remained of the Khumus of the Khaibar booty. On that, Abu Bakr said, "Allah's Apostle said, "Our property is not inherited. Whatever we leave, is Sadaqa, but the family of (the Prophet) Muhammad can eat of this property.' By Allah, I will not make any change in the state of the Sadaqa of Allah's Apostle and will leave it as it was during the lifetime of Allah's Apostle, and will dispose of it as Allah's Apostle used to do." So Abu Bakr refused to give anything of that to Fatima. So she became angry with Abu Bakr and kept away from him, and did not task to him till she died. She remained alive for six months after the death of the Prophet. When she died, her husband 'Ali, buried her at night without informing Abu Bakr and he said the funeral prayer by himself. When Fatima was alive, the people used to respect 'Ali much, but after her death, 'Ali noticed a change in the people's attitude towards him. So Ali sought reconciliation with Abu Bakr and gave him an oath of allegiance. 'Ali had not given the oath of allegiance during those months (i.e. the period between the Prophet's death and Fatima's death). 'Ali sent someone to Abu Bakr saying, "Come to us, but let nobody come with you," as he disliked that 'Umar should come, 'Umar said (to Abu Bakr), "No, by Allah, you shall not enter upon them alone " Abu Bakr said, "What do you think they will do to me? By Allah, I will go to them' So Abu Bakr entered upon them, and then 'Ali uttered Tashah-hud and said (to Abu Bakr), "We know well your superiority and what Allah has given you, and we are not jealous of the good what Allah has bestowed upon you, but you did not consult us in the question of the rule and we thought that we have got a right in it because of our near relationship to Allah's Apostle ."

Thereupon Abu Bakr's eyes flowed with tears. And when Abu Bakr spoke, he said, "By Him in Whose Hand my soul is to keep good relations with the relatives of Allah's Apostle is dearer to me than to keep good relations with my own relatives. But as for the trouble which arose between me and you about his property, I will do my best to spend it according to what is good, and will not leave any rule or regulation which I saw Allah's Apostle following, in disposing of it, but I will follow." On that 'Ali said to Abu Bakr, "I promise to give you the oath of allegiance in this after noon." So when Abu Bakr had offered the Zuhr prayer, he ascended the pulpit and uttered the Tashah-hud and then mentioned the story of 'Ali and his failure to give the oath of allegiance, and excused him, accepting what excuses he had offered; Then 'Ali (got up) and praying (to Allah) for forgiveness, he uttered Tashah-hud, praised Abu Bakr's right, and said, that he had not done what he had done because of jealousy of Abu Bakr or as a protest of that Allah had favored him with. 'Ali added, "But we used to consider that we too had some right in this affair (of rulership) and that he (i.e. Abu Bakr) did not consult us in this matter, and therefore caused us to feel sorry." On that all the Muslims became happy and said, "You have done the right thing." The Muslims then became friendly with 'Ali as he returned to what the people had done (i.e. giving the oath of allegiance to Abu Bakr).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.547]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 547

Narrated 'Aisha:

When Khaibar was conquered, we said, "Now we will eat our fill of dates!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.548]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 548

Narrated Ibn Umar:

We did not eat our fill except after we had conquered Khaibar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.549]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 549

Narrated Abu Said Al-Khudri and Abu Huraira:

Allah's Apostle appointed a man as the ruler of Khaibar who later brought some Janib (i.e. dates of good quality) to the Prophet. On that, Allah's Apostle said (to him). "Are all the dates of Khaibar like this?" He said, "No, by Allah, O Allah's Apostle! But we take one Sa of these (dates of good quality) for two or three Sa's of other dates (of inferior quality)." On that, Allah's Apostle said, "Do not do so, but first sell the inferior quality dates for money and then with that money, buy Janib." Abu Said and Abu Huraira said, "The Prophet made the brother of Bani Adi from the Ansar as the ruler of Khaibar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.550]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 550

Narrated 'Abdullah:

The Prophet gave (the land of) Khaibar to the Jews (of Khaibar) on condition that they would work on it and cultivate it and they would have half of its yield.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.551]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 551

Narrated Abu Huraira:

When Khaibar was conquered, a (cooked) sheep containing poison, was given as a present to Allah's Apostle


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.552]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 552

Narrated Ibn Umar:

Allah's Apostle appointed Usama bin Zaid as the commander of some people. Those people criticized his leadership. The Prophet said, "If you speak ill of his leadership, you have already spoken ill of his father's leadership before. By Allah, he deserved to be a Commander, and he was one of the most beloved persons to me and now this (i.e. Usama) is one of the most beloved persons to me after him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.553]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 553

Narrated Al-Bara:

When the Prophet went out for the 'Umra in the month of Dhal-Qa'da, the people of Mecca did not allow him to enter Mecca till he agreed to conclude a peace treaty with them by virtue of which he would stay in Mecca for three days only (in the following year). When the agreement was being written, the Muslims wrote: "This is the peace treaty, which Muhammad, Apostle of Allah has concluded."

The infidels said (to the Prophet), "We do not agree with you on this, for if we knew that you are Apostle of Allah we would not have prevented you for anything (i.e. entering Mecca, etc.), but you are Muhammad, the son of 'Abdullah." Then he said to 'Ali, "Erase (the name of) 'Apostle of Allah'." 'Ali said, "No, by Allah, I will never erase you (i.e. your name)." Then Allah's Apostle took the writing sheet...and he did not know a better writing..and he wrote or got it the following written! "This is the peace treaty which Muhammad, the son of 'Abdullah, has concluded: "Muhammad should not bring arms into Mecca except sheathed swords, and should not take with him any person of the people of Mecca even if such a person wanted to follow him, and if any of his companions wants to stay in Mecca, he should not forbid him."

(In the next year) when the Prophet entered Mecca and the allowed period of stay elapsed, the infidels came to Ali and said "Tell your companion (Muhammad) to go out, as the allowed period of his stay has finished." So the Prophet departed (from Mecca) and the daughter of Hamza followed him shouting "O Uncle, O Uncle!" Ali took her by the hand and said to Fatima, "Take the daughter of your uncle." So she made her ride (on her horse). (When they reached Medina) 'Ali, Zaid and Ja'far quarreled about her. 'Ali said, "I took her for she is the daughter of my uncle." Ja'far said, "She is the daughter of my uncle and her aunt is my wife." Zaid said, "She is the daughter of my brother." On that, the Prophet gave her to her aunt and said, "The aunt is of the same status as the mother." He then said to 'Ali, "You are from me, and I am from you," and said to Ja'far, "You resemble me in appearance and character," and said to Zaid, "You are our brother and our freed slave." 'Ali said to the Prophet 'Won't you marry the daughter of Hamza?" The Prophet said, "She is the daughter of my foster brother."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.554]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 554

Narrated Ibn 'Umar:

Allah's Apostle set out with the intention of performing 'Umra, but the infidels of Quraish intervened between him and the Ka'ba, so the Prophet slaughtered his Hadi (i.e. sacrificing animals and shaved his head at Al-Hudaibiya and concluded a peace treaty with them (i.e. the infidels) on condition that he would perform the 'Umra the next year and that he would not carry arms against them except swords, and would not stay (in Mecca) more than what they would allow. So the Prophet performed the 'Umra in the following year and according to the peace treaty, he entered Mecca, and when he had stayed there for three days, the infidels ordered him to leave, and he left.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.555]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 555

Narrated Mujahid:

'Urwa and I entered the Mosque and found 'Abdullah bin 'Umar sitting beside the dwelling place of 'Aisha. 'Urwa asked (Ibn 'Umar), "How many 'Umras did the Prophet perform?" Ibn 'Umar replied, "Four, one of which was in Rajab." Then we heard 'Aisha brushing her teeth whereupon 'Urwa said, "O mother of the believers! Don't you hear what Abu 'Abdur-Rahman is saying? He is saying that the Prophet performed four 'Umra, one of which was in Rajab." 'Aisha said, "The Prophet did not perform any 'Umra but he (i.e. Ibn 'Umar) witnessed it. And he (the Prophet ) never did any 'Umra in (the month of) Rajab."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.556]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 556

Narrated Ibn Abi Aufa:

When Allah's Apostle performed the 'Umra (which he performed in the year following the treaty of Al-Hudaibiya) we were screening Allah's Apostle from the infidels and their boys lest they should harm him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.557]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 557

Narrated Ibn Abbas:

When Allah's Apostle and his companions arrived (at Mecca), the pagans said, "There have come to you a group of people who have been weakened by the fever of Yathrib (i.e. Medina)." So the Prophet ordered his companions to do Ramal (i.e. fast walking) in the first three rounds of Tawaf around the Ka'ba and to walk in between the two corners (i.e. the black stone and the Yemenite corner). The only cause which prevented the Prophet from ordering them to do Ramal in all the rounds of Tawaf, was that he pitied them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.558]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 558

Narrated Ibn Abbas:

The Prophet hastened in going around the Ka'ba and between the Safa and Marwa in order to show the pagans his strength. Ibn 'Abbas added, "When the Prophet arrived (at Mecca) in the year of peace (following that of Al-Hudaibiya treaty with the pagans of Mecca), he (ordered his companions) to do Ramal in order to show their strength to the pagans and the pagans were watching (the Muslims) from (the hill of) Quaiqan.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.559]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 559

Narrated Ibn Abbas:

The Prophet married Maimuna while he was in the state of lhram but he consummated that marriage after finishing that state. Maimuna died at Saraf (i.e. a place near Mecca). Ibn 'Abbas added, The Prophet married Maimuna during the 'Umrat-al-Qada' (i.e. the 'Umra performed in lieu of the 'Umra which the Prophet could not perform because the pagans, prevented him to perform that 'Umra)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.560]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 560

Narrated Nafi:

Ibn 'Umar informed me that on the day (of Mu'tah) he stood beside Ja'far who was dead (i.e. killed in the battle), and he counted fifty wounds in his body, caused by stabs or strokes, and none of those wounds was in his back.

'Abdullah bin 'Umar said, "Allah's Apostle appointed Zaid bin Haritha as the commander of the army during the Ghazwa of Mu'tah and said, "If Zaid is martyred, Ja'far should take over his position, and if Ja'far is martyred, 'Abdullah bin Rawaha should take over his position.' " 'Abdulla-h bin 'Umar further said, "I was present amongst them in that battle and we searched for Ja'far bin Abi Talib and found his body amongst the bodies of the martyred ones, and found over ninety wounds over his body, caused by stabs or shots (of arrows).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.561]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 561

Narrated Anas:

The Prophet had informed the people of the martyrdom of Zaid, Ja'far and Ibn Rawaha before the news of their death reached. The Prophet said, "Zaid took the flag (as the commander of the army) and was martyred, then Ja'far took it and was martyred, and then Ibn Rawaha took it and was martyred." At that time the Prophet's eyes were shedding tears. He added, "Then the flag was taken by a Sword amongst the Swords of Allah (i.e. Khalid) and Allah made them (i.e. the Muslims) victorious."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.562]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 562

Narrated 'Amra:

I heard 'Aisha saying, "When the news of the martyrdom of Ibn Haritha, Ja'far bin Abi Talib and 'Abdullah bin Rawaka reached, Allah's Apostle sat with sorrow explicit on his face." 'Aisha added, "I was then peeping through a chink in the door. A man came to him and said, "O Allah's Apostle! The women of Ja'far are crying.' Thereupon the Prophet told him to forbid them to do so. So the man went away and returned saying, "I forbade them but they did not listen to me." The Prophet ordered him again to go (and forbid them). He went again and came saying, 'By Allah, they overpowered me (i.e. did not listen to me)." 'Aisha said that Allah's Apostle said (to him), "Go and throw dust into their mouths." Aisha added, "I said, May Allah put your nose in the dust! By Allah, neither have you done what you have been ordered, nor have you relieved Allah's Apostle from trouble."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.563]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 563

Narrated 'Amir:

Whenever Ibn 'Umar greeted the son of Ja'far, he used to say (to him), "Assalam 'Alaika (i.e. peace be on you) O the son of two-winged person."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.564]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 564

Narrated Khalid bin Al-Walid:

On the day (of the battle of) Mu'tah, nine swords were broken in my hand, and nothing was left in my hand except a Yemenite sword of mine.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.565]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 565

Narrated Khalid bin Al-Walid:

On the day of Mu'tah, nine swords were broken in my hand and only a Yemenite sword of mine remained in my hand.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.566]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 566

Narrated An-Nu'man bin Bashir:

Abdullah bin Rawaha fell down unconscious and his sister 'Amra started crying and was saying loudly, "O Jabala! Oh so-and-so! Oh so-and-so! and went on calling him by his (good ) qualities one by one). When he came to his senses, he said (to his sister), "When-ever you said something, I was asked, 'Are you really so (i.e. as she says)?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.567]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 567

Narrated Ash Shabi:

An Nu'man bin Bashir said, "Abdullah bin Rawaha fell down unconscious.." (and mentioned the above Hadith adding, "Thereupon, when he died she (i.e. his sister) did not weep over him."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.568]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 568

Narrated Usama bin Zaid:

Allah's Apostle sent us towards Al-Huruqa, and in the morning we attacked them and defeated them. I and an Ansari man followed a man from among them and when we took him over, he said, "La ilaha illal-Lah." On hearing that, the Ansari man stopped, but I killed him by stabbing him with my spear. When we returned, the Prophet came to know about that and he said, "O Usama! Did you kill him after he had said "La ilaha ilal-Lah?" I said, "But he said so only to save himself." The Prophet kept on repeating that so often that I wished I had not embraced Islam before that day.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.569]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 569

Narrated Salama bin Al-Akwa:

I fought in seven Ghazwat (i.e. battles) along with the Prophet and fought in nine battles, fought by armies dispatched by the Prophet. Once Abu Bakr was our commander and at another time, Usama was our commander.

Narrated Salama in another narration: I fought seven Ghazwat (i.e. battles) along with the Prophet and also fought in nine battles, fought by armies sent by the Prophet . Once Abu Bakr was our commander and another time, Usama was (our commander).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.570]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 570

Narrated Salama bin Al-Akwa:

I fought in nine Ghazwa-t along with the Prophet, I also fought along with Ibn Haritha when the Prophet made him our commander.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.571]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 571

Narrated Yazid bin Abi Ubaid:

Salama bin Al-Akwa' said, "I fought in seven Ghazwat along with the Prophet." He then mentioned Khaibar, Al-Hudaibiya, the day (i.e. battle) of Hunain and the day of Al-Qurad. I forgot the names of the other Ghazwat.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.572]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 572

Narrated 'Ali:

Allah's Apostle sent me, Az-Zubair and Al-Miqdad saying, "Proceed till you reach Rawdat Khakh where there is a lady carrying a letter, and take that (letter) from her." So we proceeded on our way with our horses galloping till we reached the Rawda, and there we found the lady and said to her, "Take out the letter." She said, "I have no letter." We said, "Take out the letter, or else we will take off your clothes." So she took it out of her braid, and we brought the letter to Allah's Apostle . The letter was addressed from Hatib, bin Abi Balta'a to some pagans of Mecca, telling them about what Allah's Apostle intended to do. Allah's Apostle said, "O Hatib! What is this?" Hatib replied, "O Allah's Apostle! Do not make a hasty decision about me. I was a person not belonging to Quraish but I was an ally to them from outside and had no blood relation with them, and all the Emigrants who were with you, have got their kinsmen (in Mecca) who can protect their families and properties. So I liked to do them a favor so that they might protect my relatives as I have no blood relation with them. I did not do this to renegade from my religion (i.e. Islam) nor did I do it to choose Heathenism after Islam." Allah's Apostle said to his companions." As regards him, he (i.e. Hatib) has told you the truth." 'Umar said, "O Allah's Apostle! Allow me to chop off the head of this hypocrite!" The Prophet said, "He (i.e. Hatib) has witnessed the Badr battle (i.e. fought in it) and what could tell you, perhaps Allah looked at those who witnessed Badr and said, "O the people of Badr (i.e. Badr Muslim warriors), do what you like, for I have forgiven you. "Then Allah revealed the Sura:--

"O you who believe! Take not my enemies And your enemies as friends offering them (Your) love even though they have disbelieved in that Truth (i.e. Allah, Prophet Muhammad and this Quran) which has come to you ....(to the end of Verse)....(And whosoever of you (Muslims) does that, then indeed he has gone (far) astray (away) from the Straight Path." (60.1


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.573]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 573

Narrated Ubaidullah bin Abdullah bin 'Utba:

Ibn Abbas said, Allah's Apostle fought the Ghazwa (i.e. battles of Al-Fath during Ramadan."

Narrated Az-Zuhri: Ibn Al-Musaiyab (also) said the same. Ibn Abbas added, "The Prophet fasted and when he reached Al-Kadid, a place where there is water between Kudaid and 'Usfan, he broke his fast and did not fast afterwards till the whole month had passed away.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.574]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 574

Narrated Ibn Abbas :

The Prophet left Medina (for Mecca) in the company of ten-thousand (Muslim warriors) in (the month of) Ramadan, and that was eight and a half years after his migration to Medina. He and the Muslims who were with him, proceeded on their way to Mecca. He was fasting and they were fasting, but when they reached a place called Al-Kadid which was a place of water between 'Usfan and Kudaid, he broke his fast and so did they. (Az-Zuhri said, "One should take the last action of Allah's Apostle and leave his early action (while taking a verdict.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.575]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 575

Narrated Ibn Abbas:

Allah's Apostle set out towards Hunain in the month of Ramadan and some of the people were fasting while some others were not fasting, and when the Prophet mounted his she-camel, he asked for a tumbler of milk or water and put it on the palm of his hand or on his she-camel and then the people looked at him; and those who were not fasting told those who were fasting, to break their fast (i.e. as the Prophet had done so). Ibn Abbas added, "The Prophet went (to Hunain) in the year of the Conquest (of Mecca)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.576]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 576

Narrated Tawus:

Ibn Abbas said, "Allah's Apostle travelled in the month of Ramadan and he fasted till he reached (a place called) 'Usfan, then he asked for a tumbler of water and drank it by the daytime so that the people might see him. He broke his fast till he reached Mecca." Ibn Abbas used to say, "Allah's Apostle fasted and sometimes did not fast while traveling, so one may fast or may not (on journeys)"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.577]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 577

Narrated Hisham's father:

When Allah's Apostle set out (towards Mecca) during the year of the Conquest (of Mecca) and this news reached (the infidels of Quraish), Abu Sufyan, Hakim bin Hizam and Budail bin Warqa came out to gather information about Allah's Apostle , They proceeded on their way till they reached a place called Marr-az-Zahran (which is near Mecca). Behold! There they saw many fires as if they were the fires of Arafat. Abu Sufyan said, "What is this? It looked like the fires of Arafat." Budail bin Warqa' said, "Banu 'Amr are less in number than that." Some of the guards of Allah's Apostle saw them and took them over, caught them and brought them to Allah's Apostle. Abu Sufyan embraced Islam.

When the Prophet proceeded, he said to Al-Abbas, "Keep Abu Sufyan standing at the top of the mountain so that he would look at the Muslims. So Al-'Abbas kept him standing (at that place) and the tribes with the Prophet started passing in front of Abu Sufyan in military batches. A batch passed and Abu Sufyan said, "O 'Abbas Who are these?" 'Abbas said, "They are (Banu) Ghifar." Abu Sufyan said, I have got nothing to do with Ghifar." Then (a batch of the tribe of) Juhaina passed by and he said similarly as above. Then (a batch of the tribe of) Sad bin Huzaim passed by and he said similarly as above. then (Banu) Sulaim passed by and he said similarly as above. Then came a batch, the like of which Abu Sufyan had not seen. He said, "Who are these?" Abbas said, "They are the Ansar headed by Sad bin Ubada, the one holding the flag." Sad bin Ubada said, "O Abu Sufyan! Today is the day of a great battle and today (what is prohibited in) the Ka'ba will be permissible." Abu Sufyan said., "O 'Abbas! How excellent the day of destruction is! "Then came another batch (of warriors) which was the smallest of all the batches, and in it there was Allah's Apostle and his companions and the flag of the Prophet was carried by Az-Zubair bin Al Awwam. When Allah's Apostle passed by Abu Sufyan, the latter said, (to the Prophet), "Do you know what Sad bin 'Ubada said?" The Prophet said, "What did he say?" Abu Sufyan said, "He said so-and-so." The Prophet said, "Sad told a lie, but today Allah will give superiority to the Ka'ba and today the Ka'ba will be covered with a (cloth) covering." Allah's Apostle ordered that his flag be fixed at Al-Hajun.

Narrated 'Urwa: Nafi bin Jubair bin Mut'im said, "I heard Al-Abbas saying to Az-Zubair bin Al-'Awwam, 'O Abu 'Abdullah ! Did Allah's Apostle order you to fix the flag here?' " Allah's Apostle ordered Khalid bin Al-Walid to enter Mecca from its upper part from Ka'da while the Prophet himself entered from Kuda. Two men from the cavalry of Khalid bin Al-Wahd named Hubaish bin Al-Ash'ar and Kurz bin Jabir Al-Fihri were martyred on that day.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.578]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 578

Narrated 'Abdullah bin Mughaffal:

I saw Allah's Apostle on the day of the Conquest of Mecca over his she-camel, reciting Surat-al-Fath in a vibrant quivering tone. (The sub-narrator, Mu'awiya added, "Were I not afraid that the people may gather around me, I would recite in vibrant quivering tone as he (i.e. 'Abdullah bin Mughaffal) did, imitating Allah's Apostle.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.579]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 579

Narrated 'Amr bin 'Uthman:

Usama bin Zaid said during the Conquest (of Mecca), "O Allah's Apostle! Where will we encamp tomorrow?" The Prophet said, "But has 'Aqil left for us any house to lodge in?" He then added, "No believer will inherit an infidel's property, and no infidel will inherit the property of a believer." Az-Zuhri was asked, "Who inherited Abu Talib?" Az-Zuhri replied, "Ail and Talib inherited him."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.580]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 580

Narrated Abu Huraira:

Allah's Apostle said, "If Allah makes us victorious, our encamping place will be Al-Khaif, the place where the infidels took an oath to be loyal to Heathenism (by boycotting Banu Hashim, the Prophet's folk)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.581]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 581

Narrated Abu Huraira:

When Allah's Apostle intended to carry on the Ghazwa of Hunain, he said, "Tomorrow, if Allah wished, our encamping) plaice will be Khaif Bani Kinana where (the infidels) took an oath to be loyal to Heathenism."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.582]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 582

Narrated Anas bin Malik:

On the day of the Conquest, the Prophet entered Mecca, wearing a helmet on his head. When he took it off, a man came and said, "Ibn Khatal is clinging to the curtain of the Ka'ba." The Prophet said, "Kill him." (Malik a sub-narrator said, "On that day the Prophet was not in a state of Ihram as it appeared to us, and Allah knows better.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.583]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 583

Narrated Abdullah:

When the Prophet entered Mecca on the day of the Conquest, there were 360 idols around the Ka'ba. The Prophet started striking them with a stick he had in his hand and was saying, "Truth has come and Falsehood will neither start nor will it reappear.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.584]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 584

Narrated Ibn Abbas:

When Allah's Apostle arrived in Mecca, he refused to enter the Ka'ba while there were idols in it. So he ordered that they be taken out. The pictures of the (Prophets) Abraham and Ishmael, holding arrows of divination in their hands, were carried out. The Prophet said, "May Allah ruin them (i.e. the infidels) for they knew very well that they (i.e. Abraham and Ishmael) never drew lots by these (divination arrows). Then the Prophet entered the Ka'ba and said. "Allahu Akbar" in all its directions and came out and not offer any prayer therein.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.585]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 585

Narrated 'Aisha:

During the year of the Conquest (of Mecca), the Prophet entered Mecca through Kada which was at the upper part of Mecca.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.586]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 586

Narrated Hisham's father:

During the year of the Conquest (of Mecca), the Prophet entered Mecca through its upper part through Kada.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.587]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 587

Narrated Ibn Laila:

None informed us that he saw the Prophet offering the Duha (i.e. forenoon) prayer, except Um Ham who mentioned that the Prophet took a bath in her house on the day of the Conquest (of Mecca) and then offered an eight Rakat prayer. She added, "I never saw the Prophet offering a lighter prayer than that prayer, but he was performing perfect bowing and prostrations."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.588]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 588

Narrated Ibn Abbas :

'Umar used to admit me (into his house) along with the old men who had fought in the Badr battle. Some of them said (to 'Umar), "Why do you allow this young man to enter with us, while we have sons of his own age? " 'Umar said, "You know what person he is." One day 'Umar called them and called me along with them, I had thought he called me on that day to show them something about me (i.e. my knowledge). 'Umar asked them, "What do you say about (the Sura): "When comes the help of Allah and the Conquest (of Mecca) And you see mankind entering the Religion of Allah (i.e. Islam) in crowds. 'So celebrate the Praises Of your Lord and ask for His forgiveness, Truly, He is the One Who accepts repentance and forgives." (110.1-3)

Some of them replied, "We are ordered to praise Allah and repent to Him if we are helped and granted victory." Some said, "We do not know." Others kept quiet. 'Umar then said to me, "Do you say similarly?" I said, "No." 'Umar said "What do you say then?" I said, "This Verse indicates the approaching of the death of Allah's Apostle of which Allah informed him. When comes the help of Allah and the Conquest, i.e. the Conquest of Mecca, that will be the sign of your Prophet's) approaching death, so testify the uniqueness of your Lord (i.e. Allah) and praise Him and repent to Him as He is ready to forgive." On that, 'Umar said, "I do not know about it anything other than what you know."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.589]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 589

Narrated Abu Shuraih:

Al-Adawi that he said to 'Amr bin Said while the latter was sending troops in batches to Mecca, "O chief! Allow me to tell you a statement which Allah's Apostle said on the second day of the Conquest of Mecca. My two ears heard it and my heart remembered it and my two eyes saw him when he said it. He (i.e. the Prophet) praised Allah and then said, 'Mecca has been made a sanctuary by Allah and not by the people, so it is not lawful for a person, who believes in Allah and the Last Day to shed blood in it, or to cut its trees and if someone asks the permission to fight in Mecca because Allah's Apostle was allowed to fight in it, say to him; Allah permitted His Apostle and did not allow you, and even he (i.e. the Apostle) was allowed for a short period of the day, and today its (Mecca's sanctity has become the same as it was before (of old) so those who are present should inform those who are absent (this Hadith)." Then Abu Shuraih, was asked, "What did 'Amr say to you? Abu Shuraih said, "He said, "I knew that better than you, O Abu Shuraih! The Haram (i.e. Mecca) does not give refuge to a sinner or a fleeing murderer or a person running away after causing destruction."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.590]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 590

Narrated Jabir bin 'Abdullah:

That he heard Allah's Apostle saying in the year of the Conquest (of Mecca) while he was in Mecca, "Allah and His Apostle have made the selling of wine (i.e. alcoholic drinks) unlawful."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.591]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 591

Narrated Anas:

We stayed (in Mecca) for ten days along with the Prophet and used to offer shortened prayers (i.e. journey prayers).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.592]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 592

Narrated Ibn Abbas:

The Prophet stayed in Mecca for 19 days during which he prayed 2 Rakat in each prayer.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.593]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 593

Narrated 'Ikrima:

Ibn 'Abbas said, "We stayed for 19 days with Prophet on a journey during which we used to offer shortened prayers." Ibn 'Abbas added, "We offer the Qasr prayer (i.e. shortened prayer) If we stay up to 19 days as travelers, But if we stay longer, we offer complete prayers


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.594]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 594

Narrated Az-Zuhri:

While we were in the company of the Ibn Al-Musaiyab, Sunain Abi Jamila informed us (a Hadith), Abu Jamila said that he lived during the lifetime of the Prophet and that he had accompanied him ( to Mecca) during the year of the Conquest (of Mecca).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.595]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 595

Narrated 'Amr bin Salama:

We were at a place which was a thoroughfare for the people, and the caravans used to pass by us and we would ask them, "What is wrong with the people? What is wrong with the people? Who is that man?. They would say, "That man claims that Allah has sent him (as an Apostle), that he has been divinely inspired, that Allah has revealed to him such-and-such." I used to memorize that (Divine) Talk, and feel as if it was inculcated in my chest (i.e. mind) And the 'Arabs (other than Quraish) delayed their conversion to Islam till the Conquest (of Mecca). They used to say." "Leave him (i.e. Muhammad) and his people Quraish: if he overpowers them then he is a true Prophet. So, when Mecca was conquered, then every tribe rushed to embrace Islam, and my father hurried to embrace Islam before (the other members of) my tribe. When my father returned (from the Prophet) to his tribe, he said, "By Allah, I have come to you from the Prophet for sure!" The Prophet afterwards said to them, 'Offer such-and-such prayer at such-and-such time, and when the time for the prayer becomes due, then one of you should pronounce the Adhan (for the prayer), and let the one amongst you who knows Qur'an most should, lead the prayer." So they looked for such a person and found none who knew more Qur'an than I because of the Quranic material which I used to learn from the caravans. They therefore made me their Imam ((to lead the prayer) and at that time I was a boy of six or seven years, wearing a Burda (i.e. a black square garment) proved to be very short for me (and my body became partly naked). A lady from the tribe said, "Won't you cover the anus of your reciter for us?" So they bought (a piece of cloth) and made a shirt for me. I had never been so happy with anything before as I was with that shirt.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.596]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 596

Narrated 'Aisha:

Utba bin Abi Waqqas authorized his brother Sad to take the son of the slave-girl of Zam'a into his custody. 'Utba said (to him). "He is my son." When Allah's Apostle arrived in Mecca during the Conquest (of Mecca), Sad bin Abi Waqqas took the son of the slave-girl of Zam'a and took him to the Prophet 'Abd bin Zam'a too came along with him. Sad said. "This is the son of my brother and the latter has informed me that he is his son." 'Abd bin Zam'a said, "O Allah's Apostle! This is my brother who is the son of the slave-girl of Zam'a and was born on his (i.e. Zam'as) bed.' Allah's Apostle looked at the son of the slave-girl of Zam'a and noticed that he, of all the people had the greatest resemblance to 'Utba bin Abi Waqqas. Allah's Apostle then said (to 'Abd), " He is yours; he is your brother, O 'Abd bin Zam'a, he was born on the bed (of your father)." (At the same time) Allah's Apostle said (to his wife Sauda), "Veil yourself before him (i.e. the son of the slave-girl) O Sauda," because of the resemblance he noticed between him and Utba bin Abi Waqqas. Allah's Apostle added, "The boy is for the bed (i.e. for the owner of the bed where he was born), and stone is for the adulterer." (Ibn Shihab said, "Abu Huraira used to say that (i.e. the last statement of the Prophet in the above Hadith 596, publicly.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.597]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 597

Narrated 'Urwa bin Az-Zubair:

A lady committed theft during the lifetime of Allah's Apostle in the Ghazwa of Al-Fath, ((i.e. Conquest of Mecca). Her folk went to Usama bin Zaid to intercede for her (with the Prophet). When Usama interceded for her with Allah's Apostle, the color of the face of Allah's Apostle changed and he said, "Do you intercede with me in a matter involving one of the legal punishments prescribed by Allah?" Usama said, "O Allah's Apostle! Ask Allah's Forgiveness for me." So in the afternoon, Allah's Apostle got up and addressed the people. He praised Allah as He deserved and then said, "Amma ba'du ! The nations prior to you were destroyed because if a noble amongst them stole, they used to excuse him, and if a poor person amongst them stole, they would apply (Allah's) Legal Punishment to him. By Him in Whose Hand Muhammad's soul is, if Fatima, the daughter of Muhammad stole, I would cut her hand." Then Allah's Apostle gave his order in the case of that woman and her hand was cut off. Afterwards her repentance proved sincere and she got married. 'Aisha said, "That lady used to visit me and I used to convey her demands to Allah's Apostle


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.598]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 598

Narrated Majashi:

I took my brother to the Prophet after the Conquest (of Mecca) and said, "O Allah's Apostle! I have come to you with my brother so that you may take a pledge of allegiance from him for migration." The Prophet said, The people of migration (i.e. those who migrated to Medina before the Conquest) enjoyed the privileges of migration (i.e. there is no need for migration anymore)." I said to the Prophet, "For what will you take his pledge of allegiance?" The Prophet said, "I will take his pledge of allegiance for Islam, Belief, and for Jihad (i.e. fighting in Allah's Cause)"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.599]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 599

Narrated Mujashi bin Masud:

I took Abu Mabad to the Prophet in order that he might give him the pledge of allegiance for migration. The Prophet said, "Migration has gone to its people, but I take the pledge from him (i.e. Abu Mabad) for Islam and Jihad."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.600]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 600

Narrated Mujahid:

I said to Ibn 'Umar, "I want to migrate to Sham." He said, "There is no migration, but Jihad (for Allah's Cause). Go and offer yourself for Jihad, and if you find an opportunity for Jihad (stay there) otherwise, come back." (In an other narration) Ibn 'Umar said, "There is no migration today or after Allah's Apostle." (and completed his statement as above.)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.601]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 601

Narrated Mujahid bin Jabr:

'Abdullah bin 'Umar used to say, "There is no migration after the Conquest (of Mecca)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.602]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 602

Narrated 'Ata' bin Abi Rabah:

'Ubaid bin 'Umar and I visited 'Aisha, and he asked her about the migration. She said, "There is no migration today. A believer used to flee with his religion to Allah and His Prophet for fear that he might be put to trial as regards his religion. Today Allah has rendered Islam victorious; therefore a believing one can worship one's Lord wherever one wishes. But there is Jihad (for Allah's Cause) and intentions." (See Hadith 42, in the 4th Vol. for its Explanation)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.603]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 603

Narrated Mujahid:

Allah's Apostle got up on the day of the Conquest of Mecca and said, "Allah has made Mecca a sanctuary since the day He created the Heavens and the Earth, and it will remain a sanctuary by virtue of the sanctity Allah has bestowed on it till the Day of Resurrection. It (i.e. fighting in it) was not made lawful to anyone before me!, nor will it be made lawful to anyone after me, and it was not made lawful for me except for a short period of time. Its game should not be chased, nor should its trees be cut, nor its vegetation or grass uprooted, not its Luqata (i.e. Most things) picked up except by one who makes a public announcement about it." Al-Abbas bin 'Abdul Muttalib said, "Except the Idhkhir, O Allah's Apostle, as it is indispensable for blacksmiths and houses." On that, the Prophet kept quiet and then said, "Except the Idhkhir as it is lawful to cut."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.604]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 604

Narrated Ismail:

I saw (a healed scar of) blow over the hand of Ibn Abi Aufa who said, "I received that blow in the battle of Hunain in the company of the Prophet." I said, "Did you take part in the battle of Hunain?" He replied, "Yes (and in other battles) before it."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.605]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 605

Narrated Abu Ishaq:

I heard Al-Bara' narrating when a man came and said to him, "O Abu 'Umara! Did you flee on the day (of the battle) of Hunain?" Al-Bara' replied, "I testify that the Prophet did not flee, but the hasty people hurried away and the people of Hawazin threw arrows at them. At that time, Abu Sufyan bin Al-Harith was holding the white mule of the Prophet by the head, and the Prophet was saying, "I am the Prophet undoubtedly: I am the son of 'Abdul-Muttalib."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.606]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 606

Narrated Abu Ishaq:

Al-Bara' was asked while I was listening, "Did you flee (before the enemy) along with the Prophet on the day of (the battle of) Hunain?" He replied, "As for the Prophet, he did not (flee). The enemy were good archers and the Prophet was saying, "I am the Prophet undoubtedly; I am the son of 'Abdul Muttalib."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.607]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 607

Narrated Abu Ishaq:

That he heard Al-Bara narrating when a man from Qais (tribe) asked him "Did you flee leaving Allah's Apostle on the day (of the battle) of Hunain?" Al-Bara' replied, "But Allah's Apostle did not flee. The people of Hawazin were good archers, and when we attacked them, they fled. But rushing towards the booty, we were confronted by the arrows (of the enemy). I saw the Prophet riding his white mule while Abu Sufyan was holding its reins, and the Prophet was saying "I am the Prophet undoubtedly." (Israil and Zuhair said, "The Prophet dismounted from his Mule.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.608]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 608

Narrated Marwan and Al-Miswar bin Makhrama:

When the delegate of Hawazin came to Allah's Apostle declaring their conversion to Islam and asked him to return their properties and captives, Allah's Apostle got up and said to them, "There Is involved in this matter, the people whom you see with me, and the most beloved talk to me, is the true one. So choose one of two alternatives: Either the captives or the properties. I have been waiting for you (i.e. have not distributed the booty)." Allah's Apostle had delayed the distribution of their booty over ten nights after his return from Ta'if. So when they came to know that Allah's Apostle was not going to return to them but one of the two, they said, "We prefer to have our captives." So Allah's Apostle got up amongst the Muslims, and praising Allah as He deserved, said, "To proceed! Your brothers have come to you with repentance and I see (it logical) to return their captives. So, whoever of you likes to do that as a favor then he can do it. And whoever of you likes to stick to his share till we give him from the very first booty which Allah will give us, then he can do so." The people said, "We do that (i.e. return the captives) willingly as a favor, 'O Allah's Apostle!" Allah's Apostle said, "We do not know which of you have agreed to it and which have not; so go back and let your chiefs forward us your decision." They went back and their chief's spoke to them, and they (i.e. the chiefs) returned to Allah's Apostle and informed him that all of them had agreed (to give up their captives) with pleasure, and had given their permission (i.e. that the captives be returned to their people). (The sub-narrator said, "That is what has reached me about the captives of Hawazin tribe.")


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.609]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 609

Narrated Ibn 'Umar:

When we returned from (the battle of) Hunain, 'Umar asked the Prophet about a vow which he had made during the Pre-lslamic period of Ignorance that he would perform Itikaf. The Prophet ordered him to fulfill his vow.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.610]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 610

Narrated Abu Qatada:

We set out along with the Prophet during the year of (the battle of) Hunain, and when we faced the enemy, the Muslims (with the exception of the Prophet and some of his companions) retreated (before the enemy). I saw one of the pagans over-powering one of the Muslims, so I struck the pagan from behind his neck causing his armor to be cut off. The pagan headed towards me and pressed me so forcibly that I felt as if I was dying. Then death took him over and he released me. Afterwards I followed 'Umar and said to him, "What is wrong with the people?" He said, "It is the Order of Allah." Then the Muslims returned (to the battle after the flight) and (after overcoming the enemy) the Prophet sat and said, "Whoever had killed an Infidel and has an evidence to this issue, will have the Salb (i.e. the belonging of the deceased e.g. clothes, arms, horse, etc)." I (stood up) and said, "Who will be my witness?" and then sat down. Then the Prophet repeated his question. Then the Prophet said the same (for the third time). I got up and said, "Who will be my witness?" and then sat down. The Prophet asked his former question again. So I got up. The Prophet said, What is the matter, O Abu Qatada?" So I narrated the whole story; A man said, "Abu Qatada has spoken the truth, and the Salb of the deceased is with me, so please compensate Abu Qatada on my behalf." Abu Bakr said, "No! By Allah, it will never happen that the Prophet will leave a Lion of Allah who fights for the Sake of Allah and His Apostle and give his spoils to you." The Prophet said, "Abu Bakr has spoken the truth. Give it (the spoils) back to him (O man)!" So he gave it to me and I bought a garden in (the land of) Banu Salama with it (i.e. the spoils) and that was the first property I got after embracing Islam.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.611]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 611

Narrated Abu Qatada:

When it was the day of (the battle of) Hunain, I saw a Muslim man fighting with one of the pagans and another pagan was hiding himself behind the Muslim in order to kill him. So I hurried towards the pagan who was hiding behind the Muslim to kill him, and he raised his hand to hit me but I hit his hand and cut it off. That man got hold of me and pressed me so hard that I was afraid (that I would die), then he knelt down and his grip became loose and I pushed him and killed him. The Muslims (excepting the Prophet and some of his companions) started fleeing and I too, fled with them. Suddenly I met 'Umar bin Al-Khattab amongst the people and I asked him, "What is wrong with the people?" He said, "It is the order of Allah" Then the people returned to Allah's Apostle (after defeating the enemy). Allah's Apostle said, "Whoever produces a proof that he has killed an infidel, will have the spoils of the killed man." So I got up to look for an evidence to prove that I had killed an infidel, but I could not find anyone to bear witness for me, so I sat down. Then it came to my mind (that I should speak of it) and I mentioned the case to Allah's Apostle. A man from the persons who were sitting with him (i.e. the Prophet), said, "The arms of the deceased one whom he ( i.e. Abu Qatada) has mentioned, are with me, so please compensate him for it (i.e. the spoils)," Abu Bakr said, "No, Allah's Apostle will not give it (i.e. the spoils) to a weak humble person from Quraish and leave one of Allah's Lions who fights on behalf of Allah and His Apostle." Allah's Apostle then got up and gave that (spoils) to me, and I bought with it, a garden which was the first property I got after embracing Islam.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.612]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 612

Narrated Abu Musa:

When the Prophet had finished from the battle of Hunain, he sent Abu Amir at the head of an army to Autas He (i.e. Abu Amir) met Duraid bin As Summa and Duraid was killed and Allah defeated his companions. The Prophet sent me with Abu 'Amir. Abu Amir was shot at his knee with an arrow which a man from Jushm had shot and fixed into his knee. I went to him and said, "O Uncle! Who shot you?" He pointed me out (his killer) saying, "That is my killer who shot me (with an arrow)." So I headed towards him and overtook him, and when he saw me, he fled, and I followed him and started saying to him, "Won't you be ashamed? Won't you stop?" So that person stopped, and we exchanged two hits with the swords and I killed him. Then I said to Abu 'Amir. "Allah has killed your killer." He said, "Take out this arrow" So I removed it, and water oozed out of the wound. He then said, "O son of my brother! Convey my compliments to the Prophet and request him to ask Allah's Forgiveness for me." Abu Amir made me his successor in commanding the people (i.e. troops). He survived for a short while and then died. (Later) I returned and entered upon the Prophet at his house, and found him lying in a bed made of stalks of date-palm leaves knitted with ropes, and on it there was bedding. The strings of the bed had their traces over his back and sides. Then I told the Prophet about our and Abu Amir's news and how he had said "Tell him to ask for Allah's Forgiveness for me." The Prophet asked for water, performed ablution and then raised hands, saying, "O Allah's Forgive 'Ubaid, Abu Amir." At that time I saw the whiteness of the Prophet's armpits. The Prophet then said, "O Allah, make him (i.e. Abu Amir) on the Day of Resurrection, superior to many of Your human creatures." I said, "Will you ask Allah's Forgiveness for me?" (On that) the Prophet said, "O Allah, forgive the sins of 'Abdullah bin Qais and admit him to a nice entrance (i.e. paradise) on the Day of Resurrection." Abu Burda said, "One of the prayers was for Abu 'Amir and the other was for Abu Musa (i.e. 'Abdullah bin Qais)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.613]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 613

Narrated Um Salama:

The Prophet came to me while there was an effeminate man sitting with me, and I heard him (i.e. the effeminate man) saying to 'Abdullah bin Abi Umaiya, "O 'Abdullah! See if Allah should make you conquer Ta'if tomorrow, then take the daughter of Ghailan (in marriage) as (she is so beautiful and fat that) she shows four folds of flesh when facing you, and eight when she turns her back." The Prophet then said, "These (effeminate men) should never enter upon you (O women!)." Ibn Juraij said, "That effeminate man was called Hit."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.614]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 614

Narrated Hisham:

The above narration and added extra, that at that time, the Prophet, was besieging Taif.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.615]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 615

Narrated 'Abdullah bin Amr:

When Allah's Apostle besieged Taif and could not conquer its people, he said, "We will return (to Medina) If Allah wills." That distressed the Companions (of the Prophet and they said, "Shall we go away without conquering it (i.e. the Fort of Taif)?" Once the Prophet said, "Let us return." Then the Prophet said (to them), "Fight tomorrow." They fought and (many of them) got wounded, whereupon the Prophet said, "We will return (to Medina) tomorrow if Allah wills." That delighted them, whereupon the Prophet smiled. The sub-narrator, Sufyan said once, "(The Prophet) smiled."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.616]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 616

Narrated Abu Uthman:

I heard from Sad, the first man who has thrown an arrow in Allah's Cause, and from Abu Bakra who jumped over the wall of the Ta'if Fort along with a few persons and came to the Prophet. They both said, "We heard the Prophet saying, " If somebody claims to be the son of somebody other than his father knowingly, he will be denied Paradise (i.e. he will not enter Paradise).' "

Narrated Ma'mar from 'Asim from Abu Al'Aliya or Abu Uthman An-Nahdi who said. "I heard Sad and Abu Bakra narrating from the Prophet." 'Asim said, "I said (to him), 'Very trustworthy persons have narrated to you.' He said, 'Yes, one of them was the first to throw an arrow in Allah's Cause and the other came to the Prophet in a group of thirty-three persons from Ta'if.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.617]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 617

Narrated Abu Burda:

Abu Musa said, "I was with the Prophet when he was encamping at Al-Jarana (a place) between Mecca and Medina and Bilal was with him. A bedouin came to the Prophet and said, "Won't you fulfill what you have promised me?" The Prophet said, 'Rejoice (at what I will do for you).' The bedouin said, "(You have said to me) rejoice too often." Then the Prophet turned to me (i.e. Abu Musa) and Bilal in an angry mood and said, 'The bedouin has refused the good tidings, so you both accept them.' Bilal and I said, 'We accept them.' Then the Prophet asked for a drinking bowl containing water and washed his hands and face in it, and then took a mouthful of water and threw it therein saying (to us), "Drink (some of) it and pour (some) over your faces and chests and be happy at the good tidings." So they both took the drinking bowl and did as instructed. Um Salama called from behind a screen, "Keep something (of the water for your mother." So they left some of it for her.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.618]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 618

Narrated Safwan bin Ya'la bin Umaiya:

Ya'la used to say, "I wish I could see Allah's Apostle at the time when he is being inspired divinely." Ya'la added "While the Prophet was at Al-Ja'rana, shaded with a cloth sheet (in the form of a tent) and there were staying with him, some of his companions under it, suddenly there came to him a bedouin wearing a cloak and perfumed extravagantly. He said, "O Allah's Apostle ! What is your opinion regarding a man who assumes the state of Ihram for 'Umra wearing a cloak after applying perfume to his body?" 'Umar signalled with his hand to Ya'la to come (near). Ya'la came and put his head (underneath that cloth sheet) and saw the Prophet red-faced and when that state (of the Prophet ) was over, he said, "Where is he who as already asked me about the 'Umra?" The man was looked for and brought to the Prophet The Prophet said (to him), "As for the perfume you have applied to your body, wash it off your body) thrice, and take off your cloak, and then do in your 'Umra the rites you do in your Hajj."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.619]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 619

Narrated 'Abdullah bin Zaid bin Asim: When Allah gave to His Apostle the war booty on the day of Hunain, he distributed that booty amongst those whose hearts have been (recently) reconciled (to Islam), but did not give anything to the Ansar. So they


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.620]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 620

Narrated Anas Bin Malik:

hen." Anas added: But they did not remain patient.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.621]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 621

Narrated Anas:

When it was the day of the Conquest (of Mecca) Allah's Apostle distributed the war booty amongst the people of Quraish which caused the Ansar to become angry. So the Prophet said, "Won't you be pleased that the people take the worldly things and you take Allah's Apostle with you? "They said, "Yes." The Prophet said, "If the people took their way through a valley or mountain pass, I would take my way through the Ansar's valley or mountain pass."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.622]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 622

Narrated Anas:

When it was the day of (the battle of) Hunain, the Prophet confronted the tribe of Hawazin while there were ten-thousand (men) besides the Tulaqa' (i.e. those who had embraced Islam on the day of the Conquest of Mecca) with the Prophet. When they (i.e. Muslims) fled, the Prophet said, "O the group of Ansari" They replied, "Labbaik, O Allah's Apostle and Sadaik! We are under your command." Then the Prophet got down (from his mule) and said, "I am Allah's Slave and His Apostle." Then the pagans were defeated. The Prophet distributed the war booty amongst the Tulaqa and Muhajirin (i.e. Emigrants) and did not give anything to the Ansar. So the Ansar spoke (i.e. were dissatisfied) and he called them and made them enter a leather tent and said, Won't you be pleased that the people take the sheep and camels, and you take Allah's Apostle along with you?" The Prophet added, "If the people took their way through a valley and the Ansar took their way through a mountain pass, then I would choose a mountain pass of the Ansar"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.623]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 623

Narrated Anas:

The Prophet gathered some people of Ansar and said, "The People of Quraish are still close to their Pre-lslamic period of ignorance and have suffered a lot, and I want to help them and attract their hearts (by giving them the war booty). Won't you be pleased that the people take the worldly things) and you take Allah's Apostle with you to your homes?" They said, "Yes, (i.e. we are pleased with this distribution)." The Prophet said, "'If the people took their way through a valley and the Ansar took their way through a mountain pass, then I would take the Ansar's valley or the Ansar's mountain pass."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.624]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 624

Narrated 'Abdullah:

When the Prophet distribute the war booty of Hunain, a man from the Ansar said, "He (i.e. the Prophet), did not intend to please Allah in this distribution." So I came to the Prophet and informed him of that (statement) whereupon the color of his face changed and he said, "May Allah bestow His Mercy on Moses, for he was troubled with more than this, but he remained patient."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.625]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 625

Narrated 'Abdullah:

When it was the day of Hunain, Prophet favored some people over some others (in the distribution of the booty). He gave Al-Aqra' one-hundred camels and gave Uyaina the same, and also gave other people (of Quraish). A man said, "Allah's Pleasure was not the aim, in this distribution." I said, "I will inform the Prophet (about your statement)." The Prophet said, "May Allah bestow Mercy on Moses, for he was troubled more this but he remained patient."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.626]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 626

Narrated Anas Bin Malik:

When it was the day (of the battle) of Hunain, the tributes of Hawazin and Ghatafan and others, along with their animals and offspring (and wives) came to fight against the Prophet The Prophet had with him, ten thousand men and some of the Tulaqa. The companions fled, leaving the Prophet alone. The Prophet then made two calls which were clearly distinguished from each other. He turned right and said, "O the group of Ansar!" They said, "Labbaik, O Allah's Apostle! Rejoice, for we are with you!" Then he turned left and said, "O the group of Ansar!" They said, "Labbaik! O Allah's Apostle! Rejoice, for we are with you!" The Prophet at that time, was riding on a white mule; then he dismounted and said, "I am Allah's Slave and His Apostle." The infidels then were defeated, and on that day the Prophet gained a large amount of booty which he distributed amongst the Muhajirin and the Tulaqa and did not give anything to the Ansar. The Ansar said, "When there is a difficulty, we are called, but the booty is given to other than us." The news reached the Prophet and he gathered them in a leather tent and said, "What is this news reaching me from you, O the group of Ansar?" They kept silent, He added," O the group of Ansar! Won't you be happy that the people take the worldly things and you take Allah's Apostle to your homes reserving him for yourself?" They said, "Yes." Then the Prophet said, "If the people took their way through a valley, and the Ansar took their way through a mountain pass, surely, I would take the Ansar's mountain pass." Hisham said, "O Abu Hamza (i.e. Anas)! Did you witness that? " He replied, "And how could I be absent from him?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.627]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 627

Narrated Ibn 'Umar:

The Prophet sent a Sariya towards Najd and I was in it, and our share from the booty amounted to twelve camels each, and we were given an additional camel each. So we returned with thirteen camels each.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.628]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 628

Narrated Salim's father:

The Prophet sent Khalid bin Al-Walid to the tribe of Jadhima and Khalid invited them to Islam but they could not express themselves by saying, "Aslamna (i.e. we have embraced Islam)," but they started saying "Saba'na! Saba'na (i.e. we have come out of one religion to another)." Khalid kept on killing (some of) them and taking (some of) them as captives and gave every one of us his Captive. When there came the day then Khalid ordered that each man (i.e. Muslim soldier) should kill his captive, I said, "By Allah, I will not kill my captive, and none of my companions will kill his captive." When we reached the Prophet, we mentioned to him the whole story. On that, the Prophet raised both his hands and said twice, "O Allah! I am free from what Khalid has done."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.629]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 629

Narrated 'Ali:

The Prophet sent a Sariya under the command of a man from the Ansar and ordered the soldiers to obey him. He (i.e. the commander) became angry and said "Didn't the Prophet order you to obey me!" They replied, "Yes." He said, "Collect fire-wood for me." So they collected it. He said, "Make a fire." When they made it, he said, "Enter it (i.e. the fire)." So they intended to do that and started holding each other and saying, "We run towards (i.e. take refuge with) the Prophet from the fire." They kept on saying that till the fire was extinguished and the anger of the commander abated. When that news reached the Prophet he said, "If they had entered it (i.e. the fire), they would not have come out of it till the Day of Resurrection. Obedience (to somebody) is required when he enjoins what is good."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.630]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 630

Narrated Abu Burda:

Allah's Apostle sent Abu Musa and Muadh bin Jabal to Yemen. He sent each of them to administer a province as Yemen consisted of two provinces. The Prophet said (to them), "Facilitate things for the people and do not make things difficult for them (Be kind and lenient (both of you) with the people, and do not be hard on them) and give the people good tidings and do not repulse them. So each of them went to carry on his job. So when any one of them toured his province and happened to come near (the border of the province of) his companion, he would visit him and greet him. Once Mu'adh toured that part of his state which was near (the border of the province of) his companion Abu Musa. Mu'adh came riding his mule till he reached Abu Musa and saw him sitting, and the people had gathered around him. Behold! There was a man tied with his hands behind his neck. Mu'adh said to Abu Musa, "O 'Abdullah bin Qais! What is this?" Abu Musa replied. "This man has reverted to Heathenism after embracing Islam." Mu'adh said, "I will not dismount till he is killed." Abu Musa replied, "He has been brought for this purpose, so come down." Mu'adh said, "I will not dismount till he is killed." So Abu Musa ordered that he be killed, and he was killed. Then Mu'adh dismounted and said, "O Abdullah (bin Qais)! How do you recite the Qur'an ?" Abu Musa said, "I recite the Qur'an regularly at intervals and piecemeal. How do you recite it O Mu'adh?" Mu'adh said, "I sleep in the first part of the night and then get up after having slept for the time devoted for my sleep and then recite as much as Allah has written for me. So I seek Allah's Reward for both my sleep as well as my prayer (at night)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.631]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 631

Narrated Abi Burda:

That Abu Musa Al-Ash'ari said that the Prophet had sent him to Yemen and he asked the Prophet about certain (alcoholic) drink which used to be prepared there The Prophet said, "What are they?" Abu Musa said, "Al-Bit' and Al-Mizr?" He said, "Al-Bit is an alcoholic drink made from honey; and Al-Mizr is an alcoholic drink made from barley." The Prophet said, "All intoxicants are prohibited."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.632]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 632

Narrated Abu Burda:

That the Prophet sent his (i.e. Abu Burda's) grandfather, Abu Musa and Mu'adh to Yemen and said to both of them "Facilitate things for the people (Be kind and lenient) and do not make things difficult (for people), and give them good tidings, and do not repulse them and both of you should obey each other." Abu Musa said, "O Allah's Prophet! In our land there is an alcoholic drink (prepared) from barley called Al-Mizr, and another (prepared) from honey, called Al-Bit"' The Prophet said, "All intoxicants are prohibited." Then both of them proceeded and Mu'adh asked Abu Musa, "How do you recite the Quran?" Abu Musa replied, "I recite it while I am standing, sitting or riding my riding animals, at intervals and piecemeal." Muadh said, "But I sleep and then get up. I sleep and hope for Allah's Reward for my sleep as I seek His Reward for my night prayer." Then he (i.e. Muadh) pitched a tent and they started visiting each other. Once Muadh paid a visit to Abu Musa and saw a chained man. Muadh asked, "What is this?" Abu Musa said, "(He was) a Jew who embraced Islam and has now turned apostate." Muadh said, "I will surely chop off his neck!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.633]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 633

Narrated Abu Musa Al-Ashari:

Allah's Apostle sent me (as a governor) to the land of my people, and I came while Allah's Apostle was encamping at a place called Al-Abtah. The Prophet said, "Have you made the intention to perform the Hajj, O Abdullah bin Qais?" I replied, "Yes, O Allah's Apostle!" He said, "What did you say?" I replied, "I said, 'Labbaik' and expressed the same intention as yours." He said, "Have you driven the Hadi along with you?" I replied, "No, I did not drive the Hadi." He said, "So perform the Tawaf of the Ka'ba and then the Sai, between Safa and Marwa and then finish the state of Ihram." So I did the same, and one of the women of (the tribe of) Banu-Qais combed my hair. We continued follow in that tradition till the caliphate of Umar.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.634]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 634

Narrated Ibn Abbas:

Allah's Apostle said to Muadh bin Jabal when he sent him to Yemen. "You will come to the people of Scripture, and when you reach them, invite them to testify that none has the right to be worshipped except Allah and that Muhammad is His Apostle. And if they obey you in that, then tell them that Allah has enjoined on them five prayers to be performed every day and night. And if they obey you in that, then tell them that Allah has enjoined on them Sadaqa (i.e. Rakat) to be taken from the rich amongst them and given to the poor amongst them. And if they obey you in that, then be cautious! Don't take their best properties (as Zakat) and be afraid of the curse of an oppressed person as there is no screen between his invocation and Allah.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.635]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 635

Narrated Amr bin Maimuin:

When Mu'adh arrived at Yemen, he led them (i.e. the people of Yemen) in the Fajr prayer wherein he recited: 'Allah took Abraham as a Khalil.' A man amongst the people said, "(How) glad the mother of Abraham is!" (In another narration) 'Amr said, "The Prophet sent Mu'adh to Yemen and he (led the people) in the Fajr prayer and recited: 'Allah took Abraham as a Khalil. A man behind him said, "(How) glad the mother of Abraham is!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.636]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 636

Narrated Al-Bara:

Allah's Apostle sent us to Yemen along with Khalid bin Al-Walid. Later on he sent Ali bin Abi Talib in his place. The Prophet said to 'Ali, "Give Khalid's companions the choice of either staying with you (in Yemen) or returning to Medina." I was one of those who stayed with him (i.e. Ali) and got several Awaq (of gold from the war booty.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.637]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 637

Narrated Buraida:

The Prophet sent 'Ali to Khalid to bring the Khumus (of the booty) and I hated Ali, and 'Ali had taken a bath (after a sexual act with a slave-girl from the Khumus). I said to Khalid, "Don't you see this (i.e. Ali)?" When we reached the Prophet I mentioned that to him. He said, "O Buraida! Do you hate Ali?" I said, "Yes." He said, "Do you hate him, for he deserves more than that from the Khumlus."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.638]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 638

Narrated Abu Said Al-Khudri:

'Ali bin Abi Talib sent a piece of gold not yet taken out of its ore, in a tanned leather container to Allah's Apostle . Allah's Apostle distributed that amongst four Persons: 'Uyaina bin Badr, Aqra bin Habis, Zaid Al-Khail and the fourth was either Alqama or Amir bin At Tufail. On that, one of his companions said, "We are more deserving of this (gold) than these (persons)." When that news reached the Prophet , he said, "Don't you trust me though I am the truth worthy man of the One in the Heavens, and I receive the news of Heaven (i.e. Divine Inspiration) both in the morning and in the evening?" There got up a man with sunken eyes, raised cheek bones, raised forehead, a thick beard, a shaven head and a waist sheet that was tucked up and he said, "O Allah's Apostle! Be afraid of Allah." The Prophet said, "Woe to you! Am I not of all the people of the earth the most entitled to fear Allah?" Then that man went away. Khalid bin Al-Wahd said, "O Allah's Apostle! Shall I chop his neck off?" The Prophet said, "No, for he may offer prayers." Khalid said, "Numerous are those who offer prayers and say by their tongues (i.e. mouths) what is not in their hearts." Allah's Apostle said, "I have not been ordered (by Allah) to search the hearts of the people or cut open their bellies." Then the Prophet looked at him (i.e. that man) while the latter was going away and said, "From the offspring of this (man there will come out (people) who will recite the Qur'an continuously and elegantly but it will not exceed their throats. (They will neither understand it nor act upon it). They would go out of the religion (i.e. Islam) as an arrow goes through a game's body." I think he also said, "If I should be present at their time I would kill them as the nations a Thamud were killed."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.639]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 639

Narrated 'Ata:

Jabir said, "The Prophet ordered 'Ali to keep the state of Ihram." Jabir added, "Ali bin Abi Talib returned (from Yemen) when he was a governor (of Yemen). The Prophet said to him, 'With what intention have you assumed the state of Ihram?' 'Ali said, "I have assumed Ihram with an intention as that of the Prophet." Then the Prophet said (to him), 'Offer a Hadi and keep the state of Ihram in which you are now.' 'Ali slaughtered a Hadi on his behalf."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.640]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 640

Narrated Ibn Umar:

The Prophet assumed the state of Ihram for Umra and Hajj, and we to assumed it for Hajj with him. When we arrived at Mecca, the Prophet said, "Whoever does not possess a Hadi should regard his Ihram for Umra only." The Prophet had a Hadi with him. 'Ali bin Abi Talib came to us from Yemen with the intention of performing Hajj. The Prophet said (to him), "With what intention have you assumed the Ihram, for your wife is with us?" 'Ali said, "I assumed the lhram with the same intention as that of the Prophet ." The Prophet said, "Keep on the state of lhram, as we have got the Hadi."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.641]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 641

Narrated Jarir:

In the Pre-lslamic Period of Ignorance there was a house called Dhu-l-Khalasa or Al-Ka'ba Al-Yamaniya or Al-Ka'ba Ash-Shamiya. The Prophet said to me, "Won't you relieve me from Dhu-l-Khalasa?" So I set out with one-hundred-and-fifty riders, and we dismantled it and killed whoever was present there. Then I came to the Prophet and informed him, and he invoked good upon us and Al-Ahmas (tribe) .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.642]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 642

Narrated Qais:

Jarir said to me, The Prophet said to me, "Won't you relieve me from Dhu-l-Khalasa?" And that was a house (in Yemem belonging to the tribe of) Khatham called Al-Kaba Al Yamaniya. I proceeded with one-hundred and-fifty cavalry from Ahmas (tribe) who were horse riders. I used not to sit firm on horses, so the Prophet stroke me over my chest till I saw the mark of his fingers over my chest, and then he said, 'O Allah! Make him (i.e. Jarir) firm and one who guides others and is guided on the right path." So Jarir proceeded to it dismantled and burnt it, and then sent a messenger to Allah's Apostle. The messenger of Jarir said (to the Prophet), "By Him Who sent you with the Truth, I did not leave that place till it was like a scabby camel." The Prophet blessed the horses of Ahmas and their men five times.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.643]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 643

Narrated Qais:

Jarir said "Allah's Apostle said to me, "Won't you relieve me from Dhul-Khalasa?" I replied, "Yes, (I will relieve you)." So I proceeded along with one-hundred and fifty cavalry from Ahmas tribe who were skillful in riding horses. I used not to sit firm over horses, so I informed the Prophet of that, and he stroke my chest with his hand till I saw the marks of his hand over my chest and he said, O Allah! Make him firm and one who guides others and is guided (on the right path).' Since then I have never fallen from a horse. Dhul-l--Khulasa was a house in Yemen belonging to the tribe of Khatham and Bajaila, and in it there were idols which were worshipped, and it was called Al-Ka'ba." Jarir went there, burnt it with fire and dismantled it. When Jarir reached Yemen, there was a man who used to foretell and give good omens by casting arrows of divination. Someone said to him. "The messenger of Allah's Apostle is present here and if he should get hold of you, he would chop off your neck." One day while he was using them (i.e. arrows of divination), Jarir stopped there and said to him, "Break them (i.e. the arrows) and testify that None has the right to be worshipped except Allah, or else I will chop off your neck." So the man broke those arrows and testified that none has the right to be worshipped except Allah. Then Jarir sent a man called Abu Artata from the tribe of Ahmas to the Prophet to convey the good news (of destroying Dhu-l-Khalasa). So when the messenger reached the Prophet, he said, "O Allah's Apostle! By Him Who sent you with the Truth, I did not leave it till it was like a scabby camel." Then the Prophet blessed the horses of Ahmas and their men five times.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.644]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 644

Narrated Abu Uthman:

Allah's Apostle sent 'Amr bin Al As as the commander of the troops of Dhat-us-Salasil. 'Amr bin Al-'As said, "(On my return) I came to the Prophet and said, 'Which people do you love most?' He replied, 'Aisha.' I said, 'From amongst the men?' He replied, 'Her father (Abu Bakr)'. I said, 'Whom (do you love) next?' He replied, "Umar.' Then he counted the names of many men, and I became silent for fear that he might regard me as the last of them."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.645]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 645

Narrated Jarir:

While I was at Yemen, I met two men from Yemen called Dhu Kala and Dhu Amr, and I started telling them about Allah's Apostle. Dhu Amr said to me, "If what you are saying about your friend (i.e. the Prophet) is true, then he has died three days ago." Then both of them accompanied me to Medina, and when we had covered some distance on the way to Medina, we saw some riders coming from Medina. We asked them and they said, "Allah's Apostle has died and Abu Bakr has been appointed as the Caliph and the people are in a good state.' Then they said, "Tell your friend (Abu Bakr) that we have come (to visit him), and if Allah will, we will come again." So they both returned to Yemen. When I told Abu Bakr their statement, he said to me, "I wish you had brought them (to me)." Afterwards I met Dhu Amr, and he said to me, "O Jarir! You have done a favor to me and I am going to tell you something, i.e. you, the nation of 'Arabs, will remain prosperous as long as you choose and appoint another chief whenever a former one is dead. But if authority is obtained by the power of the sword, then the rulers will become kings who will get angry, as kings get angry, and will be delighted as kings get delighted."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.646]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 646

Narrated Wahab bin Kaisan:

Jabir bin Abdullah said, "Allah's Apostle sent troops to the sea coast and appointed Abu 'Ubaida bin Al-Jarrah as their commander, and they were 300 (men). We set out, and we had covered some distance on the way, when our journey food ran short. So Abu 'Ubaida ordered that all the food present with the troops be collected, and it was collected. Our journey food was dates, and Abu Ubaida kept on giving us our daily ration from it little by little (piecemeal) till it decreased to such an extent that we did not receive except a date each." I asked (Jabir), "How could one date benefit you?" He said, "We came to know its value when even that finished." Jabir added, "Then we reached the sea (coast) where we found a fish like a small mountain. The people (i.e. troops) ate of it for 18 nights (i.e. days). Then Abu 'Ubaida ordered that two of its ribs be fixed on the ground (in the form of an arch) and that a she-camel be ridden and passed under them. So it passed under them without touching them."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.647]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 647

Narrated Jabir bin 'Abdullah:

Allah's Apostle sent us who were three-hundred riders under the command of Abu Ubaida bin Al-Jarrah in order to watch the caravan of the Quraish pagans. We stayed at the seashore for half a month and were struck with such severe hunger that we ate even the Khabt (i.e. the leaves of the Salam, a thorny desert tree), and because of that, the army was known as Jaish-ul-Khabt. Then the sea threw out, an animal (i.e. a fish) called Al-'Anbar and we ate of that for half a month, and rubbed its fat on our bodies till our bodies returned to their original state (i.e. became strong and healthy). Abu Ubaida took one of its ribs, fixed it on the ground; then he went to the tallest man of his companions (to let him pass under the rib). Once Sufyan said, "He took a rib from its parts and fixed it, and then took a man and camel and they passed from underneath it (without touching it). " Jabir added: There was a man amongst the people who slaughtered three camels and then slaughtered another three camels and then slaughtered other three camels, and then Abu 'Ubaida forbade him to do so.

Narrated Abu Salih: Qais bin Sad said to his father. "I was present in the army and the people were struck with severe hunger." He said, "You should have slaughtered (camels) (for them)." Qais said, "I did slaughter camels but they were hungry again. He said, "You should have slaughtered (camels) again." Qais said, "I did slaughter (camels) again but the people felt hungry again." He said, "You should have slaughtered (camels) again." Qais said, "I did slaughter (camels) again, but the people again felt hungry." He said, "You should have slaughtered (camels) again." Qais said, "But I was forbidden (by Abu 'Ubaida this time)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.648]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 648

Narrated Jabir:

We set out in the army of Al-Khabt and Abu Ubaida was the commander of the troops. We were struck with severe hunger and the sea threw out a dead fish the like of which we had never seen, and it was called Al-'Anbar. We ate of it for half a month. Abu Ubaida took (and fixed) one of its bones and a rider passed underneath it (without touching it). (Jabir added:) Abu 'Ubaida said (to us), "Eat (of that fish)." When we arrived at Medina, we informed the Prophet about that, and he said, "Eat, for it is food Allah has brought out for you, and feed us if you have some of it." So some of them gave him (of that fish) and he ate it.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.649]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 649

Narrated Abu Huraira:

That during the Hajj in which the Prophet had made Abu Bakr As Siddiq as chief of the, Hajj before the Hajj-ul-Wida,' on the day of Nahr, Abu Bakr sent him along with a group of persons to announce to the people. "No pagan is permitted to perform Hajj after this year, and nobody is permitted to perform the Tawaf of the Ka'ba naked."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.650]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 650

Narrated Al-Bara:

The last Sura which was revealed in full was Baraa (i.e. Sura-at-Tauba), and the last Sura (i.e. part of a Sura) which was revealed was the last Verses of Sura-an-Nisa':-- "They ask you for a legal decision. Say: Allah directs (thus) About those who have No descendants or ascendants As heirs." (4.177)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.651]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 651

Narrated 'Imran bin Hussein:

A delegation from Banu Tamim came to the Prophet . The Prophet said, "Accept the good tidings, O Banu Tamim!" They said, "O Allah's Apostle! You have given us good tidings, so give us (something)." Signs of displeasure appeared on his face. Then another delegation from Yemen came and he said (to them), "Accept the good tidings, for Banu Tamim refuses to accept them." They replied, "We have accepted them, O Allah's Apostle!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.652]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 652

Narrated Abu Huraira:

I have not ceased to like Banu Tamim ever since I heard of three qualities attributed to them by Allah's Apostle (He said): They, out of all my followers, will be the strongest opponent of Ad-Dajjal; 'Aisha had a slave-girl from them, and the Prophet told her to manumit her as she was from the descendants of (the Prophet) Ishmael; and, when their Zakat was brought, the Prophet said, "This is the Zakat of my people."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.653]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 653

Narrated Ibn Abi Mulaika:

'Abdullah bin Az-Zubair said that a group of riders belonging to Banu Tamim came to the Prophet, Abu Bakr said (to the Prophet ), "Appoint Al-Qa'qa bin Mabad bin Zurara as (their) ruler." 'Umar said (to the Prophet). "No! But appoint Al-Aqra bin Habis." Thereupon Abu Bakr said (to 'Umar). "You just wanted to oppose me." 'Umar replied. "I did not want to oppose you." So both of them argued so much that their voices became louder, and then the following Divine Verses were revealed in that connection:-- "O you who believe ! Do not be forward in the presence of Allah and His Apostle..." (till the end of Verse)...(49.1)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.654]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 654

Narrated Abu Jamra:

I said to Ibn 'Abbas, "I have an earthenware pot containing Nabidh (i.e. water and dates or grapes) for me, and I drink of it while it is sweet. If I drink much of it and stay with the people for a long time, I get afraid that they may discover it (for I will appear as if I were drunk). Ibn 'Abbas said, "A delegation of Abdul Qais came to Allah's Apostle and he said, "Welcome, O people! Neither will you have disgrace nor will you regret." They said, "O Allah's Apostle! There are the Mudar pagans between you and us, so we cannot come to you except in the sacred Months. So please teach us some orders on acting upon which we will enter Paradise. Besides, we will preach that to our people who are behind us." The Prophet said, "I order you to do four things and forbid you from four things (I order you): To believe in Allah...Do you know what is to believe in Allah? That is to testify that None has the right to be worshipped except Allah: (I order you also to offer prayers perfectly to pay Zakat; and to fast the month of Ramadan and to give the Khumus (i.e. one-fifth of the booty) (for Allah's Sake). I forbid you from four other things (i.e. the wine that is prepared in) Ad-Dubba, An-Naquir, Az-Hantam and Al-Muzaffat. (See Hadith No. 50 Vol. 1)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.655]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 655

Narrated Ibn 'Abbas:

The delegation of 'Abdul Qais came to the Prophet and said, "O Allah's Apostle We belong to the tribe of Rabia. The infidels of Mudar tribe intervened between us and you so that we cannot come to you except in the Sacred Months, so please order us some things we may act on and invite those left behind to act on. The Prophet said, "I order you to observe four things and forbid you from four things: (I order you) to believe in Allah, i.e. to testify that None has the right to be worshipped except Allah." The Prophet pointed with finger indicating one and added, "To offer prayers perfectly: to give Zakat, and to give one-fifth of the booty you win (for Allah's Sake). I forbid you to use Ad-Dubba', An-Naquir, Al-Hantam and Al-Muzaffat, (Utensils used for preparing alcoholic liquors and drinks)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.656]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 656

Narrated Bukair:

That Kuraib, the freed slave of Ibn Abbas told him that Ibn Abbas, 'Abdur-Rahman bin Azhar and Al-Miswar bin Makhrama sent him to 'Aisha saying, "Pay her our greetings and ask her about our offering of the two-Rak'at after 'Asr Prayer, and tell her that we have been informed that you offer these two Rakat while we have heard that the Prophet had forbidden their offering." Ibn 'Abbas said, "I and 'Umar used to beat the people for their offering them." Kuraib added, "I entered upon her and delivered their message to her.' She said, 'Ask Um Salama.' So, I informed them (of 'Aisha's answer) and they sent me to Um Salama for the same purpose as they sent me to 'Aisha. Um Salama replied, 'I heard the Prophet forbidding the offering of these two Rakat. Once the Prophet offered the 'Asr prayer, and then came to me. And at that time some Ansari women from the Tribe of Banu Haram were with me. Then (the Prophet ) offered those two Rakat, and I sent my (lady) servant to him, saying, 'Stand beside him and say (to him): Um Salama says, 'O Allah's Apostle! Didn't I hear you forbidding the offering of these two Rakat (after the Asr prayer yet I see you offering them?' And if he beckons to you with his hand, then wait behind.' So the lady slave did that and the Prophet beckoned her with his hand, and she stayed behind, and when the Prophet finished his prayer, he said, 'O the daughter of Abu Umaiya (i.e. Um Salama), You were asking me about these two Rakat after the 'Asr prayer. In fact, some people from the tribe of 'Abdul Qais came to me to embrace Islam and busied me so much that I did not offer the two Rakat which were offered after Zuhr compulsory prayer, and these two Rakat (you have seen me offering) make up for those."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.657]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 657

Narrated Ibn Abbas:

The first Friday (i.e. Jumua) prayer offered after the Friday Prayer offered at the Mosque of Allah's Apostle was offered at the mosque of Abdul Qais situated at Jawathi, that is a village at Al Bahrain .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.658]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 658

Narrated Abu Huraira:

The Prophet sent some cavalry towards Najd and they brought a man from the tribe of Banu Hanifa who was called Thumama bin Uthal. They fastened him to one of the pillars of the Mosque. The Prophet went to him and said, "What have you got, O Thumama?" He replied," I have got a good thought, O Muhammad! If you should kill me, you would kill a person who has already killed somebody, and if you should set me free, you would do a favor to one who is grateful, and if you want property, then ask me whatever wealth you want." He was left till the next day when the Prophet said to him, "What have you got, Thumama? He said, "What I told you, i.e. if you set me free, you would do a favor to one who is grateful." The Prophet left him till the day after, when he said, "What have you got, O Thumama?" He said, "I have got what I told you. "On that the Prophet said, "Release Thumama." So he (i.e. Thumama) went to a garden of date-palm trees near to the Mosque, took a bath and then entered the Mosque and said, "I testify that None has the right to be worshipped except Allah, and also testify that Muhammad is His Apostle! By Allah, O Muhammad! There was no face on the surface of the earth most disliked by me than yours, but now your face has become the most beloved face to me. By Allah, there was no religion most disliked by me than yours, but now it is the most beloved religion to me. By Allah, there was no town most disliked by me than your town, but now it is the most beloved town to me. Your cavalry arrested me (at the time) when I was intending to perform the 'Umra. And now what do you think?" The Prophet gave him good tidings (congratulated him) and ordered him to perform the 'Umra. So when he came to Mecca, someone said to him, "You have become a Sabian?" Thumama replied, "No! By Allah, I have embraced Islam with Muhammad, Apostle of Allah. No, by Allah! Not a single grain of wheat will come to you from Jamaica unless the Prophet gives his permission."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.659]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 659

Narrated Ibn Abbas:

Musailima Al-Kadhdhab came during the lifetime of the Prophet and started saying, "If Muhammad gives me the rule after him, I will follow him." And he came to Medina with a great number of the people of his tribe. Allah's Apostle went to him in the company of Thabit bin Qais bin Shammas, and at that time, Allah's Apostle had a stick of a date-palm tree in his hand. When he (i.e. the Prophet ) stopped near Musailima while the latter was amidst his companions, he said to him, "If you ask me for this piece (of stick), I will not give it to you, and Allah's Order you cannot avoid, (but you will be destroyed), and if you turn your back from this religion, then Allah will destroy you. And I think you are the same person who was shown to me in my dream, and this is Thabit bin Qais who will answer your questions on my behalf." Then the Prophet went away from him. I asked about the statement of Allah's Apostle : "You seem to be the same person who was shown to me in my dream," and Abu Huraira informed me that Allah's Apostle said, "When I was sleeping, I saw (in a dream) two bangles of gold on my hands and that worried me. And then I was inspired Divinely in the dream that I should blow on them, so I blew on them and both the bangles flew away. And I interpreted it that two liars (who would claim to be prophets) would appear after me. One of them has proved to be Al Ansi and the other, Musailima."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.660]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 660

Narrated Abu Huraira:

Allah's Apostle said, "While I was sleeping, I was given the treasures of the earth and two gold bangles were put in my hands, and I did not like that, but I received the inspiration that I should blow on them, and I did so, and both of them vanished. I interpreted it as referring to the two liars between whom I am present; the ruler of Sana and the Ruler of Yamaha."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.661]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 661

Narrated Abu Raja Al-Utaridi:

We used to worship stones, and when we found a better stone than the first one, we would throw the first one and take the latter, but if we could not get a stone then we would collect some earth (i.e. soil) and then bring a sheep and milk that sheep over it, and perform the Tawaf around it. When the month of Rajab came, we used (to stop the military actions), calling this month the iron remover, for we used to remove and throw away the iron parts of every spear and arrow in the month of Rajab. Abu Raja' added: When the Prophet sent with (Allah's) Message, I was a boy working as a shepherd of my family camels. When we heard the news about the appearance of the Prophet, we ran to the fire, i.e. to Musailima al-Kadhdhab.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.662]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 662

Narrated Ubaidullah bin Abdullah bin Utba:

We were informed that Musailima Al-Kadhdhab had arrived in Medina and stayed in the house of the daughter of Al-Harith. The daughter of Al-Harith bin Kuraiz was his wife and she was the mother of 'Abdullah bin 'Amir. There came to him Allah's Apostle accompanied by Thabit bin Qais bin Shammas who was called the orator of Allah's Apostle. Allah's Apostle had a stick in his hand then. The Prophet stopped before Musailima and spoke to him. Musailima said to him, "If you wish, we would not interfere between you and the rule, on condition that the rule will be ours after you... The Prophet said, "If you asked me for this stick, I would not give it to you. I think you are the same person who was shown to me in a dream. And this is Thabit bin Al-Qais who will answer you on my behalf." The Prophet then went away. I asked Ibn Abbas about the dream Allah's Apostle had mentioned. Ibn Abbas said, "Someone told me that the Prophet said, "When I was sleeping, I saw in a dream that two gold bangles were put in my hands, and that frightened me and made me dislike them. Then I was allowed to blow on them, and when I blew at them, both of them flew. Then I interpreted them as two liars who would appear.' One of them was Al-'Ansi who was killed by Fairuz in Yemen and the other was Musailima Al-Kadhdbab."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.663]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 663

Narrated Hudhaifa:

Al-'Aqib and Saiyid, the rulers of Najran, came to Allah's Apostle with the intention of doing Lian one of them said to the other, "Do not do (this Lian) for, by Allah, if he is a Prophet and we do this Lian, neither we, nor our offspring after us will be successful." Then both of them said (to the Prophet ), "We will give what you should ask but you should send a trustworthy man with us, and do not send any person with us but an honest one." The Prophet said, "I will send an honest man who Is really trustworthy." Then every one of the companions of Allah's Apostle wished to be that one. Then the Prophet said, "Get up, O Abu 'Ubaida bin Al-Jarrah." When he got up, Allah's Apostle said, "This is the Trustworthy man of this (Muslim) nation."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.664]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 664

Narrated Hudhaifa:

The people of Najran came to the Prophet and said, "Send an honest man to us." The Prophet said, "I will send to you an honest man who is really trustworthy." Everyone of the (Muslim) people hoped to be that one. The Prophet then sent Abu Ubaida bin Al-Jarrah.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.665]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 665

Narrated Anas:

The Prophet said, "Every nation has an Amin (i.e. the most honest man), and the Amin of this nation is Abu 'Ubaida bin Al-Jarrah."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.666]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 666

Narrated Jabir bin Abdullah:

Allah's Apostle said to me, "If the revenue of Al-Bahrain should come, I will give you so much and so much," repeating "so much" thrice. But the revenue of Al-Bahrain did not come till Allah's Apostle had died. When the revenue came during the rule of Abu Bakr. Abu Bakr ordered an announcer to announce, "Whoever had any debt or promise due upon the Prophet, should present himself to me (i.e. Abu Bakr). I came to Abu Bakr and informed him that the Prophet had said (to me), "If the revenue of Al-Bahrain should come, I will give you so-much and so much," repeating "so much" thrice. So Abu Bakr gave me (in another narration Jaibir said,). I met Abu Bakr after that and asked him (to give me what the Prophet had promised me) but he did not give me. I again went to him but he did not give me. I again went to him (for the third time) but he did not give me; On that I said to him, "I came to you but you did not give me, then I came to you and you did not give me, and then again I came to you, but you did not give me; so you should either give me or else you are like a miserly to me, on that, Abu Bakr said, "Do you say, 'You are like a miserly to me?' There is no worse disease than miserliness." Abu Bakr said it thrice and added, "Whenever I refused to give you, I had the intention of giving you." (In another narration) Jabir bin 'Abdullah said, "I went to Abu Bakr (and he gave me a handful of money) and told me to count it, I counted and found it five-hundred, and then Abu Bakr said (to me), "Take the same amount twice."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.667]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 667

Narrated Abu Musa:

My brother and I came from Yemen (to Medina) and remained for some time, thinking that Ibn Masud and his mother belonged to the family of the Prophet because of their frequent entrance (upon the Prophet) and their being attached to him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.668]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 668

Narrated Zahdam:

When Abu Musa arrived (at Kufa as a governor) he honored this family of Jarm (by paying them a visit). I was sitting near to him, and he was eating chicken as his lunch, and there was a man sitting amongst the people. Abu Musa invited the man to the lunch, but the latter said, "I saw chickens (eating something (dirty) so I consider them unclean." Abu Musa said, "Come on! I saw the Prophet eating it (i.e. chicken)." The man said "I have taken an oath that I will not ea (chicken)" Abu Musa said." Come on! I will tell you about your oath. We, a group of Al-Ash'ariyin people went to the Prophet and asked him to give us something to ride, but the Prophet refused. Then we asked him for the second time to give us something to ride, but the Prophet took an oath that he would not give us anything to ride. After a while, some camels of booty were brought to the Prophet and he ordered that five camels be given to us. When we took those camels we said, "We have made the Prophet forget his oath, and we will not be successful after that." So I went to the Prophet and said, "O Allah' Apostle ! You took an oath that you would not give us anything to ride, but you have given us." He said, "Yes, for if I take an oath and later I see a better solution than that, I act on the later (and gave the expiation of that oaths"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.669]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 669

Narrated Imran bin Husain:

The people of Banu Tamim came to Allah's Apostle, and he said, "Be glad (i.e. have good tidings). O Banu Tamim!" They said, "As you have given us good tidings then give us (some material things)." On that the features of Allah's Apostle changed (i.e. he took it ill). Then some people from Yemen came, and the Prophet said (to them) "Accept good tidings as Banu Tamim have not accepted them." They said, "We accept them, O Allah's Apostle!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.670]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 670

Narrated Abu Masud: The Prophet beckoned with his hand towards Yemen and said, "Belief is there." The harshness and mercilessness are the qualities of those farmers etc, who are busy with their camels and pay no attention to the religion (is towards


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.671]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 671

Narrated Abu Huraira:

The Prophet said, "The people of Yemen have come to you and they are more gentle and soft-hearted. Belief is Yemenite and Wisdom is Yemenite, while pride and haughtiness are the qualities of the owners of camels (i.e. bedouins). Calmness and solemnity are the characters of the owners of sheep."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.672]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 672

Narrated Abu Huraira:

The Prophet said, "Belief is Yemenite while afflictions appear from there (the east) from where the side of the head of Satan will appear."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.673]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 673

Narrated Abu Huraira:

The Prophet said, "The people of Yemen have come to you, and they are more soft hearted and gentle hearted people. The capacity for understanding religion is Yemenite and Wisdom is Yemenite."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.674]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 674

Narrated Alqama:

We were sitting with Ibn Masud when Khabbab came and said, "O Abu Abdur-Rahman! Can these young fellows recite Qur'an as you do?" Ibn Mas'ud said, "If you wish I can order one of them to recite (Qur'an) for you ." Khabbab replied, "Yes. "Ibn Mas'ud said, "Recite, O 'Alqama!" On that, Zaid bin Hudair, the brother of Ziyad bin Hudair said, (to Ibn Mas'ud), "Why have you ordered 'Alqama to recite though he does not recite better than we?" Ibn Mas'ud said, "If you like, I would tell you what the Prophet said about your nation and his (i.e. 'Alqama's) nation." So I recited fifty Verses from Sura-Maryam. 'Abdullah (bin Mas'ud) said to Khabbab, "What do you think (about 'Alqama's recitation)?" Khabbab said, "He has recited well." 'Abdullah said, "Whatever I recite, 'Alqama recites." Then 'Abdullah turned towards Khabbab and saw that he was wearing a gold ring, whereupon he said, "Hasn't the time for its throwing away come yet?" Khabbab said, "You will not see me wearing it after today," and he throw it away.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.675]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 675

Narrated Abu Huraira:

Tufail bin 'Amr came to the Prophet and said, "The Daus (nation) have perished as they disobeyed and refused to accept Islam. So invoke Allah against them." But the Prophet said, "O Allah! Give guidance to the Daus (tribe) and bring them (to Islam)!"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.676]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 676

Narrated Abu Huraira:

When I came to the Prophet said on my way, "O what a long tedious tiresome night; nevertheless, it has rescued me from the place of Heathenism." A slave of mine ran away on the way. When I reached the Prophet I gave him the oath of allegiance (for Islam), and while I was sitting with him, suddenly the slave appeared. The Prophet said to me. "O Abu Huraira! Here is your slave," I said, "He (i.e. the slave) is (free) for Allah's Sake," and manumitted him.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.677]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 677

Narrated 'Adi bin Hatim:

We came to 'Umar in a delegation (during his rule). He started calling the men one by one, calling each by his name. (As he did not call me early) I said to him. "Don't you know me, O chief of the Believers?" He said, "Yes, you embraced Islam when they (i.e. your people) disbelieved; you have come (to the Truth) when they ran away; you fulfilled your promises when they broke theirs; and you recognized it (i.e. the Truth of Islam) when they denied it." On that, 'Adi said, "I therefore don't care."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.678]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 678

Narrated 'Aisha:

We went out with Allah's Apostle during Hajjat-ul-Wada' and we assumed the Ihram for 'Umra. Then Allah's Apostle said to us, "Whoever has got the Hadi should assume the Ihram for Hajj and 'Umra and should not finish his Ihram till he has performed both ('Umra and Hajj)." I arrived at Mecca along with him (i.e. the Prophet ) while I was menstruating, so I did not perform the Tawaf around the Ka'ba or between Safa and Marwa. I informed Allah's Apostle about that and he said, "Undo your braids and comb your hair, and then assume the lhram for Hajj and leave the 'Umra." I did so, and when we performed and finished the Hajj, Allah's Apostles sent me to At-Tanim along with (my brother) 'Abdur-Rahman bin Abu Bakr As-Siddiq, to perform the 'Umra. The Prophet said, "This 'Umra is in lieu of your missed 'Umra." Those who had assumed the lhram for 'Umra, performed the Tawaf around the Ka'ba and between Safa and Marwa, and then finished their Ihram, and on their return from Mina, they performed another Tawaf (around the Ka'ba and between Safa and Marwa), but those who combined their Hajj and 'Umra, performed only one Tawaf (between Safa and Marwa) (for both).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.679]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 679

Narrated Ibn Juraij:

'Ata' said, "Ibn 'Abbas said, 'If he (i.e. the one intending to perform 'Umra) has performed the Tawaf around the Ka'ba, his Ihram is considered to have finished.' said, 'What proof does Ibn 'Abbas has as to this saying?" 'Ata' said, "(The proof is taken) from the Statement of Allah:-- "And afterwards they are brought For sacrifice unto Ancient House (Ka'ba at Mecca)" (22.33) and from the order of the Prophet to his companions to finish their Ihram during Hajjat-ul-Wada." I said (to 'Ata'), "That (i.e. finishing the Ihram) was after coming form 'Arafat." 'Ata' said, "Ibn 'Abbas used to allow it before going to 'Arafat (after finishing the 'Umra) and after coming from it (i.e. after performing the Hajj)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.680]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 680

Narrated Abu Musa Al-Ashari:

I came to the Prophet at a place called Al-Batha'. The Prophet said, "Did you assume the Ihram for Hajj?" I said, "Yes," He said, "How did you express your intention (for performing Hajj)? " I said, "Labbaik (i.e. I am ready) to assume the Ihram with the same intention as that of Allah's Apostle." The Prophet said, "Perform the Tawaf around the Ka'ba and between Safa and Marwa, and then finish your Ihram." So I performed the Tawaf around the Ka'ba and between Safa and Marwa and then I came to a woman from the tribe of Qais who removed the lice from my head.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.681]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 681

Narrated Hafsa:

(the wife of the Prophet) The Prophet ordered all his wives to finish their Ihram during the year of Hajjat-ul-Wada. On that, I asked the Prophet "What stops you from finishing your lhram?" He said, "I have matted my hair and garlanded my Hadi. So I will not finish my Ihram unless I have slaughtered my Hadi."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.682]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 682

Narrated Ibn Abbas:

A woman from the tribe of Khath'am asked for the verdict of Allah's Apostle (regarding something) during Hajjat-ul-Wada' while Al-Fadl bin 'Abbas was the companion-rider behind Allah's Apostle. She asked, "Allah's ordained obligation (i.e. compulsory Hajj) enjoined on His slaves has become due on my old father who cannot sit firmly on the riding animal. Will it be sufficient if I perform the Hajj on his behalf?" He said, "Yes."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.683]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 683

Narrated (Abdullah) bin 'Umar:

The Prophet arrived (at Mecca) in the year of the Conquest (of Mecca) while Usama was riding behind him on (his she-camel)'. Al-Qaswa.' Bilal and 'Uthman bin Talha were accompanying him. When he made his she-camel kneel down near the Ka'ba, he said to 'Uthman, "Get us the key (of the Ka'ba). He brought the key to him and opened the gate (of the Ka'ba), for him. The Prophet, Usama, Bilal and 'Uthman (bin Talha) entered the Ka'ba and then closed the gate behind them (from inside). The Prophet stayed there for a long period and then came out. The people rushed to get in, but I went in before them and found Bilal standing behind the gate, and I said to him, "Where did the Prophet pray?" He said, "He prayed between those two front pillars." The Ka'ba was built on six pillars, arranged in two rows, and he prayed between the two pillars of the front row leaving the gate of the Ka'ba at his back and facing (in prayer) the wall which faces one when one enters the Ka'ba. Between him and that wall (was the distance of about three cubits). But I forgot to ask Bilal about the number of Rakat the Prophet had prayed. There was a red piece of marble at the place where he (i.e. the Prophet) had offered the prayer.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.684]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 684

Narrated 'Aisha:

(the wife of the Prophet) Safiya bin Huyai, the wife of the Prophet menstruated during Hajjat-ul-Wada' The Prophet said, "Is she going to detain us?" I said to him, "She has already come to Mecca and performed the Tawaf (ul-ifada) around the Ka'ba, O Allah's Apostle." The Prophet said, " Let her then proceed on (to Medina)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.685]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 685

Narrated Ibn Umar:

We were talking about Hajjat-ul-Wada, while the Prophet was amongst us. We did not know what Hajjat-ul-Wada' signified. The Prophet praised Allah and then mentioned Al-Masih Ad-Dajjal and described him extensively, saying, "Allah did not send any prophet but that prophet warned his nation of Al-Masih Ad-Dajjal. Noah and the prophets following him warned (their people) of him. He will appear amongst you (O Muhammad's followers), and if it happens that some of his qualities may be hidden from you, but your Lord's State is clear to you and not hidden from you. The Prophet said it thrice. Verily, your Lord is not blind in one eye, while he (i.e. Ad-Dajjal) is blind in the right eye which looks like a grape bulging out (of its cluster). No doubt,! Allah has made your blood and your properties sacred to one another like the sanctity of this day of yours, in this town of yours, in this month of yours." The Prophet added: No doubt! Haven't I conveyed Allah's Message to you? " They replied, "Yes," The Prophet said thrice, "O Allah! Be witness for it." The Prophet added, "Woe to you!" (or said), "May Allah be merciful to you! Do not become infidels after me (i.e. my death) by cutting the necks (throats) of one another."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.686]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 686

Narrated Zaid bin Arqam:

The Prophet fought nineteen Ghazwas and performed only one Hajj after he migrated (to Medina), and did not perform another Hajj after it, and that was Hajj-ul-Wada,' Abu Ishaq said, "He performed when he was in Mecca."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.687]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 687

Narrated Jarir:

The Prophet ordered me during Hajjatul-Wada'. "Ask the people to listen." He then said, "Do not become infidels after me by cutting the necks (throats) of one another. "


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.688]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 688

Narrated Abu Bakra:

The Prophet said, "Time has taken its original shape which it had when Allah created the Heavens and the Earth. The year is of twelve months, four of which are sacred, and out of these (four) three are in succession, i.e. Dhul-Qa'da, Dhul-Hijja and Al-Muharram, and the fourth is Rajab which is named after the Mudar tribe, between (the month of) Jumaida (ath-thania) and Sha'ban." Then the Prophet asked, "Which is this month?" We said, "Allah and His Apostle know better." On that the Prophet kept quiet so long that we thought that he might name it with another name. Then the Prophet said, "Isn't it the month of Dhul-Hijja?" We replied, "Yes." Then he said, "Which town is this?" "We replied, "Allah and His Apostle know better." On that he kept quiet so long that we thought that he might name it with another name. Then he said, "Isn't it the town of Mecca?" We replied, "Yes, " Then he said, "Which day is today?" We replied, "Allah and His Apostle know better." He kept quiet so long that we thought that he might name it with another name. Then he said, "Isn't it the day of An-Nahr (i.e. sacrifice)?" We replied, "Yes." He said, "So your blood, your properties, (The sub-narrator Muhammad said, 'I think the Prophet also said: And your honor..) are sacred to one another like the sanctity of this day of yours, in this city of yours, in this month of yours; and surely, you will meet your Lord, and He will ask you about your deeds. Beware! Do not become infidels after me, cutting the throats of one another. It is incumbent on those who are present to convey this message (of mine) to those who are absent. May be that some of those to whom it will be conveyed will understand it better than those who have actually heard it." (The sub-narrator, Muhammad, on remembering that narration, used to say, "Muhammad spoke the truth!") He (i.e. Prophet) then added twice, "No doubt! Haven't I conveyed (Allah's Message) to you?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.689]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 689

Narrated Tariq bin Shibab:

Some Jews said, "Had this Verse been revealed to us, we would have taken that day as 'Id (festival)." 'Umar said, "What Verse?" They said:-- "This day I have Perfected your religion for you, Completed My Favor upon you And have chosen for you Islam as your religion" (5.3) 'Umar said, "I know the place where it was revealed; It was revealed while Allah's Apostle was staying at 'Arafat."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.690]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 690

Narrated 'Aisha:

We set out with Allah's Apostle, and some of us assumed the lhram for 'Umra, some assumed it for Hajj, and some assumed it for both Hajj and 'Umra. Allah's Apostle assumed the Ihram for Hajj. So those who had assumed the Ihram for Hajj or for both Hajj and 'Umra, did not finish their Ihram till the day of An-Nahr (i.e. slaughter of sacrifices).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.691]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 691

Narrated Malik:

The same as above (Hadith 690), saying, "(We set out) with Allah's Apostle in Hajjat-ul-Wada'...)"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.692]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 692

Narrated Malik:

The same as above (Hadith 690).


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.693]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 693

Narrated Sad:

The Prophet visited me during Hajjat ul-Wada' while I was suffering from a disease which brought me to the verge of death. I said, "O Allah's Apostle! My ailment has reached such a (bad) state as you see, and I have much wealth, but I have no-one to inherit from me except my only daughter. Shall I give 2/3 of my property as alms (in charity)?" The Prophet said, "No," I said, "Shall I give half of my property as alms?" He said, "No." I said, "(Shall I give) 1/3 of it? " He replied, " 1/3, and even 1/3 is too much. It is better for you to leave your inheritors wealthy rather than to leave them poor, begging people (for their sustenance); and whatever you spend for Allah's Sake, you will get reward for it even for the morsel of food which you put in your wives mouth." I said, "O Allah's Apostle! Should I remain (in Mecca) behind my companions (who are going with you to Medina)?" The Prophet said, "If you remain behind, any good deed which you will do for Allah's Sake, will upgrade and elevate you. May be you will live longer so that some people may benefit by you and some other (i.e. infidels) may get harmed by you." The Prophet then added, "O Allah! Complete the Migration of my companions and do not turn them on their heels. But the poor Sad bin Khaula (not the above mentioned Sad) (died in Mecca) ." Allah's Apostle pitied Sad for he died in Mecca.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.694]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 694

Narrated Ibn 'Umar:

The Prophet got his head shaved during Hajjat-ul-Wada.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.695]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 695

Narrated Ibn Umar:

During Hajjat-ul-Wada', the Prophet and some of his companions got their heads shaved while some of his companions got their head-hair cut short.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.696]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 696

Narrated 'Abdullah bin 'Abbas:

That he came riding a donkey when Allah 's Apostle was standing at Mina during Hajjat-ul-Wada', leading the people in prayer. The donkey passed in front of a part of the row (of the people offering the prayer). Then he dismounted from it and took his position in the row with the people.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.697]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 697

Narrated Hisham's father:

In my presence, Usama was asked about the speed of the Prophet during his Hajj. He replied, "It was Al-'Anaq (i.e. moderate easy speed) and if he encountered an open space, he used to increase his speed."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.698]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 698

Narrated 'Abdullah bin Yazid Al-Khatmi:

That Abu Aiyub informed him that he offered the Maghrib and 'Isha' prayers together with the Prophet during Hajjat-ul-Wada.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.699]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 699

Narrated Abu Musa:

My Companions sent me to Allah's Apostle to ask him for some animals to ride on as they were accompanying him in the army of Al-Usra, and that was the Ghazwa (Battle) of Tabuk, I said, "O Allah's Prophet! My companions have sent me to you to provide them with means of transportation." He said, "By Allah! I will not make you ride anything." It happened that when I reached him, he was in an angry mood, and I didn't notice it. So I returned in a sad mood because of the refusal the Prophet and for the fear that the Prophet might have become 'angry with me. So I returned to my companions and informed them of what the Prophet had said. Only a short while had passed when I heard Bilal calling, "O 'Abdullah bin Qais!" I replied to his call. Bilal said, "Respond to Allah's Apostle who is calling you." When I went to him (i.e. the Prophet), he said, "Take these two camels tied together and also these two camels tied together,"' referring to six camels he had brought them from Sad at that time. The Prophet added, "Take them to your companions and say, 'Allah (or Allah's Apostle ) allows you to ride on these,' so ride on them." So I took those camels to them and said, "The Prophet allows you to ride on these (camels) but by Allah, I will not leave you till some of you proceed with me to somebody who heard the statement of Allah's Apostle. Do not think that I narrate to you a thing which Allah's Apostle has not said." They said to me, "We consider you truthful, and we will do what you like." The sub-narrator added: So Abu Musa proceeded along with some of them till they came to those who have heard the statement of Allah's Apostle wherein he denied them (some animals to ride on) and (his statement) whereby he gave them the same. So these people told them the same information as Abu Musa had told them.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.700]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 700

Narrated Sad:

Allah's Apostle set out for Tabuk. appointing 'Ali as his deputy (in Medina). 'Ali said, "Do you want to leave me with the children and women?" The Prophet said, "Will you not be pleased that you will be to me like Aaron to Moses? But there will be no prophet after me."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.701]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 701

Narrated Safwan bin Yala bin Umaiya:

that his father said, "I participated in Al-Usra (i.e. Tabuk) along with the Prophet." Yala added, "(My participation in) that Ghazwa was the best of my deeds to me." Ya'la said, "I had a laborer who quarrelled with somebody, and one of the two bit the hand of the other ('Ata', the sub-narrator, said, "Safwan told me who bit whom but I forgot it"), and the one who was bitten, pulled his hand out of the mouth of the biter, so one of the incisors of the biter was broken. So we came to the Prophet and he considered the biter's claim as invalid (i.e. the biter did not get a recompense for his broken incisor). The Prophet said, "Should he leave his hand in your mouth so that you might snap it as if it were in the mouth of a male camel to snap it?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.702]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 702

Narrated Abdullah bin Kab bin Malik:

Who, from among Kab's sons, was the guide of Kab when he became blind: I heard Kab bin Malik narrating the story of (the Ghazwa of) Tabuk in which he failed to take part. Kab said, "I did not remain behind Allah's Apostle in any Ghazwa that he fought except the Ghazwa of Tabuk, and I failed to take part in the Ghazwa of Badr, but Allah did not admonish anyone who had not participated in it, for in fact, Allah's Apostle had gone out in search of the caravan of Quraish till Allah made them (i.e. the Muslims) and their enemy meet without any appointment. I witnessed the night of Al-'Aqaba (pledge) with Allah's Apostle when we pledged for Islam, and I would not exchange it for the Badr battle although the Badr battle is more popular amongst the people than it (i.e. Al-'Aqaba pledge). As for my news (in this battle of Tabuk), I had never been stronger or wealthier than I was when I remained behind the Prophet in that Ghazwa.

By Allah, never had I two she-camels before, but I had then at the time of this Ghazwa. Whenever Allah's Apostle wanted to make a Ghazwa, he used to hide his intention by apparently referring to different Ghazwa till it was the time of that Ghazwa (of Tabuk) which Allah's Apostle fought in severe heat, facing, a long journey, desert, and the great number of enemy. So the Prophet announced to the Muslims clearly (their destination) so that they might get prepared for their Ghazwa. So he informed them clearly of the destination he was going to. Allah's Apostle was accompanied by a large number of Muslims who could not be listed in a book namely, a register." Ka'b added, "Any man who intended to be absent would think that the matter would remain hidden unless Allah revealed it through Divine Revelation. So Allah's Apostle fought that Ghazwa at the time when the fruits had ripened and the shade looked pleasant. Allah's Apostle and his companions prepared for the battle and I started to go out in order to get myself ready along with them, but I returned without doing anything. I would say to myself, 'I can do that.' So I kept on delaying it every now and then till the people got ready and Allah's Apostle and the Muslims along with him departed, and I had not prepared anything for my departure, and I said, I will prepare myself (for departure) one or two days after him, and then join them.' In the morning following their departure, I went out to get myself ready but returned having done nothing. Then again in the next morning, I went out to get ready but returned without doing anything.

Such was the case with me till they hurried away and the battle was missed (by me). Even then I intended to depart to take them over. I wish I had done so! But it was not in my luck. So, after the departure of Allah's Apostle, whenever I went out and walked amongst the people (i.e, the remaining persons), it grieved me that I could see none around me, but one accused of hypocrisy or one of those weak men whom Allah had excused. Allah's Apostle did not remember me till he reached Tabuk. So while he was sitting amongst the people in Tabuk, he said, 'What did Ka'b do?' A man from Banu Salama said, 'O Allah's Apostle! He has been stopped by his two Burdas (i.e. garments) and his looking at his own flanks with pride.' Then Mu'adh bin Jabal said, 'What a bad thing you have said! By Allah! O Allahs Apostle! We know nothing about him but good.' Allah's Apostle kept silent." Ka'b bin Malik added, "When I heard that he (i.e. the Prophet ) was on his way back to Medina. I got dipped in my concern, and began to think of false excuses, saying to myself, 'How can I avoid his anger tomorrow?' And I took the advice of wise member of my family in this matter. When it was said that Allah's Apostle, had come near all the evil false excuses abandoned from my mind and I knew well that I could never come out of this problem by forging a false statement. Then I decided firmly to speak the truth. So Allah's Apostle arrived in the morning, and whenever he returned from a journey., he used to visit the Mosque first of all and offer a two-Rak'at prayer therein and then sit for the people. So when he had done all that (this time), those who had failed to join the battle (of Tabuk) came and started offering (false) excuses and taking oaths before him. They were something over eighty men; Allah's Apostle accepted the excuses they had expressed, took their pledge of allegiance asked for Allah's Forgiveness for them, and left the secrets of their hearts for Allah to judge. Then I came to him, and when I greeted him, he smiled a smile of an angry person and then said, 'Come on.' So I came walking till I sat before him. He said to me, 'What stopped you from joining us. Had you not purchased an animal For carrying you?' I answered, "Yes, O Allah's Apostle! But by Allah, if I were sitting before any person from among the people of the world other than you, I would have avoided his anger with an excuse.

By Allah, I have been bestowed with the power of speaking fluently and eloquently, but by Allah, I knew well that if today I tell you a lie to seek your favor, Allah would surely make you angry with me in the near future, but if I tell you the truth, though you will get angry because of it, I hope for Allah's Forgiveness. Really, by Allah, there was no excuse for me. By Allah, I had never been stronger or wealthier than I was when I remained behind you.' Then Allah's Apostle said, 'As regards this man, he has surely told the truth. So get up till Allah decides your case.' I got up, and many men of Banu Salama followed me and said to me. 'By Allah, we never witnessed you doing any sin before this. Surely, you failed to offer excuse to Allah's Apostle as the others who did not join him, have offered. The prayer of Allah's Apostle to Allah to forgive you would have been sufficient for you.' By Allah, they continued blaming me so much that I intended to return (to the Prophet) and accuse myself of having told a lie, but I said to them, 'Is there anybody else who has met the same fate as I have?' They replied, 'Yes, there are two men who have said the same thing as you have, and to both of them was given the same order as given to you.' I said, 'Who are they?' They replied, Murara bin Ar-Rabi Al-Amri and Hilal bin Umaiya Al-Waqifi.' By that they mentioned to me two pious men who had attended the Ghazwa (Battle) of Badr, and in whom there was an example for me. So I did not change my mind when they mentioned them to me. Allah's Apostle forbade all the Muslims to talk to us, the three aforesaid persons out of all those who had remained behind in that Ghazwa. So we kept away from the people and they changed their attitude towards us till the very land (where I lived) appeared strange to me as if I did not know it.

We remained in that condition for fifty nights. As regards my two fellows, they remained in their houses and kept on weeping, but I was the youngest of them and the firmest of them, so I used to go out and witness the prayers along with the Muslims and roam about in the markets, but none would talk to me, and I would come to Allah's Apostle and greet him while he was sitting In his gathering after the prayer, and I would wonder whether the Prophet did move his lips in return to my greetings or not. Then I would offer my prayer near to him and look at him stealthily. When I was busy with my prayer, he would turn his face towards me, but when I turned my face to him, he would turn his face away from me. When this harsh attitude of the people lasted long, I walked till I scaled the wall of the garden of Abu Qatada who was my cousin and dearest person to me, and I offered my greetings to him. By Allah, he did not return my greetings. I said, 'O Abu Qatada! I beseech you by Allah! Do you know that I love Allah and His Apostle?' He kept quiet. I asked him again, beseeching him by Allah, but he remained silent. Then I asked him again in the Name of Allah. He said, "Allah and His Apostle know it better.' Thereupon my eyes flowed with tears and I returned and jumped over the wall." Ka'b added, "While I was walking in the market of Medina, suddenly I saw a Nabati (i.e. a Christian farmer) from the Nabatis of Sham who came to sell his grains in Medina, saying, 'Who will lead me to Kab bin Malik?' The people began to point (me) out for him till he came to me and handed me a letter from the king of Ghassan in which the following was written:

"To proceed, I have been informed that your friend (i.e. the Prophet ) has treated you harshly. Anyhow, Allah does not let you live at a place where you feel inferior and your right is lost. So join us, and we will console you."

When I read it, I said to myself, 'This is also a sort of a test.' Then I took the letter to the oven and made a fire therein by burning it. When forty out of the fifty nights elapsed, behold ! There came to me the messenger of Allah's Apostle and said, 'Allah's Apostle orders you to keep away from your wife,' I said, 'Should I divorce her; or else! what should I do?' He said, 'No, only keep aloof from her and do not cohabit her.' The Prophet sent the same message to my two fellows. Then I said to my wife. 'Go to your parents and remain with them till Allah gives His Verdict in this matter." Kab added, "The wife of Hilal bin Umaiya came to Apostle and said, 'O Allah's Apostle! Hilal bin Umaiya is a helpless old man who has no servant to attend on him. Do you dislike that I should serve him? ' He said, 'No (you can serve him) but he should not come near you.' She said, 'By Allah, he has no desire for anything. By, Allah, he has never ceased weeping till his case began till this day of his.'

On that, some of my family members said to me, 'Will you also ask Allah's Apostle to permit your wife (to serve you) as he has permitted the wife of Hilal bin Umaiya to serve him?' I said, 'By Allah, I will not ask the permission of Allah's Apostle regarding her, for I do not know What Allah's Apostle would say if I asked him to permit her (to serve me) while I am a young man.' Then I remained in that state for ten more nights after that till the period of fifty nights was completed starting from the time when Allah's Apostle prohibited the people from talking to us. When I had offered the Fajr prayer on the 50th morning on the roof of one of our houses and while I was sitting in the condition which Allah described (in the Quran) i.e. my very soul seemed straitened to me and even the earth seemed narrow to me for all its spaciousness, there I heard the voice of one who had ascended the mountain of Sala' calling with his loudest voice, 'O Kab bin Malik! Be happy (by receiving good tidings).' I fell down in prostration before Allah, realizing that relief has come. Allah's Apostle had announced the acceptance of our repentance by Allah when he had offered the Fajr prayer. The people then went out to congratulate us. Some bringers of good tidings went out to my two fellows, and a horseman came to me in haste, and a man of Banu Aslam came running and ascended the mountain and his voice was swifter than the horse. When he (i.e. the man) whose voice I had heard, came to me conveying the good tidings, I took off my garments and dressed him with them; and by Allah, I owned no other garments than them on that day. Then I borrowed two garments and wore them and went to Allah's Apostle.

The people started receiving me in batches, congratulating me on Allah's Acceptance of my repentance, saying, 'We congratulate you on Allah's Acceptance of your repentance." Kab further said, "When I entered the Mosque. I saw Allah's Apostle sitting with the people around him. Talha bin Ubaidullah swiftly came to me, shook hands with me and congratulated me. By Allah, none of the Muhajirin (i.e. Emigrants) got up for me except him (i.e. Talha), and I will never forget this for Talha." Kab added, "When I greeted Allah's Apostle he, his face being bright with joy, said "Be happy with the best day that you have got ever since your mother delivered you." Kab added, "I said to the Prophet 'Is this forgiveness from you or from Allah?' He said, 'No, it is from Allah.' Whenever Allah's Apostle became happy, his face would shine as if it were a piece of moon, and we all knew that characteristic of him. When I sat before him, I said, 'O Allah's Apostle! Because of the acceptance of my repentance I will give up all my wealth as alms for the Sake of Allah and His Apostle. Allah's Apostle said, 'Keep some of your wealth, as it will be better for you.' I said, 'So I will keep my share from Khaibar with me,' and added, 'O Allah's Apostle! Allah has saved me for telling the truth; so it is a part of my repentance not to tell but the truth as long as I am alive. By Allah, I do not know anyone of the Muslims whom Allah has helped fortelling the truth more than me. Since I have mentioned that truth to Allah's Apostle till today, I have never intended to tell a lie. I hope that Allah will also save me (from telling lies) the rest of my life. So Allah revealed to His Apostle the Verse:--

"Verily, Allah has forgiven the Prophet, the Muhajirin (i.e. Emigrants (up to His Saying) And be with those who are true (in word and deed)." (9.117-119)

By Allah, Allah has never bestowed upon me, apart from His guiding me to Islam, a Greater blessing than the fact that I did not tell a lie to Allah's Apostle which would have caused me to perish as those who have told a lie perished, for Allah described those who told lies with the worst description He ever attributed to anybody else. Allah said:-- "They (i.e. the hypocrites) will swear by Allah to you when you return to them (up to His Saying) Certainly Allah is not pleased with the rebellious people--" (9.95-96) Kab added, "We, the three persons, differed altogether from those whose excuses Allah's Apostle accepted when they swore to him. He took their pledge of allegiance and asked Allah to forgive them, but Allah's Apostle left our case pending till Allah gave His Judgment about it. As for that Allah said):-- And to the three (He did for give also) who remained behind." (9.118)

What Allah said (in this Verse) does not indicate our failure to take part in the Ghazwa, but it refers to the deferment of making a decision by the Prophet about our case in contrast to the case of those who had taken an oath before him and he excused them by accepting their excuses.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.703]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 703

Narrated Ibn Umar:

When the Prophet passed by Al-Hijr, he said, "Do not enter the dwelling places of those people who were unjust to themselves unless you enter in a weeping state lest the same calamity as of theirs should befall you." Then he covered his head and made his speed fast till he crossed the valley.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.704]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 704

Narrated Ibn Umar:

Allah's Apostle said to his companions who were at Al-Hijr, "Do not enter upon these people who are being punished, except in a weeping state, lest the same calamity as of theirs should befall you..."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.705]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 705

Narrated Urwa bin Al-Mughira:

Al-Mughira bin Shu'ba, said, "The Prophet went out to answer the call of nature and (when he had finished) I got up to pour water for him." I think that he said that the event had taken place during the Ghazwa of Tabuk. Al-Mughira added. "The Prophet washed his face, and when he wanted to wash his forearms, the sleeves of his cloak became tight over them, so he took them out from underneath the cloak and then he washed them (i.e. his forearms) and passed wet hands over his Khuffs."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.706]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 706

Narrated Abu Humaid: We returned in the company of the Prophet from the Ghazwa of Tabuk, and when we looked upon Medina, the Prophet said, "This is Taba (i.e. Medina), and this is Uhud, a mountain that loves us and is loved by us."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.707]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 707

Narrated Anas bin Malik:

Allah's Apostle returned from the Ghazwa of Tabuk, and when he approached Medina, he said, "There are some people in Medina who were with you all the time, you did not travel any portion of the journey nor crossed any valley, but they were with you they (i.e. the people) said, "O Allah's Apostle! Even though they were at Medina?" He said, "Yes, because they were stopped by a genuine excuse."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.708]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 708

Narrated Ibn Abbas:

Allah's Apostle sent a letter to Khosrau with Abdullah bin Hudhafa As-Sahmi and told him to hand it over to the governor of Al-Bahrain. The governor of Al-Bahrain handed it over to Khosrau, and when he read the latter, he tore it into pieces. (The sub-narrator added, "I think that Ibn Al-Musaiyab said, 'Allah 's Apostle invoked (Allah) to tear them all totally Khosrau and his companions) into pieces.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.709]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 709

Narrated Abu Bakra:

During the days (of the battle) of Al-Jamal, Allah benefited me with a word I had heard from Allah's Apostle after I had been about to join the Companions of Al-Jamal (i.e. the camel) and fight along with them. When Allah's Apostle was informed that the Persians had crowned the daughter of Khosrau as their ruler, he said, "Such people as ruled by a lady will never be successful."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.710]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 710

Narrated As-Sa'ib bin Yazid:

I remember that I went out with the boys to (the place called) Thaniyat-ul-Wada to receive Allah's Apostle .


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.711]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 711

Narrated As-Saib:

I remember I went out with the boys to Thaniyat-ul-Wada' to receive the Prophet when he returned from the Ghazwa of Tabuk.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.712]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 712

Narrated Um Al-Fadl bint Al-Harith:

I heard the Prophet reciting Surat-al-Mursalat 'Urfan (77) in the Maghrib prayer, and after that prayer he did not lead us in any prayer till he died.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.713]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 713

Narrated Ibn Abbas:

'Umar bin Al-Khattab used to let Ibn Abbas sit beside him, so 'AbdurRahman bin 'Auf said to 'Umar, "We have sons similar to him." 'Umar replied, "(I respect him) because of his status that you know." 'Umar then asked Ibn 'Abbas about the meaning of this Holy Verse:-- "When comes the help of Allah and the conquest of Mecca . . ." (110.1)

Ibn 'Abbas replied, "That indicated the death of Allah's Apostle which Allah informed him of." 'Umar said, "I do not understand of it except what you understand."

Narrated 'Aisha: The Prophet in his ailment in which he died, used to say, "O 'Aisha! I still feel the pain caused by the food I ate at Khaibar, and at this time, I feel as if my aorta is being cut from that poison."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.714]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 714

Narrated 'Aisha:

Whenever Allah's Apostle became ill, he used to recite Al-Muawidhatan (i.e. the last two Suras of the Qur'an) and then blow his breath and passed his hand over himself. When he had his fatal illness, I started reciting Al-Muawidhatan and blowing my breath over him as he used to do, and then I rubbed the hand of the Prophet over his body.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.715]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 715

Narrated 'Aisha:

I heard the Prophet and listened to him before his death while he was Lying supported on his back, and he was saying, "O Allah! Forgive me, and bestow Your Mercy on me, and let me meet the (highest) companions (of the Hereafter)." See the Qur'an (4.69) and See Hadith No. 719.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.716]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 716

Narrated Ibn Abbas:

Thursday! And how great that Thursday was! The ailment of Allah's Apostle became worse (on Thursday) and he said, fetch me something so that I may write to you something after which you will never go astray." The people (present there) differed in this matter, and it was not right to differ before a prophet. Some said, "What is wrong with him ? (Do you think ) he is delirious (seriously ill)? Ask him ( to understand his state )." So they went to the Prophet and asked him again. The Prophet said, "Leave me, for my present state is better than what you call me for." Then he ordered them to do three things. He said, "Turn the pagans out of the 'Arabian Peninsula; respect and give gifts to the foreign delegations as you have seen me dealing with them." (Said bin Jubair, the sub-narrator said that Ibn Abbas kept quiet as rewards the third order, or he said, "I forgot it.") (See Hadith No. 116 Vol. 1)


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.717]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 717

Narrated Ubaidullah bin 'Abdullah:

Ibn Abbas said, "When Allah's Apostle was on his deathbed and there were some men in the house, he said, 'Come near, I will write for you something after which you will not go astray.' Some of them ( i.e. his companions) said, 'Allah's Apostle is seriously ill and you have the (Holy) Quran. Allah's Book is sufficient for us.' So the people in the house differed and started disputing. Some of them said, 'Give him writing material so that he may write for you something after which you will not go astray.' while the others said the other way round. So when their talk and differences increased, Allah's Apostle said, "Get up." Ibn Abbas used to say, "No doubt, it was very unfortunate (a great disaster) that Allah's Apostle was prevented from writing for them that writing because of their differences and noise."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.718]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 718

Narrated 'Aisha:

The Prophet called Fatima during his fatal illness and told her something secretly and she wept. Then he called her again and told her something secretly, and she started laughing. When we asked her about that, she said, "The Prophet first told me secretly that he would expire in that disease in which he died, so I wept; then he told me secretly that I would be the first of his family to follow him, so I laughed ( at that time)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.719]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 719

Narrated 'Aisha:

Used to hear (from the Prophet) that no Prophet dies till he is given the option to select either the worldly life or the life of the Hereafter. I heard the Prophet in his fatal disease, with his voice becoming hoarse, saying, "In the company of those on whom is the grace of Allah ..( to the end of the Verse )." (4.69) Thereupon I thought that the Prophet had been given the option.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.720]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 720

Narrated 'Aisha:

When the Prophet fell ill in his fatal illness, he started saying, "With the highest companion."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.721]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 721

Narrated Aisha:

When Allah 's Apostle was in good health, he used to say, "Never does a prophet die unless he is shown his place in Paradise ( before his death ), and then he is made alive or given option." When the Prophet became ill and his last moments came while his head was on my thigh, he became unconscious, and when he came to his senses, he looked towards the roof of the house and then said, "O Allah! (Please let me be) with the highest companion." Thereupon I said, "Hence he is not going to stay with us? " Then I came to know that his state was the confirmation of the narration he used to mention to us while he was in good health.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.722]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 722

Narrated Aisha:

'Abdur-Rahman bin Abu Bakr entered upon the Prophet while I was supporting the Prophet on my chest. 'AbdurRahman had a fresh Siwak then and he was cleaning his teeth with it. Allah's Apostle looked at it, so I took the Siwak, cut it (chewed it with my teeth), shook it and made it soft (with water), and then gave it to the Prophet who cleaned his teeth with it. I had never seen Allah's Apostle cleaning his teeth in a better way. After finishing the brushing of his teeth, he lifted his hand or his finger and said thrice, "O Allah! Let me be with the highest companions," and then died. 'Aisha used to say, "He died while his head was resting between my chest and chin."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.723]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 723

Narrated Aisha:

Whenever Allah's Apostle became ill, he used to recite the Muawidhatan and blow his breath over himself (after their recitation ) and rubbed his hands over his body. So when he was afflicted with his fatal illness. I started reciting the Muawidhatan and blowing my breath over him as he used to blow and made the hand of the Prophet pass over his body.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.724]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 724

Narrated 'Aisha:

I heard the Prophet and listened to him before his death while he was leaning his back on me and saying, "O Allah! Forgive me, and bestow Your Mercy on me, and let me meet the companions."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.725]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 725

Narrated Urwa bin Az-Zubair:

'Aisha said, "The Prophet said during his fatal illness, "Allah cursed the Jews for they took the graves of their prophets as places for worship." 'Aisha added, "Had it not been for that (statement of the Prophet ) his grave would have been made conspicuous. But he was afraid that it might be taken as a place for worship."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.726]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 726

Narrated 'Aisha:

The Prophet died while he was between my chest and chin, so I never dislike the death agony for anyone after the Prophet.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.727]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 727

Narrated Aisha:

(the wife of the Prophet) "When the ailment of Allah's Apostle became aggravated, he requested his wives to permit him to be (treated) nursed in my house, and they gave him permission. He came out (to my house), walking between two men with his feet dragging on the ground, between 'Abbas bin 'Abdul--Muttalib and another man" 'Ubaidullah said, "I told 'Abdullah of what 'Aisha had said, 'Abdullah bin 'Abbas said to me, 'Do you know who is the other man whom 'Aisha did not name?' I said, 'No.' Ibn 'Abbas said, 'It was 'Ali bin Abu Talib." 'Aisha, the wife of the Prophet used to narrate saying, "When Allah's Apostle entered my house and his disease became aggravated, he said, " Pour on me the water of seven water skins, the mouths of which have not been untied, so that I may give advice to the people.' So we let him sit in a big basin belonging to Hafsa, the wife of the Prophet and then started to pour water on him from these water skins till he started pointing to us with his hands intending to say, 'You have done your job." 'Aisha added, "Then he went out to the people and led them in prayer and preached to them." 'Aisha and 'Abdullah bin 'Abbas said, "When Allah's Apostle became ill seriously, he started covering his face with his woolen sheet, and when he felt short of breath, he removed it from hi; face and said, 'That is so! Allah's (curse be on the Jews and the Christians, as they took the graves of their prophets as (places of worship),' intending to warn (the Muslims ) of what they had done." 'Aisha added, "I argued with Allah's Apostle repeatedly about that matter (i.e. his order that Abu Bakr should lead the people in prayer in his place when he was ill), and what made me argue so much, was, that it never occurred to my mind that after the Prophet, the people would ever love a man who had taken his place, and I felt that anybody standing in his place, would be a bad omen to the people, so I wanted Allah's Apostle to give up the idea of choosing Abu Bakr (to lead the people in prayer)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.728]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 728

Narrated 'Abdullah bin Abbas:

Ali bin Abu Talib came out of the house of Allah's Apostle during his fatal illness. The people asked, "O Abu Hasan (i.e. Ali)! How is the health of Allah's Apostle this morning?" 'Ali replied, "He has recovered with the Grace of Allah." 'Abbas bin 'Abdul Muttalib held him by the hand and said to him, "In three days you, by Allah, will be ruled (by somebody else ), And by Allah, I feel that Allah's Apostle will die from this ailment of his, for I know how the faces of the offspring of 'Abdul Muttalib look at the time of their death. So let us go to Allah's Apostle and ask him who will take over the Caliphate. If it is given to us we will know as to it, and if it is given to somebody else, we will inform him so that he may tell the new ruler to take care of us." 'Ali said, "By Allah, if we asked Allah's Apostle for it (i.e. the Caliphate) and he denied it us, the people will never give it to us after that. And by Allah, I will not ask Allah's Apostle for it."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.729]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 729

Narrated Anas bin Malik:

While the Muslims were offering the Fajr prayer on Monday and Abu Bakr was leading them in prayer, suddenly Allah's Apostle lifted the curtain of 'Aisha's dwelling and looked at them while they were in the rows of the prayers and smiled. Abu Bakr retreated to join the row, thinking that Allah's Apostle wanted to come out for the prayer. The Muslims were about to be put to trial in their prayer (i.e. were about to give up praying) because of being overjoyed at seeing Allah's Apostle. But Allah's Apostle beckoned them with his hand to complete their prayer and then entered the dwelling and let fall the curtain.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.730]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 730

Narrated Aisha:

It was one of the favors of Allah towards me that Allah's Apostle expired in my house on the day of my turn while he was leaning against my chest and Allah made my saliva mix with his saliva at his death. 'Abdur-Rahman entered upon me with a Siwak in his hand and I was supporting (the back of) Allah's Apostle (against my chest ). I saw the Prophet looking at it (i.e. Siwak) and I knew that he loved the Siwak, so I said ( to him ), "Shall I take it for you ? " He nodded in agreement. So I took it and it was too stiff for him to use, so I said, "Shall I soften it for you ?" He nodded his approval. So I softened it and he cleaned his teeth with it. In front of him there was a jug or a tin, (The sub-narrator, 'Umar is in doubt as to which was right) containing water. He started dipping his hand in the water and rubbing his face with it, he said, "None has the right to be worshipped except Allah. Death has its agonies." He then lifted his hands (towards the sky) and started saying, "With the highest companion," till he expired and his hand dropped down.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.731]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 731

Narrated Urwa:

'Aisha said, "Allah's Apostle in his fatal illness, used to ask, 'Where will I be tomorrow? Where will I be tomorrow?", seeking 'Aisha's turn. His wives allowed him to stay wherever he wished. So he stayed at 'Aisha's house till he expired while he was with her." 'Aisha added, "The Prophet expired on the day of my turn in my house and he was taken unto Allah while his head was against my chest and his saliva mixed with my saliva." 'Aisha added, "Abdur-Rahman bin Abu Bakr came in, carrying a Siwak he was cleaning his teeth with. Allah's Apostle looked at it and I said to him, 'O 'AbdurRahman! Give me this Siwak.' So he gave it to me and I cut it, chewed it (it's end) and gave it to Allah's Apostle who cleaned his teeth with it while he was resting against my chest."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.732]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 732

Narrated 'Aisha:

The Prophet expired in my house and on the day of my turn, leaning against my chest. One of us (i.e. the Prophet's wives ) used to recite a prayer asking Allah to protect him from all evils when he became sick. So I started asking Allah to protect him from all evils (by reciting a prayer ). He raised his head towards the sky and said, "With the highest companions, with the highest companions." 'Abdur-Rahman bin Abu Bakr passed carrying a fresh leaf-stalk of a date-palm and the Prophet looked at it and I thought that the Prophet was in need of it (for cleaning his teeth ). So I took it (from 'Abdur Rahman) and chewed its head and shook it and gave it to the Prophet who cleaned his teeth with it, in the best way he had ever cleaned his teeth, and then he gave it to me, and suddenly his hand dropped down or it fell from his hand (i.e. he expired). So Allah made my saliva mix with his saliva on his last day on earth and his first day in the Hereafter.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.733]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 733

Narrated 'Aisha:

Abu Bakr came from his house at As-Sunh on a horse. He dismounted and entered the Mosque, but did not speak to the people till he entered upon 'Aisha and went straight to Allah's Apostle who was covered with Hibra cloth (i.e. a kind of Yemenite cloth). He then uncovered the Prophet's face and bowed over him and kissed him and wept, saying, "Let my father and mother be sacrificed for you. By Allah, Allah will never cause you to die twice. As for the death which was written for you, has come upon you."

Narrated Ibn 'Abbas: Abu Bakr went out while Umar bin Al-Khattab was talking to the people. Abu Bakr said, "Sit down, O 'Umar!" But 'Umar refused to sit down. So the people came to Abu Bakr and left Umar. Abu Bakr said, "To proceed, if anyone amongst you used to worship Muhammad , then Muhammad is dead, but if (anyone of) you used to worship Allah, then Allah is Alive and shall never die. Allah said:--"Muhammad is no more than an Apostle, and indeed (many) apostles have passed away before him..(till the end of the Verse )......Allah will reward to those who are thankful." (3.144) By Allah, it was as if the people never knew that Allah had revealed this Verse before till Abu Bakr recited it and all the people received it from him, and I heard everybody reciting it (then).

Narrated Az-Zuhri: Said bin Al-Musaiyab told me that 'Umar said, "By Allah, when I heard Abu Bakr reciting it, my legs could not support me and I fell down at the very moment of hearing him reciting it, declaring that the Prophet had died."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.734]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 734

Narrated Aisha and Ibn Abbas:

Abu Bakr kissed the Prophet after his death.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.735]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 735

Narrated 'Aisha:

We poured medicine in one side of the Prophet's mouth during his illness and he started pointing to us, meaning to say, "Don't pour medicine in my mouth." We said, "(He says so) because a patient dislikes medicines." When he improved and felt a little better, he said, "Didn't I forbid you to pour medicine in my mouth ?" We said, " ( We thought it was because of) the dislike, patients have for medicines. He said, "Let everyone present in the house be given medicine by pouring it in his mouth while I am looking at him, except 'Abbas as he has not witnessed you (doing the same to me)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.736]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 736

Narrated Al-Aswad:

It was mentioned in the presence of 'Aisha that the Prophet had appointed 'Ali as successor by will. Thereupon she said, "Who said so? I saw the Prophet, while I was supporting him against my chest. He asked for a tray, and then fell on one side and expired, and I did not feel it. So how (do the people say) he appointed 'Ali as his successor?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.737]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 737

Narrated Talha:

I asked 'Abdullah bin Abu 'Aufa "Did the Prophet make a will? ' He replied, "No." I further asked, "How comes it that the making of a will was enjoined on the people or that they were ordered to make it? " He said, "The Prophet made a will concerning Allah's Book."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.738]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 738

Narrated 'Amir bin Al-Harith:

Allah's Apostle did not leave a Dinar or a Dirham or a male or a female slave. He left only his white mule on which he used to ride, and his weapons, and a piece of land which he gave in charity for the needy travelers.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.739]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 739

Narrated Anas:

When the ailment of the Prophet got aggravated, he became unconscious whereupon Fatima said, "Oh, how distressed my father is!" He said, "Your father will have no more distress after today." When he expired, she said, "O Father! Who has responded to the call of the Lord Who has invited him! O Father, whose dwelling place is the Garden of Paradise (i.e. Al-Firdaus)! O Father! We convey this news (of your death) to Gabriel." When he was buried, Fatima said, "O Anas! Do you feel pleased to throw earth over Allah's Apostle?"


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.740]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 740

Narrated 'Aisha:

When the Prophet was healthy, he used to say, "No soul of a prophet is captured till he is shown his place in Paradise and then he is given the option." When death approached him while his head was on my thigh, he became unconscious and then recovered his consciousness. He then looked at the ceiling of the house and said, "O Allah! (with) the highest companions." I said (to myself), "Hence, he is not going to choose us." Then I realized that what he had said was the application of the narration which he used to mention to us when he was healthy. The last word he spoke was, "O Allah! (with) the highest companion."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.741]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 741

Narrated Aisha and Ibn 'Abbas:

The Prophet stayed for ten years in Mecca with the Qur'an being revealed to him and he stayed in Medina for ten years.'


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.742]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 742

Narrated 'Aisha:

Allah 's Apostle died when he was sixty-three years of age.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.743]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 743

Narrated 'Aisha:

The Prophet died while his armor was mortgaged to a Jew for thirty Sa's of barley.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.744]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 744

Narrated Salim's father:

The Prophet appointed Usama as the commander of the troops (to be sent to Syria). The Muslims spoke about Usama (unfavorably ). The Prophet said, " I have been informed that you spoke about Usama. (Let it be known that ) he is the most beloved of all people to me."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.745]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 745

Narrated Abdullah bin 'Umar:

Allah's Apostle sent troops appointed Usama bin Zaid as their commander. The people criticized his leadership. Allah's Apostle got up and said, "If you (people) are criticizing his (i.e. Usama's) leadership you used to criticize the leadership of his father before. By Allah, he (i.e. Zaid) deserved the leadership indeed, and he used to be one of the most beloved persons to me, and now this (i.e. his son, Usama) is one of the most beloved persons to me after him."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.746]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 746

Narrated Ibn Abu Habib:

Abu Al-Khair said, "As-Sanabih, I asked (me), 'When did you migrate?' I (i.e. Abu Al-Khair) said, 'We went out from Yemen as emigrants and arrived at Al-Juhfa, and there came a rider whom I asked about the news. The rider said: We buried the Prophet five days ago." I asked (As-Sanabihi), 'Did you hear anything about the night of Qadr?' He replied, 'Bilal, the Mu'adhdhin of the Prophet informed me that it is on one of the seven nights of the last ten days (of Ramadan)."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.747]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 747

Narrated Abu Ishaq:

I asked Zaid bin Al-Arqam, "In how many Ghazawat did you take part in the company of Allah's Apostle?" He replied, "Seventeen." I further asked, "How many Ghazawat did the Prophet fight?" He replied, "Nineteen."


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.748]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 748

Narrated Al-Bara:

I fought fifteen Ghazawat in the company of the Prophet.


Bukhari :: Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi) :: [5.59.749]

Military Expeditions led by the Prophet (pbuh) (Al-Maghaazi)

Bukhari :: Book 5 :: Volume 59 :: Hadith 749

Narrated Buraida:

That he fought sixteen Ghazawat with Allah's Apostle.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.1]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 1

Narrated Abu Said bin Al-Mu'alla:

While I was praying in the Mosque, Allah's Apostle called me but I did not respond to him. Later I said, "O Allah's Apostle! I was praying." He said, "Didn't Allah say'--"Give your response to Allah (by obeying Him) and to His Apostle when he calls you." (8.24)

He then said to me, "I will teach you a Sura which is the greatest Sura in the Qur'an, before you leave the Mosque." Then he got hold of my hand, and when he intended to leave (the Mosque), I said to him, "Didn't you say to me, 'I will teach you a Sura which is the greatest Sura in the Quran?' He said, "Al-Hamdu-Lillah Rabbi-l-Alamin (i.e. Praise be to Allah, the Lord of the worlds) which is Al-Sab'a Al-Mathani (i.e. seven repeatedly recited Verses) and the Grand Qur'an which has been given to me."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.2]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 2

Narrated Abu Huraira:

Allah's Apostle said, "When the Imam says: 'Ghair-il-Maghdubi 'Alaihim Walad-Dallin (i.e. not the path of those who earn Your Anger, nor the path of those who went astray (1.7)), then you must say, 'Ameen', for if one's utterance of 'Ameen' coincides with that of the angels, then his past sins will be forgiven."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.3]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 3

Narrated Anas:

The Prophet said, "On the Day of Resurrection the Believers will assemble and say, 'Let us ask somebody to intercede for us with our Lord.' So they will go to Adam and say, 'You are the father of all the people, and Allah created you with His Own Hands, and ordered the angels to prostrate to you, and taught you the names of all things; so please intercede for us with your Lord, so that He may relieve us from this place of ours.' Adam will say, 'I am not fit for this (i.e. intercession for you).' Then Adam will remember his sin and feel ashamed thereof. He will say, 'Go to Noah, for he was the first Apostle, Allah sent to the inhabitants of the earth.' They will go to him and Noah will say,

'I am not fit for this undertaking.' He will remember his appeal to his Lord to do what he had no knowledge of, then he will feel ashamed thereof and will say, 'Go to the Khalil--r-Rahman (i.e. Abraham).' They will go to him and he will say, 'I am not fit for this undertaking. Go to Moses, the slave to whom Allah spoke (directly) and gave him the Torah .' So they will go to him and he will say, 'I am not fit for this undertaking.' and he will mention (his) killing a person who was not a killer, and so he will feel ashamed thereof before his Lord, and he will say, 'Go to Jesus, Allah's Slave, His Apostle and Allah's Word and a Spirit coming from Him. Jesus will say, 'I am not fit for this undertaking, go to Muhammad the Slave of Allah whose past and future sins were forgiven by Allah.' So they will come to me and I will proceed till I will ask my Lord's Permission and I will be given permission. When I see my Lord, I will fall down in Prostration and He will let me remain in that state as long as He wishes and then I will be addressed.' (Muhammad!) Raise your head. Ask, and your request will be granted; say, and your saying will be listened to; intercede, and your intercession will be accepted.' I will raise my head and praise Allah with a saying (i.e. invocation) He will teach me, and then I will intercede. He will fix a limit for me (to intercede for) whom I will admit into Paradise. Then I will come back again to Allah, and when I see my Lord, the same thing will happen to me. And then I will intercede and Allah will fix a limit for me to intercede whom I will let into Paradise, then I will come back for the third time; and then I will come back for the fourth time, and will say, 'None remains in Hell but those whom the Quran has imprisoned (in Hell) and who have been destined to an eternal stay in Hell.' " (The compiler) Abu 'Abdullah said: 'But those whom the Qur'an has imprisoned in Hell,' refers to the Statement of Allah:

"They will dwell therein forever." (16.29)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.4]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 4

Narrated 'Abdullah:

I asked the Prophet, "What is the greatest sin in the Sight of Allah?" He said, "That you set up a rival unto Allah though He Alone created you." I said, "That is indeed a great sin." Then asked, "What is next?" He said, "To kill your son lest he should share your food with you." I asked, "What is next?" He said, "To commit illegal sexual intercourse with the wife of your neighbor."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.5]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 5

Narrated Said bin Zaid:

Allah's Apostle said, "The Kam'a (i.e. a kind of edible fungus) is like the Manna (in that it is obtained without effort) and its water is a (medicine) cure for eye trouble."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.6]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 6

Narrated Abu Huraira:

The Prophet said, "It was said to the children of Israel, 'Enter the gate (of the town), prostrate (in humility) and say: Hittatun (i.e. repentance) i.e. O Allah!

Forgive our sins.' But they entered by dragging themselves on their buttocks, so they did something different (from what they had been ordered to do) and said, 'Hittatun,' but added, "A grain in a hair."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.7]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 7

Narrated Anas:

'Abdullah bin Salam heard the news of the arrival of Allah's Apostle (at Medina) while he was on a farm collecting its fruits. So he came to the Prophet and said, "I will ask you about three things which nobody knows unless he be a prophet. Firstly, what is the first portent of the Hour? What is the first meal of the people of Paradise? And what makes a baby look like its father or mother?'. The Prophet said, "Just now Gabriel has informed me about that." 'Abdullah said, "Gabriel?" The Prophet said, "Yes." 'Abdullah said, "He, among the angels is the enemy of the Jews." On that the Prophet recited this Holy Verse:--

"Whoever is an enemy to Gabriel (let him die in his fury!) for he has brought it (i.e. Qur'an) down to your heart by Allah's permission." (2.97) Then he added, "As for the first portent of the Hour, it will be a fire that will collect the people from the East to West. And as for the first meal of the people of Paradise, it will be the caudite (i.e. extra) lobe of the fish liver. And if a man's discharge proceeded that of the woman, then the child resembles the father, and if the woman's discharge proceeded that of the man, then the child resembles the mother." On hearing that, 'Abdullah said, "I testify that None has the right to be worshipped but Allah, and that you are the Apostle of Allah, O, Allah's Apostle; the Jews are liars, and if they should come to know that I have embraced Islam, they would accuse me of being a liar." In the meantime some Jews came (to the Prophet) and he asked them, "What is 'Abdullah's status amongst you?" They replied, "He is the best amongst us, and he is our chief and the son of our chief." The Prophet said, "What would you think if 'Abdullah bin Salam embraced Islam?" They replied, "May Allah protect him from this!" Then 'Abdullah came out and said, "I testify that None has the right to be worshipped but Allah and that Muhammad is the Apostle of Allah." The Jews then said, "Abdullah is the worst of us and the son of the worst of us," and disparaged him. On that 'Abdullah said, "O Allah's Apostle! This is what I was afraid of!"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.8]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 8

Narrated Ibn Abbas:

Umar said, "Our best Qur'an reciter is Ubai and our best judge is 'Ali; and in spite of this, we leave some of the statements of Ubai because Ubai says, 'I do not leave anything that I have heard from Allah's Apostle while Allah:

"Whatever verse (Revelations) do We abrogate or cause to be forgotten but We bring a better one or similar to it." (2.106)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.9]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 9

Narrated Ibn Abbas:

The Prophet said, "Allah said, 'The son of Adam tells a lie against me though he has no right to do so, and he abuses Me though he has no right to do so. As for his telling a lie against Me, it is that he claims that I cannot recreate him as I created him before; and as for his abusing Me, it is his statement that I have offspring. No! Glorified be Me! I am far from taking a wife or offspring.' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.10]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 10

Narrated Anas:

Umar said, "I agreed with Allah in three things," or said, "My Lord agreed with me in three things. I said, 'O Allah's Apostle! Would that you took the station of Abraham as a place of prayer.' I also said, 'O Allah's Apostle! Good and bad persons visit you! Would that you ordered the Mothers of the believers to cover themselves with veils.' So the Divine Verses of Al-Hijab (i.e. veiling of the women) were revealed. I came to know that the Prophet had blamed some of his wives so I entered upon them and said, 'You should either stop (troubling the Prophet ) or else Allah will give His Apostle better wives than you.' When I came to one of his wives, she said to me, 'O 'Umar! Does Allah's Apostle haven't what he could advise his wives with, that you try to advise them?' " Thereupon Allah revealed:--

"It may be, if he divorced you (all) his Lord will give him instead of you, wives better than you Muslims (who submit to Allah).." (66.5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.11]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 11

Narrated 'Aisha:

(The wife of the Prophet) Allah's Apostle said, "Don't you see that when your people built the Ka'ba, they did not build it on all Abraham's foundations?" I said, "O Allah's Apostle! Why don't you rebuild it on Abraham's foundations?" He said, "Were your people not so close to (the period of Heathenism, i.e. the Period between their being Muslims and being infidels), I would do so." The sub-narrator, 'Abdullah bin 'Umar said, "Aisha had surely heard Allah's Apostle saying that, for I do not think that Allah's Apostle left touching the two corners of the Ka'ba facing Al-Hijr except because the Ka'ba was not built on all Abraham's foundations."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.12]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 12

Narrated Abu Huraira:

The people of the Scripture (Jews) used to recite the Torah in Hebrew and they used to explain it in Arabic to the Muslims. On that Allah's Apostle said, "Do not believe the people of the Scripture or disbelieve them, but say:-- "We believe in Allah and what is revealed to us." (2.136)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.13]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 13

Narrated Al-Bara:

The Prophet prayed facing Bait-ulMaqdis (i.e. Jerusalem) for sixteen or seventeen months but he wished that his Qibla would be the Ka'ba (at Mecca). (So Allah Revealed (2.144) and he offered 'Asr prayers(in his Mosque facing Ka'ba at Mecca) and some people prayed with him. A man from among those who had prayed with him, went out and passed by some people offering prayer in another mosque, and they were in the state of bowing. He said, "I, (swearing by Allah,) testify that I have prayed with the Prophet facing Mecca." Hearing that, they turned their faces to the Ka'ba while they were still bowing. Some men had died before the Qibla was changed towards the Ka'ba. They had been killed and we did not know what to say about them (i.e. whether their prayers towards Jerusalem were accepted or not). So Allah revealed:-- "And Allah would never make your faith (i.e. prayer) to be lost (i.e. your prayers offered (towards Jerusalem). Truly Allah is Full of Pity, Most Merciful towards mankind." (2.143)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.14]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 14

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Noah will be called on the Day of Resurrection and he will say, 'Labbaik and Sa'daik, O my Lord!' Allah will say, 'Did you convey the Message?' Noah will say, 'Yes.' His nation will then be asked, 'Did he convey the Message to you?' They will say, 'No Warner came to us.' Then Allah will say (to Noah), 'Who will bear witness in your favor?' He will say, 'Muhammad and his followers. So they (i.e. Muslims) will testify that he conveyed the Message. And the Apostle (Muhammad) will be a witness over yourselves, and that is what is meant by the Statement of Allah "Thus We have made of you a just and the best nation that you may be witnesses over mankind and the Apostle (Muhammad) will be a witness over yourselves."

(2.143)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.15]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 15

Narrated Ibn 'Umar:

While some people were offering Fajr prayer in the Quba' mosque, some-one came and said, "Allah has revealed to the Prophet Qur'anic instructions that you should face the Ka'ba (while praying) so you too, should face it." Those people then turned towards the Ka'ba.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.16]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 16

Narrated Anas:

None remains of those who prayed facing both Qiblas (that is, Jerusalem and Mecca) except myself.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.17]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 17

Narrated Ibn 'Umar:

While some people were offering morning prayer at Quba' a man came to them and said, "A Quranic Order has been revealed to Allah's Apostle tonight that he should face the Ka'ba at Mecca (in prayer), so you too should turn your faces towards it." At that moment their faces were towards Sham (i.e. Jerusalem) (and on hearing that) they turned towards the Ka'ba (at Mecca).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.18]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 18

Narrated Ibn Umar:

While some people were offering Fajr prayer at Quba' (mosque), some-one came to them and said, "Tonight some Qur'anic Verses have been revealed to the Prophet and he has been ordered to face the Ka'ba (at Mecca) (during prayers), so you too should turn your faces towards it." At that time their faces were towards Sham (Jerusalem) so they turned towards the Ka'ba (at Mecca).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.19]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 19

Narrated Al-Bara:

We prayed along with the Prophet facing Jerusalem for sixteen or seventeen months. Then Allah ordered him to turn his face towards the Qibla (in Mecca):--

"And from whence-so-ever you start forth (for prayers) turn your face in the direction of (the Sacred Mosque of Mecca) Al-Masjid-ul Haram.." (2.149)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.20]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 20

Narrated Ibn Umar:

While some people were at Quba (offering) morning prayer, a man came to them and said, "Last night Quranic Verses have been revealed whereby the Prophet has been ordered to face the Ka'ba (at Mecca), so you too should face it." So they, keeping their postures, turned towards the Ka'ba. Formerly the people were facing Sham (Jerusalem) (Allah said):--

"And from whence-so-ever you start forth (for prayers), turn your face in the direction of the Sacred Mosque of Mecca (Al-Masjid-ul-Haram), and whence-so-ever you are, turn your face towards it (when you pray)" (2.150)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.21]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 21

Narrated Ibn 'Umar:

While some people were offering Fajr prayer at Quba mosque, someone came to them and said, "Quranic literature" has been revealed to Allah's Apostle tonight, and he has been ordered to face the Ka'ba (of Mecca) so you too, should turn your faces towards it. Their faces were then towards Sham (Jerusalem), so they turned towards the Qibla (i.e. Ka'ba of Mecca)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.22]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 22

Narrated Urwa:

I said to 'Aisha, the wife of the Prophet, and I was at that time a young boy, "How do you interpret the Statement of Allah:

"Verily, Safa and Marwa (i.e. two mountains at Mecca) are among the Symbols of Allah."

So it is not harmful of those who perform the Hajj to the House of Allah) or perform the Umra, to ambulate (Tawaf) between them. In my opinion it is not sinful for one not to ambulate (Tawaf) between them." 'Aisha said, "Your interpretation is wrong for as you say, the Verse should have been: "So it is not harmful of those who perform the Hajj or Umra to the House, not to ambulate (Tawaf) between them.' This Verse was revealed in connection with the Ansar who (during the Pre-Islamic Period) used to visit Manat (i.e. an idol) after assuming their Ihram, and it was situated near Qudaid (i.e. a place at Mecca), and they used to regard it sinful to ambulate between Safa and Marwa after embracing Islam. When Islam came, they asked Allah's Apostle about it, whereupon Allah revealed:--

"Verily, Safa and Marwa (i.e. two mountains at Mecca) are among the Symbols of Allah. So it is not harmful of those who perform the Hajj of the House (of Allah) or perform the Umra, to ambulate (Tawaf) between them." (2.158)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.23]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 23

Narrated 'Asim bin Sulaiman:

I asked Anas bin Malik about Safa and Marwa. Anas replied, "We used to consider (i.e. going around) them a custom of the Pre-islamic period of Ignorance, so when Islam came, we gave up going around them. Then Allah revealed" "Verily, Safa and Marwa (i.e. two mountains at Mecca) are among the Symbols of Allah. So it is not harmful of those who perform the Hajj of the House (of Allah) or perform the Umra to ambulate (Tawaf) between them." (2.158)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.24]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 24

Narrated 'Abdullah:

The Prophet said one statement and I said another. The Prophet said "Whoever dies while still invoking anything other than Allah as a rival to Allah, will enter Hell (Fire)." And I said, "Whoever dies without invoking anything as a rival to Allah, will enter Paradise."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.25]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 25

Narrated Ibn Abbas:

The law of Qisas (i.e. equality in punishment) was prescribed for the children of Israel, but the Diya (i.e. blood money was not ordained for them). So Allah said to this Nation (i.e. Muslims):

"O you who believe! The law of Al-Qisas (i.e. equality in punishment) is prescribed for you in cases of murder: The free for the free, the slave for the slave, and the female for the female. But if the relatives (or one of them) of the killed (person) forgive their brother (i.e. the killers something of Qisas (i.e. not to kill the killer by accepting blood money in the case of intentional murder)----then the relatives (of the killed person) should demand blood-money in a reasonable manner and the killer must pay with handsome gratitude. This is an allevitation and a Mercy from your Lord, (in comparison to what was prescribed for the nations before you).

So after this, whoever transgresses the limits (i.e. to kill the killer after taking the blood-money) shall have a painful torment." (2.178)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.26]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 26

Narrated Anas:

The Prophet said, "The prescribed Law of Allah is the equality in punishment (i.e. Al-Qisas)." (In cases of murders, etc.)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.27]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 27

Narrated Anas:

That his aunt, Ar-Rubai' broke an incisor tooth of a girl. My aunt's family requested the girl's relatives for forgiveness but they refused; then they proposed a compensation, but they refused. Then they went to Allah's Apostle and refused everything except Al-Qisas (i.e. equality in punishment). So Allah's Apostle passed the judgment of Al-Qisas (i.e. equality of punishment). Anas bin Al-Nadr said, "O Allah's Apostle! Will the incisor tooth of Ar-Rubai be broken? No, by Him Who sent you with the Truth, her incisor tooth will not be broken." Allah's Apostle said, "O Anas! The prescribed law of Allah is equality in punishment (i.e. Al-Qisas.)" Thereupon those people became satisfied and forgave her. Then Allah's Apostle said, "Among Allah's Worshippers there are some who, if they took Allah's Oath (for something), Allah fulfill their oaths."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.28]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 28

Narrated Ibn 'Umar:

Fasting was observed on the day of 'Ashura' (i.e. 10th of Muharram) by the people of the Pre-lslamic Period. But when (the order of compulsory fasting) in the month of Ramadan was revealed, the Prophet said, "It is up to one to fast on it (i.e. day of 'Ashura') or not."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.29]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 29

Narrated 'Aisha:

The people used to fast on the day of 'Ashura' before fasting in Ramadan was prescribed but when (the order of compulsory fasting in) Ramadan was revealed, it was up to one to fast on it (i.e. 'Ashura') or not.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.30]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 30

Narrated 'Abdullah:

That Al-Ash'ath entered upon him while he was eating. Al-Ash'ath said, "Today is 'Ashura." I said (to him), "Fasting had been observed (on such a day) before (the order of compulsory fasting in) Ramadan was revealed. But when (the order of fasting in) Ramadan was revealed, fasting (on 'Ashura') was given up, so come and eat."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.31]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 31

Narrated Aisha:

During the Pre-lslamic Period of ignorance the Quraish used to observe fasting on the day of 'Ashura', and the Prophet himself used to observe fasting on it too. But when he came to Medina, he fasted on that day and ordered the Muslims to fast on it. When (the order of compulsory fasting in ) Ramadan was revealed, fasting in Ramadan became an obligation, and fasting on 'Ashura' was given up, and who ever wished to fast (on it) did so, and whoever did not wish to fast on it, did not fast.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.32]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 32

Narrated 'Ata:

That he heard Ibn 'Abbas reciting the Divine Verse:--

"And for those who can fast they had a choice either fast, or feed a poor for every day.." (2.184) Ibn 'Abbas said, "This Verse is not abrogated, but it is meant for old men and old women who have no strength to fast, so they should feed one poor person for each day of fasting (instead of fasting)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.33]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 33

Narrated Nafi:

Ibn 'Umar recited:

"They had a choice, either fast or feed a poor for every day.." and added, "This Verse is abrogated."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.34]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 34

Narrated Salama:

When the Divine Revelation:

"For those who can fast, they had a choice either fast, or feed a poor for every day," (2.184) was revealed, it was permissible for one to give a ransom and give up fasting, till the Verse succeeding it was revealed and abrogated it.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.35]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 35

Narrated Al-Bara:

When the order of compulsory fasting of Ramadan was revealed, the people did not have sexual relations with their wives for the whole month of Ramadan, but some men cheated themselves (by violating that restriction). So Allah revealed:-- "Allah is aware that you were deceiving yourselves but He accepted your repentance and for gave you.." (3.187)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.36]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 36

Narrated Ash-Sha'bi:

'Adi took a white rope (or thread) and a black one, and when some part of the night had passed, he looked at them but he could not distinguish one from the other. The next morning he said, "O Allah's Apostle! I put (a white thread and a black thread) underneath my pillow." The Prophet said, "Then your pillow is too wide if the white thread (of dawn) and the black thread (of the night) are underneath your pillow! "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.37]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 37

Narrated 'Adi bin Hatim:

I said, "O Allah's Apostle! What is the meaning of the white thread distinct from the black thread? Are these two threads?" He said, "You are not intelligent if you watch the two threads." He then added, "No, it is the darkness of the night and the whiteness of the day.''


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.38]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 38

Narrated Sahl bin Sad: The Verse:--

"And eat and drink until the white thread appears to you distinct from the black thread." was revealed, but: '... of dawn' was not revealed (along with it) so some men, when intending to fast, used to tie their legs, one with white thread and the other with black thread and would keep on eating till they could distinguish one thread from the other. Then Allah revealed' ... of dawn,' whereupon they understood that meant the night and the day.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.39]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 39

Narrated Al-Bara:

In the Pre-lslamic Period when the people assumed Ihram, they would enter their houses from the back. So Allah revealed:--

"And it is not righteousness that you enter houses from the back, but the righteous man is he who fears Allah, obeys His Orders and keeps away from what He has forbidden. So enter houses through their doors." (2.189)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.40]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 40

Narrated Nafi':

During the affliction of Ibn Az-Zubair, two men came to Ibn 'Umar and said, "The people are lost, and you are the son of 'Umar, and the companion of the Prophet, so what forbids you from coming out?" He said, "What forbids me is that Allah has prohibited the shedding of my brother's blood." They both said, "Didn't Allah say, 'And fight then until there is no more affliction?" He said "We fought until there was no more affliction and the worship is for Allah (Alone while you want to fight until there is affliction and until the worship become for other than Allah."

Narrated Nafi (through another group of sub-narrators): A man came to Ibn 'Umar and said, "O Abu Abdur Rahman! What made you perform Hajj in one year and Umra in another year and leave the Jihad for Allah' Cause though you know how much Allah recommends it?" Ibn 'Umar replied, "O son of my brother! Islam is founded on five principles, i.e. believe in Allah and His Apostle, the five compulsory prayers, the fasting of the month of Ramadan, the payment of Zakat, and the Hajj to the House (of Allah)." The man said, "O Abu Abdur Rahman! Won't you listen to why Allah has mentioned in His Book: 'If two groups of believers fight each other, then make peace between them, but if one of then transgresses beyond bounds against the other, then you all fight against the one that transgresses. (49.9) and:--"And fight them till there is no more affliction (i.e. no more worshiping of others along with Allah)." Ibn 'Umar said, "We did it, during the lifetime of Allah's Apostle when Islam had only a few followers. A man would be put to trial because of his religion; he would either be killed or tortured. But when the Muslims increased, there was no more afflictions or oppressions." The man said, "What is your opinion about 'Uthman and 'Ali?" Ibn 'Umar said, "As for 'Uthman, it seems that Allah has forgiven him, but you people dislike that he should be forgiven. And as for 'Ali, he is the cousin of Allah's Apostle and his son-in-law." Then he pointed with his hand and said, "That is his house which you see."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.41]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 41

Narrated Abu Wail:

Hudhaifa said, "The Verse:--

"And spend (of your wealth) in the Cause of Allah and do not throw yourselves in destruction," (2.195) was revealed concerning spending in Allah's Cause (i.e. Jihad)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.42]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 42

Narrated 'Abdullah bin Maqal:

I sat with Ka'b bin Ujra in this mosque, i.e. Kufa Mosque, and asked him about the meaning of:--"Pay a ransom (i.e. Fidya) of either fasting or - - - - (2.196) He said, "I was taken to the Prophet while lice were falling on my face. The Prophet said, 'I did not think that your trouble reached to such an extent. Can you afford to slaughter a sheep (as a ransom for shaving your head)?' I said, 'No.' He said, 'Then fast for three days, or feed six poor persons by giving half a Sa of food for each and shave your head.' So the above Verse was revealed especially for me and generally for all of you."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.43]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 43

Narrated 'Imran bin Husain:

The Verse of Hajj-at-Tamatu was revealed in Allah's Book, so we performed it with Allah's Apostle, and nothing was revealed in Qur'an to make it illegal, nor did the Prophet prohibit it till he died. But the man (who regarded it illegal) just expressed what his own mind suggested.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.44]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 44

Narrated Ibn 'Abbas:

'Ukaz, Mijanna and Dhul-Majaz were markets during the Pre-islamic Period. They (i.e. Muslims) considered it a sin to trade there during the Hajj time (i.e. season), so this Verse was revealed:-- "There is no harm for you if you seek of the Bounty of your Lord during the Hajj season." (2.198)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.45]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 45

Narrated 'Aisha:

The Quraish people and those who embraced their religion, used to stay at Muzdalifa and used to call themselves Al-Hums, while the rest of the Arabs used to stay at 'Arafat. When Islam came, Allah ordered His Prophet to go to 'Arafat and stay at it, and then pass on from there, and that is what is meant by the Statement of Allah:--"Then depart from the place whence all the people depart......" (2.199)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.46]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 46

Narrated Ibn 'Abbas:

A man who wants to perform the Hajj (from Mecca) can perform the Tawaf around the Ka'ba as long as he is not in the state of Ihram till he assumes the Ihram for Hajj. Then, if he rides and proceeds to 'Arafat, he should take a Hadi (i.e. animal for sacrifice), either a camel or a cow or a sheep, whatever he can afford; but if he cannot afford it, he should fast for three days during the Hajj before the day of 'Arafat, but if the third day of his fasting happens to be the day of 'Arafat (i.e. 9th of Dhul-Hijja) then it is no sin for him (to fast on it). Then he should proceed to 'Arafat and stay there from the time of the 'Asr prayer till darkness falls. Then the pilgrims should proceed from 'Arafat, and when they have departed from it, they reach Jam' (i.e. Al-Muzdalifa) where they ask Allah to help them to be righteous and dutiful to Him, and there they remember Allah greatly or say Takbir (i.e. Allah is Greater) and Tahlil (i.e. None has the right to be worshipped but Allah) repeatedly before dawn breaks. Then, after offering the morning (Fajr) prayer you should pass on (to Mina) for the people used to do so and Allah said:--

"Then depart from the place whence all the people depart. And ask for Allah's Forgiveness. Truly! Allah is Oft-Forgiving, Most Merciful." (2.199) Then you should go on doing so till you throw pebbles over the Jamra.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.47]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 47

Narrated Anas :

The Prophet used to say, "O Allah! Our Lord! Give us in this world that, which is good and in the Hereafter that, which is good and save us from the torment of the Fire." (2.201)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.48]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 48

Narrated 'Aisha :

The Prophet said, "The most hated man in the Sight of Allah is the one who is the most quarrelsome." Narrated 'Aisha: The Prophet said, "Or do you think that you shall enter Paradise without such (trials) as came to those who passed away before you?" (2.214)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.49]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 49

Narrated Ibn Abu Mulaika:

Ibn 'Abbas recited: "(Respite will be granted) until when the Apostles gave up hope (of their people) and thought that they were denied (by their people). There came to them Our Help ...." (12.110) reading Kudhibu without doubling the sound 'dh', and that was what he understood of the Verse. Then he went on reciting: "..even the Apostle and those who believed along with him said: When (will come) Allah's Help? Yes, verily, Allah's Help is near." (2.214)

Then I met 'Urwa bin Az-Zubair and I mentioned that to him. He said, "Aisha said, 'Allah forbid! By Allah, Allah never promised His Apostle anything but he knew that it would certainly happen before he died. But trials were continuously presented before the Apostles till they were afraid that their followers would accuse them of telling lies. So I used to recite:--

"Till they (come to) think that they were treated as liars." reading 'Kudh-dhibu with double 'dh.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.50]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 50

Narrated Nafi':

Whenever Ibn 'Umar recited the Qur'an, he would not speak to anyone till he had finished his recitation. Once I held the Qur'an and he recited Surat-al-Baqara from his memory and then stopped at a certain Verse and said, "Do you know in what connection this Verse was revealed? " I replied, "No." He said, "It was revealed in such-and-such connection." Ibn 'Umar then resumed his recitation. Nafi added regarding the Verse:--"So go to your tilth when or how you will" Ibn 'Umar said, "It means one should approach his wife in .."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.51]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 51

Narrated Jabir:

Jews used to say: "If one has sexual intercourse with his wife from the back, then she will deliver a squint-eyed child." So this Verse was revealed:--

"Your wives are a tilth unto you; so go to your tilth when or how you will." (2.223)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.52]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 52

Narrated Al-Hasan:

The sister of Ma'qal bin Yasar was divorced by her husband who left her till she had fulfilled her term of 'Iddat (i.e. the period which should elapse before she can Remarry) and then he wanted to remarry her but Maqal refused, so this Verse was revealed:--

"Do not prevent them from marrying their (former) husbands." (2.232)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.53]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 53

Narrated Ibn Az-Zubair:

I said to 'Uthman bin 'Affan (while he was collecting the Qur'an) regarding the Verse:-- "Those of you who die and leave wives ..." (2.240) "This Verse was abrogated by an other Verse. So why should you write it? (Or leave it in the Qur'an)?" 'Uthman said. "O son of my brother! I will not shift anything of it from its place."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.54]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 54

Narrated Mujahi:

(regarding the Verse):-- "Those of you who die and leave wives behind. They - (their wives) -- shall wait (as regards their marriage ) for four months and ten days)." (2.234)

The widow, according to this Verse, was to spend this period of waiting with her husband's family, so Allah revealed: "Those of you who die and leave wives (i.e. widows) should bequeath for their wives, a year's maintenance and residences without turning them out, but if they leave (their residence), there is no blame on you for what they do with themselves provided it is honorable.' (i.e. lawful marriage) (2.240).

So Allah entitled the widow to be bequeathed extra maintenance for seven months and twenty nights, and that is the completion of one year. If she wished she could stay (in her husband's home) according to the will, and she could leave it if she wished, as Allah says:

"..without turning them out, but if they leave (the residence), there is no blame on you." So the 'Idda (i.e. four months and ten days as it) is obligatory for her.

'Ata said: Ibn 'Abbas said, "This Verse, i.e. the Statement of Allah: "..without turning them out.." cancelled the obligation of staying for the waiting period in her dead husband's house, and she can complete this period wherever she likes." 'Ata's aid: If she wished, she could complete her 'Idda by staying in her dead husband's residence according to the will or leave it according to Allah's Statement:--

"There is no blame on you for what they do with themselves." 'Ata' added: Later the regulations of inheritance came and abrogated the order of the dwelling of the widow (in her dead husband's house), so she could complete the 'Idda wherever she likes. And it was no longer necessary to provide her with a residence. Ibn 'Abbas said, "This Verse abrogated her (i.e. widow's) dwelling in her dead husband's house and she could complete the 'Idda (i.e. four months and ten days) wherever she liked, as Allah's Statement says:--"...without turning them out..."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.55]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 55

Narrated Muhammad bin Sirin:

I sat in a gathering in which the chiefs of the Ansar were present, and Abdur-Rahman bin Abu Laila was amongst them. I mentioned the narration of 'Abdullah bin 'Utba regarding the question of Subai'a bint Al-Harith. Abdur-Rahman said, "But 'Abdullah's uncle used not to say so." I said, "I am too brave if I tell a lie concerning a person who is now in Al-Kufa," and I raised my voice. Then I went out and met Malik bin 'Amir or Malik bin 'Auf, and said, "What was the verdict of Ibn Mas'ud about the pregnant widow whose husband had died?" He replied, "Ibn Mas'ud said, 'Why do you impose on her the hard order and don't let her make use of the leave? The shorter Sura of women (i.e. Surat-at-Talaq) was revealed after the longer Sura (i.e. Surat-al-Baqara)." (i.e. Her 'Idda is up till she delivers.)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.56]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 56

Narrated 'Ali:

The Prophet said (as below Hadith 57)).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.57]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 57

Narrated 'Ali: on the day of Al-Khandaq (the battle of the Trench). the Prophet said


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.58]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 58

Narrated Zaid bin Arqam:

We used to speak while in prayer. One of us used to speak to his brother (while in prayer) about his need, till the Verse was revealed:--

"Guard strictly the (five obligatory) prayers, especially the middle (the Best) (Asr) Prayer and stand before Allah with obedience (and not to speak to others during the prayers)." Then we were ordered not to speak in the prayers.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.59]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 59

Narrated Nafi':

Whenever 'Abdullah bin 'Umar was asked about Salat-al-Khauf (i.e. prayer of fear) he said, "The Imam comes forward with a group of people and leads them in a one Rak'a prayer while another group from them who has not prayed yet, stay between the praying group and the enemy. When those who are with the Imam have finished their one Rak'a, they retreat and take the positions of those who have not prayed but they will not finish their prayers with Taslim. Those who have not prayed, come forward to offer a Rak'a with the Imam (while the first group covers them from the enemy). Then the Imam, having offered two Rakat, finishes his prayer. Then each member of the two groups offer the second Rak'a alone after the Imam has finished his prayer. Thus each one of the two groups will have offered two Rakat. But if the fear is too great, they can pray standing on their feet or riding on their mounts, facing the Qibla or not." Nafi added: I do not think that 'Abdullah bin 'Umar narrated this except from Allah's Apostle (See Hadith No. 451, Vol 5 to know exactly "The Fear Prayer.")


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.60]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 60

Narrated Ibn Az-Zubair:

I said to 'Uthman, "This Verse which is in Surat-al-Baqara:

"Those of you who die and leave widows behind...without turning them out." has been abrogated by another Verse. Why then do you write it (in the Qur'an)?" 'Uthman said. "Leave it (where it is), O the son of my brother, for I will not shift anything of it (i.e. the Quran) from its original position."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.61]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 61

Narrated Abu Huraira:

Allah's Apostle said, "We have more right to be in doubt than Abraham when he said, 'My Lord! Show me how You give life to the dead.' He said, 'Do you not believe?' He said, 'Yes (I believe) but to be stronger in Faith.' "(2.260)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.62]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 62

Narrated Ubaid bin Umair: Once 'Umar (bin Al-Khattab) said to the companions of the Prophet "What do you think about this Verse:--"Does any of you wish that he should have a garden?" They replied, "Allah knows best." 'Umar became angry and said, "Either say that you know or say that you do not know!" On that Ibn Abbas said, "O chief of the believers! I have something in my mind to say about it." Umar said, "O son of my brother! Say, and do not under estimate yourself." Ibn Abbas said, "This Verse has been set up as an example for deeds." Umar said, "What kind of deeds?" Ibn Abbas said, "For deeds." Umar said, "This is an example for a rich man who does goods out of obedience of Allah and then Allah sends him Satan whereupon he commits sins till all his good deeds are lost."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.63]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 63

Narrated Abu Huraira:

The Prophet said, "The poor person is not the one for whom a date or two or a morsel or two (of food is sufficient but the poor person is he who does not (beg or) ask the people (for something) or show his poverty at all. Recite if you wish, (Allah's Statement):

"They do not beg of people at all." (2.273)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.64]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 64

Narrated 'Aisha:

When the Verses of Surat-al-Baqara regarding usury (i.e. Riba) were revealed, Allah's Apostle recited them before the people and then he prohibited the trade of alcoholic liquors.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.65]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 65

Narrated 'Aisha:

When the last Verses of Surat-al-Baqara were revealed. Allah's Apostle went out and recited them in the Mosque and prohibited the trade of alcoholic liquors.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.66]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 66

Narrated 'Aisha:

When the last Verses of Surat-al-Baqara were revealed, the Prophet read them in the Mosque and prohibited the trade of alcoholic liquors. "If the debtor is in difficulty, grant him time till it is easy for him to repay.." (2.280)

Narrated 'Aisha: When the last Verses of Surat-al-Baqara were revealed, Allah's Apostle stood up and recited them before us and then prohibited the trade of alcoholic liquors.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.67]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 67

Narrated Ibn Abbas:

The last Verse (in the Quran) revealed to the Prophet was the Verse dealing with usury (i.e. Riba).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.68]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 68

Narrated Ibn 'Umar:

This Verse:--"Whether you show what is in your minds or conceal it.." (2.284) was abrogated.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.69]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 69

Narrated Marwan Al-Asghar:

A man from the companions of Allah's Apostle who I think, was Ibn 'Umar said, "The Verse:--"Whether you show what is in your minds or conceal it...." was abrogated by the Verse following it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.70]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 70

Narrated 'Aisha:

Allah's Apostle recited the Verse:--

"It is He who has sent down to you the Book. In it are Verses that are entirely clear, they are the foundation of the Book, others not entirely clear. So as for those in whose hearts there is a deviation (from the Truth ). follow thereof that is not entirely clear seeking affliction and searching for its hidden meanings; but no one knows its hidden meanings but Allah. And those who are firmly grounded in knowledge say: "We believe in it (i.e. in the Qur'an) the whole of it (i.e. its clear and unclear Verses) are from our Lord. And none receive admonition except men of understanding." (3.7)

Then Allah's Apostle said, "If you see those who follow thereof that is not entirely clear, then they are those whom Allah has named [as having deviation (from the Truth)] 'So beware of them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.71]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 71

Narrated Said bin Al-Musaiyab:

Abu Huraira said, "The Prophet said, 'No child is born but that, Satan touches it when it is born where upon it starts crying loudly because of being touched by Satan, except Mary and her Son." Abu Huraira then said, "Recite, it you wish: "And I seek Refuge with You (Allah) for her and her offspring from Satan, the outcast." (3.36)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.72]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 72

Narrated Abu Wail:

'Abdullah bin Masud said, "Allah's Apostle said, 'Whoever takes an oath when asked to do so, in which he may deprive a Muslim of his property unlawfully, will meet Allah Who will be angry with him.' So Allah revealed in confirmation of this statement:--"Verily! Those who Purchase a small gain at the cost of Allah's Covenant and oaths, they shall have no portion in the Hereafter..." (3.77) Then entered Al-Ash'ath bin Qais and said, "What is Abu 'Abdur-Rahman narrating to you?" We replied, 'So-and-so." Al-Ash'ath said, "This Verse was revealed in my connection. I had a well in the land of my cousin (and he denied my, possessing it). On that the Prophet said to me, 'Either you bring forward a proof or he (i.e. your cousin) takes an oath (to confirm his claim)' I said, 'I am sure he would take a (false) oath, O Allah's Apostle.' He said, 'If somebody takes an oath when asked to do so through which he may deprive a Muslim of his property (unlawfully) and he is a liar in his oath, he will meet Allah Who will be angry with him.' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.73]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 73

Narrated 'Abdullah bin Abu Aufa:

A man displayed some merchandise in the market and took an oath that he had been offered a certain price for it while in fact he had not, in order to cheat a man from the Muslims. So then was revealed:--"Verily! Those who purchase a small gain at the cost of Allah's Covenant and their oaths..."(3.77)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.74]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 74

Narrated Ibn Abu Mulaika:

Two women were stitching shoes in a house or a room. Then one of them came out with an awl driven into her hand, and she sued the other for it. The case was brought before Ibn 'Abbas, Ibn 'Abbas said, "Allah's Apostle said, 'If people were to be given what they claim (without proving their claim) the life and property of the nation would be lost.' Will you remind her (i.e. the defendant), of Allah and recite before her:--"Verily! Those who purchase a small gain at the cost of Allah's Covenant and their oaths..."(3.77)

So they reminded her and she confessed. Ibn 'Abbas then said, "The Prophet said, 'The oath is to be taken by the defendant (in the absence of any proof against him)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.75]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 75

Narrated Ibn Abbas:

Abu Sufyan narrated to me personally, saying, "I set out during the Truce that had been concluded between me and Allah's Apostle. While I was in Sham, a letter sent by the Prophet was brought to Heraclius. Dihya Al-Kalbi had brought and given it to the governor of Busra, and the latter forwarded it to Heraclius. Heraclius said, 'Is there anyone from the people of this man who claims to be a prophet?' The people replied, 'Yes.' So I along with some of Quraishi men were called and we entered upon Heraclius, and we were seated in front of him. Then he said, 'Who amongst you is the nearest relative to the man who claims to be a prophet?' So they made me sit in front of him and made my companions sit behind me. Then he called upon his translator and said (to him). 'Tell them ( i.e. Abu Sufyan's companions) that I am going to ask him (i.e. Abu Sufyan) regarding that man who claims to be a prophet. So, if he tell me a lie, they should contradict him (instantly).' By Allah, had I not been afraid that my companions would consider me a liar, I would have told lies. Heraclius then said to his translator, 'Ask him: What is his (i.e. the Prophet's) family status amongst you? I said, 'He belongs to a noble family amongst us." Heraclius said, 'Was any of his ancestors a king?' I said, 'No.' He said, 'Did you ever accuse him of telling lies before his saying what he has said?' I said, 'No.' He said, 'Do the nobles follow him or the poor people?' I said, 'It is the poor who followed him.' He said, 'Is the number of his follower increasing or decreasing?' I said, 'The are increasing.' He said, 'Does anyone renounce his religion (i.e. Islam) after embracing it, being displeased with it?' I said, 'No.' He said, 'Did you fight with him?' I replied, 'Yes.' He said, 'How was your fighting with him?' I said, 'The fighting between us was undecided and victory was shared by him and us by turns. He inflicts casualties upon us and we inflict casualties upon him.' He said, 'Did he ever betray?' I said, 'No, but now we are away from him in this truce and we do not know what he will do in it" Abu Sufyan added, "By Allah, I was not able to insert in my speech a word (against him) except that. Heraclius said, 'Did anybody else (amongst you) ever claimed the same (i.e. Islam) before him? I said, 'No.' Then Heraclius told his translator to tell me (i.e. Abu Sufyan), 'I asked you about his family status amongst you, and you told me that he comes from a noble family amongst you Verily, all Apostles come from the noblest family among their people. Then I asked you whether any of his ancestors was a king, and you denied that. Thereupon I thought that had one of his fore-fathers been a king, I would have said that he (i.e. Muhammad) was seeking to rule the kingdom of his fore-fathers. Then I asked you regarding his followers, whether they were the noble or the poor among the people, and you said that they were only the poor (who follow him). In fact, such are the followers of the Apostles. Then I asked you whether you have ever accused him of telling lies before saying what he said, and your reply was in the negative. Therefore, I took for granted that a man who did not tell a lie about others, could ever tell a lie about Allah. Then I asked you whether anyone of his followers had renounced his religion (i.e. Islam) after embracing it, being displeased with it, and you denied that. And such is Faith when it mixes with the cheerfulness of the hearts. Then I asked you whether his followers were increasing or decreasing You claimed that they were increasing. That is the way of true faith till it is complete. Then I asked you whether you had ever fought with him, and you claimed that you had fought with him and the battle between you and him was undecided and the victory was shared by you and him in turns; he inflicted casual ties upon you and you inflicted casualties upon them. Such is the case with the Apostles; they are out to test and the final victory is for them. Then I asked you whether he had ever betrayed; you claimed that he had never betrayed. I need, Apostles never betray. Then I asked you whether anyone had said this statement before him; and you denied that. Thereupon I thought if somebody had said that statement before him, then I would have said that he was but a man copying some sayings said before him." Abu Safyan said, "Heraclius then asked me, 'What does he order you to do?' I said, 'He orders us (to offer) prayers and (to pay) Zakat and to keep good relationship with the Kith and kin and to be chaste.' Then Heraclius said, 'If whatever you have said, is true, he is really a prophet, and I knew that he ( i.e. the Prophet ) was going to appear, but I never thought that he would be from amongst you. If I were certain that I can reach him, I would like to meet him and if I were with him, I would wash his feet; and his kingdom will expand (surely to what is under my feet.' Then Heraclius asked for the letter of Allah's Apostle and read it wherein was written:

"In the Name of Allah, the Most Beneficent, the Most Merciful. This letter is) from Muhammad, Apostle of Allah, to Heraclius, the sovereign of Byzantine........ Peace be upon him who follows the Right Path. Now then, I call you to embrace Islam. Embrace Islam and you will be saved (from Allah's Punishment); embrace Islam, and Allah will give you a double reward, but if you reject this, you will be responsible for the sins of all the people of your kingdom (Allah's Statement):--"O the people of the Scripture (Jews and Christians)! Come to a word common to you and us that we worship None but Allah....bear witness that we are Muslims.' (3.64)

When he finished reading the letter, voices grew louder near him and there was a great hue and cry, and we were ordered to go out." Abu Sufyan added, "While coming out, I said to my companions, 'The situation of Ibn Abu Kabsha (i.e. Muhammad) has become strong; even the king of Banu Al-Asfar is afraid of him.' So I continued to believe that Allah's Apostle would be victorious, till Allah made me embrace Islam." Az-Zuhri said, "Heraclius then invited all the chiefs of the Byzantines and had them assembled in his house and said, 'O group of Byzantines! Do you wish to have a permanent success and guidance and that your kingdom should remain with you?' (Immediately after hearing that), they rushed towards the gate like onagers, but they found them closed. Heraclius then said, 'Bring them back to me.' So he called them and said, 'I just wanted to test the strength of your adherence to your religion. Now I have observed of you that which I like.' Then the people fell in prostration before him and became pleased with him." (See Hadith No. 6,Vol 1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.76]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 76

Narrated Anas bin Malik:

Out of all the Ansar, living in Medina, Abu Talha had the largest number of (date palm trees) gardens, and the most beloved of his property to him was Bairuha garden which was standing opposite the Mosque (of the Prophet). Allah's Apostle used to enter it and drink of its good water. When the Verse:--"By no means shall you attain righteousness unless you spend (in charity) of that which you love." (3.92) Abu Talha got up and said, "O Allah's Apostle, Allah says:--"By no means shall you attain righteousness unless you spend (in charity) of that which you love." (3.92) and the most beloved of my property to me is the Bairuha garden, so I give it (as a charitable gift) in Allah's Cause and hope to receive good out of it, and to have it stored for me with Allah. So, O Allah's Apostle! Dispose it of (i.e. utilize it) in the way Allah orders you (to dispose it of)." Allah's Apostle said, "Bravo! That is a fruitful property! That is a fruitful property! I have heard what you have said and I think that you should distribute that (garden) amongst your relatives." The Abu Talha distributed that garden amongst his relatives and his cousins.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.77]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 77

Narrated Yahya bin Yahya:

I learnt from Malik, "..a fruitful property."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.78]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 78

Narrated Anas:

Abu Talha distributed the garden between Hassan and Ubai, but he did not give me anything thereof although I was a nearer relative to him.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.79]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 79

Narrated 'Abdullah bin Umar:

The Jews brought to the Prophet a man and a woman from among them who had committed illegal sexual intercourse. The Prophet said to them, "How do you usually punish the one amongst you who has committed illegal sexual intercourse?" They replied, "We blacken their faces with coal and beat them," He said, "Don't you find the order of Ar-Rajm (i.e. stoning to death) in the Torah?" They replied, "We do not find anything in it." 'Abdullah bin Salam (after hearing this conversation) said to them. "You have told a lie! Bring here the Torah and recite it if you are truthful." (So the Jews brought the Torah). And the religious teacher who was teaching it to them, put his hand over the Verse of Ar-Rajm and started reading what was written above and below the place hidden with his hand, but he did not read the Verse of Ar-Rajm. 'Abdullah bin Salam removed his (i.e. the teacher's) hand from the Verse of Ar-Rajm and said, "What is this?" So when the Jews saw that Verse, they said, "This is the Verse of Ar-Rajm." So the Prophet ordered the two adulterers to be stoned to death, and they were stoned to death near the place where biers used to be placed near the Mosque. I saw her companion (i.e. the adulterer) bowing over her so as to protect her from the stones.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.80]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 80

Narrated Abu Huraira:

The Verse:--"You (true Muslims) are the best of peoples ever raised up for mankind." means, the best of peoples for the people, as you bring them with chains on their necks till they embrace Islam.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.81]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 81

Narrated Jabir bin 'Abdullah:

The Verse:--"When two parties from among you were about to lose heart, but Allah was their Protector," (3.122) was revealed concerning us, and we were the two parties, i.e. Banu Haritha and Banu Salama, and we do not wish (that it had not been revealed) or I would not have been pleased (if it had not been revealed), for Allah says:--"...Allah was their Protector."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.82]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 82

Narrated Salim's father:

That he heard Allah's Apostle on raising his head from the bowing in the last Rak'a in the Fajr prayer, saying, "O Allah, curse such-and-such person and such-and-such person, and such-and-such person," after saying, "Allah hears him who sends his praises to Him, O our Lord, all praise is for you." So Allah revealed:--"Not for you (O Muhammad) (but for Allah) is the decision, verily they are indeed wrongdoers." (3.128)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.83]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 83

Narrated Abu Huraira:

Whenever Allah's Apostle intended to invoke evil upon somebody or invoke good upon somebody, he used to invoke (Allah after bowing (in the prayer). Sometimes after saying, "Allah hears him who sends his praises to Him, all praise is for You, O our Lord," he would say, "O Allah. Save Al-Walid bin Al-Walid and Salama bin Hisham, and 'Aiyash bin Abu Rabi'a. O Allah! Inflict Your Severe Torture on Mudar (tribe) and strike them with (famine) years like the years of Joseph." The Prophet used to say in a loud voice, and he also used to say in some of his Fajr prayers, "O Allah! Curse so-and-so and so-and-so." naming some of the Arab tribes till Allah revealed:--"Not for you (O Muhammad) (but for Allah) is the decision." (3.128)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.84]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 84

Narrated Al-Bara bin Azib:

The Prophet appointed 'Abdullah bin Jubair as the commander of the infantry during the battle of Uhud. They returned defeated, and that is what is meant by:--

"And the Apostle was calling them back in the rear. None remained with the Prophet then, but twelve men."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.85]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 85

Narrated Abu Talha:

Slumber overtook us during the battle of Uhud while we were in the front files. My sword would fall from my hand and I would pick it up, and again it would fall down and I would pick it up again.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.86]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 86

Narrated Ibn Abbas:

'Allah is Sufficient for us and He Is the Best Disposer of affairs," was said by Abraham when he was thrown into the fire; and it was said by Muhammad when they (i.e. hypocrites) said, "A great army is gathering against you, therefore, fear them," but it only increased their faith and they said: "Allah is Sufficient for us, and He is the Best Disposer (of affairs, for us)." (3.173)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.87]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 87

Narrated Ibn Abbas:

The last statement of Abraham when he was thrown into the fire was:--"Allah is Sufficient for us and He is the Best Disposer (of affairs for us)." (3.173)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.88]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 88

Narrated Abu Huraira:

Allah's Apostle said, "Anyone whom Allah has given wealth but he does not pay its Zakat, then, on the Day of Resurrection, his wealth will be presented to him in the shape of a bald-headed poisonous male snake with two poisonous glands in its mouth and it will encircle itself round his neck and bite him over his cheeks and say, "I am your wealth; I am your treasure." Then the Prophet recited this Divine Verse:--

"And let not those who covetously withhold of that which Allah has bestowed upon them of His Bounty." (3.180)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.89]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 89

Narrated Usama bin Zaid:

Allah's Apostle rode a donkey, equipped with a thick cloth-covering made in Fadak and was riding behind him. He was going to pay visit to Sad bin Ubada in Banu Al-Harith bin Al-Khazraj; and this incident happened before the battle of Badr. The Prophet passed by a gathering in which 'Abdullah bin Ubai bin Salul was present, and that was before 'Abdullah bin Ubai embraced Islam. Behold in that gathering there were people of different religions: there were Muslims, pagans, idol-worshippers and Jews, and in that gathering 'Abdullah bin Rawaha was also present. When a cloud of dust raised by the donkey reached that gathering, 'Abdullah bin Ubai covered his nose with his garment and then said, "Do not cover us with dust." Then Allah's Apostle greeted them and stopped and dismounted and invited them to Allah (i.e. to embrace Islam) and recited to them the Holy Qur'an. On that, 'Abdullah bin Ubai bin Saluil said, "O man ! There is nothing better than that what you say. If it is the truth, then do not trouble us with it in our gatherings. Return to your mount (or residence) and if somebody comes to you, relate (your tales) to him." On that 'Abdullah bin Rawaha said, "Yes, O Allah's Apostle! Bring it (i.e. what you want to say) to us in our gathering, for we love that."

So the Muslims, the pagans and the Jews started abusing one another till they were on the point of fighting with one another. The Prophet kept on quietening them till they became quiet, whereupon the Prophet rode his animal (mount) and proceeded till he entered upon Sad bin Ubada. The Prophet said to Sad, "Did you not hear what 'Abu Hub-b said?" He meant 'Abdullah bin Ubai. "He said so-and-so." On that Sad bin Ubada said, "O Allah's Apostle! Excuse and forgive him, for by Him Who revealed the Book to you, Allah brought the Truth which was sent to you at the time when the people of this town (i.e. Medina) had decided unanimously to crown him and tie a turban on his head (electing him as chief). But when Allah opposed that (decision) through the Truth which Allah gave to you, he (i.e. 'Abdullah bin Ubai) was grieved with jealously. and that caused him to do what you have seen." So Allah's Apostle excused him, for the Prophet and his companions used to forgive the pagans and the people of Scripture as Allah had ordered them, and they used to put up with their mischief with patience. Allah said: "And you shall certainly hear much that will grieve you from those who received the Scripture before you and from the pagans........'(3.186) And Allah also said:--"Many of the people of the Scripture wish if they could turn you away as disbelievers after you have believed, from selfish envy.." (2.109)

So the Prophet used to stick to the principle of forgiveness for them as long as Allah ordered him to do so till Allah permitted fighting them. So when Allah's Apostle fought the battle of Badr and Allah killed the nobles of Quraish infidels through him, Ibn Ubai bin Salul and the pagans and idolaters who were with him, said, "This matter (i.e. Islam) has appeared (i.e. became victorious)." So they gave the pledge of allegiance (for embracing Islam) to Allah's Apostle and became Muslims.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.90]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 90

Narrated Abu Said Al-Khudri:

During the lifetime of Allah's Apostle, some men among the hypocrites used to remain behind him (i.e. did not accompany him) when he went out for a Ghazwa and they would be pleased to stay at home behind Allah's Apostle When Allah's Apostle returned (from the battle) they would put forward (false) excuses and take oaths, wishing to be praised for what they had not done. So there was revealed:--

"Think not that those who rejoice in what they have done, and love to be praised for what they have not done.." (3.188)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.91]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 91

Narrated Alqama bin Waqqas:

Marwan said to his gatekeeper, "Go to Ibn 'Abbas, O Rafi, and say, 'If everybody who rejoices in what he has done, and likes to be praised for what he has not done, will be punished, then all of us will be punished." Ibn Abbas said, "What connection have you with this case? It was only that the Prophet called the Jews and asked them about something, and they hid the truth and told him something else, and showed him that they deserved praise for the favor of telling him the answer to his question, and they became happy with what they had concealed.

Then Ibn Abbas recited:--

"(And remember) when Allah took a Covenant from those who were given the Scripture..and those who rejoice in what they have done and love to be praised for what they have not done.' " (3.187-188)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.92]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 92

Narrated Humaid bin 'Abdur-Rahman bin 'Auf:

That Marwan had told him (the above narration No. 91).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.93]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 93

Narrated Ibn 'Abbas:

I stayed overnight in the house of my aunt Maimuna. Allah's Apostle talked with his wife for a while and then went to bed. When it was the last third of the night, he got up and looked towards the sky and said:

"Verily! In the creation of the Heavens and the Earth and in the alteration of night and day, there are indeed signs for men of understanding." (3.190)

Then he stood up, performed ablution, brushed his teeth with a Siwak, and then prayed eleven Rakat. Then Bilal pronounced the Adhan (i.e. call for the Fajr prayer). The Prophet then offered two Rakat (Sunna) prayer and went out (to the Mosque) and offered the (compulsory congregational) Fajr prayer.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.94]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 94

Narrated Ibn Abbas:

(One night) I stayed overnight in the house of my aunt Maimuna, and said to myself, "I will watch the prayer of Allah's Apostle " My aunt placed a cushion for Allah's Apostle and he slept on it in its length-wise direction and (woke-up) rubbing the traces of sleep off his face and then he recited the last ten Verses of Surat-al-Imran till he finished it. Then he went to a hanging water skin and took it, performed the ablution and then stood up to offer the prayer. I got up and did the same as he had done, and stood beside him. He put his hand on my head and held me by the ear and twisted it. He offered two Rakat, then two Rakat, then two Rakat, then two Rakat, then two Rakat, then two Rakat, and finally the Witr (i.e. one Rak'a) prayer.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.95]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 95

Narrated Abdullah bin Abbas:

That once he stayed overnight (in the house) of his aunt Maimuna. the wife of the Prophet. He added: I lay on the cushion transversely and Allah's Apostle lay along with his wife in the lengthwise direction of the pillow. Allah's Apostle slept till the middle of the night, either a bit before or a bit after it, and then woke up rubbing the traces of sleep off his face with his hands and then he recited the last ten Verses of Surat-al-Imran, got up and went to a hanging water skin. He then performed the ablution from it, and it was perfect ablution, and then stood up to offer the prayer. I too did the same as he had done, and then went to stand beside him. Allah's Apostle put his right hand on my head and held and twisted my right ear. He then offered two Rakat, then two Rakat, then two Rakat, then two Rakat, then two Rakat. then two Rakat, and finally one Rak'a, the Witr. Then he lay down again till the Muadhdhin (i.e. the call-maker) came to him, whereupon he got up and offered a light two-Rakat prayer, and went out (to the Mosque) and offered the (compulsory congregational) Fajr prayer.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.96]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 96

Narrated Ibn Abbas:

That once he stayed overnight in the house of his aunt, the wife of the Prophet. He added: I lay on the cushion transversely while Allah's Apostle lay along with his wife in the lengthwise direction of cushion. Allah's Apostle slept till the middle of the night, either a bit before or a bit after it, and then woke up rubbing the traces of sleep off his face with his hands, and then recited the last ten Verses of Suratal-Imran. Then he got up and went to a hanging water skin, performed ablution from it ---- and performed it perfectly. Then he stood up to perform the prayer. I also did the same 3S he had done and then went to stand beside him. Allah's Apostle put his right hand on my head and held and twisted my right ear. He then offered two Rakat, then two Rakat then two Rakat, then two then two Rakat, then two Rakat, and finally, one Rak'a Witr. Then lay down again till the Muadhdhin (i.e. the call-maker) came to him, whereupon he got up and offered a light two Rakat prayer and went out (to the Mosque) and offered the (compulsory congregational) Fajr prayer.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.97]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 97

Narrated Aisha:

There was an orphan (girl) under the care of a man. He married her and she owned a date palm (garden). He married her just because of that and not because he loved her. So the Divine Verse came regarding his case: "If you fear that you shall not be able to deal justly with the orphan girls..." (4.3) The sub-narrator added: I think he (i.e. another sub-narrator) said, "That orphan girl was his partner in that datepalm (garden) and in his property."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.98]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 98

Narrated 'Urwa bin Az-Zubair:

That he asked 'Aisha regarding the Statement of Allah:

"If you fear that you shall not be able to deal justly with the orphan girls..." (4.3) She said, "O son of my sister! An Orphan girl used to be under the care of a guardian with whom she shared property. Her guardian, being attracted by her wealth and beauty, would intend to marry her without giving her a just Mahr, i.e. the same Mahr as any other person might give her (in case he married her). So such guardians were forbidden to do that unless they did justice to their female wards and gave them the highest Mahr their peers might get. They were ordered (by Allah, to marry women of their choice other than those orphan girls." 'Aisha added," The people asked Allah's Apostle his instructions after the revelation of this Divine Verse whereupon Allah revealed:

"They ask your instruction regarding women " (4.127) 'Aisha further said, "And the Statement of Allah: "And yet whom you desire to marry." (4.127) as anyone of you refrains from marrying an orphan girl (under his guardianship) when she is lacking in property and beauty." 'Aisha added, "So they were forbidden to marry those orphan girls for whose wealth and beauty they had a desire unless with justice, and that was because they would refrain from marrying them if they were lacking in property and beauty."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.99]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 99

Narrated Aisha:

regarding the Statement of Allah: "And whoever amongst the guardian is rich, he should take no wages, but if he is poor, let him have for himself what is just and reasonable (according to his work). This Verse was revealed regarding the orphan's property. If the guardian is poor, he can take from the property of the orphan, what is just and reasonable according to his work and the time he spends on managing it.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.100]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 100

Narrated Ikrama:

Ibn Abbas said ( regarding the verse), "And when the relatives and the orphans and the poor are present at the time of division, "this verse and its order is valid and not abrogated."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.101]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 101

Narrated Jabir:

The Prophet and Abu Bakr came on foot to pay me a visit (during my illness) at Banu Salama's (dwellings). The Prophet found me unconscious, so he asked for water and performed the ablution from it and sprinkled some water over it. I came to my senses and said, "O Allah's Apostle! What do you order me to do as regards my wealth?" So there was revealed:--

"Allah commands you as regards your children's (inheritance):" (4.11)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.102]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 102

Narrated Ibn Abbas:

(In the Pre-Islamic Period ) the children used to inherit all the property but the parents used to inherit only through a will. So Allah cancelled that which He liked to cancel and put decreed that the share of a son was to be twice the share of a daughter, and for the parents one-sixth for each one of them, or one third, and for the wife one-eighth or one-fourth, and for the husband one-half, or one-fourth.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.103]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 103

Narrated Ibn Abbas:

regarding the Divine Verse: "O you who believe! You are forbidden to inherit women against their will, and you should not treat them with harshness that you may take back part of the (Mahr) dower you have given them." (4.19) (Before this revelation) if a man died, his relatives used to have the right to inherit his wife, and one of them could marry her if he would, or they would give her in marriage if they wished, or, if they wished, they would not give her in marriage at all, and they would be more entitled to dispose her, than her own relatives. So the above Verse was revealed in this connection.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.104]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 104

Narrated Ibn 'Abbas:

Regarding the Verse: "To everyone, We have appointed heirs." (4.33) 'Mawali' means heirs. And regarding:-- "And those to whom your right hands have pledged."

When the Emigrants came to Medina, an Emigrant used to be the heir of an Ansari with the exclusion of the latter's relatives, and that was because of the bond of brotherhood which the Prophet had established between them (i.e. the Emigrants and the Ansar). So when the Verses:-- "To everyone We have appointed heirs." was revealed, (the inheritance through bond of brotherhood) was cancelled. Ibn Abbas then said: "And those to whom your right hands have pledged." is concerned with the covenant of helping and advising each other. So allies are no longer to be the heir of each other, but they can bequeath each other some of their property by means of a will.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.105]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 105

Narrated Abu Said Al-Khudri:

During the lifetime of the Prophet some people said, : O Allah's Apostle! Shall we see our Lord on the Day of Resurrection?" The Prophet said, "Yes; do you have any difficulty in seeing the sun at midday when it is bright and there is no cloud in the sky?" They replied, "No." He said, "Do you have any difficulty in seeing the moon on a full moon night when it is bright and there is no cloud in the sky?" They replied, "No." The Prophet said, "(Similarly) you will have no difficulty in seeing Allah on the Day of Resurrection as you have no difficulty in seeing either of them. On the Day of Resurrection, a call-maker will announce, "Let every nation follow that which they used to worship." Then none of those who used to worship anything other than Allah like idols and other deities but will fall in Hell (Fire), till there will remain none but those who used to worship Allah, both those who were obedient (i.e. good) and those who were disobedient (i.e. bad) and the remaining party of the people of the Scripture. Then the Jews will be called upon and it will be said to them, 'Who do you use to worship?' They will say, 'We used to worship Ezra, the son of Allah.' It will be said to them, 'You are liars, for Allah has never taken anyone as a wife or a son. What do you want now?' They will say, 'O our Lord! We are thirsty, so give us something to drink.' They will be directed and addressed thus, 'Will you drink,' whereupon they will be gathered unto Hell (Fire) which will look like a mirage whose different sides will be destroying each other. Then they will fall into the Fire. Afterwards the Christians will be called upon and it will be said to them, 'Who do you use to worship?' They will say, 'We used to worship Jesus, the son of Allah.' It will be said to them, 'You are liars, for Allah has never taken anyone as a wife or a son,' Then it will be said to them, 'What do you want?' They will say what the former people have said. Then, when there remain (in the gathering) none but those who used to worship Allah (Alone, the real Lord of the Worlds) whether they were obedient or disobedient. Then (Allah) the Lord of the worlds will come to them in a shape nearest to the picture they had in their minds about Him. It will be said, 'What are you waiting for?' Every nation have followed what they used to worship.' They will reply, 'We left the people in the world when we were in great need of them and we did not take them as friends. Now we are waiting for our Lord Whom we used to worship.' Allah will say, 'I am your Lord.' They will say twice or thrice, 'We do not worship any besides Allah.' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.106]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 106

Narrated Abdullah bin Masud:

Allah's Apostle said to me, "Recite (of the Qur'an) for me," I said, "Shall I recite it to you although it had been revealed to you?" He said, "I like to hear (the Qur'an) from others." So I recited Surat-an-Nisa' till I reached: "How (will it be) then when We bring from each nation a witness, and We bring you (O Muhammad) as a witness against these people?" (4.41) Then he said, "Stop!" And behold, his eyes were overflowing with tears."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.107]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 107

Narrated 'Aisha:

The necklace of Asma' was lost, so the Prophet sent some men to look for it. The time for the prayer became due and they had not performed ablution and could not find water, so they offered the prayer without ablution. Then Allah revealed (the Verse of Tayammum).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.108]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 108

Narrated Ibn Abbas:

The Verse: "Obey Allah and Obey the Apostle and those of you (Muslims) who are in authority." (4.59) was revealed in connection with 'Abdullah bin Hudhafa bin Qais bin 'Adi' when the Prophet appointed him as the commander of a Sariyya (army detachment).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.109]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 109

Narrated 'Urwa:

Az-Zubair quarrelled with a man from the Ansar because of a natural mountainous stream at Al-Harra. The Prophet said "O Zubair! Irrigate (your lands and the let the water flow to your neighbor The Ansar said, "O Allah's Apostle (This is because) he (Zubair) is your cousin?" At that, the Prophet's face became red (with anger) and he said "O Zubair! Irrigate (your land) and then withhold the water till it fills the land up to the walls and then let it flow to your neighbor." So the Prophet enabled Az-Zubair to take his full right after the Ansari provoked his anger. The Prophet had previously given a order that was in favor of both of them Az-Zubair said, "I don't think but the Verse was revealed in this connection: "But no, by your Lord, they can have no faith, until they make you judge in all disputes between them." (4.6)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.110]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 110

Narrated 'Aisha:

I heard Allah's Apostle saying, "No prophet gets sick but he is given the choice to select either this world or the Hereafter." 'Aisha added: During his fatal illness, his voice became very husky and I heard him saying: "In the company of those whom is the Grace of Allah, of the prophets, the Siddiqin (those followers of the prophets who were first and foremost to believe in them), the martyrs and the pious.' (4.69) And from this I came to know that he has been given the option.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.111]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 111

Narrated Ibn Abbas:

My mother and I were among the weak and oppressed (Muslims at Mecca).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.112]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 112

Narrated Ibn Abi Mulaika:

Ibn Abbas recited:-- "Except the weak ones among men women and children," (4.98) and said, "My mother and I were among those whom Allah had excused."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.113]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 113

Narrated Zaid bin Thabit: Regarding the Verse:-- "Then what is the matter with you that you are divided into two parties about the hypocrites?" (4.88) Some of the companions of the Prophet returned from the battle of Uhud (i.e. refused to


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.114]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 114

Narrated Said bin Jubair:

The people of Kufa disagreed (disputed) about the above Verse. So I went to Ibn Abbas and asked him about it. He said, "This Verse:-- "And whoever kills a believer intentionally, his recompense is Hell." was revealed last of all (concerning premeditated murder) and nothing abrogated it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.115]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 115

Narrated Ibn Abbas:

Regarding the Verse: "And say not to anyone who offers you peace (by accepting Islam), You are not a believer." There was a man amidst his sheep. The Muslims pursued him, and he said (to them) "Peace be on you." But they killed him and took over his sheep. Thereupon Allah revealed in that concern, the above Verse up to:-- "...seeking the perishable good of this life." (4.94) i.e. those sheep.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.116]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 116

Narrated Zaid bin Thabit: That the Prophet dictated to him: "Not equal are those of the believers who sit (at home) and those who strive and fight in the Cause of Allah."

Zaid added: Ibn Um Maktum came while the Prophet was dictating to me and said, "O Allah's Apostle! By Allah, if I had the power to fight (in Allah's Cause), I would," and he was a blind man. So Allah revealed to his Apostle while his thigh was on my thigh, and his thigh became so heavy that I was afraid it might fracture my thigh. Then that state of the Prophet passed and Allah revealed:-- "Except those who are disabled (by injury or are blind or lame etc)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.117]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 117

Narrated Al-Bara:

When the Verse:-- "Not equal are those of the believers who sit (at home)" (4.95) was revealed, Allah Apostle called for Zaid who wrote it. In the meantime Ibn Um Maktum came and complained of his blindness, so Allah revealed: "Except those who are disabled (by injury or are blind or lame..." etc.) (4.95)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.118]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 118

Narrated Al-Bara:

When the Verse:--"Not equal are those of the believers who sit (at home)," (4.95) was revealed, the Prophet said, "Call so-and-so." That person came to him with an ink-pot and a wooden board or a shoulder scapula bone. The Prophet said (to him), "Write: 'Not equal are those believers who sit (at home) and those who strive and fight in the Cause of Allah." Ibn Um Maktum who was sitting behind the Prophet then said, "O Allah's Apostle! I am a blind man." So there was revealed in the place of that Verse, the Verse:--"Not equal are those of the believers who sit (at home) except those who are disabled (by injury, or are blind or lame etc.) and those who strive and fight in the Cause of Allah." (4.95)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.119]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 119

Narrated Ibn Abbas: Not equal are those believers who sat (at home) and did not join the


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.120]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 120

Narrated Muhammad bin Abdur-Rahman Abu Al-Aswad:

The people of Medina were forced to prepare an army (to fight against the people of Sham during the caliphate of 'Abdullah bin Az-Zubair at Mecca), and I was enlisted in it; Then I met 'Ikrima, the freed slave of Ibn 'Abbas, and informed him (about it), and he forbade me strongly to do so (i.e. to enlist in that army), and then said, "Ibn 'Abbas informed me that some Muslim people were with the pagans, increasing the number of the pagans against Allah's Apostle. An arrow used to be shot which would hit one of them (the Muslims in the company of the pagans) and kill him, or he would be struck and killed (with a sword)." Then Allah revealed:--

"Verily! as for those whom the angels take (in death) while they are wronging themselves (by staying among the disbelievers)" (4.97) Abu Aswad added, "Except the weak ones among men, women,..." (4.98)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.121]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 121

Narrated Ibn Abbas:

'"Except the weak ones" (4.98) and added: My mother was one of those whom Allah excused.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.122]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 122

Narrated Abu Huraira:

While the Prophet was offering the 'Isha' prayer, he said, "Allah hears him who sends his praises to Him," and then said before falling in prostration, "O Allah, save 'Aiyash bin Rabi'a. O Allah, save Salama bin Hisham. O Allah, save Al-Walid bin Al-Wahd. O Allah, save the weak ones among the believers. O Allah, let Your punishment be severe on the tribe of Mudar. O Allah, inflict upon them years (of famine) like the years of Joseph."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.123]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 123

Narrated Ibn Abbas:

Regarding the Verse: "Because of the inconvenience of rain or because you are ill." (4.102) (It was revealed in connection with) 'Abdur-Rahman bin Auf who was wounded.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.124]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 124

Narrated 'Aisha:

Regarding the Verse:--"They ask your instruction concerning the women. Say: Allah instructs you about them and yet whom you desire to marry." (4.127) (has been revealed regarding the case of) a man who has an orphan girl, and he is her guardian and her heir. The girl shares with him all his property, even a date-palm (garden), but he dislikes to marry her and dislikes to give her in marriage to somebody else who would share with him the property she is sharing with him, and for this reason that guardian prevents that orphan girl from marrying. So, this Verse was revealed: (And Allah's statement:) "If a woman fears cruelty or desertion on her husband's part." (4.128)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.125]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 125

Narrated 'Aisha:

Regarding the Verse:--"If a woman fears cruelty or desertion on her husband's part." (4.128) It is about a man who has a woman (wife) and he does not like her and wants to divorce her but she says to him, "I make you free as regards myself." So this Verse was revealed in this connection.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.126]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 126

Narrated Al-Aswad:

While we were sitting in a circle in 'Abdullah's gathering, Hudhaifa came and stopped before us, and greeted us and then said, "People better than you became hypocrites." Al-Aswad said: I testify the uniqueness of Allah! Allah says: "Verily! The hypocrites will be in the lowest depths of the Fire." (4.145)

On that 'Abdullah smiled and Hudhaifa sat somewhere in the Mosque. 'Abdullah then got up and his companions (sitting around him) dispersed. Hudhaifa then threw a pebble at me (to attract my attention). I went to him and he said, "I was surprised at 'Abdullah's smile though he understood what I said. Verily, people better than you became hypocrite and then repented and Allah forgave them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.127]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 127

Narrated Abdullah:

The Prophet said, "None has the right to say that I am better than Jonah bin Matta."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.128]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 128

Narrated Abu Huraira:

The Prophet said, "Whoever says that I am better than Jonah bin Matta, is a liar."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.129]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 129

Narrated Al-Bara:

The last Sura that was revealed was Bara'a, and the last Verse that was revealed was: "They ask you for a legal verdict, Say: Allah's directs (thus) about those who leave no descendants or ascendants as heirs." (4.176)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.130]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 130

Narrated Tariq bin Shihab:

The Jews said to 'Umar, "You (i.e. Muslims) recite a Verse, and had it been revealed to us, we would have taken the day of its revelation as a day of celebration." 'Umar said, "I know very well when and where it was revealed, and where Allah's Apostle was when it was revealed. (It was revealed on) the day of Arafat (Hajj Day), and by Allah, I was at Arafat" Sufyan, a sub-narrator said: I am in doubt whether the Verse:-- "This day I have perfected your religion for you." was revealed on a Friday or not.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.131]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 131

Narrated Aisha:

The wife of the Prophet : We set out with Allah's Apostle on one of his journeys, and when we were at Baida' or at Dhat-al-Jaish, a necklace of mine was broken (and lost). Allah's Apostle stayed there to look for it, and so did the people along with him. Neither were they at a place of water, nor did they have any water with them. So the people went to Abu Bakr As-Siddiq and said, "Don't you see what 'Aisha has done? She has made Allah's Apostle and the people, stay where there is no water and they have no water with them." Abu Bakr came while Allah's Apostle was sleeping with his head on my thigh. He said (to me), "You have detained Allah's Apostle and the people where there is no water, and they have no water with them." So he admonished me and said what Allah wished him to say, and he hit me on my flanks with his hand. Nothing prevented me from moving (because of pain! but the position of Allah's Apostle on my thigh. So Allah's Apostle got up when dawn broke and there was no water, so Allah revealed the Verse of Tayammum. Usaid bin Hudair said, "It is not the first blessing of yours, O the family of Abu Bakr." Then we made the camel on which I was riding, got up, and found the necklace under it.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.132]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 132

Narrated Aisha:

A necklace of mine was lost at Al-Baida' and we were on our way to Medina. The Prophet made his camel kneel down and dismounted and laid his head on my lap and slept. Abu Bakr came to me and hit me violently on the chest and said, "You have detained the people because of a necklace." I kept as motionless as a dead person because of the position of Allah's Apostle ; (on my lap) although Abu Bakr had hurt me (with the slap). Then the Prophet woke up and it was the time for the morning (prayer). Water was sought, but in vain; so the following Verse was revealed:--

"O you who believe! When you intend to offer prayer.." (5.6) Usaid bin Hudair said, "Allah has blessed the people for your sake, O the family of Abu Bakr. You are but a blessing for them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.133]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 133

Narrated Abdullah (bin Masud):

On the day of Badr, Al-Miqdad said, "O Allah's Apostle! We do not say to you as the children of Israel said to Moses, 'Go you and your Lord and fight you two; we are sitting here, (5.24) but (we say). "Proceed, and we are with you." That seemed to delight Allah's Apostle greatly.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.134]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 134

Narrated Abu Qilaba:

That he was sitting behind Umar bin Abdul Aziz and the people mentioned and mentioned (about At-Qasama) and they said (various things), and said that the Caliphs had permitted it. 'Umar bin 'Abdul 'Aziz turned towards Abu Qilaba who was behind him and said. "What do you say, O 'Abdullah bin Zaid?" or said, "What do you say, O Abu Qilaba?" Abu Qilaba said, "I do not know that killing a person is lawful in Islam except in three cases: a married person committing illegal sexual intercourse, one who has murdered somebody unlawfully, or one who wages war against Allah and His Apostle." 'Anbasa said, "Anas narrated to us such-and-such." Abu Qilaba said, "Anas narrated to me in this concern, saying, some people came to the Prophet and they spoke to him saying, 'The climate of this land does not suit us.' The Prophet said, 'These are camels belonging to us, and they are to be taken out to the pasture. So take them out and drink of their milk and urine.' So they took them and set out and drank of their urine and milk, and having recovered, they attacked the shepherd, killed him and drove away the camels.' Why should there be any delay in punishing them as they murdered (a person) and waged war against Allah and His Apostle and frightened Allah's Apostle ?" Anbasa said, "I testify the uniqueness of Allah!" Abu Qilaba said, "Do you suspect me?" 'Anbasa said, "No, Anas narrated that (Hadith) to us." Then 'Anbasa added, "O the people of such-and-such (country), you will remain in good state as long as Allah keeps this (man) and the like of this (man) amongst you."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.135]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 135

Narrated Anas (bin Malik):

Ar-Rubai (the paternal aunt of Anas bin Malik) broke the incisor tooth of young Ansari girl. Her family demanded the Qisas and they came to the Prophet who passed the judgment of Qisas. Anas bin An-Nadr (the paternal uncle of Anas bin Malik) said, "O Allah's Apostle! By Allah, her tooth will not be broken." The Prophet said, "O Anas! (The law prescribed in) Allah's Book is Qisas." But the people (i.e. the relatives of the girl) gave up their claim and accepted a compensation. On that Allah's Apostle said, "Some of Allah's worshippers are such that if they take an oath, Allah will fulfill it for them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.136]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 136

Narrated 'Aisha:

Whoever tells that Muhammad concealed part of what was revealed to him, is a liar, for Allah says:--

"O Apostle (Muhammad)! Proclaim (the Message) which has been sent down to you from your Lord." (5.67)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.137]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 137

Narrated 'Aisha:

This Verse: "Allah will not punish you for what is unintentional in your oaths." (5.89) was revealed about a man's state men (during his talk), "No, by Allah," and "Yes, by Allah."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.138]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 138

Narrated Aisha:

That her father (Abu Bakr) never broke his oath till Allah revealed the order of the legal expiation for oath. Abu Bakr said, "If I ever take an oath (to do something) and later find that to do something else is better, then I accept Allah's permission and do that which is better, (and do the legal expiation for my oath ) ".


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.139]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 139

Narrated Abdullah:

We used to participate in the holy wars carried on by the Prophet and we had no women (wives) with us. So we said (to the Prophet ). "Shall we castrate ourselves?" But the Prophet forbade us to do that and thenceforth he allowed us to marry a woman (temporarily) by giving her even a garment, and then he recited: "O you who believe! Do not make unlawful the good things which Allah has made lawful for you."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.140]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 140

Narrated Ibn Umar:

(The Verse of) prohibiting alcoholic drinks was revealed when there were in Medina five kinds of (alcoholic) drinks none of which was produced from grapes.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.141]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 141

Narrated Anas bin Malik:

We had no alcoholic drink except that which was produced from dates and which you call Fadikh. While I was standing offering drinks to Abu Talh and so-and-so and so-and-so, a man cam and said, "Has the news reached you? They said, "What is that?" He said. "Alcoholic drinks have been prohibited. They said, "Spill (the contents of these pots, O Anas! "Then they neither asked about it (alcoholic drinks) nor returned it after the news from that man.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.142]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 142

Narrated Jabir:

Some people drank alcoholic beverages in the morning (of the day) of the Uhud battle and on the same day they were killed as martyrs, and that was before wine was prohibited.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.143]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 143

Narrated Ibn Umar:

I heard 'Umar while he was on the pulpit of the Prophet saying, "Now then O people! The revelation about the prohibition of alcoholic drinks was revealed; and alcoholic drinks are extracted from five things: Grapes, dates, honey, wheat and barley. And the alcoholic drink is that which confuses and stupefies the mind."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.144]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 144

Narrated Anas:

The alcoholic drink which was spilled was Al-Fadikh. I used to offer alcoholic drinks to the people at the residence of Abu Talha. Then the order of prohibiting Alcoholic drinks was revealed, and the Prophet ordered somebody to announce that: Abu Talha said to me, "Go out and see what this voice (this announcement ) is." I went out and (on coming back) said, "This is somebody announcing that alcoholic beverages have been prohibited." Abu Talha said to me, "Go and spill it (i.e. the wine)," Then it (alcoholic drinks) was seen flowing through the streets of Medina. At that time the wine was Al-Fadikh. The people said, "Some people (Muslims) were killed (during the battle of Uhud) while wine was in their stomachs." So Allah revealed: "On those who believe and do good deeds there is no blame for what they ate (in the past)." (5.93)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.145]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 145

Narrated Anas:

The Prophet delivered a sermon the like of which I had never heard before. He said, "If you but knew what I know then you would have laughed little and wept much." On hearing that, the companions of the Prophet covered their faces and the sound of their weeping was heard. A man said, "Who is my father?" The Prophet said, "So-and-so." So this Verse was revealed: "Ask not about things which, if made plain to you, may cause you trouble." (5.101)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.146]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 146

Narrated Ibn Abbas:

Some people were asking Allah's Apostle questions mockingly. A man would say, "Who is my father?" Another man whose she-camel had gone astray would say, "Where is my she-camel? "So Allah revealed this Verse in this connection: "O you who believe! Ask not about things which, if made plain to you, may cause you trouble." (5.101)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.147]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 147

Narrated Said bin Al-Musaiyab:

Bahira is a she-camel whose milk is kept for the idols and nobody is allowed to milk it; Sa'iba was the she-camel which they used to set free for their gods and nothing was allowed to be carried on it. Abu Huraira said: Allah's Apostle said, "I saw 'Amr bin 'Amir Al-Khuzai (in a dream) dragging his intestines in the Fire, and he was the first person to establish the tradition of setting free the animals (for the sake of their deities)," Wasila is the she-camel which gives birth to a she-camel as its first delivery, and then gives birth to another she-camel as its second delivery. People (in the Pre-lslamic periods of ignorance) used to let that she camel loose for their idols if it gave birth to two she-camels successively without giving birth to a male camel in between. 'Ham' was the male camel which was used for copulation. When it had finished the number of copulations assigned for it, they would let it loose for their idols and excuse it from burdens so that nothing would be carried on it, and they called it the 'Hami.' Abu Huraira said, "I heard the Prophet saying so."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.148]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 148

Narrated Aisha:

Allah's Apostle said, "I saw Hell and its different portions were consuming each other and saw 'Amr dragging his intestines (in it), and he was the first person to establish the tradition of letting animals loose (for the idols)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.149]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 149

Narrated Ibn Abbas:

Allah's Apostle delivered a sermon and said, "O people! You will be gathered before Allah bare-footed, naked and not circumcised." Then (quoting Quran) he said:--

"As We began the first creation, We shall repeat it. A promise We have undertaken: Truly we shall do it.." (21.104)

The Prophet then said, "The first of the human beings to be dressed on the Day of Resurrection, will be Abraham. Lo! Some men from my followers will be brought and then (the angels) will drive them to the left side (Hell-Fire). I will say. 'O my Lord! (They are) my companions!' Then a reply will come (from Almighty), 'You do not know what they did after you.' I will say as the pious slave (the Prophet Jesus) said: And I was a witness over them while I dwelt amongst them. When You took me up. You were the Watcher over them and You are a Witness to all things.' (5.117) Then it will be said, "These people have continued to be apostates since you left them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.150]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 150

Narrated Ibn Abbas:

The Prophet said, "You will be gathered (on the Day of Resurrection) and some people will be driven (by the angels) to the left side (and taken to Hell) whereupon I will say as the pious slave (Jesus) said:-- "And I was a witness over them while I dwelt amongst them...the ALMIGHTY, the All Wise." (5.117-118)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.151]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 151

Narrated Abdullah:

Allah's Apostle said, "The key of the Unseen are five: Verily with Allah (Alone) is the knowledge of the Hour He sends down the rain and knows what is in the wombs. No soul knows what it will earn tomorrow, and no soul knows in what land it will die. Verily, Allah is All-Knower, All-Aware." (31.34)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.152]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 152

Narrated Jabir:

When this Verse was revealed: "Say: He has power to send torment on you from above." (6.65) Allah's Apostle said, "O Allah! I seek refuge with Your Face (from this punishment)." And when the verse: "or send torment from below your feet," (was revealed), Allah's Apostle said, "(O Allah!) I seek refuge with Your Face (from this punishment)." (But when there was revealed): "Or confuse you in party strife and make you to taste the violence of one another." (6.65) Allah's Apostle said, "This is lighter (or, this is easier)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.153]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 153

Narrated Abdullah:

When:"...and confuse not their belief with wrong." (6.82) was revealed, the Prophet's companions said, "Which of us has not done wrong?" Then there was revealed:-- "Verily joining others in worship with Allah is a tremendous wrong indeed." (31.13)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.154]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 154

Narrated Ibn Abbas:

The Prophet said, "Nobody has the rights to say that I am better than Jonah bin Matta."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.155]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 155

Narrated Abu Huraira:

The Prophet said, "Nobody has the right to say that I am better than Jonah bin Matta."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.156]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 156

Narrated Mujahid:

That he asked Ibn 'Abbas, "Is there a prostration Surat-al-Sad?" (38.24) Ibn Abbas said, "Yes," and then recited: "We gave...So follow their guidance." (6.85,90) Then he said, "He (David ) is one them (i.e. those prophets)." Mujahid narrated: I asked Ibn 'Abbas (regarding the above Verse). He said, "Your Prophet (Muhammad) was one of those who were ordered to follow them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.157]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 157

Narrated Jabir bin 'Abdullah:

The Prophet said, "May Allah curse the Jews! When Allah forbade them to eat the fat of animals, they melted it and sold it, and utilized its price! "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.158]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 158

Narrated Abu Wail:

'Abdullah (bin Mas'ud) said, "None has more sense of ghaira than Allah therefore - He prohibits shameful sins (illegal sexual intercourse, etc.) whether committed openly or secretly. And none loves to be praised more than Allah does, and for this reason He praises Himself." I asked Abu Wali, "Did you hear it from Abdullah?" He said, "Yes," I said, "Did Abdullah ascribe it to Allah's Apostle?" He said, "Yes."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.159]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 159

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established until the sun rises from the West: and when the people see it, then whoever will be living on the surface of the earth will have faith, and that is (the time) when no good will it do to a soul to believe then, if it believed not before." (6.158)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.160]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 160

Narrated Abu Huraira:

Allah's Apostle said, "The hour will not be established till the sun rises from the West; and when it rises (from the West) and the people see it, they all will believe. And that is (the time) when no good will it do to a soul to believe then." Then he recited the whole Verse (6.158)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.161]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 161

Narrated Abdullah bin Mas'ud:

Allah's Apostle said, "None has more sense of ghaira than Allah, and for this He has forbidden shameful sins whether committed openly or secretly, and none loves to be praised more than Allah does, and this is why He Praises Himself."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.162]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 162

Narrated Abu Said Al-Khudri:

A man from the Jews, having been slapped on his face, came to the Prophet and said, "O Muhammad! A man from your companions from the Ansar has slapped me on my face!" The Prophet said, "Call him." When they called him, the Prophet said, "Why did you slap him?" He said, "O Allah's Apostle! While I was passing by the Jews, I heard him saying, 'By Him Who selected Moses above the human beings,' I said, 'Even above Muhammad?' I became furious and slapped him on the face." The Prophet said, "Do not give me superiority over the other prophets, for on the Day of Resurrection the people will become unconscious and I will be the first to regain consciousness. Then I will see Moses holding one of the legs of the Throne. I will not know whether he has come to his senses before me or that the shock he had received at the Mountain, (during his worldly life) was sufficient for him."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.163]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 163

Narrated Said Ibn Zaid:

The Prophet said, "Al-Kam'a is like the Mann (sweet resin or gum) (in that it grows naturally without human care) and its water is a cure for the eye diseases."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.164]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 164

Narrated Abu Ad-Darda:

There was a dispute between Abu Bakr and 'Umar, and Abu Bakr made Umar angry. So 'Umar left angrily. Abu Bakr followed him, requesting him to ask forgiveness (of Allah) for him, but 'Umar refused to do so and closed his door in Abu Bakr's face. So Abu Bakr went to Allah's Apostle while we were with him. Allah's Apostle said, "This friend of yours must have quarrelled (with somebody)." In the meantime 'Umar repented and felt sorry for what he had done, so he came, greeted (those who were present) and sat with the Prophet and related the story to him. Allah's Apostle became angry and Abu Bakr started saying, "O Allah's Apostle! By Allah, I was more at fault (than Umar)." Allah's Apostle said, "Are you (people) leaving for me my companion? (Abu Bakr), Are you (people) leaving for me my companion? When I said, 'O people I am sent to you all as the Apostle of Allah,' you said, 'You tell a lie.' while Abu Bakr said, 'You have spoken the truth ."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.165]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 165

Narrated Abu Huraira:

Allah's Apostle said, "It was said to the children of Israel, 'Enter the gate in prostration and say Hitatun. (7.161) We shall forgive you, your faults.' But they changed (Allah's Order) and entered, dragging themselves on their buttocks and said, 'Habatun (a grain) in a Sha'ratin (hair)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.166]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 166

Narrated Ibn Abbas:

'Uyaina bin Hisn bin Hudhaifa came and stayed with his nephew Al-Hurr bin Qais who was one of those whom 'Umar used to keep near him, as the Qurra' (learned men knowing Qur'an by heart) were the people of 'Umar's meetings and his advisors whether they were old or young. 'Uyaina said to his nephew, "O son of my brother! You have an approach to this chief, so get for me the permission to see him." Al-Hurr said, "I will get the permission for you to see him." So Al-Hurr asked the permission for 'Uyaina and 'Umar admitted him. When 'Uyaina entered upon him, he said, "Beware! O the son of Al-Khattab! By Allah, you neither give us sufficient provision nor judge among us with justice." Thereupon 'Umar became so furious that he intended to harm him, but Al-Hurr said, "O chief of the Believers! Allah said to His Prophet: "Hold to forgiveness; command what is right; and leave (don't punish) the foolish." (7.199) and this (i.e. 'Uyaina) is one of the foolish." By Allah, 'Umar did not overlook that Verse when Al-Hurr recited it before him; he observed (the orders of) Allah's Book strictly.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.167]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 167

Narrated 'Abdullah bin AzZubair:

(The Verse) "Hold to forgiveness; command what is right..." was revealed by Allah except in connection with the character of the people. 'Abdullah bin Az-Zubair said: Allah ordered His Prophet to forgive the people their misbehavior (towards him).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.168]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 168

Narrated Said bin Jubair:

I asked Ibn 'Abbas regarding Surat-al-Anfal. He said, "It was revealed in connection with the Battle of Badr."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.169]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 169

Narrated Ibn 'Abbas:

Regarding the Verse: "Verily! The worst of beasts in the Sight of Allah are the deaf and the dumb----those who understand not." (8.22)

(The people referred to here) were some persons from the tribe of Bani 'Abd-Addar.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.170]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 170

Narrated Abu Said bin Al-Mu'alla:

While I was praying, Allah's Apostle passed me and called me, but I did not go to him until I had finished the prayer. Then I went to him, and he said, "What prevented you from coming to me? Didn't Allah say:-- "O you who believe! Answer the call of Allah (by obeying Him) and His Apostle when He calls you?" He then said, "I will inform you of the greatest Sura in the Qur'an before I leave (the mosque)." When Allah's Apostle got ready to leave (the mosque), I reminded him. He said, "It is: 'Praise be to Allah, the Lord of the worlds.' (i.e. Surat-al-Fatiha) As-sab'a Al-Mathani (the seven repeatedly recited Verses)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.171]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 171

Narrated Anas bin Malik:

Abu Jahl said, "O Allah! If this (Quran) is indeed the Truth from You, then rain down on us a shower of stones from the sky or bring on us a painful torment." So Allah revealed:-- "But Allah would not punish them while you were amongst them, nor He will punish them while they seek (Allah's) forgiveness..." (8.33) And why Allah should not punish them while they turn away (men) from Al-Masjid-al-Haram (the Sacred Mosque of Mecca)..." (8.33-34)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.172]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 172

Narrated Anas bin Malik:

Abu Jahl said, "O Allah! If this (Qur'an) is indeed the Truth from You), then rain down on us a shower of stones from the sky or bring on us a painful punishment." So there was revealed:-- 'But Allah would not punish them while you (Muhammad) were amongst them, nor will He punish them while they seek (Allah's) Forgiveness. And why Allah should not punish them while they stop (men) from Al-Masjid-al-Haram ..' (8.33-34)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.173]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 173

Narrated Ibn 'Umar:

That a man came to him (while two groups of Muslims were fighting) and said, "O Abu 'Abdur Rahman! Don't you hear what Allah has mentioned in His Book:

'And if two groups of believers fight against each other...' (49.9)

So what prevents you from fighting as Allah has mentioned in His Book?"' Ibn 'Umar said, "O son of my brother! I would rather be blamed for not fighting because of this Verse than to be blamed because of another Verse where Allah says:

'And whoever kills a believer intentionally..." (4.93) Then that man said, "Allah says:-- 'And fight them until there is no more afflictions (worshipping other besides Allah) and the religion (i.e. worship) will be all for Allah (Alone)" (8.39) Ibn 'Umar said, "We did this during the lifetime of Allah's Apostle when the number of Muslims was small, and a man was put to trial because of his religion, the pagans would either kill or chain him; but when the Muslims increased (and Islam spread), there was no persecution." When that man saw that Ibn 'Umar did not agree to his proposal, he said, "What is your opinion regarding 'Ali and 'Uthman?" Ibn 'Umar said, "What is my opinion regarding Ali and 'Uthman? As for 'Uthman, Allah forgave him and you disliked to forgive him, and Ali is the cousin and son-in-law of Allah's Apostle ." Then he pointed out with his hand and said, "And that is his daughter's (house) which you can see."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.174]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 174

Narrated Said bin Jubair:

Ibn 'Umar came to us and a man said (to him), "What do you think about 'Qit-alal-Fitnah' (fighting caused by afflictions)." Ibn 'Umar said (to him), "And do you understand what an affliction is? Muhammad used to fight against the pagans, and his fighting with them was an affliction, (and his fighting was) not like your fighting which is carried on for the sake of ruling."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.175]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 175

Narrated Ibn Abbas:

When the Verse:-- "If there are twenty steadfast amongst you, they will overcome two hundred." (8.65) was revealed, then it became obligatory for the Muslims that one (Muslim) should not flee from ten (non-Muslims). Sufyan (the sub-narrator) once said, "Twenty (Muslims) should not flee before two hundred (non Muslims)." Then there was revealed: 'But now Allah has lightened your (task)..' (8.66)

So it became obligatory that one-hundred (Muslims) should not flee before two hundred (non-muslims). (Once Sufyan said extra, "The Verse: 'Urge the believers to the fight. If there are twenty steadfast amongst you (Muslims) ..' was revealed.) Sufyan said, "Ibn Shabrama said, "I see that this order is applicable to the obligation of enjoining good and forbidding evil."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.176]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 176

Narrated Ibn Abbas:

When the Verse:--'If there are twenty steadfast amongst you (Muslims), they will overcome two-hundred (non-Muslims).' was revealed, it became hard on the Muslims when it became compulsory that one Muslim ought not to flee (in war) before ten (non-Muslims). So (Allah) lightened the order by revealing:

'(But) now Allah has lightened your (task) for He knows that there is weakness in you. So if there are of you one-hundred steadfast, they will overcome (two-hundred (non-Muslims).' (8.66) So when Allah reduced the number of enemies which Muslims should withstand, their patience and perseverance against the enemy decreased as much as their task was lightened for them.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.177]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 177

Narrated Al-Bara:

The last Verse that was revealed was:

'They ask you for a legal verdict: Say: Allah directs (thus) about Al-Kalalah (those who leave no descendants or ascendants as heirs).' And the last Sura which was revealed was Baraatun (9) .


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.178]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 178

Narrated Humaid bin Abdur-Rahman:

Abu Huraira said, "During that Hajj (in which Abu Bakr was the chief of the pilgrims) Abu Bakr sent me along with announcers on the Day of Nahr ( 10th of Dhul-Hijja) in Mina to announce: "No pagans shall perform, Hajj after this year, and none shall perform the Tawaf around the Ka'ba in a naked state." Humaid bin 'Abdur Rahman added: Then Allah's Apostle sent Ali bin Abi Talib (after Abu Bakr) and ordered him to recite aloud in public Surat Bara'a. Abu Huraira added, "So 'Ali, along with us, recited Bara'a (loudly) before the people at Mina on the Day of Nahr and announced; "No pagan shall perform Hajj after this year and none shall perform the Tawaf around the Ka'ba in a naked state."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.179]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 179

Narrated Humaid bin Abdur Rahman:

Abu Huraira said, "Abu Bakr sent me in that Hajj in which he was the chief of the pilgrims along with the announcers whom he sent on the Day of Nahr to announce at Mina: "No pagan shall perform Hajj after this year, and none shall perform the Tawaf around the Ka'ba in a naked state." Humaid added: That the Prophet sent 'Ali bin Abi Talib (after Abu Bakr) and ordered him to recite aloud in public Surat-Baraa. Abu Huraira added, "So 'Ali, along with us, recited Bara'a (loudly) before the people at Mina on the Day of Nahr and announced "No pagan shall perform Hajj after this year and none shall perform the Tawaf around the Ka'ba in a naked state."..except those pagans with whom you (Muslims) have a treaty." (9.4)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.180]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 180

Narrated Humaid bin 'Abdur-Rahman:

Abu Huraira said that Abu Bakr sent him during the Hajj in which Abu Bakr was made the chief of the pilgrims by Allah's Apostle before (the year of) Hajjat al-Wada in a group (of announcers) to announce before the people; 'No pagan shall perform the Hajj after this year, and none shall perform the Tawaf around the Ka'ba in a naked state. Humaid used to say The Day of Nahr is the day of Al-Hajj Al-Akbar (the Greatest Day) because of the narration of Abu Huraira.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.181]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 181

Narrated Zaid bin Wahb:

We were with Hudhaifa and he said, "None remains of the people described by this Verse (9.12), "Except three, and of the hypocrites except four." A bedouin said, "You the companions of Muhammad! Tell us (things) and we do not know that about those who break open our houses and steal our precious things? ' He (Hudhaifa) replied, "Those are Al Fussaq (rebellious wrongdoers) (not disbelievers or hypocrites). Really, none remains of them (hypocrite) but four, one of whom is a very old man who, if he drinks water, does not feel its coldness."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.182]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 182

Narrated Abu Huraira:

Allah's Apostle said, "The Kanz (money, the Zakat of which is not paid) of anyone of you will appear in the form of bald-headed poisonous male snake on the Day of Resurrection."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.183]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 183

Narrated Zaid bin Wahb:

I passed by (visited ) Abu Dhar at Ar-Rabadha and said to him, "What has brought you to this land?" He said, "We were at Sham and I recited the Verse: "They who hoard up gold and silver and spend them not in the way of Allah; announce to them a painful torment, " (9.34) where upon Muawiya said, 'This Verse is not for us, but for the people of the Scripture.' Then I said, 'But it is both for us (Muslim) and for them.' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.184]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 184

Narrated Abu Bakr:

The Prophet said, "Time has come back to its original state which it had when Allah created the Heavens and the Earth; the year is twelve months, four of which are sacred. Three of them are in succession; Dhul-Qa'da, Dhul-Hijja and Al-Muharram, and (the fourth being) Rajab Mudar (named after the tribe of Mudar as they used to respect this month) which stands between Jumad (ath-thani) and Sha'ban."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.185]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 185

Narrated Abu Bakr:

I was in the company of the Prophet in the cave, and on seeing the traces of the pagans, I said, "O Allah's Apostle If one of them (pagans) should lift up his foot, he will see us." He said, "What do you think of two, the third of whom is Allah?"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.186]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 186

Narrated Ibn Abi Mulaika:

When there happened the disagreement between Ibn Az-Zubair and Ibn 'Abbas, I said (to the latter), "(Why don't you take the oath of allegiance to him as) his father is Az-Zubair, and his mother is Asma,' and his aunt is 'Aisha, and his maternal grandfather is Abu Bakr, and his grandmother is Safiya?"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.187]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 187

Narrated Ibn Abi Mulaika:

There was a disagreement between them (i.e. Ibn 'Abbas and Ibn Az-Zubair) so I went to Ibn 'Abbas in the morning and said (to him), "Do you want to fight against Ibn Zubair and thus make lawful what Allah has made unlawful (i.e. fighting in Meccas?" Ibn 'Abbas said, "Allah forbid! Allah ordained that Ibn Zubair and Bani Umaiya would permit (fighting in Mecca), but by Allah, I will never regard it as permissible." Ibn Abbas added. "The people asked me to take the oath of allegiance to Ibn AzZubair. I said, 'He is really entitled to assume authority for his father, Az-Zubair was the helper of the Prophet, his (maternal) grandfather, Abu Bakr was (the Prophet's) companion in the cave, his mother, Asma' was 'Dhatun-Nitaq', his aunt, 'Aisha was the mother of the Believers, his paternal aunt, Khadija was the wife of the Prophet , and the paternal aunt of the Prophet was his grandmother. He himself is pious and chaste in Islam, well versed in the Knowledge of the Quran. By Allah! (Really, I left my relatives, Bani Umaiya for his sake though) they are my close relatives, and if they should be my rulers, they are equally apt to be so and are descended from a noble family.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.188]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 188

Narrated Ibn Abi Mulaika:

We entered upon Ibn 'Abbas and he said "Are you not astonished at Ibn Az-Zubair's assuming the caliphate?" I said (to myself), "I will support him and speak of his good traits as I did not do even for Abu Bakr and 'Umar though they were more entitled to receive al I good than he was." I said "He (i.e Ibn Az-Zubair) is the son of the aunt of the Prophet and the son of AzZubair, and the grandson of Abu Bakr and the son of Khadija's brother, and the son of 'Aisha's sister." Nevertheless, he considers himself to be superior to me and does not want me to be one of his friends. So I said, "I never expected that he would refuse my offer to support him, and I don't think he intends to do me any good, therefore, if my cousins should inevitably be my rulers, it will be better for me to be ruled by them than by some others."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.189]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 189

Narrated Abu Said:


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.190]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 190

Narrated Abu Musud:

When we were ordered to give alms, we began to work as porters (to earn something we could give in charity). Abu Uqail came with one half of a Sa (special measure for food grains) and another person brought more than he did. So the hypocrites said, "Allah is not in need of the alms of this (i.e. 'Uqail); and this other person did not give alms but for showing off." Then Allah revealed:--

'Those who criticize such of the Believers who give charity voluntarily and those who could not find to give in charity except what is available to them.' (9.79)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.191]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 191

Narrated Shaqiq:

Abu Mas'ud Al-Ansari said, "Allah's Apostle, used to order us to give alms. So one of us would exert himself to earn one Mud (special measure of wheat or dates, etc.,) to give in charity; while today one of us may have one hundred thousand." Shaqiq said: As if Abu Masud referred to himself.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.192]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 192

Narrated Ibn Abbas:

When 'Abdullah bin 'Ubai died, his son 'Abdullah bin 'Abdullah came to Allah's Apostle and asked him to give him his shirt in order to shroud his father in it. He gave it to him and then 'Abdullah asked the Prophet to offer the funeral prayer for him (his father). Allah's Apostle got up to offer the funeral prayer for him, but Umar got up too and got hold of the garment of Allah's Apostle and said, "O Allah's Apostle Will you offer the funeral prayer for him though your Lord has forbidden you to offer the prayer for him" Allah's Apostle said, "But Allah has given me the choice by saying:

'(Whether you) ask forgiveness for them, or do not ask forgiveness for them; even if you ask forgiveness for them seventy times..' (9.80) so I will ask more than seventy times." 'Umar said, "But he ('Abdullah bin 'Ubai) is a hypocrite!" However, Allah's Apostle did offer the funeral prayer for him whereupon Allah revealed:

'And never (O Muhammad) pray for anyone of them that dies, nor stand at his grave.' (9.84)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.193]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 193

Narrated Umar bin Al-Khattab:

When 'Abdullah bin Ubai bin Salul died, Allah's Apostle was called in order to offer the funeral prayer for him. When Allah's Apostle got up (to offer the prayer) I jumped towards him and said, "O Allah's Apostle! Do you offer the prayer for Ibn Ubai although he said so-and-so on such-and-such-a day?" I went on mentioning his sayings. Allah's Apostle smiled and said, "Keep away from me, O 'Umar!" But when I spoke too much to him, he said, "I have been given the choice, and I have chosen (this) ; and if I knew that if I asked forgiveness for him more than seventy times, he would be for given, I would ask it for more times than that." So Allah's Apostle offered the funeral prayer for him and then left, but he did not stay long before the two Verses of Surat-Bara'a were revealed, i.e.:-- 'And never (O Muhammad) pray for anyone of them that dies.... and died in a state of rebellion.' (9.84) Later I was astonished at my daring to speak like that to Allah's Apostle and Allah and His Apostle know best.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.194]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 194

Narrated Ibn Umar:

When Abdullah bin Ubai died, his son 'Abdullah bin 'Abdullah came to Allah's Apostle who gave his shirt to him and ordered him to shroud his father in it. Then he stood up to offer the funeral prayer for the deceased, but 'Umar bin Al-Khattab took hold of his garment and said, "Do you offer the funeral prayer for him though he was a hypocrite and Allah has forbidden you to ask forgiveness for hypocrites?" The Prophet said, "Allah has given me the choice (or Allah has informed me) saying:

"Whether you, O Muhammad, ask forgiveness for them, or do not ask forgiveness for them, even if you ask forgiveness for them seventy times, Allah will not forgive them," (9.80) The he added, "I will (appeal to Allah for his sake) more than seventy times." So Allah's Apostle offered the funeral prayer for him and we too, offered the prayer along with him. Then Allah revealed: "And never, O Muhammad, pray (funeral prayer) for anyone of them that dies, nor stand at his grave. Certainly they disbelieved in Allah and His Apostle and died in a state of rebellion." (9.84)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.195]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 195

Narrated 'Abdullah bin Ka'b:

I heard Ka'b bin Malik at the time he remained behind and did not join (the battle of) Tabuk, saying, "By Allah, no blessing has Allah bestowed upon me, besides my guidance to Islam, better than that of helping me speak the truth to Allah's Apostle otherwise I would have told the Prophet a lie and would have been ruined like those who had told a lie when the Divine Inspiration was revealed:-- "They will swear by Allah to you (Muslims) when you return to them.. the rebellious people." (9.95-96)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.196]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 196

Narrated Samura bin Jundab:

Allah's Apostle said, "Tonight two (visitors) came to me (in my dream) and took me to a town built with gold bricks and silver bricks. There we met men who, half of their bodies, look like the most-handsome human beings you have ever seen, and the other half, the ugliest human beings you have ever seen. Those two visitors said to those men, 'Go and dip yourselves in that river. So they dipped themselves therein and then came to us, their ugliness having disappeared and they were in the most-handsome shape. The visitors said, 'The first is the Garden of Eden and that is your dwelling place.' Then they added, 'As for those people who were half ugly and half handsome, they were those who mixed good deeds and bad deeds, but Allah forgave them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.197]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 197

Narrated Al-Musaiyab:

When Abu Talib's death approached, the Prophet went to him while Abu Jahl and 'Abdullah bin Abi Umaiya were present with him. The Prophet said, "O uncle, say: None has the right to be worshipped except Allah, so that I may argue for your case with it before Allah." On that, Abu Jahl and 'Abdullah bin Abu Umaiya said, "O Abu Talib! Do you want to renounce 'Abdul Muttalib's religion?" Then the Prophet said, "I will keep on asking (Allah for) forgiveness for you unless I am forbidden to do so." Then there was revealed:--

'It is not fitting for the Prophet and those who believe that they should invoke (Allah) for forgiveness for pagans even though they be of kin, after it has become clear to them that they are companions of the Fire.' (9.113)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.198]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 198

Narrated Abdullah bin Ka'b:

I heard Ka'b bin Malik talking about the Verse:-- 'And to the three (He also forgave) who remained behind.' (9.118) saying in the last portion of his talk, "(I said), 'As a part (sign) of my repentance, I would like to give up all my property in the cause of Allah and His Apostle,' The Prophet said to me, 'Keep some of your wealth as it is good for you." (To the three (He also forgave) who remained behind till for them the earth, vast as it is, was straitened..." (9.118)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.199]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 199

Narrated Abdullah bin Kab:

I heard Ka'b bin Malik who was one of the three who were forgiven, saying that he had never remained behind Allah's Apostle in any Ghazwa which he had fought except two Ghazwat Ghazwat-al'Usra (Tabuk) and Ghazwat-Badr. He added. "I decided to tell the truth to Allah's Apostle in the forenoon, and scarcely did he return from a journey he made, except in the forenoon, he would go first to the mosque and offer a two-Rak'at prayer. The Prophet forbade others to speak to me or to my two companions, but he did not prohibit speaking to any of those who had remained behind excepting us. So the people avoided speaking to us, and I stayed in that state till I could no longer bear it, and the only thing that worried me was that I might die and the Prophet would not offer the funeral prayer for me, or Allah's Apostle might die and I would be left in that social status among the people that nobody would speak to me or offer the funeral prayer for me. But Allah revealed His Forgiveness for us to the Prophet in the last third of the night while Allah's Apostle was with Um Salama. Um Salama sympathized with me and helped me in my disaster. Allah's Apostle said, 'O Um Salama! Ka'b has been forgiven!' She said, 'Shall I send someone to him to give him the good tidings?' He said, 'If you did so, the people would not let you sleep the rest of the night.' So when the Prophet had offered the Fajr prayer, he announced Allah's Forgiveness for us. His face used to look as bright as a piece of the (full) moon whenever he was pleased. When Allah revealed His Forgiveness for us, we were the three whose case had been deferred while the excuse presented by those who had apologized had been accepted. But when there were mentioned those who had told the Prophet lies and remained behind (the battle of Tabuk) and had given false excuses, they were described with the worse description one may be described with. Allah said: 'They will present their excuses to you (Muslims) when you return to them. Say: Present no excuses; we shall not believe you. Allah has already informed us of the true state of matters concerning you. Allah and His Apostle will observe your actions." (9.94)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.200]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 200

Narrated 'Abdullah bin Kab:

I heard Ka'b bin Malik talking about the story of the battle of Tabuk when he remained behind, "By Allah, I do not know anyone whom Allah has helped for telling the truth more than me since I mentioned that truth to Allah's Apostle till today, I have never intended to tell a lie. And Allah revealed to His Apostle: "Verily! Allah has forgiven the Prophet, the Muhajirin............ and be with those who are true (in words and deeds)." (9.117-119) (See Hadith No. 702 Vol 5).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.201]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 201

Narrated Zaid bin Thabit Al-Ansari:

who was one of those who used to write the Divine Revelation: Abu Bakr sent for me after the (heavy) casualties among the warriors (of the battle) of Yamama (where a great number of Qurra' were killed). 'Umar was present with Abu Bakr who said, 'Umar has come to me and said, The people have suffered heavy casualties on the day of (the battle of) Yamama, and I am afraid that there will be more casualties among the Qurra' (those who know the Qur'an by heart) at other battle-fields, whereby a large part of the Qur'an may be lost, unless you collect it. And I am of the opinion that you should collect the Qur'an." Abu Bakr added, "I said to 'Umar, 'How can I do something which Allah's Apostle has not done?' 'Umar said (to me), 'By Allah, it is (really) a good thing.' So 'Umar kept on pressing, trying to persuade me to accept his proposal, till Allah opened my bosom for it and I had the same opinion as 'Umar." (Zaid bin Thabit added:) Umar was sitting with him (Abu Bakr) and was not speaking. me). "You are a wise young man and we do not suspect you (of telling lies or of forgetfulness): and you used to write the Divine Inspiration for Allah's Apostle. Therefore, look for the Qur'an and collect it (in one manuscript). " By Allah, if he (Abu Bakr) had ordered me to shift one of the mountains (from its place) it would not have been harder for me than what he had ordered me concerning the collection of the Qur'an. I said to both of them, "How dare you do a thing which the Prophet has not done?" Abu Bakr said, "By Allah, it is (really) a good thing. So I kept on arguing with him about it till Allah opened my bosom for that which He had opened the bosoms of Abu Bakr and Umar. So I started locating Quranic material and collecting it from parchments, scapula, leaf-stalks of date palms and from the memories of men (who knew it by heart). I found with Khuzaima two Verses of Surat-at-Tauba which I had not found with anybody else, (and they were):--

"Verily there has come to you an Apostle (Muhammad) from amongst yourselves. It grieves him that you should receive any injury or difficulty He (Muhammad) is ardently anxious over you (to be rightly guided)" (9.128)

The manuscript on which the Quran was collected, remained with Abu Bakr till Allah took him unto Him, and then with 'Umar till Allah took him unto Him, and finally it remained with Hafsa, Umar's daughter.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.202]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 202

Narrated Ibn Abbas:

When the Prophet arrived at Medina, the Jews were observing the fast on 'Ashura' (10th of Muharram) and they said, "This is the day when Moses became victorious over Pharaoh," On that, the Prophet said to his companions, "You (Muslims) have more right to celebrate Moses' victory than they have, so observe the fast on this day."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.203]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 203

Narrated Muhammad bin 'Abbas bin Ja'far:

That he heard Ibn 'Abbas reciting: "No doubt! They fold up their breasts." (11.5) and asked him about its explanation. He said, "Some people used to hide themselves while answering the call of nature in an open space lest they be exposed to the sky, and also when they had sexual relation with their wives in an open space lest they be exposed to the sky, so the above revelation was sent down regarding them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.204]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 204

Narrated Muhammad bin Abbas bin Ja'far:

Ibn Abbas recited. "No doubt! They fold up their breasts." I said, "O Abu Abbas! What is meant by "They fold up their breasts?" He said, "A man used to feel shy on having sexual relation with his wife or on answering the call of nature (in an open space) so this Verse was revealed:-- "No doubt! They fold up their breasts."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.205]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 205

Narrated 'Amr:

Ibn 'Abbas recited:-- "No doubt! They fold up their breasts in order to hide from Him. Surely! Even when they cover themselves with their garments.." (11.5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.206]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 206

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'Spend (O man), and I shall spend on you." He also said, "Allah's Hand is full, and (its fullness) is not affected by the continuous spending night and day." He also said, "Do you see what He has spent since He created the Heavens and the Earth? Nevertheless, what is in His Hand is not decreased, and His Throne was over the water; and in His Hand there is the balance (of justice) whereby He raises and lowers (people)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.207]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 207

Narrated Safwan bin Muhriz:

While Ibn Umar was performing the Tawaf (around the Ka'ba), a man came up to him and said, "O Abu 'AbdurRahman!" or said, "O Ibn Umar! Did you hear anything from the Prophet about An-Najwa?" Ibn 'Umar said, "I heard the Prophet saying, 'The Believer will be brought near his Lord." (Hisham, a sub-narrator said, reporting the Prophet's words), "The believer will come near (his Lord) till his Lord covers him with His screen and makes him confess his sins. (Allah will ask him), 'Do you know (that you did) 'such-and-such sin?" He will say twice, 'Yes, I do.' Then Allah will say, 'I concealed it in the world and I forgive it for you today.' Then the record of his good deeds will be folded up. As for the others, or the disbelievers, it will be announced publicly before the witnesses: 'These are ones who lied against their Lord."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.208]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 208

Narrated Abu Musa:

Allah's Apostle said, "Allah gives respite to the oppressor, but when He takes him over, He never releases him." Then he recited:--

"Such is the seizure of your Lord when He seizes (population of) towns in the midst of their wrong: Painful indeed, and severe is His seizure.' (11.102)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.209]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 209

Narrated Ibn Masud:

A man kissed a woman and then came to Allah's Apostle and told him of that, so this Divine Inspiration was revealed to the Prophet 'And offer Prayers perfectly at the two ends of the day, and in some hours of the night; (i.e. (five) compulsory prayers). Verily, the good deeds remove the evil deeds (small sins) That is a reminder for the mindful.' (11.114) The man said, Is this instruction for me only?' The Prophet said, "It is for all those of my followers who encounter a similar situation."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.210]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 210

Narrated 'Abdullah bin Umar:

The Prophet said, "The honorable, the son of the honorable the son of the honorable, i.e. Joseph, the son of Jacob, the son of Isaac, the son of Abraham."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.211]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 211

Narrated Abu Huraira:

Allah's Apostle was asked, "Who are the most honorable of the people?" The Prophet said, "The most honorable of them in Allah's Sight are those who keep their duty to Allah and fear Him. They said, "We do not ask you about that." He said, "Then the most honorable of the people is Joseph, Allah's prophet, the son of Allah's prophet, the son of Allah's prophet, the son of Allah's Khalil i.e. Abraham) They said, "We do not ask you about that." The Prophet said, Do you ask about (the virtues of the ancestry of the Arabs?" They said, "Yes," He said, "Those who were the best amongst you in the Pre-lslamic Period are the


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.212]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 212

Narrated Az-Zuhri:

Urwa bin Az-Zubair, Said bin Al-Musaiyab, 'Al-Qama bin Waqqas and 'Ubaidullah bin 'Abdullah related the narration of 'Aisha, the wife the Prophet, when the slanderers had said about her what they had said and Allah later declared her innocence. Each of them related a part of the narration (wherein) the Prophet said (to 'Aisha). "If you are innocent, then Allah will declare your innocence: but if you have committed a sin, then ask for Allah's Forgiveness and repent to him." 'Aisha said, "By Allah, I find no example for my case except that of Joseph's father (when he said), 'So (for me) patience is most fitting.' " Then Allah revealed the ten Verses:-- "Verily those who spread the slander are a gang amongst you.." (24.11)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.213]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 213

Narrated Um Ruman:

Who was 'Aisha's mother: While I was with 'Aisha, 'Aisha got fever, whereupon the Prophet said, "Probably her fever is caused by the story related by the people (about her)." I said, "Yes." Then 'Aisha sat up and said, "My example and your example is similar to that of Jacob and his sons:--'Nay, but your minds have made up a tale. So (for me) patience is most fitting. It is Allah (alone) Whose help can be sought against that which you assert.' (12.18)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.214]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 214

Narrated Abu Wail:

'Abdullah bin Mas'ud recited "Haita laka (Come you)," and added, "We recite it as we were taught it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.215]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 215

Narrated Abdullah (bin Mas'ud):

When the Prophet realized that the Quraish had delayed in embracing Islam, he said, "O Allah! Protect me against their evil by afflicting them with seven (years of famine) like the seven years of (Prophet) Joseph." So they were struck with a year of famine that destroyed everything till they had to eat bones, and till a man would look towards the sky and see something like smoke between him and it. Allah said:--

"Then watch you (O Muhammad) for the day when the sky will produce a kind of smoke plainly visible." (44.10) And Allah further said:-- "Verily! We shall withdraw the punishment a little, Verily you will return (to disbelief)." (44.15) (Will Allah relieve them from torture on the Day of Resurrection?) (The punishment of) the smoke had passed and Al-Baltsha (the destruction of the pagans in the Badr battle) had passed too.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.216]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 216

Narrated Abu Huraira:

Allah's Apostle said, "May Allah bestow His Mercy on (Prophet) Lot. (When his nation troubled him) he wished if he could betake himself to some powerful support; and if I were to remain in prison for the period Joseph had remained, I would surely respond to the call; and we shall have more right (to be in doubt) than Abraham: When Allah said to him, "Don't you believe?' Abraham said, 'Yes, (I do believe) but to be stronger in faith; (2.260)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.217]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 217

Narrated 'Urwa bin Az-Zubair:

That when he asked 'Aisha about the statement of Allah "Until when the Apostles gave up hope (of their people)." (12.110) she told him (its meaning), 'Urwa added, "I said, 'Did they (Apostles) suspect that they were betrayed (by Allah) or that they were treated as liars by (their people)?' 'Aisha said, '(They suspected) that they were treated as liars by (their people),' I said, 'But they were sure that their people treated them as liars and it was not a matter of suspicion.' She said, 'Yes, upon my life they were sure about it.' I said to her. 'So they (Apostles) suspected that they were betrayed (by Allah).' She said, "Allah forbid! The Apostles never suspected their Lord of such a thing.' I said, 'What about this Verse then?' She said, 'It is about the Apostles' followers who believed in their Lord and trusted their Apostles, but the period of trials was prolonged and victory was delayed till the Apostles gave up all hope of converting those of the people who disbelieved them and the Apostles thought that their followers treated them as liars; thereupon Allah's help came to them.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.218]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 218

Narrated 'Urwa:

"I told her ('Aisha): (Regarding the above narration), they (Apostles) were betrayed (by Allah)." She said: Allah forbid or said similarly.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.219]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 219

Narrated Ibn Umar:

Allah's Apostle said, "The keys of Unseen are five which none knows but Allah: None knows what will happen tomorrow but Allah; none knows what is in the wombs (a male child or a female) but Allah; none knows when it will rain but Allah; none knows at what place one will die; none knows when the Hour will be established but Allah." (See The Quran 31:34.")


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.220]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 220

Narrated Ibn 'Umar:

While we were with Allah's Apostle he said, "Tell me of a tree which resembles a Muslim man. Its leaves do not fall and it does not, and does not, and does not, and it gives its fruits every now and then." It came to my mind that such a tree must be the date palm, but seeing Abu Bakr and 'Umar saying nothing, I disliked to speak. So when they did not say anything, Allah's Apostle said, "It is the date-palm tree." When we got up (from that place), I said to 'Umar, "O my father! By Allah, it came to my mind that it must be the date palm tree." 'Umar said, "What prevented you from speaking" I replied, "I did not see you speaking, so I misliked to speak or say anything." Umar then said, "If you had said it, it would have been dearer to me than so-and-so."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.221]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 221

Narrated Al-Bara bin Azib:

Allah's Apostle said, "When a Muslim is questioned in his grave, he will testify that none has the right to be worshipped but Allah and that Muhammad is Allah's Apostle, and that is what is meant by Allah's Statement:--

"Allah will keep firm those who believe with a Word that stands firm in this world and in the Hereafter." (14.27)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.222]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 222

Narrated Ata:

When Ibn 'Abbas heard:-- "Have you not seen those who have changed the favor of Allah into disbelief?" (14.28) he said, "Those were the disbelieving pagans of Mecca."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.223]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 223

Narrated Abu Huraira:

The Prophet said, "When Allah has ordained some affair in the Heaven, the angels beat with their wings in obedience to His statement, which sounds like a chain dragged over a rock." ('Ali and other sub-narrators said, "The sound reaches them.") "Until when fear is banished from their (angels) hearts, they (angels) say, 'What was it that your Lord said? They say, 'The truth; And He is the Most High, the Most Great.' (34.23) Then those who gain a hearing by stealing (i.e. devils) will hear Allah's Statement:-- 'Those who gain a hearing by stealing, (stand one over the other like this).

(Sufyan, to illustrate this, spread the fingers of his right hand and placed them one over the other horizontally.) A flame may overtake and burn the eavesdropper before conveying the news to the one below him; or it may not overtake him till he has conveyed it to the one below him, who in his turn, conveys it to the one below him, and so on till they convey the news to the earth. (Or probably Sufyan said, "Till the news reaches the earth.") Then the news is inspired to a sorcerer who would add a hundred lies to it. His prophecy will prove true (as far as the heavenly news is concerned). The people will say. 'Didn't he tell us that on such-and-such a day, such-and-such a thing will happen? We have found that is true because of the true news heard from heaven."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.224]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 224

Narrated Abu Huraira:

(The same Hadith above, starting: 'When Allah has ordained some affair...') In this narration the word foreteller is added to the word wizard.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.225]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 225

Narrated 'Abdullah bin 'Umar:

(While we were going for the Battle of Tabuk and when we reached the places of the dwellers of Al-Hijr), Allah's Apostle said about the dwellers of Al-Hijr (to us). "Do not enter (the dwelling places) of these people unless you enter weeping, but if you weep not, then do not enter upon them, lest you be afflicted with what they were afflicted with."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.226]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 226

Narrated Abu Said Al-Mualla:

While I was praying, the Prophet passed by and called me, but I did not go to him till I had finished my prayer. When I went to him, he said, "What prevented you from coming?" I said, "I was praying." He said, "Didn't Allah say" "O you who believes Give your response to Allah (by obeying Him) and to His Apostle." (8.24) Then he added, "Shall I tell you the most superior Sura in the Qur'an before I go out of the mosque?" When the Prophet intended to go out (of the Mosque), I reminded him and he said, "That is: "Alhamdu-lillahi Rabbil-'Alamin (Surat-al-fatiha)' which is the seven oft repeated verses (Al-Mathani) and the Grand Quran which has been given to me."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.227]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 227

Narrated Abu Huraira:

Allah's Apostle said, "The Um (substance) of the Quran is the seven oft-repeated verses (Al-Mathaini) and is the Great Quran (i.e. Surat-al-Fatiha)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.228]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 228

Narrated Ibn Abbas:

Those who have made their Scripture into parts are the people of the Scripture who divided it into portions and believed in a part of it and disbelieved the other.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.229]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 229

Narrated Ibn Abbas: concerning:

"As We sent down (the Scripture) on those who are divided (Jews and Christians)." (15.90) They believed in part of it and disbelieved in the other, are the Jews and the Christians. the Christians.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.230]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 230

Narrated Anas bin Malik:

Allah's Apostle used to invoke thus: "O Allah! I seek refuge with You from miserliness, laziness; from old geriatric age the punishment in the grave; from the affliction of Ad-Dajjal; and from the afflictions of life and death.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.231]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 231

Narrated Ibn Mas'ud:

Surat Bani Israel and Al-Kahf and Mary are among my first old property.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.232]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 232

Narrated Abu Huraira:

Allah's Apostle was presented with two cups one containing wine and the other milk on the night of his night journey at Jerusalem. He looked at it and took the milk. Gabriel said, "Thanks to Allah Who guided you to the Fitra (i.e. Islam); if you had taken the wine, your followers would have gone astray.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.233]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 233

Narrated Jabir bin 'Abdullah:

The Prophet said, "When the Quraish disbelieved me (concerning my night journey), I stood up in Al-Hijr (the unroofed portion of the Ka'ba) and Allah displayed Bait-ul-Maqdis before me, and I started to inform them (Quraish) about its signs while looking at it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.234]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 234

Narrated Abdullah:

During the Pre-lslamic period of ignorance if any tribe became great in number, we used to say, "Amira the children of so-and-so."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.235]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 235

Narrated Al-Humaidi:

Sufyan narrated to us something and used the word 'Amira'.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.236]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 236

Narrated Abu Huraira:

Some (cooked) meat was brought to Allah Apostle and the meat of a forearm was presented to him as he used to like it. He ate a morsel of it and said, "I will be the chief of all the people on the Day of Resurrection. Do you know the reason for it? Allah will gather all the human being of early generations as well as late generation on one plain so that the announcer will be able to make them all-hear his voice and the watcher will be able to see all of them. The sun will come so close to the people that they will suffer such distress and trouble as they will not be able to bear or stand. Then the people will say, 'Don't you see to what state you have reached? Won't you look for someone who can intercede for you with your Lord' Some people will say to some others, 'Go to Adam.' So they will go to Adam and say to him. 'You are the father of mankind; Allah created you with His Own Hand, and breathed into you of His Spirit (meaning the spirit which he created for you); and ordered the angels to prostrate before you; so (please) intercede for us with your Lord. Don't you see in what state we are? Don't you see what condition we have reached?' Adam will say, 'Today my Lord has become angry as He has never become before, nor will ever become thereafter. He forbade me (to eat of the fruit of) the tree, but I disobeyed Him . Myself! Myself! Myself! (has more need for intercession). Go to someone else; go to Noah.' So they will go to Noah and say (to him), 'O Noah! You are the first (of Allah's Messengers) to the people of the earth, and Allah has named you a thankful slave; please intercede for us with your Lord. Don't you see in what state we are?' He will say.' Today my Lord has become angry as He has never become nor will ever become thereafter. I had (in the world) the right to make one definitely accepted invocation, and I made it against my nation. Myself! Myself! Myself! Go to someone else; go to Abraham.' They will go to Abraham and say, 'O Abraham! You are Allah's Apostle and His Khalil from among the people of the earth; so please intercede for us with your Lord. Don't you see in what state we are?' He will say to them, 'My Lord has today become angry as He has never become before, nor will ever become thereafter. I had told three lies (Abu Haiyan (the sub-narrator) mentioned them in the Hadith) Myself! Myself! Myself! Go to someone else; go to Moses.' The people will then go to Moses and say, 'O Moses! You art Allah's Apostle and Allah gave you superiority above the others with this message and with His direct Talk to you; (please) intercede for us with your Lord Don't you see in what state we are?' Moses will say, 'My Lord has today become angry as He has never become before, nor will become thereafter, I killed a person whom I had not been ordered to kill. Myself! Myself! Myself! Go to someone else; go to Jesus.' So they will go to Jesus and say, 'O Jesus! You are Allah's Apostle and His Word which He sent to Mary, and a superior soul created by Him, and you talked to the people while still young in the cradle. Please intercede for us with your Lord. Don't you see in what state we are?' Jesus will say. 'My Lord has today become angry as He has never become before nor will ever become thereafter. Jesus will not mention any sin, but will say, 'Myself! Myself! Myself! Go to someone else; go to Muhammad.' So they will come to me and say, 'O Muhammad ! You are Allah's Apostle and the last of the prophets, and Allah forgave your early and late sins. (Please) intercede for us with your Lord. Don't you see in what state we are?" The Prophet added, "Then I will go beneath Allah's Throne and fall in prostration before my Lord. And then Allah will guide me to such praises and glorification to Him as He has never guided anybody else before me. Then it will be said, 'O Muhammad Raise your head. Ask, and it will be granted. Intercede It (your intercession) will be accepted.' So I will raise my head and Say, 'My followers, O my Lord! My followers, O my Lord'. It will be said, 'O Muhammad! Let those of your followers who have no accounts, enter through such a gate of the gates of Paradise as lies on the right; and they will share the other gates with the people." The Prophet further said, "By Him in Whose Hand my soul is, the distance between every two gate-posts of Paradise is like the distance between Mecca and Busra (in Sham)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.237]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 237

Narrated Abu Huraira:

The Prophet said, "The recitation of Psalms (David's Quran) was made light and easy for David that he used to have his ridding animal be saddled while he would finish the recitation before the servant had saddled it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.238]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 238

Narrated Abdullah:

Regarding the explanation of the Verse: 'Those whom they call upon (worship) (like Jesus the Son of Mary, angels etc.) desire (for themselves) means of access to their Lord (Allah) as to which of them should be the nearer and they hope for His Mercy and fear His torment.' (17.57) They themselves (e.g. Angels, saints, Apostles, Jesus, etc.,) worshipped Allah, Those Jinns who were worshipped by some Arabs became Muslims (embraced Islam), but those human beings stuck to their (old) religion. Al-Amash said extra: 'Say, (O Muhammad): Call unto those besides Him whom you assume (to be gods).' (17.56)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.239]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 239

Narrated Abdullah:

Regarding the Verse: 'Those whom they call upon (worship) (like Jesus the Son of Mary or angels etc.) desire (for themselves) means of access, to their Lord....' (17.57) (It was revealed regarding) some Jinns who used to be worshipped (by human beings). They later embraced Islam (while those people kept on worshipping them).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.240]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 240

Narrated Ibn Abbas:

Regarding: 'And We granted the vision (Ascension to the Heaven "Miraj") which We showed you (O Muhammad as an actual eye witness) but as a trial for mankind.' (17.60) It was an actual eye-witness which was shown to Allah's Apostle during the night he was taken on a journey (through the heavens). And the cursed tree is the tree of Az-Zaqqum (a bitter pungent tree which grows at the bottom of Hell).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.241]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 241

Narrated Ibn Al-Musaiyab:

Abu Huraira said, "The Prophet said, 'A prayer performed in congregation is twenty-five times more superior in reward to a prayer performed by a single person. The angels of the night and the angels of the day are assembled at the time of the Fajr (Morning) prayer." Abu Huraira added, "If you wish, you can recite:-- 'Verily! The recitation of the Qur'an in the early dawn (Morning prayer) is ever witnessed (attended by the angels of the day and the night).' (17.78)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.242]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 242

Narrated Ibn Umar:

On the Day of Resurrection the people will fall on their knees and every nation will follow their prophet and they will say, "O so-and-so! Intercede (for us with Allah), "till (the right) intercession is given to the Prophet (Muhammad) and that will be the day when Allah will raise him into a station of praise and glory (i.e. Al-Maqam -al-Mahmud).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.243]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 243

Narrated Jabir bin 'Abdullah: Allah's Apostle said, "Whoever, after listening to the Adhan (for the prayer) says, 'O Allah, the Lord of this complete call and of this prayer, which is going to be established! Give Muhammad Al-Wasila and Al-Fadila and


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.244]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 244

Narrated Abdullah bin Masud:

Allah's Apostle entered Mecca (in the year of the Conquest) and there were three-hundred and sixty idols around the Ka'ba. He then started hitting them with a stick in his hand and say: 'Truth (i.e. Islam) has come and falsehood (disbelief) vanished. Truly falsehood (disbelief) is ever bound to vanish.' (17.81) 'Truth has come and falsehood (Iblis) can not create anything.' (34.49)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.245]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 245

Narrated Abdullah:

While I was in the company of the Prophet on a farm and he was reclining on a palm leave stalk, some Jews passed by. Some of them said to the others. "Ask him (the Prophet about the spirit." Some of them said, "What urges you to ask him about it" Others said, "(Don't) lest he should give you a reply which you dislike." But they said, "Ask him." So they asked him about the Spirit. The Prophet kept quiet and did not give them any answer. I knew that he was being divinely inspired so I stayed at my place. When the divine inspiration had been revealed, the Prophet said. "They ask you (O, Muhammad) concerning the Spirit, Say: "The spirit," its knowledge is with my Lord; and of knowledge you (mankind) have been given only a Little." (17.85)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.246]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 246

Narrated Ibn Abbas:

(regarding): 'Neither say your, prayer aloud, nor say it in a low tone.' (17.110) This Verse was revealed while Allah's Apostle was hiding himself in Mecca. When he prayed with his companions, he used to raise his voice with the recitation of Qur'an, and if the pagans happened to hear him, they would abuse the Qur'an, the One who revealed it and the one who brought it. Therefore Allah said to His Prophet : 'Neither say your prayer aloud.' (17.110) i.e. do not recite aloud lest the pagans should hear you, but follow a way between.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.247]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 247

Narrated Aisha:

The (above) verse was revealed in connection with the invocations.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.248]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 248

Narrated 'Ali:

That one night Allah's Apostle came to him and Fatima and said, "Don't you (both offer the (Tahajjud) prayer?" Ali said, 'When Allah wishes us to get up, we get up." The Prophet then recited: 'But man is more quarrelsome than anything.' (18.54) (See Hadith No. 227,Vol. 2)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.249]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 249

Narrated Said bin Jubair:

I said to Ibn 'Abbas, "Nauf Al-Bikali claims that Moses, the companion of Al-Khadir was not the Moses of the children of Israel" Ibn 'Abbas said, "The enemy of Allah (Nauf) told a lie." Narrated Ubai bin Ka'b that he heard Allah's Apostle saying, "Moses got up to deliver a speech before the children of Israel and he was asked, Who is the most learned person among the people?' Moses replied, 'I (am the most learned).' Allah admonished him for he did not ascribe knowledge to Allah alone. So Allah revealed to him: 'At the junction of the two seas there is a slave of Ours who is more learned than you.' Moses asked, 'O my Lord, how can I meet him?' Allah said, 'Take a fish and put it in a basket (and set out), and where you, will lose the fish, you will find him.' So Moses (took a fish and put it in a basket and) set out, along with his boy-servant Yusha' bin Nun, till they reached a rock (on which) they both lay their heads and slept. The fish moved vigorously in the basket and got out of it and fell into the sea and there it took its way through the sea (straight) as in a tunnel). (18.61) Allah stopped the current of water on both sides of the way created by the fish, and so that way was like a tunnel. When Moses got up, his companion forgot to tell him about the fish, and so they carried on their journey during the rest of the day and the whole night.

The next morning Moses asked his boy-servant 'Bring us our early meal; no doubt, we have suffered much fatigue in this journey of ours.' (18.62) Moses did not get tired till he had passed the place which Allah had ordered him to seek after. His boy-servant then said to him,' 'Do you remember when we be-took ourselves to the rock I indeed forgot the fish, none but Satan made me forget to remember it. It took its course into the sea in a marvelous way.' (18.63)

There was a tunnel for the fish and for Moses and his boy-servant there was astonishment. Moses said, 'That is what we have been seeking'. So they went back retracing their footsteps. (18.64) They both returned, retracing their steps till they reached the rock. Behold ! There they found a man covered with a garment. Moses greeted him. Al-Khadir said astonishingly. 'Is there such a greeting in your land?' Moses said, 'I am Moses.' He said, 'Are you the Moses of the children of Israel?' Moses said, 'I have come to you so that you may teach me of what you have been taught.

Al-Khadir said, 'You will not be able to have patience with me. (18.66) O Moses! I have some of Allah's knowledge which He has bestowed upon me but you do not know it; and you too, have some of Allah's knowledge which He has bestowed upon you, but I do not know it." Moses said, "Allah willing, you will find me patient, and I will not disobey you in anything.' (18.6) Al-Khadir said to him. 'If you then follow me, do not ask me about anything until I myself speak to you concerning it.' (18.70), After that both of them proceeded along the sea coast, till a boat passed by and they requested the crew to let them go on board. The crew recognized Al-Khadir and allowed them to get on board free of charge. When they got on board suddenly Moses saw that Al-Khadir had pulled out one of the planks of the boat with an adze. Moses said to him.' These people gave us a free lift, yet you have scuttled their boat so as to drown its people! Truly, you have done a dreadful thing.' (18.71)

Al-Khadir said, 'Didn't I say that you can have no patience with me ?' (18.72) Moses said, 'Call me not to account for what I forgot and be not hard upon me for my affair (with you.)" (18.73)

Allah's Apostle said, "The first excuse given by Moses, was that he had forgotten. Then a sparrow came and sat over the edge of the boat and dipped its beak once in the sea. Al-Khadir said to Moses, 'My knowledge and your knowledge, compared to Allah's knowledge is like what this sparrow has taken out of the sea.' Then they both got out of the boat, and while they were walking on the sea shore, Al-Khadir saw a boy playing with other boys. Al-Khadir got hold of the head of that boy and pulled it out with his hands and killed him. Moses said, 'Have you killed an innocent soul who has killed nobody! Truly, you have done an illegal thing.' (18.74) He said, "Didn't I tell you that you can have no patience with me?' (18.75) (The sub narrator said, the second blame was stronger than the first one.) Moses said, 'If I ask you about anything after this, keep me not in your company, you have received an excuse from me.' (18.76)

Then they both proceeded until they came to the inhabitants of a town. They asked them food but they refused to entertain them. (In that town) they found there a wall on the point of falling down. (18.77) Al-Khadir set it up straight with his own hands. Moses said, 'These are people to whom we came, but they neither fed us nor received us as guests. If you had wished, you could surely have exacted some recompense for it. Al-Khadir said, 'This is the parting between me and you ..that is the interpretation of (those things) over which you were unable to hold patience.' (18.78-82)

Allah's Apostle said, "We wished that Moses could have been more patient so that Allah might have described to us more about their story."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.250]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 250

Narrated Ibn Juraij:

Ya'la bin Muslim and 'Amr bin Dinar and some others narrated the narration of Said bin Jubair.

Narrated Said: While we were at the house of Ibn 'Abbas, Ibn 'Abbas said, "Ask me (any question)" I said, "O Abu Abbas! May Allah let me be sacrificed for you ! There is a man at Kufa who is a story-teller called Nauf; who claims that he (Al-Khadir's companion) is not Moses of Bani Israel." As for 'Amr, he said to me, "Ibn 'Abbas said, "(Nauf) the enemy of Allah told a lie." But Ya'la said to me, "Ibn 'Abbas said, Ubai bin Ka'b said, Allah's Apostle said, 'Once Moses, Allah's Apostle, preached to the people till their eyes shed tears and their hearts became tender, whereupon he finished his sermon. Then a man came to Moses and asked, 'O Allah's Apostle! Is there anyone on the earth who is more learned than you?' Moses replied, 'No.' So Allah admonished him (Moses), for he did not ascribe all knowledge to Allah. It was said, (on behalf of Allah), 'Yes, (there is a slave of ours who knows more than you ).' Moses said, 'O my Lord! Where is he?' Allah said, 'At the junction of the two seas.' Moses said, 'O my Lord ! Tell I me of a sign whereby I will recognize the place.' " 'Amr said to me, Allah said, "That place will be where the fish will leave you." Ya'la said to me, "Allah said (to Moses), 'Take a dead fish (and your goal will be) the place where it will become alive.' " So Moses took a fish and put it in a basket and said to his boy-servant "I don't want to trouble you, except that you should inform me as soon as this fish leaves you." He said (to Moses)." You have not demanded too much." And that is as mentioned by Allah:

'And (remember) when Moses said to his attendant .... ' (18.60) Yusha' bin Nun. (Said did not state that). The Prophet said, "While the attendant was in the shade of the rock at a wet place, the fish slipped out (alive) while Moses was sleeping. His attend an said (to himself), "I will not wake him, but when he woke up, he forgot to tell him The fish slipped out and entered the sea. Allah stopped the flow of the sea. where the fish was, so that its trace looked as if it was made on a rock. 'Amr forming a hole with his two thumbs an index fingers, said to me, "Like this, as in its trace was made on a rock." Moses said "We have suffered much fatigue on this journey of ours." (This was not narrate by Said). Then they returned back and found Al-Khadir. 'Uthman bin Abi Sulaiman said to me, (they found him) on a green carpet in the middle of the sea. Al-Khadir was covered with his garment with one end under his feet and the other end under his head. When Moses greeted, he uncovered his face and said astonishingly, 'Is there such a greeting in my land? Who are you?' Moses said, 'I am Moses.' Al-Khadir said, 'Are you the Moses of Bani Israel?' Moses said, 'Yes.' Al-Khadir said, "What do you want?' Moses said, ' I came to you so that you may teach me of the truth which you were taught.' Al-Khadir said, 'Is it not sufficient for you that the Torah is in your hands and the Divine Inspiration comes to you, O Moses? Verily, I have a knowledge that you ought not learn, and you have a knowledge which I ought not learn.' At that time a bird took with its beak (some water) from the sea: Al-Khadir then said, 'By Allah, my knowledge and your knowledge besides Allah's Knowledge is like what this bird has taken with its beak from the sea.' Until, when they went on board the boat (18.71). They found a small boat which used to carry the people from this sea-side to the other sea-side. The crew recognized Al-Khadir and said, 'The pious slave of Allah.' (We said to Said "Was that Khadir?" He said, "Yes.") The boat men said, 'We will not get him on board with fare.' Al-Khadir scuttled the boat and then plugged the hole with a piece o wood. Moses said, 'Have you scuttle it in order to drown these people surely, you have done a dreadful thing. (18.71) (Mujahid said. "Moses said so protestingly.") Al-Khadir said, didn't I say that you can have no patience with me?' (18.72) The first inquiry of Moses was done because of forget fullness, the second caused him to be bound with a stipulation, and the third was done he intentionally. Moses said, 'Call me not to account for what I forgot and be not hard upon me for my affair (with you).' (18.73)

(Then) they found a boy and Al-Khadir killed him. Ya'la- said: Said said 'They found boys playing and Al-Khadir got hold of a handsome infidel boy laid him down and then slew him with knife. Moses said, 'Have you killed a innocent soul who has killed nobody' (18.74) Then they proceeded and found a wall which was on the point of falling down, and Al-Khadir set it up straight Said moved his hand thus and said 'Al-Khadir raised his hand and the wall became straight. Ya'la said, 'I think Said said, 'Al-Khadir touched the wall with his hand and it became straight (Moses said to Al-Khadir), 'If you had wished, you could have taken wages for it. Said said, 'Wages that we might had eaten.' And there was a king in furor (ahead) of them" (18.79) And there was in front of them. Ibn 'Abbas recited: 'In front of them (was) a king.'

It is said on the authority of somebody other than Said that the king was Hudad bin Budad. They say that the boy was called Haisur. 'A king who seized every ship by force. (18.79) So I wished that if that boat passed by him, he would leave it because of its defect and when they have passed they would repair it and get benefit from it. Some people said that they closed that hole with a bottle, and some said with tar. 'His parents were believers, and he (the boy) was a non-believer and we(Khadir) feared lest he would oppress them by obstinate rebellion and disbelief.' (18.80) (i.e. that their love for him would urge them to follow him in his religion, 'so we (Khadir) desired that their Lord should change him for them for one better in righteousness and near to mercy' (18:81). This was in reply to Moses' saying: Have you killed an innocent soul.'? (18.74). 'Near to mercy" means they will be more merciful to him than they were to the former whom Khadir had killed. Other than Sa'id, said that they were compensated with a girl. Dawud bin Abi 'Asim said on the authority of more than one that this next child was a girl.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.251]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 251

Narrated Said bin Jubair:

I said to Ibn 'Abbas, "Nauf-al-Bakali " claims that Moses of Bani Israel was not Moses, the companion of Al-Khadir." Ibn 'Abbas said, "Allah's enemy tells a lie! Ubai bin Ka'b narrated to us that Allah's Apostle said, 'Moses got up to deliver a sermon before Bani Israel and he was asked, 'Who is the most learned person among the people?' Moses replied, 'I (am the most learned).' Allah then admonished Moses for he did not ascribe all knowledge to Allah only (Then) came the Divine Inspiration:-- 'Yes, one of Our slaves at the junction of the two seas is more learned than you.'

Moses said, 'O my Lord ! How can meet him?' Allah said, 'Take a fish in a basket and wherever the fish is lost, follow it (you will find him at that place). So Moses set out along with his attendant Yusha' bin Nun, and they carried with them a fish till they reached a rock and rested there. Moses put his head down and slept. (Sufyan, a sub-narrator said that somebody other than 'Amr said) 'At the rock there was a water spring called 'Al-Hayat' and none came in touch with its water but became alive. So some of the water of that spring fell over that fish, so it moved and slipped out of the basket and entered the sea. When Moses woke up, he asked his attendant, 'Bring our early meal' (18.62).

The narrator added: Moses did not suffer from fatigue except after he had passed the place he had been ordered to observe. His attendant Yusha bin Nun said to him, 'Do you remember (what happened) when we betook ourselves to the rock? I did indeed forget (about) the fish ...' (18.63) The narrator added: So they came back, retracing their steps and then they found in the sea, the way of the fish looking like a tunnel. So there was an astonishing event for his attendant, and there was tunnel for the fish. When they reached the rock, they found a man covered with a garment. Moses greeted him. The man said astonishingly, 'Is there any such greeting in your land?' Moses said, 'I am Moses.' The man said, 'Moses of Bani Israel?' Moses said, 'Yes,' and added, 'may I follow you so that you teach me something of the Knowledge which you have been taught?' (18.66). Al-Khadir said to him, 'O Moses! You have something of Allah's knowledge which Allah has taught you and which I do not know; and I have something of Allah's knowledge which Allah has taught me and which you do not know.' Moses said, 'But I will follow you.' Al-Khadir said, 'Then if you follow me, ask me no question about anything until I myself speak to you concerning it.' (18.70). After that both of them proceeded along the seashore. There passed by them a boat whose crew recognized Al-Khadir and received them on board free of charge. So they both got on board. A sparrow came and sat on the edge of the boat and dipped its beak unto the sea. Al-Khadir said to Moses. 'My knowledge and your knowledge and all the creation's knowledge compared to Allah's knowledge is not more than the water taken by this sparrow's beak.'

Then Moses was startled by Al-Khadir's action of taking an adze and scuttling the boat with it. Moses said to him, 'These people gave us a free lift, but you intentionally scuttled their boat so as to drown them. Surely you have...' (18.71) Then they both proceeded and found a boy playing with other boys. Al-Khadir took hold of him by the head and cut it off. Moses said to him, 'Have you killed an innocent soul who has killed nobody? Surely you have done an illegal thing! ' (18.74) He said, "Didn't I tell you that you will not be able to have patient with me up to ..but they refused to entertain them as their guests. There they found a wall therein at the point of collapsing.' (18.75-77) Al-Khadir moved his hand thus and set it upright (repaired it). Moses said to him, 'When we entered this town, they neither gave us hospitality nor fed us; if you had wished, you could have taken wages for it,' Al-Khadir said, 'This is the parting between you and me I will tell you the interpretation of (those things) about which you were unable to hold patience.'...(18.78)

Allah's Apostle said, 'We wished that Moses could have been more patient so that He (Allah) could have described to us more about their story.' Ibn 'Abbas used to recite:-- 'And in front (ahead) of them there was a king who used to seize every (serviceable) boat by force. (18.79) ...and as for the boy he was a disbeliever. "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.252]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 252

Narrated Musab:

I asked my father, "Was the Verse:-- 'Say: (O Muhammad) Shall We tell you the greatest losers in respect of their deeds?'(18.103) revealed regarding Al-Haruriyya?" He said, "No, but regarding the Jews and the Christians, for the Jews disbelieved Muhammad and the Christians disbelieved in Paradise and say that there are neither meals nor drinks therein. Al- Hururiyya are those people who break their pledge to Allah after they have confirmed that they will fulfill it, and Sad used to call them 'Al-Fasiqin (evildoers who forsake Allah's obedience).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.253]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 253

Narrated Abu Huraira:

Allah's Apostle said, "On the Day of Resurrection, a huge fat man will come who will not weigh, the weight of the wing of a mosquito in Allah's Sight." and then the Prophet added, 'We shall not give them any weight on the Day of Resurrection ' (18.105)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.254]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 254

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "On the Day of Resurrection Death will be brought forward in the shape of a black and white ram. Then a call maker will call, 'O people of Paradise!' Thereupon they will stretch their necks and look carefully. The caller will say, 'Do you know this?' They will say, 'Yes, this is Death.' By then all of them will have seen it. Then it will be announced again, 'O people of Hell !' They will stretch their necks and look carefully. The caller will say, 'Do you know this?' They will say, 'Yes, this is Death.' And by then all of them will have seen it. Then it (that ram) will be slaughtered and the caller will say, 'O people of Paradise! Eternity for you and no death O people of Hell! Eternity for you and no death."' Then the Prophet, recited:--

'And warn them of the Day of distress when the case has been decided, while (now) they are in a state of carelessness (i.e. the people of the world) and they do not believe.' (19.39)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.255]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 255

Narrated Ibn Abbas:

The Prophet said to Gabriel, "What prevents you from visiting us more often than you visit us now?" So there was revealed:--

'And we (angels) descend not but by the command of your Lord. To Him belongs what is before us and what is behind us...'(19.64)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.256]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 256

Narrated Khabbab:

I came to Al-'Asi bin Wail As-Sahmi and demanded something which he owed me. He said, "I will not give you (your money) till you disbelieve in Muhammad." I said, "No, I shall not disbelieve in Muhammad till you die and then be resurrected." He said, "Will I die and then be resurrected?" I said, 'Yes'. He said', "Then I will have wealth and children there, and I will pay you (there)." So this Verse was revealed:--

'Have you then seen him who disbelieved in Our Signs and (yet) says: I shall certainly be given wealth and children? (19.77)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.257]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 257

Narrated Khabbab:

I was a blacksmith in Mecca Once I made a sword for Al-'Asi bin Wail As-Sahmi. When I went to demand its price, he said, "I will not give it to you till you disbelieve in Muhammad." I said, "I shall not disbelieve in Muhammad till Allah make you die and then bring you to life again." He said, "If Allah should make me die and then resurrect me and I would have wealth and children." So Allah revealed:--

'Have you seen him who disbelieved in Our Signs, and (yet) says I shall certainly be given wealth and children? Has he known the unseen or has he taken a covenant from (Allah) the Beneficent?' (19.77-78)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.258]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 258

Narrated Masruq:

Khabbab said, "During the pre-lslamic period, I was a blacksmith and Al-Asi bin Wail owed me a debt." So Khabbab went to him to demand the debt. He said, "I will not give you (your due) till you disbelieve in Muhammad." Khabbab said, "By Allah, I shall not disbelieve in Muhammad till Allah makes you die and then resurrects you." Al-Asi said, "So leave me till I die and then be resurrected, for I will be given wealth and children whereupon I will pay you your debt." So this Verse was revealed:--

'Have you seen him who disbelieved in Our Signs and, (yet) says: I shall certainly be given wealth and children.' (19.77)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.259]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 259

Narrated Khabbab:

I was a blacksmith and Al-Asi Bin Wail owed me a debt, so I went to him to demand it. He said to me. "I will not pay you your debt till you disbelieve in Muhammad." I said, "I will not disbelieve in Muhammad till you die and then be resurrected." He said, "Will I be resurrected after my death? If so, I shall pay you (there) if I should find wealth and children." So there was revealed:--

'Have you seen him who disbelieved in Our Signs, and yet says: I shall certainly be given wealth and children? Has he, known to the unseen or has he taken a covenant from (Allah) the Beneficent? Nay ! We shall record what he says, and we shall add and add to his punishment. And We shall inherit from him all that he talks of, and he shall appear before Us alone.' (19.77-80)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.260]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 260

Narrated Abu Huraira:

Allah's Apostle said, "Adam and Moses met, and Moses said to Adam "You are the one who made people miserable and turned them out of Paradise." Adam said to him, "You are the one whom Allah selected for His message and whom He selected for Himself and upon whom He revealed the Torah." Moses said, 'Yes.' Adam said, "Did you find that written in my fate before my creation?' Moses said, 'Yes.' So Adam overcame Moses with this argument."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.261]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 261

Narrated Ibn Abbas:

When Allah's Apostle arrived at Medina, he found the Jews observing the fast on the day of 'Ashura' (10th of Muharram). The Prophet asked them (about it) and they replied, "This is the day when Moses became victorious over Pharaoh." The Prophet said (to the Muslims), "We are nearer to Moses than they, so fast on this day."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.262]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 262

Narrated Abu Huraira:

The Prophet said, "Moses argued with Adam and said to him (Adam), 'You are the one who got the people out of Paradise by your sin, and thus made them miserable." Adam replied, 'O Moses! You are the one whom Allah selected for His Message and for His direct talk. Yet you blame me for a thing which Allah had ordained for me before He created me?." Allah's Apostle further said, "So Adam overcame Moses by this Argument."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.263]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 263

Narrated Abdullah:

The Suras of Bani Israel, Al-Kahf, Mariyam, Taha and Al-Anbiya are from the very old Suras which I learnt by heart, and they are my first property.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.264]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 264

Narrated Ibn Abbas:

The Prophet delivered a sermon and said, "You (people) will be gathered before Allah (on the Day of Resurrection) bare-footed, naked and uncircumcised." (The Prophet then recited):-- 'As We began the first creation We shall repeat it. (It is) a promise We have undertaken and truly We shall do it.' and added, "The first man who will be dressed on the Day of Resurrection, will be Abraham. Lo! Some men from my followers will be brought and taken towards the left side, whereupon I will say, 'O Lord, (these are) my companions!' It will be said, 'You do not know what new things they introduced (into the religion) after you.' I will then say as the righteous pious slave, Jesus, said, 'I was a witness over them while I dwelt among them...(to His Statement)..and You are the Witness to all things.' (5.117) Then it will be said, '(O Muhammad) These people never stopped to apostate since you left them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.265]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 265

Narrated Abu Said Al-Khudri:

The Prophet said, "On the day of Resurrection Allah will say, 'O Adam!' Adam will reply, 'Labbaik our Lord, and Sa'daik ' Then there will be a loud call (saying), Allah orders you to take from among your offspring a mission for the (Hell) Fire.' Adam will say, 'O Lord! Who are the mission for the (Hell) Fire?' Allah will say, 'Out of each thousand, take out 999.' At that time every pregnant female shall drop her load (have a miscarriage) and a child will have grey hair. And you shall see mankind as in a drunken state, yet not drunk, but severe will be the torment of Allah." (22.2) (When the Prophet mentioned this), the people were so distressed (and afraid) that their faces got changed (in color) whereupon the Prophet said, "From Gog and Magog nine-hundred ninety-nine will be taken out and one from you. You Muslims (compared to the large number of other people) will be like a black hair on the side of a white ox, or a white hair on the side of a black ox, and I hope that you will be one-fourth of the people of Paradise." On that, we said, "Allahu-Akbar!" Then he said, "I hope that you will be) one-third of the people of Paradise." We again said, "Allahu-Akbar!" Then he said, "(I hope that you will be) one-half of the people of Paradise." So we said, Allahu Akbar."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.266]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 266

Narrated Ibn Abbas:

Regarding the Verse: "And among men is he who worships Allah's as it were on the very edge." (22.11).

A man used to come to Medina as if his wife brought a son and his mares produces offspring. He would say, "This religion (Islam) is good," but if his wife did not give birth to a child and his mares produced no offspring, he would say, "This religion is bad."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.267]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 267

Narrated Qais bin Ubad:

Abu Dharr used to take an oath confirming that the Verse:

'These two opponents (believers, and disbelievers) dispute with each other about their Lord.' (22.19) was Revealed in connection with Hamza and his two companions and 'Utbah and his two companions on the day when they ease out of the battle of Badr.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.268]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 268

Narrated Qais bin Ubad: 'Ali said, "I will be the first to kneel before the Beneficent on the

'These two opponents (believers and disbelievers dispute with each other about their Lord,' (22.19) was revealed in connection with those who came out for the Battle of Badr, i.e. 'Ali, Hamza, 'Ubaida, Shaiba bin Rabi'a, 'Utba bin Rabi'a and Al-Walid bin Utba.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.269]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 269

Narrated Sahl bin Saud:

'Uwaimir came to 'Asim bin 'Adi who was the chief of Bani Ajlan and said, "What do you say about a man who has found another man with his wife? Should he kill him whereupon you would kill him (i.e. the husband), or what should he do? Please ask Allah's Apostle about this matter on my behalf." Asim then went to the Prophet and said, "O Allah's Apostle! (And asked him that question) but Allah's Apostle disliked the question," When 'Uwaimir asked 'Asim (about the Prophet's answer) 'Asim replied that Allah's Apostle disliked such questions and considered it shameful. "Uwaimir then said, "By Allah, I will not give up asking unless I ask Allah's Apostle about it." Uwaimir came (to the Prophet ) and said, "O Allah's Apostle! A man has found another man with his wife! Should he kill him whereupon you would kill him (the husband, in Qisas) or what should he do?" Allah's Apostle said, "Allah has revealed regarding you and your wife's case in the Qur'an "So Allah's Apostle ordered them to perform the measures of Mula'ana according to what Allah had mentioned in His Book. So 'Uwaimir did Mula'ana with her and said, "O Allah's Apostle! If I kept her I would oppress her." So 'Uwaimir divorced her and so divorce became a tradition after them for those who happened to be involved in a case of Mula'ana. Allah's Apostle then said, "Look! If she (Uwaimir's wife) delivers a black child with deep black large eyes, big hips and fat legs, then I will be of the opinion that 'Uwaimir has spoken the truth; but if she delivers a red child looking like a Wahra then we will consider that 'Uwaimir has told a lie against her." Later on she delivered a child carrying the qualities which Allah's Apostle had mentioned as a proof for 'Uwaimir's claim; therefore the child was ascribed to its mother henceforth.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.270]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 270

Narrated Sahl bin Sad:

A man came to Allah's Apostle and said, "O Allah's Apostle! Suppose a man saw another man with his wife, should he kill him whereupon you might kill him (i.e. the killer) (in Qisas) or what should he do?" So Allah revealed concerning their case what is mentioned of the order of Mula'ana. Allah's Apostle said to the man, "The matter between you and your wife has been decided." So they did Mula'ana in the presence of Allah's Apostle and I was present there, and then the man divorced his wife. So it became a tradition to dissolve the marriage of those spouses who were involved in a case of Mula'ana. The woman was pregnant and the husband denied that he was the cause of her pregnancy, so the son was (later) ascribed to her. Then it became a tradition that such a son would be the heir of his mother, and she would inherit of him what Allah prescribed for her.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.271]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 271

Narrated Ibn Abbas:

Hilal bin Umaiya accused his wife of committing illegal sexual intercourse with Sharik bin Sahma' and filed the case before the Prophet. The Prophet said (to Hilal), "Either you bring forth a proof (four witnesses) or you will receive the legal punishment (lashes) on your back." Hilal said, "O Allah's Apostle! If anyone of us saw a man over his wife, would he go to seek after witnesses?" The Prophet kept on saying, "Either you bring forth the witnesses or you will receive the legal punishment (lashes) on your back." Hilal then said, "By Him Who sent you with the Truth, I am telling the truth and Allah will reveal to you what will save my back from legal punishment." Then Gabriel came down and revealed to him:--

'As for those who accuse their wives...' (24.6-9) The Prophet recited it till he reached: '... (her accuser) is telling the truth.' Then the Prophet left and sent for the woman, and Hilal went (and brought) her and then took the oaths (confirming the claim). The Prophet was saying, "Allah knows that one of you is a liar, so will any of you repent?" Then the woman got up and took the oaths and when she was going to take the fifth one, the people stopped her and said, "It (the fifth oath) will definitely bring Allah's curse on you (if you are guilty)." So she hesitated and recoiled (from taking the oath) so much that we thought that she would withdraw her denial. But then she said, "I will not dishonor my family all through these days," and carried on (the process of taking oaths). The Prophet then said, "Watch her; if she delivers a black-eyed child with big hips and fat shins then it is Sharik bin Sahma's child." Later she delivered a child of that description. So the Prophet said, "If the case was not settled by Allah's Law, I would punish her severely."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.272]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 272

Narrated Ibn Umar:

A man accused his wife of illegal sexual intercourse and denied his paternity to her (conceived) child during the lifetime of Allah's Apostle. Allah's Apostle ordered them both to do Mula'ana as Allah decreed and then gave his decision that the child would be for the mother, and a divorce decree was issued for the couple involved in a case of Mula'ana.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.273]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 273

Narrated 'Aisha:

And as for him among them who had the greater share..' (24.11) was Abdullah bin Ubai bin Salul.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.274]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 274

Narrated Aisha:

(The wife of the Prophet) Whenever Allah's Apostle intended to go on a journey, he used to draw lots among his wives and would take with him the one on whom the lot had fallen. Once he drew lots when he wanted to carry out a Ghazwa, and the lot came upon me. So I proceeded with Allah's Apostle after Allah's order of veiling (the women) had been revealed and thus I was carried in my howdah (on a camel) and dismounted while still in it. We carried on our journey, and when Allah's Apostle had finished his Ghazwa and returned and we approached Medina, Allah's Apostle ordered to proceed at night. When the army was ordered to resume the homeward journey, I got up and walked on till I left the army (camp) behind. When I had answered the call of nature, I went towards my howdah, but behold ! A necklace of mine made of Jaz Azfar (a kind of black bead) was broken and I looked for it and my search for it detained me. The group of people who used to carry me, came and carried my howdah on to the back of my camel on which I was riding, considering that I was therein. At that time women were light in weight and were not fleshy for they used to eat little (food), so those people did not feel the lightness of the howdah while raising it up, and I was still a young lady. They drove away the camel and proceeded. Then I found my necklace after the army had gone. I came to their camp but found nobody therein so I went to the place where I used to stay, thinking that they would miss me and come back in my search. While I was sitting at my place, I felt sleepy and slept. Safwan bin Al-Mu'attil As-Sulami Adh-Dhakw-ani was behind the army. He had started in the last part of the night and reached my stationing place in the morning and saw the figure of a sleeping person. He came to me and recognized me on seeing me for he used to see me before veiling. I got up because of his saying: "Inna Lillahi wa inna ilaihi rajiun," which he uttered on recognizing me. I covered my face with my garment, and by Allah, he did not say to me a single word except, "Inna Lillahi wa inna ilaihi rajiun," till he made his she-camel kneel down whereupon he trod on its forelegs and I mounted it. Then Safwan set out, leading the she-camel that was carrying me, till we met the army while they were resting during the hot midday. Then whoever was meant for destruction, fell in destruction, and the leader of the Ifk (forged statement) was 'Abdullah bin Ubai bin Salul. After this we arrived at Medina and I became ill for one month while the people were spreading the forged statements of the people of the Ifk, and I was not aware of anything thereof. But what aroused my doubt while I was sick, was that I was no longer receiving from Allah's Apostle the same kindness as I used to receive when I fell sick. Allah's Apostle would enter upon me, say a greeting and add, "How is that (lady)?" and then depart.

That aroused my suspicion but I was not aware of the propagated evil till I recovered from my ailment. I went out with Um Mistah to answer the call of nature towards Al-Manasi, the place where we used to relieve ourselves, and used not to go out for this purpose except from night to night, and that was before we had lavatories close to our houses. And this habit of ours was similar to the habit of the old 'Arabs (in the deserts or in the tents) concerning the evacuation of the bowels, for we considered it troublesome and harmful to take lavatories in the houses. So I went out with Um Mistah who was the daughter of Abi Ruhm bin Abd Manaf, and her mother was daughter of Sakhr bin Amir who was the aunt of Abi Bakr As-Siddiq, and her son was Mistah bin Uthatha. When we had finished our affair, Um Mistah and I came back towards my house. Um Mistah stumbled over her robe whereupon she said, "Let Mistah be ruined ! " I said to her, "What a bad word you have said! Do you abuse a man who has taken part in the Battle of Badr?' She said, "O you there! Didn't you hear what he has said?" I said, "And what did he say?" She then told me the statement of the people of the Ifk (forged statement) which added to my ailment. When I returned home, Allah's Apostle came to me, and after greeting, he said, "How is that (lady)?" I said, "Will you allow me to go to my parents?" At that time I intended to be sure of the news through them. Allah's Apostle allowed me and I went to my parents and asked my mother, "O my mother! What are the people talking about?" My mother said, "O my daughter! Take it easy, for by Allah, there is no charming lady who is loved by her husband who has other wives as well, but that those wives would find fault with her." I said, "Subhan Allah! Did the people really talk about that?"

That night I kept on weeping the whole night till the morning. My tears never stopped, nor did I sleep, and morning broke while I was still weeping, Allah's Apostle called 'Ali bin Abi Talib and Usama bin Zaid when the Divine Inspiration delayed, in order to consult them as to the idea of divorcing his wife. Usama bin Zaid told Allah's Apostle of what he knew about the innocence of his wife and of his affection he kept for her. He said, "O Allah's Apostle! She is your wife, and we do not know anything about her except good." But 'Ali bin Abi Talib said, "O Allah's Apostle! Allah does not impose restrictions on you; and there are plenty of women other than her. If you however, ask (her) slave girl, she will tell you the truth." 'Aisha added: So Allah's Apostle called for Barira and said, "O Barira! Did you ever see anything which might have aroused your suspicion? (as regards Aisha). Barira said, "By Allah Who has sent you with the truth, I have never seen anything regarding Aisha which I would blame her for except that she is a girl of immature age who sometimes sleeps and leaves the dough of her family unprotected so that the domestic goats come and eat it." So Allah's Apostle got up (and addressed) the people an asked for somebody who would take revenge on 'Abdullah bin Ubai bin Salul then. Allah's Apostle, while on the pulpit, said, "O Muslims! Who will help me against a man who has hurt me by slandering my family? By Allah, I know nothing except good about my family, and people have blamed a man of whom I know nothing except good, and he never used to visit my family except with me," Sad bin Muadh Al-Ansari got up and said, "O Allah's Apostle! By Allah, I will relieve you from him. If he be from the tribe of (Bani) Al-Aus, then I will chop his head off; and if he be from our brethren, the Khazraj, then you give us your order and we will obey it." On that, Sad bin 'Ubada got up, and he was the chief of the Khazraj, and before this incident he had been a pious man but he was incited by his zeal for his tribe. He said to Sad (bin Muadh), "By Allah the Eternal, you have told a lie! You shall not kill him and you will never be able to kill him!" On that, Usaid bin Hudair, the cousin of Sad (bin Muadh) got up and said to Sad bin 'Ubada, "You are a liar! By Allah the Eternal, we will surely kill him; and you are a hypocrite defending the hypocrites!" So the two tribes of Al-Aus and Al-Khazraj got excited till they were on the point of fighting with each other while Allah's Apostle was standing on the pulpit. Allah's Apostle continued quietening them till they became silent whereupon he became silent too. On that day I kept on weeping so much that neither did my tears stop, nor could I sleep. In the morning my parents were with me, and I had wept for two nights and a day without sleeping and with incessant tears till they thought that my liver would burst with weeping. While they were with me and I was weeping, an Ansari woman asked permission to see me. I admitted her and she sat and started weeping with me. While I was in that state, Allah's Apostle came to us, greeted, and sat down,. He had never sat with me since the day what was said, was said. He had stayed a month without receiving any Divine Inspiration concerning my case. Allah's Apostle recited the Tashahhud after he had sat down, and then said, "Thereafter, O 'Aisha! I have been informed such and-such a thing about you; and if you are innocent, Allah will reveal your innocence, and if you have committed a sin, then ask for Allah's forgiveness and repent to Him, for when a slave confesses his sin and then repents to Allah, Allah accepts his repentance." When Allah's Apostle had finished his speech, my tears ceased completely so that I no longer felt even a drop thereof. Then I said to my father, "Reply to Allah's Apostle on my behalf as to what he said." He said, "By Allah, I do not know what to say to Allah's Apostle." Then I said to my mother, "Reply to Allah's Apostle."

She said, "I do not know what to say to Allah's Apostle." Still a young girl as I was and though I had little knowledge of Quran, I said, "By Allah, I know that you heard this story (of the Ifk) so much so that it has been planted in your minds and you have believed it. So now, if I tell you that I am innocent, and Allah knows that I am innocent, you will not believe me; and if I confess something, and Allah knows that I am innocent of it, you will believe me. By Allah, I cannot find of you an example except that of Joseph's father: "So (for me) patience is most fitting against that which you assert and it is Allah (Alone) Whose help can be sought. Then I turned away and lay on my bed, and at that time I knew that I was innocent and that Allah would reveal my innocence. But by Allah, I never thought that Allah would sent down about my affair, Divine Inspiration that would be recited (forever), as I considered myself too unworthy to be talked of by Allah with something that was to be recited: but I hoped that Allah's Apostle might have a vision in which Allah would prove my innocence. By Allah, Allah's Apostle had not left his seat and nobody had left the house when the Divine Inspiration came to Allah's Apostle . So there overtook him the same hard condition which used to overtake him (when he was Divinely Inspired) so that the drops of his sweat were running down, like pearls, though it was a (cold) winter day, and that was because of the heaviness of the Statement which was revealed to him. When that state of Allah's Apostle was over, and he was smiling when he was relieved, the first word he said was, "Aisha, Allah has declared your innocence." My mother said to me, "Get up and go to him." I said, "By Allah, I will not go to him and I will not thank anybody but Allah." So Allah revealed: "Verily! They who spread the Slander are a gang among you. Think it not...." (24.11-20).

When Allah revealed this to confirm my innocence, Abu Bakr As-Siddiq who used to provide for Mistah bin Uthatha because of the latter's kinship to him and his poverty, said, "By Allah, I will never provide for Mistah anything after what he has said about Aisha". So Allah revealed:

"Let not those among you who are good and are wealthy swear not to give (help) to their kinsmen, those in need, and those who have left their homes for Allah's Cause. Let them Pardon and forgive (i.e. do not punish them). Do you not love that should forgive you? Verily Allah is Oft-forgiving. Most Merciful." (24.22)

Abu Bakr said, "Yes, by Allah, I wish that Allah should forgive me." So he resumed giving Mistah the aid he used to give him before and said, "By Allah, I will never withold it from him at all." Aisha further said: Allah's Apostle also asked Zainab bint Jahsh about my case. He said, "O Zainab! What have you seen?" She replied, "O Allah's Apostle! I protect my hearing and my sight (by refraining from telling lies). I know nothing but good (about Aisha)." Of all the wives of Allah's Apostle, it was Zainab who aspired to receive from him the same favor as I used to receive, yet, Allah saved her (from telling lies) because of her piety. But her sister, Hamna, kept on fighting on her behalf so she was destroyed as were those who invented and spread the slander.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.275]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 275

Narrated Um Ruman:

Aisha's mother, When 'Aisha was accused, she fell down Unconscious.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.276]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 276

Narrated Ibn Abi Mulaika:

I heard 'Aisha reciting: "When you invented a lie (and carry it) on your tongues." (24.15)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.277]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 277

Narrated Ibn Abu Mulaika:

Ibn 'Abbas asked permission to visit Aisha before her death, and at that time she was in a state of agony. She then said. "I am afraid that he will praise me too much." And then it was said to her, "He is the cousin of Allah's Apostle and one of the prominent Muslims." Then she said, "Allow him to enter." (When he entered) he said, "How are you?" She replied, "I am Alright if I fear (Allah)." Ibn Abbas said, "Allah willing, you are Alright as you are the wife of Allah's Apostle and he did not marry any virgin except you and proof of your innocence was revealed from the Heaven." Later on Ibn Az-Zubair entered after him and 'Aisha said to him, "Ibn 'Abbas came to me and praised me greatly, but I wish that I was a thing forgotten and out of sight."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.278]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 278

Narrated Al-Qasim:

Ibn 'Abbas asked 'Aisha's permission to enter. Al-Qasim then narrated the whole Hadith (as in 277) but did not mention: "Would that I had been forgotten and out of sight."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.279]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 279

Narrated Masruq:

'Aisha said that Hassan bin Thabit came and asked permission to visit her. I said, "How do you permit such a person?" She said, "Hasn't he received a severely penalty?" (Sufyan, the subnarrator, said: She meant the loss of his sight.) Thereupon Hassan said the following poetic verse:

"A chaste pious woman who arouses no suspicion. She never talks about chaste heedless women behind their backs.' On that she said, "But you are not so."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.280]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 280

Narrated Masruq:

Hassan came to Aisha and said the following poetic Verse: 'A chaste pious woman who arouses no suspicion. She never talks against chaste heedless women behind their backs.' 'Aisha said, "But you are not," I said (to 'Aisha), "Why do you allow such a person to enter upon you after Allah has revealed:

"...and as for him among them who had the greater share therein'?" (24.11)

She said, "What punishment is worse than blindness?" She added, "And he used to defend Allah's Apostle against the pagans (in his poetry).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.281]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 281

Narrated Aisha:

When there was said about me what was said which I myself was unaware of, Allah's Apostle got up and addressed the people. He recited Tashah-hud, and after glorifying and praising Allah as He deserved, he said, "To proceed: O people Give me your opinion regarding those people who made a forged story against my wife. By Allah, I do not know anything bad about her. By Allah, they accused her of being with a man about whom I have never known anything bad, and he never entered my house unless I was present there, and whenever I went on a journey, he went with me." Sad bin Mu'adh got up and said, "O Allah's Apostle Allow me to chop their heads off" Then a man from the Al-Khazraj (Sa'd bin 'Ubada) to whom the mother of (the poet) Hassan bin Thabit was a relative, got up and said (to Sad bin Mu'adh), "You have told a lie! By Allah, if those persons were from the Aus Tribe, you would not like to chop their heads off." It was probable that some evil would take place between the Aus and the Khazraj in the mosque, and I was unaware of all that. In the evening of that day, I went out for some of my needs (i.e. to relieve myself), and Um Mistah was accompanying me. On our return, Um Mistah stumbled and said, "Let Mistah. be ruined" I said to her, "O mother Why do you abuse your Son" On that Um Mistah became silent for a while, and stumbling again, she said, "Let Mistah be ruined" I said to her, "Why do you abuse your son?" She stumbled for the third time and said, "Let Mistah be ruined" whereupon I rebuked her for that. She said, "By Allah, I do not abuse him except because of you." I asked her, "Concerning what of my affairs?" So she disclosed the whole story to me. I said, "Has this really happened?" She replied, "Yes, by Allah." I returned to my house, astonished (and distressed) that I did not know for what purpose I had gone out. Then I became sick (fever) and said to Allah's Apostle "Send me to my father's house." So he sent a slave with me, and when I entered the house, I found Um Rum-an (my mother) downstairs while (my father) Abu Bakr was reciting something upstairs. My mother asked, "What has brought you, O (my) daughter?" I informed her and mentioned to her the whole story, but she did not feel it as I did. She said, "O my daughter! Take it easy, for there is never a charming lady loved by her husband who has other wives but that they feel jealous of her and speak badly of her." But she did not feel the news as I did. I asked (her), "Does my father know about it?" She said, "yes" I asked, Does Allah's Apostle know about it too?" She said, "Yes, Allah's Apostle does too." So the tears filled my eyes and I wept. Abu Bakr, who was reading upstairs heard my voice and came down and asked my mother, "What is the matter with her? " She said, "She has heard what has been said about her (as regards the story of Al-lfk)." On that Abu- Bakr wept and said, "I beseech you by Allah, O my daughter, to go back to your home" I went back to my home and Allah's Apostle had come to my house and asked my maid-servant about me (my character). The maid-servant said, "By Allah, I do not know of any defect in her character except that she sleeps and let the sheep enter (her house) and eat her dough." On that, some of the Prophet's companions spoke harshly to her and said, "Tell the truth to Allah's Apostle." Finally they told her of the affair (of the slander). She said, "Subhan Allah! By Allah, I know nothing against her except what goldsmith knows about a piece of pure gold." Then this news reached the man who was accused, and he said, "Subhan Allah! By Allah, I have never uncovered the private parts of any woman." Later that man was martyred in Allah's Cause. Next morning my parents came to pay me a visit and they stayed with me till Allah's Apostle came to me after he had offered the Asr prayer. He came to me while my parents were sitting around me on my right and my left. He praised and glorified Allah and said, "Now then O 'Aisha! If you have committed a bad deed or you have wronged (yourself), then repent to Allah as Allah accepts the repentance from his slaves." An Al-Ansari woman had come and was sitting near the gate. I said (to the Prophet). "Isn't it improper that you speak in such a way in the presence of this lady? Allah's Apostle then gave a piece of advice and I turned to my father and requested him to answer him (on my behalf). My father said, "What should I say?" Then I turned to my mother and asked her to answer him. She said, "What should I say?" When my parents did not give a reply to the Prophet, I said, "I testify that none has the right to be worshipped except Allah, and that Muhammad is His Apostle!" And after praising and glorifying Allah as He deserves, I said, "Now then, by Allah, if I were to tell you that I have not done (this evil action) and Allah is a witness that I am telling the truth, that would not be of any use to me on your part because you (people) have spoken about it and your hearts have absorbed it; and if I were to tell you that I have done this sin and Allah knows that I have not done it, then you will say, 'She has confessed herself guilty." By Allah, 'I do not see a suitable example for me and you but the example of (I tried to remember Jacob's name but couldn't) Joseph's father when he said; So (for me) "Patience is most fitting against that which you assert. It is Allah (alone) whose help can be sought.' At that very hour the Divine Inspiration came to Allah's Apostle and we remained silent. Then the Inspiration was over and I noticed the signs of happiness on his face while he was removing (the sweat) from his forehead and saying, "Have the good tidings O ' "Aisha! Allah has revealed your innocence." At that time I was extremely angry. My parents said to me. "Get up and go to him." I said, "By Allah, I will not do it and will not thank him nor thank either of you, but I will thank Allah Who has revealed my innocence. You have heard this story but neither did not deny it nor change it (to defend me)," (Aisha used to say:) "But as regards Zainab bint Jahsh, (the Prophet's wife), Allah protected her because of her piety, so she did not say anything except good (about me), but her sister, Hamna, was ruined among those who were ruined. Those who used to speak evil about me were Mistah, Hassan bin Thabit, and the hypocrite, Abdullah bin Ubai, who used to spread that news and tempt others to speak of it, and it was he and Hamna who had the greater share therein. Abu Bakr took an oath that he would never do any favor to Mistah at all. Then Allah revealed the Divine Verse:--

"Let not those among you who are good and wealthy (i.e. Abu Bakr) swear not to give (any sort of help) to their kinsmen, and those in need, (i.e. Mistah) ...Do you not love that Allah should forgive you? And Allah if Oft-Forgiving, Most Merciful." (24.22)

On that, Abu Bakr said, "Yes, by Allah, O our Lord! We wish that You should forgive us." So Abu Bakr again started giving to Mistah the expenditure which he used to give him before.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.282]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 282

Narrated Safiya bint Shaiba:

'Aisha used to say: "When (the Verse): "They should draw their veils over their necks and bosoms," was revealed, (the ladies) cut their waist sheets at the edges and covered their faces with the cut pieces."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.283]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 283

Narrated Anas bin Malik:

A man said, "O Allah's Prophet! Will Allah gather the non-believers on their faces on the Day of Resurrection?" He said, "Will not the One Who made him walk on his feet in this world, be able to make him walk on his face on the Day of Resurrection?" (Qatada, a subnarrator, said: Yes, By the Power of Our Lord!)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.284]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 284

Narrated 'Abdullah:

I or somebody, asked Allah's Apostle "Which is the biggest sin in the Sight of Allah?" He said, "That you set up a rival (in worship) to Allah though He Alone created you." I asked, "What is next?" He said, "Then, that you kill your son, being afraid that he may share your meals with you." I asked, "What is next?" He said, "That you commit illegal sexual intercourse with the wife of your neighbor." Then the following Verse was revealed to confirm the statement of Allah's Apostle:

"Those who invoke not with Allah, any other god, nor kill life as Allah has forbidden except for just cause, nor commit illegal sexual intercourse." (25.68)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.285]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 285

Narrated Al-Qasim bin Abi Bazza:

That he asked Said bin Jubair, "Is there any repentance of the one who has murdered a believer intentionally?" Then I recited to him:--

"Nor kill such life as Allah has forbidden except for a just cause." Said said, "I recited this very Verse before Ibn 'Abbas as you have recited it before me. Ibn 'Abbas said, 'This Verse was revealed in Mecca and it has been abrogated by a Verse in Surat-An-Nisa which was later revealed in Medina."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.286]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 286

Narrated Said bin Jubair:

The people of Kufa differed as regards the killing of a believer so I entered upon Ibn 'Abbas (and asked him) about that. Ibn 'Abbas said, "The Verse (in Surat-An-Nisa', 4:93) was the last thing revealed in this respect and nothing cancelled its validity."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.287]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 287

Narrated Said bin Jubair:

I asked Ibn 'Abbas about Allah's saying:--

'.. this reward is Hell Fire.' (4.93) He said, "No repentance is accepted from him (i.e. the murderer of a believer)." I asked him regarding the saying of Allah:

'Those who invoke not with Allah any other god.' ...(25.68)

He said, "This Verse was revealed concerning the pagans of the pre-lslamic period."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.288]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 288

Narrated Said bin Jubair:

Ibn Abza said to me, "Ask Ibn 'Abbas regarding the Statement of Allah:

'And whoever murders a believer intentionally, his recompense is Hell.' (4.69)

And also His Statement: '...nor kill such life as Allah has forbidden, except for a just cause .....except those who repent, believe, and do good deeds.' " (25.68-70) So I asked Ibn 'Abbas and he said, "When this (25.68-69) was revealed, the people of Mecca said, "We have invoked other gods with Allah, and we have murdered such lives which Allah has made sacred, and we have committed illegal sexual intercourse. So Allah revealed:

'Except those who repent, believe, and do good deeds and Allah is Oft-Forgiving, Most Merciful.' (25.70)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.289]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 289

Narrated Said bin Jubair:

Abdur-Rahman bin Abza ordered me to ask Ibn 'Abbas regarding the two Verses (the first of which was ):

"And whosoever murders a believer intentionally." (4.93) So I asked him, and he said, "Nothing has abrogated this Verse." About (the other Verse): 'And those who invoke not with Allah any other god.' he said, "It was revealed concerning the pagans,'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.290]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 290

Narrated Abdullah:

Five (great events) have passed: the Smoke, the Moon, the Romans, the Mighty grasp and the constant Punishment which occurs in 'So the torment will be yours forever.' (25.77)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.291]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 291

Narrated Abu Huraira:

The Prophet said, "On the Day of Resurrection Abraham will see his father covered with Qatara and Ghabara. (i.e. having a dark face)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.292]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 292

Narrated Abu Huraira:

The Prophet said, Abraham will meet his father (on the Day of Resurrection) and will say, 'O my Lords You promised me that You would not let me in disgrace on the Day when people will be resurrected.' Allah will say, 'I have forbidden Paradise to the non-believers."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.293]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 293

Narrated Ibn Abbas:

When the Verse:--'And warn your tribe of near-kindred, was revealed, the Prophet ascended the Safa (mountain) and started calling, "O Bani Fihr! O Bani 'Adi!" addressing various tribes of Quraish till they were assembled. Those who could not come themselves, sent their messengers to see what was there. Abu Lahab and other people from Quraish came and the Prophet then said, "Suppose I told you that there is an (enemy) cavalry in the valley intending to attack you, would you believe me?" They said, "Yes, for we have not found you telling anything other than the truth." He then said, "I am a warner to you in face of a terrific punishment." Abu Lahab said (to the Prophet) "May your hands perish all this day. Is it for this purpose you have gathered us?" Then it was revealed: "Perish the hands of Abu Lahab (one of the Prophet's uncles), and perish he! His wealth and his children will not profit him...." (111.1-5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.294]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 294

Narrated Abu Huraira:

Allah's Apostle got up when the Verse:--'And warn your tribe of near kindred...." (26.214) was revealed and said, "O Quraish people! (or he said a similar word) Buy yourselves! I cannot save you from Allah (if you disobey Him) O Bani Abu Manaf! I cannot save you from Allah (if you disobey Him). O 'Abbas! The son of 'Abdul Muttalib! I cannot save you from Allah (if you disobey Him) O Safiya, (the aunt of Allah's Apostle) I cannot save you from Allah (if you disobey Him). O Fatima, the daughter of Muhammad ! Ask what you wish from my property, but I cannot save you from Allah (if you disobey Him)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.295]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 295

Narrated Al-Musaiyab:

When Abu Talib was on his death bed, Allah's Apostle came to him and found with him, Abu Jahl and Abdullah bin Abi Umaiya bin Al-Mughira. Allah's Apostle said, "O uncle! Say: None has the right to be worshipped except Allah, a sentence with which I will defend you before Allah." On that Abu Jahl and 'Abdullah bin Abi Umaiya said to Abu Talib, "Will you now leave the religion of 'Abdul Muttalib?" Allah's Apostle kept on inviting him to say that sentence while the other two kept on repeating their sentence before him till Abu Talib said as the last thing he said to them, "I am on the religion of 'Abdul Muttalib," and refused to say: None has the right to be worshipped except Allah. On that Allah's Apostle said, "By Allah, I will keep on asking Allah's forgiveness for you unless I am forbidden (by Allah) to do so." So Allah revealed:--

'It is not fitting for the Prophet and those who believe that they should invoke (Allah) for forgiveness for pagans.' (9.113) And then Allah revealed especially about Abu Talib:--'Verily! You (O, Muhammad) guide not whom you like, but Allah guides whom He will.' (28.56)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.296]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 296

Narrated Ibn Abbas:

'...will bring you home' means to Mecca.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.297]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 297

Narrated Masruq:

While a man was delivering a speech in the tribe of Kinda, he said, "Smoke will prevail on the Day of Resurrection and will deprive the hypocrites their faculties of hearing and seeing. The believers will be afflicted with something like cold only thereof." That news scared us, so I went to (Abdullah) Ibn Mas'ud while he was reclining (and told him the story) whereupon he became angry, sat up and said, "He who knows a thing can say, it, but if he does not know, he should say, 'Allah knows best,' for it is an aspect of knowledge to say, 'I do not know,' if you do not know a certain thing. Allah said to His prophet. 'Say (O Muhammad): No wage do I ask of you for this (Qur'an), nor I am one of the pretenders (a person who pretends things which do not exist.)' (38.86)

The Qur'aish delayed in embracing Islam for a period, so the Prophet invoked evil on them, saying, 'O Allah! Help me against them by sending seven years of (famine) like those of Joseph.' So they were afflicted with such a severe year of famine that they were destroyed therein and ate dead animals and bones. They started seeing something like smoke between the sky and the earth (because of severe hunger). Abu Sufyan then came (to the Prophet) and said, "O Muhammad! You came to order us for to keep good relations with Kith and kin, and your kinsmen have now perished, so please invoke Allah (to relieve them).' Then Ibn Mas'ud recited:-- 'Then watch you for the day that the sky will bring forth a kind of smoke plainly visible....but truly you will return! (to disbelief) (44.10-15)

Ibn Mas'ud added, Then the punishment was stopped, but truly, they reverted to heathenism (their old way). So Allah (threatened them thus): 'On the day when we shall seize you with a mighty grasp.' (44.16) And that was the day of the Battle of Badr. Allah's saying- "Lizama" (the punishment) refers to the day of Badr Allah's Statement:

'Alif-Lam-Mim, the Romans have been defeated, and they, after their defeat, will be victorious,' (30.1-3) (This verse): Indicates that the defeat of Byzantine has already passed.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.298]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 298

Narrated Abu- Huraira: Allah's Apostle said, "No child is born except on Al-Fitra (Islam) and then his parents make him Jewish, Christian or Magian, as an animal produces a perfect young animal: do you see any part of its body amputated?" Then he rec

'The religion of pure Islamic Faith (Hanifa),(i.e. to worship none but Allah), The pure Allah's Islamic nature with which He (Allah) has created mankind. Let There be no change in Allah's religion (i.e. to join none in Allah's worship). That is the straight religion; but most of men know not..." (30.30)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.299]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 299

Narrated Abdullah:

When there was revealed: 'It is those who believe and confuse not their beliefs with wrong.' (6.82) It was very hard for the companions of Allah's Apostle, so they said, "Which of us has not confused his belief with wrong?" Allah's Apostle said, "The Verse does not mean this. Don't you hear Luqman's statement to his son: 'Verily! Joining others in worship, with Allah is a great wrong indeed.' (31.13)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.300]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 300

Narrated Abu Huraira:

One day while Allah's Apostle was sitting with the people, a man came to him walking and said, "O Allah's Apostle. What is Belief?" The Prophet said, "Belief is to believe in Allah, His Angels, His Books, His Apostles, and the meeting with Him, and to believe in the Resurrection." The man asked, "O Allah's Apostle What is Islam?" The Prophet replied, "Islam is to worship Allah and not worship anything besides Him, to offer prayers perfectly, to pay the (compulsory) charity i.e. Zakat and to fast the month of Ramadan." The man again asked, "O Allah's Apostle What is Ihsan (i.e. perfection or Benevolence)?" The Prophet said, "Ihsan is to worship Allah as if you see Him, and if you do not achieve this state of devotion, then (take it for granted that) Allah sees you." The man further asked, "O Allah's Apostle When will the Hour be established?"

The Prophet replied, "The one who is asked about it does not know more than the questioner does, but I will describe to you its portents. When the lady slave gives birth to her mistress, that will be of its portents; when the bare-footed naked people become the chiefs of the people, that will be of its portents. The Hour is one of five things which nobody knows except Allah. Verily, the knowledge of the Hour is with Allah (alone). He sends down the rain, and knows that which is in the wombs." (31.34) Then the man left. The Prophet said, "Call him back to me." They went to call him back but could not see him. The Prophet said, "That was Gabriel who came to teach the people their religion." (See Hadith No. 47 Vol 1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.301]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 301

Narrated Abdullah bin Umar:

The Prophet said, "The keys of the Unseen are five." And then he recited:

'Verily, the knowledge of the Hour is with Allah (alone).' (31.34)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.302]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 302

Narrated Abu Huraira: Allah's Apostle said, "Allah said, 'I have prepared for my pious worshipers such things as no eye has ever seen, no ear has ever heard of, and nobody has ever thought of." Abu Huraira added: If you wish you can read:-- 'No soul


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.303]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 303

Narrated Abu Huraira:

The Prophet, said, "Allah said, 'I have prepared for My pious worshipers such things as no eye has ever seen, no ear has ever heard of, and nobody has ever thought of. All that is reserved, besides which, all that you have seen, is nothing." Then he recited:--

'No soul knows what is kept hidden (in reserve) for them of joy as a reward for what they used to do.' (32.17)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.304]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 304

Narrated Abu Huraira:

The Prophet said, "There is no believer but I, of all the people, I am the closest to him both in this world and in the Hereafter. Recite if you wish: 'The Prophet is closer to the believers than their own selves.' (33.6) so if a believer (dies) leaves some property then his relatives will inherit that property; but if he is in debt or he leaves poor children, let those (creditors and children) come to me (that I may pay the debt and provide for the children), for them I am his sponsor (surely).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.305]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 305

Narrated Abdullah bin Umar:

We used not to call Zaid bin Haritha the freed slave of Allah's Apostle except Zaid bin Muhammad till the Qu'anic Verse was revealed: "Call them (adopted sons) by (the names of) their fathers. That is more than just in the Sight of Allah." (33.5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.306]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 306

Narrated Anas:

We think that the Verse: 'Among the Believers are men who have been true to their covenant with Allah.' was revealed in favor of Anas bin An-Nadir.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.307]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 307

Narrated Zaid bin Thabit:

When we collected the fragramentary manuscripts of the Qur'an into copies, I missed one of the Verses of Surat al-Ahzab which I used to hear Allah's Apostle reading. Finally I did not find it with anybody except Khuzaima Al-Ansari, whose witness was considered by Allah's Apostle equal to the witness of two men. (And that Verse was:)

'Among the believers are men who have been true to their covenant with Allah.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.308]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 308

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle came to me when Allah ordered him to give option to his wives. So Allah's Apostle started with me, saying, "I am going to mention to you something but you should not hasten (to give your reply) unless you consult your parents.' He knew that my parents would not order me to leave him. Then he said, "Allah says:--

"O Prophet! Say to your wives..." (33.28-29)

On that I said to him, "Then why should I consult my parents? Verily, I seek Allah, His Apostle and the Home of the Hereafter."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.309]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 309

Narrated 'Aisha:

(the wife of the Prophet) when Allah's Apostle was ordered to give option to his wives, he started with me, saying, "I am going to mention to you something, but you shall not hasten (to give your reply) unless you consult your parents." The Prophet knew that my parents would not order me to leave him. Then he said, "Allah says: 'O Prophet (Muhammad)! Say to your wives: If you desire the life of this world and its glitter........a great reward." (33.28-29) I said, "Then why I consult my parents? Verily, I seek Allah, His Apostle and the Home of the Hereafter." Then all the other wives of the Prophet did the same as I did.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.310]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 310

Narrated Anas bin Malik:

The Verse: 'But you did hide in your mind that which Allah was about to make manifest.' (33.37) was revealed concerning Zainab bint Jahsh and Zaid bin Haritha.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.311]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 311

Narrated Aisha:

I used to look down upon those ladies who had given themselves to Allah's Apostle and I used to say, "Can a lady give herself (to a man)?" But when Allah revealed: "You (O Muhammad) can postpone (the turn of) whom you will of them (your wives), and you may receive any of them whom you will; and there is no blame on you if you invite one whose turn you have set aside (temporarily).' (33.51) I said (to the Prophet), "I feel that your Lord hastens in fulfilling your wishes and desires."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.312]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 312

Narrated Muadha:

'Aisha said, "Allah's Apostle used to take the permission of that wife with whom he was supposed to stay overnight if he wanted to go to one other than her, after this Verse was revealed:--

"You (O Muhammad) can postpone (the turn of) whom you will of them (your wives) and you may receive any (of them) whom you will; and there is no blame on you if you invite one whose turn you have set aside (temporarily). (33.51) I asked Aisha, "What did you use to say (in this case)?" She said, "I used to say to him, "If I could deny you the permission (to go to your other wives) I would not allow your favor to be bestowed on any other person."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.313]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 313

Narrated Umar: I said, "O Allah's Apostle! Good and bad persons enter upon you, so I suggest that you order the mothers of the Believers (i.e. your wives) to observe veils." Then Allah revealed the Verses of Al-Hijab.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.314]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 314

Narrated Anas bin Malik:

When Allah's Apostle married Zainab bint Jahsh, he invited the people to a meal. They took the meal and remained sitting and talking. Then the Prophet (showed them) as if he is ready to get up, yet they did not get up. When he noticed that (there was no response to his movement), he got up, and the others too, got up except three persons who kept on sitting. The Prophet came back in order to enter his house, but he went away again. Then they left, whereupon I set out and went to the Prophet to tell him that they had departed, so he came and entered his house. I wanted to enter along with him, but he put a screen between me and him. Then Allah revealed:

'O you who believe! Do not enter the houses of the Prophet...' (33.53)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.315]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 315

Narrated Anas bin Malik:

I of all the people know best this verse of Al-Hijab. When Allah's Apostle married Zainab bint Jahsh she was with him in the house and he prepared a meal and invited the people (to it). They sat down (after finishing their meal) and started chatting. So the Prophet went out and then returned several times while they were still sitting and talking. So Allah revealed the Verse:

'O you who believe! Enter not the Prophet's houses until leave is given to you for a meal, (and then) not (so early as) to wait for its preparation .....ask them from behind a screen.' (33.53) So the screen was set up and the people went away.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.316]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 316

Narrated Anas:

A banquet of bread and meat was held on the occasion of the marriage of the Prophet to Zainab bint Jahsh. I was sent to invite the people (to the banquet), and so the people started coming (in groups); They would eat and then leave. Another batch would come, eat and leave. So I kept on inviting the people till I found nobody to invite. Then I said, "O Allah's Prophet! I do not find anybody to invite." He said, "Carry away the remaining food." Then a batch of three persons stayed in the house chatting. The Prophet left and went towards the dwelling place of Aisha and said, "Peace and Allah's Mercy be on you, O the people of the house!" She replied, "Peace and the mercy of Allah be on you too. How did you find your wife? May Allah bless you. Then he went to the dwelling places of all his other wives and said to them the same as he said to Aisha and they said to him the same as Aisha had said to him. Then the Prophet returned and found a group of three persons still in the house chatting. The Prophet was a very shy person, so he went out (for the second time) and went towards the dwelling place of 'Aisha. I do not remember whether I informed him that the people have gone away. So he returned and as soon as he entered the gate, he drew the curtain between me and him, and then the Verse of Al-Hijab was revealed.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.317]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 317

Narrated Anas:

When Allah's Apostle married Zainab bint Jahsh, he made the people eat meat and bread to their fill (by giving a Walima banquet). Then he went out to the dwelling places of the mothers of the believers (his wives), as he used to do in the morning of his marriage. He would greet them and invoke good on them, and they (too) would return his greeting and invoke good on him. When he returned to his house, he found two men talking to each other; and when he saw them, he went out of his house again. When those two men saw Allah's Apostle: going out of his house, they quickly got up (and departed). I do not remember whether I informed him of their departure, or he was informed (by somebody else). So he returned, and when he entered the house, he lowered the curtain between me and him. Then the Verse of Al-Hijab was revealed.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.318]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 318

Narrated Aisha:

Sauda (the wife of the Prophet) went out to answer the call of nature after it was made obligatory (for all the Muslims ladies) to observe the veil. She was a fat huge lady, and everybody who knew her before could recognize her. So 'Umar bin Al-Khattab saw her and said, "O Sauda! By Allah, you cannot hide yourself from us, so think of a way by which you should not be recognized on going out. Sauda returned while Allah's Apostle was in my house taking his supper and a bone covered with meat was in his hand. She entered and said, "O Allah's Apostle! I went out to answer the call of nature and 'Umar said to me so-and-so." Then Allah inspired him (the Prophet) and when the state of inspiration was over and the bone was still in his hand as he had not put in down, he said (to Sauda), "You (women) have been allowed to go out for your needs."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.319]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 319

Narrated 'Aisha:

Aflah, the brother of Abi Al-Quais, asked permission to visit me after the order of Al-Hijab was revealed. I said, "I will not permit him unless I take permission of the Prophet about him for it was not the brother of Abi Al-Qu'ais but the wife of Abi Al-Qu'ais that nursed me." The Prophet entered upon me, and I said to him, "O Allah's Apostle! Allah, the brother of Abi Al-Qu'ais asked permission to visit me but I refused to permit him unless I took your permission." The Prophet said, "What stopped you from permitting him? He is your uncle." I said, "O Allah's Apostle! The man was not the person who had nursed me, but the woman, the wife of Abi Al-Qu'ais had nursed me." He said, "Admit him, for he is your uncle. Taribat Yaminuki (may your right hand be saved)" 'Urwa, the sub-narrator added: For that 'Aisha used to say, "Consider those things which are illegal because of blood relations as illegal because of the corresponding foster relations."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.320]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 320

Narrated Ka'b bin Ujra:

It was said, "O Allah's Apostle! We know how to greet you, but how to invoke Allah for you?" The Prophet said, "Say: Allahumma salli ala Muhammadin wa'ala Ali Muhammaddin, kama sallaita 'ala all Ibrahim, innaka Hamidun Majid."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.321]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 321

Narrated Abu Said Al-Khudri:

We said, "O Allah's Apostle! (We know) this greeting (to you) but how shall we invoke Allah for you?" He said, "Say! Allahumma salli ala Muhammadin 'Abdika wa rasulika kama- sallaita 'ala all Ibrahim wa barik ala Muhammadin wa'ala all Muhammadin kama barakta 'ala all Ibrahim.' Al-Laith said: 'Ala Muhammadin wa 'ala all Muhammadin kama barakta ala all Ibrahim.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.322]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 322

Narrated Ibn Abi Hazim and Ad-Darawardi:

Yazid said, "Kama sallaita ala Ibrahima wa barik 'ala Muhammad in wa all Muhammadin kama barakta 'ala Abrahima wa all Ibrahim."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.323]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 323

Narrated Abu Huraira:

Allah's Apostle said, "Moses was a shy man, and that is what the Statement of Allah means:

'O you who believe Be not like those who annoyed Moses, but Allah proved his innocence of that which they alleged and he was honorable in Allah's Sight.' (33.69)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.324]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 324

Narrated Abu Huraira:

Allah's Prophet said, "When Allah decrees some order in the heaven, the angels flutter their wings indicating complete surrender to His saying which sounds like chains being dragged on rock. And when the state of fear disappears, they ask each other, "What has your Lord ordered? They say that He has said that which is true and just, and He is the Most High, the Most Great." (34.23). Then the stealthy listeners (devils) hear this order, and these stealthy listeners are like this, one over the other." (Sufyan, a sub-narrator demonstrated that by holding his hand upright and separating the fingers.) A stealthy listener hears a word which he will convey to that which is below him and the second will convey it to that which is below him till the last of them will convey it to the wizard or foreteller. Sometimes a flame (fire) may strike the devil before he can convey it, and sometimes he may convey it before the flame (fire) strikes him, whereupon the wizard adds to that word a hundred lies. The people will then say, 'Didn't he (i.e. magician) tell such-and-such a thing on such-and-such date?' So that magician is said to have told the truth because of the Statement which has been heard from the heavens."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.325]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 325

Narrated Ibn Abbas:

One day the Prophet ascended Safa mountain and said, "Oh Sabah! " All the Quraish gathered round him and said, "What is the matter?" He said, Look, if I told you that an enemy is going to attack you in the morning or in the evening, would you not believe me?" They said, "Yes, we will believe you." He said, "I am a warner to you in face of a terrible punishment." On that Abu Lahab said, "May you perish ! Is it for this thing that you have gathered us?" So Allah revealed:

'Perish the hands of Abu Lahab!...' (111.1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.326]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 326

Narrated Abu Dharr:

Once I was with the Prophet in the mosque at the time of sunset. The Prophet said, "O Abu Dharr! Do you know where the sun sets?" I replied, "Allah and His Apostle know best." He said, "It goes and prostrates underneath (Allah's) Throne; and that is Allah's Statement:--

'And the sun runs on its fixed course for a term (decreed). And that is the decree of All-Mighty, the All-Knowing....' (36.38)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.327]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 327

Narrated Abu Dharr:

I asked the Prophet about the Statement of Allah:--

'And the sun runs on fixed course for a term (decreed), ' (36.38) He said, "Its course is underneath "Allah's Throne." (Prostration of Sun trees, stars. mentioned in Qur'an and Hadith does not mean like our prostration but it means that these objects are obedient to their Creator (Allah) and they obey for what they have been created for).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.328]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 328

Narrated Abdullah:

Allah's Apostle said, "Nobody has the right to be better than (Jonah) bin Matta."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.329]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 329

Narrated Abu Huraira:

The Prophet said, "He who says that I am better than Jonah bin Matta, tells a lie.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.330]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 330

Narrated Al-Awwam:

I asked Muhajid regarding the prostration in Surat Sad. He said, "Ibn Abbas was asked the same question and he said, 'Those are they (the prophets) whom Allah had Guided. So follow their guidance." (6.90) Ibn 'Abbas used to perform a prostration (on reading this Sura).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.331]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 331

Narrated Al-Awwam:

I asked Mujahid regarding the prostration in Surat Sad. He said, "I asked Ibn 'Abbas, 'What evidence makes you prostrate?' He said, "Don't you recite:--'And among his progeny, David and Solomon..(6.84). Those are they whom Allah had guided. So follow their guidance.' (6.90) So David was the one of those prophets whom Prophet (Muhammad) was ordered to follow. David prostrated, so Allah's Apostle (Muhammad) performed this prostration too.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.332]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 332

Narrated Abu Huraira:

The Prophet said, "Last night a demon from the Jinns came to me (or the Prophet said, a similar sentence) to disturb my prayer, but Allah gave me the power to overcome him. I intended to tie him to one of the pillars of the mosque till the morning so that all of you could see him, but then I remembered the Statement of my brother Solomon:--'My Lord! Forgive me and bestow on me a kingdom such as shall not belong to any other after me.' (38.35) The narrator added: Then he (the Prophet) dismissed him, rejected. 'Nor am I one of the pretenders (a person who pretends things which do not exist).' (38.86)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.333]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 333

Narrated Masruq:

We came upon 'Abdullah bin Mas'ud and he said "O people! If somebody knows something, he can say it, but if he does not know it, he should say, "Allah knows better,' for it is a sign of having knowledge to say about something which one does not know, 'Allah knows better.' Allah said to His Prophet: 'Say (O Muhammad ! ) No wage do I ask of You for this (Quran) nor am I one of the pretenders (a person who pretends things which do not exist).' (38.86) Now I will tell you about Ad-Dukhan (the smoke), Allah's Apostle invited the Quraish to embrace Islam, but they delayed their response. So he said, "O Allah! Help me against them by sending on them seven years of famine similar to the seven years of famine of Joseph." So the famine year overtook them and everything was destroyed till they ate dead animals and skins. People started imagining to see smoke between them and the sky because of severe hunger. Allah said:

'Then watch you for the Day that the sky will bring forth a kind of smoke plainly visible, covering the people. . . This is painful torment.' (44.10-11) (So they invoked Allah) "Our Lord! Remove the punishment from us really we are believers." How can there be an (effectual) reminder for them when an Apostle, explaining things clearly, has already come to them? Then they had turned away from him and said: 'One taught (by a human being), a madman?' 'We shall indeed remove punishment for a while, but truly, you will revert (to disbelief).' (44.12-15) Will the punishment be removed on the Day of Resurrection?" 'Abdullah added, "The punishment was removed from them for a while but they reverted to disbelief, so Allah destroyed them on the Day of Badr. Allah said:

'The day We shall seize you with a mighty grasp. We will indeed (then) exact retribution." (44.16)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.334]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 334

Narrated Ibn Abbas:

Some pagans who committed murders in great number and committed illegal sexual intercourse excessively, came to Muhammad and said, "O Muhammad! Whatever you say and invite people to, is good: but we wish if you could inform us whether we can make an expiration for our (past evil) deeds." So the Divine Verses came: 'Those who invoke not with Allah any other god, not kill such life as Allah has forbidden except for just cause, nor commit illegal sexual intercourse.' (25.68) And there was also revealed:-- 'Say: O My slaves who have transgressed against their souls! Despair not of the Mercy of Allah.' (39.53)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.335]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 335

Narrated 'Abdullah:

A (Jewish) Rabbi came to Allah's Apostle and he said, "O Muhammad! We learn that Allah will put all the heavens on one finger, and the earths on one finger, and the trees on one finger, and the water and the dust on one finger, and all the other created beings on one finger. Then He will say, 'I am the King.' Thereupon the Prophet smiled so that his pre-molar teeth became visible, and that was the confirmation of the Rabbi. Then Allah's Apostle recited:

'No just estimate have they made of Allah such as due to Him.' (39.67)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.336]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 336

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Allah will hold the whole earth, and roll all the heavens up in His Right Hand, and then He will say, 'I am the King; where are the kings of the earth?"'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.337]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 337

Narrated Abu Huraira:

The Prophet said, "I will be the first to raise my head after the second blowing of the trumpet and will see Moses hanging the Throne, and I will not know whether he had been in that state all the time or after the blowing of the trumpet."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.338]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 338

Narrated Abu Huraira:

The Prophet said, "Between the two blowing of the trumpet there will be forty." The people said, "O Abu Huraira! Forty days?" I refused to reply. They said, "Forty years?" I refused to reply and added: Everything of the human body will decay except the coccyx bone (of the tail) and from that bone Allah will reconstruct the whole body.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.339]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 339

Narrated Urwa bin Az-Zubair:

I asked 'Abdullah bin 'Amr bin Al-'As to inform me of the worst thing the pagans had done to Allah's Apostle. He said: "While Allah's Apostle was praying in the courtyard of the ka'ba, 'Uqba bin Abi Mu'ait came and seized Allah's Apostle by the shoulder and twisted his garment round his neck and throttled him severely. Abu Bakr came and seized 'Uqba's shoulder and threw him away from Allah's Apostle and said, "Would you kill a man because he says: 'My Lord is Allah,' and has come to you with clear Signs from your Lord?" (40.28)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.340]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 340

Narrated Ibn Mas'ud:

(regarding) the Verse: 'And you have not been screening against yourself lest your ears, and your eyes and your skins should testify against you..' (41.22) While two persons from Quraish and their brother-in-law from Thaqif (or two persons from Thaqif and their brother-in-law from Quraish) were in a house, they said to each other, "Do you think that Allah hears our talks?" Some said, "He hears a portion thereof" Others said, "If He can hear a portion of it, He can hear all of it." Then the following Verse was revealed:

'And you have not been screening against yourself lest your ears, and your eyes and your skins should testify against you...' (41.22)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.341]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 341

Narrated 'Abdullah:

There gathered near the House (i.e. the Ka'ba) two Quraishi persons and a person from Thaqif (or two persons from Thaqif and one from Quraish), and all of them with very fat bellies but very little intelligence. One of them said, "Do you think that Allah hears what we say?" Another said, "He hears us when we talk in a loud voice, but He doesn't hear us when we talk in a low tone." The third said, "If He can hear when we talk in a loud tone, then He can also hear when we speak in a low tone." Then Allah, the Honorable, the Majestic revealed:

'And you have not been screening against yourself lest your ears, and eyes and your skins should testify against you....' (41.22-23)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.342]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 342

Narrated 'Abdullah bin Mas'ud:

(As above, Hadith No. 341).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.343]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 343

Narrated Ibn Abbas:

That he was asked (regarding):

"Except to be kind to me for my Kinship with you.' (42.23) Said bin Zubair (who was present then) said, "It means here (to show what is due for) the relatives of Muhammad." On that Ibn Abbas said: you have hurried in giving the answer! There was no branch of the tribe of Quraish but the Prophet had relatives therein. The Prophet said, "I do not want anything from (you ) except to be Kind to me for my Kinship with you."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.344]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 344

Narrated Ya'la:

I heard the Prophet reciting when on the pulpit: 'They will cry, "O Malik (Keeper of Hell) Let your Lord make an end of us.' (43.77)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.345]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 345

Narrated Abdullah:

Five things have passed, i.e. the smoke, the defeat of the Romans, the splitting of the moon, Al-Batsha (the defeat of the infidels in the battle of Badr) and Al-Lizam (the punishment)'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.346]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 346

Narrated 'Abdullah:

It (i.e., the imagined smoke) was because, when the Quraish refused to obey the Prophet, he asked Allah to afflict them with years of famine similar to those of (Prophet) Joseph. So they were stricken with famine and fatigue, so much so that they ate even bones. A man would look towards the sky and imagine seeing something like smoke between him and the sky because of extreme fatigue. So Allah revealed:--

'Then watch you for the Day that the sky will bring forth a kind of smoke plainly visible, covering the people; this is a painfull of torment.' (44.10-11)

Then someone (Abu Sufyan) came to Allah's Apostle and said, "O Allah's Apostle! Invoke Allah to send rain for the tribes of Mudar for they are on the verge of destruction." On that the Prophet said (astonishingly) "Shall I invoke Allah) for the tribes of Mudar? Verily, you are a brave man!" But the Prophet prayed for rain and it rained for them. Then the Verse was revealed.

'But truly you will return (to disbelief).' (44.15) (When the famine was over and) they restored prosperity and welfare, they reverted to their ways (of heathenism) whereupon Allah revealed:

'On the Day when We shall seize you with a Mighty Grasp. We will indeed (then) exact retribution.' (44.16) The narrator said, "That was the day of the Battle of Badr."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.347]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 347

Narrated Abdullah:

It is a sign of having knowledge that, when you do not know something, you say: 'Allah knows better.' Allah said to his Prophet:

'Say: No wage do I ask of you for this (Qur'an), nor am I one of the pretenders (a person who pretends things which do not exist)' (38.86) When the Quraish troubled and stood against the Prophet he said, "O Allah! Help me against them by afflicting them with seven years of famine like the seven years of Joseph." So they were stricken with a year of famine during which they ate bones and dead animals because of too much suffering, and one of them would see something like smoke between him and the sky because of hunger. Then they said: Our Lord! Remove the torment from us, really we are believers. (44.12) And then it was said to the Prophet (by Allah), "If we remove it from them. they will revert to their ways (of heathenism)." So the Prophet invoked his Lord, who removed the punishment from them, but later they reverted (to heathenism), whereupon Allah punished them on the day of the Battle of Badr, and that is what Allah's Statement indicates:

'Then watch for the day that the sky will bring forth a kind of smoke plainly visible...we will indeed (then) exact retribution.' (44.10).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.348]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 348

Narrated Masruq:

I came upon 'Abdullah and he said, "When Allah's Apostle invited Quraish (to Islam), they disbelieved him and stood against him. So he (the Prophet) said, "O Allah! Help me against them by afflicting them with seven years of famine similar to the seven years of Joseph.' So they were stricken with a year of drought that destroyed everything, and they started eating dead animals, and if one of them got up he would see something like smoke between him and the sky from the severe fatigue and hunger." Abdullah then recited:--

'Then watch you for the Day that the sky will bring forth a kind of smoke plainly visible, covering the people. This is a painful torment... (till he reached) ........ We shall indeed remove the punishment for a while, but truly you will revert (to heathenism): (44.10-15) 'Abdullah added: "Will the punishment be removed from them on the Day of Resurrection?" He added," The severe grasp" was the Day of the Battle of Badr."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.349]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 349

Narrated Abdullah:

Allah sent (the Prophet) Muhammad and said:--

'Say, No wage do I ask of you for this (Qur'an) nor am I one of the pretenders (i.e. a person who pretends things which do not exist). (38.68) When Allah's Apostle saw Quraish standing against him, he said, "O Allah! Help me against them by afflicting them with seven years of famine similar to the seven years (of famine) of Joseph. So they were afflicted with a year of drought that destroyed everything, and they ate bones and hides. (One of them said), "And they ate hides and dead animals, and (it seemed to them that) something like smoke was coming out of the earth. So Abu Sufyan came to the Prophet and said, "O Muhammad! Your people are on the verge of destruction! Please invoke Allah to relieve them." So the Prophet invoked Allah for them (and the famine disappeared). He said to them. "You will revert (to heathenism) after that." 'Abdullah then recited:

'Then watch you for the Day that the sky will bring forth a kind of smoke plainly visible.......but truly you will revert (to disbelief).' He added, "Will the punishment be removed from them in the Hereafter? The smoke and the grasp and the Al-Lizam have all passed." One of the sub-narrater said, "The splitting of the moon." And another said, "The defeat of the Romans (has passed)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.350]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 350

Narrated 'Abdullah:

Five things have passed: Al-Lizam, the defeat of the Romans, the mighty grasp, the splitting of the moon, and the smoke.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.351]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 351

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'The son of Adam hurts me for he abuses Time though I am Time: in My Hands are all things, and I cause the revolution of day and night.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.352]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 352

Narrated Yusuf bin Mahak:

Marwan had been appointed as the governor of Hijaz by Muawiya. He delivered a sermon and mentioned Yazid bin Muawiya so that the people might take the oath of allegiance to him as the successor of his father (Muawiya). Then 'Abdur Rahman bin Abu Bakr told him something whereupon Marwan ordered that he be arrested. But 'Abdur-Rahman entered 'Aisha's house and they could not arrest him. Marwan said, "It is he ('AbdurRahman) about whom Allah revealed this Verse:--

'And the one who says to his parents: 'Fie on you! Do you hold out the promise to me..?'"

On that, 'Aisha said from behind a screen, "Allah did not reveal anything from the Qur'an about us except what was connected with the declaration of my innocence (of the slander)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.353]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 353

Narrated 'Aisha:

(the wife of the Prophet), I never saw Allah's Apostle laughing loudly enough to enable me to see his uvula, but he used to smile only. And whenever he saw clouds or winds, signs of deep concern would appear on his face. I said, "O Allah's Apostle! When people see clouds they usually feel happy, hoping that it would rain, while I see that when you see clouds, one could notice signs of dissatisfaction on your face." He said, "O 'Aisha! What is the guarantee for me that there will be no punishment in it, since some people were punished with a wind? Verily, some people saw (received) the punishment, but (while seeing the cloud) they said, 'This cloud will give us rain.' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.354]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 354

Narrated Abu Huraira:

The Prophet said, "Allah created His creation, and when He had finished it, the womb, got up and caught hold of Allah whereupon Allah said, "What is the matter?' On that, it said, 'I seek refuge with you from those who sever the ties of Kith and kin.' On that Allah said, 'Will you be satisfied if I bestow My favors on him who keeps your ties, and withhold My favors from him who severs your ties?' On that it said, 'Yes, O my Lord!' Then Allah said, 'That is for you.' " Abu Huraira added: If you wish, you can recite: "Would you then if you were given the authority. do mischief in the land and sever your ties of kinship. (47. 22)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.355]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 355

Narrated Abu Huraira:

(As above, No. 354, but added) Then Allah's Apostle said, "Recite if you wish: "Would you then." ..(47.22)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.356]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 356

Narrated Muawiya bin Abi Al-Muzarrad:

Allah's Apostle, said, "Recite if you wish: Would you then if you were given the authority." (47.22)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.357]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 357

Narrated Aslam:

While Allah's Apostle was proceeding at night during one of his journeys and 'Umar bin Al-Khattab was traveling beside him, 'Umar asked him about something but Allah's Apostle did not reply. He asked again, but he did not reply, and then he asked (for the third time) but he did not reply. On that, 'Umar bin Al-Khattab said to himself, "Thakilat Ummu 'Umar (May 'Umar's mother lose her son)! I asked Allah's Apostle three times but he did not reply." 'Umar then said, "I made my camel run faster and went ahead of the people, and I was afraid that some Qur'anic Verses might be revealed about me. But before getting involved in any other matter. I heard somebody calling me. I said to myself, 'I fear that some Qur'anic Verses have been revealed about me,' and so I went to Allah's Apostle and greeted him.

He (Allah's Apostle ) said, 'Tonight a Sura has been revealed to me, and it is dearer to me than that on which the sun rises (i.e. the world)' Then he recited: "Verily, We have given you a manifest victory." (48.1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.358]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 358

Narrated Anas:

"Verily, We have given you (O Muhammad) a manifest victory.' refers to Al-Hudaibiya Peace treaty).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.359]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 359

Narrated 'Abdullah bin Mughaffal:

On the Day of the Conquest of Mecca, the Prophet recited Surat Al-Fath in a vibrating and pleasant voice. (Muawaiya, the subnarrator said, "If I could imitate the recitation of the Prophet I would do so.")


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.360]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 360

Narrated Al-Mughira:

The Prophet used to offer night prayers till his feet became swollen. Somebody said, to him," "Allah has forgiven you, your faults of the past and those to follow." On that, he said, "Shouldn't I be a thankful slave of Allah)?"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.361]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 361

Narrated Aisha:

The Prophet used to offer prayer at night (for such a long time) that his feet used to crack. I said, "O Allah's Apostle! Why do you do it since Allah has forgiven you your faults of the past and those to follow?" He said, "Shouldn't I love to be a thankful slave (of Allah)?' When he became old, he prayed while sitting, but if he wanted to perform a bowing, he wound get up, recite (some other verses) and then perform the bowing.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.362]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 362

Narrated Abdullah bin Amr bin Al-As:

This Verse:

'Verily We have sent you (O Muhammad) as a witness, as a bringer of glad tidings and as a warner.' (48.8)

Which is in the Qur'an, appears in the Surah thus: 'Verily We have sent you (O Muhammad) as a witness, as a bringer of glad tidings and as a warner, and as a protector for the illiterates (i.e., the Arabs.) You are my slave and My Apostle, and I have named you Al-Mutawakkil (one who depends upon Allah). You are neither hard-hearted nor of fierce character, nor one who shouts in the markets. You do not return evil for evil, but excuse and forgive. Allah will not take you unto Him till He guides through you a crocked (curved) nation on the right path by causing them to say: "None has the right to be worshipped but Allah." With such a statement He will cause to open blind eyes, deaf ears and hardened hearts.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.363]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 363

Narrated Al-Bara:

While a man from the companions of the Prophet was reciting (Quran) and his horse was tied in the house, the horse got startled and started jumping. The man came out, looked around but could not find anything, yet the horse went on jumping. The next morning he mentioned that to the Prophet.

The Prophet said, "That was the tranquility (calmness) which descended because of the recitation of the Quran."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.364]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 364

Narrated Jabir:

We were one thousand and four hundred on the Day of Al-Hudaibiya.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.365]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 365

Narrated 'Uqba bin Sahban:

'Abdullah bin Mughaffal Al-Muzani who was one of those who witnessed (the event of) the tree, said, "The Prophet forbade the throwing of small stones (with two fingers)." 'Abdullah bin Al-Mughaffal Al-Muzani also said, "The Prophet also forbade urinating at the place where one takes a bath."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.366]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 366

Narrated Thabit bin Ad-Dahhak:

who was one of the companions of the tree (those who swore allegiance to the Prophet beneath the tree at Al-Hudaibiya):


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.367]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 367

Narrated Habib bin Abi Thabit:

I went to Abu Wail to ask him (about those who had rebelled against 'Ali). On that Abu Wail said, "We were at Siffin (a city on the bank of the Euphrates, the place where me battle took place between 'Ali and Muawiya) A man said, "Will you be on the side of those who are called to consult Allah's Book (to settle the dispute)?" 'Ali said, 'Yes (I agree that we should settle the matter in the light of the Qur'an)." ' Some people objected to 'Ali's agreement and wanted to fight. On that Sahl bin Hunaif said, 'Blame yourselves! I remember how, on the day of Al-Hudaibiya (i.e. the peace treaty between the Prophet and the Quraish pagans), if we had been allowed to choose fighting, we would have fought (the pagans). At that time 'Umar came (to the Prophet) and said, "Aren't we on the right (path) and they (pagans) in the wrong? Won't our killed persons go to Paradise, and theirs in the Fire?" The Prophet replied, "Yes." Umar further said, "Then why should we let our religion be degraded and return before Allah has settled the matter between us?" The Prophet said, "O the son of Al-Khattab! No doubt, I am Allah's Apostle and Allah will never neglect me." So Umar left the place angrily and he was so impatient that he went to Abu Bakr and said, "O Abu Bakr! Aren't we on the right (path) and they (pagans) on the wrong?" Abu Bakr said, "O the son of Al-Khattab! He is Allah's Apostle, and Allah will never neglect him." Then Sura Al-Fath (The Victory) was revealed."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.368]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 368

Narrated Ibn Abi Mulaika:

The two righteous persons were about to be ruined. They were Abu Bakr and 'Umar who raised their voices in the presence of the Prophet when a mission from Bani Tamim came to him. One of the two recommended Al-Aqra' bin Habeas, the brother of Bani Mujashi (to be their governor) while the other recommended somebody else. (Nafi', the sub-narrator said, I do not remember his name). Abu Bakr said to Umar, "You wanted nothing but to oppose me!" 'Umar said, "I did not intend to oppose you." Their voices grew loud in that argument, so Allah revealed:

'O you who believe! Raise not your voices above the voice of the Prophet.' (49.2) Ibn Az-Zubair said, "Since the revelation of this Verse, 'Umar used to speak in such a low tone that the Prophet had to ask him to repeat his statements." But Ibn Az-Zubair did not mention the same about his (maternal) grandfather (i.e. Abu Bakr).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.369]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 369

Narrated Anas bin Malik:

The Prophet missed Thabit bin Qais for a period (So he inquired about him). A man said. "O Allah's Apostle! I will bring you his news." So he went to Thabit and found him sitting in his house and bowing his head. The man said to Thabit, " 'What is the matter with you?" Thabit replied that it was an evil affair, for he used to raise his voice above the voice of the Prophet and so all his good deeds had been annulled, and he considered himself as one of the people of the Fire. Then the man returned to the Prophet and told him that Thabit had said, so-and-so. (Musa bin Anas) said: The man returned to Thabit with great glad tidings. The Prophet said to the man. "Go back to him and say to him: "You are not from the people of the Hell Fire, but from the people of Paradise."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.370]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 370

Narrated Abdullah bin Az-Zubair:

A group of Bani Tamim came to the Prophet (and requested him to appoint a governor for them). Abu Bakr said, "Appoint Al-Qaqa bin Mabad." Umar said, "Appoint Al-Aqra' bin Habeas." On that Abu Bakr said (to 'Umar). "You did not want but to oppose me!" 'Umar replied "I did not intend to oppose you!" So both of them argued till their voices grew loud. So the following Verse was revealed:

'O you who believe! Be not for ward......' (49.1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.371]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 371

Narrated Anas:

The Prophet said, "The people will be thrown into the (Hell) Fire and it will say: "Are there any more (to come)?' (50.30) till Allah puts His Foot over it and it will say, 'Qati! Qati! (Enough Enough!)'"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.372]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 372

Narrated Abu Huraira:

(that the Prophet said) "It will be said to the Hell, 'Are you filled?' It will say, 'Are there any more (to come)?' On that Allah will put His Foot on it, and it will say 'Qati! Qati! (Enough! Enough!)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.373]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 373

Narrated Abu Huraira:

The Prophet said, "Paradise and the Fire (Hell) argued, and the Fire (Hell) said, "I have been given the privilege of receiving the arrogant and the tyrants.' Paradise said, 'What is the matter with me? Why do only the weak and the humble among the people enter me?' On that, Allah said to Paradise. 'You are My Mercy which I bestow on whoever I wish of my servants.' Then Allah said to the (Hell) Fire, 'You are my (means of) punishment by which I punish whoever I wish of my slaves. And each of you will have its fill.' As for the Fire (Hell), it will not be filled till Allah puts His Foot over it whereupon it will say, 'Qati! Qati!' At that time it will be filled, and its different parts will come closer to each other; and Allah will not wrong any of His created beings. As regards Paradise, Allah will create a new creation to fill it with."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.374]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 374

Narrated Jarir bin Abdullah:

We were in the company of the Prophet on a fourteenth night (of the lunar month), and he looked at the (full) moon and said, "You will see your Lord as you see this moon, and you will have no trouble in looking at Him. So, whoever can, should not miss the offering of prayers before sunrise (Fajr prayer) and before sunset (Asr prayer)." Then the Prophet recited:

'And celebrate the praises of your Lord before the rising of the sun and before (its) setting.' (50.39)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.375]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 375

Narrated Mujahid:

Ibn Abbas said, "Allah ordered His Prophet to celebrate Allah's praises after all prayers." He refers to His Statement: 'After the prayers.' (50.40)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.376]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 376

Narrated Um Salama:

I complained to Allah's Apostle that I was sick, so he said, "Perform the Tawaf (of Ka'ba at Mecca) while riding behind the people (who are performing the Tawaf on foot)." So I performed the Tawaf while Allah's Apostle was offering the prayer by the side of the Ka'ba and was reciting: 'By the Mount (Saini) and by a Decree Inscribed.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.377]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 377

Narrated Jubair bin Mut'im:

I heard the Prophet reciting Surat At-Tur in the Maghrib prayer, and when he reached the Verse:

'Were they created by nothing, Or were they themselves the creators, Or did they create the Heavens and the Earth? Nay, but they have no firm belief Or do they own the treasures of Your Lord? Or have they been given the authority to do as they like...' (52.35-37) my heart was about to fly (when I realized this firm argument).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.378]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 378

Narrated Masruq:

I said to 'Aisha, "O Mother! Did Prophet Muhammad see his Lord?" Aisha said, "What you have said makes my hair stand on end ! Know that if somebody tells you one of the following three things, he is a liar: Whoever tells you that Muhammad saw his Lord, is a liar." Then Aisha recited the Verse:

'No vision can grasp Him, but His grasp is over all vision. He is the Most Courteous Well-Acquainted with all things.' (6.103) 'It is not fitting for a human being that Allah should speak to him except by inspiration or from behind a veil.' (42.51) 'Aisha further said, "And whoever tells you that the Prophet knows what is going to happen tomorrow, is a liar." She then recited:

'No soul can know what it will earn tomorrow.' (31.34) She added: "And whoever tell you that he concealed (some of Allah's orders), is a liar." Then she recited: 'O Apostle! Proclaim (the Message) which has been sent down to you from your Lord..' (5.67) 'Aisha added. "But the Prophet saw Gabriel in his true form twice."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.379]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 379

Narrated Abdullah:

Regarding the Verses: 'And was at a distance of but two bow-lengths or (even) nearer; So did (Allah) convey the Inspiration to His slave (Gabriel) and then he Gabriel) conveyed (that to Muhammad...' (53.9-10) Ibn Mas'ud narrated to us that the Prophet had seen Gabriel with six hundred wings.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.380]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 380

Narrated ASSAILANT:

I asked Sir about the Statement of Allah:

'And was at a distance of but two bow-lengths or (even) nearer. So did Allah convey the Inspiration to His slave (Gabriel) and then he (Gabriel) conveyed that to Muhammad.' (53.10) He said, "Abdullah (bin Mas'ud) informed us that Muhammad had seen Gabriel with six hundred wings."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.381]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 381

Narrated Abdullah:

(regarding the revelation) Truly he (Muhammad) did see of the signs of his Lord; the Greatest!' (53.18) The Prophet saw a green screen covering the horizon.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.382]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 382

Narrated Ibn Abbas:

(regarding His Statement about the Lat and the Uzza: Lat was originally a man who used to mix Sawiq for the pilgrim.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.383]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 383

Narrated Abu Huraira:

Allah's Apostle said, "Whomever takes an oath in which he mentions Lat and 'Uzza (forgetfully), should say: None has the right to be worshipped but Allah, and whoever says to his companion. 'Come along, let us gamble must give alms (as an expiation)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.384]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 384

Narrated 'Urwa:

I asked 'Aisha (regarding the Sai between As Safa and Al-Marwa). She said, "Out of reverence to the idol Manat which was placed in Al-Mushailal, those who used to assume Ihram in its name, used not to perform Sai between As-Safa and Al-Marwa, so Allah revealed:

'Verily! The As-Safa and Al-Marwa (two mountains at Mecca) are among the symbols of Allah.' (2.158).

Thereupon, Allah's Apostle and the Muslims used to perform Sai (between them)." Sufyan said: The (idol) Manat was at Al-Mushailal in Qudaid. 'Aisha added, "The Verse was revealed in connection with the Ansar. They and (the tribe of) Ghassan used to assume lhram in the name of Manat before they embraced Islam." 'Aisha added, "There were men from the Ansar who used to assume lhram in the name of Manat which was an idol between Mecca and Medina. They said, "O Allah's Apostle! We used not to perform the Tawaf (Sai) between As-Safa and Al-Marwa out of reverence to Manat."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.385]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 385

Narrated Ibn Abbas:

The Prophet performed a prostration when he finished reciting Surat-an-Najm, and all the Muslims and pagans and Jinns and human beings prostrated along with him.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.386]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 386

Narrated Abdullah:

The first Sura in which a prostration was mentioned, was Sura An-Najm (The Star). Allah's Apostle prostrated (while reciting it), and everybody behind him prostrated except a man whom I saw taking a hand-full of dust in his hand and prostrated on it. Later I saw that man killed as an infidel, and he was Umaiya bin Khalaf.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.387]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 387

Narrated Ibn Masud:

During the lifetime of Allah's Apostle the moon was split into two parts; one part remained over the mountain, and the other part went beyond the mountain. On that, Allah's Apostle said, "Witness this miracle."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.388]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 388

Narrated Abdullah:

The moon was cleft asunder while we were in the company of the Prophet, and it became two parts. The Prophet said, Witness, witness (this miracle)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.389]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 389

Narrated Ibn Abbas:

The moon was cleft asunder during the lifetime of the Prophet


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.390]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 390

Narrated Anas:

The people of Mecca asked the Prophet to show them a sign (miracle). So he showed them (the miracle) of the cleaving of the moon.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.391]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 391

Narrated Anas:

The moon was cleft asunder into two parts.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.392]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 392

Narrated Abdullah bin Masud:


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.393]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 393

Narrated Abdullah:

The Prophet used to recite: 'Is there any that remember? And a furious wind (plucking out men) as if they were uprooted stems of palm trees, then how terrible was My punishment and My warnings!' (54.20-21)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.394]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 394

Narrated Abu Ishaq:

A man asked Al-Aswad, 'is it 'Fahal min-Muddakir' or'..Mudhdhakir?" Al Aswad replied, 'I have heard Abdullah bin Masud reciting it, 'Fahal-min Muddakir'; I too, heard the Prophet reciting it 'Fahal-min-Muddakir' with 'd'.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.395]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 395

Narrated Abdullah:

The Prophet recited: 'Fahal-min-Muddakir' "And Verily an abiding torment seized them early in the morning So, taste you My torment and My warnings' (54.38-39)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.396]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 396

Narrated Abdullah:

The Prophet recited: 'Fahal-min Muddakir': 'And verily, We have destroyed nations like unto you; then is there any that will receive admonition?' (54.51)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.397]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 397

Narrated Abdullah:

I recited before the Prophet 'Fahal-min-Mudhdhakir'. The Prophet said, "It is Fahal-min Muddakir."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.398]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 398

Narrated Abbas:

Allah's Apostle while in a tent on the day of the Battle of Badr, said, "O Allah! I request you (to fulfill) Your promise and contract! O Allah! If You wish that you will not be worshipped henceforth.." On that Abu Bakr held the Prophet by the hand and said, "That is enough, O Allah's Apostle You have appealed to your Lord too pressingly," while the Prophet was putting on his armor. So Allah's Apostle went out, reciting Their multitude will be put to flight, and they will show their backs.' (54.45)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.399]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 399

Narrated Yusuf bin Mahik:

I was in the house of 'Aisha, the mother of the Believers. She said, "This revelation: "Nay, but the Hour is their appointed time (for their full recompense); and the Hour will be more previous and most bitter." (54.46) was revealed to Muhammad at Mecca while I was a playfull little girl."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.400]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 400

Narrated Ibn Abbas:

While in his tent on the day the Battle of Badr, the Prophet said, "O Allah! I request You (to fulfill) Your promise and contract. O Allah! It You wish that the Believers be destroyed). You will never be worshipped henceforth." On that, Abu Bakr held the Prophet by the hand and said, "That is enough, O Allah's Apostle! You have appealed to your Lord too pressingly" The Prophet was wearing his armor and then went out reciting:

'Their multitude will be put to flight and they will show their backs. Nay, but the Hour is their appointed time (for their full recompense), and the Hour will be more previous and most bitter.' (54.45-46)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.401]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 401

Narrated Abdullah bin Qais:

Allah's Apostle said, "Two gardens, the utensils and the contents of which are of silver, and two other gardens, the utensils and contents of which are of gold. And nothing will prevent the people who will be in the Garden of Eden from seeing their Lord except the curtain of Majesty over His Face."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.402]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 402

Narrated Abdullah bin Qais:

Allah's Apostle said, "In Paradise there is a pavilion made of a single hollow pearl sixty miles wide, in each corner of which there are wives who will not see those in the other corners; and the believers will visit and enjoy them. And there are two gardens, the utensils and contents of which are made of silver; and two other gardens, the utensils and contents of which are made of so-and-so (i.e. gold) and nothing will prevent the people staying in the Garden of Eden from seeing their Lord except the curtain of Majesty over His Face."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.403]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 403

Narrated Abu Huraira:

The Prophet said, "In Paradise there is a tree which is so big that a rider can travel in its shade for one hundred years without passing it; and if you wish, you can recite:


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.404]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 404

Narrated Said bin Jubair:

I asked Ibn Abbas about Surat Al-Tauba, and he said, "Surat Al-Tauba? It is exposure (of all the evils of the infidels and the hypocrites). And it continued revealing (that the oft-repeated expression): '...and of them ...and of them.' till they started thinking that none would be left unmentioned therein." I said, "What about) Surat Al-Anfal?" He replied, "Surat Al-Anfal was revealed in connection with the Badr Battle." I said, "(What about) Surat Al-Hashr?" He replied, "It was revealed in connection with Bani an-Nadir."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.405]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 405

Narrated Said:

I asked Ibn 'Abbas about Surat Al-Hashr. He replied, "Say Surat An-Nadir."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.406]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 406

Narrated Ibn Umar:

'Allah's Apostle burnt and cut down the palm trees of Bani An-Nadir which were at Al-Buwair (a place near Medina). There upon Allah revealed:

'What you (O Muslims) cut down of the palm trees (of the enemy) or you left them standing on their stems, it was by the leave of Allah, so that He might cover with shame the rebellious.' (59.5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.407]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 407

Narrated Umar:

The properties of Bam An-Nadir were among the booty that Allah gave to His Apostle such Booty were not obtained by any expedition on the part of Muslims, neither with cavalry, nor with camelry. So those properties were for Allah's Apostle only, and he used to provide thereof the yearly expenditure for his wives, and dedicate the rest of its revenues for purchasing arms and horses as war material to be used in Allah's Cause.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.408]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 408

Narrated Alqama:

'Abdullah (bin Masud) said. "Allah curses those ladies who practice tattooing and those who get themselves tattooed, and those ladies who remove the hair from their faces and those who make artificial spaces between their teeth in order to look more beautiful whereby they change Allah's creation." His saying reached a lady from Bani Asd called Um Yaqub who came (to Abdullah) and said, "I have come to know that you have cursed such-and-such (ladies)?" He replied, "Why should I not curse these whom Allah's Apostle has cursed and who are (cursed) in Allah's Book!" Um Yaqub said, "I have read the whole Quran, but I did not find in it what you say." He said, "Verily, if you have read it (i.e. the Quran), you have found it. Didn't you read:

'And whatsoever the Apostle gives you take it and whatsoever he forbids you, you abstain (from it). (59.7)

She replied, "Yes, I did," He said, "Verily, Allah's Apostle forbade such things." "She said, "But I see your wife doing these things?" He said, "Go and watch her." She went and watched her but could not see anything in support of her statement. On that he said, "If my wife was as you thought, I would not keep her in my company."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.409]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 409

Narrated Abdullah (bin Mus'ud):

Allah's Apostle has cursed the lady who uses false hair.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.410]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 410

Narrated 'Umar:

I recommend that my successor should take care of and secure the rights of the early emigrants; and I also advise my successor to be kind to the Ansar who had homes (in Medina) and had adopted the Faith, before the Prophet migrated to them, and to accept the good from their good ones and excuse their wrong doers.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.411]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 411

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "O Allah's Apostle! I am suffering from fatigue and hunger." The Prophet sent (somebody) to his wives (to get something), but the messenger found nothing with them. Then Allah's Apostle said (to his companions). "Isn't there anybody who can entertain this man tonight so that Allah may be merciful to him?" An Ansari man got up and said, "I (will, entertain him), O Allah's Apostle!" So he went to his wife and said to her, "This is the guest of Allah's Apostle, so do not keep anything away from him." She said. "By Allah, I have nothing but the children's food." He said, "When the children ask for their dinner, put them to bed and put out the light; we shall not take our meals tonight," She did so. In the morning the Ansari man went to Allah's Apostle who said, "Allah was pleased with (or He bestowed His Mercy) on so-and-so and his wife (because of their good deed)." Then Allah revealed:

'But give them preference over themselves even though they were in need of that.' (59.9)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.412]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 412

Narrated Ali:

Allah's Apostle sent me along with AzZubair and Al-Miqdad and said, "Proceed till you reach a place called Raudat-Khakh where there is a lady travelling in a howda on a camel. She has a letter. Take the letter from her." So we set out, and our horses ran at full pace till we reached Raudat Khakh, and behold, we saw the lady and said (to her), "Take out the letter!" She said, "I have no letter with me." We said, "Either you take out the letter or we will strip you of your clothes." So she took the letter out of her hair braid. We brought the letter to the Prophet and behold, it was addressed by Hatib bin Abi Balta'a to some pagans at Mecca, informing them of some of the affairs of the Prophet. The Prophet said, "What is this, O Hatib?" Hatib replied, "Do not be hasty with me, O Allah's Apostle! I am an Ansari man and do not belong to them (Quraish infidels) while the emigrants who were with you had their relatives who used to protect their families and properties at Mecca. So, to compensate for not having blood relation with them.' I intended to do them some favor so that they might protect my relatives (at Mecca), and I did not do this out of disbelief or an inclination to desert my religion." The Prophet then said (to his companions), "He (Hatib) has told you the truth." 'Umar said, "O Allah's Apostle! Allow me to chop his head off?" The Apostle said, "He is one of those who witnessed (fought in) the Battle of Badr, and what do you know, perhaps Allah looked upon the people of Badr (Badr warriors) and said, 'Do what you want as I have forgiven you.' " (Amr, a sub-narrator, said,: This Verse was revealed about him (Hatib):

'O you who believe! Take not My enemies and your enemies as friends or protectors.' (60.1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.413]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 413

Narrated 'Ali:

Sufyan was asked whether (the Verse): 'Take not My enemies and your enemies...'

was revealed in connection with Hatib. Sufyan replied, "This occurs only in the narration of the people. I memorized the Hadith from 'Amr, not overlooking even a single letter thereof, and I do not know of anybody who remembered it by heart other than myself."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.414]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 414

Narrated Urwa:

Aisha the wife of the Prophet, said, "Allah's Apostle used to examine the believing women who migrated to him in accordance with this Verse: 'O Prophet! When believing women come to you to take the oath of allegiance to you... Verily! Allah is Oft-Forgiving Most Merciful.' (60.12) 'Aisha said, "And if any of the believing women accepted the condition (assigned in the above-mentioned Verse), Allah's Apostle would say to her. "I have accepted your pledge of allegiance." "He would only say that, for, by Allah, his hand never touched, any lady during that pledge of allegiance. He did not receive their pledge except by saying, "I have accepted your pledge of allegiance for that."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.415]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 415

Narrated Um Atiya:

We took the oath of allegiance to Allah's Apostle and he recited to us:

'They will not associate anything in worship with Allah,' and forbade us to bewail the dead. Thereupon a lady withdrew her hand (refrained from taking the oath of allegiance), and said, "But such-and-such lady lamented over one of my relatives, so I must reward (do the same over the dead relatives of) hers." The Prophet did not object to that, so she went (there) and returned to the Prophet so he accepted her pledge of allegiance.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.416]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 416

Narrated Ibn Abbas:

Regarding the saying of Allah:

'And they will not disobey you in any just matter.' (60.12) That was one of the conditions which Allah imposed on The believing) women (who came to take the oath of allegiance to the Prophet)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.417]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 417

Narrated 'Ubada bin As-Samit:

While we were with the Prophet, he said, "Will you swear to me the pledge of allegiance that you will not worship any thing besides Allah, will not commit illegal sexual intercourse, and will not steal?" Then he recited the Verse concerning the women. (Sufyan, the subnarrator, often said that the Prophet: added, "Whoever among you fulfills his pledge, will receive his reward from Allah, and whoever commits any of those sins and receives the legal punishment (in this life), his punishment will be an expiation for that sin; and whoever commits any of those sins and Allah screens him, then it is up to Allah to punish or forgive them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.418]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 418

Narrated Ibn Abbas:

I witnessed the 'Id-al-Fitr prayer with Allah's Apostle , Abu Bakr, 'Umar and 'Uthman; and all of them offered it before delivering the sermon... and then delivered the sermon. Once the Prophet (after completing the prayer and the sermon) came down, as if I am now looking at him waving at the men with his hand to sit down, and walked through them till he, along with Bilal, reached (the rows of) the women. Then he recited: 'O Prophet! When believing women come to you to take the oath of allegiance that they will not worship anything other than Allah, will not steal, will not commit illegal sexual intercourse, will not kill their children, and will not utter slander, intentionally forging falsehood (by making illegal children belonging to their husbands)'....(60.12) Having finished, he said, 'Do you agree to that?" One lady, other than whom none replied the Prophet said, "Yes, O Allah's Apostle!" (The, sub-narrator, Al-Hasan did not know who the lady was.) Then the Prophet said to them: "Will you give alms?" Thereupon Bilal spread out his garment and the women started throwing big


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.419]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 419

Narrated Jubair bin Mutim:

I heard Allah's Apostle saying, 'I have several names: I am Muhammad and I am Ahmad, and I am Al-Mahi with whom Allah obliterates Kufr (disbelief), and I am Al-Hashir (gatherer) at whose feet (i.e. behind whom) the people will be gathered (on the Day of Resurrection), and I am Al-Aqib (i.e. who succeeds the other prophets in bringing about good)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.420]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 420

Narrated Abu Huraira:

While we were sitting with the Prophet Surat Al-Jumu'a was revealed to him, and when the Verse, "And He (Allah) has sent him (Muhammad) also to other (Muslims).....' (62.3) was recited by the Prophet, I said, "Who are they, O Allah's Apostle?" The Prophet did not reply till I repeated my question thrice. At that time, Salman Al-Farisi was with us. So Allah's Apostle put his hand on Salman, saying, "If Faith were at (the place of) Ath-Thuraiya (pleiades, the highest star), even then (some men or man from these people (i.e. Salman's folk) would attain it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.421]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 421

Narrated Abu Huraira:

The Prophet said. Then some men from these people would attain it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.422]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 422

Narrated Jabir bin Abdullah:

A caravan of merchandise arrived at Medina on a Friday while we were with the Prophet All the people left (the Prophet and headed for the caravan) except twelve persons. Then Allah revealed:--

'But when they see some bargain or some amusement they disperse headlong to it.' ..(62.11)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.423]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 423

Narrated Zaid bin Arqam:

While I was taking part in a Ghazwa. I heard 'Abdullah bin Ubai (bin Abi Salul) saying. "Don't spend on those who are with Allah's Apostle, that they may disperse and go away from him. If we return (to Medina), surely, the more honorable will expel the meaner amongst them." I reported that (saying) to my uncle or to 'Umar who, in his turn, informed the Prophet of it. The Prophet called me and I narrated to him the whole story. Then Allah's Apostle sent for 'Abdullah bin Ubai and his companions, and they took an oath that they did not say that. So Allah's Apostle disbelieved my saying and believed his. I was distressed as I never was before. I stayed at home and my uncle said to me. "You just wanted Allah's Apostle to disbelieve your statement and hate you." So Allah revealed (the Sura beginning with) 'When the hypocrites come to you.' (63.1) The Prophet then sent for me and recited it and said, "O Zaid! Allah confirmed your statement."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.424]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 424

Narrated Zaid bin Arqam:

I was with my uncle and I heard 'Abdullah bin Ubai bin Salul, saying, "Don't spend on those who are with Allah's Apostle that they may disperse and go away from him." He also said, "If we return to Medina, surely, the more honorable will expel the meaner." So I informed my uncle of that and then my uncle informed Allah's Apostle thereof. Allah's Apostle sent for 'Abdullah bin Ubai and his companions. They swore that they did not say anything of that sort Allah's Apostle deemed their statement true and rejected mine. Thereof I became as distressed as I have never been before, and stayed at home. Then Allah revealed (Surat Al-Munafiqin):

'When the hypocrites come to you.....(63.1) They are the ones who say: Spend nothing on those who are with Allah's Apostle ..(63.7) Verily the more honorable will expel therefrom the meaner..' (63.7-8)

Allah's Apostle sent for me and recited that Sura for me and said, "Allah has confirmed your statement." 'That is because they believed, then disbelieved, so a seal was set on their hearts, therefore they understand not.' (63.3)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.425]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 425

Narrated Zaid bin Arqam:

When 'Abdullah bin Ubai said, "Do not spend on those who are with Allah's Apostle," and also said, "If we return to Medina," I informed the Prophet of his saying. The Ansar blamed me for that, and 'Abdullah bin Ubai swore that he did not say. I returned to my house and slept. Allah's Apostle then called me and I went to him. He said, "Allah has confirmed your statement." The Verse: "They are the one who say: Spend nothing......(63.7) was revealed.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.426]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 426

Narrated Zaid bin Arqam:

We went out with the Prophet : on a journey and the people suffered from lack of provisions. So 'Abdullah bin Ubai said to his companions, "Don't spend on those who are with Allah's Apostle, that they may disperse and go away from him." He also said, "If we return to Medina, surely, the more honorable will expel therefrom the meaner. So I went to the Prophet and informed him of that. He sent for 'Abdullah bin Ubai and asked him, but 'Abdullah bin Ubai swore that he did not say so. The people said, "Zaid told a lie to 'Allah's Apostle." What they said distressed me very much. Later Allah revealed the confirmation of my statement in his saying:--

'(When the hypocrites come to you.' (63.1) So the Prophet called them that they might ask Allah to forgive them, but they turned their heads aside. (Concerning Allah's saying: 'Pieces of wood propped up,' Zaid said; They were the most handsome men.)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.427]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 427

Narrated Zaid bin Arqam:

While I was with my uncle, I heard 'Abdullah bin Ubai bin Salul saying, "Do not spend on those who are with Allah's Apostle, that they may disperse and go away (from him). And if we return to Medina, surely, the more honorable will expel therefrom the meaner. "I mentioned that to my uncle who, in turn, mentioned it to the Prophet. The Prophet called me and I told him about that. Then he sent for 'Abdullah bin Ubai and his companions, and they swore that they did not say so. The Prophet disbelieved my statement and believed theirs. I was distressed as I have never been before, and I remained in my house. My uncle said to me, "You just wanted the Prophet to consider you a liar and hate you." Then Allah revealed:--

'When the hypocrites come to you, they say: 'We bear witness that you are indeed the Apostle of Allah." (63.1) So the Prophet sent for me and recited it and said, "Allah has confirmed your statement."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.428]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 428

Narrated Jabir bin 'Abdullah:

We were in a Ghazwa (Sufyan once said, in an army) and a man from the emigrants kicked an Ansari man (on the buttocks with his foot). The Ansari man said, "O the Ansar! (Help!)" and the emigrant said. "O the emigrants! (Help!) Allah's Apostle heard that and said, "What is this call for, which is characteristic of the period of ignorance?" They said, "O Allah's Apostle! A man from the emigrants kicked one of the Ansar (on the buttocks with his foot)." Allah's Apostle said, "Leave it (that call) as is a detestable thing." 'Abdullah bin Ubai heard that and said, 'Have the (the emigrants) done so? By Allah, if we return Medina, surely, the more honorable will expel therefrom the meaner." When this statement reached the Prophet. 'Umar got up an, said, "O Allah's Apostle! Let me chop off the head of this hypocrite ('Abdullah bin Ubai)!" The Prophet said "Leave him, lest the people say that Muhammad kills his companions." The Ansar were then more in number than the emigrants when the latter came to Medina, but later on the emigrant increased.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.429]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 429

Narrated Musa bin 'Uqba:

'Abdullah bin Al-Fadl told me that Anas bin Malik said, "I was much grieve over those who had been killed in the Battle of Al-Harra. When Zaid bin Arqarr heard of my intense grief (over the killed Ansar), he wrote a letter to me saying that he heard Allah's Apostle saying, O Allah! Forgive the Ansar and the Ansar children. The subnarrator, Ibn Al-Fadl, is not sure whether the Prophet also said, And their grand-children." Some of those who were present, asked Anas (about Zaid). He said, "He (Zaid) is the one about whom Allah's Apostle said, 'He is the one whose sound hearing Allah testified.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.430]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 430

Narrated Jabir bin Abdullah:

We were in a Ghazwa and a man from the emigrants kicked an Ansari (on the buttocks with his foot). The Ansari man said, "O the Ansari! (Help!)" The emigrant said, "O the emigrants! (Help)." When Allah's Apostle heard that, he said, "What is that?" They said, "A man from the emigrants kicked a man from the Ansar (on the buttocks his foot). On that the Ansar said, 'O the Ansar!' and the emigrant said, 'O the emigrants!" The Prophet said' "Leave it (that call) for it Is a detestable thing." The number of Ansar was larger (than that of the emigrants) at the time when the Prophet came to Medina, but later the number of emigrants increased. 'Abdullah bin Ubai said, "Have they, (the emigrants) done so? By Allah, if we return to Medina, surely, the more honorable will expel therefrom the meaner," 'Umar bin Al-Khattab said, "O Allah's Apostle! Let me chop off the head of this hypocrite!" The Prophet said, "Leave him, lest the people say Muhammad kills his companions:"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.431]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 431

Narrated Salim:

That Abdullah bin Umar told him that he had divorced his wife while she was in her menses so 'Umar informed Allah's Apostle

of that. Allah's Apostle became very angry at that and said, "(Ibn 'Umar must return her to his house and keep her as his wife till she becomes clean and then menstruates and becomes clean again, whereupon, if he wishes to divorce her, he may do so while she is still clean and before having any sexual relations with her, for that is the legally prescribed period for divorce as Allah has ordered."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.432]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 432

Narrated Abu Salama:

A man came to Ibn 'Abbas while Abu Huraira was sitting with him and said, "Give me your verdict regarding a lady who delivered a baby forty days after the death of her husband." Ibn 'Abbas said, "This indicates the end of one of the two prescribed periods." I said "For those who are pregnant, their prescribed period is until they deliver their burdens." Abu Huraira said, I agree with my cousin (Abu Salama)." Then Ibn 'Abbas sent his slave, Kuraib to Um Salama to ask her (regarding this matter). She replied. "The husband of Subai 'a al Aslamiya was killed while she was pregnant, and she delivered a baby forty days after his death. Then her hand was asked in marriage and Allah's Apostle married her (to somebody). Abu As-Sanabil was one of those who asked for her hand in marriage".


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.433]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 433

Narrated Ibn 'Abbas:

If someone says to his wife, "You are unlawful to me." he must make an expiation (for his oath). Ibn 'Abbas added: There is for you in Allah's Apostle, an excellent example to follow.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.434]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 434

Narrated 'Aisha:

Allah's Apostle used to drink honey in the house of Zainab, the daughter of Jahsh, and would stay there with her. So Hafsa and I agreed secretly that, if he come to either of us, she would say to him. "It seems you have eaten Maghafir (a kind of bad-smelling resin), for I smell in you the smell of Maghafir," (We did so) and he replied. "No, but I was drinking honey in the house of Zainab, the daughter of Jahsh, and I shall never take it again. I have taken an oath as to that, and you should not tell anybody about it."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.435]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 435

Narrated Ibn Abbas:

For the whole year I had the desire to ask 'Umar bin Al-Khattab regarding the explanation of a Verse (in Surat Al-Tahrim) but I could not ask him because I respected him very much. When he went to perform the Hajj, I too went along with him. On our return, while we were still on the way home. 'Umar went aside to answer the call of nature by the Arak trees. I waited till he finished and then I proceeded with him and asked him. "O chief of the Believers! Who were the two wives of the Prophet who aided one another against him?" He said, "They were Hafsa and 'Aisha." Then I said to him, "By Allah, I wanted to ask you about this a year ago, but I could not do so owing to my respect for you." 'Umar said, "Do not refrain from asking me. If you think that I have knowledge (about a certain matter), ask me; and if I know (something about it), I will tell you." Then Umar added, "By Allah, in the Pre-lslamic Period of Ignorance we did not pay attention to women until Allah revealed regarding them what He revealed regarding them and assigned for them what He has assigned. Once while I was thinking over a certain matter, my wife said, "I recommend that you do so-and-so." I said to her, "What have you got to do with the is matter? Why do you poke your nose in a matter which I want to see fulfilled.?" She said, How strange you are, O son of Al-Khattab! You don't want to be argued with whereas your daughter, Hafsa surely, argues with Allah's Apostle so much that he remains angry for a full day!" 'Umar then reported; how he at once put on his outer garment and went to Hafsa and said to her, "O my daughter! Do you argue with Allah's Apostle so that he remains angry the whole day?" H. afsa said, "By Allah, we argue with him." 'Umar said, "Know that I warn you of Allah's punishment and the anger of Allah's Apostle . . . O my daughter! Don't be betrayed by the one who is proud of her beauty because of the love of Allah's Apostle for her (i.e. 'Aisha)." 'Umar addled, "Then I went out to Um Salama's house who was one of my relatives, and I talked to her. She said, O son of Al-Khattab! It is rather astonishing that you interfere in everything; you even want to interfere between Allah's Apostle and his wives!' By Allah, by her talk she influenced me so much that I lost some of my anger. I left her (and went home). At that time I had a friend from the Ansar who used to bring news (from the Prophet) in case of my absence, and I used to bring him the news if he was absent. In those days we were afraid of one of the kings of Ghassan tribe. We heard that he intended to move and attack us, so fear filled our hearts because of that. (One day) my Ansari friend unexpectedly knocked at my door, and said, "Open Open!' I said, 'Has the king of Ghassan come?' He said, 'No, but something worse; Allah's Apostle has isolated himself from his wives.' I said, 'Let the nose of 'Aisha and Hafsa be stuck to dust (i.e. humiliated)!' Then I put on my clothes and went to Allah's Apostle's residence, and behold, he was staying in an upper room of his to which he ascended by a ladder, and a black slave of Allah's Apostle was (sitting) on the first step. I said to him, 'Say (to the Prophet ) 'Umar bin Al-Khattab is here.' Then the Prophet admitted me and I narrated the story to Allah's Apostle. When I reached the story of Um Salama, Allah's Apostle smiled while he was lying on a mat made of palm tree leaves with nothing between him and the mat. Underneath his head there was a leather pillow stuffed with palm fibres, and leaves of a saut tree were piled at his feet, and above his head hung a few water skins. On seeing the marks of the mat imprinted on his side, I wept. He said.' 'Why are you weeping?' I replied, "O Allah's Apostle! Caesar and Khosrau are leading the life (i.e. Luxurious life) while you, Allah's Apostle though you are, is living in destitute". The Prophet then replied. 'Won't you be satisfied that they enjoy this world and we the Hereafter?' "


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.436]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 436

Narrated Ibn Abbas:

I intended to ask 'Umar so I said, "Who were those two ladies who tried to back each other against the Prophet?" I hardly finished my speech when he said, They were 'Aisha and Hafsa."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.437]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 437

Narrated Ibn Abbas:

I intended to ask 'Umar about those two ladies who back each other against 'Allah's Apostle . For one year I was seeking the opportunity to ask this question, but in vain, until once when I accompanied him for Hajj. While we were in Zahran, 'Umar went to answer the call of nature and told me to follow him with some water for ablution. So I followed him with a container of water and started pouring water for him. I found it a good opportunity to ask him, so I said, "O chief of the Believers! Who were those two ladies who had backed each other (against the Prophet)?" Before I could complete my question, he replied, "They were 'Aisha and Hafsa."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.438]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 438

Narrated 'Umar:

The wives of the Prophet out of their jealousy, backed each other against the Prophet, so I said to them, "It may be, if he divorced you all, that Allah will give him, instead of you wives better than you." So this Verse was revealed. (66.5)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.439]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 439

Narrated Ibn Abbas:

(regarding the Verse):-- 'Cruel after all that, base-born (of illegitimate birth).' (68.13) It was revealed in connection with a man from Quaraish who had a notable sign (Zanamah) similar to the notable sign which usually-hung on the neck of a sheep (to recognize it).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.440]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 440

Narrated Haritha bin Wahb Al-Khuzai:

I heard the Prophet saying. "May I tell you of the people of Paradise? Every weak and poor obscure person whom the people look down upon but his oath is fulfilled by Allah when he takes an oath to do something. And may I inform you of the people of the Hell-Fire? They are all those violent, arrogant and stubborn people."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.441]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 441

Narrated Abu Said:

I heard the Prophet saying, "Allah will bring forth the severest Hour, and then all the Believers, men and women, will prostrate themselves before Him, but there will remain those who used to prostrate in the world for showing off and for gaining good reputation. Such people will try to prostrate (on the Day of Judgment) but their back swill be as stiff as if it is one bone (a single vertebra)."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.442]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 442

Narrated Ibn Abbas:

All the idols which were worshipped by the people of Noah were worshipped by the Arabs later on. As for the idol Wadd, it was worshipped by the tribe of Kalb at Daumat-al-Jandal; Suwa' was the idol of (the tribe of) Murad and then by Ban, Ghutaif at Al-Jurf near Saba; Yauq was the idol of Hamdan, and Nasr was the idol of Himyr, the branch of Dhi-al-Kala.' The names (of the idols) formerly belonged to some pious men of the people of Noah, and when they died Satan inspired their people to (prepare and place idols at the places where they used to sit, and to call those idols by their names. The people did so, but the idols were not worshipped till those people (who initiated them) had died and the origin of the idols had become obscure, whereupon people began worshipping them.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.443]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 443

Narrated Ibn Abbas:

Allah's Apostle went out along with a group of his companions towards 'Ukaz Market. At that time something intervened between the devils and the news of the Heaven, and flames were sent down upon them, so the devils returned. Their fellow-devils said, "What is wrong with you? " They said, "Something has intervened between us and the news of the Heaven, and fires (flames) have been shot at us." Their fellow-devils said, "Nothing has intervened between you and the news of the Heaven, but an important event has happened. Therefore, travel all over the world, east and west, and try to find out what has happened." And so they set out and travelled all over the world, east and west, looking for that thing which intervened between them and the news of the Heaven. Those of the devils who had set out towards Tihama, went to Allah's Apostle at Nakhla (a place between Mecca and Taif) while he was on his way to Ukaz Market. (They met him) while he was offering the Fajr prayer with his companions. When they heard the Holy Qur'an being recited (by Allah's Apostle), they listened to it and said (to each other). This is the thing which has intervened between you and the news of the Heavens." Then they returned to their people and said, "O our people! We have really heard a wonderful recital (Qur'an). It gives guidance to the right, and we have believed therein. We shall not join in worship, anybody with our Lord." (See 72.1-2) Then Allah revealed to His Prophet (Surat al-Jinn):

'Say: It has been revealed to me that a group (3 to 9) of Jinns listened (to the Qur'an).' (72.1) The statement of the Jinns was revealed to him .


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.444]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 444

Narrated Yahya bin Abi Kathir:

I asked Aba Salama bin 'Abdur-Rahman about the first Sura revealed of the Qur'an. He replied "O you, wrapped-up (i.e. Al Muddaththir)." I said, "They say it was, 'Read, in the Name of your Lord Who created,' (i.e. Surat Al-'Alaq (the Clot)." On that, Abu Salama said, "I asked Jabir bin 'Abdullah about that, saying the same as you have said, whereupon he said, 'I will not tell you except what Allah's Apostle had told us. Allah's Apostle said, "I was in seclusion in the cave of Hiram', and after I completed the limited period of my seclusion. I came down (from the cave) and heard a voice calling me. I looked to my right, but saw nothing. Then I looked up and saw something. So I went to Khadija (the Prophet's wife) and told her to wrap me up and pour cold water on me. So they wrapped me up and poured cold water on me." Then, 'O you, (Muhammad) wrapped up! Arise and warn,' (Surat Al Muddaththir) was revealed." (74.1)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.445]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 445

Narrated Jabir bin 'Abdullah:

The Prophet said, "I was in a seclusion in the cave of Hira........."(similar to the narration related by 'Ali bin Al-Mubarak, 444 above).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.446]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 446

Narrated Yahya: I asked Aba Salama, "Which Sura of the Qur'an was revealed first?" He replied, "O you, wrapped-up' (Al-Muddaththir)." I said, "I have been informed that it was, 'Read, in the Name of your Lord who created........ (i.e. Surat Al-Alaq).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.447]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 447

Narrated Jabir bin 'Abdullah:

I heard the Prophet describing the period of pause of the Divine Inspiration. He said in his talk, "While I was walking, I heard voices from the sky. I looked up, and behold ! I saw the same Angel who came to me in the cave of Hira' sitting on a chair between the sky and the earth. I was too much afraid of him (so I returned to my house) and said, 'Fold me up in garments!' They wrapped me up. Then Allah revealed: 'O you wrapped...and desert the idols before the prayer became compulsory.' Rujz means idols.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.448]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 448

Narrated Jabir bin 'Abdullah:

That he heard Allah's Apostle describing the period of pause of the Divine Inspiration, and in his description he said, "While I was walking I heard a voice from the sky. I looked up towards the sky, and behold! I saw the same Angel who came to me in the Cave of Hira', sitting on a chair between the sky and the earth. I was so terrified by him that I fell down on the ground. Then I went to my wife and said, 'Wrap me in garments! Wrap me in garments!' They wrapped me, and then Allah revealed:

"O you, (Muhammad) wrapped-up! Arise and warn...and desert the idols." (74.1-5) Abu Salama said....Rujz means idols." After that, the Divine Inspiration started coming more frequently and regularly.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.449]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 449

Narrated Ibn Abbas:

The Prophet used to move his tongue when the divine Inspiration was being revealed to him. (Sufyan, a subnarrator, demonstrated (how the Prophet used to move his lips) and added. "In order to memorize it." So Allah revealed: "Move not your tongue concerning (the Quran) to make haste therewith." (75.16)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.450]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 450

Narrated Musa bin Abi Aisha:

That he asked Said bin Jubair regarding (the statement of Allah). 'Move not your tongue concerning (the Quran) to make haste therewith.' He said, "Ibn 'Abbas said that the Prophet used to move his lips when the Divine Inspiration was being revealed to him. So the Prophet was ordered not to move his tongue, which he used to do, lest some words should escape his memory. 'It is for Us to collect it' means, We will collect it in your chest;' and its recitation' means, We will make you recite it. 'But when We recite it (i.e. when it is revealed to you), follow its recital; it is for Us to explain it and make it clear,' (i.e. We will explain it through your tongue).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.451]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 451

Narrated Ibn Abbas:

(as regards) Allah's Statement:

"Move not your tongue concerning (the Quran) to make haste therewith." (75.16)

When Gabriel revealed the Divine Inspiration in Allah's Apostle , he (Allah's Apostle) moved his tongue and lips, and that state used to be very hard for him, and that movement indicated that revelation was taking place. So Allah revealed in Surat Al-Qiyama which begins:

'I do swear by the Day of Resurrection...' (75) the Verses:--

'Move not your tongue concerning (the Quran) to make haste therewith. It is for Us to collect it (Quran) in your mind, and give you the ability to recite it by heart. (75.16-17) Ibn Abbas added: It is for Us to collect it (Qur'an) (in your mind), and give you the ability to recite it by heart means, "When We reveal it, listen. Then it is for Us to explain it," means, 'It is for us to explain it through your tongue.' So whenever Gabriel came to Allah's Apostle ' he would keep quiet (and listen), and when the Angel left, the Prophet would recite that revelation as Allah promised him.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.452]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 452

Narrated Abdullah:

We were with the Prophet when Surat Wal-Mursalat was revealed to him. While we were receiving it from his mouth, a snake suddenly came and we ran to kill it, but it outstripped us and entered its hole quickly. Allah's le said, "It has escaped your evil, and you too, have escaped its evil."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.453]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 453

Narrated Abdullah:

(Similarly--as no. 452 above.)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.454]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 454

Narrated Abdullah:

While we were with Allah's Apostle in a cave, Surat "Wal Mursalat" was revealed to him and we received it directly from his mouth as soon as he had received the revelation. Suddenly a snake came out and Allah's Apostle said, "Get at it and kill it!" We ran to kill it but it outstripped us. Allah's Apostle said, "It has escaped your evil, as you too, have escaped its."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.455]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 455

Narrated Ibn Abbas:

(as regards the explanation of Hadith 454). 'Indeed, it (Hell) throws about sparks (huge) as Forts.' We used to collect wood in the form of logs, three cubits long or shorter. for heating purposes in winter., and we used to call such wood, the Qasr.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.456]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 456

Narrated Abdullah:

While we were with the Prophet in a cave, Surat wal-Mursalat was revealed to him and he recited it, and I heard it directly from his mouth as soon as he recited its revelation. Suddenly a snake sprang at us, and the Prophet said, "Kill it!" We ran to kill it but it escaped quickly. The Prophet said. "It has escaped your evil, and you too have escaped its evil."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.457]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 457

Narrated Al--Amash:

Abu Huraira said, "Allah's Apostle said, 'Between the two sounds of the trumpet, there will be forty." Somebody asked Abu Huraira, "Forty days?" But he refused to reply. Then he asked, "Forty months?" He refused to reply. Then he asked, "Forty years?" Again, he refused to reply. Abu Huraira added. "Then (after this period) Allah will send water from the sky and then the dead bodies will grow like vegetation grows, There is nothing of the human body that does not decay except one bone; that is the little bone at the end of the coccyx of which the human body will be recreated on the Day of Resurrection." (See Hadith No. 338)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.458]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 458

Narrated Sahl bin Sad:

I saw Allah's Apostle pointing with his index and middle fingers, saying. "The time of my Advent and the Hour are like these two fingers." The Great Catastrophe will overwhelm everything.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.459]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 459

Narrated Aisha:

The Prophet said, "Such a person as recites the Quran and masters it by heart, will be with the noble righteous scribes (in Heaven). And such a person exerts himself to learn the Quran by heart, and recites it with great difficulty, will have a double reward."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.460]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 460

Narrated Abdullah bin Umar:

The Prophet said, "On the Day when all mankind will stand before the Lord of the Worlds, some of them will be enveloped in their sweat up to the middle of their ears."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.461]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 461

Narrated Aisha:

I heard the Prophet saying...


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.462]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 462

Narrated 'Aisha:

I heard the Prophet saying...


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.463]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 463

Narrated Aisha:

Allah's Apostle said," (On the Day of Resurrection) any one whose account will be taken will be ruined (i.e. go to Hell)." I said, "O Allah's Apostle! May Allah make me be sacrificed for you. Doesn't Allah say:

"Then as for him who will be given his record in his right hand, he surely will receive an easy reckoning.?" (84.7-8) He replied, "That is only the presentation of the accounts; but he whose record is questioned, will be ruined."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.464]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 464

Narrated Ibn Abbas:

(as regards the Verse):--'You shall surely travel from stage to stage (in this life and in the Hereafter).' (It means) from one state to another. That concerns your Prophet.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.465]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 465

Narrated Al-Bara:

The first of the companions of the Prophet who came to us (in Medina), were Mus'ab bin 'Umar and Ibn Um Maktum, and they started teaching us the Qur'an. Then came 'Ammar, Bilal and Sad. Afterwards 'Umar bin Al-Kkattab came along with a batch of twenty (men): and after that the Prophet came. I never saw the people of Medina so pleased with anything as they were with his arrival, so that even the little boys and girls were saying, "This is Allah's Apostle who has come." He (the Prophet ) did not come (to Medina) till I had learnt Surat Al-Ala and also other similar Suras.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.466]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 466

Narrated Abdullah bin Zama:

That he heard the Prophet delivering a sermon, and he mentioned the shecamel and the one who hamstrung it. Allah's Apostle recited:--

'When, the most wicked man among them went forth (to hamstrung the she-camel).' (91.12.) Then he said, "A tough man whose equal was rare and who enjoyed the protection of his people, like Abi Zama went forth to (hamstrung) it." The Prophet then mentioned about the women (in his sermon). "It is not wise for anyone of you to lash his wife like a slave, for he might sleep with her the same evening." Then he advised them not to laugh when somebody breaks wind and said, "Why should anybody laugh at what he himself does?"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.467]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 467

Narrated Alqama:

I went to Sham with a group of the companions of 'Abdullah (bin Mas'ud). Abu Ad-Darda' heard of our arrival so he came to us and said, "Is there anybody among you who can recite (Qur'an)" We replied in the affirmative. Then he asked, "Who is the best reciter?" They pointed at me. Then he told me to recite, so I recited the verse:--

'By the night as it envelops 'By the day as it appears in brightness; By (Him Who created) male and the female.' (92.1-3) Abu Ad-Darda' then said to me, "Did you hear it (like this) from the mouth of your friend ('Abdullah bin Mas'ud)?" I said, "Yes." He said, "I too, heard it (like this) from the mouth of the Prophet, but these people do not consider this recitation as the correct one."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.468]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 468

Narrated Ibrahim:

The companions of 'Abdullah (bin Mas'ud) came to Abu Darda', (and before they arrived at his home), he looked for them and found them. Then he asked them,: 'Who among you can recite (Qur'an) as 'Abdullah recites it?" They replied, "All of us." He asked, "Who among you knows it by heart?" They pointed at 'Alqama. Then he asked Alqama. "How did you hear 'Abdullah bin Mas'ud reciting Surat Al-Lail (The Night)?" Alqama recited:

'By the male and the female.' Abu Ad-Darda said, "I testify that I heard me Prophet reciting it likewise, but these people want me to recite it:--

'And by Him Who created male and female.' but by Allah, I will not follow them."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.469]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 469

Narrated 'Ali:

We were in the company of the Prophet in a funeral procession at Baqi Al-Gharqad. He said, "There is none of you but has his place written for him in Paradise or in the Hell- Fire." They said, "O Allah's Apostle! Shall we depend (on this fact and give up work)?" He said, "Carry on doing (good deeds), for every body will find it easy to do (what will lead him to his destined place)." Then he recited:

'As for him who gives (in charity) and keeps his duty to Allah, and believes in the Best reward from Allah (i.e. Allah will compensate him for what he will spend in Allah's way). So, We will make smooth for him the path of ease. But he who is a greedy miser....for him, the path for evil.' (92.5-10)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.470]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 470

Narrated Abu Abdur-Rahman:

'Ali said, "We were sitting with the Prophet," (He then mentioned the Hadith above (469).


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.471]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 471

Narrated 'Ali:

While the Prophet was in a funeral procession, he took a small stick and started scraping the earth with it and said, "There is none among you but has his place written for him, either in the Hell Fire or in Paradise." They (the people) said, "Allah's Apostle! Shall we depend on this (and leave work)?" He replied. "Carry on doing (good deeds), for everybody will find easy (to do) such deeds as will lead him to his destined place." The Prophet then recited:--

'As for him who gives (in charity) and keeps his duty to Allah, and believes in the Best Reward.'.....(92.5-10)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.472]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 472

Narrated Ali:

We were in the company of the Prophet and he said, "There is none among you but has his place written for him, either in Paradise or in the Hell-Fire." We said, "O Allah's Apostle! Shall we depend (on this fact and give up work)?" He replied, "No! Carry on doing good deeds, for everybody will find easy (to do) such deeds as will lead him to his destined place." Then the Prophet recited: 'As for him who gives (in charity) and keeps his duty to Allah, and believes in the Best reward. We will make smooth for him the path of ease....the path for evil.' (92.5-10)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.473]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 473

Narrated 'Ali:

While we were in a funeral procession in Baqi Al-Gharqad, Allah's Apostle came and sat down, and we sat around him. He had a small stick in his hand and he bent his head and started scraping the ground with it. He then said, "There is none among you, and no created soul but has his place written for him either in Paradise or in the Hell-Fire, and also has his happy or miserable fate (in the Hereafter) written for him." A man said, "O Allah's Apostle! Shall we depend upon what is written for us and give up doing (good) deeds? For whoever among us is destined to be fortunate (in the Hereafter), will join the fortunate peoples and whoever among us is destined to be miserable will do such deeds as are characteristic of the people who are destined to misery." The Prophet said, "Those who are destined to be happy (in the Hereafter) will find it easy and pleasant to do the deeds characteristic of those destined to happiness, while those who are to be among the miserable (in the Hereafter), will find it easy to do the deeds characteristic of those destined to misery." Then he recited: 'As for him who gives (in charity) and keeps his duty to Allah and believes in the Best reward from Allah, We will make smooth for him the path of ease. But he who is a greedy miser and thinks himself self sufficient, and gives the lie to the Best reward from Allah we will make smooth for him the path for evil.' (92.5-10)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.474]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 474

Narrated Ali:

While the Prophet was in a funeral procession. he picked up something and started scraping the ground with it, and said, "There is none among you but has his place written for him either in the Hell Fire or in Paradise." They said, "O Allah's Apostle! Shall we not depend upon what has been written for us and give up deeds? He said, "Carry on doing (good) deeds, for everybody will find easy to do such deeds as will lead him to his destined place for which he has been created. So he who is destined to be among the happy (in the Hereafter), will find it easy to do the deeds characteristic of such people, while he who is destined to be among the miserable ones, will find it easy to do the deeds characteristic of such people." Then he recited:

'As for him who gives (in charity) and fears Allah, and believes in the best....' (92.5-10)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.475]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 475

Narrated Jundub bin Sufyan:

Once Allah's Apostle became sick and could not offer his night prayer (Tahajjud) for two or three nights. Then a lady (the wife of Abu Lahab) came and said, "O Muhammad! I think that your Satan has forsaken you, for I have not seen him with you for two or three nights!" On that Allah revealed:

'By the fore-noon, and by the night when it darkens, your Lord (O Muhammad) has neither forsaken you, nor hated you.' (93.1-3)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.476]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 476

Narrated Jundub Al-Bajali:

A lady said, "O Allah's Apostle! I see that your friend has delayed. (in conveying Quran) to you." So there was revealed: 'Your Lord (O Muhammad) has neither forsaken you, not hated you.' (93.1-3)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.477]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 477

Narrated Al-Bara:

While the Prophet was on a journey, he recited Surat At-Tini waz-Zaituni (95) in one of the first two Rakat of the Isha prayer.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.478]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 478

Narrated Aisha:

(the wife of the Prophet) The commencement (of the Divine Inspiration) to Allah's Apostle was in the form of true dreams in his sleep, for he never had a dream but it turned out to be true and clear as the bright daylight. Then he began to like seclusions, so he used to go in seclusion in the cave of Hira where he used to worship Allah continuously for many nights before going back to his family to take the necessary provision (of food) for the stay. He come back to (his wife) Khadija again to take his provision (of food) likewise, till one day he received the Guidance while he was in the cave of Hira. An Angel came to him and asked him to read. Allah's Apostle replied, "I do not know how to read." The Prophet added, "Then the Angel held me (forcibly) and pressed me so hard that I felt distressed. Then he released me and again asked me to read, and I replied, 'I do not know how to read.' Thereupon he held me again and pressed me for the second time till I felt distressed. He then released me and asked me to read, but again I replied. 'I do not know how to read.' Thereupon he held me for the third time and pressed me till I got distressed, and then he released me and said, 'Read, in the Name of your Lord Who has created (all that exists), has created man out of a clot, Read! And your Lord is the Most Generous. Who has taught (the writing) by the pen, has taught man that which he knew not." (96.1-5).

Then Allah's Apostle returned with that experience; and the muscles between his neck and shoulders were trembling till he came upon Khadija (his wife) and said, "Cover me!" They covered him, and when the state of fear was over, he said to Khadija, "O Khadija! What is wrong with me? I was afraid that something bad might happen to me." Then he told her the story. Khadija said, "Nay! But receive the good tidings! By Allah, Allah will never disgrace you, for by Allah, you keep good relations with your Kith and kin, speak the truth, help the poor and the destitute, entertain your guests generously and assist those who are stricken with calamities." Khadija then took him to Waraqa bin Naufil, the son of Khadija's paternal uncle. Waraqa had been converted to Christianity in the Pre-lslamic Period and used to write Arabic and write of the Gospel in Arabic as much as Allah wished him to write. He was an old man and had lost his eyesight. Khadija said (to Waraqa), "O my cousin! Listen to what your nephew is going to say." Waraqa said, "O my nephew! What have you seen?" The Prophet then described whatever he had seen. Waraqa said, "This is the same Angel (Gabriel) who was sent to Moses. I wish I were young." He added some other statement. Allah's Apostle asked, "Will these people drive me out?" Waraqa said, "Yes, for nobody brought the like of what you have brought, but was treated with hostility. If I were to remain alive till your day (when you start preaching). then I would support you strongly." But a short while later Waraqa died and the Divine Inspiration was paused (stopped) for a while so that Allah's Apostle was very much grieved.

Narrated Jabir bin 'Abdullah: While Allah's Apostle was talking about the period of pause in revelation. he said in his narration. "Once while I was walking, all of a sudden I heard a voice from the sky. I looked up and saw to my surprise, the same Angel as had visited me in the cave of Hira.' He was sitting on a chair between the sky and the earth. I got afraid of him and came back home and said, Wrap me! Wrap me!" So they covered him and then Allah revealed:

'O you, wrapped up! Arise and warn and your Lord magnify, and your garments purify and dessert the idols.' (74.1-5)

Abu Salama said, "(Rijz) are the idols which the people of the Pre-lslamic period used to worship." After this the revelation started coming frequently and regularly.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.479]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 479

Narrated Aisha:

The commencement of the Divine Inspiration to Allah's Apostle was in the form of true dreams. The Angel came to him and said, "Read, in the Name of your Lord Who has created (all that exists), has created man a clot. Read! And your Lord is Most Generous" ..(96.1,2,3)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.480]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 480

Narrated 'Aisha:

The commencement of (the Divine Inspirations to) Allah's Apostle was in the form of true dreams. The Angel came to him and said, "Read! In the Name of your Lord Who has created all exists), has created man from a clot. Read! And your Lord is Most Generous, Who has taught (the writing) by the pen (the first person to write was Prophet Idris. (96.1-4)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.481]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 481

Narrated Aisha:

The Prophet returned to Khadija and said, "Wrap me! Wrap me!" (Then the sub-narrator narrated the rest of the narration.)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.482]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 482

Narrated Ibn Abbas:

Abu Jahl said, "If I see Muhammad praying at the Ka'ba, I will tread on his neck." When the Prophet heard of that, he said, "If he does so, the Angels will snatch him away."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.483]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 483

Narrated Anas bin Malik:

The Prophet said to Ubai (bin Ka'b). "Allah has ordered me to recite to you:--'Those who disbelieve among the people of the Scripture and among the idolators are not going to stop (from their disbelief.') (Sura 98) Ubai said, "Did Allah mention me by name?" The Prophet said, "Yes." On that, Ubai wept.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.484]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 484

Narrated Anas bin Malik:

The Prophet said to Ubai, "Allah has ordered me recite Quran to you." Ubai asked, "Did Allah mention me by name to you?" The Prophet said, "Allah has mentioned your name to me." On that Ubai started weeping. (The sub-narrator) Qatada added: I have been informed that the Prophet recited: 'Those who disbelieve among the people of the Scripture," ...to Ubai.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.485]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 485

Narrated Anas bin Malik:

Allah's Prophet said to Ubai bin Ka'b, "Allah has ordered me to recite Quran to you." Ubai said, "Did Allah mention me by name to you?" The Prophet said, "Yes." Ubai said, "Have I been mentioned by the Lord of the Worlds?" The Prophet said, "Yes." Then Ubai burst into tears.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.486]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 486

Narrated Abu Huraira:

Allah's Apostle said, " Horses are kept for one of three purposes: A man may keep them (for Allah's Cause) to receive a reward in the Hereafter; another may keep them as a means of protection; and a third may keep them to be a burden for him. As for the man for whom the horse is a source of reward, he is the one who ties it for Allah's Cause, and he ties it with a long rope in a pasture or a garden, then, whatever it eats or drinks in that pasture or garden will be added to his good deeds. And if it breaks its rope and jumps over one or two hills, then, for all its footsteps and its manure, good deeds will be written for him. And if it passes by a river and drinks of its water though its owner had no intention to water it from that river, even then he will have good deeds written for him. So that horse will be (a source of) reward for such a man.

If a man ties a horse for earning his livelihood and abstaining from asking others for help and he does not forget Allah's right, i.e. pays its Zakat and gives it to be used in Allah's Cause, then that horse will be a means of protection for him. But if a man ties it out of pride and to show off and to excite others, then that horse will be a burden (of sins) for him." Then Allah's Apostle was asked regarding donkeys. He replied, "Nothing has been revealed to me except this comprehensive Verse which includes everything:

'So whoever does good equal to the weight of an atom (or a smallest ant) shall see it; and whoever does evil equal to the weight of an atom (or a smallest ant) shall see it.' (99.7-8)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.487]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 487

Narrated Abu Huraira:

The Prophet was asked about donkeys and he replied, "Nothing has been revealed to me regarding donkeys except this comprehensive Verse which includes everything:

"So whoever does good equal to the weight of an atom (or a smallest ant) shall see it; And whoever, does evil equal to the weight of an atom or a smallest ant) shall see it.' (99.7-8)


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.488]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 488

Narrated Anas:

When the Prophet was made to ascend to the Heavens, he said (after his return), "I came upon a river the banks of which were made of tents of hollow pearls. I asked Gabriel. What is this (river?' He replied, 'This is the Kauthar.'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.489]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 489

Narrated Abu Ubaida:

I asked 'Aisha 'regarding the verse:--'Verily we have granted you the Kauthar.' She replied, "The Kauthar is a river which has been given to your Prophet on the banks of which there are (tents of) hollow pearls and its utensils are as numberless as the stars."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.490]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 490

Narrated Abu Bishr:

Said bin Jubair said that Ibn 'Abbas said about Al-Kauthar. "That is the good which Allah has bestowed upon His Apostle." I said to Sa'id bin Jubair. "But the people claim that it is a river in Paradise." Said said, "The river in Paradise is part of the good which Allah has bestowed on His Apostle."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.491]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 491

Narrated Aisha:

"When the "Surat-An-Nasr", 'When comes the Help of Allah and the conquest,' had been revealed to the Prophet he did not offer any prayer except that he said therein, "Subhanka Rabbana wa bihamdika; Allahumma ighfirli (I testify the Uniqueness of our Lord, and all the praises are for Him: O Allah, forgive me!")


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.492]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 492

Narrated Aisha:

Allah's Apostle used to say very often in bowing and prostration (during his prayers), Subhanka Allahumma Rabbana wa bihamdika; Allahumma ighfirli," according to the order of the Qur'an.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.493]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 493

Narrated Ibn Abbas:

'Umar asked the people regarding Allah's Statement:

'When comes the Help of Allah (to you O Muhammad against your enemies) and the conquest of Mecca.' (110.1) They replied, "It indicates the future conquest of towns and palaces (by Muslims)." 'Umar said, "What do you say about it, O Ibn 'Abbas?" I replied, "(This Surat) indicates the termination of the life of Muhammad. Through it he was informed of the nearness of his death."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.494]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 494

Narrated Ibn Abbas:

'Umar used to make me sit with the elderly men who had fought in the Battle of Badr. Some of them felt it (did not like that) and said to 'Umar "Why do you bring in this boy to sit with us while we have sons like him?" Umar replied, "Because of what you know of his position (i.e. his religious knowledge.)" One day 'Umar called me and made me sit in the gathering of those people; and I think that he called me just to show them. (my religious knowledge). 'Umar then asked them (in my presence). "What do you say about the interpretation of the Statement of Allah:

'When comes Help of Allah (to you O, Muhammad against your enemies) and the conquest (of Mecca).' (110.1) Some of them said, "We are ordered to praise Allah and ask for His forgiveness when Allah's Help and the conquest (of Mecca) comes to us." Some others kept quiet and did not say anything. On that, 'Umar asked me, "Do you say the same, O Ibn 'Abbas?" I replied, "No." He said, 'What do you say then?" I replied, "That is the sign of the death of Allah's Apostle which Allah informed him of. Allah said:--

'(O Muhammad) When comes the Help of Allah (to you against your enemies) and the conquest (of Mecca) (which is the sign of your death). You should celebrate the praises of your Lord and ask for His Forgiveness, and He is the One Who accepts the repentance and forgives.' (110.3) On that 'Umar said, "I do not know anything about it other than what you have said."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.495]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 495

Narrated Ibn Abbas:

When the Verse:-- 'And warn your tribe of near kindred.' (26.214) was revealed. Allah's Apostle went out, and when he had ascended As-Safa mountain, he shouted, "O Sabahah!" The people said, "Who is that?" "Then they gathered around him, whereupon he said, "Do you see? If I inform you that cavalrymen are proceeding up the side of this mountain, will you believe me?" They said, "We have never heard you telling a lie." Then he said, "I am a plain warner to you of a coming severe punishment." Abu Lahab said, "May you perish! You gathered us only for this reason? " Then Abu Lahab went away. So the "Surat:--ul--LAHAB" 'Perish the hands of Abu Lahab!' (111.1) was revealed.


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.496]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 496

Narrated Ibn Abbas:

The Prophet went out towards Al-Batha' and ascended the mountain and shouted, "O Sabahah!" So the Quraish people gathered around him. He said, "Do you see? If I tell you that an enemy is going to attack you in the morning or in the evening, will you believe me?" They replied, "Yes." He said, "Then I am a plain warner to you of a coming severe punishment." Abu Lahab said, "Is it for this reason that you have gathered us? May you perish ! " Then Allah revealed: 'Perish the hands of Abu Lahab!'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.497]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 497

Narrated Ibn Abbas:

Abu Lahab said, "May you perish! Is it' for this that you have gathered us?" So there was revealed:-- 'Parish the hands of Abu Lahab'


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.498]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 498

Narrated Abu Huraira:

The Prophet said, "Allah said: 'The son of Adam tells a lie against Me,, though he hasn't the right to do so. He abuses me though he hasn't the right to do so. As for his telling a lie against Me, it is his saying that I will not recreate him as I created him for the first time. In fact, the first creation was not easier for Me than new creation. As for his abusing Me, it is his saying that Allah has begotten children, while I am the One, the Self-Sufficient Master Whom all creatures need, I beget not, nor was I begotten, and there is none like unto Me."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.499]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 499

Narrated Abu Huraira:

Allah's Apostle said, "Allah said:-- 'The son of Adam tells a lie against Me and he hasn't the right to do so; and he abuses me and he hasn't the right to do so. His telling a lie against Me is his saying that I will not recreate him as I created him for the first time; and his abusing Me is his saying that Allah has begotten children, while I am the self-sufficient Master, Whom all creatures need, Who begets not nor was He begotten, and there is none like unto Me."


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.500]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 500

Narrated Zirr bin Hubaish:

I asked Ubai bin Ka'b regarding the two Muwwidhat (Surats of taking refuge with Allah). He said, "I asked the Prophet about them, He said, 'These two Surats have been recited to me and I have recited them (and are present in the Quran).' So, we say as Allah's Apostle said (i.e., they are part of the Quran"


Bukhari :: Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh)) :: [6.60.501]

Prophetic Commentary on the Qur'an (Tafseer of the Prophet (pbuh))

Bukhari :: Book 6 :: Volume 60 :: Hadith 501

Narrated Zirr bin Hubaish:

I asked Ubai bin Ka'b, "O Abu AlMundhir! Your brother, Ibn Mas'ud said so-and-so (i.e., the two Mu'awwidh-at do not belong to the Quran)." Ubai said, "I asked Allah's Apostle about them, and he said, 'They have been revealed to me, and I have recited them (as a part of the Quran)," So Ubai added, "So we say as Allah's Apostle has said."


Bukhari :: Virtues of the Qur'an :: [6.61.502]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 502

Narrated 'Aisha and Ibn 'Abbas:

The Prophet remained in Mecca for ten years, during which the Qur'an used to be revealed to him; and he stayed in Medina for ten years.


Bukhari :: Virtues of the Qur'an :: [6.61.503]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 503

Narrated Abu 'Uthman:

I was informed that Gabriel came to the Prophet while Um Salama was with him. Gabriel started talking (to the Prophet). Then the Prophet asked Um Salama, "Who is this?" She replied, "He is Dihya (al-Kalbi)." When Gabriel had left, Um Salama said, "By Allah, I did not take him for anybody other than him (i.e. Dihya) till I heard the sermon of the Prophet wherein he informed about the news of Gabriel." The subnarrator asked Abu 'Uthman: From whom have you heard that? Abu 'Uthman said: From Usama bin Zaid.


Bukhari :: Virtues of the Qur'an :: [6.61.504]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 504

Narrated Abu Huraira:

The Prophet said, "Every Prophet was given miracles because of which people believed, but what I have been given, is Divine Inspiration which Allah has revealed to me. So I hope that my followers will outnumber the followers of the other Prophets on the Day of Resurrection."


Bukhari :: Virtues of the Qur'an :: [6.61.505]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 505

Narrated Anas bin Malik:

Allah sent down His Divine Inspiration to His Apostle continuously and abundantly during the period preceding his death till He took him unto Him. That was the period of the greatest part of revelation; and Allah's Apostle died after that.


Bukhari :: Virtues of the Qur'an :: [6.61.506]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 506

Narrated Jundub:

Once the Prophet fell ill and did not offer the night prayer (Tahajjud prayer) for a night or two. A woman (the wife of Abu Lahab) came to him and said, "O Muhammad ! I do not see but that your Satan has left you." Then Allah revealed (Surat-Ad-Duha):

'By the fore-noon, and by the night when it darkens (or is still); Your Lord has not forsaken you, nor hated you.' (93)


Bukhari :: Virtues of the Qur'an :: [6.61.507]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 507

Narrated Anas bin Malik:

(The Caliph 'Uthman ordered Zaid bin Thabit, Said bin Al-As, 'Abdullah bin Az-Zubair and 'Abdur-Rahman bin Al-Harith bin Hisham to write the Quran in the form of a book (Mushafs) and said to them. "In case you disagree with Zaid bin Thabit (Al-Ansari) regarding any dialectic Arabic utterance of the Quran, then write it in the dialect of Quraish, for the Quran was revealed in this dialect." So they did it.


Bukhari :: Virtues of the Qur'an :: [6.61.508]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 508

Narrated Safwan bin Ya'la bin Umaiya:

Ya'la used to say, "I wish I could see Allah's Apostle at the time he is being inspired Divinely." When the Prophet was at Al-Ja'rana and was shaded by a garment hanging over him and some of his companions were with him, a man perfumed with scent came and said, "O Allah's Apostle! What is your opinion regarding a man who assumes Ihram and puts on a cloak after perfuming his body with scent?" The Prophet waited for a while, and then the Divine Inspiration descended upon him. 'Umar pointed out to Ya'la, telling him to come. Ya'la came and pushed his head (underneath the screen which was covering the Prophet ) and behold! The Prophet's face was red and he kept on breathing heavily for a while and then he was relieved. Thereupon he said, "Where is the questioner who asked me about 'Umra a while ago?" The man was sought and then was brought before the Prophet who said (to him), "As regards the scent which you perfumed your body with, you must wash it off thrice, and as for your cloak, you must take it off; and then perform in your 'Umra all those things which you perform in Hajj."


Bukhari :: Virtues of the Qur'an :: [6.61.509]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 509

Narrated Zaid bin Thabit:

Abu Bakr As-Siddiq sent for me when the people! of Yamama had been killed (i.e., a number of the Prophet's Companions who fought against Musailama). (I went to him) and found 'Umar bin Al-Khattab sitting with him. Abu Bakr then said (to me), "Umar has come to me and said: "Casualties were heavy among the Qurra' of the! Qur'an (i.e. those who knew the Quran by heart) on the day of the Battle of Yalmama, and I am afraid that more heavy casualties may take place among the Qurra' on other battlefields, whereby a large part of the Qur'an may be lost. Therefore I suggest, you (Abu Bakr) order that the Qur'an be collected." I said to 'Umar, "How can you do something which Allah's Apostle did not do?" 'Umar said, "By Allah, that is a good project. "Umar kept on urging me to accept his proposal till Allah opened my chest for it and I began to realize the good in the idea which 'Umar had realized." Then Abu Bakr said (to me). 'You are a wise young man and we do not have any suspicion about you, and you used to write the Divine Inspiration for Allah's Apostle. So you should search for (the fragmentary scripts of) the Qur'an and collect it in one book)." By Allah If they had ordered me to shift one of the mountains, it would not have been heavier for me than this ordering me to collect the Qur'an. Then I said to Abu Bakr, "How will you do something which Allah's Apostle did not do?" Abu Bakr replied, "By Allah, it is a good project." Abu Bakr kept on urging me to accept his idea until Allah opened my chest for what He had opened the chests of Abu Bakr and 'Umar. So I started looking for the Qur'an and collecting it from (what was written on) palmed stalks, thin white stones and also from the men who knew it by heart, till I found the last Verse of Surat At-Tauba (Repentance) with Abi Khuzaima Al-Ansari, and I did not find it with anybody other than him. The Verse is:

'Verily there has come unto you an Apostle (Muhammad) from amongst yourselves. It grieves him that you should receive any injury or difficulty..(till the end of Surat-Baraa' (At-Tauba) (9.128-129) Then the complete manuscripts (copy) of the Qur'an remained with Abu Bakr till he died, then with 'Umar till the end of his life, and then with Hafsa, the daughter of 'Umar.


Bukhari :: Virtues of the Qur'an :: [6.61.510]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 510

Narrated Anas bin Malik:

Hudhaifa bin Al-Yaman came to Uthman at the time when the people of Sham and the people of Iraq were Waging war to conquer Arminya and Adharbijan. Hudhaifa was afraid of their (the people of Sham and Iraq) differences in the recitation of the Qur'an, so he said to 'Uthman, "O chief of the Believers! Save this nation before they differ about the Book (Quran) as Jews and the Christians did before." So 'Uthman sent a message to Hafsa saying, "Send us the manuscripts of the Qur'an so that we may compile the Qur'anic materials in perfect copies and return the manuscripts to you." Hafsa sent it to 'Uthman. 'Uthman then ordered Zaid bin Thabit, 'Abdullah bin AzZubair, Said bin Al-As and 'AbdurRahman bin Harith bin Hisham to rewrite the manuscripts in perfect copies. 'Uthman said to the three Quraishi men, "In case you disagree with Zaid bin Thabit on any point in the Qur'an, then write it in the dialect of Quraish, the Qur'an was revealed in their tongue." They did so, and when they had written many copies, 'Uthman returned the original manuscripts to Hafsa. 'Uthman sent to every Muslim province one copy of what they had copied, and ordered that all the other Qur'anic materials, whether written in fragmentary manuscripts or whole copies, be burnt. Said bin Thabit added, "A Verse from Surat Ahzab was missed by me when we copied the Qur'an and I used to hear Allah's Apostle reciting it. So we searched for it and found it with Khuzaima bin Thabit Al-Ansari. (That Verse was): 'Among the Believers are men who have been true in their covenant with Allah.' (33.23)


Bukhari :: Virtues of the Qur'an :: [6.61.511]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 511

Narrated Zaid bin Thabit:

Abu Bakr sent for me and said, "You used to write the Divine Revelations for Allah's Apostle : So you should search for (the Qur'an and collect) it." I started searching for the Qur'an till I found the last two Verses of Surat At-Tauba with Abi Khuzaima Al-Ansari and I could not find these Verses with anybody other than him. (They were):

'Verily there has come unto you an Apostle (Muhammad) from amongst yourselves. It grieves him that you should receive any injury or difficulty ...' (9.128-129)


Bukhari :: Virtues of the Qur'an :: [6.61.512]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 512

Narrated Al-Bara:

There was revealed: 'Not equal are those believers who sit (at home) and those who strive and fight in the Cause of Allah.' (4.95)

The Prophet said, "Call Zaid for me and let him bring the board, the inkpot and the scapula bone (or the scapula bone and the ink pot)."' Then he said, "Write: 'Not equal are those Believers who sit..", and at that time 'Amr bin Um Maktum, the blind man was sitting behind the Prophet . He said, "O Allah's Apostle! What is your order For me (as regards the above Verse) as I am a blind man?" So, instead of the above Verse, the following Verse was revealed:

'Not equal are those believers who sit (at home) except those who are disabled (by injury or are blind or lame etc.) and those who strive and fight in the cause of Allah.' (4.95)


Bukhari :: Virtues of the Qur'an :: [6.61.513]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 513

Narrated 'Abdullah bin 'Abbas:

Allah's Apostle said, "Gabriel recited the Qur'an to me in one way. Then I requested him (to read it in another way), and continued asking him to recite it in other ways, and he recited it in several ways till he ultimately recited it in seven different ways."


Bukhari :: Virtues of the Qur'an :: [6.61.514]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 514

Narrated 'Umar bin Al-Khattab:

I heard Hisham bin Hakim reciting Surat Al-Furqan during the lifetime of Allah's Apostle and I listened to his recitation and noticed that he recited in several different ways which Allah's Apostle had not taught me. I was about to jump over him during his prayer, but I controlled my temper, and when he had completed his prayer, I put his upper garment around his neck and seized him by it and said, "Who taught you this Sura which I heard you reciting?" He replied, "Allah's Apostle taught it to me." I said, "You have told a lie, for Allah's Apostle has taught it to me in a different way from yours." So I dragged him to Allah's Apostle and said (to Allah's Apostle),

"I heard this person reciting Surat Al-Furqan in a way which you haven't taught me!" On that Allah's Apostle said, "Release him, (O 'Umar!) Recite, O Hisham!" Then he recited in the same way as I heard him reciting. Then Allah's Apostle said, "It was revealed in this way," and added, "Recite, O 'Umar!" I recited it as he had taught me. Allah's Apostle then said, "It was revealed in this way. This Qur'an has been revealed to be recited in seven different ways, so recite of it whichever (way) is easier for you (or read as much of it as may be easy for you)."


Bukhari :: Virtues of the Qur'an :: [6.61.515]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 515

Narrated Yusuf bin Mahk:

While I was with Aisha, the mother of the Believers, a person from Iraq came and asked, "What type of shroud is the best?" 'Aisha said, "May Allah be merciful to you! What does it matter?" He said, "O mother of the Believers! Show me (the copy of) your Qur'an," She said, "Why?" He said, "In order to compile and arrange the Qur'an according to it, for people recite it with its Suras not in proper order." 'Aisha said, "What does it matter which part of it you read first? (Be informed) that the first thing that was revealed thereof was a Sura from Al-Mufassal, and in it was mentioned Paradise and the Fire. When the people embraced Islam, the Verses regarding legal and illegal things were revealed. If the first thing to be revealed was: 'Do not drink alcoholic drinks.' people would have said, 'We will never leave alcoholic drinks,' and if there had been revealed, 'Do not commit illegal sexual intercourse, 'they would have said, 'We will never give up illegal sexual intercourse.' While I was a young girl of playing age, the following Verse was revealed in Mecca to Muhammad: 'Nay! But the Hour is their appointed time (for their full recompense), and the Hour will be more grievous and more bitter.' (54.46) Sura Al-Baqara (The Cow) and Surat An-Nisa (The Women) were revealed while I was with him." Then 'Aisha took out the copy of the Qur'an for the man and dictated to him the Verses of the Suras (in their proper order) .


Bukhari :: Virtues of the Qur'an :: [6.61.516]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 516

Narrated 'Abdullah bin Mas'ud:

Surat Bani-lsrael, Al-Kahf (The Cave), Maryam, Taha, Al-Anbiya' (The prophets) are amongst my first earnings and my old property, and (in fact) they are my old property.


Bukhari :: Virtues of the Qur'an :: [6.61.517]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 517

Narrated Al-Bara':

I learnt, 'Glorify the Name of your Lord the Most High' (Surat al-A'la) No 87, before the Prophet came (to Medina) .


Bukhari :: Virtues of the Qur'an :: [6.61.518]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 518

Narrated Shaqiq:

Abdullah said, "I learnt An-Naza'ir which the Prophet used to recite in pairs in each Rak'a." Then Abdullah got up and Alqama accompanied him to his house, and when Alqama came out, we asked him (about those Suras). He said, "They are twenty Suras that start from the beginning of Al-Mufassal, according to the arrangement done be Ibn Mas'ud, and end with the Suras starting with Ha Mim, e.g. Ha Mim (the Smoke). and "About what they question one another?" (78.1)


Bukhari :: Virtues of the Qur'an :: [6.61.519]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 519

Narrated Ibn 'Abbas:

The Prophet was the most generous person, and he used to become more so (generous) particularly in the month of Ramadan because Gabriel used to meet him every night of the month of Ramadan till it elapsed. Allah's Apostle used to recite the Qur'an for him. When Gabriel met him, he used to become more generous than the fast wind in doing good.


Bukhari :: Virtues of the Qur'an :: [6.61.520]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 520

Narrated Abu-Huraira: Gabriel used to repeat the recitation of the Qur'an with the Prophet once a year, but he repeated it twice with him in the year he died. The Prophet used to stay in I'tikaf for ten days every year (in the month of Ramadan), but


Bukhari :: Virtues of the Qur'an :: [6.61.521]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 521

Narrated Masriq:

'Abdullah bin 'Amr mentioned 'Abdullah bin Masud and said, "I shall ever love that man, for I heard the Prophet saying, 'Take (learn) the Qur'an from four: 'Abdullah bin Masud, Salim, Mu'adh and Ubai bin Ka'b.' "


Bukhari :: Virtues of the Qur'an :: [6.61.522]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 522

Narrated Shaqiq bin Salama:

Once 'Abdullah bin Mas'ud delivered a sermon before us and said, "By Allah, I learnt over seventy Suras direct from Allah's Apostle . By Allah, the companions of the Prophet came to know that I am one of those who know Allah's Book best of all of them, yet I am not the best of them." Shaqiq added: I sat in his religious gathering and I did not hear anybody opposing him (in his speech).


Bukhari :: Virtues of the Qur'an :: [6.61.523]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 523

Narrated 'Alqama:

While we were in the city of Hims (in Syria), Ibn Mas'ud recited Surat Yusuf. A man said to him), "It was not revealed in this way." Then Ibn Mas'ud said, "I recited it in this way before Allah's Apostle and he confirmed my recitation by saying, 'Well done!' " Ibn Mas'ud detected the smell of wine from the man's mouth, so he said to him, "Aren't you ashamed of telling a lie about Allah's Book and (along with this) you drink alcoholic liquors too?" Then he lashed him according to the law.


Bukhari :: Virtues of the Qur'an :: [6.61.524]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 524

Narrated 'Abdullah (bin Mas'ud) : By Allah other than Whom none has the right to be worshipped! There is no Sura revealed in Allah's Book but I know at what place it was revealed; and there is no Verse revealed in Allah's Book but I know about whom


Bukhari :: Virtues of the Qur'an :: [6.61.525]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 525

Narrated Qatada:

I asked Anas bin Malik: "Who collected the Qur'an at the time of the Prophet ?" He replied, "Four, all of whom were from the Ansar: Ubai bin Ka'b, Mu'adh bin Jabal, Zaid bin Thabit and Abu Zaid."


Bukhari :: Virtues of the Qur'an :: [6.61.526]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 526

Narrated Anas bin Malik:

When the Prophet died, none had collected the Qur'an but four persons;: Abu Ad-Darda'. Mu'adh bin Jabal, Zaid bin Thabit and Abu Zaid. We were the inheritor (of Abu Zaid) as he had no offspring .


Bukhari :: Virtues of the Qur'an :: [6.61.527]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 527

Narrated Ibn 'Abbas: 'Umar said, Ubai was the best of us in the recitation (of the Qur'an) yet we leave some of what he recites.' Ubai says, 'PI have taken it from the mouth of Allah's Apostle and will not leave for anything whatever." But Allah said


Bukhari :: Virtues of the Qur'an :: [6.61.528]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 528

Narrated Abu Sa'id Al-Mu'alla:

While I was praying, the Prophet called me but I did not respond to his call. Later I said, "O Allah's Apostle! I was praying." He said, "Didn't Allah say: 'O you who believe! Give your response to Allah (by obeying Him) and to His Apostle when he calls you'?" (8.24)

He then said, "Shall I not teach you the most superior Surah in the Qur'an?" He said, '(It is),

'Praise be to Allah, the Lord of the worlds. ' (i.e., Surat Al-Fatiha) which consists of seven repeatedly recited Verses and the Magnificent Qur'an which was given to me."


Bukhari :: Virtues of the Qur'an :: [6.61.529]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 529

Narrated Abu Said Al-Khudri:

While we were on one of our journeys, we dismounted at a place where a slave girl came and said, "The chief of this tribe has been stung by a scorpion and our men are not present; is there anybody among you who can treat him (by reciting something)?" Then one of our men went along with her though we did not think that he knew any such treatment. But he treated the chief by reciting something, and the sick man recovered whereupon he gave him thirty sheep and gave us milk to drink (as a reward). When he returned, we asked our friend, "Did you know how to treat with the recitation of something?" He said, "No, but I treated him only with the recitation of the Mother of the Book (i.e., Al-Fatiha)." We said, "Do not say anything (about it) till we reach or ask the Prophet so when we reached Medina, we mentioned that to the Prophet (in order to know whether the sheep which we had taken were lawful to take or not). The Prophet said, "How did he come to know that it (Al-Fatiha) could be used for treatment? Distribute your reward and assign for me one share thereof as well."


Bukhari :: Virtues of the Qur'an :: [6.61.530]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 530

Narrated Abu Mas'ud:

The Prophet said, "If somebody recited the last two Verses of Surat Al-Baqara at night, that will be sufficient for him."

Narrated Abu Huraira: Allah 's Apostle ordered me to guard the Zakat revenue of Ramadan. Then somebody came to me and started stealing of the foodstuff. I caught him and said, "I will take you to Allah's Apostle!" Then Abu Huraira described the whole narration and said:) That person said (to me), "(Please don't take me to Allah's Apostle and I will tell you a few words by which Allah will benefit you.) When you go to your bed, recite Ayat-al-Kursi, (2.255) for then there will be a guard from Allah who will protect you all night long, and Satan will not be able to come near you till dawn." (When the Prophet heard the story) he said (to me), "He (who came to you at night) told you the truth although he is a liar; and it was Satan."


Bukhari :: Virtues of the Qur'an :: [6.61.531]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 531

Narrated Al-Bara':

A man was reciting Surat Al-Kahf and his horse was tied with two ropes beside him. A cloud came down and spread over that man, and it kept on coming closer and closer to him till his horse started jumping (as if afraid of something). When it was morning, the man came to the Prophet, and told him of that experience. The Prophet said, "That was As-Sakina (tranquility) which descended because of (the recitation of) the Qur'an."


Bukhari :: Virtues of the Qur'an :: [6.61.532]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 532

Narrated Aslam:

Allah's Apostle was traveling on one of his journeys, and 'Umar bin Al-Khattab was traveling along with him at night. 'Umar asked him about something, but Allah's Apostle I did not answer him. He asked again, but he did not answer. He asked for the third time!, but he did not answer. On that, 'Umar said to himself, "May your mother lose you! You have asked Allah's Apostle three times, but he did not answer at all!" Umar said, "So I made my camel go fast till I was ahead of the people, and I was afraid that something might be! revealed about me. After a little while I heard a call maker calling me, I said, 'I was afraid that some Qur'anic Verse might be revealed about me.' So I went to Allah's Apostle and greeted him. He said, 'Tonight there has been revealed to me a Surah which is dearer to me than that on which the sun shines (i.e. the world).' Then he recited: 'Verily! We have given you (O Muhammad I, a manifest victory.' " (Surat al-Fath) No. (48.1).


Bukhari :: Virtues of the Qur'an :: [6.61.533]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 533

Narrated Abu Said Al-Khudri:

A man heard another man reciting (Surat-Al-Ikhlas) 'Say He is Allah, (the) One.' (112. 1) repeatedly. The next morning he came to Allah's Apostle and informed him about it as if he thought that it was not enough to recite. On that Allah's Apostle said, "By Him in Whose Hand my life is, this Surah is equal to one-third of the Qur'an!"

Narrated Abu Said Al-Khudri: My brother, Qatada bin An-Nau'man said, "A man performed the night prayer late at night in the lifetime of the Prophet and he read: 'Say: He is Allah, (the) One,' (112.1) and read nothing besides that. The next morning a man went to the Prophet ,~ and told him about that . (The Prophet replied the same as (in Hadith 532) above.)


Bukhari :: Virtues of the Qur'an :: [6.61.534]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 534

Narrated Abu Said Al-Khudri:

The Prophet said to his companions, "Is it difficult for any of you to recite one third of the Qur'an in one night?" This suggestion was difficult for them so they said, "Who among us has the power to do so, O Allah's Apostle?" Allah Apostle replied: " Allah (the) One, the Self-Sufficient Master Whom all creatures need.' (Surat Al-Ikhlas 112.1--to the End) is equal to one third of the Qur'an."


Bukhari :: Virtues of the Qur'an :: [6.61.535]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 535

Narrated 'Aisha:

Whenever Allah's Apostle became sick, he would recite Mu'awwidhat (Surat Al-Falaq and Surat An-Nas) and then blow his breath over his body. When he became seriously ill, I used to recite (these two Suras) and rub his hands over his body hoping for its blessings.


Bukhari :: Virtues of the Qur'an :: [6.61.536]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 536

Narrated Usaid bin Hudair:

That while he was reciting Surat Al-Baqara (The Cow) at night, and his horse was tied beside him, the horse was suddenly startled and troubled. When he stopped reciting, the horse became quiet, and when he started again, the horse was startled again. Then he stopped reciting and the horse became quiet too. He started reciting again and the horse was startled and troubled once again. Then he stopped reciting and his son, Yahya was beside the horse. He was afraid that the horse might trample on him. When he took the boy away and looked towards the sky, he could not see it. The next morning he informed the Prophet who said, "Recite, O Ibn Hudair! Recite, O Ibn Hudair!" Ibn Hudair replied, "O Allah's Apostle! My son, Yahya was near the horse and I was afraid that it might trample on him, so I looked towards the sky, and went to him. When I looked at the sky, I saw something like a cloud containing what looked like lamps, so I went out in order not to see it." The Prophet said, "Do you know what that was?" Ibn Hudair replied, "No." The Prophet said, "Those were Angels who came near to you for your voice and if you had kept on reciting till dawn, it would have remained there till morning when people would have seen it as it would not have disappear


Bukhari :: Virtues of the Qur'an :: [6.61.537]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 537

Narrated 'Abdul 'Aziz bin Rufai':

Shaddad bin Ma'qil and I entered upon Ibn 'Abbas. Shaddad bin Ma'qil asked him, "Did the Prophet leave anything (besides the Qur'an)?" He replied. "He did not leave anything except what is Between the two bindings (of the Qur'an)." Then we visited Muhammad bin Al-Hanafiyya and asked him (the same question). He replied, "The Prophet did not leave except what is between the bindings (of the Qur'an)."


Bukhari :: Virtues of the Qur'an :: [6.61.538]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 538

Narrated Abu Musa Al-Ash'ari:

The Prophet said, "The example of him (a believer) who recites the Qur'an is like that of a citron which tastes good and smells good. And he (a believer) who does not recite the Qur'an is like a date which is good in taste but has no smell. And the example of a dissolute wicked person who recites the Qur'an is like the Raihana (sweet basil) which smells good but tastes bitter. And the example of a dissolute wicked person who does not recite the Qur'an is like the colocynth which tastes bitter and has no smell.


Bukhari :: Virtues of the Qur'an :: [6.61.539]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 539

Narrated Ibn 'Umar:

The Prophet said, "Your life in comparison to the lifetime of the past nations is like the period between the time of 'Asr prayer and sunset. Your example and the example of the Jews and Christians is that of person who employed laborers and said to them, "Who will work for me till the middle of the day for one Qirat (a special weight)?' The Jews did. He then said, "Who will work for me from the middle of the day till the 'Asr prayer for one Qirat each?" The Christians worked accordingly. Then you (Muslims) are working from the bar prayer till the Maghrib prayer for two Qirats each. They (the Jews and the Christians) said, 'We did more labor but took less wages.' He (Allah) said, 'Have I wronged you in your rights?' They replied, 'No.' Then He said, 'This is My Blessing which I give to whom I wish."


Bukhari :: Virtues of the Qur'an :: [6.61.540]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 540

Narrated Talha:

I asked 'Abdullah bin Abi 'Aufa, "Did the Prophet make a will (to appoint his successor or bequeath wealth)?" He replied, "No." I said, "How is it prescribed then for the people to make wills, and they are ordered to do so while the Prophet did not make any will?" He said, "He made a will wherein he recommended Allah's Book."


Bukhari :: Virtues of the Qur'an :: [6.61.541]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 541

Narrated Abu Huraira: Allah's Apostle said, "Allah does not listen to a prophet as He listens to a prophet who recites the Qur'an in a pleasant tone." The companion of the sub-narrator (Abu Salama) said, "It means, reciting it aloud."


Bukhari :: Virtues of the Qur'an :: [6.61.542]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 542

Narrated Abu Huraira: The Prophet I said, "Allah does not listen to a prophet as He listens to a prophet who recites the Qur'an in a loud and pleasant tone." Sufyan said, "This saying means: a prophet who regards the Qur'an as something that makes hi


Bukhari :: Virtues of the Qur'an :: [6.61.543]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 543

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Not to wish to be the like except of two men. A man whom Allah has given the knowledge of the Book and he recites it during the hours of the night, and a man whom Allah has given wealth, and he spends it in charity during the night and the hours of the day."


Bukhari :: Virtues of the Qur'an :: [6.61.544]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 544

Narrated Abu Huraira:

Allah's Apostle I said, "Not to wish to be the like of except two men: A man whom Allah has taught the Qur'an and he recites it during the hours of the night and during the hours of the day, and his neighbor listens to him and says, 'I wish I had been given what has been given to so-and-so, so that I might do what he does; and a man whom Allah has given wealth and he spends it on what is just and right, whereupon an other man May say, 'I wish I had been given what so-and-so has been given, for then I would do what he does."


Bukhari :: Virtues of the Qur'an :: [6.61.545]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 545

Narrated 'Uthman:

The Prophet said, "The best among you (Muslims) are those who learn the Qur'an and teach it."


Bukhari :: Virtues of the Qur'an :: [6.61.546]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 546

Narrated Uthman bin Affan:

The Prophet said, "The most superior among you (Muslims) are those who learn the Qur'an and teach it."


Bukhari :: Virtues of the Qur'an :: [6.61.547]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 547

Narrated Sahl bin Sad:

A lady came to the Prophet and declared that she had decided to offer herself to Allah and His Apostle. The Prophet said, "I am not in need of women." A man said (to the Prophet) "Please marry her to me." The Prophet said (to him), "Give her a garment." The man said, "I cannot afford it." The Prophet said, "Give her anything, even if it were an iron ring." The man apologized again. The Prophet then asked him, "What do you know by heart of the Qur'an?" He replied, "I know such-and-such portion of the Qur'an (by heart)." The Prophet said, "Then I marry her to you for that much of the Qur'an which you know by heart."


Bukhari :: Virtues of the Qur'an :: [6.61.548]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 548

Narrated Sahl bin Sad:

A lady came to Allah's Apostle and said, "O Allah's Apostle! I have come to you to offer myself to you." He raised his eyes and looked at her and then lowered his head. When the lady saw that he did not make any decision, she sat down. On that, a man from his companions got up and said. "O Allah's Apostle! If you are not in need of this woman, then marry her to me." Allah's Apostle said, "Do you have anything to offer her?" He replied. "No, by Allah, O Allah's Apostle!" The Prophet said to him, "Go to your family and see if you can find something.' The man went and returned, saying, "No, by Allah, O Allah's Apostle! I have not found anything." The Prophet said, "Try to find something, even if it is an iron ring.'' He went again and returned, saying, "No, by Allah, O Allah's Apostle, not even an iron ring, but I have this waist sheet of mine." The man had no upper garment, so he intended to give her, half his waist sheet. So Allah's Apostle said, ''What would she do with your waist sheet? If you wear it, she will have nothing of it over her body, and if she wears it, you will have nothing over your body." So that man sat for a long period and then got up, and Allah's Apostle saw him going away, so he ordered somebody to call him. When he came, the Prophet asked him, " How much of the Qur'an do you know?" He replied, "I know such Surat and such Surat and such Surat," and went on counting it, The Prophet asked him, "Can you recite it by heart?" he replied, "Yes." The Prophet said, "Go, I have married this lady to you for the amount of the Qur'an you know by heart."


Bukhari :: Virtues of the Qur'an :: [6.61.549]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 549

Narrated Ibn Umar:

Allah's Apostle said, "The example of the person who knows the Qur'an by heart is like the owner of tied camels. If he keeps them tied, he will control them, but if he releases them, they will run away."


Bukhari :: Virtues of the Qur'an :: [6.61.550]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 550

Narrated Abdullah:

The Prophet said, "It is a bad thing that some of you say, 'I have forgotten such-and-such verse of the Qur'an,' for indeed, he has been caused (by Allah) to forget it. So you must keep on reciting the Qur'an because it escapes from the hearts of men faster than camel do."


Bukhari :: Virtues of the Qur'an :: [6.61.551]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 551

Narrated Abdullah:

I heard the Prophet saying... (as above, no. 550).


Bukhari :: Virtues of the Qur'an :: [6.61.552]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 552

Narrated Abu Musa:

The Prophet said, "Keep on reciting the Qur'an, for, by Him in Whose Hand my life is, Quran runs away (is forgotten) faster than camels that are released from their tying ropes."


Bukhari :: Virtues of the Qur'an :: [6.61.553]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 553

Narrated 'Abdullah bin Mughaffal:

I saw Allah's Apostle reciting Surat-al-Fath on his she-camel on the day of the Conquest of Mecca.


Bukhari :: Virtues of the Qur'an :: [6.61.554]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 554

Narrated Said bid Jubair:

Those Suras which you people call the Mufassal, are the Muhkam. And Ibn 'Abbas said, "Allah's Apostle died when I was a boy of ten years, and I had learnt the Muhkam (of the Qur'an).


Bukhari :: Virtues of the Qur'an :: [6.61.555]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 555

Narrated Said bin Jubair:

Ibn 'Abbas said, "I have learnt all the Muhkam Suras during the life time of Allah's Apostle." I said to him, 'What is meant by the Muhkam?" He replied, "The Mufassal."


Bukhari :: Virtues of the Qur'an :: [6.61.556]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 556

Narrated Aisha:

The Prophet heard a man reciting the Qur'an in the mosque and said, "May Allah bestow His Mercy on him, as he has reminded me of such-and-such Verses of such a Surah."


Bukhari :: Virtues of the Qur'an :: [6.61.557]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 557

Narrated Hisham:

(The same Hadith, adding): which I missed (modifying the Verses).


Bukhari :: Virtues of the Qur'an :: [6.61.558]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 558

Narrated Aisha:

Allah's Apostle heard a man reciting the Qur'an at night, and said, "May Allah bestow His Mercy on him, as he has reminded me of such-and-such Verses of such-and-such Suras, which I was caused to forget."


Bukhari :: Virtues of the Qur'an :: [6.61.559]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 559

Narrated Abdullah:

The Prophet said, "Why does anyone of the people say, 'I have forgotten such-and-such Verses (of the Qur'an)?' He, in fact, is caused (by Allah) to forget."


Bukhari :: Virtues of the Qur'an :: [6.61.560]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 560

Narrated Abu Mas'ud Al-Ansari:

The Prophet said, "If one recites the last two Verses of Surat-al-Baqara at night, it is sufficient for him (for that night)."


Bukhari :: Virtues of the Qur'an :: [6.61.561]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 561

Narrated Umar bin Khattab:

I heard Hisham bin Hakim bin Hizam reciting Surat-al-Furqan during the lifetime of Allah's Apostle, and I listened to his recitation and noticed that he recited it in several ways which Allah's Apostle had not taught me. So I was on the point of attacking him in the prayer, but I waited till he finished his prayer, and then I seized him by the collar and said, "Who taught you this Surah which I have heard you reciting?" He replied, "Allah's Apostle taught it to me." I said, "You are telling a lie; By Allah! Allah's Apostle taught me (in a different way) this very Surah which I have heard you reciting." So I took him, leading him to Allah's Apostle and said, "O Allah's Apostle! I heard this person reciting Surat-al-Furqan in a way that you did not teach me, and you have taught me Surat-al-Furqan." The Prophet said, "O Hisham, recite!" So he recited in the same way as I heard him recite it before. On that Allah's Apostle said, "It was revealed to be recited in this way." Then Allah's Apostle said, "Recite, O 'Umar!" So I recited it as he had taught me. Allah's Apostle then said, "It was revealed to be recited in this way." Allah" Apostle added, "The Quran has been revealed to be recited in several different ways, so recite of it that which is easier for you."


Bukhari :: Virtues of the Qur'an :: [6.61.562]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 562

Narrated 'Aisha:

The Prophet heard a reciter reciting, the Qur'an in the mosque at night. The Prophet said, "May Allah bestow His Mercy on him, as he has remind ed me of such-and-such Verses of such and-such Suras, which I missed!"


Bukhari :: Virtues of the Qur'an :: [6.61.563]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 563

Narrated Abu Wail:

We went to 'Abdullah in the morning and a man said, "Yesterday I recited all the Mufassal Suras." On that 'Abdullah said, "That is very quick, and we have the (Prophet's) recitation, and I remember very well the recitation of those Suras which the Prophet used to recite, and they were eighteen Suras from the Mufassal, and two Suras from the Suras that start with Ha Mim.


Bukhari :: Virtues of the Qur'an :: [6.61.564]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 564

Narrated Ibn Abbas:

Regarding His (Allah's) Statement:-- 'Move not your tongue concerning (the Qur'an) to make haste therewith.' (75.16) And whenever Gabriel descended to Allah's Apostle with the Divine Inspiration, Allah's Apostle used to move his tongue and lips, and that used to be hard for him, and one could easily recognize that he was being inspired Divinely. So Allah revealed the Verse which occurs in the Surah starting with "I do swear by the Day of Resurrection.' (75.1) i.e. 'Move not your tongue concerning (the Qur'an) to make haste then with. It is for Us to collect it (in your mind) (O Muhammad) an give you the ability to recite it 'by heart.' (75.16-17) which means: It is for us to collect it (in your mind) and give you the ability to recite it by heart. And when We have recited it to you (O Muhammad) through Gabriel then follow you its recital. (75.18) means: 'When We reveal it (the Qur'an) to you, Listen to it.' for then: It is for Us to explain it and make it clear to you' (75.19) i.e. It is up to Us to explain it through your tongue. So, when Gabriel came to him, Allah's Apostle would listen to him attentively, and as soon as Gabriel left, he would recite the Revelations, as Allah had promised him.


Bukhari :: Virtues of the Qur'an :: [6.61.565]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 565

Narrated Qatada:

I asked Anas bin Malik about the recitation of the Prophet. He said, "He used to pray long (certain sounds) very much.


Bukhari :: Virtues of the Qur'an :: [6.61.566]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 566

Narrated Qatada:

Anas was asked, "How was the recitation (of the Quran) of the Prophet?' He replied, "It was characterized by the prolongation of certain sounds." He then recited: In the Name of Allah, the Most Beneficent, the Most Merciful prolonging the pronunciation of 'In the Name of Allah, 'the most Beneficent,' and 'the Most Merciful.


Bukhari :: Virtues of the Qur'an :: [6.61.567]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 567

Narrated 'Abdullah bin Mughaffal:

I saw the Prophet reciting (Qur'an) while he was riding on his she camel or camel which was moving, carrying him. He was reciting Surat Fath or part of Surat Fath very softly and in an Attractive vibrating tone.


Bukhari :: Virtues of the Qur'an :: [6.61.568]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 568

Narrated Abu Musa:

That the Prophet said to him' "O Abu Musa! You have been given one of the musical wind-instruments of the family of David .'


Bukhari :: Virtues of the Qur'an :: [6.61.569]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 569

Narrated 'Abdullah:

That the Prophet said to him, "Recite the Qur'an to me." 'Abdullah said, "Shall I recite (the Qur'an) to you while it has been revealed to you?" He said, "I like to hear it from others."


Bukhari :: Virtues of the Qur'an :: [6.61.570]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 570

Narrated Abdullah bin Mas'ud:

The Prophet said to me, "Recite (the Quran) to me." I said, "O Allah's Apostle Shall I recite (the Qur'an) to you while it has been revealed to you?" He said, "Yes." So I recited Surat-An-Nisa' (The Women), but when I recited the Verse:

'How (will it be) then when We bring from each nation a witness and We bring you (O Muhammad) as a witness against these people.' (4.41) He said, "Enough for the present," I looked at him and behold! His eyes were overflowing with tears


Bukhari :: Virtues of the Qur'an :: [6.61.571]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 571

Narrated Sufyan:

Ibn Shubruma said, "I wanted to see how much of the Qur'an can be enough (to recite in prayer) and I could not find a Surah containing less than three Verses, therefore I said to myself), "One ought not to recite less than three (Quranic) Verses (in prayer)."

Narrated Abu Mas'ud: The Prophet said, "If somebody recites the last two Verses of Surat al-Baqara at night, it will be sufficient for him.


Bukhari :: Virtues of the Qur'an :: [6.61.572]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 572

Narrated 'Abdullah bin Amr bin Al-As:

My father got me married to a lady of a noble family, and often used to ask my wife about me, and she used to reply, "What a wonderful man he is! He never comes to my bed, nor has he approached me since he married me." When this state continued for a long period, my father told the story to the Prophet who said to my father, "Let me meet him." Then I met him and he asked me, "How do you fast?" I replied, "I fast daily," He asked, "How long does it take you to finish the recitation of the whole Quran?" I replied, "I finish it every night." On that he said, "Fast for three days every month and recite the Qur'an (and finish it) in one month." I said, "But I have power to do more than that." He said, "Then fast for three days per week." I said, "i have the power to do more than that." He said, "Therefore, fast the most superior type of fasting, (that is, the fasting of (prophet) David who used to fast every alternate day; and finish the recitation of the whole Qur'an In seven days." I wish I had accepted the permission of Allah's Apostle as I have become a weak old man. It is said that 'Abdullah used to recite one-seventh of the Qur'an during the day-time to some of his family members, for he used to check his memorization of what he would recite at night during the daytime so that it would be easier for him to read at night. And whenever he wanted to gain some strength, he used to give up fasting for some days and count those days to fast for a similar period, for he disliked to leave those things which he used to do during the lifetime of the Prophet.


Bukhari :: Virtues of the Qur'an :: [6.61.573]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 573

Narrated Abdullah bin Amr:

The Prophet asked me, "How long does it take you to finish the recitation of the whole Qur'an?"


Bukhari :: Virtues of the Qur'an :: [6.61.574]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 574

Narrated 'Abdullah bin 'Amr:

Allah's Apostle said to me, "Recite the whole Qur'an in one month's time." I said, "But I have power (to do more than that)." Allah's Apostle said, "Then finish the recitation of the Qur'an in seven days, and do not finish it in less than this period."


Bukhari :: Virtues of the Qur'an :: [6.61.575]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 575

Narrated 'Abdullah (bin Mas'ud):

Allah's Apostle said (to me), "Recite the Qur'an to me." I said, "Shall I recite (it) to you while it has been revealed to you?" He said, "I like to hear it from another person." So I recited Surat An-Nisa (The Women) till I reached the Verse: 'How (will it be) then when We bring from each nation a witness, and We bring you (O Muhammad) as a witness against these people.' (4.41) Then he said to me, "Stop!" Thereupon I saw his eyes overflowing with tears.


Bukhari :: Virtues of the Qur'an :: [6.61.576]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 576

Narrated Abdullah bin Masud:

The Prophet said to me, "Recite Quran to me." I said to him. "Shall I recite (it) to you while it has been revealed to you?" He said, "I like to hear it from another person."


Bukhari :: Virtues of the Qur'an :: [6.61.577]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 577

Narrated 'Ali:

I heard the Prophet saying, "In the last days (of the world) there will appear young people with foolish thoughts and ideas. They will give good talks, but they will go out of Islam as an arrow goes out of its game, their faith will not exceed their throats. So, wherever you find them, kill them, for there will be a reward for their killers on the Day of Resurrection."


Bukhari :: Virtues of the Qur'an :: [6.61.578]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 578

Narrated Abu Said Al-Khudri:

I heard Allah's Apostle saying, "There will appear some people among you whose prayer will make you look down upon yours, and whose fasting will make you look down upon yours, but they will recite the Qur'an which will not exceed their throats (they will not act on it) and they will go out of Islam as an arrow goes out through the game whereupon the archer would examine the arrowhead but see nothing, and look at the unfeathered arrow but see nothing, and look at the arrow feathers but see nothing, and finally he suspects to find something in the lower part of the arrow."


Bukhari :: Virtues of the Qur'an :: [6.61.579]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 579

Narrated Abu Musa:

The Prophet said, "The example of a believer who recites the Qur'an and acts on it, like a citron which tastes nice and smells nice. And the example of a believer who does not recite the Qur'an but acts on it, is like a date which tastes good but has no smell. And the example of a hypocrite who recites the Qur'an is like a Raihana (sweet basil) which smells good but tastes bitter And the example of a hypocrite who does not recite the Quran is like a colocynth which tastes bitter and has a bad smell."


Bukhari :: Virtues of the Qur'an :: [6.61.580]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 580

Narrated Abdullah:

The Prophet said, "Recite (and study) the Qur'an as long as you agree about its interpretation, but if you have any difference of opinion (as regards to its interpretation and meaning) then you should stop reciting it (for the time being)."


Bukhari :: Virtues of the Qur'an :: [6.61.581]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 581

Narrated Jundub:

The Prophet said, "Recite (and study) the Quran as long as you agree about its interpretation, but when you have any difference of opinion (as regards its interpretation and meaning) then you should stop reciting it (for the time being)'


Bukhari :: Virtues of the Qur'an :: [6.61.582]

Virtues of the Qur'an

Bukhari :: Book 6 :: Volume 61 :: Hadith 582

Narrated Abdullah:

That he heard a man reciting a Quranic Verse which he had heard the Prophet reciting in a different way. So he took that man to the Prophet (and told him the story). The Prophet said, "Both of you are reciting in a correct way, so carry on reciting." The Prophet further added, "The nations which were before you were destroyed (by Allah) because they differed."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.1]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 1

Narrated Anas bin Malik:

A group of three men came to the houses of the wives of the Prophet asking how the Prophet worshipped (Allah), and when they were informed about that, they considered their worship insufficient and said, "Where are we from the Prophet as his past and future sins have been forgiven." Then one of them said, "I will offer the prayer throughout the night forever." The other said, "I will fast throughout the year and will not break my fast." The third said, "I will keep away from the women and will not marry forever." Allah's Apostle came to them and said, "Are you the same people who said so-and-so? By Allah, I am more submissive to Allah and more afraid of Him than you; yet I fast and break my fast, I do sleep and I also marry women. So he who does not follow my tradition in religion, is not from me (not one of my followers)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.2]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 2

Narrated 'Ursa:

that he asked 'Aisha about the Statement of Allah: 'If you fear that you shall not be able to deal justly with the orphan girls, then marry (other) women of your choice, two or three or four; but if you fear that you shall not be able to deal justly (with them), then only one, or (the captives) that your right hands possess. That will be nearer to prevent you from doing injustice.' (4.3) 'Aisha said, "O my nephew! (This Verse has been revealed in connection with) an orphan girl under the guardianship of her guardian who is attracted by her wealth and beauty and intends to marry her with a Mahr less than what other women of her standard deserve. So they (such guardians) have been forbidden to marry them unless they do justice to them and give them their full Mahr, and they are ordered to marry other women instead of them."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.3]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 3

Narrated 'Alqama:

While I was with Abdullah, 'Uthman met him at Mina and said, "O Abu 'Abdur-Rahman ! I have something to say to you." So both of them went aside and 'Uthman said, "O Abu 'Abdur-Rah. man! Shall we marry you to a virgin who will make you remember your past days?" When 'Abdullah felt that he was not in need of that, he beckoned me (to join him) saying, "O 'Alqama!" Then I heard him saying (in reply to 'Uthman), "As you have said that, (I tell you that) the Prophet once said to us, 'O young people! Whoever among you is able to marry, should marry, and whoever is not able to marry, is recommended to fast, as fasting diminishes his sexual power.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.4]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 4

Narrated 'Abdullah:

We were with the Prophet while we were young and had no wealth whatever. So Allah's Apostle said, "O young people! Whoever among you can marry, should marry, because it helps him lower his gaze and guard his modesty (i.e. his private parts from committing illegal sexual intercourse etc.), and whoever is not able to marry, should fast, as fasting diminishes his sexual power."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.5]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 5

Narrated 'Ata:

We presented ourselves along with Ibn 'Abbas at the funeral procession of Maimuna at a place called Sarif. Ibn 'Abbas said, "This is the wife of the Prophet so when you lift her bier, do not Jerk it or shake it much, but walk smoothly because the Prophet had nine wives and he used to observe the night turns with eight of them, and for one of them there was no night turn."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.6]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 6

Narrated Anas:

The Prophet I used to go round (have sexual relations with) all his wives in one night, and he had nine wives.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.7]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 7

Narrated Said bin Jubair:

Ibn 'Abbas asked me, "Are you married?" I replied, "No." He said, "Marry, for the best person of this (Muslim) nation (i.e., Muhammad) of all other Muslims, had the largest number of wives."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.8]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 8

Narrated 'Umar bin Al-Khattab:

The Prophet said, "The rewards (of deeds) are according to the intention, and everybody will get the reward for what he has intended. So whoever emigrated for Allah's and His Apostle's sake, his emigration was for Allah and His Apostle; and whoever emigrated for worldly benefits, or to marry a woman, then his emigration was for the thing for what he emigrated for." (1)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.9]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 9

Narrated Ibn Masud:

We used to fight in the holy battles in the company of the Prophet and we had no wives with us. So we said, "O Allah's Apostle! Shall we get castrated?" The Prophet forbade us to do so.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.10]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 10

Narrated Anas bin Malik:

'Abdur-Rahman bin 'Auf came (from Mecca to Medina) and the Prophet made a bond of brotherhood between him and Sad bin Ar-Rabi' Al-Ansari. Al-Ansari had two wives, so he suggested that 'Abdur-Rahman take half, his wives and property. 'Abdur-Rahman replied, "May Allah bless you with your wives and property. Kindly show me the market." So 'Abdur-Rahman went to the market and gained (in bargains) some dried yoghurt and some butter. After a few days the Prophet saw Abdur-Rahman with some yellow stains on his clothes and asked him, "What is that, O 'Abdur-Rahman?" He replied, "I had married an Ansari woman." The Prophet asked, "How much Mahr did you give her?" He replied, "The weight of one (date) stone of gold." The Prophet said, "Offer a banquet, even with one sheep."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.11]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 11

Narrated Sad bin Abi Waqqas:

Allah's Apostle forbade 'Uthman bin Maz'un to abstain from marrying (and other pleasures) and if he had allowed him, we would have gotten ourselves castrated.(1)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.12]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 12

Narrated Sad bin Abi Waqqas:

The Prophet prevented 'Uthman bin Mazun from that (not marrying), and had he allowed him, we would have got ourselves castrated.(1)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.13]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 13

Narrated Abu Huraira:

I said, "O Allah's Apostle! I am a young man and I am afraid that I may commit illegal sexual intercourse and I cannot afford to marry." He kept silent, and then repeated my question once again, but he kept silent. I said the same (for the third time) and he remained silent. Then repeated my question (for the fourth time), and only then the Prophet said, "O Abu Huraira! The pen has dried after writing what you are going to confront. So (it does not matter whether you) get yourself castrated or not."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.14]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 14

Narrated 'Aisha :

I said, "O Allah's Apostle! Suppose you landed in a valley where there is a tree of which something has been eaten and then you found trees of which nothing has been eaten, of which tree would you let your camel graze?" He said, "(I will let my camel graze) of the one of which nothing has been eaten before." (The sub-narrator added: 'Aisha meant that Allah's Apostle had not married a virgin besides herself .)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.15]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 15

Narrated 'Aisha:

Allah's Apostle said (to me), "You have been shown to me twice in (my) dreams. A man was carrying you in a silken cloth and said to me, 'This is your wife.' I uncovered it; and behold, it was you. I said to myself, 'If this dream is from Allah, He will cause it to come true.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.16]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 16

Narrated Jabir bin Abdullah:

While we were returning from a Ghazwa (Holy Battle) with the Prophet, I started driving my camel fast, as it was a lazy camel A rider came behind me and pricked my camel with a spear he had with him, and then my camel started running as fast as the best camel you may see. Behold! The rider was the Prophet himself. He said, 'What makes you in such a hurry?" I replied, I am newly married " He said, "Did you marry a virgin or a matron? I replied, "A matron." He said, "Why didn't you marry a young girl so that you may play with her and she with you?" When we were about to enter (Medina), the Prophet said, "Wait so that you may enter (Medina) at night so that the lady of unkempt hair may comb her hair and the one whose husband has been absent may shave her pubic region.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.17]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 17

Narrated Jabir bin 'Abdullah:

When I got married, Allah's Apostle said to me, "What type of lady have you married?" I replied, "I have married a matron' He said, "Why, don't you have a liking for the virgins and for fondling them?" Jabir also said: Allah's Apostle said, "Why didn't you marry a young girl so that you might play with her and she with you?'


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.18]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 18

Narrated 'Ursa:

The Prophet asked Abu Bakr for 'Aisha's hand in marriage. Abu Bakr said "But I am your brother." The Prophet said, "You are my brother in Allah's religion and His Book, but she (Aisha) is lawful for me to marry."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.19]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 19

Narrated Abu Huraira:

The Prophet said, "The best women are the riders of the camels and the righteous among the women of Quraish. They are the kindest women to their children in their childhood and the more careful women of the property of their husbands."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.20]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 20

Narrated Abu Burda's father:

Allah's Apostle said, any man who has a slave girl whom he educates properly, teaches good manners, manumits and marries her, will get a double reward And if any man of the people of the Scriptures believes in his own prophet and then believes in me too, he will (also) get a double reward And any slave who fulfills his duty to his master and to his Lord, will (also) get a double reward."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.21]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 21

Narrated Abu Huraira:

The Prophet said: Abraham did not tell lies except three. (One of them was) when Abraham passed by a tyrant and (his wife) Sara was accompanying him (Abu Huraira then mentioned the whole narration and said:) (The tyrant) gave her Hajar. Sara said, "Allah saved me from the hands of the Kafir (i.e. infidel) and gave me Hajar to serve me." (Abu Huraira added:) That (Hajar) is your mother, O Banu Ma'-As-Sama' (i.e., the Arabs).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.22]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 22

Narrated Anas:

The Prophet stayed for three days between Khaibar and Medina, and there he consummated his marriage to Safiyya bint Huyai. I invited the Muslims to the wedding banquet in which neither meat nor bread was offered. He ordered for leather dining-sheets to be spread, and dates, dried yoghurt and butter were laid on it, and that was the Prophet's wedding banquet. The Muslims wondered, "Is she (Saffiyya) considered as his wife or his slave girl?" Then they said, "If he orders her to veil herself, she will be one of the mothers of the Believers; but if he does not order her to veil herself, she will be a slave girl. So when the Prophet proceeded from there, he spared her a space behind him (on his she-camel) and put a screening veil between her and the people.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.23]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 23

Narrated Anas bin Malik:

Allah's Apostle manumitted Safiyya and regarded her manumission as her Mahr.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.24]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 24

Narrated Sahl bin Sad As-Sa'idi:

A woman came to Allah's Apostle and said, "O Allah's Apostle! I have come to give you myself in marriage (without Mahr)." Allah's Apostle looked at her. He looked at her carefully and fixed his glance on her and then lowered his head. When the lady saw that he did not say anything, she sat down. A man from his companions got up and said, "O Allah's Apostle! If you are not in need of her, then marry her to me." The Prophet said, "Have you got anything to offer?" The man said, "No, by Allah, O Allah's Apostle!" The Prophet said (to him), "Go to your family and see if you have something." The man went and returned, saying, "No, by Allah, I have not found anything." Allah's Apostle said, "(Go again) and look for something, even if it is an iron ring." He went again and returned, saying, "No, by Allah, O Allah's Apostle! I could not find even an iron ring, but this is my Izar (waist sheet)." He had no rida. He added, "I give half of it to her." Allah's Apostle said, "What will she do with your Izar? If you wear it, she will be naked, and if she wears it, you will be naked." So that man sat down for a long while and then got up (to depart). When Allah's Apostle saw him going, he ordered that he be called back. When he came, the Prophet said, "How much of the Quran do you know?" He said, "I know such Sura and such Sura," counting them. The Prophet said, "Do you know them by heart?" He replied, "Yes." The Prophet said, "Go, I marry her to you for that much of the Quran which you have."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.25]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 25

Narrated 'Aisha:

Abu Hudhaifa bin 'Utba bin Rabi'a bin Abdi Shams who had witnessed the battle of Badr along with the Prophet adopted Salim as his son, to whom he married his niece, Hind bint Al-Walid bin 'Utba bin Rabi'a; and Salim was the freed slave of an Ansar woman, just as the Prophet had adopted Zaid as his son. It was the custom in the Pre-lslamic Period that if somebody adopted a boy, the people would call him the son of the adoptive father and he would be the latter's heir. But when Allah revealed the Divine Verses: 'Call them by (the names of) their fathers . . . your freed-slaves,' (33.5) the adopted persons were called by their fathers' names. The one whose father was not known, would be regarded as a Maula and your brother in religion. Later on Sahla bint Suhail bin 'Amr Al-Quraishi Al-'Amiri--and she was the wife of Abu- Hudhaifa bin 'Utba--came to the Prophet and said, "O Allah's Apostle! We used to consider Salim as our (adopted) son, and now Allah has revealed what you know (regarding adopted sons)." The sub-narrator then mentioned the rest of the narration.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.26]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 26

Narrated 'Aisha:

Allah's Apostle entered upon Dubaa bint Az-Zubair and said to her, "Do you have a desire to perform the Hajj?" She replied, "By Allah, I feel sick." He said to her, "Intend to perform Hajj and stipulate something by saying, 'O Allah, I will finish my Ihram at any place where You stop me (i.e. I am unable to go further)." She was the wife of Al-Miqdad bin Al-Aswad.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.27]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 27

Narrated Abu Huraira:

The Prophet said, "A woman is married for four things, i.e., her wealth, her family status, her beauty and her religion. So you should marry the religious woman (otherwise) you will be a losers.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.28]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 28

Narrated Sahl:

A man passed by Allah's Apostle and Allah s Apostle asked (his companions) "What do you say about this (man)?" They replied "If he asks for a lady's hand, he ought to be given her in marriage; and if he intercedes (for someone) his intercessor should be accepted; and if he speaks, he should be listened to." Allah's Apostle kept silent, and then a man from among the poor Muslims passed by, an Allah's Apostle asked (them) "What do you say about this man?" They replied, "If he asks for a lady's hand in marriage he does not deserve to be married, and he intercedes (for someone), his intercession should not be accepted; And if he speaks, he should not be listened to.' Allah's Apostle said, "This poor man is better than so many of the first as filling the earth.'


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.29]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 29

Narrated 'Ursa:

that he asked 'Aisha regarding the Verse: 'If you fear that you shall not be able to deal justly with the orphans (4.3) She said, "O my nephew! This Verse refers to the orphan girl who is under the guardianship of her guardian who likes her beauty and wealth and wishes to (marry her and) curtails her Mahr. Such guardians have been forbidden to marry them unless they do justice by giving them their full Mahr, and they have been ordered to marry other than them. The people asked for the verdict of Allah's Apostle after that, so Allah revealed: 'They ask your instruction concerning the women . . . whom you desire to marry.' (4.127) So Allah revealed to them that if the orphan girl had beauty and wealth, they desired to marry her and for her family status. They can only marry them if they give them their full Mahr. And if they had no desire to marry them because of their lack of wealth and beauty, they would leave them and marry other women. So, as they used to leave them, when they had no interest, in them, they were forbidden to marry them when they had such interest, unless they treated them justly and gave them their full Mahr Apostle said, 'If at all there is evil omen, it is in the horse, the woman and the house." a lady is to be warded off. And the Statement of Allah: 'Truly, among your wives and your children, there are enemies for you (i.e may stop you from the obedience of Allah)' (64.14)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.30]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 30

Narrated Abdullah bin 'Umar:

Allah's Apostle said, "Evil omen is in the women, the house and the horse.'


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.31]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 31

Narrated Ibn 'Umar:

Evil omen was mentioned before the Prophet: The Prophet said, "If there is evil omen in anything, it is in the house, the woman and the horse."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.32]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 32

Narrated Sahl bin Sad:

Allah's Apostle said, "If at all there is bad omen, it is in the horse, the woman, and the house."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.33]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 33

Narrated Usama bin Zaid:

The Prophet said, "After me I have not left any affliction more harmful to men than women."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.34]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 34

Narrated 'Aisha :

Three principles were established because of Barira: (i) When Banra was manumitted she was given the option (to remain with her slave husband or not). (ii) Allah's Apostle said "The Wala of the slave) is for the one who manumits (the slave). (iii) When Allah's Apostle entered (the house), he saw a cooking pot on the fire but he was given bread and meat soup from the soup of the home. The Prophet said, "Didn't I see the cooking pot (on the fire)?" It was said, "That is the meat given in charity to Barira, and you do not eat the (things given in) charity." The Prophet said, "It is an object of charity for Barira, and it is a present for us."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.35]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 35

Narrated Aisha"

(regarding) the Verse: 'And if you fear that you shall not be able to deal justly with the orphans...' (4.3) It is about the orphan girl who is in the custody of a man who is her guardian, and he intends to marry her because of her wealth, but he treats her badly and does not manage her property fairly and honestly. Such a man should marry women of his liking other than her, two or three or four. 'Prohibited to you (for marriage) are: ...your foster-mothers (who suckled you).' (4.23) Marriage is prohibited between persons having a foster suckling relationship corresponding to a blood relationship which renders marriage unlawful.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.36]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 36

Narrated 'Aisha:

(the wife of the Prophet) that while Allah's Apostle was with her, she heard a voice of a man asking permission to enter the house of Hafsa. 'Aisha added: I said, "O Allah's Apostle! This man is asking permission to enter your house." The Prophet said, "I think he is so-and-so," naming the foster-uncle of Hafsa. 'Aisha said, "If so-and-so," naming her foster uncle, "were living, could he enter upon me?" The Prophet said, "Yes, for foster suckling relations make all those things unlawful which are unlawful through corresponding birth (blood) relations."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.37]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 37

Narrated Ibn 'Abbas:

It was said to the Prophet, "Won't you marry the daughter of Hamza?" He said, "She is my foster niece (brother's daughter). "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.38]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 38

Narrated Um Habiba:

(daughter of Abu Sufyan) I said, "O Allah's Apostle! Marry my sister. the daughter of Abu Sufyan." The Prophet said, "Do you like that?" I replied, "Yes, for even now I am not your only wife and I like that my sister should share the good with me." The Prophet said, "But that is not lawful for me." I said, We have heard that you want to marry the daughter of Abu Salama." He said, "(You mean) the daughter of Um Salama?" I said, "Yes." He said, "Even if she were not my step-daughter, she would be unlawful for me to marry as she is my foster niece. I and Abu Salama were suckled by Thuwaiba. So you should not present to me your daughters or your sisters (in marriage)." Narrated 'Ursa; Thuwaiba was the freed slave girl of Abu Lahb whom he had manumitted, and then she suckled the Prophet. When Abu Lahb died, one of his relatives saw him in a dream in a very bad state and asked him, "What have you encountered?" Abu Lahb said, "I have not found any rest since I left you, except that I have been given water to drink in this (the space between his thumb and other fingers) and that is because of my manumitting Thuwaiba."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.39]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 39

Narrated 'Aisha:

that the Prophet entered upon her while a man was sitting with her. Signs of anger seemed to appear on his face as if he disliked that. She said, "Here is my (foster) brother." He said, "Be sure as to who is your foster brother, for foster suckling relationship is established only when milk is the only food of the child."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.40]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 40

Narrated Aisha:

that Aflah the brother of Abu Al-Qu'ais, her foster uncle, came, asking permission to enter upon her after the Verse of Al-Hijab (the use of veils by women) was revealed. 'Aisha added: I did not allow him to enter, but when Allah's Apostle came, I told him what I had done, and he ordered me to give him permission.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.41]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 41

Narrated 'Uqba bin Al-Harith:

I married a woman and then a black lady came to us and said, "I have suckled you both (you and your wife)." So I came to the Prophet and said, "I married so-and-so and then a black lady came to us and said to me, 'I have suckled both of you.' But I think she is a liar." The Prophet turned his face away from me and I moved to face his face, and said, "She is a liar." The Prophet said, "How (can you keep her as your wife) when that lady has said that she has suckled both of you? So abandon (i.e., divorce) her (your wife)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.42]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 42

Narrated Um Habiba:

I said, "O Allah's Apostle! Do you like to have (my sister) the daughter of Abu Sufyan?" The Prophet said, "What shall I do (with her)?" I said, "Marry her." He said, "Do you like that?" I said, "(Yes), for even now I am not your only wife, so I like that my sister should share you with me." He said, "She is not lawful for me (to marry)." I said, "We have heard that you want to marry." He said, "The daughter of Um Salama?" I said, "Yes." He said, "Even if she were not my stepdaughter, she should be unlawful for me to marry, for Thuwaiba suckled me and her father (Abu Salama). So you should neither present your daughters, nor your sisters, to me."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.43]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 43

Narrated Um Habiba:

I said, "O Allah's Apostle! Marry my sister, the daughter of Abu Sufyan." He said, "Do you like that?" I said, "Yes, for even now I am not your only wife; and the most beloved person to share the good with me is my sister." The Prophet said, "But that is not lawful for me (i.e., to be married to two sisters at a time.)" I said, "O Allah's Apostle! By Allah, we have heard that you want to marry Durra, the daughter of Abu Salama." He said, "You mean the daughter of Um Salama?" I said, "Yes." He said, "By Allah ! Even if she were not my stepdaughter, she would not be lawful for me to marry, for she is my foster niece, for Thuwaiba has suckled me and Abu Salama; so you should neither present your daughters, nor your sisters to me."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.44]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 44

Narrated Jabir:

Allah's Apostle forbade that a woman should be married to man along with her paternal or maternal aunt.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.45]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 45

Narrated Abu Huraira:

Allah's Apostle said, "A woman and her paternal aunt should not be married to the same man; and similarly, a woman and her maternal aunt should not be married to the same man."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.46]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 46

Narrated Abu Huraira:

The Prophet forbade that a woman should be married to a man along with her paternal aunt or with her maternal aunt (at the same time). Az-Zuhri (the sub-narrator) said: There is a similar order for the paternal aunt of the father of one's wife, for 'Ursa told me that 'Aisha said, "What is unlawful because of blood relations, is also unlawful because of the corresponding foster suckling relations."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.47]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 47

Narrated Ibn 'Umar :

Allah's Apostle forbade Ash-Shighar, which means that somebody marries his daughter to somebody else, and the latter marries his daughter to the former without paying Mahr.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.48]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 48

Narrated Hisham's father:

Khaula bint Hakim was one of those ladies who presented themselves to the Prophet for marriage. 'Aisha said, "Doesn't a lady feel ashamed for presenting herself to a man?" But when the Verse: "(O Muhammad) You may postpone (the turn of) any of them (your wives) that you please,' (33.51) was revealed, " 'Aisha said, 'O Allah's Apostle! I do not see, but, that your Lord hurries in pleasing you.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.49]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 49

Narrated Ibn 'Abbas:

The Prophet got married while he was in the state of Ihram.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.50]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 50

Narrated 'Ali:

I said to Ibn 'Abbas, "During the battle of Khaibar the Prophet forbade (Nikah) Al-Mut'a and the eating of donkey's meat."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.51]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 51

Narrated Abu Jamra:

I heard Ibn Abbas (giving a verdict) when he was asked about the Mut'a with the women, and he permitted it (Nikah-al-Mut'a). On that a freed slave of his said to him, "That is only when it is very badly needed and women are scarce." On that, Ibn 'Abbas said, "Yes."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.52]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 52

Narrated Jabir bin 'Abdullah and Salama bin Al-Akwa':

While we were in an army, Allah's Apostle came to us and said, "You have been allowed to do the Mut'a (marriage), so do it." Salama bin Al-Akwa' said: Allah's Apostle's said, "If a man and a woman agree (to marry temporarily), their marriage should last for three nights, and if they like to continue, they can do so; and if they want to separate, they can do so." I do not know whether that was only for us or for all the people in general. Abu Abdullah (Al-Bukhari) said: 'Ali made it clear that the Prophet said, "The Mut'a marriage has been cancelled (made unlawful)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.53]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 53

Narrated Thabit Al-Banani:

I was with Anas while his daughter was present with him. Anas said, "A woman came to Allah's Apostle and presented herself to him, saying, 'O Allah's Apostle, have you any need for me (i.e. would you like to marry me)?' "Thereupon Anas's daughter said, "What a shameless lady she was ! Shame! Shame!" Anas said, "She was better than you; she had a liking for the Prophet so she presented herself for marriage to him."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.54]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 54

Narrated Sahl bin Sad:

A woman presented herself to the Prophet (for marriage). A man said to him, "O Allah's Apostle! (If you are not in need of her) marry her to me." The Prophet said, "What have you got?" The man said, "I have nothing." The Prophet said (to him), "Go and search for something) even if it were an iron ring." The man went and returned saying, "No, I have not found anything, not even an iron ring; but this is my (Izar) waist sheet, and half of it is for her." He had no Rida' (upper garment). The Prophet said, "What will she do with your waist sheet? If you wear it, she will have nothing over her; and if she wears it, you will have nothing over you." So the man sat down and when he had sat a long time, he got up (to leave). When the Prophet saw him (leaving), he called him back, or the man was called (for him), and he said to the man, "How much of the Quran do you know (by heart)?" The man replied I know such Sura and such Sura (by heart)," naming the Suras The Prophet said, "I have married her to you for what you know of the Quran "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.55]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 55

Narrated 'Abdullah bin 'Umar :

'Umar bin Al-Khattab said, "When Hafsa bint 'Umar became a widow after the death of (her husband) Khunais bin Hudhafa As-Sahmi who had been one of the companions of the Prophet, and he died at Medina. I went to 'Uthman bin 'Affan and presented Hafsa (for marriage) to him. He said, "I will think it over.' I waited for a few days, then he met me and said, 'It seems that it is not possible for me to marry at present.' " 'Umar further said, "I met Abu Bakr As-Siddique and said to him, 'If you wish, I will marry my daughter Hafsa to you." Abu Bakr kept quiet and did not say anything to me in reply. I became more angry with him than with 'Uthman. I waited for a few days and then Allah's Apostle asked for her hand, and I gave her in marriage to him. Afterwards I met Abu Bakr who said, 'Perhaps you became angry with me when you presented Hafsa to me and I did not give you a reply?' I said, 'Yes.' Abu Bakr said, 'Nothing stopped me to respond to your offer except that I knew that Allah's Apostle had mentioned her, and I never wanted to let out the secret of Allah's Apostle. And if Allah's Apostle had refused her, I would have accepted her.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.56]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 56

Narrated Zainab bint Salama:

Um Habiba said to Allah's Apostle "We have heard that you want to marry Durra bint Abu-Salama." Allah's Apostle said, "Can she be married along with Um Salama (her mother)? Even if I have not married Um Salama, she would not be lawful for me to marry, for her father is my foster brother." 'And there is no blame on you if you make hint of betrothal or conceal it in your hearts. Allah is Oft-Forgiving, Most Forbearing.' (2.235) Ibn 'Abbas said, "Hint your intention of marrying' is made by saying (to the widow) for example: "I want to marry, and I wish that Allah will make a righteous lady available for me.' " Al-Qasim said: One may say to the widow: 'I hold all respect for you, and I am interested in you; Allah will bring you much good, or something similar 'Ata said: One should hint his intention, and should not declare it openly. One may say: 'I have some need. Have good tidings. Praise be to Allah; you are fit to remarry.' She (the widow) may say in reply: I am listening to what you say,' but she should not make a promise. Her guardian should not make a promise (to somebody to get her married to him) without her knowledge. But if, while still in the Iddat period, she makes a promise to marry somebody, and he ultimately marries her, they are not to be separated by divorce (i.e., the marriage is valid).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.57]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 57

Narrated 'Aisha:

Allah's Apostle said (to me), "You were shown to me in a dream. An angel brought you to me, wrapped in a piece of silken cloth, and said to me, 'This is your wife.' I removed the piece of cloth from your face, and there you were. I said to myself. 'If it is from Allah, then it will surely be.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.58]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 58

Narrated Sahl bin Sad:

A woman came to Allah's Apostle and said, "O Allah's Apostle! I have come to you to present myself to you (for marriage)." Allah's Apostle glanced at her. He looked at her carefully and fixed his glance on her and then lowered his head. When the lady saw that he did not say anything, she sat down. A man from his companions got up and said, "O Allah's Apostle! If you are not in need of her, then marry her to me." The Prophet said, "Have you got anything to offer." The man said, 'No, by Allah, O Allah's Apostle!" The Prophet said (to him), "Go to your family and try to find something." So the man went and returned, saying, "No, by Allah, O Allah's Apostle! I have not found anything." The Prophet said, "Go again and look for something, even if it were an iron ring." He went and returned, saying, "No, by Allah, O Allah's Apostle! I could not find even an iron ring, but this is my Izar (waist sheet).' He had no Rida (upper garment). He added, "I give half of it to her." Allah's Apostle said "What will she do with your Izar? If you wear it, she will have nothing over herself thereof (will be naked); and if she wears it, then you will have nothing over yourself thereof ' So the man sat for a long period and then got up (to leave). When Allah's Apostle saw him leaving, he ordered that he e called back. When he came, the Prophet asked (him), "How much of the Qur'an do you know (by heart)?" The man replied, I know such Sura and such Sura and such Sura," naming the suras. The Prophet said, "Can you recite it by heart?" He said, 'Yes." The Prophet said, "Go I let you marry her for what you know of the Quran (as her Mahr).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.59]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 59

Narrated 'Aisha:

(as regards the Verse): 'And about what is recited unto you in the Book, concerning orphan girls to whom you give not the prescribed portions and yet, whom you desire to marry.' (4.127) This Verse is about the female orphan who is under the guardianship of a man with whom she shares her property and he has more right over her (than anybody else) but does not like to marry her, so he prevents her, from marrying somebody else, lest he should share the property with him.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.60]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 60

Narrated 'Abdullah bin 'Umar:

When Hafsa, 'Umar's daughter became a widow because of the death of her (husband) Ibn Hudhafa As-Sahmi who was one of the companion of the Prophet and the one of the Badr warriors and died at Medina, 'Umar said, "I met 'Uthman bin 'Affan and gave him an offer, saying, 'If you wish, I will marry Hafsa to you.' He said. 'I will think it over' I waited for a few days, then he met me and said, 'I have made up my mind not to marry at present' "Umar added, "Then I met Abu Bakr and said to him, 'If you wish, I will marry Hafsa to you.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.61]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 61

Narrated Al-Hasan:

concerning the Verse: 'Do not prevent them' (2.232) Ma'qil bin Yasar told me that it was revealed in his connection. He said, "I married my sister to a man and he divorced her, and when her days of 'Idda (three menstrual periods) were over, the man came again and asked for her hand, but I said to him, 'I married her to you and made her your bed (your wife) and favored you with her, but you divorced her. Now you come to ask for her hand again? No, by Allah, she will never go back to you (again)!' That man was not a bad man and his wife wanted to go back to him. So Allah revealed this Verse: 'Do not prevent them.' (2.232) So I said, 'Now I will do it (let her go back to him), O Allah's Apostle."So he married her to him again.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.62]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 62

Narrated 'Aisha:

(regarding His Statement): 'They ask your instruction concerning the women. Say: Allah instructs you about them ...' (4.127) It is about the female orphan who is under the guardianship of a man with whom she shares her property and he does not want to marry her and dislikes that someone else should marry her, lest he should share the property with him, so he prevents her from marrying. So Allah forbade such a guardian to do so (i.e. to prevent her from marrying).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.63]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 63

Narrated Sahl bin Sad:

While we were sitting in the company of the Prophet a woman came to him and presented herself (for marriage) to him. The Prophet looked at her, lowering his eyes and raising them, but did not give a reply. One of his companions said, "Marry her to me O Allah's Apostle!" The Prophet asked (him), "Have you got anything?" He said, "I have got nothing." The Prophet said, "Not even an iron ring?" He Sad, "Not even an iron ring, but I will tear my garment into two halves and give her one half and keep the other half." The Prophet; said, "No. Do you know some of the Quran (by heart)?" He said, "Yes." The Prophet said, "Go, I have agreed to marry her to you with what you know of the Qur'an (as her Mahr)." 'And for those who have no courses (i.e. they are still immature). (65.4) And the 'Iddat for the girl before puberty is three months (in the above Verse).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.64]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 64

Narrated 'Aisha:

that the Prophet married her when she was six years old and he consummated his marriage when she was nine years old, and then she remained with him for nine years (i.e., till his death).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.65]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 65

Narrated 'Aisha:

that the Prophet married her when she was six years old and he consummated his marriage when she was nine years old. Hisham said: I have been informed that 'Aisha remained with the Prophet for nine years (i.e. till his death)." what you know of the Quran (by heart)'


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.66]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 66

Narrated Sahl bin Sad:

A woman came to Allah's Apostle and said, "I present myself (to you) (for marriage). She stayed for a long while, then a man said, "If you are not in need of her then marry her to me." The Prophet said, "Have you got anything m order to pay her Mahr?" He said, "I have nothing with me except my Izar (waist sheet)." The Prophet said, "If you give her your Izar, you will have no Izar to wear, (so go) and search for something. He said, "I could not find anything." The Prophet said, "Try (to find something), even if it were an iron ring But he was not able to find (even that) The Prophet said (to him). "Do you memorize something of the Qur'an?" "Yes. ' he said, "such Sura and such Sura," naming those Suras The Prophet said, "We have married her to you for what you know of the Quran (by heart)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.67]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 67

Narrated Abu Huraira:

The Prophet said, "A matron should not be given in marriage except after consulting her; and a virgin should not be given in marriage except after her permission." The people asked, "O Allah's Apostle! How can we know her permission?" He said, "Her silence (indicates her permission)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.68]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 68

Narrated 'Aisha:

I said, "O Allah's Apostle! A virgin feels shy." He said, "Her consent is (expressed by) her silence."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.69]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 69

Narrated Khansa bint Khidam Al-Ansariya:

that her father gave her in marriage when she was a matron and she disliked that marriage. So she went to Allah's Apostle and he declared that marriage invalid.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.70]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 70

Narrated Abdur-Rahman bin Yazid and Majammi bin Yazid.

the same ,Hadith above: A man called Khidam married a daughter of his (to somebody) against her consent. 'If you fear that you shall not be able to deal justly with the orphan girls then marry (other) women of your choice.' (4.3) And if somebody says to the guardian (of a woman), "Marry me to so-and-so," and the guardian remained silent or said to him, "What have you got?" And the other said, "I have so much and so much (Mahr)," or kept quiet, and then the guardian said, "I have married her to you," then the marriage is valid (legal). This narration was told by Sahl on the authority of the Prophet


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.71]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 71

Narrated 'Ursa bin Az-Zubair:

that he asked 'Aisha, saying to her, "O Mother! (In what connection was this Verse revealed):

'If you fear that you shall not be able to deal justly with orphan girls (to the end of the verse) that your right hands possess?" (4.3) Aisha said, "O my nephew! It was about the female orphan under the protection of her guardian who was interested in her beauty and wealth and wanted to marry her with a little or reduced Mahr. So such guardians were forbidden to marry female orphans unless they deal with them justly and give their full Mahr; and they were ordered to marry women other than them."'Aisha added, "(Later) the people asked Allah's Apostle, for instructions, and then Allah revealed: 'They ask your instruction concerning the women . . . And yet whom you desire to marry.' (4.127) So Allah revealed to them in this Verse that-if a female orphan had wealth and beauty, they desired to marry her and were interested in her noble descent and the reduction of her Mahr; but if she was not desired by them because of her lack in fortune and beauty they left her and married some other woman. So, as they used to leave her when they had no interest in her, they had no right to marry her if they had the desire to do so, unless they deal justly with her and gave her a full amount of Mahr."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.72]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 72

Narrated Sahl:

A woman came to the Prophet,, and presented herself to him (for marriage). He said, "I am not in need of women these days." Then a man said, "O Allah's Apostle! Marry her to me." The Prophet asked him, "What have you got?" He said, "I have got nothing." The Prophet said, "Give her something, even an iron ring." He said, "I have got nothing." The Prophet asked (him), "How much of the Quran do you know (by heart)?" He said, "So much and so much." The Prophet said, "I have married her to you for what you know of the Quran."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.73]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 73

Narrated Ibn 'Umar:

The Prophet decreed that one should not try to cancel a bargain already agreed upon between some other persons (by offering a bigger price). And a man should not ask for the hand of a girl who is already engaged to his Muslim brother, unless the first suitor gives her up, or allows him to ask for her hand.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.74]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 74

Narrated Abu Huraira:

The Prophet said, "Beware of suspicion (about others), as suspicion is the falsest talk, and do not spy upon each other, and do not listen to the evil talk of the people about others' affairs, and do not have enmity with one another, but be brothers. And none should ask for the hand of a girl who is already engaged to his (Muslim) brother, but one should wait till the first suitor marries her or leaves her."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.75]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 75

Narrated Abdullah bin Umar:

"When Hafsa became a widow," Umar said, "I met Abu Bakr and said to him, 'If you wish I will marry Hafsa bint 'Umar to you.' I waited for a few days then Allah's Apostle asked for her hand. Later Abu Bakr met me and said, 'Nothing stopped me from returning to you concerning your offer except that I knew that Allah's Apostle had mentioned (his wish to marry) her, and I could never let out the secret of Allah's Apostle . If he had left her, I would have accepted her.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.76]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 76

Narrated Ibn 'Umar:

Two men came from the east and delivered speeches, and the Prophet said, "Some eloquent speech has the in fluency of magic (e.g., some people refuse to do something and then a good eloquent speaker addresses them and then they agree to do that very thing after his speech). "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.77]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 77

Narrated Ar-Rabi':

(the daughter of Muawwidh bin Afra) After the consummation of my marriage, the Prophet came and sat on my bed as far from me as you are sitting now, and our little girls started beating the tambourines and reciting elegiac verses mourning my father who had been killed in the battle of Badr. One of them said, "Among us is a Prophet who knows what will happen tomorrow." On that the Prophet said, "Leave this (saying) and keep on saying the verses which you had been saying before."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.78]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 78

Narrated Anas:

Abdur Rahman bin 'Auf married a woman and gave her gold equal to the weight of a date stone (as Mahr). When the Prophet noticed the signs of cheerfulness of the marriage (on his face) and asked him about it, he said, "I have married a woman and gave (her) gold equal to a date stone in weight (as Mahr)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.79]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 79

Narrated Sahl bin Sad As-Sa'idi:

While I was (sitting) among the people in the company of Allah's Apostle a woman stood up and said, "O Allah's Apostle! She has given herself in marriage to you; please give your opinion of her." The Prophet did not give her any reply. She again stood up and said, "O Allah's Apostle! She has given herself (in marriage) to you; so please give your opinion of her. The Prophet did not give her any reply. She again stood up for the third time and said, "She has given herself in marriage to you: so give your opinion of her." So a man stood up and said, "O Allah's Apostle! Marry her to me." The Prophet asked him, "Have you got anything?" He said, "No." The Prophet said, "Go and search for something, even if it were an iron ring." The man went and searched and then returned saying, "I could not find anything, not even an iron ring." Then the Prophet said, "Do you know something of the Quran (by heart)?" He replied, "I know (by heart) such Sura and such Sura." The Prophet said, "Go! I have married her to you for what you know of the Quran (by heart)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.80]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 80

Narrated Sahl bin Sad:

The Prophet said to a man, "Marry, even with (a Mahr equal to) an iron ring."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.81]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 81

Narrated 'Uqba:

The Prophet said: "The stipulations most entitled to be abided by are those with which you are given the right to enjoy the (women's) private parts (i.e. the stipulations of the marriage contract)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.82]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 82

Narrated Abu Huraira:

The Prophet said, "It is not lawful for a woman (at the time of wedding) to ask for the divorce of her sister (i.e. the other wife of her would-be husband) in order to have everything for herself, for she will take only what has been written for her."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.83]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 83

Narrated Anas bin Malik:

'Abdur-Rahman bin 'Auf came to Allah's Apostle and he had marks of Sufra (yellow perfume). Allah's Apostle asked him (about those marks). 'AbdurRahman bin Auf told him that he had married a woman from the Ansar. The Prophet asked, "How much Mahr did you pay her?" He said, "I paid gold equal to the weight of a date stone." Allah's Apostle said to him, "Give a wedding banquet, even if with one sheep."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.84]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 84

Narrated Anas:

The Prophet offered a wedding banquet on the occasion of his marriage to Zainab, and provided a good meal for the Muslims. Then he went out as was his custom on marrying, he came to the dwelling places of the mothers of the Believers (i.e. his wives) invoking good (on them), and they were invoking good (on him). Then he departed (and came back) and saw two men (still sitting there). So he left again. I do not remember whether I informed him or he was informed (by somebody else) of their departure)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.85]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 85

Narrated Anas:

The Prophet saw the traces of Sufra (yellow perfume) on Abdur-Rahman bin 'Auf and said, "What is this?" 'Abdur-Rahman, said, "I have married a woman and have paid gold equal to the weight of a datestone (as her Mahr). The Prophet said to him, "May Allah bless you: Offer a wedding banquet even with one sheep."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.86]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 86

Narrated 'Aisha:

When the Prophet married me, my mother came to me and made me enter the house where I saw some women from the Ansar who said, "May you prosper and have blessings and have good omen."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.87]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 87

Narrated Abu Huraira:

The Prophet said, "A prophet among the prophets went for a military expedition and said to his people: "A man who has married a lady and wants to consummate his marriage with her and he has not done so yet, should not accompany me.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.88]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 88

Narrated 'Ursa:

The Prophet wrote the (marriage contract) with 'Aisha while she was six years old and consummated his marriage with her while she was nine years old and she remained with him for nine years (i.e. till his death).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.89]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 89

Narrated Anas:

The Prophet stayed for three days at a place between Khaibar and Medina, and there he consummated his marriage with Safiyya bint Huyay. I invited the Muslims to a banquet which included neither meat nor bread. The Prophet ordered for the leather dining sheets to be spread, and then dates, dried yogurt and butter were provided over it, and that was the Walima (banquet) of the Prophet. The Muslims asked whether Safiyya would be considered as his wife or as a slave girl of what his right hands possessed. Then they said, "If the Prophet screens her from the people, then she Is the Prophet's wife but if he does not screen her, then she is a slave girl." So when the Prophet proceeded, he made a place for her (on the camel) behind him and screened her from people.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.90]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 90

Narrated Aisha:

When the Prophet married me, my mother came to me and made me enter the house (of the Prophet) and nothing surprised me but the coming of Allah's Apostle to me in the forenoon.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.91]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 91

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "Did you get Anmat?" I said, 'O Allah's Apostle! From where can we have Anmat?" The Prophet said, "Soon you will have them Anmat)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.92]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 92

Narrated Anas bin Malik:

"Whenever the Prophet passed by (my mother Um-Sulaim) he used to enter her and greet her. Anas further said: Once the Prophet way a bridegroom during his marriage with Zainab, Um Sulaim said to me, "Let us give a gift to Allah's Apostle ." I said to her, "Do it." So she prepared Haisa (a sweet dish) made from dates, butter and dried yoghurt and she sent it with me to him. I took it to him and he said, "Put it down," and ordered me to call some men whom he named, and to invite whomever I would meet. I did what he ordered me to do, and when I returned, I found the house crowded with people and saw the Prophet keeping his hand over the Haisa and saying over it whatever Allah wished (him to say). Then he called the men in batches of ten to eat of it, and he said to them, "Mention the Name of Allah, and each man should eat of the dish the nearest to him." When all of them had finished their meals, some of them left and a few remained there talking, over which I felt unhappy. Then the Prophet went out towards the dwelling places (of his wives) and I too, went out after him and told him that those people had left. Then he returned and entered his dwelling place and let the curtains fall while I was in (his) dwelling place, and he was reciting the Verses:-- 'O you who believe! Enter not the Prophet's house until leave is given you for a meal, (and then) not (as early as) to what for its preparation. But when you are invited, enter, and when you have taken your meals, disperse without sitting for a talk. Verily such (behavior) annoys the Prophet; and he would be shy of (asking) you (to go), but Allah is not shy of (telling you) the Truth.' (33-53) Abu Uthman said: Anas said, "I served the Prophet for ten years."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.93]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 93

Narrated 'Aisha:

that she borrowed a necklace from Asma' and then it got lost. So Allah's Apostle

sent some people from his companions in search of it. In the meantime the stated time for the prayer became due and they offered their prayer without ablution. When they came to the Prophet, they complained about it to him, so the Verse regarding Tayammum was revealed .

Usaid bin Hudair said, "(O 'Aisha!) may Allah bless you with a good reward, for by Allah, never did a difficulty happen in connection with you, but Allah made an escape from it for you, and brought Allah's Blessings for the Muslims."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.94]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 94

Narrated Ibn Abbas:

The Prophet said, "If anyone of you, when having sexual intercourse with his wife, says: Bismillah, Allahumma jannibni-Sh-Shaitan wa jannib-ish-Shaitan ma razaqtana, and if it is destined that they should have a child, then Satan will never be able to harm him."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.95]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 95

Narrated Anas bin Malik:

I was ten years old when Allah's Apostle arrived at Medina. My mother and aunts used to urge me to serve the Prophet regularly, and I served him for ten years. When the Prophet died I was twenty years old, and I knew about the order of Al-Hijab (veiling of ladies) more than any other person when it was revealed. It was revealed for the first time when Allah's Apostle had consummated his marriage with Zainab bint Jahsh. When the day dawned, the Prophet was a bridegroom and he invited the people to a banquet, so they came, ate, and then all left except a few who remained with the Prophet for a long time. The Prophet got up and went out, and I too went out with him so that those people might leave too. The Prophet proceeded and so did I, till he came to the threshold of 'Aisha's dwelling place. Then thinking that these people have left by then, he returned and so did I along with him till he entered upon Zainab and behold, they were still sitting and had not gone. So the Prophet again went away and I went away along with him. When we reached the threshold of 'Aisha's dwelling place, he thought that they had left, and so he returned and I too, returned along with him and found those people had left. Then the Prophet drew a curtain between me and him, and the Verses of Al-Hijab were revealed.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.96]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 96

Narrated Anas:

When 'Abdur-Rahman bin 'Auf married an Ansari woman, the Prophet asked him, "How much Mahr did you give her?" 'Abdur-Rahman said, "Gold equal to the weight of a date stone." Anas added: When they (i.e. the Prophet and his companions) arrived at Medina, the emigrants stayed at the Ansar's houses. 'Abdur-Rahman bin 'Auf stayed at Sad bin Ar-Rabi's house. Sad said to 'Abdur-Rahman, "I will divide and share my property with you and will give one of my two wives to you." 'Abdur-Rahman said, "May Allah bless you, your wives and property (I am not in need of that; but kindly show me the way to the market)." So 'Abdur-Rahman went to the market and traded there gaining a profit of some dried yoghurt and butter, and married (an Ansari woman). The Prophet said to him, "Give a banquet, even if with one sheep."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.97]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 97

Narrated Anas:

The Prophet did not give a better wedding banquet on the occasion of marrying any of his wives than the one he gave on marrying Zainab, and that banquet was with (consisted of) one sheep.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.98]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 98

Narrated Anas:

Allah's Apostle manumitted Safiyya and then married her, and her Mahr was her manumission, and he gave a wedding banquet with Hais (a sort of sweet dish made from butter, cheese and dates).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.99]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 99

Narrated Anas:

The Prophet consummated his marriage with a woman (Zainab), so he sent me to invite men to the meals.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.100]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 100

Narrated Thabit:

The marriage of Zainab bint Jahash was mentioned in the presence of Anas and he said, "I did not see the Prophet giving a better banquet on marrying any of his wives than the one he gave on marrying Zainab. He then gave a banquet with one sheep."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.101]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 101

Narrated Safiyya bint Shaiba:

The Prophet gave a banquet with two Mudds of barley on marrying some of his wives. (1 Mudd= 1 3/4 of a kilogram) .


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.102]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 102

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "If anyone of you is invites to a wedding banquet, he must go for it (accept the invitation) ."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.103]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 103

Narrated Abu Musa:

The Prophet said, "Set the captives free, accept the invitation (to a wedding banquet), and visit the patients."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.104]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 104

Narrated Al-Bara' bin 'Azib:

The Prophet ordered us to do seven (things) and forbade us from seven. He ordered us to visit the patients, to follow the funeral procession, to reply to the sneezer (i.e., say to him, 'Yarhamuka-l-lah (May Allah bestow His Mercy upon you), if he says 'Al-hamdulillah' (Praise be to Allah), to help others to fulfill their oaths, to help the oppressed, to greet (whomever one should meet), and to accept the invitation (to a wedding banquet). He forbade us to wear golden rings, to use silver utensils, to use Mayathir (cushions of silk stuffed with cotton and placed under the rider on the saddle), the Qasiyya (linen clothes containing silk brought from an Egyptian town), the Istibraq (thick silk) and the Dibaj (another kind of silk). (See Hadith No. 539 and 753).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.105]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 105

Narrated Sahl bin Sad:

Abu Usaid As-Sa'di invited Allah's Apostle to his wedding party and his wife who was the bride, served them on that day. Do you know what drink she gave Allah's Apostle? She had soaked some dates for him (in water) overnight, and when he had finished his meal she gave him that drink (of soaked dates).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.106]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 106

Narrated Abu Huraira:

The worst food is that of a wedding banquet to which only the rich are invited while the poor are not invited. And he who refuses an invitation (to a banquet) disobeys Allah and His Apostle .


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.107]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 107

Narrated Abu Huraira:

The Prophet said, "If I am invited to a meal of trotters I will accept it; and if I am given a trotter as a present I will accept it."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.108]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 108

Narrated Nafi':

Abdullah bin 'Umar said, "Allah's Apostle said, 'Accept the marriage invitation if you are invited to it.' " Ibn 'Umar used to accept the invitation whether to a wedding banquet or to any other party, even when he was fasting.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.109]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 109

Narrated Anas bin Malik:

Once the Prophet saw some women and children coming from a wedding party. He got up energetically and happily and said, "By Allah! You (i.e., the Ansar) are the most beloved of all people to me."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.110]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 110

Narrated Aisha:

(the wife of the Prophet) I bought a cushion having on it pictures (of animals). When Allah's Apostle saw it, he stood at the door and did not enter. I noticed the sign of disapproval on his face and said, "O Allah's Apostle! I repent to Allah and His Apostle. What sin have I committed?' Allah's Apostle said. "What is this cushion?" I said, "I have bought it for you so that you may sit on it and recline on it." Allah's Apostle said, "The makers of these pictures will be punished on the Day of Resurrection, and it will be said to them, 'Give life to what you have created (i.e., these pictures).' " The Prophet added, "The Angels of (Mercy) do not enter a house in which there are pictures (of animals)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.111]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 111

Narrated Sahl:

When Abu Usaid As-Sa'idi got married, he invited the Prophet and his companions. None prepared the food for them and brought it to them but his wife. She soaked some dates in water in a stone pot overnight, and when the Prophet had finished his food, she provided him with that drink (of soaked dates).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.112]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 112

Narrated Sahl bin Sad:

Abu Usaid As-Sa'idi invited the Prophet to his wedding party and his wife served him on that day, and she was the bride. She said (or Sahl said), "Do you know what she soaked for Allah's Apostle? She soaked some dates for him (in water) in a drinking bowl overnight."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.113]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 113

Narrated Abu Huraira:

Allah's Apostle said, "The woman is like a rib; if you try to straighten her, she will break. So if you want to get benefit from her, do so while she still has some crookedness."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.114]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 114

Narrated Abu Huraira:

The Prophet said, "Whoever believes in Allah and the Last Day should not hurt (trouble) his neighbor. And I advise you to take care of the women, for they are created from a rib and the most crooked portion of the rib is its upper part; if you try to straighten it, it will break, and if you leave it, it will remain crooked, so I urge you to take care of the women."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.115]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 115

Narrated Ibn 'Umar:

During the lifetime of the Prophet we used to avoid chatting leisurely and freely with our wives lest some Divine inspiration might be revealed concerning us. But when the Prophet had died, we started chatting leisurely and freely (with them).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.116]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 116

Narrated 'Abdullah bin 'Umar:

The Prophet said, "Everyone of you is a guardian and everyone of you is responsible (for his wards). A ruler is a guardian and is responsible(for his subjects); a man is a guardian of his family and responsible (for them); a wife is a guardian of her husband's house and she is responsible (for it), a slave is a guardian of his master's property and is responsible (for that). Beware! All of you are guardians and are responsible (for your wards)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.117]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 117

Narrated 'Aisha:

Eleven women sat (at a place) and promised and contracted that they would not conceal anything of the news of their husbands. The first one said, "My husband is like the meat of a lean weak camel which is kept on the top of a mountain which is neither easy to climb, nor is the meat fat, so that one might put up with the trouble of fetching it." The second one said, "I shall not relate my husband's news, for I fear that I may not be able to finish his story, for if I describe him, I will mention all his defects and bad traits." The third one said, "My husband is a tall man; if I describe him (and he hears of that) he will divorce me, and if I keep quiet, he will neither divorce me nor treat me as a wife." The fourth one said, "My husband is a moderate person like the night of Tihama which is neither hot nor cold. I am neither afraid of him, nor am I discontented with him." The fifth one said, "My husband, when entering (the house) is a leopard, and when going out, is a lion. He does not ask about whatever is in the house." The sixth one said, "If my husband eats. he eats too much (leaving the dishes empty), and if he drinks he leaves nothing, and if he sleeps he sleeps alone (away from me) covered in garments and does not stretch his hands here and there so as to know how I fare (get along)." The seventh one said, "My husband is a wrong-doer or weak and foolish. All the defects are present in him. He may injure your head or your body or may do both." The eighth one said, "My husband is soft to touch like a rabbit and smells like a Zarnab (a kind of good smelling grass)." The ninth one said, "My husband is a tall generous man wearing a long strap for carrying his sword. His ashes are abundant and his house is near to the people who would easily consult him." The tenth one said, "My husband is Malik, and what is Malik? Malik is greater than whatever I say about him. (He is beyond and above all praises which can come to my mind). Most of his camels are kept at home (ready to be slaughtered for the guests) and only a few are taken to the pastures. When the camels hear the sound of the lute (or the tambourine) they realize that they are going to be slaughtered for the guests." The eleventh one said, "My husband is Abu Zar and what is Abu Zar (i.e., what should I say about him)? He has given me many ornaments and my ears are heavily loaded with them and my arms have become fat (i.e., I have become fat). And he has pleased me, and I have become so happy that I feel proud of myself. He found me with my family who were mere owners of sheep and living in poverty, and brought me to a respected family having horses and camels and threshing and purifying grain . Whatever I say, he does not rebuke or insult me. When I sleep, I sleep till late in the morning, and when I drink water (or milk), I drink my fill. The mother of Abu Zar and what may one say in praise of the mother of Abu Zar? Her saddle bags were always full of provision and her house was spacious. As for the son of Abu Zar, what may one say of the son of Abu Zar? His bed is as narrow as an unsheathed sword and an arm of a kid (of four months) satisfies his hunger. As for the daughter of Abu Zar, she is obedient to her father and to her mother. She has a fat well-built body and that arouses the jealousy of her husband's other wife. As for the (maid) slave girl of Abu Zar, what may one say of the (maid) slavegirl of Abu Zar? She does not uncover our secrets but keeps them, and does not waste our provisions and does not leave the rubbish scattered everywhere in our house." The eleventh lady added, "One day it so happened that Abu Zar went out at the time when the milk was being milked from the animals, and he saw a woman who had two sons like two leopards playing with her two breasts. (On seeing her) he divorced me and married her. Thereafter I married a noble man who used to ride a fast tireless horse and keep a spear in his hand. He gave me many things, and also a pair of every kind of livestock and said, 'Eat (of this), O Um Zar, and give provision to your relatives." She added, "Yet, all those things which my second husband gave me could not fill the smallest utensil of Abu Zar's." 'Aisha then said: Allah's Apostle said to me, "I am to you as Abu Zar was to his wife Um Zar."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.118]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 118

Narrated 'Ursa:

Aisha said, "While the Ethiopians were playing with their small spears, Allah's Apostle screened me behind him and I watched (that display) and kept on watching till I left on my own." So you may estimate of what age a little girl may listen to amusement.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.119]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 119

Narrated Ibn 'Abbas :

I had been eager to ask 'Umar bin Al-Khattab about the two ladies from among the wives of the Prophet regarding whom Allah said 'If you two (wives of the Prophet namely Aisha and Hafsa) turn in repentance to Allah, your hearts are indeed so inclined (to oppose what the Prophet likes). (66.4) till 'Umar performed the Hajj and I too, performed the Hajj along with him. (On the way) 'Umar went aside to answer the call of nature, and I also went aside along with him carrying a tumbler full of water, and when 'Umar had finished answering the call of nature, I poured water over his hands and he performed the ablution. Then I said to him, "O chief of the Believers! Who were the two ladies from among the wives of the Prophet regarding whom Allah said: 'If you two (wives of the Prophet) turn in repentance to Allah your hearts are indeed so inclined (to oppose what the Prophet likes)?" (66.4) He said, "I am astonished at your question, O Ibn Abbas. They were 'Aisha and Hafsa." Then 'Umar went on narrating the Hadith and said, "I and an Ansari neighbor of mine from Bani Umaiyya bin Zaid who used to live in Awali-al-Medina, used to visit the Prophet in turn. He used to go one day and I another day. When I went, I would bring him the news of what had happened that day regarding the Divine Inspiration and other things, and when he went, he used to do the same for me. We, the people of Quraish used to have the upper hand over our wives, but when we came to the Ansar, we found that their women had the upper hand over their men, so our women also started learning the ways of the Ansari women. I shouted at my wife and she retorted against me and I disliked that she should answer me back. She said to me, 'Why are you so surprised at my answering you back? By Allah, the wives of the Prophet answer him back and some of them may leave (does not speak to) him throughout the day till the night.' The (talk) scared me and I said to her, 'Whoever has done so will be ruined!' Then I proceeded after dressing myself, and entered upon Hafsa and said to her, 'Does anyone of you keep the Prophet angry till night?' She said, 'Yes.' I said, 'You are a ruined losing person! Don't you fear that Allah may get angry for the anger of Allah's Apostle and thus you will be ruined? So do not ask more from the Prophet and do not answer him back and do not give up talking to him. Ask me whatever you need and do not be tempted to imitate your neighbor (i.e., 'Aisha) in her manners for she is more charming than you and more beloved to the Prophet ." Umar added,"At that time a talk was circulating among us that (the tribe of) Ghassan were preparing their horses to invade us. My Ansari companion, on the day of his turn, went (to the town) and returned to us at night and knocked at my door violently and asked if I was there. I became horrified and came out to him. He said, 'Today a great thing has happened.' I asked, 'What is it? Have (the people of) Ghassan come?' He said, 'No, but (What has happened) is greater and more horrifying than that: Allah's Apostle; has divorced his wives. 'Umar added, "The Prophet kept away from his wives and I said "Hafsa is a ruined loser.' I had already thought that most probably this (divorce) would happen in the near future. So I dressed myself and offered the morning prayer with the Prophet and then the Prophet; entered an upper room and stayed there in seclusion. I entered upon Hafsa and saw her weeping. I asked, 'What makes you weep? Did I not warn you about that? Did the Prophet divorce you all?' She said, 'I do not know. There he is retired alone in the upper room.' I came out and sat near the pulpit and saw a group of people sitting around it and some of them were weeping. I sat with them for a while but could not endure the situation, so I went to the upper room where the Prophet; was and said to a black slave of his, 'Will you get the permission (of the Prophet ) for 'Umar (to enter)?' The slave went in, talked to the Prophet about it and then returned saying, 'I have spoken to the Prophet and mentioned you but he kept quiet.' Then I returned and sat with the group of people sitting near the pulpit. but I could not bear the situation and once again I said to the slave, 'Will you get the permission for 'Umar?' He went in and returned saying, 'I mentioned you to him but he kept quiet.' So I returned again and sat with the group of people sitting near the pulpit, but I could not bear the situation, and so I went to the slave and said, 'Will you get the permission for 'Umar?' He went in and returned to me saying, 'I mentioned you to him but he kept quiet.' When I was leaving, behold! The slave called me, saying, 'The Prophet has given you permission.' Then I entered upon Allah's Apostle and saw him Lying on a bed made of stalks of date palm leaves and there was no bedding between it and him. The stalks left marks on his side and he was leaning on a leather pillow stuffed with date-palm fires. I greeted him and while still standing I said, 'O Allah's Apostle! Have you divorced your wives?' He looked at me and said, 'No.' I said, 'Allah Akbar!' And then, while still standing, I said chatting, 'Will you heed what I say, O Allah's Apostle? We, the people of Quraish used to have power over our women, but when we arrived at Medina we found that the men (here) were overpowered by their women.' The Prophet smiled and then I said to him, 'Will you heed what I say, O Allah's Apostle? I entered upon Hafsa and said to her, "Do not be tempted to imitate your companion ('Aisha), for she is more charming than you and more beloved to the Prophet.' " The Prophet smiled for a second time. When I saw him smiling, I sat down. Then I looked around his house, and by Allah, I could not see anything of importance in his house except three hides, so I said, 'O Allah's Apostle! Invoke Allah to make your followers rich, for the Persians and the Romans have been made prosperous and they have been given (the pleasures of the world), although they do not worship Allah.' Thereupon the Prophet sat up as he was reclining. and said, 'Are you of such an opinion, O the son of Al-Khattab? These are the people who have received the rewards for their good deeds in this world.' I said, 'O Allah's Apostle! Ask Allah to forgive me.' Then the Prophet kept away from his wives for twenty-nine days because of the story which Hafsa had disclosed to 'Aisha. The Prophet had said, 'I will not enter upon them (my wives) for one month,' because of his anger towards them, when Allah had admonished him. So, when twenty nine days had passed, the Prophet first entered upon 'Aisha. 'Aisha said to him, 'O Allah's Apostle! You had sworn that you would not enter upon us for one month, but now only twenty-nine days have passed, for I have been counting them one by one.' The Prophet said, 'The (present) month is of twenty nine days.' 'Aisha added, 'Then Allah revealed the Verses of the option. (2) And out of all his-wives he asked me first, and I chose him.' Then he gave option to his other wives and they said what 'Aisha had said . " (1) The Prophet, ' had decided to abstain from eating a certain kind of food because of a certain event, so Allah blamed him for doing so. Some of his wives were the cause of him taking that decision, therefore he deserted them for one month. See Quran: (66.4)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.120]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 120

Narrated Abu Huraira:

The Prophet said, "A woman should not fast (optional fasts) except with her husband's permission if he is at home (staying with her)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.121]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 121

Narrated Abu Huraira:

The Prophet said, "If a man Invites his wife to sleep with him and she refuses to come to him, then the angels send their curses on her till morning."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.122]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 122

Narrated Abu Huraira:

The Prophet said, "If a woman spends the night deserting her husband's bed (does not sleep with him), then the angels send their curses on her till she comes back (to her husband)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.123]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 123

Narrated Abu Huraira:

Allah's Apostle said, "It is not lawful for a lady to fast (Nawafil) without the permission of her husband when he is at home; and she should not allow anyone to enter his house except with his permission; and if she spends of his wealth (on charitable purposes) without being ordered by him, he will get half of the reward."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.124]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 124

Narrated Usama:

The Prophet said, "I stood at the gate of Paradise and saw that the majority of the people who entered it were the poor, while the wealthy were stopped at the gate (for the accounts). But the companions of the Fire were ordered to be taken to the Fire. Then I stood at the gate of the Fire and saw that the majority of those who entered it were women."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.125]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 125

Narrated 'Abdullah bin Abbas:

During the lifetime of Allah's Apostle, the sun eclipsed. Allah's Apostle offered the prayer of (the) eclipse) and so did the people along with him. He performed a long Qiyam (standing posture) during which Surat-al-Baqara could have been recited; then he performed a pro-longed bowing, then raised his head and stood for a long time which was slightly less than that of the first Qiyam (and recited Qur'an). Then he performed a prolonged bowing again but the period was shorter than the period of the first bowing, then he stood up and then prostrated. Again he stood up, but this time the period of standing was less than the first standing. Then he performed a prolonged bowing but of a lesser duration than the first, then he stood up again for a long time but for a lesser duration than the first. Then he performed a prolonged bowing but of lesser duration than the first, and then he again stood up, and then prostrated and then finished his prayer. By then the sun eclipse had cleared. The Prophet then said, "The sun and the moon are two signs among the signs of Allah, and they do not eclipse because of the death or birth of someone, so when you observe the eclipse, remember Allah (offer the eclipse prayer)." They (the people) said, "O Allah's Apostle! We saw you stretching your hand to take something at this place of yours, then we saw you stepping backward." He said, "I saw Paradise (or Paradise was shown to me), and I stretched my hand to pluck a bunch (of grapes), and had I plucked it, you would have eaten of it as long as this world exists. Then I saw the (Hell) Fire, and I have never before, seen such a horrible sight as that, and I saw that the majority of its dwellers were women." The people asked, "O Allah's Apostle! What is the reason for that?" He replied, "Because of their ungratefulness." It was said. "Do they disbelieve in Allah (are they ungrateful to Allah)?" He replied, "They are not thankful to their husbands and are ungrateful for the favors done to them. Even if you do good to one of them all your life, when she seems some harshness from you, she will say, "I have never seen any good from you.' "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.126]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 126

Narrated Imran:

The Prophet said, "I looked at Paradise and saw that the majority of its residents were the poor; and I looked at the (Hell) Fire and saw that the majority of its residents were women."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.127]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 127

Narrated 'Abdullah bin 'Amr bin Al-'As:

Allah's Apostle said, "O 'Abdullah! Have I not been formed that you fast all the day and stand in prayer all night?" I said, "Yes, O Allah's Apostle!" He said, "Do not do that! Observe the fast sometimes and also leave them (the fast) at other times; stand up for the prayer at night and also sleep at night. Your body has a right over you, your eyes have a right over you and your wife has a right over you."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.128]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 128

Narrated Ibn 'Umar:

The Prophet said, "All of you are guardians and are responsible for your wards. The ruler is a guardian and the man is a guardian of his family; the lady is a guardian and is responsible for her husband's house and his offspring; and so all of you are guardians and are responsible for your wards."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.129]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 129

Narrated Anas:

Allah's Apostle took an oath that he would not visit his wives for one month, and he sat in an upper room belonging to him. Then, on the twenty ninth day he came down. It was said, "O Allah's Apostle! You had taken an oath not to visit your wives for one month." He said, "The (present) month is of twenty-nine days."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.130]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 130

Narrated Um Salama:

The Prophet took an oath that he would not enter upon some of his wives for one month. But when twenty nine days had elapsed, he went to them in the morning or evening. It was said to him, "O Allah's Prophet! You had taken an oath that you would not enter upon them for one month." He replied, "The month can be of twenty nine days."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.131]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 131

Narrated Ibn 'Abbas:

One morning we saw the wives of the Prophet weeping, and everyone of them had her family with her, I went to the mosque and found that it was crowded with people. Then 'Umar bin Al-Khattab came and went up to the Prophet who was in his upper room. He greeted him but nobody answered. He greeted again, but nobody answered. Then the gatekeeper called him and he entered upon the Prophet, and asked, "Have you divorced your wives?" The Prophet, said, "No, but I have taken an oath not to go to them for one month." So the Prophet stayed away (from his wives) for twenty nine days and then entered upon them.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.132]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 132

Narrated 'Abdullah bin Zam'a:

The Prophet said, "None of you should flog his wife as he flogs a slave and then have sexual intercourse with her in the last part of the day."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.133]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 133

Narrated 'Aisha:

An Ansari woman gave her daughter in marriage and the hair of the latter started falling out. The Ansari women came to the Prophet and mentioned that to him and said, "Her (my daughter's) husband suggested that I should let her wear false hair." The Prophet said, "No, (don't do that) for Allah sends His curses upon such ladies who lengthen their hair artificially."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.134]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 134

Narrated Aisha:

regarding the Verse: 'If a wife fears cruelty or desertion on her husband's part ...') (4.128) It concerns the woman whose husband does not want to keep her with him any longer, but wants to divorce her and marry some other lady, so she says to him: 'Keep me and do not divorce me, and then marry another woman, and you may neither spend on me, nor sleep with me.' This is indicated by the Statement of Allah: 'There is no blame on them if they arrange an amicable settlement between them both, and (such) settlement is better." (4.128)


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.135]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 135

Narrated Jabir:

We used to practice coitus interrupt us during the lifetime of Allah's Apostle .


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.136]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 136

Narrated Jabir:

We used to practice coitus interrupt us while the Quran was being revealed. Jabir added: We used to practice coitus interrupt us during the lifetime of Allah's Apostle while the Quran was being Revealed.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.137]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 137

Narrated Abu Said Al-Khudri:

We got female captives in the war booty and we used to do coitus interruptus with them. So we asked Allah's Apostle about it and he said, "Do you really do that?" repeating the question thrice, "There is no soul that is destined to exist but will come into existence, till the Day of Resurrection."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.138]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 138

Narrated al-Qasim:

Aisha said that whenever the Prophet intended to go on a journey, he drew lots among his wives (so as to take one of them along with him). During one of his journeys the lot fell on 'Aisha and Hafsa. When night fell the Prophet would ride beside 'Aisha and talk with her. One night Hafsa said to 'Aisha, "Won't you ride my camel tonight and I ride yours, so that you may see (me) and I see (you) (in new situation)?" 'Aisha said, "Yes, (I agree.)" So 'Aisha rode, and then the Prophet came towards 'Aisha's camel on which Hafsa was riding. He greeted Hafsa and then proceeded (beside her) till they dismounted (on the way). 'Aisha missed him, and so, when they dismounted, she put her legs in the Idhkhir and said, "O Lord (Allah)! Send a scorpion or a snake to bite me for I am not to blame him (the Prophet ).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.139]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 139

Narrated 'Aisha:

Sada bint Zam'a gave up her turn to me ('Aisha), and so the Prophet used to give me ('Aisha) both my day and the day of Sad;


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.140]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 140

Narrated Anas:

The tradition, (of the Prophet) is that if someone marries a virgin and he has already a matron wife (with him), then he should stay with the virgin for seven days; and if someone marries a matron (and he has already a virgin wife with him) then he should stay with her for three days.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.141]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 141

Narrated Anas:

It is the Prophet's tradition that if someone marries a virgin and he has already a matron wife then he should stay for seven days with her (the virgin) and then by turns; and if someone marries a matron and he has already a virgin wife then he should stay with her (the matron) for three days, and then by turns.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.142]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 142

Narrated Anas bin Malik:

The Prophet used to pass by (have sexual relation with) all his wives in one night, and at that time he had nine wives.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.143]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 143

Narrated 'Aisha:

Whenever Allah's Apostle finished his 'Asr prayer, he would enter upon his wives and stay with one of them. One day he went to Hafsa and stayed with her longer than usual.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.144]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 144

Narrated 'Aisha:

that during his fatal ailment, Allah's Apostle, used to ask his wives, "Where shall I stay tomorrow? Where shall I stay tomorrow?" He was looking forward to Aisha's turn. So all his wives allowed him to stay where he wished, and he stayed at 'Aisha's house till he died there. 'Aisha added: He died on the day of my usual turn at my house. Allah took him unto Him while his head was between my chest and my neck and his saliva was mixed with my saliva.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.145]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 145

Narrated Ibn 'Abbas:

that 'Umar entered upon Hafsa and said, "O my daughter! Do not be misled by the manners of her who is proud of her beauty because of the love of Allah's Apostle for her." By 'her' he meant 'Aisha. 'Umar added, "Then I told that to Allah's Apostle and he smiled (on hearing that)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.146]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 146

Narrated Asma:

Some lady said, "O Allah's Apostle! My husband has another wife, so it is sinful of me to claim that he has given me what he has not given me (in order to tease her)?" Allah's Apostle said, The one who pretends that he has been given what he has not been given, is just like the (false) one who wears two garments of falsehood."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.147]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 147

Narrated 'Abdullah bin Masud:

The Prophet, said, "There is none having a greater sense of Ghira than Allah. And for that He has forbidden the doing of evil actions (illegal sexual intercourse etc.) There is none who likes to be praised more than Allah does."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.148]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 148

Narrated 'Aisha:

Allah's Apostle said, "O followers of Muhammad! There is none, who has a greater sense of Ghira (self-respect) than Allah, so He has forbidden that His slave commits illegal sexual intercourse or His slave girl commits illegal sexual intercourse. O followers of Muhammad! If you but knew what I know, you would laugh less and weep more!"


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.149]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 149

Narrated Asma':

I heard Allah's Apostle saying, "There is nothing (none) having a greater sense of Ghira (self-respect) than Allah." And narrated Abu Huraira that he heard the Prophet (saying the same).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.150]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 150

Narrated Abu Huraira:

The Prophet; said, "Allah has a sense of Ghira, and Allah's sense of Ghira is provoked when a believer does something which Allah has prohibited."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.151]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 151

Narrated Asma' bint Abu Bakr:

When Az-Zubair married me, he had no real property or any slave or anything else except a camel which drew water from the well, and his horse. I used to feed his horse with fodder and drew water and sew the bucket for drawing it, and prepare the dough, but I did not know how to bake bread. So our Ansari neighbors used to bake bread for me, and they were honorable ladies. I used to carry the date stones on my head from Zubair's land given to him by Allah's Apostle and this land was two third Farsakh (about two miles) from my house. One day, while I was coming with the date stones on my head, I met Allah's Apostle along with some Ansari people. He called me and then, (directing his camel to kneel down) said, "Ikh! Ikh!" so as to make me ride behind him (on his camel). I felt shy to travel with the men and remembered Az-Zubair and his sense of Ghira, as he was one of those people who had the greatest sense of Ghira. Allah's Apostle noticed that I felt shy, so he proceeded. I came to Az-Zubair and said, "I met Allah's Apostle while I was carrying a load of date stones on my head, and he had some companions with him. He made his camel kneel down so that I might ride, but I felt shy in his presence and remembered your sense of Ghira (See the glossary). On that Az-Zubair said, "By Allah, your carrying the date stones (and you being seen by the Prophet in such a state) is more shameful to me than your riding with him." (I continued serving in this way) till Abu Bakr sent me a servant to look after the horse, whereupon I felt as if he had set me free.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.152]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 152

Narrated Anas:

While the Prophet was in the house of one of his wives, one of the mothers of the believers sent a meal in a dish. The wife at whose house the Prophet was, struck the hand of the servant, causing the dish to fall and break. The Prophet gathered the broken pieces of the dish and then started collecting on them the food which had been in the dish and said, "Your mother (my wife) felt jealous." Then he detained the servant till a (sound) dish was brought from the wife at whose house he was. He gave the sound dish to the wife whose dish had been broken and kept the broken one at the house where it had been broken.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.153]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 153

Narrated Jabir:

The Prophet, said, "I entered Paradise and saw a palace and asked whose palace is this? They (the Angels) said, "This palace belongs to 'Umar bin Al-Khattab.' I intended to enter it, and nothing stopped me except my knowledge about your sense of Ghira (self-respect (O Umar)." 'Umar said, "O Allah's Apostle! Let my father and mother be sacrificed for you! O Allah's Prophet! How dare I think of my Ghira (self-respect) being offended by you?"


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.154]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 154

Narrated Abu Huraira:

While we were sitting with Allah's Apostle, (he) Allah's Apostle said, "While I was sleeping, I saw a woman performing ablution beside a palace. I asked, "Whose palace is this?' It was said, 'This palace belongs to 'Umar.' Then I remembered his sense of Ghira and returned." On that 'Umar started weeping in that gathering and said, "O Allah's Apostle! How dare I think of my self-respect being offended by you?"


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.155]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 155

Narrated Aisha:

That Allah's Apostle said to her, "I you are pleased with me or angry with me." I said, "Whence do you know that?" He said, "When you are pleased with me, you say, 'No, by the Lord of Muhammad,' but when you are angry with me, then you say, 'No, by the Lord of Abraham.' " Thereupon I said, "Yes (you are right), but by Allah, O Allah's Apostle, I leave nothing but your name."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.156]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 156

Narrated 'Aisha:

I never felt so jealous of any wife of Allah's Apostle as I did of Khadija because Allah's Apostle used to remember and praise her too often and because it was revealed to Allah's Apostle that he should give her (Khadija) the glad tidings of her having a palace of Qasab in Paradise .


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.157]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 157

Narrated Al-Miswar bin Makhrama:

I heard Allah's Apostle who was on the pulpit, saying, "Banu Hisham bin Al-Mughira have requested me to allow them to marry their daughter to Ali bin Abu Talib, but I don't give permission, and will not give permission unless 'Ali bin Abi Talib divorces my daughter in order to marry their daughter, because Fatima is a part of my body, and I hate what she hates to see, and what hurts her, hurts me."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.158]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 158

Narrated Anas:

I will narrate to you a Habith I heard from Allah's Apostle and none other than I will tell you of it. I heard Allah's Apostle saying, "From among the portents of the Hour are the following: Religious knowledge will be taken away; General ignorance (in religious matters) will increase; illegal Sexual intercourse will prevail: Drinking of alcoholic drinks will prevail. Men will decrease in number, and women will increase in number, so much so that fifty women will be looked after by one man."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.159]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 159

Narrated 'Uqba bin 'Amir:

Allah's Apostle said, "Beware of entering upon the ladies." A man from the Ansar said, "Allah's Apostle! What about Al-Hamu the in-laws of the wife (the brothers of her husband or his nephews etc.)?" The Prophet replied: The in-laws of the wife are death itself.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.160]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 160

Narrated Ibn 'Abbas :

The Prophet said, "No man should stay with a lady in seclusion except in the presence of a Dhu-Muhram." A man stood up and said, "O Allah's Apostle! My wife has gone out intending to perform the Hajj and I have been enrolled (in the army) for such-and-such campaign." The Prophet said, "Return and perform the Hajj with your wife."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.161]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 161

Narrated Anas bin Malik:

An Ansari woman came to the Prophet and he took her aside and said (to her). "By Allah, you (Ansar) are the most beloved people to me."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.162]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 162

Narrated Um Salama:

that while the Prophet was with her, there was an effeminate man in the house. The effeminate man said to Um Salama's brother, 'Abdullah bin Abi Umaiyya, "If Allah should make you conquer Ta'if tomorrow, I recommend that you take the daughter of Ghailan (in marriage) for (she is so fat) that she shows four folds of flesh when facing you and eight when she turns her back." Thereupon the Prophet said (to us), "This (effeminate man) should not enter upon you (anymore)."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.163]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 163

Narrated 'Aisha:

The Prophet was screening me with his Rida' (garment covering the upper part of the body) while I was looking at the Ethiopians who were playing in the courtyard of the mosque. (I continued watching) till I was satisfied. So you may deduce from this event how a little girl (who has not reached the age of puberty) who is eager to enjoy amusement should be treated in this respect.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.164]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 164

Narrated 'Aisha:

Once Sada bint Zam'a went out at night for some need, and 'Umar saw her, and recognizing her, he said (to her), "By Allah, O Sada! You cannot hide yourself from us." So she returned to the Prophet and mentioned that to him while he was sitting in my dwelling taking his supper and holding a bone covered with meat in his hand. Then the Divine Inspiration was revealed to him and when that state was over, he (the Prophet was saying: "O women! You have been allowed by Allah to go out for your needs."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.165]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 165

Narrated Salim's father:

The Prophet said, "If the wife of anyone of you asks permission to go to the mosque, he should not forbid her."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.166]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 166

Narrated 'Aisha:

My foster uncle came and asked permission (to enter) but I refused to admit him till I asked Allah's Apostle about that. He said, "He is your uncle, so allow him to come in." I said, "O Allah's Apostle! I have been suckled by a woman and not by a man." Allah's Apostle said, "He is your uncle, so let him enter upon you." And that happened after the order of Al-Hijab (compulsory veiling) was revealed. All things which become unlawful because of blood relations are unlawful because of the corresponding foster suckling relations.


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.167]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 167

Narrated 'Abdullah bin Mas'ud:

The Prophet said, "A woman should not look at or touch another woman to describe her to her

husband in such a way as if he was actually looking at her."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.168]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 168

Narrated 'Abdullah:

The Prophet said, "A woman should not look at or touch another woman to describe her to her husband in such a way as if he was actually looking at her."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.169]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 169

Narrated Abu Huraira:

(The Prophet) Solomon son of (the Prophet) David said, "Tonight I will go round (i.e. have sexual relations with) one hundred women (my wives) everyone of whom will deliver a male child who will fight in Allah's Cause." On that an Angel said to him, "Say: 'If Allah will.' " But Solomon did not say it and forgot to say it. Then he had sexual relations with them but none of them delivered any child except one who delivered a half person. The Prophet said, "If Solomon had said: 'If Allah will,' Allah would have fulfilled his (above) desire and that saying would have made him more hopeful."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.170]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 170

Narrated Jabir bin Abdullah:

The Prophet disliked that one should go to one's family at night (on returning from a journey).


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.171]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 171

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "When anyone of you is away from his house for a long time, he should not return to his family at night."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.172]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 172

Narrated Jabir:

I was with Allah's Apostle in a Ghazwa, and when we returned, I wanted to hurry, while riding a slow camel. A rider came behind me. I looked back and saw that the rider was Allah's Apostle . He said (to me), "What makes you in such a hurry?" I replied, "I am newly married." He said, "Did you marry a virgin or a matron?" I replied, "(Not a virgin but) a matron." He said, "Why didn't you marry a young girl with whom you could play and who could play with you?" Then when we approached (Medina) and were going to enter (it), the Prophet said, "Wait till you enter (your homes) at night (in the first part of the night) so that the ladies with unkempt hair may comb their hair, and those whose husbands have been absent (for a long time) may shave their pubic hair." (The sub-narrator, Hashim said: A reliable narrator told me that the Prophet added in this Hadith: "(Seek to beget) children! Children, O Jabir!")


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.173]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 173

Narrated Jabir bin 'Abdullah:

The Prophet said, "If you enter (your town) at night (after coming from a journey), do not enter upon your family till the woman whose husband was absent (from the house) shaves her pubic hair and the woman with unkempt hair, combs her hair" Allah's Apostle further said, "(O Jabir!) Seek to have offspring, seek to have offspring!"


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.174]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 174

Narrated Jabir bin 'Abdullah:

We were with the Prophet in Ghazwa, and when we returned and approached Medina, I wanted to hurry while riding a slow camel. A rider overtook me and pricked my camel with a spear which he had, whereupon my camel started running as fast as any other fast camel you may see. I looked back, and behold, the rider was Allah's Apostle . I said, "O Allah's Apostle! I am newly married " He asked, "Have you got married?" I replied, "Yes." He said, "A virgin or a matron?" I replied, "(Not a virgin) but a matron" He said, "Why didn't you marry a young girl so that you could play with her and she with you?" When we reached (near Medina) and were going to enter it, the Prophet said, "Wait till you enter your home early in the night so that the lady whose hair is unkempt may comb her hair and that the lady whose husband has been away may shave her pubic hair."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.175]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 175

Narrated Abu Hazim:

The people differed about the type of treatment which had been given to Allah's Apostle on the day (of the battle) of Uhud. So they asked Sahl bin Sad As-Sa'id who was the only surviving Companion (of the Prophet) at Medina. He replied, "Nobody Is left at Medina who knows it better than I. Fatima was washing the blood off his face and 'Ali was bringing water in his shield, and then a mat of date-palm leaves was burnt and (the ash) was inserted into the wound."


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.176]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 176

Narrated 'Abdur-Rahman bin 'Abis:

I heard Ibn 'Abbas answering a man who asked him, "Did you attend the prayer of 'Id al Adha or 'Id-al-Fitr with Allah's Apostle?" Ibn 'Abbas replied, "Yes, and had it not been for my close relationship with him, I could not have offered it." (That was because of his young age). Ibn 'Abbas further said, Allah's Apostle went out and offered the Id prayer and then delivered the sermon." Ibn 'Abbas did not mention anything about the Adhan (the call for prayer) or the Iqama. He added, "Then the Prophet went to the women and instructed them and gave them religious advice and ordered them to give alms and I saw them reaching out (their hands to) their ears and necks (to take off the earrings and necklaces, etc.) and throwing (it) towards Bilal. Then the Prophet returned with Bilal to his house . "


Bukhari :: Wedlock, Marriage (Nikaah) :: [7.62.177]

Wedlock, Marriage (Nikaah)

Bukhari :: Book 7 :: Volume 62 :: Hadith 177

Narrated 'Aisha:

Abu Bakr admonished me and poked me with his hands in the flank, and nothing stopped me from moving at that time except the position of Allah's Apostle whose head was on my thigh.


Bukhari :: Divorce :: [7.63.178]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 178

Narrated 'Abdullah bin 'Umar:

that he had divorced his wife while she was menstruating during the lifetime of Allah's Apostle . 'Umar bin Al-Khattab asked Allah's Apostle about that. Allah's Apostle said, "Order him (your son) to take her back and keep her till she is clean and then to wait till she gets her next period and becomes clean again, whereupon, if he wishes to keep her, he can do so, and if he wishes to divorce her he can divorce her before having sexual intercourse with her; and that is the prescribed period which Allah has fixed for the women meant to be divorced."


Bukhari :: Divorce :: [7.63.179]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 179

Narrated Anas bin Sirin:

Ibn 'Umar said: "I divorced my wife while she was menstruating. 'Umar mentioned that to the Prophet . The Prophet said, (to my father), "Let your son take her back." I asked (Ibn 'Umar), "Is such a divorce counted (i.e. as one legal divorce)?" Ibn 'Umar said, "Of course." Narrated Yunus bin Jubair: Ibn 'Umar said, "The Prophet said to 'Umar, 'Order him (Ibn 'Umar) to take her back.' " I asked, "Is such a divorce counted (as one legal divorce)?" Ibn 'Umar said, "What do you think if someone becomes helpless and foolish?"


Bukhari :: Divorce :: [7.63.180]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 180

Narrated Ibn 'Umar:

(Divorcing my wife during her menses) was counted as one legal divorce.


Bukhari :: Divorce :: [7.63.181]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 181

Narrated Al-Awza:

I asked Az-Zuhri, "Which of the wives of the Prophet sought refuge with Allah from him?" He said "I was told by 'Ursa that 'Aisha said, 'When the daughter of Al-Jaun was brought to Allah's Apostle (as his bride) and he went near her, she said, "I seek refuge with Allah from you." He said, "You have sought refuge with The Great; return to your family."


Bukhari :: Divorce :: [7.63.182]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 182

Narrated Abu Usaid:

We went out with the Prophet to a garden called Ash-Shaut till we reached two walls between which we sat down. The Prophet said, "Sit here," and went in (the garden). The Jauniyya (a lady from Bani Jaun) had been brought and lodged in a house in a date-palm garden in the home of Umaima bint An-Nu'man bin Sharahil, and her wet nurse was with her. When the Prophet entered upon her, he said to her, "Give me yourself (in marriage) as a gift." She said, "Can a princess give herself in marriage to an ordinary man?" The Prophet raised his hand to pat her so that she might become tranquil. She said, "I seek refuge with Allah from you." He said, "You have sought refuge with One Who gives refuge. Then the Prophet came out to us and said, "O Abu Usaid! Give her two white linen dresses to wear and let her go back to her family." Narrated Sahl and Abu Usaid: The Prophet married Umaima bint Sharahil, and when she was brought to him, he stretched his hand towards her. It seemed that she disliked that, whereupon the Prophet ordered Abu Usaid to prepare her and to provide her with two white linen dresses. (See Hadith No. 541).


Bukhari :: Divorce :: [7.63.183]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 183

Narrated Sahl bin Sad:

similarly as above (182).


Bukhari :: Divorce :: [7.63.184]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 184

Narrated Abi Ghallab Yunus bin Jubair:

I asked Ibn 'Umar,"(What is said regarding) a man divorces his wife during her period?" He said, "Do you know Ibn 'Umar? Ibn 'Umar divorced his wife while she was menstruating. 'Umar then went to the Prophet and mentioned that to him. The Prophet ordered him to take her back and when she became clean, he could divorce her if he wanted." I asked (Ibn 'Umar), "Was that divorce counted as one legal divorce?" He said, "If one becomes helpless and foolish (will he be excused? Of course not). "


Bukhari :: Divorce :: [7.63.185]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 185

Narrated Sahl bin Sad As-Sa'idi:

Uwaimir Al-'Ajlani came to 'Asim bin Adi Al-Ansari and asked, "O 'Asim! Tell me, if a man sees his wife with another man, should he kill him, whereupon you would kill him in Qisas, or what should he do? O 'Asim! Please ask Allah's Apostle about that." 'Asim asked Allah's Apostle about that. Allah's Apostle disliked that question and considered it disgraceful. What 'Asim heard from Allah's Apostle was hard on him. When he returned to his family, 'Uwaimir came to him and said "O 'Asim! What did Allah's Apostle say to you?" 'Asim said, "You never bring me any good. Allah's Apostle disliked to hear the problem which I asked him about." 'Uwaimir said, "By Allah, I will not leave the matter till I ask him about it." So 'Uwaimir proceeded till he came to Allah's Apostle who was in the midst of the people and said, "O Allah's Apostle! If a man finds with his wife another man, should he kill him, whereupon you would kill him (in Qisas): or otherwise, what should he do?" Allah's Apostle said, "Allah has revealed something concerning the question of you and your wife. Go and bring her here." So they both carried out the judgment of Lian, while I was present among the people (as a witness). When both of them had finished, 'Uwaimir said, "O Allah's Apostle! If I should now keep my wife with me, then I have told a lie". Then he pronounced his decision to divorce her thrice before Allah's Apostle ordered him to do so. (Ibn Shihab said, "That was the tradition for all those who are involved in a case of Lian."


Bukhari :: Divorce :: [7.63.186]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 186

Narrated 'Aisha:

The wife of Rifa'a Al-Qurazi came to Allah's Apostle and said, "O Allah's Apostle! Rifa'a divorced me irrevocably. After him I married 'Abdur-Rahman bin Az-Zubair Al-Qurazi who proved to be impotent." Allah's Apostle said to her, "Perhaps you want to return to Rifa'a? Nay (you cannot return to Rifa'a) until you and 'Abdur-Rahman consummate your marriage."


Bukhari :: Divorce :: [7.63.187]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 187

Narrated 'Aisha:

A man divorced his wife thrice (by expressing his decision to divorce her thrice), then she married another man who also divorced her. The Prophet was asked if she could legally marry the first husband (or not). The Prophet replied, "No, she cannot marry the first husband unless the second husband consummates his marriage with her, just as the first husband had done."


Bukhari :: Divorce :: [7.63.188]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 188

Narrated 'Aisha:

Allah's Apostle gave us the option (to remain with him or to be divorced) and we selected Allah and His Apostle . So, giving us that option was not regarded as divorce.


Bukhari :: Divorce :: [7.63.189]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 189

Narrated Musruq:

I asked 'Aisha about the option: She said, "The Prophet gave us the option. Do you think that option was considered as a divorce?" I said, "It matters little to me if I give my wife the option once or a hundred times after she has chosen me."


Bukhari :: Divorce :: [7.63.190]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 190

Narrated 'Aisha:

A man divorced his wife and she married another man who proved to be impotent and divorced her. She could not get her satisfaction from him, and after a while he divorced her. Then she came to the Prophet and said, "O Allah's Apostle! My first husband divorced me and then I married another man who entered upon me to consummate his marriage but he proved to be impotent and did not approach me except once during which he benefited nothing from me. Can I remarry my first husband in this case?" Allah's Apostle said, "It is unlawful to marry your first husband till the other husband consummates his marriage with you."


Bukhari :: Divorce :: [7.63.191]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 191

Narrated Said bin Jubair:

that he heard Ibn 'Abbas saying, "If a man makes his wife unlawful for him, it does not mean that she is divorced." He added, "Indeed in the Apostle of Allah , you have a good example to follow."


Bukhari :: Divorce :: [7.63.192]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 192

Narrated 'Ubaid bin 'Umar:

I heard 'Aisha saying, "The Prophet used to stay for a long while with Zanab bint Jahsh and drink honey at her house. So Hafsa and I decided that if the Prophet came to anyone of us, she should say him, "I detect the smell of Maghafir (a nasty smelling gum) in you. Have you eaten Maghafir?' " So the Prophet visited one of them and she said to him similarly. The Prophet said, "Never mind, I have taken some honey at the house of Zainab bint Jahsh, but I shall never drink of it anymore." So there was revealed: 'O Prophet ! Why do you ban (for you) that which Allah has made lawful for you . . . If you two (wives of Prophet) turn in repentance to Allah,' (66.1-4) addressing Aisha and Hafsa. 'When the Prophet disclosed a matter in confidence to some of his wives.' (66.3) namely his saying: But I have taken some honey."


Bukhari :: Divorce :: [7.63.193]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 193

Narrated 'Aisha:

Allah's Apostle was fond of honey and sweet edible things and (it was his habit) that after finishing the 'Asr prayer he would visit his wives and stay with one of them at that time. Once he went to Hafsa, the daughter of 'Umar and stayed with her more than usual. I got jealous and asked the reason for that. I was told that a lady of her folk had given her a skin filled with honey as a present, and that she made a syrup from it and gave it to the Prophet to drink (and that was the reason for the delay). I said, "By Allah we will play a trick on him (to prevent him from doing so)." So I said to Sada bint Zam'a "The Prophet will approach you, and when he comes near you, say: 'Have you taken Maghafir (a bad-smelling gum)?' He will say, 'No.' Then say to him: 'Then what is this bad smell which i smell from you?' He will say to you, 'Hafsa made me drink honey syrup.' Then say: Perhaps the bees of that honey had sucked the juice of the tree of Al-'Urfut.' I shall also say the same. O you, Safiyya, say the same." Later Sada said, "By Allah, as soon as he (the Prophet ) stood at the door, I was about to say to him what you had ordered me to say because I was afraid of you." So when the Prophet came near Sada, she said to him, "O Allah's Apostle! Have you taken Maghafir?" He said, "No." She said. "Then what is this bad smell which I detect on you?" He said, "Hafsa made me drink honey syrup." She said, "Perhaps its bees had sucked the juice of Al-'Urfut tree." When he came to me, I also said the same, and when he went to Safiyya, she also said the same. And when the Prophet again went to Hafsa, she said, 'O Allah's Apostle! Shall I give you more of that drink?" He said, "I am not in need of it." Sada said, "By Allah, we deprived him (of it)." I said to her, "Keep quiet." '


Bukhari :: Divorce :: [7.63.194]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 194

Narrated Abu Huraira:

The Prophet said, "Allah has forgiven my followers the evil thoughts that occur to their minds, as long as such thoughts are not put into action or uttered." And Qatada said, "If someone divorces his wife just in his mind, such an unuttered divorce has no effect.:


Bukhari :: Divorce :: [7.63.195]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 195

Narrated Jabir:

A man from the tribe of Bani Aslam came to the Prophet while he was in the mosque and said, "I have committed illegal sexual intercourse." The Prophet turned his face to the other side. The man turned towards the side towards which the Prophet had turned his face, and gave four witnesses against himself. On that the Prophet called him and said, "Are you insane?" (He added), "Are you married?" The man said, 'Yes." On that the Prophet ordered him to be stoned to the death in the Musalla (a praying place). When the stones hit him with their sharp edges and he fled, but he was caught at Al-Harra and then killed


Bukhari :: Divorce :: [7.63.196]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 196

Narrated Abu Huraira:

A man from Bani Aslam came to Allah's Apostle while he was in the mosque and called (the Prophet ) saying, "O Allah's Apostle! I have committed illegal sexual intercourse." On that the Prophet turned his face from him to the other side, whereupon the man moved to the side towards which the Prophet had turned his face, and said, "O Allah's Apostle! I have committed illegal sexual intercourse." The Prophet turned his face (from him) to the other side whereupon the man moved to the side towards which the Prophet had turned his face, and repeated his statement. The Prophet turned his face (from him) to the other side again. The man moved again (and repeated his statement) for the fourth time. So when the man had given witness four times against himself, the Prophet called him and said, "Are you insane?" He replied, "No." The Prophet then said (to his companions), "Go and stone him to death." The man was a married one. Jabir bin 'Abdullah Al-Ansari said: I was one of those who stoned him. We stoned him at the Musalla ('Id praying place) in Medina. When the stones hit him with their sharp edges, he fled, but we caught him at Al-Harra and stoned him till he died.


Bukhari :: Divorce :: [7.63.197]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 197

Narrated Ibn 'Abbas:

The wife of Thabit bin Qais came to the Prophet and said, "O Allah's Apostle! I do not blame Thabit for defects in his character or his religion, but I, being a Muslim, dislike to behave in un-Islamic manner (if I remain with him)." On that Allah's Apostle said (to her), "Will you give back the garden which your husband has given you (as Mahr)?" She said, "Yes." Then the Prophet said to Thabit, "O Thabit! Accept your garden, and divorce her once."


Bukhari :: Divorce :: [7.63.198]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 198

Narrated 'Ikrima:

The sister of 'Abdullah bin Ubai narrated (the above narration, 197) with the addition that the Prophet said to Thabit's wife, "Will you return his garden?" She said, "Yes," and returned it, and (then) the Prophet ordered Thabit to divorce her. Narrated Ibn 'Abbas: The wife of Thabit bin Qais came to Allah's Apostle and said, "O Allah's Apostle! I do not blame Thabit for any defects in his character or his religion, but I cannot endure to live with him." On that Allah's Apostle said, "Will you return his garden to him?" She said, "Yes."


Bukhari :: Divorce :: [7.63.199]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 199

Narrated Ibn 'Abbas:

The wife of Thabit bin Qais bin Shammas came to the Prophet and said, "O Allah's Apostle! I do not blame Thabit for any defects in his character or his religion, but I am afraid that I (being a Muslim) may become unthankful for Allah's Blessings." On that, Allah's Apostle said (to her), 'Will you return his garden to him?" She said, "Yes." So she returned his garden to him and the Prophet told him to divorce her.


Bukhari :: Divorce :: [7.63.200]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 200

Narrated 'Ikrima:

that Jamila... Then he related the whole ,Hadith, (i.e. 199).


Bukhari :: Divorce :: [7.63.201]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 201

Narrated Al-Miswar bin Makhrama Az-Zuhri:

I heard the Prophet saying, "Banu Al-Mughira have asked my leave to let 'Ali marry their daughter, but I give no leave to this effect."


Bukhari :: Divorce :: [7.63.202]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 202

Narrated 'Aisha:

(the wife of the Prophet) Three traditions were established concerning situations in which Barra was involved: When she was manumitted, she was given the option to keep her husband or leave him; Allah's Apostle said, "The wala is for the one who manumits, Once Allah's Apostle entered the house while some meat was being cooked in a pot, but only bread and some soup of the house were placed before, him. He said, "Don't I see the pot containing meat?" They said, "Yes, but that meat was given to Barira in charity (by someone), and you do not eat what it given in charity."The Prophet said "That meat is alms for her, but for us it is a present."


Bukhari :: Divorce :: [7.63.203]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 203

Narrated Ibn 'Abbas:

I saw him as a slave, (namely, Barira's husband).


Bukhari :: Divorce :: [7.63.204]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 204

Narrated Ibn 'Abbas:

That was Mughith, the slave of Bani so-and-so, i.e., Barira's husband as if I am now looking at him following her (Barira) along the streets of Medina.


Bukhari :: Divorce :: [7.63.205]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 205

Narrated Ibn 'Abbas:

Barira's husband was a black slave called Mughith, the slave of Bani so-and-so-- as if I am seeing him now, walking behind her along the streets of Medina.


Bukhari :: Divorce :: [7.63.206]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 206

Narrated Ibn 'Abbas:

Barira's husband was a slave called Mughith, as if I am seeing him now, going behind Barira and weeping with his tears flowing down his beard. The Prophet said to 'Abbas, "O 'Abbas ! are you not astonished at the love of Mughith for Barira and the hatred of Barira for Mughith?" The Prophet then said to Barira, "Why don't you return to him?" She said, "O Allah's Apostle! Do you order me to do so?" He said, "No, I only intercede for him." She said, "I am not in need of him."


Bukhari :: Divorce :: [7.63.207]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 207

Narrated Al-Aswad:

Aisha intended to buy Barira, but her masters stipulated that her wala wound be for them. Aisha mentioned that to the Prophet who said (to 'Aisha), "Buy and manumit her, for the wala is for the one who manumits." Once some me; was brought to the Prophet and was said, "This meat was given in charity to Barira. " The Prophet said, "It an object of charity for Barira and present for us."


Bukhari :: Divorce :: [7.63.208]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 208

Narrated Adam:

Shu'ba relate the same Hadith and added: Barira was given the option regarding her husband


Bukhari :: Divorce :: [7.63.209]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 209

Narrated Nafi':

Whenever Ibn 'Umar was asked about marrying a Christian lady or a Jewess, he would say: "Allah has made it unlawful for the believers to marry ladies who ascribe partners in worship to Allah, and I do not know of a greater thing, as regards to ascribing partners in worship, etc. to Allah, than that a lady should say that Jesus is her Lord although he is just one of Allah's slaves."


Bukhari :: Divorce :: [7.63.210]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 210

Narrated Ibn 'Abbas:

The pagans were of two kinds as regards their relationship to the Prophet and the Believers. Some of them were those with whom the Prophet was at war and used to fight against, and they used to fight him; the others were those with whom the Prophet made a treaty, and neither did the Prophet fight them, nor did they fight him. If a lady from the first group of pagans emigrated towards the Muslims, her hand would not be asked in marriage unless she got the menses and then became clean. When she became clean, it would be lawful for her to get married, and if her husband emigrated too before she got married, then she would be returned to him. If any slave or female slave emigrated from them to the Muslims, then they would be considered free persons (not slaves) and they would have the same rights as given to other emigrants. The narrator then mentioned about the pagans involved with the Muslims in a treaty, the same as occurs in Mujahid's narration. If a male slave or a female slave emigrated from such pagans as had made a treaty with the Muslims, they would not be returned, but their prices would be paid (to the pagans). Narrated Ibn 'Abbas: Qariba, the daughter of Abi Umaiyya, was the wife of 'Umar bin Al-Khattab. 'Umar divorced her and then Mu'awiyya bin Abi Sufyan married her. Similarly, Um Al-Hakam, the daughter of Abi Sufyan was the wife of 'Iyad bin Ghanm Al-Fihri. He divorced her and then 'Abdullah bin 'Uthman Al-Thaqafi married her.


Bukhari :: Divorce :: [7.63.211]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 211

Narrated 'Aisha:

(the wife of the Prophet) When believing women came to the Prophet as emigrants, he used to test them in accordance with the order of Allah. 'O you who believe! When believing women come to you as emigrants, examine them . . .' (60.10) So if anyone of those believing women accepted the above mentioned conditions, she accepted the conditions of faith. When they agreed on those conditions and confessed that with their tongues, Allah's Apostle would say to them, "Go, I have accepted your oath of allegiance (for Islam). By Allah, and hand of Allah's Apostle never touched the hand of any woman, but he only used to take their pledge of allegiance orally. By Allah, Allah's Apostle did not take the pledge of allegiance of the women except in accordance with what Allah had ordered him. When he accepted their pledge of allegiance he would say to them, "I have accepted your oath of allegiance."


Bukhari :: Divorce :: [7.63.212]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 212

Narrated Anas bin Malik:

Allah's Apostle took an oath that he would abstain from his wives, and at that time his leg had been sprained (dislocated). So he stayed in the Mashruba (an attic room) of his for 29 days. Then he came down, and they (the people) said, "O Allah's Apostle! You took an oath to abstain from your wives for one month." He said, "The month is of twenty nine days."


Bukhari :: Divorce :: [7.63.213]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 213

Narrated Nafi:

Ibn 'Umar used to say about the Ila (which Allah defined (in the Holy Book), "If the period of Ila expires, then the husband has either to retain his wife in a handsome manner or to divorce her as Allah has ordered." Ibn 'Umar added, "When the period of four months has expired, the husband should be put in prison so that he should divorce his wife, but the divorce does not occur unless the husband himself declares it. This has been mentioned by 'Uthman, 'Ali, Abu Ad-Darda, 'Aisha and twelve other companions of the Prophet ."


Bukhari :: Divorce :: [7.63.214]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 214

Narrated Yazid:

(the Maula of Munba'ith) The Prophet was asked regarding the case of a lost sheep. He said, "You should take it, because it is for you, or for your brother, or for the wolf." Then he was asked about a lost camel. He got angry and his face became red and he said (to the questioner), "You have nothing to do with it; it has its feet and its water container with it; it can go on drinking water and eating trees till its owner meets it." And then the Prophet was asked about a Luqata (money found by somebody). He said, "Remember and recognize its tying material and its container, and make public announcement about it for one year. If somebody comes and identifies it (then give it to him), otherwise add it to your property."


Bukhari :: Divorce :: [7.63.215]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 215

Narrated Ibn Abbas:

Allah's Apostle performed the Tawaf (around the Ka'ba while riding his camel, and every time he reached the corner (of the Black Stone) he pointed at it with his hand and said, "Allahu Akbar." (Zainab said: The Prophet said, "An opening has been made in the wall of Gog and Magog like this and this," forming the number 90 (with his thumb and index finger).


Bukhari :: Divorce :: [7.63.216]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 216

Narrated Anas bin Malik:

During the lifetime of Allah's Apostle a Jew attacked a girl and took some silver ornaments she was wearing and crushed her head. Her relative brought her to the Prophet while she was in her last breaths, and she was unable to speak. Allah's Apostle asked her, "Who has hit you? So-and so?", mentioning somebody other than her murderer. She moved her head, indicating denial. The Prophet mentioned another person other than the murderer, and she again moved her head indicating denial. Then he asked, "Was it so-and-so?", mentioning the name of her killer. She nodded, agreeing. Then Allah's Apostle; ordered that the head of that Jew be crushed between two stones.


Bukhari :: Divorce :: [7.63.217]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 217

Narrated Ibn 'Umar:

I heard the Prophet saying, "Afflictions will emerge from here," pointing towards the East.


Bukhari :: Divorce :: [7.63.218]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 218

Narrated 'Abdullah bin Abi A'ufa:

We were with Allah's Apostle on a journey, and when the sun set, he said to a man, "Get down and prepare a drink of Sawiq for me." The man said, "O Allah's Apostle! Will you wait till it is evening?" Allah's Apostle again said, "Get down and prepare a drink of Sawiq." The man said, "O Allah's Apostle! Will you wait till it is evening, for it is still daytime. " The Prophet again said, "Get down and prepare a drink of Sawiq." So the third time the man got down and prepared a drink of sawiq for him. Allah's Apostle drank thereof and pointed with his hand towards the East, saying, "When you see the night falling from this side, then a fasting person should break his fast."


Bukhari :: Divorce :: [7.63.219]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 219

Narrated Abu Huraira:

Allah's Apostle said, The example of a miser and a generous person is like that of two persons wearing iron cloaks from the breast upto the neck When the generous person spends, the iron cloak enlarges and spread over his skin so much so that it covers his fingertips and obliterates his tracks. As for the miser, as soon as he thinks of spending every ring of the iron cloak sticks to its place (against his body) and he tries to expand it, but it does not expand. The Prophet pointed with his hand towards his throat.


Bukhari :: Divorce :: [7.63.220]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 220

Narrated Anas bin Malik:

Allah's Apostle said, "Shall I tell you of the best families among the Ansar?" They (the people) said, "Yes, O Allah's Apostle!" The Prophet said, "The best are Banu- An-Najjar, and after them are Banu 'Abdil Ash-hal, and after them are Banu Al-Harith bin Al-Khazraj, and after them are Banu Sa'ida." The Prophet then moved his hand by closing his fingers and then opening them like one throwing something, and then said, "Anyhow, there is good in all the families of the Ansar. "


Bukhari :: Divorce :: [7.63.221]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 221

Narrated Sahl bin Sad As-Sa'idi:

(a companion of Allah's Apostle) Allah's Apostle, holding out his middle and index fingers, said, "My advent and the Hour's are like this (or like these)," namely, the period between his era and the Hour is like the distance between those two fingers, i.e., very short.


Bukhari :: Divorce :: [7.63.222]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 222

Narrated Ibn 'Umar:

The Prophet (holding out his ten fingers thrice), said, "The month is thus and thus and thus," namely thirty days. Then (holding out his ten fingers twice and then nine fingers), he said, "It may be thus and thus and thus," namely twenty nine days. He meant once thirty days and once twenty nine days.


Bukhari :: Divorce :: [7.63.223]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 223

Narrated Abu Masud:

The Prophet pointed with his hand towards Yemen and said twice, "Faith is there," and then pointed towards the East, and said, "Verily, sternness and mercilessness are the qualities of those who are busy with their camels and pay no attention to their religion, where the two sides of the head of Satan will appear," namely, the tribes of Rabl'a and Muqar.


Bukhari :: Divorce :: [7.63.224]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 224

Narrated Sahl:

Allah's Apostle said, "I and the one who looks after an orphan will be like this in Paradise," showing his middle and index fingers and separating them.


Bukhari :: Divorce :: [7.63.225]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 225

Narrated Abu Huraira:

A man came to the Prophet and said, "O Allah's Apostle! A black child has been born for me." The Prophet asked him, "Have you got camels?" The man said, "Yes." The Prophet asked him, "What color are they?" The man replied, "Red." The Prophet said, "Is there a grey one among them?' The man replied, "Yes." The Prophet said, "Whence comes that?" He said, "May be it is because of heredity." The Prophet said, "May be your latest son has this color because of heredity."


Bukhari :: Divorce :: [7.63.226]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 226

Narrated 'Abdullah:

An Ansari man accused his wife (of committing illegal sexual intercourse). The Prophet made both of them takes the oath of Lian, and separated them from each other (by divorce).


Bukhari :: Divorce :: [7.63.227]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 227

Narrated Ibn 'Abbas:

Hilal bin Umaiyya accused his wife of illegal sexual intercourse and came to the Prophet to bear witness (against her), (taking the oath of Lian). The Prophet was saying, "Allah knows that either of you is a liar. Will anyone of you repent (to Allah)?" Then the lady got up and gave her witness.


Bukhari :: Divorce :: [7.63.228]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 228

Narrated Sahl bin Sad As-Sa'idi:

'Uwaimir Al-Ajlani came to 'Asim bin Ad Al-Ansari and said to him, "O 'Asim! Suppose a man saw another man with his wife, would he kill him whereupon you would kill him; or what should he do? Please, O 'Asim, ask about this on my behalf." 'Asim asked Allah's Apostle about it. Allah's Apostle, disliked that question and considered it disgraceful. What 'Asim heard from Allah's Apostle was hard on him. When 'Asim returned to his family, 'Uwaimir came to him and said, "O 'Asim! What did Allah's Apostle. say to you?" 'Asim said to 'Uwaimir, "You never bring me any good. Allah's Apostle disliked the problem which I asked him about." 'Uwaimir said, "By Allah, I will not give up this matter until I ask the Prophet about it." So 'Uwaimir proceeded till he came to Allah's Apostle in the midst of people, and said, "O Allah's Apostle! If a man sees another man with his wife, would he kill him, whereupon you would kill him, or what should he do?" Allah's Apostle said, "Allah has revealed some decree as regards you and your wives case. Go and bring her." So they carried out the process of Lian while I was present among the people with Allah's Apostle. When they had finished their Lian, 'Uwaimir said, "O Allah's Apostle! If I should now keep her with me as a wife, then I have told a lie." So he divorced her thrice before Allah's Apostle ordered him. (Ibn Shihab said: So divorce was the tradition for all those who were involved in a case of Lian.)


Bukhari :: Divorce :: [7.63.229]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 229

Narrated Ibn Juraij:

Ibn Shihab informed me of Lian and the tradition related to it, referring to the narration of Sahl bin Sad, the brother of Bani Sa'idi He said, "An Ansari man came to Allah's Apostle and said, 'O Allah's Apostle! If a man saw another man with his wife, should he kill him, or what should he do?' So Allah revealed concerning his affair what is mentioned in the Holy Quran about the affair of those involved in a case of Lian. The Prophet said, 'Allah has given His verdict regarding you and your wife.' So they carried out Lian in the mosque while I was present there. When they had finished, the man said, "O Allah's Apostle! If I should now keep her with me as a wife then I have told a lie about her. Then he divorced her thrice before Allah's Apostle ordered him, when they had finished the Lian process. So he divorced her in front of the Prophet ." Ibn Shihab added, "After their case, it became a tradition that a couple involved in a case of Lian should be separated by divorce. That lady was pregnant then, and later on her son was called by his mother's name. The tradition concerning their inheritance was that she would be his heir and he would inherit of her property the share Allah had prescribed for him." Ibn Shihab said that Sahl bin Sad As'Saidi said that the Prophet said (in the above narration), "If that lady delivers a small red child like a lizard, then the lady has spoken the truth and the man was a liar, but if she delivers a child with black eyes and huge lips, then her husband has spoken the truth." Then she delivered it in the shape one would dislike (as it proved her guilty).


Bukhari :: Divorce :: [7.63.230]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 230

Narrated Al-Qasim bin Muhammad:

Ibn 'Abbas; said, "Once Lian was mentioned before the Prophet whereupon 'Asim bin Adi said something and went away. Then a man from his tribe came to him, complaining that he had found a man width his wife. 'Asim said, 'I have not been put to task except for my statement (about Lian).' 'Asim took the man to the Prophet and the man told him of the state in which he had found his wife. The man was pale, thin, and of lank hair, while the other man whom he claimed he had seen with his wife, was brown, fat and had much flesh on his calves. The Prophet invoked, saying, 'O Allah! Reveal the truth.' So that lady delivered a child resembling the man whom her husband had mentioned he had found her with. The Prophet then made them carry out Lian." Then a man from that gathering asked Ibn 'Abbas, "Was she the same lady regarding which the Prophet had said, 'If I were to stone to death someone without witness, I would have stoned this lady'?" Ibn 'Abbas said, "No, that was another lady who, though being a Muslim, used to arouse suspicion by her outright misbehavior. "


Bukhari :: Divorce :: [7.63.231]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 231

Narrated Said bin Jubair:

I asked Ibn 'Umar, "(What is the verdict if) a man accuses his wife of illegal sexual intercourse?" Ibn 'Umar said, "The Prophet separated (by divorce) the couple of Bani Al-Ajlan, and said, (to them), 'Allah knows that one of you two is a liar; so will one of you repent?' But both of them refused. He again said, 'Allah knows that one of you two is a liar; so will one of you repent?' But both of them refused. So he separated them by divorce." (Aiyub, a sub-narrator said: 'Amr bin Dinar said to me, "There is something else in this Hadith which you have not mentioned. It goes thus: The man said, 'What about my money (i.e. the Mahr that I have given to my wife)?' It was said, 'You have no right to restore any money, for if you have spoken the truth (as regards the accusation), you have also consummated your marriage with her; and if you have told a lie, you are less rightful to have your money back.' ")


Bukhari :: Divorce :: [7.63.232]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 232

Narrated Said bin Jubair:

I asked Ibn 'Umar about those who were involved in a case of Lien. He said, "The Prophet said to those who were involved in a case of Lien, 'Your accounts are with Allah. One of you two is a liar, and you (the husband) have no right over her (she is divorced)." The man said, 'What about my property (Mahr) ?' The Prophet said, 'You have no right to get back your property. If you have told the truth about her then your property was for the consummation of your marriage with her; and if you told a lie about her, then you are less rightful to get your property back.' " Sufyan, a sub-narrator said: I learned the Hadith from 'Amr. Narrated Aiyub: I heard Sa'id bin Jubair saying, "I asked Ibn 'Umar, 'If a man (accuses his wife for an illegal sexual intercourse and) carries out the process of Lian (what will happen)?' Ibn 'Umar set two of his fingers apart. (Sufyan set his index finger and middle finger apart.) Ibn 'Umar said, 'The Prophet separated the couple of Bani Al-Ajlan by divorce and said thrice, "Allah knows that one of you two is a liar; so will one of you repent (to Allah)?' "


Bukhari :: Divorce :: [7.63.233]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 233

Narrated Ibn 'Umar:

Allah's Apostle separated (divorced) the wife from her husband who accused her for an illegal sexual intercourse, and made them take the oath of Lian .


Bukhari :: Divorce :: [7.63.234]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 234

Narrated Ibn 'Umar:

The Prophet made an Ansari man and his wife carry out Lian, and then separated them by divorce.


Bukhari :: Divorce :: [7.63.235]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 235

Narrated Ibn 'Umar: The Prophet made a man and his wife carry out Lian, and the husband repudiated her child. So the Prophet got them separated (by divorce) and decided that the child belonged to the mother only.


Bukhari :: Divorce :: [7.63.236]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 236

Narrated Ibn 'Abbas:

Those involved in a case of Lian were mentioned before Allah's Apostle Asim bin Adi said something about that and then left. Later on a man from his tribe came to him and told him that he had found another man with his wife. On that 'Asim said, "I have not been put to task except for what I have said (about Lian)." 'Asim took the man to Allah's Apostle and he told him of the state in which he found his wife. The man was pale, thin and lank-haired, while the other man whom he had found with his wife was brown, fat with thick calves and curly hair. Allah's Apostle said, "O Allah! Reveal the truth." Then the lady delivered a child resembling the man whom her husband had mentioned he had found with her. So Allah's Apostle ordered them to carry out Lien. A man from that gathering said to Ibn 'Abbas, "Was she the same lady regarding whom Allah's Apostle said, 'If I were to stone to death someone without witnesses, I would have stoned this lady'?" Ibn 'Abbas said, "No, that was another lady who, though being a Muslim, used to arouse suspicion because of her outright misbehavior."


Bukhari :: Divorce :: [7.63.237]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 237

Narrated 'Aisha:

The Prophet said . . . (as in 240).


Bukhari :: Divorce :: [7.63.238]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 238

Narrated 'Aisha:

Rifa'a Al-Qurazi married a lady and then divorced her whereupon she married another man. She came to the Prophet and said that her new husband did not approach her, and that he was completely impotent. The Prophet said (to her), "No (you cannot remarry your first husband) till you taste the second husband and he tastes you (i.e. till he consummates his marriage with you)."


Bukhari :: Divorce :: [7.63.239]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 239

Narrated Um Salama:

(the wife of the Prophet) A lady from Bani Aslam, called Subai'a, become a widow while she was pregnant. Abu As-Sanabil bin Ba'kak demanded her hand in marriage, but she refused to marry him and said, "By Allah, I cannot marry him unless I have completed one of the two prescribed periods." About ten days later (after having delivered her child), she went to the Prophet and he said (to her), "You can marry now."


Bukhari :: Divorce :: [7.63.240]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 240

Narrated 'Abdullah bin 'Abdullah:

that his father had written to Ibn Al-Arqam a letter asking him to ask Subai'a Al-Aslamiya how the Prophet had given her the verdict. She said, "The Prophet, gave me his verdict that after I gave birth, I could marry."


Bukhari :: Divorce :: [7.63.241]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 241

Narrated Al-Miswer bin Makhrama:

Subai'a Al-Aslamiya gave birth to a child a few days after the death of her husband. She came to the Prophet and asked permission to remarry, and the Prophet gave her permission, and she got married.


Bukhari :: Divorce :: [7.63.242]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 242

Narrated Qasim bin Muhammad and Sulaiman bin Yasar:

that Yahya bin Said bin Al-'As divorced the daughter of 'Abdur-Rahman bin Al-Hakarn. Abdur-Rahman took her to his house. On that 'Aisha sent a message to Marwan bin Al-Hakam who was the ruler of Medina, saying, "Fear Allah, and urge your brother) to return her to her house." Marwan (in Sulaiman's version) said, "Abdur-Rahman bin Al-Hakam did not obey me (or had a convincing argument)." (In Al-Qasim's versions Marwan said, "Have you not heard of the case of Fatima bint Qais?" Aisha said, "The case of Fatima bint Qais is not in your favor.' Marwan bin Al-Hakam said to 'Aisha, "The reason that made Fatima bint Qais go to her father's house is just applicable to the daughter of 'Abdur-Rahman."


Bukhari :: Divorce :: [7.63.243]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 243

Narrated Al-Qasim:

Aisha said, "What is wrong with Fatima? Why doesn't she fear Allah?" by saying that a divorced lady is not entitled to be provided with residence and sustenance (by her husband)


Bukhari :: Divorce :: [7.63.244]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 244

Narrated Qasim:

Ursa said to Aisha, "Do you know so-and-so, the daughter of Al-Hakam? Her husband divorced her irrevocably and she left (her husband's house)." 'Aisha said, "What a bad thing she has done!" 'Ursa said (to 'Aisha), "Haven't you heard the statement of Fatima?" 'Aisha replied, "It is not in her favor to mention." 'Ursa added, 'Aisha reproached (Fatima) severely and said, "Fatima was in a lonely place, and she was proned to danger, so the Prophet

allowed her (to go out of her husband's house)."


Bukhari :: Divorce :: [7.63.245]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 245

Narrated 'Ursa:

Aisha disapproved of what Fatima used to say.'


Bukhari :: Divorce :: [7.63.246]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 246

Narrated 'Aisha:

When Allah's Apostle decided to leave Mecca after the Hajj, he saw Safiyya, sad and standing at the entrance of her tent. He said to her, "Aqr (or) Halq! You will detain us. Did you perform Tawaf-al-Ifada on the day of Nahr? She said, "Yes." He said, "Then you can depart."


Bukhari :: Divorce :: [7.63.247]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 247

Narrated Al-Hasan:

Ma'qil gave his sister in marriage and later her husband divorced her once.


Bukhari :: Divorce :: [7.63.248]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 248

Narrated Al-Hasan:

The sister of Ma'qil bin Yasar was married to a man and then that man divorced her and remained away from her till her period of the 'Iddah expired. Then he demanded for her hand in marriage, but Ma'qil got angry out of pride and haughtiness and said, "He kept away from her when he could still retain her, and now he demands her hand again?" So Ma'qil disagreed to remarry her to him. Then Allah revealed: 'When you have divorced women and they have fulfilled the term of their prescribed period, do not prevent them from marrying their (former) husbands.' (2.232) So the Prophet sent for Ma'qil and recited to him (Allah's order) and consequently Ma'qil gave up his pride and haughtiness and yielded to Allah's order.


Bukhari :: Divorce :: [7.63.249]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 249

Narrated Nafi:

Ibn 'Umar bin Al-Khattab divorced his wife during her menses. Allah's Apostle ordered him to take her back till she became clean, and when she got another period while she was with him, she should wait till she became clean again and only then, if he wanted to divorce her, he could do so before having sexual relations with her. And that is the period Allah has fixed for divorcing women. Whenever 'Abdullah (bin 'Umar) was asked about that, he would say to the questioner, "If you divorced her thrice, she is no longer lawful for you unless she marries another man (and the other man divorces her in his turn).' Ibn 'Umar further said, 'Would that you (people) only give one or two divorces, because the Prophet has ordered me so."


Bukhari :: Divorce :: [7.63.250]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 250

Narrated Yunus Ibn Jubair:

Ibn 'Umar divorced his wife while she was having her menses. 'Umar asked the Prophet who said, "Order him (your son) to take her back, and then divorced her before her period of the 'Iddah has elapsed." I asked Ibn 'Umar, "Will that divorce (during the menses) be counted?" He replied, "If somebody behaves foolishly (will his foolishness be an excuse for his misbehavior)?"


Bukhari :: Divorce :: [7.63.251]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 251

Narrated Humaid bin Nafi':

Zainab bint Abu Salama told me these three narrations: Zainab said: I went to Um Habiba, the wife of the Prophet when her father, Abu- Sufyan bin Herb had died. Um ,Habiba asked for a perfume which contained yellow scent (Khaluq) or some other scent, and she first perfumed one of the girls with it and then rubbed her cheeks with it and said, "By Allah, I am not in need of perfume, but I have heard Allah's Apostle saying, 'It is not lawful for a lady who believes in Allah and the Last Day to mourn for a dead person for more than three days unless he is her husband for whom she should mourn for four months and ten days.' " Zainab further said: I want to Zainab bint Jahsh when her brother died. She asked for perfume and used some of it and said, "By Allah, I am not in need of perfume, but I have heard Allah's Apostle saying on the pulpit, 'It is not lawful for a lady who believes in Allah and the last day to mourn for more than three days except for her husband for whom she should mourn for four months and ten days.' " Zainab further said, "I heard my mother, Um Salama saying that a woman came to Allah's Apostle and said, "O Allah's Apostle! The husband of my daughter has died and she is suffering from an eye disease, can she apply kohl to her eye?" Allah's Apostle replied, "No," twice or thrice. (Every time she repeated her question) he said, "No." Then Allah's Apostle added, "It is just a matter of four months and ten days. In the Pre-Islamic Period of ignorance a widow among you should throw a globe of dung when one year has elapsed." I said to Zainab, "What does 'throwing a globe of dung when one year had elapsed' mean?" Zainab said, "When a lady was bereaved of her husband, she would live in a wretched small room and put on the worst clothes she had and would not touch any scent till one year had elapsed. Then she would bring an animal, e.g. a donkey, a sheep or a bird and rub her body against it. The animal against which she would rub her body would scarcely survive. Only then she would come out of her room, whereupon she would be given a globe of dung which she would throw away and then she would use the scent she liked or the like."


Bukhari :: Divorce :: [7.63.252]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 252

Narrated Um Salama:

A woman was bereaved of her husband and her relatives worried about her eyes (which were diseased). They came to Allah's Apostle, and asked him to allow them to treat her eyes with kohl, but he said, "She should not apply kohl to her eyes. (In the Pre-Islamic period of Ignorance) a widowed woman among you would stay in the worst of her clothes (or the worst part of her house) and when a year had elapsed, if a dog passed by her, she would throw a globe of dung, Nay, (she cannot use kohl) till four months and ten days have elapsed."

Narrated Um Habiba: The Prophet said, "It is not lawful for a Muslim woman who believes in Allah and the Last Day to mourn for more than three days, except for her husband, for whom she should mourn for four months and ten days."


Bukhari :: Divorce :: [7.63.253]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 253

Narrated Um 'Atiyya:

We were forbidden to mourn for more than three days except for a husband.


Bukhari :: Divorce :: [7.63.254]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 254

Narrated Um 'Atiyya:

We were forbidden to mourn for more than three days for a dead person, except for a husband, for whom a wife should mourn for four months and ten days (while in the mourning period) we were not allowed to put kohl in our eyes, nor perfume our-selves, nor wear dyed clothes, except a garment of 'Asb (special clothes made in Yemen). But it was permissible for us that when one of us became clean from her menses and took a bath, she could use a piece of a certain kind of incense. And it was forbidden for us to follow funeral processions.


Bukhari :: Divorce :: [7.63.255]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 255

Narrated Um 'Atiyya:

The Prophet said, "It is not lawful for a lady who believes in Allah and the Last Day, to mourn for more than three days for a dead person, except for her husband, in which case she should neither put kohl in her eyes, nor perfume herself, nor wear dyed clothes, except a garment of 'Asb" Um 'Atiyya added: The Prophet said, "She should not use perfume except when she becomes clean from her menses whereupon she can use Qust, and Azfar (two kinds of incense).


Bukhari :: Divorce :: [7.63.256]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 256

Narrated Mujahid:

(regarding the Verse): 'If any of you dies and leaves wives behind,' That was the period of the 'Iddah which the widow was obliged to spend in the house of the late husband. Then Allah revealed: And those of you who die and leave wives should bequeath for their wives a year's maintenance and residence without turning them out, but if they leave, there is no blame on you for what they do of themselves, provided it is honorable (i.e. lawful marriage) (2.240) Mujahid said: Allah has ordered that a widow has the right to stay for seven months and twenty days with her husband's relatives through her husband's will and testament so that she will complete the period of one year (of 'Iddah). But the widow has the right to stay that extra period or go out of her husband's house as is indicated by the statement of Allah: 'But if they leave there is no blame on you,... ' (2.240) Ibn 'Abbas said: The above Verse has cancelled the order of spending the period of the 'Iddah at her late husband's house, and so she could spend her period of the 'Iddah wherever she likes. And Allah says: 'Without turning them out.' 'Ata said: If she would, she could spend her period of the 'Iddah at her husband's house, and live there according to her (husband's) will and testament, and if she would, she could go out (of her husband's house) as Allah says: 'There is no blame on you for what they do of themselves.' (2.240) 'Ata added: Then the Verses of inheritance were revealed and the order of residence (for the widow) was cancelled, and she could spend her period of the 'Iddah wherever she would like, and she was no longer entitled to be accommodated by her husband's family.


Bukhari :: Divorce :: [7.63.257]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 257

Narrated Zainab bint Um Salama:

When Um Habiba bint Abi Sufyan was informed of her father's death, she asked for perfume and rubbed it over her arms and said, "I am not in need of perfume, but I have heard the Prophet saying, "It is not lawful for a lady who believes in Allah and the Last Day to mourn for more than three days except for her husband for whom the (mourning) period is four months and ten days."


Bukhari :: Divorce :: [7.63.258]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 258

Narrated Abu Mas'ud:

The Prophet prohibited taking the price of a dog, the earnings of a soothsayer and the money earned by prostitution.


Bukhari :: Divorce :: [7.63.259]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 259

Narrated Abu Juhaifa:

The Prophet cursed the lady who practices tattooing and the one who gets herself tattooed, and one who eats (takes) Riba' (usury) and the one who gives it. And he prohibited taking the price of a dog, and the money earned by prostitution, and cursed the makers of pictures.


Bukhari :: Divorce :: [7.63.260]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 260

Narrated Abu Huraira:

The Prophet forbade taking the earnings of a slave girl by prostitution.


Bukhari :: Divorce :: [7.63.261]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 261

Narrated Said bin Jubair:

I said to Ibn 'Umar, "If a man accuses his wife of illegal sexual intercourse (what is the judgment)?" He said, "Allah's Prophet separated the couple of Bani 'Ajlan (when the husband accused his wife for an illegal sexual intercourse). The Prophet said, 'Allah knows that one of you two IS a liar; so will one of you repent?' But they refused. He then again said, 'Allah knows that one of you two is a liar; so will one of you repent?' But they refused, whereupon he separated them by divorce." Aiyub (a sub-narrator) said: 'Amr bin Dinar said to me, "In the narration there is something which I do not see you mentioning, i.e. the husband said, "What about my money (Mahr)?' The Prophet said, "You are not entitled to take back money, for if you told the truth you have already entered upon her (and consummated your marriage with her) and if you are a liar then you are less entitled to take it back.


Bukhari :: Divorce :: [7.63.262]

Divorce

Bukhari :: Book 7 :: Volume 63 :: Hadith 262

Narrated Ibn 'Umar:

The Prophet said to those who were involved in a case of Lian, "Your accounts are with Allah. One of you two is a liar. You (husband) have right on her (wife)." The husband said, "My money, O Allah's Apostle!" The Prophet

said, "You are not entitled to take back any money. If you have told the truth, the Mahr that you paid, was for having sexual relations with her lawfully; and if you are a liar, then you are less entitled to get it back."


Bukhari :: Supporting the Family :: [7.64.263]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 263

Narrated Abu Mas'ud Al-Ansari:

The Prophet said, "When a Muslim spends something on his family intending to receive Allah's reward it is regarded as Sadaqa for him."


Bukhari :: Supporting the Family :: [7.64.264]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 264

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'O son of Adam! Spend, and I shall spend on you."


Bukhari :: Supporting the Family :: [7.64.265]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 265

Narrated Abu Huraira:

The Prophet said, "The one who looks after a widow or a poor person is like a Mujahid (warrior) who fights for Allah's Cause, or like him who performs prayers all the night and fasts all the day."


Bukhari :: Supporting the Family :: [7.64.266]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 266

Narrated Sad:

The Prophet visited me at Mecca while I was ill. I said (to him), "I have property; May I bequeath all my property in Allah's Cause?" He said, "No." I said, "Half of it?" He said, "No." I said, "One third of it?" He said, "One-third (is alright), yet it is still too much, for you'd better leave your inheritors wealthy than leave them poor, begging of others. Whatever you spend will be considered a Sadaqa for you, even the mouthful of food you put in the mouth of your wife. Anyhow Allah may let you recover, so that some people may benefit by you and others be harmed by you."


Bukhari :: Supporting the Family :: [7.64.267]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 267

Narrated Al-'Amash:


Bukhari :: Supporting the Family :: [7.64.268]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 268

Narrated Abu Huraira:

"The Prophet said, 'The best alms is that which is given when one is rich, and a giving hand is better than a taking one, and you should start first to support your dependents.' A wife says, 'You should either provide me with food or divorce me.' A slave says, 'Give me food and enjoy my service." A son says, "Give me food; to whom do you leave me?" The people said, "O Abu Huraira! Did you hear that from Allah's Apostle ?" He said, "No, it is from my own self."


Bukhari :: Supporting the Family :: [7.64.269]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 269

Narrated Abu Huraira:

Allah's Apostle said, "The best alms is that which you give when you are rich, and you should start first to support your dependants."


Bukhari :: Supporting the Family :: [7.64.270]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 270

Narrated 'Umar:

The Prophet used to sell the dates of the garden of Bani An-Nadir and store for his family so much food as would cover their needs for a whole year.


Bukhari :: Supporting the Family :: [7.64.271]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 271

Narrated Malik bin Aus bin Al-Hadathan:

Once I set out to visit 'Umar (bin Al-Khattab). (While I was sitting there with him his gate-keeper, Yarfa, came and said, "Uthman AbdurRahman (bin 'Auf), Az-Zubair and Sad (bin Abi Waqqas) are seeking permission (to meet you)." 'Umar said, "Yes. So he admitted them and they entered, greeted, and sat down. After a short while Yarfa came again and said to 'Umar 'Shall I admit 'Ali and 'Abbas?" 'Umar said, "Yes." He admitted them and when they entered, they greeted and sat down. 'Abbas said, "O Chief of the Believers! Judge between me and this ('Ali)." The group, 'Uthman and his companions Sad, 'O Chief of the Believers! Judge between them and relieve one from the other." 'Umar said. Wait! I beseech you by Allah, by Whose permission both the Heaven and the Earth stand fast ! Do you know that Allah's Apostle said. 'We (Apostles) do not bequeath anything to our heirs, but whatever we leave is to be given in charity.' And by that Allah's Apostles meant himself?" The group said, "He did say so." 'Umar then turned towards 'All and 'Abbas and said. "I beseech you both by Allah, do you know that Allah's Apostle said that?" They said, 'Yes " 'Umar said, "Now, let me talk to you about this matter. Allah favored His Apostle with something of this property (war booty) which He did not give to anybody else. And Allah said:-- 'And what Allah has bestowed on His Apostle (as Fai Booty) from them for which you made no expedition with either cavalry or camelry . . . Allah is Able to do all things.' (59.6) So this property was especially granted to Allah's Apostle. But by Allah he neither withheld it from you, nor did he keep it for himself and deprive you of it, but he gave it all to you and distributed it among you till only this remained out of it. And out of this property Allah's Apostle used to provide his family with their yearly needs, and whatever remained, he would spend where Allah's Property (the revenues of Zakat) used to be spent. Allah's Apostle kept on acting like this throughout his lifetime. Now I beseech you by Allah, do you know that?" They said, "Yes." Then 'Umar said to 'Ali and 'Abbas, "I beseech you by Allah, do you both know that?" They said, "Yes." 'Umar added, "When Allah had taken His Apostle unto Him, Abu Bakr said, 'I am the successor of Allah's Apostle. So he took charge of that property and did with it the same what Allah's Apostle used to do, and both of you knew all about it then." Then 'Umar turned towards 'Ali and Abbas and said, "You both claim that Abu- Bakr was so-and-so! But Allah knows that he was honest, sincere, pious and right (in that matter). Then Allah caused Abu Bakr to die, and i said, 'I am the successor of Allah's Apostle and Abu Bakr.' So I kept this property in my possession for the first two years of my rule, and I used to do the same with it as Allah's Apostle and Abu Bakr used to do. Later both of you ('Ali and 'Abbas) came to me with the same claim and the same problem. (O 'Abbas!) You came to me demanding your share from (the inheritance of) the son of your brother, and he ('Ali) came to me demanding his wives share from (the inheritance of) her father. So I said to you, 'If you wish I will hand over this property to you, on condition that you both promise me before Allah that you will manage it in the same way as Allah's Apostle and Abu Bakr did, and as I have done since the beginning of my rule; otherwise you should not speak to me about it.' So you both said, 'Hand over this property to us on this condition.' And on this condition I handed it over to you. I beseech you by Allah, did I hand it over to them on that condition?" The group said, "Yes." 'Umar then faced 'Ali and 'Abbas and said, "I beseech you both by Allah, did I hand it over to you both on that condition?" They both said, "Yes." 'Umar added, "Do you want me now to give a decision other than that? By Him with Whose permission (order) both the Heaven and the Earth stand fast, I will never give any decision other than that till the Hour is established! But if you are unable to manage it (that property), then return it to me and I will be sufficient for it on your behalf . "


Bukhari :: Supporting the Family :: [7.64.272]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 272

Narrated 'Aisha:

Hind bint 'Utba came and said, "O Allah's Apostle! Abu Sufyan is a miser so is it sinful of me to feed our children from his property?" Allah's Apostle said, "No except if you take for your needs what is just and reasonable. "


Bukhari :: Supporting the Family :: [7.64.273]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 273

Narrated Abu Huraira:

The Prophet said, "If the wife gives of her husband's property (something in charity) without his permission, he will get half the reward."


Bukhari :: Supporting the Family :: [7.64.274]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 274

Narrated Ali:

Fatima went to the Prophet complaining about the bad effect of the stone hand-mill on her hand. She heard that the Prophet had received a few slave girls. But (when she came there) she did not find him, so she mentioned her problem to 'Aisha. When the Prophet came, 'Aisha informed him about that. 'Ali added, "So the Prophet came to us when we had gone to bed. We wanted to get up (on his arrival) but he said, 'Stay where you are." Then he came and sat between me and her and I felt the coldness of his feet on my abdomen. He said, "Shall I direct you to something better than what you have requested? When you go to bed say 'Subhan Allah' thirty-three times, 'Alhamdulillah' thirty three times, and Allahu Akbar' thirty four times, for that is better for you than a servant."


Bukhari :: Supporting the Family :: [7.64.275]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 275

Narrated 'Ali bin Abi Talib:

Fatima came to the Prophet asking for a servant. He said, "May I inform you of something better than that? When you go to bed, recite "Subhan Allah' thirty three times, 'Alhamdulillah' thirty three times, and 'Allahu Akbar' thirty four times. 'All added, 'I have never failed to recite it ever since." Somebody asked, "Even on the night of the battle of Siffin?" He said, "No, even on the night of the battle of Siffin."


Bukhari :: Supporting the Family :: [7.64.276]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 276

Narrated Al-Aswad bin Yazid:

I asked 'Aisha "What did the Prophet use to do at home?" She said, "He used to work for his family, and when he heard the Adhan (call for the prayer), he would go out."


Bukhari :: Supporting the Family :: [7.64.277]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 277

Narrated 'Aisha:

Hind bint 'Utba said, "O Allah's Apostle! Abu Sufyan is a miser and he does not give me what is sufficient for me and my children. Can I take of his property without his knowledge?" The Prophet said, "Take what is sufficient for you and your children, and the amount should be just and reasonable.


Bukhari :: Supporting the Family :: [7.64.278]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 278

Narrated Abu Huraira:

Allah's Apostle said, "The best women among the camel riders, are the women of Quraish." (Another narrator said) The Prophet said, "The righteous among the women of Quraish are those who are kind to their young ones and who look after their husband's property . "


Bukhari :: Supporting the Family :: [7.64.279]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 279

Narrated 'Ali:

The Prophet gave me a silk suit and I wore it, but when I noticed anger on his face, I cut it and distributed it among my women-folk.


Bukhari :: Supporting the Family :: [7.64.280]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 280

Narrated Jabir bin 'Abdullah:

My father died and left seven or nine girls and I married a matron. Allah's Apostle said to me, "O Jabir! Have you married?" I said, "Yes." He said, "A virgin or a matron?" I replied, "A matron." he said, "Why not a virgin, so that you might play with her and she with you, and you might amuse her and she amuse you." I said, " 'Abdullah (my father) died and left girls, and I dislike to marry a girl like them, so I married a lady (matron) so that she may look after them." On that he said, "May Allah bless you," or "That is good."


Bukhari :: Supporting the Family :: [7.64.281]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 281

Narrated Abu Huraira:

A man came to the Prophet and said, "I am ruined!" The Prophet said, "Why?" He said, "I had sexual intercourse with my wife while fasting (in the month of Ramadan)." The Prophet said to him, "Manumit a slave (as expiation)." He replied, "I cannot afford that." The Prophet said, "Then fast for two successive months." He said, "I cannot." The Prophet said, "Then feed sixty poor persons." He said, "I have nothing to do that." In the meantime a basket full of dates was brought to the Prophet . He said, "Where is the questioner." The man said, "I am here." The Prophet said (to him), "Give this (basket of dates) in charity (as expiation)." He said, "O Allah's Apostle! Shall I give it to poorer people than us? By Him Who sent you with the Truth, there is no family between Medina's two mountains poorer than us." The Prophet smiled till his pre-molar teeth became visible. He then said, "Then take it."


Bukhari :: Supporting the Family :: [7.64.282]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 282

Narrated Um Salama:

I said, "O Allah's Apostle! Shall I get a reward (in the Hereafter) if I spend on the children of Abu Salama and do not leave them like this and like this (i.e., poor) but treat them like my children?" The Prophet said, "Yes, you will be rewarded for that which you will spend on them."


Bukhari :: Supporting the Family :: [7.64.283]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 283

Narrated 'Aisha :

Hind (bint 'Utba) said, "O Allah's Apostle! Abu Sufyan is a miser. Is there any harm if I take of his property what will cover me and my children's needs?" The Prophet said, "Take (according to your needs) in a reasonable manner."


Bukhari :: Supporting the Family :: [7.64.284]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 284

Narrated Abu Huraira:

A dead man in debt used to be brought to Allah's Apostle who would ask, "Has he left anything to re pay his debts?" If he was informed that he had left something to cover his debts the Prophet would offer the funeral prayer for him; otherwise he would say to the Muslims present there), "Offer the funeral prayer for your friend:"but when Allah helped the Prophet to gain victory (on his expeditions), he said, "I am closer to the Believers than themselves, so. if one of the Believers dies in debt, I will repay it, but if he leaves wealth, it will be for his heirs.


Bukhari :: Supporting the Family :: [7.64.285]

Supporting the Family

Bukhari :: Book 7 :: Volume 64 :: Hadith 285

Narrated Um Habiba:

(the wife of the Prophet) I said, "O Allah's Apostle! Will you marry my sister, the daughter of Abu Sufyan." The Prophet said, "Do you like that?" I said, "Yes, for I am not your only wife, and the person I like most to share the good with me, is my sister." He said, "That is not lawful for me." I said, "O Allah's Apostle! We have heard that you want to marry Durra, the daughter of Abu Salama." He said, "You mean the daughter of Um Salama?" I said, "Yes." He said, "Even if she were not my step-daughter, she is unlawful for me, for she is my foster niece. Thuwaiba suckled me and Abu Salama. So you should not present to me your daughters and sisters."

Narrated 'Ursa: Thuwaiba had been a slave girl whom Abu Lahab had emancipated.


Bukhari :: Food, Meals :: [7.65.286]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 286

Narrated Abu Musa Al-Ash'ari:

The Prophet said, "Give food to the hungry, pay a visit to the sick and release (set free) the one in captivity (by paying his ransom)."


Bukhari :: Food, Meals :: [7.65.287]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 287

Narrated Abu Huraira:

Once while I was in a state of fatigue (because of severe hunger), I met 'Umar bin Al-Khattab, so I asked him to recite a verse from Allah's Book to me. He entered his house and interpreted it to me. (Then I went out and) after walking for a short distance, I fell on my face because of fatigue and severe hunger. Suddenly I saw Allah's Apostle standing by my head. He said, "O Abu Huraira!" I replied, "Labbaik, O Allah's Apostle, and Sadaik!" Then he held me by the hand, and made me get up. Then he came to know what I was suffering from. He took me to his house, and ordered a big bowl of milk for me. I drank thereof and he said, "Drink more, O Abu Hirr!" So I drank again, whereupon he again said, "Drink more." So I drank more till my belly became full and looked like a bowl. Afterwards I met 'Umar and mentioned to him what had happened to me, and said to him, "Somebody, who had more right than you, O 'Umar, took over the case. By Allah, I asked you to recite a Verse to me while I knew it better than you." On that Umar said to me, "By Allah, if I admitted and entertained you, it would have been dearer to me than having nice red camels.


Bukhari :: Food, Meals :: [7.65.288]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 288

Narrated 'Umar bin Abi Salama:

I was a boy under the care of Allah's Apostle and my hand used to go around the dish while I was eating. So Allah's Apostle said to me, 'O boy! Mention the Name of Allah and eat with your right hand, and eat of the dish what is nearer to you." Since then I have applied those instructions when eating.


Bukhari :: Food, Meals :: [7.65.289]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 289

Narrated 'Umar bin Al Salama:

Who was the son of Um Salama, the wife of the Prophet:

Once I ate a meal with Allah's Apostle and I was eating from all sides of the dish. So Allah's Apostle said to me, "Eat of the dish what is nearer to you."


Bukhari :: Food, Meals :: [7.65.290]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 290

Narrated Wahb bin Kaisan Abi Nu'aim:

A meal was brought to Allah's Apostle while his step-son, 'Umar bin Abi Salama was with him. Allah's Apostle said to him, "Mention the Name of Allah and eat of the dish what is nearer to you."


Bukhari :: Food, Meals :: [7.65.291]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 291

Narrated Anas bin Malik:

A tailor invited Allah's Apostle to a meal which he had prepared. I went along with Allah's Apostle and saw him seeking to eat the pieces of gourd from the various sides of the dish. Since that day I have liked to eat gourd. 'Umar bin Abi Salama said: The Prophet, said to me, "Eat with your right hand."


Bukhari :: Food, Meals :: [7.65.292]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 292

Narrated 'Aisha:

The Prophet used to love to start doing things from the right side whenever possible, in performing ablution, putting on his shoes, and combing his hair. (Al-Ash'ath said: The Prophet used to do so in all his affairs.)


Bukhari :: Food, Meals :: [7.65.293]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 293

Narrated Anas bin Malik:

Abu Talha said to Um Sulaim, "I have heard the voice of Allah's Apostle which was feeble, and I think that he is hungry. Have you got something (to eat)?" She took out some loaves of barley bread, then took her face-covering sheet and wrapped the bread in part of it, and pushed it under my garment and turned the rest of it around my body and sent me to Allah's Apostle . I went with that, and found Allah's Apostle in the mosque with some people. I stood up near them, and Allah's Apostle asked me, "Have you been sent by Abu Talha?" I said, "Yes." He asked, "With some food (for us)?" I said, "Yes." Then Allah's Apostle said to all those who were with him, "Get up!" He set out (and all the people accompanied him) and I proceeded ahead of them till I came to Abu Talha. Abu Talha then said, "O Um Sulaim! Allah's Apostle has arrived along with the people, and we do not have food enough to feed them all." She said, "Allah and His Apostle know better." So Abu Talha went out till he met Allah's Apostle. Then Abu Talha and Allah's Apostle came and entered the house. Allah's Apostle said, "Um Sulaim ! Bring whatever you have." She brought that very bread. The Prophet ordered that it be crushed into small pieces, and Um Sulaim pressed a skin of butter on it. Then Allah's Apostle said whatever Allah wished him to say (to bless the food) and then added, "Admit ten (men)." So they were admitted, ate their fill and went out. The Prophet then said, "Admit ten (more)." They were admitted, ate their full, and went out. He then again said, "Admit ten more!" They were admitted, ate their fill, and went out. He admitted ten more, and so all those people ate their fill, and they were eighty men.


Bukhari :: Food, Meals :: [7.65.294]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 294

Narrated 'Abdur-Rahman bin Abu Bakr:

We were one hundred and thirty men sitting with the Prophet. The Prophet said, "Have anyone of you any food with him?" It happened that one man had one Sa of wheat flour (or so) which was turned into dough then. After a while a tall lanky pagan came, driving some sheep. The Prophet asked, 'Will you sell us (a sheep), or give (it to) us as a gift?" The pagan said, "No, but I will sell it " So the Prophet bought from him a sheep which was slaughtered, and then the Prophet ordered that the liver, the kidneys, lungs and heart, etc., of that sheep be roasted. By Allah, none of those one hundred and thirty men but had his share of those things. The Prophet gave to those who were present, and also kept a share for those who were absent He then served that cooked sheep in two big trays and we all ate together our fill; yet there remained a part of it in those two trays which I carried on the camel.


Bukhari :: Food, Meals :: [7.65.295]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 295

Narrated 'Aisha :

The Prophet died when we had satisfied our hunger with the two black things, i.e. dates and water.


Bukhari :: Food, Meals :: [7.65.296]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 296

Narrated Suwaid bin An-Nu'man:

We went out with Allah's Apostle to Khaibar, and when we were at As-Sahba', (Yahya, a sub-narrator said, "As-Sahba' is a place at a distance of one day's journey to Khaibar)." Allah's Apostle asked the people to bring their food, but there was nothing with the people except Sawiq. So we all chewed and ate of it. Then the Prophet asked for some water and he rinsed his mouth, and we too, rinsed our mouths. Then he led us in the Maghrib prayer without performing ablution (again).


Bukhari :: Food, Meals :: [7.65.297]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 297

Narrated Qatada:

We were in the company of Anas whose baker was with him. Anas said, The Prophet did not eat thin bread, or a roasted sheep till he met Allah (died).


Bukhari :: Food, Meals :: [7.65.298]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 298

Narrated Anas:

To the best of my knowledge, the Prophet did not take his meals in a big tray at all, nor did he ever eat well-baked thin bread, nor did he ever eat at a dining table.


Bukhari :: Food, Meals :: [7.65.299]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 299

Narrated Anas:

The Prophet halted to consummate his marriage with Safiyya. I invited the Muslims to his wedding banquet. He ordered that leather dining sheets be spread. Then dates, dried yoghurt and butter were put on those sheets. Anas added: The Prophet consummated his marriage with Safiyya (during a journey) whereupon Hais (sweet dish) was served on a leather dining sheet.


Bukhari :: Food, Meals :: [7.65.300]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 300

Narrated Wahb bin Kaisan:

The People of Sham taunted 'Abdullah bin Az-Zubair by calling him "The son of Dhatin-Nataqain" (the woman who has two waist-belts). (His mother) (Asma, said to him, "O my son! They taunt you with "Nataqain". Do you know what the Nataqain were? That was my waist-belt which I divided in two parts. I tied the water skin of Allah's Apostle with one part, and with the other part I tied his food container."


Bukhari :: Food, Meals :: [7.65.301]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 301

Narrated Ibn 'Abbas:

that his aunt, Um Hufaid bint Al-Harith bin Hazn, presented to the Prophet butter, dried yoghurt and mastigures. The Prophet invited the people to those mastigures and they were eaten on his dining sheet, but the Prophet did not eat of it, as if he disliked it. Nevertheless. if it was unlawful to eat that, the people would not have eaten it on the dining sheet of the Prophet nor would he have ordered that they be eaten.


Bukhari :: Food, Meals :: [7.65.302]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 302

Narrated Suwaid bin An-Nu'man:

that while they were with the Prophet at As-Sahba' which was at a distance of one day's journey from Khaibar the prayer became due, and the Prophet asked the people for food but there was nothing with the people except Sawiq. He ate of it and we ate along with him, and then he asked for water and rinsed his mouth (with it), and then offered the (Maghrib) prayer and we too offered the prayer but the Prophet did not perform ablution (again after eating the Sawiq.).


Bukhari :: Food, Meals :: [7.65.303]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 303

Narrated Khalid bin Al-Walid:

That he went with Allah's Apostle to the house of Maimuna, who was his and Ibn 'Abbas' aunt. He found with her a roasted mastigure which her sister Hufaida bint Al-Harith had brought from Najd. Maimuna presented the mastigure before Allah's Apostle who rarely started eating any (unfamiliar) food before it was described and named for him. (But that time) Allah's Apostle stretched his hand towards the (meat of the) mastigure whereupon a lady from among those who were present, said, "You should inform Allah's Apostle of what you have presented to him. O Allah's Apostle! It is the meat of a mastigure." (On learning that) Allah's Apostle withdrew his hand from the meat of the mastigure. Khalid bin Al-Walid said, "O Allah's Apostle! Is this unlawful to eat?" Allah's Apostle replied, "No, but it is not found in the land of my people, so I do not like it." Khalid said, "Then I pulled the mastigure (meat) towards me and ate it while Allah's Apostle was looking at me.


Bukhari :: Food, Meals :: [7.65.304]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 304

Narrated Abu Huraira:

Allah's Apostle said, "The food for two persons is sufficient for three, and the food of three persons is sufficient for four persons."


Bukhari :: Food, Meals :: [7.65.305]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 305

Narrated Nafi':

Ibn 'Umar never used to take his meal unless a poor man was called to eat with him. One day I brought a poor man to eat with him, the man ate too much, whereupon Ibn 'Umar said, "O Nafi'! Don't let this man enter my house, for I heard the Prophet saying, "A believer eats in one intestine (is satisfied with a little food), and a kafir (unbeliever) eats in seven intestines (eats much food)."


Bukhari :: Food, Meals :: [7.65.306]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 306

Narrated Ibn 'Umar:

Allah's Apostle said, "A believer eats in one intestine (is satisfied with a little food), and a kafir (unbeliever) or a hypocrite eats in seven intestines (eats too much)."


Bukhari :: Food, Meals :: [7.65.307]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 307

Narrated 'Amr:

Abu Nahik was avaricious eater. Ibn 'Umar said to him, "Allah's Apostle said, "A Kafir (unbeliever) eats in seven intestines (eats much)." On that Abu Nahik said, "But I believe in Allah and His Apostle ."


Bukhari :: Food, Meals :: [7.65.308]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 308

Narrated Abu Huraira:

Allah's Apostle said, "A Muslim eats in one intestine (i.e. he is satisfied with a little food) while a Kafir (unbeliever) eats in seven intestines (eats much)."


Bukhari :: Food, Meals :: [7.65.309]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 309

Narrated Abu Huraira:

A man used to eat much, but when he embraced Islam, he started eating less. That was mentioned to the Prophet who then said, "A believer eats in one intestine (is satisfied with a little food) and a Kafir eats in seven intestines (eats much). "


Bukhari :: Food, Meals :: [7.65.310]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 310

Narrated Abu Juhaifa:

Allah's Apostle said, "I do not take my meals while leaning (against something).


Bukhari :: Food, Meals :: [7.65.311]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 311

Narrated Abu Juhaifa:

While I was with the Prophet he said to a man who was with him, "I do not take my meals while leaning."


Bukhari :: Food, Meals :: [7.65.312]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 312

Narrated Khalid bin Al-Walid:

"A roasted mastigure was brought to the Prophet who stretched his hand towards it to eat it. But it was said to him, "It is a mastigure." So he withdrew his hand. Khalid asked, "Is it unlawful to eat?" the Prophet said, "No, but it is not found in the land of my people and that is why I do not like eating it." So Khalid started eating (it) while Allah's Apostle was looking at him. An-Nadr said: 'Al-Khazira' (is prepared) from bran while 'Al-Harira' is prepared from milk.


Bukhari :: Food, Meals :: [7.65.313]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 313

Narrated 'Urban bin Malik:

who attended the Badr battle and was from the Ansar, that he came to the Prophet and said, "O Allah's Apostle! I have lost my eyesight and I lead my people in the prayer (as an Imam). When it rains, the valley which is between me and my people, flows with water, and then I cannot go to their mosque to lead them in the prayer. O Allah's Apostle! I wish that you could come and pray in my house so that I may take it as a praying place. The Prophet said, "Allah willing, I will do that." The next morning, soon after the sun had risen, Allah's Apostle came with Abu Bakr. The Prophet asked for the permission to enter and I admitted him. The Prophet had not sat till he had entered the house and said to me, "Where do you like me to pray in your house?" I pointed at a place in my house whereupon he stood and said, "Allahu Akbar." We lined behind him and he prayed two Rakat and finished it with Taslim. We then requested him to stay for a special meal of Khazira which we had prepared. A large number of men from the adjoining area gathered in the house. One of them said, "Where is Malik bin Ad-Dukhshun?" Another man said, "He is a hypocrite and does not love Allah and His Apostle." The Prophet said, "Do not say so. Do you not think that he has said: "None has the right to be worshipped but Allah," seeking Allah's pleasure? The man said, "Allah and His Apostle know better, but we have always seen him mixing with hypocrites and giving them advice." The Prophet said, "Allah has forbidden the (Hell) Fire for those who testify that none has the right to be worshipped but Allah, seeking Allah's pleasure. "


Bukhari :: Food, Meals :: [7.65.314]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 314

Narrated Ibn 'Abbas:

My aunt presented (roasted) mastigures, Iqt and milk to the Prophet . The mastigures were put on his dining sheet, and if it was unlawful to eat, it would not have been put there. The Prophet drank the milk and ate the Iqt only.


Bukhari :: Food, Meals :: [7.65.315]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 315

Narrated Sahl bin Sad:

We used to be happy on Fridays, for there was an old lady who used to pull out the roots of Silq and put it in a cooking pot with some barley. When we had finished the prayer, we would visit her and she would present that dish before us. So we used to be happy on Fridays because of that, and we never used to take our meals or have a mid-day nap except after the Friday prayer. By Allah, that meal contained no fat.


Bukhari :: Food, Meals :: [7.65.316]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 316

Narrated Ibn 'Abbas:

The Prophet ate of the meat of a shoulder (by cutting the meat with his teeth), and then got up and offered the prayer without performing the ablution anew. Narrated Ibn 'Abbas: The Prophet took out a bone with meat on it from a cooking pot and ate of it, and then offered the prayer without performing ablution anew.


Bukhari :: Food, Meals :: [7.65.317]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 317

Narrated Abu Qatada:

We went out towards Mecca with the Prophet.


Bukhari :: Food, Meals :: [7.65.318]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 318

Narrated Abu Qatada:

Once, while I was sitting with the companions of the Prophet at a station on the road to Mecca and Allah's Apostle was stationing ahead of us and all the people were assuming Ihram while I was not. My companion, saw an onager while I was busy Mending my shoes. They did not Inform me of the onager but they wished that I would see it Suddenly I looked and saw the onager Then I headed towards my horse, saddled it and rode, but I forgot to take the lash and the spear. So I said to them my companions), "Give me the lash and the spear." But they said, "No, by Allah we will not help you in any way to hunt it ' I got angry, dismounted, took it the spear and the lash), rode (the horse chased the onager and wounded it Then I brought it when it had dyed. My companions started eating of its (cooked) meat, but they suspected that it might be unlawful to eat of its meat while they were in a state of Ihram Then I proceeded further and I kept one of its forelegs with me. When we met Allah's Apostle we asked him about that. He said, "Have you some of its meat with you?" I gave him that foreleg and he ate the meat till he stripped the bone of its flesh although he was in a state of Ihram.


Bukhari :: Food, Meals :: [7.65.319]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 319

Narrated 'Amr bin Umaiyya

that he saw the Prophet holding a shoulder piece of mutton in his hand and cutting part of it with a knife. Then he was called for the prayer whereupon he put down the shoulder piece and the knife with which he was cutting it, and then stood for prayer without performing ablution again.


Bukhari :: Food, Meals :: [7.65.320]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 320

Narrated Abu Huraira:

The Prophet never criticized any food (he was invited to) but he used to eat if he liked the food, and leave it if he disliked


Bukhari :: Food, Meals :: [7.65.321]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 321

Narrated Abu Hazim:

that he asked Sahl, "Did you use white flour during the lifetime of the Prophet ?" Sahl replied, "No. Hazim asked, "Did you use to sift barley flour?" He said, "No, but we used to blow off the husk (of the barley)."


Bukhari :: Food, Meals :: [7.65.322]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 322

Narrated Abu Huraira:

Once the Prophet distributed dates among his companions and gave each one seven dates. He gave me seven dates too, one of which was dry and hard, but none of the other dates was more liked by me than that one, for it prolonged my chewing it.


Bukhari :: Food, Meals :: [7.65.323]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 323

Narrated Sad:

I was one of (the first) seven (who had embraced Islam) with Allah's Apostle and we had nothing to eat then, except the leaves of the Habala or Hubula tree, so that our stool used to be similar to that of sheep. Now the tribe of Bani Asad wants to teach me Islam; I would be a loser and all my efforts would be in vain (if I learn Islam anew from them).


Bukhari :: Food, Meals :: [7.65.324]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 324

Narrated Abu Hazim:

I asked Sahl bin Sad, "Did Allah's Apostle ever eat white flour?" Sahl said, "Allah's Apostle never saw white flour since Allah sent him as an Apostle till He took him unto Him." I asked, "Did the people have (use) sieves during the lifetime of Allah's Apostle?" Sahl said, "Allah's Apostle never saw (used) a sieve since Allah sent him as an Apostle until He took him unto Him," I said, "How could you eat barley unsifted?" he said, "We used to grind it and then blow off its husk, and after the husk flew away, we used to prepare the dough (bake) and eat it."


Bukhari :: Food, Meals :: [7.65.325]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 325

Narrated Abu Huraira:

that he passed by a group of people in front of whom there was a roasted sheep. They invited him but he refused to eat and said, "Allah's Apostle left this world without satisfying his hunger even with barley bread."


Bukhari :: Food, Meals :: [7.65.326]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 326

Narrated Anas bin Malik:

The Prophet never took his meals at a dining table, nor in small plates, and he never ate thin well-baked bread. (The sub-narrator asked Qatada, "Over what did they use to take their meals?" Qatada said, "On leather dining sheets."


Bukhari :: Food, Meals :: [7.65.327]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 327

Narrated 'Aisha:

The family of Muhammad had not eaten wheat bread to their satisfaction for three consecutive days since his arrival at Medina till he died.


Bukhari :: Food, Meals :: [7.65.328]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 328

Narrated 'Aisha:

(the wife of the Prophet) that whenever one of her relatives died, the women assembled and then dispersed (returned to their houses) except her relatives and close friends. She would order that a pot of Talbina be cooked. Then Tharid (a dish prepared from meat and bread) would be prepared and the Talbina would be poured on it. 'Aisha would say (to the women),"Eat of it, for I heard Allah's Apostle saying, 'The Talbina soothes the heart of the patient and relieves him from some of his sadness.' "


Bukhari :: Food, Meals :: [7.65.329]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 329

Narrated Abu Musa Al-Ash'ari:

The Prophet said, "Many men reached perfection but none among the women reached perfection except Mary, the daughter of ' Imran, and Asia, Pharoah's wife. And the superiority of 'Aisha to other women is like the superiority of Tharid to other kinds of food.


Bukhari :: Food, Meals :: [7.65.330]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 330

Narrated Anas:

The Prophet said, "The superiority of 'Aisha to other women is like the superiority of Tharid to other kinds of food . "


Bukhari :: Food, Meals :: [7.65.331]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 331

Narrated Anas:

I went along with the Prophet to the house of a young tailor of his. The tailor presented a dish of Tharid to the Prophet and resumed his work. The Prophet started picking the pieces of gourd and I too, started picking them and putting it before him. Since then I have always loved (to eat) gourd.


Bukhari :: Food, Meals :: [7.65.332]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 332

Narrated Qatada:

We used to visit Anas bin Malik while his baker was standing (and baking). Anas would say, "Eat! I do not know that the Prophet had ever seen well-baked bread till he met Allah, nor had he ever seen a roasted sheep with his own eyes."


Bukhari :: Food, Meals :: [7.65.333]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 333

Narrated 'Amr bin Umaiyay Ad-Damri:

I saw Allah's Apostle cutting part of the shoulder of mutton with a knife. He ate of it and then was called for prayer whereupon he got up and put down the knife and offered the prayer without performing new ablution.


Bukhari :: Food, Meals :: [7.65.334]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 334

Narrated 'Abis:

I asked 'Aisha "Did the Prophet forbid eating the meat of sacrifices offered on 'Id-ul-Adha for more than three days" She said, "The Prophet did not do this except in the year when the people were hungry, so he wanted the rich to feed the poor. But later we used to store even a trotter of a sheep to eat it fifteen days later." She was asked, "What compelled you to do so?" She smiled and said, "The family of Muhammad did not eat to their satisfaction white bread with meat soup for three successive days till he met Allah."


Bukhari :: Food, Meals :: [7.65.335]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 335

Narrated Jabir:

We used to carry the meat of the Hadis (sacrificed animals) to Medina during the life-time of the Prophet .


Bukhari :: Food, Meals :: [7.65.336]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 336

Narrated Anas bin Malik:

Allah's Apostle said to Abu Talha, "Seek one of your boys to serve me." Abu Talha mounted me behind him (on his riding animal) and took me (to the Prophet ). So I used to serve Allah's Apostle whenever he dismounted (to stay somewhere). I used to hear him saying very often, "O Allah! I seek refuge with You from, having worries sadness, helplessness, laziness, miserliness, cowardice, from being heavily in debt and from being overpowered by other persons unjustly." I kept on serving till we -returned from the battle of Khaibar. The Prophet then brought Safiyya bint Huyai whom he had won from the war booty. I saw him folding up a gown or a garment for her to sit on behind him (on his she-camel). When he reached As-Sahba', he prepared Hais and placed it on a dining sheet. Then he sent me to invite men, who (came and) ate; and that was his and Safiyya's wedding banquet. Then the Prophet proceeded, and when he saw (noticed) the mountain of Uhud, he said, "This mountain loves us, and we love it." When we approached Medina, he said, "O Allah! I make the area between its two mountains a sanctuary as Abraham has made Mecca a sanctuary. O Allah! Bless their Mudd and Sa (special kinds of measure)."


Bukhari :: Food, Meals :: [7.65.337]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 337

Narrated 'Abdur-Rahman bin Abi Laila:

We were sitting in the company of Hudhaifa who asked for water and a Magian brought him water. But when he placed the cup in his hand, he threw it at him and said, "Had I not forbidden him to do so more than once or twice?" He wanted to say, "I would not have done so," adding, "but I heard the Prophet saying, "Do not wear silk or Dibaja, and do not drink in silver or golden vessels, and do not eat in plates of such metals, for such things are for the unbelievers in this worldly life and for us in the Hereafter."


Bukhari :: Food, Meals :: [7.65.338]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 338

Narrated Abu Musa Al-Ash'ari:

Allah's Apostle said, "The example of a Believer who recites the Quran, is that of a citron which smells good and tastes good; And the example of a Believer who does not recite the Quran, is that of a date which has no smell but tastes sweet; and the example of a hypocrite who recites the Quran, is that of an aromatic plant which smells good but tastes bitter; and the example of a hypocrite who does not recite the Quran, is that of a colocynth plant which has no smell and is bitter in taste."


Bukhari :: Food, Meals :: [7.65.339]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 339

Narrated Anas:

The Prophet said, "The superiority of 'Aisha to other ladies is like the superiority of Tharid to other kinds of food."


Bukhari :: Food, Meals :: [7.65.340]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 340

Narrated Abu Huraira:

The Prophet said, "Traveling is a kind of torture, as it prevents one from sleeping and eating! So when one has finished his job, he should return quickly to his family."


Bukhari :: Food, Meals :: [7.65.341]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 341

Narrated Qasim bin Muhammad:

Three traditions have been established because of Barira: 'Aisha intended to buy her and set her free, but Barira's masters said, "Her wala' will be for us." 'Aisha mentioned that to Allah's Apostle who said, "You could accept their condition if you wished, for the wala is for the one who manumits the slave." Barira was manumitted, then she was given the choice either to stay with her husband or leave him; One day Allah's Apostle entered 'Aisha's house while there was a cooking pot of food boiling on the fire. The Prophet asked for lunch, and he was presented with bread and some extra food from the home-made Udm (e.g. soup). He asked, "Don't I see meat (being cooked)?" They said, "Yes, O Allah's Apostle! But it is the meat that has been given to Barira in charity and she has given it to us as a present." He said, "For Barira it is alms, but for us it is a present."


Bukhari :: Food, Meals :: [7.65.342]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 342

Narrated 'Aisha:

Allah's Apostle used to love sweet edible things and honey.


Bukhari :: Food, Meals :: [7.65.343]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 343

Narrated Abu Huraira:

I used to accompany Allah's Apostle to fill my stomach; and that was when I did not eat baked bread, nor wear silk. Neither a male nor a female slave used to serve me, and I used to bind stones over my belly and ask somebody to recite a Quranic Verse for me though I knew it, so that he might take me to his house and feed me. Ja'far bin Abi Talib was very kind to the poor, and he used to take us and feed us with what ever was available in his house, (and if nothing was available), he used to give us the empty (honey or butter) skin which we would tear and lick whatever was in it.


Bukhari :: Food, Meals :: [7.65.344]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 344

Narrated Anas:

Allah's Apostle went to (the house of) his slave tailor, and he was offered (a dish of) gourd of which he started eating. I have loved to eat gourd since I saw Allah's Apostle eating it.


Bukhari :: Food, Meals :: [7.65.345]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 345

Narrated Abu Mas'ud Al-Ansari:

There was a man called Abu Shu'aib, and he had a slave who was a butcher. He said (to his slave), "Prepare a meal to which I may invite Allah's Apostle along with four other men." So he invited Allah's Apostle and four other men, but another man followed them whereupon the Prophet said, "You have invited me as one of five guests, but now another man has followed us. If you wish you can admit him, and if you wish you can refuse him." On that the host said, "But I admit him." Narrated Muhammad bin Isma'il: If guests are sitting at a dining table, they do not have the right to carry food from other tables to theirs, but they can pass on food from their own table to each other; otherwise they should leave it.


Bukhari :: Food, Meals :: [7.65.346]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 346

Narrated Anas:

I was a young boy when I once was walking with Allah's Apostle . Allah's Apostle entered the house of his slave tailor and the latter brought a dish filled with food covered with pieces of gourd. Allah's Apostle started picking and eating the gourd. When I saw that, I started collecting and placing the gourd before him. Then the slave returned to his work. Anas added: I have kept on loving gourd since I saw Allah's Apostle doing what he was doing.


Bukhari :: Food, Meals :: [7.65.347]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 347

Narrated Anas bin Malik:

A tailor invited the Prophet to a meal which he had prepared, and I went along with the Prophet . The tailor presented barley bread and soup containing gourd and cured meat. I saw the Prophet picking the pieces of gourd from around the dish, and since then I have kept on liking gourd.


Bukhari :: Food, Meals :: [7.65.348]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 348

Narrated Anas:

I saw the Prophet being served with soup and containing gourd and cured meat, and I saw him picking and eating the pieces of gourd.


Bukhari :: Food, Meals :: [7.65.349]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 349

Narrated 'Aisha:

The Prophet did not do that (i.e., forbade the storage of the meat of sacrifices for three days) except (he did so) so that the rich would feed the poor. But later we used to keep even trotters to cook, fifteen days later. The family of Muhammad did not eat wheat bread with meat or soup to their satisfaction for three successive days.


Bukhari :: Food, Meals :: [7.65.350]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 350

Narrated Anas bin Malik:

A tailor invited Allah's Apostle to a meal which he had prepared. I went with Allah's Apostle to that meal, and the tailor served the Prophet with barley bread and soup of gourd and cured meat. I saw Allah's Apostle picking the pieces of gourd from around the dish, and since then I have kept on liking gourd.


Bukhari :: Food, Meals :: [7.65.351]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 351

Narrated 'Abdullah bin Ja'far bin Abi Talib:

I saw Allah's Apostle eating fresh dates with snake cucumber.


Bukhari :: Food, Meals :: [7.65.352]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 352

Narrated Abu 'Uthman:

I was a guest of Abu Huraira for seven days. Abu Huraira, his wife and his slave used to get up and remain awake for one-third of the night by turns. Each would offer the night prayer and then awaken the other. I heard Abu Huraira saying, "Allah's Apostle distributed dates among his companions and my share was seven dates, one of which was a Hashafa (a date which dried on the tree before it was fully ripe).


Bukhari :: Food, Meals :: [7.65.353]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 353

Narrated Abu Huraira:

The Prophet distributed dates among us, and my share was five dates, four of which were good, and one was a ,Hashafa, and I found the Hashafa the hardest for my teeth.


Bukhari :: Food, Meals :: [7.65.354]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 354

Narrated Jabir bin 'Abdullah:

There was a Jew in Medina who used to lend me money up to the season of plucking dates. (Jabir had a piece of land which was on the way to Ruma). That year the land was not promising, so the payment of the debt was delayed one year. The Jew came to me at the time of plucking, but gathered nothing from my land. I asked him to give me one year respite, but he refused. This news reached the Prophet whereupon he said to his companions, "Let us go and ask the Jew for respite for Jabir." All of them came to me in my garden, and the Prophet started speaking to the Jew, but he Jew said, "O Abu Qasim! I will not grant him respite." When the Prophet saw the Jew's attitude, he stood up and walked all around the garden and came again and talked to the Jew, but the Jew refused his request. I got up and brought some ripe fresh dates and put it in front of the Prophet. He ate and then said to me, "Where is your hut, O Jabir?" I informed him, and he said, "Spread out a bed for me in it." I spread out a bed, and he entered and slept. When he woke up, I brought some dates to him again and he ate of it and then got up and talked to the Jew again, but the Jew again refused his request. Then the Prophet got up for the second time amidst the palm trees loaded with fresh dates, and said, "O Jabir! Pluck dates to repay your debt." The Jew remained with me while I was plucking the dates, till I paid him all his right, yet there remained extra quantity of dates. So I went out and proceeded till I reached the Prophet and informed him of the good news, whereupon he said, "I testify that I am Allah's Apostle."


Bukhari :: Food, Meals :: [7.65.355]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 355

Narrated 'Abdullah bin Umar:

While we were sitting with the Prophet a spadix of palm tree was brought to him. The Prophet said, "There is a tree among the trees which is as blessed as a Muslim" I thought that it was the date palm tree and intended to say, "It is the date-palm tree, O Allah's Apostle!" but I looked behind to see that I was the tenth and youngest of ten men present there, so I kept quiet' Then the Prophet said, "It is the datepalm tree."


Bukhari :: Food, Meals :: [7.65.356]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 356

Narrated Sad:

Allah's Apostle said, "He who eats seven 'Ajwa dates every morning, will not be affected by poison or magic on the day he eats them."


Bukhari :: Food, Meals :: [7.65.357]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 357

Narrated Jabala bin Suhaim.

At the time of Ibn Az-Zubair, we were struck with famine, and he provided us with dates for our food. 'Abdullah bin 'Umar used to pass by us while we were eating, and say, "Do not eat two dates together at a time, for the Prophet forbade the taking of two dates together at a time (in a gathering)." Ibn 'Umar used to add, "Unless one takes the permission of one's companions."


Bukhari :: Food, Meals :: [7.65.358]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 358

Narrated 'Abdullah bin Ja'far:

I saw the Prophet eating fresh dates with snake cucumbers.


Bukhari :: Food, Meals :: [7.65.359]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 359

Narrated Ibn 'Umar:

The Prophet said, "There is a tree among the trees which is similar to a Muslim (in goodness), and that is the date palm tree."


Bukhari :: Food, Meals :: [7.65.360]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 360

Narrated 'Abdullah bin Ja'far:

I saw Allah's Apostle eating fresh dates with snake cucumbers.


Bukhari :: Food, Meals :: [7.65.361]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 361

Narrated Anas:

My mother, Um Sulaim, took a Mudd of barley grain, ground it and made porridge from it, and pressed (over it), a butter skin she had with her. Then she sent me to the Prophet, and I reached him while he was sitting with his companions. I invited him, whereupon he said, "And those who are with me?' I returned and said, "He says, 'And those who are with me?" Abu Talha went out to him and said, "O Allah's Apostle! It is just a meal prepared by Um Sulaim." The Prophet entered and the food was brought to him. He said, "Let ten persons enter upon me." Those ten entered and ate their fill. Again he said, 'Let ten (more) enter upon me." Those ten entered and ate their fill. Then he said, "Let ten (more) enter upon me." He called forty persons in all Then Allah's Apostle ate and got up. I started looking (at the food) to see if it decreased or not.


Bukhari :: Food, Meals :: [7.65.362]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 362

Narrated 'Abdul 'Aziz:

It was said to Anas "What did you hear the Prophet saying about garlic?" Anas replied, "Whoever has eaten (garlic) should not approach our mosque."


Bukhari :: Food, Meals :: [7.65.363]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 363

Narrated Jabir bin 'Abdullah:

The Prophet said, "Whoever has eaten garlic or onion should keep away from us (or should keep away from our mosque).'


Bukhari :: Food, Meals :: [7.65.364]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 364

Narrated Jabir bin 'Abdullah:

We were with Allah's Apostle collecting Al-Kabath at Mar-Az-Zahran. The Prophet said, "Collect the black ones, for they are better." Somebody said, (O Allah's Apostle!) Have you ever shepherded sheep?" He said, "There has been no prophet but has shepherded them. "


Bukhari :: Food, Meals :: [7.65.365]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 365

Narrated Suwaid bin An Nu'man:

We went out with Allah's Apostle to Khaibar, and when we reached As-Sahba', the Prophet asked for food, and he was offered nothing but Sawiq. We ate, and then Allah's Apostle stood up for the prayer. He rinsed his mouth with water, and we too, rinsed our mouths. Narrated Suwaid; We went out with Allah's Apostle to Khaibar. and when we reached As-Sahba', which (Yahya says) is one day' journey from Khaibar, the Prophet asked for food, and he was offered nothing but Sawiq which we chewed and ate. Then the Prophet asked for water and rinsed his mouth, and we too, rinsed our mouths along with him. He then led us in the Maghrib prayer without performing ablution again


Bukhari :: Food, Meals :: [7.65.366]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 366

Narrated Ibn 'Abbas:

The Prophet said, 'When you eat, do not wipe your hands till you have licked it, or had it licked by somebody else."


Bukhari :: Food, Meals :: [7.65.367]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 367

Narrated Said bin Al-Harith:

that he asked Jabir bin 'Abdullah about performing ablution after taking a cooked meal. He replied, "It is not essential," and added, "We never used to get such kind of food during the lifetime of the Prophet except rarely; and if at all we got such a dish, we did not have any handkerchiefs to wipe our hands with except the palms of our hands, our forearms and our feet. We would perform the prayer thereafter with-out performing new ablution."


Bukhari :: Food, Meals :: [7.65.368]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 368

Narrated Abu Umama:

Whenever the dining sheet of the Prophet was taken away (i.e., whenever he finished his meal), he used to say: "Al-hamdu lillah kathiran taiyiban mubarakan fihi ghaira makfiy wala muwada' wala mustaghna'anhu Rabbuna."


Bukhari :: Food, Meals :: [7.65.369]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 369

Narrated Abu Umama:

Whenever the Prophet finished his meals (or when his dining sheet was taken away), he used to say. "Praise be to Allah Who has satisfied our needs and quenched our thirst. Your favor cannot by compensated or denied." Once he said, upraise be to You, O our Lord! Your favor cannot be compensated, nor can be left, nor can be dispensed with, O our Lord!"


Bukhari :: Food, Meals :: [7.65.370]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 370

Narrated .Abu Huraira:

The Prophet said, "When your servant brings your food to you, if you do not ask him to join you, then at least ask him to take one or two handfuls, for he has suffered from its heat (while cooking it) and has taken pains to cook it nicely."


Bukhari :: Food, Meals :: [7.65.371]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 371

Narrated Abu Mas'ud Al-Ansari:

There was an Ansari man nicknamed, Abu Shu'aib, who had a slave who was a butcher. He came to the Prophet while he was sitting with his companions and noticed the signs of hunger on the face of the Prophet . So he went to his butcher slave and said, "Prepare for me a meal sufficient for five persons so that I may invite the Prophet along with four other men." He had the meal prepared for him and invited him. A (sixth) man followed them. The Prophet said, "O Abu Shu'aib! Another man has followed us. If you wish, you may invite him; and if you wish, you may refuse him." Abu Shu'aib said, "No, I will admit him."


Bukhari :: Food, Meals :: [7.65.372]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 372

Narrated 'Amr bin Umaiyya:

that he saw Allah's Apostle cutting a piece of mutton from its shoulder part he was carrying in his hand. When he was called for prayer, he put it down and the knife with which he was cutting it. Then he stood up and offered the prayer without performing new ablution


Bukhari :: Food, Meals :: [7.65.373]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 373

Narrated Nafi:

Once Ibn Umar was taking his supper while he was listening to the recitation of (Quran by) the Imam (in the Isha prayer).


Bukhari :: Food, Meals :: [7.65.374]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 374

Narrated Aisha:

The Prophet said, "If the Iqama for ('Isha') prayer is proclaimed and supper is served, take your supper first "


Bukhari :: Food, Meals :: [7.65.375]

Food, Meals

Bukhari :: Book 7 :: Volume 65 :: Hadith 375

Narrated Anas:

I know (about) the Hijab (the order of veiling of women) more than anybody else. Ubai bin Ka'b used to ask me about it. Allah's Apostle became the bridegroom of Zainab bint Jahsh whom he married at Medina. After the sun had risen high in the sky, the Prophet invited the people to a meal. Allah's Apostle remained sitting and some people remained sitting with him after the other guests had left. Then Allah's Apostle got up and went away, and I too, followed him till he reached the door of 'Aisha's room. Then he thought that the people must have left the place by then, so he returned and I also returned with him. Behold, the people were still sitting at their places. So he went back again for the second time, and I went along with him too. When we reached the door of 'Aisha's room, he returned and I also returned with him to see that the people had left. Thereupon the Prophet hung a curtain between me and him and the Verse regarding the order for (veiling of women) Hijab was revealed.


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.376]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 376

Narrated Abu Musa:

A son was born to me and I took him to the Prophet who named him Ibrahim, did Tahnik for him with a date, invoked Allah to bless him and returned him to me. (The narrator added: That was Abu Musa's eldest son.)


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.377]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 377

Narrated 'Aisha:

A boy was brought to the Prophet to do Tahnik for him, but the boy urinated on him, whereupon the Prophet had water poured on the place of urine.


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.378]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 378

Narrated Asma' bint Abu Bakr:

I conceived 'Abdullah bin AzZubair at Mecca and went out (of Mecca) while I was about to give birth. I came to Medina and encamped at Quba', and gave birth at Quba'. Then I brought the child to Allah's Apostle and placed it (on his lap). He asked for a date, chewed it, and put his saliva in the mouth of the child. So the first thing to enter its stomach was the saliva of Allah's Apostle. Then he did its Tahnik with a date, and invoked Allah to bless him. It was the first child born in the Islamic era, therefore they (Muslims) were very happy with its birth, for it had been said to them that the Jews had bewitched them, and so they would not produce any offspring.


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.379]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 379

Narrated Anas:

As above.


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.380]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 380

Narrated Salman bin 'Amir Ad-Dabbi:

I heard Allah's Apostle saying, "'Aqiqa is to be offered for a (newly born) boy, so slaughter (an animal) for him, and relieve him of his suffering." (Note: It has been quoted in Fateh-AL-Bari that the majority of the Religious Scholars agrees to the Hadith narrated in Sahih At-TlRMlZY that the Prophet was asked about Aqiqa and he ordered 2 sheep for a boy and one sheep for a girl and that is his tradition "SUNNA".)


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.381]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 381

Narrated Habib bin Ash-Shahid:

Ibn Sirin told me to ask Al-Hassan from whom he had heard the narration of 'Aqiqa. I asked him and he said, "From Samura bin Jundab."


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.382]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 382

Narrated Abu Huraira:

The Prophet said, "Neither Fara' nor 'Atira (is permissible):" Al-Fara' nor 'Atira (is permissible):" Al-Fara' was the first offspring (of camels or sheep) which the pagans used to offer (as a sacrifice) to their idols. And Al-'Atira was (a sheep which was to be slaughtered) during the month of Rajab.


Bukhari :: Sacrifice on Occasion of Birth (`Aqiqa) :: [7.66.383]

Sacrifice on Occasion of Birth (`Aqiqa)

Bukhari :: Book 7 :: Volume 66 :: Hadith 383

Narrated Abu Huraira:

The Prophet said, "Neither Fara' nor 'Atira) is permissible)." Al-Fara' was the first offspring (they got of camels or sheep) which they (pagans) used to offer (as a sacrifice) to their idols. 'Atira was (a sheep which used to be slaughtered) during the month of Rajab.


Bukhari :: Hunting, Slaughtering :: [7.67.384]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 384

Narrated Adi bin Hatim:

I asked the Prophet about the game killed by a Mi'rad (i.e. a sharp-edged piece of wood or a piece of wood provided with a sharp piece of iron used for hunting). He said, "If the game is killed with its sharp edge, eat of it, but if it is killed with its shaft, with a hit by its broad side then the game is (unlawful to eat) for it has been beaten to death." I asked him about the game killed by a trained hound. He said, "If the hound catches the game for you, eat of it, for killing the game by the hound, is like its slaughtering. But if you see with your hound or hounds another dog, and you are afraid that it might have shared in hunting the game with your hound and killed it, then you should not eat of it, because you have mentioned Allah's name on (sending) your hound only, but you have not mentioned it on some other hound


Bukhari :: Hunting, Slaughtering :: [7.67.385]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 385

Narrated 'Adi bin Hatim:

I asked Allah's Apostle about the Mi'rad. He said, "If you hit the game with its sharp edge, eat it, but if the Mi'rad hits the game with its shaft with a hit by its broad side do not eat it, for it has been beaten to death with a piece of wood. (i.e. unlawful)." I asked, "If I let loose my trained hound after a game?" He said, "If you let loose your trained hound after game, and mention the name of Allah, then you can eat." I said, "If the hound eats of the game?" He said "Then you should not eat of it, for the hound has hunted the game for itself and not for you." I said, "Some times I send my hound and then I find some other hound with it?" He said "Don't eat the game, as you have mentioned the Name of Allah on your dog only and not on the other."


Bukhari :: Hunting, Slaughtering :: [7.67.386]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 386

Narrated Adi bin Hatim:

I said, "O Allah's Apostle! We let loose our trained hounds after a game?" He said, "Eat what they hunt for you." I said, "Even if they killed (the game)?" He replied, 'Even if they killed (the game)." I said, 'We also hit (the game) with the Mi'rad?" He said, "Eat of the animal which the Mi'rad kills by piercing its body, but do not eat of the animal which is killed by the broad side of the Mi'rad.''


Bukhari :: Hunting, Slaughtering :: [7.67.387]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 387

Narrated Abu Tha'laba Al-Khushani:

I said, "O Allah's Prophet! We are living in a land ruled by the people of the Scripture; Can we take our meals in their utensils? In that land there is plenty of game and I hunt the game with my bow and with my hound that is not trained and with my trained hound. Then what is lawful for me to eat?" He said, "As for what you have mentioned about the people of the Scripture, if you can get utensils other than theirs, do not eat out of theirs, but if you cannot get other than theirs, wash their utensils and eat out of it. If you hunt an animal with your bow after mentioning Allah's Name, eat of it. and if you hunt something with your trained hound after mentioning Allah's Name, eat of it, and if you hunt something with your untrained hound (and get it before it dies) and slaughter it, eat of it."


Bukhari :: Hunting, Slaughtering :: [7.67.388]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 388

Narrated 'Abdullah bin Maghaffal:

that he saw a man throwing stones with two fingers (at something) and said to him, "Do not throw stones, for Allah's Apostle has forbidden throwing stones, or e used to dislike it." 'Abdullah added: Throwing stones will neither hunt the game, nor kill (or hurt) an enemy, but it may break a tooth or gouge out an eye." Afterwards 'Abdullah once again saw the man throwing stones. He said to him, "I tell you that Allah's Apostle has forbidden or disliked the throwing the stones (in such a way), yet you are throwing stones! I shall not talk to you for such-and-such a period."


Bukhari :: Hunting, Slaughtering :: [7.67.389]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 389

Narrated Ibn 'Umar:

The Prophet said, "Whoever keeps a (pet) dog which is neither a watch dog nor a hunting dog, will get a daily deduction of two Qirat from his good deeds."


Bukhari :: Hunting, Slaughtering :: [7.67.390]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 390

Narrated 'Abdullah bin Umar:

I heard the Prophet saying, "If someone keeps a dog neither for hunting, nor for guarding livestock, the reward (for his good deeds) will be reduced by two Qirats per day."


Bukhari :: Hunting, Slaughtering :: [7.67.391]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 391

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "If someone keeps a dog neither for guarding livestock, nor for hunting, his good deeds will decrease (in reward) by two Qirats a day.'


Bukhari :: Hunting, Slaughtering :: [7.67.392]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 392

Narrated Adi bin Hatim:

I asked Allah's Apostle. "We hunt with the help of these hounds." He said, "If you let loose your trained hounds after a game, and mention the name of Allah, then you can eat what the hounds catch for you, even if they killed the game. But you should not eat of it if the hound has eaten of it, for then it is likely that the hound has caught the game for itself. And if other hounds join your hound in hunting the game, then do not eat of it."


Bukhari :: Hunting, Slaughtering :: [7.67.393]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 393

Narrated Adi bin Hatim:

The Prophet said, "If you let loose your hound after a game and mention Allah's Name on sending it, and the hound catches the game and kills it, then you can eat of it. But if the hound eats of it, then you should not eat thereof, for the hound has caught it for itself. And if along with your hound, join other hounds, and Allah's Name was not mentioned at the time of their sending, and they catch an animal and kill it, you should not ea: of it, for you will not know which of them has killed it. And if you have thrown an arrow at the game and then find it (dead) two or three days later and, it bears no mark other than the wound inflicted by your arrow, then you can eat of it. But if the game is found (dead) in water, then do not eat of it." And it has also been narrated by 'Adi bin Hatim that he asked the Prophet "If a hunter throws an arrow at the game and after tracing it for two or three days he finds it dead but still bearing his arrow, (can he eat of it)?" The Prophet replied, "He can eat if he wishes."


Bukhari :: Hunting, Slaughtering :: [7.67.394]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 394

Narrated 'Adi bin Hatim:

I said, "O Allah's Apostle! I let loose my hound after a game and mention Allah's Name on sending it." The Prophet said, "If you let loose your hound after a game and you mention Allah's Name on sending it and the hound catches and kills the game and eats of it, then you should not eat of it, for it has killed it for itself." I said, "Sometimes when I send my hound after a game, I find another hound along with it and I do not know which of them has caught the game." He said, "You must not eat of it because you have not mentioned, the Name of Allah except on sending your own hound, and you did not mention it on the other hound." Then I asked him about the game hunted with a Mi'rad (i.e. a sharp edged piece of wood or a piece of wood provided with a sharp piece of iron used for hunting). He said, "If the game is killed with its sharp edge, you can eat of it, but if it is killed by its broad side (shaft), you cannot eat of it, for then it is like an animal beaten to death with a pie


Bukhari :: Hunting, Slaughtering :: [7.67.395]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 395

Narrated Adi Bin Hatim:

I asked Allah's Apostle, "We hunt with these hounds." He said, "If you send your trained hounds after a game and mention Allah's Name on sending, you can eat of what they catch for you. But if the hound eats of the game, then you must not eat of it, for I am afraid that the hound caught it for itself, and if another hound joins your hounds (during the hunt), you should not eat of the game."


Bukhari :: Hunting, Slaughtering :: [7.67.396]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 396

Narrated Abu Tha'laba Al-Khushani:

I came to Allah's Apostle and said, "O Allah's Apostle! We are living in the land of the people of the Scripture and we take our meals in their utensils, and in the land there is game and I hunt with my bow and trained or untrained hounds; please tell me what is lawful for us of that." He said, "As for your saying that you are living in the land of the people of the Scripture and that you eat in their utensils, if you can get utensils other than theirs, do not eat in their utensils, but if you do not find (other than theirs), then wash their utensils and eat in them. As for your saying that you are in the land of game, if you hung something with your bow, and have mentioned Allah's Name while hunting, then you can eat (the game). And if you hunt something with your trained hound, and have mentioned Allah's Name on sending it for hunting then you can eat (the game). But if you hunt something with your untrained hound and you were able to slaughter it before its death, you can eat of it."


Bukhari :: Hunting, Slaughtering :: [7.67.397]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 397

Narrated Anas bin Malik:

We provoked a rabbit at Marr Az-Zahran till it started jumping. My companions chased it till they got tired. But I alone ran after it and caught it and brought it to Abu Talha. He sent both its legs to the Prophet who accepted them.


Bukhari :: Hunting, Slaughtering :: [7.67.398]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 398

Narrated Abu Qatada:

that once he was with Allah's Apostle (on the way to Mecca). When he had covered some of the way to Mecca, he and some companions of his, who were in the state of lhram. remained behind the Prophet while Abu Qatada himself was not in the state of Ihram. Abu Qatada, seeing an onager rode his horse and asked his companions to hand him a whip, but they refused. He then asked them to hand him his spear, but they refused. Then he took it himself and attacked the onager and killed it. Some of the Companions of Allah's Apostle ate of it, but some others refused to eat. When they met Allah's Apostle they asked him about that. He said, "It was meal given to you by Allah."


Bukhari :: Hunting, Slaughtering :: [7.67.399]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 399

Narrated Abu Qatada:

(the same Hadith above, but he added); The Prophet asked, "Is there any of its meat left with you?"


Bukhari :: Hunting, Slaughtering :: [7.67.400]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 400

Narrated Abu Qatada:

I was with the Prophet (on a journey) between Mecca and Medina, and all of them, (i.e. the Prophet and his companions) were in the state of Ihram, while I was not in that state. I was riding my horse and I used to be fond of ascending mountains. So while I was doing so I noticed that the people were looking at something. I went to see what it was, and behold it was an onager. I asked my companions, "What is that?" They said, "We do not know." I said, "It is an onager.' They said, "It is what you have seen." I had left my whip, so I said to them, "Hand to me my whip." They said, "We will not help you in that (in hunting the onager)." I got down, took my whip and chased the animal (on my horse) and did not stop till I killed it. I went to them and said, "Come on, carry it!" But they said, "We will not even touch it." At last I alone carried it and brought it to them. Some of them ate of it and some refused to eat of it. I said (to them), "I will ask the Prophet about it (on your behalf)." When I met the Prophet, I told him the whole story. He said to me, "Has anything of it been left with you?" I said, "Yes." He said, "Eat, for it is a meal Allah has offered to you."


Bukhari :: Hunting, Slaughtering :: [7.67.401]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 401

Narrated Jabir:

We went out in a campaign and the army was called The Army of the Khabt, and Abu 'Ubaida was our commander. We were struck with severe hunger. Then the sea threw a huge dead fish called Al-'Anbar, the like of which had never been seen. We ate of it for half a month, and then Abu 'Ubaida took one of its bones (and made an arch of it) so that a rider could easily pass under it.


Bukhari :: Hunting, Slaughtering :: [7.67.402]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 402

Narrated Jabir:

The Prophet sent us as an army unit of three hundred warriors under the command of Abu 'Ubaida to ambush a caravan of the Quraish. But we were struck with such severe hunger that we ate the Khabt (desert bushes), so our army was called the Army of the Khabt. Then the sea threw a huge fish called Al-'Anbar and we ate of it for half a month and rubbed our bodies with its fat till our bodies became healthy. Then Abu Ubaida took one of its ribs and fixed it over the ground and a rider passed underneath it. There was a man amongst us who slaughtered three camels when hunger became severe, and he slaughtered three more, but after that Abu 'Ubaida forbade him to do so.


Bukhari :: Hunting, Slaughtering :: [7.67.403]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 403

Narrated Ibn Abi Aufa:

We participated with the Prophet in six or seven Ghazawat, and we used to eat locusts with him.


Bukhari :: Hunting, Slaughtering :: [7.67.404]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 404

Narrated Abu Tha'laba Al-Khushani:

I came to the Prophet and said, "O Allah's Apostle! We are living in the land of the people of the Scripture, and we take our meals in their utensils, and there is game in that land and I hunt with my bow and with my trained hound and with my untrained hound." The Prophet said, "As for your saying that you are in the land of people of the Scripture, you should not eat in their utensils unless you find no alternative, in which case you must wash the utensils and then eat in them As for your saying that you are in the land of game, if you hunt something with your bow, mention Allah's Name (while hunting the game) and eat; and if you hunt something with your trained hound, mention Allah's Name on sending and eat; and if you hunt something with your untrained hound and get it alive, slaughter it and you can eat of it"


Bukhari :: Hunting, Slaughtering :: [7.67.405]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 405

Narrated Salama bin Al-Aqwa':

In the evening of the day of the conquest of Khaibar, the army made fires (for cooking). The Prophet said, "For what have you made these fires?" They said, "For cooking the meat of domestic donkeys." He said, "Throw away what is in the cooking pots and break the pots." A man from the people got up and said, "Shall we throw the contents of the cooking pots and then wash the pots (instead of breaking them)?" The Prophet said, "Yes, you can do either'


Bukhari :: Hunting, Slaughtering :: [7.67.406]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 406

Narrated Rafi bin Khadij:

We were with the Prophet in Dhul-Hulaifa and there the people were struck with severe hunger. Then we got camels and sheep as war booty (and slaughtered them). The Prophet was behind all the people. The people hurried and fixed the cooking pots (for cooking) but the Prophet came there and ordered that the cooking pots be turned upside down. Then he distributed the animals, regarding ten sheep as equal to one camel. One of the camels ran away and there were a few horses with the people. They chased the camel but they got tired, whereupon a man shot it with an arrow whereby Allah stopped it. The Prophet said, "Among these animals some are as wild as wild beasts, so if one of them runs away from you, treat it in this way." I said. "We hope, or we are afraid that tomorrow we will meet the enemy and we have no knives, shall we slaughter (our animals) with canes?" The Prophet said, "If the killing tool causes blood to gush out and if Allah's Name is mentioned, eat (of the slaughterer animal). But do not slaughter with a tooth or a nail. I am telling you why: A tooth is a bone, and the nail is the knife of Ethiopians."


Bukhari :: Hunting, Slaughtering :: [7.67.407]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 407

Narrated 'Abdullah:

Allah's Apostle said that he met Zaid bin 'Amr Nufail at a place near Baldah and this had happened before Allah's Apostle received the Divine Inspiration. Allah's Apostle presented a dish of meat (that had been offered to him by the pagans) to Zaid bin 'Amr, but Zaid refused to eat of it and then said (to the pagans), "I do not eat of what you slaughter on your stonealtars (Ansabs) nor do I eat except that on which Allah's Name has been mentioned on slaughtering."


Bukhari :: Hunting, Slaughtering :: [7.67.408]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 408

Narrated Jundub bin Sufyan Al-Bajali:

Once during the lifetime of Allah's Apostle we offered some animals as sacrifices. Some people slaughtered their sacrifices before the (Id) prayer, so when the Prophet finished his prayer, he saw that they had slaughtered their sacrifices before the prayer. He said, "Whoever has slaughtered (his sacrifice) before the prayer, should slaughter (another sacrifice) in lieu of it; and whoever has not yet slaughtered it till we have prayed; should slaughter (it) by mentioning Allah's Name."


Bukhari :: Hunting, Slaughtering :: [7.67.409]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 409

Narrated Ka'b:

that a slave girl of theirs used to shepherd some sheep at Si'a (a mountain near Medina). On seeing one of her sheep dying, she broke a stone and slaughtered it. Ka'b said to his family, "Do not eat (of it) till I go to the Prophet and ask him, or, till I send someone to ask him." So he went to the Prophet or sent someone to him The Prophet permitted (them) to eat it.


Bukhari :: Hunting, Slaughtering :: [7.67.410]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 410

Narrated 'Abdullah

that Ka'b had a slave girl who used to graze his sheep on a small mountain, called "Sl'a", situated near the market. Once a sheep was dying, so she broke a stone and slaughtered it with it. When they mentioned that to the Prophet, he, permitted them to eat it.


Bukhari :: Hunting, Slaughtering :: [7.67.411]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 411

Narrated Rafi bin Khadij:

that he said, "O Allah's Apostle! We have no knife." The Prophet said, "if the killing tool causes blood to gush out, and if Allah's Name is mentioned, eat (of the slaughtered animal). But do not slaughter with a nail or a tooth, for the nail is the knife of Ethiopians and a tooth is a bone." Suddenly a camel ran away and it was stopped (with an arrow). The Prophet then said, "Of these camels there are some which are as wild as wild beasts; so if one of them runs away from you and you cannot catch it, treat it in this manner (i.e. shoot it with an arrow)."


Bukhari :: Hunting, Slaughtering :: [7.67.412]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 412

Narrated Ka'b bin Malik:

A lady slaughtered a sheep with a stone and then the Prophet was asked about it and he permitted it to be eaten.


Bukhari :: Hunting, Slaughtering :: [7.67.413]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 413

Narrated Mu'adh bin Sad or Sad bin Mu'adh:

A slave girl belonging to Ka'b used to graze some sheep at Sl'a (mountain). Once one of her sheep was dying. She reached it (before it died) and slaughtered it with a stone. The Prophet was asked, and he said, "Eat it."


Bukhari :: Hunting, Slaughtering :: [7.67.414]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 414

Narrated Rafi bin Khadij:

The Prophet said, "Eat what is slaughtered (with any instrument) that makes blood flow out, except what is slaughtered with a tooth or a nail.'


Bukhari :: Hunting, Slaughtering :: [7.67.415]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 415

Narrated 'Aisha:

A group of people said to the Prophet, "Some people bring us meat and we do not know whether they have mentioned Allah's Name or not on slaughtering the animal." He said, "Mention Allah's Name on it and eat." Those people had embraced Islam recently.


Bukhari :: Hunting, Slaughtering :: [7.67.416]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 416

Narrates 'Abdullah bin Mughaffal:

While we were besieging the castle of Khaibar, Somebody threw a skin full of fat and I went ahead to take it, but on looking behind, I saw the Prophet and I felt shy in his presence (and did not take it).


Bukhari :: Hunting, Slaughtering :: [7.67.417]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 417

Narrated Rafi bin Khadij:

I said, "O Allah's Apostle! We are going to face the enemy tomorrow and we do not have knives." He said, "Hurry up (in killing the animal). If the killing tool causes blood to flow out, and if Allah's Name is mentioned, eat (of the slaughtered animal). But do not slaughter with a tooth or a nail. I will tell you why: As for the tooth, it is a bone; and as for the nail, it is the knife of Ethiopians." Then we got some camels and sheep as war booty, and one of those camels ran away, whereupon a man shot it with an arrow and stopped it. Allah's Apostle said, "Of these camels there are some which are as wild as wild beasts, so if one of them (runs away and) makes you tired, treat it in this manner."


Bukhari :: Hunting, Slaughtering :: [7.67.418]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 418

Narrated Asma bint Abu Bakr:

We slaughtered a horse (by Nahr) during the lifetime of the Prophet and ate it.


Bukhari :: Hunting, Slaughtering :: [7.67.419]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 419

Narrated Asma':

We slaughtered a horse (by Dhabh) during the lifetime of Allah's Apostle while we were at Medina, and we ate it.


Bukhari :: Hunting, Slaughtering :: [7.67.420]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 420

Narrated Asma' bint Abu Bakr:

We slaughtered a horse (by Nahr) during the lifetime of Allah's Apostle and ate it.


Bukhari :: Hunting, Slaughtering :: [7.67.421]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 421

Narrated Hisham bin Zaid:

Anas and I went to Al-Hakam bin Aiyub. Anas saw some boys shooting at a tied hen. Anas said, "The Prophet has forbidden the shooting of tied or confined animals."


Bukhari :: Hunting, Slaughtering :: [7.67.422]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 422

Narrated Ibn 'Umar:

that he entered upon Yahya bin Said while one of Yahya's sons was aiming at a hen after tying it. Ibn 'Umar walked to it and untied it. Then he brought it and the boy and said. "Prevent your boys from tying the birds for the sake of killing them, as I have heard the Prophet forbidding the killing of an animal or other living thing after tying them."


Bukhari :: Hunting, Slaughtering :: [7.67.423]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 423

Narrated Said bin Jubair:

While I was with Ibn 'Umar, we passed by a group of young men who had tied a hen and started shooting at it. When they saw Ibn 'Umar, they dispersed, leaving it. On that Ibn 'Umar said, "Who has done this? The Prophet cursed the one who did so."


Bukhari :: Hunting, Slaughtering :: [7.67.424]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 424

Narrated Ibn 'Umar:

The Prophet cursed the one who did Muthla to an animal (i e., cut its limbs or some other part of its body while it is still alive).


Bukhari :: Hunting, Slaughtering :: [7.67.425]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 425

Narrated 'Abdullah bin Yazid:

The Prophet forbade An-Nuhba and Al-Muthla.


Bukhari :: Hunting, Slaughtering :: [7.67.426]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 426

Narrated Abu Musa Al-Ash'ari:

I saw the Prophet eating chicken.


Bukhari :: Hunting, Slaughtering :: [7.67.427]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 427

Narrated Zahdam:

We were in the company of Abu Musa Al-Ash'ari and there were friendly relations between us and this tribe of Jarm. Abu Musa was presented with a dish containing chicken. Among the people there was sitting a red-faced man who did not come near the food. Abu Musa said (to him), "Come on (and eat), for I have seen Allah's Apostle eating of it (i.e. chicken)." He said, "I have seen it eating something (dirty) and since then I have disliked it, and have taken an oath that I shall not eat it ' Abu Musa said, "Come on, I will tell you (or narrate to you). Once I went to Allah s Apostle with a group of Al-Ash'ariyin, and met him while he was angry, distributing some camels of Rakat. We asked for mounts but he took an oath that he would not give us any mounts, and added, 'I have nothing to mount you on' In the meantime some camels of booty were brought to Allah's Apostle and he asked twice, 'Where are Al-Ash'ariyin?" So he gave us five white camels with big humps. We stayed for a short while (after we had covered a little distance), and then I said to my companions, "Allah's Apostle has forgotten his oath. By Allah, if we do not remind Allah's Apostle of his oath, we will never be successful." So we returned to the Prophet and said, "O Allah's Apostle! We asked you for mounts, but you took an oath that you would not give us any mounts; we think that you have forgotten your oath.' He said, 'It is Allah Who has given you mounts. By Allah, and Allah willing, if I take an oath and later find something else better than that. then I do what is better and expiate my oath.' "


Bukhari :: Hunting, Slaughtering :: [7.67.428]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 428

Narrated Asma':

We slaughtered a horse during the lifetime of Allah's Apostle and ate it.


Bukhari :: Hunting, Slaughtering :: [7.67.429]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 429

Narrated Jabir bin 'Abdullah:

On the Day of the battle of Khaibar, Allah's Apostle made donkey's meat unlawful and allowed the eating of horse flesh.


Bukhari :: Hunting, Slaughtering :: [7.67.430]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 430

Narrated Ibn 'Umar:

The Prophet made the meat of donkeys unlawful on the day of the battle of Khaibar.


Bukhari :: Hunting, Slaughtering :: [7.67.431]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 431

Narrated Ibn 'Umar:

The Prophet prohibited the eating of donkey's meat.


Bukhari :: Hunting, Slaughtering :: [7.67.432]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 432

Narrated 'Ali:

Allah's Apostle prohibited Al-Mut'a marriage and the eating of donkey's meat in the year of the Khaibar battle


Bukhari :: Hunting, Slaughtering :: [7.67.433]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 433

Narrated Jabir bin 'Abdullah:

The Prophet prohibited the eating of donkey's meat on the day of the battle of Khaibar, and allowed the eating of horse flesh.


Bukhari :: Hunting, Slaughtering :: [7.67.434]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 434

Narrated Al-Bara' and Ibn Abi 'Aufa:

The Prophet prohibited the eating of donkey's meat.


Bukhari :: Hunting, Slaughtering :: [7.67.435]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 435

Narrated Az-Zuhri:

The Prophet prohibited the eating of beasts having fangs.


Bukhari :: Hunting, Slaughtering :: [7.67.436]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 436

Narrated Anas bin Malik:

Someone came to Allah's Apostle and said, "The donkeys have been (slaughtered and) eaten. Another man came and said, "The donkeys have been destroyed." On that the Prophet ordered a caller to announce to the people: Allah and His Apostle forbid you to eat the meat of donkeys, for it is impure.' Thus the pots were turned upside down while the (donkeys') meat was boiling in them.


Bukhari :: Hunting, Slaughtering :: [7.67.437]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 437

Narrated 'Amr:

I said to Jabir bin Zaid, "The people claim that Allah's Apostle forbade the eating of donkey's meat." He said, "Al-Hakam bin 'Amr Al-Ghifari used to say so when he was with us, but Ibn 'Abbas, the great religious learned man, refused to give a final verdict and recited:-- 'Say: I find not in that which has been inspired to me anything forbidden to be eaten by one who wishes to eat it, unless it be carrion, blood poured forth or the flesh of swine...' (6.145)


Bukhari :: Hunting, Slaughtering :: [7.67.438]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 438

Narrated Abu Tha'laba:

Allah's Apostle forbade the eating of the meat of beasts having fangs.


Bukhari :: Hunting, Slaughtering :: [7.67.439]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 439

Narrated 'Abdullah bin 'Abbas:

Once Allah's Apostle passed by a dead sheep and said (to the people), "Why don't you use its hide?" They said, "But it is dead," He said, "Only eating it, is prohibited."


Bukhari :: Hunting, Slaughtering :: [7.67.440]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 440

Narrated Ibn 'Abbas:

The Prophet passed by a dead goat and said, "There is no harm if its owners benefit from its skin."


Bukhari :: Hunting, Slaughtering :: [7.67.441]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 441

Narrated Abu Huraira:

Allah's Apostle said, "None is wounded in Allah's Cause but will come on the Day of Resurrection with his wound bleeding. The thing that will come out of his wound will be the color of blood, but its smell will be the smell of musk."


Bukhari :: Hunting, Slaughtering :: [7.67.442]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 442

Narrated Abu Musa:

The Prophet said, 'The example of a good pious companion and an evil one is that of a person carrying musk and another blowing a pair of bellows. The one who is carrying musk will either give you some perfume as a present, or you will buy some from him, or you will get a good smell from him, but the one who is blowing a pair of bellows will either burn your clothes or you will get a bad smell from him."


Bukhari :: Hunting, Slaughtering :: [7.67.443]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 443

Narrated Anas bin Malik:

Once we provoked a rabbit at Marr-az-Zahran. The people chased it till they got tired. Then I caught It and brought it to Abu Talha, who slaughtered it and then sent both its pelvic pieces (or legs) to the Prophet, and the Prophet accepted the present.


Bukhari :: Hunting, Slaughtering :: [7.67.444]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 444

Narrated Ibn 'Umar:

The Prophet said, "I do not eat mastigure, but I do not prohibit its eating."


Bukhari :: Hunting, Slaughtering :: [7.67.445]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 445

Narrated Khalid bin Al-Walid:

Allah's Apostle and I entered the house of Maimuna. A roasted mastigure was served. Allah's Apostle stretched his hand out (to eat of it) but some woman said, "Inform Allah's Apostle of what he is about to eat." So they said, "It is mastigure, O Allah's Apostle!" He withdrew his hand, whereupon I said, "O Allah's Apostle! Is it unlawful?" He said, "No, but this is not found in the land of my people, so I dislike it." So I pulled the mastigure towards me and ate it while Allah's Apostle was looking at me.


Bukhari :: Hunting, Slaughtering :: [7.67.446]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 446

Narrated Maimuna:

A mouse fell into the butter-fat and died. The Prophet was asked about that. He said, "Throw away the mouse and the butter-fat that surrounded it, and eat the rest of the butter-fat (As-Samn).


Bukhari :: Hunting, Slaughtering :: [7.67.447]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 447

Narrated Az-Zhuri:

regarding an animal, e.g., a mouse or some other animal that had fallen into solid or liquid oil or butter-fat: I had been informed that a mouse had died in butter-fat whereupon Allah's Apostle ordered that the butter-fat near it be thrown away and the rest of the butter-fat can be eaten.


Bukhari :: Hunting, Slaughtering :: [7.67.448]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 448

Narrated Maimuna:

The Prophet was asked about a mouse that had fallen into butter-fat (and died). He said, "Throw away the mouse and the portion of butter-fat around it, and eat the rest."


Bukhari :: Hunting, Slaughtering :: [7.67.449]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 449

Narrated Salim:

that Ibn 'Umar disliked the branding of animals on the face. Ibn 'Umar said, "The Prophet forbade beating (animals) on the face."


Bukhari :: Hunting, Slaughtering :: [7.67.450]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 450

Narrated Anas:

I brought a brother of mine to the Prophet to do Tahnik for him while the Prophet was in a sheep fold of his, and I saw him branding a sheep. (The sub-narrator said: I think Anas said, branding it on the ear.)


Bukhari :: Hunting, Slaughtering :: [7.67.451]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 451

Narrated Rait' bin Khadij:

I said to the Prophet, "We will be facing the enemy tomorrow and we have no knives (for slaughtering)' He said, "If you slaughter the animal with anything that causes its blood to flow out, and if Allah's Name is mentioned on slaughtering it, eat of it, unless the killing instrument is a tooth or nail. I will tell you why: As for the tooth, it is a bone; and as for the nail, it is the knife of Ethiopians." The quick ones among the people got the war booty while the Prophet was behind the people. So they placed the cooking pots on the fire, but the Prophet ordered the cooking pots to be turned upside down. Then he distributed (the war booty) among them, considering one camel as equal to ten sheep. Then a camel belonging to the first party of people ran away and they had no horses with them, so a man shot it with an arrow whereby Allah stopped it. The Prophet said, "Of these animals there are some which are as wild as wild beasts. So, if anyone of them runs away like this, do like this (shoot it with an arrow)."


Bukhari :: Hunting, Slaughtering :: [7.67.452]

Hunting, Slaughtering

Bukhari :: Book 7 :: Volume 67 :: Hadith 452

Narrated Rafi bin Khadij:

While we were with the Prophet. on a journey, one of the camels ran away. A man shot it with an arrow and stopped it. The Prophet said, "Of these camels some are as wild as wild beasts, so if one of them runs away and you cannot catch it, then do like this (shoot it with an arrow)." I said, "O Allah's Apostle! Sometimes when we are in battles or on a journey we want to slaughter (animals) but we have no knives." He said, "Listen! If you slaughter the animal with anything that causes its blood to flow out, and if Allah's Name is mentioned on slaughtering it, eat of it, provided that the slaughtering instrument is not a tooth or a nail, as the tooth is a bone and the nail is the knife of Ethiopians."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.453]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 453

Narrated Al-Bara:

The Prophet said (on the day of Idal-Adha), "The first thing we will do on this day of ours, is to offer the ('Id) prayer and then return to slaughter the sacrifice. Whoever does so, he acted according to our Sunna (tradition), and whoever slaughtered (the sacrifice) before the prayer, what he offered was just meat he presented to his family, and that will not be considered as Nusak (sacrifice)." (On hearing that) Abu Burda bin Niyar got up, for he had slaughtered the sacrifice before the prayer, and said, "I have got a six month old ram." The Prophet said, 'Slaughter it (as a sacrifice) but it will not be sufficient for any-one else (as a sacrifice after you). Al-Bara' added: The Prophet said, "Whoever slaughtered (the sacrifice) after the prayer, he slaughtered it at the right time and followed the tradition of the Muslims."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.454]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 454

Narrated Anas bin Malik:

The Prophet said, "Whoever slaughtered the sacrifice before the prayer, he just slaughtered it for himself, and whoever slaughtered it after the prayer, he slaughtered it at the right time and followed the tradition of the Muslims."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.455]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 455

Narrated 'Uqba bin 'Amir Al-Juhani:

that the Prophet distributed among his companions some animals for sacrifice (to be slaughtered on 'Id-al-Adha). 'Uqba's share was a Jadha'a (a six month old goat). 'Uqba said, "O Allah's Apostle! I get in my share of Jadha'a (a six month old ram)." The Prophet said, "Slaughter it as a sacrifice."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.456]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 456

Narrated 'Aisha:

that the Prophet entered upon her when she had her menses at Sarif before entering Mecca, and she was weeping (because she was afraid that she would not be able to perform the Hajj). The Prophet said, "What is wrong with you? Have you got your period?" She said, "Yes." He said, "This is a matter Allah has decreed for all the daughters of Adam, so perform all the ceremonies of Hajj like the others, but do not perform the Tawaf around the Ka'ba." 'Aisha added: When we were at Mina, beef was brought to me and I asked, "What is this?" They (the people) said, "Allah's Apostle has slaughtered some cows as sacrifices on behalf of his wives."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.457]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 457

Narrated Anas bin Malik:

The Prophet said on the day of Nahr, "Whoever has slaughtered his sacrifice before the prayer, should repeat it (slaughter another sacrifice)." A man got up and said, "O Allah's Apostle! This is a day on which meat is desired." He then mentioned his neighbors saying, "I have a six month old ram which is to me better than the meat of two sheep." The Prophet allowed him to slaughter it as a sacrifice, but I do not know whether this permission was valid for other than that man or not. The Prophet then went towards two rams and slaughtered them, and then the people went towards some sheep and distributed them among themselves.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.458]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 458

Narrated Abu Bakra:

The Prophet said, "Time has come back to its original state which it had on the day Allah created the Heavens and the Earth. The year is twelve months, four of which are sacred, three of them are in succession, namely Dhul-Qa'da, Dhul Hijja and Muharram, (the fourth being) Rajab Mudar which is between Juma'da (ath-thamj and Sha'ban. The Prophet then asked, "Which month is this?" We said, "Allah and his Apostle know better." He kept silent so long that we thought that he would call it by a name other than its real name. He said, "Isn't it the month of Dhul-Hijja?" We said, "Yes." He said, "Which town is this?" We said, "Allah and His Apostle know better." He kept silent so long that we thought that he would call it t,y a name other than its real name. He said, "isn't it the town (of Mecca)?" We replied, "Yes." He said, "What day is today?" We replied, "Allah and His Apostle know better." He kept silent so long that we thought that he would call it by a name other than its real name. He said, "Isn't it the day of Nahr?" We replied, "Yes." He then said, "Your blood, properties and honor are as sacred to one another as this day of yours in this town of yours in this month of yours. You will meet your Lord, and He will ask you about your deeds. Beware! Do not go astray after me by cutting the necks of each other. It is incumbent upon those who are present to convey this message to those who are absent, for some of those to whom it is conveyed may comprehend it better than some of those who have heard it directly." (Muhammad, the sub-narrator, on mentioning this used to say: The Prophet then said, "No doubt! Haven't I delivered (Allah's) Message (to you)? Haven't I delivered Allah's message (to you)?"


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.459]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 459

Narrated Nafi':

'Abdullah (bin 'Umar) used to slaughter his sacrifice at the slaughtering place (i.e the slaughtering place of the Prophet ) . Ibn 'Umar said, "Allah's Apostle used to slaughter (camels and sheep, etc.,) as sacrifices at the Musalla."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.460]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 460

Narrated Anas bin Malik:

The Prophet used to offer two rams as sacrifices, and I also used to offer two rams.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.461]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 461

Narrated Anas:

Allah's Apostle came towards two horned rams having black and white colors and slaughtered them with his own hands.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.462]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 462

Narrated 'Uqba bin 'Amir:

that the Prophet gave him some sheep to distribute among his companions to slaughter as sacrifices ('Id--al--Adha). A kid was left and he told the Prophet of that whereupon he said to him, "Slaughter it as a sacrifice (on your behalf)."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.463]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 463

Narrated Al-Bara' bin 'Azib:

An uncle of mine called Abu Burda, slaughtered his sacrifice before the 'Id prayer. So Allah's Apostle said to him, "Your (slaughtered) sheep was just mutton (not a sacrifice)." Abu Burda said, "O Allah's Apostle! I have got a domestic kid." The Prophet said, "Slaughter it (as a sacrifice) but it will not be permissible for anybody other than you" The Prophet added, "Whoever slaughtered his sacrifice before the ('Id) prayer, he only slaughtered for himself, and whoever slaughtered it after the prayer, he offered his sacrifice properly and followed the tradition of the Muslims."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.464]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 464

Narrated Al-Bara':

Abu Burda slaughtered (the sacrifice) before the ('Id) prayer whereupon the Prophet said to him, "Slaughter another sacrifice instead of that." Abu Burda said, "I have nothing except a Jadha'a." (Shu'ba said: Perhaps Abu Burda also said that Jadha'a was better than an old sheep in his opinion.) The Prophet said, "(Never mind), slaughter it to make up for the other one, but it will not be sufficient for anyone else after you."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.465]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 465

Narrated Anas:

The Prophet slaughtered two rams, black and white in color (as sacrifices), and I saw him putting his foot on their sides and mentioning Allah's Name and Takbir (Allahu Akbar). Then he slaughtered them with his own hands.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.466]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 466

Narrated 'Aisha:

Allah's Apostle entered upon me at Sarif while I was weeping (because I was afraid that I would not be able to perform the ,Hajj). He said, "What is wrong with you? Have you got your period?" I replied, "Yes." He said, "This is a matter Allah has decreed for all the daughters of Adam, so perform the ceremonies of the Hajj as the pilgrims do, but do not perform the Tawaf around the Ka'ba." Allah's Apostle slaughtered some cows as sacrifices on behalf of his wives.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.467]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 467

Narrated Al-Bara':

I heard the Prophet delivering a sermon, and he said (on the Day of 'Id-Allah. a), "The first thing we will do on this day of ours is that we will offer the 'Id prayer, then we will return and slaughter our sacrifices; and whoever does so, then indeed he has followed our tradition, and whoever slaughtered his sacrifice (before the prayer), what he offered was just meat that he presented to his family, and that was not a sacrifice." Abu Burda got up and said, "O Allah's Apostle! I slaughtered the sacrifice before the prayer and I have got a Jadha'a which is better than an old sheep." The Prophet said, "Slaughter it to make up for that, but it will not be sufficient for anybody else after you."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.468]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 468

Narrated Anas:

The Prophet said, "Whoever slaughtered the sacrifice before the 'Id prayer, should repeat it (slaughter another one)." A man said "This is the day on which meat is desired." Then he mentioned the need of his neighbors (for meat) and the Prophet seemed to accept his excuse. The man said, "I have a Jadha'a which is to me better than two sheep." The Prophet allowed him (to slaughter it as a sacrifice). But I do not know whether this permission was general for all Muslims or not. The Prophet then went towards two rams and slaughtered them, and the people went towards their sheep and slaughtered them.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.469]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 469

Narrated Jundab bin Sufyan Al-Bajali:

I witnessed the Prophet on the Day of Nahr. He said, "Whoever slaughtered the sacrifice before offering the 'Id prayer, should slaughter another sacrifice in its place; and whoever has not slaughtered their sacrifice yet, should slaughter now."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.470]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 470

Narrated Al-Bara':

One day Allah's Apostle offered the 'Id prayer and said, "Whoever offers our prayer and faces our Qibla should not slaughter the sacrifice till he finishes the 'Id prayer." Abu Burda bin Niyar got up and said, "O Allah's Apostle! I have already done it. The Prophet said, "That is something you have done before its due time." Abu Burda said, "I have a Jadha'a which is better than two old sheep; shall I slaughter it?" The Prophet said, "Yes, but it will not be sufficient for anyone after you."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.471]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 471

Narrated Anas:

The Prophet used to offer as sacrifices, two horned rams, black and white in color, and used to put his foot on their sides and slaughter them with his own hands.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.472]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 472

Narrated Anas:

The Prophet offered as sacrifices, two horned rams, black and white in color. He slaughtered them with his own hands and mentioned Allah's Name over them and said Takbir and put his foot on their sides.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.473]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 473

Narrated Masruq:

that he came to 'Aisha and said to her, "O Mother of the Believers! There is a man who sends a Hadi to Ka'ba and stays in his city and requests that his Hadi camel be garlanded while he remains in a state of Ihram from that day till the people finish their Ihram (after completing all the ceremonies of Hajj)" (What do you say about it?) Masruq added, I heard the clapping of her hands behind the curtain. She said, "I used to twist the garlands for the Hadi of Allah's Apostle and he used to send his Hadi to Ka'ba but he never used to regard as unlawful what was lawful for men to do with their wives till the people returned (from the Hajj)."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.474]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 474

Narrated Jabir bin 'Abdullah:

During the lifetime of the Prophet we used to take with us the meat of the sacrifices (of Id al Adha) to Medina. (The narrator often said. The meat of the Hadi).


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.475]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 475

Narrated Abu Sa'id Al-Khudri:

that once he was not present (at the time of 'Id-al-Adha) and when he came. some meat was presented to him. and the people said (to him), 'This is the meat of our sacrifices" He said. 'Take it away; I shall not taste it. (In his narration) Abu Sa'id added: I got up and went to my brother, Abu Qatada (who was his maternal brother and was one of the warriors of the battle of Badr) and mentioned that to him He Sad. 'A new verdict was given in your absence (i.e., meat of sacrifices was allowed to be stored and eaten later on)."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.476]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 476

Narrated Salama bin Al-Aqua':

The Prophet said, "Whoever has slaughtered a sacrifice should not keep anything of Its meat after three days." When it was the next year the people said, "O Allah's Apostle! Shall we do as we did last year?" He said, ' Eat of it and feed of it to others and store of it for in that year the people were having a hard time and I wanted you to help (the needy)."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.477]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 477

Narrated 'Aisha:

We used to salt some of the meat of sacrifice and present it to the Prophet at Medina. Once he said, "Do not eat (of that meat) for more than three days." That was not a final order, but (that year) he wanted us to feed of it to others, Allah knows better.


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.478]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 478

Narrated Abu 'Ubaid:

the freed slave of Ibn Azhar that he witnessed the Day of 'Id-al-Adha with 'Umar bin Al-Khattab. 'Umar offered the 'Id prayer before the sermon and then delivered the sermon before the people, saying, "O people! Allah's Apostle has forbidden you to fast (on the first day of) each of these two 'Ida, for one of them is the Day of breaking your fast, and the other is the one, on which you eat the meat of your sacrifices."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.479]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 479

Narrated Abu 'Ubaid:

(in continuation of 478). Then I witnessed the 'Id with 'Uthman bin 'Affan, and that was on a Friday. He offered the prayer before the sermon, saying, "O people! Today you have two 'Its (festivals) together, so whoever of those who live at Al-'Awali (suburbs) would like to wait for the Jumua prayer, he may wait, and whoever would like to return (home) Is granted my permission to do so." Then I witnessed (the 'Its) with 'Ali bin Abi Talib, and he too offered the 'Id prayer before the sermon and then delivered the sermon before the people and said, "Allah's Apostle has forbidden you to eat the meat of your sacrifices for more than three days."


Bukhari :: Al-Adha Festival Sacrifice (Adaahi) :: [7.68.480]

Al-Adha Festival Sacrifice (Adaahi)

Bukhari :: Book 7 :: Volume 68 :: Hadith 480

Narrated Salim:

'Abdullah bin 'Umar said, "Allah's Apostle said, "Eat of the meat of sacrifices (of 'Id al Adha) for three days." When 'Abdullah departed from Mina, he used to eat (bread with) oil, lest he should eat of the meat of Hadi (which is regarded as unlawful after the three days of the 'Id).


Bukhari :: Drinks :: [7.69.481]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 481

Narrated Ibn 'Umar:

Allah's Apostle said, "Whoever drinks alcoholic drinks in the world and does not repent (before dying), will be deprived of it in the Hereafter."


Bukhari :: Drinks :: [7.69.482]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 482

Narrated Abu Huraira:

On the night Allah's Apostle was taken on a night journey (Miraj) two cups, one containing wine and the other milk, were presented to him at Jerusalem. He looked at it and took the cup of milk. Gabriel said, "Praise be to Allah Who guided you to Al-Fitra (the right path); if you had taken (the cup of) wine, your nation would have gone astray."


Bukhari :: Drinks :: [7.69.483]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 483

Narrated Anas:

I heard from Allah's Apostle a narration which none other than I will narrate to you. The Prophet, said, "From among the portents of the Hour are the following: General ignorance (in religious affairs) will prevail, (religious) knowledge will decrease, illegal sexual intercourse will prevail, alcoholic drinks will be drunk (in abundance), men will decrease and women will increase so much so that for every fifty women there will be one man to look after them."


Bukhari :: Drinks :: [7.69.484]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 484

Narrated Abu Huraira:

The Prophet said, "An adulterer, at the time he is committing illegal sexual intercourse is not a believer; and a person, at the time of drinking an alcoholic drink is not a believer; and a thief, at the time of stealing, is not a believer." Ibn Shihab said: 'Abdul Malik bin Abi Bakr bin 'Abdur-Rahman bin Al- Harith bin Hisham told me that Abu Bakr used to narrate that narration to him on the authority of Abu Huraira. He used to add that Abu Bakr used to mention, besides the above cases, "And he who robs (takes illegally something by force) while the people are looking at him, is not a believer at the time he is robbing (taking)


Bukhari :: Drinks :: [7.69.485]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 485

Narrated Ibn 'Umar:

"Alcoholic drinks were prohibited (by Allah) when there was nothing of it (special kind of wine) in Medina.


Bukhari :: Drinks :: [7.69.486]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 486

Narrated Anas:

"Alcoholic drinks were prohibited at the time we could rarely find wine made from grapes in Medina, for most of our liquors were made from unripe and ripe dates.


Bukhari :: Drinks :: [7.69.487]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 487

Narrated Ibn 'Umar:

'Umar stood up on the pulpit and said, "Now then, prohibition of alcoholic drinks have been revealed, and these drinks are prepared from five things, i.e.. grapes, dates, honey, wheat or barley And an alcoholic drink is that, that disturbs the mind.


Bukhari :: Drinks :: [7.69.488]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 488

Narrated Anas bin Malik:

I was serving Abu 'Ubaida, Abu Talha and Ubai bin Ka'b with a drink prepared from ripe and unripe dates. Then somebody came to them and said, "Alcoholic drinks have been prohibited." (On hearing that) Abu Talha said, "Get up. O Anas, and pour (throw) it out! So I poured (threw) it out.


Bukhari :: Drinks :: [7.69.489]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 489

Narrated Anas:

While I was waiting on my uncles and serving them with (wine prepared from) dates----and I was the youngest of them----it was said, "Alcoholic drinks have been prohibited." So they said (to me), "Throw it away." So I threw it away.


Bukhari :: Drinks :: [7.69.490]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 490

Narrated Anas bin Malik:

Alcoholic drinks were prohibited. At that time these drinks used to be prepared from unripe and ripe dates.


Bukhari :: Drinks :: [7.69.491]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 491

Narrated 'Aisha:

Allah's Apostle was asked about Al-Bit. He said, "All drinks that intoxicate are unlawful (to drink.)


Bukhari :: Drinks :: [7.69.492]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 492

Anas bin Malik said:

Allah's Apostle said, "Do not make drinks in Ad-Dubba' nor in Al-Muzaffat. Abu Huraira used to add to them Al-Hantam and An-Naqir.


Bukhari :: Drinks :: [7.69.493]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 493

Narrated Ibn 'Umar:

'Umar delivered a sermon on the pulpit of Allah's Apostle, saying, "Alcoholic drinks were prohibited by Divine Order, and these drinks used to be prepared from five things, i.e., grapes, dates, wheat, barley and honey. Alcoholic drink is that, that disturbs the mind." 'Umar added, "I wish Allah's Apostle had not left us before he had given us definite verdicts concerning three matters, i.e., how much a grandfather may inherit (of his grandson), the inheritance of Al-Kalala (the deceased person among whose heirs there is no father or son), and various types of Riba(1 ) (usury) ."


Bukhari :: Drinks :: [7.69.494]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 494

Narrated Abu 'Amir or Abu Malik Al-Ash'ari:

that he heard the Prophet saying, "From among my followers there will be some people who will consider illegal sexual intercourse, the wearing of silk, the drinking of alcoholic drinks and the use of musical instruments, as lawful. And there will be some people who will stay near the side of a mountain and in the evening their shepherd will come to them with their sheep and ask them for something, but they will say to him, 'Return to us tomorrow.' Allah will destroy them during the night and will let the mountain fall on them, and He will transform the rest of them into monkeys and pigs and they will remain so till the Day of Resurrection."


Bukhari :: Drinks :: [7.69.495]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 495

Narrated Sahl:

Abu Usaid As-Sa'idi came and invited Allah's Apostle on the occasion of his wedding. His wife who was the bride, was serving them. Do you know what drink she prepared for Allah's Apostle ? She had soaked some dates in water in a Tur overnight.


Bukhari :: Drinks :: [7.69.496]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 496

Narrated Jabir:

Allah's Apostle forbade the use of (certain) containers, but the Ansar said, "We cannot dispense with them." The Prophet then said, "If so, then use them."


Bukhari :: Drinks :: [7.69.497]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 497

Narrated 'Abdullah bin 'Amr:

When the Prophet forbade the use of certain containers (that were used for preparing alcoholic drinks), somebody said to the Prophet . "But not all the people can find skins." So he allowed them to use clay jars not covered with pitch.


Bukhari :: Drinks :: [7.69.498]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 498

Narrated 'Ali:

the Prophet forbade the use of Ad-Dubba' and Al Muzaffat.


Bukhari :: Drinks :: [7.69.499]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 499

Narrated Al-A'mash:

(As above, 494).


Bukhari :: Drinks :: [7.69.500]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 500

Narrated Ibrahim:

I asked Al-Aswad, "Did you ask 'Aisha, Mother of the Believers, about the containers in which it is disliked to prepare (non-alcoholic) drinks?" He said, "Yes, I said to her, 'O Mother of the Believers! What containers did the Prophet forbid to use for preparing (non-alcoholic) drinks?" She said, 'The Prophet forbade us, (his family), to prepare (nonalcoholic) drinks in Ad-Dubba and Al-Muzaffat.' I asked, 'Didn't you mention Al Jar and Al Hantam?' She said, 'I tell what I have heard; shall I tell you what I have not heard?' "


Bukhari :: Drinks :: [7.69.501]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 501

Narrated Ash-Shaibani:

I heard 'Abdullah bin Abi Aufa saying, "The Prophet forbade the use of green jars." I said, "Shall we drink out of white jars?" He said, "No."


Bukhari :: Drinks :: [7.69.502]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 502

Narrated Sahl bin Sad

Abu Usaid As Sa'idi invited the Prophet to his wedding banquet. At that time his wife was serving them and she was the bride. She said, ''Do you know what (kind of syrup) I soaked (made) for Allah's Apostle? I soaked some dates in water in a Tur (bowl) overnight. '


Bukhari :: Drinks :: [7.69.503]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 503

Narrated Abu Al-Juwairiyya:

I asked Ibn 'Abbas about Al-Badhaq. He said, "Muhammad prohibited alcoholic drinks before It was called Al-Badhaq (by saying), 'Any drink that intoxicates is unlawful.' I said, 'What about good lawful drinks?' He said,'Apart from what is lawful and good, all other things are unlawful and not good (unclean Al-Khabith).


Bukhari :: Drinks :: [7.69.504]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 504

Narrated 'Aisha:

The Prophet used to like sweet edible things and honey.


Bukhari :: Drinks :: [7.69.505]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 505

Narrated Anas:

While I was serving Abu Talha. Abu Dujana and Abu Suhail bin Al-Baida' with a drink made from a mixture of unripe and ripe dates, alcoholic drinks, were made unlawful, whereupon I threw it away, and I was their butler and the youngest of them, and we used to consider that drink as an alcoholic drink in those days


Bukhari :: Drinks :: [7.69.506]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 506

Narrated Jabir:

The Prophet forbade the drinking of alcoholic drinks prepared from raisins, dates, unripe dates and fresh ripe dates.


Bukhari :: Drinks :: [7.69.507]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 507

Narrated Abu Qatada:

The Prophet forbade the mixing of ripe and unripe dates and also the mixing of dates and raisins (for preparing a syrup) but the syrup of each kind of fruit should be prepared separately. ( One may have such drinks as long as it is fresh )


Bukhari :: Drinks :: [7.69.508]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 508

Narrated Abu Huraira:

Allah's Apostle was presented a bowl of milk and a bowl of wine on the night he was taken on a journey (Al-Mi'raj).


Bukhari :: Drinks :: [7.69.509]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 509

Narrated Um Al-Fadl:

The people doubted whether Allah's Apostle was fasting or the Day of 'Arafat or not. So I sent a cup containing milk to him and he drank it.


Bukhari :: Drinks :: [7.69.510]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 510

Narrated Jabir bin 'Abdullah:

Abu Humaid brought a cup of mix from a place called Al-Naqi. Allah's Apostle said to him, "Will you not cover it, even by placing a stick across its"


Bukhari :: Drinks :: [7.69.511]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 511

Narrated Jabir:

Abu Humaid, an Ansari man, came from AnNaqi carrying a cup of milk to the Prophet. The Prophet said, "Will you not cover it even by placing a stick across it?"


Bukhari :: Drinks :: [7.69.512]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 512

Narrated Al-Bara:

The Prophet came from Mecca with Abu Bakr. Abu Bakr said "We passed by a shepherd and at that time Allah's Apostle was thirsty. I milked a little milk in a bowl and Allah's Apostle drank till I was pleased. Suraqa bin Ju'shum came to us riding a horse (chasing us). The Prophet invoked evil upon him, whereupon Suraqa requested him not to invoke evil upon him, in which case he would go back. The Prophet agreed.


Bukhari :: Drinks :: [7.69.513]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 513

Narrated Abu Huraira:

Allah's Apostle said, "The best object of charity is a she-camel which has (newly) given birth and gives plenty of milk, or a she-goat which gives plenty of milk; and is given to somebody to utilize its milk by milking one bowl in the morning and one in the evening."


Bukhari :: Drinks :: [7.69.514]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 514

Narrated Ibn 'Abbas: Allah's Apostle drank milk and then rinsed his mouth and said, "It contains fat. The Prophet added: I was raised to the Lote Tree and saw four rivers, two of which were coming out and two going in. Those which were coming out were the Nile and the Euphrates, and those which were going in were two rivers in paradise. Then I was given three bowls, one containing milk, and another containing honey, and a third containing wine. I took the bowl containing milk and drank it. It was said to me, "You and your followers will be on the right path (of Islam)."


Bukhari :: Drinks :: [7.69.515]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 515

Narrated Anas bin Malik:

Abu Talha had the largest number of datepalms from amongst the Ansars of Medina. The dearest of his property to him was Bairuha garden which was facing the (Prophet's) Mosque. Allah's Apostle used to enter it and drink of its good fresh water. When the Holy Verse:-- 'By no means shall you attain righteousness unless you spend (in charity) of that which you love.' (3.92) was revealed, Abu Talha got up and said, "O Allah's Apostle! Allah says: By no means shall you attain righteousness unless you spend of that which you love,' and the dearest of my property to me is the Bairuha garden and I want to give it in charity in Allah's Cause, seeking to be rewarded by Allah for that. So you can spend it, O Allah's Apostle, where-ever Allah instructs you. ' Allah s Apostle said, "Good! That is a perishable (or profitable) wealth" ('Abdullah is in doubt as to which word was used.) He said, "I have heard what you have said but in my opinion you'd better give it to your kith and kin." On that Abu Talha said, "I will do so, O Allah's Apostle!" Abu Talha distributed that garden among his kith and kin and cousins.


Bukhari :: Drinks :: [7.69.516]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 516

Narrated Anas bin Malik:

I saw Allah's Apostle drinking milk. He came to my house and I milked a sheep and then mixed the milk with water from the well for Allah's Apostle. He took the bowl and drank while on his left there was sitting Abu Bakr, and on his right there was a bedouin. He then gave the remaining milk to the bedouin and said, "The right! The right (first)."


Bukhari :: Drinks :: [7.69.517]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 517

Narrated Jabir bin 'Abdullah:

Allah's Apostle and one of his companions entered upon an Ansari man and the Prophet said to him, "If you have water kept overnight in a water skin, (give us), otherwise we will drink water by putting our mouth in it." The man was watering his garden then. He said, "O Allah's Apostle! I have water kept overnight; let us go to the shade." So he took them both there and poured water into a bowl and milked a domestic goat of his in it. Allah's Apostle drank, and then the man who had come along with him, drank.


Bukhari :: Drinks :: [7.69.518]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 518

Narrated 'Aisha:

The Prophet used to like sweet edible things (syrup, etc.) and honey.


Bukhari :: Drinks :: [7.69.519]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 519

Narrated An-Nazzal:

All came to the gate of the courtyard (of the Mosque) and drank (water) while he was standing and said, "Some people dislike to drink while standing, but I saw the Prophet doing (drinking water) as you have seen me doing now."


Bukhari :: Drinks :: [7.69.520]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 520

Narrated An-Nazzal bin Sabra:

'Ali offered the Zuhr prayer and then sat down in the wide courtyard (of the Mosque) of Kufa in order to deal with the affairs of the people till the 'Asr prayer became due. Then water was brought to him and he drank of it, washed his face, hands, head and feet. Then he stood up and drank the remaining water while he was standing. and said, "Some people dislike to drink water while standing thought the Prophet did as I have just done."


Bukhari :: Drinks :: [7.69.521]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 521

Narrated Ibn 'Abbas:

The Prophet drank Zam-Zam (water) while standing.


Bukhari :: Drinks :: [7.69.522]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 522

Narrated Um Al-Fadl:

(daughter of Al-Harith) that she sent a bowl of milk to the Prophet while he was standing (at 'Arafat) in the afternoon of the Day of 'Arafat. He took it in his hands and drank it. Narrated Abu Nadr: The Prophet was on the back of his camel.


Bukhari :: Drinks :: [7.69.523]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 523

Narrated Anas bin Malik:

Milk mixed with water was brought to Allah's Apostle while a bedouin was on his right and Abu Bakr was on his left. He drank (of it) and then gave (it) to the bedouin and said, 'The right" "The right (first)."


Bukhari :: Drinks :: [7.69.524]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 524

Narrated Sahl bin Sad:

Allah's Apostle was offered something to drink. He drank of it while on his right was a boy and on his left were some elderly people. He said to the boy, "May I give these (elderly) people first?" The boy said, "By Allah, O Allah's Apostle! I will not give up my share from you to somebody else." On that Allah's Apostle placed the cup in the hand of that boy.


Bukhari :: Drinks :: [7.69.525]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 525

Narrated Jabir bin 'Abdullah:

The Prophet and one of his companions entered upon an Ansari man. The Prophet and his companion greeted (the man) and he replied, "O Allah's Apostle! Let my father and mother be sacrificed for you! It is hot," while he was watering his garden. The Prophet asked him, "If you have water kept overnight in a water skin, (give us), or else we will drink by putting our mouths in the basin." The man was watering the garden The man said, "O Allah's Apostle! I have water kept overnight in a water-skin. He went to the shade and poured some water into a bowl and milked some milk from a domestic goat in it. The Prophet drank and then gave the bowl to the man who had come along with him to drink.


Bukhari :: Drinks :: [7.69.526]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 526

Narrated Anas:

I was waiting on my uncles, serving them with an alcoholic drink prepared from dates, and I was the youngest of them. (Suddenly) it was said that alcoholic drinks had been prohibited. So they said (to me), 'Throw it away." And I threw it away The sub-narrator said: I asked Anas what their drink was (made from), He replied, "(From) ripe dates and unripe dates."


Bukhari :: Drinks :: [7.69.527]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 527

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "When night falls (or when it is evening), stop your children from going out, for the devils spread out at that time. But when an hour of the night has passed, release them and close the doors and mention Allah's Name, for Satan does not open a closed door. Tie the mouth of your water-skin and mention Allah's Name; cover your containers and utensils and mention Allah's Name. Cover them even by placing something across it, and extinguish your lamps. "


Bukhari :: Drinks :: [7.69.528]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 528

Narrated Jabir:

Allah's Apostle said, "Extinguish the lamps when you go to bed; close your doors; tie the mouths of your water skins, and cover the food and drinks." I think he added, ". . . even with a stick you place across the container."


Bukhari :: Drinks :: [7.69.529]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 529

Narrated Abu Said Al-Khudri:

Allah's Apostle forbade the bending of the mouths of water skins for the sake of drinking from them


Bukhari :: Drinks :: [7.69.530]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 530

Narrated Abu Said Al-Khudri:

I heard Allah's Apostle forbidding the drinking of water by bending the mouths of water skins, i.e., drinking from the mouths directly.


Bukhari :: Drinks :: [7.69.531]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 531

Narrated Abu Huraira:

Allah's Apostle forbade drinking directly from the mouth of a water skin or other leather containers. and forbade preventing one's neighbor from fixing a peg in (the wall of) one's house.


Bukhari :: Drinks :: [7.69.532]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 532

Narrated Abu Huraira:

The Prophet forbade the drinking of water directly from the mouth of a water skin .


Bukhari :: Drinks :: [7.69.533]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 533

Narrated Ibn Abbas:

The Prophet forbade the drinking of water direct from the mouth of a water-skin.


Bukhari :: Drinks :: [7.69.534]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 534

Narrated Abu Qatada:

Allah's Apostle said, "When you drink (water), do not breath in the vessel; and when you urinate, do not touch your penis with your right hand. And when you cleanse yourself after defecation, do not use your right hand."


Bukhari :: Drinks :: [7.69.535]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 535

Narrated Thumama bin Abdullah:

Anas used to breathe twice or thrice in the vessel (while drinking) and used to say that the Prophet; used to take three breaths while drinking.


Bukhari :: Drinks :: [7.69.536]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 536

Narrated Ibn Abi Laila:

While Hudhaita was at Mada'in, he asked for water. The chief of the village brought him a silver vessel. Hudhaifa threw it away and said, "I have thrown it away because I told him not to use it, but he has not stopped using it. The Prophet forbade us to wear clothes of silk or Dibaj, and to drink in gold or silver utensils, and said, 'These things are for them (unbelievers) in this world and for you (Muslims) in the Hereafter.' "


Bukhari :: Drinks :: [7.69.537]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 537

Narrated Hudhaifa:

The Prophet said, "Do not drink in gold or silver utensils, and do not wear clothes of silk or Dibaj, for these things are for them (unbelievers) in this world and for you in the Hereafter."


Bukhari :: Drinks :: [7.69.538]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 538

Narrated Um Salama:

(the wife of the Prophet) Allah's Apostle said, "He who drinks in silver utensils is only filling his abdomen with Hell Fire."


Bukhari :: Drinks :: [7.69.539]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 539

Narrated Al-Bara' bin 'Azib:

Allah's Apostle ordered us to do seven things and forbade us from seven. He ordered us to visit the sick, to follow funeral processions, (to say) to a sneezer, (May Allah bestow His Mercy on you, if he says, Praise be to Allah), to accept invitations, to greet (everybody), to help the oppressed and to help others to fulfill their oaths. He forbade us to wear gold rings, to drink in silver (utensils), to use Mayathir (silken carpets placed on saddles), to wear Al-Qissi (a kind of silken cloth), to wear silk, Dibaj or Istabraq (two kinds of silk).


Bukhari :: Drinks :: [7.69.540]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 540

Narrated Um Al-Fadl:

that the people were in doubt whether the Prophet was fasting on the Day of 'Arafat or not, so a (wooden) drinking vessel full of milk was sent to him, and he drank it.


Bukhari :: Drinks :: [7.69.541]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 541

Narrated Sahl bin Sad:

An Arab lady was mentioned to the Prophet so he asked Abu Usaid As-Sa'idi to send for her, and he sent for her and she came and stayed in the castle of Bani Sa'ida. The Prophet came out and went to her and entered upon her. Behold, it was a lady sitting with a drooping head. When the Prophet spoke to her, she said, "I seek refuge with Allah from you." He said, "I grant you refuge from me." They said to her, "Do you know who this is?" She said, "No." They said, "This is Allah's Apostle who has come to command your hand in marriage." She said, "I am very unlucky to lose this chance." Then the Prophet and his companions went towards the shed of Bani Sa'ida and sat there. Then he said, "Give us water, O Sahl!" So I took out this drinking bowl and gave them water in it. The sub-narrator added: Sahl took out for us that very drinking bowl and we all drank from it. Later on Umar bin 'Abdul 'Aziz requested Sahl to give it to him as a present, and he gave it to him as a present.


Bukhari :: Drinks :: [7.69.542]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 542

Narrated 'Asim al-Ahwal:

I saw the drinking bowl of the Prophet with Anas bin Malik, and it had been broken, and he had mended it with silver plates. That drinking bowl was quite wide and made of Nadar wood, Anas said, "I gave water to the Prophet in that bowl more than so-and-so (for a long period)." Ibn Sirin said: Around that bowl there was an iron ring, and Anas wanted to replace it with a silver or gold ring, but Abu Talha said to him, "Do not change a thing that Allah's Apostle has made." So Anas left it as it was.


Bukhari :: Drinks :: [7.69.543]

Drinks

Bukhari :: Book 7 :: Volume 69 :: Hadith 543

Narrated Jabir bin 'Abdullah:

I was with the Prophet and the time for the 'Asr prayer became due. We had no water with us except a little which was put in a vessel and was brought to the Prophet . He put his hand into it and spread out his fingers and then said, "Come along! Hurry up! All those who want to perform ablution. The blessing is from Allah.'' I saw the water gushing out from his fingers. So the people performed the ablution and drank, and I tried to drink more of that water (beyond my thirst and capacity), for I knew that it was a blessing. The sub-narrator said: I asked Jabir, "How many persons were you then?" He replied, "We were one-thousand four hundred men." Salim said: Jabir said, 1500.


Bukhari :: Patients :: [7.70.544]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 544

Narrated 'Aisha:

(the wife of the Prophet) Allah's Apostle said, "No calamity befalls a Muslim but that Allah expiates some of his sins because of it, even though it were the prick he receives from a thorn."


Bukhari :: Patients :: [7.70.545]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 545

Narrated Abu Sa'id Al-Khudri and Abu Huraira:

The Prophet said, "No fatigue, nor disease, nor sorrow, nor sadness, nor hurt, nor distress befalls a Muslim, even if it were the prick he receives from a thorn, but that Allah expiates some of his sins for that."


Bukhari :: Patients :: [7.70.546]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 546

Narrated Kab:

The Prophet said, "The example of a believer is that of a fresh tender plant, which the wind bends lt sometimes and some other time it makes it straight. And the example of a hypocrite is that of a pine tree which keeps straight till once it is uprooted suddenly.


Bukhari :: Patients :: [7.70.547]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 547

Narrated Abu Huraira:

Allah's Apostle said, "The example of a believer is that of a fresh tender plant; from whatever direction the wind comes, it bends it, but when the wind becomes quiet, it becomes straight again. Similarly, a believer is afflicted with calamities (but he remains patient till Allah removes his difficulties.) And an impious wicked person is like a pine tree which keeps hard and straight till Allah cuts (breaks) it down when He wishes." (See Hadith No. 558, Vol. 9.)


Bukhari :: Patients :: [7.70.548]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 548

Narrated Abu Huraira:

Allah's Apostle said, "If Allah wants to do good to somebody, He afflicts him with trials."


Bukhari :: Patients :: [7.70.549]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 549

Narrated Aisha:

I never saw anybody suffering so much from sickness as Allah's Apostle


Bukhari :: Patients :: [7.70.550]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 550

Narrated 'Abdullah:

I visited the Prophet during his ailments and he was suffering from a high fever. I said, "You have a high fever. Is it because you will have a double reward for it?" He said, "Yes, for no Muslim is afflicted with any harm but that Allah will remove his sins as the leaves of a tree fall down."


Bukhari :: Patients :: [7.70.551]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 551

Narrated 'Abdullah:

I visited Allah's Apostle while he was suffering from a high fever. I said, "O Allah's Apostle! You have a high fever." He said, "Yes, I have as much fever as two men of you." I said, "Is it because you will have a double reward?" He said, "Yes, it is so. No Muslim is afflicted with any harm, even if it were the prick of a thorn, but that Allah expiates his sins because of that, as a tree sheds its leaves."


Bukhari :: Patients :: [7.70.552]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 552

Narrated Abu Muisa Al-Ash'ari:

The Prophet said, "Feed the hungry, visit the sick, and set free the captives."


Bukhari :: Patients :: [7.70.553]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 553

Narrated Al-Bara bin Azib:

Allah's Apostle ordered us to do seven things and forbade us to do seven other things. He forbade us to wear gold rings, silk, Dibaj, Istabriq, Qissy, and Maithara; and ordered us to accompany funeral processions, visit the sick and greet everybody. (See Hadith No. 104)


Bukhari :: Patients :: [7.70.554]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 554

Narrated Jabir bin 'Abdullah:

Once I fell ill. The Prophet and Abu Bakr came walking to pay me a visit and found me unconscious. The Prophet performed ablution and then poured the remaining water on me, and I came to my senses to see the Prophet. I said, "O Allah's Apostle! What shall I do with my property? How shall I dispose of (distribute) my property?" He did not reply till the Verse of inheritance was revealed.


Bukhari :: Patients :: [7.70.555]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 555

Narrated 'Ata bin Abi Rabah:

Ibn 'Abbas said to me, "Shall I show you a woman of the people of Paradise?" I said, "Yes." He said, "This black lady came to the Prophet and said, 'I get attacks of epilepsy and my body becomes uncovered; please invoke Allah for me.' The Prophet said (to her), 'If you wish, be patient and you will have (enter) Paradise; and if you wish, I will invoke Allah to cure you.' She said, 'I will remain patient,' and added, 'but I become uncovered, so please invoke Allah for me that I may not become uncovered.' So he invoked Allah for her."


Bukhari :: Patients :: [7.70.556]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 556

Narrated 'Ata:

That he had seen Um Zafar, the tall black lady, at (holding) the curtain of the Ka'ba.


Bukhari :: Patients :: [7.70.557]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 557

Narrated Anas bin Malik:

I heard Allah's Apostle saying, "Allah said, 'If I deprive my slave of his two beloved things (i.e., his eyes) and he remains patient, I will let him enter Paradise in compensation for them.'"


Bukhari :: Patients :: [7.70.558]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 558

Narrated 'Aisha:

When Allah's Apostle emigrated to Medina, Abu Bakr and Bilal got a fever. I entered upon them and asked, "O my father! How are you? O Bilal! How are you?" Whenever fever attacked Abu Bakr, he would recite the following poetic verses: 'Everybody is staying alive among his people, yet death is nearer to him than his shoe laces." And whenever the fever deserted Bilal, he would recite (two poetic lines): 'Would that I could stay overnight in a valley wherein I would be surrounded by Idhkhir and Jalil (two kinds of good smelling grass). Would that one day I would drink of the water of Majinna and would that Shama and Tafil (two mountains at Mecca) would appear to me.' Then I came and informed Allah's Apostle about that, whereupon he said, "O Allah! Make us love Medina as much or more than we love Mecca. O Allah! Make it healthy and bless its Mudd and Sa for us, and take away its fever and put it in Al'Juhfa."


Bukhari :: Patients :: [7.70.559]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 559

Narrated Abu 'Uthman:

Usama bin Zaid said that while he. Sad and Ubai bin Ka'b were with the Prophet a daughter of the Prophet sent a message to him, saying. 'My daughter is dying; please come to us." The Prophet sent her his greetings and added "It is for Allah what He takes, and what He gives; and everything before His sight has a limited period. So she should hope for Allah's reward and remain patient." She again sent a message, beseeching him by Allah, to come. So the Prophet got up. and so did we (and went there). The child was placed on his lap while his breath was irregular. Tears flowed from the eyes of the Prophet. Sad said to him, "What is this, O Allah's Apostle?" He said. "This Is Mercy which Allah has embedded in the hearts of whomever He wished of His slaves. And Allah does not bestow His Mercy, except on the merciful among His slaves. (See Hadith No. 373 Vol. 2)


Bukhari :: Patients :: [7.70.560]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 560

Narrated Ibn Abbas:

The Prophet went to visit a sick bedouin. Whenever the Prophet went to a patient, he used to say to him, "Don't worry, if Allah will, it will be expiation (for your sins):" The bedouin said, "You say expiation? No, it is but a fever that is boiling or harassing an old man and will lead him to his grave without his will." The Prophet said, "Then, yes, it is so."


Bukhari :: Patients :: [7.70.561]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 561

Narrated Anas:

A Jewish boy used to serve the Prophet and became ill. The Prophet went to pay him a visit and said to him, "Embrace Islam," and he did embrace Islam. Al-Musaiyab said: When Abu Talib was on his deathbed, the Prophet visited him.


Bukhari :: Patients :: [7.70.562]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 562

Narrated 'Aisha:

During the ailment of the Prophet some people came to visits him. He led them in prayer while sitting. but they prayed standing, so he waved to them to sit down. When he had finished the prayer, he said, "An Imam is to be followed, so when he bows, you should bow. and when he raises his head, you should raise yours, and if he prays sitting. you should pray sitting." Abu Abdullah said Al-Humaidi said, (The order of ) "This narration has been abrogated by the last action of the Prophet as he led the prayer sitting, while the people prayed standing behind him'


Bukhari :: Patients :: [7.70.563]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 563

Narrated Sad:

I became seriously ill at Mecca and the Prophet came to visit me. I said, "O Allah's Apostle! I shall leave behind me a good fortune, but my heir is my only daughter; shall I bequeath two third of my property to be spent in charity and leave one third (for my heir)?" He said, "No." I said, "Shall I bequeath half and leave half?" He said, "No." I said, "Shall I bequeath one third and leave two thirds?" He said, "One third is alright, though even one third is too much." Then he placed his hand on his forehead and passed it over my face and abdomen and said, "O Allah! Cure Sad and complete his emigration." I feel as if I have been feeling the coldness of his hand on my liver ever since.


Bukhari :: Patients :: [7.70.564]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 564

Narrated 'Abdullah bin Mas'ud:

I visited Allah's Apostle while he was suffering from a high fever. I touched him with my hand and said, "O Allah's Apostle! You have a high fever." Allah's Apostle said, "Yes, I have as much fever as two men of you have." I said, "Is it because you will get a double reward?" Allah's Apostle said, "Yes, no Muslim is afflicted with harm because of sickness or some other inconvenience, but that Allah will remove his sins for him as a tree sheds its leaves."


Bukhari :: Patients :: [7.70.565]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 565

Narrated 'Abdullah:

I visited the Prophet during his illness and touched him while he was having a fever. I said to him, "You have a high fever; is it because you will get a double reward?" He said, "Yes. No Muslim is afflicted with any harm, but that his sins will be annulled as the leave of a tree fall down."


Bukhari :: Patients :: [7.70.566]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 566

Narrated Ibn 'Abbas:

Allah's Apostle entered upon sick man to pay him a visit, and said to him, "Don't worry, Allah willing, (your sickness will be) an expiation for your sins." The man said, "No, it is but a fever that is boiling within an old man and will send him to his grave." On that, the Prophet said, "Then yes, it is so."


Bukhari :: Patients :: [7.70.567]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 567

Narrated Usama bin Zaid:

The Prophet rode a donkey having a saddle with a Fadakiyya velvet covering. He mounted me behind him and went to visit Sad bin 'Ubada, and that had been before the battle of Badr. The Prophet proceeded till he passed by a gathering in which 'Abdullah bin Ubai bin Salul was present, and that had been before 'Abdullah embraced Islam. The gathering comprised of Muslims, polytheists, i.e., isolators and Jews. 'Abdullah bin Rawaha was also present in that gathering. When dust raised by the donkey covered the gathering, 'Abdullah bin Ubai covered his nose with his upper garment and said, "Do not trouble us with dust." The Prophet greeted them, stopped and dismounted. Then he invited them to Allah (i.e., to embrace Islam) and recited to them some verses of the Holy Qur'an. On that, 'Abdullah bin Ubai said, "O man ! There is nothing better than what you say if it is true. Do not trouble us with it in our gathering, but return to your house, and if somebody comes to you, teach him there." On that 'Abdullah bin Rawaha said, Yes, O Allah's Apostle! Bring your teachings to our gathering, for we love that." So the Muslims, the pagans and the Jews started abusing each other till they were about to fight. The Prophet kept on quietening them till they became calm. Thereupon the Prophet mounted his animal and proceeded till he entered upon Sad bin Ubada. He said to him "O Sad! Have you not heard what Abu Hubab (i.e., 'Abdullah bin Ubai) said?" Sad said, 'O Allah's Apostle! Excuse and forgive him, for Allah has given you what He has given you. The people of this town (Medina decided unanimously to crown him and make him their chief by placing a turban on his head, but when that was prevented by the Truth which Allah had given you he ('Abdullah bin Ubai) was grieved out of jealously, and that was the reason which caused him to behave in the way you have seen."


Bukhari :: Patients :: [7.70.568]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 568

Narrated Jabir:

The Prophet came to visit me (while I was sick) and he was riding neither a mule, nor a horse.


Bukhari :: Patients :: [7.70.569]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 569

Narrated Ka'b bin 'Ujara:

The Prophet passed by me while I was kindling a fire under a (cooking) pot. He said, "Do the lice of your head trouble you?" I said, "Yes." So he called a barber to shave my head and ordered me to make expiation for that."


Bukhari :: Patients :: [7.70.570]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 570

Narrated Al-Qasim bin Muhammad:

'Aisha, (complaining of headache) said, "Oh, my head"! Allah's Apostle said, "I wish that had happened while I was still living, for then I would ask Allah's Forgiveness for you and invoke Allah for you." Aisha said, "Wa thuklayah! By Allah, I think you want me to die; and If this should happen, you would spend the last part of the day sleeping with one of your wives!" The Prophet said, "Nay, I should say, 'Oh my head!' I felt like sending for Abu Bakr and his son, and appoint him as my successor lest some people claimed something or some others wished something, but then I said (to myself), 'Allah would not allow it to be otherwise, and the Muslims would prevent it to be otherwise".


Bukhari :: Patients :: [7.70.571]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 571

Narrated Ibn Mas'ud:

I visited the Prophet while he was having a high fever. I touched him an said, "You have a very high fever" He said, "Yes, as much fever as two me of you may have." I said. "you will have a double reward?" He said, "Yes No Muslim is afflicted with hurt caused by disease or some other inconvenience, but that Allah will remove his sins as a tree sheds its leaves."


Bukhari :: Patients :: [7.70.572]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 572

Narrated Sad:

Allah's Apostle came to visit me during my ailment which had been aggravated during Hajjat-al-Wada'. I said to him, "You see how sick I am. I have much property but have no heir except my only daughter May I give two thirds of my property in charity?"! He said, "No." I said, "Half of it?" He said, "No." I said "One third?" He said, "One third is too much, for to leave your heirs rich is better than to leave them poor, begging of others. Nothing you spend seeking Allah's pleasure but you shall get a reward for it, even for what you put in the mouth of your wife."


Bukhari :: Patients :: [7.70.573]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 573

Narrated Ibn 'Abbas:

When Allah's Apostle was on his death-bed and in the house there were some people among whom was 'Umar bin Al-Khattab, the Prophet said, "Come, let me write for you a statement after which you will not go astray." 'Umar said, "The Prophet is seriously ill and you have the Qur'an; so the Book of Allah is enough for us." The people present in the house differed and quarrelled. Some said "Go near so that the Prophet may write for you a statement after which you will not go astray," while the others said as Umar said. When they caused a hue and cry before the Prophet, Allah's Apostle said, "Go away!" Narrated 'Ubaidullah: Ibn 'Abbas used to say, "It was very unfortunate that Allah's Apostle was prevented from writing that statement for them because of their disagreement and noise."


Bukhari :: Patients :: [7.70.574]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 574

Narrated As-Sa'ib:

My aunt took me to Allah's Apostle and said, "O Allah's Apostle! My nephew is- ill." The Prophet touched my head with his hand and invoked Allah to bless me. He then performed ablution and I drank of the remaining water of his ablution and then stood behind his back and saw "Khatam An-Nubuwwa" (The Seal of Prophethood) between his shoulders like a button of a tent.


Bukhari :: Patients :: [7.70.575]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 575

Narrated Anas bin Malik:

The Prophet said, "None of you should wish for death because of a calamity befalling him; but if he has to wish for death, he should say: "O Allah! Keep me alive as long as life is better for me, and let me die if death is better for me.' "


Bukhari :: Patients :: [7.70.576]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 576

Narrated Qais bin Abi Hazim:

We went to pay a visit to Khabbab (who was sick) and he had been branded (cauterized) at seven places in his body. He said, "Our companions who died (during the lifetime of the Prophet) left (this world) without having their rewards reduced through enjoying the pleasures of this life, but we have got (so much) wealth that we find no way to spend It except on the construction of buildings Had the Prophet not forbidden us to wish for death, I would have wished for it.' We visited him for the second time while he was building a wall. He said, A Muslim is rewarded (in the Hereafter) for whatever he spends except for something that he spends on building."


Bukhari :: Patients :: [7.70.577]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 577

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The good deeds of any person will not make him enter Paradise." (i.e., None can enter Paradise through his good deeds.) They (the Prophet's companions) said, 'Not even you, O Allah's Apostle?' He said, "Not even myself, unless Allah bestows His favor and mercy on me." So be moderate in your religious deeds and do the deeds that are within your ability: and none of you should wish for death, for if he is a good doer, he may increase his good deeds, and if he is an evil doer, he may repent to Allah."


Bukhari :: Patients :: [7.70.578]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 578

Narrated 'Aisha:

I heard the Prophet , who was resting against me, saying, "O Allah! Excuse me and bestow Your Mercy on me and let me join with the highest companions (in Paradise)." See Qur'an (4.69)


Bukhari :: Patients :: [7.70.579]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 579

Narrated 'Aisha:

Whenever Allah's Apostle paid a visit to a patient, or a patient was brought to him, he used to invoke Allah, saying, "Take away the disease, O the Lord of the people! Cure him as You are the One Who cures. There is no cure but Yours, a cure that leaves no disease."


Bukhari :: Patients :: [7.70.580]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 580

Narrated Jabir bin Abdullah:

The Prophet came to me while I was ill. He performed ablution and threw the remaining water on me (or said, "Pour it on him) " When I came to my senses I said, "O Allah's Apostle! I have no son or father to be my heir, so how will be my inheritance?" Then the Verse of inheritance was revealed.


Bukhari :: Patients :: [7.70.581]

Patients

Bukhari :: Book 7 :: Volume 70 :: Hadith 581

Narrated 'Aisha:

When Allah's Apostle emigrated to Medina, Abu Bakr and Bilal had a fever. I entered upon them and said, "O my father! How are you? O Bilal! How are you?" Whenever Abu Bakr got the fever he used to say, "Everybody is staying alive with his people, yet death is nearer to him than his shoe laces." And when fever deserted Bilal, he would recite (two poetic verses): "Would that I could stay overnight in a valley wherein I would be surrounded by Idhkhir and Jalil (two kinds of good smelling grass). Would that one day I could drink of the water of Majinna, and would that Shama and Tafil (two mountains at Mecca) would appear to me!" I went to Allah's Apostle and informed him about that. He said, "O Allah! Make us love Medina as much or more than we love Mecca, and make it healthy, and bless its Sa and its Mudd, and take away its fever and put it in Al-Juhfa." (See Hadith No 558) .


Bukhari :: Medicine :: [7.71.582]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 582

Narrated Abu Huraira:

The Prophet said, "There is no disease that Allah has created, except that He also has created its treatment."


Bukhari :: Medicine :: [7.71.583]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 583

Narrated Rubai bint Mu'adh bin Afra:

We used to go for Military expeditions along with Allah's Apostle and provide the people with water, serve them and bring the dead and the wounded back to Medina.


Bukhari :: Medicine :: [7.71.584]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 584

Narrated Ibn 'Abbas:

(The Prophet said), "Healing is in three things: A gulp of honey, cupping, and branding with fire (cauterizing)." But I forbid my followers to use (cauterization) branding with fire."


Bukhari :: Medicine :: [7.71.585]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 585

Narrated Ibn 'Abbas:

The Prophet said, "Healing is in three things: cupping, a gulp of honey or cauterization, (branding with fire) but I forbid my followers to use cauterization (branding with fire)."


Bukhari :: Medicine :: [7.71.586]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 586

Narrated 'Aisha:

The Prophet used to like sweet edible things and honey.


Bukhari :: Medicine :: [7.71.587]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 587

Narrated Jabir bin Abdullah:

I heard the Prophet saying, "If there is any healing in your medicines, then it is in cupping, a gulp of honey or branding with fire (cauterization) that suits the ailment, but I don't like to be (cauterized) branded with fire."


Bukhari :: Medicine :: [7.71.588]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 588

Narrated Abu Said Al-Khudri:

A man came to the Prophet and said, "My brother has some abdominal trouble." The Prophet said to him "Let him drink honey." The man came for the second time and the Prophet said to him, 'Let him drink honey." He came for the third time and the Prophet said, "Let him drink honey." He returned again and said, "I have done that ' The Prophet then said, "Allah has said the truth, but your brother's abdomen has told a lie. Let him drink honey." So he made him drink honey and he was cured.


Bukhari :: Medicine :: [7.71.589]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 589

Narrated Anas:

Some people were sick and they said, "O Allah's Apostle! Give us shelter and food. So when they became healthy they said, "The weather of Medina is not suitable for us." So he sent them to Al-Harra with some she-camels of his and said, "Drink of their milk." But when they became healthy, they killed the shepherd of the Prophet and drove away his camels. The Prophet sent some people in their pursuit. Then he got their hands and feet cut and their eyes were branded with heated pieces of iron. I saw one of them licking the earth with his tongue till he died.


Bukhari :: Medicine :: [7.71.590]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 590

Narrated Anas:

The climate of Medina did not suit some people, so the Prophet ordered them to follow his shepherd, i.e. his camels, and drink their milk and urine (as a medicine). So they followed the shepherd that is the camels and drank their milk and urine till their bodies became healthy. Then they killed the shepherd and drove away the camels. When the news reached the Prophet he sent some people in their pursuit. When they were brought, he cut their hands and feet and their eyes were branded with heated pieces of iron.


Bukhari :: Medicine :: [7.71.591]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 591

Narrated Khalid bin Sad:

We went out and Ghalib bin Abjar was accompanying us. He fell ill on the way and when we arrived at Medina he was still sick. Ibn Abi 'Atiq came to visit him and said to us, "Treat him with black cumin. Take five or seven seeds and crush them (mix the powder with oil) and drop the resulting mixture into both nostrils, for 'Aisha has narrated to me that she heard the Prophet saying, 'This black cumin is healing for all diseases except As-Sam.' Aisha said, 'What is As-Sam?' He said, 'Death."


Bukhari :: Medicine :: [7.71.592]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 592

Narrated Abu Huraira:

I heard Allah's Apostle saying, "There is healing in black cumin for all diseases except death."


Bukhari :: Medicine :: [7.71.593]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 593

Narrated 'Ursa:

Aisha used to recommend At-Talbina for the sick and for such a person as grieved over a dead person. She used to say, "I heard Allah's Apostle saying, 'At-Talbina gives rest to the heart of the patient and makes it active and relieves some of his sorrow and grief.' "


Bukhari :: Medicine :: [7.71.594]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 594

Narrated Hisham's father:

'Aisha used to recommend At-Talbina and used to say, "It is disliked (by the patient) although it is beneficial.''


Bukhari :: Medicine :: [7.71.595]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 595

Narrated Ibn 'Abbas:

The Prophet was cupped and he paid the wages to the one who had cupped him and then took Su'ut (Medicine sniffed by nose).


Bukhari :: Medicine :: [7.71.596]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 596

Narrated Um Qais bint Mihsan:

I heard the Prophet saying, "Treat with the Indian incense, for it has healing for seven diseases; it is to be sniffed by one having throat trouble, and to be put into one side of the mouth of one suffering from pleurisy." Once I went to Allah's Apostle with a son of mine who would not eat any food, and the boy passed urine on him whereupon he asked for some water and sprinkled it over the place of urine.


Bukhari :: Medicine :: [7.71.597]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 597

Narrated Ibn 'Abbas:

The Prophet was cupped while he was fasting.


Bukhari :: Medicine :: [7.71.598]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 598

Narrated Ibn 'Abbas:

The Prophet was cupped while he was in a state of Ihram.


Bukhari :: Medicine :: [7.71.599]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 599

Narrated Anas:

that he was asked about the wages of the one who cups others. He said, 'Allah's Apostle was cupped by Abd Taiba, to whom he gave two Sa of food and interceded for him with his masters who consequently reduced what they used to charge him daily. Then the Prophet s said, "The best medicines you may treat yourselves with are cupping and sea incense.' He added, "You should not torture your children by treating tonsillitis by pressing the tonsils or the palate with the finger, but use incense."


Bukhari :: Medicine :: [7.71.600]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 600

Narrated Jabir bin 'Abdullah:

that he paid Al-Muqanna a visit during his illness and said, "I will not leave till he gets cupped, for I heard Allah's Apostle saying, "There is healing in cupping."


Bukhari :: Medicine :: [7.71.601]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 601

Narrated 'Abdullah bin Buhaina:

Allah's Apostle was cupped on the middle of his head at Lahl Jamal on his way to Mecca while he was in a state of Ihram. Narrated Ibn 'Abbas: Allah's Apostle was cupped on his head.


Bukhari :: Medicine :: [7.71.602]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 602

Narrated Ibn 'Abbas:

The Prophet was cupped on his head for an ailment he was suffering from while he was in a state of Ihram. at a water place called Lahl Jamal. Ibn 'Abbas further said: Allah s Apostle was cupped on his head for unilateral headache while he was in a state of Ihram .


Bukhari :: Medicine :: [7.71.603]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 603

Narrated Jabir bin 'Abdullah:

I heard the Prophet saying, "If there is any good in your medicines, then it is in a gulp of honey, a cupping operation, or branding (cauterization), but I do not like to be (cauterized) branded.


Bukhari :: Medicine :: [7.71.604]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 604

Narrated Ka'b bin Ujrah:

The Prophet came to me during the period of Al-Hudaibiya, while I was lighting fire underneath a cooking pot and lice were falling down my head. He said, "Do your lice hurt your?" I said, "Yes." He said, "Shave your head and fast for three days or feed six poor persons or slaughter a sheep as a sacrifice:"


Bukhari :: Medicine :: [7.71.605]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 605

Narrated Jabir:

The Prophet said, "If there is any healing in your medicines then it is a cupping operation, or branding (cauterization), but I do not like to be (cauterized) branded."


Bukhari :: Medicine :: [7.71.606]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 606

Narrated Ibn 'Abbas:

Allah's Apostle said, 'Nations were displayed before me; one or two prophets would pass by along with a few followers. A prophet would pass by accompanied by nobody. Then a big crowd of people passed in front of me and I asked, Who are they Are they my followers?" It was said, 'No. It is Moses and his followers It was said to me, 'Look at the horizon.'' Behold! There was a multitude of people filling the horizon. Then it was said to me, 'Look there and there about the stretching sky! Behold! There was a multitude filling the horizon,' It was said to me, 'This is your nation out of whom seventy thousand shall enter Paradise without reckoning.' "Then the Prophet entered his house without telling his companions who they (the 70,000) were. So the people started talking about the issue and said, "It is we who have believed in Allah and followed His Apostle; therefore those people are either ourselves or our children who are born m the Islamic era, for we were born in the Pre-lslamic Period of Ignorance.'' When the Prophet heard of that, he came out and said. "Those people are those who do not treat themselves with Ruqya, nor do they believe in bad or good omen (from birds etc.) nor do they get themselves branded (Cauterized). but they put their trust (only) in their Lord " On that 'Ukasha bin Muhsin said. "Am I one of them, O Allah's Apostle?' The Prophet said, "Yes." Then another person got up and said, "Am I one of them?" The Prophet said, 'Ukasha has anticipated you."


Bukhari :: Medicine :: [7.71.607]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 607

Narrated Um Salama:

The husband of a lady died and her eyes became sore and the people mentioned her story to the Prophet They asked him whether it was permissible for her to use kohl as her eyes were exposed to danger. He said, "Previously, when one of you was bereaved by a husband she would stay in her dirty clothes in a bad unhealthy house (for one year), and when a dog passed by, she would throw a globe of dung. No, (she should observe the prescribed period Idda) for four months and ten days.'


Bukhari :: Medicine :: [7.71.608]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 608

Narrated Abu Huraira:

Allah's Apostle said, '(There is) no 'Adwa (no contagious disease is conveyed without Allah's permission). nor is there any bad omen (from birds), nor is there any Hamah, nor is there any bad omen in the month of Safar, and one should run away from the leper as one runs away from a lion ''


Bukhari :: Medicine :: [7.71.609]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 609

Narrated Said bin Zaid:

I heard the Prophet saying, "Truffles are like Manna (i.e. they grow naturally without man's care) and their water heals eye diseases."


Bukhari :: Medicine :: [7.71.610]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 610

Narrated Ibn 'Abbas and 'Aisha:

Abu Bakr kissed (the forehead of) the Prophet when he was dead. 'Aisha added: We put medicine in one side of his mouth but he started waving us not to insert the medicine into his mouth. We said, "He dislikes the medicine as a patient usually does." But when he came to his senses he said, "Did I not forbid you to put medicine (by force) in the side of my mouth?" We said, "We thought it was just because a patient usually dislikes medicine." He said, "None of those who are in the house but will be forced to take medicine in the side of his mouth while I am watching, except Al-'Abbas, for he had not witnessed your deed."


Bukhari :: Medicine :: [7.71.611]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 611

Narrated Um Qais:

I went to Allah's Apostle along with a a son of mine whose palate and tonsils I had pressed with my finger as a treatment for a (throat and tonsil) disease. The Prophet said, "Why do you pain your children by pressing their throats! Use Ud Al-Hindi (certain Indian incense) for it cures seven diseases, one of which is pleurisy. It is used as a snuff for treating throat and tonsil disease and it is inserted into one side of the mouth of one suffering from pleurisy."


Bukhari :: Medicine :: [7.71.612]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 612

Narrated 'Aisha:

(the wife of the Prophet)

When the health of Allah's Apostle deteriorated and his condition became serious, he asked the permission of all his wives to allow him to be treated In my house, and they allowed him. He came out, supported by two men and his legs were dragging on the ground between Abbas and another man. (The sub-narrator told Ibn 'Abbas who said: Do you know who was the other man whom 'Aisha did not mention? The sub-narrator said: No. Ibn Abbas said: It was 'Ali.) 'Aisha added: When the Prophet entered my house and his disease became aggravated, he said, "Pour on me seven water skins full of water (the tying ribbons of which had not been untied) so that I may give some advice to the people." So we made him sit in a tub belonging to Hafsa, the wife of the Prophet and started pouring water on him from those water skins till he waved us to stop. Then he went out to the people and led them in prayer and delivered a speech before them.


Bukhari :: Medicine :: [7.71.613]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 613

Narrated Um Qais :

that she took to Allah's Apostle one of her sons whose palate and tonsils she had pressed because he had throat trouble. The Prophet said, "Why do you pain your children by getting the palate pressed like that? Use the Ud Al-Hindi (certain Indian incense) for it cures seven diseases one of which is pleurisy."


Bukhari :: Medicine :: [7.71.614]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 614

Narrated Abu Said:

A man came to the prophet and said, 'My brother has got loose motions. The Prophet said, Let him drink honey." The man again (came) and said, 'I made him drink (honey) but that made him worse.' The Prophet said, 'Allah has said the Truth, and the abdomen of your brother has told a lie." (See Hadith No. 88)


Bukhari :: Medicine :: [7.71.615]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 615

Narrated Abu Huraira:

Allah's Apostle said, 'There is no 'Adha (no disease is conveyed from the sick to the healthy without Allah's permission), nor Safar, nor Hama." A bedouin stood up and said, "Then what about my camels? They are like deer on the sand, but when a mangy camel comes and mixes with them, they all get infected with mangy." The Prophet said, "Then who conveyed the (mange) disease to the first one?"


Bukhari :: Medicine :: [7.71.616]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 616

Narrated Um Oais:

that she took to Allah's Apostle one of her sons whose palate and tonsils she had pressed to treat a throat trouble. The Prophet said, "Be afraid of Allah! Why do you pain your children by having their tonsils pressed like that? Use the Ud Al-Hindi (a certain Indian incense) for it cures seven diseases, one of which is pleurisy."


Bukhari :: Medicine :: [7.71.617]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 617

Narrated Anas bin Malik:

Allah's Apostle allowed one of the Ansar families to treat persons who have taken poison and also who are suffering from ear ailment with Ruqya. Anas added: I got myself branded cauterized) for pleurisy, when Allah's Apostle was still alive. Abu Talha, Anas bin An-Nadr and Zaid bin Thabit witnessed that, and it was Abu Talha who branded (cauterized) me.


Bukhari :: Medicine :: [7.71.618]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 618

Narrated Sahl bin Saud As-Sa'idi:

When the helmet broke on the head of the Prophet and his face became covered with blood and his incisor tooth broke (i.e. during the battle of Uhud), 'Ali used to bring water in his shield while Fatima was washing the blood off his face. When Fatima saw that the bleeding increased because of the water, she took a mat (of palm leaves), burnt it, and stuck it (the burnt ashes) on the wound of Allah's Apostle, whereupon the bleeding stopped.


Bukhari :: Medicine :: [7.71.619]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 619

Narrated Nazi':

Abdullah bin 'Umar said, "The Prophet said, 'Fever is from the heat of Hell, so put it out (cool it) with water.' " Nafi' added: 'Abdullah used to say, "O Allah! Relieve us from the punishment," (when he suffered from fever).


Bukhari :: Medicine :: [7.71.620]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 620

Narrated Fatima bint Al-Mundhir:

Whenever a lady suffering from fever was brought to Asma' bint Abu Bakr, she used to invoke Allah for her and then sprinkle some water on her body, at the chest and say, "Allah's Apostle used to order us to abate fever with water."


Bukhari :: Medicine :: [7.71.621]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 621

Narrated 'Aisha:

The Prophet said, "Fever is from the heat of Hell, so abate fever with water."


Bukhari :: Medicine :: [7.71.622]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 622

Narrated Rafi bin Khadij:

I heard Allah's Apostle saying, "Fever is from the heat of Hell, so abate fever with water."


Bukhari :: Medicine :: [7.71.623]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 623

Narrated Anas bin Malik:

Some people from the tribes of 'Ukl and 'Uraina came to Allah's Apostle and embraced Islam and said, "O Allah's Apostle! We are owners of livestock and have never been farmers," and they found the climate of Medina unsuitable for them. So Allah's Apostle ordered that they be given some camels and a shepherd, and ordered them to go out with those camels and drink their milk and urine. So they set out, but when they reached a place called Al-Harra, they reverted to disbelief after their conversion to Islam, killed the shepherd and drove away the camels. When this news reached the Prophet he sent in their pursuit (and they were caught and brought). The Prophet ordered that their eyes be branded with heated iron bars and their hands be cut off, and they were left at Al-Harra till they died in that state.


Bukhari :: Medicine :: [7.71.624]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 624

Narrated Saud:

The Prophet said, "If you hear of an outbreak of plague in a land, do not enter it; but if the plague breaks out in a place while you are in it, do not leave that place."


Bukhari :: Medicine :: [7.71.625]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 625

Narrated 'Abdullah bin 'Abbas:

'Umar bin Al-Khattab departed for Sham and when he reached Sargh, the commanders of the (Muslim) army, Abu 'Ubaida bin Al-Jarrah and his companions met him and told him that an epidemic had broken out in Sham. 'Umar said, "Call for me the early emigrants." So 'Umar called them, consulted them and informed them that an epidemic had broken out in Sham. Those people differed in their opinions. Some of them said, "We have come out for a purpose and we do not think that it is proper to give it up," while others said (to 'Umar), "You have along with you. other people and the companions of Allah's Apostle so do not advise that we take them to this epidemic." 'Umar said to them, "Leave me now." Then he said, "Call the Ansar for me." I called them and he consulted them and they followed the way of the emigrants and differed as they did. He then said to them, Leave me now," and added, "Call for me the old people of Quraish who emigrated in the year of the Conquest of Mecca." I called them and they gave a unanimous opinion saying, "We advise that you should return with the people and do not take them to that (place) of epidemic." So 'Umar made an announcement, "I will ride back to Medina in the morning, so you should do the same." Abu 'Ubaida bin Al-Jarrah said (to 'Umar), "Are you running away from what Allah had ordained?" 'Umar said, "Would that someone else had said such a thing, O Abu 'Ubaida! Yes, we are running from what Allah had ordained to what Allah has ordained. Don't you agree that if you had camels that went down a valley having two places, one green and the other dry, you would graze them on the green one only if Allah had ordained that, and you would graze them on the dry one only if Allah had ordained that?" At that time 'Abdur-Rahman bin 'Auf, who had been absent because of some job, came and said, "I have some knowledge about this. I have heard Allah's Apostle saying, 'If you hear about it (an outbreak of plague) in a land, do not go to it; but if plague breaks out in a country where you are staying, do not run away from it.' " 'Umar thanked Allah and returned to Medina.


Bukhari :: Medicine :: [7.71.626]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 626

Narrated 'Abdullah bin 'Amir

'Umar went to Sham and when h ached Sargh, he got the news that an epidemic (of plague) had broken out in Sham. 'Abdur-Rahman bin 'Auf told him that Allah's Apostle said, "If you hear that it (plague) has broken out in a land, do not go to it; but if it breaks out in a land where you are present, do not go out escaping from it."


Bukhari :: Medicine :: [7.71.627]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 627

Narrated Abu Huraira:

Allah's Apostle said, "Neither Messiah (Ad-Dajjal) nor plague will enter Medina."


Bukhari :: Medicine :: [7.71.628]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 628

Narrated Anas bin Malik:

Allah's Apostle said, "(Death from) plague is martyrdom for every Muslim."


Bukhari :: Medicine :: [7.71.629]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 629

Narrated Abu Huraira:

The Prophet said, "He (a Muslim) who dies of an abdominal disease is a a martyr, and he who dies of plague is a martyr."


Bukhari :: Medicine :: [7.71.630]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 630

Narrated 'Aisha:

(the wife of the Prophet) that she asked Allah's Apostle about plague, and Allah's Apostle informed her saying, "Plague was a punishment which Allah used to send on whom He wished, but Allah made it a blessing for the believers. None (among the believers) remains patient in a land in which plague has broken out and considers that nothing will befall him except what Allah has ordained for him, but that Allah will grant him a reward similar to that of a martyr."


Bukhari :: Medicine :: [7.71.631]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 631

Narrated 'Aisha:

During the Prophet's fatal illness, he used to recite the Mu'auwidhat (Surat An-Nas and Surat Al-Falaq) and then blow his breath over his body. When his illness was aggravated, I used to recite those two Suras and blow my breath over him and make him rub his body with his own hand for its blessings." (Ma'mar asked Az-Zuhri: How did the Prophet use to blow? Az-Zuhri said: He used to blow on his hands and then passed them over his face.)


Bukhari :: Medicine :: [7.71.632]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 632

Narrated Abu Said Al-Khudri:

Some of the companions of the Prophet came across a tribe amongst the tribes of the Arabs, and that tribe did not entertain them. While they were in that state, the chief of that tribe was bitten by a snake (or stung by a scorpion). They said, (to the companions of the Prophet ), "Have you got any medicine with you or anybody who can treat with Ruqya?" The Prophet's companions said, "You refuse to entertain us, so we will not treat (your chief) unless you pay us for it." So they agreed to pay them a flock of sheep. One of them (the Prophet's companions) started reciting Surat-al-Fatiha and gathering his saliva and spitting it (at the snake-bite). The patient got cured and his people presented the sheep to them, but they said, "We will not take it unless we ask the Prophet (whether it is lawful)." When they asked him, he smiled and said, "How do you know that Surat-al-Fatiha is a Ruqya? Take it (flock of sheep) and assign a share for me."


Bukhari :: Medicine :: [7.71.633]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 633

Narrated Ibn 'Abbas:

Some of the companions of the Prophet passed by some people staying at a place where there was water, and one of those people had been stung by a scorpion. A man from those staying near the water, came and said to the companions of the Prophet, "Is there anyone among you who can do Ruqya as near the water there is a person who has been stung by a scorpion." So one of the Prophet's companions went to him and recited Surat-al-Fatiha for a sheep as his fees. The patient got cured and the man brought the sheep to his companions who disliked that and said, "You have taken wages for reciting Allah's Book." When they arrived at Medina, they said, ' O Allah's Apostle! (This person) has taken wages for reciting Allah's Book" On that Allah's Apostle said, "You are most entitled to take wages for doing a Ruqya with Allah's Book."


Bukhari :: Medicine :: [7.71.634]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 634

Narrated 'Aisha:

The Prophet ordered me or somebody else to do Ruqya (if there was danger) from an evil eye.


Bukhari :: Medicine :: [7.71.635]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 635

Narrated Um Salama:

that the Prophet saw in her house a girl whose face had a black spot. He said. "She is under the effect of an evil eye; so treat her with a Ruqya."


Bukhari :: Medicine :: [7.71.636]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 636

Narrated Abu Huraira:

The Prophet said, "The effect of an evil eye is a fact." And he prohibited tattooing


Bukhari :: Medicine :: [7.71.637]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 637

Narrated Al-Aswad:

I asked 'Aisha about treating poisonous stings (a snake-bite or a scorpion sting) with a Ruqya. She said, "The Prophet allowed the treatment of poisonous sting with Ruqya."


Bukhari :: Medicine :: [7.71.638]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 638

Narrated 'Abdul 'Aziz:

Thabit and I went to Anas bin Malik. Thabit said, "O Abu Hamza! I am sick." On that Anas said, "Shall I treat you with the Ruqya of Allah's Apostle?" Thabit said, "Yes," Anas recited, "O Allah! The Lord of the people, the Remover of trouble! (Please) cure (Heal) (this patient), for You are the Healer. None brings about healing but You; a healing that will leave behind no ailment."


Bukhari :: Medicine :: [7.71.639]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 639

Narrated 'Aisha:

The Prophet used to treat some of his wives by passing his right hand over the place of ailment and used to say, "O Allah, the Lord of the people! Remove the trouble and heal the patient, for You are the Healer. No healing is of any avail but Yours; healing that will leave behind no ailment."


Bukhari :: Medicine :: [7.71.640]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 640

Narrated 'Aisha:

Allah's Apostle used to treat with a Ruqya saying, "O the Lord of the people! Remove the trouble The cure is in Your Hands, and there is none except You who can remove it (the disease) . "


Bukhari :: Medicine :: [7.71.641]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 641

Narrated 'Aisha:

The Prophet used to say to the patient, "In the Name of Allah The earth of our land and the saliva of some of us cure our patient."


Bukhari :: Medicine :: [7.71.642]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 642

Narrated 'Aisha:

Allah's Apostle used to read in his Ruqya, "In the Name of Allah" The earth of our land and the saliva of some of us cure our patient with the permission of our Lord." with a slight shower of saliva) while treating with a Ruqya.


Bukhari :: Medicine :: [7.71.643]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 643

Narrated Abu Qatada:

I heard the Prophet saying, "A good dream is from Allah, and a bad dream is from Satan. So if anyone of you sees (in a dream) something he dislikes, when he gets up he should blow thrice (on his left side) and seek refuge with Allah from its evil for then it will not harm him."


Bukhari :: Medicine :: [7.71.644]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 644

Narrated 'Aisha:

Whenever Allah's Apostle went to bed, he used to recite Surat-al-Ikhlas, Surat-al-Falaq and Surat-an-Nas and then blow on his palms and pass them over his face and those parts of his body that his hands could reach. And when he fell ill, he used to order me to do like that for him.


Bukhari :: Medicine :: [7.71.645]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 645

Narrated Abu Said:

A group of the companions of Allah's Apostle proceeded on a journey till they dismounted near one of the Arab tribes and requested them to entertain them as their guests, but they (the tribe people) refused to entertain them. Then the chief of that tribe was bitten by a snake (or stung by a scorpion) and he was given all sorts of treatment, but all in vain. Some of them said, "Will you go to the group (those travelers) who have dismounted near you and see if one of them has something useful?" They came to them and said, "O the group! Our leader has been bitten by a snake (or stung by a scorpion) and we have treated him with everything but nothing benefited him Has anyone of you anything useful?" One of them replied, "Yes, by Allah, I know how to treat with a Ruqya. But. by Allah, we wanted you to receive us as your guests but you refused. I will not treat your patient with a Ruqya till you fix for us something as wages." Consequently they agreed to give those travellers a flock of sheep. The man went with them (the people of the tribe) and started spitting (on the bite) and reciting Surat-al-Fatiha till the patient was healed and started walking as if he had not been sick. When the tribe people paid them their wages they had agreed upon, some of them (the Prophet's companions) said, "Distribute (the sheep)." But the one who treated with the Ruqya said, "Do not do that till we go to Allah's Apostle and mention to him what has happened, and see what he will order us." So they came to Allah's Apostle and mentioned the story to him and he said, "How do you know that Surat-al-Fatiha is a Ruqya? You have done the right thing. Divide (what you have got) and assign for me a share with you."


Bukhari :: Medicine :: [7.71.646]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 646

Narrated 'Aisha:

The Prophet used to treat some of his wives by passing his right hand over the place of ailment and used to say, "O Lord of the people! Remove the difficulty and bring about healing as You are the Healer. There is no healing but Your Healing, a healing that will leave no ailment."


Bukhari :: Medicine :: [7.71.647]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 647

Narrated 'Aisha:

The Prophet, during his fatal ailment used to blow (on his hands and pass them) over his body while reciting the Mu'auwidhat (Surat-an-Nas and Surat-al-Falaq). When his disease got aggravated, I used to recite them for him and blow (on his hands) and let him pass his hands over his body because of its blessing. (Ma'mar asked Ibn Shihab: How did he use to do Nafth? He said: He used to blow on his hands and then pass them over his face.)


Bukhari :: Medicine :: [7.71.648]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 648

Narrated Ibn 'Abbas:

The Prophet once came out to us and said, "Some nations were displayed before me. A prophet would pass in front of me with one man, and another with two men, and another with a group of people. and another with nobody with him. Then I saw a great crowd covering the horizon and I wished that they were my followers, but it was said to me, 'This is Moses and his followers.' Then it was said to me, 'Look'' I looked and saw a big gathering with a large number of people covering the horizon. It was said, "Look this way and that way.' So I saw a big crowd covering the horizon. Then it was said to me, "These are your followers, and among them there are 70,000 who will enter Paradise without (being asked about their) accounts. " Then the people dispersed and the Prophet did not tell who those 70,000 were. So the companions of the Prophet started talking about that and some of them said, "As regards us, we were born in the era of heathenism, but then we believed in Allah and His Apostle . We think however, that these (70,000) are our offspring." That talk reached the Prophet who said, "These (70,000) are the people who do not draw an evil omen from (birds) and do not get treated by branding themselves and do not treat with Ruqya, but put their trust (only) in their Lord." then 'Ukasha bin Muhsin got up and said, "O Allah's Apostle! Am I one of those (70,000)?" The Prophet said, "Yes." Then another person got up and said, "Am I one of them?" The Prophet said, " 'Ukasha has anticipated you."


Bukhari :: Medicine :: [7.71.649]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 649

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "There is neither 'Adha (no contagious disease is conveyed to others without Allah's permission) nor Tiyara, but an evil omen may be in three a woman, a house or an animal."


Bukhari :: Medicine :: [7.71.650]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 650

Narrated Abu Huraira:

I heard Allah's Apostle saying, "There is no Tiyara, and the best omen is the Fal." They asked, "What is the Fal?" He said, "A good word that one of you hears (and takes as a good omen)."


Bukhari :: Medicine :: [7.71.651]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 651

Narrated Abu Huraira:

The Prophet said, "There is no Tiyara and the best omen is the Fal," Somebody said, "What is the Fal, O Allah's Apostle?" He said, "A good word that one of you hears (and takes as a good omen)."


Bukhari :: Medicine :: [7.71.652]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 652

Narrated Anas:

The Prophet said, "No 'Adha (no contagious disease is conveyed to others without Allah's permission), nor Tiyara, but I like the good Fal, i.e., the good word."


Bukhari :: Medicine :: [7.71.653]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 653

Narrated Abu Huraira:

The Prophet said, "There is no 'Adha, nor Tiyara, nor Hama, nor Safar."


Bukhari :: Medicine :: [7.71.654]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 654

Narrated Abu Huraira :

Allah's Apostle gave his verdict about two ladies of the Hudhail tribe who had fought each other and one of them had hit the other with a stone. The stone hit her abdomen and as she was pregnant, the blow killed the child in her womb. They both filed their case with the Prophet and he judged that the blood money for what was in her womb. was a slave or a female slave. The guardian of the lady who was fined said, "O Allah's Apostle! Shall I be fined for a creature that has neither drunk nor eaten, neither spoke nor cried? A case like that should be nullified." On that the Prophet said, "This is one of the brothers of soothsayers.


Bukhari :: Medicine :: [7.71.655]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 655

Narrated Abu Huraira:

Two ladies (had a fight) and one of them hit the other with a stone on the abdomen and caused her to abort. The Prophet judged that the victim be given either a slave or a female slave (as blood-money). Narrated Ibn Shihab: Said bin Al-Musayyab said, "Allah's Apostle judged that in case of child killed in the womb of its mother, the offender should give the mother a slave or a female slave in recompense The offender said, How can I be fined for killing one who neither ate nor drank, neither spoke nor cried: a case like that should be denied ' On that Allah's Apostle said 'He is one of the brothers of the foretellers


Bukhari :: Medicine :: [7.71.656]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 656

Narrated Abu Mas'ud:

The Prophet forbade the utilization of the price of a dog, the earnings of prostitute and the earnings of a foreteller


Bukhari :: Medicine :: [7.71.657]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 657

Narrated 'Aisha:

Some people asked Allah's Apostle about the fore-tellers He said. ' They are nothing" They said, 'O Allah's Apostle! Sometimes they tell us of a thing which turns out to be true." Allah's Apostle said, "A Jinn snatches that true word and pours it Into the ear of his friend (the fore-teller) (as one puts something into a bottle) The foreteller then mixes with that word one hundred lies."


Bukhari :: Medicine :: [7.71.658]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 658

Narrated 'Aisha:

A man called Labid bin al-A'sam from the tribe of Bani Zaraiq worked magic on Allah's Apostle till Allah's Apostle started imagining that he had done a thing that he had not really done. One day or one night he was with us, he invoked Allah and invoked for a long period, and then said, "O 'Aisha! Do you know that Allah has instructed me concerning the matter I have asked him about? Two men came to me and one of them sat near my head and the other near my feet. One of them said to his companion, "What is the disease of this man?" The other replied, "He is under the effect of magic.' The first one asked, 'Who has worked the magic on him?' The other replied, "Labid bin Al-A'sam.' The first one asked, 'What material did he use?' The other replied, 'A comb and the hairs stuck to it and the skin of pollen of a male date palm.' The first one asked, 'Where is that?' The other replied, '(That is) in the well of Dharwan;' " So Allah's Apostle along with some of his companions went there and came back saying, "O 'Aisha, the color of its water is like the infusion of Henna leaves. The tops of the date-palm trees near it are like the heads of the devils." I asked. "O Allah's Apostle? Why did you not show it (to the people)?" He said, "Since Allah cured me, I disliked to let evil spread among the people." Then he ordered that the well be filled up with earth.


Bukhari :: Medicine :: [7.71.659]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 659

Narrated Abu Huraira:

Allah's Apostle said, "Avoid the Mubiqat, i.e., shirk and witchcraft."


Bukhari :: Medicine :: [7.71.660]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 660

Narrated Aisha:

Magic was worked on Allah's Apostle so that he used to think that he had sexual relations with his wives while he actually had not (Sufyan said: That is the hardest kind of magic as it has such an effect). Then one day he said, "O 'Aisha do you know that Allah has instructed me concerning the matter I asked Him about? Two men came to me and one of them sat near my head and the other sat near my feet. The one near my head asked the other. What is wrong with this man?' The latter replied the is under the effect of magic The first one asked, Who has worked magic on him?' The other replied Labid bin Al-A'sam, a man from Bani Zuraiq who was an ally of the Jews and was a hypocrite.' The first one asked, What material did he use)?' The other replied, 'A comb and the hair stuck to it.' The first one asked, 'Where (is that)?' The other replied. 'In a skin of pollen of a male date palm tree kept under a stone in the well of Dharwan' '' So the Prophet went to that well and took out those things and said "That was the well which was shown to me (in a dream) Its water looked like the infusion of Henna leaves and its date-palm trees looked like the heads of devils." The Prophet added, "Then that thing was taken out' I said (to the Prophet ) "Why do you not treat yourself with Nashra?" He said, "Allah has cured me; I dislike to let evil spread among my people."


Bukhari :: Medicine :: [7.71.661]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 661

Narrated 'Aisha:

Magic was worked on Allah's Apostle so that he began to imagine that he had done something although he had not. One day while he was with me, he invoked Allah and invoked for a long period and then said, "O 'Aisha! Do you know that Allah has instructed me regarding the matter I asked Him about?" I asked, "What is that, O Allah's Apostle?" He said, "Two men came to me; one of them sat near my head and the other sat near my feet. One of them asked his companion, 'What is the disease of this man?' The other replied, 'He is under the effect of magic.' The first one asked, 'Who has worked magic on him?" The other replied, 'Labid bin A'sam, a Jew from the tribe of Bani Zuraiq.' The (first one asked), 'With what has it been done?' The other replied, 'With a a comb and the hair stuck to it and a skin of the pollen of a male datepalm tree.' The first one asked, 'Where is it?' The other replied, 'In the well of Dharwan.' Then the Prophet went along with some of his companions to that well and looked at that and there were date palms near to it. Then he returned to me and said, 'By Allah the water of that well was (red) like the infusion of Henna leaves and its date-palms were like the heads of devils" I said, O Allah's Apostle! Did you take those materials out of the pollen skin?" He said, 'No! As for me Allah has healed me and cured me and I was afraid that (by Showing that to the people) I would spread evil among them when he ordered that the well be filled up with earth, and it was filled up with earth "


Bukhari :: Medicine :: [7.71.662]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 662

Narrated Abdullah bin Umar:

Two men came from the East and addressed the people who wondered at their eloquent speeches On that Allah's Apostle said. Some eloquent speech is as effective as magic.'


Bukhari :: Medicine :: [7.71.663]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 663

Narrated Saud:

The Prophet said, "If somebody takes some 'Ajwa dates every morning, he will not be effected by poison or magic on that day till night." (Another narrator said seven dates).


Bukhari :: Medicine :: [7.71.664]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 664

Narrated Saud:

I heard Allah's Apostle saying, "If Somebody takes seven 'Ajwa dates in the morning, neither magic nor poison will hurt him that day."


Bukhari :: Medicine :: [7.71.665]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 665

Narrated Abu Huraira:

Allah's Apostle said: The cattle (sheep, cows, camels, etc.) suffering from a disease should not be mixed up with healthy cattle, (or said: "Do not put a patient with a healthy person ). " (as a precaution).


Bukhari :: Medicine :: [7.71.666]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 666

Narrated 'Abdullah bin Umar:

Allah's Apostle said, "there is neither 'Adha nor Tiyara, and an evil omen is only in three: a horse, a woman and a house." (See the foot-note of Hadith No. 649)


Bukhari :: Medicine :: [7.71.667]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 667

Narrated Abu Huraira:

Allah's Apostle said, "No 'Adha." Abu Huraira also said: The Prophet said, "The cattle suffering from a disease should not be mixed up with healthy cattle (or said "Do not put a patient with a healthy person as a precaution.") Abu Huraira also said: Allah's Apostle said, "No 'Adha." A bedouin got up and said, "Don't you see how camels on the sand look like deer but when a mangy camel mixes with them, they all get infected with mange?" On that the Prophet said, "Then who conveyed the (mange) disease to the first camel?"


Bukhari :: Medicine :: [7.71.668]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 668

Narrated Anas bin Malik:

The Prophet said, "No 'Adha nor Tiyara; but I like Fal." They said, "What is the Fal?" He said, "A good word."


Bukhari :: Medicine :: [7.71.669]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 669

Narrated Abu Huraira:

When Khaibar was conquered, Allah's Apostle was presented with a poisoned (roasted) sheep. Allah's Apostle said, "Collect for me all the Jews present in this area." (When they were gathered) Allah's Apostle said to them, "I am going to ask you about something; will you tell me the truth?" They replied, "Yes, O Abal-Qasim!" Allah's Apostle said to them, "Who is your father?" They said, "Our father is so-and-so." Allah's Apostle said, "You have told a lie. for your father is so-and-so," They said, "No doubt, you have said the truth and done the correct thing." He again said to them, "If I ask you about something; will you tell me the truth?" They replied, "Yes, O Abal-Qasim! And if we should tell a lie you will know it as you have known it regarding our father," Allah's Apostle then asked, "Who are the people of the (Hell) Fire?" They replied, "We will remain in the (Hell) Fire for a while and then you (Muslims) will replace us in it" Allah's Apostle said to them. ''You will abide in it with ignominy. By Allah, we shall never replace you in it at all." Then he asked them again, "If I ask you something, will you tell me the truth?" They replied, "Yes." He asked. "Have you put the poison in this roasted sheep?" They replied, "Yes," He asked, "What made you do that?" They replied, "We intended to learn if you were a liar in which case we would be relieved from you, and if you were a prophet then it would not harm you."


Bukhari :: Medicine :: [7.71.670]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 670

Narrated Abu Huraira:

The Prophet said, "Whoever purposely throws himself from a mountain and kills himself, will be in the (Hell) Fire falling down into it and abiding therein perpetually forever; and whoever drinks poison and kills himself with it, he will be carrying his poison in his hand and drinking it in the (Hell) Fire wherein he will abide eternally forever; and whoever kills himself with an iron weapon, will be carrying that weapon in his hand and stabbing his abdomen with it in the (Hell) Fire wherein he will abide eternally forever."


Bukhari :: Medicine :: [7.71.671]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 671

Narrated Sad:

I heard Allah's Apostle saying, "Whoever takes seven 'Ajwa dates in the morning will not be effected by magic or poison on that day."


Bukhari :: Medicine :: [7.71.672]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 672

Narrated Abu Tha'laba Al-Khushani:

The Prophet forbade the eating of wild animals having fangs. (Az-Zuhri said: I did not hear this narration except when I went to Sham.) Al-Laith said: Narrated Yunus: I asked Ibn Shihab, "May we perform the ablution with the milk of she-asses or drink it, or drink the bile of wild animals or urine of camels?" He replied, "The Muslims used to treat themselves with that and did not see any harm in it. As for the milk of she-asses, we have learnt that Allah's Apostle forbade the eating of their meat, but we have not received any information whether drinking of their milk is allowed or forbidden." As for the bile of wild animals, Ibn Shihab said, "Abu Idris Al-Khaulani told me that Allah's Apostle forbade the eating of the flesh of every wild beast having fangs . "


Bukhari :: Medicine :: [7.71.673]

Medicine

Bukhari :: Book 7 :: Volume 71 :: Hadith 673

Narrated Abu Huraira:

Allah's Apostle said, "If a fly falls in the vessel of any of you, let him dip all of it (into the vessel) and then throw it away, for in one of its wings there is a disease and in the other there is healing (antidote for it) i e. the treatment for that disease."


Bukhari :: Dress :: [7.72.674]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 674

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, 'Allah will not look at the person who drags his garment (behind him) out of conceit.''


Bukhari :: Dress :: [7.72.675]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 675

Narrated 'Abdullah bin 'Umar:

The Prophet said Allah will not look, on the Day of Resurrection at the person who drags his garment (behind him) out of conceit. On that Abu Bakr said, "O Allah's Apostle! One side of my Izar hangs low if I do not take care of it." The Prophet said, 'You are not one of those who do that out of conceit."


Bukhari :: Dress :: [7.72.676]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 676

Narrated Abu Bakra:

The solar eclipse occurred while we were sitting with the Prophet He got up dragging his garment (on the ground) hurriedly till he reached the mosque The people turned (to the mosque) and he offered a two-Rak'at prayer whereupon the eclipse was over and he traced us and said, "The sun and the moon are two signs among the signs of Allah, so if you see a thing like this (eclipse) then offer the prayer and invoke Allah till He remove that state,"


Bukhari :: Dress :: [7.72.677]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 677

Narrated Abu Juhaifa:

I saw Bilal bringing an 'Anza (a small spear) and fixing it in the ground, and then he proclaimed the Iqarna of the prayer, and I saw Allah's Apostle coming out, wearing a cloak with its sleeves rolled up. He then offered a two-Rak'at prayer while facing the 'Anza, and I saw the people and animals passing in front of him beyond the 'Anza.


Bukhari :: Dress :: [7.72.678]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 678

Narrated Abu Huraira:

The Prophet said, "The part of an Izar which hangs below the ankles is in the Fire."


Bukhari :: Dress :: [7.72.679]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 679

Narrated Abu Huraira:

Allah's Apostle, "Allah will not look, on the Day of Resurrection, at a person who drags his Izar (behind him) out of pride and arrogance


Bukhari :: Dress :: [7.72.680]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 680

Narrated Abu Huraira:

The Prophet (or 'Abul Qasim) said, "While a man was walking, clad in a two-piece garment and proud of himself with his hair well-combed, suddenly Allah made him sink into the earth and he will go on sinking into it till the Day of Resurrection.


Bukhari :: Dress :: [7.72.681]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 681

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "While a man was dragging his Izar on the ground (behind him), suddenly Allah made him sink into the earth and he will go on sinking into it till the Day of Resurrection."


Bukhari :: Dress :: [7.72.682]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 682

Narrated Abu Huraira:

that he heard the Prophet (narrating as above No. 680).


Bukhari :: Dress :: [7.72.683]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 683

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Whoever drags his clothes (on the ground) out of pride and arrogance, Allah will not look at him on the Day of Resurrection."


Bukhari :: Dress :: [7.72.684]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 684

Narrated 'Aisha:

(the wife of the Prophet)

The wife of Rifa'a Al-Qurazi came to Allah's Apostle while I was sitting, and Abu Bakr was also there. She said, 'O Allah s Apostle! I was the wife of Rifa'a and he divorced me irrevocably. Then I married AbdurRahman bin Az-Zubair who, by Allah, O Allah's Apostle, has only something like a fringe of a garment, Showing the fringe of her veil. Khalid bin Sa'id, who was standing at the door, for he had not been admitted, heard her statement and said, "O Abu Bakr! Why do you not stop this lady from saying such things openly before Allah's Apostle?" No, by Allah, Allah's Apostle did nothing but smiled. Then he said to the lady, "Perhaps you want to return to Rifa'a? That is impossible unless 'Abdur-Rahman consummates his marriage with you." That became the tradition after him.


Bukhari :: Dress :: [7.72.685]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 685

Narrated 'Ali:

The Prophet asked for his Rida, put it on and set out walking. Zaid bin Haritha and I followed him till he reached the house where Harnza (bin 'Abdul Muttalib) was present and asked for permission to enter, and they gave us permission.


Bukhari :: Dress :: [7.72.686]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 686

Narrated Ibn 'Umar:

A man asked, "O Allah s Apostle What kind of clothes should a Muhrim wear?" The Prophet, said, "A Muhrim should not wear a shirt, trousers a hooded cloak, or Khuffs (leather socks covering the ankles) unless he cannot get sandals, in which case he should cut the part (of the Khuff) that covers the ankles."


Bukhari :: Dress :: [7.72.687]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 687

Narrated Jabir bin Abdullah:

The Prophet came to visit Abdullah bin Ubai (bin Salul) after he had been put in his grave. The Prophet ordered that 'Abdullah be taken out. He was taken out and was placed on the knees on the knees of the Prophet, who blew his (blessed) breath on him and dressed the body with his own shirt. And Allah knows better.


Bukhari :: Dress :: [7.72.688]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 688

Narrated Abdullah bin 'Umar:

When Abdullah bin Ubdi (bin Salul) died, his son came to Allah's Apostle and said ' O Allah's Apostle, give me your shirt so that I may shroud my fathers body in it. And please offer a funeral prayer for him and invoke Allah for his forgiveness." The Prophet gave him his shirt and said to him 'Inform us when you finish (and the funeral procession is ready) call us. When he had finished he told the Prophet and the Prophet proceeded to order his funeral prayers but Umar stopped him and said, "Didn't Allah forbid you to offer the funeral prayer for the hypocrites when He said: "Whether you (O Muhammad) ask forgiveness for them or ask not forgiveness for them: (and even) if you ask forgiveness for them seventy times. Allah will not forgive them." (9.80) Then there was revealed: "And never (O Muhammad) pray for any of them that dies, nor stand at his grave." (9.34) Thenceforth the Prophet did not offer funeral prayers for the hypocrites.


Bukhari :: Dress :: [7.72.689]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 689

Narrated Abu Huraira:

Allah's Apostle has set forth an example for a miser and a charitable person by comparing them to two men wearing two iron cloaks and their hands are raised to their breasts and necks. Whenever the charitable man tries to give a charitable gift, his iron cloak expands till it becomes so wide that it will cover his fingertips and obliterate his tracks And, whenever the miser wants to give a charitable gift, his cloak becomes very tight over him and every ring gets stuck to its place Abu Huraira added; I saw Allah's Apostle putting his finger in the (chest) pocket of his shirt like that If you but saw him trying to widen (the opening of his shirt) but it did not widen


Bukhari :: Dress :: [7.72.690]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 690

Narrated Al-Mughira bin Shu'ba:

The Prophet went to answer the call of nature, and when he returned, I met him with water and he performed the ablution while he was wearing a Sham, cloak. He rinsed his mouth, put the water in his nose and blew it out, washed his face and tried to take his hands out of his sleeves, but they were too narrow, so he took out his hands from under his chest and washed them and then passed his wet hands over his head and Khuffs (leather socks) .


Bukhari :: Dress :: [7.72.691]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 691

Narrated Al-Mughira:

One night I was with the Prophet on a journey. He asked (me), "Have you got water with you?" I replied, "Yes" So he got down from his she-camel and went away till he disappeared in the darkness of the night. Then he came back and I poured water for him from the pot (for the ablution). He washed his face and hands while he was wearing a woollen cloak (the sleeves of which were narrow), so he could not take his arms out of it. So he took them out from underneath the cloak. Then he washed his forearms and passed his wet hands over his head. Then I tried to take off his Khuffs, but he said, "Leave them, for I have performed ablution before putting them on." And so he passed his wet hands over them


Bukhari :: Dress :: [7.72.692]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 692

Narrated Al-Miswar bin Makhrama:

Allah's Apostle distributed some Qaba's but he did not give anything to Makhrama. Makhrama said (to me), "O my son! Let us go to Allah's Apostle." So I proceeded with him and he said, "Go in and call him 'or me." So I called the Prophet for him The Prophet came out to him, wearing one of those Qaba's and said, (to Makhrama), "I have kept this for you " Makhrama looked at it and said, "Makhrama is satisfied now"


Bukhari :: Dress :: [7.72.693]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 693

Narrated 'Uqba bin 'Amir:

A silken Farruj was presented to Allah's Apostle and he put it on and offered the prayer in it. When he finished the prayer, he took it off violently as if he disliked it and said, "This (garment) does not befit those who fear Allah!"


Bukhari :: Dress :: [7.72.694]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 694

Narrated Abdullah bin Umar:

A man said, "O Allah's Apostle. What type of clothes should a Muhrim wear Allah's Apostle replied, 'Do not wear shirts, turbans trousers hooded cloaks or Khuffs; but if someone cannot get sandals, then he can wear Khuffs after cutting them short below the ankles. Do not wear clothes touched by saffon or wars (two kinds of perfumes) "


Bukhari :: Dress :: [7.72.695]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 695

Narrated Ibn 'Abbas:

The Prophet said, "Whoever cannot get an Izar, can wear trousers, and whoever cannot wear sandals can wear Khuffs."


Bukhari :: Dress :: [7.72.696]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 696

Narrated Abdullah:

A man got up and said, O Allah's Apostle! What do you order us to wear when we assume the state of Ihram?" The Prophet replied, "Do not wear shirts, trousers, turbans, hooded cloaks or Khuffs, but if a man has no sandals, he can wear Khuffs after cutting them short below the ankles; and do not wear clothes touched with (perfumes) of saffron or wars."


Bukhari :: Dress :: [7.72.697]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 697

Narrated 'Abdullah bin 'Umar:

The Prophet said, "A Muhrim should not wear a shirt, a turban, trousers, hooded cloaks, a garment touched with (perfumes) of saffron or wars, or Khuffs except if one has no sandals in which case he should cut short the Khuffs below the ankles."


Bukhari :: Dress :: [7.72.698]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 698

Narrated 'Aisha:

Some Muslim men emigrated to Ethiopia whereupon Abu Bakr also prepared himself for the emigration, but the Prophet said (to him), "Wait, for I hope that Allah will allow me also to emigrate." Abu Bakr said, "Let my father and mother be sacrificed for you. Do you hope that (emigration)?" The Prophet said, 'Yes." So Abu Bakr waited to accompany the Prophet and fed two she-camels he had on the leaves of As-Samur tree regularly for four months One day while we were sitting in our house at midday, someone said to Abu Bakr, "Here is Allah's Apostle, coming with his head and a part of his face covered with a cloth-covering at an hour he never used to come to us." Abu Bakr said, "Let my father and mother be sacrificed for you, (O Prophet)! An urgent matter must have brought you here at this hour." The Prophet came and asked the permission to enter, and he was allowed. The Prophet entered and said to Abu Bakr, "Let those who are with you, go out." Abu Bakr replied, "(There is no stranger); they are your family. Let my father be sacrificed for you, O Allah's Apostle!" The Prophet said, "I have been allowed to leave (Mecca)." Abu Bakr said, " I shall accompany you, O Allah's Apostles, Let my father be sacrificed for you!" The Prophet said, "Yes," Abu Bakr said, 'O Allah's Apostles! Let my father be sacrificed for you. Take one of these two she-camels of mine" The Prophet said. I will take it only after paying its price." So we prepared their baggage and put their journey food In a leather bag. And Asma' bint Abu Bakr cut a piece of her girdle and tied the mouth of the leather bag with it. That is why she was called Dhat-an-Nitaqaln. Then the Prophet and Abu Bakr went to a cave in a mountain called Thour and remained there for three nights. 'Abdullah bin Abu Bakr. who was a young intelligent man. used to stay with them at night and leave before dawn so that in the morning, he would he with the Quraish at Mecca as if he had spent the night among them. If he heard of any plot contrived by the Quraish against the Prophet and Abu Bakr, he would understand it and (return to) inform them of it when it became dark. 'Amir bin Fuhaira, the freed slave of Abu Bakr used to graze a flock of milch sheep for them and he used to take those sheep to them when an hour had passed after the 'Isha prayer. They would sleep soundly till 'Amir bin Fuhaira awakened them when it was still dark. He used to do that in each of those three nights.


Bukhari :: Dress :: [7.72.699]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 699

Narrated Anas bin Malik:

In the year of the conquest of Mecca the Prophet entered Mecca, wearing a helmet on his head.


Bukhari :: Dress :: [7.72.700]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 700

Narrated Anas bin Malik:

Once I was walking with Allah's Apostle and he was wearing a Najram Burd with thick margin. A bedouin followed him and pulled his Burd so violently that I noticed the side of the shoulder of Allah's Apostle affected by the margin of the Burd because of that violent pull. The Bedouin said, "O Muhammad! Give me some of Allah's wealth which is with you." Allah's Apostle turned and looked at him, and smiling, 'he ordered that he be given something.


Bukhari :: Dress :: [7.72.701]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 701

Narrated Abu Hazim:

Shahl bin Sad said, "A lady came with a Burda. Sahl then asked (the people), "Do you know what Burda is?" Somebody said, "Yes. it is a Shamla with a woven border." Sahl added, "The lady said, 'O Allah's Apostle! I have knitted this (Burda) with my own hands for you to wear it." Allah's Apostle took it and he was in need of it. Allah's Apostle came out to us and he was wearing it as an Izar. A man from the people felt it and said, 'O Allah's Apostle! Give it to me to wear.' The Prophet s said, 'Yes.' Then he sat there for some time (and when he went to his house), he folded it and sent it to him. The people said to that man, 'You have not done a right thing. You asked him for it, though you know that he does not put down anybody's request.' The man said, 'By Allah! I have only asked him so that it may be my shroud when I die." Sahl added, "Late it was his shroud."


Bukhari :: Dress :: [7.72.702]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 702

Narrated Abu Huraira:

I heard Allah's Apostle saying "From among my followers, a group (o 70,000) will enter Paradise without being asked for their accounts, Their faces will be shining like the moon." 'Ukasha bin Muhsin Al-Asadi got up, lifting his covering sheet and said, "O Allah's Apostle Invoke Allah for me that He may include me with them." The Prophet said! "O Allah! Make him from them." Then another man from Al-Ansar got up and said, "O Allah's Apostle! Invoke Allah for me that He may include me with them." On that Allah's Apostle said, "'Ukasha has anticipated you."


Bukhari :: Dress :: [7.72.703]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 703

Narrated Qatada:

I asked Anas, "What kind of clothes was most beloved to the Prophet?" He replied, "The Hibra (a kind of Yemenese cloth)."


Bukhari :: Dress :: [7.72.704]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 704

Narrated Anas bin Malik:

The most beloved garment to the Prophet to wear was the Hibra (a kind of Yemenese cloth).


Bukhari :: Dress :: [7.72.705]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 705

Narrated 'Aisha:

(the wife of the Prophet) When Allah's Apostle died, he was covered with a Hibra Burd (green square decorated garment).


Bukhari :: Dress :: [7.72.706]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 706

Narrated 'Aisha and 'Abdullah bin 'Abbas:

When the disease of Allah's Apostle got aggravated, he covered his face with a Khamisa, but when he became short of breath, he would remove it from his face and say, "It is like that! May Allah curse the Jews Christians because they took the graves of their prophets as places of worship." By that he warned his follower of imitating them, by doing that which they did.


Bukhari :: Dress :: [7.72.707]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 707

Narrated Abu Burda:

Aisha brought out to us a Kisa and an Izar and said, "The Prophet died while wearing these two." (Kisa, a square black piece of woolen cloth. Izar, a sheet cloth garment covering the lower half of the body).


Bukhari :: Dress :: [7.72.708]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 708

Narrated Aisha:

Allah's Apostle offered prayer while he was wearing a Khamisa of his that had printed marks. He looked at its marks and when he finished prayer, he said, "Take this Khamisa of mine to Abu Jahm, for it has just now diverted my attention from my prayer, and bring to me the Anbijania (a plain thick sheet) of Abu Jahm bin Hudhaifa bin Ghanim who belonged to Bani Adi bin Ka'b."


Bukhari :: Dress :: [7.72.709]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 709

Narrated Abu Huraira:

The Prophet had forbidden: (A) the Mulamasa and Munabadha (bargains), (B) the offering of two prayers, one after the morning compulsory prayer till the sun rises, and the others, after the 'Asr prayer till the sun sets (C) He also forbade that one should sit wearing one garment, nothing of which covers his private parts (D) and prevent them from exposure to the sky; (E) he also forbade Ishtimal-as-Samma'.


Bukhari :: Dress :: [7.72.710]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 710

Narrated Abu Sa'id Al-Khudri

Allah's Apostle forbade two ways of wearing clothes and two kinds of dealings. (A) He forbade the dealings of the Mulamasa and the Munabadha. In the Mulamasa transaction the buyer just touches the garment he wants to buy at night or by daytime, and that touch would oblige him to buy it. In the Munabadha, one man throws his garment at another and the latter throws his at the former and the barter is complete and valid without examining the two objects or being satisfied with them (B) The two ways of wearing clothes were Ishtimal-as-Samma, i e., to cover one's shoulder with one's garment and leave the other bare: and the other way was to wrap oneself with a garment while one was sitting In such a way that nothing of that garment would cover one's private part


Bukhari :: Dress :: [7.72.711]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 711

Narrated Abu Huraira:

Allah's Apostle forbade two types of dresses: (A) To sit in an Ihtiba' posture in one garment nothing of which covers his private parts. (B) to cover one side of his body with one garment and leave the other side bare The Prophet also forbade the Mulamasa and Munabadha.


Bukhari :: Dress :: [7.72.712]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 712

Narrated Abu Said Al-Khudri:

The Prophet forbade Ishtimal-as-Samma' and that a man should sit in an Ihtiba' posture in one garment, nothing of which covers his private parts.


Bukhari :: Dress :: [7.72.713]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 713

Narrated Um Khalid bint Khalid:

The Prophet was given some clothes including a black Khamisa. The Prophet said, "To whom shall we give this to wear?" The people kept silent whereupon the Prophet said, "Fetch Um Khalid for me." I (Um Khalid) was brought carried (as I was small girl at that time). The Prophet took the Khamisa in his hands and made me wear it and said, "May you live so long that your dress will wear out and you will mend it many times." On the Khamisa there were some green or pale designs (The Prophet saw these designs) and said, "O Um Khalid! This is Sanah." (Sanah in a Ethiopian word meaning beautiful).


Bukhari :: Dress :: [7.72.714]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 714

Narrated Anas:

When Um Sulaim gave birth to a child. she said to me, "O Anas! Watch this boy carefully and do not give him anything to eat or drink until you have taken him to the Prophet tomorrow morning for the Tahnik." So the next morning I took the child to the Prophet who was sitting in a garden and was wearing a Huraithiya Khamisa and was branding the she-camel on which he had come during the Conquest of Mecca.


Bukhari :: Dress :: [7.72.715]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 715

Narrated 'Ikrima:

Rifa'a divorced his wife whereupon 'AbdurRahman bin Az-Zubair Al-Qurazi married her. 'Aisha said that the lady (came), wearing a green veil (and complained to her (Aisha) of her husband and showed her a green spot on her skin caused by beating). It was the habit of ladies to support each other, so when Allah's Apostle came, 'Aisha said, "I have not seen any woman suffering as much as the believing women. Look! Her skin is greener than her clothes!" When 'AbdurRahman heard that his wife had gone to the Prophet, he came with his two sons from another wife. She said, "By Allah! I have done no wrong to him but he is impotent and is as useless to me as this," holding and showing the fringe of her garment, 'Abdur-Rahman said, "By Allah, O Allah's Apostle! She has told a lie! I am very strong and can satisfy her but she is disobedient and wants to go back to Rifa'a." Allah's Apostle said, to her, "If that is your intention, then know that it is unlawful for you to remarry Rifa'a unless Abdur-Rahman has had sexual intercourse with you." Then the Prophet saw two boys with 'Abdur-Rahman and asked (him), "Are these your sons?" On that 'AbdurRahman said, "Yes." The Prophet said, "You claim what you claim (i.e.. that he is impotent)? But by Allah, these boys resemble him as a crow resembles a crow,"


Bukhari :: Dress :: [7.72.716]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 716

Narrated Sad:

On the day of the battle of Uhud, on the right and on the left of the Prophet were two men wearing white clothes, and I had neither seen them before, nor did I see them afterwards.


Bukhari :: Dress :: [7.72.717]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 717

Narrated Abu Dharr:

I came to the Prophet while he was wearing white clothes and sleeping. Then I went back to him again after he had got up from his sleep. He said, "Nobody says: 'None has the right to be worshipped but Allah' and then later on he dies while believing in that, except that he will enter Paradise.' I said, "Even It he had committed illegal sexual intercourse and theft." I said. "Even if he had committed illegal sexual intercourse and theft? He said. 'Even If he had committed illegal sexual intercourse and theft," I said, 'Even it he had committed illegal sexual intercourse and thefts.' He said, "Even If he had committed Illegal sexual intercourse and theft, inspite of the Abu Dharrs dislikeness. Abu 'Abdullah said, "This is at the time of death or before it if one repents and regrets and says "None has the right to be worshipped but Allah. He will be forgiven his sins."


Bukhari :: Dress :: [7.72.718]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 718

Narrated Aba 'Uthman An-Nahdi:

While we were with 'Utba bin Farqad at Adharbijan, there came 'Umar's letter indicating that Allah's Apostle had forbidden the use of silk except this much, then he pointed with his index and middle fingers. To our knowledge, by that he meant embroidery.


Bukhari :: Dress :: [7.72.719]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 719

Narrated Abu 'Uthman:

While we were at Adharbijan, 'Umar wrote to us: 'Allah's Apostle forbade wearing silk except this much. Then the Prophet approximated his two fingers (index and middle fingers) (to illustrate that) to us.' Zuhair (the sub-narrator) raised up his middle and index fingers.


Bukhari :: Dress :: [7.72.720]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 720

Narrated Abu 'Uthman:

While we were with 'Utba. 'Umar wrote to us: The Prophet said, "There is none who wears silk in this world except that he will wear nothing of it in the Hereafter." ' Abu 'Uthman pointed out with his middle and index fingers.


Bukhari :: Dress :: [7.72.721]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 721

Narrated Abu Uthman:

(as above, 719)


Bukhari :: Dress :: [7.72.722]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 722

Narrated Ibn Abi Laila:

While Hudhaifa was at Al-Madain, he asked for water whereupon the chief of the village brought him water in a silver cup. Hudhaifa threw it at him and said, "I have thrown it only because I have forbidden him to use it, but he does not stop using it. Allah's Apostle said, 'Gold, silver, silk and Dibaj (a kind of silk) are for them (unbelievers) in this world and for you (Muslims) in the hereafter.'


Bukhari :: Dress :: [7.72.723]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 723

Narrated Anas bin Malik:

The Prophet said, Whoever wears silk in this world shall not wear it in the Hereafter."


Bukhari :: Dress :: [7.72.724]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 724

Narrated Thabit:

I heard Ibn Az-Zubair delivering a sermon, saying, "Muhammad said, 'Whoever wears silk in this world, shall not wear it in the Hereafter."


Bukhari :: Dress :: [7.72.725]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 725

Narrated Ibn Az-Zubair:

I heard 'Umar saying, "The Prophet said, 'Whoever wears silk in this world, shall not wear it in the Hereafter."


Bukhari :: Dress :: [7.72.726]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 726

Narrated 'Umar bin Al-Khattab:

Allah's Apostle said, "None wears silk in this world, but he who will have no share in the Hereafter."


Bukhari :: Dress :: [7.72.727]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 727

Narrated Al-Bara:

The Prophet was given a silk garment as a gift and we started touching it with our hands and admiring it. On that the Prophet said, "Do you wonder at this?" We said, "Yes." He said, "The handkerchiefs of Sad bin Mu'adh in Paradise are better than this "


Bukhari :: Dress :: [7.72.728]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 728

Narrated Hudhaifa:

The Prophet forbade us to drink out of gold and silver vessels, or eat in it, Ann also forbade the wearing of silk and Dibaj or sitting on it.


Bukhari :: Dress :: [7.72.729]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 729

Narrated Ibn Azib:

The Prophet forbade us to use the red Mayathir and to use Al-Qassiy


Bukhari :: Dress :: [7.72.730]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 730

Narrated Anas:

The Prophet allowed Az-Zubair and 'Abdur-Rahman to wear silk because they were suffering from an itch


Bukhari :: Dress :: [7.72.731]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 731

Narrated Ali bin Abi Talib:

The Prophet gave me a silk suit. I went out wearing it, but seeing the signs of anger on his face, I tore it and distributed it among my wives.


Bukhari :: Dress :: [7.72.732]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 732

Narrated Abdullah bin Umar:

'Umar saw a silk suit being sold, so he said, "O Allah's Apostle! Why don't you buy it so that you may wear it when delegates come to you, and also on Fridays?" The Prophet said, "This is worn only by him who has no share in the Hereafter." Afterwards the Prophet sent to 'Umar a silk suit suitable for wearing. 'Umar said to the Prophet, "You have given it to me to wear, yet I have heard you saying about it what you said?" The Prophet said, "I sent it to you so that you might either sell it or give it to somebody else to wear."


Bukhari :: Dress :: [7.72.733]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 733

Narrated Anas bin Malik:

that he had seen Um Kulthum, the daughter of Allah's Apostle , wearing a red silk garment.


Bukhari :: Dress :: [7.72.734]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 734

Narrated Ibn 'Abbas:

For one year I wanted to ask 'Umar about the two women who helped each other against the Prophet but I was afraid of him. One day he dismounted his riding animal and went among the trees of Arak to answer the call of nature, and when he returned, I asked him and he said, "(They were) 'Aisha and Hafsa." Then he added, "We never used to give significance to ladies in the days of the Pre-lslamic period of ignorance, but when Islam came and Allah mentioned their rights, we used to give them their rights but did not allow them to interfere in our affairs. Once there was some dispute between me and my wife and she answered me back in a loud voice. I said to her, 'Strange! You can retort in this way?' She said, 'Yes. Do you say this to me while your daughter troubles Allah's Apostle?' So I went to Hafsa and said to her, 'I warn you not to disobey Allah and His Apostle.' I first went to Hafsa and then to Um Salama and told her the same. She said to me, 'O 'Umar! It surprises me that you interfere in our affairs so much that you would poke your nose even into the affairs of Allah's Apostle and his wives.' So she rejected my advice. There was an Ansari man; whenever he was absent from Allah's Apostle and I was present there, I used to convey to him what had happened (on that day), and when I was absent and he was present there, he used to convey to me what had happened as regards news from Allah's Apostle . During that time all the rulers of the nearby lands had surrendered to Allah's Apostle except the king of Ghassan in Sham, and we were afraid that he might attack us. All of a sudden the Ansari came and said, 'A great event has happened!' I asked him, 'What is it? Has the Ghassani (king) come?' He said, 'Greater than that! Allah's Apostle has divorced his wives! I went to them and found all of them weeping in their dwellings, and the Prophet had ascended to an upper room of his. At the door of the room there was a slave to whom I went and said, "Ask the permission for me to enter." He admitted me and I entered to see the Prophet lying on a mat that had left its imprint on his side. Under his head there was a leather pillow stuffed with palm fires. Behold! There were some hides hanging there and some grass for tanning. Then I mentioned what I had said to Hafsa and Um Salama and what reply Um Salama had given me. Allah's Apostle smiled and stayed there for twenty nine days and then came down." (See Hadith No. 648, Vol. 3 for details)


Bukhari :: Dress :: [7.72.735]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 735

Narrated Um Salama:

One night the Prophet woke up, saying, "None has the right to be worshipped but Allah! How many afflictions have been sent down tonight, and how many treasures have been sent down (disclosed)! Who will go and wake up (for prayers) the lady dwellers of these rooms? Many well dressed soul (people) in this world, will be naked on the Day of Resurrection."


Bukhari :: Dress :: [7.72.736]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 736

Narrated Um Khalid bint Khalid:

Some clothes were presented to Allah's Apostle as a gift and there was a black Khamisa with it. The Prophet asked (his companions), "To whom do you suggest we give this Khamisa?" The people kept quiet. Then he said, "Bring me Um Khalid," So I was brought to him and he dressed me with it with his own hands and said twice, "May you live so long that you will wear out many garments." He then started looking at the embroidery of that Khamisa and said, "O Um Khalid! This is Sana!" (Sana in Ethiopian language means beautiful.) Ishaq, a sub-narrator, said: A woman of my family had told me that she had seen the Khamisa worn by Um Khalid.


Bukhari :: Dress :: [7.72.737]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 737

Narrated Anas:

The Prophet forbade men to use saffron.


Bukhari :: Dress :: [7.72.738]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 738

Narrated Ibn 'Umar:

The Prophet forbade Muhrims to wear clothes dyed with Wars or saffron.


Bukhari :: Dress :: [7.72.739]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 739

Narrated Al-Bara:

The Prophet was of a modest height. I saw him wearing a red suit, and I did not see anything better than him.


Bukhari :: Dress :: [7.72.740]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 740

Narrated Al-Bara:

The Prophet ordered us to observe seven things: To visit the sick; follow funeral processions; say 'May Allah bestow His Mercy on you', to the sneezer if he says, 'Praise be to Allah!; He forbade us to wear silk, Dibaj, Qassiy and Istibarq (various kinds of silken clothes); or to use red Mayathir (silk-cushions). (See Hadith No. 253 A, Vol. 8).


Bukhari :: Dress :: [7.72.741]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 741

Narrated Said Abu Maslama:

I asked Anas (bin Malik), "Did the Prophet use to offer the prayers with his shoes on?" He said, "Yes."


Bukhari :: Dress :: [7.72.742]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 742

Narrated Said Al-Maqburi:

'Ubai bin Juraij said to 'Abdullah Ben 'Umar, "I see you doing four things which are not done by your friends." Ibn 'Umar said, "What are they, O Ibn Juraij?" He said, "I see that you do not touch except the two Yemenite corners of the Ka'ba (while performing the Tawaf): and I see you wearing the Sabtiyya shoes; and I see you dyeing (your hair) with Sufra; and I see that when you are in Mecca, the people assume the state of Ihram on seeing the crescent (on the first day of Dhul-Hijja) while you do not assume the state of Ihram till the Day of Tarwiya (8th Dhul Hijja)." 'Abdullah bin 'Umar said to him, "As for the corners of the Ka'ba, I have not seen Allah's Apostle touching except the two Yemenite corners, As for the Sabtiyya shoes, I saw Allah's Apostle wearing leather shoes that had no hair, and he used to perform the ablution while wearing them. Therefore, I like to wear such shoes. As regards dyeing with Sufra, I saw Allah's Apostle dyeing his hair with it, so I like to dye (my hair) with it. As regards the crescent (of Dhul-Hijja), I have not seen Allah's Apostle assuming the state of Ihram till his she-camel set out (on the 8th of Dhul-Hijja)."


Bukhari :: Dress :: [7.72.743]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 743

Narrated Ibn 'Umar:

Allah's Apostle forbade that a Muhrim should wear clothes dyed with Saffron or Wars, and said, "Whoever has no shoes can put on Khuffs after cutting it below the ankles."


Bukhari :: Dress :: [7.72.744]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 744

Narrated Ibn Abbas:

The Prophet said, "Whoever has no Izar (waist sheet), can wear trousers; and whoever has no sandals, can wear Khuffs." (but cut them short below the ankles),


Bukhari :: Dress :: [7.72.745]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 745

Narrated 'Aisha:

The Prophet used to like starting from the right in performing ablution, combing his hair and putting on his shoes.


Bukhari :: Dress :: [7.72.746]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 746

Narrated Abu Huraira:

Allah's Apostle said, "None of you should walk, wearing one shoe only; he should either put on both shoes or put on no shoes whatsoever."


Bukhari :: Dress :: [7.72.747]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 747

Narrated Abu Huraira:

Allah's Apostle said, "If you want to put on your shoes, put on the right shoe first; and if you want to take them off, take the left one first. Let the right shoe be the first to be put on and the last to be taken off."


Bukhari :: Dress :: [7.72.748]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 748

Narrated Anas:

The sandal of the Prophet had two straps.


Bukhari :: Dress :: [7.72.749]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 749

Narrated Isaa bin Tahman:

Anas bin Malik brought out for us, two sandals having two straps. Thabit Al-Banani said, "These were the sandals of the Prophet ."


Bukhari :: Dress :: [7.72.750]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 750

Narrated Abu Juhaifa:

I came to the Prophet while he was inside a red leather tent, and I saw Bilal taking the remaining water of the ablution of the Prophet, and the people were taking of that water and rubbing it on their faces; and whoever could not get anything of it, would share the moisture of the hand of his companion (and then rub it on his face).


Bukhari :: Dress :: [7.72.751]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 751

Narrated Anas bin Malik:

The Prophet called for the Ansar and gathered them in a leather tent.


Bukhari :: Dress :: [7.72.752]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 752

Narrated 'Aisha:

The Prophet used to construct a loom with a Hasir at night m order to pray therein, and during the day he used to spread it out and sit on it. The people started coming to the Prophet at night to offer the prayer behind him When their number increased, the Prophet faced them and said. O people! Do only those good deeds which you can do, for Allah does not get tired (of giving reward) till you get tired, and the best deeds to Allah are the incessant ones though they were few


Bukhari :: Dress :: [7.72.753]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 753

Narrated Al-Bara' bin 'Azib:

The Prophet forbade us to use seven things: He forbade using gold rings, silk, Istabraq, Dibaj, red Mayathir, Al-Qassiy, and silver utensils. He ordered us to do seven other things. To pay a visit to the sick; to follow funeral processions; to say, "May Allah be merciful to you" to a sneezer if he says "Praise be to Allah"; to return greetings, to accept invitations; to help others to fulfil their oaths and to help the oppressed ones.


Bukhari :: Dress :: [7.72.754]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 754

Narrated Abu Huraira:

The Prophet forbade the wearing of a gold ring.


Bukhari :: Dress :: [7.72.755]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 755

Narrated 'Abdullah:

Allah's Apostle wore a gold or silver .. ring and placed its stone towards the palm of his hand. The people also started wearing gold rings like it, but when the Prophet saw them wearing such rings, he threw away that golden ring and then wore a silver ring.


Bukhari :: Dress :: [7.72.756]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 756

Narrated Ibn. 'Umar:

Allah's Apostle wore a gold ring or a silver ring and placed its stone towards the palm of his hand and had the name 'Muhammad, the Apostle of Allah' engraved on it. The people also started wearing gold rings like it, but when the Prophet saw them wearing such rings, he threw away his own ring and said. "I will never wear it," and then wore a silver ring, whereupon the people too started wearing silver rings. Ibn Umar added: After the Prophet Abu Bakr wore the ring, and then Umar and then 'Uthman wore it till it fell in the Aris well from 'Uthman. bin 'Umar : Allah's Apostle wore a gold ring, then he threw it and said, "I will never wear it." The people also threw their (gold) rings.


Bukhari :: Dress :: [7.72.757]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 757

Narrated Anas bin Malik:

that he saw a silver ring on the hand of Allah's Apostle for one day only. Then the people had silver rings made for themselves and wore it. On that, Allah's Apostle threw away their rings as well. (For the details of this Hadith, see Fateh-Al-Bari, Vol. 12, page 438).


Bukhari :: Dress :: [7.72.758]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 758

Narrated Humaid:

Anas was asked, "Did the Prophet wear a ring?" Anas said, "Once he delayed the: 'Isha' prayer till midnight. Then he came, facing us ..... as if l am now Looking at the glitter of his ring ..... and said, "The people have offered their prayers and slept but you have been in prayer as you have been waiting for it."


Bukhari :: Dress :: [7.72.759]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 759

Narrated Anas:

The ring of the Prophet was of silver, and its stone was of silver too.


Bukhari :: Dress :: [7.72.760]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 760

Narrated Sahl:

A woman came to the Prophet and said, "I have come to present myself to you (for marriage)." She kept standing for a long period during which period the Prophet looked at her carefully. When she stayed for a Long period, a man said to the Prophet "If you are not in need of her, then marry her to me." The Prophet said, "Have you got anything to give her (as Mahr)?" The man said, "No." The Prophet said, "Go (to your house) and search for something." The man went and came back to say, "By Allah, I could not find anything." The Prophet said, "Go again and search for something, even if it be an iron ring." He went again and came back saying, "No, by Allah, I could not get even an iron ring." The man had only an Izar and had no Rida' (upper garment). He said, "I will give her my Izar as Mahr." On that the Prophet said, "Your Izar? If she wears it, nothing of it will remain on you, and if you wear it nothing of it will be on her" The man went aside and sat down When the Prophet saw him leaving (after a while), he called back and asked. "How much Qur'an do you know (by heart)? He said, 'I know such and such Suras," naming some Suras. The Prophet said, "I marry her to you for the amount of Qur'an you know (by heart)."


Bukhari :: Dress :: [7.72.761]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 761

Narrated Anas bin Malik:

Allah's Apostle wanted to write a letter to a group of people or some non-Arabs. It was said to him, "They do not accept any letter unless it is stamped." So the Prophet had a silver ring made for himself, and on it was engraved: 'Muhammad, the Apostle of Allah'. .. as if I am now looking at the glitter of the ring on the finger (or in the palm) of the Prophet .


Bukhari :: Dress :: [7.72.762]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 762

Narrated Ibn 'Umar:

Allah's Apostle had a silver ring made for himself and it was worn by him on his hand. Afterwards it was worn by Abu Bakr, and then by 'Umar, and then by 'Uthman till it fell in the Aris well. (On that ring) was engraved: 'Muhammad, the Apostle of Allah."


Bukhari :: Dress :: [7.72.763]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 763

Narrated Anas:

The Prophet got a ring made for himself and said, "I have got a ring made (for myself) and engraved a certain engraving on it so none of you should get such an engraving on his ring." I saw the glitter of the ring on his little finger.


Bukhari :: Dress :: [7.72.764]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 764

Narrated Anas bin Malik:

When the Prophet intended to write to the Byzantines, it was said to him, "Those people do not read your letter unless it is stamped." So the Prophet took a silver ring and got 'Muhammad, the Apostle of Allah' engraved on it .... as if I am now looking at its glitter in his hand.


Bukhari :: Dress :: [7.72.765]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 765

Narrated Abdullah:

The Prophet had a golden ring made for himself, and when he wore it. he used to turn its stone toward the palm of his! hand. So the people too had gold made for themselves. The Prophet then ascended the pulpit, and after glorifying and praising Allah, he said, "I had it made for me, but now I will never wear it again." He threw it away, and then the people threw away their rings too. (Juwairiya, a sub-narrator, said: I think Anas said that the Prophet was wearing the ring in his right hand.)


Bukhari :: Dress :: [7.72.766]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 766

Narrated Anas bin Malik :

Allah's Apostle took a silver ring and had 'Muhammad, the Apostle' of Allah' engraved on it. The Prophet then said (to us), 'I have a silver ring with 'Muhammad, the Apostle of Allah engraved on it, so none of you should have the same engraving on his ring."


Bukhari :: Dress :: [7.72.767]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 767

Narrated Anas:

that when Abu Bakr became the Caliph, he wrote a letter to him (and stamped it with the Prophet's ring) and the engraving of the ring was in three lines: Muhammad in one line, 'Apostle' in another line, and 'Allah' in a third line. Anas added: 'the ring of the Prophet was in his hand, and after him, in Abu Bakr's hand, and then in 'Umar's hand after Abu Bakr. When Uthman was the Caliph, once he was sitting at the well of Aris. He removed the ring from his hand and while he was trifling with it, dropped into the well. We kept on going to the well with Uthman for three days looking for the ring, and finally the well was drained, but the ring was not found.


Bukhari :: Dress :: [7.72.768]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 768

Narrated Ibn 'Abbas:

I offered the 'Id prayer with the Prophet and he offered prayer before the Khutba (sermon). ibn 'Abbas added: After the prayer the Prophet came towards (the rows of) the women and ordered them to give alms, and the women started putting their big and small rings in the garment of Bilal.


Bukhari :: Dress :: [7.72.769]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 769

Narrated ibn 'Abbas:

The Prophet came out on the day of 'Id and offered a two-Rak'at prayer, and he did not pray any Rak'a before it, nor after it. Then he went towards the women and ordered them to give alms. The women started donating their earring and necklaces.


Bukhari :: Dress :: [7.72.770]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 770

Narrated 'Aisha:

A necklace belonging to Asma' was lost, and the Prophet sent men in its search. The time for the prayer became due and they were without ablution and they could not find water; therefore they prayed without ablution, They mentioned that to the Prophet . Then Allah revealed the Verse of Tayammum. ('Aisha added: that she had borrowed (the necklace) from Asma').


Bukhari :: Dress :: [7.72.771]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 771

Narrated Ibn 'Abbas

"The Prophet offered a two-Rak'at prayer on 'Id day and he did not offer any (Nawafil prayer) before or after it. He then went towards the women, and Bilal was accompanying him, and ordered them to give alms. And so the women started giving their earrings (etc .)."


Bukhari :: Dress :: [7.72.772]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 772

Narrated Abu Huraira:

I was with Allah's Apostle in one of the Markets of Medina. He left (the market) and so did I. Then he asked thrice, "Where is the small (child)?" Then he said, "Call Al-Hasan bin 'Ali." So Al-Hasan bin 'Ali got up and started walking with a necklace (of beads) around his neck. The Prophet stretched his hand out like this, and Al-Hasan did the same. The Prophet embraced him and said, "0 Allah! l love him, so please love him and love those who love him." Since Allah's Apostle said that. nothing has been dearer to me than Al-Hasan.


Bukhari :: Dress :: [7.72.773]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 773

Narrated Ibn 'Abbas:

Allah's Apostle cursed those men who are in the similitude (assume the manners) of women and those women who are in the similitude (assume the manners) of men.


Bukhari :: Dress :: [7.72.774]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 774

Narrated Ibn 'Abbas:

The Prophet cursed effeminate men (those men who are in the similitude (assume the manners of women) and those women who assume the manners of men, and he said, "Turn them out of your houses ." The Prophet turned out such-and-such man, and 'Umar turned out such-and-such woman.


Bukhari :: Dress :: [7.72.775]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 775

Narrated Um Salama:

that once the Prophet was in her house, and an effeminate man was there too. The effeminate man said to 'Abdullah, (Um Salama's brother) "0 'Abdullah! If Ta'if should be conquered tomorrow, I recommend you the daughter of Ghailan, for she is so fat that she has four curves in the front (of her belly) and eight at the back." So the Prophet said (to his wives) "These effeminate (men) should not enter upon you (your houses).


Bukhari :: Dress :: [7.72.776]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 776

Narrated Ibn Umar:

The Prophet said, "To get the moustaches cut 'short is characteristic of the Fitra."


Bukhari :: Dress :: [7.72.777]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 777

Narrated Abu Huraira:

Allah's Apostle said, "Five practices are characteristics of the Fitra: circumcision, shaving the pubic region, clipping the nails and cutting the moustaches short."


Bukhari :: Dress :: [7.72.778]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 778

Narrated Ibn 'Umar:

Allah's Apostle said, "To shave the pubic hair. to clip the nails and to cut the moustaches short, are characteristics of the Fitra."


Bukhari :: Dress :: [7.72.779]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 779

Narrated Abu Huraira :

I heard the Prophet saying. "Five practices are characteristics of the Fitra: circumcision, shaving the pubic hair, cutting the moustaches short, clipping the nails, and depilating the hair of the armpits."


Bukhari :: Dress :: [7.72.780]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 780

Narrated Nafi':

Ibn Umar said, The Prophet said, 'Do the opposite of what the pagans do. Keep the beards and cut the moustaches short.' Whenever Ibn 'Umar performed the Hajj or 'Umra, he used to hold his beard with his hand and cut whatever moustaches. Ibn Umar used to cut his moustache so short that the whiteness of his skin (above the upper lip) was visible, and he used to cut (the hair) between his moustaches and his beard.


Bukhari :: Dress :: [7.72.781]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 781

Narrated Ibn 'Umar:

Allah's Apostle said, "Cut the moustaches short and leave the beard (as it is)."


Bukhari :: Dress :: [7.72.782]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 782

Narrated Muhammad bin Sirin:

I asked Anas, "Did the Prophet dye his hair?" Anas replied, "The Prophet did not have except a few grey hairs."


Bukhari :: Dress :: [7.72.783]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 783

Narrated Thabit:

Anas was asked whether the Prophet used a a hair dye or not. Anas replied, "The Prophet had not enough grey hair to dye. I could even count the white grey hairs oil his beard ill would."


Bukhari :: Dress :: [7.72.784]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 784

Narrated IsraiI:

Uthman bin 'Abdullah bin Mauhab said, "My people sent me with a bowl of water to Um Salama." Isra'il approximated three fingers ('indicating the small size of the container in which there was some hair of the Prophet. 'Uthman added, "If any person suffered from evil eye or some other disease, he would send a vessel (containing water) to Um Salama. I looked into the container (that held the hair of the Prophet) and saw a few red hairs in it,"


Bukhari :: Dress :: [7.72.785]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 785

Narrated Uthman bin 'Abdullah bin Mauhab:

I went to Um Salama and she brought out for us some of the dyed hair of the Prophet . ibn Mauhab also said that Um Salama had shown him the red hair of the


Bukhari :: Dress :: [7.72.786]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 786

Narrated Abu Huraira :

The Prophet said, "Jews and Christians do not dye their hair so you should do the opposite of what they do.


Bukhari :: Dress :: [7.72.787]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 787

Narrated Anas bin Malik:

The Prophet was neither conspicuously tall, nor short; neither, very white, nor tawny. His hair was neither much curled, nor very straight. Allah sent him (as an Apostle) at the age of forty (and after that) he stayed for ten years in Mecca, and for ten more years in Medina. Allah took him unto Him at the age of sixty, and he scarcely had ten white hairs on his head and in his beard.


Bukhari :: Dress :: [7.72.788]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 788

Narrated Al-Bara':

I did not see anybody in a red cloak looking more handsome than the Prophet Narrated Malik: The hair of the Prophet used to hang near his shoulders. Narrated Shu'ba: The hair of the Prophet used to hang down to the earlobes.


Bukhari :: Dress :: [7.72.789]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 789

Narrated Abdullah bin Umar:

Allah's Apostle said, "Today I saw myself in a dream near the Ka'ba. I saw a whitish brown man, the handsomest of all brown men you might ever see. He had the most beautiful Limma (hair hanging down to the earlobes) you might ever see. He had combed it and it was dripping water; and he was performing the Tawaf around the Kaba leaning on two men or on the shoulders of two men. l asked, "Who is this?" It was said. "Messiah, the son of Mary." Suddenly I saw a curly-haired man, blind in the right eye which looked like a protruding out grape. I asked, "Who is this?" It was said, "He is Masiah Ad-Dajjal."


Bukhari :: Dress :: [7.72.790]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 790

Narrated Anas:

The head-hair of the Prophet used to hang down to his shoulders.


Bukhari :: Dress :: [7.72.791]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 791

Narrated Qatada:

l asked Anas bin Malik about the hair of Allah's Apostle. He said, "The hair of Allah's Apostle was neither much straight, nor much curly, and it used to hang down till between his shoulders and his earlobes.


Bukhari :: Dress :: [7.72.792]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 792

Narrated Anas:

The Prophet had big hands, and I have never seen anybody like him after him. The hair of the Prophet was wavy, neither curly nor straight.


Bukhari :: Dress :: [7.72.793]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 793

Narrated Anas :

The Prophet had big hands and feet, and I have not seen anybody like him, neither before nor after him, and his palms were soft.


Bukhari :: Dress :: [7.72.794]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 794

Narrated Abu Huraira :

The Prophet had big feet and a good-looking face and l have not seen anybody like him after him. Narrated Anas: The Prophet had big feet and hands. Narrated Anas or Jabir bin 'Abdullah The Prophet had big hands and feet and I have not seen anybody like him after him.


Bukhari :: Dress :: [7.72.795]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 795

Narrated Mujahid:

We were with Ibn 'Abbas and the people mentioned Ad-Dajjal. Someone said, "The word 'Kafir' (unbeliever) is written in between his (Ad-Dajjal's) eyes." Ibn 'Abbas said, "I have not heard the Prophet saying this, but he said, 'As regards Abraham, he looks like your companion (i.e. the Prophet, Muhammad), and as regards Moses, he is a brown curly haired man riding a camel and reigned with a strong jute rope, as if lam now looking at him getting down in the valley and saying, "Labbaik".'"


Bukhari :: Dress :: [7.72.796]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 796

Narrated 'Abdullah bin 'Umar :

I heard 'Umar saying, "Whoever braids his hair should shave it (on finishing lhram). You'd better not do, something like Talbid." Ibn Umar used to say: "I saw Allah's Apostle with his hair stuck together with gum."


Bukhari :: Dress :: [7.72.797]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 797

Narrated Ibn 'Umar:

I heard Allah's Apostle, while he was in the state of lhram and his hair was stuck together with gum, saying, "Labbaik, Allahumma Labbaik, Labbaik La Shanka laka Labbaik. Inn-al-Hamda Wan-Ni'mata Laka wal-Mulk, La Shanka Lak." He did not add anything to those words. (See Hadith No. 621, Vol. 2)


Bukhari :: Dress :: [7.72.798]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 798

Narrated Hafsa:

(the wife of the Prophet) I said, "O Allah's Apostle! Why have the people finished their Ihram after performing the 'Umra while you have not finished your lhram after your 'Umra?" He said, "I have done Talbid (of my hair) and have decorated my Hadis with garlands, so I shall not finish my lhram till l have slaughtered my Hadi (animal for sacrifice)."


Bukhari :: Dress :: [7.72.799]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 799

Narrated Ibn 'Abbas:

The Prophet used to copy the people of the Scriptures in matters in which there was no order from Allah. The people of the Scripture used to let their hair hang down while the pagans used to part their hair. So the Prophet let his hair hang down first, but later on he parted it.


Bukhari :: Dress :: [7.72.800]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 800

Narrated 'Aisha :

As if I am now looking at the shine of the hair parting of the Prophet while he was in the state of lhram.


Bukhari :: Dress :: [7.72.801]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 801

Narrated Ibn 'Abbas :

Once I stayed overnight in the house of my aunt Maimuna bint Al-Harith and Allah's Apostle was with her as it was her turn. Allah's Apostle got up to offer the night prayer. I stood on his left but he took hold of my two locks of hair and made me stand on his right.


Bukhari :: Dress :: [7.72.802]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 802

Narrated Abu Bishr

(the above Hadith) but he quoted: Ibn 'Abbas said, (took hold of) my two braids on my head."


Bukhari :: Dress :: [7.72.803]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 803

Narrated Ubaidullah bin Hafs:

that 'Umar bin Nafi' told him that Nafi', Maula 'Abdullah had heard 'Umar saying, "I heard Allah's Apostle forbidding Al-Qaza'." 'Ubaidullah added: I said, "What is Al-Qaza'?" 'Ubaidullah pointed (towards his head) to show us and added, "Nafi' said, 'It is when a boy has his head shaved leaving a tuft of hair here and a tuft of hair there." Ubaidullah pointed towards his forehead and the sides of his head. 'Ubaidullah was asked, "Does this apply to both girls and boys?" He said, "I don't know, but Nafi' said, 'The boy.'" 'Ubaidullah added, "I asked Nafi' again, and he said, 'As for leaving hair on the temples and the back part of the boy's head, there is no harm, but Al-Qaza' is to leave a tuft of hair on his forehead unshaved while there is no hair on the rest of his head, and also to leave hair on either side of his head.'"


Bukhari :: Dress :: [7.72.804]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 804

Narrated (Abdullah) bin 'Umar :

Allah's Apostle forbade Al-Qaza' (leaving a tuft of hair here and there after shaving one's head.)


Bukhari :: Dress :: [7.72.805]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 805

Narrated 'Aisha :

I applied perfume to the Prophet with my own hands when he wanted to assume the state of Ihram, and I also perfumed him at Mina before he departed from there (to perform Tawaf-al-Ifada).


Bukhari :: Dress :: [7.72.806]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 806

Narrated 'Aisha :

I used to perfume Allah's Apostle with the best scent available till I saw the shine of the scent on his head and shine beard.


Bukhari :: Dress :: [7.72.807]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 807

Narrated Sa'd:

A man peeped into the house of the Prophet through a hole while the Prophet was scratching his head with a Midrai (a certain kind of comb). On that the Prophet said (to him), "If I had known you had been looking, then I would have pierced your eye with that instrument, because the asking of permission has been ordained so that one would not see things unlawfully."


Bukhari :: Dress :: [7.72.808]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 808

Narrated 'Aisha :

I used to comb the hair of Allah's Apostle during my periods.


Bukhari :: Dress :: [7.72.809]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 809

Narrated 'Aisha

(As above, (808).


Bukhari :: Dress :: [7.72.810]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 810

'Narrated 'Aisha:

The Prophet used to like to start from the right side as far as possible in combing and in performing ablution.


Bukhari :: Dress :: [7.72.811]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 811

Narrated Abu Huraira :

The Prophet said, "(Allah said), 'Every good deed of Adam's son is for him except fasting; it is for Me. and I shall reward (the fasting person) for it.' Verily, the smell of the mouth of a fasting person is better to Allah than the smell of musk."


Bukhari :: Dress :: [7.72.812]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 812

Narrated 'Aisha :

used to perfume the Prophet before his assuming the state of with the best scent available.


Bukhari :: Dress :: [7.72.813]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 813

Narrated Thumama bin 'Abdullah;

Anas never used to refuse (a gift of) scent and used to say that the Prophet never used to refuse (a gift of) scent.


Bukhari :: Dress :: [7.72.814]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 814

Narrated 'Aisha :

During Hajjat-al-Wada', I perfumed Allah's Apostle with Dharira with my own hands, both on his assuming Ihram and on finishing it.


Bukhari :: Dress :: [7.72.815]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 815

Narrated 'Abdullah:

Allah has cursed those women who practise tattooing and those who get themselves tattooed, and those who remove their face hairs, and those who create a space between their teeth artificially to look beautiful, and such women as change the features created by Allah. Why then should I not curse those whom the Prophet has cursed? And that is in Allah's Book. i.e. His Saying: 'And what the Apostle gives you take it and what he forbids you abstain (from it).' (59.7)


Bukhari :: Dress :: [7.72.816]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 816

Narrated Humaid bin 'Abdur-Rahman bin 'Auf

that in the year he performed Hajj. he heard Mu'awiya bin Abi Sufyan, who was on the pulpit and was taking a tuft of hair from one of his guards, saying, "Where are your religious learned men? I heard Allah's Apostle forbidding this (false hair) and saying, 'The children of Israel were destroyed when their women started using this.'" Narrated Abu Huraira: The Prophet said, "Allah has cursed the lady who artificially lengthens (her or someone else's) hair and the one who gets her hair lengthened and the One who tattoos (herself or someone else) and the one who gets herself tattooed"


Bukhari :: Dress :: [7.72.817]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 817

Narrated 'Aisha :

An Ansari girl was married and she became sick and all her hair fell out intending to provide her with false hair. They asked the Prophet who said, "Allah has cursed the lady who artificially lengthens (her or someone else's) hair and also the one who gets her hair lengthened."


Bukhari :: Dress :: [7.72.818]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 818

Narrated Asma:

(the daughter of Abu' Bakr) A woman came to Allah's Apostle and said, "I married my daughter to someone, but she became sick and all her hair fell out, and (because of that) her husband does not like her. May I let her use false hair?" On that the Prophet cursed such a lady as artificially lengthening (her or someone else's) hair or got her hair lengthened artificially.


Bukhari :: Dress :: [7.72.819]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 819

Narrated Asma'

(the daughter of Abu Bakr) Allah's Apostle has cursed such a lady as artificially lengthening (her or someone else's) hair or gets her hair lengthened.


Bukhari :: Dress :: [7.72.820]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 820

Narrated Ibn Umar

Allah's Apostle said, "Allah has cursed such a lady as lengthens (her or someone else's) hair artificially or gets it lengthened, and also a lady who tattoos (herself or someone else) or gets herself tattooed.


Bukhari :: Dress :: [7.72.821]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 821

Narrated Sa'id bin Al-Musaiyab:

Mu'awiya came to Medina for the last time and delivered a sermon. He took out a tuft of hair and said, "I thought that none used to do this (i.e. use false hair) except Jews. The Prophet labelled such practice, (i.e. the use of false hair), as cheating.


Bukhari :: Dress :: [7.72.822]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 822

Narrated 'Alqama:

'Abdullah cursed those women who practiced tattooing and those who removed hair from their faces and those who created spaces between their teeth artificially to look beautiful, such ladies as changed what Allah has created. Um Ya'qub said, "What is that?" 'Abdullah said, "Why should I not curse those who were cursed by Allah's Apostle and are referred to in Allah's Book?" She said to him "By Allah, I have read the whole Qur'an but I have not found such a thing. 'Abdullah said, "By Allah, if you had read it (carefully) you would have found it. (Allah says:) 'And what the Apostle gives you take it and what he forbids you abstain (from it).' (59.7)


Bukhari :: Dress :: [7.72.823]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 823

Narrated Ibn 'Umar :

The Prophet has cursed the lady who lengthens her hair artificially and the one who gets her hair lengthened, and also the lady who tattoos (herself or others) and the one who gets herself tattooed.


Bukhari :: Dress :: [7.72.824]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 824

Narrated Asma':

A woman asked the Prophet saying, "0 Allah's Apostle! My daughter got measles and her hair fell out. Now that I got her married, may I let her use false hair?" He said (to her), "Allah has cursed the lady who lengthens hair artificially and the one who gets her hair lengthened artificially."


Bukhari :: Dress :: [7.72.825]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 825

Narrated Ibn 'Umar :

I heard the Prophet saying, (or the Prophet said), "Allah has cursed the lady who practices tattooing and that who gets it done for herself, and also the lady who lengthens hair artificially and that who gets her hair lengthened artificially." The Prophet has cursed such ladies.


Bukhari :: Dress :: [7.72.826]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 826

Narrated Ibn Mas'ud:

Allah has cursed those women who practise tattooing or get it done for themselves, and those who remove hair from their faces, and those who create spaces between their teeth artificially to look beautiful, such ladies as change the features created by Allah. Why then shall I not curse those whom Allah's Apostle has cursed and who are cursed in Allah's Book too?


Bukhari :: Dress :: [7.72.827]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 827

Narrated Abu Huraira :

Allah's Apostle said, "The evil eye is a fact," and he forbade tattooing.


Bukhari :: Dress :: [7.72.828]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 828

Narrated 'Abdullah:

(As above 827).


Bukhari :: Dress :: [7.72.829]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 829

Narrated Abu Juhaifa:

The Prophet forbade the use of the price of blood and the price of a dog, the one who takes (eats) usury the one who gives usury, the woman who practises tattooing and the woman who gets herself tattooed.


Bukhari :: Dress :: [7.72.830]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 830

Narrated Abu Huraira :

A woman who used to practise tattooing was brought to 'Umar. 'Umar got up and said, "I beseech you by Allah, which of you heard the Prophet saying something about tattooing?" l got up and said, "0 chief of the Believers! l heard something." He said, "What did you hear?" I said, "I heard the Prophet (addressing the ladies), saying, 'Do not practise tattooing and do not get yourselves tattooed.'"


Bukhari :: Dress :: [7.72.831]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 831

Narrated Ibn 'Umar :

The Prophet has cursed the lady who lengthens hair artificially and that who gets her hair lengthened in such away, and the lady who practises tattooing and that who gets it done for herself.


Bukhari :: Dress :: [7.72.832]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 832

Narrated 'Abdullah :

Allah has cursed those women who practise tattooing and those who get it done for themselves, and those who remove hair from their faces, and those who artificially create spaces between their teeth to look beautiful, such women as alter the features created by Allah. Why should I not then curse those whom Allah's Apostle has cursed and that is in Allah's Book?


Bukhari :: Dress :: [7.72.833]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 833

Narrated Abu Talha :

The Prophet said, "Angels do not enter a house in which there is a dog or there are pictures."


Bukhari :: Dress :: [7.72.834]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 834

Narrated Muslim:

We were with Masruq at the house of Yasar bin Numair. Masruq saw pictures on his terrace and said, "I heard 'Abdullah saying that he heard the Prophet saying, "The people who will receive the severest punishment from Allah will be the picture makers.'"


Bukhari :: Dress :: [7.72.835]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 835

Narrated 'Abdullah bin 'Umar :

Allah's Apostle said, "Those who make these pictures will be punished on the Day of Resurrection, and it will be said to them. 'Make alive what you have created.'"


Bukhari :: Dress :: [7.72.836]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 836

Narrated 'Aisha:

I never used to leave in the Prophet house anything carrying images or crosses but he obliterated it.


Bukhari :: Dress :: [7.72.837]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 837

Narrated Abu Zur'a:

l entered a house in Medina with Abu Huraira, and he saw a man making pictures at the top of the house. Abu Huraira said, "I heard Allah's Apostle saying that Allah said, 'Who would be more unjust than the one who tries to create the like of My creatures? Let them create a grain: let them create a gnat.' "Abu Huraira then asked for a water container and washed his arms up to his armpits. I said, "0 Abu i Huraira! Is this something you have heard I from Allah's Apostle?" He said, "The limit for ablution is up to the place where the ornaments will reach on the Day of Resurrection.'


Bukhari :: Dress :: [7.72.838]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 838

Narrated 'Aisha:

Allah's Apostle returned from a journey when I had placed a curtain of mine having pictures over (the door of) a chamber of mine. When Allah's Apostle saw it, he tore it and said, "The people who will receive the severest punishment on the Day of Resurrection will be those who try to make the like of Allah's creations." So we turned it (i.e., the curtain) into one or two cushions.


Bukhari :: Dress :: [7.72.839]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 839

Narrated Aisha:

The Prophet returned from a journey when I had hung a thick curtain having pictures (in front of a door). He ordered me to remove it and I removed it. Aisha added: The Prophet and I used to take a bath from one container (of water).


Bukhari :: Dress :: [7.72.840]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 840

Narrated 'Aisha :

I purchased a cushion with pictures on it. The Prophet (came and) stood at the door but did not enter. I said (to him), "I repent to Allah for what (the guilt) I have done." He said, "What is this cushion?" I said, "It is for you to sit on and recline on." He said, "The makers of these pictures will be punished on the Day of Resurrection and it will be said to them, 'Make alive what you have created.' Moreover, the angels do not enter a house where there are pictures.'"


Bukhari :: Dress :: [7.72.841]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 841

Narrated Abu Talha:

Allah's Apostle said, "Angels (of mercy) do not enter a house where there are pictures.'" The sub-narrator Busr added: "Then Zaid fell ill and we paid him a visit. Behold! There was, hanging at his door, a curtain decorated with a picture. I said to 'Ubaidullah Al-Khaulani, the step son of Maimuna, the wife of the Prophet , "Didn't Zaid tell us about the picture the day before yesterday?" 'Ubaidullah said, "Didn't you hear him saying: 'except a design in a garment'?"


Bukhari :: Dress :: [7.72.842]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 842

Narrated Anas:

Aisha had a thick curtain (having pictures on it) and she screened the side of her i house with it. The Prophet said to her, "Remove it from my sight, for its pictures are still coming to my mind in my prayers."


Bukhari :: Dress :: [7.72.843]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 843

Narrated Salim's father:

Once Gabriel promised to visit the Prophet but he delayed and the Prophet got worried about that. At last he came out and found Gabriel and complained to him of his grief (for his delay). Gabriel said to him, "We do not enter a place in which there is a picture or a dog."


Bukhari :: Dress :: [7.72.844]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 844

Narrated 'Aisha:

(the wife of the Prophet)

I bought a cushion having pictures on it. When Allah's Apostle saw it, he stopped at the gate and did not enter. I noticed the signs of hatred (for that) on his face! I said, "O Allah's Apostle! I turn to Allah and His Apostle in repentance! What sin have I committed?" He said, "What about this cushion?" I said, 'I bought it for you to sit on and recline on." Allah's Apostle said, "The makers of these pictures will be punished (severely) on the Day of Resurrection and it will be said to them, 'Make alive what you have created.'" He added, "Angels do not enter a house in which there are pictures."


Bukhari :: Dress :: [7.72.845]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 845

Narrated Abu Juhaifa:

that he had bought a slave whose profession was cupping. The Prophet forbade taking the price of blood and the price of a dog and the earnings of a prostitute, and cursed the one who took or gave (Riba') usury, and the lady who tattooed others or got herself tattooed, and the picture-maker.


Bukhari :: Dress :: [7.72.846]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 846

Narrated Ibn 'Abbas:

I heard Muhammad saying, "Whoever makes a picture in this world will be asked to put life into it on the Day of Resurrection, but he will not be able to do so."


Bukhari :: Dress :: [7.72.847]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 847

Narrated Usama bin Zaid:

Allah's Apostle rode a donkey saddled with a saddle covered with a Fadakiyya velvet sheet, and he made me ride behind him.


Bukhari :: Dress :: [7.72.848]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 848

Narrated Ibn 'Abbas:

When the Prophet arrived at Mecca, the children of Bani 'Abdul Muttalib received him. He then mounted one of them in front of him and the other behind him.


Bukhari :: Dress :: [7.72.849]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 849

Narrated Aiyub:

The worst of three (persons riding one, animal) was mentioned in 'Ikrima's presence 'Ikrima said, "Ibn 'Abbas said, '(In the year of the conquest of Mecca) the Prophet came and mounted Qutham in front of him and Al-Fadl behind him, or Qutham behind him and Al-Fadl in front of him.' Now which of them was the worst off and which was the best?"


Bukhari :: Dress :: [7.72.850]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 850

Narrated Mu'adh bin Jabal

While I was riding behind the Prophet and between me and him and between me and him there was only the back of the saddle, he said, "0 Mu'adh!" I replied, "Labbaik, 0 Allah's Apostle, and Sa'daik!" he said, "Do you know what is Allah's right upon his slave?" I said, "Allah and His Apostle know best" He said "Allah's right upon his slaves is that they should worship Him alone and not worship anything else besides Him." Then he proceeded for a while and then said, "O Muadh bin Jabal!" I replied, "Labbaik, O Allah's Apostle:, Sa'daik!' He said, "Do you know what is the right of the slaves upon Allah if they do that?" I replied, "Allah and His Apostle know best." He said, "The right of the slaves upon Allah is that He will not punish them (if they do that)."


Bukhari :: Dress :: [7.72.851]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 851

Narrated Anas bin Malik :

We were coming from Khaibar along with Allah's Apostle while l was riding behind Abu Talha and he was proceeding. While one of the wives of Allah's Apostle was riding behind Allah's Apostle, suddenly the foot of the camel Slipped and I said, "The woman!" and alighted (hurriedly). Allah's Apostle said, "She is your mother." Sol resaddled the she-camel and Allah's Apostle mounted it. When he approached or saw Medina, he said, "Ayibun, ta'ibun, 'abidun, li-Rabbina hami-dun."


Bukhari :: Dress :: [7.72.852]

Dress

Bukhari :: Book 7 :: Volume 72 :: Hadith 852

Narrated 'Abbad bin Tamim's uncle:

I saw the Prophet lying-down in the mosque and placing one leg on the other.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.1]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 1

Narrated Al-Walid bin 'Aizar:

I heard Abi Amr 'Ash-Shaibani saying, "The owner of this house." he pointed to 'Abdullah's house, "said, 'I asked the Prophet 'Which deed is loved most by Allah?" He replied, 'To offer prayers at their early (very first) stated times.' " 'Abdullah asked, "What is the next (in goodness)?" The Prophet said, "To be good and dutiful to one's parents," 'Abdullah asked, "What is the next (in goodness)?" The Prophet said, To participate in Jihad for Allah's Cause." 'Abdullah added, "The Prophet narrated to me these three things, and if I had asked more, he would have told me more."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.2]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 2

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "O Allah's Apostle! Who is more entitled to be treated with the best companionship by me?" The Prophet said, "Your mother." The man said. "Who is next?" The Prophet said, "Your mother." The man further said, "Who is next?" The Prophet said, "Your mother." The man asked for the fourth time, "Who is next?" The Prophet said, "Your father. "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.3]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 3

Narrated 'Abdullah bin 'Amr:

A man said to the Prophet, "Shall I participate in Jihad?" The Prophet said, "Are your parents living?" The man said, "Yes." the Prophet said, "Do Jihad for their benefit."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.4]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 4

Narrated 'Abdullah bin 'Amr:

Allah's Apostle said. "It is one of the greatest sins that a man should curse his parents." It was asked (by the people), "O Allah's Apostle! How does a man curse his parents?" The Prophet said, "'The man abuses the father of another man and the latter abuses the father of the former and abuses his mother."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.5]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 5

Narrated Ibn 'Umar:

Allah's Apostle said, "While three persons were traveling, they were overtaken by rain and they took shelter in a cave in a mountain. A big rock fell from the mountain over the mouth of the cave and blocked it. They said to each other. 'Think of such good (righteous) deeds which, you did for Allah's sake only, and invoke Allah by giving reference to those deeds so that Allah may relieve you from your difficulty. one of them said, 'O Allah! I had my parents who were very old and I had small children for whose sake I used to work as a shepherd. When I returned to them at night and milked (the sheep), I used to start giving the milk to my parents first before giving to my children. And one day I went far away in search of a grazing place (for my sheep), and didn't return home till late at night and found that my parents had slept. I milked (my livestock) as usual and brought the milk vessel and stood at their heads, and I disliked to wake them up from their sleep, and I also disliked to give the milk to my children before my parents though my children were crying (from hunger) at my feet.

So this state of mine and theirs continued till the day dawned. (O Allah!) If you considered that I had done that only for seeking Your pleasure, then please let there be an opening through which we can see the sky.' So Allah made for them an opening through which they could see the sky. Then the second person said, 'O Allah! I had a she-cousin whom I loved as much as a passionate man love a woman. I tried to seduce her but she refused till I paid her one-hundred Dinars So I worked hard till I collected one hundred Dinars and went to her with that But when I sat in between her legs (to have sexual intercourse with her), she said, 'O Allah's slave! Be afraid of Allah ! Do not deflower me except legally (by marriage contract). So I left her O Allah! If you considered that I had done that only for seeking Your pleasure then please let the rock move a little to have a (wider) opening.'

So Allah shifted that rock to make the opening wider for them. And the last (third) person said 'O Allah ! I employed a laborer for wages equal to a Faraq (a certain measure: of rice, and when he had finished his job he demanded his wages, but when I presented his due to him, he gave it up and refused to take it. Then I kept on sowing that rice for him (several times) till managed to buy with the price of the yield, some cows and their shepherd Later on the laborer came to me an said. '(O Allah's slave!) Be afraid o Allah, and do not be unjust to me an give me my due.' I said (to him). 'Go and take those cows and their shepherd. So he took them and went away. (So, O Allah!) If You considered that I had done that for seeking Your pleasure, then please remove the remaining part of the rock.' And so Allah released them (from their difficulty)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.6]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 6

Narrated Al-Mughira:

The Prophet said, "Allah has forbidden you ( 1 ) to be undutiful to your mothers (2) to withhold (what you should give) or (3) demand (what you do not deserve), and (4) to bury your daughters alive. And Allah has disliked that (A) you talk too much about others ( B), ask too many questions (in religion), or (C) waste your property."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.7]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 7

Narrated Abu Bakra:

Allah's Apostle said thrice, "Shall I not inform you of the biggest of the great sins?" We said, "Yes, O Allah's Apostle" He said, "To join partners in worship with Allah: to be undutiful to one's parents." The Prophet sat up after he had been reclining and added, "And I warn you against giving forged statement and a false witness; I warn you against giving a forged statement and a false witness." The Prophet kept on saying that warning till we thought that he would not stop.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.8]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 8

Narrated Anas bin Malik:

Allah's Apostle mentioned the greatest sins or he was asked about the greatest sins. He said, "To join partners in worship with Allah; to kill a soul which Allah has forbidden to kill; and to be undutiful or unkind to one's parents." The Prophet added, "Shall I inform you of the biggest of the great sins? That is the forged statement or the false witness." Shu'ba (the sub-narrator) states that most probably the Prophet said, "the false witness."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.9]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 9

Narrated Asma' bint Abu Bakr:

My mother came to me, hoping (for my favor) during the lifetime of the Prophet asked the Prophet, "May I treat her kindly?" He replied, "Yes." Ibn 'Uyaina said, "Then Allah revealed: 'Allah forbids you not with regards to those who fought not against you because of religion, and drove you not out from your homes, that you should show them kindness and deal justly with them.'.......(60.8)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.10]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 10

Narrated Abu Sufyan:

That Heraclius sent for him and said, "What did he, i.e. the Prophet order you?" I replied, "He orders us to offer prayers; to give alms; to be chaste; and to keep good relations with our relatives.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.11]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 11

Narrated Ibn 'Umar:

My father, seeing a silken cloak being sold, said, "O Allah's Apostle! Buy this and wear it on Fridays and when the foreign delegates pay a visit to you." He said, "This is worn only by that person who will have no share in the Hereafter." Later a few silken cloaks were given to the Prophet as a gift, and he sent one of those cloaks to 'Umar. 'Umar said (to the Prophet), "How can I wear it while you have said about it what you said?" The Prophet said, "I did not give it to you to wear but to sell or to give to someone else to wear." So 'Umar sent it to his (pagan) brother who was from the inhabitants of Mecca before he ('Umar's brother) embraced Islam.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.12]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 12

Narrated Abu Aiyub Al-Ansari:

A man said, "O Allah's Apostle! Inform me of a deed which will make me enter Paradise." The people said, "What is the matter with him? What is the matter with him?" Allah's Apostle said, "He has something to ask (what he needs greatly)." The Prophet said (to him), (In order to enter Paradise) you should worship Allah and join none in worship with Him: You should offer prayers perfectly, give obligatory charity (Zakat), and keep good relations with your Kith and kin." He then said, "Leave it!" (The sub-narrator said, "It seems that the Prophet was riding his she camel."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.13]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 13

Narrated Jubair bin Mut'im:

That he heard the Prophet saying, "The person who severs the bond of kinship will not enter Paradise."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.14]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 14

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Who ever is pleased that he be granted more wealth and that his lease of life be pro longed, then he should keep good relations with his Kith and kin."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.15]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 15

Narrated Anas bin Malik:

Allah 's Apostle said, "Whoever loves that he be granted more wealth and that his lease of life be prolonged then he should keep good relations with his Kith and kin."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.16]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 16

Narrated Abu Huraira:

The Prophet said, "Allah created the creations, and when He finished from His creations, Ar-Rahm i.e., womb said, "(O Allah) at this place I seek refuge with You from all those who sever me (i.e. sever the ties of Kith and kin). Allah said, 'Yes, won't you be pleased that I will keep good relations with the one who will keep good relations with you, and I will sever the relation with the one who will sever the relations with you.' It said, 'Yes, O my Lord.' Allah said, 'Then that is for you ' " Allah's Apostle added. "Read (in the Qur'an) if you wish, the Statement of Allah: 'Would you then, if you were given the authority, do mischief in the land and sever your ties of kinship?' (47.22)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.17]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 17

Narrated Abu Huraira:

The Prophet said, "The word 'Ar-Rahm (womb) derives its name from Ar-Rahman (i.e., one of the names of Allah) and Allah said: 'I will keep good relation with the one who will keep good relation with you, (womb i.e. Kith and Kin) and sever the relation with him who will sever the relation with you, (womb, i.e. Kith and Kin).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.18]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 18

Narrated 'Aisha:

(the wife of the Prophet) The Prophet said, "The word 'Ar-Rahm' (womb) derives its name from 'Ar-Rahman' (i.e. Allah). So whosoever keeps good relations with it (womb i.e. Kith and kin), Allah will keep good relations with him, and whosoever will sever it (i.e. severs his bonds of Kith and kin) Allah too will sever His relations with him.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.19]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 19

Narrated 'Amr bin Al-'As:

I heard the Prophet saying openly not secretly, "The family of Abu so-and-so (i.e. Talib) are not among my protectors." 'Amr said that there was a blank space (1) in the Book of Muhammad bin Ja'far. He added, "My Protector is Allah and the righteous believing people." 'Amr bin Al-'As added: I heard the Prophet saying, 'But they (that family) have kinship (Rahm) with me and I will be good and dutiful to them. "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.20]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 20

Narrated Abdullah bin 'Amr:

The Prophet said, "Al-Wasil is not the one who recompenses the good done to him by his relatives, but Al-Wasil is the one who keeps good relations with those relatives who had severed the bond of kinship with him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.21]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 21

Narrated Hakim bin Hizam:

That he said, "O Allah's Apostle! What do you think about my good deeds which I used to do during the period of ignorance (before embracing Islam) like keeping good relations with my Kith and kin, manumitting of slaves and giving alms etc; Shall I receive the reward for that?" Allah's Apostle said, "You have embraced Islam with all those good deeds which you did.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.22]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 22

Narrated Sa'id:

Um Khalid bint Khalid bin Said said, "I came to Allah's Apostle along with my father and I was wearing a yellow shirt. Allah's Apostle said, "Sanah Sanah!" ('Abdullah, the sub-narrator said, "It means, 'Nice, nice!' in the Ethiopian language.") Um Khalid added, "Then I started playing with the seal of Prophethood. My father admonished me. But Allah's Apostle said (to my father), "Leave her," Allah's Apostle (then addressing me) said, "May you live so long that your dress gets worn out, and you will mend it many times, and then wear another till it gets worn out (i.e. May Allah prolong your life)." (The sub-narrator, 'Abdullah aid, "That garment (which she was wearing remained usable for a long


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.23]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 23

Narrated Ibn Abi Na'm:

-smelling flowers in this world."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.24]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 24

Narrated 'Aisha:

(the wife of the Prophet) A lady along with her two daughters came to me asking me (for some alms), but she found nothing with me except one date which I gave to her and she divided it between her two daughters, and then she got up and went away. Then the Prophet came in and I informed him about this story. He said, "Whoever is in charge of (put to test by) these daughters and treats them generously, then they will act as a shield for him from the (Hell) Fire."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.25]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 25

Narrated Abu Qatada:

The Prophet came out towards us, while carrying Umamah, the daughter of Abi Al-As (his grand-daughter) over his shoulder. He prayed, and when he wanted to bow, he put her down, and when he stood up, he lifted her up.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.26]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 26

Narrated Abu Huraira:

Allah's Apostle kissed Al-Hasan bin Ali while Al-Aqra' bin Habis At-Tamim was sitting beside him. Al-Aqra said, "I have ten children and I have never kissed anyone of them," Allah's Apostle cast a look at him and said, "Whoever is not merciful to others will not be treated mercifully."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.27]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 27

Narrated 'Aisha:

A bedouin came to the Prophet and said, "You (people) kiss the boys! We don't kiss them." The Prophet said, "I cannot put mercy in your heart after Allah has taken it away from it."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.28]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 28

Narrated 'Umar bin Al-Khattab:

Some Sabi (i.e. war prisoners, children and woman only) were brought before the Prophet and behold, a woman amongst them was milking her breasts to feed and whenever she found a child amongst the captives, she took it over her chest and nursed it (she had lost her child but later she found him) the Prophet said to us, "Do you think that this lady can throw her son in the fire?" We replied, "No, if she has the power not to throw it (in the fire)." The Prophet then said, "Allah is more merciful to His slaves than this lady to her son."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.29]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 29

Narrated Abu Huraira:

I heard Allah's Apostle saying, Allah divided Mercy into one-hundred parts and He kept its ninety-nine parts with Him and sent down its one part on the earth, and because of that, its one single part, His creations are Merciful to each other, so that even the mare lifts up its hoofs away from its baby animal, lest it should trample on it."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.30]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 30

Narrated 'Abdullah:

I said 'O Allah's Apostle! Which sin is the greatest?" He said, "To set up a rival unto Allah, though He Alone created you." I said, "What next?" He said, "To kill your son lest he should share your food with you." I further asked, "What next?" He said, "To commit illegal sexual intercourse with the wife of your neighbor." And then Allah revealed as proof of the statement of the Prophet: 'Those who invoke not with Allah any other god)................. (to end of verse)...' (25.68)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.31]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 31

Narrated 'Aisha:

The Prophet took a child in his lap for Tahnik (i.e. he chewed a date in his mouth and put its juice in the mouth of the child). The child urinated on him, so he asked for water and poured it over the place of the urine.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.32]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 32

Narrated Usama bin Zaid:

Allah's Apostle used to put me on (one of) his thighs and put Al-Hasan bin 'Ali on his other thigh, and then embrace us and say, "O Allah! Please be Merciful to them, as I am merciful to them. "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.33]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 33

Narrated 'Aisha:

I never felt so jealous of any woman as I did of Khadija, though she had died three years before the Prophet married me, and that was because I heard him mentioning her too often, and because his Lord had ordered him to give her the glad tidings that she would have a palace in Paradise, made of Qasab and because he used to slaughter a sheep and distribute its meat among her friends.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.34]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 34

Narrated Sahl bin Sa'd:

The Prophet said, "I and the person who looks after an orphan and provides for him, will be in Paradise like this," putting his index and middle fingers together.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.35]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 35

Narrated Safwan bin Salim:

The Prophet said "The one who looks after and works for a widow and for a poor person, is like a warrior fighting for Allah's Cause or like a person who fasts during the day and prays all the night." Narrated Abu Huraira that the Prophet said as above.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.36]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 36

Narrated Abu Huraira:

Allah's Apostle said, "The one who looks after and works for a widow and for a poor person is like a warrior fighting for Allah's Cause." (The narrator Al-Qa'nabi is not sure whether he also said "Like the one who prays all the night without slackness and fasts continuously and never breaks his fast.")


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.37]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 37

Narrated Abu Sulaiman and Malik bin Huwairith:

We came to the Prophet and we were (a few) young men of approximately equal age and stayed with him for twenty nights. Then he thought that we were anxious for our families, and he asked us whom we had left behind to look after our families, and we told him. He was kindhearted and merciful, so he said, "Return to your families and teach them (religious knowledge) and order them (to do good deeds) and offer your prayers in the way you saw me offering my prayers, and when the stated time for the prayer becomes due, then one of you should pronounce its call (i.e. the Adhan), and the eldest of you should lead you in prayer.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.38]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 38

Narrated Abu Huraira:

Allah's Apostle said, "While a man was walking on a road. he became very thirsty. Then he came across a well, got down into it, drank (of its water) and then came out. Meanwhile he saw a dog panting and licking mud because of excessive thirst. The man said to himself "This dog is suffering from the same state of thirst as I did." So he went down the well (again) and filled his shoe (with water) and held it in his mouth and watered the dog. Allah thanked him for that deed and forgave him." The people asked, "O Allah's Apostle! Is there a reward for us in serving the animals?" He said, "(Yes) There is a reward for serving any animate (living being) ."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.39]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 39

Narrated Abu Huraira:

Allah's Apostle stood up for the prayer and we too stood up along with him. Then a bedouin shouted while offering prayer. "O Allah! Bestow Your Mercy on me and Muhammad only and do not bestow it on anybody else along with us." When the Prophet had finished his prayer with Taslim, he said to the Bedouin, "You have limited (narrowed) a very vast (thing)," meaning Allah's Mercy.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.40]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 40

Narrated An-Nu'man bin Bashir:

Allah's Apostle said, "You see the believers as regards their being merciful among themselves and showing love among themselves and being kind, resembling one body, so that, if any part of the body is not well then the whole body shares the sleeplessness (insomnia) and fever with it."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.41]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 41

Narrated Anas bin Malik:

The Prophet said, "If any Muslim plants any plant and a human being or an animal eats of it, he will be rewarded as if he had given that much in charity."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.42]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 42

Narrated Jarir bin 'Abdullah:

The Prophet said, "He who is not merciful to others, will not be treated mercifully.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.43]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 43

Narrated 'Aisha:

The Prophet said "Gabriel continued to recommend me about treating the neighbors Kindly and politely so much so that I thought he would order me to make them as my heirs.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.44]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 44

Narrates Ibn Umar:

Allah' Apostle said, Gabriel kept on recommending me about treating the neighbors in a kind and polite manner, so much so that I thought that he would order (me) to make them (my) heirs."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.45]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 45

Narrated Abu Shuraih:

The Prophet said, "By Allah, he does not believe! By Allah, he does not believe! By Allah, he does not believe!" It was said, "Who is that, O Allah's Apostle?" He said, "That person whose neighbor does not feel safe from his evil."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.46]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 46

Narrated Abu Huraira:

The Prophet used to say, "O Muslim ladies! A neighbouress should not look down upon the present of her neighbouress even it were the hooves of a sheep."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.47]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 47

Narrated Abu Huraira:

Allah's Apostle said, "Anybody who believes in Allah and the Last Day should not harm his neighbor, and anybody who believes in Allah and the Last Day should entertain his guest generously and anybody who believes in Allah and the Last Day should talk what is good or keep quiet. (i.e. abstain from all kinds of evil and dirty talk).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.48]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 48

Narrated Abu Shuraih Al-Adawi:

My ears heard and my eyes saw the Prophet when he spoke, "Anybody who believes in Allah and the Last Day, should serve his neighbor generously, and anybody who believes in Allah and the Last Day should serve his guest generously by giving him his reward." It was asked. "What is his reward, O Allah's Apostle?" He said, "(To be entertained generously) for a day and a night with high quality of food and the guest has the right to be entertained for three days (with ordinary food) and if he stays longer, what he will be provided with will be regarded as Sadaqa (a charitable gift). And anybody who believes in Allah and the Last Day should talk what is good or keep quite (i.e. abstain from all kinds of dirty and evil talks)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.49]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 49

Narrated 'Aisha:

I said, "O Allah's Apostle! I have two neighbors! To whom shall I send my gifts?" He said, "To the one whose gate in nearer to you."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.50]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 50

Narrated Jabir bin 'Abdullah:

The Prophet said, Enjoining, all that is good is a Sadaqa."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.51]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 51

Narrated Abu Musa Al-Ash'ari:

The Prophet said, "On every Muslim there is enjoined (a compulsory) Sadaqa (alms)." They (the people) said, "If one has nothing?' He said, "He should work with his hands so that he may benefit himself and give in charity." They said, "If he cannot work or does not work?" He said, "Then he should help the oppressed unhappy person (by word or action or both)." They said, "If he does not do it?" He said, "Then he should enjoin what is good (or said what is reasonable).' They said, "If he does not do that''' He said, "Then he should refrain from doing evil, for that will be considered for Him as a Sadaqa (charity) . "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.52]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 52

Narrated 'Adi bin Hatim:

The Prophet mentioned the (Hell) Fire and sought refuge (with Allah) from it, and turned his face to the other side. He mentioned the (Hell) Fire again and took refuge (with Allah) from it and turned his face to the other side. (Shu'ba, the sub-narrator, said, "I have no doubt that the Prophet repeated it twice.") The Prophet then said, "(O people!) Save yourselves from the (Hell) Fire even if with one half of a date fruit (given in charity), and if this is not available, then (save yourselves) by saying a good pleasant friendly word."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.53]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 53

Narrated 'Aisha:

(the wife of the Prophet) A group of Jews entered upon the Prophet and said, "As-Samu-Alaikum." (i.e. death be upon you). I understood it and said, "Wa-Alaikum As-Samu wal-la'n. (death and the curse of Allah be Upon you)." Allah's Apostle said "Be calm, O 'Aisha! Allah loves that on, should be kind and lenient in all matters." I said, "O Allah's Apostle! Haven't you heard what they (the Jews) have said?" Allah's Apostle said "I have (already) said (to them) "And upon you ! "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.54]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 54

Narrated Anas bin Malik:

A bedouin urinated in the mosque and the people ran to (beat) him. Allah's Apostle said, "Do not interrupt his urination (i.e. let him finish)." Then the Prophet asked for a tumbler of water and poured the water over the place of urine.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.55]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 55

Narrated Abu Musa:

The Prophet said, "A believer to another believer is like a building whose different parts enforce each other." The Prophet then clasped his hands with the fingers interlaced. (At that time) the Prophet was sitting and a man came and begged or asked for something. The Prophet faced us and said, "Help and recommend him and you will receive the reward for it, and Allah will bring about what He will through His Prophet's tongue."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.56]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 56

Narrated Masruq:

Abdullah bin 'Amr mentioned Allah's Apostle saying that he was neither a Fahish nor a Mutafahish. Abdullah bin 'Amr added, Allah's Apostle said, 'The best among you are those who have the best manners and character.'


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.57]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 57

Narrated 'Abdullah bin Mulaika:

'Aisha said that the Jews came to the Prophet and said, "As-Samu 'Alaikum" (death be on you). 'Aisha said (to them), "(Death) be on you, and may Allah curse you and shower His wrath upon you!" The Prophet said, "Be calm, O 'Aisha ! You should be kind and lenient, and beware of harshness and Fuhsh (i.e. bad words)." She said (to the Prophet), "Haven't you heard what they (Jews) have said?" He said, "Haven't you heard what I have said (to them)? I said the same to them, and my invocation against them will be accepted while theirs against me will be rejected (by Allah). "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.58]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 58

Narrated Anas bin Malik:

The Prophet was not one who would abuse (others) or say obscene words, or curse (others), and if he wanted to admonish anyone of us, he used to say: "What is wrong with him, his forehead be dusted!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.59]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 59

Narrated Anas:

The Prophet was the best among the people (both in shape and character) and was the most generous of them, and was the bravest of them. Once, during the night, the people of Medina got afraid (of a sound). So the people went towards that sound, but the Prophet having gone to that sound before them, met them while he was saying, "Don't be afraid, don't be afraid." (At that time) he was riding a horse belonging to Abu Talha and it was naked without a saddle, and he was carrying a sword slung at his neck. The Prophet said, "I found it (the horse) like a sea, or, it is the sea indeed."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.60]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 60

Narrated Jabir:

Never was the Prophet asked for a thing to be given for which his answer was 'no'.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.61]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 61

Narrated Masruq:

We were sitting with 'Abdullah bin 'Amr who was narrating to us (Hadith): He said, "Allah's Apostle was neither a Fahish nor a Mutafahhish, and he used to say, 'The best among you are the best in character (having good manners)."'


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.62]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 62

Narrated Abu Hazim:

Sahl bin Sa'd said that a woman brought a Burda (sheet) to the Prophet. Sahl asked the people, "Do you know what is a Burda?" The people replied, "It is a 'Shamla', a sheet with a fringe." That woman said, "O Allah's Apostle! I have brought it so that you may wear it." So the Prophet took it because he was in need of it and wore it. A man among his companions, seeing him wearing it, said, "O Allah's Apostle! Please give it to me to wear." The Prophet said, "Yes." (and gave him that sheet). When the Prophet left, the man was blamed by his companions who said, "It was not nice on your part to ask the Prophet for it while you know that he took it because he was in need of it, and you also know that he (the Prophet) never turns down anybody's request that he might be asked for." That man said, "I just wanted to have its blessings as the Prophet had put it on, so l hoped that I might be shrouded in it."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.63]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 63

Narrated Abu Huraira:

Allah's Apostle said, "Time will pass rapidly, good deeds will decrease, and miserliness will be thrown (in the hearts of the people), and the Harj (will increase)." They asked, "What is the Harj?" He replied, "(It is) killing (murdering), (it is) murdering (killing).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.64]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 64

Narrated Anas:

I served the Prophet for ten years, and he never said to me, "Uf" (a minor harsh word denoting impatience) and never blamed me by saying, "Why did you do so or why didn't you do so?"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.65]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 65

Narrated Al-Aswad:

I asked 'Aisha what did the Prophet use to do at home. She replied. "He used to keep himself busy serving his family and when it was time for the prayer, he would get up for prayer."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.66]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 66

Narrated Abu Huraira:

The Prophet said, "If Allah loves a person, He calls Gabriel saying: 'Allah loves so and so; O Gabriel, love him.' Gabriel would love him, and then Gabriel would make an announcement among the residents of the Heaven, 'Allah loves so-and-so, therefore, you should love him also.' So, all the residents of the Heavens would love him and then he is granted the pleasure of the people of the earth."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.67]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 67

Narrated Anas bin Malik:

The Prophet said, "None will have the sweetness (delight) of Faith (a) till he loves a person and loves him only for Allah's sake, (b) and till it becomes dearer to him to be thrown in the fire than to revert to disbelief (Heathenism) after Allah has brought him out of it, (c) and till Allah and His Apostle become dearer to him than anything else."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.68]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 68

Narrated 'Abdullah bin Zam'a:

The Prophet forbade laughing at a person who passes wind, and said, "How does anyone of you beat his wife as he beats the stallion camel and then he may embrace (sleep with) her?" And Hisham said, "As he beats his slave"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.69]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 69

Narrated Ibn 'Umar:

The Prophet said at Mina, "Do you know what day is today?" They (the people) replied, "Allah and His Apostle know better," He said "Today is 10th of Dhul-Hijja, the sacred (forbidden) day. Do you know what town is this town?" They (the people) replied, "Allah and His Apostle know better." He said, "This is the (forbidden) Sacred town (Mecca a sanctuary)." And do you know which month is this month?" They (the People) replied, "Allah and His Apostle know better." He said, ''This is the Sacred (forbidden) month ." He added, "Allah has made your blood, your properties and your honor Sacred to one another (i.e. Muslims) like the sanctity of this day of yours in this month of yours, in this town of yours." (See Hadith No. 797, Vol. 2.)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.70]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 70

Narrated 'Abdullah:

Allah's Apostle said, "Abusing a Muslim is Fusuq (i.e., an evil-doing), and killing him is Kufr (disbelief)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.71]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 71

Narrated Abu Dhar:

That he heard the Prophet saying, "If somebody accuses another of Fusuq (by calling him 'Fasiq' i.e. a wicked person) or accuses him of Kufr, such an accusation will revert to him (i.e. the accuser) if his companion (the accused) is innocent."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.72]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 72

Narrated Anas:

Allah's Apostle was neither a Fahish (one who had a bad tongue) nor a Sabbaba (one who abuses others) and he used to say while admonishing somebody, "What is wrong with him? May dust be on his forehead!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.73]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 73

Narrated Thabit bin Ad-Dahhak:

(who was one of the companions who gave the pledge of allegiance to the Prophet underneath the tree (Al-Hudaibiya)) Allah's Apostle said, "Whoever swears by a religion other than Islam (i.e. if somebody swears by saying that he is a non-Muslim e.g., a Jew or a Christian, etc.) in case he is telling a lie, he is really so if his oath is false, and a person is not bound to fulfill a vow about a thing which he does not possess. And if somebody commits suicide with anything in this world, he will be tortured with that very thing on the Day of Resurrection; And if somebody curses a believer, then his sin will be as if he murdered him; And whoever accuses a believer of Kufr (disbelief), then it is as if he killed him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.74]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 74

Narrated Sulaiman bin Surad:

A man from the companions of the Prophet said, "Two men abused each other in front of the Prophet and one of them became angry and his anger became so intense that his face became swollen and changed. The Prophet said, "I know a word the saying of which will cause him to relax if he does say it." Then a man went to him and informed him of the statement of the Prophet and said, "Seek refuge with Allah from Satan." On that, angry man said, 'Do you find anything wrong with me? Am I insane? Go away!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.75]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 75

Narrated 'Ubada bin As-Samit:

Allah's Apostle went out to inform the people about the (date of the Night of decree (Al-Qadr). There happened a quarrel between two Muslim men. The Prophet said, "I came out to inform you about the Night of Al-Qadr, but as so-and-so and so-and-so quarrelled, so the news about it had been taken away; and may be it was better for you. So look for it in the ninth, the seventh, or the fifth (of the last ten days of Ramadan)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.76]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 76

Narrated Ma'rur:

I saw Abu Dhar wearing a Burd (garment) and his slave too was wearing a Burd, so I said (to Abu Dhar), "If you take this (Burda of your slave) and wear it (along with yours), you will have a nice suit (costume) and you may give him another garment." Abu Dhar said, "There was a quarrel between me and another man whose mother was a non-Arab and I called her bad names. The man mentioned (complained about) me to the Prophet. The Prophet said, "Did you abuse so-and-so?" I said, "Yes" He said, "Did you call his mother bad names?" I said, "Yes". He said, "You still have the traits of (the Pre-lslamic period of) ignorance." I said. "(Do I still have ignorance) even now in my old age?" He said, "Yes, they (slaves or servants) are your brothers, and Allah has put them under your command. So the one under whose hand Allah has put his brother, should feed him of what he eats, and give him dresses of what he wears, and should not ask him to do a thing beyond his capacity. And if at all he asks him to do a hard task, he should help him therein."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.77]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 77

Narrated Abu Huraira:

The Prophet led us in the Zuhr prayer, offering only two Rakat and then (finished it) with Taslim, and went to a piece of wood in front of the mosque and put his hand over it. Abu Bakr and 'Umar were also present among the people on that day but dared not talk to him (about his unfinished prayer). And the hasty people went away, wondering. "Has the prayer been shortened" Among the people there was a man whom the Prophet used to call Dhul-Yadain (the longarmed). He said, "O Allah's Prophet! Have you forgotten or has the prayer been shortened?" The Prophet said, "Neither have I forgotten, nor has it been shortened." They (the people) said, "Surely, you have forgotten, O Allah's Apostle!" The Prophet said, Dhul-Yadain has told the truth." So the Prophet got up and offered other two Rakat and finished his prayer with Taslim. Then he said Takbir, performed a prostration of ordinary duration or longer, then he raised his head and said Takbir and performed another prostration of ordinary duration or longer and then raised his head and said Takbir (i.e. he performed the two prostrations of Sahu, i.e., forgetfulness)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.78]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 78

Narrated Ibn 'Abbas:

Allah's Apostle passed by two graves and said, "Both of them (persons in the grave) are being tortured, and they are not being tortured for a major sin. This one used not to save himself from being soiled with his urine, and the other used to go about with calumnies (among the people to rouse hostilities, e.g., one goes to a person and tells him that so-and-so says about him such-and-such evil things). The Prophet then asked for a green leaf of a date-palm tree, split it into two pieces and planted one on each grave and said, "It is hoped that their punishment may be abated till those two pieces of the leaf get dried." (See Hadith No 215, Vol 1).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.79]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 79

Narrated Abu Usaid As-Sa'idi:

The Prophet said, "The best family among the Ansar is the Banu An-Najjar. "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.80]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 80

Narrated 'Aisha:

A man asked permission to enter upon Allah's Apostle. The Prophet said, "Admit him. What an evil brother of his people or a son of his people." But when the man entered, the Prophet spoke to him in a very polite manner. (And when that person left) I said, "O Allah's Apostle! You had said what you had said, yet you spoke to him in a very polite manner?" The Prophet said, "O 'Aisha! The worst people are those whom the people desert or leave in order to save themselves from their dirty language or from their transgression."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.81]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 81

Narrated Ibn 'Abbas:

Once the Prophet went through the grave-yards of Medina and heard the voices of two humans who were being tortured in their graves. The Prophet said, "They are being punished, but they are not being punished because of a major sin, yet their sins are great. One of them used not to save himself from (being soiled with) the urine, and the other used to go about with calumnies (Namima)." Then the Prophet asked for a green palm tree leaf and split it into two pieces and placed one piece on each grave, saying, "I hope that their punishment may be abated as long as these pieces of the leaf are not dried."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.82]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 82

Narrated Hudhaifa:

I heard the Prophet saying, "A Qattat will not enter Paradise."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.83]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 83

Narrated Abu Huraira:

The Prophet said, "Whoever does not give up false statements (i.e. telling lies), and evil deeds, and speaking bad words to others, Allah is not in need of his (fasting) leaving his food and drink."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.84]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 84

Narrated Abu Huraira:

The Prophet said, "The worst people in the Sight of Allah on the Day of Resurrection will be the double faced people who appear to some people with one face and to other people with another face."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.85]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 85

Narrated Ibn Mas'ud:

Once Allah's Apostle divided and distributed (the war booty). An Ansar man said, "By Allah ! Muhammad, by this distribution, did not intend to please Allah." So I came to Allah's Apostle and informed him about it whereupon his face became changed with anger and he said, "May Allah bestow His Mercy on Moses for he was hurt with more than this, yet he remained patient."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.86]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 86

Narrated Abu Musa:

The Prophet heard a man praising another man and he was exaggerating in his praise. The Prophet said (to him). "You have destroyed (or cut) the back of the man."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.87]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 87

Narrated Abu Bakra:

A man was mentioned before the Prophet and another man praised him greatly The Prophet said, "May Allah's Mercy be on you ! You have cut the neck of your friend." The Prophet repeated this sentence many times and said, "If it is indispensable for anyone of you to praise someone, then he should say, 'I think that he is so-and-so," if he really thinks that he is such. Allah is the One Who will take his accounts (as He knows his reality) and no-one can sanctify anybody before Allah." (Khalid said, "Woe to you," instead of "Allah's Mercy be on you.")


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.88]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 88

Narrated Salim:

that his father said; "When Allah's Apostle mentioned wh at he mentioned about (the hanging of) the Izar (waist sheet), Abu Bakr said, "O Allah's Apostle! My Izar slackens on one side (without my intention)." The Prophet said, "You are not among those (who, out of pride) drag their Izars behind them."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.89]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 89

Narrated 'Aisha:

The Prophet continued for such-and-such period imagining that he has slept (had sexual relations) with his wives, and in fact he did not. One day he said, to me, "O 'Aisha! Allah has instructed me regarding a matter about which I had asked Him. There came to me two men, one of them sat near my feet and the other near my head. The one near my feet, asked the one near my head (pointing at me), 'What is wrong with this man? The latter replied, 'He is under the effect of magic.' The first one asked, 'Who had worked magic on him?' The other replied, 'Lubaid bin Asam.' The first one asked, 'What material (did he use)?' The other replied, 'The skin of the pollen of a male date tree with a comb and the hair stuck to it, kept under a stone in the well of Dharwan."' Then the Prophet went to that well and said, "This is the same well which was shown to me in the dream. The tops of its date-palm trees look like the heads of the devils, and its water looks like the Henna infusion." Then the Prophet ordered that those things be taken out. I said, "O Allah's Apostle! Won't you disclose (the magic object)?" The Prophet said, "Allah has cured me and I hate to circulate the evil among the people." 'Aisha added, "(The magician) Lubaid bin Asam was a man from Bani Zuraiq, an ally of the Jews."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.90]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 90

Narrated Abu Huraira:

The Prophet said, "Beware of suspicion, for suspicion is the worst of false tales; and do not look for the others' faults and do not spy, and do not be jealous of one another, and do not desert (cut your relation with) one another, and do not hate one another; and O Allah's worshipers! Be brothers (as Allah has ordered you!")


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.91]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 91

Narrated Anas bin Malik:

Allah's Apostle said, "Do not hate one another, and do not be jealous of one another, and do not desert each other, and O, Allah's worshipers! Be brothers. Lo! It is not permissible for any Muslim to desert (not talk to) his brother (Muslim) for more than three days."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.92]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 92

Narrated Abu Huraira:

Allah's Apostle said, "Beware of suspicion, for suspicion is the worst of false tales. and do not look for the others' faults, and do not do spying on one another, and do not practice Najsh, and do not be jealous of one another and do not hate one another, and do not desert (stop talking to) one another. And O, Allah's worshipers! Be brothers!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.93]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 93

Narrated 'Aisha:

The Prophet said, "I do not think that so-and-so and so-and-so know anything of our religion." (And Al-Laith said, "These two persons were among the hypocrites.")


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.94]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 94

Narrated Al-Laith:

'Aisha said "The Prophet entered upon me one day and said, 'O 'Aisha! I do not think that so-and-so and so-and-so know anything of our religion which we follow."'


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.95]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 95

Narrated Abu Huraira:

I heard Allah's Apostle saying. "All the sins of my followers will be forgiven except those of the Mujahirin (those who commit a sin openly or disclose their sins to the people). An example of such disclosure is that a person commits a sin at night and though Allah screens it from the public, then he comes in the morning, and says, 'O so-and-so, I did such-and-such (evil) deed yesterday,' though he spent his night screened by his Lord (none knowing about his sin) and in the morning he removes Allah's screen from himself."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.96]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 96

Narrated Safwan bin Muhriz:

A man asked Ibn 'Umar, "What did you hear Allah's Apostle saying regarding An-Najwa (secret talk between Allah and His believing worshipper on the Day of Judgment)?" He said, "(The Prophet said), "One of you will come close to his Lord till He will shelter him in His screen and say: Did you commit such-and-such sin? He will say, 'Yes.' Then Allah will say: Did you commit such and such sin? He will say, 'Yes.' So Allah will make him confess (all his sins) and He will say, 'I screened them (your sins) for you in the world, and today I forgive them for you."'


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.97]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 97

Narrated Haritha bin Wahb:

Al-Khuzai: The Prophet said, "Shall I inform you about the people of Paradise? They comprise every obscure unimportant humble person, and if he takes Allah's Oath that he will do that thing, Allah will fulfill his oath (by doing that). Shall I inform you about the people of the Fire? They comprise every cruel, violent, proud and conceited person." Anas bin Malik said, "Any of the female slaves of Medina could take hold of the hand of Allah's Apostle and take him wherever she wished."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.98]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 98

Narrated 'Aisha:

(the wife of the Prophet) that she was told that 'Abdullah bin Az-Zubair (on hearing that she was selling or giving something as a gift) said, "By Allah, if 'Aisha does not give up this, I will declare her incompetent to dispose of her wealth." I said, "Did he ('Abdullah bin Az-Zubair) say so?" They (people) said, "Yes." 'Aisha said, "I vow to Allah that I will never speak to Ibn Az-Zubair." When this desertion lasted long, 'Abdullah bin Az-Zubair sought intercession with her, but she said, "By Allah, I will not accept the intercession of anyone for him, and will not commit a sin by breaking my vow." When this state of affairs was prolonged on Ibn Az-Zubair (he felt it hard on him), he said to Al-Miswar bin Makhrama and 'Abdur-Rahman bin Al-Aswad bin 'Abu Yaghuth, who were from the tribe of Bani Zahra, "I beseech you, by Allah, to let me enter upon 'Aisha, for it is unlawful for her to vow to cut the relation with me." So Al-Miswar and 'Abdur-Rahman, wrapping their sheets around themselves, asked 'Aisha's permission saying, "Peace and Allah's Mercy and Blessings be upon you! Shall we come in?" 'Aisha said, "Come in." They said, "All of us?" She said, "Yes, come in all of you," not knowing that Ibn Az-Zubair was also with them. So when they entered, Ibn Az-Zubair entered the screened place and got hold of 'Aisha and started requesting her to excuse him, and wept. Al-Miswar and 'Abdur Rahman also started requesting her to speak to him and to accept his repentance. They said (to her), "The Prophet forbade what you know of deserting (not speaking to your Muslim Brethren), for it is unlawful for any Muslim not to talk to his brother for more than three nights (days)." So when they increased their reminding her (of the superiority of having good relation with Kith and kin, and of excusing others' sins), and brought her down to a critical situation, she started reminding them, and wept, saying, "I have made a vow, and (the question of) vow is a difficult one." They (Al-Miswar and 'Abdur-Rahman) persisted in their appeal till she spoke with 'Abdullah bin Az-Zubair and she manumitted forty slaves as an expiation for her vow. Later on, whenever she remembered her vow, she used to weep so much that her veil used to become wet with her tears.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.99]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 99

Narrated Anas bin Malik:

Allah's Apostle said, "Do not hate one another, nor be jealous of one another; and do not desert one another, but O Allah's worshipers! Be Brothers! And it is unlawful for a Muslim to desert his brother Muslim (and not to talk to him) for more than three nights."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.100]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 100

Narrated Abu Aiyub Al-Ansari:

Allah's Apostle said, "It is not lawful for a man to desert his brother Muslim for more than three nights. (It is unlawful for them that) when they meet, one of them turns his face away from the other, and the other turns his face from the former, and the better of the two will be the one who greets the other first."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.101]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 101

Narrated 'Aisha:

Allah's Apostle said, " I know whether you are angry or pleased." I said, "How do you know that, Allah's Apostle?" He said, "When you are pleased, you say, "Yes, by the Lord of Muhammad,' but when you are angry, you say, 'No, by the Lord of Abraham!' " I said, "Yes, I do not leave, except your name."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.102]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 102

Narrated 'Aisha:

(the wife of the Prophet) "I do not remember my parents believing in any religion other than the Religion (of Islam), and our being visited by Allah's Apostle in the morning and in the evening. One day, while we were sitting in the house of Abu Bakr (my father) at noon, someone said, 'This is Allah's Apostle coming at an hour at which he never used to visit us.' Abu Bakr said, 'There must be something very urgent that has brought him at this hour.' The Prophet said, 'I have been allowed to go out (of Mecca) to migrate.' "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.103]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 103

Narrated Anas bin Malik:

Allah's Apostle visited a household among the Ansars, and he took a meal with them. When he intended to leave, he asked for a place in that house for him, to pray so a mat sprinkled with water was put and he offered prayer over it, and invoked for Allah's Blessing upon them (his hosts).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.104]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 104

Narrated 'Abdullah:

'Umar saw a silken cloak over a man (for sale) so he took it to the Prophet and said, 'O Allah's Apostle! Buy this and wear it when the delegate come to you.' He said, 'The silk is worn by one who will have no share (in the Here-after).' Some time passed after this event, and then the Prophet sent a (similar) cloak to him. 'Umar brought that cloak back to the Prophet and said, 'You have sent this to me, and you said about a similar one what you said?' The Prophet said, 'I have sent it to you so that you may get money by selling it.' Because of this, Ibn 'Umar used to hate the silken markings on the garments.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.105]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 105

Narrated Anas:

When 'Abdur-Rahman came to us, the Prophet established a bond of brotherhood between him and Sa'd bin Ar-Rabi'. Once the Prophet said, "As you (O 'Abdur-Rahman) have married, give a wedding banquet even if with one sheep."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.106]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 106

Narrated 'Asim:

I said to Anas bin Malik, "Did it reach you that the Prophet said, "There is no treaty of brotherhood in Islam'?" Anas said, "The Prophet made a treaty (of brotherhood) between the Ansar and the Quraish in my home."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.107]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 107

Narrated 'Aisha:

Rifa'a Al-Qurazi divorced his wife irrevocably (i.e. that divorce was the final). Later on 'Abdur-Rahman bin Az-Zubair married her after him. She came to the Prophet and said, "O Allah's Apostle! I was Rifa'a's wife and he divorced me thrice, and then I was married to 'Abdur-Rahman bin AzZubair, who, by Allah has nothing with him except something like this fringe, O Allah's Apostle," showing a fringe she had taken from her covering sheet. Abu Bakr was sitting with the Prophet while Khalid Ibn Said bin Al-As was sitting at the gate of the room waiting for admission. Khalid started calling Abu Bakr, "O Abu Bakr! Why don't you reprove this lady from what she is openly saying before Allah's Apostle?" Allah's Apostle did nothing except smiling, and then said (to the lady), "Perhaps you want to go back to Rifa'a? No, (it is not possible), unless and until you enjoy the sexual relation with him ('Abdur Rahman), and he enjoys the sexual relation with you."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.108]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 108

Narrated Sa'd:

'Umar bin Al-Khattab asked permission of Allah's Apostle to see him while some Quraishi women were sitting with him and they were asking him to give them more financial support while raising their voices over the voice of the Prophet. When 'Umar asked permission to enter, all of them hurried to screen themselves the Prophet admitted 'Umar and he entered, while the Prophet was smiling. 'Umar said, "May Allah always keep you smiling, O Allah's Apostle! Let my father and mother be sacrificed for you !" The Prophet said, "I am astonished at these women who were with me. As soon as they heard your voice, they hastened to screen themselves." 'Umar said, "You have more right, that they should be afraid of you, O Allah's Apostle!" And then he ('Umar) turned towards them and said, "O enemies of your souls! You are afraid of me and not of Allah's Apostle?" The women replied, "Yes, for you are sterner and harsher than Allah's Apostle." Allah's Apostle said, "O Ibn Al-Khattab! By Him in Whose Hands my life is, whenever Satan sees you taking a way, he follows a way other than yours!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.109]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 109

Narrated 'Abdullah bin 'Umar:

When Allah Apostle was in Ta'if (trying to conquer it), he said to his companions, "Tomorrow we will return (to Medina), if Allah wills." Some of the companions of Allah's Apostle said, "We will not leave till we conquer it." The Prophet said, "Therefore, be ready to fight tomorrow." On the following day, they (Muslims) fought fiercely (with the people of Ta'if) and suffered many wounds. Then Allah's Apostle said, "Tomorrow we will return (to Medina), if Allah wills." His companions kept quiet this time. Allah's Apostle then smiled.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.110]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 110

Narrated Abu Huraira:

A man came to the Prophet and said, "I have been ruined for I have had sexual relation with my wife in Ramadan (while I was fasting)" The Prophet said (to him), "Manumit a slave." The man said, " I cannot afford that." The Prophet said, "(Then) fast for two successive months continuously". The man said, "I cannot do that." The Prophet said, "(Then) feed sixty poor persons." The man said, "I have nothing (to feed them with)." Then a big basket full of dates was brought to the Prophet. The Prophet said, "Where is the questioner? Go and give this in charity." The man said, "(Shall I give this in charity) to a poorer person than l? By Allah, there is no family in between these two mountains (of Medina) who are poorer than we." The Prophet then smiled till his premolar teeth became visible, and said, "Then (feed) your (family with it).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.111]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 111

Narrated Anas bin Malik:

While I was going along with Allah's Apostle who was wearing a Najrani Burd (sheet) with a thick border, a bedouin overtook the Prophet and pulled his Rida' (sheet) forcibly. I looked at the side of the shoulder of the Prophet and noticed that the edge of the Rida' had left a mark on it because of the violence of his pull. The bedouin said, "O Muhammad! Order for me some of Allah's property which you have." The Prophet turned towards him, (smiled) and ordered that he be given something.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.112]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 112

Narrated Jarir:

The Prophet did not screen himself from me (had never prevented me from entering upon him) since I embraced Islam, and whenever he saw me, he would receive me with a smile. Once I told him that I could not sit firm on horses. He stroked me on the chest with his hand, and said, "O Allah! Make him firm and make him a guiding and a rightly guided man.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.113]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 113

Narrated Zainab bint Um Salama:

Um Sulaim said, "O Allah's Apostle! Verily Allah is not shy of (telling you) the truth. Is it essential for a woman to take a bath after she had a wet dream (nocturnal sexual discharge)?" He said, "Yes, if she notices discharge. On that Um Salama laughed and said, "Does a woman get a (nocturnal sexual) discharge?" He said, "How then does (her) son resemble her (his mother)?"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.114]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 114

Narrated 'Aisha:

I never saw the Prophet laughing to an extent that one could see his palate, but he always used to smile only.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.115]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 115

Narrated Anas:

A man came to the Prophet on a Friday while he (the Prophet) was delivering a sermon at Medina, and said, "There is lack of rain, so please invoke your Lord to bless us with the rain." The Prophet looked at the sky when no cloud could be detected. Then he invoked Allah for rain. Clouds started gathering together and it rained till the Medina valleys started flowing with water. It continued raining till the next Friday. Then that man (or some other man) stood up while the Prophet was delivering the Friday sermon, and said, "We are drowned; Please invoke your Lord to withhold it (rain) from us" The Prophet smiled and said twice or thrice, "O Allah! Please let it rain round about us and not upon us." The clouds started dispersing over Medina to the right and to the left, and it rained round about Medina and not upon Medina. Allah showed them (the people) the miracle of His Prophet and His response to his invocation.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.116]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 116

Narrated 'Abdullah:

The Prophet said, "Truthfulness leads to righteousness, and righteousness leads to Paradise. And a man keeps on telling the truth until he becomes a truthful person. Falsehood leads to Al-Fajur (i.e. wickedness, evil-doing), and Al-Fajur (wickedness) leads to the (Hell) Fire, and a man may keep on telling lies till he is written before Allah, a liar."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.117]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 117

Narrated Abu Huraira:

Allah's Apostle said, "The signs of a hypocrite are three: Whenever he speaks, he tells a lie; and whenever he promises, he breaks his promise; and whenever he is entrusted, he betrays (proves to be dishonest)".


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.118]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 118

Narrated Samura bin Jundub:

The Prophet said, "I saw (in a dream), two men came to me." Then the Prophet narrated the story (saying), "They said, 'The person, the one whose cheek you saw being torn away (from the mouth to the ear) was a liar and used to tell lies and the people would report those lies on his authority till they spread all over the world. So he will be punished like that till the Day of Resurrection."'


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.119]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 119

Narrated Hudhaifa:

From among the people, Ibn Um 'Abd greatly resembled Allah's Apostles in solemn gate and good appearance of piety and in calmness and sobriety from the time he goes out of his house till he returns to it. But we do not know how he behaves with his family when he is alone with them.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.120]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 120

Narrated Tariq:

'Abdullah said, "The best talk is Allah's Book (Qur'an), and the best guidance is the guidance of Muhammad."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.121]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 121

Narrated Abu Musa:

The Prophet said: None is more patient than Allah against the harmful saying. He hears from the people they ascribe children to Him, yet He gives them health and (supplies them with) provision."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.122]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 122

Narrated 'Abdullah:

The Prophet divided and distributed something as he used to do for some of his distributions. A man from the Ansar said, "By Allah, in this division the pleasure of Allah has not been intended." I said, "I will definitely tell this to the Prophet ." So I went to him while he was sitting with his companions and told him of it secretly. That was hard upon the Prophet and the color of his face changed, and he became so angry that I wished I had not told him. The Prophet then said, "Moses was harmed with more than this, yet he remained patient."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.123]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 123

Narrated 'Aisha:

The Prophet did something and allowed his people to do it, but some people refrained from doing it. When the Prophet learned of that, he delivered a sermon, and after having sent Praises to Allah, he said, "What is wrong with such people as refrain from doing a thing that I do? By Allah, I know Allah better than they, and I am more afraid of Him than they."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.124]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 124

Narrated Abu Said Al-Khudri:

The Prophet was more shy than a virgin in her separate room. And if he saw a thing which he disliked, we would recognize that (feeling) in his face.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.125]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 125

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, 'If anyone says to his brother, 'O misbeliever! Then surely, one of them such."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.126]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 126

Narrated Thabit bin Ad-Dahhak:

The Prophet said, "Whoever swears by a religion other than Islam (i.e. if he swears by saying that he is a non-Muslim in case he is telling a lie), then he is as he says if his oath is false and whoever commits suicide with something, will be punished with the same thing in the (Hell) fire, and cursing a believer is like murdering him, and whoever accuses a believer of disbelief, then it is as if he had killed him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.127]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 127

Narrated Jabir bin 'Abdullah:

Mu'adh bin Jabal used to pray with the Prophet and then go to lead his people in prayer. Once he led the people in prayer and recited Surat-al-Baqara. A man left (the row of the praying people) and offered (light) prayer (separately) and went away. When Mu'adh came to know about it, he said. "He (that man) is a hypocrite." Later that man heard what Mu'adh said about him, so he came to the Prophet and said, "O Allah's Apostle! We are people who work with our own hands and irrigate (our farms) with our camels. Last night Mu'adh led us in the (night) prayer and he recited Sura-al-Baqara, so I offered my prayer separately, and because of that, he accused me of being a hypocrite." The Prophet called Mu'adh and said thrice, "O Mu'adh! You are putting the people to trials? Recite 'Wash-shamsi wad-uhaha' (91) or'Sabbih isma Rabbi ka-l-A'la' (87) or the like."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.128]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 128

Narrated Abu Huraira:

Allah's Apostle said: "Whoever amongst you swears, (saying by error) in his oath 'By Al-Lat and Al-Uzza', then he should say, 'None has the right to be worshipped but Allah.' And whoever says to his companions, 'Come let me gamble' with you, then he must give something in charity (as an expiation for such a sin)." (See Hadith No. 645)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.129]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 129

Narrated Ibn 'Umar:

that he found 'Umar bin Al-Khattab in a group of people and he was swearing by his father. So Allah's Apostle called them, saying, "Verily! Allah forbids you to swear by your fathers. If one has to take an oath, he should swear by Allah or otherwise keep quiet."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.130]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 130

Narrated 'Aisha:

The Prophet entered upon me while there was a curtain having pictures (of animals) in the house. His face got red with anger, and then he got hold of the curtain and tore it into pieces. The Prophet said, "Such people as paint these pictures will receive the severest punishment on the Day of Resurrection ."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.131]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 131

Narrated Abu Mas'ud:

A man came to the Prophet and said "I keep away from the morning prayer only because such and such person prolongs the prayer when he leads us in it. The narrator added: I had never seen Allah's Apostle more furious in giving advice than he was on that day. He said, "O people! There are some among you who make others dislike good deeds) cause the others to have aversion (to congregational prayers). Beware! Whoever among you leads the people in prayer should not prolong it, because among them there are the sick, the old, and the needy." (See Hadith No. 670, Vol 1)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.132]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 132

Narrated 'Abdullah bin 'Umar:

While the Prophet was praying, he saw sputum (on the wall) of the mosque, in the direction of the Qibla, and so he scraped it off with his hand, and the sign of disgust (was apparent from his face) and then said, "Whenever anyone of you is in prayer, he should not spit in front of him (in prayer) because Allah is in front of him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.133]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 133

Narrated Zaid bin Khalid Al-Juhani:

A man asked Allah's Apostle about "Al-Luqata" (a lost fallen purse or a thing picked up by somebody). The Prophet said, "You should announce it publicly for one year, and then remember and recognize the tying material of its container, and then you can spend it. If its owner came to you, then you should pay him its equivalent." The man said, "O Allah's Apostle! What about a lost sheep?" The Prophet said, "Take it because it is for you, for your brother, or for the wolf." The man again said, "O Allah's Apostle! What about a lost camel?" Allah's Apostle became very angry and furious and his cheeks became red (or his face became red), and he said, "You have nothing to do with it (the camel) for it has its food and its water container with it till it meets its owner."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.134]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 134

Narrated Zaid bin Thabit:

Allah's Apostle made a small room (with a palm leaf mat). Allah's Apostle came out (of his house) and prayed in it. Some men came and joined him in his prayer. Then again the next night they came for the prayer, but Allah's Apostle delayed and did not come out to them. So they raised their voices and knocked the door with small stones (to draw his attention). He came out to them in a state of anger, saying, "You are still insisting (on your deed, i.e. Tarawih prayer in the mosque) that I thought that this prayer (Tarawih) might become obligatory on you. So you people, offer this prayer at your homes, for the best prayer of a person is the one which he offers at home, except the compulsory (congregational) prayer."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.135]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 135

Narrated Abu Huraira:

Allah's Apostle said, "The strong is not the one who overcomes the people by his strength, but the strong is the one who controls himself while in anger."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.136]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 136

Narrated Sulaiman bin Sarad:

Two men abused each other in front of the Prophet while we were sitting with him. One of the two abused his companion furiously and his face became red. The Prophet said, "I know a word (sentence) the saying of which will cause him to relax if this man says it. Only if he said, "I seek refuge with Allah from Satan, the outcast.' " So they said to that (furious) man, 'Don't you hear what the Prophet is saying?" He said, "I am not mad."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.137]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 137

Narrated Abu Huraira:

A man said to the Prophet , "Advise me! "The Prophet said, "Do not become angry and furious." The man asked (the same) again and again, and the Prophet said in each case, "Do not become angry and furious."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.138]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 138

Narrated Abu As-Sawar Al-Adawi:

'Imran bin Husain said, "The Prophet said, 'Haya' does not bring anything except good." Thereupon Bashir bin Ka'b said, 'It is written in the wisdom paper: Haya leads to solemnity; Haya leads to tranquility (peace of mind)." 'Imran said to him, "I am narrating to you the saying of Allah's Apostle and you are speaking about your paper (wisdom book)?"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.139]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 139

Narrated 'Abdullah bin 'Umar:

The Prophet passed by a man who was admonishing his brother regarding Haya and was saying, "You are very shy, and I am afraid that might harm you." On that, Allah's Apostle said, "Leave him, for Haya is (a part) of Faith."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.140]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 140

Narrated Abu Said:

The Prophet was shier than a veiled virgin girl. (See Hadith No. 762, Vol. 4)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.141]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 141

Narrated Abu Mas'ud:

The Prophet said, 'One of the sayings of the early Prophets which the people have got is: If you don't feel ashamed do whatever you like." (See Hadith No 690, 691, Vol 4)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.142]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 142

Narrated Um Salama:

Um Sulaim came to Allah's Apostle and said, "O Allah's Apostle! Verily, Allah does not feel shy to tell the truth. If a woman gets a nocturnal sexual discharge (has a wet dream), is it essential for her to take a bath? He replied, "Yes if she notices a discharge."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.143]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 143

Narrated Ibn 'Umar:

The Prophet said, "The example of a believer is like a green tree, the leaves of which do not fall." The people said. "It is such-and-such tree: It is such-and-such tree." I intended to say that it was the datepalm tree, but I was a young boy and felt shy (to answer). The Prophet said, "It is the date-palm tree." Ibn 'Umar added, " I told that to 'Umar who said, 'Had you said it, I would have preferred it to such-and such a thing."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.144]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 144

Narrated Thabit:

that he heard Anas saying, "A woman came to the Prophet offering herself to him in marriage, saying, "Have you got any interest in me (i.e. would you like to marry me?)" Anas's daughter said, "How shameless that woman was!" On that Anas said, "She is better than you for, she presented herself to Allah's Apostle (for marriage)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.145]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 145

Narrated Abu Musa:

that when Allah's Apostle sent him and Mu'adh bin Jabal to Yemen, he said to them, "Facilitate things for the people (treat the people in the most agreeable way), and do not make things difficult for them, and give them glad tidings, and let them not have aversion (i.e. to make the people hate good deeds) and you should both work in cooperation and mutual understanding, obey each other." Abu Musa said, "O Allah's Apostle! We are in a land in which a drink named Al Bit' is prepared from honey, and another drink named Al-Mizr is prepared from barley." On that, Allah's Apostle said, "All intoxicants (i.e. all alcoholic drinks) are prohibited."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.146]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 146

Narrated Anas bin Malik:

The Prophet said, "Make things easy for the people, and do not make it difficult for them, and make them calm (with glad tidings) and do not repulse (them )."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.147]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 147

Narrated 'Aisha:

Whenever Allah's Apostle was given the choice of one of two matters he would choose the easier of the two as long as it was not sinful to do so, but if it was sinful, he would not approach it. Allah's Apostle never took revenge over anybody for his own sake but (he did) only when Allah's legal bindings were outraged, in which case he would take revenge for Allah's sake." (See Hadith No. 760. Vol. 4)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.148]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 148

Narrated Al-Azraq bin Qais:

We were in the city of Al-Ahwaz on the bank of a river which had dried up. Then Abu Barza Al-Aslami came riding a horse and he started praying and let his horse loose. The horse ran away, so Abu Barza interrupted his prayer and went after the horse till he caught it and brought it, and then he offered his prayer. There was a man amongst us who was (from the Khawari) having a different opinion. He came saying. "Look at this old man! He left his prayer because of a horse." On that Abu Barza came to us and said, "Since the time I left Allah's Apostle, nobody has admonished me; My house is very far from this place, and if I had carried on praying and left my horse, I could not have reached my house till night." Then Abu Barza mentioned that he had been in the company of the Prophet, and that he had seen his leniency.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.149]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 149

Narrated Abu Huraira:

A bedouin urinated in the mosque, and the people rushed to beat him. Allah's Apostle ordered them to leave him and pour a bucket or a tumbler (full) of water over the place where he has passed urine. The Prophet then said, " You have been sent to make things easy (for the people) and you have not been sent to make things difficult for them."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.150]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 150

Narrated Anas bin Malik:

The Prophet used to mix with us to the extent that he would say to a younger brother of mine, 'O father of 'Umar! What did the Nughair (a kind of bird) do?"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.151]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 151

Narrated 'Aisha:

I used to play with the dolls in the presence of the Prophet, and my girl friends also used to play with me. When Allah's Apostle used to enter (my dwelling place) they used to hide themselves, but the Prophet would call them to join and play with me. (The playing with the dolls and similar images is forbidden, but it was allowed for 'Aisha at that time, as she was a little girl, not yet reached the age of puberty.) (Fateh-al-Bari page 143, Vol.13)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.152]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 152

Narrated Aisha:

A man asked permission to see the Prophet. He said, "Let Him come in; What an evil man of the tribe he is! (Or, What an evil brother of the tribe he is)."

But when he entered, the Prophet spoke to him gently in a polite manner. I said to him, "O Allah's Apostle! You have said what you have said, then you spoke to him in a very gentle and polite manner? The Prophet said, "The worse people, in the sight of Allah are those whom the people leave (undisturbed) to save themselves from their dirty language."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.153]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 153

Narrated 'Abdullah bin Abu Mulaika:

The Prophet was given a gift of a few silken cloaks with gold buttons. He distributed them amongst some of his companions and put aside one of them for Makhrama. When Makhrama came, the Prophet said, "I kept this for you." (Aiyub, the sub-narrator held his garment to show how the Prophet showed the cloak to Makhrama who had something unfavorable about his temper.)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.154]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 154

Narrated Abu Huraira:

The Prophet said, "A believer is not stung twice (by something) out of one and the same hole."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.155]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 155

Narrated 'Abdullah bin 'Amr:

Allah's Apostle entered upon me and said, "Have I not been informed that you offer prayer all the night and fast the whole day?" I said, "Yes." He said, "Do not do so; Offer prayer at night and also sleep; Fast for a few days and give up fasting for a few days because your body has a right on you, and your eye has a right on you, and your guest has a right on you, and your wife has a right on you. I hope that you will have a long life, and it is sufficient for you to fast for three days a month as the reward of a good deed, is multiplied ten times, that means, as if you fasted the whole year." I insisted (on fasting more) so I was given a hard instruction. I said, "I can do more than that (fasting)" The Prophet said, "Fast three days every week." But as I insisted (on fasting more) so I was burdened. I said, "I can fast more than that." The Prophet said, "Fast as Allah's prophet David used to fast." I said, "How was the fasting of the prophet David?" The Prophet said, "One half of a year (i.e. he used to fast on alternate days). '


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.156]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 156

Narrated Abu Shuraih Al-Ka'bi:

Allah's Apostle said, Whoever believes in Allah and the Last Day, should serve his guest generously. The guest's reward is: To provide him with a superior type of food for a night and a day and a guest is to be entertained with food for three days, and whatever is offered beyond that, is regarded as something given in charity. And it is not lawful for a guest to stay with his host for such a long period so as to put him in a critical position."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.157]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 157

Narrated Malik:

Similarly as above (156) adding, "Who believes in Allah and the Last Day should talk what is good or keep quiet." (i.e. abstain from dirty and evil talk, and should think before uttering).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.158]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 158

Narrated Abu Huraira:

The Prophet said, "Whoever believes in Allah and the Last Day, should not hurt his neighbor and whoever believes in Allah and the Last Day, should serve his guest generously and whoever believes in Allah and the Last Day, should talk what is good or keep quiet."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.159]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 159

Narrated Uqba bin 'Amir:

We said, "O Allah's Apostle! You send us out and it happens that we have to stay with such people as do not entertain us. What do you think about it?" Allah's Apostle said to us, "If you stay with some people and they entertain you as they should for a guest, accept is; but if they do not do then you should take from them the right of the guest, which they ought to give."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.160]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 160

Narrated Abu Huraira:

The Prophet said, "Whoever believes in Allah and the Last Day, should serve his guest generously; and whoever believes in Allah and the Last Day, should unite the bond of kinship (i.e. keep good relation with his Kith and kin); and whoever believes in Allah and the Last Day, should talk what is good or keep quit. "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.161]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 161

Narrated Abu Juhaifa:

The Prophet established a bond of brotherhood between Salman and Abu Darda'. Salman paid a visit to Abu ad-Darda and found Um Ad-Darda' dressed in shabby clothes and asked her why she was in that state.?" She replied, "Your brother, Abu Ad-Darda is not interested in the luxuries of this world." In the meantime Abu Ad-Darda came and prepared a meal for him (Salman), and said to him, "(Please) eat for I am fasting." Salman said, "I am not going to eat, unless you eat." So Abu Ad-Darda' ate. When it was night, Abu Ad-Darda' got up (for the night prayer). Salman said (to him), "Sleep," and he slept. Again Abu-Ad-Darda' got up (for the prayer), and Salman said (to him), "Sleep." When it was the last part of the night, Salman said to him, "Get up now (for the prayer)." So both of them offered their prayers and Salman said to Abu Ad-Darda',"Your Lord has a right on you; and your soul has a right on you; and your family has a right on you; so you should give the rights of all those who have a right on you). Later on Abu Ad-Darda' visited the Prophet and mentioned that to him. The Prophet, said, "Salman has spoken the truth."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.162]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 162

Narrated 'Abdur-Rahman bin Abu Bakr:

Abu Bakr invited a group of people and told me, "Look after your guests." Abu Bakr added, I am going to visit the Prophet and you should finish serving them before I return." 'Abdur-Rahman said, So I went at once and served them with what was available at that time in the house and requested them to eat." They said, "Where is the owner of the house (i.e., Abu Bakr)?" 'Abdur-Rahman said, "Take your meal." They said, "We will not eat till the owner of the house comes." 'Abdur-Rahman said, "Accept your meal from us, for if my father comes and finds you not having taken your meal yet, we will be blamed severely by him, but they refused to take their meals . So I was sure that my father would be angry with me. When he came, I went away (to hide myself) from him. He asked, "What have you done (about the guests)?" They informed him the whole story. Abu Bakr called, "O 'Abdur Rahman!" I kept quiet. He then called again. "O 'Abdur-Rahman!" I kept quiet and he called again, "O ignorant (boy)! I beseech you by Allah, if you hear my voice, then come out!" I came out and said, "Please ask your guests (and do not be angry with me)." They said, "He has told the truth; he brought the meal to us." He said, "As you have been waiting for me, by Allah, I will not eat of it tonight." They said, "By Allah, we will not eat of it till you eat of it." He said, I have never seen a night like this night in evil. What is wrong with you? Why don't you accept your meals of hospitality from us?" (He said to me), "Bring your meal." I brought it to him, and he put his hand in it, saying, "In the name of Allah. The first (state of fury) was because of Satan." So Abu Bakr ate and so did his guests.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.163]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 163

Narrated 'Abdur-Rahman bin Abu Bakr:

Abu Bakr came with a guest or some guests, but he stayed late at night with the Prophet and when he came, my mother said (to him), "Have you been detained from your guest or guests tonight?" He said, "Haven't you served the supper to them?" She replied, "We presented the meal to him (or to them), but he (or they) refused to eat." Abu Bakr became angry, rebuked me and invoked Allah to cause (my) ears to be cut and swore not to eat of it!" I hid myself, and he called me, "O ignorant (boy)!" Abu Bakr's wife swore that she would not eat of it and so the guests or the guest swore that they would not eat of it till he ate of it. Abu Bakr said, "All that happened was from Satan." So he asked for the meals and ate of it, and so did they. Whenever they took a handful of the meal, the meal grew (increased) from underneath more than that mouthful. He said (to his wife), "O, sister of Bani Firas! What is this?" She said, "O, pleasure of my eyes! The meal is now more than it had been before we started eating'' So they ate of it and sent the rest of that meal to the Prophet. It is said that the Prophet also ate of it.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.164]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 164

Narrated Rafi bin Khadij and Sahl bin Abu Hathma:

'Abdullah bin Sahl and Muhaiyisa bin Mas'ud went to Khaibar and they dispersed in the gardens of the date-palm trees. 'Abdullah bin Sahl was murdered. Then 'Abdur-Rahman bin Sahl, Huwaiyisa and Muhaiyisa, the two sons of Mas'ud, came to the Prophet and spoke about the case of their (murdered) friend. 'Abdur-Rahman who was the youngest of them all, started talking. The Prophet said, "Let the older (among you) speak first." So they spoke about the case of their (murdered) friend. The Prophet said, "Will fifty of you take an oath whereby you will have the right to receive the blood money of your murdered man," (or said, "..your companion"). They said, "O Allah's Apostle! The murder was a thing we did not witness." The Prophet said, "Then the Jews will release you from the oath, if fifty of them (the Jews) should take an oath to contradict your claim." They said, "O Allah's Apostle! They are disbelievers (and they will take a false oath)." Then Allah's Apostle himself paid the blood money to them.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.165]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 165

Narrated Ibn 'Umar:

Allah's Apostle said, "Inform me of a tree which resembles a Muslim, giving its fruits at every season by the permission of its Lord, and the leaves of which do not fall." I thought of the date-palm tree, but I disliked to speak because Abu Bakr and 'Umar were present there. When nobody spoke, the Prophet said, "It is the date-palm tree" When I came out with my father, I said, "O father! It came to my mind that it was the date-palm tree." He said, "What prevented you from saying it?" Had you said it, it would have been more dearer to me than such-and-such a thing (fortune)." I said, "Nothing prevented me but the fact that neither you nor Abu Bakr spoke, so I disliked to speak (in your presence)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.166]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 166

Narrated Ubai bin Ka'b:

Allah's Apostle said, "Some poetry contains wisdom."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.167]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 167

Narrated Jundub:

While the Prophet was walking, a stone hit his foot and stumbled and his toe was injured. He then (quoting a poetic verse) said, "You are not more than a toe which


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.168]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 168

Narrated Abu Huraira:

The Prophet said, "The most true words said by a poet were the words of Labid. He said, i.e. 'Verily, everything except Allah is perishable and Umaiya bin Abi As-Salt was about to embrace Islam '


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.169]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 169

Narrated Salama bin Al-Aqwa:

We went out with Allah's Apostle to Khaibar and we travelled during the night. A man amongst the people said to 'Amir bin Al-Aqwa', "Won't you let us hear your poetry?" 'Amir was a poet, and so he got down and started (chanting Huda) reciting for the people, poetry that keep pace with the camel's foot steps, saying, "O Allah! Without You we would not have been guided on the right path, neither would we have given in charity, nor would we have prayed. So please forgive us what we have committed. Let all of us be sacrificed for Your cause and when we meet our enemy, make our feet firm and bestow peace and calmness on us and if they (our enemy) will call us towards an unjust thing we will refuse.

The infidels have made a hue and cry to ask others help against us. Allah's Apostle said, "Who is that driver (of the camels)?" They said, "He is 'Amir bin Al-Aqwa."' He said, "May Allah bestow His mercy on him." A man among the people said, Has Martyrdom been granted to him, O Allah's Prophet! Would that you let us enjoy his company longer." We reached (the people of) Khaibar and besieged them till we were stricken with severe hunger but Allah helped the Muslims conquer Khaibar. In the evening of its conquest the people made many fires. Allah's Apostle asked, "What are those fires? For what are you making fires?" They said, "For cooking meat." He asked, "What kind of meat?" They said, "Donkeys' meat." Allah's Apostle said, "Throw away the meat and break the cooking pots." A man said, O Allah's Apostle! Shall we throw away the meat and wash the cooking pots?" He said, "You can do that too." When the army files aligned in rows (for the battle), 'Amir's sword was a short one, and while attacking a Jew with it in order to hit him, the sharp edge of the sword turned back and hit 'Amir's knee and caused him to die.

When the Muslims returned (from the battle), Salama said, Allah's Apostle saw me pale and said, 'What is wrong with you?"' I said, "Let my parents be sacrificed for you! The people claim that all the deeds of Amir have been annulled." The Prophet asked, "Who said so?" I replied, "So-and-so and so-and-so and Usaid bin Al-Hudair Al-Ansari said, 'Whoever says so is telling a lie. Verily, 'Amir will have double reward."' (While speaking) the Prophet put two of his fingers together to indicate that, and added, "He was really a hard-working man and a Mujahid (devout fighter in Allah's Cause) and rarely have there lived in it (i.e., Medina or the battle-field) an "Arab like him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.170]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 170

Narrated Anas bin Malik:

The Prophet came to some of his wives among whom there was Um Sulaim, and said, "May Allah be merciful to you, O Anjasha! Drive the camels slowly, as they are carrying glass vessels!" Abu Qalaba said, "The Prophet said a sentence (i.e. the above metaphor) which, had anyone of you said it, you would have admonished him for it".


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.171]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 171

Narrated 'Aisha:

Hassan bin Thabit asked the permission of Allah's Apostle to lampoon the pagans (in verse). Allah's Apostle said, "What about my fore-fathers (ancestry)?' Hassan said (to the Prophet) "I will take you out of them as a hair is taken out of dough."

Narrated Hisham bin 'Urwa that his father said, "I called Hassan with bad names in front of 'Aisha." She said, "Don't call him with bad names because he used to defend Allah's Apostle (against the pagans)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.172]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 172

Narrated Al-Haitham bin Abu Sinan:

that he heard Abu Huraira in his narration, mentioning that the Prophet said, "A Muslim brother of yours who does not say dirty words." and by that he meant Ibn Rawaha, "said (in verse): 'We have Allah's Apostle with us who recites the Holy Qur'an in the early morning time. He gave us guidance and light while we were blind and astray, so our hearts are sure that whatever he says, will certainly happen. He does not touch his bed at night, being busy in worshipping Allah while the pagans are sound asleep in their beds.' "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.173]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 173

Narrated Abu Salama bin 'Abdur-Rahman bin 'Auf:

that he heard Hassan bin Thabit Al-Ansari asking the witness of Abu Huraira, saying, "O Abu- Huraira! I beseech you by Allah (to tell me). Did you hear Allah's Apostle saying' 'O Hassan ! Reply on behalf of Allah's Apostle. O Allah ! Support him (Hassan) with the Holy Spirit (Gabriel).'?" Abu Huraira said, "Yes."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.174]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 174

Narrated Al-Bara:

The Prophet said to Hassan, "Lampoon them (the pagans) in verse, and Gabriel is with you."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.175]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 175

Narrated Ibn 'Umar:

The Prophet said, "It is better for a man to fill the inside of his body with pus than to fill it with poetry."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.176]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 176

Narrated Abu Huraira:

Allah's Apostle; said, "It is better for anyone of you that the inside of his body be filled with pus which may consume his body, than it be filled with poetry."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.177]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 177

Narrated 'Aisha:

Allah, the brother of Abu Al-Qu'ais asked my permission to enter after the verses of Al-Hijab (veiling the ladies) was revealed, and I said, "By Allah, I will not admit him unless I take permission of Allah's Apostle for it was not the brother of Al-Qu'ais who had suckled me, but it was the wife of Al-Qu'ais, who had suckled me." Then Allah's Apostle entered upon me, and I said, "O Allah's Apostle! The man has not nursed me but his wife has nursed me." He said, "Admit him because he is your uncle (not from blood relation, but because you have been nursed by his wife), Taribat Yaminuki." 'Urwa said, "Because of this reason, ' Aisha used to say: Foster suckling relations render all those things (marriages etc.) illegal which are illegal because of the corresponding blood relations." (See Hadith No. 36, Vol. 7)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.178]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 178

Narrated 'Aisha:

The Prophet intended to return home after the performance of the Hajj, and he saw Safiya standing at the entrance of her tent, depressed and sad because she got her menses. The Prophet said, "Aqra Halqa! --An expression used in the Quraish dialect--"You will detain us." The Prophet then asked (her), "Did you perform the Tawaf Al-Ifada on the Day of Sacrifice (10th of Dhul-Hijja)?" She said, "Yes." The Prophet said, "Then you can leave (with us)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.179]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 179

Narrated Um Hani:

(the daughter of Abu Talib) I visited Allah's Apostle in the year of the Conquest of Mecca and found him taking a bath, and his daughter, Fatima was screening him. When I greeted him, he said, "Who is it?" I replied, "I am Um Hani, the daughter of Abu Talib." He said, "Welcome, O Um Hani ! " When the Prophet had finished his bath, he stood up and offered eight Rakat of prayer while he was wrapped in a single garment. When he had finished his prayer, I said, "O Allah's Apostle! My maternal brother assumes (or claims) that he will murder some man whom I have given shelter, i.e., so-and-so bin Hubaira." Allah's Apostle said, "O Um Hani! We shelter him whom you have sheltered." Um Hani added, "That happened in the forenoon."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.180]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 180

Narrated Anas:

The Prophet saw a man driving a Badana (a camel for sacrifice) and said (to him). "Ride it." The man said, "It is a Bandana." The Prophet said, "Ride on it." The man said, "It is a Bandana." The Prophet said, Ride on it, woe to you!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.181]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 181

Narrated Abu Huraira:

Allah's Apostle saw a man driving a Badana (a camel for sacrifice) and said to him, "Ride on it." The man said, "O Allah's Apostle! It is a Bandana." The Prophet said, "Ride on it, woe to you!" on the second or third time.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.182]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 182

Narrated Anas bin Malik:

Allah's Apostle was on a journey and he had a black slave called Anjasha, and he was driving the camels (very fast, and there were women riding on those camels). Allah's Apostle said, "Waihaka (May Allah be merciful to you), O Anjasha! Drive slowly (the camels) with the glass vessels (women)!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.183]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 183

Narrated Abu Bakra:

A man praised another man in front of the Prophet. The Prophet said thrice, "Wailaka (Woe on you) ! You have cut the neck of your brother!" The Prophet added, "If it is indispensable for anyone of you to praise a person, then he should say, "I think that such-and-such person (is so-and-so), and Allah is the one who will take his accounts (as he knows his reality) and none can sanctify anybody before Allah (and that only if he knows well about that person.)".


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.184]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 184

Narrated Abu Said Al-Khudri:

While the Prophet was distributing (war booty etc.) one day, Dhul Khawaisira, a man from the tribe of Bani Tamim, said, "O Allah's Apostle! Act justly." The Prophets said, "Woe to you! Who else would act justly if I did not act justly?" 'Umar said (to the Prophet ), "Allow me to chop his neck off." The Prophet said, "No, for he has companions (who are apparently so pious that) if anyone of (you compares his prayer with) their prayer, he will consider his prayer inferior to theirs, and similarly his fasting inferior to theirs, but they will desert Islam (go out of religion) as an arrow goes through the victim's body (games etc.) in which case if its Nasl is examined nothing will be seen thereon, and if its Nady is examined, nothing will be seen thereon, and if its Qudhadh is examined, nothing will be seen thereon, for the arrow has gone out too fast even for the excretions and blood to smear over it. Such people will come out at the time of difference among the (Muslim) people and the sign by which they will be recognized, will be a man whose one of the two hands will look like the breast of a woman or a lump of flesh moving loosely." Abu Said added, "I testify that I heard that from the Prophet and also testify that I was with 'Ali when 'Ali fought against those people. The man described by the Prophet was searched for among the killed, and was found, and he was exactly as the Prophet had described him." (See Hadith No. 807, Vol. 4)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.185]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 185

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "O Allah's Apostle! I am ruined!" The Prophet said, "Waihaka (May Allah be merciful to you) !" The man said, "I have done sexual intercourse with my wife while fasting in Ramadan." The Prophet said, "Manumit a slave." The man said, " I cannot afford that. " The Prophet said; "Then fast for two successive months." The man said, " I have no power to do so." The Prophet said, "Then feed sixty poor persons." The man said, "I have nothing (to feed sixty persons). Later a basket full of dates were brought to the Prophet and he said (to the man), "Take it and give it in charity." The man said, "O Allah's Apostle! Shall I give it to people other than my family? By Him in Whose Hand my life is, there is nobody poorer than me in the whole city of Medina." The Prophet smiled till his premolar teeth became visible, and said, "Take it." Az-Zuhri said (that the Prophet said). "Wailaka."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.186]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 186

Narrated Abu Sa'id Al-Khudri:

A bedouin said, "O Allah's Apostle! Inform me about the emigration." The Prophet said, "Waihaka (May Allah be merciful to you)! The question of emigration is a difficult one. Have you got some camels?" The bedouin said, "Yes." The Prophet said, "Do you pay their Zakat?" He said, "Yes." The Prophet said, "Go on doing like this from beyond the seas, for Allah will not let your deeds go in vain."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.187]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 187

Narrated Ibn 'Umar:

The Prophet said, "Wailakum" (woe to you) or "waihakum" (May Allah be merciful to you)." Shu'ba is not sure as to which was the right word. "Do not become disbelievers after me by cutting the necks of one another."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.188]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 188

Narrated Anas:

A bedouin came to the Prophet and said, "O Allah's Apostle! When will The Hour be established?" The Prophet said, "Wailaka (Woe to you), What have you prepared for it?" The bedouin said, "I have not prepared anything for it, except that I love Allah and H is Apostle." The Prophet said, "You will be with those whom you love." We (the companions of the Prophet ) said, "And will we too be so? The Prophet said, "Yes." So we became very glad on that day. In the meantime, a slave of Al-Mughira passed by, and he was of the same age as I was. The Prophet said. "If this (slave) should live long, he will not reach the geriatric old age, but the Hour will be established."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.189]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 189

Narrated 'Abdullah:

The Prophet said, "Everyone will be with those whom he loves."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.190]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 190

Narrated 'Abdullah bin Mas'ud:

A man came to Allah's Apostle and said, "O Allah's Apostle! What do you say about a man who loves some people but cannot catch up with their good deeds?" Allah's Apostle said, "Everyone will be with those whom he loves."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.191]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 191

Narrated Abu Musa:

It was said to the Prophet; , "A man may love some people but he cannot catch up with their good deeds?" The Prophet said, "Everyone will be with those whom he loves."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.192]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 192

Narrated Anas bin Malik:

A man asked the Prophet "When will the Hour be established O Allah's Apostle?" The Prophet . said, "What have you prepared for it?" The man said, " I haven't prepared for it much of prayers or fast or alms, but I love Allah and His Apostle." The Prophet said, "You will be with those whom you love."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.193]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 193

Narrated Ibn 'Abbas:

Allah's Apostle said to Ibn Saiyad "I have hidden something for you in my mind; What is it?" He said, "Ad-Dukh." The Prophet said, "Ikhsa."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.194]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 194

Narrated 'Abdullah bin 'Umar:

'Umar bin Al-Khattab set out with Allah's Apostle, and a group of his companions to Ibn Saiyad. They found him playing with the boys in the fort or near the Hillocks of Bani Maghala. Ibn Saiyad was nearing his puberty at that time, and he did not notice the arrival of the Prophet till Allah's Apostle stroked him on the back with his hand and said, "Do you testify that I am Allah's Apostle?" Ibn Saiyad looked at him and said, "I testify that you are the Apostle of the unlettered ones (illiterates)". Then Ibn Saiyad said to the Prophets . "Do you testify that I am Allah's Apostle?" The Prophet denied that, saying, "I believe in Allah and all His Apostles," and then said to Ibn Saiyad, "What do you see?" Ibn Saiyad said, "True people and liars visit me." The Prophet said, "You have been confused as to this matter." Allah's Apostle added, "I have kept something for you (in my mind)." Ibn Saiyad said, "Ad-Dukh." The Prophet said, "Ikhsa (you should be ashamed) for you can not cross your limits." 'Umar said, "O Allah's Apostle! Allow me to chop off h is neck." Allah's Apostle said (to Umar). "Should this person be him (i.e. Ad-Dajjal) then you cannot over-power him; and should he be someone else, then it will be no use your killing him." 'Abdullah bin 'Umar added: Later on Allah's Apostle and Ubai bin Ka'b Al-Ansari (once again) went to the garden in which Ibn Saiyad was present.

When Allah's Apostle entered the garden, he started hiding behind the trunks of the date-palms intending to hear something from Ibn Saiyad before the latter could see him. Ibn Saiyad was Lying on his bed, covered with a velvet sheet from where his mumur were heard. Ibn Saiyad's mother saw the Prophet and said, "O Saf (the nickname of Ibn Saiyad)! Here is Muhammad!" Ibn Saiyad stopped his murmuring. The Prophet said, "If his mother had kept quiet, then I would have learnt more about him." 'Abdullah added: Allah's Apostle stood up before the people (delivering a sermon), and after praising and glorifying Allah as He deserved, he mentioned the Ad-Dajjal saying, "I warn you against him, and there has been no prophet but warned his followers against him. Noah warned his followers against him but I am telling you about him, something which no prophet has told his people of, and that is: Know that he is blind in one eye where as Allah is not so."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.195]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 195

Narrated Ibn 'Abbas:

When the delegation of 'Abdul Qais came to the Prophet, he said, "Welcome, O the delegation who have come! Neither you will have disgrace, nor you will regret." They said, "O Allah's Apostle! We are a group from the tribe of Ar-Rabi'a, and between you and us there is the tribe of Mudar and we cannot come to you except in the sacred months. So please order us to do something good (religious deeds) so that we may enter Paradise by doing that, and also that we may order our people who are behind us (whom we have left behind at home) to follow it." He said, "Four and four:" offer prayers perfectly , pay the Zakat, (obligatory charity), fast the month of Ramadan, and give one-fifth of the war booty (in Allah's cause), and do not drink in (containers called) Ad-Duba,' Al-Hantam, An-Naqir and Al-Muzaffat."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.196]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 196

Narrated Ibn 'Umar:

The Prophet said, "For every betrayer (perfidious person), a flag will be raised on the Day of Resurrection, and it will be announced (publicly) 'This is the betrayal (perfidy) of so-and-so, the son of so-and-so.' "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.197]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 197

Narrated Ibn 'Umar:

Allah's Apostle said, "A flag will be fixed on the Day of Resurrection for every betrayer, and it will be announced (publicly in front of everybody), 'This is the betrayal (perfidy) so-and-so, the son of so-and-so."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.198]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 198

Narrated 'Aisha:

The Prophet said, "None of you should say Khabuthat Nafsi, but he is recommended to say 'Laqisat Nafsi."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.199]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 199

Narrated Sal:

The Prophet said, "None of you should say Khabuthat Nafsi but he is recommended to say 'Laqisat Nafsi (See Hadith No. 202)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.200]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 200

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, "The offspring of Adam abuse the Dahr (Time), and I am the Dahr; in My Hands are the night and the day." !


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.201]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 201

Narrated Abu Huraira: The Prophet said, "Don't call the grapes Al-Karm, and don't say 'Khai


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.202]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 202

Narrated Abu Huraira:

Allah's Apostle said, "They say Al-Karm (the generous), and in fact Al-Karm is the heart of a believer."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.203]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 203

Narrated 'Ali:

I never heard Allah's Apostle saying, "Let my father and mother be sacrificed for you," except for Sa'd (bin Abi Waqqas). I heard him saying, "Throw! (arrows), Let my father and mother be sacrificed for you !" (The sub-narrator added, "I think that was in the battle of Uhud.")


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.204]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 204

Narrated Anas bin Malik:

That he and Abu Talha were coming in the company of the Prophet towards Medina), while Safiya (the Prophet's wife) was riding behind him on his she-camel. After they had covered a portion of the way suddenly the foot of the she-camel slipped and both the Prophet and the woman (i.e., his wife, Safiya) fell down. Abu Talha jumped quickly off his camel and came to the Prophet (saying.) "O Allah's Apostle! Let Allah sacrifice me for you! Have you received any injury?" The Prophet said, "No, but take care of the woman (my wife)." Abu Talha covered his face with his garment and went towards her and threw his garment over her. Then the woman got up and Abu Talha prepared their she camel (by tightening its saddle, etc.) and both of them (the Prophet and Safiya) mounted it. Then all of them proceeded and when they approached near Medina, or saw Medina, the Prophet said, "Ayibun,' abidun, taibun, liRabbina hamidun (We are coming back (to Medina) with repentance, worshipping (our Lord) and celebrating His (our Lord's) praises". The Prophet continued repeating these words till he entered the city of Medina.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.205]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 205

Narrated Jabir:

A boy was born for a man among us, and the man named him Al-Qasim. We said to him, "We will not call you Abu-l-Qasim, nor will we respect you for that." The Prophet was informed about that, and he said, "Name your son 'Abdur-Rahman."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.206]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 206

Narrated Jabi:

A man among us begot a boy whom he named Al-Qasim. The people said, "We will not call him (i.e., the father) by that Kuniya (Abu-l-Qasim) till we ask the Prophet about it. The Prophet said. "Name yourselves by my name, but do not call (yourselves) by my Kuniya."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.207]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 207

Narrated Abu Huraira:

Abu-l-Qasim (The Prophet) said, "Name yourselves by my name, but do not call yourselves by my Kuniya."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.208]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 208

Narrated Jabir bin 'Abdullah:

A man among us begot a boy whom he named Al-Qasim. The people said (to him), "We will not call you Abul-l-Qasim, nor will we please you by calling you so." The man came to the Prophet and mentioned that to him. The Prophet said to him, "Name your son 'Abdur-Rahman."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.209]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 209

Narrated Al-Musaiyab:

That his father (Hazn bin Wahb) went to the Prophet and the Prophet asked (him), "What is your name?" He replied, "My name is Hazn." The Prophet said, "You are Sahl." Hazn said, "I will not change the name with which my father has named me." Ibn Al-Musaiyab added: We have had roughness (in character) ever since.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.210]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 210

Narrated Al-Musaiyab:

on the authority of his father similarly as above (i.e., 209).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.211]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 211

Narrated Sahl:

When Al-Mundhir bin Abu Usaid was born, he was brought to the Prophet who placed him on his thigh. While Abu Usaid was sitting there, the Prophet was busy with something in his hands so Abu Usaid told someone to take his son from the thigh of the Prophet . When the Prophet finished his job (with which he was busy), he said, "Where is the boy?" Abu Usaid replied, "We have sent him home." The Prophet said, "What is his name?" Abu Usaid said, "(His name is) so-and-so. " The Prophet said, "No, his name is Al-Mundhir." So he called him Al-Mundhir from that day.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.212]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 212

Narrated Abu Huraira:

Zainab's original name was "Barrah," but it was said' "By that she is giving herself the prestige of piety." So the Prophet changed her name to Zainab.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.213]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 213

Narrated Said bin Al-Musaiyab:

That when his grandfather, Hazn visited the Prophet the Prophet said (to him), "What is your name?" He said, "My name is Hazn." The Prophet said, " But you are Sahl." He said, "I will not change my name with which my father named me." Ibn Al-Musaiyab added: So we have had roughness (in character) ever since.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.214]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 214

Narrated Isma'il:

I asked Abi Aufa, "Did you see Ibrahim, the son of the Prophet ?" He said, "Yes, but he died in his early childhood. Had there been a Prophet after Muhammad then his son would have lived, but there is no Prophet after him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.215]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 215

Narrated Al-Bara:

When Ibrahim (the son of the Prophet) died, Allah's Apostle said, "There is a wet nurse for him in Paradise."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.216]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 216

Narrated Jabir bin 'Abdullah Al-Ansari:

Allah's Apostle said, "Name yourselves after me (by my name) but do not call (yourselves) by my Kuniya (1), for I am Al-Qasim (distributor), and I distribute among you Allah's blessings." This narration has also come on the authority of Anas that the ! Prophet said so."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.217]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 217

Narrated Abu Huraira:

The Prophet said, "Name yourselves after me (by my name), but do not call yourselves by my Kuniya, and whoever sees me in a dream, he surely sees me, for Satan cannot impersonate me (appear in my figure). And whoever intentionally ascribes something to me falsely, he will surely take his place in the (Hell) Fire.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.218]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 218

Narrated Abu Musa:

I got a son and I took him to the Prophet who named him Ibrahim, and put in his mouth the juice of a date fruit (which be himself had chewed?, and invoked for Allah's blessing upon him, and then gave him back to me. He was the eldest son of Abii Musa.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.219]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 219

Narrated Al-Mughira bin Shuba:

Solar eclipse occurred on the day of Ibrahim's death (the Prophet's son).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.220]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 220

Narrated 'Aisha:

(the wife the Prophet) Allah's Apostle said, "O Aisha! This is Gabriel sending his greetings to you." I said, "Peace, and Allah's Mercy be on him." 'Aisha added: The Prophet used to see things which we used not to see.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.221]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 221

Narrated Anas:

Once Um Sulaim was (with the women who were) in charge of the luggage on a journey, and Anjashah, the slave of the Prophet, was driving their camels (very fast). The Prophet said, "O Anjash! Drive slowly (the camels) with the glass vessels (i.e., ladies)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.222]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 222

Narrated Anas:

The Prophet was the best of all the people in character. I had a brother called Abu 'Umar, who, I think, had been newly weaned. Whenever he (that child) was brought to the Prophet the Prophet used to say, "O Abu 'Umar! What did Al-Nughair (nightingale) (do)?" It was a nightingale with which he used to play. Sometimes the time of the Prayer became due while he (the Prophet) was in our house. He would order that the carpet underneath him be swept and sprayed with water, and then he would stand up (for the prayer) and we would line up behind him, and he would lead us in prayer.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.223]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 223

Narrated Sahl bin Sad:

The most beloved names to 'Ali was Abu Turab, and he used to be pleased when we called him by it, for none named him Abu Turab (for the first time), but the Prophet. Once 'Ali got angry with (his wife) Fatima, and went out (of his house) and slept near a wall in the mosque. The Prophet came searching for him, and someone said, "He is there, Lying near the wall." The Prophet came to him while his ('Ali's) back was covered with dust. The Prophet started removing the dust from his back, saying, "Get up, O Abu Turab!"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.224]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 224

Narrated Abu Huraira:

Allah's Apostle said, "The most awful name in Allah's sight on the Day of Resurrection, will be (that of) a man calling himself Malik Al-Amlak (the king of kings)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.225]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 225

Narrated Abu Huraira:

The Prophet said, "The most awful (meanest) name in Allah's sight." Sufyan said more than once, "The most awful (meanest) name in Allah's sight is (that of) a man calling himself king of kings." Sufyan said, "Somebody else (i.e. other than Abu Az-Zinad, a sub-narrator) says: What is meant by 'The king of kings' is 'Shahan Shah.,"


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.226]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 226

Narrated Usama bin Zaid:

That Allah's Apostle rode over a donkey covered with a Fadakiya (velvet sheet) and Usama was riding behind him. He was visiting Sa'd bin 'Ubada (who was sick) in the dwelling place of Bani Al-Harith bin Al-Khazraj and this incident happened before the battle of Badr. They proceeded till they passed by a gathering in which 'Abdullah bin Ubai bin Salul was present., and that was before 'Abdullah bin Ubat embraced Islam. In that gathering there were Muslims, pagan idolators and Jews, and among the Muslims there was 'Abdullah bin Rawaha.

When a cloud of dust raised by (the movement of ) the animal covered that gathering, 'Abdullah bin Ubai covered his nose with his garment and said, "Do not cover us with dust." Allah's Apostle greeted them, stopped, dismounted and invited them to Allah (i.e. to embrace Islam) and recited to them the Holy Qur'an. On that 'Abdullah bin Ubai bin Salul said to him, "O man! There is nothing better than what you say, if it is the truth. So do not trouble us with it in our gatherings, but if somebody comes to you, you can preach to him." On that 'Abdullah bin Rawaha said "Yes, O Allah's Apostle! Call on us in our gathering, for we love that." So the Muslims, the pagans and the Jews started abusing one another till they were about to fight with one another. Allah's Apostle kept on quietening them till all of them became quiet, and then Allah's Apostle rode his animal and proceeded till he entered upon Sa'd bin 'Ubada. Allah's Apostle said, "O Sa'd! Didn't you hear what Abu Habab said?" (meaning 'Abdullah bin Unbar). "He said so-and-so." Sa'd bin Ubada said, "O Allah's Apostle! Let my father be sacrificed for you ! Excuse and forgive him for, by Him Who revealed to you the Book, Allah sent the Truth which was revealed to you at the time when the people of this town had decided to crown him ('Abdullah bin Ubai) as their ruler.

So when Allah had prevented that with the Truth He had given you, he was choked by that, and that caused him to behave in such an impolite manner which you had noticed." So Allah's Apostle excused him. (It was the custom of) Allah's Apostle and his companions to excuse the pagans and the people of the scripture (Christians and Jews) as Allah ordered them, and they used to be patient when annoyed (by them). Allah said: 'You shall certainly hear much that will grieve you from those who received the Scripture before you.....and from the pagans (3.186)

He also said: 'Many of the people of the scripture wish that if they could turn you away as disbelievers after you have believed. .... (2.109) So Allah's Apostle used to apply what Allah had ordered him by excusing them till he was allowed to fight against them. When Allah's Apostle had fought the battle of Badr and Allah killed whomever He killed among the chiefs of the infidels and the nobles of Quraish, and Allah's Apostle and his companions had returned with victory and booty, bringing with them some of the chiefs of the infidels and the nobles of the Quraish as captives. 'Abdullah bin Ubai bin Salul and the pagan idolators who were with him, said, "This matter (Islam) has now brought out its face (triumphed), so give Allah's Apostle the pledge of allegiance (for embracing Islam.)". Then they became Muslims.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.227]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 227

Narrated 'Abdullah bin Al-Harith bin Naufal:

Abbas bin 'Abdul Muttalib said, "O Allah's Apostle! Did you benefit Abu Talib with anything as he used to protect and take care of you, and used to become angry for you?" The Prophet said, "Yes, he is in a shallow place of Fire. But for me he would have been in the lowest part of the Fire."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.228]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 228

Narrated Anas bin Malik:

Once the Prophet was on one of his journeys, and the driver of the camels started chanting (to let the camels go fast). The Prophet said to him. "(Take care) Drive slowly with the glass vessels, O Anjasha! Waihaka (May Allah be Merciful to you)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.229]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 229

Narrated Anas:

The Prophet was on a journey and a slave named Anjasha was chanting (singing) for the camels to let them go fast (while driving). The Prophet said, "O Anjasha, drive slowly (the camels) with the glass vessels!" Abu Qilaba said, "By the glass vessels' he meant the women (riding the camels)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.230]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 230

Narrated Anas bin Malik:

The Prophet had a Had (a camel driver) called Anjasha, and he had a nice voice. The Prophet said to him, "(Drive) slowly, O Anjasha! Do not break the glass vessels!" And Qatada said, "(By vessels') he meant the weak women."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.231]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 231

Narrated Anas bin Malik:

There was a state of fear in Medina. Allah's Apostle rode a horse belonging to Abu Talha (in order to see the matter). The Prophet said, "We could not see anything, and we found that horse like a sea (fast in speed)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.232]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 232

Narrated 'Aisha:

Some people asked Allah's Apostle about the fore-tellers. Allah's Apostle said to them, "They are nothing (i.e., liars)." The people said, 'O Allah's Apostle ! Sometimes they tell something which comes out to be true." Allah's Apostle said, "That word which comes to be true is what a jinx snatches away by stealing and then pours it in the ear of his fore-teller with a sound similar to the cackle of a hen, and then they add to it one-hundred lies."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.233]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 233

Narrated Jabir bin 'Abdullah:

That he heard Allah's Apostle saying. "Then there was a pause in the revelation of the Divine Inspiration to me. Then while I was walking all of a sudden I heard a voice from the sky, and I raised my sight towards the sky and saw the same angel who had visited me in the cave of Hira,' sitting on a chair between the sky and the earth."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.234]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 234

Narrated Ibn 'Abbas:

Once I stayed overnight at the house of Maimuna and the Prophet was there with her. When it was the last third of the night, or some part of the night, the Prophet got up looking towards the sky and recited: 'Verily! In the creation of the heavens and the earth, and in the alternation of Night and Day, there are indeed signs for men of u understanding.' (3.190)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.235]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 235

Narrated Abu Musa:

That he was in the company of the Prophet in one of the gardens of Medina and in the hand of the Prophet there was a stick, and he was striking (slowly) the water and the mud with it. A man came (at the gate of the garden) and asked permission to enter. The Prophet said, "Open the gate for him and give him the glad tidings of entering Paradise. "I went, and behold! It was Abu Bakr. So I opened the gate for him and informed him of the glad tidings of entering Paradise. Then another man came and asked permission to enter. The Prophet said, "Open the gate for him and give him the glad tidings of entering Paradise." Behold! It was 'Umar. So I opened the gate for him and gave him the glad tidings of entering Paradise. Then another man came and asked permission to enter.

The Prophet was sitting in a leaning posture, so he sat up and said, "Open the gate for him and give him the glad tidings of entering Paradise with a calamity which will befall him or which will take place." I went, and behold ! It was Uthman. So I opened the gate for him and gave him the glad tidings of entering Paradise and also informed him of what the Prophet had said (about a calamity). 'Uthman said, "Allah Alone Whose Help I seek (against that calamity).


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.236]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 236

Narrated 'Ali:

We were with the Prophet in a funeral procession, and he started scraping the ground with a small stick and said, "There is none amongst you but has been assigned a place (either) in Paradise and (or) in the Hell-Fire." The people said (to him), "Should we not depend upon it?" He said: carry on doing (good) deeds, for everybody will find easy such deeds as will lead him to his destined place. He then recited: "As for him who gives (in charity) and keeps his duty to Allah.." (92.5)


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.237]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 237

Narrated Um Salama:

(One night) the Prophet woke up and said, "Subhan Allah ! How many treasures have been (disclosed) sent down! And how many afflictions have been descended! Who will go and wake the sleeping lady-occupants up of these dwellings (for praying)?" (He meant by this his wives.) The Prophet added, "A well-dressed soul (person) in this world may be naked in the "Hereafter." 'Umar said, "I asked the Prophet, 'Have you divorced your wives?' He said, 'No.' I said, 'Allahu Akbar.' "


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.238]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 238

Narrated Safiya bint Huyai:

The wife of the Prophet that she went to Allah's Apostle while he was in Itikaf (staying in the mosque) during the last ten nights of the month of Ramadan. She spoke to him for an hour (a while) at night and then she got up to return home. The Prophet got up to accompany her, and when they reached the gate of the mosque opposite the dwelling place of Um Salama, the wife of the Prophet, two Ansari men passed by, and greeting Allah's Apostle , they quickly went ahead. Allah's Apostle said to them, "Do not be in a hurry She is Safiya, the daughter of Huyai." They said, "Subhan Allah! O Allah's Apostle (how dare we suspect you)." That was a great thing for both of them. The Prophet then said, "Satan runs in the body of Adam's son (i.e. man) as his blood circulates in it, and I was afraid that he (Satan) might insert an evil thought in your hearts."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.239]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 239

Narrated 'Abdullah bin Mughaffal Al-Muzani:

The Prophet forbade the throwing of stones (with the thumb and the index or middle finger), and said "It neither hunts a game nor kills (or hurts) an enemy, but it gouges out an eye or breaks a tooth."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.240]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 240

Narrated Anas bin Malik:

Two men sneezed before the Prophet. The Prophet said to one of them, "May Allah bestow His Mercy on you," but he did not say that to the other. On being asked (why), the Prophet said, "That one praised Allah (at the time of sneezing), while the other did not praise Allah."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.241]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 241

Narrated Al-Bara:

The Prophet ordered us to do seven (things) and forbade us from seven (other things): He ordered us to pay a visit to the sick, to follow funeral possessions, to say: May Allah be merciful to you to a sneezer, - if he says: Praise be to Allah, to accept invitation (invitation to a wedding banquet), to return greetings, to help the oppressed, and to help others to fulfill their oaths (provided it was not sinful). And he forbade us from seven (things): to wear golden rings or golden bangles, to wear silk (cloth), Dibaj, Sundus and Mayathir.


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.242]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 242

Narrated Abu Huraira:

The Prophet said, "Allah likes sneezing and dislikes yawning, so if someone sneezes and then praises Allah, then it is obligatory on every Muslim who heard him, to say: May Allah be merciful to you (Yar-hamuka-l-lah). But as regards yawning, it is from Satan, so one must try one's best to stop it, if one says 'Ha' when yawning, Satan will laugh at him."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.243]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 243

Narrated Abu Huraira:

The Prophet said, " If anyone of you sneezes, he should say 'Al-Hamdulillah' (Praise be to Allah), and his (Muslim) brother or companion should say to him, 'Yar-hamuka-l-lah' (May Allah bestow his Mercy on you). When the latter says 'Yar-hamuka-llah", the former should say, 'Yahdikumul-lah wa Yuslih balakum' (May Allah give you guidance and improve your condition)."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.244]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 244

Narrated Anas:

Two men sneezed before the Prophet and he said Tashmit to one of them, while he did not say Tashmit to the other. So that man said, "O Allah's Apostle! You said Tashmit to that fellow but you did not say Tashmit to me. "The Prophet said, "That man praised Allah, but you did not praise Allah."


Bukhari :: Good Manners and Form (Al-Adab) :: [8.73.245]

Good Manners and Form (Al-Adab)

Bukhari :: Book 8 :: Volume 73 :: Hadith 245

Narrated Abu Huraira:

The Prophet said, "Allah loves sneezing but dislikes yawning; so if anyone of you sneezes and then praises Allah, every Muslim who hears him (praising Allah) has to say Tashmit to him. But as regards yawning, it is from Satan, so if one of you yawns, he should try his best to stop it, for when anyone of you yawns, Satan laughs at him."


Bukhari :: Asking Permission :: [8.74.246]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 246

Narrated Abu Huraira:

The Prophet said, "Allah created Adam in his complete shape and form (directly), sixty cubits (about 30 meters) in height. When He created him, He said (to him), "Go and greet that group of angels sitting there, and listen what they will say in reply to you, for that will be your greeting and the greeting of your offspring." Adam (went and) said, 'As-Salamu alaikum (Peace be upon you).' They replied, 'AsSalamu-'Alaika wa Rahmatullah (Peace and Allah's Mercy be on you) So they increased 'Wa Rahmatullah' The Prophet added 'So whoever will enter Paradise, will be of the shape and form of Adam. Since then the creation of Adam's (offspring) (i.e. stature of human beings is being diminished continuously) to the present time."


Bukhari :: Asking Permission :: [8.74.247]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 247

Narrated 'Abdullah bin 'Abbas:

Al-Fadl bin 'Abbas rode behind the Prophet as his companion rider on the back portion of his she camel on the Day of Nahr (slaughtering of sacrifice, 10th Dhul-Hijja) and Al-Fadl was a handsome man. The Prophet stopped to give the people verdicts. In the meantime, a beautiful woman From the tribe of Khath'am came, asking the verdict of Allah's Apostle. Al-Fadl started looking at her as her beauty attracted him. The Prophet looked behind while Al-Fadl was looking at her; so the Prophet held out his hand backwards and caught the chin of Al-Fadl and turned his face (to the owner sides in order that he should not gaze at her. She said, "O Allah's Apostle! The obligation of Performing Hajj enjoined by Allah on His worshipers, has become due (compulsory) on my father who is an old man and who cannot sit firmly on the riding animal. Will it be sufficient that I perform Hajj on his behalf?" He said, "Yes."


Bukhari :: Asking Permission :: [8.74.248]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 248

Narrated Abu Said Al-Khudri:

The Prophet said, 'Beware! Avoid sitting on the roads." They (the people) said, "O Allah s Apostle! We can't help sitting (on the roads) as these are (our places) here we have talks." The Prophet said, ' l f you refuse but to sit, then pay the road its right ' They said, "What is the right of the road, O Allah's Apostle?" He said, 'Lowering your gaze, refraining from harming others, returning greeting, and enjoining what is good, and forbidding what is evil."


Bukhari :: Asking Permission :: [8.74.249]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 249

Narrated 'Abdullah:

When we prayed with the Prophet we used to say: As-Salam be on Allah from His worshipers, As-Salam be on Gabriel, As-Salam be on Michael, As-Salam be on so-and-so. When the Prophet finished his prayer, he faced us and said, "Allah Himself is As-Salam (Peace), so when one sits in the prayer, one should say, 'At-Tahiyatu-lillahi Was-Salawatu, Wat-Taiyibatu, As-Salamu 'Alaika aiyuhan-Nabiyyu wa Rah-matul-lahi wa Barakatuhu, As-Salamu 'Alaina wa 'ala 'Ibadillahi assalihin, for if he says so, then it will be for all the pious slave of Allah in the Heavens and the Earth. (Then he should say), 'Ash-hadu an la ilaha illalllahu wa ash-hadu anna Muhammadan 'Abduhu wa rasulu-hu,' and then he can choose whatever speech (i.e. invocation) he wishes " (See Hadith No. 797, Vol. 1)


Bukhari :: Asking Permission :: [8.74.250]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 250

Narrated Abu Huraira:

The Prophet said, "The young should greet the old, the passer by should greet the sitting one, and the small group of persons should greet the large group of persons. "


Bukhari :: Asking Permission :: [8.74.251]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 251

Narrated Abu Huraira:

Allah's Apostle said, "The riding one should greet the walking one, and the walking one should greet the sitting one, and the small number of persons should greet the large number of persons."


Bukhari :: Asking Permission :: [8.74.252]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 252

Narrated Abu Huraira:

Allah's Apostle said, "The younger person should greet the older one, and the walking person should greet the sitting one, and the small number of persons should greet the large number of persons."


Bukhari :: Asking Permission :: [8.74.253]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 253

Narrated 'Abdullah bin 'Amr:

A man asked the Prophet, "What Islamic traits are the best?" The Prophet said, "Feed the people, and greet those whom you know and those whom you do not know."


Bukhari :: Asking Permission :: [8.74.254]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 254

Narrated Abu Aiyub:

The Prophet said, "It is not lawful for a Muslim to desert (not to speak to) his brother Muslim for more than three days while meeting, one turns his face to one side and the other turns his face to the other side. Lo! The better of the two is the one who starts greeting the other."


Bukhari :: Asking Permission :: [8.74.255]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 255

Narrated Anas bin Malik:

that he was a boy of ten at the time when the Prophet emigrated to Medina. He added: I served Allah's Apostle for ten years (the last part of his life time) and I know more than the people about the occasion whereupon the order of Al-Hijab was revealed (to the Prophet). Ubai b n Ka'b used to ask me about it. It was revealed (for the first time) during the marriage of Allah's Apostle with Zainab bint Jahsh. In the morning, the Prophet was a bride-groom of her and he Invited the people, who took their meals and went away, but a group of them remained with Allah's Apostle and they prolonged their stay. Allah's Apostle got up and went out, and I too, went out along with him till he came to the lintel of 'Aisha's dwelling place. Allah's Apostle thought that those people had left by then, so he returned, and I too, returned with him till he entered upon Zainab and found that they were still sitting there and had not yet gone. The Prophet went out again, and so did I with him till he reached the lintel of 'Aisha's dwelling place, and then he thought that those people must have left by then, so he returned, and so did I with him, and found those people had gone. At that time the Divine Verse of Al-Hijab was revealed, and the Prophet set a screen between me and him (his family).


Bukhari :: Asking Permission :: [8.74.256]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 256

Narrated Anas:

When the Prophet married Zainab, the people came and were offered a meal, and then they sat down (after finishing their meals) and started chatting. The Prophet showed as if he wanted to get up, but they did not get up. When he noticed that, he got up, and some of the people also got up and went away, while some others kept on sitting. When the Prophet returned to enter, he found the people still sitting, but then they got up and left. So I told the Prophet of their departure and he came and went in. I intended to go in but the Prophet put a screen between me and him, for Allah revealed:-- 'O you who believe! Enter not the Prophet's houses..' (33.53)


Bukhari :: Asking Permission :: [8.74.257]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 257

Narrated 'Aisha:

(the wife of the Prophet) 'Umar bin Al-Khattab used to say to Allah's Apostle "Let your wives be veiled" But he did not do so. The wives of the Prophet used to go out to answer the call of nature at night only at Al-Manasi.' Once Sauda, the daughter of Zam'a went out and she was a tall woman. 'Umar bin Al-Khattab saw her while he was in a gathering, and said, "I have recognized you, O Sauda!" He ('Umar) said so as he was anxious for some Divine orders regarding the veil (the veiling of women.) So Allah revealed the Verse of veiling. (Al-Hijab; a complete body cover excluding the eyes). (See Hadith No. 148, Vol. 1)


Bukhari :: Asking Permission :: [8.74.258]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 258

Narrated Sahl bin Sa'd:

A man peeped through a round hole into the dwelling place of the Prophet, while the Prophet had a Midray (an iron comb) with which he was scratching his head. the Prophet said, " Had known you were looking (through the hole), I would have pierced your eye with it (i.e., the comb)." Verily! The order of taking permission to enter has been enjoined because of that sight, (that one should not look unlawfully at the state of others). (See Hadith No. 807, Vol. 7)


Bukhari :: Asking Permission :: [8.74.259]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 259

Narrated Anas bin Malik:

A man peeped into a room of the Prophet. The Prophet stood up, holding an arrow head. It is as if I am just looking at him, trying to stab the man.


Bukhari :: Asking Permission :: [8.74.260]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 260

Narrated Ibn 'Abbas:

I have not seen a thing resembling 'lamam' (minor sins) than what Abu Huraira 'narrated from the Prophet who said "Allah has written for Adam's son his share of adultery which he commits inevitably. The adultery of the eyes is the sight (to gaze at a forbidden thing), the adultery of the tongue is the talk, and the inner self wishes and desires and the private parts testify all this or deny it."


Bukhari :: Asking Permission :: [8.74.261]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 261

Narrated Anas:

Whenever Allah's Apostle greeted somebody, he used to greet him three times, and if he spoke a sentence, he used to repeat it thrice.


Bukhari :: Asking Permission :: [8.74.262]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 262

Narrated Abu Said Al-Khudri:

While I was present in one of the gatherings of the Ansar, Abu Musa came as if he was scared, and said, "I asked permission to enter upon 'Umar three times, but I was not given the permission, so I returned." (When 'Umar came to know about it) he said to Abu Musa, "Why did you not enter?'. Abu Musa replied, "I asked permission three times, and I was not given it, so I returned, for Allah's Apostle said, "If anyone of you asks the permission to enter thrice, and the permission is not given, then he should return.' " 'Umar said, "By Allah! We will ask Abu Musa to bring witnesses for it." (Abu Musa went to a gathering of the Ansar and said). "Did anyone of you hear this from the Prophet ?" Ubai bin Ka'b said, "By Allah, none will go with you but the youngest of the people (as a witness)." (Abu Said) was the youngest of them, so I went with Abu Musa and informed 'Umar that the Prophet had said so. (See Hadith No. 277, Vol. 3)


Bukhari :: Asking Permission :: [8.74.263]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 263

Narrated Abu Huraira:

I entered (the house) along with Allah's Apostle . There he found milk in a basin. He said, "O Abu Hirr! Go and call the people of Suffa to me." I went to them and invited them. They came and asked permission to enter, and when it was given, they entered. (See Hadith No. 459 for details)


Bukhari :: Asking Permission :: [8.74.264]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 264

Narrated Anas bin Malik:

that he passed by a group of boys and greeted them and said, "The Prophet used to do so."


Bukhari :: Asking Permission :: [8.74.265]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 265

Narrated Abu Hazim:

Sahl said, "We used to feel happy on Fridays." I asked Sahl, "Why?" He said, "There was an old woman of our acquaintance who used to send somebody to Buda'a (Ibn Maslama said, "Buda'a was a garden of date-palms at Medina). She used to pull out the silq (a kind of vegetable) from its roots and put it in a cooking pot, adding some powdered barley over it (and cook it). After finishing the Jumua (Friday) prayer we used to (pass by her and) greet her, whereupon she would present us with that meal, so we used to feel happy because of that. We used to have neither a midday nap, nor meals, except after the Friday prayer." (See Hadith No. 60, Vol.2)


Bukhari :: Asking Permission :: [8.74.266]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 266

Narrated 'Aisha:

Allah's Apostle said, "O 'Aisha! This is Gabriel sending his greetings to you." I said, "Peace, and Allah's Mercy be on him (Gabriel). You see what we do not see." (She was addressing Allah's Apostle).


Bukhari :: Asking Permission :: [8.74.267]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 267

Narrated Jabir:

I came to the Prophet in order to consult him regarding my father's debt. When I knocked on the door, he asked, "Who is that?" I replied, "I" He said, "I, I?" He repeated it as if he disliked it.


Bukhari :: Asking Permission :: [8.74.268]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 268

Narrated Abu Huraira:

A man entered the mosque while Allah's Apostle was sitting in one side of the mosque. The man prayed, came, and greeted the Prophet. Allah's Apostle said to him, "Wa 'Alaikas Salam (returned his greeting). Go back and pray as you have not prayed (properly)." The man returned, repeated his prayer, came back and greeted the Prophet. The Prophet said, "Wa alaika-s-Salam (returned his greeting). Go back and pray again as you have not prayed (properly)." The man said at the second or third time, "O Allah's Apostle! Kindly teach me how to pray". The Prophet said, "When you stand for prayer, perform ablution properly and then face the Qibla and say Takbir (Allahu-Akbar), and then recite what you know from the Qur'an, and then bow with calmness till you feel at ease then rise from bowing, till you stand straight, and then prostrate calmly (and remain in prostration) till you feel at ease, and then raise (your head) and sit with calmness till you feel at ease and then prostrate with calmness (and remain in prostration) till you feel at ease, and then raise (your head) and sit with calmness till you feel at ease in the sitting position, and do likewise in whole of your prayer." And Abu Usama added, "Till you stand straight." (See Hadith No. 759, Vol.1)


Bukhari :: Asking Permission :: [8.74.269]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 269

Narrated Abu Huraira:

The Prophet said (in the above narration No. 268), "And then raise your head till you feel at ease while sitting. "


Bukhari :: Asking Permission :: [8.74.270]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 270

Narrated 'Aisha: that the Prophet said to her, "Gabriel sends Salam (greetings) to you." She replied, "Wa 'alaihi-s-Salam Wa Rahmatu-l-lah." (Peace and Allah's Mercy be on him).


Bukhari :: Asking Permission :: [8.74.271]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 271

Narrated 'Urwa-bin Az-Zubair:

Usama bin Zaid said, "The Prophet rode over a donkey with a saddle underneath which there was a thick soft Fadakiya velvet sheet. Usama bin Zaid was his companion rider, and he was going to pay a visit to Sa'd bin Ubada (who was sick) at the dwelling place of Bani Al-Harith bin Al-Khazraj, and this incident happened before the battle of Badr. The Prophet passed by a gathering in which there were Muslims and pagan idolators and Jews, and among them there was 'Abdullah bin Ubai bin Salul, and there was 'Abdullah bin Rawaha too. When a cloud of dust raised by the animal covered that gathering, 'Abdullah bin Ubai covered his nose with his Rida (sheet) and said (to the Prophet), "Don't cover us with dust." The Prophet greeted them and then stopped, dismounted and invited them to Allah (i.e., to embrace Islam) and also recited to them the Holy Quran. 'Abdullah bin Ubai' bin Salul said, "O man! There is nothing better than what you say, if what you say is the truth. So do not trouble us in our gatherings. Go back to your mount (or house,) and if anyone of us comes to you, tell (your tales) to him." On that 'Abdullah bin Rawaha said, "(O Allah's Apostle!) Come to us and bring it(what you want to say) in our gatherings, for we love that." So the Muslims, the pagans and the Jews started quarreling till they were about to fight and clash with one another. The Prophet kept on quietening them (till they all became quiet). He then rode his animal, and proceeded till he entered upon Sa'd bin 'Ubada, he said, "O Sa'd, didn't you hear what Abu Habbab said? (He meant 'Abdullah bin Ubai). He said so-and-so." Sa'd bin 'Ubada said, "O Allah's Apostle! Excuse and forgive him, for by Allah, Allah has given you what He has given you. The people of this town decided to crown him (as their chief) and make him their king. But when Allah prevented that with the Truth which He had given you, it choked him, and that was what made him behave in the way you saw him behaving." So the Prophet excused him.


Bukhari :: Asking Permission :: [8.74.272]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 272

Narrated 'Abdullah bin Ka'b:

I heard Ka'b bin Malik narrating (when he did not join the battle of Tabuk): Allah's Apostle forbade all the Muslims to speak to us. I would come to Allah's Apostle and greet him, and I would wonder whether the Prophet did move his lips to return to my greetings or not till fifty nights passed away. The Prophet then announced (to the people) Allah's forgiveness for us (acceptance of our repentance) at the time when he had offered the Fajr (morning) prayer.


Bukhari :: Asking Permission :: [8.74.273]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 273

Narrated 'Aisha:

A group of Jews came to Allah's Apostle and said, "As-samu 'Alaika " (Death be on you), and I understood it and said to them, "Alaikum AsSamu wa-l-la'na (Death and curse be on you)." Allah's Apostle said, "Be calm! O 'Aisha, for Allah loves that one should be kind and lenient in all matters." I said. "O Allah's Apostle! Haven't you heard what they have said?" Allah's Apostle said, "I have (already) said (to them), 'Alaikum (upon you).' "


Bukhari :: Asking Permission :: [8.74.274]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 274

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "When the Jews greet you, they usually say, 'As-Samu 'alaikum (Death be on you),' so you should say (in reply to them), 'Wa'alaikum (And on you)."


Bukhari :: Asking Permission :: [8.74.275]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 275

Narrated Anas bin Malik:

the Prophet said, "If the people of the Scripture greet you, then you should say (in reply), 'Wa'alaikum (And on you).' "


Bukhari :: Asking Permission :: [8.74.276]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 276

Narrated 'Ali:

Allah's Apostle sent me, Az-Zubair bin Al-Awwam and Abu Marthad Al-Ghanawi, and all of us were horsemen, and he said, "Proceed till you reach Rawdat Khakh, where there is a woman from the pagans carrying a letter sent by Hatib bin Abi Balta'a to the pagans (of Mecca)." So we overtook her while she was proceeding on her camel at the same place as Allah's Apostle told us. We said (to her) "Where is the letter which is with you?" She said, "I have no letter with me." So we made her camel kneel down and searched her mount (baggage etc) but could not find anything. My two companions said, "We do not see any letter." I said, "I know that Allah's Apostle did not tell a lie. By Allah, if you (the lady) do not bring out the letter, I will strip you of your clothes' When she noticed that I was serious, she put her hand into the knot of her waist sheet, for she was tying a sheet round herself, and brought out the letter. So we proceeded to Allah's Apostle with the letter. The Prophet said (to Habib), "What made you o what you have done, O Hatib?" Hatib replied, "I have done nothing except that I believe in Allah and His Apostle, and I have not changed or altered (my religion). But I wanted to do the favor to the people (pagans of Mecca) through which Allah might protect my family and my property, as there is none among your companions but has someone in Mecca through whom Allah protects his property (against harm). The Prophet said, "Habib has told you the truth, so do not say to him (anything) but good." 'Umar bin Al-Khattab said, "Verily he has betrayed Allah, His Apostle, and the believers! Allow me to chop his neck off!" The Prophet said, "O 'Umar! What do you know; perhaps Allah looked upon the Badr warriors and said, 'Do whatever you like, for I have ordained that you will be in Paradise.'" On that 'Umar wept and said, "Allah and His Apostle know best."


Bukhari :: Asking Permission :: [8.74.277]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 277

Narrated Abu Sufyan bin Harb:

that Heraclius had sent for him to come along with a group of the Quraish who were trading in Sha'm, and they came to him. Then Abu Sufyan mentioned the whole narration and said, "Heraclius asked for the letter of Allah's Apostle . When the letter was read, its contents were as follows: 'In the name of Allah, the Beneficent, the Merciful. From Muhammad, Allah's slave and His Apostle to Heraclius, the Chief of Byzantines: Peace be upon him who follows the right path (guidance)! Amma ba'du (to proceed )...' (See Hadith No 6, Vol 1 for details)


Bukhari :: Asking Permission :: [8.74.278]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 278

Narrated Abu Said:

The people of (the tribe of) Quraiza agreed upon to accept the verdict of Sa'd. The Prophet sent for him (Sa'd) and he came. The Prophet said (to those people), "Get up for your chief or the best among you!" Sa'd sat beside the Prophet and the Prophet said (to him), "These people have agreed to accept your verdict." Sa'd said, "So I give my judgment that their warriors should be killed and their women and children should be taken as captives." The Prophet said, "You have judged according to the King's (Allah's) judgment." (See Hadith No. 447, Vol. 5)


Bukhari :: Asking Permission :: [8.74.279]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 279

Narrated Qatada:

I asked Anas, "Was it a custom of the companions of the Prophet to shake hands with one another?" He said, "Yes."


Bukhari :: Asking Permission :: [8.74.280]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 280

Narrated 'Abdullah bin Hisham:

We were in the company of the Prophet and he was holding the hand of 'Umar bin Al-Khattab.


Bukhari :: Asking Permission :: [8.74.281]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 281

Narrated Ibn Mas'ud:

Allah's Apostle taught me the Tashah-hud as he taught me a Sura from the Quran, while my hand was between his hands. (Tashah-hud was) all the best compliments and the prayers and the good things are for Allah. Peace and Allah's Mercy and Blessings be on you, O Prophet! Peace be on us and on the pious slaves of Allah, I testify that none has the right to be worshipped but Allah, and I also testify that Muhammad is Allah's slave and His Apostle. (We used to recite this in the prayer) during the lifetime of the Prophet , but when he had died, we used to say, "Peace be on the Prophet."


Bukhari :: Asking Permission :: [8.74.282]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 282

Narrated 'Abdullah bin 'Abbas:

'Ali bin Abu Talib came out of the house of the Prophet during his fatal ailment. The people asked ('Ali), "O Abu Hasan! How is the health of Allah's Apostle this morning?" 'Ali said, "This morning he is better, with the grace of Allah." Al-'Abbas held Ali by the hand and said, "Don't you see him (about to die)? By Allah, within three days you will be the slave of the stick (i.e., under the command of another ruler). By Allah, I think that Allah's Apostle will die from his present ailment, for I know the signs of death on the faces of the offspring of 'Abdul Muttalib. So let us go to Allah's Apostle to ask him who will take over the Caliphate. If the authority is given to us, we will know it, and if it is given to somebody else we will request him to recommend us to him. " 'Ali said, "By Allah! If we ask Allah's Apostle for the rulership and he refuses, then the people will never give it to us. Besides, I will never ask Allah's Apostle for it." (See Hadith No 728, Vol 5)


Bukhari :: Asking Permission :: [8.74.283]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 283

Narrated Muadh:

While I was a companion rider with the Prophet he said, "O Mu'adh!" I replied, "Labbaik wa Sa'daik." He repeated this call three times and then said, "Do you know what Allah's Right on His slaves is?" I replied, "No." He said, Allah's Right on His slaves is that they should worship Him (Alone) and should not join partners in worship with Him." He said, "O Mu'adh!" I replied, "Labbaik wa Sa'daik." He said, "Do you know what the right of (Allah's) salves on Allah is, if they do that (worship Him Alone and join none in His worship)? It is that He will not punish them."


Bukhari :: Asking Permission :: [8.74.284]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 284

Narrated Mu'adh:

as above, No. 283.


Bukhari :: Asking Permission :: [8.74.285]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 285

Narrated Abu Dhar:

While I was walking with the Prophet at the Hurra of Medina in the evening, the mountain of Uhud appeared before us. The Prophet said, "O Abu Dhar! I would not like to have gold equal to Uhud (mountain) for me, unless nothing of it, not even a single Dinar remains of it with me, for more than one day or three days, except that single Dinar which I will keep for repaying debts. I will spend all of it (the whole amount) among Allah's slaves like this and like this and like this." The Prophet pointed out with his hand to illustrate it and then said, "O Abu Dhar!" I replied, "Labbaik wa Sa'daik, O Allah's Apostle!" He said, "Those who have much wealth (in this world) will be the least rewarded (in the Hereafter) except those who do like this and like this (i.e., spend their money in charity)." Then he ordered me, "Remain at your place and do not leave it, O Abu Dhar, till I come back." He went away till he disappeared from me. Then I heard a voice and feared that something might have happened to Allah's Apostle, and I intended to go (to find out) but I remembered the statement of Allah's Apostle that I should not leave, my place, so I kept on waiting (and after a while the Prophet came), and I said to him, "O Allah's Apostle, I heard a voice and I was afraid that something might have happened to you, but then I remembered your statement and stayed (there). The Prophet said, "That was Gabriel who came to me and informed me that whoever among my followers died without joining others in worship with Allah, would enter Paradise." I said, "O Allah's Apostle! Even if he had committed illegal sexual intercourse and theft?" He said, "Even if he had committed illegal sexual intercourse and theft '


Bukhari :: Asking Permission :: [8.74.286]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 286

Narrated Ibn 'Umar:

The Prophet said, "A man should not make another man get up from his (the latter's) seat (in a gathering) in order to sit there.


Bukhari :: Asking Permission :: [8.74.287]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 287

Narrated Ibn 'Umar:

The Prophet forbade that a man should be made to get up from his seat so that another might sit on it, but one should make room and spread out. Ibn 'Umar disliked that a man should get up from his seat and then somebody else sit at his place.


Bukhari :: Asking Permission :: [8.74.288]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 288

Narrated Anas bin Malik:

When Allah's Apostle married Zainab bint Jahsh, he invited the people who took their meals and then remained sitting and talking. The Prophet pretended to be ready to get up, but the people did not get up. When he noticed that, he got up, and when he had got up, some of those people got up along with him and there remained three (who kept on sitting). Then the Prophet came back and found those people still sitting. Later on those people got up and went away. So I went to the Prophet and informed him that they had left.

The Prophet came, and entered (his house). I wanted to enter(along with him) but he dropped a curtain between me and him. Allah then revealed: 'O you who believe! Do not enter the Prophet's Houses until leave is given... (to His statement)... Verily! That shall be an enormity, in Allah's sight.' (33.53)


Bukhari :: Asking Permission :: [8.74.289]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 289

Narrated Ibn 'Umar:

I saw Allah's Apostle in the courtyard of the Ka'ba in the Ihtiba.' posture putting his hand round his legs like this.


Bukhari :: Asking Permission :: [8.74.290]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 290

Narrated Abu Bakra:

Allah's Apostle said, "Shall I inform you of the biggest of the great sins?" They said, "Yes, O Allah's Apostle!" He said, "To join partners in worship with Allah, and to be undutiful to one's parents. "


Bukhari :: Asking Permission :: [8.74.291]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 291

Narrated Bishr:

as above (No. 290) adding: The Prophet was reclining (leaning) and then he sat up saying, "And I warn you against giving a false statement." And he kept on saying that warning so much so that we said, "Would that he had stopped."


Bukhari :: Asking Permission :: [8.74.292]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 292

Narrated 'Uqba bin Al-Harith:

Once the Prophet offered the 'Asr prayer and then he walked quickly and entered his house.


Bukhari :: Asking Permission :: [8.74.293]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 293

Narrated 'Aisha:

Allah's Apostle used to offer his prayer (while standing) in the midst of the bed, and I used to lie in front of him between him and the Qibla It I had any necessity for getting up and I used to dislike to get up and face him (while he was in prayer), but I would gradually slip away from the bed.


Bukhari :: Asking Permission :: [8.74.294]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 294

Narrated Abdullah bin 'Amr:

The news of my fasting was mentioned to the Prophet . So he entered upon me and I put for him a leather cushion stuffed with palm-fibres. The Prophet sat on the floor and the cushion was between me and him. He said to me, "Isn't it sufficient for you (that you fast) three days a month?" I said, "O Allah's Apostle! (I can fast more than this)." He said, "You may fast) five days a month." I said, "O Allah's Apostle! (I can fast more than this)." He said, "(You may fast) seven days." I said, "O Allah's Apostle!" He said, "Nine." I said, "O Allah's Apostle!" He said, "Eleven." I said, "O Allah's Apostle!" He said, "No fasting is superior to the fasting of (the Prophet David) which was one half of a year, and he used, to fast on alternate days. (See Hadith No. 300, Vol 3)


Bukhari :: Asking Permission :: [8.74.295]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 295

Narrated Ibrahim:

'Alaqama went to Sham and came to the mosque and offered a two-Rak'at prayer, and invoked Allah: "O Allah! Bless me with a (pious) good companion." So he sat beside Abu Ad-Darda' who asked, "From where are you?" He said, "From the people of Kufa." Abu Darda' said, "Wasn't there among you the person who keeps the secrets (of the Prophet ) which nobody knew except him (i.e., Hudhaifa (bin Al-Yaman)). And isn't there among you the person whom Allah gave refuge from Satan through the request (tongue) of Allah's Apostle? (i.e., 'Ammar). Isn't there among you the one who used to carry the Siwak and the cushion (or pillows (of the Prophets)? (i.e., Ibn Mas'ud). How did Ibn Mas'ud use to recite 'By the night as it conceals (the light)?" (Sura 92). 'Alqama said, "Wadhdhakari Wal Untha' (And by male and female.") Abu Ad-Darda added. 'These people continued to argue with me regarding it till they were about to cause me to have doubts although I heard it from Allah's Apostle "


Bukhari :: Asking Permission :: [8.74.296]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 296

Narrated Sahl bin Sad:

We used to have a midday nap and take our meals after the Jumua (prayer).


Bukhari :: Asking Permission :: [8.74.297]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 297

Narrated Sahl bin Sad:

There was no name dearer to 'Ali than his nickname Abu Turab (the father of dust). He used to feel happy whenever he was called by this name. Once Allah's Apostle came to the house of Fatima but did not find 'Ali in the house. So he asked "Where is your cousin?" She replied, "There was something (a quarrel) between me and him whereupon he got angry with me and went out without having a midday nap in my house." Allah's Apostle asked a person to look for him. That person came, and said, "O Allah's Apostle! He (Ali) is sleeping in the mosque." So Allah's Apostle went there and found him lying. His upper body cover had fallen off to one side of his body, and so he was covered with dust. Allah's Apostle started cleaning the dust from him, saying, "Get up, O Abu Turab! Get up, Abu Turab!" (See Hadith No. 432, Vol 1)


Bukhari :: Asking Permission :: [8.74.298]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 298

Narrated Thumama:

Anas said, "Um Sulaim used to spread a leather sheet for the Prophet and he used to take a midday nap on that leather sheet at her home." Anas added, "When the Prophet had slept, she would take some of his sweat and hair and collect it (the sweat) in a bottle and then mix it with Suk (a kind of perfume) while he was still sleeping. "When the death of Anas bin Malik approached, he advised that some of that Suk be mixed with his Hanut (perfume for embalming the dead body), and it was mixed with his Hanut.


Bukhari :: Asking Permission :: [8.74.299]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 299

Narrated Anas bin Malik:

Whenever Allah's Apostle went to Quba, he used to visit Um Haram bint Milhan who would offer him meals; and she was the wife of 'Ubada bin As-samit. One day he went to her house and she offered him a meal, and after that he slept, and then woke up smiling. She (Um Haram) said, "I asked him, 'What makes you laugh, O Allah's Apostle?' He said, 'Some people of my followers were displayed before me as warriors fighting for Allah's Cause and sailing over this sea, kings on thrones,' or said, 'like kings on thrones.' (The narrator, Ishaq is in doubt about it.) I (Um Haram) said, 'O Allah's Apostle! Invoke Allah that He may make me one of them.' He invoked (Allah) for her and then lay his head and slept again and then woke up smiling. I asked, 'What makes you laugh, O Allah's Apostle?' He said, 'Some people of my followers were displayed before me as warriors fighting for Allah's Cause and sailing over this sea, kings on the thrones,' or said, 'like kings on the thrones.' I (Um Haram) said, 'O Allah's Apostle! Invoke Allah that He may make me one of them.' He said, You will be amongst the first ones." It is said that Um Haram sailed over the sea at the time of Muawiya, and on coming out of the sea, she fell down from her riding animal and died.


Bukhari :: Asking Permission :: [8.74.300]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 300

Narrated Abu Sa'id Al-Khudri:

The Prophet forbade two kinds of dresses and two kinds of bargains; Ishtimal As-Samma and Al-Ihtiba in one garment with no part of it covering one's private parts. (The two kinds of bargains were:) Al-Mulamasa and Al-Munabadha.


Bukhari :: Asking Permission :: [8.74.301]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 301

Narrated 'Aisha:

He added, 'But this year he reviewed it with me twice, and therefore I think that my time of death has approached. So, be afraid of Allah, and be patient, for I am the best predecessor for you (in the Hereafter).' " Fatima added, "So I wept as you ('Aisha) witnessed. And when the Prophet saw me in this sorrowful state, he confided the second secret to me saying, 'O Fatima! Will you not be pleased that you will be chief of all the believing women (or chief of the women of this nation i.e. my followers?")


Bukhari :: Asking Permission :: [8.74.302]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 302

Narrated the uncle of 'Abbas bin Tamim:

I saw Allah's Apostle lying on his back in the mosque and putting one of his legs over the other.


Bukhari :: Asking Permission :: [8.74.303]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 303

Narrated 'Abdullah:

the Prophet said "When three persons are together, then no two of them should hold secret counsel excluding the third person."


Bukhari :: Asking Permission :: [8.74.304]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 304

Narrated Anas bin Malik:

The Prophet confided to me a secret which I did not disclose to anybody after him. And Um Sulaim asked me (about that secret) but I did not tell her.


Bukhari :: Asking Permission :: [8.74.305]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 305

Narrated 'Abdullah:

The Prophet said, "When you are three persons sitting together, then no two of you should hold secret counsel excluding the third person until you are with some other people too, for that would grieve him."


Bukhari :: Asking Permission :: [8.74.306]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 306

Narrated 'Abdullah:

One day the Prophet divided and distributed something amongst the people whereupon an Ansari man said, "In this division Allah's Countenance has not been sought." I said, "By Allah! I will go (and inform) the Prophet." So I went to him while he was with a group of people, and I secretly informed him of that, whereupon he became so angry that his face became red, and he then said, "May Allah bestow His Mercy on Moses (for) he was hurt more than that, yet he remained patient."


Bukhari :: Asking Permission :: [8.74.307]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 307

Narrated Anas:

The Iqama for the prayer was announced while a man was talking to Allah's Apostle privately. He continued talking in that way till the Prophet's companions slept, and afterwards the Prophet got up and offered the prayer with them.


Bukhari :: Asking Permission :: [8.74.308]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 308

Narrated Salim's father:

The Prophet said, "Do not keep the fire burning in your houses when you go to bed."


Bukhari :: Asking Permission :: [8.74.309]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 309

Narrated Abu Musa:

One night a house in Medina was burnt with its occupants. The Prophet spoke about them, saying, "This fire is indeed your enemy, so whenever you go to bed, put it out to protect yourselves."


Bukhari :: Asking Permission :: [8.74.310]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 310

Narrated Jabir bin 'Abdullah:

Allah's Apostle said, "(At bedtime) cover the utensils, close the doors, and put out the lights, lest the evil creature (the rat) should pull away the wick and thus burn the people of the house."


Bukhari :: Asking Permission :: [8.74.311]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 311

Narrated Jabir:

Allah s Apostle said, "When you intend going to bed at night, put out the lights, close the doors, tie the mouths of the water skins, and cover your food and drinks." Hamrnam said, "I think he (the other narrator) added, 'even with piece of wood across the utensil.'


Bukhari :: Asking Permission :: [8.74.312]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 312

Narrated Abu Huraira:

The Prophet said "Five things are in accordance with Al Fitra (i.e. the tradition of prophets): to be circumcised, to shave the pelvic region, to pull out the hair of the armpits, to cut short the moustaches, and to clip the nails.'


Bukhari :: Asking Permission :: [8.74.313]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 313

Narrated Abu Huraira:

Allah's Apostle said "The Prophet) Abraham circumcised himself after he had passed the age of eighty years and he circumcised himself with an adze."

Narrated Said bin Jubair: Ibn 'Abbas was asked, "How old were you when the Prophet died?" He replied. "At that time I had been circumcised." At that time, people did not circumcise the boys till they attained the age of puberty. Sa'id bin Jubair said, "Ibn 'Abbas said, 'When the Prophet died, I had already been circumcised. "


Bukhari :: Asking Permission :: [8.74.314]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 314

Narrated Abu Huraira:

Allah's Apostle said, "Whoever among you takes an oath wherein he says, 'By Al-Lat and Al-'Uzza,' names of two Idols worshipped by the Pagans, he should say, 'None has the right to be worshipped but Allah; And whoever says to his friend, 'Come, let me gamble with you ! He should give something in charity. " (See Hadith No. 645)


Bukhari :: Asking Permission :: [8.74.315]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 315

Narrated Ibn 'Umar:

During the life-time of the Prophet I built a house with my own hands so that it might protect me from the rain and shade me from the sun; and none of Allah's creatures assisted me in building it.


Bukhari :: Asking Permission :: [8.74.316]

Asking Permission

Bukhari :: Book 8 :: Volume 74 :: Hadith 316

Narrated, 'Amr:

Ibn 'Umar said, "By Allah, I have not put a brick over a brick (i.e. constructed a building) or planted any date-palm tree since the death of the Prophet." Sufyan (the sub narrator) said, "I told this narration (of Ibn 'Umar) to one of his (Ibn 'Umar's) relatives, and he said, 'By Allah, he did build (something.' "Sufyan added, "I said, 'He must have said (the above narration) before he built."


Bukhari :: Invocations :: [8.75.317]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 317

Narrated Anas:

that the Prophet said, "For every prophet there is an invocation that surely will be responded by Allah," (or said), "For every prophet there was an invocation with which he appealed to Allah, and his invocation was accepted (in his lifetime), but I kept my (this special) invocation to intercede for my followers on the Day of Resurrection."


Bukhari :: Invocations :: [8.75.318]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 318

Narrated Shaddad bin Aus:

The Prophet said "The most superior way of asking for forgiveness from Allah is: 'Allahumma anta Rabbi la ilaha illa anta, Anta Khalaqtani wa ana abduka, wa ana 'ala ahdika wa wa'dika mastata'tu, A'udhu bika min Sharri ma sana'tu, abu'u Laka bini'matika 'alaiya, wa Abu Laka bidhanbi faghfirli innahu la yaghfiru adhdhunuba illa anta." The Prophet added. "If somebody recites it during the day with firm faith in it, and dies on the same day before the evening, he will be from the people of Paradise; and if somebody recites it at night with firm faith in it, and dies before the morning, he will be from the people of Paradise."


Bukhari :: Invocations :: [8.75.319]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 319

Narrated Abu Huraira:

I heard Allah's Apostle saying." By Allah! I ask for forgiveness from Allah and turn to Him in repentance more than seventy times a day."


Bukhari :: Invocations :: [8.75.320]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 320

Narrated Al-Harith bin Suwaid:

'Abdullah bin Mas'ud related to us two narrations: One from the Prophet and the other from himself, saying: A believer sees his sins as if he were sitting under a mountain which, he is afraid, may fall on him; whereas the wicked person considers his sins as flies passing over his nose and he just drives them away like this." Abu Shihab (the sub-narrator) moved his hand over his nose in illustration. (Ibn Mas'ud added): Allah's Apostle said, "Allah is more pleased with the repentance of His slave than a man who encamps at a place where his life is jeopardized, but he has his riding beast carrying his food and water. He then rests his head and sleeps for a short while and wakes to find his riding beast gone. (He starts looking for it) and suffers from severe heat and thirst or what Allah wished (him to suffer from). He then says, 'I will go back to my place.' He returns and sleeps again, and then (getting up), he raises his head to find his riding beast standing beside him."


Bukhari :: Invocations :: [8.75.321]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 321

Narrated Anas bin Malik:

Allah's Apostle said, "Allah is more pleased with the repentance of His slave than anyone of you is pleased with finding his camel which he had lost in the desert. "


Bukhari :: Invocations :: [8.75.322]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 322

Narrated Aisha:

The Prophet used to pray eleven Rakat in the late part of the night, and when dawn appeared, he would offer two Rakat and then lie on his right side till the Muadhdhin came to inform him (that the morning prayer was due).


Bukhari :: Invocations :: [8.75.323]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 323

Narrated Al-Bara bin 'Azib:

Allah's Apostle said to me, "When you want to go to bed, perform ablution as you do for prayer, then lie down on your right side and say: 'Allahumma aslamtu wajhi ilaika, wa fauwadtu Amri ilaika wa aljatu zahri ilaika, raghbatan wa rahbatan ilaika, lamalja'a wa la manja mink a ill a ilaika. Amantu bikitabi kalladhi anzalta wa bi nabiyyikal-ladhi arsalta'. If you should die then (after reciting this) you will die on the religion of Islam (i.e., as a Muslim); so let these words be the last you say (before going to bed)" While I was memorizing it, I said, "Wa birasiulikal-ladhi arsalta (in Your Apostle whom You have sent).' The Prophet said, "No, but say: Wa binabiyyi-kalladhi arsalta (in Your Prophet whom You have sent)."


Bukhari :: Invocations :: [8.75.324]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 324

Narrated Hudhaifa:

When the Prophet went to bed, he would say: "Bismika amutu wa ahya." and when he got up he would say:" Al-hamdu lillahil-ladhi ahyana ba'da ma amatana wa ilaihin-nushur."


Bukhari :: Invocations :: [8.75.325]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 325

Narrated Al-Bara bin 'Azib:

e then (after reciting this before going to bed) you will die on the r


Bukhari :: Invocations :: [8.75.326]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 326

Narrated Hudhaifa:

When the Prophet went to bed at night, he would put his hand under his cheek and then say, "Allahumma bismika amutu wa ahya," and when he got up, he would say, "Al-Hamdu lil-lahi al-ladhi ahyana ba'da ma amatana, wa ilaihi an-nushur."


Bukhari :: Invocations :: [8.75.327]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 327

Narrated Al-Bara' bin 'Azib:

When Allah's Apostle went to bed, he used to sleep on his right side and then say, "All-ahumma aslamtu nafsi ilaika, wa wajjahtu wajhi ilaika, wa fauwadtu Amri ilaika, wa alja'tu zahri ilaika, raghbatan wa rahbatan ilaika. La Malja'a wa la manja minka illa ilaika. Amantu bikitabika al-ladhi anzalta wa nabiyyika al-ladhi arsalta! Allah's Apostle said, "Whoever recites these words (before going to bed) and dies the same night, he will die on the Islamic religion (as a Muslim)."


Bukhari :: Invocations :: [8.75.328]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 328

Narrated Ibn 'Abbas:

One night I slept at the house of Maimuna. The Prophet woke up, answered the call of nature, washed his face and hands, and then slept. He got up (late at night), went to a water skin, opened the mouth thereof and performed ablution not using much water, yet he washed all the parts properly and then offered the prayer. I got up and straightened my back in order that the Prophet might not feel that I was watching him, and then I performed the ablution, and when he got up to offer the prayer, stood on his left. He caught hold of my ear and brought me over to his right side. He offered thirteen Rak'at in all and then lay down and slept till he started blowing out his breath as he used to do when he slept. In the meantime Bilal informed the Prophet of the approaching time for the (Fajr) prayer, and the Prophet offered the Fajr (Morning) prayer without performing new ablution. He used to say in his invocation, Allaihumma ij'al fi qalbi nuran wa fi basari nuran, wa fi sam'i nuran, wa'an yamini nuran, wa'an yasari nuran, wa fawqi nuran, wa tahti nuran, wa amami nuran, wa khalfi nuran, waj'al li nuran." Kuraib (a sub narrator) said, "I have forgotten seven other words, (which the Prophet mentioned in this invocation). I met a man from the offspring of Al-'Abbas and he narrated those seven things to me, mentioning, '(Let there be light in) my nerves, my flesh, my blood, my hair and my body,' and he also mentioned two other things."


Bukhari :: Invocations :: [8.75.329]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 329

Narrated Ibn 'Abbas:

When the Prophet got up at night to offer the night prayer, he used to say: "Allahumma laka-l-hamdu; Anta nuras-samawati wal ardi wa man fihinna. Wa laka-l-hamdu; Anta qaiyim as-samawati wal ardi wa man fihinna. Wa laka-l-hamdu; Anta-l-,haqqun, wa wa'daka haqqun, wa qauluka haqqun, wa liqauka haqqun, wal-jannatu haqqun, wannaru haqqun, was-sa atu haqqun, wan-nabiyyuna huqqun, Mahammadun haqqun, Allahumma laka aslamtu, wa Alaika tawakkaltu, wa bika amantu, wa ilaika anabtu, wa bika Khasamtu, wa ilaika hakamtu, faghfirli ma qaddamtu wa ma akh-khartu, wa ma asrartu, wa ma a'lantu. Anta al-muqaddimu, wa anta al-mu-'akhkhiru. La ilaha il-la anta (or La ilaha ghairuka)"


Bukhari :: Invocations :: [8.75.330]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 330

Narrated 'Ali:

Fatima complained about the blisters on her hand because of using a mill-stone. She went to ask the Prophet for servant, but she did not find him (at home) and had to inform 'Aisha of her need. When he came, 'Aisha informed him about it. Ali added: The Prophet came to us when we had gone to our beds. When I was going to get up, he said, "'Stay in your places," and sat between us, till I felt the coolness of the feet on my chest. The Prophet then said, "Shall I not tell you of a thing which is better for you than a servant? When you (both) go to your beds, say 'Allahu Akbar' thirty-four times, and 'Subhan Allah' thirty-three times, 'Alhamdu 'illah' thirty-three times, for that is better for you than a servant." Ibn Sirin said, "Subhan Allah' (is to be said for) thirty-four times."


Bukhari :: Invocations :: [8.75.331]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 331

Narrated 'Aisha:

Whenever Allah's Apostle went to bed, he used to blow on his hands while reciting the Mu'auwidhat ( i.e. Suratal-Falaq and Surat-an-Nas, 113 and 114) and then pass his hands over his body,


Bukhari :: Invocations :: [8.75.332]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 332

Narrated Abu Huraira:

The Prophet said, "When anyone of you go to bed, he should shake out his bed with the inside of his waist sheet, for he does not know what has come on to it after him, and then he should say: 'Bismika Rabbi wada'tu Janbi wa bika arfa'uhu, In amsakta nafsi farhamha wa in arsaltaha fahfazha bima tahfazu bihi ibadakas-salihin."


Bukhari :: Invocations :: [8.75.333]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 333

Narrated Abu Huraira:

Allah's Apostle said, "When it is the last third of the night, our Lord, the Blessed, the Superior, descends every night to the heaven of the world and says, 'Is there anyone who invokes Me (demand anything from Me), that I may respond to his invocation; Is there anyone who asks Me for something that I may give (it to) him; Is there anyone who asks My forgiveness that I may forgive him?' "


Bukhari :: Invocations :: [8.75.334]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 334

Narrated Anas bin Malik:

Whenever the Prophet went to the lavatory, he used to say: "Allahumma Inni a'udhu bika mina-lkhubthi Wal khaba'ith."


Bukhari :: Invocations :: [8.75.335]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 335

Narrated Shaddad bin 'Aus:

The Prophet said, "The most superior way of asking for forgiveness from Allah is: 'Allahumma anta Rabbi la ilaha illa anta. Khalaqtani wa ana 'abduka, wa ana 'ala 'ahdika wa Wa'dika mastata'tu abu'u Laka bi ni 'matika wa abu'u Laka bidhanbi; faghfirli fa'innahu la yaghfiru-dh-dhunuba ill a ant a. A'uidhu bika min sharri ma sana'tu.' If somebody recites this invocation during the night, and if he should die then, he will go to Paradise (or he will be from the people of Paradise). And if he recites it in the morning, and if he should die on the same day, he will have the same fate."


Bukhari :: Invocations :: [8.75.336]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 336

Narrated Hudhaifa:

Whenever the Prophet intended to go to bed, he would recite: "Bismika Allahumma amutu wa ahya (With Your name, O Allah, I die and I live)." And when he woke up from his sleep, he would say: "Al-hamdu lil-lahil-ladhi ahyana ba'da ma amatana; wa ilaihi an-nushur (All the Praises are for Allah Who has made us alive after He made us die (sleep) and unto Him is the Resurrection). "


Bukhari :: Invocations :: [8.75.337]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 337

Narrated Abu Dhar:

Whenever the Prophet lay on his bed, he used to say: "Allahumma bismika amutu wa ahya," and when he woke up he would say: "Al-hamdu lil-lahilladhi ahyana ba'da ma an atana, wa ilaihi an-nushur."


Bukhari :: Invocations :: [8.75.338]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 338

Narrated 'Abdullah bin 'Amr:

Abu Bakr As-Siddiq said to the Prophet, "Teach me an invocation with which I may invoke (Allah) in my prayer." The Prophet said, "Say: Allahumma inni zalamtu nafsi zulman kathiran wala yaghfirudh-dhunuba illa anta, Faghfirli maghfiratan min indika war-hamni, innaka antalGhafur-Rahim."


Bukhari :: Invocations :: [8.75.339]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 339

Narrated 'Aisha:

The Verse: 'Neither say your prayer aloud, nor say it in a low tone.' (17.110) was revealed as regards invocation.


Bukhari :: Invocations :: [8.75.340]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 340

Narrated 'Abdullah:

We used to say in the prayer: 'AsSalam be on Allah, As-Salam be on so-and so.' So one day the Prophet said to us, "Allah Himself is As-Salam; when anyone of you sits during his prayer, he should say: 'At-tah, iyyatu-lillahi,' up to 'As-Salihin,' (All the compliments are for Allah ...righteous people) for when he recites this, then he says his Salam to all the righteous people present in the heavens and on the earth. Then he should say, 'I testify that none has the right to be worshipped except Allah, and that Muhammad is His slave and His Apostle,' and then he can select whatever he likes to celebrate (Allah's) Praises."


Bukhari :: Invocations :: [8.75.341]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 341

Narrated Abu Huraira:

The people said, "O Allah's Apostle! The rich people have got the highest degrees of prestige and the permanent pleasures (in this life and the life to come in the Hereafter)." He said, "How is that?" They said, "The rich pray as we pray, and strive in Allah's Cause as we do, and spend from their surplus wealth in charity, while we have no wealth (to spend likewise)." He said, "Shall I not tell you a thing, by doing which, you will catch up with those who are ahead of you and supersede those who will come after you; and nobody will be able to do such a good deed as you do except the one who does the same (deed as you do). That deed is to recite 'Subhan Allah ten times, and 'Al-Hamdulillah ten times, and 'AllahuAkbar' ten times after every prayer."


Bukhari :: Invocations :: [8.75.342]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 342

Narrated Warrad:

(the freed slave of Al-Mughira bin Shu'ba) Al-Mughira wrote to Muawiya bin Abu Sufyan that Allah's Apostle used to say at the end of every prayer after the Taslim, "La ilaha illa-l-lahu wahdahu la sharika lahu; lahu-l-mulk wa lahu-l-hamd, wahuwa 'ala kulli shai'n qadir. Allahumma la mani'a Lima a taita, wa la mu'ta Lima mana'ta, wa la yanfa'u dhal-jaddu minkal-jadd.


Bukhari :: Invocations :: [8.75.343]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 343

Narrated Salama bin Al-Akwa':

We went out with the Prophet to Khaibar. A man among the people said, "O 'Amir! Will you please recite to us some of your poetic verses?" So 'Amir got down and started chanting among them, saying, "By Allah! Had it not been for Allah, we would not have been guided." 'Amir also said other poetic verses which I do not remember. Allah's Apostle said, "Who is this (camel) driver?" The people said, "He is 'Amir bin Al-Akwa'," He said, "May Allah bestow His Mercy on him." A man from the People said, "O Allah's Apostle! Would that you let us enjoy his company longer." When the people (Muslims) lined up, the battle started, and 'Amir was struck with his own sword (by chance) by himself and died. In the evening, the people made a large number of fires (for cooking meals). Allah's Apostle said, "What is this fire? What are you making the fire for?" They said, "For cooking the meat of donkeys." He said, "Throw away what is in the pots and break the pots!" A man said, "O Allah's Prophet! May we throw away what is in them and wash them?" He said, "Never mind, you may do so." (See Hadith No. 509, Vol. 5).


Bukhari :: Invocations :: [8.75.344]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 344

Narrated Ibn Abi Aufa:

Whenever a man brought his alms to the Prophet, the Prophet would say, "O Allah! Bestow Your Blessing upon the family of so-and-so." When my father came to him (with his alms), he said, "O Allah! Bestow Your Blessings upon the family of Abi Aufa."


Bukhari :: Invocations :: [8.75.345]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 345

Narrated Jarir:

Allah's Apostle said to me. "Will you relieve me from Dhi-al-Khalasa? " Dhi-al-Khalasa was an idol which the people used to worship and it was called Al-Ka'ba al Yamaniyya. I said, "O Allah's Apostle I am a man who can't sit firm on horses." So he stroked my chest (with his hand) and said, "O Allah! Make him firm and make him a guiding and well-guided man." So I went out with fifty (men) from my tribe of Ahrnas. (The sub-narrator, Sufyan, quoting Jarir, perhaps said, "I went out with a group of men from my nation.") and came to Dhi-al-Khalasa and burnt it, and then came to the Prophet and said, "O Allah's Apostle! I have not come to you till I left it like a camel with a skin disease." The Prophet then invoked good upon Ahmas and their cavalry (fighters).


Bukhari :: Invocations :: [8.75.346]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 346

Narrated Anas:

Um Sulaim said to the Prophet "Anas is your servant." The Prophet said, "O Allah! increase his wealth and offspring, and bless (for him) what ever you give him."


Bukhari :: Invocations :: [8.75.347]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 347

Narrated 'Aisha:

The Prophet heard a man reciting (the Qur'an) in the mosque. He said," May Allah bestow His Mercy on him, as he made me remember such and-such Verse which I had missed in such-and-such Sura."


Bukhari :: Invocations :: [8.75.348]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 348

Narrated 'Abdullah:

The Prophet divided something (among the Muslims) and distributed the shares (of the booty). A man said, "This division has not been made to please Allah." When I informed the Prophet about it, he became so furious that I noticed the signs of anger on his face and he then said, "May Allah bestow His Mercy on Moses, for he was hurt with more than this, yet he remained patient."


Bukhari :: Invocations :: [8.75.349]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 349

Narrated 'Ikrima:

Ibn 'Abbas said, "Preach to the people once a week, and if you won't, then preach them twice, but if you want to preach more, then let it be three times (a week only), and do not make the people fed-up with this Qur'an. If you come to some people who are engaged in a talk, don't start interrupting their talk by preaching, lest you should cause them to be bored. You should rather keep quiet, and if they ask you, then preach to them at the time when they are eager to hear what you say. And avoid the use of rhymed prose in invocation for I noticed that Allah's Apostle and his companions always avoided it."


Bukhari :: Invocations :: [8.75.350]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 350

Narrated Anas:

Allah's Apostle said, "When anyone of you appeal to Allah for something, he should ask with determination and should not say, 'O Allah, if You wish, give me.', for nobody can force Allah to do something against His Will.


Bukhari :: Invocations :: [8.75.351]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 351

Narrated Abu Huraira:

Allah's Apostle said, "None of you should say: 'O Allah, forgive me if You wish; O Allah, be merciful to me if You wish,' but he should always appeal to Allah with determination, for nobody can force Allah to do something against His Will."


Bukhari :: Invocations :: [8.75.352]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 352

Narrated Abu Huraira:

Allah's Apostle said, "The invocation of anyone of you is granted (by Allah) if he does not show impatience (by saying, "I invoked Allah but my request has not been granted.")


Bukhari :: Invocations :: [8.75.353]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 353

Narrated Anas:

While the Prophet was delivering a sermon on a Friday, a man stood up and said, "O Allah's Apostle! Invoke Allah to bless us with rain." (The Prophet invoked Allah for rain.) So, the sky became overcast and it started raining till one could hardly reach one's home. It kept on raining till the next Friday when the same man or another man got up and said (to the Prophet), "Invoke Allah to withhold the rain from us, for we have been drowned (with heavy rain )." The Prophet said, "O Allah! Let it rain around us and not on us." Then the clouds started dispersing around Medina and rain ceased to fall on the people of Medina.


Bukhari :: Invocations :: [8.75.354]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 354

Narrated 'Abdullah bin Zaid:

Allah's Apostle went out to this Musalla (praying place) to offer the prayer of Istisqa.' He invoked Allah for rain and then faced the Qibla and turned his Rida' (upper garment) inside out.


Bukhari :: Invocations :: [8.75.355]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 355

Narrated Anas:

My mother said, "O Allah's Apostle! Please invoke Allah on behalf of your servant." He said, "O Allah! Increase his wealth and children, and bestow Your Blessing on whatever You give him." a time of distress.


Bukhari :: Invocations :: [8.75.356]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 356

Narrated Ibn Abbas:

The Prophet used to invoke Allah at the time of distress, saying, "La ilaha illal-lahu al-'Azim, al-Halim, La ilaha illal-lahu Rabbu-s-samawati wal-ard wa Rabbu-l-arsh il-azim,"


Bukhari :: Invocations :: [8.75.357]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 357

Narrated Ibn 'Abbas:

Allah's Apostle used to say at a time of distress, "La ilaha illal-lahu Rabbul-l-'arsh il-'azim, La ilaha illallahu Rabbu-s-samawati wa Rabbu-l-ard, Rabbu-l-'arsh-il-Karim."


Bukhari :: Invocations :: [8.75.358]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 358

Narrated Abu Huraira:

Allah's Apostle used to seek refuge with Allah from the difficult moment of a calamity and from being overtaken by destruction and from being destined to an evil end, and from the malicious joy of enemies. Sufyan said, "This narration contained three items only, but I added one. I do not know which one that was."


Bukhari :: Invocations :: [8.75.359]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 359

Narrated 'Aisha:

When Allah's Apostle was healthy, he used to say, "No prophet dies till he is shown his place in Paradise, and then he is given the option (to live or die)." So when death approached him(during his illness), and while his head was on my thigh, he became unconscious for a while, and when he recovered, he fixed his eyes on the ceiling and said, "O Allah! (Let me join) the Highest Companions (see Qur'an 4:69)," I said, "So, he does not choose us." Then I realized that it was the application of the statement he used to relate to us when he was healthy. So that was his last utterance (before he died), i.e. "O Allah! (Let me join) the Highest Companions."


Bukhari :: Invocations :: [8.75.360]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 360

Narrated Qais:

I came to Khabbab who had been branded with seven brands(1) and he said, "Had Allah's Apostle not forbidden us to invoke (Allah) for death, I would have invoked (Allah) for it."


Bukhari :: Invocations :: [8.75.361]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 361

Narrated Qais:

I came to Khabbab who had been branded with seven brands over his abdomen, and I heard him saying, "If the Prophet: had not forbidden us to invoke (Allah) for death, I would have invoked Allah for it."


Bukhari :: Invocations :: [8.75.362]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 362

Narrated Anas:

Allah's Apostle said," None of you should long for death because of a calamity that had befallen him, and if he cannot, but long for death, then he should say, 'O Allah! Let me live as long as life is better for me, and take my life if death is better for me.' "


Bukhari :: Invocations :: [8.75.363]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 363

Narrated As-Sa'ib bin Yazid:

My aunt took me to Allah's Apostle and said, "O Allah's Apostle! My sister's son is sick." So he passed his hand over my head and invoked for Allah's blessing upon me and then performed the ablution. I drank from the water of his ablution and I stood behind him and looked at his Khatam (the seal of Prophethood) between his shoulders (and its size was) like the button of a tent.


Bukhari :: Invocations :: [8.75.364]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 364

Narrated Abu 'Aqil:

that his grandfather. 'Abdullah bin Hisham used to take him from the market or to the market (the narrator is in doubt) and used to buy grain and when Ibn Az-Zubair and Ibn 'Umar met him, they would say to him, "Let us be your partners (in trading) as the Prophet invoked for Allah's blessing upon you." He would then take them as partners and he would Sometimes gain a whole load carried by an animal which he would send home.


Bukhari :: Invocations :: [8.75.365]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 365

Narrated Mahmud bin Ar-Rabi:

On whose face Allah's Apostle had thrown water from his mouth, the water having been taken from their well while he was still a young boy (who has not yet attained the age of puberty).


Bukhari :: Invocations :: [8.75.366]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 366

Narrated 'Aisha:

The boys used to be brought to the Prophet and he used to invoke for Allah's blessing upon them. Once an infant was brought to him and it urinated on his clothes. He asked for water and poured it over the place of the urine and did not wash his clothes.


Bukhari :: Invocations :: [8.75.367]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 367

Narrated 'Abdullah bin Tha'laba bin Su'air:

whose eye Allah's Apostle had touched, that he had seen Sa'd bin Abi Waqqas offering one Rak'a only for the Witr prayer.


Bukhari :: Invocations :: [8.75.368]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 368

Narrated 'Abdur-Rahman bin Abi Laila:

Ka'b bin 'Ujra met me and said, "Shall I give you a present? Once the Prophet came to us and we said, 'O Allah's Apostle ! We know how to greet you; but how to send 'Salat' upon you? He said, 'Say: Allahumma Salli ala Muhammadin wa 'ala Ali Muhammadin, kama sal-laita 'ala all Ibrahima innaka Hamidun Majid. Allahumma barik 'ala Muhammadin wa 'ala all Muhammadin, kama barakta 'ala all Ibrahima, innaka Hamidun Majid."


Bukhari :: Invocations :: [8.75.369]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 369

Narrated Abu Sa'id Al-Khudri:

We said, "O Allah's Apostle This is (i.e. we know) the greeting to you; will you tell us how to send Salat on you?" He said, "Say: 'Allahumma Salli 'ala Muhammadin 'abdika wa rasulika kama sal-laita 'ala Ibrahima wa barik 'ala Muhammadin wa all Muhammadin kama barakta 'ala Ibrahima wa Ali Ibrahim."


Bukhari :: Invocations :: [8.75.370]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 370

Narrated Ibn Abi Aufa:

Whenever somebody brought alms to the Prophet the used to say, "Allahumma Salli 'Alaihi (O Allah! Send Your Salat (Grace and Honor) on him)." Once when my father brought his alms to him, he said, "O Allah! Send Your Salat (Grace and Honor) on the family of Abi Aufa."


Bukhari :: Invocations :: [8.75.371]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 371

Narrated Abu Humaid As-Saidi:

The people said, "O Allah's Apostle ! How may we send Salat on you?" He said, "Say: Allahumma Salli 'ala- Muhammadin wa azwajihi wa dhurriyyatihi kama sal-laita 'ala ali Ibrahim; wa barik 'ala Muhammadin wa azwajihi wa dhurriyyatihi kamabarakta 'ala ali Ibrahim innaka hamidun majid."


Bukhari :: Invocations :: [8.75.372]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 372

Narrated Abu Huraira:

that he heard the Prophet saying, "O Allah! If I should ever abuse a believer, please let that be a means of bringing him near to You on the Day of Resurrection."


Bukhari :: Invocations :: [8.75.373]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 373

Narrated Anas:

Once the people started asking Allah's Apostle questions, and they asked so many questions that he became angry and ascended the pulpit and said, "I will answer whatever questions you may ask me today." I looked right and left and saw everyone covering his face with his garment and weeping. Behold ! There was a man who, on quarreling with the people, used to be called as a son of a person other than his father. He said, "O Allah's Apostle! Who is my father?" The Prophet replied, "Your father is Hudhaifa." And then 'Umar got up and said, "We accept Allah as our Lord, and Islam as (our) religion, and Muhammad as (our) Apostle; and we seek refuge with Allah from the afflictions." Allah's Apostle said, " I have never seen a day like today in its good and its evil for Paradise and the Hell Fire were displayed in front of me, till I saw them just beyond this wall." Qatada, when relating this Hadith, used to mention the following Verse:--

'O you who believe! Ask not questions about things which, If made plain to you, May cause you trouble. (5.101)


Bukhari :: Invocations :: [8.75.374]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 374

Narrated Anas bin Malik:

The Prophet said to Abu Talha, "Choose one of your boys to serve me." So Abu Talha took me (to serve the Prophet ) by giving me a ride behind him (on his camel). So I used to serve Allah's Apostle whenever he stayed somewhere. I used to hear him saying, "O Allah! I seek refuge with you (Allah) from (worries) care and grief, from incapacity and laziness, from miserliness and cowardice, from being heavily in debt and from being overpowered by other men." I kept on serving him till he returned from (the battle of) Khaibar. He then brought Safiya, the daughter of Huyay whom he had got (from the booty). I saw him making a kind of cushion with a cloak or a garment for her. He then let her ride behind him. When we reached a place called As-Sahba', he prepared (a special meal called) Hais, and asked me to invite the men who (came and) ate, and that was the marriage banquet given on the consummation of his marriage to her. Then he proceeded till the mountain of Uhud appeared, whereupon he said, "This mountain loves us and we love it." When he approached Medina, he said, "O Allah! I make the land between its (i.e., Medina's) two mountains a sanctuary, as the prophet Abraham made Mecca a sanctuary. O Allah! Bless them (the people of Medina) in their Mudd and the Sa' (units of measuring)."


Bukhari :: Invocations :: [8.75.375]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 375

Narrated Um Khalid bint Khalid:

I heard the Prophet seeking refuge with Allah from the punishment of the grave.


Bukhari :: Invocations :: [8.75.376]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 376

Narrated Mus'ab:

Sa'd used to recommend five (statements) and mentioned that the Prophet I used to recommend it. (It was) "O Allah! I seek refuge with You from miserliness; and seek refuge with You from cowardice; and seek refuge with You from being sent back to geriatric old age; and I seek refuge with You from the affliction of this world (i.e., the affliction of Ad-Dajjal etc.); and seek refuge with You from the punishment of the grave."


Bukhari :: Invocations :: [8.75.377]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 377

Narrated 'Aisha:

Two old ladies from among the Jewish ladies entered upon me and said' "The dead are punished in their graves," but I thought they were telling a lie and did not believe them in the beginning. When they went away and the Prophet entered upon me, I said, "O Allah's Apostle! Two old ladies.." and told him the whole story. He said, "They told the truth; the dead are really punished, to the extent that all the animals hear (the sound resulting from) their punishment." Since then I always saw him seeking refuge with Allah from the punishment of the grave in his prayers.


Bukhari :: Invocations :: [8.75.378]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 378

Narrated Anas bin Malik:

Allah's Prophet used to say, "O Allah! I seek refuge with You from incapacity and laziness, from cowardice and geriatric old age, and seek refuge with You from the punishment of the grave, and I seek refuge with You from the afflictions of life and death."


Bukhari :: Invocations :: [8.75.379]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 379

Narrated 'Aisha:

The Prophet used to say, "O Allah! I seek refuge with You from laziness and geriatric old age, from all kinds of sins and from being in debt; from the affliction of the Fire and from the punishment of the Fire and from the evil of the affliction of wealth; and I seek refuge with You from the affliction of poverty, and I seek refuge with You from the affliction of Al-Mesiah Ad-Dajjal. O Allah! Wash away my sins with the water of snow and hail, and cleanse my heart from all the sins as a white garment is cleansed from the filth, and let there be a long distance between me and my sins, as You made East and West far from each other."


Bukhari :: Invocations :: [8.75.380]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 380

Narrated Anas bin Malik:

The Prophet used to say, "O Allah! I seek refuge with You from worry and grief, from incapacity and laziness, from cowardice and miserliness, from being heavily in debt and from being overpowered by (other) men." (See Hadith No. 374)


Bukhari :: Invocations :: [8.75.381]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 381

Narrated Mus'ab bin Sa'd:

Sa'd bin Abi Waqqas used to recommend these five (statements) and say that the Prophet said so (and they are): "O Allah! I seek refuge with You from miserliness, and seek refuge with You from cowardice, and seek refuge with You from being brought back to geriatric old age, and seek refuge with You from the afflictions of the world, and seek refuge with You from the punishment of the grave."


Bukhari :: Invocations :: [8.75.382]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 382

Narrated Anas bin Malik:

Allah's Apostle used to seek refuge with Allah saying, "O Allah! I seek refuge with You from laziness, and seek refuge with You from cowardice, and seek refuge with You from geriatric old age, and seek refuge with You from miserliness."


Bukhari :: Invocations :: [8.75.383]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 383

Narrated 'Aisha:

The Prophet said, "O Allah! Make us love Medina as You made us love Mecca, or more, and transfer the fever that is in it, to Al-Juhfa. O Allah! Bless our Mudd and our Sam' (kinds of measures)."


Bukhari :: Invocations :: [8.75.384]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 384

Narrated 'Amir bin Sa'd:

that his father said, "In the year of Hajjatal-Wada', the Prophet paid me a visit while I was suffering from an ailment that had brought me to the verge of death. I said, 'O Allah's Apostle! My sickness has reduced me to the (bad) state as you see, and I am a rich man, but have no heirs except one daughter. Shall I give 2/3 of my property in charity?' He said, 'No.' I said, 'Then 1/2 of it?' He said, 'Even 1/3 is too much, for, to leave your inheritors wealthy is better than to leave them in poverty, begging from people. And (know that) whatever you spend in Allah's Cause, you will get reward for it, even for the morsel of food which you put in your wife's mouth.' I said, 'O Allah's Apostle! Will I be left behind my companions (in Mecca)?' He said, 'If you remain behind, whatever good deed you will do for Allah's Sake, will raise and upgrade you to a higher position (in Allah's Sight). May be you will live longer so that some people may benefit by you, and some e others (pagans) may get harmed by you. O Allah! Complete the migration of my companions and do not turn them on their heels; But (we pity) the poor Sa'd bin Khaula (not the above mentioned Sa'd) (died in Mecca)" Allah's Apostle lamented (or pitied) for him as he died in Mecca. (See Hadith No. 693, Vol. 5)


Bukhari :: Invocations :: [8.75.385]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 385

Narrated Sa'd:

Seek refuge with Allah by saying the words which the Prophet used to say while seeking refuge with Allah, "0 Allah! I seek refuge with You from cowardice, and seek refuge with You from miserliness, and seek refuge with You from reaching a degraded geriatric old age, and seek refuge with You from the afflictions of the world and from the punishment in the grave."


Bukhari :: Invocations :: [8.75.386]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 386

Narrated 'Aisha:

The Prophet used to say, "O Allah! I seek refuge with You from laziness from geriatric old age, from being in debt, and from committing sins. O Allah! I seek refuge with You from the punishment of the Fire, the afflictions of the grave, the punishment in the grave, and the evil of the affliction of poverty and from the evil of the affliction caused by Al-Masih Ad-Dajjal. O Allah! Wash away my sins with the water of snow and hail, and cleanse my heart from the sins as a white garment is cleansed of filth, and let there be a far away distance between me and my sins as You have set far away the East and the West from each other."


Bukhari :: Invocations :: [8.75.387]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 387

Narrated 'Aisha:

The Prophet used to seek refuge with Allah (by saying), "O Allah! I seek refuge with You from the affliction of the Fire and from the punishment in the Fire, and seek refuge with You from the affliction of the grave, and I seek refuge with You from the affliction of wealth, and I seek refuge with You from the affliction of poverty, and seek refuge with You from the affliction of Al-Masih Ad-Dajjal."


Bukhari :: Invocations :: [8.75.388]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 388

Narrated 'Aisha:

The Prophet used to say, 'O Allah! I seek refuge with You from the affliction of the Fire, the punishment of the Fire, the affliction of the grave, the punishment of the grave, and the evil of the affliction of poverty. O Allah! I seek refuge with You from the evil of the affliction of Al-Masih Ad-Dajjal, O Allah! Cleanse my heart with the water of snow and hail, and cleanse my heart from all sins as a white garment is cleansed from filth, and let there be a far away distance between me and my sins as You made the East and West far away from each other. O Allah! I seek refuge with You from laziness, sins, and from being in debt."


Bukhari :: Invocations :: [8.75.389]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 389

Narrated Um Sulaim:

that she said, "O Allah's Apostle! Anas is your servant, so please invoke for Allah's blessing for him." The Prophet said, "O Allah! Increase his wealth and offspring and bless (for him) whatever You give him."


Bukhari :: Invocations :: [8.75.390]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 390

Narrated Anas:

Um Sulaim said (to the Prophet), "Anas is your servant; so please invoke for Allah's blessings for him." He said "O Allah! Increase his wealth and offspring, and Bless (for him) whatever You give him."


Bukhari :: Invocations :: [8.75.391]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 391

Narrated Jabir:

The Prophet used to teach us the Istikhara for each and every matter as he used to teach us the Suras from the Holy Qur'an. (He used to say), "If anyone of you intends to do something, he should offer a two-Rak'at prayer other than the obligatory prayer, and then say: 'Allahumma inni astakhiruka bi'ilmika, wa astaqdiruka biqudratika, wa as'aluka min fadlika-l-'azim, fa innaka taqdiru wala aqdiru, wa ta'lamu wala a'lamu, wa anta'allamu-l-ghuyub. Allahumma in kunta ta'lamu anna hadha-lamra khairun li fi dini wa ma'ashi wa 'aqibati amri (or said, fi 'ajili amri wa ajilihi) fa-qdurhu li, Wa in junta ta'lamu anna ha-dha-l-amra sharrun li fi dini wa ma'ashi wa 'aqibati amri (or said, fi ajili amri wa ajilihi) fasrifhu 'anni was-rifni 'anhu wa aqdur li alkhaira haithu kana, thumma Raddani bihi," Then he should mention his matter (need).


Bukhari :: Invocations :: [8.75.392]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 392

Narrated Abu Musa:

The Prophet asked for some water and performed the ablution, and then raised his hands (towards the sky) and said, "O Allah! Forgive 'Ubaid Abi 'Amir." I saw the whiteness of his armpits (while he was raising his hands) and he added, "O Allah! Upgrade him over many of Your human creatures on the Day of Resurrection "


Bukhari :: Invocations :: [8.75.393]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 393

Narrated Abu Musa:

We were in the company of the Prophet on a journey, and whenever we ascended a high place, we used to say Takbir (in a loud voice). The Prophet said, "O people! Be kind to yourselves, for you are not calling upon a deaf or an absent one, but You are calling an All-Hearer, and an All-Seer." Then he came to me as I was reciting silently, "La haul a wala quwwata illa bil-lah." He said, "O 'Abdullah bin Qais! Say: La haul a walaquwata illa bil-lah, for it is one of the treasures of Paradise." Or he said, "Shall I tell you a word which is one of the treasures of Paradise? It is: La haul a wala quwwata illa bil-lah."


Bukhari :: Invocations :: [8.75.394]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 394

Narrated Ibn Umar:

Whenever Allah's Apostle returned from a Ghazwa or Hajj or 'Umra, he used to say, "Allahu Akbar," three times; whenever he went up a high place, he used to say, "La ilaha illal-lahu wahdahu la sharika lahu, lahu-l-mulk wa lahu-l-hamd, wa huwa'ala kulli Shai 'in qadir. Ayibuna ta'ibuna 'abiduna lirabbina hamidun. Sadaqa-l-lahu wa'dahu, wa nasara'abdahu wa hazama-l-ahzaba wahdahu."


Bukhari :: Invocations :: [8.75.395]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 395

Narrated Anas:

The Prophet seeing a yellow mark (of perfume) on the clothes of 'Abdur-Rahman bin 'Auf, said, "What about you?" 'Abdur-Rahman replied, "I have married a woman with a Mahr of gold equal to a date-stone." The Prophet said, "May Allah bestow His Blessing on you (in your marriage). Give a wedding banquet, (Walima) even with one sheep."


Bukhari :: Invocations :: [8.75.396]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 396

Narrated Jabir:

My father died and left behind seven or nine daughters, and I married a woman. The Prophet said, "Did you get married, O Jabir?" I replied, "Yes." He asked, "Is she a virgin or a matron?" I replied, "She is a matron." He said, "Why didn't you marry a virgin girl so that you might play with her and she with you (or, you might make her laugh and she make you laugh)?" I said, "My father died, leaving seven or nine girls (orphans) and I did not like to bring a young girl like them, so I married a woman who can look after them." He said, "May Allah bestow His Blessing on you."


Bukhari :: Invocations :: [8.75.397]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 397

Narrated Ibn 'Abbas:

The Prophet said, "If anyone of you, when intending to have a sexual intercourse with his wife, says: 'Bismillah, Allahumma jannibna-sh-shaitan, wa jannibi-sh-shaitan ma razaqtana,' and if the couple are destined to have a child (out of that very sexual relation), then Satan will never be able to harm that child."


Bukhari :: Invocations :: [8.75.398]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 398

Narrated Anas:

The most frequent invocation of The Prophet was: "O Allah! Give to us in the world that which is good and in the Hereafter that which is good, and save us from the torment of the Fire." (2.201)


Bukhari :: Invocations :: [8.75.399]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 399

Narrated Sa'd bin Abi Waqqas:

The Prophet used to teach us these words as he used to teach us the Book (Qur'an): "O Allah! seek refuge with You from miserliness, and seek refuge with You from cowardice, and seek refuge with You from being brought back to (senile) geriatric old age, and seek refuge with You from the affliction of the world and from the punishment in the Hereafter."


Bukhari :: Invocations :: [8.75.400]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 400

Narrated 'Aisha:

that Allah's Apostle was affected by magic, so much that he used to think that he had done something which in fact, he did not do, and he invoked his Lord (for a remedy). Then (one day) he said, "O 'Aisha!) Do you know that Allah has advised me as to the problem I consulted Him about?" 'Aisha said, "O Allah's Apostle! What's that?" He said, "Two men came to me and one of them sat at my head and the other at my feet, and one of them asked his companion, 'What is wrong with this man?' The latter replied, 'He is under the effect of magic.' The former asked, 'Who has worked magic on him?' The latter replied, 'Labid bin Al-A'sam.' The former asked, 'With what did he work the magic?' The latter replied, 'With a comb and the hair, which are stuck to the comb, and the skin of pollen of a date-palm tree.' The former asked, 'Where is that?' The latter replied, 'It is in Dharwan.' Dharwan was a well in the dwelling place of the (tribe of) Bani Zuraiq. Allah's Apostle went to that well and returned to 'Aisha, saying, 'By Allah, the water (of the well) was as red as the infusion of Hinna, (1) and the date-palm trees look like the heads of devils.' 'Aisha added, Allah's Apostle came to me and informed me about the well. I asked the Prophet, 'O Allah's Apostle, why didn't you take out the skin of pollen?' He said, 'As for me, Allah has cured me and I hated to draw the attention of the people to such evil (which they might learn and harm others with).' "

Narrated Hisham's father: 'Aisha said, "Allah's Apostle was bewitched, so he invoked Allah repeatedly requesting Him to cure him from that magic)." Hisham then narrated the above narration. (See Hadith No. 658, Vol. 7)


Bukhari :: Invocations :: [8.75.401]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 401

Narrated Ibn Abi Aufa:

Allah's Apostle asked for Allah's wrath upon the Ahzab (confederates), saying, "O Allah, the Revealer of the Holy Book, and the One swift at reckoning! Defeat the confederates; Defeat them and shake them."


Bukhari :: Invocations :: [8.75.402]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 402

Narrated Abu Huraira:

When the Prophet said, "Sami' al-lahu Liman hamidah (Allah heard him who sent his praises to Him)" in the last Rak'a of the 'Isha' prayer, he used to invoke Allah, saying, "O Allah! Save 'Aiyash bin Abi Rabi'a; O Allah! Save Al-Walid bin Al-Walid; O Allah! Save the weak people among the believers; O Allah! Be hard on the Tribe of Mudar; O Allah! Inflict years of drought upon them like the years (of drought) of the Prophet Joseph."


Bukhari :: Invocations :: [8.75.403]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 403

Narrated Anas:

The Prophet sent a Sariya (an army detachment) consisting of men called Al-Qurra', and all of them were martyred. I had never seen the Prophet so sad over anything as he was over them. So he said Qunut (invocation in the prayer) for one month in the Fajr prayer, invoking for Allah's wrath upon the tribe of 'Usaiya, and he used to say, "The people of 'Usaiya have disobeyed Allah and His Apostle."


Bukhari :: Invocations :: [8.75.404]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 404

Narrated 'Aisha:

The Jews used to greet the Prophet by saying, "As-Samu 'Alaika (i.e., death be upon you), so I understood what they said, and I said to them, "As-Samu 'alaikum wal-la'na (i.e. Death and Allah's Curse be upon you)." The Prophet said, "Be gentle and calm, O 'Aisha, as Allah likes gentleness in all affairs." I said, "O Allah's Prophet! Didn't you hear what they said?" He said, "Didn't you hear me answering them back by saying, 'Alaikum (i.e., the same be upon you)?"


Bukhari :: Invocations :: [8.75.405]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 405

Narrated 'Ali bin Abi Talib:

We were in the company of the Prophet on the day (of the battle) of Al-Khandaq (the Trench). The Prophet said, "May Allah fill their (the infidels') graves and houses with fire, as they have kept us so busy that we could not offer the middle prayer till the sun had set; and that prayer was the 'Asr prayer."


Bukhari :: Invocations :: [8.75.406]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 406

Narrated Abu Huraira:

At-Tufail bin 'Amr came to Allah's Apostle and said, "O Allah's Apostle! The tribe of Daus has disobeyed (Allah and His Apostle) and refused (to embrace Islam), therefore, invoke Allah's wrath for them." The people thought that the Prophet would invoke Allah's wrath for them, but he said, "O Allah! Guide the tribe Of Daus and let them come to us,"


Bukhari :: Invocations :: [8.75.407]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 407

Narrated Abu Musa:

The Prophet used to invoke Allah with the following invocation: 'Rabbi-ghfir-li Khati 'ati wa jahli wa israfi fi amri kullihi, wa ma anta a'lamu bihi minni. Allahumma ighfirli khatayaya wa 'amdi, wa jahli wa jiddi, wa kullu dhalika'indi. Allahumma ighrifli ma qaddamtu wa ma akhartu wa ma asrartu wa ma a'lantu. Anta-l-muqaddimu wa anta-l-mu'akh-khiru, wa anta 'ala kulli shai'in qadir.'


Bukhari :: Invocations :: [8.75.408]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 408

Narrated Abu Musa Al-Ash'ari:

The Prophet used to invoke Allah, saying, "Allahumma ighfirli khati'ati wa jahli wa israfi fi amri, wa ma anta a-'lamu bihi minni. Allahumma ighfirli hazali wa jiddi wa khata'i wa amdi, wa kullu dhalika 'indi"


Bukhari :: Invocations :: [8.75.409]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 409

Narrated Abu Huraira:

Abu-l-Qasim (the Prophet) said, "On Friday there is a particular time. If a Muslim happens to be praying and invoking Allah for something good during that time, Allah will surely fulfill his request." The Prophet pointed out with his hand. We thought that he wanted to illustrate how short that time was.


Bukhari :: Invocations :: [8.75.410]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 410

Narrated Ibn Abi Mulaika:

'Aisha said, "The Jews came to the Prophet and said to him, "As-Samu 'Alaika (i.e., Death be upon you)." He replied, 'The same on you.' " 'Aisha said to them, "Death be upon you, and may Allah curse you and shower His wrath upon you!" Allah's Apostle I said, "Be gentle and calm, O 'Aisha! Be gentle and beware of being harsh and of saying evil things." She said, "Didn't you hear what they said?" He said, "Didn't you hear what I replied (to them)? have returned their statement to them, and my invocation against them will be accepted but theirs against me will not be accepted."


Bukhari :: Invocations :: [8.75.411]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 411

Narrated Abu Huraira:

The Prophet said, "When the Imam says 'Amin', then you should all say 'Amin', for the angels say 'Amin' at that time, and he whose 'Amin' coincides with the 'Amin' of the angels, all his past sins will be forgiven."


Bukhari :: Invocations :: [8.75.412]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 412

Narrated Abu Huraira:

Allah's Apostle said," Whoever says: "La ilaha illal-lah wahdahu la sharika lahu, lahu-l-mulk wa lahu-l-hamd wa huwa 'ala kulli shai'in qadir," one hundred times will get the same reward as given for manumitting ten slaves; and one hundred good deeds will be written in his accounts, and one hundred sins will be deducted from his accounts, and it (his saying) will be a shield for him from Satan on that day till night, and nobody will be able to do a better deed except the one who does more than he."


Bukhari :: Invocations :: [8.75.413]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 413

Narrated 'Amr bin Maimun:

Whoever recites it (i.e., the invocation in the above Hadith (412) ten times will be as if he manumitted one of Ishmael's descendants. Abu Aiyub narrated the same Hadith from the Prophet saying, "(Whoever recites it ten times) will be as if he had manumitted one of Ishmael's descendants."


Bukhari :: Invocations :: [8.75.414]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 414

Narrated Abu Huraira:

Allah's Apostle said, "Whoever says, 'Subhan Allah wa bihamdihi,' one hundred times a day, will be forgiven all his sins even if they were as much as the foam of the sea.


Bukhari :: Invocations :: [8.75.415]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 415

Narrated Abu Huraira:

The Prophet said, "There are two expressions which are very easy for the tongue to say, but they are very heavy in the balance and are very dear to The Beneficent (Allah), and they are, 'Subhan Allah Al-'Azim and 'Subhan Allah wa bihamdihi.'"


Bukhari :: Invocations :: [8.75.416]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 416

Narrated Abu Musa: The Prophet said, "The example of the one who celebrates the Praises of his Lord (Allah) in comparison to the one who does not celebrate the Praises of his Lord, is that of a living creature compared to a dead one."


Bukhari :: Invocations :: [8.75.417]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 417

Narrated Abu Huraira:

Allah 's Apostle said, "Allah has some angels who look for those who celebrate the Praises of Allah on the roads and paths. And when they find some people celebrating the Praises of Allah, they call each other, saying, "Come to the object of your pursuit.' " He added, "Then the angels encircle them with their wings up to the sky of the world." He added. "(after those people celebrated the Praises of Allah, and the angels go back), their Lord, asks them (those angels)----though He knows better than them----'What do My slaves say?' The angels reply, 'They say: Subhan Allah, Allahu Akbar, and Alham-du-lillah, Allah then says 'Did they see Me?' The angels reply, 'No! By Allah, they didn't see You.'

Allah says, How it would have been if they saw Me?' The angels reply, 'If they saw You, they would worship You more devoutly and celebrate Your Glory more deeply, and declare Your freedom from any resemblance to anything more often.' Allah says (to the angels), 'What do they ask Me for?' The angels reply, 'They ask You for Paradise.' Allah says (to the angels), 'Did they see it?' The angels say, 'No! By Allah, O Lord! They did not see it.' Allah says, How it would have been if they saw it?' The angels say, 'If they saw it, they would have greater covetousness for it and would seek It with greater zeal and would have greater desire for it.' Allah says, 'From what do they seek refuge?' The angels reply, 'They seek refuge from the (Hell) Fire.' Allah says, 'Did they see it?' The angels say, 'No By Allah, O Lord! They did not see it.' Allah says, How it would have been if they saw it?' The angels say, 'If they saw it they would flee from it with the extreme fleeing and would have extreme fear from it.' Then Allah says, 'I make you witnesses that I have forgiven them."' Allah's Apostle added, "One of the angels would say, 'There was so-and-so amongst them, and he was not one of them, but he had just come for some need.' Allah would say, 'These are those people whose companions will not be reduced to misery.' "


Bukhari :: Invocations :: [8.75.418]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 418

Narrated Abu Musa Al-Ash'ari:

The Prophet started ascending a high place or hill. A man (amongst his companions) ascended it and shouted in a loud voice, "La ilaha illal-lahu wallahu Akbar." (At that time) Allah's Apostle was riding his mule. Allah's Apostle said, "You are not calling upon a deaf or an absent one." and added, "O Abu Musa (or, O 'Abdullah)! Shall I tell you a sentence from the treasure of Paradise?" I said, "Yes." He said, "La haul a wala quwwata illa billah,"


Bukhari :: Invocations :: [8.75.419]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 419

Narrated Abu Huraira:

Allah has ninety-nine Names, i.e., one hundred minus one, and whoever believes in their meanings and acts accordingly, will enter Paradise; and Allah is Witr (one) and loves 'the Witr' (i.e., odd numbers).


Bukhari :: Invocations :: [8.75.420]

Invocations

Bukhari :: Book 8 :: Volume 75 :: Hadith 420

Narrated Shaqiq:

While we were waiting for 'Abdullah (bin Mas'ud). Yazid bin Muawiya came. I said (to him), "Will you sit down?" He said, "No, but I will go into the house (of Ibn Mas'ud) and let your companion (Ibn Mas'ud) come out to you; and if he should not (come out), I will come out and sit (with you)." Then 'Abdullah came out, holding the hand of Yazid, addressed us, saying, "I know that you are assembled here, but the reason that prevents me from coming out to you, is that Allah's Apostle used to preach to us at intervals during the days, lest we should become bored."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.421]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 421

Narrated Ibn 'Abbas:

The Prophet said, "There are two blessings which many people lose: (They are) Health and free time for doing good."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.422]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 422

Narrated Anas:

The Prophet said, "O Allah! There is no life worth living except the life of the Hereafter, so (please) make righteous the Ansar and the Emigrants."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.423]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 423

Narrated Sahl bin Sa'd As-Sa'idi:

We were in the company of Allah's Apostle in (the battle of) Al-Khandaq, and he was digging the trench while we were carrying the earth away. He looked at us and said, "O Allah! There is no life worth living except the life of the Hereafter, so (please) forgive the Ansar and the Emigrants."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.424]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 424

Narrated Sahl:

I heard the Prophet saying, "A (small) place equal to an area occupied by a whip in Paradise is better than the (whole) world and whatever is in it; and an undertaking (journey) in the forenoon or in the afternoon for Allah's Cause, is better than the whole world and whatever is in it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.425]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 425

Narrated Mujahid:

'Abdullah bin 'Umar said, "Allah's Apostle took hold of my shoulder and said, 'Be in this world as if you were a stranger or a traveler." The sub-narrator added: Ibn 'Umar used to say, "If you survive till the evening, do not expect to be alive in the morning, and if you survive till the morning, do not expect to be alive in the evening, and take from your health for your sickness, and (take) from your life for your death."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.426]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 426

Narrated 'Abdullah:

The Prophet drew a square and then drew a line in the middle of it and let it extend outside the square and then drew several small lines attached to that central line, and said, "This is the human being, and this, (the square) in his lease of life, encircles him from all sides (or has encircled him), and this (line), which is outside (the square), is his hope, and these small lines are the calamities and troubles (which may befall him), and if one misses him, an-other will snap (i.e. overtake) him, and if the other misses him, a third will snap (i.e. overtake) him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.427]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 427

Narrated Anas bin Malik:

The Prophet drew a few lines and said, "This is (man's) hope, and this is the instant of his death, and while he is in this state (of hope), the nearer line (death) comes to Him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.428]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 428

Narrated Abu Huraira:

The Prophet said, "Allah will not accept the excuse of any person whose instant of death is delayed till he is sixty years of age."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.429]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 429

Narrated Abu Huraira:

I heard Allah's Apostle saying, "The heart of an old man remains young in two respects, i.e., his love for the world (its wealth, amusements and luxuries) and his incessant hope."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.430]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 430

Narrated Anas bin Malik:

Allah's Apostle said, "The son of Adam (i.e. man) grows old and so also two (desires) grow old with him, i.e., love for wealth and (a wish for) a long life."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.431]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 431

Narrated 'Utban bin Malik Al-Ansari:

who was one of the men of the tribe of Bani Salim: Allah's Apostle came to me and said, "If anybody comes on the Day of Resurrection who has said: La ilaha illal-lah, sincerely, with the intention to win Allah's Pleasure, Allah will make the Hell-Fire forbidden for him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.432]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 432

Narrated Abu Huraira: Allah's Apostle said, "Allah says, 'I have nothing to give but Paradise as a reward to my believer slave, who, if I cause his dear friend (or relative) to die, remains patient (and hopes for Allah's Reward)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.433]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 433

Narrated 'Amr bin 'Auf:

(an ally of the tribe of Bani 'Amir bin Lu'ai and one of those who had witnessed the battle of Badr with Allah's Apostle) Allah's Apostle sent Abu 'Ubaida bin AlJarrah to Bahrain to collect the Jizya tax. Allah's Apostle had concluded a peace treaty with the people of Bahrain and appointed Al 'Ala bin Al-Hadrami as their chief; Abu Ubaida arrived from Bahrain with the money. The Ansar heard of Abu 'Ubaida's arrival which coincided with the Fajr (morning) prayer led by Allah's Apostle. When the Prophet finished the prayer, they came to him. Allah's Apostle smiled when he saw them and said, "I think you have heard of the arrival of Abu 'Ubaida and that he has brought something." They replied, "Yes, O Allah's Apostle! " He said, "Have the good news, and hope for what will please you. By Allah, I am not afraid that you will become poor, but I am afraid that worldly wealth will be given to you in abundance as it was given to those (nations) before you, and you will start competing each other for it as the previous nations competed for it, and then it will divert you (from good) as it diverted them." '


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.434]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 434

Narrated 'Uqba bin 'Amir:

The Prophet went out and offered the funeral prayer for the martyrs of the (battle of) Uhud and then ascended the pulpit and said, "I am your predecessor and I am a witness against you. By Allah, I am now looking at my Tank-lake (Al-Kauthar) and I have been given the keys of the treasures of the earth (or the keys of the earth). By Allah! I am not afraid that after me you will worship others besides Allah, but I am afraid that you will start competing for (the pleasures of) this world."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.435]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 435

Narrated Abu Sa'id Al-Khudri:

Allah's Apostle said, "The thing I am afraid of most for your sake, is the worldly blessings which Allah will bring forth to you." It was said, "What are the blessings of this world?" The Prophet said, "The pleasures of the world." A man said, "Can the good bring forth evil?" The Prophet kept quiet for a while till we thought that he was being inspired divinely. Then he started removing the sweat from his forehead and said," Where is the questioner?" That man said, "I (am present)." Abu Sa'id added: We thanked the man when the result (of his question) was such. The Prophet said, "Good never brings forth but good. This wealth (of the world) is (like) green and sweet (fruit), and all the vegetation which grows on the bank of a stream either kills or nearly kills the animal that eats too much of it, except the animal that eats the Khadira (a kind of vegetation). Such an animal eats till its stomach is full and then it faces the sun and starts ruminating and then it passes out dung and urine and goes to eat again. This worldly wealth is (like) sweet (fruit), and if a person earns it (the wealth) in a legal way and spends it properly, then it is an excellent helper, and whoever earns it in an illegal way, he will be like the one who eats but is never satisfied."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.436]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 436

Narrated Zahdam bin Mudarrib:

'Imran bin Husain said: The Prophet said, "The best people are my contemporaries (i.e., the present (my) generation) and then those who come after them (i.e., the next generation)." Imran added: I am not sure whether the Prophet repeated the statement twice after his first saying. The Prophet added, "And after them there will come people who will bear witness, though they will not be asked to give their witness; and they will be treacherous and nobody will trust them, and they will make vows, but will not fulfill them, and fatness will appear among them."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.437]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 437

Narrated 'Abdullah :

The Prophet said, "The best people are those of my generation, and then those who will come after them (the next generation), and then those who will come after them (i.e. the next generation), and then after them, there will come people whose witness will precede their oaths, and whose oaths will precede their witness."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.438]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 438

Narrated Qais:

I heard Khabbab, who had branded his abdomen with seven brands, saying, "Had Allah's Apostle not forbidden us to invoke Allah for death, I would have invoked Allah for death. The companions of Muhammad have left this world without taking anything of their reward in it (i.e., they will have perfect reward in the Hereafter), but we have collected of the worldly wealth what we cannot spend but on earth (i.e. on building houses)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.439]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 439

Narrated Qais:

I came to Khabbab while he was building a wall, and he (Khabbab) said, "Our companions who have left this world, did not enjoy anything of their reward therein, while we have collected after them, much wealth that we cannot spend but on earth (i.e., on building)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.440]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 440

Narrated Khabbab:

We migrated with the Prophet..(This narration is related in the chapter of migration).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.441]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 441

Narrated Ibn 'Abbas:

I brought water to Uthman bin 'Affan to perform the ablution while he was sitting on his seat. He performed the ablution in a perfect way and said, "I saw the Prophet performing the ablution in this place and he performed it in a perfect way and said, "Whoever performs the ablution as I have done this time and then proceeds to the mosque and offers a two-Rak'at prayer and then sits there (waiting for the compulsory congregational prayers), then all his past sins will be forgiven." The Prophet further added, "Do not be conceited (thinking that your sins will be forgiven because of your prayer)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.442]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 442

Narrated Mirdas Al-Aslami:

The Prophet said, "The righteous (pious people will depart (die) in succession one after the other, and there will remain (on the earth) useless people like the useless husk of barley seeds or bad dates, and Allah will not


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.443]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 443

Narrated Abu Huraira:

The Prophet said, "Perish the slave of Dinar, Dirham, Qatifa (thick soft cloth), and Khamisa (a garment), for if he is given, he is pleased; otherwise he is dissatisfied."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.444]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 444

Narrated Ibn 'Abbas:

I heard the Prophet saying, "If the son of Adam (the human being) had two valley of money, he would wish for a third, for nothing can fill the belly of Adam's son except dust, and Allah forgives him who repents to Him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.445]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 445

Narrated Ibn 'Abbas:

I heard Allah's Apostle saying, "If the son of Adam had money equal to a valley, then he will wish for another similar to it, for nothing can satisfy the eye of Adam's son except dust. And Allah forgives him who repents to Him." Ibn 'Abbas said: I do not know whether this saying was quoted from the Qur'an or not. 'Ata' said, "I heard Ibn AzZubair saying this narration while he was on the pulpit."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.446]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 446

Narrated Sahl bin Sa'd:

I heard Ibn Az-Zubair who was on the pulpit at Mecca, delivering a sermon, saying, "O men! The Prophet used to say, "If the son of Adam were given a valley full of gold, he would love to have a second one; and if he were given the second one, he would love to have a third, for nothing fills the belly of Adam's son except dust. And Allah forgives he who repents to Him." Ubai said, "We considered this as a saying from the Qur'an till the Sura (beginning with) 'The mutual rivalry for piling up of worldly things diverts you..' (102.1) was revealed."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.447]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 447

Narrated Anas bin Malik:

Allah's Apostle said, "If Adam's son had a valley full of gold, he would like to have two valleys, for nothing fills his mouth except dust. And Allah forgives him who repents to Him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.448]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 448

Narrated Hakim bin Hizam:

I asked the Prophet (for some money) and he gave me, and then again I asked him and he gave me, and then again I asked him and he gave me and he then said, "This wealth is (like) green and sweet (fruit), and whoever takes it without greed, Allah will bless it for him, but whoever takes it with greed, Allah will not bless it for him, and he will be like the one who eats but is never satisfied. And the upper (giving) hand is better than the lower (taking) hand."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.449]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 449

Narrated 'Abdullah:

The Prophet said, "Who among you considers the wealth of his heirs dearer to him than his own wealth?" They replied, "O Allah's Apostle! There is none among us but loves his own wealth more." The Prophet said, "So his wealth is whatever he spends (in Allah's Cause) during his life (on good deeds) while the wealth of his heirs is whatever he leaves after his death."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.450]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 450

Narrated Abu Dhar:

Once I went out at night and found Allah's Apostle walking all alone accompanied by nobody, and I thought that perhaps he disliked that someone should accompany him. So I walked in the shade, away from the moonlight, but the Prophet looked behind and saw me and said, "Who is that?" I replied, "Abu Dhar, let Allah get me sacrificed for you!" He said, "O Abu Dhar, come here!" So I accompanied him for a while and then he said, "The rich are in fact the poor (little rewarded) on the Day of Resurrection except him whom Allah gives wealth which he gives (in charity) to his right, left, front and back, and does good deeds with it. I walked with him a little longer. Then he said to me, "Sit down here." So he made me sit in an open space surrounded by rocks, and said to me, "Sit here till I come back to you." He went towards Al-Harra till I could not see him, and he stayed away for a long period, and then I heard him saying, while he was coming, "Even if he had committed theft, and even if he had committed illegal sexual intercourse?" When he came, I could not remain patient and asked him, "O Allah's Prophet! Let Allah get me sacrificed for you! Whom were you speaking to by the side of Al-Harra? I did not hear anybody responding to your talk." He said, "It was Gabriel who appeared to me beside Al-Harra and said, 'Give the good news to your followers that whoever dies without having worshipped anything besides Allah, will enter Paradise.' I said, 'O Gabriel! Even if he had committed theft or committed illegal sexual intercourse?' He said, 'Yes.' I said, 'Even if he has committed theft or committed illegal sexual intercourse?' He said, 'Yes.' I said, 'Even if he has committed theft or committed illegal sexual intercourse?' He said, 'Yes.' "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.451]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 451

Narrated Abu Dhar:

While I was walking with the Prophet in the Harra of Medina, Uhud came in sight. The Prophet said, "O Abu Dhar!" I said, "Labbaik, O Allah's Apostle!" He said, "I would not like to have gold equal to this mountain of Uhud, unless nothing of it, not even a single Dinar of it remains with me for more than three days, except something which I will keep for repaying debts. I would have spent all of it (distributed it) amongst Allah's Slaves like this, and like this, and like this." The Prophet pointed out with his hand towards his right, his left and his back (while illustrating it). He proceeded with his walk and said, "The rich are in fact the poor (little rewarded) on the Day of Resurrection except those who spend their wealth like this, and like this, and like this, to their right, left and back, but such people are few in number." Then he said to me, "Stay at your place and do not leave it till I come back." Then he proceeded in the darkness of the night till he went out of sight, and then I heard a loud voice, and was afraid that something might have happened to the Prophet .1 intended to go to him, but I remembered what he had said to me, i.e. 'Don't leave your place till I come back to you,' so I remained at my place till he came back to me. I said, "O Allah's Apostle! I heard a voice and I was afraid." So I mentioned the whole story to him. He said, "Did you hear it?" I replied, "Yes." He said, "It was Gabriel who came to me and said, 'Whoever died without joining others in worship with Allah, will enter Paradise.' I asked (Gabriel), 'Even if he had committed theft or committed illegal sexual intercourse? Gabriel said, 'Yes, even if he had committed theft or committed illegal sexual intercourse."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.452]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 452

Narrated Abu Huraira:

Allah Apostle said, "If I had gold equal to the mountain of Uhud, it would not please me that anything of it should remain with me after three nights (i.e., I would spend all of it in Allah's Cause) except what I would keep for repaying debts."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.453]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 453

Narrated Abu Huraira:

The Prophet said, "Riches does not mean, having a great amount of property, but riches is self-contentment."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.454]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 454

Narrated Sahl bin Sa'd As-Sa'id:

A man passed by Allah's Apostle and the Prophet asked a man sitting beside him, "What is your opinion about this (passer-by)?" He replied, "This (passer-by) is from the noble class of people. By Allah, if he should ask for a lady's hand in marriage, he ought to be given her in marriage, and if he intercedes for somebody, his intercession will be accepted. Allah's Apostle kept quiet, and then another man passed by and Allah's Apostle asked the same man (his companion) again, "What is your opinion about this (second) one?" He said, "O Allah's Apostle! This person is one of the poor Muslims. If he should ask a lady's hand in marriage, no-one will accept him, and if he intercedes for somebody, no one will accept his intercession, and if he talks, no-one will listen to his talk." Then Allah's Apostle said, "This (poor man) is better than such a large number of the first type (i.e. rich men) as to fill the earth."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.455]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 455

Narrated Abu Wail:

We paid a visit to Khabbab who was sick, and he said, "We migrated with the Prophet for Allah's Sake and our wages became due on Allah. Some of us died without having received anything of the wages, and one of them was Mus'ab bin 'Umar, who was martyred on the day of the battle of Uhud, leaving only one sheet (to shroud him in). If we covered his head with it, his feet became uncovered, and if we covered his feet with it, his head became uncovered. So the Prophet ordered us to cover his head with it and put some Idhkhir (a kind of grass) over his feet. On the other hand, some of us have had the fruits (of our good deed) and are plucking them (in this world)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.456]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 456

Narrated 'Imran bin Husain:

The Prophet said, "I looked into Paradise and found that the majority of its dwellers were the poor people, and I looked into the (Hell) Fire and found that the majority of its dwellers were women."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.457]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 457

Narrated Anas:

The Prophet did not eat at a table till he died, and he did not eat a thin nicely baked wheat bread till he died.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.458]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 458

Narrated 'Aisha:

When the Prophet died, nothing which can be eaten by a living creature was left on my shelf except some barley grain. I ate of it for a period and when I measured it, it finished.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.459]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 459

Narrated Abu Huraira:

By Allah except Whom none has the right to- be worshipped, (sometimes) I used to lay (sleep) on the ground on my liver (abdomen) because of hunger, and (sometimes) I used to bind a stone over my belly because of hunger. One day I sat by the way from where they (the Prophet and h is companions) used to come out. When Abu Bakr passed by, I asked him about a Verse from Allah's Book and I asked him only that he might satisfy my hunger, but he passed by and did not do so. Then Umar passed by me and I asked him about a Verse from Allah's Book, and I asked him only that he might satisfy my hunger, but he passed by without doing so. Finally Abu-l-Qasim (the Prophet ) passed by me and he smiled when he saw me, for he knew what was in my heart and on my face. He said, "O Aba Hirr (Abu Huraira)!" I replied, "Labbaik, O Allah's Apostle!" He said to me, "Follow me." He left and I followed him.

Then he entered the house and I asked permission to enter and was admitted. He found milk in a bowl and said, "From where is this milk?" They said, "It has been presented to you by such-and-such man (or by such and such woman)." He said, "O Aba Hirr!" I said, "Labbaik, O Allah's Apostle!" He said, "Go and call the people of Suffa to me." These people of Suffa were the guests of Islam who had no families, nor money, nor anybody to depend upon, and whenever an object of charity was brought to the Prophet , he would send it to them and would not take anything from it, and whenever any present was given to him, he used to send some for them and take some of it for himself. The order off the Prophet upset me, and I said to myself, "How will this little milk be enough for the people of As-Suffa?" thought I was more entitled to drink from that milk in order to strengthen myself, but behold! The Prophet came to order me to give that milk to them. I wondered what will remain of that milk for me, but anyway, I could not but obey Allah and His Apostle so I went to the people of As-Suffa and called them, and they came and asked the Prophet's permission to enter. They were admitted and took their seats in the house.

The Prophet said, "O Aba-Hirr!" I said, "Labbaik, O Allah's Apostle!" He said, "Take it and give it to them." So I took the bowl (of Milk) and started giving it to one man who would drink his fill and return it to me, whereupon I would give it to another man who, in his turn, would drink his fill and return it to me, and I would then offer it to another man who would drink his fill and return it to me. Finally, after the whole group had drunk their fill, I reached the Prophet who took the bowl and put it on his hand, looked at me and smiled and said. "O Aba Hirr!" I replied, "Labbaik, O Allah's Apostle!" He said, "There remain you and I." I said, "You have said the truth, O Allah's Apostle!" He said, "Sit down and drink." I sat down and drank. He said, "Drink," and I drank. He kept on telling me repeatedly to drink, till I said, "No. by Allah Who sent you with the Truth, I have no space for it (in my stomach)." He said, "Hand it over to me." When I gave him the bowl, he praised Allah and pronounced Allah's Name on it and drank the remaining milk.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.460]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 460

Narrated Sa'd:

I was the first man among the Arabs to throw an arrow for Allah's Cause. We used to fight in Allah's Cause while we had nothing to eat except the leaves of the Hubla and the Sumur trees (desert trees) so that we discharged excrement like that of sheep (i.e. unmixed droppings). Today the (people of the) tribe of Bani Asad teach me the laws of Islam. If so, then I am lost, and all my efforts of that hard time had gone in vain.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.461]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 461

Narrated 'Aisha:

The family of Muhammad had never eaten their fill of wheat bread for three successive days since they had migrated to Medina till the death of the Prophet.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.462]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 462

Narrated 'Aisha:

The family of Muhammad did not eat two meals on one day, but one of the two was of dates.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.463]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 463

Narrated 'Aisha:

The bed mattress of the Prophet was made of a leather case stuffed with palm fibres.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.464]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 464

Narrated Qatada:

We used to go to Anas bin Malik and see his baker standing (preparing the bread). Anas said, "Eat. I have not known that the Prophet ever saw a thin well-baked loaf of bread till he died, and he never saw a roasted sheep with his eyes."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.465]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 465

Narrated 'Aisha:

A complete month would pass by during which we would not make a fire (for cooking), and our food used to be only dates and water unless we were given a present of some meat.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.466]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 466

Narrated 'Aisha:

that she said to Urwa, "O, the son of my sister! We used to see three crescents in two months, and no fire used to be made in the houses of Allah's Apostle (i.e. nothing used to be cooked)." 'Urwa said, "What used to sustain you?" 'Aisha said, "The two black things i.e. dates and water, except that Allah's Apostle had neighbors from the Ansar who had some milch she-camels, and they used to give the Prophet some milk from their house, and he used to make us drink it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.467]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 467

Narrated Abu Huraira:

Allah's Apostle said, "O Allah! Give food to the family of Muhammad."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.468]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 468

Narrated Masruq:

I asked 'Aisha "What deed was the most beloved to the Prophet?" She said, "The regular constant one." I said, "At what time did he use to get up at night (for the Tahajjud night prayer)?' She said, "He used to get up on hearing (the crowing of) the cock (the last third of the night)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.469]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 469

Narrated 'Aisha:

The most beloved action to Allah's Apostle was that whose doer did it continuously and regularly.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.470]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 470

Narrated Abu Huraira:

Allah's Apostle said, "The deeds of anyone of you will not save you (from the (Hell) Fire)." They said, "Even you (will not be saved by your deeds), O Allah's Apostle?" He said, "No, even I (will not be saved) unless and until Allah bestows His Mercy on me. Therefore, do good deeds properly, sincerely and moderately, and worship Allah in the forenoon and in the afternoon and during a part of the night, and always adopt a middle, moderate, regular course whereby you will reach your target (Paradise)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.471]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 471

Narrated 'Aisha:

Allah's Apostle said, "Do good deeds properly, sincerely and moderately and know that your deeds will not make you enter Paradise, and that the most beloved deed to Allah's is the most regular and constant even though it were little."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.472]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 472

Narrated 'Aisha:

The Prophet was asked, "What deeds are loved most by Allah?" He said, "The most regular constant deeds even though they may be few." He added, 'Don't take upon yourselves, except the deeds which are within your ability."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.473]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 473

Narrated 'Alqama:

I asked 'Aisha, mother of the believers, "O mother of the believers! How were the deeds of the Prophet? Did he use to do extra deeds of worship on special days?" She said, "No, but his deeds were regular and constant, and who among you is able to do what the Prophet was able to do (i.e. in worshipping Allah)?"


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.474]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 474

Narrated 'Aisha:

The Prophet said, "Do good deeds properly, sincerely and moderately, and receive good news because one's good deeds will not make him enter Paradise." They asked, "Even you, O Allah's Apostle?" He said, "Even I, unless and until Allah bestows His pardon and Mercy on me."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.475]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 475

Narrated Anas bin Malik:

Once Allah's Apostle led us in prayer and then (after finishing it) ascended the pulpit and pointed with his hand towards the Qibla of the mosque and said, "While I was leading you in prayer, both Paradise and Hell were displayed in front of me in the direction of this wall. I had never seen a better thing (than Paradise) and a worse thing (than Hell) as I have seen today, I had never seen a better thing and a worse thing as I have seen today."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.476]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 476

Narrated Abu Huraira:

I heard Allah's Apostle saying, Verily Allah created Mercy. The day He created it, He made it into one hundred parts. He withheld with Him ninety-nine parts, and sent its one part to all His creatures. Had the non-believer known of all the Mercy which is in the Hands of Allah, he would not lose hope of entering Paradise, and had the believer known of all the punishment which is present with Allah, he would not consider himself safe from the Hell-Fire."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.477]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 477

Narrated Abu Said:

Some people from the Ansar asked Allah's Apostle (to give them something) and he gave to everyone of them, who asked him, until all that he had was finished. When everything was finished and he had spent all that was in his hand, he said to them, '"(Know) that if I have any wealth, I will not withhold it from you (to keep for somebody else); And (know) that he who refrains from begging others (or doing prohibited deeds), Allah will make him contented and not in need of others; and he who remains patient, Allah will bestow patience upon him, and he who is satisfied with what he has, Allah will make him self-sufficient. And there is no gift better and vast (you may be given) than patience."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.478]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 478

Narrated Al-Mughira bin Shu'ba:

The Prophet used to pray so much that his feet used to become edematous or swollen, and when he was asked as to why he prays so much, he would say, "Shall I not be a thankful slave (to Allah)?"


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.479]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 479

Narrated Ibn Abbas:

Allah's Apostle said, "Seventy thousand people of my followers will enter Paradise without accounts, and they are those who do not practice Ar-Ruqya and do not see an evil omen in things, and put their trust in their Lord.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.480]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 480

Narrated Warrad:

(the clerk of Al-Mughira bin Shu'ba) Muawiya wrote to Al-Mughira: "Write to me a narration you have heard from Allah's Apostle." So Al-Mughira wrote to him, "I heard him saying the following after each prayer: 'La ilaha illal-lahu wahdahu la sharika lahu, lahu-l-mulk wa lahuI-hamd, wa huwa 'ala kulli Shai-in qadir.' He also used to forbid idle talk, asking too many questions (in religion), wasting money, preventing what should be given, and asking others for something (except in great need), being undutiful to mothers, and burying one's little daughters (alive)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.481]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 481

Narrated Sahl bin Sa'd:

Allah's Apostle said, "Whoever can guarantee (the chastity of) what is between his two jaw-bones and what is between his two legs (i.e. his tongue and his private parts), I guarantee Paradise for him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.482]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 482

Narrated Abu Huraira:

Allah's Apostle said, "Whoever believes in Allah and the Last Day should talk what is good or keep quiet, and whoever believes in Allah and the Last Day should not hurt (or insult) his neighbor; and whoever believes in Allah and the Last Day, should entertain his guest generously."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.483]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 483

Narrated Abu Shuraih Al-Khuza'i:

My ears heard and my heart grasped (the statement which) the Prophet said, "The period for keeping one's guest is three days (and don't forget) his reward." It was asked, "What is his reward?" He said, "In the first night and the day he should be given a high class quality of meals; and whoever believes in Allah and the Last Day, should entertain his guest generously; and whoever believes in Allah and the Last Day should talk what is good (sense) or keep quiet."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.484]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 484

Narrated Abu Huraira:

That he heard Allah's Apostle saying, "A slave of Allah may utter a word without thinking whether it is right or wrong, he may slip down in the Fire as far away a distance equal to that between the east."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.485]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 485

Narrated Abu Huraira:

The Prophet; said, "A slave (of Allah) may utter a word which pleases Allah without giving it much importance, and because of that Allah will raise him to degrees (of reward): a slave (of Allah) may utter a word (carelessly) which displeases Allah without thinking of its gravity and because of that he will be thrown into the Hell-Fire."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.486]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 486

Narrated Abu Huraira:

The Prophet said Allah will give shade to seven (types of people) under His Shade (on the Day of Resurrection). (one of them will be) a person who remembers Allah and his eyes are then flooded with tears.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.487]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 487

Narrated Hudhaifa:

The Prophet said, "There was a man amongst the people who had suspicion as to the righteousness of his deeds. Therefore he said to his family, 'If I die, take me and burn my corpse and throw my ashes into the sea on a hot (or windy) day.' They did so, but Allah, collected his particles and asked (him), What made you do what you did?' He replied, 'The only thing that made me do it, was that I was afraid of You.' So Allah forgave him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.488]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 488

Narrated Abu Said :

The Prophet mentioned a man from the previous generation or from the people preceding your age whom Allah had given both wealth and children. The Prophet said, "When the time of his death approached, he asked his children, 'What type of father have I been to you?' They replied: You have been a good father. He said, 'But he (i.e. your father) has not stored any good deeds with Allah (for the Hereafter): if he should face Allah, Allah will punish him. So listen, (O my children), when I die, burn my body till I become mere coal and then grind it into powder, and when there is a stormy wind, throw me (my ashes) in it.' So he took a firm promise from his children (to follow his instructions). And by Allah they (his sons) did accordingly(fulfilled their promise.) Then Allah said, "Be"' and behold! That man was standing there! Allah then said. "O my slave! What made you do what you did?" That man said, "Fear of You." So Allah forgave him.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.489]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 489

Narrated Abu Musa:

Allah's Apostle said. "My example and the example of the message with which Allah has sent me is like that of a man who came to some people and said, "I have seen with my own eyes the enemy forces, and I am a naked warner (to you) so save yourself, save yourself! A group of them obeyed him and went out at night, slowly and stealthily and were safe, while another group did not believe him and thus the army took them in the morning and destroyed them."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.490]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 490

Narrated Abu Huraira:

I heard Allah's Apostle saying, "My example and the example of the people is that of a man who made a fire, and when it lighted what was around it, Moths and other insects started falling into the fire. The man tried (his best) to prevent them, (from falling in the fire) but they overpowered him and rushed into the fire. The Prophet added: Now, similarly, I take hold of the knots at your waist (belts) to prevent you from falling into the Fire, but you insist on falling into it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.491]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 491

Narrated 'Abdullah bin 'Amr:

The Prophet said, "A Muslim is the one who avoids harming Muslims with his tongue or his hands. And a Muhajir (an emigrant) is the one who gives up (abandons) all what Allah has forbidden."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.492]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 492

Narrated Abu Huraira:

Allah's Apostle said, "If you knew that which I know you would laugh little and weep much."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.493]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 493

Narrated Anas:

The Prophet said, "If you knew that which I know, you would laugh little and weep much."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.494]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 494

Narrated Abu Huraira:

Allah's Apostle said, "The (Hell) Fire is surrounded by all kinds of desires and passions, while Paradise is surrounded by all kinds of disliked undesirable things."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.495]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 495

Narrated 'Abdullah:

The Prophet said, "Paradise is nearer to any of you than the Shirak (leather strap) of his shoe, and so is the (Hell) Fire.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.496]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 496

Narrated Abu Huraira:

The Prophet said, "The truest poetic verse ever said by a poet, is: Indeed! Everything except Allah, is perishable."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.497]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 497

Narrated Abu Huraira:

Allah's Apostle said, "If anyone of you looked at a person who was made superior to him in property and (in good) appearance, then he should also look at the one who is inferior to him, and to whom he has been made superior."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.498]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 498

Narrated Ibn 'Abbas:

The Prophet narrating about his Lord I'm and said, "Allah ordered (the appointed angels over you) that the good and the bad deeds be written, and He then showed (the way) how (to write). If somebody intends to do a good deed and he does not do it, then Allah will write for him a full good deed (in his account with Him); and if he intends to do a good deed and actually did it, then Allah will write for him (in his account) with Him (its reward equal) from ten to seven hundred times to many more times: and if somebody intended to do a bad deed and he does not do it, then Allah will write a full good deed (in his account) with Him, and if he intended to do it (a bad deed) and actually did it, then Allah will write one bad deed (in his account) ."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.499]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 499

Narrated Ghailan:

Anas said "You people do (bad) deeds (commit sins) which seem in your eyes as tiny (minute) than hair while we used to consider those (very deeds) during the life-time of the Prophet as destructive sins."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.500]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 500

Narrated Sa'd bin Sahl As-Sa'idi:

The Prophet looked at a man fighting against the pagans and he was one of the most competent persons fighting on behalf of the Muslims. The Prophet said, "Let him who wants to look at a man from the dwellers of the (Hell) Fire, look at this (man)." Another man followed him and kept on following him till he (the fighter) was injured and, seeking to die quickly, he placed the blade tip of his sword between his breasts and leaned over it till it passed through his shoulders (i.e., committed suicide)." The Prophet added, "A person may do deeds that seem to the people as the deeds of the people of Paradise while in fact, he is from the dwellers of the (Hell) Fire: and similarly a person may do deeds that seem to the people as the deeds of the people of the (Hell) Fire while in fact, he is from the dwellers of Paradise. Verily, the (results of) deeds done, depend upon the last actions."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.501]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 501

Narrated Abu Sa'id Al-Khudri:

A bedouin came to the Prophet and said, "O Allah's Apostle! Who is the best of mankind!" The Prophet said, "A man who strives for Allah's Cause with his life and property, and also a man who lives (all alone) in a mountain path among the mountain paths to worship his Lord and save the people from his evil."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.502]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 502

Narrated Abu Said:


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.503]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 503

Narrated Abu Huraira:

Allah's Apostle said, "When honesty is lost, then wait for the Hour." It was asked, "How will honesty be lost, O Allah's Apostle?" He said, "When authority is given to those who do not deserve it, then wait for the Hour."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.504]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 504

Narrated Hudhaifa:

Allah's Apostle narrated to us two narrations, one of which I have seen (happening) and I am waiting for the other. He narrated that honesty was preserved in the roots of the hearts of men (in the beginning) and then they learnt it (honesty) from the Qur'an, and then they learnt it from the (Prophet's) Sunna (tradition). He also told us about its disappearance, saying, "A man will go to sleep whereupon honesty will be taken away from his heart, and only its trace will remain, resembling the traces of fire. He then will sleep whereupon the remainder of the honesty will also be taken away (from his heart) and its trace will resemble a blister which is raised over the surface of skin, when an ember touches one's foot; and in fact, this blister does not contain anything. So there will come a day when people will deal in business with each other but there will hardly be any trustworthy persons among them. Then it will be said that in such-and-such a tribe there is such-and-such person who is honest, and a man will be admired for his intelligence, good manners and strength, though indeed he will not have belief equal to a mustard seed in his heart." The narrator added: There came upon me a time when I did not mind dealing with anyone of you, for if he was a Muslim, his religion would prevent him from cheating; and if he was a Christian, his Muslim ruler would prevent him from cheating; but today I cannot deal except with so-and-so and so-and-so. (See Hadith No. 208, Vol. 9)


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.505]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 505

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "People are just like camels, out of one hundred, one can hardly find a single camel suitable to ride."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.506]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 506

Narrated Jundub:

The Prophet said, "He who lets the people hear of his good deeds intentionally, to win their praise, Allah will let the people know his real intention (on the Day of Resurrection), and he who does good things in public to show off and win the praise of the people, Allah will disclose his real intention (and humiliate him).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.507]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 507

Narrated Mu'adh bin Jabal:

While I was riding behind the Prophet as a companion rider and there was nothing between me and him except the back of the saddle, he said, "O Mu'adh!" I replied, "Labbaik O Allah's Apostle! And Sa'diak!" He proceeded for a while and then said, "O Mu'adh!" I said, "Labbaik and Sa'daik, O Allah's Apostle!" He then proceeded for another while and said, "O Mu'adh bin Jabal!" I replied, "Labbaik, O Allah's Apostle, and Sa'daik!" He said, "Do you know what is Allah's right on His slaves?" I replied, "Allah and His Apostle know better." He said, "Allah's right on his slaves is that they should worship Him and not worship anything besides Him." He then proceeded for a while, and again said, "O Mu'adh bin Jabal!" I replied. "Labbaik, O Allah's Apostle, and Sa'daik." He said, "Do you know what is (Allah's) slaves' (people's) right on Allah if they did that?" I replied, "Allah and His Apostle know better." He said, "The right of (Allah's) slaves on Allah is that He should not punish them (if they did that)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.508]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 508

Narrated Anas:

The Prophet had a she-camel called Al'Adba' and it was too fast to surpass in speed. There came a bedouin riding a camel of his, and that camel outstripped it (i.e. Al-Aqba'). That result was hard on the Muslims who said sorrowfully, "Al- Adba has been outstripped." Allah's Apostle said, "It is due from Allah that nothing would be raised high in this world except that He lowers or puts it down."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.509]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 509

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'I will declare war against him who shows hostility to a pious worshipper of Mine. And the most beloved things with which My slave comes nearer to Me, is what I have enjoined upon him; and My slave keeps on coming closer to Me through performing Nawafil (praying or doing extra deeds besides what is obligatory) till I love him, so I become his sense of hearing with which he hears, and his sense of sight with which he sees, and his hand with which he grips, and his leg with which he walks; and if he asks Me, I will give him, and if he asks My protection (Refuge), I will protect him; (i.e. give him My Refuge) and I do not hesitate to do anything as I hesitate to take the soul of the believer, for he hates death, and I hate to disappoint him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.510]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 510

Narrated Sahl:

Allah's Apostle said, "I have been sent and the Hour (is at hand) as these two," showing his two fingers and sticking (separating) them out.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.511]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 511

Narrated Anas:

Allah's Apostle said, "I have been sent and the Hour (is at hand) as these two (fingers)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.512]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 512

Narrated Abu Huraira:

The Prophet said, "I have been sent and the Hour (is at hand) as these two (fingers)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.513]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 513

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established till the sun rises from the west, and when it rises (from the west) and the people see it, then all of them will believe (in Allah). But that will be the time when 'No good it will do to a soul to believe then. If it believed not before.."' (6.158)

The Hour will be established (so suddenly) that two persons spreading a garment between them will not be able to finish their bargain, nor will they be able to fold it up. The Hour will be established while a man is carrying the milk of his she-camel, but cannot drink it; and the Hour will be established when someone is not able to prepare the tank to water his livestock from it; and the Hour will be established when some of you has raised his food to his mouth but cannot eat it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.514]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 514

Narrated 'Ubada bin As-Samit:

The Prophet said, "Who-ever loves to meet Allah, Allah (too) loves to meet him and who-ever hates to meet Allah, Allah (too) hates to meet him". 'Aisha, or some of the wives of the Prophet said, "But we dislike death." He said: It is not like this, but it is meant that when the time of the death of a believer approaches, he receives the good news of Allah's pleasure with him and His blessings upon him, and so at that time nothing is dearer to him than what is in front of him. He therefore loves the meeting with Allah, and Allah (too) loves the meeting with him. But when the time of the death of a disbeliever approaches, he receives the evil news of Allah's torment and His Requital, whereupon nothing is more hateful to him than what is before him. Therefore, he hates the meeting with Allah, and Allah too, hates the meeting with him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.515]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 515

Narrated Abu Musa:

The Prophet said, "Whoever loves the meeting with Allah, Allah too, loves the meeting with him; and whoever hates the meeting with Allah, Allah too, hates the meeting with him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.516]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 516

Narrated 'Aisha:

(the wife of the Prophet) When Allah's Apostle was in good health, he used to say, "No prophet's soul is ever captured unless he is shown his place in Paradise and given the option (to die or survive)." So when the death of the Prophet approached and his head was on my thigh, he became unconscious for a while and then he came to his senses and fixed his eyes on the ceiling and said, "O Allah (with) the highest companions." (See Qur'an 4:69). I said' "Hence he is not going to choose us." And I came to know that it was the application of the narration which he (the Prophet) used to narrate to us. And that was the last statement of the Prophet (before his death) i.e., "O Allah! With the highest companions." (See Qur'an 4:69)


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.517]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 517

Narrated 'Aisha:

There was a leather or wood container full of water in front of Allah's Apostle (at the time of his death). He would put his hand into the water and rub his face with it, saying, "None has the right to be worshipped but Allah! No doubt, death has its stupors." Then he raised his hand and started saying, "(O Allah!) with the highest companions." (See Qur'an 4:69) (and kept on saying it) till he expired and his hand dropped."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.518]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 518

Narrated 'Aisha:

Some rough bedouins used to visit the Prophet and ask him, "When will the Hour be?" He would look at the youngest of all of them and say, "If this should live till he is very old, your Hour (the death of the people addressed) will take place." Hisham said that he meant (by the Hour), their death.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.519]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 519

Narrated Abu Qatada bin Rib'i Al-Ansari:

A funeral procession passed by Allah's Apostle who said, "Relieved or relieving?" The people asked, "O Allah's Apostle! What is relieved and relieving?" He said, "A believer is relieved (by death) from the troubles and hardships of the world and leaves for the Mercy of Allah, while (the death of) a wicked person relieves the people, the land, the trees, (and) the animals from him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.520]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 520

Narrated Abu Qatada:

The Prophet said, "Relieved or relieving. And a believer is relieved (by death)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.521]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 521

Narrated Anas bin Malik:

Allah's Apostle said, "When carried to his grave, a dead person is followed by three, two of which return (after his burial) and one remains with him: his relative, his property, and his deeds follow him; relatives and his property go back while his deeds remain with him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.522]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 522

Narrated Ibn 'Umar:

Allah's Apostle said, "When anyone of you dies, his destination is displayed before him in the forenoon and in the afternoon, either in the (Hell) Fire or in Paradise, and it is said to him, "That is your place till you are resurrected and sent to it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.523]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 523

Narrated 'Aisha:

The Prophet said, "Do not abuse the dead, for they have reached the result of what they have done."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.524]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 524

Narrated Abu Huraira:

Two men, a Muslim and a Jew, abused each other. The Muslim said, "By Him Who gave superiority to Muhammad over all the people." On that, the Jew said, "By Him Who gave superiority to Moses over all the people." The Muslim became furious at that and slapped the Jew in the face. The Jew went to Allah's Apostle and informed him of what had happened between him and the Muslim. Allah's Apostle said, "Don't give me superiority over Moses, for the people will fall unconscious on the Day of Resurrection and I will be the first to gain consciousness, and behold ! Moses will be there holding the side of Allah's Throne. I will not know whether Moses has been among those people who have become unconscious and then has regained consciousness before me, or has been among those exempted by Allah from falling unconscious."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.525]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 525

Narrated Abu Huraira:

The Prophet said, "The people will fall down unconscious at the time when they should fall down (i.e., on the Day of Resurrection), and then I will be the first man to get up, and behold, Moses will be there holding (Allah's) Throne. I will not know whether he has been amongst those who have fallen unconscious."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.526]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 526

Narrated Abu Huraira:

The Prophet said, "Allah will take the whole earth (in His Hand) and will roll up the Heaven in His right Hand, and then He will say, "I am King! Where are the kings of the earth ? "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.527]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 527

Narrated Abu Said Al-Khudri:

The Prophet said, "The (planet of) earth will be a bread on the Day of Resurrection, and The resistible (Allah) will topple turn it with His Hand like anyone of you topple turns a bread with his hands while (preparing the bread) for a journey, and that bread will be the entertainment for the people of Paradise." A man from the Jews came (to the Prophet) and said, "May The Beneficent (Allah) bless you, O Abul Qasim! Shall I tell you of the entertainment of the people of Paradise on the Day of Resurrection?" The Prophet said, "Yes." The Jew said, "The earth will be a bread," as the Prophet had said. Thereupon the Prophet looked at us and smiled till his premolar tooth became visible. Then the Jew further said, "Shall I tell you of the udm (additional food taken with bread) they will have with the bread?" He added, "That will be Balam and Nun." The people asked, "What is that?" He said, "It is an ox and a fish, and seventy thousand people will eat of the caudate lobe (i.e. extra lobe) of their livers."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.528]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 528

Narrated Sahl bin Sa'd:

I heard the Prophet saying, "The people will be gathered on the Day of Resurrection on reddish white land like a pure loaf of bread (made of pure fine flour)." Sahl added: That land will have no landmarks for anybody (to make use of).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.529]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 529

Narrated Abu Huraira:

The Prophet said, "The people will be gathered in three ways: (The first way will be of) those who will wish or have a hope (for Paradise) and will have a fear (of punishment), (The second batch will be those who will gather) riding two on a camel or three on a camel or ten on a camel. (The third batch) the rest of the people will be urged to gather by the Fire which will accompany them at the time of their afternoon nap and stay with them where they will spend the night, and will be with them in the morning wherever they may be then, and will be with them in the afternoon wherever they may be then."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.530]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 530

Narrated Anas bin Malik:

A man said, "O Allah's Prophet! Will a Kafir (disbeliever) be gathered (driven prone) on his face?" The Prophet said, "Is not He Who made him walk with his legs in this world, able to make him walk on his face on the Day of Resurrection?" (Qatada, a sub-narrator said: Yes, (He can), by the Power of Our Lord!")


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.531]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 531

Narrated Ibn Abbas:

The Prophet said, "You will meet Allah barefooted, naked, walking on feet, and uncircumcised."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.532]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 532

Narrated Ibn 'Abbas:

I heard Allah's Apostle while he was delivering a sermon on a pulpit, saying, "You will meet Allah barefooted, naked, and uncircumcised."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.533]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 533

Narrated Ibn 'Abbas:

The Prophet stood up among us and addressed (saying) "You will be gathered, barefooted, naked, and uncircumcised (as Allah says): 'As We began the first creation, We shall repeat it..' (21.104) And the first human being to be dressed on the Day of Resurrection will be (the Prophet) Abraham Al-Khalil. Then will be brought some men of my followers who will be taken towards the left (i.e., to the Fire), and I will say: 'O Lord! My companions whereupon Allah will say: You do not know what they did after you left them. I will then say as the pious slave, Jesus said, And I was witness over them while I dwelt amongst them..........(up to) ...the All-Wise.' (5.117-118). The narrator added: Then it will be said that those people (relegated from Islam, that is) kept on turning on their heels (deserted Islam).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.534]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 534

Narrated 'Aisha:

Allah's Apostle said, "The people will be gathered barefooted, naked, and uncircumcised." I said, "O Allah's Apostle! Will the men and the women look at each other?" He said, "The situation will be too hard for them to pay attention to that."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.535]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 535

Narrated 'Abdullah:

While we were in the company of the Prophet in a tent he said, ''Would it please you to be one fourth of the people of Paradise?" We said, "Yes." He said, "Would It please you to be one-third of the people of Paradise?" We said, "Yes." He said, "Would it please you to be half of the people of Paradise?" We said, "Yes." Thereupon he said, "I hope that you will be one half of the people of Paradise, for none will enter Paradise but a Muslim soul, and you people, in comparison to the people who associate others in worship with Allah, are like a white hair on the skin of a black ox, or a black hair on the skin of a red ox."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.536]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 536

Narrated Abu Huraira:

The Prophet said, "The first man to be called on the Day of Resurrection will be Adam who will be shown his offspring, and it will be said to them, 'This is your father, Adam.' Adam will say (responding to the call), 'Labbaik and Sa'daik' Then Allah will say (to Adam), 'Take out of your offspring, the people of Hell.' Adam will say, 'O Lord, how many should I take out?' Allah will say, 'Take out ninety-nine out of every hundred." They (the Prophet's companions) said, "O Allah's Apostle! If ninety-nine out of every one hundred of us are taken away, what will remain out of us?" He said, "My followers in comparison to the other nations are like a white hair on a black ox."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.537]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 537

Narrated Abu Said:

The Prophet said, "Allah will say, 'O Adam!. Adam will reply, 'Labbaik and Sa'daik (I respond to Your Calls, I am obedient to Your orders), wal Khair fi Yadaik (and all the good is in Your Hands)!' Then Allah will say (to Adam), Bring out the people of the Fire.' Adam will say, 'What (how many) are the people of the Fire?' Allah will say, 'Out of every thousand (take out) nine-hundred and ninety-nine (persons).' At that time children will become hoary-headed and every pregnant female will drop her load (have an abortion) and you will see the people as if they were drunk, yet not drunk; But Allah's punishment will be very severe."

That news distressed the companions of the Prophet too much, and they said, "O Allah's Apostle! Who amongst us will be that man (the lucky one out of one-thousand who will be saved from the Fire)?" He said, "Have the good news that one-thousand will be from Gog and Magog, and the one (to be saved will be) from you." The Prophet added, "By Him in Whose Hand my soul is, I Hope that you (Muslims) will be one third of the people of Paradise." On that, we glorified and praised Allah and said, "Allahu Akbar." The Prophet then said, "By Him in Whose Hand my soul is, I hope that you will be one half of the people of Paradise, as your (Muslims) example in comparison to the other people (non-Muslims), is like that of a white hair on the skin of a black ox, or a round hairless spot on the foreleg of a donkey."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.538]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 538

Narrated Ibn 'Umar:

The Prophet said (regarding the Verse), "A Day when all mankind will stand before the Lord of the Worlds,' (that day) they will stand, drowned in their sweat up to the middle of their ears."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.539]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 539

Narrated Abu Huraira :

Allah's Apostle said, "The people will sweat so profusely on the Day of Resurrection that their sweat will sink seventy cubits deep into the earth, and it will rise up till it reaches the people's mouths and ears."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.540]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 540

Narrated 'Abdullah:

The Prophet said, "The cases which will be decided first (on the Day of Resurrection) will be the cases of blood-shedding. "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.541]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 541

Narrated Abu Huraira:

Allah's Apostle said, "Whoever has wronged his brother, should ask for his pardon (before his death), as (in the Hereafter) there will be neither a Dinar nor a Dirham. (He should secure pardon in this life) before some of his good deeds are taken and paid to his brother, or, if he has done no good deeds, some of the bad deeds of his brother are taken to be loaded on him (in the Hereafter)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.542]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 542

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "The believers, after being saved from the (Hell) Fire, will be stopped at a bridge between Paradise and Hell and mutual retaliation will be established among them regarding wrongs they have committed in the world against one another. After they are cleansed and purified (through the retaliation), they will be admitted into Paradise; and by Him in Whose Hand Muhammad's soul is, everyone of them will know his dwelling in Paradise better than he knew his dwelling in this world."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.543]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 543

Narrated Ibn Abi Mulaika:

'Aisha said, "The Prophet said, 'Anybody whose account (record) is questioned will surely be punished.' I said, 'Doesn't Allah say: 'He surely will receive an easy reckoning?' (84.8) The Prophet replied. 'This means only the presentation of the account."'


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.544]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 544

Narrated 'Aisha:

The Prophet said (as above, 543).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.545]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 545

Narrated 'Aisha:

Allah's Apostle, said, "None will be called to account on the Day of Resurrection, but will be ruined." I said "O Allah's Apostle! Hasn't Allah said: 'Then as for him who will be given his record in his right hand, he surely will receive an easy reckoning? (84.7-8) -- Allah's Apostle said, "That (Verse) means only the presentation of the accounts, but anybody whose account (record) is questioned on the Day of Resurrection, will surely be punished."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.546]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 546

Narrated Anas bin Malik:

Allah's Prophet used to say, "A disbeliever will be brought on the Day of Resurrection and will be asked. "Suppose you had as much gold as to fill the earth, would you offer it to ransom yourself?" He will reply, "Yes." Then it will be said to him, "You were asked for something easier than that (to join none in worship with Allah (i.e. to accept Islam, but you refused)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.547]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 547

Narrated 'Adi bin Hatim:

The Prophet said, "There will be none among you but will be talked to by Allah on the Day of Resurrection, without there being an interpreter between him and Him (Allah) . He will look and see nothing ahead of him, and then he will look (again for the second time) in front of him, and the (Hell) Fire will confront him. So, whoever among you can save himself from the Fire, should do so even with one half of a date (to give in charity)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.548]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 548

Narrated 'Adi bin Hatim:

The Prophet said, "Protect yourself from the Fire." He then turned his face aside (as if he were looking at it) and said again, "Protect yourself from the Fire," and then turned his face aside (as if he were looking at it), and he said so for the third time till we thought he was looking at it. He then said, "Protect yourselves from the Fire, even if with one half of a date and he who hasn't got even this, (should do so) by (saying) a good, pleasant word.'


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.549]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 549

Narrated Ibn 'Abbas:

The Prophet said, "The people were displayed in front of me and I saw one prophet passing by with a large group of his followers, and another prophet passing by with only a small group of people, and another prophet passing by with only ten (persons), and another prophet passing by with only five (persons), and another prophet passed by alone. And then I looked and saw a large multitude of people, so I asked Gabriel, "Are these people my followers?' He said, 'No, but look towards the horizon.' I looked and saw a very large multitude of people. Gabriel said. 'Those are your followers, and those are seventy thousand (persons) in front of them who will neither have any reckoning of their accounts nor will receive any punishment.' I asked, 'Why?' He said, 'For they used not to treat themselves with branding (cauterization) nor with Ruqya (get oneself treated by the recitation of some Verses of the Qur'an) and not to see evil omen in things, and they used to put their trust (only) in their Lord." On hearing that, 'Ukasha bin Mihsan got up and said (to the Prophet), "Invoke Allah to make me one of them." The Prophet said, "O Allah, make him one of them." Then another man got up and said (to the Prophet), "Invoke Allah to make me one of them." The Prophet said, 'Ukasha has preceded you."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.550]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 550

Narrated Abu Huraira:

I heard Allah's Apostle saying, "From my followers there will enter Paradise a crowd, seventy thousand in number whose faces will glitter as the moon does when it is full." On hearing that, 'Ukasha bin Mihsan Al-Asdi got up, lifting his covering sheet, and said, "O Allah's Apostle! Invoke Allah that He may make me one of them." The Prophet said, "O Allah, make him one of them." Another man from the Ansar got up and said, "O Allah's Apostle! Invoke Allah to make me one of them. "The Prophet said (to him), "'Ukasha has preceded you."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.551]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 551

Narrated Sahl bin Sa'd:

The Prophet said, "Seventy-thousand or seven-hundred thousand of my followers (the narrator is in doubt as to the correct number) will enter Paradise holding each other till the first and the last of them enter Paradise at the same time, and their faces will have a glitter like that of the moon at night when it is full."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.552]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 552

Narrated Ibn 'Umar:

The Prophet; said, "The people of Paradise will enter Paradise, and the people of the (Hell) Fire will enter the (Hell) Fire: then a call-maker will get up (and make an announcement) among them, 'O the people of the (Hell) Fire! No death anymore ! And O people of Paradise! No death (anymore) but Eternity."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.553]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 553

Narrated Abu Huraira:

The Prophet said, " It will be said to the people of Paradise, 'O people of Paradise! Eternity (for you) and no death,' and to the people of the Fire, 'O people of the Fire, eternity (for you) and no death!"


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.554]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 554

Narrated 'Imran:

The Prophet said, "I looked into paradise and saw that the majority of its people were the poor, and I looked into the Fire and found that the majority of its people were women."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.555]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 555

Narrated Usama:

The Prophet said, "I stood at the gate of Paradise and saw that the majority of the people who had entered it were poor people, while the rich were forbidden (to enter along with the poor, because they were waiting the reckoning of their accounts), but the people of the Fire had been ordered to be driven to the Fire. And I stood at the gate of the Fire and found that the majority of the people entering it were women."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.556]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 556

Narrated Ibn 'Umar:

Allah's Apostle said, "When the people of Paradise have entered Paradise and the people of the Fire have entered the Fire, death will be brought and will be placed between the Fire and Paradise, and then it will be slaughtered, and a call will be made (that), 'O people of Paradise, no more death ! O people of the Fire, no more death ! ' So the people of Paradise will have happiness added to their previous happiness, and the people of the Fire will have sorrow added to their previous sorrow."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.557]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 557

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Allah will say to the people of Paradise, 'O the people of Paradise!' They will say, 'Labbaik, O our Lord, and Sa'daik!' Allah will say, 'Are you pleased?" They will say, 'Why should we not be pleased since You have given us what You have not given to anyone of Your creation?' Allah will say, 'I will give you something better than that.' They will reply, 'O our Lord! And what is better than that?' Allah will say, 'I will bestow My pleasure and contentment upon you so that I will never be angry with you after for-ever.' "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.558]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 558

Narrated Anas:

Haritha was martyred on the day (of the battle) of Badr while he was young. His mother came to the Prophet saying, "O Allah's Apostle! You know the relation of Haritha to me (how fond of him I was); so, if he is in Paradise, I will remain patient and wish for Allah's reward, but if he is not there, then you will see what I will do." The Prophet replied, "May Allah be merciful upon you! Have you gone mad? (Do you think) it is one Paradise? There are many Paradises and he is in the (most superior) Paradise of Al-Firdaus."

8.559.:

Narrated Abu Huraira:

The Prophet said, "The width between the two shoulders of a Kafir (disbeliever) will be equal to the distance covered by a fast rider in three days."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.559]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 559

Narrated Abu Sa'id:

The Prophet said: There is a tree in Paradise (so huge) that a fast (or a trained) rider may travel: for one hundred years without being able to cross it.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.560]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 560

Narrated Sahl bin Sa'd:

Allah's Apostle said, "Seventy thousand or seven hundred thousand of my followers will enter Paradise. (Abu Hazim, the sub-narrator, is not sure as to which of the two numbers is correct.) And they will be holding on to one another, and the first of them will not enter till the last of them has entered, and their faces will be like the moon on a full moon night."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.561]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 561

Narrated Sahl:

The Prophet said, "The people of Paradise will see the Ghuraf (special abodes) in Paradise as you see a star in the sky." Abu Said added: "As you see a glittering star remaining in the eastern horizon and the western horizon."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.562]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 562

Narrated Anas bin Malik:

The Prophet said, "Allah will say to the person who will have the minimum punishment in the Fire on the Day of Resurrection, 'If you had things equal to whatever is on the earth, would you ransom yourself (from the punishment) with it?' He will reply, Yes. Allah will say, 'I asked you a much easier thing than this while you were in the backbone of Adam, that is, not to worship others besides Me, but you refused and insisted to worship others besides Me."'


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.563]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 563

Narrated Hammad from 'Amr from Jabir:

The Prophet said, "Some people will come out of the Fire through intercession looking like The Thaarir." I asked 'Amr, "What is the Thaarir?" He said, Ad Daghabis, and at that time he was toothless. Hammad added: I said to 'Amr bin Dinar, "O Abu Muhammad! Did you hear Jabir bin 'Abdullah saying, 'I heard the Prophet saying: 'Some people will come out of the Fire through intercession?" He said, "Yes. "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.564]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 564

Narrated Anas bin Malik:

The Prophet said, "Some people will come out of the Fire after they have received a touch of the Fire, changing their color, and they will enter Paradise, and the people of Paradise will name them 'Al-Jahannamiyin' the (Hell) Fire people."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.565]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 565

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "When the people of Paradise have entered Paradise, and the people of the Fire have entered the Fire, Allah will say. 'Take out (of the Fire) whoever has got faith equal to a mustard seed in his heart.' They will come out, and by that time they would have burnt and became like coal, and then they will be thrown into the river of Al-Hayyat (life) and they will spring up just as a seed grows on the bank of a rainwater stream." The Prophet said, "Don't you see that the germinating seed comes out yellow and twisted?"


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.566]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 566

Narrated An-Nu'man:

I heard the Prophet saying, "The person who will have the least punishment from amongst the Hell Fire people on the Day of Resurrection, will be a man under whose arch of the feet a smoldering ember will be placed so that his brain will boil because of it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.567]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 567

Narrated An-Nu'man bin Bashir:

I heard the Prophet saying, "The least punished person of the (Hell) Fire people on the Day of Resurrection will be a man under whose arch of the feet two smoldering embers will be placed, because of which his brain will boil just like Al-Mirjal (copper vessel) or a Qum-qum (narrow-necked vessel) is boiling with water."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.568]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 568

Narrated 'Adi bin Hatim:

The Prophet mentioned the Fire and turned his face aside and asked for Allah's protection from it, and then again he mentioned the Fire and turned his face aside and asked for Allah's protection from it and said, "Protect yourselves from the Hell-Fire, even if with one half of a date, and he who cannot afford that, then (let him do so) by (saying) a good, pleasant word."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.569]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 569

Narrated Abu Said Al-Khudri:

I heard Allah's Apostles when his uncle, Abu Talib had been mentioned in his presence, saying, "May be my intercession will help him (Abu Talib) on the Day of Resurrection so that he may be put in a shallow place in the Fire, with fire reaching his ankles and causing his brain to boil."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.570]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 570

Narrated Anas:

Allah's Apostle said, "Allah will gather all the people on the Day of Resurrection and they will say, 'Let us request someone to intercede for us with our Lord so that He may relieve us from this place of ours.' Then they will go to Adam and say, 'You are the one whom Allah created with His Own Hands, and breathed in you of His soul, and ordered the angels to prostrate to you; so please intercede for us with our Lord.' Adam will reply, 'I am not fit for this undertaking, and will remember his sin, and will say, 'Go to Noah, the first Apostle sent by Allah' They will go to him and he will say, 'I am not fit for this undertaking', and will remember his sin and say, 'Go to Abraham whom Allah took as a Khalil. They will go to him (and request similarly). He will reply, 'I am not fit for this undertaking,' and will remember his sin and say, 'Go to Moses to whom Allah spoke directly.' They will go to Moses and he will say, 'I am not fit for this undertaking,' and will remember his sin and say, 'Go to Jesus.' They will go to him, and he will say, 'I am not fit for this undertaking, go to Muhammad as Allah has forgiven his past and future sins.' They will come to me and I will ask my Lord's permission, and when I see Him, I will fall down in prostration to Him, and He will leave me in that state as long as (He) Allah will, and then I will be addressed. 'Raise up your head (O Muhammad)! Ask, and your request will be granted, and say, and your saying will be listened to; intercede, and your intercession will be accepted.' Then I will raise my head, and I will glorify and praise my Lord with a saying(i.e. invocation) He will teach me, and then I will intercede, Allah will fix a limit for me (i.e., certain type of people for whom I may intercede), and I will take them out of the (Hell) Fire and let them enter Paradise. Then I will come back (to Allah) and fall in prostration, and will do the same for the third and fourth times till no-one remains in the (Hell) Fire except those whom the Qur'an has imprisoned therein." (The sub-narrator, Qatada used to say at that point, "...those upon whom eternity (in Hell) has been imposed.") (See Hadith No. 3, Vol 6).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.571]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 571

Narrated 'Imran bin Husain:

The Prophet said, "Some people will be taken out of the Fire through the intercession of Muhammad they will enter Paradise and will be called Al-Jahannamiyin (the Hell Fire people)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.572]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 572

Narrated Anas:

Um (the mother of) Haritha came to Allah's Apostle after Haritha had been martyred on the Day (of the battle) of Badr by an arrow thrown by an unknown person. She said, "O Allah's Apostle! You know the position of Haritha in my heart (i.e. how dear to me he was), so if he is in Paradise, I will not weep for him, or otherwise, you will see what I will do." The Prophet said, "Are you mad? Is there only one Paradise? There are many Paradises, and he is in the highest Paradise of Firdaus." The Prophet added, "A forenoon journey or an after noon journey in Allah's Cause is better than the whole world and whatever is in it; and a place equal to an arrow bow of anyone of you, or a place equal to a foot in Paradise is better than the whole world and whatever is in it; and if one of the women of Paradise looked at the earth, she would fill the whole space between them (the earth and the heaven) with light, and would fill whatever is in between them, with perfume, and the veil of her face is better than the whole world and whatever is in it."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.573]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 573

Narrated Abu Huraira:

The Prophet said, "None will enter Paradise but will be shown the place he would have occupied in the (Hell) Fire if he had rejected faith, so that he may be more thankful; and none will enter the (Hell) Fire but will be shown the place he would have occupied in Paradise if he had faith, so that may be a cause of sorrow for him."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.574]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 574

Narrated Abu Huraira:

I said, "O Allah's Apostle! Who will be the luckiest person who will gain your intercession on the Day of Resurrection?" The Prophet said, "O Abu Huraira! I have thought that none will ask me about this Hadith before you, as I know your longing for the (learning of) Hadiths. The luckiest person who will have my intercession on the Day of Resurrection will be the one who said, 'None has the right to be worshipped but Allah,' sincerely from the bottom of his heart."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.575]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 575

Narrated 'Abdullah:

The Prophet said, "I know the person who will be the last to come out of the (Hell) Fire, and the last to enter Paradise. He will be a man who will come out of the (Hell) Fire crawling, and Allah will say to him, 'Go and enter Paradise.' He will go to it, but he will imagine that it had been filled, and then he will return and say, 'O Lord, I have found it full.' Allah will say, 'Go and enter Paradise, and you will have what equals the world and ten times as much (or, you will have as much as ten times the like of the world).' On that, the man will say, 'Do you mock at me (or laugh at me) though You are the King?" I saw Allah's Apostle (while saying that) smiling that his premolar teeth became visible. It is said that will be the lowest in degree amongst the people of Paradise.


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.576]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 576

Narrated 'Abbas:

that he said to the Prophet "Did you benefit Abu Talib with anything?"


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.577]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 577

Narrated Abu Huraira:

Some people said, "O Allah's Apostle! Shall we see our Lord on the Day of Resurrection?" He said, "Do you crowd and squeeze each other on looking at the sun when it is not hidden by clouds?" They replied, "No, Allah's Apostle." He said, "Do you crowd and squeeze each other on looking at the moon when it is full and not hidden by clouds?" They replied, No, O Allah's Apostle!" He said, "So you will see Him (your Lord) on the Day of Resurrection similarly Allah will gather all the people and say, 'Whoever used to worship anything should follow that thing. 'So, he who used to worship the sun, will follow it, and he who used to worship the moon will follow it, and he who used to worship false deities will follow them; and then only this nation (i.e., Muslims) will remain, including their hypocrites. Allah will come to them in a shape other than they know and will say, 'I am your Lord.' They will say, 'We seek refuge with Allah from you. This is our place; (we will not follow you) till our Lord comes to us, and when our Lord comes to us, we will recognize Him.

Then Allah will come to then in a shape they know and will say, "I am your Lord.' They will say, '(No doubt) You are our Lord,' and they will follow Him. Then a bridge will be laid over the (Hell) Fire." Allah's Apostle added, "I will be the first to cross it. And the invocation of the Apostles on that Day, will be 'Allahukka Sallim, Sallim (O Allah, save us, save us!),' and over that bridge there will be hooks Similar to the thorns of As Sa'dan (a thorny tree). Didn't you see the thorns of As-Sa'dan?" The companions said, "Yes, O Allah's Apostle." He added, "So the hooks over that bridge will be like the thorns of As-Sa-dan except that their greatness in size is only known to Allah. These hooks will snatch the people according to their deeds. Some people will be ruined because of their evil deeds, and some will be cut into pieces and fall down in Hell, but will be saved afterwards, when Allah has finished the judgments among His slaves, and intends to take out of the Fire whoever He wishes to take out from among those who used to testify that none had the right to be worshipped but Allah.

We will order the angels to take them out and the angels will know them by the mark of the traces of prostration (on their foreheads) for Allah banned the f ire to consume the traces of prostration on the body of Adam's son. So they will take them out, and by then they would have burnt (as coal), and then water, called Maul Hayat (water of life) will be poured on them, and they will spring out like a seed springs out on the bank of a rainwater stream, and there will remain one man who will be facing the (Hell) Fire and will say, 'O Lord! It's (Hell's) vapor has Poisoned and smoked me and its flame has burnt me; please turn my face away from the Fire.' He will keep on invoking Allah till Allah says, 'Perhaps, if I give you what you want), you will ask for another thing?' The man will say, 'No, by Your Power, I will not ask You for anything else.'

Then Allah will turn his face away from the Fire. The man will say after that, 'O Lord, bring me near the gate of Paradise.' Allah will say (to him), 'Didn't you promise not to ask for anything else? Woe to you, O son of Adam ! How treacherous you are!' The man will keep on invoking Allah till Allah will say, 'But if I give you that, you may ask me for something else.' The man will say, 'No, by Your Power. I will not ask for anything else.' He will give Allah his covenant and promise not to ask for anything else after that. So Allah will bring him near to the gate of Paradise, and when he sees what is in it, he will remain silent as long as Allah will, and then he will say, 'O Lord! Let me enter Paradise.' Allah will say, 'Didn't you promise that you would not ask Me for anything other than that? Woe to you, O son of Adam ! How treacherous you are!' On that, the man will say, 'O Lord! Do not make me the most wretched of Your creation,' and will keep on invoking Allah till Allah will smile and when Allah will smile because of him, then He will allow him to enter Paradise, and when he will enter Paradise, he will be addressed, 'Wish from so-and-so.' He will wish till all his wishes will be fulfilled, then Allah will say, All this (i.e. what you have wished for) and as much again therewith are for you.' "

Abu Huraira added: That man will be the last of the people of Paradise to enter (Paradise).

Narrated 'Ata (while Abu Huraira was narrating): Abu Said was sitting in the company of Abu Huraira and he did not deny anything of his narration till he reached his saying: "All this and as much again therewith are for you." Then Abu Sa'id said, "I heard Allah's Apostle saying, 'This is for you and ten times as much.' " Abu Huraira said, "In my memory it is 'as much again therewith.' "


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.578]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 578

Narrated 'Abdullah:

The Prophet said, "I am your predecessor at the Lake-Fount." 'Abdullah added: The Prophet said, "I am your predecessor at the Lake-Fount, and some of you will be brought in front of me till I will see them and then they will be taken away from me and I will say, 'O Lord, my companions!' It will be said, 'You do not know what they did after you had left.'


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.579]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 579

Narrated Ibn 'Umar:

The Prophet said, "There will be a tank (Lake-Fount) in front of you as large as the distance between Jarba and Adhruh (two towns in Sham)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.580]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 580

Narrated Ibn 'Abbas:

The word 'Al-Kauthar' means the abundant good which Allah gave to him (the Prophet Muhammad). Abu Bishr said: I said to Said, "Some people claim that it (Al-Kauthar) is a river in Paradise." Said replied, "The river which is in Paradise is one item of that good which Allah has bestowed upon him (Muhammad)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.581]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 581

Narrated 'Abdullah bin 'Amr:

The Prophet said, "My Lake-Fount is (so large that it takes) a month's journey to cross it. Its water is whiter than milk, and its smell is nicer than musk (a kind of Perfume), and its drinking cups are (as numerous) as the (number of) stars of the sky; and whoever drinks from it, will never be thirsty."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.582]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 582

Narrated Anas bin Malik:

Allah's Apostle said, "The width of my Lake-Fount is equal to the distance between Aila (a town in Sham) and Sana' (the capital of Yemen) and it has as many (numerous) jugs as the number of stars of the sky."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.583]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 583

Narrated Anas bin Malik:

The Prophet said: "While I was walking in Paradise (on the night of Mi'raj), I saw a river, on the two banks of which there were tents made of hollow pearls. I asked, "What is this, O Gabriel?' He said, 'That is the Kauthar which Your Lord has given to you.' Behold! Its scent or its mud was sharp smelling musk!" (The sub-narrator, Hudba is in doubt as to the correct expression. )


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.584]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 584

Narrated Anas:

The Prophet said, "Some of my companions will come to me at my Lake Fount, and after I recognize them, they will then be taken away from me, whereupon I will say, 'My companions!' Then it will be said, 'You do not know what they innovated (new things) in the religion after you."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.585]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 585

Narrated Abu Hazim from Sahl bin Sa'd:

The Prophet said, "I am your predecessor (forerunner) at the Lake-Fount, and whoever will pass by there, he will drink from it and whoever will drink from it, he will never be thirsty. There will come to me some people whom I will recognize, and they will recognize me, but a barrier will be placed between me and them." Abu Hazim added: An-Nu'man bin Abi 'Aiyash, on hearing me, said. "Did you hear this from Sahl?" I said, "Yes." He said, " I bear witness that I heard Abu Said Al-Khudri saying the same, adding that the Prophet said: 'I will say: They are of me (i.e. my followers). It will be said, 'You do not know what they innovated (new things) in the religion after you left'. I will say, 'Far removed, far removed (from mercy), those who changed (their religion) after me." Abu Huraira narrated that the Prophet said, "On the Day of Resurrection a group of companions will come to me, but will be driven away from the Lake-Fount, and I will say, 'O Lord (those are) my companions!' It will be said, 'You have no knowledge as to what they innovated after you left; they turned apostate as renegades (reverted from Islam)."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.586]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 586

Narrated Ibn Al-Musaiyab:

The companions of the Prophet said, "Some men from my companions will come to my Lake-Fount and they will be driven away from it, and I will say, 'O Lord, my companions!' It will be said, 'You have no knowledge of what they innovated after you left: they turned apostate as renegades (reverted from Islam).


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.587]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 587

Narrated Abu Huraira:

The Prophet said, "While I was sleeping, a group (of my followers were brought close to me), and when I recognized them, a man (an angel) came out from amongst (us) me and them, he said (to them), 'Come along.' I asked, 'Where?' He said, 'To the (Hell) Fire, by Allah' I asked, 'what is wrong with them' He said, 'They turned apostate as renegades after you left.' Then behold! (Another) group (of my followers) were brought close to me, and when I recognized them, a man (an angel) came out from (me and them) he said (to them); Come along.' I asked, "Where?' He said, 'To the (Hell) Fire, by Allah.' I asked, What is wrong with them?' He said, 'They turned apostate as renegades after you left. So I did not see anyone of them escaping except a few who were like camels without a shepherd."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.588]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 588

Narrated Abu Huraira:

Allah's Apostle said, "Between my house and my pulpit there is a garden from amongst the gardens of Paradise, and my pulpit is over my Lake-Fount."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.589]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 589

Narrated Jundab:

I heard the Prophet, saying, "I am your predecessor at the Lake-Fount. (Al-Kauthar) .


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.590]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 590

Narrated 'Uqba bin 'Amir:

Once the Prophet went out and offered the funeral prayers for the martyrs of Uhud, and then went to the pulpit and said, "I am a predecessor for you and I am a witness for you: and by Allah, I am looking at my Fount just now, and the keys of the treasures of the earth (or the keys of the earth) have been given to me: and by Allah, I am not afraid that you will worship others besides Allah after me, but I am afraid that you will strive and struggle against each other over these treasures of the world."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.591]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 591

Narrated Haritha bin Wahb:

I heard the Prophet mentioning the Lake-Fount (Al-Kauthar), saying, "(The width of the Lake-Fount) is equal to the distance between Medina and Sana' (capital of Yemen)." Haritha said that he heard the Prophet saying that his Lake-Fount would be as large as the distance between Sana' and Medina. Al-Mustaurid said to Haritha, "Didn't you hear him talking about the vessels?" He said, "No." Al-Mustaurid said, "The vessels are seen in it as (numberless as) the stars."


Bukhari :: To make the Heart Tender (Ar-Riqaq) :: [8.76.592]

To make the Heart Tender (Ar-Riqaq)

Bukhari :: Book 8 :: Volume 76 :: Hadith 592

Narrated Asma 'bint Abu Bakr:

The Prophet said, "I will be standing at the Lake-Fount so that I will see whom among you will come to me; and some people will be taken away from me, and I will say, 'O Lord, (they are) from me and from my followers.' Then it will be said, 'Did you notice what they did after you? By Allah, they kept on turning on their heels (turned as renegades).' " The sub-narrator, Ibn Abi Mulaika said, "O Allah, we seek refuge with You from turning on our heels, or being put to trial in our religion."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.593]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 593

Narrated 'Abdullah:

Allah's Apostle, the truthful and truly-inspired, said, "Each one of you collected in the womb of his mother for forty days, and then turns into a clot for an equal period (of forty days) and turns into a piece of flesh for a similar period (of forty days) and then Allah sends an angel and orders him to write four things, i.e., his provision, his age, and whether he will be of the wretched or the blessed (in the Hereafter). Then the soul is breathed into him. And by Allah, a person among you (or a man) may do deeds of the people of the Fire till there is only a cubit or an arm-breadth distance between him and the Fire, but then that writing (which Allah has ordered the angel to write) precedes, and he does the deeds of the people of Paradise and enters it; and a man may do the deeds of the people of Paradise till there is only a cubit or two between him and Paradise, and then that writing precedes and he does the deeds of the people of the Fire and enters it."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.594]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 594

Narrated Anas bin Malik:

The Prophet said, "Allah puts an angel in charge of the uterus and the angel says, 'O Lord, (it is) semen! O Lord, (it is now ) a clot! O Lord, (it is now) a piece of flesh.' And then, if Allah wishes to complete its creation, the angel asks, 'O Lord, (will it be) a male or a female? A wretched (an evil doer) or a blessed (doer of good)? How much will his provisions be? What will his age be?' So all that is written while the creature is still in the mother's womb."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.595]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 595

Narrated Imran bin Husain:

A man said, "O Allah's Apostle! Can the people of Paradise be known (differentiated) from the people of the Fire; The Prophet replied, "Yes." The man said, "Why do people (try to) do (good) deeds?" The Prophet said, "Everyone will do the deeds for which he has been created to do or he will do those deeds which will be made easy for him to do." (i.e. everybody will find easy to do such deeds as will lead him to his destined place for which he has been created).


Bukhari :: Divine Will (Al-Qadar) :: [8.77.596]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 596

Narrated Ibn 'Abbas:

The Prophet ; was asked about the offspring of the pagans. He said, "Allah knows what they would have done (were they to live)."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.597]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 597

Narrated Abu Huraira:

Allah's Apostle was asked about the offspring of the pagans. He said, "Allah knows what they would have done (were they to live)."

Narrated Abu Huraira: Allah's Apostle said, "No child is born but has the Islamic Faith, but its parents turn it into a Jew or a Christian. It is as you help the animals give birth. Do you find among their offspring a mutilated one before you mutilate them yourself?" The people said, "O Allah's Apostle! What do you think about those (of them) who die young?" The Prophet said, "Allah knows what they would have done (were they to live)."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.598]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 598

Narrated Abu Huraira:

Allah's Apostle said, "No woman should ask for the divorce of her sister (Muslim) so as to take her place, but she should marry the man (without compelling him to divorce his other wife), for she will have nothing but what Allah has written for her."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.599]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 599

Narrated Usama:

Once while I was with the Prophet and Sa'd, Ubai bin Ka'b and Mu'adh were also sitting with him, there came to him a messenger from one of his daughters, telling him that her child was on the verge of death. The Prophet told the messenger to tell her, "It is for Allah what He takes, and it is for Allah what He gives, and everything has its fixed time (limit). So (she should) be patient and look for Allah's reward."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.600]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 600

Narrated Abu Said Al-Khudri:

That while he was sitting with the Prophet a man from the Ansar came and said, "O Allah's Apostle! We get slave girls from the war captives and we love property; what do you think about coitus interruptus?" Allah's Apostle said, "Do you do that? It is better for you not to do it, for there is no soul which Allah has ordained to come into existence but will be created."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.601]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 601

Narrated Hudhaifa:

The Prophet once delivered a speech in front of us wherein he left nothing but mentioned (about) everything that would happen till the Hour. Some of us stored that our minds and some forgot it. (After that speech) I used to see events taking place (which had been referred to in that speech) but I had forgotten them (before their occurrence). Then I would recognize such events as a man recognizes another man who has been absent and then sees and recognizes him.


Bukhari :: Divine Will (Al-Qadar) :: [8.77.602]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 602

Narrated 'Ali:

While we were sitting with the Prophet who had a stick with which he was scraping the earth, he lowered his head and said, "There is none of you but has his place assigned either in the Fire or in Paradise." Thereupon a man from the people said, "Shall we not depend upon this, O Allah's Apostle?" The Prophet said, "No, but carry on and do your deeds, for everybody finds it easy to do such deeds (as will lead him to his place)." The Prophet then recited the Verse: 'As for him who gives (in charity) and keeps his duty to Allah..' (92.5)


Bukhari :: Divine Will (Al-Qadar) :: [8.77.603]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 603

Narrated Abu Huraira:

We witnessed along with Allah's Apostle the Khaibar (campaign). Allah's Apostle told his companions about a man who claimed to be a Muslim, "This man is from the people of the Fire." When the battle started, the man fought very bravely and received a great number of wounds and got crippled. On that, a man from among the companions of the Prophet came and said, "O Allah's Apostle! Do you know what the man you described as of the people of the Fire has done? He has fought very bravely for Allah's Cause and he has received many wounds." The Prophet said, "But he is indeed one of the people of the Fire." Some of the Muslims were about to have some doubt about that statement. So while the man was in that state, the pain caused by the wounds troubled him so much that he put his hand into his quiver and took out an arrow and committed suicide with it. Off went some men from among the Muslims to Allah's Apostle and said, "O Allah's Apostle! Allah has made your statement true. So-and-so has committed suicide." Allah's Apostle said, "O Bilal! Get up and announce in public: None will enter Paradise but a believer, and Allah may support this religion (Islam) with a wicked man."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.604]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 604

Narrated Sahl bin Sa'd:

There was a man who fought most bravely of all the Muslims on behalf of the Muslims in a battle (Ghazwa) in the company of the Prophet. The Prophet looked at him and said. "If anyone would like to see a man from the people of the Fire, let him look at this (brave man)." On that, a man from the People (Muslims) followed him, and he was in that state i.e., fighting fiercely against the pagans till he was wounded, and then he hastened to end his life by placing his sword between his breasts (and pressed it with great force) till it came out between his shoulders. Then the man (who was watching that person) went quickly to the Prophet and said, "I testify that you are Allah's Apostle!" The Prophet asked him, "Why do you say that?" He said, "You said about so-and-so, 'If anyone would like to see a man from the people of the Fire, he should look at him.' He fought most bravely of all of us on behalf of the Muslims and I knew that he would not die as a Muslim (Martyr). So when he got wounded, he hastened to die and committed suicide." There-upon the Prophet said, "A man may do the deeds of the people of the Fire while in fact he is one of the people of Paradise, and he may do the deeds of the people of Paradise while in fact he belongs to the people of Fire, and verily, (the rewards of) the deeds are decided by the last actions (deeds)".


Bukhari :: Divine Will (Al-Qadar) :: [8.77.605]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 605

Narrated Ibn 'Umar:

The Prophet forbade vowing and said, "In fact, vowing does not prevent anything, but it makes a miser to spend his property."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.606]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 606

Narrated Abu Huraira:

The Prophet said (that Allah said), "Vowing does not bring to the son of Adam anything I have not already written in his fate, but vowing is imposed on him by way of fore ordainment. Through vowing I make a miser spend of his wealth."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.607]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 607

Narrated Abu Musa:

While we were with Allah's Apostle in a holy battle, we never went up a hill or reached its peak or went down a valley but raised our voices with Takbir. Allah's Apostle came close to us and said, "O people! Don't exert yourselves, for you do not call a deaf or an absent one, but you call the All-Listener, the All-Seer." The Prophet then said, "O 'Abdullah bin Qais! Shall I teach you a sentence which is from the treasures of Paradise? ( It is): 'La haula wala quwata illa billah. (There is neither might nor power except with Allah)."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.608]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 608

Narrated Abu Said Al-Khudri:

That the Prophet said, "No Caliph is appointed but has two groups of advisors: One group advises him to do good and urges him to adopt it, and the other group advises him to do bad and urges him to adopt it; and the protected is the one whom Allah protects."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.609]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 609

Narrated Ibn 'Abbas:

I did not see anything so resembling minor sins as what Abu Huraira said from the Prophet, who said, "Allah has written for the son of Adam his inevitable share of adultery whether he is aware of it or not: The adultery of the eye is the looking (at something which is sinful to look at), and the adultery of the tongue is to utter (what it is unlawful to utter), and the innerself wishes and longs for (adultery) and the private parts turn that into reality or refrain from submitting to the temptation."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.610]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 610

Narrated Ibn 'Abbas:

(regarding the Verse) "And We granted the vision (Ascension to the heavens "Miraj") which We showed you (O Muhammad as an actual eye witness) but as a trial for mankind.' (17.60): Allah's Apostle actually saw with his own eyes the vision (all the things which were shown to him) on the night of his Night Journey to Jerusalem (and then to the heavens). The cursed tree which is mentioned in the Qur'an is the tree of Az-Zaqqum.


Bukhari :: Divine Will (Al-Qadar) :: [8.77.611]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 611

Narrated Abu Huraira:

The Prophet said, "Adam and Moses argued with each other. Moses said to Adam. 'O Adam! You are our father who disappointed us and turned us out of Paradise.' Then Adam said to him, 'O Moses! Allah favored you with His talk (talked to you directly) and He wrote (the Torah) for you with His Own Hand. Do you blame me for action which Allah had written in my fate forty years before my creation?' So Adam confuted Moses, Adam confuted Moses," the Prophet added, repeating the Statement three times.


Bukhari :: Divine Will (Al-Qadar) :: [8.77.612]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 612

Narrated Warrad:

(the freed slave of Al-Mughira bin Shu'ba) Muawiya wrote to Mughira. 'Write to me what you heard the Prophet saying after his prayer.' So Al-Mughira dictated to me and said, "I heard the Prophet saying after the prayer, 'None has the right to be worshipped but Allah Alone Who has no partner. O Allah! No-one can withhold what You give, and none can give what You withhold, and the fortune of a man of means is useless before You (i.e., only good deeds are of value)."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.613]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 613

Narrated Abu Huraira:

The Prophet said, "Take refuge with Allah from the difficulties of severe calamities, from having an evil end and a bad fate and from the malicious joy of your enemies."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.614]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 614

Narrated 'Abdullah:

When taking an oath, the Prophet very often used to say, "No, by Him Who turns the hearts."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.615]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 615

Narrated Ibn 'Umar:

The Prophet said to Ibn Saiyad, "I have kept for you a secret." Ibn Saiyad said, "Ad-Dukh." The Prophet said, "Keep quiet, for you cannot go beyond your limits (or you cannot exceed what has been foreordained for you)." On that, 'Umar said (to the Prophet ), "Allow me to chop off his neck!" The Prophet said, "Leave him, for if he is he (i.e., Ad-Dajjal), then you will not be able to overcome him, and if he is not, then you gain no good by killing him."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.616]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 616

Narrated 'Aisha:

I asked Allah's Apostle about the plague. He said, "That was a means of torture which Allah used to send upon whom-so-ever He wished, but He made it a source of mercy for the believers, for anyone who is residing in a town in which this disease is present, and remains there and does not leave that town, but has patience and hopes for Allah's reward, and knows that nothing will befall him except what Allah has written for him, then he will get such reward as that of a martyr."


Bukhari :: Divine Will (Al-Qadar) :: [8.77.617]

Divine Will (Al-Qadar)

Bukhari :: Book 8 :: Volume 77 :: Hadith 617

Narrated Al-Bara' bin 'Azib:

I saw the Prophet on the Day of (the battle of) Al-Khandaq, carrying earth with us and saying, "By Allah, without Allah we would not have been guided, neither would we have fasted, nor would we have prayed. O Allah! Send down Sakina (calmness) upon us and make our feet firm when we meet (the enemy). The pagans have rebelled against us, but if they want to put us in affliction (i.e., fight us) we refuse (to flee)." (See Hadith No. 430, Vol. 5).


Bukhari :: Oaths and Vows :: [8.78.618]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 618

Narrated 'Aisha:

Abu Bakr As-Siddiq had never broken his oaths till Allah revealed the expiation for the oaths. Then he said, "If I take an oath to do something and later on I find something else better than the first one, then I do what is better and make expiation for my oath."


Bukhari :: Oaths and Vows :: [8.78.619]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 619

Narrated 'Abdur-Rahman bin Samura:

The Prophet said, "O 'Abdur-Rahman bin Samura! Do not seek to be a ruler, because if you are given authority for it, then you will be held responsible for it, but if you are given it without asking for it, then you will be helped in it (by Allah): and whenever you take an oath to do something and later you find that something else is better than the first, then do the better one and make expiation for your oath."


Bukhari :: Oaths and Vows :: [8.78.620]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 620

Narrated Abu Musa:

I went to the Prophet along with a group of Al-Ash'ariyin in order to request him to provide us with mounts. He said, "By Allah, I will not provide you with mounts and I haven't got anything to mount you on." Then we stayed there as long as Allah wished us to stay, and then three very nice looking she-camels were brought to him and he made us ride them. When we left, we, or some of us, said, "By Allah, we will not be blessed, as we came to the Prophet asking him for mounts, and he swore that he would not give us any mounts but then he did give us. So let us go back to the Prophet and remind him (of his oath)." When we returned to him (and reminded him of the fact), he said, "I did not give you mounts, but it is Allah Who gave you. By Allah, Allah willing, if I ever take an oath to do something and then I find something else than the first, I will make expiation for my oath and do the thing which is better (or do something which is better and give the expiation for my oath)."


Bukhari :: Oaths and Vows :: [8.78.621]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 621

Narrated Abu Huraira:

The Prophet said, "We (Muslims) are the last in the world, but will be foremost on the Day of Resurrection." Allah's Apostle also said, "By Allah, if anyone of you insists on fulfilling an oath by which he may harm his family, he commits a greater sin in Allah's sight than that of dissolving his oath and making expiation for it."


Bukhari :: Oaths and Vows :: [8.78.622]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 622

Narrated Abu Huraira:

Allah's Apostle said, "Anyone who takes an oath through which his family may be harmed, and insists on keeping it, he surely commits a sin greater (than that of dissolving his oath). He should rather compensate for that oath by making expiation."


Bukhari :: Oaths and Vows :: [8.78.623]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 623

Narrated Ibn 'Umar:

Allah's Apostle sent an army detachment and made Usama bin Zaid its commander. Some people criticized (spoke badly of) Usama's leadership. So Allah's Apostle got up saying, "If you people are criticizing Usama's leadership, you have already criticized the leadership of his father before. But Wa-aimullah (i.e., By Allah), he (i.e. Zaid) deserved the leadership, and he was one of the most beloved persons to me; and now this (his son Usama) is one of the dearest persons to me after him." (See Hadith No. 745, Vol. 5)


Bukhari :: Oaths and Vows :: [8.78.624]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 624

Narrated Ibn 'Umar:

The oath of the Prophet used to be: "No, by Him who turns the hearts."


Bukhari :: Oaths and Vows :: [8.78.625]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 625

Narrated Jabir bin Samura:

The Prophet said, "If Caesar is ruined, there will be no Caesar after him; and if Khosrau is ruined, there will be no Khosrau, after him; and, by Him in Whose Hand my soul is, surely you will spend their treasures in Allah's Cause."


Bukhari :: Oaths and Vows :: [8.78.626]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 626

Narrated Abu Huraira:

Allah's Apostle said, "If Khosrau is ruined, there will be no Khosrau after him; and if Caesar is ruined, there will be no Caesar after him. By Him in Whose Hand Muhammad's soul is, surely you will spend their treasures in Allah's Cause."


Bukhari :: Oaths and Vows :: [8.78.627]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 627

Narrated 'Aisha:

The Prophet said, "O followers of Muhammad! By Allah, if you knew what I know, you would weep much and laugh little."


Bukhari :: Oaths and Vows :: [8.78.628]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 628

Narrated 'Abdullah bin Hisham:

We were with the Prophet and he was holding the hand of 'Umar bin Al-Khattab. 'Umar said to Him, "O Allah's Apostle! You are dearer to me than everything except my own self." The Prophet said, "No, by Him in Whose Hand my soul is, (you will not have complete faith) till I am dearer to you than your own self." Then 'Umar said to him, "However, now, by Allah, you are dearer to me than my own self." The Prophet said, "Now, O 'Umar, (now you are a believer)."


Bukhari :: Oaths and Vows :: [8.78.629]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 629

Narrated Abu Huraira and Zaid bin Khalid:

Two men had a dispute in the presence of Allah's Apostle. One of them said, "O Allah's Apostle! Judge between us according to Allah's Laws." The other who was wiser, said, "Yes, O Allah's Apostle! Judge between us according to Allah's Laws and allow me to speak. The Prophet said, "Speak." He said, "My son was a laborer serving this (person) and he committed illegal sexual intercourse with his wife, The people said that my son is to be stoned to death, but I ransomed him with one-hundred sheep and a slave girl. Then I asked the learned people, who informed me that my son should receive one hundred lashes and will be exiled for one year, and stoning will be the lot for the man's wife." Allah's Apostle said, "Indeed, by Him in Whose Hand my soul is, I will judge between you according to Allah's Laws: As for your sheep and slave girl, they are to be returned to you." Then he scourged his son one hundred lashes and exiled him for one year. Then Unais Al-Aslami was ordered to go to the wife of the second man, and if she confessed (the crime), then stone her to death. She did confess, so he stoned her to death.


Bukhari :: Oaths and Vows :: [8.78.630]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 630

Narrated Abu Bakra:

The Prophet said, "Do you think if the tribes of Aslam, Ghifar, Muzaina and Juhaina are better than the tribes of Tamim, 'Amir bin Sa'sa'a, Ghatfan and Asad, they (the second group) are despairing and losing?" They (the Prophet's companions) said, "Yes, (they are)." He said, "By Him in Whose Hand my soul is, they (the first group) are better than them (the second group)."


Bukhari :: Oaths and Vows :: [8.78.631]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 631

Narrated Abu Humaid As-Sa'idi:

Allah's Apostle employed an employee (to collect Zakat). The employee returned after completing his job and said, "O Allah's Apostle! This (amount of Zakat) is for you, and this (other amount) was given to me as a present." The Prophet said to him, "Why didn't you stay at your father's or mother's house and see if you would be given presents or not?" Then Allah's Apostle got up in the evening after the prayer, and having testified that none has the right to be worshipped but Allah and praised and glorified Allah as He deserved, he said, "Now then ! What about an employee whom we employ and then he comes and says, 'This amount (of Zakat) is for you, and this (amount) was given to me as a present'? Why didn't he stay at the house of his father and mother to see if he would be given presents or not? By Him in Whose Hand Muhammad's soul is, none of you will steal anything of it (i.e. Zakat) but will bring it by carrying it over his neck on the Day of Resurrection. If it has been a camel, he will bring it (over his neck) while it will be grunting, and if it has been a cow, he will bring it (over his neck), while it will be mooing; and if it has been a sheep, he will bring it (over his neck) while it will be bleeding." The Prophet added, "I have preached you (Allah's Message)." Abu Humaid said, "Then Allah's Apostle raised his hands so high that we saw the whiteness of his armpits."


Bukhari :: Oaths and Vows :: [8.78.632]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 632

Narrated Abu Huraira:

Abu-l-Qasim (the Prophet) said, "By Him in Whose Hand Muhammad's soul is, if you know that which I know, you would weep much and laugh little."


Bukhari :: Oaths and Vows :: [8.78.633]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 633

Narrated Abu Dhar:

I reached him (the Prophet ) while in the shade of the Ka'ba; he was saying, "They are the losers, by the Lord of the Ka'ba! They are the losers, by the Lord of the Ka'ba!" I said (to myself ), "What is wrong with me? Is anything improper detected in me? What is wrong with me? Then I sat beside him and he kept on saying his statement. I could not remain quiet, and Allah knows in what sorrowful state I was at that time. So I said, ' Who are they (the losers)? Let My father and mother be sacrificed for you, O Allah's Apostle!" He said, "They are the wealthy people, except the one who does like this and like this and like this (i.e., spends of his wealth in Allah's Cause)."


Bukhari :: Oaths and Vows :: [8.78.634]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 634

Narrated Abu Huraira:

Allah's Apostle said, "(The Prophet) Solomon once said, 'Tonight I will sleep with ninety women, each of whom will bring forth a (would-be) cavalier who will fight in Allah's Cause." On this, his companion said to him, "Say: Allah willing!" But he did not say Allah willing. Solomon then slept with all the women, but none of them became pregnant but one woman who later delivered a half-man. By Him in Whose Hand Muhammad's soul is, if he (Solomon) had said, 'Allah willing' (all his wives would have brought forth boys) and they would have fought in Allah's Cause as cavaliers. "


Bukhari :: Oaths and Vows :: [8.78.635]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 635

Narrated Al-Bara 'bin 'Azib:

A piece of silken cloth was given to the Prophet as a present and the people handed it over amongst themselves and were astonished at its beauty and softness. Allah's Apostle said, "Are you astonished at it?" They said, "Yes, O Allah's Apostle!" He said, "By Him in Whose Hand my soul is, the handkerchiefs of Sa'd in Paradise are better than it."


Bukhari :: Oaths and Vows :: [8.78.636]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 636

Narrated 'Aisha:

Hind bint 'Utba bin Rabi 'a said, "O Allah 's Apostle! (Before I embraced Islam), there was no family on the surface of the earth, I wish to have degraded more than I did your family. But today there is no family whom I wish to have honored more than I did yours." Allah's Apostle said, "I thought similarly, by Him in Whose Hand Muhammad's soul is!" Hind said, "O Allah's Apostle! (My husband) Abu Sufyan is a miser. Is it sinful of me to feed my children from his property?" The Prophet said, "No, unless you take it for your needs what is just and reasonable."


Bukhari :: Oaths and Vows :: [8.78.637]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 637

Narrated Abdullah bin Masud:

While Allah's Apostle was sitting, reclining his back against a Yemenite leather tent he said to his companions, "Will you be pleased to be one-fourth of the people of Paradise?" They said, 'Yes.' He said "Won't you be pleased to be one-third of the people of Paradise" They said, "Yes." He said, "By Him in Whose Hand Muhammad's soul is, I hope that you will be one-half of the people of Paradise."


Bukhari :: Oaths and Vows :: [8.78.638]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 638

Narrated Abu Sa'id Al-Khudri:

A man heard another man reciting: Surat-ul-Ikhlas (The Unity) 'Say: He is Allah, the One (112) and he was repeating it. The next morning he came to Allah's Apostle and mentioned the whole story to him as if he regarded the recitation of that Sura as insufficient On that, Allah's Apostle said, "By Him in Whose Hand my soul is! That (Sura No. 112) equals one-third of the Qur'an."


Bukhari :: Oaths and Vows :: [8.78.639]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 639

Narrated Anas bin Malik:

I heard the Prophet saying, "Perform the bowing and the prostration properly (with peace of mind), for, by Him in Whose Hand my soul is, I see you from behind my back when you bow and when you prostrate."


Bukhari :: Oaths and Vows :: [8.78.640]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 640

Narrated Anas bin Malik:

An Ansari woman came to the Prophet in the company of her children, and the Prophet said to her, "By Him in Whose Hand my soul is, you are the most beloved people to me!" And he repeated the statement thrice.


Bukhari :: Oaths and Vows :: [8.78.641]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 641

Narrated Ibn 'Umar:

Allah's Apostle met 'Umar bin Al-Khattab while the latter was going with a group of camel-riders, and he was swearing by his father. The Prophet said, "Lo! Allah forbids you to swear by your fathers, so whoever has to take an oath, he should swear by Allah or keep quiet."


Bukhari :: Oaths and Vows :: [8.78.642]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 642

Narrated Ibn 'Umar:


Bukhari :: Oaths and Vows :: [8.78.643]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 643

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Do not swear by your fathers."


Bukhari :: Oaths and Vows :: [8.78.644]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 644

Narrated Zahdam:

There was a relation of love and brotherhood between this tribe of Jarm and Al-Ash'ariyin. Once we were with Abu Musa Al-Ash'ari, and then a meal containing chicken was brought to Abu Musa, and there was present, a man from the tribe of Taimillah who was of red complexion as if he were from non-Arab freed slaves. Abu Musa invited him to the meal. He said, "I have seen chickens eating dirty things, so I deemed it filthy and took an oath that I would never eat chicken." On that, Abu Musa said, "Get up, I will narrate to you about that. Once a group of the Ash'ariyin and I went to Allah's Apostle and asked him to provide us with mounts; he said, 'By Allah, I will never give you any mounts nor do I have anything to mount you on.' Then a few camels of war booty were brought to Allah's Apostle , and he asked about us, saying, 'Where are the Ash-'ariyin?' He then ordered five nice camels to be given to us, and when we had departed, we said, 'What have we done? Allah's Apostle had taken the oath not to give us any mounts, and that he had nothing to mount us on, and later he gave us that we might ride? Did we take advantage of the fact that Allah's Apostle had forgotten his oath? By Allah, we will never succeed.' So we went back to him and said to him, 'We came to you to give us mounts, and you took an oath that you would not give us any mounts and that you had nothing to mount us on.' On that he said, 'I did not provide you with mounts, but Allah did. By Allah, if I take an oath to do something, and then find something else better than it, I do that which is better and make expiation for the dissolution of the oath.' "


Bukhari :: Oaths and Vows :: [8.78.645]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 645

Narrated Abu Huraira:

The Prophet said, "Whoever swears saying in his oath. 'By Al-Lat and Al'Uzza,' should say, 'None has the right to be worshipped but Allah; and whoever says to his friend, 'Come, let me gamble with you,' should give something in charity."


Bukhari :: Oaths and Vows :: [8.78.646]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 646

Narrated Ibn 'Umar:

Allah's Apostle had a gold ring made for himself, and he used to wear it with the stone towards the inner part of his hand. Consequently, the people had similar rings made for themselves. Afterwards the Prophet; sat on the pulpit and took it off, saying, "I used to wear this ring and keep its stone towards the palm of my hand." He then threw it away and said, "By Allah, I will never wear it." Therefore all the people threw away their rings as well.


Bukhari :: Oaths and Vows :: [8.78.647]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 647

Narrated Thabit bin Ad-Dahhak:

The Prophet said, "Whoever swears by a religion other than Islam, is, as he says; and whoever commits suicide with something, will be punished with the same thing in the (Hell) Fire; and cursing a believer is like murdering him; and whoever accuses a believer of disbelief, then it is as if he had killed him."


Bukhari :: Oaths and Vows :: [8.78.648]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 648

Narrated Al-Bara:

The Prophet ordered us to help others to fulfill the oaths.


Bukhari :: Oaths and Vows :: [8.78.649]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 649

Narrated Usama:

Once a daughter of Allah's Apostle sent a message to Allah's Apostle while Usama, Sa'd, and my father or Ubai were (sitting there) with him. She said, (in the message); My child is going to die; please come to us." Allah's Apostle returned the messenger and told him to convey his greetings to her, and say, "Whatever Allah takes, is for Him and whatever He gives is for Him, and everything with Him has a limited fixed term (in this world): so she should be patient and hope for Allah's reward." Then she again sent for him swearing that he should come; so The Prophet got up, and so did we. When he sat there (at the house of his daughter), the child was brought to him, and he took him into his lap while the child's breath was disturbed in his chest. The eyes of Allah's Apostle started shedding tears. Sa'd said, "What is this, O Allah's Apostle?" The Prophet said, "This is the mercy which Allah has lodged in the hearts of whoever He wants of His slaves, and verily Allah is merciful only to those of His slaves who are merciful (to others).'


Bukhari :: Oaths and Vows :: [8.78.650]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 650

Narrated Abu Huraira:

Allah's Apostle said, "Any Muslim who has lost three of his children will not be touched by the Fire except that which will render Allah's oath fulfilled."


Bukhari :: Oaths and Vows :: [8.78.651]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 651

Narrated Haritha bin Wahb:

I heard the Prophet saying, "Shall I tell you of the people of Paradise? They comprise every poor humble person, and if he swears by Allah to do something, Allah will fulfill it; while the people of the fire comprise every violent, cruel arrogant person."


Bukhari :: Oaths and Vows :: [8.78.652]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 652

Narrated 'Abdullah:

The Prophet was asked, "Who are the best people?" He replied: The people of my generation, and then those who will follow (come after) them, and then those who will come after the later; after that there will come some people whose witness will precede their oaths and their oaths will go ahead of their witness." Ibrahim (a sub-narrator) said, "When we were young, our elder friends used to prohibit us from taking oaths by saying, 'I bear witness swearing by Allah, or by Allah's Covenant."'


Bukhari :: Oaths and Vows :: [8.78.653]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 653

Narrated 'Abdullah:

The Prophet said, "Whoever swears falsely in order to grab the property of a Muslim (or of his brother), Allah will be angry with him when he meets Him." Allah then revealed in confirmation of the above statement:--'Verily those who purchase a small gain at the cost of Allah's Covenant and their own oaths.' (3.77) Al-Ash'ath said, "This Verse was revealed regarding me and a companion of mine when we had a dispute about a well."


Bukhari :: Oaths and Vows :: [8.78.654]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 654

Narrated Anas bin Malik:

The Prophet said, "The Hell Fire will keep on saying: 'Are there anymore (people to come)?' Till the Lord of Power and Honor will put His Foot over it and then it will say, 'Qat! Qat! (sufficient! sufficient!) by Your Power and Honor. And its various sides will come close to each other (i.e., it will contract). "


Bukhari :: Oaths and Vows :: [8.78.655]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 655

Narrated Az-Zuhri:

I heard 'Urwa bin Az-Zubair, Said bin Al-Musaiyab, 'Alqama bin Waqqas and 'Ubaidullah bin 'Abdullah narrating from 'Aisha, the wife of the Prophet, the story about the liars who said what they said about her and how Allah revealed her innocence afterwards. Each one of the above four narrators narrated to me a portion of her narration. (It was said in it), "The Prophet stood up, saying, 'Is there anyone who can relieve me from 'Abdullah bin Ubai?' On that, Usaid bin Hudair got up and said to Sa'd bin 'Ubada, La'amrullahi (By the Eternity of Allah), we will kill him!' "


Bukhari :: Oaths and Vows :: [8.78.656]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 656

Narrated 'Aisha:

regarding: 'Allah will not call you to account for that which is unintentional in your oaths...' (2.225) This Verse was revealed concerning such oath formulas as: 'No, by Allah!' and 'Yes, by Allah!' something against his oath due to forgetfulness should he make expiation?). And the Statement of Allah: 'And there is no blame on you if you make a mistake therein.' (33.5) And Allah said:-- '(Moses said to Khadir): Call me not to account for what I forgot.' (18.73)


Bukhari :: Oaths and Vows :: [8.78.657]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 657

Narrated Abu Huraira: The Prophet said, "Allah forgives my followers those (evil deeds) the


Bukhari :: Oaths and Vows :: [8.78.658]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 658

Narrated 'Abdullah bin 'Amr bin Al-As:

While the Prophet was delivering a sermon on the Day of Nahr (i.e., 10th Dhul-Hijja-Day of slaughtering the sacrifice), a man got up saying, "I thought, O Allah's Apostle, such-and-such a thing was to be done before such-and-such a thing." Another man got up, saying, "O Allah's Apostle! As regards these three (acts of Hajj), thought so-and-so." The Prophet said, "Do, and there is no harm," concerning all those matters on that day. And so, on that day, whatever question he was asked, he said, "Do it, do it, and there is no harm therein."


Bukhari :: Oaths and Vows :: [8.78.659]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 659

Narrated Ibn 'Abbas:

A man said to the Prophet (while he was delivering a sermon on the Day of Nahr), "I have performed the Tawaf round the Ka'ba before the Rami (throwing pebbles) at the Jamra." The Prophet said, "There is no harm (therein)." Another man said, "I had my head shaved before slaughtering (the sacrifice)." The Prophet said, "There is no harm." A third said, "I have slaughtered (the sacrifice) before the Rami (throwing pebbles) at the Jamra." The Prophet said, "There is no harm."


Bukhari :: Oaths and Vows :: [8.78.660]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 660

Narrated Abu Huraira:

A man entered the mosque and started praying while Allah's Apostle was sitting somewhere in the mosque. Then (after finishing the prayer) the man came to the Prophet and greeted him. The Prophet said to him, "Go back and pray, for you have not prayed. The man went back, and having prayed, he came and greeted the Prophet. The Prophet after returning his greetings said, "Go back and pray, for you did not pray." On the third time the man said, "(O Allah's Apostle!) teach me (how to pray)." The Prophet said, "When you get up for the prayer, perform the ablution properly and then face the Qibla and say Takbir (Allahu Akbar), and then recite of what you know of the Quran, and then bow, and remain in this state till you feel at rest in bowing, and then raise your head and stand straight; and then prostrate till you feel at rest in prostration, and then sit up till you feel at rest while sitting; and then prostrate again till you feel at rest in prostration; and then get up and stand straight, and do all this in all your prayers."


Bukhari :: Oaths and Vows :: [8.78.661]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 661

Narrated 'Aisha:

When the pagans were defeated during the (first stage) of the battle of Uhud, Satan shouted, "O Allah's slaves! Beware of what is behind you!" So the front files of the Muslims attacked their own back files. Hudhaifa bin Al-Yaman looked and on seeing his father he shouted: "My father! My father!" By Allah! The people did not stop till they killed his father. Hudhaifa then said, "May Allah forgive you." 'Urwa (the sub-narrator) added, "Hudhaifa continued asking Allah forgiveness for the killers of his father till he met Allah (till he died)."


Bukhari :: Oaths and Vows :: [8.78.662]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 662

Narrated Abu Huraira:

The Prophet said, "If somebody eats something forgetfully while he is fasting, then he should complete his fast, for Allah has made him eat and drink."


Bukhari :: Oaths and Vows :: [8.78.663]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 663

Narrated 'Abdullah bin Buhaina:

Once Allah's Apostle led us in prayer, and after finishing the first two Rakat, got up (instead of sitting for At-Tahiyyat) and then carried on with the prayer. When he had finished his prayer, the people were waiting for him to say Taslim, but before saying Tasiim, he said Takbir and prostrated; then he raised his head, and saying Takbir, he prostrated (SAHU) and then raised his head and finished his prayer with Taslim.


Bukhari :: Oaths and Vows :: [8.78.664]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 664

Narrated Ibn Mas'ud:

that Allah's Prophet led them in the Zuhr prayer and he offered either more or less Rakat, and it was said to him, "O Allah's Apostle ! Has the prayer been reduced, or have you forgotten?" He asked, "What is that?" They said, "You have prayed so many Rak'at." So he performed with them two more prostrations and said, "These two prostrations are to be performed by the person who does not know whether he has prayed more or less (Rakat) in which case he should seek to follow what is right. And then complete the rest (of the prayer) and perform two extra prostrations."


Bukhari :: Oaths and Vows :: [8.78.665]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 665

Narrated Ubai bin Ka'b:

that he heard Allah's Apostle saying, "(Moses) said, 'Call me not to account for what I forget and be not hard upon me for my affair (with you)' (18.73) the first excuse of Moses was his forgetfulness."

Narrated Al-Bara bin Azib that once he had a guest, so he told his family (on the Day of Id-ul-Adha) that they should slaughter the animal for sacrifice before he returned from the ('Id) prayer in order that their guest could take his meal. So his family slaughtered (the animal ) before the prayer. Then they mentioned that event to the Prophet who ordered Al-Bara to slaughter another sacrifice. Al-Bara' said to the Prophet , "I have a young milch she-goat which is better than two sheep for slaughtering." (The sub-narrator, Ibn 'Aun used to say, "I don't know whether the permission (to slaughter a she-goat as a sacrifice) was especially given to Al-Bara' or if it was in general for all the Muslims.") (See Hadith No. 99, Vol. 2.)


Bukhari :: Oaths and Vows :: [8.78.666]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 666

Narrated Jundub:

I witnessed the Prophet offering the 'Id prayer (and after finishing it) he delivered a sermon and said, "Whoever has slaughtered his sacrifice (before the prayer) should make up for it (i.e. slaughter another animal) and whoever has not slaughtered his sacrifice yet, should slaughter it by mentioning Allah's Name over it."


Bukhari :: Oaths and Vows :: [8.78.667]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 667

Narrated 'Abdullah bin 'Amr:

The Prophet said, "The biggest sins are: To join others in worship with Allah; to be undutiful to one's parents; to kill somebody unlawfully; and to take an oath Al-Ghamus.


Bukhari :: Oaths and Vows :: [8.78.668]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 668

Narrated 'Abdullah:

Allah's Apostle said, "If somebody is ordered (by the ruler or the judge) to take an oath, and he takes a false oath in order to grab the property of a Muslim, then he will incur Allah's Wrath when he will meet Him." And Allah revealed in its confirmation: 'Verily! Those who purchase a small gain at the cost of Allah's covenants and their own oaths.' (3.77) (The sub-narrator added:) Al-Ash'ath bin Qais entered, saying, "What did Abu 'Abdur-Rahman narrate to you?" They said, "So-and-so," Al-Ash'ath said, "This verse was revealed in my connection. I had a well on the land of my cousin (and we had a dispute about it). I reported him to Allah 's Apostle who said (to me). "You should give evidence (i.e. witness) otherwise the oath of your opponent will render your claim invalid." I said, "Then he (my opponent) will take the oath, O Allah's Apostle." Allah's Apostle said, "Whoever is ordered (by the ruler or the judge) to give an oath, and he takes a false oath in order to grab the property of a Muslim, then he will incur Allah's Wrath when he meets Him on the Day of Resurrection."


Bukhari :: Oaths and Vows :: [8.78.669]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 669

Narrated Abu Musa:

My companions sent me to the Prophet to ask him for some mounts. He said, "By Allah! I will not mount you on anything!" When I met him, he was in an angry mood, but when I met him (again), he said, "Tell your companions that Allah or Allah's Apostle will provide you with mounts."


Bukhari :: Oaths and Vows :: [8.78.670]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 670

Narrated Az-Zuhri:

I heard 'Urwa bin Az-Zubair, Said bin Al-Musaiyab, 'Alqama bin Waqqas and 'Ubaidullah bin 'Abdullah bin 'Uqba relating from 'Aisha, the wife of the Prophet the narration of the people (i.e. the liars) who spread the slander against her and they said what they said, and how Allah revealed her innocence. Each of them related to me a portion of that narration. (They said that 'Aisha said), ''Then Allah revealed the ten Verses starting with:--'Verily! Those who spread the slander..' (24.11-21)

All these verses were in proof of my innocence. Abu Bakr As-Siddiq who used to provide for Mistah some financial aid because of his relation to him, said, "By Allah, I will never give anything (in charity) to Mistah, after what he has said about 'Aisha" Then Allah revealed:-- 'And let not those among you who are good and are wealthy swear not to give (any sort of help) to their kins men....' (24.22) On that, Abu Bakr said, "Yes, by Allah, I like that Allah should forgive me." and then resumed giving Mistah the aid he used to give him and said, "By Allah! I will never withhold it from him."


Bukhari :: Oaths and Vows :: [8.78.671]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 671

Narrated Abu Musa Al-Ash'ari:

I went along with some men from the Ash-ariyin to Allah's Apostle and it happened that I met him while he was in an angry mood. We asked him to provide us with mounts, but he swore that he would not give us any. Later on he said, "By Allah, Allah willing, if ever I take an oath (to do something) and later on I find something else better than the first, then I do the better one and give expiation for the dissolution of my oath."


Bukhari :: Oaths and Vows :: [8.78.672]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 672

Narrated Al-Musaiyab:

When the death of Abu Talib approached, Allah's Apostle came to him and said, "Say: La ilaha illallah, a word with which I will be able to defend you before Allah."


Bukhari :: Oaths and Vows :: [8.78.673]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 673

Narrated Abu Huraira:

Allah's Apostle said, "(Following are) two words (sentences or utterances that are very easy for the tongue to say, and very heavy in the balance (of reward,) and the must beloved to the Gracious Almighty (And they are): Subhan Allah wa bi-hamdihi; Subhan Allahi-l-'Azim,"


Bukhari :: Oaths and Vows :: [8.78.674]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 674

Narrated 'Abdullah: Allah's Apostle said a sentence and I said another. He said, "Whoever dies while he is setting up rivals along with Allah (i.e. worshipping others along with Allah) shall be admitted into the (Hell) Fire." And I said the other: "W


Bukhari :: Oaths and Vows :: [8.78.675]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 675

Narrated Anas:

Allah's Apostle took an oath for abstention from h is wives (for one month), and during those days he had a sprain in his foot. He stayed in a Mashrubah (an upper room) for twenty-nine nights and then came down. Then the people said, "O Allah's Apostle! You took an oath for abstention (from your wives) for one month." On that he said, A month can be of twenty-nine days '


Bukhari :: Oaths and Vows :: [8.78.676]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 676

Narrated Abu Hazim:

Sahl bin Sa'd said, "Abu Usaid, the companion of the Prophet, got married, so he invited the Prophet to his wedding party, and the bride herself served them. Sahl said to the People, 'Do you know what drink she served him with? She infused some dates in a pot at night and the next morning she served him with the infusion."


Bukhari :: Oaths and Vows :: [8.78.677]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 677

Narrated Sauda:

(the wife of the Prophet) One of our sheep died and we tanned its skin and kept on infusing dates in it till it was a worn out water skin.


Bukhari :: Oaths and Vows :: [8.78.678]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 678

Narrated 'Aisha:

The family of (the Prophet) Muhammad never ate wheat-bread with meat for three consecutive days to their fill, till he met Allah.


Bukhari :: Oaths and Vows :: [8.78.679]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 679

Narrated Anas bin Malik:

Abu Talha said to Um Sulaim, "I heard the voice of Allah's Apostle rather weak, and I knew that it was because of hunger. Have you anything (to present to the Prophet)?" She said, "Yes." Then she took out a few loaves of barley bread and took a veil of hers and wrapped the bread with a part of it and sent me to Allah's Apostle. I went and found Allah's Apostle sitting in the mosque with some people. I stood up before him. Allah's Apostle said to me, "Has Abu Talha sent you?" I said, ' Yes. Then Allah's Apostle said to those who were with him. "Get up and proceed." I went ahead of them (as their forerunner) and came to Abu Talha and informed him about it. Abu Talha said, "O Um Sulaim! Allah's Apostle has come and we have no food to feed them." Um Sulaim said, "Allah and His Apostle know best." So Abu Talha went out (to receive them) till he met Allah's Apostle.

Allah's Apostle came in company with Abu Talha and they entered the house. Allah's Apostle said, "O Um Sulaim! Bring whatever you have." So she brought that (barley) bread and Allah's Apostle ordered that bread to be broken into small pieces, and then Um Sulaim poured over it some butter from a leather butter container, and then Allah's Apostle said what Allah wanted him to say, (i.e. blessing the food). Allah's Apostle then said, "Admit ten men." Abu Talha admitted them and they ate to their fill and went out. He again said, "Admit ten men." He admitted them, and in this way all the people ate to their fill, and they were seventy or eighty men."


Bukhari :: Oaths and Vows :: [8.78.680]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 680

Narrated 'Umar bin Al-Khattab:

I heard Allah's Apostle saying, "The (reward of) deeds, depend upon the intentions and every person will get the reward according to what he has intended. So whoever emigrated for the sake of Allah and His Apostle, then his emigration will be considered to be for Allah and His Apostle, and whoever emigrated for the sake of worldly gain or for a woman to marry, then his emigration will be considered to be for what he emigrated for."


Bukhari :: Oaths and Vows :: [8.78.681]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 681

Narrated Ka'b bin Malik:

In the last part of his narration about the three who remained behind (from the battle of Tabuk). (I said) "As a proof of my true repentance (for not joining the Holy battle of Tabuk), I shall give up all my property for the sake of Allah and His Apostle (as an expiation for that sin)." The Prophet said (to me), "Keep some of your wealth, for that is better for you."


Bukhari :: Oaths and Vows :: [8.78.682]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 682

Narrated 'Aisha:

The Prophet used to stay (for a period) in the house of Zainab bint Jahsh (one of the wives of the Prophet ) and he used to drink honey in her house. Hafsa and I decided that when the Prophet entered upon either of us, she would say, "I smell in you the bad smell of Maghafir (a bad smelling raisin). Have you eaten Maghafir?" When he entered upon one of us, she said that to him. He replied (to her), "No, but I have drunk honey in the house of Zainab bint Jahsh, and I will never drink it again." Then the following verse was revealed: 'O Prophet ! Why do you ban (for you) that which Allah has made lawful for you?. ..(up to) If you two (wives of the Prophet turn in repentance to Allah.' (66.1-4) The two were 'Aisha and Hafsa And also the Statement of Allah: 'And (Remember) when the Prophet disclosed a matter in confidence to one of his wives!' (66.3) i.e., his saying, "But I have drunk honey." Hisham said: It also meant his saying, "I will not drink anymore, and I have taken an oath, so do not inform anybody of that '


Bukhari :: Oaths and Vows :: [8.78.683]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 683

Narrated Sa'id bin Al-Harith:

that he heard Ibn 'Umar saying, "Weren't people forbidden to make vows?" The Prophet said, 'A vow neither hastens nor delays anything, but by the making of vows, some of the wealth of a miser is taken out."


Bukhari :: Oaths and Vows :: [8.78.684]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 684

Narrated 'Abdullah bin 'Umar:

The Prophet forbade the making of vows and said, "It (a vow) does not prevent anything (that has to take place), but the property of a miser is spent (taken out) with it."


Bukhari :: Oaths and Vows :: [8.78.685]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 685

Narrated Abu Huraira:

The Prophet said, "Allah says, 'The vow, does not bring about for the son of Adam anything I have not decreed for him, but his vow may coincide with what has been decided for him, and by this way I cause a miser to spend of his wealth. So he gives Me (spends in charity) for the fulfillment of what has been decreed for him what he would not give Me before but for his vow."


Bukhari :: Oaths and Vows :: [8.78.686]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 686

Narrated Zahdam bin Mudarrab:

'Imran bin Hussain said, "The Prophet said, 'The best of you (people) are my generation, and the second best will be those who will follow them, and then those who will follow the second generation." Imran added, "I do not remember whether he mentioned two or three (generations) after his generation. He added, 'Then will come some people who will make vows but will not fulfill them; and they will be dishonest and will not be trustworthy, and they will give their witness without being asked to give their witness, and fatness will appear among them.' "


Bukhari :: Oaths and Vows :: [8.78.687]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 687

Narrated 'Aisha:

The Prophet said, "Whoever vows that he will be obedient to Allah, should remain obedient to Him; and whoever made a vow that he will disobey Allah, should not disobey Him."


Bukhari :: Oaths and Vows :: [8.78.688]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 688

Narrated Ibn 'Umar:

'Umar said "O Allah's Apostle! I vowed to perform I'tikaf for one night in Al-Masjid-al-Haram, during the Pre-Islamic Period of ignorance (before embracing Islam). "The Prophet said, "Fulfill your vow." Ibn 'Umar said to the lady, "Pray on her behalf." Ibn 'Abbas said the same.


Bukhari :: Oaths and Vows :: [8.78.689]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 689

Narrated Sa'id bin 'Ubada Al-Ansari:

that he consulted the Prophet about a vow that had been made by his mother who died without fulfilling it. The Prophet gave his verdict that he should fulfill it on her behalf. The verdict became Sunna (i.e. the Prophet's tradition).


Bukhari :: Oaths and Vows :: [8.78.690]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 690

Narrated Ibn 'Abbas:

A man came to the Prophet and said to him, "My sister vowed to perform the Hajj, but she died (before fulfilling it)." The Prophet said, "Would you not have paid her debts if she had any?" The man said, "Yes." The Prophet said, "So pay Allah's Rights, as He is more entitled to receive His rights."


Bukhari :: Oaths and Vows :: [8.78.691]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 691

Narrated 'Aisha:

The Prophet said, "Whoever vowed to be obedient to Allah, must be obedient to Him; and whoever vowed to be disobedient to Allah, should not be disobedient to Him."


Bukhari :: Oaths and Vows :: [8.78.692]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 692

Narrated Anas:

The Prophet said, "Allah is not in need of this man) torturing himself," when he saw the man walking between his two sons (who were supporting him).


Bukhari :: Oaths and Vows :: [8.78.693]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 693

Narrated Ibn 'Abbas:

The Prophet saw a man performing Tawaf around the Ka'ba, tied with a rope or something else (while another person was holding him). The Prophet cut that rope off.


Bukhari :: Oaths and Vows :: [8.78.694]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 694

Narrated Ibn 'Abbas:

While performing the Tawaf around the Ka'ba, the Prophet passed by a person leading another person by a hair-rope nose-ring in his nose. The Prophet cut the hair-rope nose-ring off with his hand and ordered the man to lead him by the hand.


Bukhari :: Oaths and Vows :: [8.78.695]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 695

Narrated Ibn 'Abbas:

While the Prophet was delivering a sermon, he saw a man standing, so he asked about that man. They (the people) said, "It is Abu Israil who has vowed that he will stand and never sit down, and he will never come in the shade, nor speak to anybody, and will fast.'' The Prophet said, "Order him to speak and let him come in the shade, and make him sit down, but let him complete his fast."


Bukhari :: Oaths and Vows :: [8.78.696]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 696

Narrated 'Abdullah bin 'Umar:

that he was asked about a man who had vowed that he would fast all the days of his life then the day of 'Id al Adha or 'Id-al-Fitr came. 'Abdullah bin 'Umar said: You have indeed a good example in Allah's Apostle. He did not fast on the day of 'Id al Adha or the day of 'Id-al-Fitr, and we do not intend fasting on these two days.


Bukhari :: Oaths and Vows :: [8.78.697]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 697

Narrated Ziyad bin Jubair:

I was with Ibn 'Umar when a man asked him, "I have vowed to fast every Tuesday or Wednesday throughout my life and if the day of my fasting coincided with the day of Nahr (the first day of 'Id-al-Adha), (What shall I do?)" Ibn 'Umar said, "Allah has ordered the vows to be fulfilled, and we are forbidden to fast on the day of Nahr." The man repeated his question and Ibn 'Umar repeated his former answer, adding nothing more.


Bukhari :: Oaths and Vows :: [8.78.698]

Oaths and Vows

Bukhari :: Book 8 :: Volume 78 :: Hadith 698

Narrated Abu Huraira:

We went out in the company of Allah's Apostle on the day of (the battle of) Khaibar, and we did not get any gold or silver as war booty, but we got property in the form of things and clothes. Then a man called Rifa'a bin Zaid, from the tribe of Bani Ad-Dubaib, presented a slave named Mid'am to Allah's Apostle. Allah's Apostle headed towards the valley of Al-Qura, and when he was in the valley of Al-Qura an arrow was thrown by an unidentified person, struck and killed Mid'am who was making a she-camel of Allah's Apostle kneel down. The people said, "Congratulations to him (the slave) for gaining Paradise." Allah's Apostle said, "No! By Him in Whose Hand my soul is, for the sheet which he stole from the war booty before its distribution on the day of Khaibar, is now burning over him." When the people heard that, a man brought one or two Shiraks (leather straps of shoes) to the Prophet. The Prophet said, "A Shirak of fire, or two Shiraks of fire."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.699]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 699

Narrated Ka'b bin 'Ujra:

I came to the Prophet and he said to me, "Come near." So I went near to him and he said, "Are your lice troubling you?" I replied, "Yes." He said, "(Shave your head and) make expiation in the form of fasting, Sadaqa (giving in charity), or offering a sacrifice." (The sub-narrator) Aiyub said, "Fasting should be for three days, and the Nusuk (sacrifice) is to be a sheep, and the Sadaqa is to be given to six poor persons."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.700]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 700

Narrated Abu Huraira:

A man came to the Prophet and said, "I am ruined!" The Prophet said, "What is the matter with you?" He said, "I had sexual relation with my wife (while I was fasting) in Ramadan." The Prophet said, "Have you got enough to manumit a slave?" He said, "No." The Prophet said, "Can you fast for two successive months?" The man said, "No." The Prophet said, "Can you feed sixty poor persons?" The man said, "No." Then the Prophet said to him, "Sit down," and he sat down. Afterwards an 'Irq, i.e., a big basket containing dates was brought to the Prophet and the Prophet said to him, "Take this and give it in charity." The man said, "To poorer people than we?" On that, the Prophet smiled till his premolar teeth became visible, and then told him, "Feed your family with it." (See Hadith No. 157, Vol 3)


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.701]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 701

Narrated Abu Huraira:

A man came to Allah's Apostle and said, "I am ruined!" The Prophet said to him, "What is the matter?" He said, "I have done a sexual relation with my wife (while fasting) in Ramadan." The Prophet said to him?" "Can you afford to manumit a slave?" He said, "No." The Prophet said, "Can you fast for two successive months?" He said, "No." The Prophet said, "Can you feed sixty poor persons?" He said, "No." Then an Ansari man came with an Irq (a big basket full of dates). The Prophet said (to the man), "Take this (basket) and give it in charity." That man said, "To poorer people than we, O Allah's Apostle? By Him Who has sent you with the Truth! There is no house in between the two mountains (of the city of Medina) poorer than we." So the Prophet said (to him), "Go and feed it to your family."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.702]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 702

Narrated Abu Huraira :

A man came to the Prophets and said, "I am ruined!" The Prophet said, "What is the matter with you?" He said, "I have done a sexual relation with my wife (while fasting) in Ramadan" The Prophet said to him, "Can you afford to manumit a slave?" He said, "No." The Prophet said, "Can you fast for two successive months?" He said, "No." The Prophet said, "Can you feed sixty poor persons?" He said, "I have nothing." Later on an Irq (big basket) containing dates was given to the Prophet, and the Prophet said (to him), "Take this basket and give it in charity." The man said, "To poorer people than we? Indeed, there is nobody between its (i.e., Medina's) two mountains who is poorer than we." The Prophet then said, "Take it and feed your family with it."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.703]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 703

Narrated Al-Ju'aid bin Abdur-Rahman:

As-Sa'ib bin Yazid said, "The Sa' at the time of the Prophet was equal to one Mudd plus one-third of a Mudd of your time, and then it was increased in the time of Caliph 'Umar bin 'Abdul Aziz."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.704]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 704

Narrated Nafi:

Ibn Umar used to give the Zakat of Ramadan (Zakat-al-Fitr) according to the Mudd of the Prophet, the first Mudd, and he also used to give things for expiation for oaths according to the Mudd of the Prophet. Abu Qutaiba said, "Malik said to us, 'Our Mudd (i.e., of Medina) is better than yours and we do not see any superiority except in the Mudd of the Prophet!' Malik further said, to me, 'If a ruler came to you and fixed a Mudd smaller than the one of the Prophet, by what Mudd would you measure what you give (for expiation or Zakat-al-Fitr?' I replied, 'We would give it according to the Mudd of the Prophet' On that, Malik said, 'Then, don't you see that we have to revert to the Mudd of the Prophet ultimately?'"


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.705]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 705

Narrated Anas bin Malik:

Allah's Apostle said, "O Allah! Bestow Your Blessings on their measures, Sa' and Mudd (i.e., of the people of Medina) "


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.706]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 706

Narrated Abu Huraira:

The Prophet said, "If somebody manumits a Muslim slave, Allah will save from the Fire every part of his body for freeing the corresponding parts of the slave's body, even his private parts will be saved from the Fire) because of freeing the slave's private parts."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.707]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 707

Narrated 'Amr:

Jabir said: An Ansari man made his slave a Mudabbar and he had no other property than him. When the Prophet heard of that, he said (to his companions), "Who wants to buy him (i.e., the slave) for me?" Nu'aim bin An-Nahham bought him for eight hundred Dirhams. I heard Jabir saying, "That was a coptic slave who died in the same year."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.708]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 708

Narrated 'Aisha:

that she intended to buy Barira (a slave girl) and her masters stipulated that they would have her Wala'. When 'Aisha mentioned that to the Prophet ; he said, "Buy her, for the Wala' is for the one who manumits."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.709]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 709

Narrated Abu Musa Al-Ash'ari:

I went to Allah's Apostle along with a group of people from (the tribe of) Al-Ash'ari, asking for mounts. The Prophet said, "By Allah, I will not give you anything to ride, and I have nothing to mount you on." We stayed there as long as Allah wished, and after that, some camels were brought to the Prophet and he ordered that we be given three camels. When we set out, some of us said to others, "Allah will not bless us, as we all went to Allah's Apostle asking him for mounts, and although he had sworn that he would not give us mounts, he did give us." So we returned to the Prophet; and mentioned that to him. He said, "I have not provided you with mounts, but Allah has. By Allah, Allah willing, if I ever take an oath, and then see that another is better than the first, I make expiration for my (dissolved) oath, and do what is better and make expiration."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.710]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 710

Narrated Hammad:

the same narration above (i.e. 709), "I make expiation for my dissolved oath, and I do what is better, or do what is better and make expiation."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.711]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 711

Narrated Abu Huraira:

(The Prophet) Solomon said, "Tonight I will sleep with (my) ninety wives, each of whom will get a male child who will fight for Allah's Cause." On that, his companion (Sufyan said that his companion was an angel) said to him, "Say, "If Allah will (Allah willing)." But Solomon forgot (to say it). He slept with all his wives, but none of the women gave birth to a child, except one who gave birth to a halfboy. Abu Huraira added: The Prophet said, "If Solomon had said, "If Allah will" (Allah willing), he would not have been unsuccessful in his action, and would have attained what he had desired." Once Abu Huraira added: Allah apostle said, "If he had accepted."


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.712]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 712

Narrated Zahdam al-Jarmi:

We were sitting with Abu Musa Al-Ash'sari, and as there were ties of friendship and mutual favors between us and his tribe. His meal was presented before him and there was chicken meat in it. Among those who were present there was a man from Bani Taimillah having a red complexion as a non-Arab freed slave, and that man did not approach the meal. Abu Musa said to him, "Come along! I have seen Allah's Apostle eating of that (i.e., chicken)." The man said, "I have seen it (chickens) eating something I regarded as dirty, and so I have taken an oath that I shall not eat (its meat) chicken." Abu Musa said, "Come along! I will inform you about it (i.e., your oath).

Once we went to Allah's Apostle in company with a group of Ash'airiyin, asking him for mounts while he was distributing some camels from the camels of Zakat. (Aiyub said, "I think he said that the Prophet was in an angry mood at the time.") The Prophet said, 'By Allah! I will not give you mounts, and I have nothing to mount you on.' After we had left, some camels of booty were brought to Allah's Apostle and he said, "Where are those Ash'ariyin? Where are those Ash'ariyin?" So we went (to him) and he gave us five very fat good-looking camels. We mounted them and went away, and then I said to my companions, 'We went to Allah's Apostle to give us mounts, but he took an oath that he would not give us mounts, and then later on he sent for us and gave us mounts, perhaps Allah's Apostle forgot his oath. By Allah, we will never be successful, for we have taken advantage of the fact that Allah's Apostle forgot to fulfill his oath. So let us return to Allah's Apostle to remind him of his oath.' We returned and said, 'O Allah's Apostle! We came to you and asked you for mounts, but you took an oath that you would not give us mounts) but later on you gave us mounts, and we thought or considered that you have forgotten your oath.' The Prophet said, 'Depart, for Allah has given you Mounts. By Allah, Allah willing, if I take an oath and then later find another thing better than that, I do what is better, and make expiation for the oath.' "


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.713]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 713

Narrated Zahdam:

the same narration as above (i.e. No. 712).


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.714]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 714

Narrated Zahdam:

the same narration as above (i.e. No. 712).


Bukhari :: Expiation for Unfulfilled Oaths :: [8.79.715]

Expiation for Unfulfilled Oaths

Bukhari :: Book 8 :: Volume 79 :: Hadith 715

Narrated 'Abdur-Rahman bin Samura:

Allah's Apostle said, "(O 'Abdur-Rahman!) Do not seek to be a ruler, for, if you are given the authority of ruling without your asking for it, then Allah will help you; but if you are given it by your asking, then you will be held responsible for it (i.e. Allah will not help you ) . And if you take an oath to do something and later on find another thing, better than that, then do what is better and make expiation for (the dissolution of) your oath."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.716]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 716

Narrated Jabir bin 'Abdullah:

I became sick so Allah's Apostle and Abu Bakr came on foot to pay me a visit. When they came, I was unconscious. Allah's Apostle performed ablution and he poured over me the water (of his ablution) and I came to my senses and said, "O Allah's Apostle! What shall I do regarding my property? How shall I distribute it?" The Prophet did not reply till the Divine Verses of inheritance were revealed .


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.717]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 717

Narrated Abu Huraira:

Allah's Apostle said, 'Beware of suspicion, for it is the worst of false tales and don't look for the other's faults and don't spy and don't hate each other, and don't desert (cut your relations with) one another O Allah's slaves, be brothers!" (See Hadith No. 90)


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.718]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 718

Narrated 'Aisha:

Fatima and Al 'Abbas came to Abu Bakr, seeking their share from the property of Allah's Apostle and at that time, they were asking for their land at Fadak and their share from Khaibar. Abu Bakr said to them, " I have heard from Allah's Apostle saying, 'Our property cannot be inherited, and whatever we leave is to be spent in charity, but the family of Muhammad may take their provisions from this property." Abu Bakr added, "By Allah, I will not leave the procedure I saw Allah's Apostle following during his lifetime concerning this property." Therefore Fatima left Abu Bakr and did not speak to him till she died.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.719]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 719

Narrated 'Aisha:

The Prophet said, "Our (Apostles') property should not be inherited, and whatever we leave, is to be spent in charity."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.720]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 720

Narrated Malik bin Aus:

'I went and entered upon 'Umar, his doorman, Yarfa came saying 'Uthman, 'Abdur-Rahman, Az-Zubair and Sa'd are asking your permission (to see you). May I admit them? 'Umar said, 'Yes.' So he admitted them Then he came again and said, 'May I admit 'Ali and 'Abbas?' He said, 'Yes.' 'Abbas said, 'O, chief of the believers! Judge between me and this man (Ali ). 'Umar said, 'I beseech you by Allah by Whose permission both the heaven and the earth exist, do you know that Allah's Apostle said, 'Our (the Apostles') property will not be inherited, and whatever we leave (after our death) is to be spent in charity?' And by that Allah's Apostle meant himself.' The group said, '(No doubt), he said so.' 'Umar then faced 'Ali and 'Abbas and said, 'Do you both know that Allah's Apostle said that?' They replied, '(No doubt), he said so.' 'Umar said, 'So let me talk to you about this matter. Allah favored His Apostle with something of this Fai' (i.e. booty won by the Muslims at war without fighting) which He did not give to anybody else;

Allah said:-- 'And what Allah gave to His Apostle ( Fai' Booty) .........to do all things....(59.6) And so that property was only for Allah's Apostle . Yet, by Allah, he neither gathered that property for himself nor withheld it from you, but he gave its income to you, and distributed it among you till there remained the present property out of which the Prophet used to spend the yearly maintenance for his family, and whatever used to remain, he used to spend it where Allah's property is spent (i.e. in charity etc.). Allah's Apostle followed that throughout his life.

Now I beseech you by Allah, do you know all that?' They said, 'Yes.' 'Umar then said to 'Ali and 'Abbas, 'I beseech you by Allah, do you know that?' Both of them said, 'Yes.' 'Umar added, 'And when the Prophet died, Abu Bakr said, ' I am the successor of Allah's Apostle, and took charge of that property and managed it in the same way as Allah's Apostle did.

Then I took charge of this property for two years during which I managed it as Allah's Apostle and Abu Bakr did. Then you both ('Ali and 'Abbas) came to talk to me, bearing the same claim and presenting the same case. (O 'Abbas!) You came to me asking for your share from the property of your nephew, and this man (Ali) came to me, asking for the share of h is wife from the property of her father. I said, 'If you both wish, I will give that to you on that condition (i.e. that you would follow the way of the Prophet and Abu Bakr and as I (Umar) have done in man aging it).' Now both of you seek of me a verdict other than that? Lo! By Allah, by Whose permission both the heaven and the earth exist, I will not give any verdict other than that till the Hour is established. If you are unable to manage it, then return it to me, and I will be sufficient to manage it on your behalf.' "


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.721]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 721

Narrated Abu Huraira:

Allah's Apostle said, "Not even a single Dinar of my property should be distributed (after my deaths to my inheritors, but whatever I leave excluding the provision for my wives and my servants, should be spent in charity."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.722]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 722

Narrated 'Urwa:

'Aisha said, "When Allah's Apostle died, his wives intended to send 'Uthman to Abu Bakr asking him for their share of the inheritance." Then 'Aisha said to them, "Didn't Allah's Apostle say, 'Our (Apostles') property is not to be inherited, and whatever we leave is to be spent in charity?'"


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.723]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 723

Narrated Abu Huraira:

The Prophet said, "I am more closer to the believers than their own selves, so whoever (of them) dies while being in debt and leaves nothing for its repayment, then we are to pay his debts on his behalf and whoever (among the believers) dies leaving some property, then that property is for his heirs."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.724]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 724

Narrated Ibn 'Abbas:

The Prophet said, "Give the Fara'id (the shares of the inheritance that are prescribed in the Qur'an) to those who are entitled to receive it. Then whatever remains, should be given to the closest male relative of the deceased ."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.725]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 725

Narrated Sa'd bin Abi Waqqas:

I was stricken by an ailment that led me to the verge of death. The Prophet came to pay me a visit. I said, "O Allah's Apostle! I have much property and no heir except my single daughter. Shall I give two-thirds of my property in charity?" He said, "No." I said, "Half of it?" He said, "No." I said, "One-third of it?" He said, "You may do so) though one-third is also to a much, for it is better for you to leave your off-spring wealthy than to leave them poor, asking others for help. And whatever you spend (for Allah's sake) you will be rewarded for it, even for a morsel of food which you may put in the mouth of your wife." I said, "O Allah's Apostle! Will I remain behind and fail to complete my emigration?" The Prophet said, "If you are left behind after me, whatever good deeds you will do for Allah's sake, that will upgrade you and raise you high. May be you will have long life so that some people may benefit by you and others (the enemies) be harmed by you." But Allah's Apostle felt sorry for Sa'd bin Khaula as he died in Mecca. (Sufyan, a sub-narrator said that Sa'd bin Khaula was a man from the tribe of Bani 'Amir bin Lu'ai.)


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.726]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 726

Narrated Al-Aswad bin Yazid:

Mu'adh bin Jabal came to us in Yemen as a tutor and a ruler, and we (the people of Yemen) asked him about (the distribution of the property of ) a man who had died leaving a daughter and a sister. Mu'adh gave the daughter one-half of the property and gave the sister the other half.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.727]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 727

Narrated Ibn 'Abbas:

Allah's Apostle said, "Give the Fara'id (shares prescribed in the Qur'an) to those who are entitled to receive it; and whatever remains, should be given to the closest male relative of the deceased.'


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.728]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 728

Narrated Huzail bin Shirahbil:

Abu Musa was asked regarding (the inheritance of) a daughter, a son's daughter, and a sister. He said, "The daughter will take one-half and the sister will take one-half. If you go to Ibn Mas'ud, he will tell you the same." Ibn Mas'ud was asked and was told of Abu Musa's verdict. Ibn Mas'ud then said, "If I give the same verdict, I would stray and would not be of the rightly-guided. The verdict I will give in this case, will be the same as the Prophet did, i.e. one-half is for daughter, and one-sixth for the son's daughter, i.e. both shares make two-thirds of the total property; and the rest is for the sister." Afterwards we cams to Abu Musa and informed him of Ibn Mas'ud's verdict, whereupon he said, "So, do not ask me for verdicts, as long as this learned man is among you."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.729]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 729

Narrated Ibn 'Abbas:

The Prophet said, "Give the Fara'id, (the shares prescribed in the Qur'an) to those who are entitled to receive it, and then whatever remains, should be given to the closest male relative of the deceased."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.730]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 730

Narrated Ibn 'Abbas:

The person about whom Allah's Apostle said, "If I were to take a Khalil from this nation (my followers), then I would have taken him (i.e., Abu Bakr), but the Islamic Brotherhood is better (or said: good)," regarded a grandfather as the father himself (in inheritance).


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.731]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 731

Narrated Ibn 'Abbas:

(During the early days of Islam), the inheritance used to be given to one's offspring and legacy used to be bequeathed to the parents, then Allah cancelled what He wished from that order and decreed that the male should be given the equivalent of the portion of two females, and for the parents one-sixth for each of them, and for one's wife one-eighth (if the deceased has children) and one-fourth (if he has no children), for one's husband one-half (if the deceased has no children) and one-fourth (if she has children)."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.732]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 732

Narrated Abu Huraira:

Allah's Apostle gave the judgment that a male or female slave should be given in Qisas for an abortion case of a woman from the tribe of Bani Lihyan (as blood money for the fetus) but the lady on whom the penalty had been imposed died, so the Prophets ordered that her property be inherited by her offspring and her husband and that the penalty be paid by her Asaba.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.733]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 733

Narrated Al-Aswad:

Mu'adh bin Jabal gave this verdict for us in the lifetime of Allah's Apostle. One-half of the inheritance is to be given to the daughter and the other half to the sister. Sulaiman said: Mu'adh gave a verdict for us, but he did not mention that it was so in the lifetime of Allah's Apostle.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.734]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 734

Narrated Huzail:

'Abdullah said, "The judgment I will give in this matter will be like the judgment of the Prophet, i.e. one-half is for the daughter and one-sixth for the son's daughter and the rest of the inheritance for the sister."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.735]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 735

Narrated Jabir:

While I was sick, the Prophet entered upon me and asked for some water to perform ablution, and after he had finished his ablution, he sprinkled some water of his ablution over me, whereupon I became conscious and said, "O Allah's Apostle! I have sisters." Then the Divine Verses regarding the laws of inheritance were revealed.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.736]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 736

Narrated Al-Bara:

The last Quranic Verse that was revealed (to the Prophet) was the final Verse of Surat-an-Nisa, i.e., 'They ask you for a legal verdict Say: Allah directs (thus) About those who leave No descendants or ascendants as heirs....' (4.176)


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.737]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 737

Narrated Abu Huraira:

Allah's Apostle said, "I am more closer to the believers than their ownselves, so whoever (among them) dies leaving some inheritance, his inheritance will be given to his 'Asaba, and whoever dies leaving a debt or dependants or destitute children, then I am their supporter."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.738]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 738

Narrated Ibn 'Abbas:

The Prophet said, "Give the Fara'id (the shares of the inheritance that are prescribed in the Qur'an) to those who are entitled to receive it; and whatever is left should be given to the closest male relative of the deceased."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.739]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 739

Narrated Ibn 'Abbas: regarding the Holy Verse:--'And to everyone, We have appointed heirs.

When the emigrants came to Medina, the Ansar used to be the heir of the emigrants (and vice versa) instead of their own kindred by blood (Dhawl-l-arham), and that was because of the bond of brotherhood which the Prophet had established between them, i.e. the Ansar and the emigrants. But when the Divine Verse:--

'And to everyone We have appointed heirs,' (4.33) was revealed, it cancelled the other, order i.e. 'To those also, to whom Your right hands have pledged.'


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.740]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 740

Narrated Ibn 'Umar:

A man and his wife had a case of Lian (or Mula'ana) during the lifetime of the Prophet and the man denied the paternity of her child. The Prophet gave his verdict for their separation (divorce) and then the child was regarded as belonging to the wife only.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.741]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 741

Narrated 'Aisha:

'Utba (bin Abi Waqqas) said to his brother Sa'd, "The son of the slave girl of Zam'a is my son, so be his custodian." So when it was the year of the Conquest of Mecca, Sa'd took that child and said, "He is my nephew, and my brother told me to be his custodian." On that, 'Abu bin Zam'a got up and said, 'but the child is my brother, and the son of my father's slave girl as he was born on his bed." So they both went to the Prophet. Sa'd said, "O Allah's Apostle! (This is) the son of my brother and he told me to be his custodian." Then 'Abu bin Zam'a said, "(But he is) my brother and the son of the slave girl of my father, born on his bed." The Prophet said, "This child is for you. O 'Abu bin Zam'a, as the child is for the owner of the bed, and the adulterer receives the stones." He then ordered (his wife) Sauda bint Zam'a to cover herself before that boy as he noticed the boy's resemblance to 'Utba. Since then the boy had never seen Sauda till he died.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.742]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 742

Narrated Abu Huraira:

The Prophet said, "The boy is for the owner of the bed."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.743]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 743

Narrated 'Aisha:

I bought Barira (a female slave). The Prophet said (to me), "Buy her as the Wala' is for the manumitted." Once she was given a sheep (in charity). The Prophet said, "It (the sheep) is a charitable gift for her (Barira) and a gift for us." Al-Hakam said, "Barira's husband was a free man." Ibn 'Abbas said, 'When I saw him, he was a slave."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.744]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 744

Narrated Ibn 'Umar:

The Prophet said, "The Wala' is for the manumitted (of the slave)."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.745]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 745

Narrated 'Abdullah:

The Muslims did not free slaves as Sa'iba, but the People of the Pre-lslamic Period of Ignorance used to do so.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.746]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 746

Narrated Al-Aswad:

'Aisha bought Barira in order to manumit her, but her masters stipulated that her Wala' (after her death) would be for them. 'Aisha said, "O Allah's Apostle! I have bought Barira in order to manumit her, but her masters stipulated that her Wala' will be for them." The Prophet said, "Manumit her as the Wala is for the one who manumits (the slave)," or said, "The one who pays her price." Then 'Aisha bought and manumitted her. After that, Barira was given the choice (by the Prophet) (to stay with her husband or leave him). She said, "If he gave me so much and so much (money) I would not stay with him." (Al-Aswad added: Her husband was a free man.) The sub-narrator added: The series of the narrators of Al-Aswad's statement is incomplete. The statement of Ibn Abbas, i.e., when I saw him he was a slave, is more authentic.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.747]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 747

Narrated 'Ali:

We have no Book to recite except the Book of Allah (Qur'an) and this paper. Then 'Ali took out the paper, and behold ! There was written in it, legal verdicts about the retaliation for wounds, the ages of the camels (to be paid as Zakat or as blood money). In it was also written: 'Medina is a sanctuary from Air (mountain) to Thaur (mountain). So whoever innovates in it an heresy (something new in religion) or commits a crime in it or gives shelter to such an innovator, will incur the curse of Allah, the angels and all the people, and none of his compulsory or optional good deeds will be accepted on the Day of Resurrection. And whoever (a freed slave) takes as his master (i.e. be-friends) some people other than hi real masters without the permission of his real masters, will incur the curse of Allah, the angels and all the people, and none of his compulsory, or optional good deeds will be accepted on the Day of Resurrection. And the asylum granted by any Muslim is to be secured by all the Muslims, even if it is granted by one of the lowest social status among them; and whoever betrays a Muslim, in this respect will incur the curse of Allah, the angels, and all the people, and none of his Compulsory or optional good deeds will be accepted on the Day of Resurrection."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.748]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 748

Narrated Ibn 'Umar:

The Prophet forbade the selling of the Wala' (of slaves) or giving it as a present.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.749]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 749

Narrated Ibn Umar:

That Aisha, the mother of the Believers, intended to buy a slave girl in order to manumit her. The slave girl's master said, "We are ready to sell her to you on the condition that her Wala should be for us." Aisha mentioned that to Allah's Apostle who said, "This (condition) should not prevent you from buying her, for the Wala is for the one who manumits (the slave)."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.750]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 750

Narrated Al-Aswad:

Aisha said, "I bought Barira and her masters stipulated that the Wala would be for them." Aisha mentioned that to the Prophet and he said, "Manumit her, as the Wala is for the one who gives the silver (i.e. pays the price for freeing the slave)." Aisha added, "So I manumitted her. After that, the Prophet caller her (Barira) and gave her the choice to go back to her husband or not. She said, "If he gave me so much and so much (money) I would not stay with him." So she selected her ownself (i.e. refused to go back to her husband)."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.751]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 751

Narrated Ibn Umar:

When Aisha intended to buy Barira, she said to the Prophet, "Barira's masters stipulated that they will have the Wala." The Prophet said (to Aisha), "Buy her, as the Wala is for the one who manumits."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.752]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 752

Narrated Aisha:

Allah's Apostle said, "The wala is for the one who gives the silver (pays the price) and does the favor (of manumission after paying the price)."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.753]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 753

Narrated Anas bin Malik:

The Prophet said, "The freed slave belongs to the people who have freed him," or said something similar.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.754]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 754

Narrated Anas bin Malik:

The Prophet said, "The son of the sister of some people is from them or from their own selves."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.755]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 755

Narrated Abu Huraira:

The Prophet said, " If somebody dies (among the Muslims) leaving some property, the property will go to his heirs; and if he leaves a debt or dependants, we will take care of them."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.756]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 756

Narrated Usama bin Zaid:

the Prophet said, "A Muslim cannot be the heir of a disbeliever, nor can a disbeliever be the heir of a Muslim."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.757]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 757

Narrated 'Aisha:

Sa'd bin Abi Waqqas and 'Abu bin Zam'a had a dispute over a boy. Sa'd said, "O Allah's Apostle! This (boy) is the son of my brother, 'Utba bin Abi Waqqas who told me to be his custodian as he was his son. Please notice to whom he bears affinity." And 'Abu bin Zam'a said, "This is my brother, O Allah's Apostle! He was born on my father's bed by his slave girl." Then the Prophet looked at the boy and noticed evident resemblance between him and 'Utba, so he said, "He (the toy) is for you, O 'Abu bin Zam'a, for the boy is for the owner of the bed, and the stone is for the adulterer. Screen yourself before the boy, O Sauda bint Zam'a." 'Aisha added: Since then he had never seen Sauda.


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.758]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 758

Narrated Sa'd:

I heard the Prophet saying, "Whoever claims to be the son of a person other than his father, and he knows that person is not his father, then Paradise will be forbidden for him." I mentioned that to Abu Bakra, and he said, "My ears heard that and my heart memorized it from Allah's Apostle


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.759]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 759

Narrated Abu Huraira:

The Prophet said, "Do not deny your fathers (i.e. claim to be the sons of persons other than your fathers), and whoever denies his father, is charged with disbelief."


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.760]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 760

Narrated Abu Huraira:

Allah's Apostle said, "There were two women with whom there were their two sons. A wolf came and took away the son of one of them. That lady said to her companion, 'The wolf has taken your son.' The other said, 'But it has taken your son.' So both of them sought the judgment of (the Prophet) David who judged that the boy should be given to the older lady. Then both of them went to (the Prophet) Solomon, son of David and informed him of the case. Solomon said, 'Give me a knife so that I may cut the child into two portions and give one half to each of you.' The younger lady said, 'Do not do so; may Allah bless you ! He is her child.' On that, he gave the child to the younger lady." Abu Huraira added: By Allah! I had never heard the word 'Sakkin' as meaning knife, except on that day, for we used to call it 'Mudya"


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.761]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 761

Narrated 'Aisha:

Allah's Apostle once entered upon me in a very happy mood, with his features glittering with joy, and said, "O 'Aisha! won't you see that Mujazziz (a Qa'if) looked just now at Zaid bin Haritha and Usama bin Zaid and said, 'These feet (of Usama and his father) belong to each other." (See Hadith No. 755, Vol. 4)


Bukhari :: Laws of Inheritance (Al-Faraa'id) :: [8.80.762]

Laws of Inheritance (Al-Faraa'id)

Bukhari :: Book 8 :: Volume 80 :: Hadith 762

Narrated 'Aisha:

Once Allah's Apostle entered upon me and he was in a very happy mood and said, "O 'Aisha: Don't you know that Mujazziz Al-Mudliji entered and saw Usama and Zaid with a velvet covering on them and their heads were covered while their feet were uncovered. He said, 'These feet belong to each other.'


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.763]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 763

Narrated Abu Huraira:

Allah's Apostle said, "When an adulterer commits illegal sexual intercourse, then he is not a believer at the time he is doing it; and when somebody drinks an alcoholic drink, then he is not believer at the time of drinking, and when a thief steals, he is not a believer at the time when he is stealing; and when a robber robs and the people look at him, then he is not a believer at the time of doing it." Abu Huraira in another narration, narrated the same from the Prophet with the exclusion of robbery.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.764]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 764

Narrated Anas bin Malik:

The Prophet beat a drunk with palm-leaf stalks and shoes. And Abu Bakr gave (such a sinner) forty lashes.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.765]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 765

Narrated 'Uqba bin Al-Harith:

An-Nu'man or the son of An-Nu'man was brought to the Prophet on a charge of drunkenness. So the Prophet ordered all the men present in the house, to beat him. So all of them beat him, and I was also one of them who beat him with shoes.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.766]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 766

Narrated' Uqba bin Al-Harith:

An-Nu'man or the son of An-Nu'man was brought to the Prophet in a state of intoxication. The Prophet felt it hard (was angry) and ordered all those who were present in the house, to beat him. And they beat him, using palm-leaf stalks and shoes, and I was among those who beat him.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.767]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 767

Narrated Anas:

The Prophet lashed a drunk with dateleaf stalks and shoes. And Abu Bakr gave a drunk forty lashes.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.768]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 768

Narrated Abu Salama:

Abu Huraira said, "A man who drank wine was brought to the Prophet. The Prophet said, 'Beat him!" Abu Huraira added, "So some of us beat him with our hands, and some with their shoes, and some with their garments (by twisting it) like a lash, and then when we finished, someone said to him, 'May Allah disgrace you!' On that the Prophet said, 'Do not say so, for you are helping Satan to overpower him.' "


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.769]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 769

Narrated 'Ali bin Abi Talib:

I would not feel sorry for one who dies because of receiving a legal punishment, except the drunk, for if he should die (when being punished), I would give blood money to his family because no fixed punishment has been ordered by Allah's Apostle for the drunk.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.770]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 770

Narrated As-Sa'ib bin Yazid:

We used to strike the drunks with our hands, shoes, clothes (by twisting it into the shape of lashes) during the lifetime of the Prophet, Abu Bakr and the early part of 'Umar's caliphate. But during the last period of 'Umar's caliphate, he used to give the drunk forty lashes; and when drunks became mischievous and disobedient, he used to scourge them eighty lashes.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.771]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 771

Narrated 'Umar bin Al-Khattab:

During the lifetime of the Prophet there was a man called 'Abdullah whose nickname was Donkey, and he used to make Allah's Apostle laugh. The Prophet lashed him because of drinking (alcohol). And one-day he was brought to the Prophet on the same charge and was lashed. On that, a man among the people said, "O Allah, curse him ! How frequently he has been brought (to the Prophet on such a charge)!" The Prophet said, "Do not curse him, for by Allah, I know for he loves Allah and His Apostle."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.772]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 772

Narrated Abu Huraira:

A drunk was brought to the Prophet and he ordered him to be beaten (lashed). Some of us beat him with our hands, and some with their shoes, and some with their garments (twisted in the form of a lash). When that drunk had left, a man said, "What is wrong with him? May Allah disgrace him!" Allah's Apostle said, "Do not help Satan against your (Muslim) brother."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.773]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 773

Narrated Ibn 'Abbas:

The Prophet said, "When (a person) an adulterer commits illegal sexual intercourse then he is not a believer at the time he is doing it; and when somebody steals, then he is not a believer at the time he is stealing."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.774]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 774

Narrated Abu Huraira:

The Prophet said, "Allah curses a man who steals an egg and gets his hand cut off, or steals a rope and gets his hands cut off." Al-A'mash said, "People used to interpret the Baida as an iron helmet, and they used to think that the rope may cost a few dirhams."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.775]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 775

Narrated 'Ubada bin As-Samit:

We were with the Prophet in a gathering and he said, 'Swear allegiance to me that you will not worship anything besides Allah, Will not steal, and will not commit illegal sexual intercourse." And then (the Prophet) recited the whole Verse (i.e. 60:12). The Prophet added, 'And whoever among you fulfills his pledge, his reward is with Allah; and whoever commits something of such sins and receives the legal punishment for it, that will be considered as the expiation for that sin, and whoever commits something of such sins and Allah screens him, it is up to Allah whether to excuse or punish him."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.776]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 776

Narrated Abdullah:

Allah Apostle said in Hajjat-al-Wada, "Which month (of the year) do you think is most sacred?" The people said, "This current month of ours (the month of Dhull-Hijja)." He said, "Which town (country) do you think is the most sacred?" They said, "This city of ours (Mecca)." He said, "Which day do you think is the most sacred?" The people said, "This day of ours." He then said, "Allah, the Blessed, the Supreme, has made your blood, your property and your honor as sacred as this day of yours in this town of yours, in this month of yours (and such protection cannot be slighted) except rightfully." He then said thrice, "Have I conveyed Allah's Message (to you)?" The people answered him each time saying, 'Yes." The Prophet added, 'May Allah be merciful to you (or, woe on you)! Do not revert to disbelief after me by cutting the necks of each other.'


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.777]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 777

Narrated Aisha:

Whenever the Prophet was given an option between two things, he used to select the easier of the tow as long as it was not sinful; but if it was sinful, he would remain far from it. By Allah, he never took revenge for himself concerning any matter that was presented to him, but when Allah's Limits were transgressed, he would take revenge for Allah's Sake.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.778]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 778

Narrated 'Aisha:

Usama approached the Prophet on behalf of a woman (who had committed theft). The Prophet said, "The people before you were destroyed because they used to inflict the legal punishments on the poor and forgive the rich. By Him in Whose Hand my soul is! If Fatima (the daughter of the Prophet ) did that (i.e. stole), I would cut off her hand."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.779]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 779

Narrated 'Aisha:

The Quraish people became very worried about the Makhzumiya lady who had committed theft. They said, "Nobody can speak (in favor of the lady) to Allah's Apostle and nobody dares do that except Usama who is the favorite of Allah's Apostle. " When Usama spoke to Allah's Apostle about that matter, Allah's Apostle said, "Do you intercede (with me) to violate one of the legal punishment of Allah?" Then he got up and addressed the people, saying, "O people! The nations before you went astray because if a noble person committed theft, they used to leave him, but if a weak person among them committed theft, they used to inflict the legal punishment on him. By Allah, if Fatima, the daughter of Muhammad committed theft, Muhammad will cut off her hand.!"


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.780]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 780

Narrated 'Aisha:

The Prophet said, "The hand should be cut off for stealing something that is worth a quarter of a Dinar or more."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.781]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 781

Narrated 'Aisha:

The Prophet said, "The hand of a thief should be cut off for stealing a quarter of a Dinar."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.782]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 782

Narrated 'Aisha:

The Prophet said, "The hand should be cut off for stealing a quarter of a Dinar."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.783]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 783

Narrated 'Aisha:

The hand of a thief was not cut off during the lifetime of the Prophet except for stealing something equal to a shield in value.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.784]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 784

Narrated 'Aisha:

as above (783).


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.785]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 785

Narrated 'Aisha:

A thief's hand was not cut off for stealing something cheaper than a Hajafa or a Turs (two kinds of shields), each of which was worth a (respectable) price.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.786]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 786

Narrated 'Aisha:

A thief's hand was not cut off for stealing something worth less than the price of a shield, whether a Turs or Hajafa (two kinds of shields), each of which was worth a (respectable) price.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.787]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 787

Narrated Ibn 'Umar:

Allah's Apostle cut off the hand of a thief for stealing a shield that was worth three Dirhams.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.788]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 788

Narrated Ibn 'Umar:

The Prophet cut off the hand of a thief for stealing a shield that was worth three Dirhams.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.789]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 789

Narrated 'Abdullah bin 'Umar:

The Prophet cut off the hand of a thief for stealing a shield that was worth three Dirhams.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.790]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 790

Narrated 'Abdullah bin 'Umar:

The Prophet cutoff the hand of a thief for stealing a shield that was worth three Dirhams.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.791]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 791

Narrated Abu Huraira:

Allah 's Apostle said, "Allah curses the thief who steals an egg (or a helmet) for which his hand is to be cut off, or steals a rope, for which his hand is to be cut off."


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.792]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 792

Narrated 'Aisha:

The Prophet cut off the hand of a lady, and that lady used to come to me, and I used to convey her message to the Prophet and she repented, and her repentance was sincere.


Bukhari :: Limits and Punishments set by Allah (Hudood) :: [8.81.793]

Limits and Punishments set by Allah (Hudood)

Bukhari :: Book 8 :: Volume 81 :: Hadith 793

Narrated Ubada bin As-Samit:

I gave the pledge of allegiance to the Prophet with a group of people, and he said, "I take your pledge that you will not worship anything besides Allah, will not steal, will not commit infanticide, will not slander others by forging false statements and spreading it, and will not disobey me in anything good. And whoever among you fulfill all these (obligations of the pledge), his reward is with Allah. And whoever commits any of the above crimes and receives his legal punishment in this world, that will be his expiation and purification. But if Allah screens his sin, it will be up to Allah, Who will either punish or forgive him according to His wish." Abu Abdullah said: "If a thief repents after his hand has been cut off, the his witness well be accepted. Similarly, if any person upon whom any legal punishment has been inflicted, repents, his witness will be accepted."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.794]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 794

Narrated Anas:

Some people from the tribe of 'Ukl came to the Prophet and embraced Islam. The climate of Medina did not suit them, so the Prophet ordered them to go to the (herd of milch) camels of charity and to drink, their milk and urine (as a medicine). They did so, and after they had recovered from their ailment (became healthy) they turned renegades (reverted from Islam) and killed the shepherd of the camels and took the camels away. The Prophet sent (some people) in their pursuit and so they were (caught and) brought, and the Prophets ordered that their hands and legs should be cut off and that their eyes should be branded with heated pieces of iron, and that their cut hands and legs should not be cauterized, till they die.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.795]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 795

Narrated Anas:

The Prophet cut off the hands and feet of the men belonging to the tribe of 'Uraina and did not cauterise (their bleeding limbs) till they died.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.796]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 796

Narrated Anas:

A group of people from 'Ukl (tribe) came to the Prophet and they were living with the people of As-Suffa, but they became ill as the climate of Medina did not suit them, so they said, "O Allah's Apostle! Provide us with milk." The Prophet said, I see no other way for you than to use the camels of Allah's Apostle." So they went and drank the milk and urine of the camels, (as medicine) and became healthy and fat. Then they killed the shepherd and took the camels away. When a help-seeker came to Allah's Apostle, he sent some men in their pursuit, and they were captured and brought before mid day. The Prophet ordered for some iron pieces to be made red hot, and their eyes were branded with them and their hands and feet were cut off and were not cauterized. Then they were put at a place called Al-Harra, and when they asked for water to drink they were not given till they died. (Abu Qilaba said, "Those people committed theft and murder and fought against Allah and His Apostle.")


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.797]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 797

Narrated Anas bin Malik:

A group of people from 'Ukl (or 'Uraina) tribe ----but I think he said that they were from 'Ukl came to Medina and (they became ill, so) the Prophet ordered them to go to the herd of (Milch) she-camels and told them to go out and drink the camels' urine and milk (as a medicine). So they went and drank it, and when they became healthy, they killed the shepherd and drove away the camels. This news reached the Prophet early in the morning, so he sent (some) men in their pursuit and they were captured and brought to the Prophet before midday. He ordered to cut off their hands and legs and their eyes to be branded with heated iron pieces and they were thrown at Al-Harra, and when they asked for water to drink, they were not given water. (Abu Qilaba said, "Those were the people who committed theft and murder and reverted to disbelief after being believers (Muslims), and fought against Allah and His Apostle").


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.798]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 798

Narrated Abu Huraira:

The Prophet said, "Seven (people) will be shaded by Allah by His Shade on the Day of Resurrection when there will be no shade except His Shade. (They will be), a just ruler, a young man who has been brought up in the worship of Allah, a man who remembers Allah in seclusion and his eyes are then flooded with tears, a man whose heart is attached to mosques (offers his compulsory congregational prayers in the mosque), two men who love each other for Allah's Sake, a man who is called by a charming lady of noble birth to commit illegal sexual intercourse with her, and he says, 'I am afraid of Allah,' and (finally), a man who gives in charity so secretly that his left hand does not know what his right hand has given."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.799]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 799

Narrated Sahl bin Sa'd:

The Prophet said, "Whoever guarantees me (the chastity of) what is between his legs (i.e. his private parts), and what is between his jaws (i.e., his tongue), I guarantee him Paradise."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.800]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 800

Narrated 'Ikrima from Ibn 'Abbas:

Allah's Apostles said, "When a slave (of Allah) commits illegal sexual intercourse, he is not a believer at the time of committing it; and if he steals, he is not a believer at the time of stealing; and if he drinks an alcoholic drink, when he is not a believer at the time of drinking it; and he is not a believer when he commits a murder," 'Ikrima said: I asked Ibn Abbas, "How is faith taken away from him?" He said, Like this," by clasping his hands and then separating them, and added, "But if he repents, faith returns to him like this, by clasping his hands again.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.801]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 801

Narrated Abu Huraira:

The Prophet said, "The one who commits an illegal sexual intercourse is not a believer at the time of committing illegal sexual intercourse and a thief is not a believer at the time of committing theft and a drinker of alcoholic drink is not a believer at the time of drinking. Yet, (the gate of) repentance is open thereafter."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.802]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 802

Narrated 'Abdullah bin Mas'ud:

I said, "O Allah's Apostle! Which is the biggest sin?" He said, "To set up rivals to Allah by worshipping others though He alone has created you." I asked, "What is next?" He said, "To kill your child lest it should share your food." I asked, "What is next?" He said, "To commit illegal sexual intercourse with the wife of your neighbor."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.803]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 803

Narrated Ash-Sha'bi:

from 'Ali when the latter stoned a lady to death on a Friday. 'Ali said, "I have stoned her according to the tradition of Allah's Apostle."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.804]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 804

Narrated Ash Shaibani:

I asked 'Abdullah bin Abi Aufa, 'Did Allah's Apostle carry out the Rajam penalty ( i.e., stoning to death)?' He said, "Yes." I said, "Before the revelation of Surat-ar-Nur or after it?" He replied, "I don't Know."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.805]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 805

Narrated Jabir bin Abdullah Al-Ansari:

A man from the tribe of Bani Aslam came to Allah's Apostle and Informed him that he had committed illegal sexual intercourse and bore witness four times against himself. Allah's Apostle ordered him to be stoned to death as he was a married Person.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.806]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 806

Narrated Abu Huraira:

A man came to Allah's Apostle while he was in the mosque, and he called him, saying, "O Allah's Apostle! I have committed illegal sexual intercourse.'" The Prophet turned his face to the other side, but that man repeated his statement four times, and after he bore witness against himself four times, the Prophet called him, saying, "Are you mad?" The man said, "No." The Prophet said, "Are you married?" The man said, "Yes." Then the Prophet said, 'Take him away and stone him to death." Jabir bin 'Abdullah said: I was among the ones who participated in stoning him and we stoned him at the Musalla. When the stones troubled him, he fled, but we over took him at Al-Harra and stoned him to death.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.807]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 807

Narrated 'Aisha:

Sa'd bin Abi Waqqas and 'Abd bin Zam'a quarrelled with each other (regarding a child). The Prophet said, "The boy is for you, O 'Abd bin Zam'a, for the boy is for (the owner) of the bed. O Sauda ! Screen yourself from the boy." The sub-narrator, Al-Laith added (that the Prophet also said), "And the stone is for the person who commits an illegal sexual intercourse."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.808]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 808

Narrated Abu Huraira:

The Prophet said, "The boy is for (the owner of) the bed and the stone is for the person who commits illegal sexual intercourse.'


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.809]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 809

Narrated Ibn 'Umar:

A Jew and a Jewess were brought to Allah's Apostle on a charge of committing an illegal sexual intercourse. The Prophet asked them. "What is the legal punishment (for this sin) in your Book (Torah)?" They replied, "Our priests have innovated the punishment of blackening the faces with charcoal and Tajbiya." 'Abdullah bin Salam said, "O Allah's Apostle, tell them to bring the Torah." The Torah was brought, and then one of the Jews put his hand over the Divine Verse of the Rajam (stoning to death) and started reading what preceded and what followed it. On that, Ibn Salam said to the Jew, "Lift up your hand." Behold! The Divine Verse of the Rajam was under his hand. So Allah's Apostle ordered that the two (sinners) be stoned to death, and so they were stoned. Ibn 'Umar added: So both of them were stoned at the Balat and I saw the Jew sheltering the Jewess.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.810]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 810

Narrated Jabir:

A man from the tribe of Aslam came to the Prophet and confessed that he had committed an illegal sexual intercourse. The Prophet turned his face away from him till the man bore witness against himself four times. The Prophet said to him, "Are you mad?" He said "No." He said, "Are you married?" He said, "Yes." Then the Prophet ordered that he be stoned to death, and he was stoned to death at the Musalla. When the stones troubled him, he fled, but he was caught and was stoned till he died. The Prophet spoke well of him and offered his funeral prayer.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.811]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 811

Narrated 'Aisha:

A man came to the Prophet in the mosque and said, "I am burnt (ruined)!" The Prophet asked him, "With what (what have you done)?" He said, "I have had sexual relation with my wife in the month of Ramadan (while fasting)." The Prophet said to him, "Give in charity." He said, "I have nothing." The man sat down, and in the meantime there came a person driving a donkey carrying food to the Prophet ..... (The sub-narrator, 'Abdur Rahman added: I do not know what kind of food it was). On that the Prophet said, "Where is the burnt person?" The man said, "Here I am." The Prophet said to him, "Take this (food) and give it in charity (to someone)." The man said, "To a poorer person than l? My family has nothing to eat." Then the Prophet said to him, "Then eat it yourselves."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.812]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 812

Narrated Anas bin Malik:

While I was with the Prophet a man came and said, "O Allah's Apostle! I have committed a legally punishable sin; please inflict the legal punishment on me'.' The Prophet did not ask him what he had done. Then the time for the prayer became due and the man offered prayer along with the Prophet , and when the Prophet had finished his prayer, the man again got up and said, "O Allah's Apostle! I have committed a legally punishable sin; please inflict the punishment on me according to Allah's Laws." The Prophet said, "Haven't you prayed with us?' He said, "Yes." The Prophet said, "Allah has forgiven your sin." or said, "....your legally punishable sin."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.813]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 813

Narrated Ibn 'Abbas:

When Ma'iz bin Malik came to the Prophet (in order to confess), the Prophet said to him, "Probably you have only kissed (the lady), or winked, or looked at her?" He said, "No, O Allah's Apostle!" The Prophet said, using no euphemism, "Did you have sexual intercourse with her?" The narrator added: At that, (i.e. after his confession) the Prophet ordered that he be stoned (to death).


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.814]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 814

Narrated Abu Huraira:

A man from among the people, came to Allah's Apostle while Allah's Apostle was sitting in the mosque, and addressed him, saying, "O Allah's Apostle! I have committed an illegal sexual intercourse." The Prophet turned his face away from him. The man came to that side to which the Prophet had turned his face, and said, "O Allah's Apostle! I have committed an illegal intercourse." The Prophet turned his face to the other side, and the man came to that side, and when he confessed four times, the Prophet called him and said, "Are you mad?" He said, "No, O Allah's Apostle!" The Prophet said, "Are you married?" He said, "Yes, O Allah's Apostle." The Prophet said (to the people), "Take him away and stone him to death." Ibn Shihab added, "I was told by one who heard Jabir, that Jabir said, 'I was among those who stoned the man, and we stoned him at the Musalla ('Id praying Place), and when the stones troubled him, he jumped quickly and ran away, but we overtook him at Al-Harra and stoned him to death (there).' "


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.815]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 815

Narrated Abu Huraira and Zaid bin Khalid:

While we were with the Prophet , a man stood up and said (to the Prophet ), "I beseech you by Allah, that you should judge us according to Allah's Laws." Then the man's opponent who was wiser than him, got up saying (to Allah's Apostle) "Judge us according to Allah's Law and kindly allow me (to speak)." The Prophet said, "'Speak." He said, "My son was a laborer working for this man and he committed an illegal sexual intercourse with his wife, and I gave one-hundred sheep and a slave as a ransom for my son's sin. Then I asked a learned man about this case and he informed me that my son should receive one hundred lashes and be exiled for one year, and the man's wife should be stoned to death." The Prophet said, "By Him in Whose Hand my soul is, I will judge you according to the Laws of Allah. Your one-hundred sheep and the slave are to be returned to you, and your son has to receive one-hundred lashes and be exiled for one year. O Unais! Go to the wife of this man, and if she confesses, then stone her to death." Unais went to her and she confessed. He then stoned her to death.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.816]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 816

Narrated Ibn 'Abbas:

'Umar said, "I am afraid that after a long time has passed, people may say, "We do not find the Verses of the Rajam (stoning to death) in the Holy Book," and consequently they may go astray by leaving an obligation that Allah has revealed. Lo! I confirm that the penalty of Rajam be inflicted on him who commits illegal sexual intercourse, if he is already married and the crime is proved by witnesses or pregnancy or confession." Sufyan added, "I have memorized this narration in this way." 'Umar added, "Surely Allah's Apostle carried out the penalty of Rajam, and so did we after him."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.817]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 817

Narrated Ibn 'Abbas:

I used to teach (the Qur'an to) some people of the Muhajirln (emigrants), among whom there was 'Abdur Rahman bin 'Auf. While I was in his house at Mina, and he was with 'Umar bin Al-Khattab during 'Umar's last Hajj, Abdur-Rahman came to me and said, "Would that you had seen the man who came today to the Chief of the Believers ('Umar), saying, 'O Chief of the Believers! What do you think about so-and-so who says, 'If 'Umar should die, I will give the pledge of allegiance to such-and-such person, as by Allah, the pledge of allegiance to Abu Bakr was nothing but a prompt sudden action which got established afterwards.' 'Umar became angry and then said, 'Allah willing, I will stand before the people tonight and warn them against those people who want to deprive the others of their rights (the question of rulership)."

'Abdur-Rahman said, "I said, 'O Chief of the believers! Do not do that, for the season of Hajj gathers the riff-raff and the rubble, and it will be they who will gather around you when you stand to address the people. And I am afraid that you will get up and say something, and some people will spread your statement and may not say what you have actually said and may not understand its meaning, and may interpret it incorrectly, so you should wait till you reach Medina, as it is the place of emigration and the place of Prophet's Traditions, and there you can come in touch with the learned and noble people, and tell them your ideas with confidence; and the learned people will understand your statement and put it in its proper place.' On that, 'Umar said, 'By Allah! Allah willing, I will do this in the first speech I will deliver before the people in Medina."

Ibn Abbas added: We reached Medina by the end of the month of Dhul-Hijja, and when it was Friday, we went quickly (to the mosque) as soon as the sun had declined, and I saw Sa'id bin Zaid bin 'Amr bin Nufail sitting at the corner of the pulpit, and I too sat close to him so that my knee was touching his knee, and after a short while 'Umar bin Al-Khattab came out, and when I saw him coming towards us, I said to Said bin Zaid bin 'Amr bin Nufail "Today 'Umar will say such a thing as he has never said since he was chosen as Caliph." Said denied my statement with astonishment and said, "What thing do you expect 'Umar to say the like of which he has never said before?"

In the meantime, 'Umar sat on the pulpit and when the callmakers for the prayer had finished their call, 'Umar stood up, and having glorified and praised Allah as He deserved, he said, "Now then, I am going to tell you something which (Allah) has written for me to say. I do not know; perhaps it portends my death, so whoever understands and remembers it, must narrate it to the others wherever his mount takes him, but if somebody is afraid that he does not understand it, then it is unlawful for him to tell lies about me. Allah sent Muhammad with the Truth and revealed the Holy Book to him, and among what Allah revealed, was the Verse of the Rajam (the stoning of married person (male & female) who commits illegal sexual intercourse, and we did recite this Verse and understood and memorized it. Allah's Apostle did carry out the punishment of stoning and so did we after him.

I am afraid that after a long time has passed, somebody will say, 'By Allah, we do not find the Verse of the Rajam in Allah's Book,' and thus they will go astray by leaving an obligation which Allah has revealed. And the punishment of the Rajam is to be inflicted to any married person (male & female), who commits illegal sexual intercourse, if the required evidence is available or there is conception or confession. And then we used to recite among the Verses in Allah's Book: 'O people! Do not claim to be the offspring of other than your fathers, as it is disbelief (unthankfulness) on your part that you claim to be the offspring of other than your real father.' Then Allah's Apostle said, 'Do not praise me excessively as Jesus, son of Marry was praised, but call me Allah's Slave and His Apostles.' (O people!) I have been informed that a speaker amongst you says, 'By Allah, if 'Umar should die, I will give the pledge of allegiance to such-and-such person.' One should not deceive oneself by saying that the pledge of allegiance given to Abu Bakr was given suddenly and it was successful. No doubt, it was like that, but Allah saved (the people) from its evil, and there is none among you who has the qualities of Abu Bakr. Remember that whoever gives the pledge of allegiance to anybody among you without consulting the other Muslims, neither that person, nor the person to whom the pledge of allegiance was given, are to be supported, lest they both should be killed.

And no doubt after the death of the Prophet we were informed that the Ansar disagreed with us and gathered in the shed of Bani Sa'da. 'Ali and Zubair and whoever was with them, opposed us, while the emigrants gathered with Abu Bakr. I said to Abu Bakr, 'Let's go to these Ansari brothers of ours.' So we set out seeking them, and when we approached them, two pious men of theirs met us and informed us of the final decision of the Ansar, and said, 'O group of Muhajirin (emigrants) ! Where are you going?' We replied, 'We are going to these Ansari brothers of ours.' They said to us, 'You shouldn't go near them. Carry out whatever we have already decided.' I said, 'By Allah, we will go to them.' And so we proceeded until we reached them at the shed of Bani Sa'da. Behold! There was a man sitting amongst them and wrapped in something. I asked, 'Who is that man?' They said, 'He is Sa'd bin 'Ubada.' I asked, 'What is wrong with him?' They said, 'He is sick.' After we sat for a while, the Ansar's speaker said, 'None has the right to be worshipped but Allah,' and praising Allah as He deserved, he added, 'To proceed, we are Allah's Ansar (helpers) and the majority of the Muslim army, while you, the emigrants, are a small group and some people among you came with the intention of preventing us from practicing this matter (of caliphate) and depriving us of it.'

When the speaker had finished, I intended to speak as I had prepared a speech which I liked and which I wanted to deliver in the presence of Abu Bakr, and I used to avoid provoking him. So, when I wanted to speak, Abu Bakr said, 'Wait a while.' I disliked to make him angry. So Abu Bakr himself gave a speech, and he was wiser and more patient than I. By Allah, he never missed a sentence that I liked in my own prepared speech, but he said the like of it or better than it spontaneously. After a pause he said, 'O Ansar! You deserve all (the qualities that you have attributed to yourselves, but this question (of Caliphate) is only for the Quraish as they are the best of the Arabs as regards descent and home, and I am pleased to suggest that you choose either of these two men, so take the oath of allegiance to either of them as you wish. And then Abu Bakr held my hand and Abu Ubada bin Abdullah's hand who was sitting amongst us. I hated nothing of what he had said except that proposal, for by Allah, I would rather have my neck chopped off as expiator for a sin than become the ruler of a nation, one of whose members is Abu Bakr, unless at the time of my death my own-self suggests something I don't feel at present.'

And then one of the Ansar said, 'I am the pillar on which the camel with a skin disease (eczema) rubs itself to satisfy the itching (i.e., I am a noble), and I am as a high class palm tree! O Quraish. There should be one ruler from us and one from you.'

Then there was a hue and cry among the gathering and their voices rose so that I was afraid there might be great disagreement, so I said, 'O Abu Bakr! Hold your hand out.' He held his hand out and I pledged allegiance to him, and then all the emigrants gave the Pledge of allegiance and so did the Ansar afterwards. And so we became victorious over Sa'd bin Ubada (whom Al-Ansar wanted to make a ruler). One of the Ansar said, 'You have killed Sa'd bin Ubada.' I replied, 'Allah has killed Sa'd bin Ubada.' Umar added, "By Allah, apart from the great tragedy that had happened to us (i.e. the death of the Prophet), there was no greater problem than the allegiance pledged to Abu Bakr because we were afraid that if we left the people, they might give the Pledge of allegiance after us to one of their men, in which case we would have given them our consent for something against our real wish, or would have opposed them and caused great trouble. So if any person gives the Pledge of allegiance to somebody (to become a Caliph) without consulting the other Muslims, then the one he has selected should not be granted allegiance, lest both of them should be killed."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.818]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 818

Narrated Zaid bin Khalid Al-Jihani:

I heard the Prophet ordering that an unmarried person guilty of illegal sexual intercourse be flogged one-hundred stripes and be exiled for one year. Umar bin Al-Khattab also exiled such a person, and this tradition is still valid.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.819]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 819

Narrated Abu Huraira:

Allah's Apostle judged that the unmarried person who was guilty of illegal sexual intercourse be exiled for one year and receive the legal punishment (i.e., be flogged with one-hundred stripes) .


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.820]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 820

Narrated Ibn 'Abbas:

The Prophet cursed the effeminate men and those women who assume the similitude (manners) of men. He also said, "Turn them out of your houses." He turned such-and-such person out, and 'Umar also turned out such-and-such person.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.821]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 821

Narrated Abu Huraira and Zaid bin Khalid:

A bedouin came to the Prophet while he (the Prophet) was sitting, and said, "O Allah's Apostle! Give your verdict according to Allah's Laws (in our case)." Then his opponent got up and said, "He has told the truth, O Allah's Apostle! Decide his case according to Allah's Laws. My son was a laborer working for this person, and he committed illegal sexual intercourse with his wife, and the people told me that my son should be stoned to death, but I offered one-hundred sheep and a slave girl as a ransom for him. Then I asked the religious learned people, and they told me that my son should be flogged with one-hundred stripes and be exiled for one year." The Prophet said, "By Him in Whose Hand my soul is, I will judge you according to Allah's Laws. The sheep and the slave girl will be returned to you and your son will be flogged one-hundred stripes and be exiled for one year. And you, O Unais! Go to the wife of this man (and if she confesses), stone her to death." So Unais went in the morning and stoned her to death (after she had confessed).


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.822]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 822

Narrated Abu Huraira and Said bin Khalid:

The verdict of Allah's Apostle was sought about an unmarried slave girl guilty of illegal intercourse. He replied, "If she commits illegal sexual intercourse, then flog her (fifty stripes), and if she commits illegal sexual intercourse (after that for the second time), then flog her (fifty stripes), and if she commits illegal sexual intercourse (for the third time), then flog her (fifty stripes) and sell her for even a hair rope." Ibn Shihab said, "I am not sure whether the Prophet ordered that she be sold after the third or fourth time of committing illegal intercourse."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.823]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 823

Narrated Abu Huraira:

The Prophet said, "If a lady slave commits illegal sexual intercourse and she is proved guilty of illegal sexual intercourse, then she should be flogged (fifty stripes) but she should not be admonished; and if she commits illegal sexual intercourse again, then she should be flogged again but should not be admonished; and if she commits illegal sexual intercourse for the third time, then she should be sold even for a hair rope."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.824]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 824

Narrated Ash-Shaibani:

I asked 'Abdullah bin Abi 'Aufa about the Rajam (stoning somebody to death for committing illegal sexual intercourse). He replied, "The Prophet carried out the penalty of Rajam," I asked, "Was that before or after the revelation of Surat-an-Nur?" He replied, "I do not know."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.825]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 825

Narrated Abdullah bin Umar:

The jews came to Allah's Apostle and mentioned to him that a man and a lady among them had committed illegal sexual intercourse. Allah's Apostle said to them, "What do you find in the Torah regarding the Rajam?" They replied, "We only disgrace and flog them with stripes." 'Abdullah bin Salam said to them, 'You have told a lie the penalty of Rajam is in the Torah.' They brought the Torah and opened it. One of them put his hand over the verse of the Rajam and read what was before and after it. Abdullah bin Salam said to him, "Lift up your hand." Where he lifted it there appeared the verse of the Rajam. So they said, "O Muhammad! He has said the truth, the verse of the Rajam is in it (Torah)." Then Allah's Apostle ordered that the two persons (guilty of illegal sexual intercourse) be stoned to death, and so they were stoned, and I saw the man bending over the woman so as to protect her from the stones.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.826]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 826

Narrated Abu Huraira and Zaid bin Khalid:

Two men had a dispute in the presence of Allah's Apostle. One of them said, "Judge us according to Allah's Laws." The other who was more wise said, "Yes, Allah's Apostle, judge us according to Allah's Laws and allow me to speak (first)" The Prophet said to him, 'Speak " He said, "My son was a laborer for this man, and he committed illegal sexual intercourse with his wife, and the people told me that my son should be stoned to death, but I have given one-hundred sheep and a slave girl as a ransom (expiation) for my son's sin. Then I asked the religious learned people (about It), and they told me that my son should he flogged one-hundred stripes and should be exiled for one year, and only the wife of this man should be stoned to death " Allah's Apostle said, "By Him in Whose Hand my soul is, I will judge you according to Allah's Laws: O man, as for your sheep and slave girl, they are to be returned to you." Then the Prophet had the man's son flogged one hundred stripes and exiled for one year, and ordered Unais Al-Aslami to go to the wife of the other man, and if she confessed, stone her to death. She confessed and was stoned to death.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.827]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 827

Narrated 'Aisha:

Abu Bakr came to me while Allah's Apostle was sleeping with his head on my thigh. Abu Bakr said (to me), "You have detained Allah's Apostle and the people, and there is no water in this place." So he admonished me and struck my flanks with his hand, and nothing could stop me from moving except the reclining of Allah's Apostle (on my thigh), and then Allah revealed the Divine Verse of Tayammum.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.828]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 828

Narrated Aisha:

Abu Bakr came to towards me and struck me violently with his fist and said, "You have detained the people because of your necklace." But I remained motionless as if I was dead lest I should awake Allah's Apostle although that hit was very painful.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.829]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 829

Narrated Al-Mughira:

Sa'd bin Ubada said, "If I found a man with my wife, I would kill him with the sharp side of my sword." When the Prophet heard that he said, "Do you wonder at Sa'd's sense of ghira (self-respect)? Verily, I have more sense of ghira than Sa'd, and Allah has more sense of ghira than I."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.830]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 830

Narrated Abu Huraira:

A bedouin came to Allah's Apostle and said, "My wife has delivered a black child." The Prophet said to him, "Have you camels?" He replied, "Yes." The Prophet said, "What color are they?" He replied, "They are red." The Prophet further asked, "Are any of them gray in color?" He replied, "Yes." The Prophet asked him, "Whence did that grayness come?" He said, "I thing it descended from the camel's ancestors." Then the Prophet said (to him), "Therefore, this child of yours has most probably inherited the color from his ancestors."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.831]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 831

Narrated Abu Burda:

The Prophet used to say, "Nobody should be flogged more than ten stripes except if he is guilty of a crime, the legal punishment of which is assigned by Allah."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.832]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 832

Narrated 'Abdur-Rahman bin Jabir:

On the authority of others, that the Prophet said, "No Punishment exceeds the flogging of the ten stripes, except if one is guilty of a crime necessitating a legal punishment prescribed by Allah."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.833]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 833

Narrated Abu Burda Al-Ansari:

I heard the Prophet saying, "Do not flog anyone more than ten stripes except if he is involved in a crime necessitating Allah's legal Punishment."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.834]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 834

Narrated Abu Huraira:

Allah's Apostle forbade Al-Wisal (fasting continuously for more than one day without taking any meals). A man from the Muslims said, "But you do Al-Wisal, O Allah's Apostle!" Allah's Apostle I said, "Who among you is similar to me? I sleep and my Lord makes me eat and drink." When the people refused to give up Al-Wisal, the Prophet fasted along with them for one day, and did not break his fast but continued his fast for another day, and when they saw the crescent, the Prophet said, "If the crescent had not appeared, I would have made you continue your fast (for a third day)," as if he wanted to punish them for they had refused to give up Al-Wisal.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.835]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 835

Narrated 'Abdullah bin 'Umar:

Those people who used to buy foodstuff at random (without weighing or measuring it) were beaten in the lifetime of Allah's Apostle if they sold it at the very place where they had bought it, till they carried it to their dwelling places.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.836]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 836

Narrated 'Aisha:

Allah's Apostle never took revenge for his own self in any matter presented to him till Allah's limits were exceeded, in which case he would take revenge for Allah's sake.


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.837]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 837

Narrated Sahl bin Sa'd:

I witnessed the case of Lian (the case of a man who charged his wife for committing illegal sexual intercourse when I was fifteen years old. The Prophet ordered that they be divorced, and the husband said, "If I kept her, I would be a liar." I remember that Az-Zubair also said, "(It was said) that if that woman brought forth the child with such-and-such description, her husband would prove truthful, but if she brought it with such-and-such description looking like a Wahra (a red insect), he would prove untruthful." I heard Az-Zubair also saying, "Finally she gave birth to a child of description which her husband disliked .


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.838]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 838

Narrated Al-Qasim bin Muhammad:

Ibn 'Abbas mentioned the couple who had taken the oath of Lian. 'Abdullah bin Shaddad said (to him), "Was this woman about whom Allah's Apostle said, 'If I were ever to stone to death any woman without witnesses. (I would have stoned that woman to death)?' Ibn 'Abbas replied," No, that lady exposed herself (by her suspicious behavior)."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.839]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 839

Narrated Ibn Abbas:

Lian was mentioned in the presence of the Prophet, Asim bin Adi said a statement about it, and when he left, a man from his tribe came to him complaining that he had seen a man with his wife. Asim said, "I have been put to trial only because of my statement." So he took the man to the Prophet and the man told him about the incident. The man (husband) was of yellow complexion, thin, and of lank hair, while the man whom he had accused of having been with his wife, was reddish brown with fat thick legs and fat body. The Prophet said, "O Allah! Reveal the truth." Later on the lady delivered a child resembling the man whom the husband had accused of having been with her. So the Prophet made them take the oath of Lian. A man said to Ibn Abbas in the gathering, "Was that the same lady about whom the Prophet said, "If I were to stone any lady (for committing illegal sexual intercourse) to death without witnesses, I would have stoned that lade to death?" Ibn Abbas said, "No, that was another lady who used to behave in such a suspicious way among the Muslims that one might accuse her of committing illegal sexual intercourse."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.840]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 840

Narrated Abu Huraira:

The Prophet said, "Avoid the seven great destructive sins." They (the people!) asked, "O Allah's Apostle! What are they?" He said, "To join partners in worship with Allah; to practice sorcery; to kill the life which Allah has forbidden except for a just cause (according to Islamic law); to eat up usury (Riba), to eat up the property of an orphan; to give one's back to the enemy and freeing from the battle-field at the time of fighting and to accuse chaste women who never even think of anything touching chastity and are good believers."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.841]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 841

Narrated Abu Huraira:

I heard Abu-l-Qasim (the Prophet) saying, "If somebody slanders his slave and the slave is free from what he says, he will be flogged on the Day of Resurrection unless the slave is really as he has described him."


Bukhari :: Punishment of Disbelievers at War with Allah and His Apostle :: [8.82.842]

Punishment of Disbelievers at War with Allah and His Apostle

Bukhari :: Book 8 :: Volume 82 :: Hadith 842

Narrated Abu Huraira and Zaid bin Khalid Al-Juhani:

A man came to the Prophet and said, "I beseech you to judge us according to Allah's Laws." Then his opponent who was wiser than he, got up and said, "He has spoken the truth. So judge us according to Allah's Laws and please allow me (to speak), O Allah's Apostle." The Prophet said, "Speak." He said, "My son was a laborer for the family of this man and he committed illegal sexual intercourse with his wife, and I gave one-hundred sheep and a slave as a ransom (for my son), but I asked the religious learned people (regarding this case), and they informed me that my son should be flogged one-hundred stripes, and be exiled for one year, and the wife of this man should be stoned (to death)."The Prophet said, "By Him in Whose Hand my soul is, I will Judge you (in this case) according to Allah's Laws. The one-hundred (sheep) and the slave shall be returned to you and your son shall be flogged one-hundred stripes and be exiled for one year. And O Unais! Go in the morning to the wife of this man and ask her, and if she confesses, stone her to death." She confessed and he stoned her to death.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.1]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 1

Narrated 'Abdullah:

A man said, "O Allah's Apostle! Which sin is the greatest in Allah's Sight?" The Prophet said, "To set up a rival unto Allah though He Alone created you . " The man said, "What is next?" The Prophet said, "To kill your son lest he should share your food with you." The man said, "What is next?" The Prophet said, "To commit illegal sexual intercourse with the wife of your neighbor." So Allah revealed in confirmation of this narration:--

'And those who invoke not with Allah, any other god. Nor kill, such life as Allah has forbidden except for just cause nor commit illegal sexual intercourse. And whoever does this shall receive the punishment.' (25.68)


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.2]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 2

Narrated Ibn 'Umar:

Allah's Apostle said, "A faithful believer remains at liberty regarding his religion unless he kills somebody unlawfully."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.3]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 3

Narrated 'Abdullah bin 'Umar:

One of the evil deeds with bad consequence from which there is no escape for the one who is involved in it is to kill someone unlawfully.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.4]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 4

Narrated 'Abdullah:

The Prophet said, "The first cases to be decided among the people (on the Day of Resurrection) will be those of blood-shed."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.5]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 5

Narrated Al-Miqdad bin 'Amr Al-Kindi:

An ally of Bani Zuhra who took part in the battle of Badr with the Prophet, that he said, "O Allah's Apostle! If I meet an unbeliever and we have a fight, and he strikes my hand with the sword and cuts it off, and then takes refuge from me under a tree, and says, 'I have surrendered to Allah (i.e. embraced Islam),' may I kill him after he has said so?" Allah's Apostle said, "Do not kill him." Al-Miqdad said, "But O Allah's Apostle! He had chopped off one of my hands and he said that after he had cut it off. May I kill him?" The Prophet said. "Do not kill him for if you kill him, he would be in the position in which you had been before you kill him, and you would be in the position in which he was before he said the sentence." The Prophet also said to Al-Miqdad, "If a faithful believer conceals his faith (Islam) from the disbelievers, and then when he declares his Islam, you kill him, (you will be sinful). Remember that you were also concealing your faith (Islam) at Mecca before."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.6]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 6

Narrated 'Abdullah:

The Prophet said, "No human being is killed unjustly, but a part of responsibility for the crime is laid on the first son of Adam who invented the tradition of killing (murdering) on the earth. (It is said that he was Qabil).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.7]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 7

Narrated 'Abdullah bin 'Umar:

The Prophet said, "After me (i.e. after my death), do not become disbelievers, by striking (cutting) the necks of one another.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.8]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 8

Narrated Abu Zur'a bin 'Amr bin Jarir:

The Prophet said during Hajjat-al-Wada', "Let the people be quiet and listen to me. After me, do not become disbelievers, by striking (cutting) the necks of one another."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.9]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 9

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Al-Kaba'ir (the biggest sins) are: To join others (as partners) in worship with Allah, to be undutiful to one's parents," or said, "to take a false oath." (The sub-narrator, Shu'ba is not sure) Mu'adh said: Shu'ba said, "Al-kaba'ir (the biggest sins) are: (1) Joining others as partners in worship with Allah, (2) to take a false oath (3) and to be undutiful to one's parents," or said, "to murder (someone unlawfully).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.10]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 10

Narrated Anas bin Malik:

The Prophet said, "The biggest of Al-Kaba'ir (the great sins) are (1) to join others as partners in worship with Allah, (2) to murder a human being, (3) to be undutiful to one's parents (4) and to make a false statement," or said, "to give a false witness."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.11]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 11

Narrated Usama bin Zaid bin Haritha:

Allah's Apostle sent us (to fight) against Al-Huraqa (one of the sub-tribes) of Juhaina. We reached those people in the morning and defeated them. A man from the Ansar and I chased one of their men and when we attacked him, he said, "None has the right to be worshipped but Allah." The Ansari refrained from killing him but I stabbed him with my spear till I killed him. When we reached (Medina), this news reached the Prophet. He said to me, "O Usama! You killed him after he had said, 'None has the right to be worshipped but Allah?"' I said, "O Allah's Apostle! He said so in order to save himself." The Prophet said, "You killed him after he had said, 'None has the right to be worshipped but Allah." The Prophet kept on repeating that statement till I wished I had not been a Muslim before that day.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.12]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 12

Narrated 'Ubada bin As-Samat:

I was among those Naqibs (selected leaders) who gave the Pledge of allegiance to Allah's Apostle. We gave the oath of allegiance, that we would not join partners in worship besides Allah, would not steal, would not commit illegal sexual intercourse, would not kill a life which Allah has forbidden, would not commit robbery, would not disobey (Allah and His Apostle), and if we fulfilled this pledge we would have Paradise, but if we committed any one of these (sins), then our case will be decided by Allah.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.13]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 13

Narrated 'Abdullah:

The Prophet said, "Whoever carries arms against us, is not from us."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.14]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 14

Narrated Al-Ahnaf bin Qais:

I went to help that man (i.e., 'Ali), and on the way I met Abu Bakra who asked me, "Where are you going?" I replied, "I am going to help that man." He said, "Go back, for I heard Allah's Apostle saying, 'If two Muslims meet each other with their swords then (both) the killer and the killed one are in the (Hell) Fire.' I said, 'O Allah's Apostle! It is alright for the killer, but what about the killed one?' He said, 'The killed one was eager to kill his opponent."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.15]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 15

Narrated Anas bin Malik:

A Jew crushed the head of a girl between two stones, and the girl was asked, "Who has done that to you, so-and-so or so and so?" (Some names were mentioned for her) till the name of that Jew was mentioned (whereupon she agreed). The Jew was brought to the Prophet and the Prophet kept on questioning him till he confessed, whereupon his head was crushed with stones.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.16]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 16

Narrated Anas bin Malik:

A girl wearing ornaments, went out at Medina. Somebody struck her with a stone. She was brought to the Prophet while she was still alive. Allah's Apostle asked her, "Did such-and-such a person strike you?" She raised her head, denying that. He asked her a second time, saying, "Did so-and-so strike you?" She raised her head, denying that. He said for the third time, "Did so-and-so strike you?" She lowered her head, agreeing. Allah's Apostle then sent for the killer and killed him between two stones.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.17]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 17

Narrated 'Abdullah:

Allah's Apostle said, "The blood of a Muslim who confesses that none has the right to be worshipped but Allah and that I am His Apostle, cannot be shed except in three cases: In Qisas for murder, a married person who commits illegal sexual intercourse and the one who reverts from Islam (apostate) and leaves the Muslims."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.18]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 18

Narrated Anas:

A Jew killed a girl so that he may steal her ornaments. He struck her with a stone, and she was brought to the Prophet while she was still alive. The Prophet asked her, "Did such-and-such person strike you?" She gestured with her head, expressing denial. He asked her for the second time, and she again gestured with her head, expressing denial. When he asked her for the third time, she beckoned, "Yes." So the Prophet killed him (the Jew) with two stones.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.19]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 19

Narrated Abu Huraira:

In the year of the Conquest of Mecca, the tribe of Khuza'a killed a man from the tribe of Bam Laith in revenge for a killed person belonging to them in the Pre-lslamic Period of Ignorance. So Allah's Apostle got up saying, "Allah held back the (army having) elephants from Mecca, but He let His Apostle and the believers overpower the infidels (of Mecca). Beware! (Mecca is a sanctuary)! Verily! Fighting in Mecca was not permitted for anybody before me, nor will it be permitted for anybody after me; It was permitted for me only for a while (an hour or so) of that day. No doubt! It is at this moment a sanctuary; its thorny shrubs should not be uprooted; its trees should not be cut down; and its Luqata (fallen things) should not be picked up except by the one who would look for its owner. And if somebody is killed, his closest relative has the right to choose one of two things, i.e., either the Blood money or retaliation by having the killer killed." Then a man from Yemen, called Abu Shah, stood up and said, "Write that) for me, O Allah's Apostle!" Allah's Apostle said (to his companions), "Write that for Abu Shah." Then another man from Quraish got up, saying, "O Allah's Apostle! Except Al-Idhkhir (a special kind of grass) as we use it in our houses and for graves." Allah's Apostle said, "Except Al-idhkkir."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.20]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 20

Narrated Ibn 'Abbas:

For the children of Israel the punishment for crime was Al-Qisas only (i.e., the law of equality in punishment) and the payment of Blood money was not permitted as an alternate. But Allah said to this nation (Muslims): 'O you who believe! Qisas is prescribed for you in case of murder, .....(up to) ...end of the Verse. (2.178)

Ibn 'Abbas added: Remission (forgiveness) in this Verse, means to accept the Blood-money in an intentional murder. Ibn 'Abbas added: The Verse: 'Then the relatives should demand Blood-money in a reasonable manner.' (2.178) means that the demand should be reasonable and it is to be compensated with handsome gratitude.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.21]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 21

Narrated Ibn 'Abbas:

The Prophet said, "The most hated persons to Allah are three: (1) A person who deviates from the right conduct, i.e., an evil doer, in the Haram (sanctuaries of Mecca and Medina); (2) a person who seeks that the traditions of the Pre-lslamic Period of Ignorance, should remain in Islam (3) and a person who seeks to shed somebody's blood without any right."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.22]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 22

Narrated 'Aisha:

The pagans were defeated on the day (of the battle) of Uhud. Satan shouted among the people on the day of Uhud, "O Allah's worshippers! Beware of what is behind you!" So the front file of the army attacked the back files (mistaking them for the enemy) till they killed Al-Yaman. Hudhaifa (bin Al-Yaman) shouted, "My father!" My father! But they killed him. Hudhaifa said, "May Allah forgive you." (The narrator added: Some of the defeated pagans fled till they reached Taif.)


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.23]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 23

Narrated Anas bin Malik:

A Jew crushed the head of a girl between two stones. It was said to her. "Who has done this to you, such-and-such person, such-and-such person?" When the name of the Jew was mentioned, she nodded with her head, agreeing. So the Jew was brought and he confessed. The Prophet ordered that his head be crushed with the stones. (Hammam said, "with two stones.")


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.24]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 24

Narrated Anas bin Malik: The Prophet killed a Jew for killing a girl in order to take her orna


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.25]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 25

Narrated 'Aisha:

We poured medicine into the mouth of the Prophet during his ailment. He said, "Don't pour medicine into my mouth." (We thought he said that) out of the aversion a patient usually has for medicines. When he improved and felt better he said, "There is none of you but will be forced to drink medicine, except Al-'Abbas, for he did not witness your deed."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.26]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 26

Narrated Abu Huraira:

That he heard Allah's Apostle saying, "We (Muslims) are the last (to come) but (will be) the foremost (on the Day of Resurrection)." And added, "If someone is peeping (looking secretly) into your house without your permission, and you throw a stone at him and destroy his eyes, there will be no blame on you."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.27]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 27

Narrated Yahya:

Humaid said, "A man peeped into the house of the Prophet and the Prophet aimed an arrow head at him to hit him." I asked, "Who told you that?" He said, "Anas bin Malik" (See Hadith No. 258 and 259, Vol. 8)


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.28]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 28

Narrated 'Aisha:

"When it was the day of (the battle of) Uhud, the pagans were defeated. Then Satan shouted, "O Allah's worshipers! Beware of what is behind you!" So the front files attacked the back files of the army. Hudhaifa looked, and behold, there was his father, Al-Yaman (being attacked) ! He shouted (to his companions), "O Allah's worshipers, my father, my father!" But by Allah, they did not stop till they killed him (i.e., Hudhaifa's father). Hudhaifa said, "May Allah forgive you." ('Urwa said, Hudhaifa continued asking Allah's Forgiveness for the killer of his father till he died.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.29]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 29

Narrated Salama:

We went out with the Prophet to Khaibar. A man (from the companions) said, "O 'Amir! Let us hear some of your Huda (camel-driving songs.)" So he sang some of them (i.e. a lyric in harmony with the camels walk). The Prophet said, "Who is the driver (of these camels)?" They said, "Amir." The Prophet said, "May Allah bestow His Mercy on him !" The people said, "O Allah's Apostle! Would that you let us enjoy his company longer!" Then 'Amir was killed the following morning. The people said, "The good deeds of 'Amir are lost as he has killed himself." I returned at the time while they were talking about that. I went to the Prophet and said, "O Allah's Prophet! Let my father be sacrificed for you! The people claim that 'Amir's good deeds are lost." The Prophet said, "Whoever says so is a liar, for 'Amir will have a double reward as he exerted himself to obey Allah and fought in Allah's Cause. No other way of killing would have granted him greater reward."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.30]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 30

Narrated 'Imran bin Husain:

A man bit another man's hand and the latter pulled his hand out of his mouth by force, causing two of his incisors (teeth) to fall out. They submitted their case to the Prophet, who said, "One of you bit his brother as a male camel bites. (Go away), there is no Diya (Blood-money) for you."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.31]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 31

Narrated Ya'la:

I went out in one of the Ghazwa and a man bit another man and as a result, an incisor tooth of the former was pulled out. The Prophet cancelled the case.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.32]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 32

Narrated Anas:

The daughter of An-Nadr slapped a girl and broke her incisor tooth. They (the relatives of that girl), came to the Prophet and he gave the order of Qisas (equality in punishment).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.33]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 33

Narrated Ibn 'Abbas:

The Prophet said, "This and this are the same." He meant the little finger and the thumb.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.34]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 34

Narrated Ibn 'Abbas:

I heard the Prophet (saying the same as above Hadith 34).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.35]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 35

Narrated 'Aisha:

We poured medicine into the mouth of Allah's Apostle during his illness, and he pointed out to us intending to say, "Don't pour medicine into my mouth." We thought that his refusal was out of the aversion a patient usually has for medicine. When he improved and felt a bit better he said (to us.) "Didn't I forbid you to pour medicine into my mouth?" We said, "We thought (you did so) because of the aversion, one usually have for medicine." Allah's Apostle said, "There is none of you but will be forced to drink medicine, and I will watch you, except Al-'Abbas, for he did not witness this act of yours."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.36]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 36

Narrated Sahl bin Abi Hathma:

(a man from the Ansar) that a number of people from his tribe went to Khaibar and dispersed, and then they found one of them murdered. They said to the people with whom the corpse had been found, "You have killed our companion!" Those people said, "Neither have we killed him, nor do we know his killer." The bereaved group went to the Prophet and said, "O Allah's Apostle! We went to Khaibar and found one of us murdered." The Prophet said, "Let the older among you come forward and speak." Then the Prophet said, to them, "Bring your proof against the killer." They said "We have no proof." The Prophet said, "Then they (the defendants) will take an oath." They said, "We do not accept the oaths of the Jews." Allah's Apostle did not like that the Blood-money of the killed one be lost without compensation, so he paid one-hundred camels out of the camels of Zakat (to the relatives of the deceased) as Diya (Blood-money).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.37]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 37

Narrated Abu Qilaba:

Once 'Umar bin 'Abdul 'Aziz sat on his throne in the courtyard of his house so that the people might gather before him. Then he admitted them and (when they came in), he said, "What do you think of Al-Qasama?" They said, "We say that it is lawful to depend on Al-Qasama in Qisas, as the previous Muslim Caliphs carried out Qisas depending on it." Then he said to me, "O Abu Qilaba! What do you say about it?" He let me appear before the people and I said, "O Chief of the Believers! You have the chiefs of the army staff and the nobles of the Arabs. If fifty of them testified that a married man had committed illegal sexual intercourse in Damascus but they had not seen him (doing so), would you stone him?" He said, "No." I said, "If fifty of them testified that a man had committed theft in Hums, would you cut off his hand though they did not see him?" He replied, "No." I said, "By Allah, Allah's Apostle never killed anyone except in one of the following three situations: (1) A person who killed somebody unjustly, was killed (in Qisas,) (2) a married person who committed illegal sexual intercourse and (3) a man who fought against Allah and His Apostle and deserted Islam and became an apostate." Then the people said, "Didn't Anas bin Malik narrate that Allah's Apostle cut off the hands of the thieves, branded their eyes and then, threw them in the sun?" I said, "I shall tell you the narration of Anas. Anas said: "Eight persons from the tribe of 'Ukl came to Allah's Apostle and gave the Pledge of allegiance for Islam (became Muslim). The climate of the place (Medina) did not suit them, so they became sick and complained about that to Allah's Apostle. He said (to them ), "Won't you go out with the shepherd of our camels and drink of the camels' milk and urine (as medicine)?" They said, "Yes." So they went out and drank the camels' milk and urine, and after they became healthy, they killed the shepherd of Allah's Apostle and took away all the camels. This news reached Allah's Apostle , so he sent (men) to follow their traces and they were captured and brought (to the Prophet). He then ordered to cut their hands and feet, and their eyes were branded with heated pieces of iron, and then he threw them in the sun till they died." I said, "What can be worse than what those people did? They deserted Islam, committed murder and theft."

Then 'Anbasa bin Said said, "By Allah, I never heard a narration like this of today." I said, "O 'Anbasa! You deny my narration?" 'Anbasa said, "No, but you have related the narration in the way it should be related. By Allah, these people are in welfare as long as this Sheikh (Abu Qilaba) is among them." I added, "Indeed in this event there has been a tradition set by Allah's Apostle. The narrator added: Some Ansari people came to the Prophet and discussed some matters with him, a man from amongst them went out and was murdered. Those people went out after him, and behold, their companion was swimming in blood. They returned to Allah's Apostle and said to him, "O Allah's Apostle, we have found our companion who had talked with us and gone out before us, swimming in blood (killed)." Allah's Apostle went out and asked them, "Whom do you suspect or whom do you think has killed him?" They said, "We think that the Jews have killed him." The Prophet sent for the Jews and asked them, "Did you kill this (person)?" They replied, "No." He asked the Al-Ansars, "Do you agree that I let fifty Jews take an oath that they have not killed him?" They said, "It matters little for the Jews to kill us all and then take false oaths." He said, "Then would you like to receive the Diya after fifty of you have taken an oath (that the Jews have killed your man)?" They said, "We will not take the oath." Then the Prophet himself paid them the Diya (Blood-money)." The narrator added, "The tribe of Hudhail repudiated one of their men (for his evil conduct) in the Pre-lslamic period of Ignorance.

Then, at a place called Al-Batha' (near Mecca), the man attacked a Yemenite family at night to steal from them, but a. man from the family noticed him and struck him with his sword and killed him. The tribe of Hudhail came and captured the Yemenite and brought him to 'Umar during the Hajj season and said, "He has killed our companion." The Yemenite said, "But these people had repudiated him (i.e., their companion)." 'Umar said, "Let fifty persons of Hudhail swear that they had not repudiated him." So forty-nine of them took the oath and then a person belonging to them, came from Sham and they requested him to swear similarly, but he paid one-thousand Dirhams instead of taking the oath. They called another man instead of him and the new man shook hands with the brother of the deceased. Some people said, "We and those fifty men who had taken false oaths (Al-Qasama) set out, and when they reached a place called Nakhlah, it started raining so they entered a cave in the mountain, and the cave collapsed on those fifty men who took the false oath, and all of them died except the two persons who had shaken hands with each other. They escaped death but a stone fell on the leg of the brother of the deceased and broke it, whereupon he survived for one year and then died." I further said, "'Abdul Malik bin Marwan sentenced a man to death in Qisas (equality in punishment) for murder, basing his judgment on Al-Qasama, but later on he regretted that judgment and ordered that the names of the fifty persons who had taken the oath (Al-Qasama), be erased from the register, and he exiled them in Sham."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.38]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 38

Narrated Sahl bin Sa'd As-Sa'idi:

A man peeped through a hole in the door of Allah's Apostle's house, and at that time, Allah's Apostle had a Midri (an iron comb or bar) with which he was rubbing his head. So when Allah's Apostle saw him, he said (to him), "If I had been sure that you were looking at me (through the door), I would have poked your eye with this (sharp iron bar)." Allah's Apostle added, "The asking for permission to enter has been enjoined so that one may not look unlawfully (at what there is in the house without the permission of its people)."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.39]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 39

Narrated Abu Huraira:

Abul Qasim said, "If any person peeps at you without your permission and you poke him with a stick and injure his eye, you will not be blamed."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.40]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 40

Narrated Ash-Sha'bi:

liever." (See Hadith No. 283,Vol. 4)


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.41]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 41

Narrated Abu Huraira:

Two women from the tribe of Hudhail (fought with each other) and one of them threw (a stone at) the other, causing her to have a miscarriage and Allah's Apostle gave his verdict that the killer (of the fetus) should give a male or female slave (as a Diya).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.42]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 42

Narrated Hisham's father:

'Umar asked the people, "Who heard the Prophet giving his verdict regarding abortions?" Al-Mughira said, "I heard him judging that a male or female slave should be given (as a Diya)." 'Umar said, "Present a witness to testify your statement." Muhammad bin Maslama said, "I testify that the Prophet gave such a judgment."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.43]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 43

Narrated 'Urwa:

I heard Al-Maghira bin Shu'ba narrating that 'Umar had consulted them about the case of abortion (similarly as narrated in No. 42).


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.44]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 44

Narrated Abu Huraira:

Allah's Apostle gave a verdict regarding an aborted fetus of a woman from Bani Lihyan that the killer (of the fetus) should give a male or female slave (as a Diya) but the woman who was required to give the slave, died, so Allah's Apostle gave the verdict that her inheritance be given to her children and her husband and the Diya be paid by her 'Asaba.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.45]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 45

Narrated Abu Huraira:

Two women from Hudhail fought with each other and one of them hit the other with a stone that killed her and what was in her womb. The relatives of the killer and the relatives of the victim submitted their case to the Prophet who judged that the Diya for the fetus was a male or female slave, and the Diya for the killed woman was to be paid by the 'Asaba (near relatives) of the killer.


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.46]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 46

Narrated 'Abdul-'Aziz:

Anas said, "When Allah's Apostle arrived at Medina, Abu Talha took hold of my hand and brought me to Allah's Apostle and said, "O Allah's Apostle! Anas is an intelligent boy, so let him serve you." Anas added, "So I served the Prophet L at home and on journeys; by Allah, he never said to me for anything which I did: Why have you done this like this or, for anything which I did not do: 'Why have you not done this like this?"


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.47]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 47

Narrated Abu Huraira:

Allah's Apostle said, "There is no Diya for persons killed by animals or for the one who has been killed accidentally by falling into a well or for the one killed in a mine. And one-fifth of Rikaz (treasures buried before the Islamic era) is to be given to the state."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.48]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 48

Narrated Abu Huraira:

The Prophet said, "There is no Diya for a person injured or killed by an animal (going about without somebody to control it) and similarly, there is no Diya for the one who falls and dies in a well, and also the one who dies in a mine. As regards the Ar-Rikaz (buried wealth), one-fifth thereof is for the state."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.49]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 49

Narrated 'Abdullah bin 'Amr:

The Prophet said, "Whoever killed a Mu'ahid (a person who is granted the pledge of protection by the Muslims) shall not smell the fragrance of Paradise though its fragrance can be smelt at a distance of forty years (of traveling)."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.50]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 50

Narrated Abu Juhaifa:

I asked 'Ali "Do you have anything Divine literature besides what is in the Qur'an?" Or, as Uyaina once said, "Apart from what the people have?" 'Ali said, "By Him Who made the grain split (germinate) and created the soul, we have nothing except what is in the Quran and the ability (gift) of understanding Allah's Book which He may endow a man, with and what is written in this sheet of paper." I asked, "What is on this paper?" He replied, "The legal regulations of Diya (Blood-money) and the (ransom for) releasing of the captives, and the judgment that no Muslim should be killed in Qisas (equality in punishment) for killing a Kafir (disbeliever)."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.51]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 51

Narrated Abu Said:

The Prophet said, "Do not prefer some prophets to others."


Bukhari :: Blood Money (Ad-Diyat) :: [9.83.52]

Blood Money (Ad-Diyat)

Bukhari :: Book 9 :: Volume 83 :: Hadith 52

Narrated Abu Said Al-Khudri:

A Jew whose face had been slapped (by someone), came to the Prophet and said, "O Muhammad! A man from your Ansari companions slapped me. " The Prophet said, "Call him". They called him and the Prophet asked him, "Why did you slap his face?" He said, "O Allah's Apostle! While I was passing by the Jews, I heard him saying, 'By Him Who chose Moses above all the human beings.' I said (protestingly), 'Even above Muhammad?' So I became furious and slapped him." The Prophet said, "Do not give me preference to other prophets, for the people will become unconscious on the Day of Resurrection and I will be the first to gain conscious, and behold, I will Find Moses holding one of the pillars of the Throne (of Allah). Then I will not know whether he has become conscious before me or he has been exempted because of his unconsciousness at the mountain (during his worldly life) which he received."


Bukhari :: Dealing with Apostates :: [9.84.53]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 53

Narrated 'Abdullah:

When the Verse: 'It is those who believe and confuse not their belief with wrong (i.e., worshipping others besides Allah): (6.82) was revealed, it became very hard on the companions of the Prophet and they said, "Who among us has not confused his belief with wrong (oppression)?" On that, Allah's Apostle said, "This is not meant (by the Verse). Don't you listen to Luqman's statement: 'Verily! Joining others in worship with Allah is a great wrong indeed.' (31.13)


Bukhari :: Dealing with Apostates :: [9.84.54]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 54

Narrated Abu Bakra:

The Prophet. said, "The biggest of the great sins are: To join others in worship with Allah, to be undutiful to one's parents, and to give a false witness." He repeated it thrice, or said, "....a false statement," and kept on repeating that warning till we wished he would stop saying it. (See Hadith No.7, Vol. 8)


Bukhari :: Dealing with Apostates :: [9.84.55]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 55

Narrated 'Abdullah bin 'Amr:

A bedouin came to the Prophet and said, "O Allah's Apostle! What are the biggest sins?: The Prophet said, "To join others in worship with Allah." The bedouin said, "What is next?" The Prophet said, "To be undutiful to one's parents." The bedouin said "What is next?" The Prophet said "To take an oath 'Al-Ghamus." The bedouin said, "What is an oath 'Al-Ghamus'?" The Prophet said, "The false oath through which one deprives a Muslim of his property (unjustly)."


Bukhari :: Dealing with Apostates :: [9.84.56]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 56

Narrated Ibn Mas'ud:

A man said, "O Allah's Apostle! Shall we be punished for what we did in the Prelslamic Period of ignorance?" The Prophet said, "Whoever does good in Islam will not be punished for what he did in the Pre-lslamic Period of ignorance and whoever does evil in Islam will be punished for his former and later (bad deeds)."


Bukhari :: Dealing with Apostates :: [9.84.57]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 57

Narrated 'Ikrima:

Some Zanadiqa (atheists) were brought to 'Ali and he burnt them. The news of this event, reached Ibn 'Abbas who said, "If I had been in his place, I would not have burnt them, as Allah's Apostle forbade it, saying, 'Do not punish anybody with Allah's punishment (fire).' I would have killed them according to the statement of Allah's Apostle, 'Whoever changed his Islamic religion, then kill him.'"


Bukhari :: Dealing with Apostates :: [9.84.58]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 58

Narrated Abu Burda:

Abu Musa said, "I came to the Prophet along with two men (from the tribe) of Ash'ariyin, one on my right and the other on my left, while Allah's Apostle was brushing his teeth (with a Siwak), and both men asked him for some employment. The Prophet said, 'O Abu Musa (O 'Abdullah bin Qais!).' I said, 'By Him Who sent you with the Truth, these two men did not tell me what was in their hearts and I did not feel (realize) that they were seeking employment.' As if I were looking now at his Siwak being drawn to a corner under his lips, and he said, 'We never (or, we do not) appoint for our affairs anyone who seeks to be employed. But O Abu Musa! (or 'Abdullah bin Qais!) Go to Yemen.'" The Prophet then sent Mu'adh bin Jabal after him and when Mu'adh reached him, he spread out a cushion for him and requested him to get down (and sit on the cushion). Behold: There was a fettered man beside Abu Muisa. Mu'adh asked, "Who is this (man)?" Abu Muisa said, "He was a Jew and became a Muslim and then reverted back to Judaism." Then Abu Muisa requested Mu'adh to sit down but Mu'adh said, "I will not sit down till he has been killed. This is the judgment of Allah and His Apostle (for such cases) and repeated it thrice. Then Abu Musa ordered that the man be killed, and he was killed. Abu Musa added, "Then we discussed the night prayers and one of us said, 'I pray and sleep, and I hope that Allah will reward me for my sleep as well as for my prayers.'"


Bukhari :: Dealing with Apostates :: [9.84.59]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 59

Narrated Abu Huraira:

When the Prophet died and Abu Bakr became his successor and some of the Arabs reverted to disbelief, 'Umar said, "O Abu Bakr! How can you fight these people although Allah's Apostle said, 'I have been ordered to fight the people till they say: 'None has the right to be worshipped but Allah, 'and whoever said, 'None has the right to be worshipped but Allah', Allah will save his property and his life from me, unless (he does something for which he receives legal punishment) justly, and his account will be with Allah?' "Abu Bakr said, "By Allah! I will fight whoever differentiates between prayers and Zakat as Zakat is the right to be taken from property (according to Allah's Orders). By Allah! If they refused to pay me even a kid they used to pay to Allah's Apostle, I would fight with them for withholding it." 'Umar said, "By Allah: It was nothing, but I noticed that Allah opened Abu Bakr's chest towards the decision to fight, therefore I realized that his decision was right."


Bukhari :: Dealing with Apostates :: [9.84.60]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 60

Narrated Anas bin Malik:

A Jew passed by Allah's Apostle and said, "As-Samu 'Alaika." Allah's Apostle said in reply, "We 'Alaika." Allah's Apostle then said to his companions, "Do you know what he (the Jew) has said? He said, 'As-Samu 'Alaika.'" They said, "O Allah's Apostle! Shall we kill him?" The Prophet, said, "No. When the people of the Book greet you, say: 'Wa 'Alaikum.'"


Bukhari :: Dealing with Apostates :: [9.84.61]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 61

Narrated 'Aisha:

A group of Jews asked permission to visit the Prophet (and when they were admitted) they said, "As-Samu 'Alaika (Death be upon you)." I said (to them), "But death and the curse of Allah be upon you!" The Prophet said, "O 'Aisha! Allah is kind and lenient and likes that one should be kind and lenient in all matters." I said, "Haven't you heard what they said?" He said, "I said (to them), 'Wa 'Alaikum (and upon you).


Bukhari :: Dealing with Apostates :: [9.84.62]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 62

Narrated Ibn 'Umar:

Allah's Apostle said, "When the Jews greet anyone of you they say: 'Sam'Alaika (death be upon you); so you should say; 'Wa 'Alaika (and upon you).'"


Bukhari :: Dealing with Apostates :: [9.84.63]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 63

Narrated 'Abdullah:

As if I am looking at the Prophet while he was speaking about one of the prophets whose people have beaten and wounded him, and he was wiping the blood off his face and saying, "O Lord! Forgive my, people as they do not know."


Bukhari :: Dealing with Apostates :: [9.84.64]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 64

Narrated 'Ali:

Whenever I tell you a narration from Allah's Apostle, by Allah, I would rather fall down from the sky than ascribe a false statement to him, but if I tell you something between me and you (not a Hadith) then it was indeed a trick (i.e., I may say things just to cheat my enemy). No doubt I heard Allah's Apostle saying, "During the last days there will appear some young foolish people who will say the best words but their faith will not go beyond their throats (i.e. they will have no faith) and will go out from (leave) their religion as an arrow goes out of the game. So, where-ever you find them, kill them, for who-ever kills them shall have reward on the Day of Resurrection."


Bukhari :: Dealing with Apostates :: [9.84.65]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 65

Narrated 'Abdullah bin 'Amr bin Yasar:

That they visited Abu Sa'id Al-Khudri and asked him about Al-Harauriyya, a special unorthodox religious sect, "Did you hear the Prophet saying anything about them?" Abu Sa'id said, "I do not know what Al-Harauriyya is, but I heard the Prophet saying, "There will appear in this nation---- he did not say: From this nation ---- a group of people so pious apparently that you will consider your prayers inferior to their prayers, but they will recite the Quran, the teachings of which will not go beyond their throats and will go out of their religion as an arrow darts through the game, whereupon the archer may look at his arrow, its Nasl at its Risaf and its Fuqa to see whether it is blood-stained or not (i.e. they will have not even a trace of Islam in them)."


Bukhari :: Dealing with Apostates :: [9.84.66]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 66

Narrated 'Abdullah bin 'Umar:

Regarding Al-Harauriyya: The Prophet said, "They will go out of Islam as an arrow darts out of the game's body.'


Bukhari :: Dealing with Apostates :: [9.84.67]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 67

Narrated Abu Sa'id:

While the Prophet was distributing (something, 'Abdullah bin Dhil Khawaisira At-Tamimi came and said, "Be just, O Allah's Apostle!" The Prophet said, "Woe to you ! Who would be just if I were not?" 'Umar bin Al-Khattab said, "Allow me to cut off his neck ! " The Prophet said, " Leave him, for he has companions, and if you compare your prayers with their prayers and your fasting with theirs, you will look down upon your prayers and fasting, in comparison to theirs. Yet they will go out of the religion as an arrow darts through the game's body in which case, if the Qudhadh of the arrow is examined, nothing will be found on it, and when its Nasl is examined, nothing will be found on it; and then its Nadiyi is examined, nothing will be found on it. The arrow has been too fast to be smeared by dung and blood. The sign by which these people will be recognized will be a man whose one hand (or breast) will be like the breast of a woman (or like a moving piece of flesh). These people will appear when there will be differences among the people (Muslims)." Abu Sa'id added: I testify that I heard this from the Prophet and also testify that 'Ali killed those people while I was with him. The man with the description given by the Prophet was brought to 'Ali. The following Verses were revealed in connection with that very person (i.e., 'Abdullah bin Dhil-Khawaisira At-Tarnimi): 'And among them are men who accuse you (O Muhammad) in the matter of (the distribution of) the alms.' (9.58)


Bukhari :: Dealing with Apostates :: [9.84.68]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 68

Narrated Yusair bin 'Amr:

I asked Sahl bin Hunaif, "Did you hear the Prophet saying anything about Al-Khawarij?" He said, "I heard him saying while pointing his hand towards Iraq. "There will appear in it (i.e, Iraq) some people who will recite the Quran but it will not go beyond their throats, and they will go out from (leave) Islam as an arrow darts through the game's body.' "


Bukhari :: Dealing with Apostates :: [9.84.69]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 69

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established till two (huge) groups fight against each other, their claim being one and the same."


Bukhari :: Dealing with Apostates :: [9.84.70]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 70

Narrated 'Abdullah:

When the Verse:--'Those who believe and did not confuse their belief with wrong (worshipping others besides Allah).' (6.82) was revealed, it was hard on the companions of the Prophet and they said, "Who among us has not wronged (oppressed) himself?" Allah's Apostle said, "The meaning of the Verse is not as you think, but it is as Luqman said to his son, 'O my son! Join not in worship others with Allah, Verily! Joining others in worship with Allah is a great wrong indeed.'" (31.13)


Bukhari :: Dealing with Apostates :: [9.84.71]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 71

Narrated 'Itban bin Malik:

Once Allah's Apostle came to me in the morning, and a man among us said, "Where is Malik bin Ad-Dukhshun?" Another man from us replied, "He is a hypocrite who does not love Allah and His Apostle." The Prophet said, "Don't you think that he says: None has the right to be worshipped but Allah, only for Allah's sake?" They replied, "Yes" The Prophet said, "Nobody will meet Allah with that saying on the Day of Resurrection, but Allah will save him from the Fire."


Bukhari :: Dealing with Apostates :: [9.84.72]

Dealing with Apostates

Bukhari :: Book 9 :: Volume 84 :: Hadith 72

Narrated:

Abu 'Abdur-Rahman and Hibban bin 'Atiyya had a dispute. Abu 'Abdur-Rahman said to Hibban, "You know what made your companions (i.e. Ali) dare to shed blood." Hibban said, "Come on! What is that?" 'Abdur-Rahman said, "Something I heard him saying." The other said, "What was it?" 'AbdurRahman said, "'Ali said, Allah's Apostle sent for me, Az-Zubair and Abu Marthad, and all of us were cavalry men, and said, 'Proceed to Raudat-Hajj (Abu Salama said that Abu 'Awana called it like this, i.e., Hajj where there is a woman carrying a letter from Hatib bin Abi Balta'a to the pagans (of Mecca). So bring that letter to me.' So we proceeded riding on our horses till we overtook her at the same place of which Allah's Apostle had told us. She was traveling on her camel. In that letter Hatib had written to the Meccans about the proposed attached of Allah's Apostle against them. We asked her, "Where is the letter which is with you?' She replied, 'I haven't got any letter.' So we made her camel kneel down and searched her luggage, but we did not find anything. My two companions said, 'We do not think that she has got a letter.' I said, 'We know that Allah's Apostle has not told a lie.'"

Then 'Ali took an oath saying, "By Him by Whom one should swear! You shall either bring out the letter or we shall strip off your clothes." She then stretched out her hand for her girdle (round her waist) and brought out the paper (letter). They took the letter to Allah's Apostle. 'Umar said, "O Allah's Apostle! (Hatib) has betrayed Allah, His Apostle and the believers; let me chop off his neck!" Allah's Apostle said, "O Hatib! What obliged you to do what you have done?" Hatib replied, "O Allah's Apostle! Why (for what reason) should I not believe in Allah and His Apostle? But I intended to do the (Mecca) people a favor by virtue of which my family and property may be protected as there is none of your companions but has some of his people (relatives) whom Allah urges to protect his family and property." The Prophet said, "He has said the truth; therefore, do not say anything to him except good." 'Umar again said, "O Allah's Apostle! He has betrayed Allah, His Apostle and the believers; let me chop his neck off!" The Prophet said, "Isn't he from those who fought the battle of Badr? And what do you know, Allah might have looked at them (Badr warriors) and said (to them), 'Do what you like, for I have granted you Paradise?' " On that, 'Umar's eyes became flooded with tears and he said, "Allah and His Apostle know best."


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.73]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 73

Narrated Abi Huraira:

The Prophet used to invoke Allah in his prayer, "O Allah! Save 'Aiyash bin Abi Rabi'a and Salama bin Hisham and Al-Walid bin Al-Walid; O Allah! Save the weak among the believers; O Allah! Be hard upon the tribe of Mudar and inflict years (of famine) upon them like the (famine) years of Joseph."


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.74]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 74

Narrated Anas:

Allah's Apostle said, "Whoever possesses the (following) three qualities will have the sweetness of faith (1): The one to whom Allah and His Apostle becomes dearer than anything else; (2) Who loves a person and he loves him only for Allah's Sake; (3) who hates to revert to atheism (disbelief) as he hates to be thrown into the Fire."


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.75]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 75

Narrated Qais:

I heard Sa'id bin Zaid saying, "I have seen myself tied and forced by 'Umar to leave Islam (Before 'Umar himself embraced Islam). And if the mountain of Uhud were to collapse for the evil which you people had done to 'Uthman, then Uhud would have the right to do so." (See Hadith No. 202, Vol. 5)


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.76]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 76

Narrated Khabbab bin Al-Art:

We complained to Allah's Apostle (about our state) while he was leaning against his sheet cloak in the shade of the Ka'ba. We said, "Will you ask Allah to help us? Will you invoke Allah for us?" He said, "Among those who were before you a (believer) used to be seized and, a pit used to be dug for him and then he used to be placed in it. Then a saw used to be brought and put on his head which would be split into two halves. His flesh might be combed with iron combs and removed from his bones, yet, all that did not cause him to revert from his religion. By Allah! This religion (Islam) will be completed (and triumph) till a rider (traveler) goes from San'a' (the capital of Yemen) to Hadramout fearing nobody except Allah and the wolf lest it should trouble his sheep, but you are impatient." (See Hadith No. 191, Vol. 5)


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.77]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 77

Narrated Abu Huraira:

While we were in the mosque, Allah's Apostle came out to us and said, "Let us proceed to the Jews." So we went along with him till we reached Bait-al-Midras (a place where the Torah used to be recited and all the Jews of the town used to gather). The Prophet stood up and addressed them, "O Assembly of Jews! Embrace Islam and you will be safe!" The Jews replied, "O Aba-l-Qasim! You have conveyed Allah's message to us." The Prophet said, "That is what I want (from you)." He repeated his first statement for the second time, and they said, "You have conveyed Allah's message, O Aba-l-Qasim." Then he said it for the third time and added, "You should Know that the earth belongs to Allah and His Apostle, and I want to exile you fro,,, this land, so whoever among you owns some property, can sell it, otherwise you should know that the Earth belongs to Allah and His Apostle." (See Hadith No. 392, Vol. 4)


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.78]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 78

Narrated Khansa' bint Khidam Al-Ansariya:

That her father gave her in marriage when she was a matron and she disliked that marriage. So she came and (complained) to the Prophets and he declared that marriage invalid. (See Hadith No. 69, Vol. 7)


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.79]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 79

Narrated 'Aisha:

I asked the Prophet, "O Allah's Apostle! Should the women be asked for their consent to their marriage?" He said, "Yes." I said, "A virgin, if asked, feels shy and keeps quiet." He said, "Her silence means her consent."


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.80]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 80

Narrated Jabir:

A man from the Ansar made his slave, a Mudabbar. And apart from that slave he did not have any other property. This news reached Allah's Apostle and he said, "Who will buy that slave from me?" So Nu'aim bin An-Nahham bought him for 800 Dirham. Jabir added: It was a coptic (Egyptian) slave who died that year.


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.81]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 81

Narrated Ibn 'Abbas:

wished, for they had more right to dispose of her than her own relativ


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.82]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 82

Narrated Abu Huraira:

Allah's Apostle said, "(The Prophet) Abraham migrated with his wife Sarah till he reached a town where there was a king or a tyrant who sent a message, to Abraham, ordering him to send Sarah to him. So when Abraham had sent Sarah, the tyrant got up, intending to do evil with her, but she got up and performed ablution and prayed and said, 'O Allah ! If I have believed in You and in Your Apostle, then do not empower this oppressor over me.' So he (the king) had an epileptic fit and started moving his legs violently. "


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.83]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 83

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "A Muslim is a brother of another Muslim. So he should neither oppress him nor hand him over to an oppressor. And whoever fulfilled the needs of his brother, Allah will fulfill his needs."


Bukhari :: Saying Something under Compulsion (Ikraah) :: [9.85.84]

Saying Something under Compulsion (Ikraah)

Bukhari :: Book 9 :: Volume 85 :: Hadith 84

Narrated Anas:

Allah's Apostle said, "Help your brother whether he is an oppressor or an oppressed," A man said, "O Allah's Apostle! I will help him if he is oppressed, but if he is an oppressor, how shall I help him?" The Prophet said, "By preventing him from oppressing (others), for that is how to help him."


Bukhari :: Tricks :: [9.86.85]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 85

Narrated 'Umar bin Al-Khattab:

The Prophet said, 'O people! The reward of deeds depends upon the intentions, and every person will get the reward according to what he has intended. So, whoever emigrated for Allah and His Apostle, then his emigration was for Allah and His Apostle, and whoever emigrated to take worldly benefit or for a woman to marry, then his emigration was for what he emigrated for."


Bukhari :: Tricks :: [9.86.86]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 86

Narrated Abu Huraira:

The Prophet said, "Allah does not accept prayer of anyone of you if he does Hadath (passes wind) till he performs the ablution (anew)."


Bukhari :: Tricks :: [9.86.87]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 87

Narrated Anas:

That Abu Bakr wrote for him, Zakat regulations which Allah's Apostle had made compulsory, and wrote that one should neither collect various portions (of the property) nor divide the property into various portions in order to avoid paying Zakat.


Bukhari :: Tricks :: [9.86.88]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 88

Narrated Talha bin 'Ubaidullah:

A bedouin with unkempt hair came to Allah's Apostle and said, "O Allah's Apostle! Tell me what Allah has enjoined on me as regards prayers." The Prophet said, "You have to offer perfectly the five (compulsory) prayers in a day and a night (24 hrs.), except if you want to perform some extra optional prayers." The bedouin said, "Tell me what Allah has enjoined on me as regards fasting." The Prophet said, "You have to observe fast during the month of Ramadan except if you fast some extra optional fast." The bedouin said, "Tell me what Allah has enjoined on me as regard Zakat." The Prophet then told him the Islamic laws and regulations whereupon the bedouin said, "By Him Who has honored you, I will not perform any optional deeds of worship and I will not leave anything of what Allah has enjoined on me." Allah's Apostle said, "He will be successful if he has told the truth (or he will enter Paradise if he said the truth)." And some people said, "The Zakat for one-hundred and twenty camels is two Hiqqas, and if the Zakat payer slaughters the camels intentionally or gives them as a present or plays some other trick in order to avoid the Zakat, then there is no harm (in it) for him.


Bukhari :: Tricks :: [9.86.89]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 89

Narrated Abu Huraira:

Allah's Apostle said, "On the Day of Resurrection the Kanz (Treasure or wealth of which, Zakat has not been paid) of anyone of you will appear in the shape of a huge bald headed poisonous male snake and its owner will run away from it, but it will follow him and say, 'I am your Kanz.'" The Prophet added, "By Allah, that snake will keep on following him until he stretches out his hand and let the snake swallow it." Allah's Apostle added, "If the owner of camels does not pay their Zakat, then, on the Day of Resurrection those camels will come to him and will strike his face with their hooves." Some people said: Concerning a man who has camels, and is afraid that Zakat will be due so he sells those camels for similar camels or for sheep or cows or money one day before Zakat becomes due in order to avoid payment of their Zakat cunningly! "He has not to pay anything." The same scholar said, "If one pays Zakat of his camels one day or one year prior to the end of the year (by the end of which Zakat becomes due), his Zakat will be valid."


Bukhari :: Tricks :: [9.86.90]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 90

Narrated 'Abdullah:

Nafi narrated to me that 'Abdullah said that Allah's Apostle forbade the Shighar. I asked Nafi', "What is the Shighar?" He said, "It is to marry the daughter of a man and marry one's daughter to that man (at the same time) without Mahr (in both cases); or to marry the sister of a man and marry one's own sister to that man without Mahr." Some people said, "If one, by a trick, marries on the basis of Shighar, the marriage is valid but its condition is illegal." The same scholar said regarding Al-Mut'a, "The marriage is invalid and its condition is illegal." Some others said, "The Mut'a and the Shighar are permissible but the condition is illegal."


Bukhari :: Tricks :: [9.86.91]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 91

Narrated Muhammad bin 'Ali:

'Ali was told that Ibn 'Abbas did not see any harm in the Mut'a marriage. 'Ali said, "Allah's Apostle forbade the Mut'a marriage on the Day of the battle of Khaibar and he forbade the eating of donkey's meat." Some people said, "If one, by a tricky way, marries temporarily, his marriage is illegal." Others said, "The marriage is valid but its condition is illegal."


Bukhari :: Tricks :: [9.86.92]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 92

Narrated Abu Huraira:

Allah's Apostle said, "One should not prevent others from watering their animals with the surplus of his water in order to prevent them from benefiting by the surplus of grass."


Bukhari :: Tricks :: [9.86.93]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 93

Narrated Ibn 'Umar:

Allah's Apostle forbade the practice of An-Najsh.


Bukhari :: Tricks :: [9.86.94]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 94

Narrated 'Abdullah bin 'Umar:

A man mentioned to the Prophet that he had always been cheated in bargains. The Prophet said, "Whenever you do bargain, say, 'No cheating.'"


Bukhari :: Tricks :: [9.86.95]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 95

Narrated 'Urwa:

That he asked 'Aisha regarding the Verse: 'If you fear that you shall not be able to deal justly with the orphan girls, marry (other) women of your choice.' (4.3) 'Aisha said, "It is about an orphan girl under the custody of her guardian who being attracted by her wealth and beauty wants to marry her with Mahr less than other women of her status. So such guardians were forbidden to marry them unless they treat them justly by giving them their full Mahr. Then the people sought the verdict of Allah's Apostle for such cases, whereupon Allah revealed: 'They ask your instruction concerning women..' (4.127) (The sub-narrator then mentioned the Hadith.)


Bukhari :: Tricks :: [9.86.96]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 96

Narrated 'Abdullah bin 'Umar:

The Prophet said, "For every betrayer there will be a flag by which he will be recognized on the Day of Resurrection. "


Bukhari :: Tricks :: [9.86.97]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 97

Narrated Um Salama:

The Prophet said, "I am only a human being, and you people have disputes. May be some one amongst you can present his case in a more eloquent and convincing manner than the other, and I give my judgment in his favor according to what I hear. Beware! If ever I give (by error) somebody something of his brother's right then he should not take it as I have only, given him a piece of Fire." (See Hadith No. 638. Vol. 3)


Bukhari :: Tricks :: [9.86.98]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 98

Narrated Abu Huraira:

The Prophet said, "A virgin should not be married till she is asked for her consent; and the matron should not be married till she is asked whether she agrees to marry or not." It was asked, "O Allah's Apostle! How will she(the virgin) express her consent?" He said, "By keeping silent." Some people said, "If a virgin is not asked for her consent and she is not married, and then a man, by playing a trick presents two false witnesses that he has married her with her consent and the judge confirms his marriage as a true one, and the husband knows that the witnesses were false ones, then there is no harm for him to consummate his marriage with her and the marriage is regarded as valid."


Bukhari :: Tricks :: [9.86.99]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 99

Narrated Al-Qasim:

A woman from the offspring of Ja'far was afraid lest her guardian marry her (to somebody) against her will. So she sent for two elderly men from the Ansar, 'AbdurRahman and Mujammi', the two sons of Jariya, and they said to her, "Don't be afraid, for Khansa' bint Khidam was given by her father in marriage against her will, then the Prophet cancelled that marriage." (See Hadith No. 78)


Bukhari :: Tricks :: [9.86.100]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 100

Narrated Abu Haraira:

Allah's Apostle said, "A lady slave should not be given in marriage until she is consulted, and a virgin should not be given in marriage until her permission is granted." The people said, "How will she express her permission?" The Prophet said, "By keeping silent (when asked her consent)." Some people said, "If a man, by playing a trick, presents two false witnesses before the judge to testify that he has married a matron with her consent and the judge confirms his marriage, and the husband is sure that he has never married her (before), then such a marriage will be considered as a legal one and he may live with her as husband."


Bukhari :: Tricks :: [9.86.101]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 101

Narrated 'Aisha:

Allah's Apostle said, "It is essential to have the consent of a virgin (for the marriage). I said, "A virgin feels shy." The Prophet; said, "Her silence means her consent." Some people said, "If a man falls in love with an orphan slave girl or a virgin and she refuses (him) and then he makes a trick by bringing two false witnesses to testify that he has married her, and then she attains the age of puberty and agrees to marry him and the judge accepts the false witness and the husband knows that the witnesses were false ones, he may consummate his marriage."


Bukhari :: Tricks :: [9.86.102]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 102

Narrated 'Aisha:

Allah's Apostle used to like sweets and also used to like honey, and whenever he finished the 'Asr prayer, he used to visit his wives and stay with them. Once he visited Hafsa and remained with her longer than the period he used to stay, so I enquired about it. It was said to me, "A woman from her tribe gave her a leather skin containing honey as a present, and she gave some of it to Allah's Apostle to drink." I said, "By Allah, we will play a trick on him." So I mentioned the story to Sauda (the wife of the Prophet) and said to her, "When he enters upon you, he will come near to you whereupon you should say to him, 'O Allah's Apostle! Have you eaten Maghafir?' He will say, 'No.' Then you say to him, 'What is this bad smell? ' And it would be very hard on Allah's Apostle that a bad smell should be found on his body. He will say, 'Hafsa has given me a drink of honey.' Then you should say to him, 'Its bees must have sucked from the Al-'Urfut (a foul smelling flower).' I too, will tell him the same. And you, O Saifya, say the same."

So when the Prophet entered upon Sauda (the following happened). Sauda said, "By Him except Whom none has the right to be worshipped, I was about to say to him what you had told me to say while he was still at the gate because of fear from you. But when Allah 's Apostle came near to me, I said to him, 'O Allah's Apostle! Have you eaten Maghafir?' He replied, 'No.' I said, 'What about this smell?' He said, 'Hafsa has given me a drink of honey.' I said, 'Its bees must have sucked Al-'Urfut.' " When he entered upon me, I told him the same as that, and when he entered upon Safiya, she too told him the same. So when he visited Hafsa again, she said to him, "O Allah's Apostle! Shall I give you a drink of it (honey)?" He said, "I have no desire for it." Sauda said, Subhan Allah! We have deprived him of it (honey)." I said to her, "Be quiet!"


Bukhari :: Tricks :: [9.86.103]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 103

Narrated 'Abdullah bin 'Amir bin Rabi'a:

'Umar bin Al-Khattab left for Sham, and when he reached a placed called Sargh, he came to know that there was an outbreak of an epidemic (of plague) in Sham. Then 'AbdurRahman bin 'Auf told him that Allah's Apostle said, "If you hear the news of an outbreak of an epidemic (plague) in a certain place, do not enter that place: and if the epidemic falls in a place while you are present in it, do not leave that place to escape from the epidemic." So 'Umar returned from Sargh.


Bukhari :: Tricks :: [9.86.104]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 104

Narrated 'Amir bin Sa'd bin Abi Waqqas:

That he heard Usama bin Zaid speaking to Sa'd, saying, "Allah's Apostle mentioned the plague and said, 'It is a means of punishment with which some nations were punished and some of it has remained, and it appears now and then. So whoever hears that there is an outbreak of plague in some land, he should not go to that land, and if the plague breaks out in the land where one is already present, one should not run away from that land, escaping from the plague."


Bukhari :: Tricks :: [9.86.105]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 105

Narrated Ibn 'Abbas:

The Prophet said, "The one who takes back his gift is like a dog swallowing its own vomit, and we (believers) should not act according to this bad example."


Bukhari :: Tricks :: [9.86.106]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 106

Narrated Jabir bin 'Abdullah:

The Prophet has decreed that preemption is valid in all cases where the real estate concerned has not been divided, but if the boundaries are established and the ways are made, then there is no preemption. A man said, "Preemption is only for the neighbor," and then he makes invalid what he has confirmed. He said, "If someone wants to buy a house and being afraid that the neighbor (of the house) may buy it through preemption, he buys one share out of one hundred shares of the house and then buys the rest of the house, then the neighbor can only have the right of preemption for the first share but not for the rest of the house; and the buyer may play such a trick in this case."


Bukhari :: Tricks :: [9.86.107]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 107

Narrated 'Amr bin Ash-Sharid:

Al-Miswar bin Makhrama came and put his hand on my shoulder and I accompanied him to Sa'd. Abu Rafi' said to Al-Miswar, "Won't you order this (i.e. Sa'd) to buy my house which is in my yard?" Sa'd said, "I will not offer more than four hundred in installments over a fixed period." Abu Rafi said, "I was offered five hundred cash but I refused. Had I not heard the Prophet saying, 'A neighbor is more entitled to receive the care of his neighbor,' I would not have sold it to you." The narrator said, to Sufyan: Ma'mar did not say so. Sufyan said, "But he did say so to me." Some people said, "If someone wants to sell a house and deprived somebody of the right of preemption, he has the right to play a trick to render the preemption invalid. And that is by giving the house to the buyer as a present and marking its boundaries and giving it to him. The buyer then gives the seller one-thousand Dirham as compensation in which case the preemptor loses his right of preemption."

Narrated 'Amr bin Ash-Sharid: Abu Rafi' said that Sa'd offered him four hundred Mithqal of gold for a house. Abu Rafi ' said, "If I had not heard Allah's Apostle saying, 'A neighbor has more right to be taken care of by his neighbor,' then I would not have given it to you." Some people said, "If one has bought a portion of a house and wants to cancel the right of preemption, he may give it as a present to his little son and he will not be obliged to take an oath."


Bukhari :: Tricks :: [9.86.108]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 108

Narrated Abu Humaid As-Sa'idi:

Allah's Apostle appointed a man called Ibn Al-Lutabiyya to collect the Zakat from Bani Sulaim's tribe. When he returned, the Prophet called him to account. He said (to the Prophet, 'This is your money, and this has been given to me as a gift." On that, Allah's Apostle said, "Why didn't you stay in your father's and mother's house to see whether you will be given gifts or not if you are telling the truth?" Then the Prophet addressed us, and after praising and glorifying Allah, he said: "Amma Ba'du", I employ a man from among you to manage some affair of what Allah has put under my custody, and then he comes to me and says, 'This is your money and this has been given to me as a gift. Why didn't he stay in his father's and mother's home to see whether he will be given gifts or not? By Allah, not anyone of you takes a thing unlawfully but he will meet Allah on the Day of Resurrection, carrying that thing. I do not want to see any of you carrying a grunting camel or a mooing cow or a bleating sheep on meeting Allah." Then the Prophet raised both his hands till the whiteness of his armpits became visible, and he said, "O Allah! Haven't I have conveyed (Your Message)?" The narrator added: My eyes witnessed and my ears heard (that Hadith).


Bukhari :: Tricks :: [9.86.109]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 109

Narrated Abu Rafi':

The Prophet said, "The neighbor has more right to be taken care of by his neighbor (than anyone else)." Some men said, "If one wants to buy a house for 20,000 Dirhams then there is no harm to play a trick to deprive somebody of preemption by buying it (just on paper) with 20,000 Dirhams but paying to the seller only 9,999 Dirhams in cash and then agree with the seller to pay only one Dinar in cash for the rest of the price (i.e. 10,001 Dirhams). If the preemptor offers 20,000 Dirhams for the house, he can buy it otherwise he has no right to buy it (by this trick he got out of preemption). If the house proves to belong to somebody else other than the seller, the buyer should take back from the seller what he has paid, i.e., 9,999 Dirhams and one Dinar, because if the house proves to belong to somebody else, so the whole bargain (deal) is unlawful. If the buyer finds a defect in the house and it does not belong to somebody other than the seller, the buyer may return it and receive 20,000 Dirhams (instead of 9999 Dirham plus one Dinar) which he actually paid.' Abu 'Abdullah said, "So that man allows (some people) the playing of tricks amongst the Muslims (although) the Prophet said, 'In dealing with Muslims one should not sell them sick (animals) or bad things or stolen things."


Bukhari :: Tricks :: [9.86.110]

Tricks

Bukhari :: Book 9 :: Volume 86 :: Hadith 110

Narrated 'Amr bin Ash-Sharid:

Abu Rafi' sold a house to Sa'd bin Malik for four-hundred Mithqal of gold, and said, "If I had not heard the Prophet saying, 'The neighbor has more right to be taken care of by his neighbor (than anyone else),' then I would not have sold it to you."


Bukhari :: Interpretation of Dreams :: [9.87.111]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 111

Narrated 'Aisha:

The commencement of the Divine Inspiration to Allah's Apostle was in the form of good righteous (true) dreams in his sleep. He never had a dream but that it came true like bright day light. He used to go in seclusion (the cave of) Hira where he used to worship(Allah Alone) continuously for many (days) nights. He used to take with him the journey food for that (stay) and then come back to (his wife) Khadija to take his food like-wise again for another period to stay, till suddenly the Truth descended upon him while he was in the cave of Hira. The angel came to him in it and asked him to read. The Prophet replied, "I do not know how to read." (The Prophet added), "The angel caught me (forcefully) and pressed me so hard that I could not bear it anymore. He then released me and again asked me to read, and I replied, "I do not know how to read," whereupon he caught me again and pressed me a second time till I could not bear it anymore. He then released me and asked me again to read, but again I replied, "I do not know how to read (or, what shall I read?)." Thereupon he caught me for the third time and pressed me and then released me and said, "Read: In the Name of your Lord, Who has created (all that exists). Has created man from a clot. Read and Your Lord is Most Generous...up to..... ..that which he knew not." (96.15)

Then Allah's Apostle returned with the Inspiration, his neck muscles twitching with terror till he entered upon Khadija and said, "Cover me! Cover me!" They covered him till his fear was over and then he said, "O Khadija, what is wrong with me?" Then he told her everything that had happened and said, 'I fear that something may happen to me." Khadija said, 'Never! But have the glad tidings, for by Allah, Allah will never disgrace you as you keep good reactions with your Kith and kin, speak the truth, help the poor and the destitute, serve your guest generously and assist the deserving, calamity-afflicted ones." Khadija then accompanied him to (her cousin) Waraqa bin Naufal bin Asad bin 'Abdul 'Uzza bin Qusai. Waraqa was the son of her paternal uncle, i.e., her father's brother, who during the Pre-Islamic Period became a Christian and used to write the Arabic writing and used to write of the Gospels in Arabic as much as Allah wished him to write. He was an old man and had lost his eyesight. Khadija said to him, "O my cousin! Listen to the story of your nephew." Waraqa asked, "O my nephew! What have you seen?" The Prophet described whatever he had seen.

Waraqa said, "This is the same Namus (i.e., Gabriel, the Angel who keeps the secrets) whom Allah had sent to Moses. I wish I were young and could live up to the time when your people would turn you out." Allah's Apostle asked, "Will they turn me out?" Waraqa replied in the affirmative and said: "Never did a man come with something similar to what you have brought but was treated with hostility. If I should remain alive till the day when you will be turned out then I would support you strongly." But after a few days Waraqa died and the Divine Inspiration was also paused for a while and the Prophet became so sad as we have heard that he intended several times to throw himself from the tops of high mountains and every time he went up the top of a mountain in order to throw himself down, Gabriel would appear before him and say, "O Muhammad! You are indeed Allah's Apostle in truth" whereupon his heart would become quiet and he would calm down and would return home. And whenever the period of the coming of the inspiration used to become long, he would do as before, but when he used to reach the top of a mountain, Gabriel would appear before him and say to him what he had said before. (Ibn 'Abbas said regarding the meaning of: 'He it is that Cleaves the daybreak (from the darkness)' (6.96) that Al-Asbah. means the light of the sun during the day and the light of the moon at night).


Bukhari :: Interpretation of Dreams :: [9.87.112]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 112

Narrated Anas bin Malik:

Allah's Apostle said, "A good dream (that comes true) of a righteous man is one of forty-six parts of prophetism."


Bukhari :: Interpretation of Dreams :: [9.87.113]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 113

Narrated Abu Qatada:

The Prophet said, "A true good dream is from Allah, and a bad dream is from Satan."


Bukhari :: Interpretation of Dreams :: [9.87.114]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 114

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "If anyone of you sees a dream that he likes, then it is from Allah, and he should thank Allah for it and narrate it to others; but if he sees something else, i.e., a dream that he dislikes, then it is from Satan, and he should seek refuge with Allah from its evil, and he should not mention it to anybody, for it will not harm him."


Bukhari :: Interpretation of Dreams :: [9.87.115]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 115

Narrated Abu Qatada:

The Prophet said, "A good dream that comes true is from Allah, and a bad dream is from Satan, so if anyone of you sees a bad dream, he should seek refuge with Allah from Satan and should spit on the left, for the bad dream will not harm him."


Bukhari :: Interpretation of Dreams :: [9.87.116]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 116

Narrated 'Ubada bin As-Samit:

The Prophet said, "The (good) dreams of a faithful believer is a part of the forty-six parts of prophetism:'


Bukhari :: Interpretation of Dreams :: [9.87.117]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 117

Narrated Abu Huraira:

Allah's Apostle said, "The (good) dream of a faithful believer is a part of the forty-six parts of prophetism."


Bukhari :: Interpretation of Dreams :: [9.87.118]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 118

Narrated Abu Sa'id Al-Khudri:

I heard Allah's Apostle saying, "A good dream is a part of the forty six parts of prophetism."


Bukhari :: Interpretation of Dreams :: [9.87.119]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 119

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Nothing is left of the prophetism except Al-Mubashshirat." They asked, "What are Al-Mubashshirat?" He replied, "The true good dreams (that conveys glad tidings)."


Bukhari :: Interpretation of Dreams :: [9.87.120]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 120

Narrated Ibn 'Umar:

Some people were shown the Night of Qadr as being in the last seven days (of the month of Ramadan). The Prophet said, "Seek it in the last seven days (of Ramadan)."


Bukhari :: Interpretation of Dreams :: [9.87.121]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 121

Narrated Abu Huraira:

Allah's Apostle said, "If I stayed in prison as long as Joseph stayed and then the messenger came, I would respond to his call (to go out of the prison) ."


Bukhari :: Interpretation of Dreams :: [9.87.122]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 122

Narrated Abu Huraira:

I heard the Prophet saying, "Whoever sees me in a dream will see me in his wakefulness, and Satan cannot imitate me in shape." Abu 'Abdullah said, "Ibn Sirin said, 'Only if he sees the Prophet in his (real) shape.'"


Bukhari :: Interpretation of Dreams :: [9.87.123]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 123

Narrated Anas:

The Prophet said, "Whoever has seen me in a dream, then no doubt, he has seen me, for Satan cannot imitate my shape.


Bukhari :: Interpretation of Dreams :: [9.87.124]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 124

Narrated Abu Qatada:

The Prophet said, "A good dream is from Allah, and a bad dream is from Satan. So whoever has seen (in a dream) something he dislike, then he should spit without saliva, thrice on his left and seek refuge with Allah from Satan, for it will not harm him, and Satan cannot appear in my shape."


Bukhari :: Interpretation of Dreams :: [9.87.125]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 125

Narrated Abu Qatada:

The Prophet said, "Whoever sees me (in a dream) then he indeed has seen the truth ."


Bukhari :: Interpretation of Dreams :: [9.87.126]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 126

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "Who ever sees me (in a dream) then he indeed has seen the truth, as Satan cannot appear in my shape."


Bukhari :: Interpretation of Dreams :: [9.87.127]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 127

Narrated Abu Huraira:

The Prophet said, "I have been given the keys of eloquent speech and given victory with awe (cast into the hearts of the enemy), and while I was sleeping last night, the keys of the treasures of the earth were brought to me till they were put in my hand." Abu Huraira added: Allah's Apostle left (this world) and now you people are carrying those treasures from place to place.


Bukhari :: Interpretation of Dreams :: [9.87.128]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 128

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "I saw myself (in a dream) near the Ka'ba last night, and I saw a man with whitish red complexion, the best you may see amongst men of that complexion having long hair reaching his earlobes which was the best hair of its sort, and he had combed his hair and water was dropping from it, and he was performing the Tawaf around the Ka'ba while he was leaning on two men or on the shoulders of two men. I asked, 'Who is this man?' Somebody replied, '(He is) Messiah, son of Mary.' Then I saw another man with very curly hair, blind in the right eye which looked like a protruding out grape. I asked, 'Who is this?' Somebody replied, '(He is) Messiah, Ad-Dajjal.'"


Bukhari :: Interpretation of Dreams :: [9.87.129]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 129

Narrated Ibn 'Abbas:

About a man who came to Allah's Apostle and said, "I was shown in a dream last night..." Then Ibn 'Abbas mentioned the narration.


Bukhari :: Interpretation of Dreams :: [9.87.130]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 130

Narrated Anas bin Malik:

Allah's Apostle used to visit Um Haram bint Milhan she was the wife of 'Ubada bin As-Samit. One day the Prophet visited her and she provided him with food and started looking for lice in his head. Then Allah's Apostle slept and afterwards woke up smiling. Um Haram asked, "What makes you smile, O Allah's Apostle?" He said, "Some of my followers were presented before me in my dream as fighters in Allah's Cause, sailing in the middle of the seas like kings on the thrones or like kings sitting on their thrones." (The narrator Ishaq is not sure as to which expression was correct). Um Haram added, 'I said, "O Allah's Apostle! Invoke Allah, to make me one of them;" So Allah's Apostle invoked Allah for her and then laid his head down (and slept). Then he woke up smiling (again). (Um Haram added): I said, "What makes you smile, O Allah's Apostle?" He said, "Some people of my followers were presented before me (in a dream) as fighters in Allah's Cause." He said the same as he had said before. I said, "O Allah's Apostle! Invoke Allah to make me from them." He said, "You are among the first ones." Then Um Haram sailed over the sea during the Caliphate of Muawiya bin Abu Sufyan, and she fell down from her riding animal after coming ashore, and died.


Bukhari :: Interpretation of Dreams :: [9.87.131]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 131

Narrated Kharija bin Zaid bin Thabit:

Um Al-'Ala an Ansari woman who had given a pledge of allegiance to Allah's Apostle told me:, "The Muhajirln (emigrants) were distributed amongst us by drawing lots, and we got 'Uthman bin Maz'un in our share. We made him stay with us in our house. Then he suffered from a disease which proved fatal. When he died and was given a bath and was shrouded in his clothes. Allah's Apostle came, I said, (addressing the dead body), 'O Aba As-Sa'ib! May Allah be Merciful to you! I testify that Allah has honored you.' Allah's Apostle said, 'How do you know that Allah has honored him?" I replied, 'Let my father be sacrificed for you, O Allah's Apostle! On whom else shall Allah bestow. His honor?' Allah's Apostle said, 'As for him, by Allah, death has come to him. By Allah, I wish him all good (from Allah). By Allah, in spite of the fact that I am Allah's Apostle, I do not know what Allah will do to me.", Um Al-'Ala added, "By Allah, I will never attest the righteousness of anybody after that."


Bukhari :: Interpretation of Dreams :: [9.87.132]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 132

Narrated Az-Zuhri:

Regarding the above narration, The Prophet said, "I do not know what Allah will do to him (Uthman bin Maz'un)." Um Al-'Ala said, "I felt very sorry for that, and then I slept and saw in a dream a flowing spring for 'Uthman bin Maz'un, and told Allah's Apostle of that, and he said, "That flowing spring symbolizes his good deeds."


Bukhari :: Interpretation of Dreams :: [9.87.133]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 133

Narrated Abu Qatada Al-Ansari:

(a companion of the Prophet and one of his cavalry men) "I heard Allah's Apostle saying, "A good dream is from Allah, and a bad dream is from Satan; so, if anyone of you had a bad dream which he disliked, then he should spit on his left and seek refuge with Allah from it, for it will not harm him."


Bukhari :: Interpretation of Dreams :: [9.87.134]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 134

Narrated Ibn 'Umar:

I heard Allah's Apostle saying, "While I was sleeping, I was given a bowl full of milk (in a dream), and I drank of it to my fill until I noticed its wetness coming out of my nails, and then I gave the rest of it to 'Umar." They (the people) asked, "What have you interpreted (about the dream)? O Allah's Apostle?" He said, "(It is Religious) knowledge."


Bukhari :: Interpretation of Dreams :: [9.87.135]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 135

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "While I was sleeping, I was given a bowl full of milk (in the dream) and I drank from it (to my fill) till I noticed its wetness coming out of my limbs. Then I gave the rest of it to 'Umar bin Al-Khattab." The persons sitting around him, asked, "What have you interpreted (about the dream) O Allah's Apostle?" He said, "(It is religious) knowledge."


Bukhari :: Interpretation of Dreams :: [9.87.136]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 136

Narrated Abu Sa'id Al-Khudri:

Allah's Apostle said, "While I was sleeping, some people were displayed before me (in a dream). They were wearing shirts, some of which were merely covering their breasts, and some a bit longer. Then there passed before me, 'Umar bin Al-Khattab wearing a shirt he was dragging it (on the ground behind him.)" They (the people) asked, "What have you interpreted (about the dream) O Allah's Apostle?" He said, "The Religion."


Bukhari :: Interpretation of Dreams :: [9.87.137]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 137

Narrated Abu Sa'id Al-Khudri:

I heard Allah's Apostle saying, "While I was sleeping, I saw (in a dream) the people being displayed before me, wearing shirts, some of which (were so short that it) reached as far as their breasts and some reached below that. Then 'Umar bin Al-Khattab was shown to me and he was wearing a shirt which he was dragging (behind him)." They asked. What have you interpreted (about the dream)? O Allah's Apostle?" He said, "The religion."


Bukhari :: Interpretation of Dreams :: [9.87.138]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 138

Narrated Qais bin 'Ubada:

I was sitting in a gathering in which there was Sa'd bin Malik and Ibn 'Umar. 'Abdullah bin Salam passed in front of them and they said, "This man is from the people of Paradise." I said to 'Abdullah bin Salam, "They said so-and-so." He replied, "Subhan Allah! They ought not to have said things of which they have no knowledge, but I saw (in a dream) that a post was fixed in a green garden. At the top of the post there was a handhold and below it there was a servant. I was asked to climb (the post). So I climbed it till I got hold of the handhold." Then I narrated this dream to Allah's Apostle. Allah's Apostle said, "'Abdullah will die while still holding the firm reliable handhold (i.e., Islam)."


Bukhari :: Interpretation of Dreams :: [9.87.139]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 139

Narrated 'Aisha:

Allah's Apostle said (to me), "You were shown to me twice in (my) dream. Behold, a man was carrying you in a silken piece of cloth and said to me, "She is your wife, so uncover her,' and behold, it was you. I would then say (to myself), 'If this is from Allah, then it must happen.' "


Bukhari :: Interpretation of Dreams :: [9.87.140]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 140

Narrated 'Aisha:

Allah's Apostle said to me, "You were shown to me twice (in my dream) before I married you. I saw an angel carrying you in a silken piece of cloth, and I said to him, 'Uncover (her),' and behold, it was you. I said (to myself), 'If this is from Allah, then it must happen.' Then you were shown to me, the angel carrying you in a silken piece of cloth, and I said (to him), 'Uncover (her), and behold, it was you. I said (to myself), 'If this is from Allah, then it must happen.' "


Bukhari :: Interpretation of Dreams :: [9.87.141]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 141

Narrated Abu Huraira:

I heard Allah's Apostle saying, "I have been sent with Jawami al-Kalim (i.e., the shortest expression carrying the widest meanings), and I was made victorious with awe (caste into the hearts of the enemy), and while I was sleeping, the keys of the treasures of the earth were brought to me and were put in my hand." Muhammad said, Jawami'-al-Kalim means that Allah expresses in one or two statements or thereabouts the numerous matters that used to be written in the books revealed before (the coming of) the Prophet .


Bukhari :: Interpretation of Dreams :: [9.87.142]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 142

Narrated 'Abdullah bin Salam:

(In a dream) I saw myself in a garden, and there was a pillar in the middle of the garden, and there was a handhold at the top of the pillar. I was asked to climb it. I said, "I cannot." Then a servant came and lifted up my clothes and I climbed (the pillar), and then got hold of the handhold, and I woke up while still holding it. I narrated that to the Prophet who said, "The garden symbolizes the garden of Islam, and the handhold is the firm Islamic handhold which indicates that you will be adhering firmly to Islam until you die."


Bukhari :: Interpretation of Dreams :: [9.87.143]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 143

Narrated Ibn 'Umar:

I saw in a dream a piece of silken cloth in my hand, and in whatever direction in Paradise I waved it, it flew, carrying me there. I narrated this (dream) to (my sister) Hafsa and she told it to the Prophet who said, (to Hafsa), "Indeed, your brother is a righteous man," or, "Indeed, 'Abdullah is a righteous man."


Bukhari :: Interpretation of Dreams :: [9.87.144]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 144

Narrated Abu Huraira:

Allah's Apostle said, "When the Day of Resurrection approaches, the dreams of a believer will hardly fail to come true, and a dream of a believer is one of forty-six parts of prophetism, and whatever belongs to prothetism can never be false." Muhammad bin Sirin said, "But I say this." He said, "It used to be said, 'There are three types of dreams: The reflection of one's thoughts and experiences one has during wakefulness, what is suggested by Satan to frighten the dreamer, or glad tidings from Allah. So, if someone has a dream which he dislikes, he should not tell it to others, but get up and offer a prayer." He added, "He (Abu Huraira) hated to see a Ghul (i.e., iron collar around his neck in a dream) and people liked to see fetters (on their feet in a dream). The fetters on the feet symbolizes one's constant and firm adherence to religion." And Abu 'Abdullah said, "Ghuls (iron collars) are used only for necks."


Bukhari :: Interpretation of Dreams :: [9.87.145]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 145

Narrated Kharija bin Zaid bin Thabit:

Um Al-'Ala an Ansari woman who had given the Pledge of allegiance to Allah's Apostle said, "'Uthman bin Maz'un came in our share when the Ansars drew lots to distribute the emigrants (to dwell) among themselves, He became sick and we looked after (nursed) him till he died. Then we shrouded him in his clothes. Allah's Apostle came to us, I (addressing the dead body) said, "May Allah's Mercy be on you, O Aba As-Sa'ib! I testify that Allah has honored you." The Prophet said, 'How do you know that?' I replied, 'I do not know, by Allah.' He said, 'As for him, death has come to him and I wish him all good from Allah. By Allah, though I am Allah's Apostle, I neither know what will happen to me, nor to you.'" Um Al-'Ala said, "By Allah, I will never attest the righteousness of anybody after that." She added, "Later I saw in a dream, a flowing spring for 'Uthman. So I went to Allah's Apostle and mentioned that to him. He said, 'That is (the symbol of) his good deeds (the reward for) which is going on for him.' "


Bukhari :: Interpretation of Dreams :: [9.87.146]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 146

Narrated Ibn 'Umar:

Allah's Apostle said, "(I saw in a dream that) while I was standing at a well and drawing water therefrom, suddenly Abu Bakr and 'Umar came to me. Abu Bakr took the bucket and drew one or two buckets (full of water), but there was weakness in his pulling, but Allah forgave him. Then Ibn Al-Khattab took the bucket from Abu Bakr's hand and the bucket turned into a very large one in his hand. I have never seen any strong man among the people doing such a hard job as 'Umar did, till (the people drank to their satisfaction) and water their camels to their fill and they sat near the water."


Bukhari :: Interpretation of Dreams :: [9.87.147]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 147

Narrated Salim's father:

about the Prophet's dream in which he has seen Abu Bakr and 'Umar: The Prophet said, "I saw (in a dream) that the people had gathered. Then Abu Bakr stood up and pulled out one or two buckets full of water (from a well) and there was weakness in his pulling -- may Allah forgive him. Then Ibn Al-Khattab stood up, and the bucket turned into a very large one and I have never seen any strong man among the people doing such a hard job. He pulled out so much water that the people (drank to their satisfaction) and watered their camels to their fill, (and then after quenching their thirst) they sat beside the water."


Bukhari :: Interpretation of Dreams :: [9.87.148]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 148

Narrated Abu Huraira:

Allah's Apostle said, "While I was sleeping, I saw myself standing at a well over which there was a bucket. I pulled out from it as many buckets of water as Allah wished, and then Ibn Abi Quhafa (Abu Bakr) took the bucket from me and pulled out one or two full buckets, and there was weakness in his pull--may Allah forgive him. Then the bucket turned into a very large one and 'Umar bin Al-Khattab took it. I have never seen any strong man among the people, drawing water with such strength as 'Umar did, till the people (drank to their satisfaction and) watered their camels to their fill; whereupon the camels sat beside the water."


Bukhari :: Interpretation of Dreams :: [9.87.149]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 149

Narrated Abu Huraira:

Allah's Apostle said, "While I was sleeping, I saw myself standing over a tank (well) giving water to the people to drink. Then Abu Bakr came to me and took the bucket from me in order to relieve me and he pulled out one or two full buckets, and there was weakness in his pulling --may Allah forgive him. Then Ibn Al-Khattab took it from him and went on drawing water till the people left (after being satisfied) while the tank was over flowing with water."


Bukhari :: Interpretation of Dreams :: [9.87.150]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 150

Narrated Abu Huraira:

We were sitting with Allah's Apostle, he said, "While I was sleeping, I saw myself in Paradise. Suddenly I saw a woman performing ablution beside a palace. I asked, "For whom is this palace?" They (the angels) replied, "It is for 'Umar bin Al-Khattab." Then I remembered 'Umar's ghira and went back hurriedly." On hearing that, 'Umar started weeping and said, " Let my father and mother be sacrificed for you. O Allah's Apostle! How dare I think of my Ghira being offended by you?


Bukhari :: Interpretation of Dreams :: [9.87.151]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 151

Narrated Jabir bin 'Abdullah:

Allah's Apostle said: (I saw in a dream that) I entered Paradise, and behold, there was a palace built of gold! I asked, 'For whom is this palace?' They (the angels) replied, 'For a man from the Quraish.' " The Prophet added, "O Ibn Al-Khattab! Nothing stopped me from entering it except your Ghira." 'Umar said, "How dare I think of my Ghira being offended by you, O Allah's Apostle?"


Bukhari :: Interpretation of Dreams :: [9.87.152]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 152

Narrated Abu Huraira:

We were sitting with Allah's Apostle he said, "While I was sleeping, I saw myself in Paradise, and behold, a woman was performing ablution by the side of a palace. I asked, 'For whom is this palace?' They replied, 'For 'Umar' Then I remembered the Ghira of 'Umar and returned immediately." 'Umar wept (on hearing that) and said, " Let my father and mother be sacrificed for you, O Allah's Apostle! How dare I think of my Ghira being offended by you.'


Bukhari :: Interpretation of Dreams :: [9.87.153]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 153

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "While I was sleeping, I saw myself performing the Tawaf of the Ka'ba. Behold, there I saw a whitish-red lank-haired man (holding himself) between two men with water dropping from his hair. I asked, 'Who is this?' The people replied, 'He is the son of Mary.' Then I turned my face to see another man with red complexion, big body, curly hair, and blind in the right eye which looked like a protruding out grape. I asked, 'Who is he?' They replied, 'He is Ad-Dajjal.' Ibn Qatan resembles him more than anybody else among the people and Ibn Qatan was a man from Bani Al-Mustaliq from Khuza'a."


Bukhari :: Interpretation of Dreams :: [9.87.154]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 154

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "While I was sleeping, I saw a bowl full of milk was brought to me and I drank of it (to my fill) till I noticed its wetness flowing (in my body). Then I gave the remaining of it to 'Umar." They asked, "O Allah's Apostle! What have you interpreted (about the dream)? He said, "(It is Religious) knowledge." (See Hadith No. 134)


Bukhari :: Interpretation of Dreams :: [9.87.155]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 155

Narrated Ibn 'Umar:

Men from the companions of Allah's Apostle used to see dreams during the lifetime of Allah's Apostle and they used to narrate those dreams to Allah's Apostle. Allah's Apostle would interpret them as Allah wished. I was a young man and used to stay in the mosque before my wedlock. I said to myself, "If there were any good in myself, I too would see what these people see." So when I went to bed one night, I said, "O Allah! If you see any good in me, show me a good dream." So while I was in that state, there came to me (in a dream) two angels. In the hand of each of them, there was a mace of iron, and both of them were taking me to Hell, and I was between them, invoking Allah, "O Allah! I seek refuge with You from Hell." Then I saw myself being confronted by another angel holding a mace of iron in his hand. He said to me, "Do not be afraid, you will be an excellent man if you only pray more often." So they took me till they stopped me at the edge of Hell, and behold, it was built inside like a well and it had side posts like those of a well, and beside each post there was an angel carrying an iron mace. I saw therein many people hanging upside down with iron chains, and I recognized therein some men from the Quraish. Then (the angels) took me to the right side. I narrated this dream to (my sister) Hafsa and she told it to Allah's Apostle. Allah's Apostle said, "No doubt, 'Abdullah is a good man." (Nafi' said, "Since then 'Abdullah bin 'Umar used to pray much.)


Bukhari :: Interpretation of Dreams :: [9.87.156]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 156

Narrated Ibn 'Umar:

I was a young unmarried man during the lifetime of the Prophet. I used to sleep in the mosque. Anyone who had a dream, would narrate it to the Prophet. I said, "O Allah! If there is any good for me with You, then show me a dream so that Allah's Apostle may interpret it for me." So I slept and saw (in a dream) two angels came to me and took me along with them, and they met another angel who said to me, "Don't be afraid, you are a good man." They took me towards the Fire, and behold, it was built inside like a well, and therein I saw people some of whom I recognized, and then the angels took me to the right side. In the morning, I mentioned that dream to Hafsa. Hafsa told me that she had mentioned it to the Prophet and he said, "'Abdullah is a righteous man if he only prays more at night." (Az-Zuhri said, "After that, 'Abdullah used to pray more at night.")


Bukhari :: Interpretation of Dreams :: [9.87.157]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 157

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle saying, "While I was sleeping, I saw that a cup full of milk was brought to me and I drank of it and gave the remaining of it to 'Umar bin Al-Khattab." They asked. What have you interpreted (about the dream)? O Allah's Apostle?" The Prophet said. "(It is Religious) knowledge."


Bukhari :: Interpretation of Dreams :: [9.87.158]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 158

Narrated 'Abdullah bin 'Abbas:

Allah's Apostle said, "While I was sleeping, two golden bangles were put in my two hands, so I got scared (frightened) and disliked it, but I was given permission to blow them off, and they flew away. I interpret it as a symbol of two liars who will appear." 'Ubaidullah said, "One of them was Al-'Ansi who was killed by Fairuz at Yemen and the other was Musailama (at Najd) .


Bukhari :: Interpretation of Dreams :: [9.87.159]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 159

Narrated Abu Musa:

The Prophet said, "I saw in a dream that I was migrating from Mecca to a land where there were date palm trees. I thought that it might be the land of Al-Yamama or Hajar, but behold, it turned out to be Yathrib (i.e. Medina). And I saw cows (being slaughtered) there, but the reward given by Allah is better (than worldly benefits). Behold, those cows proved to symbolize the believers (who were killed) on the Day (of the battle) of Uhud, and the good (which I saw in the dream) was the good and the reward and the truth which Allah bestowed upon us after the Badr battle. (or the Battle of Uhud) and that was the victory bestowed by Allah in the Battle of Khaibar and the conquest of Mecca) .


Bukhari :: Interpretation of Dreams :: [9.87.160]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 160

Narrated Abu Huraira:

Allah's Apostle said, "We (Muslims) are the last (to come) but (will be) the foremost (on the Day of Resurrection)." Allah's Apostle further said, ''While sleeping, I was given the treasures of the world and two golden bangles were put in my hands, but I felt much annoyed, and those two bangles distressed me very much, but I was inspired that I should blow them off, so I blew them and they flew away. Then I interpreted that those two bangles were the liars between whom I was (i.e., the one of San'a' and the one of Yamama)."


Bukhari :: Interpretation of Dreams :: [9.87.161]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 161

Narrated 'Abdullah:

The Prophet said, "I saw (in a dream) a black woman with unkempt hair going out of Medina and settling at Mahai'a, i.e., Al-Juhfa. I interpreted that as a symbol of epidemic of Medina being transferred to that place (Al-Juhfa)."


Bukhari :: Interpretation of Dreams :: [9.87.162]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 162

Narrated 'Abdullah bin 'Umar:

concerning the dream of the Prophet in Medina: The Prophet said, "I saw (in a dream) a black woman with unkempt hair going out of Medina and settling at Mahai'a. I interpreted that as (a symbol of) the epidemic of Medina being transferred to Mahai'a, namely, Al-Juhfa."


Bukhari :: Interpretation of Dreams :: [9.87.163]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 163

Narrated Salim's father:

The Prophet said, "I saw (in a dream) a black woman with unkempt hair going out of Medina and settling in Mahai'a. I interpreted that as (a symbol of) epidemic of Medina being transferred to Mahai'a, namely, Al-Juhfa."


Bukhari :: Interpretation of Dreams :: [9.87.164]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 164

Narrated Abu Musa:

The Prophet said, "I saw in a dream that I waved a sword and it broke in the middle, and behold, that symbolized the casualties the believers suffered on the Day (of the battle) of Uhud. Then I waved the sword again, and it became better than it had ever been before, and behold, that symbolized the Conquest (of Mecca) which Allah brought about and the gathering of the believers. "


Bukhari :: Interpretation of Dreams :: [9.87.165]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 165

Narrated Ibn Abbas:

The Prophet said, "Whoever claims to have seen a dream which he did not see, will be ordered to make a knot between two barley grains which he will not be able to do; and if somebody listens to the talk of some people who do not like him (to listen) or they run away from him, then molten lead will be poured into his ears on the Day of Resurrection; and whoever makes a picture, will be punished on the Day of Resurrection and will be ordered to put a soul in that picture, which he will not be able to do."


Bukhari :: Interpretation of Dreams :: [9.87.166]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 166

Narrated Ibn 'Abbas:

as above, 165.


Bukhari :: Interpretation of Dreams :: [9.87.167]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 167

Narrated Ibn 'Umar:

Allah's Apostle said, "The worst lie is that a person claims to have seen a dream which he has not seen."


Bukhari :: Interpretation of Dreams :: [9.87.168]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 168

Narrated Abu Salama:

I used to see a dream which would make me sick till I heard Abu Qatada saying, "I too, used to see a dream which would make me sick till I heard the Prophet saying, "A good dream is from Allah, so if anyone of you saw a dream which he liked, he should not tell it to anybody except to the one whom he loves, and if he saw a dream which he disliked, then he should seek refuge with Allah from its evil and from the evil of Satan, and spit three times (on his left) and should not tell it to anybody, for it will not harm him. "


Bukhari :: Interpretation of Dreams :: [9.87.169]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 169

Narrated Abu Sa'id Al-Khudri:

I heard Allah's Apostle saying, "If anyone of you saw a dream which he liked, then that was from Allah, and he should thank Allah for it and tell it to others; but if he saw something else, i.e, a dream which he did not like, then that is from Satan and he should seek refuge with Allah from it and should not tell it to anybody for it will not harm him."


Bukhari :: Interpretation of Dreams :: [9.87.170]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 170

Narrated Ibn 'Abbas:

A man came to Allah's Apostle and said, "I saw in a dream, a cloud having shade. Butter and honey were dropping from it and I saw the people gathering it in their hands, some gathering much and some a little. And behold, there was a rope extending from the earth to the sky, and I saw that you (the Prophet) held it and went up, and then another man held it and went up and (after that) another (third) held it and went up, and then after another (fourth) man held it, but it broke and then got connected again." Abu Bakr said, "O Allah's Apostle! Let my father be sacrificed for you! Allow me to interpret this dream." The Prophet said to him, "Interpret it." Abu Bakr said, "The cloud with shade symbolizes Islam, and the butter and honey dropping from it, symbolizes the Quran, its sweetness dropping and some people learning much of the Qur'an and some a little. The rope which is extended from the sky to the earth is the Truth which you (the Prophet) are following. You follow it and Allah will raise you high with it, and then another man will follow it and will rise up with it and another person will follow it and then another man will follow it but it will break and then it will be connected for him and he will rise up with it. O Allah's Apostle! Let my father be sacrificed for you! Am I right or wrong?" The Prophet replied, "You are right in some of it and wrong in some." Abu Bakr said, "O Allah's Prophet! By Allah, you must tell me in what I was wrong." The Prophet said, "Do not swear."


Bukhari :: Interpretation of Dreams :: [9.87.171]

Interpretation of Dreams

Bukhari :: Book 9 :: Volume 87 :: Hadith 171

Narrated Samura bin Jundub:

Allah's Apostle very often used to ask his companions, "Did anyone of you see a dream?" So dreams would be narrated to him by those whom Allah wished to tell. One morning the Prophet said, "Last night two persons came to me (in a dream) and woke me up and said to me, 'Proceed!' I set out with them and we came across a man Lying down, and behold, another man was standing over his head, holding a big rock. Behold, he was throwing the rock at the man's head, injuring it. The rock rolled away and the thrower followed it and took it back. By the time he reached the man, his head returned to the normal state. The thrower then did the same as he had done before. I said to my two companions, 'Subhan Allah! Who are these two persons?' They said, 'Proceed!' So we proceeded and came to a man Lying flat on his back and another man standing over his head with an iron hook, and behold, he would put the hook in one side of the man's mouth and tear off that side of his face to the back (of the neck) and similarly tear his nose from front to back and his eye from front to back. Then he turned to the other side of the man's face and did just as he had done with the other side. He hardly completed this side when the other side returned to its normal state. Then he returned to it to repeat what he had done before. I said to my two companions, 'Subhan Allah! Who are these two persons?' They said to me, 'Proceed!' So we proceeded and came across something like a Tannur (a kind of baking oven, a pit usually clay-lined for baking bread)." I think the Prophet said, "In that oven t here was much noise and voices." The Prophet added, "We looked into it and found naked men and women, and behold, a flame of fire was reaching to them from underneath, and when it reached them, they cried loudly. I asked them, 'Who are these?' They said to me, 'Proceed!' And so we proceeded and came across a river." I think he said, ".... red like blood." The Prophet added, "And behold, in the river there was a man swimming, and on the bank there was a man who had collected many stones. Behold. while the other man was swimming, he went near him. The former opened his mouth and the latter (on the bank) threw a stone into his mouth whereupon he went swimming again. He returned and every time the performance was repeated, I asked my two companions, 'Who are these (two) persons?' They replied, 'Proceed! Proceed!' And we proceeded till we came to a man with a repulsive appearance, the most repulsive appearance, you ever saw a man having! Beside him there was a fire and he was kindling it and running around it. I asked my companions, 'Who is this (man)?' They said to me, 'Proceed! Proceed!' So we proceeded till we reached a garden of deep green dense vegetation, having all sorts of spring colors. In the midst of the garden there was a very tall man and I could hardly see his head because of his great height, and around him there were children in such a large number as I have never seen. I said to my companions, 'Who is this?' They replied, 'Proceed! Proceed!' So we proceeded till we came to a majestic huge garden, greater and better than I have ever seen! My two companions said to me, 'Go up and I went up' The Prophet added, "So we ascended till we reached a city built of gold and silver bricks and we went to its gate and asked (the gatekeeper) to open the gate, and it was opened and we entered the city and found in it, men with one side of their bodies as handsome as the handsomest person you have ever seen, and the other side as ugly as the ugliest person you have ever seen. My two companions ordered those men to throw themselves into the river. Behold, there was a river flowing across (the city), and its water was like milk in whiteness. Those men went and threw themselves in it and then returned to us after the ugliness (of their bodies) had disappeared and they became in the best shape." The Prophet further added, "My two companions (angels) said to me, 'This place is the Eden Paradise, and that is your place.' I raised up my sight, and behold, there I saw a palace like a white cloud! My two companions said to me, 'That (palace) is your place.' I said to them, 'May Allah bless you both! Let me enter it.' They replied, 'As for now, you will not enter it, but you shall enter it (one day) I said to them, 'I have seen many wonders tonight. What does all that mean which I have seen?' They replied, 'We will inform you: As for the first man you came upon whose head was being injured with the rock, he is the symbol of the one who studies the Quran and then neither recites it nor acts on its orders, and sleeps, neglecting the enjoined prayers. As for the man you came upon whose sides of mouth, nostrils and eyes were torn off from front to back, he is the symbol of the man who goes out of his house in the morning and tells so many lies that it spreads all over the world. And those naked men and women whom you saw in a construction resembling an oven, they are the adulterers and the adulteresses;, and the man whom you saw swimming in the river and given a stone to swallow, is the eater of usury (Riba) and the bad looking man whom you saw near the fire kindling it and going round it, is Malik, the gatekeeper of Hell and the tall man whom you saw in the garden, is Abraham and the children around him are those children who die with Al-Fitra (the Islamic Faith)." The narrator added: Some Muslims asked the Prophet, "O Allah's Apostle! What about the children of pagans?" The Prophet replied, "And also the children of pagans." The Prophet added, "My two companions added, 'The men you saw half handsome and half ugly were those persons who had mixed an act that was good with another that was bad, but Allah forgave them.'"


Bukhari :: Afflictions and the End of the World :: [9.88.172]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 172

Narrated Asma':

The Prophet said, "I will be at my Lake-Fount (Kauthar) waiting for whoever will come to me. Then some people will be taken away from me whereupon I will say, 'My followers!' It will be said, 'You do not know they turned Apostates as renegades (deserted their religion).'" (Ibn Abi Mulaika said, "Allah, we seek refuge with You from turning on our heels from the (Islamic) religion and from being put to trial").


Bukhari :: Afflictions and the End of the World :: [9.88.173]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 173

Narrated 'Abdullah:

The Prophet said, "I am your predecessor at the Lake-Fount (Kauthar) and some men amongst you will be brought to me, and when I will try to hand them some water, they will be pulled away from me by force whereupon I will say, 'O Lord, my companions!' Then the Almighty will say, 'You do not know what they did after you left, they introduced new things into the religion after you.'"


Bukhari :: Afflictions and the End of the World :: [9.88.174]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 174

Narrated Sahl bin Sa'd:

I heard the Prophet saying, "I am your predecessor at the Lake-Fount (Kauthar), and whoever will come to it, will drink from it, and whoever will drink from it, will never become thirsty after that. There will come to me some people whom I know and they know me, and then a barrier will be set up between me and them." Abu Sa'id Al-Khudri added that the Prophet further said: "I will say those people are from me. It will be said, 'You do not know what changes and new things they did after you.' Then I will say, 'Far removed (from mercy), far removed (from mercy), those who changed (the religion) after me! "


Bukhari :: Afflictions and the End of the World :: [9.88.175]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 175

Narrated Abdullah:

Allah's Apostle said to us, "You will see after me, selfishness (on the part of other people) and other matters that you will disapprove of." They asked, "What do you order us to do, O Allah's Apostle? (under such circumstances)?" He said, "Pay their rights to them (to the rulers) and ask your right from Allah."


Bukhari :: Afflictions and the End of the World :: [9.88.176]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 176

Narrated Ibn Abbas:

The Prophet said, "Whoever disapproves of something done by his ruler then he should be patient, for whoever disobeys the ruler even a little (little = a span) will die as those who died in the Pre-lslamic Period of Ignorance. (i.e. as rebellious Sinners).


Bukhari :: Afflictions and the End of the World :: [9.88.177]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 177

Narrated Ibn 'Abbas:

The Prophet said, "Whoever notices something which he dislikes done by his ruler, then he should be patient, for whoever becomes separate from the company of the Muslims even for a span and then dies, he will die as those who died in the Pre-lslamic period of Ignorance (as rebellious sinners). (Fateh-Al-Bari page 112, Vol. 16)


Bukhari :: Afflictions and the End of the World :: [9.88.178]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 178

Narrated Junada bin Abi Umaiya:

We entered upon 'Ubada bin As-Samit while he was sick. We said, "May Allah make you healthy. Will you tell us a Hadith you heard from the Prophet and by which Allah may make you benefit?" He said, "The Prophet called us and we gave him the Pledge of allegiance for Islam, and among the conditions on which he took the Pledge from us, was that we were to listen and obey (the orders) both at the time when we were active and at the time when we were tired, and at our difficult time and at our ease and to be obedient to the ruler and give him his right even if he did not give us our right, and not to fight against him unless we noticed him having open Kufr (disbelief) for which we would have a proof with us from Allah."


Bukhari :: Afflictions and the End of the World :: [9.88.179]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 179

Narrated Usaid bin Hudair:

A man came to the Prophet and said, "O Allah's Apostle! You appointed such-and-such person and you did not appoint me?" The Prophet said, "After me you will see rulers not giving you your right (but you should give them their right) and be patient till you meet me."


Bukhari :: Afflictions and the End of the World :: [9.88.180]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 180

Narrated Abu Huraira:

I heard the truthful and trusted by Allah (i.e., the Prophet ) saying, "The destruction of my followers will be through the hands of young men from Quraish."


Bukhari :: Afflictions and the End of the World :: [9.88.181]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 181

Narrated Zainab bint Jahsh:

The Prophet got up from his sleep with a flushed red face and said, "None has the right to be worshipped but Allah. Woe to the Arabs, from the Great evil that is nearly approaching them. Today a gap has been made in the wall of Gog and Magog like this." (Sufyan illustrated by this forming the number 90 or 100 with his fingers.) It was asked, "Shall we be destroyed though there are righteous people among us?" The Prophet said, "Yes, if evil increased."


Bukhari :: Afflictions and the End of the World :: [9.88.182]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 182

Narrated Usama bin Zaid:

Once the Prophet stood over one of the high buildings of Medina and then said (to the people), "Do you see what I see?" They said, "No." He said, "I see afflictions falling among your houses as rain drops fall."


Bukhari :: Afflictions and the End of the World :: [9.88.183]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 183

Narrated Abu Huraira:

The Prophet said, "Time will pass rapidly, good deeds will decrease, miserliness will be thrown (in the hearts of the people) afflictions will appear and there will be much 'Al-Harj." They said, "O Allah's Apostle! What is "Al-Harj?" He said, "Killing! Killing!" (See Hadith No. 63, Vol. 8)


Bukhari :: Afflictions and the End of the World :: [9.88.184]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 184

Narrated 'Abdullah and Abu Musa:

The Prophet said, "Near the establishment of the Hour there will be days during which Religious ignorance will spread, knowledge will be taken away (vanish) and there will be much Al-Harj, and Al-Harj means killing."


Bukhari :: Afflictions and the End of the World :: [9.88.185]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 185

Narrated Abu Musa:

The Prophet said, "Near the establishment of the Hour there will be days during which (religious) knowledge will be taken away (vanish) and general ignorance will spread, and there will be Al-Harj in abundance, and Al-Harj means killing."


Bukhari :: Afflictions and the End of the World :: [9.88.186]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 186

Narrated Abu Musa:

The Prophet said...(as above, 185). And Harj, in the Ethiopian language, means killing.


Bukhari :: Afflictions and the End of the World :: [9.88.187]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 187

Narrated 'Abdullah:

The Prophet said, "Near the establishment of the Hour, there will be the days of Al-Harj, and the religious knowledge will be taken away (vanish i.e. by the death of Religious scholars) and general ignorance will spread." Abu Musa said, "Al-Harj, in the Ethiopian language, means killing," Ibn Mas'ud added: I heard Allah's Apostle saying; (It will be) from among the most wicked people who will be living at the time when the Hour will be established."


Bukhari :: Afflictions and the End of the World :: [9.88.188]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 188

Narrated Az-Zubair bin 'Adi:

We went to Anas bin Malik and complained about the wrong we were suffering at the hand of Al-Hajjaj. Anas bin Malik said, "Be patient till you meet your Lord, for no time will come upon you but the time following it will be worse than it. I heard that from the Prophet."


Bukhari :: Afflictions and the End of the World :: [9.88.189]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 189

Narrated Um Salama:

(the wife of the Prophet) Allah's Apostle woke up one night in a state of terror and said, "Subhan Allah, How many treasures Allah has sent down! And how many afflictions have been sent down! Who will go and wake the lady dwellers (wives of the Prophet) up of these rooms (for prayers)?" He meant his wives, so that they might pray. He added, "A well-dressed (soul) in this world may be naked in the Hereafter."


Bukhari :: Afflictions and the End of the World :: [9.88.190]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 190

Narrated:

The statement of the Prophet: Whoever takes up arms against us, is not from us."


Bukhari :: Afflictions and the End of the World :: [9.88.191]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 191

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Whoever takes up arms against us, is not from us."


Bukhari :: Afflictions and the End of the World :: [9.88.192]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 192

Narrated Abu Musa:

The Prophet said, "Whoever takes up arms against us, is not from us."


Bukhari :: Afflictions and the End of the World :: [9.88.193]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 193

Narrated Abu Huraira:

The Prophet said, "None of you should point out towards his Muslim brother with a weapon, for he does not know, Satan may tempt him to hit him and thus he would fall into a pit of fire (Hell)"


Bukhari :: Afflictions and the End of the World :: [9.88.194]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 194

Narrated Sufyan:

I said to 'Amr, "O Abu Muhammad! Did you hear Jabir bin 'Abdullah saying, 'A man carrying arrows passed through the mosque and Allah's Apostle said to him, 'Hold the arrows by their heads! "'Amr replied, "Yes."


Bukhari :: Afflictions and the End of the World :: [9.88.195]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 195

Narrated Jabir:

A man passed through the mosque and he was carrying arrows, the heads of which were exposed (protruding). The man was ordered (by the Prophet) to hold the iron heads so that it might not scratch (injure) any Muslim.


Bukhari :: Afflictions and the End of the World :: [9.88.196]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 196

Narrated Abu Musa:

The Prophet said, "If anyone of you passed through our mosque or through our market while carrying arrows, he should hold the iron heads," or said, "..... he should hold (their heads) firmly with his hand lest he should injure one of the Muslims with it."


Bukhari :: Afflictions and the End of the World :: [9.88.197]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 197

Narrated 'Abdullah:

The Prophet, said, "Abusing a Muslim is Fusuq (evil doing) and killing him is Kufr (disbelief)."


Bukhari :: Afflictions and the End of the World :: [9.88.198]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 198

Narrated Ibn 'Umar:

I heard the Prophet saying, "Do not revert to disbelief after me by striking (cutting) the necks of one another."


Bukhari :: Afflictions and the End of the World :: [9.88.199]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 199

Narrated Abu Bakra:

Allah's Apostle addressed the people saying, "Don't you know what is the day today?" They replied, "Allah and His Apostle know better." We thought that he might give that day another name. The Prophet said, "Isn't it the day of An-Nahr?" We replied, "Yes. O Allah's Apostle." He then said, "What town is this? Isn't it the forbidden (Sacred) Town (Mecca)?" We replied, "Yes, O Allah's Apostle." He then said, "Your blood, your properties, your honors and your skins (i.e., bodies) are as sacred to one another like the sanctity of this day of yours in this month of yours in this town of yours. (Listen) Haven't I conveyed Allah's message to you?" We replied, "Yes" He said, "O Allah! Be witness (for it). So it is incumbent upon those who are present to convey it (this message of mine) to those who are absent because the informed one might comprehend what I have said better than the present audience who will convey it to him.)" The narrator added: In fact, it was like that. The Prophet added, "Beware! Do not renegade as disbelievers after me by striking (cutting) the necks of one another."


Bukhari :: Afflictions and the End of the World :: [9.88.200]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 200

Narrated Ibn Abbas:

The Prophet said, "Beware! Do not renegade as (disbelievers) after me by striking (cutting) the necks of one another."


Bukhari :: Afflictions and the End of the World :: [9.88.201]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 201

Narrated Jarir:

The Prophet said to me during Hajjat-al-Wada', "Let the people keep quiet and listen." Then he said (addressing the people), "Beware! Do not renegade as disbelievers after me by striking (cutting) the necks of one another."


Bukhari :: Afflictions and the End of the World :: [9.88.202]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 202

Narrated Abu Huraira:

Allah's Apostle said, "There will be afflictions (in the near future) during which a sitting person will be better than a standing one, and the standing one will be better than the walking one, and the walking one will be better than the running one, and whoever will expose himself to these afflictions, they will destroy him. So whoever can find a place of protection or refuge from them, should take shelter in it."


Bukhari :: Afflictions and the End of the World :: [9.88.203]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 203

Narrated Abu Huraira:

Allah's Apostle said, "There will be afflictions (in the near future) during which a sitting person will be better than a standing one, and the standing one will be better than a walking one, and the walking one will be better than a running one, and whoever will expose himself to these afflictions, they will destroy him. So whoever can find a place of protection or refuge from them, should take shelter in it."


Bukhari :: Afflictions and the End of the World :: [9.88.204]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 204

Narrated Al-Hasan:

(Al-Ahnaf said:) I went out carrying my arms during the nights of the affliction (i.e. the war between 'Ali and 'Aisha) and Abu Bakra met me and asked, "Where are you going?" I replied, "I intend to help the cousin of Allah's Apostle (i.e.,'Ali)." Abu Bakra said, "Allah's Apostle said, 'If two Muslims take out their swords to fight each other, then both of them will be from amongst the people of the Hell-Fire.' It was said to the Prophet, 'It is alright for the killer but what about the killed one?' He replied, 'The killed one had the intention to kill his opponent.'" (See Hadith No. 30, Vol. 1)


Bukhari :: Afflictions and the End of the World :: [9.88.205]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 205

Narrated Al-Ahnaf:

Abu Bakra said: The Prophet said (as above, 204).


Bukhari :: Afflictions and the End of the World :: [9.88.206]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 206

Narrated Hudhaifa bin Al-Yaman:

The people used to ask Allah's Apostle about the good but I used to ask him about the evil lest I should be overtaken by them. So I said, "O Allah's Apostle! We were living in ignorance and in an (extremely) worst atmosphere, then Allah brought to us this good (i.e., Islam); will there be any evil after this good?" He said, "Yes." I said, 'Will there be any good after that evil?" He replied, "Yes, but it will be tainted (not pure.)'' I asked, "What will be its taint?" He replied, "(There will be) some people who will guide others not according to my tradition? You will approve of some of their deeds and disapprove of some others." I asked, "Will there be any evil after that good?" He replied, "Yes, (there will be) some people calling at the gates of the (Hell) Fire, and whoever will respond to their call, will be thrown by them into the (Hell) Fire." I said, "O Allah s Apostle! Will you describe them to us?" He said, "They will be from our own people and will speak our language." I said, "What do you order me to do if such a state should take place in my life?" He said, "Stick to the group of Muslims and their Imam (ruler)." I said, "If there is neither a group of Muslims nor an Imam (ruler)?" He said, "Then turn away from all those sects even if you were to bite (eat) the roots of a tree till death overtakes you while you are in that state."


Bukhari :: Afflictions and the End of the World :: [9.88.207]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 207

Narrated Abu Al-Aswad:

An army unit was being recruited from the people of Medina and my name was written among them. Then I met 'Ikrima, and when I informed him about it, he discouraged me very strongly and said, "Ibn 'Abbas told me that there were some Muslims who were with the pagans to increase their number against Allah's Apostle (and the Muslim army) so arrows (from the Muslim army) would hit one of them and kill him or a Muslim would strike him (with his sword) and kill him. So Allah revealed:--

'Verily! As for those whom the angels take (in death) while they are wronging themselves (by staying among the disbelievers).' (4.97)


Bukhari :: Afflictions and the End of the World :: [9.88.208]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 208

Narrated Hudhaifa:

Allah's Apostle related to us, two prophetic narrations one of which I have seen fulfilled and I am waiting for the fulfillment of the other. The Prophet told us that the virtue of honesty descended in the roots of men's hearts (from Allah) and then they learned it from the Qur'an and then they learned it from the Sunna (the Prophet's traditions). The Prophet further told us how that honesty will be taken away: He said: "Man will go to sleep during which honesty will be taken away from his heart and only its trace will remain in his heart like the trace of a dark spot; then man will go to sleep, during which honesty will decrease further still, so that its trace will resemble the trace of blister as when an ember is dropped on one's foot which would make it swell, and one would see it swollen but there would be nothing inside. People would be carrying out their trade but hardly will there be a trustworthy person. It will be said, 'in such-and-such tribe there is an honest man,' and later it will be said about some man, 'What a wise, polite and strong man he is!' Though he will not have faith equal even to a mustard seed in his heart." No doubt, there came upon me a time when I did not mind dealing (bargaining) with anyone of you, for if he was a Muslim his Islam would compel him to pay me what is due to me, and if he was a Christian, the Muslim official would compel him to pay me what is due to me, but today I do not deal except with such-and-such person.


Bukhari :: Afflictions and the End of the World :: [9.88.209]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 209

Narrated Salama bin Al-Akwa:

That he visited Al-Hajjaj (bin Yusuf). Al-Hajjaj said, "O son of Al-Akwa! You have turned on your heels (i.e., deserted Islam) by staying (in the desert) with the bedouins." Salama replied, "No, but Allah's Apostle allowed me to stay with the bedouin in the desert." Narrated Yazid bin Abi Ubaid: When 'Uthman bin Affan was killed (martyred), Salama bin Al-Akwa' went out to a place called Ar-Rabadha and married there and begot children, and he stayed there till a few nights before his death when he came to Medina.


Bukhari :: Afflictions and the End of the World :: [9.88.210]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 210

Narrated Abu Sa'id Al-Khudri:

Allah's Apostle said, "There will come a time when the best property of a Muslim will be sheep which he will take to the tops of mountains and the places of rainfall so as to flee with his religion from the afflictions.


Bukhari :: Afflictions and the End of the World :: [9.88.211]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 211

Narrated Anas:

The people started asking the Prophet too many questions importunately. So one day he ascended the pulpit and said, "You will not ask me any question but I will explain it to you." I looked right and left, and behold, every man was covering his head with his garment and weeping. Then got up a man who, whenever quarreling with somebody, used to be accused of not being the son of his father. He said, "O Allah's Apostle! Who is my father?" The Prophet replied, "Your father is Hudhaifa." Then 'Umar got up and said, "We accept Allah as our Lord, Islam as our religion and Muhammad as our Apostle and we seek refuge with Allah from the evil of afflictions." The Prophet said, " I have never seen the good and bad like on this day. No doubt, Paradise and Hell was displayed in front of me till I saw them in front of that wall," Qatada said: This Hadith used to be mentioned as an explanation of this Verse:-- 'O you who believe! Ask not questions about things which, if made plain to you, may cause you trouble.' (5.101)


Bukhari :: Afflictions and the End of the World :: [9.88.212]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 212

Narrated Salim's father:

The Prophet stood up beside the pulpit (and pointed with his finger towards the East) and said, "Afflictions are there! Afflictions are there, from where the side of the head of Satan comes out," or said, "..the side of the sun.."


Bukhari :: Afflictions and the End of the World :: [9.88.213]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 213

Narrated Ibn 'Umar:

I heard Allah's Apostle while he was facing the East, saying, "Verily! Afflictions are there, from where the side of the head of Satan comes out."


Bukhari :: Afflictions and the End of the World :: [9.88.214]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 214

Narrated Ibn 'Umar:

The Prophet said, "O Allah! Bestow Your blessings on our Sham! O Allah! Bestow Your blessings on our Yemen." The People said, "And also on our Najd." He said, "O Allah! Bestow Your blessings on our Sham (north)! O Allah! Bestow Your blessings on our Yemen." The people said, "O Allah's Apostle! And also on our Najd." I think the third time the Prophet said, "There (in Najd) is the place of earthquakes and afflictions and from there comes out the side of the head of Satan."


Bukhari :: Afflictions and the End of the World :: [9.88.215]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 215

Narrated Sa'id bin Jubair:

'Abdullah bin 'Umar came to us and we hoped that he would narrate to us a good Hadith. But before we asked him, a man got up and said to him, "O Abu 'Abdur-Rahman! Narrate to us about the battles during the time of the afflictions, as Allah says:--

'And fight them until there is no more afflictions (i.e. no more worshipping of others besides Allah).'" (2.193) Ibn 'Umar said (to the man), "Do you know what is meant by afflictions? Let your mother bereave you! Muhammad used to fight against the pagans, for a Muslim was put to trial in his religion (The pagans will either kill him or chain him as a captive). His fighting was not like your fighting which is carried on for the sake of ruling."


Bukhari :: Afflictions and the End of the World :: [9.88.216]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 216

Narrated Shaqiq:

I heard Hudhaifa saying, "While we were sitting with 'Umar, he said, 'Who among you remembers the statement of the Prophet about the afflictions?' Hudhaifa said, "The affliction of a man in his family, his property, his children and his neighbors are expiated by his prayers, Zakat (and alms) and enjoining good and forbidding evil." 'Umar said, "I do not ask you about these afflictions, but about those afflictions which will move like the waves of the sea." Hudhaifa said, "Don't worry about it, O chief of the believers, for there is a closed door between you and them." 'Umar said, "Will that door be broken or opened?" I said, "No. it will be broken." 'Umar said, "Then it will never be closed," I said, "Yes." We asked Hudhaifa, "Did 'Umar know what that door meant?" He replied, "Yes, as I know that there will be night before tomorrow morning, that is because I narrated to him a true narration free from errors." We dared not ask Hudhaifa as to whom the door represented so we ordered Masruq to ask him what does the door stand for? He replied, "'Umar."


Bukhari :: Afflictions and the End of the World :: [9.88.217]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 217

Narrated Abu Musa Al-Ash'ari:

The Prophet went out to one of the gardens of Medina for some business and I went out to follow him. When he entered the garden, I sat at its gate and said to myself, "To day I will be the gatekeeper of the Prophet though he has not ordered me." The Prophet went and finished his need and went to sit on the constructed edge of the well and uncovered his legs and hung them in the well. In the meantime Abu Bakr came and asked permission to enter. I said (to him), "Wait till I get you permission." Abu Bakr waited outside and I went to the Prophet and said, "O Allah's Prophet! Abu Bakr asks your permission to enter." He said, "Admit him, and give him the glad tidings of entering Paradise." So Abu Bakr entered and sat on the right side of the Prophet and uncovered his legs and hung them in the well. Then 'Umar came and I said (to him), "Wait till I get you permission." The Prophet said, "Admit him and give him the glad tidings of entering Paradise." So Umar entered and sat on the left side of the Prophet and uncovered his legs and hung them in the well so that one side of the well became fully occupied and there remained no place for any-one to sit. Then 'Uthman came and I said (to him), "Wait till I get permission for you." The Prophet said, "Admit him and give him the glad tidings of entering Paradise with a calamity which will befall him." When he entered, he could not find any place to sit with them so he went to the other edge of the well opposite them and uncovered his legs and hung them in the well. I wished that a brother of mine would come, so I invoked Allah for his coming. (Ibn Al-Musaiyab said, "I interpreted that (narration) as indicating their graves. The first three are together and the grave of 'Uthman is separate from theirs.")


Bukhari :: Afflictions and the End of the World :: [9.88.218]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 218

Narrated Abu Wail:

Someone said to Usama, "Will you not talk to this (Uthman)?" Usama said, "I talked to him (secretly) without being the first man to open an evil door. I will never tell a ruler who rules over two men or more that he is good after I heard Allah's Apostle saying, 'A man will be brought and put in Hell (Fire) and he will circumambulate (go around and round) in Hell (Fire) like a donkey of a (flour) grinding mill, and all the people of Hell (Fire) will gather around him and will say to him, O so-and-so! Didn't you use to order others for good and forbid them from evil?' That man will say, 'I used to order others to do good but I myself never used to do it, and I used to forbid others from evil while I myself used to do evil.' "


Bukhari :: Afflictions and the End of the World :: [9.88.219]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 219

Narrated Abu Bakra:

During the battle of Al-Jamal, Allah benefited me with a Word (I heard from the Prophet). When the Prophet heard the news that the people of the Persia had made the daughter of Khosrau their Queen (ruler), he said, "Never will succeed such a nation as makes a woman their ruler."


Bukhari :: Afflictions and the End of the World :: [9.88.220]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 220

Narrated Abu Maryam Abdullah bin Ziyad Al-Aasadi:

When Talha, AzZubair and 'Aisha moved to Basra, 'Ali sent 'Ammar bin Yasir and Hasan bin 'Ali who came to us at Kufa and ascended the pulpit. Al-Hasan bin 'Ali was at the top of the pulpit and 'Ammar was below Al-Hasan. We all gathered before him. I heard 'Ammar saying, "'Aisha has moved to Al-Busra. By Allah! She is the wife of your Prophet in this world and in the Hereafter. But Allah has put you to test whether you obey Him (Allah) or her ('Aisha)."


Bukhari :: Afflictions and the End of the World :: [9.88.221]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 221

Narrated Abu Wail:

'Ammar stood on the pulpit at Kufa and mentioned 'Aisha and her coming (to Busra) and said, "She is the wife of your Prophet in this world and in the Hereafter, but you people are being put to test in this issue."


Bukhari :: Afflictions and the End of the World :: [9.88.222]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 222

Narrated Abu Wail:

Abu Musa and Abii Mas'ud went to 'Ammar when 'Ali had sent him to Kufa to exhort them to fight (on 'Ali's side). They said to him, "Since you have become a Muslim, we have never seen you doing a deed more criticizable to us than your haste in this matter." 'Ammar said, "Since you (both) became Muslims, I have never seen you doing a deed more criticizable to me than your keeping away from this matter." Then Abu Mas'ud provided 'Ammar and Abu Musa with two-piece outfits to wear, and one of them went to the mosque (of Kufa).


Bukhari :: Afflictions and the End of the World :: [9.88.223]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 223

Narrated Shaqiq bin Salama:

I was sitting with Abu Mas'ud and Abu Musa and 'Ammar. Abu Mas'ud said (to 'Ammar), "There is none of your companions but, if I wish, I could find fault with him except with you. Since you joined the company of the Prophet I have never seen anything done by you more criticizable by me than your haste in this issue." 'Ammar said, O Abu Mas'ud ! I have never seen anything done by you or by this companion of yours (i.e., Abu Musa) more criticizable by me than your keeping away from this issue since the time you both joined the company of the Prophet."

Then Abu Mas'ud who was a rich man, said (to his servant), "O boy! Bring two suits." Then he gave one to Abu Musa and the other to 'Ammar and said (to them), "Put on these suits before going for the Friday prayer. "


Bukhari :: Afflictions and the End of the World :: [9.88.224]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 224

Narrated Ibn 'Umar:

Allah's Apostle said, "If Allah sends punishment upon a nation then it befalls upon the whole population indiscriminately and then they will be resurrected (and judged) according to their deeds. "


Bukhari :: Afflictions and the End of the World :: [9.88.225]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 225

Narrated Al-Hasan Al-Basri:

When Al-Hasan bin 'Ali moved with army units against Muawiya, 'Amr bin AL-As said to Muawiya, "I see an army that will not retreat unless and until the opposing army retreats." Muawiya said, "(If the Muslims are killed) who will look after their children?" 'Amr bin Al-As said: I (will look after them). On that, 'Abdullah bin 'Amir and 'Abdur-Rahman bin Samura said, "Let us meet Muawaiya and suggest peace." Al-Hasan Al-Basri added: No doubt, I heard that Abu Bakra said, "Once while the Prophet was addressing (the people), Al-Hasan (bin 'Ali) came and the Prophet said, 'This son of mine is a chief, and Allah may make peace between two groups of Muslims through him."


Bukhari :: Afflictions and the End of the World :: [9.88.226]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 226

Narrated Harmala:

(Usama's Maula) Usama (bin Zaid) sent me to 'Ali (at Kufa) and said, "'Ali will ask you, 'What has prevented your companion from joining me?' You then should say to him, 'If you ('Ali) were in the mouth of a lion, I would like to be with you, but in this matter I won't take any part.' " Harmala added: "'Ali didn't give me anything (when I conveyed the message to him) so I went to Hasan, Hussain and Ibn Ja'far and they loaded my camels with much (wealth)."


Bukhari :: Afflictions and the End of the World :: [9.88.227]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 227

Narrated Nafi':

When the people of Medina dethroned Yazid bin Muawiya, Ibn 'Umar gathered his special friends and children and said, "I heard the Prophet saying, 'A flag will be fixed for every betrayer on the Day of Resurrection,' and we have given the oath of allegiance to this person (Yazid) in accordance with the conditions enjoined by Allah and His Apostle and I do not know of anything more faithless than fighting a person who has been given the oath of allegiance in accordance with the conditions enjoined by Allah and His Apostle , and if ever I learn that any person among you has agreed to dethrone Yazid, by giving the oath of allegiance (to somebody else) then there will be separation between him and me."


Bukhari :: Afflictions and the End of the World :: [9.88.228]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 228

Narrated Abu Al-Minhal:

When Ibn Ziyad and Marwan were in Sham and Ibn Az-Zubair took over the authority in Mecca and Qurra' (the Kharijites) revolted in Basra, I went out with my father to Abu Barza Al-Aslami till we entered upon him in his house while he was sitting in the shade of a room built of cane. So we sat with him and my father started talking to him saying, "O Abu Barza! Don't you see in what dilemma the people has fallen?" The first thing heard him saying "I seek reward from Allah for myself because of being angry and scornful at the Quraish tribe. O you Arabs! You know very well that you were in misery and were few in number and misguided, and that Allah has brought you out of all that with Islam and with Muhammad till He brought you to this state (of prosperity and happiness) which you see now; and it is this worldly wealth and pleasures which has caused mischief to appear among you. The one who is in Sham (i.e., Marwan), by Allah, is not fighting except for the sake of worldly gain: and those who are among you, by Allah, are not fighting except for the sake of worldly gain; and that one who is in Mecca (i.e., Ibn Az-Zubair) by Allah, is not fighting except for the sake of worldly gain."


Bukhari :: Afflictions and the End of the World :: [9.88.229]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 229

Narrated Abi Waih:

Hudhaifa bin Al-Yaman said, 'The hypocrites of today are worse than those of the lifetime of the Prophet, because in those days they used to do evil deeds secretly but today they do such deeds openly.'


Bukhari :: Afflictions and the End of the World :: [9.88.230]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 230

Narrated Abi Asha'sha:

Hudhaifa said, 'In fact, it was hypocrisy that existed in the lifetime of the Prophet but today it is Kufr (disbelief) after belief.'


Bukhari :: Afflictions and the End of the World :: [9.88.231]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 231

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till a man passes by a grave of somebody and says, 'Would that I were in his place.' "


Bukhari :: Afflictions and the End of the World :: [9.88.232]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 232

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established till the buttocks of the women of the tribe of Daus move while going round Dhi-al-Khalasa." Dhi-al-Khalasa was the idol of the Daus tribe which they used to worship in the Pre Islamic Period of ignorance.


Bukhari :: Afflictions and the End of the World :: [9.88.233]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 233

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established till a man from Qahtan appears, driving the people with his stick."


Bukhari :: Afflictions and the End of the World :: [9.88.234]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 234

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established till a fire will come out of the land of Hijaz, and it will throw light on the necks of the camels at Busra."


Bukhari :: Afflictions and the End of the World :: [9.88.235]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 235

Narrated Abu Huraira:

Allah's Apostle said, "Soon the river "Euphrates" will disclose the treasure (the mountain) of gold, so whoever will be present at that time should not take anything of it." Al-A'raj narrated from Abii Huraira that the Prophet said the same but he said, "It (Euphrates) will uncover a mountain of gold (under it)."


Bukhari :: Afflictions and the End of the World :: [9.88.236]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 236

Narrated Haritha bin Wahb:

I heard Allah's Apostle saying, "Give in charity because there will come a time on the people when a person will go out with his alms from place to place but will not find anybody to accept it."


Bukhari :: Afflictions and the End of the World :: [9.88.237]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 237

Narrated Abu Huraira:

Allah's Apostle said, "The Hour will not be established (1) till two big groups fight each other whereupon there will be a great number of casualties on both sides and they will be following one and the same religious doctrine, (2) till about thirty Dajjals (liars) appear, and each one of them will claim that he is Allah's Apostle, (3) till the religious knowledge is taken away (by the death of Religious scholars) (4) earthquakes will increase in number (5) time will pass quickly, (6) afflictions will appear, (7) Al-Harj, (i.e., killing) will increase, (8) till wealth will be in abundance ---- so abundant that a wealthy person will worry lest nobody should accept his Zakat, and whenever he will present it to someone, that person (to whom it will be offered) will say, 'I am not in need of it, (9) till the people compete with one another in constructing high buildings, (10) till a man when passing by a grave of someone will say, 'Would that I were in his place (11) and till the sun rises from the West. So when the sun will rise and the people will see it (rising from the West) they will all believe (embrace Islam) but that will be the time when: (As Allah said,) 'No good will it do to a soul to believe then, if it believed not before, nor earned good (by deeds of righteousness) through its Faith.' (6.158) And the Hour will be established while two men spreading a garment in front of them but they will not be able to sell it, nor fold it up; and the Hour will be established when a man has milked his she-camel and has taken away the milk but he will not be able to drink it; and the Hour will be established before a man repairing a tank (for his livestock) is able to water (his animals) in it; and the Hour will be established when a person has raised a morsel (of food) to his mouth but will not be able to eat it."


Bukhari :: Afflictions and the End of the World :: [9.88.238]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 238

Narrated Al-Mughira bin Shu'ba:

Nobody asked the Prophet as many questions as I asked regarding Ad-Dajjal. The Prophet said to me, "What worries you about him?" I said, "Because the people say that he will have a mountain of bread and a river of water with him (i.e. he will have abundance of food and water)" The Prophet said, "Nay, he is too mean to be allowed such a thing by Allah"' (but it is only to test mankind whether they believe in Allah or in Ad-Dajjal.)


Bukhari :: Afflictions and the End of the World :: [9.88.239]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 239

Narrated Anas bin Malik:

The Prophet said, "Ad-Dajjal will come and encamp at a place close to Medina and then Medina will shake thrice whereupon every Kafir (disbeliever) and hypocrite will go out (of Medina) towards him."


Bukhari :: Afflictions and the End of the World :: [9.88.240]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 240

Narrated Abu Bakra:

The Prophet said, "The terror caused by Al-Masih Ad-Dajjal will not enter Medina and at that time Medina will have seven gates and there will be two angels at each gate (guarding them).


Bukhari :: Afflictions and the End of the World :: [9.88.241]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 241

Narrated Abdullah bin Umar:

Allah's Apostle stood up amongst the people and then praised and glorified Allah as He deserved and then he mentioned Ad-Dajjal, saying, "I warn you of him, and there was no prophet but warned his followers of him; but I will tell you something about him which no prophet has told his followers: Ad-Dajjal is one-eyed whereas Allah is not."


Bukhari :: Afflictions and the End of the World :: [9.88.242]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 242

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said. "While I was sleeping, I saw myself (in a dream) performing Tawaf around the Ka'ba. Behold, I saw a reddish-white man with lank hair, and water was dropping from his head. I asked, "Who is this?' They replied, 'The son of Mary.' Then I turned my face to see another man with a huge body, red complexion and curly hair and blind in one eye. His eye looked like a protruding out grape. They said (to me), He is Ad-Dajjal." The Prophet added, "The man he resembled most is Ibn Qatan, a man from the tribe of Khuza'a. "


Bukhari :: Afflictions and the End of the World :: [9.88.243]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 243

Narrated 'Aisha:

I heard Allah's Apostle in his prayer, seeking refuge with Allah from the afflictions of Ad-Dajjal.


Bukhari :: Afflictions and the End of the World :: [9.88.244]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 244

Narrated Hudhaifa:

The Prophet said about Ad-Dajjal that he would have water and fire with him: (what would seem to be) fire, would be cold water and (what would seem to be) water, would be fire.


Bukhari :: Afflictions and the End of the World :: [9.88.245]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 245

Narrated Anas:

The Prophet said, "No prophet was sent but that he warned his followers against the one-eyed liar (Ad-Dajjal). Beware! He is blind in one eye, and your Lord is not so, and there will be written between his (Ad-Dajjal's) eyes (the word) Kafir (i.e., disbeliever)." (This Hadith is also quoted by Abu Huraira and Ibn 'Abbas).


Bukhari :: Afflictions and the End of the World :: [9.88.246]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 246

Narrated Abu Sa'id:

One day Allah's Apostle narrated to us a long narration about Ad-Dajjal and among the things he narrated to us, was: "Ad-Dajjal will come, and he will be forbidden to enter the mountain passes of Medina. He will encamp in one of the salt areas neighboring Medina and there will appear to him a man who will be the best or one of the best of the people. He will say 'I testify that you are Ad-Dajjal whose story Allah's Apostle has told us.' Ad-Dajjal will say (to his audience), 'Look, if I kill this man and then give him life, will you have any doubt about my claim?' They will reply, 'No,' Then Ad-Dajjal will kill that man and then will make him alive. The man will say, 'By Allah, now I recognize you more than ever!' Ad-Dajjal will then try to kill him (again) but he will not be given the power to do so."


Bukhari :: Afflictions and the End of the World :: [9.88.247]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 247

Narrated Abu Huraira:

Allah's Apostle said, "There are angels at the mountain passes of Medina (so that) neither plague nor Ad-Dajjal can enter it.'


Bukhari :: Afflictions and the End of the World :: [9.88.248]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 248

Narrated Anas bin Malik:

The Prophet said, "Ad-Dajjal will come to Medina and find the angels guarding it. So Allah willing, neither Ad-Dajjal, nor plague will be able to come near it."


Bukhari :: Afflictions and the End of the World :: [9.88.249]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 249

Narrated Zainab bint Jahsh:

That one day Allah's Apostle entered upon her in a state of fear and said, "None has the right to be worshipped but Allah! Woe to the Arabs from the Great evil that has approached (them). Today a hole has been opened in the dam of Gog and Magog like this." The Prophet made a circle with his index finger and thumb. Zainab bint Jahsh added: I said, "O Alllah's Apostle! Shall we be destroyed though there will be righteous people among us?" The Prophet said, "Yes, if the (number) of evil (persons) increased."


Bukhari :: Afflictions and the End of the World :: [9.88.250]

Afflictions and the End of the World

Bukhari :: Book 9 :: Volume 88 :: Hadith 250

Narrated Abu Huraira:

The Prophet said, "A hole has been opened in the dam of Gog and Magog." Wuhaib (the sub-narrator) made the number 90 (with his index finger and thumb).


Bukhari :: Judgments (Ahkaam) :: [9.89.251]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 251

Narrated Abu Huraira:

Allah's Apostle said, "Whoever obeys me, obeys Allah, and whoever disobeys me, disobeys Allah, and whoever obeys the ruler I appoint, obeys me, and whoever disobeys him, disobeys me."


Bukhari :: Judgments (Ahkaam) :: [9.89.252]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 252

Narrated 'Abdullah bin 'Umar:

Allah's Apostle said, "Surely! Everyone of you is a guardian and is responsible for his charges: The Imam (ruler) of the people is a guardian and is responsible for his subjects; a man is the guardian of his family (household) and is responsible for his subjects; a woman is the guardian of her husband's home and of his children and is responsible for them; and the slave of a man is a guardian of his master's property and is responsible for it. Surely, everyone of you is a guardian and responsible for his charges."


Bukhari :: Judgments (Ahkaam) :: [9.89.253]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 253

Narrated Muhammad bin Jubair bin Mut'im:

That while he was included in a delegation of Quraish staying with Muawiya, Muawiya heard that 'Abdullah bin 'Amr had said that there would be a king from Qahtan tribe, whereupon he became very angry. He stood up, and after glorifying and praising Allah as He deserved, said, "To proceed, I have come to know that some of you men are narrating things which are neither in Allah's Book, nor has been mentioned by Allah's Apostle . Such people are the ignorant among you. Beware of such vain desires that mislead those who have them. I have heard Allah's Apostle saying, 'This matter (of the caliphate) will remain with the Quraish, and none will rebel against them, but Allah will throw him down on his face as long as they stick to the rules and regulations of the religion (Islam).'"


Bukhari :: Judgments (Ahkaam) :: [9.89.254]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 254

Narrated Ibn 'Umar:

Allah's Apostle said, "This matter (caliphate) will remain with the Quraish even if only two of them were still existing."


Bukhari :: Judgments (Ahkaam) :: [9.89.255]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 255

Narrated 'Abdullah:

Allah's Apostle said, "Do not wish to be like anyone, except in two cases: (1) A man whom Allah has given wealth and he spends it righteously. (2) A man whom Allah has given wisdom (knowledge of the Quran and the Hadith) and he acts according to it and teaches it to others."


Bukhari :: Judgments (Ahkaam) :: [9.89.256]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 256

Narrated Anas bin Malik:

Allah's Apostle said, "You should listen to and obey, your ruler even if he was an Ethiopian (black) slave whose head looks like a raisin."


Bukhari :: Judgments (Ahkaam) :: [9.89.257]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 257

Narrated Ibn 'Abbas:

The Prophet said, "If somebody sees his Muslim ruler doing something he disapproves of, he should be patient, for whoever becomes separate from the Muslim group even for a span and then dies, he will die as those who died in the Pre-lslamic period of ignorance (as rebellious sinners). (See Hadith No. 176 and 177)


Bukhari :: Judgments (Ahkaam) :: [9.89.258]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 258

Narrated 'Abdullah:

The Prophet said, "A Muslim has to listen to and obey (the order of his ruler) whether he likes it or not, as long as his orders involve not one in disobedience (to Allah), but if an act of disobedience (to Allah) is imposed one should not listen to it or obey it. (See Hadith No. 203, Vol. 4)


Bukhari :: Judgments (Ahkaam) :: [9.89.259]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 259

Narrated 'Ali:

The Prophet sent an army unit (for some campaign) and appointed a man from the Ansar as its commander and ordered them (the soldiers) to obey him. (During the campaign) he became angry with them and said, "Didn't the Prophet order you to obey me?" They said, "Yes." He said, "I order you to collect wood and make a fire and then throw yourselves into it." So they collected wood and made a fire, but when they were about to throw themselves into, it they started looking at each other, and some of them said, "We followed the Prophet to escape from the fire. How should we enter it now?" So while they were in that state, the fire extinguished and their commander's anger abated. The event was mentioned to the Prophet and he said, "If they had entered it (the fire) they would never have come out of it, for obedience is required only in what is good." (See Hadith No. 629. Vol. 5)


Bukhari :: Judgments (Ahkaam) :: [9.89.260]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 260

Narrated 'Abdur-Rahman bin Samura:

The Prophet said, "O 'Abdur-Rahman! Do not seek to be a ruler, for if you are given authority on your demand then you will be held responsible for it, but if you are given it without asking (for it), then you will be helped (by Allah) in it. If you ever take an oath to do something and later on you find that something else is better, then you should expiate your oath and do what is better."


Bukhari :: Judgments (Ahkaam) :: [9.89.261]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 261

Narrated 'Abdur-Rahman bin Samura:

Allah's Apostle said, "O 'Abdur-Rahman bin Samura! Do not seek to be a ruler, for if you are given authority on your demand, you will be held responsible for it, but if you are given it without asking for it, then you will be helped (by Allah) in it. If you ever take an oath to do something and later on you find that something else is better, then do what is better and make expiation for your oath."


Bukhari :: Judgments (Ahkaam) :: [9.89.262]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 262

Narrated Abu Huraira:

The Prophet said, "You people will be keen to have the authority of ruling which will be a thing of regret for you on the Day of Resurrection. What an excellent wet nurse it is, yet what a bad weaning one it is!"


Bukhari :: Judgments (Ahkaam) :: [9.89.263]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 263

Narrated Abu Musa:

Two men from my tribe and I entered upon the Prophet. One of the two men said to the Prophet, "O Allah's Apostle! Appoint me as a governor," and so did the second. The Prophet said, "We do not assign the authority of ruling to those who ask for it, nor to those who are keen to have it."


Bukhari :: Judgments (Ahkaam) :: [9.89.264]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 264

Narrated Ma'qil:

I heard the Prophet saying, "Any man whom Allah has given the authority of ruling some people and he does not look after them in an honest manner, will never feel even the smell of Paradise."


Bukhari :: Judgments (Ahkaam) :: [9.89.265]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 265

Narrated Ma'qil:

Allah's Apostle said, "If any ruler having the authority to rule Muslim subjects dies while he is deceiving them, Allah will forbid Paradise for him."


Bukhari :: Judgments (Ahkaam) :: [9.89.266]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 266

Narrated Tarif Abi Tamima:

I saw Safwan and Jundab and Safwan's companions when Jundab was advising. They said, "Did you hear something from Allah's Apostle?" Jundab said, "I heard him saying, 'Whoever does a good deed in order to show off, Allah will expose his intentions on the Day of Resurrection (before the people), and whoever puts the people into difficulties, Allah will put him into difficulties on the Day of Resurrection.'" The people said (to Jundab), "Advise us." He said, "The first thing of the human body to purify is the abdomen, so he who can eat nothing but good food (Halal and earned lawfully) should do so, and he who does as much as he can that nothing intervene between him and Paradise by not shedding even a handful of blood, (i.e. murdering) should do so."


Bukhari :: Judgments (Ahkaam) :: [9.89.267]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 267

Narrated Anas bin Malik:

Apostle." The Prophet said, "You will be with the one whom you love."


Bukhari :: Judgments (Ahkaam) :: [9.89.268]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 268

Narrated Thabit Al-Bunani:

Anas bin Malik said to a woman of his family, "Do you know such-and-such a woman?" She replied, "Yes." He said, "The Prophet passed by her while she was weeping over a grave, and he said to her, 'Be afraid of Allah and be patient.' The woman said (to the Prophet). 'Go away from me, for you do not know my calamity.'" Anas added, "The Prophet left her and proceeded. A man passed by her and asked her, 'What has Allah's Apostle said to you?' She replied, 'I did not recognize him.' The man said, 'He was Allah's Apostle."' Anas added, "So that woman came to the gate of the Prophet and she did not find a gate-keeper there, and she said, 'O Allah's Apostle! By Allah. I did not recognize you!' The Prophet said, 'No doubt, patience is at the first stroke of a calamity.'"


Bukhari :: Judgments (Ahkaam) :: [9.89.269]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 269

Narrated Anas:

Qais bin Sa'd was to the Prophet like a chief police officer to an Amir (chief).


Bukhari :: Judgments (Ahkaam) :: [9.89.270]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 270

Narrated Abu Musa:

that the Prophet sent him and sent Mu'adh after him (as rulers to Yemen).


Bukhari :: Judgments (Ahkaam) :: [9.89.271]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 271

Narrated Abu Musa:

A man embraced Islam and then reverted back to Judaism. Mu'adh bin Jabal came and saw the man with Abu Musa. Mu'adh asked, "What is wrong with this (man)?" Abu Musa replied, "He embraced Islam and then reverted back to Judaism." Mu'adh said, "I will not sit down unless you kill him (as it is) the verdict of Allah and His Apostle


Bukhari :: Judgments (Ahkaam) :: [9.89.272]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 272

Narrated 'Abdur Rahman bin Abi Bakra:

Abu Bakra wrote to his son who was in Sijistan: 'Do not judge between two persons when you are angry, for I heard the Prophet saying, "A judge should not judge between two persons while he is in an angry mood."


Bukhari :: Judgments (Ahkaam) :: [9.89.273]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 273

Narrated Abu Mas'ud Al-Ansari:

A man came to Allah's Apostle and said, "O Allah's Apostle! By Allah, I fail to attend the morning congregational prayer because so-and-so (i.e., Muadh bin Jabal) prolongs the prayer when he leads us for it." I had never seen the Prophet more furious in giving advice than he was on that day. He then said, "O people! some of you make others dislike (good deeds, i.e. prayers etc). So whoever among you leads the people in prayer, he should shorten it because among them there are the old, the weak and the busy (needy having some jobs to do). (See Hadith No. 90, Vol. 1)


Bukhari :: Judgments (Ahkaam) :: [9.89.274]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 274

Narrated 'Abdullah bin 'Umar:

That he had divorced his wife during her menses. 'Umar mentioned that to the Prophet. Allah's Apostle became angry and said, "He must take her back (his wife) and keep her with him till she becomes clean from her menses and then to wait till she gets her next period and becomes clean again from it and only then, if he wants to divorce her, he may do so."


Bukhari :: Judgments (Ahkaam) :: [9.89.275]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 275

Narrated 'Aisha:

Hind bint 'Utba bin Rabia came and said. "O Allah's Apostle! By Allah, there was no family on the surface of the earth, I like to see in degradation more than I did your family, but today there is no family on the surface of the earth whom I like to see honored more than yours." Hind added, "Abu Sufyan is a miser. Is it sinful of me to feed our children from his property?" The Prophet said, "There is no blame on you if you feed them (thereof) in a just and reasonable manner.


Bukhari :: Judgments (Ahkaam) :: [9.89.276]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 276

Narrated Anas bin Malik:

When the Prophet intended to write to the Byzantines, the people said, "They do not read a letter unless it is sealed (stamped)." Therefore the Prophet took a silver ring----as if I am looking at its glitter now----and its engraving was: 'Muhammad, Apostle of Allah'


Bukhari :: Judgments (Ahkaam) :: [9.89.277]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 277

Narrated 'Abdullah bin As-Sa'di:

That when he went to 'Umar during his Caliphate. 'Umar said to him, "Haven't I been told that you do certain jobs for the people but when you are given payment you refuse to take it?" 'Abdullah added: I said, "Yes." 'Umar said, "Why do you do so?" I said, "I have horses and slaves and I am living in prosperity and I wish that my payment should be kept as a charitable gift for the Muslims." 'Umar said, "Do not do so, for I intended to do the same as you do. Allah's Apostles used to give me gifts and I used to say to him, 'Give it to a more needy one than me.' Once he gave me some money and I said, 'Give it to a more needy person than me,' whereupon the Prophet said, 'Take it and keep it in your possession and then give it in charity. Take what ever comes to you of this money if you are not keen to have it and not asking for it; otherwise (i.e., if it does not come to you) do not seek to have it yourself.' "

Narrated 'Abdullah bin 'Umar: I have heard 'Umar saying, "The Prophet used to give me some money (grant) and I would say (to him), 'Give it to a more needy one than me.' Once he gave me some money and I said, 'Give it to a more needy one than me.' The Prophet said (to me), 'Take it and keep it in your possession and then give it in charity. Take whatever comes to you of this money while you are not keen to have it and not asking for it; take it, but you should not seek to have what you are not given. ' "


Bukhari :: Judgments (Ahkaam) :: [9.89.278]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 278

Narrated Sahl bin Sa'd:

I witnessed a husband and a wife who were involved in a case of Lian. Then (the judgment of) divorce was passed. I was fifteen years of age, at that time.


Bukhari :: Judgments (Ahkaam) :: [9.89.279]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 279

Narrated Sahl:

(the brother of Bani Sa'ida) A man from the Ansar came to the Prophet and said, "If a man finds another man sleeping with his wife, should he kill him?" That man and his wife then did Lian in the mosque while I was present.


Bukhari :: Judgments (Ahkaam) :: [9.89.280]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 280

Narrated Abu Huraira:

A man came to Allah's Apostle while he was in the mosque, and called him, saying, "O Allah's Apostle! I have committed illegal sexual intercourse." The Prophet turned his face to the other side, but when the man gave four witnesses against himself, the Prophet said to him, "Are you mad?" The man said, "No." So the Prophet said (to his companions), "Take him away and stone him to death. "


Bukhari :: Judgments (Ahkaam) :: [9.89.281]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 281

Narrated Um Salama:

Allah's Apostle said, "I am only a human being, and you people (opponents) come to me with your cases; and it may be that one of you can present his case eloquently in a more convincing way than the other, and I give my verdict according to what I hear. So if ever I judge (by error) and give the right of a brother to his other (brother) then he (the latter) should not take it, for I am giving him only a piece of Fire." (See Hadith No. 638, Vol. 3).


Bukhari :: Judgments (Ahkaam) :: [9.89.282]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 282

Narrated Abu Qatada:

Allah's Apostle said on the Day of (the battle of) Hunain, "Whoever has killed an infidel and has a proof or a witness for it, then the salb (arms and belongings of that deceased) will be for him." I stood up to seek a witness to testify that I had killed an infidel but I could not find any witness and then sat down. Then I thought that I should mention the case to Allah's Apostle I (and when I did so) a man from those who were sitting with him said, "The arms of the killed person he has mentioned, are with me, so please satisfy him on my behalf." Abu Bakr said, "No, he will not give the arms to a bird of Quraish and deprive one of Allah's lions of it who fights for the cause of Allah and His Apostle." Allah's Apostle I stood up and gave it to me, and I bought a garden with its price, and that was my first property which I owned through the war booty.

The people of Hijaz said, "A judge should not pass a judgment according to his knowledge, whether he was a witness at the time he was the judge or before that" And if a litigant gives a confession in favor of his opponent in the court, in the opinion of some scholars, the judge should not pass a judgment against him till the latter calls two witnesses to witness his confession. And some people of Iraq said, "A judge can pass a judgement according to what he hears or witnesses (the litigant's confession) in the court itself, but if the confession takes place outside the court, he should not pass the judgment unless two witnesses witness the confession." Some of them said, "A judge can pass a judgement depending on his knowledge of the case as he is trust-worthy, and that a witness is Required just to reveal the truth. The judge's knowledge is more than the witness." Some said, "A judge can judge according to his knowledge only in cases involving property, but in other cases he cannot." Al-Qasim said, "A judge ought not to pass a judgment depending on his knowledge if other people do not know what he knows, although his knowledge is more than the witness of somebody else because he might expose himself to suspicion by the Muslims and cause the Muslims to have unreasonable doubt. "


Bukhari :: Judgments (Ahkaam) :: [9.89.283]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 283

Narrated 'Ali bin Husain:

Safiya bint (daughter of) Huyai came to the Prophet (in the mosque), and when she returned (home), the Prophet accompanied her. It happened that two men from the Ansar passed by them and the Prophet called them saying, "She is Safiya!" those two men said, "Subhan Allah!" The Prophet said, "Satan circulates in the human body as blood does."


Bukhari :: Judgments (Ahkaam) :: [9.89.284]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 284

Narrated Abu Burda:

The Prophet sent my father and Mu'adh bin Jabal to Yemen and said (to them), "Make things easy for the people and do not put hurdles in their way, and give them glad tiding, and don't let them have aversion (i.e. to make people to hate good deeds) and you both should work in cooperation and mutual understanding" Abu Musa said to Allah's Apostle, "In our country a special alcoholic drink called Al-Bit', is prepared (for drinking)." The Prophet said, "Every intoxicant is prohibited. "


Bukhari :: Judgments (Ahkaam) :: [9.89.285]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 285

Narrated Abu Musa:

The Prophet said, "Set free the captives and accept invitations."


Bukhari :: Judgments (Ahkaam) :: [9.89.286]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 286

Narrated Abu Humaid Al-Sa'idi:

The Prophet appointed a man from the tribe of Bani Asad, called Ibn Al-Utabiyya to collect the Zakat. When he returned (with the money) he said (to the Prophet), "This is for you and this has been given to me as a gift." The Prophet stood up on the pulpit (Sufyan said he ascended the pulpit), and after glorifying and praising Allah, he said, "What is wrong with the employee whom we send (to collect Zakat from the public) that he returns to say, 'This is for you and that is for me?' Why didn't he stay at his father's and mother's house to see whether he will be given gifts or not? By Him in Whose Hand my life is, whoever takes anything illegally will bring it on the Day of Resurrection by carrying it over his neck: if it is a camel, it will be grunting: if it is a cow, it will be mooing: and if it is a sheep it will be bleating!" The Prophet then raised both his hands till we saw the whiteness of his armpits (and he said), "No doubt! Haven't I conveyed Allah's Message?" And he repeated it three times.


Bukhari :: Judgments (Ahkaam) :: [9.89.287]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 287

Narrated Ibn 'Umar:

Salim, the freed salve of Abu Hudhaifa used to lead in prayer the early Muhajirin (emigrants) and the companions of the Prophet in the Quba mosque. Among those (who used to pray behind him) were Abu Bakr, 'Umar, Abu Salama, and Amir bin Rabi'a.


Bukhari :: Judgments (Ahkaam) :: [9.89.288]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 288

Narrated 'Urwa bin Az-Zubair:

Marwan bin Al-Hakam and Al-Miswar bin Makhrama told him that when the Muslims were permitted to set free the captives of Hawazin, Allah's Apostle said, "I do not know who amongst you has agreed (to it) and who has not. Go back so that your 'Urafa' may submit your decision to us." So the people returned and their 'Urafa' talked to them and then came back to Allah's Apostle and told him that the people had given their consent happily and permitted (their captives to be freed).


Bukhari :: Judgments (Ahkaam) :: [9.89.289]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 289

Narrated Muhammad bin Zaid bin Abdullah bin 'Umar:

Some people said to Ibn 'Umar, "When we enter upon our ruler(s) we say in their praise what is contrary to what we say when we leave them." Ibn 'Umar said, "We used to consider this as hypocrisy."


Bukhari :: Judgments (Ahkaam) :: [9.89.290]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 290

Narrated Abu Huraira:

Allah's Apostles said, "The worst of all mankind is the double-faced one, who comes to some people with one countenance and to others, with another countenance."


Bukhari :: Judgments (Ahkaam) :: [9.89.291]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 291

Narrated 'Aisha:

Hind (bint 'Utba) said to the Prophet "Abu Sufyan is a miserly man and I need to take some money of his wealth." The Prophet said, "Take reasonably what is sufficient for you and your children "


Bukhari :: Judgments (Ahkaam) :: [9.89.292]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 292

Narrated Um Salama:

(the wife of the Prophet) Allah's Apostle heard some people quarreling at the door of his dwelling, so he went out to them and said, "I am only a human being, and litigants with cases of dispute come to me, and someone of you may happen to be more eloquent (in presenting his case) than the other, whereby I may consider that he is truthful and pass a judgment in his favor. If ever I pass a judgment in favor of somebody whereby he takes a Muslim's right unjustly, then whatever he takes is nothing but a piece of Fire, and it is up to him to take or leave."


Bukhari :: Judgments (Ahkaam) :: [9.89.293]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 293

Narrated 'Aisha:

(the wife of the Prophet) 'Utba bin Abi Waqqas said to his brother Sa'd bin Abi Waqqas, "The son of the slave girl of Zam'a is from me, so take him into your custody." So in the year of Conquest of Mecca, Sa'd took him and said. (This is) my brother's son whom my brother has asked me to take into my custody." 'Abd bin Zam'a got up before him and said, (He is) my brother and the son of the slave girl of my father, and was born on my father's bed." So they both submitted their case before Allah's Apostle. Sa'd said, "O Allah's Apostle! This boy is the son of my brother and he entrusted him to me." 'Abd bin Zam'a said, "This boy is my brother and the son of the slave girl of my father, and was born on the bed of my father." Allah's Apostle said, "The boy is for you, O 'Abd bin Zam'a!" Then Allah's Apostle further said, "The child is for the owner of the bed, and the stone is for the adulterer," He then said to Sauda bint Zam'a, "Veil (screen) yourself before him," when he saw the child's resemblance to 'Utba. The boy did not see her again till he met Allah.


Bukhari :: Judgments (Ahkaam) :: [9.89.294]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 294

Narrated 'Abdullah:

The Prophet said, "If somebody on the demand of a judge takes an oath to grab (a Muslim's) property and he is liar in it, he will meet Allah Who will be angry with him". So Allah revealed,:--

'Verily! those who purchase a small gain at the cost of Allah's Covenant and their oaths..' (3.77) 'Al-Ashath came while Abdullah was narrating (this) to the people. Al-Ashath said, "This verse was revealed regarding me and another man with whom I had a quarrel about a well. The Prophet said (to me), "Do you have any evidence?' I replied, 'No.' He said, 'Let your opponent take an oath.' I said: I am sure he would take a (false) oath." Thereupon it was revealed: 'Verily! those who purchase a small gain at the cost of Allah's Covenant....' (3.77) (See Hadith No. 72, Vol 6).


Bukhari :: Judgments (Ahkaam) :: [9.89.295]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 295

Narrated Um Salama:

The Prophet heard the voices of some people quarreling near his gate, so he went to them and said, "I am only a human being and litigants with cases of disputes come to me, and maybe one of them presents his case eloquently in a more convincing and impressive way than the other, and I give my verdict in his favor thinking he is truthful. So if I give a Muslim's right to another (by mistake), then that (property) is a piece of Fire, which is up to him to take it or leave it." (See Hadith No. 281 )


Bukhari :: Judgments (Ahkaam) :: [9.89.296]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 296

Narrated Jabir:

The Prophet came to know that one of his companions had given the promise of freeing his slave after his death, but as he had no other property than that slave, the Prophet sold that slave for 800 dirhams and sent the price to him.


Bukhari :: Judgments (Ahkaam) :: [9.89.297]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 297

Narrated Ibn 'Umar:

Allah's Apostle sent an army unit headed by Usama bin Zaid and the people criticized his leadership. The Prophet said (to the people), "If you are criticizing his leadership now, then you used to criticize his father's leadership before. By Allah, he (Usama's father) deserved the leadership and used to be one of the most beloved persons to me, and now his son (Usama) is one of the most beloved persons to me after him. " (See Hadith No. 745, Vol. 5)


Bukhari :: Judgments (Ahkaam) :: [9.89.298]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 298

Narrated 'Aisha:

Allah's Apostle said, "The most hated person in the sight of Allah, is the most quarrelsome person."


Bukhari :: Judgments (Ahkaam) :: [9.89.299]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 299

Narrated Ibn 'Umar:

The Prophet sent (an army unit under the command of) Khalid bin Al-Walid to fight against the tribe of Bani Jadhima and those people could not express themselves by saying, "Aslamna," but they said, "Saba'na! Saba'na! " Khalid kept on killing some of them and taking some others as captives, and he gave a captive to everyone of us and ordered everyone of us to kill his captive. I said, "By Allah, I shall not kill my captive and none of my companions shall kill his captive!" Then we mentioned that to the Prophet and he said, "O Allah! I am free from what Khalid bin Al-Walid has done," and repeated it twice.


Bukhari :: Judgments (Ahkaam) :: [9.89.300]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 300

Narrated Sahl bin Sa'd As-Saidi:

There was some quarrel (sighting) among Bani 'Amr, and when this news reached the Prophet, he offered the Zuhr prayer and went to establish peace among them. In the meantime the time of 'Asr prayer was due, Bilal pronounced the Adhan and then the Iqama for the prayer and requested Abu Bakr (to lead the prayer) and Abu Bakr went forward. The Prophet arrived while Abu Bakr was still praying. He entered the rows of praying people till he stood behind Abu Bakr in the (first) row. The people started clapping, and it was the habit of Abu Bakr that whenever he stood for prayer, he never glanced side-ways till he had finished it, but when Abu Bakr observed that the clapping was not coming to an end, he looked and saw the Prophet standing behind him.

The Prophet beckoned him to carry on by waving his hand. Abu Bakr stood there for a while, thanking Allah for the saying of the Prophet and then he retreated, taking his steps backwards. When the Prophet saw that, he went ahead and led the people in prayer. When he finished the prayer, he said, "O Abu Bakr! What prevented you from carrying on with the prayer after I beckoned you to do so?" Abu Bakr replied, "It does not befit the son of Abi Quhafa to lead the Prophet in prayer." Then the Prophet said to the people, "If some problem arises during prayers, then the men should say, Subhan Allah!; and the women should clap." (See Hadith No. 652, Vol. 1)


Bukhari :: Judgments (Ahkaam) :: [9.89.301]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 301

Narrated Zaid bin Thabit:

Abu Bakr sent for me owing to the large number of casualties in the battle of Al-Yamama, while 'Umar was sitting with him. Abu Bakr said (to me), 'Umar has come to my and said, 'A great number of Qaris of the Holy Quran were killed on the day of the battle of Al-Yamama, and I am afraid that the casualties among the Qaris of the Quran may increase on other battle-fields whereby a large part of the Quran may be lost. Therefore I consider it advisable that you (Abu Bakr) should have the Qur'an collected.' I said, 'How dare I do something which Allah's Apostle did not do?' 'Umar said, By Allah, it is something beneficial.' 'Umar kept on pressing me for that till Allah opened my chest for that for which He had opened the chest of 'Umar and I had in that matter, the same opinion as 'Umar had." Abu Bakr then said to me (Zaid), "You are a wise young man and we do not have any suspicion about you, and you used to write the Divine Inspiration for Allah's Apostle. So you should search for the fragmentary scripts of the Quran and collect it (in one Book)." Zaid further said: By Allah, if Abu Bakr had ordered me to shift a mountain among the mountains from one place to another it would not have been heavier for me than this ordering me to collect the Qur'an. Then I said (to 'Umar and Abu Bakr), "How can you do something which Allah's Apostle did not do?" Abu Bakr said, "By Allah, it is something beneficial." Zaid added: So he (Abu Bakr) kept on pressing me for that until Allah opened my chest for that for which He had opened the chests of Abu Bakr and 'Umar, and I had in that matter, the same opinion as theirs.

So I started compiling the Quran by collecting it from the leafless stalks of the date-palm tree and from the pieces of leather and hides and from the stones, and from the chests of men (who had memorized the Quran). I found the last verses of Sirat-at-Tauba: ("Verily there has come unto you an Apostle (Muhammad) from amongst yourselves--' (9.128-129) ) from Khuzaima or Abi Khuzaima and I added to it the rest of the Sura. The manuscripts of the Quran remained with Abu Bakr till Allah took him unto Him. Then it remained with 'Umar till Allah took him unto Him, and then with Hafsa bint 'Umar.


Bukhari :: Judgments (Ahkaam) :: [9.89.302]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 302

Narrated Abu Laila bin 'Abdullah bin Abdur-Rahman bin Sahl:

Sahl bin Abi Hathma and some great men of his tribe said, 'Abdullah bin 'Sahl and Muhaiyisa went out to Khaibar as they were struck with poverty and difficult living conditions. Then Muhaiyisa was informed that Abdullah had been killed and thrown in a pit or a spring. Muhaiyisa went to the Jews and said, "By Allah, you have killed my companion." The Jews said, "By Allah, we have not killed him." Muhaiyisa then came back to his people and told them the story. He, his elder brother Huwaiyisa and 'Abdur-Rahman bin Sahl came (to the Prophet) and he who had been at Khaibar, proceeded to speak, but the Prophet said to Muhaiyisa, "The eldest! The eldest!" meaning, "Let the eldest of you speak." So Huwaiyisa spoke first and then Muhaiyisa. Allah's Apostle said, "The Jews should either pay the blood money of your (deceased) companion or be ready for war." After that Allah's Apostle wrote a letter to the Jews in that respect, and they wrote that they had not killed him. Then Allah's Apostle said to Huwaiyisa, Muhaiyisa and 'Abdur-Rahman, "Can you take an oath by which you will be entitled to take the blood money?" They said, "No." He said (to them), "Shall we ask the Jews to take an oath before you?" They replied, "But the Jews are not Muslims." So Allah's Apostle gave them one-hundred she-camels as blood money from himself. Sahl added: When those she-camels were made to enter the house, one of them kicked me with its leg.


Bukhari :: Judgments (Ahkaam) :: [9.89.303]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 303

Narrated Abu Huraira and Zaid bin Khalid Al-Juhani:

A bedouin came and said, "O Allah's Apostle! Judge between us according to Allah's Book (Laws)." His opponent stood up and said, "He has said the truth, so judge between us according to Allah's Laws." The bedouin said, "My son was a laborer for this man and committed illegal sexual intercourse with his wife. The people said to me, 'Your son is to be stoned to death,' so I ransomed my son for one hundred sheep and a slave girl. Then I asked the religious learned men and they said to me, 'Your son has to receive one hundred lashes plus one year of exile.' " The Prophet said, "I shall judge between you according to Allah's Book (Laws)! As for the slave girl and the sheep, it shall be returned to you, and your son shall receive one-hundred lashes and be exiled for one year. O you, Unais!" The Prophet addressed some man, "Go in the morning to the wife of this man and stone her to death." So Unais went to her the next morning and stoned her to death.


Bukhari :: Judgments (Ahkaam) :: [9.89.304]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 304

Narrated 'Abdullah bin 'Abbas:

That Abu Sufyan bin Harb told him that Heraclius had called him along with the members of a Quraish caravan and then said to his interpreter, "Tell them that I want to ask this (Abu Sufyan) a question, and if he tries to tell me a lie, they should contradict him." Then Abu Sufyan mentioned the whole narration and said that Heraclius said to the inter Peter, "Say to him (Abu Sufyan), 'If what you say is true, then he (the Prophet) will take over the place underneath my two feet.' "


Bukhari :: Judgments (Ahkaam) :: [9.89.305]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 305

Narrated Abu Humaid As-Sa'idi:

The Prophet employed Ibn Al-Utbiyya to collect Zakat from Bani Sulaim, and when he returned (with the money) to Allah's Apostle the Prophet called him to account, and he said, "This (amount) is for you, and this was given to me as a present." Allah's Apostle said, "Why don't you stay at your father's house or your mother's house to see whether you will be given gifts or not, if you are telling the truth?" Then Allah's Apostle stood up and addressed the people, and after glorifying and praising Allah, he said: Amma Ba'du (then after) I employ some men from among you for some job which Allah has placed in my charge, and then one of you comes to me and says, 'This (amount) is for you and this is a gift given to me.' Why doesn't he stay at the house of his father or the house of his mother and see whether he will be given gifts or not if he was telling the truth by Allah, none of you takes anything of it (i.e., Zakat) for himself (Hisham added: unlawfully) but he will meet Allah on the Day of Resurrection carrying it on his neck! I do not want to see any of you carrying a grunting camel or a mooing cow or a bleating sheep on meeting Allah." Then the Prophet raised both his hands till I saw the whiteness of his armpits, and said, "(No doubt)! Haven't I conveyed Allah's Message!"


Bukhari :: Judgments (Ahkaam) :: [9.89.306]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 306

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "Allah never sends a prophet or gives the Caliphate to a Caliph but that he (the prophet or the Caliph) has two groups of advisors: A group advising him to do good and exhorts him to do it, and the other group advising him to do evil and exhorts him to do it. But the protected person (against such evil advisors) is the one protected by Allah.' "


Bukhari :: Judgments (Ahkaam) :: [9.89.307]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 307

Narrated 'Ubada bin As-Samit:

We gave the oath of allegiance to Allah's Apostle that we would listen to and obey him both at the time when we were active and at the time when we were tired and that we would not fight against the ruler or disobey him, and would stand firm for the truth or say the truth wherever we might be, and in the Way of Allah we would not be afraid of the blame of the blamers. (See Hadith No. 178 and 320)


Bukhari :: Judgments (Ahkaam) :: [9.89.308]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 308

Narrated Anas:

The Prophet went out on a cold morning while the Muhajirin (emigrants) and the Ansar were digging the trench. The Prophet then said, "O Allah! The real goodness is the goodness of the Here after, so please forgive the Ansar and the Muhajirin." They replied, "We are those who have given the Pledge of allegiance to Muhammad for to observe Jihad as long as we remain alive."


Bukhari :: Judgments (Ahkaam) :: [9.89.309]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 309

Narrated 'Abdullah bin 'Umar:

Whenever we gave the Pledge of allegiance to Allah's Apostle for to listen to and obey, he used to say to us, for as much as you can"


Bukhari :: Judgments (Ahkaam) :: [9.89.310]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 310

Narrated 'Abdullah bin Dinar:

I witnessed Ibn 'Umar when the people gathered around 'Abdul Malik. Ibn 'Umar wrote: I gave the Pledge of allegiance that I will listen to and obey Allah's Slave, 'Abdul Malik, Chief of the believers according to Allah's Laws and the Traditions of His Apostle as much as I can; and my sons too, give the same pledge.'


Bukhari :: Judgments (Ahkaam) :: [9.89.311]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 311

Narrated Jabir bin 'Abdullah:

I gave the Pledge of allegiance to the Prophet that I would listen and obey, and he told me to add: 'As much as I can, and will give good advice to every Muslim.'


Bukhari :: Judgments (Ahkaam) :: [9.89.312]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 312

Narrated 'Abdullah bin Dinar:

When the people took the oath of allegiance to 'Abdul Malik, 'Abdullah bin 'Umar wrote to him: "To Allah's Slave, 'Abdul Malik, Chief of the believers, I give the Pledge of allegiance that I will listen to and obey Allah's Slave, 'Abdul Malik, Chief of the believers, according to Allah's Laws and the Traditions of His Apostle in whatever is within my ability; and my sons too, give the same pledge."


Bukhari :: Judgments (Ahkaam) :: [9.89.313]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 313

Narrated Yazid:

I said to Salama, "For what did you give the Pledge of allegiance to the Prophet on the Day of Hudaibiya?" He replied, "For death."


Bukhari :: Judgments (Ahkaam) :: [9.89.314]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 314

Narrated Al-Miswar bin Makhrama:

The group of people whom 'Umar had selected as candidates for the Caliphate gathered and consulted each other. Abdur-Rahman said to them, "I am not going to compete with you in this matter, but if you wish, I would select for you a caliph from among you." So all of them agreed to let 'Abdur-Rahman decide the case. So when the candidates placed the case in the hands of 'Abdur-Rahman, the people went towards him and nobody followed the rest of the group nor obeyed any after him. So the people followed 'Abdur-Rahman and consulted him all those nights till there came the night we gave the oath of allegiance to 'Uthman. Al-Miswar (bin Makhrama) added: 'Abdur-Rahman called on me after a portion of the night had passed and knocked on my door till I got up, and he said to me, "I see you have been sleeping! By Allah, during the last three nights I have not slept enough. Go and call Az-Zubair and Sa'd.' So I called them for him and he consulted them and then called me saying, 'Call 'Ali for me." I called 'Ali and he held a private talk with him till very late at night, and then 'Al, got up to leave having had much hope (to be chosen as a Caliph) but 'Abdur-Rahman was afraid of something concerning 'Ali. 'Abdur-Rahman then said to me, "Call 'Uthman for me." I called him and he kept on speaking to him privately till the Mu'adhdhin put an end to their talk by announcing the Adhan for the Fajr prayer. When the people finished their morning prayer and that (six men) group gathered near the pulpit, 'Abdur-Rahman sent for all the Muhajirin (emigrants) and the Ansar present there and sent for the army chief who had performed the Hajj with 'Umar that year. When all of them had gathered, 'Abdur-Rahman said, "None has the right to be worshipped but Allah," and added, "Now then, O 'Ali, I have looked at the people's tendencies and noticed that they do not consider anybody equal to 'Uthman, so you should not incur blame (by disagreeing)." Then 'Abdur-Rahman said (to 'Uthman), "I gave the oath of allegiance to you on condition that you will follow Allah's Laws and the traditions of Allah's Apostle and the traditions of the two Caliphs after him." So 'Abdur-Rahman gave the oath of allegiance to him, and so did the people including the Muhajirin (emigrants) and the Ansar and the chiefs of the army staff and all the Muslims.


Bukhari :: Judgments (Ahkaam) :: [9.89.315]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 315

Narrated Salama:

We gave the oath of allegiance to the Prophet under the tree. He said to me, "O Salama! Will you not give the oath of allegiance?" I replied, "O Allah's Apostle! I have already given the oath of allegiance for the first time." He said, (Give it again) for the second time.


Bukhari :: Judgments (Ahkaam) :: [9.89.316]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 316

Narrated Jabir bin 'Abdullah:

A bedouin gave the Pledge of allegiance to Allah's Apostle for Islam and the bedouin got a fever where upon he said to the Prophet "Cancel my Pledge." But the Prophet refused. He came to him (again) saying, "Cancel my Pledge.' But the Prophet refused. Then (the bedouin) left (Medina). Allah's Apostle said: "Medina is like a pair of bellows (furnace): It expels its impurities and brightens and clears its good."


Bukhari :: Judgments (Ahkaam) :: [9.89.317]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 317

Narrated 'Abdullah bin Hisham:

who was born during the lifetime of the Prophet that his mother, Zainab bint Humaid had taken him to Allah's Apostle and said, "O Allah's Apostle! Take his Pledge of allegiance (for Islam)." The Prophet said, "He ('Abdullah bin Hisham) is a little child," and passed his hand over his head and invoked Allah for him. 'Abdullah bin Hisham used to slaughter one sheep as a sacrifice on behalf of all of his family.


Bukhari :: Judgments (Ahkaam) :: [9.89.318]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 318

Narrated Jabir bin 'Abdullah:

A bedouin gave the Pledge of allegiance to Allah's Apostle for Islam. Then the bedouin got fever at Medina, came to Allah's Apostle and said, "O Allah's Apostle! Cancel my Pledge," But Allah's Apostle refused. Then he came to him (again) and said, "O Allah's Apostle! Cancel my Pledge." But the Prophet refused Then he came to him (again) and said, "O Allah's Apostle! Cancel my Pledge." But the Prophet refused. The bedouin finally went out (of Medina) whereupon Allah's Apostle said, "Medina is like a pair of bellows (furnace): It expels its impurities and brightens and clears its good.


Bukhari :: Judgments (Ahkaam) :: [9.89.319]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 319

Narrated Abu Huraira:

Allah's Apostle said, "There will be three types of people whom Allah will neither speak to them on the Day of Resurrection nor will purify them from sins, and they will have a painful punishment: They are, (1) a man possessed superfluous water (more than he needs) on a way and he withholds it from the travelers. (2) a man who gives a pledge of allegiance to an Imam (ruler) and gives it only for worldly benefits, if the Imam gives him what he wants, he abides by his pledge, otherwise he does not fulfill his pledge; (3) and a man who sells something to another man after the 'Asr prayer and swears by Allah (a false oath) that he has been offered so much for it whereupon the buyer believes him and buys it although in fact, the seller has not been offered such a price." (See Hadith No. 838, Vol. 3)


Bukhari :: Judgments (Ahkaam) :: [9.89.320]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 320

Narrated 'Ubada bin As-Samit:

Allah's Apostle said to us while we were in a gathering, "Give me the oath (Pledge of allegiance for: (1) Not to join anything in worship along with Allah, (2) Not to steal, (3) Not to commit illegal sexual intercourse, (4) Not to kill your children, (5) Not to accuse an innocent person (to spread such an accusation among people), (6) Not to be disobedient (when ordered) to do good deeds. The Prophet added: Whoever amongst you fulfill his pledge, his reward will be with Allah, and whoever commits any of those sins and receives the legal punishment in this world for that sin, then that punishment will be an expiation for that sin, and whoever commits any of those sins and Allah does not expose him, then it is up to Allah if He wishes He will punish him or if He wishes, He will forgive him." So we gave the Pledge for that. (See Hadith No. 17, Vol. 1)


Bukhari :: Judgments (Ahkaam) :: [9.89.321]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 321

Narrated 'Aisha:

The Prophet used to take the Pledge of allegiance from the women by words only after reciting this Holy Verse:--(60.12) "..that they will not associate anything in worship with Allah." (60.12) And the hand of Allah's Apostle did not touch any woman's hand except the hand of that woman his right hand possessed. (i.e. his captives or his lady slaves).


Bukhari :: Judgments (Ahkaam) :: [9.89.322]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 322

Narrated Um Atiyya:

We gave the Pledge of allegiance to the Prophet and he recited to me the verse (60.12). That they will not associate anything in worship with Allah (60.12). And he also prevented us from wailing and lamenting over the dead. A woman from us held her hand out and said, "Such-and-such a woman cried over a dead person belonging to my family and I want to compensate her for that crying" The Prophet did not say anything in reply and she left and returned. None of those women abided by her pledge except Um Sulaim, Um Al-'Ala', and the daughter of Abi Sabra, the wife of Al-Muadh or the daughter of Abi Sabra, and the wife of Mu'adh.


Bukhari :: Judgments (Ahkaam) :: [9.89.323]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 323

Narrated Jabir:

A bedouin came to the Prophet and said, "Please take my Pledge of allegiance for Islam." So the Prophet took from him the Pledge of allegiance for Islam. He came the next day with a fever and said to the Prophet "Cancel my pledge." But the Prophet refused and when the bedouin went away, the Prophet said, "Medina is like a pair of bellows (furnace): It expels its impurities and brightens and clears its good."


Bukhari :: Judgments (Ahkaam) :: [9.89.324]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 324

Narrated Al-Qasim bin Muhammad:

'Aisha said, "O my head!" Allah's Apostle said, "If that (i.e., your death) should happen while I am still alive, I would ask Allah to forgive you and would invoke Allah for you." 'Aisha said, "O my life which is going to be lost! By Allah, I think that you wish for my death, and if that should happen then you would be busy enjoying the company of one of your wives in the last part of that day." The Prophet said, "But I should say, 'O my head!' I feel like calling Abu Bakr and his son and appoint (the former as my successors lest people should say something or wish for something. Allah will insist (on Abu Bakr becoming a Caliph) and the believers will prevent (anyone else from claiming the Caliphate)," or "..Allah will prevent (anyone else from claiming the Caliphate) and the believers will insist (on Abu Bakr becoming the Caliph)."


Bukhari :: Judgments (Ahkaam) :: [9.89.325]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 325

Narrated 'Abdullah bin 'Umar:

It was said to 'Umar, "Will you appoint your successor?" Umar said, "If I appoint a Caliph (as my successor) it is true that somebody who was better than I (i.e., Abu Bakr) did so, and if I leave the matter undecided, it is true that somebody who was better than I (i.e., Allah's Apostle) did so." On this, the people praised him. 'Umar said, "People are of two kinds: Either one who is keen to take over the Caliphate or one who is afraid of assuming such a responsibility. I wish I could be free from its responsibility in that I would receive neither reward nor retribution I won't bear the burden of the caliphate in my death as I do in my life."


Bukhari :: Judgments (Ahkaam) :: [9.89.326]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 326

Narrated Anas bin Malik:

That he heard 'Umar's second speech he delivered when he sat on the pulpit on the day following the death of the Prophet 'Umar recited the Tashahhud while Abu Bakr was silent. 'Umar said, "I wish that Allah's Apostle had outlived all of us, i.e., had been the last (to die). But if Muhammad is dead, Allah nevertheless has kept the light amongst you from which you can receive the same guidance as Allah guided Muhammad with that. And Abu Bakr is the companion of Allah's Apostle He is the second of the two in the cave. He is the most entitled person among the Muslims to manage your affairs. Therefore get up and swear allegiance to him." Some people had already taken the oath of allegiance to him in the shed of Bani Sa'ida but the oath of allegiance taken by the public was taken at the pulpit. I heard 'Umar saying to Abu Bakr on that day. "Please ascend the pulpit," and kept on urging him till he ascended the pulpit whereupon, all the people swore allegiance to him.


Bukhari :: Judgments (Ahkaam) :: [9.89.327]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 327

Narrated Jubair bin Mut'im:

A woman came to the Prophet and spoke to him about something and he told her to return to him. She said, "O Allah's Apostle! If I come and do not find you?" (As if she meant, "...if you die?") The Prophet said, "If you should not find me, then go to Abu Bakr."


Bukhari :: Judgments (Ahkaam) :: [9.89.328]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 328

Narrated Tariq bin Shihab:

Abu Bakr said to the delegate of Buzakha. "Follow the tails of the camels till Allah shows the Caliph (successor) of His Prophet and Al-Muhajirin (emigrants) something because of which you may excuse yourselves "


Bukhari :: Judgments (Ahkaam) :: [9.89.329]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 329

Narrated Jabir bin Samura:

I heard the Prophet saying, "There will be twelve Muslim rulers (who will rule all the Islamic world)." He then said a sentence which I did not hear. My father said, "All of them (those rulers) will be from Quraish."


Bukhari :: Judgments (Ahkaam) :: [9.89.330]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 330

Narrated Abu Huraira:

Allah's Apostle said, "By Him in Whose Hands my life is, I was about to order for collecting fire wood and then order someone to pronounce the Adhan for the prayer and then order someone to lead the people in prayer and then I would go from behind and burn the houses of men who did not present themselves for the (compulsory congregational) prayer. By Him in Whose Hands my life is, if anyone of you had known that he would receive a bone covered with meat or two (small) pieces of meat present in between two ribs, he would come for 'Isha' prayer." (See Hadith No. 617, Vol. 1)


Bukhari :: Judgments (Ahkaam) :: [9.89.331]

Judgments (Ahkaam)

Bukhari :: Book 9 :: Volume 89 :: Hadith 331

Narrated 'Abdullah bin Ka'b bin Malik:

Who was Ka'b's guide from among his sons when Ka'b became blind: I heard Ka'b bin Malik saying, "When some people remained behind and did not join Allah's Apostle in the battle of Tabuk.." and then he described the whole narration and said, "Allah's Apostle forbade the Muslims to speak to us, and so we (I and my companions) stayed fifty nights in that state, and then Allah's Apostle announced Allah's acceptance of our repentance."


Bukhari :: Wishes :: [9.90.332]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 332

Narrated Abu Huraira:

I heard Allah's Apostle saying, "By Him in Whose Hands my life is! Were it not for some men who dislike to be left behind and for whom I do not have means of conveyance, I would not stay away (from any Holy Battle). I would love to be martyred in Allah's Cause and come to life and then get, martyred and then come to life and then get martyred and then get resurrected and then get martyred.


Bukhari :: Wishes :: [9.90.333]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 333

Narrated Al-A'rai:

Abu Huraira said, Allah's Apostle said, "By Him in Whose Hand my life is, I would love to fight in Allah's Cause and then get martyred and then resurrected (come to life) and then get martyred and then resurrected (come to life) and then get martyred, and then resurrected (come to life) and then get martyred and then resurrected (come to life)." Abu Huraira used to repeat those words three times and I testify to it with Allah's Oath.


Bukhari :: Wishes :: [9.90.334]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 334

Narrated Abu Huraira:

The Prophet said, "If I had gold equal to the mountain of Uhud, I would love that, before three days had passed, not a single Dinar thereof remained with me if I found somebody to accept it excluding some amount that I would keep for the payment of my debts.''


Bukhari :: Wishes :: [9.90.335]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 335

Narrated 'Aisha:

Allah's Apostle said, "If I had formerly known hat I came to know lately, I would not have driven the Hadi with me and would have finished the state of Ihram along with the people when they finished it


Bukhari :: Wishes :: [9.90.336]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 336

Narrated Jabir bin Abdullah:

We were in the company of Allah's Apostle and we assumed the state of Ihram of Hajj and arrived at Mecca on the fourth of Dhul-Hijja. The Prophet ordered us to perform the Tawaf around the Ka'ba and (Sa'i) between As-Safa and Al-Marwa and use our lhram just for 'Umra, and finish the state of Ihram unless we had our Hadi with us. None of us had the Hadi with him except the Prophet and Talha. 1AIj came from Yemen and brought the Hadi with him. 'Ali said, 'I had assumed the state of Ihram with the same intention as that with which Allah's Apostle had assumed it. The people said, "How can we proceed to Mina and our male organs are dribbling?" Allah's Apostle said, "If I had formerly known what I came to know latterly, I would not have brought the Hadi, and had there been no Hadi with me, I would have finished my Ihram." Suraqa (bin Malik) met the Prophet while he was throwing pebbles at the Jamrat-al-'Aqaba, and asked, "O Allah's Apostle! Is this (permitted) for us only?" The Prophet replied. "No, it is forever" 'Aisha had arrived at Mecca while she was menstruating, therefore the Prophet ordered her to perform all the ceremonies of Hajj except the Tawaf around the Ka'ba, and not to perform her prayers unless and until she became clean . When they encamped at Al-Batha, 'Aisha said, "O Allah's Apostle! You are proceeding after performing both Hajj and 'Umra while I am proceeding with Hajj only?" So the Prophet ordered 'Abdur-Rahman bin Abu Bakr As-Siddiq to go with her to At-Tan'im, and so she performed the 'Umra in Dhul-Hijja after the days of the Hajj.


Bukhari :: Wishes :: [9.90.337]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 337

Narrated Aisha:

One night the Prophet was unable to sleep and said, "Would that a righteous man from my companions guarded me tonight." Suddenly we heard the clatter of arms, whereupon the Prophet said, "Who is it?" It was said, "I am Sa'd, O Allah's Apostle! I have come to guard you." The Prophet then slept so soundly that we heard him snoring. Abu 'Abdullah said: 'Aisha said: Bilal said, "Would that I but stayed overnight in a valley with Idhkhir and Jalil (two kinds of grass) around me (i.e., in Mecca)." Then I told that to the Prophet .


Bukhari :: Wishes :: [9.90.338]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 338

Narrated Abu Huraira:

Allah's Apostle said, "Not to wish to be the like except of two men. A man whom Allah has given the (knowledge of the) Qur'an and he recites it during the hours of night and day and the one who wishes says: If I were given the same as this (man) has been given, I would do what he does, and a man whom Allah has given wealth and he spends it in the just and right way, in which case the one who wishes says, 'If I were given the same as he has been given, I would do what he does.' " (See Hadith No. 543 and 544, Vol 6)


Bukhari :: Wishes :: [9.90.339]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 339

Narrated Anas:

If I had not heard the Prophet saying, "You should not long for death," I would have longed (for it).


Bukhari :: Wishes :: [9.90.340]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 340

Narrated Qais:

We went to pay a visit to Khabbab bin Al-Art and he had got himself branded at seven spots over his body. He said, "If Allah's Apostle had not forbidden us to invoke Allah for death, I would have invoked for it."


Bukhari :: Wishes :: [9.90.341]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 341

Narrated Sa'd bin Ubaid:

(the Maula of 'Abdur-Rahman bin Azhar) Allah's Apostle said, "None of you should long for death, for if he is a good man, he may increase his good deeds, and if he is an evil-doer, he may stop the evil deeds and repent."


Bukhari :: Wishes :: [9.90.342]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 342

Narrated Al-Bara' bin 'Azib:

The Prophet was carrying earth with us on the day of the battle of Al-Ahzab (confederates) and I saw that the dust was covering the whiteness of his abdomen, and he (the Prophet ) was saying, "(O Allah) ! Without You, we would not have been guided, nor would we have given in charity, nor would we have prayed. So (O Allah!) please send tranquility (Sakina) upon us as they, (the chiefs of the enemy tribes) have rebelled against us. And if they intend affliction (i.e. want to frighten us and fight against us) then we would not (flee but withstand them). And the Prophet used to raise his voice with it. (See Hadith No. 430 and 432, Vol. 5)


Bukhari :: Wishes :: [9.90.343]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 343

Narrated 'Abdullah bin Abi Aufa:

Allah's Apostle said, "Do not long for meeting your enemy, and ask Allah for safety (from all sorts of evil)." (See Hadith No. 266, Vol. 4)


Bukhari :: Wishes :: [9.90.344]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 344

Narrated Al-Qasim bin Muhammad:

Ibn 'Abbas mentioned the case of a couple on whom the judgment of Lian has been passed. 'Abdullah bin Shaddad said, "Was that the lady in whose case the Prophet said, "If I were to stone a lady to death without a proof (against her)?' "Ibn 'Abbas said, "No! That was concerned with a woman who though being a Muslim used to arouse suspicion by her outright misbehavior." (See Hadith No. 230, Vol.7)


Bukhari :: Wishes :: [9.90.345]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 345

Narrated 'Ata:

One night the Prophet delayed the Isha' prayer whereupon 'Umar went to him and said, "The prayer, O Allah's Apostle! The women and children had slept." The Prophet came out with water dropping from his head, and said, "Were I not afraid that it would be hard for my followers (or for the people), I would order them to pray Isha prayer at this time." (Various versions of this Hadith are given by the narrators with slight differences in expression but not in content).


Bukhari :: Wishes :: [9.90.346]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 346

Narrated Abu Huraira:

Allah's Apostle said, "Were I not afraid that it would be hard on my followers, I would order them to use the siwak (as obligatory, for cleaning the teeth)


Bukhari :: Wishes :: [9.90.347]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 347

Narrated Anas:

The Prophet fasted Al-Wisal on the last days of the month. Some people did the same, and when the news reached the Prophet he said, "If the month had been prolonged for me, then I would have fasted Wisal for such a long time that the most exaggerating ones among you would have given up their exaggeration. I am not like you; my Lord always makes me eat and drink."


Bukhari :: Wishes :: [9.90.348]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 348

Narrated Abu Huraira:

Allah's Apostle forbade Al-Wisal. The people said (to him), "But you fast Al-'Wisal," He said, "Who among you is like me? When I sleep (at night), my Lord makes me eat and drink. But when the people refused to give up Al-Wisal, he fasted Al-Wisal along with them for two days and then they saw the crescent whereupon the Prophet said, "If the crescent had not appeared I would have fasted for a longer period," as if he intended to punish them herewith.


Bukhari :: Wishes :: [9.90.349]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 349

Narrated 'Aisha:

I asked the Prophet about the wall (outside the Ka'ba). "Is it regarded as part of the Ka'ba?" He replied, "Yes." I said, "Then why didn't the people include it in the Ka'ba?" He said, "(Because) your people ran short of money." I asked, "Then why is its gate so high?" He replied, ''Your people did so in order to admit to it whom they would and forbid whom they would. Were your people not still close to the period of ignorance, and were I not afraid that their hearts might deny my action, then surely I would include the wall in the Ka'ba and make its gate touch the ground."


Bukhari :: Wishes :: [9.90.350]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 350

Narrated Abu Huraira:

Allah's Apostle said, "But for the emigration, I would have been one of the Ansar: and if the people took their way in a valley (or a mountain pass), I would take the Ansar's valley or the mountain pass."


Bukhari :: Wishes :: [9.90.351]

Wishes

Bukhari :: Book 9 :: Volume 90 :: Hadith 351

Narrated 'Abdullah bin Zaid:

The Prophet said, "But for the emigration, I would have been one of the Ansar; and if the people took their way in a valley (or a mountain pass), I would take Ansar's valley or their mountain pass."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.352]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 352

Narrated Malik:

We came to the Prophet and we were young men nearly of equal ages and we stayed with him for twenty nights. Allah's Apostle was a very kind man and when he realized our longing for our families, he asked us about those whom we had left behind. When we informed him, he said, "Go back to your families and stay with them and teach them (religion) and order them (to do good deeds). The Prophet mentioned things some of which I remembered and some I did not. Then he said, "Pray as you have seen me praying, and when it is the time of prayer, one of you should pronounce the call (Adhan) for the prayer and the eldest of you should lead the prayer. "


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.353]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 353

Narrated Ibn Mas'ud:

Allah's Apostle said, "The (call for prayer) Adhan of Bilal should not stop anyone of you from taking his Suhur for he pronounces the Adhan in order that whoever among you is praying the night prayer, may return (to eat his Suhur) and whoever among you is sleeping, may get up, for it is not yet dawn (when it is like this)." (Yahya, the sub-narrator stretched his two index fingers side ways).


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.354]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 354

Narrated 'Abdullah bin 'Umar:

The Prophet said, "Bilal pronounces the Adhan at night so that you may eat and drink till Ibn Um Maktum pronounces the Adhan (for the Fajr prayer)."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.355]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 355

Narrated 'Abdullah:

The Prophet led us in Zuhr prayer and prayer five Rakat. Somebody asked him whether the prayer had been increased." He (the Prophet ) said, "And what is that?" They (the people) replied, "You have prayed five Rakat." Then the Prophet offered two prostrations (of Sahu) after he had finished his prayer with the Taslim.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.356]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 356

Narrated Abu Huraira:

Allah's Apostle finished his prayer after offerings two Rakat only. Dhul-Yaddain asked him whether the prayer had been reduced, or you had forgotten?" The Prophet said, "Is Dhul-Yaddain speaking the truth?" The people said, "Yes." Then Allah's Apostle stood up and performed another two Rakat and then finished prayer with Taslim, and then said the Takbir and performed a prostration similar to or longer than his ordinary prostrations; then he raised his head, said Takbir and prostrated and then raised his head (Sahu prostrations).


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.357]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 357

Narrated 'Abdullah bin 'Umar:

While the people were at Quba offering the morning prayer, suddenly a person came to them saying, "Tonight Divine Inspiration has been revealed to Allah's Apostle and he has been ordered to face the Ka'ba (in prayers): therefore you people should face it." There faces were towards Sham, so they turned their faces towards the Ka'ba (at Mecca).


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.358]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 358

Narrated Al-Bara':

When Allah's Apostle arrived at Medina, he prayed facing Jerusalem for sixteen or seventeen months but he wished that he would be ordered to face the Ka'ba. So Allah revealed: --

'Verily! We have seen the turning of your face towards the heaven; surely we shall turn you to a prayer direction (Qibla) that shall please you.' (2.144) Thus he was directed towards the Ka'ba. A man prayed the 'Asr prayer with the Prophet and then went out, and passing by some people from the Ansar, he said, "I testify. that I have prayed with the Prophet and he (the Prophet) has prayed facing the Ka'ba." Thereupon they, who were bowing in the 'Asr prayer, turned towards the Ka'ba.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.359]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 359

Narrated Anas bin Malik:

I used to offer drinks prepared from infused dates to Abu Talha Al-Ansari, Abu 'Ubada bin Al Jarrah and Ubai bin Ka'b. Then a person came to them and said, "All alcoholic drinks have been prohibited." Abii Talha then said, "O Anas! Get up and break all these jars." So I got up and took a mortar belonging to us, and hit the jars with its lower part till they broke.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.360]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 360

Narrated Hudhaifa:

The Prophet said to the people of Najran, "I will send to you an honest person who is really trustworthy." The Companion, of the Prophet each desired to be that person, but the Prophet sent Abu 'Ubaida.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.361]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 361

Narrated Anas:

The Prophet said, "For every nation there is an Amin (honest, trustworthy person) and the Amin of this nation is Abu 'Ubaida."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.362]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 362

Narrated 'Umar:

There was a man from the Ansar (who was a friend of mine). If he was not present in the company of Allah's Apostle I used to be present with Allah's Apostle, I would tell him what I used to hear from Allah's Apostle, and when I was absent from Allah's Apostle he used to be present with him, and he would tell me what he used to hear from Allah's Apostle .


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.363]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 363

Narrated Ali:

The Prophet , sent an army and appointed some man their commander The man made a fire and then said (to the soldiers), "Enter it." Some of them intended to enter it while some others said, 'We have run away from it (i.e., embraced Islam to save ourselves from the 'fire')." They mentioned that to the Prophet, and he said about people who had intended to enter the fire. ''If they had entered it, they would have remained In it till the Day of Resurrection.'' Then he said to others, "No obedience for evil deeds, obedience is required only in what is good ."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.364]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 364

Narrated Abu Huraira and Zaid bin Khalid:

Two men sued each other before the Prophet.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.365]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 365

Narrated Abu Huraira:

While we were with Allah's Apostle a bedouin got up and said, "O Allah's Apostle! Settle my case according to Allah's Book (Laws)." Then his opponent got up and said, "O Allah's Apostle! He has said the truth! Settle his case according to Allah's Book (Laws.) and allow me to speak," He said, "My son was a laborer for this man and he committed illegal sexual intercourse with his wife. The people told me that my son should be stoned to death but I ransomed him with one-hundred sheep and a slave girl. Then I asked the religious learned people and they told me that his wife should be stoned to death and my son should receive one-hundred lashes and be sentenced to one year of exile.' The Prophet said, "By Him in Whose Hands my life is, I will judge between you according to Allah's Book (Laws): As for the slave girl and the sheep, they are to be returned; and as for your son, he shall receive one-hundred lashes and will be exiled for one year. You, O Unais!" addressing a man from Bani Aslam, "Go tomorrow morning to the wife of this (man) and if she confesses, then stone her to death." The next morning Unais went to the wife and she confessed, and he stoned her to death.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.366]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 366

Narrated Jabir bin Abdullah:

On the day of (the battle of) the Trench, the Prophet called the people (to bring news about the enemy). Az-Zubair responded to his call. He called them again and Az-Zubair responded to his call again; then he called them for the third time and again Az-Zubair responded to his call whereupon the Prophet said, "Every prophet has his Hawairi (helper), and Az-Zubair is my Hawari."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.367]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 367

Narrated Abu Musa:

The Prophet entered a garden and told me to guard its gate. Then a man came and asked permission to enter. The Prophet, said, "Permit him and give him the good news that he will enter Paradise." Behold! It was Abu Bakr. Then 'Umar came, and the Prophet said, "Admit him and give him the good news that he will enter Paradise." Then 'Uthman came and the Prophet said, "Admit him and give him the good news that he will enter Paradise. "


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.368]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 368

Narrated 'Umar:

I came and behold, Allah's Apostle was staying on a Mashroba (attic room) and a black slave of Allah's Apostle was at the top if its stairs. I said to him, "(Tell the Prophet) that here is 'Umar bin Al-Khattab (asking for permission to enter)." Then he admitted me.


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.369]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 369

Narrated 'Abdullah bin 'Abbas:

Allah's Apostle sent a letter to Khosrau and told his messenger to give it first to the ruler of Bahrain, and tell him to deliver it to Khosrau. When Khosrau had read it, he tore it into pieces. (Az-Zuhri said: I think Ibn Al-Musaiyab said, "Allah's Apostle invoked Allah to tear them (Khosrau and his followers) into pieces."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.370]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 370

Narrated Salama bin Al-Akwa':

Allah's Apostle said to a man from the tribe of Al-Aslam, "Proclaim among your people (or the people) on the day of 'Ashura' (tenth of Muharram), 'Whosoever has eaten anything should fast for the rest of the day; and whoever has not eaten anything, should complete his fast.' "


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.371]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 371

Narrated Ibn Abbas:

When the delegate of 'Abd Al-Qais came to Allah's Apostle, he said, "Who are the delegate?" They said, "The delegate are from the tribe of Rabi'a." The Prophet said, "Welcome, O the delegate, and welcome! O people! Neither you will have any disgrace nor will you regret." They said, "O Allah's Apostle! Between you and us there are the infidels of the tribe of Mudar, so please order us to do something good (religious deeds) that by acting on them we may enter Paradise, and that we may inform (our people) whom we have left behind, about it." They also asked (the Prophet) about drinks. He forbade them from four things and ordered them to do four things. He ordered them to believe in Allah, and asked them, "Do you know what is meant by belief in Allah?" They said, "Allah and His Apostle know best." He said, ''To testify that none has the right to be worshipped except Allah, the One, Who has no partners with Him, and that Muhammad is Allah's Apostle; and to offer prayers perfectly and to pay Zakat." (the narrator thinks that fasting in Ramadan is included), "and to give one-fifth of the war booty (to the state)." Then he forbade four (drinking utensils): Ad-Duba', Al-Hantam, Al-Mazaffat and An-Naqir, or probably, Al-Muqaiyar. And then the Prophet said, "Remember all these things by heart and preach it to those whom you have left behind."


Bukhari :: Accepting Information Given by a Truthful Person :: [9.91.372]

Accepting Information Given by a Truthful Person

Bukhari :: Book 9 :: Volume 91 :: Hadith 372

Narrated Tauba Al-'Anbari:

Ash-'Sha'bi asked me, "Did you notice how Al-Hasan used to narrate Hadiths from the Prophets? I stayed with Ibn 'Umar for about two or one-and-half years and I did not hear him narrating any thing from the Prophet except his (Hadith): He (Ibn 'Umar) said, "Some of the companions of the Prophet including Sa'd, were going to eat meat, but one of the wives of the Prophet called them, saying, 'It is the neat of a Mastigure.' The people then stopped eating it. On that Allah's Apostle said, 'Carry on eating, for it is lawful.' Or said, 'There is no harm in eating it, but it is not from my meals."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.373]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 373

Narrated Tariq bin Shihab:

A Jew said to 'Umar, "O Chief of the Believers, if this verse: 'This day I have perfected your religion for you, completed My favors upon you, and have chosen for you, Islam as your religion.' (5.3) had been revealed upon us, we would have taken that day as an 'Id (festival) day." 'Umar said, "I know definitely on what day this Verse was revealed; it was revealed on the day of 'Arafat, on a Friday."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.374]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 374

Narrated Anas bin Malik:

That he heard 'Umar speaking while standing on the pulpit of the Prophet in the morning (following the death of the Prophet), when the people had sworn allegiance to Abu Bakr. He said the Tashah-hud before Abu Bakr, and said, "Amma Ba'du (then after) Allah has chosen for his Apostle what is with Him (Paradise) rather than what is with you (the world). This is that Book (Quran) with which Allah guided your Apostle, so stick to it, for then you will be guided on the right path as Allah guided His Apostle with it."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.375]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 375

Narrated Ibn 'Abbas:

The Prophet embraced me and said, "O Allah! Teach him (the knowledge of) the Book (Quran)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.376]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 376

Narrated Abal Minhal:

Abu Barza said, "(O people!) Allah makes you self-sufficient or has raised you high with Islam and with Muhammad


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.377]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 377

Narrated Abdullah bin Dinar:

'Abdullah Bin 'Umar wrote to 'Abdul Malik bin Marwan, swearing allegiance to him: 'I swear allegiance to you in that I will listen and obey what is in accordance with the Laws of Allah and the Tradition of His Apostle as much as I can.'


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.378]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 378

Narrated Said bin Al-Musaiyab:

Abu Huraira said that Allah's Apostle said, "I have been sent with 'Jawami-al-Kalim ' (the shortest expression with the widest meaning) and have been made victorious with awe (cast in my enemy's hearts), and while I was sleeping, I saw that the keys of the treasures of the world were placed in my hand." Abu Huraira added: Allah's Apostle has gone, and you people are utilizing those treasures, or digging those treasures out." or said a similar sentence.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.379]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 379

Narrated Abu Huraira:

The Prophet said, "There was no prophet among the prophets but was given miracles because of which people had security or had belief, but what I was given was the Divine Inspiration which Allah revealed to me. So I hope that my followers will be more than those of any other prophet on the Day of Resurrection."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.380]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 380

Narrated Abu Wail:

I sat with Shaiba in this Mosque (Al-Masjid-Al-Haram), and he said, "'Umar once sat beside me here as you are now sitting, and said, 'I feel like distributing all the gold and silver that are in it (i.e., the Ka'ba) among the Muslims'. I said, 'You cannot do that.' 'Umar said, 'Why?' I said, 'Your two (previous) companions (the Prophet and Abu Bakr) did not do it. 'Umar said, 'They are the two persons whom one must follow.'" (See Hadith No. 664, Vol. 2)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.381]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 381

Narrated Hudhaifa:

Allah's Apostle said to us, "Honesty descended from the Heavens and settled in the roots of the hearts of men (faithful believers), and then the Quran was revealed and the people read the Quran, (and learnt it from it) and also learnt it from the Sunna." Both Quran and Sunna strengthened their (the faithful believers') honesty. (See Hadith No. 208)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.382]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 382

Narrated 'Abdullah:

The best talk (speech) is Allah's Book 'Quran), and the best way is the way of Muhammad, and the worst matters are the heresies (those new things which are introduced into the religion); and whatever you have been promised will surely come to pass, and you cannot escape (it).


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.383]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 383

Narrated Abu Huraira and Zaid bin Khalid:

We were with the Prophet when he said (to two men), "I shall judge between you according to Allah's Book (Laws)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.384]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 384

Narrated Abu Huraira:

Allah's Apostle said, "All my followers will enter Paradise except those who refuse." They said, "O Allah's Apostle! Who will refuse?" He said, "Whoever obeys me will enter Paradise, and whoever disobeys me is the one who refuses (to enter it)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.385]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 385

Narrated Jabir bin 'Abdullah:

Some angels came to the Prophet while he was sleeping. Some of them said, "He is sleeping." Others said, "His eyes are sleeping but his heart is awake." Then they said, "There is an example for this companion of yours." One of them said, "Then set forth an example for him." Some of them said, "He is sleeping." The others said, "His eyes are sleeping but his heart is awake." Then they said, "His example is that of a man who has built a house and then offered therein a banquet and sent an inviter (messenger) to invite the people. So whoever accepted the invitation of the inviter, entered the house and ate of the banquet, and whoever did not accept the invitation of the inviter, did not enter the house, nor did he eat of the banquet." Then the angels said, "Interpret this example to him so that he may understand it." Some of them said, "He is sleeping.'' The others said, "His eyes are sleeping but his heart is awake." And then they said, "The houses stands for Paradise and the call maker is Muhammad; and whoever obeys Muhammad, obeys Allah; and whoever disobeys Muhammad, disobeys Allah. Muhammad separated the people (i.e., through his message, the good is distinguished from the bad, and the believers from the disbelievers)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.386]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 386

Narrated Hammam:

Hudhaifa said, "O the Group of Al-Qurra! Follow the straight path, for then you have taken a great lead (and will be the leaders), but if you divert right or left, then you will go astray far away."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.387]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 387

Narrated Abu Musa:

The Prophet said, "My example and the example of what I have been sent with is that of a man who came to some people and said, 'O people! I have seen the enemy's army with my own eyes, and I am the naked warner; so protect yourselves!' Then a group of his people obeyed him and fled at night proceeding stealthily till they were safe, while another group of them disbelieved him and stayed at their places till morning when the army came upon them, and killed and ruined them completely So this is the example of that person who obeys me and follows what I have brought (the Quran and the Sunna), and the example of the one who disobeys me and disbelieves the truth I have brought."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.388]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 388

Narrated Abu Huraira:

When Allah's Apostle died and Abu Bakr was elected as a Caliph after him, some of the Arabs reverted to disbelief, 'Umar said to Abu Bakr, "How dare you fight the people while Allah's Apostle said, I have been ordered to fight the people till they say 'None has the right to be worshipped but Allah' And whoever says: None has the right to be worshipped but Allah.' waves his wealth and his life from me unless he deserves a legal punishment lusty, and his account will be with Allah! Abu Bakr said, "By Allah, I will fight him who discriminates between Zakat and prayers, for Zakat is the Compulsory right to be taken from the wealth By Allah, if they refuse to give me even a tying rope which they use to give to Allah's Apostle, I would fight them for withholding it." 'Umar said, 'By Allah, It was nothing, except I saw that Allah had opened the chest of Abu Bakr to the fight, and I came to know for certain that was the truth."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.389]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 389

Narrated 'Abdullah bin 'Abbas:

Uyaina bin Hisn bin Hudhaifa bin Badr came and stayed (at Medina) with his nephew Al-Hurr bin Qais bin Hisn who has one of those whom 'Umar used to keep near him, as the Qurra' (learned men knowing Quran by heart) were the people of Umar's meetings and his advisors whether they were old or young. 'Uyaina said to his nephew, "O my nephew! Have you an approach to this chief so as to get for me the permission to see him?" His nephew said, "I will get the permission for you to see him." (Ibn 'Abbas added: ) So he took the permission for 'Uyaina, and when the latter entered, he said, "O the son of Al-Khattab! By Allah, you neither give us sufficient provision nor judge among us with justice." On that 'Umar became so furious that he intended to harm him. Al-Hurr, said, "O Chief of the Believers!" Allah said to His Apostle 'Hold to forgiveness, command what is good (right), and leave the foolish (i.e. do not punish them).' (7.199) and this person is among the foolish." By Allah, 'Umar did not overlook that Verse when Al-Hurr recited it before him, and 'Umar said to observe (the orders of) Allah's Book strictly." (See Hadith No. 166, Vol. 6)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.390]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 390

Narrated Asma' bint Abu Bakr:

I came to 'Aisha during the solar eclipse. The people were standing (offering prayer) and she too, was standing and offering prayer. I asked, "What is wrong with the people?" She pointed towards the sky with her hand and said, Subhan Allah!'' I asked her, "Is there a sign?" She nodded with her head meaning, yes. When Allah's Apostle finished (the prayer), he glorified and praised Allah and said, "There is not anything that I have not seen before but I have seen now at this place of mine, even Paradise and Hell. It has been revealed to me that you people will be put to trial nearly like the trial of Ad-Dajjal, in your graves. As for the true believer or a Muslim (the sub-narrator is not sure as to which of the two (words Asma' had said) he will say, 'Muhammad came with clear signs from Allah, and we responded to him (accepted his teachings) and believed (what he said)' It will be said (to him) 'Sleep in peace; we have known that you were a true believer who believed with certainty.' As for a hypocrite or a doubtful person, (the sub-narrator is not sure as to which word Asma' said) he will say, 'I do not know, but I heard the people saying something and so I said the same.' "


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.391]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 391

Narrated Abu Huraira:

The Prophet said, "Leave me as I leave you) for the people who were before you were ruined because of their questions and their differences over their prophets. So, if I forbid you to do something, then keep away from it. And if I order you to do something, then do of it as much as you can."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.392]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 392

Narrated Sa'd bin Abi Waqqas:

The Prophet said, "The most sinful person among the Muslims is the one who asked about something which had not been prohibited, but was prohibited because of his asking."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.393]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 393

Narrated Zaid bin Thabit:

The Prophet took a room made of date palm leaves mats in the mosque. Allah's Apostle prayed in it for a few nights till the people gathered (to pray the night prayer (Tarawih) (behind him.) Then on the 4th night the people did not hear his voice and they thought he had slept, so some of them started humming in order that he might come out. The Prophet then said, "You continued doing what I saw you doing till I was afraid that this (Tarawih prayer) might be enjoined on you, and if it were enjoined on you, you would not continue performing it. Therefore, O people! Perform your prayers at your homes, for the best prayer of a person is what is performed at his home except the compulsory congregational) prayer." (See Hadith No. 229,Vol. 3) (See Hadith No. 134, Vol. 8)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.394]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 394

Narrated Abu Musa Al-Ash'ari:

Allah's Apostle was asked about things which he disliked, and when the people asked too many questions, he became angry and said, "Ask me (any question)." A man got up and said, "O Allah's Apostle! Who is my father?" The Prophet replied, "Your father is Hudhaifa." Then another man got up and said, "O Allah's Apostle! Who is my father?" The Prophet said, "Your father is Salim, Maula Shaiba." When 'Umar saw the signs of anger on the face of Allah's Apostle, he said, "We repent to Allah."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.395]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 395

Narrated Warrad:

(The clerk of Al-Mughira) Muawiya wrote to Al-Mughira 'Write to me what you have heard from Allah's Apostle.' So he (Al-Mughira) wrote to him: Allah's Prophet used to say at the end of each prayer: "La ilaha illalla-h wahdahu la sharika lahu, lahul Mulku, wa lahul Hamdu wa hula ala kulli shai'in qadir. 'Allahumma la mani' a lima a'taita, wala mu'tiya lima mana'ta, wala yanfa'u dhuljadd minkal-jadd." He also wrote to him that the Prophet used to forbid (1) Qil and Qal (idle useless talk or that you talk too much about others), (2) Asking too many questions (in disputed Religious matters); (3) And wasting one's wealth by extravagance; (4) and to be undutiful to one's mother (5) and to bury the daughters alive (6) and to prevent your favors (benevolence to others (i.e. not to pay the rights of others (7) And asking others for something (except when it is unavoidable).


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.396]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 396

Narrated Anas:

We were with 'Umar and he said, "We have been forbidden to undertake a difficult task beyond our capability (i.e. to exceed the religious limits e.g., to clean the inside of the eyes while doing ablution)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.397]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 397

Narrated Anas bin Malik:

The Prophet came out after the sun had declined and offered the Zuhr prayer (in congregation). After finishing it with Taslim, he stood on the pulpit and mentioned the Hour and mentioned there would happen great events before it. Then he said, "Whoever wants to ask me any question, may do so, for by Allah, you will not ask me about anything but I will inform you of its answer as long as I am at this place of mine." On this, the Ansar wept violently, and Allah's Apostle kept on saying, "Ask Me! " Then a man got up and asked, ''Where will my entrance be, O Allah's Apostle?" The Prophet said, "(You will go to) the Fire." Then 'Abdullah bin Hudhaifa got up and asked, "Who is my father, O Allah's Apostle?" The Prophet replied, "Your father is Hudhaifa." The Prophet then kept on saying (angrily), "Ask me! Ask me!" 'Umar then knelt on his knees and said, "We have accepted Allah as our Lord and Islam as our religion and Muhammad as an Apostle." Allah's Apostle became quiet when 'Umar said that. Then Allah's Apostle said, "By Him in Whose Hand my life is, Paradise and Hell were displayed before me across this wall while I was praying, and I never saw such good and evil as I have seen today."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.398]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 398

Narrated Anas bin Malik:

A man said, "O Allah's Prophet! Who is my father?" The Prophet said, "Your father is so-and-so." And then the Divine Verse:-- 'O you who believe! Ask not questions about things..(5.101)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.399]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 399

Narrated Anas bin Malik:

Allah's Apostle said, "People will not stop asking questions till they say, 'This is Allah, the Creator of everything, then who created Allah?' "


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.400]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 400

Narrated Ibn Masud:

I was with the Prophet at one of the farms of Medina while he was leaning on a date palm leaf-stalk. He passed by a group of Jews and some of them said to the other, Ask him (the Prophet) about the spirit. Some others said, "Do not ask him, lest he should tell you what you dislike" But they went up to him and said, "O Abal Qasim! Inform us bout the spirit." The Prophet stood up for a while, waiting. I realized that he was being Divinely Inspired, so I kept away from him till the inspiration was over. Then the Prophet said, "(O Muhammad) they ask you regarding the spirit, Say: The spirit its knowledge is with my Lord (i.e., nobody has its knowledge except Allah)" (17.85) (This is a miracle of the Qur'an that all the scientists up till now do not know about the spirit, i.e, how life comes to a body and how it goes away at its death) (See Hadith No. 245, Vol. 6)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.401]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 401

Narrated Ibn 'Umar:

The Prophet wore a gold ring and then the people followed him and wore gold rings too. Then the Prophet said, "I had this golden ring made for myself. He then threw it away and said, "I shall never put it on." Thereupon the people also threw their rings away.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.402]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 402

Narrated Abu Huraira:

The Prophet said (to his companions), "Do not fast Al-Wisal." They said, "But you fast Al-Wisail." He said, "I am not like you, for at night my Lord feeds me and makes me drink." But the people did not give up Al-Wisal, so the Prophet fasted Al-Wisal with them for two days or two nights, and then they saw the crescent whereupon the Prophet said, "If the crescent had delayed, I would have continued fasting (because of you)," as if he wanted to vanquish them completely (because they had refused to give up Al Wisal).


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.403]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 403

Narrated Ibrahim At Tamii's father:

Ali addressed us while he was standing on a brick pulpit and carrying a sword from which was hanging a scroll He said "By Allah, we have no book to read except Allah's Book and whatever is on this scroll," And then he unrolled it, and behold, in it was written what sort of camels were to be given as blood money, and there was also written in it: 'Medina is a sanctuary form 'Air (mountain) to such and such place so whoever innovates in it an heresy or commits a sin therein, he will incur the curse of Allah, the angles, and all the people and Allah will not accept his compulsory or optional good deeds.' There was also written in it: 'The asylum (pledge of protection) granted by any Muslims is one and the same, (even a Muslim of the lowest status is to be secured and respected by all the other Muslims, and whoever betrays a Muslim in this respect (by violating the pledge) will incur the curse of Allah, the angels, and all the people, and Allah will not accept his compulsory or optional good deeds.' There was also written in it: 'Whoever (freed slave) befriends (takes as masters) other than his real masters (manumitters) without their permission will incur the curse of Allah, the angels, and all the people, and Allah will not accept his compulsory or optional good deeds. ' (See Hadith No. 94, Vol. 3)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.404]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 404

Narrated 'Aisha:

The Prophet did something as it was allowed from the religious point of view but some people refrained from it. When the Prophet heard of that, he, after glorifying and praising Allah, said, "Why do some people refrain from doing something which I do? By Allah, I know Allah more than they."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.405]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 405

Narrated Ibn Abi Mulaika:

Once the two righteous men, i.e., Abu Bakr and 'Umar were on the verge of destruction (and that was because): When the delegate of Bani Tamim came to the Prophet, one of them (either Abu Bakr or 'Umar) recommended Al-Aqra' bin Habis At-Tamimi Al-Hanzali, the brother of Bani Majashi (to be appointed as their chief), while the other recommended somebody else. Abu Bakr said to 'Umar, "You intended only to oppose me." 'Umar said, "I did not intend to oppose you!" Then their voices grew louder in front of the Prophet whereupon there was revealed: 'O you who believe! Do not raise your voices above the voice of the Prophet..a great reward.' (49.2-3) Ibn Az-Zubair said, 'Thence forward when 'Umar talked to the Prophet, he would talk like one who whispered a secret and would even fail to make the Prophet hear him, in which case the Prophet would ask him (to repeat his words)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.406]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 406

Narrated 'Aisha:

(the mother of believers) Allah's Apostle during his fatal ailment said, "Order Abu Bakr to lead the people in prayer." I said, "If Abu Bakr stood at your place (in prayers, the people will not be able to hear him because of his weeping, so order 'Umar to lead the people in prayer." He again said, "Order Abu Bakr to lead the people in prayer " Then I said to Hafsa, "Will you say (to the Prophet), 'If Abu Bakr stood at your place, the people will not be able to hear him be cause of his weeping, so order 'Umar to lead the people in prayer?" Hafsa did so, whereupon Allah's Apostle said, "You are like the companions of Joseph (See Qur'an, 12:30-32). Order Abu Bakr to lead the people in prayer." Hafsa then said to me, "I have never received any good from you!"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.407]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 407

Narrated Sahl bin Sa'd As-Sa'idi:

'Uwaimir Al-'Ajlani came to 'Asim bin 'Adi and said, "If a man found another man with his wife and killed him, would you sentence the husband to death (in Qisas,) i.e., equality in punishment)? O 'Asim! Please ask Allah's Apostle about this matter on my behalf." 'Asim asked the Prophet but the Prophet disliked the question and disapproved of it. 'Asim returned and informed 'Uwaimir that the Prophet disliked that type of question. 'Uwaimir said, "By Allah, I will go (personally) to the Prophet." 'Uwaimir came to the Prophet when Allah had already revealed Qur'anic Verses (in that respect), after 'Asim had left (the Prophet ). So the Prophet said to 'Uwaimir, "Allah has revealed Qur'anic Verses regarding you and your wife." The Prophet then called for them, and they came and carried out the order of Lian.

Then 'Uwaimir said, "O Allah's Apostle! Now if I kept her with me, I would be accused of telling a lie." So 'Uwaimir divorced her although the Prophet did not order him to do so. Later on this practice of divorcing became the tradition of couples involved in a case of Li'an. The Prophet said (to the people). "Wait for her! If she delivers a red short (small) child like a Wahra (a short red animal). then I will be of the opinion that he ('Uwaimir) has told a lie but if she delivered a black big-eyed one with big buttocks, then I will be of the opinion that he has told the truth about her." 'Ultimately she gave birth to a child that proved the accusation. (See Hadith No. 269, Vol. 6)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.408]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 408

Narrated Malik bin Aus An-Nasri:

I proceeded till I entered upon 'Umar (and while I was sitting there), his gate-keeper Yarfa came to him and said, " 'Uthman, 'Abdur-Rahman, Az-Zubair and Sa'd ask your permission to come in." 'Umar allowed them. So they entered, greeted, and sat down. (After a while the gatekeeper came) and said, "Shall I admit 'Ali and 'Abbas?'' 'Umar allowed them to enter. Al-'Abbas said "O Chief of the believers! Judge between me and the oppressor ('Ali)." Then there was a dispute (regarding the property of Bani Nadir) between them ('Abbas and 'Ali). 'Uthman and his companions said, "O Chief of the Believers! Judge between them and relieve one from the other." Umar said, "Be patient! beseech you by Allah, with Whose permission the Heaven and the Earth Exist! Do you know that Allah's Apostle said, 'Our property is not to be inherited, and whatever we leave is to be given in charity,' and by this Allah's Apostle meant himself?" On that the group said, "He verily said so." 'Umar then faced 'Ali and 'Abbas and said, "I beseech you both by Allah, do you both know that Allah's Apostle said so?" They both replied, "Yes". 'Umar then said, "Now I am talking to you about this matter (in detail) . Allah favored Allah's Apostle with some of this wealth which He did not give to anybody else, as Allah said: 'What Allah bestowed as Fai (Booty on His Apostle for which you made no expedition... ' (59.6)

So that property was totally meant for Allah's Apostle, yet he did not collect it and ignore you, nor did he withhold it with your exclusion, but he gave it to you and distributed it among you till this much of it was left behind, and the Prophet, used to spend of this as the yearly expenditures of his family and then take what remained of it and spent it as he did with (other) Allah's wealth. The Prophet did so during all his lifetime, and I beseech you by Allah, do you know that?" They replied, "Yes." 'Umar then addressed 'Ali and 'Abbas, saying, "I beseech you both by Allah, do you know that?" Both of them replied, "Yes." 'Umar added, "Then Allah took His Apostle unto Him. Abu Bakr then said 'I am the successor of Allah's Apostle' and took over all the Prophet's property and disposed of it in the same way as Allah's Apostle used to do, and you were present then." Then he turned to 'Ali and 'Abbas and said, "You both claim that Abu Bakr did so-and-so in managing the property, but Allah knows that Abu Bakr was honest, righteous, intelligent, and a follower of what is right in managing it.

Then Allah took Abu Bakr unto Him, 'I said: I am the successor of Allah's Apostle and Abu Bakr.' So I took over the property for two years and managed it in the same way as Allah's Apostle, and Abu Bakr used to do. Then you both ('Ali and 'Abbas) came to me and asked for the same thing! (O 'Abbas! You came to me to ask me for your share from nephew's property; and this ('Ali) came to me asking for his wives share from her father's property, and I said to you both, 'If you wish, I will place it in your custody on condition that you both will manage it in the same way as Allah's Apostle and Abu Bakr did and as I have been doing since I took charge of managing it; otherwise, do not speak to me anymore about it.'

Then you both said, 'Give it to us on that (condition).' So I gave it to you on that condition. Now I beseech you by Allah, did I not give it to them on that condition?" The group (whom he had been addressing) replied, "Yes." 'Umar then addressed 'Abbas and 'Ali saying, "I beseech you both by Allah, didn't I give you all that property on that condition?" They said, "Yes." 'Umar then said, "Are you now seeking a verdict from me other than that? By Him with Whose Permission the Heaven and the Earth exists I will not give any verdict other than that till the Hour is established; and if you both are unable to manage this property, then you can hand it back to me, and I will be sufficient for it on your behalf." (See, Hadith No. 326, Vol. 4)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.409]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 409

Narrated 'Asim:

I said to Anas, "Did Allah's Apostle make Medina a sanctuary?" He replied, "Yes, (Medina is a sanctuary from such-and-such place to such-and-such place. It is forbidden to cut its trees, and whoever innovates an heresy in it or commits a sin therein, will incur the curse of Allah, the angels, and all the people." Then Musa bin Anas told me that Anas added, "..... or gives refuge to such an heretic or a sinner..."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.410]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 410

Narrated 'Abdullah bin 'Amr:

I heard the Prophet saying, "Allah will not deprive you of knowledge after he has given it to you, but it will be taken away through the death of the religious learned men with their knowledge. Then there will remain ignorant people who, when consulted, will give verdicts according to their opinions whereby they will mislead others and go astray."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.411]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 411

Narrated Al-A'mash:

I asked Abu Wail, "Did you witness the battle of Siffin between 'Ali and Muawiya?" He said, "Yes," and added, "Then I heard Sahl bin Hunaif saying, 'O people! Blame your personal opinions in your religion. No doubt, I remember myself on the day of Abi Jandal; if I had the power to refuse the order of Allah's Apostle, I would have refused it.

We have never put our swords on our shoulders to get involved in a situation that might have been horrible for us, but those swords brought us to victory and peace, except this present situation.' " Abu Wail said, "I witnessed the battle of Siffin, and how nasty Siffin was!"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.412]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 412

Narrated Jabir bin 'Abdullah:

I fell ill, Allah's Apostle and Abu Bakr came to visit me on foot. The Prophet came to me while I was unconscious. Allah's Apostle performed ablution and poured the Remaining water of his ablution over me whereupon I became conscious and said, 'O Allah's Apostle! How should I spend my wealth? Or how should I deal with my wealth?" But the Prophet did not give me any reply till the Verse of the laws of inheritance was revealed.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.413]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 413

Narrated Abu Said:

A woman came to Allah's Apostle and said, "O Allah's Apostle! Men (only) benefit by your teachings, so please devote to us from (some of) your time, a day on which we may come to you so that you may teach us of what Allah has taught you." Allah's Apostle said, "Gather on such-and-such a day at such-and-such a place." They gathered and Allah's Apostle came to them and taught them of what Allah had taught him. He then said, "No woman among you who has lost her three children (died) but that they will screen her from the Fire." A woman among them said, "O Allah's Apostle! If she lost two children?" She repeated her question twice, whereupon the Prophet said, "Even two, even two, even two!" (See Hadith No. 341, Vol. 2)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.414]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 414

Narrated Al-Mughira bin Shu'ba:

The Prophet said, "A group of my follower swill remain predominant (victorious) till Allah's Order (the Hour) comes upon them while they are still predominant (victorious)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.415]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 415

Narrated Humaid:

I heard Muawiya bin Abi Sufyan delivering a sermon. He said, "I heard the Prophet saying, "If Allah wants to do a favor to somebody, He bestows on him, the gift of understanding the Quran and Sunna. I am but a distributor, and Allah is the Giver. The state of this nation will remain good till the Hour is established, or till Allah's Order comes."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.416]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 416

Narrated Jabir bin 'Abdullah:

When the (following) Verse was revealed to Allah's Apostle: 'Say: He has power to send torment on you from above,'..(6.65) he said, "O Allah! I seek refuge with Your Face (from that punishment)." And when this was revealed: '..or from beneath your feet.' (6.65) he said, "O Allah! I seek refuge with Your Face (from that)." And when this Verse was revealed: '..or to cover you with confusion in party-strife, and make you to taste the violence of one another,'...(6.65) he said: "These two warnings are easier (than the previous ones)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.417]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 417

Narrated Abu Huraira:

A bedouin came to Allah's Apostle and said, "My wife has delivered a black boy, and I suspect that he is not my child." Allah's Apostle said to him, "Have you got camels?" The bedouin said, "Yes." The Prophet said, "What color are they?" The bedouin said, "They are red." The Prophet said, "Are any of them Grey?" He said, "There are Grey ones among them." The Prophet said, "Whence do you think this color came to them?" The bedouin said, "O Allah's Apostle! It resulted from hereditary disposition." The Prophet said, "And this (i.e., your child) has inherited his color from his ancestors." The Prophet did not allow him to deny his paternity of the child.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.418]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 418

Narrated Ibn 'Abbas:

A woman came to the Prophet and said, "My mother vowed to perform the Hajj but she died before performing it. Should I perform the Hajj on her behalf?" He said, "Yes! Perform the Hajj on her behalf. See, if your mother had been in debt, would you have paid her debt?" She said, "Yes." He said, "So you should pay what is for Him as Allah has more right that one should fulfill one's obligations to Him. "


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.419]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 419

Narrated 'Abdullah:

Allah's Apostle said, "Do not wish to be like anybody except in two cases: The case of a man whom Allah has given wealth and he spends it in the right way, and that of a man whom Allah has given religious wisdom (i.e., Qur'an and Sunna) and he gives his verdicts according to it and teaches it." (to others i.e., religious knowledge of Qur'an and Sunna (Prophet's Traditions)). "


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.420]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 420

Narrated Al-Mughira bin Shu'ba:

'Umar bin Al-Khattab asked (the people) about the Imlas of a woman, i.e., a woman who has an abortion because of having been beaten on her abdomen, saying, "Who among you has heard anything about it from the Prophet?" I said, "I did.'' He said, "What is that?" I said, "I heard the Prophet saying, "Its Diya (blood money) is either a male or a female slave.' " 'Umar said, "Do not leave till you present witness in support of your statement." So I went out, and found Muhammad bin Maslama. I brought him, and he bore witness with me that he had heard the Prophet saying, "Its Diya (blood money) is either a male slave or a female slave."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.421]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 421

Narrated Abu Huraira:

The Prophet said, "The Hour will not be established till my followers copy the deeds of the previous nations and follow them very closely, span by span, and cubit by cubit (i.e., inch by inch)." It was said, "O Allah's Apostle! Do you mean by those (nations) the Persians and the Byzantines?" The Prophet said, "Who can it be other than they?"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.422]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 422

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "You will follow the ways of those nations who were before you, span by span and cubit by cubit (i.e., inch by inch) so much so that even if they entered a hole of a mastigure, you would follow them." We said, "O Allah's Apostle! (Do you mean) the Jews and the Christians?" He said, "Whom else?"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.423]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 423

Narrated 'Abdullah:

The Prophet said, "None is killed unjustly, but the first son of Adam will have a part of its burden." Sufyan said, "..a part of its blood because he was the first to establish the tradition of murdering"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.424]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 424

Narrated Jabir bin 'Abdullah As-Salami:

A bedouin gave the Pledge of allegiance for embracing Islam to Allah's Apostle, and then he got an attack of fever in Medina and came to Allah's Apostle: and said, "O Allah's Apostle! Cancel my pledge." Allah's Apostle refused to do so. The bedouin came to him again and said, "Cancel my pledge," but he refused again, and then again, the bedouin came to him and said, "Cancel my pledge," and Allah's Apostle refused. The bedouin finally went away, and Allah's Apostle said, "Medina is like a pair of bellows (furnace), it expels its impurities while it brightens and clears its good.'

9.424.:

Narrated Ibn 'Abbas:

I used to teach Qur'an to 'Abdur-Rahman bin Auf. When Umar performed his last Hajj, 'Abdur-Rahman said (to me) at Mina, "Would that you had seen Chief of the believers today! A man came to him and said, "So-and-so has said, "If Chief of the Believers died, we will give the oath of allegiance to such-and-such person,' 'Umar said, 'I will get up tonight and warn those who want to usurp the people's rights.' I said, 'Do not do so, for the season (of Hajj) gathers the riffraff mob who will form the majority of your audience, and I am afraid that they will not understand (the meaning of) your saying properly and may spread (an incorrect statement) everywhere. You should wait till we reach Medina, the place of migration and the place of the Sunna (the Prophet's Traditions). There you will meet the companions of Allah's Apostle from the Muhajirin and the Ansar who will understand your statement and place it in its proper position' 'Umar said, 'By Allah, I shall do so the first time I stand (to address the people) in Medina.' When we reached Medina, 'Umar (in a Friday Khutba-sermon) said, "No doubt, Allah sent Muhammad with the Truth and revealed to him the Book (Quran), and among what was revealed, was the Verse of Ar-Rajm (stoning adulterers to death).'" (See Hadith No. 817,Vol. 8)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.425]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 425

Narrated Muhammad:

We were with Abu Huraira while he was wearing two linen garments dyed with red clay. He cleaned his nose with his garment, saying, "Bravo! Bravo! Abu Huraira is cleaning his nose with linen! There came a time when I would fall senseless between the pulpit of Allah's Apostle and 'Aisha's dwelling whereupon a passerby would come and put his foot on my neck, considering me a mad man, but in fact, I had no madness, I suffered nothing but hunger."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.426]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 426

Narrated 'Abdur-Rahman bin 'Abis:

Ibn 'Abbas was asked, "Did you offer the Id prayer with the Prophet?" He said, "Yes, had it not been for my close relation to the Prophet, I would not have performed it (with him) because of my being too young The Prophet came to the mark which is near the home of Kathir bin As-Salt and offered the Id prayer and then delivered the sermon. I do not remember if any Adhan or Iqama were pronounced for the prayer. Then the Prophet ordered (the women) to give alms, and they started stretching out their hands towards their ears and throats (giving their ornaments in charity), and the Prophet ordered Bilal to go to them (to collect the alms), and then Bilal returned to the Prophet


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.427]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 427

Narrated Ibn 'Umar:

The Prophet used to go to the Quba' mosque, sometimes walking, sometimes riding.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.428]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 428

Narrated Hisham's father:

'Aisha said to 'Abdullah bin Az-Zubair, "Bury me with my female companions (i.e. the wives of the Prophet) and do not bury me with the Prophet in the house, for I do not like to be regarded as sanctified (just for being buried there).''

Narrated Hisham's father: 'Umar sent a message to 'Aisha, saying, "Will you allow me to be buried with my two companions (the Prophet and Abu Bakr) ?" She said, "Yes, by Allah." though it was her habit that if a man from among the companions (of the Prophet ) sent her a message asking her to allow him to be buried there, she would say, "No, by Allah, I will never give permission to anyone to be buried with them."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.429]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 429

Narrated Anas bin Malik:

Allah's Apostle used to perform the 'Asr prayer and then one could reach the 'Awali (a place in the outskirts of Medina) while the sun was still quite high.

Narrated Yunus: The distance of the 'Awali (from Medina) was four or three miles.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.430]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 430

Narrated As-Sa'ib bin Yazid:

The Sa' (a kind of measure) during the lifetime of the Prophet used to be equal to the one Mudd (another kind of measure) and one third of a Mudd which we use today, but the Sa' of today has become large.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.431]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 431

Narrated Anas bin Malik:

Allah's Apostle said, "O Allah! Bestow Your Blessings on their measures, and bestow Your Blessings on their Sa' and Mudd." He meant those of the people of Medina.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.432]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 432

Narrated Ibn 'Umar:

The Jews brought a man and a woman who had committed illegal sexual intercourse, to the Prophet and the Prophet ordered them to be stoned to death, and they were stoned to death near the mosque where the biers used to be placed.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.433]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 433

Narrated Anas bin Malik:

The Mountain of Uhud came in sight of Allah's Apostle who then said, "This is a mountain that loves us and is loved by us. O Allah! Abraham made Mecca a sanctuary and I make the area between its (Medina's) two mountains a sanctuary."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.434]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 434

Narrated Sahl:

The distance between the pulpit and the wall of the mosque on the side of the Qibla was just sufficient for a sheep to pass through.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.435]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 435

Narrated Abu Huraira:

Allah's Apostle said, "Between my house and my pulpit there is a garden from one of the gardens of Paradise, and my pulpit is over my Lake-Tank. (Kauthar);


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.436]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 436

Narrated Nafi:

'Abdullah said, "The Prophet arranged for a horse race, and the prepared horses were given less food for a few days before the race to win the race, and were allowed to run from Al-Hafya to Thaniyat-al-Wada', and the unprepared horses were allowed to run between Thaniyat-al-Wada' and the mosque of Bani Zuraiq," 'Abdullah was one of those who participated in the race.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.437]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 437

Narrated Ibn 'Umar:

I heard 'Umar (delivering a sermon) on the pulpit of the Prophet.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.438]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 438

Narrated As-Sa'ib bin Yazid:

That he heard 'Uthman bin 'Affan delivering a sermon on the pulpit of the Prophet


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.439]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 439

Narrated 'Aisha:

This big copper vessel used to be put for me and Allah's Apostle and we would take water from it together (on taking a bath) .


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.440]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 440

Narrated Anas:

The Prophet brought the Ansar and the Quarish people into alliance in my house at Medina, and he invoked Allah for one month against the tribe of Bani Sulaim in (the last Rak'a of each compulsory) prayer.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.441]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 441

Narrated Abu Burda:

When I arrived at Medina, 'Abdullah bin Salam met me and said to me, "Accompany me to my house so that I may make you drink from a bowl from which Allah's Apostle used to drink, and that you may offer prayer in the mosque in which the Prophet used to pray." I accompanied him, and he made me drink Sawiq and gave me dates to eat, and then I prayed in his mosque.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.442]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 442

Narrated 'Umar:

The Prophet said to me, "Someone came to me tonight from my Lord while I was in the 'Aqiq (valley), and said to me, "Offer prayer in this blessed valley and say: 'Labbaik' for the (performance of) 'Umra and Hajj."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.443]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 443

Narrated 'Abdullah bin Dinar:

Ibn 'Umar said, "The Prophet fixed Qarn as the Miqat (for assuming the Ihram) for the people of Najd, and Al-Juhfa for the people of Sham, and Dhul-Hulaifa for the people of Medina." Ibn 'Umar added, "I heard this from the Prophet, and I have been informed that the Prophet said, 'The Miqat for the Yemenites is Yalamlam.' "When Iraq was mentioned, he said, "At that time it was not a Muslim country."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.444]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 444

Narrated 'Abdullah bin 'Umar:

The Prophet had a dream in the last portion of the night when he was sleeping at Dhul-Hulaifa. (I n the dream) it was said to him, "You are in a blessed Batha' (i.e., valley)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.445]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 445

Narrated Ibn 'Umar:

That he heard the Prophet, after raising his head from the bowing in morning prayer, saying, "O Allah, our Lord! All the praises are for you." And in the last (Rak'a) he said, "O Allah! Curse so-and-so and so--and-so." And then Allah revealed:-- 'Not for you (O Muhammad) is the decision, (but for Allah), whether He turns in mercy to them or punish them, for they are indeed wrongdoers.' (3.128)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.446]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 446

Narrated 'Ali bin Abi Talib:

That Allah's Apostle came to him and Fatima the daughter of Allah's Apostle at their house at night and said, "Won't you pray?" 'Ali replied, "O Allah's Apostle! Our souls are in the Hands of Allah and when he wants us to get up, He makes us get up." When 'Ali said that to him, Allah's Apostle left without saying anything to him. While the Prophet was leaving, 'Ali heard him striking his thigh (with his hand) and saying, "But man is quarrelsome more than anything else." (18.54)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.447]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 447

Narrated Abu Huraira:

While we were in the mosque, Allah's Apostle came out and said, "Let us proceed to the Jews." So we went out with him till we came to Bait-al-Midras. The Prophet stood up there and called them, saying, "O assembly of Jews! Surrender to Allah (embrace Islam) and you will be safe!" They said, "You have conveyed Allah's message, O Aba-al-Qasim" Allah's Apostle then said to them, "That is what I want; embrace Islam and you will be safe." They said, "You have conveyed the message, O Aba-al-Qasim." Allah's Apostle then said to them, "That is what I want," and repeated his words for the third time and added, "Know that the earth is for Allah and I want to exile you from this land, so whoever among you has property he should sell it, otherwise, know that the land is for Allah and His Apostle."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.448]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 448

Narrated Abu Said Al-Khudri:

Allah's Apostle said, "Noah will be brought (before Allah) on the Day of Resurrection, and will be asked, 'Did you convey the message of Allah?" He will reply, 'Yes, O Lord.' And then Noah's nation will be asked, 'Did he (Noah) convey Allah's message to you?' They will reply, 'No warner came to us.' Then Noah will be asked, 'Who are your witnesses?' He will reply. '(My witnesses are) Muhammad and his followers.' Thereupon you (Muslims) will be brought and you will bear witness." Then the Prophet recited: 'And thus We have made of you (Muslims) a just and the best nation, that you might be witness over the nations, and the Apostle a witness over you.' (2.143)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.449]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 449

Narrated Abu Said Al-Khudri and Abu Huraira:

Allah's Apostle sent the brother of the tribe of Bani Adi Al-Ansari as governor of Khaibar. Then the man returned, bringing Janib (a good kind of date). Allah's Apostle asked him, "Are all the dates of Khaibar like that?" He replied, "No, by Allah, O Allah's Apostle! We take one Sa' of these (good) dates for two Sas of mixed dates." Allah's Apostle then said, "Do not do so. You should either take one Sa of this (kind) for one Sa' of the other; or sell one kind and then buy with its price the other kind (of dates), and you should do the same in weighing."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.450]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 450

Narrated 'Amr bin Al-'As:

That he heard Allah's Apostle saying, "If a judge gives a verdict according to the best of his knowledge and his verdict is correct (i.e. agrees with Allah and His Apostle's verdict) he will receive a double reward, and if he gives a verdict according to the best of his knowledge and his verdict is wrong, (i.e. against that of Allah and His Apostle) even then he will get a reward ."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.451]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 451

Narrated 'Ubai bin 'Umar:

Abu Musa asked permission to enter upon 'Umar, but seeing that he was busy, he went away. 'Umar then said, "Didn't I hear the voice of 'Abdullah bin Qais? Allow him to come in." He was called in and 'Umar said to him, "What made you do what you did." He replied, "We have been instructed thus by the Prophet" 'Umar said, "Bring proof (witness) for this, other wise I will do so-and-so to you." Then 'Abdullah bin Qais went to a gathering of the Ansar who then said, "None but the youngest of us will give the witness for it." So Abu Said Al-Khudri got up and said, "We used to be instructed thus (by the Prophet)." 'Umar said, "This tradition of the Prophet remained hidden from me. Business in the market kept me busy."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.452]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 452

Narrated Al-A'raj:

Abu Huraira said, "You people claim that Abu Huraira narrates many narrations of Allah's Apostle. (Anyhow) with Allah will be our appointment. I was a poor man, and used to stick to Allah's Apostle contented with what will fill my stomach, and the Muhajirin (emigrants) used to be busy trading in the markets, and the Ansar used to be busy looking after their properties. One-day I heard Allah's Apostle saying, 'Who will spread his Rida' (a garment covering the upper part of the body) till I finished my speech and then fold it, (i.e. wrap it over your body), in which case he will never forget anything he had heard from me." So I spread my garment which I was wearing; and by Him Who sent Muhammad with the Truth, ever since, I have never forgotten whatever I heard from him (the Prophet)" (See, Hadith No. 119, Vol. 1)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.453]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 453

Narrated Muhammad bin Al-Munkadir:

I saw Jabir bin 'Abdullah swearing by Allah that Ibn Sayyad was the Dajjal. I said to Jabir, "How can you swear by Allah?" Jabir said, "I have heard 'Umar swearing by Allah regarding this matter in the presence of the Prophet and the Prophet did not disapprove of it."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.454]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 454

Narrated Abu Huraira:

Allah's Apostle said, "Horses may be used for three purposes: For a man they may be a source of reward (in the Hereafter); for another, a means of protection; and for another, a source of sin. The man for whom they are a source of reward, is the one who keeps them for Allah's Cause and ties them with long ropes and lets them graze in a pasture or garden. Whatever those long ropes allow them to eat of that pasture or garden, will be written as good deeds for him and if they break their ropes and run one or two rounds, then all their footsteps and dung will be written as good deeds for him, and if they pass a river and drink from it though he has had no intention of watering them, even then, that will be written as good deeds for him. So such horses are a source of reward for that man. For the man who keeps horses for his livelihood in order not to ask others for help or beg his bread, and at the same time he does not forget Allah's right of what he earns through them and of their backs (that he presents it to be used in Allah's Cause), such horses are a shelter for him (from poverty). For the man who keeps them just out of pride and for showing off, they are a source of sin." Then Allah's Apostle was asked about donkeys. He said, "Allah has not revealed anything to me regarding them except this comprehensive Verse:

"Then anyone who has done good, equal to the weight of an atom (or a small ant) shall see it, and any one who has done evil, equal to the weight of an atom (or a small ant) shall see it." (99.7-8)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.455]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 455

Narrated 'Aisha:

A woman asked the Prophet (Hadith 456).


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.456]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 456

Narrated 'Aisha:

A woman asked the Prophet about the periods: How to take a bath after the periods. He said, "Take a perfumed piece of cloth and clean yourself with it." She said,' "How shall I clean myself with it, O Allah's Apostle?" The Prophet said, "Clean yourself" She said again, "How shall I clean myself, O Allah's Apostle?" The Prophet said, "Clean yourself with it." Then I knew what Allah's Apostle meant. So I pulled her aside and explained it to her.


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.457]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 457

Narrated Ibn 'Abbas:

Um Hufaid bint Al-Harith bin Hazn presented the Prophet with some butter, dried yoghurt (curd milk) and mastigures as a gift. The Prophet then asked for a meal (mastigures etc. to be put) and it was eaten over his table cloth, but the Prophet did not eat of it, as he had aversion to it. But if it had been illegal to eat, it would not have been eaten over his table cloth nor would he have ordered that (mastigures meat) to be eaten


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.458]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 458

Narrated Jabir bin Abdullah:

The Prophet said, "Whoever has eaten garlic or onion, should keep away from us, or should keep away from our mosque and should stay at home." Ibn Wahb said, "Once a plate full of cooked vegetables was brought to the Prophet at Badr. Detecting a bad smell from it, he asked about the dish and was informed of the kinds of vegetables in contained. He then said, "Bring it near," and so it was brought near to one of his companions who was with him. When the Prophet saw it, he disliked eating it and said (to his companion), "Eat, for I talk in secret to ones whom you do not talk to."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.459]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 459

Narrated Jubair bin Mutim:

A lady came to Allah's Apostle and she talked to him about something, and he gave her some order. She said, "O Allah's Apostle! If I should not find you?" He said, "If you should not find me, then go to Abu Bakr." Ibrahim bin Sa'd said, "As if she meant the death (of the Prophet)."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.460]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 460

Narrated Abu Huraira:

The people of the Book used to read the Torah in Hebrew and then explain it in Arabic to the Muslims. Allah's Apostle said (to the Muslims). "Do not believe the people of the Book, nor disbelieve them, but say, 'We believe in Allah and whatever is revealed to us, and whatever is revealed to you.' "


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.461]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 461

Narrated Ubaidullah:

Ibn 'Abbas said, "Why do you ask the people of the scripture about anything while your Book (Quran) which has been revealed to Allah's Apostle is newer and the latest? You read it pure, undistorted and unchanged, and Allah has told you that the people of the scripture (Jews and Christians) changed their scripture and distorted it, and wrote the scripture with their own hands and said, 'It is from Allah,' to sell it for a little gain. Does not the knowledge which has come to you prevent you from asking them about anything? No, by Allah, we have never seen any man from them asking you regarding what has been revealed to you!"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.462]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 462

Narrated 'Aisha:

After the slanderers had given a forged statement against her, Allah's Apostle called 'Ali bin Abi Talib and Usama bin Zaid when the Divine Inspiration was delayed. He wanted to ask them and consult them about the question of divorcing me. Usama gave his evidence that was based on what he knew about my innocence, but 'Ali said, "Allah has not put restrictions on you and there are many women other than her. Furthermore you may ask the slave girl who will tell you the truth." So the Prophet asked Barira (my salve girl), "Have you seen anything that may arouse your suspicion?" She replied, "I have not seen anything more than that she is a little girl who sleeps, leaving the dough of her family (unguarded) that the domestic goats come and eat it." Then the Prophet stood on the pulpit and said, "O Muslims! Who will help me against the man who has harmed me by slandering my wife? By Allah, I know nothing about my family except good." The narrator added: Then the Prophet mentioned the innocence of 'Aisha. (See Hadith No. 274, Vol. 6)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.463]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 463

Narrated Aisha:

Allah's Apostle addressed the people, and after praising and glorifying Allah, he said, "What do you suggest me regarding those people who are abusing my wife? I have never known anything bad about her." The sub-narrator, 'Urwa, said: When 'Aisha was told of the slander, she said, "O Allah's Apostle! Will you allow me to go to my parents' home?" He allowed her and sent a slave along with her. An Ansari man said, "Subhanaka! It is not right for us to speak about this. Subhanaka! This is a great lie!"


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.464]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 464

Narrated Ata:

I heard Jabir bin 'Abdullah in a gathering saying, "We, the companions of Allah's Apostle assumed the state of Ihram to perform only Hajj without 'Umra." Jabir added, "The Prophet arrived (at Mecca) on the fourth of Dhul-Hijja. And when we arrived (in Mecca) the Prophet ordered us to finish the state of Ihram, saying, "Finish your lhram and go to your wives (for sexual relation)." Jabir added, "The Prophet did not oblige us (to go to our wives) but he only made that legal for us. Then he heard that we were saying, "When there remains only five days between us and the Day of Arafat he orders us to finish our Ihram by sleeping with our wives in which case we will proceed to 'Arafat with our male organs dribbling with semen?' (Jabir pointed out with his hand illustrating what he was saying). Allah's Apostle stood up and said, 'You (People) know that I am the most Allah-fearing, the most truthful and the best doer of good deeds (pious) from among you. If I had not brought the Hadi with me, I would have finished my Ihram as you will do, so finish your Ihram. If I had formerly known what I came to know lately, I would not have brought the Hadi with me.' So we finished our Ihram and listened to the Prophet and obeyed him." (See Hadith No. 713, Vol. 2)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.465]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 465

Narrated 'Abdullah Al Muzam:

The Prophet said, "Perform (an optional) prayer before Maghrib prayer." (He repeated it thrice) and the third time he said, "Whoever wants to offer it can do so," lest the people should take it as a Sunna (tradition). (See Hadith No. 277, Vol. 2)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.466]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 466

Narrated Jundab bin 'Abdullah:

Allah's Apostle said, "Recite (and study) the Quran as long as you are in agreement as to its interpretation and meanings, but when you have differences regarding its interpretation and meanings, then you should stop reciting it (for the time being.) (See Hadith No 581, Vol. 6)


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.467]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 467

Narrated Jundab bin 'Abdullah:

Allah's Apostle said, "Recite (and study) the Qur'an as long as your hearts are in agreement as to its meanings, but if you have differences as regards its meaning, stop reading it then."


Bukhari :: Holding Fast to the Qur'an and Sunnah :: [9.92.468]

Holding Fast to the Qur'an and Sunnah

Bukhari :: Book 9 :: Volume 92 :: Hadith 468

Narrated Ibn 'Abbas:

When the time of the death of the Prophet approached while there were some men in the house, and among them was 'Umar bin Al-Khatttab, the Prophet said, "Come near let me write for you a writing after which you will never go astray." 'Umar said, "The Prophet is seriously ill, and you have the Quran, so Allah's Book is sufficient for us." The people in the house differed and disputed. Some of them said, "Come near so that Allah's Apostle may write for you a writing after which you will not go astray," while some of them said what 'Umar said. When they made much noise and differed greatly before the Prophet, he said to them, "Go away and leave me." Ibn 'Abbas used to say, "It was a great disaster that their difference and noise prevented Allah's Apostle from writing that writing for them.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.469]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 469

Narrated Ibn Abbas:

When the Prophet sent Muadh to Yemen, he said to him, "You are going to a nation from the people of the Scripture, so let the first thing to which you will invite them, be the Tauhid of Allah. If they learn that, tell them that Allah has enjoined on them, five prayers to be offered in one day and one night. And if they pray, tell them that Allah has enjoined on them Zakat of their properties and it is to be taken from the rich among them and given to the poor. And if they agree to that, then take from them Zakat but avoid the best property of the people."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.470]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 470

Narrated Mu'adh bin Jabal:

The Prophet said, "O Mu'adh! Do you know what Allah's Right upon His slaves is?" I said, "Allah and His Apostle know best." The Prophet said, "To worship Him (Allah) Alone and to join none in worship with Him (Allah). Do you know what their right upon Him is?" I replied, "Allah and His Apostle know best." The Prophet said, "Not to punish them (if they do so)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.471]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 471

Narrated Abu Said Al-Khudri:

A man heard another man reciting (in the prayers): 'Say (O Muhammad): "He is Allah, the One." (112.1) And he recited it repeatedly. When it was morning, he went to the Prophet and informed him about that as if he considered that the recitation of that Sura by itself was not enough. Allah's Apostle said, "By Him in Whose Hand my life is, it is equal to one-third of the Quran."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.472]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 472

Narrated 'Aisha:

The Prophet sent (an army unit) under the command of a man who used to lead his companions in the prayers and would finish his recitation with (the Sura 112): 'Say (O Muhammad): "He is Allah, the One." ' (112.1) When they returned (from the battle), they mentioned that to the Prophet. He said (to them), "Ask him why he does so." They asked him and he said, "I do so because it mentions the qualities of the Beneficent and I love to recite it (in my prayer)." The Prophet; said (to them), "Tell him that Allah loves him"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.473]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 473

Narrated Jarir bin 'Abdullah:

Allah's Apostle said, "Allah will not be merciful to those who are not merciful to mankind."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.474]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 474

Narrated Usama bin Zaid:

We were with the Prophet when suddenly there came to him a messenger from one of his daughters who was asking him to come and see her son who was dying. The Prophet said (to the messenger), "Go back and tell her that whatever Allah takes is His, and whatever He gives is His, and everything with Him has a limited fixed term (in this world). So order her to be patient and hope for Allah's reward." But she sent the messenger to the Prophet again, swearing that he should come to her. So the Prophets got up, and so did Sa'd bin 'Ubada and Mu'adh bin Jabal (and went to her). When the child was brought to the Prophet his breath was disturbed in his chest as if it were in a water skin. On that the eyes of the Prophet . became flooded with tears, whereupon Sa'd said to him, "O Allah's Apostle! What is this?" The Prophet said, "This is mercy which Allah has put in the heart of His slaves, and Allah bestows His mercy only on those of His slaves who are merciful (to others)." (See Hadith No. 373, Vol. 2)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.475]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 475

Narrated Abu Musa Al-Ashari:

The Prophet said, "None is more patient than Allah against the harmful and annoying words He hears (from the people): They ascribe children to Him, yet He bestows upon them health and provision .


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.476]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 476

Narrated Ibn Umar:

The Prophet said, "The keys of the unseen are five and none knows them but Allah: (1) None knows what is in the womb, but Allah: (2) None knows what will happen tomorrow, but Allah; (3) None knows when it will rain, but Allah; (4) None knows where he will die, but Allah (knows that); (5) and none knows when the Hour will be established, but Allah."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.477]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 477

Narrated Masruq:

'Aisha said, "If anyone tells you that Muhammad has seen his Lord, he is a liar, for Allah says: 'No vision can grasp Him.' (6.103) And if anyone tells you that Muhammad has seen the Unseen, he is a liar, for Allah says: "None has the knowledge of the Unseen but Allah."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.478]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 478

Narrated 'Abdullah:

We used to pray behind the Prophet and used to say: "As-Salamu 'Al-Allah. The Prophet said, "Allah himself is As-Salam (Name of Allah), so you should say: 'At-Tahiyatu lil-laihi was- sala-watu wat-taiyibatu, as-sallamu 'Alayka aiyuha-n-nabiyyu wa rahrmatu-l-lahi wa barak-atuhu, As-salamu 'alaina wa 'ala 'ibaldi-l-lahi as-salihin. Ashhadu an la ilaha il-lallah, wa ash-hadu anna Muhammadan 'abduhu wa rasuluhu."'


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.479]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 479

Narrated Abu Huraira:

The Prophet said, "On the Day of Resurrection Allah will hold the whole earth and fold the heaven with His right hand and say, 'I am the King: where are the kings of the earth?" '


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.480]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 480

Narrated Ibn 'Abbas:

The Prophet used to say, "I seek refuge (with YOU) by Your 'Izzat, None has the right to be worshipped but You Who does not die while the Jinns and the human beings die."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.481]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 481

Narrated Anas:

The Prophet said, "(The people will be thrown into Hell ( Fire) and it will keep on saying, 'Is there any more?' till the Lord of the worlds puts His Foot over it, whereupon its different sides will come close to each other, and it will say, 'Qad! Qad! (enough! enough!) By Your 'Izzat (Honor and Power) and YOUR KARAM (Generosity)!' Paradise will remain spacious enough to accommodate more people until Allah will create some more people and let them dwell in the superfluous space of Paradise. "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.482]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 482

Narrated Ibn 'Abbas:

The Prophet used to invoke Allah at night, saying, "O Allah: All the Praises are for You: You are the Lord of the Heavens and the Earth. All the Praises are for You; You are the Maintainer of the Heaven and the Earth and whatever is in them. All the Praises are for You; You are the Light of the Heavens and the Earth. Your Word is the Truth, and Your Promise is the Truth, and the Meeting with You is the Truth, and Paradise is the Truth, and the (Hell) Fire is the Truth, and the Hour is the Truth. O Allah! I surrender myself to You, and I believe in You and I depend upon You, and I repent to You and with You (Your evidences) I stand against my opponents, and to you I leave the judgment (for those who refuse my message). O Allah! Forgive me my sins that I did in the past or will do in the future, and also the sins I did in secret or in public. You are my only God (Whom I worship) and there is no other God for me (i.e. I worship none but You)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.483]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 483

Narrated Sufyan:

(regarding the above narration) that the Prophet added, "You are the Truth, and Your Word is the Truth."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.484]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 484

Narrated Abu Musa:

We were with the Prophet on a journey, and whenever we ascended a high place, we used to say, "Allahu Akbar." The Prophet said, "Don't trouble yourselves too much! You are not calling a deaf or an absent person, but you are calling One Who Hears, Sees, and is very near." Then he came to me while I was saying in my heart, "La hawla wala quwwatta illa billah (There is neither might nor power but with Allah)." He said, to me, "O 'Abdullah bin Qais! Say, 'La hawla wala quwwata illa billah (There is neither might nor power but with Allah), for it is one of the treasures of Paradise." Or said, "Shall I tell you of it?"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.485]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 485

Narrated 'Abdullah bin 'Amr:

Abu Bakr As-Siddiq said to the Prophet "O Allah's Apostle! Teach me an invocation with which I may invoke Allah in my prayers." The Prophet said, "Say: O Allah! I have wronged my soul very much (oppressed myself), and none forgives the sins but You; so please bestow Your Forgiveness upon me. No doubt, You are the Oft-Forgiving, Most Merciful."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.486]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 486

Narrated 'Aisha:

The Prophet said, "Gabriel called me and said, 'Allah has heard the statement of your people and what they replied to you.'"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.487]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 487

Narrated Jabir bin Abdullah:

As-Salami: Allah's Apostle used to teach his companions to perform the prayer of Istikhara for each and every matter just as he used to teach them the Suras from the Quran He used to say, "If anyone of you intends to do some thing, he should offer a two rakat prayer other than the compulsory prayers, and after finishing it, he should say: O Allah! I consult You, for You have all knowledge, and appeal to You to support me with Your Power and ask for Your Bounty, for You are able to do things while I am not, and You know while I do not; and You are the Knower of the Unseen. O Allah If You know It this matter (name your matter) is good for me both at present and in the future, (or in my religion), in my this life and in the Hereafter, then fulfill it for me and make it easy for me, and then bestow Your Blessings on me in that matter. O Allah! If You know that this matter is not good for me in my religion, in my this life and in my coming Hereafter (or at present or in the future), then divert me from it and choose for me what is good wherever it may be, and make me be pleased with it." (See Hadith No. 391, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.488]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 488

Narrated 'Abdullah:

The Prophet frequently used to swear, "No, by the One Who turns the hearts."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.489]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 489

Narrated Abu Huraira:

Allah's Apostle said, "Allah has ninety-nine Names, one-hundred less one; and he who memorized them all by heart will enter Paradise." To count something means to know it by heart.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.490]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 490

Narrated Abu Huraira:

The Prophet said, "When anyone of you goes to bed, he should dust it off thrice with the edge of his garment, and say: Bismika Rabbi wada'tu janbi, wa bika arfa'hu. In amsakta nafsi faghfir laha, wa in arsaltaha fahfazha bima tahfaz bihi 'ibadaka-s-salihin."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.491]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 491

Narrated Juhaifa:

When the Prophet went to bed, he used to say, "Allhumma bismika ahya wa amut." And when he got Up in the mornings he used to say, "Alhamdu lillahi al-ladhi ahyana ba'da ma amatana wa ilaihi-n-nushur."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.492]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 492

Narrated Abu Dharr:

When the Prophet went to bed at night, he used to say: "Bismika namutu wa nahya." And when he got up in the morning, he used to say, "Alhamdu lillahi al-ladhi ahyana ba'da ma amatana, wa ilaihi-n-nushur."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.493]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 493

Narrated Ibn 'Abbas:

Allah's Apostle said, "If anyone of you, when intending to have a sexual relation (sleep) with his wife, says: Bismillah, Allahumma jannibna ashShaitan, wa Jannib ash-Shaitana ma razaqtana, Satan would never harm that child, should it be ordained that they will have one. (Because of that sleep)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.494]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 494

Narrated 'Adi bin Hatim:

I asked the Prophet, "I send off (for a game) my trained hunting dogs; (what is your verdict concerning the game they hunt?" He said, "If you send off your trained hunting dogs and mention the Name of Allah, then, if they catch some game, eat (thereof). And if you hit the game with a mi'rad (a hunting tool) and it wounds it, you can eat (it)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.495]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 495

Narrated 'Aisha:

The people said to the Prophet , "O Allah's Apostle! Here are people who have recently embraced Islam and they bring meat, and we do not know whether they had mentioned Allah's Name while slaughtering the animals or not." The Prophet said, "You should mention Allah's Name and eat."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.496]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 496

Narrated Anas:

The Prophet slaughtered two rams as sacrifice and mentioned Allah's Name and said, "Allahu-Akbar" while slaughtering).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.497]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 497

Narrated Jundab:

That he witnessed the Prophet on the Day of Nahr. The Prophet offered prayer and then delivered a sermon saying, "Whoever slaughtered his sacrifice before offering prayer, should slaughter another animal in place of the first; and whoever has not yet slaughtered any, should slaughter a sacrifice and mention Allah's Name while doing so."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.498]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 498

Narrated Ibn 'Umar:

The Prophet said, "Do not swear by your fathers; and whoever wants to swear should swear by Allah."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.499]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 499

Narrated Abu Huraira:

Allah's Apostle sent ten persons to bring the enemy's secrets and Khubaib Al-Ansari was one of them. 'Ubaidullah bin 'Iyad told me that the daughter of Al-Harith told him that when they gathered (to kill Khubaib Al Ansari) he asked for a razor to clean his pubic region, and when they had taken him outside the sanctuary of Mecca in order to kill him, he said in verse, "I don't care if I am killed as a Muslim, on any side (of my body) I may be killed in Allah's Cause; for that is for the sake of Allah's very Self; and if He will, He will bestow His Blessings upon the torn pieces of my body." Then Ibn Al-Harith killed him, and the Prophet informed his companions of the death of those (ten men) on the very day they were killed.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.500]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 500

Narrated 'Abdullah:

The Prophet said, "There is none having a greater sense of Ghira than Allah, and for that reason He has forbidden shameful deeds and sins (illegal sexual intercourse etc.) And there is none who likes to be praised more than Allah does." (See Hadith No. 147, Vol. 7)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.501]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 501

Narrated Abu Huraira:

The Prophet said, "When Allah created the Creation, He wrote in His Book--and He wrote (that) about Himself, and it is placed with Him on the Throne--'Verily My Mercy overcomes My Anger.'"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.502]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 502

Narrated Abu Huraira:

The Prophet said, "Allah says: 'I am just as My slave thinks I am, (i.e. I am able to do for him what he thinks I can do for him) and I am with him if He remembers Me. If he remembers Me in himself, I too, remember him in Myself; and if he remembers Me in a group of people, I remember him in a group that is better than they; and if he comes one span nearer to Me, I go one cubit nearer to him; and if he comes one cubit nearer to Me, I go a distance of two outstretched arms nearer to him; and if he comes to Me walking, I go to him running.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.503]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 503

Narrated Jabir bin 'Abdullah:

when this Verse:--'Say (O Muhammad!): He has Power to send torments on you from above,' (6.65) was revealed; The Prophet said, "I take refuge with Your Face." Allah revealed:-- '..or from underneath your feet.' (6.65) The Prophet then said, "I seek refuge with Your Face!" Then Allah revealed:--'...or confuse you in party-strife.' (6.65) Oh that, the Prophet said, "This is easier."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.504]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 504

Narrated 'Abdullah:

Ad-Dajjal was mentioned in the presence of the Prophet. The Prophet said, "Allah is not hidden from you; He is not one-eyed," and pointed with his hand towards his eye, adding, "While Al-Masih Ad-Dajjal is blind in the right eye and his eye looks like a protruding grape."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.505]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 505

Narrated Anas:

The Prophet said, "Allah did not send any prophet but that he warned his nation of the one-eyed liar (Ad-Dajjal). He is one-eyed while your Lord is not one-eyed, The word 'Kafir' (unbeliever) is written between his two eyes."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.506]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 506

Narrated Abu Said Al-Khudri:

That during the battle with Bani Al-Mustaliq they (Muslims) captured some females and intended to have sexual relation with them without impregnating them. So they asked the Prophet about coitus interrupt us. The Prophet said, "It is better that you should not do it, for Allah has written whom He is going to create till the Day of Resurrection." Qaza'a said, "I heard Abu Sa'id saying that the Prophet said, 'No soul is ordained to be created but Allah will create it."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.507]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 507

Narrated Anas:

The Prophet said, "Allah will gather the believers on the Day of Resurrection in the same way (as they are gathered in this life), and they will say, 'Let us ask someone to intercede for us with our Lord that He may relieve us from this place of ours.' Then they will go to Adam and say, 'O Adam! Don't you see the people (people's condition)? Allah created you with His Own Hands and ordered His angels to prostrate before you, and taught you the names of all the things. Please intercede for us with our Lord so that He may relieve us from this place of ours.' Adam will say, 'I am not fit for this undertaking' and mention to them the mistakes he had committed, and add, "But you d better go to Noah as he was the first Apostle sent by Allah to the people of the Earth.' They will go to Noah who will reply, 'I am not fit for this undertaking,' and mention the mistake which he made, and add, 'But you'd better go to Abraham, Khalil Ar-Rahman.'

They will go to Abraham who will reply, 'I am not fit for this undertaking,' and mention to them the mistakes he made, and add, 'But you'd better go to Moses, a slave whom Allah gave the Torah and to whom He spoke directly' They will go to Moses who will reply, 'I am not fit for this undertaking,' and mention to them the mistakes he made, and add, 'You'd better go to Jesus, Allah's slave and His Apostle and His Word (Be: And it was) and a soul created by Him.' They will go to Jesus who will say, 'I am not fit for this undertaking, but you'd better go to Muhammad whose sins of the past and the future had been forgiven (by Allah).' So they will come to me and I will ask the permission of my Lord, and I will be permitted (to present myself) before Him. When I see my Lord, I will fall down in (prostration) before Him and He will leave me (in prostration) as long as He wishes, and then it will be said to me, 'O Muhammad! Raise your head and speak, for you will be listened to; and ask, for you will be granted (your request); and intercede, for your intercession will be accepted.' I will then raise my head and praise my Lord with certain praises which He has taught me, and then I will intercede. Allah will allow me to intercede (for a certain kind of people) and will fix a limit whom I will admit into Paradise.

I will come back again, and when I see my Lord (again), I will fall down in prostration before Him, and He will leave me (in prostration) as long as He wishes, and then He will say, 'O Muhammad! Raise your head and speak, for you will be listened to; and ask, for you will be granted (your request); and intercede, for your intercession will be accepted.' I will then praise my Lord with certain praises which He has taught me, and then I will intercede. Allah will allow me to intercede (for a certain kind of people) and will fix a limit to whom I will admit into Paradise, I will return again, and when I see my Lord, I will fall down (in prostration) and He will leave me (in prostration) as long as He wishes, and then He will say, 'O Muhammad! Raise your head and speak, for you will be listened to, and ask, for you will be granted (your request); and intercede, for your intercession will be accepted.' I will then praise my Lord with certain praises which He has taught me, and then I will intercede. Allah will allow me to intercede (for a certain kind of people) and will fix a limit to whom I will admit into Paradise. I will come back and say, 'O my Lord! None remains in Hell (Fire) but those whom Qur'an has imprisoned therein and for whom eternity in Hell (Fire) has become inevitable.' "

The Prophet added, "There will come out of Hell (Fire) everyone who says: 'La ilaha illal-lah,' and has in his heart good equal to the weight of a barley grain. Then there will come out of Hell (Fire) everyone who says: ' La ilaha illal-lah,' and has in his heart good equal to the weight of a wheat grain. Then there will come out of Hell (Fire) everyone who says: 'La ilaha illal-lah,' and has in his heart good equal to the weight of an atom (or a smallest ant)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.508]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 508

Narrated Abu Huraira:

Allah's Apostle said, "Allah's Hand is full, and (its fullness) is not affected by the continuous spending, day and night." He also said, "Do you see what He has spent since He created the Heavens and the Earth? Yet all that has not decreased what is in His Hand." He also said, "His Throne is over the water and in His other Hand is the balance (of Justice) and He raises and lowers (whomever He will)." (See Hadith No. 206, Vol. 6)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.509]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 509

Narrated Ibn 'Umar:

Allah's Apostle said, "On the Day of Resurrection, Allah will grasp the whole Earth by His Hand, and all the Heavens in His right, and then He will say, 'I am the King." Abu Huraira said, "Allah's Apostle said," Allah will grasp the Earth...' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.510]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 510

Narrated 'Abdullah:

A Jew came to the Prophet and said, "O Muhammad! Allah will hold the heavens on a Finger, and the mountains on a Finger, and the trees on a Finger, and all the creation on a Finger, and then He will say, 'I am the King.' " On that Allah's Apostle smiled till his premolar teeth became visible, and then recited:--

'No just estimate have they made of Allah such as due to him....(39.67) 'Abdullah added: Allah's Apostle smiled (at the Jew's statement) expressing his wonder and believe in what was said.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.511]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 511

Narrated 'Abdullah:

A man from the people of the scripture came to the Prophet and said, "O Abal-Qasim! Allah will hold the Heavens upon a Finger, and the Earth on a Finger and the land on a Finger, and all the creation on a Finger, and will say, 'I am the King! I am the King!' " I saw the Prophet (after hearing that), smiling till his premolar teeth became visible, and he then recited: -- 'No just estimate have they made of Allah such as due to him... (39.67)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.512]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 512

Narrated Al-Mughira:

Sa'd bin 'Ubada said, "If I saw a man with my wife, I would strike him (behead him) with the blade of my sword." This news reached Allah's Apostle who then said, "You people are astonished at Sa'd's Ghira. By Allah, I have more Ghira than he, and Allah has more Ghira than I, and because of Allah's Ghira, He has made unlawful Shameful deeds and sins (illegal sexual intercourse etc.) done in open and in secret. And there is none who likes that the people should repent to Him and beg His pardon than Allah, and for this reason He sent the warners and the givers of good news. And there is none who likes to be praised more than Allah does, and for this reason, Allah promised to grant Paradise (to the doers of good)." 'Abdul Malik said, "No person has more Ghira than Allah."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.513]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 513

Narrated Sahl bin Sa'd:

The Prophet said to a man, "Have you got anything of the Qur'an?" The man said, "Yes, such-and-such Sura, and such-and-such Sura," naming the Suras.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.514]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 514

Narrated 'Imran bin Hussain:

While I was with the Prophet , some people from Bani Tamim came to him. The Prophet said, "O Bani Tamim! Accept the good news!" They said, "You have given us the good news; now give us (something)." (After a while) some Yemenites entered, and he said to them, "O the people of Yemen! Accept the good news, as Bani Tamim have refused it. " They said, "We accept it, for we have come to you to learn the Religion. So we ask you what the beginning of this universe was." The Prophet said "There was Allah and nothing else before Him and His Throne was over the water, and He then created the Heavens and the Earth and wrote everything in the Book." Then a man came to me and said, 'O Imran! Follow your she-camel for it has run away!" So I set out seeking it, and behold, it was beyond the mirage! By Allah, I wished that it (my she-camel) had gone but that I had not left (the gathering). "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.515]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 515

Narrated Abu Huraira:

The Prophet said, "The Right (Hand) of Allah Is full, and (Its fullness) is not affected by the continuous spending night and day. Do you see what He has spent since He created the Heavens and the Earth? Yet all that has not decreased what is in His Right Hand. His Throne is over the water and in His other Hand is the Bounty or the Power to bring about death, and He raises some people and brings others down." (See Hadith No. 508)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.516]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 516

Narrated Anas:

Zaid bin Haritha came to the Prophet complaining about his wife. The Prophet kept on saying (to him), "Be afraid of Allah and keep your wife." Aisha said, "If Allah's Apostle were to conceal anything (of the Quran he would have concealed this Verse." Zainab used to boast before the wives of the Prophet and used to say, "You were given in marriage by your families, while I was married (to the Prophet) by Allah from over seven Heavens." And Thabit recited, "The Verse:-- 'But (O Muhammad) you did hide in your heart that which Allah was about to make manifest, you did fear the people,' (33.37) was revealed in connection with Zainab and Zaid bin Haritha."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.517]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 517

Narrated Anas bin Malik:

The Verse of Al-Hijab (veiling of women) was revealed in connection with Zainab bint Jahsh. (On the day of her marriage with him) the Prophet gave a wedding banquet with bread and meat; and she used to boast before other wives of the Prophet and used to say, "Allah married me (to the Prophet in the Heavens."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.518]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 518

Narrated Abu Huraira:

The Prophet said, "When Allah had finished His creation, He wrote over his Throne: 'My Mercy preceded My Anger.'


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.519]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 519

Narrated Abu Huraira:

The Prophet said, "Whoever believes in Allah and His Apostle offers prayers perfectly and fasts (the month of) Ramadan then it is incumbent upon Allah to admit him into Paradise, whether he emigrates for Allah's cause or stays in the land where he was born." They (the companions of the Prophet) said, "O Allah's Apostle! Should we not inform the people of that?" He said, "There are one-hundred degrees in Paradise which Allah has prepared for those who carry on Jihad in His Cause. The distance between every two degrees is like the distance between the sky and the Earth, so if you ask Allah for anything, ask Him for the Firdaus, for it is the last part of Paradise and the highest part of Paradise, and at its top there is the Throne of Beneficent, and from it gush forth the rivers of Paradise."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.520]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 520

Narrated Abu Dharr:

I entered the mosque while Allah's Apostle was sitting there. When the sun had set, the Prophet said, "O Abu Dharr! Do you know where this (sun) goes?" I said, "Allah and His Apostle know best." He said, "It goes and asks permission to prostrate, and it is allowed, and (one day) it, as if being ordered to return whence it came, then it will rise from the west." Then the Prophet recited, "That: "And the sun runs on its fixed course (for a term decreed)," (36.38) as it is recited by 'Abdullah.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.521]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 521

Narrated Zaid bin Thabit:

Abu Bakr sent for me, so I collected the Qur'an till I found the last part of Surat-at-Tauba with Abi Khuzaima Al-Ansari and did not find it with anybody else. (The Verses are): -- 'Verily, there has come to you an Apostle (Muhammad) from amongst yourselves..(till the end of Surat Bara'a) (i.e., At-Tauba).' (9.128-129)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.522]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 522

Narrated Yunus:

(As 521).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.523]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 523

Narrated Ibn 'Abbas:

The Prophet used to say at the time of difficulty, 'La ilaha il-lallah Al-'Alimul-Halim. La-ilaha il-lallah Rabul- Arsh-al-Azim, La ilaha-il-lallah Rabus-Samawati Rab-ul-Ard; wa Rab-ul-Arsh Al-Karim.' (See Hadith No. 356 and 357, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.524]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 524

Narrated Abu Said Al-Khudri:

The Prophet said, "The people will fall unconscious on the Day of Resurrection, then suddenly I will see Moses holding one of the pillars of the Throne." Abu Huraira said: The Prophet said, "I will be the first person to be resurrected and will see Moses holding the Throne."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.525]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 525

Narrated Abu Huraira:

Allah's Apostle said, "If somebody gives in charity something equal to a date from his honestly earned money ----for nothing ascends to Allah except good---- then Allah will take it in His Right (Hand) and bring it up for its owner as anyone of you brings up a baby horse, till it becomes like a mountain." Abu Huraira said: The Prophet. said, "Nothing ascends to Allah except good."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.526]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 526

Narrated Ibn Abbas:

Allah's Apostle used to say at the time of difficulty, "None has the right to be worshipped but Allah, the Majestic, the Most Forbearing. None has the right to be worshipped but Allah, the Lord of the Tremendous Throne. None has the right to be worshipped but Allah, the Lord of the Heavens and the Lord of the Honourable Throne. (See Hadith No. 357, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.527]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 527

Narrated Abu Said Al-Khudri:

When 'Ali was in Yemen, he sent some gold in its ore to the Prophet. The Prophet distributed it among Al-Aqra' bin Habis Al-Hanzali who belonged to Bani Mujashi, 'Uyaina bin Badr Al-Fazari, 'Alqama bin 'Ulatha Al-'Amiri, who belonged to the Bani Kilab tribe and Zaid AI-Khail At-Ta'i who belonged to Bani Nabhan. So the Quraish and the Ansar became angry and said, "He gives to the chiefs of Najd and leaves us!" The Prophet said, "I just wanted to attract and unite their hearts (make them firm in Islam)." Then there came a man with sunken eyes, bulging forehead, thick beard, fat raised cheeks, and clean-shaven head, and said, "O Muhammad! Be afraid of Allah! " The Prophet said, "Who would obey Allah if I disobeyed Him? (Allah). He trusts me over the people of the earth, but you do not trust me?" A man from the people (present then), who, I think, was Khalid bin Al-Walid, asked for permission to kill him, but the Prophet prevented him. When the man went away, the Prophet said, "Out of the offspring of this man, there will be people who will recite the Quran but it will not go beyond their throats, and they will go out of Islam as an arrow goes out through the game, and they will kill the Muslims and leave the idolators. Should I live till they appear, I would kill them as the Killing of the nation of 'Ad."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.528]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 528

Narrated Abu Dharr:

I asked the Prophet regarding the Verse:--'And the sun runs on its fixed course for a term decreed for it.' (36.28) He said, "Its fixed course is underneath Allah's Throne."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.529]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 529

Narrated Jarir:

We were sitting with the Prophet and he looked at the moon on the night of the full-moon and said, "You people will see your Lord as you see this full moon, and you will have no trouble in seeing Him, so if you can avoid missing (through sleep or business, etc.) a prayer before sunrise (Fajr) and a prayer before sunset (Asr) you must do so." (See Hadith No. 529, Vol. 1)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.530]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 530

Narrated Jarir bin 'Abdullah:

The Prophet said, "You will definitely see your Lord with your own eyes."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.531]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 531

Narrated Jarir:

Allah's Apostle came out to us on the night of the full moon and said, "You will see your Lord on the Day of Resurrection as you see this (full moon) and you will have no difficulty in seeing Him."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.532]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 532

Narrated Anas:

The Prophet said, "The believers will be kept (waiting) on the Day of Resurrection so long that they will become worried and say, "Let us ask somebody to intercede far us with our Lord so that He may relieve us from our place.

Then they will go to Adam and say, 'You are Adam, the father of the people. Allah created you with His Own Hand and made you reside in His Paradise and ordered His angels to prostrate before you, and taught you the names of all things will you intercede for us with your Lord so that He may relieve us from this place of ours? Adam will say, 'I am not fit for this undertaking.' He will mention his mistakes he had committed, i.e., his eating off the tree though he had been forbidden to do so. He will add, 'Go to Noah, the first prophet sent by Allah to the people of the Earth.' The people will go to Noah who will say, 'I am not fit for this undertaking' He will mention his mistake which he had done, i.e., his asking his Lord without knowledge.' He will say (to them), 'Go to Abraham, Khalil Ar-Rahman.' They will go to Abraham who will say, 'I am not fit for this undertaking. He would mention three words by which he told a lie, and say (to them). 'Go to Moses, a slave whom Allah gave the Torah and spoke to, directly and brought near Him, for conversation.'

They will go to Moses who will say, 'I am not fit for this undertaking. He will mention his mistake he made, i.e., killing a person, and will say (to them), 'Go to Jesus, Allah's slave and His Apostle, and a soul created by Him and His Word.' (Be: And it was.) They will go to Jesus who will say, 'I am not fit for this undertaking but you'd better go to Muhammad the slave whose past and future sins have been forgiven by Allah.' So they will come to me, and I will ask my Lord's permission to enter His House and then I will be permitted. When I see Him I will fall down in prostration before Him, and He will leave me (in prostration) as long as He will, and then He will say, 'O Muhammad, lift up your head and speak, for you will be listened to, and intercede, for your intercession will be accepted, and ask (for anything) for it will be granted:' Then I will raise my head and glorify my Lord with certain praises which He has taught me. Allah will put a limit for me (to intercede for a certain type of people) I will take them out and make them enter Paradise." (Qatada said: I heard Anas saying that), the Prophet said, "I will go out and take them out of Hell (Fire) and let them enter Paradise, and then I will return and ask my Lord for permission to enter His House and I will be permitted.

When I will see Him I will fall down in prostration before Him and He will leave me in prostration as long as He will let me (in that state), and then He will say, 'O Muhammad, raise your head and speak, for you will be listened to, and intercede, for your intercession will be accepted, and ask, your request will be granted.' " The Prophet added, "So I will raise my head and glorify and praise Him as He has taught me. Then I will intercede and He will put a limit for me (to intercede for a certain type of people). I will take them out and let them enter Paradise." (Qatada added: I heard Anas saying that) the Prophet said, 'I will go out and take them out of Hell (Fire) and let them enter Paradise, and I will return for the third time and will ask my Lord for permission to enter His house, and I will be allowed to enter.

When I see Him, I will fall down in prostration before Him, and will remain in prostration as long as He will, and then He will say, 'Raise your head, O Muhammad, and speak, for you will be listened to, and intercede, for your intercession will be accepted, and ask, for your request will be granted.' So I will raise my head and praise Allah as He has taught me and then I will intercede and He will put a limit for me (to intercede for a certain type of people). I will take them out and let them enter Paradise." (Qatada said: I heard Anas saying that) the Prophet said, "So I will go out and take them out of Hell (Fire) and let them enter Paradise, till none will remain in the Fire except those whom Quran will imprison (i.e., those who are destined for eternal life in the fire)." The narrator then recited the Verse:-- "It may be that your Lord will raise you to a Station of Praise and Glory.' (17.79) The narrator added: This is the Station of Praise and Glory which Allah has promised to your Prophet.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.533]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 533

Narrated Anas bin Malik:

Allah's Apostle sent for the Ansar and gathered them in a tent and said to them, "Be patient till you meet Allah and His Apostle, and I will be on the lake-Tank (Al-Kauthar)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.534]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 534

Narrated Ibn 'Abbas:

Whenever the Prophet offered his Tahajjud prayer, he would say, "O Allah, our Lord! All the praises are for You; You are the Keeper (Establisher or the One Who looks after) of the Heavens and the Earth. All the Praises are for You; You are the Light of the Heavens and the Earth and whatever is therein. You are the Truth, and Your saying is the Truth, and Your promise is the Truth, and the meeting with You is the Truth, and Paradise is the Truth, and the (Hell) Fire is the Truth. O Allah! I surrender myself to You, and believe in You, and I put my trust in You (solely depend upon). And to You I complain of my opponents and with Your Evidence I argue. So please forgive the sins which I have done in the past or I will do in the future, and also those (sins) which I did in secret or in public, and that which You know better than I. None has the right to be worshipped but You."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.535]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 535

Narrated 'Adi bin Hatim:

Allah's Apostle said, "There will be none among you but his Lord will speak to him, and there will be no interpreter between them nor a screen to screen Him."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.536]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 536

Narrated 'Abdullah bin Qais:

The Prophet said, "(There will be) two Paradises of silver and all the utensils and whatever is therein (will be of silver); and two Paradises of gold, and its utensils and whatever therein (will be of gold), and there will be nothing to prevent the people from seeing their Lord except the Cover of Majesty over His Face in the Paradise of Eden (eternal bliss)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.537]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 537

Narrated 'Abdullah:

The Prophet said, "Whoever takes the property of a Muslim by taking a false oath, will meet Allah Who will be angry with him." Then the Prophet recited the Verse:-- 'Verily those who purchase a small gain at the cost of Allah's Covenant and their oaths, they shall have no portion in the Hereafter, neither will Allah speak to them, nor look at them.' (3.77)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.538]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 538

Narrated Abu Huraira:

The Prophet said, "(There are) three (types of persons to whom) Allah will neither speak to them on the Day of Resurrections, nor look at them (They are):--(1) a man who takes a false oath that he has been offered for a commodity a price greater than what he has actually been offered; (2) and a man who takes a false oath after the 'Asr (prayer) in order to grab the property of a Muslim through it; (3) and a man who forbids others to use the remaining superfluous water. To such a man Allah will say on the Day of Resurrection, 'Today I withhold My Blessings from you as you withheld the superfluous part of that (water) which your hands did not create.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.539]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 539

Narrated Abu Bakra:

The Prophet said, "Time has come back to its original state which it had when Allah created the Heavens and the Earth, the year is twelve months, of which four are sacred; (and out of these four) three are in succession, namely, Dhul-Qa'da, Dhul-Hijja and Muharram, and (the fourth one) Rajab Mudar which is between Jumad (Ath-Tham) and Sha'ban." The Prophet then asked us, "Which month is this?" We said, "Allah and His Apostle know (it) better." He kept quiet so long that we thought he might call it by another name. Then he said, "Isn't it Dhul-Hijja?" We said, "Yes." He asked "What town is this?" We said, "Allah and His Apostle know (it) better.' Then he kept quiet so long that we thought he might call it by another name. He then said, "Isn't it the (forbidden) town (Mecca)?" We said, "Yes." He asked, "What is the day today?" We said, "Allah and His Apostle know (it) better. Then he kept quiet so long that we thought that he might call it by another name. Then he said, "Isn't it the Day of An-Nahr (slaughtering of sacrifices)?" We said, "Yes." Then he said, "Your blood (lives), your properties," (the sub narrator Muhammad, said: I think he also said): "..and your honor) are as sacred to one another like the sanctity of this Day of yours, in this town of yours, in this month of yours.

You shall meet your Lord and He will ask you about your deeds. Beware! Don't go astray after me by striking the necks of one another. Lo! It is incumbent upon those who are present to inform it to those who are absent for perhaps the informed one might comprehend it (understand it) better than some of the present audience." Whenever the sub-narrator Muhammad mentioned that statement, he would say, "The Prophet said the truth.") And then the Prophet added, "No doubt! Haven't I conveyed Allah's Message to you! No doubt! Haven't I conveyed Allah's Message to you?"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.540]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 540

Narrated Usama:

A son of one of the daughters of the Prophet was dying, so she sent a person to call the Prophet. He sent (her a message), "What ever Allah takes is for Him, and whatever He gives is for Him, and everything has a limited fixed term (in this world) so she should be patient and hope for Allah's reward." She then sent for him again, swearing that he should come. Allah's Apostle got up, and so did Mu'adh bin Jabal, Ubai bin Ka'b and 'Ubada bin As-Samit. When he entered (the house), they gave the child to Allah's Apostle while its breath was disturbed in his chest. (The sub-narrator said: I think he said, "...as if it was a water skin.") Allah's Apostle started weeping whereupon Sa'd bin 'Ubada said, "Do you weep?" The Prophet said, "Allah is merciful only to those of His slaves who are merciful (to others)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.541]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 541

Narrated Abu Huraira:

The Prophet said, "Paradise and Hell (Fire) quarrelled in the presence of their Lord. Paradise said, 'O Lord! What is wrong with me that only the poor and humble people enter me ?' Hell (Fire) said, I have been favored with the arrogant people.' So Allah said to Paradise, 'You are My Mercy,' and said to Hell, 'You are My Punishment which I inflict upon whom I wish, and I shall fill both of you.'" The Prophet added, "As for Paradise, (it will be filled with good people) because Allah does not wrong any of His created things, and He creates for Hell (Fire) whomever He will, and they will be thrown into it, and it will say thrice, 'Is there any more, till Allah (will put) His Foot over it and it will become full and its sides will come close to each other and it will say, 'Qat! Qat! Qat! (Enough! Enough! Enough!) .


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.542]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 542

Narrated Anas:

The Prophet said, "Some people who will be scorched by Hell (Fire) as a punishment for sins they have committed, and then Allah will admit them into Paradise by the grant of His Mercy. These people will be called, 'Al-JahannamiyyLin' (the people of Hell)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.543]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 543

Narrated 'Abdullah:

A Jewish Rabbi came to Allah's Apostle and said, "O Muhammad! Allah will put the Heavens on one finger and the earth on one finger, and the trees and the rivers on one finger, and the rest of the creation on one finger, and then will say, pointing out with His Hand, 'I am the King.' "On that Allah's Apostle smiled and said, "No just estimate have they made of Allah such as due to Him. (39.67)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.544]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 544

Narrated Ibn 'Abbas:

Once I stayed overnight at the house of (my aunt ) Maimuna while the Prophet was with her, to see how was the night prayer of Allah s Apostle Allah's Apostle talked to his wife for a while and then slept. When it was the last third of the night (or part of it), the Prophet got up and looked towards the sky and recited the Verse:-- 'Verily! In the creation of the Heavens and the Earth....there are indeed signs for the men of understanding.' (3.190)

Then He got up and performed the ablution, brushed his teeth and offered eleven Rakat. Then Bilal pronounced the Adhan whereupon the Prophet offered a two-Rak'at (Sunna) prayer and went out to lead the people in Fajr (morning compulsory congregational prayer.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.545]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 545

Narrated Abu Huraira:

Allah's Apostle said, "When Allah created the creations, He wrote with Him on His Throne: 'My Mercy has preceded My Anger."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.546]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 546

Narrated 'Abdullah bin Mas'ud:

Allah's Apostle the true and truly inspired, narrated to us, "The creation of everyone of you starts with the process of collecting the material for his body within forty days and forty nights in the womb of his mother. Then he becomes a clot of thick blood for a similar period (40 days) and then he becomes like a piece of flesh for a similar period. Then an angel is sent to him (by Allah) and the angel is allowed (ordered) to write four things; his livelihood, his (date of) death, his deeds, and whether he will be a wretched one or a blessed one (in the Hereafter) and then the soul is breathed into him. So one of you may do (good) deeds characteristic of the people of Paradise so much that there is nothing except a cubit between him and Paradise but then what has been written for him decides his behavior and he starts doing (evil) deeds characteristic of the people of Hell (Fire) and (ultimately) enters Hell (Fire); and one of you may do (evil) deeds characteristic of the people of Hell (Fire) so much so that there is nothing except a cubit between him and Hell (Fire), then what has been written for him decides his behavior and he starts doing (good) deeds characteristic of the people of Paradise and ultimately) enters Paradise." (See Hadith No. 430, Vol. 4)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.547]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 547

Narrated Ibn 'Abbas:

The Prophet said, "O Gabriel, what prevents you. from visiting us more often than you do?" Then this Verse was revealed:--'And we angels descend not but by Command of your Lord. To Him belongs what is before us and what is behind us..' (19.64) So this was the answer to Muhammad.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.548]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 548

Narrated 'Abdullah:

While I was walking with Allah's Apostle in one of the fields of Medina and he was walking leaning on a stick, he passed a group of Jews. Some of them said to the others, "Ask him (the Prophet) about the spirit." Others said, "Do not ask him." But they asked him and he stood leaning on the stick and I was standing behind him and I thought that he was being divinely inspired. Then he said, "They ask you concerning the spirit say: The spirit, its knowledge is with My Lord. And of knowledge you (O men!) have been given only a little." ...(17.85) On that some of the Jews said to the others, "Didn't we tell you not to ask?"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.549]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 549

Narrated Abu Huraira:

Allah's Apostle said, "Allah guarantees to the person who carries out Jihad for His Cause and nothing compelled him to go out but the Jihad in His Cause, and belief in His Words, that He will either admit him into Paradise or return him with his reward or the booty he has earned to his residence from where he went out." (See Hadith No. 555).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.550]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 550

Narrated Abu Musa:

A man came to the Prophet and said, "A man fights for pride and haughtiness another fights for bravery, and another fights for showing off; which of these (cases) is in Allah's Cause?" The Prophet said, "The one who fights that Allah's Word (Islam) should be superior, fights in Allah's Cause." (See Hadith No. 65, Vol. 4)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.551]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 551

Narrated Al-Mughira bin Shu'ba:

I heard the Prophet saying, "Some people from my followers will continue to be victorious over others till Allah's Order (The Hour) is established." (See Hadith No. 414)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.552]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 552

Narrated Muawiya:

I heard the Prophet saying, "A group of my followers will keep on following Allah's Laws strictly and they will not be harmed by those who will disbelieve them or stand against them till Allah's Order (The Hour) will come while they will be in that state."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.553]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 553

Narrated Ibn 'Abbas:

The Prophet stood before Musailama (the liar) who was sitting with his companions then, and said to him, "If you ask me for this piece (of palm-leaf stalk), even then I would not give it to you. You cannot avoid what Allah has ordained for you, and if you turn away from Islam, Allah will surely ruin you! "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.554]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 554

Narrated Ibn Mas'ud:

While I was walking in company with the Prophet in one of the fields of Medina, the Prophet was reclining on a palm leave stalk which he carried with him. We passed by a group of Jews. Some of them said to the others, "Ask him about the spirit." The others said, "Do not ask him, lest he would say something that you hate." Some of them said, "We will ask him." So a man from among them stood up and said, 'O Abal-Qasim! What is the spirit?" The Prophet kept quiet and I knew that he was being divinely inspired. Then he said: "They ask you concerning the Spirit, Say: The Spirit; its knowledge is with my Lord. And of knowledge you (mankind) have been given only a little." (17.85)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.555]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 555

Narrated Abu Huraira:

Allah's Apostle said, "Allah guarantees (the person who carries out Jihad in His Cause and nothing compelled him to go out but Jihad in His Cause and the belief in His Word) that He will either admit him into Paradise (Martyrdom) or return him with reward or booty he has earned to his residence from where he went out."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.556]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 556

Narrated Anas:

Allah's Apostle said, "Whenever anyone of you invoke Allah for something, he should be firm in his asking, and he should not say: 'If You wish, give me...' for none can compel Allah to do something against His Will."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.557]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 557

Narrated 'Ali bin Abi Talib:

That one night Allah's Apostle visited him and Fatima, the daughter of Allah's Apostle and said to them, "Won 't you offer (night) prayer?.. 'Ali added: I said, "O Allah's Apostle! Our souls are in the Hand of Allah and when He Wishes to bring us to life, He does." Then Allah's Apostle went away when I said so and he did not give any reply. Then I heard him on leaving while he was striking his thighs, saying, 'But man is, more quarrelsome than anything.' (18.54)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.558]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 558

Narrated Abu Huraira:

Allah's Apostle said, "The example of a believer is that of a fresh green plant the leaves of which move in whatever direction the wind forces them to move and when the wind becomes still, it stand straight. Such is the similitude of the believer: He is disturbed by calamities (but is like the fresh plant he regains his normal state soon). And the example of a disbeliever is that of a pine tree (which remains) hard and straight till Allah cuts it down when He will." (See Hadith No. 546 and 547, Vol. 7).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.559]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 559

Narrated 'Abdullah bin 'Umar:

I heard Allah's Apostle while he was standing on the pulpit, saying, "The remaining period of your stay (on the earth) in comparison to the nations before you, is like the period between the 'Asr prayer and sunset. The people of the Torah were given the Torah and they acted upon it till midday, and then they were worn out and were given for their labor, one Qirat each. Then the people of the Gospel were given the Gospel and they acted upon it till the time of the 'Asr prayer, and then they were worn out and were given (for their labor), one Qirat each. Then you people were given the Quran and you acted upon it till sunset and so you were given two Qirats each (double the reward of the previous nations)." Then the people of the Torah said, 'O our Lord! These people have done a little labor (much less than we) but have taken a greater reward.' Allah said, 'Have I withheld anything from your reward?' They said, 'No.' Then Allah said, 'That is My Favor which I bestow on whom I wish.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.560]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 560

Narrated 'Ubada bin As-Samit:

I, along with a group of people, gave the pledge of allegiance to Allah's Apostle. He said, "I take your Pledge on the condition that you (1) will not join partners in worship with Allah, (2) will not steal, (3) will not commit illegal sexual intercourse, (4) will not kill your offspring, (5) will not slander, (6) and will not disobey me when I order you to do good. Whoever among you will abide by his pledge, his reward will be with Allah, and whoever commits any of those sins and receives the punishment in this world, that punishment will be an expiation for his sins and purification; but if Allah screens him, then it will be up to Allah to punish him if He will or excuse Him, if He will."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.561]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 561

Narrated Abu Huraira:

Allah's Prophet Solomon who had sixty wives, once said, "Tonight I will have sexual relation (sleep) with all my wives so that each of them will become pregnant and bring forth (a boy who will grow into) a cavalier and will fight in Allah's Cause." So he slept with his wives and none of them (conceived and) delivered (a child) except one who brought a half (body) boy (deformed). Allah's Prophet said, "If Solomon had said; 'If Allah Will,' then each of those women would have delivered a (would-be) cavalier to fight in Allah's Cause." (See Hadith No. 74 A, Vol. 4).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.562]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 562

Narrated Ibn 'Abbas:

Allah's Apostle entered upon a sick bedouin in whom he went to visit and said to him, "Don't worry, Tahur (i.e., your illness will be a means of cleansing of your sins), if Allah Will." The bedouin said, "Tahur! No, but it is a fever that is burning in the body of an old man and it will make him visit his grave." The Prophet said, "Then it is so."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.563]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 563

Narrated Abu Qatada:

When the people slept till so late that they did not offer the (morning) prayer, the Prophet said, "Allah captured your souls (made you sleep) when He willed, and returned them (to your bodies) when He willed." So the people got up and went to answer the call of nature, performed ablution, till the sun had risen and it had become white, then the Prophet got up and offered the prayer.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.564]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 564

Narrated Abu Huraira:

"A man from the Muslims and a man from the Jews quarrelled, and the Muslim said, "By Him Who gave superiority to Muhammad over all the people!" The Jew said, "By Him Who gave superiority to Moses over all the people!' On that the Muslim lifted his hand and slapped the Jew. The Jew went to Allah's Apostle and informed him of all that had happened between him and the Muslim. The Prophet said, "Do not give me superiority over Moses, for the people will fall unconscious on the Day of Resurrection, I will be the first to regain consciousness and behold, Moses will be standing there, holding the side of the Throne. I will not know whether he has been one of those who have fallen unconscious and then regained consciousness before me, or if he has been one of those exempted by Allah (from falling unconscious)." (See Hadith No. 524, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.565]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 565

Narrated Anas bin Malik:

Allah's Apostle said, "Ad-Dajjal will come to Medina and find the angels guarding it. If Allah will, neither Ad-Dajjal nor plague will be able to come near it."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.566]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 566

Narrated Abu Huraira:

Allah's Apostle said, "For every Prophet there is one invocation which is definitely fulfilled by Allah, and I wish, if Allah will, to keep my that (special) invocation as to be the intercession for my followers on the Day of Resurrection."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.567]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 567

Narrated Abu Huraira:

Allah's Apostle said, "While I was sleeping, I saw myself (in a dream) standing by a well. I drew from it as much water as Allah wished me to draw, and then Ibn Quhafa (Abu Bakr) took the bucket from me and drew one or two buckets, and there was weakness in his drawing----may Allah forgive him! Then 'Umar took the bucket which turned into something like a big drum. I had never seen a powerful man among the people working as perfectly and vigorously as he did. (He drew so much water that) the people drank to their satisfaction and watered their camels that knelt down there. (See Hadith No. 16, Vol. 5)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.568]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 568

Narrated Abu Musa:

Whenever a beggar or a person in need of something came to the Prophet , he used to say (to his companions), "Intercede (for him) and you will be rewarded for that, and Allah will fulfill what He will through His Apostle's tongue."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.569]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 569

Narrated Abu Huraira:

The Prophet said, "None of you should say: 'O Allah! Forgive me if You wish,' or 'Bestow Your Mercy on me if You wish,' or 'Provide me with means of subsistence if You wish,' but he should be firm in his request, for Allah does what He will and nobody can force Him (to do anything)."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.570]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 570

Narrated Ibn 'Abbas:

That he differed with Al-Hurr bin Qais bin Hisn Al-Fazari about the companion of Moses, (i.e., whether he was Kha,dir or not). Ubai bin Ka'b Al-Ansari passed by them and Ibn 'Abbas called him saying, 'My friend (Hur) and I have differed about Moses' Companion whom Moses asked the way to meet. Did you hear Allah's Apostle mentioning anything about him?" Ubai said, "Yes, I heard Allah's Apostle saying, "While Moses was sitting in the company of some Israelites a man came to him and asked, 'Do you know Someone who is more learned than you (Moses)?' Moses said, 'No.' So Allah sent the Divine inspiration to Moses:--

'Yes, Our Slave Khadir is more learned than you' Moses asked Allah how to meet him ( Khadir) So Allah made the fish as a sign for him and it was said to him, 'When you lose the fish, go back (to the place where you lose it) and you will meet him.' So Moses went on looking for the sign of the fish in the sea. The boy servant of Moses (who was accompanying him) said to him, 'Do you remember (what happened) when we betook ourselves to the rock? I did indeed forget to tell you (about) the fish. None but Satan made me forget to tell you about it' (18.63) Moses said:

'That is what we have been seeking." Sa they went back retracing their footsteps. (18.64). So they both found Kadir (there) and then happened what Allah mentioned about them (in the Quran)!' (See 18.60-82)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.571]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 571

Narrated Abu Huraira:

Allah's Apostle said, "If Allah will, tomorrow we will encamp in Khaif Bani Kinana, the place where the pagans took the oath of Kufr (disbelief) against the Prophet. He meant Al-Muhassab. (See Hadith No. 659, Vol. 2)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.572]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 572

Narrated 'Abdullah bin 'Umar:

The Prophet besieged the people of Ta'if, but he did not conquer it. He said, "Tomorrow, if Allah will, we will return home. On this the Muslims said, "Then we return without conquering it?" He said, 'Then carry on fighting tomorrow." The next day many of them were injured. The Prophet said, "If Allah will, we will return home tomorrow." It seemed that statement pleased them whereupon Allah's Apostle smiled.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.573]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 573

Narrated Abu Huraira:

The Prophet said, "When Allah ordains something on the Heaven the angels beat with their wings in obedience to His Statement which sounds like that of a chain dragged over a rock. His Statement: "Until when the fear is banished from their hearts, the Angels say, 'What was it that your Lord said?' 'They reply, '(He has said) the Truth. And He is the Most High, The Great. " (34.23)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.574]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 574

Narrated Abu Huraira :

Allah's Apostle said, "Allah never listens to anything as He listens to the Prophet reciting Quran in a pleasant sweet sounding voice." A companion of Abu Huraira said, "He means, reciting the Quran aloud."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.575]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 575

Narrated Abu Said Al-Khudri:

The Prophet said, "Allah will say (on the Day of Resurrection), 'O Adam!' Adam will reply, 'Labbaik wa Sa'daik! ' Then a loud Voice will be heard (Saying) 'Allah Commands you to take out the mission of the Hell Fire from your offspring.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.576]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 576

Narrated 'Aisha:

I never felt so jealous of any woman as I felt of Khadija, for Allah ordered him (the Prophet ) to give Khadija the glad tidings of a palace in Paradise (for her).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.577]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 577

Narrated Abu Huraira:

Allah's Apostle said, "If Allah loves a person, He calls Gabriel, saying, 'Allah loves so and so, O Gabriel love him' So Gabriel would love him and then would make an announcement in the Heavens: 'Allah has loved so and-so therefore you should love him also.' So all the dwellers of the Heavens would love him, and then he is granted the pleasure of the people on the earth." (See Hadith No. 66, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.578]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 578

Narrated Abu Huraira:

Allah's Apostle said, "There are angels coming to you in succession at night, and others during the day, and they all gather at the time of 'Asr and Fajr prayers. Then the angels who have stayed with you overnight ascend (to the heaven) and He (Allah) asks them though He perfectly knows their affairs. 'In what state have you left my slaves?' They say, 'When we left them, they were praying and when we came to them they were praying.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.579]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 579

Narrated Abu Dharr:

The Prophet said, Gabriel came to me and gave me the glad tidings that anyone who died without worshipping anything besides Allah, would enter Paradise. I asked (Gabriel), 'Even if he committed theft, and even if he committed illegal sexual intercourse?' He said, '(Yes), even if he committed theft, and even if he Committed illegal sexual intercourse."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.580]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 580

Narrated Al-Bara' bin 'Azib:

Allah's Apostle said, "O so-and-so, whenever you go to your bed (for sleeping) say, 'O Allah! I have surrendered myself over to you and have turned my face towards You, and leave all my affairs to You and depend on You and put my trust in You expecting Your reward and fearing Your punishment. There is neither fleeing from You nor refuge but with You. I believe in the Book (Qur'an) which You have revealed and in Your Prophet (Muhammad) whom You have sent.' If you then die on that night, then you will die as a Muslim, and if you wake alive in the morning then you will receive the reward." (See Hadith No. 323, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.581]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 581

Narrated 'Abdullah bin Abi Aufa:

Allah's Apostle said on the Day of (the battle of) the Clans, "O Allah! The Revealer of the Holy Book, The Quick Taker of Accounts! Defeat the clans and shake them."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.582]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 582

Narrated Ibn 'Abbas:

(regarding the Verse):-- 'Neither say your prayer aloud, nor say it in a low tone.' (17.110) This Verse was revealed while Allah's Apostle was hiding himself in Mecca, and when he raised his voice while reciting the Qur'an, the pagans would hear him and abuse the Qur'an and its Revealer and to the one who brought it. So Allah said:--

'Neither say your prayer aloud, nor say it in a low tone.' (17.110) That is, 'Do not say your prayer so loudly that the pagans can hear you, nor say it in such a low tone that your companions do not hear you.' But seek a middle course between those (extremes), i.e., let your companions hear, but do not relate the Qur'an loudly, so that they may learn it from you.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.583]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 583

Narrated Abu Huraira:

The Prophet said, "Allah said: "The son of Adam hurts Me by abusing Time, for I am Time; in My Hands are all things and I cause the revolution of night and day.' " (See Hadith No. 351, Vol. 6)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.584]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 584

Narrated Abu Huraira:

The Prophet said, "Allah said: The Fast is for Me and I will give the reward for it, as he (the one who observes the fast) leaves his sexual desire, food and drink for My Sake. Fasting is a screen (from Hell) and there are two pleasures for a fasting person, one at the time of breaking his fast, and the other at the time when he will meet his Lord. And the smell of the mouth of a fasting person is better in Allah's Sight than the smell of musk." (See Hadith No. 128, Vol. 3).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.585]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 585

Narrated Abu Huraira:

The Prophet said, "Once while Job (Aiyub) was taking a bath in a naked state. Suddenly a great number of gold locusts started falling upon him and he started collecting them in his clothes. His Lord called him, 'O Job! Didn't I make you rich enough to dispense with what you see now?' Job said, 'Yes, O Lord! But I cannot dispense with Your Blessings


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.586]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 586

Narrated Abu Huraira:

Allah's Apostle said, "Every night when it is the last third of the night, our Lord, the Superior, the Blessed, descends to the nearest heaven and says: Is there anyone to invoke Me that I may respond to his invocation? Is there anyone to ask Me so that I may grant him his request? Is there anyone asking My forgiveness so that I may forgive him?. " (See Hadith No. 246,Vol. 2)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.587]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 587

Narrated Abu Huraira:

Allah's Apostle said, "We (Muslims) are the last (to come) but will be the foremost on the Day of Resurrection." The narrators of this Hadith said: Allah said (to man), 'Spend (in charity), for then I will compensate you (generously).' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.588]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 588

Narrated Abu Huraira:

The Prophet said that Gabriel said, "Here is Khadija coming to you with a dish of food or a tumbler containing something to drink. Convey to her a greeting from her Lord (Allah) and give her the glad tidings that she will have a palace in Paradise built of Qasab wherein there will be neither any noise nor any fatigue (trouble)." (See Hadith No. 168, Vol. 5)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.589]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 589

Narrated Abu Huraira:

the Prophet said, "Allah said, "I have prepared for My righteous slaves (such excellent things) as no eye has ever seen, nor an ear has ever heard nor a human heart can ever think of.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.590]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 590

Narrated Ibn Abbas:

Whenever the Prophet offered the night (Tahajjud) prayer, he used to say, "O Allah! All the Praises are for You; You are the Light of the Heavens and the Earth. And all the Praises are for You; You are the Keeper of the Heavens and the Earth. All the Praises are for You; You are the Lord of the Heavens and the Earth and whatever is therein. You are the Truth, and Your Promise is the Truth, and Your Speech is the Truth, and meeting You is the Truth, and Paradise is the Truth and Hell (Fire) is the Truth and all the prophets are the Truth and the Hour is the Truth. O Allah! I surrender to You, and believe in You, and depend upon You, and repent to You, and in Your cause I fight and with Your orders I rule. So please forgive my past and future sins and those sins which I did in secret or in public. It is You Whom I worship, None has the right to be worshipped except You ." (See Hadith No. 329,Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.591]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 591

Narrated 'Urwa bin Az-Zubair:

Sa'id bin Al-Musaiyab, 'Alqama bin Waqqas and 'Ubaidullah bin 'Abdullah regarding the narrating of the forged statement against 'Aisha, the wife of the Prophet, when the slanderers said what they said and Allah revealed her innocence. 'Aisha said, "But by Allah, I did not think that Allah, (to confirm my innocence), would reveal Divine Inspiration which would be recited, for I consider myself too unimportant to be talked about by Allah through Divine Inspiration revealed for recitation, but I hoped that Allah's Apostle might have a dream in which Allah would reveal my innocence. So Allah revealed:-- 'Verily! Those who spread the slander are a gang among you...' (The ten Verses in Surat-an-Nur) (24.11-20)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.592]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 592

Narrated Abu Huraira:

Allah's Apostle said, "Allah says, "If My slave intends to do a bad deed then (O Angels) do not write it unless he does it; if he does it, then write it as it is, but if he refrains from doing it for My Sake, then write it as a good deed (in his account). (On the other hand) if he intends to go a good deed, but does not do it, then write a good deed (in his account), and if he does it, then write it for him (in his account) as ten good deeds up to seven-hundred times.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.593]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 593

Narrated Abu Huraira:

Allah's Apostle said, "Allah created the creation, and when He finished from His creation the Rahm (womb) got up, and Allah said (to it). "Stop! What do you want? It said; "At this place I seek refuge with You from all those who sever me (i.e. sever the ties of Kinship.)" Allah said: "Would you be pleased that I will keep good relation with the one who will keep good relation with you, and I will sever the relation with the one who will sever the relation with you. It said: 'Yes, 'O my Lord.' Allah said (to it), 'That is for you.'' And then Abu Huraira recited the Verse:-- "Would you then if you were given the authority, do mischief in the land, and sever your ties of kinship." (47.22)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.594]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 594

Narrated Zaid bin Khalid:

It rained (because of the Prophet's invocation for rain) and the Prophet said, "Allah said, 'Some of My slaves have become disbelievers in Me, and some others, believers in Me.'"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.595]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 595

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'If My slaves loves the meeting with Me, I too love the meeting with him; and if he dislikes the meeting with Me, I too dislike the meeting with him.' " (See Hadith No. 514, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.596]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 596

Narrated Abu Huraira:

Allah's Apostle said, "Allah said, 'I am to my slave as he thinks of Me, (i.e. I am able to do for him what he thinks I can do for him). (See Hadith No. 502)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.597]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 597

Narrated Abu Huraira:

Allah's Apostle said, "A man who never did any good deed, said that if he died, his family should burn him and throw half the ashes of his burnt body in the earth and the other half in the sea, for by Allah, if Allah should get hold of him, He would inflict such punishment on him as He would not inflict on anybody among the people. But Allah ordered the sea to collect what was in it (of his ashes) and similarly ordered the earth to collect what was in it (of his ashes). Then Allah said (to the recreated man ), 'Why did you do so?' The man replied, 'For being afraid of You, and You know it (very well).' So Allah forgave him."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.598]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 598

Narrated Abu Huraira:

I heard the Prophet saying, "If somebody commits a sin and then says, 'O my Lord! I have sinned, please forgive me!' and his Lord says, 'My slave has known that he has a Lord who forgives sins and punishes for it, I therefore have forgiven my slave (his sins).' Then he remains without committing any sin for a while and then again commits another sin and says, 'O my Lord, I have committed another sin, please forgive me,' and Allah says, 'My slave has known that he has a Lord who forgives sins and punishes for it, I therefore have forgiven my slave (his sin). Then he remains without Committing any another sin for a while and then commits another sin (for the third time) and says, 'O my Lord, I have committed another sin, please forgive me,' and Allah says, 'My slave has known that he has a Lord Who forgives sins and punishes for it I therefore have forgiven My slave (his sin), he can do whatever he likes."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.599]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 599

Narrated Abu Said:

The Prophet mentioned a man from the people of the past or those who preceded you. The Prophet said a sentence meaning: Allah had given him wealth and children. When his death approached, he said to his sons, "What kind of father have I been to you?" They replied, "You have been a good father." He told them that he had not presented any good deed before Allah, and if Allah should get hold of him He would punish him.' "So look!" he added, "When I die, burn me, and when I turn into coal, crush me, and when there comes a windy day, scatter my ashes in the wind." The Prophet added, "Then by Allah, he took a firm promise from his children to do so, and they did so. (They burnt him after his death) and threw his ashes on a windy day. Then Allah commanded to his ashes. "Be," and behold! He became a man standing! Allah said, "O My slave! What made you do what you did?" He replied, "For fear of You." Nothing saved him then but Allah's Mercy (So Allah forgave him).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.600]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 600

Narrated Anas:

I heard the Prophet saying, "On the Day of Resurrection I will intercede and say, "O my Lord! Admit into Paradise (even) those who have faith equal to a mustard seed in their hearts." Such people will enter Paradise, and then I will say, 'O (Allah) admit into Paradise (even) those who have the least amount of faith in their hearts." Anas then said: As if I were just now looking at the fingers of Allah's Apostle.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.601]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 601

Narrated Ma'bad bin Hilal Al'Anzi:

We, i.e., some people from Basra gathered and went to Anas bin Malik, and we went in company with Thabit Al-Bunnani so that he might ask him about the Hadith of Intercession on our behalf. Behold, Anas was in his palace, and our arrival coincided with his Duha prayer. We asked permission to enter and he admitted us while he was sitting on his bed. We said to Thabit, "Do not ask him about anything else first but the Hadith of Intercession." He said, "O Abu Hamza! There are your brethren from Basra coming to ask you about the Hadith of Intercession." Anas then said, "Muhammad talked to us saying, 'On the Day of Resurrection the people will surge with each other like waves, and then they will come to Adam and say, 'Please intercede for us with your Lord.' He will say, 'I am not fit for that but you'd better go to Abraham as he is the Khalil of the Beneficent.' They will go to Abraham and he will say, 'I am not fit for that, but you'd better go to Moses as he is the one to whom Allah spoke directly.' So they will go to Moses and he will say, 'I am not fit for that, but you'd better go to Jesus as he is a soul created by Allah and His Word.' (Be: And it was) they will go to Jesus and he will say, 'I am not fit for that, but you'd better go to Muhammad.'

They would come to me and I would say, 'I am for that.' Then I will ask for my Lord's permission, and it will be given, and then He will inspire me to praise Him with such praises as I do not know now. So I will praise Him with those praises and will fall down, prostrate before Him. Then it will be said, 'O Muhammad, raise your head and speak, for you will be listened to; and ask, for your will be granted (your request); and intercede, for your intercession will be accepted.' I will say, 'O Lord, my followers! My followers!' And then it will be said, 'Go and take out of Hell (Fire) all those who have faith in their hearts, equal to the weight of a barley grain.' I will go and do so and return to praise Him with the same praises, and fall down (prostrate) before Him. Then it will be said, 'O Muhammad, raise your head and speak, for you will be listened to, and ask, for you will be granted (your request); and intercede, for your intercession will be accepted.' I will say, 'O Lord, my followers! My followers!' It will be said, 'Go and take out of it all those who have faith in their hearts equal to the weight of a small ant or a mustard seed.' I will go and do so and return to praise Him with the same praises, and fall down in prostration before Him. It will be said, 'O, Muhammad, raise your head and speak, for you will be listened to, and ask, for you will be granted (your request); and intercede, for your intercession will be accepted.' I will say, 'O Lord, my followers!' Then He will say, 'Go and take out (all those) in whose hearts there is faith even to the lightest, lightest mustard seed. (Take them) out of the Fire.' I will go and do so."'

When we left Anas, I said to some of my companions, "Let's pass by Al-Hasan who is hiding himself in the house of Abi Khalifa and request him to tell us what Anas bin Malik has told us." So we went to him and we greeted him and he admitted us. We said to him, "O Abu Said! We came to you from your brother Anas Bin Malik and he related to us a Hadith about the intercession the like of which I have never heard." He said, "What is that?" Then we told him of the Hadith and said, "He stopped at this point (of the Hadith)." He said, "What then?" We said, "He did not add anything to that." He said, Anas related the Hadith to me twenty years ago when he was a young fellow. I don't know whether he forgot or if he did not like to let you depend on what he might have said." We said, "O Abu Said ! Let us know that." He smiled and said, "Man was created hasty. I did not mention that, but that I wanted to inform you of it.

Anas told me the same as he told you and said that the Prophet added, 'I then return for a fourth time and praise Him similarly and prostrate before Him me the same as he 'O Muhammad, raise your head and speak, for you will be listened to; and ask, for you will be granted (your request): and intercede, for your intercession will be accepted .' I will say, 'O Lord, allow me to intercede for whoever said, 'None has the right to be worshiped except Allah.' Then Allah will say, 'By my Power, and my Majesty, and by My Supremacy, and by My Greatness, I will take out of Hell (Fire) whoever said: 'None has the right to be worshipped except Allah.' ''


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.602]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 602

Narrated 'Abdullah:

Allah's Apostle said, "The person who will be the last one to enter Paradise and the last to come out of Hell (Fire) will be a man who will come out crawling, and his Lord will say to him, 'Enter Paradise.' He will reply, 'O Lord, Paradise is full.' Allah will give him the same order thrice, and each time the man will give Him the same reply, i.e., 'Paradise is full.' Thereupon Allah will say (to him), 'Ten times of the world is for you.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.603]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 603

Narrated 'Adi bin Hatim:

Allah's Apostle said, "There will be none among you but his Lord will talk to him, and there will be no interpreter between him and Allah. He will look to his right and see nothing but his deeds which he has sent forward, and will look to his left and see nothing but his deeds which he has sent forward, and will look in front of him and see nothing but the (Hell) Fire facing him. So save yourself from the (Hell) Fire even with half a date (given in charity)." Al-A'mash said: 'Amr bin Murra said, Khaithama narrated the same and added, '..even with a good word.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.604]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 604

Narrated 'Abdullah:

A priest from the Jews came (to the Prophet) and said, "On the Day of Resurrection, Allah will place all the heavens on one finger, and the Earth on one finger, and the waters and the land on one finger, and all the creation on one finger, and then He will shake them and say. 'I am the King! I am the King!'" I saw the Prophet smiling till his premolar teeth became visible expressing his amazement and his belief in what he had said. Then the Prophet recited: 'No just estimate have they made of Allah such as due to Him (up to)...; High is He above the partners they attribute to Him.' (39.67)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.605]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 605

Narrated Safwan bin Muhriz:

A man asked Ibn 'Umar, "What have you heard from Allah's Apostle regarding An-Najwa?" He said, "Everyone of you will come close to His Lord Who will screen him from the people and say to him, 'Did you do so-and-so?' He will reply, 'Yes.' Then Allah will say, 'Did you do so-and-so?' He will reply, 'Yes.' So Allah will question him and make him confess, and then Allah will say, 'I screened your sins in the world and forgive them for you today.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.606]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 606

Narrated Abu Huraira:

The Prophet said, "Adam and Moses debated with each other and Moses said, 'You are Adam who turned out your offspring from Paradise.' Adam said, "You are Moses whom Allah chose for His Message and for His direct talk, yet you blame me for a matter which had been ordained for me even before my creation?' Thus Adam overcame Moses."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.607]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 607

Narrated Anas:

Allah's Apostle said, "The believers will be assembled on the Day of Resurrection and they will say, 'Let us look for someone to intercede for us with our Lord so that He may relieve us from this place of ours.' So they will go to Adam and say, 'You are Adam, the father of mankind, and Allah created you with His Own Hands and ordered the Angels to prostrate before you, and He taught you the names of all things; so please intercede for us with our Lord so that He may relieve us.' Adam will say, to them, 'I am not fit for that,' and then he will mention to them his mistake which he has committed.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.608]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 608

Narrated Anas bin Malik:

The night Allah's Apostle was taken for a journey from the sacred mosque (of Mecca) Al-Ka'ba: Three persons came to him (in a dreamy while he was sleeping in the Sacred Mosque before the Divine Inspiration was revealed to Him. One of them said, "Which of them is he?" The middle (second) angel said, "He is the best of them." The last (third) angle said, "Take the best of them." Only that much happened on that night and he did not see them till they came on another night, i.e. after The Divine Inspiration was revealed to him. (Fateh-Al-Bari Page 258, Vol. 17) and he saw them, his eyes were asleep but his heart was not----and so is the case with the prophets: their eyes sleep while their hearts do not sleep. So those angels did not talk to him till they carried him and placed him beside the well of Zam-Zam. From among them Gabriel took charge of him. Gabriel cut open (the part of his body) between his throat and the middle of his chest (heart) and took all the material out of his chest and abdomen and then washed it with Zam-Zam water with his own hands till he cleansed the inside of his body, and then a gold tray containing a gold bowl full of belief and wisdom was brought and then Gabriel stuffed his chest and throat blood vessels with it and then closed it (the chest). He then ascended with him to the heaven of the world and knocked on one of its doors.

The dwellers of the Heaven asked, 'Who is it?' He said, "Gabriel." They said, "Who is accompanying you?" He said, "Muhammad." They said, "Has he been called?" He said, "Yes" They said, "He is welcomed." So the dwellers of the Heaven became pleased with his arrival, and they did not know what Allah would do to the Prophet on earth unless Allah informed them. The Prophet met Adam over the nearest Heaven. Gabriel said to the Prophet, "He is your father; greet him." The Prophet greeted him and Adam returned his greeting and said, "Welcome, O my Son! O what a good son you are!" Behold, he saw two flowing rivers, while he was in the nearest sky. He asked, "What are these two rivers, O Gabriel?" Gabriel said, "These are the sources of the Nile and the Euphrates."

Then Gabriel took him around that Heaven and behold, he saw another river at the bank of which there was a palace built of pearls and emerald. He put his hand into the river and found its mud like musk Adhfar. He asked, "What is this, O Gabriel?" Gabriel said, "This is the Kauthar which your Lord has kept for you." Then Gabriel ascended (with him) to the second Heaven and the angels asked the same questions as those on the first Heaven, i.e., "Who is it?" Gabriel replied, "Gabriel". They asked, "Who is accompanying you?" He said, "Muhammad." They asked, "Has he been sent for?" He said, "Yes." Then they said, "He is welcomed.'' Then he (Gabriel) ascended with the Prophet to the third Heaven, and the angels said the same as the angels of the first and the second Heavens had said.

Then he ascended with him to the fourth Heaven and they said the same; and then he ascended with him to the fifth Heaven and they said the same; and then he ascended with him to the sixth Heaven and they said the same; then he ascended with him to the seventh Heaven and they said the same. On each Heaven there were prophets whose names he had mentioned and of whom I remember Idris on the second Heaven, Aaron on the fourth Heavens another prophet whose name I don't remember, on the fifth Heaven, Abraham on the sixth Heaven, and Moses on the seventh Heaven because of his privilege of talking to Allah directly. Moses said (to Allah), "O Lord! I thought that none would be raised up above me."

But Gabriel ascended with him (the Prophet) for a distance above that, the distance of which only Allah knows, till he reached the Lote Tree (beyond which none may pass) and then the Irresistible, the Lord of Honor and Majesty approached and came closer till he (Gabriel) was about two bow lengths or (even) nearer. (It is said that it was Gabriel who approached and came closer to the Prophet. (Fate Al-Bari Page 263, 264, Vol. 17). Among the things which Allah revealed to him then, was: "Fifty prayers were enjoined on his followers in a day and a night."

Then the Prophet descended till he met Moses, and then Moses stopped him and asked, "O Muhammad ! What did your Lord en join upon you?" The Prophet replied," He enjoined upon me to perform fifty prayers in a day and a night." Moses said, "Your followers cannot do that; Go back so that your Lord may reduce it for you and for them." So the Prophet turned to Gabriel as if he wanted to consult him about that issue. Gabriel told him of his opinion, saying, "Yes, if you wish." So Gabriel ascended with him to the Irresistible and said while he was in his place, "O Lord, please lighten our burden as my followers cannot do that." So Allah deducted for him ten prayers where upon he returned to Moses who stopped him again and kept on sending him back to his Lord till the enjoined prayers were reduced to only five prayers.

Then Moses stopped him when the prayers had been reduced to five and said, "O Muhammad! By Allah, I tried to persuade my nation, Bani Israel to do less than this, but they could not do it and gave it up. However, your followers are weaker in body, heart, sight and hearing, so return to your Lord so that He may lighten your burden."

The Prophet turned towards Gabriel for advice and Gabriel did not disapprove of that. So he ascended with him for the fifth time. The Prophet said, "O Lord, my followers are weak in their bodies, hearts, hearing and constitution, so lighten our burden." On that the Irresistible said, "O Muhammad!" the Prophet replied, "Labbaik and Sa'daik." Allah said, "The Word that comes from Me does not change, so it will be as I enjoined on you in the Mother of the Book." Allah added, "Every good deed will be rewarded as ten times so it is fifty (prayers) in the Mother of the Book (in reward) but you are to perform only five (in practice)."

The Prophet returned to Moses who asked, "What have you done?" He said, "He has lightened our burden: He has given us for every good deed a tenfold reward." Moses said, "By Allah! I tried to make Bani Israel observe less than that, but they gave it up. So go back to your Lord that He may lighten your burden further." Allah's Apostle said, "O Moses! By Allah, I feel shy of returning too many times to my Lord." On that Gabriel said, "Descend in Allah's Name." The Prophet then woke while he was in the Sacred Mosque (at Mecca).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.609]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 609

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "Allah will say to the people of Paradise, "O the people of Paradise!" They will say, 'Labbaik, O our Lord, and Sa'daik, and all the good is in Your Hands!' Allah will say, "Are you satisfied?' They will say, 'Why shouldn't we be satisfied, O our Lord as You have given us what You have not given to any of Your created beings?' He will say, 'Shall I not give you something better than that?' They will say, 'O our Lord! What else could be better than that?' He will say, 'I bestow My Pleasure on you and will never be angry with you after that.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.610]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 610

Narrated Abu Huraira:

Once the Prophet was preaching while a bedouin was sitting there. The Prophet said, "A man from among the people of Paradise will request Allah to allow him to cultivate the land Allah will say to him, 'Haven't you got whatever you desire?' He will reply, 'yes, but I like to cultivate the land (Allah will permit him and) he will sow the seeds, and within seconds the plants will grow and ripen and (the yield) will be harvested and piled in heaps like mountains. On that Allah will say (to him), "Take, here you are, O son of Adam, for nothing satisfies you.' "On that the bedouin said, "O Allah's Apostle! Such man must be either from Quraish or from Ansar, for they are farmers while we are not." On that Allah's Apostle smiled .


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.611]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 611

Narrated 'Abdullah:

I asked Allah's Apostle "What is the biggest sin in the sight of Allah?" He said, "To set up rivals unto Allah though He alone created you." I said, "In fact, that is a tremendous sin," and added, "What next?" He said, "To kill your son being afraid that he may share your food with you." I further asked, "What next?" He said, "To commit illegal sexual intercourse with the wife of your neighbor."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.612]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 612

Narrated 'Abdullah:

Two person of Bani Thaqif and one from Quarish (or two persons from Quraish and one from Bani Thaqif) who had fat bellies but little wisdom, met near the Ka'ba. One of them said, "Did you see that Allah hears what we say? " The other said, "He hears us if we speak aloud, but He does not hear if we speak in stealthy quietness (softly)." The third fellow said, "If He hears when we speak aloud, then He surely hears us if we speak in stealthy quietness (softly)." So Allah revealed the Verse:--

'And you have not been screening against yourselves, lest your ears, and your eyes and your skins should testify against you..." (41.22)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.613]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 613

Narrated 'Ikrima:

Ibn 'Abbas said, "How can you ask the people of the Scriptures about their Books while you have Allah's Book (the Qur'an) which is the most recent of the Books revealed by Allah, and you read it in its pure undistorted form?"


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.614]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 614

Narrated 'Ubaidullah bin 'Abdullah:

'Abdullah bin 'Abbas said, "O the group of Muslims! How can you ask the people of the Scriptures about anything while your Book which Allah has revealed to your Prophet contains the most recent news from Allah and is pure and not distorted? Allah has told you that the people of the Scriptures have changed some of Allah's Books and distorted it and wrote something with their own hands and said, 'This is from Allah, so as to have a minor gain for it. Won't the knowledge that has come to you stop you from asking them? No, by Allah, we have never seen a man from them asking you about that (the Book Al-Qur'an ) which has been revealed to you.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.615]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 615

Narrated Musa bin Abi 'Aisha:

Sa'id bin Jubair reported from Ibn 'Abbas (regarding the explanation of the Verse: 'Do not move your tongue concerning (the Qur'an) to make haste therewith) . He said, "The Prophet used to undergo great difficulty in receiving the Divine Inspiration and used to move his lips.' Ibn 'Abbas said (to Sa'id), "I move them (my lips) as Allah's Apostle used to move his lips." And Said said (to me), "I move my lips as I saw Ibn 'Abbas moving his lips," and then he moved his lips. So Allah revealed:--

'(O Muhammad!) Do not move your tongue concerning (the Qur'an) to make haste therewith. It is for Us to collect it and give you (O Muhammad) the ability to recite it. (i.e., to collect it in your chest and then you recite it).' (75.16-17) But when We have recited it, to you (O Muhammad through Gabriel) then follow you its recital.' (75.18) This means, "You should listen to it and keep quiet and then it is upon Us to make you recite it."

The narrator added, "So Allah's Apostle used to listen whenever Gabriel came to him, and when Gabriel left, the Prophet would recite the Qur'an as Gabriel had recited it to him."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.616]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 616

Narrated Ibn 'Abbas:

regarding the explanation of the Verse:-- '(O Muhammad!) Neither say your prayer aloud, nor say it in a low tone.' (17.110) This Verse was revealed while Allah's Apostle was hiding himself at Mecca. At that time, when he led his companions in prayer, he used to raise his voice while reciting the Qur'an; and if the pagans heard him, they would abuse the Qur'an, its Revealer, and the one who brought it. So Allah said to His Prophet: "Neither say your prayer aloud. i.e., your recitation (of Qur'an) lest the pagans should hear (it) and abuse the Quran" nor say it in a low tone, "lest your voice should fail to reach your companions, "but follow a way between." (17.110)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.617]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 617

Narrated 'Aisha:

The Verse:-- '(O Muhammad!) Neither say your prayer aloud nor say it in a low tone.' (17.110) was revealed in connection with the invocations.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.618]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 618

Narrated Abu Salama:

Abu Huraira said, "Allah's Apostle said, 'Whoever does not recite Qur'an in a nice voice is not from us,' and others said extra," (that means) to recite it aloud."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.619]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 619

Narrated Abu Huraira:

Allah's Apostle said, "Not to wish to be the like of except the like of two men: a man whom Allah has given the Qur'an and he recites it during the hours of the night and the hours of the day, in which case one may say, "If I were given the same as this man has been given, I would do the same as he is doing.' The other is a man whom Allah has given wealth and he spends it in the right way, in which case one may say, 'If I were given the same as he has been given, I would do the same as he is doing."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.620]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 620

Narrated Salim's father:

The Prophet said, "Not to wish to be the like of except the like of two (persons): a man whom Allah has given the knowledge of the Quran and he recites it during the hours of the night and the hours of the day; and a man whom Allah has given wealth and he spends it (in Allah's Cause) during the hours of the night and during the hours of the day."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.621]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 621

Narrated Al-Mughira:

Our Prophet has informed us our Lord's Message that whoever of us is martyred, will go to Paradise.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.622]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 622

Narrated 'Aisha:

Whoever tells you that the Prophet concealed something of the Divine Inspiration, do not believe him, for Allah said: 'O Apostle Muhammad! Proclaim (the Message) which has been sent down to you from your Lord, and if you do it not, then you have not conveyed His Message.' (5.67)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.623]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 623

Narrated 'Abdullah:

A man said, "O Allah's Apostle! Which sin is the biggest in Allah's Sight?" The Prophet said, "To set up rivals unto Allah though He Alone created you." That man said, "What is next?" The Prophet said, "To kill your son lest he should share your food with you.'' The man said, "What is next?" The Prophet said, "To commit illegal sexual intercourse with the wife of your neighbor." Then Allah revealed in confirmation of that: "And those who invoke not with Allah any other god, nor kill such life as Allah has made sacred except for just cause, nor commit illegal sexual intercourse and whoever does this shall receive the punishment..... (25.68)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.624]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 624

Narrated Ibn 'Umar:

Allah's Apostle said, "Your stay (in this world) in comparison to the stay of the nations preceding you, is like the period between 'Asr prayer and the sun set (in comparison to a whole day). The people of the Torah were given the Torah and they acted on it till midday and then they were unable to carry on. And they were given (a reward equal to) one Qirat each. Then the people of the Gospel were given the Gospel and they acted on it till 'Asr Prayer and then they were unable to carry on, so they were given la reward equal to) one Qirat each. Then you were given the Qur'an and you acted on it till sunset, therefore you were given (a reward equal to) two Qirats each. On that, the people of the Scriptures said, 'These people (Muslims) did less work than we but they took a bigger reward.' Allah said (to them). 'Have I done any oppression to you as regards your rights?' They said, "No." Then Allah said, 'That is My Blessing which I grant to whomsoever I will.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.625]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 625

Narrated Ibn Mas'ud:

A man asked the Prophet "What deeds are the best?" The Prophet said: (1) To perform the (daily compulsory) prayers at their (early) stated fixed times, (2) To be good and dutiful to one's own parents. (3) and to participate in Jihad in Allah's Cause."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.626]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 626

Narrated Al-Hasan:

'Amr bin Taghlib said, "Some property was given to the Prophet and he gave it to some people and withheld it from some others. Then he came to know that they (the latter) were dissatisfied. So the Prophet said, 'I give to one man and leave (do not give) another, and the one to whom I do not give is dearer to me than the one to whom I give. I give to some people because of the impatience and discontent present in their hearts, and leave other people because of the content and goodness Allah has bestowed on them, and one of them is 'Amr bin Taghlib." 'Amr bin Taghlib said, "The sentence which Allah's Apostle said in my favor is dearer to me than the possession of nice red camels."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.627]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 627

Narrated Anas:

The Prophet said, "My Lord says, 'If My slave comes nearer to me for a span, I go nearer to him for a cubit; and if he comes nearer to Me for a cubit, I go nearer to him for the span of outstretched arms; and if he comes to Me walking, I go to him running.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.628]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 628

Narrated Abu Huraira:

Perhaps the Prophet mentioned the following (as Allah's Saying): "If My slave comes nearer to Me for a span, I go nearer to him for a cubit; and if he comes nearer to Me for a cubit; I go nearer to him for the span of outstretched arms. (See Hadith No. 502)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.629]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 629

Narrated Abu Huraira:

The Prophet said that your Lord said, "Every (sinful) deed can be expiated; and the fast is for Me, so I will give the reward for it; and the smell which comes out of the mouth of a fasting person, is better in Allah's Sight than the smell of musk." (See Hadith No. 584)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.630]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 630

Narrated Ibn 'Abbas:

The Prophet said that his Lord said: "It does not befit a slave that he should say that he is better than Jonah (Yunus) bin Matta.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.631]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 631

Narrated Shu'ba:

Mu'awiya bin Qurra reported that 'Abdullah bin Al-Maghaffal Al-Muzani said, "I saw Allah's Apostle on the day of the Conquest of Mecca, riding his she-camel and reciting Surat-al-Fath (48) or part of Surat-al-Fath. He recited it in a vibrating and pleasant voice. Then Mu'awiya recited as 'Abdullah bin Mughaffal had done and said, "Were I not afraid that the people would crowd around me, I would surely recite in a vibrating pleasant voice as Ibn Mughaffal did, imitating the Prophet." I asked Muawiya, "How did he recite in that tone?" He said thrice, "A, A , A."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.632]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 632

Narrated Abu Huraira:

The people of the Scripture used to read the Torah in Hebrew and explain it to the Muslims in Arabic. Then Allah's Apostle said, "Do not believe the people of the Scripture, and do not disbelieve them, but say, 'We believe in Allah and whatever has been revealed...' (3.84)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.633]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 633

Narrated Ibn 'Umar:

A Jew and Jewess were brought to the Prophet on a charge of committing an illegal sexual intercourse. The Prophet asked the Jews, "What do you (usually) do with them?" They said, "We blacken their faces and disgrace them." He said, "Bring here the Torah and recite it, if you are truthful." They (fetched it and) came and asked a one-eyed man to recite. He went on reciting till he reached a portion on which he put his hand. The Prophet said, "Lift up your hand!" He lifted his hand up and behold, there appeared the verse of Ar-Rajm (stoning of the adulterers to death). Then he said, "O Muhammad! They should be stoned to death but we conceal this Divine Law among ourselves." Then the Prophet ordered that the two sinners be stoned to death and, and they were stoned to death, and I saw the man protecting the woman from the stones. (See Hadith No. 809, Vol. 8)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.634]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 634

Narrated Abu Huraira:

that he heard the Prophet saying, "Allah does not listen to anything as He listens to the recitation of the Quran by a Prophet who recites it in attractive audible sweet sounding voice."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.635]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 635

Narrated 'Aisha:

(when the slanderers said what they said about her): I went to my bed knowing at that time that I was innocent and that Allah would reveal my innocence, but by Allah, I never thought that Allah would reveal in my favor a revelation which would be recited, for I considered myself too unimportant to be talked about by Allah in the Divine Revelation that was to be recited. So Allah revealed the ten Verses (of Surat-an-Nur). 'Those who brought a false charge........' (24.11-20)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.636]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 636

Narrated Al-Bara':

I heard the Prophet reciting Surat at-Tin waz Zaitun (By the Fig and the Olive) in the 'Isha' prayer and I have never heard anybody with a better voice or recitation than his.


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.637]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 637

Narrated Ibn 'Abbas:

The Prophet was hiding himself in Mecca and used to recite the (Qur'an) in a loud voice. When the pagans heard him they would abuse the Qur'an and the one who brought it, so Allah said to His Prophet: 'Neither say your prayer aloud, nor say it in a low tone.' (17.110)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.638]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 638

Narrated 'Abdullah bin 'Abdur-Rahman:

that Abu Sa'id Al-Khudri said to him, "I see that you like sheep and the desert, so when you are looking after your sheep or when you are in the desert and want to pronounce the Adhan, raise your voice, for no Jinn, human being or any other things hear the Mu'adh-dhin's voice but will be a witness for him on the Day of Resurrection." Abu Sa'id added, "I heard this from Allah's Apostle."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.639]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 639

Narrated 'Aisha:

The Prophet used to recite the Quran with his head in my lap while I used to be in my periods (having menses).


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.640]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 640

Narrated 'Umar bin Al-Khattab:

I heard Hisham bin Hakim reciting Surat-al-Furqan during the lifetime of Allah's Apostle, I listened to his recitation and noticed that he was reciting in a way that Allah's Apostle had not taught me. I was about to jump over him while He was still in prayer, but I waited patiently and when he finished his prayer, I put my sheet round his neck (and pulled him) and said, "Who has taught you this Sura which I have heard you reciting?" Hisham said, "Allah's Apostle taught it to me." I said, "You are telling a lie, for he taught it to me in a way different from the way you have recited it!" Then I started leading (dragged) him to Allah's Apostle and said (to the Prophet), " I have heard this man reciting Surat-al-Furqan in a way that you have not taught me." The Prophet said: "(O 'Umar) release him! Recite, O Hisham." Hisham recited in the way I heard him reciting. Allah's Apostle said, "It was revealed like this." Then Allah's Apostle said, "Recite, O 'Umar!" I recited in the way he had taught me, whereupon he said, "It was revealed like this," and added, "The Quran has been revealed to be recited in seven different ways, so recite of it whichever is easy for you ." (See Hadith No. 514, Vol. 6)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.641]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 641

Narrated 'Imran:

I said, "O Allah's Apostle! Why should a doer (people) try to do good deeds?' The Prophet said, "Everybody will find easy to do such deeds as will lead him to his destined place for which he has been created.'


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.642]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 642

Narrated 'Ali:

While the Prophet was in a funeral procession, he took a stick and started scraping the earth with it and said, "There is none of you but has his place assigned either in Hell or in Paradise." They (the people) said, "Shall we not depend upon that (and give up doing any deeds)?' He said, " Carry on doing (good deeds) for everybody will find it easy to do such deeds as will lead him to his destined place for which he has been created ." (And then the Prophet recited the Verse):-- 'As for him who gives (in charity) and keeps his duty to Allah...' (92.5)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.643]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 643

Narrated Abu Huraira:

I heard Allah's Apostle saying, "Before Allah created the creations, He wrote a Book (wherein He has written): My Mercy has preceded my Anger." and that (Book) is written with Him over the Throne."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.644]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 644

Narrated Zahdam:

There were good relations and brotherhood between this tribe of Jurm and the Ash'ariyyin. Once, while we were sitting with Abu Musa Al-Ash'ari, there was brought to him a meal which contained chicken meat, and there was sitting beside him, a man from the tribe of Bani Taimul-lah who looked like one of the Mawali. Abu Musa invited the man to eat but the man said, "I have seen chicken eating some dirty things, and I have taken an oath not to eat chicken." Abu Musa said to him, "Come along, let me tell you something in this regard. Once I went to the Prophet with a few men from Ash'ariyyin and we asked him for mounts. The Prophet said, By Allah, I will not mount you on anything; besides I do not have anything to mount you on.' Then a few camels from the war booty were brought to the Prophet, and he asked about us, saying, 'Where are the group of Ash'ariyyin?' So he ordered for five fat camels to be given to us and then we set out. We said, 'What have we done? Allah's Apostle took an oath that he would not give us anything to ride and that he had nothing for us to ride, yet he provided us with mounts. We made Allah's Apostle forget his oath! By Allah, we will never be successful.' So we returned to him and reminded him of his oath. He said, 'I have not provided you with the mount, but Allah has done so. By Allah, I may take an oath to do something, but on finding something else which is better, I do that which is better and make the expiation for my oath.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.645]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 645

Narrated Ibn 'Abbas:

The delegates of 'Abdul Qais came to Allah's Apostle and said, "The pagans of the tribe of Mudar intervene between you and us therefore we cannot come to you except in the Holy months. So please order us to do something good (Religious deeds) by which we may enter Paradise (by acting on them) and we may inform our people whom we have left behind to observe it." The Prophet said, "I order you to do four things and forbid you from four things: I order you to believe in Allah. Do you know what is meant by belief in Allah? It is to testify that none has the right to be worshipped except Allah, to offer prayers perfectly, to give Zakat, and to give Al-Khumus (one-fifth of the war booty) (in Allah's Cause). And I forbid you four things, (i.e., Do not drink alcoholic drinks) Ad-Dubba, An-Naqir, (pitched water skins), Az-Zuruf, Al-Muzaffat and Al--Hantam (names of utensils used for the preparation of alcoholic drinks)." (See Hadith No. 50, Vol. 1)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.646]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 646

Narrated Aisha:

Allah's Apostle said, "The painter of these pictures will be punished on the Day of Resurrection, and it will be said to them, Make alive what you have created.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.647]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 647

Narrated Ibn 'Umar:

The Prophet said, "The painters of these pictures will be punished on the Day of Resurrection, and it will be said to them, 'Make alive what you have created."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.648]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 648

Narrated Abu Huraira:

I heard the Prophet saying, "Allah said, 'Who are most unjust than those who try to create something like My creation? I challenge them to create even a smallest ant, a wheat grain or a barley grain.' "


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.649]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 649

Narrated Abu Musa:

The Prophet said, 'The example of a believer who recites the Qur'an is that of a citron (a citrus fruit) which is good in taste and good in smell. And the believer who does not recite the Quran is like a date which has a good taste but no smell. And the example of an impious person who recites the Qur'an is that of Ar-Rihana (an aromatic plant) which smells good but is bitter in taste. And the example of an impious person who does not recite the Quran is that of a colocynth which is bitter in taste and has no smell."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.650]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 650

Narrated 'Aisha:

Some people asked the Prophet regarding the soothsayers. He said, "They are nothing." They said, "O Allah's Apostle! Some of their talks come true." The Prophet said, "That word which happens to be true is what a Jinn snatches away by stealth (from the Heaven) and pours it in the ears of his friend (the foreteller) with a sound like the cackling of a hen. The soothsayers then mix with that word, one hundred lies."


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.651]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 651

Narrated Abu Sa'id Al-Khudri:

The Prophet said, "There will emerge from the East some people who will recite the Qur'an but it will not exceed their throats and who will go out of (renounce) the religion (Islam) as an arrow passes through the game, and they will never come back to it unless the arrow, comes back to the middle of the bow (by itself) (i.e., impossible). The people asked, "What will their signs be?" He said, "Their sign will be the habit of shaving (of their beards). (Fateh Al-Bari, Page 322, Vol. 17th)


Bukhari :: Oneness, Uniqueness of Allah (Tawheed) :: [9.93.652]

Oneness, Uniqueness of Allah (Tawheed)

Bukhari :: Book 9 :: Volume 93 :: Hadith 652

Narrated Abu Huraira:

The Prophet said, "(There are) two words which are dear to the Beneficent (Allah) and very light (easy) for the tongue (to say), but very heavy in weight in the balance. They are: 'Subhan Allah wa-bi hamdihi' and 'Subhan Allah Al-'Azim." (See Hadith No. 673, Vol. 8).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.1]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 1

It is narrated on the authority of Yahya b. Ya'mur that the first man who discussed about Qadr (Divine Decree) in Basra was Ma'bad al-Juhani. I along with Humaid b. 'Abdur-Rahman Himyari set out for prilgrimage or for 'Umrah and said: Should it so happen that we come into contact with one of the Companions of the Messenger of Allah (peace be upon him) we shall ask him a bout what is talked about Taqdir (Division Decree). Accidentally we came across Abdullah ibn Umar ibn al-Khattab, while he was entering the mosque. My companion and I surrounded him. One of us (stood) on his right and the other stood on his left. I expected that my companion would authorize me to speak. I therefore said: Abu Abdur Rahman! there have appeared some people in our land who recite the Holy Qur'an and pursue knowledge. And then after talking about their affairs, added: They (such people) claim that there is no such thing as Divine Decree and events are not predestined. He (Abdullah ibn Umar) said: When you happen to meet such people tell them that I have nothing to do with them and they have nothing to do with me. And verily they are in no way responsible for my (belief). Abdullah ibn Umar swore by Him (the Lord) (and said): If any one of them (who does not believe in the Divine Decree) had with him gold equal to the bulk of (the mountain) Uhud and then, it (in the way of Allah), Allah would not accept it unless he affirmed his faith in Divine Decree. He further said: My father, Umar ibn al-Khattab, told me: One day we were sitting in the company of Allah's Apostle (peace be upon him) when there appeared before us a man dressed in pure white clothes, his hair extraordinarily black. There were no signs of travel on him. None amongst us recognized him. At last he sat with the Apostle (peace be upon him) He knelt before him placed his palms on his thighs and said: Muhammad, inform me about al-Islam. The Messenger of Allah (peace be upon him) said: Al-Islam implies that you testify that there is no god but Allah and that Muhammad is the messenger of Allah, and you establish prayer, pay Zakat, observe the fast of Ramadan, and perform pilgrimage to the (House) if you are solvent enough (to bear the expense of) the journey. He (the inquirer) said: You have told the truth. He (Umar ibn al-Khattab) said: It amazed us that he would put the question and then he would himself verify the truth. He (the inquirer) said: Inform me about Iman (faith). He (the Holy Prophet) replied: That you affirm your faith in Allah, in His angels, in His Books, in His Apostles, in the Day of Judgment, and you affirm your faith in the Divine Decree about good and evil. He (the inquirer) said: You have told the truth. He (the inquirer) again said: Inform me about al-Ihsan (performance of good deeds). He (the Holy Prophet) said: That you worship Allah as if you are seeing Him, for though you don't see Him, He, verily, sees you. He (the enquirer) again said: Inform me about the hour (of the Doom). He (the Holy Prophet) remarked: One who is asked knows no more than the one who is inquiring (about it). He (the inquirer) said: Tell me some of its indications. He (the Holy Prophet) said: That the slave-girl will give birth to her mistress and master, that you will find barefooted, destitute goat-herds vying with one another in the construction of magnificent buildings. He (the narrator, Umar ibn al-Khattab) said: Then he (the inquirer) went on his way but I stayed with him (the Holy Prophet) for a long while. He then, said to me: Umar, do you know who this inquirer was? I replied: Allah and His Apostle knows best. He (the Holy Prophet) remarked: He was Gabriel (the angel). He came to you in order to instruct you in matters of religion.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.2]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 2

It is narrated on the authority of Yahya b. Ya'mur that when Ma'bad discussed the problem pertaining to Divine Decree, we refuted that. He (the narrator) said: I and Humaid b. Abdur-Rahman Himyari argued. And they carried on the conversation about the purport of the hadith related by Kahmas and its chain of transmission too, and there is some variation of words.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.3]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 3

It is narrated on the authority of Yahya b. Ya'mur and Humaid b. 'Abdur-Rahman that they said: We met Abdullah b. 'Umar and we discussed about the Divine Decree, and what they talked about it and he narrated the hadith that has been transmitted by 'Umar (may Allah be pleased with him) from the Apostle (may peace be upon him). There is a slight variation in that.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.4]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 4

Abu Huraira reported: One day the Messenger of Allah (may peace be upon him) appeared before the public that a man came to him and said: Prophet of Allah, (tell me) what is Iman. Upon this he (the Holy Prophet) replied: That you affirm your faith in Allah, His angels, His Books, His meeting, His Messengers and that you affirm your faith in the Resurrection hereafter. He (again) said: Messenger of Allah, (tell me) what does al-Islam signify. He (the Holy Prophet) replied: Al-Islam signifies that you worship Allah and do not associate anything with Him and you establish obligatory prayer and you pay the obligatory poor-rate (Zakat) and you observe the fast of Ramadan. He (the inquirer) again said: Messenger of Allah, what does al-Ihsan imply? He (the Holy Prophet) replied: That you worship Allah as if you are seeing Him, and in case you fail to see Him, then observe prayer (with this idea in your mind) that (at least) He is seeing you. He (the inquirer ) again said: Messenger of Allah, when would there be the hour (of Doom)? He (the Holy Prophet) replied: The one who is asked about it is no better informed than the inquirer. I, however, narrate some of its signs (and these are): when the slave-girl will give birth to he master, when the naked, barefooted would become the chiefs of the people - these are some of the signs of (Doom). (Moreover) when the shepherds of the black (camels) would exult themselves in buildings, this is one of the signs of (Doom). (Doom) is one of the five (happenings wrapped in the unseen) which no one knows but Allah. Then he (the Messenger of Allah) recited (the verse):" Verily Allah! with Him alone is the knowledge of the hour and He it is Who sends (down the rain) and knows that which is in the wombs and no person knows whatsoever he shall earn tomorrow, and a person knows not in whatsoever land he shall die. Verily Allah is Knowing, Aware. He (the narrator, Abu Huraira) said: Then the person turned back and went away. The Messenger of Allah (may peace be upon him) said: Bring that man back to me. They (the Companions of the Holy Prophet present there) went to bring him back, but they saw nothing there. Upon this the Messenger of Allah remarked: he was Gabriel, who came to teach the people their religion.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.5]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 5

This hadith is narrated to us on the authority of Muhammad b. 'Abdullah b. Numair, on the authority of Muhammad b. Bishr, on the authority of Abd Hayyan al-Taymi with the exception that in this narration (instead of the words (Iza Waladat al'amah rabbaha), the words are (Iza Waladat al'amah Ba'laha), i, e, when slave-girl gives birth to her master.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.6]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 6

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Ask me (about matters pertaining to religion), but they (the Companions of the Holy Prophet) were too much overawed out of profound respect for him to ask him (anything). In the meanwhile a man came there, and sat near his knees and said: Messenger of Allah, what al-lslam is? -to which he (the Holy Prophet) replied: You must not associate anything with Allah, and establish prayer, pay the poor-rate (Zakat) and observe (the fasts) of Ramadan. He said: You (have) told the truth. He (again) said: Messenger of Allah, what al-Iman (the faith) is? He (the Holy Prophet) said: That you affirm your faith in Allah, His angels, His Books, His meeting, His Apostles, and that you believe in Resurrection and that you believe in Qadr (Divine Decree) in all its entirety, He (the inquirer) said: You (have) told the truth. He (again) said: Messenger of Allah, what al-Ihsan is? Upon this he (the Holy Prophet) said: (Al-Ihsan implies) that you fear Allah as if you are seeing Him, and though you see Him not, verily He is seeing you. He (the inquirer) said: You (have) told the truth. He (the inquirer) said: When there would be the hour (of Doom)? (Upon this) he (the HolyProphet said: The one who is being asked about it is no better informed than the inquirer himself. I, however, narrate some of its signs (and these are): when you see a slave (woman) giving birth to her master - that is one of the signs of (Doom) ; when you see barefooted, naked, deaf and dumb (ignorant and foolish persons) as the rulers of the earth - that is one of the signs of the Doom. And when you see the shepherds of black camels exult in buildings - that is one of the signs of Doom. The (Doom) is one of the five things (wrapped) in the unseen. No one knows them except Allah. Then (the Holy Prophet) recited (the folowing verse):" Verily Allah! with Him alone is the knowledge of the hour and He it is Who sends down the rain and knows that which is in the wombs and no person knows whatsoever he shall earn on morrow and a person knows not in whatsoever land he shall die. Verily Allah is Knowing, Aware. He (the narrator, Abu Huraira) said: Then the person stood up an (made his way). The Messenger of Allah (may peace be upon him) said: Bring him back to me. He was searched for, but they (the Companions of the Holy Prophet) could not find him. The Messenger of Allah (may peace be upon him) thereupon said: He was Gabriel and he wanted to teach you (things pertaining to religion) when you did not ask (them yourselves).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.7]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 7

It is reported on the authority of Talha b. 'Ubaidullah that a person with dishevelled hair, one of the people of Nejd, came to the Messenger of Allah (may peace be upon him). We heard the humming of his voice but could not fully discern what he had been saying, till he came nigh to the Messenger of Allah (may peace be upon him). It was then (disclosed to us) that he was asking questions pertaining to Islam. The Messenger of Allah (may peace be upon him) said: Five prayers during the day and the night. (Upon this he said: Am I obliged to say any other (prayer) besides these? He (the Holy Prophet, ) said: No, but whatever you observe voluntarily, out of your own free will, and the fasts of Ramadan. The inquirer said: Am I obliged to do anything else besides this? He (the Holy Prophet) said: No, but whatever you do out of your own free will. And the Messenger of Allah told him about the Zakat (poor-rate). The inquirer said: Am I obliged to pay anything else besides this? He (the Holy Prophet) said: No, but whatever you pay voluntarily out of your own free will. The man turned back and was saying: I would neither make any addition to this, nor will decrease anything out of it. The Prophet remarked: He is successful, if he is true to what he affirms.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.8]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 8

Another hadith, the like of which has been narrated by Malik (b. Anas) (and mentioned above) is also reported by Talha b. 'Ubaidullah, with the only variation that the Holy Prophet remarked: By his father, he shall succeed if he were true (to what he professed), or: By his father, he would enter heaven if he were true (to what he professed).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.9]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 9

It is reported on the authority of Anas b. Malik that he said: We were forbidden that we should ask anything (without the genuine need) from the Holy Prophet. It, therefore, pleased us that an intelligent person from the dwellers of the desert should come and asked him (the Holy Prophet) and we should listen to it. A man from the dwellers of the desert came (to the Holy Prophet) and said: Muhammad, your messenger came to us and told us your assertion that verily Allah had sent you (as a prophet). He (the Holy Prophet) remarked: He told the truth. He (the bedouin) said: Who created the heaven? He (the Holy Prophet) replied: Allah. He (the bedouin again) said: Who created the earth? He (the Holy Prophet) replied: Allah. He (the bedouin again) said: Who raised these mountains and who created in them whatever is created there? He (the Holy Prophet) replied: Allah. Upon this he (the bedouin) remarked: By Him Who created the heaven and created the earth and raised mountains thereupon, has Allah (in fact) sent you? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger also told us that five prayers (had been made) obligatory for us during the day and the night. He (the Holy Prophet) remarked: He told you the truth. He (the bedouin) said: By Him Who sent you, is it Allah Who ordered you about this (i. e. prayers)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger told us that Zakat had been made obligatory in our riches. He (the Holy Prophet) said. He has told the truth. He (the bedouin) said: By Him Who sent you (as a prophet), is it Allah Who ordered you about it (Zakat)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger told us that it had been made obligatory for us to fast every year during the month of Ramadan. He (the Holy Prophet) said: He has told the truth. He (the bedouin) said: By Him Who sent you (as a prophet), is it Allah Who ordered you about it (the fasts of Ramadan)? He (the Holy Prophet) said: Yes. He (the bedouin) said: Your messenger also told us that pilgrimage (Hajj) to the House (of Ka'bah) had been made obligatory for him who is able to undertake the journey to it. He (the Holy Prophet) said: Yes. The narrator said that he (the bedouin) set off (at the conclusion of this answer, but at the time of his departure) remarked: 'By Him Who sent you with the Truth, I would neither make any addition to them nor would I diminish anything out of them. Upon this the Holy Prophet remarked: If he were true (to what he said) he must enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.10]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 10

It is narrated on the authority of Thabit that Anas said: We were forbidden in the Holy Qur'an that we should ask about anything from the Messenger of Allah (may peace be upon him) and then Anas reported the hadith in similar words.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.11]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 11

It is narrated on the authority of Abu Ayyub Ansari that once during the journey of the Holy Prophet (may peace of Allah be upon him) a bedouin appeared before him and caught hold of the nosestring of his she-camel and then said, Messenger of Allah (or Muhammad), inform me about that which takes me near to Paradise and draws me away from the Fire (of Hell). He (the narrator) said: The Prophet (may peace be upon him) stopped for a while and cast a glance upon his companions and then said: He was afforded a good opportunity (or he had been guided well). He (the Holy Prophet) addressing the bedouin said: (Repeat) whatever you have uttered. He (the bedouin) repeated that. Upon this the Apostle (may peace be upon him) remarked: The deed which can draw you near to Paradise and take you away from Hell is, that you worship Allah and associate none with Him, and you establish prayer and pay Zakat, and do good to your kin. After having uttered these words, the Holy Prophet asked the bedouin to release the nosestring of his she-camel.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.12]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 12

This hadith is transmitted by Muhammad b. Hatim on the authority of Abu Ayyub Ansari.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.13]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 13

It is narrated on the authority of Abu Ayyub that a man came to the Prophet (may peace be upon him) and said: Direct me to a deed which draws me near to Paradise and takes me away from the Fire (of Hell). Upon this he (the Holy Prophet) said: You worship Allah and never associate anything with Him, establish prayer, and pay Zakat, and do good to your kin. When he turned his back, the Messenger of Allah (may peace be upon him) remarked: If he adheres to what he has been ordered to do, he would enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.14]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 14

It is reported on the authority of Abu Huraira that a bedouin came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, direct me to a deed by which I may be entitled to enter Paradise. Upon this he (the Holy Prophet) remarked: You worship Allah and never associate anything with Him, establish the obligatory prayer, and pay the Zakat which is incumbent upon you, and observe the fast of Ramadan. He (the bedouin) said: By Him in Whose hand is my life, I will never add anything to it, nor will I diminish anything from it. When he (the bedouin) turned his back, the Prophet (may peace be upon him) said: He who is pleased to see a man from the dwellers of Paradise should catch a glimpse of him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.15]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 15

It is narrated on the authority of Jabir that Nu'man b. Qaufal came to the Holy Prophet (may peace be upon him) and said: Would I enter Paradise if I say the obligatory prayers and deny myself that which is forbidden and treat that as lawful what has been made permissible (by the Shari'ah)? The Holy Prophet (may peace be upon him) replied in the affirmative.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.16]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 16

A similar hadith is narrated on Jabir's authority in which the following words are added: I will do nothing more.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.17]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 17

It is narrated on the authority of Jabir that a man once said to the Messenger of Allah (may peace be upon him): Shall I enter Paradise in case I say the obligatory prayers, observe the (fasts) of Ramadan and treat that as lawful which has been made permissible (by the Shari'ah) and deny myself that what is forbidden, and make no addition to it? He (the Holy Prophet) replied in the affirmative. He (the inquirer) said: By Allah, I would add nothing to it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.18]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 18

It is narrated on the authority of ('Abdullah) son of Umar (may Allah be pleased with them) that the Holy Prophet (may peace of Allah be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), i. e. the oneness of Allah, the establishment of prayer, payment of Zakat, the, fast of Ramadan, Pilgrimage (to Mecca).

A person said (to 'Abdullah b. Umar the narrator): Which of the two precedes the other-Pilgrimage or the fasts of Rarnadan? Upon this he (the narrator) replied: No (it is not the Pilgrimage first) but the fasts of Ramadan precede the Pilgrimage.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.19]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 19

It is narrated on the authority of ('Abdullah) son of 'Umar, that the Holy Prophet (may peace of Allah be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), i. e. Allah (alone) should be worshipped, and (all other gods) beside Him should be (categorically) denied. Establishment of prayer, the payment of Zakat, Pilgrimage to the House, and the fast of Ramadan (are the other obligatory acts besides the belief in the oneness of Allah and denial of all other gods).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.20]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 20

It is narrated on the authority of 'Abdullah son of 'Umar that the Messenger of Allah (may peace be upon him) said: (The superstructure of) al-Islam is raised on five (pillars), testifying (the fact) that there is no god but Allah, that Muhammad is His bondsman and messenger, and the establishment of prayer, payment of Zakat, Pilgrimage to the House (Ka'ba) and the fast of Ramadan.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.21]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 21

It is reported on the authority of Ta'us that a man said to 'Abdullah son of 'Umar (may Allah be pleased with him). Why don't you carry out a military expedition? Upon which he replied: I heard the messenger of Allah (may peace be upon him) say: Verily, al-Islam is founded on five (pillars): testifying the fact that there is no god but Allah, establishment of prayer, payment of Zakat, fast of Ramadan and Pilgrimage to the House.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.22]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 22

It is narrated on the authority of Ibn 'Abbas that a delegation of Abdul Qais came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, verily ours is a tribe of Rabi'a and there stand between you and us the unbelievers of Mudar and we find no freedom to come to you except in the sacred month. Direct us to an act which we should ourselves perform and invite those who live beside us. Upon this the Prophet remarked: I command you to do four things and prohibit you against four acts. (The four deeds which you are commanded to do are): Faith in Allah, and then he explained it for them and said: Testifying the fact. that there is no god but Allah, that Muhammad is the messenger of Allah, performance of prayer, payment of Zakat, that you pay Khums (one-fifth) of the booty fallen to your lot, and I prohibit you to use round gourd, wine jars, wooden pots or skins for wine. Khalaf b. Hisham has made this addition in his narration: Testifying the fact that there is no god but Allah, and then he with his finger pointed out the oneness of the Lord.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.23]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 23

Abu Jamra reported: I was an interpreter between Ibn Abbas and the people, that a woman happened to come there and asked about nabidh or the pitcher of wine. He replied: A delegation of the people of 'Abdul-Qais came to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) asked the delegation or the people (of the delegation about their identity). They replied that they belonged to the tribe of Rabi'a. He (the Holy Prophet) welcomed the people or the delegation which were neither humiliated nor put to shame. They (the members of the delegation) said: Messenger of Allah, we come to you from a far-off distance and there lives between you and us a tribe of the unbelievers of Mudar and, therefore, it is not possible for us to come to you except in the sacred months. Thus direct us to a clear command, about which we should inform people beside us and by which we may enter heaven. He (the Holy Prophet) replied: I command you to do four deeds and forbid you to do four (acts), and added: I direct you to affirm belief in Allah alone, and then asked them: Do you know what belief in Allah really implies? They said: Allah and His Messenger know best. The Prophet said: It implies testimony to the fact that there is no god but Allah, and that Muhammad is the messenger of Allah, establishment of prayer, payment of Zakat, fast of Ramadan, that you pay one-fifth of the booty (fallen to your lot) and I forbid you to use gourd, wine jar, or a receptacle for wine. Shu'ba sometimes narrated the word naqir (wooden pot) and sometimes narrated it as muqayyar. The Holy Prophet also said: Keep it in your mind and inform those who have been left behind.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.24]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 24

There is another hadith narrated on the authority of Ibn Abbas (the contents of which are similar to the one) narrated by Shu'ba in which the Holy Prophet (may peace be upon him) said: I forbid you to prepare nabidh in a gourd, hollowed block of wood, a varnished jar or receptacle. Ibn Mu'adh made this addition on the authority of his father that the Messenger of Allah said to Ashajj, of the tribe of 'Abdul-Qais: You possess two qualities which are liked by Allah: insight and deliberateness.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.25]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 25

It is reported on the authority of Qatada that one among the delegates of the 'Abdul-Qais tribe narrated this tradition to him. Sa'id said that Qatada had mentioned the name of Abu Nadra on the authority of Abu Sa'id Khudri who narrated this tradition: That people from the- tribe of 'Abdul-Qais came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, we belong to the tribe of Rabi'a and there live between you and us the unbelievers of the Mudar tribe and we find it impossible to come to you except in the sacred months; direct us to a deed which we must communicate to those who have been left behind us and by doing which we may enter heaven. Upon this the Messenger of Allah (may peace be upon him) said: I enjoin upon you four (things) and forbid you to do four (things): worship Allah and associate none with Him, establish prayer, pay Zakat, and observe the fast of Ramadan, and pay the fifth part out of the booty. And I prohibit you from four (things): dry gourds, green-coloured jars, hollowed stumps of palm-trees, and receptacles. They (the members of the delegation) said: Do you know what al-naqir is? He replied: Yes, it is a stump which you hollow out and in which you throw small dates. Sa'id said: He (the Holy Prophet) used the word tamar (dates). (The Holy Prophet then added): Then you sprinkle water over it and when its ebullition subsides, you drink it (and you are so intoxicated) that one amongst you, or one amongst them (the other members of your tribe, who were not present there) strikes his cousin with the sword. He (the narrator) said: There was a man amongst us who had sustained injury on this very account due to (intoxication), and he told that he tried to conceal it out of shame from the Messenger of Allah (may peace be upon him). I, however, inquired from the Messenger of Allah (it we discard those utensils which you have forbidden us to use), then what type of vessels should be used for drink? He (the Holy Prophet) replied: In the waterskin the mouths of which are tied (with a string). They (again) said: Prophet of Allah, our land abounds in rats and water-skins cannot remain preserved. The holy Prophet of Allah (may peace be upon him) said: (Drink in water-skins) even if these arenibbled by rats. And then (addressing) al-Ashajj of 'Abdul-Qais he said: Verily, you possess two such qualities which Allah loves: insight and deliberateness.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.26]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 26

It is narrated on the authority of Abu Said al-Khudri that when the delegation of the tribe of Abdul-Qais came to the Prophet of Allah (may peace be upon him), (its members) said: Apostle of Allah, may God enable us to lay down our lives for you, which beverage is good for us? He (the Prophet) said: (Not to speak of beverages, I would lay stress) that you should not drink in the wine jars. They said: Apostle of Allah, may God enable us to lay down our lives for you, do you know what al-naqir is? He (the Holy Prophet) replied: Yes, it is a stump which you hollow out in the middle, and added: Do not use gourd or receptacle (for drink). Use water-skin the mouth of which is tied with a thong (for this purpose).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.27]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 27

It is reported on the authority of Ibn 'Abbas that Mu'adh said: The Messenger of Allah sent me (as a governor of Yemen) and (at the time of departure) instructed me thus: You will soon find yourself in a community one among the people of the Book, so first call them to testify that there is no god but Allah, that I (Muhammad) am the messenger of Allah, and if they accept this, then tell them Allah has enjoined upon them five prayers during the day and the night and if they accept it, then tell them that Allah has made Zakat obligatory for them that it should be collected from the rich and distributed among the poor, and if they agree to it don't pick up (as a share of Zakat) the best of their wealths. Beware of the supplication of the oppressed for there is no barrier between him and Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.28]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 28

It is narrated on the authority of Ibn 'Abbas that when the Messenger of Allah (may peace be upon him) sent Mu'adh towards Yemen (as governor) he said to him: Verily you would reach a community of the people of the Book, the very first thing to which you should call them is the worship of Allah, may His Glory be Magnificent, and when they become fully aware of Allah, instruct them that He has enjoined five prayers on them during the day and the night, and when the begin observing it, then instruct them that verily Allah has made Zakat obligatory for them which would be collected from the wealthy amongst them and distributed to their needy ones, and when they submit to it, then collect it from them and avoid (the temptation) of selecting the best (items) of their riches.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.29]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 29

It is narrated on the authority of Abu Huraira that when the Messenger of Allah (may peace be upon him) breathed his last and Abu Bakr was appointed as his successor (Caliph), those amongst the Arabs who wanted to become apostates became apostates. 'Umar b. Khattab said to Abu Bakr: Why would you fight against the people, when the Messenger of Allah declared: I have been directed to fight against people so long as they do not say: There is no god but Allah, and he who professed it was granted full protection of his property and life on my behalf except for a right? His (other) affairs rest with Allah. Upon this Abu Bakr said: By Allah, I would definitely fight against him who severed prayer from Zakat, for it is the obligation upon the rich. By Allah, I would fight against them even to secure the cord (used for hobbling the feet of a camel) which they used to give to the Messenger of Allah (as zakat) but now they have withheld it. Umar b. Khattab remarked: By Allah, I found nothing but the fact that Allah had opened the heart of Abu Bakr for (perceiving the justification of) fighting (against those who refused to pay Zakat) and I fully recognized that the (stand of Abu Bakr) was right.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.30]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 30

It is reported on the authority of Abu Huraira that the Messenger of Allah said: I have been commanded to fight against people so long as they do not declare that there is no god but Allah, and he who professed it was guaranteed the protection of his property and life on my behalf except for the right affairs rest with Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.31]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 31

It is reported on the authority of Abu Huraira that he heard the Messenger of Allah say: I have been commanded to fight against people, till they testify to the fact that there is no god but Allah, and believe in me (that) I am the messenger (from the Lord) and in all that I have brought. And when they do it, their blood and riches are guaranteed protection on my behalf except where it is justified by law, and their affairs rest with Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.32]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 32

It is narrated on the authority of Jabir that the Messenger of Allah said: I have been commanded that I should fight against people till they declare that there is no god but Allah, and when they profess it that there is no god but Allah, their blood and riches are guaranteed protection on my behalf except where it is justified by law, and their affairs rest with Allah, and then he (the Holy Prophet) recited (this verse of the Holy Qur'an):" Thou art not over them a warden" (lxxxviii, 22).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.33]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 33

It has been narrated on the authority of Abdullah b. 'Umar that the Messenger of Allah said: I have been commanded to fight against people till they testify that there is no god but Allah, that Muhammad is the messenger of Allah, and they establish prayer, and pay Zakat and if they do it, their blood and property are guaranteed protection on my behalf except when justified by law, and their affairs rest with Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.34]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 34

It Is narrated on the authority of Abu Malik: I heard the Messenger of Allah (may peace be upon him) say: He who professed that there is no god but Allah and made a denial of everything which the people worship beside Allah, his property and blood became inviolable, an their affairs rest with Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.35]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 35

Abu Malik narrated on the authority of his father that he heard the Apostle (may peace be upon him) say: He who held belief in the unity of Allah, and then narrated what has been stated above.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.36]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 36

It is reported by Sa'id b. Musayyib who narrated it on the authority of his father (Musayyib b. Hazm) that when Abu Talib was about to die, the Messenger of Allah (may peace be upon him) came to him and found with him Abu Jahl ('Amr b. Hisham) and 'Abdullah b. Abi Umayya ibn al-Mughirah. The Messenger of Allah (may peace be upon him) said: My uncle, you just make a profession that there is no god but Allah, and I will bear testimony before Allah (of your being a believer), Abu Jahl and 'Abdullah b. Abi Umayya addressing him said: Abu Talib, would you abandon the religion of 'Abdul-Muttalib? The Messenger of Allah (may peace be upon him) constantly requested him (to accept his offer), and (on the other hand) was repeated the same statement (of Abu Jahl and 'Abdullah b. Abi Umayya) till Abu Talib gave his final decision and be stuck to the religion of 'Abdul-Muttalib and refused to profess that there is no god but Allah. Upon this the Messenger of Allah remarked: By Allah, I will persistently beg pardon for you till I am forbidden to do so (by God), It was then that Allah, the Magnificent and the Glorious, revealed this verse:

" It is not meet for the Prophet and for those who believe that they should beg pardon for the polytheists, even though they were their kith and kin, after it had been made known to them that they were the denizens of Hell" (ix. 113)

And it was said to the Messenger of Allah (may peace be upon him):

" Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will, and He knoweth best who are the guided" (xxviii, 56).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.37]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 37

It is narrated on the authority of Abu Huraira that the Messenger of Allah said to his uncle at the time of his death: Make a profession of it that there is no god but Allah and I will bear testimony (of your being a Muslim) on the Day of judgment. But he (Abu Talib) refused to do so. Then Allah revealed this verse:

" Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will and He knoweth best who are the guided" (xxviii. 56).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.38]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 38

It is narrated on the authority of Abu Huraira that the Messenger of Allah said to his uncle (at the time of his death): Make a profession of it that there is no god but Allah and I will bear testimony (of your being a Muslim) on the Day of judgment. He (Abu Talib) said: Were it not the fear of the Quraysh blaming me (and) saying that it was the fear of (approaching death) that induced me to do so, I would have certainly delighted your eyes. It was then that Allah revealed:

" Verily thou canst not guide to the right path whom thou lovest. And it is Allah Who guideth whom He will and He knoweth best who are the guided" (xxviii-56).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.39]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 39

It is narrated on the authority of 'Uthman that the Messenger of Allah (may peace be upon him) said. He who died knowing (fully well) that there is no god but Allah entered Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.40]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 40

It is narrated on the authority of Humran that he heard Uthman saying this: I heard the Messenger of Allah (may peace be upon him) uttering these words (as stated above).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.41]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 41

It is narrated on the authority of Abu Huraira: We were accompanying the Apostle (may peace be upon him) in a march (towards Tabuk). He (the narrator) said: The provisions with the people were almost depleted. He (the narrator) said: (And the situation became so critical) that they (the men of the army) decided to slaughter some of their camels. He (the narrator) said: Upon this Umar said: Messenger of Allah, I wish that you should pool together what has been left out of the provisions with the people and then invoke (the blessings of) Allah upon it. He (the narrator) said: He (the Holy Prophet) did it accordingly. He (the narrator) said: The one who had wheat in his possession came there with wheat. He who had dates with him came there with dates. And Mujahid said: He who possessed stones of dates came there with stones. I (the narrator) said: What did they do with the date-stones. They said: They (the people) sucked them and then drank water over them. He (the narrator said): He (the Holy Prophet) invoked the blessings (of Allah) upon them (provisions). He (the narrator) said: (And there was such a miraculous increase in the stocks) that the people replenished their provisions fully. He (the narrator) said: At that time he (the Holy Prophet) said: I bear testimony to the fact that there is no god but Allah, and I am His messenger. The bondsman who would meet Allah without entertaining any doubt about these (two fundamentals) would enter heaven.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.42]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 42

It is narrated either on the authority of Abu Huraira or that of Abu Sa'id Khudri. The narrator A'mash has narrated this hadith with a little bit of doubt (about the name of the very first narrator who was in direct contact with the Holy Prophet. He was either Abu Huraira or Abu Sa'id Khudri. Both are equally reliable transmitters of the traditions). He (the narrator) said: During the time of Tabuk expedition, the (provisions) ran short and the men (of the army) suffered starvation; they said: Messenger of Allah, would you permit us to slay our camels? We would eat them and use their fat. The Messenger of Allah (may peace be upon him) said: Do as you please. He (the narrator) said: Then 'Umar came there and said: Messenger of Allah, if you do that (if you give your consent and the men begin to slay their camels), the riding animals would become short. But (I would suggest you to) summon them along with the provisions left with them Then invoke Allah's blessings on them (different items of the provisions) It is hoped Allah shall bless them. The Messenger of Allah replied in the affirmative. (the narrator) said: He called for a leather mat to be used as a table cloth and spread it out. Then he called people along with the remaining portions of their provisions. He (the narrator) said: Someone was coming with handful of mote, another was coming with a handful of dates, still another was coming with a portion of bread, till small quantities of these things were collected on the table cloth. He (the narrator said): Then the messenger of Allah invoked blessing (on them) and said: Fill your utensils with these provisions. He (the narrator) said: They filled their vessel to the brim with them, and no one amongst the army (which comprised of 30,000 persons) was left even with a single empty vessel. He (the narrator) aid: They ate to their fill, and there was still a surplus. Upon this the Messenger of Allah (may peace be upon him) remarked: I bear testimony that there is no god but Allah and I am the messenger of Allah. The man who meets his Lord without harboring any doubt about these two (truths) would never be kept away from Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.43]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 43

It is narrated on the authority of Ubadah b. Samit that the messenger of Allah (may peace be upon him) observed: He who said:" There is no god but Allah, He is One and there is no associate with Him, that Muhammad is his servant and His messenger, that Christ is servant and the son of His slave-girl and he (Christ) His word which He communicated to Mary and is His Spirit, that Paradise is a fact and Hell is a fact," Allah would make him (he who affirms these truths enter Paradise through any one of its eight doors which he would like.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.44]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 44

It is narrated on the authority of Umar b. Hani with the same chain of transmitters with the exception of these words: Allah would make him (he who affirms these truths) enter Paradise through one of the eight doors which he would like.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.45]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 45

It is narrated on the authority of Sunabihi that he went to Ubada b. Samit when he was about to die. I burst into tears. Upon this he said to me: Allow me some time (so that I may talk with you). Why do you weep? By Allah, if I am asked to bear witness, I would certainly testify for you (that you are a believer). Should I be asked to intercede, I would certainly intercede for you, and if I have the power, I would certainly do good to you, and then observed: By Allah, never did I hear anything from the Messenger of Allah (may peace be upon him) which could have been a source of benefit to you and then not conveyed it to you except this single hadith. That I intend to narrate to you today, since I am going to breathe my last. I heard the Messenger of Allah (may peace be upon him) say: He who testifies that there is no god but Allah and that Muhammad is the messenger of Allah, Allah would prohibit the fire of Hell for him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.46]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 46

It is narrated on the authority of Mu'adh b. Jabal: I was riding behind the Prophet (may peace be upon him) and there was nothing between him and me but the rear part of the saddle, when he said: Mu'adh b. Jabal: To which I replied: At your beck and call, and at your pleasure, Messenger of Allah! He moved along for a few minutes, when again he said: Mu'adh b. Jabal: To which I replied: At your beck and call, and at your pleasure, Messenger of Allah! He then again moved along for a few minutes and said: Mu'adh b. Jabal: To which I replied. At your beck and call, and at your pleasure. Messenger of Allah He, (the Holy Prophet) said: Do you know what right has Allah upon His servants? I said: Allah and His Messenger know best. He (the Holy Prophet) said: Verily the right of Allah over His servants is that they should worship Him, not associating anything with Him. He (the Holy Prophet) with Mu'adh behind him, moved along for a few minutes and said: Mu'adh b. Jabal: To which I replied: At your beck and call, and at your pleasure, Messenger of Allah! He (the Holy Prophet) said: Do you know what rights have servants upon Allah in case they do it (i. e. they worship Allah without associating anything with Him)? I (Mu'adh b. Jabal) replied: Allah and His Messenger know best. (Upon this) he (the Holy Prophet) remarked: That He would not torment them (with the fire of Hell).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.47]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 47

It is narrated on the authority of Mu'adh b. Jabal that he observed: I was riding behind the Messenger of Allah (may peace be upon him) on an ass known as 'Ufair. He (Mu'adh) observed: He (the Holy Prophet) said: Mu'adh, do you know what right has Allah over His bondsmen and what right have His bondsmen over Him? Mu'adh added: I replied: Allah and his Messenger know best. Upon this he (the Holy Prophet remarked: The right of Allah over His bondsmen is that they should worship Allah and should not associate anything with Him, and the right of His bondsmen over Allah, Glorious and Sublime, is that He does not punish him who associates not anything with Him. He (Mu'adh) added: I said to the Messenger of Allah: Should I then give the tidings to the people? He (the Holy Prophet) said: Do not tell them this good news, for they would trust in it alone.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.48]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 48

It is narrated on the authority of Mu'adh b. Jabal that the Messenger of Allah (may peace be upon him) said: Mu'adh, do you know the right of Allah over His bondsmen? He (Mu'adh) said: Allah and His Apostle know best. He (the Messenger of Allah) said: That Allah alone should be worshipped and nothing should be associated with Him. He (the Holy Prophet) said: What right have they (bondsmen) upon Him in case they do it? He (Mu'adh) said: Allah and His Apostle know best. He (the Holy Prophet) said: That He would not punish them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.49]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 49

It is narrated on the authority of Aswad b. Hilal that he heard Mu'adh say this: The Messenger of Allah (may peace be upon him) called, me and I replied to him. He (the Holy Prophet) said: Do you know the right of Allah upon the people? and then followed the hadith (mentioned above).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.50]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 50

It is reported on the authority of Abu Huraira: We were sitting around the Messenger of Allah (may peace and blessings be upon him). Abu Bakr and Umar were also there among the audience. In the meanwhile the Messenger of Allah got up and left us, He delayed in coming back to us, which caused anxiety that he might be attacked by some enemy when we were not with him; so being alarmed we got up. I was the first to be alarmed. I, therefore, went out to look for the Messenger of Allah (may peace and blessings be upon him) and came to a garden belonging to the Banu an-Najjar, a section of the Ansar went round it looking for a gate but failed to find one. Seeing a rabi' (i. e. streamlet) flowing into the garden from a well outside, drew myself together, like a fox, and slinked into (the place) where God's Messenger was. He (the Holy Prophet) said: Is it Abu Huraira? I (Abu Huraira) replied: Yes, Messenger of Allah. He (the Holy Prophet) said: What is the matter with you? replied: You were amongst us but got up and went away and delayed for a time, so fearing that you might be attacked by some enemy when we were not with you, we became alarmed. I was the first to be alarmed. So when I came to this garden, I drew myself together as a fox does, and these people are following me. He addressed me as Abu Huraira and gave me his sandals and said: Take away these sandals of mine, and when you meet anyone outside this garden who testifies that there is no god but Allah, being assured of it in his heart, gladden him by announcing that he shall go to Paradise. Now the first one I met was Umar. He asked: What are these sandals, Abu Huraira? I replied: These are the sandals of the Messenger of Allah with which he has sent me to gladden anyone I meet who testifies that there is no god but Allah, being assured of it in his heart, with the announcement that he would go to Paradise. Thereupon 'Umar struck me on the breast and I fell on my back. He then said: Go back, Abu Huraira, So I returned to the Messenger of Allah (may peace be upon him), and was about to break into tears. 'Umar followed me closely and there he was behind me. The Messenger of Allah (may peace and blessings be on him) said: What is the matter with you, Abu Huraira? I said: I happened to meet 'Umar and conveyed to him the message with which you sent me. He struck me on my breast which made me fall down upon my back and ordered me to go back. Upon this the Messenger of Allah (may peace be upon him) said: What prompted you to do this, 'Umar? He said: Messenger of Allah, my mother and father be sacrificed to thee, did you send Abu Huraira with your sandals to gladden anyone he met and who testified that there is no god but Allah, and being assured of it in his heart, with the tidings that he would go to Paradise? He said: Yes. Umar said: Please do it not, for I am afraid that people will trust in it alone; let them go on doing (good) deeds. The Messenger of Allah (may peace be upon him) said: Well, let them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.51]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 51

It is reported on the authority of Anas b. Malik that the Prophet of Allah (may peace and blessings be upon him) addressed Mu'adh b. Jabal as he was riding behind him to which he replied: At thy beck and call, and at thy pleasure, Messenger of Allah. He again called out: Mu'adh, to which he (again) replied: At thy beck and call, and at thy pleasure. He (the Holy Prophet) addressed him (again): Mu'adh, to which he replied: At thy beck and call, and at thy pleasure, Messenger of Allah. Upon this he (the Holy Prophet) observed: If anyone testifies (sincerely from his heart) that there is no god but Allah, and that Muhammad is His bondsman and His messenger, Allah immuned him from Hell. He (Mu'adh) said: Messenger of Allah, should I not then inform people of it, so that they may be of good cheer? He replied: Then they would trust in it alone. Mu'adh told about it at the time of his death, to avoid sinning.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.52]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 52

It is narrated on the authority of 'Itban b. Malik that he came to Medina and said: Something had gone wrong with my eyesight. I, therefore, sent (a message to the Holy Prophet): Verily it is my ardent desire that you should kindly grace my house with your presence and observe prayer there so, that I should make that corner a place of worship. He said: The Prophet (may peace be upon him) came there, and those amongst the Companions whom Allah willed also accompanied him. He entered (my place) and offered prayer at my residence and his Companions began to talk amongst themselves (and this conversation centered round hypocrites), and then the conspicuous one, Malik b. Dukhshum was made the target and they wished that he (the Holy Prophet) should curse him and he should die or he should meet some calamity. In the meanwhile the Messenger of Allah (may peace and blessings be upon him) completed his prayer and said: Does Malik b. Dukhshum not testify the fact that there is no god but Allah and verily I am the messenger of Allah. They replied: He makes a profession of it (no doubt) but does not do it out of (sincere) heart. He (the Holy Prophet) said: He who testifies that there is no god but Allah and I am the messenger of Allah would not enter Hell or its (flames) would not consume him. Anas said: This hadith impressed me very much and I told my son to write it down.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.53]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 53

It is narrated on the authority of Anas that 'Itban b. Malik told him that he became blind. He sent a message to the Messenger of Allah (may peace be upon him) that he should come and mark a place of worship for him. Thereupon came the Messenger of Allah (may peace be upon him) and his people and then there was a discussion among them about a man who was known as Malik b. Dukhshum, and subsequently the narrator described the hadith of Sulaiman b. Mughira as stated above.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.54]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 54

It is narrated on the authority of 'Abbas b. 'Abdul-Muttalib that he heard the Messenger of Allah saying: He relished the flavor of faith (Iman) who became the book of faith pleased with Allah as Lord, with al-Islam as the code of life and with Muhammad as the Messenger (of Allah).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.55]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 55

It is narrated on the authority of Abu Huraira that the Prophet (may peace be upon him) said: Iman has over seventy branches, and modesty is a branch of Iman.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.56]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 56

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Faith has over seventy branches or over sixty branches, the most excellent of which is the declaration that there is no god but Allah, and the humblest of which is the, removal of what is injurious from the path: and modesty is the branch of faith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.57]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 57

Salim reported on the authority of his father that the Prophet (may peace and blessings be upon him) heard a man instruction his brother about modesty. Upon this the Prophet remarked: Modesty is an ingredient of Iman (faith).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.58]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 58

Zuhri has narrated this hadith with the addition of these words: He (the Holy Prophet) happened to pass by a mass of Ansar who was instructing his brother (about modesty).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.59]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 59

It is narrated on the authority of 'Imran b. Husain that the Prophet (may peace and blessings be upon him) said: Modesty brings forth nothing but goodness. Bushair b. Ka'b said: It is recorded in the books of wisdom, there lies sobriety in it and calmness of mind in it, Imran said: I am narrating to you the tradition of the Messenger of Allah (may peace and blessings be upon him) and you talk of your books.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.60]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 60

It is narrated on the authority of Qatada. We were sitting with 'Imran b. Husain in a company and Bushair ibn Ka'b was also amongst us. 'Imran narrated to us that on a certain occasion the Messenger of Allah (may peace and blessings be upon him) said: Modesty is a virtue through and through, or said: Modesty is a goodness complete. Upon this Bushair ibn Ka'b said: Verily we find in certain books or books of (wisdom) that it is God-inspired peace of mind or sobriety for the sake of Allah and there is also a weakness in it. Imran was so much enraged that his eyes became red and he said: I am narrating to you the hadith of the Messenger of Allah (may peace be upon him) and you are contradicting it. He (the narrator) said: Imran reported the hadith, He (the narrator) said: Bushair repeated, (the same thing). Imran was enraged. He (the narrator) said: We asserted: Verily Bushair is one amongst us. Abu Nujaid! There is nothing wrong, with him (Bushair).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.61]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 61

Ishaq b. Ibrahim narrates this hadith of the Holy Prophet on the authority of Imran b. Husain, like the one narrated by Hammad b. Zaid.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.62]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 62

It is narrated on the authority of Sufyan b. 'Abdulla al-Thaqafi that he said: I asked the Messenger of Allah to tell me about Islam a thing which might dispense with the necessity of my asking anybody after you. In the hadith of Abu Usama the (words) are: other than you. He (the Holy Prophet) remarked: Say I affirm my faith in Allah and then remain steadfast to it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.63]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 63

It is narrated on the authority of 'Abdullah b. 'Amr that a man asked the Messenger of Allah (may peace and blessings be upon him) which of the merits (is superior) in Islam. He (the Holy Prophet) remarked: That you provide food and extend greetings to one whom you know or do not know.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.64]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 64

'Abdullah b. Amr b. al-As is reported to have said: Verily a person asked the Messenger of Allah (may peace and blessings be upon him) who amongst the Muslims was better. Upon this (the Holy Prophet) remarked: From whose hand and tongue the Muslims are safe.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.65]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 65

It is narrated on the authority of Jabir that he heard the (Holy Prophet) say: A Muslim is he from whose hand and tongue the Muslim's are safe.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.66]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 66

It is narrated on the authority of Abu Musa Ash'ari: I asked the Messenger of Allah which (attribute) of Islam is more excellent. Upon this he remarked: One in which the Muslims are safe, protected from the tongue and hand of (other Muslims). Ibrahim b. Sa'id al-Jauhari has narrated this hadith with the same words in addition to these. The Messenger of Allah (may peace and blessings be upon him) was asked as to who amongst the Muslims is better, and the rest of the hadith was narrated like this.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.67]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 67

It is reported on the authority of Anas that the Prophet of Allah (may peace and blessings be upon him ) said: There are three qualities for which anyone who is characterised by them will relish the sweetness of faith: he to whom Allah and His Messenger are dearer than all else; he who loves a man for Allah's sake alone; and he who has as great an abhorrence of returning to unbelief after Allah has rescued him from it as he has of being cast into Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.68]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 68

It is reported on the authority of Anas that the Messenger of Allah (may peace be upon him) said: There are three qualities for which any one who is characterised by them will relish the savour of faith: that he loves man and he does not love him but for Allah's sake alone; he is to whom Allah and His Messenger are dearer than all else; he who prefers to be thrown into fire than to return to unbelief after Allah has rescued him out of it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.69]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 69

A similar hadith has been reported on the authority of Anas (with another chain of transmitters) with the exception of these words: that he again becomes a Jew or a Christian.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.70]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 70

It is reported on the authority of Anas that the Messenger of Allah (may peace be upon him) said: No bondsman believes, and, in the hadith narrated by Abdul Warith, no person believes, till I am dearer to him than the members of his household, his wealth and the whole of mankind.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.71]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 71

It is reported on the authority of Anas b. Malik that the Messenger of Allah said: None of you is a believer till I am dearer to him than his child, his father and the whole of mankind.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.72]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 72

It is arrested on the authority of Anas b. Malik that the Prophet (may peace and blessings be upon him) observed: one amongst you believes (truly) till one likes for his brother or for his neighbour that which he loves for himself.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.73]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 73

It is narrated on the authority of Anas that the Prophet (may peace blessings be upon him) observed: By Him in whose Hand is my life, no, bondsman (truly) believes till he likes for his neighbour, or he (the Holy Prophet) said: for his brother, whatever he likes for himself.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.74]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 74

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessing be upon him) observed: He will not enter Paradise whose neighbour is not secure from his wrongful conduct.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.75]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 75

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who believes in Allah and the Last Day should either utter good words or better keep silence; and he who believes in Allah and the Last Day should treat his neighbour with kindness and he who believes in Allah and the Last Day should show hospitality to his guest.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.76]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 76

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: He who believes in Allah and the Last Day does not harm is neighbour, and he who believes in Allah and the Last Day shows hospitality to his guest and he who believes in Allah and the Last Day speaks good or remains silent.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.77]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 77

Another hadith similar to one narrated (above) by Abu Husain is also reported by Abu Huraira with the exception of these words: He (the Prophet) said: He should do good to the neighbour.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.78]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 78

It is narrated on the authority of Abu Shuraih al-Khuzai' that the Prophet (may peace and blessings of Allah be upon him) observed: He who believes in Allah and the Last Day should do good to his neighbour and he who believes in Allah and the Last Day should show hospitality to the guest and he who believes in Allah and the Last Day should either speak good or better remain silent.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.79]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 79

It is narrated on the authority of Tariq b. Shihab: It was Marwan who initiated (the practice) of delivering khutbah (address) before the prayer on the 'Id day. A man stood up and said: Prayer should precede khutbah. He (Marwan) remarked, This (practice) has been done away with. Upon this Abu Sa'id remarked: This man has performed (his duty) laid on him. I heard the Messenger of Allah as saying: He who amongst you sees something abominable should modify it with the help of his hand; and if he has not strength enough to do it, then he should do it with his tongue, and if he has not strength enough to do it, (even) then he should (abhor it) from his heart, and that is the least of faith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.80]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 80

The same hadith of the Holy Prophet (may peace and blessings be upon him) has been reported by Abu Sa'id al-Khudri in connection with the story of Marwan.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.81]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 81

It is narrated on the authority 'Abdullah b. Mas'ud that the Messenger of Allah (may peace and blessings be upon him) observed: Never a Prophet had been sent before me by Allah towards his nation who had not among his people (his) disciples and companions who followed his ways and obeyed his command. Then there came after them their successors who said whatever they did not practise, and practised whatever they were not commanded to do. He who strove against them with his hand was a believer: he who strove against them with his tongue was a believer, and he who strove against them with his heart was a believer and beyond that there is no faith even to the extent of a mustard seed. Abu Rafi' said: I narrated this hadith to 'Abdullah b. 'Umar; he contradicted me. There happened to come 'Abdullah b. Mas'ud who stayed at Qanat, and 'Abdullah b 'Umar wanted me to accompany him for visiting him (as 'Abdullah b. Mas'ud was ailing), so I went along with him and as we sat (before him) I asked Ibn Mas'ud about this hadith. He narrated it in the same way as I narrated it to Ibn 'Umar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.82]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 82

The same hadith has been transmitted by another chain of narrators on the authority of 'Abdullah b. Mas'ud who observed: Never was there one among the prophets who had had not disciples who followed his direction and followed his ways. The remaining part of the hadith is like that as narrated by Salih but the arrival of Ibn Mas'ud and the meeting of Ibn 'Umar with him is not mentioned.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.83]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 83

It is narrated on the authority of Ibn Mas'ud that the Apostle of Allah (may peace and blessings be upon him) pointed towards Yemen with his hand and said: Verily Iman is towards this side, and harshness and callousness of the hearts is found amongst the rude owners of the camels who drive them behind their tails (to the direction) where emerge the two horns of Satan, they are the tribes of Rabi'a and Mudar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.84]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 84

It is narrated on the authority of Abu Huraira that the Messenger of Allah observed: There have come the people of Yemen; they are tender of hearts, the belief is that of the Yemenites, the understanding (of the faith) is that of the Yemenites and sagacity is that of the Yemenites.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.85]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 85

Abu Huraira reported the same hadith which is transmitted to us by another chain of transmitters, e. g. Muhammad b. al-Muthanna, Ishaq b. Yusuf Azraq, Ibn 'Aun, etc.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.86]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 86

Abu Huraira reported: The Messenger of Allah (may peace and blessings be upon him) observed: There came to you the people from Yemen; they are tender of hearts and mild of feelings, the understanding is Yemenite, the sagacity is Yemenite.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.87]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 87

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) remarked: The summit of unbelief is towards the East and the pride and conceitedness is found among the owners of horses and camels who are rude and uncivil, people of the tents, and tranquillity is found among those who rear goats and sheep.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.88]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 88

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: The belief is among the Yemenites, and the unbelief is towards the East, and tranquillity is among those who rear goats and sheep, and pride and simulation is among the uncivil and rude owners of horses and camels.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.89]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 89

It is reported on the authority of Abu Huraira: I heard the Messenger of Allah saying this: Pride and conceitedness is found among the uncivil owners of the camels and tranquillity is found among the owners of sheep and goats.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.90]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 90

The same hadith has been narrated by Zuhri with the same chain of authorities with the addition: The belief is among the Yemenites, the sagacity is that of the Yemenites.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.91]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 91

Abu Huraira said: I heard the Prophet (may peace and blessings be upon him) saying: There came the people of Yemen, they are tender of feelings and meek of hearts. The belief is that of the Yemenites, the sagacity is that of the Yemenites, the tranquillity is among the owners of goats and sheep, and pride and conceitedness is among the uncivil owners of the camels, the people of the tents in the direction of sunrise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.92]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 92

It is reporter on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: There came the people of Yemen who are soft of hearts, tender in feelings: the belief is that of the Yemenites, the sagacity is that of the Yemenites and the summit of unbelief is towards the East.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.93]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 93

Qutaiba b. Sa'id and Zubair b. Harb say: Jarir narrated this on the authority of A'mash with the same chain of narrators (as mentioned above).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.94]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 94

Shu'ba narrated the hadith as reported by Jarir with the same chain of narrators with this addition: Pride and conceitedness is among the owners of the camels and tranquillity and sobriety is found amongst the owners of sheep.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.95]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 95

It is reported on the authority of Jabir b. Abdullah that the Messenger of Allah (may peace and, blessings be upon him) observed: The callousness of heart and sternness is in the East and faith is among the people of the Hijaz.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.96]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 96

Abu Huraira reported: The Messenger of Allah (may peace and blessing be upon him) observed: You shall not enter Paradise so long as you do not affirm belief (in all those things which are the articles of faith) and you will not believe as long as you do not love one another. Should I not direct you to a thing which, if you do, will foster love amongst you: (i. e.) give currency to (the practice of paying salutation to one another by saying) as-salamu alaikum.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.97]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 97

Zuhair b. Harb said: Jarir reported on the authority of A'mash with this chain of transmitters that the Messenger of Allah (may peace be upon him) observed: By him in Whose hand is my life, you shall not enter Paradise unless you believe. The rest of the hadith is the same as narrated by Abd Mu'awiya and Waki'.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.98]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 98

It is narrated on the authority of Tamim ad-Dari that the Apostle of Allah (may peace and blessings be upon him) observed: Al-Din is a name of sincerity and well wishing. Upon this we said: For whom? He replied: For Allah, His Book, His Messenger and for the leaders and the general Muslims.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.99]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 99

Muhammad b. Hatim and others narrate the same hadith of the Apostle (may peace and blessings be upon him) on the authority of Tamim ad-Dari.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.100]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 100

Umayya b. Bistam narrates the same hadith of the Messenger of Allah (may peace and blessings be upon him) on the authority of Tamim ad-Dari.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.101]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 101

It is narrated on the authority of Jarir that he observed I gave pledge of allegiance to the Messenger of Allah (may peace and blessings be upon him) on the observance of prayer, payment of Zakat, and sincerity and well-wishing for every Muslim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.102]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 102

Sufyan narrated on the authority of Ziyad b. 'Ilaqa that he heard Jarir b. 'Abdullah saying: I pledged allegiance to the Apostle of Allah may peace and blessings be upon him) on sincerity and well-wishing for every Muslim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.103]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 103

It is narrated on the authority of Jarir that he observed: I owed allegiance to the Apostle of Allah (may peace and blessings be upon him) on hearing ( is commands) and obeying (them) and the Prophet) instructed me (to act) as lay in my power, and sincerity and goodwill for every Muslim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.104]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 104

Abu Huraira reported that the Messenger of Allah observed: The fornicator who fornicates is not a believer so long as he commits it and no thief who steals is a believer as long as he commits theft, and no drunkard who drinks wine is a believer as long as he drinks it. 'Abdul-Malik b. Abi Bakr' narrated this on the authority of Abu Bakr b. Abdur-Rahman b. Harith and then said: Abu Huraira made this addition: No plunderer who plunders a valuable thing that attracts the attention of people is a believer so long as he commits this act.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.105]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 105

'Abdul-Malik b. Shu'aib narrated this hadith on the authority of Abu Huraira that he observed: The Messenger of Allah said that a fornicator does not fornicate, and then narrated the hadith like this, and he also made mention of plundering too, but did not mention of a thin having value. Ibn Shihab said: Sa'id b. al-Musayyib and Abu Salama narrated this hadith on the authority of Abu Huraira a hadith like that of Abu Bakr with the exception of (the mention) of plundering.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.106]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 106

Muhammad b. Mihran narrates this hadith on the authority of Abu Huraira and made mention of plundering but did not talk of (a thing) having value.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.107]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 107

Imam Muslim has reported this hadith by Hasan b. 'Ali al-Halwani and other traditions.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.108]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 108

It is reported on the authority of Qutaiba b. Sa'id who reported on the authority of Abu Huraira the hadith like that narrated from Zuhri with this exception that in the hadith narrated by 'Ala ' and Safwan b. Sulaim there is no mention of: People raise there eyes towards him, and in the hadith narrated by Hammam: The believers raise their eyes towards him, and such like words, so long as he plunders (is not) a believer, and these words were added: And no exploiter who makes an exploitation is a believer as long as he exploits It; therefore avoid and shun (these evils).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.109]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 109

It is narrated on the authority of Abu Huraira: A fornicator who fornicates is not a believer as long as he commits fornication, and no one who steals is a believer as long as he commits theft, and no one who drinks wine is a believer as long as he drinks it, and repentance may be accepted after that.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.110]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 110

Muhammad b. Rafi', Abdur-Razzaq, Sufyan, A'mash narrated this hadith like one narrated by Shu'ba, on the authority of Abu Huraira tracing, it (right to the Holy Prophet).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.111]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 111

It is narrated on the authority of Abdullah b. 'Amr that the Prophet observed: Four characteristics made anyone who possessed them, a sheer hypocrite; anyone who possessed one of them possessed a characteristic of hypocrisy till be abandons it: when he talked he lied, when he made a covenant he acted treacherously, and when he quarreled he deviated from the truth.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.112]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 112

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Three are the signs of a hypocrite: when he spoke he told a lie, when he made a promise he acted treacherously against it, when he was trusted he betrayed.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.113]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 113

Abu Huraira reported that the Messenger of Allah (may peace and blessings be upon him) observed: There are three characteristics of a hypocrite: when he spoke he told a lie, when he made promise he acted treacherously, and when he was trusted he betrayed.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.114]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 114

'Uqba b. Mukarram al-'Ami reported that he heard 'Ala' b. 'Abdur-Rahman narrating this hadith with this chain of transmitters and he said: Three are the signs of a hypocrite, even if he observed fast and prayed and asserted that he was a Muslim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.115]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 115

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings of Allah be upon him) made observations like them embodied in the hadith narrated by Yahya b. Muhammad on the authority of 'Ala', and added to it: even if he observed fast and prayed and asserted that he was a Muslim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.116]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 116

It is reported on the authority of Ibn 'Umar that the Apostle (may peace and blessings be upon him) observed: When a man calls his brother an unbeliever, it returns (at least) to one of them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.117]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 117

It is reported on the authority of Ibn 'Umar that the Messenger of Allah (may peace and blessings be upon him) said: Any person who called his brother: or unbeliever (has in fact done an act by which this unbelief) would return to one of them. If it were so, as he asserted (then the unbelief of man was confirmed but if it was not true), then it returned to him (to the man who labeled it on his brother Muslim).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.118]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 118

It is reported on the authority of Abu Dharr that he heard the Messenger of Allah (may peace and blessings be upon him) saying: No person who claimed knowingly anyone else as his father besides (his own) committed nothing but infidelity, and he who made a claim of anything, which (in fact) did not belong to him, is not amongst us; he should make his abode in Fire, and he who labeled anyone with unbelief or called him the enemy of Allah, and he was in fact not so, it rebounded on him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.119]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 119

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: Do not detest your fathers; he who detested his father committed infidelity.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.120]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 120

It is reported on the authority of Sa'd b. Abi Waqqas: Both of my ears heard the Messenger of Allah saying this: He who claimed the fatherhood of anyone else besides his real father knowingly (committed a great sin) ;Paradise is forbidden to him. Abu Bakra asserted that he too heard it from the Messenger of Allah (may peace be upon him ).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.121]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 121

Sa'd and Abu Bakra each one of them said: My ears heard and my hearing preserved it that Muhammad (peace and blessings be upon him) observed: He who claimed for another one his fatherhood besides his own father knowingly that he was not his father-to him Paradise is forbidden.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.122]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 122

It is narrated on the authority of 'Abdullah b. Mas'ud that the Messenger of Allah (may peace and blessings be upon him) observed: Abusing a Muslim is an outrage and fighting against him is unbelief. Zubaid said: I asked Abu Wa'il: Did you hear it from Abdullah narrating if from the Messenger of Allah (may peace and blessings be upon him)? He replied: Yes. But there is mention of the talk between Zubaid and Abu Wa'il in the hadith narrated by Shu'ba.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.123]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 123

Abu Bakr b. Abu Shaiba narrated a hadith like this from the Apostle (may peace and blessings be upon him) on the authority of Abdullah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.124]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 124

It is narrated on the authority of Jarir b. 'Abdullah that the Apostle of Allah (may peace and blessings be upon him) asked him on the occasion of the Farewell Pilgrimage to make the people silent and then said: Do not return to unbelief after me by striking the necks of one another.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.125]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 125

Abdullah b. Mu'adh narrated from the Apostle (may peace and blessings be upon him) a hadith like this on the authority on Ibn Umar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.126]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 126

It is narrated on the authority of Abdullah b. Umar that the Apostle (may peace and blessings be upon him) observed on the occasion of the Farewell Pilgrimage Woe unto you distress unto you! Don't turn back as unbelievers after me by striking the necks of one another.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.127]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 127

Harmala b. Yahya, Abdullah b. Wahb, Umar b. Muhammad, Ibn Umar narrated like the hadith reported by Shu'ba on the authority of Waqid.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.128]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 128

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) observed: Two (things) are found among men which are tantamount to unbelief: slandering one's lineage and lamentation on the dead.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.129]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 129

It is narrated on the authority of Jarir that he heard (the Holy Prophet) saying, The slave who fled from his master committed an act of infidelity as long as he would not return to him. Mansur observed: By God, this hadith was narrated from the Apostle (may peace and blessings be upon him), but I do not like that this should be narrated on my authority here in Basra.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.130]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 130

It is narrated on the authority of Jarir that the Messenger of Allah (may peace and blessings be upon him) observed: The slave who fled from his master, responsibility with regard to him was absolved.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.131]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 131

Jarir b. Abdullah reported it from the Holy Prophet: When the slave runs away from his master, his prayer is not accepted.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.132]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 132

It is narrated on the authority of Zaid b. Khalid al-Juhani: The Messenger of Allah (may peace and blessings be upon him) led the morning prayer at Hudaybiya. There were some marks of the rainfall during the night. At the conclusion of prayer he turned towards people and observed: Do you know what your Lord has said? They replied: Allah and His Messenger know best. Upon this he (the Holy Prophet) remarked: He (Allah) said: Some of My bondsmen entered the morning as My believers and some as unbelievers. He who said: We have had a rainfall due to the Blessing and Mercy of Allah, he is My believer and a disbeliever of stars, and who said: We have had a rainfall due to the rising of such and such (star) disbelieved Me and affirmed his faith in the stars.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.133]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 133

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: Don't you know what your Lord said? He observed: I have never endowed My bondsmen with a favor, but a section amongst them disbelieved it and said: Stars, it was due to the stars.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.134]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 134

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessing be upon him) observed: Allah does not shower His blessings from the heaven that in the morning a group of men disbelieve it (to be a blessing from Allah). Allah sends down rain, but they (the disbelievers) say: Such and such star (is responsible for that).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.135]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 135

It is reported on the authority of Ibn 'Abbas that there was (once) a downpour during the life of the Apostle (may peace and blessings be upon him Upon this the Apostle (may peace and blessings be upon him) observed: Some people entered the morning with gratitude and some with ingratitude (to Allah). Those who entered with gratitude said: This is the blessing of Allah, and those who entered with ingratitude said: Such and such asterism was right. It was upon this that the verse was revealed:

I swear by the setting of the stars to the end and make your provision that you should disbelieve it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.136]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 136

It is reported on the authority of Anas that the Messenger of Allah (may peace and blessings Be upon him) observed: The sign of a hypocrite is the hatred against the Ansar and the sign of a believer is the love for the Ansar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.137]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 137

It is narrated on the authority of Anas that the Apostle (may peace and blessings be upon him) said: The love of the Ansar is the sign of faith and hatred against them is the sign of dissemblance.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.138]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 138

Al-Bara reported it from the Apostle (may peace and blessing be upon him) that he observed with regard to the Ansar, None but the believer loves them, none but the hypocrite hates them. He who loved them loved Allah and he who hated them hated Allah. I (the narrator) said: Did you hear this hadith from al-Bara'? He said: To me, he narrated it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.139]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 139

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace and blessings be upon him) said: A person who believes in Allah and the Last Day never nurses a grudge against the Ansar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.140]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 140

It is narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah observed: The person who believes in Allah and the Last Day never nurses a grudge against the Ansar.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.141]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 141

Zirr reported: 'Ali observed: By Him Who split up the seed and created something living, the Apostle (may peace and blessings be upon him) gave me a promise that no one but a believer would love me, and none but a hypocrite would nurse grudge against me.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.142]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 142

It is narrated on the authority of 'Abdullah b. Umar that the Messenger of Allah observed: O womenfolk, you should give charity and ask much forgiveness for I saw you in bulk amongst the dwellers of Hell. A wise lady among them said: Why is it, Messenger of Allah, that our folk is in bulk in Hell? Upon this the Holy Prophet observed: You curse too much and are ungrateful to your spouses. I have seen none lacking in common sense and failing in religion but (at the same time) robbing the wisdom of the wise, besides you. Upon this the woman remarked: What is wrong with our common sense and with religion? He (the Holy Prophet) observed: Your lack of common sense (can be well judged from the fact) that the evidence of two women is equal to one man, that is a proof of the lack of common sense, and you spend some nights (and days) in which you do not offer prayer and in the month of Ramadan (during the days) you do not observe fast, that is a failing in religion. This hadith has been narrated on the authority of Abu Tahir with this chain of transmitters.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.143]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 143

A hadith like this as narrated by Ibn 'Umar has also been transmitted by Abu Huraira.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.144]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 144

It is narrated on the authority of Abu Huraira that when, the son of Adam recites the Ayat of Sajdah (prostration) and then falls down in prostration, the Satan goes into seclusion and weeps and says: Alas, and in the narration of Abu Kuraib the words are: Woe unto me, the son of Adam was commanded to prostrate, and he prostrated and Paradise was entitled to him and I was commanded to prostrate, but I refused and am doomed to Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.145]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 145

A'mash narrated this hadith with the same chain of transmitters, with this change of words that he (the Satan) said: I disobeyed and I am doomed to Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.146]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 146

It is narrated on the authority of Jabir that he heard the Apostle (may peace and blessings be upon him) saying. Verily between man and between polytheism and unbelief is the negligence of prayer.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.147]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 147

It is narrated on the authority of Abu Zubair that he heard Jabir b. 'Abdullah saying. I heard the Messenger of Allah (may peace and blessings be upon him) observing this: Between man and polytheism and unbelief is the abandonment of salat.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.148]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 148

Abu Huraira reported: The Messenger of Allah was asked about the best of deeds. He observed: Belief in Allah. He (the inquirer) said: What next? He (the Holy Prophet) replied: Jihad (struggle to the utmost) in the cause of Allah. He (the inquirer) again said: What next? He (the Holy Prophet) replied: Pilgrimage accepted into the grace of the Lord. In the. tradition narrated on the authority of Muhammad b. Ja'far (the words are) that he (the Holy Prophet) said: Belief in Allah and His Messenger. Muhammad b. Rafi and 'Abd b. Humaid, 'Abdur-Razzaq and Ma'mar and Zuhri have narrated a hadith like this on the authority of the same chain of transmitters.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.149]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 149

Abu Dharr reported: I said: Messenger of Allah, which of the deeds is the best? He (the Holy Prophet) replied: Belief in Allah and Jihad in His cause. I again asked: Who is the slave whose emancipation is the best? He (the Holy Prophet) replied: One who is valuable for his master and whose price is high. I said: If I can't afford to do it? He (the Holy Prophet) replied: Help an artisan or make anything for the unskilled (labourer). I (Abu Dharr) said: Messenger of Allah, you see that I am helpless in doing some of these deeds. He (the Holy Prophet) replied: Desist from doing mischief to the people. That is the charity of your person on your behalf.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.150]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 150

Muhammad b. Abu Rafi' narrated the hadith on the authority of Abu Dharr with a slight difference.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.151]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 151

It is narrated on the authority of 'Abdullah b. Mas'ud that he observed. I asked the Messenger of Allah (may peace be upon him) which deed was the best. He (the Holy Prophet) replied: Prayer at its appointed hour. I (again) said: Then what? He (the Holy Prophet) replied: Kindness to the parents. I (again) said: Then what? He replied: Earnest endeavour (Jihad) in the cause of Allah. And I would have not ceased asking more questions but out of regard (for his feelings).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.152]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 152

'Abdullah b. Mas'ud reported: I said: Messenger of Allah, which of the deeds (takes one) nearer to Paradise? He (the Holy Prophet) replied: Prayer at its proper time, I said: What next, Messenger of Allah? He replied: Kindness to the parents. I said: What next? He replied: Jihad in the cause of Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.153]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 153

It was heard from Abu 'Amr Shaibani that, pointing towards the house of Abdullah, he said: The owner of this house told me that he asked the Messenger of Allah (may peace be upon him): Which of the deeds are liked by Allah? He (the Holy Prophet) observed: Prayer at its proper time. I (again) said: What next? He replied: Then goodness to the parents. I (again) said: What then? He replied: Then Jihad in the cause of Allah. He ('Abdullah) said: This is what I was told (by the Holy Prophet). Had I questioned further, he would have made additions for me.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.154]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 154

This hadith has been transmitted by Muhammad b. Bashshar, Muhammad b. Ja'far Shu'ba with this chain of narrators, with the addition that he pointed towards the house of 'Abdullah, but he did not mention his name for us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.155]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 155

It is reported on the authority of 'Abdullah that the Apostle of Allah observed: The best of' the deeds or deed is the (observance of) prayer at its proper time and kindness to the parents.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.156]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 156

'Abdullah reported: I asked the Messenger of Allah (may peace be upon him): Which sin is the gravest in the eye of Allah? He (the Holy Prophet) replied: That you associate a partner with Allah (despite the fact) that He has created you. He (the reporter) said: I told him (the, Holy Prophet): Verily it is indeed grave. He (the reporter) said: I asked him what the next (gravest sin) was. He (the Holy Prophet) replied: That you kill your child out of fear that he shall join you in food. He (the reporter) said: I asked (him) what the next (gravest sin) was. He (the Holy Prophet) observed: Then (the next gravest sin) is that you commit adultery with the wife of your neighbour.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.157]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 157

It is narrated on the authority of Abdullah b. Mas'ud that a man said: Messenger of Allah, which offence is the most grievous in the eye of Allah? He (the Holy Prophet) replied: That you associate a partner with Allah (despite the fact) that He created you. He (the man) said: What next? He (the Holy Prophet) replied: That you kill your child out of fear that he would join you in food. He (the inquirer) said (again): What next? He (the Holy Prophet) replied: That you commit adultery with the wife of your neighbour. And the Almighty and Exalted Lord testified it (with this verse):

All those who call not unto another god along with Allah, and slay not any soul which Allah has forbidden, except in the cause of justice, nor commit fornication, and he who does this shall meet a requital of sin (xxv. 68).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.158]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 158

It is narrated on the authority of 'Abdur-Rahman b. Abu Bakra that his father said: We were in the company of the Messenger of Allah (may peace be upon him) that he observed: Should I not inform you about the most grievous of the grave sins? (The Holy Prophet) repeated it three times, and then said: Associating anyone with Allah, disobedience to parents, false testimony or false utterance. The Holy Prophet was reclining, then he sat up, and he repeated it so many times that we wished that he should become silent.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.159]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 159

Anas narrated from the Apostle (may peace be upon him) about the major sins. He (the Holy Prophet) observed: Associating anyone with Allah, disobedience to parents, killing a person and false utterance.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.160]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 160

Ubaidullah b. Abu Bakr said: I heard Anas b. Malik saying: The Messenger of Allah (may peace be upon him) talked about the major sins, or he was asked about the major sins. Upon this he observed: Associating anyone with Allah, killing of a person, disobedience to parents. He (the Holy Prophet further) said: Should I not inform you about the gravest of the major sins, and (in this connection) observed: False utterance or false testimony. Shu'ba said. It was most probably" false testimony".


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.161]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 161

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Avoid the seven noxious things. It was said (by the hearers): What are they, Messenger of Allah? He (the Holy Prophet) replied: Associating anything with Allah, magic, killing of one whom God has declared inviolate without a just cause, consuming the property of an orphan, and consuming of usury, turning back when the army advances, and slandering chaste women who are believers, but unwary.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.162]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 162

It is narrated on the authority of 'Abdullah b. Amr b. al-'As that the Messenger of Allah (may peace be upon him) observed: Abusing one's parents is one of the major sins. They (the hearers) said: Messenger of Allah, does a man abuse his parents too? He (the Holy Prophet) replied: Yes, one abuses the father of another man, who in turn abuses his father. One abuses his mother and he in turn abuses his (the former's) mother.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.163]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 163

This hadith has also been transmitted on the authority of Sa'd b. Ibrahim with this chain of narrators.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.164]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 164

It Is narrated on the authority of Abdullah b. Mas'ud that the Apostle of Allah (may peace be upon him), observed: He who has in his heart the weight of a mustard seed of pride shall not enter Paradise. A person (amongst his hearers) said: Verily a person loves that his dress should be fine, and his shoes should be fine. He (the Holy Prophet) remarked: Verily, Allah is Graceful and He loves Grace. Pride is disdaining the truth (out of self-conceit) and contempt for the people.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.165]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 165

It is narrated on the authority of 'Abdullah b. Mas'ud that the Messenger of Allah (may peace be upon him) observed: None shall enter the Fire (of Hell) who has in his heart the weight of a mustard seed of Iman and none shall enter Paradise who has in his heart the weight of a mustard seed of pride.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.166]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 166

It is narrated on the authority of 'Abdullah that the Apostle of Allah (may peace be upon him) observed: He who as in his heart the weight of a mustard seed of pride shall not enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.167]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 167

It is narrated on the authority of Abdullah b. Mas'ud that Waki told (him) that the Messenger of Allah had observed and Ibn Numair asserted: I heard the Messenger of Allah (may peace be upon him) saying: He who dies associating anything with Allah would enter the Fire (of Hell). 'Abdullah b. Mas'ud said: I say that he who died without associating anything with Allah entered Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.168]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 168

It is narrated on the authority of Jabir that a man came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, what are the two things quite unavoidable? He replied: He who dies without associating anyone with Allah would (necessarily) enter Paradise and he who dies associating anything with Allah would enter the (Fire of) Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.169]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 169

It is narrated on the authority of Jabir b. Abdullah: I heard the Messenger of Allah (may peace be upon him) saying: He who met Allah without associating anything with Allah entered Paradise and he who met Him associating (anything) with Him entered Fire.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.170]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 170

The same hadith has been narrated by Ishaq b. Mansur on the authority of Jabir with another chain of transmitters.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.171]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 171

I heard Abu Dharr narrating it from the Apostle (may peace be upon him) that he observed: Gabriel came to me and gave me the tidings: Verily he who died amongst your Ummah without associating anything with Allah would enter Paradise. I (the narrator) said: Even if he committed adultery and theft. He (the Holy Prophet) said: (Yes), even if he committed adultery and theft.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.172]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 172

Abu Dharr reported,: I came to the Apostle (may peace be upon him ) and he was asleep with a white mantle over him. I again came, he was still asleep, I came again and he had awakened. I sat by his side and (the Holy Prophet) observed: There is none among the bondsmen who affirmed his faith in La illaha ill-Allah there is no God but Allah) and died in this state and did not enter Paradise. I (Abu Dharr) said: Even if he committed adultery and theft? He (the Holy Prophet) replied: (Yes) even though he committed adultery and theft. I (again said): Even if he committed adultery and theft? He replied: (Yes) even though he committed adultery and theft. (Th Holy Prophet repeated it three times) and said for the fourth time: In defiance of Abu Dharr. Abu Dharr then went out and he repeated (these words): In defiance of Abu Dharr.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.173]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 173

It is narrated on the authority of Miqdad b. Aswad that he said. Messenger of Allah, you just see (here is a point): If I encountered a person amongst the infidels (in the battlefield) and he attacked me and struck me and cut off one of my hands with the sword. Then he (in order to protect himself from me) took shelter of a tree and said: I become Muslim for Allah's sake. Messenger of Allah, can I kill him after he had uttered this? The Messenger of Allah (may peace be upon him) said: Do not kill him. I (the narrator) said: Messenger of Allah, he cut off my hand and uttered this after amputating it; should I then kill him? The Messenger of Allah (may peace be upon him) said: Don't kill him, for I you kill him, verily he would be in a position where you had been before killing him and verily you would be in a position where he had been before uttering (kalima).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.174]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 174

The same hadith has been transmitted by the same chain of narrators. The hadith transmitted by Auza'i and Ibn Juraij contains these words: I embraced Islam for Allah's sake. and in the hadith narrated by Ma'mar the words are: I knelt down to kill him, that he said; There is no god but Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.175]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 175

It is narrated by Miqdad, and he was an ally of B. Zuhra and was of those who participated in the Battle of Badr along with the Messenger of Allah, that he said: Messenger of Allah, here is a point: If I happened to encounter a person amongst the infidels (in the battle). Then he narrated a hadith similar to the one transmitted by Laith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.176]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 176

It is narrated on the authority of Usama b. Zaid that the Messenger of Allah (may peace be upon him) sent us in a raiding party. We raided Huraqat of Juhaina in the morning. I caught hold of a man and he said: There is no god but Allah, I attacked him with a spear. It once occurred to me and I talked about it to the Apostle (may peace be upon him). The Messenger of Allah (may peace be upon him) said: Did he profess" There is no god but Allah," and even then you killed him? I said: Messenger of Allah, he made a profession of it out of the fear of the weapon. He (the Holy Prophet) observed: Did you tear his heart in order to find out whether it had professed or not? And he went on repeating it to me till I wished I had embraced Islam that day. Sa'd said: By Allah, I would never kill any Muslim so long as a person with a heavy belly, i. e., Usama, would not kill. Upon this a person remarked: Did Allah not say this: And fight them until there is no more mischief and religion is wholly for Allah? Sa'd said: We fought so that there should be no mischief, but you and your companions wish to fight so that there should be mischief.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.177]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 177

It is narrated on the authority of Usama b. Zaid: The Messenger of Allah may peace be upon him) sent us to Huraqat, a tribe of Juhaina. We attacked that tribe early in the morning and defeated them and I and a man from the Ansar caught hold of a person (of the defeated tribe). When we overcame him, he said: There is no god but Allah. At that moment the Ansari spared him, but I attacked him with my spear and killed him. The news had already reached the Apostle (peace be upon him), so when we came back he (the Apostle) said to me: Usama, did you kill him after he had made the profession: There is no god but Allah? I said. Messenger of Allah, he did it only as a shelter. The Holy Prophet observed: Did you kill him after he had made the profession that there is no god but Allah? He (the Holy Prophet) went on repeating this to me till I wished I had not embraced Islam before that day.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.178]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 178

It is narrated by Safwan b. Muhriz that Jundab b. 'Abdullah al-Bajali during the stormy days of Ibn Zubair sent a message to 'As'as b. Salama: Gather some men of your family so that I should talk to them. He ('As'as) sent a messenger to them (to the members of his family). When they had assembled, Jundab came there with a yellow hooded cloak on him, He said: Talk what you were busy in talking. The talk went on by turns, till there came his (Jundab's) turn. He took off the hooded cloak from his head and said: I have come to you with no other intention but to narrate to you a hadith of your Apostle: Verily the Messenger of Allah (may peace be upon him) sent a squad of the Muslims to a tribe of the polytheists. Both the armies confronted one another. There was a man among the army of polytheists who (was so dashing that), whenever he intended to kill a man from among the Muslims, he killed him. Amongst the Muslims too was a man looking forward to (an opportunity of) his (the polytheist's) unmindfulness. He (the narrator) said: We talked that he was Usama b, Zaid. When he raised his sword, he (the soldier of the polytheists) uttered:" There is no god but Allah," but he (Usama b. Zaid) killed him. When the messenger of the glad tidings came to the Apostle (may peace be upon him) he asked him (about the events of the battle) and he informed him about the man (Usama) and what he had done He (the Prophet of Allah) called for him and asked him why he had killed him. He (Usama) said: Messenger of Allah, he struck the Muslims and killed such and such of them. And he even named some of them. (He continued): I attacked him and when he saw the sword he said: There is no god but Allah. The Messenger of Allah (may peace be upon him) said: Did you kill him? He (Usama) replied in the affirmative. He (the Holy Prophet) remarked: What would you do with:" There is no god but Allah," when he would come (before you) on the Day of Judgment? He (Usama) said: Messenger of Allah, beg pardon for me (from your Lord). He (the Holy Prophet) said: What would you do with:" There is no god but Allah" when he would come (before you) on the Day of Judgment? He (the Holy Prophet) added nothing to it but kept saying: What would you do with:" There is no god but Allah," when he would come (before you) on the Day of Judgment?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.179]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 179

It is narrated on the authority of Abdullah b. Umar who narrates from the Prophet of Allah (may peace be upon him) who said: He who took up arms against us is not of us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.180]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 180

Iyas b. Salama narrated from his father that the Apostle (may peace be upon him) observed: He who draws the sword against us is not of us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.181]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 181

It is narrated on the authority of Abu Musa Ash'ari: He who took up arms against us is not of us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.182]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 182

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who took up arms against us is not of us and he who acted dishonestly towards us is not of us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.183]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 183

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) happened to pass by a heap of eatables (corn). He thrust his hand in that (heap) and his fingers were moistened. He said to the owner of that heap of eatables (corn): What is this? He replied: Messenger of Allah, these have been drenched by rainfall. He (the Holy Prophet) remarked: Why did you not place this (the drenched part of the heap) over other eatables so that the people could see it? He who deceives is not of me (is not my follower).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.184]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 184

It is narrated on the authority of Abdullah b. Mas'ud that the Holy Prophet observed: He is not one of us (one among the Ummah of Islam) who beat the cheeks or tore the front opening of the shirt or uttered the slogans of (the days of) Jahiliya (ignorance). Ibn Numair and Abu Bakr said (instead of the word" au" (or) it is" wa" [and] the words are) and tore and uttered (the slogans) of Jahiliya without" alif".


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.185]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 185

This hadith has been narrated by A'mash with the same chain of narrators and the transmitters said: He tore and called.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.186]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 186

It is narrated on the authority of Abu Burda b. Abu Musa that Abu Musa was afflicted with grave pain and he became unconscious and his head was in the lap of a lady of his household. One of the women of his household walled. He (Abu Musa) was unable (because of weakness) to say anything to her. But when he was a bit recovered he said: I have no concern with one with whom the Messenger of Allah (may peace be upon him) has no concern, Verily the Messenger of Allah (may peace be upon him) has no concern with that woman who wails loudly, shaves her hair and tears (her garment in grief).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.187]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 187

It is narrated on the authority of Abu Burda that Abu Musa fell unconscious and his wife Umm Abdullah came there and wailed loudly. When he felt relief he said: Don't you know? -and narrated to her: Verily the Messenger of Allah (may peace be upon him) said: I have no concern with one who shaved her hair, lamented loudly and tore (her clothes in grief).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.188]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 188

This hadith is narrated on the authority of Abu Musa with this change only: That (the Holy Prophet) did not say that he had no concern but said: He is not one of us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.189]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 189

It is reported from Hudhaifa that news reached him (the Holy Prophet) that a certain man carried tales. Upon this Hudhaifa remarked: I heard Allah's Messenger (may peace be upon him) saying: The tale-bearer shall not enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.190]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 190

It is reported on the authority of Hammam b, al-Harith that a man used to carry tales to the governor. We were sitting in the mosque. the people said: He is one who carries tales to the governor. He (the narrator) said: Then he came and sat with us. Thereupon Hudhaifa remarked: I heard the Messenger of Allah (may peace be upon him) saying: The beater of false tales would never enter heaven.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.191]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 191

It is narrated on the authority of Hammam b. al-Harith: We were sitting with Hudhaifa in the mosque. A man came and sat along with us. It was said to Hudhaifa that he was the man who carried tales to the ruler. Hudhaifa remarked with the intention of conveying to him: I have heard the Messenger of Allah (may peace be upon him) saying: The tale-bearer will not enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.192]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 192

It is narrated o the authority of Abu Dharr that the Messenger of Allah (may ace he upon him) observed: Three are the (persons) with whom Allah would neither speak on the Day of Resurrection, nor would look at them nor would absolve the and there is a painful chastisement for them. The Messenger of Allah (may peace be upon him) repeated it three times. Abu Dharr remarked: They failed and they lost; who are these persons, Messenger of Allah? Upon this he (the Holy) Prophet) observed: They are: the dragger of lower garment, the recounter of obligation the seller of goods by false oath.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.193]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 193

It is narrated on the authority of Abu Dharr who narrates that the Prophet (may peace be upon him) observed: Three are the persons with whom Allah would not speak on the Day of Resurrection: the bestower of gift who does not give anything but by laying obligation on him, the seller of goods who sells them by taking false oath and one who hangs low his lower garment.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.194]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 194

Bishr b. Khalid has narrated this hadith on the authority of Sulaiman with the same chain of transmitters with this addition: Allah shall neither speak nor look at nor absolve then, and there is a tormenting punishment for them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.195]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 195

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Three (are the persons) with whom Allah would neither speak, nor would He absolve them on the Day of Resurrection. Abu Mu'awiya added: He would not look at them and there is grievous torment for them: the aged adulterer, the liar king and the proud destitute.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.196]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 196

Abu Huraira narrated on the authority of Abu Bakr that the Messenger of Allah (may peace be upon him) said: Three are the persons with whom Allah would neither speak on the Day of Resurrection, nor would He look towards them, nor would purify them (from sins), and there would be a tormenting chastisement for them: a person who in the waterless desert has more water (than his need) and he refuses to give it to the traveller and a person who sold a commodity to another person in the afternoon and took an oath of Allah that he had bought it at such and such price and he (the buyer) accepted it to be true though it was not a fact, and a person who pledged allegiance to the Imam but for the sake of the world (material gains). And if the Imam bestowed on him (something) out of that (worldly riches) he stood by his allegiance and if he did not give him, he did not fulfil the allegiance.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.197]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 197

The same hadith has been transmitted by another chain of transmitters with the exception of these words: He offered for sale a commodity to another person.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.198]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 198

This hadith has been narrated on the authority of Abu Huraira that he (the Apostle of Allah) observed: Three are the persons with whom Allah would neither speak (on the Day of Resurrection) nor would He look at them, and there would be a painful chastisement for them, a person who took an oath on the goods of a Muslim in the afternoon and then broke it. The rest of the hadith is the same as narrated by A'mash.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.199]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 199

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who killed himself with steel (weapon) would be the eternal denizen of the Fire of Hell and he would have that weapon in his hand and would be thrusting that in his stomach for ever and ever, he who drank poison and killed himself would sip that in the Fire of Hell where he is doomed for ever and ever; and he who killed himself by falling from (the top of) a mountain would constantly fall in the Fire of Hell and would live there for ever and ever.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.200]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 200

This hadith has been narrated by another chain of transmitters.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.201]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 201

Thabit b. Dahhak reported that he pledged allegiance to the Messenger of Allah (may peace be upon him) under the Tree, and verily the Messenger of Allah (may peace be upon him) observed: He who took an oath of a religion other than Islam, in the state of being a liar, would became so, as he professed. He who killed himself with a thing would be tormented on the Day of Resurrection with that very thing. One is not obliged to offer votive offering of a thing which is not in his possession.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.202]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 202

It is narrated on the authority of Thabit b. al-Dahhak that the Apostle of Allah (may peace be upon him) observes: None is obliged to give votive offering (of a thing) which is not in his possession and the cursing of a believer is tantamount to killing him, and he who killed himself with a thing in this world would be tormented with that (very thing) on the Day of Resurrection, and he who made a false claim to increase (his wealth), Allah would make no addition but that of paucity, and he who perjured would earn the wrath of God


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.203]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 203

It is narrated on the authority of Thabit b. Dahhak that the Apostle of Allah (may peace be upon him) observed: He who took deliberately a false oath on a religion other than Islam would become that which he had professed. And he who killed himself with anything Allah would torment him with that in the Fire of Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.204]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 204

In the hadith narrated by Shu'ba the words are: Verily the Messenger of Allah (may peace be upon him) said: He who took an oath on a religion other than Islam as a liar would become so as he said, and he who slaughtered himself with a thing would be slaughtered with that on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.205]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 205

It is narrated on the authority of Abu Huraira: We participated in the Battle of Hunain along with the Messenger of Allah (may peace be upon him). He (the Holy Prophet) said about a man who claimed to be a Muslim that he was one of the denizens of the Fire (of Hell). When we were in the thick of the battle that man fought desperately and was wounded. It was said: Messenger of Allah, the person whom you at first called as the denizen of Fire fought desperately and died. Upon this the Apostle of Allah (may peace be upon him) remarked: He was doomed to the Fire (of Hell). Some men were on the verge of doubt (about his fate) when it was said that he was not dead but fatally wounded. When it was night he could not stand the (pain of his) wound and killed himself. The Apostle (may peace be upon him) was informed of that. He (the Holy Prophet) observed: Allah is Great, I bear testimony to the fact that I am the servant of Allah and His messenger. He then commanded Bilal to announce to the people that none but a Muslim would enter Paradise. Verily Allah helps this faith even by a sinful person.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.206]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 206

It is reported on the authority of Sahl b. Sa'd al-Sa'idi that there was an encounter between the Messenger of Allah (may peace be upon him) and the polytheists, and they fought (against one another). At the conclusion of the battle the Messenger of Allah (may peace be upon him) bent his steps towards his army and they (the enemies) bent their steps towards their army. And there was a person (his name was Quzman and he was one of the hypocrites) among the Companions of the Messenger of Allah (may peace be upon him) who did not spare a detached (fighter of the enemy) but pursued and killed him with the sword. They (the Companions of the Holy Prophet) said: None served us better today than this man Upon this the Messenger of Allah (may peace be upon him) remarked: Verily he is one of the denizens of Fire. One of the people (Muslims) said: I will constantly shadow him. Then this man went out along with him. He halted whenever he halted, and ran along with him whenever he ran. He (the narrator) said: The man was seriously injured. He (could not stand the pain) and hastened his own death. He placed the blade of the sword on the ground with the tip between his chest and then pressed himself against the sword and killed himself. Then the man (following him) went to the Messenger of Allah (may peace be upon him) and said: I bear testimony that verily thou art the Messenger of Allah, He (the Holy Prophet) said: What is the matter? He replied: The person about whom you just mentioned that he was one among the denizens of Fire and the people were surprised (at this) and I said to them that I would bring (the news about him) and consequently I went out in search of him till I (found him ) to be very seriously injured. He hastened his death. He placed the blade of the sword upon the ground and its tip between his chest and then pressed himself against that and killed himself. Thereupon the Messenger of Allah (may peace be upon him) remarked: A person performs the deeds which to the people appear to be the deeds befitting the dweller of Paradise, but he is in fact one of the denizens of Hell. And verily a person does an act which in the eyes of public is one which is done by the denizens of Hell, but the person is one among the dwellers of Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.207]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 207

It is reported on the authority of Hasan: A person belonging to the people of the past suffered from a boil, when it pained him, he drew out an arrow from the quiver and pierced it. And the bleeding did not stop till he died. Your Lord said: I forbade his entrance into Paradise. Then he (Hasan) stretched his hand towards the mosque and said: By God, Jundab transmitted this hadith to me from the Messenger of Allah (may peace be upon him) in this very mosque.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.208]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 208

It is reported on the authority of Hasan: Jundab b. 'Abdullah al-Bajali narrated this hadith in this mosque which we can neither forget and at the same time we have no apprehension that Jundab could attribute a lie to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) observed: A person belonging to the people of the past suffered from a boil, and then the rest of the hadith was narrated.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.209]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 209

It is narrated on the authority of 'Umar b. Khattab that when it was the day of Khaibar a party of Companions of the Apostle (may peace be upon him) came there and said: So and so is a martyr, till they happened to pass by a man and said: So and so is a martyr. Upon this the Messenger of Allah remarked: Nay, not so verily I have seen him in the Fire for the garment or cloak that he had stolen from the booty, Then the Messenger of Allah (may peace be upon him) said: Umar son of Khattab, go and announce to the people that none but the believers shall enter Paradise. He ('Umar b. Khattab) narrated: I went out and proclaimed: Verily none but the believers would enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.210]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 210

It is narrated on the authority of Abu Huraira: We went to Khaibar along with the Apostle (may peace be upon him) and Allah granted us victory. We plundered neither gold nor silver but laid our hands on goods, corn and clothes, and then bent our stops to a valley; along with the Messenger of Allah (may peace be upon him) there was a slave who was presented to him by one Rifa'a b. Zaid of the family of Judham, a tribe of Dubayb. When we got down into the valley the slave of the Messenger of Allah stood up and began to unpack the saddle-bag and was suddenly struck by a (stray) arrow which proved fatal. We said: There is a greeting for him, Messenger of Allah, as he is a martyr. Upon this the Messenger of Allah (may peace be upon him) remarked: Nay, not so. By Him in Whose hand is the life of Muhammad, the small garment which he stole from the booty on the day of Khaibar but which did not (legitimately) fall to his lot is burning like the Fire (of Hell) on him. The people were greatly perturbed (on hearing this). A person came there with a lace or two laces and said: Messenger of Allah, I found (them) on the day of Khaibar. He (the Holy Prophet) remarked: This is a lace of fire or two laces of fire.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.211]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 211

It is narrated on the authority of Jabir that Tufail son of Amr al-Dausi came to the Apostle (may peace be upon him) and said: Do you need strong, fortified protection? The tribe of Daus had a fort in the pre-Islamic days. The Apostle (may peace be upon him) declined this offer, since it (the privilege of protecting the Holy Prophet) had already been reserved for the Ansar. When the Apostle (may peace be upon him) migrated to Medina, Tufail son of Amr also migrated to that place, and there also migrated along with him a man of his tribe. But the climate of Medina did not suit him, and he fell sick. He felt very uneasy. So he took hold of an iron head of an arrow and cut his finger-joints. The blood streamed forth from his hands, till he died. Tufail son of Amr saw him in a dream. His state was good and he saw him with his hands wrapped. He (Tufail) said to him: What treatment did your Allah accord to you? He replied. Allah granted me pardon for my migration to the Apostle (may peace be upon him): He (Tufail) again said: What is this that I see you wrapping up your hands? He replied: I was told (by Allah): We would not set right anything of yours which you damaged yourself. Tufail narrated this (dream) to the Messenger of Allah (may peace be upon him). Upon this he prayed: O Allah I grant pardon even to his hands.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.212]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 212

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Verily Allah would make a wind to blow from the side of the Yemen more delicate than silk and would spare none but cause him to die who, in the words of Abu 'Alqama, has faith equal to the weight of a grain; while Abdul-'Aziz said: having faith equal to the weight of a dust particle.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.213]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 213

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Be prompt in doing good deeds (before you are overtaken) by turbulence which would be like a part of the dark night. During (that stormy period) a man would be a Muslim in the morning and an unbeliever in the evening or he would be a believer in the evening and an unbeliever in the morning, and would sell his faith for worldly goods.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.214]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 214

It is narrated on the authority of Anas b. Malik that when this verse:" O ye who believe I raise not your voices above the voice of the Prophet, nor shout loud unto him in discourse, as ye shout loud unto one another, lest your deeds should become null and void, while you perceive not" (xlix. 2-5), was revealed. Thabit b. Qais confined himself in his house and said: I am one of the denizens of Fire, and he deliberately avoided coming to the Apostle (may peace be upon him). The Apostle (may peace be upon him) asked Sa'd b, Mu'adh about him and said, Abu Amr, how is Thabit? Has he fallen sick? Sa'd said: He is my neighbour, but I do not know of his illness. Sa'd came to him (Thabit), and conveyed to him the message of the Messenger of Allah (may peace be upon him). Upon this Thabit said: This verse was revealed, and you are well aware of the fact that, amongst all of you, mine is the voice louder than that of the Messenger of Allah, and so I am one amongst the denizens of Fire, Sa'd Informed the Holy Prophet about it. Upon this the Messenger of Allah observed: (Nay, not so) but he (Thabit) is one of the dwellers of Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.215]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 215

This hadith has been narrated on the authority of Anas b. Malik by another chain of transmitters in which these words are found: Thabit b. Qais was the orator of the Ansar, when this verse was revealed: the rest of the hadith is the same with the exception that there is no mention of Sa'd b. Mu'adh in it. This hadith is also transmitted by Ahmad b. Sa'id, Habban, Sulaiman b. Mughira on the authority of Anas who said: When the verse was revealed:" Do not raise your voice louder than the voice of the Apostle," no mention was made of Sa'd b, Mu'adh in it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.216]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 216

This hadith is narrated on the authority of Anas by another chain of transmitters in which there is no mention of Sa'd b. Mu'adh, but the following words are there: We observed a man, one of the dwellers of Paradise, walking about amongst us.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.217]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 217

It is narrated on the authority of Abdullah b. Mas'ud that some people said to the Messenger of Allah (may peace be upon him): Messenger of Allah, would we be held responsible for our deeds committed in the state of ignorance (before embracing Islam)? Upon his he (the Holy Prophet) remarked: He who amongst you performed good deeds in Islam, He would not be held responsible for them (misdeeds which he committed in ignorance) and he who committed evil (even after embracing Islam) would be held responsible or his misdeeds that he committed in the state of ignorance as well as in that of Islam.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.218]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 218

It is narrated on the authority of Abdullah b. Mas'ud: We once said: Messenger of Allah, would we be held responsible for our deeds committed in the state of ignorance? He (the Holy Prophet) observed: He who did good deeds in Islam would not be held responsible for what he did in the state of ignorance, but he who committed evil (after having come within the fold of Islam) would be held responsible for his previous and later deeds.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.219]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 219

This hadith has been transmitted by Minjab b. al-Harith Tamimi with the same chain of transmitters.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.220]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 220

It is narrated on the authority of Ibn Shamasa Mahri that he said: We went to Amr b. al-As and he was about to die. He wept for a long time and turned his face towards the wall. His son said: Did the Messenger of Allah (may peace be upon him not give you tidings of this? Did the Messenger of Allah (may peace be upon him) not give you tidings of this? He (the narrator) said: He turned his face (towards the audience) and said: The best thing which we can count upon is the testimony that there is no god but Allah and that Muhammad is the Apostle of Allah. Verily I have passed through three phases. (The first one) in which I found myself averse to none else more than I was averse to the Messenger of Allah (may peace be upon him) and there was no other desire stronger in me than the one that I should overpower him and kill him. Had I died in this state, I would have been definitely one of the denizens of Fire. When Allah instilled the love of Islam in my heart, I came to the Apostle (may peace be upon him) and said: Stretch out your right hand so that may pledge my allegiance to you. He stretched out his right hand, I withdrew my hand, He (the Holy Prophet) said: What has happened to you, O 'Amr? replied: I intend to lay down some condition. He asked: What condition do you intend to put forward? I said: should be granted pardon. He (the Holy Prophet) observed: Are you not aware of the fact that Islam wipes out all the previous (misdeeds)? Verily migration wipes out all the previous (misdeeds), and verily the pilgrimage wipes out all the (previous) misdeeds. And then no one as or dear to me than the Messenger of Allah and none was more sublime in my eyes than he, Never could I, pluck courage to catch a full glimpse of his face due to its splendour. So if I am asked to describe his features, I cannot do that for I have not eyed him fully. Had I died in this state had every reason to hope that I would have bee among the dwellers of Paradise. Then we were responsible for certain things (in the light of which) I am unable to know what is in store for me. When I die, let neither female mourner nor fire accompany me. When you bury me, fill my grave well with earth, then stand around it for the time within which a camel is slaughtered and its meat is distributed so that I may enjoy your intimacy and (in your company) ascertain what answer I can give to the messengers (angels) of Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.221]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 221

It is narrated on the authority of Ibn 'Abbas that some persons amongst the polytheist had committed a large number of murders and had excessively indulged in fornication. Then they came to Muhammad (may peace be upon him) and said: Whatever you assert and whatever you call to is indeed good. But if you inform us that there is atonement of our past deeds (then we would embrace Islam). Then it was revealed:

And those who call not unto another god along with Allah and slay not any soul which Allah has forbidden except in the cause of justice, nor commit fornication; and he who does this shall meet the requital of sin. Multiplied for him shall be the torment on the Day of Resurrection, and he shall therein abide disgraced, except him who repents a believes and does good deeds. Then these! for the Allah shall change their vices into virtues. Verily Allah is Ever Forgiving, Merciful (xxv. 68-70).

Say thou: O my bondsmen woo have committed extravagance against themselves despair not of the Mercy of Allah I Verily Allah will forgive the sins altogether. He is indeed the Forgiving, the Merciful (xxxix. 53).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.222]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 222

Hakim b. Hizam reported to 'Urwa b. Zubair that he said to the Messenger of Allah: Do you think that there is any thing for me (of he reward with the Lord) for the deed of religious purification that I did in the state of ignorance? Upon this he (the Apostle of Allah) said to him: You accepted Islam with all the previous virtues that you practised.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.223]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 223

Hakim b. Hizam reported to 'Urwa b. Zubair that he said to the Messenger of Allah (may peace be upon him): Messenger of Allah, do you think if there is any reward (of the Lord with me on the Day of Resurrection) for the deeds of religious purification that I performed in the state of ignorance, such as charity, freeing a slave, cementing of blood-relations? Upon this he (the Apostle of Allah) said to him: You have accepted Islam with all the previous virtues that you had practised.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.224]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 224

It is narrate on the authority of Hakim b. Hizam: I said: Messenger of Allah, I did so some of the deeds in the state of ignorance. (One of the transmitters Hisham b. Urwa explained them as acts of piety. Upon this the Messenger, of Allah remarked: You have embraced Islam with all the previous acts of virtue. I said: By God, I would leave nothing undone in Islam the like of which I did in the state of ignorance.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.225]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 225

Hisham b. Urwa narrated it on the authority of his father: Hakim b. Hizam freed one hundred slave and donated one hundred camels (for the sake of Allah) during the state of ignorance. Then he freed one hundred slaves and donated one hundred camel (for the sake of Allah) after) he had embraced Islam. He subsequently came to the Apostle (may peace be upon him). The rest of the hadith is the same as narrated above.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.226]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 226

It is narrated on the authority of 'Abdullah (b. Mas'ud) that when this verse was revealed:" It is those who believe and confound not their belief with wrongdoing" (vi. 82), the Companions of the Messenger of Allah wore greatly perturbed. They said: Who amongst us (is so fortunate) that he does not wrong himself? Upon this the Messenger of Allah (may peace be upon him) remarked: It does not mean that which you presume It implies that which Luqman said to his son: O my son, do not associate anything with Allah, for indeed it is the gravest wrongdoing (xxxi. 13).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.227]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 227

This hadith is narrated by another chain of transmitters, (namely) lshaq b. Ibrahim. Ibn Idris says: My father transmitted it from Aban b. Taghlib who heard it from A'mash; then I heard it also from him (A'mash).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.228]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 228

It is reported on the authority of Abu Huraira that when it was revealed to the Messenger of Allah (may peace be upon him): To Allah belongs whatever is in the heavens and whatever is in the earth and whether you disclose that which is in your mind or conceal it, Allah will call you to account according to it. Then He forgives whom He pleases and chastises whom He Pleases; and Allah is over everything Potent" (ii. 284). the Companions of the Messenger of Allah (may peace be upon him) felt it hard and severe and they came to the Messenger of Allah (may peace be upon him) and sat down on their knees and said: Messenger of Allah, we were assigned some duties which were within our power to perform, such as prayer, fasting, struggling (in the cause of Allah), charity. Then this (the above-mentioned) verse was revealed unto you and it is beyond our power to live up to it. The Messenger of Allah (may peace be upon him) said: Do you intend to say what the people of two books (Jews and Christians) said before you:" We hear and disobey"? You should rather say:" We hear and we obey, (we seek) Thy forgiveness, our Lord! and unto Thee is the return." And they said:" We hear and we obey, (we seek) Thy forgiveness, Our Lord! and unto Thee is the return." When the people recited it and it smoothly flowed on their tongues, then Allah revealed immediately afterwards:" The Apostle believes in that which is sent down unto him from his Lord, and so do the believers. Each one believes in Allah and His Angels and His Books and His Apostles, saying: We differentiate not between any of His Apostles and they say: We hearken and we obey: (we seek) Thy forgiveness, our Lord! and unto Thee is the return" (ii. 285). When they did that, Allah abrogated this (verse) and the Great, Majestic Allah revealed:" Allah burdens not a soul beyond its capacity. It gets every good that it earns and it suffers every ill that it earns. Our Lord, punish us not if we forget or make a mistake." (The Prophet said: ) Yes, our Lord! do not lay on us a burden as Thou didst lay on those before us. (The Prophet said: ) Yes, our Lord, impose not on us (burdens) which we have not the strength to bear (The Prophet said: ) Yes, and pardon us and grant us protection! and have mercy on us. Thou art our Patron, so grant us victory over the disbelieving people" (ii. 286). He (the Lord) said: Yes.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.229]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 229

It is narrated on the authority of Ibn 'Abbas: When this verse:" Whether you disclose that which is in your mind or conceal it, Allah will call you to account according to it" (ii 284), there entered in their minds something (of that fear) such as had never entered their hearts (before). The Apostle (may peace be upon him) observed: Say: We have heard and obeyed and submitted ourselves. He (the reporter) said: Allah instilled faith in their hearts and He revealed this verse:" Allah burdens not a soul beyond its capacity. It gets every good that it earns and it suffers every ill that it earns. Our Lord, call us not to account if we forget or make a mistake. He the (Lord) said: I indeed did it. Our Lord! do not lay on us a burden as Thou didst lay on those before us. He (our Lord) said: I indeed did it. And pardon us, have mercy on us. Thou art our Protector" (ii. 286). He said: I indeed did it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.230]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 230

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Verily Allah forgave my people the evil promptings which arise within their hearts as long as they did not speak about them or did not act upon them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.231]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 231

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Verily the Great and Mighty Allah forgave my people the evil promptings arising in their minds, but they neither talked about them nor acted upon them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.232]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 232

The same hadith has been narrated by Zuhair b. Harb, Waki, Ishaq b. Mansur, Husain b. 'Ali.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.233]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 233

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: The Great and the Glorious Lord said (to angels): Whenever My bondsman intends to corn it an evil, do not record it against him, but if he actually commits it, then write it as one evil. And when he intends to do good but does not do it, then take it down is one act of goodness, but if he does it, then write down ten good deeds (in his record).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.234]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 234

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: Allah, the Great and Glorious, said: Whenever my bondsman intends to do good, but does not do it, I write one good act for him, but if he puts it into practice I wrote from ten to seven hundred good deeds in favour of him. When he intends to commit an evil, but does not actually do it, do not record it. But if he does it, I write only one evil.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.235]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 235

Abu Huraira reported that Muhammad, the Messenger of Allah (may peace be upon him), said: When it occurs to my bondsman that he should do a good deed but he actually does not do it, record one good to him, but if he puts it into practice, I make an entry of ten good acts in his favour. When it occurs to him to do evil, but he does not commit it, I forgive that. But if he commits it, I record one evil against his name. The Messenger of Allah (may peace be upon him) observed. The angels said: That bondsman of Yours intends to commit evil. though His Lord is more Vigilant than he. Upon this He (the Lord) said: Watch him; if he commits (evil), write it against his name but if he refrains from doing it, write one good deed or him, for he desisted from doing it for My sake. The Messenger of Allah said: He who amongst you is good of faith, all his good acts are multiplied from ten to seven hundred times (and are recorded in his name) and all the evils that he commits are recorded as such (i, e. without increase) till he meets Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.236]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 236

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: He who intended to do good, but did not do it, one good was recorded for him, and he who intended to do good and also did it, ten to seven hundred good deeds were recorded for him. And he who intended evil, but did not commit it, no entry was made against his name, but if he committed that, it was recorded.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.237]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 237

It is narrated on the authority of Ibn Abbas that the Messenger of Allah (may peace be upon him) transmitted it from the Blessed and Great Lord: Verily Allah recorded the good and the evil and then made it clear that he who intended good but did not do it, Allah recorded one complete good in his favour, but if he intended it and also did it, the Glorious and Great Allah recorded ten to seven hundred virtues and even more to his credit. But it he intended evil, but did not commit it, Allah wrote down full one good in his favour. If he intended that and also committed it, Allah made an entry of one evil against him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.238]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 238

This hadith has been narrated with another chain of transmitters with the addition of these words: Allah would even wipe out (the evil committed by a man) and Allah does not put to destruction anyone except he who is doomed to destruction.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.239]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 239

It is narrated on the authority of Abu Huraira that some people from amongst the Companions of the Apostle (may peace be upon him) came to him and said: Verily we perceive in our minds that which every one of us considers it too grave to express. He (the Holy Prophet) said: Do you really perceive it? They said: Yes. Upon this he remarked: That is the faith manifest.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.240]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 240

The same hadith has been transmitted by Muhammad b. 'Amr, Abu Baker b. Ishaq, Abu'l-Jawwab, A'mash and Abu Huraira.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.241]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 241

It is narrated on the authority of 'Abdullah b. Mas'ud that the Apostle (may peace be upon him) was asked about evil prompting, to which he replied: It is pure faith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.242]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 242

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Men will continue to question one another till this is propounded: Allah created all things but who created Allah? He who found himself confronted with such a situation should say: I affirm my faith in Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.243]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 243

This hadith has been transmitted by Mahmud b. Ghailan by another chain of transmitters (and the words are): The Messenger of Allah (may peace be upon him) said: The Satan will come to everyone of you and say: Who created the heaven, who created the earth? (And the man) replies: It is Allah, Then the remaining part of the hadith was narrated as mentioned above and the words 'His prophets" were added to it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.244]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 244

It is narrated on the authority of Abu Huraira that the Messenger of Allah may peace be upon him) observed: The Satan comes to everyone. of you and says: Who created this and that? till he questions: Who created your Lord? When he comes to that, one should seek refuge in Allah and keep away (from such idle thoughts).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.245]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 245

This hadith is transmitted by Urwa b. Zubair on the authority of Abu Huraira (and the words are): The Satan comes to the bondsman (of Allah) and says: Who created this and that? The remaining part of the hadith is the same.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.246]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 246

It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) observed: People will constantly ask you questions pertaining to knowledge till they would say: Allah created us, but who created Allah? he (the narrator) says: he (Abu Huraira) was (at the time of narrating this hadith) catching hold of the hand of a man and he said: Allah and the Messenger told the truth. Two persons have already put me this question, and this is the third one, or he said: One man has put me this question and he is the second one.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.247]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 247

It is narrated on the authority of Abu Huraira that he said: The people will constantly, and the rest of the hadith is the same as that transmitted by 'Abdul-Warith with the exception that there is no mention of the Apostle of Allah in that, but he observed at the end of the hadith: Allah and His Messenger told the truth.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.248]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 248

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said to me: they (the people) till constantly ask you, Abu Huraira, (about different things pertaining to religion) the they would say: Well, there is Allah, but after all who created Allah? He (Abu Huraira) narrated: Once we were in the mosque that some of the Bedouins came there and said: Well, there is Allah, but who created Allah? He (the narrator) said: I took hold of the pebbles in my fist and flung at them and remarked: Stand up, stand up (go away) my friend (the Holy Prophet) told the truth.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.249]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 249

Yazid b. al-Asamm said: I heard Abu Huraira saying that the Messenger of Allah (may peace be upon him) observed: people will certainly ask you about everything till they will propound: Allah created every thing, but who created Allah?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.250]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 250

Anas b. Malik transmitted it from the Messenger of Allah (may peace be upon him) that the Great and Glorious Allah said: Verily your people would constantly question about this and that till they would say: Well, it is Allah Who created the creation, but who created Allah?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.251]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 251

This hadith has been narrated by another chain of transmitters with the exception that Ishaq made no mention of this: Allah said: Verily your people.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.252]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 252

It is narrated on the authority of Abu Umama that the Messenger of Allah (may peace be upon him) observed: He who appropriated the right of a Muslim by (swearing a false) oath, Allah would make Hell-fire necessary for him and would declare Paradise forbidden for him. A person said to him: Messenger of Allah, even if it is something insignificant? He (the Holy Prophet) replied: (Yes) even if it is the twig of the arak tree.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.253]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 253

This hadith has been transmitted by another chain of narrators: Abu Bakr b. Abi Shaiba, Ishaq b. Ibrahim, Harun b. Abdullah, Abi Usama, Walid b. Kathir, Muhammad b. Ka'b, his brother Abdullah b. Ka'b and Abi Usama.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.254]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 254

It is narrated on the authority of Abdullah (b. Umar) that the Messenger of Allah (may peace be upon him) observed: He who perjured with a view to appropriating the property of a Muslim, and he is in fact a liar and would meet Allah in a state that He would be angry with him. He (the narrator) said: There came Ash'ath b. Qais and said (to the people): What does Abu Abdur-Rahman (the Kunya of Abdullah b. Umar) narrate to you? They replied: So and so. Upon this he remarked: Abu Abdur-Rahman told the truth. This (command) has been revealed in my case. There was a piece of land in Yemen over which I and another person had a claim. I brought the dispute with him to the Apostle of Allah (to decide) He (the Holy Prophet) said: Can you produce an evidence (in your support)? I said: No. He (the Holy Prophet) observed: (Then the decision would be made) on his oath. I said: He would readily take an oath. Upon this the Messenger of Allah (may peace be upon him) remarked: He who perjured for appropriating the wealth of a Muslim, whereas he is a liar, would meet Allah while He would be angry with him. This verse was then revealed:" Verily those who barter Allah's covenant and their oaths at a small price..." (iii 77).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.255]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 255

It is narrated on the authority of Abdullah that he heard the Prophet (may peace be upon him) saying: He who took an oath in order to entitle himself (to the possession) of a property, whereas he is a liar, would meet Allah in a state that He would be very much angry with him. Then the remaining part of the hadith was narrated as transmitted by A'mash but with the exception of these words: There was a dispute between me and another person in regard to a well. We referred this dispute to the Messenger of Allah (may peace be upon him). Upon this he remarked: Either (you should produce) two witnesses (to support your contention) or his oath (would be accepted as valid).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.256]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 256

Ibn Mas'ud says: I heard the Messenger of Allah observing: He who took an oath on the property of a Muslim without legitimate right would meet Allah and He would be angry, with him. Then the Messenger of Allah (may peace be upon him) in support of his contention recited the verse:" Verily those who barter Allah's covenant and their oaths at a small price.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.257]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 257

It is narrated on the authority of Wa'il that there came a person from Hadramaut and another one from Kinda to the Apostle (may peace be upon him). One who had come from Hadramaut said: Messenger of Allah, only this man has appropriated my land which belonged to my father. The one who had came from Kinda contended. This is my land and is in my possession: I cultivate it. There is no right for him in it. The Messenger of Allah said to the Hadramite: Have you any evidence (to support you)? He replied in the negative. He (the Apostle of Allah) said: Then your case is to be decided on his oath. He (the Hadramite) said: Messenger of Allah, he is a liar and cares not what he swears and has no regard for anything. Upon this he (the Messenger of Allah) remarked: For you then there is no other help to it. He (the man from Kinda) set out to take an oath. When he turned his back the Messenger of Allah (may peace be upon him) observed: If he took an oath on his property with a view to usurping it, he would certainly meet his Lord in a state that He would turn away from him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.258]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 258

Wa'il reported it on the authority of his father Hujr: I was with the Messenger of Allah (may peace be upon him) that two men came there disputing over a piece of land. One of them said: Messenger of Allah, this man appropriated my land without justification in the days of ignorance. The (claimant) was Imru'l-Qais b. 'Abis al-Kindi and his opponent was Rabi'a b. 'Iban He (the Holy Prophet) said (to the claimant): Have you evidence (to substantiate your claim)? He replied: I have no evidence. Upon this he (the Messenger of Allah) remarked: Then his (that is of the defendant) is the oath. He (the claimant) said: In this case he (the defendant) would appropriate this (the property). He (the Holy Prophet) said: There is than no other way left for you but this. He (the narrator) said: When he (the defendant) stood up to take oath, the Messenger of Allah (may peace be upon him) said: He who appropriated the land wrongfully would meet Allah in a state that He would be angry with him. Ishaq in his narration mentions Rabi'a b. 'Aidan (instead of Rabi'a b. 'Ibdan).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.259]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 259

Abu Huraira reported: A person came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, what do you think if a man comes to me in order to appropriate my possession? He (the Holy Prophet) said: Don't surrender your possession to him. He (the inquirer) said: If he fights me? He (the Holy Prophet) remarked: Then fight (with him). He (the inquirer) again said: What do you think if I am killed? He (the Holy Prophet) observed: You would be a martyr. He (the inquirer) said: What do you think of him (Messenger of Allah) If I kill him. He (the Holy Prophet) said: he would be in the Fire.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.260]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 260

It is narrated on the authority of Thabit, that when 'Abdullah b. 'Amr and 'Anbasa b. Abi Sufyan were about to fight against each other, Khalid b. 'As rode to 'Abdullah b. 'Amr and persuaded him (not to do so). Upon this Abdullah b. 'Amr said: Are you not aware that the Messenger of Allah (may peace be upon him) had observed:" He who died in protecting his property is a martyr."

This hadith has been narrated by Muhammad b. Hatim, Muhammad b. Bakr, Ahmad b. 'Uthman Naufali, Abu 'Asim, Ibn Juraij.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.261]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 261

Hasan reported: 'Ubaidullah b. Ziyad paid a visit to Ma'qil b. Yasar Muzani in his illness of which he (later on) died. (At this juncture) Ma'qil said: I am going to narrate to you a hadith which I have heard from the Messenger of Allah (may peace be upon him) and which I would not have transmitted if I knew that I would survive. Verily I have heard the Messenger of Allah (may peace be upon him) say: There is none amongst the bondsmen who was entrusted with the affairs of his subjects and he died in such a state that he was dishonest in his dealings with those over whom he ruled that the Paradise is not forbidden for him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.262]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 262

Hasan reported: Ubaidullah b. Ziyad went to see Ma'qil b. Yasir and he was ailing. He ('Ubaidullah) inquired (about his health) to which he (Ma'qil) replied: I am narrating to you a hadith which I avoided narrating to you (before). Verily the Messenger of Allah (may peace be upon him) observed: Allah does not entrust to his bondsman the responsibility of managing the affairs of his subjects and he dies as a dishonest (ruler) but Paradise is forbidden by Allah for such a (ruler). He (Ibn Ziyad) said: Why did you not narrate it to me before this day? He replied: I (in fact) did not narrate it to you as it was not (fit) for me to narrate that to you.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.263]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 263

Hasan reported: We were with Ma'qil b. Yasar inquiring about his health that Ubaidullah b. Ziyad came there. Ma'qil said to him: Verily I am going to narrate to you a hadith which I heard from the Messenger of Allah (may peace be upon him). Then he narrated the hadith like those two (mentioned above).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.264]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 264

It is narrated on the authority of Abu Malih that Ubaidullah b. Ziyad visited Ma'qil b. Yasar in his illness. Ma'qil said to him: I am narrating to you a hadith which I would have never narrated to you had I not been in death-bed. I heard Allah's apostle (may peace be upon him) say: A ruler who has been entrusted with the affairs of the Muslims but he makes no endeavors ( for the material and moral uplift) and does not sincerely mean (their welfare) would not enter Paradise along with them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.265]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 265

Hudhaifa reported: The Messenger of Allah (may peace be upon him) narrated to us two ahadith. I have seen one (crystallized into reality), and I am waiting for the other. He told us: Trustworthiness descended in the innermost (root) of the hearts of people. Then the Qur'an was revealed and they learnt from the Qur'an and they learnt from the Sunnah. Then he (the Holy Prophet) told us about the removal of trustworthiness. He said: The man would have a wink of sleep and trustworthiness would be taken away from his heart leaving the impression of a faint mark. He would again sleep and trustworthiness would be taken away from his heart leaving an impression of a blister, as if you rolled down an ember on your foot and it was vesicled. He would see a swelling having nothing in it. He (the Holy Prophet) then took up a pebble and rolled it down over his foot and (said): The people would enter into transactions amongst one another and hardly a person would be left who would return (things) entrusted to him. (And there would be so much paucity of honest persons) till it would be said: There in such a such tribe is a trustworthy man. And they would also say about a person: How prudent he is, how broad-minded he is and how intelligent he is, whereas in his heart there would not be faith even to the weight of a mustard seed. I have passed through a time in which I did not care with whom amongst you I entered into a transaction, for if he were a Muslim his faith would compel him to discharge his obligations to me and it he were a Christian or a Jew, the ruler would compel him to discharge his obligations to me. But today I would not enter into a transaction with you except so and so.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.266]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 266

This hadith has been transmitted by another chain of transmitters: Ibn Numair, Waki', Ishaq b. Ibrahim, 'Isa b. Yunus on the authority of A'mash.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.267]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 267

It is narrated on the authority of Hudhaifa: We were sitting in the company of Umar and he said: Who amongst you has heard the Messenger of Allah (may peace be upon him) talking about the turmoil? Some people said: It is we who heard it. Upon this be remarked: Perhaps by turmoil you presume the unrest of man in regard to his household or neighbour, they replied: Yes. He ('Umar) observed: Such (an unrest) would be done away with by prayer, fasting and charity. But who amongst you has heard from the Apostle (may peace be upon him) describing that turmoil which would come like the wave of the ocean. Hudhaifa said: The people hushed into silence, I replied: It is I. He ('Umar) said: Ye, well, your father was also very pious. Hudhaifa said: I heard the Messenger of Allah (may peace be, upon him ) observing: Temptations will be presented to men's hearts as reed mat is woven stick by stick and any heart which is impregnated by them will have a black mark put into it, but any heart which rejects them will have a white mark put in it. The result is that there will become two types of hearts: one white like a white stone which will not be harmed by any turmoil or temptation, so long as the heavens and the earth endure; and the other black and dust-coloured like a vessel which is upset, not recognizing what is good or rejecting what is abominable, but being impregnated with passion. Hudhaifa said: I narrated to him ('Umar): There is between you and that (turmoil) a closed door, but there is every likelihood of its being broken. 'Umar said: Would it be broken? You have, been rendered fatherless. Had it been opened, it would have been perhaps closed also. I said: No, it would be broken, and I narrated to him: Verily that door implies a person who would be killed or die. There is no mistake in this hadith. Abu Khalid narrated: I said to Sa'd, O Abu Malik, what do you mean by the term" Aswad Murbadda"? He replied: High degree of whiteness in blackness. I said: What is meant by" Alkoozu Mujakhiyyan"? He replied: A vessel turned upside down.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.268]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 268

It is narrated on the authority of Rib'i (b. Hirash). When Hudhaifa came from 'Umar he sat down to narrate to us and said: Verily yesterday when I was sitting with the Commander of the believers he asked his companions: When amongst you retains in his memory the utterance of the Messenger of Allah (may peace be upon him) with regard to the turmoil? -and he cited the hadith like the hadith narrated on the authority of Abu Khalid, but he did not mention the exposition of his words (Murbaddan) and (Mujakhiyyan).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.269]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 269

It is transmitted by Rib'i b. Hirash. who narrated it on the authority of Hudhaifa that verily 'Umar said: Who would narrate to us or who amongst you would narrate to us (and Hudhaifa was one amongst them) what the Messenger of Allah (may peace be upon him) had said about the turmoil? Hudhaifa said: I will, and recited the hadith like that transmitted by Abu Malik on the authority of Rib'i and he observed in connection with this hadith that Hudhaifa remarked: I am narrating to you a hadith and it has no mistake, and said: That it is transmitted from he Messenger of Allah (may peace be upon him).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.270]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 270

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Islam initiated as something strange, and it would revert to its (old position) of being strange. so good tidings for the stranger.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.271]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 271

It is narrated on the authority of Ibn 'Umar ('Abdullah b. 'Umar) that the Messenger of Allah (may peace be upon him) observed: Verily Islam started as something strange and it would again revert (to its old position) of being strange just as it started, and it would recede between the two mosques just as the serpent crawls back into its hole.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.272]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 272

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Verily the faith would recede to Medina just as the serpent crawls back into its hole.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.273]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 273

It is narrated on the authority of Anas that verily the Messenger of Allah (may peace be upon him) observed: The Hour (Resurrection) would not come so long as Allah is supplicated in the world.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.274]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 274

It is narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) said: The Hour (Resurrection) would not come upon anyone so long as he supplicates Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.275]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 275

Hudhaifa reported: We were in the company of the Messenger of Allah (may peace be upon him) when he said. Count for me those who profess al-Islam. We said: Messenger of Allah, do you entertain any fear concerning us and we are (at this time) between six hundred and seven hundred (in strength). He (the Holy Prophet) remarked: You don't perceive; you may be put to some trial, He (the narrator) said: We actually suffered trial so much so that some of our men were constrained to offer their prayers in concealment.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.276]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 276

Sa'd narrated it on the authority of his father (Abi Waqqas) that he observed: The Messenger of Allah (may peace be upon him) distributed shares (of booty among his Companions). I said: Messenger of Allah! Give it to so and so, for verily he is a believer. Upon this the Apostle of Allah remarked: Or a Muslim. I (the narrator) repeated it (the word" believer" ) thrice and he (the Holy Prophet) turned his back upon me (and substituted the word)" Muslim," and then observed: I bestow it (this share) to a man out of apprehension lest Allah should throw him prostrate into the fire (of Hell) whereas in fact the other man is dearer to me than he.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.277]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 277

It is narrated on the authority of Sa'd that the Messenger of Allah (may peace be upon him) bestowed upon a group of persons (things), and Sa'd was sitting amongst them. Sa'd said: The Messenger of Allah (may peace be upon him) ignored some of them. And he who was ignored seemed to be more deserving in my eyes (as compared with others). I (Sa'd) said: Messenger of Allah I why is it that you did not give to such and such (man)? Verily I see him a believer. Upon this the Messenger of Allah (may peace be upon him) observed: Or a Muslim? I kept quiet for some time but I was again impelled (to express) what I knew about him. I said: Messenger of Allah why is it that you did not give it to such and such? Verily, by Allah, see him a believer. Upon this the Messenger of Allah (may peace be upon him) remarked: (Nay, not a believer) but a Muslim. He (Sa'd) said: I again kept quite for some time but what I knew about him again impelled me (to express my opinion) and I said: Why is it that you did not give (the share) to so and so: By Allah, verily I see him a believer. The Messenger of Allah (may peace be upon him) remarked; (Nay, not so) but a Muslim. Verily (at times) I give (a share) to a certain man apprehending that he may not be thrown prostrate in the Fire, whereas the other man (who is not given) is dearer to me (as compared with him).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.278]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 278

Sa'd reported: The Messenger of Allah (may peace be upon him) bestowed upon a group of persons (booty) and I was sitting with them. The remaining part of the hadith is the same as mentioned (above) with the additionI stood up and went to the Messenger of Allah (may peace be upon him) and whispered to him: Why did you omit such and such a man?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.279]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 279

The same hadith has been narrated on the authority of Muhammad b Sa'd and these words (are also there): The Messenger of Allah (may peace be upon him) gave a stroke on my neck or between my two shoulders and said: Sa'd, do you fight with me simply because I gave (a share) to a man?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.280]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 280

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: We have more claim to doubt than Ibrahim (may peace be upon him) when he said: My Lord! Show me how Thou wilt quicken the dead. He said: Believeth thou not? He said: Yes! But that my heart may rest at ease. He (the Holy Prophet) observed: May Lord take mercy on Lot, that he wanted a strong support, and had I stayed (in the prison) as long as Yusuf stayed, I would have responded to him who invited me.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.281]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 281

'Abdullah b. Muhammad narrated the same hadith on the authority of Abu Huraira and in the transmission by Malik the words are that he (the Holy Prophet) recited the verse:" but that my heart may rest at ease" and completed it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.282]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 282

This hadith has also been narrated by Abd b. Humaid Ya'qub, i. e. son of Ibrahim b. Sa'd, Abu Uwais, Zuhri, like the one narrated by Malik with the same chain of transmission and said: He recited this verse till he completed it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.283]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 283

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: There has never been a Prophet amongst the prophets who was not bestowed with a sign amongst the signs which were bestowed (on the earlier prophets). Human beings believed in it and verily I have been conferred upon revelation (the Holy Qur'an) which Allah revealed to me. I hope that I will have the greatest following on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.284]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 284

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: By Him in Whose hand is the life of Muhammad, he who amongst the community of Jews or Christians hears about me, but does not affirm his belief in that with which I have been sent and dies in this state (of disbelief), he shall be but one of the denizens of Hell-Fire.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.285]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 285

It is narrated on the authority of Sha'bi that one among the citizens of Khurasan asked him: 0 Abu! some of the people amongst us who belong to Khurasan say that a person who freed his bondswoman and then married her is like one who rode over a sacrificial animal. Sha'bi said: Abu Burda b. Abi Musa narrated it to me on the authority of his father that verily the Messenger of Allah (may peace be upon him) said: There are three (classes of persons) who would be given a double reward. One who is amongst the People of the Book and believed in his apostle and (lived) to see the time of Apostle Muhammad (may peace be upon him) and affirmed his faith in him and followed him and attested his truth, for him is the double reward; and the slave of the master who discharges all those obligations that he owes to Allah and discharges his duties that he owes to his master, for him there is a double reward. And a man who had a bondswoman and fed her and fed her well, then taught her good manners, and did that well and later on granted her freedom and married her, for him is the double reward. Then Sha'bi said: Accept this hadith without (giving) anything. Formerly a man was (obliged) to travel to Medina even for a smaller hadith than this.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.286]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 286

This hadith has been narrated by another chain of transmitters like Abu Bakr b. Abi Shaiba, 'Abda b. Sulaiman Ibn Abi 'Umar Sufyan, 'Ubaidullah b. Mu'adh, Shu'ba; all of them heard it from Salih b. Salih.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.287]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 287

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: By Him in Whose hand is my life, the son of Mary (may peace be upon him) will soon descend among you as a just judge. He will break crosses, kill swine and abolish Jizya and the wealth will pour forth to such an extent that no one will accept it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.288]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 288

The same hadith is transmitted from Zuhri with the same chain of transmission. But in the tradition narrated by Ibn 'Uyaina the words are:" impartial leader and just judge" and in the tradition narrated by Yunus: the" judge judging with justice" and" impartial leader" are not mentioned. And in the hadith narrated by Salih like the one transmitted by Laith the words are:" impartial judge". And in the hadith transmitted by Ziyad the words are:" Till one sajda is better than the worldand what it contains. Then Abu Huraira used to say," recite" if you like: Not one of the People of the Book will fail to believe in him before his death.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.289]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 289

It is narrated on the authority of Abu Huraira that the Messenger or Allah (may peace be upon him) observed: I swear by Allah that the son of Mary will certainly descend as a just judge and he would definitely break the cross, and kill swine and abolish Jizya and would leave the young she-camel and no one would endeavour to (collect Zakat on it). Spite, mutual hatred and jealousy against one another will certainly disappear and when he summons people to accept wealth, not even one would do so.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.290]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 290

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: What will be your state when the son of Mary descends amongst you and there will be an Imam amongst you?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.291]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 291

It is narrated on the authority of Abu Huraira that he heard the Messenger of Allah (may peace be upon him) as saying: What would you do when the son of Mary would descend and lead you?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.292]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 292

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: What would you do when the son of Mary would descend amongst you and would lead you as one amongst you? Ibn Abi Dhi'b on the authority of Abu Huraira narrated: Your leader amongst you. Ibn Abi Dhi'b said: Do you know what the words:" He would lead as one amongst you" mean? I said: Explain these to me. He said: He would lead you according to the Book of your: Lord (hallowed be He and most exalted) and the Sunnah of your Apostle (may peace be upon him).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.293]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 293

Jabir b. 'Abdullah reported: I heard the Messenger of Allah (may peace be upon him) say: A section of my people will not cease fighting for the Truth and will prevail till the Day of Resurrection. He said: Jesus son of Mary would then descend and their (Muslims') commander would invite him to come and lead them in prayer, but he would say: No, some amongst you are commanders over some (amongst you). This is the honour from Allah for this Ummah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.294]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 294

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: The (Last) Hour shall not came till the sun rises from the place of its setting And on the day when it rises from the place of its setting even if all the people together affirmed their faith, it would not be of any avail to one who did not believe previously and derived no good out of his belief.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.295]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 295

This hadith has been narrated by another chain of transmitters, Abu Bakr b. Abi Shaiba, Ibn Numair, Abu Kuraib, Ibn Fudail.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.296]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 296

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) observed: When three things appear faith will not benefit one who has not previously believed or has derived no good from his faith: the rising of the sun in its place of setting, the Dajjal, and the beast of the earth.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.297]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 297

It is narrated on the authority of Abu Dharr that the Messenger of Allah (may peace be upon him) one day said: Do you know where the sun goes? They replied: Allah and His Apostle know best. He (the Holy Prophet) observed: Verily it (the sun) glides till it reaches its resting place under the Throne. Then it falls prostrate and remains there until it is asked: Rise up and go to the place whence you came, and it goes back and continues emerging out from its rising place and then glides till it reaches its place of rest under the Throne and falls prostrate and remains in that state until it is asked: Rise up and return to the place whence you came, and it returns and emerges out from it rising place and the it glides (in such a normal way) that the people do not discern anything ( unusual in it) till it reaches its resting place under the Throne. Then it would be said to it: Rise up and emerge out from the place of your setting, and it will rise from the place of its setting. The Messenger of Allah (may peace be upon him) said. Do you know when it would happen? It would happen at the time when faith will not benefit one who has not previously believed or has derived no good from the faith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.298]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 298

It is narrated on the authority of Abu Dharr that the Apostle of Allah (may peace be upon him) one day said: Do you know where the sun goes? The remaining part of the hadith is the same.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.299]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 299

Abu Dharr reported: I entered the mosque and the Messenger of Allah (may peace be upon him) was sitting there. When the sun disappeared (from the sight) he said: O Abu Dharr! Do you know where it goes? He (the narrator) said: Allah and His Apostle know best. He (the Holy Prophet) said. Verily it goes and begs permission, for prostration (to Allah) and the permission is granted to it. Once it would be said: Return to the place whence you came, and then it would rise from its setting place. Then he, after the recitation of 'Abdullah recited it: And that is its appointed term.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.300]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 300

Abu Dharr reported: I asked the Messenger of Allah (may peace be upon him) the (implication of the) words of Allah, the Exalted: The sun glides to its appointed resting place. He replied: Its appointed resting place is under the Throne.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.301]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 301

A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: The first (form) with which was started the revelation to the Messenger of Allah was the true vision in sleep. And he did not see any vision but it came like the bright gleam of dawn. Thenceforth solitude became dear to him and he used to seclude himself in the cave of Hira', where he would engage in tahannuth (and that is a worship for a number of nights) before returning to his family and getting provisions again for this purpose. He would then return to Khadija and take provisions for a like period, till Truth came upon him while he was in the cave of Hira'. There came to him the angel and said: Recite, to which he replied: I am not lettered. He took hold of me [the Apostle said] and pressed me, till I was hard pressed; thereafter he let me off and said: Recite. I said: I am not lettered. He then again took hold of me and pressed me for the second time till I was hard pressed and then let me off and said: Recite, to which I replied: I am not lettered. He took hold of me and pressed me for the third time, till I was hard pressed and then let me go and said: Recite in the name of your Lord Who created, created man from a clot of blood. Recite. And your most bountiful Lord is He Who taught the use of pen, taught man what he knew not (al-Qur'an, xcvi. 1-4). Then the Prophet returned therewith, his heart was trembling, and he went to Khadija and said: Wrap me up, wrap me up! So they wrapped him till the fear had left him. He then said to Khadija: O Khadija! what has happened to me? and he informed her of the happening, saying: I fear for myself. She replied: It can't be. Be happy. I swear by Allah that He shall never humiliate you. By Allah, you join ties of relationship, you speak the truth, you bear people's burden, you help the destitute, you entertain guests, and you help against the vicissitudes which affect people. Khadija then took him to Waraqa b. Naufal b. Asad b. 'Abd al-'Uzza, and he was the son of Khadija's uncle, i. e., the brother of her father. And he was the man who had embraced Christianity in the Days of Ignorance (i. e. before Islam) and he used to write books in Arabic and, therefore, wrote Injil in Arabic as God willed that he should write. He was very old and had become blind Khadija said to him: O uncle! listen to the son of your brother. Waraqa b. Naufal said: O my nephew! what did you see? The Messenger of Allah (may peace be upon him), then, informed him what he had seen, and Waraqa said to him: It is namus that God sent down to Musa. Would that I were then (during your prophetic career) a young man. Would that I might be alive when your people would expel you! The Messenger of Allah (may peace be upon him) said: Will they drive me out? Waraqa said: Yes. Never came a man with a like of what you have brought but met hostilities. If I see your day I shall help you wholeheartedly.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.302]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 302

This hadith has been narrated on the authority of 'A'isha with another chain of narrators like one transmitted by Yunus, i. e. the first thing with which the revelation was initiated with the Messenger of Allah (may peace be upon him) except the words: By Allah, Allah would never humiliate you, and Khadija said: O son of my uncle! Listen to the son of your brother.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.303]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 303

This hadith has been reported from 'A'isha by another chain of transmitters and the words are: He (the Holy Prophet) came to Khadija an his heart was trembling. The rest of the hadith has been narrated like one transmitted by Yunus and Ma'mar, but the first part is not mentioned, i. e. the first thing with which was started the revelation to the Holy Prophet was the true vision. And these words like those transmitted by Yunus are mentioned thus: By Allah, Allah would never humiliate you. And there is also a mention of the words of Khadija: O son of my uncle! Listen to the son of your brother.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.304]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 304

Jabir b. 'Abdullah al-Ansari who was one of the Companions of the Messenger of Allah (may peace be upon him) reportedThe Messenger of Allah (may peace be upon him) told about the intermission of revelation and narrated While I was walking I heard a voice from the sky, and raising my head I saw the angel who had come to me in Hira', sitting on a Throne between heaven and earth I was terror-stricken on that account and came back (to my family) and said: Wrap me up, wrap me up! So they wrapped me up, and the Blessed and Most Exalted Allah sent down:" You who are shrouded, arise and deliver warning, your Lord magnify, your clothes cleanse, and defilement shun," and" defilement" means idols; and then the revelation was followed continuously.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.305]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 305

It is narrated on the authority of Jabir b. Abdullah that he heard the Messenger of Allah (may peace be upon him) says: The wahi was intermitted for me for a small span of time and while I was walking, and then the hadith like the one narrated by Yunus was transmitted but with the exception of these words: I was terror-stricken till I fell on the ground. Abu Salama said: Defilement means idols. After this the revelation was speeded up and followed rapidly.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.306]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 306

This hadith, the like of one narrated by Yunus has also been transmitted by Ma'mar on the authority of al-Zuhri who narrated: Allah the Most Glorious and Exalted revealed this:" You who are shrouded, arise and deliver warning, your Lord magnify, your clothes cleanse and defilement shun," before making the prayer obligatory. I felt terror-stricken as narrated by Uqail.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.307]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 307

Yahya reported: I asked Abu Salama what was revealed first from the Qur'an. He said:" 0, the shrouded one." I said: Or" Recite." Jabir said: I am narrating to you what was narrated to us by the Messenger of Allah (may peace be upon him). He said: I stayed in Hira' for one month and when my stay was completed, I come down and went into the heart of the valley. Somebody called me aloud. I looked in front of me, behind me, on the right of my side and on my left, but I did not see any body. I was again called and I looked about but saw nothing. I was called again and raised my head, and there on the Throne in the open atmosphere he, i. e. Gabriel (peace be upon him) was sitting. I began to tremble on account of fear. I came to Khadija and said: Wrap me up. They wrapped me up and threw water on me and Allah, the Exalted and Glorious, sent down this: you who are shrouded! arise and deliver warning, your Lord magnify, your clothes cleanse."


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.308]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 308

Yahya b Abi Kathir has reported this hadith with the same chain of transmitters and narrated: And there he was sitting on the Throne between the heaven and the earth.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.309]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 309

It is narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: I was brought al-Buraq Who is an animal white and long, larger than a donkey but smaller than a mule, who would place his hoof a distance equal to the range of version. I mounted it and came to the Temple (Bait Maqdis in Jerusalem), then tethered it to the ring used by the prophets. I entered the mosque and prayed two rak'ahs in it, and then came out and Gabriel brought me a vessel of wine and a vessel of milk. I chose the milk, and Gabriel said: You have chosen the natural thing. Then he took me to heaven. Gabriel then asked the (gate of heaven) to be opened and he was asked who he was. He replied: Gabriel. He was again asked: Who is with you? He (Gabriel) said: Muhammad. It was said: Has he been sent for? Gabriel replied: He has indeed been sent for. And (the door of the heaven) was opened for us and lo! we saw Adam. He welcomed me and prayed for my good. Then we ascended to the second heaven. Gabriel (peace be upon him) (asked the door of heaven to be opened), and he was asked who he was. He answered: Gabriel; and was again asked: Who is with you? He replied: Muhammad. It was said: Has he been sent for? He replied: He has indeed been sent for. The gate was opened. When I entered 'Isa b. Maryam and Yahya b. Zakariya (peace be upon both of them), cousins from the maternal side. welcomed me and prayed for my good Then I was taken to the third heaven and Gabriel asked for the opening (of the door). He was asked: Who are you? He replied: Gabriel. He was (again) asked: Who is with you? He replied Muhammad (may peace be upon him). It was said: Has he been sent for? He replied He has indeed been sent for. (The gate) was opened for us and I saw Yusuf (peace of Allah be upon him) who had been given half of (world) beauty. He welcomed me prayed for my well-being. Then he ascended with us to the fourth heaven. Gabriel (peace be upon him) asked for the (gate) to be opened, and it was said: Who is he? He replied: Gabriel. It was (again) said: Who is with you? He said: Muhammad. It was said: Has he been sent for? He replied: He has indeed been sent for. The (gate) was opened for us, and lo! Idris was there. He welcomed me and prayed for my well-being (About him) Allah, the Exalted and the Glorious, has said:" We elevated him (Idris) to the exalted position" (Qur'an xix. 57). Then he ascended with us to the fifth heaven and Gabriel asked for the (gate) to be opened. It was said: Who is he? He replied Gabriel. It was (again) said: Who is with thee? He replied: Muhammad. It was said Has he been sent for? He replied: He has indeed been sent for. (The gate) was opened for us and then I was with Harun (Aaron-peace of Allah be upon him). He welcomed me prayed for my well-being. Then I was taken to the sixth heaven. Gabriel (peace be upon him) asked for the door to be opened. It was said: Who is he? He replied: Gabriel. It was said: Who is with thee? He replied: Muhammad. It was said: Has he been sent for? He replied: He has indeed been sent for. (The gate) was opened for us and there I was with Musa (Moses peace be upon him) He welcomed me and prayed for my well-being. Then I was taken up to the seventh heaven. Gabriel asked the (gate) to be opened. It was said: Who is he? He said: Gabriel It was said. Who is with thee? He replied: Muhammad (may peace be upon him.) It was said: Has he been sent for? He replied: He has indeed been sent for. (The gate) was opened for us and there I found Ibrahim (Abraham peace be upon him) reclining against the Bait-ul-Ma'mur and there enter into it seventy thousand angels every day, never to visit (this place) again. Then I was taken to Sidrat-ul-Muntaha whose leaves were like elephant ears and its fruit like big earthenware vessels. And when it was covered by the Command of Allah, it underwent such a change that none amongst the creation has the power to praise its beauty.

Then Allah revealed to me a revelation and He made obligatory for me fifty prayers every day and night. Then I went down to Moses (peace be upon him) and he said: What has your Lord enjoined upon your Ummah? I said: Fifty prayers. He said: Return to thy Lord and beg for reduction (in the number of prayers), for your community shallnot be able to bear this burden. as I have put to test the children of Isra'il and tried them (and found them too weak to bear such a heavy burden). He (the Holy Prophet) said: I went back to my Lord and said: My Lord, make things lighter for my Ummah. (The Lord) reduced five prayers for me. I went down to Moses and said. (The Lord) reduced five (prayers) for me, He said: Verily thy Ummah shall not be able to bear this burden; return to thy Lord and ask Him to make things lighter. I then kept going back and forth between my Lord Blessed and Exalted and Moses, till He said: There are five prayers every day and night. O Muhammad, each being credited as ten, so that makes fifty prayers. He who intends to do a good deed and does not do it will have a good deed recorded for him; and if he does it, it will be recorded for him as ten; whereas he who intends to do an evil deed and does not do, it will not be recorded for him; and if he does it, only one evil deed will be recorded. I then came down and when I came to Moses and informed him, he said: Go back to thy Lord and ask Him to make things lighter. Upon this the Messenger of Allah remarked: I returned to my Lord until I felt ashamed before Him.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.310]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 310

It is narrated on the the outhority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: (the angels) came to me and took me to the Zamzam and my heart was opened and washed with the water of Zamzam and then I was left (at my place).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.311]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 311

Anas b. Malik reported that Gabriel came to the Messenger of Allah (may peace be upo him) while he was playing with his playmates. He took hold of him and lay him prostrate on the ground and tore open his breast and took out the heart from it and then extracted a blood-clot out of it and said: That was the part of Satan in thee. And then he washed it with the water of Zamzam in a golden basin and then it was joined together and restored to it place. The boys came running to his mother, i. e. his nurse, and said: Verily Muhammad has been murdered. They all rushed toward him (and found him all right) His color was changed, Anas said. I myself saw the marks of needle on his breast.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.312]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 312

Anas b. Malik, while recountig the Night journey of the Holy Prophet (may peace be upon him), from the mosque of Ka'bah, reported: Three beings (angels) came to him in the osque of the Ka'bah, while he was sleeping in the sacred mosque before it (the Command of Night Journey and Accension) was revealed to him. The rest of the hadith is narrated like that of Thabit. However, some portions have occurred before and some of them have occurred after; some have been added and some deleted.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.313]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 313

Anas b. Malik reported: Abu Dharr used to relate that the Messenger of Allah (may peace be upon him) said: The roof of my house was cleft when I was in Mecca and Gabriel descended and opened my heart and then washed it with the water of Zamzam. He then brought a gold basin full of wisdom and faith and after emptying it into my breast, he closed it up. Then taking me by he hand, he ascended with me to th heaven, and when we came to the lowest heaven, Gabriel said to the guardian of the lowest heaven: Open. He asked who was there? He replied. It is Gabriel. He again asked whe he there was someone with him. He replied: Yes, it is Muhammad with me. He was asked if he had been sent for, He (Gabriel) said: Yes. Then he opened (the gate). When we ascended the lowest heaven (I saw) a man seated with parties on his right side and parties on his left side. When he looked up to his right, he laughed and when he looked to his left, he wept. He said: Welcome to the righteous apostle and the righteous son. I asked Gabriel who he was and he replied: He is Adam (peace be upon him) and these parties on his right and on his left are the souls of his descendants. Those of them on his right are the inmates of Paradise and the parties which are on his left side are the inmates of Hell; so when he looked towards his right side, he laughed, and when he looked towards his left side, he wept. Then Gabriel ascended with me to the second heaven. He asked its guardian to open (its gate), and its guardian replied in the same way as the guardian of the lowest heaven had said. He (opened it). Anas b. Malik said: He (the Holy Prophet) mentioned that he found in the heavens Adam, Idris, Jesus, Moses and Abraham (may peace be on all of them), but he did not ascertain as to the nature of their abodes except that he had found Adam in the lowest heaven and Abraham in the sixth heaven. When Gabriel and the Messenger of Allah (may peace be upon him) passed by Idris (peace be upon him) he said: Welcome to the righteous apostle and righteous brother. He (the narrator) said: He then proceeded and said: Who is he? Gabriel replied: It is Idris. Then I passed by Moses (peace be upon him) and he said: Welcome tothe righteous apostle and righteous brother. I said to (Gabriel): Who is he? He replied: It is Moses. Then I passed by Jesus and he said: Welcome to the righteous apostle and righteous brother. I said (to Gabriel): Who is he? He replied: Jesus, son of Mary. He (the Holy Prophet) said: Then I went to Ibrahim (peace be upon him). He said: Welcome to the righteous apostle and righteous son. I asked: Who is he? He (Gabriel) replied: It is Abraham. Ibn Shihab said: Ibn Hazm told me that Ibn 'Abbas and Abd Habba al-Ansari used to say that the Messenger of Allah (may peace be upon him) said: Thereafter he ascended with me till I was taken to such a height where I heard the scraping of the pens. Ibn Hazm and Anas told that the Messenger of Allah (may peace be upon him) said: Allah then made fifty prayers obligatory for my Ummah and I returned with that and passed by Moses. Moses, (peace be upon him) said: What has thy Lord enjoined on thy people? I said: Fifty prayers have been made obligatory on them. Moses (peace be upon him) said: Return to thy Lord, for thy Ummah would not be able to bear this burden. Then I came back to my Lord and He remitted a portion out of thut. I then again went to Moses (peace be upon him) and informed him about it He said: Return to thy Lord, for thy Ummah shall not be able to bear this burden. I then went back to my Lord and He said: They are five and at the same time fifty, and what has been said will not be changed. I then returned to Moses and he said: Go back to thy Lord. whereupon I said: I feel ashamed of my Lord. Gabriel then travelled with me till we came to the farthest lote-tree Many a colour had covered it which I do not know. Then I was admitted to Paradise and saw in it domes of pearls, and its soil of musk.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.314]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 314

Anas b. Malik reported on the authority of Malik b. Sa sa', perhaps a person of his tribe, that the Prophet of Allah (may peace be upon him) said: I was near the House (i. e. Ka'bah) in a state between sleep and wakefulness when I heard someone say: He is the third among the two persons. Then he came to me and took me with him. Then a golden basin containing the water of Zamzam was brought to me and my heart was opened up to such and such (part). Qatada said: I asked him who was with me (i e. the narrator) and what he meant by such and such (part). He replied: (It means that it was opened) up to the lower part of his abdomen (Then the hadith continues): My heart was extracted and it was washed with the water of Zamzam and then it was restored in its original position, after which it was filled with faith and wisdom. I was then brought a white beast which is called al-Buraq, bigger than a donkey and smaller than a mule. Its stride was as long as the eye could reach. I was mounted on it, and then we went forth till we reached the lowest heaven. Gabriel asked for the (gate) to be opened, and it was said: Who is he? He replied: Gabriel. It was again said: Who is with thee? He replied: Muhammad (may peace be upon him). It was said: Has he been sent for? He (Gabriel) said: Yes. He (the Prophet) said: Then (the gate) was opened for us (and it was said): Welcome unto him! His is a blessed arrival. Then we came to Adam (peace be upon him). And he (the narrator) narrated the whole account of the hadith. (The Holy Prophet) observed that he met Jesus in the second heaven, Yahya (peace be on both of them) in the third heaven, Yusuf in the third, Idris in the fourth, Harun in the fifth (peace and blessings of Allah be upon them). Then we travelled on till we reached the sixth heaven and came to Moses (peace be upon him) and I greeted him and he said: Welcome unto righteous brother and righteous prophet. And when I passed (by him) he wept, and a voice was heard saying: What makes thee weep? He said: My Lord, he is a young man whom Thou hast sent after me (as a prophet) and his followers will enter Paradise in greater numbers than my followers. Then we travelled on till we reached the seventh heaven and I came to Ibrahim. He (the narrator) narrat- ed in this hadith that the Prophet of Allah (may peace be upon him) told that he saw four rivers which flowed from (the root of the lote-tree of the farthest limits): two manifest rivers and two hidden rivers. I said: ' Gabriel! what are these rivers? He replied: The two hidden rivers are the rivers of Paradise, and as regards the two manifest ones, they are the Nile and the Euphrates. Then the Bait-ul-Ma'mur was raised up to me. I said: O Gabriel! what is this? He replied: It is the Bait-ul-Ma'mur. Seventy thousand angels enter into it daily and, after they come out, they never return again. Two vessels were then brought to me. The first one contained wine and the second one contained milk, and both of them were placed before me. I chose milk. It was said: You did right. Allah will guide rightly through you your Ummah on the natural course. Then fifty prayers daily were made obligatory for me. And then he narrated the rest of the hadith to the end.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.315]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 315

It is reported on the authority of Malik b. Sa'sa' that the Messenger of Allah (may peace be upon him) narrated the hadith (mentioned above) and added to it: I was brought a gold basin full of wisdom and faith, and then the (part of the body) right from the upper end of the chest to the lower part of the abdomen was opened and it was washed with the water of Zamzam and then flled with wisdom and faith.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.316]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 316

Qatada reported that he heard Abu al-'Aliya saying that the cousin of your Prophet (may peace be upon him), i. e. Ibn Abbas, told him: The Messenger of Allah (may peace be upon him), while narrating his night journey observed: Musa (peace be upon him) was a man of high stature as if he was of the people of the Shanu'a (tribe), and Jesus was a well-built person having curly hair. He also mentioned Malik, the guardian of Hell, and Dajjal.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.317]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 317

Abu al-'Aliya reported: Ibn Abbas, the son of your Prophet's uncle, told us that the Messenger of Allah (may peace be upon him) had observed: On the night of my night journey I passed by Moses b. 'Imran (peace be upon him), a man light brown in complexion, tall. well-built as if he was one of the men of the Shanu'a, and saw Jesus son of Mary as a medium-statured man with white and red complexion and crisp hair, and I was shown Malik the guardian of Fire, and Dajjal amongst the signs which were shown to me by Allah. He (the narrator) observed: Then do not doubt his (i. e. of the Holy Prophet) meeting with him (Moses). Qatada elucidated it thus: Verily the Apostle of Allah (may peace be upon him), met Moses (peace be upon him).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.318]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 318

Abu al-'Aliya narrated it on the authority of Ibn 'Abbas that the Messenger of Allah (may peace be upon him) passed through the valley of Azraq, and he asked: Which valley is this? They said: This is the valley of Azraq, and he observed: (I perceive) as if I am seeing Moses (peace be upon him) coming down from the mountain track, and he is calling upon Allah loudly (saying: Here I am! at your service! ). Then he came to the mountain track of Harsha. He (the Holy Prophet) said: Which is this mountain track? They said: It is the mountain track of Harsha. He observed (I feel) as If I am seeing Yunus (Jonah-peace be upon him) son of Matta on a well- built red dromedary, with a cloak of wool around him and the rein of his dromedary is made of the fibres of date-palm, and he is calling upon Allah (saying: Here I am! at your service, my Lord! ). Ibn Hanbal said in the hadith narrated by him: Hushaim said that the meaning of khulba was fibre of date-palm.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.319]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 319

Abu al-'Aliya narrated it on the authority of Ibn 'Abbas that he said: We travelled with the Messenger of Allah (may peace be upon him) between Mecca and Medina and we passed by a valley. He (the Holy Prophet) asked: Which valley is this? They said: This is the valley of Azraq Upon this he (the Holy Prophet) remarked: (I feel) as if I am seeing Moses (peace be upon him), and then he described something about his complexion and hair, which Diwud (the narrator) could not remember. He (Moses, as described by the Holy Prophet) was keeping his fingers in his ears and was responding loudly to Allah (saying: I am as Thy service, my Lord) while passing through that valley. We then travelled (further) till we came to the mountain trail. He (the Holy Prophet) said: Which mountain trail is this? They said: It is the Harsha or Lift. He (the Holy Prophet) said: (I perceive) as if I am seeing Yunus on a red camel, with a cloak of wool around him. The halter of his camel was that of the fibre of date-palm, and he was passing through the valley saying: I am at Thy service! my Lord.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.320]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 320

It is narrated on the authority of Mujahid that he said: We were with Ibn 'Abbas and (the people) talked about al-Dajjal. (One of them remarked. There is written between his eyes (the word) Kafir (infidel). The narrator said: Ibn 'Abbas remarked: I did not hear him (the Holy Prophet) say it, but he said: So far as Ibrahim is concerned. you may see your companion and so far as Moses is concerned, he is a well-built man with wheat complexion (riding) on a red camel with its halter made of the fibre of date-palm (and I perceive) as if I am seeing towards him as he is going down in the valley saying: I am at Thy service! my Lord.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.321]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 321

It is narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: There appeared before me the apostles, and Moses was among men as if he was one of the people of Shanu'a, and I saw Jesus son of Mary (peace be upon him) and I saw nearest in resemblance with him was 'Urwa b. Mas'ud, and I saw Ibrahim (blessings of Allah be upon him) and I see your companions much in resemblance with him, i. e. his personality, and I saw Gabriel (peace be upon him) and I saw Dihya nearest in resemblance to him; but in the narration of Ibn Rumh it is Dihya b. Khalifa.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.322]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 322

It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) said: When I was taken for the night journey I met Moses peace be upon him). The Apostle of Allah (may peace be upon him) gave his description thus: He was a man, I suppose-and he (the narrator) was somewhat doubtful (that the Holy Prophet observed): (Moses) was a man erect in stature with straight hair on his head as it he was one of the men of the Shanu'a; and I met Jesus and the Apostle of Allah (may peace be upon him) described him as one having a medium stature and a red complexion as if he had (just) come out of the bath He observed: I saw Ibrahim (peace be upon him) and amongst his children I have the greatest resemblance with him. He said: There were brought to me two vessels. In one of them was milk and in the other one there was wine. And it was said to me: Select any one you like. So I selected the vessel containing milk and drank it. He (the angel) said: You have been guided on al-fitra or you have attained al-fitra. Had you selected wine, your Ummah would have been misled.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.323]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 323

It is narrated on the authority of 'Abdullah b. Umar that the Messenger of Allah (may peace be upon him) said: I found myself one night near the Ka'bah, and I saw a man with wheat complexion amongst the fair-complexioned men that you ever saw. He had a lock of hair the most beautiful of the locks that you ever saw. He had combed it. Water was trickling out of them. He was leaning on two men, or on the shoulders of two men, and he was circumscribing the Ka'bah. I asked, What is he? It was said: He is al-Masih son of Mary. Then I saw another person, stout and having too much curly hair, and blind in his right eye as if it was a full swollen grape. I asked Who is he? It was said: He is al-Masih al-Dajjal.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.324]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 324

It is narrated on the authority of 'Abdulldh b. Umar that one day the Messenger of Allah (may peace be upon him) mentioned in the presence of people about al-Masih al-Dajjal. He said: Verily Allah (hallowed be He and High) is not blind of one eye. Behold, but the Masih al-Dajjal is blind of right eye as if his eye is like a swollen grape, and the Messenger of Allah (may peace be upon him) said: I was shown in a dream in the night that near the Ka'bah there was a man fair-complexioned, fine amongst the white-complexioned men that you ever saw, his locks of hair were falling on his shoulders. He was a man whose hair were neither too curly nor too straight, and water trickled down from his head. He was placing his bands on the shoulders of two persons and amidst them was making a circuit around the Ka'bah. I said: Who is he? They replied: Al-Masih son of Mary. And I saw behind him a man with intensely curly hair, blind of right eye. Amongst the persons I have ever seen Ibn Qatan has the greatest resemblance with him. He was making a circuit around the Ka'bah by placing both his hands on the shoulders of two persons. I said: Who is he? They said; It is al-Masih al-Dajjal.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.325]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 325

It is narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: I saw near the Ka'bah a man of fair complexion with straight hair, placing his hands on two persons. Water was flowing from his head or it was trickling from his head. I asked: Who is he? They said: He is Jesus son of Mary or al-Masih son of Mary. The narrator) says: I do not remember which word it was. He (the Holy Prophet) said: And I saw behind him a man with red complexion and thick curly hair, blind in the right eye. I saw in him the greatest resemblance with Ibn Qitan I asked: Who is he? They replied: It is al-Masih al-Dajjal.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.326]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 326

It is narrated on the authority of Jabir b. 'Abdullah that the Messenger of Allah (may peace be upon him) said: When the Quraish belied me, I was staying in Hatim and Allah lifted before me Bait-ul-Maqdis and I began to narrate to them (the Quraish of Mecca) its signs while I was in fact looking at it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.327]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 327

'Abdullah reported on the authority of his father 'Umar b. Khattab that he heard from the Messenger of Allah (may peace he upon him) say: I was sleeping when I saw myself making circuit around the Ka'bah, and I saw there a man of fair complexion with straight hair between two men. Water was flowing from his head or water was falling from his head. I said: Who is he? They answered: He is the son of Mary. Then I moved forward and cast a glance and there was a bulky man of red complexion with thick locks of hair on his head, blind of one eye as it his eye was a swollen grape. I asked: Who is he? They said: He is Dajjal. He had close resemblance with Ibn Qatan amongst men.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.328]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 328

It is narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: I found myself in Hijr and the Quraish were asking me about my might journey. I was asked about things pertaining to Bait-ul-Maqdis which I could not preserve (in my mind). I was very much vexed, so vexed as I had never been before. Then Allah raised it (Bait-ul-Maqdis) before my eyes. I looked towards it, and I gave them the information about whatever they questioned me I also saw myself among the group of apostles. I saw Moses saying prayer and found him to be a well-built man as if he was a man of the tribe of Shanu'a. I saw Jesus son of Mary (peace be upon him) offering prayer, of all of men he had the closest resemblance with 'Urwa b. Masu'd al-Thaqafi. I saw Ibrahim (peace be upon him) offering prayer; he had the closest resemblance with your companion (the Prophet himself) amongst people. When the time of prayer came I led them. When I completed the prayer, someone said: Here is Malik, the keeper of the Hell; pay him salutations. I turned to him, but he preceded me in salutation.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.329]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 329

It is narrated on the authority of Abdullah (b. Umar) that when the Messenger of Allah (may peace be upon him) was taken for the Night journey, he was taken to Sidrat-ul-Muntaha, which is situated on the sixth heaven, where terminates everything that ascends from the earth and is held there, and where terminates every- thing that descends from above it and is held there. (It is with reference to this that) Allah said:" When that which covers covered the lote-tree" (al-Qur'an, Iiii. 16). He (the narrator) said: (It was) gold moths. He (the narrator further) said: The Messenger of Allah (may peace be upon him) was given three (things): he was given five prayers, be was given the concluding verses of Sura al-Baqara, and remission of serious Sins for those among his Ummah who associate not anything with Allah


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.330]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 330

Al-Shaibini reported to us: I asked Zirr b. Hubaish about the words of Allah (the Mighty and Great):" So he was (at a distance) of two bows or nearer" (al-Qur'an, Iiii 8). He said: Ibn Mas'ud informed me that, verily, the Apostle of Allah (may peace be upon him) saw Gabriel and he had six hundred wings.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.331]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 331

Al-Shaibani narrated on the authority of Zirr who narrated it on this authority of Abdullah that the (words of Allah):" The heart belied not what he saw" (al Qur'an, Iiii. 11) imply that he saw Gabriel (peace be upon him) and he had six hundred wings.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.332]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 332

Zirr b. Hubaish narrated it on the authority of 'Abdullah (that the words of Allah):" Certainly he saw of the greatest signs of Allah" (al-Qur'an, liii. 18) imply that he saw Gabriel in his (original) form and he had six hundred wings.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.333]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 333

It is narrated on the authority of Abu Huraira that the (words of Allah):" And certainly he saw him in another descent" (al-Qur'an, Iiii. 13) imply that he saw Gabriel.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.334]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 334

It is narrated on the authority of Ibn 'Abbas that he (the Holy Prophet) saw (Allah) with, his heart.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.335]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 335

It is narrated on the authority of Ibn Abbas that the words:" The heart belied not what he saw" (al-Qur'an, Iiii. 11) and" Certainly he saw Him in another descent" (al-Qur'an, Iiii. 13) imply that he saw him twice with his heart.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.336]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 336

Abu Bakr b. Abi Shaiba narrated it on the same authorities.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.337]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 337

It is narrated on the authority of Masruq that he said: I was resting at (the house of) 'A'isha that she said: O Abu 'A'isha (kunya of Masruq), there are three things, and he who affirmed even one of them fabricated the greatest lie against Allah. I asked that they were. She said: He who presumed that Muhammad (may peace be upon him) saw his Lord (with his ocular vision) fabricated the greatest lie against Allah. I was reclining but then sat up and said: Mother of the Faithful, wait a bit and do not be in a haste. Has not Allah (Mighty and Majestic) said:" And truly he saw him on the clear horizon" (al-Qur'an, lxxxi. 23) and" he saw Him in another descent" (al-Qur'an, iiii. 13)? She said: I am the first of this Ummah who asked the Messenger of Allah (may peace be upon him) about it, and he said: Verily he is Gabriel. I have never seen him in his original form in which he was created except on those two occasions (to which these verses refer) ; I saw him descending from the heaven and filling (the space) from the sky to the earth with the greatness of his bodily structure. She said: Have you not heard Allah saying." Eyes comprehend Him not, but He comprehends (all) vision. and He is Subtle, and All-Aware" (al-Qur'an, v. 104)? (She, i. e. 'A'isha, further said): Have you not heard that, verily, Allah says:" And it is not vouchsafed to a human being that Allah should speak unto him otherwise than by revelation, or from behind a veil, or that He sendeth a messenger (angel), so that he revealth whatsoever He wills. Verily He is Exalted. Wise" (al. Qur'an, xii. 51) She said: He who presumes that the Messengerof Allah (may peace be upon him) concealed anything, from the Book, of Allah fabricates the greatest lie against Allah. Allah says:" O Messenger! deliver that which has been revealed to thee from thy Lord, and if thou do (it) not, thou hast not delivered His message" (al-Qur'an, v. 67). She said: He who presumes that he would inform about what was going to happen tomorrow fabricates the greatest lie against Allah. And Allah says" Say thou (Muhammad): None in the heavens and the earth knoweth the unseen save Allah" (al-Qur'an, xxvii 65).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.338]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 338

Dawud reported on the same authorities the hadith as narrated above by Ibn 'Uliyya and added: She ('A'isha) said: If Muhammad were to conceal anything which was sent to him, he would have certainly concealed this verse:" And when thou saidst to him on whom Allah had conferred favour and thou too had conferred favour: Keep thy wife to thyself and fear Allah, and thou wast concealing in thy heart that which Allah was going to disclose, and thou wast fearing men while Allah has a better right that thou shouldst fear Him."


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.339]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 339

Masruq reported: I asked 'A'isha if Muhammad (may peace be upon him) had seen his Lord. She replied: Hallowed be Allah, my hair stood on end when you said this, and he (Masruq) narrated the hadith as narrated above. The hadith reported by Diwud is more complete and longer.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.340]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 340

Masruq reported: I said to 'A'isha: What about the words of Allah:" Then he drew nigh and came down, so he was at a distance of two bows or closer still: so He revealed to His servant what He revealed" (al-Qur'an, liii. 8-10)? She said: It implies Gabriel. He used to come to him (the Holy Prophet) in the shape of men; but he came at this time in his true form and blocked up the horizon of the sky.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.341]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 341

It is narrated on the authority of Abu Dharr: I asked the Messenger of Allah (may peace be upon him): Did you see thy Lord? He said: He is a Light;. bow could I see Him?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.342]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 342

Abdullah b. Shaqiq reported: I said to Abu Dharr: Had I seen the Messenger of Allah, I would have asked him. He (Abu Dharr) said: What is that thing that you wanted to inquire of him? He said: I wanted to ask him whether he had seen his Lord. Abu Dharr said: I, in fact, inquired of him, and he replied: I saw Light.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.343]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 343

Abu Musa reported: The Messenger ofallah (may peace be upon him) was standing amongst us and he told us five things. He said: Verily the Exalted and Mighty God does not sleep, and it does not befit Him to sleep. He lowers the scale and lifts it. The deeds in the night are taken up to Him before the deeds of the day. and the deeds of the day before the deeds of the night. His veil is the light. In the hadith narrated by Abu Bakr (instead of the word" light" ) it is fire. If he withdraws it (the veil), the splendour of His countenance would consume His creation so far as His sight reaches.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.344]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 344

A'mash has narrated this hadith on the same authority and said: The Messenger of Allah (may peace be upon him) was standing amongst us and he told us four things. He then narrated the hadith like the one reported by Abu Mua'wiya, but did not mention the words" His creation" and said: His veil is the light.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.345]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 345

Abu Musa reported: The Messenger of Allah (znay peace be upon him) was standing amongst us and (he said) four (things): Verily Allah dock not sleep and it does not befit Him to sleep. He raises the scale and lowers it. The deeds of the day are presented to Him in the night and the deeds of the night in the day.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.346]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 346

'Abdullah b. Qais transmitted on the authority of his father (Abu Musa Ash'ari) that the Apostle (may peace be upon him) said: There would be two gardens (in Paradise) the vessels and contents of which would be of silver, and two gardens whose vessels and contents would be of gold. The only thing intervening to hinder the people from looking at their Lord will be the mantle of Grandeur over His face in the Garden of Eden.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.347]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 347

Suhaib reported the Apostle (may peace be upon him) saying: When those deserving of Paradise would enter Paradise, the Blessed and the Exalted would ask: Do you wish Me to give you anything more? They would say: Hast Thou not brightened our faces? Hast Thou not made us enter Paradise and saved us from Fire? He (the narrator) said: He (God) would lift the veil, and of things given to them nothing would he dearer to them than the sight of their Lord, the Mighty and the Glorious.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.348]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 348

Hammad b. Salama narrated it on the same authority and added: He then recited the verse:" Those who do good will have the best reward and even more" (x. 26)


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.349]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 349

Abu Haraira reported: The people said to the Messenger of Allah (may peace be upon him): Messenger of Allah, shall we see our Lord on the Day of Resurrection? The Messenger of Allah (may peace be upon him) said: Do you feel any trouble in seeing the moon on the night when it is full? They said: Messenger of Allah, no. He (the Messenger) further said: Do you feel any trouble in seeing the sun, when there is no cloud over it? They said: Messenger of Allah. no. He (the Holy Prophet) said: Verily you would see Him like this (as you see the sun and the moon). God will gather people on the Day of Resurrection and say: Let every people follow what they worshipped. Those who worshipped the sun would follow the sun, and those who worshipped the moon would follow the moon, and those who worshipped the devils would follow the devils. This Ummah (of Islam) alone would be left behind and there would be hypocrites too amongst it. Allah would then come to them in a form other than His own Form, recognisable to them, and would say: I am your Lord. They would say: We take refuge with Allah from thee. We will stay here till our Lord comes to us. and when our Lord would come we would recognise Him. Subsequently Allah would come to them in His own Form, recognisable to them, and say: I am your Lord. They would say: Thou art our Lord. And they would follow Him, and a bridge would be set over the Hell; and I (the Holy Prophet) and my Ummah would be the first to pass over it; and none but the messengers would speak on that day, and the prayer of the messengers on that day would be: O Allah! grant safety, grant safety. In Hell, there would be long spits like the thorns of Sa'dan He (the Holy Prophet) said: Have you seen Sa'dan? They replied: Yes, Messenger of Allah. He said: Verily those (hooks) would be like the thorns of Sa'dan, but no one knows their size except Allah. These would seize people for their misdeeds. Some of them would escape for their (good) deeds, and some would be rewarded for their deeds till they get salvation. When Allah would finish judging His bondsmen and because of His mercy decide to take out of Hell such people as He pleases. He would command the angels to bring out those who had not associated anything with Allah; to whom Allah decided to show mercy. those who would say: There is no god but Allah. They (the angels) would recognise them in the Fire by the marks of prostration, for Hell-fire will devour everything (limb) of the sons of Adam except the marks of prostration. Allah has forbidden the fire to consume the marks of prostration. They will be taken out of the Fire having been burnt, and the water of life would be poured over them, and they will sprout as seed does In the silt carried by flood.

Then Allah would finish judging amongst His bondsmen; but a man who will be the last to enter Paradise will remain facing Hell and will say: O my Lord I turn my face away from Hell, for its air has poisoned me ard its blaze has burnt me. He will then call to Allah as long as Allah would wish that he should call to Him. Then Allah, Blessed and Exalted, would say: If I did that, perhaps you would ask for more than that. He would say: I would not ask You more than this, and he would give his Lord covenants and agreements as Allah wished, and so He would turn his face away from the Fire When he turns towards the Paradise and sees it, he will remain silent as long as Allah wishes him to remain so. He will then say: O my Lord I bring me forward to the gate of the Paradise. Allah would say to him: Did you not give covenants and agreements that you would not ask for anything besides what I had given you. Woe to thee! O son of Adam, how treacherous you are! He would say: O my Lord! and would continue calling to Allah till He would say to him: If I grant you that, perhaps you will ask for more. He will reply: No, by Thy greatness, and he will give His Lord promises and covenants as Allah had wished. He would then bring him to the gate of the Paradise, and when he would stand at the gate of the Paradise, it would lay open before him. and he would see the bounty and the joy that there is in it. He would remain quiet as long as Allah would desire him to remain silent. He would then say: O my Lord, admit me to Paradise. Allah. Blessed and Exalted, would say: Did you not give covenants and agreements that you would not ask for anything more than what I had granted you? Woe to you! son of Adam, how treacherous you are! And he would say: O my Lord, I do not wish to be the most miserable of Thy creatures. He would continue calling upon Allah till Allah, Blessed and Exalted, would laugh. When Allah would laugh at him, He would say: Enter the Paradise. When he would enter, Allah would say: State your wish. He would express his wishes till Allah would remind him (the desire of) such and such (things). When his desires would be exhausted Allah would say: That is for thee and, besides it, the like of it also. 'Ata' b. Yazid said: Abu Sa'id al-Khudri was with Abu Huraira and be did not reject anything from the hadith narrated by him, but when Abu Huraira narrated:" Allah said to that man; ind its like along with it," Abu Sa'id said:" Ten like it along with it," O Abu Huraira. Abu Huraira said: I do not remember except the words:" That is for you and a similar one along with it." Abu Sa'id said: I bear witness to the fact that I remembered from the Messenger of Allah (may peace be upon him) his words:" That is for thee and ten like it." Abu Huraira said: That man was the last of those deserving of Paradise to enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.350]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 350

Abu Huraira reported: The people said to the Apostle of Allah (may peace be upon him): Messenger of Allah I shall we see our Lord on the Day of Resurrection? The rest of the hadith was narrated according to the narration of Ibrahim b. Sa'd.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.351]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 351

Hammam b. Munabbih said: This is what Abu Huraira transmitted to us from the Messenger of Allah (may peace be upon him), and he narrated many of them;- one of them was: The Messenger of Allah (may peace be upon him) said: The lowest in rank among you in Paradise would be asked: Desire (whatever you like). And he would express his desire and again and again express a desire. tHe would be asked: Have you expressed your desire? He would say: Yes. Then He (Allah) would say: For thee is (granted) what thou desirest, and the like of it along with it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.352]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 352

Abu Sa'id al-Khudri reported: Some people during the lifetime of the Messenger of Allah (may peace be upon him) said: Messenger of Allah! shall we see our Lord on the Day of Resurrection? The Messenger of Allah (may peace be upon him) said: Yes, and added: Do you feel any trouble in seeing the sun at noon with no cloud over it, and do you feel trouble in seeing the moon (open) in the full moonlit night with no cloud over it? They said: No, Messenger of Allah! He (the Holy Prophet) said: You will not feel any trouble in seeing Allah on the Day of Resurrection any more than you do in seeing any one of them. When the Day of Resurrection comes a Mu'adhdhin (a proclaimer) would proclaim: Let every people follow what they used to worship. Then all who worshipped idols and stones besides Allah would fall into the Fire, till only the righteous and the vicious and some of the people of the Book who worshipped Allah are left. Then the Jews would be summoned, and it would be said to them: What did you worship? They will say: We worshipped 'Uzair, son of Allah. It would be said to them: You tell a lie; Allah had never had a spouse or a son. What do you want now? They would say: We feel thirsty, O our Lord! Quench our thirst. They would be directed (to a certain direction) and asked: Why don't you go there to drink water? Then they would be pushed towards the Fire (and they would find to their great dismay that) it was but a mirage (and the raging flames of fire) would be consuming one another, and they would fall into the Fire. Then the Christians would be summoned and it would be said to them: What did you worship? They would say: We worshipped Jesus, son of Allah. It would be said to them: You tell a lie; Allah did not take for Himself either a spouse or a son. Then it would be said to them: What do you want? They would say: Thirsty we are, O our Lord! Quench our thirst. They would be directed (to a certain direction) and asked: Why don't you go there to get water? But they would be pushed and gathered together towards the Hell, which was like a mirage to them, and the flames would consume one another. They would fall Into the Fire, till no one is left except he who worshipped Allah, be he pious or sinful. The Lord of the Universe, Glorified and Exalted, would come to them in a form recognisable to them and say; What are you looking for? Every people follow that which they worshipped. They would say: Our Lord, we kept ourselves separate from the people in the world, though we felt great need of them; we, however, did not associate ourselves with them. He would say: I am your Lord. They would say: We take refuge with Allah from thee and do not associate anything with Allah. They would repeat it twice or thrice, till some of them would be about to return. It would be said: Is there any sign between you and Him by which you will recognise Him? They would say: Yes. and the things would be laid bare. Those who used to prostrate themselves before God of their own accord would be permitted by God to prostrate themselves. But there would remain none who used to prostrate out of fear (of people) and ostentation but Allah would make his back as one piece, and whenever he would attempt to prostrate he would fall on his back. Then they would raise their heads and He would assume the Form in which they had seen Him the first time and would say: I am your Lord. They would say: Thou art our Lord. Then the bridge would be set up over the Hell and intercession would be allowed and they will say: O God, keep safe, keep safe.

It was asked: Messenger of Allah, what is this bridge? He said: The void in which one Is likely to slip. There would be hooks, tongs, spits like the thorn that is found in Najd and is known as Sa'dan. The believers would then pass over within the twinkling of an eye, like lightning, like wind, like a bird, like the finest horses and camels. Some will escape and be safe, some will be lacerated and let go, and some will be pushed into the fire of Hell till the believers will find rescue from the Fire. By One in Whose hand is my life, there will be none among you more eager to claim a right than the believers on the Day of Resurrection for (saying their) brethren in the Fire who would say: O our Lord, they were fasting along with us, and praying and performing pilgrimage. It will be said to them: Take out those whom you recognise. Then their persons would be forbidden to the Fire; and they would take out a large number of people who had been overtaken by Fire up to the middle of the shank or up to the knees. They would then say: O our Lord I not one of those about whom Thou didst give us command remains in it. He will then say: Go back and bring out those in whose hearts you find good of the weight of a dinar Then they will take out a large number of people. Then they would say: O our Lord! we have not left anyone about whom You commanded us. He will then say: Go back and bring out those in whose hearts you find as much as half a dinar of good. Then they will take out a large number of people, and would say: O our Lord! not one of those about whom Thou commanded us we have left in it. Then He would say: Go back and in whose heart you find good to the weight of a particle bring him out. They would bring out a large number of people, and would then say: O our Lord, now we have not left anyone in it (Hell) having any good in him.

Abu Sa'id Khudri said: If you don't testify me in this hadith, then recite if you like:" Surely Allah wrongs not the weight of an atom; and if it is a good deed. He multiplies it and gives from Himself a great reward" (al-Qur'an, iv. 40). Then Allah, Exalted and Great, would say: The angels have interceded, the apostles have interceded and the believers have interceded, and no one remains (to grant pardon) but the Most Merciful of the mercifuls. He will then take a handful from Fire and bring out from it people who never did any good and who had been turned into charcoal, and will cast them into a river called the river of life, on the outskirts of Paradise. They will come out as a seed comes cut from the silt carried by flood. You see it near the stone or near the tree. That which is exposed to the sun is yellowish or greenish and which is under the shade is white. They said: Messenger of Allah! it seems as if you had been tending a flock in the jungle. He (the Holy Prophet) said: They will come forth like pearls with seals on their necks. The inhabitants of Paradise would recognise them (and say): Those are who have been set free by the Compassionate One. Who has admitted them into Paradise without any (good) deed that they did or any good that they sent in advance Then He would say: Enter the Paradise; whatever you see in it is yours. They would say: O Lord, Thou hast bestowed upon us (favours) which Thou didst not bestow upon anyone else in the world. He would say: There is with Me (a favour) for you better than this. They would say: O our Lord! which thing is better than this? He would say: It is My pleasure. I will never be angry with you after this


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.353]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 353

It is narrated on the authority of Abu Sa'id al-Khudri: We said: Messenger of Allah, shall we see our Lord? The Messenger of Allah (may peace be upon him) said: Do you feel any trouble in seeing the sun on a cloudless day? We said: No. And the remaining part of the hadith has been narrated to the end like the hadith transmitted by Hafs b. Maisara with the addition of these words: Without the deed that they did or any good that they had sent before. It would be said to them: For you is whatever you see (in it) and with it the like of it. Abu Sa'id said: I have come to know that the bridge would be thinner even than the hair and sharper than the sword; and in the hadith narrated by Laith these words are not found: They would say, O our Lord! Thou hast bestowed upon us (favours) which thou didst not bestow on anyone else in the world.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.354]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 354

Abu Bakr b. Abi Shaiba, Ja'far b. 'Aun, Hisham b. Sa'd, Zaid b. Aslam narrated the hadith as transmitted by Hafs b. Maisara, with certain additions and omissions.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.355]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 355

Abu Sa'id al-Khudri reported: Verily the Messenger of Allah (may peace be upon him) said: Allah will admit into Paradise those deserving of Paradise, and He will admit whom He wishes out of His Mercy, and admit those condemned to Hell into the Fire (of Hell). He would then say: See, he whom you find having as much faith in his heart as a grain of mustard, bring him out. They will then be brought out burned and turned to charcoal, and would be cast into the river of life, and they would sprout aj does a seed in the silt carried away by flood. Have you not seen that it comes out yellow (fresh) and intertwined?


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.356]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 356

This hadith is transmitted by 'Amr b. Yahya with the same chain of transmitters who narrated: They would be cast into the river which is called (the river of) life, and (both the narrators) did not doubt the hadith. The text transmitted by Khalid is: just as seeds sprout beside the flood water; and in the hadith of Wuhaib it is: Just as the seed sprouts in the silt or deposit left by flood.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.357]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 357

It is reported by Abu Sa'id that the Messenger of Allah (may peace be upon him) said: The (permanent) inhabitants of the Fire are those who are doomed to it, and verily they would neither die nor live in it (al-Qur'an, xx. 47; lxxxvii. 13). But the people whom the Fire would afflict (temporarily) on account of their sins, or so said (the narrator)" on account of their misdeeds," He would cause them to die till they would be turned into charcoal. Then they would be granted intercession and would be brought in groups and would be spread on the rivers of Paradise and then it would be said: O inhabitants of Paradise, pour water over them; then they would sprout forth like the sprouting of seed in the silt carried by flood. A man among the people said: (It appears) as if the Messenger of Allah lived in the steppe.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.358]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 358

Abu Nadra narrated it from Abu Sa'id al-Khudri who reported it from the Apostle (may peace be upon him) a similar (hadith) up to the words:" in the mud of the flood," and he did not mention (the words narrated) after it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.359]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 359

Abdullah b. Mas'ud reported that the Messenger of Allah (may peace be upon him) said: I know the last of the inhabitants of Fire to be taken out therefrom, and the last of the inhabitants of Paradise to enter it. A man will come out of the Fire crawling. Then Allah, the Blessed and Exalted will say to him: Go and enter Paradise. So he would come to it and it would appear to him as if it were full. He would go back and say: O my Lord! I found it full. Allah, the Blessed and Exalted, would say to him: Go and enter Paradise. He would come and perceive as if it were full. He would return and say: O my Lord! I found it full. Allah would say to him: Go and enter Paradise, for there is for you the like of the world and ten times like it, or for you is ten times the like of this world. He (the narrator) said. He (that man) would say: Art Thou making a fun of me? or Art Thou laughing at me. though Thou art the King? He (the narrator) said: I saw the Messenger of Allah laugh till his front teeth were visible. And it was said: That would be the lowest rank among the inhabitants of Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.360]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 360

It is narrated on the authority of Abdullah b. Mas'ud that the Messenger of Allah (may peace be upon him said: I recognise the last of the inhabitants of Fire to be taken out thereof. A man will come out of it crawling. It will be said to him: Go and enter Paradise. He (the Holy Prophet) said: He would go there to enter Paradise, but would find persons who have already occupied all its apartments. It would be said to him: Do you recall the time when you were in it (in the Hell)? He would say: Yes. It would be said to him: Express any desire. And he would express the desire. It would be said to him: For thee is that which thou desireth and ten times the world (worldly resources). He (the Holy Prophet) said: He would say: Art Thou making a fun of me, though Thou art the King? I saw the Messenger of Allah laugh till his front teeth were visible.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.361]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 361

Ibn Mas'ud reported: Verily the Messenger of Allah said: The last to enter Paradise would be a man who would walk once and stumble once and be burnt by the Fire once. Then when he gets beyond it, he will turn to it and say: Blessed is He Who has saved me from thee. Allah has given me something He has not given to any one of those in earlier or later times. Then a tree would be raised up for him and he will say: O my Lord I bring me near this tree so that I may take shelter in its shade and drink of its water. Allah, the Exalted and Great, would say: O son of Adam, if I grant you this, you will ask Me for something else. He would say: No. my Lord. And he would promise Him that he would not ask for anything else. His Lord would excuse him because He sees what he cannot help desiring; so He would bring him near it, and he would take shelter in its shade and drink of its water. Afterwards a tree more beautiful than the first would be raised up before him and he would say: O my Lord! bring me near this tree in order that I may drink of its water and take shelter in its shade and I shall not ask Thee for anything else. He (Allah) would say: O son of Adam, if I bring you near it you may ask me for something else. He would promise Him that he would not ask for anything else. His Lord will excuse him because He would see something he cannot help desiring. So He would bring him near it and he would enjoy its shade and drink its water. Then a tree would be raised up for him at the gate of the Paradise, more beautiful than the first two. He would say: O my Lord! bring me near this (tree) so that I may enjoy its shade and drink from its water. I shall not ask Thee for anything else. He (Allah) would say: O son of Adam! did you not promise Me that you would not ask Me anything else? He would say: Yes, my Lord, but I shall not ask Thee for anything else. His Lord would excuse him for He sees something the temptation of which he could not resist. He (Allah) would bring him near to it, and when He would bring him near it he would hear the voices of the inhabitants of the Paradise. He would say: O my Lord! admit me to it. He (Allah) would say: O son of Adam, what will bring an end to your requests to Me? Will it please you if I give you the whole world and a like one along with it? He will say: O my Lord! art Thou mocking at me, though Thou art the Lord of the worlds? Ibn Mas'ud laughed and asked (the hearers): Why don't you ask me what I am laughing at. They (then) said: Why do you laugh? He said: It is in this way that the Messenger of Allah (may peace be upon him) laughed. They (the companions of the Holy Prophet) asked: Why do you laugh. Messenger of Allah? He said: On account of the laugh of the Lord of the universe, when he ldesirer of Paradise) sai Thou mocking at me though Thou art the Lord of the worlds? He would say: I am not mocking at you, but I have power to do whatever I will.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.362]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 362

It is transmitted from Abu Sa'id al-Khudri that, verily, the Messenger of Allah (may peace be upon him) said: Amongst the inhabitants of Paradise the lowest in rank will be the person whose face Allah would turn away from the Fire towards the Paradise, and make a shady tree appear before him. He would say: O my Lord! direct my steps to this tree so that I (should enjoy) its shade; and the rest of the hadith is like that narrated by Ibn Mas'ud, but he did not mention:" He (Allah) would say: O son of Adam! what will bring an end to your making requests to Me" to the end of the tradition. In it, he added: Allah will remind him: Ask such and such, and when his expectations would be realised, Allah would say: That is for you, and ten times as much. He said that he would then enter his house and his two wives with large and dark eyes would enter after him. They will say: Praise be to Allah, Who has created you for us and us for you. He will say: No one has been given the like of what I have been given.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.363]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 363

It is reported on the authority of al-Mughira b. Shu'ba that the Messenger of Allah (may peace be upon him) said: Moses asked his Lord: Who amongst the inhabitants of Paradise is the lowest to rank? He (Allah) said: The person who would be admitted into Paradise last of all among those deserving of Paradise who are admitted to it. I would be said to him: Enter Paradise. He would gay: O my Lord! how (should I enter) while the people have settled in their apartments and taken the shares (portions)? It would be said to him: Would you be pleased if there be for you like the kingdom of a king amongst the kings of the world? He would say: I am pleased my Lord. He (Allah) would say: For you is that, and like that, and like that, and like that, and that. He would say at the fifth (point): I am well pleased. My Lord. He (Allah) would say: It is for you and, ten times like it, and for you is what your self desires and your eye enjoys. He would say: I am well pleased, my Lord. He (Moses) said: (Which is) the highest of their (inhabitants of Paradise) ranks? He (Allah) said: They are those whom I choose. I establish their honour with My own hand and then set a seal over it (and they would be blessed with Bounties) which no eye has seen, no ear has heard and no human mind has perceived: and this is sub- stantiated by the Book of Allah, Exalted and Great:" So no soul knows what delight of the eye is hidden for them; a reward for what they did" (xxxii. 17).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.364]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 364

Sha'bi reported he had heard al-Mughira b. Shu'ba say on the pulpit that Moses (peace be upon him) had asked Allah, Exalted and Great, about the reward of the lowest of the inhabitants of Paradise, and the remaining part of hadith is the same (as narrated) above.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.365]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 365

Abu Dharr reported that Allah's Messenger (may peace be upon him) said: I know the last of the inhabitants of Paradise to enter it and the last of the inhabitants of Hell to come out of it. He is a man who would be brought on the Day of Resurrection and it will be said: Present his minor sins to him, and withhold from him his serious Sins. Then the minor sins would be placed before him, and it would be said: On such and such a day you did so and so and on such and such a day you did so and so. He would say: Yes. It will not be possible for him to deny, while he would be afraid lest serious sins chould be presented before him. It would be said to him: In place of every evil deed you will have good deed He will say: My Lord! I have done things I do not see here. I indeed saw the Messenger of Allah laugh till his front teeth were exposed.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.366]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 366

This hadith is also narrated by another chain of narrators, i. e. Ibn Numair, Abu Mu'awiya, Waki', Abu Bakr b. Abi Shaiba, Abu Kuraib, A'mash.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.367]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 367

It is reported on the authority of Abu Zubair that he heard from Jabir b 'Abdullah, who was asked about the arrival (of people on the Day of Resurrection). He said. We would come on the Day of Resurrection like this, like this, and see. carefully. that which concerns" elevated people". He (the narrator) said: Then the people would be summoned along with their idols whom they worshipped, one after another. Then our Lord would come to us and say: Whom are you waiting for? They would say: We are waiting for our Lord. He would say: I am your Lord. They would say: (We are not sure) till we gaze at Thee, and He would manifest Himself to them smilingly, and would go along with them and they would follow Him; and every person, whether a hypocrite or a believer, would be endowed with a light, and there would be spikes and hooks on the bridge of the Hell, which would catch hold of those whom Allah willed. Then the light of the hypocrites would be extinguished, and the believers would secure salvation. and the first group to achieve it would comprise seventy thousand men who would have the brightness of full moon on their faces, and they would not be called to account. Then the people immediately following them would have their faces as the brightest stars in the heaven. This is how (the groups would follow one after another). Then the stage of intercession would come, and they (who are permitted to intercede) would intercede, till he who had declared:" There is no god but Allah" and had in his heart virtue of the weight of a barley grain would come out of the Fire. They would be then brought in the courtyard of Paradise and the inhabitants of Paradise would begin to sprinkle water over them till they would sprout like the sprouting of a thing in flood water, and their burns would disappear. They would ask their Lord till they would be granted (the bounties) of the world and with it ten more besides it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.368]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 368

Jabir reported that he had heard with his ears the Apostle (may peace be upon him) saying: Allah will bring out people from the Fire and admit them into Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.369]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 369

Hammad b. Zaid, reported: I said to 'Amr b. Dinar: Did you hear Jabir b. 'Abdullah narrating from the Messenger of Allah (may peace be upon him) that Allah would bring out people from the Fire through intercession. He said: Yes.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.370]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 370

Jabir b. 'Abdullah repotted: The Messenger of Allah (may peace be upon him) said: Verily people would be brought out from the Fire, and they would be burnt except the exterior (surfaces, fronts) of their faces; and they would enter Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.371]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 371

Yazid al-Faqir said: This view of the Khwarij (i. e. those who commit major sins and would be eternally doomed to Hell) had obsessed me, and we set out in a large group intending to perform the hajj and then going to the people (for the propagation of the views of the Khwarij). He (the narrator) said: We happened to past by Medina and found there Jabir b. 'Abdullah sitting near a column narrating to the people (the ahadith of) the Holy Prophet (may peace be upon him). When he mentioned the inhabitants of Hell, I said: O companion of the Messenger of Allah what is this that thou narrateth, whereas Allah sayeth:" Verily whomsoever Thou shall commit to the Fire, Thou indeed humillateth him" (al-Qur'an, iii. 192) ; and All those who endeavoured to get out of that would be thrown back into it" (al-Qur'an, xxxi i. 20)? So what is it that you say? He said: Have you read the Qur'an? I said: Yes. He said: Have you heard about' the (exalted) position of Muhammad (may peace be upon him), i. e. to which Allah would raise, him? I said: Yes. He said: Verily the position of Muhammad (may peace be upon him) is that of great glory and that is by which Allah would bring out whornsoever He would wish to bring out. He then described the Path (the Bridge) and the passing of the people over it, and said: I am afraid I may not have remembered (other things) but this much is still in my memory that people would come out of the Hell after having gone into it, and he said: They would come out of it as if they were the wood of the ebony tree. He (the narrator said: They would enter a river, one or the rivers of Paradise, and would bathe in it, and then come out as if they were (white like) paper. We then turned back and said: Woe be upon you! How can this old man tell a lie against the Messenger of Allah (may peace be upon him)? We turned back (from the views of the Khwarij), and by God every one of us abandoned this (band of Khwarij) except one man. A similar statement has been made by Abu Nu'aim.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.372]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 372

It is narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: Four persons would be brought out from the Fire and would be presented to Allah. One of them would turn (towards the He) ) ) and say: O my Lord, when Thou hast brought me out from it, do not throw me back into it, and Allah would rescue him from it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.373]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 373

Anas b Malik reported: The Messenger of Allah (may peace be upon him) said: Allah would gather people on the Day of Resurrection and they would be concerned about it, and Ibn Ubaid said. They would get a Divine inspiration about it, and would say: If we could seek intercession with our Lord, we may be relieved from this predicament of ours. He (the Holy Prophet) said: They would come to Adam andsay, Thou art Adam, the father of mankind. Allah created thee with His own hand and breathed unto thee of His Spirit and commanded the angels and they prostrated before thee. So intercede for us with thy Lords, that He may relieve us from this position of ours. He would say: I am not in a position to do this, and would recall his error, and would fight shy of his Lord on account of that; go to Noah the first messenger (after me) sent by Allah. He (the Holy Prophet) said: So they would come to Noah (peace be upon him). He would say: I am not in a position to do that for you, and recall his fault which he had committed, and would fight shy of his Lord on account of that, (and would say): You better go to Ibrahim (peace be upon him) whom Allah took for a friend. They would come to Ibrahim (peace be upon him) and he would say: I am not in a position to do that for you, and would recall his fault that he had committed and would, therefore, fight shy of his Lord on that account (and would say): You better go to Moses (peace be upon him) with whom Allah conversed and con- ferred Torah upon him. He (the Holy Prophet) said: So they would come to Moses (peace be upon him) He would say: I am not in a position to do that for you, and would recall his fault that he had committed and would fight shy of his Lord on account of that (and would say): You better go to Jesus, the Spirit of Allah and His word He would say: I am not in a position to do that for you; you better go to Muhammad (may peace be upon him), a servant whose former and later sins have been forgiven. He (the narrator) said: The Messenger or Allah (may peace be upon him) observed: So they would come to me and I would ask the permission of my Lord and it would be granted to me, and when I would see Him, I would fall down in prostration, and He (Allah) would leave me thus as long as He would wish, and then it would be said: O Muhammad, raise your head, say and you would be heard; ask and it would be granted; intercede and intercession would be accepted. Then I would raise my head and extrol my Lord with the praise which my Lord would teach me. I shall then inter- cede, but a limit would be set for me I would bring them out from the Fire and make them enter Paradise (according to the limit). I shall return then ard fall down in pros- tration and Allah would leave me (in that position) as long as He would wish to leave me it would be said: Rise, O Muhammad, say and you would be heard; ask and it would be conferred; intercede and intercession would be granted. I would raise my head and extrol my Lord with praise that He would teach me. I would theft intercede and a limit would be set for me. I would bring them out of the Fire (of Hell) and make them enter Paradise. He (the narrator) said: I do not remember whether he (the Holy Prophet) said at tLe third time or at the fourth time: O my Lord, none has been left in the Fire, but thise restrained by the Holy Qur'an, i e. those who were eternally doomed. Ibn Ubaid said in a narration: Qatada observed: whose everlasting stay was imperative".


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.374]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 374

Anas reported: The Messenger of Allah (may peace be upon him) said: The believers would gather on the Day of Resurrection, and they would be concerned about it, or would be made mindful of it (i. e. the trjuble for it), (and the remaining part of the hadith w, ) uld be narrated) like the one transmitted by Abu Uwana, and he said in the hadith: Then I would come for the fourth time, or I would return the fourth time, and would say: O my Lord, no one has been left but he whom the Holy Qur'an has restrained.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.375]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 375

Anas b. Malik reported: The Prophet of Allah (may peace be, upon him) said: Allah will gather the believers on the Day of Resurrection and they would be made mindful of it; and the rest (of the hadith) is like the one narrated above; and then he mentioned the fourth time: And I (the Holy Prophet) would say: O my Lord, no one is left in the Fire except he whom the Qur'an has restrained, i e. eternally doomed.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.376]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 376

Anas b. Malik reported: Verily the Apostle (may peace be upon him) said: He who professed: There is no god but Allah, would be brought out of the Fire even though he has in his heart virtue equal to the weight of a barley grain. Then he who professed: There is no god but Allah, would come out of the Fire, even though he has in his heart virtue equal to the weight of a wheat grain. He would then bring out from the Fire he who professed: There is no god but Allah, even though he has in his heart virtue equal to the weight of an atom. Ibn Minhal has made an addition (of these words) in his narration: Yazid said: I met Shu'ba and narrated to him this hadith. Shu'ba said: Qatada transmitted to us this hadith from Anas b. Malik who heard it from the Apostle of Allah (may peace be upon him) with this alteration that he substituted the word Zurra (grain) in place of Zarra (atom). Yazid said: Abu Bistam has made a change in it.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.377]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 377

Ma'bad b. Hilal al 'Anazi reported: We went to Anas b. Malik through Thabit and reached there (his house) while he was offering the forenoon prayer. Thabit sought permission for us and we entered, and he seated Thabit with him on his bedstead. He (Thabit) said to him (Anas b. Malik): O Abu Hamza (kunya of Anas b. Malik), your brothers from among the inhabitants of Basra ask you to narrate to them the hadith of intercession. He said: Muhammad (may peace be upon him) narrated to us: When it would be the Day of Resurrection, some of the people would rush to one another in bewilderment. They would come to Adam and say: Intercede (with your Lord) for your progeny. He would say: I am not fit to do this, but go to Ibrabim (peace be upon him) for he is the Friend of Allah. They would come to Ibrahim, but he would say: I am not fit to do this, but go to Moses, for he is Allah's Interlocutor. They would come to Moses, but he would say: I am not fit to do this, but you should go to Jesus, for he is the Spirit of Allah and His word. They would come to Jesus, and he would say, I am not fit to do this; you better go to Muhammad (may peace be upon him). They would come to me, and I would say: I am in a position to do that, I would go and ask the permission of my Lord and it would be granted to me. I would then stand before Him and would extol Him with praises which I am not able to do now, but with which Allah would inspire me, then I would fall in prostration and it would be said to me: O Muhammad, raise thy head, and say and it would be listened to; ask and it would be granted, intercede and it would be accepted. I shall say: My Lord, my people, my people It would be said: Go, and bring forth from it (Hell) him who has in his heart faith equal to the weight of a wheat grain or a barley seed. I would go and do that; then I would return to my Lord and extol Him with those praises (taught to me by Allah), then I would fall in prostration. It would be said to me: O Muhammad, raise your head, and say and it would be heard; ask and it would be granted; intercede and intercession would be accepted. So I would say: My people. my people. It would be said to me: Go and take out from it (Hell) him who has in his heart faith equal to the weight of a mustard seed. I would go and do that. I would again return to my Lord and extol Him with those praises. I would then fall in prostration. It would be said to me: O Muhammad, raisevour head: say, and you would be listened to; ask and it would be granted; intercede and intercession would be accepted. I would say: My Lord, my people, my people. It would be said to me: Go, and bring out of the Fire him who has in his heart as much faith as the smallest, smallest, smallest grain of mustard seed. I would go and do that.

This is the hadith which Anas narrated to us. We went out of his (house) and when we reached the upper part of Jabban (graveyard) we said: Would that we meet Hasan and salute him and he was hiding in the house of Abu Khalifa. He (Ma'bad b. Hilal, the narrator) said: We went to him and greeted him and we said: O Abu Sa'id, we come from your brother Abu Hamza (kunya of Anas), and we have never heard a hadith like this relating to intercession, which he has narrated to us. He said: Narrate it, we narrated the hadith. He said: Narrate it (still further). We said: He did not (narrate it) before us more than this. He said: He (Anas) had narrated it to us twenty years back, when he was strong and healthy. He has in fact missed something. I cannot make out whether the old man has forgotten or he has (intentionally) avoided to narrate it to you lest you should rely (absolutely) upon it (and abandon doing good deeds). We said to him: Relate that to us, and he laughed and said: There is haste in the nature of man. I did not make mention of it to you but for the fact that I wanted to narrate that to you (and added that the Holy Prophet said): I would then return to my Lord for the fourth time and extol Him with these praises. I would then fall in prostration. It would be said to me: O Muhammad, raise your head: say and it will be listened to; ask and it will be granted; intercede and intercession would be accepted. I would say: O my Lord, permit me regarding him who professed: There is no god but Allah. He (the Lord) would say: That is not for thee or that is not what lies with thee, but by My Honour, Glory, Greatness and Might, I would certainly take him out who professed it: There is no god but Allah. He (the narrator, Ma'bad) said: I hear testimony to the fact that the hadith transmitted to us-by Hasan was heard by him from Anas b. Malik and I can see that he reported it twenty years back, when he was hale and hearty.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.378]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 378

Abu Huraira reported: Meat was one day brought to the Messenger of Allah (may peace be upon him) and a foreleg was offered to him, a part which he liked. He sliced with his teeth a piece out of it and said: I shall be the leader of mankind on the Day of Resurrection. Do you know why? Allah would gather in one plain the earlier and the later (of the human race) on the Day of Resurrection. Then the voice of the proclaimer would be heard by all of them and the eyesight would penetrate through all of them and the sun would come near. People would then experience a degree of anguish, anxiety and agony which they shall not be able to bear and they shall not be able to stand. Some people would say to the others: Don you see in which trouble you are? Don't you see what (misfortune) has overtaken you? Why don't you find one who should intercede for you with your Lord? Some would say to the others: Go to Adam. And they would go to Adam and say: O Adam, thou art the father of mankind. Allah created thee by His own Hand and breathed in thee of His spirit and ordered the angels to prostrate before thee. Intercede for us with thy Lord Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? Adam would say: Verily, my Lord is angry, to an extent to which He had never been angry before nor would He be angry afterward. Verily, He forbade me (to go near) that tree and I disobeyed Him. I am concerned with my own self. Go to someone else; go to Noah. They would come to Noah and would say: O Noah, thou art the first of the Messengers (sent) on the earth (after Adam), and Allah named thee as a" Grateful Servant," intercede for us with thy Lord. Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? He would say: Verily, my Lord is angry today as He had never been angry before, and would never be angry afterwards. There had emanated a curse from me with which I cursed my people. I am concerned with only myself, I am concerned only with myself; you better go to Ibrahim (peace be upon him). They would go to Ibrahim and say: Thou art the apostle of Allah and His Friend amongst the inhabitants of the earth; intercede for us with thy Lord. Don't you see in which (trouble) we are? Don't you see what (misfortune) has overtaken us? Ibrahim would say to them: Verily, my Lord is today angry as He had never been angry before and would never be angry afterwards. and (Ibrahim) would mention his lies (and then say): I am concerned only with myself, I am concerned only with myself. You better go to someone else: go to Moses. They would come to Moses (peace be upon him) and say: O Moses, thou art Allah's messenger, Allah blessed thee with His messengership and His conversation amongst people. Intercede for us with thy Lord. Don't you see in what (trouble) we are? Don't you see what (misfortune) has overtaken us? Moses (peace be upon him) would say to them: Verily. my Lord is angry as He had never been angry before and would never be angry afterwards. I, in fact, killed a person whom I had not been ordered to kill. I am concerned with myself, I am concerned with myself. You better go to Jesus (peace be upon him). They would come to Jesus and would say: O Jesus, thou art the messenger of Allah and thou conversed with people in the cradle, (thou art) His Word which I-Ie sent down upon Mary. and (thou art) the Spirit from Him; so intercede for us with thy Lord. Don't you see (the trouble) in which we are? Don't you see (the misfortune) that has overtaken us? Jesus (peace be upon him) would say: Verily, my Lord is angry today as He had never been angry before or would ever be angry afterwards. He mentioned no sin of his. (He simply said: ) I am concerned with myself, I am concerned with myself; you go to someone else: better go to Muhammad (may peace be upon him).

They would come to me and say: O Mahammad, thou art the messenger of Allah and the last of the apostles. Allah has pardoned thee all thy previous and later sins. Intercede for us with thy Lord; don't you see in which (trouble) we are? Don't you see what (misfortune) has overtaken us? I shall then set off and come below the Throne and fall down prostrate before my Lord; then Allah would reveal to me and inspire me with some of His Praises and Glorifications which He had not revealed to anyone before me. He would then say: Muhammad, raise thy head; ask and it would be granted; intercede and intercession would be accepted I would then raise my head and say: O my Lord, my people, my people. It would be said: O Muhammad, bring in by the right gate of Paradise those of your people who would have no account to render. They would share with the people some other door besides this door. The Holy Prophet then said: By Him in Whose Hand is the life of Muhammad, verify the distance between two door leaves of the Paradise is as great as between Mecca and Hajar, or as between Mecca and Busra.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.379]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 379

It is reported on the authority of Abu Huraira that there was placed before the Messenger of Allah a cup of soft bread, soup and meat. He took part of the foreleg which he liked most. He sliced (with his teeth) a slice (out of that) and said: I would be the leader of mankind on the Day of Resurrection. He then sliced (that meat) for the second time and said: I am the leader of mankind on the Day of Resurrection. When he saw that his companions did not ask him (about this assertion) he said: Why don't you say: How would that be? They said: How would be it, Messenger of Allah? He said: People would stand before the Lord of the worlds. And the rest of the hadith was narrated like the one transmitted by Abu Hayyan, on the authority of Abu Zur'a, and in the story of Ibrahim, this addition was made. He said and made mention of his words with regard to the star: This is my Lord. And his words with regard to their gods: But the big among them has done that. And his words: I am ailing. He (the Holy Prophet) said: By Him in Whose Hand is the life of Muhammad, the distance between two leaves of the door from their supporting frames is as the distance between Mecca and Hajar or Hajar and Mecca. I do not remember how he said it (whether Mecca and Hajar or Hajar and Mecca).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.380]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 380

It is narrated on the authority of Abu Huraira and Hudhaifa that the Messenger of Allah (may peace be upon him) said: Allah, the Blessed and Exalted, would gather people. The believers would stand till the Paradise would be brought near them. They would come to Adam and say: O our father, open for us the Paradise. He would say: What turned ye out from the Paradise was the sin of your father Adam. I am not in a position to do that; better go to my son Ibrahim, the Friend of Allah. He (the Holy Prophet) said: He (Ibrahim) would say: I am not in a position to do that. Verily I had been the Friend (of Allah) from beyond, beyond; you better approach Moses (peace be upon him) with whom Allah conversed. They would come to Moses (peace be upon him), but he would say: I am not in a position to do that; you better go to Jesus, the Word of Allah and His Spirit. Jesus (peace be upon him) would say: I am not in a position to do that. So they would come to Mubammad (may peace be upon him). He would then be permitted (to open the door of Paradise). Trust worthiness and kinship would be despatched, and these would stand on the right and left of the Path and the first of you would pass with (the swiftness) of lightning. He (the narrator) said: I said, O thou who art far dearer to me than my father and my mother I which thing is like the passing of lightning? He said: Have you not seen lightning, how it passes and then comes back within the twinkling of an eye? Then (they would pass) like the passing of the wind, then like the passing of a bird, and the hastening of persons would be according to their deeds, and your Apostle would be standing on the Path saying: Save, O my Lord, save. (The people would go on passing) till the deeds of the servants would be failing in strength, till a man would come who would find it hard to go along (that Path) but crawlingly. He (the narrator) said: And on the sides of the Path hooks would be suspended ready to catch anyone whom these would be required (to catch). There would be those who would somehow or other succeed in trasversing that Path and some would be piled up in Hell. By Him in Whose Hand is the life of Abu Huraira it would take one seventy years to fathom the depth of Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.381]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 381

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: I would be the first among people to intercede in the Paradise and amongst the apostles I would have the largest following (on the Day of Resurrection).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.382]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 382

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Amongst the apostles I would have the largest following on the Day of Resurrec tion, and I would be the first to knock at the door of Paradise.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.383]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 383

Anas b. Malik said: The Apostle of Allah (may peace be upon him) said: I would be the first intercessor in the Paradise and no apostle amongst the apostles has been testified (by such a large number of people) as I have been testified. And verily there woald be an apostle among the apostles who would be testified to by only one man from his people.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.384]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 384

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: I will come to the gate of Paradise on the Day of Resurrection. and would seek its opening. and the keeper would say: Who art thou? I would say: Muhammad. He would then say: It is for thee that I have been ordered, and not to open it for anyone before thee.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.385]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 385

Abu Huraira reported: Verity the Messenger of Allah (may peace be upon him) said: There is for every apostle a (special) prayer with which he would pray. I wish I could reserve, my prayer for intercession of my Ummah on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.386]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 386

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: There is for every apostle a prayer, and I intend (if Allah so willed) that I would reserve my prayer for the intercession of my Ummah on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.387]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 387

'Amr b. Abu Sufyan transmitted a hadith like this from Abu Huraira who narrated it from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.388]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 388

Amr b. Abu Sufyan reported: Abu Huraira said to Ka'b al-Ahbar that the Apostle of Allah (may peace be upon him) had said: For every apostle there Is a (special) prayer by which he would pray (to his Lord). I, however, intend (if Allah so willed) that I would reserve my prayer for the intercession of my Ummah on the Day of Resurrection. Ka'b said to Abu Huraira: Did you hear this from the Messenger of Allah (may peace be upon him)? Abu Huraira said: Yes.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.389]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 389

Abu Huraira said: The Prophet of Allah (may peace be upon him) said: There is for every apostle a prayer which is granted, but every prophet showed haste in his prayer. I have, however, reserved my prayer for the intercession of my Ummah on the Day of Resurrection, and it would be granted, if Allah so willed, in case of everyone amongst my Ummah provided he dies without associating anything with Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.390]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 390

Abu Huraira said: The Messenger of Allah (may peace be upon him) said: Every Messenger is endowed with a prayer which is granted and by which he would (pray to his Lord) and it would he granted for him. I have, however, reserved my prayer for the intercession of my Ummab on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.391]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 391

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: There was for every apostle a prayer with which he prayed for his Ummah and it was granted to him; but I wish, if Allah so wills, to defer my prayer for the intercession of my Ummah on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.392]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 392

Anas b. Malik reported: Verily the Apostle of Allah (may peace be upon him) said: There is for every apostle a prayer with which he prays (to Allah) for his Ummah. I have reserved my prayer for the intercession of my Ummah on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.393]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 393

This hadith is narrated with the same chain of narrators by Qatada.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.394]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 394

Mis'ar transmitted it with the same chain of narrators from Qatada except that in the hadith narrated by Waki' (the Prophet) said:" He was endowed," and in the hadith reported by Abu Usama (the words are):" It is reported from the Apostle of Allah (may peace be upon him)."


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.395]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 395

Muhammad b. 'Abd al-A'la reported it to me: Mu'tamir narrated to us on the authority of his father who transmitted it liom Anas that verity the Apostle of Allah (may peace be upon him) said, and then narrated the hadith like the one transmitted by Qatada on the authority of Anas.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.396]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 396

Abu Zubair heard Jabir b. Abdullah reporting it from the Apostle of Allah (may peace be upon him): For every apostle was a prayer with which he prayed (to his Lord) for his Ummah, but I have reserved my prayer for the intercession of my Ummah on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.397]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 397

'Abdullah b. Amr b. al-'As reported: Verily the Apostle of Allah (may peace be upon him) recited the words of Allah, the Great and Glorious, that Ibrahim uttered. My Lord! lo! they have led many of mankind astray:" But whoso followeth me, he verily is of me" (al-Qur'an, xiv. 35) and Jesus (peace be upon him) said:" If thou punisheth them, lo! they are Thy slaves, and if Thou forgiveth them-verily Thou art the Mighty, the Wise" (al-Qur'an, v 117). Then he raised his hands and said: O Lord, my Ummah, my Ummah, and wept; so Allah the High and the Exalted said: O Gabriel, go to Muhammad (though your Lord knows it fully well) and ask him: What makes thee weep? So Gabriel (peace be upon him) came to him and asked him, and the Messenger of Allah (may peace be upon him) informed him what he had said (though Allah knew it fully well). Upon this Allah said: O Gabriel, go to Muhammad any say: Verily We will please thee with regard to your Ummah and would not displease thee.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.398]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 398

Anas reported: Verily, a person said: Messenger of Allah, where is my father? He said: (He) is in the Fire. When he turned away, he (the Holy Prophet) called him and said: Verily my father and your father are in the Fire.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.399]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 399

Abu Huraira reported: When this verse was revealed:" And warn thy nearest kindred (al-Qur'an, xxvi. 214), the Messenger of Allah (may peace be upon him) called the Quraish; so they gathered and he gave them a general warning. Then he made a particular (reference to certain tribes) and said: O sons of Ka'b b. Luwayy, rescue yourselves from the Fire; O sons of Murra b. Ka'b, rescue yourselves from the Fire: O sons of Abd Shams, rescue yourselves from the Fire; 0 sons of Abd Manaf rescue yourselves from the Fire; O sons of Hashim, rescue yourselves from the Fire; 0 sons of Abd al-Muttalib, rescue yourselves from the Fire; O Fatimah, rescue thyself from the Fire, for I have no power (to protect you) from Allah in anything except this that I would sustain relationship with you.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.400]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 400

The same hadith is narrated by Ubaidallah b. Umar al-Qawariri from Abu 'Uwana, who transmitted it to 'Abd al-Malik b. 'Umair on the same chain of transmitter and the hadith of Jarir is more perfect and comprehensive.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.401]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 401

It is narrated on the authority of 'A'isha that when this verse was revealed:" And warn thy nearest kindred," the Messenger of Allah (may peace be upon him) stood up on Safa' and said: O Fatima, daughter of Muhammad. O Safiya, daughter of 'Abd al-Muttalib, O sons of 'Abd al-Muttalib. I have nothing which can avail you against Allah; you may ask me what you want of my worldly belongings.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.402]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 402

Abu Huraira reported: When (this verse) was revealed to him:" Warn your nearest kinsmen." the Messenger of Allah (may peace be upon him) said: O people of Quraish, buy yourselves from Allah, I cannot avail you at all against Allah; O sons of Abd al-Muttalib. I cannot avail you at all against Allah; 0 Abbas b. 'Abd al- Muttalib, I cannot avail you at all against Allah; O Safiya (aunt of the Messenger of Allah), I cannot avail you at all against Allah; 0 Fatima, daughter of Muhammad, ask me whatever you like, but I cannot avail you at all against Allah.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.403]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 403

This hadith is narrated from the Apostle (may peace be upon him) by another chain of narrators, 'Amr al-Naqid, Mu'awiya b. 'Amr, Abdullah b. Dhakwan, A'raj on the authority of Abu Huraira.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.404]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 404

Qabisa b. al-Mukhariq and Zuhair b. 'Amr reported: When this verse was revealed:" And warn thy nearest kindred," the Apostle of Allah (may peace be upon him) set off towards a rock of the hill and ascended the highest of the rocks and then called: 0 sons of 'Abd Manaf! I am a warner; my similitude and your similitude is like a man who saw the enemy and went to guard his people, but, being afraid they might get there before him, he shouted: Be on your guard!


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.405]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 405

This hadith is narrated from the Apostle of Allah (may peace be upon him) by another chain of narrators, Muhammad b. Abd al-A'la, Mu'tamir, Abu 'Uthman, Zuhair b. 'Amr, Qabisa b. Mukhariq.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.406]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 406

It is reported on the authority of Ibn 'Abbas that when this verse was revealed:" And warn thy nearest kindred" (and thy group of selected people among them) the Messenger of Allah (may peace be upon him) set off till he climbed Safa' and called loudly: Be on your guard! They said: Who is it calling aloud? They said: Muhammad. They gathered round him, and he said: O sons of so and so, O sons of so and so, O sons of 'Abd Manaf, O sons of 'Abd al-Muttalib, and they gathered around him. He (the Apostle) said: If I were to inform you that there were horsemen emerging out of the foot of this mountain, would you believe me? They said: We have not experienced any lie from you. He said: Well, I am a warner to you before a severe torment. He (the narrator) said that Abu Lahab then said: Destruction to you! Is it for this you have gathered us? He (the Holy Prophet) then stood up, and this verse was revealed:" Perish the hands of Abu Lahab, and he indeed perished" (cxi. 1). A'mash recited this to the end of the Sura.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.407]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 407

This hadith was narrated by A'mash on the authority of the same chain of narrators and he said: One day the Messenger of Allah (may peace be upon him) climbed the hill of Safa' and said: Be on your guard, and the rest of the hadith was narrated like the hadith transmitted by Usama; he made no mention of the revelation of the verse:" Warn thy nearest kindred."


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.408]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 408

It is reported on the authority of 'Abbas b. Abd al-Muttalib that he said: Messenger of Allah, have you benefited Abu Talib in any way for he defended you and was fervent in your defence? The Messenger of Allah (may peace he upon him) said: Yes; he would be in the most shallow part of the Fire: and but for me he would have been in the lowest part of Hell.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.409]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 409

Abdullah b. al-Harith reported: I heard Abbas say: I said: Messenger of Allah, verily Abu Talib defended you and helped you; would it be beneficial for him? He (the Holy Prophet) said: Yes; I found him in the lowest part of the Fire and I brought him to the shallow part.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.410]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 410

This hadith is narrated from the Apostle (may peace be upon him) like one narrated by Abu 'Uwana on the authority of the chain of transmitters like Muhammad b. Hatim, Yahya b. Sa'id, Abu Sufyan, 'Abbas b. 'Abd al-Muttalib and others.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.411]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 411

Abu Sa'id al-Khudri reported: A mention was made of his uncle Abu Talib before the Messenger of Allah (may peace be upon him) He said: My intercession may benefit him on the Day of Resurrection and he may be placed in the shallow part of the Fire which would reach his ankles and his brain would be boiling.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.412]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 412

Abu Sa'id al-Khudri reported: Verily, the Messenger of Allah (may peace be upon him) said: The least tormented of the inhabitants of the Fire would be he who would wear two shoes of Fire and his brain would boil on account of the heat of the shoes.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.413]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 413

Ibn 'Abbas reported: The Prophet (may peace be upon him) said: Among the inhabitants of the Fire Abu Talib would have the least suffering, and he would be wearing two shoes (of Fire) which would boil his brain.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.414]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 414

Nu'man b. Bashir was delivering an address and saying: I heard the Messenger of Allah (may peace be upon him) say: the least suffering for the inhabitants of Hell on the Day of Resurrection would be for the man under whose soles would be placed two embers and his brain would boil on account of them.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.415]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 415

Nu'man b. Bashir reported: The Messenger of Allah (may peace be upon him) said: Verily the least suffering for the inhabitants of Fire would be for him who would have two shoes and two laces of Fire (on his feet), and with these would boil his brain as boils the cooking vessel, and he would think that he would not see anyone in a more grievous torment than him, whereas he would be in the least torment.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.416]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 416

'A'isha reported: I said: Messenger of Allah, the son of Jud'an established ties of relationship, fed the poor. Would that be of any avail to him? He said: It would be of no avail to him as he did not ever say: O my Lord, pardon my sins on the Day of Resurrection.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.417]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 417

'Amr b. 'As reported: I heard it from the Messenger of Allah (may peace be upon him) quite audibly and not secretly: Behold! the posterity of my fathers, that is, so and so, are not my friends. Verily Allah and the pious believers are my friends.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.418]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 418

It is narrated on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) said: Seventy thousand (persons) of my Ummah would enter Paradise without rendering an account. Upon this a person said: Messenger of Allah. pray to Allah that He make me one of them. He (the Holy Prophet) said: O Allah! make him one of them. Then another stood up and said: Messenger of Allah, pray to Allah that He make me one of them. He (the Holy Prophet) said: 'Ukkasha has preceded you in this matter.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.419]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 419

Muhammad b. Ziyad reported: I heard Abu Huraira narrate this: I heard it from the Messenger of Allah (may peace be upon him) saying a hadith like one narrated by al-Rabi'.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.420]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 420

Abu Huraira reported: I heard it from the Messenger of Allah (may peace be upon him) saying: A group of my Ummah consisting of seventy thousand persons would enter Paradise; their faces would be as bright as the brightness of the full moon. Abd Huraira said: 'Ukkasha b. Mihsan al-Asadi then stood up wrapping the blanket around him and said: Messenger of Allah, supplicate (before) Allah that He should make me one among them. Upon this the Messenger of Allah (may peace be upon him) said: O Allah, make him among them. Then stood up a man from the Ansa and said: Messenger of Allah, pray to Allah that He should make me one among them. The Messenger of Allah (may peace be upon him) said: 'Ukkasha has preceded you in this matter.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.421]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 421

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Seventy thousand (persons) would enter Paradise as one group and among them (there would be people) whom faces would be bright like the moon.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.422]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 422

It is reported on the authority of 'Imran that the Apostle of Allah (may peace be upon him) said: Seventy thousand people of my Ummah would be admitted into Paradise without rendering any account. They (the companions) said: Who would be of those (fortunate persons)? He (the Holy Prophet) said: Those who do not cauterise and practise charm, but repose trust in their Lord, 'Ukkasha then stood up and said: Supplicate (before) Allah that He should make me one among them. He (the Holy Prophet) said: Thou art one among them He (the narrator) said: A man stood up and said: Apostle of Allah, supplicate (before) Allah that He should make me one among them. He (the Holy Prophet said: 'Ukkasha has preceded you (in this matter).


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.423]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 423

'Imran b. Husain reported: Verily the Messenger of Allah (may peace be upon him) said: Seventy thousand men of my Ummah would enter Paradise without rendering account. They (the companions of the Holy Prophet) said: Who would be those, Messenger of Allah? He (the Holy Prophet) said: They would be those who neither practise charm, not take omens, nor do they cauterise, but they repose their trust in their Lord.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.424]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 424

Abu Hazim narrated it on the authority of Ibn Sa'd that the Messenger of Allah (may peace be upon him) said: Seventy thousand persons or seven hundred thousand persons (Abu Hazim does not remember the exact number) would enter Paradise holding and supporting one another, and the first among them would not enter till the last among them would enter (therein) ; (they would enter simultaneously) and their faces would be bright like the full moon.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.425]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 425

Husain b. 'Abd al-Rahman reported: I was with Sa'id b. Jubair when he said: Who amongst you saw a star shooting last night? I said: It was I; then I said: I was in fact not (busy) in prayer, but was stung by a scorpion (and that is the reason why I was awake and had a glimpse of the shooting star). He said: Then what did you do? I said: I practised charm. He said: What urged you to do this? I said: (I did this according to the implied suggestion) of the hadith which al-Shu'ba narrated. He said: What did al-Shu'ba narrate to you? I said: Buraida b. Husaib al-Aslami narrated to us. The charm is of no avail except in case of the (evil influence) of an eye or the sting of a scorpion. He said: He who acted according to what he had heard (from the Holy Prophet) acted rightly, but Ibn 'Abbas narrated to us from the Apostle of Allah (may peace be upon him) that he said: There were brought before me the peoples and I saw an apostle and a small group (of his followers) along with him, another (apostle) and one or two persons (along with him) and (still another) apostle having no one with him. When a very large group was brought to me I conceived as if it were my Ummah. Then it was said to me: It is Moses and his people. You should look at the horizon, and I saw a very huge group. It was again said to me: See the other side of the horizon, and there was (also) a very huge group. It was said to me: This is your Ummah, and amongst them there were seventy thousand persons who would be made to enter Paradise without rendering any account and without (suffering) any torment. He then stood up and went to his house. Then the people began to talk about the people who would be admitted to Paradise without rendering any account and without (suffering) any torment. Some of them said: They may be those who (have had the good fortune of living) in the company of the Messenger of Allah (may peace be upon him) and some of them said: They be those who were born in Islam and did not associate anything with Allah. Some people mentioned other things. Thereupon came forth the Messenger of Allah (may peace be upon him) before them and he said: What was that which you were talking about? They informed him. He said: They are those persons who neither practise charm, nor ask others to practise it, nor do they take omens, and repose their trust in their Lord. Upon this 'Ukkasha b. Mihsan stood up and said: Supplicate for me that He should make me one among them. Upon this he (Messenger of Allah) said: Thou are one among them. Then another man stood up and said: Supplicate before Allah that He should make me one among them. Upon this he said: 'Ukkisha has preceded you.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.426]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 426

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) said: Peoples would be presented to me (on the Day of Resurrection), and then the remaining part of the hadith was narrated like the one transmitted by Hushaim, but he made no mention of the first portion.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.427]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 427

Abdullah b. Mas'ud reported: The Messenger of Allah (may peace be upon him) addressing us said: Aren't you pleased that you should constitute one-fourth of the inhabitants of Paradise? He (the narrator) said: We glorified (our Lord, i. e. we called aloud Allah-o Akbar, Allah is the Greatest). He, then, again said: Aren't you pleased that you should constitute one-third of the inhabitants of Paradise? He (the narrator) said: We glorified (our Lord) and he (the Holy Prophet) then again said: I hope that you would constitute half of the inhabitants of Paradise and I shall explain to you its (reason). The believers among the unbelievers would not be more than a white hair on (the body of a) black ox or a black hair on (the body of a) white ox.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.428]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 428

'Abdullah (b. Mas'ud) reported: We, about forty men, were with the Messenger of Allah (may peace be upon him) in a camp when he said: Aren't you pleased that they should constitute one-fourth of the inhabitants of Paradise? He (the narrator) said: Yes. He (the Holy Prophet) again said: Aren't you pleased that you should constitute one-third of the inhabitants of Paradise? They said: Yes. Upon this he again said: By Him in Whose Hand is my life, I hope that you would constitute one-half of the inhabitants of Paradise and the reason is that no one would be admitted into Paradise but a believer and you are no more among the polytheists than as a white hair on the skin of a black ox or a black hair on the skin of a red ox.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.429]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 429

Abdullah b Mas'ud reported: The Messenger of Allah (may peace be upon him) addressed us and then supported his back (by reclining) against a leather tent and said: Behold, no one but a believing person would enter Paradise. O Allah, (see) have I conveyed (it not)? 0 Allah, be witness (to it that I have conveyed it). (Then addressing the companions) he said: Don't you like that you should constitute one-fourth of the inhabitants of Paradise? We said: Yes, Messenger of Allah. He again said: Don't you like that you should constitute one-third of the inhabitants of Paradise? They said: Yes, Messenger of Allah. He said: I hope that you would constitute one- half of the inhabitants of Paradise and you would be among the peoples of the world, like a black hair on (the body of) a white ox or like a white hair on the body of a black ox.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.430]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 430

Abu Sa'id reported: The Messenger of Allah (may peace be upon him) said: Allah, the High and Glorious, would say: O Adam I and he would say: At Thy service, at thy beck and call, O Lord, and the good is in Thy Hand. Allah would say: Bring forth the group of (the denizens of) Fire. He (Adam) would say: Who are the denizens of Hell? It would be said: They are out of every thousand nine hundred and ninety-nine. He (the Holy Prophet) said: It is at this juncture that every child would become white-haired and every pregnant woman would abort and you would see people in a state of intoxication, and they would not be in fact intoxicated but grievous will be the torment of Allah. He (the narrator) said: This had a very depressing effect upon them (upon the companions of the Holy Prophet) and they said: Messenger of Allah, who amongst us would be (that unfortunate) person (who would be doomed to Hell)? He said: Good tidings for you, Yajuj Majuj would be those thousands (who would be the denizens of Hell) and a person (selected for Paradise) would be amongst you. He (the narrator) further reported that he (the Messenger of Allah) again said: By Him in Whose Hand is thy life, I hope that you would constitute one-fourth of the inhabitants of Paradise. We extolled Allah and we glorified (Him). He (the Holy Prophet) again said: BY Him in Whose Hand is my life, I wish you would constitute one-third of the inhabitants of Paradise. We extolled Allah and Glorified (Him). He (the Holy Prophet) again said: By Him in Whose Hand is my life, I hope that you would constitute half of the inhabitants of Paradise. Your likeness among the people is the likeness of a white hair on the skin of a black ox or a strip on the foreleg of an ass.


Muslim :: The Book of Faith (Kitab Al-Iman) :: [1.431]

The Book of Faith (Kitab Al-Iman)

Muslim :: Book 1 : Hadith 431

The same hadith has been narrated from A'mash on the authority of the same chain of transmitters with the exception of these words: You would be no more among men (on the Day of Resurrection) but like a white hair on (the body of) a black ox, or like a black hair on (the body of) a white ox, and he made no mention of: a strip on the foreleg of an ass.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.432]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 432

Abu Malik at-Ash'ari reported: The Messenger of Allah (may peace be upon him) said: Cleanliness is half of faith and al-Hamdu Liliah (Praise be to Allah) fills the scale, and Subhan Allah (Glory be to Allah) and al-Hamdu Liliah (Praise be to Allah) fill upwhat is between the heavens and the earth, and prayer is a light, and charity is proof (of one's faith) and endurance is a brightness and the Holy Qur'an is a proof on your behalf or against you. All men go out early in the morning and sell themselves, thereby setting themselves free or destroying themselves.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.433]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 433

Mus'ab b. Sa'd reported: 'Abdullah son of Umar came to Ibn'Amir in order to inquire after his health as he was ailing. He said Ibn 'Umar, why don't you prayto Allah for me? He said: I heard of Allah's Messenger (may peace be upon him) say: Neither the prayer is accepted without parification nor is charity accepted out of the ill-gotten (wealth), and thou wert the (governor) of Basra.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.434]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 434

A hadith like this is narrated from the Apostle (may peace be upon him) with the same chain of transmitters by Muhammad b. Muthanna, Ibn Bashshar, Muhammad b. Ja'far, Shu'ba.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.435]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 435

Hammam b. Munabbih who is the brother of Wahb b. Munabbih. said: This is what has been transmitted to us by Abu Huraira from Muhammad, the Messenger of Allah (may peace be upon him) and then narrated a hadith out of them and observed that the Messenger of Allah (may peace be upon him) said: The prayer of none amongst you would be accepted in a state of impurity till he performs ablution.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.436]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 436

Humran, the freed slave of 'Uthman, said: Uthman b. 'Affan called for ablution water and this is how he performed the ablution. He washed his hands thrice. He then rinsed his mouth and cleaned his nose with water (three times). He then washed his face three times, then washed his right arm up to the elbow three times, then washed his left arm like that, then wiped his head; then washed his right foot up to the ankle three times, then washed his left foot like that, and then said: I saw the Messenger of Allah (may peace be upon him) perform ablution like this ablution of mine. Then the Messenger of Allah (may peace be upon him) said: He who performs ablution like this ablution of mine and then stood up (for prayer) and offered two rak'ahs of prayer without allowing his thoughts to be distracted, all his previous sins are expiated. Ibn Shihab said: Our scholars remarked: This is the most complete of the ablutions performed for prayer.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.437]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 437

Humran, the freed slave of 'Uthman said: I saw Uthman call for a vessel (of water) and poured water over his hands three times and then washed them. Then he put his right hand in the vessel and rinsed his mouth and cleaned his nose. Then he washed his face three times and his hands up to the elbow three times; then wiped his head, then washed his feet three times. Then he said that the Messenger of Allah (may peace be upon him) had said: He who performed ablution like this ablution of mine and offered two raklahs of prayer without allowing his thoughts to be distracted, all his previous sins would be expiated.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.438]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 438

Humran. the freed slave of 'Uthman. said: I heard from 'Uthman b. 'Affan and he was in the courtyard of the mosque, when the Mu'adhdhin (announcer of the prayer) came to him at the time of afternoon prayer. So the ('Uthman) called for the ablution water and performed ablution and then said: By Allah, I am narrating to you a hadith. If there were not a verse in the Book of Allah, I would have never narrated it to you. I heard Allah's Messenger (may peace be upon him) say: If a Muslim performs ablution and does it well and offers prayer, all his (sins) daring the period from one prayer to another would be pardoned by Allah.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.439]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 439

This hadith is also narrated on the authority with the same chain of transmitters and in the hadith of Abu Usama the words are:" He who performed the ablution well and then offered the obligatory prayer."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.440]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 440

Humran reported when 'Uthman performed ablution he said: By Allah, I am narrating to you a hadith had there not been this verse in the Book of Allah. I would not have narrated it to you. Verily I heard the Messenger of Allah (may peace be upon him) say: Not a person is there who performed ablution, and did it well, then offered prayer, but his sins (which he committed) were not pardoned between the prayer that he offered and the next one. 'Urwa said: The verse is this:" Those who suppress the clear proofs and the guidance which We have sent down"... to His words:" the Cursers" (ii. 15).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.441]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 441

'Amr b Sa'id b al-As reported: I was, with Uthman that he called for ablution water and said: I heard Allah's Messenger (may peace be upon him) say: When the time for a prescribed prayer comees, if any Muslim perform ablution well and offers his prayer) with humility and bowing, it will be an expiation for his past sins, so long as he has not committed a major sin; and this applies to for all times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.442]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 442

Humran, the freed slave of 'Uthman reported: I brought for Uthman b. 'Affan the ablution water. He performed ablution and then said: Verily the people narrate from the Messenger of Allah (may peace be upon him) a hadith. I do not know what these are. but (I know this fact) that I saw the Messenger of Allah (may peace be upon him) perform ablution like this ablution of mine and then he said: He who performed ablution like this, all his previous sins would be expiated and his prayer and going towards the mosque would have an extra reward. In the tradition narrated by Ibn 'Abda (the words are):" I came to Uthman and he performed ablution."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.443]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 443

Abu Anas reported that Uthman performed ablution at Maqi'aid and said: Should I not show you the ablution performed by Allah's Messenger (may peace be upon him)? And he then washed (the different parts of the body) three times. 4" Qutaiba has added in his narration the words:" There were with him (with Uthman) Companions of Allah's Messenger (may peace be upon him)."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.444]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 444

Humran b. Abin reported: I used to fetch water for 'Uthman for his purification. Never was there a day that he did not take a bath with a small quantity of water. And Uthman said: The Messenger of Allah (may peace be upon him) at the time of our returning from our prayer told us (certain things pertaining to purification). Mis'ar said: I find that it was afternoon prayer. He said: I do not know whether I should tell you a thing or keep quiet. We said: Messenger of Allah, tell us if it is good and if it is otherwise, Allah and His Apostle know better. Upon this he said: A Muslim who purifies (himself) and completes purification as enjoined upon him by Allah and then offers the prayers, that will be expiatious (of his sins he committed) between these (prayers).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.445]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 445

Jami' b. Shaddad reported: I heard Humran b. Aban narrate to Abu Burda in this very mosque during the governorship of Bishr that 'Uthman b. Alfan said: The Messenger of Allah (may peace be upon him) observed: He who completed ablution as Allah, the Exalted, enjoined upon him, his obligatory prayers would be explatious (for his minor sins that he would commit) during (the interval) between them. This hadith is transmitted by Ibn Mu'adh, and in the hadith narrated by Ghundar, the words" during the governorship of Bishr" are omitted and there is no mention of the obligatory prayers.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.446]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 446

Humran, the freed slave of Uthman reported: One day Uthman b. Affan performed the ablution well, and then said: I saw Allah's Messenger (may peace be upon him) perform ablution, the best ablution, and then observed: He who performed ablution like this and then went towards the mosque and nothing (but the love of) prayer urged him (to do so), all his previous (minor) sins would be expiated.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.447]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 447

Humran, the freed slave of 'Uthman b. 'Affan, reported on the authority of 'Uthman b. 'Affan that he heard Allah's Messenger (may peace be upon him) say: He who performed ablution for prayer and performed it properly and then went (to observe) obligatory prayer and offered it along with people or with the congregation or in the mosque, Allah would pardon his sins.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.448]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 448

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Five prayers and from one Friday prayer to (the next) Friday prayer is an expiation (of the sins committed in between their intervals) if major sins are not committed.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.449]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 449

Abu Huraira reported that the Messenger of Allah (way peace be upon him) said: Five prayers and one Friday prayer to (the next) Friday prayer are expiatious (for the sins committed in the intervals) between them.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.450]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 450

Abu Huraira reported: Verily the Messenger of Allah (may peace be upon him) said: Five (daily) prayers and from one Friday prayer to the (next) Friday prayer, and from Ramadhan to Ramadhan are expiatious for the (sins) committed in between (their intervals) provided one shuns the major sins.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.451]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 451

'Uqba b. 'Amir reported: We were entrusted with the task of tending the camels. On my turn when I came back in the evening after grazing them in the pastures, I found Allah's Messenger (may peace be upon him) stand and address the people. I heard these words of his: If any Muslim performs ablution well, then stands and prays two rak'ahs setting about them with his heart as well as his face, Paradise would be guaranteed to him. I said: What a fine thing is this! And a narrator who was before me said: The first was better than even this. When I cast a glance, I saw that it was 'Umair who said: I see that you have just come and observed: If anyone amongst you performs the ablution, and then completes the ablution well and then says: I testify that there is no god but Allah and that Muhammad is the servant of Allah and His Messenger, the eight gates of Paradise would be opened for him and he may enter by whichever of them he wishes.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.452]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 452

Uqba b. 'Amir al-Juhani reported: Verily the Messenger of Allah (may peace be upon him) said and then narrated (the hadith) like one (mentioned above) except (this) that he said: He who performed ablution and said: I testify that there is no god but Allah, the One, there is no associate with Him and I testify that Muhammad is His servant and His Messenger.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.453]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 453

'Abdullah b. Zaid b. 'Asim al-Ansari, who was a Companion (of the Holy Prophet), reported: It was said to him (by people): Perform for us the ablution (as it was performed) by the Messenger of Allah (way peace be upon him). He ('Abdullah b. Zaid) called for a vessel (of water), and poured water from it on his hands and washed them three times. Then he inserted his hand (in the vessel) and brought it (water) out, rinsed his mouth and snuffed up water from the palm of one hand doing that three times, He again inserted his hand and brought it out and washed his face three times, then inserted his hand and brought it out and washed each arm up to the elbow twice, then inserted his hand and brought it out and wiped his head both front and back with his hands. He then washed his feet up to the ankles, and then said: This is how God's Messenger (peace be upon him) performed ablution.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.454]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 454

This hadith is narrated by Amr b. Yahya with the same chain of transmitters, but there is no mention of ankles.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.455]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 455

Malik b. Anas narrated it from 'Amr b. Yahya with the same chain of transmitters, transmitters and mentioned the rinsing (of mouth) and snuffing (of water into the nostrils) three times, but he did not mention" from one palm," and made this addition: He moved them (his hands) for wiping to the front of his head and then the nape of his neck, then bringing them back till he reached the place from which he had begun, after which he washed his feet.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.456]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 456

Babz reported: This hadith has been narrated by Wuwb on the authority of 'Amr b. Yahyi with the same chain of transmitters and it has been mentioned therein: He rinsed his mouth. snuffed up water in nostrils and cleaned the nose with three handfuls and wiped his head moving (his hand) in front and then back once. Bahz said: Wuhaib narrated this hadith to me and Wuhaib said: Amr b. Yahya narrated to me this hadith twice.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.457]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 457

'Abdullah b. Zaid b. 'Asim al-Mazini reported: He saw Allah's Messenger (may peace be upon him) perform the ablution. He rinsed his mouth then cleaned his nose, then washed his face three times, then washed his right hand thrice and then the other one, thrice. He then took fresh water and wiped his head and then washed his feet till he cleaned them.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.458]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 458

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: When anyone wipes himself with pebbles (after answering the call of nature) he must make use of an odd number and when any one of you performs ablution he must snuff in his nose water and then clean it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.459]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 459

Hammam b. Munabbih reported: This is what Abu Huraira transmitted to us from Muhammad, the Messenger of Allah (may peace be upon him), and he mentioned a number of a hadith, of which this is one: that the Messenger of Allah (may peace be upon him) said: When anyone amongst you (performs ablution) he must snuff his nostrils with water and then clean them.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.460]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 460

Abu Huraira reported: The Messenger of Allah (way peace he upon him) said: When anyone performs ablution he must clean his nose and when anyone wipes himself with pebbles (after answering the call of nature) he must do that odd number of times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.461]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 461

It has been transmitted by Abu Huraira and Abu Sa'id al-Khudri (both of them the reputed Companions of the Holy Prophet) that the Messenger of Allah (may peace be upon him) said like that.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.462]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 462

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said. When any one of you awakes up from sleep and performs ablution, he must clean his nose three times, for the devil spends the night in the interior of his nose.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.463]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 463

Jabir b. 'Abdullah reported that he heard the Messenger of Allah (may peace be upon him) say: When anyone wipes himself with pebbles (after answering the call of nature) he should do this odd number of times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.464]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 464

Salim, the freed slave of Shaddad, said: I came to 'A'isha, the wife of the Holy Prophet (may peace be upon him), on the day when Sa'db. Abi Waqqas died. 'Abd al-Rahman b. Abu Bakr also came there and he performed ablution in her presence. She (Hadrat 'A'isha) said: Abd al-Rahman, complete the ablution as I heard the Allah's Messenger (may peace be upon him) say: Woe to the heels because of hell-fire.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.465]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 465

Abdullah, the freed slave of Shahddad, came to 'A'isha and transmitted from her a hadith like this (which she narrated) from the Holy Prophet (may peace be upon him).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.466]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 466

Salim, the freed slave of Mahri, reported: I and 'Abd al-Rahman b. Abu Bakr went out (in order to join) the funeral procession of Sa'd b. Abi Waqqas and passed by the door of the residence of 'A'isha, and then he transmitted a hadith like this from her who (narrated it) from the Holy Prophet (may peace be upon him).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.467]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 467

Salim, the freed slave of Shaddad b. al-Had said: I was in the presence of 'A'isha, and then narrated on her authority a hadith like this from the Holy Prophet (way peace be upon him).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.468]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 468

'Abdullah b. 'Amr reported: We returned from Mecca to Medina with the Messenger of Allah (may peace be upon him), and when we came to some water on the way, some of the people were in a hurry at the time of the afternoon prayer and performed ablution hurriedly; and when we reached them, their heels were dry, no water had touched them. The Prophet (may peace be upon him) said: Woe to (dry) heels, because of Hell-fire. Make your ablution thorough.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.469]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 469

In the hadith transmitted by Shu'ba these words are not there:" Complete the Wudu," and there is the name of Abu Yahya al-A'raj (a narrator).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.470]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 470

'Abdullah b. Amr reported: The Messenger of Allah (may peace be upon him) lagged behind us on a journey. We travelled (back) and be took him; and then came the time of the afternoon prayer, and as we were going to wipe our feet he (the Holy Prophet) called out: Woe to the heels because of Hell-fire.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.471]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 471

Abu Huraira reported: Allah's Apostle (may peace be upon him) saw a man who did not wash his heel and he remarked: Woe to the heels because of hell-fire.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.472]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 472

Abu Huraira reported: He saw people perform ablution with the help of a water jar and he said: Complete the Wudu for i heard Abu al-Qasim (may peace be upon him) say: Woe to the hamstrings because of hell-fire.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.473]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 473

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Woe to the heels because of hell-fire.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.474]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 474

Jabir reported: 'Umar b. Khattab said that a person performed ablution and left a small part equal to the space of a nail (unwashed). The Apostle of Allah (may peace be upon him) saw that and said: Go back and perform ablution well. He then went back (performed ablution well) and offered the prayer.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.475]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 475

Abu Huraira reported: Allah's Messenger (may peace be upon him) said: When a bondsman-a Muslim or a believer-washes his face (in course of ablution), every sin he contemplated with his eyes, will be washed away from his face along with water, or with the last drop of water; when he washes his hands, every sin they wrought will be effaced from his hands with the water, or with the last drop of water; and when he washes his feet, every sin towards which his feet have walked will be washed away with the water or with the last drop of water with the result that he comes out pure from all sins.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.476]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 476

Uthman b. 'Affan reported: The Messenger of Allah (way peace be upon him) said: He who performed ablution well, his sins would come out from his body, even coming out from under his nails.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.477]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 477

Nu'aim b. 'Abdullah al-Mujmir reported: I saw Abu Huraira perform ablution. He washed his face and washed it well. He then washed his right hand including a portion of his arm. He then washed his left hand including a portion of his arm. He then wiped his head. He then washed his right foot including his shank, and then washed his left foot including shank, and then said: This is how I saw Allah's Messenger (may peace be upon him) perform his ablution. And (Abu Huraira) added that the Messenger of Allah (may peace be upon him) had observed: You shall have your faces hands and feet bright on the Day of Resurrection because of your perfect ablution. He who can afford among you, let him increase the brightness of his forehead and that of hands and legs.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.478]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 478

Nu'aim b. 'Abdallah reported: He saw Abu Huraira perform ablution. He washed his face and washed his hands up to the arms. He then washed his feet and reached up to the shanks and then said: I heard Allah's Messenger (may peace be upon him) say: My people would come with bright faces and bright hands and feet on account of the marks of ablution, so he who can increase the lustre of his forehead (and that of his hands and legs) should do so.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.479]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 479

Abu Huraira reported: Verily Allah's Messenger (may peace be upon him) said: My Cistern has its dimensions wider than the distance between Aila and Aden, and its water is whiter than ice and sweeter than the honey diluted with milk, and its cups are more numerous than the numbers of the stars. Verily I shall prevent the (faithless) people therefrom just as a man prevents the camels of the people from his fountain. They said: Messenger of Allah, will you recognise us on that day? He said: Yes, you will have distinctive marks which nobody among the peoples (except you) will have; you would come to me with blazing forehead and bright hands and feet on account of the traces of ablution.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.480]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 480

Abu Huraira reported the Messenger of Allah (may peace be upon him) said: My people would come to me on the Cistern and I would drive away persons (from it) just as a person drives away other people's camels from his camels. They (the hearers) said: Apostle of Allah, would you recognize us? He replied: Yea, you would have a mark which other people will not have. You would come to me with a white blaze on your foreheads and white marks on your feet because of the traces of ablution. A group among you would be prevented from coming to me, and they would not meet me, and I would say: O my Lord, they are my companions. Upon this an angel would reply to me saying: Do you know what these people did after you.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.481]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 481

Hudhaifa reported: The Messenger of Allah (may peace be upon him) said: My Cistern is bigger than the space between Aila and Aden. By Him in Whose Hand is my life, I will drive away persons (from it) just as a person drives away unknown camels from his cistern. They (the companions) said: Messenger of Allab, would you recognise us? He said: Yes, you would come to me with white faces, and white hands and feet on account of the traces of ablution. None but you would have (this mark).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.482]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 482

Abu Huraira reported: The Messenger of Allah (may peace be upon him) came to the graveyard and said: Peace be upon you! the abode of the believing people and we, if God so wills, are about to join you. I love to see my brothers. They (the hearers) said: Arn't we your brothers-Messenger of Allah? He said: You are my companions, and our brothers are those who have, so far, not come into the world. They said: Messenger of Allah, how would you recognise those persons of your Ummah who have not yet been born? He said: Supposing a man had horses with white blazes on fore- heads and legs among horses which were all black, tell me, would he not recognise his own horses? They said: Certainly. Messenger of Allah. He said: They would come with white faces and arms and legs owing to ablution, and I would arrive at the Cistern before them. Some people would be driven away from my Cistern as the stray camel is driven away. I would call out. Come. come. Then it would be said (to me): These people changed themselves after you, and I would say: Be off, be off.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.483]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 483

Abu Huraira reported: The Messenger of Allah (may peace The upon him) went out to the graveyard and said: Peace be upon you, the abode of the believing people. and If Allah so wills we shall join you.... (and so on and so forth) like the hadith narrated by Isma'il b. Ja'far except the words of Malik: Then some persons would be driven away from my Cistern.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.484]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 484

Abu Hazim reported: I was (standing) behind Abu Huraira and he was performing the ablution for prayer. He extended the (washing) of his hand that it went up to his armpit. I said to him: O Abu Huraira, what is this ablution? He said: O of the tribe of Faruukh, you are here; if I knew that you were here, I would have never performed ablution like this; I have heard my Friend (may peace be upon him) say. In a believer adornment would reach the places where ablution reaches.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.485]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 485

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Should I not suggest to you that by which Allah obliterates the sins and elevates the ranks (of a man). They (the hearers) said: Yes, Messenger of Allah. He said: Performing the ablution thoroughly despite odds, tranverside of more paces towards the mosque, and waiting for the next prayer after observing a prayer, and that is mindfulness.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.486]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 486

This hadith has been narrated on the authority of Ali' b. 'Abd al-Rahman with the same chain of transmitters and there is no mention of the word of al-Ribat in the hadith transmitted by Shu'ba and in the badith narrated by Malik" Ribat" has been mentioned twice. This is the" Ribat" for you, this is the" Ribat" for you.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.487]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 487

Abu Huraira reported: The Apostle (may peace be upon him) said: Were it not that I might over-burden the believers-and in the hadith transmitted by Zuhair" people" -I would have ordered them to use toothstick at every time of prayer.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.488]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 488

Miqdam b. Shuraih narrated it from his father who said: I asked A'isha what Allah's Apostle (may peace be upon him) did first when he entered his house, and she replied: He used tooth-stick (first of all).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.489]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 489

'A'isha reported: Whenever Allah's Messenger (may peace be upon him) entered his house, he used tooth-stick first of all.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.490]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 490

Abu Musa reported: I went to the Apostle (may peace be upon him) and found one end of the tooth-stick upon his tongue (i. e. he was rinsing his mouth).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.491]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 491

Huddaifa reported: Whenever the Messenger of Allah (may peace be upon him) got up for Tahajjud prayer, he cleansed his mouth with the tooth-stick.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.492]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 492

This hadith is reported from Hudaifa by another chain of transmitters. Whenever he (the Holy Prophet) got up in the night, they (the transmitters) have not mentioned the words: for offering Tahajjud prayer.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.493]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 493

(493) Hudaifa reported: Whenever he (the Holy Prophet) got up for prayer during the night, he cleansed his mouth with the tooth-stick.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.494]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 494

Ibn 'Abbas reported that he spent a night at the house of the Apostle of Allah (may peace be upon him), The Apostle of Allah (way peace be upon him) got up for prayer in the latter part of the night. He went out and looked towards the sky and then recited this verse (190th) of AI-i-'Imran:" Verily in the creation of the heavens and the earth and the alternation of night and day." up to the (words)" save us from the torment of Hell." He then returned to his house, used the tooth-stick, performed the ablution, and then got up and offered the prayer. He than lay down on the bed. and again got up and went out and looked towards the sky and recited this verse (mentioned above), then returned, used the tooth-stick, performed ablution and again offered the prayer.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.495]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 495

Abu Huraira reported: Five are the acts quite akin to the Fitra, or five are the acts of Fitra: circumcision, shaving the pubes, cutting the nails, plucking the hair under the armpits and clipping the moustache.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.496]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 496

Abu Huraira reported: Five are the acts of fitra: circumcision, removing the pubes, clipping the moustache, cutting the nails, plucking the hair under the armpits.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.497]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 497

Anas reported: A time limit has been prescribed for us for clipping the moustache, cutting the nails, plucking hair under the armpits, shaving the pubes, that it should not be neglected far more than forty nights.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.498]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 498

Ibn Umar said: The Apostle of Allah (may peace be upon him) said: Trim closely the moustache, and let the beard grow.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.499]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 499

Ibn Umar said: The Apostle of Allah (may peace be upon him) ordered us to trim the moustache closely and spare the beard.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.500]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 500

Ibn Umar said: The Messenger of Allah (may peace be opon him) said: Act against the polytheists, trim closely the moustache and grow beard.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.501]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 501

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Trim closely the moustache, and grow beard, and thus act against the fire-worshippers.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.502]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 502

'A'isha reported: The Messenger of Allah (may peace be npon him) said: Ten are the acts according to fitra: clipping the moustache, letting the beard grow, using the tooth-stick, snuffing water in the nose, cutting the nails, washing the finger joints, plucking the hair under the armpits, shaving the pubes and cleaning one's private parts with water. The narrator said: I have forgotten the tenth, but it may have been rinsing the mouth.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.503]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 503

This hadith has been narrated by Mus'ab b. Shaiba with the same chain of transmitters except for these words:" His father said: I forgot the tenth one."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.504]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 504

Salman reported that it was said to him: Your Apostle (may peace be upon him) teaches you about everything, even about excrement. He replied: Yes, he has forbidden us to face the Qibla at the time of excretion or urination, or cleansing with right hand or with less than three pebbles, or with dung or bone.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.505]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 505

Salman said that (one among) the polytheists remarked: I see that your friend even teaches you about the excrement. He replied; Yes, he has in fact forbidden us that anyone amongst us should cleanse himself with his right hand, or face the Qibla. He has forbidden the use of dung or bone for it, and he has also instructed us not to use less than three pebbles (for this purpose).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.506]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 506

Jabir reported: The Messenger of Allah (may peace be upon him) forbade the use of bone or the droppings of camels for wiping (after excretion).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.507]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 507

Abu Ayyub reported: The Apostle of Allah (may peace be upon him) said: Whenever you go to the desert, neither turn your face nor turn your back towards the Qibla while answering the call of nature, but face towards the east or the west. Abu Ayyub said: When we came to Syria we found that the latrines already built there were facing towards the Qibla. We turned our faces away from them and begged forgiveness of the Lord. He said: Yes.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.508]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 508

Abu Huraira said: When any one amongst you squats for answering the call of nature, he should neither turn his face towards the Qibla nor turn his back towards it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.509]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 509

Wasi' b. Habban reported: I was offering my prayer in the mosque and Abdullah b. Umar was sitting there reclining with his back towards the Qibla. After completing my prayer. I went to him from one side. Abdullah said: People say when you go to the latrine, you should neither turn your face towards the Qibla nor towards Bait-ul-Maqdis. 'Abdullah said (farther): I went up to the roof of the house and saw the Messenger of Allah (may peace be upon him) squatting on two bricks for relieving himself with his face towards Bait-al-Maqdis.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.510]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 510

Abdullah b. Umar said: I went up to the roof of the house of my sister Hafsa and saw the Messenger of Allah (may peace be upon him) relieving himself facing Syria. with his back to the Qibla.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.511]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 511

Abu Qatada reported it from his father: The Messenger of Allah (may peace be upon him) said: None of you should hold penis with his right hand while urinating, or wipe himself with his right hand in privy and should not breathe into the vessel (from which he drinks).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.512]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 512

Abu Qatada reported it from his father that the Messenger of Allah (may peace be upon him) said: When anyone amongst you enters the privy he should not touch his penis with his right hand.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.513]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 513

Aba Qatada reported: The Messenger of Allah (way peace be upon him) forbade (us) to breathe into the venel, to touch the penis with the right hand and to wipe after relieving with right hand.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.514]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 514

'A'isha reported: The Messenger of Allah (way peace be upon him) loved to start from the right-hand side for performing ablution, for combing (the hair) and wearing the shoes.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.515]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 515

'A'isha reported: The Messenger of Allah (may peace be upon him) loved to start from the right-hand side in his every act i. e. in wearing shoes, in combing (his hair) and in performing ablution.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.516]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 516

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Be on your guard against two things which provoke cursing. They (the companions present there) said: Messenger of Allah, what are those things which provoke cursing? He said: Easing on the thoroughfares or under the shades (where they take shelter and rest).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.517]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 517

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) entered an enclosure while a servant was following him with a jar of water and he was the youngest amongst us and he placed it by the side of a lote-tree. When the Messenger of Allah, (may peace be upon him) relieved himself, he came out and had cleansed himself with water.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.518]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 518

Anas b. Malik reported: When the Messenger of Allah (may peace be upon him) entered the privy, a servant and I used to carry a skin of water, and a pointed staff, and he would cleanse himself with water.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.519]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 519

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) went to a far-off place in the desert (hidden from the sight of human beings) for relieving himself. Then I brought water for him and he cleansed himself.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.520]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 520

Hummam reported: Jarir urinated, then performed ablution and wiped over the socks. It was said to him: Do you do like this? He said: Yes, I saw that the Messenger of Allah (may peace be upon him) urinated, then performed ablution and then wiped over his shoes. A'mash said: Ibrahim had observed that this hadith was a surprise for them (the people) because Jarir had embraced Islam after the revelation of Surat al-Ma'ida.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.521]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 521

This hadith is narrated on the same authority from A'mash by another chain of transmitters like one transmitted by Abu Mu'awyia. The hadith reported by 'Isa and Sufyan has these words also:" This hadith surprised the friends of Abdullab'" for Jarir had embraced Islam after the revelation of al-Ma'ida.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.522]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 522

Hudhaifa reported: I was with the Apostle of Allah (may peace be upon him) when he came to the dumping ground of filth belonging to a particular tribe. He urinated while standing, and I went aside. He (the Holy Prophet) asked me to come near him and I went so near to him that I stood behind his heels. He then performed ablution and wiped over his socks.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.523]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 523

Abu Wa'il reported: Abu Musa inflicted extreme rigour upon himself in the matter of urination and urinated in a bottle and said: When the skin of anyone amongst the people of Israel was besmeared with urine, he cut that portion with a cutter. Hudhaifa said: I wish that'your friend should not inflict such an extreme rigour. I and the Messenger of Allah (may peace be upon him) were going together till we reached the dumping ground of filth behind an enclosure. He stood up as one among you would stand up. and he urinated, I tried to turn away from him, but he beckoned to me, so I went to him and I stood behind him, till he had relieved himself.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.524]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 524

The son of Mughira b. Shu'ba reported: The Messenger of Allah (may peace be upon him) went out for relieving himself. Mughira went with him carrying a jug full of water. When he (the Holy Prophet) came back after relieving himself, he poured water over him and he performed ablution and wiped over his socks; and in the narration of Ibn Rumh there is" till" instead of" when".


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.525]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 525

This hadith has been transmitted with the same chain of transmitters by Yahya b. Sa'id with the addition of these words:" He washed his face and hands, and wiped his head and then wiped his socks."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.526]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 526

Mughira b. Shu'ba reported: I was with the Messenger of Allah (may peace be upon him) one night. He came down (from the ride) and relieved himself. He then came and I poured water upon him from the jar that I carried with me. He performed ablution and wiped over his socks.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.527]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 527

Mughira b. Shu'ba reported: I was in the company of the Messenger of Allah (may peace be upon him) on a journey when he said: Mughira take hold of this jar (of water). I took hold of it and I went out with him. (I stopped but) the Messenger of Allah (may peace be upon him) proceeded on till he was out of my sight. He relieved himself and then came back and he was wearing a tight-sleeved Syrian gown. He tried to get his forearms out. but the sleeve of the gown was very narrow, so he brought his hands out from under the gown. I poured water over (his hands) and he performed ablution for prayer, then wiped over his socks and prayed.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.528]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 528

Mughira b. Shu'ba reported: The Messenger of Allah (may peace be upon him) went out for relieving himself. When he came back I brought for him a jar (of water) and poured water upon his hands and He washed his face. He tried to wash his forearms, but as the (sleeves of the) gown were tight. He, therefore, brought them out from under the gown. He then washed them, wiped his head, and wiped his socks and then prayed.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.529]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 529

'Urwa b. Mughira reported his father having said: I was one night with the Apostle of Allah (may peace be upon him) on a journey. He said to me: Have you any water with you? I said: Yes. He (the Holy Prophet) came down from his ride and went on till he disappeared in the darkness of night. He then came back and I poured water for him from the jar. He washed his face, He had a woollen gown on him and he could not bring out his forearms from it (i. e. from its sleeves) and consequently he brought them out from under his gown. He washed his forearms, wiped over his head. I then bent down to take off his socks. But he said: Leave them, for my feet were clean when I put them in, and he only wiped over them.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.530]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 530

'Urwah al Mughira reported it from his father: He (Mughira) helped the Apostle (may peace be upon him) in performing the ablution, and he performed it and wiped over his shoes. He (Mughira) said to him (about the washing of the feet after putting them off), but he (the Holy Prophet) said: I put them (feet) in when these were clean.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.531]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 531

'Urwa b. al Mughira b. Shu'ba reported it on the authority of his father that he said: The Messenger of Allah (may peace be upon him) lagged behind (in a journey) and I also lagged behind along with him. After having relieved himself he said: Have you any water with you? I brought to him a jar of water; he washed his palms, and face, and when he tried to get his forearms out (he could not) for the sleeve of the gown was tight. He, therefore, brought them out from under the gown and, throwing it over his shoulders, he washed his forearm. He then wiped his forelock and his turban and his socks. He then mounted and I also mounted (the ride) and came to the people. They had begun the prayer with 'Abd ar-Rabmin b. 'Anf leading them and had completed a rak'a. When he perceived the presence of the Apostle of Allah (may peace be upon him) he began to retire. He (the Holy Prophet) signed to him to continue and offered prayer along with them. Then when he had pronounced the salutation, the Apostle (may peace be upon him) got up and I also got up with him, and we offered the rak'a which had been finished before we came.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.532]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 532

Ibn Mughira narrated it from his father: The Apostle of Allah (may peace be upon him) wiped over his socks and over his forehead and over his turban.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.533]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 533

This hadith has been transmitted by Ibn Mughira on the authority of his father by another chain of transmitters.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.534]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 534

Bakr reported that he had heard from the son of Mughira that verily the Apostle of Allah (may peace be upon him) performed ablution and wiped over his forehead and wiped over his turban and over his socks.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.535]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 535

It is narrated from Bilal that the Messenger of Allah (may peace be upon him) wiped over the socks and turban, and in the hadith transmitted by 'Isa b. Yaunus the words are:" Bilal narrated it to me."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.536]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 536

This tradition is transmitted by A'mash with this addition;, I saw the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.537]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 537

Shuraih b. Hani said: I came to 'A'isha to ask her about wiping over the socks. She said: You better ask ('Ali) son of Abu Talib for he used to travel with Allah's Messenger (may peace be upon him). We asked him and he said: The Messenger of Allah (may peace be upon him) stipulated (the upper limit) of three days and three nights for a traveller and one day and one night for the resident.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.538]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 538

This hadith is narrated by Ubaidullah b. 'Amr and Zaid b. Abu Unaisa with the same chain of transmitters.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.539]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 539

Shuraib b. Hani reported: I asked 'A'isha about wiping over the shoes. She said: You better go to 'Ali, for he knows more about this than I. I, therefore, came to 'Ali and he narrated from the Apostle (may peace be upon him) like this.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.540]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 540

Sulaiman b. Buraida narrated it from his father that the Apostle of Allah (may peace be upon him) offered prayers with one ablution on the day of the Conquest (of Mecca) and wiped over the socks. 'Umar said to him: You have today done something that you have not been accustomed to before. He (the Holy Prophet) said: 0 'Umar, I have done that on purpose.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.541]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 541

Abu Huraira said: When anyone amongst you wakes up from sleep, he must not put his hand in the utensil till he has washed it three times, for he does not know where his hand was during the night.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.542]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 542

This hadith is transmitted from Abu Huraira by another chain of transmitters.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.543]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 543

Zahri and Ibn Musayyab have both transmitted a hadith like this from Abu Huraira who narrated it from the Apostle (may peace be upon him).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.544]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 544

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When anyone amongst you wakes up from sleep, he should wash his hands three times before putting it in the utensil, for he does not know wher.. his hand was during the night.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.545]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 545

This hadith has been transmitted through other chains of transmitters on the authority of Abu Huraira in which it is reported that the Apostle of Allah (may peace be upon him) made a mention of washing the hand, and did not instruct to wash it three times. But the hadith narrated from Jabir and Ibn Musayyab. Abu Salama, and Abdullah b. Shaqiq, Abu Salih, Abla Razin, there is a mention of" three times".


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.546]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 546

Abu Huraira reported the Messenger of Allah (may peace be upon him) to have said: When a dog licks a utensil belonging to any one of you, (the thing contained in it) should be thrown away and then (the utensil) should be washed seven times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.547]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 547

This hadith has been transmitted by another chain of transmitters in which there is no mention of" throwing away".


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.548]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 548

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When a dog drinks out of a vessel belonging to any one of you, he must wash it seven times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.549]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 549

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The purification of the utensil belonging to any one of you, after it is licked by a dog, lies in washing it seven times, using sand for the first time.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.550]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 550

Hammam b. Munabbih reported: Of the a hadith narrated by Abu Huraira from Muhammad, the Messenger of Allah (may peace be upon him), one is this: The Messenger of Allah (may peace be upon him) said: The purification of the utensil belonging to one amongst you, after it is licked by a dog, lies in washing it seven times.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.551]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 551

Ibn Mughaffal reported: The Messenger of Allah (may peace be upon him) ordered killing of the dogs, and then said: What about them, i. e. about other dogs? and then granted concession (to keep) the dog for hunting and the dog for (the security) of the herd, and said: When the dog licks the utensil, wash it seven times, and rub it with earth the eighth time.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.552]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 552

A hadith like this has been narrated from Shu'ba with the same chain of transmitters except for the fact that in the hadith transmitted by Yahya those words are:" He (the Holy Prophet) gave concession in the case of the dog for looking after the herd, for hunting and for watching the cultivated land," and there is no mention of this addition (i. e. concession in case of watching the cultivated lands) except in the hadith transmitted by Yahya.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.553]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 553

Jabir reported: The Messenger of Allah (may peace be upon him) forbade to urinate in stagnant water.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.554]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 554

Abu Huraira reported: the Messenger of Allah (may peace be upon him) said: None amongst you should urinate in standing water, and then wash in it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.555]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 555

Hammam b. Munabbih said: Of the ahadith narrated to us by Abfi Huraira from Muhammad the Messenger of Allah (may peace be upon him) one is this: The Messenger or Allah (may peace be upon him) said: You should not urinate in standing water, that is not flowing, then wash in it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.556]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 556

Abu Huraira reported the Messenger of Allah (may peace be upon him) saying: None of you must wash in standing water when he is in a state of Junub. And Abu Huraira was asked how it was to be done; he said: It was to be taken out in handfuls.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.557]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 557

Anas reported: A Bedouin urinated in the mosque. Some of the persons stood up (to reprimand him or to check him from doing so), but the Messenger of Allah (may peace be upon him) said: Leave him alone; don't interrupt him. He (the narrator) said: And when he had finished, he called for a bucket of water and poured it over.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.558]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 558

Anas b. Malik narrated that a desert Arab (Bedouin) stood in a corner of the mosque and urinated there. The people (the Companions of the Holy Prophet who were present there) shouted, but the Messenger of Allah (may peace be upon him) said: Leave him alone. When he had finished, the Messenger of Allah (may peace be upon him) ordered that a bucket (of water) should be brought and poured over it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.559]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 559

Anas b. Malik reported: While we were in the mosque with Allah's Messenger (may peace be upon him), a desert Arab came and stood up and began to urinate in the mosque. The Companions of Allah's Messenger (may peace be upon him) said: Stop, stop, but the Messenger of Allah (may peace be upon him) said: Don't interrupt him; leave him alone. They left him alone, and when he finished urinating, Allah's Messenger (may peace be upon him) called him and said to him: These mosques are not the places meant for urine and filth, but are only for the remembrance of Allah, prayer and the recitation of the Qur'an, or Allah's Messenger said something like that. He (the narrator) said that he (the Holy Prophet) then gave orders to one of the people who brought a bucket of water and poured It over.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.560]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 560

A'isha, the wife of the Apostle (may peace be upon him) said: Babies were brought to the Messenger of Allah (may peace be upon him) and he blessed them, and after having chewed (something, e. g. dates or any other sweet thing) he rubbed there with their soft palates. A baby was brought to him and he passed water over him (over his garment), so he asked water to be brought and sprinkled it, but he did not wash it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.561]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 561

A'isha reported: A suckling babe was brought to the Messenger of Allah (way peace be upon him) and he urinated in his tap. He (the Holy Prophet) sent for water and poured it over.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.562]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 562

Hisham narrated the hadith like one transmitted by Ibn Numair (the above mentioned one) with the same chain of transmitters.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.563]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 563

Umm Qais daughter of Mihsan reported that she came to the Messenger of Allah (may peace be upon him) with her child. who was not yet weaned, and she placed him in his lap; and he urinated in his (Holy Prophet's) lap. He (the Holy Prophet) did nothing more than spraying water over it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.564]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 564

This hadith has also been narrated from al-Zuhri with the same chain of narrators. (but for the words):" He (the Holy Prophet) sent for water and sprinkled it over."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.565]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 565

Ubaidullah b. Abdullah b. 'Utba b. Mas'ud said: Umm Qais, daughter of Mihsan, was among the earliest female emigrants who took the oath of allegiance to the Messenger of Allah (may peace be upon him), and she was the sister of 'Ukkasha b. Mihsan, one amongst the sons of Asad b. Khuzaima. He (the narrator) said: She (Umm Qais) told me that she came to the Messenger of Allah (may peace he upon him) with her son and he had not attained the age of eating food. He (the narrator, 'Ubaidullah), said: She told me that her son passed urine in the lap of the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) sent for water and sprayed it over his garment (over that part which was contaminated with the urine of the child) and he did not wash it thoroughly.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.566]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 566

Alqama and Aswad reported: A person stayed in the house of A'isha and in the morning began to wash his garment. A'isha said: In case you saw it (i. e. drop of semen), it would have served the purpose (of purifying the garment) if you had simply washed that spot; and in case you did not see it, it would have been enough to sprinkle water around it, for when I saw that on the garment of the Messenger of Allah (may peace be upon him). I simply scraped it off and he offered prayer, while putting that on.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.567]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 567

Al-Aawad and Hammam reported A'isha as saying: I used to scrape off the (drop of) semen from the garment of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.568]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 568

Qutaiba b. Sa'id, Ishaq b. Ibrahim, Ibn Abi 'Aruba, Abu Ma'shar, Abu Bakr b. Abu Shaiba, Mansur and Mughira have all transmitted from Ibrahim, who transmitted it on the authority of A'isha's narration pertaining to the scraping off of the (drop) of semen from the garment of the Messenger of Allah (may peace be upon him) like the hadith of Khalid on the authority of Abu Ma'shar.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.569]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 569

Hammam narrated the hadith from A'isha like the (above-mentioned) traditions.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.570]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 570

'Amr b. Maimun said: I asked Sulaiman b. Yasir whether the semen that gets on to the garment of a person should be washed or not. He replied: A'isha told me: The Messenger of Allah (may peace be upon him) washed the semen, and then went out for prayer in that very garment and I saw the mark of washing on it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.571]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 571

Abu Kuraib, Ibn al-Mubarak, Ibn Abu Za'ida all of them narrated from Amr b. Maimun with the same chain of transmitters. Ibn Abu Za'ida narrated as was transmitted from Ibn Bishr that the Messenger of Allah (may peace be upon him) washed semen, and in the hadith transmitted on the authority of Ibn Mabarak and Abdul Wahid the words are:" She (A'isha) reported: I used to wash it from the garment of the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.572]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 572

Abdullah b. Shihab al-Khaulani reported: I stayed in the house of 'A'isha and had a wet dream (and perceived its effect on my garment), so (in the morning) I dipped both (the clothes) in water. This (act of mine) was watched by a maid-servant of A'isha and she informed her. She (Hadrat A'isha) sent me a message: Whatprompted you to act like this with your clothes? He (the narrator) said: I told that I saw in a dream what a sleeper sees. She said: Did you find (any mark of the fluid) on your clothes? I said: No. She said: Had you found anything you should have washed it. Incase I found that (semen) on the garment of the Messenger of Allah (may peace be upon him) dried up, I scraped it off with my nails.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.573]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 573

Asma (daughter of Abu Bakr) reported: A woman came to the Apostle of Allah (may peace be upon him) and said: What should one do if the blood of menses smears the garment of one amongst us? He (the Holy Prophet) replied: She should scrape it, then rub it with water, then pour water over it and then offer prayer in it.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.574]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 574

This tradition is narrated by Abu Kuraib, Ibn Numair, Abu Tahir, Ibn Wahb, Yahya b. 'Abdullah b. Salim, Malik b. Anas, 'Amr b. Harith on the authority of Hisham b. 'Urwa, with the same chain of transmitters like one transmitted by Yahya b. Sa'id like the above-mentioned.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.575]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 575

Ibn Abbas reported: The Messenger of Allah (may peace be upon him) happened to pass by two graves and said: They (their occupants) are being tormented, but they are not tormented for a grievous sin. One of them carried tales and the other did not keep himself safe from being defiled by urine. He then called for a fresh twig and split it into two parts, and planted them on each grave and then said: Perhaps, their punishment way be mitigated as long as these twigs remain fresh.


Muslim :: The Book of Purification (Kitab Al-Taharah) :: [2.576]

The Book of Purification (Kitab Al-Taharah)

Muslim :: Book 2 : Hadith 576

This hadith is transmitted from A'mash by Abmad b. Yusuf al-Azdi, Mu'alla b. Asad, Abd al-Wahid, Sulaiman with the same chain of transmitters but for the words:" The other did not keep himself safe from being defiled by urine."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.577]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 577

'A'isha reported: When anyone amongst us (amongst the wives of the Holy Prophet) menstruated, the Messenger of Allah (may peace be upon him) asked her to tie a waist-wrapper over her (body) and then embraced her.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.578]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 578

'A'isha reported: When anyone amongst us was menstruating the Messenger of Allah (may peace be upon him) asked her to tie waist-wrapper daring the time when the menstrual blood profusely flowed and then embraced her; and she ('A'isha) observed: And who amongst you can have control over his desires as the Messenger of Allah (may peace be upon him) had over his desires.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.579]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 579

Maimuna (the wife of the Holy Prophet) reported: The Messenger of Allah (may peace be upon him) contacted and embraced his wives over the waist-wrapper when they were menstruating.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.580]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 580

Kuraibthe freed slave of Ibn Abbas, reported: I heard it from Maimuna, the wife of the Apostle of Allah (way peace be upon him): The Messenger of Allah (may peace be upon him) used to lie with me when I menstruated, and there was a cloth between me and him.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.581]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 581

Umm Salama reported: While I was lying with the Messenger of Allah (may peace be upon him) in a bed cover I menstruated, so I slipped away and I took up the clothes (which I wore) in menses. Upon this the Messenger of Allah (may peace be upon him) said: Have you menstruated? I said: Yes. He called me and I lay down


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.582]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 582

It is reported from 'A'isha that she observed: When the Messenger of Allah (may peace be upon him) was in I'tikaf, he inclined his head towards me and I combedhis hair, and he did not enter the house but for the natural calls (for relieving himself).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.583]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 583

'Amra daughter of 'Abd al-Rahman reported: 'A'isha, wife of the Apostle of Allah (may peace be upon him) observed: When I was (in I'tikaf), I entered the house for the call of nature, and while passing I inquired after the health of the sick (in the. family), and when the Messenger of Allah (may peace be upon him) was (in I'tikaf), he put out his head towards me, while he himself was in the mosque, and I combed his hair; and he did not enter the house except for the call of nature so long as he was In I'tikaf; and Ibn Rumh stated: As long as they (the Prophet and his wives) were among the observers of I'tikaf.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.584]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 584

'A'isha, the wife of the Apostle (may peace he upon him), reported: The Messenger of Allah (may peace be upon him) put out from the mosque his head for me as he was in I'tikaf, and I washed it in the state that I was menstruating.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.585]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 585

'Urwa reported it from 'A'isha that she observed: The Messenger of Allah (may peace be upon him) inclined his head towards me (from the mosque) while I was in my apartment and I combed it in a state of menstruation.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.586]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 586

Al-Aswad narrated it from 'A'isha that she observed: I used to wash the head of the Messenger of Allah (may peace be upon him), while I was in a state of menstruation.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.587]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 587

'A'isha reported: The Messenger of Allah (may peace be upon him) said to me: Get me the mat from the mosque. I said: I am menstruating. Upon this he remarked: Your menstruation is not in your hand.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.588]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 588

'A'isha reported: The Messenger of Allah (may peace be upon him) ordered me that I should get him the mat from the mosque. I said: I am menstruating. He (the Holy Prophet) said: Do get me that, for menstruation is not in your hand.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.589]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 589

Abu Huraira reported: While the Messenger of Allah (may peace be upon him) was in the mosque, he said: O 'A'isha, get me that garment. She said: I am menstruating. Upon this he remarked: Your menstruation is not in your hand, and she, therefore, got him that.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.590]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 590

'A'isha reported: I would drink when I was menstruating, then I would hand it (the vessel) to the Apostle (may peace be upon him) and he would put his mouth where mine had been, and drink, and I would eat flesh from a bone when I was menstruating, then hand it over to the Apostle (may peace be upon him) and he would put his mouth where mine had been. Zuhair made no mention of (the Holy Prophet's) drinking.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.591]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 591

'A'isha reported: The Messenger of Allah (may peace be upon him) would recline in my lap when I was menstruating, and recite the Qur'an.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.592]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 592

Thabit narrated it from Anas: Among the Jews, when a woman menstruated, they did not dine with her, nor did they live with them in their houses; so the Companions of the Apostle (may peace be upon him) asked The Apostle (may peace be upon him), and Allah, the Exalted revealed:" And they ask you about menstruation; say it is a pollution, so keep away from woman during menstruation" to the end (Qur'an, ii. 222). The Messenger of Allah (may peace be upon him) said: Do everything except intercourse. The Jews heard of that and said: This man does not want to leave anything we do without opposing us in it. Usaid b. Hudair and Abbad b. Bishr came and said: Messenger of Allah, the Jews say such and such thing. We should not have, therefore, any contactwith them (as the Jews do). The face of the Messenger of Allah (way peace be upon him) underwent such a change that we thought he was angry with them, but when they went out, they happened to receive a gift of milk which was sent to the Apostle of Allah (may peace be upon him). He (the Holy Prophet) called for them and gave them drink, whereby they knew that he was not angry with them.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.593]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 593

'Ali reported: I was one whose prostatic fluid flowed readily and I was ashamed to ask the Apostle (may peace be upon him) about it, because of the position of his daughter. I, therefore, asked Miqdad. b. al-Asad and he inquired of him (the Holy Prophet). He (the Holy Prophet) said: He should wash his male organ and perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.594]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 594

'Ali reported: I felt shy of asking about prostatic fluid from the Apostle (may peace be upon him) because of Fatimah. I, therefore, asked al-Miqdad (to ask on my behalf) and he asked. He (the Holy Prophet) said: Ablution is obligatory in such a case.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.595]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 595

Ibn 'Abbas reported it from 'Ali: We sent al-Miqdad b. al-Aswad to the Messenger of Allah (may peace be upon him) to ask him what must be done about prostatic fluid which flows from (the private part of) a person. The Messenger of Allah (may peace be upon him) said: Perform ablution and wash your sexual organ.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.596]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 596

Ibn 'Abbas reported: The Apostle (may peace be upon him) woke up at night; relieved himself, and then washed his face and hands and then again slept.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.597]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 597

'A'isha reported: Whenever the Messenger of Allah (may peace be upon him) intended to sleep after having sexual intercourse, he performed ablution as for the prayer before going to sleep.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.598]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 598

'A'isha reported: Whenever the Messenger of Allah (may peace be upon him) had sexual intercourse and intended to eat or sleep, he performed the ablution of prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.599]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 599

This hadith has been transmitted by Shu'ba with the same chain of transmitters. Ibn at-Muthanna said in his narration: AI-Hakam narrated to us who heard from Ibrahim narrating that.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.600]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 600

Ibn 'Umar reported: Umar said: Is one amongst us permitted to sleep in a state of impurity (i. e. after having sexual intercourse)? He (the Holy Prophet) said: Yes, after performing ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.601]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 601

Ibn 'Umar said: 'Umar asked the verdict of the Shari'ah from the Apostle (may peace be upon him) thus: Is it permissible for any one of us to sleep in a state of impurity? He (the Holy Prophet said: Yes, he must perform ablution and then sleep and take a bath when he desires.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.602]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 602

Ibn Umar reported: Umar b. al-Khattab said to the Messenger of Allah (may peace be upon him), that he became Junbi during the night. The Messenger of Allah (may peace be upon him) said to him: Perform ablution, wash your sexual organ and then go to sleep.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.603]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 603

'Abdullah b. Abu'l-Qais reported: I asked 'A'isha about the Witr (prayer) of the Messenger of Allah (may peace be upon him) and made mention of a hadith, then I said: What did he do after having sexual intercourse? Did he take a bath before going to sleep or did he sleep before taking a bath? She said: He did all these. Some- times he took a bath and then slept, and sometimes he performed ablution only and went to sleep. I (the narrator) said: Praise be to Allah Who has made things easy (for human beings).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.604]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 604

This hadith has been transmitted with the same chain of transmitters from Mu'awyia b. Salih by Zuhair b. Harb, 'Abd al-Rahman b. Mahdi, Harun b. Sa'id al-'Aili and Ibn Wahb.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.605]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 605

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you has sexual intercourse with his wife and then he intends to repeat it, he should perform ablution. In the hadith transmitted by Abu Bakr. (the words are):" Between the two (acts) there should be an ablution," or he (the narrator) said:" Then he intended that it should be repeated."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.606]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 606

Anas reported: The Messenger of Allah (may peace be upon him) used to have sexual intercourse with his wives with a single bath.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.607]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 607

Anas b. Malik reported: Umm Sulaim who was the grandmother of Ishaq came to the Messenger of Allah (may peace be upon him) in the presence of 'A'isha and said to him: Messenger of Allah, in case or woman sees what a man sees in dream and she experiences in dream what a man experiences (i. e. experiences orgasm)? Upon this 'A'isha remarked: O Umm Sulaim, you brought humiliation to women;may your right hand be covered with dust. He (the Holy Prophet) said to 'A'isha: Let your hand be covered with dust, and (addressing Umm Sulaim) said: Well, O Umm Sulaim, she should take a bath if she sees that (i. e. she experiences orgasm in dream).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.608]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 608

Anas b. Malik reported that Umm Sulaim narrated it that she asked the Apostle of Allah (may peace be upon him) about a woman who sees in a dream what a man sees (sexual dream). The Messenger of Allah (may peace be upon bi m) said: In case a woman sees that, she must take a bath. Umm Sulaim said: I was bashful on account of that and said: Does it happen? Upon this the Apostle of Allah (may peace be upon him) said: Yes (it does happen), otherwise how can (a child) resemble her? Man's discharge (i. e. sperm) is thick and white and the discharge of woman is thin and yellow; so the resemblance comes from the one whose genes prevail or dominate.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.609]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 609

Anas b. Malik reported: A woman asked the Messenger of Allah (way peace be upon him) about a woman who sees in her dream what a man sees in his dream (sexual dream). He (the Holy Prophet) said: If she experiences what a man experiences, she should take a bath.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.610]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 610

Umm Salama reported: Umm Sulaim went to the Apostle of Allah (may peace be upon him) and said: Apostle of Allah, Allah is not ashamed of the truth. Is bathing necessary for a woman when she has a sexual dream? Upon this the Messenger of Allah (may peace be upon him) said: Yes, when she sees the liquid (vaginal secretion). Umm Salama said: Messenger of Allah, does a woman have sexual dream? He (the Holy Prophet) said: Let your hand be covered with dust, in what way does her child resemble her?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.611]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 611

This hadith with the same sense (as narrated above) bus been transmitted from Hisham b. 'Urwa with the same chain of narrators but with this addition that she (Umm Salama) said:" You humiliated the women.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.612]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 612

'A'isha the wife of the Apostle (may peace be upon him) narrated: Umm Sulaim, the mother of Bani Abu Talha, came to the Messenger of Allah (may peace be upon him), and a hadith (like that) narrated by Hisham was narrated but for these words. A'isha said: I expressed disapproval to her, saying: Does a woman see a sexual dream?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.613]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 613

It is reported on the authority of 'A'isha that a woman came to the Messenger of Allah (may peace be upon him) and inquired: Should a woman wash herself when she sees a sexual dream and sees (the marks) of liquid? He (the Holy Prophet) said: Yes. 'A'isha said to her: May your hand be covered with dust and injured. She narrated: The Messenger of Allah (may peace be upon him) said: Leave her alone. In what way does the child resemble her but for the fact that when the genes contributed by woman prevail upon those of man, the child resembles the maternal family, and when the genes of man prevail upon those of woman the child resembles the paternal family.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.614]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 614

Thauban, the freed slave of the Messenger of Allah (may peace be upon him), said: While I was standing beside the Messenger of Allah (may peace be upon him) one of the rabbis of the Jews came and said: Peace be upon you, O Muhammad. I pushed him backwith a push that he was going to fall. Upon this he said: Why do you push me? I said: Why don't you say: O Messenger of Allah? The Jew said: We call him by the name by which he was named by his family. The Messenger of Allah (may peace be upon him) said: My name is Muhammad with which I was named by my family. The Jew said: I have come to ask you (something). The Messenger of Allah (may peace be upon him) said: Should that thing be of any benefit to you, if I tell you that? He (the Jew) said: I will lend my ears to it. The Messenger of Allah (may peace be upon him) drew a line with the help of the stick that he had with him and then said: Ask (whatever you like). Thereupon the Jew said: Where would the human beings be on the Daywhen the earth would change into another earth and the heavens too (would change into other heavens)? The Messenger of Allah (may peace be upon him) said: They would be in darkness beside the Bridge. He (the Jew) again said: Who amongst people would be the first to cross (this bridge).? He said: They would be the poor amongst the refugees. The Jew said: What would constitute their breakfast when they would enter Paradise? He (the Holy Prophet) replied: A caul of the fish-liver. He (the Jew) said. What would be their food alter this? He (the Holy Prophet) said: A bullockwhich was fed in the different quarters of Paradise would be slaughtered for them. He (the Jew) said: What would be their drink? He (the Holy Prophet) said: They would be given drink from the fountain which is named" Salsabil". He (the Jew) said: I have come to ask you about a thing which no one amongst the people on the earth knows except an apostle or one or two men besides him. He (the Holy Prophet) said: Would it benefit you if I tell you that? He (the Jew) said: I would lend ears to that. He then said: I have come to ask you about the child. He (the Holy Prophet) said: The reproductive substance of man is white and that of woman (i. e. ovum central portion) yellow, and when they have sexual intercourse and the male's substance (chromosomes and genes) prevails upon the female's substance (chromosomes and genes), it is the male child that is created by Allah's Decree, and when the substance of the female prevails upon the substance contributed by the male, a female child is formed by the Decree of Allah. The Jew said: What you have said is true; verily you are an Apostle. He then returned and went away. The Messenger of Allah (may peace be upon him) said: He asked me about such and such things of which I have had no knowledge till Allah gave me that.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.615]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 615

This tradition has been narrated by Mu'awyia b. Salim with the same chain of transmitters except for the words: I was sitting beside the Messenger of Allah" and some other minor alterations.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.616]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 616

'A'isha reported: When Allah's Messenger (may peace be upon him) bathed because of sexual intercourse, he first washed his hands: he then poured water with his right hand on his left hand and washed his private parts. He then performed ablution as is done for prayer'. He then took some water and put his fingers and moved them through the roots of his hair. And when he found that these had been properly mois- tened, then poured three handfuls on his head and then poured water over his body and subsequently washed his feet.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.617]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 617

This hadith is narrated by Abu Kuraib. Ibn Numair and others, all on the authority of Hisham with the same chain of transmitters, but in their narration these words are not there:" washed his feet."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.618]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 618

Hisham narrated it from his father, who narrated it on the authority of 'A'isha that when the Apostle (may peace be upon him) took a bath because of sexual inter-course, he first washed the palms of his hands three times, and then the whole hadith was transmitted like that based on the authority of Abu Mu'awyia, but no mention is made of the washing of feet.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.619]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 619

'Urwa has narrated it on the authority of 'A'isha that when Allah's Messenger (may peace be upon him) took a bath because of sexual intercourse, he first washed his hands before dipping one of them into the basin, and then performed ablu- tion as is done for prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.620]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 620

Ibn 'Abbas reported it on the authority of Maimuna, his mother's sister, that she said: I placed water near the Messenger of Allah (may peace be upon him) to take a bath because of sexual intercourse. He washed the palms of his bands twice or thrice and then put his hand In the basin and poured water over his private parts and washed them with his left hand. He then struck his hand against the earth and rubbed it with force and then performed ablution for the prayer and then poured three handfuls of water on his head and then washed his whole body after which he moved aside from that place and washed his feet, and then I brought a towel (so that he may wipe his body). but he returned it.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.621]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 621

This hadith is narrated by A'mash with the same chain of transmitters, but in the hadith narrated by Yahya b. Yahya and Abu Kuraib there is no mention of:" Pouring of three handfuls of water on the head." and in the hadith narrated by Waki' all the features of ablution have been recorded: rinsing (of mouth), snuffing of water (in the nostrils) ; and in the hadith transmitted by Abu Mu'awyia, there is no mention of a towel.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.622]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 622

Ibn Abbas narrated It on the authority of Maimuna that the Apostle of Allah (may peace be upon him) was given a towel, but he did not rub (his body) with it, but he did like this with water, i. e. he shook it off.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.623]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 623

'A'isha reported: When the Messenger of Allah (may peace be upon him) took a bath because of sexual intercourse, he called for a vessel and took a handful of water from it and first (washed) the right side of his head, then left, and then took a handful (of water) and poured it on his head.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.624]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 624

'A'isha reported: The Messenger of Allah (may peace be upon him) washed himself with water from a vessel (measuring seven to eight seers) because of sexual intercourse.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.625]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 625

'A'isha reported: The Messenger of Allah (may peace be upon him) took a bath from the vessel (which contained seven to eight seers, i. e. fifteen to sixteen pounds) of water And I and he (the Holy Prophet) took a bath from the same vessel. And in the hadith narrated by Sufyan the words are:" from one vessel". Qutaiba said: Al-Faraq is three Sa' (a cubic measuring of varying magnitude).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.626]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 626

Abu Salamab. 'Abd al-Rahman reported: I along with the foster brother of 'A'isha went to her and he asked about the bath of the Apostle (may peace be upon him) because of sexual intercourse. She called for a vessel equal to a Sa' and she took a bath. and there was a curtain between us and her. She poured water on her head thrice and he (Abu Salama) said: The wives of the Apostle (may peace be upon him) collectedhair on their heads and these lopped up to ears (and did rot go beyond that).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.627]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 627

Salama b. Abd al-Rahman narrated it on the authority of A'isha that when the Messenger of Allah (may peace be upon him) took a bath, he started from the right hand and poured water over it and washed it, and then poured water on the impurity with the right band and washed it away with the help of the left hand. and after having removed it, he poured water on his head. A'isha said: I and the Messenger of Allah (may peace be upon him) took a bath from the same vessel, after sexual intercourse.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.628]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 628

Hafsa, daughter of 'Abd al-Rahman b. Abu Bakr, reported that 'A'isha narrated to her that she and the Apostle of Allah (may peace be upon him) took a bath from the same vessel which contained water equal to three Mudds or thereabout.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.629]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 629

'A'isha reported: I and the Messenger (may peace be upon him) took a bath from the same vessel and our hands alternated into it in the state that we had had sexual intercourse.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.630]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 630

'A'isha reported: I and the Messenger of Allah (may peace be upon him) took a bath from one vessel which was placed between me and him and he would get ahead of me, so that I would say: Spare (some water for) me, spare (some water for) me; and she said that they had had sexual intercourse.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.631]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 631

Ibn Abbas said: Maimuna (the wife of the Holy Prophet) reported to me that she and the Apostle of Allah (may peace be upon him) took a bath from one vessel.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.632]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 632

Ibn Abbas reported that the Messenger of Allah (may peace be upon him) took a bath with the water left over by Maimuna.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.633]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 633

Zainab bint Umm Salama (the wife of the Holy Prophet) reported that Umm Salama and the Messenger of Allah (may peace be upon him) took a bath from the same vessel.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.634]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 634

Anas reported that the Messenger of Allah (may peace he upon him) took a bath with five Makkuks of water and performed ablution with one Makkuk. Ibn Muthanna has used the words five Makakiyya, and Ibn Mu'adh narrated it from 'Abdullah b. 'Abdullah and he made no mention of Ibn Jabr.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.635]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 635

Anas said: The Apostle of Allah (may peace be upon him) performed ablution with one Mudd and took bath with a Sa' up to five Mudds.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.636]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 636

Safina reported: The Messenger of Allah (may peace be upon him) took a bath with one g' of water because of sexual intercourse and performed ablution with one Mudd.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.637]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 637

Safina reported that Abd Bakr, the Companion of the Messenger of Allah (way peace be upon him), observed: The Messenger of Allah (may peace. 1) e upon him) took a bath with one Sa' of water and performed ablution with one Mudd (of water) ; and in the hadith narrated by Ibn Hujr the words are: One Mudd sufficed for his (Holy Prophet's) ablution. And Ibn Hujr said that (his Shaikh) Isma'il was much advanced in age, and it was because of this that he could not fully rely on him for this tradition.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.638]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 638

Jubair b. Mut'im reported: The people contended amongst themselves in the presence of the Messenger of Allah (may peace be upon him) with regard to bathing. Some of them said: We wash our heads like this and this. Upon this the Messenger (may peace be upon him) said: As for me I pour three handfuls of water upon my head.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.639]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 639

Jubair b. Mut'im reported it from the Apostle of Allah (may peace be upon him) that a mention was made before him about bathing because of sexual intercourse and he said: I pour water over my head thrice.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.640]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 640

Jabir b. Abdullah reported: A delegation of the Thaqif said to the Apostle of Allah (may peace be upon him): Our land is cold; what about our bathing then? He (the Holy Prophet) said: I pour water thrice over my head.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.641]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 641

Ibn Salim in his narration reported:" The delegation of the Thaqif said: Messenger of Allah."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.642]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 642

Jabir b. 'Abdullah reported: When the Messenger of Allah (may peace be upon him) took a bath because of sexual intercourse, he poured three handfuls of water upon his head. Hasan b. Muhammad said to him (the narrator): My hair is thick. Upon this Jabir observed. I said to him: O son of my brother, the hair of the Messenger of Allah (may peace be upon him) was thicker than your hair and these were more fine (than yours).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.643]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 643

Umm Salama reported: I said: Messenger of Allah, I am a woman who has closely plaited hair on my head; should I undo it for taking a bath, because of sexual intercourse? He (the Holy Prophet) said: No, it is enough for you to throw three handfuls of water on your head and then pour water over yourself, and you shall be purified.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.644]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 644

This hadith has been narrated by Amr al-Naqid, Yazid b. Harun, 'Abd b. Humaid, Abd al-Razzaq, Thauri, Ayyub b. Musa, with the same chain of transmitters. In hadith narrated by Abd al-Razzaq there is a mention of the menstruation and of the sexual intercourse. The rest of the hadith has been transmitted like that of Ibn 'Uyaina.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.645]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 645

This hadith is narrated by the same chain of transmitters by Ahmad al. Darimi, Zakariya b. 'Adi, Yazid, i. e. ' Ibn Zurai', Rauh b. al-Qasim, Ayyub b. Musa with the same chain of transmitters, and there is a mention of these words:" Should I undo the plait and wash it, because of sexual intercourse?" and there is no mention of menstruation.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.646]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 646

'Ubaid b. Umair reported: It was conveyed to 'A'isha that 'Abdullah b. 'Amr ordered the women to undo the (plaits) of hair on their heads. She said: How strange it is for Ibn 'Amr that he orders the women to undo the plaits of their head while taking a bath; why does he not order them to shave their beads? I and the Messenger of Allah (may peace be upon him) took bath from one vessel. I did no more than this that I poured three handfuls of water over my head.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.647]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 647

'A'isha reported: A woman asked the Apostle of Allah (may peace be upon him) how to wash herself after menstruation. She mentioned that he taught her how to take bath and then told her to take a piece of cotton with musk and purify herself. She said: How should I purify myself with that? He (the Holy Prophet) said: Praise be to Allah, purify yourself with it, and covered his face, Sufyan b. 'Uyaina gave a demonstration by covering his face (as the Holy Prophet had done). 'A'isha reported: I dragged her to my side for I had understood what the Apostle of Allah (may peace be upon him) intended and, therefore, said: Apply this cotton with musk to the trace of blood. Ibn 'Umar in his hadith (has mentioned the words of 'A'isha thus): Apply it to the marks of blood.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.648]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 648

'A'isha reported: A woman asked the Apostle of Allah (may peace be upon him) how he should wash herself after the menstrual period. He (the Holy Prophet) said: Take a cotton with musk and purity yourself, and the rest of the hadith was narrated like that of Sufyan.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.649]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 649

'A'isha reported: Asma (daughter of Shakal) asked the Apostle of Allah (may peace be upon him) about washing after menstruation. He said: Everyone amongst you should use water (mixed with the leaves of) the lote-tree and cleanse herself well, and then pour water on her head and rub it vigorously till it reaches the roots of the hair. Then she should pour water on it. Afterwards she should take a piece of cotton smeared with musk and cleanse herself with it. Asma' said: How should she cleanse herself with the help of that? Upon this he (the Apostle of Allah) observed: Praise be to Allah, she should cleanse herself. 'A'isha said in a subdued tone that she should apply it to the trace of blood. She (Asma) then further asked about bathing after sexual intercourse. He (the Holy Prophet) said: She should take water and cleanse herself well or complete the ablution and then (pour water) on her head and rub it till it reaches the roots of the hair (of her) head and then pour water on her. 'A'isha said: How good are the women of Ansar (helpers) that their shyness does not prevent them from learning religion.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.650]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 650

This hadith is narrated by 'Ubaidullah b. Mu'adh with the same chain of transmitters (but for the words) that he (the Holy Prophet) said: Cleanse yourself with it, and he covered (his face on account of shyness).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.651]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 651

'A'isha reported: Asma' b. Shakal came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, how one amongst us should take a bath after the menstruation, and the rest of the hadith is the same and there is no mention of bathing because of sexual intercourse.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.652]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 652

'A'isha reported: Fatimah b. Abu Hubaish came to the Apostle (may peace be upon him) and said: I am a woman whose blood keeps flowing (even after the menstruation period). I am never purified; should I, therefore, abandon prayer? He (the Holy Prophet) said: Not at all, for that is only a vein, and is not a menstruation, so when menstruation comes, abandon prayer, and when it ends wash the blood from yourself and then pray.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.653]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 653

The hadith narrated by Waki' and with its chain of narrators has been transmitted on the authority of Hisham b. 'Urwa, but in the hadith narrated by Qutaiba on the authority of Jarir, the words are:" There came Fatimah b. Abu Hubaish, b. 'Abd al-Muttalib b. Asad, and she was a woman amongst us," and in the hadith of Hammid b. Zaid there is an addition of these words:" We abandoned mentioning him."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.654]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 654

'A'isha reported: Umm Habiba b. Jahsh thus asked for a verdict from the Messenger of Allah (may peace be upon him): I am a woman whose blood keeps flowing (after the menstrual period). He (the Holy Prophet) said: That is only a vein, so take a bath and offer prayer; and she took a bath at the time of every prayer. Laith b. Sa'd said: Ibn Shihab made no mention that the Messenger of Allah (may peace be upon him) had ordered her to take a bath at the time of every prayer, but she did it of her own accord. And in the tradition transmitted by Ibn Rumh there is no mention of Umm Habiba (and there is mention of the daughter of Jahsh only.)


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.655]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 655

'A'isha, the wife of the Messenger of Allah (may peace be upon him) reported: Umm Habiba b. Jahsh who was the sister-in-law of the Messenger of Allah (may peace be upon him) and the wife of 'Abd al-Rahman b. Auf, remained mustahada for seven years, and she, therefore, asked for the verdict of Shari'ah from the Messenger of Allah (may peace be upon him) about it The Messenger of Allah (may peace be upon him) said: This is not menstruation, but (blood from) a vein: so bathe yourself and offer prayer. 'A'isha said: She took a bath in the wash-tub placed in the apartment of her sister Zainab b. Jahsh, till the redness of the blood came over the water. Ibn Shihab said: I narrated it to Abu Bakr b. 'Abd al-Rahman b. al-Harith b. Hisham about it who observed: May Allah have mercy on Hinda! would that she listened to this verdict. By Lord, she wept for not offering prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.656]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 656

This hadith has been thus reported by another chain of transmitters: Umm Habiba b. Jahsh came to the Messenger of Allah (may peace be upon him) and she had been a mustahada for seven years, and the rest of the hadith was narrated like that of 'Amr b. al-Harith up to the words:" There came the redness of the blood over water." and nothing was narrated beyond it.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.657]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 657

The hadith has been narrated by 'A'isha through another chain of transmitters (in these words): I The daughter of jahsh had been mustabida for seven years," and the rest of the hadith is the same (as mentioned above).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.658]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 658

On the authority of 'A'isha: Umm Habiba asked the Messenger of Allah (may peace be upon him) about the blood (which flows beyond the period of menstruation). 'A'isha said: I saw her wash-tub full of blood. The Messenger of Allah (may peace be upon him) said: Remain away (from prayer) equal (to the length of time) that your menses prevented you. After this (after the period of usual courses) bathe yourself and offer prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.659]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 659

'A'isha, the wife of the Apostle (may peace be upon him), said: Umm Habiba b. Jahsh who was the spouse of Abd al- Rahman b. Auf made a complaint to the Messenger of Allah (may peace be upon him) about blood (which flows beyond the menstrual period). He said to her: Remain away (from prayer) equal (to the length of time) that your menstruation holds you back. After this, bathe yourself. And she washed herself before every prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.660]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 660

Mu'adha reported: A woman asked 'A'isha: Should one amongst us complete prayers abandoned during the period of menses? 'A'isha said: Are you a Haruriya? When any one of us during the time of the Messenger of Allah (may peace be upon him) was in her menses (and abandoned prayer) she was not required to complete them.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.661]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 661

It is reported from Mu'adha that she asked 'A'isha: Should a menstruating woman complete the prayer (abandoned during the menstrual period)? 'A'isha said: Are you a Hurariya? The wives of the Messenger of Allah (may peace be upon him) have had their monthly courses, (but) did he order them to make compensation (for the abandoned prayers)? Muhammad b. Ja'far said: (Compensation) denotes their completion.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.662]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 662

Mu'adha said: I asked 'A'isha: What is the reason that a menstruating woman completes the fasts (that she abandons during her monthly course). but she does not complete the prayers? She (Hadrat 'A'isha) said: Are you a Haruriya? I said: I am not a Haruriya, but I simply want to inquire. She said: We passed through this (period of menstruation), and we were ordered to complete the fasts, but were not ordered to complete the prayers.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.663]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 663

Umm Hani b. Abu Talib reported: I went to the Messenger of Allah (may peace be upon him) on the day of the conquest (of Mecca) and found him take a bath. while his daughter Fatimah was holding a curtain around him.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.664]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 664

Umm Hani b. Abu Talib reported: It was the day of the conquest (of Mecca) that she went to the Messenger of Allah (may peace be upon him) and he was staying at a higher part (of that city). The Messenger of Allah (may peace be upon him) got up for his bath. Fatimah held a curtain around him (in order to provide him privacy). He then put on his garments and wrapped himself with that and then offered eight rak'ahs of the forenoon prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.665]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 665

This hadith is narrated by Sa'id b. Abu Hind with the same chain of transmitters and said: His (the Holy Prophet's) daughter Fatimah provided him privacy with the help of his cloth, and when he had taken a bath he took it up and wrapped it around him and then stood and offered eight rak'ahs of the forenoon prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.666]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 666

Maimuna reported: I placed water for the Apostle (may peace be upon him) and provided privacy for him, and he took a bath.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.667]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 667

'Abd al-Rahman, the son of Abu Sa'id al-Khudri, reported from his father: The Messenger of Allah (may peace be upon him) said: A man should not see the private parts of another man, and a woman should not see the private parts of another woman, and a man should not lie with another man under one covering, and a woman should not lie with another woman under one covering.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.668]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 668

This hadith has been narrated by Ibn Abu Fudaik and Dabbik b. 'Uthman with the same chain of transmitters and they observed: Private parts of man are the nakedness (which is concealed).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.669]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 669

Amongst the traditions narrated from Muhammad, the Messenger of Allah (may peace be upon him) on the authority of Abu Huraira, the one is that Banu Isra'il used to take a bath naked, and they looked at the private parts of one another. Moses (peace be upon him), however, took a bath alone (in privacy) ; and they said (tauntingly): By Allah, nothing prohibits Moses to take a bath along with us, but sacrotal hernia. He (Moses) once went for a bath and placed his clothes on a stone and the stone moved on with his clothes. Moses ran after it saying: 0 stone, my clothes,0 stone, my clothes, and Banu Isra'il had the chance to see the private parts of Moses, and said: By Allah, Moses does not suffer from any ailment. The stone then stopped, till Moses had been seen by them, and he then took hold of his clothes and struck the stone. Abu Huraira said: By Allah, there are the marks of six or seven strokes made by Moses on the stone.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.670]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 670

Jabir b. 'Abdullah reported: When the Ka'ba was constructed the Apostle of Allah (may peace be upon him) and Abbas went and lifted stones. Abbas said to the Messenger of Allah (may peace be upon him): Place your lower garment on your shoulder (so that you may protect yourself from the roughness and hardness of stones). He (the Holy Prophet) did this, but fell down upon the ground in a state of unconciousness and his eyes were turned towards the sky. He then stood up and said: My lower garment, my lower garment; and this wrapper was tied around him. In the hadith transmitted by Ibn Rafi', there is the word:" On his neck" and he did not say:" Upon his shoulder."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.671]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 671

Jabir b. 'Abdullah reported: The Messenger of Allah (may peace be upon him) was carrying along with them (his people) stones for the Ka'ba and there was a waist wrapper around him. His uncle," Abbas, said to him: 0 son of my brother! if you take off the lower garment and place it on the shoulders underneath the stones, it would be better. He (the Holy Prophet) took it off and placed it on his shoulder and fell down unconscious. He (the narrator) said: Never was he seen naked after that day.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.672]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 672

Al-Miswar b. Makhrama reported: I was carrying a heavy stone and my lower garment was loose, and it, therefore, slipped off (so soon) that I could not place the stone (on the ground) and carry to its proper place. Upon this the Messenger of Allah (may peace be upon him) said: Return to your cloth (lower garment), take it (and tie it around your waist) and do not walk naked.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.673]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 673

'Abdullah b. Ja'far reported: The Messenger of Allah (may peace be upon him) one day made me mount behind him and he confided to me something secret which I would not disclose to anybody; and the Messenger of Allah (may peace be upon him) liked the concealment provided by a lofty place or cluster of dates (while answering the call of nature), Ibn Asma' said in his narration: It implied an enclosure of the date-trees.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.674]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 674

Sa'id al-Khudri narrated it from his father: I went to Quba' with the Messenger of Allah (may peace be upon him) on Monday till we reached (the habitation) of Banu Salim. The Messenger of Allah (may peace be upon him) stood at the door of 'Itban and called him loudly. So he came out dragging his lower garnment. Upon this the Messenger of Allah (may peace be upon him) said: We have made this man to make haste 'Itban said: Messenger of Allah, if a man parts with his wife suddenly without seminal emission, what is he required to do (with regard to bath)? The Messenger of Allah (may peace be upon him) said: It is with the seminal emission that bath becomes obligatory.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.675]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 675

Abu al. 'Ala' b. al-Shikhkhir said: The Messenger of Allah (may peace be upon him) abrogated some of his commands by others, just as the Qur'an abrogates some part with the other.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.676]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 676

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) happened to pass by (the house) of a man amongst the Ansar, and he sent for him. He came out and water was trickling down from his head. Upon this he (the Holy Prophet) said: Perhaps we put you to haste. He said: Yes. Messenger of Allah. He (the Holy Prophet) said: When you made haste or semen is not emitted, bathing is not obligatory for you, but ablution is binding. Ibn Bashshir has narrated it with a minor alteration.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.677]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 677

Ubayy Ibn Ka'b reported: I arked the Messenger of Allah (may peace be upon him) about a man who has sexual intercourse with his wife, but leaves her before orgasm. Upon this he (the Holy Prophet) said: He should wash the secretion of his wife, and then perform ablution and ofier prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.678]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 678

Ubayy ibn Ka'b narrated it from the Messenger of Allah (may peace be upon him) that he said: If a person has sexual intercourse with his wife, but does not experience orgasm, he should wash his organ and perform an ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.679]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 679

Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) observed: Bathing is obligatory in case of seminal emission.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.680]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 680

Zaid b. Khalid al-Jubani reported that he askad Uthman b. 'Affan: What is your opinion about the man who has sexual intercourse with his wife, but does not experience orgasm? Uthman said: He should perform ablution as he does for prayer, and wash his organ. 'Uthmin also said: I have heard it from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.681]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 681

Abu Ayyub reported that he had heard like this from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.682]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 682

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When a man has sexual intercourse, bathing becomes obligatory (both for the male and the female). In the hadith of Matar the words are: Even if there is no orgasm. Zuhair has narrated it with a minor alteration of words.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.683]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 683

This hadith is narrated by Qatida with the same chain of transmitters, but with minor alterations. Here instead of the word - (jahada, (ijtahada) has been used, and the words;" Even if there is no orgasm" have been omitted.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.684]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 684

Abu Musa reported: There cropped up a difference of opinion between a group of Muhajirs (Emigrants and a group of Ansar (Helpers) (and the point of dispute was) that the Ansar said: The bath (because of sexual intercourse) becomes obligatory only-when the semen spurts out or ejaculates. But the Muhajirs said: When a man has sexual intercourse (with the woman), a bath becomes obligatory (no matter whether or not there is seminal emission or ejaculation). Abu Musa said: Well, I satisfy you on this (issue). He (Abu Musa, the narrator) said: I got up (and went) to 'A'isha and sought her permission and it was granted, and I said to her: 0 Mother, or Mother of the Faithful, I want to ask you about a matter on which I feel shy. She said: Don't feel shy of asking me about a thing which you can ask your mother, who gave you birth, for I am too your mother. Upon this I said: What makes a bath obligatory for a person? She replied: You have come across one well informed! The Messenger of Allah (may peace be upon him) said: When anyone sits amidst four parts (of the woman) and the circumcised parts touch each other a bath becomes obligatory.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.685]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 685

'A'isha the wife of the Apostle of Allah (may peace be upon him) reported. A person asked the Messenger of Allah (may peace be upon him) about one who has sexual intercourse with his wife and parts away (without orgasm) whether bathing is obligatory for him. 'A'isha was sitting by him. The Messenger of Allah (may peace be upon him) said: I and she (the Mother of the Faithful) do it and then take a bath.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.686]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 686

Zaid b Thabit reported: I heard the Messenger of Allah (may peace be upon him) say this: Ablution is obligatory (for one who takes anything) touched by fire.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.687]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 687

'Abdullah b. Ibrahim b. Qariz reported that he found Abu Huraira performing ablution in the mosque, who said: I am performing ablution because of having eaten pieces of cheese, for I heard the Messenger of Allah (may peace be upon him) say: Perform ablution (after eating anything) touched by fire.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.688]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 688

'Urwa reported on the authority of'A'isha, the wife of the Messenger of Allah (may peace be upon him), saying this: The Messenger of Allah (may peace be upon him) said. Perform ablution (after eating) anything touched by fire.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.689]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 689

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) took (meat of) goat's shoulder and offered prayer and did not perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.690]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 690

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) took flesh from the bone or meat, and then offered prayer and did not perform ablution, and (in fact) he did not touch water.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.691]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 691

Ja'far b. Amr b. Umayya al-Damari reported on the authority of his father who said: I saw the Messenger of Allah (may peace be upon him) take slices from goat's shoulder, and then eat them, and then offer prayer without having performed ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.692]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 692

Ja'far b. 'Amr b. Umayya al-Damari reported on the authority of his father who said: I saw the Messenger of Allah (may peace be upon him) take slices from goat's shoulder and then eat them. He was called for prayer and he got'up, leaving aside the knife, and offered prayer but did not perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.693]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 693

Ibn 'Abbas reported it on the authority of Maimuana, the wife of the Apostle of Allah (may peace be upon him), that the Apostle of Allah (may peace be upon him) took (a piece of goat's) shoulder at her place, and then offered prayer but did not perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.694]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 694

This hadith has been narrated by Ibn 'Abbas on the authority of Maimuna. the wife of the Apostle (may peace be upon him), by another chain of transmitters.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.695]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 695

Abu Rafi' reported: I testify that I used to roast the liver of the goat for the Messenger of Allah (may peace be tipcn him) and then he offered praver but did not perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.696]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 696

Ibn Abbas reported: The Apostle (may peace be upon him) took milk and then called for water and rinsed (his mouth) and said: It contains greasiness.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.697]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 697

This hadith has been narrated by another chain of transmitters.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.698]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 698

Ibn Abbas reported: The Messenger of Allah (may peace be upon him) dressed himself, and then went out for prayer, when he was presented with bread and meat. He took three morsels out of that, and then offered prayer along with other people and did not touch water.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.699]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 699

This hadith is narrated by Muhammad b. 'Amr b. Ata' with these words: I was with Ibn 'Abbas, and Ibn 'Abbas saw the Apostle of Allah (may peace be upon him) doing like this, and it is also said that the words are: He (the Holy Prophet) offered prayer; and the word" people" is not mentioned.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.700]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 700

Jabir b. Samura reported: A man asked the Messenger of Allah (may peace he upon him) whether he should perform ablution after (eating) mutton. He (the Messenger of Allah) said: Perform ablution it you so desire, and if you do not wish, do not perform it. He (again) asked: Should I perform ablution (after eating) camel's flesh? He said: Yes, perform ablution (after eating) camel's flesh. He (again) said: May I say prayer in the sheepfolds? He (the Messenger of Allah) said: Yes. He (the narrator) again said: May I say prayer where camels lie down? He (the Holy Prophet) said: No.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.701]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 701

This hadith is also narrated by another chain of transmitters.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.702]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 702

'Abbad b. Tamim reported from his uncle that a person made a complaint to the Apostle (may peace be upon him) that he entertained (doubt) as it something had happened to him breaking his ablution. He (the Holy Prophet) said: He should not return (from prayer) unless he hears a sound or perceives a smell (of passing wind). Abu Bakr and Zuhair b. Harb have pointed out in their narrations that it was 'Abdullah b. Zaid.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.703]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 703

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If any one of you has pain in his abdomen, but is doubtful whether or not anything has issued from him, be should not leave the mosque unless he hears a sound or perceives a smell.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.704]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 704

The freed slave-girl of Maimuna was given a goat in charity but it died. The Messenger of Allah (may peace be upon him) happened to pass by that (carcass). Upon this be said: Why did you not take off its skin? You could put it to use, after tanning it. They (the Companions) said: It was dead. Upon, this he (the Messenger of Allah) said: Only its eating is prohibited. Abu bakr and Ibn Umar in their narrations said: It is narrated from Maimuna (may Allah be pleased with her).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.705]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 705

Ibn 'Abbas said: The Messenger of Allah (may peace be upon him) saw a dead goat, which had been given in charity to the freed slave-girl of Maimuna. The Messenger of Allah (may peace be upon him) said: Why don't you make use of its skin? They (the Companions around the Holy Prophet) said: It is dead. Upon this he said: It is the eating (of the dead animal) which is prohibited.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.706]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 706

This hadith is narrated by Ibn Shihab with the same chain of transmitters as transmitted by Yunus.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.707]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 707

Ibn Abbas reported: The Messenger of Allah (may peace be upon him) happened to pass by a goat thrown (away) which had been in fact given to the freed slave-girl of Maimuna as charity. Upon this the Messenger of Allah (way peace he upon him) said: Why did they not get its skin? They had better tan it and make use of it.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.708]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 708

Ibn'Abbas reported on the authority of Maimuna that someone amongst the wives of the Messenger of Allah (may peace be upon him) had a domestic animal and it died. Upon this the Messenger of Allah (may peace be upon him) said: Why did you not take off its skin and make use of that?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.709]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 709

Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) happened to pass by (the dead body) of the goat which belonged to the freed slave-girl of Maimuna and said: Why did you not make use of its skin?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.710]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 710

Abdullah b. Abbas said: I heard the Apostle of Allah (may peace be upon him) say: When the skin is tanned it becomes purified.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.711]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 711

This hadith has been transmitted on the authority of Ibn 'Abbas by another chain of transmitters.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.712]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 712

Abu al-Khair reported: I saw Ibn Wa'la al-Saba'i wear a fur. I touched it. He said: Why do you touch it? I asked Ibn 'Abbas saying: We are the inhabitants of the western regions, and there (live) with us Berbers and Magians. They bring with them rams and slaughter them, but we do not eat (the meat of the animals) slaughtered by them, and they come with skins full of fat. Upon this Ibn 'Abbas said: We asked the Messenger of Allah (may peace be upon him) about this and he said: Its tanning makes it pure.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.713]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 713

Ibn Wa'la al-Saba'i reported: I asked 'Abdullah b. 'Abbas saying: We are the inhabitants of the western regions. The Magians come to us with skins full of water and fat. He said: Drink. I said to him: Is it your own opinion? Ibn Abbas said: I heard the Messenger of Allah (may peace be upon him) say: Tanning purifies it (the skin).


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.714]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 714

'A'isha reported: We went with the Apostle of Allah (may peace be upon him) on one of his journeys and when we reached the place Baida' or Dhat al-jaish, my necklace was broken (and fell somewhere). The Messenger of Allah (way peace be upon him) along with other people stayed there for searching it. There was neither any water at that place nor was there any water with them (the Companions of the Holy Prophet). Some persons came to my father Abu Bakr and said: Do you see what 'A'isha has done? She has detained the Messenger of Allah (may peace be upon him) and persons accompanying him, and there is neither any water here or with them. So Abu Bakr came there and the Messenger of Allah (may peace be upon him) was sleeping with his head on my thigh. He (Abu Bakr) said: You have detained the Messenger of Allah (may peace be upon him) and other persons and there is neither water here nor with them. She ('A'isha) said: Abu Bakr scolded me and uttered what Allah wanted him to utter and nudged my hips with his hand. And there was nothing to prevent me from stirring but for the fact that the messenger of Allah (may peace be upon him) was lying upon my thigh. The Messenger of Allah (may peace be upon him) slept till it was dawn at a waterless place. So Allah revealed the verses pertaining to tayammum and they (the Holy Prophet and his Companions) performed tayammum. Usaid b. al-Hudair who was one of the leaders said: This is not the first of your blessings,0 Family to Abu Bakr. 'A'isha said: We made the came) stand which was my mount and found the necklace under it.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.715]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 715

'A'isha reported she had borrowed from Asma' (her sister) a necklace and it was lost. The Messenger of Allah (may peace be upon him) sent men to search for it. As it was the time for prayer, they offered prayer without ablution (as water was not available there). When they came to the Messenger of Allah (may peace be upon him), they made a complaint about it, and the verses pertaining to tayammum were revealed. Upon this Usaid b. Hadair said (to 'A'isha): May Allah grant you a good reward! Never has been there an occasion when you were beset with difficulty and Allah did not make you come out of that and made it an occasion of blessing for the Muslims.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.716]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 716

Shaqiq reported: I was sitting in the company of Abdullah and Abu Musa when Abu Musa said: 0 'Abd al-Rahman (kunya of 'Abdullah b. Mas'ud), what would you like a man to do about the prayer if he experiences a seminal emission or has sexual intercourse but does not find water for a month? 'Abdullah said: He should not perform tayammum even if he does not find water for a month. 'Abdullah said: Then what about the verse in Sura Ma'ida:" If you do not find water, betake yourself to clean dust"? 'Abdullah said: If they were granted concession on the basis of this verse, there is a possibility that they would perform tayammum with dust on finding water very cold for themselves. Abu Musa said to Abdullah: You have not heard the words of 'Ammar: The Messenger of Allah (may peace be upon him) sent me on an errand and I had a seminal emission, but could find no water, and rolled myself in dust just as a beast rolls itself. I came to the Messenger of Allah (may peace be upon him) then and made a mention of that to him and he (the Holy Prophet) said: It would have been enough for you to do thus. Then he struck the ground with his hands once and wiped his right hand with the help of his left hand and the exterior of his palms and his face. 'Abdullah said: Didn't you see that Umar was not fully satisfied with the words of 'Ammar only?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.717]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 717

This hadith is narrated by Shaqiq with the same chain of transmitters but with the alteration of these words: He (the Holy Prophet) struck hands upon the earth, and then shook them and then wiped his face and palm.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.718]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 718

Abd al-Rabmin b. Abza narrated It on the authority of his father that a man came to 'Umar and said: I am (at times) affected by seminal emission but find no water. He ('Umar) told him not to say prayer. 'Ammar then said. Do you remember,0 Commander of the Faithful, when I and you were in a military detachment and we had had a seminal emission and did not find water (for taking bath) and you did not say prayer, but as for myself I rolled in dust and said prayer, and (when it was mentioned before) the Apostle (may peace be upon him) said: It was enough for you to strike the ground with your hands and then blow (the dust) and then wipe your face and palms. Umar said: 'Ammar, fear Allah. He said: If you so like, I would not narrate it.

A hadith like this has been transmitted with the same chain of transmitters but for the words: 'Umar said: We hold you responsible for what you claim."


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.719]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 719

'Abd al-Rahman b. Abza mnated it on the authority of his father that a man came to Umar and said: I have had a seminal emission but I found no water, and the rest of the hadith is the same but with this addition: 'Amr said: 0 Commander of the Faithful, because of the right given to you by Allah over me, if you desire, I would not narrate this hadith to anyone.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.720]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 720

Umair, the freed slave of Ibn 'Abbas, reported: I and 'Abd al-Rahmin b. Yasir, the freed slave of Maimuna, the wife of the Apostle (way peace be upon him). came to the house of Abu'l-Jahm b. al-Harith al-Simma Ansari and he said: The Messenger of Allah (may peace be upon him) came from the direction of Bi'r Jamal and a man met him; he saluted him but the Messenger of Allah (may peace be upon him) made no response, till he (the Holy Prophet) came to the wall, wiped his face and hands and then returned his salutations.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.721]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 721

Ibn Umar reported: A person happened to pass by the Messenger of Allah (may peace be upon him) when he was making water and saluted him, but he did not respond to his salutation.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.722]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 722

Abu Huraira reported that he met the Apostle of Allah (may peace be upon him) on one of the paths leading to Medina in a state of (sexual) defilement and he slipped away and took a bath. The Apostle of Allah (may peace be upon him) searched for him and when he came, he said to him: 0 Abu Huraira, where were you? He said: Messenger of Allah, you met when I was (sexually) defiled and I did not like to sit in your company before taking a bath. Upon this the Messenger of Allah (may peace be upon him) said: Hallowed be Allah, verily a believer is never defiled.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.723]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 723

Hudhaifa reported: The Messenger of Allah (may peace be upon him) happened to meet him and he was (sexually) defiled, and he slipped away and took a bath and then came and said: I was (sexually) defiled. Upon this he (the Holy Prophet) remarked: A Muslim is never defiled.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.724]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 724

'A'isha said: The Apostle of Allah (may peace be upon him) used to remember Allah at all moments.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.725]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 725

Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) came out of the privy, and he was presented with some food, and the people reminded him about ablution, but he said: Am I to say prayer that I should perform ablution?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.726]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 726

Ibn 'Abbas reported: We were with the Apostle of Allah (may peace be upon him) and he had come out of the privy. Food was presented to him. It was said to him (by the Companions around him): Wouldn't you perform ablution? Upon this he said: Why, am I to say prayer that I should perform ablution?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.727]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 727

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) went to the privy and when he came back, he was presented with food. It was said to him; Messenger of Allah, wouldn't you perform ablution. He said: Why, am I to say prayer?


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.728]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 728

Ibn Abbas, reported: The Apostle of Allah (may peace be upon him) came out of the privy after relieving himself, and food was brought to him and he took it, and did not touch water. In another narration transmitted by Sa'id b. al-Huwairith it is like this: It was said to the Apostle of Allah (may peace be upon him) You have not performed ablution. He said: I do not intend to say prayer that I should perform ablution.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.729]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 729

Anas reported: When the Messenger of Allah (may peace be upon him) entered the privy, and in the hadith transmitted by Hushaim (the words are): When the Messenger of Allah (may peace be upon him) entered the lavatory, be used to say: O Allah, I seek refuge in Thee from wicked and noxious things.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.730]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 730

This hadith is also transmitted by 'Abd al-'Aziz with the same chain of transmitters, and the words are: I seek refuge with Allah from the wicked and noxious things.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.731]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 731

Anas reported: (The people) stood up for prayer and the Messenger of Allah (may peace be upon him) was whispering to a man, and in the narration of 'Abd al-Warith (the words are): The Apostle of Allah (may peace be upon him) was having a private conversation with a man, and did not start the prayer till the people dozed off.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.732]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 732

Anas b. Malik reported: (The people) stood up for prayer and the Apostle of Allah (may peace be upon him) was talking in whispers with a man, and he did not discontinue the conversation till his Companions dozed off; he then came and led the prayer.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.733]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 733

Qatida reported: I heard Anas as saying that the Companion of the Messenger of Allah (may peace be upon him) dozed off and then offered prayer and did not perform ablution. He (the narrator) said: I asked him if he had actually heard it from Anas. He said: By Allah. yes.


Muslim :: The Book of Menstruation (Kitab Al-Haid) :: [3.734]

The Book of Menstruation (Kitab Al-Haid)

Muslim :: Book 3 : Hadith 734

Anas reported: (The people) stood up for the night prayer when a man spoke forth: I need to say something. The Apostle of Allah (may peace be upon him) entered into secret conversation with him, till the people dozed off or some of the people (dozed off), and then they said the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.735]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 735

Ibn Umar reported: When the Muslims came to Medina, they gathered and sought to know the time of prayer but no one summoned them. One day they discussed the matter, and some of them said: Use something like the bell of the Christians and some of them said: Use horn like that of the Jews. Umar said: Why may not a be appointed who should call (people) to prayer? The Messenger of Allah (may peace be upon him) said: O Bilal, get up and summon (the people) to prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.736]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 736

Anas reported: Bilal was commanded (by the Apostle of Allah) to repeat (the phrases of) Adhan twice and once in Iqama. The narrator said: I made a men- tion of it before Ayyub who said: Except for saying: Qamat-is-Salat [the time for prayer has come].


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.737]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 737

Anas b. Malik reported: They (the Companions) discussed that they should know the timings of prayer by means of something recognized by all. Some of them said that fire should be lighted or a bell should be rung. But Bilal was ordered to repeat the phrases twice in Adhan, and once in Iqama.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.738]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 738

This hadith is transmitted by Khalid Hadhdha with the same chain of transmitters (and the words are): When the majority of the people discussed they should know, like the hadith narrated by al-Thaqafi (mentioned above) except for the words:" They (the people) should kindle fire."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.739]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 739

Anas reported: Bilal was commanded (by the Holy Prophet) to repeat the phrases twice in Adhan, and once in lqama.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.740]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 740

Abu Mahdhura said that the Apostle of Allah (may peace be upon him) taught him Adhan like this: Allah is the Greatest, Allah is the Greatest; I testify that there is no god but Allah, I testify that there is no god but Allah; I testify that Muhammad Is the Messenger of Allah, I testify that Muhammad is the Messenger of Allah, and it should be again repeated: I testify that there is no god but Allah, I testify that there is no god but Allah; I testify that Muhammad Is the Messenger of Allah, I testify that Muhammad is the Messenger of Allah. Come to the prayer (twice). Come to the prayer (twice). Ishaq added: Allah is the Greatest, Allah is the Greatest; there Is no god but Allah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.741]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 741

Ibn Umar reported: The Messenger of Allah (may peace be upon him) had two Mu'adhdhins, Bilal and 'Abdullah b. Umm Maktum, who (latter) was blind.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.742]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 742

This hadith has been narrated on the authority of 'A'isha by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.743]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 743

A'isha reported: Ibn Umm Maktum used to pronounce Adhan at the behest of the Messenger of Allah (may peace be upon him) (despite the fact) that he was blind.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.744]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 744

A hadith like this has been transmitted by Hisham.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.745]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 745

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) used to attack the enemy when it was dawn. He would listen to the Adhan; so if he heard an Adhan, he stopped, otherwise made an attack. Once on hearing a man say: Allah is the Greatest, Allah is the Greatest, the Messenger of Allah (may peace be upon him) remarked: He is following al-Fitra (al-Islam). Then hearing him say: I testify that there is no god but Allah. there is no god but Allah, the Messenger of Allah (may peace be upon him) said: You have come out of the Fire (of Hell). They looked at him and found that he was a goatherd.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.746]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 746

Abu Sa'id al-Khudri reported: When you hear the call (to prayer), repeat what the Mu'adhdhin pronounces.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.747]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 747

'Abdullah b. Amr b. al-As reported Allah's Messenger (may peace be upon him) as saying: When you hear the Mu'adhdhin, repeat what he says, then invoke a blessing on me, for everyone who invokes a blessing on me will receive ten blessings from Allah; then beg from Allah al-Wasila for me, which is a rank in Paradise fitting for only one of Allah's servants, and I hope that I may be that one. If anyone who asks that I be given the Wasila, he will be assured of my intercession.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.748]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 748

'Umar b. al-Khattab reported: The Messenger of Allah (may peace be upon him) said: When the Mu'adhdhin says: Allah is the Greatest, Allah is the Greatest, and one of you should make this response: Allah is the Greatest, Allah is the Greatest; (and when the Mu'adhdhin) says: I testify that there is no god but Allah, one should respond: I testify that there is no god but Allah, and when he says: I testify that Muhammad is the Messenger of Allah, one should make a response: I testify that Muhammad is Allah's Messenger. When he (the Mu'adhdhin) says: Come to prayer, one should make a response: There is no might and no power except with Allah. When he (the Mu'adhdhin) says: Come to salvation, one should respond: There is no might and no power except with Allah, and when he (the Mu'adhdhin) says: Allah is the Greatest, Allah is the Greatest, then make a response: Allah is the Greatest, Allah is the Greatest. When he (the Mu'adhdhin) says: There is no god but Allah, and he who makes a re- sponse from the heart: There is no god but Allah, he will enter Paradise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.749]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 749

Sa'd b. Abu Waqqas reported: The Messenger of Allah (may peace be upon him) said: If anyone says on hearing the Mu'adhdhin: I testify that there is no god but Allah alone. Who has no partner, and that Muhammad is His servant and His Messenger, (and that) I am satisfied with Allah as my Lord, with Muhammad as Messenger. and with Islam as din (code of life), his sins would be forgiven. In the narration transmitted by Ibn Rumh the words are:" He who said on hearing the Mu'adhdhin and verity I testify." ' Qutaiba has not mentioned his words:" And I."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.750]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 750

Yahya narrated it on the authority of his uncle that he had been sitting in the company of Mu'awiya b. Abu Sufyan when the Mu'adhdhin called (Muslims) to prayer. Mu'awiya said: I heard the Messenger of Allah (may peace be upon him) saying The Mu'adhdhins will have the longest necks on the Day of Resurrection.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.751]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 751

Abu Sufyan reported it on the authority of Jabir that he had heard the Apostle of Allah (may peace be upon him) say: When Satan hears the call to prayer, he runs away to a distance like that of Rauha. Sulaimin said: I asked him about Rauha. He replied: It is at a distance of thirty-six miles from Medina.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.752]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 752

Abu Mu'awiya narrated it on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.753]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 753

AbuHuraira reported the Messenger of Allah (may peace be upon him) as saying: When Satan hears the call to prayer, he turns back and breaks the wind so as not to bear the call being made, but when the call is finished he turns round and distracts (the minds of those who pray), and when he bears the Iqama he again runs away so as not to hear its voice and when it subsides, he comes back and distracts (the minds of those who stand for prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.754]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 754

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the Mu'adhdhin calls to prayer, Satan runs back vehemently.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.755]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 755

Suhail reported that his father sent him to Banu Haritha along with a boy or a man. Someone called him by his name from an enclosure. He (thenarrator) said: The person with me looked towards the enclosure, but saw nothing. I made a mention of that to my father. He said: If I knew that you would meet such a situation I would have never sent you (there), but (bear in wind) whenever you hear such a call (from the evil spirits) pronounce the Adhan. for I have heard Abu Huraira say that the Messenger of Allah (may peace be upbn him) said: Whenever Adhan is proclaimed, Satan runs back vehemently.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.756]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 756

Abu Huraira reported: The Apostle (may peace be upon him) said When the call to prayer is made, Satan runs back and breaks wind so as not to hear the call being made, and when the call is finished. he turns round. When Iqama is proclaimed he turns his back, and when it is finished he turns round to distract a man, saying: Re- member such and such; remember such and such, referring to something the man did not have in his mind, with the result that he does not know how much he has prayed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.757]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 757

A hadith like it has been narrated by Abu Huraira but for these words:" He (the man saying the prayer) does not know how much he has prayed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.758]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 758

Salim narrated it on the authority of his father who reported: I saw the Messenger of Allah (may peace be upon him) raising his hands apposite the shoulders at the time of beginning the prayer and before bowing down and after coming back to the position after bowing. but he did not raise them between two prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.759]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 759

Ibn Umar reported that the Messenger of Allah (may peace be upon him), when he stood up for prayer, used to raise his hands apposite the shoulders and then recited takbir (Allah-o-Akbar), and when he was about to bow he again did like it and when he raised himself from the ruku' (bowing posture) he again did like it, but he did not do it at the time of raising his head from prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.760]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 760

This hadith has been transmitted with the same chain of transmitters by al. Zuhri as narrated by Ibn Juraij (who) said. When the Messenger of Allah (may peace be upon him) stood up for prayer, he raised hands (to the height) apposite the shoulders and then recited takbir.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.761]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 761

Abu Qilaba reported that he saw Malik b. Huwairith raising his hands at the beginning of prayer and raising his hands before kneeling down, and raising his hands after lifting his head from the state of kneeling, and he narrated that the Messenger of Allah (may peace be upon him) used to do like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.762]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 762

Malik b. Huwairith reported: The Messenger of Allah (may peace be upon him) raised his hands apposite his ears at the time of reciting the takbir (i. e. at the time of beginning the prayer) and then again raised his hands apposite the ears at the time of bowing and when he lifted his head after bowing he said: Allah listened to him who praised Him, and did like it (raised his hands up to the ears).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.763]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 763

This hadith has been transmitted by Qatada with the same chain of trans. mitters that he saw the Apostle of Allah (may peace be upon him) doing like this (i. e. raising his hands) till they were apposite the lobes of cars.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.764]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 764

Abu Salama reported: Abu Huraira led prayer for them and recited takbir when he bent and raised himself (in ruku' and sujud) and after completing (the prayer) he said: By Allah I say prayer which has the best resemblance with the prayer of the Holy Prophet (may peace be upon him) amongst you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.765]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 765

Abu Huraira reported: When the Messenger of Allah (may peace be upon him) got up for prayer, he would say the takbir (Allah-o-Akbar) when standing, then say the takbir when bowing. then say:" Allah listened to him who praised him," when coming to the erect position after bowing, then say while standing:" To Thee, our Lord, be the praise", then recite the takbir when getting down for prostration, then say the takbir on raising his head, then say the takbir on prostrating himself, then say the takbir on raising his head. He would do that throughout the whole prayer till he would complete it, and he would say the takbir when he would get up at the end of two rak'as after adopting the sitting posture. Abu Huraira said: My prayer has the best resemblance amongst you with the prayer of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.766]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 766

Ibn al-Harith reported: He had heard Abu Huraira say: The Messenger of Allah (may peace be upon him) recited takbir on standing for prayer, and the rest of the hadith is like that transmitted by Ibn Juraij (recorded above), but he did not mention Abu Huraira as saying:" My prayer has the best resemblance amongst you with the prayer of the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.767]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 767

Abu Salama b. 'Abd al-Rahman reported.. When Marwan appointed Abu Huraira as his deputy in Medina, he recited takbir whenever he got up for obligatory prayer, and the rest of the hadith is the same as transmitted by Ibn Juraij (but with the addition of these words): On completing the prayer with salutation, and he turned to the people in the mosque and said....


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.768]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 768

Abu Salama reported that Abu Huraira recited takbir in prayer on all occasions of rising and kneeling. We said: O Abu Huraira, what is this takbir? He said: Verily it is the prayer of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.769]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 769

Suhail reported on the authority of his father that Abu Huraira used to recite takbir on all occasions of rising and bending (in prayer) and narrated that the Messenger of Allah (may peace be upon him) used to do like that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.770]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 770

Mutarrif reported: I and 'Imran b. Husain said prayer behind 'Ali b. Abu, Talib. He recited takbir when he prostrated, and he recited takbir when he raised his head and he recited takbir while rising up (from the sitting position at the end of two rak'ahs). When we had finished our prayer, 'Imran caught hold of my hand and said: He (Hadrat Ali) has led prayer like Muhammad (may peace be upon him) or he said: He in fact recalled to my mind the prayer of Muhammad (may peace be upon him.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.771]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 771

'Ubada b. as-Samit reported from the Apostle of Allah (may peace be upon him ): He who does not recite Fatihat al-Kitab is not credited with having observed the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.772]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 772

Ubada b. as-Samit reported: The Messenger of Allah (may peace be upon him) said: He who does not recite Umm al-Qur'an is not credited with having observed the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.773]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 773

Mahmud b. al-Rabi', on whose face the Messenger of Allah (may peace be upon him) squirted water from the well, reported on the authority of 'Ubada b. as- Samit that the Messenger of Allah (may peace be upon him) said: He who does not recite Umm al-Qur'an is not credited with having observed prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.774]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 774

This hadith has also been transmitted by Ma'mar from al-Zuhri with the same chain of transmitters with the addition of these words:" and something more".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.775]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 775

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: If anyone observes prayer in which he does not recite Umm al-Qur'an, It is deficient [he said this three times] and not complete. It was said to Abu Huraira: At times we are behind the Imam. He said: Recite it inwardly, for he had heard the Messenger of Allah (may peace be upon him) declare that Allah the Exalted had said: I have divided the prayer into two halves between Me and My servant, and My servant will receive what he asks. When the servant says: Praise be to Allah, the Lord of the universe, Allah the Most High says: My servant has praised Me. And when he (the servant) says: The Most Compassionate, the Merciful, Allah the Most High says: My servant has lauded Me. And when he (the servant) says: Master of the Day of judg- ment, He remarks: My servant has glorified Me. and sometimes He would say: My servant entrusted (his affairs) to Me. And when he (the worshipper) says: Thee do we worship and of Thee do we ask help, He (Allah) says: This is between Me and My servant, and My servant will receive what he asks for. Then, when he (the worshipper) says: Guide us to the straight path, the path of those to whom Thou hast been Gracious not of those who have incurred Thy displeasure, nor of those who have gone astray, He (Allah) says: This is for My servant, and My servant will receive what he asks for. Sufyan said: 'Ala b. 'Abd al-Rahman b. Ya'qub narrated it to me when I went to him and he was confined to his home on account of illness, and I asked him about it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.776]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 776

It is naratted on the authority of Abu Huraira that he had heard the Messenger of Allah (may peace be upon him) say: He who observed prayer but he did not recite the Umm al-Qur'an in it, and the rest of the hadith is the same as transmitted by Sufyan, and in this hadith the words are:" Allah the Most High said: the prayer is divided into two halves between Me and My servant. The half of it is for Me and the half of it is for My servant."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.777]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 777

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who said his prayer, but did not recite the opening chapter of al-Kitab, his prayer is incomplete. He repeated it thrice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.778]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 778

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: One is not credited with having observed the prayer without the recitation (of al-Fatiha). So said Abu Huraira: (The prayer in which) the Messenger of Allah (may peace be upon him) recited in a loud voice, we also recited that loudly for you (and the prayer in which) he recited inwardly we also recited inwardly for you (to give you a practical example of the prayer of the Holy Prophet).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.779]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 779

'Ata' narrated on the authority of Abu Huraira who said that one should recite (al-Fatiha) in every (rak'ah of) prayer. What we heard (i. e. recitation) from the Messenger of Allah (may peace be upon him), we made you listen to that. And that which he (recited) inwardly, we (recited) inwardly for you. A person said to him: If I add nothing to the (recitation) of the Umm al Qur'an (Surat al-Fatiha), would it make the prayer incomplete? He (AbuHuraira) said: If you add to that (if you recite some of verses of the Qur'an along with Surat at-Fatiha) that is better for you. But if you are contented with it (Surat al-Fatiha) only, it is sufficient for you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.780]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 780

'Ata' reported it on the authority of Abu Huraira who said: Recitation (of Surat al-Fatiha) in every (rak'ah) of prayer in essential. (The recitation) that we listened to from the Apostle of Allah (may peace be upon him) we made you listen to it. And that which he recited inwardly to us, we recited it inwardly for you. And he who recites Umm al-Qur'an, it is enough for him (to complete the prayer), and he who adds to it (recites some other verses of the Holy Qur'an along with Surat al-Fatiha), it is preferable for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.781]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 781

Abu Huraira reported: The Messenger of Allah (may peace be upon him) entered the mosque and a person also entered therein and offered prayer, and then came and paid salutation to the Messenger of Allah (may peace be upon him). The Mes- senger of Allah (may peace be upon him) returned his salutation and said: Go back and pray, for you have not offered the prayer. He again prayed as he had prayed before, and came to the Apostle of Allah (may peace be upon. him) and saluted him. The Messenger of Allah (may peace be upon him) returned the salutation and said: Go back and say prayer, for you have not offered the prayer. This (act of repeating the prayer) was done three times. Upon this the person said: By Him Who hast sent you with Truth, whatever better I can do than this, please teach me. He (the Holy Prophet) said: When you get up to pray, recite takbir, and then recite whatever you conveniently can from the Qur'an, then bow down and remain quietly in that position, then raise your- self and stand erect; then prostrate yourself and remain quietly in that attitude; then raise yourself and sit quietly; and do that throughout all your prayers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.782]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 782

Abu Huraira reported: A person entered the mosque and said prayer while the Messenger of Allah (may peace be upon him) was sitting in a nook (of the mosque), and the rest of the hadith is the same as mentioned above, but with this addition:" When you get up to pray, perform the ablution completely, and then turn towards the Qibla and recite takbir (Allah o Akbar =Allah is the Most Great)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.783]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 783

lmrin b. Husain reported: The Messenger of Allah (may peace beupon him) led us In Zuhr or 'Asr prayer (noon or the afternoon prayer). (On concluding it) he said: Who recited behind me (the verses): Sabbih Isma Rabbik al-a'la (Glorify the name of thy Lord, the Most High)? There upon a person said: It was I, but I in- tended nothing but goodness. I felt that some one of you was disputing with me in it (or he was taking out from my tongue what I was reciting), said the Holy Prophet (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.784]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 784

'Imran b. Husain reported: The Messenger of Allah (may peace be upon him) observed the Zuhr prayer and a person recited Sabbih Isma Rabbik al-a'la (Glorify the name of thy Lord, the Most High) behind him. When he (the Holy Pro- phet) concluded the prayer he said: Who amongst you recited (the above-mentioned verse) or who amongst you was the reciter? A person said: It was I. Upon this he (the Holy Prophet) observed: I thought as if someone amongst you was disputing with me (in what I was reciting).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.785]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 785

This hadith has been narrated by Qatada with the same chain of transmitters that the Messenger of Allah (may peace be upon him) observed Zuhr prayer and said: I felt that someone amongst you was disputing with me (in what I was reciting).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.786]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 786

Anas reported: I observed prayer along with the Messenger of Allah (may peace be upon him) and with Abu Bakr, Umar and Uthman (may Allah be pleased with all of them), but I never heard any one of them reciting Bismillah-ir-Rahman-ir-Rahim loudly.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.787]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 787

Shu'ba reported it with the same chain of transmitters. with she addition of these words:" I said to Qatada: Did you hear it from Anas? He replied in the affir- mative and added: We had inquired of him about it."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.788]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 788

'Abda reported: 'Umar b. al-Khattab used to recite loudly these words: Subhanak Allahumma wa bi hamdika wa tabarakasmuka wa ta'ala jadduka wa la ilaha ghairuka [Glory to Thee,0 Allah, and Thine is the Praise, and Blessed is Thy Name. and Exalted is Thy Majesty. and there is no other object of worship beside Thee]. Qatada informed in writing that Anas b. Malik had narrated to him: I observed prayer behind the Apostle of Allah (may peace be upon him) and Abu Bakr and Umar and 'Uthman. They started (loud recitation) with: AI-hamdu lillahi Rabb al-'Alamin [All Praise is due to Allah, the Lord of the worlds] and did not recite Bismillah ir- Rahman-ir-Rahim (loudly) at the beginning of the recitation or at the end of it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.789]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 789

It is reported on the authority of Abu Talha that he had heard Anas b. Malik narrating this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.790]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 790

Anas reported: One day the Messenger of Allah (may peace be upon him) was sitting amongst us that he dozed off. He then raised his head smilingly. We said: What makes you smile. Messenger of Allah? He said: A Sura has just been revealed to me, and then recited: In the name of Allah, the Compassionate, the Merciful. Verily We have given thee Kauthar (fount of abundance). Therefore turn to thy Lord for prayer and offer sacrifice, and surely thy enemy is cut off (from the good). Then he (the Holy Prophet) said: Do you know what Kauthar is? We said: Allah and His Messenger know best. The Holy Prophet (may peace be upon him) said: It (Kauthar) is a canal which my Lord, the Exalted and Glorious has promised me, and there is an abundance of good in it. It is a cistern and my people would come to it on the Day of Resurrection, and tumblers there would be equal to the number of stars. A servant would be turned away from (among the people gathered there). Upon this I would say: My Lord, he is one of my people, and He (the Lord) would say: You do not know that he innovated new things (in Islam) after you. Ibn Hujr made this addition in the hadith:" He (the Holy Prophet) was sitting amongst us in the mosque, and He (Allah) said: (You don't know) what he innovated after you"


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.791]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 791

Mukhtar b. Fulful reported that he had heard Anas b. Malik say that the Messenger of Allah (may peace be upon him) dozed off, and the rest of the hadith is the same as transmitted by Mus-hir except for the words that he (the Holy Prophet) said: It (Kauthar) is a canal which my Lord the Exalted and the Glorious has promised me in Paradise. There is a tank over it, but he made no mention of the tumblers like the number of the stars.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.792]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 792

Wa'il b. Hujr reported: He saw the Apostle of Allah (may peace be upon him) raising his hands at the time of beginning the prayer and reciting takbir, and according to Hammam (the narrator), the hands were lifted opposite to ears. He (the Holy Prophet) then wrapped his hands in his cloth and placed his right hand over his left hand. And when he was about to bow down, he brought out his hands from the cloth, and then lifted them, and then recited takbir and bowed down, and when (he came back to the erect position) he recited:" Allah listened to him who praised Him." And when prostrates. he prostrated between the two palms.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.793]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 793

'Abdullah (b. Mas'ud) said: While observing prayer behind the Messenger of Allah (may peace be upon him) we used to recite: Peace be upon Allah, peace be upon so and so. One day the Messenger of Allah (may peace be upon him) said to us: Verily Allah is Himself Peace. When any one of you sits during the prayer. he should say: All services rendered by words, by acts of worship, and all good things are due to Allah. Peace be upon you,0 Prophet, and Allah's mercy and blessings. Peace be upon us and upon Allah's upright servants, for when he says this it reaches every upright servant in heaven and earth (and say further): I testify that there is no god but Allah and I testify that Muhammad is His servant and Messenger. Then he may choose any supplication which pleases him and offer it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.794]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 794

Shu'ba has narrated this on the authority of Mansur with the same chain of transmitters, but he made no mention of this:" Then he may choose any supplication which pleases him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.795]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 795

This hadith has been narrated on the authority of Mansur with the same chain of transmitters and he made a mention of this:" Then he may choose any supplication which pleases him or which he likes."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.796]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 796

Abdullah b. Mas'ud reported: We were sitting with the Apostle (may peace be upon him) in prayer, and the rest of the hadith is the same as narrated by Mansur He (also said): After (reciting tashahud) he may choose any prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.797]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 797

Ibn Mas'ud is reported to have said: The Messenger of Allah (may peace be upon him) taught me tashahhud taking my hand within his palms, in the same way as he taught me a Sura of the Qur'an, and he narrated it as narrated above.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.798]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 798

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) used to teach us tashahbud just as he used to teach us a Sura of the Qur'an, and he would say: All services rendered by., words, acts of worship. and all good thirgs are due to Allah. Peace be upon you,0 Prophet. and Allah's mercy and blessings. Peace be upon us and upon Allah's upright servants. I testify that there is no god but Allah, and I testify that Muhammad is the Messenger of Allah. In the narration of Ibn Rumb (the words are):" As he would teach us the Qur'an."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.799]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 799

Tawus narrated it on the authority of Ibn 'Abbas that he said: The Messenger of Allah (may peace be upon him) used to teach us tashahhud as he would teach us a Sura of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.800]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 800

Hattan b. 'Abdullah al-Raqiishi reported: I observed prayer with Abu Musu al-Ash'ari and when he was in the qa'dah, one among the people said: The prayer has been made obligatory along with piety and Zakat. He (the narrator) said: When Abu Musa had finished the prayer after salutation he tuined (towards the people) and said: Who amongst you said such and such a thing? A hush fell on the people. He again said.. Who amongst you has said such and such a thing? A hush fell on the people. He (Abu Musa) said: Hattan, It is perhaps you that have uttered it. He (Hattan) said No. I have not uttered it. I was afraid that you might be annoyed with me on account of this. A person amongst the people said: It was I who said it, and In this I intended nothing but good. Abu Musa said: Don't you know what you have to recite in your prayers? Verily the Messenger of Allah (may peace be upon him) addressed us and explained to us all Its aspects and taught us how to observe prayer (properly). He (the Holy Prophet) said: When you pray make your rows straight and let anyone amongst you act as your Imim. Recite the takbir when he recites it and when be recites: Not of those with whom Thou art angry. nor of those who go astray, say: Amin. Allah would respond you. And when he (the Imim) recites the takbir, you may also recite the takbir, for the Imam bows before you and raises himself before you. Then the Messenger of Allah (may peace be upon him) said: The one is equivalent to the other. And when he says: Allah listens to him who praises Him, you should say: 0 Allah, our. Lord, to Thee be the praise, for Allah, the Exalted and Glorious, has vouchsafed (us) through the tongue of His Apostle (may peace be upon him) that Allah listens to him who praises Him. And when he (the Imim) recites the takbir and prostrates, you should also recite the takbir and prostrate, for the Imim prostrates before you and raises himself before you. The Messenger' of Allah (may peace be upon him) said: The one is equi- valent to the other. And when he (the Imim) sits for Qa'da (for tashahhud) the first words of every one amongst you should be: All services rendered by words, acts of worship and all good things are due to Allah. Peace be upon you,0 Apostle, and Allah's mercy and blessings. Peace be upon us and upon the upright servants of Allah. I testify that there is no god but Allah, and I testify that Mubammad is His servant and His Messenger.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.801]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 801

Qatida has narrated a badith like this with another chain of transmitters. In the badith transmitted by Jarir on the authority of Sulaiman, Qatida's further words are: When (the Qur'in) is recited (in prayer), you should observe silence, and (the following words are) not found in the hadith narrated by anyone except by Abu Kamil who heard it from Abu 'Awina (and the words are): Verily Allah vouchsafed through the tongue of the Apostle of Allah (may peace be upon him) this: Allah listens to him who praises Him. Abu Ishaq (a student of Imam Muslim) said: Abu Bakr the son of Abu Nadr's sister has (critically) discussed this hadith. Imam Muslim said: Whom can you find a more authentic transmitter of badith than Sulaiman? Abu Bakr said to him (Imam Muslim): What about the hadith narrated by Abd Huraira, i. e. the hadith that when the Qur'in is recited (in pray er) observe silence? He (Abu Bakr again) said: Then, why. have you not included it (in your compilation)? He (Imam Muslim) said: I have not included in this every hadith which I deem authentic; I have recorded only such ahadith on which there is an agreement (amongst the Muhaddithin apart from their being authentic).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.802]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 802

This hadith has been transmitted by Qatida with the same chain of transmitters (and the words are):" Allah, the Exalted and the Glorious, commanded it through the tongue of His Apostle (may peace be upon-him): Allah listens to him who praises Him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.803]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 803

Abdullah b. Zaid-he who was shown the call (for prayer in a dream) narrated it on the authority of Mas'ad al-Ansiri who said: We were sitting in the company of Sa'id b. 'Ubida when the Messenger of Allah (may peace be upon him) came to us. Bashir b. S'ad said: Allah has commanded us to bless you. Messenger of Allah! But how should we bless you? He (the narrator) said: The Messenger of Allah (may peace be upon him) kept quiet (and we were so much perturbed over his silence) that we wished we had not asked him. The Messenger of Allah (may peace be upon him) then said: (For blessing me) say:" 0 Allah, bless Muhammad and the members of his household as Thou didst bless the mernbers of Ibrahim's household. Grant favours to Muhammad and the members of his household as Thou didst grant favours to the members of the household of Ibrahim in the world. Thou art indeed Praiseworthy and Glorious" ; and salutation as you know.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.804]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 804

Ibn Abi Laila reported: Ka'b b. 'Ujra met me and said: Should I not offer you a present (and added): The Messenger of Allah (may peace be upon him) came to us and we said: We have learnt how to invoke peace upon you; (kindly tell us) how we should bless you. He (the Holy Prophet) said: Say:" O Allah: bless Muhammad and his family as Thou didst bless the family of Ibrahim. Verily Thou art Praiseworthy and Glorious, O Allah."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.805]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 805

A hadith like this has been narrated by Mis'ar on the authority of al-Hakam, but in the hadith transmitted by Mis'ar these words are not found:" Should I not offer you a present?"


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.806]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 806

A hadith like this has been narrated by al-Hakam except that he said:" Bless Muhammad (may peace be upon him)" and he did not say:" O Allah I


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.807]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 807

Abu Humaid as-Sa'idi reported: They (the Companions of the Holy Prophet) said: Apostle of Allah, how should we bless you? He (the Holy Prophet) observed: Say:" O Allah! bless Muhammad, his wives and his offspring as Thou didst bless Ibrahim, and grant favours to Muhammad, and his wives and his offspring as Thou didst grant favours to the family of Ibrahim; Thou art Praiseworthy and Glorious."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.808]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 808

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who blesses me once, Allah would bless him ten times.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.809]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 809

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the Imam says:" Allah listens to him who praises Him." you should say:" O Allah, our Lord for Thee is the praise." for if what anyone says synchronises with what the angels say, his past sins will be forgiven.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.810]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 810

A hadith like this is narrated by Abd Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.811]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 811

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: SayAmin when the Imam says Amin, for it anyone's utterance of Amin synchronises with that of the angels, he will be forgiven his past sins.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.812]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 812

Abu Huraira said: I heard from the Messenger of Allah (may peace be upon him) the hadith like one transmitted by Malik, but he made no mention of the words of Shibab.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.813]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 813

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you utters Amin in prayer and the angels in the sky also utter Amin, and this (utterance of the one) synchronises with (that of) the other, all his previous sins are pardoned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.814]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 814

Abu Harare reported: The Messenger of Allah (may peace be upon him) said: When anyone amongst you utters Amin and the angels In the heaven also utter Amin and (the Amin) of the one synchronises with (that of) the other, all his previous sins are pardoned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.815]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 815

'A hadith like this is transmitted by Ma'mar from Hammam b. Munabbih on the authority of Abu Huraira who reported it from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.816]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 816

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the reciter (Imam) utters:" Not of those on whom (is Thine) wrath and not the erring ones," and (the person) behind him utters Amin and his utterance synchronises with that of the dwellers of heavens, all his previous sins would be pardoned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.817]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 817

Anas b. Malik reported: The Apostle of Allah (may peace be upon him) fell down from a horse and his right side was grazed. We went to him to inquire after his health when the time of prayer came. He led us in prayer in a sitting posture and we said prayer behind him sitting, and when he finished the prayer hesaid: The Imam is appointed only to be followed; so when he recites takbir, you should also recite that; when he prostrates, you should also prostrate; when he rises up, you should also rise up, and when he said" God listens to him who praises Him," you should say:" Our Lord, to Thee be the praise," and when he prays sitting, all of you should pray sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.818]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 818

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from a horse and he was grazed and he led the prayer for us sitting, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.819]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 819

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from a horse and his right side was grazed, and the rest of the hadith is the same with the addition of these words:" When he (the Imam) says prayer standing, you should also do so."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.820]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 820

Anas reported: The Messenger of Allah (may peace be upon him) rode a horse and fell down from it and his right side was grazed, and the rest of the hadith is the same, and (these words) are found in it:" When he (the Imam) says prayer in an erect posture, you should also say it in an erect posture."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.821]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 821

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) fell down from his horse and his right side was grazed, and the rest of the hadith is the same. In this hadith there are no additions (of words) as transmitted by Yunus and Malik.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.822]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 822

'A'isha reported: The Messenger of Allah (may peace be upon him) fell ill and some of his Companions came to inquire after his health. The Messenger of Allah (may peace he upon him) said prayer sitting, while (his Companions) said it (behind him) standing. He (the Holy Prophet) directed them by his gesture to sit down, and they sat down (in prayer). After finishing the (prayer) lie (the Holy Prophet) said: The Imam is appointed so that be should be followed, so bow down when lie bows down, and rise rip when he rises up and say (prayer) sitting when he (the Imam) says (it) sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.823]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 823

This hadith is narrated with the same chain of transmitters by Hisham b. 'Urwa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.824]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 824

Jabir reported: The Messenger of Allah (may peace be upon him) was ill and we said prayer behind him and he was sitting. And Abu Bakr was making audible to the people his takbir. As he paid his attention towards us he saw us standing and (directed us to sit down) with a gesture. So we sat down and said our prayer with his prayer in a sitting posture. After uttering salutation he said: You were at this time about to do an act like that of the Persians and the Romans. They stand before their kings while they sit, so don't do that; follow your Imams. If they say prayer standing, you should also do so, and if they say prayer sitting, you should also say prayer sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.825]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 825

Jabir said: The Messenger of Allah (may peace be upon him) led the prayer and Abu Bakr was behind him. When the Messenger of Allah (may peace be upon him) recited the takbir, Abu Bakr also recited (it) in order to make it audible to us. And the rest of the hadith is like one transmitted by Laith.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.826]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 826

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The Imam is appointed, so that he should be followed, so don't be at variance with him. Recite takbir when he recites it; bow down when he bows down and when he says:" Allah listens to him who praises Him," say:" O Allah, our Lord, to Thee be the Praise." And when he (the Imam) prostrates, you should also prostrate, and when he says prayer sitting, you should all observe prayer sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.827]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 827

A hadith like this has been transmitted by Hammam b. Munabbih from the Apostle of Allah (may peace be upon him) on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.828]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 828

Abu Huraira reported: The Messenger of Allah (may peace be upon him) while teaching us (the principles of faith), said: Do not try to go ahead of the Imam, recite takbir when he recites it. and when he says:" Nor of those who err," you should say Amin, bow down when lie bows down, and when he says:" Allah listens to him who praises Him," say:" O Allah, our Lord, to Thee be the praise".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.829]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 829

Abu Huraira reported from the Apostle of Allah (may peace be upon him) (a hadith) like it, except the words:" Nor of those who err, say Amin" and added:" And don't rise up ahead of him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.830]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 830

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Verily the Imam is a shield, say prayer sitting when he says prayer sitting. And when he says:" Allah listens to him who praises Him," say:" O Allah, our Lord, to Thee be the praise." and when the utterance of the people of the earth synchronises with that of the beings of heaven (angels), all the previous sins would be pardoned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.831]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 831

Abu Huraira reported Allah's Messenger (may peace be upon him) saying: The Imamis appointed to be followed. So recite takbir when he recites it, and bow down when he bows down and when he utters:" Allah listens to him who praises Him," say" O Allah, our Lordfor Thee be the praise." And when he prays, standing, you should pray standing. And when he prays sitting, all of you should pray sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.832]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 832

Ubaidullah b. Abdullah reported: I visited 'A'isha and asked her to tell about the illness of the Messenger of Allah (may peace be upon him). She agreed and said: The Apostle (may peace be upon him) was seriously ill and he asked whether the people had prayed. We said: No, they are waiting for you, Messenger of Allah. He (the Holy Prophet) said: Put some water in the tub for me. We did accordingly and he (the Holy Prophet) took a bath;and, when he was about to move with difficulty, he fainted. When he came round, he again said: Have the people said prayer? We said: No, they are waiting for you, Messenger of Allah. He (the Holy Prophet) again said: Put some water for me in the tub. We did accordingly and he took a bag, but when he was about to move with difficultyhe fainted. When he came round, he asked whether the people had prayed. We said: No, they are waiting for you, Messenger of Allah. He said: Put some water for me in the tub. We did accordingly and he took a bath and he was about to move with difficulty when he fainted. When he came roundhe said: Have the people saidprayer? We said: No, they are waiting for you, Messenger of Allah. She ('A'isha) said: The people were staying in the mosque and waiting for the Messenger of Allah (may peace be upon him) to lead the last (night) prayer. She ('A'isha) said: The Messenger of Allah (may peace be upon him) sent (instructions) to Abu Bakr to lead the people in prayer. When the messenger came, he told him (Abd Bakr): The Messenger of Allah (may peace be upon him) has ordered you to lead the people in prayer. Abu Bakr who was a man of very tenderly feelings asked Umar to lead the prayer. 'Umar said: You are more entitled to that. Abu Bakr led the prayers during those days. Afterwards the Messenger of Allah (may peace be upon him) felt some relief and he went out supported by two men, one of them was al-'Abbas, to the noon prayer. Abu Bakr was leading the people in prayer. When Abu Bakr saw him. he began to withdraw, but the Apostle of Allah (may peace be upon him) told him not to withdraw. He told his two (companions) to seat him down beside him (Abu Bakr). They seated him by the side of Abu Bakr. Abu Bakr said the prayer standing while following the prayer of the Apostle (way peace be upon him) and the people Bald prayer (standing) while following the prayer of Abu Bakr. The Apostle (may peace be upon him) was seated. Ubaidullah said: I visited 'Abdullah b. 'Abbas, and said: Should I submit to you what 'A'isha had told about the illness of the Apostle (may peace be upon him)? He said: Go ahead. I submitted to him what had been transmitted by her ('A'isha). He objected to none of it, only asking whether she had named to him the man who accompanied al-'Abbas. I said: No. He said: It was 'Ali.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.833]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 833

'A'isha reported: It was in the house ofMaimuna that the Messenger of Allah (may peace be upon him) first fell ill. He asked permission from his wives to stay in her ('A'isha's) house during his illness. They granted him permission. She ('A'isha) narrated: He (the Holy Prophet) went out (for prayer) with his hand over al-Fadl b. 'Abbas and on the other hand there was another person and (due to weakness) his feet dragged on the earth. 'Ubaidullah said: I narrated this hadith to the son of 'Abbas ('Abdullah b. 'Abbas) and he said: Do you know who the man was whose name 'A'isha did not mention? It was 'Ali.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.834]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 834

'A'isha, the wife of the Apostle (may peace be upon him), said: When the Messenger of Allah (may peace be upon him) fell ill and his illness became serious, he asked permission from his wives to stay in my house during his illness. They gave him permission to do so. He stepped out (of'A'isha's apartment for prayer) supported by two persons. (He was so much weak) that his feet dragged on the ground and he was being supported by 'Abbas b. 'Abd al-Muttalib and another person. 'Ubaidullah said: I informed 'Abdullah (b. 'Abbas) about that which 'A'isha had said. 'Abdullah b. 'Abbas said: Do you know the man whose name 'A'isha did not mention? He said: No. Ibn 'Abbas said: It was 'Ali.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.835]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 835

'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: I tried to dissuade the Messenger of Allah (may peace be upon him) from it (i. e. from appointing Abu Bakr as the Imam.) and my insistence upon it was not due to the fact that I entertained any apprehension in my mind that the people would not love the man who would occupy his (Prophet's) place (i. e. who would be appointed as his caliph) and I feared that the people would be superstitious about one who would occupy his place. I, therefore, desired that the Messenger of Allah (may peace be upon him) should leave Abu Bakr aside in this matter.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.836]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 836

'A'isha reported: When the Messenger of Allah (may peace be upon him) came to my house, he said: Ask Abu Bakr to lead people in prayer. 'A'isha narrated: I said, Messenger of Allah, Abu Bakr is a man of tenderly feelings; as he recites the Qur'an, he cannot help shedding tears: so better command anyone else to lead the prayer. By Allah, there is nothing disturbing in it for me but the idea that the people may not takeevil omen with regard to one who is the first to occupy the place of the Messenger of Allah (may peace be upon him). I tried to dissuade him (the Holy Prophet) twice or thrice (from appointing my father as an Imam in prayer), but he ordered Abu Bakr to lead the people in prayer and said: You women are like those (who had) surrounded Yusuf.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.837]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 837

'A'isha reported: When the Messenger of Allah (may peace be upon him) was confined to bed, Bilal came to him to summon him to prayer. He (the Holy Prophet) said: Ask Abu Bakr to lead the people in prayer. She ('A'isha) reported: I said: Messenger of Allah, Abu! Bakr is a tenderhearted man, go when ]be would stand at your place (he would be so overwhelmed by feelings) that he would not be able to make the people hear anything (his recitation would not be audible to the followers in prayer). You should better order Umar (to lead the prayer). He (the Holy Prophet) said: Ask Abu Bakr to lead people in- prayer. She ('A'isha) said: I asked Hafsa to (convey) my impression to him (the Holy Prophet) that Abu Bakr was a tenderhearted man, so when he would stand at his place, he would not be able to make the people bear anything. He better order Umar. Hafsa conveyed this (message of Hadrat 'A'isha) to him (the Holy Prophet). The Messenger of Allah (may peace be upon him) said: (You are behaving) as if you are the females who had gathered around Yusuf. Order Abd Bakr to lead the people in prayer. She ('A'isha) reported: So Abu Bakr was ordered to lead the people in prayer. As the prayer began, the Messenger of Allah (may peace he upon him) felt some relief; he got up and moved supported by two persons and his feet dragged on earth (due to excessive weakness). 'A'isha reported: As he (the Holy Prophet) entered the mosque. Abu Bakr perceived his (arrival). He was about to with. draw, but the Messenger of Allah (may peace be upon him) by the gesture (of This hand) told him to keep standing at his place. The Messenger of Allah (may peace be upon him) came and seated himself on the left side of Abu Bakr. She ('A'isha) reported: The Messenger of Allah (may peace be upon him) was leading people in prayer sitting. Abu Bakr was following the prayer of the Apostle (may peace be upon him) in a standing posture and the people were following the prayer of Abu Bakr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.838]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 838

A'mash reported: When the Messenger of Allah (may peace be upon him) suffered from illness of which he died, and in the hadith transmitted by Ibn Mus-hir, the words are: The Messenger of Allah (may peace be upon him) was brought till he was seated by his (Abu Bakr's) side and the Apostle (may peace be upon him) led the people in prayer and Abu Bakr was making takbir audible to them, and in the hadith transmitted by 'Isa the (words are):" The Messenger of Allah (may peace be upon him) sat and led the people in prayer and Abu Bakr was by his side and he was making (takbir) audible to the people."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.839]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 839

'A'isha reported: The Messenger of Allah (may peace be upon him) ordered Abu Bakr that he should lead people in prayer during his illness, and he led them In prayer. 'Urwa said: The Messenger of Allah (may peace be upon him) felt relief and went (to the mosque) and Abd Bakr was leading the people in prayer. When Abel Bakr saw him he began to withdraw, but the Messenger of Allah (may peace be upon him) signed him to remain where he was. The Messenger of Allah (may peace be upon him) sat opposite to Abu Bakr by his side. Abu Bakr said prayer following the prayer of the Messenger of Allah (may peace be upon him), and the people said prayer following the prayer of Abu Bakr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.840]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 840

Anas b. Malik reported, Abu Bakr led them in prayer due to the illness of the Messenger of Allah (may peace be upon him) of which be died. It was a Monday and they stood in rows for prayer. The Messenger of Allah (may peace be upon him) drew aside the curtain of ('A'isha's) apartment and looked at us while he was standing, and his (Prophet's) face was (as bright) as the paper of the Holy Book. The Messenger of Allah (may peace be upon him) felt happy and smiled. And we were confounded with joy while in prayer due to the arrival (among our midst) of the Messenger of Allah (may peace be upon him), Abu Bakr stepped back upon his heels to say prayer in a row perceiving that the Messenger of Allah (may peace be upon him) had come out for prayer. The Messenger of Allah (may peace be upon him) with the help of his hand signed to them to complete their prayer. The Messenger of Allah (may peace be upon him) went back (to his apartment) and drew the curtain. He (the narrator) said: The Messenger of Allah (may peace be upon him) breathed his last on that very day.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.841]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 841

Anas reported: The last glance that I have had of the Messenger of Allah (may peace be upon him) (before his death) was that when he on Monday drew the curtain aside. The hadith transmitted by Salih is perfect and complete.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.842]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 842

This hadith is narrated on the authority of Anas b. Malik by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.843]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 843

Anas reported: The Apostle of Allah (may peace be upon him) did not come to us for three days. When the prayer was about to start. Abu Bakr stepped forward (to lead the prayer), and the Apostle of Allah (may peace be upon him) lifted the curtain. When the face of the Apostle of Allah (may peace be upon him) became visible to us, we (found) that no sight was more endearing to us than the face of the Apostle of Allah (may peace be upon him) as it appeared to us. The Apostle of Allah (may peace be upon him) with the gesture of his hand directed Abu Bakr to step forward (and lead the prayer). The Apostle of Allah (may peace be upon him) then drew the curtain, and we could not see him till he died.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.844]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 844

Abu Musa reported: When the Messenger of Allah (may peace be upon him) became ill and illness became serious he ordered Abu Bakr to lead the people in prayer. Upon this 'A'isha said: Messenger of Allah, Abd Bakr is a man of tenderly feelings: when he would stand in your place (he would be so much overwhelmed -by grief that) he would not be able to lead the people in prayer. He (the Holy Prophet) said: You order Abu Bakr to lead the people in prayer, and added: You are like the female companions of Yusuf. So Abu Bakr led the prayer (during this period of illness) in the life of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.845]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 845

Sahl b. Sa'd al-Sa'idi reported: The Messenger of Allah (may peace be upon him) went to the tribe of Bani Amr b. Auf in order to bring reconciliation amongst (its members), and It was a time of prayer. The Mu'adhdhin came to Abu Bakr and said: Would you lead the prayer in case I recite takbir (tahrima, with which the prayer begins)? He (Abu Bakr) said: Yes. He (the narrator) said: He (Abu Bakr) started (leading) the prayer. The people were engaged in observing prayer when the Messenger of Allah (may peace be upon him) happened to come there and made his way (through the people) till he stood in a row. The people began to clap (their hands), but Abu Bakr paid no heed (to it) in prayer. When the people clapped more vigorously, he (Abu Bakr) then paid heed and saw the Messenger of Allah (may peace be upon him) there. (He was about to withdraw when) the Messenger of Allah (may peace be upon him) signed to him to keep standing at his place. Abu Bakr lifted his hands and praised Allah for what the Messenger of Allah (may peace be upon him) had commanded him and then Abu Bakr withdrew himself till he stood in the midst of the row and the Messenger of Allah (may peace be upon him) stepped forward and led the prayer. When (the prayer) was over, he (the Holy Prophet) said: 0 Abu Bakr, what prevented you from standing (at that place) as I ordered you to do? Abu Bakr said: It does not become the son of Abu Quhafa to lead prayer before the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) said (to the people) around him: What is it that I saw you clapping so vigorously? (Behold) when anything happens in prayer, say: Subha Allah, for when you would utter it, it would attract the attention, while clapping of hands is meant for women.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.846]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 846

This hadith is transmitted by Sahl b. Sa'd in the same way as narrated by Malik, with the exception of these words:" Abu Bakr lifted his hands and praised Allah and retraced his (steps) till he stood in a row."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.847]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 847

Sahl b. Sa'd al-Sa'idi reported: The Apostle of Allah (may peace be upon him) went to Bani Amr b. 'Auf in order to bring about reconciliation amongst them. The rest of the hadith is the same but with (the addition of these words):" The Messenger of Allah (may peace be upon him) came and made his way through the rows till he came to the first row and Abu Bakr retraced his steps."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.848]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 848

Mughira b. Shu'ba reported that he participated In the expedition of Tabuk along with the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) went out to answer the call of nature before the morning prayer. and I carried along with him a jar (full of water). When the Messenger of Allah (may peace be upon him) came back to me (after relieving himself). I began to pour water upon his hands out of the jar and he washed his hands three times, then washed his face three times. He then tried to tuck up the sleeves of his cloak upon his forearms but since the sleeves were tight he inserted his hands in the cloak and then brought out his forearms up to the elbow below the cloak, and then wiped over his shoes and then moved on. Mughira said: I also moved along with him till he came to the people and (he found) that they had been saying their prayer under the Imamah of 'Abd al-Rahman b. 'Auf. The Messenger of Allah (may peace be upon him) could get one rak ah out of two and said (this) last rak'ah along with the people. When Abd al-Rahman b. 'Auf pronounced the salutation, the Messenger of Allah (may peace be upon him) got up to complete the prayer. This made the Muslims terrified and most of them began to recite the glory of the Lord. When the Apostle of Allah (may peace be upon him) finished his prayer, he turned towards them and then said: You did well, or said with a sense of joy: You did the right thing that you said prayer at the appointed hour.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.849]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 849

This hadith is narrated by Hamza b. Mughira by another chain of trans- mitters (but with the addition of these words): I made up my mind to hold Abd al-Rahman b. 'Auf back, but the Messenger of Allah (may peace be upon him) said: Leave him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.850]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 850

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Glorification of Allah is for men and clapping of hands is meant for women (if something happens in prayer). Harmala added in his narration that Ibn Shihab told him: I saw some of the scholars glorifying Allah and making a gesture.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.851]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 851

This hadith is narrated on the authority of Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.852]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 852

This hadith is transmitted by Muhammad b. Rafi', Abu'I-Razzaq. Ma'mar, Hammam on the authority of Abu Huraira with the addition of (the word)" prayer".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.853]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 853

Abu Huraira reported: one day the Messenger of Allah (may peace be upon him) led the prayer. Then turning (towards his Companions) he said: 0 you, the man, why don't you say your prayer well? Does the observer of prayer not see how he is performing the prayer for he performs it for himself? By Allah, I see behind me as I see In front of me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.854]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 854

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Do you find me seeing towards the Qibla only? By Allah, your bowing and your prostrating are not hidden from my view. Verily I see them behind my back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.855]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 855

Anas b. Malik reported. The Messenger of Allah (may peace be upon him) said: Perform bowing and prostration well. By Allah. I see you even if you are behind me, or he said'. (1 see you) behind my back when you bow or prostrate.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.856]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 856

Anas reported: The Apostle of Allah (may peace be upon him) said: Complete the bowing and prostration well. By Allah, 1 see you behind my back as to how you bow and prostrate or when you bow and prostrate.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.857]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 857

Anas reported: The Messenger of Allah (may peace be upon him) one day led us in the prayer. and when he completed the Prayer he turned his face towards us and said: 0 People, I am your Imam, so do not precede me in bowing and prostration and in standing and turning (faces, i. e. In pronouncing salutation), for I see you in front of me and behind me, and then said: By Him in Whose hand Is the life of Muhammad, if you could see what I see, you would have laughed little and wept much more. They said: What did you see, Messenger of Allah? He replied: (I saw) Paradise and Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.858]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 858

This hadith is narrated by Anas with another chain of transmitters, and in the hadith transmitted by Jarir there is no mention of" turning (faces)".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.859]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 859

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Does the man who lifts his head ahead of the Imam (from prostration) not fear that Allah may change his head into the head of an ass?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.860]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 860

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Does the man who lifts his head before the Imam not fear that Allah may change his face into that of an ass?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.861]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 861

This hadith has been narrated by Abu Huraira by another chain of transmitters except for the words narrated by Rabi' b. Muslim:" Allah may make his face like the face of an ass."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.862]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 862

Jabir b. Samura reported: The Messenger of Allah (may peace be upon him) said: The people who lift their eyes towards the sky in Prayer should avoid it or they would lose their eyesight.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.863]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 863

Abu Huraira reported: People should avoid lifting their eyes towards the sky while supplicating in prayer, otherwise their eyes would be snatched away.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.864]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 864

Jabir b. Samura reported: The Messenger of Allah (may peace be upon him) came to us and said: How is it that I see you lifting your hands like the tails of headstrong horses? Be calm in prayer. He (the narrator) said: He then again came to us and saw us (sitting) in circles; he said: How is it that I see you in separate groups? He (the narrator) said: He again came to us and said: Why don't you draw yourselves up in rows as angels do in the presence of their Lord? We said: Messenger of Allah, bow do the angels draw themselves up in rows in the presence of their Lord? He (the Holy Prophet) said: They make the first rows complete and keep close together in the row.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.865]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 865

This hadith has been narrated by A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.866]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 866

Jabir b. Samura reported: When we said prayer with the Messenger of Allah (may peace be upon him), we pronounced: Peace be upon you and Mercy of Allah, peace be upon you and Mercy of Allah, and made gesture with the hand on both the sides. Upon this the Messenger of Allah (may peace be upon him said: What do you point out with your hands as if they are the tails of headstrong horses? This is enough for you that one should place one's hand on one's thigh and then pronounce salutation upon one's brother on the right side and then on the left.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.867]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 867

Jabir b. Samura reported: We said our prayer with the Messenger of Allah (may peace be upon him) and, while pronouncing salutations, we made gestures with our hands (indicating)" Peace be upon you, peace be upon you." The Messenger of Allah (may peace be upon him) looked towards us and said: Why is it that you make gestures with your hands like the tails of headstrong horses? When any one of you pro- nounces salutation (in prayer) he should only turn his face towards his companion and should not make a gesture with his hand.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.868]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 868

Abu Mas'ud reported: The Messenger of Allah (may peace he upon him) used to touch our shoulders in prayer and say: Keep straight, don't be irregular, for there would be dissension in your hearts. Let those of you who are sedate and prudent be near me, then those who are next to them, then those who are next to them. Abu Mas'ud said: Now-a-days there is much dissension amongst you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.869]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 869

This hadith is narrated by Ibn Uyaina with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.870]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 870

Abdullah b. Mas'ud reported: The Messenger of Allah (may peace be upon him) said: Let those who are sedate and prudent be near me, then those who are next to them (saying it tliree tinies), and beware of the tumult of the markets.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.871]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 871

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Straighten your rows. for the straightening of a row is a part of the perfection of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.872]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 872

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Complete the rows, for I can see you behind my back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.873]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 873

Hammam b. Munabbih reported: This is what was transmitted to us by Abu Huraira from the Messenger of Allah (may peace be upon him) and, while making a mention of a few ahadith, said: (The Messengerof Allah directed us thus): Establish rows in prayer, for the making of a row (straight) is one of the merits of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.874]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 874

Nu'man b. Bashir reported: I heard the Messenger of Allah (may peace be upon him) say: Straighten your rows, or Allah would create dissension amongst you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.875]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 875

Nu'man b. Bashir reported: The Messenger of Allah (may peace-be upon him) used to straighten our rows as it lie were straightening an arrow with their help until be saw that we had learnt it from him. One day he came out, stood up (for prayer) and was about to say: Allah is the Greatest, when he saw a man, whose chest was bulging out from the row, so he said: Servants of Allah, you hint straighten your rows or Allah would create dissension amongst you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.876]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 876

Abu 'Awana reported this hadith with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.877]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 877

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If the people were to know what excellence is there in the Adhan and in the first row, and they could not (get these opportunities) except by drawing lots, they would have definitely done that. And if they were to know what excellence lies in joining the prayer in the first takbir (prayer), they would have vied with one another. And if they were to know what excellence lies in the night prayer and morning prayer, they would have definitely come even if crawling (on their knees).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.878]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 878

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) saw (a tendency ) among his Companions to go to the back, so he said to them: Come forward and follow my lead, and let those who come after you follow your lead. People will continue to keep back till Allah will put them at the back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.879]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 879

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) saw people at the end of the mosque, and then the (above-mentioned hadith) was narrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.880]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 880

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If you were to know, or if they were to know, what (excellence) lies in the first rows, there would have been drawing of lots (for filling them) ; and Ibn Harb said: For (occupying) the first row there would have been drawing of lots.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.881]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 881

Abu Huraira said: The best rows for men are the first rows, and the worst ones the last ones, and the best rows for women are the last ones and the worst ones for them are the first ones.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.882]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 882

This hadith is narrated by Suhail with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.883]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 883

Sahl b. Sa'd reported: I saw men having tied (the ends) of their lower garments around their necks, like children, due to shortage of cloth and offering their prayers behind the Apostle of Allah (may peace be upon him). One of the proclaimers said: O womenfolk, do not lift your heads till men raise (them).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.884]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 884

Salim narrated it from his father ('Abdullah b. Umar) that the Messenger of Allah (may peace be upon him) said: When women ask permission for going to the mosque, do not prevent them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.885]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 885

Abdullah b. Umar reported: I heard Allah's Messenger (may peace be upon him) say: Don't prevent your women from going to the mosque when they seek your permission. Bilal b. 'Abdullah said: By Allah, we shall certainly prevent them. On this'Abdullah b. Umar turned towards him and reprimanded him to harshly as I had never heard him do before. He ('Abdullah b. Umar) said: I am narrating to you that which comes from the Messenger of Allah (may peace be upon him) and you (have the audicity) to say: By Allah, we shall certainly prevent them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.886]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 886

Ibn 'Umar reported: 'The Messenger of Allah (may peace be upon him) said: Do not prevent the maid-servants of Allah from going to the mosque.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.887]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 887

lbn Umar reported: I heard the Messeinger of Allah (may peace be upon him) say: When your women seek your permission for going to the mosque, you grant them (permission).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.888]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 888

Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said: Do not prevent women from going to the mosque at night. A boy said to 'Abdullah b. Umar: We would never let them go out, that they may not be caught in evil. He (the narrator) said: Ibn Umar reprimanded him and said.. I am saying that the Messenger of Allah (may peace be upon him) said this, but you say: We would not allow!


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.889]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 889

A hadith like this has been narrated by A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.890]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 890

Ibn 'Umar reported: Grant permission to women for going to the mosque in the night. His son who was called Waqid said: Then they would make mischief. He (the narrator) said: He thumped his (son's) chest and said: I am narrating to you the hadith of the Messenger of Allah (may peace be upon him), and you say: No!


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.891]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 891

Ibn Umar reported: The Messenger of Allah (may peace be upon him) said: Do not deprive women of their share of the mosques, when they seek permission from you. Bilal said: By Allah, we would certainly prevent them. 'Abdullah said: I say that the Messenger of Allah (may peace be upon him) said it and you say: We would certainly prevent them!


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.892]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 892

Zainab Thaqafiya reported: The Messenger of Allah (may peace be upon him) said: When any one of you (women) participates in the 'Isha' prayer, she should not perfume herself that night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.893]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 893

Zainab, the wife of Abdullah (b. 'Umar), reported: The Messenger of Allah (may peace be upon him) said to us: When any one of you comes to the mosque, she should not apply perfume.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.894]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 894

Abu Huraira said: The Messenger of Allah (may peace be upon him) said: Whoever (woman) fumigates herself with perfume should not join us in the 'Isha' prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.895]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 895

'Amra, daughter of Abd al-Rahmin, reported: I heard 'A'isha, the wife of the Apostle of Allah (may peace be upon him). say: If the Messenger of Allah (may peace be upon him) had seen what new things the women have introduced (in their way of life) he would have definitely prevented them from going to the mosque, as the women of BaniIsra'il were prevented.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.896]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 896

This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.897]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 897

Ibn 'Abbas reported: The word of (Allah) Great and Glorious: 'And utter not thy prayer loudly, nor be low in it" (xvii. 110) was revealed as the Messenger of Allah (may peace beupon him) was hiding himself in Mecca. When he led his Companions in prayer he raised his voice (while reciting the) Qur'an. And when the polytheists heard that, they reviled the Qur'an and Him Who revealed it and him who brought it. Upon this Allah, the Exalted, said to His Apostle (may peace be upon him): Utter not thy prayer so loudly that the polytheists may hear thy recitation and (recite it) not so low that it may be inaudible to your Companions. Make them hear the Qur'an, but do not recite it loudly and seek a (middle) way between these. Recite between loud and low tone.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.898]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 898

'A'isha reported that so far as these words of (Allah) Glorious and High are concerned:" And utter not thy prayer loudly, not be low in it" (xvii. 110) relate to supplication (du'a').


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.899]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 899

A hadith like this has been narrated by Hisham with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.900]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 900

Ibn 'Abbas reported with regard to the words of Allah, Great and Glorious:" Move not thy tongue therewith" (Ixxv. 16) that when Gabriel brought revelation to him (the Holy Prophet) he moved his tongue and lips (with a view to committing it to memory instantly). This was something hard for him and it was visible (from his face). Then Allah, the Exalted. revealed this a" Move not thy tongue therewith to make haste (in memorising it). Surely on us rests the collecting of it and the reciting of it" (ixxv. 16), i. e. Verily it rests with Us that We would preserve it in your heart and (enable you) to recite it You would recite it when We would recite it and so follow its recitation, and He (Allah) said:" We revealed it, so listen to it attentively. Verily its exposition rests with Us. i. e. We would make it deliver by your tongue." So when Gabriel came to him (to the Holy Prophet), he kept silence, and when he went away he recited as Allah had promised him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.901]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 901

Ibn Abbas reported with regard to the words:" Do not move thy tongue there with to make haste," that the Apostle of Allah (may peace be upon him) felt it hard and he moved his lips. Ibn 'Abbas said to me (Sa'id b. Jubair): I move them just as the Messenger of Allah (may peace be upon him) moved them. Then said Sa'id: I move them just as Ibn 'Abbas moved them, and he moved his lips. Allah, the Exalted, revealed this:" Do not move your tongue therewith to make haste. It is with US that its collection rests and its recital" (al-Qur'an, ixxv. 16). He said: Its preservation in your heart and then your recital. So when We recite it, follow its recital. He said: Listen to it, and be silent and then it rests with Us that you recite it. So when Gabriel came to the Messenger of Allah (may peace be upon him), he listened to him attentively, and when Gabriel went away, the Apostle of Allah (may peace be upon him) recited as he (Gabriel) had recited it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.902]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 902

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) neither recited the Qur'an to the Jinn nor did he see them. The Messenger of Allah (may peace be upon him) went out with some of his Companions with the intention of going to the bazaar of 'Ukaz And there had been (at that time) obstructions between satans and the news from the Heaven, and there were flung flames upon them. So satan went back to their people and they said: What has happened to you? They said: There have been created obstructions between us and the news from the Heaven. And there have been flung upon us flames. They said: It cannot happen but for some (important) event. So traverse the eastern parts of the earth and the western parts and find out why is it that there have been created obstructions between us and the news from the Heaven. So they went forth and traversed the easts of the earth and its wests. Some of them proceeded towards Tihama and that is a nakhl towards the bazaar of 'Ukaz and he (the Holy Prophet) was leading his Companions in the morning prayer. So when they heard the Qur'an. they listened to it attentively and said: It is this which has caused obstruction between us and news from the Heaven. They went back to their people and said: O our people, we have heard a strange Qur'an which directs us to the right path; so we affirm our faith in it and we would never associate anyone with our Lord. And Allah, the Exalted and Glorious, revealed to His Apostle Muhammad (may peace be upon him):" It has been revealed to me that a party of Jinn listened to it" (Qur'an, lxxii. 1).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.903]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 903

Dawud reported from 'Amir who said: I asked 'Alqama if Ibn Mas'ud was present with the Messenger of Allah (may peace be upon him) on the night of the Jinn (the night when the Holy Prophet met them). He (Ibn Mas'uad) said: No, but we were in the company of the Messenger of Allah (may peace be upon him) one night and we missed him. We searched for him in the valleys and the hills and said. He has either been taken away (by jinn) or has been secretly killed. He (the narrator) said. We spent the worst night which people could ever spend. When it was dawn we saw him coming from the side of Hiri'. He (the narrator) reported. We said: Messenger of Allah, we missed you and searched for you, but we could not find you and we spent the worst night which people could ever spend. He (the Holy Prophet) said: There came to me an inviter on behalf of the Jinn and I went along with him and recited to them the Qur'an. He (the narrator) said: He then went along with us and showed us their traces and traces of their embers. They (the Jinn) asked him (the Holy Prophet) about their provision and he said: Every bone on which the name of Allah is recited is your provision. The time it will fall in your hand it would be covered with flesh, and the dung of (the camels) is fodder for your animals. The Messenger of Allah (may peace be upon him) said: Don't perform istinja with these (things) for these are the food of your brothers (Jinn).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.904]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 904

This hadith has been reported by Dawud with the same chain of transmitters up to the word (s):" The traces of their embers." Sha'bi said: They (the Jinn) asked about their provision, and they were the Jinn of al-jazira, up to the end of the hadith, and the words of Sha'bi have been directly transmitted from the hadith of Abdullah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.905]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 905

This hadith has been narrated on the authority of 'Abdullah from the Apostle (may peace be upon him) up to the words:" The traces of the embers," but he made no mention of what followed afterward.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.906]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 906

Abdullah (b. Mas'ud) said: I was not with the Messenger of Allah (may peace be upon him) but I wish I were with him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.907]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 907

Ma'n reported.. I heard it from my father who said: I asked Masruq who informed the Messenger of Allah (may peace be upon him) about the night when they heard the Qur'an. He said: Your father, Ibn Mas'ud, narrated it to me that a tree informed him about that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.908]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 908

Abu Qatada reported: The Messenger of Allah (may peace be upon him) led us in prayer and recited in the first two rak'ahs of the noon and afternoon prayers Surat al-Fitiha and two (other) surahs. And he would sometimes recite loud enough for us the verses. He would prolong the first rak'ah more than the second. And he acted similarly in the morning prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.909]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 909

Abu Qatada reported it on the authority of his father: The Messenger of Allah (may peace be upon him) would recite in the first two rak'ahs of the noon and afternoon prayers the opening chapter of the Book and another surah. He would sometimes recite loud enough to make audible to us the verse and would recite in the last two rak'ahs Surat al-Faitiha (only).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.910]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 910

Abu Sa'id al-Khudri reported: We used to estimate how long Allah's Messenger (may peace be upon him) stood in the noon and afternoon prayers, and we estimated hat he stood in the first two rak'ahs of the noon prayer as long as it takes to recite Alif Lam Mim, Tanzil, i. e. as-Sajda. We estimated that he stood half that time in the last two rak'ahs; that he stood in the first two of the afternoon as long as he did in the last two at noon; and in the last two of the afternoon prayer about half that time.

Abu Bakr in his narration has made no mention of Alif Lam Mim, Tanzil, but said: As long as it takes to recite thirty verses.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.911]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 911

Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) used to recite in every rak'ah of the first two rak'ahs of the noon prayer about thirty verses and in the last two about fifteen verses or half (of the first rak'ah) and in every rak'ah of the 'Asr prayer of the first two rak'ahs about fifteen verses and in the last two verses half (of the first ones).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.912]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 912

Jabir b. Samura reported: The people of Kufa complained to Umar b. Khattab about Sa'id and they made a mention of his prayer. 'Umar sent for him. He came to him. He ('Umar) totd him that the people had found fault with his prayer. He said: I lead them in prayer in accorance with the prayer of the Messenger of Allah (may peace be upon him). I make no decrease in it. I make them stand for a longer time in the first two (rak'ahs) and shorten it in the last two. Upon this 'Umar remarked: This is what I deemed of thee, O Abu Ishaq


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.913]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 913

This hadith his been narrated by 'Abu al-Malik with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.914]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 914

Jabir b. Samura reported: 'Umar said to Sa'd: They complain against you in every matter, even in prayer. He (Sa'd) said: I prolong (standing) in the first two (rak'ahs) and shorten it in the last two, and I make no negligence in following the prayer of the Messenger of Allah (may peace be upon him). He ('Umar) remarked: This is what is expected of you, or, that is what I deemed of you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.915]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 915

This hadith is narrated by Jabir b. Samura but with the addition of these words:" (Sa'd said): These bedouins presume to teach me prayer."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.916]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 916

Abu Sa'id al-Khudri reported: The noon prayer would start and one would go to al-Baqi' and after having relieved himself he would perform ablution and then come, while the Messenger of Allah (may peace be upon him) would be in the first rak'ah, because he would prolong it so much.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.917]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 917

Qaz'a reported: I came to Abu Sa'id al-Khudri and he was surrounded by people. When the people departed from him I said: I am not going to ask you what these people have been asking you. I want to ask you about the prayer of the Messenger of Allah (may peace be upon him). He (Abu Sa'id) said: There is no good for you in this. He (Qaz'a), however, repeated (his demand). He then said: The noon prayer would start and one of us would go to Baqi' and, having relieved himself, would come to his home, then perform ablution and go to the mosque, and (he would find) The Messenger of Allah (may peace be upon him) in the first rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.918]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 918

Abdullah b. Sa'id reported: The Apostle of Allah (may peace be upon him) led us in the morning prayer in Mecca and began Sarat al-Mu'minin (xxiii ) but when he came to the mention of Moses and Aaron (verse. 45) or to the mention of Jesus (verse 50), a cough got the better of him, and he bowed. 'Abdullah b. Sa'ib was present there, and in the hadith narrated by Abd al-Razzaq (the words are): He cut short (the recitation) and bowed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.919]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 919

'Amr b. Huwairith reported: I heard the Apostle of Allah (may peace be upon him) recite in the morning prayer" Wa'l-lail-i-idhd 'As'asa" (ixxxi. 17).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.920]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 920

Qutba b. Malik reported: I said prayer and the Messenger of Allah (may peace be upon him) led it and he recited" Qaf. (I.). By the Glorious Qur'an," till he recited" and the tall palm trees" (l. 10). I wanted to repeat it but I could not follow its significance.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.921]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 921

Qutba b. Malik reported that he had heard the Messenger of Allah (may peace be upon him) reciting in the morning prayer this:" And the tall palm trees having flower spikes piled one above another" (l. 10).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.922]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 922

Ziyad b. 'Ilaqa reported it on the authority of his uncle that he said the morning prayer with the Apostle of Allah (may peace be upon him) and he recited in the first rak'ah:" And the tall palm trees having flower spikes piled one above another (l. 10) or perhaps Sarah Qaf.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.923]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 923

Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the morning prayer" Qaf. By the Glorious Quran." and his prayer afterward shortened.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.924]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 924

Simak asked Jabir b. Samura about the prayer of the Apostle (may peace be upon him). He said: He (the Holy Prophet) shortened the prayer and he did not pray like these people then, and he informed me that the Messenger of Allah (may peace be upon him) used to recite" Qaf. By the (Glorious) Qur'an," and a passage of similar length.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.925]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 925

Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the noon prayer:" By the night when it envelopes" (xcii.), and in the afternoon like this, but he prolonged the morning prayer as compared to that (noon and afternoon prayers).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.926]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 926

Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to recite in the noon prayer:" Glorify the name of thy Most High Lord in the morning prayer longer than this" (lxxxvii.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.927]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 927

Abu Barza reported: The Messenger of Allah (may peace be upon him) used to recite in the morning prayer from sixty to one hundred verses.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.928]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 928

Abu Barza Aslami reported: The Messenger of Allah (may peace be upon him) used to recite from sixty to one hundred verses in the morning prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.929]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 929

Ibn Abbas reported: Umm al-Fadl daughter of al-Harith heard him reciting:" By those sent forth to spread goodness" (lxxvii.). (Upon this) she remarked: O my son, you reminded me by the recitation of this surah (the fact) that it was the last surah that I heard from the Messenger of Allah (may peace be upon him) and he recited it in the evening prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.930]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 930

This hadith has been narrated by Zuhri with the same chain of transmitters but with this addition:" And he did not lead the player after this till his death."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.931]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 931

Jubair b. Mut'im reported: I heard the Messenger of Allah (may peace be upon him) reciting Surat al-Tur (Mountain) (lii) in the evening prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.932]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 932

This hadith has been narrated by Zuhri with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.933]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 933

'Adi reported: I heard al-Bara' narrating it from the Apostle of Allah (may peace be upon him) that while in a journey he said the night prayer and recited in one of the two rak'ahs:" By the Fig and the Olive" (Su'rah xcv.).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.934]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 934

Al-Bara' b. 'Azib reported that he said prayer with the Messenger of Allah (may peace be upon him) and he recited:" By the Fig and the Olive."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.935]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 935

Al-Bara' b. 'Azib reported: I heard the Apostle of Allah (may peace be upon him) reciting in the night prayer:" By the Fig and the Olive," and I have never heard anyone with a sweeter voice than he.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.936]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 936

Jabir reported that Mu'adh b. jabal used to pray with the Apostle (may peace be upon him), then came and led his people in prayer. One night he said the night prayer with the Apostle of Allah (may peace be upon him). He then came to his people and led them in prayer beginning with Surat al-Baqara. A man turned aside, pronounced the taslim (salutation for concluding the prayer), then prayed alone and departed. The people said to him: Have you become a hypocrite, so and so? He said: I swear by Allah that I have not, but I will certainly go to Allah's Messenger (may peace be upon him) and will inform (him) about this. He then came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, we look after camels used for watering and work by day. Mu'idh said the night prayer with you. He then came and began with Surat al-Baqara. Allah's Messenger (may peace be upon him) then turned to Mu'adh and said: Are you there to (put the people) to trial? Recite such and recite such (and such a surah). It is transmitted on the authority of Jabir, as told by Sufyan, that he (the Holy Prophet) had said:" By the Sun and its morning brightness" (Sarah xci.)," By brightness" (Surah xciii)" By the night when it spreads" (Surah xcii.), and" Glorify the name of thy most high Lord" (Surah lxxxii.).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.937]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 937

Jabir reported: 'Mu'adh b jabal al-Ansari led his companions in the night prayer and prolonged it for them. A person amongst us said prayer (after having separated himself from the congregation). Mu'adh was informed of this, and he remarked that he wasa hypocrite. When it (the remark) was conveyed to the man, he went to the Messenger of Allah (may peace be upon him) and informed him of what Mu'adh had said. Upon this the Apostle of Allah (may peace be upon him) said to him: Mu'adh, do you want to become a person putting (people) to trial? When you lead people in prayer, recite:" By the Sun and its morning brightness" (Surah xci.)," Glorify the name of thy most high Lord" (Surah lxxxvi.) and" Read in the name of Lord" (Surah xcvi.), and" By the night when it spreads" (Surah xcii.).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.938]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 938

Jabir b. 'Abdullah reported: Mu'adh b. Jabal said the night prayer with the Messenger of Allah (may peace be upon him) and then returned to his people and then led them in this prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.939]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 939

Jabir b. Abdullah reported: Mu'adh said the night prayer with the Messenger of Allah (may peace be upon him). He then came to the mosque of his people and led them in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.940]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 940

Abu Mas'ud al-Ainsari reported: A person came to the Messenger of Allah (may peace be upon him) and said: I keep away from the morning prayer on account of such and such (a man), because; he keeps us so long. I never saw God's Messenger (may peace be upon him) more angry when giving an exhortation than he was that day. He said: 0 people, some of you are scaring people away. So whoever of you leads the people in prayer he must be brief, for behind him are the weak, the aged, and the people who have (argent) business to attend.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.941]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 941

This hadith like one narrated by Hashalm has been narrated from Isma'il with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.942]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 942

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: When any one of you leads the people in prayer, he should be brief for among them are the young and the aged, the weak and the sick. But when one of you prays by himself, he may (prolong) as he likes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.943]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 943

Hammam b. Munabbih reported: This is what Abu Huraira transmitted to us from Muhammad the Messenger of Allah (may peace be upon him), and he narrated (some) ahadith out of (these narrations and one of them is this): The Messenger of Allah (may peace be upon him) said: When any one of you stands to lead people In prayer, he should shorten it, for amongst them are the aged, and amongst them are the weak, but when he prays by himself, he may prolong his prayer as he likes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.944]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 944

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you leads people in prayer, he must shorten it for among them are the weak, the infirm and those who have business to attend.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.945]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 945

Abu Bakr b. 'Abd al-Rahman reported that he had heard Abu Huraira say that the Messenger of Allah (may peace be upon him) said like it, but he substituted" the aged" for 'the infirm".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.946]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 946

Uthman b. Abu'l-'As at-Thaqafi reported: The Apostle of Allah (may peace be upon him) said to him: Lead your people in prayer. I said: Messenger of Allah. I perceive something (disturbing) in my soul. He (the Holy Prophet) asked me to draw near him and making me sit down in front of him he placed his hand on my breast between my nipples. and then, telling me to turn round, he placed it on my back between my shoulders. He then said: Act as an Imam for your people. He who acts as Imam of the people, he must be brief, for among them are the aged, among them are the sick, among them are the weak, and among them are the people who have business to attend. But when any of you prays alone, he may pray as he likes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.947]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 947

Uthman b. Abu'l-'As reported: The last thing which the Messenger of Allah (may peace be upon him) instructed me was: When you lead the people in prayer, be brief.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.948]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 948

Anas reported: The Apostle of Allah (may peace be upon him) used to be brief and perfect in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.949]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 949

Anas reported: The Messenger of Allah (may peace be upon him) was among those whose prayers was brief and perfect.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.950]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 950

Anas reported: I never prayed behind an Imam who was more brief and more perfect in prayer than the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.951]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 951

Anas reported: The Messenger of Allah (may peace be upon him) would listen to the crying of a lad in the company of his mother, in prayer, and he would recite a short surah or a small surah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.952]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 952

Anas b. Malik reported the Messenger of Allah (may peace be upon him) having said: When I begin the prayer I Intend to make it long, but I hear a boy cry. ing; I then shorten it because of his mother's feelings.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.953]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 953

Al-Bara' b. 'Azib reported: I noticed the prayer of Muhammad (may peace be upon him) and saw his Qiyam (standing), his bowing, and then going back to the standing posture after bowing, his prostration, his sitting between the two prostrations, and his prostration and sitting between salutation and going away, all these were nearly equal to one another.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.954]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 954

Hakam reported: There dominated in Kufa a man whose name was men- tioned as Zaman b. al-Ash'ath, who ordered Abu 'Ubaidah b. 'Abdullah to lead people in prayer and he accordingly used to lead them. Whenever he raised his head after bowing, he stood up equal to the time that I can recite (this supplication): O Allah! our Lord! unto Thee be the praise which would fill the heavens and the earth, and that which will please Thee besides them I Worthy art Thou of all praise and glory. None can prevent that which Thou bestowest, and none can bestow that whichthou preventest. And the greatness of the great will not avail him against Thee. Hakam (the narrator) said: I made a mention of that to Abd al-Rahman ibn Abi Laila who reported: I heard al-Bara' b. 'Azib say that the prayer of the Messenger of Allah (may peace be upon him) and his bowing, and when he lifted his head from bowing, and his prostration, and between the two prostrations (all these acts) were nearly proportionate. I made a mention of that to 'Ar b. Murrah and he said: I saw Ibn Abi Laili (saying the prayer), but his prayer was not like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.955]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 955

Hakam reported: When Matar b. Najiya dominated Kufa he ordered Abu Ubaida to lead people in prayer, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.956]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 956

Thabit reported it on the authority of Anas: While leading you in prayer I do not shorten anything in the prayer. I pray as I saw the Messenger of Allah (may peace be upon him) leading us. He (Thabit) said: Anas used to do that which I do not see you doing; when he lifted his head from bowing he stood up (so long) that one would say: He has forgotten (to baw down in prostration). And when he lifted his head from prostration, he stayed in that position, till someone would say: He has forgotten (to bow down in prostration for the second sajda).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.957]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 957

Thabit reported it on the authority of Anas: I have never said such a light and perfect prayer as I said behind the Messenger of Allah (may peace be upon him). The prayer of the Messenger. of Allah (may peace be upon him) was well balanced. And so too was the prayer of Abu Bakr well balanced. When it was the time of 'Umar b. al-Khattab he prolonged the morning prayer. When the Messenger of Allah (may peace be upon him) said: Allah listened to him who praised Him, he stood erect till we said: He has forgotten. He then prostrated and sat between two prostration till we said: He has forgotten.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.958]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 958

Al-Bara' (b. 'Azib), and he was no liar (but a truthful Companion of the Holy Prophet), reported: They used to say prayer behind the Messenger of Allah (may peace be upon him). I never saw anyone bending his back at the time when he (the Holy Prophet) raised his head, till the Messenger of Allah (may peace be upon him) placed his forehead on the ground. They then fell in prostration after him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.959]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 959

Al-Bara' reported, and he was no liar: When the Messenger of Allah (may peace be upon him) said: Allah listened to him who praised Him, none of us bent his back till he (the Holy Prophet) prostrated; we then, afterwards, went down in prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.960]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 960

Al-Bara' reported: They (the Companions) said prayer with the Messenger of Allah (may peace be upon him), and they bowed when he (the Holy Prophet) bowed. and when he raised his head after bowing, he pronounced:" Allah listened to him who praised Him," and we kept standing till we saw him placing his face on the ground and then we followed him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.961]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 961

Al-Bara' reported: When we were (in prayer) with the Messenger of Allah Allah (may peace be upon him) none of us benfft his back till we saw he prostrated. Zuhair and others reported:" till we saw him prostrating".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.962]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 962

'Amr b. Huraith reported: I said the dawn prayer behind the Apostle of (may peace be upon him) and heard him reciting: 'Nay. I call to witness the stars, running their courses and setting" (al-Qur'an, lxxxi. 15-16) and Done of us bent his back till he completed prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.963]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 963

('Abdullah b ) Ibn Abi Aufa reported: When the Messenger of Allah (may peace be upon him) raised his back from the rukd' he pronounced: Allah listened to him who praised Him. O Allah! our Lord! unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.964]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 964

'Abdullah b. Aufa reported: The Messenger of Allah (may peace be upon him) used to recite this supplication: O Allah! our Lord, unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.965]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 965

Abdullah b. Abu Aufa reported that the Apostle of Allah (may peace be upon him) used to recite (this supplication): O Allah! our Lord, unto Thee be praise that would fill the heavens and the earth and fill that which will please Thee besides (them). O Allah! purify me with snow, (water of) hail and with cold water; O Allah. cleanse me from the sins and errors just as a white garment is cleansed from dirt.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.966]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 966

This hadith with the same chain of transmitters has been narrated by Shu'ba, and in the narration of Mu'adh the words are:" just as the white garment is cleansed from filth," and in the narration of Yazid:" from dirt".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.967]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 967

Abu Sa'id al-Khudri reported: When the Messenger of Allah (may peace be upon him) raised his head after bowing, he said: O Allah! our Lord, to Thee be the praise that would fill all the heavens and the earth, and all that it pleases Thee besides (them). O, thou art worthy of praise and glory, most worthy of what a servant says, and we all are Thy servants, no one can withhold what Thou givest or give what Thou withholdest, and riches cannot avail a wealthy person against Thee.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.968]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 968

Ibn Abbas reported: When the Apostle of Allah (may peace be upon him) raised his head after bowing, he said: Allah! our Lord, to Thee be the praise that would fill the heavens and the earth and that which is between them, and that which will please Thee besides (them). Worthy art Thou of all praise and glory. No one can withhold what Thou givest, or give what Thou withholdest. And the greatness O! the great availeth not against Thee.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.969]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 969

Ibn Abbas reported from the Apostle of Allah (may peace be upon him) the words:" And that would fill that which will please Thee besides (them)!" and he did not mention the subsequent (portion of supplication).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.970]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 970

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) drew aside the curtain (of his apartment) and (he saw) people in rows (saying prayer) behind Aba Bakr. And he said: Nothing remains of the glad tidings of apostlehood, except good visions which a Muslim sees or someone is made to see for him. And see that I have been forbidden to recite the Qur'an in the state of bowing and prostration. So far as Ruk'u is concerned, extol in it the Great and Glorious Lord, and while prostrating yourselves be earnest in supplication, for it is fitting that your supplications should be answered.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.971]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 971

'Abdullah b. 'Abbas reported: The Messenger of Allah (may peace be upon him) drew aside the curtain and his head was bandaged on account of illness in which he died. He said: O Allah, have I not delivered (Thy Message)? (He repeated it) three times. Nothing has been left out of the glad tidings of apostlebood, but good vision. which a pious servant (of Allah) sees or someone else is made to see for him. He then narrated like the hadith transmitted by Sufyan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.972]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 972

'Ali b. Abi Talib reported: The Messenger of Allah (may peace be upon him) forbade me to recite (the Qur'an) in a state of bowing and prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.973]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 973

'Ali b. Abi Talib reported: The Messenger of Allah (may peace be upon him) forbade to recite the Qur'an, while I am in the state of bowing and prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.974]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 974

'Ali b. Abi Talib reported: The Messenger of Allah (may peace be upon him) forbade me from the recitation (of the Qur'an) in bowing and prostration and I do not say that he forbade you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.975]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 975

'Ali reported: My loved one (the Holy Prophet) forbade me that I should recite (the Qur'an) in a state of bowing and prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.976]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 976

This hadith has been narrated by some other narrators, Ibn 'Abbas and others, and they all reported that 'Ali said: The Apostle of Allah (may peace be upon him) forbade me to recite the Qur'an while I am in a state of bowing and prostration, and in their narration (there is a mention of) forbiddance from that (recital) in the state of prostration as it has been transmitted by Zuhri, Zaid b. Aslam, al-Wahid b. Kathir, and Dawud b. Qais.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.977]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 977

This hadith is transmitted on the authority of 'Ali, but he made no mention of" while in prostration".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.978]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 978

Ibn 'Abbas reported: I was forbidden to recite (the Qur'an) while I was bowing, and there is no mention of 'Ali in the chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.979]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 979

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The nearest a servant comes to his Lord is when he is prostrating himself, so make supplication (in this state).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.980]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 980

Abu Huraira reported: The Messenger of Allah (may peace be upon him) used to say while prostrating himself: O Lord, forgive me all my sins, small and great, first and last, open and secret.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.981]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 981

'A'isha reported: The Messenger of Allah (may peace be upon him') often said while bowing and prostrating himself:" Glory be to Thee, O Allah, our Lord, and praise be to Thee, O Allah, forgive me," thus complying with the (command in) the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.982]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 982

'A'isha reported that the Messenger of Allah (may peace be upon him) before his death recited often: Hallowed be Thou, and with Thy praise, I seek forgiveness from Thee and return to Thee. She reported: I said: Messenger of Allah, what are these words that I find you reciting? He said: There has been made a sign for me in my Ummah; when I saw that, I uttered them (these words of glorification for Allah), and the sign is:" When Allah's help and victory..... to the end of the surah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.983]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 983

'A'isha reported: Never did I, see the Apostle of Allah (may peace be upon him) after the revelation (of these verses):" When Allah's help and victory came." observin- his prayer without making (this supplication) or he said in it (supplication): Hallowed be Thee, my Lord, and with Thy praise, O Allah, forgive me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.984]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 984

'A'isha reported: The Messenger of Allah (may peace be upon him) recited often these words: Hallowed be Allah and with His praise, I seek the forgiveness of Allah and return to Him. She said: I asked: Messenger of Allah, I see that you often repeat the saying" subhan allahi bihamdihi astag firullahi watubuilaih" whereupon he said: My Lord informed me that I would soon see a sign in my Ummah, so when I see it I often recite (these) words: Hallowed be Allah and with His Praise, I seek forgiveness of Allah and return to Him. Indeed I saw it (when this verse) was revealed:" When Allah's help and victory came, it marked the victory of Mecca, and you see people entering into Allah's religion in troops, celebrate the praise of Thy Lord and ask His forgiveness. Surely He is ever returning to Mercy."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.985]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 985

Ibn Juraij reported: I asked 'Ata': What do you recite when you are in a state of bowing (in prayer)? He said:" Hallowed be Thou, and with Thy praise, there is no god but Thou." Son of Abd Mulaika narrated to me on the anthority of 'A'isha (who reported): I missed one night the Apostle of Allah (may peace be upon him) (from his bed). I thought that he might have gone to one of his other wives. I searched for him and then came back and (found him) in a state of bowing, or prostration, saying: Hallowed be Thou and with Thy praise; there is no god but Thou. I said: With my father mayest thou be ransomed and with my mother. I was thinking of (another) affair, whereas you are (occupied) in another one.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.986]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 986

'A'isha reported: One night I missed Allah's Messenger (may peace be upon him) from the bed, and when I sought him my hand touched the soles of his feet while he was in the state of prostration; they (feet) were raised and he was saying:" O Allah, I seek refuge in Thy pleasure from Thy anger, and in Thy forgiveness from Thy punishment, and I seek refuge in Thee from Thee (Thy anger). I cannot reckon Thy praise. Thou art as Thou hast lauded Thyself."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.987]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 987

'A'isha reported that the Messenger of Allah (way peace he upon him) used to pronounce while bowing and prostrating himself: All Glorious, All Holy, Lord of the Angels and the Spirit.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.988]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 988

This hadith has been narrated on the authority of 'A'isha by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.989]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 989

Ma'dan b. Talha reported: I met Thauban, the freed slave. of Allah's Messenger (may peace be upon him), and asked him to tell me about an act for which, if I do it, Allah will admit me to Paradise, or I asked about the act which was loved most by Allah. He gave no reply. I again asked and he gave no reply. I asked him for the third time, and he said: I asked Allah's Messenger (may peace be upon him) about that and he said: Make frequent prostrations before Allah, for you will not make one prostration without raising you a degree because of it, and removing a sin from you, because of it. Ma'dan said that then lie met Abu al-Darda' and when he asked him, he received a reply similar to that given by Thauban.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.990]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 990

Rabi'a b. Ka'b said: I was with Allah's Messenger (may peace be upon him) one night. and I brought him water and what he required. He said to me: Ask (anything you like). I said: I ask your company in Paradise. He (the Holy Prophet) said: Or anything else besides it. I said: That is all (what I require). He said: Then help me to achieve this for you by deyoting yourself often to prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.991]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 991

Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) had been commanded that he should prostrate on the seven (bones) and he was forbidden to fold back the hair and clothing. And in the narration transmitted by Abu Rabi' (the words are):" on the seven bones and I was forbidden to fold back the hair and clothing". According to Abu'l-Rabi' (the seven bones are): The hands, the knees, and the (extremities) of the feet and the forehead.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.992]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 992

Ibn 'Abbas reported from the Apostle of Allah (may peace be upon him): I was commanded to prostrate myself on seven bones and not to fold back clothing or hair.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.993]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 993

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) had been commanded to prostrate on seven (bones) and forbidden to fold back hair and clothing.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.994]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 994

Ibn Abbas reported that the Messenger of Allah (may peace be upon him) said: I have been commanded to prostrate myself on seven bones:" forehead," and then pointed with his hand towards his nose, hands, feet, and the extremities of the feet; and we were forbidden to fold back clothing and hair.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.995]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 995

Ibn Abbas reported: The Messenger of Allah (may peace be upon him) said: I was commanded to prostrate myself on the seven (bones) and forbidden to fold back hair and clothing. (The seven bones are): forehead, nose, bands, knees and feet.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.996]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 996

Abdullah b. Abbas reported that he saw 'Abdullah b. al-Harith observing the prayer and (his hair) was plaited behind his head. He ('Abdullah b. 'Abbas) stood up and unfolded them. While going back (from the prayer) he met Ibn 'Abbas and said to him: Why is it that you touched my head? He (Ibn 'Abbas) replied: (The man who observes prayer with plaited hair) is like one who prays with his hands tied behind.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.997]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 997

Anas reported: The Messenger of Allah (may peace be upon him) said: Observe moderation in prostration, and let none of you stretch out his forearms (on the ground) like a dog.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.998]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 998

This hadith has been narrated by Shu'ba with the same chain of transmitters. And in the hidith transmitted by Ibn Ja'far (the words are):" None of you should stretch out his forearms like the stretching out of a dog."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.999]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 999

Al-Bira' (b. 'Azib) reported: The Messenger of Allah (may peace be upon him) said. When you prostrate yourself, place the palms of your hands on the ground and raise your elbows.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1000]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1000

'Abdullah b. Malik ibn Bujainah reported: When the Prophet (may peace be upon him) prostrated, lie spread out his arms so that the whiteness of his armpits was visible.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1001]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1001

This hadith has been narrated by Ja'far b. Rabi' with the same chain of transmitters. And in the narration transmitted by 'Amr b. al-Harith (the words are):" When the Messenger of Allah (rtiay peace be upon him) prostrated, he spread out his arms so that the whiteness of his armpits was visible." And in the narration transmitted by al-Laith (the words are:" When the Messenger of Allah (may peace be upon him) prostrated. he spread his hands from the armpits so that I saw their whiteness."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1002]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1002

Maimuna reported: When the Apostle of Allah (may peace be upon him) prostrated himself, if a lamb wanted to pass between his arms, it could pass.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1003]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1003

Maimuna, the wife of the Apostle of Allah (may peace be upon him), reported: When the Messenger of Allah (may peace be upon him) prostrated himself, he spread his arms, i. e. he separated them so much that the whiteness of his armpits became visible from behind and when he sat (for Jalsa) he rested on his left thigh.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1004]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1004

Maimuna daughter of Harith reported: When the Messenger of Allah (may peace be upon him) prostrated, he kept his hands so much apart from each other that when it was seen from behind the armpits became visible. Waki' said: That is their whiteness.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1005]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1005

'A'isha reported: The Messenger of Allah (may peace be upon him) used to begin prayer with takbir (saying Allih-o-Akbar) and the recitation:" Praise be to Allah, the Lord of the Universe." When he bowed he neither kept his head up nor bent it down, but kept it between these extremes; when he raised his bead after bow- ing he did not prostrate himself till he had stood erect; when he raised his head after prostration he did not prostrate himself again till he satup. At the end of every two rak'ahs he recited the tahiyya; and he used to place his left foot flat (on the ground) and raise up the right; he prohibited the devil's way of sitting on the heels, and he forbade people to spread out their arms like a wild beast. And he used to finish the prayer with the taslim.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1006]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1006

Musa b. Talha reported it on the authority of his father: The Messenger of Allah (may peace be upon him) said: When one of you places in front of him so me. thing such as the back of a saddle, he should pray without caring who passes on the other side of it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1007]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1007

Musa b. Talha reported on the authority of his father: We used to say prayer and the animals moved in front of us. We mentioned it to the Messenger of Allah (may peace be upon him) and he said: If anything equal to the back of a saddle is in front of you, then what walks in front, no harm would come to him. Ibn Numair said: No harm would come whosoever walks in front.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1008]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1008

'A'isha reported: The Messenger of Allah (may peace be upon him) was asked about sutra of a worshipper; he said: Equal to the back of the saddle.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1009]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1009

'A'isha reported: The Messenger of Allah (may peace be upon him) was asked in the expedition of Tabuk about the sutra the worshipper; he said: Like the back of the saddle.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1010]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1010

Ibn Umar reported: When the Messenger of Allah (may peace he upon him) went out on the 'Id day, he ordered to carry a spear-and it was fixed in front of him, and he said prayer towards its (direction), and the people were behind him. And he did it in the journey, and that is the reason why the Amirs carried it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1011]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1011

Ibn Umar reported: The Apostle of Allah (may peace be upon him) set up (sutra), and Abu Bakr said: He implanted iron-tipped spear and said prayer towards its direction. Ibn Abu Shaiba made this addition to it:" Ubaidullah said that it was a spear."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1012]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1012

Ibn 'Umar said: The Apostle of Allah (may peace be upon him) used to place his camel (towards the Ka'ba) and said prayer in its direction.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1013]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1013

Ibn 'Umar reported: The Apostle of Allah (may peace be upon him) used to say prayer towards his camel. Ibn Numair said: The Apostle of Allah (may peace be upon him) said prayer towards the camel.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1014]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1014

Abu Juhaifa reported it on the authority of his father: I came to the Apostle of Allah (may peace be upon him) in Mecca and he was (at that time) at al- Abtah in a red leather tent. And Bilal stepped out with ablution water for him. (And what was left out of that water) some of them got it (whereas others could not get it) and (those who got it) rubbed themselves with it. Then the Apostle of Allah (may peace be upon him) stepped out with a red mantle on him and I was catching a glimpse of the whiteness of his shanks. The narrator said: He (the Holy Prophet) performed the ablution. and Bilal pronounced Adhan and I followed his mouth (as he turned) this side and that as he said on the right and the left:" Come to prayer, come to success." ' A spear was then fixed for him (on the ground). He stepped forward and said two rak'ahs of Zuhr, while there passed in front of him a donkey and a dog, and these were not checked. He then said two rak'ahs of the 'Asr prayer, and he then continued saying two rak'ahs till he came back to Medina.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1015]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1015

Abu Juhaifa reported on the authority of his father: I saw the Messenger of Allah (may peace be upon him) (in Mecca at al-Abtah) in a red leather tent. and I saw Bilal take the ablution water (left by Allah's Messenger), and I saw the people racing, with one another to get that ablution water. If anyone got some of it, he rubbed himself with it, and anyone who did not get any got some of the moisture from his companion's hand. I then saw Bilal take a staff and fix it in the ground, after which the Messenger of Allah (may peace be upon him) came out quickly in a red mantle and led the people in two rak'ahs facing the staff, and I saw people and animals passing in front of the staff.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1016]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1016

'Aun b. Abu Juhaifa narrated from the Apostle of Allah (may peace be upon him) on the authority of his father a hadith like that of Sufyan, and 'Umar b. Abu Za'ida made this addition: Some of them tried to excel the others (in obtaining water), and in the hadith transmitted by Malik b. Mighwal (the words are): When it was noon, Bilal came out and summoned (people) to (noon) prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1017]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1017

Abu Juhaifa reported: The Messenger of Allah (may peace be upon him) went at noon towards al-Batha', he performed ablution, and said two rak'ahs of the Zuhr prayer and two of the 'Asr prayer, and there was a spear in front of him. Shu'ba said and Aun made this addition to it on the authority of his father Abu Juhaifa: And the woman and the donkey passed behind it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1018]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1018

Shu'ba narrated the same on the basis of two authorities and in the hadith transmitted by Hakam (the words are): The people began to get water that was left out of his (the Prophet's) ablution.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1019]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1019

Ibn 'Abbas reported: I came riding on a she-ass, and I was on the threshold of maturity, and the Messenger of Allah (may peace be upon him) was leading people in prayer at Mina. I passed in front of the row and got down, and sent the she-ass for grazing and joined the row, and nobody made any objection to it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1020]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1020

Abdullah b. Abbas reported that he came riding on a donkey, and the Messenger of Allah (may peace be upon him) was leading the people in prayer at Mina on the occasion of the Farewell Pilgrimage and (the narrator) reported: The donkey passed in front of the row and then he got down from it And joined the row along with the people.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1021]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1021

This hadith has been narrated by Ibn 'Uyaina on the authority of al-Zuhri with the same chain of transmitters and he reported: The Apostle of Allah (may peace be upon him) was leading prayer at 'Arafa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1022]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1022

This hadith has been reported by Ma'mar on the authority of al-Zuhri with the came chain of transmitters, but here no mention has been made of Mina or 'Arafa, and he said: It was in the Farewell Pilgrimage or on the Day of Victory.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1023]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1023

Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) said: When any one of you prays he should not let anyone pass in front of him (if there is no sutra), and should try to turn him away as far as possible, but if he refuses to go, he should turn him away forcibly for he is a devil.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1024]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1024

Abu Salih al-Samman reported: I narrate to you what I heard and saw from Abu Sa'id al-Khudri: One day I was with Abu Sa'id and he was saying prayer on Friday turning to a thing which concealed him from the people when a young man from Banu Mu'ait came there and he tried to pass in front of him; he turned him back by striking his chest. He looked about but finding no other way to pass except in front of Abu Sa'id, made a second attempt. He (Abu Sa'id) turned him away by Striking his chest more vigorously than the first stroke. He stood up and had a scuffle with Abu Sa'id. Then the people gathered there He came out and went to Marwan and complained to him what had happened to him. Abu Sa'id too came to Marwan. Marwin said to him: What has happened to you and the son of your brother that he came to complain against you? Abu Sa'id said: I heard from the Messenger of Allah (may peace be upon him) saying: When any one of you prays facing something which conceals him from people and anyone tries to pass in front of him, he should be turned away, but if he refuses, he should be forcibly restrained from it, for he is a devil.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1025]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1025

'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) said: When any one of you prays, he should not allow anyone to pass before him, and if he refuses, he should be then forcibly resisted, for there is a devil with him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1026]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1026

This hadith has been narrated by Ibn Umar by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1027]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1027

Busr b Sa'id reported that Zaid b Khalid al-Juhani sent him to Abu Juhaim in order to ask him what he had heard from the Messenger of Allah (may peace be upon him) with regard to the passer in front of the worshipper. Abu Juhaim reported that the Messenger of Allah (may peace be upon him) said: If anyone who passes in front of a man who is praying knew the responsibility he incurs, he would stand still forty (years) rather than to pass in front of him Abu Nadr said: I do not know whether he said forty days or months or years.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1028]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1028

This hadith has been narrated from Abu Juhaim Ansari by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1029]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1029

Sahl b. Sa'd al-Si'idi reported: Between the place of worship where the Messenger of Allah (may peace be upon him) prayed and the wall, there was a gap through which a goat could pass.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1030]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1030

Salama b. Akwa' reported: He sought the place (in the mosque) where the copies of the Qur'an were kept and glorified Allah there, and the narrator made a mention that the Messenger of Allah (may peace be upon him) sought that place and that was between the pulpit and the qibla-a place where a goat could pass.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1031]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1031

Yazid reported: Salama sought to say prayer near the pillar which was by that place where copies of the Qur'an were kept. I said to him: Abu Muslim. I see you striving to offer your prayer by this pillar. He said: I saw the Messenger of Allah (may peace be upon him) seeking to pray by its side.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1032]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1032

Abu Dharr reported: The Messenger of 'Allah (may peace be upon him) said: When any one of you stands for prayer and there is a thing before him equal to the back of the saddle that covers him and in case there is not before him (a thing) equal to the back of the saddle, his prayer would be cut off by (passing of an) ass, woman, and black Dog. I said: O Abu Dharr, what feature is there in a black dog which distinguish it from the red dog and the yellow dog? He said: O, son of my brother, I asked the Messenger of Allah (may peace be upon him) as you are asking me, and he said: The black dog is a devil.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1033]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1033

This hadith has been transmitted by Humaid b. Hilal on the authority of Yunus.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1034]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1034

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: A woman, an ass and a dog disrupt the prayer, but something like the back of a saddle guards against that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1035]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1035

'A'isha reported: The Prophet (may peace be upon him) used to pray at night while I lay interposed between him and the Qibla like a corpse on the bier.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1036]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1036

'A'isha reported: The Apostle of Allah (may peace be upon him) said his whole prayer (Tahajjud prayer) during the night while I lay between him and the Qibla. When he intended to say Witr (prayer) he awakened me and I too said witr (prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1037]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1037

'Urwa b. Zubair reported: 'A'isha asked: What disrupts the prayer? We said: The woman and the ass. Upon this she remarked: Is the woman an ugly animal? I lay in front of the Messenger of Allah (may peace be upon him) like the bier of a corpse and he said prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1038]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1038

Masruq reported: It was mentioned before'A'isha that prayer is invalidated (in case of passing) of a dog, an ass and a woman (before the worshipper, when he is not screened). Upon this 'A'isha said: You likened us to the asses and the dogs. By Allah I saw the Messenger of Allah (may peace be upon him) saying prayer while I lay on the bedstead interposing between him and the Qibla. When I felt the need, I did not like to wit to front (of the Holy Prophet) and perturb the Messenger of Allah (may peace be upon him) and quietly moved out from under its (i. e. of the bedstead) legs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1039]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1039

Al-Aswad reported that 'A'isha said: You have made us equal to the dogs and the asses, whereas I lay on the bedstead and the Messenger of Allah (may peace be upon him) came there and stood in the middle of the bedstead and said prayer. I did not like to take off the quilt from me (in that state), so I moved away quietly from the front legs of the bedstead and thus came out of the quilt.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1040]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1040

'A'isha reported: I was sleeping in front of the Mcsseinger ef Allah (may peace be upon him) with my legs between him and the Qibla. When he prostrated himself he pinched me and I drew up my legs, and when be stood up, I stretched them out. She said: At that time there were no lamps in the houses.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1041]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1041

Maimuna, the wife of the Apostle (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) said prayer and I (lay) opposite to him while I was in menses. Sometimes his clothes touched me when he prostrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1042]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1042

'A'isha reported: The Apostle of Allah (may peace be upon him) said prayer at night and I was by his side in a state of meanses and I had a sheet pulled over me a portion of which was on his side.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1043]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1043

Abu Huraira reported: An inquirer asked the Messenger of Allah (may peace be upon him) about the prayer in a single garment. He (the Holy Prophet) add: Has everyone of you two garments?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1044]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1044

A hadith like this has been narrated by Abu Huraira with another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1045]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1045

Abu Huraira reported: A person addressed the Apostle of Allah (may peace be upon him) and said to him: Can any one of us say prayer in one garment? He said: Do all of you possess two garments?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1046]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1046

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: None of you must pray in a single garment of which no part comes over his shoulders.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1047]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1047

Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) praying in Umm Salama's house in a single garment, placing its two ends over his shoulders.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1048]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1048

This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters except (with this difference) that the word mutawashshihan was used and not the word mushtamilan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1049]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1049

'Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) saying prayer in the house of Umm Salama in a single garment with its extremities crossing each other.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1050]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1050

Umar b. Abu Salama reported: I saw the Messenger of Allah (may peace be upon him) praying in a single garment with its ends crossing each other. 'Isa b. Hammad added:" placing on his shoulders".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1051]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1051

Jabir reported: I saw the Messenger of Allah (may peace be upon him) praying in a single garment crossing the two ends.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1052]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1052

This hadith has been narrated by Sufyan with the same chain of transmitters and in the hadith transmitted by Numair the words are: I called upon the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1053]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1053

Abu Zubair reported that he saw Jabir b. 'Abdullah praying in a single garment crossing Its ends even though he had the garments, and Jabir said: He saw the Messenger of Allah (may peace be upon him) doing like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1054]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1054

Abu Sa'id al Khudri reported: I visited the Apostle (may peace be upon him) and saw him praying on a reed mat on which he was prostrating himself. And I saw him praying in a single garment with ends crossed with each other.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1055]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1055

This hadith has been narrated by A'mash with the came chain of transmitters, and in the narration of Abu Karaib the words are:" Placing its (mantle's) ends on his shoulders" ; and the narration transmitted by Abu Bakr and Suwaid (the words are):" the ends crossing with each other".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1056]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1056

Abu Dharr reported: I said: Messenger of Allah, which mosque was set up first on the earth? He said: Al-Masjid al-Haram (the sacred). I (again) said: Then which next? He said: It was the Masjid Aqsa. I (again) said: How long the space of time (between their setting up)? He (the Holy Prophet) said: It was forty years. And whenever the time comes for prayer, pray there, for that is a mosque; and in the hadith transmitted by Abu Kamil (the words are):" Whenever time comes for prayer, pray, for that is a mosque (for you)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1057]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1057

Ibrahim b. Yazid al-Tayml reported: I used to read the Qur'an with my father in the vestibule (before the door of the mosque). When I recited the ayat (verses) concerning prostration, he prostrated himself. I said to him: Father, do you prostrate yourself in the path? He said: I heard Abu Dharr saying: I asked the Messenger of Allah (may peace be upon him) about the mosque that was first set up on the earth. He said: Masjid Harim. I said: Then which next? He said: The Masjid al-Aqsa. I said: How long is the space of time between the two? He said: Forty years. He (then) further said: The earth is a mosque for you, so wherever you are at the time of prayer, pray there.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1058]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1058

Jabir b. 'Abdullah al-Ansari reported: The Prophet (may peace be upon him) said: I have been conferred upon five (things) which were not granted to anyone before me (and these are): Every apostle wassent particularly to his own people, whereas I have been sent to all the red and the black the spoils of war have been made lawful for me, and these were never made lawful to anyone before me, and the earth has been made sacred and pure and mosque for me, so whenever the time of prayer comes for any one of you he should pray whenever he is, and I have been supported by awe (by which the enemy is overwhelmed) from the distance (which one takes) one month to cover and I have been granted intercession.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1059]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1059

Jabir b. 'Abdullah related that the Messenger of Allah (may peace be upon him) said, and he related like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1060]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1060

Hudhaifa reported: The Messenger of Allah (may peace be npon him) said: We have been made to excel (other) people in three (things): Our rows have been made like the rows of the angels and the whole earth has been made a mosque for us, and its dust has been made a purifier for us in case water is not available. And he mentioned another characteristic too


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1061]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1061

Hudhaifa reported: The Messenger of Allah (may peace be upon him) said like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1062]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1062

Abu Huraira reported that the Messenger of Allah (may peace be upon hlmg) said: I have been given superiority over the other prophets in six respects: I have been given words which are concise but comprehensive in meaning; I have been helped by terror (in the hearts of enemies): spoils have been made lawful to me: the earth has been made for me clean and a place of worship; I have been sent to all mankind and the line of prophets is closed with me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1063]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1063

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: I have been commissioned with words which are concise but comprehensive in meaning; I have been helped by terror (in the hearts of enemies): and while I was asleep I was brought the keys of the treasures of the earth which were placed in my hand. And Abfi Huraira added: The Messenger of Allah (may peace be upon him) has left (for his heavenly home) and you are now busy in getting them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1064]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1064

Abu Huraira reported: I heard the Messenger of Allah (may peace be upon him) saying a hadith like that of Yunus.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1065]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1065

This hadith has been narratted by Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1066]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1066

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: I have been helped by terror (in the heart of the enemy) ; I have been given words which are concise but comprehensive in meaning; and while I was asleep I was brought the keys of the treasures of the earth which were placed in my hand.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1067]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1067

Hammam b. Munabbih reported: That is what Abu Huraira reported to us from the Messenger of Allah (may peace be upon him) and he narrated (some) ahadith one of which is that the Messenger of Allah (may peace be upon him) said: I have been helped by terror (in the hearts of enemies) and I have been given words which are concise but comprehensive in meaning.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1068]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1068

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) came to Medina and stayed in the upper part of Medina for fourteen nights with a tribe called Banu 'Amr b 'Auf. He then sent for the chiefs of Banu al-Najir, and they came with swords around their inecks. He (the narrator) said: I perceive as if I am seeing the Messenger of Allah (may peace be upon him) on his ride with Abu Bakr behind him and the chiefs of Banu al-Najjar around him till he alighted in the courtyard of Abu Ayyub. He (the narrator) said: The Messenger of Allah (may peace be upon him) said prayer when the time came for prayer, and he prayed in the fold of goats and sheep. He then ordered mosques to be built and sent for the chiefs of Banu al-Najjar, and they came (to him). He (the Holy Prophet) said to them: O Banu al-Najjar, sell these lands of yours to me. They said: No, by Allah. we would not demand their price, but (reward) from the Lord. Anas said: There (in these lands) were trees and graves of the polytheists, and ruins. The Messenger of Allah (may peace he upon him) ordered that the trees should be cut, and the graves should be dug out, and the ruins should be levelled. The trees (were thus) placed in rows towards the qibla and the stones were set on both sides of the door, and (while building the mosque) they (the Companions) sang rajaz verses along with the Messenger of Allah (may peace be upon him):

O Allah: there is no good but the good of the next world, So help the Ansar and the Muhajirin.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1069]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1069

Anas reported: The Messenger of Allah (may peace be upon him) used to pray in the folds of the sheep and goats before the mosque was built.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1070]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1070

Abu al-Tiyyah reported: I heard from Anas a narration like this from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1071]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1071

Al-Bara' b. 'Azib reported: I said prayer with the Apostle (may peace be upon him) turning towards Bait-ul-Maqdis for sixteen months till this verse of Surah Baqara wis revealed:" And wherever you are turn your faces towards it" (ii. 144). This verse was revealed when the Apostle (may peace be upon him) had said prayer. A person amongst his people passed by the people of Ansar as they were engaged in prayer. He narrated to them (this command of Allah) and they turned their faces towards the Ka'ba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1072]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1072

Abu Ishaq reported: I heard al-Bara' saying: We prayed with the Messenger of Allah (may peace be upon him) (with our faces) towards Bait-ul-Maqdis for sixteen months or seventeen months. Then we were made to change (our direction) towards the Ka'ba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1073]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1073

Ibn 'Umar reported: As the people were praying at Quba' a man came to them and said: It has been revealed to file Messenger of Allah (may peace be upon him) during the night and he has been directed to turn towards the Ka'ba. So turn towards it. Their faces were towards Syria and they turned round towards Ka'ba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1074]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1074

Ibn 'Umar reported: As the people were engaged in the morning prayer a man came to them. The rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1075]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1075

Anas reported: The Messenger of Allah (may peace be upon him) used to pray towards Bait-ul-Maqdis, that it was revealed (to him):" Indeed We see the turning of the face to heaven, wherefore We shall assuredly cause thee to turn towards Qibla which shall please thee. So turn thy face towards the sacred Mosque (Ka'ba)" (ii. 144). A person from Banu Salama was going; (he found the people) in ruk'u (while) praying the dawn prayer and they had said one rak'ah. He said in a loud voice: Listen! the Qibla has been changed and they turned towards (the new) Qibla (Ka'ba) in that very state.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1076]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1076

'A'isha reported: Umm Habiba and Umm Salama made a mention before the Messenger of Allah (may peace be upon him) of a church which they had seen in Abyssinia and which had pictures in it. The Messenger of Allah (may peace be upon him) said: When a pious person amongst them (among the religious groups) dies they build a place of worship on his grave, and then decorate it with such pictures. They would be the worst of creatures on the Day of judgment in the sight of Allah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1077]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1077

'A'isha reported: They (some Companions of the Holy Prophet) were conversing with one another in the presence of the Messenger of Allah (may peace be upon him) (during his last) illness. Umm Salama and Umm Habiba made a mention of the church and then (the hadith was) narrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1078]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1078

'A'isha reported: The wives of the Apostle of Allah (may peace be Upon him) made a mention of the church which they had seen in Abyssinia which was called Marya, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1079]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1079

'A'isha reported: The Messenger of Allah (may peace be upon him) said during his illness from which he never recovered: Allah cursed the Jews and the Christians that they took the graves of their prophets as mosques. She ('A'isha) reported: Had it not been so, his (Prophet's) grave would have been in an open place, but it could not be due to the fear that it may not be taken as a mosque.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1080]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1080

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Let Allah destroy the Jews for they have taken the graves of their apostles as places of worship.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1081]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1081

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Let there be curse of Allah upon the Jews and the Christians for they have taken the graves of their apostles as places of worship.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1082]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1082

'A'isha and Abdullah reported: As the Messenger of Allah (may peace be upon him) was about to breathe his last, he drew his sheet upon his face and when he felt uneasy, he uncovered his face and said in that very state: Let there be curse upon the Jews and the Christians that they have taken the graves of their apostles as places of worship. He in fact warned (his men) against what they (the Jews and the Christians) did.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1083]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1083

Jundub reported: I heard from the Apostle of Allah (may peace be upon him) five days before his death and he said: I stand acquitted before Allah that I took any one of you as friend, for Allah has taken me as His friend, as he took Ibrahim as His friend. Had I taken any one of my Ummah as a friend, I would have taken Abu Bakr as a friend. Beware of those who preceded you and used to take the graves of their prophets and righteous men as places of worship, but you must not take graves as mosques; I forbid you to do that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1084]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1084

Ubaidullah al-Khaulini reported: 'Uthman b. 'Affan listened to the opinion of the people (which was not favourable) when he rebuilt the mosque of the Messenger of Allah (may peace be upon him). Thereupon he said: You have not been fair to me for I have heard from the Messenger of Allah (may peace be upon him) saying: He who built a mosque for Allah, the Exalted, Allah would build for him a house in Paradise. Bukair said: I think he (the Holy Prophet) said: While he seeks the pleasure of Allah (by building the mosque). And in the narration of Ibn 'Isa (the words are):" (a house) like that (mosque) in Paradise."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1085]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1085

Mahmud b. Labid reported: When 'Uthman b. 'Affan intended to build the mosque (of the Prophet) the people did not approve of it. They liked that it should be kept in the same state. Thereupon he said: I heard the Messtnger of Allah (may peace be upon him) say: He who built a mosque for Allah, Allah would build a house for him like it in Paradise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1086]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1086

Al-Aswad and 'Alqama reported: We came to the house of 'Abdullah b. Mas'ud. He said: Have these people said prayer behind you? We said: No. He said: Then stand up and say prayer. He neither ordered us to say Adhan nor Iqama. We went to stand behind him. He caught hold of our hands and mode one of us stand on his right hand and the other on his left side. When we bowed, we placed our hands on our knees. He struck our hands and put his hands together, palm to palm, then put them between his thighs. When he completed the prayer he said. There would soon come your Amirs, who would defer prayers from their appointed time and would make such delay that a little time is left before sunset. So when you see them doing so, say prayer at its appointed time and then say prayer along with them as (Nafl), and when you are three, pray together (standing in one row), and when you are more than three, appoint one amongst you as your Imam. And when any one of you bows he must place his hands upon hie thighs and kneel down. and putting his palms together place (them within his thighs). I perceive as if I am seeing the gap between the fingers of the Messenger of Allah (may peace he upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1087]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1087

This hadith is narrated on the authority of Alqama and Aswad by another chain of transmitters and in the hadith transmitted by Ibn Mus-hir and Jabir the words are:" I perceive as if I am seeing the gap between the fingers of the Messenger of Allah (may peace be upon him) as he was bowing."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1088]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1088

'Alqama and Aswad reported that they went to 'Abdullah. He said: Have (people) behind you said prayer? They said: Yes. He stood between them ('Alqama and Aswad). One was on his right aide and the other was on his left. We then bowed and placed our hands on our knees. He struck our hands and then putting his hands together, palm to palm, placed them between his thighs. When he completed the prayer he said: This is how the Messenger of Allah (may peace be upon him) used to do.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1089]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1089

Mus'ab b. Sa'd reported: I said prayer by the side of my father and placed my hands between my knees. My father said to me: Place your hands on your knees. I repeated that (the previous act) for the second time, and he struck at my hands and said: We have been forbidden to do so and have been commanded to place our palms on the knees.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1090]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1090

This hadith has been narrated by Abu Ya'fur with the same chain of transmitters up to these words: We have been forbidden from it and no mention of that has been made what follows it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1091]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1091

Ibn Sa'd reported: I bowed and my hands were in this state, i. e. they were put together, palm to palm, and were placed between his thighs. My father said: We used to do like this but were later on commanded to place them on the knees.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1092]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1092

Mus'ab b. Sa'd b. Abu Waqqas reported: I said prayer by the side of my father. When I bowed I intertwined my fingers and placed them between my knees. He struck my hands. When he completed the prayer he said: We used to do that but then were commanded to lift (our palms) to the knees.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1093]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1093

Tawus reported: We asked Ibn Abbas about sitting on one's buttocks (in prayer). (ala alqad mein) He said: It is sunnah. We said to him: We find it a sort of cruelty to the foot. Ibn 'Abbas said: It is the sunnah of your Apostle (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1094]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1094

Mu'awiya b. al-Hakam said: While I was praying with the Messenger of Allah (may peace be upon him), a man in the company sneezed. I said: Allah have mercy on you! The people stared at me with disapproving looks, so I said: Woe be upon me, why is it that you stare at me? They began to strike their hands on their thighs, and when I saw them urging me to observe silence (I became angry) but I said nothing. When the Messenger of Allah (may peace be upon him) had said the prayer (and I declare that neither before him nor after him have I seen a leader who gave better instruction than he for whom I would give my father and mother as ransom). I swear that he did not scold, beat or revile me but said: Talking to persons is not fitting during the prayer, for it consists of glorifying Allah, declaring his Greatness. and recitation of the Qur'an or words to that effect. I said: Messenger of Allah. I was till recently a pagan, but Allah has brought Islam to us; among us there are men who have recourse to Kahins. He said, Do not have recourse to them. I said. There are men who take omens. That is something which they find in their breasts, but let it not turn their way (from freedom of action). I said: Among us there are men who draw lines. He said: There was a prophet who drew lines, so if they do it as they did, that is allowable. I had a maid-servant who tended goats by the side of Uhud and Jawwaniya. One day I happened to pass that way and found that a wolf had carried a goat from her flock. I am after all a man from the posterity of Adam. I felt sorry as they (human beings) feel sorry. So I slapped her. I came to the Messenger of Allah (may peace be upon him) and felt (this act of mine) as something grievous I said: Messenger of Allah, should I not grant her freedom? He (the Holy Prophet) said: Bring her to me. So I brought her to him. He said to her: Where is Allah? She said: He is in the heaven. He said: Who am I? She said: Thou art the Messenger of Allah. He said: Grant her freedom, she is a believing woman.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1095]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1095

This hadith has been narrated by Yahya b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1096]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1096

Abdullah (b. Masu'd) reported: We used to greet the Messenger of Allah (may peace be upon him) while he was engaged in prayer and he would respond to our greeting. But when we returned from the Negus we greeted him and he did not respond to us; so we said: Messenger of Allah. we used to greet you when you were engaged in prayer and you would respond to us. He replied: Prayer demands whole attention.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1097]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1097

This hadith has been reported by A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1098]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1098

Zaid b. Arqam reported: We used to talk while engaged in prayer and a person talked with a companion on his side in prayer till (this verse) was revealed:" And stand before Allah in devout obedience" (ii, 238) and we were commanded to observe silence (in prayer) and were forbidden to speak.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1099]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1099

A hadith like this has been transmitted by Isma'il b. Abu Khalid.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1100]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1100

Jabir reported: The Messenger of Allah (may peace be upon him) sent me on an errand. I (having done the business assigned to me came back and) joined him as he was going (on a ride). Qutaiba said that he was saying prayer while he rode. I greeted him. He gestured to me. When he completed the prayer. he called me and said: You greeted me just now while I was engaged in prayer. (Qutaiba said): His (Prophet's face) was towards the east, as he was praying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1101]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1101

Jabir reported: The Messenger of Allah (may peace be upon him) sent me (on an errand) while he was going to Banu Mustaliq. I came to him and he was engaged in prayer on the back of his camel. I talked to him and he gestured to me With his hand, and Zuhair gestured with his hand. I then again talked and he again (gestured to me with his hand). Zuhair pointed with his hand towards the ground. I heard him (the Holy Prophet) reciting the Qur'an and making a sign with his head. When he com- pleted the prayer he sa'id: What have you done (with regard to that business) for which I sent you? I could not talk with you but for the fact that I was engaged in prayer. Zuhair told that Abu Zubair was sitting with his face turned towards Qibla (as he transmitted this hadith). Abu Zuhair pointed towards Banu Mustaliq with his hand and the direction to which he pointed with his hand was not towards the Ka'ba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1102]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1102

Jabir reported: We were in the company of the Messenger of Allah (may peace be upon him), and he sent me on an errand, and when I came back (I saw him) saying prayer on his ride and his face was not turned towards Qibla. I greeted him but he did not respond to me. As he completed the prayer, he said: Nothing prevented me from responding to your greeting but the fact that I was praying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1103]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1103

This hadith that the Messenger of Allah (may peace be upon him) sent Jabir on an errand has been reported by him through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1104]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1104

Abu Huraira reported that he heard the Messenger of Allah (may peace be upon him) saying: A highly wicked one amongst the Jinn escaped yesternight to interrupt my prayer, but Allah gave me power over him, so I seized him and intended to tie him to one of the pillars of the mosque in order that you, all together or all, might look at him, but I remembered the supplication of my brother Sulaiman:" My Lord, forgive me, give me such a kingdom as will not be possible for anyone after me" (Qur'an, xxxvii. 35).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1105]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1105

This hadith has been transmitted by Ibn Abi Shaiba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1106]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1106

Abu Darda' reported: Allah's Messenger (may peace be upon him) stood up (to pray) and we heard him say:" I seek refuge in Allah from thee." Then said:" curse thee with Allah's curse" three times, then he stretched out his hand as though he was taking hold of something. When he finished the prayer, we said: Messenger of Allah, we heard you say something during the prayer which we have not heard you say before, and we saw you stretch out your hand. He replied: Allah's enemy Iblis came with a flame of fire to put it in my face, so I said three times:" I Seek refuge in Allah from thee." Then I said three times:" I curse thee with Allah's full curse." But he did not retreat (on any one of these) three occasions. Thereafter I meant to seize him. I swear by Allah that had it not been for the supplication of my brother Sulaiman he would have been bound, and made an object of sport for the children of Medina.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1107]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1107

Abu Qatadi reported: I saw the Messenger of Allah (may peace be upon him) saying the prayer while he was carrying Umama, daughter of Zainab, daughter of the Messenger of Allah (may peace be upon him). and Abu'l-'As b. al-Rabi'. When he stood up, he took her up and when he prostrated he put her down, Yahya said: Malik replied in the affirmative.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1108]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1108

Abu Qatada al-Ansari reported: I saw the Apostle (may peace be upon him) leading the people in prayer with Umima, daughter of Abu'l-'As and Zainab, daughter of the Apostle of Allah (may peace be upon him), on his shoulder. When he bowed, he put her down, and when he got up after prostration, he lifted her again.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1109]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1109

Abu Qatada reported: I saw the Messenger of Allah (may peace be upon him) leading the people in prayer with Umama daughter of Abu'l-'As on his neck; and when he prostrated he put her down.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1110]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1110

Abu Qatada reported: As we were sitting in the mosque, the Messenger of Allah (may peace be upon him) came to us, and the rest of the hadith is the same except that he made no mention that he led people in this prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1111]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1111

Abu Hazim is reported on the authority of his father: Some people came to Sahl b. Sa'd and began to differ about the wood of which the (Prophet's pulpit was made. He (Sahl b. Sa'd) said: By Allah, I know of which wood it is made and who made it, and the day when I saw the Messenger of Allah (may peace be upon him) seated himself on it on the first day. I said to him: O Abu Abbas (kunyah of Sabl b. Sa'd), narrate to us (all these facts), He said: The Messenger of Allah (may peace be upon him) sent a person to a woman asking her to allow her slave, a carpenter, to work on woods (to prepare a pulpit) so that I should talk to the people (sitting on it). Abu Hazim said: He (Sahl b. Sa'd) pointed out the name of (that lady) that day. So he (the carpenter) made (a pulpit) with these three steps. Then the Messengerof Allah (may peace be upon him) commanded it to be placed here (where it is lying now). It was fashioned out of the wood of al-Ghaba. And I saw the Messenger of Allah (may peace he upon him) standing upon it and glorifying Allah and the people also glorified Allah after him, while he was on the pulpit. He then raised (his head from prostration) and stepped back (on his heels) till he prostrated himself at the base of pulpit, and then returned (to the former place and this movement of one or two steps continued) till the prayer was complete. He then turned towards the people and said: O people, I have done it so that you should follow me and learn (my mode of) prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1112]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1112

Abu Hazim reported: They (the people) came to Sahl b. Sa'd and they asked him of what thing the pulpit of the Apostle of Allah (may peace be upon him) was made, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1113]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1113

Abu Huraira reported from the Apostle of Allah (may peace be upon him) that he forbade keeping one's hand on one's waist while praying, and in the narration of Abu Bakr (the words are): The Messenger of Allah (may peace be upon him) forbade to do so.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1114]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1114

Mu'aiqib quoted the Apostle of Allah (may peace be upon him) mentioning the removal of pebbles from the ground where he prostrated himself. He (the Prophet) said: It you must do so, do it only once.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1115]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1115

Mu'aiqib said: They asked the Apostle (may peace be upon him) about the removal of (pebbles) in prayer, whereupon he said: If you do it, do it only once.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1116]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1116

Abdullah b. Umar reported: The Messenger of Allah (may peace be upon him) saw spittle on the wall towards Qibla, and scratched it away and then turning to the people said: When any one of you prays, he must not spit in front of him, for Allah is in front of him when he is engaged in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1117]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1117

Ibn Umar reported that the Messenger of Allah (may peace be upon him) saw sputum sticking to the Qibla wall of the mosque, the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1118]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1118

Abu Sa'id al-Khudri reported: The Apostle of Allah (may peace be upon him) saw sputum sticking to the Qibla of the mosque. He scratched it off with a pebble and then forbade spitting on the right side or in front, but (it is permissible) to spit on the left side or under the left foot.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1119]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1119

Abu Huraira and Abu Sa'id narrated that the Messenger of Allah (may peace be upon him) saw sputum, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1120]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1120

'A'isha reported: The Apostle of Allah (may, peace be upon him) saw spittle or snot or sputum, sticking to the wall towards Qibla and scratched it off.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1121]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1121

Abu Huraira reported that the Messenger of Allah (may peace be upon him) saw some sputum in the direction of the Qibla of the mosque. He turned towards people and said: How Is it that someone amongst you stands before his Lord and then spits out in front of Him? Does any one of you like that he should be made to stand in front of someone and then spit at his face? So when any one of you spits, he must spit on his left side under his foot. But if he does not find (space to spit) he should do like this. Qasim (one of the narrators) spat in his cloth and then folded it and rubbed it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1122]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1122

Abu Huraira reported: I perceive as if I am looking at the Messenger of Allah (may peace be upon him) folding up a part of his cloth with another one.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1123]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1123

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: When any one of you is engaged in prayer, he is holding intimate conversation with his Lord, so none of you must spit in front of him, or towards his right side, but towards his left side under his foot.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1124]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1124

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: Spitting in a mosque is a sin, and its expiation is that it should be buried.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1125]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1125

Shu'ba reported: I asked Qatada about spitting, in the mosque. He said: I heard Anas b. Malik say: I heard the Messenger of Allah (may peace be upon him) say: Spitting in the mosque is a sin, and its expiation is that it should be buried.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1126]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1126

Abu Dharr reported: The Apostle of Allah (may peace be upon him) said: The deeds of my people, good and bad, were presented before me, and I found the removal of something objectionable from the road among their good deeds, and the sputum mucus left unburied in the mosque among their evil deeds.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1127]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1127

Abdullah b. Shakhkhir reported on the authority of his father that he said: I said prayer with the Messenger of Allah (may peace be upon him) and saw him spitting and rubbing it off with his shoe.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1128]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1128

'Abdullah b. Shakhkhir narrated it on the authority of his father that he said prayer with the Messenger of Allah (may peace be upon him), and he spat and then rubbed it off with his left shoe.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1129]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1129

Sa'd b. Yazid reported: I said to Anas b. Malik: Did the Messenger of Allah (may peace be upon him) pray while putting on the shoes? He said: Yes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1130]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1130

Sa'd b. Yazid Abu Mas'ama reported: I said to Anas like (that mentioned above).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1131]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1131

'A'isha reported: The Apostle of Allah (may peace be upon him) prayed in a garment which had designs over it, so he (the Holy Prophet) said: Take it to Abu Jahm and bring me a plain blanket from him, because its designs have distracted me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1132]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1132

'A'isha reported: The Messenger of Allah (may peace be upon him) stood for prayer with a garment which had designs over it. He looked at these designs and after completing the prayer said: Take this garment to Abu Jahm b. Hudhaifa and bring me a blanket for it has distracted me just now.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1133]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1133

'A'isha reported: The Apostle of Allah (way peace be upon him) had a garment which had designs upon it and this distracted him in prayer. He gave it to Abu Jahm and took a plain garment in its place which is known anbijaniya.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1134]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1134

Anas b. Malik reported the Apostle of Allah (may peace be upon him) saying: When the supper is brought and the prayer begins, one, should first take food.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1135]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1135

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) said: When the supper is brought before you, and it is also the time to say prayer, first take food before saying evening prayer and do not hasten (to prayer, leaving aside the food).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1136]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1136

This hadith has been narrated on the authority of Anas by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1137]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1137

Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said: When the supper is served to any one of you and the prayer also begins. (in such a case) first take supper, and do not make haste (for prayer) till you have (taken the food).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1138]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1138

A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) on the authority of Ibn 'Umar with another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1139]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1139

Ibn Atiq reported: Al-Qasim was in the presence of 'A'isha (Allah be pleased with her) that I narrated a hadith and Qasim was a man who committed errors in (pronouncing words) and his mother was a freed slave-girl. 'A'isha said to him: What is the matter with you that you do not narrate as this son of my brother narrated (the ahaditb)? Well I know from where you picked it up. This is how his mother brought him up and how your mother brought you up. Qasim felt angry (on this remark of Hadrat 'A'isha) and showed bitterness towards her. When he saw that the table had been spread for 'A'isha, he stood up, 'A'isha, said: Where are you going? He said: (I am going) to say prayer. She said: Sit down (to take the food). He said: I must say prayer. She said: Sit down, ) faithless, for I have heard the Messenger of Allah (may peace be upon him) say: No prayer can be (rightly said) when the food is there (before the worshipper), or when he is prompted by the call of nature.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1140]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1140

'Abdullah b. 'Atiq narrated from the Apostle (may peace be upon him) on the authority of 'A'isha, but he made no mention of the account of Qasim.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1141]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1141

Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said during the battle of Khaybar: He who ate of this plant, i. e. garlic, should not come to the mosques. In the narration of Zubair, there is only a mention of" battle" and not of Khaybar.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1142]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1142

Ibn 'Umar reported: The Messenuer of Allah (may peace be upon him) said: He who eats of this (offensive) plant must not approach our mosque, till its odour dies: (plant signifies) garlic.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1143]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1143

Ibn Suhaib reported: Anas was asked about the garlic; he stated that the Messenger of Allah (may peace be upon him) had said: He who eats of this plant (garlic) should not approach us and pray along with us.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1144]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1144

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who eats of this plant (garlic) should not approach our mosque and should not harm us with the odour of garlic.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1145]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1145

Jabir reported: The Messenger of Allah (may peace be upon him) forbade eating of onions and leek. When we were overpowered by a desire (to eat) we ate them. Upon this he (the Holy Prophet) said: He who eats of this offensive plant must not approach our mosque, for the angels are harmed by the same things as men.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1146]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1146

Jabir reported: The Messenger of Allah (may peace be upon him) said: He who eats garlic or onion should remain away from us or from our mosque and stay in his house. A kettle was brought to him which had (cooked) vegetables in it, He smelt (offensive) odour in it. On asking he was informed of the vegetables (cooked in it). He said: Take it to such and such Companion. When he saw it, he also disliked eating it. (Upon this). he (the Holy Prophet) said: You may eat it, for I converse wkh one with whom you do not converse.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1147]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1147

Jabir b. 'Abdullah reported the Apostle of Allah (may peace be upon him) mying: He who eats of this (offensive) plant, i. e garlic, and sometirres he said: He who eats onion and garlic and leek, should not approach our mosque for the angels are harmed by the same things as the children of Adam.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1148]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1148

Ibn Juraij has narrated it with the same chain of transmitters: He who eats of this plant, i. e. garlic, should not come to us in our mosque, and he made no mention of onions or leek.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1149]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1149

Abu Sa'id reported: We made no transgression but Khaybar was conquered. We, the Companions of the Messenger of Allah (may peace be upon him), fell upon this plant. i e. garlic. because the people were hungry. We ate it to our heart's content and then made our way towards the mosque. The Messenger of Allah (may peace be upon him) sensed its odour and he said: He who takes anything of this offensive plant must not approach us in the mosque. The people said: Its (use) has been forbidden; its (use) bu been forbidden. This reached the Apostle of Allah (may peace be upon him) and he said: O people, I cannot forbid (the use of a thing) which Allah has made lawful, but (this garlic) is a plant the odour of which is repugnant to me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1150]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1150

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) along with his Companions happened to pass by a field in which onions were sown. The people stopped there and ate out of that, but some of them did not eat. Then they (Propbet's Companions) went to him. He (first) called those who had not eaten the onions and kept the others (who had taken onions) waiting till its odour vanished.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1151]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1151

Ma'dan b. Talha reported: 'Umar b. Khattab, delivered the Friday sermon and he made a mention of the Apostle of Allah (may peace be upon him) and Abu Bakr. He (further) said: I saw in a dream that a cock pecked me twice, and I perceive that my death is near. Some people have suggested me to appoint my successor. And Allah would not destroy His religion. His caliphate and that with which He sent His Apostle (may peace be upon him) If death approaches me soon, the (issue) of Caliphate (would be decided) by the consent of these six men with whom the Messenger of Allah (may peace be upon him) remained well pleased till his death. And I know fully well that some people would blame me that I killed with these very hands of mine some persons who apparently professed (Islam). And if they do this (blame me) they are the enemies of Allah, and are non-believers and have gone astray. And I leave not after me anything which to my mind seems more important than Kalala. And I never turned towards the Messenger of Allah (may peace be upon him) (for guidance) more often than this Kalala, and he (the Holy Prophet) was not annoyed with me on any other (issue) than this: (And he was so perturbed) that he struck his fingers on my chest and said: Does this verse. that is at the end of Surat al-Nisa'. which was revealed in the hot season not suffice you? And if I live longer I would decide this (problem so clearly) that one who reads the Qur'an, or one who does not read it, would be able to take (correct), decisions (under its light). He ('Umar) further said: Allah! I call You witness on these governors of lands, that I sent them to (the peoples of these lands) so that they should administer justice amongst them, teach them their religion and the Sunnah of the Apostle of Allah (may peace be upon him), and distribute amongst them the spoils of war and refer to me that which they find difficult to perform. O people. you eat 'these two plants and these are onions and garlic. and I find them nothing but repugnant for I saw that when the Messenger of Allah (may peace be upon him) sensed the odour of these two from a person in a mosque, he was made to go to al-Baqi'. So he who eats it should (make its odour) die by cooking it well.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1152]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1152

This hadith has been narrated by Qatada with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1153]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1153

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: If anyone bears a man crying out in the mosque about something lie has lost, he should say: May Allah not restore it to you, for the mosques were not built for this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1154]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1154

Abu Huraira reported Allah's Messenger (may peace be upon him) saying like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1155]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1155

Sulaiman b. Buraida narrated it on the authority of his father that a man cried out in the mosque saying: Who had called out for the red camel? Upon this the Apostle of Allah (may peace be upon him) said: May it not be restored to you! The mosques are built for what they are meant.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1156]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1156

Sulaiman b. Buraida reported on the authority of his father that when the Apostle of Allah (may peace be upon him) had said prayer a man stood up and said: Who called for a red camel? (Upon this) the Apostle of Allah (may peace be upon him) said: May it not be restored to you! The mosques are built for what they are meant.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1157]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1157

Ibn Buraida narrated it on the authority of his father that a Bedouin came when the Apostle of Allah (may peace be upon him) had completed the morning prayer. He thrust his head in the door of the mosque, and then the hadith (as narrated above) was narrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1158]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1158

This hadith has been reported by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1159]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1159

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you stands up to pray. the devil comes to him and confuses him to that he does not know how much he has prayed. If any one of you h" such an experience he should perform two prostrations while sitting down (in qa'da).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1160]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1160

This hadith has been narrated by al-Zubri with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1161]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1161

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When there is a call to prayer the devil runs back breaking the wind so that he may not hear the call, and when the call is complete he comes back. And when the takbir is pronounced he again runs back, and when takbir is over he comes back and distracts a man saying: Remember such and such, remember such and such, referring to something the man did not have in his mind. with the result that he does not know how much he has prayed; so when any one of you is not sure how much he has prayed. he should perform two prostrations while sitting (qa'da).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1162]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1162

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The devil takes to his heels breaking wind when the prayer begins. and the rest is the same but with this addition:" He (the devil) makes him think of pleasant things (or things productive of enjoyment) and of the things wished for, and reminds him of such needs which he had forgotten."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1163]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1163

'Abdullah b. Buhaina reported: The Messenger of Allah (may peace be upon him) led us two rak'ahs of prayer in one of the (obligatory) prayers and then got up and did not sit. and the people stood up along with him. When he finished the prayer and we expected him to pronounce salutation. he said:" Allah is Most Great" while sitting and made two prostrations before salutation and then pronounced (the, final) salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1164]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1164

'Abdullah b. Buhaina al-Asadi, the ally of Abual-Muttalib, reported: The Messenger of Allah (may peace be upon him) stood up in the noon prayer (though) he hadith sit (after the two rak'ahs). When he completed the prayer he performed two prostrations and said," Allah is the Most Great" in each prostration, while he was sitting before pronouncing salutation, and the people performed prostration along with him. That was a compensation for he had forgotten to observe jalsa (after two rak'ahs).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1165]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1165

'Abdullah b. Malik ibn Buhaina al-Asadi reported: The Messenger of Allah (may peace be upon him) stood up (at the end of two rak'ahs) when he had to sit and proceeded on with the prayer. But when he was at the end of the prayer, he performed a prostration before the salutation and then pronounced the salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1166]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1166

Abu Sa'id al-Khudri reported: The Messenger of Allah (may peace be upon him) said: When any one of you is in doubt about his prayer and he does Dot know how much he has prayed, three or four (rak'ahs). he should cast aside his doubt and base his prayer on what he is sure of. then perform two prostrations before giving salutations. If he has prayed five rak'ahs, they will make his prayer an even number for him, and if he has prayed exactly four, they will be humiliation for the devil.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1167]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1167

This hadith has been narrated by Zaid b. Aslam with the same chain of transmitters and he said: He should perform two prostrations before the salutation, as it was mentioned by Sulaiman b. Bilal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1168]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1168

'Alqama narrated It on the authority of 'Abdullah (b. Mas'ud) who said: The Messenger of Allah (may peace be upon him) said the prayer; (the narrator added): He made some act of omission or commission when he pronounced salutation; it was said to him: Messenger of Allah, is there something new about (he prayer? He (the Holy Prophet) said: What is it? They said: You said prayer in such and such away. He (the narrator) said: He (the Holy Prophet) turned his feet and faced the Qibla and performed two prostrations and then pronounced salutations, and then turned his face towards us and said: If there is anything new about prayer (new command from the Lord) I informed you of that. But I am a human being and I forget as you for. get, so when I forget, remind me, and when any one of you is in doubt about his prayer. he should aim at what Is correct. and complete his prayer in that respect and then make two prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1169]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1169

This hadith has been narrated by Mansur with the same chain of transmitters, with a slight modification of words.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1170]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1170

This hadith is reported by Mansur with the same chain of transmitters, but with these words:" He should aim at correct (prayer) and it is advisable."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1171]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1171

This hadith has been narrated by Mansur with the same chain of transmitters with the words: I, He should aim at what is correct and complete."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1172]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1172

This hadith has been narrated by Mansur with the same chain of transmitters and said:" He should aim at correctness and that is right."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1173]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1173

This hadith has been reported by Mansur with the same chain of transwitters and he said:" He should aim at what is according to him correct."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1174]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1174

This hadith has been narrated by Mansur and he said:" He should aim at correctness."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1175]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1175

'Abdullah (b. Mas'ud) reported: The Apostle of Allah (may peace be upon him) said five rak'ahs of the noon prayer and when he completed the prayer, It was said to him: Has there been (commanded) an addition In prayer? He said: What is it? They said: You have said five rak'ahs, so he performed two prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1176]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1176

Alqama reported: He (the Holy Prophet) had led them five rak'ahs in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1177]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1177

Ibrahim b. Suwaid-reported: 'Alqama led us in the noon prayer and be offered five rak'ahs; when the prayer was complete, the people said to him: Abu Shibl, you have offered five rak'ahs. He said: No, I have not done that. They said: Yes (you said five rak'ahs). He (the narrator) said: And I was sitting in a corner among people and I was just a boy. I (also) said: Yes, you have offered five (rak'ahs). He said to me: O, one-eyed, do you say the same thing? I said: Yes. Upon this he turned (his face) and performed two prostrations and then gave salutations, and then reported 'Abdullah as saying: The Messenger of Allah (may peace be upon him) led us in prayer and offered five rak'ahs. And as he turned away the people began to whisper amongst themselves. He (the Holy Prophet) said: What is the matter with you? They said: Has the prayer been extended? He said: No. They said: You have in fact said five rak'ahs. He (the Holy Prophet) then turned his back (and faced the Qibla) and performed two prostrations and then gave salutations and further said: Verily I am a human being like you, I forget just as you forget. Ibn Numair made this addition:" When any one of you forgets, he must perform two prostrations."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1178]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1178

'Abdullah (b. Mas'ud) reported: The Messenger of Allah (may peace be upon him) led us five (rak'ahs in prayer). We said: Messenger of Allah, has the prayer been extended? He said: What is the matter? They said: You have said five (rak'ahs). He (the Holy Prophet) said: Verily I am a human being like you. I remember as you remember and I forget just as you forget. He then performed two prostrations as (compensation of) forgetfulness.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1179]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1179

'Abdullah (b. Mas'ud) reported: The Messenger of Allah (may peace be upon him) said prayer and he omitted or committed (something). Ibrahim (one of the narrators of this hadith) said: It is my doubt, and it was said: Messenger of Allah, has there been any addition to the prayer? He (the Holy Prophet) said: Verily I am a human being like you. I forget just as you forget so when any one of you forgets, he must perform two prostrations, and he (the Holy Prophet) was sitting and then the Messenger of Allah (may peace be upon him) turned (his face towards the Qibla) and performed two prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1180]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1180

'Abdullah b. Mas'ud reported: The Apostle of Allah (may peace be upon him) performed two prostrations for forgetfulness after salutation and talking.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1181]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1181

Abdullah reported: We prayed along with the Messenger of Allah (may peace he upon him) and he committed or omitted (something). Ibrahim said: By Allah, this is a misgiving of mine only. We said: Messenger of Allah, is there something new about the prayer? He (the Holy Prophet) said: No. We told him about what he had done. He (the Holy Prophet) said: When a man commits or omits (something in prayer), he should perform two prostrations, and he then himself performed two prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1182]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1182

Ibn Sirin reported Abu Huraira as saying: The Messenger of Allah (may peace be upon him) led us in one of the two evening prayers, Zuhr or 'Asr, and gave salutations after two rak'ahs and going towards a piece of wood which was placed to the direction of the Qibla in the mosque, leaned on it looking as if he were angry. Abu Bakr and Umar were among the people and they were too afraid to speak to him and the people came out in haste (saying): The prayer has been shortened. But among them was a man called Dhu'I-Yadain who said: Messenger of Allah, has the prayer been shortened or have you forgotten? The Apostle of Allah (may peace be upon him) looked to the right and left and said: What was Dhu'I-Yadain saying? They said: He is right. You (the Holy Prophet) offered but two rak'ahs. lie offered two (more) rak'ahs and gave salutation, then said takbir and prostrated and lifted (his head) and then said takbir and prostrated, then said takbir and lifted (his head). He (the narrator) says: It has been reported to me by Imran b. Husain that he said: He (their) gave salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1183]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1183

Abu Huraira reported: The Messenger of Allah (may peace be upon him) led us in one of the evening prayers. And this hadith was narrated like one transmitted by Sufyan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1184]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1184

Abu Huraira reported: The Messenger of Allah (may peace be upon him) led us in the 'Asr prayer and gave salutation after two rak'ahs. Dhu'l-Yadain (the possessor of long arms) stood up and said: Messenger of Allah, has the prayer been shortened or have you forgotten? The Messenger of Allah (may peace be upon him) said: Nothing like this has happened (neither the prayer has been shortened nor have I forgotten). He (Dhu'l-Yadain) said: Messenger of Allah, something has definitely happened. The Messenger of Allah (may peace be upon him) turned towards people and said: Is Dhu'l-Yadain true (in his assertion)? They said: Messenger of Allah, he is true. Then the Messenger of Allah (may peace be upon him) completed the rest of the prayer. and then performed two prostrations while he was sitting after salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1185]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1185

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said two rak'ahs of the noon prayer and then gave salutation when a man from Band Sulaim came to him and said: Messenger of Allah. has the prayer been shortened, or have you forgotten? -and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1186]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1186

Abu Huraira reported: I offered with the Apostle of Allah (may peace be upon him) the noon prayer and the Messenger of Allah (may peace be upon him) gave salutation after two rak'ahs. A person from Bani Sulaim stood up, and the rest of the hadith was narrated as mentioned above.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1187]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1187

'Imran b. Husain reported: The Messenger of Allah (may peace be upon him) said the afternoon prayer and gave the salutation. at the end of three rak'ahs and then went into his house. A man called al-Khirbaq, who bad long aims, got up and went to him, and addressed him as Messenger of Allah and mentioned to him what he had done. He came out angrily trailing his mantle, and when he came to the people he said: Is this man telling the truth? They said: Yes. He then said one rak'ah and then gave salutation and then performed two prostrations and then gave salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1188]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1188

Imran b. Husain reported: The Messenger of Allah (may peace be upon him) said three rak'ahs of the 'Asr prayer and then got up and went to his apartment. A man possessing large arms stood up and said: Messenger of Allah, bias the player been shortened? He came out angrily, and said the rak'ah which he had omitted and then gave salutation. then performed two prostrations of forgetfulness and then gave salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1189]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1189

Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) while reciting the Qur'an recited its scarab containing sajda, and he performed prostration and we also prostrated along with him (but we were so overcrowded) that some of us could not find a place for our forehead (when prostrating ourselves).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1190]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1190

Ibn 'Umar reported: Sometimes the Messenger of Allah (may peace be upon him) recited the Qur'an, and would pass by (recite) the verse of sajda and performed prostration and he did this along with us, but we were so crowded in his company that none of us could find a place for performing prostration. (and it was done on occasions) other than prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1191]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1191

Abdullah (b. 'Umar) reported: The Apostle of Allah (may peace be upon him) recited (Surat) al Najm and performed prostration during its recital and all those who were along with him also prostrated themselves except one old man who took a handful of pebbles or dust in his palm and lifted it to his forehead and said: This is sufficient for me. 'Abdullah said: 1 saw that he was later killed in a state of unbelief.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1192]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1192

'ta' b. Yasar reported that he had asked Zaid b. Thabit about recital along with the Imam, to which he said: There should be no recital along with the Imam in anything, and alleged that he recited:" By the star when it sets" (Surah Najm) before the Messenger of Allah (may peace be upon him) and he did not prostrate himself.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1193]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1193

Abu Salama b. 'Abual-Rahman reported: Abu Huraira recited before them:" hen the heaven burst asunder" (al-Qur'an, lxxxiv. 1) and performed prostration. After completing (the prayer) he informed them that the Messenger of Allah (may peace be upon him) has prostrated himself at it (this verse).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1194]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1194

A hadith like this has been narrated by AbuSalama on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1195]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1195

Abu Huraira reported: We performed prostration along with the Messenger of Allah (may peace be upon him) (as he recited these verses: )" When the heaven burst asunder" and" Read in the name of Thy Lord" (al-Qur'an, xcvi. 1).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1196]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1196

Abu Huraira reported: The Messenger of Allah (may peace be upon him) prostrated himself (while reciting these verses)." When the heaven burst asunder" ;" Read in the name of Thy Lord".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1197]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1197

A hadith like this has been transmitted by Abual-Rahman al-Araj on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1198]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1198

Abu Rafi' reported: I said the night prayer along with Abu Huraira and -as he recited:" When the heaven burst asunder," he performed prostration. Isaid to him: What prostration is this? He said: I prostrated myself (on this occasion of recital) behind Abu'I-Qasim (Muhammad. may peace be upon him), and Iwould go on doing this till I meet him (in the next world). Ibn 'Abu al-A'la said: (Abu Huraira uttered this: ) I would not abandon performing prostration.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1199]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1199

This hadith has been narrated by Tamimi with the same chain of transmitters except for this that they made no mention of:" Behind Abu'l-Qasim" (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1200]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1200

Abu Rafi' reported: I saw Abu Huraira performing prostration (while reciting this verse: )" When the heaven burst asunder." I said to him: Do you prostrate yourself (while reciting) i? He said: Yes, I saw my best Friend (may peace be upon him) prostrating himself on (the recital of this verse) and I shall continue prostrating till I meet him. Shu'ba asked: Do you mean (by Friend) the Apostle of Allah (may peace be upon him)? He said: Yes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1201]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1201

Abdullah b. Zubair narrated on the authority of his father: When the Messenger of Allah (may peace be upon him) sat in prayer. he placed the left foot between his thigh and shank and stretched the right foot and placed his left hand or his left knee and placed his right hand on his right thigh, and raised his finger.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1202]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1202

'Abdullah b. Zubair narrated on the authority of his father that when the Messenger of Allah (may peace be upon him) sat for supplication, i. e. tashahhud (blessing and supplication), he placed his right hand on his right thigh and his left hand on his left thigh, and pointed with his forefinger, and placed his thumb on his (milddle) finger, and covered his knee with the palm of his left hand..


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1203]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1203

Ibn 'Umar reported that when the Messenger of Allah (may peace be upon him) sat for tashahhud he placed his left hand on his left knee. and his right hand on his right knee. and he raised his right finger, which is next to the thumb, making supplication in this way, and he stretched his left hand on his left knee. Another version on the authority of Ibn Umar says: When the Messenger of Allah (may peace be upon him) sat for tashahhud, he placed his left hand on his left knee and placed his right hand on his right knee, and he formed a ring like (fifty-three) and pointed with his finger of attestation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1204]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1204

'Ali b. 'Abual-Rahman al-Mu'awi reported: 'Abdullah b. Umar saw me playing with pebbles during prayer. After finishing the prayer he forbade me (to do it) and said: Do as the Messenger of Allah (may peace be upon him) used to do. I said: How did Allah's Messenger (may peace be upon him) do? He said that he (the Messenger of Allah) sat at tashahhud, placed his right palm on the right thigh and closed all his fingers and pointed with the help of finger next to the thumb, and placed his left palm on his right thigh.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1205]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1205

This hadith has been narrated by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1206]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1206

Abu Ma'mar reported: There was an Amir in Mecca who pronounced taslim twice. Abdullah said: Where did he get this sunnah? Al-Hakam said: There is a hadith to the effect that the Messenger of Allah (may peace be upon him) did like It.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1207]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1207

'Abdullah reported: An Amir or a person pronounced taslim twice. 'Abdullah said: Where did he get this sunnah?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1208]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1208

'Amir b. Sa'd reported: I saw the Messenger of Allah (may peace be open him) pronouncing taslim on his right and on his left till I saw the whiteness of his cheek.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1209]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1209

Ibn 'Abbas said: We used to know that Allah's Messenger (may peace be upon him) had finished his prayer when we heard the takbir (Allah-O-Akbar).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1210]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1210

Ibn 'Abbas reported: We knew the finishing of the prayer of the Messenger of Allah (may peace be upon him) through takbir. 'Amr (b. Dinar) said: I made a mention of it to Abu Mas'ud. hue he rejected it and said: I never narrated it to you. 'Amr said: He did narrate it before this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1211]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1211

Ibn 'Abbas reported: Dhikr (mentioning the name of Allah) in a loud voice after obligatory prayers was (a common practice) during the lifetime of the Apostle of Allah (may peace be upon him) ; and when I heard that I came to knew that they (the people) had finished the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1212]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1212

'A'isha reported: The Holy Prophet (may peace be upon him) entered my house when a Jewess was with me and she was saying: Do you know that you would be put to trial in the grave? The Messenger of Allah (may peace be upon him) trembled (on hearing this) and said: It is the Jews only who would-be put to trial. 'A'isha said: We passed some nights and then the Messenger of Allah (may peace be upon him) said: Do you know that it has been revealed to me:" You would be put to trial in the grave"? 'A'isha said: 1 heard the Messenger of Allah (may peace be upon him) seeking refuge from the torment of the grave after this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1213]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1213

Abu Huraira reported. I heard the Messenger of Allah (may peace be upon him) seeking refuge from the torment of the grave after this (after the revelation).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1214]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1214

'A'isha reported: There came to me two old women from the old Jewesses of Medina and said: The people of the grave are tormented in their graves. I contradicted them and I did not deem it proper to testify them. They went away and the Messenger of Allah (may peace be upon him) came to me and I said to him: Messenger of Allah I there came to me two old women from the old Jewesses of Medina and asserted that the people of the graves would be tormented therein. He (the Prophet) said: They told the truth; they would be tormented (so much) that the animals would listen to it. She ('A'isha) said: Never did I see him (the Holy Prophet) afterwards but seeking refuge from the torment of the grave in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1215]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1215

Masruq reported this hadith on the authority of 'A'isha who said: Never did he (the Holy Prophet) say prayer after this in which I did not hear him seeking refuge from the torment of the grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1216]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1216

'A'isha reported: 1 heard the Messenger of Allah (may peace be upon him) seeking refuge from the trial of Dajjal (Antichrist) in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1217]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1217

Abu Huraira reported: The Messenger of Allah (way peace be upon him) said: When any one of you utters tashahhud (in prayer) he must seek refuge with Allah from four (trials) and should thus say:" O Allah! I seek refuge with Thee from the torment of the Hell, from the torment of the grave, from the trial of life and death and from the evil of the trial of Masih al-Dajjal" (Antichrist).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1218]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1218

'A'isha, the wife of the Apostle of Allah (may peace be upon him) reported: The Apostle of Allah (may peace be upon him) used to supplicate in prayer thus:" O Allah! I seek refuge with Thee from the torment of the grave, and I seek refuge with Thee from the trial of the Masih al-Dajjal (Antichrist) and I seek refuge with Thee from the trial of life and death. O Allah! I seek refuge with Thee from sin and debt." She ('A'isha) reported: Someone said to him - (the Holy Prophet): Messenger of Allah! why is it that you so often seek refuge from debt? He said: When a (person) incurs debt, (he is obliged) to tell lies and break promise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1219]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1219

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When any one of you completes the last tashahhud. he should seek refuge with Allah from four (trials). I. e. from the torment of Hell, from the torment of grave, from the trial of life and death. -and from the mischief of Masih at-Dajjal (Antichrist). This hadith has been narrated by al-Auza'i with the same chain of transmitters but with these words:" When any one of you completes the tashahhud" and he made no mention of the words" the last".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1220]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1220

Abu Huraira reported: The Apostle of Allah (may peace be upon him) said: O Allah! I seek refuge with Thee from the torment of the grave, and the torment of Hell, and the trial of life and death and the mischief of Masih al-Dajjal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1221]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1221

Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: Seek refuge with Allah from the torment of Hell, seek refuge with Allah from the torment of the grave, and seek refuge with Allah from the trial of Masih al-Dajjal and seek refuge with Allah from the trial of life and death.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1222]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1222

A hadith like this has been transmitted by Ibn Tawus from his father on the authority of AbuHuraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1223]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1223

A hadith like this has been transmitted by A'raj on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1224]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1224

Abu Huraira reported that the Apostle of Allah (may peace be upon him) use (t to seek refuge from the torment of the grave, torment of Hell and the trial of Dajjal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1225]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1225

Ibn 'Abbas reported that the Messenger of Allah (may peace he upon him) used to teach them this supplication (in the same spirit) with which he used to teach them a surah of the Qur'an. He would thus instruct us:" Say, O Allah I we seek refuge with Thee from the torment of Hell, and I seek refuge with Thee from the torment of the grave, and I seek refuge with Thee from the trial of Masih al-Dajjal. and I seek refuge with Thee from the trial of life and death." Muslim b. Hajjaj said: It has reached me that Tawus said to his son: Did you make this supplication in prayer? He said: No. (Upon this) he (Tawus) said: Repeat the prayer. Tawus has narrated this hadith through three or four (transmitters) with words to the same effect.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1226]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1226

Thauban reported: When the Messenger of Allah (may peace be upon him) finished his prayer. he begged forgiveness three times and said: O Allah! Thou art Peace, and peace comes from Thee; Blessed art Thou, O Possessor of Glory and Honour. Walid reported: I said to Auza'i: How Is the seeking of forgiveness? He replied: You should say:, I beg forgiveness from Allah, 1 beg forgiveness from Allah."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1227]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1227

'A'isha reported: When the Messenger of Allah (may peace be upon him) pronounced salutation, he salutation longer than it took him to say: O Allah: Thou art Peace, and peace comes from Thee, blessed art Thou, Possessor of Glory and ]Honour; and in the narration of Ibn Numair the words are:" O Possessor of Glory and Honour."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1228]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1228

Ibn Numair narrated it with the same chain of transmitters and said: O Possessor of Glory and Honour.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1229]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1229

A hadith like this has been transmitted by Abdullah b. Harith on the authority of A'isha except for the words that he (the Holy Prophet) used to say:" 0 Possessor of Glory and Honour."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1230]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1230

Mughira b. Shu'ba wrote to Mu'awiya: When the Messenger of Allah (may peace be upon him) finished the prayer and pronounced salutation he uttered (this supplication):" There is no god but Allah. He is alone, Who has no partner. To Him belongs the sovereignty and to Him praise is due and He is Potent over every. thing. O Allah! no one can withhold what Thou givest, or give what Thou withholdest, and the riches cannot avail a wealthy person with Thee."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1231]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1231

A hadith like this has been narrated by Mughira b. Shu'ba with another chain of transmitters. Abu Bakr and Abu Kuraib narrated in their narration (that Warrad reported): Mughira gave me dictation of it and 1 wrote it to Mu'awiya.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1232]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1232

Warrad, the freed slave of Mughira b. Shu'ba, reported: Mughira b. Shu'ba wrote to Mu'awiya (it was Warrad who wrote this letter for him, i. e. Mughira): I heard the Messenger of Allah (may peace be upon him) saying:" When the salutation is pronounced." and the rest of the hadith is the same except this that he made no mention of:" He is Potent over everything."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1233]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1233

Warrad, the scribe of Mughira b. Shu'ba, reported: Mu'awiya wrote to Mughira (the contents) of the hadith as transmitted by Mansur and A'mash.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1234]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1234

Warrad, the scribe of Mughira b. Shu'ba, reported: Mu'awiya wrote to Mughira: Write to me anything which you heard from the Messenger of Allah (may peace be upon him). So he (Mughira) wrote to him (Mu'awiya): I heard the Messenger of Allah (may peace be upon him) uttering (these words) at the completion of prayer:" There is no god but Allah. He is alone and there is no partner with Him. Sovereignty belongs to Him and to Him is praise due and He is Potent over everything. O Allah! no one can withhold what Thou givest, or give what Thou withholdest, and riches cannot avail a wealthy person with Thee."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1235]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1235

Abu Zubair reported: Ibn Zubair uttered at the end of every prayer after pronouncing salutation (these words):" There is no god but Allah. He is alone. There is no partner with Him. Sovereignty belongs to Him and He is Potent over everything. There is no might or power except with Allah. There is no god but Allah and we do not worship but Him alone. To Him belong all bounties, to Him belongs all Grace, and to Him is worthy praise accorded. There is no god but Allah, to Whom we are sincere in devotion, even though the unbelievers should disapprove it." (The narrator said): He (the Holy Prophet) uttered it at the end of every (obligatory) prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1236]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1236

Abu Zubair reported: Abdullah b Zubair used to say La ilaha il-Allah at the end of every prayer like the hadith narrated by Ibn Numair and he reported it in the end, and then reported Ibn Zubair saying: The Messenger of Allah (may peace be upon him) uttered La ilaha il-Allah at the end of every prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1237]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1237

Abu Zubair reported: I heard Abdullah b. Zubair addressing (people) on the pulpit and saying: When the Messenger of Allah (may peace be upon him) pronounced salutation at the end of the prayer or prayers, and then he made a mention of the hadith as transmitted by Hisham b. 'Urwa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1238]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1238

Abu Zubair al-Makki reported that he had heard 'Abdullah b. Zubair uttering (the words) like that of the hadith (narrated above) at the end of the prayer after pronouncing salutation. He at the conclusion also said that he was making a mention of that from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1239]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1239

Abu Huraira reported: The poor amongst the emigrants came to the Messenger of Allah (may peace be upon him) and said: The possessors of great wealth have obtained the highest ranks and the lasting bliss. lie (the Holy Prophet) said: How Is that? They said: They pray as we pray, and they observe fast as we observe fast, and they give charity but we do not give charity, and they set slaves free but we do not set slaves free. Upon this the Messenger of Allah (may peace be upon him) said: Shall A not teach you something by which you will catch upon those who have preceded you, and get ahead of those who come after you, only those who do as you do being more excellent than you? They said: Yes, Messenger of Allah. He (the Holy Prophet) said: Extol Allah, declare His Greatness, and Praise Him thirty-three times after every prayer. Abu Salih said: The poor amongst the emigrants returned to the Messenger of Allah (may peace upon him) saying: Our brethren, the possessors, of property have heard what we have done and they did the same. So the Messenger of Allah (may peace be upon him) said: This is Allah's Grace which He gives to whom He wishes. Sumayy reported: I made a mention of this hadith to some members of my family (and one of them) said: You have forgotten; he (the Holy Prophet) had said (like this):." Extol Allah thirty-three time. praise Allah thirty-three times and declare His Greatness thirty-three times. Ibn 'Ajjan said: 1 made a mention of this hadith to Raja' b. Haiwata and he narrated to me a hadith like this from AbuSalih from the Messenger of Allah (may peace be upon him) on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1240]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1240

Abu Huraira narrated it from the Messenger of Allah (may peace be upon him) that they (the poor among the emigrants) said: Messenger of Allah, the possessors of great wealth have obtained the highest ranks and lasting bliss, and the rest of the hadith is the same as transmitted by Qutaiba on the authority of Laith except that he inserted the words of Abu Salih in the narration of Abu Huraira that" the poor of the emigrants came back," to the end of the hadith,, but this addition was made that Suhail said (that every part of the supplication, i. e. Glorification of Allah, His Praise and declaration of His Greatness) should be uttered eleven times making the total as thirty-three.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1241]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1241

Ka'b b. 'Ujra reported Allah's Messenger (may peace be upon him) as saying: There are certain ejaculations, the repeaters of which or the performers of which after every prescribed prayer will never be caused disappointment:" Glory be to Allah" thirty-three times." Praise be to Allah" thirty-three times, and" Allah is most Great" thirty-four times.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1242]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1242

Ka'b b. 'Ujra reported Allah's Messenger (may peace be upon him) as saying: There are certain ejaculations, the repeaters of which or the performers of which at the end of every prayer will never be caused disappointment:" Glory be to Allah" thirty-three times," Praise be to Allah" thirty-three times, and" Allah is most Great" thirty-four times.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1243]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1243

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If anyone extols Allah after every prayer thirty-three times, and praises Allah thirty-three times, and declares His Greatness thirty-three times, ninety-nine times in all, and says to complete a hundred:" There is no god but Allah, having no partner with Him, to Him belongs sovereignty and to Him is praise due, and He is Potent over everything," his sins will be forgiven even If these are as abundant as the foam of the sea.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1244]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1244

This hadith has been narrated by Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1245]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1245

Abu Huraira reported that Allah's Messenger (may peace be upon him) used to observe, silence for a short while between the takbir (at the time of opening the prayer) and the recitation of the Qur'an. I said to him: Messenger of Allah, for whom I would give my father and mother in ransom, what do you recite during your period of silence between the takbir and the recitation? He said: I say (these words):" O Allah, remove my sins from me as Thou hast removed the East from the West. O Allah purify me from sins as a white garment is purified from filth. O Allah! wash away my sins with water, snow and hall."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1246]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1246

Abu Huraira reported that when the Messenger of Allah (may peace be upon him) stood up for the second rak'ah he opened it with the recitation of the praise of Allah, the Lord of universe (al-Fatiha), and he did not observe silence (before the recitation of al-Fatiha).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1247]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1247

Anas reported: A man came panting and entered the row of worshippers and said: Praise be to Allah, much praised and blessed. When the Messenger of Allah (may peace be upon him) finished the prayer he said: Who amongst you uttered these words? The people remained silent. He (the Holy Prophet again said) -: Who amongst you uttered these words? He said nothing wrong. Then a man said: I came and had a difficulty in breathing, so I uttered them. He replied: I saw twelve angels facing one another as to who will take them up (to Allah).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1248]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1248

Ibn 'Umar reported: While we said prayer with the Messenger of Allah (may peace be upon him), one among the people said: Allah is truly Great, praise be to Allah in abundance. Glory be to Allah in the morning and the evening. The Messenger of Allah (may peace be upon, him) said: Who uttered such and such a word? A person among the people said: It is I, Messenger of Allah (who have recited these words). He (the Holy Prophet) said: It (its utterance) surprised me, for the doors of heaven were opened for It. Ibn 'Umar said: I have not abandoned them (these words) since I heard the Messenger of Allah (may peace be upon him) saying this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1249]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1249

Abu Huraira reported: I heard the Messenger of Allah (may peace be upon him) saying: When the Iqama has been pronounced for prayer, do not go running to it, but go walking in tranquillity and pray what you are in time for, and complete what you have missed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1250]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1250

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: When the words of Iqama are pronounced, do not come to (prayer) running, but go with tranquillity, and pray what you are in time for, and complete (what you have missed) for when one of you is preparing for prayer he is in fact engaged in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1251]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1251

Abu Huraira reported ahadith from the Messenger of Allah (may peace be upon him), and one of them is that the Messenger of Allah (may peace be upon), said: When the call is made for prayer come to it walking with tranquillity, and pray what you are in time for, and complete what you have missed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1252]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1252

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When the words of Iqama are pronounced, none of you should run to it (to join the prayer) but walk with tranquillity and dignity, and pray what you are in time for and complete what has gone before (what the Imam has completed).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1253]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1253

Abdullah b. Abu Qatada reported on the authority of his father: While we said our prayer with the Messenger of Allah (may peace be upon him) he heard tumult. (At the end of the prayer) he (the Holy Prophet) said: What is the matter with you? They said: We hastened to prayer. He (the Holy Prophet) said: Don't do that; when you come for prayer, there should be tranquillity upon you. Pray (along with the Imam) what you can find and complete what preceded you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1254]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1254

This hadith has been narrated by Shaiban with the same chain of transmitters


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1255]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1255

Abu Qatada reported: The Messenger of Allah (may peace be upon him) said: When the Iqama is pronounced do not get up till you see me Ibn Hatim was in doubt whether it was said:" When the Iqama is pronounced" or" When call is made".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1256]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1256

Abu Salama son of Abd al-Rahman b. Auf reported Abu Huraira as saying: Iqama was pronounced and we stood up and made rows straight till he (the Holy Prophet) stood at his place of worship (the place ahead of the rows where he stood to lead the prayer) before takbir tahrima. He reminded to (himself something) and went back saying that we should stand at our places and not leave them. We waited, till he came back to us and he had taken a bath and water trickled out of his head and then led us in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1257]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1257

Abu Salama reported Abu Huraira as saying: Iqama was pronounced. ant the people had formed themselves into rows. The Messenger of Allah (may peace be upon him) came out and stood at his place, and then pointed out with his hand that we should stand at our places. He then went away and took a bath and water trickled from his head and then led them in prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1258]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1258

Abu Salama reported on the authority of Abu Huraira that when Iqama was pronounced for the Messenger of Allah (may peace be upon him), the people occupied their places in the rows before the Apostle of Allah (way peace be upon him) stood up at his place.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1259]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1259

Jabir b. Samura reported: Bilal summoned to prayer as the sun declined but did not pronounce Iqama till the Apostle of Allah (may peace be upon him) came out and the Iqama was pronounced on seeing him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1260]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1260

Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: He who finds a rak'ah of the prayer, he in fact finds the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1261]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1261

Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: He who finds one rak'ah of the prayer with the Imam, he in fact finds the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1262]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1262

This hadith has been narrated on the authority of Malik and there is no mention of" along with the Imam" and In the hadith transmitted by Abdullah the words are:" he in fact finds the entire prayer".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1263]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1263

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who finds one rak'ah at dawn before the rising of the sun, he in fact finds the dawn prayer. and he who finds one rak'ah of the afternoon prayer before sunset, he in fact finds the afternoon prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1264]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1264

A'isha reported: The Messenger of Allah (may peace be upon him) said: He who finds a prostration before sunset or at dawn (prayer) before the rising (of the sun) he Id fact finds that (prayer), and prostration implies a rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1265]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1265

This hadith is narrated by Abu Huraira with another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1266]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1266

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: He who finds (gets) a rak'ah of the afternoon (prayer) before the setting of the sun, he in fact gets (the full prayer), and he who gets a rak'ah of the morning (prayer) before the rising of the sun he in fact gets (the full prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1267]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1267

This hadith has been reported by Ma'mar with another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1268]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1268

Ibn Shibab reported: 'Umar b. 'Abd al-'Aziz deferred the afternoon prayer somewhat and 'Urwa said to him: Gabriel came down and he led the Messenger of Allah (may peace be upon him) in prayer. 'Umar said to him: O 'Urwa, are you aware of what you are saying? Upon this he ('Urwa) said: I heard Bashir b. Abu Mas'ud say that he heard Abu Mas'ud say that he heard the Messenger of Allah (may peace be upon him) say: Gabriel came down and acted as my Imam, then I prayed with him, then I prayed with him, then I prayed with him. then I prayed with him. then I prayed with him. reckoning with his fingers five times of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1269]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1269

Ibn Shibab reported: Umar b. 'Abd al-'Aziz one day deferred the prayer. 'Urwa b. Zubair came to him and informed him that one day as Mughira b. Shu'ba was in Kufa (as its governor), he deferred the prayer, Abu Mas'ud al-Ansari came to him and said: What is this, O Mughira? Did you know that it was Gabriel who came and said prayer and (then) the Messenger of Allah (may peace be upon him) said the prayer (along with him), then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) also prayed, then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) also prayed, then (Gabriel) prayed and the Messenger of Allah (may peace be upon him) prayed (along with him). then Gabriel prayed and the Messenger of Allah (may peace be upon him) also prayed (along with him) and then said: This is how I have been ordered to do. 'Umar (b. 'Abd al-'Aziz) said. O 'Urwa be mindful of what you are saying that Gabriel (peace be upon him) taught the Messenger of Allah (may peace be upon him) the times of prayer. Upon this 'Urwa said: This is how Bashir b. Abu Mas'ud narrated on the authority of his father and (also said): 'A'isha?, the wife of the Apostle (may peace be upon him). narrated it to me that the Messenger of Allah (may peace be upon him) used to say the afternoon prayer, when the light of the sun was there in her apartment before it went out (of it).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1270]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1270

A'isha reported: The Apostle of Allah (may peace be upon him) said the afternoon" prayer as the sun shone in my apartment, and the afternoon shadow did not extend further. Abu Bakr said: The afternoon shadow did not appear to extend further.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1271]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1271

'A'isha, the wife of the Apostle (may peace be upon him), said that the Messenger of Allah (may peace be upon him) said the afternoon prayer (at the time) when the sun shone in her apartment and its shadow did not extend beyond her apartment.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1272]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1272

A'isha reported: The Messenger of Allah (may peace be upon him) said the afternoon prayer (at a time) when the (light) of the sun was there in my apartment.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1273]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1273

Abdullah b. 'Amr reported the Apostle (may peace be upon him) saying: The time of the noon prayer (lasts) as long as it is not afternoon, and the time of the afternoon prayer (lasts) as long as the sun does not turn pale and the time of the evening prayer (lasts) as long as the spreading appearance of the redness above the horizon after sunset does not sink down, and the, time of the night prayer (lasts) by midnight and the time of the morning prayer (lasts) as long as the sun dots not rise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1274]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1274

Abu Bakr b Abu Shaiban and Yahya b Abu Bukair both of them narrated this hadith with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1275]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1275

'Abdullah b. 'Amr reported: The Messenger of Allah (may peace be upon him) said: The time of the noon prayer is when the sun passes the meridian and a man's shadow is the same (length) as his height, (and it lasts) as long as the time for the afternoon prayer has not come; the time for the afternoon prayer is as long as the sun has not become pale; the time of the evening prayer is as long as the twilight has not ended; the time of the night prayer is up to the middle of the average night and the time of the morning prayer is from the appearance of dawn, as long as the sun has not risen; but when the sun rises, refrain from prayer for it rises between the horns of the devil.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1276]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1276

'Abdullah b. 'Amr b. al-'As reported: The Messenger of Allah (may peace be upon him) was asked about the times of prayers. He said: The time for the morning prayer (lasts) as long as the first visible part of the rising sun does not appear and the time of the noon prayer is when the sun declines from the zenith and there is not a time for the afternoon prayer and the time for the afternoon prayer is so long as the sun does not become pale and its first visible part does not set, and the time for the evening prayer is that when the sun disappears and (it lasts) till the twilight is no more and the time for the night prayer is up to the midnight.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1277]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1277

'Abdullah narrated it on the authority of his father Yahya: Knowledge cannot be acquired with sloth.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1278]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1278

Sulaiman b. Buraida narrated it on the authority of his father that a person asked the Apostle of Allah (may peace be upon him) about the time of prayer. Upon this he said: Pray with us these two, meaning two days. When the sun passed the meridian. he gave command to Bilal who uttered the call to prayer. then lie commanded him and pronounced Iqama for noon prayer (Then at the tine of the afternoon prayer) he again commanded and Iqama for the afternoon prayer was pronounced when the sun was high, white and clear. He then commanded and Iqama for the evening prayer was pronounced, when the sun had set. He then commanded him and the Iqama for the night prayer was pronounced When the twilight had disappeared. He then commanded him and the Iqama for the morning prayer was pronounced, when the dawn had appeared. When it was the next day, he commanded him to delay the noon prayer till the extreme heat had passed and he did so, and he allowed it to be delayed till the extreme heat had passed. He observed the afternoon prayer when the sun was high, delaying it beyond the time he had previously observed it. He observed the evening prayer before the twilight had vanished; he observed the night prayer when a third of the night had passed; and he observed the dawn prayer when there was clear daylight. He (the Holy Prophet) then said: Where is the man who inquired about the time of prayer? He (the inquirer) said: Messenger of Allah I here I am. He (the Holy Prophet) said: The time for your prayer is within the limits of what you have seen.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1279]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1279

Buraida narrated on the authority of his father that a man came to the Prophet (may peace be upon him) and asked about the times of prayer. He said: You observe with us the prayer. He commanded Bilal, and he uttered the call to prayer in the darkness of night preceding daybreak and he said the morning prayer till dawn had appeared. He then commanded him (Bilal) to call for the noon prayer when the sun had declined from the zenith. He then commanded him (Bilal) to call for the afternoon prayer when the sun was high. He then commanded him for the evening prayer when the sun had set. He then commanded him for the night prayer when the twilight had disappeared. Then on the next day he commanded him (to call for prayer) when there was light in the morning. He then commanded him (to call) for the noon prayer when the extreme heat was no more. He then commanded him for the afternoon prayer when the sun was bright and clear and yellowness did not blend with it. He then commanded him to observe the sunset prayer. He then commanded him for the night prayer when a third part of the night bad passed or a bit less than that. Harami (the narrator of this hadith) was in doubt about that part of the mentioned hadith which concerned the portion of the night. When it was dawn, he (the Holy Prophet) said: Where is the inquirer (who inquired about the times of prayer and added): Between (these two extremes) is the time for prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1280]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1280

Abu Musa narrated on the authority of his father that a person came to the Messenger of Allah (may peace be upon him) for inquiring about the times of prayers. He (the Holy Prophet) gave him no reply (because he wanted to explain to him the times by practically observing these prayers). He then said the morning player when it was daybreak, but the people could hardly recognise one another. He then commanded and the Iqama for the noon prayer was pronounced when the tan had passed the meridian and one would say that it was midday but he (the Holy Prophet) knew batter than them. He then again commanded and the Iqama for the afternoon prayer was pronounced when the sun was high. He then commanded and Iqama for the evening prayer was pronounced when the sun had sunk. He then commanded and Iqama for the night prayer was pronounced when the twilight had disappeared. He then delayed the morning prayer on the next day (so much so) that after returning from it one would say that the sun had risen or it was about to rise. He then delayed the noon prayer till it was near the time of afternoon prayer (as it was observed yesterday). He then delayed the afternoon prayer till one after returning from it would say that the sun had become red. He then delayed the evening prayer till the twilight was about to disappear. He then delayed the night prayer till it was one-third of the night. He then called the inquirer in the morning and said: The time for prayers is between these two extremes).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1281]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1281

Abu Musa reported on the authority of his father that an Inquirer came to the Prophet (may peace be upon him) and asked him about the times of prayers, and the rest of the hadith is the same (as narrated above) but for these words:" On the second day he (the Holy Prophet) observed the evening prayer before the disappearance of the twilight."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1282]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1282

Abu Huraira reported that the Messenger of Allah (may peace he upon him) said: When it is very hot, say (the noon prayer) when the extreme beat passes away, for intensity of beat is from the exhalation of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1283]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1283

Another hadith like this has been transmitted by Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1284]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1284

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When it is a hot day, (delay) the prayer till the extreme heat passes away, for the intensity of heat is from the exhalation of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1285]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1285

Abu Huraira reported: Refrain from saying (the noon prayer) till the extreme heat passes away, for the Intensity of heat is from the exhalation of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1286]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1286

Abu Huraira narrated this hadith from the Messenger of Allah (may peace be up on him) by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1287]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1287

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: This heat is from the exhalation of Hell-fire, so delay the prayer till it is cool.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1288]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1288

Hammam b. Munabbih reported: This is what Abu Huraira narrated to us from the Holy Prophet and he transmitted some ahadith-one of them was that the Messenger of Allah (may peace be upon him) said: Let the heat become less severe before prayer, for the intensity of heat is from the exhalation of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1289]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1289

Abu Dharr reported: The Mu'adhdbin (the announcer of the hour of prayer) of the Messenger of Allah (may peace be upon him) called for the noon prayer. Upon this the Apostle of Allah (may peace be upon him) said: Let it cool down, let it cool down, or he said: Wait, wait for the intensity of heat is from the exhalation of Hell. When the heat is intense, delay the prayer till it becomes cooler. Abu Dharr said: (We waited) till we saw the shadow of the mounds.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1290]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1290

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: The Fire made a complaint before the Lord saying." O Lord, some parts of mine have consumed the others." So it was allowed to take two exhalations, one exhalation in winter and the other exhalation in summer. That is why you find extreme heat (in summer) and extreme cold (in winter).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1291]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1291

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: When it is hot, make delay (in the noon prayer) till it cools down, for the intensity of beat is from the Exhalation of Hell; and lie also mentioned that the Hellfire complained to the Lord (about the congested atmosphere) and so it was permitted to take two exhalation during the whole year, one exhalation during the winter and one exhalation during the summer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1292]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1292

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: The Fire said to the Lord: O Lord! some parts of mine have consumed the others, so allow me to exhale (in order to find some relief from this congestion). It was granted permission to take two exhalations, one exhalation during the winter and the other exhalation during the summer So whatever you perceive in the form of intense cold or hurting cold is from the exhalation of Hell. And whatever you perceive in the form of extreme heat or intense beat is from the exhalation of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1293]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1293

Jabir b. Samura reported: The Apostle of Allah (may peace be upon him) used to offer the noon prayer when the sun declined.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1294]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1294

Khabbab reported: We complained to the Messenger of Allah (may peace be upon him) (the difficulty of) saying prayer on the intensely heated (ground or sand), but he paid no heed to our complaint.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1295]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1295

Khabbab reported: We came to the Messenger of Allah (may peace be upon him) and we complained to the Messenger of Allah (may peace be upon him) about (saying prayer) on the extremely heated ground (or sand), but he paid no heed to us. Zuhair said: I asked Abu Ishaq whether it was about the noon prayer. He said: Yes. I again said whether it concerned the (offering) of the noon (prayer) in earlier hours. He said: Yes. I said: Did it concern expediting it? He said: Yes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1296]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1296

Anas b. Malik reported: We used to say (the noonprayer) with the Messenger of Allah (may peace be upon him) in the intense heat, but when someone amongst us found it hard to place his forehead on the ground, he spread his cloth and prostrated on it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1297]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1297

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) used to pray the afternoon prayer when the sun was high and bright, then one would go off to al-'Awali and get there while the sun was still high. Ibn Qutaiba made no mention of" one would go off to al-'Awali".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1298]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1298

This hadith that the Messenger of Allah (may peace be upon him) used to offer the afternoon prayer like the one narrated above has been transmitted by Anas b. Malik by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1299]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1299

Anas b. Malik reported: We used to offer the 'Asr prayer, then one would go to Quba' and reach there and the sun would be still high.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1300]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1300

Anas b. Malik reported: We used to offer the afternoon prayer (at such a time) that a person would go to Bani 'Amr b. Auf and he would find them busy offering the afternoon prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1301]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1301

'Ala' b. 'Abd al-Rahman reported that they came to the house of Anas b. Malik in Basra after saying the noon prayer. His (Anas) house was situated by the side of the mosque. As revisited him he (Anas) said: Have you said the afternoon prayer? We said to him: It is just a few minutes before that we finished the noon prayer. He said: Offer the afternoon prayer. So we stood up and said our prayer. And when we completed it, he said: I have heard the Messenger of Allah (may peace be upon him) saying: This is how the hypocrite prays: he sits watching the sun, and when it is between the horns of devil, he rises and strikes the ground four times (in haste) mentioning Allah a little during it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1302]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1302

Abu Umama b. Sahl reported: We offered the noon prayer with Umar b. 'Abd al-'Aziz. We then set out till we came to Anas b. Malik and found him busy in saying the afternoon prayer. I said to him: O uncle! which is this prayer that you are offering? He said: It is the afternoon prayer and this is the prayer of the Messenger of Allah (may peace be upon him) that we offered along with him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1303]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1303

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) led us in the afternoon prayer. When he completed it, a person from Bani Salama came to him and said: Messenger of Allah, we intend to slaughter our came and we are desirous that you should also be present there (on this occasion). He (the Holy Prophet) said: Yes. He (the person) went and we also went along with him and we found that the camel had not been slaughtered yet. Then it was slaughtered, and it was cut into pieces and then some of those were cooked, and then we ate (them) before the setting of the sun. This hadith has also been narrated by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1304]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1304

Rafi' b. Khadij reported: We used to say the afternoon prayer with the Messenger of Allah (may peace be upon him), and then the camel was slaughtered and ten parts of it were distributed; then it was cooked and then we ate this cooked meat before the sinking of the sun.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1305]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1305

This hadith has been reported by 'Auza'i with the same chain of transmitters: We used to slaughter the camel during the lifetime of the Messenger of Allah (may peace be upon him) after the 'Asr prayer, but he made no mention of:" We used to pray along with him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1306]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1306

Ibn Umar reported that the Messenger of Allah (may peace be upon him) said: He who misses the afternoon prayer, it is as though he has been deprived of his family and his property.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1307]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1307

This hadith has been narrated as Marfu by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1308]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1308

Abdullah relates on the authority of his father. He who missed his afternoon prayer it is as though he was deprived of his family and property.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1309]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1309

'Ali reported: When it was the day (of the Battle) of Ahzab, the Messenger of Allah (may peace be upon him) said: May Allah fill their graves and houses with fire, as they detained us and diverted us from the middle prayer, till the sun set.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1310]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1310

This hadith has been narrated by Hisham with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1311]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1311

'Ali reported: The Messenger of Allah (may peace be upon him) said: On the day (of the Battle) of Ahzab we were diverted from the middle prayer, till the sun set. May Allah fill their graves or their houses, or their stomachs with fire. The narrator is in doubt about" houses" and" stomachs".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1312]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1312

This hadith has heed narrated by Qatada with the same chain of transmitters. And he said: Their houses and their graves (be filled with fire), and did not express doubt over the words," houses" and" graves".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1313]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1313

Yahya heard 'Ali saying that the Messenger of Allah (may peace be upon him) said on the day (of the Battle) of Ahzab, while sitting in one of the openings of the ditch: They (the enemies) have diverted us from the middle prayer till the sun set. May Allah fill their graves and their houses with fire, or their graves and stomachs with fire.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1314]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1314

'Ali reported: The Messenger of Allah (may peace be upon him) said on the day (of the Battle) of Ahzab: They diverted us from saying the middle prayer, i. e. the 'Asr prayer. May Allah fill their houses and graves with fire; he then observed this prayer between the evening prayer and the night prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1315]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1315

'Abdullah (b. Mas'ud) reported that the polytheists detained the Messenger of Allah (may peace be upon him) from observing the afternoon prayer till the sun became red or it became yellow. Upon this the Messenger of Allah (may peace be upon him) said: They have diverted us from (offering) the middle prayer. i. e. the 'Asr prayer. May Allah fill their bellies and their graves with fire, or he said: May Allah stuff their bellies and their graves with fire.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1316]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1316

Abu Yunus, the freed slave of 'A'isha said: 'A'isha ordered me to transcribe a copy of the Qur'an for her and said: When you reach this verse:" Guard the prayers and the middle prayer" (ii. 238), inform me; so when I reached it, I informed her and she gave me dictation (like this): Guard the prayers and the middle prayer and the afternoon prayer, and stand up truly obedient to Allah. 'A'isha said: This is how I have heard from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1317]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1317

Al-Bara' b. 'Azib reported: This verse was revealed (in this way):" Guard the prayers and the 'Asr prayer." We recited it (in this very way) so long as Allah desired. Allah, then, abrogated it and it was revealed:" Guard the prayers, and the middle prayer." A person who was sitting with Shaqiq (one of the narrators in the chain of transmitters) said: Now it implies the 'Asr prayer. Upon this al-Bara' said: I have already informed you how this (verse) was revealed and how Allah abrogated it, and Allah knows best. Imam Muslim said: Ashja'i narrated it from Sufyan al-Thauri, who narrated it from al-Aswad b. Qais, who narrated it from 'Uqba, who narrated it from al-Bara' b. 'Azib who said: We recited with the Prophet (may peace be upon him) (the above-mentioned verse like this, i. e. instead of Salat al- Wusta, Salat al-'Asr) for a certain period. as It has been mentioned (in the above-quoted hadith).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1318]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1318

Jabir b. 'Abdullah reported that Umar b. al-Khattab had been cursing the pagans of the Quraish an the day (of the Battle) of Khandaq (Ditch). (He came to the Holy Prophet) and said: Messenger of Allah, by God, I could not say. the 'Asr prayer till the sun set. Upon this the Messenger (may peace be upon him) said: By Allah I, too, have not observed it. So we went to a valley. The Messenger of Allah (may peace be upon him) performed ablution and we too performed ablution, and then the Messenger of Allah (may peace be upon him) said the 'Asr prayer after the sun had set. and then said the evening prayer after it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1319]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1319

This hadith has been reported by Yahya b. Abd Kathir with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1320]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1320

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Angels take turns among you by night and by day, and they all assemble at the dawn and afternoon prayers. Those (of the angels) who spend the night among you, then, ascend, and their Lord asks them, though He is the best informed about them: How did you leave My servants? -they say: We left them while they were praying and we came to them while they were praying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1321]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1321

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels take turns among you by night and by day, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1322]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1322

Jarir b. Abdullah is reported to have said: We were sitting with the Messenger of Allah (may peace be upon him) that he looked at the full moon and observed: You shall see your Lord as you are seeing this moon, and you will not be harmed by seeing Him. So if you can, do not let -yourselves be overpowered in case of prayer observed before the rising of the sun and its setting, i. e. the 'Asr prayer and the morning prayer. Jarir then recited it:" Celebrate the praise of thy Lord before the rising of the sun and before Its setting" (xx. 130).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1323]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1323

Waki' reported (this hadith) with the same chain of transmitters (that the Holy Prophet) said: You will be soon presented before your Lord, and you will see Him as you are seeing this moon, and then recited (the above-mentioned verse). But (in this hadith) no mention is made of Jarir.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1324]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1324

'Umara b. Ruwaiba is reported to have said on the authority of his father: I heard the Messenger of Allah (may peace be upon him) saying: He who observed prayer before the rising of the son and its setting, i. e. the dawn prayer and the afternoon prayer, would not cater the (Hell) fire. A person belonging to Basra said to him: Did you yourself bear it from the Messenger of Allah (may peace be upon him)? He said: Yes. The person (from Basra) said: I bear witness that I heard it from the Messenger of Allah (may peace be upon him) ; my ears heard it and my heart retained it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1325]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1325

Umara b. Ruwaiba reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: He who said prayer before the rising of the sun and its setting would not enter the fire (of Hell), and there was a man from Basra (sitting) beside him who said: Did you hear it from the Apostle of Allah (way peace be upon him)? He said: Yes, I bear witness to it. The man from Basra said: I bear witness that I did hear from the Apostle of Allah (may peace be upon him) saying it from the place that you heard from him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1326]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1326

Abu Bakr reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: He who observed two prayers at two cool (hours) would enter Paradise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1327]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1327

This hadith has been narrated by the same chain of transmitters by Hammam, and said about Abu Bakr that he was Ibn Abu Musa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1328]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1328

Salama b. al-Akwa' reported that the Messenger of Allah (may peace be upon him) used to say the evening prayer when the sun had set and disappeared (behind the horizon).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1329]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1329

Rafi' b. Khadij reported: We used to observe the evening prayer with the Messenger of Allah (may peace be upon him) and then one of us would go away and he could see the (distant) place where his arrow would fall.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1330]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1330

A hadith like this, i. e." We used to observe evening prayer...." so on and so forth, has been narrated by Rafi' b. Khadij by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1331]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1331

'A'isha. the wife of the Apostle of Allah (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) deferred one night the 'Isya' prayer. And this is called 'Atama. And the Messenger of Allah (may peace be upon him) did not come out till Umar b. Khattab told (him) that the women and children had gone to sleep. So the Messenger of Allah (may peace be upon him) came out towards them and said to the people of the mosque: None except you from the people of the earth waits for it (for the night prayer at this late hour), and it was before Islam had spread amongst people. And in the narration transmitted by Ibn Shihab the Messenger of Allah (may peace be upon him) is reported to have said: It is not meant that you should compel the Messenger of Allah (may peace be upon him) for prayer. And (this he said) when 'Umar b. Khattab called (the Holy Prophet) in a loud voice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1332]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1332

A hadith like this has been narrated by Ibn Shihab with the same chain of transmitters, but therein no mention has been made of the words of al-Zuhri: It was narrated to me, and that which followed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1333]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1333

'A'isha reported: The Apostle of Allah (may peace be upon him) one night delayed (observing the 'Isya' prayer) till a great part of the night was over and the people in the mosque had gone to sleep. He (the Holy Prophet) then came out and observed prayer and said: This is the proper time for it; were it not that I would impose a burden on my people (I would normally pray at this time). In the hadith transmitters by 'Abd al-Razzaq (the words are):" Were it not that it would impose burden on my people."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1334]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1334

Abdullah b. Umar reported: We waited one night in expectation of the Messenger of Allah (may peace be upon him) for the last prayer of the night, and he came out to us when a third of the night had passed even after that. We do not know whether he had been occupied with family business or something else. When he came cut he said: You are waiting for prayer, for which the followers of no other religion wait. except you. Were it not a burden for my Ummah, I would have led them (in the 'Isya' prayer) at this hour. He then ordered the Mu'adhdbin (to call for prayer) and then stood up for prayer and observed prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1335]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1335

Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) was one night occupied (in some work) and he delayed it ('Isya' prayer) till we went to sleep in the mosque. We then woke up and again went to sleep and again woke up. The Messenger of Allah (may peace be upon him) then came to us and said: None among the people of the earth except you waits for prayer in the night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1336]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1336

Thabit reported: They (the believers) asked Anas about the ring of the Messenger of Allah (may peace be upon him) and he said: One night the Messenger of Allah (may peace be upon him) delayed (observing) the 'Isya' prayer up to the midnight or midnight was about to be over. He then came and said: (Other) people have offered prayers and slept, but you are constantly in prayer as long as you wait for prayer. Anas said: I perceive as if I am seeing the lustre of his silver ring, and lifted his, small left finger (in order to show how the Holy Prophet had lifted it).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1337]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1337

Anas b. Malik reported: We waited for the Messenger of Allah (may peace be upon hi n) one night, till it was about midnight. He (the Holy Prophet) came and observed prayer and then turned his face towards us, as it I was seeing the lustre of the silver ring on his finger.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1338]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1338

This hadith has been narrated by Qurra with the same chain of transmitters, but therein he did not mention:" He turned his face towards us."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1339]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1339

Abu Musa reported: I and my companions who had sailed along with me in the boat landed with me in the valley of Buthan while the Messenger of Allah (may peace be upon him) was staying in Medina. A party of people amongst them went to the Messenger of Allah (may peace be upon him) every night at the time of the 'Isya' prayer turn by turn. Abu Musa said: (One night) we (I and my companions) went to the Messenger of Allah (may peace be upon him) and he was occupied in some matter till there was a delay in prayer so much so that it was the middle of the night. The Messenger of Allah (may peace be upon him) then came out and led them (Musa's companions) in prayer. And when he had observed his prayer he said to the audience present: Take it easy, I am going to give you information and glad tidings that it is the blessing of Allah upon you for there is none among the people, except you, who prays at this hour (of the night), or he said: None except you observed prayer at this. (late) hour. He (i. e. the narrator) said: I am not sure which of these two sentences he actually uttered. Abu Musa, said: We came back happy for what we heard from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1340]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1340

Ibn Juraij reported: I said to Ata': Which time do you deem fit for me to say the 'Isya' prayer, -as an Imam or alone, -that time which is called by people 'Atama? He said: I heard Ibn 'Abbas saying: The Apostle of Allah (may peace be upon him) one night delayed the 'Isya' prayer till the people went to sleep. They woke up and again went to sleep and again woke up. Then 'Umar b. Khattab stood up and said (loudly)" Prayer." Ata' further reported that Ibn 'Abbas said: The Apostle of Allah (may peace be upon him) came out, and as if I am still seeing him with water trickling from his head, and with his hand placed on one side of the head, and he said: Were it not hard for my Ummah, I would have ordered them to observe this prayer like this (i. e. at late hours). I inquired from 'Ata' how the Apostle of Allah (may peace be upon him) placed his hand upon his head as Ibn Abbas had informed. So Ata' spread his fingers a little and then placed the ends of his fingers on the side of his head. He then moved them like this over his head till the thumb touched that part of the ear which is near the face and then it (went) to the earlock and the part of the heard. It (the bind) neither held nor caught anything but this is how (it moved oil). I said to Ata': Was it mentioned to you (by Ibn Abbas) how long did the Apostle (may peace be upon him) delay it (the prayer) during that eight? He said: I do not know (I cannot give you the exact time). Ali' said: I love that I should say prayer, whether as an Imam or alone at delayed hours as the Apostle of Allah (may peace be upon him) said that night, but if It is hard upon you in your individual capacity or upon people in the congregation and you are their Imam, then say prayer ('Isya') at the middle hours neither too early nor too late.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1341]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1341

Jabir b. Samura reported that the Messenger of Allah (may peace be upon him) postponed the last 'Isya' prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1342]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1342

Jabir b. Samura reported: The Messenger of Allah (may peace be upon him) used to observe prayers like your prayers, but he would delay the prayer after nightfall to a little after the time you observed it, and he would shorten the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1343]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1343

Abdullah b. 'Umar reported: I heard the Messenger of Allah (may peace be upon him) as saying: Let the bedouin not gain upper hand over you in regard to the name of your prayer. See I (The night prayer should be called) 'Isya' (and the bedouins call it Atama (because) they milk their camels late.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1344]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1344

Ibn 'Umar said: The Messenger of Allah (may peace be upon him) said: Let the bedouin not gain upper band over you In regard to the name of your prayer, i. e. night prayer, for it is mentioned 'Isya' in the Book of Allah (i. e. the Qur'an). (The bedouin call it 'Atama because) they make delay in milling their she-camels.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1345]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1345

'A'isha reported: The believing women used to pray the morning prayer with the Messenger of Allah and then return wrapped in their mantles. No one could recognise them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1346]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1346

'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: The believing women observed the morning prayer with the Messenger of Allah (may peace be upon him) wrapped in their mantles. They then went back to their houses and were unrecognisable, because of the Messenger of Allah's (may peace be upon him) praying in the darkness before dawn.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1347]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1347

'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe the morning prayer, and the women would go back wrapped in their mantles being unrecognisable because of the darkness before dawn. (Ishaq b. Musa) al-Ansari (one of the transmitters in this chain of narration) narrated" wrapped" (only) in his narration. (No mention was made of mantles.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1348]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1348

Muhammad b. 'Amr b. al-Hasan b. 'All reported: When Hajjaj came to Medina we asked Jabir b. Abdullah (about the timings of prayer as observed by the Holy Prophet). He said: The Messenger of Allah (may peace be upon him) used to pray afternoon prayer in the midday heat; the afternoon prayer when the sun was bright; the evening prayer when the sun had completely set; and as for the night prayer, he sometimes delayed and sometimes (observed it) at earlier hours. When he found them (his Companions) assembled (at earlier hours) he (prayed) early. and when he saw them coming late, he delayed the (prayer). and the morning prayer the Apostle of Allah (may peace be upon him) observed in the darkness before dawn.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1349]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1349

Muhammad b. 'Amr al-Hasan b. 'All reported: Hajjaj used to delay the prayers, and so we asked Jabir b. 'Abdullah, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1350]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1350

Sayyar b. Salama reported: I heard my father asking Abu Barza (al- Aslami) about the prayer of Allah's Messenger (may peace be upon him) I (Shu'ba, one of the narrators) said: Did you hear it (from Abu Barza)? He said: 1 feel as if I am bearing you at this very time. He said: I heard my father asking about the prayer of the Messenger of Allah (may peace be upon him) and he (Abu Barza) making this reply: He (the Holy Prophet) did not mind delaying-some (prayer) i. e. 'Isya' prayer, even up to the midnight and did not like sleeping before observing it, and talking after it. Shu'ba said: I met him subsequently and asked him (about the prayers of the Holy Prophet) and he said: He observed the noon prayer when the sun was past the meridian, he would pray the afternoon prayer, after which a person would o to the outskirts of Medina and the sun was still bright; (I forgot what he said about the evening prayer) ; I then met him on a subsequent occasion and asked him (about the prayers of the Holy Prophet; and he said: He would observe the morning prayer (at such a time) so that a man would go back and would recognise his neighbour by casting a glance at his face, and he would recite from sixty to one hundred verses in it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1351]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1351

Sayyar b. Salama reported: I heard Abu Barza saying that the Messenger of Allah (may peace be upon him) did not mind some delay in the 'Isya' prayer even up to the midnight and he did not like sleeping before (observing it) and talking after it. Shu'ba said: I again met him (Sayyar b. Salama) for the second time and he said: Even up to the third (part) of the night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1352]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1352

Abu Barza b. Aslami is reported to have said: The Messenger of Allah (may peace be upon him) delayed the night prayer till a third of the night had passed and he did not approve of sleeping before it, and talking after it, and he used to recite in the morning prayer from one hundred to sixty verses (and completed the prayer at such hours) when we recognised the faces of one another.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1353]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1353

Abu Dharr reported: The Messenger of Allah (may peace be upon him) said to me: How would you act when you are under the rulers who would delay the prayer beyond its prescribed time, or they would make prayer a dead thing as far as its proper time is concerned? I said: What do you command? He (the Holy Prophet) said: Observe the prayer at Its proper time, and if you can say it along with them do so, for it would be a superetogatory prayer for you. Khalaf (one of the narrators in the above hadith) has not mentioned" beyond their (prescribed) time".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1354]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1354

Abu Dharr reported: The Messenger of Allah (may peace be upon him) said to me: O Abu Dharr, you would soon find after me rulers who would make their prayers dead. You should say prayer at its prescribed time. If you say prayer at its prescribed time that would be a supererogatory prayer for you, otherwise you saved your prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1355]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1355

Abu Dharr reported: My friend (the Holy Prophet) bade me to hear and obey (the ruler) even if he is a slave having his feet and arms cut off, and observe prayer at its prescribed time. (And further said): It you find people having observed the prayer, you in fact saved your prayer, otherwise (if you join with them) that would be a Nafl prayer for you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1356]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1356

Abu Dharr reported: The Messenger of Allah (may peace be upon him) struck my thigh and said: How would you act if you survive among the people who would delay prayers beyond their (prescribed) time? He (Abu Dharr) said: What do you command (under this situation)? He (the Holy Prophet) slid: Observe prayer at its prescribed time, then go (to meet) your needs, and if the Iqama is pronounced, and you are present in the mosque, then observe prayer (along with the Jama'at).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1357]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1357

'Abu'l-'Aliyat al-Bara reported: Ibn Ziyad delayed the prayer. 'Abdullah b. Samit came to me and I placed a chair for him and he sat in it and I made a mention of whit Ibn Ziyad had done. He bit hit lips (as a sign of extreme anger and annoyance) and struck at my thigh and said: I asked Abu Dharr as you have asked me, and he struck my thigh just as I have struck your thigh, and said: I asked the Messenger of Allah (may peace be upon him) as you have asked me and he struck my thigh just as I have struck your thigh, and he (the Holy Prophet) said: Observe prayer at its prescribed time, and if you can say prayer along with them. do so, and do not say." I have observed prayer and so I shall not pray."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1358]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1358

Abu Dharr reported: (The Messenger of Allah) said: How would you, or how would thou, act if you survive to live among people who defer prayer beyond the (prescribed) time? (The narrator said: Allah and His Messenger know best). whereupon he said: Observe prayer at its prescribed time, but if the Iqama is pronounced for (congregational) prayer, then observe prayer along with them. for herein is an excess of virtue.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1359]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1359

Abu'l-'Aliyat al-Bara' reported: I said to 'Abdullah b. Samit: We say our Jumu'a prayer behind those rulers who defer the prayer. He ('Abdullah b. Samit), struck. my thigh that I felt pain and said: I asked Abu Dharr about it, he struck my thigh and said: I asked the Messenger of Allah (may peace be upon him) about it. Upon this he said: Observe prayer at its prescribed time, and treat prayer along with them (along with those Imams who deter prayer) as Nafl. 'Abdullah said: It was narrated to me that the Messenger of Allah (may peace be upon him) struck the thigh of Abd Dharr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1360]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1360

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Prayer said in a congregation is twenty-five degrees more excellent than prayer said by a single person.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1361]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1361

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Prayer said in a congregation is twenty-five degrees more excellent than prayer said by a single person. He (Abu Huraira further) said: The angels of the night and the angels of the day meet together. Abu Huraira said: Recite it you like:" Surely the recital of the Qur'an at dawn is witnessed" (al-Qur'an, xvii. 78).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1362]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1362

A hadith like this has been narrated by Abu Huraira with another chain of transmitters with a very slight change of words.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1363]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1363

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Prayer said in a congregation is equivalent to twenty-five (prayers) as compared with the prayer said by a single person.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1364]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1364

Abu Huraira reported: The Messenger of Allah (way peace be upon him) said: Prayer along with the Imam is twenty-five times more excellent than prayer said by a single person.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1365]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1365

Ibn Umar reported Allah's Messenger (may peace be upon him) assaying: Prayer said in a congregation is twenty-seven degrees more excellent than prayer said by a single person.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1366]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1366

Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: The prayer of a person in congregation is twenty-seven times in excess to the prayer said alone.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1367]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1367

Ibn Numair reported it on the authority of his father (a preference of) more than twenty (degrees) and Abu Bakr in his narration (has narrated it) twenty- seven degrees.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1368]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1368

Ibn 'Umar reported from the Apostle of Allah (may peace be upon him) as some and twenty (degrees).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1369]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1369

Abu Huraira reported: The Messenger of Allah (may peace be upon him) found some people absenting from certain prayers and he said: I intend that I order (a) person to lead people in prayer, and then go to the persons who do not join the (congregational prayer) and then order their houses to be burnt by the bundles of fuel. If one amongst them were to know that he would find a fat fleshy bone he would attend the night prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1370]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1370

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The most burdensome prayers for the hypocrites are the night prayer and the morning prayer. If they were to know the blessings they have in store, they would have come to them, even though crawling, and I thought that I should order the prayer to be commenced and command a person to lead people in prayer, and I should then go along with some persons having a fagot of fuel with them to the people who have not attended the prayer (in congregation) and would burn their houses with fire.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1371]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1371

Hammam b. Munabbih reported: This is what Abu Huraira reported to us from the Messenger of Allah (may peace be upon him) and (in this connection) he narrated some ahadith, one of them is: The Messenger of Allah (may peace be upon him) said: I intend that I should command my young men to gather bundles fuel for me, and then order a person to lead people in prayer, and then burn the houses with their inmates (who have not joined the congregation).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1372]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1372

A hadith like this has been narrated by Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1373]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1373

'Abdullah reported Allah's Messenger (may peace be upon him) as saying about people who are absent from Jumu'a prayer: I intend that I should command a person to lead people in prayer, and then burn those persons who absent themselves from Jumu'a prayer in their houses.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1374]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1374

Abu Huraira reported: There came to the Apostle of Allah (may peace be upon him) a blind man and said: Messenger of Allah, I have no one to guide me to the mosque. He, therefore, asked. Allah's Messenger (may peace be upon him) permission to say prayer in his house. He (tee Holy Prophet) granted him permission. Then when the man turned away he called him and said: Do you hear the call to prayer? He said: Yes. He (the Holy Prophet then) said: Respond to it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1375]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1375

'Abdullah (b. Mas'ud) reported: I have seen the time when no one stayed away from prayer except a hypocrite, whose hypocrisy was well known, or a sick man, but it a sick man could walk between two persons (i. e. with the help of two persons with one on each side) he would come to prayer. And (further) said: The Messenger of Allah (may peace be upon him) taught us the paths of right guidance. among which is prayer in the mosque in which the Adzan is called.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1376]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1376

Abdullah (b. Mas'ud) reported: He who likes to meet Allah tomorrow as Muslim, he should persevere in observing these prayers, when a call is announced for them, for Allah has laid down for your Prophet the paths of right guidance, and these (prayers) are among the paths of right guidance. If you were to pray in your houses as this man why stays away (from the mosque) prays in his house, you would abandon the practice of your Prophet, and if you were to abandon the practice of your Prophet, you would go astray. No man purifies himself, doing it well, then makes for one of those mosques without Allah recording a blessing for him for every step he takes raising him a degree for it, and effacing a sin from him for it. I have seen the time when no one stayed away from it, except a hypocrite, who was well known for his hypocrisy, whereas a man would be brought swaying (due to weakness) between two men till he was set up in a row.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1377]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1377

Abu Sha'tha' reported: While we were sitting with Abu Huraira in a mosque a man went out of the mosque after the call to prayer had been announced. (A man stood up in the mosque and set off.) Abu Huraira's eyes followed him till he went out of the mosque. Upon this Abu Huraira said: This man has disobeyed Abu'l- Qasim (Muhammad) (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1378]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1378

Abu Sha'tha' al-Muharibi reported on the authority of his father, who said: I heard it from Abu Huraira that he saw a person getting out of the mosque after the call to prayer had been announced. Upon this he remarked: This (man) disobeyed Abu'l-Qasim (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1379]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1379

'Abd al-Rahman b. Abd 'Amr reported: 'Uthman b. 'Affan (narrated the mosque after evening prayer and sat alone. I also sat alone with him, so he said: 0, son of m brother, I heard tile Messenger of Allah (may peace be upon him) say: He who observed the 'Isya' prayer in congregation, it was as if he prayed up to the midnight, and he who prayed the morning prayer in congregation, it was as if he prayed the whole night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1380]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1380

This hadith has been narrated by the chain of transmitters by Abu Sahl 'Uthman b. Hakim.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1381]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1381

Jundab b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who prayed the morning prayer (in congregation) he is in fact under the protection of Allah. And it can never happen that Allah should demand anything from you in connection with the protection (that He guarantees) and one should not get it. He would then throw him in the fire of Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1382]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1382

Anas b. Sirin reported: I heard Jundab b. Qasri saying that the Messenger of Allah (may peace be upon him) said: He who observed the morning prayer (in congregation), he is in fact under the protection of Allah and it never happens that Allah should make a demand in connection with the protection (that He guarantees and should not get it) for when he asks for anything in relation to His protection, he definitely secures it. He then throws him flatly in the Hell-fire.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1383]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1383

This hadith has been narrated by Jundab b. Sufyan in from the Apostle of Allah (may peace be upon him) with the same chain of transmitters, but this has not been mentioned:" He would throw him in fire."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1384]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1384

Mahmud b. al-Rabi' reported that 'Ibn b. Malik, who was one of the Companions of the Apostle of Allah (may peace be upon him) and who participated in the (Battle of) Badr and was among the Ansar (of Medina), told that he came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, I have lost my eyesight and I lead my people in prayer. When there is a downpour there is then a current (of water) in the valley that stands between me and them and I find it impossible to go to their mosque and lead them in prayer. Messenger of Allah, I earnestly beg of you that you should come and observe prayer at a place of worship (in my house) so that I should then use it as a place of worship. The Messenger of Allah (may peace be upon him) said: Well, it God so wills. I would soon do so. 'Itban said: On the following day when the day dawned, the Messenger of Allah (may peace he upon him) came along with Abu Bakr at-Siddiq, and the Messenger of Allah (may peace be upon him) asked permission (to get into the house). I gave him the permission, and be did not sit after entering the house, when he said: At what place in your house you desire me to say prayer? I ('Itban b. Malik) said: I pointed to a corner in the house, The Messenger of Allah (may peace be upon him) stood (at that place for prayer) and pronounced Allah-o-Akbar (Allah is the Greatest) (as an expression for the commencement of prayer). We too stood behind him, and he said two rak'ahs and then pronounced salutation (marking the end of the prayer). We detained him (the Holy Prophet) for the meat curry we had prepared for, him. The people of the neighbouring houses came and thus there was a good gathering in (our house). One of them said: Where is Malik b. Dukhshun? Upon this one of them remarked: He is a hypocrite; he does not love Allah and His Messenger. Thereupon the Messenger of Allah (may peace be upon him) said: Do not say so about him. Don't you see that he utters La ilaha ill-Allah (There is no god but Allah) and seeks the pleasure of Allah through it? They said: Allah and His Messenger know beet. One (among the audience) said: We see his inclination and wellwishing for hypocrites only. Upon this the Messenger of Allah' (may peace be upon him) again said: Verily Allah has forbidden the Fire for one who says: There is no god but Allah, thereby seeking Allah's pleasure. Ibn Shihab said: I asked Husain b. Muhammad al-Ansar (he was one of the leaders of Banu Salim) about the hadith transmitted by Mahmud b. Rabi' and he testified it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1385]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1385

'Itban b. Malik reported: I came to the Messenger of Allah (may peace be upon him) and the rest of the hadith is the same as narrated (above) except this that a man said: Where is Malik b. Dukhshun or Dukhaishin, and also made this addition that Mahmud said: I narrated this ver hadith to many people and among them was Abu Ayyub al-Ansari who said: I cannot think that the Messenger of Allah (may peace be upon him) could have said so as you say. He (the narrator) said: I took an oath that if I ever go to 'Itban. I would ask him about it. So I went to him and found him to be a very aged man, having lost his eyesight, but he was the Imam of the people. I sat by his side and asked about this hadith and he narrated it In the same way as he had narrated it for the first time. Then so many other obligatory acts and commands were revealed which we see having been completed. So he who wants that he should not be deceived would not be deceived.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1386]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1386

Mahmud b. Rabi' reported: I well remember the disgorge of the Messenger of Allah (may peace be upon him) that he did (with water) from a bucket of our house. Mahmud said: 'Itban b. Malik narrated it to me that he had said: Messenger of Allah, I have lost my eyesight, and the rest of the hadith is the same up to these words:" He led us in two rak'ahs of prayer and we detained the Messenger of Allah (may peace be upon him) for serving him the pudding that we had prepared for him," and no mention has been made of what follows next from the addition made by Yunus and Ma'mar.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1387]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1387

Anas b. Malik reported that his grandmother, Mulaika, invited the Messenger of Allah (may peace be upon him) to a dinner which she had prepared. He (the Holy Prophet) ate out of that and then said: Stand up so that I should observe prayer (in order to bless) you Anas b. Malik said: I stood up on a mat (belonging to us) which had turned dark on account of its long use. I sprinkled water over it (in order to soften it), and the Messenger of Allah (may peace be upon him) stood upon it, and I and an orphan formed a row behind him (the Holy Prophet) and the old woman was behind us, and the Messenger of Allah (may peace be upon him) led us in two rak'ahs of prayer and then went back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1388]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1388

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) wits the best among people in character. On occasions, the time of prayer would come while he was in our house. He would then order to spread the mat lying under him. That was dusted and then water was sprinkled over it. The Messenger of Allah (may peace be upon him) then led the prayer and we stood behind him, and that mat was made of the leaves of date-palm.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1389]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1389

Thabit reported on the authority of Anas: The Apostle of Allah (may peace be upon him) came to us and there was none in our house but I, my mother and my aunt Umm Haram. He (the Holy Prophet) said: Stand up so that I may lead you in prayer (and there was no time for prescribed prayer). He led us in prayer. A person said to Thabit: Where stood Anas with him (the Holy Prophet)? He replied: He was on the right side. He then blessed us, the members of the household with every good of this world and of the Hereafter. My mother said: Messenger of Allah (and then, pointing towards Anas, said), here is your little servant, invoke the blessing of Allah upon him too. He then blessed me with every good, and he concluded his blessings for me (with these words): Allah! increase his wealth, and his children and make (them the source of) blessing for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1390]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1390

Abdullah b. al-Mukhtar heard Musa b. Anas narrating on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) led him, his mother or his aunt in prayer. He made me, stand on his right side and made the woman stand, behind us.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1391]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1391

This hadith has also been narrated by Shu'ba with this chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1392]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1392

Maimuna, the wife of the Apostle of Allah (may peace be upon him), reported: The Messenger of Allah (may peace be upon him) said prayer while I was by his side, and at times when he prostrated his cloth touched me, and he prayed on a small mat.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1393]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1393

Abu Sa'id al-Khudri reported that he went to the Messenger of Allah (may peace be upon him) and found him observing prayer on a mat and prostrating on that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1394]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1394

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A man's prayer in congregation is more valuable than twenty degrees and some above them as compared with his prayer in his house and his market, for when he performs ablution doing it well, then goes out to the mosque, and he is impelled (to do so) only by (the love of congregational) prayer, he has no other objective before him but prayer. He does not take a step without being raised a degree for it and having a sin remitted for it, till he enters the mosque, and when he is busy in prayer after having entered the mosque. the angels continue to invoke blessing on him as long as he is in his place of worship. saying: O Allah, show him mercy, and pardon him! Accept his repentance (and the angels continue this supplication for him) so long as he does not do any harm in it, or as long as his ablution is not broken.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1395]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1395

A hadith having the same meaning (as mentioned above) has been transmitted by A'mash.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1396]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1396

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The angels invoke blessings on everyone among you so long as he is in a place of worship with these words: O Allah! pardon him, O Allah, have mercy upon him, (and they continue to do so) as long as, he ablution (of the worshipper) is not broken, and one among you is in prayer and so long as he is detained for the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1397]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1397

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The servant is constantly in prayer so long as he is in a place of worship waiting for the prayer (to be observed in congregation), and the angels invoke (blessings upon him in these words): O Allah! pardon him. O Allah! show mercy to him, (and they continue to do so) till he returns (from the mosque having completed the prayer) or his ablution breaks. I said: How is the ablution broken? He said: By breaking of the wind noiselessly or with noise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1398]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1398

Abu Huraira reported the Messenger of Allah (may peace be upon him) as saying: Everyone among you is constantly in prayer so long as the prayer detains him (for this noble objective) and nothing prevents him to return to his family but the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1399]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1399

Abu Huraira reported: The Messenger of Allah (may peace be upon him) said: Anyone amongst you who sat in a place of worship waiting for the prayer is in prayer and his ablution is not broken, the angels invoke blessing upon him (in these words): O Allah! pardon him. O Allah! have mercy upon him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1400]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1400

A hadith like this has been narrated by Hammam b. Munabbih on the authority of Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1401]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1401

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The most eminent among human beings (as a recipient of) reward (is one) who lives farthest away, and who has to walk the farthest distance, and he who waits for the prayer to observe it along with the Imam, his reward is greater than one who prays (alone) and then goes to sleep. In the narration of Abu Kuraib (the words are):" (He waits) till he prays along with the Imam in congregation."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1402]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1402

Ubayy b. Ka'b reported: There was a man, and I do not know of any other man, whose house was farther than his from the mosque and he never missed the prayer (in congregation). It was said to him or I said to him: It you were to buy a donkey you could ride upon it In the dark nights and in the burning sand. He said: I do not like my house to be situated by the side of the mosque, for I (eagerly) desire that my steps towards the mosque and back from it, should be recorded when I return to my family. Upon this the Messenger of Allah (may peace be upon him) said: Allah has gathered all (rewards) for you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1403]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1403

This hadith has been transmitted by Taimi with the same chain of narrators.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1404]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1404

Ubayy b. Ka'b reported: There was a person among the Ansar whose house was situated at the farthest end of Medina, but he never in missed any prayer along with the Messenger of Allah (may peace be upon him). We felt pity for him and said to him: O, so and so, had you bought a donkey it would have saved you from the burning sand and would have saved you from the reptiles of the earth. He said: Listen I by Allah, I do not like my house to be situated by the side of Muhammad (may peace be upon him). I took (these words of his) ill and came to the Apostle of Allah (may peace be upon him) and informed him about (these words). He (the Holy Prophet) called him and he said exactly like that (which he had mentioned to Ubbay b. Ka'b), but made a mention of this (also) that he wanted a reward for his steps. Upon this the Apostle of Allah (may peace be upon him) said: In fact for you is the reward which you expect.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1405]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1405

A hadith like this has been narrated by 'Asim with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1406]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1406

Jabir b. 'Abdullah narrated: Our houses were situated far away from the mosque; we, therefore, decided to sell our houses so that we may be able to come near the mosque. The Messenger of Allah (may peace be upon him) forbade us (to do so) and said: There is for every step (towards the mosque) a degree (of reward) for you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1407]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1407

Jabir b. Abdullah reported: There were some plots vacant around the mosque. Banu Salama decided to shift (to this land) and come near the mosque. This (news) reached the Messenger of Allah (may peace be upon him) and he said to them (Banu Salama): I have received (information) that you intend to shift near the mosque. They said: Yes, Messenger of Allah, we have taken this decision. Upon this he (the Holy Prophet) said: O Banu Salama, live in your houses, for your steps are recorded; live in your houses, for your steps are recorded.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1408]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1408

Jabir b. Abdullah reported that Banu Salama decided to shift near the mosque (as there were) some plots vacant. This (news) reached the Apostle of Allah (may peace be upon him), whereupon he said: O people of the Salama tribe, you better stay in your houses (where you are living), for your footsteps are recorded They said. We could not be more delighted even by shifting (near the mosque) as we were delighted (on hearing these words from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1409]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1409

Abu Huraira reported: The Messenger of Allah (may peace be' upon him) said: He who purified himself in his house, and then he walked to one of the houses of Allah for the sake of performing a Fard (obligatory act) out of the Fara'id (obligatory acts) of Allah, both his steps (would be significant) as one of them would obliterate his sin and the second one would raise his status.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1410]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1410

In the hadith narrated of the authority of Abd Huraira the Messenger of Allah (may peace be upon him) is reported to have said. while in the hadith narrated by Bakr (the words are like this): He heard the Messenger of Allah (may peace be upon him) as saying: just see, can anything of his filthiness remain (on the body of) any one of you if there were a river at his door in which he washed himself five times daily? They, said: Nothing of his filthiness will remain (on his body). He said: That is like the five prayers by which Allah obliterates sins.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1411]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1411

Jabir b. 'Abdullah reported that the Messenger of Allah (may peace be upon him) said: The similitude of five prayers is like an overflowing river passing by the gate of one of you in which he washes five times daily Hasan said: No filthiness can remain on him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1412]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1412

Ata' b. Yasar reported, on the authority of Abu Huraira, the Apostle of Allah (may peace be upon him) as saying: He who went towards the mosque in the morning or evening, Allah would arrange a feast for him morning or evening in Paradise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1413]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1413

Simak b. Harb reported: I said to Jabir b. Samura: Did you sit in the company of the Messenger of Allah (may peace he upon him)? He said: Yes, very often. He (the Holy Prophet) used to sit at the place where he observed the morning or dawn prayer till the sun rose or when it had risen; he would stand, and they (his Companions) would talk about matters (pertaining to the days) of ignorance, and they would laugh (on these matters) while (the Holy Prophet) only smiled.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1414]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1414

Simak narrated on the authority of Jabir b. Samura that when the Apostle of Allah (may peace be upon him) observed the dawn prayer, he sat at the place of worship till the sun had risen enough.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1415]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1415

This hadith has been narrated by Simak with the same chain of transmitters, but no mention has been made of, enough".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1416]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1416

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: The parts of land dearest to Allah are its mosques, and the parts most hateful to Allah are markets.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1417]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1417

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: When there are three persons, one of them should lead them. The one among them most worthy to act as Imam is one who is best versed in the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1418]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1418

A hadith like this has been narrated by Qatida with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1419]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1419

This hadith has been narrated by Abu Sa'id al-Khudri by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1420]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1420

Abu Mas'ud al-Ansari reported Allah's Messenger (may peace be upon him) as saying: The one who is most versed in Allah's Book should act as Imam for the people, but If they are equally versed in reciting it, then the one who has most knowledge regarding Sunnah if they are equal regarding the Sunnah, then the earliest one to emigrate; it they emigrated at the same time, then the earliest one to embrace Islam. No man must lead another in prayer where (the latter) has authority, or sit in his place of honour in his house, without his permission. Ashajj in his narration used the word," age" in place of" Islam".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1421]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1421

A hadith like this has been narrated by A'mash by the same chain of transmitters


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1422]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1422

Abu Mas'ud al-Ansari reported: The Messenger of Allah (may peace be upon him) said to us: The one who is well grounded in Allah's Book and is distinguished among them in recitation should act as; Imam for the people. and if they are equally versed in reciting it, then the one who has most knowledge regarding Sunnah; if they are equal regarding the Sunnah, then the earliest one to emigrate; If they emigrated at the same time, then the oldest one in age. No man must lead another in prayer in latter's house or where (the latter) has authority, or sit in his place of honour in his house, except that he gives you permission or with his permission.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1423]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1423

Malik b. Huwairith rejected: We came to the Messenger of Allah (may peace be upon him) and we were all young men of nearly equal age. We stayed with him (the Holy Prophet) for twenty nights, and as the Messenger of Allah may peace be upon him) was extremely kind and tender of heart, he. therefore, thought that we were eager (to see) our family (we felt home-sickness). So he asked us about the members of the family that we had left behind and when we informed him, he said: Go back to your family, stay with them, and teach them (beliefs and practices of Islam) and exhort them to good, and when the time for prayer comes, one amongst you should-announce Adzan and then the oldest among you should lead the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1424]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1424

This hadith has been transmitted by Ayyub with the same chain of narrator.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1425]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1425

Malik b. Huwairith Abu Sulaiman reported: I came to the Messenger of Allah (may peace be upon him) along with other persons and we were young men of nearly equal age, and the rest of the hadith was transmitted like the hadith narrated before.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1426]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1426

Malik b Huwairith reported: I came to the Apostle of Allah (may peace be upon him) along with a companion of mine, and when we intended to return from him, he said: When there is time for prayer, announce prayer, pronounce Iqama, and the oldest amongst you should lead the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1427]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1427

This hadith has been narrated with the same chain of transmitters, but al-Hadra' made this addition:" They both were equal in recitation."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1428]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1428

Abu Salama b. Abd al-Rahman b. 'Auf heard Abu Huraira say: (When) Allah's Messenger (may peace be upon him) (wished to invoke curse or blessing on someone, he would do so at the end) of the recitation in the dawn prayer, when he had pronounced Allah-o-Akbar (for bending) and then lifted his head (saying):" Allah listened to him who praised Him; our Lord! to Thee is all praise" ; he would then stand up and say:" Rescue al-Walid b. Walid, Salama b. Hisham, and 'Ayyash b. Abd Rabi'a, and the helpless among the Muslims. O Allah! trample severely Mudar and cause them a famine (which broke out at the time) of Joseph. O Allah! curse Lihyan, Ri'l, Dhakwan, 'Usayya, for they disobeyed Allah and His Messenger." (The narrator then adds): The news reached us that he abandoned (this) when this verse was revealed:" Thou but no concern in the matter whether He turns to them (mercifully) or chastises them; surely they are wrongdoers" (ill. 127)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1429]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1429

This hadith has been narrated on the authority of Abu Huraira by another chain of transmitters up to the words:" And cause them a famine like that (which broke out at the time) of Joseph," but the subsequent portion was not mentioned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1430]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1430

Abu Salama reported it on the authority of Abu Huraira that the Apostle of Allah (may peace be upon him) recited Qunut after ruku' in prayer for one mouth at the time of reciting (these words):" Allah listened to him who praised Him," and he said in Qunut:" 0 Allah! rescue al-Walid b. al-Walid; O Allah! rescue Salama b. Hisham; O Allah! rescue 'Ayyash b. Abu Rabi'a; O Allah! rescue the helpless amongst the Muslims; O Allah! trample Mudar severely; O Allah! cause them a famine like that (which was caused at the time) of Joseph." Abu Huraira (further) said: I saw that the Messenger of Allah (may peace be upon him) afterwards abandoned this supplication. I, therefore said: I see the Messenger of Allah (may peace be upon him) abandoning this blessing upon them. It was raid to him (Abu Huraira): Don't you see that (those for whom was blessing invoked by the Holy Prophet) have come (i. e. they have been rescued)?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1431]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1431

Abu Salama narrated that Abu Huraira told him that when the Messenger of Allah (may peace be upon him) pronounced:" Allah listened to him who praised Him." and before prostration, he would recite this in the 'Isya' prayer: O Allah! rescue 'Ayyash b. Abu Rabi'a, and the rest of the hadith is the same as narrated by Auza'i to the words:" Like the famine (at the time) if Joseph." but he made no mention of that which follows afterwards.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1432]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1432

Abu Salama b. 'Abd al-Rahman is reported to have said that he had heard Abu Huraira saying: I would say prayer along with you which is near to the prayer of the Messenger of Allah (may peace be upon him). and Abu Huraira recited Qunut in the noon and in the 'Isya' and in the morning prayer, and invoked blessing (of Allah) upon Muslims-and curse upon the unbelievers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1433]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1433

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) invoked curse in the morning (prayer) for thirty days upon those who killed the Companions (of the Holy Prophet) at Bi'r Ma'una. He cursed (the tribes) of Ri'l, Dhakwan, Lihyan, and Usayya, who had disobeyed Allah and His Messenger (may peace be upon him). Anas said: Allah the Exalted and Great revealed (a verse) regarding those who were killed at Bi'r Ma'una, and we recited it, till it was abrogated later on (and the verse was like this):, convey to it our people the tidings that we have met our Lord, and He was pleased with us and we were pleased with Him".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1434]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1434

Muhammad reported: I asked Anas whether the Messenger of Allah (may peace be upon him) observed Qunut in the dawn prayer. He said: Yes, (he did so) after the ruku', for a short while.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1435]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1435

Anas b. Malik reported: The Messenger of Allah (may peace be upon him) observed Qunut for a month in the dawn prayer after ruku' and invoked curse upon Ri'l, Dhakwan, and said that 'Usayya had disobeyed Allah and His Apostle (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1436]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1436

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) observed Qunut for a month in the dawn prayer after ruku' and invoked curse upon Bani Usayya.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1437]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1437

Asim reported: I asked Anas whether Qunut was observed (by the Holy prophet) before ruku' or after ruku'. He replied: Before ruku'. I said: People conceive that the Messenger of Allah (may peace be upon him) observed Qunut after the ruku'. He said: The Messenger of Allah (may peace be upon him) observed Qunut (after the ruku' as the people conceive it) for a mouth invoking curse upon those persons who had killed men among his Companions who were called the reciter (of the Qur'an).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1438]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1438

'Asim reported - I heard Anas saying: Never did I ace the Messenger of Allah (may peace be upon him) so much grieved (at the loss of a) small army as I saw him grieved at those seventy men who were called" reciters" (and were killed) at Bi'r Ma'una; and he invoked curse for full one month upon their murderers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1439]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1439

This hadith has been narrated by Anas with another chain of transmitters and with minor additions.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1440]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1440

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) observed Qunut for one month Invoking curse upon Ri'l, Dhakwan, 'Usayya. those who disobeyed Allah and His Messenger (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1441]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1441

A hadith like this has been transmitted by Anas from the Apostle of Allah (way peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1442]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1442

Anas reported that the Messenger of Allah (may peace be upon him) observed Qunut for one month invoking curse upon some tribes of Arabia (those who were responsible for the murders in Bi'r Ma'una and Raji'), but then abandoned it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1443]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1443

Al-Bari' b. 'Azib reported that the Messenger of Allah (may peace be upon him) observed Qunut in the morning and evening (prayers).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1444]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1444

Al-Bari' reported that the Messenger of Allah (may peace be upon him) observed Qunut in the dawn and evening (prayers).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1445]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1445

Khufaf b. Ima' al-Ghifari reported that the Messenger of Allah (may peace be upon him) aid in prayer: 0 Allah I curse the tribes of Lihyan, Ri'l, Dhakwan, and 'Usayya for they disobeyed Allah and His Messenger (may peace be upon him). Allah pardoned (the tribe of) Ghifar and Allah granted protection to (the tribe of) Aslam


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1446]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1446

Khufaf b. Ima' reported that the Messenger of Allah (may peace he upon him), bowed (in prayer) and then lifted his head and then said: So far as the tribe of Ghifar is concerned, Allah had pardoned it, and Allah had granted protection to the tribe of Aslam, and as for the tribe of Usayya, It had disobeyed Allah and His Messenger, (and further said): O Allah! curse the tribe of Lihyan curse Ri'l, and Dhakwan, and then fell in prostration. It is after this that the cursing of the unbelievers got a sanction.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1447]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1447

A hadith like this has been transmitted by Khufaf b. Ima' except this that he did not mention (these words):" cursing of unbelievers got a sanctions.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1448]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1448

Abu Huraira reported that when the Messenger of Allah (may peace be upon him) returned from the expedition to Khaibar, he travelled one night, and stopped for rest when he became sleepy. He told Bilal to remain on guard during the night and he (Bilal) prayed as much as he could, while the Messenger of Allah (may peace be upon him) and his Companions slept. When the time for dawn approached Bilal leaned against his camel facing the direction from which the dawn would appear but he was overcome by sleep while he was leaning against his camel, and neither the Messenger of Allah (may peace be upon him) nor Bilal, nor anyone else among his Companions got up, till the sun shone on them. Allah's Messenger (may peace be upon him) was the first of them to awake and, being startled, he called to Bilal who said: Messenger of Allah I may my father and mother be offered as ransom for thee, the same thing overpowered me which overpowered you. He (the Holy Prophet, then) said: Lead the beasts on: so they led their camels to some distance. The Messenger of Allah (may peace be upon him) then performed ablution and gave orders to Bilal who pronounced the Iqama and then led them in the morning prayer. When he finished the prayer he said: When anyone forgets the prayer, he should observe it when he remembers it, for Allah has said:" And observe the prayer for remembrance of Me" (Qur'an. xx. 14). Yunus said: Ibn Shilab used to recite it like this:" (And observe the prayer) for remembrance."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1449]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1449

Abu Huraira reported: We stopped for rest along with the Apostle of Allah (may peace be upon him) and did not awake till the sun rose. The Apostle of Allah (may peace be upon him) then told us that everybody should take hold of his camel's nosestring (get out of this ground) for it was the place where devil had visited us. We did accordingly. He then called for water and performed ablution and then performed two prostrations. Ya'qub said: Then he prayed (performed) two prostrations. then takbir was pronounced for prayer and then he offered the morning prayer (in congregation).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1450]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1450

Abu Qatida reported: The Messenger of Allah (way peace be upon him) addressed us and said: You would travel In the evening and the might till (God willing) you would come in the morning to a place of water. So the people travelled (self absorbed) without paying any heed to one another, and the Messenger of Allah (may peace be upon him) also travelled till It was midnight. I was by his side. The Messenger of Allah (may peace be upon him) began to doze and leaned (to one side) of his camel. I came to him and I lent him support without awaking him till he sat poised on his ride. He went on travelling till a major part of the night was over and (he again) leaned (to one side) of his camel. I supported him without awaking him till he sat" bed on his ride. and then travelled till it was near dawn. He (again) leaned which was far more inclined than the two earlier leanings and he was about to fall down. So I came to him and supported him and he lifted his head and said; Who is this? I said: it is Abu Qatida. He (the Holy Prophet again) said: Since how long have you been travelling along with me like this? I said: I have been travelling in this very state since the night. He said: May Allah protect you, as you have protected His Apostle (from falling down), and again said: Do you see that we are hidden from the people? - and again said: Do you see anyone? I said: Here is a rider. I again said: Here Is another rider till we gathered together and we were seven riders. The Messenger of Allah (may peace be upon him) stepped aside of the highway and placed his head (for sleep and said): Guard for us our prayers. The Messenger of Allah (may peace be upon him) was the first to wake up and the rays of the sun were falling on his back. We got up startled He (the Holy Prophet) said: Ride on So we rode on till the sun had (sufficiently) risen. He then came down from his camel and called for a jug of water which I had with me. There was a little water in that. He performed ablution with that which was less thorough as compared with his usual ablutions and some water of that had been left. He (the Holy Prophet) said to Abu Qatida: Keep a watch over your jug of water; it would have (a miraculous) condition about it. Then Bilal summoned (people) to prayer and then the Messenger of Allah (may peace be upon him) observed two rak'ahs and then said the morning prayer as he said every day. The Messenger of Allah (may peace be upon him) (then) rode on and we rode along with him and some of us whispered to the others saying: How would there be compensation for omission in our prayers? Upon this he (the Apostle of Allah) said: Is there not in me (my life) a model for you? There is no omission in sleeping. The (cognizable) emission is that one should not say prayer (intentionally) till the time of the other prayer comes. So he who did like it (omitted prayer in sleep or due to other unavoidable circumstances) should say prayer when he becomes aware of it and on the next day he should observe it at its prescribed time.

He (the Holy Prophet) said: What do you think the people would have done (at this hour)? They would have in the morning found their Apostle missing from amongst them and then Abu Bakr and 'Umar would have told them that the Messenger of Allah (may peace be upon him) must be behind you, he cannot leave you behind (him), but the people said: The Messenger of Allah (may peace be upon him) is ahead of you. So if you had obeyed Abu Bakr and Umar, you would have gone on the right path. So we proceeded on till we came up to the people (from whom we had lagged behind) and the day had considerably risen and everything became hot, and they (the Companions of the Holy Prophet) said: Messenger of Allah, we are dying of thirst. Upon this he (the Holy Prophet) remarked: There is no destruction for you. And again said: Bring that small cup of mine and he then asked for the jug of water to be brought to him. The Messenger of Allah (may peace be upon him) began to pour water (in that small cup) and Abu Qatida gave them to drink. And when the people saw that there was (a little) water in the jug, they fell upon it. Upon this the Messenger of Allah (may peace be upon him) said: Behave well; the water (is enough) to satiate all of you. Then they (the Companions) began to receive (their share of) water with calmness (without showing any anxiety) and the Messenger of Allah (may peace be upon him) began to fill (the cap), and I began to serve them till no one was left except me and the Messenger of Allah (may peace be upon him). He then filled (the cup) with water and said to me: Drink it. I said: Messenger of Allah, I would not drink till you drink. Upon this he said: The server of the people Is the last among them to drink. So I drank and the Messenger of Allah (may peace be upon him) also drank and the people came to the place of water quite happy and satiated. 'Abdullah b. Rabah said: I am going to narrate this hadith in the great mosque, when 'Imran b. Husain said: See, O young man, how will you narrate for I was also one of the riders on that night? I said: So you must be knowing this hadith well. He said: Who are you? I said: I am one of the Ansar. Upon this he said: You narrate, for you know your hadith better. I, therefore, narrated it to the people. 'Imran said: I was also present that night, but I know not anyone else who learnt it so well as you have learnt.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1451]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1451

'Imran b. Husain reported: I was with the Apostle of Allah (may peace be upon him) in a journey. We travelled the whole of the night, and when it was about to dawn, we got down for rest, and were overpowered (by sleep) till the sun shone. Abu Bakr was the first to awake amongst us. and we did not awake the Apostle of Allah (may peace be upon him) from his sleep allowing him to wake up (of his own accord). It was 'Umar who then woke up. He stood by the side of the Apostle of Allah (may peace be upon him) and recited takbir in a loud voice till the Messenger of Allah (may peace be upon him) woke up. When he lifted his head, he saw that the sun had arisen; he then said: Proceed on. He travelled along with us till the sun shone brightly. He came down (from his camel) and led us in the morning prayer. A person, however, remained away from the people and did not say, prayer along with us. After having completed the prayer, the Messenger of Allah (may peace be upon him) said to him: O, so and so, what prevented you from observing prayer with us? He said: Apostle of Allah! I was not in a state of purity. The Messenger of Allah (may peace be upon him) ordered him arid lie performed Tayammum with dust and said prayer. He then urged me to go ahead immediately along with other riders to find out water, for we felt very thirsty. We were traveling when we came across a woman who was sitting (on a camel) with her feet hanging over two leathern water bags. We said to her: How far is water available? She, said: Far, very far, very far. You cannot get water. We (again) said: How much distance is there between (the residence of) your family and water? She said: It is a day and night journey. We said to her: You go to the Messenger of Allah (may peace be upon him). She said: Who is the Messenger of Allah? We somehow or the other managed to bring her to the Messenger of Allah (may peace be upon him) and he asked about her, and she informed him as she had informed us that she was a widow having orphan children. He ordered that her camel should be made to kneal down and he gargled in the opening (of her leathern water-bag). The camel was then raised up and we forty thirsty men drank water till we were completely satiated, and we filled up all leathern water-bags and water-skins that we had with us and we washed our companions, but we did not make any camel drink, and (the leathern water-bags) were about to burst (on account of excess of water). He then said: Bring whatever you have with you. So we collected the bits (of estable things) and dates and packed them up in a bundle, and said to her: Take it away. This is meant for your children, and know that we have not its any way done any loss to your water. W hen she came to her family she said: I have met the greatest magician amongst human beings, or he is an apostle, as he claims to be, and she then narrated what had happened and Allah guided aright those people through that woman. She affirmed her faith in Islam and so did the people embrace Islam.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1452]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1452

'Imran b. Husain reported: We were with the Messenger of Allah (may peace be upon him) in a journey and we travelled throughout the night till at the end, just before dawn, we lay down (for rest), and nothing is sweeter for a traveller than this and none awakened us but the heat of the sun, and the rest of the hadith is the same (as mentioned above) except this additien:" When 'Umar b. Khattab woke up, he saw what had happened to the people. And he was a man having a big belly and strongly built; he recited takbir in a loud voice till the Messenger of Allah (may peace be upon him) woke up by the loudness of his voice in takbir. When the Messenger of Allah (may peace be upon him) got up, the people told him what had happened. Upon this the Messenger of Allah (may peace be upon him) said: There is no harm; you better proceed further," and (the rest of the hadith) was narrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1453]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1453

Abu Qatada reported that when the Messenger of Allah (may peace be upon him) was in a journey he got down for rest at night, and he used to lie down on his right side, and when he lay down for rest before the dawn, he used to stretch his forearm and place his head over his palm.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1454]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1454

Qatada reported from Anas b. Malik that the Messenger of Allah (may peace be upon him) said: He who forgets the prayer should say it when he remembers it, there is no explation for it, except this. Qatada said: (Allah says)" And observe prayer for remembrance of Me"


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1455]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1455

This hadith has been narrated by Qatada, but here no mention has been made of" There is no explation for it except this."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1456]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1456

Qatada narrated it on the authority of Anas b. Malik that the Apostle of Allah (may peace be upon him) said: He who forgets tte prayer, or he slept (and it was omitted), its expiation is this only that he should observe it when he remembers it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1457]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1457

Qatada reported it on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: When any one of you omits the prayer due to sleep or he forgets it, he should observe it when he remembers it, for Allah has said:" Observe prayer for remembrance of Me."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1458]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1458

'A'isha, the wife of the Messenger of Allah (may peace be upon him), reported: The prayer was prescribed as two rak'abs, two rak'ahs both in journey and at the place of residence. The prayer while travelling remained as it was (originally prescribed), but an addition was made in the prayer (observed) at the place of residence.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1459]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1459

'A'isha, the wife of the Messenger of Allah (may peace be upon him), said Allah prescribed the prayer as two rak'ahs, then it was completed (to four rak'ahs) at the place of residence, but was retained in the same position in journey as it was first made obligatory.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1460]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1460

'A'isha reported: The prayer was prescribed as consisting of two rak'abs, the prayer in travelling remained the same, but the prayer at the place of residence was completed. (Zuhri said he asked 'Urwa why 'A'isha said prayer in the complete form during journey, and he replied that she interpreted the matter herself as 'Uthman did.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1461]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1461

Yahya b. Umayya said: I told 'Umar b. al-Khattab that Allah had said:" You may shorten the prayer only if you fear that those who are unbelievers may afflict you" (Qur'an, iv. 101), whereas the people are now safe. He replied: I wondered about it in the same way as you wonder about it, so I asked the Messenger of Allah (may peace be upon him) about it and he said: It is an act of charity which Allah has done to you, so accept His charity.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1462]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1462

Ya'la b. Umayya reported: I said to 'Umar b. al-Khattab, and the rest of the hadlth is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1463]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1463

Ibn 'Abbas reported: Allah has prescribed the prayer through the word of your Prophet (may peace be upon him) as four rak'ahs when resident, two when travelling, and one when danger is present.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1464]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1464

Ibn 'Abbas reported: Allah has prescribed the prayer by the tongue of your Apostle (may peace be upon him) as two rak'ahs for the traveller, four for the resident, and one in danger.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1465]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1465

Musa b. Salama Hudhali said: I asked Ibn 'Abbas: How should I say prayer when I am in Mecca, and when I do not pray along with the Imam? He said: Two rak'ahs (of prayer) is the Sunnah of Abu'l-Qasim (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1466]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1466

A hadith like this has been narrated by Abu Qatada with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1467]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1467

Hafs b. 'Asim said: I accompanied Ibn 'Umar on the road to Mecca and he led us in two rak'ahs at the noon prayer, then he went forward and we too went along with him to a place where he alighted, and he sat and we sat along with him, and he cast a glance to the side where he said prayer and he saw people standing and asked: What are they doing? I said: They are engaged in glorifying Allah, offering Sunnah prayer. He said: If I had done so I would have perfected my prayer; O my nephew! I accompanied the Messenger of Allah (may peace be upon him) on a journey, and he made no addittion to two rak'ahs, till Allah called him. I accompanied Abu Bakr and he made no addition to two rak'ahs till Allah caused him to die. I accompanied 'Umar and he made no addition to two rak'ahs till Allah caused him to die. I accompanied 'Uthman and he made no addition to two rak'ahs, till Allah caused him to die, and Allah has said:" There is a model pattern for you in the Messenger of Allah" (al-Qur'an, xxxiii. 21).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1468]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1468

Hafs b. 'Asim reported: I fell ill and lbn 'Umar came to inquire after my health, and I asked him about the glorification of Allah (i. e. prayer) while travelling. Thereupon he said: I accompanied the Messenger of Allah (may peace be upon him) on a journey but I did not see him glorifying Him, and were I to glorify (Him). I would have completed the prayer. Allah, the Exalted, has said:" Verily there is a model pattern for you in the Messenger of Allah."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1469]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1469

Anas reported: The Messenger of Allah (may peace be upon him) said four rak'ahs in the noon prayer while at Medina, but he offered two rak'ahs in the afternoon prayer at Dhu'l-Hulaifa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1470]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1470

Anas b. Malik is reported to have said: I observed four rak'ahs in the noon prayer with the Messenger of Allah (may peace be upon him) at Medina, and said two rak'ahs in the afternoon prayer at Dhu'l-Hulaifa.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1471]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1471

Yahya b. Yazid al-Huna'i reported: I asked Anas b. Malik about shortening of prayer. He said: When the Messenger of' Allah (may peace be upon him) had covered a distance of three miles or three farsakh (Shu'ba, one of the narrators, had some doubt about it) he observed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1472]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1472

Jubair b. Nufair reported: I went along with Shurahbil b. al-Simt to a village which was situated at a distance of seventeen or eighteen miles, and he said only two rak'ahs of prayer. I said to him (about it) and he said: I saw 'Umar observing two rak'ahs at Dhu'l-Hulaifa and I (too) said to him (about it) and he said: I am doing the same as I saw the Messenger of Allah (may peace be upon him) doing. (This hadith has been transmitted by Shu'ba with the same chain of narrators and it is narrated from Simt, and the name of Shurahbil has not been mentioned, and he said that he had gone to a place called Dumin, situated at a distance of eighteen miles from Hims.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1473]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1473

Anas b. Malik reported: We went out from Medina to Mecca with the Messenger of Allah (may peace be upon him) and he prayed two rak'ahs at each time of prayer till we returned to Medina. I said: For how long did he stay in Mecca? He said: (For) ten (days).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1474]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1474

A hadith like this has been narrated by Anas by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1475]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1475

Yahya b. Abu Ishaq reported: I heard Anas b. Malik say: We went out for Pilgrimage from Medina. The rest is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1476]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1476

A hadith like this has been transmitted by Anas, but no mention has been made of Pilgrimage.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1477]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1477

Salim b. 'Abdullah (b. 'Umar) reported on the authority of his father that Allah's Messenger (way peace be upon him) observed the prayer of a traveller, i. e. two rak'ahs in Mina, and other places; so did Abu Bakr and 'Umar, and 'Uthman too observed two rak'abs at the beginning of his caliphate, but he then completed four.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1478]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1478

A hadith like this has been reported by Zuhri, with the same chain of transmitters, and in it mention was made of Mina only, but not of other places.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1479]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1479

Ibn 'Umar reported: The Messenger of Allah (may peace be upon him) said two rak'ahs at Mina, and Abu Bakr after him, and 'Umar after Abu Bakr, and 'Uthman at the beginning of his caliphate; then 'Uthman observed four rak'ahs, and when Ibn 'Umar prayed with the Imam, he said four rak'ahs, but when he observed prayer alone, he said two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1480]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1480

A hadith like this has been narrated by the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1481]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1481

Ibn 'Umar reported: The Apostle of Allah (may peace be upon him) said in Mina the prayer of a traveller (short prayer) ; Abu Bakr and 'Umar did the same and 'Uthmia did it for eight years or six years. Hafs (one of the narrators) said: Ibn 'Umar would also say two rak'ahs at Mina and then go to bed. I said to him: O uncle, I wish you could have said two rak'ahs (of Sunnah prayer after shorenting the Fard prayer). He said: Were I to do that, I would have completed the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1482]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1482

This hadith has been narrated by Shu'ba with the same chain of transmitters but no mention has been made of Mina, but they (the narrators) only said: He prayed while travelling.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1483]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1483

Ibrahim reported: I heard 'Abd al-Rahman as saying; 'Uthman led us four rak'ahs of prayer at Mina. It was reported to Abdullah b. Mas'ud and he recited:" Surely we are Allah's and to Him shall we return," and then said: I prayed with the Messenger of Allah (may peace be upon him) at Mina two rak'ahs of prayer. I prayed along with Abu Bakr al-Siddiq two rak'ahs of prayer at Mina. I prayed along with 'Umar b. Khattab two rak'ahs of prayer at Mina. I wish I had my share of the two rak'ahs acceptable (to God) for the four rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1484]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1484

A hadith like this has been reported by A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1485]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1485

Haritha b. Wahb reported: I prayed with the Messenger of Allah (may peace be upon him) two rak'abs and most of them offered two rak'ahs only in Mina, while the people felt secure.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1486]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1486

Wahb al-Khuza'i reported: I prayed behind the Messenger of Allah (way peace be upon him) at Mina, and there was the greatest number of people, and they prayed two rak'ahs on the occasion of the Farwell Pilgrmage. (Muslim said: Haritha b. Wahb al-Khuza'i is the brother of 'Ubaidullah b. 'Umar son of Khattab from the side of mother.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1487]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1487

Ibn 'Umar announced Adhan for prayer on a cold, windy night. Then added: Pray in your dwellings; and then said: When it was a cold, rainy night, the Messenger of Allah (may peace be upon him) used to command the Mu'adhdhin to say" Pray in your dwellings."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1488]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1488

Ibn 'Umar reported that he summoned (people) to pray on a cold, windy and rainy night, and then observed at the end of the Adhin: Pray in your dwellings, pray in your dwellings, and then said: When it was a cold night or it was raining in a journey the Messenger of Allah (may peace he upon him) used to command the Mu'adhdhin to announce: Pray in your dwellings.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1489]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1489

Ibn 'Umar reported that he summoned (people) to prayer at a place (known as) Dajnan, and the rest of the hadith is the same, and then said: Pray in your dwellings, but he did not repeat for the second time words of Ibn 'Umar (Pray in your dwellings).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1490]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1490

Jabir reported: We set cut with the Messenger of Allah (may peace be upon him) on a journey when it began to rain. Upon this he said: He who desires may pray in his dwelling.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1491]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1491

'Abdullah b. 'Abbas reported that he said to the Mu'adhdhin on a rainy day: When you have announced" I testify that there is no god but Allah; I testify that Muhammad is the Messenger of Allah," do not say:" Come to the prayer," but make this announcement:" Say prayer in your houses." He (the narrator) said that the people disapproved of it. Ibn 'Abbas said: Are you astonished at it? He (the Holy Prophet), who is better than I, did it. Jumu'a prayer is no doubt obligatory, but I do not like that I should (force you) to come out and walk in mud and slippery ground.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1492]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1492

'Abd al-Hamid reported: I heard 'Abdullah b. al-Harith say: 'Abdullah b. 'Abbas addressed us on a rainy day, and the rest of the hadith is the same, but he made no mention of Jumu'a prayer, and added: He who did it (who commanded us to say prayer in our houses), i. e. the Apostle of Allah (may peace be upon him), is better than I.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1493]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1493

This hadith has been narrated by Ayyub and 'Asim al-Ahwal with the same chain of transmitters, but in this hadith it is not recorded:" i. e. the Apostle of Allah (may peace be upon him)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1494]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1494

'Abdullah b. Harith reported that Ibn 'Abbas commanded the Mu'adhdhin to (summon the people to prayer on Friday and make announcement to say prayer in their houses) when it was rainy, and the rest of the hadith is the same (except this) that he said: I do not like you should walk in muddy slippery place.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1495]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1495

'Abdullah b. Harith reported that the Mu'adhdhin of Ibn 'Abba said Adhan on Friday (and then made the announcement to say prayer in houses) because it was a rainy day; as it has been narrated by Ma'mar and others, and in this hadith it was mentioned: He who did it, i. e. the Apostle of Allah (may peace be upon him), was better than I.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1496]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1496

A hadith like this that Ibn 'Abbas ordered his Mu'adhdhin (to summon people to prayer and then make announcement to say prayer in their houses) on Friday which was a rainy day, has been transmitted by 'Abdullah b. Harith. Wuhaib, however, says that he did not hear it from him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1497]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1497

Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) used to say Nafl prayer on (the back of) his camel in whatever direction it took him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1498]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1498

Ibn 'Umar reported that the Apostle (may peace be upon him) used to pray on (the back of) his camel in whatever direction it took him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1499]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1499

Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) used to say prayer on his camel while coming from Mecca to Medina, in whatever direction his face had turned; and its was (in this context) that this verse was revealed:" So whether you turn thither is Allah's face" (ii. 115).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1500]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1500

This hadith has been narrated by another chain of transmitters and in the one narrated by Ibn Mubarak and Ibn Abu Za'ida (these words are narrated). Ibn 'Umar then recited:" Whether you turn thither is Allah's face," and it was revealed in this context.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1501]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1501

Ibn 'Umar reported: I saw the Messenger of Allah (may peace be upon him) praying (Nafl prayer) on a donkey's back while his face was turned towards Khaibar.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1502]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1502

Sa'id b. Yasar reported: I was travelling along with Ibn 'Umar on the way to Mecca. Sa'id said: When I apprehended dawn, I dismounted (the ride) and observed Witr prayer and then again joined him. Ibn 'Umar said to me: Where were you? I said: I apprehended the appearance of dawn, so I dismounted and observed Witr prayer. Upon this 'Abdullah said: Is there not a model pattern for you in the Messenger of Allah (may peace be upon him)? I said: Yes, by Allah, and (then) he said: The Messenger of Allah (may peace be upon him) used to observe Witr prayer on the camel's back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1503]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1503

'Abdullah b. Dinar reported on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) used to observe prayer on his ride (no matter) in which direction it had its face turned. 'Abdullah b. Dinar said that Ibn 'Umar used to do like that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1504]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1504

'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) used to observe Witr prayer on his ride.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1505]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1505

Salim b. 'Abdullah reported on the authority of his father that the Messenger of Allah (may peace be. upon him) used to observe Nafl (supererogatory) prayer on his ride no matter in what direction it turned its face, and he observed Witr too on it, but did not observe obligatory prayer on it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1506]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1506

'Abdullah b. 'Amir b. Rabi'a has reported on the authority of his father that he had seen the Messenger of Allah (may peace be upon him) observing Nafl player at night on a journey on the back of his ride in whichever direction it turned its face.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1507]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1507

Anas b. Sirin reported: We met Anas b. Malik as he came to Syria at a place known as 'Ain-al-Tamar and saw him observing prayer on the back of his donkey with his face turned in that direction. (Hammam one of the narrators) pointed towards the left of Qibla, so I said to him: I find you observing prayer towards the side other than that of Qibla. Upon this he said: Had I not seen the Messenger of Allah (may peace be upon him) doing like this, I would not have done so at all.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1508]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1508

Ibn 'Umar reported: When the Messenger of Allah (may peace be upon him) was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1509]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1509

Nafi' reported that when Ibn 'Umar was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers after the twilight had disappeared, and he would say that when the Messenger of Allah (may peace be upon him) was in a state of hurry on a journey, he combined the sunset and 'Isha' prayers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1510]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1510

Salim reported from his father to be saying: I saw the Messenger of Allah (may peace be upon him) combining the sunset and Isha' prayers when he was in a hurry on a journey.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1511]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1511

Salim b. 'Abdullah reported that his father had said: I saw the Messenger of Allah (may peace be upon him) delaying the sunset prayer till he would combine it with the 'Isha' when he hastened to set out on a journey.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1512]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1512

Anas b. Malik reported: When the Messenger of Allah (may peace be upon him) set out on a journey before the sun declined (from the meridian), he delayed the noon prayer till the afternoon prayer, and then dismounted (his ride) and combined them (noon and afternoon prayers), but if the sun had declined before his setting out on a journey, he observed the noon prayer and then mounted (the ride).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1513]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1513

Anas reported: When the Apostle of Allah (may peace be upon him) intended to combine two prayers on a journey, he delayed the noon prayer till came the early time of the afternoon prayer, and then combined the two.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1514]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1514

Anas reported that when the Apostle of Allah (may peace be upon him) had to set out on a journey hurriedly, he delayed the noon prayer to the earlier time for the afternoon prayer, and then he would combine them, and he would delay the sunset prayer to the time when the twilight would disappear and then combine it with the 'Isha' prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1515]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1515

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) observed the noon and afternoon prayers together, and the sunset and Isha' prayers together without being in a state of fear or in a state of journey.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1516]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1516

Ibn 'Abbas reported: The Messenger of Allah (may peace be upon him) observed the noon and afternoon prayers together in Medina without being in a state of fear or in a state of journey. (Abu Zubair said: I asked Sa'id [one of the narrators] why he did that. He said: I asked Ibn 'Abbas as you have asked me, and he replied that he [the Holy Prophet] wanted that no one among his Ummah should be put to [unnecessary] hardship.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1517]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1517

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) combined the prayers as he set on a journey in the expedition to Tabuk. He combined the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer. Sa'id (one of the rawis) said to Ibn 'Abbas: What prompted him to do this? He said: He wanted that his Ummah should not be put to (unnecessary) hardship.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1518]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1518

Mu'adh reported: We set out with the Messenger of Allah (may peace be upon him) on the Tabuk expedition, and he observed the noon and afternoon prayers together and the sunset and 'Isha' prayers together.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1519]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1519

Mu'adh b. Jabal reported: The Messenger of Allah (may peace be upon him) combined in the expedition to Tabuk the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer. He (one of the narrators) said: What prompted him to do that? He (Mu'adh) replied that he (the Holy Prophet) wanted that his Ummah should not be put to (unnecessary) hardship.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1520]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1520

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) combined the noon prayer with the afternoon prayer and the sunset prayer with the 'Isha' prayer in Medina without being in a state of danger or rainfall. And in the hadith transmitted by Waki' (the words are):" I said to Ibn 'Abbas: What prompted him to do that? He said: So that his (Prophet's) Ummah should not be put to (unnecessary) hardship." And in the hadith transmitted by Mu'awiya (the words are):" It was said to Ibn 'Abbas: What did he intend thereby? He said he wanted that his Ummah should not be put to unnecessary hardship."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1521]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1521

Ibn 'Abbas reported: I observed with the Apostle of Allah (may peace be upon him) eight (rak'ahs) in combination, and seven rak'ahs in combination. I (one of the narrators) said: O Abd Sha'tha', I think that he (the Holy Prophet) had delayed the noon prayer and hastened the afternoon prayer, and he delayed the sunset prayer and hastened the 'Isha' prayer. He said: I also think so.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1522]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1522

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) observed in Medina seven (rak'ahs) and eight (rak'ahs), i. e. (be combined) the noon and afternoon prayers (eight rak'ahs) and the sunset and 'Isha' prayers (seven rak'ahs).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1523]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1523

'Abdullah b. Shaqiq reported: Ibn 'Abbas one day addressed us in the afternoon (after the afternoon prayer) till the sun disappeared and the stars appeared, and the people began to say: Prayer, prayer. A person from Banu Tamim came there. He neither slackened nor turned away, but (continued crying): Prayer, prayer. Ibn 'Abbas said: May you be deprived of your mother, do you teach me Sunnah? And then he said: I saw the Messenger of Allah (may peace be upon him) combining the noon and afternoon prayers and the sunset and 'Isha' prayers. 'Abdullah b. Shaqiq said: Some doubt was created in my mind about it. So I came to Abu Huraira and asked him (about it) and he testified his assertion.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1524]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1524

'Abdullah b. Shaqiq al-'Uqaili reported: A person said to Ibn 'Abbas (as he delayed the prayer): Prayer. He kept silence. He again said: Prayer. He again kept silence, and he again cried: Prayer. He again kept silence and said: May you be deprived of your mother, do you teach us about prayer? We used to combine two prayers during the life of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1525]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1525

Abdullah reported: None of you should give a share to Satan out of your self. He should not deem that it is necessary for him to turn but to the right only (after prayer). I saw the Messenger of Allah (may peace be upon him) turning to the left.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1526]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1526

A hadith like this has been narrated by A'mash, with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1527]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1527

Suddi reported: I asked Anas how I should turn-to the right or to the left-when I say my prayers. He said: I have very often seen the Messenger of Allah (may peace be upon him) turning to the right.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1528]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1528

Anas reported: The Apostle of Allah (may peace be upon him) used to turn to the right (at the end of the prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1529]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1529

Bara' reported: When we prayed behind the Messenger of Allah (may peace be upon him) we cherished to be on his right side so that his face would turn towards us (at the end of the prayer), and he (the narrator) said: I heard him say: O my Lord! save me from Thy torment on the Day when Thoil, wouldst raise or gather Thy servants.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1530]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1530

This hadith has been reported by Mis'ar with the same chain of transmitters, but he made no mention of:" His face would turn towards us."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1531]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1531

Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: When the prayer commences then there is no prayer (valid), but the obligatory prayer. This hadith has been narrated by Warqa' with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1532]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1532

Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: When the prayer commences, there is no prayer but the obligatory one.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1533]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1533

A hadith like this has been reported by Ishaq with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1534]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1534

This hadith has been narrated by Abu Huraira with another chain of transmitters. Hammad (one of the narrators) said: I then met 'Amr (the other narrator) and he narrated it to me, but it was not transmitted directly from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1535]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1535

'Abdullah b. Malik b. Buhaina reported: The Messenger of Allah (may peace be upon him) happened to pass by a person who was busy in praying while the (Fard of the) dawn prayer had commenced. He said something to him, which we do not know what it was. When we turned back we surrounded him and said: What is it that the Messenger of Allah (may peace be upon him) said to you? He replied: He (the Holy Prophet) had said to me that he perceived as if one of them was about to observe four (rak'ahs) of the dawn prayer. Qa'nabi reported that 'Abdullah b. Malik b. Buhaina narrated it on the authority of his father. (Abu'l-Husain Muslim said): His assertion that he has narrated this hadith on the authority of his father is not correct.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1536]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1536

Ibn Buhaina reported: The dawn prayer had commenced when the Messen- ger of Allah (may peace be upon him) saw a person observing prayer, whereas the Mu'adhdhin had pronounced the Iqama. Upon this he (the Holy Prophet) remarked: Do you say four (rak'ahs) of Fard in the dawn prayer?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1537]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1537

'Abdullah b. Sarjis reported: A person entered the mosque, while the Messenger of Allah (may peace be upon him) was leading the dawn prayer. He observed two rak'ahs in a corner of the mosque, and then joined the Messenger of Allah (may peace be upon him) in prayer. When the Messenger of Allah (may peace be upon him) had pronounced salutations (he had concluded the prayer), he said: O, so and so, which one out of these two prayers did you count (as your Fard prayer), the one that you observed alone or the prayer that you observed with us?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1538]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1538

Abu Usaid reported that the Messenger of Allah (may peace be upon him) said: When any one of you enters the mosque, he should say:" O Allah! open for me the doors of Thy mercy" ; and when he steps out he should say: 'O Allah! I beg of Thee Thy Grace." (Imam Muslim said: I heard Yahya saying: I transcribed this hadith from the compilation of Sulaiman b. Bilal.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1539]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1539

A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) by Abu Usaid.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1540]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1540

Abu Qatada (a Companion of the Prophet) reported Allah's Messenger (may peace be upon him) as saying: When any one of you enters the mosque, he should observe two rak'ahs (of Nafl prayer) before sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1541]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1541

Abu Qatada, a Companion of the Messenger of Allah (may peace be upon him), said: I entered the mosque, when the Messenger of Allah (may peace be upon him) had been sitting among people, and I also sat down among them. Upon this the Messenger of Allah (may peace be upon him) said: What prevented you from offering two rak'ahs (of Nafl prayer) before sitting down? I said: Messenger of Allah, I saw you sitting and people sitting (around you and I, therefore, sat in your company). He (the Holy Prophet) then said: When anyone among you enters the mosque, he should not sit till he has observed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1542]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1542

Jabir b. 'Abdullah reported: The Apostle of Allah (may peace be upon him) owed me a debt; he paid me back and made an addition (of this). I entered the mosque and he (the Holy Prophet) said to me: Observe two rak'ahs of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1543]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1543

Jabir b. 'Abdullah reported: The Messenger of Allah (may peace be upon him) bought a camel from me. When he came back to Medina, he ordered me to come to the mosque and observed two rak'ahs of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1544]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1544

Jabir b. 'Abdullah reported: I went with the Messenger of Allah (may peace be upon him) on an expedition and my camel delayed me and I was exhausted. The Messenger of Allah (may peace be upon him) thus came earlier than I, whereas I came on the next day and went to the mosque and found him (the Holy Prophet) at the gate of the mosque. He said: It is now that you have come. I said. Yes. He said: Leave your camel and enter (the mosque) and observe two rak'ahs. He (the narrator) said: So I entered and observed (two rak'ahs) of prayer and then went back.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1545]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1545

Ka'b b. Malik reported: The Messenger of Allah (may peace be upon him) did not come back from the journey but by day in the forenoon, and when he arrived, he went first to the mosque, and having prayed two rak'ahs in it he sat down in it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1546]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1546

'Abdullah b. Shaqiq reported: I asked 'A'isha whether the Apostle of Allah (may peace be upon him) used to observe the forenoon prayer. She said: No, but when he came back from the journey.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1547]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1547

'Abdullah b. Shaqiq reported: I aksed 'A'isha whether the Apostle of Allah (may peace be upon him) used to observe the forenoon prayer. She said: No, except when he came back from a journey.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1548]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1548

'Urwa reported 'A'isha to be sayidg: I have never seen the Messenger of Allah (may peace be upon him) observing the supererogatory prayer of the forenoon, but I observed it. And if the Messenger of Allah (way peace be upon him) abandoned any act which he in fact loved to do, it was out of fear that if the people practised it constantly, it might become obligatory for them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1549]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1549

Mu'adha asked 'A'isha (Allah be pleased with her) how many rak'ahs Allah's Messenger (may peace be upon him) prayed at the forenoon prayer. She replied: Four rak'ahs, but sometimes more as he pleased.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1550]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1550

A hadith like this has been reported by the same chain of transmitters, but with this alteration that the transmitter said:" As Allah pleased."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1551]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1551

Mua'ada 'Adawiyya reported 'A'isha as saying: The Messenger of Allah (may peace be upon him) used to observe four rak'ahs in the forenoon prayer and he sometimes observed more as Allah pleased.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1552]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1552

A hadith like this has been narrated by Qatada with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1553]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1553

Abd al-Rahman b. Abu Laila reported: No one has ever narrated to me that he saw the Apostle of Allah (may peace be upon him) observing the forenoon prayer, except Umm Hani. She, however, narrated that the Apostle of Allah (may peace be upon him) entered her house on the day of the Conquest of Mecca and prayed eight rak'ahs (adding): I never saw a shorter prayer than it except that he performed the bowing and prostration completely. But (one of the narrators) Ibn Bashshar in his narration made no mention of the word:" Never".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1554]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1554

'Abdullah b. Harith b. Naufal reported: I had been asking about, as I was desirous to find one among people who should inform me, whether the Messenger of Allah (may peace be upon him) observed the forenoon prayer, but I found none to narrate that to me except Umm Hani, daughter of Abu Talib (the real sister of Hadrat 'Ali), who told me that on the day of the Conquest the Messenger of Allah (may peace be upon him) came (to our house) after the dawn had (sufficiently) arisen. A cloth was brought and privacy was provided for him (the Holy Prophet). He took a bath and then stood up and observed eight rak'ahs. I do not know whether his Qiyam (standing posture) was longer, or bending or prostration or all of them were of equal duration. She (Umm Hani) further said: I never saw him saying this Nafl prayer prior to it or subsequently. (Al-Muradi narrated on the authority of Yunus that he made no mention of the words:" He informed me." )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1555]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1555

Abu Murra, the freed slave of Umm Hani, daughter of Abu Talib, reported Umm Hani to be saying: I went to the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca and found him taking bath, and Fatimah, his daughter, had provided him privacy with the help of a cloth. I gave him salutation and he said: Who is she? I said: It is Umm Hani, daughter of Abu Talib. He (the Holy Prophet) said: Greeting for Umm Hani. When he had completed the bath, he stood up and observed eight rak'ahs wrapped up in one cloth. When he turned back (after the prayer), I said to him: Messenger of Allah, the son of my mother 'Ali b. Abu Talib is going to kill a person, Fulan b. Hubaira whom I have given protection. Upon this the Messenger of Allah (way peace be upon him) said: We too have given protection whom you have given protection, O Umm Hani. Umm Hani said: It was the forenoon (prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1556]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1556

Abu Murra narrated on the authority of Umm Hani that the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca observed in her house eight rak'abs of prayer in one cloth, its opposite corners having been tied from the opposite sides.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1557]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1557

Abu Dharr reported Allah's Apostle (may peace be upon him) as saying: In the morning charity is due from every bone in the body of every one of you. Every utterance of Allah's glorification is an act of charity. Every utterance of praise of Him is an act of charity, every utterance of profession of His Oneness is an act of charity, every utterance of profession of His Greatness is an act of charity, enjoining good is an act of charity, forbidding what is distreputable is an act of charity, and two rak'ahs which one prays in the forenoon will suffice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1558]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1558

Abu Huraira reported. My friend (the Holy Prophet, may peace be upon him) has instructed me to do three things: three fasts during every month, two rak'ahs of the forenoon prayer, and observing Witr prayer before going to bed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1559]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1559

A hadith like this has been narrated by Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1560]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1560

Abu Huraira reported: My friend Abu'l-Qasim (may peace be upon him) instructed me to do three things, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1561]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1561

Abu Murra, the freed slave of Umm Hani, narrated on the authority of Abu Darda': My Friend (may peace be upon him) instructed me in three (acts), and I would never abandon them as long as I live. (And these three things are): Three fasts during every month, the forenoon prayer, and this that I should not sleep till I have observed the Witr prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1562]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1562

Ibn 'Umar reported that Hafsa, the Mother of the Believers, informed him that when the Mu'adhdhin became silent after calling (people) to the dawn prayer, the Messenger of Allah (may peace be upon him) commenced the dawn (prayer) when it dawned by observing two short rak'ahs before the commencement of the (Fard) prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1563]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1563

This hadith has been transmitted by Nafi' with the same chain of narrators.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1564]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1564

Hafsa reported that when it was dawn, the Messenger of Allah (may peace be upon him) did not observe (any other prayers) but two short rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1565]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1565

A hadith like this has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1566]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1566

Hafsa reported: When the dawn appeared, the Apostle of Allah (may peace be upon him) observed two rak'ahs (of Sunnah prayers).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1567]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1567

'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe two rak'ahs of Sunnah (prayer) when he heard the Adhin and shortened them. (This hadith has been narrated by the same chain of transmitters and in the hadith narrated by Usama the words are:" When it was dawn".)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1568]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1568

'A'isha reported that the Apostle of Allah (may peace be upon him) used to observe two (supererogatory) rak'ahs in between the call to prayer and the Iqama of the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1569]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1569

'A'isha reported that the Messenger of Allah (may peace be upon him) observed two rak'ahs of the dawn prayer and he shortened them (to the extent) that I (out of surprise) said: Did he recite in them Surah Fatiha (only)?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1570]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1570

'A'isha reported: When it was dawn, the Messenger of Allah (may peace be upon him) observed two rak'ahs, and I would say: Does he recite only the opening chapter of the Qur'an in it?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1571]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1571

'A'isha reported that the Apostle (may peace be upon him) was not so much particular about observing supererogatory rak'ahs as in case of the two rak'ahs of the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1572]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1572

'A'isha reported: I have never seen the Messenger of Allah (may peace be upon him) hastening as much in observing supererogatory as two rak'ahs before the (Fard) of the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1573]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1573

'A'isha reported Allah's Messenger as saying: The two rak'ahs at dawn are better than this world and what it contains.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1574]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1574

'A'isha reported that the Apostle of Allah (may peace be upon him) said about the two (supererogatory) rak'ahs of the dawn: They are dearer to me than the whole world.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1575]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1575

Abu Huraira reported that the Messenger of Allah (may peace be upon him) recited in the two (supererogatory) rak'ahs of the dawn (prayer):" Say: O unbelievers," (Qur'an, cix.) and" Say: Allah is one" (cxii.).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1576]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1576

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) used to recite in first of the two (supererogatory) rak'ahs of the dawn:" Say: We believed in Allah and what was revealed to us..." verses 285-286 from Surah Baqara, and in the second of the two:" I believe in Allah and I bear testimony that we are Muslims" (iii. 51).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1577]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1577

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) used to recite in the two (supererogatory) rak'ahs of the dawn prayer:" Say: We believed in Allah and what was revealed to us" and that which is found in Surah Al-i-'lmran:" Come to that word (creed) which is common between you and us" (iii. 64).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1578]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1578

This hadith has been transmitted by another chain of narrators.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1579]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1579

Umm Habiba (the wife of the Holy Prophet) reported Allah's Messenger (may peace be upon him) as saying: A house will be built in Paradise, for anyone who prays in a day and a night twelve rak'ahs; and she added: I have never abandoned (observing them) since I heard it from the Messenger of Allah (may peace be upon him). Some of the other narrators said the same words: I have never abandoned (observing them) since I heard (from so and so).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1580]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1580

Nu'man b. Salim reported with the same chain of transmitters: He who observed twelve voluntary rak'ahs, a house will be built for him in Paradise.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1581]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1581

Umm Habiba, the wife of the Apostle of Allah (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: If any Muslim servant (of Allah) prays for the sake of Allah twelve rak'ahs (of Sun'an) every day, over and above the obligatory ones, Allah will build for him a house in Paradise, or a house will be built for him in Paradise; and I have not abandoned to observe the in after (hearing it from the Messenger of Allah). (So said also 'Amr and Nu'man.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1582]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1582

Umm Habiba reported the Messenger of Allah (may peace be upon him) having said: If any Muslim servant (of Allah) performed ablution, and performed it well, and then observed every day, the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1583]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1583

Ibn 'Umar reported: I prayed along with Allah's Messenger (may peace be upon him) two rak'ahs before and two rak'ahs after the noon prayer, two rak'ahs after the sunset prayer and two rak'ahs after the 'Isha' prayer and two rak'ahs after the Friday prayer; and so far as the sunset, 'Isha' and Friday prayers are concerned, I observed (them) along with the Apostle of Allah (may peace be upon him) in his house.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1584]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1584

'Abdullah b. Shaqiq said: I asked 'A'isha about the Messenger of Allah's (may peace be upon him) voluntary prayers, and she replied: Before the noon prayer, he used to pray four rak'abs in my house; then would go out and lead the people in prayer; then come in and pray two rak'ahs. He would then lead the people in the sunset prayer; then come in and pray two rak'abs. Then he would lead the people in the 'Isha' prayer, and enter my house and pray two rak'ahs. He would pray nine rak'ahs during the night, including Witr. At night he would pray for a long time standing and for a long time sitting, and when he recited the Holy Qur'an while standing, he would bow and prostrate himself from the standing position, and when he recited while sitting, he would bow and prostrate himself from the sitting position, and when it was dawn he would pray two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1585]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1585

'A'isha reported that the Messenger of Allah (may peace be upon him) would pray in the night for a long time, and when he prayed standing be bowed in a standing posture, and when he prayed sitting, he bowed in a sitting posture.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1586]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1586

'Abdullah b. Shaqiq reported: I fell ill in Persia and therefore, prayed in a sitting posture, and I asked 'A'isha about it and she said: The Messenger of Allah (may peace be upon him) prayed for a long time in the night sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1587]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1587

'Abdullah b. Shaqiq al-'Uqaili reported: I asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him) during the night (i. e. Tahajjud prayer) She replied: He used to pray for a long time standing and for a long time sitting in the night, and when he recited the Qur'an while standing, he would bow himself from the standing position, and when he recited while sitting, he would bow from the sitting position.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1588]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1588

'Abdullah b. Shaqiq al-'Uqaili reported: I asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him). She said: The Messenger of Allah (may peace be upon him) would observe prayer (Nafl) in a standing position as well as in a sitting position, and when he commenced the prayer in a standing position, he bowed in this very position, and when he commenced the prayer in a sitting position, he bowed in this very position.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1589]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1589

'A'isha reported: I did not see the Messenger of Allah (may peace be upon him) reciting (the Qur'an) in the night prayer in a sitting position, till he grew old and then he recited (it) in a sitting position, but when thirty or forty verses were left out of the Surah, he would then stand up, recite them and then bowed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1590]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1590

'A'isha reported: The Messenger of Allah (may peace be upon him) used to pray while sitting (when he grew old) and he recited in this position and when the recitation equal to thirty or forty verses was left, he would then stand up and recite (for this duration) in a standing position and then bowed himself and then prostrated himself and did the same in the second rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1591]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1591

'A'isha reported: The Messenger of Allah (may peace be upon him) used to recite in sitting position (while observing the Tahajjud prayer) and when he intended to bow, he would stand up and recite (for the duration in which) a man (ordinarily) recites forty verses.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1592]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1592

Alqama b. Waqqas reported: I asked 'A'isha how the Messenger of Allah (may peace be upon him) did in the two rak'ahs as he (observed them) sitting. She said: He would recite (the Qur'an) in them, and when he intended to bow, he would stand up and then bowed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1593]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1593

'Abdullah b. Shaqiq reported: I asked 'A'isha whether the Apostle of Allah (may peace be upon him) observed (Nafl) sitting. She said: Yes, when the people had made him old.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1594]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1594

'Abdullah b. Shaqiq reported: I said to 'A'isha and she made a mention of that (recorded above) about the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1595]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1595

'A'isha reported that the Messenger of Allah (may peace be upon him) died (in this very state) that he observed most of his (Nafl) prayers in a sitting position.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1596]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1596

'A'isha reported: When the Messenger of Allah (may peace be upon him) grew bulky and heavy he would observe (most of his Nafl) prayers sitting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1597]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1597

Hafsa reported: Never did I see the Messenger of Allah (may peace be upon him) observing supererogatory prayer sitting till one year before his death when he would observe Nafl prayer in a sitting position, and he would recite the Surah (of the Qur'an) in such a slow-measured tone (that duration of its recital) became more lengthy than the one longer than this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1598]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1598

Zuhri reported this hadith with the same chain of transmitters, except this that he made a mention of one year or two years.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1599]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1599

Jabir b. Samura reported that the Apostle of Allah (may peace be upon him) observed (Nafl) prayer sitting before his death.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1600]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1600

'Abdullah b. 'Amr reported: It was narrated to me that the Messenger of Allah (may peace be upon him) had said: The prayer observed by a person sitting is half of the prayer. I came to him (may peace be upon him) and found him praying in a sitting position. I placed my hand on his head. He said: O 'Abdullah b. 'Amr, what is the matter with you? I said: Messenger of Allah, it has been narrated to me that you said: The prayer of a man in a sitting position is half of the prayer, whereas you are observing prayer sitting. He (the Holy Prophet) said: Yes, it is so, but I am not like anyone amongst you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1601]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1601

A hadith like this has been narrated by Abu Yahya al-A'raj with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1602]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1602

'A'isha reported that the Messenger of Allah (may peace be upon him) used to pray eleven rak'ahs at night, observing the Witr with a single rak'ah, and when he had finished them, he lay down on his right side, till the Mu'adhdhin came to him and he (the Holy Prophet) then observed two short rak'ahs (of Sunan of the dawn prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1603]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1603

'A'isha, the wife of the Apostle of Allah (may peace be upon him), said that between the time when the Messenger of Allah (may peace be upon him) finished the 'Isha' prayer which is called 'Atama by the people, he used to pray eleven rak'ahs, uttering the salutation at the end of every two rak'ahs, and observing the Witr with a single one. And when the Mu'adhdhin had finished the call (for the) dawn prayer and he saw the dawn clearly and the Mu'adhdhin had come to him, he stood up and prayed two short rak'ahs. Then he lay down on his right side till the Mu'adhdhin came to him for lqama. (This hadith has been narrated with the same chain of transmitters by Ibn Shihab, but in it no mention has been made of Iqama )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1604]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1604

'A'isha reported: The Messenger of Allah (may peace be upon him) used to observe thirteen rak'ahs of the night prayer. Five out of them consisted of Witr, and he did not sit, but at the end (for salutation).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1605]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1605

This hadith has been narrated by Hisham with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1606]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1606

'A'isha reported that the Messenger of Allah (may peace be upon him) used to pray thirteen rak'ahs during the night including the two rak'ahs (Sunan) of the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1607]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1607

Abu Salama b. Abd al-Rahman asked 'A'isha about the (night) prayer of the Messenger of Allah (may peace be upon him) during the month of Ramadan. She said: The Messenger of Allah (may peace be upon him) did not observe either in Ramadan or in other months more than eleven rak'ahs (of the night prayer). He (in the first instance) observed four rak'ahs. Ask not about their excellence and their length (i. e. these were matchless in perfection and length). He again observed four rak'ahs, and ask not about their excellence and their length. He would then observe three rak'ahs (of the Witr prayer). 'A'isha again said: I said: Messenger of Allah, do you sleep before observing the Witr prayer? He said: O 'A'isha, my eyes sleep but my heart does not sleep.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1608]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1608

Abu Salama asked 'A'isha about the prayer of the Messenger of Allah (may peace be upon him) She said: He observed thirteen rak'ahs (in the night prayer). He observed eight rak'ahs and would then observe Witr and then observe two rak'ahs sitting, and when he wanted to bow he stood up and then bowed down, and then observed two rak'ahs in between the Adhan and lqama of the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1609]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1609

Abu Salama reported that he asked 'A'isha about the prayer of the Messenger of Allah (may peace he upon him) (during the night). The rest of the hadith is the same but with this exception that he (the Holy Prophet) observed nine rak'ahs including Witr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1610]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1610

Abu Salama is reported to have said. I came to 'A'isha. I said: O mother, inform me about the prayer of the Messenger of Allah (may peace be upon him). She said: His (night prayer) in Ramadan and (during other months) was thirteen rak'ahs at night including two rak'ahs of fajr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1611]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1611

It is reported on the authority of 'A'isha that the prayer of Allah's Messenger (may peace be upon him) in the night consisted of ten rak'ahs. He observed a Witr and two rak'ahs (of Sunan) of the dawn prayer, and thus the total comes to thirteen rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1612]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1612

'A'isha thus reported about the (night prayer) of the Messenger of Allah (may peace be upon him): He used to sleep in the early part of the night, and woke up in the latter part. If he then wished intercourse with his wife, he satisfied his desire, and then went to sleep; and when the first call to prayer was made he jumped up (by Allah, she, i. e. 'A'isha, did not say" he stood up" ), and poured water over him (by Allah she, i. e. 'A'isha, did not say that he took a bath but I know what she meant) and if he did not have an intercourse, he performed ablution, just as a man performs ablution for prayer and then observed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1613]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1613

'A'isha observed that the Messenger of Allah (may peace be upon him) used to observe prayer in the night and the last of his (night) prayer was Witr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1614]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1614

Masruq is reported to have asked 'A'isha about the action (most pleasing to) the Messenger of Allah (may peace be upon him). She said: He (the Holy Prophet) loved (that action) which one keeps on doing regularly. I said (to 'A'isha): When did he pray (at night)? She replied: When he heard the cock crow, he got up and observed prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1615]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1615

'A'isha reported: Never did the earlier part of the dawn find the Messenger of Allah (may peace be upon him) but sleeping in my house or near me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1616]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1616

'A'isha reported: When the Apostle of Allah (may peace be upon him) had prayed the two rak'ahs (Sunan) of the dawn prayer, he would talk to me if I was awake, otherwise he would lie down.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1617]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1617

A hadith like this has been narrated by 'A'isha by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1618]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1618

'A'isha reported: The Messenger of Allah (may peace be upon him) used to pray in the night and when he observed Witr, he said to me: O 'A'isha, get up and observe Witr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1619]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1619

'A'isha reported that the Messenger of Allah (may peace be upon him) used to offer prayer at night while she lay in front of him, and when the Witr prayer was yet to be observed, he would awaken her and she observed Witr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1620]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1620

'A'isha reported: The Messenger of Allah (may peace be upon him) observed the Witr prayer every night and he completed Witr at the time of dawn.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1621]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1621

Masruq reported on the authority of 'A'isha that she said that the Messenger Of Allah (may peace be upon him) used to observe the Witr prayer every night, maybe in the early part of night, at midnight and in the latter part, finishing his Witr at dawn.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1622]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1622

'A'isha reported that the Messenger of Allah (may peace be upon him) used to observe Witr every night, and he would (at times) complete his Witr at the end of the night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1623]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1623

Sa'd b. Hisham b. 'Amir decided to participate in the expedition for the sake of Allah, so he came to Medina and he decided to dispose of his property there and buy arms and horses instead and fight against the Romans to the end of his life. When he came to Medina, he met the people of Medina. They dissuaded him to do such a thing, and informed him that a group of six men had decided to do so during the lifetime of the Apostle of Allah (may peace be upon him) and the Apostle of Allah (may peace be upon him) forbade them to do it, and said: Is there not for you a model pattern in me? And when they narrated this to him (Sa'd b. Hisham), he returned to his wife, though he had divorced her and made (people) witness to his reconciliation. He then came to Ibn 'Abbas and asked him about the Witr of the Messenger of Allah (may peace be upon him). Ibn 'Abbas said: Should I not lead you to one who knows best amongst the people of the world about the Witr of the Messenger of Allah (may peace be upon him)? He said: Who is it? He (Ibn 'Abbas) said: It is 'A'isha. So go to her and ask her (about Witr) and then come to me and inform me about her answer that she would give you. So I came to Hakim b. Aflah and requested him to take me to her. He said: I would not go to her, for I forbade her to speak anything (about the conflict) between the two groupS, but she refused (to accept my advice) and went (to participate in that corflict). I (requested) him (Hakim) with an oath to lead me to her. So we went to 'A'isha and we begged permission to meet her. She granted us permission and we went in. She said: Are you Hakim? (She recognised him.) He replied: Yes. She said: Who is there with you? He said: He is Sa'd b. Hisham. She said: Which Hisham? He said: He is Hisham b. 'Amir. She blessed him ('Amir) with mercy from Allah and spoke good of him (Qatada said that he died as a martyr in Uhud). I said: Mother of the Faithful, tell me about the character of the Messenger of Allah (may peace be upon him). She said: Don't you read the Qur'an? I said: Yes. Upon this she said: The character of the Apostle of Allah (may peace be upon him) was the Qur'an. He said: I felt inclined to get up and not ask anything (further) till death. But then I changed my mind and said: Inform me about the observance (of the night prayer) of the Messenger of Allah (may peace be upon him). She said: Did you not recite:" O thou wrapped up"? He said: Yes. She said: Allah, the Exalted and the Glorious, made the observance of the night prayer at the beginning of this Surah obligatory.

So the Apostle of Allah (may peace be upon him and his Companions around him observed this (night prayer) for one year. Allah held back the concluding portion of this Surah for twelve months in the Heaven till (at the end of this period) Allah revealed the concluding verses of this Surah which lightened (the burden of this prayer), and the night prayer became a supererogatory prayer after being an obligatory one. I said: Mother of the Faithful, inform me about the Witr of the Messenger of Allah (may peace be upon him). She said: I used to prepare tooth stick for him and water for his ablution, and Allah would rouse him to the extent He wished during the night. He would use the tooth stick, and perform ablution, and would offer nine rak'ahs, and would not sit but in the eighth one and would remember Allah, and praise Him and supplicate Him, then he would get up without uttering the salutation and pray the ninth rak'ah. He would then sit, remember, praise Him and supplicate Him and then utter a salutation loud enough for us to hear. He would then pray two rak'ahs sitting after uttering the salutation, and that made eleven rak'ahs. O my son, but when the Apostle of Allah (may peace be upon him) grew old and put on flesh, he observed Witr of seven, doing in the two rak'ahs as he had done formerly, and that made nine. O my son, and when the Apostle of Allah (may peace be upon him) observed prayer, he liked to keep on observing it, and when sleep or pain overpowered him and made it impossible (for him) to observe prayer in the night, he prayed twelve rak'ahs daring the day. I am not aware of Allah's Prophet (may peace be upon him) having recited the whole Qur'an during one single night, or praying through the night till morning, or fasting a complete month, except Ramadan. He (the narrator) said: I then went to Ibn 'Abbas and narrated to him the hadith (transmitted from her), and he said: She says the truth If I went to her and got into her presence, I would have listened to it orally from her. He said: If I were to know that you do not go to her. I would not have transmitted this hadith to you narrated by her.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1624]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1624

Zurara b. Aufa said that Sa'd b. Hisham divorced his wife, and then proceeded to Medina to sell his property, and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1625]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1625

Sa'd b. Hisham reported: I went to 'Abdullah b. 'Abbas and asked him about the Witr prayer, and the rest of the hadith is the same as recorded in this event. She (Hadrat 'A'isha) said: Who is that Hisham? I said: Son of 'Amir. She said: What a fine man 'Amir was! He died as a martyr in the Battle of Uhud.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1626]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1626

Zurara b. Aufa reported that Sa'd b. Hisham was his neighbour and he informed him that he had divorced his wife and he narrated the hadith like the one transmitted by Sa'd. She ('A'isha) said: Who is Hisham? He said: The son of 'Amir. She said: What a fine man he was; he participated in the Battle of Uhud along with the Messenger of Allah (may peace be upon him). Hakim b. Aflah said: If I ever knew that you do not go to 'A'isha, I would not have informed you about her hadith (So that you would have gone to her and heard it from her orally).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1627]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1627

'A'isha reported that when the Messenger of Allah (may peace be upon him) missed the night prayer due to pain or any other reason, he observed twelve rak'ahs during the daytime.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1628]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1628

'A'isha reported that when the Messenger of Allah (may peace be upon him) decided upon doing any act, he continued to do it, and when he slept at night or fell sick he observed twelve rak'ahs during the daytime. I am not aware of Allah's Messenger (may peace be upon him) observing prayer during the whole of the night till morning, or observing fast for a whole month continuously except that of Ramadan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1629]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1629

'Umar b. Khattab reported Allah's Messenger (may peace be upon him) as saying: Should anyone fall asleep and fail to recite his portion of the Qur'an, or a part of it, if he recites it between the dawn prayer and the noon prayer, it will be recorded for him as though he had recited it during the night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1630]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1630

Zaid b. Arqam, on seeing some people praying in the forenoon, said: They well know that prayer at another time than this is more excellent, for Allah's Messenger (may peace be upon him) said: The prayer of those who are penitent is observed when your weaned camels feel the heat of the sun.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1631]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1631

Zaid b. Arqam reported that the Messenger of Allah (may peace be upon him) went out to the people of Quba' and saw them observing prayer; upon this he said: The prayer of the penitent should be observed when the young weaned camels feel heat of the sun.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1632]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1632

Ibn 'Umar reported that a person asked the Messenger of Allah (may peace be upon him) about the night prayer. The Messenger of Allah (may peace be upon him) said: Prayer during the night should consist of pairs of rak'ahs, but if one of you fears morning is near, he should pray one rak'ah which will make his prayer an odd number for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1633]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1633

Salim reported on the authority of his father that a person asked the Apostle of Allah (may peace be upon him) about the night prayer. He said: It consists of pairs of rak'ahs, but if one fears morning is near, he should make it an odd number by praying one rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1634]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1634

'Abdullah b. 'Umar reported: A man stood up and said. Messenger of Allah, how is the night prayer? The Messenger of Allah (may peace be upon him) said: The night prayer consists of pair, but if you apprehend the rise of dawn, make it odd number by observing one rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1635]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1635

'Abdullah b. 'Umar reported: A person asked the Apostle of Allah (may peace be upon him) as I stood between him (the Holy Prophet) and the inquirer and he said: Messenger of Allah, how is the night prayer? He (the Holy Prophet) said: It consists of pairs of rak'ahs, but if you apprehend morning, you should pray one rak'ah and make the end of your prayer as Witr. Then a person asked him (the Holy Prophet) at the end of the year and I was at that place near the Messenger of Allah (may peace be upon him) ; but I do not know whether he was the same person or another person, but he (the Holy Prophet) gave him the same reply.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1636]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1636

This hadith his been narrated by Ibn 'Umar by another chain of trans- mitters but it does not have these words:" Then a person asked him at the end of the year," and what follows subsequently.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1637]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1637

Ibn 'Umar reported the Apostle of Allah (may peace be upon him) as say- ing: Hasten to pray Witr before morning.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1638]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1638

Ibn 'Umar said: He who prayed at night should make Witr the end of his prayer, for the Messenger of Allah (way peace be upon him) ordered this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1639]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1639

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Make Witr the end of your night prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1640]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1640

Nafi' reported Ibn 'Umar as saying: He who observed the night prayer should make Witr the end of his prayer before dawn. The Messenger of Allah (may peace be upon him) used to order them thus.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1641]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1641

Ibn 'Umar reported Allah's Messenger (way peace be upon him) as saying: Witr is a rak'ah at the end of the prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1642]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1642

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Witr is a rak'ah at the end of the night prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1643]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1643

Abu Mijlaz reported: I asked Ibn 'Abbas about the Witr prayer. He said: I heard the Messenger of Allah (may peace be upon him) as saying: It is a rak'ah at the end of the night prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1644]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1644

Ibn 'Umar reported: A person called (the attention) of the Messenger of Allah (may peace be upon him) as he was in the mosque, and said: Messenger of Allah, how should I make the rak'ahs of the night prayer an odd number? Upon this the Messenger of Allah (way peace he upon him) said: He who prays (night prayer) he should observe it in pairs, but if he apprehends the rise of morning, he should observe one rak'ah; that would make the number odd (for the rak'ahs) observed by him. This was narrated by Abd Kuraib 'Ubaidullah b. 'Abdullah and Ibn 'Umar did not make mention of it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1645]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1645

Anas b. Sirin reported: I asked Ibn 'Umar to tell me about the practice of the Holy Prophet (may peace be upon him) in regard to two rak'ahs before the dawn prayer: Should I make lengthy recitation in them? He said: The Messenger of Allah (may peace be upon him) used to observe, the night prayer in pairs and then made the number odd by observing one rak'ah. I said: I am not asking you about it. He said: You are a bulky man, will you not show me the patience to narrate to you the hadith completely? The Messenger of Allah (may peace be upon him) used to observe the night prayer in pairs and then made the number odd by observing one rak'ah, and then he observed two rak'ahs before dawn quite close to the call for prayer (Khalaf said:" Did you see [yourself the Holy Prophet observing] the two rak'ahs before the dawn?" and he made no mention of prayer.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1646]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1646

Anas b. Sirin reported: I asked Ibn 'Umar like this (as recorded in the previous hadith) and he made this addition:" And he (the Holy Prophet) made the end of the night prayer as odd number by one rak'ah." And there is also (this addition):" Stop, stop, you are bulky."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1647]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1647

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: The night prayer consists of pairs and when you see the approach of dawn, make this number odd by one rak'ah. It was said to Ibn 'Umar: What does the (word) pair imply? He said: (It means) that salutation is uttered after every two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1648]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1648

Abu Sa'id (al Khudri) reported Allah's Apostle (may peace be upon him) as saying: Observe Witr prayer before it is morning. Abu Sa'id reported that they (the Prophet's Companions) asked the Apostle of Allah (may peace be upon him) about Witr (prayer). (In reply to their inquiry) he said: Observe Witr prayer before it is morning.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1649]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1649

Abu Sa'id reported that they (some of the Companions) of the Holy Prophet (may peace be upon him) asked the Apostle of Allah (may peace be upon him) about Witr. He said: Observe Witr before morning.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1650]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1650

Jabir reported Allah's Messenger (may peace be upon him) as saying: If anyone is afraid that he may not get up in the latter part of the night, he should observe Witr in the first part of it; and if anyone is eager to get up in the last part of it, he should observe Witr at the end of the night, for prayer at the end of the night is witnessed (by the angels) and that is preferable.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1651]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1651

Jabir reported Allah's Messenger (may peace be upon him) as saying: He who amongst you is afraid that he may not be able to get up at the end of the night should observe Witr (in the first part) and then sleep, and he who is confident of getting up and praying at night (i. e. Tahajjud prayer) should observe it at the end of it, for the recitation at the end of the night to visited (by angels), and that is excellent.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1652]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1652

Jabir reported Allah's Messenger (may peace be upon him) as saying: The most excellent prayer is that in which the duration of standing is longer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1653]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1653

Jabir reported: The Messenger of Allah (may peace be upon him) was asked about the prayer which was most excellent. He said: That in which the standing is longer. (This hadith is narrated by another chain of transmitters too.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1654]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1654

Jabir said he heard Allah's Messenger (may peace be upon him) say: There is an hour during the night in which no Muslim individual will ask Allah for good in this world and the next without His giving it to him; and that applies to every night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1655]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1655

Jabir reported: I heard the Apostle of Allah (may peace be upon him) as saying: There is an hour during the night in which no Muslim bondman will ask Allah for good in this world and the next but He will grant it to him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1656]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1656

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Our Lord, the Blessed and the Exalted, descends every night to the lowest heaven when one-third of the latter part of the night is left, and says: Who supplicates Me so that I may answer him? Who asks Me so that I may give to him? Who asks Me forgiveness so that I may forgive him?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1657]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1657

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah descends every night to the lowest heaven when one-third of the first part of the night is over and says: I am the Lord; I am the Lord: who is there to supplicate Me so that I answer him? Who is there to beg of Me so that I grant him? Who is there to beg forgiveness from Me so that I forgive him? He continues like this till the day breaks.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1658]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1658

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When half of the night or two-third of it is over. Allah, the Blessed and the Exalted, descends to the lowest heaven and says: Is there any beggar, so that he be given? Is there any supplicator so that he be answered? Is there any beggar of forgiveness so that he be forgiven? (And Allah continues it saying) till it is daybreak.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1659]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1659

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah descends to the lowest heaven at half of the night or at one-third of the latter part and says: Who is there to supplicate Me so that I answer him? Who is there to ask Me so that I grant him? And then says: Who will lend to One Who is neither indigent nor tyrant? (This hadith has been narrated by Sa'd b. Sa'id with the same chain of transmitters with this addition:" Then the Blessed and the Exalted (Lord) stretches His Hands and says: Who will lend to One Who is neither indigent nor tyrant? )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1660]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1660

Abu Sa'id and Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah waits till when one-third of the first part of the night is over; He descends to the lowest heaven and says: It there any supplicator of forgiveness? Is there any penitant? Is there any petitioner (for mercy and favour)? Is there any solicitor? -till it is daybreak.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1661]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1661

This hadith is narrated by Ishaq with the same chain uf transmitters except this that the hadith transmitted by Mansur (the above one) is more comprehensive and lengthy.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1662]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1662

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who observed prayer at night during Ramadan, because of faith and seeking his reward from Allah, his previous sins would be forgiven.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1663]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1663

Abu Huraira reported: The Messenger of Allah (may peace be upon him) used to exhort (his Companions) to pray (at night) during Ramadan without commanding them to observe it as an obligatory act, and say: He who observed the night prayer in Ramadan because of faith and seeking his reward (from Allah), all his previous sins would be forgiven. When Allah's Messenger (may peace be upon him) died, this was the practice, and it continued thus during Abu Bakr's caliphate and the early part of 'Umar's caliphate.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1664]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1664

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who observed the fasts of Ramadan with faith and seeking reward (from Allah), all his previous sins would be forgiven, and he who observed prayer on Lailat-ul- Qadr with faith and seeking reward (from Allah), all his previous sins would be forgiven.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1665]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1665

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who prayed on the Lailat-ul-Qadr (the Majestic Night) knowing that it is (the same night). I (believe) that he (the Holy Prophet also) said: (He who does) it with faith and seeking reward (from Allah), his sins would be forgiven.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1666]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1666

'A'isha reported that the Messenger of Allah (may peace be upon him) prayed one night in the mosque and people also prayed along with him. He then prayed on the following night and there were many persons. Then on the third or fourth night (many people) gathered there, but the Messenger of Allah (may peace be upon him) did not come out to them (for leading the Tarawih prayer). When it was morning he said: I saw what you were doing, but I desisted to come to you (and lead the prayer) for I feared that this prayer might become obligatory for you. (He the narrator) said: It was the month of Ramadan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1667]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1667

'A'isha reported: The Messenger of Allah (may peace be upon him) came out during the night and observed prayer in the mosque and some of the people prayed along with him. When it was morning the people talked about this and so a large number of people gathered there. The Messenger of Allah (may peace be upon him) went out for the second night, and they (the people) prayed along with him. When it was morning the people began to talk about it. So the mosque thronged with people on the third night. He (the Holy Prophet) came out and they prayed along with him. When it was the fourth night, the mosque was filled to its utmost capacity but the Messenger of Allah (may peace be upon him) did not come out. Some persons among then cried:" Prayer." But the Messenger of Allah (may peace be upon him) did not come to them till he came out for the morning prayer. When he had completed the morning prayer, he turned his face to the people and recited Tashahhud (I bear testi- mony that there is no god but Allah and I bear testimony that Muhammad is His Messen- ger) and then said: Your affair was not hidden from me in the night, but I was afraid that (my observing prayer continuously) might make the night prayer obligatory for you and you might be unable to perform it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1668]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1668

Zirr (b. Hubaish) reported: I heard from Ubayy b. Ka'b a statement made by 'Abdullah b. Mas'ud in which he said: He who gets up for prayer (every night) during the year will hit upon Lailat-ul-Qadr. Ubayy said: By Allah I there is no god but He, that (Lailat-ul-Qadr) is in Ramadhan (He swore without reservation: ) By Allah, I know the night; it is the night on which the Messenger of Allah (may peace be upon him) commanded us to pray. It is that which precedes the morning of twenty-seventy and its indication is that the sun rises bright on that day without rays.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1669]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1669

Ubayy b Ka'b reported: By Allah, I know about Lailat-ul Qadr and I know it fully well that it is the twenty-seventh night (during Ramadan) on which the Messenger of Allah (may peace be upon him) commanded us to observe prayer. (Shu'ba was in doubt about these words:" the night on which the Messenger of Allah [may peace be upon him] commanded us to observe the prayer." This has been transmitted to me by a friend of mine.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1670]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1670

Shu'ba reported this hadith with the same chain of transmitters, but he made no mention that Shu'ba was in doubt and what follows subsequently.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1671]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1671

Ibn 'Abbas reported: I spent a night with my material aunt (sister of my mother) Maimuna. The Apostle of Allah (may peace be upon him) got up during the night and relieved himself, then washed his face and hands and went to sleep. He then got up again, and came to the water skin and loosened its straps, then performed good ablution between the two extremes. He then stood up and observed prayer. I also stood up and stretched my body fearing that he might be under the impression that I was there to find out (what he did at night). So I also performed ablution and stood up to pray, but I stood on his left. He took hold of my hand and made me go round to his right side. The Messenger of Allah (may peace be upon him) completed thirteen rak'abs of his night prayer. He then lay down and slept and snored (and it was his habit to snore while asleep). Then Bilal came and he informed him about the prayer. He (the Holy Prophet) then stood up for prayer and did not perform ablution, and his supplication included there words:" O Allah, place light in my heart, light in my sight, light in my hearing, light on my right hand, light on my left hand, light above me, light below me, light in front of me, light behind me, and enhance light for me."

Kuraib (the narrator) said: There are seven (words more) which are in my heart (but I cannot recall them) and I met some of the descendants of 'Abbas and they narrated these words to me and mentioned in them: (Light) in my sinew, in my flesh, in my blood, in my hair, in my skin, and made a mention of two more things.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1672]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1672

Kuraib, the freed slave of Ibn 'Abbas, reported that Ibn 'Abbas narrated to him that he spent a night in the house of Maimuna, the mother of the believers, who was his mother's sister. I lay down across the cushion, whereas the Messenger of Allah (may peace be upon him) and his wife lay down on it length-wise. The Messenger of Allah (may peace be upon him) slept up till midnight, or a little before midnight of a little after midnight, and then got up and began to cast off the effects of sleep from his face by rubbing with his hand, and then recited the ten concluding verses of Surah 'Imran. He then stood up near a hanging water-skin and performed ablution well, and then stood up and prayed, 'Ibn 'Abbas said: I also stood up and did the same, as the Messenger of Allah (may peace be upon him) had done, and then went to him and stood by his side. The Messenger of Allah (may peace be upon him) placed his right hand upon my head and took hold of my right ear and twistedit, and then observed a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, again a pair of rak'ahs, and then observed Witr and then lay down till the Mu'adhdhin came to him. He (the Holy Prophet) then stood up and observed two short rak'ahs, and then went out (to the mosque) and observed the dawn prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1673]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1673

Makhrama b. Sulaiman narrated it with the same chain of narrators and he made this addition:" He then went to the water-skin and brushed his teeth and performed ablution well. He did not pour water but a little. He then awakened me and I stood up," and the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1674]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1674

Ibn Abbas reported: I slept (one night) in the house of Maimuna, the wife of the Apostle of Allah (may peace be upon him), and the Apostle of Allah (may peace be upon him) was with her that night. He (after sleeping for half of the night got up and) then performed ablution and then stood up and observed prayer. I too stood on his left side. He took hold of me and made me stand on his right side. He (the Holy Prophet) observed thirteen rak'ahs on that night. The Messenger of Allah (may peace be upon him) then slept and snored and it was a habit with him to snore while sleeping. The Mu'adhdbin then came to him (to inform him about the prayer). He then went out and observed prayer without performing ablution. ('Amr said: Bukair b. Ashajj had narrated it to me )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1675]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1675

Ibn 'Abbas reported: I spent one night in the house of my mother's sister Maimuna, daughter of Harith, and said to her: Awake me when the Messenger of Allah (may peace be upon him) stands to pray (at night). (She woke me up when) the Messenger of Allah (may peace be upon him) stood up for prayer. I stood on his left side. He took hold of my hand and made me stand on his right side, and whenever I dozed off he took hold of my earlobe (and made me alert). He (the narrator) said: He (the Holy Prophet) observed eleven rak'ahs. He then sat with his legs drawn and wrapped in his garment and slept so that I could bear his breathing while asleep. And when the dawn appeared, he observed two short rak'ahs of (Sunnah) prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1676]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1676

Ibn 'Abbas reported that he spent a night in the house of his matenial aunt, Maimuna. The Messenger of Allah (may peace he upon him) got up at night and performed short ablution (taking water) from the water-skin hanging there. (Giving a description of the ablution Ibn 'Abbas said: It was short and performed with a little water.) I also got up and did the same as the Apostle of Allah (may peace be upon him) had done. I then came (to him) and stood on his left. He then made me go around to his right side. He then observed prayer and went to sleep till he began to snore. Bilal came to him and informed him about the prayer. He (the Holy Prophet) then went out and observed the dawn prayer without performing ablution. Sufyan said: It was a special (prerogative of the) Apostle of Allah (may peace be upon him) for it has been conveyed to us that the eyes of the Apostle of Allah (may peace be upon him) sleep, but his heart does not sleep.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1677]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1677

Ibn 'Abbas said: I spent the night in the house of my mother's sister, Maimuna, and observed how the Messenger of Allah (may peace be upon him) prayed (at night). He got up and relieved himself. He then washed his face and hands and then went to sleep. He again got up and went near the water-skin and loosened its straps and then poured some water in a bowl and inclined it with his hands (towards himself). He then performed a good ablution between the two extremes and then stood up to pray. I also came and stood by his left side. He took hold of me and made me stand on his right side. It was in thirteen rak'ahs that the (night) prayer of the Messenger of Allah (may peace be upon him) was completed. He then slept till he began to snore, and we knew that he had gone to sleep by his snoring. He then went out (for the dawn prayer) and then again slept, and said while praying or prostrating himself:" O Allah! place light in my heart, light in my hearing, light in my sight, light on my right, light on my left, light in front of me, light behind me, light above me, light below me, make light for me," or he said:" Make me light."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1678]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1678

Salama said: I met Kuraib and he reported Ibn 'Abbas as saying: I was with my mother's sister Maimuna that the Messenger of Allah (may peace be upon him) came there, and then he narrated the rest of the hadith as was narrated by Ghundar and said these words:" Make me light," beyond any doubt.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1679]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1679

Ibn 'Abbas reported: I spent a night in the house of my mother's sister, Maimuna, and then narrated (the rest of the) haditb, but he made no mention of the washing of his face and two hands but he only said: He then came to the water-skin and loosened its straps and performed ablution between the two extremes, and then came to his bed and slept. He then got up for the second time and came to the waterskin and loosened its straps and then performed ablution which was in fact an ablution (it was performed well), and implored (the Lord) thus:" Give me abundant light," and he made no raention of:" Make me light."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1680]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1680

Kuraib reported that Ibn 'Abbas spent a night in the house of the Messenger of Allah (may peace be upon him) and he said: The Messenger of Allah may peace be upon him) stood near the water-skin and poured water out of that and performed ablution in which he neither used excess of water nor too little of it, and the rest of the hadith is the same, and in this mention is also made (of the fact) that on that night the Messenger of Allah (may peace be upon him) made supplication before Allah in nineteen words. Kuraib reported: I remember twelve words out of these, bux have forgotten the rest. The Messenger of Allah said:" Place light in my heart, light in my tongue, light in my hearing, light in my sight, light above me, light below me, light on my right, light on my left, light in front of me, light behind me, place light in my soul, and make light abundant for me."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1681]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1681

Ibn 'Abbas reported: I slept one night in the house of Maimuna when the Apostle of Allah (may peace be upon him) was there, with a view to seeing the prayer of the Apostle of Allah (may peace be upon him) at night. The Apostle of Allah (may peace be upon him) entered into conversation with his wife for a short while, and then went to sleep, and the rest of the hadith is the same and in it mention is made of:" He then got up, performed ablution and brushed his teeth."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1682]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1682

'Abdullah b. 'Abbas reported: He spent (one night) in the house of the Messenger of Allah (may peace be upon him). He (the Holy Prophet) got up, brushed his teeth and performed ablution and said:" In the creation of the heavens and the earth, and the alternation of the night and the day, there are indeed signs for people of understanding" (al-Qur'an, iii. 190), to the end of the Surah. He then stood up and prayed two rak'ahs, standing, bowing and prostrating himself at length in them. Then he finished, went to sleep and snored. He did that three times, six rak'ahs altogether, each time cleaning his teeth, performing ablution, and reciting these verses. Then he observed three rak'ahs of Witr. The Mu'adhdhin then pronounced the Adhan and he went out for prayer and was saying,:" O Allah I place light in my heart, light in my tongue, place light in my hearing, place light in my eyesight, place light behind me, and light in front of me, and place light above me, and light below me. O Allah! grant me light."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1683]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1683

Ibn Abbas reported: I spent a night in the house of my mother's sister Maimuna. The Apostle of Allah (way peace be upon him) got up for observing voluntary prayer (Tahajjud) at night. The Apostle of Allah (may peace be upon him) stood by the water-skin and performed ablution and then stood up and prayed. I also got up when I saw him doing that. I also performed ablution from the water-skin and then stood at his left side. He took hold of my hand from behind his back and then turned me from his back to his right side. I ('Ata', one of the narrators) said: Did it concern the voluntary prayer (at night)? He ('Ibn 'Abbas) said: Yes.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1684]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1684

Ibn 'Abbas reported: (My father) Abbas sent me to the Apostle of Allah (may peace be upon him) and he was in the house of my mother's sister Maimuna and spent that night along with him. He (the Holy Prophet) got up and prayed at night, and I stood up on his left side. He caught hold of me from behind his back and made me stand on his right side.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1685]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1685

Ibn 'Abbas reported: I spent a night in the house of my mother's sister Maimuna, and the rest of the hadith is the same as narrated above.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1686]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1686

Abu Jamra reported: I heard Ibn 'Abbas saying that the Messenger of Allah (may peace be upon him) observed thirteen rak'ahs at night.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1687]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1687

Zaid b Khalid al-Juhani said: I would definitely watch at night the prayer observed by the Messenger of Allah (may peace be upon him). He prayed two short rak'ahs, then two long, long, long rak'ahs, then he prayed two rak'ahs which were shorter than the two preceding rak'ahs, then he prayed two rak'ahs which were shorter than the two preceding, then he prayed two rak'ahs which were shorter than the two preceding, then observed a single one (Witr), making a total of thirteen rak'ahs


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1688]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1688

Jabir b. 'Abdullah reported: I accompanied the Messenger of Allah (may peace be upon him) in a journey and we reached a watering place. He said: Jabir, are you going to enter it? I said: Yes. The Messenger of Allah (may peace be upon him) then got down and I entered it. He (the Holy Prophet) then went away to relieve himself and I placed for him water for ablution. He then came back and performed ablution, and then stood and prayed in one garment, having its ends tied from the opposite sides. I stood. behind him and he caught hold of my ear and made me stand on his right side.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1689]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1689

'A'isha reported that when the Messenger of Allah (may peace be upon him) stood up at night to pray, he began his prayer with two short rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1690]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1690

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying When any one of you gets up at night, he should begin the prayer with two short rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1691]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1691

Ibn Abbas reported that when the Messenger of Allah (may peace be upon him) got up during the night to pray, he used to say: O Allah, to Thee be the praise Thou art the light of the heavens and the earth. To Thee be the praise; Thou art the Supporter of the heavens and the earth. To Thee be the praise; Thou art the Lord of the heavens and the earth and whatever is therein. Thou art the Truth; Thy promise is True, the meeting with Thee is True. Paradise is true, Hell is true, the Hour is true. O Allah, I submit to Thee; affirm my faith in Thee; repose my trust in Thee, and I reurn to Thee for repentance; by Thy help I have disputed; and to Thee I have come for decision, so forgive me my earlier and later sins, the sins that I committed in secret and openly. Thou art my God. There is no god but Thee.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1692]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1692

This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters and with slight alteration of two words. Instead of the word Qayyam (Supporter, as used in the above hadith here the word) Qayyim (the Custodian) has been used, and he (further said):" What I did in secret." And in the hadith narrated by Ibn 'Uyaina there is some addition.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1693]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1693

This hadith has been narrated by Ibn 'Abbas by another chain of transmitters and the words are nearly the same (as recorded in the above-mentioned hadith).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1694]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1694

'Abd al-Rahman b. 'Auf reported: I asked 'A'isha, the mother of the believers, (to tell me) the words with which the Apostle of Allah (may peace be upon him) commenced the prayer when he got up at night. She said: When he got up at night he would commence his prayer with these words: O Allah, Lord of Gabriel, and Michael, and Israfil, the Creator of the heavens and the earth, Who knowest the unseen and the seen; Thou decidest amongst Thy servants concerning their differences. Guide me with Thy permission in the divergent views (which the people) hold about Truth, for it is Thou Who guidest whom Thou wilt to the Straight Path.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1695]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1695

'Ali b. Abu Talib reported that when the Messenger of Allah (may peace be upon him) got up at night for prayer he would say: I turn my face in complete devotion to One Who is the Originator of the heaven and the earth and I am not of the polytheists. Verily my prayer, my sacrifice, my living and my dying are for Allah, the Lord of the worlds; There is no partner with Him and this is what I have been commanded (to profess and believe) and I am of the believers. O Allah, Thou art the King, there is no god but Thee, Thou art my Lord, and I am Thy bondman. I wronged myself and make a confession of my Sin. Forgive all my sins, for no one forgives the sins but Thee, and guide me in the best of conduct for none but Thee guideth anyone (in) good conduct. Remove sins from me, for none else but Thou can remove sins from me. Here I am at Thy service, and Grace is to Thee and the whole of good is in Thine hand, and one cannot get nearneststo Thee through evil. My (power as well as existence) is due to Thee (Thine grace) and I turn to Thee (for supplication). Thou art blessed and Thou art exalted. I seek forgiveness from Thee and turn to Thee in repentance: and when he would bow, he would say: O Allah, it is for Thee that I bowed. I affirm my faith in Thee and I submit to Thee, and submit humbly before Thee my hearing, my eyesight, my marrow, my bone, my sinew; and when he would raise his head, he would say: O Allah, our Lord, praise is due to Thee, (the praise) with which is filled the heavens and the earth, and with which is filled that (space) which exists between them, and filled with anything that Thou desireth afterward. And when he prostrated himself, he (the Holy Prophet) would say: O Allah, it is to Thee that I prostrate myself and it is in Thee that I affirm my faith, and I submit to Thee. My face is submitted before One Who created it, and shaped it, and opened his faculties of hearing and seeing. Blessed is Allah, the best of Creators; and he would then say between Tashahhud and the pronouncing of salutation: Forgive me of the earlier and later open and secret (sins) and that where I made transgression and that Thou knowest better than I. Thou art the First and the Last. There is no god, but Thee.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1696]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1696

A'raj reported that when the Messenger of Allah (may peace be upon him) would start the prayer, he would pronounce takbir (Allah-o-Akbar) and then say: I turn my face (up to Thee), I am the first of the believers; and when he raised his head from ruku' he said: Allah listened to him who praised Him; O our Lord, praise be to Thee; and he said: He shaped (man) and how fine is his shape? And he (the narrator) said: When he pronounced salutation he said: O Allah, forgive me my ear- lier (sins), to the end of the hadith; and he did not say it between the Tashahhud and salutation (as mentioned above).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1697]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1697

Hudhaifa reported: I prayed with the Apostle of Allah (may peace be upon him) one night and he started reciting al-Baqara. I thought that he would bow at the end of one hundred verses, but he proceeded on; I then thought that he would perhaps recite the whole (surah) in a rak'ah, but he proceeded and I thought he would perhaps bow on completing (this surah). He then started al-Nisa', and recited it; he then started Al-i-'Imran and recited leisurely. And when he recited the verses which referred to the Glory of Allah, he glorified (by saying Subhan Allah-Glory to my Lord the Great), and when he recited the verses which tell (how the Lord) is to be begged, he (the Holy Prophet) would then beg (from Him), and when he recited the verses dealing with protection from the Lord, he sought (His) protection and would then bow and say: Glory be to my Mighty Lord; his bowing lasted about the same length of time as his standing (and then on returning to the standing posture after ruku') he would say: Allah listened to him who praised Him, and he would then stand about the same length of time as he had spent in bowing. He would then prostrate himself and say: Glory be to my Lord most High, and his prostration lasted nearly the same length of time as his standing. In the hadith transmitted by Jarir the words are:" He (the Holy Prophet) would say:" Allah listened to him who praised Him, our Lord, to Thee i the praise."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1698]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1698

'Abdullah reported: I prayed with the Messenger of Allah (may peace be upon him) and he lengthened it till I entertained an evil thought. It was said to him what that thought was. He said: I thought that I should sit down and forsake him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1699]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1699

A hadith like this has been narrated by A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1700]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1700

'Abdullah (b. Mas'ud) reported that a mention was made of a man who slept the whole night till morning. He (the Holy Prophet) remarked: That is a man in whose ears (or in whose ear) the devil urinated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1701]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1701

Husain b. 'Ali narrated on the authority of (his father) 'Ali b. Abu Talib that the Apostle of Allah (may peace be upon him) came one night to see him ('Ali) and Fatimah (the daughter of the Holy Prophet) and said: Don't you observe (Tahajjud) prayer? I ('Ali) said: Messenger of Allah, verily our souls are in the hands of Allah and when He wants to awaken us, He awakens us. The Messenger of Allah (may peace be upon him) went back when I said this to him. He was striking his hand on his thigh while returning, and I heard him say: Verily the man disputes with many things.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1702]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1702

Abu Huraira transmitted it from the Apostle of Allah (may peace be upon him): When any one of you goes to sleep, the devil ties three knots at the back of his neck, sealing every knot with:" You have a long night, so sleep." So if one awakes and mentions Allah, a knot will be loosened; if he performs ablution two knots are loosened; and if he prays (all) knots will be loosened, and in the morning he will be active and in good spirits; otherwise we will be in bad spirits and sluggish in the morning.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1703]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1703

Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: Observe some of your prayers in your houses and do not make them graves.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1704]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1704

Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: Pray in your houses, and do not make them graves.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1705]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1705

Jabir reported Allah's Messenger (may peace be upon him) as saying: When any one of you observes prayer in the mosque he should reserve a part of his prayer for his house, for Allah would make the prayer as a means of betterment in his house.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1706]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1706

Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The house in which remembrance of Allah is made and the house in which Allah is not remembered are like the living and the dead.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1707]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1707

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not make your houses as graveyards. Satan runs away from the house in which Surah Baqara is recited.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1708]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1708

Zaid b. Thabit reported: The Messenger of Allah (may peace be upon him) made an apartment with the help of the leaves of date trees or of mats. The Messenger of Allah (may peace be upon him) went out to pray in it. People followed him and came to pray with him. Then they again came one night and waited (for him), but the Messenger of Allah (may peace be upon him) delayed in coming out to them. And when he did not come out, they cried aloud and threw pebbles at the door. The Messenger of Allah (may peace be upon him) came out in anger and said to them: By what you have been constantly doing, I was inclined to think that it (prayer) might not become obligatory for you. So you must observe prayer (optional) in your houses, for the prayer observed by a man in the house is better except an obligatory prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1709]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1709

Zaid b. Thabit reported that the Apostle of Allah (may peace be upon him) made an apartment in the mosque of mats, and he observed in it prayers for many nights till people began to gather around him, and the rest of the hadith is the same but with this addition:" Had this (Nafl) prayer become obligatory for you, you would not be able to observe it."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1710]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1710

'A'isha reported that the Messenger of Allah (may peace be upon him) had a mat and he used it for making an apartment during the night and observed prayer in it, and the people began to pray with him, and he spread it (the mat) during the day time. The people crowded round him one night. He (the Holy Prophet) then Eaid: O people, perform such acts as you are capable of doing, for Allah does not grow weary but you will get tired. The acts most pleasing to Allah are those which are done continuously, even if they are small. And it was the habit of the members of Muhammad's (may peace be upon him) household that whenever they did an act they did it continuously.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1711]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1711

'A'isha is reported to have said that the Messenger of Allah (may peace be upon him) was asked about the act most pleasing to Allah. He replied: That which is done continuously, even if it is small.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1712]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1712

Alqama reported: I asked 'A'isha, the mother of the believers, saying O mother of the believers, how did the Messenger of Allah (may peace be upon him) act? Did he choose a particular act for a particular day? She said: No. He act was continuous, and who amongst you is capable of doing what the Messenger of Allah (may peace be upon him) did?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1713]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1713

'A'isha reported Allah's Messenger (may peace be upon him) as saying: The acts most pleasing to Allah are those which are done continuously, even if they are small. and when 'A'isha did any act she did it continuously.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1714]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1714

Anas reported that the Messenger of Allah (may peace be upon him) entered the mosque (and he found) a rope tied between the two pillars; so he said: What is this? They said: It is for Zainab. She prays and when she slackens or feels tired she holds it. Upon this he (the Holy Prophet) said: Untie it. Let one pray as long as one feels fresh but when one slackens or becomes tired one must stop it. (And in the hadith transmitted by Zuhair it is:" He should sit down." )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1715]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1715

A hadith like this has been narrated from the Apostle of Allah (may peace be upon him) on the authority of Anas by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1716]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1716

'Urwa b. Zubair reported that 'A'isha, the wife of the Apostle of Allah (may peace be upon him), told him that (once) Haula' dint Tuwait b. Habib b. Asad b. 'Abd al-'Uzzi passed by her (at the time) when the Messenger of Allah (may peace be upon him) was with her. I ('A'Isha) said: It Is Haula' bint Tuwait and they say that she does not sleep at night. Upon this the Messenger of Allah (may peace be upon him) said: (Oh) she does not sleep at night! Choose an act which you are capable of doing (continuously). By Allah, Allah would not grow weary, but you will grow weary.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1717]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1717

'A'isha said: The Messenger of Allah (way peace be upon him) came to me when a woman was sitting with me. He said: Who is she? I said: She is a woman who does not sleep but prays. He said: Do such acts which you are capable of doing. By Allah, Allah does not grow weary but you will grow weary. The religious act most pleasing to Him is one the doer of which does it continuously. (And in the hadith transmitted by Abu Usama [the words are]:" She was a woman from Banu Asad." )


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1718]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1718

'A'isha reported Allah's Apostle (may peace be upon him) as saying: When anyone amongst you dozes in prayer, he should sleep, till sleep is gone, for when one of you prays while dozing he does not know whether he may be asking pardon or vilifying himself.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1719]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1719

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you gets up at night (for prayer) and his tongue falters in (the recitation) of the Qar'an, and he does not know what he is reciting, he should go to sleep.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1720]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1720

'A'isha reported that the Apostle of Allah (may peace be upon him) heard a person reciting the Qur'an at night. Upon this he said: May Allah show mercy to him; he has reminded me of such and such a verse which I had missed in such and such a surah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1721]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1721

'A'isha reported that the Apostle of Allah (may peace be upon him) listened to the recitation of the Qur'an by a man in the mosque. Thereupon he said: May Allah have mercy upon him; be reminded me of the verse which I had been made to forget.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1722]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1722

'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: The example of a man who has memorised the Qur'an is like that of a hobbled camel. If he remained vigilant, he would be able to retain it (with him), and if he loosened the hobbled camel it would escape.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1723]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1723

This hadith has been narrated by Ibn 'Umar from the Apostle of Allah (may peace be upon him), but in the hadith transmited by Musa b. 'Uqba, this addition is made:" When one who had committed the Qur'an to memory (or who is familiar with it) gets up (for night prayer) and recites it night and day, it remains fresh in his mind, but if he does not get up (for prayer and thus does not recite it) he forgets it."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1724]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1724

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: What a wretched person is he amongst them who says: I have forgotten such and such a verse. (He should instead of using this expression say): I have been made to forget it. Try to remember the Qur'an for it is more apt to escape from men's minds than a hobbled camel.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1725]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1725

'Abdullah is reported to have said: Keep refreshing your knowledge of the sacred books (or always renew your knowledge of these sacred books) and sometimes he would mention the Qur'an for it is more apt to escape from men's minds than animals which are hobbled, and the Messenger of Allah (may peace be upon him) said: None of you should say: I forgot such and such a verse, but he has been made to forget.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1726]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1726

Ibn Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Wretched is the man who says: I forgot such and such a sura, or I forget such and such a verse, but he has been made to forget.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1727]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1727

Abu Musa al-Ash'ari reported Allah's Apostle (may peace be upon him) as saying: Keep refreshing your knowledge of the Qur'an, for I swear by Him in Whose Hand is the life of Mahammad that it is more liable to escape than camels which are hobbled.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1728]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1728

Abu Huraira reported this directly from the Messenger of Allah (may peace be upon him): God has not listened to anything as He listens to a Prophet reciting the Qur'an in a sweet voice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1729]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1729

This hadith has been narrated by Ibn Shihab with the same chain of transmitters with words:" As He listens to a Prophet reciting the Qur'an in a sweet voice."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1730]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1730

Abu Huraira is reported to have heard Allah's Messenger (may peace be upon him) as saying: Allah does not listen to anything, (more approvingly) as He listens to a Prophet reciting loudly the Qur'an in a sweet voice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1731]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1731

This hadith has been narrated with the same chain of transmitters by Ibn al-Had except this that Abu Huraira reported Allah's Messenger (may peace be upon him) as saying and he did not say:" He heard it."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1732]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1732

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah has not heard anything (more pleasing) than listening to the Prophet reciting the Qur'an in a sweet loud voice.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1733]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1733

This hadith has been narrated by another chain of transmitters but with a slight modification of words.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1734]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1734

Buraida reported on the authority of his father that the Messenger of Allah (may peace be upon him) had said: 'Abdullah b. Qais or al-Ash'ari has been gifted with a sweet melodious voice out of the voices of the family of David.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1735]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1735

Abu Burda narrated on the authority of Abu Musa that the Messenger of Allah (may peace be upon him) had said to Abu Musa: If you were to see me, as I was listening to your recitation (of the Qur'an) yester-night (you would have felt delighted). You are in fact endowed with a sweet voice like that of David himself.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1736]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1736

Mu'awiya b. Qurra reported 'Abdullah b. Mughaffal al-Muzani as saying: The Apostle of Allah (may peace be upon him) recited on his ride Surat al Fath during a journey in the year of the Conquest (of Mecca), and he repeated (the words) in his recitation. Mu'awiya said: If I were not afraid that the people would crowd around me, I would have given a demonstration of (the Prophet's) recitation before you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1737]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1737

Mu'awiya b. Qurra is reported to have heard 'Abdullah b. Mughaffal as saying: I saw the Messenger of Allah (may peace be upon him) reciting Surah Fath on his camel on the day of the Conquest of Mecca. He (the narrator) said: Ibn Mughaffal recited it and repeated it. Mu'awiya said: Had there been (no crowed of) people, I would have given a practical demonstration of that which Ibn Mughaffal had mentioned from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1738]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1738

This hadlth has been narrated by Khalid al-Harith with the same chain of transmitters (with these words:) (The Holy Prophet) was reciting Surat al-Fath as he was travelling on his mount.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1739]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1739

Al-Bara' reported that a person was reciting Surat al-Kahf and there was a horse tied with two ropes at his side, a cloud overshadowed him, and as it began to come nearer and nearer his horse began to take fright from it. He went and mentioned that to the Prophet (may peace be upon him) in the morning, and he (the Holy Prophet) said: That was tranquillity which came down at the recitation of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1740]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1740

Ibn Ishaq reported: I heard al-Bara' as saying that a man recited al-Kahf when an animal was there in the house and it began to take fright. And as he looked around, he found a cloud overshadowing it. He mentioned that to the Apostle of Allah (may peace be upon him). Upon this he said: O so and so, recite on (the surah) as- Sakina descends at the (recitation of the Qur'an) or on account (of the recitation) of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1741]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1741

This hadith has been narrated on the authority of al-Bara' with a slight modification of words.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1742]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1742

Abu Sa'id al-Khudri told of Usaid b. Hudair saying that one night he recited the Qur'an in his enclosure, when the horse began to jump about. He again recited and (the horse) again jumped. He again recited and it jumped as before. Usaid said: I was afraid lest it should trample (his son) Yahya. I stood near it (the horse) and saw something like a canopy over my head with what seemed to be lamps in it, rising up in the sky till it disappeared. I went to the Messenger of Allah (may peace be upon him) on the next day and said: Messenger of Allah, I recited the Qur'an during the night in my enclosure and my horse began to jump. Upon this the Messenger of Allah (may peace be upon him) said: You should have kept on reciting, Ibn Hudair. He (Ibn Hudair) said: I recited. It jumped (as before). Upon this the Messenger of Allah (may peace be upon him) again said: You should have kept on reciting, Ibn Hudair. He (Ibn Hudair) said: I recited and it again jumped (as before). The Messenger of Allah (may peace be upon him) again said: You should kave kept on reciting, Ibu Hudair. He (Ibn Hudair) said: (Messenger of Allah) I finished (the recitation) for Yahya was near (the horse) and I was afraid lest it should trample him. I saw something like a canopy with what seemed to be lamps in it rising up in the sky till it disappeared. Upon this the Messenger of Allah (may peace be upon him) said: Those were the angels who listened to you; and if you had continued reciting, the people would have seen them in the morning and they would not have concealed themselves from them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1743]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1743

Abu Musa al-Ash'ari reported Allah's Messenger (may peace be upon him) as saying: A believer who recites the Qur'an is like an orange whose fragrance is sweet and whose taste is sweet; a believer who does not recite the Qur'an is like a date which has no fragrance but has a sweet taste; and the hypocrite who recites the Qur'an is like a basil whose fragrance is sweet, but whose taste is bitter; and a hypocrite who does not recite the Qur'an is like the colocynth which has no fragrance and has a bitter taste.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1744]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1744

This hadith has been narrated by Qatada with the same chain of transmitters but with one alteration that instead of the word:" hypocrite" (Munafiq), there it is" wicked" (fajir).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1745]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1745

'A'isha reported Allah's Messenger (may peace be upon him) (as saying): One who is proficient in the Qur'an is associated with the noble, upright, recording angels; and he who falters in it, and finds it difficult for him, will have a double reward.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1746]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1746

This hadith has been reported with the same chain of transmitters by Qatada except with this change:" He who finds it hard (to recite the Qur'an) will have a double reward."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1747]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1747

Anas reported Allah's Messenger (may peace be upon him) as saying to Ubayy b. Ka'b: Allah has commanded me to recite the Qur'an to you. He said: Did Allah mention me to you by name? He (the Holy Prophet) said: Allah made a mention of your name to me. (On hearing this) Ubayy b. Ka'b wept.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1748]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1748

Anas reported Allah's Messenger (may peace be upon him) as saying to Ubayy b. Ka'b: Aliah has commanded me to recite to you:" Those who disbelieve were not..." (al-Qur'an, xcviii. 1). He said: Did He mention me by name? He (the Holy Prophet said): Yes. Upon this he shed tears (of gratitude).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1749]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1749

Qatada said: I heard Anas saying that the Messenger of Allah (may peace be upon him) said to Ubayy the same thing.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1750]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1750

'Abdullah (b. Mas'ud) reported: The Messenger of Allah (may peace be upon (him) asked me to recite the Qur'an. He said: Messenger of Allah, (how) should I recite to you whereas it has been sent down to you? He (the Holy Prophet) said: I desire to hear it from someone else. So I recited Surat al-Nisa' till I reached the verse: How then shall it be when We shall bring from every people a witness and bring you against them as a witness?" (verse 41). I lifted my head or a person touched me in my side, and so I lifted my head and saw his tears falling (from the Holy Prophet's eyes).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1751]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1751

This hadith has been narratted by A'mash with the same chain of transmitters but with this addition:" The Messenger of Allah (may peace be upon him) was on the pulpit when he asked me to recite to him."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1752]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1752

Ibrahim reported that the Apostle of Allah (may peace be upon him) asked 'Abdullah b. Mas'ud to recite to him (the Qur'an). He said: Should I recite it to you while it has been sent down or revealed to you? He (the Holy Prophet) said: I love to hear it from someone else. So he ('Abdullah b. Mas'ud) recited to him (from the beginning of Surat al Nisa' up to the verse:" How shall then it be when We bring from every people a witness and bring you as a witness against them?" He (the Holy Prophet) wept (on listening to it). It is narrated on the authority of Ibn Mas'ud through another chain of transmitters that the Apostle of Allah (may peace be upon him) also said that he had been a witness to his people as long as (said he): I lived among them or I had been among them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1753]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1753

'Abdullah (b. Mas'ud) reported: I was in Hims when some of the people asked me to recite the Qur'an to them. So I recited Surah Yusuf to them. One of the persons among the people said: By Allah, this is not how it has been sent down. I said: Woe upon you! By Allah, I recited it to the Messenger of Allah (may peace be upon him) and he said to me: You have (recited) it well. I was talking with him (the man who objected to my recitation) that I sensed the smell of wine from him. So I said to him. Do you drink wine and belie the Book (of Allah)? You would not depart till I would whip you. So I lashed him according to the prescribed punishment (for the offence of drinking wine).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1754]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1754

This hadith has been narrated by A'mash with the same chain of transmitters but with an exception that it is not mentioned in it:" He said to me: You recited (the Qur'an) well."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1755]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1755

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Would any one of you like, when he returns to his family, to find there three large, fat, pregnant she-camels? We said: Yes. Upon this he said: Three verses that one of you recites in his prayer are better for him than three large, fat, pregnant she-camels.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1756]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1756

'Uqba b. 'Amir reported: When we were in Suffa, the Messenger of Allah (may peace be upon him) came out and said: Which of you would like to go out every morning to Buthan or al-'Aqiq and bring two large she-camels without being guilty of sin or without severing the ties of kinship? We said: Messenger of Allah, we would like to do it. Upon this he said: Does not one of you go out in the morning to the mosque and teach or recite two verses from the Book of Allah. the Majestic and Glorious? That is better for him than two she-camels, and three verses are better (than three she-camels). and four verses are better for him than four (she-camels), and to on their number in camels.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1757]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1757

Abu Umama said he heard Allah's Messenger (may peace be upon him) say: Recite the Qur'an, for on the Day of Resurrection it will come as an intercessor for those who recite It. Recite the two bright ones, al-Baqara and Surah Al 'Imran, for on the Day of Resurrection they will come as two clouds or two shades, or two flocks of birds in ranks, pleading for those who recite them. Recite Surah al-Baqara, for to take recourse to it is a blessing and to give it up is a cause of grief, and the magicians cannot confront it. (Mu'awiya said: It has been conveyed to me that here Batala means magicians.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1758]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1758

This hadith has been narrated by Mu'awiya with the same chain of transmitters but with this exception that in this the words of Mu'awiya:" It has been conveyed to me..." have not been mentioned.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1759]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1759

An-Nawwas b. Sam'an said he heard the Apostle (may peace be upon him) say: On the Day of Resurrection the Qur'an and those who acted according to it will be brought with Surah al-Baqara and AI 'Imran preceding them. The Messenger of Allah (may peace be upon him) likened them to three things, which I did not forget afterwards. He (the Holy Prophet) likened them to two clouds, or two black canopies with light between them, or like two flocks of birds in ranks pleading for one who recited them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1760]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1760

Ibn 'Abbas reported that while Gabriel was sitting with the Apostle (may peace be upon him) he heard a creaking sound above him. He lifted his head and said: This As a gate opened in heaven today which had never been opened before. Then when an angel descended through it, he said: This is an angel who came down to the earth who had-never come down before. He greeted and said: Rejoice in two lights given to you which have not been given to any prophet before you: Falihat al-Kitab and the concluding verses of Suarah al-Baqara. You will never recite a letter from them for which you will not be given (a reward).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1761]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1761

'Abd al-Rahman b. Yazid reported: I met Abu Mas'ud near the House (Ka'ba) and said to him: A hadith has been conveyed to me on your authority about the two (concluding verses of Surah al-Baqara. He said: Yes. The Messenger of Allah (may peace be upon him) (in fact) said: Anyone who recites the two verses at the end of Surah al-Baqara at night, they would suffice for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1762]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1762

This hadith has been narrated by Mansur with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1763]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1763

Abu Mas'ud reported Allah's Messenger (may peace be upon him) as saying: If anyone recites the two verses at the end of Surah al-Baqara at night, they would suffice for him 'Abd al-Rahman said: I met Abu Mas'ud and he was circumambulating the House (of Allah) and asked him about this (tradition) and he narrated it to me from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1764]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1764

A hadith like this has been narrated by Abu Mas'ud from the Apostle of Allah (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1765]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1765

It is through another chain of transmitters that this hadith has been reported by Abu Mas'ud from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1766]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1766

Abu Darda' reported Allah's Apostle (may peace be upon him) as saying: If anyone learns by heart the first ten verses of the Surah al-Kahf, he will be protected from the Dajjal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1767]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1767

This hadith has been transmitted by Qatada with the same chain of transmitters. But Shu'ba (one of the narrators) said: At the end of Surah al-Kahf, but Hammam said: At the beginning of Surah al-Kahf.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1768]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1768

Ubayy b. Ka'b said: Allah's Messenger (may peace be upon him) said: O Abu' al-Mundhir, do you know the verse from the Book of Allah which, according to you, is the greatest? I said: Allah and His Apostle (may peace be upon him) know best. He again said: Abu'l-Mundhir, do you know the verse from the Book of Allah which, according to you, is the greatest? I said: Allah, there is no god but He, the Living, the Eternal. Thereupon he struck me on my breast and said: May knowledge be pleasant for you, O Abu'l-Mundhir!


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1769]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1769

Abu Darda' reported Allah's Apostle (may peace be upon him) as saying: Is any one of you incapable of reciting a third of the Qur'an in a night? They (the Companions) asked: How could one recite a third of the Qur'an (in a night)? Upon this he (the Holy Prophet) said:" He is Allah, One" (Qur'An. cxii.) is equivalent to a third of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1770]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1770

This hadith has been narrated by Qatada with the same chain of transmitters in these words: He (the Apostle of Allah) said: Allah divided the Qur'an into three parts, and he made:" Say: He, Allah is One." one part out of the (three) parts of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1771]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1771

It is reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Get together. for I am going to recite one-third of the Qur'an before you. And those who could get together gathered there. Then the Apostle of Allah (may peace be upon him) came out and recited:" Say: He, Allah, is One." He then entered (his house). Some of us said to the others: Perhaps there has been some news from the heaven on account of which he has gone Inside (the house). The Apostle of Allah (may peace be upon him) again came out and said: I told you that I was going to recite one-third of the Qur'in; keep in mind, this (Surah Ikhlas) is equivalent to one-third of the Qur'an.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1772]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1772

Abu Huraira reported: The Messenger of Allah (may peace be upon him) came out to us and said: I am going to recite before you one-third of the Qur'an. He (the Holy Prophet) then recited:" Say: He is Allah, One--Allah, the Eternal," to the end of the Surah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1773]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1773

'A'isha reported: The Messenger of Allah (may peace be upon him) sent a man in charge of an expedition and he would recite for his Companions during their prayer, ending (recitation) with:" Say, He is God, One." When they returned mention was made of it to the Messenger of Allah (may peace be upon him). He (the Holy Prophet) told them to ask him why he had done like that. So they asked him and he said: Verily, it is an attribute of the Compassionate One, and (for this reason) I love to recite it. The Messenger of Allah (may peace be upon him) thereupon said: Inform him that Allah loves him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1774]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1774

'Uqba b. 'Amir reported Allah's Messenger (may peace be upon him) as saying: What wonderful verses have been sent down today. the like of which has never been seen! They are:" Say: I seek refuge with the Lord of the dawn," and" Say: I seek refuge with the Lord of men."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1775]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1775

'Uqba b. 'Amir reported: The Messenger of Allah (may peace be upon him) said to me: There have been sent down to me verses the like of which had never been seen before. They are the Mu'awwadhatain.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1776]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1776

This hadith has been narrated through another chain of transmitters directly from the Companions of Muhammad (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1777]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1777

Salim narrated on the authority of his father (Ibn 'Umar) that the Apostle of Allah (may peace be upon him) said: Envy is not justified but in case of two persons only: one who, having been given (knowledge of) the Qur'an by Allah, recites it during the night and day (and also acts upon it) and a man who, having been given wealth by God, spends it during the night and the day (for the welfare of others. seeking the pleasure of the Lord).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1778]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1778

Salim son of Abdullah b. 'Umar is reported to have said on the authority of his father that the Messenger of Allah (may peace be upon him) observed: Envy is not justified but in case of two persons only: one who, having been given (knowledge of) the Qur'an by Allah, recites it during the night and during the day (and acts upon it), and the person who, having been given wealth by God, gives it in charity during the night and the day.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1779]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1779

'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: There should be no envy but only in case of two persons: one having been endowed with wealth and power to spend it in the cause of Truth, and (the other) who has been endowed with wisdom and he decides cases with the help of it and teaches it (to others).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1780]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1780

'Amir b. Wathila reported that Nafi' b. 'Abd al-Harith met 'Umar at 'Usfan and 'Umar had employed him as collector in Mecca. He (Hadrat 'Umar) said to him (Nafi'): Whom have you appointed as collector over the people of the valley? He said: Ibn Abza. He said: Who is Ibn Abza? He said: He is one of our freed slaves. He (Hadrat 'Umar) said: So you have appointed a freed slave over them. He said: He is well versed In the Book of Allah. the Exalted and Great, and he is well versed In the commandments and injunctions (of the Shari'ah). 'Umar said: So the Holy Prophet (may peace be upon him) said: By this Book, Allah would exalt some peoples and degrade others.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1781]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1781

This hadith has been narrated by Zuhri through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1782]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1782

'Umar b. Khattab said: I heard Hisham b. Hakim b. Hizam reciting Surah al-Furqan in a style different from that in which I used to recite it, and in which Allah's Messenger (may peace be upon him) had taught me to recite it. I was about to dispute with him (on this style) but I delayed till he had finished that (the recitation). Then I caught hold of his cloak and brought him to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, I heard this man reciting Surah al-Furqan in a style different from the one in which you taught me to recite. Upon this the Messenger of Allah (may peace be upon him) told (me) to leave him alone and asked him to recite. He then recited in the style in which I beard him recite it. The Messenger of Allah (may peace be upon him) then said: Thus was it sent down. He then told me to recite and I recited it, and he said: Thus was it sent down. The Qur'an was sent down in seven dialects. So recite what seems easy therefrom.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1783]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1783

This hadith has been transmitted thus by 'Umar b. Khattab (with a slight change of words):" I heard Hisham b. Hakim reciting Surah al-Furqan during the lifetime of Allah's Messenger (may peace be upon him)." The rest is the same but with this addition:" I was about to catch hold of him in prayer, but I exercised patience till he pronounced salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1784]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1784

This hadith has been transmitted by Zuhri.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1785]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1785

Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: Gabriel taught me to recite in one style. I replied to him and kept asking him to give more (styles), till he reached seven modes (of recitation). Ibn Shibab said: It has reached me that these seven styles are essentially one, not differing about what is permitted and what is forbidden.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1786]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1786

This hadith has been narrated by Zuhri with the same chain of trans- mitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1787]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1787

Ubayy b. Ka'b reported: I was in the mosque when a man entered and prayed and recited (the Qur'in) in a style to which I objected. Then another man entered (the mosque) and recited in a style different from that of his companion. When we had finished the prayer, we all went to Allah's Messenger (may peace be upon him) and said to him: This man recited in a style to which I objected, and the other entered and recited in a style different from that of his companion. The Messenger of Allah (may peace be upon him) asked them to recite and so they recited, and the Apostle of Allah (may peace be upon him) expressed approval of their affairs (their modes of recitation). and there occurred In my mind a sort of denial which did not occur even during the Days of Ignorance. When the Messenger of Allah (may peace be upon him) saw how I was affected (by a wrong idea), he struck my chest, whereupon I broke into sweating and felt as though I were looking at Allah with fear. He (the Holy Prophet) said to me: Ubayy. a message was sent to me to recite the Qur'an in one dialect, and I replied: Make (things) easy for my people. It was conveyed to me for the second time that it should be recited in two dialects. I again replied to him: Make affairs easy for my people. It was again conveyed to me for the third time to recite in seven dialects And (I was further told): You have got a seeking for every reply that I sent you, which you should seek from Me. I said: O Allah! forgive my people, forgive my people, and I have deferred the third one for the day on which the entire creation will turn to me, including even Ibrahim (peace be upon him) (for intercession).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1788]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1788

Ubayy b. Ka'b reported that he was sitting in a mosque that a person entered it and he observed prayer, and made recitation, the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1789]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1789

Ubayy b. Ka'b reported that the Apostle of Allah (may peace be upon him) was near the tank of Banu Ghifar that Gabriel came to him and said: Allah has commanded you to recite to your people the Qur'an in one dialect. Upon this he said: I ask from Allah pardon and forgiveness. My people are not capable of doing it. He then came for the second time and said: Allah has commanded you that you should recite the Qur'an to your people in two dialects. Upon this he (the Holy prophet) again said: I seek pardon and forgiveness from Allah, my people would not be able to do so. He (Gabriel) came for the third time and said: Allah has commanded you to recite the Qur'an to your people in three dialects. Upon this he said: I ask pardon and forgiveness from Allah. My people would not be able to do it. He then came to him for the fourth time and said: Allah has commanded you to recite the Qur'an to your people in seven dialects, and in whichever dialect they would recite, they would be right.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1790]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1790

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1791]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1791

Abu Wa'il reported that a person named Nabik b. Sinan came to Abdullah (b. Mas'ud) and said: Abu 'Abd al-Rahman, how do you recite this word (alif) or (ya)? Would you read It as: min ma'in ghaira asin or au min ma'in ghaira ghaira yasin. (al-Qur'an, xlvii. 15)? 'Abdullah said: You (seem to) have memorised the whole of the Qur'an except this. He (again) said: I recite all the mufassal surahs in one rak'ah. Upon this 'Abdullah said: (You must have been reciting It) hastily like the recitation of poetry. Verily. there are people who recite the Qur'an, but it does not go down beyond their collar bones. It is (a fact with the Qur'an) that it is beneficial only when it settles in the heart and is rooted deeply in it. The best of (the acts) in prayer are bowing and prostration. I am quite aware of the occasions when the Messenger of Allah (may peace be upon him) combined together two surahs in every rak'ah. 'Abdullah then stood up and went out with 'Alqama following in his footstep. He said Ibn Numair had told him that the narration was like that:" A person belonging to Banu Bajila came to 'Abdullah," and he did not mention (the name of) Nahik b. Sinan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1792]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1792

Abu Wa'il reported: A person came to 'Abdullah, who was called Nahik b. Sinan, and the rest of the hadith is the same but for this:" Alqama came to him ('Abdullah b. Mas'ud) and we said to him: Ask him about the manners in which he combined (two surahs) in one rak'ah. So he went to him and asked him and then came to us and said: Twenty are the mufassal surahs in the compilation (of the Qur'an) made by 'Abdullah."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1793]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1793

This hadith has been narrated by A'mash with the same chain of transmitters in which ('Abdullah b. Mas'ud) said:" I know the manners in which the Messenger of Allah (may peace be upon him) recited the two surahs in one rak'ah and then twenty surahs in ten rak'ahs."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1794]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1794

Abu Wa'il reported: One day we went to 'Abdullah b. Mas'ud after we had observed the dawn prayer and we paid salutation at the door. He permitted us to enter, but we stayed for a while at the door, when the slave-girl came out and said: Why don't you come in? So we went in and (we found 'Abdullah b. Mas'ud) sitting and glorifying Allah (i. e. he was busy in dhikr) and he said: What obstructed you from coming in though you had been granted permission for it? We said: There was nothing (behind it) but we entertained the idea that some inmate of the house might be sleeping. He said: Do you presume any idleness on the part of the family of Ibn Umm 'Abd (the mother of Abdullah b. Mas'ud)? He was again busy with the glorification of Allah till he thought that the sun had risen. He said: Girl, see whether (the sun) has arisen. She glanced but it had not risen (by that time). He was again busy with the glorification (of Allah) and he (again) thought that the sun had arisen. She glanced (and confirmed) that, it had risen. Upon this he ('Abdullah b. Mas'ud) said: Praise be to Allah Who did not call us to account for our sins today. Mahdi said: I think that he said, He did not destroy us for our sins. One among the people said: I recited all the mufassal surahs during the night. 'Abdullah said: (You must have recited them) like the (recitation) of poetry. I heard (the Holy Prophet) combining (the sarahs) and I remember the combinations which the Messenger of Allah (may peace be upon him) made In the recitation (of surahs). These were constituted of eighteen mufassal surahs and two surahs (commencing with) Ha-Mim.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1795]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1795

Shaqiq reported: A person from Banu Bajila who was called Nabik b. Sinan came to Abdullah and said: I recite mufassal surahs in one rak'ah. Upon this 'Abdullah said: (You recite) like the recitation of poetry. I know the manner in which the Messenger of Allah (may peace be upon him) recited two surahs in one rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1796]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1796

Abu Wa'il reported: A person came to 'Abdullah b. Mas'ud and said: I recited all the mufassal surahs in one rak'ah during the night. 'Abdullah said: You must have recited hastily like the recitation of poetry. 'Abdullah said: I remember well the manner in which the Messenger of Allah (may peace be upon him) used to combine them, and he then mentioned twenty of the mufassal surahs, and (their combinations in) two in every rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1797]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1797

Abu Ishaq reported: I saw a man asking Aswad b. Yazid who taught the Qur'an in the mosque: How do you recite the verse (fahal min muddakir) whether (the word muddakir) Is with (d) or (dh)? He (Aswad) said: It was with (d). I heard Abdullah b. Mas'ud saying that he had heard the Messenger of Allah (may peace be upon him) reciting (muddakir) with (d).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1798]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1798

Ishaq is reported to have said on the authority of Aswad who quoted on the authority of 'Abdullah b. Mas'ud that the Apostle of Allah (may peace be upon him) used to recite these words as (fahal min muddakir).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1799]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1799

'Alqama reported. We went to Syria and Abu Darda' came to us and said: Is there anyone among you who recites according to the recitation of Abdullah? I said: Yes, it is I. He again said: How did you hear 'Abdullah reciting this verse: (wa'l-lail-i-idha yaghsha = when the night covers)? He ('Alqama) said: I heard him reciting it (like this) (wa'l-lail-i-idha yaghsha) wa-dhakar wal untha = when the night covers and the males and the females). Upon this he said: By Allah, I heard the Messenger of Allah (may peace be upon him) reciting in this way, but they (the Muslims of Syria) desire us to recite: (wa ma khalaqa), but I do not yield to their desire.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1800]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1800

Ibrahim reported: 'Alqama came to Syria and entered the mosque and prayed there and then went to a (place where people were sitting in a) circle and he sat therein. Then a person came there and I perceived that the people were annoyed and perturbed (on this arrival). and he sat on my side and then said: Do you remember how 'Abdullah used to recite (the Qur'an)? And then the rest of the hadith was narrated.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1801]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1801

'Alqama reported: I met Abu Darda', and he said to me: To which country do you belong? I said: I am one of the people of Iraq. He again said: To which city? I replied: City of Kufa. He again said: Do you recite according to the recitation of 'Abdullah b. Mas'ud? I said: Yes. He said: Recite this verse (By the night when it covers) So I recited it: (By the night when it covers, and the day when it shines, and the creating of the male and the female). He laughed and said: I have heard the Messenger of Allah (may peace be upon him) reciting like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1802]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1802

This hadith has been narrated by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1803]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1803

Abu Huraira is reported to have said that the Messenger of Allah (may peace be upon him) prohibited to observe prayer after the 'Asr prayer till the sun is set, and after the dawn till the sun rises.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1804]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1804

Ibn 'Abbas reported: I heard it from so many Companions of the Messenger of Allah (may peace be upon him) and one among them is 'Umar b. Khattab, and he is most dear to me among them that the Messenger of Allah (may peace be upon him) prohibited observing of prayer after the dawn prayer till the sun rose and after the 'Asr till the sun set. This hadith has been narrated by Qatada with the same chain of transmitters with a minor alteration of words.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1805]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1805

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No prayer is valid after the 'Asr prayer till the sun sets and no prayer is valid after the dawn prayer till the sun rises.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1806]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1806

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Let not any one of you intend to observe prayer at the time of the rising of the sun or of the setting sun.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1807]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1807

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Do not intend to observe prayer at the time of the rising of the sun nor at its setting, for it rises between the horns of Satan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1808]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1808

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When the rim of the sun starts appearing defer prayer till it completely appears, and when the rim of the sun disappears defer prayer till it completely disappears.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1809]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1809

Abu Basra Ghifari reported: The Messenger of Allah (may peace be upon him) led us in the 'Asr prayer at (the place known as) Mukhammas, and then said: This prayer was presented to those gone before you, but they lost it, and he who guards it has two rewards in store for him. And no prayer is valid after till the onlooker appears (by onlooker is meant the evening star).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1810]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1810

This hadith has been narrated by Abu Basra Ghifari through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1811]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1811

Uqba b. 'Amir said: There were the times at which Allah's Messenger (may peace be upon him) forbade us to pray, or bury our dead: When the sun begins to rise till it is fully up, when the sun is at its height at midday till it passes over the meridian, and when the sun draws near to setting till it sets.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1812]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1812

'Amr b. 'Abasa Sulami reported: I in the state of the Ignorance (before embracing Islam) used to think that the people were in error and they were not on anything (which may be called the right path) and worshipped the idols. In the meanwhile I heard of a man in Mecca who was giving news (on the basis of his prophetic knowledge) ; so I sat on my ride and went to him. The Messenger of Allah (may peace be upon him) was at that time hiding as his people had made life hard for him. I adopted a friendly attitude (towards the Meccans and thus managed) to enter Mecca and go to him (the Holy Prophet) and I said to him: Who are you? He said: I am a Prophet (of Allah). I again said: Who is a Prophet? He said: (I am a Prophet in the sense that) I have been sent by Allah. I said: What is that which you have been sent with? He said: I have been sent to join ties of relationship (with kindness and affection), to break the Idols, and to proclaim the oneness of Allah (in a manner that) nothing is to be associated with Him. I said: Who is with you in this (in these beliefs and practices)? He said: A free man and a slave. He (the narrator) said: Abu Bakr and Bilal were there with him among those who had embraced Islam by that time. I said: I intend to follow you. He said: During these days you would not be able to do so. Don't you see the (hard) condition under which I and (my) people are living? You better go back to your people and when you hear that I have been granted victory, you come to me. So I went to my family. I was in my home when the Messengerof Allah (may peace be upon him) came to Medina. I was among my people and used to seek news and ask people when he arrived in Medina. Then a group of people belonging to Yathrib (Medina) came. I said (to them): How is that person getting on who has come to Medina? They said: The people are hastening to him, while his people (the polytheists of Mecca) planned to kill him, but they could not do so. I (on hearing It) came to Medina and went to him and said: Messenger of Allah, do you recognise me? He said: Yes, you are the same man who met me at Mecca. I said: It is so. I again said: Prophet of Allah, tell me that which Allah has taught you and which I do not know, tell me about the prayer.

He said: Observe the dawn prayer, then stop praying when the sun is rising till it Is fully up, for when it rises it comes up between the horns of Satan, and the unbelievers prostrate themselves to it at that time. Then pray, for the prayer is witnessed and attended (by angels) till the shadow becomes about the length of a lance; then cease prayer, for at that time Hell is heated up. Then when the shadow moves forward, pray, for the prayer is witnessed and attended by angels, till you pray the afternoon prayer, then cease prayer till the sun sets, for it sets between the horns of devil, and at that time the unbelievers prostrate themselves before it. I said: Apostle of Allah, tell me about ablution also. He said: None of you who uses water for ablution and rinses his mouth, snuffs up water and blows it, but the sins of his face, and his mouth and his nostrils fall out. When he washes his face, as Allah has commanded him, the sins of his face fall out from the end of his beard with water. Then (when) he washes his forearms up to the elbows, the sins of his arms fall out along with water from his finger-tips. And when he wipes his head, the sins of his head fall out from the points of his hair along with water. And (when) he washes his feet up to the ankles, the sins of his feet fall out from his toes along with water. And if he stands to pray and praises Allah, lauds Him and glorifies Him with what becomes Him and shows wholehearted devotion to Allah, his sins would depart leaving him (as innocent) as he was on the day his mother bore him. 'Amr b. 'Abasa narrated this hadith to Abu Umama, a Companion of the Messenger of Allah (may peace be upon him), and Abu Umama said to him: 'Amr b. 'Abasa, think what you are saying that such (a great reward) is given to a man at one place (only in the act of ablution and prayer). Upon this 'Amr said: Abu Umama, I have grown old and my bones have become weak and I am at the door of death; what impetus is there for me to attribute a lie to Allah and the Messenger of Allah (may peace be upon him)? Had I heard it from the Messenger of Allah (may peace be upon him) once, twice, or three times (even seven times), I would have never narrated it, but I have heard it from him on occasions more than these.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1813]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1813

'A'isha reported that 'Umar misconstrued the fact that the Messenger of Allah (may peace be upon him) had prohibited the observance of prayer at the time of the rising sun and at the time of its setting.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1814]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1814

'A'isha said that the Messenger of Allah (may peace be upon him) did not abandon observing two rak'ahs after 'Asr, but she reported Allah's Messenger (may peace be upon him) as saying: Do not get used to observe prayer at the time of the rising sun and at the time of its setting and (exhorted the Muslims) to pray at their times.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1815]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1815

Kuraib, the freed slave of Ibn 'Abbas, reported that 'Abdullah b. 'Abbas, 'Abd al-Rahman b. Azhar, al-Miswar b. Makhrama sent him to 'A'isha, the wife of the Messenger of Allah (may peace be upon him), telling him to give her their greetings, and ask her about the two rak'ahs after the afternoon prayer, (for)" we have heard that you observe them whereas it has been conveyed to us that the Messenger of Allah (may peace be upon him) prohibited their observance." Ibn 'Abbas said: I along with 'Umar b. al-Khattab dissuaded people to do so (to observe two rak'ahs of prayer). Kuraib said: I went to her ('A'isha) and conveyed to her the message with which I was sent. She said: (Better) ask Umm Salama. So I went to them (those who had sent him to Hadrat 'A'isha) and informed them about what she had said. They sent me back to Umm Salama with that with which I was sent to 'A'isha. Umm Salama said: I beard the Messenger of Allah (may peace be upon him) prohibiting them, and then afterwards I saw him observing them. And when he observed them (two rak'ahs) he had already observed the 'Asr prayer. Then he (the Holy Prophet) came, while there were with me ladies of Banu Haram, a tribe of the Ansar and he (the Holy Prophet) observed them (the two rak'ahs). I sent a slave-girl to him asking her to stand by his side and say to him that Umm Salama says: Messenger of Allah, I heard you prohibiting these two rak'ahs, whereas I saw you observing them; and if he (the Holy Prophet) points with his hand (to wait), then do wait. The slave-girl did like that. He (the Holy Prophet) pointed out with his hand and she got aside and waited, and when he had finished (the prayer) he said: Daughter of Abu Umayya. you have asked about the two rak'ahs after the 'Asr prayer. Some people of 'Abu al-Qais came to me for embracing Islam and hindered me from observing the two rak'ahs which come after the noon prayer. So those are the two I have been praying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1816]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1816

Abu Salama asked 'A'isha about the two prostrations (i. e. rak'ahs) which the Messenger of Allah (may peace be upon him) made after the 'Asr. She said: He (the Holy Prophet) observed them before the 'Asr prayer, but then he was hindered to do so, or he forgot them and then he observed them after the 'Asr, and then he continued observing them. (It was his habit) that when he (the Holy Prophet) observed prayer, he then continued observing it. Isma'il said: It implies that he always did that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1817]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1817

'A'isha reported: The Messenger of Allah (may peace be upon him) did not abandon at all observing two rak'ahs after the 'Asr in my house.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1818]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1818

'A'isha reported: Two are the prayers which the Messenger of Allah (may peace be upon him) always observed in my house-openly or secretly-two rak'ahs before the dawn and two rak'ahs after the 'Asr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1819]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1819

Aswad and Masruq reported: We bear testimony to the fact that 'A'isha said: Never was there a day that he (the Holy Prophet) was with me and he did not observe two rak'ahs of prayer in my house, i. e. two rak'ahs after the Asr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1820]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1820

Mukhtar b. Fulful said: I asked Anas b. Malik about the voluntary prayers after the afternoon prayer, and he replied: 'Umar struck hit hands on prayer observed after the 'Asr prayer and we used to observe two rak'ahs after the sun set before the evening prayer during the time of the Apostle of Allah (may peace be upon him). I said to him: Did the Messenger of Allah (may peace be upon him) observe them? He said: He saw us observing them, but he neither commanded us nor forbade us to do so.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1821]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1821

Anas b. Malik reported: When we were in Medina, the moment the Mu'adhdhin made the call to the sunset prayer, the people hastened to the pillars of the mosque and prayed two rak'ahs with the result that any stranger coming into the mosque would think that the obligatory prayer had been observed owing to the number who were praying then.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1822]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1822

Abdullah b. Mughaffal reported Allah's Messenger (may peace be upon him) u saying: There Is between the two calls (Adhan and Iqama) a prayer. And he mentioned it three times, and at the third time he said: This applies to those who wish to do it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1823]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1823

This hadith has been narrated by Abdullah b. Mughaffal by another chain of transmitters, but with this variation that he (the Holy Prophet) said at the fourth time:" He who wishes (may do to)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1824]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1824

Salim b. Abdullah b. 'Umar reported: The Messenger of Allah (may peace he upon him) led on* of the two groups In one rak'ah of prayer in danger, while the other group faced the -enemy. Then they (the members of the first group) went back and replaced their companions who were facing the enemy. and then they (the members of the second group) came and the Apostle of Allah (may peace be upon him) led them in one rak'ah of prayer. Then the Apostle of Allah (may peace be upon him) pronounced salutation, and then they (the members of the Ant group) completed the rak'ah and they (the members of the second group) completed the rak'ah. This hadith has been narrated by another chain of tranamitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1825]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1825

Ibn Umar reported that the Messenger of Allah (may peace be upon him) observed prayer in danger on some day (in this way): a group stood with him (the Holy Prophet) (for prayer) and the other group stood In front of the enemy. Then those who were with (him) observed one rak'ah of prayer and they went back and the others came and they observed one rak'ah (with him). Then both the groups completed one rak'ah each. Ibn Umar said: When there is greater danger, then observe prayer even on the ride or with the help of gestures in a standing posture.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1826]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1826

Jabir b. 'Abdullah reported: I observed prayer in danger with the Messenger of Allah (may peace be upon him). We drew ourselves up in two rows, one row behind him with the enemy between us and the Qibla. The Apostle of Allah (may peace be upon him) said: Allah is Most Great, and we all said it. He then bowed and we all bowed. He then raised his head from bowing, we all raised (our heads). He then went down in prostration along with the row close to him, and the rear row faced the enemy; then when the Apostle of Allah (may peace be upon him) completed the prostration, ; and then stood up, the row near to him also did it; then went down the rear row in prostration; then they stood up; then the rear row went to the front and the front row went to the rear. Then the Apostle of Allah (may peace he upon him) bowed down and we all bowed. He then raised his head from bowing and we also raised (our heads). He and the row close to him which I had been in the rear then went down in prostration In the first rak'ah, whereas the rear row faced the enemy. And when the Apostle of Allah (may peace be upon him) and the rear row close to him had finished the prostration, the rear row went down and prostrated themselves; then the Apostle of Allah pronounced the salutation and we also pronounced the salutation. (Jabir said we hadith) as your guards behave with their chiefs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1827]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1827

Jabir reported: We fought In the company of the Messenger of Allah (may peace be upon him) with the tribe of Juhaina. They fought with us terribly. When we had finished the noon prayer, the polytheists said: Had we attacked them at once. we would have killed them. Gabriel informed the Messenger of Allah (may peace be upon him) about It (about their evil design). The Messenger of Allah (may peace be upon him) made a mention of it to us, adding that they (the polytheists) had also said: Shortly there would be time for the 'Asr prayer. which is dearer o them (the Muslims) than even their children. So when the time of the 'Asr prayer came. we formed ourselves into two rows, while the polytheists were between us and the Qibla. The Messenger of Allah (may peace be upon him) said: Allah is Most Great, and we also said so. He bowed and we also bowed. He went down in prostration and the first row prostrated along with him. When they stood up, the second row went down in prostration. Then the first row went into the rear, and the second row came in the front and occupied the place of the first row. The Messenger of Allah (may peace be upon him) then said: Allah is Most Great, and we also said so. He then bowed, and we also bowed. He then went down in prostration and along with him the row also (went down in prostration), and the second row remained standing. And when the second row had also prostrated and all of them sat down then the Messenger of Allah (may peace be upon him) pronounced salutation to them. Abu Zubair said: Jabir made a mention specially of this thing: just as your chiefs observe prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1828]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1828

Sahl b. Abu Hathma reported that the Messenger of Allah (may peace be upon him) led his Companions in prayer in danger. He made them stand in two rows behind him. He led them who were close to him in one rak'ah. He then stood up and kept standing till those who were behind them observed one rak'ah. Then they (those standing in the second row) came in front and those who were in front went into the rear. He then led them In one rak'ah. He then sat down, till those who were behind him observed one rak'ah and then pronounced salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1829]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1829

Yazid b. Ruman told on the authority of Salih b. Khawwat on the authority of one who prayed in time of danger with Allah's Messenger (may peace he upon him) at the Battle of Dhat ar-Riqa' that a group formed a row and prayed along with him, and a group faced the enemy. He led the group which was along with him in a rak'ah, then remained standing while they finished the prayer by themselves. Then they departed and formed a row facing the enemy. Then the second group came and he led them in the remaining rak'ah, after which he remained seated while they finished the prayer themselves. He then led them in salutation.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1830]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1830

Jabir reported: We went forward with the Messenger of Allah (may peace be upon him) and when we reached Dhat ar-Riqa', we came to a shady tree which -we left for him One of the polytheists came there and, seeing the sword of the Messenger (may peace be upon him) hanging by a free. took it up. drew it from the scabbard and said to the Messenger of Allah (may peace be upon him): Are you afraid of Me? He (the Holy Prophet) said: No. He again said: Who would protect you from me? He said: Allah will protect me from you. The Companions of the Messenger of Allah (may peace be upon him) threatened him. He sheathed the sword and hung it up. Then call to prayer was made and he (the Holy Prophet) led a group in two rak'ah. Then (the members of this group) withdrew and he led the second group in two rak'ah. So the Messenger of Allah (may peace be upon him) observed four rak'ah and people observed two rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1831]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1831

Abu Salama b. 'Abd al-Rahman reported that Jabir told him that he had observed the prayer in danger with the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) (first) led one of the two groups in two rak'ah of prayer. and then led the second group in two rak'ah of prayer. So the Messenger of Allah (may peace be upon him) observed four rak'ah and led in two rak'ah each of the groups.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1832]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1832

Abdullah is reported to have heard Allah's Messenger (may peace be upon him) as saying: When any one of you intends to come for Jumu'a prayer, he should take a bath.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1833]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1833

Abdullah b. Umar is reported to have said that The Messenger of Allah (may peace be up on him) was standing on the pulpit when he said this: He who comes for Jumu'a he should take a bath.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1834]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1834

This hadith has been narrated by Ibn Umar by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1835]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1835

'Abdullah (b. Umar) reported on the authority of his father that he beard like this from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1836]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1836

'Abdullah (b. 'Umar) reported from his father that while he was addressing the people on Friday (sermon), a person, one of the Companions of the Messenger of Allah (may peace be upon him), entered (the mosque). Umar said to him loudly: What is this hour (for attending the prayer)? He said: I was busy today and I did not return to my house when I heard the call (to Friday prayer), and I did no more but performed ablution only. Upon this Umar said: just ablution! You know that the Messenger of Allah (may peace be upon him) commanded (us) to take a bath (on Friday).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1837]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1837

Abu Huraira reported: Umar b. Khattab was delivering a sermon to the people on Friday when 'Uthman b. 'Affan came there. 'Umar hinting to him said: What would become of those persons who come after the call to prayer? Upon this 'Uthman said: Commander of the faithful, I did no more than this that after listening to the call, I performed ablution and came (to the mosque). 'Umar said: Just ablution! Did you not bear the Messenger of Allah (my peace be upon him) say this: When any one of you comes for Jumu'a, he should take a bath.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1838]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1838

Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Taking a bath on Friday is essential for every adult person.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1839]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1839

'Aisha reported: The people came for Jumu'a prayer from their houses in the neighbouring villages dressed in woollen garments on which dust was settled and this emitted a foal smell. A person among them (those who were dressed so) came to the Messenger of Allah (may peace be upon him) while he was in my house. The Messenger of Allah (may peace he upon him) said to him: Were you to cleanse yourselves on this day.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1840]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1840

'Aisha reported: The people (mostly) were workers and they had no servants. Ill-smell thus emitted out of them. It was said to them: Were you to take bath on Friday.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1841]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1841

'Abd al-Rahman son of Abd Sa'id al-Khudri reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: Bathing on Friday for every adult, using of Miswak and applying some perfume, that is available-these are essential. So far as the perfume is concerned, it may be that used by a lady.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1842]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1842

Tawus reported that Ibn Abbas narrated the words of the Apostle of Allah (may peace be upon him) about taking bath on Friday. Tawus said: I asked Ibn Abbas it one should apply to oneself perfume or oil which is available with his wife. He (Ibn Abbas) said: I do not know of it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1843]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1843

This hadith has been narrated by Ibn Juraij with the came chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1844]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1844

Abu Huraira reported that the Apostle of Allah (may peace be upon him) said. it is the right of Allah upon every Muslim that he should take a bath (at least) on one day (Friday) during the seven days (of the week) and he should wash his head and body.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1845]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1845

Abu Huraira reported that the Messenger of, Allah (may peace be upon him) said. He who takes a bath on Friday, the bath which is obligatory after the sexual discharge and then goes (to the mosque), he is like one who offers a she-camel as a sacrifice, and he who comes at the second hour would be like one who offers a cow, and he who comes at the third hour is live one who offers a ram with horns, and he who comes at the fourth hour is like one who offers a hen, and he who comes at the fifth hour is like one who offers an egg. And when the Imam comes out, the angels are also present and listen to the mention of God (the sermon).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1846]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1846

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you (even) ask your companion to be quiet on Friday while the Imam is delivering the sermon, you have in fact talked irrelevance.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1847]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1847

A hadith like this has been narrated by Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1848]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1848

The same hadith has been narrated by Abu Huraira, but instead of the word laghauta the word laghita has been used. Abu Zinad (one of the narrators) says that laghita is the dialect of Abu Huraira, whereas it is laghauta.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1849]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1849

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is a time on Friday at which no Muslim servant would pray and would ask Allah for a thing (that is good) but He would give it to him. Qutaiba pointed with the help of his hand that it (the time) is short.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1850]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1850

Abu Huraira reported Abu'l-Qasim (the kunya of the Holy Prophet) (may peace be upon him) as saying: There is a time on Friday at which no Muslim would stand and pray and beg Allah for what Is good but He would give it to him; and he pointed with his hand that (this time) is short and narrow.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1851]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1851

A hadith like this has been narrated by Abu Huraira.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1852]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1852

This hadith has been narrated by Abu Huraira by another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1853]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1853

Abu Huraira reported Allah's Apostle (way peace be upon him) as saying. There is a time on Friday at which no Muslim would ask Allah for what is good but He would give it to him. And further said: This is a very short time.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1854]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1854

Hammam b. Munabbih reported this hadith from Abu Huraira who reported from the Apostle of Allah (may peace be upon him) but he did not say:" That time is short."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1855]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1855

Abu Burda b. Abu Musa al-Ash'ari reported: 'Abdullah b. Umar said to me: Did you hear anything from your father narrating something from the messenger of Allah (may peace be upon him) about the time on Friday? I said: Yes, I heard him say from the Messenger of Allah (may peace be upon him) (these words):" It is between the time when the Imam sits down and the end of the prayer."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1856]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1856

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The best day on which the sun has risen is Friday; on it Adam was created, on it he was made to enter Paradise, on it he. was expelled from it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1857]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1857

Abu Huraira reported the Apostle of Allah (may peace be upon him) as saying: The best day on which the sun has risen is Friday; on it Adam was created. on it he was made to enter Paradise, on it he was expelled from it. And the last hour will take place on no day other than Friday.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1858]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1858

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We who are the last shall be the first on the Day of Resurrection, except that every Ummah was given the Book before us and we were given it after them. It was this day which Allah prescribed for us and guided us to it and the people came after us with regard to it, the Jews observing the next day and the Christians the day following that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1859]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1859

A hadith like this has been narrated by Abu Huraira that the Messenger of Allah (way peace be upon him) said: We are the last and would be the first on the Day of Resurrection.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1860]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1860

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We are the last (but) we would be the first on the Day of Resurrection, and we would be the first to enter Paradise, but that they were given the Book before us and we were given after them. They disagreed and Allah guided us aright on whatever they disagreed regarding the truth. And it was this day of theirs about which they disagreed, but Allah guided us to it, and that is Friday for us; the next day is for the Jews and the day following for the Christians.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1861]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1861

Abu Huraira reported Muhammad, the Messenger of Allah (may peace be upon him), as saying: We who are the last would be the first on the Day of Resurrection but they (other Ummahs) were given the Book before us and we were given after them, and this was the day that was prescribed for them but they disagreed on it. And Allah guided us to it. and they came after us with regard to it, the Jews observing the next day and the Christians the day following that.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1862]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1862

It is narrated by Abu Huraira and Huraira that the Messenger of Allah (may peace be upon him) said: It was Friday from which Allah diverted those who were before us. For the Jews (the day set aside for prayer) was Sabt (Saturday), and for the Christians it was Sunday. And Allah turned towards us and guided us to Friday (as the day of prayer) for us. In fact, He (Allah) made Friday, Saturday and Sunday (as days of prayer). In this order would they (Jews and Christians) come after us on the Day of Resurrection. We are the last of (the Ummahs) among the people in this world and the first among the created to be judged on the Day of Resurrection. In one narration it is: ', to be judged among them".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1863]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1863

Huraira reported Allah's Messenger (may peace be upon him) as saying: We were guided aright to Friday (as a day of prayer and meditation), but Allah diverted those who were before us from it. The rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1864]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1864

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When it is Friday, the angels stand at every door of the mosque and record the people in the order of their arrival, and when the Imam sits (on the pulpit for delivering the sermon) they fold up their sheets (manuscripts of the Qur'an) and listen to the mention (of Allah). And he who comes early is like one who offers a she-camel as a sacrifice, the next like one who offers a cow, the next a ram, the next a hen, the next an egg.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1865]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1865

This hadith has been narrated by Abu Huratra through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1866]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1866

Abu Huraira reported Allah Messenger (way peace be upon him) as saying: There is an angel on every door of the mosque recording him first who (conies) first (a the mosque for Friday prayer). And he [the Prophet] likened him as one who offers a camel as a sacrifice and then he went on in the descending order till he reached the point at which the minimum (sacrifice) is that of an egg. And when the Imam sits (on the pulpit) the sheets are folded and they (the angels) attend to the mention of Allah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1867]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1867

Abu-Huraira reported Allah's Apostle (may peace be upon him) as saying: He who took a bath and then came for Jumu'a prayer and then prayed what was fixed for him, then kept silence till the Imam finished the sermon, and then prayed along with him, his sins between that time and the next Friday would be forgiven, and even of three days wore.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1868]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1868

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who performed ablution well, then came to Friday prayer, listened (to the sermon), kept silence all (his sins) between that time and the next Friday would be forgiven with three days extra, and he who touched pebbles caused an interruption.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1869]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1869

Jabir b. 'Abdullah reported: We used to observe (Jumu'a) prayer with the Messenger of Allah (may peace be upon him) and then we returned and gave rest to our camels used for carrying water. Hassan[ (one of the narrators) said: I asked Ja'far what time that was. He said.. It is the time when the sun passes the meridian.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1870]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1870

Ja'far reported on the authority of his father that he asked Jabir b. 'Abdullah when the Messenger of Allah (may peace be upon him) observed Jumu'a prayer. Re said: He used to observe prayer, and we then went (back) to our camels and gave them rest. 'Abdullah made this addition in his narration:" Till the sun passed the meridian. and the camels used for carrying water (took rest)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1871]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1871

Sahl b. Said said: We did not have a siesta or lunch till after the Friday prayer. (Ibn Hujr added: )" Daring the lifetime of the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1872]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1872

Iyas b. Salama b. al-Akwa' reported on the authority of his father: We used to observe the Friday prayer with the Messenger of Allah (may peace be upon him) when the sun passed the meridian. and we then returned and tried to find out afternoon shadow (of the walls for protecting themselves from the heat of the sun).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1873]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1873

Iyas b. Salama b. Akwa' reported on the authority of his father, saying: We used to observe the Friday prayer with the Messenger of Allah (may peace be upon him), and when we returned we did not find the shadow of the walls in which we could take protection (from the heat of the sun).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1874]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1874

Ibn 'Umar said that the Messenger of Allah (may peace be upon him) used to deliver the sermon on Friday while standing. He would then sit and then stand (for the second sermon) as they (the Muslims) do nowadays.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1875]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1875

Jabir b. Samura said: The Apostle of Allah (may peace be upon him) gave two sermons between which he sat, recited the Qur'an and exhorted the people.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1876]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1876

Jabir b. Samura said that the Messenger of Allah (may peace be upon him) used to deliver the sermon while standing. He would then sit down and then stand up and address in a standing posture; and whoever informed you that he (the Holy Prophet) delivered the sermon while sitting told a lie. By Allah. I prayed with him more than two thousand times.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1877]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1877

Jabir b. Abdullah reported that the Apostle (may peace be upon him) was delivering the sermon on Friday in a standing posture when a caravan from Syria arrived. The people flocked towards it till no one was left (with the Holy Prophet) but twelve persons, and it was on this occasion that this verse in regard to Jumu'a was revealed." And when they see merchandise or sport. they break away to it and leave thee standing."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1878]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1878

This hadith has been narrated by Husain with the same chain of transmitters but with this alteration that he did not make mention of the standing position.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1879]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1879

Jabir b. Abdullah reported: I was along with the Apostle of Allah (may peace be upon him) on Friday when a caravan arrived. The people went to it, and none but twelve persons were left behind and I was one of them; and it was on this occasion that this verse was revealed:" And when they see merchandise or sport away to it, and leave thee standing" (lxii. 1 1). they break


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1880]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1880

Jabir b. Abdullah reported: While the Apostle of Allah (may peace be upon him) was delivering (a sermon) on Friday, a caravan of merchandise came to Medina. The Companions of the Messenger of Allah (may peace be upon him) rushed towards it till only twelve persons were left with him including Abu Bakr and 'Umar; and it was at this occasion that this verse was revealed." And when they see merchandise or sport, they break away to it."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1881]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1881

Ka'b b. 'Ujra reported that he entered the mosque and saw Abd al-Rahman b. Umm Hakam delivering the sermon in a sitting posture. Upon this he said: Look at this wretched person; he delivers the sermon while sitting, whereas Allah said:" And when they see merchandise or sport, they break away to it and leave thee standing."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1882]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1882

Abdullah b. Umar and Abu Huraira said that they heard Allah's Messenger (way peace be upon him) say on the planks of his pulpit: People most cease to neglect the Friday prayer or Allah will seal their hearts and then they will be among the negligent.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1883]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1883

Jabir b. Samura reported: I used to pray with the Messenger of Allah (may peace be upon him) and both his prayer and sermon were of moderate length.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1884]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1884

Jabir b. Samura reported: I used to observe prayer with the Apostle of Allah (may peace be upon him) and his prayer was of moderate length and his sermon too was of moderate length.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1885]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1885

Jabir b. Abdullah said: When Allah's Messenger (may peace he upon him) delivered the sermon, his eyes became red, his voice rose. and his anger increased so that he was like one giving a warning against the enemy and saying:" The enemy has made a morning attack on you and in the evening too." He would also say:" The last Hour and I have been sent like these two." and he would join his forefinger and middle finger; and would further say:" The best of the speech is embodied in the Book of Allah, and the beet of the guidance is the guidance given by Muhammad. And the most evil affairs are their innovations; and every innovation is error." He would further say:, I am more dear to a Muslim even than his self; and he who left behind property that is for his family. and he who dies under debt or leaves children (in helplessness). the responsibility (of paying his debt and bringing up his children) lies on me."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1886]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1886

Ja'far b. Muhammad said on the authority of his father: I heard Jabir b. 'Abdullah saying that in the sermon of the Apostle of Allah (may peace be upon him) he praised Allah, lauded Him (and subsequently said [other words] and raised his voice, and the rest of the hadith is the same).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1887]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1887

Jabir reported that the Messenger of Allah (may peace be upon him), while delivering the sermon' to the people, praised Allah, and lauded Him for what He deserves, and would then say: He whom Allah guides aright, there is none to mislead him, and he who is led astray, there is none to guide him (aright), and the best of the talk is embodied in the Book of Allah. And the rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1888]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1888

Ibn 'Abbas reported: Dimad came to Mecca and he belonged to the tribe of Azd Shanu'a, and he used to protect the person who was under the influence of charm. He heard the foolish people of Mecca say that Muhammad (may peace be upon him) was under the spell. Upon this he said: If 1 were to come across this man, Allah might cure him at my hand. He met him and said: Muhammad, I can protect (one) who is under the influence of charm, and Allah cures one whom He so desires at my hand. Do you desire (this)? Upon this the Messenger of Allah (may peace be upon him) said: Praise is due to Allah, we praise Him, ask His help; and he whom Allah guides aright there is none to lead him astray, and he who is led astray there is none to guide him, and I bear testimony to the fact that there is no god but Allah, He is One, having no partner with Him, and that Muhammad is His Servant and Messenger. Now after this he (Dimad) said: Repeat these words of yours before me, and the messenger of Allah (may peace be upon him) repeated these to him thrice; and he said I have heard the words of soothsayers and the words of magicians, and the words of poets, but I have never heard such words as yours, and they reach the depth (of the ocean of eloquence) ; bring forth your hand so that I should take oath of fealty to you on Islam. So he took an oath of allegiance to him. The Messenger of Allah (may peace be upon him) said: It (this allegiance of yours) is on behalf of your people too. He said: It is on behalf of my people too. The Messenger of Allah (may peace be upon him) sent an expedition and the flying column passed by his people. The leader of the flying column said to the detachment: Did you find anything from these people? One of the people said: I found a utensil for water. Upon this he (the commander) said: Return it, for he is one of the people of Dimad.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1889]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1889

Abu Wa'il reported: 'Ammar delivered to us the sermon. It was short and eloquent. When he (, Ammir) descended (from the pulpit) we said to him: 0 Abd al-Yaqzn, you have delivered a short and eloquent sermon. Would that you had lengthened (the sermon). He said: I have heard the Messenger of Allah (may peace be upon him) as saying: The lengthening of prayer by a man and the shortness of the sermon is the sign of his understanding (of faith). So lengthen the prayer and shorten the sermon, for there is charm (in precise) expression.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1890]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1890

'Adi b. Hatim reported that a person recited a sermon before the Apostle of Allah (may peace be upon him) thus: He who obeys Allay and His Apostle, he in fact follows the right path, and he who disobeys both of them, he goes astray. Upon this the Messenger of Allah (may peace be upon him) said: What a bad speaker you are; say: He who disobeys Allah and His Apostle. Ibn Numair added: He in fact went astray.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1891]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1891

Safwan b. Ya'la reported on the authority of his father that he heard the Apostle of Allah (may peace be upon him) reciting (verses of the Qur'an) on the pulpit. and" They cried: 0 Malik."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1892]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1892

'Amra daughter of Abd al-Rahman reported on the authority of the sister of Amra, I memorised (surah) Qaf=surah l.):" By the glorious Qur'an" from the mouth of the Messenger of Allah (may peace be upon him) on Friday for he recited it on the pulpit on-every Friday.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1893]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1893

The daughter of Haritha b. Nu'man said: I did not memorise (Surah) Qaf but from the mouth of the Messenger of Allah (may peace be upon him) as he used to deliver the. sermon along with it on every Friday. She also added: Our oven and that of the Messenger of Allah (may peace be upon him) was one.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1894]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1894

Umm Bisham hint Haritha b. Nu'man said: Our oven and that of the Messenger of Allah (may peace be upon him) was one for two years, or for one year or for a part of a year; and I learnt" Qaf. By the Glorious Qur'an" from no other source than the tongue of Allah's Messenger (may peace be upon him) who used to recite it every Friday on the pulpit when he delivered the sermon to the people.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1895]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1895

Umara b. Ruwaiba said he saw Bishr b. Marwan on the pulpit raising his hands and said: Allah, disfigure these hands! I have seen Allah's Messenger (may peace be upon him) gesture no more than this with his hands, and he pointed with his forefinger.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1896]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1896

This hadith has been narrated by another chain of transmitters on the authority of Husain b. Abd al-Rahman.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1897]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1897

Jabir b. 'Abdullah reported that while Allah's Messenger (may peace be upon him) was delivering the sermon on Friday a person came there, and the Apostle of Allah (may peace be upon him) said to him: So and so, have you prayed (two rak'ahs)? He said: No. He (the Holy Prophet) said: Then stand and pray.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1898]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1898

This hadith is narrated by Jabir through another chain of transmitters but Hammad (one of the narrators) made no mention of the two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1899]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1899

Jabir b. 'Abdullah said that a person entered the Mosque while the Messenger of Allah (may peace be upon him) was delivering the sermon on Friday. Upon this he (the Holy Prophet) said: Have you observed prayer? He said: No. He (the Holy Prophet) said: Stand and offer the two rak'ahs. According to Qutaiba, the words are:" He said: Offer two rak'ahs."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1900]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1900

Jabir b. 'Abdullah reported that a person came (in the Mosque) while the Apostle of Allah (may peace be upon him) was delivering the sermon on Friday (standing) on the pulpit. He (the Holy Prophet) said to him: Have you offered two rak'ahs? He said: No. Upon this he said: Then observe (them).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1901]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1901

Jabir b. 'Abdullah said that the Apostle of Allah (may peace be upon him) delivered the sermon and said: When any one of you comes for the Friday (prayer) and the Imam comes out (from his apartment), (even then) should observe two rak'ahs (of prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1902]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1902

Jabir reported that Sulaik Ghatafani came on Friday (for prayer) while the Messenger of Allah (may peace be upon him) was sitting on the pulpit. Sulaik also sat down before observing prayer. The Apostle of Allah (may peace be upon him) said: Have you observed two rak'ahs? He said: No. He (the Holy Prophet) said: Stand and observe them


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1903]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1903

Jabir b. 'Abdullah reported: Sulaik Ghatafani came on Friday when the Messenger of Allah (may peace be upon him) was delivering the sermon. He (Sulaik) sat down. He (the Holy Prophet) said to him: 0 Sulaik I stand and observe two rak'ahs and make them short, and then said: When any one of you comes on Friday, while the Imam delivers the sermon, he should observe two rak'ahs and should make them short.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1904]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1904

Abu Rifa'a reported: I came to the Holy Prophet (way peace be upon him) when he was delivering the sermon, and I said: Messenger of Allah, here is a stranger and he wants to learn about this religion and he does not know what this religion is. The Messenger of Allah (may peace be upon him) looked at me and left his sermon till he came to me, and he was given a chair and I thought that Its legs were made of iron. The Messenger of Allah (may peace be upon him) sat In it and he began to teach me what Allah had taught him. He then came (to the pulpit) for his sermon and completed it to the end.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1905]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1905

Ibn Abu Rafi' said: Marwan appointed Abu Huraira as his deputy in Medina and he himself left t for Mecca. Abu Huraira led as in the Jumu'a prayer and recited after Surah Jumu'a in the second rak'ah:" When the hypocrites came to thee" (Surah lxiii.). I then met Abu Huraira as he came back and said to him: You have recited two surahs which 'Ali b. Abu Talib used to recite in Kufah. Upon this Abu Huraira said: I heard the Messenger of Allah (may peace: be upon him) 'reciting these two in the Friday (prayer).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1906]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1906

This hadith is narrated by Abdullah b. Abu Rafi' with the same chain of transmitters but with this modification:" That he recited Surah Jumu'a (lxii.) in the first rak'ah and" The hypocrites came" in the second rak'ah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1907]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1907

Nu'man b. Bashir reported that the Messenger of Allah (may peace be upon him) used to recite on two 'Ids and in Friday prayer:" Glorify The name of Thy Lord, the Most High" (Surah lxxxvii.), and:" Has there come to thee the news of the overwhelming event" (lxxxviii.). And when the 'Id and Jumu'a combined on a day he recited these two (surah) in both the prayers.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1908]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1908

This hadith has been narrated by Ibrahim b Muhammad b. al-Muntashir with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1909]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1909

Dahhak b. Qais wrote to Nu'man b. Bashir asking him what the Messenger of Allah (may peace be upon him) recited on Friday besides Surah Jumu'a He said that he recited:" Has there reached..." (Surah lxxxviii, ).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1910]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1910

Ibn Abbas reported: The Apostle of Allah (way peace be upon him) used to recite in the morning prayer on Friday Surah" Alif-Lam-Mim, Tanz'il ul-Sajda" (Surah xxxii.): Surely there came over the man a time" (Surah lxxvii) and he used to recite in Jumu'a prayer Surahs Jumu'a and al-Munafiqin.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1911]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1911

A hadith like this has been narrated by Sufyan with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1912]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1912

Mukhawwil has narrated this hadith on the authority of Sufyan.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1913]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1913

Abu Huraira reported that the Apostle of Allah (may peace be upon him) used to recite in the dawn prayer on Friday" Alif-Lam-Mim, Tanzil" and" Surely there came."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1914]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1914

Abu Huraira reported that the Apostle of Allah (may peace be upon him) used to recite in the dawn prayer on Friday:" Alif-Lam-Mim, Tanzil" in the first rak'ah, and in the second one:" Surely there came over the man a time when he was nothing that could be mentioned."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1915]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1915

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you observes the Jumu'a prayer (two obligatory rak'ahs in congregation), he should observe four (rak'ahs) afterwards.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1916]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1916

Suhail reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you observe prayer after (the two obligatory raklabs) of Jumu'a, you should observe four rak'ahs (and 'Amr in his narration has made this addition that Ibn Idris said this on the authority of Suhail): And if you are in a hurry on account of something, you should observe two rak'ahs in the mosque and two when you return (to your house).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1917]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1917

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one amongst you observes prayer after Jumu'a, he should observe four rak'ahs. (In the hadith transmitted by Jarir the word minkum is not recorded.)


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1918]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1918

Nafi' reported that when 'Abdullah (b. 'Umar) observed the Friday prayer and came back he observed two rak'ahs in his house, and then said: The Messenger of Allah (may peace be updn him) used to do this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1919]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1919

'Abdullah b. 'Umar, while describing the Nafl prayer of the Messenger of Allah (may peace be upon him), said: He did not observe (Nafl) prayer after Jumu'a till he went back and observed two rak'ahs in his house. Yahya said: I guess that I uttered these words (before Imam Malik) that he of course observed (them).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1920]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1920

Salim narrated on the authority of his father that the Apostle of Allah (may peace be upon him) used to observe two rak'ahs after Jumu'a.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1921]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1921

'Umar b. 'Ata' b. Abu Khuwar said that Nafi' b. Jubair sent him to al- Sa'ib the son of Namir's sister with a view to asking him about what he had seen in the prayer of Mu'awiya. He said: Yes, I observed the Jumu'a prayer along with him in Maqsura and when the Imam pronounced salutation I stood up at my place and observed (Sunan rak'ahs). As he entered (the apartment) he sent for me and said: Do not repeat what you have done. Whenever you have observed the Jumu'a prayer, do not observe (Sunan prayer) till you, have talked or got out For the Messenger of Allah (may peace be upon him) had ordered us to do this and not to combine two (types of) prayers without talking of going out.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1922]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1922

The same hadith is narrated on the authority of 'Umar b. Ata' but with this modification: When he (the Imam) pronounced salutation I stood up at my place. No mention was made of the Imam in it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1923]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1923

Ibn 'Abbas reported: I participated in the Fitr prayer with the Apostle of Allah (may peace be upon him) and Abu Bakr, 'Umar and 'Uthman, and all of them observed this prayer before the Khutba, and then he (the Holy Prophet) delivered the sermon. Then the Apostle of Allah (may peace be upon him) descended (from the pulpit) and I (perceive) as if I am seeing him as he is commanding people with his hand to sit down. He then made his way through their (assembly) till he came to the women. Bilal was with him. He then recited (this verse): O Prophet, when believing women come to thee giving thee a pledge that they will not associate aught with Allah" (lx. 12) till he finished (his address to) them and then said: Do you conform to it (what has been described in the verse)? Only one woman among them replied: Yes, Apostle of Allah, but none else replied. He (the narrator) said: It could not be ascertained who actually she was. He (the Holy Prophet) exhorted them to give alms. Bilal stretched his cloth and then said: Come forward with alms. Let my father and mother be taken as ransom for you. And they began to throw rings and ringlets in the cloth of Bilal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1924]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1924

Ibn 'Abbas reported: I bear testimony to the Messenger of Allah (may peace be upon him) offering prayer before Kbutba. He (after saying prayer) delivered the Kutba, and he found that the women could not hear it, so he came to them and exhorted them and preached them and commanded them to give alms, and Bilal had stretched his cloth and the women were throwing rings, earrings and other things. This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1925]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1925

Jabir b. 'Abdullah reported: The Apostle of Allah (may peace be upon him) stood up on the day of 'Id al-Fitr and observed prayer. And he commenced the prayer before the sermon. He then delivered the sermon. When the Apostle of Allah (may peace be upon him) had finished (the sermon) he came down from (the pulpit), and made his way to the women and exhorted them (to do good acts), and he was leaning on the hand of Bilal. Bilal had stretched his cloth in which women were throwing alms. I (one of the narrators) said to 'Ata' (the other narrator): It must be Zakat on the day of Fitr. He ('Ata') said: No. It was alms (which) they were giving on that occasion, and a woman gave her ring, and then others gave, and then others gave. I said to 'Ata': Is It right now for the Imam to come to the women when he has finished (his address to the men) that he should exhort them (to good deeds)? He said: (Why not) by my life, it is right for them (to do so). What is the matter with them that they do not do it now?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1926]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1926

Jabir b. 'Abdullah reported: I observed prayer with the Messenger of Allah (may peace be upon him) on the 'Id day. He commenced with prayer before the sermon without Adhan and Iqama. He then stood up leaning on Bilal, and he commanded (them) to be on guard (against evil for the sake of) Allah, and he exhorted (them) on obedience to Him, and he preached to the people and admonished them. He then walked on till he came to the women and preached to them and admonished them, and asked them to give alms, for most of them are the fuel for Hell. A woman having a dark spot on the cheek stood up and said: Why is it so, Messenger of Allah? He said: For you grumble often and show ingratitude to your spouse. And then they began to give alms out of their ornaments such as their earrings and rings which they threw on to the cloth of Bilal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1927]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1927

Ibn 'Abbas and Jaibir b. 'Abdullah al-Ansari reported: There was no Adhan on the (occasion) of Id-ul-Fitr and Id-ul-Adha. I (Ibn Juraij) said: I asked him after some time about it. He ('Ata', one of the narrators) said: Jabir b. 'Abdullah al-Ansari told me: There is neither any Adhan on Id-ul-Fitr when the Imam comes out, nor even after his coming out; their is neither lqama nor call nor anything of the sort of calling on that day and nor Iqama.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1928]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1928

'Ata' reported that Ibn 'Abbas sent (him) to Ibn Zubair at the commencement of the oath of allegiance to him (for Caliphate saying): As there is no Adhan on 'Id-ul-Fitr, so you should not pronounce it. Ibn Zubair did not pronounce Adhan on that day. He (Ibn 'Abbas) also sent him (with this message) that sermon (is to be delivered) after the prayer, and thus it was done. So lbn Zubair observed prayer before Khutba.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1929]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1929

Jabir b. Samura said: I prayed with the Messenger of Allah (may peace be upon him) prayers on two I'ds wore than once or twice without there being Adhan and Iqama.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1930]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1930

Ibn 'Umar reported that the Apostle of Allah (may peace be upon him), Abu Bakr and 'Umar used to observe the two 'Id prayers before the sermon.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1931]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1931

Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) used to go out on the day of Adha and on the day of Fitr and commenced the prayer. And after having observed his prayer and pronounced the salutation, he stood up facing people as they were seated at their places of worship. And if he intended to send out an army he made mention of it to the people, and if he intended any other thing besides it, he commanded them (to do that). He used to say (to the people): Give alms, give alms, give alms, and the majority that gave alms was of women. He then returned and this (practice) remained (in vogue) till Marwan b. al- Hakam (came into power). I went out hand in hand with Marwan till we came to the place of worship and there Kathir b. Salt had built a pulpit of clay and brick. Marwan began to tug me with his hand as though he were pulling me towards the pulpit, while I was pulling him towards the prayer. When I saw him doing that I said: What has happened to the practice of beginning with prayer? He said: No, Abu Sa'id, what you are familiar with has been abandoned. I thereupon said (three times and went back): By no means, by Him in Whose hand my life is, you are not doing anything better than what I am familiar with.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1932]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1932

Umm 'Atiyya said: He (the Apostle of Allah) commanded us that we should take out unmarried women and purdah-observing ladies for 'Id prayers, and he commanded the menstruating women to remain away from the place of worship of the Muslims.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1933]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1933

Umm Atiyya reported: We were commanded to bring out on old days purdah-observing ladies and those unmarried, and menstruating women came out but remained behind people and pronounced takbir (Allah-o-Akbar) along with them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1934]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1934

Umm 'Atiyya reported: The Messenger of Allah (may peace be upon him) commanded us to bring out on'Id-ul-Fitr and 'Id-ul-Adha young women, menstruating women and purdah-observing ladies, menstruating women kept back from prayer, but participated in goodness and supplication of the Muslims. I said: Messenger of Allah, one of us does not have an outer garment (to cover her face and body). He said: Let her sister cover her with her outer garment.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1935]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1935

Ibn 'Abbas reported that the Messenger of Allah (may peace be upon him) went out on the day of Adha or Fitr and observed two rak'ahs, and did not observe prayer (at that place) before and after that. He then came to the women along with Bilal and commanded them to give alms and the women began to give their rings and necklaces.

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1936]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1936

'Abdullah b. 'Umar reported that (his father) 'Umar b. Khattab asked Abu Waqid al-Laithi what the Messenger of Allah (may peace be upon him) used to recite on 'Id-ul-Adha and 'Id-ul-Fitr. He said: He used to recite in them:" Qaf. By the Glorious Qur'an" (Surah 1)," The Hour drew near, and the moon was rent asunder" (Surah liv.).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1937]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1937

'Utba reported that his father Waqid al-Laithi said: 'Umar b. Khattab asked me what the Messenger of Allah (may peace be upon him) recited on 'Id day. I said:" The Hour drew near" and Qaf. By the Glorious Qur'an".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1938]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1938

'A'isha reported: Abu Bakr came to see me and I had two girls with me from among the girls of the Ansar and they were singing what the Ansar recited to one another at the Battle of Bu'ath. They were not, however, singing girls. Upon this Abu Bakr said: What I (the playing of) this wind instrument of Satan in the house of the Messenger of Allah (may peace be upon him) and this too on 'Id day? Upon this the Messenger of Allah (may peace be upon him) said: Abu Bakr, every people have a festival and it is our festival (so let them play on).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1939]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1939

This hadith has been narrated by Hisham with the same chain of transmitters, but there the words are:" Two girls were playing upon a tambourine."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1940]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1940

'A'isha reported that Abu Bakr came to her and there were with her two girls on Adha days who were singing and beating the tambourine and the Messenger of Allah (may peace be upon him) had wrapped himself with his mantle. Abu Bakr scolded them. The Messenger of Allah (may peace he upon him) uncovered (his face) and said: Abu Bakr, leave them alone for these are the days of 'Id. And 'A'isha said: I recapitulate to my mind the fact that once the Messenger of Allah (may peace be upon him) screened me with his mantle and I saw the sports of the Abyssinians, and I was only a girl, and so you can well imagine how a girl of tender age is fond of watching the sport.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1941]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1941

'A'isha reported: BY Allah, I remember the Messenger of Allah (may peace be upon him) standing on the door of my apartment screening me with his mantle enabling me to see the sport of the Abyssinians as they played with their daggers in the mosque of the Messenger of Allah (may peace be upom him). He (the Holy Prophet) kept standing for my sake till I was satiated and then I went back; and thus you can well imagine how long a girl tender of age who is fond of sports (could have watched it).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1942]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1942

'A'isha reported: The Messenger of Allah (way peace be upon him) came (in my apartment) while there were two girls with me singing the song of the Battle of Bu'ath. He lay down on the bed and turned away his face. Then came Abu Bakr and he scolded me and said: Oh! this musical instrument of the devil in the house of the Messenger of Allah (may peace be upon him)! The Messenger of Allah (may peace be upon him) turned towards him and said: Leave them alone. And when he (the Holy Prophet) became unattentive, I hinted them and they went out, and it was the day of 'Id and negroes were playing with shields and speare. (I do not remember) whether I asked the Messenger of Allah (may peace be upon him) or whether he said to me if I desired to see (that sport). I said: Yes. I stood behind him with his face parallel to my face, and he said: O Banu Arfada, be busy (in your sports) till I was satiated. He said (to me): Is that enough? I said: Yes. Upon this he asked me to go.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1943]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1943

'A'isha reported that some Abyssinians came and gave a demonstration of armed fight on the 'Id day in the mosque. The Apostle of Allah (may peace be upon him) invited me (to see that fight). I placed my head on his shoulder and began to see their sport till it was I who turned away from watching them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1944]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1944

This hadith has been narrated by Hisham with the same chain of transmitters but (the narrators) did not make mention of the mosque.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1945]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1945

'A'isha said that she sent a message to the players (of this armed fight) saying: I like to see them (fighting). She further said: The Messenger of Allah (may peace be upon him) stood up and I stood at the door (behind him) and saw (this fight) between his ears and his shoulders they played in the mosque. 'Ata' (one of the narra- tors) said: Were they persians or Abyssinians? Ibn 'Atiq told me they were Abyssinians.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1946]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1946

Abu Huraira reported: While the Abyssinians were busy playing with their arms in the presence of the Messenger of Allah (may peace be upon him) 'Umar b. Khattab came there. He bent down to take up pebbles to throw at them (in order to make them go off). The Messenger of Allah (may peace be upon him) said to him: 'Umar, leave them alone.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1947]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1947

'Abdullah b. Zaid b. Mazini reported: The Messenger of Allah (may peace be upon him) went to the place of prayer and prayed for rain and turned round his mantle while facing the Qibla.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1948]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1948

Ibn Tamim narrated on the authority of his uncle ('Abdullah b. Zaid) that the Apostle of Allah (may peace be upon him) went out to the place of prayer and prayed for rain and faced towards Qibla, and turned round his mantle and prayed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1949]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1949

'Abdullah b. Zaid al-Ansari reported that the Messenger of Allah (may peace be upon him) went out to the place of prayer in order to offer prayer for rainfall. And when he intended to make supplication he faced Qibla and turned round his mantle.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1950]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1950

'Abbad b. Tamim Mazini heard his uncle, who was one of the Companions of the Messenger of Allah (may peace be upon him), as saying: The Messenger of Allah (may peace be upon him) went out one day in order to pray for rain. He turned his back towards people, supplicated before Allah, facing towards Qibla, and turned his mantle round and then observed two rak'ahs of prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1951]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1951

Anas reported: I saw the Messenger of Allah (may peace be upon him) raising his hands (high enough) in supplication (for rain) that the whiteness of his armpits became visible.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1952]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1952

Anas b. Malik reported that the Apostle of Allah (may peace be upon him) prayed for rain pointing the back of his hands to the sky.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1953]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1953

Anas reported that the Apostle of Allah (may peace be upon him) was not accustomed to raice his hands in any supplication he made except when praying for rain. (He would then raise [his hands] high enough) that the whiteness of his armpits became visible. 'Abd al-A'la said that (he was in doubt whether it was) the whiteness of his armpit or armpits.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1954]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1954

This hadith has been narrated by Anas b. Malik through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1955]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1955

Anas b. Malik reported that a person entered the mosque through the door situated on theside of Daral-Qada' during Friday (prayer) and the messenger of Allah (may peace be upon him) was delivering the sermon while standing. He came and stood in front of the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, the camels died and the passages were blocked; so supplicate Allah to send down rain upon us. The Messenger of Allah (may peace be upon him) raised his hands and then said: (O Allah, send down rain upon us; O Allah, send dowp rain upon us; O Allah, send down rain upon us. Anas said: By Allah, we did not see any cloud or any patch of it, and there was neither any house or building standing between us and the (hillock) Sal'a. There appeared a cloud in the shape of a shield from behind it, and as it (came high) in the sky it spread and then there was a downpour of rain. By Allah, we did not see the sun throughout the week. Then (that very man) came on the coming Friday through the same door when the Messenger of Allah (may peace be upon him) was standing and delivering the sermon. He stood in front of him and said: Messenger of Allah, our animals died and the passages blocked. Supplicate Allah to stop the rain for us. The Messenger of Allah (may peace be upon him) again raised his hands and said: O Allah, let it (rain) fall in our suburbs and not on us, O Allah (send it down) on the hillocks and small mountains and the river-beds and at places where trees grow. The rain stopped, and as we stepped out we were walking in sun- shine. He (the narrator) said to Sharik: I asked Anas b. Malik if he was the same man. He said: I do not know.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1956]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1956

Anas b. Malik reported: The people were in the grip of famine during the lifetime of the Messenger of Allah (may peace be upon him), and (once) as the Messenger of Allah (may peace be upon him) was delivering the sermon standing on the pulpit on Friday, a bedouin stood up and said: Messenger of Allah, the animals died and the children suffered starvation. The rest of the hadith is the same (and the words are) that he (the Holy Prophet) said: O Allah, send down rain in our suburbs but not on us. He (the narrator) said: To whichever directions he pointed with his hands, the clouds broke up and I saw Medina like the opening of a (courtyard) and the stream of Qanat flowed for one month, and none came from any part (of Arabia) but with the news of heavy rainfall.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1957]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1957

Anas b. Malik reported that while the Apostle of Allah (may peace be upon him) was delivering the sermon on Friday, people stood up before him and said in a loud voice: Apostle of Allah, there is a drought and the trees have become yellow, the animals have died; and the rest of the hadith is the same, and in the narration transmitted by 'Abd al-A'la the words are:" The clouds cleard from Medina and it began to rain around it and not a single drop of rain fell in Medina. And as I looked towards Medina, I found it hollow like (the hollowness of) a basin.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1958]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1958

This hadith has been narrated on the authority of Anas but with this addition:" Allah gathered the clouds and as we (were obliged) to stay back I saw that even the strong man, impelled by a desire to go to his family, (could not do so)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1959]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1959

'Ubaidullah b. Anas b. Malik heard (his father) Anas b. Malik as saying: A bedouin came to the Messenger of Allah (may peace be upon him) on Friday as he was (delivering the sermon on his) pulpit; and the rest of the hadith is the same but with this addition:" I saw the cloud clearing just as a sheet is folded."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1960]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1960

Anas (b. Malik) reported: It rained upon us as we were with the Messenger of Allah (may peace be upon him). The Messenger of Allah (way peace be upon him) removed his cloth (from a part of his body) till the rain fell on it. We said: Messenger of Allah, why did you do this? He said: It is because it (the rainfall) has just come from the Exalted Lord.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1961]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1961

'Ata' b. Abi Rabah reported that he heard 'A'isha, the wife of the Apostle of Allah (way peace be upon him), as saying: When there was on any day windstorm or dark cloud (its effects) could be read on the face of the Messenger of Allah (may peace be upon him), and he moved forward and backward (in a state of anxiety) ; and when it rained, he was delighted and it (the state of restlessness) disappeared. 'A'isha said: I asked him the reason of this anxiety and he said: I was afraid that it might be a calamity that might fall upon my Ummah, and when he saw rainfall he said: It is the mercy (of Allah).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1962]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1962

'Ata' b. Rabah reported on the authority of 'A'isha, the wife of the Apostle of Allah (way peace be upon him), who said: Whenever the wind was stormy, the Apostle of Allah (may peace be upon him) used to say: O Allah! I ask Thee for what is good in it, and the good which it contains, and the good of that which it was sent for. I seek refuge with Thee from what is evil in it, what evil it contains, and the evil of that what it was sent for; and when there was a thunder and lightning in the sky, his colour underwent a change, and he went out and in, backwards and forwards; and when the rain came, he felt relieved, and I noticed that (the sign of relief) on his face. 'A'isha asked him (about it) and he said: It may be as the people of 'Ad said: When they saw a cloud formation coming to their valley they said:" It is a cloud which would give us rain" (Qur'an, xlvi. 24).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1963]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1963

'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported: I never saw Allah's Messenger (may peace be upon him) laugh to such an extent that I could see his uvula-whereas he used to smile only-and when he saw dark clouds or wind, (the signs of fear) were depicted on his face. I said: Messenger of Allah, I find people being happy when they ace the dark cloud in the hope that it would bring rain, but I find that when you see that (the cloud) there is an anxiety on your face. He said: 'A'isha, I am afraid that there may be a calamity in it, for a people was afflicted with wind, when the people saw the calamity they said:" It is a cloud which would give us rain" (Qur'an. xlvi. 24).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1964]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1964

Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: I have been helped by the east wind and the 'Ad were destroyed by the west wind.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1965]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1965

This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1966]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1966

'A'isha reported that there was a solar eclipse in the time of the Messenger of Allah (may peace be upon him). He stood up to pray and prolonged his stand very much. He then bowed and prolonged very much his bowing. He then raised his head and prolonged his stand much, but it was less than the (duration) of the first stand. He then bowed and prolonged bowing much, but it was less than the duration of his first bowing. He then prostrated and then stood up and prolonged the stand, but it was less than the first stand. He then bowed and prolonged his bowing, but it was less than the first bowing. He then lifted his head and then stood up and prolonged his stand, but it was less than the first stand. He then bowed and prolonged bowing and it was less than the first bowing. He then prostrated himself; then he turned about, and the sun had become bright, and he addressed the people. He praised Allah and landed Him and said: The sun and the moon are two signs of Allah; they are not eclipsed on account of anyones death or on account of anyone's birth. So when you see them, glorify and supplicate Allah, observe prayer, give alms. O Ummah of Muhammad, none is more indignant than Allah When His servant or maid commits fornication. O people of Muhammad, by Allah, if you knew what I know, you would weep much and laugh little.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1967]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1967

This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters but with this addition:" Verily the sun and the moon are among the signs of Allah." And similarly this addition was made:" He then lifted his hands and said: O Allah! have I not conveyed it?"


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1968]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1968

'A'isha, the wife of the Apostle of Allah (may peace be upon him), reported There was an eclipse of the sun during the lifetime of the Messenger of Allah (may peace be upon him). So, the Messenger of Allah (may peace he upon him) went to the mosque and stood up and glorified Allah, and the people formed themselves in rows behind him. The Messenger of Allah (may peace be upon him) made a long recital (of the Qur'an) and then pronounced takbir and then observed a long ruku'. He then raised his head and said: Allah listened to him who praised Him: our Lord, praise is due to Thee. He then again stood up and made a long recital, which was less than the first recital. He pronounced takbir and observed a long ruku', and it was less than the first one. He again said: Allah listened to him who praised Him; our Lord, praise is due to Thee. (Abu Tahir, one of the narrators) made no mention of:" He then prostrated himself." He did like this in the second rak'ah, till he completed four rak'ahs and four prostrations and the sun became bright before he deported. He then stood up and addressed people, after lauding Allah as He deserved, and then said: The sun and the moon are two signs among the signs of Allah These do not eclipse either on the death of anyone or on his birth. So when you see them, hasten to prayer. He also said this: Observe prayer till Allah dispels the anxiety (of this extraordinary phenomenon) from you. The Messenger of Allah (may peace be upon him) said: I saw in my place everything which you have been promised. I even saw myself desiring to pluck a bunch (of grapes) from Paradise (and it was at the time) when you saw me moving forward. And I saw Hell and some of its parts crushing the others, when you saw me moving back; and I saw in it Ibn Luhayy and he was the person who made the she-camels loiter about. In the hadith transmitted by Abu Tahir the words are:" He hastened to prayer," and he made no mention of what follows.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1969]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1969

'A'isha reported that there was a solar eclipse during the lifetime of the Messenger of Allah (way peace be upon him) and he sent the announcer (to summon them) for congregational prayer. The people gathered together and he pronounced takbir and he observed four rak'ahs, in the form of two rak'ahs (i. e. he observed two qiyams and two ruku's in one rak'ah) and four prostrations.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1970]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1970

'A'isha reported that the Apostle of Allah (may peace be upon him) recited loudly in the eclipse prayer, and he observed four rak'ahs in the form of two rak'ahs and four prostrations. Zuhri said: Kathir b. 'Abbas narrated on the authority of Ibn 'Abbas that the Apostle of Allah (may peace be upon him) observed four rak'ahs and four prostrations in two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1971]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1971

Zuhri said: Kathir b. Abbas used to narrate that Ibn 'Abbas used to relate about the prayer of the Messenger of Allah (may peace be upon him) in regard to the eclipse of the sun like that what was narrated by 'Urwa on the authority of 'A'isha.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1972]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1972

'Ata' reported: I heard 'Ubaid b. 'Umair say: It has been narrated to me by one whom I regard as truthful, (the narrator says: I can well guess that he meant 'A'isha) that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) and he stood up (in prayer) for a rigorously long time. He then bowed and then stood up and then bowed and then stood up and then bowed, thus observing three ruku's in two rak'ahs and four prostrations. He then departed and the sun brightened. He pronounced" Allah is the Greatest" while bowing. He would then bow and say:" Allah listened to him who praised Him" while lifting up his head. He then stood up, and praised Allah and lauded Him, and then said: The sun and the moon do not eclipse on the death of anyone or on his birth. But both of them are among the signs of Allah with which Allah terrifies His servants. So when you see them under eclipse, remember Allah till they are brightened. This hadith is narrated thus on the authority of 'A'isha through another chain of transmitters:" The Messenger of Allah (may peace be upon him) observed six ruku's and four prostration in (two rak'ahs)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1973]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1973

'Amra reported that a Jewess came to 'A'isha to ask (about something) and said: May Allah protect you from the torment of the grave! 'A'isha said: Messenger of Allah, would people be tormented in the graves? The Messenger of Allah (may peace be upon him) said: (May there be) protection of Allah! The Messenger of Allah (may peace be upon him) mounted one morning on the ride, and the sun eclipsed. 'A'isha said: I came in the company of the women in the mosque from behind the rooms. The Messenger of Allah (way peace he upon him) dismounted from his ride and came to the place of worship where he used to pray. He stood up (to pray) and the people stood behind him. 'A'isha said: He stood for a long time. He then bowed and it was a long ruku'. He then raised his head and he stood for a long time, less than the first standing. He then bowed and his ruku' was long, but it was less than that (the first) ruku'. He then raised (his head) and the sun had become bright. He (the Holy Prophet) then said: I saw you under trial in the grave like the turmoil of Dajjal. 'Amra said: I heard 'A'isha say: I listened after this to the Messenger of Allah (may peace be upon him) seeking refuge from the torment of Fire and the torment of the grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1974]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1974

This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1975]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1975

Jabir b. 'Abdullah reported: The sun eclipsed on one extremely hot day during the lifetime of the Messenger of Allah (may peace be upon him). The Messenger of Allah (may peace be upon him) prayed along with his Companions. He prolonged his qiyam (standing posture in prayer) till they (his Companions) began to fall down. He then observed a long ruku'. He raised his head (and stood up for long) and then observed a long ruku'. He then raised (his head and stood up) for a long time and then made two prostrations. He then stood up and did like this and thus he observed four ruku's and four prostrations (in two rak'ahs) and then said: All these things were brought to me in which you will be made to enter. Paradise was brought to me till (I was so close to it) that if I (had intended) to pluck a bunch (of grapes) out of it. I would have got it, or he (the Holy Prophet) said: I intended to get a bunch (out of that) but my hand could not reach it. Hell was also brought to me and I saw in it a woman belonging to the tribe of Israel who was tormented for a cat whom she had tied, but did not give it food nor set it free to eat the creatures of the earth; and I saw Abu Thumama 'Amr b. Malik who was dragging his intestines in Hell. They (the Arabs) used to say that the sun and the moon do not eclipse but on the death of some great person; but (in reality) both these (the sun and the moon) are among the signs of Allah which are shown to you; so when there is an eclipse, observe prayer till it (the sun or the moon) brightens. This hadith has been narrated by Hisham with the same chain of transmitters except this" I saw a dark woman with a tail stature and loud voice," but he made no mention of" from among Bani Israel".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1976]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1976

Jabir reported that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) on that very day when Ibrahim (the Prophet's son) died. The Apostle of Allah (may peace be upon him) stood up and led people in (two rak'ahs of) prayer with six ruku's and four prostrations. He commenced (the prayer) with takbir (Allah-o-Akbar) and then recited and prolonged his recital. He then bowed nearly the (length of time) that he stood up. He then raised his head from the ruku' and recited but less than the first recital. He then bowed (to the length of time) that he stood up. He then raised his head from the ruku' and again recited but less than the second recital. He then bowed (to the length of time) that he stood up. He then lifted his head from the ruku'. He then fell in prostration and observed two prostrations. He stood up and then bowed, observing six ruku's like it, without (completing) the rak'ah in them, except (this difference) that the first (qiyam of ruku') was longer than the later one, and the ruku' was nearly (of the same length) as prostration. He then moved backward and the rows behind him also moved backward till we reached the extreme (Abu Bakr said: till he reached near the women) He then moved forward and the people also moved forward along with him till he stood at his (original) place (of worship). He then completed the prayer as it was required to complete and the sun brightened and he said: O people! verily the sun and the moon are among the signs of Allah and they do not eclipse at the death of anyone among people (Abu Bakr said: On the death of any human being). So when you see anything like it (of the nature of eclipse), pray till it is bright. There is nothing which you have been promised (in the next world) but I have seen it in this prayer of mine. Hell was brought to me as you saw me moving back on account of fear lest its heat might affect me; and I saw the owner of the curved staff who dragged his intestines in the fire, and he used to steal (the belongings) of the pilgrims with his curved staff. If he (the owner of the staff) became aware, he would say: It got (accidentally) entangled in my curved staff, but if he was unaware of that, he would take that away. I also saw in it (in Hell) the owner of a cat whom she had tied and did not feed her nor set her free so that she could eat the creatures of the earth, till the cat died of starvation. Paradise was brought to me, and it was on that occasion that you saw me moving forward till I stood at my place (of worship). I stretched my hand as I wanted to catch hold of its fruits so that you may see them. Then I thought of not doing it. Nothing which you have been promised was there that I did not see in this prayer of mine.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1977]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1977

Asma' reported: The sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him). As I went to 'A'isha who was busy in prayer. I said: What is the matter with the people that they are praying (a special prayer)? She ('A'isha) pointed towards the sky with her head. I said: Is it (an unusual) sign? She said: Yes. The Messenger of Allah (may peace be upon him) stood up for prayer for such a long time that I was about to faint. I caught hold of a waterskin lying by my side, and began to pour water over my head, or (began to sprinkle water) on my face. The Messenger of Allah (may peace be upon him) then finished and the sun had brightened. The Messenger of Allah (may peace be upon him) then addressed the people, (after) praising Allah and lauding Him, and then said: There was no such thing as I did not see earlier, but I saw it at this very place of mine. I ever saw Paradise and Hell. It was also revealed to me that you would be tried in the graves, as you would he tried something like the turmoil of the Dajjal. Asma' said: I do not know which word he actually used (qariban or mithl), and each one of you would be brought and it would be said: What is your knowledge about this man? If the person is a believer, (Asma' said: I do not know whether it was the word al-Mu'min or al-Mu'qin) he would say: He is Muhammad and he is the Messenger of Allah. He brought to us the clear signs and right guidance. So we responded and obeyed him. (He would repeat this three times), and it would be said to him: You should go to sleep. We already knew that you are a believer in him. So the pious man would go to sleep. So far as the hypocrite or sceptic is concerned (Asma' said: I do not know which word was that: al-Munafiq (hypocrite) or al-Murtad (doubtful) he would say: I do not know. I only uttered whatever I heard people say.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1978]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1978

Asma' said: I came to 'A'isha when the people were standing (in prayer) and she was also praying. I said: What is this excitement of the people for? And the rest of the hadith was narrated like one, (narrated above). 'Urwa said: Do not say Kasafat-ush-Shamsu, but say Khasafat-ush-Shamsu.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1979]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1979

Asma' bint Abu Bakr said: The Apostle of Allah (may peace be upon him) was one day (i. e. on the day when the sun eclipsed) so perturbed that he (in haste) took hold of the outer garment (of a female member of his family) and it was later on that his (own) cloak was sent to him. He stood in prayer along with people for such a long time that if a man came he did not realise that the Apostle of Allah (may peace be upon him) had observed ruku', as it has been narrated about ruku' in connection with long qiyam.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1980]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1980

Abu Juraij narrated this hadith with the same chain of transmitters (but with the addition of these words):" It was for a long duration that he (the Holy Prophet) observed qiyam and he would then observe ruku'. (The narrator also added) I (Asma') looked at a woman who was older than I, and at another who was weaker than I.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1981]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1981

Asma' daughter of Abu Bakr reported: The sun eclipsed during the lifetime of the Apostle of Allah (may peace be upon him) ; so he felt perturbed and he, by mistake, took hold of the outer garment of a woman till he was given his own cloak. After this I satisfied my need and then came and entered the mosque. I saw the Messenger of Allah (may peace be upon him) standing in prayer. I stood along with him. He prolonged his qiyam till I wished to sit down. Then I cast a glance towards an old woman. So I said: She is older than I. I, therefore, kept standing. He (the Holy Prophet) then observed ruku', and prolonged his ruku'. He then raised his head. He then prolonged his qiyam to such an extent that if a person happened to come he would have thought that he had not observed the ruku'.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1982]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1982

Ibn 'Abbas reported: There was an eclipse of the sun during the lifetime of the Messenger of Allah (may peace be upon him). The Messenger of Allah, (may peace be upon him) prayed accompanied by the people. He stood for a long time, about as long as it would take to recite Surah al-Baqara; then he bowed for a long time; then he raised his head and stood for a long time, but it was less than the first qiyam. He then bowed for a long time but for a shorter while than the first. He then prostrated and then stood for a long time, but it was less than the first qiyam. He then bowed for a long time, but it was less than the first bowing. He then raised (his head) and stood for a long time, but it was less than the first qiyam. He then bowed for a long time but it was less than the first bowing. He then observed prostration, and then he finished, and the sun had cleared (by that time). He (the Holy Prophet) then said: The sun and moon are two signs from the signs of Allah. These two do not eclipse on account of the death of anyone or on account of the birth of anyone. So when you see that, remember Allah. They (his Companions) said: Messenger of Allah, we saw you reach out to something, while you were standing here, then we saw you restrain yourself. He said: I saw Paradise and reached out to a bunch of its grapes; and had I taken it you would have eaten of it as long as the world endured. I saw Hell also. No such (abominable) sight have I ever seen as that which I saw today; and I observed that most of its inhabitants were women. They said: Messenger of Allah, on what account is it so? He said: For their ingratitude or disbelief (bi-kufraihinna). It was said: Do they disbelieve in Allah? He said: (Not for their disbelief in God) but for their ingratitude to their husbands and ingratitude to kindness. If you were to treat one of them kindly for ever, but if she later saw anything (displeasing) in you, she would say: i have never seen any good in you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1983]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1983

This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters except with this difference that he (the narrator said):" then we saw you keeping aloof (back)."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1984]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1984

Ibn 'Abbas reported: When there was a solar eclipse the Messenger of Allah (way peace be upon him) observed eight ruku's and four prostrations (in two rak'ahs). This has been narrated by 'Ali also.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1985]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1985

Ibn 'Abbas reported: The Apostle of Allah (may peace be upon him) observed prayer while it was (solar) eclipse. He recited (the Qur'an in qiyam) and then bowed. He again recited and again bowed. He again recited and again bowed and again recited and again bowed, and then prostrated; and the second (rak'ah) was like this.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1986]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1986

'Amr b. al-'As reported: When the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him), they (the people) were called to congregational prayers. The Messenger of Allah (may peace be upon him) observed two ruku's in one rak'ah. He then stood and observed two ruku's in (the second) rak'ah. The sun then became bright, and 'A'isha said; Never did I observe, ruku' and prostration longer than this (ruku' and prostration).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1987]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1987

Abu Mas'ud al-Ansari reported Allah's Messenger (may peace be upon him) as saying: Verily the sun and the moon are the two signs among the signs of Allah by which He frightens his servants and they do not eclipse on account of the death of any one of the people. So when you see anything about them, observe prayer, supplicate Allah till it is cleared from you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1988]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1988

Abu Mas'ud reported that the Messenger of Allah (may peace be upon him) said: Verily the sun and the moon do not eclipse on account of the death of any one of the people, but they are the two signs among the signs of Allah. So when you see it, stand up and observe prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1989]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1989

This hadith has been narrated on the authority of Isma'il with the same chain of transmitters and in the hadith narrated by Sufyan and Waki' (the words are):" The sun eclipsed on the day when Ibrahim died, and the people said: It has eclipsed on the death of Ibrahim."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1990]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1990

Abu Musa reported: The sun eclipsed during the time of the Apostle of Allah (may peace be upon him). He stood in great anxiety fearing that it might be the Doomsday, till he came to the mosque. He stood up to pray with prolonged qiyam, ruku', and prostration which I never saw him doing in prayer; and then he said: These are the signs which Allah sends, not on account of the death of anyone or life of any one, but Allah sends them to frighten thereby His servants. So when you see any such thing, hasten to remember Him, supplicate Him and beg pardon from Him, and in the narration transmitted by Ibn 'Ala the words are:" The sun eclipsed"."" He frightens His servants."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1991]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1991

'Abd al-Rahman b. Samura said: During the lifetime of Allah's Messenger (may peace be upon him) I was shooting my arrows in Medina, when an eclipse of the sun took place. I, therefore, threw them away and said, I must see how the Messenger of Allah (may peace be upon him) acts in a solar eclipse today. When I came to him, he had been supplicating with his hands, raised, pronouncing Allah-o-Akbar, praising Him, acknowledging that He is One God till the eclipse was over, then he recited two surahs and prayed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1992]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1992

'Abd al-Rahman b. Samura, who was one of the Companions of the Messenger of Allah (may peace be upon him) said: During the lifetime of Allah's Messenger (may peace be upon him) I was shooting some of my arrows in Medina, when the sun eclipsed. I threw (the arrows) and said: By Allah, I must see how the Messenger of Allah (may peace be upon him) acts in solar eclipse. So I came to him and he was standing in prayer, raising his hands, glorifying Him, praising Him, acknowledging His Oneness, declaring His greatness, and supplicating Him, till the sun cleared. When the eclipse was over, he recited two surahs and prayed two rak'ahs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1993]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1993

'Abd al-Rahman b. Samura reported: I was shooting some of my arrows during the lifetime of the Messenger of Allah (may peace be upon him) that the sun eclipsed. The rest of the hadith is the same.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1994]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1994

'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) observed: Verily the sun and the moon do not eclipse on account of the death or life of anyone. They are in fact the signs among the signs of Allah. So when you see them, observe prayer.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1995]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1995

Ziyad b. 'Ilaqa reported: I heard Mughira b. Shu'ba saying that the sun eclipsed during the lifetime of the Messenger of Allah (may peace be upon him) on the day when Ibrahim died. Upon this the Messenger of Allah (may peace be upon him) said: Verily the sun and the moon are the two signs among the signs of Allah. They do not eclipse on account of the death of anyone or on account of the birth of anyone. So when you see them, supplicate Allah, and observe prayer till it is over.

KITAB-UL-JANA'IZ

BOOK RELATING TO THE DEAD

A Divine Service is held over the dead body of every Muslim, young or old, even of infants who have lived only for a few minutes. A Muslim opens his eyes in the world with the words of Adhan in his ears in which he is told that he is a moral being having moral and spiritual responsibilities far more important than the physical needs. He should live in the world with a firm belief in the Creator of the Universe as his only Deity. Then he should spend his life as a sincere and devoted follower of Muhammad (may peace be upon him), for it is through him that he has received full information about the Will of God and the Divine Code of life. It Is also imprinted upon his fresh and clear mind that prayer elevates the soul of man and herein lies his success in this world and the world to come. With this sacred message he is made to start his life. Both the paths are shown to him, the path of righteousness and religious piety and the path of evil and irreligiousness, and then it is left to his discretion to choose the path he likes. After spending the allotted length of time he is called back to his Master.

When the soul leaves the body, preparations are made for bidding him the last farewell. He is washed and perfumed and is wrapped in white sheets. Then the funeral prayer is observed keeping his dead body in front of the Imam in which God to requested in congregation to grant him pardon for his minor and major sins, for all his failings and to wrap him in His Mercy.

A Muslim is received in this world with Adhan and lqama and he is given a send- off with prayer and supplication to Allah for treating him kindly in his heavenly home.

There is neither Adhan nor Iqama in the funeral prayer which has very deep significance. It implies that the Adhan and lqama for the funeral prayer had been pronounced at the time of his birth. He is thus awakened to the realisation of the fact that he should spend the whole span of his life with such single-minded devotion as is found in a worshipper waiting for the commencement of prayer after the Adhan and Iqama are pronounced.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1996]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1996

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Exhort to recite" There is no god but Allah" to those of you who are dying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1997]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1997

This hadith has been narrated by Sulaiman b. Bilal with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1998]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1998

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Exhort to recite" There is no god but Allah" to those of you who are dying.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.1999]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 1999

Umm Salama reported Allah's Messenger (may peace be upon him) as saying: If any Muslim who suffers some calamity says, what Allah has commanded him," We belong to Allah and to Him shall we return; O Allah, reward me for my affliction and give me something better than it in exchange for it," Allah will give him something better than it in exchange. When Abu Salama died she said: What Muslim is better than Abu Salama whose family was the first to emigrate to the Messenger of Allah (may peace be upon him). I then said the words, and Allah gave me God's Messenger (may peace be upon him) in exchange. She said: The Messenger of Allah (may peace be upon him) sent Hatib b. Abu Balta'a to deliver me the message of marriage with him. I said to him: I have a daughter (as my dependant) and I am of jealous temperament. He (the Holy Prophet) said: So far as her daughter is concerned, we would supplicate Allah, that He may free her (of her responsibility) and I would also supplicate Allah to do away with (her) jealous (temperament).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2000]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2000

Umm Salama, the wife of the Apostle of Allah (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: If any servant (of Allah) who suffers a calamity says:" We belong to Allah and to Him shall we return; O Allah, reward me for my affliction and give me something better than it in exchange for it," ' Allah will give him reward for affliction, and would give him something better than it in exchange. She (Umm Salama) said: When Abu Salama died. I uttered (these very words) as I was commanded (to do) by the Messenger of Allah (may peace be upon him). So Allah gave me better in exchange than him. i. e. (I was taken as the wife of) the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2001]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2001

Umm Salama, the wife of the Apostle of Allah (way peace be upon him), reported Allah's Messenger (may peace be upon him) saying like the hadith transmitted by Abu Usama, but with this addition that she said:" When Abu Salama died I said: Who is better than Abu Salama, the Companion of the Messenger of Allah (may peace be upon him), and Allah decided for me and I said (these words contained in the supplication mentioned above) and I was married to the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2002]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2002

Umm Salama reported Allah's Messenger (may peace be upon him) as saying: Whenever you visit the sick or the dead, supplicate for good because angels say" Amen" to whatever you say. She added: When Abu Salama died, I went to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, Abu Salama has died. He told me to recite:" O Allah! forgive me and him (Abu Salama) and give me a better substitute than he." So I said (this), and Allah gave me in exchange Muhammad, who is better for me than him (Abu Salama).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2003]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2003

Umm Salama reported: The Messenger of Allah (may peace be upon came to Abu Salama (as he died). His eyes were fixedly open. He closed them, and then said: When the soul is taken away the sight follows it. Some of the people of his family wept and wailed. So he said: Do not supplicate for yourselves anything but good, for angels say" Amen" to what you say. He then said: O Allah, forgive Abu Salama, raise his degree among those who are rightly guided, grant him a successor in his descendants who remain. Forgive us and him, O Lord of the Universe, and make his grave spacious, and grant him light in it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2004]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2004

This hadith has been narrated by Khalid al Hadhdha' with the same chain of transmitters but with this alteration that he said: (O Allah! ) let Thee be the caretaker of what is left by him, and he said: Grant him expansion of the grave, but he did not say: Make his grave spacious. Khalid said: He supplicated for the seventh (thing too) which I have forgotten.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2005]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2005

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Did you not see when the man died and his eyes were fixedly open? He (Abu Huraira) said: Yes. He (the Holy Prophet) said: It is due to the fact that when (the soul leaves the body) his eyesight follows the soul.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2006]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2006

This hadith is narrated on the authority of 'Ala' with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2007]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2007

Umm Salama reported: When Abu Salama died I said: I am a stranger in a strange land; I shall weep for him in a manner that would be talked of. I made preparation for weeping for him when a woman from the upper side of the city came there who intended to help me (in weeping). She happened to come across the Messenger of Allah (may peace be upon him) and he said: Do you intend to bring the devil into a house from which Allah has twice driven him out? I (Umm Salama), therefore, refrained from weeping and I did not weep.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2008]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2008

Usama b. Zaid reported: While we were with the Apostle of Allah (may peace be upon him), one of his daughters sent to him (the Messenger) to call him and inform him that her child or her son was dying. The Messenger of Allah (may peace be upon him) told the messenger to go back and tell her that what Allah had taken belonged to Him, and to him belonged what He granted; and He has an appointed time for everything. So you (the messenger) order her to show endurance and seek reward from Allah. The messenger came back and said: She adjures him to come to her. He got up to go accompanied by Sa'd b. 'Ubada, Mu'adh b. Jabal, and I also went along with them. The child was lifted to him and his soul was feeling as restless as if it was in an old (waterskin). His (Prophet's) eyes welled up with tears. Sa'd said: What is this, Messenger of Allah? He replied: This is compassion which Allah has placed in the hearts of His servants, and God shows compassion only to those of His servants who are compassionate.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2009]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2009

This hadith has been narrated by another chain of transmitters on the authority of 'Asim al-Ahwal.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2010]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2010

'Abdullah b. 'Umar said that Sa'd b. Ubada complained of illness. The Messenger of Allah (may peace be upon him) came to visit him accompanied by 'Abd al-Rahman b. 'Auf, Sa'd b. Abi Waqqas and 'Abdullah b. Mas'ud. As he entered (his room) he found him in a swoon. Upon this he said: Has he died? They said: Messenger of Allah, it is not so. The Messenger of Allah (may peace be upon him) wept. When the people saw Allah's Messenger (may peace be upon him) weeping, they also began to weep. He said. Listen, Allah does not punish for the tears that the eye sheds or the grief the heart feels, but He punishes for this (pointing to his tongue), or He may show mercy.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2011]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2011

'Abdullah b. 'Umar reported: While we were sitting with the Messenger of Allah (may peace be upon him), a person, one of the Ansar, came to him and greeted him. The Ansari then turned back. Upon this the Messenger of Allah (may peace be upon him) said: o brother of Ansar, how is my brother Sa'd be 'Ubada? He said: He is better. The Messenger of Allah (may peace be upon him) said: Who amongst you would visit him? He (the Holy Prophet) stood up and we also got up along with him, and we were more than ten persons. We had neither shoes with us, nor socks, nor caps, nor shirts. We walked on the barren land till we came to him. The people around him kept away till the Messenger of Allah (may peace be upon him) and his Companions with him came near him (Sa'd b. 'Ubada).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2012]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2012

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Endurance is to be shown at the first blow.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2013]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2013

Anas b. Malik reported that Allah's Messenger (may peace be upon him) came to a woman who had been weeping for her (dead) child, and said to her: Fear Allah and show endurance. She (not recognising him) said: You have not been afflicted as I have been. When he (the Holy Prophet) had departed, it was said to her that he was the Messenger of Allah (may peace be upon him), she was mortally shocked. She came to his door and she did not find doorkeepers at his door. She said: Messenger of Allah. I did not recognise you. He said: Endurance is to be shown at first blow, or at the first blow.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2014]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2014

A hadith like this is narrated with the same chain of transmitters but with the addition of these words:" The Apostle of Allah (may peace be upon him) happened to pass by a woman (who was sitting) by the side of a grave."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2015]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2015

'Abdullah b. 'Umar reported that Hafsa wept for 'Umar (when he was about to due). He ('Umar) said: Be quiet, my daughter. Don't you know that the Messenger of Allah (may peace be upon him) had said:" The dead is punished because of his family's weeping over it"?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2016]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2016

Umar reported Allah's Apostle (may peace be upon him) as saying: The dead is punished in the grave because of wailing on it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2017]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2017

The same hadith is narrated on the authority of 'Umar through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2018]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2018

Ibn 'Umar reported: When 'Umar was wounded he fainted, and there was a loud lamentation over him. When he regained consciousness he said: Didn't you know that the Messenger of Allah (may peace be upon him) said:" The dead is punished because of the weeping of the living"?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2019]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2019

Abu Burda narrated on the authority of his father that when 'Umar was wounded Suhaib uttered (loudly in lamentation): O brother! Upon this 'Umar said: Suhaib, did you not know that the Messenger of Allah (may peace be upon him) said:" The dead is punished because of the lamentation of the living"?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2020]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2020

Abu Musa reported that when 'Umar was wounded, there came Suhaib from his house and went to 'Umar and stood by his side, and began to wail. Upon this 'Umar said: What are you weeping for? Are you weeping for me? He said: By Allah, it is for you that I weep, O Commander of the believers. He said: By Allah, you already know that the Messenger of Allah (may peace be upon him) had said: He who is lamented upon is punished. I made a mention of it to Musa b. Talha, and he said that 'A'isha told that it concerned the Jews (only).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2021]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2021

Anas reported that when 'Umar b. Khattab was wounded Hafsa lamented for him. Upon this he said: O Hafsa, did you not hear the Messenger of Allah (may peace be upon him) saying:" One who is lamented would be punished"? Suhaib also lamented over him. 'Umar told him also: O Suhaib, didn't you know that one who is lamented is punished?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2022]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2022

'Abdullah b. Abu Mulaika reported: I was sitting by the side of Ibn 'Umar, and we were waiting for the bier of Umm Aban, daughter of 'Uthman, and there was also 'Amr b. 'Uthman. In the meanwhile there came Ibn 'Abbas led by a guide. I conceive that he was informed of the place of Ibn 'Umar. So he came till he sat by my side. While I was between them (Ibn 'Abbas and Ibn 'Umar) there came the noise (of wailing) from the house. Upon this Ibn 'Umar said (that is, he pointed out to 'Amr that he should stand and forbid them, for): I heard the Messenger of Allah (may peace be upon him) as saying: The dead is punished because of the lamentation of his family. 'Abdullah made it general (what was said for a particular occasion). Ibn 'Abbas said: When we were with the Commander of the believers, 'Umar b. Khattab, we reached Baida', and there was a man under the shadow of the tree. He said to me: Go and inform me who is that person. So I went and (found) that he was Suhaib. I returned to him and said: You commanded me to find out for you who that was, and he is Suhaib. He (Hadrat 'Umar) said: Command him to see us. I said: He has family along with him. He said: (That is of no account) even if he has family along with him. So he (the narrator) told him to see (the Commander of the believers and his party). When we came (to Medina), it was before long that the Commander of the believers was wounded, and Suhaib came weeping and crying: Alas for the brother, alas for the companion. Upon this 'Umar said: Didn't you know, or didn't you hear, that the Messenger of Allah (may peace be upon him) said:" The dead is punished because of the lamentation of his family"? Then 'Abdullah made it general and 'Umar told it of certain occasions. So I ('Abdullah b. Abu Mulaika) stood up and went to 'A'isha and told her what Ibn 'Umar had said. Upon this she said: I swear by Allah that Allah's Messenger (may peace be upon him) never said that dead would be punished because of his family's lamenting (for him). What he said was that Allah would increase the punishment of the unbeliever because of his family's lamenting for him. Verily it is Allah Who has caused laughter and weeping. No bearer of a burden will bear another's burden. Ibn Abu Mulaika said that al-Qasim b. Muhammad said that when the words of 'Umar and Ibn 'Umar were conveyed to 'A'Isha, she said: You have narrated it to me from those who are neither liar nor those suspected of lying but (sometimes) hearing misleads.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2023]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2023

'Abdullah b. Abu Mulaika said: The daughter of 'Uthman b. 'Affan died in Mecca. We came to attend her (funeral). Ibn 'Umar and Ibn 'Abbas were also present there, and I was sitting between them. He added: I (first sat) by the side of one of them, then the other one came and he sat by my side. 'Abdullah b. 'Umar said to 'Amr b. 'Uthman who was sitting opposite to him: Will you not prevent the people from lamenting, for the Messenger of Allah (may peace be upon him) had said:" The dead is punished because of the lamenting of his family for him"? Ibn 'Abbas then said that Umar used to say someting of that nature, and then narrated saying: I proceeded from Mecca along with 'Umar till we reached al-Baida' and there was a party of riders under the shade of a tree. He said (to me): Go and find out who this party is. I cast a glance and there was Suhaib (in that party). So I informed him ('Umar) about it. He said: Call him to me. So I went back to Suhaib and said: Go and meet the Commander of the believers. When 'Umar was wounded, Suhaib came walling: Alas, for the brother! alas for the companion! 'Umar said: O Suhaib, do you wail for me, whereas the Messenger of Allah (may peace be upon him) said:" The dead would be punished on account of the lamentation of the (members of his family)"? Ibn 'Abbas said: When 'Umar died I made a mention of it to 'A'isha. She said: May Allah have mercy upon 'Umar! I swear by Allah that Allah's Messenger (may peace be upon him) never said that Allah would punish the believer because of the weeping (of any one of the members of his family), but he said that Allah would increase the punishment of the unbeliever because of the weeping of his family over him. 'A'isha said: The Qur'an is enough for you (when it states):" No bearer of burden will bear another's burden" (vi. 164). Thereupon Ibn 'Abbas said: Allah is He Who has caused laughter and weeping. Ibn Abu Mulaika said: By Allah, Ibn 'Umar said nothing.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2024]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2024

'Amr reported on the authority of Ibn Abu Mulaika: We were with the bier of Umm Aban, daughter of 'Uthman, and the rest of the hadith is the same, but he did not narrate it as a marfu' hadith on the authority of 'Umar from the Apostle of Allah (may peace be upon him) as it was narrated by Ayyub and Ibn Juraij, and the hadith narrated by them (Ayyub and Ibn Juraij) is more complete than that of 'Amr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2025]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2025

'Abdullah b. 'Umar reported that the Messenger of Allah (may peace be upon him) said: The dead is punished because of the lamentation of the living.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2026]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2026

Hisham b. 'Urwa narrated on the authority of his father that the saying of Ibn 'Umar, viz." The dead would be punished because of the lamentation of his family over him" was mentioned to 'A'isha. Upon this she said: May Allah have mercy upon Abu 'Abd al-Rahman (the kunya of Ibn 'Umar) that he heard something but could not retain it (well). (The fact is) that the bier of a Jew passed before the Messenger of Allah (may peace be upon him) and (the members of his family) were waiting over him. Upon this he said: You are wailing and he is being punished.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2027]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2027

Hisham narrated on the authority of his father that it was mentioned to 'A'isha that Ibn 'Umar had narrated as marfu' hadith from the Apostle of Allah (may peace be upon him) that the dead would be punished in the grave because of the lamentation of his family for him. Upon this she said: He (Ibn 'Umar) missed (the point). The Messenger of Allah (may peace be upon him) had (in fact) said: He (the dead) is punished for his faults or for his sins, and the members of his family are wailing for him now. (This misunderstanding of Ibn 'Umar is similar to his saying: ) The Messenger of Allah (may peace be upon him) stood by the well in which were lying the dead bodies of those polytheists who had been killed on the Day of Badr, and he said to them what he had to say, i. e.: They hear what I say. But he (Ibn 'Umar) misunderstood. The Holy Prophet (may peace be upon him) had only said: They (the dead) understand that what I used to say to them was truth. She then recited:" Certainly, thou canst not make the dead hear the call" (xxvii. 80), nor can you make those hear who are in the graves, nor can you inform them when they have taken their seats in Hell.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2028]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2028

This hadith has been narrated by Ibn 'Urwa with the same chain of transmitters. The hadith narrated by Abu Usama is more complete.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2029]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2029

'Amra daughter of 'Abd al Rahman narrated that she heard (from) 'A'isha and made a mention to her about 'Abdullah b. 'Umar as saying: The dead is punished because of the lamentation of the living. Upon this 'A'isha said: May Allah have mercy upon the father of 'Abd al-Rahman (Ibn 'Umar). He did not tell a lie, but he forgot or made a mistake. The Messenger of Allah (may peace be upon him) happened to pass by a (dead) Jewess who was being lamented. Upon this he said: They weep over her and she is being punished in the grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2030]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2030

'Ali b. Rabi'a reported that the first one who was lamented upon in Kufa was Qaraza b. Ka'b. Mughira b. Shu'ba said: I heard the Messenger of Allah (may peace be upon him) saying: He who is lamented upon would be punished because of the lamentation for him on the Day of judgment.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2031]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2031

A hadith like this has been narrated by Mughira b. Shu'ba from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2032]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2032

This hadith has been narrated from the Apostle of Allah (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2033]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2033

Abu Malik al-Ash'ari reported Allah's Messenger (may peace be upon him) as saying: Among my people there are four characteristics belonging to pre-Islamic period which they do not abandon: boasting of high rank, reviling other peoples' genealogies, seeking rain by stars, and walling. And he (further) said: If the wailing woman does not repent before she dies, she will be made to stand on the Day of Resurrection wearing a garment of pitch and a chemise of mange.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2034]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2034

'A'isha reported that when the Messenger of Allah (may peace be upon him) was told that Ibn Haritha, Ja'far b. Abu Talib and Abdullah b. Rawaha were killed, he sat down, showing signs of grief. She (further) said: I was looking (at him) through the crevice of the door. A man came to him and mentioned that Ja'far's women were lamenting. He (the Holy Prophet) commanded him to go and forbid them (to do so). So he went away but came back and told (him) that they did not obey (him). He commanded him a second time to go and forbid them (to do so). He again went but came back to him and said: I swear by God, Messenger of Allah, that they have overpowered us. She ('A'isha) said that she thought the Messenger of Allah (may peace be upon him) had told (her) to throw dust in their mouths. Thereupon 'A'isha said: May Allah humble you! You did not do what Allah's Messenger (may peace be upon him) ordered you, nor did you stop annoying Allah's Messenger (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2035]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2035

This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters like one narrated by 'Abd al-'Aziz (with the change of these words):" You did not spare the Messenger of Allah (may peace be upon him) the botheration."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2036]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2036

Umm 'Atiyya reported: The Messenger of Allah (may peace be upon him) took a promise from us along with the oath of Allegiance that we would not lament. But only five among us fulfilled the promise (and they are) Umm Sulaim, and Umm al-'Ala', and the daughter of Abu Sabra the wife of Mu'adh, or daughter of Abu Sabra and wife of Mu'adh.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2037]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2037

Umm 'Atiyya reported that the Messenger of Allah (may peace be upon him) took pledge from us (including this promise) that we would not lament. Only five amongst us fulfilled the promise, and one of them (who fulfilled the promise) was Umm Sulaim.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2038]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2038

Hafsa narrated on the authority of Umm 'Atiyya that she said: When this verse was revealed:" When believing women came to thee giving thee a pledge that they will not associate aught with Allah, and will not disobey thee in good" (lx. 12), she (Umm Atiyya) said: In (this pledge) was also included wailing. I said: Messenger of Allah I except members of such a tribe who helped me (in lamentation) during pre-Islamic days, there is left no alternative for me, but that I should also help them. Upon this the Messenger of Allah (may peace be upon him) said: (Yes) but only in case of the members of such a tribe.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2039]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2039

Umm 'Atiyya reported: We were forbidden to follow the bier, but it was not made absolute on us.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2040]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2040

Umm 'Atiyya reported: We were refrained from following the bier, but it was not made absolute on us.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2041]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2041

Umm 'Atiyya reported: The Apostle of Allah (may peace be upon him) came to us when we were bathing his daughter, and he told us: Wash her with water and (with the leaves of) the lote tree, three or five times, or more than that if you think fit, and put camphor or something like camphor in the last washing; then inform me when you have finished. So when we had finished, we informed him, and he gave to us his (own) under-garment saying:" Put it next her body."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2042]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2042

Umm 'Atiyya reported: We braided her hair in three plaits.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2043]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2043

Umm 'Atiyya reported: One of the daughters of the Apostle of Allah (may peace be upon him) died. And in the hadith transmitted by Ibn 'Ulayya (the words are): The Messenger of Allah (may peace be upon him) came to us and we were washing his daughter. And in the hadith transmitted by Malik (the words are): There came in (our apartment) the Messenger of Allah (way peace be upon him) when his daughter died. The rest of the hadith is the same as narrated by Yazid b. Zurai' from Ayyub from Muhammad from Umm 'Atiyya.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2044]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2044

A hadith like this has been transmitted by Hafsa on the authority of Umm 'Atiyya with the exception (of these words that the Holy Prophet asked them to wash her dead body):" three times, five times, seven times, or more than that, if you deem fit:" Hafsa (further) said on the authority of Umm 'Atiyya: We braided (the hair) of her head in three plaits.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2045]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2045

Umm 'Atiyya reported: We washed her an odd number of times, i. e. three, five or seven times; and Umm 'Atiyya (further) said: We braided her hair in three plaits.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2046]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2046

Umm 'Atiyya reported: When Zainab the daughter of the Messenger of Allah (may peace be upon him) died, he said to us: Wash her odd number of times, i. e. three or five times, and put camphor or something-like camphor at the fifth time, and after you have washed her inform me. So we informed him and he gave us his under-garment, saying:" Put it next her body."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2047]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2047

Umm 'Atiyya reported: There came to us the Messenger of Allah (may peace be upon him) as we were washing one of his daughters. So he said: Wash her (dead body) an odd number of times, five times or more than that, the rest of the hadith is the same. She (further) said: We braided her hair in three plaits: (two) on the sides of her head and one on her forehead.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2048]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2048

Umm 'Atiyya reported that when the Messenger of Allah (may peace be upon him) asked her to wash his daughter, he told her to start from the right side, and with those parts of the body over which Wudu' is performed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2049]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2049

Umm 'Atiyya reported that the Messenger of Allah (may peace be upon him) said to them (the women) in regard to the washing of his daughter to start from the right side and with those parts of the body over which Wudu' is performed.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2050]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2050

Khabbab al-Aratt reported: We migrated with the Messenger of Allah (may peace be upon him) in the path of Allah seeking Allah's pleasure alone. Thus our reward was assured with Allah. And amongst us were those who spent life (in such a state of piety and austerity) that nothing consumed their reward. Mus'ab b. 'Umair was one of them. He was killed on the Day of Uhud, and nothing but a woollen cloak was found to shroud him. When we covered his head with it, his feet became uncovered, and when we covered his feet, his head was uncovered. Upon this the Messenger of Allah (may peace be upon him) said: Place it (this cloak) on the side of his head and cover his feet with grass. And there is one amongst us for whom the fruit is ripened and he enjoys it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2051]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2051

A hadith like this has been narrated by 'Uyaina on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2052]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2052

'A'isha reported that the Messenger of Allah (may peace be upon him) was shrouded in three cotton garments of white Yamani stuff from Sahul, among which was neither a shirt nor a turban; and so far as Hullah is concerned there was some doubt about it in the minds of people, that it was brought for him in order to shroud him with it, but it was abandoned, and he was shrouded in three cotton garments of white Yamani stuff from Sahul. Then 'Abdullah b. Abu Bakr got it and said: I would keep it in order to shroud myself in it. He then said: If Allah, the Exalted and Majestic, would have desired it for His Apostle, he would have been shrouded with it. So he sold it and gave its price in charity.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2053]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2053

'A'isha reported that the Messenger of Allah (may peace be upon him) was wrapped in a Yamani wrapper which belonged to 'Abdullah b Abu Bakr; then it was removed from him, and he was shrouded in three cotton sheets of white Yamani stuff from Sahul among which was neither a shirt nor a turban. 'Abdullah took up the Hullah and said: I would be shrouded in it, but then said: How is it that I should be shrouded in it in which the Messenger of Allah (may peace be upon him) was not shrouded! So he gave it in charity.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2054]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2054

This hadith is narrated on the authority of Hisham with the same chain of transmitters, but in the hadith narrated by him there is no mention of the story of 'Abdullah b. Abu Bakr.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2055]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2055

Abu Salama said: I asked 'A'isha with how many garments the Messenger of Allah (may peace be upon him) was shourded. She said: With three garments of Sahul.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2056]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2056

'A'isha reported: When the Messenger of Allah (may peace be upom him) died, he was covered with a Yamani wrapper.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2057]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2057

This hadith has been narrated by Zuhri with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2058]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2058

Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) one day in the course of his sermon made mention of a person among his Companions who had died and had been wrapped in a shroud not long (enough to cover his whole body) and was buried during the night. The Apostle of Allah (may peace be upon him) reprimanded (the audience) that a person was buried during the night (in a state that) funeral prayer could not be offered (over him by the Messenger of Allah). (And this is permissible only) when it becomes a dire necessity for a man. The Apostle of Allah (may peace be upon him) also said: When any one of you shrouds his brother, he should shroud him well.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2059]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2059

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Make haste at a funeral; if the dead person was good, it is a good state to which you are sending him on; but if he was otherwise it is an evil of which you are ridding yourselves.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2060]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2060

This hadith has been narrated by another chain of transmitters except with this variation (of words) that in the hadith narrated by Ma'mar (the words are):" I do not know whether the hadith is marfu'."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2061]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2061

Abu Huraira reported Allah's Messenger as saying: Hasten at a funeral, for if (the dead person) is good, you would (soon) bring him close to the good. And if it is otherwise, it is an evil of which you are ridding yourselves.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2062]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2062

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who attends the funeral till the prayer is offered for (the dead), for him is the reward of one qirat, and he who attends (and stays) till he is buried, for him is the reward of two qirats. It was said: What are the qirats? He said: They are equivalent to two huge mountains. Two other narrators added: Ibn 'Umar used to pray and then depart (without waiting for the burial of the dead). When the tradition of Abu Huraira reached him, he said:" We have lost many qirats."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2063]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2063

This hadith has been narrated on the authority of Abu Huraira through another chain of narrators up to these words:" two great mountains." No mention is made of what followed (these words) ; and in the hadith transmitted by 'Abd al- A'la (the words are):" till (the burial) is complete." In the hadith transmitted by 'Abd ar-Razzaq (the words are):" till he is placed in the grave."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2064]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2064

This hadith is narrated on thp authority of Abu Huraira through another chain of transmitters (with these words):" He who followed it (the bier) till he (the dead) is buried."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2065]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2065

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who offered prayer over the dead, but did not follow the bier, for him is the reward of one qirat, and he who followed it, for him is the reward of two qirats. It was asked what the qirats were. He said: The smaller amongst the two is equivalent to Uhud.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2066]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2066

Nafi' narrated that it was said to Ibn 'Umar that Abu Huraira reported to have heard Allah's Messenger (may peace be upon him) as saying: He who follows the bier, for him is the reward of one qirat. Ibn 'Umar said: Abu Huraira narrated it too often. So he sent (a messenger to) 'A'isha to ascertain (the fact). She ('A'isha) testified Abu Huraira. Ibn 'Umar said: We missed so many qirats.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2067]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2067

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who offers prayer for the dead, for him is (the reward of) one qirat; and he who follows the bier till it is placed in the grave, for him (is the reward of) two qirats. I (Abu Hazim, one of the narrators) raid: Abu Huraira, what is this qirat? He said: It is like the hill of Uhud.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2068]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2068

Dawud b. 'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father that while he was sitting along with 'Abdullah b. 'Umar, Khabbab, the owner of Maqsura, said: Ibn 'Umar, do you hear what Abu Huraira says that he heard the Messenger of Allah (may peace be upon him) say:" He who goes out with the bier when taken out from its residence and offers prayer for it and he then follows it till it is buried, he would have two qirats of reward, each qirat being equivalent to Uhud; and he who, after having offered prayer, (directly) came back would have his reward (as great) as Uhud"? Ibn 'Umar sent Khabbab to 'A'isha in order to ask her about the words of Abu Huraira (and also told him) to come back to him (Ibn 'Umar) and inform him what 'A'isha said. (In the meanwhile) Ibn 'Umar took up a handful of pebbles and turned them over in his hand till the messenger (Khabbab) came back to him and told (him) that 'A'isha testified (the statement of) Abu Huraira. Ibn 'Umar threw the pebbles he had in his hand on the ground and then said: We missed a large number of qirats.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2069]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2069

Thauban, the freed slave of the Messenger of Allah (may peace be upon him) reported Allah's Messenger (may peace be upon him) as saying: He who offered prayer for the dead, for him is the reward of one qirat, and he who attended its burial, he would have two qirats as his reward. And qirat is equivalent to Uhud.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2070]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2070

This hadith has been narrated by Qatada with the same chain of transmitters. And in the hadith transmitted by Sa'id and Hisham, (the words are):" The Apostle of Allah (may peace be upon him) was asked about qirat, and he said: It is equivalent to Uhud."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2071]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2071

'A'isha reported Allah's Apostle (may peace be upon him) saying: If a company of Muslims numbering one hundred pray over a dead person, all of them interceding for him, their intercession for him will be accepted.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2072]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2072

'Abdullah b. 'Abbas reported that his son died in Qudaid or 'Usfan. He said to Kuraib to see as to how many people had gathered there for his (funeral). He (Kuraib) said: So I went out and I informed him about the people who had gathered there. He (Ibn 'Abbas) said: Do you think they are forty? He (Kuraib) said: Yes. Ibn 'Abbas then said to them: Bring him (the dead body) out for I have heard Allah's Messenger (may peace be upon him) as saying: If any Muslim dies and forty men who associate nothing with Allah stand over his prayer (they offer prayer over him), Allah will accept them as intercessors for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2073]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2073

Anas b. Malik reported: There passed a bier (being carried by people) and it was lauded in good terms. Upon this the Apostle of Allah (may peace be upon him) said: It has become certain, it has become certain, it has become certain. And there passed a bier and it was condemned in bad words. Upon this the Apostle of Allah (may peace be upon him) said: It has become certain, it has become certain, it has become certain. 'Umar said: May my father and mother be ransom for you! There passed a bier and it was praised in good terms, and you said: It has become certain, it has become certain, it has become certain. And there passed a bier and it was condemned in bad words, and you said: It has become certain, it has become certain, it has become certain. Upon this the Messenger of Allah (way peace be upon him) said: He whom you praised in good terms, Paradise has become certain for him, and he whom you condemned in bad words, Hell has become certain for him. You are Allah's witnesses in the earth, you are Allah's witnesses in the earth, you are Allah's witnesses in the earth.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2074]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2074

This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2075]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2075

Qatada b. Rib'i reported Allah's Messenger (may peace be upon him) as saying: Whenever a bier passed before him, he said: He is the one to find relief and the one with (the departure of him) other will find relief. They said: Apostle of Allah, who is al-Mustarih and al-Mustarah? Upon this he said: The believing servant finds relief from the troubles of the world, and in the death of a wicked person, the people, towns, trees and animals find rellef.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2076]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2076

In the hadith transmitted by Yahya b. Sa'id on the authority of Qatada (the words are): (The believing servant) finds relief from the troubles of the world and its hardships and (gets into) the Mercy of Allah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2077]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2077

Abu Huraira reported that the Messenger of Allah (may peace be upon him) gave the people news of the death of Negus on the day he died, and he took them out to the place of prayer and observed four takbirs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2078]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2078

Abu Huraira reported: The Messenger of Allah (may peace be upon him) gave us the news of the death of Negus, the ruler of Abyssinia, on the day when he died, and he said (to us): Beg pardon for your brother. Ibn Shihab said that Sa'id b. Musayyib had told that Abu Huraira had narrated to him that the Messenger of Allah (may peace be upon him) drew them up in a row in a place of prayer, and offered prayer and recited four takbirs for him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2079]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2079

This hadith is narrated through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2080]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2080

Jabir b. 'Abdullah reported that the Messenger of Allah (may peace be upon him) offered prayer for Ashama, the Negus, and recited four takbirs.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2081]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2081

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: There died today the pious servant of Allah, Ashama. So he stood up and led us in (funeral prayer) over him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2082]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2082

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: A brother of yours has died, so stand up and offer prayer over him. So we stood up and drew ourselves up into two rows.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2083]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2083

'Imran b. Husain reported Allah's Messenger (may peace be upon him) as saying: A brother of yours has died; so stand up and offer prayer for him, i. e. Negus. And in the hadith transmitted by Zubair (the words are):" Your brother."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2084]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2084

Sha'bi reported that the Messenger of Allah (may peace be upon him) observed prayer over a grave after the dead was buried and he recited four takbirs over him. Shaibani said: I said to Sha'bi: Who narrated it to you? He said: An authentic one, 'Abdullah b. 'Abbas. This is the word of a hasan hadith. In the narration of Ibn Numair (the words are): The Messenger of Allah (may peace be upon him) went to the grave which had been newly prepared and prayed over it, and they also prayed who were behind him and he recited four takbirs. I said to 'Amir: Who narrated it to you? He said: An authentic one who saw him, i e. Ibn 'Abbas.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2085]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2085

This hadith has been narrated through another chain of transmitters, but in one of them (these words are found):" The Apostle of Allah (may peace be upon him) recited four takbirs."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2086]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2086

The hadith as narrated by Shaibani has been narrated through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2087]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2087

Anas reported that the Apostle of Allah (may peace be upon him) observed prayer on the grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2088]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2088

It is narrated on the authority of Abu Huraira that a dark-complexioned woman (or a youth) used to sweep the mosque. The Messenger of Allah (may peace be upon him) missed her (or him) and inquired about her (or him). The people told him that she (or he) had died. He asked why they did not inform him, and it appears as if they had treated her (or him) or her (or his) affairs as of little account. He (the Holy Prophet) said: Lead me to her (or his) gtave. They led him to that place and he said prayer over her (or him) and then remarked: Verily, these graves are full of darkness for their dwellers. Verily, the Mighty and Glorious Allah illuminates them for their occupants by reason of my prayer over them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2089]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2089

It is narrated on the authority of 'Abd al-Rahman b. Abu Laila that Zaid used to recite four takbirs on our funerals and he recited five takbirs on one funeral. I asked him the reason (for this variation), to which he replied: The Messenger of Allah (may peace be upon him) recited thus.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2090]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2090

It is narrated on the authority of 'Amir Ibn Rabi'a (may Allah be pleased with him) that the Prophet (may peace be upon him) said: Whenever you see a funeral procession, stand up for that until it moves away or is lowered on the ground.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2091]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2091

It is narrated on the authority of 'Amir ibn Rabi'a (may Allah be pleased with him) that the Holy Prophet (may peace be upon him) said: Should any one of you come across a funeral procession, and if he does not intend to accompany it, he must stand up until it passes by him or is placed upon the ground before it passes him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2092]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2092

It is reported on the authority of Ibn Juraij that the Holy Prophet (may peace be upon him) said: Should anyone amongst you see a bier he must stand up so long as it is within sight in case he does not intend to follow it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2093]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2093

It is narrated on the authority of Abu Sa'id al-Khudri that the Holy Prophet (may peace be upon him) said: When you follow a bier, do not sit until it is placed on the (ground).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2094]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2094

It is narrated on the authority of Abu Sa'id al-Khudri that the Holy Prophet (may peace be upon him) said: Whenever you come across a bier you should stand up, and he who follows it should not sit down till it is placed on the ground.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2095]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2095

It is narrated on the authority of Jabir ibn 'Abdullah: There passed a bier and the Holy Prophet (may peace be upon him) stood up for it and we also stood up along with him. We said: Messenger of Allah, that was the bier of a Jewess. Upon this he remarked: Verily, death is a matter of consternation, so whenever you come across a bier stand up.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2096]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2096

Ibn Juraij told me that Abu Zubair heard Jabir say that the Holy Prophet (may peace be upon him) kept standing for a bier until it disappeared.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2097]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2097

Again Abu Zubair heard Jabir say that the Holy Prophet (may peace be upon him) and his Companions kept standing for a bier of a Jew until it disappeared from sight.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2098]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2098

It is narrated on the authority of Ibn Abu Laila that while Qais b. Sa'd and Sahl b. Hunaif were both in Qadislyya a bier passed by them and they both stood up. They were told that it was the bier of one of the people of the land (non-Muslim). They said that a bier passed before the Holy Prophet (may peace be upon him) and he stood up. He was told that he (the dead man) was a Jew. Upon this he remarked: Was he not a human being or did he not have a soul? And in the hadith narrated by 'Amr b. Murra with the same chain of transmitters, (the words) are:" There passed a bier before us."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2099]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2099

It is narrated on the authority of Waqid: Nafi' b. Jubair saw me and we were standing for a bier, while he was sitting and waiting for the bier to be placed on the ground. He said to me: What makes you keep standing? I said: I am waiting that the bier may be placed on the ground (and I am doing that) on the hadith narrated to me by Abu Sa'id al-Khudri. Upon this Nafi' said: Verily, Mas'ud b. Hakam reported to me on the authority of Hadrat 'Ali b. Abu Talib that the Holy Prophet (may peace be upon him) stood up first (for a bier) and then sat down.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2100]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2100

Mas'ud b. al-Hakam al-Ansari informed Nafi' that he had heard Hadrat 'Ali (may Allah be pleased with him), son of Abu Talib, say about the biers: Verily, the Holy Prophet (may peace be upon him) used to stand first but later on kept sitting; but it is also narrated that Nafi' ibn Jubair saw Waqid b. 'Amr standing for a bier till it was placed down.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2101]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2101

This hadith has been narrated by Yahya b. Sa'id with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2102]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2102

It is narrated on the authority of Muhammad b. Munkadir that he said: I heard from Mas'ud b. al-Hakam who narrated it on the authority of Hadrat 'Ali that he said: We saw the Holy Prophet (may peace be upon him) stood up for a (bier) and we also stood up; he sat down and we too sat down.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2103]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2103

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2104]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2104

Jubair b. Nufair says: I heard it from 'Auf b. Malik that the Holy Prophet (may peace be upon him) said prayer on the dead body, and I remembered his prayer:" O Allah! forgive him, have mercy upon him, give him peace and absolve him. Receive him with honour and make his grave spacious; wash him with water, snow and hail. Cleanse him from faults as Thou wouldst cleanse a white garment from impurity. Requite him with an abode more excellent than his abode, with a family better than his family, and with a mate better than his mate. Admit him to the Garden, and protect him from the torment of the grave and the torment of the Fire." ('Auf bin Malik) said: I earnestly desired that I were this dead body.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2105]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2105

A hadith like this has been narrated through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2106]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2106

'Anas b. Malik said: I heard the Holy Prophet (may peace be upon him) say (while offering prayer on a dead body): O Allah! forgive him, have mercy upon him. Give him peace and absolve him. Receive him with honour and make his grave spacious. Wash him with water, snow and hail, cleanse him from faults as is cleaned a white garment from impurity. Requite him with an abode more excellent than his abode, with a family better than his family, and with a mate better than his mate, and save him from the trial of the grave and torment of Hell. 'Auf b. Malik said: I earnestly desired that I were the dead person to receive the prayer of the Messenger of Allah (may peace be upon him) as this dead body had (received).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2107]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2107

Samura b. Jundub said: I prayed behind the Messenger of Allah (may peace be upon him) and he prayed for a woman who had died in the state of delivery. He stood in front of her waist.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2108]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2108

This hadith has been narrated by Husain with the same chain of transmitters, but no mention is made of Umm Ka'b.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2109]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2109

Samura b. Jundub said: I was a young boy during the time of the Holy Prophet (may peace be upon him) and I retained in my mind (what I learnt from him), and nothing restrained me from speaking except the fact that there were persons far more advanced in age than I. Verily, I said prayer behind the Messenger of Allah (may peace be upon him) over a woman who had died in the state of delivery, and the Messenger of Allah (may peace be upon him) stood up to say prayer in front of the middle part of her body. And in the tradition narrated on the authority of Ibn Muthanna the words are:" (The Holy Prophet) stood in the middle part of her body for offering prayer for her."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2110]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2110

It is reported on the authority of Jabir ibn Samura that an unsaddled horse was brought to the Holy Prophet (may peace be upon him) and he rode on it when he returned after having offered the funeral prayer of Ibn Dahdah and we walked on foot around him.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2111]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2111

Jabir ibn Samura reported that the Holy Prophet (may peace be upon him) said (funeral) prayer on Ibn Dahdah: then an unsaddled horse was brought to him and a person hobbled it, and he (the Messenger of Allah) rode upon it and it bounded and we followed it and ran after it. One of the people said that the Holy Prophet (may peace be upon him) remarked: How many among hanging bunches in the Paradise are meant for Ibn Dahdah?


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2112]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2112

'Amir b. Sa'd b. Abu Waqqas told that Sa'd b. Abu Waqqas said during his illness of which he died:" Make a niche for me in the side of the grave and set up bricks over me as was done in case of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2113]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2113

Ibn 'Abbas said that a piece of red stuff was put in the grave of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2114]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2114

Thumama b. Shafayy reported: When we were with Fadala b. 'Ubaid in the country of the Romans at a place (known as) Rudis, a friend of ours died. Fadala b. 'Ubaid ordered to prepare a grave for him and then it was levelled; and then he said: I heard the Messenger of Allah (may peace be upon him) commanding (us) to level the grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2115]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2115

Abu'l-Hayyaj al-Asadi told that 'Ali (b. Abu Talib) said to him: Should I not send you on the same mission as Allah's Messenger (may peace be upon him) sent me? Do not leave an image without obliterating it, or a high grave without levelling It. This hadith has been reported by Habib with the same chain of transmitters and he said: (Do not leave) a picture without obliterating it.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2116]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2116

Jabir said: Allah's Messenger (may peace be upon him) forbade that the graves should be plastered or they be used as sitting places (for the people), or a building should be built over them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2117]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2117

A hadith like this has been transmitted on the authority of Jabir b. 'Abdullah.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2118]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2118

Jabir said that he was forbidden to build pucca graves.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2119]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2119

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is better that one of you should sit on live coats which would burn his clothing and come in contact with his skin than that he should sit on a grave.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2120]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2120

A hadith like this has been narrated by Suhail with the same chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2121]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2121

Abu Marthad al-Ghanawi reported Allah's Messenger (may peace be upon him) as saying: Do not sit on the graves and do not pray facing towards them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2122]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2122

Abu Marthad al-Ghanawi reported Allah's Messenger (may peace be upon him) as saying: Do not pray facing towards the graves, and do not sit on them.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2123]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2123

'Abbad b. 'Abdullah b. Zubair reported that 'A'isha ordered the bier of Sa'd b. Abu Waqqas to be brought into the mosque so that she should pray for him. The people disapproved this (act) of hers. She said: How soon the people have forgotten that the Messenger of Allah (may peace be upon him) offered not the funeral prayer of Suhail b al-Baida' but in a mosque.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2124]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2124

'Abbad b. 'Abdullah b. Zubair reported on the authority of 'A'isha that when Sa'd b. Abu Waqqas died, the wives of the Apostle of Allah (may peace be upon him) sent message to bring his bier into the mosque so that they should offer prayer for him. They (the participants of the funeral) did accordingly, and it was placed in front of their apartments and they offered prayer for him. It was brought out of the door (known as) Bab al-Jana'iz which was towards the side of Maqa'id, and the news reached them (the wives of the Holy Prophet) that the people bad criticised this (i. e. offering of funeral prayer in the mosque) saying that it was not desirable to take the bier inside the mosque. This was conveyed to 'A'isha. She said: How hastily the people criticise that about which they know little. They criticise us for carrying the bier in the mosque. The Messenger of Allah (may peace be upon him) offered not the funeral prayer of Suhail b. Baida' but in the innermost part of the mosque.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2125]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2125

Abu Salama b. 'Abd al-Rahman reported on the authority ot 'A'isha that when Sa'd b. Abu Waqqas died she said: Bring it (the bier) into the mosque so that I offer prayer for him. But, this act of hers was disapproved. She said: By Allah, the Messenger of Allah (may peace be upon him) offered prayer in the mosque for the two sons of Baida', viz, for Suhail and his brother.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2126]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2126

'A'isha reported (that whenever it was her turn for Allah's Messenger [may peace be upon him] to spend the night with her) he would go out towards the end of the night to al-Baqi' and say: Peace be upon you, abode of a people who are believers. What you were promised would come to you tomorrow, you receiving it after some delay; and God willing we shall join you. O Allah, grant forgiveness to the inhabitants of Baqi' al-Gharqad. Qutaiba did not mention his words:" would come to you".


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2127]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2127

Muhammad b. Qais said (to the people): Should I not narrate to you (a hadith of the Holy Prophet) on my authority and on the authority of my mother? We thought that he meant the mother who had given him birth. He (Muhammad b. Qais) then reported that it was 'A'isha who had narrated this: Should I not narrate to you about myself and about the Messenger of Allah (may peace be upon him)? We said: Yes. She said: When it was my turn for Allah's Messenger (may peace be upon him) to spend the night with me, he turned his side, put on his mantle and took off his shoes and placed them near his feet, and spread the corner of his shawl on his bed and then lay down till he thought that I had gone to sleep. He took hold of his mantle slowly and put on the shoes slowly, and opened the door and went out and then closed it lightly. I covered my head, put on my veil and tightened my waist wrapper, and then went out following his steps till he reached Baqi'. He stood there and he stood for a long time. He then lifted his hands three times, and then returned and I also returned. He hastened his steps and I also hastened my steps. He ran and I too ran. He came (to the house) and I also came (to the house). I, however, preceded him and I entered (the house), and as I lay down in the bed, he (the Holy Prophet) entered the (house), and said: Why is it, O 'A'isha, that you are out of breath? I said: There is nothing. He said: Tell me or the Subtle and the Aware would inform me. I said: Messenger of Allah, may my father and mother be ransom for you, and then I told him (the whole story). He said: Was it the darkness (of your shadow) that I saw in front of me? I said: Yes. He struck me on the chest which caused me pain, and then said: Did you think that Allah and His Apostle would deal unjustly with you? She said: Whatsoever the people conceal, Allah will know it. He said: Gabriel came to me when you saw me. He called me and he concealed it from you. I responded to his call, but I too concealed it from you (for he did not come to you), as you were not fully dressed. I thought that you had gone to sleep, and I did not like to awaken you, fearing that you may be frightened. He (Gabriel) said: Your Lord has commanded you to go to the inhabitants of Baqi' (to those lying in the graves) and beg pardon for them. I said: Messenger of Allah, how should I pray for them (How should I beg forgiveness for them)? He said: Say, Peace be upon the inhabitants of this city (graveyard) from among the Believers and the Muslims, and may Allah have mercy on those who have gone ahead of us, and those who come later on, and we shall, God willing, join you.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2128]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2128

Sulaiman b. Buraida narrated on the authority of his father that the Messenger of Allah (may peace be upon him) used to teach them when they went out to the graveyard. One of the narrators used to say this in the narration transmitted on the authority of Abu Bakr:" Peace be upon the inhabitants of the city (i. e. graveyard)." In the hadith transmitted by Zuhair (the words are):" Peace be upon you, the inhabitants of the city, among the believers, and Muslims, and God willing we shall join you. I beg of Allah peace for us and for you."


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2129]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2129

Abu Huraira reported Allah's Messenger, (may peace be upon him) as saying: I sought permission to beg forgiveness for my mother, but He did not grant it to me. I sought permission from Him to visit her grave, and He granted it (permission) to me.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2130]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2130

Abu Huraira reported: The Apostle of Allah (may peace be upon him) visited the grave of his mother and he wept, and moved others around him to tears, and said: I sought permission from my Lord to beg forgiveness for her but it was not granted to me, and I sought permission to visit her grave and it was granted to motel So visit the graves, for that makes you mindful of death.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2131]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2131

Ibn Buraida reported on the authority of his father that the Messenger of Allah (may peace be upon him) said: I forbade you to visit graves, but you may now visit them; I forbade you to eat the flesh of sacrificial animals after three days, but you way now keep it as along as you feel inclined; and I forbade you nabidh except in a water-skin, you may drink it from all kinds of water-skins, but you must not drink anything intoxicating.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2132]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2132

This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Prayers (Kitab Al-Salat) :: [4.2133]

The Book of Prayers (Kitab Al-Salat)

Muslim :: Book 4 : Hadith 2133

Jabir b. Samura reported: (The dead body) of a person who had killed himself with a broad-headed arrow was brought before the Apostle of Allah (may peace be upon him), but he did not offer prayers for him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2134]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2134

Abu Sa'id al-Khudri reported Allah's Messenger (way peace be upon him) as saying: No sadaqa (zakat) is payable on less than five wasqs of (dates or grains), on less than five camel-heads and on less than five uqiyas (of silver).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2135]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2135

A hadith like this has been narrated by 'Amr b. Yahya with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2136]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2136

'Umara reported: I heard Abd Sa'id al-Khudri as saying that he had heard Allah's Messenger (may peace be upon him) make (this) observation with a gesture of his five fingers, and then he narrated the hadith as transmitted by 'Uyaina (hadith 2134).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2137]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2137

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Sadaqa (zakat) is payable on less than five wasqs of (dates or grains), on less than five camel-heads, and on less than five uqiyas (of silver).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2138]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2138

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on less than five wasqs of dates or grains.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2139]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2139

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on the grains and dates till it (comes to the Weight) of five wasqs, or less than five heads of camels, or less than five uqiyas (of silver).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2140]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2140

A hadith like this has been narrated by Isma'il b. Umayya with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2141]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2141

A hadith like this has been narrated by Isma'il b. Umayya with the same chain of transmitters, but instead of the word dates, fruit has been used.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2142]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2142

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is payable on less than five fiqiyas of silver, and on less than five heads of camels, and less than five wasqs of dates.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2143]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2143

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: A tenth is payable on what is watered by rivers, or rains, and a twentieth on what is watered by camels.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2144]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2144

Abu Huraira reported Allah's Messsenger (may peace be upon him) as saying: No Sadaqa is due from a Muslim on his slave or horse.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2145]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2145

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No Sadaqa is due from a Muslim on his slave or horse.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2146]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2146

A hadith like this has been narrated by Abu Huraira through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2147]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2147

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no Sadaqa on a slave except Sadaqat-ul-Fitr.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2148]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2148

Abu Huraira reported that the Messenger of Allah (may peace be upon him) sent Umar for (collecting) Sadaqa (zakat), and it was said that Ibn Jamil, Khalid b. Walid and 'Abbas the uncle of the Messenger of Allah (may peace be upon him), refused (to pay it). Upon this the Messenger of Allah (may peace be upon him) said: Ibn Jamil is taking revenge but for this that he was destitute and Allah made him rich. As regards Khalid, you are unjust to Khalid, for be reserved his armours and weapons for the sake of Allah, and as for 'Abbas, I shall be responsible for it and an equal amount along with it. And he again said: 'Umar, bear this in mind, the uncle of a person is like his father.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2149]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2149

Ibn Umar said that Allah's Messenger (way peace be upon him) prescribed the payment of Zakat-ul-Fitr (on breaking the fast) of Ramadan for people, for every freeman, or slave, male and female among the Muslims-one sa' of dried dates, or one sa' of barley.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2150]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2150

Ibn 'Umar said that the Messenger of Allah (may peace be upon him) prescribed Zakat-ul-Fitr one sa' of dates or one sa' of barley for every slave or freeman, young or old.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2151]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2151

Ibn 'Umar said that the Apostle of Allah (may peace be upon him) prescribed the Sadaqa of Ramadan (Sadaqat-al-Fitr) one sa' of dates or one sa' of barley for every free man or a slave, male or female, and then the people equalised (one sa' of dates or barley) with half a sa' of wheat.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2152]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2152

Abdullah b. Umar reported that the Messenger of Allah (may peace be upon him) ordered the (payment of) Zakat-ul-Fitr one sa' of dates, or one sa' of barley. Ibn 'Umar ('Abdullah b. 'Umar) further said: The people equalised it (then) with two mudds of fine wheat.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2153]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2153

Ibn Umar reported that the Messenger of Allah (may peace be upon him) prescribed Zakat-ul-Fitr of Ramadan one sa' of dates or one sa' of barley for every individual among the Muslims (whether) free man or slave, male or female, young or old.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2154]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2154

Sad b. Abu Sarh heard Abu Sa'id al-Khudri as saying: We used to take out as the Zakat of Fitr one sa' of grain, or one sa' of barley or one sa' of dates, or one sa' of cheese or one sa' of raisins.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2155]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2155

Abd Sa'id al-Khudri reported: We, on behalf of every young or old, free man or slave (amongst us), used to take out during the lifetime of the Messenger of Allah (may peace be upon him) as the Zakat of Fitr one sa' of grain, or one sa' of cheese or one sa' of raisins. And we continued taking out these till Mu'awiya b. Abu Sufyan came to us for pilgrimage or 'Umra, and addressed the people on the pulpit and said to them: I see that two mudds of zakat out of the wheat (red) of Syria is equal to one sa' of dates. So the people accepted it. But Abu Sa'id said: I would continue to take out as I used to take out (before, i e. one sa') as long as I live.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2156]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2156

Sa'd b. Abu Sarh heard Abu Sa'id al-Khudri as saying: We, on behalf of young or old, free or slave, used to take out the Zakat of Fitr while the Messenger of Allah (may peace he upon him) was among us, in three kinds, one sa' of dates, one sa' of cheese, or one sa' of barley, and we continued to take that out till the time of Mu'awiya, for he saw that two mudds of wheat were equal to one sa' of dates. Abu Sa'id sald: I would continue to take that out as before (i e. one sa' of wheat).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2157]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2157

Abu Sa'id al Khudri reported: We used to take out the Zakat of Fitr in three kinds, cheese, dates and barley.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2158]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2158

Abu Sa'id al-Khudri reported that when Mu'awiya prescribed half a sa' of wheat equal to one sa' of dates, he (Abu Sa'id al-Khudri) objected to it, and said: I would take out (Sadaqat-ul-Fitr) but that which I used to bring forth during the lifetime of the Messenger of Allah (may peace be upon him) one sa' of dates, or one sa' of raisins, or one sa' of barley, or one sa' of cheese.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2159]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2159

Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) ordered that the Sadaqat-ul-Fitr should be paid before the people go out for prayer.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2160]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2160

Abdullah b 'Umar reported that the Messenger of Allah (may peace be upon him) ordered the payment of Sadaqat-ul-Fitr before people go out for prayer.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2161]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2161

Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: If any owner of gold or silver does not pay what is due on him, when the Day of Resurrection would come, plates of fire would be beaten out for him; these would then be heated in the fire of Hell and his sides, his forehead and his back would be cauterized with them. Whenever these cool down, (the process is) repeated during a day the extent of which would be fifty thousand years, until judgment is pronounced among servants, and he sees whether his path is to take him to Paradise or to Hell. It was said: Messenger of Allah, what about the camel? He (the Holy Prophet) said: If any owner of the camel does not pay what is due on him, and of his due in that (camel) is (also) to milk it on the day when it comes down to water. When the Day of Resurrection comes a soft sandy plain would be set for him, as extensive as possible, (he will find) that not a single young one is missing, and they will trample him with their hoofs and bite him with their mouths. As often as the first of them passes him, the last of them would be made to return during a day the extent of which would be fifty thousand years, until judgment is pronounced among servants and he sees whether his path is to take him to Paradise or to Hell. It was (again) said: Messenger of Allah, what about cows (cattle) and sheep? He said: It any owner of the cattle and sheep does not pay what is due on them, when the Day of Resurrection comes a soft sandy plain would be spread for them, he will find none of them missing, with twisted horns, without horns or with a broken horn, and they will gore him with their horns and trample him with their hoofs. As often as the first of them passes him the last of them would be made to return to him during a day the extent of which would be fifty thousand years, until judgment would be pronounced among the servants. And he would be shown his path-path leading him to Paradise or to Hell. It was said: Messenger of Allah, what about the horse? Upon this he said: The horses are of three types. To one than (these are) a burden, and to another man (these are) a covering, and still to another man (these are) a source of reward. The one for whom these are a burden is the person who rears them in order to show off, for vainglory and for opposing the Muslims; so they are a burden for him. The one for whom these are a covering is the person who rears them for the sake of Allah but does not forget the right of Allah concerning their backs and their necks, and so they are a covering for him. As for those which bring reward (these refer to) the person who rears them for the sake of Allah to be used for Muslims and he puts them in meadow and field. And whatever thing do these eat from that meadow and field would be recorded on his behalf as good deeds, as would also the amount of their dung and urine. And these would not break their halter and prance a course or two without having got recorded the amount of their hoof marks and their dung as a good deed on his behalf (on behalf of their owner). And their master does not bring them past a river from which they drink, though he did not intend to quench their thirst, but Allah would record for him the amount of what they drink on his behalf as deeds. It was said: Messenger of Allah, what about the asses?, Upon this he said: Nothing has been revealed to me in regard to the asses (in particular) except this one verse of a comprehensive nature:" He who does an atom's weight of good will see it, and he who does an atom's weight of evil will see it" (xcix. 7)


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2162]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2162

This hadith has been narrated by Zaid b. Aslam with the same chain of transmitters except that he said:" None among the owners of camels who does not pay their due," but did not say" their due (Zakat) out of them." and he make a mention:" He did not miss a single young one out of them." and he said:" Their sides. their foreheads and their backs would be cauterised."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2163]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2163

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No owner of the treasure who does not pay Zakat (would be spared) but (his hoards) would be heated in the Fire of Hell and these would be made into plates and with these his sides, his forehead would be cauterised till Allah would pronounce judgment among His servants during a day, the extent of which would be fifty thousand years. He would then see his path, leading either to Paradise or to Hell. And no owner of the camels who does not pay Zakat (would be spared) but a soft sandy plain would be set for him and they (the camels) would be made to pass over him till the last of them would be made to return till Allah would pronounce judgment among His servants during a day the extent of which would be fifty thousand years. He would then see his path leading him to Paradise or leading him to Hell. And no owner of the (cattle and) goats who does not pay Zakat (would be spared) but a soft sandy plain would be set for him, he would find none of them missing, with twisted horns, without horns, or with broken horns, and they will gore him with their horns and trample him with their hoofs and they would be made to pass over him till the last of them would be made to return till Allah would pronounce judgment among His servants, during a day the extent of which would be fdty thousand years, and he would see the paths leading to Paradise or to Hell. Suhail said: I do not know whether he made mention of the cows. They said: Messenger of Allah (may peace be upon him), what about the horses? He said: The horses have goodness in their foreheads (or he said) or goodness is ingrained in the foreheads of the horses (Suhail said: I am in doubt as to what was actually said) up till the Day of judgement. The horses are of three kinds. They are a source of reward to a person, they are a covering to a person, and they are a burden to a person. As for those which bring reward is that a person would get reward who rears them for the sake of Allah and trains them for Him, and nothing disappears in their stomachs but Allah would record for him a good deed. And if they were to graze in the meadow, they would eat nothing but Allah would record for him a reward. And if they were to drink water from the canal, with every drop that, would disappear in their stomachs there would be reward (for the owner). He went on describing till a reward was mentioned for their urine and dung. And if they pranced a course or two, there would be recorded a reward for every pace that they covered. As for one for whom they are a covering, he is the man who rears them for honour and dignity but does not forget the right of their backs and their stomachs, in plenty and adversity, As regards one for whom they are a burden, he is that who rears them for vainglory and showing off to the people; for him they are, the burden. They said: Messenger of Allah, what about asses? He said: Allah has not revealed to me anything in regards to it except this one comprehensive verse:" He who does an atom's weight of good will see it, and he who does an atom's weight of evil will see it" (xcix. 7).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2164]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2164

This hadith has been narrated by Suhail b. Abu Salih with the same chain of transmitters, and he said he substituted the word aqsa' with 'adba' and said:" his side and his back," but he made no mention of his forehead.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2165]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2165

This hadith has been narrated by Abu Huraira through another chain of transmitters: The Messenger of Allah (may peace be upon him) said:" When a person does not pay what is due to Allah or Sadaqa of his camels...." The rest of the hadith is the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2166]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2166

Jabir b. 'Abdullah al-Ansari reported Allah's Messenger (may peace be upon him) as saying: The owner of a camel who does not pay what is due on it (would be punished in this way) that on the Day of Resurrection many more (along with his camel) would come and the owner would be made to sit on a soft sandy ground and they would trample him with their feet and hooves. And no owner of the cattle who does not pay what is due on them (would be spared the punishment) but on the Day of Resurrection, many more would come and he (the owner) would be made to sit on the soft sandy ground and would be gored by their horns and trampled under their feet. And no owner of the goats and sheep who does not pay what is due on them (would be spared of punishment) but many more would come on the Day of Resurrection and he (the owner) would be made to sit on a soft sandy ground and they would gore him with their horns and trample him under their hooves. And there would be more (among this flock of sheep and goat) without horns or with broken horns. And no owner of the treasure who does not pay its due but his treasure would come on the Day of Resurrection like a bald snake and would pursue him with its mouth open, and when it would come near he would run away from it, and he would be called thus:" Take your treasure which you concealed, for I do not need it." When he would find no way out he would put his hand in its mouth and it would gnaw it like a he-camel. Abu Zubair said: We heard Ubaid b. Umair saying this. We then asked Jabir b. 'Abdullah about this. And he also said like Ubaid b. Umair, Abu Zubair said: I heard 'Ubaid b. 'Umair saying: A man said: Messenger of Allah, what is due on camels? He said: Milking them near water, and lending of bucket (used for drawing water from it), or lending its male for mating with a she-camel and providing it as a ride for the sake of Allah.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2167]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2167

Jabir b. Abdullah reported the Apostle of Allah (may peace be upon him) as saying: No owner of camels or cattle or flock of sheep or goats who does not pay his due (would be spared punishment) but would be made to sit on the Day of Resurrection on a soft sandy ground and the hoofed animals would trample him with their hoofs and gore him with their horns. And none of them on that day would be without horns, or with broken horns. We said: Messenger of. Allab, but what is due on them? He said: Lending of the male (for use) and lending of the bucket (used for drawing water for them) and for mating and milking them near water and providing them as a ride for the sake of Allah. And no owner of the property who does not pay Zakat (would be spared punishment) but it (his property) would turn into a bald snake and would follow its owner wherever he would go, and he would run away from it, and it would be said to him: That is your property about which you were stingy. And when he would find no other way out he would thrust his hand in its mouth and it would gnaw it like a male camel.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2168]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2168

Jabir b. 'Abdullah reported: There came people from among the Bedouins to the Messenger of Allah (may peace be upon him) and said: Collectors of Sadaqa come to us and treat us unjustly. Upon this the Messenger of Allah (may peace be upon him) said: Please your collectors. Jarir said: Ever since I heard it from the Messenger of Allah (may peace be upon him) no collector had departed but was pleased with me.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2169]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2169

This hadith has been narrated by Muhammad b. Isma'il with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2170]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2170

Abu Dharr reported: I went to the Apostle of Allah (may peace be upon him) and he was sitting under the shade of the Ka'ba. As he saw me he said: By the Lord of the Ka'ba, they are the losers. I came there till I sat and I could not stay (longer) and (then) stood up. I said: Messenger of Allah, let my father, be ransom for you, who are they (the losers)? He said: They are those having a huge amount of wealth except so and so and (those who spend their wealth generously on them whom they find in front of them, behind them and on their right side and on their left side) and they are a few. And no owner of camels, or cattle or goat and sheep, who does not pay Zakat (would be spared punishment) but these (camels, cattle, goats and sheep) would come on the Day of Resurrection wearing more flesh and would gore him with their horns and trample them with their hooves. And when the last one would pass away, the first one would return (to trample him) till judgment would be pronounced among people.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2171]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2171

Abu Dbarr reported: I went to the Apostle of Allah (may peace be upon him) and he was sitting under the shade of the Ka'ba, and the rest of the hadith it the same but for this that he (the Holy Prophet) said:" By Allah, in Whose hand is my life, no person on earth who dies and leaves behind camels, or cattle or goat and sheep, and does not pay Zakat (would be spared the punishment)."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2172]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2172

Abu Huraira reported that the Prophet (may peace be upon him) said: Nothing is more delighting to me than this that Uhud should be of gold for me, and no dinar is left with me out of it before three nights pass except a dinar which I would set aside for the repayment of debt upon me.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2173]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2173

Abu Huraira reported the same from the Prophet (may peace be upon him).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2174]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2174

Abu Dharr reported: I walked with the Messenger of Allah (may peace be upon him) on the stony ground of Medina in the afternoon and we were looking at Uhud. The Messenger of Allah (way peace by upon him) said: Abu Dharr! I said: Messenger of Allah, I am here at thy beck and call. He said: What I desire is that Uhud be gold with me and three nights should pass and there is left with me any dinar but one coin which I would keep to pay debt. (I love) to spend it among the servants of Allah like this and he pointed in front of him, and on his right side and on his left side. We then proceeded on and he said: Abu Dharr. I said: At thy beck and call, Messenger of Allah. He (the Holy Prophet) said: The rich would be poor on the Day of Resurrection, but he who spent like this and like this and like this, and he pointed as at the first time. We again went on when he said. Abu Dharr, stay where you are till I come back to you. He (the Holy Prophet) then moved on till he disappeared from my sight He (Abu Dharr) said: I heard a sound and I heard a noise. I said (to myself): The Messenger of Allah (may peace be upon him) might have met (mishap or an enemy). I wished to follow him but I remembered his command for not departing till he would come back. So I waited for him, and when he came I made a mention of what I heard. He said: it was Gabriel, who came to me and said:" He who dies among your Ummah without associating Anything with Allah would enter Paradise. I said: Even if he committed fornication or theft? He said: Even if he committed fornication or theft.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2175]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2175

Abu Dharr reported: I went out one night (and found) the Messenger of Allah (may peace be upon him) walking all alone. There was no man with him. I thought that he did not like anyone walking along with him. So I began to walk in the light of the moon. He, however turned his attention to me and saw me and said: Who is this? I said: It is Abu Dharr. Let Allah make me as ransom for you. He said: Abu Dharr, come on. He (Abu Dharr) said: So I walked along with him for some time and he said: The wealthy persons would have little (reward) on the Day of Resurrection, except upon whom Allah conferred goodness (wealth). He dispensed it to his right, left, in front of him and at his back (just as the wind diffuses fragrance) and did good with it (riches). I went along with him for some time when He said: Sit here. And he made me sit at a safe place and there were stones around it, and he said to me: Sit here till I come to you. He went away on the stony ground till I could not see him. He stayed away from me, and he prolonged his stay. Then I heard him as he came back and he was saying: Even if he committed theft and even if he committed fornication. When he came I could not help asking him: Apostle of Allah, let Allah make me ransom for you, whom were you speaking on the stony ground? I heard nobody responding to you. He (the Holy Prophet) said: It was Gabriel who met me by the side of the stony ground and said: Give glad tidings to your Ummah that he who died without associating ought with Allah would go into Paradise. I said: Gabriel, even if he committed theft and fornication? He said: Yes. I said: Even it he committed theft and fornication? He said: Yes, I again said: Even if he committed theft and fornication? He said: Yes, even if he drank wine.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2176]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2176

Ahnaf b. Qais reported: I came to Medina and when I was in the company of the grandees of Quraish a man with a crude body and an uncouth face wearing coarse clothes came there. He stood up before them and said: Give glad tidings to those whom who amass riches of the stones which would be heated in the Fire of Hell, and would be placed at the tick of the chest till it would project from the shoulder bone and would he put on the shoulder bone till it would project from the tick of his chest, and it (this stone) would continue passing and repassing (from one side to the other). He (the narrator) said: Then people hung their heads and I saw none among them giving any answer. He then returned and I followed him till he sat near a pillar. I said: I find that these (people) disliked what you said to them and they do not understand anything. My friend Abu'l-Qasim (Muhammad) (may peace he upon him) called me and I responded to him, and he said: Do you see Uhud? I saw the sun (shining) on me and I thought that he would send me on an errand for him. So I said: I see it. Upon this he said: Nothing would delight me more than this that I should have gold like it (equal to the bulk of Uhud), and I should spend it all except three dinars. (How sad it is) that they hoard worldly riches, and they know nothing. I said: What about you and your brothers Quraish? You do not go to thein for any need and do not accept anything from them. He said: By Allah, I neither beg anything from them (from worldly goods), nor do I ask them anything about religion till I meet my Allah and His Messenger.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2177]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2177

Ahnaf b. Qais reported: While I was in the company of the (elites) of Quraiah, Abu Dharr came there and he was saying: Give glad tidings to the hoarders of riches that their backs would be branded (so deeply) that (the hot Iron) would come out of their sides, and when the backs of their necks would be branded, it would come out of their foreheads. He (Abu Dharr) then went away and sat down. I asked who he was. They said: He is Abu Dharr. I went to him and said to him: What is this that I heard from you which you were saying before? He said: I said nothing but only that which I heard from their Prophet (may peace be upon him). I again said: What do you say about this gift? He said: Take it, for today it is a help. But when it becomes a price for your religion, then abandon it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2178]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2178

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Most Blessed and High, said: O son of Adam, spend. I will spend on you. The right hand of Allah is full and overflowing and in nothing would diminish it, by overspending day and night.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2179]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2179

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah said to him:" Spend, I will bestow upon you." And the Messenger of Allah (may peace be upon him) said: The right hand of Allah is full and spending (the riches) liberally during day and night will not diminish (the resources of Allah). Don't you see what (an enormous amount of resources) He has spent since He created the heaven and the earth, and what is in His right hand has not decreased? His Throne is upon the water. And in His other hand is death, and He elevates and degrades (whom He likes).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2180]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2180

Thauban reported Allah's Messenger (may peace be upon him) as saying: The most excellent dinar is one that a person spends on his family, and the dinar which he spends on his animal in Allah's path, and the dinar he spends on his companions in Allah's path. Abu Qilaba (one of the narrators) said: He (the narrator) started with family, and then Abu Qilaba said: Who is the person with greater reward than a person who spends on young members of his family (and thus) preserves (saves them from want) (and by virtue of which) Allah brings profit for them and makes them rich.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2181]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2181

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Of the dinar you spend as a contribution in Allah's path, or to set free a slave, or as a sadaqa given to a needy, or to support your family, the one yielding the greatest reward is that which you spent on your family.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2182]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2182

Khaithama reported: While we were sitting in the company of 'Abdullah b. 'Umar there came in his steward. He (Ibn 'Umar) said: Have you supplied the provision to the slaves? He said: No. Upon this he said: Go and give (the provision) to them, for the Messenger of Allah (may peace be upon him) has said: This sin is enough for a man that he withholds the subsistence from one whose master he is.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2183]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2183

Jabir reported: A person from the Banu 'Udhra set a slave free after his death. This news reached the Messenger of Allah (may peace be upon hhn). Upon this he said: Have you any property besides it? He said: No. Upon this he said: Who would buy (this slave) from me? Nulaim b. Abdullah bought it for eight hundred dirhams and (this amount was) brought to the Messenger of Allah (may peace be upon him) who returned it to him (the owner), and then said: Start with your own self and spend it on yourself, and if anything is left, it should be spent on your family, and if anything is left (after meeting the needs of the family) it should be spent on relatives, and if anything is left from the family, it should be spent like this, like this. And he was saying: In front of you, on your right and on your left.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2184]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2184

Jabir reported that a person among the Ansar who was called Abu Madhkur granted posthumous freedom to his slave who was called Ya'qub. The rest of the hadith is the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2185]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2185

Anas b. Malik is reported as saying: Abu Talha was the one among the Ansar of Medina who possessed the largest property and among his property he valued most was his garden known as Bairaha' which was opposite the mosque, and the Messenger of Allah (may peace be upon him) often visited it and he drank of its sweet water. When this verse was revealed:" You will never attain righteousness till you give freely of what you Have" (iii. 91), Abu Talha got up and, going to Allah's Messenger (may peace be upon him), said: Allah says in His Book:" You will never attain righteousness till you give freely of what you love," and the dearest of my property is Bairaha' so I give it as Sadaqa to God from Whom I hope for reward for it and the treasure with Allah; so spend it, Messenger of Allah, on whatever purpose you deem it proper. The Messenger of Allah (may peace be upon him) said: Bravo I that is profit earning property. I have heard what you have said, but I think you should spend it on your nearest relatives. So Abu Talha distributed it among the neatest relatives and his cousins on his father's side.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2186]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2186

Anas reported that when this verse was tevealed:" You will not attain righteousness till you give freely of what you love," Abu Talha said: I see that our Lord has demanded from us out of our property; so I make you a witness, Messenger of Allah. that I give my land known as Bairaha' for the sake of Allah. Upon this the Messenger of Allah (may peace be upon him) said: Give that to your relatives. So he gave it to Hassan b. Thabit and Ubayy b. Ka'b.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2187]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2187

Maimuna bint Harith reported that she set free a slave-girl during the lifetime of the Messenger of Allah (may peace be upon him) and she made a mention of that to the Messenger of Allah (may peace be upon him) and he said: Had you gives her to your maternal uncles, you would have a greater reward.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2188]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2188

Zainab, the wife of 'Abdullah (b. Mas'ud ), reported that the Messenger of Allah (may peace be upon him) said: 0 women, give sadaqa even though it be some of your jewellery. She returned to 'Abdullah and said: You are a person with empty hands, whereas the Messenger of Allah (may peace be upon him) has commanded us to give sadaqa, so better go to him and ask and if this will suffice for me; otherwise I shall give it to someone else. 'Abdullah said to me (his wife): You better go yourself. So I went and there was another woman of the Ansar at the door of the Messenger of Allah (may peace be upon him) having the same porpose as I had. Now Allah's Messenger (may peace be upon him) was invested with awe (so we did not like to knock). Then Bilal came out and we said to him: Go to the Messenger of Allah (may peace be upon him) and inform him that there are two women at the door asking him whether it will serve them to give sadaqa to their spouses and to orphans who are under their charge, but do not inform him who we are. Bilal went to the Messenger of Allah (may peace be upon him) and asked him (what these women had instructed him to ask). The Messenger of Allah (may peace be upon him) asked him who these women were. He (Bilal) said: They are women from Ansar and Zainab. Upon this the Messenger of Allah (may peace be upon him) said: Which of the Zainabs? He said: The wife of 'Abdullah. The Messenger of Allah (may peace be upon him) said: There are two rewards for them, the reward of kinship and the reward of Sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2189]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2189

A hadith like this has been narrated on the authority of Zainab the wife of 'Abdullah, and she said: I was in the mosque and the Prophet of Allah (may peace be upon him) saw me and said: Give Sadaqa even though it is out of your jewellery. The rest of the hadith is the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2190]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2190

Umm Salama said: I asked the Messenger of Allah (may peace be upon him) whether there is a reward for me if I spend oh Abu Salama's sons, and I am not going to abandon them in this state (of helplessness) for they are my sons. He (the Holy Prophet) said: Yes. For you is the reward for what you spend on them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2191]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2191

This hadith has been narrated by Ibn 'Urwa with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2192]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2192

Abu Mas'ud reported Allah's Messenger (way peace be upon him) as saying: When a Muslim spends on his family seeking reward for it from Allah, it counts for him as sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2193]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2193

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2194]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2194

Asma' daughter of Abu Bakr reported: I said: Messenger of Allah, my mother, who is inclined or scared has come to me. Should I (even An her position of being opposed to Islam) treat her well? He said: Yes.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2195]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2195

Asma' bint Abu Bakr reported: My mother who was a polytheist came to me when he (the Holy Prophet) entered into treaty with, the Quraish (of Mecca). I inquired from the Messenger of Allah (may peace be upon him) saying: Messenger of Allah, there has come to me my mother and she is inclined; should I (in this state of her mind) show her kindness? He said: Yes, treat her kindly.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2196]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2196

'A'isha said that a person came to the Apostle of Allah (may peace be upon him) and said: My mother died suddenly without having made any will. I think she would have definitely given Sadaqa if she had been able to speak. Would she have a reward if I gave Sadaqa on her behalf? He (the Holy Prophet) said: Yes. This hadith has been narrated on the authority of Hisham with the same chain of transmitters. And in the hadith transmitted by Abu Usama the words are:" She did not make any will," as it has been reported by Ibn Bishr, but it was not reported by the rest of the narrators.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2197]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2197

Hudhaifa and Abu Shaiba reported Allah's Messenger (may peace be upon him) as saying: Every act of goodness is sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2198]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2198

Abu Dharr reported: some of the people from among the Companions of the Apostle of Allah (may peace be upon him) said to him: Messenger of Allah, the rich have taken away (air the) reward. They observe prayer as we do; they keep the fasts as we keep, and tray give Sadaqa out of their surplus riches. Upon this he (the Holy Prophet) said: Has Allah not prescribed for you (a course) by following which you can (also) do sadaqa? In every declaration of the glorification of Allah (i. e. saying Subhan Allah) there is a Sadaqa, and every Takbir (i. e. saying Allah-O-Akbar) is a sadaqa, and every praise of His (saying al-Hamdu Lillah) is a Sadaqa and every declaration that He is One (La illha ill-Allah) is a sadaqa, and enjoining of good is a sadaqa, and forbidding of that which is evil is a Sadaqa, and in man's sexual Intercourse (with his wife, ) there is a Sadaqa. They (the Companions) said: Messenger of Allah, is there reward for him who satisfies his sexual passion among us? He said: Tell me, if he were to devote it to something forbidden, would it not be a sin on his part? Similarly, if he were to devote it to something lawful, he should have a reward.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2199]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2199

'A'isha reported Allah's Messenger (may peace be upon him) as saying: Every one of the children of Adam has been created with three hundred and sixty joints; so he who declares the Glory of Allah, praises Allah, declares Allah to be One, Glorifies Allah, and seeks forgiveness from Allah, and removes stone, or thorn, or bone from people's path, and enjoins what is good and forbids from evil, to the number of those three hundred and sixty-four, will walk that day haviing removed himself from Hell.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2200]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2200

This hadith has been narrated on the authority of Zaid with the same chain of transmitters except with (a slight) change of words (i. e. he [the Holy Prophet]) said: Or he enjoined what is good,... and said: He enters the evening [ie. he walks till eveningl.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2201]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2201

This hadith has been narrated by 'A'isha through anothr chain of transmitters in which she reported Allah's Messenger (may peace be ulon him) as saying:" Every man is created" ; the rest of the hadith is the same and he said:" He walks on that day."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2202]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2202

Sa'id b. Abu Burda reported on the authority of his grandfather that the Apostle of Allah (may peace be upon him) said: Giving of Sadaqa is essential for every Muslim. It was said (to him): What do you say of him who does not find (the means) to do so? He said: Let him work with both his hands, thus doing benefit to himself and give Sadaqa. It was said to him: What about him who does not have (the means) to do so? He said: Then let him assist the needy, the aggrieved. It was said: What do you say of one who cannot even do this? He said: Then he should enjoin what is reputable or what is good. He said: What about him if he cannot do that? He (the Holy Prophet) said: He should then abstain from evil, for verify that is Sadaqa on his behalf.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2203]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2203

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2204]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2204

Hammam b. Munabbih reported that-this is out of (those ahadith) which Abu Huraira narrated to us from Muhammad, the Messenger of Allah (may peace be upon him). And he while making a mention of ahadith reported from Allah's Messenger (may peace be upon him) said this: Sadaqa is due on every joint of a person, every day the sun rises. Administering of justice between two men is also a Sadaqa. And assisting a man to ride upon his beast, or helping him load his luggage upon it, is a Sadaqa; and a good word is a Sadaqa; and every step that you take towards prayer is a Sadaqa, and removing of harmful things from the pathway is a Sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2205]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2205

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is never a day wherein servants (of God) get up at morn, but are not visited by two angels. One of them says: 0 Allah, give him more who spends (for the sake of Allah), and the other says: 0 Allah, bring destruction to one who withholds.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2206]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2206

Haritha b. Wahb reported Allah's Messenger (may peace be upon him) as saying: Give Sadaqa for a time is about to come when a person would walk with alms and the one whom it is to be given would say: Had you brought it yesterday, I would have accepted it. For the present I do not need it. (And the giver of Sadaqa) I would not find anyone to accept it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2207]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2207

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: There would come a time for the people when a person would roam about with Sadaqa of gold, but he would find no one to accept it from him. And a man would be seen followed by forty women seeking refuge with him on account of the scarcity of males and abundance of females."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2208]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2208

Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: The Last Hour will not come before wealth becomes abundant and overflowing, so much so that a man takes Zakat out of his property and cannot find anyone to accept it from him and till the land of Arabia becomes meadows and rivers.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2209]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2209

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour will not come till wealth is abundant and overflowing, so much so that the owner of the property will think as to who will accept Sadaqa from him, and a person would be called to accept Sadaqa and he would say: I do not need it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2210]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2210

Abu Huraira reported Allah's Messenaer (may peace be upon him) as saying: The earth will vomit long pieces of its liver like columns of gold and silver, and the murderer will come and say: It was for this that I committed murder. The breaker of family ties will come and say: It was for this that I broke the family ties; and the thief will come and say: It is for this that my hands were cut off. They will then leave it and will not take anything out of it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2211]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2211

Abu Huraira reported Allah's Messenger (tray peace be upon him) as saying: If anyone gives as Sadaqa the equivalent of a date from that (earning) earned honestly, for Allah accepts that which is lawful, the Lord would accept it with His Right Hand, and even if it is a date, it would foster in the Hand of the lord, as one of you fosters his colt, till it becomes bigger than a mountain.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2212]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2212

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No one gives Sadaqa of a date out of his honest earning, but Allah accepts it with His Right Hand, and then fosters it as one of you fosters the colt or a young she-camel, till it becomes like a mountain or even greater.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2213]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2213

This hadith has been narrated through another chain of transmitters with a change of words. In the hadith transmitted Rauh (the words are):" Out of the honest earning and its spending at what is its (due) right" ; and in the hadith transmitted by Sulaiman (the words are):" And its spending at its proper place."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2214]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2214

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 people, Allah is Good and He therefore, accepts only that which is good. And Allah commanded the believers as He commanded the Messengers by saying:" O Messengers, eat of the good things, and do good deeds; verily I am aware of what you do" (xxiii. 51). And He said: ' 0 those who believe, eat of the good things that We gave you" (ii. 172) He then made a mention of a person who travels widely, his hair dishevelled and covered with dust. He lifts his hand towards the sky (and thus makes the supplication):" O Lord,0 Lord," whereas his diet is unlawful, his drink is unlawful, and his clothes are unlawful and his nourishment is unlawful. How can then his supplication be accepted?


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2215]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2215

'Adi b. Hatim reported that he heard Allah's Messenger (way peace be upon him) as saying: He who among you can protect himself against Fire, he should do so, even if it should be with half a date.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2216]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2216

'Adi b. Hatim reported Allah's Messenger (may peace be upon him) as saying: Allah will speak with everyone amongst you without any interpreter between them. He (the man) would see towards his right and would not find anything but (the deeds) which he had done before, and he would see towards the left and would not find anything but (the deeds) which he had done before. He would see in front of him and would find nothing but Fire just before his face. So protect (yourselves) against Fire even if it is with the help of half a date. A hadith like this has been transmitted by Khaithama and addition has been made in this of (these words) ;" Even if it is with a good word."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2217]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2217

'Adi b. Hatim reported that the Messenger of Allah (may peace be upon him) made a mention of Fire. He turned his face aside and diverted his attention and then said: Guard (yourselves) against Fire. He turned his face and diverted his attention till we thought as if he were (actually seeing it and then said: Protect yourselves against Fire even if it is with half a date, and he who does not find it, (he should do so) with pleasant words. Abu Kuraib did not mention the word: (as if).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2218]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2218

Adi b. Hatim reported that the Messenger of Allah (may peace be upon him) made a mention of the Fire and sought refuge (with Allah against it). He turned aside his face three times and then said: Protect yourselves against Fire even if with half a date. But if you fail to find it (then protect yourselves against Fire) with the help of a pleasant word).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2219]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2219

Mundhir b. Jarir reported on the authority of his father: While we were in the company of the Messenger of Allah (may peace be upon him) in the early hours of the morning, some people came there (who) were barefooted, naked, wearing striped woollen clothes, or cloaks, with their swords hung (around their necks). Most of them, nay, all of them, belonged to the tribe of Mudar. The colour of the face of the Messenger of Allah (may peace be upon him) underwent a change when he saw them in poverty. He then entered (his house) and came out and commanded Bilal (to pronounce Adhan). He pronounced Adhan and Iqima, and he (the Holy Prophet) observed prayer (along with his Companion) and then addressed (them reciting verses of the Holy Qur'an): '" 0 people, fear your Lord, Who created you from a single being" to the end of the verse," Allah is ever a Watcher over you" (iv. 1). (He then recited) a verse of Sura Hashr:" Fear Allah. and let every soul consider that which it sends forth for the morrow and fear Allah" (lix. 18). (Then the audience began to vie with one another in giving charity.) Some donated a dinar, others a dirham, still others clothes, some donated a sa' of wheat, some a sa' of dates; till he (the Holy Prophet) said: (Bring) even if it is half a date. Then a person from among the Ansar came there with a money bag which his hands could scarcely lift; in fact, they could not (lift). Then the people followed continuously, till I saw two heaps of eatables and clothes, and I saw the face of the Messenger (may peace be upon him) glistening, like gold (on account of joy). The Messenger of Allah (may peace be upon him) said: He who sets a good precedent in Islam, there is a reward for him for this (act of goodness) and reward of that also who acted according to it subsequently, without any deduction from their rewards; and he who sets in Islam an evil precedent, there is upon him the burden of that, and the burden of him also who acted upon it subsequently, without any deduction from their burden.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2220]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2220

This hadith has been narrated on the authority of Mandhir through another chain of transmitters. And the hadith transmitted by Ibn Mu'adh contains an addition:" He then observed the noon prayer and then gave the sermon."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2221]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2221

Mundhir b. Jarir narrated on the authority of his father: When we were sitting in the company of the Apostle of Allah (may peace be upon him). There came people dressed in striped woollen clothes, and the rest of the hadith in the same, and there (it is also mentioned):" He observed the Zuhr prayer and then climbed up a small pulpit, praised Allah, lauded Him, and then said: Verily Allah in His Book has revealed: 'O people, fear your Lord, ' etc." (iv. 1).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2222]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2222

Jarir b. 'Abdullah reported: People came to to the Messenger of Allah (may peace be upon him) and they ware dressed in woollen clothes. He (the Holy Prophet) saw their dismal state, as they were suffering from want and the rest of the hadith is the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2223]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2223

Abu Mas'ud reported: We were commanded to give charity (despite the fact.) that we were coolies. Abu 'Aqil donated half a sa'. And there came another man with more than this. The hypocrites said: Verily Allah does not stand in need of the charity of this, and the second one has done nothing but only made a show (of his charity). Then this verse was revealed." Those who scoff at the voluntary givers of charity among the believers as well as those who cannot find anything (to give) but with their hard labour" (ix. 80). And Bishr did not utter the word Muttawwi'in.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2224]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2224

This hadith has been narrated by Shu'ba with the same chain of transmitters and in the hadith transmitted by Sa'id b. al Rabi (the words are):" We used to carry loads on our backs."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2225]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2225

It is narrated on the authority of Abu Huraira (that the Messenger of Allah) said: Of course the person who gives to the family a she-camel as a gift, which gives milk morning and evening equal to a large bowl, its reward (the reward of the gift) is great.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2226]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2226

Abu Huraira reported that the Apostle of Allah (may peace be upon him) forbade (to do certain things) and then he made a mention of certain habits and said: He who gives a she-camel as a gift, for him is the reward (of the gift) both morn- ing and evening-a reward for drinking milk in the morning and a reward for drinking milk in the evening.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2227]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2227

Abu Haraira reported that the likeness of one who spends or one who gives charity is that of a person who has two cloaks or two coats-of-mail over him right from the breast to the collar bones. And when the spender (and the other narrator said, when the giver of charity) makes up his mind to give charity, it (coat-mail) becomes expanded for him. But when a miserly person intends to spend, it contracts and every ring grips the place where it is. For the giver of charity, this coat-of. mail expands to cover his whole body and obliterates even his footprints. Abu Huraira said: (The miserly man) tries to expand it (the coat-of-mail) but it does not expand.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2228]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2228

Abu Haraira reported that the Messenger of Allah (may peace be upon him) gave similitudes of a miserly man and the giver of charity as two persons who have two coats-of-mail over them with their hands pressed closely to their breasts and their collar bones. Whenever the giver of charity gives charity it (the coat-of mail) expands so much as to cover his finger tips and obliterate his foot prints. And whenever the miserly person intends to give charity (the coat-of-mail) contracts and every ring grips the place where it is. He (Abu Huraira) said: I saw the Messenger of Allah (may peace be upon him) saying with fingers in the opening of his shirt:" If you had seen him trying to expand it, it will not expand."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2229]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2229

Abu Haraira reported Allah's Messenger (may peace be upon him) as-saying:. The similitude of a miserly man and the giver of charity is that of two persons with coatsof mail over them; when the giver of charity intends to give charity, it expands over him (to much so) that the footprints are also obliterated. And when the miserly man intends to give charity, it contracts over him, and his hands are tied up to his collar bone, and every ring is fixed up to another. He (the narrator) said: I heard the Messenger of Allah (may peace be upon him) as saying: He would try to expand it. but he would not be able to do so.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2230]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2230

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: A man expressed his intention to give charity, so he came out with charity and placed it in the hand of an adulteress. In the morning, the people were talking and saying: charity was given to an adulteress last night. He (the giver of Sadaqa) said: 0 Allah, to Thee be the praise-to an adulteress. He then again expressed his intention to give charity; so he went out with the charity and placed it in the hand of a rich person. In the morning the people were talking and saying: Charity was given to a rich person. He (the giver of charity) said: 0 Allah, to Thee be the praise-to a well-to-do person. He then expressed his intention to give charity, so he went out with charity and placed it in the hand of a thief. In the morning, the people were talking and saying: Charity was given to a thief. So (one of the persons) said: 0 Allah, to Thee be the praise (what a misfortune it is that charity has been given to) the adulteress, to a rich person. to a thief! There came (the angel to him) and he was told: Your charity has been accepted. As for the adulteress (the charity might become the means) whereby she might restrain herself from fornication. The rich man might perhaps learn a lesson and spend from what Allah has given him, and the thief might thereby refrain from committing theft.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2231]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2231

Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The honest Muslim trustee who spends (sometimes he said" who gives" ) what he is commanded to do and he gives that in full with his heart overflowing with cheerfulness and he gives it to one to whom he is ordered, he is one of the givers of charity.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2232]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2232

'A'isha reported Allah's Messenger (may peace be upon him) as saying: When a woman gives in charity some of the food in her house, without causing any damage, there is reward for her for whatever she has given, and a reward for her husband for what he earned. The same applies to the trustee. In no respect does the one diminish the reward of the other.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2233]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2233

This hadith has been narrated by Mansur with the same chain of transmitters (with this alteration of words):" from the food of her husband".


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2234]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2234

'A'isha reported Allah's Messenger (may peace be upon him) as saying: When a woman spends (something as Sadaqa) out of the household of her husband without causing any damage, there is a reward for her and for him too like it for whatever he earned, and for her (for the wife) because of her spending (for the sake of Allah), and for the trustee also (there is a reward like it), without any reduction from their rewards.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2235]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2235

This hadith has been narratedby A'mash with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2236]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2236

Umair, the freed slave of Abi'l-Lahm reported: 1 was the slave (of Abi'l-Lahm). I asked the Messenger of Allah (may peace be upon him) if I could give some charity out of my master's wealth. He said: Yes, and the reward is half and half between you two.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2237]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2237

'Umair, the freed slave of Abi'l-Lahm, said: My master commanded me to cut some meat in strips; (as I was doing it) a poor man came to me and I gave him some of it to eat. My master came to know of that, and he beat me. I came to the Messenger of Allah (may peace be upon him) and narrated it to him. He (the Holy Prophet) summoned him and said: Why did you beat him? He (Abi'l-Lahm) said: He gives away my food without being commanded to do so. Upon this he (the Holy Prophet) sbid: The reward would be shared by you two.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2238]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2238

Hammam b. Munabbih said: These are some of the a hadith of Muhammad. the Messenger of Allah (may peace be upon him), transmitted to us on the authority of Abu Huraira. So he narrated one hadith out of them (as this): The Messenger of Allah (may peace be upon him) said: No woman should observe fast when her spouse is present (in the house) but with his permission. And she should not admit any (mahram) in his house, while he (her husband) is present, but with his permission. And whatever she spends from his earnings without his sanction, for him is half the reward.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2239]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2239

Abu Huraira reported Allah's Messenger (may peace be upon him) assaying: If anyone contributes a pair of anything for the sake of Allah, he would be invited to enter Paradise (with these words): O servant of Allah. it is good (for you). These who engage in prayer will he invited to enter by the gate of prayer; those who take part in Jihad will be Invited to enter by the gate of Jihad; those wto give charity will be invited to enter by the gate of charity; and those who observe fast will be invited to enter by the gate ar-Rayyan. Abu Bakr Siddiq said: Messenger of Allah, is it necessary that a person be invited through one of these gates? Will anyone he invited to enter by all those gates? The Messenger of Allah (way peace be upon him) said: Yes, and I hope you will be one of them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2240]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2240

This hadith has been narrated by Zuhri through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2241]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2241

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who spent pairs for the sake of Allah, the guardians of Paradise would call him, (in fact) every guardian of the door (of Paradise would welcome him saying): O, so and so, come on. Upon this Abu Bakr said: Messenger of Allah, (it means) there would be no distress on this person. The Messenger of Allah (may peace be upon him) said. I hope you would be among them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2242]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2242

Abu Huraira reported that the Messenger of Allah (may peace be upon him) said: Who has observed fast among you today? Abu Bakr (Allah be pleased with him) replied: It is I. He (the Holy Prophet again) said: Who among you follow. ed the bier today? Abu Bakr (Allah be pleased with him) replied: It is I. He (the Holy Prophet again) said: Who among you led a poor man today? Abu Bakr (Allah he pleased with him) replied: It is I. He (again) said: Who among you visited an invalid today? Abu Bakr (Allah be pleased with him) said: It is I. Upon this the Messenger of Allah (may peace be upon him) said: Anyone in whom (these good deeds) are combined will certainly, enter paradise.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2243]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2243

Asma', daughter of Abu Bakr (Allah be pleated with him), reported: The Messenger of Allah (may peace be upon him) said to me: Spend, and do not calculate, or otherwise Allah would also calculate in your case.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2244]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2244

Asma' reported Allah's Messenger (way peace be upon him) as saying (to her): Spend and do not calculate, (for) Allah would calculate in your case; and do not hoard, otherwise Allah would be withholding from you.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2245]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2245

This hadith has been narrated on the authority of Asma' through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2246]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2246

Asma', daughter of Abu Bakr, reported that abe came to the Apostle of Allah (may peace he upon him) and said: Apostle of Allah, I have nothing with me, but only, that which is given to me by Zubair (for household expenses). Is there any sin for me if I spend out of that which is given to me (by Zabair)? Upon this he (the Holy Prophet) said: Spend according to your means; and do not hoard, for Allah will withhold from you.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2247]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2247

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Muslim women, none of you should consider even a sheep's trotter too insignificant to give to her neighbour.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2248]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2248

Abu Huraira reported that the Apostle of Allah (may peace be upon him) had said: Seven are (the persons) whom Allah would give protection with His Shade on the Day when there would be no shade but that of Him (i. e. on the Day of Judgment, and they are): a just ruler, a youth who grew up with the worship of Allah; a person whose heart is attached to the mosques; two persons who love and meet each other and depart from each other for the sake of Allah; a man whom a beautiful woman of high rank seduces (for illicit relation), but he (rejects this offer by saying):" I fear Allah" ; a person who gives charity and conceals it (to such an extent) that the right hand does not know what the left has given: and a person who remembered Allah in privacy and his eyes shed tears.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2249]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2249

This hadith has been narrated, on the authority, of Abu Huraira (with this change of words)." A person whose heart is attached to the mosque when he goes out of it till he returns to it."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2250]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2250

Abu Huraira reported that there came a person to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, which charity is the best? Upon this he said: That you should give charity (in a state when you are) healthy and close-fisted, one haunted by the fear of poverty, hoping to become rich (charity in such a state of health and mind is the best). And you must not defer (charity to such a length) that you are about to die and would he saying: This is for so and so, and this is for so and so. Lo, it has already come into (the possession of so and so).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2251]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2251

Abu Huraira reported that a person came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, which charity is the greatest in reward? (The Holy Prophet said): By your father, beware, you should give charity (in a state when you are) healthy and close-fisted, haunted by the fear of poverty, and still hoping to live (as rich). And you must not defer charity (to the time) when you are about to die, and would then say:" This is for so and so, and this for so and so." It has already become the possession of so and so.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2252]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2252

This hadith has been narrated with the same chain of transmitters except with this change (of words):" Which charity is most excellent?"


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2253]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2253

Abdullah b. Umar reported that as Allah's Messenger (may peace be upon him) was sitting on the pulpit and talking about Sadaqa and abstention from begging, he said: The upper hand is better than the lower one, the upper being the one which bestows and the lower one which begs.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2254]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2254

Hakim b. Hizam reported Allah's Messenger (may peace be upon him) having said this: The most excellent Sadaqa or the best of Sadaqa is that after giving which the (giver) remains rich and the upper hand is better than the lower hand, and begin from the members of your household.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2255]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2255

Hakim b. Hizam reported: I begged the Apostle of Allah (may peace be upon him), and he gave me. I again begged, he again gave me. I again begged, he again gave me, and then said: This property is green and sweet; he who receives it with a cheerful heart is blessed in it, and he who receives it with an avaricious mind would not be blessed in it, he being like one who eats without being satished, and the upper hand is better thad the lower hand.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2256]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2256

Abu Umama reported Allah's Messenger (may peace be upon him) as saying: 0 son of Adam, it is better for you if you spend your surplus (wealth), but if you withhold it, it is evil for you. There is (however) no reproach for you (if you withhold means necessary) for a living. And begin (charity) with your dependants; and the upper hand is better than the lower hand.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2257]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2257

Mu'awiya said: Be cautious about ahadith except those which were current during the reign of Umar, for he exhorted people to ftar Allah, the Exalted and majestic. I heard the Messenger of Allah (may peace be upon him) as saying: He upon whom Allah intends to bestow goodness, He confers upon him an insight in religion; and I heard the Messenger of Allah (way peace be upon him) as saying: I am the treasurer. To one whom I give out of (my own) sweet will, he would be blessed in that, but he whom I give (yielding to his constant begging and for his covetousness is like one who would eat, but would not be satisfied.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2258]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2258

Mu'awiya reported AUah's Messenger (may prom be upon him) as saying: Do not beg importunately, for, I swear by Allah, none of you who asks me for anything and manages to get what he asks for when I disapprove td it will he be blessed in that which I give him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2259]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2259

'Amr b. Dinar reported from Wahb b. Munabbih: I went to his house in San'a' and he offered me nuts grown in his house to eat. And his brother said: I heard Mu'awiya b. Abu Sufyan saying that he had heard the Messenger of Allah (may peace be upon him) as saying, and then he made a mention (of a hadith) like one mentioned above.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2260]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2260

Abd al-Rahman b. Auf reported: I heard Mu'awiya b. Abu Sufyan saying in an address that he had heard the Messenger of Allah (may peace be upon him) as saying: He to whom Allah intends to do good, He gives him insight into religion. And I am only the distributor while Allah is the Bestower.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2261]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2261

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The poor man (miskin) is not the one who goes round to the people and is dismissed with one or two morsels. and one or two dates. They (the Prophet's Companions) said: Messenger of Allah, then who is miskin? He said: He who does not get enough to satisfy him, and he is not considered so (as to elicit the attention of the benevolent people), so that charity way be given to him. and he does not beg anything from people.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2262]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2262

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Miskin is not he who is dismissed with one or two dates, and with one morsel or two morsels. (In fact) miskin is he who abstains (from begging). Read if you so desire (the verse):" They beg not of men importunately)" (ii. 273). This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2263]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2263

Hamza. son of 'Abdullah, reported on the authority of his father that the Apostle of Allah (may peace be upon him) said: When a man is always begging from people. he would meet Allah (in a state) that there would be no flesh on his face.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2264]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2264

This hadith has been narrated on the authority of the brother of Zuhri with the same chain of transmitters, but no mention has been made of the word" muz'a" (piece).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2265]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2265

Hamza b. 'Abdullah b. Umar heard his father cay that the Messenger of Allah (may peace be upon him) had said: The person would continue begging from people till he would come on the Day of Resurrection and there would be no flesh on his face.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2266]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2266

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who begs the riches of others to increase his own is asking only for live coals, so let him ask a little or much.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2267]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2267

Abu Huraira is reported to have heard the Messenger of Allah (may peace be upon him) as saying: It is letter for one among you to bring a load of firewood on his back and give charity out of it (and satisfy his own need) and be independent of people, than that he should beg from people, whether they give him anything or refuse him. Verily the upper hand is better than the lower hand, and begin (charity) with your dependants.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2268]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2268

Qais b. Abu Hizam reported: We came to Abu Huraira and he told Allah's Messenger (may peace be upon him) having said this: By Allah, (it is better) that one among you should go and bring a load of firewood on his back and he should sell it, and the rest of the hadith was narrated (like the previous one).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2269]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2269

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is better for any one of you to tie a bundle of firewood and carry it on his back and sell it than to beg a person, he may give or may refuse.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2270]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2270

Malik al-Ashja'i reported: We, nine, eight or seven men, were in the company of the Messenger of Allah (may peace be upon him) and he said: Why don't you pledge allegiance to the Messenger of Allah? -while we had recently pledged allegiance. So we said: Messenger of Allah, we have already pledged allegiance to you. He again said: Why don't you pledge allegiance to the Messenger of Allah? And we said: Messenger of Allah, we have already pledged allegiance to you. He again said: Why don't you pledge allegiance to the Messenger of Allah? We stretched our hands and said: Messenger of Allah. we have already pledged allegiance to you. Now tell (on what things) should we pledge allegiance to you. He said I (You must pledge allegiance) that you would worship Allah only and would not associate with Him anything, (and observe) five prayers, and obey- (and he said onething in an undertone) -that you would not beg people of anything. (And as a consequence of that) I saw that some of these people did not ask anyone to pick up the whip for them if it fell down.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2271]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2271

Qabisa b. Mukhariq al-Hilali said: I was under debt and I came to the Messenger of Allah (may peace be upon him) and begged from him regarding it. He said: Wait till we receive Sadaqa, so that we order that to be given to you. He again said: Qabisa, begging is not permissible but for one of the three (classes) of persons: one who has incurred debt, for him begging is permissible till he pays that off, after which he must stop it; a man whose property has been destroyed by a calamity which has smitten him, for him begging is permissible till he gets what will support life, or will provide him reasonable subsistence; and a person who has been smitten by poverty. the genuineness of which is confirmed by three intelligent members of this peoples for him begging is permissible till he gets what will support him, or will provide him subsistence. Qabisa, besides these three (every other reason) for begging is forbidden, and one who engages in such consumes that what is forbidden.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2272]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2272

Salim b. Abdullah b. 'Umar reported on the authority of his father ('Abdullah b. 'Umar) that he had heard 'Umar b. Khattab (Allah be pleased with him) saying: The Messenger of Allah (may peace be upon him) gave me a gift, but I said: Give it to one who needs it more than I. He gave me wealth for the second time but I said: Give it to one who needs it more than I. Upon this the Messenger of Allah (may peace be upon him) said: Take out of this wealth which comes to you without your being avaricious and without begging, but in other circumstance's do not let your heart hanker after it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2273]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2273

Salim b. 'Abdullah reported on the authority of his father that the Messenger of Allah (may peace be upon him) gave to 'Umar b. Khattab some gift. Umar said to him: Messenger of Allah, give it to one who needs it more than I. Upon this the Messenger of Allah (may peace be upon him) said: Take it; either keep it with you or give it as a charity, and whatever comes to you in the form of this type of wealth, without your being avaricious or begging for it, accept it, but in other circumstances do not let your heart hanker after it. And it was on account of this that Ibn 'Umar never begged anything from anyone, nor refused anything given to him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2274]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2274

This hadith has been narrated by Abdullah b. al-Sa'di from 'Umar b. al-Khattab who heard it from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2275]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2275

Ibn al-Sa'di Maliki reported: 'Umar b. Khattab (Allah be pleased with him) appointed me as a collector of Sadaqa. When I had finished that (the task assigned to me) and I handed over that to him (to 'Umar), he commanded me to (accept) some remuneration (for the work). I said: I performed this duty for Allah and my reward is with Allah. He said: Take whatever has been given to you, for I also performed this duty during the time of the Messenger of Allah (may peace be upon him). He assigned me the task of a collector and I said as you say, and the Messenger of Allah (may peace be upon him) said to me: When you are given anything without your begging for it, (then accept it), eat it and give it in charity.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2276]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2276

Ibn al-Sa'di reported: 'Umar b. Khattab (Allah be pleased with him) appointed me as a collector of Sadaqat. The rest of the hadith in the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2277]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2277

Abu Huraira reported from the Messenger of Allah (may peace be upon him) as having said this: The heart of an old person feels young for the love of two things: love for long life and wealth.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2278]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2278

Abu Huraira reported that the Messenger of Allah (may peace be upon him) had said this: The heart of an old person is young for two things: for long life and love for wealth.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2279]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2279

Anas reported Allah's Messenger (may peace be upon him) as saying: The son of Adam grows old, but two (desires) in him remain young: desire for wealth and desire for life.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2280]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2280

A hadith like this has been narrated by Anas through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2281]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2281

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2282]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2282

Anas reported Allah's Messenger (may peace be upon him) as saying: If the son of Adam were to possess two valleys of riches. he would long for the third one. And the stomach of the son of Adam is not filled but with dust. And Allah returns to him who repents.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2283]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2283

Anas b. Malik reported: I heard the Messenger of Allah (may peace be upon him) as saying this, but 1 do not know whether this thing was revealed to him or not, but he said to.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2284]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2284

Anas b. MILlik reported Allah's Messenger (may peace be upon him) as saying: If there were two valleys of gold for the son of Adam, he would long for an- other one. and his mouth will not be filled but with dust, and Allah returns to him who repents.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2285]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2285

Ibn Abbas reported Allah's Messenger (may peace be upon him) as saying: If there were for the son of Adam a valley full of riches, he would long to possess another one like it. and Ibn Adam does not feel satiated but with dust. 1413 And Allah returns to him who returns (to HiM). 1414 Ibn Abbas said: I do not know whether it is from the Qur'an or not; and in the narration transmitted by Zuhair it was said: I do not know whether it is from the Qur'an, and he made no mention of Ibn Abbas.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2286]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2286

Abu Harb b. Abu al-Aswad reported on the authority of his father that Abu Musa al-Ash'ari sent for the reciters of Basra. They came to him and they were three hundred in number. They recited the Qur'an and he said: You are the best among the inhabitants of Basra, for you are the reciters among them. So continue to recite it. (But bear in mind) that your reciting for a long time may not harden your hearts as were hardened the hearts of those before you. We used to recite a surah which resembled in length and severity to (Surah) Bara'at. I have, however, forgotten it with the exception of this which I remember out of it:" If there were two valleys full of riches, for the son of Adam, he would long for a third valley, and nothing would fill the stomach of the son of Adam but dust." And we used so recite a slirah which resembled one of the surahs of Musabbihat, and I have forgotten it, but remember (this much) out of it:" Oh people who believe, why do you say that which you do not practise" (lxi 2.) and" that is recorded in your necks as a witness (against you) and you would be asked about it on the Day of Resurrection" (xvii. 13).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2287]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2287

Abu Huraira reported that the Messenger of Allah (may peace be upon him) had said: Richness does not lie in the abundance of (worldly) goods but richness is the richness of the soul (heart, self).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2288]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2288

Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) stood up and addressed the people thus: 0 people, by Allah, I do not entertain fear about you in regard to anything else than that which Allah would bring forth for you in the form of adornment of the world. A person said: Messenger of Allah, does good produce evil? The Messenger of Allah (may peace be upon him) remained silent for a while and he then said: What did you say? He replied: Messenger of Allah, I said: Does good produce evil? The Messenger of Allah (may peace be upon him) said to him: The good does not produce but good. but among the plants the spring rain produces There some which kill with a tremour or nearly kill all but the animal which feeds on vegetation. It eats and when its flanks are distended, it faces the can. then when it has donged or urinated and chewed it returns and eats. He who accepts wealth rightly, Allah confers blessing on it for him. and he who takes wealth without any right, he is like one who eats and is not satisfied.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2289]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2289

Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) had said: The most dreadful thing I fear in your case is what Allah brings forth for you in the form of the adornment of the world. They (the Prophet's Com panions) said: Messenger of Allah, what is the adornment of the world? He said: Blessings (the natural resources) of the earth. They (again) said: Messenger of Allah, does good produce evil? He said: No, only good comes out of good. No, only good comes out of good. No. only good comes out of good. All that which the spring rain helps to grow kills or is about to kill but (the animal) which feeds on vegetation. It eats and when its flanks are distended, it faces the sun, it chews the cud, it has dunged and urinated. it returns and eats. This wealth is green and sweet, and he who accepts it and applies it rightly, finds it a good help, but he who takes it wrongfully is like one who eats without being satisfied.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2290]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2290

Abu Said al-Khudri reported: The Messenger of Allah (may peace be upon him) was sitting on the pulpit and we were sitting around him, and he said: What I am afraid of in regard to you after my death is that there would be opened for you the adornments of the world and its beauties. A person said: Messenger of Allah, does good produce evil? The Messenger of Allah (may peace be upon him) remained silent. And it was said to him (the man who had asked the question from the Holy Prophet): What Is the matter with you, that you speak with the Messenger of Allah (may peace be upon him) but he does not speak with you? We thought as if revelation was descending upon him. He regained himself and wiped the sweat from him and said: He was the inquirer (and his style of expression showed as if he praised him and then added): Verily good does not produce evil. Whatever the spring rainfall causes to grow kills or is about to kill, but that (animal) which feeds on vegetation. It eats till its flanks are filled; it faces the sun and dungs and urinates. and then returns to eat. And this Wealth is a sweet vegetation, and it is a good companion for a Muslim who gives out of it to the needy, to the orphan. to the wayfarer, or something like that as the Messenger of Allah (may peace be upon him) said: He who takes it without his right is like one who eats but does not feel satisfied, and it would stand witness against him on the Day of judgment.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2291]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2291

Abu Sa'id al-Khudri reported that some people from among the Ansar begged from the Messenger of Allah (may peace be upon him) and he gave them. They again begged him and he again gave them, till when what was in his possession was exhausted he said: Whatever good (riches, goods) I have, I will not withhold it from you. He who refrains from begging Allah safeguards him against want. and he who seeks sufficiency, Allah would keep him in a state of sufficiency, and he who shows endurance. Allah would grant him power to endure, and none is blessed with an endowment better and greater than endurance.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2292]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2292

This hadith has been narrated by Zuhri with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2293]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2293

'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: He Is successful who has accepted Islam, who has been provided with sufficient for his want and been made contented by Allah with what He has given him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2294]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2294

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Allah, make the provision of Mahammad's family sufficient just to sustain life.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2295]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2295

Umar b. Khattab (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) distributed something. Upon this I said: Messenger of Allah, I swear by God, the others besides them were more deserving than these (to whom you gave charity). He said: They had in fact left no other alternative for me. but (that they should) either beg importunately from me or they would regard me as a miser, but I am not a miser.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2296]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2296

Anas b. Malik reported: I was walking with the Messenger of Allah (may peace be upon him) and he had put on a mantle of Najran with a thick border. A bedouin met him and pulled the mantle so violently that I saw this violent pulling leaving marks of the border of the mantle on the skin of the neck of the Messenger of Allah (may peace be upon him). And he (the bedouin) said: Muhammad, issue command that I should be given out of the wealth of Allah which is at your disposal. The Messenger of Allah (may peace be upon him) turned his attention to him and smiled, and then ordered for him a gift (provision).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2297]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2297

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters. And In the hadith transmitted by Ikrima b. 'Ammir there is an addition:" He (the bedouin) pulled his (mantle) so violently that the Apostle of Allah (may peace be upon him) was drifted very close to the bedouin." And in the hadith transmitted by Hammam, (the words are):" He pulled it so violently that the mantle was torn and the border was left around the neck of the Messenger of Allah (may peace be upon him)."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2298]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2298

Miswar b. Makhrama reported that the Messenger of Allah (may peace be upon him) distributed some cloaks but did not bestow one upon Makhrama. Upon this Makhrama said: 0 my son, come along with me to the Messenger of Allah (may peace be upon him). So I went with him. He said: Enter the house and call him (to come out) for me. So I called him and he (the Holy Prophet) came out, and there was a cloak (from those already distributed) on him. He (the Holy Prophet) said: I had kept it for you. He (Makhrama), looked at it and was pleased.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2299]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2299

Miswar b. Makhrama reported: Some cloaks were presented to the Messenger of Allah (may peace be upon him). My father Makhrama said to me: Come along with me to him; perhaps we may be able to get anything out of that (stock of cloaks). My father stood at the door and began to talk. The Apostle of Allah (may peace be upon him) recognised him by his voice and came out and there was a cloak with him, and he was showing its beauties and saying: I kept it for you, I kept it for you.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2300]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2300

Sa'd reported that the Messenger of Allah (may peace be upon him) bestow- ed (some gifts) upon a group of people and I was sitting amongst them. The Messenger of Allah (may peace be upon him), however, left a person and he did not give him any. thing. and he seemed to me the most excellent among them (and thus deserved the gifts more than anyone else). So I stood up before the Messenger of Allah (may peace be upon him) and said to him in undertone: Messenger of Allah, what obout so and so? By Allah, I find him a believer. He (the Messenger of Allah) said: He may be a Muslim. I kept quiet for a short while, and then what I knew of him urged me (to plead his case again) and I said: Messenger of Allah, what about so and so? By Allah, I find him a believer. Upon this he (the Holy Prophet) said: He may, be a Muslim. I again remained quiet for a short while, and what I knew of him again urged me (to plead his case so I) said: Messenger of Allah, what about so and so? By Allah, I find him a believer. Upon this he (the Holy Prophet) said: He may be a Muslim. I often bestow (something) upon a person, whereas someone else is dearer to me than he, because of the fear that he may fall headling into the fire. And in the hadith transmitted by Hulwani this statement was repeated twice.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2301]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2301

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2302]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2302

This hadith has been narrated on the authority of Muhammad b. Sa'd through another chain of transmitters (and the words are):" The Messenger of Allah (may peace be upon him) struck between my neck and shoulder with his hand and said: Do you wrangle,0 Sa'd, because I bestow (some gifts) upon a person?"


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2303]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2303

Anas b. Malik reported that when on the Day of Hunain Allah conferred upon His Apostle (may peace be upon him) the riches of Hawazin (without armed encounter), the Messenger of Allah (may peace be upon him) set about distributing to some persons of Quraish one hundred camels Upon this they (the young people from the Ansar) said: May Allah grant pardon to the Messenger of Allah (may peace be upon him) that he bestowed (these camels) upon the people of Quraish, and he ignored us, whereas our swords are still dripping blood. Anas b. Malik said: Their statement was conveyed to the Messenger of Allah (may peace be upon him) and he sent (someone) to the Ansar and gathered them under a tent of leather. When they had assembled, the Messenger of Allah (may peace be upon him) came to thera and said: What is this news that has reached me from you? The wise people of the Ansar said: Messenger of Allah, so far as the sagacious amongst us are concerned they have said nothing, but we have amongst us persons of immature age; they said: May Allah grant pardon to the Messenger of Allah (may peace be upon him) that he gave to the Quraish and ignored us (despite the fact) that our swords are besmeared with their blood. Upon this the Messenger of Allah (may peace be upon him) said: I give (at times material gifts) to persons who were quite recently in the state of unbelief, so that I may incline them to truth Don't you feel delighted that people should go with riches, and you should go back to your places with the Apostle of Allah? By Allah, that with which you would return is better than that with which they would return. They said: Yes, Messenger of Allah, we are pleased. The Holy Prophet said too: You would find marked preference (in conferring of the material gifts) in future, so you should show patience till you meet Allah and His Messenger and I would he at the Haud Kauthar. They said: We would show patience.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2304]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2304

Anas b. Malik reported that when Allah conferred upon His Messenger (may peace be upon him) the riches of Hawazin (without armed encounter) ; the rest of the hadith is the same except some variation (of words):" Anas said: We could not tolerate it and he also said: The people were immature in age."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2305]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2305

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2306]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2306

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) gathered the Ansar and said: Is there someone alien among you? They said: No, but only the son of our sister. Upon this the Messenger of Allah (may peace be upon him) said: The son of the sister of the people is included among the tribe, and (farther) said: The Quraish have recently abandoned Jahillyya and have just been delivered from distress; I, therefore, intend to help them and conciliate them. Don't you feel happy that the people should return with worldly riches and you return with the Messenger of Allah to your houses? (So far as my love for you is concerned I should say) if the people were to tread a valley and the Ansar tread a narraw path (in a mountain) I would tread the narrow path of the Ansar.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2307]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2307

Anas b. Malik reported: When Mecca was conquered, he (the Holy Prophet) distributed the spoils among the Quraish. Upon this the Ansar said: It is strange that our swords are dripping with their blood, whereas our spoils have been given to them (to the Quraish). This (remark) reached the Messenger of Allah (may peace be upon him), and so he gathered them and said: What is this that has been conveyed to me about you? They said: (Yes) it is that very thing that, has reached you-and they were not (the people) to speak lie. Upon this he said: Don't you like that the people should return to their houses along with worldly riches, whereas you should return to your houses with the Messenger of Allah? If the people were to tread a valley or d narrow path, and the Ansar were also to tread a valley or a narrow path, I would tread the valley (along with the) Ansar or the narrow path (along with the) Ansar.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2308]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2308

Anas b. Malik reported that when it was the Day of Hunain there came the tribes of Hawazin, Ghatafan and others along with their children and animals, and there were with the Apostle of Allah (may peace be upon him) that day ten thousand (soldiers), and newly freed men (of Mecca after its conquest). All these men (once) turned their backs, till he (the Holy Prophet) was left alone. He (the Messenger of Allah) on that day called twice and he did not interpose anything between these two (announcements) He turned towards his right and said: 0 people of Ansar! They said: At thy beck and call (are we), Messenger of Allah. Be glad we are with thee. He then turned towards his left and said: 0 people of Ansar. They said: At thy beck and call (are we). Be glad we are with thee. He (the Holy Prophet) was riding a white mule. He dismounted and said: I am the servant of Allah and His Apostle. The polytheists suffered defeat. and the Messenger of Allah (may peace he upon him) acquired a large quantity of spoils, and he distributed them among the refugees and the people recently delivered (of Mecca) but did not give anything to the Ansar. The Ansar said: In the hour of distress it is we who are called (for help). but the spoils are given to other people besides us. This (remark) reached him (the Holy Prophet). and he gathered them In a tent. and said: What is this news that has reached me on your behalf? They kept silence. Upon this he said: 0 people of Ansar, don't you like that people should go away with worldly (riches), and you go away with Muhammad taking him to your houses? They said: Yes, happy we are. Messenger of Allah. He (the Holy Prophet) said: If the people were to tread a valley, and the Ansar were to tread a narrow path, I would take the narrow path of the Ansar. Hisham said: I asked Abu Hamza if he was present there. He said: How could Ibe absent from him?


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2309]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2309

Anas b. Malik reported: We conquered Mecca and then we went on an expedition to Hunain. The polytheists came, forming themselves into the best rows that I have seen. They first formed the rows of cavalry, then those of infantry, and then those of women behind them. Then there were formed the rows of sheep and goats and then of other animals. We were also people large in number, and our (number) had reached six thousand. And on one side Khalid b. Walid was in charge of the cavalry. And our horses at once turned back from our rear. And we could hardly hold our own when our horses were exposed, and the bedouins and the peoplewhom we knew took to their heels. (Seeing this) the Messenger of Allah (may peace be upon him) called thus: 0 refugees,0 refugees. He then. said: 0 Ansar,0 Ansar. (Anas said: This hadith is transmitted by a group of eminent persons.) We said: At thy beck and call are we, Messenger of Allah. The Messenger of Allah (may peace be upon him) then advanced and he (Anas) said: By Allah, we had not yet reached them when Allah defeated them. and we took possession of the wealth and we then marched towards Ta'if, and we besieged them for forty nights. and then came back to Mecca and encamped (at a place), and the Messenger of Allah (may peace be upon him) began to bestow a hundred camels upon each individual. The rest of the hadith is the same.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2310]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2310

Rafi' b. Khadij reported that the Messenger of Allah; (may peace be upon him) gave to Abu Sufyan b. Harb and Saf wan. b. Umayya and 'Uyaina b. Hisn and Aqra' b. Habis, i. e. to every one of these persons, one hundred of camels, and gave to 'Abbas b. Mirdas less than this number. Upon this 'Abbas b. Mirdis said:

You allot the share of my booty and that of my horse between 'Uyaina and Aqra'.

Both Uyaina and Aqra' are in no way more eminent than Mirdas (my father) in the assembly.

I am in no way inferior to any one of these persons.

And he who is let downtoday would not be elevated.

He (the narrator) said: The Messenger of Allah (may peace be upon him) then complet- ed one hundred camels for him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2311]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2311

This hadith has been narrated by Sa'id b. Masruq with the same chain of transmitters (with the words):" The Apostle of Allah (may peace be upon him) distributed the spoils of Hunain, and he (the Holy Prophet) gave one hundred camels to Abu Sufyan b. Harb. The rest of the hadith is the same, but with this addition:" He bestowed upon" Alqama b. 'Ulatha one hundred (camels)."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2312]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2312

This hadith has been narrated by Sa'id with the same chain of transmitters, but no mention has been made of Alqama b. 'Ulatha, nor of safwin b. Umayya, and he did not mention the verse in his hadith.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2313]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2313

Abdullah b. Zaid reported that when the Messenger of Allah (may peace be upon him) conquered Hunain he distributed the booty, and he bestowed upon those whose hearts it was intended to win. It was conveyed to him (the Holy Prophet) that the Ansar cherished a desire that they should be given (that very portion) which the people (of Quraish) had got. Upon this the Messenger of Allah (may peace be upon him) stood up and, after having praised Allah and lauded Him, addressed them thus: 0 people of Ansar, did I not find you erring and Allah guided you aright through me, and (in the state of) being destitute and Allah made you free from want through me, and in a state of disunity and Allah united you through me, and they (the Ansar) said: Allah and His Messenger are most benevolent. He (again) said: Why do you not answer me? They said: Allah and His Messenger are the most benevolent. He said, If you wish you should say so and so, and the event (should take) such and such course (and in this connection he made a mention) of so many things. 'Amr is under the impressionthat he has not been able to remember them. He (the Holy Prophet) further said: Don't you feel happy (over this state of affairs) that the people should go away with goats and camels, and you go to your places along with the Messenger of Allah? The Ansar are inner garments (more close to me) and (other) people are outer garments. Had there not been migration, I would have been a man from among the Ansar. If the people were to tread a valley or a narrow path, I would tread the valley (chosen) by the Ansar or narrow path (trodden) by them. And you would soon find after me preferences (over you in getting material benefits). So you should show patience till you meet me at the Haud (Kauthar).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2314]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2314

Abdullah reported: On the day of Hunain, the Messenger of Allah (may peace be upon him) showed preference (to some) People in the distribution of the spoils. He bestowed on Aqra' b. Habis one hundred camels, and bestowed an equal (number) upon 'Uyaina, and bestowed on people among the elites of Arabia, and pre. ferred them) (to others) on that day, in the distribution (of spoils). Upon this a person said: By Allah, neither justice has been done In this distribution (of spoils), nor has the pleasure of Allah been sought in it. I (the Narrator ) said: By Allah, I will certainly inform the Messenger of Allah (may peace be upon him) about it. so I came to him and informed him about what he had said. - The colour of his (the Prophet's) face changed red like blood and he then said: Who would do justice, if Allah and His Messenger do not do justice? He further said: May Allah have mercy upon Moses; he was tormented more than this, but he showed patience. I said: Never would I convey him (the Holy Prophet) after this (unpleasant) narration.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2315]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2315

Abdullah reported: The Messenger of Allah (may peace be upon him) distributed spoils (of war). Upon this a person said: This is a distribution In which the pleasure of Allah has not been sought. I came to the Apostle of Allah (may peace be upon him) and informed him in an undertone. He (the Holy Prophet) was deeply angry at this and his face became red till I wished that I had not made a mention of it to him. He (the Holy Prophet) then said: Moses was tormented more than this, but he showed patience.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2316]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2316

Jabir b. Abdullah reported that a person came to the Messenger of Allah (may peace be upon him) at Jirana on his way back from Hunain, and there was in the clothes of Bilal some silver. The Messenger of Allah (may peace be upon him) took a handful out of that and bestowed it upon the people. He (the person who had met the Prophet at Ji'rana) said to him: Muhammad, do justice. He (the Holy Prophet) said: Woe be upon thee, who would do justice if I do not do justice, and you would be very unfortunate and a loser if I do not do justice. Upon this Umar b. Khattab (Allah be pleased with him) said: Permit me to kill this hypocrite. Upon this he (the Holy Prophet) said: May there be protection of Allah! People would say that I kill my companions. This man and his companions would recite the Qur'an but it would not go beyond their throat, and they swerve from it just as the arrow goes through the prey.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2317]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2317

This hadith has been narrated on the authority of Jabir b. 'Abdullah through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2318]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2318

Abu Said Khudri reported that 'Ali (Allah be pleased with him) sent some gold alloyed with dust to the Messenger of Allah (may peace be upon him), and the Messenger of Allah (may peace be upon him) distributed that among four men, al-Aqra b. Habis Hanzali and Uyaina b. Badr al-Fazari and 'Alqama b. 'Ulatha al-'Amiri, then to one person of the tribe of Kilab and to Zaid al-Khair al-Ta'l, and then to one person of the tribe of Nabhan. Upon this the people of Quraish felt angry and said: He (the Holy Prophet) gave to the chiefs of Najd and ignored us. Upon this the Messenger of Allah (may peace be upon him) said: I have done it with a view to con- cillating them. Then there came a person with thick beard, prominent cheeks, deep sunken eyes and protruding forehead and shaven head. He said: Muhammad, fear Allah. Upon this the Messenger of Allah (may peace be upon him) said: If I disobey Allah, who would then obey Him? Have I not been (sent as the) most trustworthy among the people of the-world? -but you do not repose trust in me. That person then went back. A person among the people then sought permission (from the Holy Prophet) for his murder. According to some, it was Khalid b. Walid who sought the permission. Upon this the Messenger of Allah (may peace be upon him), said: From this very person's posterity there would arise people who would recite the Qur'an, but it would not go beyond their throat; they would kill the followers of Islam and would spare the idol-worshippers. They would glance through the teachings of Islam so hurriedly just as the arrow passes through the pray. If I were to ever find them I would kill them like 'Ad.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2319]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2319

Abu Said al-Khudri reported: 'Ali b. Abu Talib sent to the Messenger of Allah (may peace be upon him) from Yemen some gold alloyed with clay in a leather bag dyed in the leaves of Mimosa flava. He distributed it among four men. 'Uyaina b. Hisna, Aqra' b. Habis and Zaid al-Khail, and the fourth one was either Alqama b. 'Ulatha or 'Amir b. Tufail. A person from among his (Prophet's) Companions said: We had a better claim to this (wealth) than these (persons). This (remark) reached the Apostle of Allah (may peace be upon him) upon which he said: Will you not trust me, whereas I am a trustee of Him Who is in the heaven? The news come to me from the heaven morning and evening. Then there stood up a person with deep snnken eyes, prominent cheek bones, and elevated forehead, thick beard, shaven head, tucked up loin cloth, and he said: Messenger of Allah, fear Allah. He (the Holy Prophet) said: Woe to thee. do I not deserve most to fear Allah amongst the people of the earth? That man then returned. Khalid b. Walid then said: Messenger of Allah, should I not strike his neck? Upon this he (the Holy Prophet) said: Perhaps he may be observing the prayer. Khalid said: How many observers of prayer are there who profess with their tongue what is not in their heart? Upon this the Messenger of Allah (may peace be upon him) said: I have not been commanded to pierce through the hearts of people, nor to split their bellies (insides). He again looked at him and he was going back. Upon this he (the Holy Prophet) said: There would arise a people from the progeny of this (man) who would recite the Qur'an glibly, but it would not go beyond their throats; they would (hurriedly) pass through (the teachings of their) religion just as the arrow passes through the prey. I conceive that he (the Holy Prophet) also said this: If I find them I would certainly kill them as were killed the (people of) Thamud.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2320]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2320

This hadith has been narrated through another chain of transmitters and (the narrator) made a mention of elevated forehead, but he made no mention of tucked-up loin cloth and made this addition:" There stood up 'Umar b. Khattab (Allah be pleased with him), and said: Should I not strike his neck? Upon this he said: No. Then he turned away, and Khalid the Sword of Allah stood up against him, and said: Prophet of Allah. shall I not strike off his neck? He said, No, and then said: A people would rise from his progeny who would recite the Book of Allah glibly and fluently. 'Umar said: I think he (the Holy Prophet) also said this: If I find them I would certainly kill them like Thamud."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2321]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2321

This hadith has been narrated through another chain of transmitters, but no mention has been made of:" If I find them, I would kill them as the Thamud were killed."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2322]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2322

Abu Salama and 'Ata' b. Yasar came to Abu Sa'id al-Khudri and asked him about Haruriya, saying: Did you hear the Messenger of Allah (may peace be upon him) making a mention of them? He (Abu Sai'd al-Khudri) said: I don't know who the Haruriya are, but I heard the Messenger of Allah (may peace be upon him) as saying: There would arise in this nation (and he did not say" out of them" ) a people and you would hold insignificant your prayers as compared with their prayers. And they would recite the Qur'an which would not go beyond their throats and would swerve through the religion (as blank) just as a (swift) arrow passes through the prey. The archer looks at his arrow, at its iron head and glances at its end (which he held) in the tip of his fingers to see whether it had any stain of blood.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2323]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2323

Abu Sai'd al-Khudri reported: When we were in the company of the Messenger of Allah (may peace be upon him) and he was distributing the spoils of war, there came to him Dhul-Khuwasira, one of Banu Tamim. He said: Messenger of Allah, do justice. Upon this the Messenger of Allah (may peace be upon him) said: Woe be upon thee I Who would do justice, if I do not do justice? You would be unsuccessful and incurring a loss, if I do not do justice. Upon this Umar b. Khattab (Allah be pleased with him) said: Messenger of Allah, permit me to strike off his neck. The Messenger of Allah (may peace be upon him) said: Leave him, for he has friends (who would outwardly look to be so religious and pious) that everyone among you would consider his prayer insignificant as compared with their prayer, and his fast as com- pared with their fasts. They would recite the Qur'an but it would not go beyond their collar-bones. They would pass through (the teachings of Islam so hurriedly) just as the arrow passes through the prey. He would look at its Iron head, but would not find anything ticking) there. He would then see at the lowest end, but would not find anything sticking there. He would then see at its grip but would not find anything sticking to it. He would then see at its feathers and he would find nothing sticking to them (as the arrow would pass so quickly that nothing would stick to it) neither excre- ment nor blood. They would be recognised by the presence of a black man among them whose upper arms would be like a woman's breast, or like a piece of meat as it quivers, and they would come forth at the time when there is dissension among the people. Abu Sai'd said: I testify to the fact that I heard it from the Messenger of Allah (may peace be upon him), and I testify to the fact that 'Ali b. Abu Talib fought against them and I was with him. He gave orders about that man who was sought for, and when he was brought in, and when I looked at him, he was exactly as the Messenger of Allah (may peace be upon him) had described him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2324]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2324

Abu Sa'id al-Khudri said that the Apostle of Allah (may peace be upon him) made a mention of a sect that would be among his Ummah which would emerge out of the dissension of the people. Their distinctive mark would be shaven heads. They would be the worst creatures or the worst of the creatures. The group who would be nearer to the truth out of the two would kill them. The Apostle of Allah (may peace be upon him) gave an example (to give their description) or he said: A man throws an arrow at the prey (or he said at the target), and sees at its iron head, but finds no sign (of blood there), or he sees at the lowest end, but would not see or find any sign (of blood there). He would then see into the grip but would not find (anything) sticking to it. Abu Sai'd then said: People of Iraq. it is you who have killed them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2325]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2325

Abu Sa'id al-Khudri reported that the Messenger of Allah (may peace be upon him) said: A group would secede itself (from the Ummah) when there would be dissension among the Muslims. Out of the two groups who would be nearer the truth would kill them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2326]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2326

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: There would be two groups in my Ummah, and there would emerge another group (seceding itself from both of them), and the party nearer to the truth among the two would kill them (the group of the Khwarij).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2327]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2327

Abu Sa'id al-Khudri reported from the Apostle of Allah (may peace be upon him) that a group (Khwarij) would emerge from the different parties (the party of Hadrat 'Ali and the party of Amir Mu'awiya), the group nearer the truth between the two would kill them.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2328]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2328

'Ali said: Whenever I narrate to you anything from the Messenger of Allah (may peace be upon him) believe it to be absolutely true as falling from the sky is dearer to me than that of attributing anything to him (the Holy Prophet) which he never said. When I talk to you of anything which is between me and you (there might creep some error in it) for battle is an outwitting. I heard the Messenger of Allah (may peace be upon him) as saying: There would arise at the end of the age a people who would be young in age and immature in thought, but they would talk (in such a manner) as if their words are the best among the creatures. They would recite the Qur'an, but it would not go beyond their throats, and they would pass through the religion as an arrow goes through the prey. So when you meet them, kill them, for in their killing you would get a reward with Allah on the Day of judgmelat.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2329]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2329

A hadith like this has been narrated through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2330]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2330

This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but (these words) are not there:" They pass through the religion clean as the arrow passes through the prey."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2331]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2331

'Abida narrated from 'Ali that he made a mention of the Khwarij (and in this connection) said that there would be a person among them with a defective hand. (or with a short hand) or a fleshy hand. If you were to exercise restraint, I would tell you what Allah has promised to those who would kill them on the order of Mubarrmad (may peace be upon him). I (the narrator) said to him: Did you hear it from Muhammad: (may peace be upon him)? He (Hadrat 'Ali) said: Yes, by the Lord of the Ka'ba; Yes, by the Lord of the Ka'ba; yes, by the Lord of the Ka'ba.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2332]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2332

'Abida said: I will not narrate to you except what I heard from him (Hadrat 'Ali), and then he narrated from him.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2333]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2333

Zaid b. Wahb Jahani reported and he was among the squadron which wall under the command of Ali (Allah be pleased with him) and which set out (to curb the activities) of the Khwarij. 'Ali (Allah be pleased with him) said: 0 people, I heard the Messeinger of Allah (may peace be upon him) say: There would arise from my Ummah a people who would recite the Qur'an, and your recital would seem insignificant as compared with their recital, your prayer as compared with their prayer, arid your fast, as compared with their fast. They would recite the Qur'an thinking that it sup- ports them, whereas it is an evidence against them. Their prayer does not get beyond their collar bone; they would swerve through Islam just as the arrow passes through the prey. If the squadron which is to encounter them were to know (what great boon) has been assured to them by their Apostle (may peace be upon him) they would completely rely upon this deed (alone and cease to do other good deeds), and their (that of the Khwarij) distinctive mark is that there would be (among them) a person whose wrist would be without the arm, and the end of his wrist would be fleshy like the nipple of the breast on which there would be white hair. You would be marching towards Muawiya and the people of Syria and you would leave them behind among your children and your property (to do harm). By Allah, I believe that these are the people (against whom you have been commanded to fight and get reward) for they have shed forbidden blood, and raided the animals of the people. So go forth in the name of Allah (to fight against them). Salama b. Kuhail mentioned that Zaid b. Wahb made me alight at every stage, till we crossed a bridge. 'Abdullah b. Wahb al-Rasibi was at the head of the Khwarij when we encountered them. He ('Abdullah) said to his army: Throw the spears and draw out your swords from their sheaths, for I fear that they would attack you as they attacked you on the day of Harura. They went back and threw their spears and drew out their swords, and people fought against them with spears and they were killed one after another. Only two persons were killed among the people (among the army led by Hadrat 'Ali) on that day. 'Ali (Allah be pleased with him) said: Find out from among them (the dead bodies of the Khwarij) (the maimed). They searched but did not find him. 'Ali (Allah be pleased with him) then himself stood up and (walked) till he came to the people who had been killed one after another. He ('Ali) said: Search them to the last, and then ('Ali's companions) found him (the dead body of the maimed) near the earth. He (Hadrat 'Ali) then pronounced Allah-O-Akbar (Allah is the Greatest) and then said, Allah told the Truth and His Messenger (may peace be upon him) conveyed it. Then there stood before him 'Abida Salmani who said: Commander of the Believers, by Allah, besides Whom there is no god but He, (tell me) whether you heard this hadith from the Messenger of Allah (may peace be upon him). He said: Yes, by Allah, besides Whom there is no god but He. He asked him to take an oath thrice and he took the oath.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2334]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2334

'Ubaidullah b. Abu Rafi', the freed slave of the Messenger of Allah (may peace be upon him), said: When Haruria (the Khwarij) set out and as he was with 'Ali b. Abu Talib (Allah be pleased with him) they said," There is no command but that of Allah." Upon this 'Ali said: The statement is true but it is intentionally applied (to support) a wrong (cause). The Messenger of Allah (may peace be upon him described their characteristics and I found these characteristics in them. They state the truth with their tongue, but it does not go beyond this part of their bodies (and the narrator pointed towards his throat). The most hateful among the creation of Allah us one black man among them (Khwarij). One of his hand is like the teat of a goat or the nipple of the breast. When 'Ali b. Abu Talib (Allah be pleased with him) killed them, he said: Search (for his dead body). They searched for him, but they did not find it (his dead body). Upon this he said: Go (and search for him). By Allah, neither I have spoken a lie nor has the lie been spoken to me. 'Ali said this twice and thrice. They then found him (the dead body) in a rain. They brought (his dead) body till they placed it before him (Hadrat 'Ali). 'Ubaidullah said: And, I was present at (that place) when this happened and when 'Ali said about them. A person narrated to me from Ibn Hanain that he said: I saw that black man.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2335]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2335

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Verily there would arise from my Ummah after me or soon after me a group (of people) who would recite the Qar'an, but it would not go beyond their throats, and they would pass clean through their religion just as the arrow passes through the prey, and they would never come back to it. They would be the worst among the creation and the creatures. Ibn Samit (one of the narrators) said: I met Rafi' b. 'Amr Ghifari, the brother of Al-Hakam Ghifari and I said: What is this hadith that I heard from Abu Dharr, i. e. so and so? -and then I narrated that hadith to him and said: I heard it from the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2336]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2336

Yusair b. 'Amr reported that he inquired of Sahl b. Hunaif: Did you hear the Apostle of Allah (may peace be upon him) making a mention of the Khwarij? He said: I heard him say (and he pointed with his hand towards the east) that these would be a people who would recite the Qur'an with their tongues and it would not go beyond their collar bones. They would pass clean through their religion just as the arrow passes through the prey.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2337]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2337

This hadith had been transmitted by Sulaiman Shaibani with the same chain of narrators (and the words are)," There would arise out of (this group) many a group"


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2338]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2338

Sahl b. Hunaif reported Allah's Apostle (may peace be upon him) as saying: There would arise from the east a people with shaven heads.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2339]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2339

Abu Huraira reported that Hasan b. 'Ali took one of The dates of the sadaqa and put it in his mouth, whereupon the Prophet (may peace be upon him) said: Leave it, leave it, throw it; don't you know that we do not eat the sadaqa?


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2340]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2340

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters (and the words of the Holy Prophet) are:" Sadaqa is not permis- sible for us."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2341]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2341

This very hadith has been narrated on the authority of Sbu'ba with the same chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2342]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2342

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I go back to my family and I find a date lying on my bed. I then take it up to eat it, but then I throw it away fearing that it may be a Sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2343]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2343

Out of so many ahadith which Hammam b. Munabbih narrated on the authority of Abu Huraira from the Messenger of Allah (may peace be upon him) one is this that the Messenger of Allah (may peace be upon him) said: I go back to my family and I find a date lying on my bed or in my house, and I take it up to eat it, but then I throw it away fearing that it may be a Sadaqa or from Sadaqa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2344]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2344

Anas b. Malik reported that the Apostle of Allah (may peace be upon him) found a date in the street and said: If it were not of sadaqa I would have eaten it. 1457


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2345]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2345

Anas b. Malik reported that the Messenger of Allah (may peace be upon him) found a date lying on the path and said: If it were not out of Sadaqa, I would have eaten it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2346]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2346

Anas b. Malik reported that the Apostle of Allah (may peace be upon him) found a date and said: Were it not (that I fear) it may be part of sadaqa, I would have eaten it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2347]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2347

'Abd al-Muttalib b. Rabi'a b. al-Harith reported that Rabi'a b. al-Harith and Abbas b. Abd al-Muttalib gathered together and said: By Allah, if we had sent these two young boys (i. e. I and Fadl b. 'Abbas) to the Messenger of Allah (may peace be upon him) and they had spoken to him, he would have appointed them (as the collectors) of these sadaqat; and they would (collect them) and pay (to the Holy Prophet) as other people (collectors) paid and would get a share as other people got it. As they were talking about it there came 'Ali b. Abu Talib and stood before them, and they made a mention of it to him. 'Ali b. Abu Talib said: Don't do that; by Allah he (the Holy Prophet) would not do that (would not accept your request). Rabi'a b. Harith turned to him and said: By Allah, you are not doing so but out of jealousy that you nurse against us By Allah, you became the son-in-law of the Messenger of Allah (may peace be upon him) but we felt no jealousy against you (for this great privilege of yours). 'Ali then said: Send them (if you like). They set out and 'Ali lay on the bed. When the Messenger of Allah (may peace be upon him) offered the noon prayer. we went ahead of him to his apartment and stood near it till he came out. He took hold of our ears (out of love and affection) and then said: Give out what you have kept in your hearts. He then entered (the apartment) and we also went in and he (the Holy Prophet) was on that day (in the house of) Zainab b. jahsh. We urged each (of us) to speak. Then one of us thus spoke: Messenger of Allah, you are the best of humanity and the best to cement the ties of blood-relations. We have reached the-marriageable age. We have come (to you) so that you may appoint us (as collectors) of these sadaqat. and we would pay you just as thin people (other collectors) pay you, and get our share as others get it. He (the Holy Prophet) kept silence for a long time till we wished that we should speak with him (again), and Zainab pointied to us from behind the curtain not to talk (any more). He (the Holy Prophet) said; It does not become the family of Muhammad (to accept) sadaqat for they are the impurities of people. You call to me Mahmiya (and he was in charge of khums, i. e, of the one-fifth part that goes to the treasury out of the spoils of war), and Naufal b. Harith b. 'Abd al-Muttalib. They both came to him, and he (the Holy Prophet) said to Mahmiya: Marry your daughter to this young man (i. e. Fadl b. 'Abbas), and he married her to him And he said to Naufal b. Harith: Marry your daughter to this young man (i e. 'Abd al-Muttalib b. Rabi'a, the narrator of this hadith) and he married her to me, and he said to Mahmiya: Pay so much mahr on behalf of both of them from this khums Zuhri, however. said: He did not determine (the amount of mahr).


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2348]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2348

Rabi'a b. Harith b. 'Abd al-Muttalib and Abbas b. 'Abd al-Muttalib said to Abd al-Muttalib b. Rabi'a and Fadl b. Ibn Abbas: Go to the Messenger of Allah (may peace be upon him), and the rest of the hadith is the same (but with this addition):" 'Ali spread his cloak and then lay down on it and said: I am the father of Hasan, and I am the chief. By Allah, I would not move from my place till your sons come back to you with the reply to that for which you sent them to the Messenger of Allah (may peace be upon him). And he then also said: Verily these sadaqat are the impurities of people, and they are not permissible for Muhammad (may peaace be upon him), and for the family of Muhammad. And he also said: The Messenger of Allah (may peace be upon him) also said to me: Call Mahmiya b. Jaz', and he was person from Banu Asad. and the Messenger of Allah (may peace be upon him) had apointed him as a collector of khums.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2349]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2349

Juwayriya, the wife of the Messenger of Allah (may peace be upon him)" said that Messenger of Allah (may peace be upon him) came to her and said: Is there anything to eat? She said: Messenger of Allah, I swear by God, there is no food with us except a bone of goat which my freed maid-servant was given as sadaqa. Upon this he said: Bring that to me, for it (the sadaqa) has reached its destination.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2350]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2350

This hadith has been narrated by Zuhri with the same chain of trainsmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2351]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2351

Anas b. Malik reported that Barira presented to the Apostle of Allah (may peace be upon him) a piece of meat which had been given to her as sadaqa. Upon this he (the Holy Prophet) said: That is a Sadaqa for her and a gift for us.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2352]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2352

'A'isha reported that (once) the Apostle of Allah (may peace be upon him, ) was presented with beef. It was said (by someone) that it had been given to Barira as Sadaqa. Upon this he (the Prophet) said: It is a Sadaqa for her and a gift for us.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2353]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2353

'A'isha (Allah be pleased with her) said: Three are the decions (of the Shari'ah that we have come to know) through Barira. The people gave her sadaqa and she offered us as gift. We made a mention of it to the Apostle of Allah (may peace be upon him), whereupon he said: It is a sadaqa for her and a gift for you; so eat it.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2354]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2354

This hadith has been narrated on the authority of A'isha through another chain of transmitters.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2355]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2355

This hadith has been transmitted on the authority of 'A'isha in a similar manner except a slight variation that he said:" That is a gift for us out of it."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2356]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2356

Umm 'Atiyya, said: The Messenger of Allah (may peace be upon him) sent me some mutton of sadaqa. I sent a piece out of that to 'A'isha. When the Messenger of Allah (may peace be upon him) came to 'A'isha, he said: Have you anything with you (to eat)? She said: Nothing, except only that mutton sent to us by Nusaiba (the kunya of Umm 'Atiyya) which you had sent to her. Whereupon he said: It has reached its proper place.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2357]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2357

Abu Huraira reported: Whenever the Apostle of Allah (may peace be upon him) was presented with food, he asked about it, If he was told that it was a gift, he ate out of that, and if he was told that it was a sadaqa he did not eat out of that.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2358]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2358

'Abdullah b. Abu Aufa said that it was the common practice of the Mes- senger of Allah (may peace be upon him) that when the people brought to him sadaqa he blessed them: 0 Allah, bless them. So when Abu Aufa brought to him Sadaqa he (the Holy Prophet) said: 0 Allah, bless, the posterity of Abu Aufa.


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2359]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2359

This hadith has been narrated by Shu'ba with the same chain of transmitters (but with a slight variation of words, that he said): (0 Allah), bless them."


Muslim :: The Book of Zakat (Kitab Al-Zakat) :: [5.2360]

The Book of Zakat (Kitab Al-Zakat)

Muslim :: Book 5 : Hadith 2360

Jarir b. 'Abdullah said: 'When the collector of sadaqat (Zakat) comes to you, (you should see) that he goes away pleased with you.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2361]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2361

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When there comes the month of Ramadan, the gates of mercy are opened, and the gates of Hell are locked and the devils are chained,


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2362]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2362

This hadith is reported by Abu Huraira (with a slight alteration of words) that the Messenger of Allah (may peace be upon him) said:" When (the month of) Ramadan begins."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2363]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2363

Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying in connection with Ramadan: Do not fast till you see the new moon, and do not break fast till you see it; but if the weather is cloudy calculate about it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2364]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2364

Ibn Umar reported that Allah's Messenger (may peace be upon him) made a mention of Ramadan and he with the gesture of his hand said: The month is thus and thus. (He then withdrew his thumb at the third time). He then said: Fast when you see it, and break your fast when you see it, and if the weather is cloudy calculate it (the months of Sha'ban and Shawwal) as thirty days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2365]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2365

This hadith is narrated on the authority of 'Ubaidullah with the same chain of transmitters, and he said: If (the sky) is cloudy for you, then calculate thirty days (for the month of Ramadan).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2366]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2366

'Ubaidullah narrated on the authority of the same chain of transmitters that the Messenger of Allah (may peace be upon him) made a mention of Ramadan and said: The month may consist of twenty-nine days, and it may be thus, thus and thus, and (he further) said: Calculate it, but he did not say thirty.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2367]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2367

Ibn'Umar (Allah be pleased with-both of them) reported Allah's Messenger (may peace be upon him) as saying: The month of Ramadan may consist of twenty-nine days. So do not fast till you have sighted it (the new moon) and do not break fast, till you have sighted it (the new moon of Shawwal), and if the sky is cloudy for you, then calculate.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2368]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2368

'Abdullah b. 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month (of Ramadan) may consist of twenty nine days; so when you see the new moon observe fast and when you see (the new moon again at the commencement of the month of Shawwal) then break It, and if the sky is cloudy for you, then calculate it (and complete thirty days).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2369]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2369

'Abdullah b. Umar (Allah be pleased with both of them) reported Allah's Measenger (may peace be upon him) as saying: When you see the new moon, observe fast, and when you see it (again) then break it, and if the sky is cloudy for you, then calculate it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2370]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2370

Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month may consist of twenty-nine nights. So do not fast till you have sighted it (the new moon) and do not break it till you have sighted it, except when the sky is cloudy for you, and if it is so, then calculate it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2371]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2371

Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month is thus and thus and thus (i. e. pointing with his fingers thrice), and he held back his thumb at the third time (in order to show that it can also consist of twenty-nine days).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2372]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2372

Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month may consist of twenty-nine days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2373]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2373

Abdullah b. 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The mouth (of Ramadan) is thus and thus, and thus. i. e. ten, ten and-nine.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2374]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2374

Ibn Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month is thus, and thus, and thus, and he flapped his hands with all their fingers twice. but at the third turn, folded his right thumb or left thumb (in order to give an idea of twenty-nine).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2375]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2375

Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: The month (of Ramadan) may consist of twenty. nine days, and Shu'ba (one of the narrators) (gave a practical demonstration how the Holy prophet (may peace be upon him) explained to them) by unfolding his hands thrice and folding his thumb at the third turn. 'Uqba (one of the narrators in this chain of trans- mitters) said: I think that he said that the month consists of thirty days and unfolded his palm three times.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2376]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2376

Ibn 'Umar (may Allah be pleased with both of them) reported Allah's Apostle (may peace be upon him) as saying: We are an unlettered people who can neither write nor count. The month is thus, and thus. folding his thumb when he said it the third time. This hadith has been narrated on the authority of Aswad b. Qais with the same chain of transmitters, but herein no mention has been made of the other month (consisting of) thirty days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2377]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2377

Sa'd b. 'Ubaida reported that Ibn'Umar (Allah be pleased with both of them) heard a person saying: This night is the midnight (of the month). Upon this he said to him: How do you know that it is the midnight (of the month), for I heard the Mes- senger of Allah (may peace be upon him) as saying: The month is thus and thus (and he pointed with his ten fingers twice) and thus (i. e. at the third time he pointed with all his fingers but withdrew or folded his thumb)?


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2378]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2378

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Whenever you sight the new moon (of the month of Ramadan) observe fast. and when you sight it (the new moon of Shawwal) break it, and if the sky is cloudy for you, then observe fast for thirty days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2379]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2379

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe fast on sighting it (the new moon) and break (fast) on sighting it (the new moon), but if the sky is cloudy for you, then complete the number (of thirty).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2380]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2380

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe fast on sighting it (the new moon) and break it on sighting it. But if (due to clouds) the actual position of the month is concealed from you, you should then count thirty (days).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2381]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2381

Abu Huraira (Allah be pleased with him) narrated that the Messenger of Allah (may peace he upon him) made a mention of the new moon and (in this connection) said: Observe fast when you see it (the new moon) and break fast when you see it (the new moon of Shawwal), but when (the actual position of the month is) concealed from you (on account of cloudy sky), then count thirty days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2382]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2382

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not observe fast for a day, or two days ahead of Ramadan except a person who is in the habit of observing a particular fast; he may fast on that day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2383]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2383

This hadith has been narrated on the authority of Yahya b. Abi Kathir with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2384]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2384

Zuhri reported that (once) the Apostle of Allah (may peace be upon him) took an oath that he would not go to his wives for one Month. Zuhri said that 'Urwa narrated to him from 'A'isha (Allah be pleased with her) that she said: When twenty-nine nights were over, which I had counted, the Messenger of Allah (may peace be upon him) came to me (he came to me first of all). I said: Messenger of Allah, you had taken an oath that you would not come to us for a month, whereas you have come after twenty nine days which I have counted. Whereupon he said: The month may also consist of twenty-nine days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2385]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2385

Jabir (Allah be pleased with her) narrated that the Holy Prophet (may peace be upon him) separated himself from his wives for a month. (His wives said: ) He came to us on the twenty-ninth day, whereupon we said: It is the twenty-ninth (day) today. Thereupon he said: So far as the month is concerned, (and he, with a view to explaining it) flapped his hands thrice, but held back one finger at the last turn.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2386]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2386

Abu Zubair is reported to have heard Jabir b. 'Abdullah (Allah be pleased with both of them) as saying: The Apostle of Allah (may peace be upon him) separated himself from his wives for a month. (His wives said: ) He came to us on the morning of the twenty-ninth. Upon this some, of the people said: It is the morning of twenty- ninth (according to our calculation). Upon this the Apostle of Allah (may peace be upon him) said: The month. may also consist of twenty-nine days. The Apostle of Allah (may peace be upon him) then flapped his bands thrice, twice with all the fingers of both his hand (to indicate twenty-nine) and by the third time with nine (fingers).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2387]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2387

Umm Salama (Allah be pleased with him) reported that the Apostle of Allah (may peace be upon him) took an oath that he would not go to some of his wives for the whole of the month. When twenty-nine days bad passed he (the Holy Prophet) went to them in the morning or in the evening. Upon this it was said to him: Apostle of Allah, you took an oath that you would not come to us for a month, whereupon he said: The month may also consist of twenty-nine days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2388]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2388

A hadith like this has been narrated on the authority of Ibn Juraij with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2389]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2389

Sa'd b. Abi Waqqas (Allah be pleased with him) said that the Messenger of Allah (may peace be upon him) struck his hand against the other and (then with the gesture of his two hands) said: The month is thus, thus (two times). He then withdrew (one of) his fingers at the third turn.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2390]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2390

Muhammad b. Sa'd reported on the authority of his father (Sa'd b. Abi Waqqas (Allah be pleased with him) that the Apostle of Allah (may peace be upon him) had said: Tho month is thus and thus, and thus, i. e. ten, ten and nine. This hadith has been narrated by Abu Khalid with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2391]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2391

Kuraib reported that Umm Fadl, daughter of Harith, sent him (Fadl, i. e. her son) to Mu'awiya in Syria. I (Fadl) arrived in Syria, and did the needful for her. It was there in Syria that the month of Ramadan commenced. I saw the new moon (of Ramadan) on Friday. I then came back to Medina at the end of the month. Abdullah b. 'Abbas (Allah be pleased with him) asked me (about the new moon of Ramadan) and said: When did you see it? I said.: We saw it on the night of Friday. He said: (Did) you see it yourself? -I said: Yes, and the people also saw it and they observed fast and Mu'awiya also observed fast, whereupon he said: But we saw it on Saturday night. So we would continue to observe fast till we complete thirty (lasts) or we see it (the new moon of Shawwal). I said: Is the sightidg of the moon by Mu'awiya not valid for you? He said: No; this is how the Messenger of Allah (may peace be upon him) has commanded us. Yahya b. Yahya was in doubt (whether the word used in the narration by Kuraib) was Naktafi or Taktafi.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2392]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2392

Abu'l-Bakhtari reported: We went out to perform Umra and when we encamped in the valley of Nakhla, we tried to see the new moon. Some of the people said: It was three nights old, and others (said) that it was two nights old. We then met Ibn 'Abbas and told him we had seen the new moon, but that some of the people said it was three nights old and others that it was two nights old. He asked on which night we had seen it; and when we told him we had seen it on such and such night, he said the Prophet of Allah (may peace be upon him) had said: Verily Allah deferred it till the time it is seen, so it is to be reckoned from the night you saw it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2393]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2393

Abu'l-Bakhtari reported: We saw the new moon of Ramadan as we were at Dhit-i-'Irq. We sent a man to Ibn Abbas (Allah be pleased with both of them) to ask him (whether the sighting of a small moon had something of the nature of defect in it). Upon this Ibn 'Abbas (Allah be pleased with both of them) said that the Messenger of Allah (may peace be upon him) had said: Verily Allah deferred its sight, but if (the new moon) is hidden from you, then, complete its number (thirty).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2394]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2394

The son of Abu Bakra reported it on the authority of his father that the Apostle of Allah (may peace be upon him) had said: The two months of 'Id, Ramadan and Dhu'l-Hijja (are not incomplete).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2395]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2395

'Abd ar-Rahman b. Abu Bakra reported on the authority of Abu Bakra that the Apostle of Allah (may peace be upon him) had said: The months of 'Id are not incomplete. And in the hadith narrated by Khalid (the words are):" The months, of 'Id are Ramadan and Dhu'l-Hijja."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2396]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2396

'Adi b. Hatim (Allah be pleased with him) reported that when (this verse) was revealed:" Until the white streak of the dawn becomes distinct from the dark streak" (ii. 187) Adi b. Hatim said: Messenger of Allah, verily I keep underneath my pillow two strings, one white and the other black, by which I distinguish night from dawn. Upon this the Messenger of Allah (may peace be upon him) said: Your pillow seems to be very large. For the word khait implies the blackness of the night and the whiteness of the dawn.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2397]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2397

Sahl b. Sa'd said that when this verse was revealed:" Eat and drink till the white streak is distinct from the dark streak," a person would take hold of a white thread and a black thread and keep on eating till he could find them distinct (in the light of the dawn). It was then that Allah, the Majestic and Great, reveiled (the words) min al-fajr (from the dawn), and then it became clear (that the word khait refers to the streak of light in the dawn).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2398]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2398

Sahl b. Sa'd (Allah be pleased with him) said: When this verse was reveal- ed." Eat and drink till the white streak becomes distinct from the dark streak for you," the person who decided to observe fast tied on one of his feet a black thread and on the other a white thread. And he went on eating and drinking till he could distinguish (between their colour) on seeing them. It was after this that Allah reveal- ed (the words): min al-fajr. And they (the Muslims) came to know that (the word khait) refers to the night and day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2399]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2399

'Abdullah b. Mas'ud (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) had said: Bilal would pronounce Adhan (at the fag end of the night in order to inform the people about the time of the Sahri). So you eat and drink till you hear the Adhan of Ibn Umm Maktum (which was pro- nounced at the conclusion of the Sahri and the commencement of the fast).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2400]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2400

Abdullah b. 'Umar (Allah be pleased with both of them) reported: I heard the Messenger of Allah (may peace be upon him) as saying: Bilal announces Adhan during the night, so you eat and drink, till you hear the Adhan of Ibn Umm Maktum.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2401]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2401

Ibn 'Umar (Allah be pleased with both of them) reported that the Messenger of Allah (may peace be upon him) had two Mu'adhdhins, Bilal and son of Umm Maktum, the blind. The Messenger of Allah (may peace be upon him) said: Bilal announces Adhan at (the fag end of the) night (i. e. Sahri), so eat and drink till the son of Umm Maktum announces Adhan. And he (the narrator) said: And the (difference of time) between their (Adhans) was not more than this that one climbed down (from the minaret) and the other climbed up (to announce Adhan).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2402]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2402

A hadith like this has been transmitted on the authority of 'A'isha (Allah be pleased with her).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2403]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2403

A hadith like this has been narrated on the authority of 'Ubaidullah on the two chains of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2404]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2404

Ibn Mas'ud (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying The Adhan of Bilal should not restrain anyone among you from eating Sahur (last meal before daybreak during the month of Ramadan) for he announces Adhan (or he calls) at (the fag end of) the night to make him turn who stands for prayer among you, and to awaken those who are sleeping among you. And he said: The dawn is not like it, as one says (and he lifted his hand) till he (dispersed his fingers) and said: It is like this.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2405]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2405

This hadith has been narrated by Sulaiman al-Taimi with the same chain of transmitters (but with a slight variation of words) that he (the Holy Prophet) said: The dawn is not like it as it is said; he then gathered his fingers and lowered them. But he said, it is like this (and he placed the index finger upon the other one and spread his hand).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2406]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2406

This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters and, at the end, it was said that the first Adhan was meant to awaken those who were in slumber amongst them and in order to make them turn who stand in (prayer) among them (towards food at the commencement of the fast). Jarir (one of the narrators) said that the Messenger (may peace be upon him) did not say like this but he said like it (true dawn) that the streaks of (true dawn ) are horizontal and not vertical.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2407]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2407

Samura b. Jandub reported Muhammad (may peace be upon him) as saying. The call of Bilal may not mislead any one of you (and he may, under the wrong impression gathered from it, refrain) from taking meal before the commencement of the fast (for the streaks) of this whiteness (which are vertical indicate the false dawn and the true dawn with which the fast commences is that when the streaks of light are) spread.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2408]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2408

Samura b. Jundub reported Allah's Messenger (may peace be upon him) as saying: The Adhan of Bilal should not mislead you nor the whiteness (of the pillar) of dawn, for it is not the whiteness of the true dawn, but that of the false dawn which is vertical like a pillar and you can eat food till the streaks of whiteness spread like it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2409]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2409

Samura b. Jundub (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The Adhan of Bilal may not mislead you with regard to your food at the commencement of the fast, nor the vertical (streaks) of whiteness in the horizon (for it is an indication of false dawn). You should stop eating (food) till (the whiteness) spreads like it. Hammad narrated it and with the gesture of his band he explained, the horizontal position (of the streaks of light).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2410]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2410

Samura b. Jundub addressed and narrated from the Apostle of Allah (may peace be upon him) having said (these words): Neither the call of Bilal should mislead you nor this whiteness (of false dawn) till (the true) dawn appears (or he said) till the dawn breaks.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2411]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2411

A hadith like this has been narrated on the authority of Samura b. Jundub.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2412]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2412

Anas (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Take meal a little before dawn, for there is a blessing in taking meal at that time.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2413]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2413

'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: The difference between our fasting and that of the people of the Book is eating shortly before dawn.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2414]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2414

Musa b. 'Ali has narrated this hadith through the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2415]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2415

Zaid b. Thabit (Allah be pleased with him) said: We took meal shortly before dawn along with the Messenger of Allah (may peace be upon him). We then stood up for prayer. I said: How much span of time was there between the two (acts, i. e. taking of Sahri and observing of prayer)? He said (a span of reciting) fifty verses.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2416]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2416

This hadith has been transmitted on the authority of Qatada too.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2417]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2417

Sahl b. Sa'd (Allah be pleased with him) repotted Allah's Messenger (may peace be upon him) as saying: The people will continue to prosper as long as they hasten the breaking of the fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2418]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2418

A hadith like this has been transmitted by Sahl b. Sa'd.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2419]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2419

Abu 'Atiyya reported: I and Masruq went to 'A'isha and said to her: Mother of the Believers, there are two persons among the Companions of Muhammad (may peace be upon him) one among whom hastens in breaking the fast and in observing prayer, and the other delays breaking the fast and delays observing prayer. She said: Who among the two hastens in breaking fast and observing prayers? We said, It is 'Abdullah. i. e. son of Mas'ud. whereupon she said: This is how the Messenger of Allah (may peace be upon him) did. Abu Kuraib added: The second one was Abu Musa.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2420]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2420

Abu 'Atiyya reported: I and Misruq went to 'A'isha (Allah be pleased with her) and Masruq said to her: There are two persons among the Companions of Muhammad (may peace be upon him) none of whom abandons the good, but one of them hastens to observe sunset prayer and break the fast, and the other delays in observing the sunset prayer and in breaking the fast, whereupon she said: Who hastens to observe sunset prayer and break the fast? He said: It is 'Abdullah. Upon this she said: This is how the Messenger of Allah (may peace be upon him) used to do.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2421]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2421

'Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: When the night approaches and the day retreates and the sun sinks down, then the observer of the fast should break it. Ibn Numair made no mention of the word" then".


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2422]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2422

'Abdullah b. Abi Aufa reported: We were with the Messenger of Allah (may peace be upon him) on a journey during the month of Ramadan. When the sun had sunk he said: So and so, get down (from your ride) and prepare the meal of parched barley for us. He said: Messenger of Allah, still (there is light of) day. He (the Holy Prophet) said: Get down and prepare meal of parched barley for us. So he got down and prepared the meal of parched barley and offered him, and the apostle of Allah (may peace be upon him) drank that (liquid meal). He then told with the gesture of his hand that when the sun sank from that side and the night appeared from that side, then the observer of the fast should break it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2423]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2423

Ibn Abi Aufa (Allah be pleased with him) reported: We were with the Messenger of Allah (may peace be upon him) on a journey. When the sun sank he said to a person: Get down and prepare barley meal for us. Upon this he said: Messenger of Allah, let there be dusk. (He the Holy Prophet) said: Get down and prepare barley meal for us. He (the person) said: There is still (the light of) day upon us. (But) he got down (in obedience to the command of the Holy Prophet) and prepared a barley meal for him and he (the Holy Prophet) drank that (liquid meal) and then said: When you see the night approaching from that side (west) (and he pointed towards the east with his hand), then the observer of the fast should break it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2424]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2424

Abdullah b. Abi Aufa (Allah be pleased with him) reported: We travelled with the Messenger of Allah (may peace be upon him) as he had been observing fast. When the sun sank he said: So and so, get down and prepare barley meal for us. The rest of the hadith is the same.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2425]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2425

This hadith has been narrated on the authority of Ibn Abi Aufa (Allah be pleased with him) through another chain of transmitters (but with a sight alteration of words): In this hadith transmitted by one of the narrators (neither these words are found): During the month of Ramadan." nor his statement:" And the night prevails from that side (the eastern side)." (These words are found in the narration of) Hushaim only.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2426]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2426

Ibn 'Umar (Allah be pleased with both of them) said that the Apostle of Allah (may peace be upon him) forbade uninterrupted fasting. They (some of the Companions) said: You yourself fast uninterruptedly, whereupon he said: I am not like you. I am fed and supplied drink (by Allah).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2427]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2427

Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) abserved fasts uninterruptedly in Ramadan and the people (in his wake) did this. But he forbade them to do so. It was said to him (to the Holy Prophet): You yourself observe the fasts uninterruptedly (but you forbid us to do so) Upon this he said: I am not like you; I am fed and supplied drink (by Allah).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2428]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2428

A hadith like this has been transmitted by Ibn 'Umar (Allah be pleased with both of them), but he did not make mention of (the words):" During the month of Ramadan."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2429]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2429

Abu Huraira (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) forbade (his Companions) from observing fast unintermptedly. One of the Muslims said: Messenger of Allah, you yourself observe Saum Wisal. whereupon the Messenger of Allah (may peace be upon him) said: Who among you is like me? I spend night (in a state) that my Allah feeds me and provides me drink. When they (the Companions of the Holy Prophet) did not agree in abandoning the uninterrupted fast, then the Holy Prophet (may peace. be upon him) also observed this fast with them for a day, and then for a day. They then saw the new moon and he (the Holy Prophet) said: If the appearance of the new moon were delayed. I would have observed more (fasts) with you (and he did it) by way of warning to them as they had not agreed to refrain (from observing Saum Wisal)


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2430]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2430

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Abstain from Saum-Wisal. They (his Companions) said: Messenger of Allah, but you observe Saum Wisal. Upon this he said: You are not like me in this matter, for I spend my night (in a state) that my Lord feeds me and provides me drink Devote yourselves to the deeds (the burden of which) you can bear.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2431]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2431

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying (the words as said in the previous hadith) but with this alteration (of words):" Take upon yourselves (the burden of the deeds) for which you have the strength to bear."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2432]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2432

Abu Huraira reported that the Apostle of Allah (may peace be upon him) forbade (his Companions) to observe Saum Wisal.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2433]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2433

Anas (Allah be pleased with him) reported The Messenger of Allah (may peace be upon him) was observing prayer during Ramedan. I came and stood by his side. Then another man came and he stood likewise till we became a group. When the Apostle of Allah (may peace be upon him) perceived that we were behind him, he lightened the prayer. He then went to his abode and observed such (a long) prayer (the like of which) he never observed with us. When it was morning we said to him: Did you perceive us during the night? Upon this he said: Yes, it was this (realisation) that induced me to do that which I did. He (the narrator) said: The Messenger of Allah (may peace be upon him) began to observe Saum Wisal at the end of the month (of Ramadan), and some persons among his Companions began to observe this uninter- rupted fast, whereupon the Apostle of Allah (may peace be upon him) said: What about such persons who observe uninterrupted fasts? You are not like me. By Allah. if the month were lengthened for me, I would have observed Saum Wisal, so that those who act with an exaggeration would (have been obliged) to abandon their exaggeration. 1501


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2434]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2434

Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) observed Saum Wisal during the early part of the month of Ramadan. The people among Muslims also observed uninterrupted fast. This (news) reached him (the Holy Prophet) and he said: Had the month been lengthened for me I would have continued observing Saum Wisal, so that those who act with forced hardness would (have been obliged) to abandon it. You are not like me (or he said): I am not like you. I continue to do so (in a state) that my Lord feeds me and provides me drink.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2435]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2435

'A'isha (Allah be pleased with her) said: The Apostle of Allah (may peace be upon him) forbade them (his Companions) to observe Saum Wisal out of mercy for them. They said: You (Holy Prophet) yourself observe it. Upon this he said: I am not like you. My Lord feeds me and provides me drink.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2436]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2436

'A'isha (Allah be pleased with her) said that the Messenger of Allah (may peace be upon him) kissed one of his wives while he was fasting, and then she ('A'isha) smiled (as she narrated).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2437]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2437

Sufyan reported: I said to 'Abd al-Rahman b. Qasim: Have you heard from your father narrating from 'A'isha (Allah be pleased with her) that he kissed her while observing fast? He ('Abd al-Rahman b. Qasim) kept silence for a short while and then said:" Yes."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2438]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2438

'A'isha reported: Allah's Messenger (may peace be upon him) used to kiss me while observing fast; and who among you can control his desire as the Messenger of Allah (may peace be upon him) could control his desire.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2439]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2439

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) used to kiss (his wives) while fasting and embraced (them) while fasting; but he had the greatest mastery over his desire among you.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2440]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2440

'A'isha (Allah be pleased with her) reported: The Messenger of Allah (may peace be upon him) used to kiss (his wives) while fasting; and he had the greatest control over his desire (as compared with you).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2441]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2441

'A'isha (Allah be pleased with her) said that the Messenger of Allah (may peace be upon him) used to embrace (his wives) while fasting.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2442]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2442

Aswad reported: I and Masruq went to 'A'isha (Allah be pleased with her) and asked. her if the Messenger of Allah (may peace be upon him) embraced (his wives) while fasting. She said: Yes; but he had the greatest control over his desire among you: or he was one of those who had control over his desire. It is further narrated on the authority of Aswad and Masruq that they went to the Mother of the Believers and they asked her (and the rest of the hadith is the same)


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2443]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2443

'Urwa b. Zubair narrated that 'A'isha the Mother of the Believers (Allah be pleased with her) informed him that the Messenger of Allah (may peace be upon him) kissed her while fasting.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2444]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2444

A hadith like this has been narrated by Yahya b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2445]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2445

'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) used to kiss her during the month of fasting.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2446]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2446

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) kissed (his wives) during Ramadan while observing fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2447]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2447

'A'isha (Allah be pleased with her) reported that Allah's Apostle (peace be upon him) kissed (his wives) while fasting.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2448]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2448

Hafsa (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) kissed (his wives) while fasting.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2449]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2449

A hadith like this has been narrated by Hafsa (Allah be pleased with her) through another chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2450]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2450

Umar b Abu Salama reported that he asked the Messenger of Allah (may peace be upon him): Should one observing fast kiss (his wife)? The Messenger of Allah (may peace be upon him) said to him: Ask her (Umm Salama). She informed him that the Messenger of Allah (may peace be upon him) did that, where upon he said: Messenger of Allah, Allah pardoned thee all thy sins, the previous and the later ones. Upon this the Messenger of Allah (may peace be upon him) ) said: By Allah, I am the most God conscious among you and I fear Him most among you.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2451]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2451

Abu Bakr (he is Abu Bakr b. Abd al-Rahman b. Harith) reported: I heard Abu Huraira (Allah be pleased with him) narrating that he who is overtaken by dawn in a state of seminal emission should not observe fast. I made a mention of it to 'Abd al-Rahman b. Harith (i. e. to his father) but he denied it. 'Abd al-Rahman went and I also went along with him till we came to'A'isha and Umm Salama (Allah be pleased with both of them) and Abd al-Rahman asked them about it. Both of them said: (At times it so happened) that the Apostle of Allah (may peace be upon him) woke up in the morning in a state of junub (but without seminal emission in a dream) and observed fast He (the narrator) said: We then proceeded till we went to Marwan and Abd al-Rahman made a mention of it to him. Upon this Marwan said: I stress upon you (with an oath) that you better go to Abu Huraira and refer to him what is said about it. So we came to Abu Huraira and Abu Bakr had been with us throughout and 'Abd al-Rahman made a mention of it to him, whereupon Abu Huraira said: Did they (the two wives of the Holy Prophet) tell you this? He replied: Yes Upon this (Abu Huraira) said: They have better knowledge. Abu Huraira then attributed that what was said about it to Fadl b. 'Abbas and said: I heard it from Fadl and not from the Apostle of Allah (may peace be upon him). Abu Huraira then retracted from what he used to say about it. Ibn Juraij (one of the narrators) reported: I asked 'Abd al-Malik, if they (the two wives) said (made the statement) in regard to Ramadan, whereupon he said: It was so, and he (the Holy Prophet) (woke up in the) morning in a state of junub which was not due to the wet dream and then observed fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2452]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2452

'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: The dawn broke upon the Messenger of Allah (may peace be upon him) during the Ramadan in a state of junub not because of sexual dream (but on account of intercourse) and he washed himself and observed fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2453]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2453

Abu Bakr reported that Marwan sent him to Umm Salama to ask whether a person should observe fast who is in a state of junub and the dawn breaks upon him, whereupon she said that the Messenger of Allah (may peace be upon him) (was at times) junbi on account of intercourse and not due to sexual dream, and the dawn broke upon him, but he neither broke the fast nor recompensed.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2454]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2454

Abu Bakr b. 'Abd al-Rahman b. al-Harith b. Hisham reported on the authority of 'A'isha and Umm Salama, the wives of the Apostle of Allah (may peace be upon him): The Messenger of Allah (may peace be upon him) at times got up in the morning in a state of junub on account of having a sexual intercourse (with his wives during night) but not due to sexual dreams in the month of Ramadan, and would observe fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2455]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2455

'A'isha reported that a person came to the Apottle of Allah (may peace be upon him) asking for a fatwa (religious verdict). She ('A'isha) had been overhearing it from behind the curtain. 'A'isha added that he (the person) had said: Messenger of Allah, (the time) of prayer overtakes me as I am in a state of junub; should I observe fast (in this state)? Upon this the Messenger of Allah (may peace be upon him) said: (At times the time) of prayer overtakes me while I am in a state of junub, and I observe fast (in that very state), whereupon he said: Messenger of Allah, you are not like us Allah has pardoned all your sins, the previous ones and the later ones. Upon this he (the Holy Prophet) said: By Allah, I hope I am the most God-fearirg of you, and possess the best knowledge among you of those (things) against which I should guard.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2456]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2456

Sulaiman b. Yasar reported that he asked Umm Salama whether a person (who gets up) in the morning in a state of junub should observe fast. She said: The Messenger of Allah (may peace be upon him) (at times) got up in the morning in a state of junub, not because of sexual dreams (but on account of intercourse at night), and then observed fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2457]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2457

Abu Huraira (Allah be pleased with him) reported that a person came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, I am undone. He (the Holy Prophet) said: What has brought about your ruin? He said: I have had intercourse with my wife during the month of Ramadan. Upon this he (the Holy prophet) said: Can you find a slave to set him free? He said: NO He (the Holy Prophet again) said: Can you observe fast for two consecutive months? He said: No. He (the Holy Prophet) said: Can you provide food to sixty poor people?, He said: No. He then sat down and (in the meanwhile) there was brought to the Apostle of Allah (may peace be upon him) a basket which contained dates. He (the Holy Prophet) said: Give these (dates) in charity. He (the man) said: Am I to give to one who is poorer than I? There is no family poorer than mine between the two lava plains of Medina. The Apostle of Allah (may peace be upon him) laughed so that his molar teeth became visible and said: Go and give it to your family to eat.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2458]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2458

A hadith like this has been narrated on the authority of Mubammad b. Muslim al-Zuhri with the same chain of transmitters, and he said: There was brought an 'araq containing dates, an 'araq being a huge basket. But in this hadith no men- tion has been made of (the fact) that the Apostle of Allah (may peace be upon him) laughed till his molar teeth became visible.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2459]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2459

Abu Huraira reported that a person had intercourse with his wife during Ramadan (while fasting). He asked for the religious verdict (about it) from the Messenger of Allah (may peace be upon him), whereupon he (the Holy Prophet) said: Can you find a slave (to grant him freedom)? He said: No. He (the Holy Prophet again) said: Can you afford to observe fasts for two (consecutive) months? He said: No. He (the Holy Prophet) said: Then feed sixty poor men.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2460]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2460

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters that a person broke fast in Ramadan whereupon the Messenger of Allah (may peace be upon him) commanded him to free a slave (as an atonement), and the rest of the hadith is the same as narrated by Ibn Uyaina.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2461]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2461

Humaid b. 'Abd al-Rahman reported that Abu Huraira had narrated to him that the Apostle of Allah (may peace be upon him) commanded the person (who) broke the fast in Ramadan to free a slave or observe fasts for two (consecutive) months or feed sixty poor persons.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2462]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2462

This hadith has been narrated with the same chain of transmitters on the authority of Zuhri.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2463]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2463

'A'isha (Allah be pleased with her) reported that a person came to the Messenger of Allah (may peace be upon him) and said: I am burnt, whereupon the Messenger of Allah (may peace be upon him) said: How is it? He (the person) said: I had intercourse with my wife during the day in Ramadan. Upon this (the Holy Prophet) said: Give charity, give charity. He (the person) said: There is nothing with me. He commanded him to sit down, (In the meanwhile) there were brought to him (to the Holy Prophet) two baskets containing eatables, whereupon the Messenger of Allah (may peace be upon him) told him to give them as sadaqa.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2464]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2464

'Abbad b. Abdullah b. Zubair narrated that he heard 'A'isha (Allah be pleased with her) saying: A person came to the Messenger of Allah (may peace be upon him), and he then narrated the hadith. But (neither these words are found):" Give charity, give charity" (nor) his words:" during the day time".


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2465]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2465

Abbad b. Abdullah b. Zubair reported that he had heard 'A'isha, the wife of the Apostle of Allah (may peace be upon him), as saying: A person came to the Messenger of Allah (may peace be upon him) in the mosque during (the month of) Ramadan and said: Messenger of Allah, I am burnt I am burnt, whereupon the Mes- senger of Allah (may peace be upon him) asked him as to what the matter was. Upon this he said: I had intercourse with my wife (in a state of fasting) Thereupon he (the Holy Prophet) said: Give charity. Upon this he said: Apostle of Allah, I swear by God, there is nothing with me (to give in charity) as I do not possess anything. He (the Holy Prophet) said: Sit down. So he sat down and he was in this very state when there came a person urging a donkey with a load of eatables upon it. The Mes- senger of Allah (may peace be upon him) said: Where is that burnt one who was just here? Thereupon the person stood up. The Messenger of Allah (may peace be upon him) said: Give this (eatables brought by the man) in charity. Upon this the person said: Messenger of Allah, can there be anyone else (more deserving than I)? By Allah. we are hungry, we have nothing with us. Upon this he (the Holy Prophet) said: Then eat (these eatables).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2466]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2466

Ibn Abbas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) went out during the month of Ramadan in the year of Victory (when Mecca was conquered) and was fasting till he reached Kadid (a canal situated at a distance of forty-two miles from Mecca) and he then broke the fast. And it was the habit of the Companions of the Messenger of Allah (may peace be upon him) to follow him in every new thing (or act). So they followed him also (in this matter).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2467]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2467

This hadith is narrated on the authority of Zuhri with the same chain of transmitters. Yahya (one of the narrators) said that Sufyan (the narrator) had stated: I do not know whose statement it is:" It is the last word of the Messenger of Allah (may peace be upon him) which is accepted as (final as it abrogates the previous ones)."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2468]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2468

It has been narrated on the authority of Zuhri with the same chain of transmitters that breaking of fast (in a journey) is the final of the two commands (whether one may fast or one may break it), and it is the last command of the Messenger of Allah (may peace be upon him) which is to be accepted as final. Zuhri said: The Messenger of Allah (may peace be upon him) marched on Mecca on the morning of 14th of Ramadan (lit. when thirteen nights had passed).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2469]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2469

A hadlth like this has been transmitted on the authority of Ibn Shibab who said that they (the Compnions of the Holy Prophet) followed the latest of his commands and looked upon it as one abrogating (the previous ones) and the most firm.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2470]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2470

Ibn 'Abbas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) journeyed during the month of Ramadan in a slate of fasting till he reached 'Usfan. He then ordered a cup containing drinking water and he drank that openly so that the people might see it, and broke the fast (and did not resume it) till he reached Mecca. Ibn 'Abbas (Allah be pleased with him) said: Allah's Messenger (may peace be upon him) fasted and broke the fast, so he who wished fasted and he who wished to break it broke it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2471]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2471

Ibn Abbas (Allah be pleased with him) reported: Do not condemn one who observes fast, or one who does not observe (in a journey). for the Messenger of Allah (may peace be upon him) observed fast in a journey or he did not observe it (too).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2472]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2472

Jabir b. 'Abdullah (Allah be pleased with both of them) reported that Allah's Messenger (may peace be upon him) went out to Mecca in Ramadan in the year of Victory, and he and the people fasted till he came to Kura' al-Ghamim and the people also fasted. He then called for a cup of water which he raised till the people saw it, and then he drank. He was told afterwards that some people had continued to fast, and he said: These people are the disobedient ones; these are the disobedient ones.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2473]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2473

This hadith has been narrated by Ja'far with the some chain of trans- mitters and he added: It was said to him (to the Holy Prophet): There are people to whom fasting has become unbearable and they are waiting how you do. He (the Holy Prophet) then called for a cup of water when it was afternoon. The rest of the hadith is the same.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2474]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2474

Jabir b. 'Abdullah (Allah be pleased with both of them) reported that in the course of a journey Allah's Messenger (may peace be upon him) saw a man, people crowding around him and providing him a shade. Upon this he (the Holy Prophet) said: What is the matter with him? They said: He is a person observing fast. Whereupon the Messenger of Allah (may peace be upon him) said: It is no righteousness that you fast on journey.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2475]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2475

'Amr b. al-Hasan is reported to have said that he heard Jabir b. 'Abdullah (Allah be pleased with both of them) as saying that the Messenger of Allah (may peace be upon him) saw a man. The rest of the hadith is the same as mentioned above.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2476]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2476

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this addition that he (the Holy Prophet) said:" Take advantage of the concession of Allah Who Wanted it to you." When he (one of the narrators) asked him (the other one, Yabya b. Abi Kathar) he did not retain it in his mind.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2477]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2477

Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with Allah's Messenger (may peace be upon him) on the 16th of Ramadan. Some of us fasted and some of us broke the fast. But neither the observer of the fast found fault with one who broke it, nor the breaker of the fast found fault with one who observed it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2478]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2478

A hadith like this has been narrated on the authority of Qatada with the same chain of transmitters by different narrators (except this difference) that in the hadith transmitted by Taimi and Umar b. Amir and Hisham (the date of setting out is) 18th, and in the hadith transmitted by Sa'id it is the 12th, and in the one transmitted by Shu'ba it is the 17th or 19th.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2479]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2479

Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with the Messenger of Allah (may peace be upon him) during Ramadan and neither the observer of the fast was found fault with for his fasting, nor the breaker of the fast for breaking it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2480]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2480

Abu Sa'id al-Khudri (Allah be pleased with him) reported: We went out on an expedition with the Messenger of Allah (may peace be upon him) during Ramadan. Some of us observed the fast and some of us broke it. Neither the observer of the fast had any grudge against one who broke it, nor the breaker of the fast had any grudge against one who had fasted They knew that he who had strength enough (to bear its rigour) fasted and that was good, and they also found that he who felt weakness (and could not bear the burden) broke it, and that was also good.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2481]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2481

Abu Nadra reported Abu Sa'id al. Khudri and Jabir b. Abdullah as saying: We travelled with the Messenger of Allah (may peace be upon him). The observer of the fast observed it, and the breaker of the fast broke it, but none of them found fault with each other.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2482]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2482

Humaid reported that Anas (Allah be pleased with him) was asked about fasting during Ramadan while travelling. He said: We travelled with the MesseDger of Allah (may peace be upon him) during the month of Ramadan, but neither the ob- server of the fast found fault with the breaker of the fast, nor the breaker of the fast found fault with the observer of the fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2483]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2483

Abu Khalid al-Ahmar narrated from Humaid who said: I went out and was fasting; they said to me: Break (lit go back, repeat). He said that Anas reported that the Companions of the Messenger of Allah (may peace be upon him) used to set out on a journey and neither the observer of the fast found fault with the breaker of the fast, nor the breaker of the fast found fault with the observer of the fast. (One of the narrators Humaid said): I met Ibn Abi Mulaika who informed me the same thing on the authority of 'A'isha.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2484]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2484

Anas (Allah be pleased with him) reported: We were with the Apostle of Allah (may peace be upon him) on a journey. Some of us had been observing the fast and some of us had not been fasting. We got down at a place on a hot day. Most of us had the cloth for shelter. There were also those amongst us who sheltered (themselves against the rays of the) sun with the help of their hands. The observers of the fast fell down (on account of weakness). Those who had not observed it got up and pitched tents and watered the mounts. Thereupon the Messenger of Allah (may peace be upon him) said: The breakers of the fast have taken away the reward today.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2485]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2485

Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) was journeying (along with his Companions). Some of them had observed the fast whereas the others had broken it. Those who did not fast girded up their loins and worked, but the observers of the fast were too weak to work. Upon this he (the Apostle of Allah) said: Today the breakers of the fast have gone with the reward.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2486]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2486

Qaza'a reported: I came to Abu Sa'id al-Khudri (Allah be pleased with him) and he was surrounded (by people), and when they dispersed I said to him: I am not going to ask you about what these people were asking. I ask you about fasting on a journey. Upon this he said: We travelled with the Messenger of Allah (may peace be upon him) towards Mecca and we had been observing fast. We halted at a place. There the Messenger of Allah (may peace be upon him) said: You are nearing your enemy and breaking of fast would give you greater strength, and that was a concession (given to us). But some of us continued to observe the fast and some of us broke it. We then got down at another place and he (the Holy Prophet) said: You are going to encounter the enemy in the morning and breaking of the fast would give you strength, so break the fast. As it was a point of stress, so we broke the fast. But subsequently we saw ourselves observing the fast with the Messenger of Allah (may peace be upon him) on a journey.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2487]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2487

'A'isha (Allah be pleased with her) reported that Hamza b. 'Amr al-Aslami asked the Messenger of Allah (may peace be upon him) about fasting on a journey, and he (the Holy Prophet) said: Fast if you like and break it if you like.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2488]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2488

'A'isha (Allah be pleased with her) reported that Hamza b. Amr al-Aslami asked the Messenger of Allah (may peace be upon him) thus: Messenger of Allah, I am a person devoted much to fasting. Should I fast during the journey? He (the Holy Prophet) said: Fast if you like and break it if you like.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2489]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2489

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2490]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2490

This hadith has been narrated on the authority of Hisham with the same chain of transmitters that Hamza said: I am a person much used to fasting. Should I fast during the journey? (The rest of the hadith is the same.)


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2491]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2491

Hamza b. 'Amr al-Aslami (Allah be pleased with him) said: Messenger of Allah, I find strength in me for fasting on a journey; is there any sin upon me (in doing it)? Thereupon the Messenger of Allah (may peace be upon him) said: It is a concession from Allah. He who took advantage of it, it is good for him, and he who preferred to observe fast, there is no sin upon him. Harun (one of the narrators) in his narration said: 'lt is a concession, and he made no mention of" from Allah".


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2492]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2492

Abu Darda' (Allah be pleased with him) reported: We set out during the month of Ramadan with the Messenger of Allah (may peace be upon him) in such an intense heat that one of us would place his hand over his head (in order to protect himself) against the excessive heat, and none among us was observing the fast, except the Messenger of Allah (may peace be upon him) and 'Abdullah b. Rawaha.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2493]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2493

Abu Darda' reported: We were with the Messenger of Allah (may peace be upon him) on some of his journeys on an intensely hot day so much so that a person would place his hand on his head (in order to protect himself) against excessive heat, and none amongst us was fasting but the Messenger of Allah (may peace be upon him) and Abdullah b. Rawaha


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2494]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2494

Umm al-Fadl bint- al-Harith reported that some people argued about the fasting of the Messenger of Allah (may peace be upon him) on the day of 'Arafa. Some of them said that he had been fasting, whereas the others said that he had not been fasting. I sent a cup of milk to him while he was riding his camel at 'Arafa, and he drank it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2495]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2495

This hadith has been narrated on the authority of Abu Nadr with the same chain of transmitters, but he did not mention that he was mounting (riding on) his camel.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2496]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2496

This hadith has been narrated by Abu Nadr on the authority of Umair, the freed slave of Umm al-Fadl, through the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2497]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2497

Umm al-Fadl (Allah be pleased with her) is reported to have said that some people among the Companions of the Messenger of Allah (may peace be upon him) were in doubt about fasting on the day of 'Arafa and we were with him on that day. I (Umm al-Fadl) sent him a cup of milk and he was halting at 'Arafa, and he drank that.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2498]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2498

Kuraib, the freed slave of Ibn 'Abbas (Allah be pleased with him), reported from Maimuna, the wife of the Apostle of Allah (may peace be upon him), that people had doubt about the fasting of Allah's Messenger (may peace be upon him) on the day of 'Arafa. Maimuna sent him a cup of milk and he was halting at a place and he drank it and the people were seeing him.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2499]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2499

'A'isha (Allah be pleased with her) reported that the Quraish used to fast on the day of 'Ashura in the pre-Islamic days and the Messenger ot Allah (may peace be upon him) also observed it. When he migrated to Medina, he himself observed this fast and commanded (others) to observe it. But when fasting during the month of Ramadan was made obligatory he said: He who wishes to observe this fast may do so, and he who wishes to abandon it may do so.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2500]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2500

This hadith is narrated on the authority of Hisham with the same chain of transmitters, but he made no mention in the first part of the hadith that the Messenger of Allah (may peace be upon him) used to observe fast, and said about the second part that he abandoned the (fast) of Ashura, and he who wished observed the fast and who wished otherwise abandoned it, and he did not hold it as the words of the Apostle of Allah (may peace be upon him) as mentioned in the narration transmitted by Jarir.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2501]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2501

'A'isha (Allah be pleased with her) reported. In the pre-Islamic days fast was observed on the day of Ashura, but with the advent of Islam (its position was ascertained as that of a voluntary fast). Then he who wished to fast fasted, and he who liked to abandon it abandoned it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2502]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2502

'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) had ordered to observe fast (on 'Ashura) before the fasting in Ramadan was made obligatory. But when it became obligatory, then he who wished fasted on the day of Ashura, and he who wished did not observe it (on that day).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2503]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2503

'A'isha (Allah be pleased with her) reported that the Quraish used to observe fast on the day of Ashura during the pre-Islamic days. The Messenger of Allah (may peace be upog him) then commanded to fast on that day till (fasting) in Ramadan became obligatory. Then the Messenger of Allah (may peace be upon him) said: He who wished to fast should do so. and he who wished to break it may do so.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2504]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2504

Abdullah b. 'Umar (Allah be pleased with them) reported that (the Arabs of) pre-Islamic days used to observe fast on the day of Ashura and the Messenger of Allah (may peace be upon him) observed it and the Muslims too (observed it) before fasting in Ramadan became obligatory. But when it became obligatory, the Messenger of Allah (may peace be upon him) said: 'Ashura is one of the days of Allah, so he who wished should observe fast and he who wished otherwise should abandon it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2505]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2505

A hadith like this has been narrated on the authority of Abdullah through the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2506]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2506

Ibn 'Umar (Allah be pleased with them) said that the day of 'Ashura was mentioned before the Messenger of Allah (may peace he upon him). Thereupon the Messenger of Allah, (may peace be upon him) said: That was a day on which the people of pre-Islamic days used to observe fast. So he who amongst you likes to observe fast should do so, and he who does not like it should abandon it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2507]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2507

Abdullah b. 'Umar (Allah be pleased with both of them) reported that he heard the Messenger of Allah (may peace be upon him) say about the day of Ashura: It is a day on which the people of pre-Islamic days observed fast. So he who liked to fast on this day should do so, and he who liked to abandon it should abandon it. 'Abdullah (Allah be pleased with him) did not observe fast except when it coincided (with the days when he was in the habit of observing voluntary fasts during every month).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2508]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2508

Abdullah b. Umar (Allah be pleased with them) reported that the day of 'Ashura was mentioned before the Apostle of Allah (may peace be upon him) and he narrated a hadith like one (narrated above).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2509]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2509

'Abdullah b. Umar (Allah be pleased with them) reported that the day of 'Ashura was mentioned before the Messenger of Allah (may peace be upon him) and he said: It is a day when the people in the pre-Islamic days need to observe fast, so he who wishes to observe fast should do so, and he who wishes to abandon it should do so.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2510]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2510

Abd al-Rahman b. Yazid said: When al-Ash'ath b. Qais entered the house of 'Abdullah he was having his breakfast. He ('Abdullah b. Umar) said: Abd Muhammad (al-Asha'th), come near to the breakfast. Thereupon he said: Is not today the day of 'Ashura? He ('Abd al-Rahman) said: Do you know what the day of 'Ashura is? He said: What is it? He said: It is a day on which the Messenger of Allah (may peace be upon him) used to observe fast before the (fasting) in the month of Ramadan (became) obligatory. But when it became obligatory the (fasting of 'Ashura) was abandoned (as compulsory). Abu Kuraib said: He (the Holy Prophet) abandoned it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2511]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2511

This hadith has been narrated from Jarir on the authority of A'mash with the same chain of transmitters and he said (these words with a little bit of variation from the previous hadith): When (fasting) in Ramadan was (made) obligatory, he aban- doned it (the practice of observing fast on Ashura).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2512]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2512

Qais b Sakan reported that al-Ash'ath b. Qais went to 'Abdullah on the day of 'Ashura while he was eating. He said: Abu Muhammad, come near and dine. Upon this he said: I am fasting. Thereupon he said: We used to observe fast and then (this practice) was abandoned.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2513]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2513

'Alqama reported that Ash'ath b. Qais went to Ibn Mas'udd while he was eating on the day of Ashura. Thereupon he said: Abu Abd al-Rahman, it is the day of 'Ashura (and you are eating). Upon this he said: Fast was observed on (this day) before the (fasting) in Ramadan was made obligatory, but when it was made obligatory, (fasting on the day of 'Ashura) was abandoned. So if you are not fasting, then take food.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2514]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2514

Jabir b Samura reported that the Messenger of Allah (may peace be upon him) commanded us to observe fast on the day of Ashura and exhorted us to do it and was particular about it But when (fasting) in Ramadan was made obligatory, he hence. forth neither commanded us nor forbade us, nor was he so particular about it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2515]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2515

Abd al-Rahman reported that he heard Mu'awiya b. Abu Sufyan delivering a sermon in Medina. i. e. when he came there (for Hajj). He delivered a sermon on the day of 'Ashura and said: People of Medina, where are your scholars? I heard the Messenger of Allah (may peace be upon him) say on this very day: It is the day of 'Ashura. Allah has not made fasting on This day obligatory for you but I am fasting. He who likes to observe fast among you should do so, and he who likes not to observe it may not observe it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2516]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2516

A hadith like this has been narrated on the authority of Ibn Shihab through the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2517]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2517

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters that be heard Allah's Apostle (may peace be upon him) as saying on a similar day: I am fasting today, so he who wishes to observe fast should do so; but he did not make mention of the rest of the hadith.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2518]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2518

Ibn Abbas (Allah be pleased with both of them) reported that when Allah's Messenger (may peace be upon him) came to Medina, he found the Jews observing the fast on the day of Ashura. They (the Jews) were asked about it and they said: It is the day on which Allah granted victory to Moses and (his people) Bani Isra'il over the Pharaoh and we observe fast out of gratitude to Him. Upon this the Apostle of Allah (may peace be upon him) said: We have a closer connection with Moses than you have, and he commanded to observe fast on this day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2519]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2519

This hadith has been narrated by Ibn Bishr with the same chain of trans- mitters (but with a slight variation) that he (the Holy Prophet) inquired of them (Jews) about it (fasting on the day of 'Ashura).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2520]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2520

Ibn'Abbas (Allah be pleased with both of them) reported that the Messenger of Allah (may peace be upon him) arrived in Medina and found the Jews observing fast on the day of 'Ashura. The Messenger of Allah (may peace be upon him) said to them: What is the (significance) of this day that you observe fast on it? They said: It is the day of great (significance) when Allah delivered Moses and his people, and drowned the Pharaoh and his people, and Moses observed fast out of gratitude and we also observe it. Upon this the Messenger of Allah (may peace be upon him) said: We have more right, and we have a closer connection with Moses than you have; so Allah's Messenger (may peace be upon him) observed fast (on the day of 'Ashura), and gave orders that it should be observed.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2521]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2521

This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2522]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2522

Abu Musa (Allah be pleased with him) reported: The day of 'Ashura was one which the Jews respected and they treated it as Id. The Messenger of Allah (may peace be upon him) said: You also observe fast on this day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2523]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2523

Abu Musa reported that the people of Khaibar (most of them were Jews) observed fast on tht day of 'Ashura and they treated it as 'Id and gave their women ornaments and beautiful dresstowear. The Messenger of Allah (may peace be upon him) said: You (only) observe fast on this day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2524]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2524

Ibn Abbas was asked about observing of fast on the day of Ashura, whereupon he said: I do not know Allah's Messenger (may peace be upon him) singling out any day's fast and considering it more excellent than another, except this day (the day of Ashura) and this month, meaning the month of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2525]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2525

A hadith like this has been narrated on the authority of 'Ubaidullah b. Abi Yazid.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2526]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2526

Hakam b. al-'Araj reported: I went to Ibn 'Abbas (Allah be Pleased with both of them) and he was reclining using his mantle as a pillow near the fountain of Zamzam. I said to him: Tell me about fasting on Ashura. He said: When you see the new moon of Muharram then count the (days) and observe fast on the 9th. I said to him: Is it how the Messenger of Allah (may peace be upon him) observed the fast? He said: Yes.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2527]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2527

Hakam b. 'Araj reported: I asked Ibn Abbas (Allah be pleased with them) as he was reclining using his cloak as a pillow near Zamzam about fasting on 'Ashura. The rest of the hadith is the same.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2528]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2528

Ibn 'Abbas reported that when the Messenger of Allah (may peace be upon him) fasted on the day of 'Ashura and commanded that it should he observed as a fast, they (his Companions) said to him: Messenger of Allah, it is a day which the Jews and Christians hold in high esteem. Thereupon the Messenger of Allah (may peace be upon him) said: When the next year comes, God willing, we would observe fast on the 9th But the Messenger of Allah (may peace be upon him) died before the advent of the next year.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2529]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2529

Abdullah b 'Abbas reported that the Messenger of Allah (may peace be upon him) had said: If I live till the next (year), I would definitely observe fast on the 9th, and the narration transmitted by Abu Bakr is:" He meant the day of Ashura."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2530]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2530

Salama b. al-Akwa' (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) sent a person of the tribe of Aslam on the day of 'Ashura and commanded him to declare to the people to observe fast in case they had not observed it, and to complete fast till evening if they had taken food


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2531]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2531

Rubayyi' daughter of Mu'awwidh b. 'Afra' said that the Messenger of Allah (may peace be upon him) sent (a person) on the morning of Ashura to the villages of Ansar around Medina (with this message): He who got up in the morning fasting (without eating anything) he should complete his fast, and he who had had his breakfast in the morning, he should complete the rest of the day (without food). The Companions said; We henceforth observed fast on it (on the day of 'Ashura) and, God willing, made our children observe that. We went to the mosque and made toys out of wool for them and when anyone felt hungry and wept for food we gave them these toys till it was the time to break the fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2532]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2532

Khalid b. Dhakwan reported: I asked Rubayyi' daugther of Mu'awwidh about fasting on the day of 'Ashura. Thereupon she said: The Messenger of Allah (may peace he upon him) sent his messenger to the villages of the Ansar, and the rest of the hadith is the same (but with this variation that one of the Companions) said:" We used to make toys out of wool and took (them to the mosque) along with us. When they (the children) asked us for food, we gave them these toys to play with, and these made them forgetful till they completed their fast."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2533]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2533

Abu Ubaid, the freed slave of Ibn Azhar, reported: I observed Id along with Umar b. al-Khattab (Allah be pleased with him). He came (out in an open space) and prayed and (after) completing it addressed the people and said: The Messenger of Allah (may peace be upon him) has forbidden the observing of fast on these two days. One is the day of Fitr (at the end of your fasts), and the second one, the day when you eat (the meat) of your sacrifices.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2534]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2534

Abu Huraira (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) forbade to observe fast on these two days. 'Id-ul-Adha bi and 'Id-ul-Fitr.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2535]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2535

Qaza'a related from Abu Sa'id. He said: I heard from him (Abu Sa'id) a hadith which impressed me, and I said to him: Did you hear it from the Messenger of Allah (may peace be upon him)? Thereupon he said: (Is it possible) that (I should) say about the Messenger of Allah (may peace be upon him) that which I have not heard? I heard him saying: It is not proper to fast on two days, Adha and Fitr (at the end) of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2536]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2536

Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) forbade to observe fast on two days the day of Fitr and the day of Sacrifice ('Id-ul-Adha).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2537]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2537

Ziyad b. Jubair reported that a person came to Ibn 'Umar (Allah be pleased with them) and said: I had taken a vow that I would fast on the day (but it accidentally) synchronises with the day of Adha or the day of Fitr. Thereupon Ibn 'Umar (Allah be pleased with him) said: Allah, the Exalted, has commanded fulfilling of the vow, but the Messenger of Allah (may peace be upon him) has forbidden the observance of fast on this day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2538]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2538

'A'isha (Allah be pleased with her) said that the Prophet (may peace be upon him) forbade to observe fast on two days-the day of Fitr and the day of Adha.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2539]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2539

Nubaisha al-Hudhali reported Allah's Messenger (may peace be upon him) as saying: The days of Tashriq are the days of eating and drinking.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2540]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2540

Nabaisha reported that Khalid said: I met Abu Malih and asked him and he narrated it to me from the Apostle of Allah (may peace be upon him). a hadith like one (narrated above) with this addition:" And remembrance of Allah"


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2541]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2541

Ibn Ka'b b. Malik reported on the authority of his father that the Messenger of Allah (may peace be upon him) sent him and Aus b. Hadathan during the days of Tashriq to make this announcement: None but the believer would be admitted into Paradise, and the days of Mina' are the days meant for eating and drinking.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2542]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2542

This hadith has been narrated on the authority of Ibrahim b. Tahman with the same chain of transmitters but with this variation that he said: Both of them made the announcement."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2543]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2543

Muhammad b. 'Abbas b. Ja'far reported: I asked Jabir b. 'Abdullah (Allah be pleased with both of them) as he was circumambulating the House (Ka'ba) whether the Messenger of Allah (may peace be upon him) had forbidden the fasting on Friday, whereupon he said: Yes, by the Lord of this House.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2544]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2544

Muhammad b. 'Abbas b. Ja'far reported that he asked Jabir b. Abdullah (Allah be pleased with them), whether he had heard like this from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2545]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2545

Abu Huraira (Allah be pleased with him) reported the Apostle of Allah (may peace be upon him) as saying: None among you should observe fast on Friday, but only that he observes fast before it and after it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2546]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2546

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Do not single out the night (preceding) Friday among the nights for prayer and do not single out Friday among days for fasting but only when anyone among you is accustomed to fast (on dates) which coincide with this day (Friday).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2547]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2547

Salama b. Akwa' (Allah be pleased with him) reported that when this verse was revealed:" And as for those who can fast (but do not) expiation is the feeding of a needy person" (ii. 183), (he who liked to observe fast did observe it) and he who felt reluctant to observe it ate and expiated till the verse was revealed which abro- gated it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2548]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2548

Salama b. Akwa' reported: We, during the lifetime of the Messenger of Allah (may peace be upon him), in one month of Ramadan (observed fast according to our liking). He who wished to fast lasted and he who wished to break broke it and fed a needy person as an expiation 1544 till this verse was revealed:" He who witnesses among you the month (of Ramadan) he should observe fast during it" (ii. 184).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2549]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2549

Abu Salama reported: I heard 'A'isha (Allah be pleased with her) as saying: I had to complete some of the fasts of Ramadan, but I could not do it but during the month of Sha'ban due to my duties to the Messenger of Allah (may peace be upon him) or with the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2550]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2550

This hadith is narrated on the authority of Yahya b. Sa'id with the same chain of transmitters but with this variation that he said that ('A'isha did not observe fast but in Sha'ban) out of regard for the Messenger of Allah (may peace be upon him). (In another version, the words are):" Yahya said: I think it was due to the regard for the Apostle of Allah (may peace be upon him)."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2551]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2551

This hadith is reported on the authority of Yahya with the same chain of transmitters but no mention is made of the duty to the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2552]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2552

'A'isha reported: If one amongst us had to break fasts (of Ramadan due to natural reasons, i. e. menses) during the life of the Messenger of Allah (may peace be upon him) she could not find it possible to complete them so long she had been in the presence of Allah's Messenger (may peace be upon him) till Sha'ban commenced.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2553]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2553

'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: If anyone dies in a state (that he had to complete) some fasts, his heir must fast on his behalf.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2554]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2554

Ibn 'Abbas (Allah be pleased with both of them) reported: A woman came to the Messenger of Allah (may peace be upon him) and said: My mother has died, and fasts of a month are due from her. Thereupon he said: Don't you see that if debt was due from her, would you not pay it? She said: Yes (I would pay on her behalf). Thereupon he said: The debt of Allah deserves its payment more than (the payment of anyone else).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2555]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2555

Ibn 'Abbas (Allah be pleased with them) reported: A man came to the Apostle of Allah (may peace be upon him) and said: Messenger of Allah, my mother has died (in a state) that she had to observe fasts of a month (of Ramadan). Should I complete (them) on her behalf? thereupon he (the Holy Prophet) said: Would you not pay the debt if your mother had died (without paying it)? He said: Yes. He (the Holy Prophet) said: The debt of Allah deserves more that it should he paid.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2556]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2556

This hadith has been narrated on the authority of Ibn 'Abbas (Allah be pleased with them) from the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2557]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2557

Ibn Abbas (Allah be pleased with them) reported: A woman came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, my mother has died and there is due from her a fast of vow; should I fast on her behalf? Thereupon he said: You see that if your mother had died in debt, would it not have been paid on her behalf? She said: Yes. He (the Holy Prophet) said: Then observe fast on behalf of your mother.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2558]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2558

Abdullah b. Buraida (Allah be pleased with him) reported on the authority of his father: When we were sitting with the Messenger of Allah (may peace be upon him), a woman came to him and said: I had gifted to my mother a maid-servant, and now she (the mother) has died. Thereupon he (the Holy Prophet) said: There is a definite reward for you and she (the maid-servant) has been returned to you as an inheritance. She (that woman) again said: Fasts of a month (of Ramadan) are due upon her; should I observe them on her behalf? He (the Holy Prophet) said: Observe fasts on her behalf. She (again) said: She did not perform Hajj, should I perform it on her behalf? He (the Holy Prophet) said: Perform Hajj on her behalf.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2559]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2559

'Abdullah b. Buraida (Allah be pleased with him) reported on the authority of his father: I was sitting with the Apostle of Allah (may peace be upon him) ; the rest of the hadith is the same but with this variation that the (the narrator) said:" Fasts of two months."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2560]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2560

Ibn Buraida (Allah be pleased with him) reported on the authority of his father: A woman came to the Apostle of Allah (may peace be upon him), and the rest of the hadith is the same, but he said:" Fasting of one month." This hadith has been narrated on the authority of Sufyan with the same chain of transmitters in which it is said:" Fasting of two months."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2561]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2561

Buraida (Allah be pleased with him) reported a similar hadith on the authority of his father that a woman came to the Apostle of Allah (may peace be upon him) and he said:" Fasting for one month."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2562]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2562

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: If any one of you is invited to a meal when he is fasting, he should say:" I am fasting."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2563]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2563

Abu Huraira (Allah be pleased with him) reported: When any one of you gets up in the morning in the state of fasting, he should neither use obscene language nor do any act of ignorance. And if anyone slanders him or quarrels with him, he should say:" I am fasting, I am fasting."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2564]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2564

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Majestic and the Exalted, said: Every act of the son of Adam is for him except fasting. It is done for My sake, and I will give a reward for it. By Allah in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah than the fragrance of musk.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2565]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2565

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Fasting is a shield.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2566]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2566

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah the Exalted and Majestic said: Every act of the son of Adam is for him, except fasting. It is (exclusively) meant for Me and I (alone) will reward it. Fasting is a shield. When any one of you is fasting on a day, he should neither indulge in obscene language, nor raise the voice; or if anyone reviles him or tries to quarrel with him he should say: I am a person fasting. By Him, in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah on the Day of judgment than the fragrance of musk. The one who fasts has two (occasions) of joy, one when he breaks the fast he is glad with the breaking of (the fast) and one when he meets his Lord he is glad with his fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2567]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2567

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Every (good) deed of the son of Adam would be multiplied, a good deed receiving a tenfold to seven hundredfold reward. Allah, the Exalted and Majestic, has said: With the exception of fasting, for it is done for Me and I will give a reward for it, for one abandons his passion and food for My sake. There are two occasions of joy for one who fasts, joy when he breaks it, and joy when he meets his Lord, and the breath (of an observer of fast) is sweeter to Allah than the fragrance of musk.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2568]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2568

Abu Huraira and Abu Sa'id (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) (as saying): Allah, the Exalted and Majestic, said: Fast (is exclusively) meant for Me and I would give its reward. There are two (occasions) of joy for the observer of fast. He feels joy when he breaks the fast and he is happy when he meets Allah. By Allah in Whose Hand is the life of Muhammad, the breath of the observer of fast is sweeter to Allah than the fragrance of musk. A hadith like this is narrated on the authority of Abu Sinan with the same chain of transmitters (and the words are):" As he meets Allah, He rewards him, and he is happy."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2569]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2569

Sahl b. Sa'd (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: In Paradise there is a gate which is called Rayyan through which only the observers of fast would enter on the Day on Resurrection. None else would enter along with them. It would be proclaimed: Where are the observers of fast that they should be admitted into it? -and when the last of them would enter, it would be closed and no one would enter it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2570]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2570

Abu Sa'id al Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Every servant of Allah who observes fast for a day in the way of Allah, Allah would remove, because of this day, his face farther from the Fire (of Hell) to the extent of seventy years' distance.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2571]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2571

This hadith has been narrated by Suhail with the, arne chainof trausmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2572]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2572

Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who observes fast for a day in the way of Allah He would remove his face from the Hell to the extent of seventy years' distance.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2573]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2573

'A'isha, the Mother of the Believers (Allah be pleased with her), reported that one day the Messenger of Allah tpay peace be upon him) said to me: 'A'isha, have you anything (to eat)? I said: 'Messenger of Allah, there is nothing with us. Thereupon he said: I am observing fast. She said: The Messenger of Allah (may peace be upon him) went out, and there was a present, for us and (at the same time) some visitors dropped in. When the Messenger of Allah (may peace be upon him) came back, I said to him: Messenger of Allah, a present was given to us, (and in the meanwhile) there came to us visitors (a major Portion of it has been spent on them), but I have saved something for you. He said: What is it? I said: It is hais (a compound of dates and clarified butter). He said: Bring that. So I brought it to him and he ate it and then said: I woke up in the morning observing fast. Talha said: I narrated this hadith to Mujahid and he said: This (observing of voluntary fast) is like a person who sets apart Sadaqa out of his wealth. He may spend it if he likes, or he may retain it if he so likes.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2574]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2574

'A'isha, the Mother of the Believers (Allah be pleased with her), reported: The Apostle of Allah (may peace be upon him) came to me one day and said: Is there anything with you (to eat)? I said: No. Thereupon he said: I shall then be fasting. Then he came to us another day and we said: Messenger of Allah, hais has been offered to us as a gift. Thereupon he said: Show that to me; I had been fasting since morning. He then ate it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2575]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2575

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If anyone forgets that he is fasting and eats or drinks he should complete his fast, for it is only Allah Who has fed him and given him drink.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2576]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2576

Abdullah b. Shaqiq reported: I said to'A'isha (Allah be pleased with her): Did the Apostle of Allah (may peace be upon him) observe fast for full one month besides Ramadan? She said: I do not know of any month in which he fasted through- out, but that of the month of Ramadan and (the month) in which he did not fast at all, till he ran the course of his life.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2577]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2577

'Abdullah b. Shaqiq reported: I said to 'A'isha (Allah be pleased with her): Did the Messenger of Allah (may peace be upon him) observe fast during a month? She said, I do not know of any month in which he fasted throughout except Ramedan and (the month) in which he did not fast at all till he ran the course of his life. May peace be upon him.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2578]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2578

Abdullah b. Shaqiq reported. I asked 'A'isha (Allah be pleased with her) about fasting of the Messenger of Allah (may peace be upon him). She said: He used to observe fast (at times) so continuously that we said: He has fasted, he has fasted. And (at times) he did not observe fast (for days) and we began to say: He has abandoned fasting, he has abandoned fasting. She said: I did not see him observing fast throughout the whole of the month since he arrived in Medina, but that of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2579]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2579

A hadith like this has been narrated on the authority of Abdullah b. Shaqiq but in the chain of transmitters no mention is made of Hisham and Muhammad.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2580]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2580

'A'isha, the Mother of the Believers (Allah be pleased with her), reported that the Messenger of Allah (may peace be upon him) used to observe fasts (so conti- nuously) that we said that he would not break, and did not observe (them) till we said that he would not fast: and I did not see the Messenger of Allah (may peace be upon him) completing the fast of a month, but that of Ramadan, and I did not see him fasting more in any other month than that of Sha'ban.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2581]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2581

Abu Salama reported: I asked 'A'isha (Allah be pleased with her) about the fasting of the Messenger of Allah (may peace be upon him). She said: He used to observe fast (at times so continuously) that we said: He has fasted (never to break), and he did not observe fast till we said: He has given up perhaps never to fast, and I never saw him observing (voluntary fasts) more in any other month than that of Sha'ban. (lt appeared as if) he observed fast throughout the whole of Sha'ban except a few (days).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2582]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2582

'A'isha (Allah be pleased with her) reported: The Messenger of Allah (may peace be upon him) did not observe fast in any month of the year more than in the month of Sha'ban, and used to say: Do as many deeds as you are capable of doing, for Allah will not become weary (of giving you reward), but you would be tired (of doing good deeds) ; and he also said: The deed liked most by Allah is one to which the doer adheres constantly even if it is small.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2583]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2583

Ibn Abbas (Allah be pleased with both of them) reported: The Messenger of Allah (may peace be upon him) did not fast throughout any month except during ramadan. And when he observed fast (he fasted so continuously) that one would say that he would not break (them) and when he Abandoned, he abandoned (so continuously) that one would say: By Allah, perhaps he would never fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2584]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2584

This hadith has been narrated on the authority of Abu Bishr with the same chain of transmitters (with a slight variation of words and these are), that he (the narrator) said:" During any month continuously since he came to Medina."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2585]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2585

'Uthman b. Hakim al-Ansari said: I asked Sa'id b. Jubair about fasting In Rajab, and we were then passing through the month of Rajab, whereupon he said: I heard Ibn 'Abbas (Allah be pleased with both of them) as saying: The Messenger of Allah (may peace be upon him) used to observe fast (so continuously) that we (were inclined) to say that he would not break (them) and did not observe them so conti- nuously) that we (were inclined to say) that he would not observe fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2586]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2586

Anas (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) used to observe fast till it was said that he had observed fast, he had observed fast (perhaps never to break it), and he did not fast till it was said that he had given up fast, he had given up fast (perhaps never to observe it).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2587]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2587

'Abdullah b. 'Amr b. al-'As reported that the Messenger of Allah (may peace be upon him) was informed that he could stand up for (prayer) throughout the night and observe fast every day so long as he lived. Thereupon the Messenger of Allah (may peace be upon him) said: Is it you who said this? I said to him: Messenger of Allah. it is I who said that. Thereupon the Messenger of Allah may peace be upon him) said: You are not capable enough to do so. Observe fast and break it; sleep and stand for prayer, and observe fast for three days during the month; for every good is multiplied ten times and this is like fasting for ever. I said: Messenger of Allah. I am capable of doing more than this. Thereupon he said: Fast one day and do not fast for the next two days. I said: Messenger of Allah, I have the strength to do more than that. The Holy Prophet (may peace be upon him), said: Fast one day and break on the other day. That is known as the fasting of David (peace be upon him) and that is the best fasting. I said: I am capable of doing more than this. Thereupon the Messenger of Allah (may peace be upon him) said: There is nothing better than this. 'Abdullah b. 'Amr (Allah be pleased with them) said: Had I accepted the three days (fasting during every month) as the Messeinger of Allah (may peace be upon him) had said, it would have been more dear to me than my family and my property.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2588]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2588

Yahya reported: I and 'Abdullah b. Yazid set out till we came to Abu Salama. We sent a messenger to him (in his house in order to inform him about our arrival) and he came to us. There was a mosque near the door of his house, and we were in that mosque, till he came out to us. He said: If you like you may enter (the house) and, if you like, you may sit here (in the mosque). We said: We would rather sit here and (you) relate to us. He (Yahya) then narrated that 'Abdullah b Amr b. al-'As (Allah be pleased with them) told him: I used to observe fast uninterruptedly and recited the (whole of the) Qur'an every night. It (the uninterrupted fasting and recital of the Qur'in every night) was mentioned to the Apostle of Allah (may peace be upon him) or he sent for me, and I went to him and he said to me: I have been informed that you fast continuously and recite (the whole of the Qur'An) every night. I said: Apostle of Allah, it is right, but I covet thereby nothing but good, whereupon he said: It suffices for you that you should observe fast for three days during every mouth. I said: Apostle of Allah, I am capable of doing more than this. He said: Your wife has a right upon you, your visitor has a right upon you, your body has a right upon you; so observe the fast of David, the Apostle of Allah (peace be upon him), for he was the best worshipper of Allah. I said: Apostle of Allah, what is the fast of David? He said: He used to fast one day and did not fast the other day. He (also) said: Recite the Qur'an during every month. I said: Apostle of Allah, I am capable of doing more than this, whereupon he said: Recite it in twenty days; recite it in ten days. I said: I am capable of doing more than this, whereupon he said: Recite it every week, and do not exceed beyond this, for your wife has a right upon you, your visitor has a right upon you, your body has a right upon you. He ('Amr b. 'As) said: I was hard to myself and thus I was put to hardship. The Apostle of Allah (may peace be upon him) had told me: 'You do not know you may live long (thus and bear the hardships for a long time), and I accepted that which the Apostle of Allah (may peace be upon him) had told me. When I grew old I wished I had availed myself of the conces- sion (granted by) the Apostle of Allah (may-peace be upon him). This hadith has been narrated by Yahya b. Abu Kathir with the same chain of transmitters and he made this addition after these words: During every month, (fasting) for three days, there is for you ten times for every good and that is perpetual fasting (for three days would bring a reward for full thirty days). I said: What is the fast of the Apostle of Allah, David? He said: Half of the age (observing fast on alternate days for the whole life). And in the hadith no mention has been made of the recital of the Qur'an, and he did not say: Your visitor has a right upon you, but (instead) he said: Your son has a right upon you.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2589]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2589

'Abdullah b. 'Amr (Allah be pleased with them) reported: The Messenger of Allah (may peace be upon him) said to me: Recite the whole of the Qur'An during every nonth. I said: I find power (to recite it) in a shorter period. He said: Then recite it in twenty nights. I said: I find power (to recite it in a shorter period even than this), whereupon he said: Then recite it in seven (nights) and do not exceed beyond it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2590]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2590

'Abdullah b. 'Amr b. al-'As (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said: 'Abdullah, don't be like so and so who observed prayer during the whole night and then abandoned it (altogether).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2591]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2591

Abdu'llah b. 'Amr b. 'As (Allah be pleased with them) reported: It was conveyed to the Apostle of Allah (may peace be upon him) that I observe fast succes- sively and pray during the whole night. He sent for me or I met him and he (the Holy Prophet) said: It has been conveyed to me that you observe fast continuously and do not break it and pray during the whole night. Don't do that. for there is share for your eyes, share for your own self, share for your family; so observe fast and break it, pray and sleep and observe fast for one day during the ten days, and there is a reward for you (for other) nine (days besides the tenth day of the fast). I said: Apostle of Allah, I find myself more powerful than this. He said: Then observe the fast of David (peace be upon him). He ('Amr) said: Apostle of Allah, how did David observe fast? He (the Holy Prophet) said: He used to fast one day and break it on the other day, and he did not run (from the battlefield) as he encountered (the enemy). He said: Apostle of Allah, who can guarantee this for me (will I also encounter the enemy dauntlessly)? 'Ata', the narrator of the hadith, said: I do not know how there (crept in) the matter of perpetual fast. The Apostle of Allah (may peace be upon him), however, said: He who observed perpetual fast did not fast at all; he who observed perpetual fast did not fast at all, he who observed perpetual fast did not fast at all. This hadith has been narrated by Ibn Juraij with the same chain of transmitters. Imam Muslim has narrated this hadith on the authority of Abu 'Abbas al-Sa'ib b. Farrukh and he was a trustworthy and reliable (narrator) among the people of Mecca.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2592]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2592

Abdullah b. Amr (Allah be pleased with both of them) reported: The Messenger of Allah (may peace be upon him) said to me: 'Abdullah b. Amr, you fast continuously and stand in prayer for the whole of night. If you do like that, your eyes would be highly strained and would sink and lose sight. There is no (reward for) fasting (for him) who fasts perpetually. Fasting for three days during the month is like fasting, the whole of the month. I said: I am capable of doing more than this, whereupon he said: Observe the fast of David. He used to fast one day and break (the other) day. And he did not turn back in the encounter.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2593]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2593

This hadith is narrated on the authority of Habib b. Abu Thabit with the same chain of transmitters and he said:" And you would become exhausted."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2594]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2594

'Abdullah b. 'Amr (Allah be pleased with both of them) reported: The Messenger of Allah (may peace be upon him) said to me: I have been informed that you stand for prayer the whole of night and fast during the day. I said: I do that, whereupon he said: If you did that you in fact strained heavily your eyes and made yourself weak. There is a right of your eyes (upon you) and a right of your self (upon you) and a right of your family (upon you). Stand for prayer and sleep. observe fasts and break (them).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2595]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2595

'Abdullah b. 'Amr (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: With Allah the best fasting is that of David and the best prayer is that of David (peace be upon him) for he slept half of the night and stood for prayer for the third of it and (then) slept the sixth part of it and he observed fast one day and broke on the other.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2596]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2596

'Abdullah b. 'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: The best fasting in the eye of Allah is that of David, for he fasted for half of the age (he fasted on alternate days), and the best prayer in the eye of Allah, the Exalted and Majestic, is that of David (peace be upon him), for he slept for half of the night and then stood for prayer and then again slept. He prayed for one-third of the night after midnight. He (the narrator) said: I asked 'Amr b. Dinar whether 'Amr b. Aus said that he stood for prayer one-third of the night after midnight. He said: Yes.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2597]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2597

Abu Qatada reported that Abu al Malih informed me: I went along with your father to 'Abdullah b. Amr, and he narrated to us that the Messenger of Allah (may peace be upon him) was informed about my fasting and he came to me, and I placed a leather cushion filled with fibre of date-palms for him. He sat down upon the ground and there was that cushion between me and him, and he said to me: Does three days' fasting in a month not suffice you? I said: Messenger of Allah, (I am capable of observing more fasts). He said: (Would) five (not suffice for you)? I said: Messenger of Allah, (I am capable of observing more fasts) He said: (Would) seven (fasts) not suffice you? I said: Messenger of Allah, (I am capable of observing more fasts). He (the Holy Prophet) then said: (Would) nine (fasts not suffice you)? I said: Messenger of Allah, (I am capable of observing more fasts). He said: (Would) eleven (fasts not suffice you)? I said: Messenger of Allah, (I am capable of observing more fasts than these). Thereupon the Apostle of Allah (may peace be upon him) said: There is no fasting (better than) the fasting of David which comprises half of the age, fasting a day and not fasting a day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2598]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2598

'Abdullah b. Amr (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) had said to him: Observe fast for a day and there would be reward for you for the rest (of the days). He said: I am capable of doing more than this. He then said: Observe fast for two days, and there would be reward for you for the rest (of the days). He said: I am capable of doing more than this. He (the Holy Prophet) said: Observe fast for three days and there would be reward for you for the rest of the days. He said: I am capable of doing more than this, whereupon he said: Observe fast for four days and there would be reward for you for the rest of the days. He said: I am capable of doing more than this. Thereupon he said: Then observe fast (which is the) best in the eye of Allah, the fast of David (peace be upon him) ; he used to observe fast one day and break on the other day.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2599]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2599

'Abdullah b. 'Amr (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said to me! 'Abdullah b. 'Amr, it has been conveyed to me that you observe fast during the day and stand in prayer during the whole night. Don't do that, for your body has a share of its own in you, your eye has a share of its own in you, your wife has a share of her own in you. Observe fast and break it too. Fast for three days in every month and that is a prepetual fasting. I said! Messenger of Allah, I have got strength enough (to do more than this), whereupon he said: Then observe the fast of David (peace be upon him). Observe fast one day and break it (on the other) day. And he ('Abdullah b. 'Amr) used to say: Would that I had availed myself of this concession.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2600]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2600

Mu'adha al-'Adawiyya reported that she asked 'A'isha, the wife of the Apostle of Allah (may peace be upon him), whether the Messenger of Allah (may peace be upon him) observed fasts for three days during every month. She said: Yes I said to her: Which were (the particular) days of the month on which he observed fast? She said: He was not particular about the days of the month on which to observe fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2601]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2601

'Imran b. Husain (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) said to him (or he said to another person and he was listening to it): O, so and so, did you observe fast in the middle of the month? He said: No. Thereupon he (the Messenger of Allah) said: When you break it, then observe fast for two days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2602]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2602

Abu Qatada reported that a person came to the Apostle of Allah (may peace be upon him) and said: How do you observe fast? The Messenger of Allah (may peace be upon him) felt annoyed. 1560 When 'Umar (Allah be pleased with him) noticed his annoyance, he said: We are well pleased with Allah as our Lord, with Islam as our Code of Life, and with Muhammad as our Prophet. We seek refuge with Allah from the anger of Allah and that of His Messenger. 'Umar kept on repeating these words till his (the Prophet's) anger calmed down. Then Umar said: Messenger of Allah. what is the position of one who perpetually observes fasts? Thereupon he said: He neither fasted nor broke it, or he said: He did not fast and he did not break it. He said: What about him who observes fast for two days and breaks one day. There- upon he said: Is anyone capable of doing it? He ('Umar) said: What is the position of him who observes fast for a day and breaks on the other day? Thereupon he (the Holy Prophet) said: That is the fast of David (peace be upon him). He ('Umar) said: What about him who observes fast one day and breaks it for two days. Thereupon he (the Messenger of Allah) said: I wish, I were given strength to observe that. Thereafter he said: The observance of three days' fast every Month and that of Ramadan every year is a perpetual fasting. I seek from Allah that fasting on the day of 'Arafa may atone for the sins of the preceding and the coming years. and I seek from Allah that fasting on the day of Ashura may atone for the sins of the preceding year.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2603]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2603

Abu Qatada al-Ansari (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) was asked about his fasting. The Messenger of Allah (may peace be upon him) felt annoyed. Thereupon 'Umar (Allah be pleased with him) said: We are pleased with Allah as the Lord, with Islam as our Code of Life, with Muhammad as the Messenger and with our pledge (to you for willing and cheerful submission) as a (sacred) commitment. He was then asked about perpetual fasting, whereupon he said: He neither fasted nor did he break it, or he did not fast and he did not break it. He was then asked about fasting for two days and breaking one day. He (the Holy Prophet) said: And who has strength enough to do it? He was asked about fasting for a day and breaking for two days, whereupon he said: May Allah bestow upon us strength to do it. He was then asked about fasting for a day and breaking on the other, whereupon he said: That is the fasting of my brother David (peace be upon him). He was then asked about fasting on Monday, whereupon he said: It was the day on which I was born. on which I was commissioned with prophethood or revelation was sent to me, (and he further) said: Three days' fasting every month and of the whole of Ramadan every year is a perpetual fast. He was asked about fasting on the day of 'Arafa (9th of Dhu'I-Hijja), whereupon he said: It expiates the sins of the preceding year and the coming year. He was asked about fasting on the day of 'Ashura (10th of Muharram), whereupon be said: It expiates the sins of the preceding year. (Imam Muslim said that in this hadith there is a) narration of Imam Shu'ba that he was asked about fasting on Monday and Thursday, but we (Imam Muslim) did not mention Thursday for we found it as an error (in reporting).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2604]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2604

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2605]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2605

This hadith has been narrated by Ghailan b. Jarir with the same chain of transmitters, but with one variation, that there has been made mention of Monday and not of Thursday.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2606]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2606

Abu Qatada Ansari (Allah be pleased with him) reported that Allah's Massenger (may peace be upon him) was asked about fasting on Monday, whereupon he said: It is (the day) when I was born and revelation was sent down to me.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2607]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2607

'Imran b. Husain (Allah be pleased with them) reported Allah's Messenger (may peace he upon him) having said to him or to someone else: Did you fast in the middle of Sha'ban? He said: No. Thereupon he (the Holy Prophet) said: If you did not observe fast, then you should observe fast for two days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2608]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2608

Imran b. Husain (Allah be pleased with them) reported that Allah's Apostle (way peace heupon him) said. to a person: Did you observe any fast in the middle of this month (Sha'ban)? He said: No. Thereupon the Messenger of Allah (may peace be upon him) said: Fast for two days instead of (one fast) when you have completed (fasts of) Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2609]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2609

'Imran b. Husain (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) said to a person: Did you observe fast in the middle of this month. i. e. Sha'ban? He said: No. Thereupon he said to him: When it is the end of Ramadan, then observe fast for one day or two (Shu'ba had some doubt about it) but he said: I think that he has said: two days.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2610]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2610

This hadith is narrated by 'Abdullah b. Hani b. Akhi Mutarrif with the same chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2611]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2611

Abu Haraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The most excellent fast after Ramadan is God's month. al-Muharram, and the most excellent prayer after what is prescribed is prayer during the night.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2612]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2612

Abu Huraira (Allah be pleased with him) reported that he (the Messenger of Allah) was asked as to which prayer was most excellent after the prescribed prayer, and which fast was most excellent after the month of Ramadan. He said: Prayer offered in the middle of the night and the most excellent fast after (fasting) in the month of Ramadan is the fast in God's month al-Muharram.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2613]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2613

A hadith like this has been reported from the Apostle of Allah (may peace be upon him) by 'Abd al-Malik with the same chain of transmitters in connection with fast.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2614]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2614

Abu Ayyub al-Ansari (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who observed the fast of Ramadan and then followed it with six (fasts) of Shawwal. it would be as if he fasted perpetually.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2615]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2615

Abu Ayyub al-Ansari reported (through another chain of transmitters): I heard Allah's Messenger (may peace be upon him) saying like this.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2616]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2616

Abu Ayyub reported a hadith like this (through another chain of transmitters).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2617]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2617

Ibn 'Umar (Allah be pleased with them) reported that some persons among the Companions of the Apostle of Allah (may peace be upon him) were shown Lailat- ul-Qadr while sleeping in the last week (of Ramadan). Thereupon Allah's Messenger (may peace be upon him) said: I see that your dreams agree regarding the last week; so he who wants to seek it should seek it in the last week (during the night).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2618]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2618

Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Seek Lailat-ul-Qadr in the last week (of Ramadan).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2619]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2619

Salim reported on the authority of his father that a person saw Lailat-ul- Qadr on the 27th (of Ramadan). Thereupon Allah's Apostle (may peace be upon him) said: I see that your dreams agree regarding the last ten (nights of Ramadan). So seek it on an odd number (of these ten nights).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2620]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2620

Salim b. 'Abdullah b. 'Umar reported that his father said: I heard Allah's Messenger (may peace be upon him) as saying: So far as Lailat-ul-Qadr is concerned. some persons among you have seen it (in a dream) in the first week and some persons among you have been shown that it is in the last week; so seek it in the last ten (nights).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2621]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2621

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Seek it (Lailat-ul-Qadr) in the last (ten nights). If one among you shows slackness and weakness (in the earlier part of Ramadan), it should not be allowed to prevail upon him in the last week.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2622]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2622

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who is anxious to seek it (Lailat-ul-Qadr) should seek it in the last ten (nights of Ramadan).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2623]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2623

'Ibn 'Umar (Allah be pleased with both of them) reported Allah's Messenger (may peace be upon him) as saying: Seek the time of Lailat-ul-Qadr in the last (ten nights), or he said: in the last nine (nights).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2624]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2624

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: I was shown Lailat-ul-Qadr; then some members of my family awoke me up, then I was caused to forget it. So seek it in the last week. Harmala said: (The Holy Prophet did not say:" I was made to forget," but he stated):" But I forgot it."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2625]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2625

Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) spent in devotion (in i'tikaf) the middle ten nights of the month of Ramadan, and when twenty nights were over and it was the twenty-first night, he went back to his residence and those who were along with him also returned (to their respective residences). He spent one month in devotion. Then he addressed the people on the night he came back (to his residence) and commanded them as Allah desired (him to command) and then said: I used to devote myself (observe i'tikaf) during these ten (nights). Then I started devoting myself in the last ten (nights). And he who desires to observe i'tikaf along with me should spend the night) at his place of i'tikaf. And I saw this night (Lailat-ul-Qadr) but I forgot it (the exact night) ; so seek it;In the last ten nights on odd numbers. I saw (the glimpses of that dream) that I was prostrating in water and mud. Abu Sa'id al-Khudri said: It rained on the twenty-first night and the water dripped (from the roof) of the mosque at the place where the Messenger of Allah (may peace be upon him) observed prayer. I looked at him and as he completed the dawn prayer, (I found) his face was wet with mud and water.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2626]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2626

Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) devoted (himself to prayer) in the middle (ten nights) of Ramadan. The rest of the hadith is the same except for these words:" That he adhered to his place of i'tikaf and his forehead was besmeared with mud and water."


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2627]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2627

Abu Sa'id al-Khudri (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) observed i'tikaf (confined himself for devotion and prayer) in the first ten (days) of Ramadan; he then observed i'tikaf in the middle ten (days) in a Turkish tent with a mat hanging at its door. He (the Holy Prophet) took hold of that mat and placed it in the nook of the tent. He then put his head out and talked with people and they came near him, and he (the Holy Prophet) said: I observed i'tikaf in the first ten (nights and days) in order to seek that night (Lailat-ul-Qadr). I then observed i'tikaf in the middle ten days. Then (an angel) was sent to me and I was told that this (night) is among the last ten (nights). He who among you likes to observe i'tikaf should do so; and the people observed it along with him, and he (the Holy Prophet) said: That (Lailat-ul-Qadr) was shown to me on an odd (night) and I (saw in the dream) that I was prostrating in the morning in clay and water. So in the morning of the twenty-first night when he (the Holy Prophet) got up for dawn (prayer). there was a rainfall and the mosque dripped, and I saw clay and water. When he came out after completing the morning prayer (I saw) that his forehead and the tip of his nose had (traces) of clay and water, and that was the twenty-first night among the last ten (nights).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2628]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2628

Abu Salama reported: 'We discussed amongst ourselves Lailat-ul-Qadr. I came to Abu Sa'id al-Khudri (Allah be pleased with him) who was a friend of mine and said to him: Would you not go with us to the garden of date trees? He went out with a cloak over him. I said to him: Did you hear the Messenger of Allah (may peace be upon him) making mention of Lailat-ul-Qadr? He said: Yes, (and added) we were observing i'tikaf with the Messenger of Allah (may peace be upon him) in the middle ten days of Ramadan, and came out on the morning of the twentieth and the Messenger of Allah (may peace be upon him) addressed us and said: I was shown Lailat-ul-Qadr, but I forgot (the exact night) or I was caused to forget it, so seek it in the last ten odd (nights), and I was shown that I was prostrating in water and clay. So he who wanted to observe i'tikaf with the Messenger of Allah (inay peace be upon him) should return (to the place of i'tikaf). He (Abu Sa'id al-Khudri) said: And we returned and did not find any patch of cloud in the sky. Then the cloud gathered and there was (so heavy) a downpour that the roof of the mosque which was made of the branches of date-palms began to drip. Then there was prayer and I saw the Messenger of Allah (may peace be upon him) prostrating in water and clay till I saw the traces of clay on his forehead.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2629]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2629

This badith has been reported on the authority of Yahya b. Abu Kathir with the same chain of transmitters (with a slight variation of these words): I saw the Messenger of Allah (may peace be upon him) after he had completed (the prayer) and there was a trace of clay on his forehead and tip (of the nose).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2630]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2630

Abu Sa'id al-Khudri (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) observed i'tikaf in the middle ten days of Ramadan to seek Lailat-ul-Qadr before it was made manifest to him. When (these nights) were over, he commanded to strike the tent. Then it was made manifest to him that (Lailat-ul-Qadr) was in the last ten nights (of Ramadan), and commanded to pitch the tent (again). He then came to the people and said: O people, Lailat-ul-Qadr was made manifest to me and I came out to inform you about it that two persons came contend- ing with each other and there was a devil along with them and I forgot it. So seek it in the last ten nights of Ramadan. Seek it on the ninth, on the seventh and on the fifth. I (one of the narrators) said: Abu Sa'id, you know more than us about numbers. He said: Yes, indeed we have better right than you. I said: What is this ninth, seventh, and fifth? He said: When twenty-one (nights are over) and the twenty-second begins, it is the ninth, and when twenty-three (nights) are over, that which follows (the last night) is the seventh, and when twenty-five nights are over, what follows it is fifth. Ibn Khallad said: Instead of the word Yahliqan (contending), he said Yakhtasiman, (they are disputing).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2631]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2631

'Abdullah b. Unais reported Allah's Messenger (may peace beupon him) as saying: I was shown Lailat-ul-Qadr; then I was made to forget it, and saw that I was prostrating in water and clay in the morning of that (night). He (the narrator) said: There was a downpour on the twenty-third night and the Messenger of Allah (may peace be upon him) led us in prayer, and as he went back, there was a trace of water and clay on his forehead and on his nose. He (the narrator) said: 'Abdullah b. Unais used to say that it was the twenty-third (night).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2632]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2632

'A'isha (Allah be pleased with her) and Ibn Numair reported Allah's Mes- senger (may peace be upon him) as saying: Look for (and in the words of Waki, seek) Lailat-ul-Qadr in the last ten nights of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2633]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2633

Zirr b. Habaish reported: I thu asked Ubayy b. Ka'b (Allah be pleased with him): Your brother (in faith) Ibn Mas'ud says: He who stands (for the night prayer) throughout the year would find Lailat-ul-Qadr, whereupon he said: May Allah have mercy upon him; (he said these words) with the intention that people might not rely only (on one night), whereas he knew that it (Lailat-ul-Qadr) is in the month of Ramadan and it is the twenty-seventh night. He then took oath (without making any exception, i. e. without saying Innsha Allah) that it was the twenty-seventh night. I said to him: Abu Mundhir, on what ground do you say that? Thereupon he said: By the indication or by the sign which the Messenger of Allah (may peace be upon him) gave us, and that is that on that day (the sun) would rise without having any ray in it.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2634]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2634

Zirr b. Hubaish reported that Ubayy b. Ka'b (Allah be pleased with him) said about Lailat-ul-Qadr: By Allah, I know well about it. Shu'ba said: To the best of my knowledge it was the twenty-seventh night for which the Messenger of Allah (may peace be upon him) commanded us to stand for prayer. Shu'ba doubted these words: That it was the night for which the Messenger of Allah (may peace be upon him) commanded us to stand for prayer. And (he further) said: This was narrated to me by a friend of mine from him (the Holy Prophet).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2635]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2635

Abu Huraira (Allah be pleased with him) reported: We were talking about Lailat-ul-Qadr in the presence of the Messenger of Allah (may peace be upon him) and he said: He who amongst you remembers (the night) when the moon arose and it was like a piece of plate (at the fag end of the month in a state of waning).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2636]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2636

Ibn 'Umar (Allah be pleased with both of them) reported that the Apostle of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2637]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2637

Abdullah b. Umar (Allah be pleased with both of them) reported that the Messenger of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan. Nafi' said: Abdullah (Allah be pleased with him) showed me the place in the mosque where the Messenger of Allah (may peace be upon him) used to observe i'tikaf.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2638]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2638

'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) used to observe i'tikaf in the last ten days of Ramadan.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2639]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2639

This hadith has been narrated by 'A'isha (Allah be pleased with her) through another chain of transmitters.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2640]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2640

'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace he upon him) used to observe i'tikif in the last ten days of Ramadan till Allah called him back (to his heavenly home). Then his wives observed i'tikaf after him.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2641]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2641

'A'isha (Allah be pleased with her) reported that when the Messenger of Allah (may peace be upon him) decided to observe i'tikaf, he prayed in the morning and then went to the place of his i'tikaf, and he commanded that a tent should be pitched for him, and it was pitched. He (once) decided to observe i'tikaf in the last ten days of Ramadan. Zainab (the wife of the Holy Prophet) commanded that a tent should be pitched for her. It was pitched accordingly. And some other wives of Allah's Apostle (may peace be upon him) commanded that tents should be pitched for them too. And they were pitched. When the Messenger of Allah (may peace he upon him) offered the morning prayer, he looked and found (so many) tents. Thereupon he said: What is this virtue that these (ladies) have decided to acquire? He commanded his tent to be struck and abandoned i'tikaf in the month of Ramadan and postponed it to the first ten days of Shawwal.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2642]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2642

This hadith has been reported through another chain of transmitters, and there it is mentioned that. 'A'isha, Hafsa and Zainab (Allah be pleased with them) pitched the tents for i'tikaf.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2643]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2643

'A'Isha (Allah be pleased with her) reported that when the last ten nights began Allah's Messenger (may peace be upon him) kept awake at night (for prayer and devotion), wakened his family, and prepared himself to observe prayer (with more vigour).


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2644]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2644

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) used to exert himself in devotion during the last ten nights to a greater extent than at any other time.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2645]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2645

'A'isha (Allah be pleased with her) reported: I never saw the Messenger of Allah (may peace be upon him) fasting in the ten days of Dhu'I-Hijja.


Muslim :: The Book of Fasting (Kitab Al-Sawm) :: [6.2646]

The Book of Fasting (Kitab Al-Sawm)

Muslim :: Book 6 : Hadith 2646

'A'isha (Allah be pleased with her) reported: The Apostle of Allah (may peace be upon him) did not observe fast in the ten days of Dhul-Hijja.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2647]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2647

Ibn 'Umar (Allah be pleased with them) reported that a person asked the Messenger of Allah (may peace be upon him) what a Muhrim should put on as dress. Thereupon the Messenger of Allah (may peace be upon him) said: Do not put on a shirt or a turban, or trousers or a cap, or leather stockings except one who does not find shoes; he may put on stockings but he should trim them below the ankles. And do not wear clothes to which saffron or wars is applied.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2648]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2648

Salim reported on the authority of his father ('Abdullah b. 'Umar) that the Apostle of Allah (may peace be upon him) was asked what a Muhrim should wear, whereupon he said: A Muhrim should not wear a shirt, or a turban, or a cap, or trousers, or a cloth touched with wars or with saffron, nor (should he wear) stock- ings, but in case he does not find shoes, but (before wearing stockings) be should trim them (in such a way) that these should become lower than the ankles.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2649]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2649

Ibn 'Umar reported that the Messenger of Allah (may peace be upon him) forbade the Muhrim to put on a cloth dyed in saffron or wars and he further said: One who does not find shoes (to wear) he way wear stockings, but (only) after trimming them below the ankles.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2650]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2650

Ibn 'Abbas (Allah be pleased with both of them) reported: I heard Allah's Messenger (may peace be upon him) say as he was delivering an address: So far as the trousers are concerned, one who does not find lower garment, he may wear them; as also socks, he may wear them who does not find shoes. It concerns the Muhrim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2651]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2651

'Amr b. Dinar narrated with the same chain of transmitters that he heard the Messenger of Allah (may peace be upon him) delivering sermon at 'Arafat, and he made a mention of this hadith (as quoted above).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2652]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2652

This hadith has been narrated on the authority of 'Amr b. Dinar with the same chain of transmitters, but none of them (the narrators) made a mention that he (the Holy Prophet) was delivering address at 'Arafia except Sbu'ba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2653]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2653

Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who does not find shoes to wear may wear socks, and he who does not find lower garment to wear may put on trousers.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2654]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2654

Ya'la b. Umayya reported on the authority of his father (Allah be pleased with them) that a person came to the Apostle of Allah (may peace be upon him) as he was at Ji'rana and he (the person) had been putting on a cloak which was perfumed, or he (the narrator) said: There was a trace of yellowness on it. He said (to the Holy Prophet): What do you command me to do during my Umra? (It was at this juncture) that the revelation came to the Apostle of Allah (way peace be upon him) and he was covered with a cloth, and Ya'la said: Would that I see revelation coming to the Apostle of Allah (may peace be upon him). He (Hadrat 'Umar) said: Would it please you to see the Apostle of Allah (may peace be upon him) receiving the revelations 'Umar lifted a corner of the cloth and I looked at him and he was emitting a sound of snorting. He (the narrator) said: I thought it was the sound of a camel. When he was relieved of this he said: Where is he who asked about Umra? When the person came, the Holy Prophet (may peace be upon him) said: Wash out the trace of yellowness, or he said: the trace of perfume and put off the cloak and do in your 'Umra what you do in your Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2655]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2655

Safwan b. Ya'la reported on the authority of his father (who said): A person came to the Apostle of Allah (may peace be upon him) as he was staying at Ji'rana and I (the narrator's father) was at that time in the apostle's (may peace be upon him) company and (the person) was donning a cloak having the marks of perfume on it, and he said: I am in a state of Ihram for the sake of Umra, and it (this cloak) is upon me and I am perfumed. The Apostle of Allah (may peace be upon him) said to him: What would you do in your Hajj? He said: I would take off the clothes and would wash from me this perfume. Thereupon the Apostle of Allah (may peace be upon him) said: What you do in your Hajj do it in your Umra.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2656]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2656

Safwan b. Ya'la b. Umayya reported that Ya'la used to say to 'Umar b. Khattab (Allah be pleased with him): Would that I see revelation descending upon the Apostle of Allah (may peace be upon him). (Once) when the Apostle of Allah (may peace be upon him) was in Ji'rana and there was a cloth which provided shade over him, and there were his Companions with him. 'Umar being one of them, there came a person with a cloak of wool on him daubed with perfume and he said: Messenger of Allah, what about the person who, entered upon the state of Ihram with a cloak after daub- ing it with perfume? The Apostle of Allah (may peace be upon him) looked at him for a short while, and then became quiet, and revelation began descending upon him, and 'Umar gestured (with his hand) to Ya'la b Umayya to come. Ya'la came and he enter- ed his head (beneath the cloth and saw) the Apostle of Allah (may peace be upon him) with his face red, and breathing with a snore. Then he felt relieved (of that burden) and he said: Where is the man who was just asking me about Umra? The man was searched for and he was brought, and the Apostle of Allah (may peace be upon him) said: So far as the perfume is concerned, wash it three times, and remove the cloak too (as it was sewn) and do in 'Umra as you do in Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2657]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2657

Ya'la b. Umayya (Allah be pleased with him) reported that a person came to the Apostle of Allah (may peace be upon him) as he was staying at Ji'rana and he had put on Ihram for 'Umra and he had dyed his beard and his head with yellow colour and there was a cloak on him. He said: I put on Ihram for 'Umra and I am in this state as you see (with dyed beard and head and a cloak over me). He (the Holy Prophet) said: Take off the cloak and wash the yellowness and do in your 'Umra what you do in Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2658]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2658

Ya'la reported: We were with the Messenger of Allah (may peace be upon him) that a person came to him with a cloak on him having the traces of scent. He said, Messenger of Allah, I put on Ihram for 'Umra: what should I do? He (the Holy Prophet) kept quiet and did not make him any reply. And 'Umar screened him and it was (usual) with 'Umar that when the revelation descended upon him, he provided him shade (with the help of a piece of cloth). I (the person who came to the Holy Prophet) said: I said to 'Umar I wish to project my head into the cloth (to see how the Holy Prophet receives revelation). So when the revelation began to descend upon him 'Umar wrapped him (the Holy Prophet) with cloth I came to him and projected my head with him into the cloth, and saw him (the Holy Prophet) (receiving the revelation). When he (the Holy Prophet) was relieved (of its burden), he said: Where is the inquirer who was just inquiring about 'Umra? That man came to him. Thereupon he (the Apostle of Allah) said: Take off the cloak from (your body) and wash the traces of perfume which were upon you, and do in 'Umra what you did in Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2659]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2659

Ibn 'Abbas (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) specified Dhu'l-Hulaifa, for the people of Medina; Juhfa for the people of Syria; Qarn al-Manazil, for the people of Najd; Yalamlam for the people of Yemen (the Mawaqit) and those (Mawaqit) are also meant for those who live at these (places) and for those too who come from without towards them for the sake of Hajj or 'Umra. And those who live within them (within the bounds of these places) or in the suburbs of Mecca or within Mecca, they should enter upon the state of Ihram at these very places.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2660]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2660

Ibn 'Abbas (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) specified Dhu'l-Hulaifa for the people of Medina; Juhfa for the people of Syria, Qarn al-Manazil for the people of Najd, Yalamlam for the people of Yemen (as their respective Mawaqit), and he also said: These are (Mawaqit) of them too (who live there) and everyone who comes from outside (through) their (directions) for the sake of Hajj and 'Umra and for those who live within (those bounds their Miqat is that) from which they commenced (their journey), and for the people of Mecca, Mecca itself is (the Miqat).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2661]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2661

Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) said: The people of Medina should enter upon the state of Ihram at Dhu'l-Hulaifa, and people of Syria at Juhfa, and people of Najd at Qarn (al-Manazil), and 'Abdullah (further) said: It has reached me that the Messenger of Allah (may peace be upon him) also caid: The people of Yemen should enter upon the state of Ihram at Yalamlam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2662]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2662

Salim reported on the authority of his father ('Abdullah b. 'Umar) that the Messenger of Allah (may peace be upon him) said: The people of Medina should enter upon the state of Ihram at Dhu'l-Hulaifa; the people of Syria at Juhfa, the people of Najd at Qarn (al-Manazil). Ibn 'Umar (Allah be pleased with them) said: It was mentioned to me but I did not myself bear it (directly) from the Messenger of Allah (may peace be upon him) having said this: The people of Yemen should enter upon the state of Ihram at Yalamlam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2663]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2663

Salim b. 'Abdullah b. 'Umar b. al-Khattab (Allah be pleased with them) reported his father as saying: I heard the Messenger of Allah (may peace be upon him) as saying that the people of Medina should enter upon the state of Ihram at Dhu'l- Hulaifa, the people of Syria at Mahya'a and that is Juhfa, and the people of Najd at Qarn (al-Manazil). 'Abdullah b. 'Umar (Allah be pleased with them) said: (I did not hear it myself from him) but heard from them saying that the Messenger of Allah (may peace be upon him) had (also) said: The people of Yemen should enter upon the state of Ihram at Yalamlam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2664]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2664

Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) had commanded the people of Medina to enter upon the state of Ihram at Dhu'l-Hulaifa; the people of Syria at Juhfa; the people of Najd at Qarn (al-Manazil). 'Abdullah b. 'Umar (Allah be pleased with them) said: I was informed that he said that the people of Yemen should enter upon the state of Ihram at Yalamlam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2665]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2665

Abu Zubair reported that he heard Jabir b. 'Abdullah (Allah be pleased with them) saying that as he was asked about (the places for entering upon the) state of ihram, he said: I heard (and he then carried the narration directly, I think to) the Apostle of Allah (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2666]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2666

Abu Zubair heard Jabir b. 'Abdullah (Allah be pleased with them) as saying as he was asked about (the place for entering upon the) state of Ihram: I heard (and I think he carried it directly to the Apostle of Allah) him saying: For the people of Medina Dhu'l-Hulaifa is the place for entering upon the state of Ihram, and for (the people coming through the other way, i. e. Syria) it is Juhfa; for the people of Iraq it is Dbat al-'Irq; for the people uf Najd it is Qarn (al-Manazil) and for the people of Yemen it is Yalamlam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2667]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2667

'Abdullah b. 'Umar (Allah be pleased with them) reported that the Talbiya of the Messenger of Allah (may peace be upon him) was this: Here I am at Thy service. O Allah, here I am at Thy service, here I am at Thy service. There is no associate with Thee; here I am at Thy service. Verily all praise and grace is due to Thee, and the sovereignty (too). There is no associate with Thee. He (the narrator) further said that 'Abdullah b. 'Umar (Allah be pleased with them) made this addition to it: Here I am at Thy service; here I am at Thy service; ready to obey Thee, and good is in Thy Hand; here 1 am at Thy service; unto Thee is the petition, and deed (is also for Thee).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2668]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2668

'Abdullah b. 'Umar (Allah be pleased with them) reported that the Mes- senger of Allah (may peace be upon him) entered upon the state of Ihram near the mosque at Dhu'l-Hulaifa as his camel stood by it and he said: Here I am at Thy service, O Lord; here I am at Thy service: here I am at Thy service. There is no associate with Thee. Here I am at Thy service. All praise and grace is due to Thee and the sovereignty (too). There is no associate with Thee. They (the people) said that 'Abdullah b. 'Umar said that that was the Talbiya of the Messenger of Allah (may peace be upon him). Nafi' said: 'Abdullah (Allah be pleased with him) made this addition to it: Here I am at Thy service; here I am at Thy service; ready to obey Thee. The Good is in Thy Hand. Here I am at Thy service. Unto Thee is the petition and deed (is also for Thee).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2669]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2669

Ibn 'Umar (Allah be pleased with him) reported: I immediately learnt Talbiya from the Messenger of Allah (may peace be upon him), and he then narrated the hadith.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2670]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2670

'Abdullah b. 'Umar (Allah be pleased with them) reported: I heard the Messenger of Allah (may peace be upon him) pronouncing Talbiya with compacted hair: Here I am at Thy service. O Allah: here I am at Thy service; here I am at Thy service. There is no associate with Thee; here I am at Thy service. Verily all praise and grace is due to Thee and the Sovereignty (too). There is no associate with Thee; and he did not make any addition to these words. 'Abdullah b. 'Umar (Allah be pleased with them) (further) said: The Messenger of Allah (may peace be upon him) used to offer two rak'ahs of prayer at Dhu'l-Hulaifa and then when his camel stood up with him on its back near the mosque at Dhu'l-Hulaifa, he pronounced these words (of Talbiya). And 'Abdullah b. 'Umar (Allah be pleased'with them) said that 'Umar b. Khattab (Allah be pleased with him) pronounced, the Talbiya of the Messenger of Allah (may peace be upon him) in these words of his (Prophet's words) and said: Here I am at Thy service, O Lord; here I am at Thy service, ready to obey Thee, and good is in Thy Hand, Here I am at Thy service. Unto Thee is the petition and deed (is also for Thee).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2671]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2671

Ibn 'Abbas (Allah be pleased with them) reported that the polytheists also pronounced (Talbiya) as: Here I am at Thy service, there is no associate with Thee. The Messenger of Allah (may peace be upon him) said: Woe be upon them, as they also said: But one associate with Thee, you possess mastery over him, but he does not possess mastery (over you). They used to say this and circumambulate the Ka'ba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2672]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2672

Salim b. 'Abdullah (Allah be pleased with them) reported that he heard his father saying: This place Baida' is for you that about which you attribute lie to the Messenger of Allah (may peace be upon him). And the Messenger of Allah (may peace be upon him) did not enter upon the state of Ihram but near the mosque at Dhu'l- Hulaifa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2673]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2673

Salim reported that when it was said to Ibn 'Umar (Allah be pleased with them) that the state of Ihram (commences from) al-Baida' he said: Al-Baida', you attribute lie about it to the Messenger of Allah (may peace be upon him). And the Messenger of Allah (mav peace be upon him) did not enter upon the state of Ihram but near the-tree when his camel stood up with him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2674]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2674

'Ubaid b. Juraij said to 'Ahdullah b. 'Umar (Allah be pleased with them): 'Abd al-Rahman, I find you doing four things which I do not see anyone among your companions doing. He said: Son of Juraij, what are these? Thereupon he said: You (while circumambulating the Ka'ba) do not touch but the two pillars situated on the side of yaman (south), and I find you wearing the sandals of tanned leather, and I find you with dyed beard and head, and I also found that, when you were at Mecca, the people pronounced Talbiya as they saw the new moon (Dhu'l-Hijja), but you did not do it till the 8th of Dhu'l-Hijja. Upon this 'Abdullab b. 'Umar said: (So far as the touching of) the pillars is concerned, I did not see the Messenger of Allah (may peace be upon him) touching them but only those situated on the side of yaman. (So far asthe wearing of) the shoes of tanned leather is concerned, I saw the Messenger of Allah (may peace be upon him) wearing shoes without hair on them, and he (wore them with wet feet) after performing ablution, and I like to wear them. So far as the yellowness is concerned, I saw the Messenger of Allah (may peace be upon him) dyeing (head, beard and cloth) with this colour and I love to dye (my head, beard or cloth) with this colour. And so far as the pronouncing of Talbiya is concerned, I did not see the Messenger of Allah (may peace be upon him) pronouncing it until his camel proceeded on (to Dhu'l-Hulaifa).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2675]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2675

'Ubaid b. Juraij reported: I remained in the company of 'Abdullah b. 'Umar b. al-Khattab (Allah be pleased with them) its twelve Hajjs and 'Umras and I said to him: I saw four characteristics (peculiar in you), and the rest of the hadith is the same except the case of Talbiya. There he offered the narration given by al-Maqburi and he stated the facts excepting the one given above.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2676]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2676

Ibn 'Umar (Allah be pleased with them) reported that the Messenger of Allah (may peace be upon him) pronounced Talbiya in Dhu'l-Hulaifa as he put his feet in the stirrup and his camel stood up and proceeded.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2677]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2677

Ibn 'Umar (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) pronounced Talbiya as his camel stood up.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2678]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2678

'Abdullah b. 'Umar reported: I saw the Messenger of Allah (may peace be upon him) riding on his camel at Dhu'l-Hulaifa and pronouncing Talbiya as it stood up with him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2679]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2679

'Abdullah b. 'Umar (Allah be pleased with them) reported that the Mes- senger of Allah (may peace be upon him) spent the night at Dhu'l-Hulaifa while com- mencing (the rites of) Pilgrimage and he observed prayer in the mosque.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2680]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2680

'A'isha (Allah be pleased with her) reported: I applied perfume to the Messenger of Allah (may peace be upon him) before he entered upon the state of lhram and (concluding) before circumambulating the (sacred) House.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2681]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2681

'A'isha (Allah be pleased with her), the wife of the Apostle of Allah (may peace be upon him), reported: I applied perfume to the Messenger of Allah (may peace be upon him) with my own hand before he entered upon the state of Ihram, and as he concluded it before-circumambulating the House (for Tawaf-i-lfada).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2682]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2682

'A'isha (Allah be pleased with her) reported: I used to apply perfume to the Messenger of Allah (may peace be upon him) before his entering upon the state of Ihram and at the conclusion of it, before circumambulating the House (for Tawf-i- Ifada).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2683]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2683

'A'isha (Allah be pleased with her) said: I applied perfume to the Messenger of Allah (may peace be upon him) as he became free from Ihram and as he entered upon it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2684]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2684

'A'isha (Allah be pleased with her) said: I applied perfume of Dharira to the Messenger of Allah (may peace be upon him) with my hand (on the occasion of) the Farewell Pilgrimage on freeing from the state of Ihram and entering upon it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2685]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2685

'Uthman b. 'Urwa reported on the authority of his father that he said: I asked 'A'isha with what thing she perfumed the Messenger of Allah (may peace be upon him) at the time of entering upon the state of Ihram. She said: With the best of perfume.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2686]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2686

'A'isha (Allah be pleased with her) reported: I applied the best perfume, which I could get, to the Messenger of Allah (may peace be upon him) before entering upon the state of Ihram (and after this) he put on the Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2687]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2687

'A'isha (Allah be pleased with her) reported: I applied the best available perfume I could find to the Messenger of Allah (may peace be upon him) before he entered upon the state of Ihram and after he was free from it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2688]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2688

'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head as he was in the state of Ihram, and Khalaf (one of the narrators) did not say: As he was in the state of Ihram, but said: That was the perfume of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2689]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2689

'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head and he was free from Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2690]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2690

'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of the perfume where the hair parted on Allah's Messenger's (may peace be upon him) head, while he was pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2691]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2691

'A'isha (Allah be pleased with her) reported: I still seem to see; the rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2692]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2692

'A'isha (Allah be pleased with her) said: I still seem to see the glistening of the perfume where the hair was parted on Allah's Messeinger's (may peace be upon him) head while he was in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2693]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2693

'A'isha (Allah be pleased with her) reported: I still seem to perceive the glistening of perfume where the hair was parted on Allah's Messenger's (may peace be upon him) head as he was in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2694]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2694

'A'isha (Allah be pleased with her) reported that when the Messenger of Allah (may peace be upon him) intended to enter upon the state of Ihram he perfumed himself with the best of perfumes which he could find and after that I saw the glisten- ing of oil on his head and beard.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2695]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2695

'A'isha (Allah be pleased with her) reported: I still seem to see the glisten- ing of musk (in the parting of the head) of the Messenger of Allah (may peace be upon him) while he was in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2696]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2696

This hadith has been narrated by 'Ubaidullah with the same chain of trans- mitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2697]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2697

'A'isha (Allah be pleased with her) reported: I used to perfume the Apostle of Allah (may peace be upon him) with a perfume containing musk before entering upon the state of Ihram and on the day of sacrifice (10th of Dhu'l-Hijja) and (at the conclusion of Ihram) before circumambulating the House (for Tawaf-i-Ifada).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2698]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2698

Muhammad b. al-Muntashir reported on the authority of his father: I asked 'Abdullah b. 'Umar (Allah be pleased with them) about a person who applied perfume and then (on the following) morning entered upon the state of lhram. There- upon he said: I do not like to enter upon the state of Ihram shaking off the perfume. Rubbing of tar (upon my body) is dearer to me than doing this (i. e. the applying of perfume), I went to 'A'isha (Allah be pleased with her) and told her that Ibn 'Umar stated:" I do not like to enter upon the state of Ihram shaking off the perfume. Rubbing of tar (upon my body) is dearer to me than doing it (the applying of perfume)." Thereupon 'A'isha said: I applied perfume to the Messenger of Allah (may peace be upon him) at the time of his entering upon the state of Ihram. He then went round his wives and then put on Ihram in the morning.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2699]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2699

'A'isha (Allah be pleased with her) reported: I used to apply perfume to the Messenger of Allah (may peace be upon him). He then went round his wives, and entered upon the state of Ihram in the morning and the perfume was shaken off.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2700]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2700

Muhammad b. al-Muntashir reported on the authority of his father: I heard from Ibn 'mar having said this:" It is dearer to me to rub tar (on my body) than to enter upon the state of Ihram (in a state) of shaking off the perfume." He (the narrator) said: I went to 'A'isha and told her about this statement of his (of Ibn 'Umar). Thereupon she said: I applied perfume to the Messenger of Allah (may peace be upon him) and he then went round his wives and then entered upon the state of Ihram in the morning.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2701]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2701

Al-Sa'b b. Jaththama al-Laithi reported that he presented a wild ass to Allah's Messenger (may peace be upon him) when he was at al-Abwa', or Waddan, and he refused to accept it. He (the narrator) said: When the Messenger of Allah (may peace be upon him) looked into my face (which had the mark of dejection as my present had been rejected by him) he (in order to console me) said: We have refused it only because we are in a state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2702]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2702

A hadith (pertaining to this topic), has been narrated on the authority of Zuhri (and the words are):" I presented to him (the Holy Prophet) a wild ass."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2703]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2703

It is narrated on the authority of Zuhri with the same chain of transmitters (the narrator having) said this:" I presented to him the flesh of a wild ass."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2704]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2704

Ibn 'Abbas (Allah be pleased with them) reported that al-Sa'b b. Jaththama presented to the Apostle of Allah (may peace be upon him) a wild ass as he was in a state of Ihram, and he returned it to him saying: If we were not in a state of Ihram, we would have accepted it from you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2705]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2705

The narration transmitted by Hakam (the words are): Al-Sa'b b. Jaththama presented to the Apostle of Allah (may peace be upon him) the leg of a wild ass. And in the narration transmitted by Shu'ba (the words are): (He presented to him) the rump of a wild ass as the blood was trickling from it. In the narration transmitted by Shu'ba on the authority of Habib (the words are): A part of a wild ass was presented to the Apostle (may peace he upon him) and he returned it to him (who presented it).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2706]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2706

Tawus reported on the authority of Ibn 'Abbas (Allah be pleased with them) that one Zaid b. Arqamwent to him (Ibn 'Abbas) and said: Narrate how you informed me about the meat of the game presented to the Messenger of Allah (may peace be upon him) as he was in the state of Ihram. Thereupon he said: He was pre- sented with a slice of the meat of game, but he returned it to him (who presented it) saying: We are not going to eat it, as we are in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2707]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2707

Abu Qatada reported: We went with the Messenger of Allah (may peace be upon him) till we reached al-Qaha (a place three stages away from Medina). Some of us were in the state of Ihram and some of us were not. I saw my companions looking towards something, and as I saw I found It to be a wild ass. I saddled my horse and took up my spear and then mounted upon (the horse) and my whip, fell down. I said to my companions as they were in the state of Ihram to pick up the whip for me but they said: By Allah, we cannot help you in any (such) thing (i. e. hunting). So i dis- mounted (the horse) and picked it (whip) up and mounted again and caught the wild ass after chasing it. It was behind a hillock and I attacked it with my spear and killed it. Then I brought it to my companions. Some of them said: Eat it, while others said: Do not eat it. The Apostle of Allah (may peace be upon him) was in front of us. I moved my horse and came to him (and asked him), whereupon he said: It is permis- sible, so eat it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2708]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2708

Abu Qatada (Allah be pleased with him) reported that while he was with the Messenger of Allah (may peace be upon him) on one of the highways of Mecca, he lagged behind him (the Holy Prophet) along with companions who were in the state of Ihram, whereas he was himself not Muhrim. He saw a wild ass. As he was mounting his horse he asked his companions to pick up for him his whip (which had dropped) but they refused to do so. He asked them to hand him over the spear, but they refused. He then himself took hold of it and chased the wild ass and killed it. Some of the Companions of the Apostle of Allah (way peace be upon him) ate (its meat), but some of them refused to do so. They overtook the Messenger of Allah (may peace be upon him) and asked him about it, and he said: It is a food which Allah provided you (so eat it).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2709]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2709

This hadith pertaining to the wild ass is reported on the authority of Abu Qatada. The rest of the hadith is the same but with this (variation of words) that the Messenger of Allah (may peace be upon him) said:" Is there with you some of its flesh?"


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2710]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2710

'Abdullah b. Abu Qatada reported: My father went with the Messenger of Allah (may peace be upon him) in the year of Hudaibiya. His Companions entered upon the state of Ihram whereas he did not, for it was conveyed to the Messenger of Allah (may peace be upon him) that the enemy (was hiding at) Ghaiqa. The Messenger of Allah (may peace be upon him) went forward. He (Abu Qatada) said: Meanwhile I was along with his Companions, some of them smiled (to one another) As I cast a glance I saw a wild ass. I attacked It with a spear and held it, and begged for their (i. e. of his companions) assistance, but they refused to help me and we ate its meat. But we were afraid lest we should be separated (from the Messenger of Allah). So I proceeded on (with a view to) seeking the Messenger of Allah (may peace be upon him). Some- times I'dashed my horse and sometimes I made it run at a leisurely pace (keeping pace with others). (In the meanwhile) I met a person from Banfu Ghifar in the middle of the night. I said to him: Where did you meet the messenger of Allah (may peace be upon him)? He said: I left him at Ta'bin and he intended to halt at Suqya to spend the afternoon. I met him and said: Messenger of Allah. your Companions convey salutations and benedictions of Allah to you and they fear that they may not be separated from you (and the enemy may do harm to you), so wait for them, and he (the Holy Prophet) waited for them. I said: Messenger of Allah, I killed a game and there is left with me (some of the meat). The Apostle of Allah (may peace be upon him) said to his people: Eat it. And they were in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2711]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2711

'Abdullah b. Abo. Qatada reported on the ant 'hority of his father (Allah be pleased with him): The Messenger of Allah (may peace be upon him) set out for Pil- grimage and we also set out along with him. He (Abu Qatada) said: There proceeded on some of his Companions and Abu Qatada was (one of them). He, (the Holy Prophet) said: You proceed along the coastline till you meet me. He (Abfl Qatida) said: So they proceeded ahead of the Prophet of God (may peace be upon him), all of them had entered upon the state of Ihram, except Abu Qatada; he had not put on ]hram. As they went on they saw a wild ass, and Abu Qatada attacked it and cut off its hind legs. They got down and ate its meat. They said: We ate meat In the state of Ihram. They carried the meat that was left of it. As they came to the Messenger of Allah (way peace be upon him) they said: Messenger of Allah, we were in the state of Ibrim where as Abu Qatada was not. We saw a wild ass and Abu Qatada attacked it and cut off its hind legs. We got down and ate its meat and we thus ate the meat of a game while we were In the state of Ihram. We have (carried to you) what was left out of its meat. There upon he (the holy Prophet) said: Did anyone among you command him (to hunt) or point to him with anythiny (to do so)? They said: No. There upon he said: Then eat what is left out of its meat.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2712]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2712

This hadith is narrated'on the authority of 'Uthman b. 'Abdullah b. Mauhab with the same chain of transmitters. And in the narration transmitted on the authority of Shaiban (the words are):" The Messenoer of Allah (may peace be upon him) said: Did any one of you command him to attack it or point towards it?" And in the narration transmitted by Shu'ba (the words are):" Did you point out or did you help or did you hunt?" Shu'ba said: I do not know whether he said:" Did you help or did you hunt?"


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2713]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2713

Abdullah b. Abu Qatada narrated on the authority of his father (Allah be pleased with him) that they went with the Messenger of Allah (may peace be upon him) on an expedition to Hudaibiya. He (further) said: They had entered upon the state of Ihram except I for 'Umra. He (again) said: I (Abu Qatada) hunted a wild ass and fed my companions In the state of their being Muhrim. 1 then came to the Messenger of Allah (may peace be upon him) and informed him that we had with us the meat that was left out of it Thereupon he said: Eat It, while they were in the state of Ibrim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2714]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2714

'Abdullah b. Abu Qatada reported on the authority of his father (Allah be pleased with him) that they went out with the Messenger of Allah (may peace be upon him) and they were Muhrim except Abu Qatada. The rest of the hadith Is the same (but with the exception of these words):" He (the Holy Prophet) said: 15 there any- thing out of it? They said: We have its leg with us. The Messenger of Allah (may peace be upon him) took it and ate it."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2715]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2715

Abdullah b. Abi Qatada reported that Abu Qatada was among the party of those who had entered upon the state of Ihram whereas he was not. The rest of the hadith is the same (and herein it is also narrated):" He (the Holy Prophet) said: Did any person among you point to him (to hunt) or command him (in any form)? They said: Messenger of Allah, not at all. Thereupon he said: Then eat it."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2716]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2716

Abd al-Rahman b. 'Uthman Taimi reported on the authority of his father; While we were with Talha b. Ubaidullah and were in the state of Ihram we were pre- sented a (cooked) bird. Talha was sleeping. Some of us ate it and some of us refrained from (eating) it. When Talba awoke he agreed, with him who ate it, and said: We ate it along with the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2717]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2717

A'isha, the wife of the Apostle of Allah (may peace be upon him). said: I heard Allah's Messenger (may peace be upon him) as saying: Four are the vicious (birds, beasts and reptiles) which should be killed in the state of Ihram or otherwise: kite (and vulture), crow, rat, and the voracious dog I (one of the narrators, 'Ubaid- ullah b. Miqsam) said to Qasim (the other narrator who beard it from 'A'isha): What about the snake? lie said: Let it be killed with disgrace.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2718]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2718

A'isha (Allah be pleased with her) reported Allah'* Apostle (may peace be upon him) as saying: Five are the harmful things which should be killed in the state of Ihram or otherwise: snake, speckled crow. rat. voracious dog, and kite.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2719]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2719

A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Five are the vicious beasts which should be killed even in the state of Ihram: scorpion, rat, kite, crow and voracious dog.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2720]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2720

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2721]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2721

A'isha reported Allah's Mdssenger (may peace be upon him) having said this: Five are the vicious and harmful things which should be killed even within the precincts of Haram: rat, scorpion, crow. kite and voracious dog.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2722]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2722

This hadith has been narrated on the authority Zuhri with the same chain of transmitters that she (A'isha) reported: The Messenger of Allah (may peace be upon him) commanded to kill five harmful things in the state of lhram or other- wise. The rest of the badith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2723]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2723

IA'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Five are the beasts 1618 harmful and vicious and these must be killed even within the precincts of the Ka'ba: crow, kite, voracio@s dog, kcorpion and rat.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2724]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2724

Salim reported on the authority of his father (Allah be pleased with them) that the Apostle of Allah (may peace be upon him) said: Five are the (beasts) which if one kills them in the precincts of the Ka'ba or in the state of lhram entail no sin: rat, scorpion, crow, kite and voracious dog. In another version the words are:" as a Muhrim and in the state of lhram".


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2725]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2725

Hafsa, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) having said this: There are five beasts, all of them are vicious and harmful and there is no tin for one who kills them (and these are): scorpion, crow. kite, rat and voracious dog.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2726]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2726

Zaid b. Jubair reported: A person asked Ibn Umar which beast a Muhrim could kill. Thereupon he said: One of the wives of Allah's Apostle (may peace be upon him) told me: He (the Holy Prophet) commanded to kill rat, scorpion, kite, voracious dog and crow.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2727]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2727

Zaid b. Jubair reported: A person asked Ibn 'Umar which beast a Mubrim could kill, whereupon he said: One of the wives of Allab's Apostle (may peace be upon him) told me: He (the Holy Prophet) commanded to kill voracious dcg, rat, scorpion, kite, crow, and snake (and this is allowed) likewise in prayer.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2728]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2728

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Five are the beasts for killing which there is no sin for the Muhrim: crow, kite, scorpiou, rat and voracious dog.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2729]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2729

Ibn Juraij reported: I said to Nafi: What is that which you heard Ibn, Umar declaring permissible for a Mubrim to kill some of the beasts? Nafi, said to me that 'Abdullah had reported: I heard Allah's Messenger (may peace be upon him) as saying: Five are the beasts in killing which or their being killed, there is no sin: crow, kite, scorpion, rat and voracious dog.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2730]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2730

This hadith has been narrated on the authority of Ibn 'Umar through be upon him) as saying: Five (are the beasts) in killing which or their being killed in the precinct of the Ka'ba there is no sin." The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2731]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2731

'Abdullah b. Umar (Allah be pleased with them) reported Allah's Messen- ger (may peace be upon him) as saying: Five (are the animals) which, it one kills them In the state of Ihram, entail no sin for one (who does it): scorpion, rat, voracious dog, crow and kite.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2732]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2732

Ka'b b. 'Ujra (Allah be pleased with him) reported: The Messenger of Allah (may peace be upon him) came to me on the occasion of Hudaibiya and I was kindling fire under my cooking pot and lice were creeping on my face. Thereupon he (the Holy Prophet) said: Do the vermins harm your head? I said: Yes. He said: Get your head shaved and (in lieu of it) observe fasts for three days or feed six needy persons, or offer sacrifice (of an animal). Ayyub said: I do not know with what (type of expiation) did he commence (the statement).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2733]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2733

This hadith is narrated on the authority of Ayyub.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2734]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2734

Kalb b. Ujra (Allah be pleased with him) reported: It was I for whom this verse was revealed (to the Holy Prophet):" Whoever among you is sick or has an ail- ment of the head, he (may effect) a compensation by lasting or alms or a sacrifice" He said: I came to him (the Holy Prophet) and he said: Come Dear. So Iwent near. He (again) said: Come near. So I went near. Thereupon the Messenger of Allah (may peace be upon him) said: Do the vermins trouble you? Ibn Aun (one of the narrators) said: I think he (Ka'b b. Ujra) replied in the affirmative. He (the Holy Prophet) then commanded to do compensation by fasting or by giving @adaqa (feed- ing six needy persons) or by sacrifice (of a animal) that is available.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2735]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2735

Ka'b b. 'Ujra (Allah be pleased with him) reported that the Messenger of Allah (may peace be, upon him) stood near him and lice were falling from his head. Thereupon he (the Holy Prophet) said: Do these vermins trouble you? I said: Yes. Thereupon he said: Then shave your head; and it was in connection with me that this verse was revealed:" Whoever among you is sick or has an ailment of the head, he (may effect) a compensation by fasting or alms or a sacrifice". He (the Holy Prophet, therefore) said to me: Observe fast for three days or give a quantity of alms enough to feed six needy persons or offer sacrifice (of an animal) that is available.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2736]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2736

Ka'b b. 'Ujra (Allah be pleased with him) reported that the Apostle of Allah (may peace be upon him) happened to pass by him at Hudaibiya before entering Mecca in a state of Ibrim and he (Ka'b) was kindling fire under the cooking pot and virmins were creeping on his (Kalb's) face. Thereupon (the Holy Prophet) said: Dothese vermins trouble you? He (Ka'b) said: Yes. The Messenger of Allah (way peace be upon him) said: Shave your head and give some quantity of food enough to feed six needy persons (faraq is equal to three sa's), or observe fast for three days or offer sacri- fice of a sacrificial animal. Ibn Najih (one of the narrators) said:" Or sacrifice a goat."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2737]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2737

Ka'b b. Ujra (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) happened to pass by him during the period of Hudaibiya. Thereupon he (the Holy Prophet) said to him (Ka'b b. Ujra): Do these vermins trouble your head? He said: Yes. Thereupon he (the Holy Prophet) said: Shave your head. Then sacrifice a goat or observe fasts for three days or give three sits of dates to feed six needy persons.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2738]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2738

Abdullah b. Ma'qil said: I sat with Ka'b (Allah be pleased with him) and he was in the mosque. I asked him about this verse:" Compensation in (the form of) fasting, or Sadaqa or sacrifice." Ka'b (Allah be pleased with him) said: It was reveal- ed In my case. There was some trouble in my head. I was taken to the Messenger of Allah (may peace be upon him) and lice were creeping upon my face. Thereupon he said: I did not think that your trouble had become so unbearable as I see. Would you be able to afford (the sacrificing) of a goat? I (Ka'b) said: Then this verse was revealed:" Com- pensation (in the form of) fasting or alms or a sacrifice." He (the Holy Prophet) said: (It Implies) fasting for three days, or feeding six needy perscins, half sa' of food for every needy person. This verse was revealed particularly for me and (now) Its applica- tion is general for all of you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2739]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2739

Ka'b b. Ujra (Allah be pleased with him) reported that he went out with the Apostle of Allah (may peace be upon him) in the state of Ihram, and his (Ka'b's) head and beard were infested with lice. This was conveyed to the Apostle of Allah (may peace be upon him). He sent for him (Ka'b) and called a barber (who) shaved his head. He (the Holy Prophet) said. Is there any sacrificial animal with you? He (Kalb) said: I cannot afford it. He then commanded him to observe fasts for three days or feed six needy persons, one sa' for every two needy persons. And Allah the Exalted and Majestic revealed this (verse) particular with regard to him:" So whosoever among you is sick and has an ailment of the head.." ; then (its application) became general for the Muslims.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2740]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2740

Ibn 'Abbas (Allah be pleased with them) reported that the Apostle of Allah (may peace be upon him) got himself cupped in the state of lhrim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2741]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2741

Ibn Buhaina reported that the Apostle of Allah (may peace be upon him) got himself cupped in the middle of his head on his way to Mecca.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2742]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2742

Nubaih b. Wabb reported: We went with Aban b. Uthman (in a state of lhram). When we were at Malal the eyes of Umar b. Ubaidullah became sore and, when we reached Rauba' the pain grew intense. He (Nubaib b. Wahb) sent (one) to Aban b. Uthman to ask him (what to do). He sent him (the message) to apply aloes to them, for 'Uthman (Allah be pleased with him) reported that the Messenger of Allah (may peace be upon him) applied aloes to the person whose eyes were sore and he was in the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2743]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2743

Nubaih b Wahb reported that the eyes of Umar b. Ubaidnllah b. Ma'mar were swollen, and he decided to use antimony. Aban b. 'Uthman forbade him to do so and commanded him to apply aloes on them, and reported on the authority of 'Uthman b. Affan that the Apostle of Allah (may peace be upon him) had done that.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2744]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2744

Ibrahim b. 'Abdullah narrated on the authorrity of his father that there cropped up a difference of opinion between Abdullah b. 'Abbas and al-Miswar b. Makhrama at a place (called) Abwa'. Abdullah b. 'Abbas contended that a Muhrim (is permitted) to wash his head, whereas Miswar contended that a Muhrim is not (permit- fed) to wash his head. So Ibn Abbas sent me (the father of Ibrabim) to Abu Ayyub al- Ansirl to ask him about it. (So I went to him) and found him taking bath behind two poles covered by a cloth. I gave him salutation, whereupon be asked: Who is this? I said: I am 'Abdullah b. Hunain. 'Abdullah b. 'Abbas has sent me to you to find out how the Messenger of Allah (may peace be upon him) washed his head in the state of Ihram. Abu Ayyub (Allah be pleased with him) placed his hand on the cloth and lowered it (a little) till his head became visible to me; and he said to the man who was pouring water upon him to pour water. He poured water on his head. He then moved his head with the help of his hands and moved them (the hands) forward and backward and then said: This is how I saw him (the Messenger of Allah) doing.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2745]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2745

This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters that Abu Ayyub rubbed his whole head with his hands and then moved them forward and backward. Miswar said to Ibn 'Abbas: I would never dispute with you (in future).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2746]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2746

Ibn Abbas (Allah be pleased with them) reported that a person fell down from his camel (in a state of Ihram) and his neck was broken and he died. Thereupon Allah's Apostle. (may peace be upon him) said: Bathe him with water mixed with the leaves of the lote tree and shroud him in his two (pieces of) cloth (Ihbram), and do not cover his head for Allah will raise him on the Day of Resurrection Pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2747]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2747

Ibn Abbas (Allah be pleased with them) reported: While a person was standing in 'Arafat with the Messenger of Allah (may peace be upon him) he fell down from his camel and broke his neck. This was mentioned to the Apostle of Allah (may peace be upon him), whereupon he said: Bathe him with water mixed with the leaves of the lote tree and shroud him in two (pieces of) cloth and neither perfume him nor cover his head; (Ayyub said) for Allah would raise him on the Day of Resurrection in the state of pronouncing Talbiya. ('Amr. however, said): Verily Allah would raise him on the Day of Resurrection pronouncing Talbiya. Sa'id b. Jubair narrated this hadith on the authority of Ibn 'Abbas (Allah be pleased with them) that a person was standing with the Apostle of Allah (may peace be upon him) as he was in the state of Ihram. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2748]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2748

Ibn Abbas (Allah be pleased with them) reported that a person proceeded along with the Apostle of Allah (may peace he upon him) in the state of Ihram and fell down from his camel and his neck was broken, and he died. The Messenger of Allah (may peace be upon him) said: Bathe him with water mixed with lote (leaves) and shroud him in two (pieces of) cloth and do'not cover his head for he would come on the Day of Resurrection pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2749]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2749

Sa'id b. Jubair reported on the authority of Ibn Abbas (Allah be pleased with him) that a person proceeded with the Messenger of Allah (may peace be upon him) in the state of Ihram. The rest of the hadith th is the same except that he (the Holy Prophet) (is reported to have) said: He would be raised on the Day of Resurrection pronouncing Talbiya. Sa'id b. Jubair did not name the place where he fell down.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2750]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2750

Ibn Abbas (Allah be pleased with them) reported that there was a person in the state of Ihram whose camel broke his neck and he died. Thereupon the Mes- senger of Allah (may peace be upon him) said: Bathe him with water mixed (with the leaves of) lote tree and shroud him In his two (pieces of) cloth and cover neither his head nor his face, for he would be raised on the Day of Resurrection pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2751]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2751

Ibn 'Abbas (Allah be pleased with them) reported that when a person who was in the state of Ihram was in the company of the Messenger of Allah (may peace be upon him), his camel broke his neckand he died. Upon this the Messenger of Allah (may peace be upon him) said: Bathe him with water (mixed with the leaves) of the lute tree and shroud him in his two (pieces of) cloth and, neither perfume him nor cover his head, for he would be raised on the Day of Resurrection pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2752]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2752

Sa'id b. Jubair reported on the authority of Ibn 'Abbas (Allah be pleased with them) that a camel broke the neck of its owner while he was in the state of lhram and he was at that time in the company of the Messenger of Allah (may peace be upon him). Allah's Messenger (may peace be upon him) commanded that he should be bathed with water mixed with (leaves of the) lote (tree) and no perfume should be applied to him and his head should not be covered, for he would be raised on the Day of Resurrection pronouncing Talblya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2753]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2753

Sa'id b. Jubair heard Ibn 'Abbas (Allah be pleased with them) as saying: A person came to Allah's Apostle (may peace be upon him) while he was in the state of lhram. He fell down from his camel and broke his neck. Thereupon Allah's Apostle (may peace be upon him) commanded to bathe him with water (mixed with the leaves of) the lote (tree), and shroud him in two (pieces of) cloth and not to apply perfume (to him), keeping his head out (of the shroud). Shu'ba said: He then narrated to me after this (the words)" keeping his head out," his face out, for he would be raised on the Day of Resurrection pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2754]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2754

Sa'id b. Jubair reported on the authority of Ibn 'Abbas (Allah be pleased with them) that the camel of a person broke his neck as he was in the company of Allah's Messenger (may peace be upon him). The Messenger of Allah, (way peace be upon him) commanded them (Companions) to wash him with water mixed (with the leaves of) the lote (tree) and to keep his face exposed; (he, the narrator) said: And his head (too), for he would be raised on the Day of Resurrection pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2755]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2755

Ibn 'Abbas (Allah be pleased with him) reported that there was a person in the company of Allah's Messenger (may peace' be upon him) whose camel broke his neck and he died. thereupon Allah's Apostle (may peace be upon him) said: Wash him, but do not apply perfume and do not cover his face, for he would be raised (on the Day of Resurrection) pronouncing Talbiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2756]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2756

A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) went (into the house of) Duba'a bint Zubair and said to her: Did you intend to perform Hajj? She said: By Allah, (I intend to do so) but I often remain ill, whereupon he (the Holy Prophet) said to her: Perform Hajj but with con- dition, and say: O Allah, I shall be free from Ihram where you detain me. And she (Duba'a) was the wife of Miqdad.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2757]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2757

A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) went (to the house of) Duba'a bint al-Zubair b. Abd al-Muttalib. She said: Messenger of Allah, I intend to perform Hajj, but I am ill. Thereupon Allah's Apostle (may peace be upon him) said: Enter Into the state of Ihram on condition that you would abandon it when Allah would detain you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2758]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2758

This hadith has been reported on the authority of A'isha through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2759]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2759

Ibn Abbas reported that Duba'a bint al-Zubair b. 'Abd al-Muttalib (Allah be pleased with her) came to Allah's Messenger (may peace be upon him) and said: I am an ailing woman but I intend to perform Hajj; what you command me (to do)? He (the Holy Prophet) said: Enter into the state of Ihram (uttering these words) of condition: I would be free from it when Thou wouldst detain me. 'He (the narrator) said: But she was able to complete (the Hajj without breaking down).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2760]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2760

Ibn Abbas (Allah be pleased with him) reported that Duba'a intended to perform Hajj. and the Apostle of Allah (may peace be upon him) commanded her (to enter into the state of Ihram) with condition. She did it in compliance with the com- mand of Allah's Apostle (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2761]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2761

This hadith has been narrated on the authority of Ibn 'Abbas with a slight variation of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2762]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2762

A'isha (Allah be pleased with her) reported that Asma' hint 'Umais gave birth to Muhammad b Abu Bakr near Dhu'I-Hulaifa. The Messenger of Allah (may peace be upon him) commanded Abu Bakr to convey to her that she should take a bath and then enter into the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2763]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2763

Jabir b. Abdullah (Allah be pleased with them) reported that when Asma' hint Umais gave birth (to a child) in Dhu'I-Hulaifa. Allah's Messenger (may peace be upon him) commanded Abyl Bakr (to convey to her) that she should take a bath and enter Into the state of Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2764]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2764

'A'isha (Allah be pleased with her) said: We went with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. We entered into the state of Ibrim for Umra. Then the Messenger of Allah (may peace be upon him) said: Who has the sacrificial animal with him, he should put on Ihram for Hajj along with Umra. and should not put it off till he has completed them (both Hajj and Umra). She said: When I came to Mecca. I was having menses, I neither circumambulated the House, nor ran between as-safa' and al-Marwa. I complained about it to the Messenger of Allah (may peace be upon him) and he said: Undo your hair, comb it, and pronounce Talbiya for Hajj, and give up Umra (for the time being), which I did. When we had performed the Hajj, the Messenger of Allah (way peace he upon him) sent me with Abd al-Rabman b. Abu Bakr to Tan'im saying: This is the place for your Umra. Those who had put on Ibrim for Umra circumambulated the House, and ran between al-safa' and al-Marwa. They then put off Ihram and then made the last circuit after they had returned from Mina after performing their Hajj, but those who had combined the Hajj and the Umra made only one circuit (as they had combined Hajj and 'Umra).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2765]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2765

'A'isha, the wife of the Apostle of Allah (may peace be upon him), said: We went out with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. There were some amongst us who had put on IHram for Umra and there were some who had put on Ihram for Hajj. (We proceeded on till) we came to Mecca. The Messenger of Allah (may peace be upon him) said: He who put on Ihram for 'Umra but did not bring the sacrificial animal with him should put it off. and he who put on Ihram for Umra and he who had brought the sacrificial animal with him should not put it off until he had slaughtered the animal; and he who put on lhram for Hajj should complete it. A'isha (Allah be pleased with her) said: I was in the monthlyperiod, and I remained In this state till the day of 'Arafa, and I had entered into the state of Ihram for 'Umra. The Messenger of Allah (may peace be upon him) thus commanded me to undo my hair and comb them (again) and enter into the state of Ihram for Hajj, and abandon (the rites of 'Umra). She ('A'isha) said: I did so, and when I had completed my Pilgrimage, the Messenger of Allah (may peace be upon him) sent with me 'Abd al-Rabman b. Abu Bakr and commanded me to (resume the rites of) 'Umra at Tan'im. the place where (I abandoned) 'Umra and put on Ihram for Hajj (before completing Umra).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2766]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2766

A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. I put on Ihram for Umra and did not bring the sacrificial animal. The Apostle of Allah (may peace be upon him) said: He who has the sacrihcial animal with him should enter into the state of Ibrim for Hajj along with 'Umra, and. he should not put the Ibrim off till he has completed both of them. She (Hadrat A'isha) said: The monthly period began. When it was the nigt of Arafa, I said to the Messenger of Allah (may peace be upon him): I entered into the state of Ihram for 'Umra. but now how should I perform the Hajj? Thereupon he said: Undo your hair and comb them, and desist from performing Umra, and put on Ihram for Hajj She (A'isha, said: When I had completed my Hajj he commanded 'Abd al-Rahman b. Abu Bakr to carry me behind him (on boneback) in order to enable me to resume the rituals of Umra from Tan'im, the place where I abandoned its rituals.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2767]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2767

'A'isha (Allah be pleased with her) reported: 'We went with the Messenger of Allah (may peace be upon him) (to Mecca). He said: He who intended among you to put on Ihram for Hajj and Umra should do so. And he who intended to put on Ihram for Hajj may do so. and he who intended to put on Ihram for 'Umra only may do so. A'isha (Allah be pleased with her) said: The Messenger of Allah (way peace be upon him) put on Ihram for Hajj and some people did that along with him. And some people put on Ihram for Umra and Hajj (both). and some persons put on Ihram for Umra only, and I was among those who put on Ihram for Umra (only).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2768]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2768

A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him? (in his) Farewell Pilgrimage near the time of the appearance of the new moon of Dhu'I-Hijja. The Messenger of Allah (may peace be upon him) said: He who amongst you intends to put on Ihram for Umra may do so; bad I not brought sacrificial animal along with me, I would have put on Ihram for Umra. She (further said). There were some persons who put on Ihram for Umrs, and some persons who put on Ibrim for gajj, and 1 was one of those who put on Ihram for Umra. We went on till we reached Mecca, and on the day of 'Arafa I found myself In a state of menses, but I did not put off the Ihram for Umra. I told about (this state of mine) to the Apostle of Allah (may peace be upon him). whereupon he said: Abandon your 'Umra, and undo the hair of your head and comb (them), and put on Ihram for Hajj 'she ('A'isha) said: I did accordingly. When it was the night at Hasba and Allah enabled us to complete our Hajj, he (the Holy Prophet) sent with me Abd al-Rahman b. Abu Bakr, and he mounted me behind him on his camel and took me to Tan'im and I put on Ihram for 'Umra, and thus Allah enabled us to complete our Hajj and Umra and (we wore required to observe) neither sacrifice nor alms nor fasting.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2769]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2769

'A'isha (Allah be pleased with her) said: We set out with the Messenger of Allah (may peace be upon him) just at the appearance of the new moon of Dhu'l- Hijja. We had no other intention but that of performing the Hajj, whereupon the Messenger of Allah (may peace be upon him) said: He who among you intends to put on Ihram for 'Umra should do so for 'Umra. The rest of the badith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2770]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2770

A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) at the appearance of the new moon of Dhu'I-Hijja. There were amongst us those who had put on Ihram for Umra, and those also who had put on Ihram both for Hajj and Umra, and still those who had put on Ihram for Hajj (alone). I was one of those who had put on Ihram for. Umra (only). 'Urwa (one of the narrators) said: Allah enabled her (Hdrat A'isha) to complete both Hajj and Umra (according to the way as mentioned above). Hisham (one of the narrators) said: She had neither the sacrificial animal nor (was she required to) fast, nor (was she obliged to give) alms.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2771]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2771

A'isha (Allah be pleased with her) said: We proceeded with the Messenger of Allah (may peace be upon him) during the year of the Farewell Pilgrimage. There were those amongst us who had put on Ihram for Umra, and those who had put on Ibrim both for Hajj and" Umra, and those amongst us who had put on Ihram for Hajj (only), while the Messenger of Allah (may peace be upon him) had put on Ihram for Hajj (only). He who put on Ihrim for Umra put it off (after performing Umra), and he who had put on Ihram for Hajj or for both Hajj and 'Umra did not put it off before the day of sacrifice (10th of Dhu'I-Hijja).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2772]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2772

A'isba (Allah be pleased with her) said: We proceeded with the Apostle of Allah (may peace be upon him) with no other Intention but that of performing the Hajj. As I was at Sarif or near it, 1 entered in the state of menses. The Apostle of Allah (may peace be upon him) came to me and I was weeping, whereupon he said: Are you in a state of menses? I said. Yes. whereupon he said: This is what Allah has ordained for all the daughters, of Adam. Do whatever the pilgrim does. except that you should not circumambulate the House till you have washed yourself (at the end of the menses period). And the Messenger of Allah (may peace be upon him) offered sacrifice of a cow on behalf of his wives.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2773]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2773

A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) with no other aim but that of Hajj till we came (to the place known as) Sarif; and there I entered in the state of menses. The Messenger of Allah (may peace be upon him) came to me while I was weeping. He said: What makes you weep? I said: Would that I had not come (for Pilgrimage) this year. He (the Holy Prophet) said: What has happened to you? You have perhaps entered the period of menses. I said: Yes. He said: This is what has been ordained for the daughters of Adam. Do what a pilgrim does except that you should not circumambu- late the House, till you are purified (of the menses). She ('A'isha) said: When I came to Mecca, the Messenger of Allah (may peace be upon him) said to his companions: Make this (Ihram) the Ihram for 'Umra. So the people put off Ihbaim except those who had sacrificial animals with them. She ('A'isha) said: The Apostle of Allah (may peace be upon him) had the sacrificial animal with him, and so had Abd Bakr, 'Umar and other persons of means. They (those who had put off lhram again) put on Ihram (for Hajj) when they marched (towards Mina), and it was the 8th of Dhu'I-Hijja. She ('A'isha) said: When it was the day of sacrifice (10th of Dhu'I-Hijia), I was purified, and the Messenger of Allah (may peace be upon him) commanded me and I did the circumambulation of Ifada. She said that the flesh of cow was sent to us. I said: What is It? They said: The Messenger of Allah (may peace be upon him) has offered cow as sacrifice on behalf of his wives. When it was the might at Hasba, I said: Messenger of Allah, people are coming back from Hajj and Umra, where as I am coming back from Hajj (alone). She (IA'isha) reported: He (the Holy Prophet) commanded" Abd al- Rahman b. Abu Bakr to mount me upon his camel behind him. She ('A'isha) said: I was very young and I well remember that I dozed oil and my face touched the bind part of the haudaj (camel litter) till we came to Tan'im, and entered into the state of Ihram in lieu of Umra (which I for the time being abandoned) and which the people had performed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2774]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2774

A'isha (Allah be pleased with her) reported: We entered into the state of. Ihram for Hajj till we were at Sarif and I was in menses. The Messenger of Allah (may peace be upon him) came to me and I was weeping. The rest of the hadith is the same but (with this portion) that there were sacrificial animals with Allah's Apostle (may peace be upon him) and with Abu Bakr, Umar and with rich persons. And they pro- nounced Talbiya as they proceeded on. And there is no mention of this (too):" I was a girl of tender age and I dozed off and my face touched the bind part of the Haudaj."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2775]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2775

'A'Isha reported that the Messenger of Allah (may peace be upon him) entered into the state of Ihram for Hajj Ifrid.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2776]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2776

'A'isha (Allah be pleased with her) reported: We proceeded with the Mes- senger of Allah (may peace be upon him) putting on the Ihram for Hajj during the months of Hajj and the night of Hajj till we encamped at Sarlf. He (the Holy Prophet) went to his Companiens and said: He who has no sacrificial animal with him, in his case I wish that he should perform Umra (with this Ihram), and he who has the sacrificial animal with him should not do it. So some of thtm performed Hajj whereas others who had no sacrificial animals with them did not do (Hajj, but per- formed only 'Umra). The Messenger of Allah (may peace be upon him) had the sacrificial animal with him and those too who could afford it (performed) Hajj). The Messenger of Allah (may peace be upon him) came to me (i. e. A'isha) while I was weeping, and he said: What makes thee weep? I said: I heard your talk with Companions about Umra. He said: What has happened to you? I said: I do not observe prayer (due to the monthly period), whereupon besaid: It would not harm you; you should perform (during this time) the rituals of Hajj (which you can do outside the House). Maybe Allah will compensate you for this. You are one among the daughters of Adam and Allah has ordained for you as He has ordained for them. So I proceeded on (with the rituals of Hajj) till we came to Mina. I washed myself and then circumambuleted the House, and the Messenger of Allah (may peace be upon him) encamped at Muhassab and called, Abd al-Rahman b. Abua Bakr. and said: Take out your sister from the precincts of the Ka'ba in order to put on Ihram for Umra and circumambulate the House. and I shall wait for you here. She said: So I went out and put on Ihram and then circu- mambulated the House. and (ran) between al-Safa and al-Marwa, and then we came to the Messenger of Allah (may peace be upon him) and he was in his bouse in the middle of the night. He said: Have you completed your (rituals)? I said: Yes. He then announced to his Companions to march on. He came out, and went to the House and circumambulated it before the dawn prayer and then proceeded to Medina.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2777]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2777

A'isha (Allah be pleased with her) said: Some among us put on Ihram for Hajj alone (Hajj Mufrad) ; some of us for Hajj and Umra together (Qiran), and some of us for Tamattal (first for Umra and after completing it for Haii).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2778]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2778

AI-Qasim b. Muhammad reported that A'isha had come for Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2779]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2779

'Umra reported: I heard A'isha (Allah be pleased with her) as saying: We went out with the Messenger of Allah (may peace be upon him) five days before the end of Dhi Qa'dah, and we did see but that he intended to perform Hajj (only), but as we came near Mecca the Messenger of Allah (may peace be upon him) commanded that he who did not have the sacrificial animal with him should put off Ibrim after circumambulating the House and running between al-Safa and aI-Marwa (and thus convert his Ihram from that of Hajj to 'Umra). 'A'isha (Allah be pleased with her) said: The flesh of cow was sent to us on the Day of Sacrifice (10th of Dhu'I-Hijja). I said. What is this? It was said: The Messenger of Allah (may peace be upon him) sacrificed (the cow) on behalf of his wives. Yabyi said: I made a mention of this hadith (what has been stated by Umra) to Qisim b. Muhammad, whereupon be said: By Allah, she has rightly narrated it to you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2780]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2780

This hadlth has been narrated by Yahyi through the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2781]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2781

AI-Qasim narrated from the Mother of the Believers (Hadrat 'A'isha) that she said: Messenger of Allah. the people return (from Mecca) having ione two worships (both Hajj and Umra), but I am coming back with one (only). whereupon he said: You should wait and when the period of menses is over, you should go to Tan'im and put on lhram and then meet us at such and such time (and I think he said tomorrow) ; and (the reward of this Umra) is for you equal to your hardship or your spending.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2782]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2782

Ibn al-Muththanna reported on the authority of Ibn Abu'Adi who transmit- ted on the authority of Ibn'Aun who narrated from al-Qasim and Ibrahim having said: I cannot differentiate the badith of one from the other (Q[Lsim and Ibribim) that the Mother of the Believers (Allah be pleased with her) said this: Messenger of Allah, people have come back with two acts of worship. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2783]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2783

A'isha (Allah be pleased with her) reported: We went with the Messenger of Allah (may peace be upon him) and we did not see but that he (intended to perform) Rajj (only), but when we reached Mecca we circmambulated the House; and the Messenger of Allah (may peace be upon him) commanded that he who did not have with him a sacrificial animal should put off Ihram. She (A'isha) said: (And consequent- ly) those who did not bring the sacrificial anima) s with them put off Ihram; and among his wives (too) who had not brought the sacrificial animals with them put off Ihram. A'isha said: I entered in the monthly period and could not (therefore) circumambulate the House. When it was the night of Hasba she said: Messenger of Allah, people are coming. back (after having performed @oth) Hajj and'Umra, whereas I am coming back only with Hajj, whereupon he said: Did you not eircumambulate (the Ka'ba) that very night we intered Mecca? She (A'isha) said: No, whereupon he said: Go along with your brother to Tan'im and put on the Ihram for Umra, and it is at such and such a place that you can meet (us). (In the meanwhile) Safiyya (the wife of the Holy Prophet) said: I think, I will detain you (since I have entered in the monthly) period and you shall have to wait for me for the farewell circuit). Thereupon he (the Holy Prophet) said: May you be wounded and your head shorn did you not circumambulate on the Day of Sacrifice (10th of Dhu'I-Hijja)? She said: Yes. The Holy Prophet (way peace be upon him) said: There is no harm. You should go forward. 'A'isha said: The Messenger of Allah (may peace be upon him) was going upwards to the side of Mecca, whereas I was coming down from it, or I was going upward, whereas he was coming down. Isbiq said: She was clim bing down, and he was climbing down.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2784]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2784

'A'isha (Allah be pleased, with her) reported: We went out with the Mes. senger of Allah (may peace be upon him) pronouncing Talbiya having no explicit inten- tion of Pilgrimage or 'Umra. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2785]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2785

'A'isha (Allah be pleased with her) reported that the Messenger of Allah (may peace be upon him) came out on the 4th or 5th of Dhul'I-Hijja (for Pilgrimage to Mecca) and came to me, and he was very angry. I said: Messenger of Allah, who has annoyed you? May Allah cast him in fire I He said: Don't you know that I commanded the people to do an act, but they are hesitant. (Hakam said: I think that he said: They seem to be hesitant.) And if I were to know my affair before what I had to do subsequently, I would not have brought with me the sacrificial animals, and would have bought them (at Mecca) and would have put off lhram as others have done.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2786]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2786

A'isha (Allah be pleased with her) reported that the Apostle of Allah (may peace be upon him) came out (for Pilgrimage) on The 4th or 5th of Dbu'l Hjjja. The rest of the hadith is the same, but he (the narrator) made no mention of the doubt of Hakam about his (the Prophet's) words:" They were reluctant."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2787]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2787

A'isha (Allah be pleased with her) reported that she put on Ihram for, Umra and arrived 'at Mecca) but did not circumambulate the House as she had entered in the period of menses, and then put on Ihram for Hajj and performed all the rituals concerning it (except circumambulating the House). The Apostle of Allah (may peace be upon him) said to her on the day of march (when pilgrims come to Mina): Your circumambulation would suffice both Hajj and Umra. She, however, felt reluc- tant. Thereupon the Holy Prophet (may peace be upon him) sent her with 'Abd al- Rahman to Tan'im and she performed Umra (with separate rituals) after Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2788]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2788

'A'isha (Allah be pleased with her) reported that she entered in the monthly period at Sarif, and took bath at 'Arafa (after the period was over). The messenger of Allah (may peace be upon him) said to her: Your circumambulation between al Safa and al-Marwa is enough for your Hajj and 'Umra.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2789]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2789

Safiyya hint Shaiba reported that 'A'isha (Allah be pleased with her) said: Messenger of Allah, lo! the people are returning with two rewards whereas I am return- ing with one reward. Thereupon he commanded 'Abd al-Rahman b. Abu Bakr to take her to al-Tan'im. She ('A'isha) said: He seated me behind him on his camel. She (further) stated: I lifted my head covering and took it off from my neck. He struck my foot as if he was striking the camel. I said to him: Do you find anyone bere? She (further) said: I entered into the state of Ihram fond. 'Umra till we reached the Messen- ger of Allah (may peace be upon him) and he was at Hasba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2790]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2790

Abd al-Rahman b. Abu Bakr reported that the Apostle of Allah (may peace be upon him) ordered him to mount A'isha behind him and enable her to (enter into the state of Ibrim for 'Umra) at Tan'im.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2791]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2791

Jabir (Allah be pleased with him) said: We, in the state of lhram, came with the Messenger of Allah (may peace be upon him) for Hajj Mufrad (with the aim of Hajj only), and 'A'isha set out for Umra, and when we reached Sarif, she (Hadrat A'isha) entered in the state of monthly period; we proceeded on till we reached (Mecca) and circumambulated the Ka'ba and ran between (al-Safa) and al-Marwa; and the Messenger of Allah (may peace be upon him) commanded that one who amongst us had no sacrificial animal with him should put off Ihram. We said: What does this" Putting off" imply? He said: Getting out completely from the state of lhram, (so we put off Ihram), and we turned to our wives and applied perfume and put on our clothes. and we were at a four night's distance from 'Arafa. And we again put on Ihram on the day of Tarwiya (8th of Dhu'l-Hijja). The Messenger of Allah (may peace be upon him) came to 'A'isha (Allah be pleased with her) and found her weeping, and said: What is the matter with you? She said: The matter is that I have entered in the monthly period, and the people had put off lhram, but I did not and I did not circumambulate the House, and the people are going for Hajj now (but I can't go), whereupon he said: It is the matter which Allah has ordaiucd for the daughters of Adam, so now take a bath and put on Ihram for Hajj. She ('A'isha) did accordingly, and stayed at the places of staying till the monthly period was over. She then circu- mambulated the House, and (ran between) al-Safa and al-Marwa. He (the Holy Prophet) then said: Now both your Hajj and 'Umra are complete, whereupon she said: I feel in my mind that I did not circumambulate the House till I performed Hajj (I missed the circumambulation of 'Umra). Thereupon he (Allah's Apostle) said: 'Abd al- Rahman, take her to Tan'im (so as to enable her) to perform Umra (separately), and it was the night at Hasba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2792]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2792

Jabir b. Abdullah is reported to have said that the Apostle of Allah (may peace be upon him) came to 'A'isha (Allah be pleased with her) and she was weeping. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2793]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2793

Jabir b. 'Abdullah reported that A'isha (Allah be pleased with her) enter- ed into the state of Ihram (separately) for 'Umra while the Prophet (may peace be upon him) was performing Hajj. The rest of the hadith is the same, but with this addi- tion: The Messenger of Allah (may peace be upon him) was a person of gentle disposi- tion, so when she (A'Isha) wished for a thing, he accepted it (provided it did not contravene the teachings of Islam). So he (in pursuance of her desire for a separate lhram for Umra) sent her with 'Abd al-Rahman b. Abu Bakr and she put on Ihram for 'Umra at al-Tan'im. Matar and Abu Zubair (the two narrators amongst the chain of transmitters) said: Whenever 'A'isha performed Hajj she did as she bad done along with Allah's Apostle (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2794]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2794

Jabir (Allah be pleased with him) said.: We went with Allah's Messenger (may peace be upon him) in 'a state of Ihram for the Hajj. There were women and children with us. When we reached Mecca we circumambulated the House and (ran) between al-Safa and al-Marwa. The Messenger of Allah (may peace be upon him) said: He who has no sacrificial animal with him should put off lhram. We said: What kind of putting off? He said: Getting out of lhram completely. So we came to our wives, and put on our clothes and applied perfume. When it was the day of Tarwiya, we put on Ihram for Hajj. and the first circumambulation and (running) between al-Safa and al-Marwa sufficed us.. Allah's Messenger (may peace be upon him) commanded us to become seven partners (in the sacrifice) of a camel and a cow.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2795]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2795

Jabir b. Abdullah reported that the Apostle of Allah (may peace be upon him) ordered us to put on Ihram (again) as we proceeded towards Mina after we had put it off (i. e. 'on the 8th of Dhu'l-Hijja). So we pronounced Talbiya at al-Abtah.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2796]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2796

Jabir b. Abdullah is reported to have said: Neither Allah's Apostle (may peace be upon him) nor his Companions (circumambulated the Ka'ba and) ran between al-Safa and al-Marwa but once (sufficing both for Hajj and 'Umra). But in the hadith transmitted by Muhammad b. Bakr there is an addition:" That is first circumambu- lation."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2797]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2797

'Ata'reported: I, along with some people, heard Jabir b. 'Abdullah saying: We the Companions of Muhammad (may peace be upon him) put on Ihram for Hajj only. Ata' further said that Jabir stated: Allah's Apostle (may peace be upon him) came on the 4th of Dhu'l-Hijja and he commanded us to put off Ihram. 'Ata'said that he (Allah's Apostle) commanded them to put off Ihram and to go to their wives (for inter- course). 'Ata' said: It was not obligatory for them, but (intercourse) with them had become permissible. We said: When only five days had been left to reach 'Arafa, he (the Holy Prophet) commanded us to have intercourse with our wives. And we reached 'Arafa in a state as if we had just intercoursed (with tbem). He ('Ata') said: Jabir pointed with his hand and I (perceive) as if I am seeing his hand as it moved. In the (meantime) the Apostle of Allah (may peace be upon him) stood amongst us and said: You are well aware that I am the most God-fearing, most truthful and most pious amongst you. And if there were not sacrificial animals with me, I would also have put off Ihram as you have put off. And if I were to know this matter of mine what I have come to know later on. I would not have brought sacrificial animals with me. SO they (the Companions) put. olf Ihrim and we also put off and listened to (the Holy Prophet) and obeyed (his command). Jabir said: 'All came with the revenue of the taxes (from Yemen). He (the Holy Prophet) said: For what (purpose) have you entered into the state of Ihram (whether you entered into the state purely for Hajj and, Umra jointly or Hajj and Umra separately)? He said: For the purpose for which the Apostle of Allah (may peace be upon him) had entered. (The Holy Prophet had entered as a Qiran, i. e. Ihram covering both Umra and Hajj simultaneously.) Thereupon Allah's Messenger (may peace be upon him) said: Offer a sacrifice of animal, and retain Ihram. And 'All brought a sacrificial animal for him (for the Holy Prophet). Suraqa b. Malik b. Ju'shum said: Messenger of Allah, is it (this concession putting off Ihram of Hajj or Umra) meant for this year or is it for ever?. He said: It is for ever.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2798]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2798

Jabir b. 'Abdullah (Allah be pleased with them) reported: We entered with the Messenger of Allah (may peace be upon him) in the state of Ihram for Hajj. When we came to Mecca he commanded us to put off Ihrim and make it for 'Umra. We felt It (the command) hard for us, and our hearts were anguished on account of this and it (this reaction of the people) reached the Apostle of Allah (may peace be upon him). We do not know whether he received (this news) from the Heaven (through revelation) or from the people. (Whatever the case might be) he said; O people, put off Ihram. If there were not the sacrificial animals with me, I would have done as you do. So we put off the Ihram (after performing Umra), and we bad intercourse with our wives and did everything which a non-Muhrim does (applying perfume, putting on clothes, etc.), and when It was the day of Tarwiya (8th of Dhu'l-Hijja) we turned our back to Mecca (in order to go to Mini, 'Arafat) and we put on lhram for Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2799]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2799

Musa b. Nafi reported: I came to Mecca as a Mutamattil for Umra (per- forming Umra first and then putting off lhram and again entering into the state of Ihram for Hajj) four days before the day of Tarwiya (i. e. on tee 4th of Dhu'l-Hijja). Thereupon the people said: Now yours is the Hajj of the Meccans. I went to 'Ata' b. Abi Rabah and asked his religious verdict. Ata' said: Jabir b. 'Abdullah al'Ans-ari (Allah be pleased wa'th them) narrated to me that he peirforfned Hajj with the Messenger of Allah (may peace be upon him) in the year when he took sacrificial animals with him (i. e. during the 10th year of Hijra known as the Farewell Pilgrimage) and they had put on Ihram for Hajj only (as Mufrid). The Messenger of Allah (may peace be upon him) said: Put off Ihram and circumambulate the House, and (run) between al-Safa and al-Marwa. and get your hair cut and stay as non-Muhrims. When it was the day of Tarwiya, then put on Ihram for Hajj and make lhram for Mut'a (you had put on Ihram i f or Hajj, but take it off af ter perf orming Umra and then again put on Ihram for Hajj). They said: How should we make it Mut'a although we entered upon lhram in the name of Hajj? He said: Do whatever I command you to do. Had I not brought sacrificial animals with me, I would have done as I have commanded you to do. But it is not permissible for me to put off Ihram till tLe sacrifice is offered. Then they also did accordingly.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2800]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2800

Jabir b. 'Abdullah (Allah be pleased with them) reported: We set out with Allah's Messenger (may peace be upon him) as Muhrim for Hajj. The Messenger of Allah (may peace be upon him) commanded us to make this Ihram for Umra, and some put it off (af ter performing 'Umra), but the Prophet (may peace be upon him) had sacrificial animals with him, so he could not make it (this Ihram) as that of Umra.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2801]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2801

Abu Nadra reported: Ibn'Abbas commanded the performance of Mut'a putting lhram for 'Umra during the months of Dhu'I-Hijja and after completing it. then putting on Ibrim for Hajj), but Ibn Zubair forbade to do it. I made a mention of it to Jabir b. Abdullih and he said: It is through me that this hadith has been circulated. We entered into the state of Ihram as Tamattu' with the Messenger of Allah (may peace be upon him). When 'Umar was Installed as Caliph, he said: Verily Allah made permissible for His Messenger (may peace be upon him) whatever He liked and as Re liked. And (every command) of the Holy Qur'an has been revealed for every occasion. So accomplish Hajj and Umra for Allah as Allah has commanded you; and confirm by (proper conditions) the marriage of those women (with whom you have performed Mut'a). And any person would come to me with a marriage of appointed duration (Mut'a), I would stone him (to death). Qatada narrated this hadith with the same chain of transmitters saying: (That 'Umar also said): Separate your Hajj from 'Umra, for that is the most complete Hajj, and complete your Umra.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2802]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2802

Jabir b. 'Abdullah (Allah be pleased with them) reported: We came with the Messenger of Allah (May peace be upon him) pronouncing Talbiya for Hajj, and the Messenger of Allah (May peace be upon him) commanded us to make (our Ihram) into that of Umra.

FAREWELL PILGRIMAGE OF THE APOSTLE OF ALLAH (MAY PEACE BE UPON HIM)

Just as the first revelation in the cave of Hira' marks the advent of the apostolic mission of Muhammad (May peace be upon him), similarly his Farewell Pilgrimage marks its crowning glory. Opinions differ as to when Hajj became obligatory but the commonly accepted opinion is that it was in the eighth year of Hijra that Allah declared it as one of the five fundamentals of Islam. In the ninth year of Hijra the Holy Prophet (may peace be upon him) sent Abu Bakr as the leader of the Hajj delegation but he himself did not go. Hadrat Abu Bakr was later on joined by Hadrat Ali in order to make a sure declaration on behalf of the Holy Prophet (may peace be upon him) which concerned the freedom from obligation in regard to those idolatrous tribes who had shown no respect for the treaties which they had entered into with the Holy Prophet (May peace be upon him). This declaration is contains in the opening verses of Sura Tauba.

The Holy Prophet (May peace be upon him) spent this year in making preparations for the Hajj in the tenth year of Hijra which coincided with the sixty-third year (the last year) of his life. Every attempt was, therefore, made to take full advantage of this great assembly. Messengers were sent to all parts of Arabia inviting people to join him in this great Pilgrimage. It was necessary for them since they should learn by first-hand knowledge the several injunctions and practices of the Pilgrimage-free from all taints of ignorance-an ideal pattern which was to be kept intact in its pristine glory for all times to come. Not only the rites and rituals of the Pilgrimage were to be finally explained by the Holy Prophet (May peace be upon him) but all those things which had any concern with Islam had been finalized.

The Holy Prophet (May peace be upon him) delivered a khutba on the 24th of Dhi-Qa'da on the occasion of the Friday prayer and gave the Muslims necessary instructions relating to Hajj. Next day, I. e. on the 25th of Dhi-Qa'da, he set out after Zuhr prayer on a journey for Hajj along with thousands of his devoted Companions. The 'Asr prayer was offered at Dhu'l-Hulaifa. The caravan spent the night there and it was there after the Zuhr prayer that the Holy Prophet (May peace be upon him) and his Companions put on Ihram and proceeded towards Mecca. They reached their destination on the 4th of Dhu'l-Hijja pronouncing Talbiya (Labbaik, Labbaik, Allahumma Labbaik).

As the caravan moved on the number of participants swelled till, according to some of the narrators, it reached more than one lakh and thirty thousands. The Farewell Pilgrimage is one of the most important occasions in the sacred life of Muhammad (May peace be upon him). Apart from the rites and rituals, the addresses and speeches of the Holy Prophet (May peace be upon him) succinctly sum up the teachings of Islam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2803]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2803

Ja'far b Muhammad reported on the authority of his father: We went to Jabir b. Abdullah and he began inquiring about the people (who had gone to see him) till it was my turn. I said: I am Muhammad b. 'Ali b. Husain. He placed his hand upon my head and opened my upper button and then the lower one and then placed his palm on my chest (in order to bless me), and I was, during those days, a young boy, and he said: You are welcome, my nephew. Ask whatever you want to ask. And I asked him but as he was blind (he could not respond to me immediately), and the time for prayer came. He stood up covering himself in his mantle. And whenever he placed its ends upon his shoulders they slipped down on account of being short (in size). Another mantle was, however, lying on the clothes rack near by. And he led us in the prayer. I said to him: Tell me about the Hajj of Allah's Messenger (May peace be upon him). And he pointed with his hand nine, and then stated: The Messenger of Allah (may peace be upon him) stayed in (Medina) for nine years but did not perform Hajj, then he made a public announcement in the tenth year to the effect that Allah's Messenger (may peace be upon him) was about to perform the Hajj. A large number of persons came to Medina and all of them were anxious to follow the Messenger of Allah (May peace be upon him) and do according to his doing. We set out with him till we reached Dhu'l-Hulaifa. Asma' daughter of Umais gave birth to Muhammad b. Abu Bakr. She sent message to the Messenger of Allah (May peace be upon him) asking him: What should 1 do? He (the Holy Prophet) said: Take a bath, bandage your private parts and put on Ihram. The Messenger of Allah (May peace be upon him) then prayed in the mosque and then mounted al-Qaswa (his she-camel) and it stood erect with him on its back at al-Baida'. And I saw as far as I could see in front of me but riders and pedestrians, and also on my right and on my left and behind me like this. And the Messenger of Allah (may peace be upon him) was prominent among us and the (revelation) of the Holy Qur'an was descending upon him. And it is he who knows (its true) significance. And whatever he did, we also did that. He pronounced the Oneness of Allah (saying):" Labbaik,0 Allah, Labbaik, Labbaik. Thou hast no partner, praise and grace is Thine and the Sovereignty too; Thou hast no partner."

And the people also pronounced this Talbiya which they pronounce (today). The Messenger of Allah (May peace be upon him) did not reject anything out of it. But the Messenger of Allah (May peace. be upon him) adhered to his own Talbiya. Jabir (Allah be pleased with him) said: We did not have any other intention but that of Hajj only, being unaware of the Umra (at that season), but when we came with him to the House, he touched the pillar and (made seven circuits) running three of them and walking four. And then going to the Station of Ibrahim, he recited:" And adopt the Station of Ibrahim as a place of prayer." And this Station was between him and the House. My father said (and I do not know whether he had made a mention of it but that was from Allah's Apostle [May peace be upon him] that he recited in two rak'ahs:" say: He is Allah One," and say:" Say: 0 unbelievers." He then returned to the pillar (Hajar Aswad) and kissed it. He then went out of the gate to al-Safa' and as he reached near it he recited:" Al-Safa' and al-Marwa are among the signs appointed by Allah," (adding: ) I begin with what Allah (has commanded me) to begin. He first mounted al-Safa' till he saw the House, and facing Qibla he declared the Oneness of Allah and glorified Him, and said:" There is no god but Allah, One, there is no partner with Him. His is the Sovereignty. to Him praise is due. and He is Powerful over everything. There is no god but Allah alone, Who fulfilled His promise, helped His servant and routed the confederates alone." He then made supplication in the course of that saying such words three times. He then descended and walked towards al-Marwa, and when his feet came down in the bottom of the valley, he ran, and when he began to ascend he walked till he reached al-Marwa. There he did as he had done at al-Safa'. And when it was his last running at al-Marwa he said: If I had known beforehand what I have come to know afterwards, I would not have brought sacrificial animals and would have performed an 'Umra. So, he who among you has not the sacrificial animals with him should put off Ihram and treat it as an Umra. Suraqa b. Malik b. Ju'sham got up and said: Messenger of Allah, does it apply to the present year, or does it apply forever? Thereupon the Messenger of Allah (May peace be upon him) intertwined the fingers (of one hand) into another and said twice: The 'Umra has become incorporated in the Hajj (adding):" No, but for ever and ever." 'All came from the Yemen with the sacrificial animals for the Prophet (May peace be upon him) and found Fatimah (Allah be pleased with her) to be one among those who had put off Ihram and had put on dyed clothes and had applied antimony. He (Hadrat'Ali) showed disapproval to it, whereupon she said: My father has commanded me to do this. He (the narrator) said that 'Ali used to say in Iraq: I went to the Messenger of Allah (may peace be upon him) showing annoyance at Fatimah for what she had done, and asked the (verdict) of Allah's Messenger (may peace be upon him) regarding what she had narrated from him, and told him that I was angry with her, whereupon he said: She has told the truth, she has told the truth. (The Holy Prophet then asked 'Ali): What did you say when you undertook to go for Hajj? I ('Ali) said: 0 Allah, I am putting on Ihram for the same purpose as Thy Messenger has put it on.

He said: I have with me sacrificial animals, so do not put off the Ihram. He (Jabir) said: The total number of those sacrificial animals brought by 'Ali from the Yemen and of those brought by the Apostle (may peace be upon him) was one hundred. Then all the people except the Apostle (may peace be upon him) and those who had with them sacrificial animals, put off Ihram, and got their hair clipped; when it was the day of Tarwiya (8th of Dhu'l-Hijja) they went to Mina and put on the Ihram for Hajj and the Messenger of Ailah (may peace be upon him) rode and led the noon, afternoon, sunset 'Isha' and dawn prayers. He then waited a little till the sun rose, and commanded that a tent of hair should be pitched at Namira. The Messenger of Allah (may peace be upon him) then set out and the Quraish did not doubt that he would halt at al-Mash'ar al-Haram (the sacred site) as the Quraish used to do in the pre-Islamic period. The Messenger of Allah (may peace be upon him), however, passed on till he came to 'Arafa and he found that the tent had been pitched for him at Namira. There he got down till the sun had passed the meridian; he commanded that al-Qaswa should be brought and saddled for him. Then he came to the bottom of the valley, and addressed the people saying: Verily your blood, your property are as sacred and inviolable as the sacredness of this day of yours, in this month of yours, in this town of yours. Behold! Everything pertaining to the Days of Ignorance is under my feet completely abolished. Abolished are also the blood-revenges of the Days of Ignorance.

The first claim of ours on blood-revenge which I abolish is that of the son of Rabi'a b. al-Harith, who was nursed among the tribe of Sa'd and killed by Hudhail. And the usury of she pre-Islamic period is abolished, and the first of our usury I abolish is that of 'Abbas b. 'Abd al-Muttalib, for it is all abolished. Fear Allah concerning women! Verily you have taken them on the security of Allah, and intercourse with them has been made lawful unto you by words of Allah. You too have right over them, and that they should not allow anyone to sit on your bed whom you do not like. But if they do that, you can chastise them but not severely. Their rights upon you are that you should provide them with food and clothing in a fitting manner. I have left among you the Book of Allah, and if you hold fast to it, you would never go astray. And you would be asked about me (on the Day of Resurrection), (now tell me) what would you say? They (the audience) said: We will bear witness that you have conveyed (the message), discharged (the ministry of Prophethood) and given wise (sincere) counsel. He (the narrator) said: He (the Holy Prophet) then raised his forefinger towards the sky and pointing it at the people (said):" O Allah, be witness. 0 Allah, be witness," saying it thrice. (Bilal then) pronounced Adhan and later on Iqama and he (the Holy Prophet) led the noon prayer. He (Bilal) then uttered Iqama and he (the Holy Prophet) led the afternoon prayer and he observed no other prayer in between the two.

The Messenger of Allah (may peace be upon him) then mounted his camel and came to the place of stay, making his she-camel al-Qaswa, turn towards the side where there we are rocks, having the path taken by those who went on foot in front of him, and faced the Qibla. He kept standing there till the sun set, and the yellow light had somewhat gone, and the disc of the sun had disappeared. He made Usama sit behind him, and he pulled the nosestring of Qaswa so forcefully that its head touched the saddle (in order to keep her under perfect control), and he pointed out to the people with his right hand to be moderate (in speed), and whenever he happened to pass over an elevated tract of sand, he slightly loosened it (the nose-string of his camel) till she climbed up and this is how he reached al-Muzdalifa. There he led the evening and 'Isha prayers with one Adhan and two Iqamas and did not glorify (Allah) in between them (i. e. he did not observe supererogatory rak'ahs between Maghrib and 'Isha' prayers). The Messenger of Allah (may peace be upon him) then lay down till dawn and offered the dawn prayer with an Adhan and Iqama when the morning light was clear. He again mounted al-Qaswa, and when he came to al-Mash'ar al-Haram, he faced towards Qibla, supplicated Him, Glorified Him, and pronounced His Uniqueness (La ilaha illa Allah) and Oneness, and kept standing till the daylight was very clear.

He then went quickly before the sun rose, and seated behind him was al-Fadl b. 'Abbas and he was a man having beautiful hair and fair complexion and handsome face. As the Messenger of Allah (May peace be upon him) was moving on, there was also going a group of women (side by side with them). Al-Fadl began to look at them. The Messenger of Allah (may peace be upon him) placed his hand on the face of Fadl who then turned his face to the other side, and began to see, and the Messenger of Allah (may peace be upon him) turned his hand to the other side and placed it on the face of al-Fadl. He again turned his face to the other side till he came to the bottom of Muhassir. 1680 He urged her (al-Qaswa) a little, and, following the middle road, which comes out at the greatest jamra, he came to the jamra which is near the tree. At this be threw seven small pebbles, saying Allah-o-Akbar while throwing every one of them in a manner in which the small pebbles are thrown (with the help of fingers) and this he did in the bottom of the valley. He then went to the place of sacrifice, and sacrificed sixty-three (camels) with his own hand. Then he gave the remaining number to 'All who sacrificed them, and he shared him in his sacrifice. He then commanded that a piece of flesh from each animal sacrificed should be put in a pot, and when it was cooked, both of them (the Holy Prophet and Hadrat 'All) took some meat out of it and drank its soup. The Messenger of Allah (May peace be upon him) again rode and came to the House, and offered the Zuhr prayer at Mecca. He came to the tribe of Abd al-Muttalib, who were supplying water at Zamzam, and said: Draw water. O Bani 'Abd al-Muttalib; were it not that people would usurp this right of supplying water from you, I would have drawn it along with you. So they handed him a basket and he drank from it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2804]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2804

Ja'far b. Muhammad narrated on the authority of his father thus: I came to Jabir b. Abdullah and asked him about the (Farewell) Pilgrimage of Allah's Messenger (may peace be upon him). The rest of the hadith is the same, but with the addition of this:" There was one Abu Sayyara among the Arabs, (of pre-Islamic period) who carried (people from Muzdalifa to Mini). As the Messenger of Allah (May peace be upon him) set out from Muzdalifa to al-Mash'ar al-Haram, the Quraish were certain that he would halt there and that would be his station. But he passed on (without staying) there. and paid no heed to it till he came to 'Arafat and there he stayed."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2805]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2805

Jabir reported Allah's Messenger (May peace be upon him) as saying: I have sacrificed (the animals) here, and the whole of Mini is a place for sacrifice; so sacrifice your animals at your places. 1 have stayed here (near these rocks), and the whole of Arafat is a place for stay. And I have stayed here (at Muzdalifa near Mash'ar al-Haram and the whole of Muzdalifa) is a place for stay (i. e. one is permitted to spend night in any part of it, as one likes).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2806]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2806

Jabir b. Abdullah (Allah be pleased with them) reported that when Allah's Messenger (may peace be upon him) proceeded to Mecca, he came to it (the Black Stone). he kissed it. and moved to his right. and moved quickly in three circuits, and walked in four circuits.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2807]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2807

'A'isha (Allah be pleased with her) reported that the Quraish (of the pre-Islamic days) and those who followed their religions practices stayed at Muzdalifa, and they named themselves as Hums, whereas all other Arabs stayed at 'Arafa. With the advent of Islam, Allah, the Exalted and Glorious, commanded His Apostle (may peace be upon him) to come to 'Arafat and stay there, and then hurry from there, and this is the significance of the words of Allah:" Then hasten on from where the people hasten on."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2808]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2808

Hisham narrated on the authority of his father that the Arabs with the exception of Hums who were Quraish, and their descendants, circumambulated the House naked. They kept circumambulating In this state of nudity unless the Hums supplied to them the clothes. The male provided (clothes) to the male and the female provided clothes to the female. And the Hums did not get out of Muzdalifa, whereas the people (other than the Quraish) went t o 'Arafat. Hisham said on the authority of his father who related from 'A'isha (Allah be pleased with her) who said: Hums are those about whom Allah, the Exalted and Glorious, revealed this verse:" Then hasten to where the people hasten." She (further) said: The people hastened on from 'Arafat, whereas Hums hastened from Muzdalifa, and said: We'do not hasten but from Haram. But when this (verse) was revealed:" Hasten on from that (place) where the people hasten on," they (the Quraish) then went to 'Arafat.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2809]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2809

Jubair. b. Mut'im reported: I lost my camel and went in search of it on the day of 'Arafa, and I saw the Messenger of Allah (may peace be upon him) staying along with people in 'Ara'fit. Thereupon I said: By Allah, he is among the Hums (Quraish) ; what has happened to him that he has come to this (place)? The Quraish were counted among Hums.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2810]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2810

Abu Musa (Allah be pleased with him) said: I came to the Messenger of Allah (may peace be upon him) as he was encamping at Batha. He said to me: Did you intend to perform Hajj? I said: Yes. He again said: With what intention have you entered into the state of Ihram (for Ifrad, Qiran or Tamattu'). I said: I pronounced Talbiya (I have entered into the state of Ihram ) with that very aim with which the Apostle of Allah (may peace be upon him) is pronouncing Talbiya. He (the Holy Prophet) said; You have done well. Then circumambulate the House and run between al-Safa' and al-Marwa' and put off Ihram (as you have not brought the sacrificial animals along with you). So I circumambulated the House, and ran between al-Safa' and al-Marwa' and then came to a woman of the tribe of Qais and she rid my head of the lice. I again put on Ihram for Hajj. and continued giving religious verdict (according to this practice) till during the Caliphate of Umar (Allah be pleased with him) when a person said to him: Abu Musa, or Abdullah b. Qais, exercise restraint in delivering some religious verdict of yours, for you do not know what has been introduced after you by the Commander of the Believers in the rites (of Hajj). Thereupon he said: 0 people, whom we gave the religious verdict (concerning putting off Ihram ) they should wait, for the Commander of the Believers is about to come to you, and you should follow him. Umar (Allah be pleased with him) then came and I made a mention of it to him. whereupon he said: If we abide by the Book of Allah (we find) the Book of Allah has commanded us to complete the (. Hajj and 'Umra), and if we abide by the Sunnah of Allah's Messenger (may peace be upon him), we find that Allah's Messenger (may peace be upon him) did not put off Ihram till the sacrificial animal was brought to its end (till it was sacrificed).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2811]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2811

This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2812]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2812

Abu Musa (Allah be pleased with him) reported: I came to the Messenger of Allah (may peace be upon him) and he was encamping at Batha. He (the Holy Prophet) said: With what purpose have you entered into the state of Ihram? I said: I have entered into the state of Ihram in accordance with the Ihram of Allah's Apostle (may peace be upon him). He said: Have you brought sacrificial animals along with you? I said: No. whereupon he said: Then circumambulate the House and run between al-Safa' and al-Marwa and put off Ihram. So I circumambulated the House, ran between al-Safa' and al-Marwa, and then came to a woman of my tribe. She combed and washed my head. I used to give religious verdict (according to the above mentioned command of the Holy Prophet) during the Caliphate of Abu Bakr and also during that of 'Umar. And it was during the Hajj season that a person came to me and said: You (perhaps) do not know what the Commander of the Believers has introduced in the rites (of Hajj). I said: 0 people, those whom we have given religious verdict about a certain thing should wait, for the Commander of the Believers is about to arrive among you, so follow him. When the Commander of the Believers arrived, I said: What is this that you have introduced in the rites (of Hajj)? -where upon he said: If we abide by the Book of Allah (we find) that there Allah, Exalted and Majestic, has said: Complete Hajj and 'Umra for Allah." And if we abide by the Sunnah of our Apostle (may peace be upon him) (we find) that the Apostle of Allah (May peace be upon him) did not put off Ihram till he had sacrificed the animals.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2813]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2813

Abu Musa (Allah be pleased with him) reported: The Messenger of Allah (May peace be upon im) had sent me to Yemen and I came back In the year in which he (the Holy Prophet) performed the (Farewell) Pilgrimage. Allah's Messenger (may peace be upon, him) said to me: Abu Musa, what did you ' say when you entered into the state of Ihram? I said: At thy beck and call; my (Ihram) is that of the Ihram of Allah's Apostle (May peace be upon him). He said: Have you brought the sacrificial animals? I said: No. Thereupon he said: Go and circumambulate the House, and (run) between al-Safa' and al-Marwa and then put off Ihram. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2814]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2814

Abu Musa, (Allah be pleased with him) reported that he used to deliver religious verdict in favor of Hajj Tamattu'. A person said to him: Exercise restraint in delivering some of your religious verdicts, for you do not know what the Commander of Believers has introduced in the rites (of Hajj) after you (when you were away in Yemen). He (Abu Musa, ) met him (Hadrat Umar) subsequently and asked him (about it), whereupon 'Umar said: I know that Allah's Apostle (May peace be upon him) and also his Companions did that (observed Tamattu'), but I do not approve that the married persons should have intercourse with their wives under the shade of the trees, and then set out for Hajj with water trickling down from their beads.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2815]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2815

'Abdullah b. Shaqiq reported that 'Uthman (Allah be pleased with him) used to forbid Tamattu', whereas 'Ali (Allah be pleased with him) ordered to do it. 'Uthman said a word to 'Ali, but 'Ali said: You know that we used to perform Tamattu' with the Messenger of Allah (may peace be upon him), whereupon he said: It is right, but we entertained fear. This hadith has been narrated by Shu'ba with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2816]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2816

Sa'id b. al-Musayyab reported that 'Ali and 'Uthman (Allah be pleased with them) met at 'Usfan; and Uthman used to forbid (people) from performing Tamattu' and 'Umra (during the period of Hajj), whereupon 'Ali said: What is your opinion about a matter which the Messenger of Allah (may peace be upon him) did but you forbid it? Thereupon Uthman said: You leave us alone, whereupon he ('Ali) said: I cannot leave you alone. When 'Ali saw this, he put on Ihram for both of them together (both for Hajj and 'Umra).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2817]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2817

Abu Dharr (Allah be pleased with him) said that Tamattu' in Ha was a special (concession) 1694 for the Companions of Muhammad (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2818]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2818

Abu Dharr (Allah be pleased with him) reported: Tamattu' in Hajj was a special concession for us.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2819]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2819

Abu Dharr (Allah be pleased with him) said: Two are the Mut'as which were not permissible but only for us, i. e. temporary marriage with women and Tamattu' in Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2820]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2820

'Abd al-Rahman b. Abi al-Sha'tha' reported: I came to Ibrahim al-Nakha'I and Ibrahim Taimi and said: I intend to combine 'Umra and Hajj this year, whereupon Ibrahim al-Nakha'i said: But your father did not make such intention. Ibrahim narrated on the authority of, his father that he passed by Abu Dharr (Allah be pleased with him) at Rabdha, and made a mention of that, whereupon he said: It was a special concession for us and not for you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2821]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2821

Ghunaim b. Qais said: I asked Sa'd b. Abu Waqqas (Allah be pleased with him) about Mut'a, whereupon he said: We did that, and it was the day when he was an unbeliever living in (one of the) houses of Mecca.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2822]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2822

This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters and in his narration (he) refers to Mu'awiya.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2823]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2823

This hadith has been transmitted on the authority of Sulaiman (but with a slight modification of words).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2824]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2824

Mutarrif reported: 'Imran b. Husain said to me: Should I not narrate to you a hadith today by which Allah will benefit you subsequently-and bear in mind that Allah's Messenger (may peace be upon him) made some members of his family perform 'Umra within ten days of Dhu'l-Hijja. No verse was revealed to abrogate that, and he (the Holy Prophet) did not refrain from doing it till he died. So after him everyone said as he liked, (but it would be his. personal opinion and not the verdict of the Shari'ah).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2825]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2825

This hadith been narrated on the authority of Jurairi with the same chain of transmitters, and Ibn Hatim said in his narration:" A person said according to his personal opinion, and it was Umar."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2826]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2826

Imran b. Husain reported: I am narrating to you a hadith by which Allah will benefit you (and the hadith is) that Allah's Messenger (may peace be upon him) combined Hajj and 'Umra, and he did not forbid (this combination) till he died. (Moreover) nothing was revealed in the Holy Qur'an which forbade it. And I was always blessed till I was branded and then it (blessing) was abandoned. I then abandoned branding and it (the blessing was restored).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2827]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2827

This hadith has been narrated on the authority of Mutarrif with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2828]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2828

Mutarrif reported: 'Imran b. Husain sent for me during his illness of which he died, and said: I am narrating to you some ahadith which may benefit you after me. If I live you conceal (the fact that these have been transmitted by me), and if I die, then you narrate them if you like (and these are): I am blessed, and bear in mind that the Messenger of Allah (may peace be upon him) combined Hajj and Umra. Then no verse was revealed in regard to it in the Book of Allah (which abrogated it) and the Apostle of Allah (may peace be upon him) did not forbid (from doing it). And whatever a person (, Umar) said was out of his personal opinion.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2829]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2829

'Imran b. al-Husain (Allah be pleased with him) said: Know well that Allah's Messenger (may peace be upon him) combined 'Hajj and 'Umra, and nothing was revealed in the Book (to abrogate it), and the Messenger of Allah (may peace be upon him) too did not forbid us from (combining) them. And whatever a person said was out of his personal opinion.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2830]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2830

'Imran b. Husain (Allah be pleased with him) reported: We performed Tamattu' (Hajj and 'Umra combining together) in the company of Allah's Messenger (may peace be upon him), and nothing was revealed in the Qur'an (concerning the abrogation of this practice), and whatever a person (Hadhrat 'Umar) said was his personal opinion. 'Imran b. Husain narrated this hadith (in these words also):" Allah's Apostle (may peace be upon him) performed Hajj Tamattu' and we also performed it along with him."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2831]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2831

'Imran b. Husain said: There was revealed the verse of Tamattu' in Hajj in the Book of Allah and the Messenger of Allah (may peace be upon him) commanded us to perform it. and then no verse was revealed abrogating the Tamattu' (form of Hajj), and the Messenger of Allah (may peace be upon him) did not forbid to do it till he died. So whatever a person said was his personal opinion. A hadith like this is transmitted on the authority of Imran b. Husain, but with this variation that he ('Imran) said: We did that (Tamattu') in the company of Allah's Messenger (may peace be upon him) and he did not say anything but he (the Holy Prophet) commanded us to do it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2832]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2832

Abdullah b. 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) observed Tamattu' in Hajjat-ul-Wada'. He first put on Ihram for 'Umra and then for Hajj. and then offered animal sacrifice. So he drove the sacrificial animals with him from Dhu'l-Hulaifa. Allah's Messenger (may peace be upon him) commenced Ihram of Umra and thus pronounced Talbiya for 'Umra. and then (put on Ihram for Hajj) and pronounced Talbiya for Hajj. And the people performed Tamattu' in the company of Allah's Messenger (may peace be upon him). They put on Ihram for Umra (first) and then for Hajj. Some of them had sacrificial animals which they had brought with them, whereas some of them had none to sacrifice. So when Allah's Messenger (may peace be upon him) came to Mecca, he said to the people: He who amongst you has brought sacrificial animals along with him must not treat as lawful anything which has become unlawful for him till he has completed the Hajj; and he, who amongst you has not brought the sacrificial animals should circumambulate the House, and run between al-Safa' and al-Marwa and clip (his hair) and put off the Ihram, and then again put on the Ihram for Hajj and offer sacrifice of animals. But he who does not find the sacrificial animal, he should observe fast for three days during the Hajj and for seven days when he returns to his family. Allah's Messenger (may peace be upon him) circumambulated (the House) when he came to Mecca: he first kissed the corner (of the Ka'ba containing the Black Stone), then ran in three circuits out of seven and walked in four circuits. And then when he had finished the circumambulation of the House he observed two rak'ahs of prayer at the Station (of Ibrahim), and then pronounced Salaam (for concluding the rak'ahs), and departed and came to al-Safa' and ran seven times between al-Safa' and al-Marwa. After that he did not treat anything as lawful which had become unlawful till he had completed his Hajj and sacrificed his animal on the day of sacrifice (10th of Dhu'l-Hijja). and then went back quickly (to Mecca) and performed circumambulation of the House (known as tawaf ifada) after which all that was unlawful for him became lawful; and those who had brought the sacrificial animals along with them did as Allah's Messenger (may peace be upon him) had done. This hadith has been narrated on the authority of 'A'isha. The wife of Allah's Messenger (may peace be upon him), concerning his Tamattu' of Hajj and 'Umra and performing of Tamattu' by people in his company.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2833]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2833

Hafsa (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), said: Messenger of Allah. what about people who have put off Ihram whereas you have not put it off after your 'Umra? He said: I have stuck my hair and have driven my sacrificial animal, and would not, therefore, put off Ihram until I have sacrificed the animal.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2834]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2834

Hafsa (Allah be pleased with her) reported: I said: Messenger of Allah what is the matter with you that you have not put off Ihram? The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2835]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2835

Hafsa (Allah be pleased with her) reported: I said to Allah's Messenger (may peace be upon him): What is the matter with people that they have put off Ihram, whereas you have not put it off after your Umra'? He said: I have driven my sacrificial animal and stuck my hair, and it is not permissible for me to put off Ihram unless I have completed the Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2836]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2836

Hafsa (Allah be pleased with her) said: Messenger of Allah; the rest of the hadith is the same and (the concluding words of the Holy Prophet):" I won't put off Ihram until I have sacrificed the animal."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2837]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2837

Hafsa (Allah be pleased with her) said that Allah's Apostle (may peace be upon him) commanded his wives that they should put off Ihram during the year of Hajj (at-ul-Wada'). whereupon she (Hafsa) said: What hinders you that you have not put off Ihram? Thereupon he said: I have stuck my hair and driven my sacrificial animal along with men and it is not permissible to put off Ihram (under this condition until I have sacrificed the animal.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2838]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2838

Nafi' reported that 'Abdullah b. Umar (Allah be pleased with them) set out for Umra during the turmoil, and he said: If I am detained (from going to) the House, we would do the same as we did with Allah's Messenger (may peace be upon him). So he went out and put on Ihram for 'Umra and moved on until he reached al-Baida'. He turned towards his Companions and said: There is one command for both of them. and 1 call you as my witness (and say) that verify I have- made Hajj with 'Umra compulsory for me. He proceeded until, when he came to the House, he circumambulated it seven times and ran between al-Safa' and al-Marwa seven times, and made no addition to it and thought it to be sufficient for him and offered sacrifice.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2839]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2839

Nafi' reported that 'Abdullah b. 'Abdullah and Salim b. Abdullah said to 'Abdullah (b. 'Umar) at the time when Hajjaj came to fight against Ibn Zubair: There would be no harm if you do not (proceed) for Hajj this year, for we fear that there would be fight among people which would cause obstruction between you and the House, whereupon he said: If there would be obstruction between me and that (Ka'ba), I would do as Allah's Messenger (may peace be upon him) did. I was with him (the Holy Prophet) when the infidels of Quraish caused obstructions between him (the Holy Prophet) and the House. I call you as my witness (to the fact) that I have made 'Umra essential for me. He proceeded until he came to Dhu'l-Hulaifa and pronounced Talbiya for Umra, and said: If the way Is clear forme, I would then complete my 'Umra but If there is some obstruction between me and that (the Ka'ba). I would then do what Allah's Messenger (may peace be upon him) had done (at the occasion of Hudaibiya), and I was with him (the Holy Prophet). and then recited:" Verily in the Messenger of Allah, there is a model pattern for you" (xxxiii. 21). He then moved on until he came to the rear side of al-Baida' and said: There is one command for both of them automatically) (Hajj and Umra). If I am detained (in the performance) of 'Umra, I am ( automatically detained (in the performance) of Hajj (too). I call you as witness that Hajj along with 'Umra I had made essential for me. (I am performing Hajj and 'Umra as Qiran.) He then bought sacrificial animals at Qudaid and then circumambulated the House and ran between al-Safa' and al-Marwa once (covering both Hajj and Umra), and did not put off Ihram until on the Day of Sacrifice in the month of Dhu'l-Hijja.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2840]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2840

Nafi' reported that Ibn Umar intended to go to Hajj (during the year) when Hajjaj attacked Ibn Zubair, and he narrated the account as (narrated above), and he used to say at the end of the hadith: He who combines Hajj with Umra, for him one single circumambulation is sufficient, and he did not put off Ihram until he had completed both of them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2841]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2841

Nafi' reported that Ibn Umar intended to go for Hajj during the year when Hajjaj attacked Ibn Zubair. It was said to him: There is a state of war between people and we fear that they would detain you, whereupon he ('Abdullah b. Umar) said:" Verily in the Messenger of Allah there is a model pattern for you." I would do as Allah's Messenger (may peace be upon him) did. I call you as witness that I have undertaken to perform 'Umra. He then set out until, when he reached the rear side of al-Baida', he said: There is one command both for Hajj and Umra. so bear witness. Ibn Rumh said: I call you as witness that I have undertaken to perform my Hajjalong with my Umra (i. e. I am performing both of them as Qiran), and he offered the sacrifice of animals which he had bought at Qudaid. He then proceeded pronouncing Talbiya for both of them together until he reached Mecca, He circumambulated the House. and (ran) between al-Safa' and al-Marwa and made no addition to it. He neither sacrificed the animal, nor got his head shaved, nor got his hair clipped, nor did he make anything lawful which was unlawful (due to Ihram) until it was the Day of Sacrifice (10th of Dhu'l-Hijja). He then offered sacrifice, and got his hair cut, and saw that circumambulation of Hajj and 'Umra was complete with the first circumambulation. Ibn 'Umar said: This is how Allah's Messenger (may peace be upon him) had done.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2842]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2842

This hadith has been narrated from Ibn Umar through another chain of transmitters except with (this variation) that Allah's Apostle (may peace be upon him) was mentioned in the first part of the hadith,. i. e. when it was said to him: They would bar you (from going) to the House. He said: In that, case I would do what Allah's Messenger (may peace be upon him) had done. He did not mention at the end of this hadith (i. e. these words):" This is how the Messenger of Allah (may peace be upon him) had done," as it Is narrated by al-Laith.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2843]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2843

Nafi' thus reported on the authority of Ibn Umar: We entered into the state of Ihram with Allah's Messenger (may peace be upon him) for Hajj Mufrad and in the narration of Ibn 'Aun (the words are):" Allah's Messenger (may peace be upon him) entered into the state of Ihram (with the intention) of Hajj Mufrad."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2844]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2844

Anas (Allah be pleased with him) said: I heard Allah's Apostle (way peace be upon him) pronouncing Talbiya for both Hajj and Umra. Bakr (one of the narrators) said: I narrated it to Ibn 'Umar, whereupon he said: He (the Holy Prophet) pronounced the Talbiya for Hajj alone. I met Anas and narrated to him the words of Ibn 'Umar, whereupon he said: You treat us not but only as children. I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya both for 'Umra and Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2845]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2845

Bakr b. 'Abdullah reported: Anas (Allah be pleased with him) had narrated to us that he saw Allah's Apostle (may peace be upon him) combining Hajj and 'Umra. He (Bakr) said: I asked (about it) from Ibn 'Umar, whereupon he said: We entered into the state of Ihram for Hajj (only). I came to Anas and told him what Ibn Umar had said, whereupon he remarked: (You are treating us) as if we were children.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2846]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2846

Wabara reported: While I was sitting in the company of Ibn 'Umar, a person came to him and said: Is it right for me to circumambulate the House before I come to stay (at 'Arafat)? Ibn 'Umar said: Yes. whereupon he said: Ibn Abbas, however, says: Do not circumambulate the House until you come to stay at 'Arafat. Thereupon Ibn 'Umar said: Allah's Messenger (may peace be upon him) Performed the Hajj and circumambulated the House before coming to stay (at 'Arafat). If you say the Truth, is it more rightful to follow the saying of the Prophet (may peace be upon him) or the words of Ibn Abbas?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2847]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2847

Wabara reported: A person asked Ibn Umar (Allah be pleased with him): May I circumambulate the House, whereas I have entered-into the state of Ihram for Hajj? Thereupon he said: What prevents you from doing it? He said: I saw the son of so and so showing disapproval of it, and you are dearer to us as compared with him. And we see that he is allured by the world, whereupon he said: Who amongst you and us is not allured by the world? And said (further) ': 'We saw that Allah's Messenger (may peace be upon him) put on Ihram for Hajj and circumambulated the House and run between al Safa' and al-Marwa. And the way prescribed by Allah and that prescribed by His Apostle (may peace be upon him) deserve more to be followed than the way shown by so and so, if you speak the truth.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2848]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2848

Amr b. Dinar said: We asked Ibn Umar about a person who came for Umra and circumambulated the House, but he did not run between al-Safa' and al-Marwa, whether he is allowed to (put off Ihram) and have intercourse with his wife. He replied: Allah's Messenger (may peace be upon him) circumambulated the House seven times and offered two rak'ahs of prayer after staying (at 'Arafat), and ran between al-Safa and al-Marwa seven times." Verily there is in Allah's Messenger a model pattern for you" (xxxill. 21).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2849]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2849

This hadith is narrated by another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2850]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2850

Muhammad b. 'Abd al-Rahman reported: A person from Iraq said to him to inquire from 'Urwa b. Zubair for him whether a person who puts on Ihram for Hajj is allowed to put it off or not as he circumambulates the House. And if he says:" No, it can't be put off," then tell him that there is a person who makes such an assertion. He (Muhammad b. 'Abd al-Rahman) then said: I asked him ( Urwa b. Zubair), where- upon he said: The person who has entered into the state of Ihram for Hajj cannot get out of it unless he has, completed the Hajj I (further) said (to him): (What) if a person makes that assertion? Thereupon he said: It is indeed unfortunate that he makes such an assertion. That person ('Iraqi) then met me and he asked me and I narrated to him (the reply of 'Urwa), whereupon he (the Iraqi) said: Tell him ('Urwa) that a person had informed him that Allah's Messenger (may peace be upon him) had done that; and why is it that Asma' and Zubair have done like this? He (Muhammad b. 'Abd al-Rahman) said: I went to him and made a mention of that to him, whereupon he ('Urwa) said: Who is he (the 'Iraqi)? I said: I do not know, whereupon he said: What is the matter that he does not come to me himself and ask me? I suppose he is an 'Iraqi. I said: I do not know, whereupon he said: He has told a lie. Allah's Messenger (may peace be upon him) performed Hajj, and 'A'isha (Allah be pleased with her) has told me that the first thing with which he commenced (the rituals) when he arrived at Mecca was that he performed ablution and then circumambulated the Ka'ba. Then Abu Bakr performed Hajj and the first thing with which he commenced (the Hajj) as the circumambulation of the Ka'ba and nothing besides it. So did 'Umar. Then 'Uthman performed Hajj and I saw that the first thing with which he commenced the Hajj was the circumambulation of the Ka'ba and nothing besides it. Then Mu'awiya and Abdullah b. 'Umar did that. Then I performed Hajj with my father Zubair b. al-'Awwam, and the first thing with which he commenced (Hajj) was the circumambulation of the House. He then did nothing besides it. I then saw the emigrants (Muhajirin) and the helpers (Ansar) doing like this and nothing besides it. And the last one whom I saw doing like this was Ibn 'Umar. And he did not break it (the Hajj) after performing 'Umra. And Ibn 'Umar is with them. Why don't they ask him (to testify it)? And none amongst those who had passed away commenced (the rituals of Hajj) but by circumambulating the Ka'ba on their (first arrival) and they did not put off Ihram (without completing the Hajj), and I saw my mother and my aunt commencing (their Hajj) with the circumambulation of the House, and they did not put off Ihram. My mother informed me that she came and her sister, and Zubair and so and so for 'Umra, and when they had kissed the corner (the Black Stone, after Sa'i and circumambulation), they put off Ihram. And he (the 'Iraqi) has told a lie in this matter.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2851]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2851

Asma bint Abu Bakr (Allah be pleased with both of them) reported: We set out (to Mecca) in a state of Ihram. Allah's Messenger (may peace be upon him) said: He who has the sacrificial animal with him should remain in the state of Ihram, but he who has not the sacrificial animal with him should put off Ihram. As I had not the sacrificial animal with me, I put off Ihram. And since Zubair (her husband) - had the sacrificial animal with him, he did not put off Ihram. She (Asma) said: I put on my clothes and then went out and sat by Zabair, whereupon he said: Go away from me, whereupon I said: Do you fear that I would jump upon you?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2852]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2852

Asma bint Abu Bakr (Allah be pleased with th (m) said: We came for Hajj in the state of Ihram with Allah's Messenger (may peace be upon him). The rest of the hadith is the same except (for the words) that he (Zubair) said: Keep away from me, keep away from me, whereupon I said: Do you fear that I will jump upon you?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2853]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2853

Abdullah, the freed slave of Asma' bint Abu Bakr (Allah be pleased with them), narrated that he used to hear Asma, ' whenever she passed by Hajun, saying (these words):" May there be peace and blessing of Allah upon His Messenger." We used to stay here along with him with light burdens. Few were our rides, and small were our provisions. I performed 'Umra and so did my sister 'A'isha, and Zubair and so and so. And as we touched the House (performed circumambulation and Sa'i) we put off Ihram, and then again put on Ihram in the afternoon for Hajj. Harun (one of the narrators) in one of the narrations said: The freed slave of Asma' and he did not mention 'Abdullah.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2854]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2854

Muslim al-Qurri reported: I asked Ibn Abbas (Allah be pleased with them) about Tamattu' in Hajj and he permitted it, whereas Ibn Zubair had forbidden it. He (Ibn 'Abbas) said: This is the mother of Ibn Zubair who states that Allah's Messenger (may peace be upon him) had permitted it, so you better go to her and ask her about it. He (Muslim al-Qurri said): So we went to her and she was a bulky blind lady and she said: Verily Allah's Messenger (may peace be upon him) permitted it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2855]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2855

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but with a slight variation of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2856]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2856

Muslim al-Qurri heardlbn 'Abbas (Allah be pleased with them) saying that Allah's Apostle (may peace be upon him) entered into the state of Ihram for Umra and his Companions for Hajj. Neither Allah's Apostle (may peace be upon him) nor those among his Companions who had brought sacrificial animals with them put off Ihram, whereas the rest (of the pilgrims) did so. Talha b. Ubaidullah was one of those who had brought the sacrificial animals along with them so he did not put off Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2857]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2857

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this variation (of words):" Talha and another person also were among those who had not brought the sacrificial animals with them and so they put off Ihram."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2858]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2858

Ibn Abbas (Allah be pleased with them) reported that they (the Arabs of pre-Islamic days) looked upon Umra during the months of Hajj as the greatest of sins on the earth. So they intercalated the month of Muharram for Safar and said: When the backs of their camels would become all right and traces (if the pilgrims) would be effaced (from the paths) and the month of Safar would be over, then Umra would be permissible for one who wants to perform it. When Allah's Apostle (may peace be upon him) and his Companions came in the state of Ihram for performing Hajj on the fourth (of Dhu'l-Hijja) he (Allah's Apostle) commanded them to change their state of Ihram (from Hajj) to that of 'Umra. It was something inconceivable for them. So they said: Messenger of Allah, is it a complete freedom (of the obligation) of Ihram? Thereupon he said: It is a complete freedom (from Ihram).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2859]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2859

Ibn 'Abbas (Allah be pleased with them) 'is reported to have said: The Messenger of Allah (may peace be upon him) put on Ihigm for Hajj. When four days of Dhu'l-Hijja were over, he led the dawn prayer, and when the prayer was complete, he said: He who wants to change it to Umra may do so.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2860]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2860

Rauh and Yahya b. Kathir narrated as Nasr reported that the Messenger of Allah (may peace be upon him) entered into the state of Ihram for Hajj. And in the narration of Abu Shihab (the words are): We went out with the Messenger of Allah (may peace be upon him) pronouncing Talbiya for Hajj, And in an the ahadith (narrated in this connection the words are): He led the morning prayer at al-Batha', except al- jahdami who did not make mention of it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2861]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2861

Ibn 'Abbas (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came along with his Companions when four days had passed out of ten days (of Dhu'l-Hijja) and they were pronouncing Talbiya for Hajj, and he (the Holy Prophet) commanded them to change (this Ihram) into that of 'Umra.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2862]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2862

Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the morning prayer at Dhu Tawa (a valley near Mecca) and arrived (in Mecca) when four days of Dhul-Hijja had passed and he commanded his Companions that they should change their Ihram (of Hajj) to that of Umra, except those who had brought sacrificial animals with them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2863]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2863

Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: This is the 'Umra of which we have taken advantage. So he who has not the sacrificial animal with him should get out of the state of Ihram completely, for 'Umra has been incorporated in Hajj until the Day of Resurrection,


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2864]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2864

Abu Jam at al-Dubu'i reported: I performed Tamattu' but the people dis- couraged me to do so. I came to Ibn 'Abbas and asked him about it. He ordered me to do so. I came to the House (Ka'ba) and slept. I saw a visitant in the dream who said: 'Umra is acceptable and so is the Hajj performed for God's sake. I came to Ibn Abbas and informed him about that Which I saw in the dream whereupon he said: Allah is the Greatest, Allah is the Greatest This is the Sunnah of Abu'l-Qasim (the Holy Pro- phet) (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2865]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2865

Ibn 'Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the Zuhr prayer at Dhu'l-Hulaifa; then called for his she-camel and marked it on the right side of its bump, removed the blood from it, and tied two sandals round its neck. He then mounted his camel, and when it brought him up to al-Baida', he pronounced Talbiya for the Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2866]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2866

This hadith has been narrated on the authority of Qatada with the same chain of transmitters but with this variation (of words):" When Allah's Apostle (may peace be upon him) came to Dhu'l-Hulaifa" and he made no mention (of the fact) that he led the Zuhr prayer.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2867]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2867

Abu Hassan al-A'raj reported that a person from Bani Hujaim said to Ibn 'Abbas (Allah be pleased with them): What is this religious verdict of yours which has engaged the attention of the people or which has become a matter of dispute among them that he who circumambulated the House can be free from Ihram? Thereupon he said: That is the Sunnah of your Apostle (may peace be upon him), even though you may not approve of it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2868]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2868

Abu Hassan reported: It was said to Ibn 'Abbas (Allah be pleased with them) that this affair had engaged the attention of the people that he who circumambu- lates the House was permitted to circumambulate for Umra (even though he was in a state of Ihram for Hajj), whereupon he said: That is the Sunnah of your Apostle (may peace be upon him), even though you may not approve of it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2869]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2869

Ata' said: Ibn 'Abbas (Allah be pleased with them) used to say that a pilgrim or non-pilgrim (one performing 'Umar) who circumambulates the House is free from the responsibility of Ihram. I (Ibn Juraij, one of the narrators) said to 'Ata': On what authority does he (Ibn Abbas) say this? He said: On the authority uf Allah's words:" Then their place of sacrifice is the Ancient House" (al-Qur'an, xxii. 33). I said: It concerns the time after staying at 'Arafat, whereupon he said: Ibn 'Abbas (Allah be pleased with them) had stated (that the place of sacrifice is the Ancient House) ; it way be after staying at 'Arafat or before (staying there). And he (Ibn Abbas) made this deduction I from the command of Allah's Apostle (may peace be upon him) when he had ordered to put off Ihram on the occasion of the Farewell Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2870]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2870

Ibn Abbas reported that Mu'awiya had said to them: Do you know that I clipped some hair from the head of Allah's Messenger (may peace be upon him) at al- Marwa with the help of a clipper? I said: I do not know it except as it verdict against you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2871]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2871

Ibn Abbis (Allah be pleased with him) reported that Mu'awiya b. Abu Safyin had told him: I clipped the hair (from the head of) Allah's Messenger (may peace he upon him) with a clipper while he was at al-Marwa, or I saw him getting his hair clipped with a clipper as he was at al-Marwa. 1722


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2872]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2872

Abu Sa'id (Allah be pleased with him) reported: We went out with Allah's messenger (may peace be upon him) pronouncing loudly the Talbiya for Hajj When we came to Mecca, he commanded us that we should change this (Ibrim for Hajj) to that of Umra except one who had brought the sacrificial animal with him. When it was the day of Tarwiya (8th of Dhu'l-Hijja) and we went to Mini, we (again) pronounced Talbiya for Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2873]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2873

jibir and Abil Salld al-Khudri (Allah be pleased with them) reported: We went with Allah's Apostle (may peace be upon him) and we were pronouncing Talbiya for Hajj loudly.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2874]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2874

Abd Nadra reported: While I was in the company of Jibir, a person came and said: There is difference of opinion amomg Ibn Abbas and Ibn Zubair about two Mut'as (benefits, Tamattul in Hajj and temporary marriage with women), whereupon jibir said: We have been doing this during the lifetime of Allah's Messenger (way peace be upon him), and then 'Umar forbade us to do so, and we never resorted to them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2875]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2875

Anas (Allah be pleased with him) reported that 'All (Allah be pleased with him) came from the Yemen, and the Apostle (may peace be upon him) said: With (what intention) have you put on Ihram? He said: I have put on Ibram in accordance with the intention with which Allah's Apostle (may peace be upon him) has put on Ibram, whereupon he (the Holy Prophet) said: Had there not been the sacrificial animals with me, I would have put off Ibram (after performing 'Umra). This hadith is narrated by Salim b. Hayyin with the same chain of transmitters, but with a slight variation of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2876]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2876

Anas (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya for both simultaneously, Talbiya for 'Umra and Hajj. Talbiya for Uwra and Hajj (he performed both Hajj and Umra as a Qarin). In another version words are: I heard Allah's Messenger (may peace be upon him) pronouncing Talbiya for Umra and Hajj (simultaneously)."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2877]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2877

Hanzala al-Aslami reported: I heard Abu Huraira (Allah be pleased with him) as narrating from Allah's Apostle (may peace be upon him) who said: By Him in Whose Hand is my life. Ibn Maryam (Jesus Christ) would certainly pronounce Talbiya for Hajj or for Umra or for both (simultaneously as a Qiran) In the valley of Rauha


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2878]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2878

Hanzala b. 'Ali al-Aslaml reported that he had heard Abu Huraira (Allah be pleased with him) as saying that Allah's Messenger (may peace be upon him) bed said: By Him In Whose Hand is my life; the rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2879]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2879

Qatida saia. that Anas (Allah be pleased with him) had informed him that Allah's Messenger (may peace be upon him) performed four 'Umras, all during the month of Dhu'l-Qa'da except the one he performed along with Hajj (and these are) the Umra that he performed from al-Hudaibiya or during the time of (the truce of) Hudaibiya in the month of Dhu'l-Qa'da then the Umra of the next year in the month of Dhu'l-Qa'da, then the Umra for which b'e had started from ji'rana, the place where he distributed the spoils of (the battle of) Hunain in the month of Dhu'l-Qa'da, and then the 'Umra that he performed along with his Hajj (on the occasion of the Farewell Pilgrimage).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2880]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2880

Qatida said: I asked Anas (Allah be pleased with him) as to bow many Pilgrimages had been performed by Allah's Messenger (may peace be upon him), and he replied: One Hajj and four 'Umras were performed by him. The rest of the badith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2881]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2881

Abu lshaq said: I asked Zaid b. Arqam: In how many military expeditions have you participated with Allah's Messenger (may peace be upon him)? He said: In seventeen (expeditions). He (Abu Ishaq) said: Zaid b. Arqam reported to me that Allah's Messenger (may peace be upon him) had led nineteen expeditions. And he performed Hajj only once after Migration, and that was the Farewell Pilgrimage. Abu Ishaq also said: The second (Hajj) he performed at Mecca (before his Migration to Medina)


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2882]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2882

'Ataa reported that 'Urwa b. Zubair (Allah be pleased with him) had informed him (this): I and Ibn 'Umar were reclining against the (wall) of the apartment of A'isha and we were listening to the sound produced by the brushing of her teeth. I said Abu Abd al-Rahman (the kunya of 'Abdullah b. Umar), did Allah's Apostle (may peace be upon him) perform 'Umra in the month of Rijab? He said: Yes. I said to 'A'isha: Mother, are you listening to what Abu Abd al-Rabman is saying? She said: What is he Saying? I said: He is saying that Allah's Apostle (may peace be upon him) performed 'Umra during the month of Rajab, whereupon she said: May Allah grant pardon to Abu Abd al-Rahman I By my life he (the Holy Prophet) did not perform 'Umra during the month of Rajab. And never was there an Umra performed by him (the Holy Prophet) in which he ('Abdullah b. 'Umar) did not join him. Ibn 'Umar heard this and said nothing to affirm It or to deny it, but kept quiet.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2883]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2883

Mujihid reported: I and 'Urwa h Zubair entered the mosque and there found 'Abdullah b. 'Umar sitting near the apartment of IA'isha and the people were observing the forenood" prayer (when the sun bad sufficiently risen). We asked him about their prayer, and he said: It is bid'a (innovation), Urwa said to him: Abd al-Rahman, how many, 'Umras had Allah's Messenger (may peace be upon him) performed? He said: Four Umras, one he performed during the month of Rajab. We were reluctant either to belie him or reject him. We heard the noise of brushing of her teeth by 'A'isha in her apartment. 'Urwa said: Mother of the Faithful, are you not hearing what Abfi 'Abd al-Rahman is saying? She said: What is he saying? Thereupon he ('Urwa) said: He (Ibn 'Umar) states that Allah's Apostle (may peace be upon him) performed four Umras and one of them during the month of Rajab. Thereupon she remarked: May Allah have merely upon Abu 'Abd al-Rahman. Never did Allah's Messenger (may peace be upon him) perform 'Umra in which he did not accompany him, and he (Allah's Apostle) never performed 'Umra during the month of Rajab.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2884]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2884

Ataa reported: I heard Ibn Abbas (Allah be pleased with him) narrating to us that Allah's Messenger (may peace be upon him) said to a woman of the Ansar (Ibn Abbas had mentioned her name but I have forgotten it): 'What has prevented you that you do not perform Hajj along with us? She said: We have only two camels for carrying water. One of the camels has been taken by my husband and my son for performing Hajj and one has been left for us for carrying water, whereupon he (the Holy Prophet) said: So when the month of Ramadan come, perform Umra, for'Umra in this (month) is equal to Hajj (in reward).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2885]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2885

Ibn Abbis reported that Allah's Apostle (may peace be upon him) said to a woman of the Ansar who was called Umm Sinan: What has prevented you that you did not perform Hajj with us? She said: The father of so and so (i. e. her husband) had only two camels. One of them had been taken away by him (my busbard) and his son for Hajj, whereas the other one is used by our boy to carry water. Upon this he (the Holy Prophet) said: Umra during the month of Rawadin would suffice for Hajj or Hajj along with me.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2886]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2886

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) used to come out (of Medina) by way of al-Shajarah and entered it by the way of al-Mu'arras and whenever he entered Mecca, he entered it from the upper side and went out of it from the lower side. This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters and in the narration transmitted by Zubair (it is mentioned) that the upper side is that'which is at al-Batha


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2887]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2887

'A'isha (Allah be pleased with her) reported that when Allah's Messenger may peace be upon him) came to Mecca he entered from its upper side and came out from its lower side.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2888]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2888

A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) entered Mecca during the year of Victory from Kada I. e. from the upper side. Hisham said.. My father entered It from both the Fides, but generally he entered from Kada.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2889]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2889

Ibn Umar (Allah be pleased with him) reported that Allah's Messenger may peace be upon him) spent the night at Dhi Tuwa till it was dawn and then entered Mecca. 'Abdullah (b. 'Umar) himself did like it. And in the narration transmitted by Ibn Sa'ld (the words are): Until he obrerved the dawn prayer. Yahya (another narrator) said: Until it was dawn.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2890]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2890

Nafi' reported that Ibn Umar (Allah be pleased with them) did not enter Mecca without spending the night at Dhi Tawu until it was dawn, when he took a bath, and then entered Mecca in the morning, and made a mention that Allah's Apostle (may peace be upon him) did that.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2891]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2891

Abdullah (b. 'Umar) reported that whenever Allah's Messenger (may peace be upon him) entered Mecca, he got down at Dhi Tuwa and spend the night there until he observed the dawn prayer. And Allah's Messenger (may peace be upon him) observed this prayer on a rough hillock, and not in the mosque which had been then built there, but to the lower side of it (the mosque) on a hillock.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2892]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2892

Nafi' reported that Abdullah (b. 'Umar) informed him that Allah's Messenger (may peace be upon him) turned his face to the two hillocks which intervened between him and the long mountain by the side of the Ka'ba, and the mosque which had been built there was thus on the left of the hillock. Allah's Messenger's (may peace be upon him) place of prayer was lower than the black hillock, at a distance of ten cubits or near it. He (may peace be upon him) would then observe prayer facing these two hillocks of the long mountain that is intervening between you and the Ka'ba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2893]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2893

Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that when Allah's Messenger (may peace be upon him) circumambulated the House, while observing the first circumambulation, he walked swiftly in three (circuits), and walked in four circuits, and ran in the bottom of the valley as he moved between al-Safa and al-Marwa. Ibn 'Umar (Allah be pleased with them) also used to do like this.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2894]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2894

Ibn'Umar (Allah be pleased with them) reported that when Allah's messenger (may peace be upon him) circumambulated in Hajj and Umra he walked swiftly in the first three circuit about the House, and then walked in four circuits, and then observed two rak'ahs of prayer, and then ran between al-Safa and al-Marwa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2895]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2895

Abdullah b. 'Umar (Allah be pleased with them) reported: I saw that when Allah's Messenger (may peace be upon him) came to Mecca and kissed the Black Stone, (in the first circumambulation) he moved quickly in three circuits out of seven circuits.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2896]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2896

Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that Allaws Messenger (may peace be upon him) walked swiftly from stone to stone in three circuits and walked (normally) in four.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2897]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2897

Nafi' reported that Ibn Umar (Allah he pleased with them) walked swiftly from stone to stone, and stated that Allah's Messenger (may peace be upon him) did like this.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2898]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2898

jabir b. Abdullah (Allah be pleased with them) reported: I saw Allah's Messenger (may peace be upon him) walking swiftly from the Black Stone till he completed three circuits up to it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2899]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2899

Jabir b." Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) walked swiftly in three circuitsfrom stone to stone.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2900]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2900

Abu Tufail reported: I said to Ibn Abbas (Allah be pleased with them): Do you think that walking swiftly round the House in three circuits, and just walking in four circuits is the Sunnah (of the Holy Prophet), for your people say that it is Sunnah? Thereupon he (Ibn 'Abbas) said: They have told the truth and the lie (too). I said: What do your words" They have told the truth and the lie (too)" imply? Thereupon he said: Allah's Messenger (may peace be upon him) came to Mecca and the polytheists said that Mubammad and his Companions had emaciated and would, therefore, be unable to circumambulate the House; and they felt jealous of him (the Holy Prophet). (It was due to this) that Allah's Messenger (may peace be upon him) commanded them to walk swiftly in three (circuits) and walk (normally) in four. I said to him: Inform me if it is Sunnah to observe Tawaf between al-Safa and al-Marwa while riding, for your people look upon it as Sunnah. He (Ibn Abbas) said: They have told the truth and the lie too. I said: What do your words" They have told the truth and the lie tool, iMply? He said: as Allah's Messenger (may peace be upon him) had come to Mecca, there was such a large gathering of people around him that even the virgins had come out of their houses (to catch a glimpse of his face). and they were saying: He is Muhammad; He is Muhammad. Allah's Messenger (may peace be upon him) (was so gentle and kind) that the people were not beaten back (to make way) in front of him. When there was a; throng (of people) around him, he rode (the she-camel) but walking and trotting is, however, better.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2901]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2901

This hadith has been narrated on the authority of jurairi with the same chain of transmitters but with a slight variation of words (and this is) that he (the narrator) did not say:" They felt jealous of him. but said: The people of Mecca, were jealous people."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2902]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2902

Abu Tufail reported: I said to Ibn 'Abbas (Allah be pleased with them): People are of the view that Allah's Messenger (may peace be upon him) moved quickly round the House and between al-Safa and al-Marwa, and (thus) it is Sunnah. He said: They told the truth and they told the lie.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2903]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2903

Abu Tufail reported; I. said to Ibn 'Abbas (Allah be pleased with them): I think that I saw Allah's Messenger (may peace be upon him). He (Ibn 'Abbis) said' Give a description of him to me. I said: I saw him near al-Marwa on the back of a she- camel, and people had thronged around him. Thereupon Ibn'Abbis said: It was Allah's Messenger (may peace be upon him) for they (the Compainions of the Holy Prophet) were neither pushed aside from him, nor were they turned away.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2904]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2904

Ibn 'Abbas (At lab be pleased with them) reported: Allah's Messenger (may peace be upon him) and his Companions came to Mecca and the fever in Medina had weakened them. Thereupon the polytheists (of Mecca) said: There would come to you a people whom the fever has made weak and they have suffered severely from it. They sat in Hatim. Thereupon Allah's Apostle (may peace be upon him) commanded them to walk quickly ift three circuits and walk (in four) between the two corners. so that the polytheists should. see their endurance. The polytheists then said (to one anothery You were under the impression that fever had emaciated them. whereas they are stronger than so and so. Ibn Abbas said: He (the Holy Prophet) did not command them (the Muslims) to walk quickly in all the circuits out of kindness to them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2905]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2905

Ibn Abbas (Allah be pleased with them) reported: Allah. 's Messenger (peace be upon him) observed Sa'i and walked quickly round the House with a view to showing his strength to the polytheists.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2906]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2906

Ahdullah b. Umar (reported) that he had not seen Allah's Messenger (way peace he upon him) touching anything in the House, except the two Yamani corners.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2907]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2907

Salim reported on the authority of his father (Allah he pleased with him) that Allah'& Messenger (tinny peace be upon him) did not touch any of the corners of the House. except that of Black Corner (in which the Black Stone is embedded and that (portion) near it, towards the houses of the tribe of jumuhi.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2908]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2908

Nafi' reported on the authority of 'Abdullah (Allah be pleased with him) that Allah's Messenger (way peace be upon him) did not touch but the Stone and the Yamani corner.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2909]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2909

Ibn 'Umar (Allah be pleased with them) reported: I have not abandoned touching of Yamani corners (and kissing of) the Stone since I saw Allah's messneger (may peace be upon him) touching them both In hardship and ease.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2910]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2910

NAfi' (Allah be pleased with him) reported: I saw'lbn 'Umar (Allah be pleased with them) touching the Stone with his hand and then kissing his hand. and he said: I have never abandoned it since I saw Allah's Messenger (way peace be upon him) doing It.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2911]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2911

Ibn 'Abbas (Allah be pleased with them) is reported to have said that he did not see Allah's Messenger (may peace be upon him) touching other than the Yamani corners.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2912]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2912

Salim narrated on the authority of his father (Allah be pleased with him) that 'Umar b. al-Khattib (Allah be pleased with him) kissed (the Black Stone) and then said: By Allah, I know that you are a stone and if I were not to see Allah's Messenger (may peace be upon him) kissing you, I would not have kissed you. Harun said in his narration: A hadith like this has been transmitted to me by Zaid b. Aslam on the authority of his father Aslam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2913]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2913

Ibn 'Umar (Allah be pleased with them) reported that Umar (Allah be pleased with him) kissed the Stone and said: I am kissing you, whereas I know that you are a stone, but I saw Allah's Messenger (may peace be upon him) kissing you (that Is why I kiss you).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2914]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2914

Abdullah b. Sarjis reported: I saw the bald one, i. e. 'Umar b. Khattib (Allah be pleased with him). kissing the Stone and saying: By Allah. I am kissing with full consciousness of the fact that you are a stone and that you can neither do any harm nor good; and if I had not seen Allah's Messenger (may peace be upon him) kissing you. I would not have kissed you. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2915]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2915

Abis b. Rabi'a reported: I saw 'Umar (Allah'be pleased with him) kissing the Stone and saying: I am kissing you and I know that you are a stone. And if I had not seen Allah's Messenger (may peace be upon him) kissing you, I would not have kissed you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2916]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2916

Suwaid b. Ghafala reported: I saw Umar (Allah be pleased with him) kissing the Stone and clinging to it and saying: 1 saw Allah's Messenger (may peace be upon him) having great love for you. This hadith has been narrated on the authority of Sufyin with the same chain of transmitters (and the words are):" That he ('Umar) said: But I saw Abu'l-Qasim (way peace be upon him) having great love for you." And he did not'mention about clinging to it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2917]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2917

Ibn 'Abbas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) circumambulated the House on the occasion of the Farewell Pilgrimage on the back of his camel and touched the Corner (of Black Stone) with a stick.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2918]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2918

Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) circumambulated the House on the back of his riding camel on the occasion of the Farewell Pilgrimage and touched the Stone with his stick so that the people should see him, and he should be conspicuous, and they should be able to ask him (questions pertaining to religion) as the people had crowded round him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2919]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2919

jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) circumambulated the House (and ran) between al-Safa and al-Marwa on the back of his she-camel, at the occasion of the Farewell Pilgrimage. so that the people should see him and he should be conspicuous, and they should be able to ask him (questions pertaining to religion), and the people had crowded round him. In the hadith transmitted on the authority of Ibn Khashram no mention Is made of:" So that they should ask him."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2920]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2920

'A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) circumambulated the Ka'ba on the back of his camel on the occasion of the Farewell Pilgrimage and touched the corner and he did not like that the people should be pushed away from him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2921]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2921

Abu Tufail reported: I saw Allah's Messenger (may peace be upon him) circumambulating the House. and touching the corner with a stick that he had with him, and then kissing the stick.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2922]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2922

Umm Salama reported: I made a complaint to Allah's Messenger (may peace be upon him) of my ailment, whereupon be said: Circumambulate behind the people while riding. She said: So I circumambulated and Allah's Messenger (may peace be upon him) was at that time praying towards the side of the House and he was reciting al-Tur and a Book Inscribed (i. e. Sura Iii. of the Qur'un).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2923]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2923

Hisham b. 'Urwa reported on the authority of his father who narrated from 'A'isha. He said to 'A'isha: I think if a person does not run between al- Safa' and al-Marwa, It does not do any harm to him (so far as Hajj is concerned). She said: Why (do you think so)? I said: For Allah says:" Verily al-Safa' and al-Marwa are among the Signs of Allah" (ii. 158) (to the end of the verse), whereupon she said: Allah does not complete the Hajj of a person or his Umra if he does not observe Sa'i between al-Safa' and al-marwa; and if it were so as you state, then (the wording would have been (fala janah an la yatufu biha) [" There is no harm for him if he does not circumambulate between them']. Do you know in what context (this verse was revealed)? (It was revealed in this context) that the Ansar in the Days of Ignorance pronounced the Talbiya for two idols. (fixedl on the bank of the river which were called Isaf and Na'ila. The people went there, and then circumambulated between al-Safa' and al-Marwa and then got their heads shaved. With the advent of Islam they (the Muslims) did not like to circumambulate between them as they used to do during the Days of Ignorance. It was on account of this that Allah. the Exalted and Majestic, revealed:" Verily al-Safe and al-Marwa are among the Signs of Allah" to the end of the verse. She said: Then people began to observe Sa'i.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2924]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2924

Hisham b. 'Urwa narrated on the authority of his father who reported: I said to 'A'isha: I do not see any harm to me if I do not circumambulate betweez al-Safa' and al-Marwa. She said: On what ground do you say so? (I said: ) Since Allah, the Exalted and Majestic, says:" Verily al-Safa' and al-Marwa are among the Signs of Allah." It (your assertion) were (correct), it would have been said like this:" There is no harm for him, that he should not circumambulate between them." It (this verse) has been revealed about the people of Ansar. Whenever they pronounced the Talbiya, they pronounced it in the name of al-Manat during the Days of Ignorance; so they (thought) that it was not permissible for them (for the Muslims) to circumambulate between and al-Marwa. When they (the Muslims) came with Allah's Apostle (may peace he upon him) for Hajj, they mentioned it to him. So Allah, the Exalted and Majestic, revealed this verse. By my life, Allah will not complete the Hajj of one who has not circumambulated between al-Safa and al-Marwa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2925]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2925

'Urwa b. Zabair reported: I said to 'A'isha, the wife of Allah's Apostle (may peace be upon him): I do not see any (fault) in one who does not circumambl" te between al-Safa' and al-Marwa, and I do not mind if I do not circumambulate between them, whereupon she said: O, the son of my sister, what you say is wrong. Allah's Messenger (may peace be upon him) observed Sa'i and so did the Muslims. So it is a Sunnah (of the Prophet). And it was a common practice (with the pagan Arabs) that those who pronounced Talbiya for the wretched al-Manat, situated at Mushalla, did not observe Sa'i between al-Safa' and al-Marwa. With the advent of Islam, we asked Allah's Apostle (may peace be upon him) about this practice, and (it was on this occasion) that Allah, the Exalted and Majestic, revealed this verse:" Verily al-Safa' and al-Marwa are among the Signs of Allah" ; so he who performed Hajj or 'Umra it is no sin on him if he circumambulates them. And if it were as you state, (then the wording would have been):" There is no harm for him, that he should not circumambulate round them." Zuhri said: I made a mention of that to Abu Bakr b. 'Abd al- Rahman b. al-Harith b. Hisham; he was impressed by that and said: This is what is called knowledge. And I have heard many a scholar saying: Many of the Arabs who did not circumambulate between al-Safa' and al-Marwa caid: Our circumambulation between these two hills is an act of ignorance; whereas others among the Ansar said: We have been commanded to circumambulate the House, and not Commanded to run between al-Safa' and al-Marwa. So Allah, the Exalted and Majestic, revealed thia verse:" Verily al-Safa' and al-Marwa are among the Signs of Allah." Abu Bakr b. 'Abd al-Rahman said: I think that this (verse) has been revealed for such and such (persons).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2926]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2926

'Urwa b. Zubair reported: I asked 'A'isha (Allah be pleased with her) ; the rest of the hadith is the same. And in this hadith (these words are also found):" When they (the Companions of the Holy Prophet) asked Allah's Messenger (may peace be upon him) about this, they said: Messenger of Allah, we felt reluctant to circumambulate between al-Safa' and al-Marwa. Then Allah, the Exalted and Majestic, revealed this verse:" Verily al-Safa' and al-Marwa are among the Signs of. Allah so he who perform Hajj or Umra it is no sin on him if he should circumambulate between them. 'A'isha (Allah be pleased with her) said: Allah's Messenger (may peace be upon him) laid down this Sa'i between them as Sunnah (of the Holy Prophet). So it is not advisable for anyone to abandon this Sa'i between them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2927]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2927

'Urwa b. Zabair narrated on the authority of 'A'isha (Allah be pleased with her) who informed him that the Ansar and the people of the tribe of Ghassan before embracing Islam pronounced Talbiya for Manat, and so they avoided circumambulating between al-Safa' and al-Marwa, and it was a common practice with their forefather, that he who put on Ihram for Manat did not circumambulate between al-Safa' and al-Marwa. And when they embraced Islam, they asked Allah's Messenger (may peace be upon him) about it, and then Allah, the Exalted and Majestic, revealed this verse:" Verily al-Safa' and al-Marwa are among the Signs of Allah" ; so he who performs Hajj or Umra, for him there is no harm if he should circumambulate between them, and he who does good spontaneously-surely Allah is Bountiful in rewarding and Knowing.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2928]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2928

Anas (Allah be pleased with him) reported that the Ansar felt reluctant that they should circumambulate between al-Safa' and al-Marwa until it was revealed:" Verily al-Safa' and al-Marwa are among the Signs of Allah" ; so whoever performs Hajj or 'Umra, for him there is no harm that he should circumambulate between them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2929]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2929

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) and his Companions did not observe Sa'i between al-Safa' and al-Marwa but only one Sa'i.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2930]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2930

Ibn Juraij reported on the same authority a hadith like that, and said: But one Tawaf and that was the first Tawaf.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2931]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2931

Usama b. Zaid (Allah be pleased with him) reported: I was sitting behind Allah's Messenger (may peace be upon him) on the riding animal from 'Arafat. As Allah's Messenger (may peace be upon him) reached the left side of the mountain which was situated near Muzdalifa, he made the camel kneel down and made water and then came back. I poured water and he, performed light ablution. I then said: Messenger of Allah, it is time for prayer. Thereupon Allah's Messenger (may peace be upon him) said: The prayer awaits you (at the next station, Muzdalifa). Allah's Messenger (may peaced be upon him) rode on until he came to Muzdalifa and observed prayer. Then al-Fadl (Allah be pleased with him) sat behind Allah's Messenger (may peace be upon him) and reached (Muzdalifa) in the morning. Kuraib said: 'Abdullah b. 'Abbas (Allah be pleased with them) narrated from al-Fadl (Allah be pleased with him) that Allah's Messenger (may peace be upon him) continued pronouncing Talbiya until he reached al-Jamara (al-'Aqaba).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2932]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2932

Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) made al-Fadl sit behind him (on the camel back) from the place (where the two prayers) are combined (Muzdalifa). Ibn Abbas (Allah be pleased with them) also informed that Allah's Apostle (may peace be upon him) did not stop pronouncing Talbiya till he threw pebbles at Jamrat al-'Aqaba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2933]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2933

Ibn 'Abbas narrated from al-Fadl b. Abbas (Allah be pleased with them) who sat behind Allah's Messenger (may peace be upon him) that he (the Holy Prophet) said to the people on the evening of 'Arafa and on the morning to the gathering of people (at Muzdalifa) as they were pushing on to proceed slowly. And he himself drove his she-camel with restraint until he entered Muhassir (it is a place in Mina), and further told them to take up pebbles which were to be thrown at Jamra. And Allah's Messenger (may peace be upon him) continued pronouncing Talbiya till he stoned the Jamra. This hadith has been narrated on the authority of Abd Zubair with the same chain of transmitters but with this variation that in the hadith no mention is made of (this) that Allah's Messenger (may peace be upon him) continued pronouncing Talbiya till he stoned the Jamra, and he made this addition in his hadith:" The Apostle (may peace be upon him) pointed with his hand how a person should catch hold of pebbles (in order to throw them)."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2934]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2934

'Abdullah narrated to us as we had gathered (at Muzdalifa): I have heard from one upon whom Surah al-Baqara was revealed (the Holy Prophet) pronouncing Talbiya at this place.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2935]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2935

'Abd al-Rahman b. Yazid reported that 'Abdullah (b. Mas'ud) pronounced Talbiya as he returned from the gathering of the people (at Muzdalifa). It was said: He might be a Bedouin (not knowing correctly the rituals of Hajj and, therefore, pronouncing Talbia at this stage), whereupon Abdullah said: Hive the people forgotten (this Sunnah of the Holy Prophet) or have they gone astray? I heard him, upon whom Sibrah al-Baqara was revealed, pronouncing Talbiya at the very place.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2936]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2936

'Abd al-Rahman b. Yazid and al-Aswad b. Yazid reported: We heard 'Abdullah b. Mas'ud saying to the gathering of people (at Muzdalifa) that he had heard Talbiya from him, upon whom Surah al-Baqara was revealed, at this very place. And so he ('Abdullah b. Mas'ud) pronounced Talbiya and we also pronounced it with him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2937]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2937

'Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them). He said: As we proceeded in the morning along with AUbs Messenger (may peace be upon him) from Mina to 'Arafat, some of us prounced Talbiya, and some pronounced Takbir (Allah-o-Akbar).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2938]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2938

Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them): We were along with Allah's Messenger (way peace he upon him) in the morning of 'Arafa (9th of Dhu'l-Hijja). Some of us pronounced Takbir and some of us Tahlil La ilaha ill-Allah). And to those of us who pronounced Takbir, I said: By Allah, how strange it is that you did not care to ask him: What did you see Allah's Messenger (may peace be upon him) doing (on this occasion)?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2939]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2939

Muhammad b. Abu Bakr al-Thaqafi asked Anas b. Malik (Allah be pleased with him), while on their way from Mina to 'Arafa in the morning: What did you do on this day in the company of Allah's Messenger (may peace be upon him)? Thereupon he said: One of us pronounced Tahlil, and he met with no disapproval, and one of us pronounced Takbir, and he also met with no disapproval.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2940]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2940

Muhammad b. Abu Bakr reported: I said to Anas b. Malik in the morning of 'Arafa: What do you say as to pronouncing Talbiya on this day? He said: I travelled with Allah's Apostle (may peace he upon him) and his Companions in this journey. Some of us pronounced Takbir and some of us pronounced Tahlil, and none of us found fault with his companion.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2941]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2941

Kuraib, the freed slave of Ibn Abbas, narrated from Usama b. Zaid (Allah be pleased with him) that he had heard him saying: Allah's Messenger (may peace be upon him) proceeded from 'Arafa, and as he approached the creek of a hill, he got down (from his camel) and urinated, and then performed a light ablution. I said to him: Prayer, whereupon he said: The prayer awaits you (at Muzdalifa). So he rode again, and as he came to Muzdalifa, he got down and performed ablution well. Then Iqima was pronounced for prayer, and he 'observed the sunset prayer. Then every person made his camel kneel down there, and then Iqama was pronounced for 'Isha' prayer and he observed it, and he (the Holy Prophet) did not observe any prayer (either Sunan or Nawifil) in between them (He observed the Fard of sunset and 'Isha' prayers successively.)


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2942]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2942

Usama b. Zaid (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) on his way back from 'Arafat got down in one of these creeks (to answer the call of nature), and after he had done that I poured water (over his hands) and said: Are you going to pray? Thereupon he said: The place of prayer is ahead of you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2943]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2943

Usama b. Zaid (Allah be pleased with him) narrated: AHah's Messenger (may peace be upon him) was on his way back from 'Arafat and as he reached the creek (of a hillock) he got down and urinated (Usama did not say that he poured water), but said: He (the Holy Prophet) called for water and performed ablution, but it was not a thorough one. I said: Messenger of Allah, the prayer! Thereupon he said: Prayer awaits you ahead (at Muzdalifa). He then proceeded, until he reached Muzdalifa and observed sunset and 'Isha' prayers (together) there.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2944]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2944

Kuraib reported that he asked Usama b. Zaid (Allah be pleased with him) What did you do in the evening of 'Arafa as you rode behind Allah's Messenger (may peace be upon him)? He said: We came to a valley where people generally halted their (camels) for the sunset prayer. Allah's Messenger (may peace be upon him) halted his camel and urinated (and he did not say that he had poured water). He then called for water and performed light ablution. I said: Messenger of Allah, the prayer! Thereupon he said: Prayer awaits you (at Muzdalifa). and he rode on until we came to Muzdalifa. Then he offered the sunset prayer. and the people halted their camels at their places, and did not untie them until Iqama was pronounced for the 'Isha' prayer and he observed the prayer, and then they untied (their camels). I said: What did you do in the morning? He said: Al-Fadl b. Abbas (Allah be pleased with them) sat behind him (the Holy Prophet) in the morning, whereas I proceeded on foot with the Quraish who had gone ahead.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2945]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2945

Usama b. Zaid (Allah be pleased with him) reported that when Allah's Messenger (may peace jbe upod him) came to the valley where the rich (people of Mecca) used to get down. he got down. and urinated (and he did not mention about pouring water) ; he then called for water and performed a light ablution. I said: Messenger of Allah, the prayer I Thereupon he said: Prayer awaits you ahead.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2946]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2946

Usama b. Zaid (Allah be pleased with him) reported that he sat behind Allah's Messenger (may peace be upon him) on his ride as he came back from 'Arafa. And as he came to the valley, he halted his camel, and then went to the wilderness (to urinate). And when he came back, I poured water on him from the jug and he performed ablution, and then rode on until he came to Muzdalifa and there he combined the sunset and 'Isha' prayers.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2947]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2947

Ibn Abbas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon, him) came back from 'Arafa and Usama (Allah be pleased with him) was seated behind him. Usama said that he (the Holy Prophet) continued the journey in this very state until he came to Muzdalifa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2948]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2948

Hisham (Allah be pleased with him) reported from his father: Usama (Allah be pleased with him) was asked in my presence or I asked Usama b. Zaid andhe rode behind Allah's Messenger (may peace be upon him) as he came back from 'Arafat. I said (to him): How did Allah's Messenger (may peace be upon him) journey as he came back from 'Arafat? Thereupon he said: He made it (his riding camel) walk at a slow speed, and when he found an open space, he made it walk briskly.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2949]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2949

This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters. and in the hadith narrated by Humaid there is an addition (of these words):" Hisham said: Al-nass (speed of camel) is faster than al-'anaq."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2950]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2950

Abdullah b. Yazid al-Khatmi reported on the authority of Abu Ayyub (Allah be pleased with him) that he prayed the sunset and 'Isha' prayers (together) at Muzdalifa in the company of Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2951]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2951

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) observed the sunset and 'Isha' prayers together at Muzdalifa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2952]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2952

Ubaidullah b. 'Abdullah b. 'Umar reported on the authority of his father (Allah be pleased with them) that Allah's Messenger (may peace be upon him) combined the sunset and 'Isha', prayers at Muzdalifa and there was no prostration (i. e. any rak'ahs of Sunan or Nawafil prayers) in between them. He observed three rak'ahs of the sunset prayer and two rak'ahs of the 'Isha' prayer, and 'Abdullah (b. 'Umar) observed the prayers in this very manner (at Muzdalifa) until he met his Lord.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2953]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2953

Sa'id b. Jubair reported that he observed the sunset and 'Isha' prayers at Muzdalifa with (one) iqama. He narrated on the authority of Ibn 'Umar (Allah be pleased with them) that he observed prayers like this. and Ibn 'Umar (Allah be pleased with them) narrated that Allah's Apostle (may peace be upon him) did like this. Shu'ba reported this hadith with the same chain of transmitters and said: He (the Holy Prophet) observed the two prayers (together) with one iqama.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2954]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2954

Ibn 'Umar rep rte that Allah's Messenger (may peace be upon him) combined the sunset and 'Isha ' prayers at Muzdalifa. He observed three rak'ahs of the sunset prayer and two rak'ahs of the 'Isha' prayer with one Iqama.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2955]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2955

Sa'id b. Jubair reported: We came back along with Ibn 'Umar till we reached Muzdalifa. There he led us in the sunset and 'Isha' prayers with one iqama and we then proceeded and he said: This is how Allah's Messenger (may peace be upon him) led us in prayer at this place.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2956]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2956

A'bdullah (b. 'Umar) reported: I have never seen Allah's Messenger, (may peace be upon him) but observing the prayers at their appointed times except two players, sunset and 'Isha, ' at Muzdalifa (where he deferred the sunset prayer to combine it with 'Isha' and he observed the dawn prayer before its stipulated time on that day (10th of Dhu'l-Hijja).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2957]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2957

This badith has been transmitted by A'mash with a slight variation of words, i. e. he said before its time when it was still dark.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2958]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2958

'A'isha (Allah be pleased with her) reported: Sauda (the wife of the Holy Prophet) who was bulky sought the permission of Allah's Messenger (may peace be upon him) on the night of Muzdalifa to move from (that place) ahead of him and before the multitude (set forth). He (Allah's Apostle) gave her the permission. So she set forth before his (Holy Prophet's) departure. But we stayed there until it was dawn and we moved on, when he departed. And if I were to seek the permission of Allah's Messenger. (may peace be upon him) as Sauda had sought permission, I could have also gone with his permission and it would have been better for me than that for which I was happy.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2959]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2959

A'isha (Allah be pleased with her) reported that (hadrat) Sauda was a bulky lady, so she sought permission from Allah's Messenger (may peace be upon him) to proceed from Muzdalifa (to Mina) in the (latter part of the) night. He granted her permission. 'A'isha said: I wish I had also sought permission from Allah's Messenger (may peace be upon him) as Sauda had. sought permission from him. 'A'isha did not proceed but with the Imam.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2960]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2960

'A'isha said: I wish I had sought permission from Allah's Messenger (may peace be upon him) as Sauda had sought, and observed the dawn prayer at Mina and stoned at al-Jamra before the people had come there. It was said to 'A'isha (Allah be pleased with her): Did Sauda seek permission from him (the Holy Prophet)? She said: Yes. She was a bulky lady and so she sought permission from Allah's Messenger (may peace be upon him) (to proceed to mina from Muzdalifa ahead of him), and he granted her permission.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2961]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2961

A hadith like this has been narrated by 'Abd al-Rahman b. al-Qasim with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2962]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2962

Abdullah, the freed slave of (Hadrat) Asma', reported: Asma' (Allah be pleased with her), as she was in the house at Muzdalifa, asked me whether the moon had set. I said: No. She prayed for some time, and again said: My son has the moon set? I said: Yes. And she said: Set forth along with me, and so we set forth until (we reached Mini) and the stoned at al-Jamra. She then prayed in her place. I said to her: Respected lady, we set forth (in the very early part of dawn) when it was dark, whereupon she said: My son, there is no harm in it; Allah's Apostle (may peace be upon him) had granted permission to women. This hadith has been narrated by Ibn Juraij with the same chain of transmitters, and In his narration (the words are):" She (Asma') said: My son, Allah's Apostle (may peace be upon him) granted permission to women."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2963]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2963

Ibn Shawwal (the freed slave of Umm Habiba) reported that he went to Umm Habiba (the wife of Allah's Apostle) who informed him that Allah's Apostle (may peace be upon him) sent her from Muzdalifa during the night.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2964]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2964

It is narrated from Umm Habiba: We used to set forth from Muzdalifa to Mina, (very early in the dawn) when it was dark. And in the narration of Naqid (the words are):" We set from Muzdalifa in the darkness (of the dawn)."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2965]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2965

Ibn 'Abbas reported: Allah's Messenger (may peace be upon him) sent me from Muzdalifa ahead (of the caravan) along with the luggage or with the weak ones during (the latter part of the) night.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2966]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2966

Ibn 'Abbas (Allah be pleased with them) reported: I was among those (i. e. women and children) whom Allah's Messenger (may peace be upon him) sent forth with the weak members of his family.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2967]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2967

This hadith has been transmitted by Ibn 'Abbas (Allah be pleased with them) with a slight variation of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2968]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2968

'Ata' reported from Ibn Abbas (Allah be pleased with them): Allah's Messenger (may peace be upon him) sent me from Muzdalifa along with his luggage (in the very early part of @he dawn). I (Ibn Juraij, one of the narrators) said (to 'Ati'): Has this (news) reached you that Ibn 'Abbas (Allah be pleased with them) had said:" He (Allah's Messenger) had sent me in the latter part of the night"? Thereupon he said: No, it was the dawn. I (again) said to him: (Did you hear) Ibn 'Abbas (Allah be pleased with them) having said this (too):" We stoned al-Jamra before the dawn prayer"? So where did he observe the dawn prayer? He said: No. But he said only so much (as described above).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2969]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2969

Salim b. 'Abdullah reported that 'Abdullah b. 'Umar (Allah be pleased with them) used to send ahead of him the weak members of his household to stay during the night at Mash'ar al-Haram at Muzdalifa. They remembered Allah so long as they could afford, and then they proceeded before the stay of the Imam, and before his return. So some of them reached Mina for the dawn prayer and some of them reached there after that; and as they reached there, they stoned al-Jamra; and Ibn 'Umar (Allah be pleased with them) used to say: Allah's Messenger (may peace be upon him) has granted this concession to them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2970]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2970

'Abd al-Rahman b. Yazid reported that 'Abdullah b. Mas'ud (Allah be pleased with them) threw seven pebbles at Jamrat al-'Aqaba from the heart of the valley. He pronounced Takbir with every pebble. It was said to him that people fling stones from the upper side (of the valley), whereupon 'Abdullah b. Mas'ud (Allah he pleased with them) said: By him, besides Whom there is no other god, that is the place (of flinging stones) of one upon whom Surah al-Baqara was revealed (the Holy Prophet).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2971]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2971

A'mash reported: I heard Hajjaj b. Yusuf saying as he was delivering sermon on the pulpit: Observe the order of the (Holy) Qur'an which has been observed by Gabriel. (Thus state the surahs in this manner)" one in which mention has been made of al-Baqara,"" one in which mention has been made of women (Surah al-Nisa')" and then the surah in which mention has been made of the Family of 'Imrin. He (the (narrator) said: I met Ibrahim and informed him about these words of his (the statement of Hajjaj b. Yusuf). He cursed him and said: Abd al-Rahman b. Yazid has narrated to me that when he was in the company of 'Abdullah b. Mas'udd (Allah be pleased with them) he came to Jamrat al-'Aqaba and then entered the heart of the valley and faced towards it (the Jamra) and then flung seven pebbles at it from the heart of the valley pronouncing Takbir with every pebble. I said: Abu 'Abd al-Rahman, people fling pebbles at it (Jamra) from the upper side, whereupon he said: By Him besides Whom there is no god, that is the place (of flinging pebbles of one) upon whom Surah al-Baqara was revealed;


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2972]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2972

A'mash reported: I heard Hajjaj saying I Do not say Surah al-Baqara. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2973]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2973

Abd al-Rahman b. Yazid reported that he performed Hajj along with 'Abdullah (Allah be pleased with him) and he flung seven pebbles at al-Jamra (from a position) that the House was on his left and Mina was on his right and said: That is the place (of flinging pebbles of one) upon whom Surah al-Baqara was revealed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2974]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2974

This hadith nas been narrated on the authority of Shu'ba with the same chain of transmitters except with this variation of (words): As he came to Jamrat al-'Aqaba."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2975]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2975

Abd al-Rahman b. Yazid reported: It was said to 'Abdullah (Allah be pleased with bird) that people threw pebbles at the Jamra from the upper side of 'Aqaba, whereas he threw stones at it from the heart of the valley, whereupon he said: By Him besides Whom there is no god, it is at this very place that one upon whom was revealed Surah al-Baqara threw stones at it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2976]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2976

Jabir (Allah be pleased with him) reported: I saw Allah's Apostle (may peace be upon him) flinging pebbles while riding his camel on the Day of Nahr, and he was saying: Learn your rituals (by seeing me performing them), for I do not know whether I would be performing Hajj after this Hajj of mine.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2977]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2977

Umm al-Husain (Allah be pleased with her) reported: I performed Hajj along with Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage and saw him when he flung pebbles at Jamrat al-'Aqaba and returned while he was riding the camel, and Bilal and Usama were with him. One of them was leading his camel, while the other was raising his cloth over the head of Allah's Messenger (may peace be upon him) to protect him from the sun. She (further) said: Allah's Messenger (may peace be upon him) said so many things, and I heard him saying: If a slave having some limb of his missing and having dark complexion is appointed to govern you according to the Book of Allah the Exalted. listen to him and obey him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2978]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2978

Umm al-Husain (Allah be pleased with her) reported: I performed Hajj along with Allah's Messenger (may peace be upon him) on the occasion of the Farewell Pilgrimage and saw Usama and Bilal (too), one of whom had caught hold of the lose string of the she-camel of Allah's Apostle (may peace be upon him) while the other one was raising his cloth (over his head) protecting him from the heat, till he flung pebbles at Jamrat al-'Aqaba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2979]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2979

Jabir b. 'Abdullah reported: I saw Allah's Apostle (may peace be upon him) throwing stones (at Jamrat al 'Aqaba) like pelting of small pebbles.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2980]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2980

Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) flung pebbles at jamra on the Day of Nahr after sunrise, and after that (i. e. on the 11th, 12th and 13th of Dhu'l-Hijja when the sun had declined.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2981]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2981

Jabir b. Abdullah reported a hadith like this from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2982]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2982

Jabir (b. Abdullab) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Odd number of stones are to be used for cleaning (the private parts after answering the call of nature), and casting of pebbles at the Jamras is to be done by odd numbers (seven), and (the number) of circuits between al-Safa' and al-Marwa is also odd (seven), and the number of circuits (around the Ka'ba) is also odd (seven). Whenever any one of you is required to use stones (for cleaning the private parts) he should use odd number of stones (three, five or seven).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2983]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2983

'Abdullah reported that Allah's Messenger (may peace be upon him) got his head shaved (after slaughtering the sacrificial animal on the 10th of Dhu'l-Hijja), and so did a group of Companions, while some of them got their hair clipped. Abdullah said: Allah's Messenger (may peace'be upon him) observed once or twice:" May Allah have mercy upon those who get their heads shaved." And he also said:" Upon those too who got their hair clipped."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2984]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2984

Abdullah b. Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having observed: O Allah, have mercy upon those who get their heads shaved. They (the Companions) said: Messenger of Allah, (what about those) who have got their hair clipped? He said: O Allah, have mercy upon those who have got their heads shaved. They (again) said: Allah's Messenger, (what about those) who have got their hair clipped? Thereupon he said: (O Allah, have mercy upon those) who have got their hair clipped.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2985]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2985

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) said: May Allah have mercy upon those who have got their heads shaved. They said: Messenger of Allah, (what about) those who got their hair clipped? He said: May Allah have mercy upon those who have got their heads shaved. They said: Messenger of Allah, (what about those who have got their hair clipped)? He said: May Allah have mercy upon those who got their hair shaved. They said: Messenger of Allah, (what about) those who got their hair clipped? He said: (O Allah, have mercy upon) those who got their hair clipped.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2986]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2986

Ubaidullah reported this hadith with the same chain of transmitters and (it is said) that it was on the fourth turn that he (the Holy Prophet) said: (May Allah have mercy upon) those who got their hair clipped."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2987]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2987

Abu Huraira reported Allah's Messenger (may peace be upon him) as having said: O Allah, grant pardon to those who got their heads shaved They (Companions of the Holy Prophet) said: Messenger of Allah, (what about those) who get their hair cut? He said: O Allah, grant pardon to those who get their heads shaved. They said: Messenger of Allah, (what about those) who got their hair clipped? He said: O Allah, grant pardon to those who get their heads shaved. They said: Messenger of Allah, (what about those) who get their hair clipped? He said: O Allah, grant pardon to those who get their heads shaved. They said: (What about those) who get their hair clipped? He said: (O Allah, grant pardon to) those who get their hair clipped.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2988]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2988

A hadith like this is narrated on the authority of Abu Huraira.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2989]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2989

Yahya b. al-Husain reported on the authority of his grandfather that Allah's Apostle (may peace be upon him) invoked blessing on the occasion of the Farewell Pilgrimage three times for those who got their heads shaved and once for those who got their hair clipped. In the narration transmitted by Waki' there is no mention of the Farewell Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2990]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2990

Ibn Umar reported that Allah's Messenger (may peace be upon him) got his head shaved on the occasion of the Farewell Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2991]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2991

Anas b. Malik (Allah be pleased wish him) reported that Allah's Messenger (may peace be upon him) came to Mina; he went to the Jamra and threw pebbles at it, after which he went to his lodging in Mina, and sacrificed the animal. He then called for a barber and, turning his right side to him, let him shave him; after which he tiimed his left side. He then gave (these hair) to the people.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2992]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2992

Abu Bakr reported: (He called for) the barber and, pointing towards the right side of his head, said: (Start from) here, and then distributed his hair among those who were near him. He then pointed to the barber (to shave) the left side and he shaved it, and he gave (these hair) to Umm Sulaim (Allah be pleased with her). And in the narration of Abu Kuraib (the words are):" He started from the right half (of his head), and he distributed a hair or two among the people. and then (asked the barber) to shave the left side and he did similarly, and he (the Holy Prophet) said: Here is Abu Talha and he gave these (hair) to Abu Talha."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2993]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2993

Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) threw stones at Jamrat al-'Aqaba. He then want to his sacrificial animal and sacrificed it, and there was sitting the barber, and he pointed with his hand towards his head, and he shaved the right half of it, and he (the Holy Prophet) distributed them (the hair) among those who were near him. And he again said: Shave the other half, and said: Where is Abu Talha and gave it (the hair) to him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2994]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2994

Anas b. Malik (Allah be pleased with him) reported: When Allah's Messenger (may peace be upon him) had thrown pebbles at the Jamra and had sacrificed the animal, he turned (the right side) of his head towards the barber, and i. e shaved it. He then called Abu Talha al-Ansari and gave it to him. He then turned his left side and asked him (the barber) to shave. And he (the barber) shaved. and gave it to Abu Talha and told him to distribute it amongst the people.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2995]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2995

Abdullah b. 'Amr b. al-'As said that Allah's Messenger (may peace be upon him) stopped during the Farewell Pilgrimage at Mina for people who had something to ask. A man came and said: Messenger of Allah, being ignorant. I shaved before sacrificing, whereupon he (the Holy Prophet) said: Now sacrifice (the animal) and there is no harm (for you). Then another man came and he said: Messenger of Allah, being ignorant, I sacrificed before throwing the pebbles, whereupon he (the Holy Prophet) said: (Now) throw the pebbles, and there is no harm (for you). Allah's Messenger (may peace be upon him) was not asked about anything which had been done before or after (its proper time) but he said: Do it, and no harm is there (for you).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2996]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2996

'Abdullah b. 'Amr b. al-'As (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) stopped while riding his camel and the people began to ask him. One of the inquirers said: Messenger of Allah, I did not know that pebbles should be thrown before sacrificing the animal, and by mistake I sacrificed the animal before throwing pebbles, whereupon Allah's Messenger (may peace be upon him) said: (Now) throw pebbles and there is no harm in it. Then another (person) came saying: I did not know that the animal was to be sacrificed before shaving, but I got myself shaved before sacrificing the animal, whereupon he (the Holy Prophet) said: Sacrifice the animal (now) and there is no harm in it. He (the narrator) said: I did not hear that anything was asked on that day (shout a matter) which a person forgot and could not observe the sequence or anything like it either due to forgetfulness or ignorance, but Allah's Messenger (may peace be upon him) said (about that): Do it; there is no harm in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2997]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2997

This hadith has been narrated on the authority of Zuhri.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2998]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2998

Abdullah b. Amr b. al-'As (Allah be pleased with them) reported: As Allah's Apostle. (may peace be upon him) was delivering sermon on the Day of Nahr, a man stood up before him and said: Messenger of Allah, I did not know that such and such (rite was to be performed) before such and such (rite). Then another man came and said: Messenger of Allah, I thought that such and such (rite) should precede such and such (rite), and then another man came and said: Messenger of Allah, I had thought that such and such was before such and such, and such and such (is the sequence) of the three (rites, viz. throwing of pebbles, sacrificing of animal and shaving of one's head). He said to all these three: Do now (if you have not observed the cequence) ; there is no harm in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.2999]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 2999

This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters. And the narration of Ibn Bakr is like one transmitted by 'Isa but with this (variation):" There are not these words in it: To all these three rites (throwing of pebbles sacrificing of animal and shaving of one's head)." And so far as the narration of Yahya al-Umawi (the words are): I got (my head) shaved before I sacrificed the animal, and I sacrified the animal before throwing pebbles, and like that.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3000]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3000

Adullah b. 'Amr (b. al-'As) (Allah be pleased with him) reported that a person came to Allah's Apostle (may peace be upon him) and said: I got (my head) shaved before sacrificing the, animal, whereupon be (the Holy Prophet) said: Sacrifice the animal (now) ; there is no harm in it. He (the person said): I sacripced the animal before throwingpebbles. whereupon he said: Throw pebbles (now) ; there is no harm in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3001]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3001

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters (and the words are): I saw Allah's Messenger (may peace be upon him) on the back of the camel at Mina, and a person came to him," and the rest of the hadith Is like that transmitted by Ibn 'Uyaina.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3002]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3002

'Abdullah b. 'Amr b. al-As (Allah be pleased with them) said: As Allah's Messenger (may peace be'upon him) was standing near the jamra, a person came to him on the Day of Nahr and said: Messenger of Allah, I got (my head shaved) before throwing pebbles, whereupon he (the Holy Prophet) said: Throw pebbles (now) ; there is no harm in it. Another man (then) came and said: I have sacrificed before throwing the stones. He said: Throw stones (now) and there is no harm. Another came to him and said: I have observed the circumambulation of Ifada of the House before throwing pebbles. He said: Throw pebbles (now) ; there is no harm in it, He (the narrator) said: I did not see that he (the Holy Prophet) was asked about anything on that day, but he said: Do, and there is no harm in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3003]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3003

Ibn Abbas (Allah be pleased with them) reported that it was said to Allah's Apostle (may peace be upon him) about sacrificing of animals, shaving of one's head, throwing of pebbles, and (the order of) precedence and succession, and he said: There is no harm in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3004]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3004

Ibn Umar reported that Allah's Messenger (may peace be upon him) observed the circumambulation of Ifada on the Day of Nabr (10th of Dhu'l-Hijja), and then came back and observed the noon prayer at Mina. Nafi' (one of the narrators) said that Ibn Umar used to observe the circumambulation of Ifada on the Day of Nahr, and then return and observe the noon prayer at Mina, and mentioned that Allah's Apostle (may peace be upon him) did that.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3005]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3005

Abd al-'Aziz b. Rufai' (Allah be pleased with him) said: I asked Anas b. Malik to tell me about something he knew about Allah's Messenger (may peace be upon him), viz. where he observed the noon prayer on Yaum al-Tarwiya. He said: At Mina. I said: Where did he observe the afternoon prayer on the Yaum an-Nafr? and he said: It was at al-Abtah. He then said: Do as your rulers do.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3006]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3006

Ibn 'Umar (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) and Abu Bakr and 'Umar observed halt at al-Abtah.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3007]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3007

Nafi' reported that Ibn 'Umar regarded halt at Muhassab as Sunnah (of the Holy Prophet) and observed the noon prayer on Yaum al-Nafr at that place. Nafi' said: Allah's Messenger (may peace be upon him) halted at Muhassab and the Caliphs did the same after him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3008]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3008

'A'isha (Allah be pleased with her) reported.: Halt at al-Abtah is not the Sunnah. Allah's Messenger (may peace be upon him) halted there simply because it was easier for him to depart from there, when he left.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3009]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3009

This hadith is narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3010]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3010

Salim reported that Abu Bakr, 'Umar and Ibn Umar used to halt at Abtah. 'Urwa narrated from 'A'isha (Allah be pleased with her) that he did not observe this practice and said: Allah's Messenger (may peace be upon him) halted there, for it is a place from where it was easy to depart.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3011]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3011

Ibn 'Abbas (Allah be pleased with them) reported: Halt at Muhassab is not something (significant from the point of view of the Shari'ah). It is a place of halt where Allah's Messenger (way peace be upon him) halted.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3012]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3012

Abu Rafi' reported: Allah's Messenger (may peace be upon him) did not command me to observe halt at al-Abtah when be departed from Mina, but I came and set up his (the Holy Prcphet's) tent (of my own accord) ; and he (Allah's Apostle) came and observed halt. This hadith is narrated through another chain of transmitters from Abu Rafi' who was (in charge) of the luggage of Allah's Apostle (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3013]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3013

Abu Huraira (Allah be pleated with him) reported that Allah's Messenger (may peace be upon him) said: God willing, we will get down tomorrow, at Khaif of Banu Kinanah, the place where they had taken an oath on unbelief.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3014]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3014

Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) said to us as we were at Mina: We would observe halt tomorrow at-Khaif of Banu Kinanah, where (the polytheists) had taken an oath on unbelief, and that was that the Quraish and Banu Kinanah had, pledged against Banu Hashim and Banu Muttalib that they would neither marry nor do any transaction with them unless they deliver Allah's Messenger (way peace be upon him) to them. And (this pledge was) taken at this (place) Muhassab.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3015]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3015

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: God willing, when Allah has granted us victory, our halt tomorrow will be at Khaif, where they (the unbelievers of Mecca) had taken an oath on unbelief.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3016]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3016

Ibn Umar (Allah be pleased with them) reported that al-'A'bbas b. Abd al-Muttalib (Allah be pleased with him) sought permission from Allah's Messenger (may peace be upon him) to spend in Mecca the nights (which be was required to spend) at Mina on account of his office of supplier of water, and he (the Holy Prophet) granted him permission.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3017]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3017

A hadith like this has been narrated by 'Ubaidullah b. Umar with the the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3018]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3018

Bakr b. 'Abdullah al-Muzani said: While I was sitting along with Ibn 'Abbas (Allah be pleased with him) near the Ka'ba, there came a bedouin to him and said: What is the matter that I see that the progeny of your uncle supply honey and milk (as drink to the travellers), whereas you supply al-nabidh (water sweetened with dates)? Is it due to your poverty or due to your close-fistedness? Thereupon Ibn 'Abbas said: Allah be praised, it is neither due to poverty nor due to close-fistedness (but due to the fact) that Allah's Apostle (may peace be upon him) came here riding his she-came, and there was sitting behind him Usama. He asked for water, and we gave him a cup full of nabidh and he drank it, and gave the remaining (part) to Usama; and he (the Holy Prophet) said: You have done Food, You have done well. So continue doing like it So we do not like to change what Allah's Messenger (may peace be upon him) had commanded us to do.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3019]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3019

'All (Allah be pleased with him) reperted: Allah's Messenger (may peace be upon him) put me in charge of his sacrificial animals, that I should give their flesh. skins and saddle cloths as sadaqa, but not to give anything to the butcher, saying: We would pay him ourselves.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3020]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3020

This hadith has been narrated on the authority of Abd al-Karim al-Jazari with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3021]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3021

This hadith has been narrated on the authority of 'Ali (Allah be pleased with him) with another chain of transmitters, but there is no mention of the wages of the butcher in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3022]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3022

Ali b. Abi Talib (Allah be pleased with him) reported: Allah's Apostle (may peace be upon him) put him in charge of his sacrificial animals, and commanded him to distribute the whole of their meat, hides, and saddle cloths to the poor, and not to give to the butcher anything out of them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3023]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3023

A hadith like this has been narrated on the authority of Hadrat 'Ali (Allah be pleased with him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3024]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3024

Jabir b. 'Abdullah (Allah be pleased with him) reported: In the year of Hudaibiya (6 H ), we, along with Allah's Messenger (way peace be upon him), sacrificed a camel for seven persons and a cow for seven persons.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3025]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3025

Jabir (Allah be pleased with him) reported: We set out in the state of Ihram for Hajj along, with Allah's Messenger (may peace be upon him). He commanded us that seven perons should join in a camel and a cow for offering sacrifice.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3026]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3026

Jabir b. 'Abdullah (Allah be pleased with him) reported: We performed Hajj along with Allah's Messenger (may peace be upon him), and we sacrificed a camel on behalf of seven persons, and a cow on behalf of seven persons.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3027]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3027

Jabir b. 'Abdullah (Allah be pleased with them) reported: We joined Allah's Apostle (may pea, @. e be upon him) in Hajj and Umra and seven persons shared in the sacrifice of an animal. A person said to Jabir (Allah be pleased with him): Can seven persons share in the sacrifice of al-Badnah (a camel) as he shares in al- Jazur (a cow)? He, (Jabir) said: It (al-Jazur) is nothing but one among the budun. Jabir was present at Hudaibiya and he said: We sacrificed on that day seventy camel, and seven men shared in each sacrifice (of camel).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3028]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3028

Jabir b. 'Abdullah (Allah be pleased with them), describing the Hajj of Allah's Apostle (may peace be upon him) said: He (the Holy Prophet) commanded us as we had entered into the state of Ihram to sacrifice the animals (as a rite of Hajj) and a group (of person; amongst us, i. e. seven) shared in the sacrifice of one (camel or cow), and it happened at that time when he commanded them to put off Ihram for Hajj (after performing 'Umra).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3029]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3029

Jaibir b. 'Abdullah (Allah be pleased with them) reported: We performed Hajj Tamattu' along with Allah's Messenger (may peace be upon him) and we slaughtered a cow on behalf of seven persons sharing in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3030]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3030

Jabir reported that Allah's Messenger (may peace be upon him) sacrificed a cow on behalf of 'A'isha on the Day of Nahr (10th of Dhu'l-Hijja).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3031]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3031

Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) sacrificed (animals) on behalf of his wives, and in the hadith transmitted by Ibn Abu Bakr (the words are):" A cow on behalf of 'A'isha on the occasion of the Hajj."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3032]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3032

Ziyad b. Jubair reported that Ibn 'Umar came upon a person who was slaughtering (sacrificing) his camel and had made him kneel down. So he told him to make it stand up festered (and then sacrifice it) according to the Sunnah of the Holy Prophet (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3033]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3033

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) sent the sacrificial animals from Medina. I wove garlands for his sacrificial animals (and then he hung them round their necks), and he would not avoid doing anything which the Muhrim avoids A hadith like this has been transmitted on the authority of Ibn Shihab.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3034]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3034

'A'isha narrated (in another badith narrated through another chain of transmitters) these words:" As if I am seeing myself weaving the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him)."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3035]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3035

Abd al-Rahman b. al-Qasim reported on the authority of his father that he heard 'A'isha (Allah be pleased with her) saying: I used to weave garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with these hands of mine, but he (Allah's Apostle) neither avoided anything nor gave up anything (which a Muhrim should avoid or give up).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3036]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3036

'A'isha reported: I wove the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own bands, and then he (the Holy Prophet) marked them, and garlanded them, and then sent them to the House, and stayed at Medina and nothing was forbidden to him which was lawful for him (before).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3037]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3037

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) sent the sacrificial animals and I wove garlands for them with my own 'hands, and he did not refrain from doing anything which he did not avoid in the state of non-Muhrim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3038]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3038

Al-Qasim reported the Mother of the Faithful (Hadrat 'A'isha Siddiqa) (Allah be pleased with her) as saying: I used to weave these garlands from the multicoloured wool which was with us. The Messenger of Allah (may peace be upon him) was in the state of non Muhrim among us, and he would do all that was lawful for a lion-Muhrim with his wife.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3039]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3039

'A'isha (Allah be pleased with her) reported: I recall how I wove garlands for the sacrificial animals (the goats) of Allah's Messenger (may peace be upon him). He sent them and then stayed with us as a non-Muhrim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3040]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3040

'A'isha (Allah, be pleased, with her) reported: I often wove garlands for the sacrificial animals of Allah's Messenger (may peace be upon him), and he garlanded his sacrificial animals, and then he sent them and stayed in the ouse) avoiding nothing which a Muhrim avoids.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3041]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3041

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon, him) sent some goats as sacrificial animals to the House and He garlanded them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3042]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3042

'A'isha (Allah be pleased with her) reported: We used to garland the goats and send them (to Mecca), and Allah's Messenger (may peace be upon him) stayed back in Medina as a non-Muhrim ard nothing was forbidden for him (which is forbidden for a Muhrim).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3043]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3043

'Amra daughter of Abd al-Rahman reported that Ibn Ziyad had written to 'A'isha (Allah be pleased with him) that 'Abdullah b. Abbas (Allah be pleased with them) bad said that he who sent a sacrificial animal (to Mecca) for him was forbidden what is forbidden for a pilgrim (in the state of Ihram) until the animal is sacrificed I have myself sent my sacrificial animal (to Mecca), so write to me your opinion. Amra reported 'A'isha (Allah be pleased with her) as saying: It is not as Ibn 'Abbas (Allah be pleased with them) had asserted, for I wove the garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own hands. Allah's Messenger (may peace be upon him) then garlanded them with his own hands, and then sent them with my father, and nothing was forbidden for Allah's Messenger (may peace be upon him) which had been made lawful for him by Allah until the animals were sacrificed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3044]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3044

Masruq reported: I heard 'A'isha (Allah be pleased with her) clapping her hands behind the curtain and saying: I used to weave garlands for the sacrificial animals of Allah's Messenger (may peace be upon him) with my own hands, and then he (the Holy Prophet) sent them (to Mecca), and he did not avoid doing anything which a Muhritn avoids until his animal was sacrificed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3045]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3045

A hadith like this has been narrated on the authority of 'A'isha (Allah be pleased with her) through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3046]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3046

Abu Huraira (Allah be pleased with him) rerorted that Allah's Messenger (may peace be upon him) saw a person who was driving a sacrificial camel (and told him to ride on it. Thereupon he said: Messenger of Allah, it is a sacrificial camel. He told him again to ride on it; (when he received the same reply) he said: Woe to you, (he uttered these words on the second or the third reply).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3047]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3047

This hadith has been narrated by A'raj with the same chain of transmitters (and the words are):" Whereas the person was driving a sacrificial camel which was garlanded."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3048]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3048

Hammam b. Munabbih reported: It is one out of these (narrations) that Abu Huraira (Allah be pleased with him) narrated to us from Muhammad the Messenger of Allah (may peace be upon him), and he narrated to us traditions out of which is that he said: When there was a person who was driving a garlanded sacrificial camel, Allah's Messenger (may peace be upon him) said to him: Woe to you; ride on it. He said: Messenger of Allah, it is a sacrificial animal, whereupon Allah's Messenger (may peace be upon him) said: Woe to you, ride on it; woe to you, ride on it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3049]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3049

Anas reported that Allah's Messenger (may peace be upon him) happened to pass by a person who was driving a sacrificial camel, whereupon he (the Holy Prophet) said: Ride on It. He said: It is a sacrificial camel. Thereupon he (the Holy Prophet) said twice or thrice: Ride on it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3050]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3050

Anas reported: Someone happened to pass by Allah's Apostle (may peace be upon him) with a sacrificial camel, or a sacrificial animal, whereupon he said: Ride on it. He said: It is a sacrificial camel, or animal, whereupon he said: (Ride) even if (it is a sacrificial camel).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3051]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3051

Anas (Allah be pleased with him) reported: There happened to pass (a person) with a sacrificial camel by Allah's Apostle (may peace be upon him) and the rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3052]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3052

Jabir b. 'Abdullah (Allah be pleased with them) reported that he was asked about riding on a sacrificial animal, and he said: I heard Allah's Messenger (may peace be upon him) as saying: Ride on it gently, when you have need for it, until you find (another) mount.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3053]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3053

Abu Zubair reported: I asked Jabir (Allah be pleased with him) about riding on the sacrificial animal, to which he replied: I heard Allah's Apostle (may peace be upon him) as saying: Ride on them gently until you find another mount.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3054]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3054

Musa b. Salama al-Hudhali reported: I and Sinan b. Salama proceeded (to Mecca to perform Umra. Sinan had a sacrificial camel with him which he was driving. The camel stopped in the way being completely exhausted and this state of it made him (Sinan) helpless. (He thought) if it stops proceeding further how he would be able to take it, along with him and said: I would definitely find out (the religious verdict) about it. I moved on in the morning and as we encamped at al-Batha', (Sinan) said: Come (along with me) to Ibn 'Abbis (Allah be pleased with them) so that we should narrate to him (this incident), and he (Sinan) reported to him the incident of the sacrificial camel. He (Ibn Abbas) said: You have referred (the matter) to the well informed person. (Now listen) Allah's Messenger (may peace be upon him) sent sixteen sacrificial camels with a man whom he put in change of them. He set out and came back and said: Messenger of Allah, what should I do with those who are completely exhausted and become powerless to move on, whereupon he said: Slaughter them, and dye their hoofs in their blood, and put them on the sides of their humps, but neither you nor anyone among those who are with you must eat any part of them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3055]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3055

Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) sent eighteen sacrificial camels with a person. The rest of the hadith is the same, and the first part (of the above-mentioned hadith) is not mentioned.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3056]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3056

Ibn Abbas (Allah be pleased with them) reported that Dhuwaib, father of Qabisa (Allah be pleased with him) narrated to him that Allah's Messenger (may peace be upon him) sent under his charge the sacrificial camels, and said: If any of these is completely exhausted and you apprehend its death, then slaughter it, then dip its hoofs in its blood and imprint it on its hump; but neither you nor any one of your comrades should eat it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3057]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3057

Ibn 'Abbas (Allah be pleased with them) reported that the people used to return through every path, whereupon Allah's Messenger (way peace be upon him) said: None amongst you should depart until he performs the last circumambulation round the House. Zuhair said (the words are): [ARABIC: YANSWARIFUWN KULLA WAJH] and the word [arabic: FIY] was not mentioned.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3058]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3058

Ibn Abbas reported: The people were commanded (by the Holy Prophet) to perform the last circumambulation round the House, but menstruating women were exempted.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3059]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3059

Tawus reported: I was in the company of Ibn Abbas (Allah be pleased with them) when Zaid b. Thabit said: Do you give religious verdict that the woman who is in menses is allowed to go without performing the last circumambulation of the House? Ibn 'Abbas (Allah be pleased with them) said to him: Ask such and such woman of the Ansar, if you do not (believe my religious verdict) whether Allah's Messenger (may peace be upon him) had coimmanded her this. Zaid b Thabit (went to that lady and after getting this verdict attested by her) came back to Ibn Abbas (Allah be pleased with them) smilingly and said: I did not find you but telling the truth.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3060]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3060

'A'isha (Allah be pleased with her) reported: Safiyyah bint Huyayy entered the period of menses after performing Tawaf Ifada. I made a mention of her menses to Allah's Messenger (may peace be upon him), whereupon Allah's. Messenger (may peace be upon him) remarked: Well, then she will detain us. I said: Messenger of Allah. she has performed Tawif Ifada and circumambulated the House, and it was after this that she entered the period of menses. Thereupon Allah's Messenger (may peace be upon him) said: (If it is so), then proceed forth.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3061]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3061

This hadith is narrated (from 'A'isha) on the authority of Ibn Shihab with the same chain of transmitters (and the words are): Safiyyah bint Huyayy, the wife of Allah's Apostle (may peace be upon him), entered the period of menses at the occasion of the Farewell Pilgrimage after she had performed Tawaf Ifada in the state of cleanliness; the rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3062]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3062

Abd al-Rahman b. al Qasim narrated on the authority of 'A'isha (Allah be pleased with her) that she made a mention to Allah's Messenger (may peace be upon him) that Safiyyah had entered the period of menses. The rest of the hadith is the same.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3063]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3063

'A'isha (Allah be pleased with her) reported: We feared that Safiyyah might have entered the period of menses before performing Tawaf Ifada. Allah's Messenger (may peace be upon him) came to us and said: Is Safiyyah going to detain us? Thereupon we said: She has performed Tawaf Ifada. He (the Holy Prophet) said: Then there is no detention (for us) now.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3064]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3064

'A'isha (Allah be pleased with her) said to the Messenger of Allah (may peace be upon him): Messenger of Allah, Safiyyah bint Huyayy has entered the state of menses, whereupon Allah's Messenger (may peace be upon him) said: Perhaps she is going to detain us. Has she not clicumambulated the House along with you (i. e. whether she has not performed Tawaf Ifada)? They said: Yes. He said: Then they should set out.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3065]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3065

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) inclined to do with Safiyyah what a man feels inclined to do with his wife. They said: Messenger of Allah, she has entered the state of menses, whereupon he said: (Well) she is going to detain us. They (his wives) said: Messenger of Allah, she performed Tawaf Ziyara (Tawaf Ifada) on the Day of Nahr. Thereupon he said: Then she should proceed along with you


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3066]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3066

'A'isha (Allah be pleased with her) reported: When Allah's Apostle (may peace be upon him) decided to march (for return journey), he found Safiyyah at the door of her tent, sad and downcast. He remarked. Barren, shaven-head, you are going to detain us, and then said: Did you perform Tawaf Ifada on the Day of Nahr? She replied in the affirmative, whereupon he said: Then march on.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3067]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3067

This hadith is narrated by 'A'isha (Allah be pleased with her) through another chain of transmitters, but no mention is made of" sad and downcast".


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3068]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3068

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace, be upon him) entered the Ka'ba. Usama, Bilal and 'Uthman b. Talha, the keeper (of the Ka'ba), were along with him. He closed the door and stayed in it for some time. Ibn 'Umar (Allah be pleased with them) said: I asked Bilal as he came out what Allah's Messenger (may peace be upon him) had done there. He said: He prayed there in (such a position) that two pillars were on his left side, one pillar on his right, and three pillars were behind him, and the House at that time was resting on six pillars.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3069]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3069

Ibn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came on the Day of Victory, and got down in the courtyard of the Ka'ba and he sent (a message) for 'Uthman b. Talha (Allah be pleased with them). He came with the key and opened the door. Allah's Apostle (may peace be upon him) then entered therein and Bilal, Usama b. Zaid, and 'Uthman b. Talha (along with him), and then commanded the door to be closed. They stayed there for a considerable time, and then the door was opened, and Abdullah said: I was the first to meet Allah's Messenger. (may peace be upon him). outside (the Ka'ba), and Bilal was close behind him. I said to Bilal: Did Allah's Messenger (may peace be upon him) observe prayer therein? He said: Yes. I said: Where? He said: Between the two pillars in front of his face. He said: I forgot to ask him as to the number of rakahs he prayed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3070]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3070

lbn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) came daring the year of Victory on the she-camel of Usama b. Zaid until he made her kneel down in the courtyard of the Ka'ba (and got down). He then sent for 'Uthman b. Talha and said: Bring me the key. He went to his mother and she refused to give that to him. He said: By Allah, give that to him or this sword would be thrust into my side. So she gave that to him, and he came with that to Allah's Apostle (may peace be upon him) and gave that to him, and he opened the door. The rest of the hadith is the same as the above one.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3071]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3071

Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger, (may peace be upon him) entered the House, and Usama, Bilal and Uthman b. Talha were with him, and they kept the door closed for a considerable time. Then it was opened and I was the first to enter the House and meet Bilal, and I said: Where did Allah's Messenger (may peace be upon him) observe prayer? He said: Between these two front pillars. I, however, forgot to ask him the number of rak'ahs that he observed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3072]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3072

Abdullah b. Umar reported that he reached the Ka'ba and Allah's Apostle (may peace be upon him) had entered therein, and Bilal and Usama too. 'Uthman b. Talha closed the door to them, and they stayed there for a considerable time, and then the door was opend and Allah's Apostle (may peace be upon him) came out, and I went upstairs and entered the House and said: Where did Allah's Apostle (may peace be upon him) observe prayer? They said: At this very place. I, however, forgot to ask them about the (number of) rak'ahs that he observed.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3073]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3073

Salim narrated on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) entered the House along with Usama b. Zaid, Bilal and Uthman b. Talha. They closed the door from within, and, as they opened it, I was the first to get into it and meet Bilal, and I asked him: Did Allah's Messenger (may peace be upon him) observe prayer in it? He said: Yes, he observed prayer between these two Yemenite pillars (pillars situated towards the side of Yemen).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3074]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3074

Salim b. Abdullah reported his father (Allah be pleased with him) saying: I saw Allah's Messenger (may peace be upon him) entering the Ka'ba, and Usama b. Zaid, Bilal and 'Uthman b. Talha were along with him, but none (else) entered therein along with them. Then the door was closed for them from within. 'Abdullah b. Umar (Allah be pleased with them) said: Bilal and Uthman b. Talha informed me that Allah's Messenger (may peace be upon him) observed prayer in the interior of the Ka'ba between the two Yemenite pillars.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3075]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3075

Ibn Juraij reported: I said to 'Ata': Have you heard Ibn 'Abbas saying: You have been commanded to observe circumambulation, and not commanded to enter it (the Ka'ba)? He ('Ata') said: He (Ibn Abbas) (at the same time) did not forbid entrance into it. I, however, heard him saying: Usama b. Zaid informed me that when Allah's Apostle (may peace be upon him) entered the House, he supplicated in all sides of it; and he did not observe prayer therein till he came out, and as he came out he observed two rak'ahs in front of the House, and said: This is your Qibla. I said to him: What is meant by its sides? Does that mean its corners? He said: (In all sides and nooks of the House) there is Qibla.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3076]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3076

Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) entered the Ka'ba, and in it there were six pillars, and he stood near a pillar and made supplication, bnt did not observe the prayer.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3077]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3077

Isma'il b. Abu Khalid reported: I asked Abdullah b. Abu Aufa (Allah be pleased with him), a Companion of Allah's Messenger (may peace be upon him), whether Allah's Apostle (may peace be upon him) had entered the House, while performing 'Umra, He said: NO.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3078]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3078

'A'isha (Allah be pleased with her) reported: Allah's Messenger may peace be upon him) said to me: Had your people not been unbelievers in the recent past (had they not quite recently accepted Islam), I would have demolished the Ka'ba and would have rebuilt it on the foundation (laid) by Ibrahim; for when the Quraish had built the Ka'ba, they reduced its (area), and I would also have built (a door) in the rear.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3079]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3079

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3080]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3080

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) as having said this: Didn't you see that when your people built the Ka'ba, they reduced (its area with the result that it no longer remains) on the foundations (laid) by Ibrahim. I said: Messenger of Allah, why don't you rebuild it on the foundations (laid by) Ibrahim? Thereupon Allah's Messenger (may peace be upon him) said: Had your people not been new converts to Islam, I would have done that. 'Abdullah b. 'Umar (Allah be pleased with them) said: If 'A'isha (Allah be pleased with her) had heard it from Allah's Messenger (may peace be up (vn him), I would not have seen Allah's Messenger (may peace be upon him) abandoning the touching of the two corners situated near al-Hijr, but (for the fact) that it was not completed on the foundations (laid) by Ibrihim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3081]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3081

'A'isha (Allah be pleased with her), wife of Allah's Apostle (may peace be upon him), heard Allah's Messenger (may peace be upon him) as saying: If your people, had not been recent converts to Islam, I would have spent the treasure of the Ka'ba in the way of Allah and would have constructed its door just on the level of the ground and would have encompassed in it the space of Hijr.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3082]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3082

'Abdullah b. Zubair (Allah be pleased with him) reported on the authority of his mother's sister ('A'isha) saying that Allah's Messenger (may peace be upon him) said: 'A'isha, if your people had not been recently polytheists (and new converts to Islam), I would have demolished the Ka'ba, and would have brought it to the level of the ground and would have constructed two doors, one facing the east and the other one to the west, and would have added to it six cubits of area from Hijr, for the Quraish had reduced it when they rebuilt it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3083]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3083

'Ata' reported: The House was burnt during the time of Yazid b. Muawiya when the people of Syria had fought (in Mecca). And it happened with it (the Ka'ba) what was (in store for it). Ibn Zubair (Allah be pleased with him) felt it (in the same state) until the people came in the season (of Hajj). (The idea behind was) that he wanted to exhort them or incite them (to war) against the people of Syria. When the people had arrived he said to them: O people, advise me about the Ka'ba. Should I demolish it and then build it from its very foundation, or should I repair whatever has been damaged of it? Ibn 'Abbas said: An idea has occurred to me according to which I think that you should only repair (the portion which has been) damaged, and leave the House (in that very state in which) people embraced Islam (and leave those very stones in the same state) when people embraced Islam, and over which Allah's Apostle (may peace be upon him) had raised it. Thereupon Ibn Zubair said: It the house of any one of you is burnt, he would not be contented until he had reconstructed it, then what about the House of your Lord (which is far more Important than your house)? I would seek good advice from my Lord thrice and then I would make up (my mind) about this affair. After seeking good advice thrice, he made up his mind to demolish it. The people apprehended that calamity might fall from heaven on those persons who would be first to climb (over the building for the purpose of demolishing it), till one (took up courage, and ascended the roof), and threw down one of its stones. When the people saw no calamity befalling him, they followed him, demolished it until it was razed to the ground. Then Ibn Zubair erected pillars and hung cartains on them (in order to provide facilities to the people for observing the time of its construction). And the walls were raised; and Ibn Zubair said: I heard 'A'isha (Allah be pleased with her) say that Allah's Apostle (may peace be upon him) had observed: If the people had Rot recently (abandoned) unbelief, find I had means enough to reconstruct it, which I had not, I would have definitely excompassed in it five cubits of area from Hijr. And I would also have constructed a door for the people to enter, and a door for their exit. I today have (the means to spend) and I entertain no fearfrom the side of people (that they would protest against this change). So he added five cubits of area from the side of Hatim to it that there appeared (the old) foundation (upon which Hadrat Ibrahim had built the Ka'ba). and the people saw that and it was upon this foundation that the wall was raised. The length of the Ka'ba was eighteen cubits. when addition was made to it (which was in its breadth), then naturally the length appears to be) small (as compared with its breadth). Then addition of ten cubits (of area) was made in its length (also). Two doors were also constructed, one of which (was meant) for entrance and the other one for exit. When Ibn Zubair (Allah be pleased with him) was killed, Hajjaj wrote to 'Abd al-Malik (b. Marwan) informing him about it, and telling him that Ibn Zubair (Allah be pleased with him) had built (the Ka'ba) on those very foundations (which were laid by Ibrahim) and which reliable persons among the Meccans had seen. 'Abd al-Malik wrote to him: We are not concerned with the censuring of Ibn Zubair in anything. Keep intact the addition made by him in the side of length, and whatever he has added frem the side of Hijr revert to (its previous) foundation, and wall up the door which he had opened. Thus Hajjaj at the command of Abd al-Malik) demolished it (that portion) and rebuilt it on (its previous) foundations.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3084]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3084

Abdullah b. 'Ubaid reported that Harith b. 'Abdullah led a deputation to 'Abd al-Malik b. Marwan during his caliphate. 'Abd al-Malik said: I do riot think that Abu Khubaib (i. e. Ibn Zabair) had heard from 'A'isha (Allah be pleased with her) (about the intended wish of the Holy Prophet [may peace be upon him) In regard to the alteration of the Ka'ba). Harith said: Yes, I myself did hear from her. He ('Abd al-Malik) said: Well, tell me what you heard from her. He stated that she (Hadrat 'A'isha) had said that Allah's Messenger (may peace be upon him) remarked: Verily your people have reduced (the area) of the House from its (original foundations, and if they had not recently abandoned polytheism (and embraced Islam) I would have reversed it to (those foundations) which they had left out of it. nd if your people would take initiative after me in rebuilding it, then come along with me so that I should show you what they have left out of it. He showed her about fifteen cubits of area from the side of Hatim (that they had separated). This is the narration transmitted by 'Abdullah b. Ubaid. Walid b. 'Ata' has, however, made this addition to it:" Allah's Apostle (may peace be upon him) said: I would have made two doors on the level of the ground (facing) the east and the west. Do you know why your people raised the level of its door (i. e. the door of the Ka'ba)? She said: No. He said: (They did it) out of vanity so that (they might be in a position) to grant admittance to him only whom they wished. When a person intended to get into it, they let him climb (the stairs), and as he was about to enter, they pushed him and he fell down." 'Abd al-Malik said to Harith; Did you yourself hear her saying this? He said: Yes. He (Harith) said that he ('Abd al-Malik) scratched the ground with his staff for some time and then said: I wish I had left his (Ibn Zubair's) work there.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3085]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3085

This hadith has been narrated on the authority of Juraij with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3086]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3086

Abu Qaza'ah reported that while Abd al-Malik b. Marwan was circumambulating the Ka'ba he said: May Allah ruin Ibn Zubair that he lies in attributing to the Mother of the Faithful, as he says: I heard her stating that Allah's Messenger (may'peace be upon him) had said: 'A'isha, if your people had not been new converts to Islam, I would have demolished the House and would have added (in it area) from the Hijr for your people have reduced the area from its foundations. Harith b. 'Abdullah b. Abu Rabi'a (Allah be pleased with him) said: Commander of the Faithful, don't say that, for I heard the Mother of the Faithful saying this, whereupon he said: If I had heard this before demolishing it, I would have left it in the state in which Ibn Zabair had built it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3087]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3087

'A'isha (Allah be pleased with her) reported: I asked Allah's Messenger (may peace be upon him) about the wall, circumpassing the House (i. e. whether the wall on the side of Hijr was included in the Ka'ba). He said, Yes. I said: Then why did they not include it in the House? He said: 'Your people ran short of the means (to do so). I said: Why is it that the level of its door is raised high? He said: Your people did it so that they should admit one whom they liked, and forbid him whom they disliked, and if your people were not new converts to faith, and I did not apprehend that their hearts would feel agitated at this. I would have definitely included (the area of) this wall-in the House and would have brought the door to the level of the ground.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3088]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3088

'A'isha reported: I asked Allah's Messenger (may peace be upon him) about Hijr, and the rest of the hadith is the same. I also said: Why is it that the door has been made on a higher level, and one cannot (get into it) but with the help of a ladder? The rest of the hadith is the same as reported above and the concluding words are: (I do not change it) out of the apprehension that their hearts may disapprove of it."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3089]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3089

'Abdullah b. 'Abbas reported that while al-Fadl b. Abbas had been riding behind Allah's Messenger (may peace be upon him) a women of the tribe of Khath'am came to him (to the Holy Proppet) asking for a religious verdict. Fadl looked at her and she looked at him. Allah's Messenger (may peace be upon him) turned the face of al-Fadl to the other side. She said: Messenger of Allah, there is an obligation from Allah upon His servants in regard to Hajj. (But) my father is an aged man; he is incapable of riding safely. May I perform Hajj on his behalf? He said: Yes. It was during the Farewell Pilgrimage.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3090]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3090

Fadl reported that a woman of Banu Khath'am said: Messenger of Allah, my father is very old. There is an old obligation of Hajj upon him from Allah, but he is not capable of sitting on the back of the camel. Thereupon Allah's Apostle (may peace be upon him) said: Perform Hajj on his behalf.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3091]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3091

Ibn Abbas reported that Allah's Apostle (may peace be upon him) met some riders at al-Rauha and asked who they were. They replied that they were Muslims. They said: Who art thou? He said: (I am) Messengef of Allah. A woman (then) lifted up a boy to him and said: Would this child be credited with having performed the Hajj? Thereupon he said: Yes, and you will have a reward.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3092]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3092

Ibn Abbas (Allah be pleased with them) reported: A woman lifted up her child and said: Messenger of Allah, would the child be credited with having performed the Hajj? Thereupon he said: Yes, and there would be a reward for you.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3093]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3093

Karaib reported: A woman lifted a child and said: Messenger of Allah, would he be credited with Hajj? He said: Yes. and for you there would be a reward.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3094]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3094

A hadith like this has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3095]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3095

Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) addressed us and said: O people, Allah has made Hajj obligatory for you; so perform Hajj. Thereupon a person said: Messenger of Allah, (is it to be performed) every year? He (the Holy Prophet) kept quiet, and he repeated (these words) thrice, whereupon Allah's Messenger (may peace be upon him) said: If I were to say" Yes," it would become obligatory (for you to perform it every year) and you would not be able to do it. Then he said: Leave me with what I have left to you, for those who were before you were desroyed because of excessive questioning, and their opposition to their apostles. So when I command you to do anything, do it as much as it lies in your power and when I forbid you to do anything, then abandon it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3096]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3096

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A woman should not set out on three (days' journey) except when she has a Mahram with her.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3097]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3097

This hadith has been narrated on the same authority by Ubaidullah. And in the narration of Abu Bakr (the words are):" More than three (days)." Ibn Numair narrated on the authority of his father, (and the words are):" Three (days) except (when) she has a Mahram with her."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3098]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3098

'Abdullah b. Umar (Allah -be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: It is not lawful for a woman who believes in Allah and the Hereafter to travel for more than three nights journey except when there is a Mahram with her.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3099]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3099

Qaza'ah reported: I heard a hadith from Abu Sa'id (Allah be pleased with him) and it impressed me (very much), so I said to him: Did you hear it (yourself) from Allah's Messenger (may peace be upon him)? Thereupon he said: (Can) I speak of anything about Allah's Messenger (may peace be upon him) which I did not bear? He said: I heard Allah's Messenger (may peace be upon him) saying: Do not set out on a journey (for religious devotion) but for the three mosques-for this mosque of mine (at Medina) the Sacred Mosque (at Mecca), and the Mosque al-Aqsa (Bait al-Maqdis), and I heard him saying also: A woman should not travel for two days duration, but only when there is a Mahram with her or her husband.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3100]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3100

Qaza'ah reported: I heard Abu Sa'id al-Khudri (Allah be pleased with him) saying: I heard four things from Allah's Messenger (may peace be upon him) which impressed me and captivated me (and one out of these is this), that he forbade a woman to undertake journey extending over two days but with her husband, or with a Mahram; and he then narrated the rest of the hadith.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3101]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3101

Abu Sa'id (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A woman should not set out on three (days') journey, but in the company of a Mahram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3102]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3102

Abu Sa'id Khudri (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A woman should not set out on a journey extending beyond three nights but with a Mahram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3103]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3103

This hadith has been narrated on the authority of Qatada with the same chain of transmitters and he said:" More than three (days) except in the company of a Mahram."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3104]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3104

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a Muslim woman to travel a night's journey except when there is a Mahram with her.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3105]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3105

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: It is not lawful for a woman who believes in Allah and the Hereafter to undertake a day's journey except in the company of a Mahram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3106]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3106

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman believing in Allah and the Hereafter to undertake journey extending over a day and a night except when there is a Mahram with her.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3107]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3107

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman to undertake three (days, ) journey except when there is a Mahram with her.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3108]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3108

Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: It is not lawful for a woman believing in Allah and the Hereafter to undertake journey extending over three days or more, except when she is in the company of her father, or her son, or her husband, or her brother, or any other Mahram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3109]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3109

A hadith like this has been narrated by A'mash with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3110]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3110

Ibn 'Abbas (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) delivering a sermon and making this observation:" No person should be alone with a woman except when there is a Mahram with her, and the woman should not undertake journey except with a Mahram." A person stood up and said: Allah's Messenger, my wife has set out for pilgrimage, whereas I am enlisted to fight in such and such battle, whereupon he said:" You go and perform Hajj with your wife."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3111]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3111

A hadith like this has been narrated by 'Amr on the authority of the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3112]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3112

Ibn Juraij narrated this hadith with the same chain of transmitters, but he made no mention of it:" No person should be alone with a woman except when there is a Mahram with her."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3113]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3113

Ibn Umar (Allah be pleased with them) reported that whenever Allah's Messenger (may peace be upon him) mounted his camel while setting out on a journey, he glorified Allah (uttered Allah-o-Akbar) thrice, and then said: Hallowed is He Who subdued for us this (ride) and we were not ourselves powerful enough to use It as a ride, and we are going to return to our Lord. O Allah, we seek virtue and piety from Thee in this journey of ours and the act which pleaseth Thee. O Allah, lighten this journey of ours, and make its distance easy for us. O Allah, Thou art (our) companion during the journey, and guardian of (our) family. O Allah, I seek refuge with Thee from hardships of the journey, gloominess of the sights, and finding of evil changes in property and family on return. And he (the Holy Prophet) uttered (these words), and made this addition to them: We are returning, repentant, worshipping our Lord. and praising Him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3114]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3114

Abdullah b. Sarjis (Allah be pleased with him) reported that when Allah's Messenger (may peace be upon him) set forth on a journey, he sought refuge (with Allah) from the hardships of the travelling, and finding of evil changes on return, and disgrace after honour, and the curse of the oppressed and a gloomy sad scene in family and property.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3115]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3115

A hadlth like this has been narrated on the authority of Asim With the same chain of transmitters except (this difference) that the hadith transmitted by 'Abd al-Wahid (one of the narrators) the (word)" property" precedes the family, and in the hadith transmitted by Mahammad b. Khazim (the word)" family" precedes (theword" Property" ), on returning home, in the narrations of both the narrators (these words are found):" O Allah I seek refuge with Thee from the hardships of the journey."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3116]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3116

Abdullah b. 'Umar reported that whenever Allah's Messenger (may peace be upon him) came back from the battle or from expeditions or from Hajj or Umra and as he reached the top of the hillock or upon the elevated hard ground, he uttered Allah-o- Akbar thrice, and then said: There is no god but Allah. He is One, there is no partner with Him, His is the sovereignty and His is the praise and He is Potent over everything. (We are) returning, repenting, worshipping, prostrating before our Lord, and we praise Him Allah fulfilled His promise and helped His servant, and routed the confederates alone.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3117]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3117

This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters (but with one alteration) that here Allah-o-Akbar is mentioned twice.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3118]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3118

Anas b. Malik (Allah be pleased with him) reported: I and Abu Talha (both) came back along with Allah's Apostle (may peace be upon him). Safiyyah (the wife of the Holy Prophet) rode behind him on his camel and as we came to the out- skirts of Medina he said: (We are those) who return, who repent, who worship our Lord, who praise (Him), and he went on uttering this until we entered Medina.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3119]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3119

A hadith like this has been narrated by Anas b. Malik (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3120]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3120

Abdullah b. 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) made (his camel) kneel down (i, e. halt at the stony ground of Dhu'l-Hulaifa) and prayed there, and so did Abdullah b. Umar (Allah be pleased with them).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3121]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3121

Nafi' reported that 'Abdullah b. Umar (Allah be pleased with them) used to halt his camel in the stony ground at Dhu'l-Hulaifa, where Allah's Messenger (may peace be upon him) used to make a halt (and pray).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3122]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3122

Nafi' reported that when 'Abdullah b. 'Umar returned from Hajj or 'Umra he made his camel kneel down (i. e. halted) in the stony ground of Dhu'l-Hulaifa where Allah's Messenger (may peace be upon him) had made his camel halt.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3123]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3123

Salim (b. Abdullah b. 'Umar) reported on the authority of his father (Allah be pleased with them) that Allah's Apostle (may peace be upon him) was visited by (someone, i. e. an angel) during the fag end of the night at Dhu'l-Hulaifa, and it was said to him: Verily it is a blessed stony-ground.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3124]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3124

Salim b. Abdullah b. Umar reported on the authority of his father (Allah be pleased with them) that Allah's Apostle (may peace be upon him) came to Dhu'l- Hulaifa in the heart of the valley at the fag end of the night, and it was said to him: It is a blessed stony ground. Musa (one of the narrators) said: Salim made his came) halt at the mosque where 'Abdullah made his camel halt as seeking the place of stay of Allah's Messenger (may peace be upon him). It is, in fact, situated at a lower plain than the mosque, which stands in the heart of the valley, and it is between it (the mosque) (and Qibla) that that place (where Allah's Apostle used to get down for rest and prayer) is situated.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3125]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3125

Abu Huraira (Allah be pleased with him) reported: Abu Bakr Siddiq (Allah be pleased with him) sent me during Hajj before the Farewell Pilgrimage for which Allah's Messenger (may peace be upon him) had appointed him an Amir, among a group of people whom he had ordered to make announcement to the people on the Day of Nahr:" After this year no polytheist may perform the Pilgrimage and no naked person may circumambulate the House." Ibn Shihab stated that Humaid b. Abd al-Rahman said that according to this narration of Abu Huraira (Allah be pleased with him) the day of Hajj al-Akbar (Great Hajj) is this Day of Nahr (10th of Dhu'l-Hijja).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3126]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3126

'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: There is no day when God sets free more servants from Hell than the Day of 'Arafa. He draws near, then praises them to the angels, saying: What do these want?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3127]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3127

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: An Umra is an expiation for the sins committed between it and the next, and Hajj which is accepted will receive no other reward than Paradise.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3128]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3128

This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3129]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3129

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying. He who came to this House (Ka'ba) (with the intention of performing Pilgrimage), and neither spoke indecently nor did he act wickedly. would return (free from sin) as on the (very first day) his mother bore him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3130]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3130

This hadith has been narrated on the authority of Mainsur with the same chain of transmitters (and the words are):" He who performed Pilgrimage but neither spoke indecently nor acted wickedly."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3131]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3131

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3132]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3132

Usama b. Zaid b. Haritha (Allah be pleased with him) said to Alla's Messenger (may peace be upon him): Will you stay in your house at Mecca (which you abandoned at the time of migration)? Thereupon he said: Has 'Aqil left for as any land or house? And 'Aqil and Talib became the Inheritors of Abu Talib's (property), and neither Ja'far nor 'Ali inherited anything from him, for both (Ja'far and 'Ali) were Muslims whereas 'Aqil and Talib were non-Muslims.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3133]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3133

Usama b. Zaid (Allah be pleased with him) said: Allah's Messenger, God willing, where will you stay tomorrow? And it was at the time of the Conquest (of Mecca). Thereupon he (the Holy Prophet) said: Has 'Aqil left any accommodation for us?


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3134]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3134

Al-'Ali' b. al-Hadrami reported Allah's Messenger (may peace he upon as saying: For a Mahijir, it is only three (days') stay at Mecca, after completing (the Hajj or 'Umra) that is allowed, and it seemed as if he was saying that he should not (stay) beyond this (period).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3135]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3135

Al-'Ali, ' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: The Muhijir should stay at Mecca after performing the rituals (of Hajj) but for three (days) only.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3136]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3136

Al-'Ala' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: It is only for three nights that a Muhajir should stay at Mecca after the completion of the rituals of Hajj.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3137]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3137

Al-" Ala' b. al-Hadrami reported Allah's Messenger (may peace be upon him) as saying: The stay at Mecca after the completion of his rituals (of Hajj) is only for three days.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3138]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3138

Ibn Juraij narrated this hadith with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3139]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3139

Ibn 'Abbas (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying on the Day of Victory over Mecca: There is no Hijra (emigration) but only Jihad and good intention; and when you are called to battle, then go forth. He also said on the Day of Victory over Mecca: Allah made this town sacred on the day He created the earth and the heavens; so it is -sacred by the sacred- ness conferred on it by Allah until the Day of Resurrection and fighting in it was not lawful to anyone before me, and it was made lawful for me only during an hour on one day, for it is sacred by the sacredness conferred on it by Allah until the Day of Resurrection. Its thorns are not to be cut, its game is not to be molested, and the things dropped are to be picked up only by one who makes a public announcement of it, and its fresh herbage is not to be cut. Abbas (Allah be pleased with him) said: Messenger of Allah, exception may be made in case of rush, for it is useful for their blacksmiths and for their houses. He (the Holy Prophet) conceding the suggestion of 'Abbas) said: Except rush.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3140]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3140

A hadith like this has been narrated on the authority of Mansur, but he did not mention:" On that very day He created the heavens and the earth," and he (the narrator) substituted the word" fighting" (qital) for" killing" (qatl), and further said:" No one is to pick up the dropped thing except one who makes a public announcement of it."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3141]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3141

Abu Shuraih al-'Adawi reported that he said to Amr b. Sa'id when he was sending troops to Mecca: Let me tell you something. O Commander, which Allah's Messenger (may peace be upon him) said on the day following, the Conquest which my ears heard and my heart has retained, and my eyes saw as he spoke it. He praised Allah and extolled Him and then said: Allah, not men, has made Mecca sacred; so it is not permissible for any person believing in Allah and the Last Day to shed blood in it, or lop a tree in it. If anyone seeks a concession on the basis of fighting of Allah's Messenger (may peace be upon him), tell him that Allah permitted His Messenger, but not you, and He gave him permission only for an hour on one day, and its sacredness was restored on the very day like that of yesterday. Let him who is present convey the information to him who is absent. It was said to Abu Shuraih: What did Amr say to you? He said: I am better informed of that than you, Abu Shuraih, but the sacred territory does not grant protection to one who is disobedient, or one who runs away after shedding blood, or one who runs away after committing


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3142]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3142

Abu Huraira, (Allah be pleased with him) reported. When Allah, the Exalted and Majestic, granted Allah's Messenger (may peace be upon him) victory over Mecca, he stood before people and praised and extolled Allah and then said: Verily Allah held back the elephants from Mecca and gave the domination of it to His Messenger and believers, and it (this territory) was not violable to anyone before me and it was made violable to me for an hour of a day, and it shall not be violable to anyone after me. So neither molest the game, nor weed out thorns from it. And it is not lawful for anyone to pick up a thing dropped but one who makes public announcement of it. And it a relative of anyone is killed he is entitled to opt for one of two things. Either he should be paid blood-money or he can take life as (a just retribution). 'Abbas (Allah be pleased with him) said: Allah's Messenger, but Idhkhir (a kind of herbage), for we use it for our graves and for our houses, whereupon Allah's Messenger (may peace be upon him) said: With the exception of Idhkhir. A person known as Abu Shah, one of the people of Yemen, stood up and said: Messenger of Allah, (kindly) write it for me. Thereupon Allah's Messenger (may peace be upon him) said I Write it for Abu Shah. Walid said: I asked al-Auzai': What did his saying mean:" Write it for me, Messenger of Allah"? He said: This very address that he had heard from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3143]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3143

Abu Huraira (Allah be pleased with him) reported: The people of the Khuza'ah tribe killed a man of the tribe of Laith in the Year of Victory as a retaliation for one whom they had killed (whom the people of the tribe of Laith had killed). It was reported to Allah's Messenger (may peace be upon him). He mounted his camel and delivered this address: Verily Allah, the Exalted and Majestic, held back the Ele- phants from Mecca, and gave its domination to His Messenger and believers. Behold, it was not violable for anyone before me and it will not be violable for anyone after me. Behold, it was made violable for me for an hour of a day; and at this very hour it has again been made inviolable (for me as well as for others). So its thorns are not to be cut, its trees are not to be lopped, and (no one is allowed to) pick up a thing dropped, but the one who makes an announcement of it. And one whose fellow is killed is allowed to opt between two alternatives: either he should receive blood-money or get the life of the (murderer) in return. He (the narrator said): A person from the Yemen, who was called Abu Shah, came to him and said: Messenger of Allah, write it down for me, whereupon he (Allah's Messenger) said: Write it down for Abu Shah. One of the persons from among the Quraish also said: Except Idhkhir, for we use it in our houses ant our graves. Thereupon Allah's Messenger (may peace be upon him) said: Except Idhkhir.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3144]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3144

Jabir (Allah be pleased with him) reported: I heard Allah's Apostle (may peace be upon him) say: It is not permissible for any one of you to carry weapons in Mecca.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3145]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3145

Anas b. Malik (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) entered Mecca in the Year of Victory with a helmet on his head; and when he took it off, a man came to him and said: Ibn Khatal is hanging on to the curtains of the Ka'ba, whereupon he said: Kill him. Malik (one of the narrators) attested this statement having been made.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3146]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3146

Jabir b. 'Abdullah al-Ansari (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) entered Mecca and Qutaiba (another narrator) stated that he entered Mecca in the Year of Victory, wearing a black turban, but not wearing the Ihram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3147]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3147

Jabir b. Abdullah reported that Allah's Apostle (may peace be upon him) entered on the day of Victory of Mecca wearing a black turban on his head. and she said: In case Allah cures me I will certainly go and observe prayer in Bait al-Maqdis. She recovered and so she made preparations to go out (to that place). She came to Maimuna. the wife of Allah's Apostle (may peace be upon him). and after greeting her she informed her about it, whereupon she said: Stay here. and eat the provision (which you had made) and observe prayer In the mosque of the Messenger (may peace be upon him). for I heard Allah's Messenger (may peace be upon him) say: Prayer in it is better than a thousand prayers observed in other mosques except the mosque of the Ka'ba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3148]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3148

Amr b. Huraith reported on the authority of his father that Allah's Messenger (may peace be upon him) addressed the people (on the day of the Victory of Mecca) with a black turban on his head.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3149]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3149

Ja'far b. 'Amr b. Huraith reported his father as saying: As if I am seeing Allah's Messenger (may peace be upon him) on the pulpit with a black turban on his head, and its two ends hanging between his shoulders. Abu Bakr (another narrator) did not make mention of:" Upon the pulpit".


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3150]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3150

'Abdullah b. Zaid b. 'Asim (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Verily Ibrahim declared Mecca sacred and supplicated (for blessings to be showered) upon its inhabitants, and I declare Medina to be sacred as lbrahim had declared Mecca to be sacred. I have supplicated (Allah for His blessings to be showered) in its sa' and its mudd (two standards of weight and measurement) twice as did Ibrahim for the inhabitants of Mecca. This hadith has been narrated through another chain of transmitters with a slight varia- tion of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3151]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3151

Rafi' b. Khadij reported Allah's Messenger (may peace be upon him) as saying: Ibrahim declared Mecca as sacred and I declare sacred the area between its two stony grounds (lava lands by which he meant Medina).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3152]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3152

Nafi' b. Jubair reported that Marwan b. al-Hakam (Allah be pleased with him) addressed people and made mention of Mecca and its inhabitants and its sacredness, but he made no mention of Medina, its inhabitants and its sacredness. Rafi' b. Khadij called to him and said: What is this that I hear you making mention of Mecca and its inhabitants and its sacredness, but you did not make mention of Medina and its inhabitants and its sacredness, while the Apostle of Allah (may peace be upon him) has also declared sacred (the area) between its two lava lands (Medina)? And (we have record of this) with us written on Khaulani parchment. If you like, I can read it out to you. Thereupon Marwan became silent, and then Said: I too have heard some part of it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3153]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3153

Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Ibrahim declared Mecca as sacred; I declare Medina, that between the two mountains, as inviolable. No tree should be lopped and no game is to be molested.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3154]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3154

Amir b. Sa'd reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said: I have declared sacred the territory between the two lava plains of Medina, so its trees should not be cut down, or its game killed; and he also said: Medina is best for them if they knew. No one leaves it through dislike of it without Allah putting in it someone better than he in place of him; and no one will stay there in spite of its hardships and distress without my being an intercessor or witness on behalf of him on the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3155]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3155

'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said, and then the (above-mentioned) hadith was narrated with this addition:" None should nurse ill-will towards the people of Medina, or Allah will melt him in fire like the melting of lead or the dissolution of salt in water.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3156]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3156

'Amir b. Sa'd reported that Sa'd rode to his castle in al-'Aqiq and found a slave cutting down the trees, or beating off their leaves, so he stripped him off his belongings. When Sa'd returned, there came to him the masters of the slave and negotiated with him asking him to return to their slave or to them what he had taken from their slave, whereupon he said: God forbid that I should return anything which Allah's Messenger (may peace be upon him) has given me as spoil, and refused to return anything to them.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3157]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3157

Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said to Abu Talha (Allah be pleased with him): Find for me a servant from amongst your boys to serve me. Abu Talha went out along with me and made me sit behind him. And I used to serve Allah's Messenger (may peace be upon him) whenever he got down from the camel. And in one hadith he said: He proceeded and when (the mountain of) Uhud was within sight, he said: This is the mountain which loves us and we love it. And as he came close to Medina he said: O Allah, I declare (the area) between the two mountains of it (Medina) sacred just as Ibrahim declared Mecca as sacred. O Allah, bless them (the people of Medina) in their mudd and sa'.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3158]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3158

Anas b. Malik reported a hadith like this from Allah's Apostle (may peace be upon him) except with this variation that he said:" I declare sacred the area between its two lava mountains."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3159]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3159

'Asim reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) had declared Medina as sacred. He said: Yes. (the area) between so and so. He who made any innovation in it, and further said to me: It is something serious to make any innovation in it (and he who does it) there is upon him the curse of Allah, and that of the angels and of all the people, Allah will not accept from him on the Day of Resurrection either obligatory acts or the surpererogatory acts. Ibn Anas said: Or he accommodates an innovator.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3160]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3160

'Asim reported: I asked Anas (Allah be pleased with him) whether Allah's Messenger (may peace be upon him) had declared Medina as sacred. He said: Yes, it is sacred, so its tree is not to be cut; and he who did that let the curse of Allah and that of the angels and of all people be upon him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3161]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3161

Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: Allah bless them in their measurements, bless them in their sa's and bless them in their mudd.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3162]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3162

Anas b. Malik (Allah he pleased with him) reported that Allah's Messenger (may peace be upon him) said: O Allah, increase in Medina twice the blessings (Thou showered) on Mecca.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3163]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3163

Ibrahim al-Taimi reported on the authority of his father: 'Ali b. Abi Talib (Allah be pleased with him) addressed us and said: He who thought that we have besides the Holy Qur'an anything else that we recite, he told a lie. And this document which is hanging by the sheath of the sword contains but the ages of the camels, and the nature of the wounds. He (Hadrat 'Ali) reported Allah's Apostle (may peace be upon him) as saying: Medina is sacred from 'Air to Thaur; So if anyone makes an innovation or accommodates an innovator, the curse of Allah, the angels, and all persons will fall upon him, and Allah will not accept any obligatory or supererogatory act as recompense from them. And the protection granted by the Muslims is one and must be respected by the humblest of them. If anyone makes a false claim to paternity, or being a client of other than his own masters, there is upon him the curse of Allah, the angels, and all the people. Allah will not accept from him any recompense in the form of obligatory acts or supererogatory acts. The hadith transmitted on the authority of Abu Bakr and Zabair ends with (these words): The humblest among them should respect it; and what follows after it is not mentioned there, and in the hadith transmitted by them (these words are) not found: (The document was hanging) on the sheath of his sword.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3164]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3164

A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters (but at the end) these words are added:" He who violated the covenant with a Muslim, there is upon him the curse of Allah, of angels and of all people. Neither an obligatory act nor a supererogatory act would be accepted from him as recompense on the Day of Resurrection; and in the hadith transmitted by two other narrators these words are not found:" He who claimed false paternity." And in the hadith transmitted by Waki' there is no mention of the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3165]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3165

A hadith like this has been narrated with the same chain of transmitters by A'mash with a slight variation of words.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3166]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3166

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Medina is a sacred territory, so he who made any innovation in it. or gave protection to an innovator, there is upon him the curse of Allah, that of the angels and that of all the people. There would not be accepted on the Day of Resurrection either obligatory acts or supererogatory acts from him.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3167]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3167

A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters, but no mention has been made of the Day of Resurrection. But this addition is made:" The protection granted by Muslims is one and must be respected by the humblest of them. And he who broke the covenant made by a Muslim, there is a curse of Allah, of his angels, and of the whole people upon him, and neither an obligatory act nor a supererogatory act would be accepted from him as recompense on the Day of Resurrection."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3168]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3168

Abu Huraira (Allah be pleased with him) reported: If I were to see deer grazing in Medina, I would have never molested them, for Allah's Messenger (may peace be upon him) has stated: There is between the two lava mountains a sacred territory.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3169]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3169

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) declared sacred the territory between two lava mountains of Medina. Abu Huraira said: If I were to find deer in the territory between the two mountains, I would not molest them, and he (the Holy Prophet) declared twelve miles of suburb around Medina as a prohibited pasture.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3170]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3170

Abu Huraira (Allah be pleased with him) reported that when the people saw the first fruit (of the season or of plantation) they brought it to Allah's Apostle (may peace be upon him). When he received it he said: O Allah, bless us in our fruits; and bless us in our city; and bless us in our sa's and bless us in our mudd. O Allah, Ibrahim was Thy servant, Thy friend, and Thy apostle; and I am Thy servant and Thy apostle. He (Ibrahim) made supplication to Thee for (the showering of blessings upon) Mecca, and I am making supplication to Thee for Medina just as he made supplication to Thee for Mecca, and the like of it in addition. He would then call to him the youngest child and give him these fruits.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3171]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3171

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) was given the first fruit and he said: O Allah, shower blessings upon us in our city, and in our fruits, in our mudd and in our sa's, blessings upon blessings, and he would then give that to the youngest of the children present there.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3172]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3172

Abu Sa'id Maula al-Mahri reported that they were hard pressed by the distress and hardship of Medina, and he come to AbU Sa'Id al-Khudri and said to him: I have a large family (to support) and we are enduring hardships; I have, therefore, made up my mind to take my family to some fertile land. Thereupon Abu Sa'id said: Don't do that, stick to Medina, for we have come out with Allah's Apostle (may peace be upon him), and (I think that he also said) until we reached 'Usfan, and he (the Holy Prophet along with his Companions) stayed there for some nights. There the people said: By Allah, we are lying here idle, whereas our children are unprotected behind us, and we do not feel secure about them. This (apprehension of theirs) reached Allah's Apostle (may peace be upon him), whereupon he said: What is this matter concerning you that has reached me? (I do not retain how he said it, whether he said like this: ) By Him (in the name of Whom) I take oath, (or he said like this: ) By Him in Whose Hand is my life, I made up my mind or if you like (I do not retain what word did he actually say), I should command my camel to proceed and not to let it halt until it comes to Medina and then said: Ibrahim declared Mecca as the sacred territory and it became sacred, and I declare Medina as the sacred territory-the area between the two mountains ('Air and Uhud). Thus no blood is to be shed within its (bounds) and no weapon is to be carried for fighting, and the leaves of the trees there should not be beaten off except for fodder. O Allah, bless us in our city; O Allab, bless us in our sil; O Allah, bless us in our mudd; O Allah, bless us in our sa; O Allah, bless us in our mudd. O Allah, bless us in our city. O Allah, bless with this blessing two more blessings. By Him in Whose Hand is my life, there is no ravine or mountain path of Medina which is not protected by two angels until you reach there. (He then said to the people: ) Proceed, and we, therefore, proceeded and we came to Medina By Him (in Whose name) we take oath and (in Whose name) oath is taken (Hammad is in doubt about it), we had hardly put down our camel saddles on arriving at Medina that we were attacked by the people of the tribe of 'Abdullah b. Ghatafan but none dared to do it before.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3173]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3173

Abu Sa'id al-Kbudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: O Allah, bless us in our sa' and mud and shower with its blessings two other blessings (multiply blessings showerted upon it).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3174]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3174

A hadith like this has been narrated by Yabya b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3175]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3175

Abu Sa'id Maula al-Mahri reported that he came to Abu Sa'id al-Khudri during the nights (of the turmoil) of al-Barrah, and sought his advice about leaving Medina, and complained of the high prices prevailing therein and his large family, and informed him that he could not stand the hardships of Medina and its rugged surrounding. He said to him: Woe to you; I will not advise you to do it, for I heard Allah's Messenger (may peace be upon him) as saying: No one will endure hardships of Medina without my being an intercessor or a witness on his behalf on the Day of Resurrectiar), if he is a Muslim.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3176]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3176

Abd al-Rahman reported on the authority of his father Abu Sa'id (Allah be pleased with him) that he heard Allah's Messenger (may peace be upon him) as saying: I have declared sacred what is between the two lava grounds of Medina just as Ibrahim (peace be upon him) declared Mecca as sacred. He (the narrator) then said: Abu Sa'id caught hold of (Abu Bakr, another narrator, used the word" found" ) a bird in his hand and then released it from his hand and set it free.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3177]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3177

Sahl b. Hunif reported that Allah's Messenger (may peace be upon him) pointed with his hands towards Medina and said: That is a sacred territory and a place of safety.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3178]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3178

'A'isha (Allah be pleased with her) reported: When we came to Medina, and it was an unhealthy, uncogenial place, Abu Bakr fell sick and Bilal also fell sick; and when Allah's Messenger (may peace be upon him) saw the illness of his Companions he said: O Allah, make Medina as congenial to us as you made Mecca congenial or more than that; make it conducive to health, and bleesus in its sa' and in its mudd, and transfer its fever to al-juhfa.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3179]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3179

This hadith has been narrated by Hisham b. 'Urwa with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3180]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3180

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who patiently endures the hardships of it (of this city of Medina), I would be an intercessor or a withness on his behalf on the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3181]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3181

Yuhannis, the freed slave of Zubair, narrated that when he was sitting with Abdullah b. 'Umar (Allah be pleased with him) during the days of turmoil, his freed slave-girl came to him. After saluting him she said: Abu Abd al-Rahmin, I have decided to leave (Medina) for the time is hard for us, whereupon Abdullah said to her: Stay here, foolish lady, for I have heard Allah's Messenger (may peace be upon him) as saying: For one who shows endurance on the hardships and rigour of it (of Medina) I would be an intercessor or a witness on his behalf on the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3182]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3182

Abdullah b. 'Umar (Allah be pleased with them) said: I heard Allah's Messenger (may peace be upon him) as saying: He who patiently endured the hardships and rigours of (this city, i. e. Medina), I would be his witness and intercessor on the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3183]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3183

Abu Huraira (Allah be pleased with him) reported the Apostle of Allah (may peace be upon him) as saying: For one among my Ummah who shows endurance against the hardships and rigours of Medina, I would be an intercessor or a witness on his behalf on the Day of Resurrection.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3184]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3184

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3185]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3185

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: None who shows endurance on the hardships of Medina,... (the rest of the hadith is the same).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3186]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3186

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: There are at the approaches of Medina angels so that plague and the Dajjal shall not penetrate into it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3187]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3187

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Dajjal will come from the eastern side with the intention of attacking Medina until he will get down behind Uhud. Then the angels will turn his face towards Syria and there he will perish.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3188]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3188

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A time will come for the people (of Medina) when a man will invite his cousin and any other near relation: Come (and settle) at (a place) where living is cheap, come to where there is plenty, but Medina will be better for them; would they know it! By Him in Whose Hand is my life, none amongst them would go out (of the city) with a dislike for it, but Allah would make his successor in it someone better than be. Behold. Medina is like furnace which eliminates from it the impurities. And the Last Hour will not come until Medina banishes its evils just as a furnace eliminates the impurities of iron.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3189]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3189

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: I have been commanded (to migrate) to a town (Medina) which would overpower other towns. They (the people) call it Yathrib; its correct name is (in fact) Medina. It eliminates (bad) people just as a furnace removes the alloy of iron.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3190]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3190

This hadith has been narrated by Yabya b. Sa'id with the same chain of transmitters (and the words are):" Just as a furance removes impurity," but no mention is made of iron.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3191]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3191

Jabir b. Abdullah (Allah be pleased with them) reported that a desert Arab swore allegiance to Allah's Messenger (may peace be upon him). He suffered frozn a severe fever in Medina (and) so he came to Allah's Messenger (may peace be upon him) saying: Mubammad. cancel my oath of allegiance, but Allah's Messenger (may peace be upon him) refused it. He again came and caid: Cancel my oath of allegiance. but he (the Holy Prophet) refused it. He again came to him and said: Cancel my oath of allegiance, but he refused. The desert Arab, however, went away (cancelling the allegiance himself) ; thereupon Allah's Messenger (may peace be upon him) said: Medina is like a furnace which drives away its impurity and purifies what is good.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3192]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3192

Zaid b. Thabit reported Allah's Apostle (may peace be upon him) as saying: It is Taiba, thereby meaning Medina. It drives away impurity just as fire removes the impurity of silver.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3193]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3193

Jabir b. Samura (Allah be pleased with him) reported that he heard Allah's Messenger (may peace be upon him) say: Allah named Medina as Tabba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3194]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3194

Abu Huraira (Allah be pleased with him) reported that Abu'I-Qasim (Mubammad, may peace be upon him) said: He who intends to do harm to the people of this city (that is, Medina). Allah would efface him as salt is dissolved in water.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3195]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3195

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who intends to do harm to its people (he meant Medina), Allah would efface him as salt is dissolved in water. Ibn Hatim (one of the narrators) substituted the word" harm" for" mischief".


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3196]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3196

This hadith is narrated on the authority of Abu Huraira by another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3197]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3197

Sa'd b. Abu Waqqas reported Allah's Messenger (may peace be upon him) as saying: He who intends to do harm to the people of Medina, Allah would efface him just as water dissolves salt.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3198]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3198

Sa'd b. Malik heard Allah's Messenger (may peace be upon him) saying like this except (this variation) that he said:" Sudden attack or harm."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3199]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3199

Abu Huraira and Sa'd reported Allah's Messenger (way peace be upon him) as saying: O Allah, bless the people of Medina in their mudd, the rest of the hadith being the same, and in It (this is also mentioned):" He wo intends to do harm to its people, Allah would efface him just as salt it dissolved in water."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3200]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3200

Sufyan b. Abd Zuhair reported Allah's Messenger (may peace be upon him) as saying: Syria will be conquered and some people will go out of Medina along with their families driving their camels. and Medina is better for them if they were to know it. Then Yemen will be conquered and some people will go out of Medina along with their families driving their camels, and Medina is better for them if they were to know it. Then Iraq will be conquered and some people will go out of it along with their families driving their camels, and Medina is better for them if they were to know it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3201]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3201

Sufyan b. Abu Zuhair heard Allah's Messenger (may peace be upon him) say: Yemen will be conquered and some people will go away (to that country) driving their camels and carrying their families on them and those who are under their authority, while Medina is better for them if they were to know it. Then Syria will be conquered and some people will go away driving their camels along with them and carrying their families with them and those who are under their authority, while Medina is better for theni if they were to know it. Thtn lraq will be conquered and some people will go away (to that country) driving their camels and carrying their families with them and those who are under their authority. while Medina is better for them if they were to know it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3202]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3202

Salid b. Musayyib heard Abu Huraira (Allah be pleased with him) say that 'Allah's Messenger (may peace be upon him) said about Medina: Its inhabitants will abandon it, whereas it is good for them and it will become the haunt of beasts and birds. (Imam Muslim said that Abu Safwan, one of the narrators whose name was 'Abdullah b. 'Abd al-Malik, was an orphan and I bn juraij took him under his care for ten years.)


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3203]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3203

Abu Huraira (Allah be pleased with him) heard Allah's Messenger (may peace be upon him) say: They (the residents of) Medina will abandon Medina whereas it is good for them and it will be haunted by beasts and birds, and two shepherds will come out from Muzainah intending (to go) towards Medina and tending their herd, and will find nothing but wilderness there until when they will reach the mountain path of Wada, they will fall down on their faces.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3204]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3204

AbduUah b. Zaid al-Mazini (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: That which is between my house" and my pulpit is a garden from the gardens of Paradise.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3205]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3205

Abdullah b. Zaid al-Ansari heard Allah's Messenger (may peace be upon him) as saying: That which exists between my pulpit and my house is a garden from the gardens of Paradise.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3206]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3206

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: That which exists between my house and my pulpit is a garden from the gardens of Paradise, and my pulpit is upon my cistern.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3207]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3207

Abu Humaid (Allah be pleased with him) reported: We went out along with Allah's Messenger (may peace be upon him) in the expedition of Tabuk, and Humaid further related: We proceeded until we reached the valley of Qura; and Allah's Messenger (may peace be upon him) said: I am going forth, so he who among you wants to move fast with me may do so; and he who likes to go slowly may do so. We proceeded until Medina wag within our sight. and he said: This is Tibba (another name of Medina) ; this is Ubud, the mountain which loves us and we love it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3208]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3208

Anas b. Malik (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: Ohud is a mountain which loves us and which we love. This hadith is narrated by Anas b. Malik (Allah be pleased with him) with another chain of transmitters (and the words are):" AIlah's Messenger (may peace be upon him) cast a glance at Ubud and said: Ubud is a mountain which loves us and we love it."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3209]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3209

Abu Huraira (Allah be pleased with him) narrated It directly from Allah's Apostle' (may peace be upon him) having said this: A prayer in my mosque is a thousand times more excellent than a prayer in any other mosque, except Masjid al-Haram (Mosque of the Ka'ba).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3210]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3210

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Prayer in my mosque is more excellent than a thousand prayers observed in other mosques except the Masjid al- Haram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3211]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3211

Abu Huraira (Allah be pleased with him) reported: Prayer in the mosque of Allah's Messenger (may peace be upon him) is more excellent than a thousand prayers in other mosques except the Masjid al-Haram, for Allah's Messenger (may peace be upon him) is the last of the Apostles, and his mosque is the last of the mosques. Abu Salama and Abu Abdullah (two of the narrators in this chain of narrations said: We had no doubt that what Abu Haraira (Allah be pleased with him) had said was from Allah's Messenger (may peace be upon him), and so we did not like to get an attestation from Abu Huraira about this hadith until Abu Huraira (Allah be pleased with him) died. We discussed it (the issue of getting attestation from Abu Huraira) amongst ourselves and blamed one another as to why we did not talk about it to Abu Huraira regarding it so that he could attribute its transmission to Allah's Messenger (may peace be upon him) in case he had heard It from him. While we were discussing it as we sat with 'Abdullah b. Ibrahlm b. Qariz; we made a mention of this hadith, and our omission (in getting its attestation) about its direct transmission by Abu Huraira from him (the Holy Proohet) ; thereupon Abdullah b. Ibrahim said to us: I bear witness to the fact that I heard Abu Huraira (Allah be pleased with him) say that Allah's Messenger (may peace be upon him) said: I am the last of the Apostles and my mosque is the last of the mosques.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3212]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3212

Yahya b. Sa'id (Allah be pleased with him) reported: I said to Abu Salih: Did you hear Abu Huraira (Allah be pleased with him) making a mention of the excellence of prayer in the mosque of Allah's Messenger (may peace be upon him)? He said: No (I did not hear directly from Abu Huraira), but I heard Abdullah b. Ibrahlm b. Qariz; say that' he had heard from Abu Huraira (Allah be pleased with him) that Allah's Messenger (may peace be upon him) had said: Prayer in this mosque of mine is better than a thousand prayers. or. is like one thousand prayers observed in other mosques besides It, except that it be in al-Masjid al-Haram. This hadith has been narrated by Yabya b. Sa'id with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3213]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3213

Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Prayer in this mosque of mine is better than a thousand prayers (observed in other mosque.) besides it, except that of Masjid al-Haram.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3214]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3214

A hadith like this has been narrated on the authority of Ubaidullah with the same chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3215]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3215

Ibn 'Umar reported: I heard Allah's Messenger (may peace be upon him) saying like this.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3216]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3216

Ibn Umar narrated from Allah's Apostle (may peace be upon him) a hadlth like this.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3217]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3217

Ibn Abbas (Allah be pleased with them) reported that a woman fell ill and she said: In case Allah cures me I will certainly go and observe prayer in Bait al-Maqdis. She recovered and so she made preparations to go out (to that place). She came to Maimuna. the wife of Allah's Apostle (may peace be upon him). and after greeting her she informed her about it, whereupon she said: Stay here. and eat the provision (which you had made) and observe prayer In the mosque of the Messenger (may peace be upon him). for I heard Allah's Messenger (may peace be upon him) say: Prayer In it is better than a thousand prayers observed in other mosques except the mosque of the Ka'ba.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3218]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3218

Abu Huraira (Allah be pleased with him) reported it directly from Allah's Apostle (may peace be upon him) that he said: Do not undertake journey but to three mosques: this mosque of mine, the Mosque of al-Haram and the Mosque of Aqsa (Bait al-Maqdis).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3219]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3219

This hadith has been narrated on the authority of Zuhri (but with this change of words) that he (Allah's Apostle) said:" Undertake journey to three mosques."


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3220]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3220

Abu Haraira (Allah be pleased with him) reported Allah's Messenger (way peace be upon him) as saying: One should undertake journey to three mosques: the mosque of the Ka'ba, my mosque, and the mosque of Elia (Bait al-Maqdis).


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3221]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3221

Abu Salama b. Abd al-Rabman reported: 'Abd al-Rabman b. Abu Sa'id al-Khudri (Allah be pleased with him) happened to pass by me and I said to him. How did you hear your father making mention of the mosque founded on Piety? He said: My father said: I went to Allah's Messenger (may peace be upon him) as he was in the house of one of his wives, and said: Messenger of Allah, which of the two mosques is founded on piety? Thereupon he took a handful of pebbles and threw them on the ground and then said: This is the very mosque of yours (mosque at Medina). He (the narrator) said: I bear witness that I heard your father making mention of it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3222]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3222

Abu Sa'id reported from Allah's Apostle (may peace be upon him) a hadlth like this, but in the chain of transmitters no mention was made of Abd al- Rahman b. Abu Sa'id.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3223]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3223

Ibn Umar reported that Allah's Messenger (may peace be upon him) visited (the mosque) at Quba' riding and on foot.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3224]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3224

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) came to the mosque at Quba' riding and on foot, and he observed two rak'ahs of (Nafl prayer) in it.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3225]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3225

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) came to Quba' riding as well as on foot.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3226]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3226

This hadith has been reported on the authority of Ibn Umar (Allah be pleased with them) with another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3227]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3227

Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) used to come to Quba' riding and on foot


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3228]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3228

Ibn 'Umar had narrated this hadith through another chain of transmitters.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3229]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3229

Ibn Umar used to come to Quba' on every Saturday and he said: I saw Allah's Apostle (may peace be upon him) coming (to this place) on every Saturday.


Muslim :: The Book of Pilgrimage (Kitab Al-Hajj) :: [7.3230]

The Book of Pilgrimage (Kitab Al-Hajj)

Muslim :: Book 7 : Hadith 3230

'Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) used to come to Quba', i. e. (he came) on every Saturday, and he used to come riding or on foot. Ibn Dinar (another narrator) said that Ibn Umar used to do like this. This hadlth has been narrated on the authority of Ibn Dinar, but he made no mention of:" Every Saturday."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3231]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3231

'Alqama reported: While I was walking with 'Abdullah at Mina, 'Uthman happened to meet him. He stopped there and began to talk with him. Uthman said to him: Abu 'Abd al-Rahman, should we not marry you to a young girl who may recall to you some of the past of your bygone days; thereupon he said: If you say so, Allah's Messenger (may peace be upon him) said: 0 young men, those among you who can support a wife should marry, for it restrains eyes from casting (evil glances). and preserves one from immorality; but those who cannot should devote themselves to fasting for it is a means of controlling sexual desire.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3232]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3232

'Alqama reported: While I was going along with 'Abdullah b. Ma'sud (Allah he pleased with him) in Mina, 'Uthman b. 'Affan (Allah be pleased with him) happened to meet him and said: Come here, Abu 'Abd al-Rahman (kunya of Abdullah b. Mas'ud), and he isolated him (from me), and when 'Abdullah (b. Mas'ud) saw that there was no need (for this privacy), he said to me: 'Alqama, come on, and so I went there. (Then) 'Uthman said to him: Abu Abd al-Rahman, should we not marry you to a virgin girl that your past may be recalled to your mind? 'Abdullah said: If you say so, the rest of the hadith is the same as narrated above.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3233]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3233

Abdullah (b. Mas'ud) (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said to us: 0 young men, those among you who can support a wife should marry, for it restrains eyes (from casting evil glances) and preserves one from immorality; but he who cannot afford It should observe fast for it is a means of controlling the sexual desire.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3234]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3234

Abu al-Rahman b. Yazid said: I and my uncle 'Alqama and al-Aswad went to 'Abdullah b. Mas'ud (Allah be pleased with him). He (the narrator further) said: I was at that time young, and he narrated a hadith which it seemed he narrated for me that Allah's Messenger (may peace be upon him) said like one transmitted by Mu'awiya, and further added: I lost no time in marrying.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3235]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3235

'Abd al-Rahman b. Yazid reported on the authority of Abdullah: We went to him, and I was the youngest of all (of us), but he did not mention:" I lost no time in marrying."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3236]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3236

Anas (Allah be pleased with him) reported that some of the Companions of Allah's Apostle (may peace be upon him) asked his (the Prophet's) wives about the acts that he performed in private. Someone among them (among his Companions) said: I will not marry women; someone among them said: I will not eat meat; and someone among them said: I will not lie down in bed. He (the Holy Prophet) praised Allah and glorified Him, and said: What has happened to these people that they say so and so, whereas I observe prayer and sleep too; I observe fast and suspend observing them; I marry women also? And he who turns away from my Sunnah, he has no relation with Me


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3237]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3237

Sa'd b. Abi Waqqas (Allah be pleased with him) reported: The Messengger of Allah (may peace be upon him) rejected (the idea) of Uthman b. Muz'unliving in celibacy (saying): And if he (the Holy Prophet) had given me permission We would have got ourselves castrated.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3238]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3238

Sa'id b. al-Musayyib reported: I heard Sa'd (b. Abi Waqqas) saying that the idea of 'Uthman b. Maz'un for living in celibacy was rejected (by the Holy Prophet), and if he had been given permission they would have got themselves castrated.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3239]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3239

Sa'id b. al Musayyib heard Sa'd b. Abi Waqqas (Allah be pleased with him) saying that Uthman b. Maz'un decided to live in celibacy, but Allah's Messenger (may peace be upon him) forbade him to do so, and if he had permitted him, we would have got ourselves castrated.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3240]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3240

Jabir reported that Allah's Messenger (may peace be upon him) saw a woman, and so he came to his wife, Zainab, as she was tanning a leather and had sexual intercourse with her. He then went to his Companions and told them: The woman advances and retires in the shape of a devil, so when one of you sees a woman, he should come to his wife, for that will repel what he feels in his heart.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3241]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3241

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) saw a woman; and the rest of the hadith was narrated but (with this exception) that he said he came to his wife Zainab, who was tanning a (piece of) leather, and he made no mention of:" She retires in the shape of satan."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3242]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3242

Jabir heard Allah's Apostle (may peace be upon him) say: When a woman fascinates any one of you and she captivates his heart, he should go to his wife and have an intercourse with her, for it would repel what he feels.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3243]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3243

Abdullah (b. Mas'ud) reported: We were on an expedition with Allah's Messenger (may peace be upon him) and we had no women with us. We said: Should we not have ourselves castrated? He (the Holy Prophet) forbade us to do so He then granted us permission that we should contract temporary marriage for a stipulated period giving her a garment, and 'Abdullah then recited this verse: 'Those who believe do not make unlawful the good things which Allah has made lawful for you, and do not transgress. Allah does not like trangressers" (al-Qur'an, v. 87).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3244]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3244

This hadith has been narrated on the authority of Jarir with the same chain of transmitters and he also recited this (above-mentioned verse) to us, but he did not say that 'Abdullah recited it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3245]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3245

This hadith has been narrated on the authority of Isma'il with the same chain of transmitters (and the words are):" We were young, so we said: Allah's Messenger, should we not have ourselves castrated? But he (the narrator) did not say; We were on an expedition."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3246]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3246

Jabir b. 'Abdullah and Salama b. al-Akwa' said: There came to us the proclaimer of Allah's Messenger (may peace be upon him) and said: Allah's Messenger (may peace be upon him) has granted you permission to benefit yourselves, i. e. to contract temporary marriage with women.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3247]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3247

Salama b. al. Akwa' and Jabir b. Abdullah reported: Allah's Messenger (may peace be upon him) came to us and permitted us to contract temporary marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3248]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3248

Ibn Uraij reported: 'Ati' reported that jibir b. Abdullah came to perform 'Umra, and we came to his abode, and the people asked him about different things, and then they made a mention of temporary marriage, whereupon he said: Yes, we had been benefiting ourselves by this temporary marriage during the lifetime of theHoly Prophet (may peace be upon him) and during the tinie of Abi! Bakr and 'Umar.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3249]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3249

Jabir b. 'Abdullah reported: We contracted temporary marriage giving a handful of (tales or flour as a dower during the lifetime of Allah's Messenger (may peace be upon him) and durnig the time of Abu Bakr until 'Umar forbade it in the case of 'Amr b. Huraith.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3250]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3250

Abu Nadra reported: While I was in the company of Jabir b. Abdullah, a person came to him and said that Ibn 'Abbas and Ibn Zubair differed on the two types of Mut'as (Tamattu' of Hajj 1846 and Tamattu' with women), whereupon Jabir said: We used to do these two during the lifetime of Allah's Messenger (may peace be upon him). Umar then forbade us to do them, and so we did not revert to them.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3251]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3251

Iyas b. Salama reported on the authority of his father that Allah's Messenger (may peace be upon him) gave sanction for contracting temporary marriage for three nights in the year of Autas 1847 and then forbade it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3252]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3252

Sabra Juhanni reported: Allah's Messenger (may peace be upon him) permitted temporary marriage for us. So I and another person went out and saw a woman of Bana 'Amir, who was like a young long-necked she-camel. We presented ourselves to her (for contracting temporary marriage), whereupon she said: What dower would you give me? I said: My cloak. And my companion also said: My cloak. And the cloak of-my companion was superior to my cloak, but I was younger than he. So when she looked at the cloak of my companion she liked it, and when she cast a glance at me I looked more attractive to her. She then said: Well, you and your cloak are sufficient for me. I remained with her for three nights, and then Allah's Messenger (may peace be upon him) said: He who has any such woman with whom he had contracted temporary marriage, he should let her off.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3253]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3253

Rabi' b. Sabra reported that his father went on an expedition with Allah's Messenger (may peace be upon him) during the Victory of Mecca, and we stayed there for fifteen days (i. e. for thirteen full days and a day and a night), and Allah's Messenger (may peace be upon him) permitted us to contract temporary marriage with women. So I and another person of my tribe went out, and I was more handsome than he, whereas he was almost ugly. Each one of us had a cloaks, My cloak was worn out, whereas the cloak of my cousin was quite new. As we reached the lower or the upper side of Mecca, we came across a young woman like a young smart long-necked she-camel. We said: Is it possible that one of us may contract temporary marriage with you? She said: What will you give me as a dower? Each one of us spread his cloak. She began to cast a glance on both the persons. My companion also looked at her when she was casting a glance at her side and he said: This cloak of his is worn out, whereas my cloak is quite new. She, however, said twice or thrice: There is no harm in (accepting) this cloak (the old one). So I contracted temporary marriage with her, and I did not come out (of this) until Allah's Messenger (may peace be upon him) declared it forbidden.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3254]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3254

Rabi' b. S'abra al-jahanni reported on the authority of his father. We went with Allah's Messenger (may peace be upon him) to Mecca during the year of Victory and he narrated like this a hadith transmitted by Bishr (the previous one) but with this addition:" She said: Can it be possible?" And it is also mentioned in it:" He said: The cloak of this (man) is old and worn out."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3255]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3255

Sabra al-Juhanni reported on the authority of his father that while he was with Allah's Messenger (may peace be upon hm) he said: 0 people, I had permitted you to contract temporary marriage with women, but Allah has forbidden it (now) until the Day of Resurrection. So he who has any (woman with this type of marriage contract) he should let her off, and do not take back anything you have given to then (as dower).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3256]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3256

This hadith has been narrated on the authority of 'Abd al-'Aziz b 'Umar with the same chain of transmitters, and he said: I saw Allah's Messenger (may peace be upon him) standing between the pillar and the gate (of the Ka'ba) and he was relating a hadith as narrated by Ibn Numair.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3257]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3257

'Abd al-Malik b. Rabi' b. Sabraal-Juhanni reported on the authority of his father who narrated it on the authority of his father (i e. 'Abd al-Malik's grandfather, Sabura al-juhanni): Allah's Messenger (may peace be upon him) permitted us to contract temporary marriage in the Year of Victory, as we entered Mecce, and we did come out of it but he forbade us to do it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3258]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3258

Sabra b. Ma'bad reported that Allah's Apostle (may peace be upon him) permitted his Companions to contract temporary marriage with women in the Year of Victory. So I and a friend of mine from Banu Sulaim went out, until we found a young woman of Banu Amir who was like a young she-camel having a long neck. We made proposal to her for contracting temporary marriage with us, and presented to her our cloaks (as dower). She began to look and found me more handsome than my friend, but found the cloak of my friend more beautiful than my cloak. She thought in her wind for a while, but then preferred me to my friend. So I remained with her for three (nights), and then Allah's Messenger (may peace be upon him) commanded us to part with them (such women).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3259]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3259

Rabi' b. Sabra reported on the authority of his father that Allah's Apostle (may peace be upon him) prohibited the contracting of temporary marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3260]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3260

Rabi' b. Sabra reported on the authority of his father that Allah's Messenger (may peace be upon him) forbade on the Day of Victory to contract temporary marriage with women. This hadith has been narrated on the authority of Rabi' b. Sabra that Allah's Messenger (may peace be upon him) forbade to contracf temporary marriage with women at the time of Victory, and that his father had contracted the marriage for two red cloaks.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3261]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3261

'Urwa b. Zabair reported that 'Abdullah b. Zubair (Allah be pleased with him) stood up (and delivered an address) in Mecca saying: Allah has made blind the hearts of some people as He has deprived them of eyesight that they give religious verdict in favour of temporary marriage, while he was alluding to a person (Ibn 'Abbas). Ibn Abbas called him and said: You are an uncouth person, devoid of sense. By my life, Mut'a was practised during the lifetime of the leader of the pious (he meant Allah's Messenger, may peace be upon him), and Ibn Zubair said to him: just do it yourselves, and by Allah, if you do that I will stone you with your stones. Ibn Shihab said. Khalid b. Muhajir b. Saifullah informed me: While I was sitting in the company of a person, a person came to him and he asked for a religious verdict about Mut'a and he permitted him to do it. Ibn Abu 'Amrah al-Ansari (Allah be pleased with him) said to him: Be gentle. It was permitted in- the early days of Islam, (for one) who was driven to it under the stress of necessity just as (the eating of) carrion and the blood and flesh of swine and then Allah intensified (the commands of) His religion and prohibited it (altogether). Ibn Shihab reported: Rabi' b. Sabra told me that his father (Sabra) said: I contracted temporary marriage with a woman of Banu 'Amir for two cloaks during the lifetime of Allah's Messenger (may peace be upon him) ; then he forbade us to do Mut'a. Ibn Shihab said: I heard Rabi' b. Sabra narrating it to Umar b. 'Abd al-'Aziz and I was sitting there.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3262]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3262

Sabra al-Juhanni reported on the authority of his father: Allah's Messenger (may peace be upon him) prohibited the contracting of temporary marriage and said: Behold, it is forbidden from this very day of yours to the Day of Resurrection, and he who has given something (as a dower) should not take it back.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3263]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3263

'Ali b. AbiTalib reported that Allah's Messenger (may peace be upon him) prohibited on the Day of Khaibar the contracting of temporary marriage with women and the eating of the flesh of domestic asses.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3264]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3264

Malik narrated this hadith on the authority of the same chain of trans- witters that 'Ali b. Abil Talib said to a person: You are a person led astray; Allah's Messenger (may peace be upon him) forbade us (to do Mut'a), as is stated In the hadith transmitted on the authority of Yahya b. Malik.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3265]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3265

Muhammad b. 'Ali narrated on the authority of his father 'Ali that Allah's Apostle (may peace be upon him) on the Day of Khaibar prohibited for ever the contracting of temporary marriage and eating of the flesh of the domestic asses.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3266]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3266

'Ali (Allah be pleased with him) heard that Ibn Abbas (Allah be pleased with them) gave some relaxation in connection with the contracting of temporary marriage, whereupon he said: Don't be hasty (in your religious verdict), Ibn 'Abbas, for Allah's Messenger (may peace be upon him) on the Day of Khaibar prohibited for ever the doing of it-And eating of the flesh of domestic asses.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3267]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3267

'Ali (Allah be pleased with him) said to Ibn 'Abbas (Allah be pleased with them) that Allah's Messenger (may peace be upon him) on the Day of Khaibar forbade forever the contracting of temporary marriage and the eating of the flesh of domestic asses.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3268]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3268

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace upon him) having said this: One should not combine a woman and her father's sister, nor a woman and her mother's sister in marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3269]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3269

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade combining of four women in marriage: a woman with her tather's sister, and a woman with her mother's sister.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3270]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3270

Abu Huraira (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) say: Father's sister should not be combined with her brother's daughter, nor the daughter of a sister with her mother's sister.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3271]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3271

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade a person to combine in marriage a womanarid her father's sister, and a woman and her mother's sister. Ibn Shihab said: So we regarded the paternal aunt of her (wife's) father and the maternal aunt of her (wife's) father at the same level.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3272]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3272

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: One should not combine in marriage a woman with her father's sister, or her mother's sister.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3273]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3273

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3274]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3274

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A man must not make proposal of marriage to a woman when his brother has done so already. And he must not offer a price for a thing for which his brother had already offered a price; and a woman must not be combined in marriage with her father's sister, nor with her mother's sister, and a woman must not ask to have her sister divorced in order to deprive her of what belongs to her, but she must marry, because she will have what Allah has decreed for her.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3275]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3275

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the combining of a woman in marriage with her father's sister, or with her mother's sister, or that a woman should ask for divorce for her sister in order to deprive her of what belongs to her. Allah, the Exalted'and Majestic, is her Sustainer too.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3276]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3276

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade to combine a woman and her father's sister, and a woman and her mother's sister.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3277]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3277

A hadith like this has been transmitted on the authority of Amr b. Dinar


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3278]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3278

Nubaih b. Wahb reported that 'Umar b. Ubaidullah intended to marry Talha b. 'Umar with the daughter of Shaiba b. Jubair; so he sent a messenger to Aban b. Uthman to attend the marriage, and he was at that time the Amir of Hajj. Aban said: I heard 'Uthman b. 'Affan say that Allah's Messenger (may peace be upon him) had stated: A Muhrim must neither marry himself, nor arrange the marriage of another one, nor should he make the proposal of marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3279]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3279

Nubaih b. Wahb reported: Umar b. Ubaidullah b. Ma'mar sent me to Aban b. Uthman as he wanted to make the proposal of the marriage of his son with the daughter of Shaiba b. Uthman. He (Aban b. Uthman) was at that time (busy) in the season of Pilgrimage. He said: I deem him to be a man of the desert (for it is a common thing) that a Muhrim can neither marry, nor is he allowed to be married to anyone. It is Uthman (b. Affan) who reported this to us from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3280]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3280

Uthman b. 'Affan reported that Allah's Messenger (may peace be upon him) had said: A Muhrim should neither marry himself, nor should he be got married to anyone, nor should he make the proposal of marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3281]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3281

'Uthman (b. 'Affan) reported it directly from Allah's Apostle (may peace be upon him) that he said: A Muhrim should neithermarry (in that state) nor make the proposal of marriage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3282]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3282

Nabaih b. Wahb reported that Umar b. 'Ubaidullah b. Ma'mar intended to marry his son Talha with the daughter of Shaiba b. Jubair during the Pilgrimage. Aban b. Uthman was at that time the Amir of Pilgrims. So he ('Umar b. Ubaidullah) sent someone (as a messenger) to Aban saying: I intend to marry Talha b. 'Umar and I earnestly desire you to be present there (in this ceremony of marriage). Aban said to him: I find you a block-headed 'Iraqi. I heard 'Uthman b. 'Affan say that Allah's Messenger (may peace be upon him) said: A Muhrim should not marry.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3283]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3283

Ibn Abbas (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) married Maimulna in the state of Ihram. Ibn Numair made this addition:" I narrated it to Zuhri and he said: Yazid b. al-Asamm (Allah be pleased with him) told me that he (the Holy Prophet) married her when he was not a muhrim."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3284]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3284

Ibn 'Abbas (Allah be pleased with them) reported: Allah's Messenger. (may peace be upon him) married Maimuna while he was a Muhrim.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3285]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3285

Yazid b. al-Asamm reported: Maimuna daughter of al-Harith narrated to me that Allah's Messenger (may peace be upon him) married her and he was not in the state of Ihram. And she (Maimuna) was my mother's sister and that of Ibn 'Abbas (Allah be pleased with them).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3286]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3286

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as having said this: None amongst you should outbid another in a transaction, nor should he make proposals of marriage upon the proposal made by someone else.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3287]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3287

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as having said this: A person should not enter into a transaction when his brother (had already entered into but not finalised), and he should not make proposal of marriage upon the proposal already made by his brother, until he permits it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3288]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3288

A hadith like this has been reported on the authority of Nafi' with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3289]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3289

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as having forbidden a dweller of the town selling the merchandise of a villager or outbidding in a sale (in order that another might fall into a snare), or a person making the proposal of marriage when his brother has already made such a proposal, or entering into a transaction when his brother has already entered; and a woman asking the divorce of her sister in order to deprive her of what belongs to her. 'Amr made this addition:" The person should not purchase in opposition to his brother."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3290]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3290

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having said this: Do not outbid in a sale in order to ensnare. No man should enter into a transaction in which his brother has already entered, and no dweller of the town should sell on behalf of the villager. And no man should make a proposal of marriage which his brother has already made and no woman should ask for the divorce of another (co-wife) in order to deprive her of what belongs to her.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3291]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3291

A hadith like this has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight alteration.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3292]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3292

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The Muslim should not purchase in opposition to his brother, and he should not make the proposal of marriage on the proposal already made by his brother.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3293]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3293

This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3294]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3294

'Uqba b. 'Amir said on the pulpit that Allah's Messenger (may peace be upon him) said: A believer is the brother of a believer, so it is not lawful for a believer to outbid his brother, and he should not propose an engagement when his brother has thus proposed until he gives it up.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3295]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3295

Ibn Umar (Allah be pleased with them) said that Allah's Messenger (may peace be upon him) prohibited Shighar which means that a man gives his daughter in marriage on the condition that the other gives his daughter to him in marriage with- out any dower being paid by either.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3296]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3296

A hadith like this has been narrated on the authority of" Abdullah b. 'Umar (Allah be pleased with them) but with a slight variation of words.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3297]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3297

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) prohibited Shighar.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3298]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3298

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as having said: There is no Shighar in islam.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3299]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3299

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) prohibited Shighar. Ibn Numair added: Shighar means that a person should say to the other person: Give me the hand of your daughter in marriage and I will (in return) marry my daughter to you; or merry me your sister, and I will marry my sister to you.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3300]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3300

This hadith has been narrated on the authority of Ibn Vmar with the same chain of transmitters, but there is no mention of Ibn Numair.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3301]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3301

Jabir b. Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) prohibited Shighar.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3302]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3302

'Uqba b. Amir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The most worthy condition which must be fulfilled is that which makes sexual intercourse lawful. In the narration transmitted by Ibn Muthanna (instead of the word" condition" ) it is" conditions".


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3303]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3303

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as having said: A woman without a husband (or divorced or a widow) must not be married until she is consulted, and a virgin must not be married until her permission is sought. They asked the Prophet of Allah (may peace be upon him): How her (virgin's) consent can be solicited? He (the Holy Prophet) said: That she keeps silence.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3304]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3304

This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3305]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3305

'A'isha (Allah be pleased with her) reported: I asked Allah's Messenger (may peace be upon him) about a virgin whose marriage is solemnised by her guardian, whether it was necessary or not to consult her. Allah's Messerger (may peace be upon him) said: Yes, she must be consulted. 'A'isha reported: I told him that she feels shy, whereupon Allah's Messenger (may peace be upon him) said: Her silence implies her consent.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3306]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3306

Ibn 'Abbas (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A woman without a husband has wore right to her person than her guardian, and a virgin's consent must be asked from her, and her silence implies her consent.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3307]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3307

Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A woman who has been previously married (Thayyib) has more right to her person than her guardian. And a virgin should also be consulted, and her silence implies her consent.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3308]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3308

Sufyan reported on the basis of the same chain of transmitters (and the words are): A woman who has been previously married (Thayyib) has more right to her person than her guardian; and a virgin's father must ask her consent from her, her consent being her silence, At times he said: Her silence is her affirmation.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3309]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3309

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) married me when I was six years old, and I was admitted to his house at the age of nine. She further said: We went to Medina and I had an attack of fever for a month, and my hair had come down to the earlobes. Umm Ruman (my mother) came to me and I was at that time on a swing along with my playmates. She called me loudly and I went to her and I did not know what she had wanted of me. She took hold of my hand and took me to the door, and I was saying: Ha, ha (as if I was gasping), until the agitation of my heart was over. She took me to a house, where had gathered the women of the Ansar. They all blessed me and wished me good luck and said: May you have share in good. She (my mother) entrusted me to them. They washed my head and embellished me and nothing frightened me. Allah's Messenger (, may peace be upon him) came there in the morning, and I was entrusted to him.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3310]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3310

'A'isha (Allah be pleased with her) reported: Allah's Apostle (may peace be upon him) married me when I was six years old, and I was admitted to his house when I was nine years old.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3311]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3311

'A'isha (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) married her when she was seven years old, and he was taken to his house as a bride when she was nine, and her dolls were with her; and when he (the Holy Prophet) died she was eighteen years old.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3312]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3312

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) contracted marriage with me in Shawwal and took me to his house as a bride during Shawwal. And who among the wives of Allah's Messenger (may peace be upon him) was dearer to him than I, and' A'isha liked that the women (of her family) should enter the houses as brides during the month of Shawwal.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3313]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3313

This hadith has been narrated on the authority of Sufyan with the same chain of transmitters, but he made no mention of the act of 'A'isha (being admitted as a wife in the house of the Holy Prophet).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3314]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3314

Abu Huraira (Allah be pleased with him) reported: I was in the company of Allah's Messenger (way peace be upan him) when there came a man and informed him that he had contracted to marry a woman of the Ansar. Thereupon Allah's Messenger (may peace be upon him) said: Did you cast a glance at her? He said: No. He said: Go and cast a glance at her, for there is something in the eyes of the Ansar.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3315]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3315

Abu Huraira (Allah be pleased with him) reported: A man came to Allah's Messenger (may peace be upon him) and said: I have contracted marriage with a woman of the Ansar, whereupon Allah's Apostle (may peace be upon him) said: Did you cast a glance at her, for there is something in the eyes of the Ansar? He said: I did cast a glance at her, whereupon he said: For what (dower) did you marry her? He said: For four 'uqiyas. Thereupon Allah's Apostle (may peace be upon him) said: For four 'uqiyas; it seems as if you dig out silver from the side of this mountain (and that is why you are prepared to pay such a large amount of dower). We have nothing which we should give you. There is a possibility that we may send you to an (expedition) where you may get (booty). So he sent that man (in the expedition) which was despatched to Banu 'Abs.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3316]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3316

Sahl b. Sa'd al-Sa'idi (Allah be pleased with him) reported: A woman came to Allah's Messenger. (may peace be upon him) and said: Messerbger of Allah, I have come to you to entrust myself to you (you may contract my marriage with anyone at your discretion). Allah's Messenger (may peace be upon him) saw her and cast a glance at her from head to foot. Allah's Messenger (may peace be upon him) then lowered his head. When the woman saw that he had made no decision in regard to her, she sat down. There stood up a person from amongst his companions and said: Messenger of Allah, marry her to me if you have no need of her. He (the Holy Prophet) said: is there anything with you (which you con give as a dower)? He said: No, Messenger of Allah, by Allah I have nothing. Thereupon Allah's Messenger (may peace be upon him) said: Go to your people (family) and see if you can find something. He returned and said: I have found nothing. The Apostle of Allah (may peace be upon him) said: See even if it is an Iron ring. He went and returned and said: No, by God, not even an iron ring, but only this lower garment of mine (Sahl said that he had no upper garment), half of which (I am prepared to part with) for her. Thereupon Allah's Messenger (may peace be upon him) said: How can your lower garment serve your purpose, for it you wear it, she would not be able to make any use of it and if she wears it there would not be anything on you? The man sat down and as the sitting prolonged he stood up (in disappointment) and as he was going back Allah's Messenger (may peace be upon him) commanded (him) to be called back, and as he came, he said to him: Do you know any part of the Qur'an? He said: I know such and such surahs (and he counted them). whereupon he said: Can you recite them from heart (from your memory)? He said: Yes, whereupon he (Allah's Messenger) said: Go, I have given her to you in marriage for the part of the Qur'an which you know.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3317]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3317

This hadith has been narrated on the authority of Sahl b. Sa'd with a minor alteration of words, but the hadith transmitted through Za'idah (the words are that the Holy Prophet) said: Go, I have married her to you, and you teach her something of the Qur'an.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3318]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3318

Abu Salama b. 'Abd al-Rahman reported: I asked 'A'isha, the wife of Allah's Messenger (may peace be upon him): What is the amount of dower of Allah's Messenger (may peace be upon him)? She said: It was twelve 'uqiyas and one nash. She said: Do you know what is al-nash? I said: No. She said: It is half of uqiya, and it amounts to five hundred dirhams, and that was the dower given by Allah's Messenger (may peace be upon him) to his wives.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3319]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3319

Anas b. Malik reported that Allah's Apostle (may peace be upon him) saw the trace of yellowness on 'Abd al-Rahman b. 'Auf and said: What is this? Thereupon he said: Allah's Messenger, I have married a woman for a date-stone's weight of gold. He said: God bless you! Hold a wedding feast, even if only with a sheep.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3320]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3320

Anas b. Malik (Allah be pleasedwith him) reported that 'Abd al-Rahman b. 'Auf (Allah be pleased with him) married during the lifetime of Allah's Messenger (may peace be upon him) for a nawat weight of gold and the messenger of Allah (may peace be upon him) said to him: Give a feast even with a sheep.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3321]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3321

Anas b. Malik (Allah be pleased with him) reported that 'Abd al-Rahman b. 'Auf (Allah be pleased with him) married a woman for a date-stone's weight of gold and Allah's Apostle (may peace be upon him) said to him: Hold a wedding feast, even if only with a sheep.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3322]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3322

This hadith has been narrated on the authority of Humaid with the same chain of transmitters except (with this minor alteration of words) that 'Abd al-Rahman said:" I married a woman."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3323]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3323

Abd al-Rahman b. 'Auf (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) saw the signs of the happiness of wedding in me, and I said: I have married a woman of the Ansar. He said: How much Mahr have you paid? I said: For a date-stone weight of gold. And in the hadith transmitted by Ishaq (it is): (nawat weight) of gold.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3324]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3324

Anas b. Malik reported that 'Abd al-Rahman married a woman for a datestone weight of gold. Shu'ba has narrattd this hadith with the same chain of transmitters except for (this alteration) that he said that a person from among the sons of 'Abd al Rahman said:" from gold".


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3325]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3325

Anas (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) set out on an expedition to Khaibar and we observed our morning prayer in early hours of the dawn. The Apostle of Allah (may peace be upon him) then mounted and so did Abu Talha ride, and I was seating myself behind Abu Talha. Allah's Apostle (may peace be upon him) moved in the narrow street of Khaibar (and we rode so close to each other in the street) that my knee touched the leg of Allah's Apostle (may peace be upon him). (A part of the) lower garment of Allah's Apostle (may peace be upon him) slipped from his leg and I could see the whiteness of the leg of Allah's Apostle (may peace be upon him). As he entered the habitation he called: Allah-o-Akbar (Allah is the Greatest). Khaibar is ruined. And when we get down in the valley of a people evil is the morning of the warned ones. He repeated it thrice. In the meanwhile the people went out for their work, and said: By Allah, Muhammad (has come). Abd al-'Aziz or some of our com- panions said: Muhammad and the army (have come). He said: We took it (the territory of Khaibar) by force, and there were gathered the prisoners of war. There came Dihya and he said: Messenger of Allah, bestow upon me a girl ont of the prisones. He said: Go and get any girl. He made a choice for Safiyya daughter of Huyayy (b. Akhtab). There came a person to Allah's Apostle (may peace be upon him) and said: Apostle of Allah, you have bestowed Safiyya bint Huyayy, the chief of Quraiza and al-Nadir, upon Dihya and she is worthy of you only. He said: Call him along with her. So he came along with her. When Allah's Apostle (may peace be upon him) saw her he said: Take any other woman from among the prisoners. He (the narrator) said: He (the Holy Prophet) then granted her emancipation and married her. Thabit said to him: Abu Hamza, how much dower did he (the Holy Prophet) give to her? He said: He granted her freedom and then married her. On the way Umm Sulaim embellished her and then sent her to him (the Holy Prophet) at night. Allah's Apostle (may peace be upon him) appeared as a bridegroom in the morning. He (the Holy Prophet) said: He who has anything (to eat) should bring that. Then the cloth was spread. A person came with cheese, another came with dates, and still another came with refined butter, and they prepared hais and that was the wedding feast of Allah's Messenger (may peace be upon him)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3326]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3326

This hadith has been narrated through another chain of transmitters on the authority of Anas that Allah's Apostle (may peace be upon him) emancipated Safiyya, and her emancipation was treated as her wedding gift, and in the hadith transmitted by Mu'adh on the authority of his father (the words are):" He (the Holy Prophet) married Safiyya and bestowed her emancipation as her wedding gift."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3327]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3327

Abu Musa reported that Allah's Messenger (may peace be upon him) said about one who emancipated a slave woman, and then married her, that for him there are two rewards.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3328]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3328

Anas (Allah be pleased with him) reported: I was sitting behind Abu Talha on the Day of Khaibar and my feet touched the foot of Allah's Messenger (may peace be upon him), and we came (to the people of Khaibar) when the sun had risen and they had driven out their cattle, and had themselves come out with their axes, large baskets and hatchets, and they said: (Here come) Muhammad and the army. Allah's Messenger (may peace be upon him) said: Khaibar is ruined. Verily when we get down in the valley of a people, evil is the morning of the warned ones (al-Qur'an, xxxvii. 177). Allah, the Majestic and the Glorious, defeated them (the inhabitants of Khaibar), and there fell to the lot of Dihya a beautiful girl, and Allah's Messenger (may peace be upon him) got her in exchange of seven heads, and then entrusted her to Umm Sulaim so that she might embellish her and prepare her (for marriage) with him. He (the narrator) said: He had been under the impression that he had said that so that she might spend her period of 'Iddah in her (Umm Sulaim's) house. (The woman) was Safiyya daughter of Huyayy. Allah's Messenger (may peace be upon him) arranged the wedding feast consisting of dates, cheese, and refined butter, and pits were dug and tiers were set in them dining cloths, and there was brought cheese and refined butter, and these were placed there. And the people ate to their fill, and they said: We do not know whether he (the Holy Prophet) had married her (as a free woman), or as a slave woman. They said: If he (the Holy Prophet) would make her wear the veil, then she would be a (free married) woman, and if he would not make her wear the veil, then she should be a slave woman. When he intended to ride, he made her wear the veil and she sat on the hind part of the camel; so they came to know that he had married her. As they approached Medina, Allah's Messenger (may peace be upon him) drove (his ride) quickly and so we did. 'Adba' (the name of Allah's Apostle's camel) stumbled and Allah's Messenger (may peace be upon him) fell down and she (Radrat Safiyya: also fell down. He (the Holy Prophet) stood up and covered her. woman looked towards her and said: May Allah keep away the Jewess! He (the narrator) said: I said: Aba Hamza, did Allah's Messenger (may peace be upon him) really fall down? He said: Yes, by Allah, he in fact fell down. Anas said: I also saw the wedding feast of Zainab, and he (the Holy Prophet) served bread and meat to the people, and made them eat to their heart's content, and he (the Holy Prophet) sent me to call people, and as he was free (from the ceremony) he stood up and I followed him. Two persons were left and they were busy in talking and did not get out (of the apartment). He (the Holy Prophet) then proceeded towards (the apartments of) his wives. He greeted with as-Salamu 'alaikum to every one of them and said: Members of the household, how are you? They said: Messenger of Allah, we are in good state 'How do you find your family? He would say: In good state. When he was free from (this work of exchanging greetings) he came back, and I also came back along with him. And as he reached the door, (he found) that the two men were still busy in talking. And when they saw him having returned, they stood up and went out; and by Allah! I do not know whether I had informed him, or there was a revelation to him (to the affect) that they had gone. He (the Holy Prophet) then came back and I also returned along with him, and as he put his step on the threshold of his door he hung a curtain between me and him, and (it was on this occasion) that Allah revealed this verse: (" O you who believe), do not enter the houses of the Prophet unless permission is given to 'you" (xxxiii. 53).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3329]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3329

Anas, (Allah be pleased with him) reported: Safiyya (Allah be pleased with her) fell to the lot of Dihya in the spoils of war, and they praised her in the presence of Allah's Messenger (may peace be upon him) and said: We have not seen the like of her among the captives of war. He sent (a messenger) to Dihya and he gave him whatever he demanded. He then sent her to my mother and asked her to embellish her. Allah's Messenger (may peace be upon him) then got out of Khaibar until when he was on the other side of it, he halted, and a tent was pitched for him. When it was morning Allah's Messenger (may peace be upon him) said: He who has surplus of provision with him should bring that to us. Some persons would bring the surplus of dates, and the other surplus of mush of barley until there became a heap of bals. They began to eat the hais and began to drink out of the pond which had the water of rainfall in it and which was situated by their side. Anas said that that constituted the wedding feast of Allah's Messenger (may peace be upon him). He (further) said: We proceeded until we saw the walls of Medina, and we were delighted. We made our mounts run quickly and Allah's Messenger (may peace be upon him) also made his mount run quickly. And Safiyya (Allah be pleased with her) was at his back, and Allah's Messenger (may peace be upon him) had seated her behind him. The camel of Allah's Messenger (may peace be upon him) stumbled and he (the Holy Prophet) fell down and she also fell down. And none among the people was seeing him and her, until Allah's Messeuger (may peace be upon him) stood up and he covered her, and we came to him and he said: We have received no injury. We entered Medina and there came out the young ladies of the household. They saw her (hadrat Safiyya) and blamed her for falling down.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3330]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3330

Anas (Allah be pleased with him) reported: When the 'Iddah of Zainab was over, Allah's Messenger (may peace be upon him) said to Zaid to make a mention to her about him. Zaid went on until he came to her and she was fermenting her flour. He (Zaid) said: As I saw her I felt in my heart an idea of her greatness so much so that I could not see towards her (simply for the fact) that Allah's Messenger (may peace be upon him) had made a mention of her. So I turned my back towards her. and I turned upon my heels, and said: Zainab, Allah's Messenger (may peace be upon him) has sent (me) with a message to you. She said: I do not do anything until I solicit the will of my Lord. So she stood at her place of worship and the (verse of) the Qur'an (pertaining to her marriage) were revealed, and Allah's Messenger (may peace be upon him) came to her without permission. He (the narrator) said: I saw that Allah's Messenger (may peace be upon him) served us bread and meat until it was broad day light and the people went away, but some persons who were busy in con- versation stayed on in the house after the meal. Allah's Messenger (may peace be upon him) also went out and I also followed him, and he began to visit the apartments of his wives greeting them (with the words): As-Salamu 'alaikum, and they would say: Allah's Messenger, how did you find your family (hadrat Zainab)? He (the narrator) stated: I do not know whether I had informed him that the people had gone out or he (the Holy Prophet) informed me (about that). He moved on until he entered the apartment, and I also went and wanted to enter (the apartment) along with him, but he threw a curtain between me and him, as (the verfes pertaining to seclusion) had been revealed, and people were instructed in what they had been instructed. Ibn Rafii had made this addition in his narration:" O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished..." to the words"... Allah forbears not from the truth."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3331]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3331

Anas (Allah be pleased with him) reported: I did not see Allah's Messenger (may peace be upon him) giving a wedding feast (on the marriage) of any one (of his wives) as he did in the case of (his marriage with) Zainab, for then he sacrificed a goat (on this occasion).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3332]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3332

Anas b. Malik (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) gave no better wedding feast than the one he did (on the occasion of his marriage with) Zainab. Thabit al-Bunani (one of the narrators) said: What did he serve in the wedding feast? He (Anas) said: He fed them bread and meat (so lavishly) that they (the guests) abandoned it (of their own accord after having taken them to their hearts' content).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3333]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3333

Anas b. Malik (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) married Zainab bint jahsh, he invited people (to the wedding feast) and they ate food. They then sat there and entered into conversation. He (the Holy Prophet) made a stir as if he was preparing to stand up, but (the persons busy in talking) did not stand up. When he (the Holy Prophet) saw it, he stood up and when he did so, some other persons stood up. 'Asim and Abd al-A'la in their narrations made this addition: Three (persons) sat there, and Allah's Apostle (may peace be upon him) came there to enter (the apartment) but he found the people sitting there. Then they stood up and went away. He said: Then I came and informed Allah's Apostle (may peace be upon him) that they had gone away. He (the Holy Prophet) then came there until he entered (the apartment). I also went and was about to enter, when he hung a curtain between me and him (and it was on this occasion that) Allah, the Exalted and Majestic, revealed this verse:" O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished to the (words)" Surely this is serious in the sight of Allah" (xxxiii. 53).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3334]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3334

Anas b. Malik (Allah be pleased with him) reported: I was the best informed among the people pertaining to Hijab (veil and seclusion). Ubayy b. Ka'b used to ask me about it. Anas (Allah be pleased with him) thus narrated: The Messenger of Allah (may peace be upon him) got up in the morning as a bridegroom of Zainab bint jahsh (Allah be pleased witt her) as he had married her at Medina. He invited people to the wedding feast after the day had well risen. There sat Allah's Messenger (may peace be upon him) and there kept sitting along with him some persons after the people had stood up (for departure) ; then Allah's Messenger (may peace be upon him) stood up and walked on and I also walked along with him until he reached the door of the apartment of 'A'isha (Allah be pleased with her). He then thought that they (those who had been sitting there after meal) had gone away. So he returned and I also returned with him, but they were still sitting at their places. So he returned for the second time and I also returned until he reached the apartment of 'A'isha. He again returned and I also returned and they had (by that time) stood up, and he hung a curtain between me and him (at the door of the apartment of Hadrat Zainab, where he had to stay), and Allah revealed the verse pertaining to veil.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3335]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3335

Anas b. Malik (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) contracted marriage and he went to his wife. My mother Umm Sulaim prepared hais and placed it in an earthen vessel and said: Anas, take it to Allah's Messenger (may peace be upon him) and say: My mother has sent that to you and she offers greetings to you, and says that it is a humble gift for you on our behalf, Messenger of Allah. So I went along with it to Allah's Messenger (may peace be upon him) and said: My mother offers you salutations, and says that it is a humble gift for you on our behalf. He said: Place it here, and then said: Go and invite on my behalf so and so and anyone whom you meet, and he even named some persons. He (Anas) said: I invited whom he had named and whom I met. I (one of the narrators) said: I said to Anas: How many (persons) were there? He (Anas) said: They were about three hundred persons. Then Allah's Messenger (may peace be upon him) (said to me): Anas, bring that earthen vessel. They (the guests) then began to enter until the courtyard and the apartment were fully packed. Allah's Messenger (may peace be upon him) said: Make a circle of ten (guests), and every person should eat from that nearest to him. They began to eat, until they ate to their fill. A group went out (after eating the food), and another group came in until all of them had eaten. He (the Holy Prophet) said to me: Anas, lift it (the earthen vessel), so I lifted it, but I could not assess whether it had more (food) when I placed it (before Allah's Messenger) or when I lifted it (after the people had been served out of it). A group among them (the guests) began to talk in the house of Allah's Messenger (may peace be upon him) and the Messenger of Allah (may peace be upon him) was sitting and his wife had been sitting with her face turned towards the wall. It was troublesome for Allah's Messenger (may peace be upon him), so Allah's Messenger (may peace be upon him) went out and greeted his wives. He then returned. When they (the guests) saw that Allah's Messenger (may peace be upon him) had returned they thought that it (their overstay) was something troublesome for him. He (the narrator) said: They hastened towards the door and all of them went out. And there came Allah's Messenger (may peace be upon him) and he hung a curtain and went in, and I was sitting in his apartment and he did not stay but for a short while. He then came to me and these verses were revealed. Allah's Messenger (may peace be upon him) came out and recited them to the people:" O you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished-but when you are invited, enter, and when you have taken food, disperse not seeking to listen to talk. Surely this gives the Prophet trouble", to the end of verse (xxxiii. 53). (Al-Ja'd said that Anas [b. Malik] stated: I am the first amongst the people to hear these verses), and henceforth the wives of the Apostle (may peace be upon him) began to observe seclusion (al-hijab).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3336]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3336

Anas (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) contracted marriage with Zainab (Allah be pleased with bet), Umm Sulaim sent him hats in a vessel of stone as a gift. Anas stated that Allah's Messenger (may peace be upon him) said to him: Go and invite on my behalf all the Muslims whom you meet. So I invited on his behalf everyone whom I met. They entered (his house) and they ate and went out. And Allah's Messenger (may peace be upon him) had kept his hand on the food, and he invoked blessing on that, and said whatever Allah wished him to say, and none whom I met was left uninvited. They ate to their fill and went out, but a group among them remained there and was engaged in lengthy discussion. Allah's Apostle (may peace be upon him) felt shy of saying them anything. So he went out and left them in his house and Allah the Great and Majestic revealed this verse:" 0 you who believe, enter not the houses of the Prophet unless permission is given to you for a meal, not waiting for its cooking being finished." Qatada (instead of using the word Ghaira Nazirina) used the word Ghaira Mutahayyinina (i. e. not waiting for the time of the food). But when you are invited, enter..." up to this verse. This is purer for your hearts and their hearts.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3337]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3337

Ibn Umar (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: When any one of you is invited to a feast, he should attend it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3338]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3338

Ibn 'Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: When any one of you is invited to a feast, he should accept. 'Ubaidallah took this feast to be a wedding feast.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3339]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3339

Ibn Umar (Allah be pleased withthem) reported Allah's Apostle (may peace be upon him) having said this: When any one of you is invited to a wedding feast, he should accept that.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3340]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3340

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may be upon him) having said this: Accept the feast, when you are invited.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3341]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3341

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: When any one of you invites his brother, he (the latter) should accept his wedding feast, or any other like it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3342]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3342

Ibn 'Umar (Allah be pleated with them) reported Allah's Messenger (may peace be upon him) having said: He who is invited to a wedding feast or like it, he should accept it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3343]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3343

" Abdullah b. Umar (Allah be pleased with them) reported Allah's Messen- ger (may peace be upon him) as saying: Come to the feast, when you are invited.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3344]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3344

Nafil reported: I heard Abdullah b. Umar (Allah be pleased with them) narrating that Allah's Messenger (may peace be upon him) said: Accept the feast when you are invited to it. And Abdullah (b. Umar) used to come to the feast, whether it was a wedding feast or other than that, and he would come there even in the state of fasting.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3345]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3345

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) having said: When you are invited to a feast (even though it is) the leg of the sheep, you should accept it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3346]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3346

Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace he upon him) said: When any one of you is invited to a feast, he should accept it. He may eat if he likes, or he may abandon (eating) if he likes. Ibn Mathanni did not make mention of the word" feast".


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3347]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3347

A hadith like this has been narrated on the authority of Abd Zubair with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3348]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3348

Abu Haraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: If any one of you is invited, he should accept (the invitation). In case he is fasting, he should pray (in order to bless the inmates of the house), and if he is not fasting he should eat.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3349]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3349

Abu Huraira (Allah be pleased with him) used to say: The worst kind of food is the wedding feast to which the rich are invited and the poor are ignored. He who does not come to the feast, he in fact disobeys Allah and His Messenger (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3350]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3350

Sufyan reported: I said to Zuhri: Abu Bakr, what does this hadith mean:" The worst kind of food is at a wedding feast of the rich"? He laughed and said: The food served in the feast given by the rich is not worst (in itself). Sufyan said: My father was rich, so I felt disturbed when I heard this hadith, so I asked Zuhri who said: I heard from 'Abd al-Rahman al-Alraj that he heard Abu Huraira (Allah he pleased with him) say: The worst kind of food is that served at the wedding feast. The rest of the hadith is the same.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3351]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3351

This hadith has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3352]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3352

A hadith like this has been narrated by Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3353]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3353

Abu Haraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying. The worst kind of food is at the wedding feast from which one who comes is turned away, and he who refuses it is invited, and he who did not accept the invitation disobeyed Allah and His Messenger (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3354]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3354

'A'isha (Allah he pleased with her) reported: There came the wife of Rifa'a to Allah's Apostle (may peace be upon him) and said: I was married to Rifa'a but he divorced me, making may divorce irrevocable. Afterwards I married Abd al-Rahman b. al-Zubair, but all he possesses is like the fringe of a garment (i. e. he is sexually weak). Thereupon Allah's Messenger (may peace be upon him) smiled, and said: Do you wish to return to Rifa'a. (You) cannot (do it) until you have tasted his sweetness and he ('Abd al-Rahman) has tasted your sweetness. Abu Bakr was at that time near him (the Holy Prophet) and Khalid (b. Sa'id) was at the door waiting for the permission to be granted to him to enter), He (Khalid) said; Abu Bakr, do you hear what she is saying loudly in the presence of Allah's Messenger (may peace be upon him)?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3355]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3355

'A'isha (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), reported that Rifa'a al-Quraid (Allah be pleased with him) divorced his wife, making her divorce irrevocable. Afterwards she married Abd at-Rahman b. al-Zubair (Allah be pleased with him), She came to Allah'sApostle (may peace be upon him and said to Allah's messenger (may peace be upon him) that she had been the wife of Rifa'a (Allah be pleased with him) and he had divorced her by three pronouncements and afterwards she married 'Abd al-Rahman b. al-Zubair. By Allah, all he possesses is like the fringe of a garment, and she took hold of the fringe of her garment. Thereupon Allah's Messenger (may peace be upon him) laughed and said: Perhaps you wish to return to Rifa'a, (but you) cannot (do it) until he has tasted your sweetness and you have tasted his sweetness. Abu Bakr al-siddiq (Allah be pleased with him) was sitting at that time with Allah's Messenger (may peace be upon him) and Khalid b. Sa'id b. al-'As (Allah be pleased with him) was sitting at the door of his apartment and he was not permitted to (enter the room), and Kbalid called loudly saying: Abu Bakr, why don't you scold her for what she is saying loudly in the presence of Allah's Messenger (may peace be upon him)?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3356]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3356

'A'isha (Allah bjpl'eased with her) reported that Rifa'a al Qurazi divorced his wife and afterwards Abd al-Rahman b. al-Zubair married her. She came to Allah's Apostle (may peace he upon him) and said: Messenger of Allah, Rifa'a has divorced me by three pronouncements. (The rest of the hadith is the same.)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3357]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3357

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) was asked about a woman whom a man married and then divorced her, and then she married (another) person, and she was divorced before sexual intercourse with her, whether it was lawful for her first husband (to marry her in this state). He (the Holy Prophet) said: No, until he has tasted her sweetness.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3358]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3358

A hadith like this has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3359]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3359

'A'Asha (Allah be pleased with her) reported: A person divorced his wife by three pronouncements; then another person married her and he also divorced her without having sexual intercourse with her. Then the first husband of her intended to remarry her. It was about such a case that Allah's Messenger (may peace be upon him) was asked, whereupon he said: No, until the second one has tasted her sweetness as the first one had tasted.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3360]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3360

A hadith like this has been narrated on the same chain of transmitters by 'A'isha (Allah be pleased with her).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3361]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3361

Ibn" Abbas (Allah be pleased with thern) reported that Allah's Messenger (may peace be upon him) said: If anyone amongst you intends to go to his wife he should say: In the name of Allah,0 Allah protect us against Satan and keep away the Satan from the one that you have bestowed upon us, and if He has ordained a male child for them, Satan will never be able to do any harm to him.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3362]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3362

This hadith is narrated through another chain of transmitters and there is no mention of (the words)" Bismillah" (In the name of Allah) in it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3363]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3363

Jabir (Allah be pleased with him) declared that the Jews used to say: When a man has intercourse with his wife through the vagina but being on her back. the child will have squint, so the verse came down:" Your wives are your tilth; go then unto your tilth as you may desire" (ii. 223)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3364]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3364

Jabir (b. Abdullah) (Allah be pleased with him) reported that the Jews used to say that when one comes to one's wife through the vagina, but being on her back, and she becomes pregnant, the child has a squint. So the verse came down:" Your wives are your ti'Ith; go then unto your tilth, as you may desire."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3365]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3365

This hadith has been reported on the authority of Jabir through another chain of transmitters, but in the hadith transmitted on the authority of Zuhri there is an addition (of these words):" If he likes he may (have intercourse) being on the back or in front of her, but it should be through one opening (vagina)."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3366]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3366

Abu Huraira (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) said: When a woman spends the night away from the bed of her husband, the angels curse her until morning. This hadith has been narrated through the same chain of transmitters (with a slight variation):" He said: Until she comes back."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3367]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3367

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is my life, when a man calls his wife to his bed, and she does not respond, the One Who is in the heaven is displeased with her until he (her husband) is pleased with her.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3368]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3368

Abu Huraira (Allah he pleased with him) reported Allah's Messenger (may, peace be upon him) as saying: When a man invites his wife to his bed and she does not come, and he (the husband) spends the sight being angry with her, the angels curse her until morning.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3369]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3369

Abu Sa'id al-Khudri (Allah he pleased with him) reported that Allah's Messenger (may peace be upoin him) said: The most wicked among the people in the eye of Allah on the Day of judgment is the men who goes to his wife and she comes to him, and then he divulges her secret.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3370]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3370

Abu Sirma al-Khudri (Allah he pleased with him ) reported Allah's Messen- ger (may peace be upon him) as saying: The most important of the trusts in the sight of Allah on the Day of judgment is that a man goes to his wife and she goes to him (and the breach of this trust is) that he should divulge her secret Ibn Numair narrates this hadith with a slight change of wording.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3371]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3371

Abu Sirma said to Abu Sa'id al Khadri (Allah he pleased with him): 0 Abu Sa'id, did you hear Allah's Messenger (may peace be upon him) mentioning al-'azl? He said: Yes, and added: We went out with Allah's Messenger (may peace be upon him) on the expedition to the Bi'l-Mustaliq and took captive some excellent Arab women; and we desired them, for we were suffering from the absence of our wives, (but at the same time) we also desired ransom for them. So we decided to have sexual intercourse with them but by observing 'azl (Withdrawing the male sexual organ before emission of semen to avoid-conception). But we said: We are doing an act whereas Allah's Messenger is amongst us; why not ask him? So we asked Allah's Mes- senger (may peace be upon him), and he said: It does not matter if you do not do it, for every soul that is to be born up to the Day of Resurrection will be born.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3372]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3372

A hadith like this has been narrated on the authority of Habban with the same chain of transmitters (but with this alteration) that he said:" Allah has ordained whom he has to createuntil the Day of judgment."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3373]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3373

Abu Sa'id al-Khudri (Allah be pleased with him) reported: We took women captives, and we wanted to do 'azl with them. We then asked Allah's Messen- ger (may peace be upon him) about it, and he said to us: Verily you do it, verily you do it, verily you do it, but the soul which has to be born until the Day of judg- ment must be born.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3374]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3374

Abu Sa'id al-Khudri (Allah be pleased with him) (was asked if he had heard it himself), to which he said: Yes. (I heard) Allah's Apostle (may peace be upon him) as saying: There is no harm if you do not practise it, for it (the birth of the child) is something ordained (by Allah).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3375]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3375

This hadith is reported on the authority of Abu Sa'id with the same chain of transmitters but with a slight variation (of words).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3376]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3376

Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) was asked about 'azl, whereupon he said: There is no harm if you do not do that, for it (the birth of the child) is something ordained. Muhammad (one of the narrators) said: (The words) La 'alaykum (there is no harm) implies its Prohibition.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3377]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3377

Abu Sa'id al-Khudri (Allah be pleased with him) reported that mention was made of 'azl in the presence of Allah's Apostle (may peace be upon him) whereupon he said: Why do you practise it? They said: There is a man whose wife has to suckle the child, and if that person has a sexual intercourse with her (she may conceive) which he does not like, and there is another person who has a slave-girl and he has a sexual intercourse with her, but he does not like her to have conception so that she may not become Umm Walad, whereupon he (the Holy Prophet) said: There is no harm if you do not do that, for that (the birth of the child) is something pre- ordained. Ibn 'Aun said: I made a mention of this hadith to Hasan, and he said: By Allah, (it seems) as if there is upbraiding in it (for 'azl).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3378]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3378

Ibn 'Aun reported: I reported to Muhammad on the authority of Ibrahim the hadith reported by 'Abd al-Rahmann b. Bishr (the hadith concerning 'azl), where- upon he said: That (hadith) Abd al-Rahman b. Bishr had narrated to me (also).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3379]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3379

Ma'bad b. Sirin said to Abu Sa'id (Allah be pleased with him): Did you hear Allah's Messenger (may peace be upon him) making a mention of something in regard to al-'azl? Thereupon he said: Yes. The rest (of the hadith is the same)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3380]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3380

Abu Sa'id al-Khudri (Allah be pleased with him) reported: Mention was made about al-'azl in the presence of Allah's Messenger (may peace be upon him), whereupon he said: Why any one of you practises it? (He did not say: One of you should not do it), for there is no created soul, whose creator is not Allah.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3381]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3381

Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) was asked about 'azl, whereupon he said: The child does not come from all the liquid (sermen) and when Allah intends to create anything nothing can prevent it (from coming into existence).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3382]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3382

A hadith like this has been transmitted by Abu Sa'id from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3383]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3383

Jabir (Allah be pleased with him) reported that a man came to Allah's Messenger (may peace be upon him) and said: I have a slave-girl who is our servant and she carries water for us and I have intercourse with her, but I do not want her to conceive. He said: Practise 'azl, if you so like, but what is decreed for her will come to her. The person stayed back (for some time) and then came and said: The girl has become pregnant, whereupon he said: I told you what was decreed for her would come to her.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3384]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3384

Jabir b. 'Abdullah (Allah be pleased with them) reported that a person asked Allah's Apostle (may peace be upon him) saying: I have a slave-girl and I practise 'azl with her, whereupon Allah's Messenger (may peace be upon him) said: This cannot prevent that which Allah has decreed. The person then came (after some time) and said: Messenger of Allah, the slave-girl about whom I talked to you has conceived, whereupon Allah's Messeuger (may peace be upon him) said: I am the servant of Allah and His Messenger.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3385]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3385

Jabir b. 'Abdullah (Allah be pleased with them) reported: A person came to Allah's Apostle (the rest of the hadith is the same).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3386]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3386

Jabir (Allah be pleased with him) reported: We used to practise 'azl while the Qur'an was revealed (during the days when the Holy Prophet was alive).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3387]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3387

Jabir (Allah be pleased with him) reported: We used to practise 'azl during the life of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3388]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3388

Jabir (Allah be pleased with him) reported: We used to practise 'azl during the lifetime of Allah's Messenger (may peace be upon him). This (the news of this practise) reached Allah's Apostle (may peace be upon him), and he did not forbid us.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3389]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3389

Abu Darda' (Allah be pleased with him) related from the Prophet of Allah (may peace be upon him) that he came upon a woman who was in the advanced stage of pregnancy at the door of a tent. He (the Holy Prophet) said: Perhaps he (the man accompanying her) intends to cohabit with her. They said: Yes. Thereupon Allah's Messenger (may peace be upon him) said: I have decided to curse him with such a curse as may go along with him to his grave. How can he own him (the child to be born) and that is not lawful for him, and how can he take him as a servant for that is not lawful for him?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3390]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3390

A hadith like this has been transmitted on the authority of Shu'ba.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3391]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3391

Judaima daughter of Wahb al-Asadiyya (Allah be pleased with her) reported that she heard Allah's Messenger (may peace be upon him) assaying: I intended to prohibit cohabitation with a suckling woman until I considered that the Romans and the Persians do it without any injury being caused to their children thereby. (Imam Muslim said: Khalaf reported it from Judamat al-'Asadiyya, but the correct wording is what has been stated by Yahya.)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3392]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3392

Judama daughter of Wahb, sister of Ukkasha (Allah be pleased with her). reported: I went to Allah's Messenger (may peace be upon him) along with some persons and he was saying: I intended to prohibit cohabitation with the suckling women, but I considered the Greeks and Persians, and saw that they suckle their children and this thing (cohabitation) does not do any harm to them (to the suckling women). Then they asked him about 'azl, whereupon he said. That is the secret (way of) burying alive, and Ubaidullah has made this addition in the hadith transmitted by al-Muqri and that is:" When the one buried alive is asked."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3393]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3393

Judama bint Wahb al-Asadiyya (Allah be pleased with her) reported: I heard Allah's Messenger (may peace be upon him) saying this. The rest of the hadith is the same concerning 'azl and ghila (cohabitating with a suckling woman), but with a slight variation of words.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3394]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3394

Sa'd b. Abu Waqqas (Allah be pleased with him) reported that a person came to Allah's Messenger (may peace be upon him) and said: I do 'azi with my wife. Thereupon Allah's Messenger (may peace be upon him) said: Why do you do that? The person said: I fear harm to her child or her children. Thereupon Allah's Messenger (way peace be upon him) said: If that were harmful it would harm the Persians and the Greeks.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3395]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3395

'A'isha (Allah be pleased with her) reported tha Allah's Messenger (may peace be upon him) was with her and she heard the voice of a person seeking permission to enter the house of Hafsa. 'A'isha (Allah he pleased with her) said: Allah's Messenger, he is the person who seeks permission to enter your house, whereupon Allah's Messenger (may peace be upon him) said: I think he is so and so (uncle of Hafsa by reason of fosterage). 'A'isha said: Messenger of Allah, if so and so (her uncle by reason of fosterage) were alive, could he enter my house? Allah's Messenger (may peace be upon him) said: Yes. Fosterage makes unlawful what consanguinity makes unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3396]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3396

'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: Fosterage makes unlawful what consanguinity makes unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3397]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3397

'A'isha (Allah be pleased with her) reported that Aflah, the brother of Abu'l-Qu'ais, who was her uncle by reason of fosterage, came, and asked her permission (to enter the house) after seclusicin was instituted. I refused to admit him. When Allah's Messenger (may peace be upon him) came, I Informed him what I had done. He commanded me to grant him permission (as the brother of her foster-father was also her uncle).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3398]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3398

'A'isha (Allah be pleased with her) reported: There came to me Aflah b. Abu Qulais, my uncle by reason of fosterage; the rest of the hadith is the same (but with this) addition:" I ('A'isha) said (to the Holy Prophet): It was the woman who suckled me and not the man, whereupon he (Allah's Messenger) said: May your hands or your right hand be besmeared with dust (you were mistaken)."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3399]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3399

'A'isha (Allah be pleased with her) reported that there came Aflah the brother, of Abu'l-Qu'ais, who sought her permission (to enter) after seclusion was instituted, and AbuQu'ais was the father of 'A'isha by reason of fosterage. 'A'isha said: By Allah, I would not permit Aflah unless I have solicited the opinion of Allah's Messenger (may peace be upon him) for Abu Qulais has not suckled me, but his wife has given me suck. 'A'isha' (Allah be pleased with her) said: When Allah's Messenger (may peace be upon him) entered, I said: Allah's Messenger, Aflah is the brother of Abu'l-Qulais; he came to me to seek my permission for entering (the houst). I did not like the idea of granting him permission until I had solicited your opinion. Thereupon Allah's Apostle (may peace be upon him) said: Grant him permission. 'Urwa said it was on account of this that 'A'isha used to say. What is unlawful by reason of consanguinity is unlawful by reason of fosterage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3400]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3400

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters (that 'A'isha said): There came Aflah, the brother of Abu'l Qulais (Allah be pleased with him), and sought permission from her, the rest of the hadith is the same (except for the words that the Holy Prophet) said:" He is your uncle. Let your hand be besmeared with dust. Abu'l Qulais was the husband of the woman who had suckled 'A'isha (Allah be pleased with her).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3401]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3401

'A'isha (Allah be pleased with her) reported: My foster uncle came to me and sought permission (to enter the house), but I refused him permission until I had solicited the opinion of Allah's Messenger (may peace be upon him). When Allah's Messenger (may peace be upon him) came, I said to him: My foster-uncle sought my permission to (enter the house), but I did not permit him, whereupon Allah's Messenger (may peace be upon him) said: You better admit your uncle (into the house). I ('A'isha) said: It was the woman who suckled me and not the man. (But he) said: He is your uncle, admit him.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3402]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3402

This hadith has been narrated on the authority of Hisham with the same chain of transmitters (and the words are):" The brother of Abu'l-Qu'ais sought permission from her ('A'isha) (to enter the house). The rest is the same.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3403]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3403

This hadith has been narrated on the authority of Hisham with the same chain of transmitters but with a slight variation of words.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3404]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3404

'A'isha (Allah be pleased with her) reported: My foster-uncle Abu'l Ja'd (kunya of Aflah) sought permission from me, which I refused. (Hisham said to me that Abu'l-Ja'd was in fact Abu'l-Qu'ais). When Allah's Apostle (may peace be upon him) came, I ('A'isha) informed him about it. He said: Why did you not permit him? Let your right hand or hand be besmeared with dust.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3405]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3405

'A'isha (Allah be pleased with her) reported that her foster-uncle whose name was Aflah sought permission from her (to enter the house) but she observed seclusion from him, and informed Allah's Messenger (may peace be upon him) who said to her: Don't observe veil from him for he is Mahram (one with whom marriage cannot be contracted) on account of fosterage as one is Mahram on account of consanguinity.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3406]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3406

'A'isha (Allah be pleased with her) reported: Aflah b. Qu'ais sought permission from me (to enter the house), but I refused to grant him the permission, and he sent me (the message saying): I am your uncle (in the sense) that the wife of my brother has suckled you, (but still) I refused to grant him permission. There came the Messenger of Allah (may peace be upon him) and I made a mention of it to him, and he said: He can enter (your house), for he is your uncle.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3407]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3407

'Ali (Allah be pleased with him) reported having said this: Messenger of Allah, why is it that you select (your wife) from among the Quraish, but you ignore us (the nearest of the kin)? Thereupon he said: Have you anything for me (a suitable match for me)? I said; Yes, the daughter of Hamza, whereupon Allah's Messenger (may peace be upon him) said: She is not lawful for me, for she is the daughter of my brother by reason of fosterage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3408]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3408

A hadith like this has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3409]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3409

Ibn Abbas (Allah be pleased with them) reported: It was proposed that he (the Holy Prophet) be married to the daughter of Hamza, whereupon he said: She is not lawful for me for she is the daughter of my foster-brother, and that is unlawful by reason of fosterage what is unlawful by reason of genealogy.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3410]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3410

A hadith like this is narrated on the authority of Hammam, Sa'id, Bishr b 'Umar, but with a small variation of words.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3411]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3411

Umm Salama (Allah be pleased with her), the wife of Allah's Apostle (may peace be upon him), said: It was said to the Messenger of Allah (may peace be upon him): Is not the daughter of Hamza a suitable match for you? Or it was said: Why don't you propose to marry the daughter of Hamza, the son of Abd al-Muttalib? Thereupon he said: Hamza is my brother by reason of fosterage.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3412]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3412

Umm Habiba, the daughter of AbuSufyan, reported: The Messenger of Allah (may peace be upon him) came to me and I said to him: Have you any inclination towards my the daughter of Abu Sufyan? He (the Holy Prophet) said: Then what should I do? I said: Marry her. He said: Do you like that? I said: I am not the exclusive (wife) of yours; I, therefore, wish to join my sister in good. He, said: She is not lawful for me. I said: I have been informed that you have given the proposal of marriage to Durrah daughter of Abu Salama He raid: You mean the daughter of Umm Salama? I said: Yes. He said: Even if she had not been my step-daughter brought up under my guardianship, she would not have been lawful for me, for she is the daughter of my foster-brother (Hamza), for Thuwaiba had suckled me and her father. So do not give me the proposal of the marriage of your daughters and sisters. This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3413]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3413

Umm Habiba, the wife of Allah's Apostle (may peace be upon him), reported that she said to Allah's Messenger (may peace be upon him): Messenger of Allah, marry my sister 'Azza, whereupon Allah's Messenger (may peace be upon him) said: Do you like it? She said: Yes, Messenger of Allah, I am not the exclusive wife of yours, and I wish that the person who joins me in good should be my sister. Thereupon Allah's Messenger (may peace be upon him) said: That is not lawful for me. I said: Messenger of Allah, we discussed that You intend to marry Durrah bint Abu Salama. He (the Holy Prophet) said: You mean the daughter of Abu Salama? She said: Yes, whereupon Allah's Messenger (may. peace be upon him) said: Even if she were not the step-daughter of mine, brought up under my guardianship, she would not have been lawful for me, for she is the daughter of my foster-brother. Thuwaiba gave me suck and to Abu Salama (also), so do not offer to me your daughters and sisters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3414]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3414

'A'isha (Allah be pleased with her), Suwaid and Zubair reported Allah's Apostle (may peace be upon him) as saying: One suckling or two do not make (marriage) unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3415]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3415

Umm al-Fadl reported: A bedouin came to Allah's Apostle (may peace be upon him) when he was in my house and said: Allah's Apostle, I have had a wife and I married another besides her, and my first wife claimed that she had suckled once or twice my newly married wife, thereupon Allah's Apostle (may peace be upon him) said: One suckling or two do not make the (marriage) unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3416]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3416

Umm Fadl (Allah be pleased with her) reported that a person from Banu 'Amir b. Sa'sa said: Allah's Apostle, does one suckling make the (marriage) unlawful? He said: No.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3417]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3417

Umm Fadl (Allah be pleased with her) reported that Allah's Apostle (may peace be upon him) said: Being suckled once or twice, or one suckling or two, do not make marriage unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3418]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3418

In the narration transmitted on the authority of Ibn Bishr there is a mention of two sucklings and Ibn Abu Shaiba has narrated it with a small variation of wording.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3419]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3419

Umm Fadl (Allah be pleased with her) reported Allah's Apostle (may peace be'apon him) having said this: One or two sucklings do not make (the marriage) unlawful.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3420]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3420

Umm Fadl (Allah be pleased with her) reported that a person asked Allah's Apostle (may peace be upon him): Does one suckling make (the marriage) unlawful? He said: No.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3421]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3421

'A'isha (Allah be pleased with, her) reported that it had been revealed in the Holy Qur'an that ten clear sucklings make the marriage unlawful, then it was abrogated (and substituted) by five sucklings and Allah's Apostle (may peace be upon him) died and it was before that time (found) in the Holy Qur'an (and recited by the Muslims).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3422]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3422

'Amra reported that she beard 'A'isha (Allah he pleased with her) discussing fosterage which (makes marriage) unlawful; and she ('A'isha) said: There was revealed in the Holy Qur'an ten clear sucklings, and then five clear (sucklings).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3423]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3423

Ahadith like this is transmitted by 'A'isha through another chain of narrators.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3424]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3424

' A'isha (Allah be pleased with her) reported that Sahla bint Suhail came to Allah's Apostle (may peace be eupon him) and said: Messengerof Allah, I see on the face of Abu Hudhaifa (signs of disgust) on entering of Salim (who is an ally) into (our house), whereupon Allah's Apostle (may peace be upon him) said: Suckle him. She said: How can I suckle him as he is a grown-up man? Allah's Messenger (may peace be upon him) smiled and said: I already know that he is a young man 'Amr has made this addition in his narration that he participated in the Battle of Badr and in the narration of Ibn 'Umar (the words are): Allah's Messenger (may peace be upon him) laughed.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3425]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3425

'A'isha (Allah be pleased with her) reported that Salim, the freed slave of Abu Hadhaifa, lived with him and his family in their house. She (i. e. the daughter of Suhail came to Allah's Apostle (may peace be upon him) and said: Salim has attained (purbety) as men attain, and he understands what they understand, and he enters our house freely, I, however, perceive that something (rankles) in the heart of Abu Hudhaifa, whereupon Allah's Apostle (may peace be upon him) said to her: Suckle him and you would become unlawful for him, and (the rankling) which Abu Hudhaifa feels in his heart will disappear. She returned and said: So I suckled him, and what (was there) in the heart of Abu Hudhaifa disappeared.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3426]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3426

Ibn Abu Mulaika reported that al-Qasim b. Muhammad b. Abu Bakr had narrated to him that 'A'isha (Allah be pleased with her) reported that Sahla bint Suhail b. 'Amr came to Allah's Apostle (may peace be upon him) and said: Messenger of Allah, Salim (the freed slave of Abu Hudhaifa) is living with us in our house, and he has attained (puberty) as men attain it and has acquired knowledge (of the sex problems) as men acquire, whereupon he said: Suckle him so that he may become unlawful (in regard to marriage) for you He (Ibn Abu Mulaika) said: I refrained from (narrating this hadith) for a year or so on account of fear. I then met al-Qasim and said to him: You narrated to me a hadith which I did not narrate (to anyone) afterwards. He said: What is that? I informed him, whereupon he said: Narrate it on my authority that 'A'isha (Allah be pleased with her) had narrated that to me.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3427]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3427

Umm Salama said to 'A'isha (Allah be pleased with her): A young boy who is at the threshold of puberty comes to you. I, however, do not like that he should come to me, whereupon 'A'isha (Allah be pleased with her) said: Don't you see in Allah's Messenger (may peace be upon him) a model for you? She also said: The wife of Abu Hudhaifa said: Messenger of Allah, Salim comes to me and now he is a (grown-up) person, and there is something that (rankles) in the mind of Abu Hudhaifa about him, whereupon Allah's Messenger (may peace be upon him) said: Suckle him (so that he may become your foster-child), and thus he may be able to come to you (freely).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3428]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3428

Zainab daughter of Abu Salama reported: I heard Umm Salama, the wife of Allah's Apostle (may peace be upon himy, saying to 'A'isha: By Allah, I do not like to be seen by a young boy who has passed the period of fosterage, whereupon she ('A'isha) said: Why is it so? Sahla daughter of Suhail came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I swear by Allah that I see in the face of Abu Hudhaifa (the signs of disgust) on account of entering of Salim (in the house), whereupon Allah's Messenger (may peace be upon him) said: Suckle him. She (Sahla bint Suhail) said: He has a heard. But he (again) said: Suckle him, and it would remove what is there (expression of disgust) on the face of Abu Hudhaifa. She said: (I did that) and, by Allah, I did not see (any sign of disgust) on the face of Abu Hadhaifa.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3429]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3429

Umm Salama, the wife of Allah's Apostle (may peace be upon him), used to say that all wives of Allah's Apostle (may peace be upon him) disclaimed the idea that one with this type of fosterage (having been suckled after the proper period) should come to them. and said to 'A'isha: By Allah, we do not find this but a sort of concession given by Allah's Messenger (may peace be upon him) only for Salim, and no one was ging to be allowed to enter (our houses) with this type of fosterage and we do not subscribe to this view.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3430]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3430

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) visited me when a man was sitting near me, and he seemed to disapprove of that. And I saw signs of anger on his face and I said: Messenger of Allah, he is my brother by forsterage, whereupon he said: Consider who your brothers are because of fosterage since fosterage is through hunger (i. e. in infancy).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3431]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3431

This hadith is narrated on the authority of Abd al-Ahwas with another chain of transmitters and a slight variation of words.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3432]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3432

Abu Sa'id al-Khudri (Allah her pleased with him) reported that at the Battle of Hanain Allah's Messenger (may peace be upon him) sent an army to Autas and encountered the enemy and fought with them. Having overcome them and taken them captives, the Companions of Allah's Messenger (may peace te upon him) seemed to refrain from having intercourse with captive women because of their husbands being polytheists. Then Allah, Most High, sent down regarding that:" And women already married, except those whom your right hands possess (iv. 24)" (i. e. they were lawful for them when their 'Idda period came to an end).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3433]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3433

Abu Sa'id al-Khudri (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) sent a small army. The rest of the hadith is the same except this that he said: Except what your right hands possessout of them are lawful for you; and he did not mention" when their 'idda period comes to an end". This hadith has been reported on the authority of AbuSa'id (al-Khudri) (Allah be pleased with him) through another chain of transmitters and the words are: They took captives (women) on the day of Autas who had their husbands. They were afraid (to have sexual intercourse with them) when this verse was revealed:" And women already married except those whom you right hands posses" (iv. 24)


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3434]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3434

Qatada reported a hadith like this with the same chain of transmitters.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3435]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3435

'A'isha (Allah be pleased with her) reported: Sa'd b. Abu Waqqas and Abd b. Zam'a (Allah be pleased with them) disputed with each other over a young boy. Sa'd said: Messenger of Allah, he is the son of my brother 'Utba b. Abu Waqqas as he made it explicit that he was his son. Look at his resemblance. Abd b. Zam'a said Messenger of Allah, he is my brother as he was born on the bed of my father from his slave-girl. Allah's Messenger (way peace he upon him) looked at his resembl-. ance and found a clear resemblance with 'Utba. (But) he said: He is yours 0 'Abd (b. Zam'a), for the child is to be attributed to one on whose bed it is born, and stoning for a fornicator. Sauda bint Zam'a, O you should observe veil from him. So he did not see Sauda at all. Muhammad b. Rumh did not make a mention (of the words):" O Abd."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3436]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3436

A hadith like this is narrated on the authority of Ibn 'Uyaiyna and Ma'mar (and the words are): The child is attributed to him on whose bed he is born; but they did not mention this:" For a fornicator there is stoning."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3437]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3437

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The child is to be attributed to one on whose bed he is born, and for a fornicator there is stoning.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3438]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3438

A hadith like this is narrated on the authority of Abu Huraira.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3439]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3439

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) visited me looking pleased as if his face was glistening and said: Did you see that Mujazziz cast a glance at Zaid b. Haritha and Usama b. Zaid, and (then) said: Some (of the features) of their feet are found in the others?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3440]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3440

'A'isha (Allah be pleased with her) reported: One day Allah's Apostle (may peace be upon him) visited me looking pleased and he said: 'A'isha, don't you see Mujazziz al-Mudliji? (He) entered (my house) and saw Usama and Zaid with a rug over them covering their heads, but their feet appeared, and (he) said: These feet are related to one another.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3441]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3441

'A'isha (Allah be pleased with her) reported: A physiognomist visited (our house) and Allah's Messenger (may peace be upon him) was present, and Usama b. Zaid and Zaid b. Haritha were both lying asleep, and he (the physiognomist), said: These feet are related to one another. Allah's Apostle (may peace be upon him) was pleased to hear this, and he was happy and informed 'A'isha (Allah be pleased with her) about it.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3442]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3442

A hadith like this has been narrated on the authority of Zuhri and Yunus said: Mujazziz was a physiognomist.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3443]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3443

'Abd al-Malik b. Abu Bakr b. Abd al-Rahman b. al-Harith b. Hisham reported on the authority of his father from Umm Salama (Allah be pleased with her) that when Allah's Messenger (may peace be upon him) married Umm Salama, he stayed with her for three nights, and said: There is no lack of estimation on the part of your husband for you. If you wish I can stay with you for a week, but in case I stay with you for a week, then I shall have to stay for a week with all my wives.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3444]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3444

Ibn Abu Bakr b. Abd al-Rahman reported that when Allah's Messenger (may peace be upon him) married Umm Salama and she stayed with him (during the night), and it was dawn, he (the Holy Prophet) said to her: There is no lack of estimation for you on the part of your husband. So if you desire I can spend a week with you, and if you like I may spend three (nights). and then I will visit you in turn. She said: Spend three (nights).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3445]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3445

Abu Bakr b. 'Abd al-Rahman reported that when Allah's Messenger (may peace be upon him) married Umm Salama and he visited her, and when he intended to come out, she caught hold of his cloth. whereupon Allah's Messenger (may peace be upon him) said: If you so desire, I can extend the time (of my stay) with you, but then I shall have to calculate the time (that I stay with you and shall have to spend the same time with other wives). For the virgin woman, (her husband has to stay with her) for a week, and for the woman previously married it is three days.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3446]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3446

A hadith like this has been narrated on the authority of Ibn Humaid.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3447]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3447

Umm Salama (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) married her, and he (the narrator) made mention of so many things in this connection (and one of them was this) that he said: If you desire that I spend a week with you, I shall have to spend a week with my (other) wives, and if spend a week with you, I shall have to spend a week with my (other) wives.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3448]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3448

Anas b. Malik reported: When anyone who has already a wife marries virgin, he should stay with her for seven nights (and then turn to his other wife), but when anyone having a virgin with him (as his wife) marries a woman who has been previously married he should stay with her for three nights. Khalid (one of the narrators) said. If I were to say that it could be directly traced to the Holy Prophet (may peace be upon him). I would have told the truth, but he (Hadrat Anas) said: Such is the tradition.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3449]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3449

Abu Qilaba reported on the authority of Anas: It is the Sunnph to stay with a virgin (after having married her) for a week. Khalid (one of the narrators) said: If wish I can say that it can be traced up to the Holy Prophet (may peace be upon him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3450]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3450

Anas (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) had ninewives. So when he divided (his stay) with them, the turn of the first wife did not come but on the ninth (day). They (all the wives) used to gather every night in the house of one where he had to come (and stay that night). It was (the night when he had to stay) in the house of 'A'isha (Allah be pleased with her), when Zainab came there. He (the Holy Prophet) stretched his hand towards her (Zainab), whereupon she ('A'isha) said: It is Zainab. Allah's Apostle (may peace be upon him) withdrew his hand. There was an altercation between the two until their voices became loud (and it was at that time) when Iqama was pronounced for prayer. There happened to come Abu Bakr and he heard their voices and said: Messenger of Allah, (kindly) come for prayer, and throw dust in their moths. So the Prophet (may peace be upon him) went out. 'A'isha said: When Allah's Apostle (may peace be upon him) would finish his prayer there would also come Abu Bakr and he would do as he does (on such occasions, i. e. reprimanding). When Allah's Apostle (may peace be upon him) had finished his prayer, there came to her Abu Bakr. and spoke to her ('A'isha) in stern words and said: Do you behave like this?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3451]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3451

'A'isha (Allah be pleased with her) reported: Never did I find any woman more loving to me than Sauda bint Zam'a. I wished I could be exactly like her who was passionate. As she became old, she had made over her day (which she had to spend) with Allah's Messenger (may peace be upon him) to 'A'isha. She said: I have made over my day with you to 'A'isha. So Allah's Messenger (may peace be upon him) allotted two days to 'A'isha, her own day (when it was her turn) and that of Sauda.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3452]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3452

A hadith like this has been transmitted on the authority of Hisham with the same chain of narrators (and the words are): When Sauda became old (the rest of the hadith is the same) and in the narration of Sharik there is an addition (of these words:" She was the first woman whom he (Allah's Apostle) married after me."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3453]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3453

'A'isha (Allah be pleased with her) reported: I felt jealous of the women who offered themselves to Allah's Messenger (may peace be upon him) and said: Then when Allah, the Exalted and Glorious, revealed this:" You may defer any one of them you wish, and take to yourself any you wish; and if you desire any you have set aside (no sin is chargeable to you)" (xxxiii. 51), I ('A'isha.) said: It seems to me that your Lord hastens to satisfy your desire.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3454]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3454

Hisham reported on the authority of his father that 'A'isha (Allah be pleased with her) used to say: Does the woman not feel shy of offering herself to a man? Then Allah the Exalted and Glorious revealed this verse:" You may defer any of them you wish and take to yourself any you wish." I ('A'isha said): It seems to me that your Lord hastens to satisfy your desire.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3455]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3455

'Ata related that when they were with Ibn 'Abbas (Allah be pleased with them) at the funeral of Maimuna In Sarif, Ibn 'Abbas (Allah be pleased with them) said: This is the wife of Allah's Apostle (may peace be upon him) ; so when you lift her bier, do not shake her or disturb her, but be gentle, for Allah's Messenger (may peace be upon him) had nine wives, with eight of whom he shared his time, but to one of them, he did not allot a share. 'Ati said: The one to whom he did not allot a share of time was Safiyya, daughter of Huyayy b. Akhtab.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3456]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3456

Ibn Juraij narrated a hadith with the same chain of transmitters, and she (Hadrat Maimuna) was the last of them to die at Medina.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3457]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3457

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A woman may be married for four reasons: for her property, her status. her beauty and her religion, so try to get one who is religious, may your hand be besmeared with dust.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3458]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3458

Jabir b. 'Abdullah (Allah be pleased with them) reported: I married a woman during the lifetime of Allah's Messenger (may peace be. upon him). I met the Apostle of Allah (may peace be upon him), whereupon he said: Jabir, have you married? I said: Yes. He said: A virgin or one previously marrried? I said: With due previously married, whereupon he said: Why did you not marry a virgin with whom you could sport? I said: Allah's Messenger, I have sisters; I was afraid that she might intervene between me and them, whereupon he said: Well and good, if it is so. A woman is married for four reasons, for her religion, her property, her status, her beauty, so you should choose one with religion. May your hands cleave to dust.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3459]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3459

Jabir b. 'Abdullah (Allah be pleased with them) reported: I married a woman, whereupon Allah's Messenger (may peace be upon him) said to me: Have you married? I said: Yes. He said: Is it a virgin or a previously married one (widow or divorced)? I said: With a previously married one, whereupon he said: Where had you been (away) from the amusements of virgins? Shu'ba said: I made a mention of it to 'Amr b. Dinar and he said: I too heard from Jabir making mention of that (that Allah's Apostle) said: Why didn't you marry a girl, so that you might sport with her and she might sport with you?


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3460]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3460

Jabir b. 'Abdullah (Allah be pleased with them) reported: 'Abdullah died and he left (behind him) nine or seven daughters. I married a woman who had been previously married. Allah's Messenger (may peace be upon him) said to me: Jabir, have you married? I said: Yes. He (again) said: A virgin or one previously married? I said: Messenger of Allah, with one who was previously married, whereupon he said: Why didn't you marry a young girl so that you could sport with her and she could sport with you, or you could amuse with her and she could amuse with you? I said to him: 'Abdullah died (he fell as martyr in Uhud) and left nine or seven daughters behind him; I, therefore, did not approve of the idea that I should bring a (girl) like them, but I preferred to bring a woman who should look after them and teach them good manners, whereupon he (Allah's Messenger) said: May Allah bless you, or he supplicated (for the) good (to be) conferred on me (by Allah).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3461]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3461

Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) said to me: Jabir, have you married? The rest of the hadith is the same up to (the words):" The woman would look after them and comb them." He (Allah's Messenger), said: You did well. But no mention is made of the subsequent portion.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3462]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3462

Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in an expedition. When we returned I urged my camel to move quickly as it was slow. There met me a rider from behind me and he goaded it with an iron-tipped stick which he had with him. My camel moved forward like the best that you have ever seen. As I turned (my face) I found him to be Allah's Messenger (may peace be upon him) He said: Jabir, what hastens you? I said: Messenger of Allah, I am newly wedded. whereupon he said: Is it a virgin that you have married or one previously married? I said: With one previously married. He said: Why not a young girl so that you could play with her and she could play with you? Then when we arrived at and were about to enter Medina he said: Wait, so that we may enter by night (i. e. in the evening) in order that the woman with dishevelled hair may comb it, and the woman whose husband had been away may get herself clean; and when you enter (then you have the) enjoyment (of tho wife's company).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3463]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3463

Jabir b. 'Abdullah (Allah be pleased with him) reported: I went out with Allah's Messenger (may peace be upon him) on an expedition, but my camel delayed me. Allah's Messenger (may peace be upon him) came to me and said to me: Jabir, I said: Yes. Allah's Messenger, (here I am at your beck and call) He said: What is the matter with you? I said: My camel has delayed me and is tired, so I have lagged behind. He (the Holy Prophet) got down and goaded it with a crooked stick and then said: Mount it. So I mounted and (to my great surprise) I saw it (moving so quickly that) I had to restrain it (from going ahead of) Allah's Messenger (may peace be upon him). He (the Holy Prophet) (in the course of journey said to me): Have you married? I said: Yes. He (again) said: Is it with a virgin or one previously married? I said. With one previously married, whereupon he (again) said: Why not with a young girl with whom you could sport and she could have sported with you? I said: I have sisters, so I preferred to marry a woman who could keep them together (as one family). who could comb them and look after them. He said: You are about to go (to your house), and there you have the enjoyment (of the wife's company). He again said: Do you want to sell your camel? I said: Yes. So he bought it from me for one u'qiya (of silver), Then Allah's Messenger (may peace be upon him) arrived (at Medina) and I arrived in the evening. I went to the mosque and found him at the door of the mosque, and said: Is it now that you have arrived? I said: Yes, He said: Leave your camel, and enter (the mosque) and offer two rak'ahs. So I entered and offered two rak'ahs of prayer, and then returned. He (the Holy Prophet) then commanded Bilal to weigh out one 'uqiya (of silver) tor me. Bilal weighed that out for me (lowering the scale of) balance. So I proceeded and as I turned my back he said: Call for me, Jabir. So I was called back, and I said (to myself): He would return me the camel, and nothing was more displeasing to me than this (that after having received the price I should also get the camel). He said: Take your camel and keep its price with you, (also).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3464]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3464

Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in a journey, and I was riding a camel meant for carrying water and it lagged behind all persons. Allah's Messenger (may peace be upon him) hit it or goaded it (I think) with something he had with him. And after it (it moved so quickly) that it went ahead of all persons and it struggled with me (to move faster than I permitted It) and I had to restrain it. Allah's Messenger (may peace be upon him) said: Do you sell it at such and such (price)? May Allah grant you pardon. I said: Allah's Apostle, it is yours. He (again) said: Do you sell it at such and such (price)? May Allah grant you pardon. ' I said: Allah's Apostle, it is yours. He said to me: Have you married after the death of your father? I said: Yes. He (again) said: With one previously married or a virgin? I said: With one previously married. He said: Why didn't you marry a virgin who might amuse you and you might amuse her, and she might sport with you and you might sport with her? Abu Nadra said: That was the common phrase which the Muslims spoke:" You do such and such (thing) and Allah may grant you pardon."


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3465]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3465

'Abdullah b. Amr reported Allah's Messenger (may peace be upon him) as saying: The whole world is a provision, and the best object of benefit of the world is the pious woman.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3466]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3466

AbuHuraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Woman is like a rib. When you attempt to straighten it, you would break it. And if you leave her alone you would benefit by her, and crookedness will remain in her. A hadith like this is reported by another chain of narrators


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3467]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3467

Abu Huraira (Allah be pleased with him) reported: Woman has been created from a rib and will in no way be straightened for you; so if you wish to benefit by her, benefit by her while crookedness remains in her. And if you attempt to straighten her, you will break her, and breaking her is divorcing her.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3468]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3468

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: He who believes in Allah and the Hereafter, if he witnesses any matter he should talk in good terms about it or keep quiet. Act kindly towards woman, for woman is created from a rib, and the most crooked part of the rib is its top. If you attempt to straighten it, you will break it, and if you leave it, its crookedness will remain there. So act kindly towards women.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3469]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3469

Ab Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A believing man should not hate a believing woman; if he dislikes one of her characteristics, he will be pleased with another.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3470]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3470

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him).


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3471]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3471

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Had it not been for Eve, woman would have never acted unfaithfully towards her husband.


Muslim :: The Book of Marriage (Kitab Al-Nikah) :: [8.3472]

The Book of Marriage (Kitab Al-Nikah)

Muslim :: Book 8 : Hadith 3472

Hammam b. Munabbih said: These are some of the ahadith which Abu Huraira (Allah be pleased with him) narrated to us from Allah's Messenger (may peace be upon him), and one of these (this one): Allah's Messenger (may peace be upon him) said: Had it not been for Bani Isra'il, food would not have become stale, and meal would not have gone bad; and had it not been for Eve, a woman would never have acted unfaithfully toward her husband.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3473]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3473

Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was menstruating during the lifetime of Allah's Messenger (may peace be upon him). 'Umar b. Khattib (Allah be pleased with him) asked Allah's Messenger (may peace be upon him) about it, whereupon Allah's Messenger (may peace be upon him) said: Command him ('Abdullah b. 'Umar) to take her back (and keep her) and pronounce divorce when she is purified and she again enters the period of menstruation and she is again purified (after passing the period of menses), and then if he so desires he may keep her and if he desires divorce her (finally) before touching her (without having an intercourse with her), for that is the period of waiting ('ldda) which God, the Exalted and Glorious, has commanded for the divorce of women.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3474]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3474

Abdullah (b. 'Umar) reported that he divorced a wife of his with the pronouncement of one divorce during the period of menstruation. Allah's Messenger (may peace be upon him) commanded him to take her back and keep her until she was purified, and then she entered the period of menses in his (house) for the second time. And he should wait until she was purified of her menses. And then if he would decide to divorce her, he should do so when she was purified before having a sexual intercourse with her; for that was the 'Idda which Allah had commanded for the divorce of women. Ibn Rumh in his narration made this addition: When 'Abdullah was asked about it, he said to one of them: If you have divorced your wife with one pronouncement or two (then you can take her back), for Allah's Messenger (may peace be upon him) commanded me to do it; but if you have divorced her with three pronouncements, then she is forbidden for you until she married another husband, and you disobeyed Allah in regard to the divorce of your wife what He had commanded you. (Muslim said: The word" one divorce" used by Laith is good.)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3475]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3475

Ibn Umar (Allah be pleased with them) reported: I divorced my wife during the lifetime of Allah's Messenger (may peace be upon him) when she was in the state of menses. 'Umar (Allah be pleased with him) made a mention of it to Allah's Messenger (may peace be upon him), whereupon he said: Command him to take her back and leave her (in that state) until she is purified. Then (let her) enter the period of second menses, and when she is purified, then divorce her (finally) before having a sexual intercourse with her, or retain her (finally). That is the 'Idda (the prescribed period) which Allah commanded (to be kept in view) while divorcing the women. 'Ubaidullah reported: I said to Nafi': What became of that divorce (pronounced within 'Idda)? He said: It was as one which she counted.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3476]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3476

A hadith like this has been narrated on the authority of 'Ubaidullah, but he made no mention of the words of Ubaidullah that he said to Nafi'.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3477]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3477

Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife during the period of menses. 'Umar (Allah be, pleas'ed with him) asked Allah's Apostle (may peace be upon him), and he commanded him ('Abdullah b. 'Umar) to have her back and then allow her respite until she enters the period of the second menses, and then allow her respite until she is purified, then divorce her (finally) before touching her (having a sexual intercourse with her), for that is the prescribed period which Allah commanded (to be kept in view) for divorcing the women. When Ibn 'Umar (Allah be pleased with them) was asked about the person who divorces his wife in the state of menses, he said: If you pronounced one divorce or two, Allah's Messenger (may peace be upon him) had commanded him to take her back, and then allow her respite until she enters the period of the second menses, and then allow her respite until she is purified, and then divorce her (finally) before touching her (having a sexual intercourse with her) ; and if you have pronounced (three divorces at one and the same time) you have in fact disobeyed your Lord with regard to what He commanded you about divorcing your wife. But she is however (finally separated from you).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3478]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3478

Abdullah b. 'Umar (Allah be pleased with them) reported: I divorced my wife while she was in the state of menses. 'Umar (Allah be pleased with him) made mention of it to Allah's Apostle (may peace be upon him) and he was enraged and he said: Command him to take her back until she enters the second ensuing menses other than the one in which he divorced her and in case he deems proper to divorce her, he should pronounce divorce (finally) before touching her (in the period) when she is purified of her menses, and that is the prescribed period in regard to divorce as Allah has commanded. 'Abdullah made a pronouncement of one divorce and it was counted in case of divorce. 'Abdullah took her back as Allah's Messenger (may peace be upon him) had commanded him. A hadith like this was reported on the authority of Zuhri with the same chain of narrators. Ibn Umar (Allah be pleased with them), however, said: I took her back, and counted this pronouncement of divorce (as valid) with which I divorced her.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3479]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3479

Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was in the state of menses. 'Umar (Allah be pleased with him) made mention of it to Allah's Apostle (may peace be upon him) and he said: Command him to take her back, then divorce her when she is pure or she is pregnant.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3480]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3480

Ibn 'Umar (Allah be pleased with them) reported that he divorced his wife while she was in her menses. 'Umar (Allah be pleased with him) asked Allah's Apostle (may peace be upon him) about that, and he said: Command him to take her back until she is pure and then she enters the second menses and then becomes pure. Then either divorce her (finally) or retain her.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3481]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3481

Ibn Sirin reported: One who was blameless (as a narrator) narrated to me for twenty years that Ibn 'Umar (Allah be pleased with him) pronounced three divorces to his wife while she was in the state of menses. He was commanded to take her back. I neither blamed them (the narrators) nor recognised the hadith (to be perfectly genuine) until I met Abu Ghallab Yunus b. Jubair al-Bahili and he was very authentic, and he narrated to me that he had asked Ibn 'Umar (Allah be pleased with there) and he narrated it to him that he made one pronouncement of divorce to his wife as she was in the state of menses, but he was commanded to take her back. I said: Was it counted (as one pronouncement)? He said: Why not, was I helpless or foolish?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3482]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3482

A hadith like this has been transmitted on the authority of Ayyub with a slight variation of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3483]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3483

Ayyub reported a hadith like this with the same chain of narrators and he said: Umar (Allah be pleased with him) asked Allah's Apostle (may peace be upon him) about it and he commanded him that he should take her back until she is divorced in the state of purity without having a sexual intercourse with her, and said: Divorce her in the beginning of her 'Idda or her 'Idda commences.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3484]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3484

Yunus b. Jubair reported: I said to Ibn'Umar (Allah be pleased with them): A person divorcedhis wife while she was in the state of menses, whereupon he said: Do you know 'Abdullah b. Umar (Allah be pleased with them), for he divorced his wife in the state of menses. 'Umar (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and asked him, and he (the Holy Prophet) commanded him that he should take her back, and she started her 'Idda. I said to him: When a person divorces his wife, and she is in the state of menses, should that pronouncement of divorce be counted? He said: Why not, was he hopless or foolish?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3485]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3485

Ibn 'Umar (Allah be pleased with them) reported: I divorced my wife while she was in the state of menses. 'Umar (Allah he pleased wish him) came toAllah's Apostle (may peace be upon him) and made mention of that to him, whereupon Allah's Apostle (may peace be upon him) told that be should take her back, and when she is pure he may divorce her. if he would so wish. I (one of the narrators) said to Ibn 'Umar (Allah be pleased with them): Did you count (this pronouncement of divorce) in her case? He said: What (after all) prevents him from doing so? Do you find him (Ibn Umar) either helpless or foolish?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3486]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3486

Anas b. Sirin reported: I asked Ibn 'Umar (Allah be pleased with them) about the woman whom he had divorced. He said: I divorced her while she was in the state of menses. It was mentioned to 'Umar (Allah be pleased with him) and he then made a mention of that to Allah's Apostle (may peace be upon him), whereupon he said: Command him to take her back and when the period of menses is over, then (he may divorce her in the state of her purity. He (Ibn Umar) said: So I took her back, then divorced her in her purity. I (the narrator) said: Did you count that divorce which you pronounced in the state of menses? He said: Why should I not have counted that? Was I helpless or foolish?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3487]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3487

Anas b. Sirin reported that he had heard Ibn 'Umar (Allah be pleased with them) as saying. I divorced my wife while she was in the state of menses. 'Umar (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and informed him about it, whereupon he (Allah's Apostle) said: Command him to take her back and when she is pure, then divorce her. I said to Ibn 'Umar Allah be pleased with them): Did you count that pronouncement of divorce? He said: Why not? This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with a slight variation in wording.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3488]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3488

Ibn Tawus narrated on the authority of his father that Ibn 'Umar (Allah be pleased with them) was asked about the person who divorced his wife in the state of menses, whereupon he said: Do you know 'Abdullah b. Umar? He said: Yes. He said: It was he who divorced his wife jn the state of menses and 'Umar went to Allah's Apostle (may peace be upon him) and gave him this information. and he commanded him that he should take her back; and he (Abu Tawus) said: I did not hear any addition to this (hadith) from my father.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3489]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3489

Abu Zubair reported that he heard 'Abd al-Rahman b. Aiman (the freed slave of 'Azza) say that he asked Ibn 'Umar (Allah be pleased with them) and Abu Zubair heard: What is your opinion about the person who divorced his wife in the state of menses? Thereupon he said: Ibn Umar (Allah be pleased with them) divorced his wife during the lifetime of Allah's Messenger (may peace be upon him) while she was in the state of menses. Upon this Allah's Messenger (may peace be upon him) told him to take her back and so he took her back and he (further) said: When she is pure, then either divorce her or retain her. Ibn 'Umar (Allah be pleased with them) said that Allah's Apostle (may peace be upon him) then recited this verse:" O Apostle, when you divorce women, divorce them at the commencement of their prescribed period" (Ixv 1).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3490]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3490

A hadith like this is reported on the same authority (but with this difference that the narrator) 'Abd al-Rahman b. Aiman (was mentioned) as the freed slave of 'Urwa (Imam Muslim said: He made a mistake who said that it was 'Urwa; it was in fact the freed slave of 'Azza.)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3491]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3491

Ibn 'Abbas (Allah be pleased with them) reported that the (pronouncement) of three divorces during the lifetime of Allah's Messenger (may peace be upon him) and that of Abu Bakr and two years of the caliphate of Umar (Allah be pleased with him) (was treated) as one. But Umar b. Khattab (Allah be pleased with him) said: Verily the people have begun to hasten in the matter in which they are required to observe respite. So if we had imposed this upon them, and he imposed it upon them.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3492]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3492

Abu Sahba' said toIbn 'Abbas (Allah be pleased with them): Do you know that three (divorces) were treated as one during the lifetime of Allah's Apostle (may peace be upon him), and that of Abu Bakr, and during three (years) of the caliphate of Umar (Allah be pleased with him)? Ibn Abbas (Allah be pleased with them) said: Yes.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3493]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3493

Abu al-Sahba' said to Ibn 'Abbas: Enlighten us with your information whether the three divorces (pronounced at one and the same time) were not treated as one during the lifetime of Allah's Messenger (may peace be upon him) and Abu Bakr. He said: It was in fact so, but when during the caliphate of 'Umar (Allah be pleased with him) people began to pronounce divorce frequently, he allowed them to do so (to treat pronouncements of three divorces in a single breath as one).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3494]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3494

Ibn Abbas (Allah be pleased with them) reported about (declaring of one's woman) unlawful as an oath which must be atoned, and Ibn 'Abbas said: Verily, there is in the Messenger of Allah (may peace be upon him) a model pattern for you.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3495]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3495

Ibn Abbas (Allah be pleased with them) reported: When a man declares his wife unlawful for himself that is an oath which must be atoned, and he said: There is in the Messenger of Allah (may peace be upon him) a noble pattern for you.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3496]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3496

'A'isha (Allah be pleased with her) narrated that Allah's Apostle (may peace be upon him) used to spend time with Zainab daughter of Jahsh and drank honey at her house. She ('A'isha further) said: I and Hafsa agreed that one whom Allah's Apostle (may peace be upon him) would visit first should say: I notice that you have an odour of the Maghafir (gum of mimosa). He (the Holy Prophet) visited one of them and she said to him like this, whereupon he said: I have taken honey in the house of Zainab bint Jabsh and I will never do it again. It was at this (that the following verse was revealed): 'Why do you hold to be forbidden what Allah has made lawful for you... (up to). If you both ('A'isha and Hafsa) turn to Allah" up to:" And when the Holy Prophet confided an information to one of his wives" (lxvi. 3). This refers to his saying: But I have taken honey.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3497]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3497

'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) liked sweet (dish) and honey. After saying the afternoon prayer he used to visit his wives going close to them. So he went to Hafsa and stayed with her more than what was his usual stay. I ('A'isha) asked about that. It was said to me: A woman of her family had sent her a small vessel of honey as a gift, and she gave to Allah's Messenger (may peace be upon him) from that a drink. I said: By Allah, we would also contrive a device for him. I mentioned that to Sauda, and said: When he (Allah's Apostle) would visit you and draw close to you, say to him: Allah's Messenger, have you taken maghafir? And he would'say to you: No. Then say to him: What is this odour? And Allah's Messenger (may peace be upon him) felt it very much that unpleasant odour should emit from him. So he would say to you: Hafsa has given me a drink of honey. Then you should say to him: The honey-bees might have sucked 'Urfut, and I would also say the same to him and. Safiyya, you should also say this. So when he (the Holy Prophet) came to Sauda, she said: By Him besides whom there is no god, it was under compulsion that I had decided to state that which you told me when he would be at a little distance at the door. So when Allah's Messenger (may peace be upon him) came near, she said: Messenger of Allah, did you eat Maghafir? He said: No. She (again) said: Then what is this odour? He said: Hafsa gave me honey to drink. She said: The honey-bee might have sucked 'Urfut. When he came to me I told him like this. He then visited Safiyya and she also said to him like this. When he (again) visited Hafsa, she said: Messenger of Allah, should I not give you that (drink)? He said: I do not need that. Sauda said: Hallowed be Allah, by Him we have (contrived) to make that (honey) unlawful for him. I said to her: Keep quiet. This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3498]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3498

'A'isha (Allah be pleased with her) reported: When the Messenger of Allah (may peace be upon him) was commanded to give option to his wives, he started it from me saying: I am going to mention to you a matter which you should not (decide) in haste until you have consulted your parents. She said that he already knew that my parents would never allow me to seek separation from him She said: Then he said: Allah, the Exalted and Glorious, said: Prophet, say to thy wives: If you desire this world's life and its adornment, then come, I will give you a provision and allow you to depart a goodly departing; and if you desire Allah and His Messenger and the abode of the Hereafter, then Allah has prepared for the doers of good among you a great reward She is reported to have said: About what should I consult my parents, for I desire Allah and His Messenger and the abode of the Hereafter? She ('A'isha) said: Then all the wives of Allah's Messenger (may peace be upon him) did as I had done.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3499]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3499

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) sought our permission when he had a (turn to spend) a day with (one of his wives) amongst us (whereas he wanted to visit his other wives too). It was after this that this verse was revealed:" Thou mayest put off whom thou pleasest of them, and take for thee whom thou pleasest" (xxxiii. 5). Mu'adha said to her: What did you say to Allah's Messenger (may peace be upon him) when he sought your permission? She said: I used to say: If it had the option in this I would not have (allowed anyone) to have precedence over me.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3500]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3500

'A'isha reported: Allah's Messenger (may peace be upon him) gave us the option (to get divorce) but we did not deem it as divorce.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3501]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3501

Masruq reported: I do not mind if I give option to my wife (to get divorce) once, hundred times, or thousand times after (knowing it) that she has chosen me (and would never seek divorce). I asked 'A'isha (Allah be pleased with her) (about it) and she said: Allah's Messenger (may peace be upon him) gave us the option, but did it imply divorce? (It was in fact not a divorce; it is effective when women actually avail themselves of it.)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3502]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3502

'A'isha reported that Allah's Messenger (may peace be upon him) gave option to his wives, but it was not a divorce.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3503]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3503

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) gave us the option (to get divorce) and we chose him and he did not count it a divorce.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3504]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3504

'A'isha (Allah be pleased with her) reported: Allah's Messeinger (may peace be upon him) gave us the option (to get divorce), but me made a choice of him and he did not count anything (as divorce) in regard to us.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3505]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3505

A hadith like this has been transmitted on the authority of 'A'isha through another chain of narrators.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3506]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3506

Jabir b. 'Abdullah (Allah be pleased with them) reported: Abu Bakr (Allah be pleased with him) came and sought permission to see Allah's Messenger (may peace be upon him). He found people sitting at his door and none amongst them had been granted permission, but it was granted to Abu Bakr and he went in. Then came 'Umar and he sought permission and it was granted to him, and he found Allah's Apostle (may peace be upon him) sitting sad and silent with his wives around him. He (Hadrat 'Umar) said: I would say something which would make the Holy Prophet (may peace be upon him) laugh, so he said: Messenger of Allah, I wish you had seen (the treatment meted out to) the daughter ofKhadija when you asked me some money, and I got up and slapped her on her neck. Allah's Messenger (mav peace be upon him) laughed and said: They are around me as you see, asking for extra money. Abu Bakr (Allah be pleased with him) then got up went to 'A'isha (Allah be pleased with her) and slapped her on the neck, and 'Umar stood up before Hafsa and slapped her saying: You ask Allah's Messenger (may peace be upon him) which he does not possess. They said: By Allah, we do not ask Allah's Messenger (may peace be upon him) for anything he does not possess. Then he withdrew from them for a month or for twenty-nine days. Then this verse was revealed to him:" Prophet: Say to thy wives... for a mighty reward" (xxxiii. 28). He then went first to 'A'isha (Allah be pleased with her) and said: I want to propound something to you, 'A'isha, but wish no hasty reply before you consult your parents. She said: Messenger of Allah, what is that? He (the Holy Prophet) recited to her the verse, whereupon she said: Is it about you that I should consult my parents, Messenger of Allah? Nay, I choose Allah, His Messenger, and the Last Abode; but I ask you not to tell any of your wives what I have said He replied: Not one of them will ask me without my informing her. God did not send me to be harsh, or cause harm, but He has sent me to teach and make things easy.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3507]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3507

'Umar b. al-Khattab (Allah be pleased with him) reported: When Allah's Apostle (may peace be upon him) kept himself away from his wives, I entered the mosque, and found people striking the ground with pebblesand saying: Allah's Messenger (may peace be upon him) has divorced his wives, and that was before they were commanded to observe seclusion 'Umar said to himself: I must find this (actual position) today. So I went to 'A'isha (Allah be pleased with her) and said (to her): Daughter of Abu Bakr, have you gone to the extent of giving trouble to Allah's Messenger (may peace be upon him)? Thereupon she said: Son of Khattab, you have nothing to do with me, and I have nothing to do with you. You should look to your own receptacle. He ('Umar) said: I visited Hafsa daughter of 'Umar, and said to her: Hafsa, the (news) has reached me that you cause Allah's Messenger (may peace be upon him) trouble. You know that Allah's Messenger (may peace be upon him) does not love you, and had I not been (your father) he would have divorced you. (On hearing this) she wept bitterly. I said to her: Where is Allah's Messenger (may peace be upon him)? Shesaid: He is in the attic room. I went in and found Rabah, the servant of Allah's Messenger (may peace be upon him), sitting on the thresholds of the window dangling his feet on the hollow wood of the date-palm with the help of which Allah's Messenger (may peace be upon him) climbed (to the apartment) and came down. I cried: 0 Rabah, seek permission for me from Allah's Messenger (way peace be upon him). Rabah cast a glance at the apartment and then looked toward me but said nothing. I again said: Rabah, seek permission for me from Allah's Messenger (may peace be upon him). Rabah looked towards the apartment and then cast a glance at me, but said nothig. I then raised my voice and said: 0 Rabah, seek permission for me from Allah's Messenger (may peace be upon him). I think that Allah's Messenger (may peace be upon him) is under the impression that I have come for the sake of Hafsa. By Allah, if Allah's Messenger (may peace be upon him) would command me to strike her neck, I would certainly strike her neck. I raised my voice and he pointed me to climb up (and get into his apartment). I visited Allah's Messenger (may peace be upon him), and he was lying on a mat. I sat down and he drew up his lower garment over him and he had nothing (else) over him, and that the mat had left its marks on his sides. I looked with my eyes in the store room of Allah's Messenger (may peace be upon him). I found only a handful of barley equal to one sa' and an equal quantity of the leaves of Mimosa Flava placed in the nook of the cell, and a semi-tanned leather bag hanging (in one side), and I was moved to tears (on seeing this extremely austere living of the Holy Piophet), and he said: Ibn Khattab, what wakes you weep?

I said: Apostle of Allah, why should I not shed tears? This mat has left its marks on your sides and I do not see in your store room (except these few things) that I have seen; Ceasar and Closroes are leading their lives in plenty whereas you are Allah's Messenger. His chosen one, and that is your store! He said: Ibn Khattab, aren't you satisfied that for us (there should be the prosperity) of the Hereafter, and for them (there should be the prosperity of) this world? I said: Yes. And as I had entered I had seen the signs of anger on his face, and I therefore, said: Messenger of Allah, what trouble do you feel from your wives, and if youhave divorced them, verily Allah is with you, His angels, Gabriel, Mika'il, I and Abu Bakr and the believers are with you. And seldom I talked and (which I uttered on that day) I hoped that Allah would testify to my words that I uttered. And so the verse of option (Ayat al-Takhyir) was revealed. Maybe his Lord, if he divorce you, will give him in your place wives better than you..." (Ixv. 5). And if you back up one another against him, then surely Allah is his Patron, and Gabriel and the righteous believers, and the angels after that are the aidera (lvi. 4). And it was 'A'isha, daughter of Abu Bakr, and Hafsa who had prevailed upon all the wives of Allah's Prophet (way peace be upon him) for (pressing them for mote money). I said: Messenger of Allah, have you divorced them? He said: No. I said: Messenger of Allah, I entered the mosque and found the Muslims playing with pebbles (absorbed in thought) and saying: Allah's Messenger has divorced his wives. Should I get down and inform there that you have not divorced them? He said: Yes, if you so like. And I went on talking to him until I (found) the signs of anger disappeared on his face and (his seriousness was changed to a happy mood and as a result thereof) his face had the natural tranquillity upon it and he laughed and his teeth were the most charming (among the teeth) of all people. Then Allah's Apostle (may peace be upon him) climbed down and I also climbed down and catching hold of the wood of the palm-tree and Allah's Messenger (may peace be upon him) came down (with such ease) as if he was walking on the ground, not touching anything with his hand (to get support). I said: Messenger of Allah, you remained in your apartment for twenty-nine days. He said: (At times) the month consists of twenty-nine days. I stood at the door of the mosque and I called out at the top of my voice: The Messenger of Allah (may peace be upon him) has not divorced his wives (and it was on this occasion that this) verse was revealed:" And if any matter pertaining to peace or alarm comes within their ken, they broadcast it; whereas, if they would refer it to the Apostle and those who have been entrusted with authority amongst them, those of them who are engaged in obtaining intelligence would indeed know (what to do with) it" (iv 83). And it was I who understood this matter, and Allah revealed the verse pertaining to option (given to the Holy Prophet (may peace be upon him in regard to the retaining or divorcing of his wives).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3508]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3508

Abdullah b. Abbas (Allah be pleased with tlicm) reported: I intended to ask 'Umar b. al-Khattab (Allah be pleased with him) about a verse, but I waited for one year to ask him out of his fear, until he went out for Pilgrimage and I also accompanied him. As he came back and we were on the way he stepped aside towards an Arak tree to ease himself. I waited for him until he was free. I then walked along with him and said: Commander of the Faithful, who are the two among the wives of Allah's Messenger (may peace be upon him) who backed up one another (in their demand for extra money)? He said: They were Hafsa and 'A'isha (Allah be pleased with them). I said to him: It is for one year that I intended to ask you about this matter but I could not date so on account of the awe for you. He said: Don't do that. If you think that I have any knowledge, do ask me about that. And if I were to know that, I would inform you. He (the narrator) stated that 'Umar had said: By Allah, during the days of ignorance we had no regard for women until Allah the Exalt- ed revealed about them what He has revealed, and appointed (turn) for them what he appointed. He said: It so happened that I was thinking about some matter that my wife said: I wish you had done that and that. I said to her: It does not concern you and you should not feel disturbed in a matter which I intend to do. She said to me: How strange is it that you, O son of Khattab, do not like anyone to retort upon you, whereas your daughter retorts upon Allah's Messenger (may peace be upou him) until he spends the day in vexation. 'Umar said: I took hold of my cloak, then came out of my house until I visited Hafsa and said to her: O daughter, (I heard) that you retort upon Allah's Messenger (may peace be upon him) until he spends the day in vexation, whereupon Hafsa said: By Allah, we do retort upon him. I said: You should bear in mind, my daughter, that I warn you against the punishment of Allah and the wrath of His Messenger (may peace be upon him). You may not be misled by one whose beauty has fascinated her, and the love of Allah's Messenger (may peace be upon him) for her. I ('Umar) then visited Umm Salama because of my relationship with her and I talked to her. Umm Salama said to me: Umar b. al-Khattab, how strange is it that you meddle with every matter so much so that you are anxious to interfere between Allah's Messenger (may peace be upon him) and his wives, and this perturbed me so much that I refrained from saying what I had to say, so I came out of her apartment, and I had a friend from the Anar.

When I had been absent (from the company of the Holy Prophet) he used to bring me the news and when he had been absent I used to bring him the news, and at that time we dreaded a king of Ghassan. It was mentioned to us that he intended to attack us, and our minds were haunted by him. My friend, the Ansari, came to me, and he knocked at the door and said: Open it, open it. I said: Has the Ghassani come? He said: (The matter is) more serious than that. The Messenger of Allah (may peace be upon him) has separated himself from his wives. I said: Let the nose of Hafsa and 'A'isha be besmeared with dust. I then took hold of my cloth and went out until I came and found Allah's Messenger (may peace be upon him) in his attic to which he climbed by means of a ladder made of date-palm, and the servant of Allah's Messenger (may peace be upon him) who was black had been sitting at the end of the ladder. I said: This is Umar. So permission was granted to me. I narrated this news to Allah's Messenger (may peace be upon him) and as I narrated the news concerning Umm Salama, Allah's Messenger (may peace be upon him) smiled. He was lying on the mat and there was nothing between him and that (mat), and under his head there was a pillow made of leather and it was stuffed with plam fibres and at his feet were lying a heap of sant tree (acacia niloctica, meant for dyeing) and near his head there was hanging a hide. And I saw the marks of the maton the side of Allah's Messenger (may peace be upon him), and so I wept. He said: What makes you weep? I said: Messenger of Allah, the Khusrau and the Ceasars (spendd their lives in) the midst of (luxuries), whereas you being Allah's Messenger (are leading your life in this poverty). Thereupon Allah's Messenger (may peace be upon him) said: Don't you like that they should have riches of their world, and you have the Hereafter.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3509]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3509

Ibn Abbas (Allah be pleased with them) said: I came along with Umar until we reached Marr al-Zahran (the name of a place), and the rest of the hadith is the same as narrated by Sulaiman b. Bilal (except with) the variation (of words) that I said: (What) about these two women? He said: They were Hafsa and Umm Salama. And he made this addition: I came to the apartments and in every apartment there was (the noise) of weeping. And this addition was also made: And he (the Holy Prophet) had taken an oath of remaining away from them for a month, and when twenty-nine days had passed, he visited them.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3510]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3510

Ibn Abbas (Allah be pleased with them) is reported to have said: I intended to ask Umar about those two ladies who had pressed for (worldly riches) during the lifetime of the Holy Prophet (may peace be upon him), and I kept waiting for one year, but found no suitable opportunity with him until I happened to accompany him to Mecca. And as he reached Marr al Zahran he went away to answer the call of nature, and he said (to me): Bring me a jug of water, and I took that to him. After having answered the call of nature, as he came back, I began to pour water (over his hands and feet), and I remembered (this event of separation of Allah's Apostle [may peace be upon him] from his wives). So I said to him: Commander of the Faithful, who are the two ladies (who had pressed the Holy Prophet [may peace be upon him] for providing comforts of life) and I had not yet finished my talk when he said: They were 'A'isha and Hafsa.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3511]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3511

Ibn 'Abbas (Allah be pleased with them) reported. I had always been anxious to ask 'Umar (Allah be pleased with him) about the two ladies amongst the wives of Allah's Prophet (may peace be upon Lim) about whom Allah, the Exalted, said:" If you both turn in repentance to Allah, then indeed your hearts are inclined (to this)" (Ixvi. 4), until 'Umar (Allah be pleased with him) set out for Hajj and I also went along with him. And as we were going along a path, 'Umar (Allah be pleased with hiyn) went aside and I also went aside with him with a jug (of water). He answered the call of nature, and then came to me and I poured water over his hands and he performed ablution I said: Commander of the Faithful, who are the two ladies amongst the wives of Allah's Prophet (may peace be upon him) about whom Allah, the Exalted and Majestic, said: 'If you both turn to Allah in repentance, then indeed your heart are inclined to it"? 'Umar (Allah he pleased with him) said: How strange is it for you, Ibn 'Abbas! (Zuhri said: By Allah, he disliked what he asked about, but did not keep it a secret.) He ('Umar) said: They are Hafsa and 'A'isha; and he then began to narrate the hadith and said: We were such people among the Quraish who dominated women, and as we reached Medina we found there people who were dominated by their women, and our women began to learn (the habits) of their women. He further said: And my house was situated in the suburb of Aledina in the tribe of Banu Umayya b. Zaid. One day I became angry with my wife and she retorted upon me. I did not like that she should retort upon me. She said: You disapprove of my retorting upon you By Allah, the wives of Allah's Apostle (may peace be upon him) retort upon him, and one of them detaches herself from him for the day until the night. So I ('Umar) went out and visited Hafsa and said: Do you retort upon Allah's Messenger (may peace be upon him)? She said: Yes. I said; Does any one of you detach herself from him from the day to the night? She said: Yes. He said: She who did like it amongst you in fact failed and incurred loss. Does everyone amongst you not fear the wrath of Allah upon her due to the wrath of His Messenger (may peace be upon him), and (as a result thereof) she may perish? So do not retort upon Allah's Messenger (may peace be upon him) and do not ask him for anything, but ask me that which you desire, (and the frank behaviour) of your companion may not mislead you, if she is more graceful and is dearer to Allah's Messenger (may peace be upon him) than you (meaning 'A'isha) (Allah be pleased with her).

He (Hadrat 'Umar further) said: I had a compalaion from the Ansar and, we used to remain in the company of the Messenger (may peace be upon him) turn by turn. He remained there for a day while I remained there on the other day, and he brought me the news about the revelation and other (matter), and I brought him (the news) like this. And we discussed that the Ghassanids were shoeing the horses in order to attack us. Id y companion once attended (the Apostle). and then came to me at night and knocked at my door and called me, and I came out to him, and he said: A matter of great importance has happened. I said: What is that? Have the Ghassanids come? He said: No, but even more serious and more significant than that: the Holy Prophet (may peace be upon him) has divorced his wives. I said: Hafsa has failed and has incurred loss. and I feared that it would happen. When it was dawn I observed the dawn prayer and dressed myself, and then came there (in the house of the Holy Prophet) and visited Hafsa, and she was weeping. I said: Has Allah's Messenger (may peace be upon him) divorced you (all)? She said: I do not know. He has, however, separated himself in his attic. I came to a black servant and said to him: Seek permission for 'Umar. He went in and then came to me and said: I made mention of you to him, but he kept quiet. I then went to the pulpit and sat there, and there was a group of people sitting by it and some of then were weeping. I sat there for some time, until I was overpowered (by that very idea) which was in my mind. I then came back to the boy and said to him: Seek permission for Umar. He went in and came to me and said: I made mention of you to him but he kept quiet. I was about to turn back when the boy called me and said: Go in; permission has been granted to you. I went in and greeted Allah's Messenger (may peace be upon him) and he was reclining against the couch of mat and it had left its marks upon his side. I said: Messenger of Allah, have you divorced your wives? He raised his head towards me and said: No. I said: Allah is the Greatest. Messenger of Allah, I wish if you had seen how we the people of Quraish had domination over women but when we came to Medina we found people whom their women dominated. So our women began to learn from their women. One dily I became angry with my wife and she began to retort upon me. I did not approve that she should retort upon me. She said: You do not like that I should retort upon you, but, by Allah. the wives of Allah's Apostle (may peace be upon him) retort upon him and any one of them separates herself from him for a day until night. I said: He who did that amongst them in fact failed and incurred loss. Does any of them feel sate from the wrath of Allahupon her due to the wrath of Allah's Messenger (may peace be upon him), and she has certainly perished. Allah's Messtnger (may peace be upon him) smiled, I said: Messenger of Allah, I visited Hafsa and said: (The behaviour) of your companion ('A'isha) may not mislead you, If she is more graceful than you and is dearer to Allah's Messenger (may peace be upon him) than you.

Allah's Messenger (may peace be upon him) smiled for the second time. I said: Allah's Messenger, way I talk to you about agreeable things? He said: Yes. I sat down and lifted my head (to see things) in the house and, by Allah, I did not see anything significant besides three hides. I said: Messenger of Allah, supplicate the Lord that He should make (life) prosperous for your Ummah as He has made plentiful for the people of Persia and Rome (in spite of the fact) that they do no, worship Allah, the Exalted and Majestic, whereupon he (Allah's Messenger) sat up an I then said: Ibn Khattab, do you doubt that they are a nation whom their nice things have been given immediately in the life of this world. I said: Allah's Messenger! seek pardon for me. And he (Allah's Messenger) had taken an oath that he would not visit them for a month due to extreme annoyance with them until Allah showed His displeasure to him (Allah's Messenger). Zuhri said: 'Urwa informed me that 'A'Isha (Allah be pleased with her) said: When twenty-nine nights were over, Allah's Messenger (may peace be upon him) visited me, and he began (his visit) with me. I said: Messenger of Allah, you had taken an oath that you would not visit us for a month, while you have visited after I have counted only twenty-nine (nights). Thereupon he said: The month may also be of twenty-nine (days). He then said: 'A'isha, I am going to talk to you about a matter, and you should not be hasty in it (and do not give your final decision) until you have consulted your parents. He then recited this verse to me:" O Prophet, say to your wives" till he reached" mighty reward" (xxxiii. 28). 'A'isha (Allah be pleased with her) said: By Allah, he knew that my parents would not allow me to separate from him. I said: Is there any need to consult my parents in this matter? I in fact choose Allah and His Messenger (may peace be upon him) and the abode in the Hereafter. Ma'mar said: Ayyub reported to me that 'A'isha said: Don't inform your wives that I have chosen you, whereupon Allah's Apostle (may peace be upon him) said: Verily Allah has sent me as a conveyer of message, and He has not sent me as a source of hardship (to others). Qatada said:" Saghat qulubukum" means" Your hearts have inclined."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3512]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3512

Fatima bint Qais reported that Abu 'Amr b. Hafs divorced her absolutely when he was away from home, and he sent his agent to her with some barley. She was displeased with him and when he said: I swear by Allah that you have no claim on us. she went to Allah's Messenger (may peace be upon him) and mentioned that to him. He said: There is no maintenance due to you from him, and he commanded her to spend the 'Idda in the house of Umm Sharik, but then said: That is a woman whom my companions visit. So better spend this period in the house of Ibn Umm Maktum, for he is a blind man and yon can put off your garments. And when the 'Idda is over, inform me. She said: When my period of 'Idda was over, I mentioned to him that Mu'awiya b. Abu Sufyan and Jahm had sent proposal of marriage to me, whereupon Allah's Messenger (may peace be upon him) said: As for Abu Jahm, he does not put down his staff from his shoulder, and as for Mu'awiya, he is a poor man having no property; marry Usama b. Zaid. I objected to him, but he again said: Marry Usama; so I married him. Allah blessed there in and I was envied (by others).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3513]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3513

Fatima bint Qais reported that her husband divorced her during the life time of Allah's Prophet (may peace be upon him) and gave her a meagre maintenance allowance. When she saw that, she said: By Allah, I will inform Allah's Messenger (may peace be upon him), and if maintenance allowance is due to me then I will accept that which will suffice me, and if it is not due to me, I will not accept anything from him. She said: I made a mention of that to Allah's Messenger (may peace be upon him) and he said: There is neither maintenance allowance for you nor lodging.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3514]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3514

Fatima bint Qais reported that her husband al-Makhzulmi divorced her and refused to pay her maintenance allowance. So she came to Allah's Messenger (may peace he upon him) and informed him, whereupon he said: There is no maintenance allowance for you, and you better go to the house of Ibn Umm Maktum and live with him for he is a blind man and you can put off your clothes in his house (i. e. you shall not face much difficulty in observing purdah there).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3515]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3515

Abu Salama reported that Fatima bint Qais, the sister of al-Dahhak b. Qais informed him that Abu Hafs b. Mughira al-Makhzumi divorced her three times and then he proceeded on to the Yemen. The members of his family said to her: There is no maintenance allowance due to you from us. Khalid b. Walid along with a group of persons visited Allah's Messenger (may peace be upon him) in the house of Maimuna and they said: Abu Hafs has divorced his wife with three pronouncements; is there any maintenance allowance due to her? Thereupon Allah's Messenger (may peace be upon him) said: No maintenance allowance is due to her, but she is required to spend the 'Idda; and he sent her the message that she should not be hasty in making a decision about herself and commanded her to move to the house of Umm Sharik, and then sent her the message that as the first immigrants (frequently) visit the house of Umm Sharik, she should better go to the house of Ibn Umm Maktum, the blind, (and further said: In case you put off your head-dress, he (Ibn Umm Makhtum) will not see you. So she went to his house, and when the 'Idda was over, Allah's Messenger (may peace be upon him) married her to Usama b. Zaid b. Haritha.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3516]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3516

Fatima bint Qais reported: I had been married to a person from Banu Makhzum and he divorced me with irrevocable divorce. I sent a message to his family asking for maintenance allowance, and the rest of the hadith has been transmitted with a slight change of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3517]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3517

Fatima bint Qais (Allah be pleased with her) reported that she had been married to Abu 'Amr b. Hafs b. al-Mughira and he divorced her with three pronouncements. She stated that she went to Allah's Messenger (may peace be upon him) asking him about abandoning that house. He commanded her to move to the house of Ibn Umm Maktum, the blind. Marwan refused to testify the divorced woman abandoning her house (before the 'Idda was over). 'Urwa said that 'A'isha objected to (the words of) Fatima bint Qais. This hadith has been transmitted through another chain of narrators.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3518]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3518

'Ubaidullah b. 'Abdullah b. 'Utba reported that 'Amr b. Hafs b. al-Mughira set out along with 'Ali b. Abi Talib (Allah be pleased with him) to the Yemen and sent to his wife the one pronouncement of divorce which was still left from the (irrevocable) divorce; and he commanded al-Harith b. Hisham and 'Ayyash b. Abu Rabi'a to give her maintenance allowance. They said to her: By Allah, there is no maintenance allowance for you, except in case you are pregnant. She came to Allah's Apostle (may peace he upon him) and mentioned their opinion to him, whereupon he said: There is no maintenance allowance for you. Then she sought permission to move (to another place), and he (the Holy Prophet) permitted her. She said: Allah's Messenger, where (should I go)? He said: To the house of Ibn Umm Maktum and, as he is blind, she could put off her garmeqts in his presence and he would not see her. And when her 'Idda was over. Allah's Apostle (may peace be upon him) married her to Usama b. Zaid. Marwan (the governor of Medina) sent Qabisa b. Dhuwaib in order to ask her about this hadith, and she narrated it to him, whereupon Marwan said: We have not heard this hadith but from a woman. We would adopt a safe (path) where we found the people. Fatima said that when these words of, Marwan were conveyed to her. There is between me and you the word of Allah, the Exalted and Majestic: Do" not turn them out" of their houses. She asserted: This is in regard to the revocable divorce what new (turn can the event take) after three pronouncements (separation between irrevocable). Why do you say there is no maintenance allowance for her if she is not pregnant? Then on what ground do you restrain her?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3519]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3519

Sha'bi reported: I visited Fatima bint Qais and asked her about the verdict of Allah's Messenger (may peace be upon him) about (board and lodging during the 'Idda) and she said that her husband divorced her with an irrevocable divorce. She (further. said): I contended with him before Allah's Messerger (may peace be upon him) about lodging and maintenance allowance, and she said: He did not provide me with any lodging or maintenance allowance, and he commanded me to spend the 'Idda in the house of Ibn Umm Maktum.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3520]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3520

A hadith like this has been trarismitted on the authority of Hushaim through another chain of narrators.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3521]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3521

Sha'bi reported: We visited Fitima hint Qais and she served us fresh dates and a drink of barley flour, and I asked where should a woman who has been divorced by three pronouncements, spend the period of her 'Idda. She said: My husband divorced me with three pronouncements, and Allah's Apostle (may peace be upon him) permitted me to spend my 'Idda period in my family (with my parents).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3522]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3522

Fatima bint Qais (Allah be pleased with her) reported from Allah's Messenger (may peace be upon him) that there is no lodging and maintenance allowance for a woman who has been given irrevocable divorce.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3523]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3523

Fatima bint Qais (Allah be pleased with her) reported: My husband divorced me with three pronouncements. I decided to move (from his house to another place). So I came to Allah's Messenger (may peace be upon him), and he said: Move to the house of your cousin 'Amr b. Umm Maktum and spend your period of 'Idda there.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3524]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3524

Abu Ishaq reported: I was with al-Aswad b. Yazid sitting in the great mosque, and there was with us al-Sha'bi, and he narrated the narration of Fatima bint Qais (Allah be pleased with her) that Allah's Messenger (may peace be upon him) did not make any provision for lodging and maintenance allowance for her. Al-Aswad caught hold of some pebbles in his fist and he threw them towards him saying: Woe be to thee, you narrate like it, whereas Umar said: We cannot abandon the Book of Allah and the Sunnah of our Apostle (may peace be upon him) for the words of a woman. We do not know whether she remembers that or she forgets. For her, there is a provision of lodging and maintenance allowance. Allah, the Exalted and Majestic, said:" Turn them not from their houses nor should they themselves go forth unless they commit an open indecency" (lxv. 1).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3525]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3525

A hadith like this has been narrated on the authority of Ishaq with the same chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3526]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3526

Fatima bint Qais (Allah be pleased with her) reported that her husband divorced her with three, pronouncements and Allah's Messenger (may peace be upon him) made no provision for her lodging and maintenance allowance. She (further said): Allah's Messenger (may peace be upon him) said to me: When your period of 'Idda is over, inform me. So I informed him. (By that time) Mu'awiya, Abu Jahm and Usama b. Zaid had given her the proposal of marriage. Allah's Messenger (may peace be upon him) said: So far as Mu'awiya is concerned, he is a poor man without any property. So far as Abu Jahm is concerned, he is a great beater of women, but Usama b. Zaid... She pointed with her hand (that she did not approve of the idea of marrying) Usama. But Allah's Messenger (may peace be upon himn) said: Obedience to Allah and obedience to His Messenger is better for thee. She said: So I married him, and I became an object of envy.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3527]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3527

Fatima bint Qais (Allah be pleased with her) reported: My husband Abu 'Amr b. Hafs b. al-Mughira sent 'Ayyish b. Abu Rabi'a to me with a divorce, and he also sent through him five si's of dates and five si's of barley. I said: Is there no maintenance allowance for me but only this, and I cannot even spend my 'Idda period in your house? He said: No. She said: I dressed myself and came to Allah's Messenger (may peace be upon him). He said: How many pronouncements of divorce have been made for you? I said: Three. He said what he ('Ayyish b. Abu Rabi'a) had stated was true. There is no maintenance allowance for you. Spend 'Idda period in the house of your cousin, Ibn Umm Maktum. He is blind and you can put off your garment in his presence. And when you have spent your Idda period, you inform me. She said: Mu'awiya and Abu'l-Jahm (Allah be pleased with them) were among those who had given me the proposal of marriage. Thereupon Allah's Apostle (may peace be upon him) said: Mu'awiya is destitute and in poor condition and Abu'l-Jahm is very harsh with women (or he beats women, or like that), you should take Usama b. Zaid (as your husband).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3528]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3528

Abu Bakr b. Abu'l-Jahm reported: I and Abu Salama b 'Abd al-Rahman came to fatima bint Qais (Al! ah be pleased with her) and asked her (about divorce, etc.). She said: I was the wife of Abu 'Amr b. Hafs b. al-Mughira, and he set out to join the battle of Najran. The rest of the hadith is the same, but he made this addition:" She said: I married him and Allah hornoured me on account of Ibn Zaid and Allah favoured me because of him."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3529]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3529

Abu Bakr reported: I and Abu Salama came to Fatima bint Qais (Allah be pleased with her) during the time of Ibn Zubair (Allah be pleased with him) and she narrated to us that her husband gave her an irrevocable divorce. (The rest of the hadith is the same.)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3530]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3530

Fatima bint Qais (Allah be pleased with her) reported: My husband divorced me with three pronouncements and Allah's Messenger (may peace be upon him) made no provision for lodging and maintenance allowance.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3531]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3531

Hisham reported on the authority of his father that Yahya b. Sa'id b. al-'As married the daughter of 'Abd al-Rahman b. al-Hakam, and he divorced her and he turned her out from his house. 'Urwa (Allah be -pleased with him) criticised this (action) of theirs (the members of the family of her in-laws). They said: Verily, Fatima too went out (of her in-laws' house). 'Urwa said: I came to 'A'isha (Allah be pleased with her) and told her about it and she said: There is no good for Fatima bint Qais (Allah be pleased with her) in making mention of it.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3532]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3532

Fatima bint Qais (Allah be pleased with her) reported that she said: Allah's Messenger, my husband has divorcee me with three pronouncements and I am afraid that I may be put to hardship, and so he commanded her and so she moved (to another house).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3533]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3533

'A'isha (Allah be pleased with her) said: It is no good for Fatima to make mention of it, i. e. her statement:" There is no lodging and maintenance allowance (for the divorced women)."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3534]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3534

Ibn al-Qasim narrated on the authority of his father that 'Urwa b. Zubair (Allah be pleased with him) said to 'A'isha (Allah be pleased with her): Didn't you see that such and such daughter of al-Hakam was divorced by her husband with an irrevocable divorce, and she left (the house of her husband)? Thereupon 'A'isha (Allah be pleased with her) said: It was bad that she did. He ( Urwa) said: Have you not heard the words of Fatima? Thereupon she said: There if no good for her in making mention of it.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3535]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3535

Jabir b. 'Abdullah (Allah be pleased with them) reported: My maternal aunt was divorced, and she intended to pluck her dates. A person scolded her for having come out (during the period of 'Idda). She came to Allah's Prophet (may peace be upon him.) and he said: Certainly you can pluck (dates) from your palm trees, for perhaps you may give charity or do an act of kindness.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3536]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3536

'Ubaidullah b. 'Abdullah b. 'Utba (b. Mas'ud) reported that his father wrote to Umar b. 'Abdullah b al Arqam al-Zuhri that he would go to Subai'ah bint al-Hirith al-Aslamiyya (Allah be pleased with her) and ask her about a verdict from him which Allah's Messenger (may peace be upon him) gave her when she had asked that from him (in regard to the termination of 'Idda at the birth of a child) 'Umar b. Abdullah wrote to 'Abdullah b. 'Utba informing him that Subai'ah had told him that she had been married to Sa'd b. Khaula and he belonged to the tribe of Amir b. Lu'ayy, and was one of those who participated in the Battle of Badr, and he died in the Farewell Pilgrimage and she had been in the family way at that time. And much time had not elapsed that she gave birth to a child after his death and when she was free from the effects of childbirth she embellished herself for those who had to give proposals of marriage. Abd al-Sunabil b. Ba'kak (from Banu 'Abd al-Dar) came to her and said: What is this that I see you embellished; perhaps you are inclined to marry, By Allah, you cannot marry unless four months and ten days (of 'Idda are passed). When he said that. I dressed myself, and as it was evening I came to Allah's Messenger (may peace be upon him) and asked him about it, and he gave me a religious verdict that I was allowed to marry when I had given birth to a child and asked me to marry if I so liked. Ibn Shihab said: I do not find any harm fur her in marrying when she has given birth to a child even when she is bleeding (after the birth of the child) except that her husband should not go near her until she is purified.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3537]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3537

Abu Salama b. 'Abd al-Rahman and Ibn 'Abbas. (Allah be pleased with them) got together in the house of Abu Huraira (Allah be pleased with him) and began to discuss about the woman who gave birth to a child a few nights after the death of her husband. Ibn 'Abbas (Allah be pleased with then) ) said: Her 'Idda is that period which is longer of the two (between four months and ten days and the birth of the child, whichever is longer). AbuSalama, however said: Her period of 'Idda is over (with the birth of the child), and they were contending with each other over this issue, whereupon Abu Huraira (Allah be pleased with him) said: I subscribe (to the view) held by my nephew (i. e. Abu Salama). They sent Kuraib (the freed slave of Ibn 'Abbas) to Umm Salama to ask her about it. He came (back) to them and informed them that Umm Salama (Allah be pleased with her) said that Subai'ah al-Aslamiyya gave birth to a child after the death of her husband when the few flights (had hardly) passed and she made mention of that to Allah's Messenger (may peace be upon him) and he commanded her to marry.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3538]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3538

This hadith has been narated with the same chain of transrmitters except with a small change of words (and that is): They sent him to Umm Salama, but no mention was made of Kuraib.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3539]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3539

Zainab (bint Abu Salama) (Allah be pleased with her) reported: I went to Umm Habiba, the wife of Allah's Apostle (may peace be upon him), when her father Abu Sufyan had died. Umm Habiba sent for a perfume having yellowness in it or something else like it, and she applied it to a girl and then rubbed it on her cheeks and then said: By Allah, I need no perfume but for the fact that I heard Allah's Messenger (may peace be upon him) say on the pulpit:" It is not permissible for a woman believing in Allah and the Hereafter to mourn for the dead beyond three days, but (in case of the death) of the husband it is permissible for four months and ten days." Zainab said: I then visited Zainab hint Jahsh (Allah be pleased with her) when her brother died and she sent for perfume and applied it and then said: By Allah, I don't feel any need for the perfume but that I heard Allah's Messenger (may peace be upon him) say on the pulpit:" It is not permissible for a woman believing in Allah and the Hereafbler to mourn the dead beyond three days except in case of her husband (for whom she can mourn) for four months and ten days." Zainab (Allah be pleased with her) said: I heard my mother Umm Salama (Allah be pleased with her) as saying: A woman came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger. I have a daughter whose husband has died and there has developed some trouble in her eye; should we apply collyrium to it? Thereupon Allah's Messenger (may peace be upon him) said: No (repeating it twice or thrice, saying only, NO" all the time). Then he said: It is only four mouths and ten days, whereas in the preIslamic period none of you threw away the dung until one year had passed. Humaid said: I said to Zainab: What is this throwing of dung until a year is passed? Zainab said: When the husband of a woman died, she went into a hut and put on her worst clothes, and did not apply perfume or something like it until a year was over. Then an animal like a donkey, or a goat, or a bird was brought to her and she rubbed her hand over it, and it so happened that one on which she rubbed her hand died. She then came out of her house and she was given dung and she threw it and then she made use of anything like perfume or something else as she liked.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3540]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3540

Zainab bint Umm Salama (Allah be pleased with her) reported that a relative of Umm Habiba (Allah he pleased with her) died. She sent for a yellow (perfume) and applied that to her forearm and said: I, am doing it, for I have heard Allah's Messenger (may peace be upon him) saying: It is not permissible for a woman believing in Allah and the Hereafter to mourn beyond three days except the husband (for whom she can mourn) for four months and ten days, This hadith was narrated by Zainab from her mother and from Zainab, the wife of Allah's Apostle (may peace be upon him), or from some other lady from among the wives of the Prophet (may peace be upon him).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3541]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3541

Zainab bint Umm Salama (Allah be pleased with her) reported on the authority of her mother that a woman lost her husband. (As her eyes were ailing) they (her kith and kin) entertained fear about her eyes, so they came to Allah's Apostle (may peace be upon him) and sought permission for the use of collyrium, whereupon Allah's Messenger (may peace be upon him) said: One among you used to spend one year in a dungeon dressed in worst clothes. (And at the end of this period) she threw dung at the dog which happened to pass that way and then she came out (of her 'Idda). Can't she (wait) even for four months and ten days?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3542]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3542

Humaid b. Nafi' narrated two traditions from Umm Salama dealing with collyrium and the other hadith from the wives of Allah's Prophet (may peace be upon him) except with this that no mention was made of Zainab.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3543]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3543

Zainab bint Abu Salama reported: Umm Salama and Umm Habiba (Allah be pleased with them) were talking with each other (and saying) that a woman came to Allah's Messenger (may peace be upon him) and mentioned to him that her daughter had lost her husband, and her eyes were sore and she wnted to use collyrium, whereupon Allah's Messenger (may peace be upon him) said: One among you used to throw dung at the end of a year, and now (this abstinence from adornment) is only for four months and ten days.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3544]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3544

Zainab bint Abu Salama reported that when the news of the death of Abu Safyan came to Umm Habiba she sent for yellow (perfume) on the third day and rubbed it on her forearms and on her cheeks and said: I had in fact no need of it, but I heard Allah's Messenger (may peace be upon him) as saying: It is not permissible for the women believing in Allah and the Hereafter to abstain from adornment beyond three days except (at the death of) husband (in which case she must abstain from adornment) for four months and ten days.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3545]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3545

Safiyya bint Abu 'Ubaid reported on the authority of Hafsa or 'A'isha (Allah be pleased with thein) or from both of them that Allah's Messenger (may peace he upon him) said: It is not permissible for a woman believing in Allah and the Hereafter (or believing in Allah and His Messenger) that she should observe mourning for the dead beyond three days except in case of her husband.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3546]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3546

A hadith like this is transmitted on the authority of Nafi'.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3547]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3547

Safiyya bint Abu 'Ubaid reported that she heard Hafsa daughter of Umar (Allah be pleased with them), (and) wife of Allah's Prophet (may peace be upon him), narrating a hadith like this from Allah's Apostle (may peace be upon him), and she made this addition:" She should abstain from adorning herself (in case of the death of her husband) for four months and ten days."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3548]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3548

Safiyya bint Abu 'Ubaid narrated this tradition of Allah's Prophet (may peace be upon him) on the authority of some wives of Allah's Apostle (may peace be upon him)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3549]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3549

'A'isha (Allah be pleased with her) reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a woman believing in Allah and the Hereafter to observe mourning on the dead for more than three (days), except in case of her husband.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3550]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3550

Umm 'Atiyya (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) had said: A woman must not observe mouriaing for one who had died for more than three (days) except for four months and ten days in the case of her husband. and she must not wear a dyed garment except one of the types made of dyed yarn, or apply collyrium, or touch perfume except a little perfume or incense, when she has been purified after her courses.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3551]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3551

A hadith like this has been narrated on the authority of Hisham with the same chain of narrators but with a slight variation of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3552]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3552

Umm 'Atiyya ('Allah be pleased with her) said: We were forbidden to observe mourning for the dead beyond three days except in the case of husband (where it is permissible) for four months and ten days, and (that during this period) we should neither use collyrium nor touch perfume, nor wear dyed clothes, but concession was given to a woman when one of us was purified of our courses to make use of a little incense or scent.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3553]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3553

Sahl b. Sa'd al-Sa'idi reported that'Uwaimir al-'Ajlani came to 'Asim b. 'Adi al-Ansari and said to him. Tell me about a person who finds a man with his wife; should he kill him, and be killed In retaliation; or how should he act? 'Asim, ask for me (religious verdict about it) from Allah's Messenger (may peace be upon him). So 'Asim asked Allah's Messenger (may peace be upon him) and he did not like this question and he disapproved of it so much that'Asim felt aggrieved at what he had heard from Allah's Messenger (may peace be upon him). When 'Asim came back to his family, 'Uwaimir came to him and said: 'Asim, what did Allah's Messenger (may peace be upon him) say to you? 'Asim said to 'Uwaimir: You did not bring something good. Allah's Messenger (may peace be upon him) did not like this religious verdict that I sought from him. 'Uwaimir said: By Allah, I will not rest until I have asked him about it. 'Uwaimir proceeded until he came to Allah's Messenger (may peace be upon him) as he was sitting amidst people, and said: Messenger of Allah, tell me about a person who found a man with his wife. Should he kill him, and then you would kill him, or how should he act? Thereupon Allah's Messenger (may peace be upon him) said: (Verses) have been revealed concerning you and your wife; so go and bring her. Sahl said that they both invoked curses (and further said): I was along with people in the company of Allah's Messenger (may peace be upon him). And when they had finished, Uwaimir said: Allah's Messenger, I shall have told a lie against her if I keep her (now). So he divorced her with three pronouncements before Allah's Messenger (may peace be upon him) had commanded him. Ibn Shihab said: Subsequently that was the practice of invokers of curses (al Mutala'inain)


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3554]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3554

Sahl b. Sa'd reported.. 'Uwaimir al-Ansari (Allah be pleased with him) from Banu'l-'Ajlan came to 'Asim b. 'Adi (Allah be pleased with him) the remaining part of the hadith is the same and it was also reecorded in it:" And subsequebtly the separation became the practice of al-Mutala'inain." And this addition was also made:" She was pregnant and her son was ascribed to her, and it became customary that such (a son) would inherit her and she would inherit him in the share prescribed by Allah for her.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3555]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3555

Ibn Shihab narrated about the invokers of curses and the practice of (li'an) based on the authority of Sahl b. Sa'd, of the tribe of Sa'ida. that a person from the Ansar came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, tell me about the person who found a man with his wife. The remaining part of the hadith is the same (but) with this addition: They invoked curses in the mosque and I was present there. And he narrated in the hadith: He divorced her with three pronouncements before Allah's Messenger (may peace be upon him) commanded him (to get separation). He separated from her in the presence of Allah's Apostle (may peace be upon him), whereupon he said: There is a separation between the invokers of curses.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3556]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3556

Sa'id b Jubair reported: I was asked about the invokers of curses during the reign of Mus'ab (b. Zubair) whether they could separate (themselves by this process). He said: I did not understand what to say. So I went to the house of Ibn 'Umar (Allah be pleased with them) in Mecca. I said to his servant: Seek permission for Me. He said that he (Ibn 'Umar) had been taking rest. He (Ibn 'Umar) heard my voice. and said: Are you Ibn Jubair? I said: Yes. He'said: Come in. By Allah, it must be some (great) need which has brought you here at this Hour. So I got in and found him lying on a blanket reclining against a pillow stuffed with fibres of date-palm. I said: O Abu'Abd al-Rahman, should there be separation between the invokers of curses? He said: Hallowed be Allah, yes, The first one who asked about it was so and so. he said: Messenger of Allah, tell me If one of us finds his wife committing adultery: what should he do? If he talks, that is something great, and if he keeps quiet that is also (something great) (which he cannot afford to do). Allah's Prophet (may peace be upon him) kept quiet (or some time). After some time he (that very person) came to him (Allah's Messenger) and said: I have been involved in that very cage about which I had asked you Allah the Exalted and Majestic then revealed (these) verses of Surah Nur:" Those who accuse their wives" (verse 6), and he (the Holy Prophet) recited them to him and admonished him, and exhorted him and informed him that the torment of the world is less painful than the torment of the Hereafter. He said: No, by Him Who sent you with Truth, I did not tell a lie against her. He (the Holy Prophet) then called her (the wife of that person who had accused her) and admonished her, and exhorted her, and informed her that the torment of this world is less painful than the torment of the Hereafter. She said: No, by Him Who sent thee with Truth, he is a liar. (it was) the man who started the swearing of oath and he swore in the name of Allah four times that he was among the truthful. and at the fifth turn he said: Let there be curse of Allah upon him if he were among the liars. Then the woman was called and she swore four times in the name of Allah that he (her husband) was among the liars, and at the fifth time (she said): Let there be curse upon her if he were among the truthful. He (the Holy Prophet) then effected separation between the two. A hadith like this is narrated by Ibn Numair with a slight variation of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3557]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3557

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) saying to the invokers of curse: Your account is with Allah. One of you must be a liar. You have now no right over this woman. He said: Messenger of Allah, what about my wealth (dower that I paid her at the time of marriage)? He said: You have no claim to wealth. If you tell the truth, it (dower) is the recompense for your having had the right to intercourse with her, and if you tell a lie against her, it is still more remote from you than she is. Zuhair said in his narration: Sufyan reported to us on the authority of 'Amr that he had heard Sa'id b Jubair saying: I heard Ibn Umar (Allah be pleased with them) saying that Allah's Messenger (may peace be upon him) had said it.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3558]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3558

Ibn 'Umar (Allah be pleased with them) said that Allah's Messenger (may peace be upon him) effected separation between the two members of Banu al-'Ajlan, and said: Allah knows that one of you is a liar. Is there one to repent among you?


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3559]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3559

Sa'id b. Jubair reported: I asked Ibn 'Umar (Allah be pleased with them) about invoking curse (li'an), and he narrated Similarly from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3560]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3560

Sa'id b. Jubair reported that Mus'ab b. Zubair did not effect separation between the Mutala'inain (invokers of curses). Sa'id said: It was mentioned to 'Abdullah b. Umar (Allah be pleased with them) and he said: Allah's Apostle (may peace be upon him) effected separation between the two members of Banu al-'Ajlan.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3561]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3561

Nafi' reported on the authority of Ibn Umar (Allah be pleased with them) that a person invoked curse on the wife during the lifetime of Allah s Messenger (may peace be upon him), so he effected separation between them and traced the lineage of the son to his mother.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3562]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3562

Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) asked a person from the Anger and his wife to invoke curse (upon one another in order to testify to their truthfulness), and then effected separation between them.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3563]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3563

A hadith like this has been narrated on the authority of 'Ubaidulah with the same chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3564]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3564

'Abdullah reported: We were on the night of Friday staying in the mosque when a person from the Ansar came there and said: If a person finds hiswoman along with a man, and he speaks about it, you would lash him, and if he kills, you will kill him, and if he keeps quiet he shall have to consume anger. By Allah, I will definitely ask about him from Allah's Mescenger (may peace be upon him). On the following day he came to Allah's Messenger (may peace be upon him) and asked him thus: If a man were to find with his wife a man and if he were to talk about it, you would lash him; and if he killed, you would kill him, and if he were to keep quiet. he would consume anger, whereupon he (the Holy Prophet) said: Allah, solve (this problem), and he began to supplicate (before Him), and then the verses pertaining to li'an were revealed:" Those who accuse their wives and have no witnesses except themselves" (xxiv. 6). The person was then put to test according to these verses in the presence of the people. There came he and his wife in the presence of Allah's Messenger (may peace be upon him), and they invoked curses (in order to testify their claim). The man swore four times in the name of Allah that he was one of the truthful and then invoked curse for the fifth time saying: Let there be curse of Allah upon him if he were among the liars. Then she began to invoke curse. Allah's Messenger (may peace be upon him) said to her: just wait (and curse after considering over it), but she refused and invoked curse and when she turned away, he (Allah's Apostle) said: It seems that this woman shall give birth to a curly-haired black child, And so she did gave birth to a curly-haired black child.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3565]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3565

A hadith like this is narrated on the authority of A'mash.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3566]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3566

Muhammad (one of the narrators) reported: I asked Anas b. Malik (Allah be pleased with him) knowing that he had a knowledge of (the case of li'an). He said: Hilal b. Umayya (Allah be pleased with him) accused his wife with the charge of fornication with Sharik b. Sahma, the brother of al-Bara'b Malik from the side of his mother. And he was the first person who invoked curse (li'an) in Islam. He in fact invoked curse upon her. Allah's Messenger (may peace be upon him) said: See to her if she gives birth to a white-complexioned child having dark hair and bright eyes; he must be the son of Hilal b. Umayya; and if she gives birth to a child with dark eyelids, curly hair and lean shanks, he must be the offspring of Sharik b. Sahma. He said: I was informed that she gave birth to a child having dark eyelids, curly hair and lean shanks.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3567]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3567

Ibn Abbas (Allah be pleased with them) reported: Mention was made of li'an in the presence of Allah's Messenger (may peace be upon him). And Asim b. 'Adi passed a remark about it and then turned away, and a man of his tribe came to him complaining that he had found a man with his wife, whereupon 'Asim said: I have been taken by my words. He took him to Allah's Messenger (may peace be upon him) and told him about the man whom he had found with his wife and this man was a lean, yellow-coloured man with lank hair, and the person who was accused of committing adultery with her (his wife) had fleshy shanks, with wheat complexion and heavy bulk. Allah's Messenger (may peace be upon him) said: O Allah, make (this case) manifest. And as she gave birth to a child, whose face resembled that person about whom her husband had made mention that he had found her with, and Allah's Messenger (may peace be, upon him) had asked them to invoke curses. A person said to Ibn 'Abbas (Allah be pleased with him): Is she (that woman) about whom Allah's Messenger (may peace be upen him) (said):" If I were to stone anybody without evidence, I would have stoned her"? Ibn 'Abbas (Allah be pleased with him) said: No, it is not she. That woman was one who openly spread evil in society. This hadith has been narrated on the authority of Ibn 'Abbas (Allah be pleased with them) through another chain of transmitters with the addition of these words: 'With flesh, and curly tangled hair."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3568]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3568

'Abdullah b Shaddad reported that mention was made about the invokers of curses before Ibn 'Abbas (Allah be pleased with them). Ibn Shaddad said: Are these the two about whom Allah's Apostle (clay peace be upon him) said." If I were to stone one without evidence, I would have definitely stoned her"? Ibn Abbas (Allah be pleased with them) said: She is not this woman; but she is the one who (committed adultery) openly.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3569]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3569

Abu Huraira (Allah be pleased with him) reported that Sa'd b. 'Ubada al-Ansari said: Messenger of Allah, tell the if a man finds his wife with another person, should he kill him? Allah's Messenger (may peace be upon him) said: No. Sa'd said: Why not? I swear by Him Who has honoured you with Truth. There upon Allah's Messenger (may peace be upon him) said: Listen to what your chief says.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3570]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3570

Abu Huraira (Allah be pleased with him) reported that Sa'd b. Ubada (Allah be pleased with him) said: Messenger of Allah, if I were to find with my wife a man, should I wait until I bring four witnesses? He said: Yes.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3571]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3571

Abu Huraira (Allah be pleased with him) reported that Sa'd b. Ubada (Allah be pleased with him) said: Messenger of Allah, if I were to find with my wife a man, should I not touch him before bringing four witnesses? Allah's Messenger (may peace be upon him) said: Yes. He said: By no means. By Him Who has sent you with the Truth, I would hasten with my sword to him before that. Allah's Messenger (may peace be upon him) said: Listen to what your chief says. He is jealous of his honour, I am more jealous than he (is) and God is more jealous than I.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3572]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3572

AI-Mughira b. Shu'ba (Allah be pleased with him) reported that Sa'd b. 'Ubada (Allah be pleased with him) said: If I were to see a man with my wife, I would have struck him with the sword, and not with the flat part (side) of it. When Allah's Messenger (may peace be upon him) heard of that, he said: Are you surprised at Sa'd's jealousy of his honour? By Allah, I am more jealous of my honour than he, and Allah is more jealous than I. Because of His jealousy Allah has prohibited abomination, both open and secret And no person is more jealous of his honour than Allah, and no persons, is more fond of accepting an excuse than Allah, on account of which He has sent messengers, announcers of glad tidings and warners; and no one is more fond of praise than Allah on account of which Allah has promised Paradise.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3573]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3573

A hadith like this has been transmitted on the authority, of 'Abd al-Malik b. Umair with the same chain of narraters but with a slight change of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3574]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3574

Abu Huraira (Allah be pleased with him) reported: There came a person to the Holy Prophet (may peace he upon him) ) from Banu Fazara and said: My wife has given birth to a child who is black, whereupon Allah's Apostle (may peace be upon him) said: Have you any camels? He said: Yes. He again said: What is this colour? He said: They are red. He said: Is there a dusky one among them? He said: Yes, there are dusky ones among them He said: How has it come about? He said: It is perhaps the strain to which it has reverted, whereupon he (the Holy Prophet) said: It is perhaps the strain to which he (the child) has reverted.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3575]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3575

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters. In the hadith transmitted on the authority of Ma'mar, the (words are):" Messenger of Allah, my wife has given birth to a dark-complexioned boy, and he at that time was intending to disown him." And this addition has been made at the end of the hadith:" He (the Holy Prophet) did not permit him to disown him."


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3576]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3576

Abu Huraira (Allah be pleased with him) reported: A desert Arab came to Allah's Messenger (may peace be upon him) and said: My wife has given birth to a dark-complexioned child and I have disowned him. Thereupon Allah's Apostle (may peace be upon him) said: Have you any camels? He said: Yes. He said: What is their colour? He said? They are red. He said: Is there anyone dusky among them? He said: Yes. Allah's Messenger (may peace be upon him) said: How has it come about? He said: Messenger of Allah, it is perhaps due to the strain to which it has reverted, whereupon the Holy Prophet (may peace be upon him) said: It (the birth) of the black child may be due to the strain to which he (the child) might have reverted.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3577]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3577

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3578]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3578

Ibn Umar (Allah be pleased with them) reported Allah's Messenger may peace be upon him) as saying: If anyone emancipates his share ina slave and has enough money to pay the full price for him, a fair price for the slave should be fixed, his partners given their shares, and the slave be thus emancipated, otherwise he is emancipated only to the extent of the first man's share.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3579]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3579

This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3580]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3580

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The slave who is jointly owned by two persons, and is emancipated by one of them, (this one) has liability (upon him to secure complete freedom for that slave).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3581]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3581

Abu Huraira (Allah be pleased witli him) reported Allah's Prophet (may peace be upon him) as saying: If anyone emancipates a share in a slave, he is to be completely emancipated if he has money; but if he has none, the slave will be required to work to pay for his freedom, but must not be over-burhened.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3582]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3582

This hadith has been narrated on the authority of Sa'id b. Abu 'Aruba with the same chain of transmitters but with the addition:" If he (one of the joint owners emancipating the slave) has not (enough) money (to secure freedom for the other half) a fair price for the slave should be fixed, and he will be required to work to pay for his freedom, but must not be over-burdened.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3583]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3583

A hadith like this is reported on the authority of the same chain of transmitters but with a slight change of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3584]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3584

Ibn Umar reported that 'A'isha decided to buy a slave-girl and then set her free, but her masters said: We are prepared to sell her to you on the condition that her right of inheritance would vest with you. She (Hadrat A'isha) made a mention of that to Allah's Messenger (may peace be upon him) whereupon he said: This should not stand in your way. The right of inheritance vests in one who emancipates.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3585]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3585

'A'isha (Allah be pjeased with her) reported that Barira came to her in order to seek her help in securing freedom, but she had (so far) paid nothing out of that sum stipulated in the contract. 'A'isba said to her. Go to your family (who owns you), and if they like that I should pay the amount (of the contract) on your behalf (for purchasing your freedom), then I shall have the right in your inheritance. (If they accepted it) I am prepared (to make this payment). Barira made a mention of that to the (members of) her family, but they refused and said: If she (Hadrat 'A'isha) wants to do good to You for the sake of Allah, she may do it, but the right of inheritance will be ours. She (Hadrat 'A'isha) made a mention of that to Allah's Messenger (may peace be upon him), and he said to her: Buy her, and emancipate her, for the right of inheritance vests with one who emancipates (the slave). Allah's Messenger, may peace be upon him) then stood up and said: What has happened to the people that they lay down conditions which are not (found) in the Book of Allah? And he who laid down a condition not found in the Book of Allah, that is not valid. even if it is laid down hundred times. The condition laid down by Allah is the most weighty and the most valid.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3586]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3586

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported: Barira came to me and said: 'A'isha, I have entered into contract for securing freedom with my family (who owns me) for nine 'uqiyas (of silver), one 'uqiya every year The rest of the hadith is the same (but with this addition):" This (the problem of the right of inheritance) should not stand in your way. Buy her, and set her free. He said in a hadith: Allah's Messenger (may peace be upon him) stood up among men, extolled Allah, praised Him, and then said:" for......"


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3587]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3587

'A'isha (Allah be pleased with her) reported: Barira came to me and said: My family (owners) have made contract with me (for granting freedom) for nine 'uqiyas (of silver) payable in nine years, one 'uqiya every year. Help me (in making this payment). I said to her: If your family so desires, I am prepared to make them the full payment in one instalment, and thus secure freedom for you, but the right of inheritance will vest in me, if I do so. She (Barira) made a mention of that to her family, but they refused (except) on the condition that the right of inheritance would vest in them. She came to me and made mention of if She ('A'isha) said: I scolded her. She (Barira) said: By Allah, it is not possible (they will never agree to it). And as she was saying it, Allah's messenger (may peace be upon him) heard, and he asked me, I informed him and he said: Buy her and emancipate her, and let the right of inherit- ance vest in them, for they cannot claim it (rightfully) since the right of inherritance vests with one who emancipates (the slave; therefore, these people have no right to lay such false claims). And I did so. She ('A'isha) said: Then Allah's Messenger (may peace be upon him) delivered a sermon in the evening. He extolled Allah and praised Him with what He deserves, and then said afterwards,: What has happened to the people that they lay down conditions which are not found in the Book of Allah? And the condition which is not found in the Book of Allah is invalid, even if its number is one hundred. The Book of Allah is more true (than any other deed) and the condition laid down by Allah is more binding (than any other condition). What has happened to the people among you that someone among you says:" Emancipate so and so, but the right of inheritance vests in me"? Verily, the right of inheritance vests in one who emancipates.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3588]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3588

Hisham b. 'Urwa narrated a hadith like this with the same chain of trans- mitters except (with this change) that in the hadith transmitted on the authority of jartr (the words are): Her (Barira's) husband was a slave, so Allah's Messenger (may peace be upon him) gave her the option (either to retain her matrimonial relation with her husband or sever it off). She opted to break off (and secure freedom for her even from the matrimonial alliance). And if he were free he would not have given her the option. In the hadith narrated on the authority (of this chain of transmitters) these words are not found: Amma ba'du.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3589]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3589

'Abd al-Rahman b. al. Qasim reported on the authority of his father: 'A'isha (Allah be pleased with her) said: There were three issues which were clarified in case of Barira: her owners had decided to sell her on the condition that the right of her inheritance would vest with them. She ('A'isha) said: I made a mention of that to Allah's Apostle (may peace be upon him) and he said: Buy her and emancipate her, for verily the right of inheritance vests with one who emancipates. She said that she emancipated (her) and Allah's Messenger (may peace be upon him) gave her the option (either to retain her matrimonial alliance or break it after emancipation). She (taking advantage of the option) opted for herself (the severing of matrimonial alliance). 'A'isha said: The people used to give her charity and she gave us that as gift. I made a mention of it to Allah's Apostle (may peace be upon him), whereupon he said: That is charity for her but gift for you, so take that.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3590]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3590

'A'isha (Allah's be pleased with her) reported that she had bought Barira from the people of Ansar, but they laid down the condition that the right of inheritance (would vest in them), whereupon Allah's Messenger (may peace be upon him) said: The right of inheritance vests with one who shows favour (who emancipates) and Allah's Messenger (may peacebe upon him) gave her the choice (either to retain) her matrimonial alliance or break it). Her husband was a slave. She (Barira also) gave 'A'isha some meat as gift. Allah's Messenger (may peace be upon him) said: I wish you could prepare (cook) for us out of this meat. 'A'isha said, It has been given as charity to Barira, whereupon he said: That is charity for her and gift for us.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3591]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3591

'A'isha (Allah be pleased with her) reported: She wanted to buy Barira with a view to emancipating her. They (the sellers) laid down the condition that the right of inheritance would vest (with them). She (Hadrat 'A'isha) made a mention of that to Allah's Messenger (may peace be upon him), whereupon he said: Buy her and emancipate her for the right of inheritance vests with one who emancipates. Allah's Messenger (may peace be upon him) was given meat as gift. They (his Companions) said to Allah's Apostle (may peace be upon him): This was given as charity to Barira, whereupon he said: That is charity for her but gift for us. And she was given option (to retain her matrimonial alliance or to break it). Abd al-Rahman said: Her husband was a free man. Shu'ba said: I then asked him (one of the narrators) about Barira's husband (whether he had been a free mart or a slave), whereupon he said: I do not know.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3592]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3592

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3593]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3593

'A'isha reported that the husband of Barira was a slave.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3594]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3594

'A'isha (Allah be pleased with her). the wife of Allah's Apostle (may Peace be upon him) said: Three are the Sunan (usages) (that we came to know in case of Bairara). She was given option in regard to her husband when she was emancipated. Sbe was given meat as charity. Allah's Messenger (way peace be upon him) visited me when an earthen pot with meat in it was placed on the fire. He asked for food and be was given bread with ordinary meat (usually cooked in the) house. Thereupon he (Allah's Messenger) said: Don't I see the earthen pot on fire with meat in it? They said: Yes. Allah's Messenger, there is meat in it which was given as charity to Barira. We did not deem it advisable that we should give you that to eat, whereupon he said: It is charity for her, but it is gift for us. Allah's Apostle (may peace be upon him) also said: The right of inheritance vests with one who emancipates.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3595]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3595

Abu Huraira (Allah be pleased with him) reported: 'A'isha (Allah be pleated with her) thought of buying a slave-girl and emancipating her, but her owners refused to (sell her but on the condition) that the right of inheritance would vest in them. She made a mention of that to Allah's Messenger (may peace be upon him). whereupon he said: Let this (condition) not stand in your way for the right of inheritance vests with one who emancipates.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3596]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3596

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace he upon him) forbade the selling and making a gift of the right of inheritance of a slave. Imam Muslim said: All the persons depend upon Abdullah b. Dinar in regard to this hadith.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3597]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3597

This hadith has been narrated on the authority of Ibn 'Umar (Allah be pleased with them) through another chain of transmitters but with this change that in tba hadith narrated by al-Thaqafi from Ubaidullah there is only a mention of selling (or right of inheritance, al-Wala' ) but not that of making a gift.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3598]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3598

Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Apostle (may peace be upon him) made it obligatory for every tribe (the payment) of blood-wit; he then also made it explicit that it is not permissible for a Muslim to make himself the ally (of the slave emancipated by another) Muslim without his permission. He (the narrator further added): I was informed that he (the Holy Prophet) cursed the one who did that (and it was recorded) in his Sahifa (in a document).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3599]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3599

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) said: He who takes anyone as his ally without the consent of his previous master, there will be the curse of Allah and that of His angels upon him, and neither, any obligatory act of his nor the supererogatory one will be accepted (by Allah).


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3600]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3600

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: He who took the freed slave as his ally without the consent of his previous master, there is upon him the curse of Allah and that of His angels and that of the whole mankind, and there will not be accepted from him his obligatory acts or supercrogatory acts on the Day of Resurrection. This hadith is narrated through the same chain of transmitters, but with a slight change of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3601]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3601

Ibrahim al-Taimi reported on the authority of his father: 'Ali b. Abu Talib (Allah be pleased with him) addressed us and said: He who thinks that we (the members of the Prophet's family) read anything else besides the Book of Allah and this Sahifa (and he said that Sahifa was tied to the scabbard of the sword) tells a lie. (This Sahifa) contains (problems) pertaining to the ages of the camels and (the recompense) of the injuries, and it also records the words of the Prophet (may peace be upon him): Medina is a sacred territory from 'Ayr to Thaur (it is most probably Uhud). He who innovates (an act or practice) or gives protection to an innovator, there is a curse of Allah and that of His angels and that of the whole humanity upon him. Allah will not accdpt from him (as a recompense) any obligatory act or supererogatory act, and the responsibility of the Muslims is a joint responsibility; even the lowest in rank can undertake the responsibility (on behalf of others), and he who claims anyone else as his father besides his own father or makes one his ally other than the one (who freed him), there is a curse of Allah. that of His angels and that of the wholemankind upon him. Allah will not accept the obligatory act of the supererogatery act (as a recompense) from him.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3602]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3602

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: If anyone emancipates a Muslim slave, Allah will set free from Hell an organ of his body for every organ of his (slave's) body.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3603]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3603

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace benpon him) as saying: He who emancipates a slave, Allah will set free from Hell every limb (of his body) for every limb of his (slave's) body, even his private parts.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3604]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3604

Abu Huraira (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) as saying: He who emancipates a believing slave. Allah will set free from Fire his every limb for every limb of his (slave's), even his private parts for his.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3605]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3605

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A Muslim who emancipates a Muslim (slave). Allah will save from Fire every limb of his for every limb (of the slave). Sa'id b. Marjana said: When I heard this hadith from Abu Huraira (Allah be pleased with him), I went away and made a mention of it to 'Ali b. Husain and he at once emancipated the slave for which Ibn ja'far was prepared to pay ten thousand dirhams or one thousand dinars.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3606]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3606

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A son does not repay what he owes his father unless he buys him (the father) in case he is a slave and then emancipates him. In the narration transmitted by Ibn Abu Shaiba there is a slight change of words.


Muslim :: The Book of Divorce (Kitab Al-Talaq) :: [9.3607]

The Book of Divorce (Kitab Al-Talaq)

Muslim :: Book 9 : Hadith 3607

A hadith like this has been narrated on the authority of Suhail with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3608]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3608

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade (two types of transactions) Mulamasa and Munabadha


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3609]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3609

Abu Huraira (Allah be pletsed with him) reported like this from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3610]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3610

Abu Huraira reported from Allah's Messenger (may peace be upon him) a hadith like this through another chain cf transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3611]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3611

A hadith like this has been narrated on the authority of Abu Huraira (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3612]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3612

Abu Huraira (Allah be pleased with him) reported: Two types of trarisactions have been forbidden (by the Holy Prophet), al-Mlulamasa and al-Munabadha. As far as Mulamasa transaction is concerned, it is that every one of them (the parties entering into transaction) should touch the garment of the other without careful consideration, and al-Munabadha is that every one of them should throw his cloth to the other and one of them should not see the cloth of his friend.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3613]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3613

Abu Sa'id al-Khudri (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) forbade us (from), two types of business transactions and two ways of dressing. He forbade Mulamasa and Munabadha in transactions. Mulamasa means the touching of another's garment with his hand, whether at night or by day, without turning it over except this much. Munabadha means that a man throws his garment to another and the other throws his garment, and thus confirming their contract without the inspection of mutual agreement. This hadith has been narrated on the authority of Ibn Shihab through the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3614]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3614

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade a transaction determined by throwing stones, and the type which involves some uncertainty.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3615]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3615

'Abdullah (b. 'Umar) (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) forbade the transaction called habal al-habala.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3616]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3616

Ibn 'Umar (Allah be pleased with them) reported that the people of pre-Islamic days used to sell the meat of the slaughtered camel up to habal al-habala. And habal al-habala implies that a she-camel should give birth and then the (born one should grow young) and become pregnant. Allah's Messenger (may peace be upon him) forbade them that (this transaction).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3617]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3617

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as having said this: One amongst you should not enter into a transaction when another is bargaining.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3618]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3618

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: A person should not enter into a transaction when his brother is already making a transaction and he should not make a proposal of marriage when his brother has already made a proposal except when lie gives permission.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3619]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3619

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A Muslim should not purchase (in opposition) to his brother. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight change of words.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3620]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3620

Abu Huraira reported Allah's Messenger (may peace'be upon him) as saying: Do not go out to meet riders to enter into transaction with them; none of you must buy in opposition to another, nor must you bid against one another; a townsman must not sell for a man from the desert, and do not tie up udders of carnels and sheep, and he who buys them after that has been done has two courses open to him: after he has milked them he may keep them if he is pleased with them, or he may return them along with a sit of dates if he is displeased with them.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3621]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3621

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the (people) meeting the caravan (for entering into business transaction with them), and the selling of goods by a townsman on behalf of a man of the desert, and seeking by a woman the divorce of her sister (from her husband), and outbidding (against one another), and tying up the udders (of animals), and buying of (things) in opposition to one's brother. This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3622]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3622

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the outbidding (against another).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3623]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3623

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Do not go out to meet merchandise in the way, (wait) until it is brought into the market. This hadith has been reported on the authority of Ibn Numair but with a slight change of words.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3624]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3624

This hadith has been reported on the authority of 'Ubaidullah.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3625]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3625

Abdullah (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Do not meet the traders (in the way).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3626]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3626

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) as saying: Do not meet the merchandise (in the way).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3627]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3627

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not meet the merchant in the way and enter into business transaction with him, and whoever meets him and buys from him (and in case it is done, see) that when the owner of (merchandise) comes into the market (and finds that he has been paid less price) he has the option (to declare the transaction null and void).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3628]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3628

Abu Huraira (Allah be pleased with him) reported it directly from Allah's Apostle (may peace be upon him): The townsman'should not sell for a man from the desert (with a view to taking advantage of his ignorance of the market conditions of the city). And Zuhair reported from the Holy Prophet (may peace be upon him) that he forbade the townsman to sell on behalf of the man from the desert.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3629]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3629

Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: The riders (carrying merchandise) should not be met in the way, and townsman should not sell for a man of the desert. The narrator reported. I said to Ibn 'Abbas: What do these words really imply-" The townsman for the man of the desert"? He said: That he should work as a broker on his behalf.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3630]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3630

Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The townsman should not sell for a man from the desert, leave the people alone, Allah will give them provision from one another. Yahya reported it with a slight change of words.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3631]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3631

Jabir (Allah be pleased with him) reported a similar hadith from Allah's Apostle (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3632]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3632

Anas b. Malik (Allah be pleased with him) reported: We were forbidden that a townsman should sell for a man of the desert, even if he is his brother or father.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3633]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3633

Anas b. Malik (Allah be pleased with him) said: We were forbidden that a townsman should sell for a man of the desert.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3634]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3634

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be'upon him) as saying: He who bought a goat having its udder tied up should go back with it, milk it, and, if he is satisfied with its milk, he should retair it, otherwise he should return it along with a sa' of dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3635]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3635

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who buys a goat with its udder tied up has the option to retain the goat if he so desires or return it within three days, and in case he returns it he should do so along with a sa' of dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3636]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3636

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: lie who buys a goat having its udder tied up has the option to return it within three days. If he returns it he should pay a sa' of dates. Wheat is not essential.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3637]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3637

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who buys a goat having its udder tied up has two courses left for him. He may retain it, and if he desires may return it along with a sa' of dates and not wheat.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3638]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3638

Ayyub narrated with the same chain of transmitters but with this change of words:" He who buys a goat has the option...."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3639]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3639

Hammam b. Munabbih said: Out of the ahadith which Abu Huraira (Allah be pleased with him) reported to us from Allah's Messenger (may peace be upon him) one is this that Allah's Messenger (may peace be upon him) said: If one among you buys a she-camel having its udder tied up he has the two options for him after milking it either (to retain it) or return it with a sa' of dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3640]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3640

Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it until he has taken possession of it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3641]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3641

A hadith like this has been narrated through the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3642]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3642

Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys food-rain should not sell it until he has taken possession of it. Ibn Abbas (Allah be pleased with them) said: I regard everything like food (so far as this principle is concerned).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3643]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3643

Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it, until he has weighed it (and then taken possession of it). I (Tawus) said to Ibn Abbas (Allah be pleased with them): Why is it so? Thereupon he said: Don't you see that they (the people) sell foodgrains against gold for the stipulated time. Abu Kuraib did not make any mention of the stipulated time.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3644]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3644

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell it until he has taken full possession of it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3645]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3645

Ibn Umar (Allah be pleased with them) reported: We used to buy foodgrains during the lifetime of Allah's Messenger (may peace be upon him). He (the Holy Prophet) would then send to us one who commanded us to take them (the foodgrains) to a place other than the one where we had bought them before we sold it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3646]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3646

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who buys foodgrain should not sell that before taking possession of it. He (the narrator) said: We used to buy foodgrain from the caravans in bulk, but Allah's Messenger (may peace be upon him) forbade us to re-sell that until we had shifted it to some other place.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3647]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3647

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who bought foodgrain should not sell it until he had taken full possession of it (after measuring it).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3648]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3648

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying,: He who bought foodgrain should not sell it until he had taken possession of it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3649]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3649

Ibn 'Umar (Allah be pleased with them) reported that they were beaten during the lifetime of Allah's Messenger (may peace be upon him) if they had bought foodgrains in bulk and then sold them in the spot without shifting them (to some other place).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3650]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3650

Salim b. 'Abdullah (Allah be pleased with them) reported his father havingsaid this: I saw people being beaten during the lifetime of Allah's Messenger (may peace be upon him) in case they bought the foodgrain in bulk, and then sold them at that spot before taking it to their places. This hadith is narrated on the authority of 'Ubaidullah b. Abdullah b. 'Umar through another chain of transmitters (and the words are):" His father (Ibn 'Umar) used to buy foodgrains in bulk and then carried them to his people."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3651]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3651

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who bought foodgrain should not sell it until he had measured it. In the narration of Abu Bakr there the word is Ibta' instead of Ishtara.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3652]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3652

Abu Huraira (Allah be please with him) is reported to have said to Marwan: Have you made lawful the transactions involving interest? Thereupon Marwan said: I have not done that. Thereupon Abu Huraira (may peace be upon him) said: You have made lawful the transactions with the help of documents only, whereas Allah's Messenger (may peace be upon him) forbade the transaction of foodgrains until full possession is taken of them. Marwan then addressed the people and forbade them to enter into such transactions (as are done with the help of documents). Sulaiman said: I saw the sentinels snatching (these documents) from the people.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3653]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3653

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: When you purchase foodgrains, do not sell them until you have taken possession of them.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3654]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3654

Jabir b. Abdullah (Allah be pleased with them) is reported to have said that Allah's Messenger (may peace be upon him) forbade the sale of a heap of dates the weight of which is unknown in accordance with the known weight of dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3655]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3655

This hadith is narrated on the authority of Jabir b. Abdullah (Allah be pleased with them) but with this variation that no mention is made of the dates (which one finds) at the end of the previous hadith.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3656]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3656

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Both parties in a business transaction have the right to annul it so long as they have not separated; except in transactions which have been made subject to the right of parties to annul them.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3657]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3657

This hadith has been narrated on the authority of Ibn 'Umar (Allah be pleased with them) through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3658]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3658

Ibn 'Umar (Allah be pleased with thcm) reported Allah's Messenger (may peace be upon him) as saying: When two persons enter into a transaction, each of them has the right to annul it so long as they are not separated and are together (at the place of transaction) ; or if one gives the other the right (to annul the transaction) But if one gives the other the option, the transaction is made on this condition (i. e. one has the right to annul the transaction), it becomes binding. And if they are separated after they have made the bargain and none of them annulled it, even then the transaction is binding.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3659]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3659

Abdullah b. 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: When two persons enter into a transac. tion, each one of them has the right to annul it so long as they are not separated, or their transaction gives one another (as a condition) the right of annulling, and if their transaction, has the right of annulling it the transaction becomes binding. Ibn Abi Umar made this addition that whenever he (Ibn Umar) entered into a transaction with a person with the intention of not breaking it, he walked a while and then returned to him.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3660]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3660

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: There is no transaction between two persons entering a transaction until they separate, but only when there is an option to annul it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3661]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3661

Hakim b. Hazim (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Both parties in a business transaction have the right to annul it so long as they have not separated; and if they speak the truth and make everything clear they will be blessed in their transaction; but if they tell a lie and conceal anything the blessing on their transaction will be blotted out.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3662]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3662

A hadith like this has been transmitted on the authority of Hakim b. Hizam (Imam Muslim) said: Hakim b. Hizam was born inside the Ka'ba and lived for one hundred and twenty years.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3663]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3663

Abdullah b. Dinar narrated that he heard Ibn 'Umar (Allah be pleased with them) saying: A man mentioned to the Messenger of Allah (may peace be upon him) that he was deceived in a business transaction, whereupon Allah's Messenger (may peace be upon him) said: When you enter into a transaction, say: There should be no attempt to deceive.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3664]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3664

This hadith has been narrated on the authority of 'Abdullah b. Dinar with the same chain of transmitters but these words are not found in it." When he buys he should say: There should be no attempt to deceive."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3665]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3665

Ibn 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the sale of fruits until they were clearly in good condition, he forbade it both to the seller and to the buyer.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3666]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3666

Ibn 'Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the sale of palm-trees (i. e. their trults) until the dates began to ripen, and ears of corn until they were white and were safe from blight. He forbade the seller and the buyer.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3667]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3667

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Do not buy fruit until its good condition becomes clear, and (the danger) of blight is no more. He said: Its good condition becoming clear implies that it becomes red or yellow.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3668]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3668

This hadith is reported or the authority of Yahya with the same chain of transmitters up to" until its good condition becomes clear," but lie did not mention what follows (these words).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3669]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3669

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3670]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3670

Nafi, reported on the authority of Ibn Umar (Allah be pleased with them) a hadith like that narrated before.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3671]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3671

Ibn Umar (Allah be pleased with them) reported Allah's Messenger' (may peace be upon him) as saying: Do not buy fruits (on the trees) until their good condition becomes clear. In the hadith transmitted on the authority of Shu'ba it was stated that Ibn Umar (Allah be pleased with them) was asked what good condition implied. He said: When (the danger of) blight is no more.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3672]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3672

Jabir (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade (or forbade us) the sale of fruits until they are ripe in a good condition.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3673]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3673

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding the sale of fruit until its good condition is obvious.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3674]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3674

Abu Bakhtari reported: I asked Ibn 'Abbas (Allah be pleased with them) about the sale of dates. He said: Allah's Messenger (may peace be upon him) forbade the sale of dates of the trees until one eats them or they are eaten (i. e. they are fit to be eaten) or until they are weighed (or measured). I said: What does it imply:" Until it is weighed"? Thereupon a person who was with him (Ibn Abbas) said: Until he is able to keep it with him (after plucking them).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3675]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3675

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not sell the fruits until their good condition becomes evident."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3676]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3676

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) forbidding the sale of fruits until their good condition becomes evident and the purchase of dates for dates. Zaid b. Thabit (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) gave a concession in case of the sale known as al-araya, there is an addition of the word an tuba'a in the hadith transmitted by Ibn Numair.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3677]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3677

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not buy the fruit until their condition is clear, and do not buy the fresh dates. A hadith like this has been reported by Ibn 'Umar through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3678]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3678

Sa'id b. al-Musayyib said that Allah's Messenger (may peace be upon him) forbade the transaction of Af Muzabana and Muhaqala. Muzabana means that fresh dates on the trees should be sold against dry dates. Muhaqala implies that the wheat in the ear should be sold against the wheat and getting the land on rent for the wheat (produced in it). He (the narrator) said that the Holy Prophet (may peace be upon him) had aid: Do not sell fresh fruits on the trees until their good condition becomes manifest, and do not sell fresh dates on the trees against dry dates. Salim said: Abdullah informed me on the authority of Zaid b. Thabit, Allah's Messenger (may peace be upon him) having given concession afterwards in case of ariyya transactions by which dry dates can be exchanged with fresh dates, but he did not permit it in other cases.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3679]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3679

Zaid b. Thabit (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) having given concession in case of 'ariyya for selling dry dates (with) fresh dates after measuring them out.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3680]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3680

Zaid b. Thabit reported that Allah's Messenger (may peace be upon him) give concession in case of 'ariyya transactions according to which the members of the household give dry dates according to a measure and then eat fresh dates (in exchange for it)


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3681]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3681

A hadith like this has been narrated on the authority of Nafi' with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3682]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3682

Yahya b. Sa'id reported this hadith with the same chain of transmitters but with this change: 'Ariyya implies that date-palm trees should be donated to the people and then they sell it with a measure of dry dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3683]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3683

Zaid b Thabit (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) gave concession in case of al-'ariyya transactions (for exchanging dates) for dates with measure. Yahya said: 'Ariyya implies that a person should buy fresh dates on the tree for his family to eat against a measure of dry dates.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3684]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3684

Zaid b. Thabit (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) granting concession in case of 'ariyya transactions and that implies selling of (dry dates for fresh dates) according to a measure.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3685]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3685

Ubaidullah reported this hadith with a slight change of words on the same authority (as quoted above).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3686]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3686

Nafi, reported this hadith with the same chain of transmitters stating that Allah's Messengtr (may peace be upon him) granted concession in case of 'ariyya transactions (for exchange of the same commodity) with measure.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3687]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3687

Bashair b. Yasir reported on the authority of some of the Companions of Allah's Messenger (may peace be upon him) among the members of his family among whom one was Sahl b. Abu Hathma that Allah's Messenger (may peace be upon him) forbade buying of fresh dates against dry dates and that it is Riba and this is Muzabana, but he made an exemption of 'ariyya (donations) of a tree or two in which case the members of a family sell dry dates and buy fresh dates for eating them.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3688]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3688

Bushair b. Yasar reported on the authority of some of the Companion of Allah's Messenger (may peace be upon him) that he exempted the transactions, of 'ariyya (from the direct exchange of one kind) after measuring the dry dates (in exchange for fresh dates).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3689]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3689

Bushair b. Yasir reported on the authority of some of the Companions of Allah's Messenger (may peace be upon hinn) from among the members of his family that he forbade (the direct exchange of a commodity having different qualities) but with the change that Ishaq and Ibn al-Muthanna used the word Zabn in place ot Riba and Ibn Abu 'Umar used the word Riba (interest).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3690]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3690

A hadith like this has been narrated on the authority of Sahl b. Abu Hathma.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3691]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3691

Sahl b. Abu Hathma reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, i. e. exchange of fresh dates with dry dates. except in case of those to whom donations of some trees have been made. It is for them that concession has been given.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3692]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3692

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having given exemption of 'ariyya transactions measuring less than five wasqs or up to five wasqs (the narrator Dawud is in doubt whether it was five or less than five).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3693]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3693

Ibn Umar (Allah be pleased them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana implies the selling of fresh dates for dry dates by measuring them out and the selling of raisins by measure for grapes.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3694]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3694

'Abdullah (b. Umar) reported that Allah's Apostle (may peace be upon him) forbade Muzabana, i. e. buying of fresh dates (on) the trees for dry dates by measure, and the buying of grapes for raisins by measure and the selling of field of corn for corn by measure.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3695]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3695

A hadith like this has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3696]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3696

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana is the selling of dry dates by measure for fresh dates and the selling of raisins by measure for grapes and selling of all Ports of fruits on the basis of calculation.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3697]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3697

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Muzabana, and Muzabana implies the selling of dry dates for fresh dates on the tree with a definite measure (making it clear) that in case it increases, it belongs to me and if it is less, it is my responsibility.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3698]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3698

A hadith like this has been transmitted on the authority of Ayyub.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3699]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3699

Abdullah (b. Umar) (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden Mazabana, and it implies that one should sell the fresh fruits of his orchard (for dry fruits) or, if it is fresh dates, for dry dates with a measure, or if it is grapes for raisins or if it is corn in the field for dry corn with a measure He (the Holy Prophet) in fact forbade all such transactions. Qutaiba has narrated it with a slight variation of words. This hadith has been narrated on the authority of Nafi with another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3700]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3700

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: If anyone buys palm-trees after they have been fecundated the fruit belongs to the seller unless the buyer makes a proviso.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3701]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3701

Nafi reported on the authority of Ibn Umar (Allah be pleased with them) that the Messenger of Allah (may peace be upon him) said: Whichever tree is bought with its roots, and if it is fecundatedits fruit would belong to one who has grafted it except when the provision is laid down by the buyer.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3702]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3702

Ibn Umar (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Whosoever grafts the tree and then sells its roots, its fruit will belong to one who grafts it except when provision is laid down by the buyer.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3703]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3703

This hadith has been narrated on the authority of Nafi, with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3704]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3704

Abdullah b. Umar (Allah be pleased with them) reported Allah's Massenger (may peace be upon him) as saying: He who buys a tree after it has been fecundated, its fruit belongs to one who sells it except when the provision has been laid down by the buyer (that it will belong to him), and he who buys a slave, his property belongs to one who sells him except when a provision has been laid down by the buyer (that it will be transferred to him with the slave).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3705]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3705

A hadith like this has been narrated on the authority of al Zuhri.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3706]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3706

Ibn Umar reported on the authority of his father as Allah's Apostle (may peace be upon him) saying so.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3707]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3707

Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) had forbidden Muhaqala. and Muzabana, Mukhibara and the sale of fruits until their good condition becomes clear, and (he commanded) that (commodities) should not be sold but for the dinar and dirham except in case of araya.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3708]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3708

Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade the types of sales as described before.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3709]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3709

Jabir b. 'Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade Mukhabara and Muhaqala, and Muzabana, and the sale of the fruit until it is fit for eating, and its sale but with dirham and dinar. Exception is made in case of 'araya. Ata' said: Jabir explained (these terms) for us. As for Mukhabara it is this that a wasteland is given by a person to another and he makes an investment in it and then gets a share in the produce. According to him (Jabir), Muzabana is the sell of fresh dates on the tree for dry dates with a measure, and Muhaqala in agriculture implies that one should sell the standing crop for grains with a measure.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3710]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3710

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala, and Muzabana, and Mukhabara, and the buying of date-palm until its fruit is ripened (ripening means that its colour becomes red or yellow, or it is fit for being eaten). And Muhaqala implies that crops in the field are bought for grains according to a customary measure. Muzabana implies that date-palm should be sold for dry dates by measuring them with wisqs, and al-Mukhabara is (a share), maybe one-third or one-fourth (in produce) or something like it. Zaid (one of the narrators) said to Ata' b. Abu Rabah (the other narrator): Did You bear Jabir b. Abdullah (Allah be pleased with them) making a mention of it that he had heard it directly from Allah's Messenger (may peace be upon him)? He said: Yes.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3711]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3711

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muzabana and Muhaqala, and Mukhabara, and the sale of fruits until they are ripe. I (the narrator) said to Sa'id (the other narrator): What does ripening imply? He said: It meant that they become red or become yellow and are fit for eating.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3712]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3712

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala and Muzabana and Mu'awama and Mukhabara. (One of the narrators) 'said: Sale years ahead is Mu'awama, and making exceptional but he made an exemption of araya.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3713]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3713

A hadith like this has been narrated on the authority of Jabir (Allah be pleased with him) from Allah's Apostle (may peace be upon him). but he made no mention of transactions years (ahead) implying Mu'awama.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3714]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3714

Jabir b. Abdullah (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) forbade leasing of land, and selling ahead for years and selling of fruits before they become ripe.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3715]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3715

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden the renting of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3716]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3716

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it himself, but if he does not cultivate it himself, then he should let his brother cultivate it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3717]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3717

Jabir b. Abdullah (Allah be pleased with them) reported some of the Companions of Allah's Messenger (may peace be upon him) had surplus of land. Thereupon Allah's Messenger (may peace be upon him) said: He, who has surplus land (in his possession) should cultivate it, or he should lend it to his brother for benefit, but if he refuses to accept it, he should retain it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3718]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3718

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) having forbidden taking of rent or share of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3719]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3719

Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it, but if he does not find it possible to cultivate it, or finds himself helpless to do so, he should lend it to his Muslim brother, but he should not accept rent from him.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3720]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3720

Sulaiman b. Musa asked Ata': Did Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying:" He who has land should cultivate it himself, or let his brother cultivate it, and should not give on rent"? He said: Yes.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3721]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3721

Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) having forbidden Mukhabara.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3722]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3722

Jabir b. Abdullah (Allah be pleased with them) heard Allah's Messenger (may peace be upon him) say: He who has surplus of land should either cultivate it himself, or let his brother cultivate it, an should not sell it. I (the narrator) said to Sa'id: What does his statement" do not sell it" mean? Does it imply" rent"? He said: Yes.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3723]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3723

Jabir b. 'Abdullah reported: We used to cultivate land on rent during the lifetime of Allah's Apostle (may peace be upon him) and we got a share out of the grain left in the ears after threshing them and something unspecified. Allah's Messenger (may peace be upon him) said: He who has land should cultivate it or let his brother till it, otherwise he should leave it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3724]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3724

Jabir b. Abdullah (Allah be pleased with them) reported: We used to get land (on rent) during the lifetime of Allah's Messeuge, (may peace be upon him) with a share of one-third or one-fourth (of the produce from the land irrigated) with the help of canals. Thereupon Allah's Messenger (may peace be upon him) stood up (to address) and said: HRe who has land should cultivate it, and if he does not cultivate it, he should lend it to his brother, and if he does not lend it to his brother, he should then retain it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3725]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3725

Jabir (Allah he pleased with him) reported: I heard Allah's Apostle (may peace be upon him) as saying: He who has (surplus) land should donate it (to others), or lend it. This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but with a slight change of words.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3726]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3726

Jabir b. `Abdullah (Allah be pleased with them) reportedthat Allah's Messenger (may peace be upon him) had forbidden renting of land. Bukair (one of the narrators) said: Nafi` reported to me that he heard Ibn `Umar (Allah be pleased with them) saying: We usedto give land on rent; we then abandoned this practice when we heard the hadith of Rafi` b. Khadij.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3727]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3727

Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) forbidding the selling (renting of) uncultivated land for two years or three.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3728]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3728

Jabir (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) forbidding selling of (produce) in advance for two years, and in the narmtion of Ibu Abd Shaiba (the words are):" Selling of the fruits (on the tree) in advance for two years."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3729]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3729

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who has land should cultivate it or lend it to his brother, but if he refuses, he should retain his land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3730]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3730

Jabir b. Abdullah (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) forbidding Muzabana, and Huqul. Jabir b. Abdullah (Allah be pleased with them) said: Muzabana means the selling of fruits for dry dates and Huqul is the renting of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3731]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3731

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) forbidding Muhaqala and Muzabana.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3732]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3732

Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having forbidden Mazabana and Muhaqala. Muzibana means the buying of fruits on the trees and Muhaqala is the renting of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3733]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3733

Zaid b. Amr reported: I heard Ibn Umar (Allah be pleased with them) say: We did not see any harm in renting of the land, but as the first year was over Rafi' alleged Allah's Apostle (may peace be upon him) having forbidden that.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3734]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3734

This hadith has been narrated on the authority of Amr b. Dinar with the same chain of transmitters but (in) the hadith transmitted on the authority of 'Uyainah (the words are):" We abandoned it (renting) on account of that."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3735]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3735

Ibn 'Umar (Allah be pleased with them) reported: Rafi forbade us from benefitting from our land (in the form of rent).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3736]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3736

Nafi reported that Ibn Umar (Allah be pleased with them) rented his land during the lifetime of Allah's Messenger (may peace be upon him) and during the caliphate of Abu Bakr and that of Umar and that of Uthman (Allah be pleased with them) and during the early period of Muawiya's caliphate until at the end of Muawiya's reign, it reached him (Ibn 'Umar) that Rafi b. Khadij (Allah be pleased with him) narratted (a hadith) in which (there was a decree) of prohibition by Allah's Apostle (may peace be upon him). He (Ibn 'Umar) went to him (Rafi b. Khadij) and I was with him and he asked him, whereupon he said: Allah's Messenger (may peace be upon him) used to forbid the renting of land. So Ibn Umar (Allah be pleased with them) abandoned it, and subsequently whenever he was asked about it, he said: Rafi b. Khadij (Allah be pleased with him) alleged that Allah's Messenger (may peace be upon him) forbade it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3737]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3737

This hadith has been narrated on the authority of Ayyub and he made an addition in the hadith narrated by Ibn Ulayya in which he said: Ibn Umar abandoned it afterwards and he did not rent it (the land).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3738]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3738

Nafi reported: I went to Rafi b. Khadij in the company of Ibn 'Umar (All be pleased with them) until he (Ibn 'Umar) came to him at Balat (a place near Prophet's Mosque at Medina) and he (Rafi b. Khadij) informed him that Allah's Messenger (may peace be upon him) had forbidden the renting of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3739]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3739

Nafi, reported from Ibn Umar (Allah be pleated with them) that he came to Rafi and he narrated this hadith from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3740]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3740

Nafi, reported that Ibn Umar (Allah be pleased with them) used to rent the land, and that he was conveyed the hadith transmitted on the authority of Rafi b. Khadij. He (the narrator) said: He then went to him along with me. He (Rafi) narrated from some of his uncles in which it was mentioned that Allah's Apostle (may peace be upon him) forbade the renting of land. Ibn 'Umar (Allah be pleased with them) then abandoned this practice of renting. This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3741]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3741

Salim b. Abdullah reported that AbduUah b. Umar (Allah be pleased with them) used to give land on rent until (this news) reached him that Rafi b. Khadij Ansari used to forbid the renting of land. Abdullah met him and said: Ibn Khadij, what is this that you narrate from Allah's Messenger (may peace be upon him) pertaining to renting of land? Rafi b. Khadij said to Abdullah: I heard it from two uncles of mine and they had participated in the Battle of Badr who narrated to the members of the family that Allah's Messenger (may peace be upon him) forbade the renting of land. Abdullah said: I knew it that the land was rented during the lifetime of Allah's Messenger (may peace be upon him). Abdullah then apprehended that Allah's Messenger (may peace be upon him) might have said something new in this connection (in regard to prohibition of renting) which I failed to know. So he abandoned the renting of land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3742]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3742

Rafi b. Khadij (Allah be pleased with him) reported: We used to give on rent land during the lifetime of Allah's Messenger (may peace be upon him). We rented it on the share of one-third or one-fourth of the (produce) along with a definite quantity of corn. One day a person from among my uncles came to us and said: Allah's Messenger (may peace be upon him) forbade us this act which was a source of benefit to us, but the obedience to Allah and to His Messenger (may peace be upon him) is more beneficial to us. He forbade us that we should rent land with one-third or one-fourth of (the produce) and the corn of a measure, and he commanded the owner of land that he should cultivate it or let it be cultivated by other (persons) but he showed disapproval of renting it or anything besides it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3743]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3743

Rafi b. Khadij (Allah be pleased with him) reported: We used to give land on rent, and we rented it on one-third or one-fourth share. The rest of the hadith is the same.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3744]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3744

This hadith has been narrated on the authority of Rafi' b. Khadij with the same chain of transmitters, but in it no mention is made of some of his uncles.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3745]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3745

Rafi (Allah be pleased with him) reported that Zuhair b. Rafi (who was his uncle) came to me and said: Allah's Messenger (may peace be upon him) forbade a practice which was useful for us. I said: What is this? (I believe) that whatrver Allah's Messenger (may peace be upon him) says is absolutely true. He (Zuhair) said that he (the Holy Prophet) asked me: What do you do with your cultivable lands? I said: Allah's Messenger, we rent those irrigated by canals for dry dates or barley. He said: Don't do that. Cultivate them or let them be cultivated (by others) or retain them yourself.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3746]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3746

This hadith has been transmitted on the authority of Rafi from the Prophet (may peace be upon him) about this, but he did not make mention of his uncle Zuhair.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3747]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3747

Hanzala b. Qais reported that he asked Rafi b. Khadij (Allah be pleased with him) about renting of land, whereupon he said: Allah's Messenger (may peace be upon him) forbade the renting of land. I said: Is it forbidden (even if it is paid) in gold (dinar) and silver (dirham)? Thereupon he said: If it is paid in gold and silver, there is no harm in it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3748]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3748

Hanzala b. Qais al-Ansri reported: I asked Rafi' b. Khadij about the renting of land for gold and silver, whereupon he said: There is no harm in it for the people let out land situated near canals and at the ends of the streamlets or portion of fields. (But it so happened) that at times this was destroyed and that was saved. whereas (on other occasions) this portion was saved and the other was destroyed and thus no rent was payable to the people (who let out lands) but for this one (which was saved). It was due to this that he (the Holy Prophet) prohibited it. But if there is something definite and reliable (e. g. money). there is no harm in it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3749]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3749

Hanzala reported that he heard Rafi' b. Khadij (Allah be pleased with him) say: We were the major agriculturists of the Ansar and so we let out land (saying): The produce of this (part of land) would be ours and (the produce) of that would be theirs. But it so happened that at times this (land) gave harvest, but the other one produced nothing. So he (the Holy Prophet) forbade this. But so far as the payment in silver (dirham, a coin) is concerned, he did not forbid.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3750]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3750

This hadith has been narrated on the authority of Yahya b. Sa'id with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3751]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3751

Abdullah b. al Sa'ib reported: I asked Abdullah b. Ma'qil about Muzara'a (cultivating land on share basis in the produce). He said: Thabit b. Dahhak informed me that Allah's Messenger (may peace be upon him) forbade Muzara'a as Ibn Abu Shaiba forbade it with a slight change of words. He (the narrator) said: I asked Ibn Ma'qil but he did not name 'Abdullah.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3752]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3752

Abdullah b. al-Sa'ib reported: We visited 'Abdullah b. Ma'qil and asked him about sharing of crops, whereupon he said: Thabit alleged that Allah's Messenger (may peace be upon him) forbade Muzara'a and commanded leasing it out on rent (for money) and said: There is no harm in it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3753]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3753

Mujahid said to Tiwus: Come along with me to Ibn Rafi b. Khadij in order to listen from him the hadith transmitted on the authority of his father (pertaining to the renting of land) from Allah's Apostle (may peace be upon him). He (Tawus) scolded him and said: By Allah, it I were to know that Allah's Messenger (may peace be upon him) had forbidden it, I would have never done it. But it has been narrated to me by one who has better knowledge of it amongst them (and he meant Ibn 'Abbas) that Allah's Messenger (may peace be upon him) said: It is better if a person lends, his land to his brother (for cultivation) than that he gets recognised rent on it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3754]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3754

Tawus reported that he let out his land on rent, whereupon Amr said: I said to him: Abu Abd al-Rahrman, I wish if you abandon this renting of land, for they alleged that Allah's Apostle (may peace be upon him) forbade Mukhabara. He siad: Amr, one who has informed me has the best knowledge of it among them (he meant Ibn Abbas). (He said) that Allah's Apostle (may peace be upon him) did not prohibit it altogether, but said: Lending of land by one among you to his brother is better for him than getting a specified amount of produce from it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3755]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3755

A hadith like this has been transmitted on the authority of Ibn Abbas (Allah be pleased with them).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3756]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3756

Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: If one among you lets out land to his brother, that is better for him than if he receives such and such (the definite thing). Ibn 'Abbis (Allah be pleased with them) said: It is Haql, and in the parlance of the Ansr it is Muhaqala.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3757]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3757

Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: He who has land, it is better for him that he should let it out to his brother.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3758]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3758

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) contracted with the people of Khaibar the (trees) on the condition that he would have half the produce in fruits and harvest.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3759]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3759

Ibn Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) handed over the land of Khaibar (on the condition) of the share of produce of fruits and harvest, and he also gave to his wives every year one hundred wasqs: eighty wasqs of dates and twenty wasqs of barley. When 'Umar became the caliph he distributed the (lands and trees) of Khaibar, and gave option to the wives of Allah's Apostle (may peace be upon him) to earmark for themselves the land and water or stick to the wasqs (that they got) every year. They differed in this matter. Some of them opted for land and water, and some of them opted for wasqs every year. 'A'isha and Hafsa were among those who opted for land and water.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3760]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3760

Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) contracted with the people of Khaibar (land and trees on the condition that they should give) half of the yield from land and trees. The rest of the hadith is the same. In the hadith transmitted on the authority of AIi b. Mushir there is no mention of it, but that A'isha and Hafsa were those who opted for land and water, but he (the narrator) said: He (Hadrat 'Umar, gave option to the wives of Allah's Apostle (may peace be upon him) that land would be earmarked for them, but he made no mention of water.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3761]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3761

'Abdullah b. Umar (Allah be pleased with them) reported that when Khaibar had been conquered, the Jews asked Allah's Messenger (may peace be upon him) to let them continue (cultivation in those lands) on half of the share of yield in fruits and crop, whereupon Allah's Messenger (may peace be upon him) said: I will allow you to continue here, so long as we would desire. The rest of the hadith is the same, but with this addition:" The fruit would be distributed equal to the half of Khaibar. And out of hall of the produce of the land, Allah's Apostle (may peace be be upon him) got the fifth part."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3762]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3762

Abdullah b. Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) returned to the Jews of Khaibar the date-palms of Khaibar and its land on the condition that they should work upon them with their own wealth (seeds, implements), and give half of the yield to Allah's Messenger (may peace be upon him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3763]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3763

Ibn Umar reported that 'Umar b. al-Khattab (Allah be pleased with him) expelled the Jews and Christians from the land of Hijaz, and that when Allah's Messenger (may peace be upon him) conquered Khaibar he made up his mind to expel the Jews from it (the territory of Khaibar) because, when that land was conquered, it came under the sway of Allah, that of His Messenger (may peace be upon him) and that of the Muslims. The jews asked Allah's Messenger (may peace be upon him) to let them continue there on the condition that they would work on it, and would get in turn half of the fruit (of the trees), whereupon Allah's Messenger (may peace be upon him) said: We would let you continue there so long as we will desire. So they continued (to cultivate the lands) till 'Umar externed them to Taima' ang Ariha (two villages in Arabia, but out of Hijaz).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3764]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3764

Jabir (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Never a Muslim plants a tree, but he has the reward of charity for him, for what is eaten out of that is charity; what is stolen out of that, what the beasts eat out of that, what the birds eat out of that is charity for him. (In short) none incurs a los! k to him but it becomes a charity on his part.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3765]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3765

Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) visited Umm Mubashshir al-Ansariya at her orchard of date-palms and said to her: Who has planted these trees of dates-a Muslim or a non-Musim? She said: A Muslim, of course, whereupon he said: Never a Muslim plants, or cultivates a land, and it out of that men eat, or the animals eat, or anything else eats, but that becomes charity on his (planter's) behalf.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3766]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3766

Jabir b. 'Abdullah (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) saying: Never does a Muslim plant, or cultivate, but has reward for him for what the beasts eat, or the birds eat or anything else eats out of that.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3767]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3767

Jabir b. Abdullah (Allah be pleased with them) reported: Allah's Apostle (may peace be upon him) visited the orchard of Umm Ma'sud and said: Umm Ma'bad. he who has planted this tree, is he a Muslim or a non-Muslim? She said: Of course, he is a Muslim, whereupon he (the Holy Prophet) said: No Muslim who plants (trees) and from their fruits the human beings or the beasts or birds eat, but that would be taken as an act of charity on the Day of Resurrection.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3768]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3768

This hadith is transmitted on the authority of Abu Muawiya (but With a slight change of words).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3769]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3769

Anas reported Allah's Messenger (may peace be upon him) as saying Never does a Muslim plant trees or cultivate land and birds or a man or a beast eat out of them but that is a charity on his behalf.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3770]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3770

Anas b. Malik (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) visited the date-palms of Umm Mubashshir (Allah be pleased with her), a lady from the Ansar, and said: Who planted this palm-a Muslim or an unbelievers The rest of the hadith is the same.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3771]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3771

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) saying: If You sell fruits to your brother (and Jabir b. Ahduthh reported through another chain of narrators: If you were to sell fruits to your brother) and these is a stricken with Calamity, it is not permissible for you to get anything from him. Why do you get the wealth of your brother, without jutification?


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3772]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3772

A hadith like this has been narrated on the authority of Juraij with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3773]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3773

Anas (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) forbade the sale of the fruit of date-palms until it becomes mellow. We (some of the other narrators in the chain of transmitters) said: What does the word" mellow" mean? He said: (There the fruit) turns red or yellow. Don't you see if Allah had checked (the growth of) fruits; then what for the wealth of your brother would be permissible for you?


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3774]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3774

Anas b. Malik (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the sale of fruits until these are mellow. They (the companions of Anas) said: What is meant by" mellow"? He said: It implies that these became red. He said: When Allah hinders the growth of fruits, (then) what for the wealth of your brother would become permissible for you?


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3775]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3775

Anas (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: If Allah does not fructify them, then what is permissible for one of you to take the wealth of his brother?


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3776]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3776

Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) commanded to make deductions in the payment of that stricken with a Calamity.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3777]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3777

Abu Sa'id al-Khudri (Allah be pleeased with him) reported that in the time of Allah's Messenger (may peace be upon him) a man suffered loss in fruits he had bought and his debt increased; so Allah's Messenger (may peace be upon him) told (the people) to give him charity and they gave him charity, but that was not enough to pay the debt in full, whereupon Allah's Messenger (may peace be upon him) said to his creditors:" Take what you find, you will have nothing but alms.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3778]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3778

This hadith has been narrated on the authority of Bukair b. al-Ashajj with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3779]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3779

A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) heard the voices of altercation of two disputants at the door; both the voices were quite loud. The one demanded some remission and desired that the other one should show leniency to him, whereupon the (other one) was saying: By Allah will not do that. Then there came Allah's Messenger (may peace be upon him) to them and said: Where is he who swears by Allah that he would not do good? He said: Massenger of Allah, it is I. He may do as he desires.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3780]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3780

Abdullah b. Ka'ab b. Malik reported from his father that he pressed in the mosque Ibn Abu Hadrad for the payment of the debt that he owed to him during the lifetime of Allah's Messenger (may peace be upon him). (In this altercation) their voices became loud, until Allah's Messenger (may peace be upon him) heard them, while he was in the house, so Allah's Messenger (may peace be upon him) came out towards them, and he lifted the curtain of his apartment and he called upon Ka'b b. Malik and said: O Ka'b. He said: At thy beck and call, Allah's Messenger. He pointed out with the help of his hand to remit half of the loan due to him. Ka'b said: Allah's Messenger, I am ready to do that, whereupon Allah's Messenger (may peace be upon him) said (to Ibn Abu Hadrad): Stand up and make him the payment (of the rest).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3781]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3781

Ka'b b. Malik reported that he made a demand for the payment of the debt that Ibn Abu Hadrad owed to him. This hadith is narrated through another chain of transmitters and (the words are):" He had to get the loan from Abdullah b. Hadrad al-Aslami. He met him and pressed him for payment. There was an altercation between them, until their voices became loud. There happened to pass by them Allah's Messenger (may peace be upon him) and he said: O Ka'b, and pointed out with his hand in such a way as he meant half. So he got half of what he (Ibn Abu Hadrad) owed to him and remitted the half."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3782]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3782

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who found his property intact with a person (who bought it but who later on) became insolvent (or a person who became insolvent), he (the seller) is entitled to get it more than anyone else. '


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3783]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3783

This hadith has been narrated on the authority of Yahya b. Sa'id with the same chain of transmitters (but with a slight variation of words and these are)" Whenever a man becomes poor."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3784]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3784

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) saying about a person who becomes insolvent and (the thing bought by him) is found intact with him, that belongs to one who sold it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3785]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3785

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: When a man becomes insolvent (and the other) man (the seller) finds his commodity intact with him, he is more entitled to get it (than anyone else)


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3786]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3786

This hadith has been narrated on the authority of Qatada with the same chain of transmitters (but with a change of these words):" He is more entitled to get it than any other creditor."


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3787]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3787

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: When a inan becomes insolvent, and the other person (seller) finds his goods intact with him, he is more entitled to get them than anyone else.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3788]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3788

Hudhaifa reported Allah's Messenger (may peace be upon him) as saying The angels took away the soul of a person who had lived among people who were before you. They (the angels) said: Did you do anything good? He said: No. they said: Try to recall. He said: I used to lend to people and order my servants to give respite to one in straitened circumstances and give allowance to the solvent, for Allah, the Exalted and Majestic, said (to the angels): You should ignore (his failing).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3789]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3789

Hudhaifa reported: A person met his Lord (after death) and He said: What (good) did you do? He said: I did no good except this that I was a rich man, and I demanded from the people (the repayment of debt that I advanced to them). I, however, accepted that which the solvent gave and remitted (the debt) of the insolvent, whereupon He (the Lord) said: You should ignore (the faults) of My servant. Abu Mas'ud (Allah be pleased with him) said: This is what I heard Allah's Messenger (may peace be upon him) as saying.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3790]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3790

Hudhaifa (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: A person died and he entered Paradise. It was said to him What (act) did you do? (Either he recalled it himself or he was made to recall), he said I used to enter into transactions with people and I gave respite to the insolvent and did not show any strictness in case of accepting a coin or demanding cash payment. (For these acts of his) he was granted pardon. Abu Mas'ud said: I heard this from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3791]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3791

Hudhaifa (Allah be pleased with him) reported: A servant from amongst the servants of Allah was brought to Him whom Allah had endowed with riches. He (Allah) said to him: What (did you do) in the world? (They cannot conceal anything from Allah) He (the person) said: O my Lord, You endowed me with Your riches. I used to enter into transactions with people. It was my nature to be lenient to (my debtors). I showed leniency to the solvent and gave respite to the insolvent, whereupon Allah said: I have more right than you to do this to connive at My servant. 'Uqba b. 'Amir al-Juhani and Abu Mas'ud said: This is what we heard from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3792]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3792

Abu Mas'ud (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: A person from people who lived before you was called to account (by Allah at the Day of Judgment) and no good was found in his account except this that lie being a rich man had (financial) dealings with people and had commanded his servants to show leniency to the straitened ones. Upon this Allah, the Exalted and Majestic, said: We have more right to this, so overlook (his faults).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3793]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3793

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: There was a person who gave loans to the people and said to his men: When an insolvent comes to you show him leniency that Allah may overlook our (faults). So when he met Allah, He overlooked his faults (forgave him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3794]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3794

A hadith like this is narrated on the authority of Abu Huraira (Allah be pleased with him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3795]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3795

Abdullah b. Abu Qatida reported that Abu Qatada (Allah be pleased with him) demanded (the payment of his debt) from his debtor but he disappeared; later on he found him and he said: I am hard up financially, whereupon he said: (Do you state it) by God? He said: By God. Upon this he (Qatada) said: I heard Allah's Messenger (may peace be upon him) as saying: He who loves that Allah saves him from the torments of the Day of Resurrection should give respite to the insolvent or remit (his debt) This hadith has been narrated on the authority of Ayyob with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3796]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3796

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Delay (in the payment of debt) on the part of a rich man is injustice, and when one of you is retired to a rich man, he should follow him.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3797]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3797

A hadith like this has been transmitted on the authority of Abu Huraira (Allah be pleased with him).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3798]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3798

Jabir b. 'Abdullah (, Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the sale of excess water.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3799]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3799

Jabir b. 'Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the hiring of a Camel to cover a she-Camel and from selling water and land to be tilled. So from all this the Messenger of Allah (may peace be upon him) forbade.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3800]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3800

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Excess water must not be withheld so that the growth of herbage may be hindered.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3801]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3801

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not withhold excess of water, so that you may prevent the growth of herbage.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3802]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3802

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: The excess of water should not be sold in order to enable the sate of herbage.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3803]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3803

Aba Mas'ud al-Ansari (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) forbade the charging of price of the dog, and earnings of a prostitute and sweets offered to a kahin.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3804]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3804

A hadith like this is reported on the authority of Abu Mas'ud through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3805]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3805

Rafi b. Khadij (Allah be pleased with him) reported: I heard Allah's Apostle (may peace be upon him) as saying: The worst earning is the earning of a prostitute, the price of a dog and the earning of a cupper.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3806]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3806

Rafi b. Khadij reported Allah'& Messenger (may peace be upon him) as saying: The price of a dog is evil, the earning of a prostitute is evil and the earning of a cupper is evil.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3807]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3807

A hadith like this has been narrated on the authority of Rifi' b. Khadlj through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3808]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3808

Abu Zubair said: I asked Jabir about the price of a dog and a cat; he said: Allah's Messenger (may peace be upon him) disapproved of that.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3809]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3809

Ibn 'Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) giving command for killing dogs.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3810]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3810

Ibn 'Umar (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) ordered to kill dogs, and he sent (men) to the corners of Medina that they should be killed.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3811]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3811

Abdullah (b. Umar) (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) ordered the killing of dogs and we would send (men) in Medina and its corners and we did not spare any dog that we did not kill, so much so that we killed the dog that accompanied the wet she-camel belonging to the people of the desert.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3812]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3812

Ibn Umar (Allah be pleased with them) reported that Allah's Messenger (may peace be, upon him) ordered the killing of dogs except the dog tamed for hunting, or watching of the herd of sheep or other domestic animals. It was said to Ibn Umar (Allah be pleased with them) that Abu Huraira (Allah be pleased with him) talks of (exception) about the dog for watching the field, whereupon he said: Since Abu Huraira (Allah be pleased with him) possessed land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3813]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3813

Abu Zubair heard Jabir b. 'Abdullah (Allah be pleased with him) saying: Allah's Messenger (may peace be upon him) ordered us to kill dogs, and we carried out this order so much so that we also kill the dog coming with a woman from the desert. Then Allah's Apostle (may peace be upon him) forbade their killing. He (the Holy Prophet further) said: It is your duty the jet-black (dog) having two spots (on the eyes), for it is a devil.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3814]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3814

Ibn Mughaffal reported: Allah's Messenger (may peace be upon him) ordered the killing of dogs and then said: what is the trouble with them (the people of Medina)? How dogs are nuisance to them (the citizens of Medina)? He then permitted keehing of dogs for hunting and (the protection of) herds. In the hadith transmitted on the authority of Yahya, he (the Holy Prophet) permitted the keeping of dogs for (the protection of) herds, for hunting and (the protection of) cultivated land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3815]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3815

Ibn Umar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who keeps a dog other than that meant for watching the herd or for hunting loses every day out of his deeds equal to two qirat.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3816]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3816

Salim reported on the authority of his father that Allah's Apostle (may peace be upon him) said: He who kept a dog other than one meant for hunting or for watching the herd, lost two qirat of his reward every day.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3817]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3817

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying He who kept a dog other than one meant for hunting or for watching the herd lost out of his deeds (equal to) two qirat every day.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3818]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3818

Salim b. 'Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him) said: He who kept a dog other than one meant for watching the herd or for hunting would lose every day two qirat of his good deeds. 'Abdullah and Abu Huraira also said: Or dog meant for watching the field.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3819]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3819

Salim reported on the authority of his father (Allah be pleased with him) that Allah's Messenger (may peace be upon him) said: He who kept a dog other than one meant for hunting or for the protection of the herd would lose two qirat of his deeds every day. Salim said: Abu Huraira (Allah be pleased with him) used to say: Or the dog meant for watching the field, and he was the owner of the land.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3820]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3820

Salim b. Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him) said: Whosover amongst the owners of the house keeps a dog other than one meant for watching the herd or for hunting loses two qirat of his deeds every day.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3821]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3821

Ibn Umar (Allah be pleased with them) narrated Allah's Messenger (may peace be upon him) as saying: He who kept a dog ther than one meant for watching the fields or herds or hunting would lose one qirat every day out of his reward (with God).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3822]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3822

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog which is neither meant for hunting nor for watching the anitmals nor for watching the fields would lose two qirat every day out of his reward; and there is no mention of the fields in the hadith transmitted by Abu Tahir.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3823]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3823

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog except one meant for watching the herd, or for hunting or for watching the fields. he lost two qirat of reward every day. Zuhri said: The words of Abu Huraira (Allah be pleased with him) were conveyed to Ibn Umar who said: May Allah have mercy upon Abu Huraira; he owned a field.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3824]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3824

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog would lose out of his deeds equal to one qirat every day. except (one kept) for watching the field or herd.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3825]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3825

A hadith like this has been transmitted on the authority of Abu Huraira.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3826]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3826

This hadith has been reported on the authority of Yahya b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3827]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3827

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who kept a dog, but not meant for hunting or watching the herd, would lose one qirat of reward every day.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3828]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3828

Sufyan b. Abu Zuhair (he was a person belonging to the tribe of Shanu'a and was amongst the Conpanions of Allah's Messenger [may peace be upon him ) said: I heard Messenger of Allah (may peace be upon him) as saying: He who kept a dog (other than that) which is indispensable for watching the field or the animals would lose one qirat out of his deeds every day. As-Sa'ib b Yazid (one of the narrators) said: Did you hear it from Allah's Messenger (may peace be upon him)? He said: Yes. by the Lord of this mosque.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3829]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3829

This hadith has been narrated on the authority of Sufyan b. Abu Zuhair al-Shana'i.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3830]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3830

It is narrated on the authority of Humaid that Anas b. Malik was asked about the earnings of the cupper. He said: Allah's Messenger (may peace be upon him) got himself cupped. His cupper was Abu Taiba and he (the Holy Prophet) commanded to give him two sa's of corn. He (the Holy Prophet) talked with the members of his family and they lightened the burden of Kharaj (tax) from him (i. e. they made remis- sion in the charges of their own accord). He (Allah's Apostle) said: The best (treat- ment) which you take is cupping, or it is the best of your treatments.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3831]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3831

Rumaid reported that Anas b. Malik (Allah be pleased with him) has asked about the earnings of a cupper. Then (the above-mentioned hadith was reported but with this addition) that he said: The best treatment which you get is cupping. or aloeswood and do not torture your children by pressing their uvula.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3832]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3832

Humaid reported Anas (Allah be pleased with him) having said this: Allah's Apostle (may peace be upon him) called for young cupper belonging to us. He capped him and he (the Holy Prophet) commanded that he should be paid one sa' or one mudd or two mudds (of wheat). It was said (that charges were high) and a reduction was made in the charges.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3833]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3833

Ibn Abbas (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) got himself cupped and he paid the clipper his charges and he put medicine in his nostrils.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3834]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3834

Ibn 'Abbas (Allah be pleased with them) reported: The slave of Banu Bayada cupped Allah's Apostle (may peace be upon him) and he gave him his wages, and talked to his master and he reduced the charges, and if this earning was unlawful Allah's Apostle (may peace be upon him) would not have given it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3835]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3835

Abu Sa'id al-Khudri (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon him) addressing in Medina. He said: O people, Allah is giving an indication (of the prohibition) of wine. and He is probably soon going to give an order about it. So he who has anything of it with him should sell that, and derive benefit out of it. He (the narrator) said: We waited for some time that Allah's Apostle (may peace be upon him) said: Verily Allah, the Exalted, has forbidden wine. So who hears this verse and he has anything of it with him, he should neither drink it nor sell it. He (the narrator) said: The people then brought whatever they had of it with them on the streets of Medina and spilt that.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3836]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3836

'Abd al-Rahman b. Wa'ala as-Saba'i (who was an Egyptian) asked 'Abdullah b. Abbas; (Allah be pleased with them) about that which is extracted from the grapes, whereupon he said: A person presented to Allah's Messenger (may peace be upon him) a small water-skin of wine. Allab's Messenger (may peace be upon him) said to him: Do you know that Allah has forbidden it? He said: No. He then whisper- ed to another man. Allah's Messenger (may peace be upon him) asked him what he had whispered. He said: I advised him to sell that, whereupon he (the Holy Prophet) said: Verily He Who has forbidden its drinking has forbidden its sale also. He (the narrator) said: He opened the waterskin until what was contained in it was spilt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3837]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3837

'Abd al-Rahman b. Wa'ala narrated this on the authority of 'Abdullah b. Abbas.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3838]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3838

'A'isha (Allah be pleased with her) reported: When the concluding verses of Sura Baqara were revealed, Allah's Messenger (may peace be upon him) went out and read them out to the people and then forbade them to trade in wine.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3839]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3839

'A'isha (Allah be pleased with her) reported: When the concluding verses of Sura Baqara pertaining to Riba were revealed, Allah's Messenger (may peace be upon him) went out to the mosque and he forbade the trade in wine.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3840]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3840

Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying in the Year of Victory while he was in Mecca: Verily Allah and His Messenger have forbidden the sale of wine, carcass, swine and idols, It was said: Allah's Messenger, you see that the fat of the carcass is used for coating the boats and varnishing the hides and people use it for lighting purposes, whereupon he said: No, it is forbidden, Then Allah's Messenger (may peace be upon him) said: May Allah the Exalted and Majestic destroy the Jews; when Allah forbade the use of fat of the carcass for them, they melted it, and then sold it and made use of its price (received from it).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3841]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3841

Yazid b. Abu Habib reported: 'Ata' reported to me that he heard Jabir (b. 'Abdullah) saying it that he had heard that from Allah's Messenger (may peace be upon him) in the Year of Victory.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3842]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3842

Ibn Abbas (Allah be pleased with him) reported: This news reached 'Umar that Samura had sold wine, whereupon he said: May Allah destroy Samura; does he not know that Allah's Messenger (may peace be upon him) said:" Let there be the curse of Allah upon the Jews that fat was declared forbidden for them, but they melted it and then sold it"?


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3843]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3843

This hadith has been narrated on the authority of 'Amr b. Dinar with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3844]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3844

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: May Allah destroy the Jews for Allah forbade the use of fat for them, but they sold it and made use of its price.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3845]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3845

Abu Salid al-Khudri reported Allah's Messenger (may peace be upon him) as saying: Do not sell gold for gold, except like for like, and don't increase something of it upon something; and don't sell silver unless like for like, and don't increase some thing of it upon something, and do not sell for ready money something to be given later.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3846]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3846

Nafi' reported that Ibn 'Umar told him that a person of the tribe of Laith said that Abu Sa'id al-Kludri narrated it (the above-mentioned hadith) from tile Messenger of Allah (may peace be upon him) in a narration of Qutaiba. So 'Abduliali and Nafi' went along with him, and in the hadith transmitted by Ibn Rumh (the words are) that Nafi' said: 'Abdullah (b. 'Umar) went and I along with the person belonging to Banu Laith entered (the house) of Sa'id al-Khudri, and he ('Abdullah b. Umar) said: I have been informed that you say that Allah's Messenger (may peace be upon him) forbade the sale of silver with silver except in case of like for like, and sale of gold for gold except in case of like for like. Abu Sa'id pointed towards this eyes and his ears with his fingers and said: My eyes saw, and my ears listened to Allah's Messenger (may peace be upon him) saying: Do not sell gold for gold, and do not sell silver for silver except in case of like for like, and do not increase something of it upon something, and do not sell for ready money something, not present, but hand to hand.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3847]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3847

This hadith has been narrated on the authority of Abu Sa'id al-Khudri through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3848]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3848

Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Do not sell gold for gold and silver for silver weight for weight or of the same quality.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3849]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3849

'Uthman b. 'Affan reported Allah's Messenger (may peace be upon him) as saying: Do not sell a dinar for two dinars and one dirham for two dirhams.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3850]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3850

Malik b. Aus b. al-Hadathan reported: I came saying who was prepared toexchange dirhams (for my gold), whereupon Talha b. Ubaidullah (Allah be pleased with him) (as he was sitting with 'Umar b. Khattib) said: Show us your gold and then come to us (at a later time). When our servant would come we would give you your silver (dirhams due to you). Thereupon 'Umar b. al-Khattib (Allah be pleased with him) said: Not at all. By Allah, either give him his silver (coins). or return his gold to him, for Allah's Messenger (may peace be upon him) said: Exchange of silver for gold (has an element of) interest in it. except when (it is exchanged) on the spot;and wheat for wheat is an interest unless both are handed over on the spot: barley for barley is interest unless both are handed over on the spot; dates for dates is interest unless both are handed over on the Spot.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3851]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3851

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3852]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3852

Abil Qiliba reported: I was in Syria (having) a circle (of friends). in which was Muslim b. Yasir. There came Abu'l-Ash'ath. He (the narrator) said that they (the friends) called him: Abu'l-Ash'ath, Abu'l-Ash'ath, and he sat down. I said to him: Narrate to our brother the hadith of Ubada b. Samit. He said: Yes. We went out on an expedition, Mu'awiya being the leader of the people, and we gained a lot of spoils of war. And there was one silver utensil in what we took as spoils. Mu'awiya ordered a person to sell it for payment to the people (soldiers). The people made haste in getting that. The news of (this state of affairs) reached 'Ubada b. Samit, and he stood up and said: I heard Allah's Messenger (may peace be upon him) forbidding the sale of gold by gold, and silver by silver, and wheat by wheat, and barley by barley, and dates by dates, and salt by salt, except like for like and equal for equal. So he who made an addition or who accepted an addition (committed the sin of taking) interest. So the people returned what they had got. This reached Mu'awiya. and he stood up to deliver an address. He said: What is the matter with people that they narrate from the Messenger (may peace be upon him) such tradition which we did not hear though we saw him (the Holy Prophet) and lived in his company? Thereupon, Ubida b. Samit stood up and repeated that narration, and then said: We will definitely narrate what we heard from Allah's Messenger (may peace be upon him) though it may be unpleasant to Mu'awiya (or he said: Even if it is against his will). I do not mind if I do not remain in his troop in the dark night. Hammad said this or something like this.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3853]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3853

Ubida b. al-Simit (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Gold is to be paid for by gold, silver by silver, wheat by wheat, barley by barley, dates by dates, and salt by salt, like for like and equal for equal, payment being made hand to hand. If these classes differ, then sell as you wish if payment is made hand to hand.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3854]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3854

Abu Sa'id al-Khudri (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Gold is to be paid for by gold, silver by silver, wheat by wheat, barley by barley, dates by dates, salt by salt, like by like, payment being made hand to hand. He who made an addition to it, or asked for an addition, in fact dealt in usury. The receiver and the giver are equally guilty.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3855]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3855

This hadith has been narrated on the authority of Abu Sa'id al-Khudri (Allah be pleased with him) through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3856]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3856

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Dates are to be paid for by dates, wheat by wheat, barley by barley, salt by salt, like for like, payment being made on the spot. He who made an addition or demanded an addition, in fact, dealt in usury except in case where their classes differ. This hadith has been narrated on the authority of Fudail b. Ghazwan with the same chain of transmitters, but he made no mention of (payment being) made on the spot.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3857]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3857

Abu Huraira (Allah be pleased with him) reported Allah's Mess-., nger (may peace be upon him) as saying: Gold is to be paid for by gold with equal weight, like for like, and silver is to be paid for by silver with equal weight, like for like. He who made an addition to it or demanded an addition dealt in usury.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3858]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3858

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Let dinar be exchanged for dinar, with no addition on either side and dirham be exchanged for dirham with no addition on either side. This hadith has been narrated on the authority of Musa b. Abu Tamim with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3859]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3859

Abu Minhal reported: My partner sold silver to be paid in the (Hajj) season or (in the days of) Hajj. He (my partner) came to me and informed me, and I said to him: Such transaction is not desirable. He said: I sold it in the market (on loan) but nobody objected to this. I went to al-Bara' b. 'Azib and asked him, and he said: Allah's Apostle (may peace be upon him) came to Medina and we made such transaction, whereupon he said: In case the payment is made on the spot, there is no harm in it, and in case (it is 'sold) on loan, it is usury. You better go to Zaid b. Arqam, for he is a greater trader than I; so I went to him and asked him, and he said like it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3860]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3860

Habib reported that he heard Abu Minhal as saying: I asked al-Bara' b. Azib about the exchange of (gold for silver or vice versa), whereupon he said: you better ask Zaid b. Arqam for he knows more than I. So I asked Zaid but he said: You better ask al-Bara' for he knows more than I. Then both of them said: Allah's Messenger (may peace be upon him) forbade the sale of silver for gold when payment is to be made in future.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3861]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3861

Abd al-Rabman b. Abia Bakra reported on the authority of his father that Allah's Messenger (may peace be upon him) forbade the sale of gold for gold, and silver for silver except equal for equal, and commanded us to buy silver for gold as we desired and buy gold for silver as we desired. A person asked him (about the nature of payment), whereupon he said: It is to be made on the spot. This is what I heard (from Allah's Messenger (may peace be upon him ).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3862]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3862

Abd al-Rabman b. Abu Bakra said: Allah's Messenger (may peace be upon him) prohibited us. The rest of the hadith is the same.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3863]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3863

Fadala b. Ubaid al-Ansari reported: A necklace having gold and gems in it was brought to Allah's Messenger (may peace be upon him) in Khaibar and it was one of the spoils of war and was put to sale. Allah's Messenger (may peace be upon him) said: The gold used in it should be separated, and then Allah's Messenger (may peace be upon him) further said: (Sell) gold for gold with equal weight.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3864]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3864

Fadila b. 'Ubaid (Allah be pleased with him) reported: I bought on the day (of the Victory of Khaibar) a necklace for twelve dinars (gold coins). It was made of gold studded with gems. I separated (gold from gems) in it, and found (gold) of more (worth) than twelve dinars. I made a mention of it to Allah's Apostle (may peace be upon him), whereupon he said: It should not be sold unless it is separated.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3865]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3865

A hadith like this is narrated on the authority of Sa'id b. Yazid with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3866]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3866

Fadala b. 'Ubaid reported: We were in the company of Allah's Messenger ( may peace be upon him) on the day (of the Victory of) Khaibar, and made transaction with the Jews for the 'uqiya of gold for the dinars or three (gold coins), whereupon Allah's Messenger (may peace be upon him) said: Do not sell gold for gold but for equal weight


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3867]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3867

Hanash reported: We were along with Fadala b. Ubaid (Allah be pleased with him) in an expedition. There fell to my and my friend's lot a necklace made of gold, silver and jewels. I decided to buy that. I asked Fadala b. 'Ubaid, whereupon he said: Separate its gold and place it in one pan (of the balance) and place your gold in the other pan, and do not receive but equal for equal, for I heard Allah's Messenger (may peace be upon him) as saying: He who believes in Allah and the Hereafter should not take but equal for equal.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3868]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3868

Ma'mar b. Abdullah reported that he sent his slave with a sa' of wheat and said to him: Sell it, and then buy with it barley. The slave went away and he got a sa' (of barley) and a part of sa' over and above that. When he came to Ma'mar he informed him about that, whereupon Ma'mar said to him: Why did you do that? Go back and return that, and do not accept but weight, for weight, for I used to hear from Allah's Apostle (may peace be upon him) as saying: Wheat for wheat and like for like. He (one of the narrators) said: Our food in those days consisted of barley. It was said to him (Ma'mar) that (wheat) is not like that (barley). He replied: I am afraid these may not be similar


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3869]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3869

Abu Huraira and Abu Sa'id al-Khudri (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) deputed a person from Banu 'Adi al-Ansari to collect revenue from Khaibar. He came with a fine quality of dates, whereupon Allah's Messenger (may peace be upon him) said to him: Are all the dates of Khaibar like this? He said: Allah's Messenger, it is not so. We buy one sa' of (fine quality of dates) for two sa's out of total output (including even the inferior quality of dates), whereupon Allah's Messenger (may peace be upon him) said: Don't do that, but like for like, or sell this (the inferior quality and receive the price) and then buy with the price of that, and that would make up the measure.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3870]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3870

Abu Huraira (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) deputed a person to collect revenue from Khaibar. He brought fine quality of dates, whereupon Allah's Messenger (may peace be upon him) said: Are all the dates of Khaibar like this)? He said: No. We got one sa' (of fine dates) for two sa's (of inferior dates), and (similarly) two sa's for three sa's. Thereupon Allah's Messenger (may peace be upon him) said: Don't do that rather sell the inferior quality of dates for dirhams (money), and then buy the superior quality with the help of dirhams.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3871]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3871

Abd Sa'id reported: Bilal (Allah be pleased with him) came with fine quality of dates. Allah's Messenger (may peace be upon him) said to him: From where (you have brought them)? Bilal said: We had inferior quality of dates and I exchanged two sa's (of inferior quality) with one sa (of fine quality) as food for Allah's Apostle (may peace be upon him), whereupon Allah's Messenger (may peace be upon him) said: Woe! it is in fact usury; therefore, don't do that. But when you intend to buy dates (of superior quality), sell (the inferior quality) in a separate bargain and then buy (the superior quality). And in the hadith transmitted by Ibn Sahl there is no mention of" whereupon".


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3872]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3872

Abu Sa'id (Allah be pleased with him) reported: Dates were brought to Allah's Messenger (may peace be upon him), and he said: These dates are not like our dates, whereupon a man said: We sold two sa's of our dates (in order to get) one sa', of these (fine dates), whereupon Allah's Messenger (may peace be upon him) said: That is interest; so return (these dates of fine quality), and get your (inferior dates) ; then sell our dates (for money) and buy for us (with the help of money) such (fine dates).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3873]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3873

Abu Sa'id (Allah be pleased with him) reported: We were given to eat, during the lifetime of Allah's Messenger (may peace be upon him), dates of different qualities mixed together, and we used to sell two sa's of these for one sa, (of fine quality of dates). This reached Allah's Messenger (may peace be upon him), whereupon he said: There should be no exchange of two sa's of (inferior) dates for one sa (of fine dates) and two sa's of (inferior) wheat for one sa' of (fine) wheat. and one dirham for two dirharms.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3874]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3874

Abu Nadra reported: I asked Ibn Abbas (Allah be pleased with them) about the conversion (of gold and silver for silver and gold). We said: Is it hand to hand exchange? I said: Yes. whereupon he said: There is no harm in it. I informed Abu Sa'id about it, telling him that I had asked Ibn 'Abbas about it and he said: Is it hand to hand exchange? I said: Yes, whereupon he said: There is no harm in it. He (the narrator) said, or he said like it: We will soon write to him, and he will not give you this fatwa (religious verdict). He said: By Allah, someone of the boy-servants of Allah's Messenger (may peace be upon him) brought dates, but he refused to accept them (on the plea) that those did not seem to be of the dates of our land. He said: Something had happened to the dates of our land, or our dates. So I got these dates (in exchange by giving) excess (of the dates of our land), whereupon he said: You made an addition for getting the fine dates (in exchange) which tantamounts, to interest; don't do that (in future). Whenever you find some doubt (as regards the deteriorating quality of) your dates, sell them, and then buy the dates that you like.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3875]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3875

Abu Nadra reported: I asked Ibn Umar and Ibn Abbas (Allah be pleased with them) about the conversion of gold with gold but they did not find any harm in that. I was sitting in the company of Abd Sa'id al-Khudri (Allah be pleased with him) and asked him about this exchange, and he said: Whatever is addition is an' interest. I refused to accept it on account of their statement (statement of Ibn 'Abbas and Ibn 'Umar). He said: I am not narrating to you except what I heard from Allah's Messenger (may peace be upon him). There came to him the owner of a date-palm with one sa' of fine dates, and the dates of Allah's Apostle (may peace be upon him) were of that colour. Allah's Apostle (may peace be upon him) said to him: Where did you get these dates? I went with two sa's of (inferior dates) and bought one sa' of (these fine dates), for that is the prevailing price (of inferior dates) in the market and that is the price (of the fine quality of dates in the market), whereupon Allah's Messenger (may peace be upon him) said: Woe be upon you! You have dealt in interest, when you decide to do it (i. e. exchange superior quality of dates for inferior quality) ; so you should sell your dates for another commodity (or currency) and then with the help of that commodity buy the dates you like. Abu Sa'ad said: When dates are exchanged for dates (with different qualities) there is the possibility (of the element of) interest (creeping into that) or when gold is exchanged for gold having different qualities. I subsequently came to Ibn 'Umar and he forbade me (to do it), but I did not come to Ibn 'Abbas; (Allah be pleased with them). He (the narrator) said: Abu as-Sahba' narrated to me: He asked Ibn Abbas (Allah be pleased with them) in Mecca, and he too disapproved of it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3876]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3876

Abu Salih reported: I heard Abu Sa'id al-Khudri (Allah be pleased with him) said: Dinar (gold) for gold and dirham for dirham can be (exchanged) with equal for equal; but he who gives more or demands more in fact deals in interest. I sald to him: Ibn 'Abbas (Allah be pleased with them) says otherwise, whereupon he said: I met Ibn 'Abbas (Allah be pleased with them) and said: Do you see what you say; have you heard it from Allah's Messenger (may peace be upon him), or found it in the Book of Allah, the Glorious and Majestic? He said: I did not hear it from Allah's Messenger (may peace be upon him). and I did not find it in the Book of Allah (Glorious and Majestic), but Usama b. Zaid narrated it to me that Allah's Apostle (may peace be upon him) said: There can be an element of interest in credit.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3877]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3877

Ubaidullah b. Abu Yazid heard Ibn 'Abbas (Allah be pleased with them) as saying: Usama b. Zaid reported Allah's Apostle (may peace be upon him) as saying: There can be an element of interest in credit (when the payment is not equal).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3878]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3878

Ibn 'Abbas; (Allah be pleased with them) reported on the authority of Usama b. Zaid Allah's Messenger (may peace be upon him) as having said this: There is no element of interest when the money or commodity is exchanged hand to hand.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3879]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3879

Ata' b. Abu Rabah reported: Abu Sa'id al-Khudri (Allah be pleased with them) met Ibn 'Abbas (Allah be pleased with them) and said to him: What do you say in regard to the conversion (of commodities or money) did you hear it from Allah's Messenger (may peace be upon him), or is it something which you found In Allah's Book, Majestic and Glorious? Thereupon Ibn Abbas (Allah be pleated with them) said: I don't say that. So far at Allah's Massenger (may peace be upon him) is concerned, you know him better, and to far as the Book of Allah to concerned, I do not know it (more than you do), but 'Usama b. Zaid (Allah be pleased with him) narrated to me Allah's Messenger (may peace be upon him) as having said this: Beware, there can be an element of interest in credit.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3880]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3880

'Abdullah (b. Mas'ud) (Allah be pleased with him) said that Allah's Messenger (may peace be upon him) cursed the one who accepted interest and the one who paid it I asked about the one who recorded it, and two witnesses to it. He (the narrator) said: We narrate what we have heard.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3881]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3881

Jabir said that Allah's Messenger (may peace be upon him) cursed the accepter of interest and its payer, and one who records it, and the two witnesses, and he said: They are all equal.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3882]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3882

Nu'man b. Bashir (Allah be pleased with him) reported: I heard Allah's Messenger (may peace be upon himn) as having said this (and Nu'man) pointed towards his ears with his fingers): What is lawful is evident and what is unlawful is evident, and in between them are the things doubtful which many people do not know. So he who guards against doubtful things keeps his religion and honour blameless, and he who indulges in doubtful things indulges in fact in unlawful things, just as a shepherd who pastures his animals round a preserve will soon pasture them in it. Beware, every king has a preserve, and the things God his declaced unlawful are His preserves. Beware, in the body there is a piece of flesh; if it is sound, the whole body is sound and if it is corrupt the whole body is corrupt, and hearken it is the heart.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3883]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3883

This hadith has been narrated on the authority of Zakariya with the same chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3884]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3884

AI-Nu'man b. Bashir reported it from Allah's Apostle (may peace be upon him). The hadith narrated by Zakariya is, however, more complete and lengthy than the other ones.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3885]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3885

Nu'man b. Bashir b. Sa'd, a Companion of Allah's Messenger (may peace be upon him) was heard delivering a sermon at Hims and was saying: I heard Allah's Messenger (way peace be upon him) as saying: The lawful is evident and the unlawful is evident, the rest of the hadith is the same as related by Zakariya.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3886]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3886

Jabir b. 'Abdullah (Allah be pleased with them) reported that he was travelling on his camel which had grown jaded, and he decided to let it off. When Allah's Apostle (may peace be upon him) met him and prayed for him and struck it, so it trotted as it had never trotted before. He said: Sell it to me for an 'uqaya. I said: No. He again said: Sell it to me. So I sold it to him for an 'uqaya, but made the stipulation that I should be allowed to ride back to my family. Then when I came to (my place) I took the camel to him and he paid me its price in ready money. I then went back and he sent: (someone) behind me (and as I came) he said: Do you see that I asked you to reduce price for buying your camel. Take your camel and your coins; these are yours.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3887]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3887

This hadith has been narrated on the authority of Jabir through another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3888]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3888

Jabir b. 'Abdullah (Allah be pleased with them) reported: I went on an expedition with Allah's Messenger (may peace be upon him). He overtook me and I was on a water-carrying camel who had grown tired and did not walk (trot). He (the Holy Prophet) said to me: What is the matter with your camel? I said: It is sick. He (the Holy Prophet) stepped behind and drove it and prayed for it, and then it always moved ahead of other camels. He (then) said: How do you find your camel? I said: It is, by the grace of your prayer, all right. He said: Would you sell this (camel) to me? I felt shy (to say him," No" ) as we had no other camel for carrying water, but (later on) I said: Yes, and to I sold it to him on the condition that (I would be permitted) to ride it until I reached Madina. I said to him: Allah's Messenger, I am newly married, so I asked his permission (to go ahead of the caravan). He permitted me, and I reached Medina well in advance of other people, until I reached my destination. There my maternal uncle met me and asked me about the camel, and I told him what I had done with regard to it. He reproved me in this connection. He (Jabir) said: When I asked his permission (to go ahead of the caravan) Allah's Messenger (may peace be upon him) inquired of me whether I had married a virgin or a non-virgin. I said to him: I have married a non-virgin. He said: Why did you not marry a virgin who would have played with you and you would have played with her? I said to him: Allah's Messenger, my father died (or he fell as a martyr), and I have small sisters to (look after), so I did not like the idea that I should marry a woman who is like them and thus be not able to teach them manners and look after them properly. So I have married a non-virgin so that she should be able to look after them and teach them manners, When Allah's Messenger (may peace be upon him) came to Medina, I went to him in the morning with the camel. He paid me its price and returned that (the camel) to me.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3889]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3889

Jabir reported: We went from Mecca to Medina with Allah's Messenger (may peace be upon him) when my camel fell ill, and the rest of the hadith is the same. (But it in also narrated in it: ) He (the Holy Prophet) said to me: Sell your camel to me. I said: No, but it is yours. He said: No. (it can't be), but sell it to me. I said: No, but, Allah's Messenger, it is yours. He said: No, it can't be, but sell it to me. I said: Then give me an 'uqaya of gold for I owe that to a person and then it would be yours. He (the Holy Prophet) said: I take it (for an 'uqiya of gold) and you reach Medina on it. As I reached Medina, Allah's Messenger (may peace be upon him) said to Bilal: Give him an 'uqiya of gold and make some extra payment too. He (Jabir) said: He gave me an 'uqiya of gold and made an addition of a qirat. He (Jabir) said: The addition made by Allah's Messenger (may peace be upon him) was with me (as a sacred trust for belssing) and lay with me in a pocket until the people of Syria took it on the Day of Harra.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3890]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3890

Jabir b. 'Abdullah (Allah be pleased with them) reported: We were with Allah's Messenger (may peace be upon him) in a journey and my camel meant for carrying water lagged behind. The rest of the hadith is the same and it is mentioned also: Allah's Messenger (may peace be upon him) pricked it and then said to me: Ride in the name of Allah. He constantly made addition (in prayers for me) and went on saying. May Allah forgive you!


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3891]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3891

Jabir (Allah be pleased with him) reported: My camel had grown tired as Allah's Messenger (may peace be upon him) came to me. He goaded it and it began to jump. After that I tried to restrain its rein so that I could listen to his (Prophet's) words, but I could not do that. Allah's Apostle (may peace be upon him) met me and said: Sell it to me, and I sold it for five 'uqiyas. I said: On the condition that I may use it as a ride (for going back) to Medina. He (the Holy Prophet) said: Well, you may use it as a ride up till Medina. When I came to Medina I handed over that to him and he made an addition of an uqiya (to that amount which had been agreed upon) and then presented that (camel) to me.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3892]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3892

Abd Mutawakkil al-Najl reported from Jabir b. 'Abdullah (Allah be pleased with them) who said: I accompanied Allah's Messenger (may peace be upon him) in one of his journeys (the narrator says, he said in Jihad), and he narrated the rest of the hadith, and made this addition: He (the Holy Prophet) said: Jabir, have you received the price? I said: Yes, whereupon he said: Yours is the price as well as the camel; yours is the price as well as the camel.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3893]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3893

Jabir b. 'Abdullah (Allah be pleased with them) reported: Allah's Messenger (may peace be upon him) bought a camel from me for two 'uqiyas and a dirham or two dirhams. As he reached Sirar (a village near Medina), he commanded a cow to be slaughtered and it was slaughtered, and they ate of that, and as he (the Holy Prophet) reached Medina he ordered me to go to the mosque and offer two rak'ahs of prayer, and he measured for me the price of the camel and even made an excess payment to me.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3894]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3894

Jabir b. 'Abdullah (Allah be pleased with them) reported this narration from Allah's Apostle (may peace be upon him) but with this variation that he said: He (the Holy Prophet) bought the camel from me on a stipulated price. And he did not mention two 'uqiyas and a dirham or two dirhams, and he comanded a cow (to be slaughtered) and it was slaughtered, and he then distributed its flesh.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3895]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3895

Jabir (Allah be pleased with him) reported that Allah's Apostle (may peace be upon him) said to him: I have taken your camelfor four dinars, and you may ride upon it to Medina.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3896]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3896

Abu Rafi' reported that Allah's Messenger (may peace be upon him) took from a man as a loan a young camel (below six years). Then the camels of Sadaqa were brought to him. He ordered Abu Rafi' to return to that person the young camel (as a return of the loan). Abu Rafi' returned to him and said: I did not find among them but better camels above the age of six. He (the Holy Propet) said: Give that to him for the best men are those who are best in paying off the debt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3897]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3897

Abu Rafi', the freed slave of Allah's Messenger (may peace be upon him), said: Allah's Messenger (may peace be upon him) took as a loan (the rest of the hadith is the same), but with this variation that he (the Holy Prophet) said: Good amongst the servants of Allah is he who is best in paying off the debt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3898]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3898

Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) owed (something) to a person. He behaved in an uncivil manner with him. This vexed the Companions of the Holy Prophet (may peace be upon him), whereupon Allah's Apostle (may peace be upon him) said: He who has a right is entitled to speak, and said to them (his Companions): Buy a camel for him and give that to him. They said: We do not find a camel (of that age) but one with better age than that. He said: Buy that and give that to him, for best of you or best amongst you are those who are best in paying off debt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3899]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3899

Abu Huraira (Allah be pleased with him) reported: Allah's Messenger (may peace be upon him) took a camel on loan, and then returned him (the lender) the camel of a more mature age and said: Good among you are those who are good in clearing off the debt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3900]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3900

Abu Huraira (Allah be pleased with him) reported: There came a person demanding a camel from Allah's Messenger (may peace be upon him). He (the Holy Prophet) said: Give him (the camel) of that age or of more mature age, and said: Best among you is one who is best in clearing off the debt.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3901]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3901

Jabir (Allah be pleased with him) reported: There came a slave and pledg- ed allegiance to Allah's Apostle (may peace be upon him) on migration; he (the Holy Prophet) did not know that he was a slave. Then there came his master and demanded him back, whereupon Allah's Apostle (may peace be upon him) said: Sell him to me. And he bought him for two black slaves, and he did not afterwards take allegiance from anyone until he had asked him whether he was a slave (or a free man)


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3902]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3902

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) bought some grain from a Jew on credit and gave him a coat-of- mail of his as a pledge.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3903]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3903

'A'isha (Allah be pleased with her) reported: Allah's Messenger (may peace be upon him) bought from a Jew grain (as loan) and pledged him his iron coat-of-mail.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3904]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3904

'A'isha (Allah be pleased with her) reported that Allah's Messenger (may peace be upon him) bought from a Jew grain for a specified time; and gave him iron coat-of-mail of his as a pledge.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3905]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3905

This hadith has been narrated on the authority of 'A'isha (Allah be pleased with her), through another chain ol transmitters, but no mention was made of (its being made) of iron.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3906]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3906

Ibn 'Abbas (Allah be pleased with them) reported that when Allah's Prophet (may peace be upon him) came to Medina, they were paying one and two years in advance for fruits, so he said: Those who pay in advance for anything must do so for a specified weight and for a definite time.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3907]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3907

Ibn 'Abbas (Allah be pleased with them) reported that when Allah's Messenger (may peace be upon him) came to (Medina) and the people were paying in advance (for the fruits, etc.), he said to them: He who makes an advance payment should not make advance payment except for a specified measure and weight (and for a specified period).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3908]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3908

Ibn Abu Najih has narrated a hadith like this with the same chain of transmitters, but he has not mentioned:" for a definite period".


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3909]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3909

This hadith has been narrated by Ibn Abu Najih through another chain of transmitters mentioning in it" for a specified period".


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3910]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3910

Ma'mar (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: He who hoards is a sinner. It was said to Sa'id (b. al-Musayyib): You also hoard. Sa'id said: Ma'mar who narrated this badith also hoarded.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3911]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3911

Ma'mar b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: No one hoards but the sinner.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3912]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3912

This hadith has been transmitted on the authority of Sulaiman b. Bilal from Yahya.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3913]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3913

Abu Huraira (Allah be pleased with him) said he heard Allah's Messenger (may peace be upon him) as saying: Swearing produces a ready sale for a commodity, but blots out the blessing.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3914]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3914

Abu Qatada al-Ansari (Allah be pleased with him) reported he heard Allah's Messenger (may peace be upon him) say: Beware of swearing; it produces a ready sale for a commodity, but blots out the blessing.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3915]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3915

Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who has a partner in a dwelling or a garden, it is not lawful for him to sell that until he is permitted by his partner. If he (the partner) agrees, he should go in for that, and if he disapproves of that, he should abandon (the idea of selling it).


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3916]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3916

Jabir bin 'Abdullah (Allah be pleased with them) said that the Messenger of Allah (may peace be upon him) decreed pre-emption in every joint ownership and not divided-the one-it may be a dwelling or a garden. It is not lawful for him (for the partner) to sell that until his partner gives his consent. He (the partner) is entitled to buy it when he desires and he can abandon it if he so likes. And if he (the one partner) sells it without getting the consent of the (other partner), he has the greatest right to it.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3917]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3917

Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: There is pre-emption in everything which is shared, be it land, or a dwelling or a garden. It is not proper to sell it until he informs his partner; he may go in for that, or he may abandon it; and it he (the partner intending to sell his share) does not do that, then his partner has the greatest right to it until he permits him.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3918]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3918

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: None among you should prevent his neighbour from fixing a beam in his wall. Abu Huraira (Allah be pleased with him) then said: What is this that I see you evading (this injunction of the Holy Prophet)? By Allah, I will certainly throw it between your shoulders (narrate this to you.)


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3919]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3919

This hadith is narrated on the authority of Zuhri with the same chain of transrmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3920]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3920

Sa'id b. Zaid b. 'Amr b. Nufail (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: He who wrongly took a span of land, Allah shall make him carry around his neck seven earths.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3921]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3921

Sa'id b. Zaid b. 'Amr b. Nufail (Allah be pleased with them) reported that Arwi (bint Uwais) disputed with him (in regard to a part of the land) of his hodse. He said: Leave it and take off your claim from it, for I heard Allah's Messenger (may peace be upon him) as saying: He who took a span of land without his right would be made to wear around his neck seven earths on the Day of Resurrection. He (Sa'id b. Zaid) said: O Allah, make her blind if she has told a lie and make her grave in her house. He (the narrator) said: I saw her blind groping (her way) by touching the walls and saying: The curse of Sa'id b. Zaid has hit me. And it so happened that as she was walking in her house, she passed by a well in her house and fell therein and that be- came her grave.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3922]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3922

Hisham b. Urwa reported on the authority of his father (Allah be pleased with him) that Arwa bint Uwais disputed with Sa'id b. Zaid that he had seized some of the land belonging to her. She brought this dispute before Marwan b. al-Hakam. Sa'id said: How could I take a part of her land, after what I heard from Allah's Messenger (may peace be upon'him)? He (Marwan) said: What did you hear from Allah's Messenger (may peace be upon him)? He said: I heard Allah's Messenger (may peace be upon him) say: He who wrongly took a span of land would be made to wear around his neck seven earths. Marwan said: I do not ask any evidence from you after this. He (Sa'id) said: O Allah, make her blind if she has told a lie and kill her in her own land. He (the narrator) said: She did not die until she had lost her eyesight, and (one day) as she was walking in her land, she fell down into a pit and died.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3923]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3923

Sa'id b. Zaid reported: I heard Allah's Apostle (may peace be upon him) say: He who took a span of earth wrongly would be made to wear around his neck seven earths on the Day of Resurrection.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3924]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3924

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace he upon him) as saying: One should not take a span of land without having legitimate right to it, otherwise Allah would make him wear (around his neck) seven earths on the Day of Resurrection.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3925]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3925

Muhammad b. Ibrahim said that Abu Salama reported to him that there was between him and his people dispute over a piece of land, and he came to 'A'isha and mentioned that to her, whereupon she said: Abu Salama, abstain from getting this land, for Allah's Messenger (may peace be upon him) said: He who usurps even a span of land would be made to wear around his neck seven earths.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3926]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3926

This hadith has been narrated on the authority of Abu Salama with another chain of transmitters.


Muslim :: The Book of Transactions (Kitab Al-Buyu`) :: [10.3927]

The Book of Transactions (Kitab Al-Buyu`)

Muslim :: Book 10 : Hadith 3927

Abu Haraira reported Allah's Apostle (may peace be upon him) as saying: When you disagree about a path, its breadth should be made seven cubits.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3928]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3928

Usama b. Zaid reported Allah's Messenger (may peace be upon him) as saying: A Muslim is not entitled to inherit from a non-Muslim, and a non-Muslim is not entitled to inherit from a Muslim.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3929]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3929

Ibn Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Give the shares to those who are entitled to them, and what remains over goes to the nearest male heir.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3930]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3930

Ibn 'Abbas (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Give the shares to those who are entitled to them, and what is left from those wno are entitled to it goes to the nearest male heir.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3931]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3931

Tawus reported on the authority of his father Ibn Abbas (Allah be pleased with them) narrating that Allah's Messenger (may peace be upon him) said: Distribute the property amongst Ahl al-Fara'id, according to the Book of Allah, and what is left out of them goes to the nearest male heir.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3932]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3932

Jabir b. 'Abdullah (Allah be pleased with them) reported: I fell sick and there came to me on foot Allah's Messenger (may peace be upon him) and Abu Bakr for inquiring after my health. I fainted. He (the Holy Prophet) performed ablution and then sprinkled over me the water of his ablution. I felt some relief and said: Allah's Messenger, how should I decide about my property? He said nothing to me in response until this verse pertaining to the law of inheritance was revealed:" They ask you for a decision; say: Allah gives you a decision concerning the person who has neither parents nor children" (iv. 177).


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3933]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3933

Jabir b. 'Abdullah (Allah be pleased with him) reported: Allah's Apostle (may peace be upon him) and Abi Bakr (Allah be pleased with him) visited me on foot in Banu Salama, and found me unconscious. He (the Holy Prophet) called for water and performed ablution and sprinkled out of it (the water) over me. I felt relieved. I said: Allah's Messenger, what should I do with my property? And this verse was revealed:" Allah enjoins you concerning your children: for the male is equal of the portion of two females."


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3934]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3934

Jabir b. 'Abdullah (Allah be pleased with them) reported: While I had been ill Allah's Messenger (may peace be upon him) visited me and Abu akr (Allah be pleased with him) was with him, and they both came walking on foot. He (the Holy Prophet) found me unconscious. Allahs Messenger (may peace be upon him) performed ablution and then sprinkled over me the water of his ablution. I felt relieved regained my consciousness) and found Allah's Messenger (may peace be upon him) there. I said: Allah's Messenger, what should I do with my property? He gave me no reply until the verse (iv. 177) relating to the law of inheritance was revealed.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3935]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3935

Jabir b. Abdullah (Allah be pleased with him) reported: Whilo I was ill Allah's Messenger (may peace be upon him) came to me and found me unconscious. He (the Holy Prophet) performed ablution, and sprinkled over me the water of his ablution. I regained my consciousness and said: Allah's Messenger, my case of inheritance is that of Kalala. Then the verse pertaining to the inheritance ( of Kalala) was revealed. I (one of the narrators) said: I said to Muhammad b. Munkadir: (Do you mean this verse)" They ask you; say: Allah gives you decision in regard to Kalala" (iv. 177)? He said: Yes, it was thus revealed.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3936]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3936

This hadith is transmitted on the authority of Shu'ba but with a slight variation of words.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3937]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3937

Abu Talha reported: 'Umar b. al-Khattab (Allah be pleased with him) delivered a sermon on Friday and made a mention of Allah's Apostle (may peace be upon him) and he also made a mention of Abu Bakr (Allah be pleased with him) and then said: I do not leave behind me any problem more difficult than that of Kalala. I did not refer to Allah's Messenger (may peace be upon him) more repeatedly than in case of the problem of Kalala, and he (the Holy Prophet) never showed more annoyance to me than in regard to this problem, so much so that he struck my chest with his fingers and said: 'Umar, does the verse revealed in summer season, at the end of Sura al-Nisa' not suffice you? Hadrat 'Umar (then) said: If I live I would give such verdict about (Kalala) that everyone would be able to decide whether he reads the Qur'an or he does not.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3938]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3938

This hadith has been narrated on the authority of Qatada with the same chain of transmitters.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3939]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3939

Al-Bara' (Allah be pleased with him) reported that the last verse revealed in the Holy Qur'an is:" They ask thee for a religious verdict; say: Allah gives you a religious verdict about Kalala (the person who has neither parents nor children)" (iv 177).


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3940]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3940

Abu Ishaq said that he heard al-Bara' b. 'Azib (Allah be pleased with him say: The last verse revealed (in the Holy Quran) is that pertaining to Kalala, and the last sura revealed is Sura al-Bara'at.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3941]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3941

Abu Ishaq said that he heard al-Bara' b. 'Azib (Allah be pleased with him) say: The last complete sura revealed (in the Holy Qur'an) is Sura Tauba (i e. al-Bara'at, ix.), and the last verse revealed is that pertaining to Kalala.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3942]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3942

Aba Ishaq reported this hadith on the authority of al-Bara' (Allah be pleased with him) with a slight variation of words, viz. the last sura that was revealed complete.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3943]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3943

Al-Bara' (Allah be pleased with him) reported that the last verse revealed was:" They ask of thee religious verdict.." (iv. 177).


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3944]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3944

Abu Huraira (Allah be pleased with him) reported that when the body of a dead person having burden of debt upon him was brought to Allah's Messenger (may peace be upon him) he would ask whether he had left property enough to clear off his debt, and if the property left had been sufficient for that (purpose), he observed funeral prayer for him, otherwise he said (to his companions): You observe prayer for your companion. But when Allah opened the gateways of victory for him, he said: I am nearer to the believers than themselves, so if anyone dies leaving a debt, its payment is my responsibility, and if anyone leaves a property, it goes to his heirs.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3945]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3945

This hadith has been narrated on the authority of al-Zuhri through another chain of transmitters.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3946]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3946

Abn Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) having said this: By Him in Whose Hand is the life of Muhammad, there is no believer on the earth with whom I am not the nearest among all the people. He who amongst you (dies) and leaves a debt, I am there to pay it, and he who amongst you (dies) leaving behind children I am there to look after them. And he who amongst You leaves behind property, that is for the inheritor whoever he is.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3947]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3947

Hammam b. Munabbih reported: This is what Abu Huraira (Allah be pleased with him) narratted to us from Allah's Messenger (may peace he upon him). And he narrated many ahadith, and one was this: Allali's Messenger (may peace be upon him said: I am, according to the Book of Allah, the Exalted and Majestic, nearest to the believers of all the human beings. So whoever amongst you dies in debt or leaves behind destitute children, you should call me (for help) ), for I am his guardian. And who amongst you leaves property, his inheritor is entitled to get it, whoever he is.


Muslim :: The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d) :: [11.3948]

The Book Pertaining to the Rules of Inheritance (Kitab Al-Farai`d)

Muslim :: Book 11 : Hadith 3948

Abu Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: He who leaves property, that is for the inheritors; and he who leaves behind destitute children, then it is my responsibility (to look after them). This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3949]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3949

Umar b. Khattab (Allah be pleased with him) reported: I donated a pedigree horse in the path of Allah. Its possesser made it languish. I thought that he would sell it at a cheap price. I asked Allah's Menengsr (may peace be upon him) about it, whereupon he said: Don't buy it and do not get back your charity, for one who gets back the charity is like a dog who swallows its vomit. This hadith has been narrated on the authority of Malik b. Anas with the same chain of transmitters but with this addition:" Don't buy that even if he gives you for one dirham."


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3950]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3950

Zaid b. Aslam reported on the authority of his father that 'Umar (Allah be pleased with him) donated a horse in the path of Allah. He found that it had languished in the hand of its possessor, and he was a man of meagre resources He (Hadrat 'Umar) intended to buy it. He came to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: Don't buy that even if you get it for a dirham for he who gets back the charity is like a dog which swallows its vomit.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3951]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3951

This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters but with this (change) that the hadith transmitted on the authority of Malik and Rauh (he was the son of Qisirn) is more complete and lengthy.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3952]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3952

Ibn 'Umar reported that 'Umar b. al-Khattib (Allah be pleased with him) donated a horse in the path of Allah and (later on) he found it being sold, and he decided to buy that. He asked the Messenger of Allah (may peace be upon him) about it. whereupon he (the Holy prophet) said: Don't buy that and do not get back what you gave in charity.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3953]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3953

This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3954]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3954

Salim reported from Ibn Umar (Allah be pleased with them) that 'Umar donated a horse in the path of Allah and then found it being sold, and he decided to buy that. He asked Allah's Apostle (may peace be upon him) about it, whereupon Allah's Messenger (may peace be upon him) said: Umar, do not get back what you gave as charity.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3955]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3955

Ibn 'Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) having said this: He who gets back his charity is like a dog which vomit, and then returns to that and eats it.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3956]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3956

A hadith like this is reported on the authority of Muhammad son of Fatima (Allah be pleased with her) daughter of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3957]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3957

Ibn Abbas (Allah be pleased with them) reported: I heard Allah's Messenger (may peace be upon him) say: The similitude of one who gives a charity and then gets it back is like that of a dog which vomits and then eats its vomit.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3958]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3958

Ibn Abbas (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: One who gets back the gift is like one who eats vomit.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3959]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3959

This hadith has been narrated on the authority of Qatada with the same chain of transmitters.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3960]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3960

Abdullah b. Tawus reported on the authority of his father who reported from Ibn Abas (Allah be pleased with them) who reported from Allah's Messenger 'may peace be upon him) that he said: One who gets back his gift is like a dog which vomits and then swallows that vomit.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3961]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3961

Nu'man b. Bashir reported that his father brought him to Allah's Messenger (may peace be upon him) and said: I have donated this slave of mine to my son. Allah's Messenger (may peace be upon him) said: Have you donated to every one of your sons (a slave) like this? He said: No. Thereupon Allah's Messenger (may peace he upon him) said: Then take him back.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3962]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3962

Nu'man b. Bashir reported: My father brought me to Allah's Messenger (may peace be upon him) and said: I have donated this slave to my son. whereupon he said: Have you made (such) donation to every one or your sons? He said: No. Thereupon he (the-Holy Prophet) said: Then take him back.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3963]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3963

This hadith has been narrated on the authority of Zubri with different chains of transmitters and a slight variation of words.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3964]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3964

Nu'man b. Bashir reported that his father had donated a slave to him. Allah's Apostle (may peace he upon him) said: Who is this slave (how have you come to possess it)? Thereupon he (Nu'man b. Bashir) said: My father has donated it to me, whereupon he said: Have all brothers (of yours) been given this gift as given to you? He said: No. Thereupon he (the Holy Prophet) said: Then return him.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3965]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3965

Nu'man b. Bashir reported: My father donated to me some of his property. My mother Amra bint Rawaha said: I shall not be pleased (with this act) until you make Allah's Messenger (may peace be upon him) a witness to it. My father went to Allah's Apostle (may peace be upon him) in order to make him the witness of the donation given to me. Allah's Messenger (may peace be upon him) said to him: Have you done the same with every son of yours? He said: No. Thereupon he (the Holy Prophet) said: Fear Allah, and observe equity in case of your children. My father returned and got back the gift.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3966]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3966

Nu'man b. Bashir reported that his mother bint Rawaha asked his (Nu'man's) father about donating some gifts from his property to his son. He deferred the matter by one year, and then set forth to do that. She (Nu'man's mother) said: I shall not be pleased unless you call Allah's Messenger (may peace be upon him) as witness to what you confer as a gift on your son. (Nu'man said): So father took hold of my hand and I was at that time a boy, and came to Allah's Messenger (may peace be upon him). and said: Allah's Messenger, the mother of this son (of mine), daughter of Rawaha wishes that I should call you witness to what I confer as gift to her son. Allah's Messenger (may pease be upon him) said: Bashir, have you any other son besides this (son of yours)? He said: Yes. He (the Holy Prophet) said: Have you given gifts to all of them like this? He said: No. Thereupon he (the Holy Prophet) said: Then call me not as witness, for I cannot be witness to an injustice.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3967]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3967

Nu'man b. Bashir, reported that Allah's Messenger (may peace be upon him) had said: Have you, besides him, other sons? He said: Yes. Thereupon he (the Holy Prophet) said: Have you given gifts to all of them like this (as you have given to Nu'man)? He said: No. Thereupon he (the Holy Prophet) said: I cannot bear witness to an injustice.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3968]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3968

Nu'man b. Bashir (Allah be pleased with them) reported that Allah's Messenger (may peace be upon him) said to his father: Call me not as witness to an injustice.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3969]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3969

Nu'man b. Bashir (Allah be pleased with them) reported: My father took me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, bear witness that I have given such and such gift to Nu'man from my property, whereupon he (the Holy Prophet) said: Have you conferred upon all of your sons as you have conferred upon Nu'man? He said: No. Thereupon he (the Holy Prophet) said: Call someone else besides me as a witness. And he further said: Would it, please you that they (your children) should all behave virtuously towards you? He said: Yes. He (the Holy Prophet) said: Then don't do that (i e. don't give gift to one to the exclusion of others).


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3970]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3970

Nu'man b. Bashir reported: My father conferred a gift upon me, and then brought me to Allah's Messenger (may peace be upon him) to make him a witness (to it). He (the Holy Prophet) said: Have you given such gift to every son of yours (as you have given to Nu'man)? He said: No. Thereupon he (the Holy Prophet) said: Don't you expect goodness from them as you expect from him? He said: Yes. of course. He (the Holy Prophet) said: I am not going to bear witness to it (as it is injustice). Ibn Aun (one of the narrators) said: I narrated this hadith to Muhammad (the other narrator) who said: Verily we narrated that lie (the Holy Prophet) had said: Observe equity amongst your children.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3971]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3971

Jabir (Allah be pleased with him) reported that the wife of Bashir said (to her husband): Give to my son your slave as a gift, and make for me Allah's Messenger (may peace be upon him) a witness He came to Allah's Messenger (may peace be upon him) and said: The daughter of so and so (his wife Amra bint Rawaha) asked me to give my slave as a gift to her son, and call for me Allah's Messenger (may peace be upon him) as a witness. Thereupon he (the Holy Prophet) said: Has he (Nu'man) brothers? He (Bashir) said: Yes. He (further) said: Have you given to all others as you have given to him? He said: No. He said: Then it is not fair; and verily I cannot bear witness but only to what is just.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3972]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3972

Jabir b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: Whoever a person is gifted a life grant, then it is for him (belongs to him and to his posterity, for it belongs to him who has been gven it). It would not return to him who gave it for he conferred it as a gift (it becomes the property of the donee and as such) rules of inheritance will apply to it.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3973]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3973

Jaber b. 'Abdullah (Allah be pleased with them) reported Allah's Messenger (may peace be upan him) as saying: He who conferred a life grant upon a person, it becomes his possession and that of his successors, for he surrendered his right in that by his declaration. (This property) now belongs to one to whom this lifelong grant has been made, and to his successors. Yahya narrated in the beginning of his narration: Whatever man is given a life grant, then it belongs to him and his posterity.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3974]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3974

Jabir b. 'Abdullah al-Ansari (Allah be pleased with him) said: Allah's Messenger (may peace be upon him) said: Whoever a person conferred Umra (life grant) upon a person and he says: I confer upon you this and upon your descendants and anyone who survives you, and that becomes his possession and that of his posterity. It would become (a permanent possession) of those who were conferred upon this gift, and it would not return to its owner (donor), for he gave that as a gift in which accrued the right of inheritance.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3975]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3975

Jabir (Allah be pleased with him) said: The Umra for which Allah's Messenger (may peace be upon him) gave sanction that a person way say: This (property) is for you and for your descendants. And when he said: That is for you as long as you live, then it will return to its owner (after the death of the donee). Ma'mar said: Zuhri used to give religious verdict according to this.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3976]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3976

Jabir b. 'Abdullah (Allah be pleased with him) reported that Allah's Messenger (may peace be upon him) commanded that whoever is conferred upon a life grant along with his descendants is entitled to make use of the property conferred so long as he lives and his successors (also enjoy this privilege). That (property) becomes the their defect belonging. The donor cannot (after declaring Umra) lay down any condition or make any exception. Abu Salama said: For he conferred a grant and as such it becomes heritage. and the right of inheritance abrogated his condition.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3977]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3977

Jabir (b. 'Abdullah) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: Life grant is for one upon whom it is bestowed.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3978]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3978

Jabir b. 'Abdullah reported a hadith like this through another chain of transmitters.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3979]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3979

Jabir reported this hadith directly from Allah's Apostle (may peace be upon him)


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3980]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3980

Jabir (b. 'Abdullah) (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) having said: Keep your property to yourselves and do not squander it, for he who conferred a life grant upon another that property will belong to him upon whom it is conferred whether he lives or dies, and (would pass on) to his successors (as heritage).


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3981]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3981

This hadith is narrated on the authority of Jabir through other chains of transmitters, but (with this addition of words) that thehadith transmitted on the authority of Ayyub (these words are found):" The Helpers (Ansar) conferred the benefit of 'Umra, upon the Emigrants (Muhajirin), whereupon Allah's Messenger (may peace be upon him) said: Keep your property to yourselves.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3982]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3982

Jabir (Allah be pleased with him) reported that a woman gave her garden as a life grant to her son. He died and later on she also died and left a son behind and brothers also, The sons of the woman making life grant said (to those who had been conferred upon this 'Umra): This garden has returned to us. The sons of the one who had been given life grant said: This belonged to our father, during his lifetime and in case of his death. They took their dispute to Tariq, the freed slave of 'Uthman. He called Jabir and he gave testimony of Allah's Messenger (may peace be upon him) having said: Life grant belongs to one who is conferred upon this (privilege). Tariq gave this decision and then wrote to Abd al-Malik and informed him, Jabir bearing witness to it. Abd al-Malik said: Jabir has told the truth. Then Tariq gave a decree and, as a result thereof, it is to this day that the garden belongs to descendants of one who was conferred upon the life grant.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3983]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3983

Sulaiman b. Yasir reported that Jabir gave this verdict. The inheritor has a right (to inherit) the life grant according to the statement of Jabir (b. 'Abdullah) (Allah be pleased with him) which he narrated from Allah's Messenger (may peace be upon him).


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3984]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3984

Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: Life grant is permissible.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3985]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3985

Jabir b. Abdullah (Allah be pleased with them) reported Allah's Apostle (may peace be upon him) as saying: Life grant is the heritage of one upon whom it is conferred.


Muslim :: The Book of Gifts (Kitab Al-Hibat) :: [12.3986]

The Book of Gifts (Kitab Al-Hibat)

Muslim :: Book 12 : Hadith 3986

Abd Huraira (Allah be pleased with him) reported Allah's Apostle (may peace be upon him) as saying: Life grant is permissible. This ha: dith is narrated on the authority of Qatada with the same chain of transmitters.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3987]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3987

Ibn Umar (Allah be pleased with them) reported Allah's Messenger (may peace be upon him) as saying: It is the duty of a Muslim who has something which is to be given as a bequest not to have it for two nights without having his will written down regarding it.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3988]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3988

This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters. but with a slight variation of words.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3989]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3989

A hadith like this have been narrated on the authority of Nifi', who based his narrations of the words of Ibn 'Umar but with a slight variation of words.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3990]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3990

Salim reported on the authority of his father ('Abdullah b. Umar) that he (his father) had heard Allah's Messenger (may peace be upon him) as saying: It is not proper for a Muslim who has got something to bequeathe to spend even three nights without having his will written down with him regarding it. 'Abdullah b. 'Umar (Allah be pleased with them) said: Ever since I heard Allah's Messenger (may peace be upon him) say this I have not spent a night without having my will (written) along with me. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3991]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3991

Amir b. Sa'd reported on the authority of his father (Sa'd b. Abi Waqqas): Allah's Messenger (may peace be upon him) visited me in my illness which brought me near death in the year of Hajjat-ul-Wada' (Farewell Pilgrimage). I said: Allah's Messenger, you can well see the pain with which I am afflicted and I am a man possessing wealth, and there is none to inherit me except only one daughter. Should I give two-thirds of my property as Sadaqa? He said: No. I said: Should I give half (of my property) as Sadaqa? He said: No. He (further) said: Give one-third (in charity) and that is quite enough. To leave your heirs rich is better than to leave them poor, begging from people; that you would never incur an expense seeking therewith the pleasure of Allah, but you would be rewarded therefor, even for a morsel of food that you put in the mouth of your wife. I said: Allah's Messenger. would I survive my companions? He (the Holy Prophet) said: If you survive them, then do such a deed by means of which you seek the pleasure of Allah, but you would increase in your status (in religion) and prestige; you may survive so that people would benefit from you, and others would be harmed by you. (The Holy Prophet) further said: Allah, complete for my Companions their migration, and not cause them to turn back upon their heels. Sa'd b. Khaula is, however, unfortunate. Allah's Messenger (may peace be upon him) felt grief for him as he had died in Mecca.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3992]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3992

This hadith is narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3993]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3993

'Amir b. Sa'd reported from S'ad (b. Abu Waqqas): Allah's Apostle (may peace be upon him) visited me to inquire after my health, the rest of the hadith is the same as transmitted on the authority of Zuhri, but lie did not make mention of the words of Allah's Apostle (may peace be upon him) in regard to Sa'd b. Khaula except this that he said:" He (the Holy Prophet) did not like death in the land from which lie had migrated."


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3994]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3994

Mus'ab b. Sa'd reported on the authority of his father. I was ailing. I sent message to Allah's Apostle (may peace be upon him) saying: Permit me to give away my property as I like. He refused. I (again) said: (Permit me) to give away half. He (again refused). I (again said): Then one-third. He (the Holy Prophet) observed silence after (I had asked permission to give away) one-third. He (the narrater) said: It was then that endowment of one-third became permissible.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3995]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3995

This hadith has been narrated on the authority of Simak with the same chain of transmitters. But he did not mention:" It was then that one-third became permissible."


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3996]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3996

Ibn Sa'd reported his father as saying: Allah's Apostle (may peace be upon him) visited me during my illness. I said: I am willing away the whole of my property. He said: No. I said: Then half? He said: No. I said: Should I will away one-third? He said: Yes, and even one-third is enough.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3997]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3997

Humaid b. 'Abd al-Rahman al-Himyari reported from three of the sons of Sa'd all of whom reported from their father that Allah's Apostle (may peace be upon him) visited Sa'd as he was ill in Mecca. He (Sa'd) wept. He (the Holy Prophet) said: What makes you weep? He said: I am afraid I may die in the land from where I migrated as Sa'd b. Khaula had died. Thereupon Allah's Apostle (may peace be upon him) said: O Allah, grant health to Sa'd. O Allah, grant health to Sad. He repeated it three times. He (Sa'd) said: Allah's Messenger, I own a large property and I have only one daughter as my inheritor. Should I not will away the whole of my property? He (the Holy Prophet) said: No. He said: (Should I not will away, ) two-thirds of the property? he (the Holy Prophet) said: No. He (Sa'd) (again) said: (Should I not will away) half (of my property)? He said: No. He (Sa'd) said: Then one-third? Thereupon he (the Holy Prophet) said: (Yes), one-third, and one-third is quite substanial. And what you spend as charity from your property is Sadaqa and flour spending on your family is also Sadaqa, and what your wife eats from your property is also Sadaqa, and that you leave your heirs well off (or he said: prospreous) is better than to leave them (poor and) begging from people. He (the Holy Prophet) pointed this with his hands.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3998]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3998

Humaid b. Abd al-Rahmin al-Himayri reported on the authority of the three of the sons of Sa'd: They said: Sa'd fell ill in Mecca. Allah's Messenger (may peace be upon him) visited him to inquire after his health. The rest of the hadith is the same.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.3999]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 3999

Humaid b. Abd al-Rahman reported this hadith on the authority of three of Sa'd's sons: Sa'd fell ill in Mecca and Allah's Apostle (may peace be upon him) visited him. The rest of the hadith is the same.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4000]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4000

Ibn 'Abbas (Allah be pleased with them) said: (I wish) if people would reduce from third to fourth (part for making a will of their property), for Allah's Messenger (may peace be upon him) said: So far as the third (part) is concerned it is quite substantial. In the hadith transmitted on the authority of Waki (the words are)" large" or" much".


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4001]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4001

Abu Huraira (Allah be pleased with him) reported that a person said to Allah's Apostle (may peace be upon him): My father died and left behind property without making any will regarding it. Would he be relieved of the burden of his sing if I give sadaqa on his behalf? He (the Holy Prophet) said: Yea.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4002]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4002

A'isha (Allah be pleased with her) reported that a man said to Allah's Apostle (may peace be upon him): My mother died all of a sudden, and I think if she (could have the opportunity) to speak she would have (made a will) regarding Sadaqa'. Will I be entitled to reward if I give charity on her behalf? He (the Holy Prophet) said: Yes.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4003]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4003

A'isha (Allah be pleased with her) reported that a man came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, my mother died all of a sudden without making any will. I think if (she could have the opportunity) to speak she would have made a Sadaqa. Would there be any reward for her if I give charity on her behalf? He (the Holy Prophet) said: Yes.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4004]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4004

This hadith has been narrated on the authority of Hisham b. 'Urwa with the same chain of transmitters.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4005]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4005

Abu Huraira (Allah be pleased with him) reported Allah's Messenger (may peace be upon him) as saying: When a man dies, his acts come to an end, but three, recurring charity, or knowledge (by which people) benefit, or a pious son, who prays for him (for the deceased).


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4006]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4006

Ibn Umar reported: Umar acquired a land at Khaibar. He came to Allah's Apostle (may peace be upon him) and sought his advice in regard to it. He said: Allah's Messenger, I have acquired land in Khaibar. I have never acquired property more valuable for me than this, so what do you command me to do with it? Thereupon he (Allah's Apostle) said: If you like, you may keep the corpus intact and give its produce as Sadaqa. So 'Umar gave it as Sadaqa declaring that property must not be sold or inherited or given away as gift. And Umar devoted it to the poor, to the nearest kin, and to the emancipation of slaves, aired in the way of Allah and guests. There is no sin for one, who administers it if he eats something from it in a reasonable manner, or if he feeds his friends and does not hoard up goods (for himself). He (the narrator) said: I narrated this hadith to Muhammad, but as I reached the (words)" without hoarding (for himself) out of it." he (Muhammad' said:" without storing the property with a view to becoming rich." Ibn 'Aun said: He who read this book (pertaining to Waqf) informed me that in it (the words are)" without storing the property with a view to becoming rich."


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4007]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4007

This hadith has been narrated on the authority of Ibn 'Aun with the same chain of transmitters up to the words:" Or he may feed the friend withoiut hoarding from it" and he made no mention of what follows.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4008]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4008

'Umar reported: I acquired land from the lands of Khaibar. I came to Allah's Messenger (may peace be upon him) and said: I have acquired a piece of land. Never have I acquired land more loved by me and more cherished by me than this. The rest of the hadith is the same, but he made no mention of this:" I narrated it to Muhammad" and what follows.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4009]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4009

Talha b. Musarrif reported: I asked 'Abdullah b. Abu Aufa whether Allah's Messenger (may peace be upon him) had made any will (in regard to his property). He said: NO. I said: Then why has making of will been made necessary for the Muslims, or why were they commanded to make will? Thereupon he said: He made the will according to the Book of Allah, the Exalted and Majestic.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4010]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4010

This hadith has been narrated on the authority of Malik b. Mighwal with the same chain of transmitters but with a slight variation of words. In the hadith related by Waki (the words are)" I said: How the people have been ordered about the will" ; and in the hadith of Ibn Numair (the words are):" How the will has been prescribed for the Muslims, '.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4011]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4011

A'isha reported: Allah's Messenger (may peace be upon him) left neither dinar nor dirham (wealth in the form of cash), nor goats (and sheep), nor camels. And he made no will about anything (in regard to his material possessions, as he had none),


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4012]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4012

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4013]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4013

Aswad b. Yazid reported: It was mentioned before A'isha that will had been made (by the Holy Prophet) in favour of 'Ali (as the Prophet's first caliph), whereupon she said: When did he make will in his favour? I had been providing support to him (to the Holy Prophet) with my chest (or with my lap). He asked for a tray, when he fell in my lap (relaxing his body), and I did not realise that he had breathed his last. When did he make any will in his ('Ali's) favour?


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4014]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4014

Sa'id b. Jubair reported that Ibn 'Abbas said: Thursday, (and then said): What is this Thursday? He then wept so much that his tears moistened the pebbles. I said: Ibn 'Abbas, what is (significant) about Thursday? He (Ibn 'Abbas) said: The illness of Allah's Messenger (may peace be upon him) took a serious turn (on this day), and he said: Come to me, so that I should write for you a document that you may not go astray after me. They (the Companions around him) disputed, and it is not meet to dispute in the presence of the Apostle. They said: How is lie (Allah's Apostle)? Has he lost his consciousness? Try to learn from him (this point). He (the Holy Prophet) said: Leave me. I am better in the state (than the one in which you are engaged). I make a will about three things: Turn out the polytheists from the territory of Arabia; show hospitality to the (foreign) delegations as I used to show them hospitality. He (the narrator) said: He (Ibn Abbas) kept silent on the third point, or he (the narrator) said: But I forgot that.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4015]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4015

Sa'id b. Jubair reported from Ibn Abbas that he said: Thursday, and what about Thursday? Then tears began to flow until I saw them on his cheeks as it they were the strings of pearls. He (the narrator) said that Allah's Messenger (may peace be upon him) said: Bring me a shoulder blade and ink-pot (or tablet and inkpot), so that I write for you a document (by following which) you would never go astray. They said: Allah's Messenger (may peace upon him) is in the state of unconsciousness.


Muslim :: The Book of Bequests (Kitab Al-Wasiyya) :: [13.4016]

The Book of Bequests (Kitab Al-Wasiyya)

Muslim :: Book 13 : Hadith 4016

Ibn Abbas reported: When Allah's Messenger (may peace be upon him) was about to leave this world, there were persons (around him) in his house, 'Umar b. al-Kbattab being one of them. Allah's Apostle (may peace be upon him) said: Come, I may write for you a document; you would not go astray after that. Thereupon Umar said: Verily Allah's Messenger (may peace be upon him) is deeply afflicted with pain. You have the Qur'an with you. The Book of Allah is sufficient for us. Those who were present in the house differed. Some of them said: Bring him (the writing material) so that Allah's Messenger (may peace be upon him) may write a document for you and you would never go astray after him And some among them said what 'Umar had (already) said. When they indulged in nonsense and began to dispute in the presence of Allah's Messenger (may peace be upon him), he said: Get up (and go away) 'Ubaidullah said: Ibn Abbas used to say: There was a heavy loss, indeed a heavy loss, that, due to their dispute and noise. Allah's Messenger (may peace be upon him) could not write (or dictate) the document for them.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4017]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4017

Ibn Abbas reported that Sa'd b. Ubida asked Allah's Messenger (may peace be upon him) for a decision about a vow taken by his mother who had died before fulfilling it. Allah's Messenger (may peace be upon him) said: Fulfil it on her behalf.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4018]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4018

This hadith has been narrated on the authority of Zuhri with a different chains of transmitters.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4019]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4019

'Abdullah b. Umar reported: Allah's Messenger (may peace he upon him) singled out one day forbidding us to take vows and said: It would not avert anything; it is by which something is extracted from the miserly person.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4020]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4020

Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: The vow neither hastens anything nor defers anything, but is the means whereby (something) is extracted from the miserly person.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4021]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4021

Ibn Umar reported that Allah's Apostle (may peace be upon him) forbade (people) taking vows, and said: It does not (necessarily) bring good (in the form of substantial, and tangible results), but it is the meant whereby something is extracted from the miserly persons.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4022]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4022

This hadith has been narrated on the authority of Mansur with the same chain of transmitters.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4023]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4023

Abu Heraira reported Allah's Messenger (may peace be upon him) as saying: Do not take vows, for a vow has no effect against Fate; it is only from the miserly that something is extracted.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4024]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4024

Abu Huraira reported Allah's Messenger (may peace be upon him) forbidding taking of vows, and said: It does not avert Fate, but is the means by which something is extracted from the miser.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4025]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4025

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The vow does not bring anything near to the son of Adam which Allah has not ordained for him, but (at times) the vow coincides with Destiny, and this is how something is extracted from the miserly person, which that miser was not willing to give.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4026]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4026

This hadith has been transmitted on the authority of 'Amr b. Abu 'Amr.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4027]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4027

Imran b. Husain reported that the tribe of Thaqif was the ally of Banu 'Uqail. Thaqif took two persons from amongst the Companiobs of Allah's Messenger (may peace be upon him) as prisoners. The Campanions of Allah's Messenger (may peace be upon him) took one person at Banu Uqail as prisoner, and captured al-'Adbi (the she-camel of the Holy Prophet) along with him. Allah's Messenger (may peace be upon him) came to him and he was tied with ropes. He said: Muhammad. He came near him and said: What is the matter with you? Thereupon he (the prisoner) said: Why have you taken me as prisoner and why have you caught hold of one proceeding the pilgrims (the she-camel as she carried the Holy Prophet on her back and walked ahead of the multitude)? He (the Holy Prophet) said: (Yours is a great fault). I (my men) have caught hold of you for the crime of your allies, Banu Thaqif. He (the Holy Prophet) then turned away. He again called him and said: Muhammad, Muhammad, and since Allah's Messenger (may peace be upon him) was very compassionate, and tenderhearted, he returned to him, and said: What is the matter with you? He said: I am a Muslim, whereupon he (the Holy Prophet) said: Had you said this when you had been the master of yourself, you would have gained every success. He then turned away. He (the prisoner) called him again saying: Muhammad, Muhammad. He came to him and said: What is the matter with you? He said: I am hungry, feed me, and I am thirsty, so provide me with drink. He (the Holy Prophet) said: That is (to satisfy) your want. He was then ransomed for two persons (who had been taken prisoner by Thaqif). He (the narrator) said: A woman of the Ansar had been taken prisoner and also al-Adbi' was caught. The woman had been tied with ropes. The people were giving rest to their animals before their houses. She escaped one night from the bondage and came to the camels. As she drew near the camels, they fretted and fumed and so she left them until she came to al-, Adbi'. It did not fret and fume; it was docile She rode upon its back and drove it away and she went off. When they (the enemies of Islam) were warned of this, they went in search of it, but it (the she-camel) exhausted them. She (the woman) took vow for Allah, that in case He would save her through it, she would offer that as a sacrifice. As she reached Medina, the people saw her and they said: Here is al-Adbi, the she-camel of Allah's Messanger (may peace be upon him). She (the woman) said that she had taken a vow that if Allah would save her on its back, she would sacrifice it. They (the Prophet's Companions) came to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: Hallowed be Allah, how ill she rewarded it that she took vow to Allah that if He saves her on its back, she would sacrifice it! There is no fulfilment of the vow in an act of disobedience, nor in an act over which a person has no control. In the version of Ibn Hujr (the words are):" There is no vow in disobedience to Allah."


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4028]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4028

This hadith is narrated on the authority of Ayyub with the same chain of transmitters and a slight variation of words.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4029]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4029

Anas reported that Allah's Apostle (may peace be upon him) saw an old man being supported between his two sons. He (the Holy Prophet) said: What is the matter with him? They said: He had taken the vow to walk (on foot to the Ka'ba). Thereupon he (Allah's Apoitle) said: Allah is indifferent to his inflicting upon himself chastisement, and he commanded him to ride.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4030]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4030

Abu Huraira reported: Allah's Apostle (may peace be upon him) found an old man walking between his two sons supported by them, whereupon Allah's Apostle (may peace be upon him) said: What is the matter with him? He (the narrator) said: Allah's Messenger, they are his sons and there is upon him the (fulfilment) of the vow, whereupon Allah's Apostle (may peace be upon him) said: Ride, old man, for Allah is not in need of you and your vow.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4031]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4031

This hadith has been narrated on the authority of 'Amr b. Abu 'Amr with the same chain of transmitters.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4032]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4032

'Uqba b. Amir reported: My sister took a vow that she would walk bare foot to the house of Allah (Ka'ba). She asked me to inquire from Allah's Messenger (may peace be upon him) about it. I sought his decision and he said: She should walk on foot and ride also.


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4033]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4033

This hadith has been narrated on the authority of 'Uqba b. Amir Juhani. but in this no mention has been made of" barefoot".


Muslim :: The Book of Vows (Kitab Al-Nadhr) :: [14.4034]

The Book of Vows (Kitab Al-Nadhr)

Muslim :: Book 14 : Hadith 4034

'Uqba. b. Amir reported Allah's Messenger (may peace be upon him) as saying: The expiation of the (breach of) a vow is the same as that of the (breach of an oath).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4035]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4035

'Umar b. al-Khattib reported Allah's Messenger (may peace be upon him) as saying: Allah, the Great and Majestic, forbids you to swear by your fathers. Umar said: By Allah. I have never sworn (by my father) since I heard Allah's Messenger (may peace be upon him) forbidding it mentioning them" on my behalf" nor on behalf of someone else.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4036]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4036

This hadith has been transmitted on the authority of Zuhri except that in the hadith narrated on the authority of Uqail the words are:" I did not take oath by (anyone else except Allah) since I heard Allah's Messenger forbidding it. nor did I speak in such terms, and the narrator did not say," on my own behalf or on behalf of someone else".


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4037]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4037

Salim reported on the authority of his father that Allah's Apostle (may peace be upon him) heard 'Umar while he was taking oath by his father. The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4038]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4038

'Abdullah (b. Umar) reported that Allah's Messenger (may peace be upon him) found, Umar b. al-Khattab amongst the riders and he was taking oath by his father Allah's Messenger (may peace be upon him) called them (saying) ; Our Allah, the Exated and Majestic, has forbidden you that you take oath by your father. He who bag to take an oath, he must take it by Allah or keep quiet.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4039]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4039

This hadith is narrated on the authority of Ibn Umar through another chain of transmitters.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4040]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4040

Ibn 'Umar heard Allah's Messenger (may peace be upon him) as saying: He who has to take an oath, he must not take oath but by Allah. The Quraish used to take oath by their fathers. So he (the Holy Prophet) said: Do not take oath by your fathers.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4041]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4041

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who takes an oath in the course of which he says: By Lat (and al-'Uzza), he should say: There is no god but Allah; and that it anyone says to his friend:" Come and I will gamble with you," he should pay sadaqa.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4042]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4042

This hadith has been narrated on the authority of Zuhri.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4043]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4043

Abd al-Rahman b. Samura reported Allah's Messenger (may peace be upon him) as saying: Do not swear by idols, nor by your fathers.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4044]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4044

Abu Musa al-Ash'ari reported: I came to Allah's Apostle (may peace be upon him) along with a group of Ash'arites requesting to give us a mount. He (the Holy Prophet) said: By Allah, I cannot provide you with a mount, and there is nothing with me which I should give you as a ride. He (the narrator) said: We stayed there as long as Allah willed. Then there were brought to him (to the Holy Prophet) camels. He (the Holy Prophet) then ordered to give us three white humped camels, We started and said (or some of us said to the others): Allah will not bless us. We came to Allah's Messenger (may peace be upon him) begging him to provide us with riding camels. He swore that he could not provide us with a mount, but later on he provided us with that. They (some of the Prophet's Companions) came and informed him about this (rankling of theirs), whereupon he said: It was not I who provided you with a mount, but Allah has provided you with that. So far as I am concerned, by Allah, if He so wills, I would not swear, but if, later on, I would see better than it, I (would break the vow) and expiate it and do that which is better.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4045]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4045

Abu Musa reported: My friends sent me to Allah's Messenger (may peace be upon him) asking him to provide them with mounts as they were going along with him in jaish al-'Usrah (the army of destitutes or of meagre means or army setting out during the hard times and that is the occasion of the expedition of Tabuk) I said: Apostle of Allah, my friends have sent me to you so that you may provide them with mounts. He (the Holy Prophet) said: By Allah, I cannot provide you with anything to ride. And it so happened that he was at that time much perturbed. I little knew of it, so I came back with a heavy heart on account of the refusal of Allah's Messenger (may peace be upon him), and the fear that Allah's Messenger (may peace be upon him) might have some feelings against me. I returned to my friends and informed them about what Allah's Messenger (may peace be upon him) had said. I had hardly stayed for a little that I heard Bilal calling: 'Abdullah b. Qais. I responded to his call. He said: Hasten to Allah's Messenger (may peace be upon him), he is calling you, When I came to the Holy Prophet (may peace be upon him) he said: Take this pair, this pair, and this pair (i. e. six camels which he had bought from Sa'd), and take them to y, our friends and say: Verily Allah (or he said: Verily Allah's Messenger (may peace be upon him) has provided you with these animals. So ride upon them. Abu Musa said: I went along with them to my friends and said: Verily Allah's messenger (may peace be upon him) has provided you with these animals for riding; but by Allah, I shall not leave you until some of you go along with me to him who had heard the talk of Allah's Messenger (may peace be upon him) then I asked him for you, and his refusal for the first time, and then his granting them to me subsequently; so you should not think that I narrated to you something which he did not say. They said to me: By Allah, in our opinion you are certainly truthful, and we would do as you like. So Abu Musa went along withsome of the menfrom them until they came to those who had heard the words of Allah's Messenger (may, peace be upon him) and his refusal to (provide) them with (animals) ; and subsequently his granting (the animals) to them; and they narrated to them exactly as Abu Masa had narrated to them.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4046]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4046

Ayyub said: We were sitting in the company of Abu Musa that he called for food and it consisted of flesh of fowl. It was then that a person from Banu Tamim visited him. His complexion was red having the resemblance of a slave. He said to him: Come and (join me in food). He showed reluctance. He (Abu Masa) said: Come on, for I saw Allah's Messenger (may peace be upon him) eating it (fowl's meat), whereupon that person said: I saw it eating something (of filth and rubbish) and I found it repugnant and took an oath that I would never eat that. He (Abu Muds) said: Come, so that I would narrate to you about that (the incident pertaining to vow). (And he narrated thus): I came to Allah's Messenger (may peace be upon him) along with a group of people belonging to the tribe of Ash'ari, asking him to provide us with riding camels. He (the Holy Prophet) said: By Allah, I cannot provide you with riding animals. And there is nothing with me with which I can provide you a mount. We stayed (for some time) there as Allah willed, and there was brought to Allah's Messenger (may peace be upon him) booty of camels. He called us and commanded that we should be given five white humped camels. As we were about to go back, some of us said to the other: As we made Allah's Messenger (may peace be upon him) forget oath, there would be no blessing for us (in his gift). We went back to him and said: Allah's Messenger, we came to you to provide us with riding animals and you took an oath that you would never equip us with mounts and then you have provided us with the riding beasts Allali's Messenger, have you forgotten? Thereupon he said: I swear by Allah that if Allah so wills, I shall not swear an oath, and then consider something else to be better than it without making atonement for my oath and doing the thing that is better. So you go; Allah, the Exalted and Glorious, has given you riding animals.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4047]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4047

This hadith has been narrated on the authority of Abu Musa al-Ash'ari with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4048]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4048

Zahdam al-Jarmi reported: We were in the company of Abu Musa. The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4049]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4049

Zahdam al-Jarmi reported: I visited Abu Musa and lie was eating fowl's meat. The rest of the hadith is the same with this addition that he (the Holy Prophet) said: By Allah, I did not forget it.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4050]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4050

Abu Musa al-Ash'ari reported: We came to Allah's Messenger (may peace be upon him) requesting him to provide us with riding camels. He (the Holy Prophet) said: There is nothing with me with which I should equip you. By Allah, I would not provide you with (riding camels). Then Allah's Messenger (may peace be upon him) sent to us three camels with spotted bumps. We said: We came to Allah's Messenger (may peace be upon him) asking him to equip us with riding animals. He took an oath that he could not equip us. We came to him and informed him. He said: By Allah, I do not take an oath, but when I find the other thing better than that, I do that which is better.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4051]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4051

Abu Musa reported: We walked on foot and came to Allah's Apostle (may peace he upon him) asking him to provide us with mounts. The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4052]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4052

Abu Huraira reported: A person sat late in the night with Allah's Apostle (may peace be upon him), and then came to his family and found that his children had gone to sleep. His wife brought food for him. but he took an oath that he would not eat because of his children (having gone to sleep without food) He then gave precedence (of breaking the vow and then expiating it) and ate the food He then came to Allah s Messenger (may peace be upon him) and made mention of that to him, whereupon Allah's Messenger (may peace he upon him) said: He who took an oath and (later on) found something better than that should do that, and expiate for (breaking) his vow.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4053]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4053

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who took an oath and then found another thing better than (this) should expiate for the oath (broken) by him and do (the better thing).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4054]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4054

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who took an oath and (later on) found another thing better than that, he should do that which is better, and expiate for the vow (broken by him).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4055]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4055

This hadith is narrated on the authority of Suhail with the same chain of transmitters (with these words):" He should expiate for (breaking) the vow and do that which is better."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4056]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4056

Tamim b. Tarafa reported: A beggar came to 'Adi b. Hatim and he begged him to give him the price of a slave, or some portion of the price of the slave. He ('Adi) said: I have nothing to give you except my coat-of-mail and helmet. I will, however, write to my family to give that to you, but he did not agree to that. Thereupon 'Adi was enraged, and said: By Allah, I will not give you anything. The person (then) agreed to accept that, whereupon he said: By Allah, had I not heard Allah's Messenger (may peace be upon him) saying:" He who took an oath, but then found something more pious in the sight of Allah, he should (break the oath) and do that which is more pious," I would not have broken the oath (and thus paid you anything).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4057]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4057

'Adi b. Hatim reported Allah's Messenger (may peace be upon him) as saying: He who took an oath, but he found something else better than that, should do that which is better and break his oath.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4058]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4058

'Adi reported Allah's Messenger (may peace be upon him) as saying: When anyone amongst you takes an oath, but he finds (something) better than that he should expiate (the breaking of the oath), and do that which is better.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4059]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4059

This hadith is reported on the authority of Adi b. Hatim through another chain of transmitters.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4060]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4060

Tamim b. Tarafa reported that he beard 'Adi b. Hatim say that a person came to him and asked for one hundred dirhams. He ('Adi) said: You asked Me for one hundred dirhams and I am the son of Hatim; by Allah, I will not give you. But then he said: (I would have done that) if I had not heard Allah's Messenger (may peace be upon him) say: He who takes an oath, but then finds something better than that, should do that which is better.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4061]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4061

Tamim b. Tarafa reported: I heard 'Adi b. Hatim say that a person asked that and then narrated (the hadith) like one (mentioned above), but he made this addition:" Here are four hundred (dirhams) for you out of my gift."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4062]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4062

Abd al-Rahman b. Samura reported that Allah's Messenger (may peace be upon him) said to me: Abd al-Rahman b. Samura, don't ask for authority for if it is granted to you for asking for it, you would be commissioned for it (without having the support of Allah), but if you are granted it without your asking for it. You would be helped (by Allah) in it. And when you take an oath and find something else better than that, expiate for (breaking) your oath, and do that which is better. This hadith has also been transmitted on the authority of Ibn Farrukh.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4063]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4063

This hadith has been narrated on the authority of 'Abd al-Rahman b. Samura through another chain of transmitters but there is no mention of the word" authority".


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4064]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4064

Abu Haraira reported Allah's Messenger (may peace be upon him) as saying: Your oath should be about something regarding which your companion will believe you. 'Amr said: By which your companion will believe you.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4065]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4065

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An oath is to be interpreted according to the intention of the one who takes it.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4066]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4066

Abu Huraira reported that (Hadrat) Sulaiman had sixty wives. He (one day) said: I will visit each one of them every night, and every one of them will become pregnant and give birth to a male child who will be a horseman and fight in the cause of Allah. But (it so happened) that none of them became pregnant except one, but she gave birth to an incomplete child. Thereupon Allah's Messenger (may peace be upon him) said: Had he said Insha' Allah (if God so wills), then every one of them would have given birth to a child who would have been a horseman and fought in the cause of Allah


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4067]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4067

Abu Huraira reported Allah's Prophet (may peace be upon him) as saying that Sulaiman b. Dawud, the Apostle of Allah, observed: I will have an intercourse with seventy wives during the night; all of them will give birth to a male child who will fight in the cause of Allah. His companion or the ang I said to him: Say," If God wills." But he (Hadrat Sulaimin) did not say so, and he forgot it. And none of his wives gave birth to a child, but one who gave birth to a premature child. Allah's Messenger (may peace be upon him) said: Had he said Insha' Allah (if God so will). he would not have failed and his desire would have been materialised.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4068]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4068

Abu Huraira reported this hadith from the Apostle of Allah (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4069]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4069

Abu Huraira reported that Sulaiman b. Dawud said: I will certainly have intercourse with seventy wives during the night, and every wife amongst them will give birth to a child, who will fight in the cause of Allah. It was said to him: Say:" Insha' Allah" (God willing), but he did not say so and forgot it. He went round them but none of them give birth to a child except one woman and that too was an incomplete person. Upon this Allah's Messenger (may peace be upon him) said: If he had said" Insha' Allah." he would not have failed, and his desire must have been fulfilled.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4070]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4070

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that Sulaiman b. Dawud (once) said: I will go round in the night to my ninety wives, and every one of them will give birth to a child (who will grow up) as a horseman and fight in the cause of Allah His companions said to him: Say" Insha' Allah." but he did not say Inshii' Allah. He went round all of them but none of them became pregnant but one, and she gave birth to a premature child. And by Him in Whose hand is the life of Muhammad, if he had said, Insha' Allah (his wives would have given birth to the children who would all have grown up into horsemen and fought in the way of Allah). This hadith has been narrated on the authority of Abu Zinad with the same chain of transmitters with a variation of (these words):" Every one of them giving birth to a child, who would have fought in the cause of Allah."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4071]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4071

Hammam b. Munabbih reported: This is what Abu Huraira reported to us from Allah's Messenger (may peace be upon him), and he narrated a hadith and (one) of them is that Allah's Messenger (may peace be upon him) said: I swear by Allah, it is more sinful in Allah's sight for one of you to persist in an oath regarding his family than payment of its expiation which Allah has imposed upon him (for breaking the oath).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4072]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4072

Ibn 'Umar reported that Umar (b. Khattab) said: Messenger of Allah, I had taken a vow during the days of Ignorance (Jahiliyya) that I would observe I'tikaf for a night in the Sacred Mosque. He (the Holy Prophet) said: Fulfil your vow.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4073]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4073

This hadith is transmitted on the authority of Ibn Umar with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4074]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4074

'Abdullah b. 'Umar reported that 'Umar b. Khattab asked the Messenger of Allah (may peace be upon him) as he was at ji'rana (a town near Mecca) on his way back from Ta'if: Messenger of Allah, I had taken a vow during the days of Ignorance that I would observe I'tikaf for one day in the Sacred Mosque. So what is your opinion? He said: Go and observe I'tikaf for a day. And Allah's Messenger (may peace be upon him) gave him a slave girl out of the one-fifth (of the spoils of war meant for the Holy Prophet). And when Allah's Messenger (inay peace be upon him) set the war prisoners free. 'Umar b. Khattab heard their voice as they were saying: Allah's Messenger (may peace be upon him) has set as free. He (Hadrat 'Umar) said: What is this? They said: Allah's Messenger (may peace be upon him) has set free the prisoners of war (which had fallen to the lot of people). Thereupon he (Hadrat 'Umar) said: Abdullah, go to that slave-girl and set her free.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4075]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4075

lbn 'Umar reported: When Allah's Apostle (may peace be upon him) came back from the Battle of Hunain, Umar asked Allah's Messenger (may peace be upon him) about the vow he had taken during the days of Ignorance that he would observe I'tikaf for a day. The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4076]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4076

Nafi' reported: A mention of Allah's Messenger (may peace be upon him) observing 'Umra from ja'rina was made before Ibn 'Umar. He said: He did not enter into the state of Ihram from that (place), and Umar had taken a vow of observing I'tikaf for a night during the days of Ignorance. The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4077]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4077

This hadith has been transmitted on the authority of Ibn Umar through another chain of transmitters but with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4078]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4078

Zadhan Abl Umar reported: I came to Ibn 'Umar as he had granted freedom to a stave. He (the narrator further) said: He took hold of a wood or something like it from the earth and said: It (freedom of a slave) has not the reward evert equal to it, but the fact that I heard Allah's Messenger (way peace be upon him) say: He who slaps his slave or beats him, the expiation for it is that he should set him free.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4079]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4079

Zadhan reported that Ibn Umar called his slave and he found the marks (of beating) upon his back. He said to him: I have caused you pain. He said: No. But he (Ibn Umar) said: You are free. He then took hold of something from the earth and said: There is no reward for me even to the weight equal to it. I heard Allah's Messenger (may peace be upon him) as saying: He who beats a slave without cognizable offence of his or slaps him (without any serious fault), then expiation for it is that he should set him free.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4080]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4080

This hadith has been narrated through another chain of transmitters with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4081]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4081

Mu'awiya b. Suwaid reported: I slapped a slave belonging to us and then fled away. I came back just before noon and offered prayer behind my father. He called him (the slave) and me and said: Do as he has done to you. He granted pardon. He (my father) then said: We belonged to the family of Muqarrin during the lifetime of Allah's Messenger (may peace be upon him. and had only one slave-girl and one of us slapped her. This news reached Allah's Apostle (may peace be upon him) and he said: Set her free. They (the members of the family) said: There is no other servant except she. Thereupon he said: Then employ her and when you can afford to dispense with her services, then set her free.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4082]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4082

Hilal b. Yasaf reported that a person got angry and slapped his slave-girl. Thereupon Suwaid b. Muqarrin said to him: You could find no other part (to slap) but the prominent part of her face. See I was one of the seven sons of Muqarrin, and we had but only one slave-girl. The youngest of us slapped her, and Allah's Messenger (may peace be upon him) commanded us to set her free. 2097


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4083]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4083

Hilal b. Yasaf reported: We used to sell cloth in the house of Suwaid b. Muqarrin, the brother of Nu'man b. Muqarrin. There came out a slave-girl, and she said something to a person amongst us, and he slapped her. Suwaid was enraged-the rest of the hadlth is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4084]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4084

Suwaid b. Muqarrin reported that he had a slave-girl and a person (one of the members of the family) slapped her, whereupon Suwaid said to him: Don't you know that it is forbidden (to strike the) face. He said: You see I was the seventh one amongst my brothers during the lifetime of Allah's Messenger (may peace be upon him), and we had but only one servant. One of us got enraged and slapped him. Thereupon Allah's Messenger (may peace be upon him) commanded us to set him free.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4085]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4085

Wahb b. Jarir reported: Shu'ba informed that Muhammad b. Munkadir said to me: What is your name? The rest of the hadith is the same.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4086]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4086

Abu Mas'ud al-Badri reported: I was beating my slave with a whip when I heard a voice behind me: Understand, Abu Masud; but I did not recognise the voice due to intense anger. He (Abu Mas'ud) reported: As he came near me (I found) that he was the Messenger of Allah (may peace be upon him) and he was saying: Bear in mind, Abu Mas'ud; bear in mind. Abu Mas'ud. He (Aba Maslad) said: threw the whip from my hand. Thereupon he (the Holy Prophet) said: Bear in mind, Abu Mas'ud; verily Allah has more dominance upon you than you have upon your slave. I (then) said: I would never beat my servant in future.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4087]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4087

This hadith has been narrated on the authorityo A'mash but with this variation of words:" There fell from my hand the whip on account of his (the Prophet's) awe."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4088]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4088

Abu Mas'ud al-Ansari reported: When I was beating my servant, I heard a voice behind me (saying): Abu Mas'ud, bear in mind Allah has more dominance over you than you have upon him. I turned and (found him) to be Allah's Messenger (may peace be upon him). I said: Allah's Messenger, I set him free for the sake of Allah. Thereupon he said: Had you not done that, (the gates of) Hell would have opened for you, or the fire would have burnt you.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4089]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4089

Abu Mas'ud reported that he had been beating his slave and he had been saying: I seek refuge with Allah, but he continued beating him, whereupon he said: I seek refuge with Allah's Messenger, and he spared him. Thereupon Allah's Messenger (may peace be upon him) said: By Allah, God has more dominance over you than you have over him (the slave). He said that he set him free. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but made no mention of (these words) of his: I seek refuge with Allah, I seek refuge with Allah's Messenger (may peace be upon him).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4090]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4090

Abu Huraira reported that Abu'l-Qasim (one of the names of Allah's Messenger [may peace be upon him]) said: He who accused his slave of adultery, punishment would be imposed upon him on the Day of Resurrection, except in case the accusation was as he had said.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4091]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4091

This hadith has been narrated on the authority of Ibn Ghazwan (and the words are):" I heard Abu'l-Qasim (may peace be upon him) as the Prophet of repentance."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4092]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4092

Al-Ma'rur b. Suwaid said: We went to Abu Dharr (Ghifari) in Rabadha and he had a mantle over him, and his slave had one like it. We said: Abu Dharr, had you joined them together, it would have been a complete garment. Thereupon he said: There was an altercation between me and one of the persons among my brothers. His mother was a non-Arab. I reproached him for his mother. He complained against me to Allah's Apostle (may peace be upon him). As I met Allah's Apostle (may peace be upon him) he said: Abu Dharr, you are a person who still has (in him the remnants) of the days (of Ignorance). Thereupon I said: Allah's Messenger, he who abuses (other) persons, they abuse (in return) his father and mother. He (the Holy Prophet) said: Abu Dharr, you are a person who still has (the remnants) of Ignorance in him They (your servants and slaves) are your brothers. Allah has put them in your care, so feed them with what you eat, clothe them with what you wear. and do not burden them beyond their capacities; but if you burden them (with an unbearable burden), then help them (by sharing their extra burden).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4093]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4093

This hadith has been narrated on the authority of A'mash but with a slight variation of words, e. g. in the hadith transmitted on the authority of Zuhair and Abu Mu'awiya after his words (these words of the Holy Prophet):" You are a person having the remnants of Ignorance in him." (these words also occur, that Abu Dharr) said: Even up to this time of my old age? He (the Holy Prophet) said: Yes. In the tradition transmitted on the authority of Abu Mu'awiya (the words are):" Yes, in this time of your old age." In the tradition transmitted on the authority of 'Isa (the words are):" If you burden him (with an unbearable burden), you should sell him (and get another slave who can easily undertake this burden)." In the hadith transmitted on the authority of Zuhair (the words are):" Help him in that (work)." In the hadith transmitted by Abu Mu'awiya (separately) there is no such word: Then sell him or help him." This hadith concludes with these words:" Do not burden him beyond his capacity."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4094]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4094

Ma'rur b. Suwaid reported: I saw Abu Dharr wearing clothes, and his slave wearing similar ones. I asked him about it, and he narrated that he had abused a person during the lifetime of Allah's Messenger (may peace be upoe. him) and he reproached him for his mother. That person came to Allah's Apostle (may peace be upon him) and made mention of that to him. Thereupon Allah's Apostle (may peace be upon him) said: You are a person who has (remnants of) Ignorance in him. Your slaves are brothers of yours. Allah has placed them in your hand, and he who has his brother under him, he should feed him with what he eats, and dress him with what he dresses himself, and do not burden them beyond their capacities, and if you burden them, (beyond their capacities), then help them.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4095]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4095

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is essential to feed the slave, clothe him (properly) and not burden him with work which is beyond his power.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4096]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4096

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When the slave of anyone amongst you prepares food for him and he serves him after having sat close to (and undergoing the hardship of) heat and smoke, he should make him (the slave) sit along with him and make him eat (along with him), and if the food seems to run short, then he should spare some portion for him (from his own share) - (another narrator) Dawud said:" i. e. a morsel or two". 4097


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4097]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4097

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: When a slave looks to the welfare of his master and worships Allah well, he has two rewards for him.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4098]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4098

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4099]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4099

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: For a faithful slave there are two rewards. By him in Whose hand is the life of Abu Huraira, but for Jibad in the cause of Allah, and Pilgrimage and kindness to my mother, I would have preferred to die as a slave. He (one of the narrators in the chain of transmitters) said: This news reached us that Abu Huraira did not perform Pilgrimage until his mother died for (keeping himself constantly) in her service. This hadith has been transmitted on the authority of Abu Tahir but with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4100]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4100

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When a slave fulfils obligation of Allah and obligation of his master, he has two rewards for him. I narrated this to Ka'b, and Ka'b said: (Such a slave) has no accountability, nor has a poor believer.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4101]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4101

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It is good for a slave that he worships Allah well, and serves his master (well). It is good for him.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4102]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4102

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who gives up his share in a slave, and has enough money to pay the full price of the slave, then full emancipation devolves upon him; but if he has not the money, then he emancipated what he emancipated.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4103]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4103

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who emancipates his share in the slave, it is his responsibility to secure full freedom for him provided he (the slave) has enough money to pay the (remaining) price, but it he has not so much money he would be emancipated to the extent that the first man emancipated.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4104]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4104

'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who gives up his share in a slave, and he has money enough to meet the full price, a fair price for him should be fixed; otherwise be has emancipated him to the extent that he has emancipated.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4105]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4105

This hadith has been narrated through another chain of transmitters with a slight variation of words.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4106]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4106

Salim b. 'Abdullah reported on the authority of his father that Allah's Apostle (may peace be upon him) said: He who emancipates a slave (shared) by him and another one, his full price may be justly assessed from his wealth, neither less nor more, and he (the slave) would be emancipated if he (the partner) would be solvent enough (to forgo the amount of his share).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4107]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4107

Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: He who gives up his share in a slave, the remaining (share) will be paid out of his riches if his riches are enough to meet the price of the slave.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4108]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4108

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: In case the slave is owned by two persons, and one of them emancipates him, he will guarantee (his full freedom).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4109]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4109

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters (and the words are):" He who emancipates a portion in a slave, he should (secure full) freedom for him from his property."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4110]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4110

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who emancipates his portion in a slave, full emancipation may be secured for him out of his property (if he has money) if he has enough property to meet (the required expenses), but if he has not enough property, the slave should be put to extra labour (in order to earn money for buying his freedom), but he should not be overburdened.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4111]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4111

This hadith has been narrated through another chain of transmitters (and the words are):" He will be required to work (in order to secure freedom) for that por- tion in which he has not been emancipated, without overburdening him."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4112]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4112

'Imran b. Husain reported that a person who had no other property emancipated six slaves of his at the time of his death. Allah's Messenger (may peace be upon him) called for them and divided them into three sections, cast lots amongst them, and set two free and kept four in slavery; and he (the Holy Prophet) spoke severely of him.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4113]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4113

This hadith has been narrated through another chain of transmitters (and the words are):" A person from among the Ansar willed away the freedom of six slaves of his at the time of his death."


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4114]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4114

This hadith has been reported on the authority of Imran b. Husain through another chain of narrators.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4115]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4115

Jabir b. 'Abdullah said that a person among the Ansar declared his slave free after his death, as he had no other property. This news reached the Apostle of Allah (may peace be upon him) and he said: Who will buy him from me? And Nu'aim b. al-Nahham bought him for eight hundred dirhams and he handed them over to him, 'Amr (one of the narrators) said: I heard Jabir b. 'Abdullah as saying: He was a Coptic slave, and he died in the first year (of the Caliphate of 'Abdullah b. Zubair).


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4116]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4116

Jabir is reported to have said: A person amongst the Ansar who had no other property declared a slave free after his death. Allah's Messenger (may peace be upon him) sold him, and Ibn al-Nahham bought him and he was a Coptic slave (who) died in the first year of the Caliphate of Ibn Zubair.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4117]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4117

A hadith like this has been narrated on the authority of Jabir through another chain of transmitters.


Muslim :: The Book of Oaths (Kitab Al-Aiman) :: [15.4118]

The Book of Oaths (Kitab Al-Aiman)

Muslim :: Book 15 : Hadith 4118

This hadith has been narrated from Allah's Messenger (may peace be upon him) through other chains of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4119]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4119

Sahl b. Abu Hathma and Rafi' b. Khadij reported that 'Abdullah b. Sahl b. Zaid and Muhayyisa b. Mas'ud b. Zaid went out and as they reached Khaibar they were separated. Then Muhayyisa found 'Abdullah b. Sahl having been killed. He buried him, and then came to Allah's Messenger (may peace be upon him). They were Huwayyisa b. Mas'ud and 'Abd al-Rahman b. Sahl, and he (the latter one) was the youngest of the people (those three who had come to seek an interview with the Holy Prophet) began to talk before his Companions (had spoken). Thereupon Allah's Messenger (may peace be upon him) said: The eldest one (eldest in regard to age should speak). So he kept quiet, and his companions (Muhayyisa and Huwayyisa) began to speak, and he ('Abd al Rahman) spoke along with them and they narrated to Allah's Messenger (may peace be upon him) the murder of 'Abdullah b. Sahl. Thereupon he said to them: Are you prepared to take fifty oaths so that you may be entitled (to blood-wit) of your companion (or your man who has murdered)? They said: How can we take an oath on a matter which we have not witnessed? He (the Holy Prophet) said: Then the Jews will exonerate themselves by fifty oaths. They said: How can we accept the oaths of people who are unbelievers? When Allah's Messenger (may peace be upon him) saw that, he himself paid his blood-wit.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4120]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4120

Sahl. b. Abu Hathma and Rafi' b. Khadij reported that Muhayyisa b. Mas'ud and 'Abdullah b. Sahl went towards Khaibar and they separated near the palm-trees. 'Abdullah b. Sahl was killed. They accused the Jews (for this act). And there came to Allah's Apostle (may peace be upon him) his brother (the brother of the slain person) 'Abd al-Rahman and his cousins Huwayyisa and Muhayyisa; and 'Abd al-Rahman talked to him about the matter pertaining to (the murder of) his brother, and he was the youngest among them. Thereupon Allah's Messenger (may peace be upon him) said: Show regard for the greatness of the old, or he said: Let the eldest begin speaking. Then they (Huwayyisa and Muhayyisa) spoke about the matter of their companion (murder of their cousin, 'Abdullah b. Sahl). Thereupon Allah's Messenger (may peace be upon him) said: Let fifty (persons) among you take oath for levelling the charge (of murder) against a person amongst them, and he would be surrendered to you. They said: We have not witnessed this matter ourselves. How can we then take oath? He (the Holy Prophet) said: The Jews will exonerate themselves by the oaths of fifty of them. They said: Messenger of Allah, they are non-believing people. Thereupon Allah's Messenger (may peace be upon him) paid the blood wit for him. Sahl said: As one day I entered the fold a she-camel amongst those camels hit me with its leg.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4121]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4121

Sahl b. Abu Hathma has narrated this hadith through another chain of transmitters with a slight variation of words, but no mention has been made of the hitting by the she-camel.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4122]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4122

This hadith has been narrated on the authority of Sahl b. Abu Hathma through another chain of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4123]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4123

Bushair b. Yasar reported that 'Abdullah b. Sahl b. Zaid and Muhayyisa b. Mas'ud b. Zaid, both of them were Ansar belonging to the tribe of Banu Haritha, set out to Khaibar during the lifetime of Allah's Messenger (may peace be upon him). There was peace during those days and (this place) was inhabited by the Jews. They parted company for their (respective) needs. 'Abdullab b. Sahl was killed, and his dead body was found in a tank. His companion (Muhayyisa) buried him and came to Medina, and the brothers of the slain 'Abd al-Rahman b. Sahl. and Muhayyisa and Huwayyisa told Allah's Messenger (may peace be upon him) the case of 'Abdullah and the place where he had been murdered. Bushair reported on the authority of one who had seen Allah's Messenger (may peace be upon him) that he had said to them: You take fifty oaths and you are entitled to blood-wit of (one) slain among you (or your companion). They said: Messenger of Allah, we neither saw (with our own eyes this murder) nor were we present there. Thereupon (Allah's Messenger is reported to have said): Then the Jews will exonerate themselves by taking fifty oaths. They said: Allah's Messenger, how can we accept the oath of unbelieving people? Bushair said that Allah's Messenger (may peace be upon him) paid the blood-wit himself.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4124]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4124

Bushair b. Yasar reported that a person from the Ansar belonging to the tribe of Banu Haritha who was called 'Abdullah b. Sahl b. Zaid set out and the son of his uncle called Muhayyisa b. Mas'ud b. Zaid, the rest of the hadith is the same up to the words:" Allah's Messenger (may peace be upon him) paid the blood-wit himself." Bushair b. Yasar reported that Sahl b. Abu Hathma said: One camel amongst the camels paid as blood-wit kicked me while I was in the (camel) enclosure.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4125]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4125

Bushair b. Yasar al-Ansari reported on the authority of Sahl b. Abu Hathma al-Ansari that some men (of his tribe went to Khaibar, and they were separated from one another, and they found one of them slain. The rest of the hadith is the same. And it was said in this connection: Allah's Messenger (may peace be him) did not approve of his blood go waste. He paid blood-wit of one hundred camels of Sadaqa.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4126]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4126

Abu Laila 'Abdullah b. 'Abd al-Rahman b. Sahl reported that the elderly persons of (the tribe) had informed Sahl b. Abu Hathma that 'Abdullah b. Sahl and Muhayyisa went out to Khaibar under some distress which had afflicted them. Muhayyisa came and informed that Abdutlah b. Sahl had been killed, and (his dead body) had been thrown in a well or in a ditch. He came to the Jews and said: By Allah, it is you who have killed him. They said: By Allah, we have not killed him. He then came to his people, and made mention of that to them. Then came he and his brother Huwayyisa, and he was older than he, and 'Abd al-Rahman b. Sahl. Then Muhayyisa went to speak, and it was he who had accompanied ('Abdullah) to Khaibar, whereupon Allah's Messenger (may peace be upon him) said to Muhayyisa: Observe greatness of the great (he meant the seniority of age). Then Huwayyisa spoke and then Muhayyisa also spoke. Thereupon Allah's Messenger (may peace be upon him) said: They should either pay blood-wit for your companion, or be prepared for war. Allah's Messenger (may peace be upon him) wrote about it to them (to the Jews). They wrote: Verily, by Allah, we have not killed him. Thereupon Allah's Messenger (may peace be upon him) said to Huwayyisa and Muhayyisa and Abd al-Rahman: Are you prepared to take oath in order to entitle yourselves for the blood-wit of your companion? They said: No. He (the Holy Prophet) said: Then the Jews will take oath (of their innocence). They said: They are not Muslims. Allah's Messenger (may peace be upon him), however, himself paid the blood-wit to them and sent to them one hundred camels until they entered into their houses, Sahl said: One red she-camel among them kicked me.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4127]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4127

Sulaiman b. Yasar, the freed slave of Maimuna, the wife of Allah's Apostle (may peace be upon him), narrated from one of the Ansari Companions of Allah's Messenger (may peace be upon him) that Allah's Messenger (may peace be upon him) retained (the practice) of Qasama as it was in the pre-Islamic days.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4128]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4128

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with this addition:" Allah's Messenger (may peace be upon him) decided (according to Qasama) between the persons of Ansar (and yours) about a slain (Muslim) for which they made claim against the Jews


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4129]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4129

This hadith has been narrated on the authority of Abu Salama b. 'Abd al-Rahman and Sulaiman b. Yasar.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4130]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4130

Anas b. Malik reported that some people belonging (to the tribe) of 'Uraina came to Allah's Messenger (may peace be upon him) at Medina, but they found its climate uncogenial. So Allah's Messenger (may peace be upon him) said to them: If you so like, you may go to the camels of Sadaqa and drink their milk and urine. They did so and were all right. They then fell upon the shepherds and killed them and turned apostates from Islam and drove off the camels of the Prophet (may peace be upon him). This news reached Allah's Apostle (may peace be upon him) and he sent (people) on their track and they were (brought) and handed over to him. He (the Holy Prophet) got their hands cut off, and their feet, and put out their eyes, and threw them on the stony ground until they died.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4131]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4131

Anas reported: Eight men of the tribe of 'Ukl came to Allah's Messenger (may peace be upon him) and swore allegiance to him on Islam, but found the climate of that land uncogenial to their health and thus they became sick, and they made complaint of that to Allah's Messenger (may peace be upon him), and he said: Why don't you go to (the fold) of our camels along with our shepherd, and make use of their milk and urine. They said: Yes. They set out and drank their (camels') milk and urine and regained their health. They killed the shepherd and drove away the camels. This (news) reached Allah's Messenger (may peace be upon him) and he sent them on their track and they were caught and brought to him (the Holy Prophet). He commanded about them, and (thus) their hands and feet were cut off and their eyes were gouged and then they were thrown in the sun, until they died.

This hadith has been narrated on the authority of Ibn al-Sabbah with a slight variation of words.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4132]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4132

Anas b. Malik reported that some people of the tribe of 'Ukl or 'Uraina came to Allah's Messenger (may peace be upon him), and they found the climate of Medina uncogenial. Allah's Messenger (may peace be upon him) commanded them to the milch she-camels and commanded them to drink their urine and their milk. The rest of the hadith is the same (and the concluding words are):" Their eyes were pierced, and they were thrown on the stony ground. They were asking for water, but they were not given water."


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4133]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4133

Abu Qilaba reported: I was sitting behind 'Umar b. 'Abd al-'Aziz and he said to the people: What do you say about al-Qasama? Thereupon 'Anbasa said: Anas b Malik narrated to us such and such (hadith pertaining to al-Qasama). I said: This is what Anas had narrated to me: People came to Allah's Apostle (may peace be upon him), and the rest of the hadith is the same. When I (Abu Qilaba) finished (the narration of this hadith), 'Anbasa said: Hallowed be Allah. I said: Do you blame me (for telling a lie)? He ('Anbasa) said: No. This is how Anas b Malik narrated to us. O people of Syria, you would not be deprived of good, so long as such (a person) or one like him lives amongst you.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4134]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4134

Anas b. Malik reported: There came to Allah's Messenger (may peace be upon him) eight persons from the tribe of 'Ukl, but with this addition that he did not cauterise (the wounds which hid been inflicted upon them while punishing them).


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4135]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4135

Anas reported: There came to Allah's Messenger (may peace be upon him) some ponple from 'Uraina. They embraced Islam and swore allegiance to him and there had spread at that time pleurisy. The rest of the hadith is the same (but with this addition):" There were by his (the Prophet's) side about twenty young men of the Ansar; he sent them (behind) them (culprits), and he also sent along with them one expert in following the track so that he might trace their footprints."


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4136]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4136

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4137]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4137

Anas reported that Allah's Messenger (may peace be upon him) pierced their eyes because they had pierced the eyes of the shepherds.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4138]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4138

Anas b. Malik reported that a Jew killed a girl with a stone for her silver ornaments. She was brought to Allah's Messenger (may peace be upon him) when there was yet some life in her. He (the Holy Prophet) said to her: Has so and so killed you? She indicated with the nod of her head: No. He said for the second time, and she again said: No with the nod of her head. He asked for the third time, and she said: Yes with the nod of her head and Allah's Messenger (may peace be upon him) commanded to crush his head between two stones.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4139]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4139

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters and in the hadith narrated on the authority of Ibn Idris (the words are):" He (commanded) to crush his head between two stones."


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4140]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4140

Anas reported that a Jew killed a girl of the Ansar for her ornaments and then threw her in a well and smashed her head with a stone. He was caught and brought to the Messenger of Allah (may peace be upon him), and he commanded that he should be stoned to death. So he was stoned until he died.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4141]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4141

This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4142]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4142

Anas b. Malik reported: A girl was found with her head crushed between two stones. They asked her as to who had done that-has so and so (done it) until they mentioned a Jew. She indicated with the nod of her head (that it was so). So the Jew was caught, and he made confession (of his guilt). And Allah's Messenger (may peace be upon him) commanded that his head be smashed with stones.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4143]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4143

Imran b. Husain reported: Ya'la b. Munya or Ibn Umayya fought with a person, and the one bit the hand of the other. And he tried to draw his hand from his mouth and thus his foreteeth ware pulled out. They referred their dispute to Allah's Apostle (may peace be upon him), whereupon he said: Does any one of you bite as the camel bites? So there is no blood-wit for it.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4144]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4144

This hadith has been transmitted on the authority of Ya'la.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4145]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4145

'Imran b. Husain reported that a person bit the arm of another person; he pulled it out and his foretooth fell down. This matter was taken to Allah's Apostle (may peace be upon him), and he turned it down saying: Did you want to eat his flesh?


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4146]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4146

Safwan b. Ya'la reported that a person bit the arm of the servant of Ya'la b. Munya. He pulled it and his foretooth fell. The matter was referred to Allah's Apostle (may peace be upon him) and he turned it down and said: Did you intend to bite his hand, as the camel bites?


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4147]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4147

'Imran b. Husain reported that a person bit the hand of a person. He withdrew his hand and his foretooth or foreteeth fell down. He (the man who lost his teeth) referred the matter to Allah's Messenger (may peace be upon him) and he said, What do you want me to do? Do you ask me that I should order him to put his hand in your month, and you should bite it as the camel bites? (If you want retaliation, then the only way out is) that you put your hand in his mouth (allow him) to bite that and then draw it away.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4148]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4148

Safwan b. Ya'la b. Munya reported on the authority of his father that there came to Allah's Apostle (may peace be upon him) a person who had bitten the hand of another person and who had withdrawn his hand (and as a result thereof) his foreteeth had fallen (those which had bitten). The Apostle of Allah (may peace be upon him) turned down his (claim), and said: Do you wish to bite as the camel bites?


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4149]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4149

Safwan b. Ya'la b. Umayya thus reported from his father: I participated in the expedition to Tabuk with Allah's Apostle (may peace be upon him). And Ya'la used to say: That was the most weighty of my deeds, in my opinion. Safwan said that Ya'la had stated: I had a servant; he quarrelled with another person, and the one bit the hand of the other. ('Ata' said that Safwan had told him which one had bitten the hand of the other.) So he whose hand was bitten drew ill from (the mouth) of the one who had bitten it and (in this scuffle) one of his foreteeth was also drawn out. They both came to Allah's Apostle (may peace be upon him) and he declared his (claim for the compensation of) tooth as invalid.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4150]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4150

This hadith has been narrated on the authority of Juraij with the same chain of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4151]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4151

Anas reported that Umm Haritha, the sister of Rubayyi' (she was the father's sister of Hadrat Anas) injured a person (she broke his teeth). The dispute was referred to Allah's Apostle (may peace be upon him). Allah's Messenger (may peace be upon him) said: Retribution, retribution. Umm Rubayyi' said: Messenger of Allah, will retribution be taken from so and so? By Allah, it shall not be taken from her (i. e. from Umm Haritha). Thereupon Allah's Apostle said: Hallowed be Allah. O Umm Rubayyi', Qisas (retribution is a command, prescribed) in the Book of Allah. She said: No, by Allah, Qisas will never be taken from her; and she went on saying this until they (the relatives of the one who had been injured) accepted the blood-wit. Thereupon Allah's Messenger (may peace be upon him) said: Verily there are amongst the servants of Allah (such pious persons) who, if they take oath of Allah, He honours it.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4152]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4152

'Abdullah (b. Mas'ud) reported Allah's Messenger (may peace be upon him) as saying: It is not permissible to take the life of a Muslim who bears testimony (to the fact that there is no god but Allah, and I am the Messenger of Allah, but in one of the three cases: the married adulterer, a life for life, and the deserter of his Din (Islam), abandoning the community.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4153]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4153

This hadith has been narrated on the authority of A'mash.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4154]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4154

'Abdullah (b. Mas'ud) reported: Allah's Messenger (may peace be upon him) stood up and said: By Him besides Whom there is no god but He, the blood of a Muslim who bears the testimony that there is no god but Allah, and I am His Messenger, may be lawfully shed only in case of three persons: the one who abandons Islam, and deserts the community [Ahmad, one of the narrators, is doubtful whether the Holy Prophet (may peace be upon him) used the word li'l-jama'ah or al-jama'ah), and the married adulterer, and life for life.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4155]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4155

This hadith has been reported on the authority of A'mash with the same chain of narrators but with a slight variation of words, i. e. he did not say: By Him besides Whom there is no god.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4156]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4156

'Abdullah (b. Mas'ud) reported: Allah's Apostle (may peace be upon him) having said: No person who is killed unjustly, but the share of (this offence of his also) falls upon the first son of Adam, for he was the first to introduce killing.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4157]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4157

This hadith has been narrated on the authority of Jarir and 'Isa b. Yunus with a slight variation of words.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4158]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4158

'Abdullah b. (Mas'ud) reported Allah's Messenger (may peace be upon him) as saying: The first (thing) that will be decided among people on the Day of Judgment will pertain to bloodshed.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4159]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4159

This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters with a slight variation of words.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4160]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4160

Abu Bakra reported that (in the Farewell Address) Allah's Apostle (may peace be upon him) said: Time has completed a cycle and come to the state of the day when Allah created the heavens and the earth. The year is constituted of twelve months, of which four are sacred; three of them consecutive, viz. Dhu'l-Qa'da, Dhu'l- Hijja and Muharram, and also Rajab the month of Mudar which comes between Jumada and Sha'ban. He (the Holy Prophet) then said: which month is this? We said Allah and His Messenger know best. He (the narrator) said: He (the Holy Prophet) remained silent for some time until we thought that he would give it a name other than that (by which it was known). He said: Is it not Dha'l-Hijja? We said: Yes. He (the Holy Prophet) said: Which city is this? We said: Allah and His Messenger know best. He (the Holy Prophety remained silent until we thought that he would give it another name. He (the Holy Prophet) said: Is it not the Balda (the city of Mecca)? We said: Yes. He said: What day is this? We said: Allah and His Messenger know best. He (the Holy Prophet) remained silent until we thought that he would give it another name. He said: Is it not the Day of Sacrifice? We said: Allah's Messenger. yes. Thereupon he said: Your blood, your property (Muhammad, one of the narrators, said: I think, he also said this) and your honour are sacred to you like the sacredness of this day of yours, in this city of yours, and in this month of yours. You will soon meet your Lord and He will ask you about your deeds. So do not turn after me unbelievers (or misguided), some of you striking the necks of the others. Behold I let him who is present convey to him who is absent, for many a one whom a message is conveyed has a more retentive memory than one who hears. He again said: Behold! have I not delivered (the message) to you? This hadith has been narrated through another chain of transmitters, but with a slight variation of words.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4161]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4161

Abu Bakra reported that when it was that day (the 10th of Dhu'l-Hijja) he mounted his camel and a person caught its nosestring, whereupon he said: Do you know which day is this? They said: Allah and His Messenger know best. (The Holy Prophet [may peace be upon him] kept silent) until we thought that he would give that another name. He said: Is it not the day of Nahr (Sacrifice) (10th of Dhu'l- Hijja)? We said: Allah's Messenger, yes. He (again) said: Which month is it? We said: Allah and His Messenger knows best. He said: Is it not Dhu'l-Hijja? We said: Allah's Messenger, yes. He said: Which city is this? We said: Allah and His Messenger know best. He (the narrator) said (that the Holy Prophet kept silent until we thought that he would give it another name besides its (original) name. He said: Is it not Balda (the city of Mecca)? We said: Yes, Allah's Messenger. He (then) said: Verily your blood (lives) and your property and your honour are as sacred unto you as sacred is this day of yours, in this month of yours, in this city of yours. Let him who is present convey it to one who is absent. He then turned his attention towards two multicoloured (black and white) rams and slaughtered them, and two goats, and distributed them amongst us.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4162]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4162

Abu Bakra reported that when it was the day of (Dhu'l-Hijja) Allah's Apostle (may peace be upon him) mounted the camel and addressed and a person had been holding its nosestring. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4163]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4163

This hadith has been narrated on the authority of Abu Bakra through another chain of transmitters (and the words are):" Allah's Messenger (may peace be upon him) addressed us on the day of Nahr (Sacrifice) and said: What day is this? And the rest of the hadith is the same except that he did not make mention of" your honour," and also did not make mention of this: He then turned his attention towards two rams and what follows, and in a hadith (the words pertaining to sacred- ness are recorded in this way):" Like the sacredness of this day of yours, in this month of yours, in this city of yours to the day when you will meet your Lord. Behold, have I not conveyed (the Message of God)? They said: Yes. He said: O Allah, bear witness."


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4164]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4164

'Alqama b. Wa'il reported on the authority of his-father: While I was sitting in the company of Allah's Apostle (may peace be upon him), a person came there dragging another one with the help of a strap and said: Allah's Messenger, this man has killed my brother. Allah's Messenger (may peace be upon him) said to him: Did you kill him? And the other man said: (In case he did not make a confession of this, I shall brine, a witness against him). He (the murderer) said: Yes, I have killed him. He (the Holy Prophet) said: Why did you kill him? He said: I and he won striking down the leaves of a tree and he abused me and enraged me, and to I struck his head with an axe and killed him, whereupon Allah's Messenger (may peace be upon him) said: Have you anything with you to pay blood-wit on your behalf? He said: I do not possess any property but this robe of mine and this axe of mine. He (the Holy, Prophet) said: Do you think your people will pay ransom for you? He said: I am more insignificant among my people than this (that I would not be able to get this benefit from my tribe). He (the Holy Prophet) threw the strap towards him (the claimant of the blood-wit) saying: Take away your man. The man took him away, and as he returned, Allah's Messenger (may peace be upon him) said: If he kills him, he will be like him. He returned and said: Allah's Messenger, it has reached me that you have said that" If he killed him, he would be like him." I caught hold of him according to your command, whereupon Allah's Messenger (may peace be upon him) said: Don't you like that he should take upon him (the burden) of your sin and the sin of your companion (your brother)? He said: Allah's Apostle, why not? The Messenger of Allah (may peace be. upon him) said: If it is so, then let it be. He threw away the strap (around the offender) and set him free.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4165]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4165

'Alaqama b. Wa'il reported on the authority of his father that a person was brought to the Messenger of Allah (may peace be upon him) who had killed another person, and the heir of the person slain had dragged him (to the Holy Prophet) with a strap around his neck. As he turned away Allah's Messenger (may peace be upon him) said: The killer and the killed are (doomed) to fire. A person came to the other person (the heir of the deceased) and he reported to him the words of the Messenger of Allah (may peace be upon him), and so he let him off. Isma'il b. Salim said: I made a mention of it to Habib b. Abu Thabit and he said: Ibn Ashwa' reported to me that Allah's Apostle (may peace be upon him) had asked him to pardon him, but he refused.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4166]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4166

Abu Huraira reported that among two women of the tribe of Hudhail one flung a stone upon the other causing an abortion to her Allah's Apostle (may peace he upon him) gave judgment that a male or a female slave of best quality be given as compensation.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4167]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4167

Abu Huraira reported that Allah's Messenger (may peace be upon him) gave judgment in case of the abortion of a woman of Banu Lihyan (that the offender and near relative should give compensation in the form of) good quality of a slave or a slave-girl. And the woman about whom the judgment was given for compensation died and thereupon Allah's Messenger (may peace be upon him) gave judgment that her inheritance goes to her sons and her husband, and the payment of the blood-wit lies with the family of (one who struck her).


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4168]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4168

Abu Huraira reported that two women of the tribe of Hudhail fought with each other and one of them flung a stone at the other, killing her and what was in her womb. The case was brought to Allah's Messenger (may peace be upon him) and he gave judgment that the diyat (indemnity) of her unborn child is a male or a female slave of the best quality, and he also decided that the diyat of the woman is to be paid by her relative on the father's side, and he (the Holy Prophet) made her sons and those who were with them her heirs. Hamal b. al-Nabigha al-Hudhali said: Messenger of Allah, why should I play blood-wit for one who neither drank, nor ate, nor spoke, nor made any noise; it is like a nonentity (it is, therefore, not justifiable to demand blood-wit for it). Thereupon Allah's Messenger (may peace be upon him) said: He seems to be one of the brothers of soothsavers on account of the rhymed speech which he has composed.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4169]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4169

Abu Huraira reported that two women fought-the rest of the hadith is the same but herein no mention has been made of: He made her son and those who were with them her heirs. Someone said: Why should we pay blood-wit? And he did not name Hamal b. Malik.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4170]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4170

Al-Mughira b. Shu'ba reported that a woman struck her co-wife with a tent-pole and she was pregnant and she killed her. One of them belonged to the tribe of Lihyan. Allah's Messenger (may peace be upon him) made the relatives of the murderer responsible for the payment of blood-wit on her behalf, and fixed a slave or a female slave as the indemnity for what was in her womb. One of the persons amongst the relatives of the murderer said: Should we pay indemnity for one who, neither ate, nor drank, nor made any noise, who was just like a nonentity? Thereupon Allah's Messenger (may peace be upon him) remarked: He speaks rhymed phrases like the people of the desert. He did impose indemnity upon them.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4171]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4171

Al-Mughira b. Shu'ba reported: A woman killed her fellow-wife with a tent-pole. Her case was brought to Allah's Messenger (may peace be upon him), and he gave judgment that blood-wit should be paid by the relatives (of the offender) on the father's side. And as she was pregnant, he decided regarding her unborn child that a male or a female slave of good quality be given. Some of her offender's) relatives said: Should we make compensation for one who never ate, nor drank, nor made any noise, who was like a nonentity? Thereupon Allah's Messenger (may peace be upon him) said: He was talking rhymed phrases like the rhymed phrases of desert Arabs.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4172]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4172

This hadith has been narrated on the authority of Mansur with the same chain of transmitters.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4173]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4173

Mansur transmitted this hadith with a slight variation of words.


Muslim :: The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat) :: [16.4174]

The Book Pertaining to the Oath, for Establishing the Responsibility of Murders, Fighting, Requital and Blood-Wit (Kitab Al-Kitab Al-Qasama wa'l-Muharaba wa'l-Qisas wa'l-Diyat)

Muslim :: Book 16 : Hadith 4174

Miswar b. Makhrama reported that 'Umar b. Khattab consulted people about the diyat of abortion of an unboam child. Mughira b. Shu'ba said: I bear witness to the fact that Allah's Messenger (may peace be upon him) gave judgment about it that a good quality of slave or female slave should be given for it. Thereupon 'Umar said: Bring one who may bear witness to you. Then Muhammad b. Maslama bore witness to him.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4175]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4175

'A'isha reported that Allah's Messenger (may peace be upon him) cut off the hand of a thief for a quarter of a dinar rid upwards.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4176]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4176

This hadith has been transmitted on the authority of Zuhri.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4177]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4177

'A'isha reported Allah's Messenger (may peace be upon him) as saying: The hand of a thief should not be cut off but for a quarter of a dinar and upwards.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4178]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4178

'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: The hand (of a thief) should not be cut off but for a quarter of a dinar and what is above that.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4179]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4179

'A'isha reported that she heard Allah's Apostle (may peace be upon him) as saying: The hand of the thief may not be cut off but for a quarter of a dinar and upwards.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4180]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4180

A hadith like this has been narrated on the authority of Yazid b. 'Abdullah b. al-Had with the same chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4181]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4181

'A'isha reported that during the lifetime of Allah's Messenger (may peace be upon him) the hand of the thief was not cut off for less than the price of a shield, iron coat or armour and both of them are valuable.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4182]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4182

This hadith has been narrated on the authority of Hisham through another chain of transmitters, and in the hadith narrated by 'Abd al-Rahim and Abu Usama (the words are):" That (the shield) was valuable those days."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4183]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4183

Ibn 'Umar reported that Allah's Messenger (may peace upon him) cut off the hand of a thief (in case of the theft) of a shield the price of which was three dirhams.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4184]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4184

This hadith has been narrated on the authority of Ibn 'Umar through some other chains of transmitters but with a slight variation of words.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4185]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4185

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let there be the curse of Allah upon the thief who steals an egg and his hand is cut off, and steals a rope and his hand is cut off.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4186]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4186

This hadith is narrated on the authority of A'mash with the same chain of transmitters with a slight variation of words.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4187]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4187

'A'isha reported that the Quraish had been anxious about the Makhzumi woman who had committed theft, and said: Who will speak to Allah's Messenger (may peace be upon him) about her? They said: Who dare it, but Usama, the loved one of Allah's Messenger (may peace be upon him)? So Usama spoke to him. Thereupon Allah's Messenger (may peace be upon him) said: Do you intercede regarding one of the punishments prescribed by Allah? He then stood up and addressed (people) saying: O people, those who have gone before you were destroyed, because if any one of high rank committed theft amongst them, they spared him; and it anyone of low rank committed theft, they inflicted the prescribed punishment upon him. By Allah, if Fatima, daughter of Muhammad, were to steal, I would have her hand cut off. In the hadith transmitted on the authority of Ibn Rumh (the words are):" Verily those before you perished."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4188]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4188

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that the Quraish were concerned about the woman who had committed theft during the lifetime of Allah's Apostle (may peace be upon him), in the expedition of Victory (of Mecca). They said: Who would speak to Allah's Messenger (may peace be upon him) about her? They (again) said: Who can dare do this but Usama b Zaid, the loved one of Allah's Messenger (may peace be upon him)? She was brought to Allah's Messenger (may peace be upon him) and Usama b. Zaid spoke about her to him (interceded on her behalf). The colour of the face of Allah's Messenger (may peace be upon him) changed, and he said: Do you intercede in one of the prescribed punishments of Allah? He (Usama) said: 'Messenger of Allah, seek forgiveness for me. When it was dusk. Allah's Messenger (may peace be upon him) stood up and gave an address. He (first) glorified Allah as He deserves, and then said: Now to our topic. This (injustice) destroyed those before you that when any one of (high) rank committed theft among them, they spared him, and when any weak one among them committed theft, they inflicted the prescribed punishment upon him. By Him in Whose Hand is my life, even if Fatima daughter of Muhammad were to commit theft, I would have cut off her hand. He (the Holy Prophet) then commanded about that woman who had committed theft, and her hand was cut off. 'A'isha (further) said: Hers was a good respentance, and she later on married and used to come to me after that, and I conveyed her needs (and problems) to Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4189]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4189

'A'isha reported that a woman from the tribe of Makhzum used to borrow things (from people) and then denied (having taken them). Allah's Apostle (may peace be upon him) commanded her hand to be cut off. Her relatives came to Usama b. Zaid and spoke to him (requesting him to intercede on her behalf). He spoke to Allah's Messenger (may peace be upon him) about her. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4190]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4190

Jaibir reported that a woman from the tribe of Makhzum committed theft. She was brought to Allah's Apostle (may peace be upon him) and she sought refuge (intercession) from Umm Salama, the wife of Allah's Apostle (may peace be upon him). Thereupon Allah's Apostle (may peace be upon him) said: By Allah, even if she were Fatima, I would have her hand cut off. And thus her hand was cut off.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4191]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4191

'Ubada b. as-Samit reported: Allah's Messenger (may peace be upon him) as saying: Receive (teaching) from me, receive (teaching) from me. Allah has ordained a way for those (women). When an unmarried male commits adultery with an unmarried female (they should receive) one hundred lashes and banishment for one year. And in case of married male committing adultery with a married female, they shall receive one hundred lashes and be stoned to death.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4192]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4192

'Ubada b. as-Samit reported that whenever Allah's Apostle (may peace be upon him) received revelation, he felt its rigour and the complexion of his face changed. One day revelation descended upon him, he felt the same rigour. When it was over and he felt relief, he said: Take from me. Verily Allah has ordained a way for them (the women who commit fornication),: (When) a married man (commits adultery) with a married woman, and an unmarried male with an unmarried woman, then in case of married (persons) there is (a punishment) of one hundred lashes and then stoning (to death). And in case of unmarried persons, (the punishment) is one hundred lashes and exile for one year.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4193]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4193

This hadith has been reported on the authority of Qatada with the same chain of transmitters except with this variation that the unmarried is to be lashed and exiled, and the married one is to be lashed and stoned. There is neither any mention of one year nor that of one hundred.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4194]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4194

'Abdullah b. 'Abbas reported that 'Umar b. Khattab sat on the pulpit of Allah's Messenger (may peace be upon him) and said: Verily Allah sent Muhammad (may peace be upon him) with truth and He sent down the Book upon him, and the verse of stoning was included in what was sent down to him. We recited it, retained it in our memory and understood it. Allah's Messenger (may peace be upon him) awarded the punishment of stoning to death (to the married adulterer and adulteress) and, after him, we also awarded the punishment of stoning, I am afraid that with the lapse of time, the people (may forget it) and may say: We do not find the punishment of stoning in the Book of Allah, and thus go astray by abandoning this duty prescribed by Allah. Stoning is a duty laid down in Allah's Book for married men and women who commit adultery when proof is established, or it there is pregnancy, or a confession.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4195]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4195

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4196]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4196

Abu Huraira reported that a person from amongst the Muslims came to Allah's Messenger (may peace be upon him) while he was in the mosque. He called him saying: Allah's Messenger. I have committed adultery. He (the Holy Prophet) turned away from him, He (again) came round facing him and said to him: Allah's Messenger, I have committed adultery. He (the Holy Prophet) turned away until he did that four times, and as he testified four times against his own self, Allah's Messenger (may peace be upon him) called him and said: Are you mad? He said: No. He (again) said: Are you married? He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said: Take him and stone him. Ibn Shihab (one of the narrators) said: One who had heard Jabir b. 'Abdullah saying this informed me thus: I was one of those who stoned him. We stoned him at the place of prayer (either that of 'Id or a funeral). When the stones hurt him, he ran away. We caught him in the Harra and stoned him (to death). This hadith has been narrated through another chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4197]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4197

This hadith has been narrated on the authority of Abu Huraira through other chains of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4198]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4198

Jabir b. Samura reported: As he was being brought to Allah's Apostle (may peace be upon him) I saw Ma'iz b. Malik-a short-statured person with strong sinews, having no cloak around him. He bore witness against his own self four times that he had committed adultery, whereupon Allah's Messenger (may peace be upon him) said: Perhaps (you kissed her or embraced her). He said: No. by God, one deviating (from the path of virtue) has committed adultery. He then got him stoned (to death), and then delivered the address: Behold, as we set out for Jihad in the cause of Allah, one of you lagged behind and shrieked like the bleating of a male goat, and gave a small quantity of milk. By Allah, in case I get hold of him, I shall certainly punish him.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4199]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4199

Jabir b. Samura reported that there was brought to Allah's Messenger (may peace be upon him) a short-statured person with thick uncombed hair, muscular body, having a mantle around him and he had committed adultery. He turned him away twice and then made pronouncement about him and he was stoned. Then Allah's Messenger (may peace be upon him) said: We set out for Jihad in the cause of Allah and one of you lagged behind and shrieked like the bleating of a male goat and one of then (goats' gave a small quantity of milk. In case Allah gives me power over one of them, I will punish him (in such a way that it may have a deterrent effect upon others). In another narration transmitted on the authority of Sa'id b Jubair (the words are), that He (the Holy Prophet) turned him away four times."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4200]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4200

This hadith has been narrated on the authority of Jabir b. Samura through another chain of transmitters with the difference that along with the mentioning (of the fact) that he (the Holy Prophet) turned him away twice, or thrice.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4201]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4201

Ibn Abbas reported that Allah's Apostle (may peace be upon him) said to Ma'iz b. Malik: Is it true what has reached me about you? He said: What has reached you about me? He said: It has reached me that you have committed (adultery) with the slave-girl of so and so? He said: Yes. He (the narrator) said: He testified four times. He (the Holy Prophet) then made pronouncement about him and he was stoned (to death).


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4202]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4202

Abu Sa'id reported that a person belonging to the clan of Aslam, who was called Ma, iz b. Malik, came to Allah's Messenger (may peace be upon him) and said: I have committed immorality (adultery), so inflict punishment upon me. Allah's Apostle (may peace be upon him) turned him away again and again. He then asked his people (about the state of his mind). They said: We do not know of any ailment of his except that he has committed something about which he thinks that he would not be able to relieve himself of its burden but with the Hadd being imposed upon him. He (Ma'iz) came back to Allah's Apostle (may peace be upon him) and he commanded us to stone him. We took him to the Baqi' al-Gharqad (the graveyard of Medina). We neither tied him nor dug any ditch for him. We attacked him with bones, with clods and pebbles. He ran away and we ran after him until he came upon the ston ground (al-Harra) and stopped there and we stoned him with heavy stones of the Harra until he became motionless (lie died). He (the Holy Prophet) then addressed (us) in the evening saying Whenever we set forth on an expedition in the cause of Allah, some one of those connected with us shrieked (under the pressure of sexual lust) as the bleating of a male goat. It is essential that if a person having committed such a deed is brought to me, I should punish him. He neither begged forgiveness for him nor cursed him.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4203]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4203

Dawud narrated the hadith with the same chain of transmitters (and the words are): Allah's Apostle (may peace be upon him) stood tip (to address the audience) in the evening and praised Allah, glorified Him and then said: What about the people, that as we set out on an expedition, one of you remained behind us and he shrieked like the bleating of a male goat? But he did not mention (these words): People connected with us."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4204]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4204

This hadith has been narrated on the authority of Dawud with the same chain of transmitters but with this variation that in the hadith narrated by Sufyan (the words are):" He made a confession of having committed adultery, thrice."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4205]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4205

Sulaiman b. Buraida reported on the authority of his father that Ma, iz b. Malik came to Allah's Apostle (may peace be upon him) and said to him: Messenger of Allah, purify me, whereupon he said: Woe be upon you, go back, ask forgiveness of Allah and turn to Him in repentance. He (the narrator) said that he went back not far, then came and said: Allah's Messenger, purify me. whereupon Allah's Messenger (may peace be upon him) said: Woe be upon you, go back and ask forgiveness of Allah and turn to Him in repentance. He (the narrator) said that he went back not far, when he came and said: Allah's Messenger, purify me. Allah's Apostle (may peace be upon him) said as he had said before. When it was the fourth time, Allah's Messenger (may, peace be upon him) said: From what am I to purify you? He said: From adultery, Allah's Messenger (may peace be upon him) asked if he had been mad. He was informed that he was not mad. He said: Has he drunk wine? A person stood up and smelt his breath but noticed no smell of wine. Thereupon Allah's Messenger (may peace be upon him) said: Have you committed adultery? He said: Yes. He made pronouncement about him and he was stoned to death. The people had been (divided) into two groups about him (Ma'iz). One of them said: He has been undone for his sins had encompassed him, whereas another said: There is no repentance more excellent than the repentance of Ma'iz, for he came to Allah's Apostle (may peace be upon him) and placing his hand in his (in the Holy Prophet's) hand said: Kill me with stones. (This controversy about Ma'iz) remained for two or three days. Then came Allah's Messenger (may peace be upon him) to them (his Companions) as they were sitting. He greeted them with salutation and then sat down and said: Ask forgiveness for Ma'iz b. Malik. They said: May Allah forgive Ma'iz b. Malik. Thereupon Allah's Messenger (may peace be upon him) said: He (Ma'iz) has made such a repentance that if that were to be divided among a people, it would have been enough for all of them. He (the narrator) said: Then a woman of Ghamid, a branch of Azd, came to him and said: Messenger of of Allah, purify me, whereupon he said: Woe be upon you; go back and beg forgiveness from Allah and turn to Him in repentance. She said: I find that you intend to send me back as you sent back Ma'iz. b. Malik. He (the Holy, Prophet) said: What has happened to you? She said that she had become pregnant as a result of fornication. He (the Holy Prophet) said: Is it you (who has done that)? She said: Yes. He (the Holy Prophet) said to her: (You will not be punished) until you deliver what is there in your womb. One of the Ansar became responsible for her until she was delivered (of the child). He (that Ansari) came to Allah's Apostle (may peace be upon him) and said the woman of Ghamid has given birth to a child. He (the Holy Prophet) said: In that case we shall not stone her and so leave her infant with none to suckle him. One of the Ansar got up and said: Allah's Apostle, let the responsibility of his suckling be upon me. She was then stoned to death.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4206]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4206

'Abdullah b. Buraida reported on the authority of his father that Ma'iz b. Malik al-Aslami came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I have wronged myself; I have committed adultery and I earnestly desire that you should purify me. He turned him away. On the following day, he (Ma'iz) again came to him and said: Allah's Messenger, I have committed adultery. Allah's Messenger (may peace be upon him) turned him away for the second time, and sent him to his people saying: Do you know if there is anything wrong with his mind. They denied of any such thing in him and said: We do not know him but as a wise good man among us, so far as we can judge. He (Ma'iz) came for the third time, and he (the Holy Prophet) sent him as he had done before. He asked about him and they informed him that there was nothing wrong with him or with his mind. When it was the fourth time, a ditch was dug for him and he (the Holy Prophet) pronounced judg- ment about him and he wis stoned. He (the narrator) said: There came to him (the Holy Prophet) a woman from Ghamid and said: Allah's Messenger, I have committed adultery, so purify me. He (the Holy Prophet) turned her away. On the following day she said: Allah's Messenger, Why do you turn me away? Perhaps, you turn me away as you turned away Ma'iz. By Allah, I have become pregnant. He said: Well, if you insist upon it, then go away until you give birth to (the child). When she was delivered she came with the child (wrapped) in a rag and said: Here is the child whom I have given birth to. He said: Go away and suckle him until you wean him. When she had weaned him, she came to him (the Holy Prophet) with the child who was holding a piece of bread in his hand. She said: Allah's Apostle, here is he as I have weaned him and he eats food. He (the Holy Prophet) entrusted the child to one of the Muslims and then pronounced punishment. And she was put in a ditch up to her chest and he commanded people and they stoned her. Khalid b Walid came forward with a stone which he flung at her head and there spurted blood on the face of Khalid and so he abused her. Allah's Apostle (may peace be upon him) heard his (Khalid's) curse that he had huried upon her. Thereupon he (the Holy Prophet) said: Khalid, be gentle. By Him in Whose Hand is my life, she has made such a repentance that even if a wrongful tax-collector were to repent, he would have been forgiven. Then giving command regarding her, he prayed over her and she was buried.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4207]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4207

Imran b. Husain reported that a woman from Juhaina came to Allah's Apostle (may peace be upon him) and she had become pregnant because of adultery. She said: Allah's Apostle, I have done something for which (prescribed punishment) must be imposed upon me, so impose that. Allah's Apostle (may peace be upon him) called her master and said: Treat her well, and when she delivers bring her to me. He did accordingly. Then Allah's Apostle (may peace be upon him) pronounced judgment about her and her clothes were tied around her and then he commanded and she was stoned to death. He then prayed over her (dead body). Thereupon Umar said to him: Allah's Apostle, you offer prayer for her, whereas she had committed adultery! Thereupon he said: She has made such a repentance that if it were to be divided among seventy men of Medina, it would be enough. Have you found any repentance better than this that she sacr ficed her life for Allah, the Majestic?


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4208]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4208

This hadith has been transmitted on the authority of Yahya b. Abu Kathir.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4209]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4209

Abu Huraira and Zaid b Khalid al-Juhani reported that one of the desert tribes came to Allah's Messenger (may peace be upon him) and said: Messenger of Allah, I beg of you in the name of Allah that you pronounce judgment about me according to the Book of Allah. The second claimant who was wiser than him said: Well, decide amongst us according to the Book of Allah, but permit me (to say something). Thereupon Allah's Messenger (may peace be upon ham) said: Say. He said: My son was a servant in the house of this person and he committed adultery with his wife. I was informed that my son deserved stoning to death (as punishment for this offence). I gave one hundred goats and a slave girl as ransom for this. I asked the scholars (if this could serve as an expiation for this offence). They informed me that my son deserved one hundred lathes and exile for one year. and this woman deserved stoning (as she was married). Thereupon Allah's Messenger (may peace he upon him) said: By Him in Whose Hand is my life. I will decide between you according to the Book of Allah. The slave-girl and the goats should be given back, and your son is to be punished with one hundred lashes and exile for one year. And, O Unais (b. Zuhaq al-Aslami), go to this woman in the morning, and if she makes a confession, then stone her. He (the narrator) said: He went to her in the morning and she made a confession. And Allah's Messenger (may peace be upon him) made pronouncement about her and she was stoned to death.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4210]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4210

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4211]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4211

Abdullah b. 'Umar reported that a Jew and a Jewess were brought to Allah's Messenger (may peace be upon him) who had committed adultery. Allah's Messenger (may peace be upon him) came to the Jews and said: What do you find in Torah for one who commits adultery? They said: We darken their faces and make them ride on the donkey with their faces turned to the opposite direction (and their backs touching each other), and then they are taken round (the city). He said: Bring Torah if you are truthful. They brought it and recited it until when they came to the verse pertaining to stoning, the person who was reading placed his hand on the verse pertaining to stoning, and read (only that which was) between his hands and what was subsequent to that. Abdullah b. Salim who was at that time with the Messenger of Allah (may peace be upon him) said: Command him (the reciter) to lift his hand. He lifted it and there was, underneath that, the verse pertaining to stoning. Allah's Messenger (may peace be upon him) pronounced judgment about both of them and they were stoned. Abdullah b. 'Umar said: I was one of those who stoned them, and I saw him (the Jew) protecting her (the Jewess) with his body.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4212]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4212

Ibn Umar reported that Allah's Messenger (may peace be upon him) stoned to death the Jews, both male and female, who had committed adultery. The Jews brought them to Allah's Messenger (may peace he upon him). The rest of the hadith is the same.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4213]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4213

Ibn 'Umar reported that the Jews brought to Allah's Messenger (may peace be upon him) a man and a woman who had committed adultery. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4214]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4214

Al-Bara' b. 'Azib reported: There happened to pass by Allah's Apostle (may peace be upon him) a Jew blackened and lashed. Allah's Apostle (may peace be upon him) called them (the Jews) and said: Is this the punishment that you find in your Book (Torah) as a prescribed punishment for adultery? They said: Yes. He (the Holy Prophet) called one of the scholars amongst them and said: I ask you in the name of Allah Who sent down the Torah on Moses if that is the prescribed punishment for adultery that you find in your Book. He said: No. Had you not asked me in the name of Allah, I would not have given you this information. We find stoning to death (as punishment prescribed in the Torah). But this (crime) became quite common amongst our aristocratic class. So when we caught hold of any rich person (indulging in this offence) we spared him, but when we caught hold of a helpless person we imposed the prescribed punishment upon him. We then said: Let us argree (on a punishment) which we can inflict both upon the rich and the poor. So We decided to blacken the face with coal and flog as a substitute punishment for stoning. Thereupon Allah's Messenger (may peace be upon him) said: O Allah, I am the first to revive Thy command when they had made it dead. He then commanded and he (the offender) was stoned to death. Allah, the Majestic and Glorious, sent down (this verse):" O Messenger, (the behaviour of) those who vie with one another in denying the truth should not grieve you..." up to" is vouchsafed unto you, accept it" (v. 41) 2176 It was said (by the Jews): Go to Muhammad; it he commands you to blacken the face and award flogging (as punishment for adultery), then accept it, but it he gives verdict for stoning, then avoid it. It was (then) that Allah, the Majestic and Great, sent down (these verses):" And they who do not judge in accordance with what Allah has revealed are, indeed, deniers of the truth" (v. 44) ;" And they who do not judge in accordance with what Allah has revealed-they, they indeed are the wrongdoers" (v. 45) ;" And they who do not judge in accordance with what God has revealed-they are the iniquitous (v. 47). (All these verses) were revealed in connection with the non-believers.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4215]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4215

This hadith has been narrated on the authority of A'mash up to the words:" Allah's Apostle (may peace be upon him) pronounced judgment and he was stoned (to death)" And he mentioned nothing subsequent to that pertaining to the revelation of verses.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4216]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4216

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) stoned (to death) a person from Banu Aslam, and a Jew and his wife.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4217]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4217

This hadith has been transmitted on the authority of Juraij with a slight variation of words.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4218]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4218

Abu Ishaq Shaibani said: I asked 'Abdullah b. Abu Aufi if Allah's Messenger (may peace be upon him) awarded (the punishment) of stoning (to death). He said: Yes. I said: After Sura al-Nur was revealed or before that? He said: I do not know.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4219]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4219

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: When the slave-woman of any of you commits adultery and this (offence of hers) becomes clear, she should be flogged (as the presribed) punishment, but hurl no reproach at her. If she commits adultery again, she should (again be punished) by flogging, but hurl no reproach upon her. It she commits fornication for the third time. and it becomes clear, then he should sell her, even if only for a rope of hair.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4220]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4220

This hadith his been narrated on the authority of Abu Huraira through another chain of transmitters with a slight variation of words.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4221]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4221

Abu Huraira reported that Allah's Messenger (may peace be upon him) was asked about the slave-woman who committed adultery and was not protected (married). He said: If she commits adultery, then flog her and it she commits adultery again, then flog her and then sell her even for a rope. Ibn Shihab said: I do not know whether he said this (his statement pertaining to the sale of slave-woman) at the third or the fourth time. Ibn Shihab said that the word) dafir (used in the text) means rope.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4222]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4222

This hadith has been narrated on the authority of Abu Huraira and Zaid b. Khalid al-Jubani, but in this no merition is made of the words of Ibn Shihab that dafir means rope.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4223]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4223

This hadith has been transmitted on the authority of Abu Huraira and Zaid b. Khalid al-Juhani in the same way as transmitted by Malik with this (difference) tnat there is a doubt whether her sale (that of the slave-girl committing adultery) was mentioned after the third or the fourth time.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4224]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4224

Abd al-Rahman reported that 'Ali, while delivering the address said: O people, impose the prescribed punishment upon your slaves, those who are married and those not married, for a slave-woman belonging to Allah's Messenger (may peace be upon him) had committed adultery, and he committed me to flog her. But she had recently given birth to a child and I was afraid that if I flogged her I might kill her. So I mentioned that to Allah's Apostle (may peace be upon him) and he said: You have done well.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4225]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4225

This hadith has been narrated on the authority of as-Suddi with the same chain of trznsmitters, but he did not mention:" Those who are married and those who are not married." There is also an addition in it:" I spare her until she is all right."


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4226]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4226

Anas b. Malik reported that a person who had drink wine was brought to Allah's Apostle (may peace be upon him). He gave him forty stripes with two lashes. Abu Bakr also did that, but when Umar (assumed the responsibilities) of the Caliphate, he consulted people and Abd al-Rahman said: The mildest punishment (for drinking) is eighty (stripes) and 'Umar their prescribed this punishment.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4227]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4227

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4228]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4228

Anas b. Malik reported that Allah's Apostle (may peace be upon him) gave a beating with palm branches and shoes, and that Abu Bakr gave forty lashes. When Umar (became the Commander of the Faithful) and the people went near to pastures and towns, he said (to the Companions of the Holy Prophet). What is your opinion about lashing for drinking? Thereupon Abd al-Rahman b. Auf said: My opinion is that you fix it as the mildest punishment. Then 'Umar inflicted eighty stripes.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4229]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4229

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4230]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4230

Anas reported that Allah's Apostle (may peace be upon him) used to strike forty times with shoes and palm branches (in case of drinking of) wine. The rest of the hadith is the same and there is no mention of pastures and towns.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4231]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4231

Hudain b. al-Mundhir Abu Sasan reported: I saw that Walid was brought to Uthmin b. 'Affan as he had prayed two rak'ahs of the dawn prayer, and then he said: I make an increase for you. And two men bore witness against him. One of them was Humran who said that he had drunk wine. The second one gave witness that he had seen him vomiting. Uthman said: He would not have vomited (wine) unless he had drunk it. He said: 'Ali, stand up and lash him. 'Ali said: Hasan, stand up and lash him. Thereupon Hasan said: Let him suffer the heat (of Caliphate) who has enjoyed its coolness. ('Ali felt annoyed at this remark) and he said: 'Abdullah b. Ja'far, stand up and flog him, and he began to flog him and 'Ali counted the stripes until these were forty. He (Hadrat 'Ali) said: Stop now, and then said: Allah's Apostle (may peace be upon him) gave forty stripes, and Abu Bakr also gave forty stripes, and Umar gave eighty stripes, and all these fall under the category of the Sunnab, but this one (forty stripes) is dearer to me.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4232]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4232

Ali reported: If I impose Hadd on anyone, and he (in course of punish ment) dies, I would not mind except in case of a drunkard. If he dies. I would pay indemnity for him because the Messenger of Allah (may peace be upon him) has laid down no rule for it.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4233]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4233

This hadith is narrated on the authority of Sufyan.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4234]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4234

Abu Barda Ansari reported Allah's Messenger (may peace be upon him) as saying: None should be given more than ten lashes, but in case of any Hadd out of the Huded of Allah.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4235]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4235

Ubida b. as-Samit reported: While we were in the company of Allah's Messenger (may peace be upoi him) he said: Swear allegiance to me that you will not associate anything with Allah, that you will not commit adultery, that you will not steal, that you will not take any life which it is forbidden by Allah to take but with (legal) justification; and whoever among you fulfils it, his reward is with Allah and he who commits any such thing and is punished for it, that will be all atonement for it And if anyone commits anything and Allah conceals (his faultfls), his matter rests with Allah. He may forgive if He likes, and He may punish him if He likes.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4236]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4236

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters with this addition:" He recited to us the verse pertaining to women, viz, that they will not associate anything with Allah.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4237]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4237

'Ubida b. as-Samit reported: Allah's Messenger (may peace be upon him) took (a pledge) from us as he took from the women that we will not associate anything with Allah and we will not steal, and we will not commit adultery, and we will not kill our children, and we will not bring calumny upon one another. And he who amongst you fulfils (this pledge), his reward rests with Allah, and he upon whom amongst you is imposed the prescribed punishment and that is carried out, that is his expiation (for that sin), and he whose (sins) were covered by Allah, his matter rests with Allah. He may punish him if He likes or may forgive him if He so likes.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4238]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4238

Ubida b. as-Samit repnrted: I was one of those headmen who swore allegiance to Allah's Messenger (may peace be upon him) that we will not associate anything with Allah, and will not commit adultery, and will not steal, and will not kill any soul which Allah has forbidden, but with justice nor plunder, nor disobey (Allah and His Apostle), then Paradise (will be the reward) in case we do these (acts) ; and if we commit any outrage (and that goes unpunished in the world), it is Allah Who would decide about it. Ibn Rumh said: Its judgment lies with Allah.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4239]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4239

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No requital is payable for a wound caused by an animal, for (falling into) a well and a mine, and one-fifth (is the share of the government) in the buried treasure (treasure-trove).


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4240]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4240

A hadith like this has been transmitted on the authority of Zuhri.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4241]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4241

A hadith like this has been transmitted on the authority of Abu Huraira.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4242]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4242

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The wound caused (by falling) in the well, in the mine, and caused bv the animal has no requital for it; and there is one-fifth (for the government) in the buried treasure.


Muslim :: The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud) :: [17.4243]

The Book Pertaining to Punishments Prescribed by Islam (Kitab Al-Hudud)

Muslim :: Book 17 : Hadith 4243

A hadith like this has been transmitted on the authority of Abu Huraira.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4244]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4244

Ibn Abbas reported Allah's Apostle (may peace be upon him) as saying: If the people were given according to their claims, they would claim the lives of persons and their properties, but the oath must be taken by the defendant.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4245]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4245

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) pronounced judgment on the basis of oath by the defendant.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4246]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4246

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) pronounced judgment on the basis of an oath and a witness (by the plaintiff).


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4247]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4247

Umm Salama reported Allah's Messenger (may peace be upon him) as saying: You bring to me, for (judgment) your disputes, some of you perhaps being more eloquent in their plea than others, so I give judgment on their behalf according to what I hear from them. (Bear in mind, in my judgment) if I slice off anything for him from the right of his brother, he should not accept that, for I sliced off for him a portion from the Hell.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4248]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4248

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4249]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4249

Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) heard the clamour of contenders at the door of his apartment. He went to them, and said: I am a human being and the claimants bring to me (the dispute) and perhaps some of them are more eloquent than the others. I judge him to be on the right, and thus decide in his favcur. So he whom I, by my judgment, (give the undue share) out of the right of a Muslim,. I give him a portion of Fire; he may burden himself with it or abandon it.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4250]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4250

This hadith has been transmitted on the authority of Ma'mar with a slight variation of words.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4251]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4251

A'isha reported: Hind. the daughter of 'Utba, wife of Abu Sufyan, came to Allah's Messenger (may peace be upon him) and said: Abu Sufyan is a miserly person. He does not give adequate maintenance for me and my children, but (I am constrained) to take from his wealth (some part of it) without his knowledge. Is there any sin for me? Thereupon Allah's Messenger (may peace be upon him) said: Take from his property what is customary which may suffice you and your children.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4252]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4252

This hadith has been narrated on the authority of Hisham with the same chair of transmitters.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4253]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4253

A'isha reported that Hind came to Allah's Apostle (may peace be upon him) and said: Messenger of Allah, by Allah, there was no other household upon the surface of the earth than your household about which I cherished Allah bringing disgrace upon it, (and now) there is no other household upon the surface of the earth than your household about which I cherish Allah granting it honour. Allah's Apostle (may peace be upon him) said: It is so, by Him in Whose Hand is my life She said: Allah's Messenger, Abu Sufyan is a niggardly person. Is there any harm for me if I spend upon his children out of his wealth without his permission? Thereupon Allah's Apostle (may peace be upon him) said: There is no harm for you if you spend upon them what is reasonable.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4254]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4254

A'isha reported that Hind, daughter of Utba h. Rabi', came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, by Allah, there was no household upon the surface of the earth than your household about which I cherished that it should be disgraced. But today there is no household on the surface of the earth than your household about which I cherish that it be honoured Thereupon Allah's Messenger (may peace be upon him) said. It will increase, by Him in Whose Hand is my life. She then said: Messenger of Allah, Abu Sufyan is a niggardly person; is there any harm for me if I spend out of that which belongs to him on our children? He said to her: No, but only that what is reasonable.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4255]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4255

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily Allah likes three things for you and He disapproves three things for you. He is pleased with you that you worship Him and associate nor anything with Him, that you hold fast the rope of Allah, and be not scattered; and He disapproves for you irrelevant talk, persistent questioning ane the wasting of wealth.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4256]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4256

This hadith has been narrated on the authority of Suhail with the same chain of transmitters, but with a slight variation of words.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4257]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4257

Mughira b. Shu'ba reported Allah's Messenger (may peace be upon him) as saying: Verity Allah, the Glorious and Majestic, has forbidden for you: disobedience to mothers, and burying alive daughters, withholding the right of others in spite of having the power to return that to them and demanding that (which is not one's legitimate right). And He disapproved three things for you; irrelevant talk, persistent questioning and wasting of wealth.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4258]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4258

A hadith like this has been trransmitted on the authority of Mansur with a slight vairiation of words.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4259]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4259

Sha'bi reported that the scribe of al-Mughira b. Shu'ba said: Mu'awiya wrote to Mughira: Write for me something which you heard from Allah's Messenger (may peace be upon him) ; and he wrote: I heard Allah's Messenger (may peace be upon him) as saying. Verily Allah disapproves three thingq for you: irrelevant talk, wasting of wealth and persistent questioning.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4260]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4260

Warrad reported that al-Mughira wrote to Mu'awiya: Peace be upon you, and then coming to the poirt (I should say) that I heard Allah's Messenger (may peace be upon him) as saying: Verily Allah has Prohibited three things and has forbidden three things. He has declared absolutely haram the disobedience of father, burying of daughters alive, and withholding that which you have power to return, and has forbidden three things: irrelevant talk, persistent questioning, and wasting of wealth.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4261]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4261

'Amr b. al-'As reported that he heard Allah's Messenger (may peace be upon him) as saying: When a judge gives a decision, having tried his best to decide correctly and is right, there are two rewards for him; and if he gave a judgment after having tried his best (to arrive at a correct decision) but erred, there is one reward for him.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4262]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4262

This hadith has been narrated on the authority of Abu Huraira with another chain of transmitters.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4263]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4263

This hadith has been transmitted on the authority of Usama b. al-Had al-Laithi.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4264]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4264

Abd al-Rabmin b. Abu Bakra reported: My father dictated (and I wrote for him) to Ubaidullah b. Abu Bakra while he was the judge of Sijistan: Do not judge between two persons when you are angry, for I have heard Allah's Messenger (may peace be upon him) as saying: None of you should judge between two persons when he is angry.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4265]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4265

This hadith has been narrated on the authority of 'Abd al-Rahman b. Abu Bakra through another chain of transmitters.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4266]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4266

'A'isha reported Allah's Messenger (may peace be upon him) as saying: He who innovates things in our affairs for which there is no valid (reason) (commits sin) and these are to be rejected.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4267]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4267

Sa'd b. Ibrahim reported: I asked Qasim b. Muhammad about a person who had three dwelling houses and he willed away the third part of every one of these houses; he (Qasim b. Muhammad) said: All of them could be combined in one house; and then said: 'A'isha informed me that Allah's Messenger (may peace be upon him) said: He who did any act for which there is no sanction from our behalf, that is to be rejected.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4268]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4268

Zaid b. Khalid al-Juhani reported Allah's Apostle (may peace be upon him) as saying: Should I not tell you of the best witnesses? He is the one who produces his evidence before he is asked for it.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4269]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4269

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: While two women had been going along witn their two sons, a wolf came and made away with the child of one of them. One of them said to her companion: It is with your child that it (the wolf) has run away The other one said: It has run away with your child. They brought the matter to (Hadrat) Dawud (David) for decision and he made a decision in favour of the elder one. They then went to Sulaiman b. Dawud (may there be peace upon both of them) and told them (the story). He said: Bring me a knife so that I may cut him (the child) (into two parts) for you. The younger one said: No, it can't be, may Allah have mercy upon you, he (the child) belongs to her (the elder). So he gave a decision in favour of the younger one. abu Huraira said: If ever I heard of the word as-sikin at all, it was that day. We called it by no other name but al-Mudya.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4270]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4270

This hadith has been narrated on the authority of Abu az-Zinad with the same chain of transmitters.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4271]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4271

Hammim b. Munabbih said: Abu Huraira reported (so many) ahadith of Allah's Messenger (may peace be upon him), and one of them is this: A person bought from another person a piece of land, and the person who had, bought that land found in it an earthen ware which contained gold. The person who had bought the land said (to the seller of the land): Take your gold from me, for I bought only the land from you and not the gold. The man who had sold the land said: I sold the land to you and whatever was in it. They referred the matter to a person. One who was made as a judge said to them: Have you any issue? One of them said: I have a boy, and the other said: I have a young daughter He (the judge) said: Marry this young boy with the girl, and spend something on yourselves and also give (some) charity out of it.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4272]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4272

Zaid b. Khalid al-Juhani reported: A man came to Allah's Apostle (may peace be upon him) and asked him about picking up of stray articles. He said: Recognise (well) its bag and the strap (by which it is tied) then make announcement of that for a year. If its owner comes (within this time return that to him), otherwise it is yours. He (again) said: (What about) the lost goat? Thereupon he (the Holy Prophet) said: It is yours or for your brother, or for the wolf. He said: (What about) the lost camel? Thereupon he said: You have nothing to do with it; it has a leather bag along with it, and its shoes also. It comes to the watering-place, eats (the leaves of the) trees until its master finds him.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4273]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4273

Zaid b. Khalid al-Juhani reported that a person asked Allah's Apostle (may peace be upon him) about picking up of stray articles, whereupon he said: Make announcement about it for a year, and recognise well the strap and the bag (containing that) ; then spend that; and if its owner comes, make him the payment of that. He (the inquirer) said: Messenger of Allah, what about the lost goat? he said: Take it, for that is yours or for your brother, or for the wolf. He (again) said: (What about) the lost camel? The Messenger of Allah (may peace be upon him) was enraged until his cheeks became red (or his face became red) and then said: You have nothing to do about that; it has feet and a leather bag (to quench its thirst) until its owner finds it.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4274]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4274

This hadith has been narrated on the authority of Rabi'a b. Abu Abd al-Rahman with the same chain of transmitters but with this addition:" There came a person to Allah's Messenger (may peace be upon him) while I was with him, and he asked him about picking up of a stray article, and he said: When none comes to demand it, then spend that."


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4275]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4275

Zaid b. Khalid al-Juhani reported. There came to Allah's Messenger (may peace be upon him) a person, the rest of the hadith is the same but with the variation (of these words): His face became red, his forehead too, and he felt annoyed; and made an addition after the words: He should make announcement of that for a year, and if its owner does not turn up, then it is a trust with you.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4276]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4276

Zaid b. Khalid al-Juhani, the Companion ot Allah's Messenger (may peace be upon him), said that Allah's Messenger (may peace be upon him) was asked about the picking up of stray gold or silver, whereupon he said: Recognise well the strap and the bag (containing) that and then make an announcement regarding that for one year, but if none recognises it, then spend that and it would be a trust with you; and if someone comes one day to make demand of that, then pay that to him. He (the inquirer) asked about the lost camel, whereupon he said: You have nothing to do with that. Leave that alone, for it has feet and also a leather bag, it drinks water, and eats (the leaves) of the trees. He asked him about sheep, whereupon he said: Take it, it is for you, or for your brother, or for the wolf.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4277]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4277

Zaid b. Khalid al-Juhani reported: A person asked Allah's Apostle (may peace be upon him) about a lost camel; Rabi'a made this addition: He (the Holy Prophet) was so much annoyed that his cheeks became red." The rest of the hadith is the same. He (the narrator) made this addition:" If its (that of the article) owner comes and he recognises the bag (which contained it) and its number, and the strap. then give that to them, but if not, then it is for you."


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4278]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4278

Zaid b. Khalid al-Juhani reported that Allah's Messenger (may peace be upon him) was asked about picking up of stray things, whereupon he said: Make announcement of that for one year, but if it is not recognised (by the owner), then recognise its big and strap, then eat it; and if its owner comes, then give that to him. This hadith has been narrated on the authority of Al-Dahhak b. Uthman with the same chain of transmitters but with a slight variation of words.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4279]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4279

Salama b. Kuhail reported: I heard Sowaid b. Ghafala say: I went out, and also Zaid b. Suhan and Salman b. Rabi'a for Jibad, and I found a whip and took it up. They said to me: Leave it. I said: No. but I will make announcement of it and if its owner comes (then I will return that), otherwise I will use it, and I refused them. When we returned from Jihad. by a good fortune for me, I performed Pilgrimage. I came to Medina and met Ubayy b. Ka'b, and related to him the affair of the whip and their opinion (the opinion of Zaid b. Suhan and Salman b. Rabi'a) about it (i. e. I should throw it). Thereupon he said: I found a money bag during the lifetime of Allah's Messenger (may peace be upon him) which contained one hundred dinars. I came to him along with it, and he said: Make an announcement of it for one year; so I announced it, but did not find anyone who could (claim it after) recognising it. I again came to him and he said: Make announcement for one year. So I made announcement of it, but I found none who could recognise it. I came to him he said: Make announcement of it for one year. I made announcement of that but did not find one who could recognise it, whereupon he said: Preserve (in your mind) its number, its bag and its strap, and if its owner comes (then return that to him), otherwise make use of it. So I made use of that. I (Shu'ba) met him (Salama b. Kuhail) after this in Mecca, and he said: I do not know whether he said three years or one year.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4280]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4280

Shu'ba reported: Salama b. Kuhail informed me or he informed people and I was among them. He said: I heard Sawaid b. Ghafala who reported: I went out along with Zaid b. Suhan and Salman b. Rabi'a, and found a whip, the rest of the hadith is the same up to the words:" I made use of that." Shu'ba said: I heard him say after ten years, that he made an announcement of it for one year.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4281]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4281

This hadith has been narrated on the authority of Salama b. Kuhail through different chains of transmitters. In their ahadith, it is three years, except in the hadith of Hammid b. Salama it is two years or three years. In the hadith transmitted on the authority of Sufyan and Zaid b. Abu Unaisa and Hammid b. Salama (the words are):" If someone comes and informs you about the number (of articles) of the bag and the straps, then give that to him." Sufyan has made this addition in the narration of Waki':" Otherwise it is like your property." And in the narration of Ibn Numair the words are:" Otherwise make use of that."


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4282]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4282

'Abd al-Rahman b. 'Uthman al-Taimi reported that Allah's Messenger (may peace be upon him) forbade taking into custody the stray thing of the pilgrims.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4283]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4283

Zaid b. Khalid al-Juhani reported Allah's Messenger (may peace be upon him) as sayin.: He who found a stray article is himself led astray if he does not advertise it.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4284]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4284

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said this: None (of you) should milk the animal of another, but with his permission. Does any one of you like that his chamber be raided, and his vaults be broken, and his foodstuff be removed? Verily the treasures for them (those who keep animals) are the udders of the animals which feed them. So none of you should milk the animal of another but with his permission.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4285]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4285

This hadith has been narrated through another chain of transmitters with a slight variation of words.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4286]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4286

Abd Shuraib al-Adawi reported: My eare listened and my eye saw when Allah's Messenger (may peace be upon him) spoke and said: He who believes In Allah and the eireafter should show respect to the guest even with utmost kindness and courtesy. They said: Messenger of Allah, what is this utmost kindness and courtesy? He replied: It is for a day and a night. Hospitality extends for three days, and what is beyond that is a Sadaqa for him; and he who believes in Allah and the Hereafter should say something good or keep quiet.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4287]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4287

Abu Shuriah al-Khuza'i reported Allah's Messenger (may peace be upon him) as saying: (The period of the entertainment of a guest is three days, and utmost kindness and courtesy is for a day and a night. =" It is not permissible for a Muslim to stay with, his brother until he makes him sinful. They said: Messenger of Allah, how he would make him sinful? He (the Holy Prophet) said: He stays with him (so long) that nothing is left with him to entertain him.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4288]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4288

Sa'id al-Maqburi reported: I heard Abu Shuraih al-Khuzill saying: My ears heard and my eyes saw and my mind retained it, when Allah's Messenger (may peace be upon him) spok this, and he then narrated the hadith and made mention of this:" It is not permissible for any one of you to stay with his brother until he makes him sinful."


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4289]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4289

'Uqba b. Amir reported: We said to Allah's Messenger (may peace be upon him): You send us out and we come to the people who do not give us hospitality, so what is your opinion? Thereupon Allah's Messenger (may peace be upon him) said: If you come to the people who order for you what is befitting a guest, accept it; but if they do not. take from them what befits them to give to a guest.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4290]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4290

Abu Sa'id al-Khudri reported: While we were with the Apostle of Allah (may peace be upon him) on a journey, a person came upon his mount and began to stare on the right and on the left, (it was at this moment) that Allah's Messenger (may peace be upon him) said: He who has an extra mount should give that to one who has no mount for him, and he who has surplus of provisions should give them to him who has no provisions, and he made mention of so many kinds of wealth until we were of the opinion that none of us has any right over the surplus.


Muslim :: The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya) :: [18.4291]

The Book Pertaining to Judicial Decisions (Kitab Al-Aqdiyya)

Muslim :: Book 18 : Hadith 4291

Iyas b. Salama reported on the authority of his father: We set out on an expedition with, Allah's Messenger (may peace be upon him). We facts hardship (in getting provisions) until we decided to slaughter some of our riding animals. Allah's Apostle (may peace be upon him), commanded us to pool our provisions of food. So we spread a sheet of leather and the provisions of the people were collected on it. I stretched myself to measure how much that was (the length and, breadth of the sheet on which the provisions were laid). I measured it and (found) that it was (in length and breadth) of (so much size) on which a goat could sit. We were fourteen hudnred persons. We (all) ate until we were fully satisfied and then filled our bags with provisions. Then Allah's Apostle (may peace be upon him) said: Is there any water for performing ablution. Then there came a man with a small bucket containing some water. He threw it in a basin. We all fourteen hundred persons performed ablution using the water in plenty. Then there came after that eight persons and they said: Is there any water to perform ablution? Thereupon Allah's Messenger (may peace be upon him) said: The ablution has already been performed.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4292]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4292

Ibn 'Aun reported: I wrote to Nafi' inquiring from him whether it was necessary to extend (to the disbelievers) an invitation to accept (Islam) before m". ing them in fight. He wrote (in reply) to me that it was necessary in the early days of Islam. The Messenger of Allah (may peace be upon him) made a raid upon Banu Mustaliq while they were unaware and their cattle were having a drink at the water. He killed those who fought and imprisoned others. On that very day, he captured Juwairiya bint al-Harith. Nafi' said that this tradition was related to him by Abdullah b. Umar who (himself) was among the raiding troops.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4293]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4293

This hadith has been narrated on the authority of Ibn 'Aun and the name of Juwairiya bint al-Harith was mentioned beyond any doubt.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4294]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4294

It has been reported from Sulaiman b. Buraid through his father that when the Messenger of Allah (may peace be upon him) appointed anyone as leader of an army or detachment he would especially exhort him to fear Allah and to be good to the Muslims who were with him. He would say: Fight in the name of Allah and in the way of Allah. Fight against those who disbelieve in Allah. Make a holy war, do not embezzle the spoils; do not break your pledge; and do not mutilate (the dead) bodies; do not kill the children. When you meet your enemies who are polytheists, invite them to three courses of action. If they respond to any one of these, you also accept it and withold yourself from doing them any harm. Invite them to (accept) Islam; if they respond to you, accept it from them and desist from fighting against them. Then invite them to migrate from their lands to the land of Muhairs and inform them that, if they do so, they shall have all the privileges and obligations of the Muhajirs. If they refuse to migrate, tell them that they will have the status of Bedouin Muilims and will be subjected to the Commands of Allah like other Muslims, but they will not get any share from the spoils of war or Fai' except when they actually fight with the Muslims (against the disbelievers). If they refuse to accept Islam, demand from them the Jizya. If they agree to pay, accept it from them and hold off your hands. If they refuse to pay the tax, seek Allah's help and fight them. When you lay siege to a fort and the besieged appeal to you for protection in the name of Allah and His Prophet, do not accord to them the guarantee of Allah and His Prophet, but accord to them your own guarantee and the guarantee of your companions for it is a lesser sin that the security given by you or your companions be disregarded than that the security granted in the name of Allah and His Prophet be violated When you besiege a fort and the besieged want you to let them out in accordance with Allah's Command, do not let them come out in accordance with His Command, but do so at your (own) command, for you do not know whether or not you will be able to carry out Allah's behest with regard to them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4295]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4295

Sulaiman b. Buraida repotted on the authority of his father that when Allah's Messenger (may peace be upon him) sent an Amir with a detachment he called him and advised him. The rest of the hadith is the same.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4296]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4296

This hadith has been transmitted on the authority of Shu'ba.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4297]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4297

It has been narrated on the authority of Abu Masa that when the Messenger of Allah (may peace be upon him) deputed any of his Companions on a mission, he would say: Give tidings (to the people) ; do not create (in their minds) aversion (towards religion) ; show them leniency and do not be hard upon them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4298]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4298

It has also been narrated by Sa'd b. Abu Burda through his father through his grandfather that the Prophet of Allah (may peace be upon him) sent him and Mu'adh (on a mission) to the Yemen, and said (by way of advising them): Show leniency (to the people) ; don't be hard upon them; give them glad tidings (of Divine favours in this world and the Hereafter) ; and do not create aversion. Work in collaboration and don't be divided.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4299]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4299

This hadith has been transmitted on the authority of Buraida but for the last two words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4300]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4300

The Messenger of Allah (may peace he upon him) has been reported by Anas b. Malik to have said: Show leniency; do not be hard; give solace and do not create aversion.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4301]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4301

It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: When Allah will gather together, on the Day of Judgment, all the earlier and later generations of mankind, a flag will be raised (to mark off) every person guilty of breach of faith, and it will be announced that this is the perfidy of so and so, son of so and so (to attract the attention of people to his guilt).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4302]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4302

This hadith has been narrated on the authority of Ibn Umar through some other Chains of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4303]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4303

This hadith has been narrated by another chain of transmitters on the authority of the same narrator, with the wording: Allah will set up a flag for every person guilty of breach of faith on the Day of Judgment, and it will be announced: Look, this is the perfidy of so and so.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4304]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4304

Ibn Umar reported that he heard the Messenger of Allah (may peace be upon him) saying: There will be a flag for every perfidious person on the Day of Judgment.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4305]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4305

'Abdullah reported Allah's Prophet (may peace be upon him) as saying: There will be a flag for every perfidious person on the Day of Judgment, and it would be said: Here is the perfidy of so and so.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4306]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4306

This hadith has been narrated on the authority of Shu'ba with a slight variation of wording.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4307]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4307

It has been narrated on the authority of Abdullah that the Messenger of Allah (may peace be upon him) said: There will be for every perfidious person on the Day of Judgment a flag by which he will be recognised. It will be announced: Here is the breach of faith of so and so.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4308]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4308

Anas reported Allah's Messenger (may peace be upon him) having said this: There would be a flag for every perfidious person on the Day of Judgment by which he will be recognised.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4309]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4309

It is narrated on the authority of Abu Sa'id that the Messenger of Allah (may peace be upon him) said: On the Day of Judgment there will be a flag fixed behind the buttocks of every person guilty of the breach of faith.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4310]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4310

It is narrated on the authority of Abu Sa'id that the Messenger of Allah (may peace be upon him) said: On the Day of Judgment there will be a flag for every person guilty of the breach of faith. It will be raised in proportion to the extent of his guilt; and there is no guilt of treachery more serious than the one committed by the ruler of men.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4311]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4311

It is narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: War is a stratagem.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4312]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4312

This hadith has also been narrated on the authority of Abu Huraira.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4313]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4313

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Do not desire an encounter with the enemy; but when you encounter them, be firm.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4314]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4314

It is narrated by Abu Nadr that he learnt from a letter sent by a man from the Aslam tribe, who was a Companion of the Holy Prophet (may peace be upon him) and whose name was 'Abdullah b. Abu Aufa, to 'Umar b. 'Ubaidullah when the latter marched upon Haruriyya (Khawarij) informing him that the Messenger of Allah (may peace be upon him) in one of those days when lie was confronting the enemy waited until the sun had declined. Then he stood up (to address the people) and said: O ye men, do not wish for an encounter with the enemy. Pray to Allah to grant you security; (but) when you (have to) encounter them exercise patience, and you should know that Paradise is under the shadows of the swords. Then the Messenger of Allah (may peace be upon him) stood up (again) and said: O Allah. Revealer of the Book, Disperser of the clouds, Defeater of the hordes, put our enemy to rout and help us against them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4315]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4315

It is narrated on the authority of Ibn Abu Aufa that the Messenger of Allah (may peace be upon him) cursed the tribes (who had marched upon Medina with a combined force in 5 H) and said: O Allah, Revealer of the Book, swift in (taking) account, put the tribes to rout. O Lord, defeat them and shake them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4316]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4316

This hadith has been transmitted on the authority of Ibn Abu Aufa with a slight variation of words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4317]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4317

This hadith has been narrated on the authority of Ibn 'Uyaina through another chain of transmitters (who added the words)" the Disperser of clouds" in his narration.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4318]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4318

It is narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) said on the day of the Battle of Ubud: O Allah, if Thou wilt (defeat Muslims), there will be none on the earth to worship Thee.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4319]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4319

It is narrated on the authority of 'Abdullah that a woman was found killed in one of the battles fought by the Messenger of Allah (may peace be upon him). He disapproved of the killing of women and children.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4320]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4320

It is narrated by Ibn 'Umar that a woman was found killed in one of these battles; so the Messenger of Allah (may peace be upon him) forbade the killing of women and children.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4321]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4321

It is reported on the authority of Sa'b b. Jaththama that the Prophet of Allah (may peace be upon him), when asked about the women and children of the polytheists being killed during the night raid, said: They are from them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4322]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4322

It is narrated by Sa'b b. Jaththama that he said (to the Holy Prophet): Messenger of Allah, we kill the children of the polytheists during the night raids. He said: They are from them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4323]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4323

Sa'b b. Jaththama has narrated that the Prophet (may peace be upon him) asked: What about the children of polytheists killed by the cavalry during the night raid? He said: They are from them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4324]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4324

It is narrated on the authority of 'Abdullah that the Messenger of Allah (may peace be upon him) ordered the date-palms of Banu Nadir to be burnt and cut. These palms were at Buwaira. Qutaibah and Ibn Rumh in their versions of the tradition have added: So Allah, the Glorious and Exalted, revealed the verse:" Whatever trees you have cut down or left standing on their trunks, it was with the permission of Allah so that He may disgrace the evil-doers" (lix. 5).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4325]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4325

It is narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) caused the date-palms of Banu Nadir to be cut down and burnt. It is in this connection that Hassan (the poet) said:

It was easy for the nobles of Quraish to barn Buwaira whose sparks were flying in all directions.

in the same connection was revealed the Qur'anic verse:" Whatever trees you have cut down or left standing on their trunks."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4326]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4326

'Abdullah b. Umar reported that Allah's Apostle (may peace be upon him) burnt the date-palms of Banu Nadir.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4327]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4327

It has been narrated by Abu Huraira that the Messenger of Allah (may peace be upon him) said: One of the Prophets made a holy war. He said to his followers: One who has married a woman and wants to consummate to his marriage but has not yet done so; another who has built a house but has not yet erected its roof; and another who has bought goats and pregnantshe-camels and is waiting for their offspring-will not accommpany me. So he marched on and approached a village at or about the time of the Asr prayers. He said to the sun: Thou art subserviant (to Allah) and so am I. O Allah, stop it for me a little. It was stopped for him until Allah granted him victory. The people gathered the spoils of war (at one place). A fire approached the spoils to devour them, but it did not devour them. He (the Holy Prophet) said: Some of you have been guilty of misappropriation. So one man from each tribe should swear fealty to me. The did so (putting their hands into his). The hand of one man stuck to his hand and the Prophet (may peace be upon him) said: Your tribe is guilty of misappropriation. Let all the members of your tribe swear fealty to me one by one. They did so, when the hands of two or three persons got stuck with his hand. He said: You have misappropriated. So they took out gold equal in volume to the head of a cow. They-placed it among the spoils on the earth. Then the fire approached the spoils and devoured them. The spoils of war were not made lawful for any people before us, This is because Allah saw our weakness and humility and made them lawful for us.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4328]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4328

A hadith has been narrated by Mus'ab b. Sa'd who heard it from his father as saying: My father took a sword from Khums and brought it to the Holy Prophet (may peace be upon him) and said: Grant it to me. He refused. At this Allah revealed (the Qur'anic verse):" They ask thee concerning the spoils of war. Say: The spoils of war are for Allah and the Apostle" (viii. 1).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4329]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4329

A hadith has been narrated by Mus'ab b. Sa'd who heard it from his father as saying:" Four verses of the Qur'an have been revealed about me. I found a sword (among the spoils of war). It was brought to the Holy Prophet (may peace be upon him). He (my father) said: Messenger of Allah, bestow it upon me. The Apostle of Allah (may peace be upon him) said: Place it there. Then he (my father) stood up and the Messenger of Allah (may peace be upon him) said to him: Place it from where you got it. (At this) he (my father) said again: Messenger of Allah, bestow it upon me Shall I be treated like one who has no share in (the booty)? The Apostle of Allah (may peace be upon him said: Place it from where you got it. At this was revealed the verse:" They ask thee about the spoils of war.... Say: The spoils of war are for Allah and the Messenger"


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4330]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4330

It has been narrated on the authority of Ibn Umar that the Prophet (may peace be upon him) sent an expedition to Najd and I was among the troops. They got a large number of camels as a booty. Eleven or twelve camels fell to the lot of every fighter and each of them also got one extra camel.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4331]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4331

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) sent an expedition to Najd and Ibn Umar was also among the troops, and their share (of the spoils) came to twelve camels and they were given one camel over and above that. and Allah's Messenger (may peace be upon him) did not make any change in it.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4332]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4332

It has been narrated by Ibn 'Umar that the Messenger of Allah (may peace be upon him) sent an expedition to Najd, and I (also) went with the troops. We got camels and goats as spoils of war, and our share amounted to twelve camels per head, and the Messenger of Allah (may peace be upon him) gave an extra camel to each of us.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4333]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4333

This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4334]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4334

Ibn Aun said: I wrote to Nafi' asking him about Nafl (spoils of war) and be wrote to me that Ibn 'Umar was among that expedition. (The rest of the hadith is the same.)


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4335]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4335

A hadith has been narrated by Salim who learnt it from his father and said: The Messenger of Allah (may peace be upon him) gave us an extra (camel) besides our share of Khums; (and in this extra share) I got a Sharif (and a Sharif is a big old camel).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4336]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4336

Ibn Shihab reported: It reached me through Ibn Umar that Allah's Messenger (may peace be upon him) gave a share of spoils to the troop. The rest of the hadith is the same.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4337]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4337

It has been narrated on the authority of Abdullah b. 'Umar that the Messenger of Allah (may peace be upon him) used to give (from the spoils of war) to small troops seat on expeditions something more than the due share of each fighter in a large force. And Khums (one-fifth of the total spoils) was to be reserved (for Allah and His Apostle) in all cases.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4338]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4338

Abu Muammad al-Ansari, who was the close companion of Abu Qatada. narrated the hadith (which follows).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4339]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4339

Abu Muhammad, the freed slave of Abu Qatada reported on the authority of Abu Qatda and narrated the hadith.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4340]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4340

Abu Qatada reported: We accompanied the Messenger of Allah (my peace be upon him) on an expedition in the year of the Battle of Hunain. When we encountered the enemy, (some of the Muslims turned back (in fear). I saw that a man from the polytheists overpowered one of the Muslims. I turned round and attacked him from behind giving a blow between his neck and shoulder. He turned towards me and grappled with me in such a way that I began to see death staring me in the face. Then death overtook him and left me alone. I joined 'Umar b. al-Khattab who was saying: What has happened to the people (that they are retreating)? I said: It is the Decree of Allah. Then the people returned. (The battle ended in a victory for the Muslims) and the Messenger of Allah (may peace be upon him) sat down (to distribute the spoils of war). He said: One who has killed an enemy and can bring evidence to prove it will get his belongings. So I stood up and said: Who will give evidence for me? Then I sat down. Then he (the Holy Prophet) said like this. I stood up (again) and said: Who will bear witness for me? He (the Holy Prophet) made the same observation the third time, and I stood up (once again). Now the Messenger of Allah (may peace be upon him) said: What has happened to you, O Abu Qatada? Then I related the (whole) story, to him. At this, one of the people said: He has told the truth. Messenger of Allah 1 The belongings of the enemy killed by him are with me. Persuade him to forgo his right (in my favour). (Objecting to this proposal) Abu Bakr said: BY Allah, this will not happen. The Messenger of Allah (may peace be upon him) will not like to deprive one of the lions from among the lions of Allah who fight in the cause of Allah and His Messenger and give thee his share of the booty. So the Messenger of Allah (may peace he upon him) said: He (Abu Bakr) has told the truth, and so give the belongings to him (Abu Qatada). So he gave them to me. I sold the armour (which was a part of my share of the booty) and bought with the sale proceeds a garden in the street of Banu Salama. This was the first property I acquired after embracing Islam.

In a version of the hadith narrated by Laith, the words uttered by Abu Bakr are:" No, never! He will not give it to a fox from the Quraish leaving aside a lion from the lions of Allah among...." And the hadith is closed with the words:" The first property I acquired."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4341]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4341

It has been narrated on the authority of 'Abd al-Rahman b. Auf who said: While I was standing in the battle array on the Day of Badr, I looked towards my right and my left, and found myself between two boys from the Ansar quite young in age. I wished I were between stronger persons. One of them made a sign to me and. said: Uncle, do you recognise Abu Jahl? 1 said: Yes. What do you want to do with him, O my nephew? He said: I have been told that he abuses the Messenger of Allah (may peace be upon him). By Allah, in Whose Hand is my life, if I see him (I will grapple with him) and will not leave him until one of us who is destined to die earlier is killed. The narrator said: I wondered at this. Then the other made a sign to me and said similar words. Soon after I saw Abu Jahl. He was moving about among men. I said to the two boys: Don't you see? He is the man you were inquiring about. (As soon as they heard this), they dashed towards him, struck him with their swords until he was killed. Then they returned to the Messenger of Allah (may peace be upon him) and informed him (to this effect). He asked: Which of you has killed him? Each one of them said: I have killed him. He said: Have you wiped your swords? They said: No. He examined their swords and said: Both of you have killed him. He then decided that the belongings of Abu Jahl he handed over to Mu'adh b. Amr b. al-Jamuh. And the two boys were Mu'adh b. Amr b. Jawth and Mu'adh b. Afra.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4342]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4342

Auf b. Malik has narrated that a man from the Himyar tribe killed an enemy and wanted to take the booty. Khalid b. Walid, who was the commander over them, forbade, him. 'Auf b Malik (the narrator) came to the Messenger of Allah (may peace be upon him) and informed him (to this effect). The latter asked Khalid: What prevented you from giving the booty to him? Khalid said: I thought it was too much. He (the Holy Prophet) said: Hand it over to him. Now when Khalid by Auf, the latter pulled him by his cloak and said (by way of chafing him): Hasn't the same thing happened what I reported to you from the Messenger of Allah (may peace he upon him)? When the Messenger of Allah (may peace be upon him) heard it. he was angry (and said): Khalid, don't give him, Khalid, don't give him. Are you going to desert the commanders appointed by roe? Your similitude and theirs is like a person who took camels and sheep for grazing. He grazed them and when it was time for them to have a drink, he brought them to a pool. So they drank from it, drinking away its clear water and leaving the turbid water below So the clear water (i. e. the best reward) is for you and the turbid water (i e. blame) is for them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4343]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4343

It has been narrated on the authority of Auf b. Malik al-Ashja'i who said: I joined the expedition that marched under Zaid b. Haritha to Muta, and I received reinformcement from the Yemen. (After this introduction), the narrator narrated the tradition that had gone before except that in his version Auf was reported to have said (to Khalid): Khalid, didn't you know that the Messenger of Allah (way peace be upon him) had decided In favour of giving the booty (sized from an enemy) to one who killed him? He (Khalid) said: Yes. but I thought it was too much.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4344]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4344

It has been reported by Salama b. al-Akwa': We fought the Battle of Hawazin along with the Messenger of Allah (may peace be upon him). (One day) when we were having our breakfast with the Messenger of Allah (may peace he upon him), a man came riding a red camel. He made it kneel down, extracted a strip of leather from its girth and tethered the camel with it. Then he began to take food with the people and look (curiously around). We were in a poor condition as some of us were on foot (being without any riding animals). All of a sudden, he left us hurriedy, came to his camel, untethered it, made it kneel down, mounted it and urged the beast which ran off with him. A man on a brown rhe-camel chased him (taking him for a spy). Salama (the narrator) said: I followed on foot. I ran on until I was near the thigh of the she-camel. I advanced further until I was near the haunches of the camel. I advanced still further until I caught hold of the nosestring of the camel. I made it kneel down. As soon as it placed its knee on the ground, I drew my sword and struck at the head, of the rider who fell down. I brought the camel driving it along with the man's baggage and weapons. The Messenger of Allah (may peace be upon him) came forward to meet me and the people were with him. He asked: Who has killed the man? The people said: Ibn Akwa'. He said: Everything of the man is for him (Ibn Akwa').


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4345]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4345

It has been narrated on the authority of Salama (b. al-Akwa') who said: We fought against the Fazara and Abu Bakr was the commander over us. He had been appointed by the Messenger oi Allah (may peace be upon him). When we were onlv at an hour's distance from the water of the enemy, Abu Bakr ordered us to attack. We made a halt during the last part of the night tor rest and then we attacked from all sides and reached their watering-place where a battle was fought. Some of the enemies were killed and some were taken prisoners. I saw a group of persons that consisted of women and children. I was afraid lest they should reach the mountain before me, so I shot an arrow between them and the mountain. When they saw the arrow, they stopped. So I brought them, driving them along. Among them was a woman from Banu Fazara. She was wearing a leather coat. With her was her daughter who was one of the prettiest girls in Arabia. I drove them along until I brought them to Abu Bakr who bestowed that girl upon me as a prize. So we arrived in Medina. I had not yet disrobed her when the Messenger of Allah (may peace be upon him) met me in the street and said: Give me that girl, O Salama. I said: Messenger of Allah, she has fascinated me. I had not yet disrobed her. When on the next day. the Messenger of Allah (may peace be upon him) ag;tin met me in the street, he said: O Salama, give me that girl, may God bless your father. I said: She is for you. Messenger of Allah! By Allah. I have not yet disrobed her. The Messenger of Allah (may peace be upon him) sent her to the people of Mecca, and surrendered her as ransom for a number of Muslims who had been kept as prisoners at Mecca.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4346]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4346

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If you come to a township (which has surrendered without a formal war) and stay therein, you have a share (that will be in the form of an award) in (the properties obtained from) it. If a township disobeys Allah and His Messenger (and actually fights against the Muslims) one-fifth of the booty seized therefrom is for Allah and His Apostle and the rest is for you.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4347]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4347

It has been narrated on the authority of Umar, who said: The properties abandoned by Banu Nadir were the ones which Allah bestowed upon His Apostle for which no expedition was undertaken either with cavalry or camelry. These properties were particularly meant for the Holy Prophet (may peace be upon him). He would meet the annual expenditure of his family from the income thereof, and would spend what remained for purchasing horses and weapons as preparation for Jihad.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4348]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4348

This hadith has been narrated on the authority of Zuhri.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4349]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4349

It is reported by Zuhri that this tradition was narrated to him by Malik b. Aus who said: Umar b. al-Khattab sent for me and I came to him when the day had advanced. I found him in his house sitting on his bare bed-stead, reclining on a leather pillow. He said (to me): Malik, some people of your tribe have hastened to me (with a request for help). I have ordered a little money for them. Take it and distribute it among them. I said: I wish you had ordered somebody else to do this job. He said: Malik, take it (and do what you have been told). At this moment (his man-servant) Yarfa' came in and said: Commander of the Faithful, what do you say about Uthman, Abd al-Rabman b. 'Auf, Zubair and Sa'd (who have come to seek an audience with you)? He said: Yes, and permitted them. so they entered. Then he (Yarfa') came again and said: What do you say about 'Ali and Abbas (who are present at the door)? He said: Yes, and permitted them to enter. Abbas said: Commander of the Faithful, decide (the dispute) between me and this sinful, treacherous, dishonest liar. The people (who were present) also said: Yes. Commander of the Faithful, do decide (the dispute) and have mercy on them. Malik b. Aus said: I could well imagine that they had sent them in advance for this purpose (by 'Ali and Abbas). 'Umar said: Wait and be patient. I adjure you by Allah by Whose order the heavens and the earth are sustained, don't you know that the Messenger of Allah (may peace be upon him) said:" We (prophets) do not have any heirs; what we leave behind is (to be given in) charity"? They said: Yes. Then he turned to Abbas and 'Ali and said: I adjure you both by Allah by Whose order the heavens and earth are sustained, don't you know that the Messenger of Allah (may peace be upon him) said:" We do not have any heirs; what we leave behind is (to be given in) charity"? They (too) said: Yes. (Then) Umar said: Allah, the Glorious and Exalted, had done to His Messenger (may peace be upon him) a special favour that He has not done to anyone else except him. He quoted the Qur'anic verse:" What Allah has bestowed upon His Apostle from (the properties) of the people of township is for Allah and His Messenger". The narrator said: I do not know whether he also recited the previous verse or not. Umar continued: The Messenger of Allah (may peace be upon him) distrbuted among you the properties abandoned by Banu Nadir. By Allah, he never preferred himself over you and never appropriated anything to your exclusion. (After a fair distribution in this way) this property was left over.

The Messenger of Allah (may peace be upon him) would meet from its income his annual expenditure, and what remained would be deposited in the Bait-ul-Mal. (Continuing further) he said: I adjure you by Allah by Whose order the heavens and the earth are sustained. Do you know this? They said: Yes. Then he adjured Abbas and 'All as he had adjured the other persons and asked: Do you both know this? They said: Yes. He said: When the Messenger of Allah (may peace be upon him) passed away, Abu Bakr said:" I am the successor of the Messenger of Allah (may peace be upon him)." Both of you came to demand your shares from the property (left behind by the Messenger of Allah). (Referring to Hadrat 'Abbas), he said: You demanded your share from the property of your nephew, and he (referring to 'Ali) demanded a share on behalf of his wife from the property of her father. Abu Bakr (Allah be pleased with him) said: The Messenger of Allah (may peace be upon him) had said:" We do not have any heirs; what we leave behind is (to be given in) charity." So both of you thought him to be a liar, sinful, treacherous and dishonest. And Allah knows that he was true, virtuous, well-guided and a follower of truth. When Abu Bakr passed away and (I have become) the successor of the Messenger of Allah (may peace be upon him) and Abu Bakr (Allah be pleased with him), you thought me to be a liar, sinful, treacherous and dishonest. And Allah knows that I am true, virtuous, well-guided and a follower of truth. I became the guardian of this property. Then you as well as he came to me. Both of you have come and your purpose is identical. You said: Entrust the property to us. I said: If you wish that I should entrust it to you, it will be on the condition that both of you will undertake to abide by a pledge made with Allah that you will use it in the same way as the Messenger of Allah (may peace be upon him) used it. So both of you got it. He said: Wasn't it like this? They said: Yes. He said: Then you have (again) come to me with the request that I should adjudge between you. No, by Allah. I will not give any other judgment except this until the arrival of the Doomsday. If you are unable to hold the property on this condition, return it to me.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4350]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4350

The same hadith has been narrated by a different chain of transmitters with a slight variation in wording: 'Umar b. al-Khattab sent for me and said: Some families from your tribe have come to me (then follows the foregoing hadith) by Malik with the difference that the Messenger of Allah (may peace be upon him) would spend on his family for a year. And sometimes Ma'mar said: He would retain sustenance for his family for a year, and what was left of that he spent in the cause of Allah, the Majestic and Exalted.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4351]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4351

It is narrated on the authority of 'A'isha who said: When the Messenger of Allah (may peace be upon him) passed away, his wives made up their minds to send 'Uthman b. 'Affan (as their spokesman) to Abu Bakr to demand from him their share from the legacy of the Holy Prophet (may peace be upon him). (At this), A'isha said to them: Hasn't the Messenger of Allah (may peace be upon him) said:" We (Prophets) do not have any heirs; what we leave behind is (to be given in) charity"?


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4352]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4352

It is narrated on the authority of Urwa b. Zubair who narrated from A'isha that she informed him that Fatima, daughter of the Messenger of Allah (may peace be upon him), sent someone to Abu Bakr to demand from him her share of the legacy left by the Messenger of Allah (may peace be upon him) from what Allah had bestowed upon him at Medina and Fadak and what was left from one-filth of the income (annually received) from Khaibar. Abu Bakr said: The Messenger of Allah (may peace be upon him) said:" We (prophets) do not have any heirs; what we leave behind is (to be given in) charity." The household of the Messenger of Allah (may peace be upon him) will live on the income from these properties, but, by Allah, I will not change the charity of the Messenger of Allah (may peace be upon him) from the condition in which it was in his own time. I will do the same with it as the Messenger of Allah (may peace be upun him) himself used to do. So Abu Bakr refused to hand over anything from it to Fatima who got angry with Abu Bakr for this reason. She forsook him and did not talk to him until the end of her life. She lived for six months after the death of the Messenger of Allah (may peace be upon him). When she died, her husband. 'Ali b. Abu Talib, buried her at night. He did not inform Abu Bakr about her death and offered the funeral prayer over her himself. During the lifetime of Fatima, 'All received (special) regard from the people. After she had died, he felt estrangement in the faces of the people towards him. So he sought to make peace with Abu Bakr and offer his allegiance to him. He had not yet owed allegiance to him as Caliph during these months. He sent a person to Abu Bakr requesting him to visit him unaccompanied by anyone (disapproving the presence of Umar). 'Umar said to Abu Bakr: BY Allah, you will not visit them alone. Abu Bakr said: What will they do to me? By Allah, I will visit them. And he did pay them a visit alone. 'All recited Tashahhud (as it is done in the beginning of a religious sermon) ; then said: We recognise your moral excellence and what Allah has bestowed upon you. We do not envy the favour (i. e. the Catiphate) which Allah nas conferred upon you; but you have done it (assumed the position of Caliph) alone (without consulting us), and we thought we had a right (to be consulted) on account of our kinship with the Messenger of Allah (may peace be upon him). He continued to talk to Abu Bakr (in this vein) until the latter's eyes welled up with tears. Then Abd Bakr spoke and said: By Allah, in Whose Hand is my life, the kinship of the Messenger of Allah (may peace be upon him) is dearer to me than the kinship of my own people. As regards the dispute that has arisen between you and me about these properties, I have not deviated from the right course and I have not given up doing about them what the Messenger of Allah (may peace be upon him) used to do. So 'Ali said to Abu Bakr: This aftetnoon is (fixed) for (swearing) allegiance (to you). So when Abu Bakr had finished his Zuhr prayer, he ascended the pulpit and recited Tashahhud, and described the status of 'Ali, his delay in swearing allegiance and the excuse which lie had offered to him (for this delay). (After this) he asked for God's forgiveness. Then 'Ali b. Abu Talib recited the Tashahhud. extolled the merits of Abu Bakr and (said that) his action was nott prompted by any jealousy of Abu Bakr on his part or his refusal to accept the high position which Allah had conferred upon him, (adding: ) But we were of the opinion that we should have a share in the government, but the matter had been decided without taking us into confidence, and this displeased us. (Hence the delay in offering allegiance. The Muslims were pleased with this (explanation) and they said: You have done the right thing. The Muslims were (again) favourably inclined to 'Ali since he adopted the proper course of action.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4353]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4353

It has been narrated on the authority of 'A'isha that Fatima and 'Abbas approached Abu Bakr, soliciting transfer of the legacy of the Messenger of Allah (may peace be upon him) to them. At that time, they were demanding his (Holy Prophet's) lands at Fadak and his share from Khaibar. Abu Bakr said to them: I have heard from the Messenger of Allah (may peace be upon him). Then he quoted the hadith having nearly the same meaning as the one which has been narrated by Uqail on the authority of al-Zuhri (and which his gone before) except that in his version he said: Then 'Ali stood up, extolled the merits of Abu Bakr mentioned his superiority, and his earlier acceptance of Islam. Then he walked to Abu Bakr and swore allegiance to him. (At this) people turned towards 'Ali and said: you have done the right thing. And they became favourably inclined to 'Ali after he had adopted the proper course of action.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4354]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4354

It has been narrated by 'Urwa b Zubair on the authority of 'A'isha, wife of the Holy Prophet (may peace be upon him), that Fatima, daughter of the Messenger of Allah (may peace be upon him), requested Abu Bakr, after the death of the Messenger of Allah (may peace he upon him), that he should set apart her share from what the Messenger of Allah (may peace be upon him) had left from the properties that God had bestowed upon him. Abu Bakr said to her: The Messenger of Allah (may peace be npon him) said:" We do not have any heirs; what we leave behind is Sadaqa (charity)." The narrator said: She (Fatima) lived six months after the death of the Messenger of Allah (may peace be upon him) and she used to demand from Abu Bakr her share from the legacy of the Messenger of Allah (may peace be upon him) from Khaibar, Fadak and his charitable endowments at Medina. Abu Bakr refused to give her this, and said: I am not going to give up doing anything which the Messenger of Allah (may peace be upon him) used to do. I am afraid that it I go against his instructions in any matter I shall deviate from the right course. So far as the charitable endowments at Medina were concerned, 'Umar handed them over to 'All and Abbas, but 'Ali got the better of him (and kept the property under his exclusive possession). And as far as Khaibar and Fadak were concerned 'Umar kept them with him, and said: These are the endowments of the Messenger of Allah (may peace be upon him) (to the Umma). Their income was spent on the discharge of the responsibilities that devolved upon him on the emergencies he had to meet. And their management was to be in the hands of one who managed the affairs (of the Islamic State). The narrator said: They have been managed as such up to this day.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4355]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4355

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: My heirs cannot share even a dinar (from my legacy) ; what I leave behind after paving mtintenance allowance to my wives and remuneration to my manager is (to go in) charity.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4356]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4356

A similar hadith has been narrated on the authority of Abu Zinad through a different chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4357]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4357

It his been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said:" We do not have any heirs; what we leave behind is a charitable endowment."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4358]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4358

It has been narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) allowed two shares from the spoils to the horseman and one share to the footman.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4359]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4359

The same tradition has been narrated on the authority of Ubaidullah by a different chain of transmitters who do not mention the words:" from the booty".


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4360]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4360

It has been narrated on the authority of 'Umar b. al-Khattab who said: When it was the day on which the Battle of Badr was fought, the Messenger of Allah (may peace be upon him) cast a glance at the infidels, and they were one thousand while his own Companions were three hundred and nineteen. The Holy Prophet (may peace be upon him) turned (his face) towards the Qibla Then he stretched his hands and began his supplication to his Lord:" O Allah, accomplish for me what Thou hast promised to me. O Allah, bring about what Thou hast promised to me. O Allah, if this small band of Muslims is destroyed. Thou will not be worshipped on this earth." He continued his supplication to his Lord, stretching his hands, facing the Qibla, until his mantle slipped down from his shoulders. So Abu Bakr came to him, picked up his mantle and put it on his shoulders. Then he embraced him from behind and said:. Prophet of Allah, this prayer of yours to your Lord will suffice you, and He will fulfil for you what He has promised you. So Allah, the Glorious and Exalted, revealed (the Qur'anic verse):" When ye appealed to your Lord for help, He responded to your call (saying): I will help you with one thousand angels coming in succession." So Allah helped him with angels.

Abu Zumail said that the badith was narrated to him by Ibn 'Abbas who said: While on that day a Muslim was chasing a disbeliever who was going ahead of him, he heard over him' the swishing of the whip and the voice of the rider saying: Go ahead, Haizi'm! He glanced at the polytheist who had (now) fallen down on his back. When he looked at him (carefully he found that) there was a scar on his nose and his face was torn as if it had been lashed with a whip, and had turned green with its poison. An Ansari came to the Messenger of Allah (may peace be upon him) and related this (event) to him. He said: You have told the truth. This was the help from the third heaven. The Muslims that day (i. e. the day of the Battle of Badr) killed seventy persons and captured seventy. The Messenger of Allah (may peace be upon him) said to Abu Bakr and 'Umar (Allah be pleased with them): What is your opinion about these captives? Abu Bakr said: They are our kith and kin. I think you should release them after getting from them a ransom. This will be a source of strength to us against the infidels. It is quite possible that Allah may guide them to Islam. Then the Messenger of Allah (may peace be upon him) said: What is your opinion. Ibn Khattab? He said: Messenger of Allah. I do not hold the same opinion as Abu Bakr. I am of the opinion that you should hand them over to us so that we may cut off their heads. Hand over 'Aqil to 'Ali that he may cut off his head, and hand over such and such relative to me that I may but off his head. They are leaders of the disbelievers and veterans among them. The Messenger of Allah (may peace be upon him) approved the opinion of Abu Bakr and did not approve what I said The next day when I came to the Messenger of Allah (may peace be upon him), I found that both he and Abu Bakr were sitting shedding tears. I said: Messenger of Allah, why are you and your Companion shedding tears? Tell me the reason. For I will weep ate, if not, I will at least pretend to weep in sympathy with you. The Messenger of Allah (may peace be upon him) said: I weep for what has happened to your companions for taking ransom (from the prisoners). I was shown the torture to which they were subjected. It was brought to me as close as this tree. (He pointed to a tree close to him.) Then God revealed the verse:" It is not befitting for a prophet that he should take prisoners until the force of the disbelievers has been crushed..." to the end of the verse:" so eat ye the spoils of war, (it is) lawful and pure. So Allah made booty lawful for them."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4361]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4361

It has been narrated on the authority of Abu Huraira who said: The Messenger of Allah (may peace be upon him) sent some horsemen to Najd. They captured a man. He was from the tribe of Banu Hanifa and was called Thumama b. Uthal. He was the chief of the people of Yamama. People bound him with one of the pillars of the mosque. The Messenger of Allah (may peace be upon him) came out to (see) him. He said: O Thumama, what do you think? He replied: Muhammad, I have good opinion of you. If you kill me, you will kill a person who has spilt blood. If you do me a favour, you will do a favour to a grateful person. If you want wealth, ask and you will get what you will demand. The Messenger of Allah (may peace be pon him) lefthim (in this condition) for two days, (and came to him again) and said: What do you think, O Thumama? He replied: What I have already told you. If you do a favour, you will do a favour to a grateful person. If you kill me, you will kill a person who has spilt blood. If you want wealth, ask and you will get what you will demand. The Messenger of Allah (may peace be upon him) left him until the next day when he (came to him again) and said: What do you think, O Thumama? He replied: What I have already told you. If you do me a favour, you will do a favour to a grateful person. If you kill me, you will kill a person who has spilt blood. If you want wealth ask and you will get what you will demand. The Messenger of Allah (may peace be upon him) said: Set Thumama free. He went to a palm-grove near the mosque and took a bath. Then he entered the mosque and said: I bear testimony (to the truth) that there is no god but Allah and I testify that Muhammad is His bondman and His messenger. O Muhammad, by Allah, there was no face on the earth more hateful to me than your face, but (now) your face has become to me the dearest of all faces. By Allah, there was no religion more hateful to me than your religion, but (now) your religion has become the dearest of all religions to me. By Allah, there was no city more hateful to me than your city, but (now) your city has become the dearest of all cities to me. Your horsemen captured me when I intended going for Umra. Now what is your opinion (in the matter)? The Messenger of Allah (may peace be upon him) announced good tidings to him and told him to go on 'Umra. When he reached Mecca, somebody said to him: Have you changed your religion? He said: No! I have rather embraced Islam with the Messenger of Allah (may peace be upon him). By Allah, you will not get a single grain of wheat from Yamama until it is permitted by the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4362]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4362

The same tradition has been narrated by a different chain of transmitters with a slight difference in the wording.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4363]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4363

It has been narrated on the authority of Abu Huraira who said: We were (sitting) in the mosque when the Messenger of Allah (may peace be upon him) came to us and said: (Let us) go to the Jews. We went out with him until we came to them. The Messenger of Allah (may peace be upon him) stood up and called out to them (saying): O ye assembly of Jews, accept Islam (and) you will be safe. They said: Abu'l-Qasim, you have communicated (God's Message to us). The Messenger of Allah (may peace be upon him) said: I want this (i. e. you should admit that God's Message has been communicated to you), accept Islam and you would be safe. They said: Abu'l-Qisim, you have communicated (Allah's Message). The Messenger of Allah (may peace be upon him) said: I want this... - He said to them (the same words) the third time (and on getting the same reply) he added: You should know that the earth belongs to Allah and His Apostle, and I wish that I should expel you from this land Those of you who have any property with them should sell it, otherwise they should know that the earth belongs to Allah and His Apostle (and they may have to go away leaving everything behind).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4364]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4364

It has been narrated on the authority of Ibn Umar that the Jews of Banu Nadir and Banu Quraizi fought against the Messenger of Allah (may peace be upon him) who expelled Banu Nadir, and allowed Quraiza to stay on, and granted favour to them until they too fought against him Then he killed their men, and distributed their women, children and properties among the Muslims, except that some of them had joined the Messenger of Allah (may peace be upon him) who granted them security. They embraced Islam. The Messenger of Allah (may peace be upon him) turned out all the Jews of Medlina. Banu Qainuqa' (the tribe of 'Abdullah b. Salim) and the Jews of Banu Haritha and every other Jew who was in Medina.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4365]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4365

A similar hadith has been transmitted by a different chain of narrators, but the hadith narrated by Ibn Juraij is more detailed and complete.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4366]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4366

It has been narrated by 'Umar b. al-Khattib that he heard the Messenger of Allah (may peace be upon him) say: I will expel the Jews and Christians from the Arabian Peninsula and will not leave any but Muslim.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4367]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4367

This hadith has been narrated on the authority of Zubair with the same chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4368]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4368

It has been narrated on the authority of Abu Sa'id al-Khudri who said: The people of Quraiza surrendered accepting the decision of Sa'd b. Mu'adh about them. Accordingly, the Messenger of Allah (may peace be upon him) sent for Sa'd who came to him riding a donkey. When he approached the mosque, the Messenger of Allah (may peace be upon him) said to the Ansar: Stand up to receive your chieftain. Then he said (to Sa'd): These people have surrendered accepting your decision. He (Sa'd) said: You will kill their fighters and capture their women and children. (Hearing this), the Propbot (may peace he tpon him) said: You have adjudged by the command of God. The narrator is reported to have said: Perhaps he said: You have adjuged by the decision of a king.

Ibn Muthanna (in his version of the tradition) has not mentioned the alternative words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4369]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4369

Through the same chain of transmitters Shu'ba has narrated the same tradition in which he says that the Messenger of Allah (may peace be upon him) said (to Sa'd): You have adjudged according to the command of God. And once he said: you have adjudged by the decision of a king.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4370]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4370

It has been narrated on the authority of A'isha who said: Sa'd was wounded on the day of the Battle of the Ditch. A man from the Quraish called Ibn al-Ariqah shot at him an arrow which pierced the artery in the middle of his forearm. The Messenger of Allah (may peacce be upon him) pitched a tent for him in the mosque and would inquire after him being in close proximity. When he returned from the Ditch and laid down his arms and took a bath, the angel Gabriel appeared to him and he was removing dust from his hair (as if he had just returned from the battle). The latter said: You have laid down arms. By God, we haven't (yet) laid them down. So march against them. The Messenger of Allah (may peace be upon him) asked: Where? He poirftad to Banu Quraiza. So the Messenger of Allah (may peace he upon him) fought against them. They surrendered at the command of the Messenger of Allah (may peace be upon him), but he referred the decision about them to Sa'd who said: I decide about them that those of them who can fight be killed, their women and children taken prisoners and their properties distributed (among the Muslims).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4371]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4371

It has been narrated on the authority of Hisham (who learnt it from his father) that the Messenger of Allah (may peace be upon him) said (to Sa'd): You have adjudged their case with the judgment of God. the Exalted and Glorified.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4372]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4372

It has been narrated on the authority of 'A'isha that Sa'd's wound became dry and was going to heal when he prayed: O God, surely Thou knowest that nothing is dearer to me than that I should fight for Thy cause against the people who disbeliever Your Messenger (may peace be upon him) and turned him out (from his native place). If anything yet remains to be decided from the war against the Quraish, spare my life so that I may fight against them in Thy cause. O Lord, I think Thou hast ended the war between us and them. If Thou hast done so, open my wound (so that it may discharge) and cause my death thereby. So the wound begin to bleed from the front part of his neck. The people were not scared except when the blood flowed towards them, and in the mosque along with Sa'd's tent was the tent of Banu Ghifar. They said: O people of the tent, what is it that is coming to us from you? Lo! it was Sa'd's wound that was bleeding and he died thereof.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4373]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4373

This tradition has been narrated by Hishim through the same chain of transmitters with a little difference in the wording. He said: (His wound) began to bleed that very night and it continued to bleed until he died. He has made the addition that it was then that (a non-believing) poet said:

Hark, O Sa'd, Sa'd of Banu Mu'adh,

What have the Quraiaa and Nadir done?

By thy life! Sa'd b. Mu'adh>br> Was steadfast on the morn they departed.

You have left your cooking-pot empty,

While the cooking-pot of the people is hot and boiling.

Abu Hubab the nobleman has said,

O Qainuqa', do not depart.

They were weighty in their country

just aa rocks are weighty in Maitan.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4374]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4374

It has been narrated on the authority of Abdullah who said: On the day he returned from the Battle of Ahzab, the Messenger of Allah (may peace be upon him) made for us an announcement that nobody would say his Zuhr prayer but in the quarters of Banu Quraiza (Some) people, being afraid that the time for prayer would expire, said their prayers before reaching the street of Banu Quraiza. The others said: We will not say our prayer except where the Messenger of Allah (may peace be upon him) has ordered us to say it even if the time expires. (When he learned of the difference in the view of the two groups of the people, the Messenger of Allah (may peace be tipon him) did not blame anyone from the two groups.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4375]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4375

It has been narrated on the authority of Anas b. Malik who said: When the Muhajirs migrated from Mecca to Medina; they came (in a state that) they had not anything (i. e. money) in theirhands, while the Ansar possessed lands and date palms. They divided their properties with the Muhajirs. The Ansar divided and gave them on the condition that they would give half the fruit from the orchards every year, and the Muhajirs would recompense them by working with them and putting in labour. The mother of Anas b. Malik was called Umm Sulaim and she was also the mother of 'Abdullah b. Talha who was a brother of Anas from his mother's side. The mother of Anas had given the Messenger of Allah (may peace be upon him) her date-palms. He bestowed them upon Umm Aiman, the slave-girl who had been freed by him and was the mother of Usama b. Zaid. When the Messenger of Allah (may peace be upon him) had finished the war with the people of Khaibar and returned to Medina, the Muhajirs returned to the Ansar all the gifts which they had given them out of the fruits. (Anas b. Malik said: ) The Messenger of. Allah (may peace be upon him) returned to my mother her date-palms and gave to Umm Aiman instead of them date-palms from his orchard. Ibn Shihab says that Umm Aiman was the mother of Usama b. Zaid who was the slave-girl of 'Abdullah b. 'Abd-ul-Muttalib and hailed from Abyssinia. When Amina gave birth to the Messenger of Allah (may peace be upon him) after the death of his father, Umm Aiman used to nurse him until he grew up. He (later on) freed her and married her to Zaid b. Haritha. She died five months after the death of the Messenger of Allah (may peace be upon him).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4376]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4376

It has been narrated by Anas that (after his migration to Medina) a person placed at the Prophet's (may peace be upon him) disposal some date-palms growing on his land until the lands of Quraiza and Nadir were conquered. Then he began to return to him whatever he had received. (In this connection) my people told me to approach the Messenger of Allah (may peace be upon him) and ask from him what his people had given him or a portion thereof, but the Messenger of Allah (may peace be upon him) had bestowed those trees upon Umm Aiman. So I came to the Prophet (may peace be upon him) and he gave hem (back) to me. Umm Aiman (also) came (at this time). She put the cloth round my neck and said: No, by Allah, we will not give to, you what he has granted to me. The Holy Prophet (may peace be upon him) said: Umm Aiman, let him have them and for you are such and such trees instead. But she said: By Allah, there is no god besides Him. No, never! The Holy Prophet (may peace be upon him) continued saying: (You will get) such and such. until he had granted her ten times or nearly ten times more (than the original gift).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4377]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4377

It has been narrated on the authority of Abdullah b. Mughaffal who said I found a bag containing fat on the day of the Battle of Khaibar. I caught hold of it and said: I will not give anything today from it to anybody. Then I turned round and saw that the Messenger of Allah (may peace be upon him) was smiling (at my words).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4378]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4378

This tradition has been transmitted by a different chain of narrators with a different wording, the last in the chain being the same narrator, (i. e. 'Abdullah b. Mughaffal), who said: A bag containing food and fat was thrown to us. I lept forward to catch it. Then I turned round and saw (to my surprise) the Messenger of Allah (may peace be upon him) and I felt ashamed of my act in his presence.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4379]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4379

This hadith has been transmitted on the authority of Shu'ba with a slight variation of words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4380]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4380

It has been narrated on the authority of Ibn Abbas who learnt the tradition personally from Abu Safyan. The latter said: I went out (on a mercantile venture) during the period (of truce) between me and the Messenger of Allah (may peace be upon him). While I was in Syria, the letter of the Messenger of Allah (may peace be upon him) was handed over to Hiraql (Ceasar), the Emperor of Rome (who was on a visit to Jerusalem at that time). The letter was brought by Dihya Kalbi who delivered it to the governor of Busra The governor passed it on to Hiraql, (On receiving the letter), he said: Is there anyone from the people of this man who thinks that he is a prophet. People said: Yes. So, I was called along with a few others from the Quraish. We were admitted to Hiraql and he seated usbefore him. He asked: Which of you has closer kinship with the man who thinks that he is a prophet? Abu Sufyan said: I. So they seated me in front of him and stated my companions behind me. Then, he called his interpreter and said to him: Tell them that I am going to ask this fellow (i. e. Abu Sufyan) about the man who thinks that he is a prophet. It he tells me a lie, then refute him.

Abu Sufyan told (the narrator): By God, if there was not the fear that falsehood would be imputed to me I would have lied. (Then) Hiraqi said to his interpreter: Inquire from him about his ancestry, I said: He is of good ancestry among us. He asked: Has there been a king among his ancestors? I said: No. He asked: Did you accuse him of falsehood before he proclaimed his prophethood? I said: No. He asked: Who are his follower people of high status or low status? I said: (They are) of low status. He asked: Are they increasing in number or decreasing? I said. No. they are rather increasing. He asked: Does anyone give up his religion, being dissatisfied with it, after having embraced it? I said: No. He asked: Have you been at war with him? I said: Yes. He asked: How did you fare in that war? I said: The war between us and him has been wavering like a bucket, up at one turn and down at the other (i. e. the victory has been shared between us and him by turns). Sometimes he suffered loss at our hands and sometimes we suffered loss at his (hand). He asked: Has he (ever) violated his covenant? I said: No. but we have recently concluded a peace treaty with him for a petiod and we do not know what he is going to do about it. (Abu Sufyin said on oath that he could not interpolate in this dialogue anything from himself more than these words ) He asked: Did anyone make the proclamation (Of prophethood) before him? I said: No. He (now) said to his interpreter: Tell him, I asked him about his ancestry and he had replied that he had the best ancestry. This is the case with Prophets; they are the descendants of the noblest among their people (Addressing Abu Sufyan), he continued: I asked you if there had been a king among his ancestors. You said that there had been none. If there had been a king among his ancestors, I would have said that he was a man demanding his ancestral kingdom. I asked you about his followers whether they were people of high or low status, and you said that they were of rather low status. Such are the followers of the Prophets. I asked you whether you used to accuse him of falsehood before he proclaimed his prophethood, and you said that you did not.

So I have understood that when he did not allow himself to tell a lie about the poeple, he would never go to the length of forging a falsehood about Allah. I asked you whether anyone renounced his religion being dissatisfied with it after he had embraced it, and you replied in the negative. Faith is like this when it enters the depth of the heart (it perpetuates them). I asked you whether his followers were increasing or decreasing. You said they were increasing. Faith is like this until it reaches its consummation. I asked you whether you had been at war with him, and you replied that you had been and that the victory between you and him had been shared by turns, sometimes he suffering loss at your hand and sometimes you suffering lost at his. This is how the Prophets are tried before the final victory its theirs. I asked you whether he (ever) violated his covenant, and you said that he did not. This is how the Prophets behave. They never violate (their covenants). I asked you whether anyone before him had proclaimed the same thing, and you replied in the negative. I said: If anyone had made the same proclamation before, I would have thought that he was a man following what had been proclaimed before. (Then) he asked: What does he enjoin upon you? I said: He exhorts us to offer Salat, to pay Zakat, to show due regard to kinship and to practise chastity. He said: It what you have told about him is true, he is certainly a Prophet. I knew that he was to appear but I did not think that he would be from among you. If I knew that I would be able to reach him. I would love to meet him; and it I had been with him. I would have washed his feet (out of reverence). His dominion would certainly extend to this place which is under my feet. Then he called for the letter of the Messenger of Allah (may pface be upon him) and read it. The letter ran as follows:" In the name of Allah, Most Gracious and Most Merciful. From Muhammad, the Messenger of Allah, to Hiraql, the Emperor of the Romans. Peace be upon him who follows the guidance. After this, I extend to you the invitation to accept Islam. Embrace Islam and you will be safe. Accept Islam, God will give you double the reward. And if you turn away, upon you will be the sin of your subjects." O People of the Book, come to the word that is common between us that we should worship none other than Allah, should not ascribe any partner to Him and some of us should not take their fellows as Lords other than Allah. If they turn away, you should say that we testify to our being Muslims [iii. 64]."

When he hid finished the reading of the letter, noise and confused clamour was raise around him, and he ordered us to leave. Accordingly, we left. (Addressing my companions) while we were coming out (of the place). I said: Ibn Abu Kabsha (referring sarcastically to the Holy Prophet) has come to wield a great power. Lo! (even) the king of the Romans is afraid of him. I continued to believe that the authority of the Messenger of Allah (may peace be upon him) would triumph until God imbued me with (the spirit of) Islam.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4381]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4381

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with the addition:" When Allah inflicted defeat on the armies of Persia, Caesar moved from Hims to Aelia (Bait al-Maqdis) for thanking Allah as He granted him victory." In this hadith these words occur:" From Muhammad, servant of Allah and His Messenger," and said:" The sin of your followers," and also said the words:" to the call of Islam".


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4382]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4382

It has been narrated on the authority of Anas that the Prophet of Allah (may peace be upon him) wrote to Chosroes (King of Persia), Caesar (Emperor of Rome), Negus (King of Abyssinia) and every (other) despot inviting them to Allah, the Exalted. And this Negus was not the one for whom the Messenger of Allah (may peace be upon him) had said the funeral prayers.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4383]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4383

The tradition has been narrated on the authority of Anas b. Malik (the same narrator) through a different chain of transmitters, but this version does not mention:" And he was not the Negus for whom the Prophet (may peace be upon him) had said the funeral prayers."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4384]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4384

It has been narrated on the authority of the same narrator through another chain of transmitters with the same difference in the wording.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4385]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4385

It has been narrated on the authority of 'Abbas who said: I was in the company of the Messenger of Allah (may peace be upon him) on the Day of Hunain. I and Abd Sufyan b. Harith b. 'Abd al-Muttalib stuck to the Messenaer of Allah (may peace be upon him) and we did not separate from him. And the Messenger of Allah (may place be upon him) was riding on his white mule which had been presented to him by Farwa b. Nufitha al-Judhami. When the Muslims had an encounter with the disbelievers, the Muslims fled, falling back, but the Messenger of Allah (may peace be upon him) began to spur his mule towards the disbelievers. I was holding the bridle of the mule of the Messenger of Allah (may peace be upon him) checking it from going very fast, and Abu Sufyan was holding the stirrup of the (mule of the) Messenger of Allah (may peace be upon him), who said: Abbas, call out to the people of al-Samura. Abbas (who was a man with a loud voice) called out at the top of the voice: Where are the people of Samura? (Abbas said: ) And by God, when they heard my voice, they came back (to us) as cows come back to their calves, and said: We are present, we are present! 'Abbas said: They began to fight the infidels. Then there was a call to The Ansar. Those (who called out to them) shouted: O ye party of the Ansar! O party of the Ansar! Banu al-Harith b. al-Khazraj were the last to be called. Those (who called out to them) shouted: O Banu Al-Harith b. al-Khazraj! O BanU Harith b. al-Khazraj! And the Messenger of Allah (may peace be upon him) who was riding on his mule looked at their fight with his neck stretched forward and he said: This is the time when the fight is raging hot. Then the Messenger of Allah (may peace be upon him) took (some) pebbles and threw them in the face of the infidels. Then he said: By the Lord of Muhammad, the infidels are defeated. 'Abbas said: I went round and saw that the battle was in the same condition in which I had seen it. By Allah, it remained in the same condition until he threw the pebbles. I continued to watch until I found that their force had been spent out and they began to retreat.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4386]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4386

A version of the tradition has been transmitted through another chain of narrators. In this version the words uttered by the Holy Prophet (may peace be upon him) (after he had thrown the pebbles in the face of the enemy) are reported as:" By the Lord of the Ka'ba, they have been defeated." And there is at the end the addition of the words:" Until Allah defeated them" (and I imagine) as if I saw the Prophet of Allah (may peace be upon him) chasing them on his mule.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4387]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4387

'Abbas reported: I was with Allah's Apostle (may peace be upon him) on the Day of Hunain. The rest of the hadith is the same but with this variation that the hadith transmitted by Yonus and Ma'mar is more detailed and complete.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4388]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4388

It has been narratedon the authority of Abu Ishaq who said: A man asked Bara' (b. 'Azib): Did you run away on the Day of Hunain. O, Abu Umira? He said: No, by Allah, The Messenger of Allah (may peace be upon him) did not turn his back; (what actually happened was that) some young men from among his companions, who were hasty and who were either without any arms or did not have abundant arms, advanced and met a party of archers (who were so good shots) that their arrows never missed the mark. This party (of archers) belonged to Banu Hawazin and Banu Nadir. They shot at the advancing young men and their arrows were not likely to miss their targets. So these young men turned to the Messenger of Allah (may peace be upon him) while he was riding on his white mule and Abu Sufyan b. al-Harith b. 'Abd al-Muttalib was leading him. (At this) he got down from his mule, invoked God's help, and called out: I am the Prophet. This is no untruth. I am the son of 'Abd al-Muttalib. Then he deplnved his men into battle array.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4389]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4389

It has been narrated (through a different chain of transmitters) by Abu Ishiq that a person said to Bara' (b. 'Azib): Abu Umara, did you flee on the Day of Hunain? He replied: The Messenger of Allah (may peace be upon him) did not retreat. (What actually happened was that some hasty young men who were either inadequately armed or were unarmed met a group of men from Banu Hawazin and Banu Nadir who happened to be (excellent) archers. The latter shot at them a volley of arrows that did not miss. The people turned to the Messenger of Allah (may peace be upon him). Abu Sufyan b. Harith was leading his mule. So he got down, prayed and invoked God's help. He said: I am the Prophet. This is no untruth. I am the son of Abd al-Muttalib. O God, descend Thy help. Bara' continued: When the battle grew fierce. we, by God. would seek protection by his side, and the bravest among us was he who confronted the onslaught and it was the Holy Prophet (may peace be upon him).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4390]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4390

It has been narrated through a still different chain of transmitters by the same narrator (i. e. Abu Ishaq) who said: I heard from Bara' who was asked by a man from the Qais tribe: Did you run away from the Messenger of Allah (may peace be upon him) on the Day of Hunain? Bara' said: But the Messenger of Allah (may peace be upon him) did not run away. On that day Banu Hawzzin took part in the battle as archers (on the side of the disbelievers). When we attacked them, they retreated and we fell upon the booty; (they rallied) and advanced towards us with arrows. (At that time) I saw the Messenger of Allah (may peace be upon him) riding on his white mule and Abu Sufyan b. al-Harith was holding its bridle. He (the Messenger of Allah was saying: I am the Prophet. This is no untruth. I am a descendant of 'Abd al-Muttalib.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4391]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4391

This hadith has been narrated on the authority of Bara' with another chain of transmitters, but this hadith is short as compared with other ahadith which are more detailed.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4392]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4392

This tradition has been narrated on the authority of Salama who said: We fought by the side of the Messenger of Allah (may peace be upon him) at Hunain. When we encountered the enemy, I advanced and ascended a hillock. A man from the enemy side turned towards me and I shot him with an arrow. He (ducked and) hid himself from me. I could not understand what he did, but (all of a sudden) I saw that a group of people appeared from the other hillock. They and the Companions of the Prophet (may peace be upon him) met in combat, but the Companions of the Prophet turned back and I too turned back defeated. I had two mantles, one of which I was wrapping round the waist (covering the lower part of my body) and the other I was putting around my shoulders. My waist-wrapper got loose and I held the two mantles together. (In this downcast condition) I passed by the Messenger of Allah (may peace be upon him) who was riding on his white mule. He said: The son of Akwa' finds himself to be utterly perplexed. Wher. the Companions gathered round him from all sides. the Messenger of Allah (may peace be upon him) got down from his mule. picked up a handful of dust from the ground, threw it into their (enemy) faces and said: May these faces be deformed 1 There was no one among the enemy whose eyes were not filled with the dust from this handful. So they turned back fleeing. and Allah the Exalted and Glorious defeated them, and the Messenger of Allah (may peace be upon him) distributed their booty among the Muslims.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4393]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4393

It has been narrated on the authority of Ibn 'Amr who said: The Messenger of Allah (may peace be upon him) besieged the people of Ta'if, but did get victory over them. He said: God willing, we shall return. His Companions said: Shall we depart without having conquered it? The Messenger of Allah (may peace be upon him) said: (All right) make a raid in the morning. They did so. and were wounded (with the arrows showered upon them). So the Messenger of Allah (may peace be upon him) said: We shall depart tomorrow. (The narrator says): (Now) this (announcement) pleased them, and the Messenger of Allah (may peace be upon him) laughed at (their waywardness).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4394]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4394

It has been narrated on the authority of Anas that when (the news of) the advance of Abu Sufyan (at the head of a force) reached him. the Messenger of Allah (may peace be upon him) held consultations with his Companions. The narrator said: Abu Bakr spoke (expressing his own views), but he (the Holy Prophet) did not pay heed to him. Then spoke 'Umar (expressing his views), but he (the Holy Prophet) did not pay heed to him (too). Then Sa'd b. 'Ubada stood up and said: Messenger of Allah, you want us (to speak). By God in Whose control is my life, if you order us to plunge our horses into the sea, we would do so. If you order us to goad our horses to the most distant place like Bark al-Ghimad, we would do so. The narrator said: Now the Messenger of Allah (may peace be upon him) called upon the people (for the encounter). So they set out and encamped at Badr. (Soon) the water-carriers of the Quraish arrived. Among them was a black slave belonging to Banu al-Hajjaj. The Companions of the Messenger of Allah (may peace be upon him) caught him and interrogated him about Abu Sufyan and his companions. He said: I know nothing about Abu Sufyan, but Abu Jahl, Utba, Shaiba and Umayya b. Khalaf are there. When he said this, they beat him. Then he said: All right, I will tell you about Abu Sufyan. They would stop beating him and then ask him (again) about Abu Sufyan. He would again say', I know nothing about Abu Sufyan, but Abu Jahl. 'Utba, Shaiba and Umayya b. Khalaf are there. When he said this, they beat him likewise. The Messenger of Allah (may peace be upon him) was standing in prayer. When he saw this he finished his prayer and said: By Allah in Whose control is my life, you beat him when he is telling you the truth, and you let him go when he tells you a lie. The narrator said: Then the Messenger of Allah (may peace be upon him) said: This is the place where so and so would be killed. He placed his hand on the earth (saying) here and here; (and) none of them fell away from the place which the Messenger of Allah (may peace be upon him) had indicated by placing his hand on the earth.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4395]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4395

It has been narrated by 'Abdullah b. Rabah from Abu Huraira, who said: Many deputations came to Mu'awiya. This was in the month of Ramadan. We would prepare food for one another. Abu Huraira was one of those who frequently invited us to his house. I said: Should I not prepare food and invite them to my place? So I ordered meals to be prepared Then I met Abu Huraira in the evening and said: (You will have) your meals with me tonight. He said: You have forestalled me. I said: Yes, and invited them. (When they had finished with the meals) Abu Huraira said: Should I not tell yon a tradition from your traditions, O ye assembly of the Ansar? He then gave an account of the Conquest of Mecca and said: The Messenger of Allah (may peace be upon him) advanced until he reached Mecca. He deputed Zubair on his right flank and Khalid on the left, and he despatched Abu Ubaida with the force that had no armour. They advanced to the interior of the valley. The Messenger of Allah (may peace be upon him) was in the midst of a large contingent of fighters. He saw me and said: Abu Huraira. I said: I am here at your call, Messenger of Allah I He said: Let no one come to me except the Ansar, so call to me the Ansar (only). Abu Huraira continued: So they gathered round him. The Quraish also gathered their ruffians and their (lowly) followers, and said: We send these forward. If they get anything, we shall be with them (to share it), and if misfortune befalls them, we shall pay (as compensation) whatever we are asked for. The Messenger of Allah (may peace be upon him) said (to the Ansar): You see the ruffians and the (lowly) followers of the Quraish. And he indicated by (striking) one of his hands over the other that they should be killed and said: Meet me at as-Safa. Then we went on (and) if any one of us wanted that a certain person should be killed, he was killed, and none could offer any resistance. Abu Huraira continued: Then came Abu Sufyan and said: Messenger of Allah, the blood of the Quraish has become very cheap. There will be no Quraish from this day on.

Then he (the Holy Prophet) said: Who enters the house of Abu Sufyan, he will be safe. Some of the Ansar whispered among themselves: (After all), love for his city and tenderness towards his relations have overpowered him. Abu Huraira said: (At this moment) revelation came to the Holy Prophet (may peace be upon him) and when he was going to receive the Revelation, we understood it, and when he was (actually) receiving it, none of us would dare raise his eyes to the Messenger of Allah (may peace be upon him) until the revelation came to an end. When the revelation came to an end, the Messenger of Allah (may peace be upon him) said: O ye Assembly of the Ansar! They said: Here we are at your disposal, Messenger of Allah. He said: You were saying that love for his city and tenderness towards his people have overpowered this man. They said: So it was. He said: No, never. I am a bondman of God and His Messenger. I migrated towards God and towards you. I will live with you and will die with you. So, they (the Ansar) turned towards him in tears and they were saying: By Allah, we said what we said because of our tenacious attachment to Allah and His Messenger. The Messenger of Allah (may peace be upon him) said: Surely, Allah and His Messenger testify to your assertions and accept your apology. The narrator continued: People turned to the house of Abu Sufyan and people locked their doors. The Messenger of Allah (may peace be upon him) proceeded until he approached the (Black) Stone. He kissed it and circumambulated the Ka'ba. He reached near an idol by the side of the Ka'ba which was worshipped by the people. The Messenger of Allah (may peace be upon him) had a bow in his hand, and he was holding it from a corner. When he came near the idol, he began to pierce its eyes with the bow and (while doing so) was saying: Truth has been established and falsehood has perished. When he had finished the circumambulation, he came to Safa', ascended it to a height from where he could see the Ka'ba, raised his hands (in prayer) and began to praise Allah and prayed what he wanted to pray.

The tradition has been narrated by a different chain of transmitters with the following additions: (i) Then be (the Messenger of Allah) said with his hands one upon the other: Kill them (who stand in your way).... (ii) They (the Ansar) replied: We said so, Messenger of Allah! He said: What is my name? I am but Allah's bondman and His Messenger.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4396]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4396

It has been narrated on the authority of Abdullah b. Rabah who said: We came to Mu'awiya b. Abu Sufyan as a deputation and Abu Huraira was among us. Each of us would prepare food for his companions turn by turn for a day. (Accordingly) when it was my turn I said: Abu Huraira, it is my turn today. So they came to my place. The food was not yet ready, so I said to Abu Huraira: I wish you could narrate to us a tradition from the Messenger of Allah (may peace be upon him) until the food was ready. (Complying with my request) Abu Huraira said: We were with the Messenger of Allah (may peace be upon him) on the day of the Conquest of Mecca. He appointed Khalid b. Walid as commander of the right flank, Zubair as commander of the left flank, and Abu 'Ubaida as commander of the foot-soldiers (who were to advance) to the interior of the valley. He (then) said: Abu Huraira, call the Ansar to me. So I called out to them and they came hurriedly. He said: O ye Assembly of the Ansaar, do you see the ruffians of the Quraish? They said: Yes. He said: See, when you meet them tomorrow, wipe them out. He hinted at this with his hand, placing his right hand on his left and said: You will meet us at as-Safa'. (Abu Huraira continued): Whoever was seen by them that day was put to death. The Messenger of Allah (may peace be upon him) ascended the mount of as-Safa'. The Ansar also came there and surrounded the mount. Then came Abu Sufyan and said: Messenger ot Allah, the Quraish have perished. No member of the Quraish tribe will survive this day. The Messenger of Allah (may peace be upon him) said: Who enters the house of Abu Safyin will be safe, who lays down arms will be safe, who locks his door will be safe. (some of) the Ansar said: (After all) the man has been swayed by tenderness towards his family and love for his city. At this, Divine inspiration descended upon the Messenger of Allah (may peace be upon him). He said: You were saying that the man has been swayed by tenderness towards his family and love for his city. Do you know what my name is? I am Muhammad, the bondman of God and His Messenger. (He repeated this thrice.) I left my native place for the take of Allah and joined you. So I will live with you and die with you. Now the Ansar said: By God, we said (that) only out of our greed for Allah and His Messenger. He said: Allah and His Apostle testify to you and accept your apology.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4397]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4397

It has been narrated by Ibn Abdullah who said: The Holy Prophet (may peace be upon him) entered Mecca. There were three hundred and sixty idols around the Ka'ba. He began to thrust them with the stick that was in his hand saying:" Truth has come and falsehood has vanished. Lo! falsehood was destined to vanish" (xvii. 8). Truth has arrived, and falsehood can neither create anything from the beginning nor can It restore to life


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4398]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4398

This tradition has been narrated by Ibn Abu Najah through a different chain of transmitters up to the word: Zahaqa, (This version) does not contain the second verse and substitutes Sanam for Nusub (both the words mean" idol" or" image" that is worshipped).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4399]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4399

It has been narrated on the authority of Abdullah b. Muti' who heard from his father and said: I heard the Holy Prophet (may peace be upon him) say on the day of the Conquest of Mecca: No Quraishite will be killed hound hand and foot from this day until the Day of judgment.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4400]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4400

The same tradition has been narrated on the authority of Zakriyya through the same chain of transmitters with the following addition:" No rebellious Quraishite with al-Asi as his name embraced Islam that day except Muti. His name-was al-Asi, but the Messenger of Allah (way peace be upon him) changed his name to Muti.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4401]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4401

It has been narrated on the authority of al-Bara' b. 'Azib who said: 'Ali b. Abu Talib penned the treaty between the Holy Prophet (may peace be upon him) and the polytheists on the Day of Hudaibiya. He wrote: This is what Muhammad, the Messenger of Allah, has settled. They (the polytheists) said: Do not write words" the Messenger of Allah". If we knew that you were the Messenger of Allah, we would not fight against you. The Prophet (may peace be upon him) said to 'Ali: Strike out these words. He (Ali) said: I am not going to strike them out. So the Prophet (may peace be upon him) struck them out with his own hand. The narrator said that the conditions upon which the two sides had agreed included that the Muslims would enter Mecca (next year) and would stay there for three days, and that they would not enter bearing arms except in their sheaths or bolsters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4402]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4402

It has been narrated on the authority of Abu Ishaq, who heard Bars' b. Azib say: When the Messenger of Allah (may peace be upon him) made peace with the people of Hudaibiya, 'Ali drew up the agreement between them, and so he wrote: Muhammad, the Messenger of Allah. (This is followed by the same wording as we have in the previous tradition except the omission of the words: This is what he has settled.)


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4403]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4403

It has been narrated on the authority of Bara' who said: When the Prophet (may peace be upon him) was checked from going to the Ka'ba, the people of Mecca made peace with him'on the condition that he would (be allowed to) enter Mecca (next year) and stay there for three days, that he would not enter (the city) except with swords in their sheaths and arms encased in their covers, that he would not take eway with him anyone from its dwellers, nor would he prevent anyone from those with him to stay on in Mecca (if he so desired). He said to 'Ali: Write down the terms settled between us. (So 'Ali wrote): In the name of Allah, most Gracious and most Merciful. This is what Muhammad, the Messenger of Allah, has settled (with the Meccans), The polytheists said to him: If we knew that thou art the Messenger of of Allah, we would follow you. But write: Muhammad b. 'Abdullah. So he told 'Ali to strike out these words. 'Ali said: No, by Allah, I will not strike them out. The Messenger of Allah (may Peace be upon him) said: Show me their place (on the parchment). So he ('Ali) showed him their place and he (the Holy Prophet) struck them out; and 'Ali wrote: Ibn 'Abdullah. (According to the terms of the treaty, next year) the Holy Prophet (may peace be upon him) stayed there for three days When it was the third day, they said to 'Ali: This is the last day according to the terms of your companion. So tell him to leave. 'Ali informed the Prophet (may peace be upon him) accordingly. He said: Yes, and left (the city). Ibn Janab in his version of the tradition used:" we would swear allegiance to you" instead of" we would follow you".


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4404]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4404

It has been narrated on the authority of Anas that the Quraish made peace with the Prophet (may peace be upon him). Among them was Suhail b. Amr. The Prophet (may peace be upon him) said to 'Ali: Write" In the name of Allah, most Gracious and most Merciful." Suhail said: As for" Bismillah," we do not know what is meant by" Bismillah-ir-Rahman-ir-Rahim" (In the name of Allah most Gracious and most Merciful). But write what we understand, i. e. Bi ismika allahumma (in thy name. O Allah). Then, the Prophet (may peace be upon him) said: Write:" From Muhammad, the Messenger of Allah." They said: If we knew that thou welt the Messenger of Allah, we would follow you. Therefore, write your name and the name of your father. So the Holy Prophet (may peace be upon him) said: Write" From Muhammad b. 'Abdullah." They laid the condition on the Prophet (may peace be upon him) that anyone who joined them from the Muslims, the Meccans would not return him, and anyone who joined you (the Muslims) from them, you would send him back to them. The Companions said: Messenger of Allah, should we write this? He said: Yes. One who goes away from us to join them-may Allah keep him away! and one who comes to join us from them (and is sent back) Allah will provide him relief and a way of escape.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4405]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4405

It has been narrated on the authority of Abu Wa'il who said: Sahal b. Hunaif stood up on the Day of Siffin and said: O ye people, blame yourselves (for want of discretion) ; we were with the Messenger of Allah (may peace be upon him) on the Day of Hudaibiya. If we had thought it fit to fight, we could fight. This was in the truce between the Messenger of Allah (may peace be upon him) and the polytheists. Umar b. Khattab came, approached the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, aren't we fighting for truth and they for falsehood? He replied: By all means. He asked: Are not those killed from our side in Paradise and those killed. from their side in the Fire? He replied: Yes. He said: Then why should we put a blot upon our religion and return, while Allah has not decided the issue between them and ourselves? He said: Son of Khattab, I am the Messenger of Allah. Allah will never ruin me. (The narrator said): Umar went away, but he could not contain himself with rage. So he approached Abu Bakr and said: 'Abu Bakr, aren't we fighting for truth and they for falsehood? He replied: Yes. He asked: Aren't those killed from our side in Paradise and those killed from their side in the Fire? He replied: Why not? He (then) said: Why should we then disgrace our religion and return while God has not yet decided the issue between them and ourselves? Abu Bakr said: Son of Khattab, verily, he is the Messenger of Allah, and Allah will never ruin him. (The narrator continued): At this (a Sura of) the Qur'an (giving glad tidings of the victory) was revealed to the Messenger of Allah (may peace be upon him). He sent for Umar and made him read it. He asked: Is (this truce) a victory? He (the Messenger of Allah) replied: Yes. At this Umar was pleased, and returned.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4406]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4406

It has been narrated on the authority of Shaqiq who said: I heard Sahl b. Hunaif say at Siffin: O ye people, find fault with your (own) discretion. By Allah, on the Day of Abu Jandal (i. e. the day of Hudaibiya), I thought to myself that, if I could, I would reverse the order of the Messenger of Allah (may peace be upon him) (the terms of the truce being unpalatable). By Allah, we have never hung our swords on our shoulders in any situation whatsoever except when they made easy for us to realise the goal envisaged by us, but this battle of yours (seems to be an exception). Ibn Numair (in his version) did not mention the words:" In any situatina whatsoever"


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4407]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4407

The same tradition has been narrated through a different chain of transmitters on the authority of A'mash. This version contains the words: Ila amrin yofzi'una instead of Ila amrin na'rifuhu.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4408]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4408

It has been narrated through a different chain of transmitters on the authority of Abu Wa'il who said: I heard Sahl b. Hunaif say at Siffin: Blame (the hollowness) of your views about your religion. I thought to myself on the day of Abu Jandal that if I could turn down the order of the Messenger of Allah (may peace be upon him), I would. The situation was so difficult that if we mended it at one place, it was rent at another.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4409]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4409

It has been narrated on the authority of Anas b. Malik who said: When they (Companions of the Holy Prophet) were overwhelmed with grief and distress on his return from Hudaibiya where he had slaughtered his sacrificial beasts (not being allowed to proceed to Mecca), the Qur'anic verse: Inna fatahna... laka fathan mobinan to fauzan 'aziman, was revealed to him. (At this) he said: On me has descended a verse that is dearer to me than the whole world.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4410]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4410

This tradition has been narrated through a different chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4411]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4411

It has been reported on the authority of Hudbaifa b. al-Yaman who said: Nothing prevented me from being present at! he Battle of Badr except this incident. I came out with my father Husail (to participate in the Battle), but we were caught by the disbelievers of Quraish. They said: (Do) you intend to go to Muhammad? We said: We do not intend to go to him, but we wish to go (back) to Medina. So they took from us a covenant in the name of God that we would turn back to Medina and would not fight on the side of Muhammad (may peace be upon him). So, we came to the Messenger of Allah (may peace be upon him) and related the incident to him. He said: Both, of you proceed (to Medina) ; we will fulfil the covenant made with them and seek God's help against them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4412]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4412

It has been narrated by Ibrahim al-Taimi on the authority of his father who said: We were sitting in the company of Hudhaifa. A man said: If I were in the time of the Messenger of Allah (may peace be upon him), I would have fought by his side and would have striven hard for his causes. Hudhaifa said: You might have done that, (but you should not make a flourish of your enthusiasm). I was with the Messenger of Allah (may peace be upon him) on the night of the Battle of Abzib and we were gripped by a violent wind and severe cold. The Messenger of Allah (may peace be him) said: Hark, the man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgment by Allah (the Glorious and Exalted). We all kept quiet and none of us responed to him. (Again) he said: Hark, a man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgment by Allah (the Glorious and Exalted). We kept quiet and none of us responded to him. He again said: Hark, a man who (goes reconnoitring and) brings me the news of the enemy shall be ranked with me on the Day of Judgtuent by Allah (the Glorious and Exalted) Then he said: Get up Hudhaifa, bring me the news of the enemy. When he called me by name I had no alternative but to get up. He said: Go and bring me information about the enemy, and do nothing that may provoke them against me. When I left him, I felt warm as if I were walking in a heated bath untill I reached them. I saw Abu Sufyan warming his back against fire I put an arrow in the middle of the bow. intending to shoot at him, when I recalled the words of the Messenger of Allah (may peace be upon him)" Do not provoke them against me." Had I shot at him, I would have hit him. But I returned and (felt warm as if) I were walking in a heated bath (hammam). Presenting myself before him, I gave him information about the enemy. When I had done so, I began to feel cold, so the Messenger of Allah (may peace be upon him) wrapped me in a blanket that he had in excess to his own requirement and with which he used to cover himself while saying his prayers. So I continued to sleep until it was morning. When it was morning he said: Get up, O heavy sleeper.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4413]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4413

It has been reported on the authority of Anas b. Malik that (when the enemy got the upper hand) on the day of the Battle of Uhud, the Messenger of Allah (may peace be upon him) was left with only seven men from the ansar and two men from the Quraish. When the enemy advanced towards him and overwhelmed him, he said: Whoso turns them away from us will attain Paradise or will be my Companion in Paradise. A man from the Ansar came forward and fought (the enemy) until he was killed. The enemy advanced and overwhelmed him again and he repeated the words: Whoso turns them away, from us will attain Paradise or will be my Companion in Paradise. A man from the Arsar came forward and fought until he was killed. This state continued until the seven Ansar were killed (one after the other). Now, the Messenger of Allah (may peace be upon him) said to his two Companions: We have not done justice to our Companions.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4414]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4414

It has been narrated on the authority of Abd-ul-'Aziz b. Abu Hazim, who learnt from his father (Abu Hazim). The latter heard it from Sahl b. Sa'd who was asked about the injury which the Messenger of Allah (may peace be upon him) got on the day of the Battle of Uhud. He said: The face of the Messenger of Allah (may peace be upon him) was injured, his front teeth were damaged and his helmet was crushed. Fatima, the daughter of the Messenger of Allah (may peace be upon him), was washing the blood (from his head), and 'Ali b. Abu Talib was pouring water on it from a shield. When Fatima saw that the bleeding had increased on account of (pouring) water (on the wound), she took a piece of mat and burnt it until it was reduced to ashes. She put the ashes on the wound and the bleeding stopped.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4415]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4415

It has been reported on the authority of Abu Hazim who heard from Sahl b. Sa'd. The latter was asked about the injury of the Messenger of Allah (may peace be upon him). He said: By God, I know the person who washed the wound of the Messenger of Allah (may peace be upon him), who poured water on it and with what the wound was treated. Then Sahl narrated the same tradition as has been narrated by 'Abd al-'Azlz except that he added the words:" And his face was injured" and replaced the word" Hushimat" by" Kusirat" (i. e. it was broken).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4416]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4416

The same tradition has been narrated on the authority of Sahl b. Sa'd through a different chain of transmitters with a slight difference in the wording.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4417]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4417

It has been narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) had his front teeth damaged on the day of the Battle of Uhud, and got a wound on his head. He was wiping the blood (from his face) and was saying: How will these people attain salvation who have wounded their Prophet and broken his tooth while he called them towards God? At this time, God, the Exalted and Glorious, revealed the Verse:" Thou hast no authority" (iii. 127).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4418]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4418

It has been narrated on the authority of 'Abdullah who said: It appeared to me as if I saw the Messenger of Allah (may peace be upon him) (and heard him) relate the story of a Prophet who had been beaten by his people, was wiping the blood from his face and was saying. My Lord, forgive my people, for they do not know.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4419]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4419

A version of the tradition with a slightly different wording has been narrated by another chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4420]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4420

It has been narrated by Hammam b. Munabbih who said: This is what has been related to us by Abu Huraira from the Messenger of Allah (may peace be upon him). (With this introduction) he narrated a number of traditions. One of these was that the Messenger of Allah (may peace be upon him) said: Great is the wrath of Allah upon a people who have done this to the Messenger of Allah (may peace be upon him), and he was at that time pointing to his front teeth. The Messenger of Allah (may peace be upon him) also said: Great is the wrath of Allah upon a person who has been killed by the Messenger of Allah (may peace be upon him) in the way of Allah, the Exalted and Glorious.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4421]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4421

It has been narrated on the authority of Ibn Mas'ud who said: While the Messenger of Allah (may peace be upon him) was saying his prayer near the Ka'ba and Abu Jahl with his companions was sitting (near by), Abu Jahl said, referring to the she-camel that had been slaughtered the previous day: Who will rise to fetch the foetus of the she-camel of so and so, and place it between the shoulders of Muhammad when he goes down in prostration (a posture in prayer). The one most accursed among the people got up, brought the foetus and, when the Prophet (may peace be upon him) went down in prostration, placed it between his shoulders. Then they laughed at him and some of them leaned upon the others with laughter. And I stood looking. If I had the power, I would have thrown it away from the back of the Messenger of Allah (may peace be upon him). The Prophet (may peace be upon him) had bent down his head in prostration and did not raise it, until a man went (to his house) and informed (his daughter) Fatima, who was a young girl (at that time) (about this ugly incident). She came and removed (the filthy thing) from him. Then she turned towards them rebuking them (the mischief-mongers). When the Prophet (may peace be upon him) had finished his prayer, he invoked God's imprecations upon them in a loud voice. When he prayed, he prayed thrice, and when he asked for God's blessings, he asked thrice. Then he said thrice: O Allah, it is for Thee to deal with the Quraish. When they heard his voice, laughter vanished from them and they feared his malediction. Then he said: O God, it is for Thee to deal with Abu Jahl b. Hisham, 'Utba b. Rabi'a, Shaiba b. Rabi'a. Walid b. Uqba, Umayya b. Khalaf, Uqba b. Abu Mu'ait (and he mentioned the name of the seventh person. which I did not remember). By One Who sent Muhammad with truth, I saw (all) those he had named lying slain on the Day of Badr. Their dead bodies were dragged to be thrown into a pit near the battlefield.

Abu Ishiq had said that the name of Walid b. 'Uqba has been wrongly mentioned in this tradition.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4422]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4422

It has been narrated by Abdullah (b. Mas'ud) who said: When the Messenger of Allah (may peace be upon him) was lying postrate in prayer and around him were some people from the Quraish, 'Uqba b. Abu Mu'ait brought the foetus of a she-camel and threw it on the back of the Messenger of Allah (may peace be upon him). He did not raise his head until Fatima arrived, removed it from his back and cured him who had done that (ugly act). He said: O Allah, it is for Thee to deal with the chiefs of the Quraish. Abu Jahl b. Hisham, 'Utba b. Rabi'a. Uqba b. Abu Mu'ait, Shaiba b. Rabi'a, Umayya b. Khalaf or Ubayy b. Khalaf (Shu'ba, one of the narrator of this tradition is in doubt about the exact person). I saw that all were slain in the Battle of Badr and their dead bodies were thrown into a well, except that of Umayya or Ubayy which was cut into pieces and was thrown into the well.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4423]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4423

Abu Ishiq has narrated a similar tradition through a different chain of transmitters and has added: He (the Messenger of Allah) loved to repeat the supplication thrice. He was saying: O Allah, it is for Thee to deal with the Quraish (repeating these words thrice). And among the Quraish, he mentioned (the names of) al-Walid b. 'Utba and Umayya b. Khalaf. (The narrator says there is no doubt about the names of these persons but he has forgotten the name of the seventh man).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4424]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4424

It has been narrated on the authority of 'Abdullah that, the Messenger of Allah (may peace be upon him) turned his face towards the Ka'ba and invoked God's imprecations upon six men of the Quraish, amorig whom were Abu Jahl. Umayya b. Khalaf, Utba b. Rabi'a, Shaiba b. Rabi'a and 'Uqba b. Abu Mu'ait I swear by God that I saw them lying slain in the battlefield of Badr. It being a hot day, their complexion had changed (showing signs of decay).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4425]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4425

It has been narrated on the authority of 'A'isha, the wife of the Prophet (may peace be upon him), who said to the Messenger of Allah (may peace he upon him): Messenger of Allah, has there come upon you a day more terrible than the day of Ubud. He said: I have experienced from thy people and the hardest treatment I met from them was what I received from them on the day of 'Aqaba. I betook myself to Ibn Abd Yalil b. Abd Kulal with the purpose of inviting him to Islam, but he did not respond to me as I desired. So I departed with signs of (deep) distress on my face. I did not recover until I reached Qarn al-Tha'alib. Where I raised my head, lo! near me was a cloud which had cast its shadow on me. I looked and lo! there was in it the angel Jibril who called out to me and said.: God. the Honoured and Glorious, has heard what thy people have said to thee, and how they have reacted to thy call. And He has sent to thee the angel in charge of the mountains so that thou mayest order him what thou wishest (him to do) with, regard to them. The angel in charge of the mountains (then) called out to me, greeted me and said: Muhammad, God has listened to what thy people have said to thee. I am the angel in charge of the mountains. and thy Lord has sent me to thee so that thou mayest order me what thou wishest. If thou wishest that I should bring together the two mountains that stand opposite to each other at the extremities of Mecca to crush them in between, (I would do that). But the Messenger of Allah (may peace he upon him) said to him: I rather hope that God will produce from their descendants such persons as will worship Allah, the One, and will not ascribe partners to Him.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4426]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4426

It has been narrated on the authority of Jundub b. Sufyan who said: A finger of the Messenger of Allah (may peace be upon him) was wounded in one of the encounters He said: Thou art just a little finger which has bled, and what thou hast experienced is in the cause of Allah.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4427]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4427

It has been narrated on the authority of Aswad b. Qais who said: The Messenger of Allah (may peace be upon him) was in a cave (or raid) when his finger was hurt.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4428]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4428

It has been narrated on the authority of Aswad b. Qais who heard Jundub saying that Gabriel delayed his visit to the Messenger of Allah (may peace be upon him) The polytheists began to say that Muhammad has been forsaken. At this Allah, the Glorious and Exalted, revealed:" Wa'dd hd wa'l-laili iza saja, ma wadda'ka Rabbuka wa' ma qala" [By the glorious morning light, and by the night when it is still: thy Lord has not forsaken thee, nor is He displeased].


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4429]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4429

It has been narrated on the authority of Aswad b. Qais who said: I heard Jundub b. Sufyan say: The Messenger of Allah (may peace be upon him) fell ill and did not wake up for two or three nights (for prayers) A woman came to him and said: Muhammad, I hope that your satan has left you. I haven't seen him approach you for two or three nights. The narrator says: At this, Allah, the Glorious and Exalted, revealed:" By the Glorious......"


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4430]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4430

This hadith has been narrated on the authority of Aswad b. Qais with the same chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4431]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4431

It has been narrated on the authority of Usama b. Zaid that the Prophet (may peace be upon him) rode a donkey. It had on it a saddle under which was a mattress made at Fadak (a place near Medina). Behind him he seated Usama. He was going to the street of Banu Harith al-Khazraj to inquire after the health of Sa'd b. Ubada This happened before the Battle of Badr. (He proceeded) until he passed by a mixed company of people in which were Muslims, polytheists, idol worshippers and the Jews and among them were 'Abdullah b. Ubayy and 'Abdullah b. Rawaha. When the dust raised by the hoofs of the animal spread over the company, 'Abdullah b. Ubayy covered his nose with his mantle and said: Do not scatter the dust over us (Not minding this remark), the Holy Prophet (may peace be upon him) greeted them, stopped, got down from his animal, invited them to Allah, and recited to them the Qur'an. 'Abdullah b. Ubayy said: O man, if what you say is the truth, the best thing for you would be not to bother us with it in our assemblies. Get back to your place. Whoso comes to you from us, tell him (all) this. Abdullah b. Rawaha said: Come to us in our gatherings, for we love (to hear) it. The narrator says: (At this), the Muslims, the polytheists and the Jews began to rebuke one another until they were determined to come to blows. The Holy Prophet (may peace be upon him) continued to pacify them. (When they were pacified), he rode his animal and came to Sa'd b. 'Ubida. He said: Sa'd, haven't you heard what Abu Hubab (meaning 'Abdullah b. Ubayy) has said? He has said so and so. Sa'd said: Messenger of Allah, forgive and pardon. God has granted you a sublime position, (but so far as he is concerned) the people of this settlement had-decided to make him their king by making him wear a crown and a turban (in token thereof), but God has circumvented this by the truth He has granted you. This has made him jealous and his jealousy (must have) prompted the behaviour that you have witnessed. So, the Holy Prophet (may peace upon him) forgave him.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4432]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4432

A similar tradition has been narrated through a different chain of transmitters by Ibn Shihab with the addition of the words:" Before Abdullah (b. Ubayy) became a Muslim."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4433]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4433

It has been narrated on the authority of Anas b. Malik that it was said to the Holy Prophet (may peace be upon him): Would that you approached Abdullah b. Ubayy (to persuade him to accept Islam). The Holy Prophet (may peace be upon him) (accordingly) went to him, riding a donkey, and (a party of) Muslims also went (with him). On the way they had to walk over a piece of land affected with salinity. When the Holy Prophet (may peace be upon him) approached him, he said: Do not come near me. By Allah, the obnoxious smell of your donkey has offended me. (As a rejoinder to this remark), a man from the Ansar said: By God, the smell of the donkey of the Messenger of Allah (may peace be upon him) is better than your smell. (At this), a man from the tribe of 'Abdullah got furious. Then people from both sides got furious and exchanged blows with sticks, hands and shoes. (The narrator says) that (after this scuffle) we learnt that (the Qur'anic verse):" It two parties of the Believers have a quarrel, make ye peace between them" (xlix. 9) was revealed about these fighting parties.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4434]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4434

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said (after the encounter at Badr): Who will ascertain for us what has happened to Abu Jahl? Ibn Mas'ud went (to gather this information). He found that the two sons of 'Afra' had struck him and he lay cold at the point of death. He caught him by his beard and said: Art thou Abu Jahl? He said: is there anybody superior to the person you have killed, or (he said) his people have killed him. Ibn Mas'ud says that, according to Abu Mijlaz, Abu Jahl said: Alas! a person other than a farmer would have killed me.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4435]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4435

A similar tradition has been transmitted by a different chain of narrators, on the same authority with a slight difference In the wording.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4436]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4436

It has been narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: Who will kill Ka'b b. Ashraf? He has maligned Allah, the Exalted, and His Messenger. Muhammad b. Maslama said: Messenger of Allah, do you wish that I should kill him? He said: Yes. He said: Permit me to talk (to him in the way I deem fit). He said: Talk (as you like). So, Muhammad b. Maslama came to Ka'b and talked to him, referred to the old friendship between them and said: This man (i. e. the Holy Prophet) has made up his mind to collect charity (from us) and this has put us to a great hardship. When be heard this, Ka'b said: By God, you will be put to more trouble by him. Muhammad b. Maslama said: No doubt, now we have become his followers and we do not like to forsake him until we see what turn his affairs will take. I want that you should give me a loan. He said: What will you mortgage? He said: What do you want? He said: Pledge me your women. He said: You are the most handsome of the Arabs; should we pledge our women to you? He said: Pledge me your children. He said: The son of one of us may abuse us saying that he was pledged for two wasqs of dates, but we can pledge you (cur) weapons. He said: All right. Then Muhammad b. Maslama promised that he would come to him with Harith, Abu 'Abs b. Jabr and Abbad b. Bishr. So they came and called upon him at night. He came down to them. Sufyan says that all the narrators except 'Amr have stated that his wife said: I hear a voice which sounds like the voice of murder. He said: It is only Muhammad b. Maslama and his foster-brother, Abu Na'ila. When a gentleman is called at night even it to be pierced with a spear, he should respond to the call. Muhammad said to his companions: As he comes down, I will extend my hands towards his head and when I hold him fast, you should do your job. So when he came down and he was holding his cloak under his arm, they said to him: We sense from you a very fine smell. He said: Yes, I have with me a mistress who is the most scented of the women of Arabia. He said: Allow me to smell (the scent on your head). He said: Yes, you may smell. So he caught it and smelt. Then he said: Allow me to do so (once again). He then held his head fast and said to his companions: Do your job. And they killed him.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4437]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4437

It has been narrated on the authority of Anas that the Messenger of Allah (may peace be upon him) raided Khaibar. One morning we offered prayers in the darkness of early dawn (near Khaibar). Then the Messenger of Allah (may peace be upon him) mounted (his horse). Abu Talha mounted his and I mounted behind Abu Talha on the same horse. The Prophet of Allah (may peace be upon him) rode through the streets of Khaibar and (I rode so close to him) that my knee touched the thigh of the Prophet of Allah (may peace be upon him). The wrapper got aside from his thigh, and I could see its whiteness. When he entered the town, he said: God is Great. Khaibar shall face destruction. When we descend in the city-square of a people, it is a bad day for them who have been warned (and have not taken heed). He said these words thrice. The people of the town had just come out from (their houses) to go about their jobs. They said (in surprise): Muhammad has come. We captured Khaibar by force.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4438]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4438

It has been narrated (through another chain of transmitters) on the authority of the same narrator (i. e. Anas) who said: I was riding behind Abu Talha on the day of the Battle of Khaibar (and we were riding so close to the Holy Prophet that) my foot would touch his We encountered the people at sunrise when they had come out with their axes, spades and strings driving their cattle along. They shouted (in surprise): Muhammad has come along with his force! The Messenger of Allah (may peace be upon him) said: Khaibar shall face destruction. Behold! when we descend in the city-square of a people, it is a bad day for those who have been warned (but have not taken heed). Allah, the Glorious and Majestic, inflicted defeat upon them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4439]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4439

This hadith has been transmitted on the authority of Anas b. Malik with a slight variation of words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4440]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4440

It has been narrated on the authority of Salama b. al-Akwa' who said: We marched upon Khaibar with the Messenger of Allah (may peace be upon him). We journeyed during the night. One of the people said to (my brother) 'Amir b. al-Akwa': Won't you recite to us some of your verses? Amir was a poet. So he began to chant his verses to urge the camels, reciting:

O God, if Thou hadst not guided us

We would have neither been guided rightly nor practised charity,

Nor offered prayers.

We wish to lay down our lives for Thee; so forgive Thou our lapses,

And keep us steadfast when we encounter (our enemies).

Bestow upon us peace and tranquillity.

Behold, when with a cry they called upon us to help.

The Messenger of Allah (may peace be upon him) said: Who is this driver (of the camels)? They said: It is 'Amir. He said: God will show mercy to him. A man said: Martyrdom is reserved for him. Messenger of Allah, would that you had allowed us to benefit ourselves from his life. (The narrator says): We reached Khaibar and besieged them, and (we continued the siege) until extreme hunger afflicted us. Then the Messenger of Allah (may peace be upon him) said: Behold, God has conquered it for you. When it was evening of the day on which the city was conquered. the Muslims lit many fires. The Messenger of Allah (may peace be upon him) said: What are these fires? And what are they cooking? They said: They are cooking meat. He asked. Which meat? They said: That of domestic asses. He said: Let them throw it away and break the pots (in which it is being cooked). A man said: Or should they throw it away and wash the pots? He said: They may do that. When the people drew themselves up in battle array 'Amir caught hold of his sword that was rather short He drove a Jew before him to strike him with it. (As he struck him), his sword recoiled and struck his own knee, and 'Amir died of the wound. When the people returned (after the conquest of Kliaibar) and he (Salama) had caught hold of my hand, and said: The Messenger of Allah (may peace be upon him) saw that I was silent (and dejected) ; he said: What's the matter with thee? I said to him: My father and my mother be thy ransom, people presume that 'Amir's sacrifice has been in vain. He asked: Who has said that? I said: So and so and Usaid b. Hudair al-Ansari. He said: Who has said that has lied. For him (for 'Amir) there is a double reward. (He indicated this by putting two of his fingers together.) He was a devotee of God and a warrior fighting for His cause. There will be hardly any Arab who can fight as bravely as he did. Qutaiba has differed in a few words.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4441]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4441

It has been reported on the authority of Salama b. Akwa' who said: On the day of the Battle of Khaibar my brother fought a fierce fight by the side of the Messenger of Allah (may peace be upon him). His sword rebounded and killed him. The Companions of the Messenger of Allah (may peace be upon hill) talked about his death and doubted (whether it was martyrdom). (They said): (He is) a man killed by his own weapon, and expressed doubt about his affair. Salama said: When the Messenger of Allah (may peace be upon him) returned from Khaibar, I said: Messenger of Allah, permit me that I may recite to you some rajaz verses. The Messenger of Allah (may peace be upon him) permitted him. 'Umar b. Khattab said: I know what you will recite. I recited:

By God, if God had guided us not,

We would hive neither been guided aright nor practised charity,

Nor offered prayers.

The Messenger of Allah (may peace be upon him) said: What you have said is true, 'I (continued):

And descend on us peace and tranquillity

And keep us steadfast if we encounter (with our enemies)

And the polytheists have rebelled against us.

When I finished my rajaz, the Messenger of Allah (may peace be upon him) said: Who composed these verses? I said: They were composed by my brother. The Messenger of Allah (may peace be upon him) said: May God show mercy to him! I said: By God, some people are reluctant to invoke God's mercy on him (because) they say he is a man who died by his own sword. (Hearing this) the Messenger of Allah (may peace be upon him) said: He died as God's devotee and warrior. Ibn Shihab has said: I asked one of the sons of Salama (b. Akwa') about (the death of 'Amir). He related to me a similar tradition except that he said: When I said some people were reluctant invoke God's blessings on him, the Messenger of Allah (may peace be, upon him said: They lied. ('Amir) died as God's devotee and warrior (in the cause of Allah). For him there is a double reward, and he pointed out this by putting his two fingers together.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4442]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4442

It has been reported on the authority of Barra' who said: The Messenger of Allah (may peace be upon him) was carrying the earth with us on the Day of Ahzab and the whiteness of his belly had been covered with earth. (While engaged in this toil) he was reciting:

By God, if Thou hadst not guided us

We would have neither been guided aright nor practised charity,

Nor offered prayers.

Descend on us peace and tranquillity.

Behold I these people (the Meccans) refused to follow us.

According to another version, he recited:

The chieftains (of the tribes) refused to follow us

When they contemplated mischief, we rejected it.

And with this (verse) he would raise his voice.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4443]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4443

It has been narrated on the authority of Abu Ishaq who said: I heard from Bara' a similar tradition except that he said:" These people (the Meccans) rebelled against us."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4444]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4444

It has been reported on the authority of Sahl b. Sa'd who said: The Messenger of Allah (may peace be upon him) came to us while we were digging the ditch and were carrying the earth on our shoulders. (Seeing our condition), he said:

O God, there is no life but the life of the Hereafter.

So forgive Thou the Muhajirs and the Ansar.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4445]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4445

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said:

O God, there is no life, but the life of the Hereafter,

So forgive Thou the Ansar and the Muhajirs.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4446]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4446

According to another version of the tradition, reported on the authority of Anas b. Malik, the Messenger of Allah (may peace he upon him) is reported to have said:

O God, there is no life but the life of the Hereafter,

So grant honour to the Ansar and the Muhajirs.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4447]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4447

According to still another version of the tradition narrated by the same authority, and handed down through a different chain of transmitters, it has been reported that they (the Companions of the Holy Prophet) were reciting rajaz verses and the Messenger of Allah (may peace be upon him) was (reciting) with them. And they were chanting:

O God, there is no good but the good of the Hereafter.

So help Thou the Ansar and the Muhajirs.

Shaiban substituted" So forgive Thou" for" So help Thou".


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4448]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4448

It has been narrated (through a still difterent chain of transmitters) by Anas that the Companions of Muhammad (may peace be upon him) were chanting on the day of the Battle of the Ditch:

We are those who have sworn allegiance to Muhammad

(And made a covenant with him) to follow Islam as long as we live.

Hammad is not sure whether Anas said:" Ala'l-Islam" or," Ala'l-Jihad". And the Holy Prophet (may peace be upon him) was chanting:

O God, the real good is the good of the Hereafter,

So forgive Thou the Ansar and the Muhajirs.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4449]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4449

It has been narrated on the authority of Yazid b. Abu 'Ubaid who said that he heard Salama b. al-Akwa' say: I went out before the Adhan for the morning prayer had been delivered. The milch she-camels of the Messenger of Allah (may peace be upon him) were grazing at Dhu Qarad. 'Abd al-Rahman b. Auf's slave met me and said: The milch she-camels of the Messenger of Allah (may peace be upon him) had been taken away. I said: Who has taken them away? He said: (the people belonging to the tribe of) Ghatafan. I cried thrice: Help! I made the whole city between the two lavas hear my cry. Then I ran straight in their pursuit until I overtook them at Dhu Qarad where they were just going to water their animals. I, being an archer, began to shoot them with my arrows and was saying: I am the son of al-Akwa'. And today is the day when the cowards will meet their doom. I continued to chant until I rescued the milch she-camels from them, and snatched from them thirty mantles. Now, the Messenger of Allah (may peace be upon him) and some other people came along. I said: Prophet of Allah, I have prevented them from water while they were thirsty. So you should send a force (to punish them). He (the Holy Prophet) said: Ibn al-Akwa', you have taken (what, you have taken). Now let them go. Then we returned and the Messenger of Allah (may peace be upon him) made me mount behind him on his she-camel until we entered Medina.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4450]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4450

It has been narrated on the authority of Ibn Salama. He heard the tradition from his father who said: We arrived at Hudaibiya with the Messenger of Allah (may peace be upon him) and we were fourteen hundred in number. There were fifty goats for them which could not be watered (by the small quantity of water in the local well). So, the Messenger of Allah (may peace be upon him) sat on the brink of the well. Either he prayed or spat into the well The water welled up. We drank and watered (the beasts as well). Then the Messenger of Allah (may peace be upon him) called us to take the vow of allegiance, as he was sitting at the base of a tree. I was the first man to take the vow. Then other people took the vow. When half the number of people had done so, he said to me: You take the vow, Salama. I said: I was one of those who took the vow in the first instance. He said: (You may do) again. Then the Messenger. of Allah (may peace be upon him) saw that I was without weapons. He gave me a big or a small shield. Then he continued to administer vows to the people until it was the last batch of them. He said (to me): Won't you swear allegiance, Salama? I said: Messenger of Allah, I took the oath with the first batch of the people and then again when you were in the middle of the people. He said: (Doesn't matter), you may (do so) again. So I took the oath of allegiance thrice. Then he said to me: Salama, where is the shield which I gave to thee? I said: Messenger of Allah, my uncle 'Amir met me and he was without any weapons. So I gave the shield to him. The Messenger of Allah (may peace be upon him) laughed and said: You are like a person of the days gone by who said: O God. I seek a friend who is dearer to me than myself. (When all Companions had sworn allegiance to the Holy Prophet), the polytheists sent messages of peace, until people could move from our camp to that of the Meccans and vice versa. Finally, the peace treaty was concluded.

I was a dependant of Talha b. Ubaidullah. I watered his horse, rubbed its back. I served Talha (doing odd jobs for him) and partook from his food. I had left my family and my property as an emigrant in the cause of Allah and His Messenger (may peace be uron him). When we and the people of Mecca had concluded a peace treaty and the people of one side began to mix with those of the other, I came to a tree, swept away its thorns and lay down (for rest) at its base; (while I lay there), four of the polytheists from the Meccans came to me and began to talk ill of the Messenger of Allah (may peace be upon him). I got enraged with them and moved to another tree. They hung their weapons (to the branches of the tree) and lay down (for rest). (While they lay there), somebody from the lower part of the valley cried out: Run up, O Muhajirs! Ibn Zunaim has been murdered. I drew my sword and attacked these four while they were asleep. I seized their arms and collected them up in my hand, and said: By the Being Who has conferred honour upon Muhammad, none of you shall raise his head, else I will smite his face. (Then) I came driving them along to the Holy Prophet (may peace be upon him). (At the same time). my uncle Amir came (to him) with a man from" Abalat called Mikraz. Amir was dragging him on a horse with a thick covering on its back along with seventy polytheists. The Messenger of Allah (may peace be upon him) cast a glance at them and said: Let them go (so that) they may prove guilty of breach of trust more than once (before we take action against them). So the Messenger of Allah (may peace be upon him) forgave them. On this occasion. God revealed the Qur'anic verse:" It is He Who restrained their hands from you and your hands from them in the valley of Mecca after He had granted you a victory over them" (xlviii. 24). Then we moved returning to Medina, and halted at a place where there was a mountain between us and Banu Lihyan who were polytheists. The Messenaer of Allah (may peace be upon him) asked God's forgiveness for one who ascended the mountain at night to act as a scout for the Messenger of Allah (may peace be upon him) and his Compinions. I ascended (that mountain) twice or thrice that night. (At last) we reached Medina. The Messenger of Allah (may peace be upon him) sent his camels with his slave, Rabah, and I was with him. I (also) went to the pasture with the horse of Talha along with the camels.

When the day dawned, Abd al-Rahman al-Fazari made a raid and drove away all the camels of the Messenger of Allah (may peace be upon him), and killed the man who looked after them. I said: Rabah, ride this horse, take it to Talha b. 'Ubaidullah and Inform the Messenger of Allah (may peace be upon him) that the polytheists have made away with his camels. Then I stood upon a hillock and turning my face to Medina, shouted thrice: Come to our help I Then I set out in pursuit of the raiders, shooting at them with arrows and chanting a (self-eulogatory) verse in the Iambic metre:

I am the son of al-Akwa'

And today is the day of defeat for the mean.

I would overtake a man from them, shoot at him an arrow which, piercing through the saddle, would reach his shoulder. and I would say: Take it, chanting at the same time the verse

And I am the son of al-Akwa'

And tody is the day of defeat for the mean.

By God, I continued shooting at them and hamstringing their animals. Whenever a horseman turned upon me, I would come to a tree and (hid myself) sitting at its base. Then I would shoot at him and hamstring his horse. (At last) they entered a narrow mountain gorge. I ascended that mountain and held them at bay throwing stones at them. I continued to chase them in this way until I got all the camels of the Messenger of Allah (may peace be upon him) released and no camel was left with them. They left me; then I followed them shooting at them (continually) until they dropped more than thirty mantles and thirty lances. lightening their burden. On everything they dropped, I put a mark with the help of (a piece of) stone so that the Messenger of Allah (may peace be upon him) and his Companions might recognise them (that it was booty left by the enemy). (They went on) until They came to a narrow valley when so and so, son of Badr al-Fazari joined them. They (now) sat down to take their breakfast and I sat on the top of a tapering rock. Al-Fazari said: Who is that fellow I am seeing? They said: This fellow has harassed us. By God, he has not left us since dusk and has been (continually) shooting at us until he has snatched everything from our hands. He said: Four of you should make a dash at him (and kill him). (Accordingly), four of them ascended the mountain coming towards me. When it became possible for me to talk to them, I said: Do you recognise me? They said: No. Who are thou? I said: I am Salama, son of al-Akwa'. By the Being Who has honoured the countenance of Muhammad (may peace be upon him) I can kill any of you I like but none of you will be able to kill me. One of them said: I think (he is right). So they returned. I did not move from my place until I saw the horsemen of the Messenger of Allah (may peace be upon him), who came riding through the trees. Lo! the foremost among them was Akhram al-Asadi.

Behind him was Abu Qatada al-Ansari and behind him was al-Miqdad b. al-Aswad al-Kindi. I caught hold of the rein of Akhram's horse (Seeing this). they (the raiders) fled. I said (to Akhram): Akhram, guard yourself against them until Allah's Messenger (may peace be upon him) and his Companions join you. He said: ) Salama, if you believe In Allah and the Day of Judgment and (if) you kaow that Paradise is a reality and Hell is a reality, you should not stand between me and martyrdom. so I let him go. Akhram and Abd al-Rahman (Fazari) met in combat. Akhram hamstrung Abd al-Rahman's horse and the latter struck him with his lance and killed him. Abd al-Rabman turned about riding Akhram's horse. Abu Qatada, a horse-man of the Messenger of Allah (may peace be upon him), met 'Abd al-Rahman (in combat), smote him with his lance and killed him. By the Being Who honoured the countenance of Muhammad (may peace oe upon him), I followed them running on my feet (so fast) that I couldn't see behind me the Companions of Muhammad (may peace be upon him), nor any dust raised by their horses. (I followed them) until before sunset they reached a valley which had a spring of water, which was called Dhu Qarad, so that they could have a drink, for they were thirsty. They saw me running towards them. I turned them out of the valley before they could drink a drop of its water. They left the valley and ran down a slope. I ran (behind them), overtook a man from them, shot him with an arrow through the shoulder blade and said: Take this. I am the son of al-Akwa'; and today is the day of annihilation for the people who are mean. The fellow (who was wounded) said: May his mother weep over him! Are you the Akwa' who has been chasing us since morning? I said: Yes, O enemy of thyself, the same Akwa'. They left two horses dead tired on the hillock and I came dragging them along to the Messenger of Allah (may peace be upon him). I met 'Amir who had with him a container having milk diluted with water and a container having water. I performed ablution with the water and drank the milk. Then I came to the Messenger of Allah (may peace be upon him) while he was at (the spring of) water from which I had driven them away. The Messenger of Allah (may peace be upon him) had captured those camels and everything else I had captured and all the lances and mantles I had snatched from the polytheists and Bilal had slaughtered a she-camel from the camels I had seized from the people, and was roasting its liver and hump for the Messenger of Allah (may peace be upon him). I said: Messenger of Allah, let me select from our people one hundred men and I will follow the marauders and I will finish them all so that nobody is left to convey the news (of their destruction to their people). (At these words of mine), the Messenger of Allah (may peace be upon him) laughed so much that his molar teeth could be seen in the light of the fire, and he said: Salama, do you think you can do this? I said: Yes, by the Being Who has honoured you. He said: Now they have reached the land of Ghatafan where they are being feted. (At this time) a man from the Ghatafan came along and said: So and so slaughtered a camel for them. When they were exposing its skin, they saw dust (being raised far off). They said: They (Akwa' and his companions) have come. So. they went away fleeing.

When it was morning, the Messenger of Allah (may peace be upon him) said: Our best horseman today is Abu Qatada and our best footman today is Salama. Then he gave me two shares of the booty-the share meant for the horseman and the share meant for the footman, and combined both of them for me. Intending to return to Medina, he made me mount behind him on his she-camel named al-Adba'. While we were travelling, a man from the Ansar who could not be beaten in a race said: Is there anyone who could compete (with me) in race to Medina? Is there any competitor? He continued repeating this. When I heard his talk, I said: Don't you show consideration to a dignified person and don't you have awe for a noble man? He said: No, unless he be the Messenger of Allah (may peace be upon him). I said: Messenger of Allah, may my father and mother be thy ransom, let me get down so that I may beat this man (in the race). He said: It you wish, (you may). I said (to the man): I am coming to thee, I then turned my feet. sprang up and tan and gasped (for a while) when one or two elevated places were left and again followed his heel and again gasped (for a while) when one or two elevated places were left and again dashed until I joined him and gave a blow between his shoulders. I said: You have been overtaken, by God. He said: I think so. Thus, I reached Medina ahead of him. By God, we had stayed there only three nights when we set out to Khaibar with the Messenger of Allah (may peace be upon him). (On the way) my uncle, Amir, began to recite the following rajaz verses for the people:

By God, if Thou hadst not guided us aright,

We would have neither practised charity nor offered prayers.

(O God! ) We cannot do without Thy favours;

Keep us steadfast when we encounter the enemy,

And descend tranquillity upon us.

The Messenger of Allah (may peace be upon him) said: Who is this? 'Amir said: it is 'Amir. He said: May thy God forgive thee! The narrator said: Whenever the Messenger of Allah (may peace be upon him) asked forgiveness for a particular person, he was sure to embrace martyrdom. Umar b. Khattab who was riding on his camel called out: Prophet of Allah, I wish you had allowed us to benefit from Amir. Salama continued: When we reached Khaibar, its king named Marhab advanced brandishing his sword and chanting:

Khaibar knows that I am Marhab (who behaves like)

A fully armed, and well-tried warrior.

When the war comes spreading its flames.

My uncle, Amir, came out to combat with him, saying:

Khaibar certainly knows that I am 'Amir,

A fully armed veteran who plunges into battles.

They exchanged blows. Marbab's sword struck the shield of 'Amir who bent forward to attack his opponent from below, but his sword recoiled upon him and cut the main artery: in his forearm which caused his death. Salama said: I came out and beard some people among the Companions of the Holy Prophet (may peace be upon him) as saying: Amir's deed has gone waste; he has killed himself. So I came to the Holy Prophet (may peace be upon him) weeping and I said: Messenger of Allah. Amir's deed has gone waste. The Messenger (may peace be upon him) said: Who passed this remark? I said: Some of your Companions. He said: He who has passed that remark has told a lie, for 'Amir there is a double reward. Then he sent me to 'Ali who had tore eyes, and said: I will give the banner to a man who loves Allah and His Messenger or whom Allah and His Messenger love. So I went to 'Ali, brought him beading him along and he had sore eyes, and I took him to the Messenger of Allah (may peace be upon him), who applied his saliva to his eyes and he got well. The Messenger of Allah (may peace be upon him) gave him the banner (and 'Ali went to meet Marhab in a single combat). The latter advanced chanting:

Khaibar knows certainly that I am Marhab,

A fully armed and well-tried valorous warrior (hero)

When war comes spreading its flames.

'Ali chanted in reply:

I am the one whose mother named him Haidar, (And am) like a lion of the forest with a terror-striking countenance. I give my opponents the measure of sandara in exchange for sa' (i. e. return thir attack with one that is much more fierce).

The narrator said: 'Ali struck at the head of Mirhab and killed him, so the victory (capture of Khaibar) was due to him. This long tradition has also been handed down Through a different chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4451]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4451

This hadith has been transmitted on the authority of 'Ikrama b. Ammar.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4452]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4452

It has been narrated on the authority of Anas b. Malik that eighty Persons from the inhabitants of Mecca swooped down upon the Messenger of Allah (may peace be upon him) from the mountain of Tan'im. They were armed and wanted to attack the Holy Prophet (may peace be upon him) and his Companions unawares. He (the Holy Prophet) captured them but spared their lives. So, God, the Exalted and Glorious, revealed the verses:" It is He Who restrained your hands from them and their hands from you in the valley of Mecca after He had given you a victory over them."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4453]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4453

It has been narrated on the authority of Anas that, on the Day of Hunain. Umm Sulaim took out a dagger she had in her possession. Abiu Talha saw her and said: Messenger of Allah, this is Umm Sulaim. She is holding a dagger. The Messenger of Allah (may peace be upon him) asked (her): What for are you holding this dagger? She said: I took it up so that I may tear open the belly of a polytheist who comes near me. The Messenger of Allah (may peace be upon him) began to smile (at these words). She said: Messenger of Allah, kill all those people-other than us-whom thou hast declared to be free (on the day of the Conquest of Mecca). (They embraced Islam because) they were defeated at your hands (and as such their Islam is not dependable). The Messenger of Allah (may peace be upon him) said: Umm Sulaim. God is sufficient (against the mischief of the polytheists) and He will be kind to us (so you need not carry this dagger).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4454]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4454

It has been narrated on the authority of Anas b. Malik who said that the Messenger of Allah (may peace be upon him) allowed Umm Sulaim and some other women of the Ansar to accompany him when he went to war; they would give water (to the soldiers) and would treat the wounded.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4455]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4455

It has been narrated on the authority of Anas b. Malik who said: On the Day of Ubud some of the people, being defeated, left the Holy Prophet (may peace he upon him), but Abu Talha stood before him covering him with a shield. Abu Talha was a powerful archer who broke two or three bows that day. When a man would pass by carrying a quiver containing arrows, he would say: Spare them for Abu Talha. Whenever the Holy Prophet (way peace be upon him) raised his head to look at the people, Abd Talba would say: Prophet of Allah, may my father and my mother be thy ransom, do not raise your head lest you be struck by an arrow shot by the enemy. My neck is before your neck. The narrator said: I saw A'isha bint Abu Bakr and Umm Sulaim. Both of them had tucked up their garments, so I could me the anklets on their feet. They were carrying water-skins on their backs and would pour water into the mouths of the people. They would then go back (to the well), would fill them again and would return to pour water into the mouths of the soldiers. (On this day). Abu Talha's sword dropped down from his hands twice or thrice because of drowsiness.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4456]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4456

It has been narrated on the authority of Yazid b. Hurmuz that Najda wrote to Ibn Abbas inquiring of him five things. Ibn Abbas said: If I had not the fear of committing (sin) for concealing the knowledge I would not have written to him. Najda wrote to him saying (after praising the Almighty and invoking blessings on the Prophet): Tell me whether the Messenger of Allah (may peace be upon him) took women to participate with him in Jihad; (if he did), whether he allotted them a regular share from the booty; whether he killed the children of (the enemy in the war how long an orphan would be entitled to consideration as such and for whom the Kbums (fifth part of the booty) was booty. Ibn Abbas wrote to him: You have written asking me whether the Messenger of Allah (may peace be upon him) took women with him to participate in Jihad. He did take them to the battle and sometimes he fought along with them. They would treat the wounded and were given a reward from the booty, but he did not assign any regular share for them. And the of Allah (may peace be upon him) did not kill the children of the enemy, so thou shouldst not kill the children. Also you have written to me asking me when the orphanhood of an orphan comes to an end. By my life, if a man has become bearded but is still incapable of getting his due from others as well u meeting his obligation towards them, (he is yet an orphan to be treated you such), but when he can look after his interests like grown-up people, he is no longer an orphan. And you have written to me inquiring about Khums as to whom it is meant for. (In this connection) we (the kinsmen of the Messenger of Allah) used to say: It is for us, but those people (i. e. Banu Umayya) have denied it to us.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4457]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4457

This tradition has been narrated by the game authority (Yazid b. Hurmus) through a different chain of transmitters with the following difference in the elucidation of one of the points raised by Najda in his letter to Ibn Abas: The Messenger of Allah (may peace be upon him) used not to kill the children, so thou shouldst not kill them unless you could know what Khadir had known about the child he killed, or you could distinguish between a child who would grow up to he a believer (and a child who would grow up to be a non-believer), so that you killed the (prospective) non-believer and left the (prospective) believer aside.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4458]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4458

It has been narrated on the authority of Yazid b. Hurmuz who said: Najda b. 'Amir al-Haruri wrote to Ibn Abbas asking him about the slave and the woman as to whether they would get a share from the booty (it they participated in Jihad) ; about the killing of (enemy) children (in war) ; about the orphan as to when his orphanhood comes to an end; about kinsmen (of the Holy Prophet) as to who they are. He said to Yazid: Write to him. (If he were not likely to fall into folly, I would not have written to him.) Write: You have written asking about the woman and the slave whether they would get a share of the booty if they participated in Jihad. (You should know that) there is nothing of the sort for them except that they will be given a prize. And you have written asking me about the killing of the enemy children in war. (You should understand that) the Messenger of Allah (may peare be upon him) did not kill them. and thou shouldst not kill them unless thou knew what the companion of Moses (i. e. Khadir) knew about the boy he had killed. And you have written asking me about the orphan as to when the period of his orphanhood comes to an end, so that the sobriquet of" orphan" is dropped from him. (In this regard, you should know that) the sobriquet" orphan" will not be dropped from him until he attains maturity of body and mind. And you have written asking me about the close relatives (of the Holy Prophet) as to who they are. We think that it is we, but our people have denied us this (position and its concomitant privileges).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4459]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4459

This hadith has been narrated on the authority of Yazid b. Hurmuz through another chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4460]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4460

It has been narrated on the anthority of Yazid b. Hurmuz who said: Najda wrote to Ibn Abbas. I was sitting in the company of Ibn 'Abbas when he read his letter and wrote its reply. Ibn Abbas said: Were it not for preventing him from falling into wickedness. I would not have replied to his letter, may he never be joyful. He wrote in reply to him referring to the share of the close relatives (of the Holy Prophet) (from the booty) whom God has mentioned. (I have to tell you that) we thought we were the close relatives of the Messenger of Allah (may peace be upon him), but our people have refused to recognise us as such. You have asked about the orphan as to when his orphanhood comes to an end. (I have to say that) when he reaches the age of marriage, attains maturity of mind, and his property is returned to him, then he is no longer an orphan. You have inquired whether the Messenger of Allah (may peace be upo him) used to kill anyone from the children of the polytheists in the war. (You should know that) the Messenger of Allah (may peace be upon him) used not to kill any one of their children, and you (too) should not kill any one of them, except when you knew about them what Khadir had known about the boy whom he killed. And you have inquired whether there is a fixed share of the booty for women and slaves when they participate in a battle. (I have to tell you that) there is no fixed share for them except that they will be given some reward from the spoils of war.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4461]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4461

This hadith has been transmitted on the authority of Yazid b. Hurmuz. but not complete (as we find in the above mentioned ahadith).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4462]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4462

It has been narrated on the authority of Umm 'Atiyya, the Ansarite, who said: I took part with the Messenger of Allah (may peace be upon him) in seven battles. I would stay behind in the camp of men, cook their food, treat the wounded and nurse the aick.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4463]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4463

A similar tradition has been narrated on the authority of Hisham b. Hassan through a different chain of transmitters.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4464]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4464

It has been narrated on the authority of Abu Ishaq that 'Abdullah b. Yazid went (out of the city) with people for offering" Istisqa" ' prayer (for rainfall). He offered two rak'ahs. Then he prayed for rain. That day I met Zaid b. Arqam. There was only one man between me and him (at that time). I asked him: How many military expeditions did the Messenger of Allah (may peace be upon him) undertake? He said: Nineteen expeditions. I asked him: On how many expeditions did you accompany him? He said: On seventeen expeditions. I asked: Which was the first expedition he led? He answered: Dhat-ul-, Usair or 'Ushair.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4465]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4465

It has been narrated on the authority of Zaid b. Arqam that the Messenger of Allah (may peace be upon him) fought nineteen battles and after the Migration performed only one Pilgrimage called Hajjat-ul-Wada'.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4466]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4466

It has been reported on the authority of Abu Zubair who heard Jabir b. Abdullah say: I fought in the company of the Messenger of Allah (may peace be upon him) nineteen battles. Jabir said: I did not participate in the Battle of Badr and the Battle of Uhud. My father prevented me (from participating in these battles as my age was tender). After 'Abdullah (my father) was killed on the Day of Ubud, I never lagged behind the Messenger of Allah (may peace be upon him) and joined every battle (he fought).


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4467]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4467

It has been narrated on the authority of Buraida (who heard the tradition from his father) that the Messenger of Allah (may peace be upon him) conducted nineteen military campaigns and he (actually) fought in eight of them.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4468]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4468

It has been narrated by Buraida who heard it from his father that he joined the Messenger of Allah (may peace be upon him) in sixteen military campaigns


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4469]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4469

It has been narrated on the authority of Salama who said: I joined seven military expeditions led by the Messenger of Allah himself (may peace be upon him), and nine expeditions which he sent out once under Abu Bakr and once under Usama b. Zaid.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4470]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4470

The (foregoing) tradition has also been narrated on the authority of Hatim through the same chain of transmitters with the difference that according to this version both these types of expeditions were seven in number.


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4471]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4471

It has been narrated on the authority of Abu Musa (Ash'ari) who said: We set out on an expedition with the Messenger of Allah (may peace be upon him). We were six in number and had (with us) only one camel which we rode turn by turn Our feet were injured. My feet were so badly injured that my nails dropped off. We covered our feet with rags. so this expedition was called Dhat-ur-Riqa' (i. e. the expedition of rags) because we bandaged our feet with rags (on that day). Abu Burda said: Abu Musa narrated this tradition, and then disliked repeating it as he did not want to give any publicity to what he did in a noble cause Abu Usama said: Narrators other than Abu Buraida have added to the version of the words:" God will reward it."


Muslim :: The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar) :: [19.4472]

The Book of Jihad and Expedition (Kitab Al-Jihad wa'l-Siyar)

Muslim :: Book 19 : Hadith 4472

It has been narrated on the authority of A'isha, wife of the Holy Prophet (may peace be upon him), who said: The Messenger of Allah (may peace be upon him) set out for Badr. When he reached Harrat-ul-Wabara (a place four miles from Medina) a man met him who was known for his valour and courage. The Companions of the Messenger of Allah (may peace be upon him) were pleased to see him. He said: I have come so that I may follow you and get a share from the booty. The Messenger of Allah (may peace be upon him) said to him: Do you believe in Allah and His Apostle? He said: No. The Messenger of Allah (may peace be upon him) said: Go back, I will not seek help from a Mushrik (polytheist). He went on until we reached Shajara, where the man met him again. He asked him the same question again and the man gave him the same answer. He said: Go back. Im will not seek help from a Mushrik. The man returned and overtook him at Baida'? He asked him as he had asked previously: Do you believe in Allah and His Apostle? The man said: Yes. The Messenger of Allah (may peace be upon him) said to him: Then come along with us.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4473]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4473

It has been narrarted on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: People are subservient to the Quraish: the Muslims among them being subservient to the Muslims among them, and the disbelievers among the people being subservient to the disbelievers among them.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4474]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4474

It has been narrated on the authority of Hammam b. Munabbih who said: This is one of the traditions narrated by Abu Huraira from the Messenger of Allah (may peace be upon him) who said: People are subservient to the Quraish: the Muslims among them being subservient to the Muslims among them, and the disbelievers among them being subservient to the disbelievers among them.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4475]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4475

It has been narrated on the authority of Jabir b. 'Abdullah that the Messenger of Allah (may peace be upon him) said: People are the followers of Quraish in good as well as evil (i. e. in the customs of Islamic as well as pre-Islamic times).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4476]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4476

It has been narrated on the authority of 'Abdullah that the Messenger of Allah (may peace be upon him) said: The Caliphate will remain among the Quraish even if only two persons are left (on the earth),


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4477]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4477

It has been narrated on the authority of Jabir b. Samura who said: I joined the company of the Holy Prophet (may peace be upon him) with my father and I heard him say: This Caliphate will not end until there have been twelve Caliphs among them. The narrator said: Then he (the Holy Prophet) said something that I could not follow. I said to my father: What did he say? He said: He has said: All of them will be from the Quraish.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4478]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4478

It has been reported on the authority of Jabir b. Samura who said: I heard the Messenger of Allah (may peace be upon him) say: The affairs of the people will continue to be conducted (well) as long as they are governed by twelve men. Then the Holy Prophet (may peace be upon him) said words which were obscure to me. I asked my father: What did the Messenger of Allah (may peace be upon him) say? He said: All of the (twelve men) will be from the Quraish.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4479]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4479

This hadith has been narrated on the authority of Jabir b. Samura through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4480]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4480

It has been narrated on the authority of Jabir b. Samura who said: I heard the Messenger of Allah (may peace be upon him) say: Islam will continue to be triumphant until there have been twelve Caliphs. Then the Holy Prophet (may peace be upon him) said something which I could not understand. I asked my father: What did he say? He said: He has said that all of them (twelve Caliphs) will be from the Quraish.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4481]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4481

It has been narrated on the authority of Jabir b. Samura that the Holy Prophet (may peace be upon him) said: This order will continue to be dominant until there have been twelve Caliphs. The narrator says: Then he said something which I could not understand, and I said to my father: What did he say? My father told me that he said that all of them (Caliphs) would be from the Quraish.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4482]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4482

It has been reported on the authority of Jabir b. Samura who said: I went with my father to the Messenger of Allah (may peeace be upon him) and I heard him say: This religion would continue to remain powerful and dominant until there have been twelve Caliphs. Then he added something which I couldn't catch on account of the noise of the people. I asked my father: What did he say? My father said: He has said that all of them will be from the Quraish.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4483]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4483

It has been narrated on the authority of Amir b. Sa'd b. Abu Waqqas who said: I wrote (a letter) to Jabir b. Samura and sent it to him through my servant Nafi', asking him to inform me of something he had heard from the Messenger of Allah (may peace be upon him). He wrote to me (in reply): I heard the Messenger of Allah (may peace be upon him) say on Friday evening, the day on which al-Aslami was stoned to death (for committing adultery): The Islamic religion will continue until the Hour has been established, or you have been ruled over by twelve Caliphs, all of them being from the Quraish. also heard him say: A small force of the Muslims will capture the white palace, the police of the Persian Emperor or his descendants. I also heard him say: Before the Day of Judgment there will appear (a number of) impostors. You are to guard against them. I also heard him say: When God grants wealth to any one of you, he should first spend it on himself and his family (and then give it in charity to the poor). I heard him (also) say: I will be your forerunner at the Cistern (expecting your arrival).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4484]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4484

Ibn Samura al-'Adawi reported: I heard Allah's Messenger (may peace be upon him) say, and he then narrated (the above-mentioned hadith).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4485]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4485

It has been narrated on the authority of 'Abdullah b. 'Umar who said: I was present with my father when he was wounded. People praised him and said: May God give you a noble recompense! He said: I am hopeful (of God's mercy) as well as afraid (of His wrath) People said: Appoint anyone as your successor. He said: Should I carry the burden of conducting your affairs in my life as well as in my death? (So far as Caliphate is concerned) I wish I could acquit myself (before the Almighty) in a way that there is neither anything to my credit nor anything to my discredit. If I would appoint my successor, (I would because) one better than me did so. (He meant Abu Bakr.) If I would leave You alone, (I would do so because) one better than me, i. e. the Messenger of Allah (may peace be upon him), did so. 'Abdullah says: When he mentioned the Messenger of Allah (may peace be upon him) I understood that he would not appoint anyone as Caliph.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4486]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4486

It has been reported on the authority of Ibn 'Umar who said: I entered the apartment of (my sister) Hafsa. She said: Do yoa know that your father is not going to nominate his successor? I said: He won't do that (i. e. he would nominate). She said: He is going to do that. The narrator said: I took an oath that I will talk to him about the matter. I kept quiet until the next morning, still I did not talk to him, and I felt as if I were carryint, a mountain on my right hand. At last I came to him and entered his apartment. (Seeing me) he began to ask me about the condition of the people, and I informed him (about them). Then I said to him: I heard something from the people and took an oath that I will communicate it to you. They presume that you are not going to nominate a successor. If a grazer of camels and sheep that you had appointed comes back to you leaving the cattle, you will (certainly) think that the cattle are lost. To look after the people is more serious and grave. (The dying Caliph) was moved at my words. He bent his head in a thoughtful mood for some time and raised it to me and said: God will doubtlessly protect His religion. If I do not nominate a successor (I have a precedent before me), for the Messenger of Allah (may peace be upon him) did not nominate his successor. And if I nominate one (I have a precedent), for Abu Bakr did nominate. The narrator (Ibn Umar) said: By God. when he mentioned the Messenger of Allah (may peace be upon him) and Abu Bakr, I (at once) understood that he would not place anyone at a par with the Messenger of Allah (may peace be upon him) and would not nominate anyone.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4487]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4487

It has been reported on the authority of 'Abd al-Rahman b. Samura who said: The Messenger of Allah (may peace be upon him) said to me: 'Abd al-Rahman, do not ask for a position of authority, for if you are granted this position as a result of your asking for it, you will be left alone (without God's help to discharge the responsibilities attendant thereon), and it you are granted it without making any request for it, you will be helped (by God in the discharge of your duties).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4488]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4488

The same tradition has been narrated through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4489]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4489

It has been narrated by Abu Musa who said: Two of my cousins and I entered the apartment of the Holy Prophet (may peace be upon him). One of them said: Messenger of Allah, appoint us rulers of some lands that the Almighty and Glorious God has entrusted to thy care. The other also said something similar. He said: We do not appoint to this position one who asks for it nor anyone who is covetous for the same.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4490]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4490

It has been reported on the authority of Abu Musa who said: I went to the Holy Prophet (may peace be upon him) and with me were two men from the Ash'ari tribe. One of them was on my right hand and the other on my left. Both of them made a request for a position (of authority) while the Holy Prophet (may peace be upon him) was brushing his teeth with a tooth-stick. He said (to me): Abu Musa (or 'Abdullah b. Qais), what do you say (about the request they have made)? I said: By God Who sent thee on thy mission with truth, they did not disclose to me what they had in their minds, and I did not know that they would ask for a position. The narrator says (while recalling this hadith): I visualise as if I were looking at the miswak of the Holy Prophet (may peace be upon him) between his lips. He (the Holy Prophet) said: We shall not or shall never appoint to the public offices (in our State) those who with to have them, but you may go, Abu Musa (or Abdullah b. Qais) (to take up your assignment). He sent him to Yemen as governor. then he sent Mu'adh b. jabal in his wake (to help him in the discharge of duties). When Mu'adh reached the camp of Abu Musa, the latter (received him and) said: Please get yourself down; and he spread for him a mattress, while there was a man bound hand and foot as a prisoner. Mu'adh said: Who is this? Abu Musa said: He was a Jew. He embraced Islam. Then he reverted to his false religion and became a Jew. Mu'adh said: I won't sit until he is killed according to the decree of Allah and His Apostle (may peace be upon him) (in this case). Abu Musa said: Be seated. It will be done. He said: I won't sit unless he is killed in accordance with the decree of Allah and His Apostle (may peace be upon him). He repeated these words thrice. Then Abu Musa ordered him (to be killed) and he was kilied. Then the two talked of standing in prayer at night. One of them, i. e. Mu'adh, said: I sleep (for a part of the night) and stand in prayer (for a part) and I hope that I shall get the same reward for steeping as I shall get for standing (in prayer).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4491]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4491

It has been narrated on the authority of Abu Dharr who said: I said to the Holy Prophet (may peace be upon him): Messenger of Allah, will you not appoint me to a public office? He stroked my shoulder with his hand and said: Abu Dharr, thou art weak and authority is a trust. and on the Day of judgment it is a cause of humiliation and repentance except for one who fulfils its obligations and (properly) discharges the duties attendant thereon.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4492]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4492

It has been reported on the authority of Abu Dharr that the Messenger of of Allah (may peace be upon him) said: Abu Dharr, I find that thou art weak and I like for thee what I like for myself. Do not rule over (even) two persons and do not manage the property of an orphan.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4493]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4493

It has been narrated on the authority of 'Abdullah b. 'Umar that the Messenger of Allah (may peace be upon him) said: Behold! the Dispensers of justice will be seated on the pulpits of light beside God, on the right side of the Merciful, Exalted and GlorioUS. Either side of the Being is the right side both being equally mrneritorious. (The Dispensers of justice are) those who do justice in their rules, in matters relating to their families and in all that they undertake to do.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4494]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4494

It has been reported on the authority of Abd al-Rahman b. Shumasa who said: I came to A'isha to inquire something from her. She said: From which people art thou? I said: I am from the people of Egypt. She said: What was the behaviour of your governor towards you in this war of yours? I said: We did not experience anything bad from him. If the camel of a man from us died, he would bestow on him a camel. If any one of us lost his slave, he would give him a slave. If anybody was in need of the basic necessities of life, he would provide them with provisions. She said: Behold! the treatment that was meted out to my brother, Muhammad b. Abu Bakr, does not prevent me from telling you what I heard from the Messenger of Allah (may peace be upon him). He said in this house of mine: O God, who (happens to) acquire some kind of control over the affairs of my people and is hard upon them-be Thou hard upon him, and who (happens to) acquire some kind of control over the affairs of my people and is kind to them-be Thou kind to him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4495]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4495

This hadith has been narrated on the authority of Abd al-Rahman b. Shumasa with another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4496]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4496

It has been narrated on the authority of Ibn 'Umar that the Holy Prophet (May be upon him) said: Beware. every one of you is a shepherd and every one is answerable with regard to his flock. The Caliph is a shepherd over the people and shall be questioned about his subjects (as to how he conducted their affairs). A man is a guardian over the members of his family and shal be questioned about them (as to how he looked after their physical and moral well-being). A woman is a guardian over the household of her husband and his children and shall be questioned about them (as to how she managed the household and brought up the children). A slave is a guardian over the property of his master and shall be questioned about it (as to how he safeguarded his trust). Beware, every one of you is a guardian and every one of you shall be questioned with regard to his trust.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4497]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4497

This tradition has been narrated through more; than one chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4498]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4498

This hadith has been transmitted on the authority of Ibn 'Umar, but there is (a slight change of wording) in the hadith transmitted through Zuhri that he said:" I think that he (the narrator) said: The man is a custodian of the wealth of his father, and he would be answerable for what is in his custody."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4499]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4499

A hadith having the same meaning has been transmitted on the authority of 'Abdullah b. 'Umar.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4500]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4500

It has been narrated on the authority of Hasan who said: Ubaidullah b Ziyad visited Ma'qil b. Yasir al-Muzani in his last iliness. Ma'qil said (to him): I am narrating to you a tradition I heard from the Messenger of Allah (may peace be upon him). If I knew that I am to survive this illness. I would, not narrate it to you. I heard the Messenger of Allah (may peace be upon him) say: If God appointed anyone ruler over a people and he died while he was still treacherous to his people, God would forbid his entry into Paradige.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4501]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4501

It has been narrated through a different chain of transmitters on the authority of Hasan who said: Ibn, Ziyad paid a visit to Ma'qil b. Yasir who was seriously ill. Here follows the same tradition as has gone before with the addition that Ibn Ziyad asked: Why didn't you narrate this tradition to me before this day? Ma'qil reprimanded him and said: I did not narrate it to you or I was not going to narrate it to you.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4502]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4502

It has been narrated on the authority of Abu Malik that Ubaidullah b. Ziyad visited Ma'qil b. Yaser in the latter's illness. Ma'qil said to him: I am narrating to you a tradition. If I were not at death's door, I would not narrate it to you. I heard the Messenger of Allah (may peace he upon him) say: A ruler who, having obtained control over the affairs of the Muslims, does not strive for their betterment and does not serve them sincerely shall not enter Paradise with them.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4503]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4503

It has been narrated on the authority of Abu al-Aswad who said: My father related to me that Ma'qil b. Yasir fell ill. 'Ubaidullah b. Ziyad called on him to inquire after his health. Here follows the tradition as narrated by Hasan from Ma'qil.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4504]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4504

It has been narrated on the authority of Hasan that A'idh b. 'Amr who was one of the Companions of the Messenger of Allah (may peace be upon him) called on 'Ubaidullah b. Ziyad and said (to him): O my son, I have heard the Messenger of Allah (may peace be upon him) say: The worst of guardians is the cruel ruler. Beware of being one of them. Ubaidullah said (to him out of arrogance): Sit you down. You are from the chaff of the Companions of Muhammad (may peace be upon him). A'idh said: Was there worthless chaff among them? Such worthless chaff appeared after them and among other people.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4505]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4505

It has been narrated on the authority of Abu Huraira who said: One day the Messenger of Allah (may peace be upon him) stood among us (to deliver a sermon). He talked about the misappropriation of booty, and declared it to be a serious matter and a grave sin. Then he said: I shouldn't find that any of you should come on the Day of Judgment with a growling camel mounted on his neck, and should appeal to me for help saying:" Messenger of Allah, help me." and I should say: I have no authority to help you; I already communicated to you. I shouldn't find that any of you should come on the Day of Judgment with a bleating ewe mounted on his neck, and he should say to me:" Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that one of you should come on the Day of Judgment with a Person crying loudly mounted on his neck, and he should say to me:" Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that any one of you should come on the Day of Judgment with fluttering clothes wrapped round his neck and he should say to me:" Messenger of Allah, help me," and I should say: I have no authority to help you; I conveyed to you. I shouldn't find that any of you should come on the Day of Judgment with a heap of gold and silver placed on his neck and he should say to me:" Messenger of Allah, help me." and I should say: I have no authority to help you; I already conveyed to you (the warning from the Almighty).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4506]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4506

The above tradition has been narrated on the same authority through different chains of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4507]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4507

Abu Huraira has narrated this hadith with a slight variation of words.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4508]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4508

Abu Huraira has narrated this hadith similar to the above mentioned hadith.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4509]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4509

It has been narrated on the authority of Abu Humaid as-Sa'idi who said: The Messenger of Allah (may peace be upon him) appointed a man from the Asad tribe who was called Ibn Lutbiyya in charge of Sadaqa (i. e. authorised hign to receive Sadaqa from the people on behalf of the State. When he returned (with the collictions), he said: This is for you and (this is mine as) it was presented to me as a gift. The narrator said: The Messenger of Allah (may peace be upod him) stood on the pulpit and praised God and extolled Him. Then he said: What about a State official whom I give an assignment and who (comes and) says: This is for you and this has been presented to me as a gift? Why didn't he remain in the house of his father or the house of his mother so that he could observe whether gifts were presented to him or not. By the Being in Whose Hand is the life of Muhammad, any one of you will not take anything from it but will bring it on the Day of Judgment, carrying on his neck a camel that will be growling, or a cow that will be bellowing or an ewe that will be bleating. Then he raised his hands so that we could see the whiteness of his armpits. Then he said twice: O God, I have conveyed (Thy Commandments).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4510]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4510

It has been reported on the authority of Abu Humaid as-Sa'idi who said: The Holy Prophet (may peace be upon him) appointed Ibn Lutbiyya, a man from the Azd tribe, in charge of Sadaqa (authorising him to receive gifts from the people on behalf of the State). He came with the collectio, gave it to the Holy Prophet (may peace be upon him). and said: This wealth is for you and this is a gift presented to me. The Holy Prophet (may peace be upon him) said to him: Why didn't you remain in the house of your father and your mother to see whether gifts were presented to you or not. Then he stood up to deliver a sermon. Here follows the tradition like the tradition of Sufyan.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4511]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4511

It has been reported on the authority of Abu Humaid as-Sa'idi who said: The Messenger of Allah (may peace be upon him) appointed a man from the Azd tribe. called Ibn al-, Utbiyya, in charge of Sadaqat to be received from Banu Sulaim. When he came (back), the Messenger of Allah (may peace be upon him) asked him to render his account. He said: This wealth is for you (i. e. for the public treasury) and this is a gift (presented to me). The Messenger of Allah (may peace be upon him) said: You should have remained in the house of your father and your mother, until your gift came to you if you spoke the truth; then he addressed us. He praised God and extolled Him, and afterwards said: I appoint a man from you to a responsible post sharing with the authority that God has entrusted to me, and he comes to me saying: This wealth is for you (i. e. for the public treasury) and this is a gift presented to me. Why did he not remain in the house of his father and his mother and his gift came to him, if he was truthful? By God, any one of you will not take anything from (the public funds) without any justification, but will meet his Lord carrying it on himself on the Day of judgment. I will recognise any one of you meeting Allah and carrying a growling camel, or a cow bellowing or a goat bleating. Then he raised his hands so high that whiteness of his armpits could be seen. Then he said: O my Lord, I have conveyed (Thy Commandments). The narrator says: My eyes saw (the Holy Prophet standing in that pose) and my ears heard (what he said).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4512]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4512

This tradition has been hanoed down through a different chain of transmitters on the authority of Hisham with aslight variation in the wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4513]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4513

It has been narrated on the authority of Abu Humaid as-Sa'idi that the Messenger of Allah (may peace be upon him) appointed a man in charge of Sadaqa (authorising him to receive charity from the people on behalf of the State). He came (back to the Holy prophet) with a large number of things and started saying: This is for you and this has been presented to me as a gift. Here follows the tradition that has gone before except that 'Urwa (one of the narrators in the chain of transmitters) asked Abu Humaid: Did you hear it from the Messenger of Allah (himself) (may peace be upon him)? He replied: My ears heard it from his mouth.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4514]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4514

It has been reported on the authority of 'Adi b. 'Amira al-Kindi who said: I heard the Messenger of Allah (may peace be upon him) say: Whoso from you is appointed by us to a position of authority and he conceals from us a needle or something smaller than that, it would be misappropriation (of public funds) and will (have to) produce it on the Day of Judgment. The narrator says: A dark-complexioned man from the Ansar stood up-I can visualise him still-and said: Messenger of Allah, take back from me your assignment. He said: What has happened to you? The man said: I have heard you say so and so. He said: I say that (even) now: Whoso from you is appointed by as to a position of authority, he should bring everything, big of small, and whatever he is given therefrom he should take, and he should restrain himself from taking that which is forbidden.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4515]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4515

This hadith has been narrated on the authority of Isma'il with the same chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4516]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4516

Adi b. 'Amira al-Kindi heard Allah's Messenger (may peace be upon him) as saying (as) was narrated in the (above-mentioned) hadith.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4517]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4517

It has been narrated on the authority of Ibn Juraij that the Qur'anic injunction:" 0 you who believe, obey Allah, His Apostle and those in authority from amongst You" (iv. 59) -was revealed in respect of 'Abdullah b. Hudhafa b. Qais b. Adi al-Sahmi who was despatched by the Holy Prophet (may peace be upon him) as leader of a military campaign. The narrator said: He was informed of this fact by Ya'la b. Muslim who was informed by Sa'id b. Jubair who in turn was informed by Ibn Abbas.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4518]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4518

It has been narrated on the authority of Abu Huraira that the Holy prophet (may peace be upon him) said: Whoso obeys me obeys God, and whoso disobeys me disobeys God. Whoso obeys the commander (appointed by me) obeys me, and whoso disobeys the commander disobeys me. The same tradition transmitted by different persons omits the portion: And whose disobeys the commander disobeys me.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4519]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4519

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Whoso obeys me obeys God; and whose disobeys me disobeys God. Whoso obeys my commander obeys me, and whoso disobeys my commander disobeys me.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4520]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4520

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4521]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4521

This hadith has been narrated on the authority of Abu Huraira by more than one chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4522]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4522

Hammam b. Munabbih has transmitted this hadith on the authority of Abu Huraira.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4523]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4523

According to one version of the tradition, the Messenger of Allah (may peace be upon him) said: Whoso obeys the commander. He did not say:" My commander."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4524]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4524

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: It is obligatory for you to listen to the ruler and obey him in adversity and prosperity, in pleasure and displeasure, and even when another person is given (rather undue) preference over you.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4525]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4525

It has been narrated on the authority of Abu Dharr who said: My friend (i. e. the Holy Prophet) advised me to listen (to the man in position of authority) and obey (him) even if he were a slave maimed (and disabled).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4526]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4526

In another version of the tradition, we have the wording:" An Abyssinian slave maimed and disabled."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4527]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4527

Abu 'Imran narrated this hadith with a slight change of wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4528]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4528

It has been narrated on the authority of Yahya b. Husain who learnt the tradition from his grandmother. She said that she heard the Holy Prophet (may peace be upon him) delivering his sermon on the occasion of the Last Pilgrimage. He was saying: If a slave is appointed over you and he conducts your affairs according to the Book of Allah, you should listen to him and obeey (his orders).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4529]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4529

This hadith has been transmitted on the authority of Shu'ba with the same chain of transmitters, and he said:" a negro slave".


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4530]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4530

In other versions of the above tradition, the wordings are" an Abyssinian slave." and" a maimed Abyssinian slave".


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4531]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4531

Another version of the tradition does not qualify the slave with the epithets" maimed,"" an Abyssinian" but makes the addition:" I have heard the Holy Prophet (may peace be upon him) (say this) at Mina or 'Arafat."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4532]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4532

It has been narrated on the authority of Yahya b. Husain who learnt the tradition from his grandmother. Umm Husain. He said': I heard her say: I performed Hajjat-ul-Wada' in the company of the Messenger of Allah (may peace be upon him). He said a lot of things (on this occasion). Then I heard him say: If a maimed slave is appointed a commander over you the narrator says: I think she said:" a black stave" who leads you according to the Book of Allah, then listen to him and obey him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4533]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4533

It has been narrated on the authority of Ibn 'Umar that the Holy Prophet (may peace be upon him) said: It is obligatory upon a Muslim that he should listen (to the ruler appointed over him) and obey him whether he likes it or not, except that he is ordered to do a sinful thing. If he is ordered to do a sinful act, a Muslim should neither. listen to him nor should he obey his orders.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4534]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4534

This hadith has been transmitted on the authority of 'Ubaidullah.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4535]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4535

It has been narrated on the authority of Abu 'Abd al-Rahman from 'Ali that the Messenger of Allah (may peace be upon him) sent a force (on a mission) and appointed over them a man. He kindled a fire and said: Enter it. Some people made up their minds to enter it (the fire), (carrying out the order of their commander), but the others said: We fled from the fire (that's why we have come into the fold of Islam). The matter was reported to the Messenger of Allah (may peace be upon him). He said to those who Contemplated entering (the fire at the order of their commander): If you had entered it, you would have remained there until the Day of Judgment. He commanded the act of the latter group and said: There is no submission in matters involving God's disobedience or displeasure. Submission is obligatory only in what is good (and reasonable).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4536]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4536

It has been narrated on the authority of 'All who said: The Mersenger of Allah (may peace be upon him) sent an expeditionand appointed over the Mujahids a man from the Ansar. (While making the appointment), he ordered that his work should be listened to and obeyed. They made him angry in a matter. He said: Collect for me dry wood. They collected it for him. Then he said: Kindle a fire. They kindled (the fire). Then he said: Didn't the Messenger of Allah (may peace be upon him) order you to listen to me and obey (my orders)? They said: Yes. He said: Enter the fire. The narrator says: (At this), they began to look at one another and said: We fled from the fire to (find refuge with) the Messenger of Allah (may peace be upon him) (and now you order us to enter it). They stood quiet until his anger cooled down and the fire went out. When they returned, they related the incident to the Messenger of Allah (may peace be upon him). He said: If they had entered it, they would not have come out. Obedience (to the commander) is obligatory only in what is good.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4537]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4537

This hadith has been transmitted on the authority of A'mash.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4538]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4538

It has been narrated on the authority of" Ubida who learnt the tradition from his father who, in turn, learnt it from his own father. 'Ubada's grandfather said: The Messenger of Allah (may peace be upon him) took an oath of allegiance from us on our listening to and obeying the orders of our commander in adversity and prosperity, in pleasure and displeasure (and even) when somebody is given preference over us, on our avoiding to dispute the delegation of powers to a person deemed to be a fit recipient thereof (in the eye of one who delegates it) and on our telling the truth in whatever position we be without fearing in the matter ef Allah the reproach of the reproacher.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4539]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4539

This hadith has been narrated on the authority of 'Ubada b. Walid with the same chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4540]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4540

The same tradition has been handed down through more than one chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4541]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4541

It has been narrated on the authority of Junida b. Abu Umayya who said: We called upon 'Ubada b. Samit who was ill and said to him: May God give you health I Narrate to us a tradition which God may prove beneficial (to us) and which you have heard from the Messenger of Allah (may peace be upon him). He said: The Messenger of Allah (may peace be upon him) called us and we took the oath of allegiance to him. Among the injunctions he made binding upon us was: Listening and obedience (to the Amir) in our pleasure and displeasure, in our adversity and prosperity, even when somebody is given preference over us, and without disputing the delegation of powers to a man duly invested with them (Obedience shall be accorded to him in all circumstances) except when you have clear signs of his disbelief in (or disobedience to) God-signs that could be used as a conscientious justification (for non-compliance with his orders).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4542]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4542

It has been narrated on the authority of Abu Huraira that the Prophet of Allah (may peace be upon him) said: A commander (of the Muslims) is a shield for them. They fight behind him and they are protected by (him from tyrants and aggressors). If he enjoins fear of God, the Exalted and Glorious, and dispenses justice, there will be a (great) reward for him; and if he enjoins otherwise, it redounds on him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4543]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4543

It has been narrated by Abu Huraira that the Holy Prophet (may pceace be upon him) said: Banu Isra'il were ruled over by the Prophets. When one Prophet died, another succeeded him; but after me there is no prophet and there will be caliphs and they will be quite large in number. His Companions said: What do you order us to do (in case we come to have more than one Caliph)? He said: The one to whom allegiance is sworn first has a supremacy over the others. Concede to them their due rights (i. e. obey them). God (Himself) will question them about the subjects whom He had entrusted to them.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4544]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4544

The same tradition has been transmitted by a different chain of narrators.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4545]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4545

It has been narrated on the authority of 'Abdullah who said: The Messenger of Allah (may peace be upon him) said: After me there will be favouritism anad many things that you will not like. They (his Companions) said: Messenger of Allah, what do you order that one should do it anyone from us has to live through such a time? He said: You should discharge your own responsibility (by obeying your Amir), and ask God to cuncede your right (by guiding the Amir to the right path or by replacing him by one more just and God-fearing).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4546]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4546

It has been narrated on the authority of 'Abd al-Rahman b. Abd Rabb al-Ka'ba who said: I entered the mosque when 'Abdullah b. 'Amr b. al-'As was sitting in the shade of the Ka'ba and the people had gathered around him. I betook myself to them and sat near him. (Now) Abdullah said: I accompanied the Messenger of Allah (may peace be upon him) on a journey. We halted at a place. Some of us began to set right their tents, others began to compete with one another in shooting, and others began to graze their beasts, when an announcer of the Messenger of Allah (may peace be upon him) announced that the people should gather together for prayer, so we gathered around the Messenger of Allah (may peace be upon him). He said: It was the duty of every Prophet that has gone before me to guide his followers to what he knew was good for them and warn them against what he knew was bad for them; but this Umma of yours has its days of peace and (security) in the beginning of its career, and in the last phase of its existence it will be afflicted with trials and with things disagreeable to you. (In this phase of the Umma), there will be tremendous trials one after the other, each making the previous one dwindle into insignificance. When they would be afflicted with a trial, the believer would say: This is going to bring about my destruction. When at (the trial) is over, they would be afflicted with another trial, and the believer would say: This surely is going to be my end. Whoever wishes to be delivered from the fire and enter the garden should die with faith in Allah and the Last Day and should treat the people as he wishes to be treated by them. He who swears allegiance to a Caliph should give him the piedge of his hand and the sincerity of his heart (i. e. submit to him both outwardly as well as inwardly). He should obey him to the best of his capacity. It another man comes forward (as a claimant to Caliphate), disputing his authority, they (the Muslims) should behead the latter. The narrator says: I came close to him ('Abdullah b. 'Amr b. al-'As) and said to him: Can you say on oath that you heard it from the Messenger of Allah (may peace be upon him)? He pointed with his hands to his ears and his heart and said: My ears heard it and my mind retained it. I said to him: This cousin of yours, Mu'awiya, orders us to unjustly consume our wealth among ourselves and to kill one another, while Allah says:" O ye who believe, do not consume your wealth among yourselves unjustly, unless it be trade based on mutual agreement, and do not kill yourselves. Verily, God is Merciful to you" (iv. 29). The narrator says that (hearing this) Abdullah b. 'Amr b. al-As kept quiet for a while and then said: Obey him in so far as he is obedient to God; and diqobey him in matters involving disobedience to God.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4547]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4547

This hadith has been narrated on the authority of A'mash with a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4548]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4548

It has been narrated on the authority of 'Abd Rabb al-Ka'ba as-Sa'idl who said: I saw a group of people near the Ka'ba.... Then he narrated the tradition as narrated by A'mash.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4549]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4549

It has been narrated on the authority of Usaid b. Hudair that a man from the Ansar took the Messenger of Allah (may peace be upon him) aside and said to him: Will you not appoint me governor as you have appointed so and so? He (the Messenger of Allah) said: You will surely come across preferential treatment after me, so you should be patient until you meet me at the Cistern (Haud-i-Kauthar).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4550]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4550

This tradition has been narrated on the same authority through a different chain of transmitters. Another version of the tradition narrated on the authority of Shu'ba does not include the words:" He took the Messenger of Allah (may peace be upon him) aside."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4551]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4551

It has been narrated on the authority of Alqama b. Wai'l al-Hadrami who learnt the tradition from his father. The latter said: Salama b. Yazid al-ju'afi asked the Messenger of Allah (may peace be upon him): Prophet of Allah, what do you think if we have rulers who rule over us and demand that we discharge our obligations towards them, but they (themselves) do not discharge their own responsibilities towards us? What do you order us to do? The Messenger of Allah (may peace be upon him) avoided giving any answer. Salama asked him again. He (again) avoided giving any answer. Then he asked again-it was the second time or the third time-when Ash'ath b. Qais (finding that the Holy Prophet was unnecessarily being pressed for answer) pulled him aside and said: Listen to them and obey them, for on them shall he their burden and on you shall be your burden.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4552]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4552

It has been narrated through a different chain of transmitters. on the authority of Simak who said: Ash'ath b. Qais pulled him (Salama b. Yazid) when the Messenger of Allah (may peace be upon him) said: Listen to them and obey them, for on them shall be the burden of what tney do and on you shall be the burden of what you do.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4553]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4553

It has been narrated on the authority of Hudhaifa b. al-Yaman who said: People used to ask the Messenger of Allah (may peace be upon him) about the good times, but I used to ask him about bad times fearing lest they overtake me. I said: Messenger of Allah, we were in the midst of ignorance and evil, and then God brought us this good (time through Islam). Is there any bad time after this good one? He said: Yes. I asked: Will there be a good time again after that bad time? He said: Yes, but therein will be a hidden evil. I asked: What will be the evil hidden therein? He said: (That time will witness the rise of) the people who will adopt ways other than mine and seek guidance other than mine. You will know good points as well as bad points. I asked: Will there be a bad time after this good one? He said: Yes. (A time will come) when there will be people standing and inviting at the gates of Hell. Whoso responds to their call they will throw them into the fire. I said: Messenger of Allah, describe them for us. He said: All right. They will be a people having the same complexion as ours and speaking our language. I said: Messenger of Allah, what do you suggest if I happen to live in that time? He said: You should stick to the main body of the Muslims and their leader. I said: If they have no (such thing as the) main body and have no leader? He said: Separate yourself from all these factions, though you may have to eat the roots of trees (in a jungle) until death comes to you and you are in this state.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4554]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4554

It his been narrated through a different chain of transmitters, on the authority of Hudhaifa b. al-Yaman who said: Messenger of Allah, no doubt, we had an evil time (i. e. the days of Jahiliyya or ignorance) and God brought us a good time (i. e. Islamic period) through which we are now living Will there be a bad time after this good time? He (the Holy Prophet) said: Yes. I said: Will there be a good time after this bad time? He said: Yes. I said: Will there be a bad time after good time? He said: Yes. I said: How? Whereupon he said: There will be leaders who will not be led by my guidance and who will not adopt my ways? There will be among them men who will have the hearts of devils in the bodies of human beings. I said: What should I do. Messenger of Allah, if I (happen) to live in that time? He replied: You will listen to the Amir and carry out his orders; even if your back is flogged and your wealth is snatched, you should listen and obey.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4555]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4555

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who defected from obedience (to the Amir) and separated from the main body of the Muslims-if he died in that state-would die the death of one belonging to the days of Jahiliyya (i. e. would not die as a Muslim). One who fights under the banner of a people who ate blind (to the cause for which they are fighting. i. e. do not know whether their cause is just or otherwise), who gets flared up with family pride, calls, (people) to fight for their. family honour, and supports his kith and kin (i. e. fignts not for the cause of Allah but for the sake of this family or tribe) -if he is killed (in this fight), he dies as one belonging to the days of Jhiliyya. Whoso attacks my Umma (indiscriminately) killing the righteous and the wicked of them, sparing not (even) those staunch in faith and fulfilling not his promise made with those who have been given a pledge of security-he has nothing to do with me and I have nothing to do with him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4556]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4556

The same tradition has been narrated by the same authority through another chain of transmitters with a slight difference in wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4557]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4557

It has been narrated (through a different chain of transmitters) on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Who defected from obedience (to the Amir) and separated from the main body of the Muslim-then he died in that state-would die the death of one belonging to the days of Jahillyya. And he who is killed under the banner of a man who is blind (to the cause for which he is fighting), who gets flared up with family pride and fights for his tribe-is not from my Umma, and whoso from my followers attacks my followers (indiscriminately) killing the righteous and the wicked of them, sparing not (even) those staunch in faith and fulfilling not his obligation towards them who have been given a pledge (of security), is not from me (i. e. is not my follower).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4558]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4558

This hadlth has been narrated on the authority of Jarir with the same chain of transmitters with a slight variation in wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4559]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4559

It has been narrated on the authority of Ibn 'Abbas that the messenger of Allah (may peace be upon him) said: One who found in his Amir something which he disliked should hold his patience, for one who separated from the main body of the Muslims even to the extent of a handspan and then he died would die the death of one belonging to the days of Jahiliyya.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4560]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4560

It has been narrated (through a different chain of transmitters) on the authority of Ibn Abbas that the Messenger of Allah (may peace be upoh him) said: One who dislikes a thing done by his Amir should be patient over it, for anyone from the people who withdraws (his obedience) from the government, even to the extent of a handspan and died in that conditions, would die the death of one belonging to the days of jahilliyya.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4561]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4561

It has been narrated on the authority of Ibn 'Abdullah al-Bajali that the Messenger of Allah (may peace be upon him) said: One who is killed under the banner of a man who is blind (to his just cause), who raises the slogan of family or supports his own tribe, dies the death of one belonging to the days of Jahiliyya.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4562]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4562

It has been reported on the authority of Nafi, that 'Abdullah b. Umar paid a visit to Abdullah b. Muti' in the days (when atrocities were perpetrated on the People Of Medina) at Harra in the time of Yazid b. Mu'awiya. Ibn Muti' said: Place a pillow for Abu 'Abd al-Rahman (family name of 'Abdullah b. 'Umar). But the latter said: I have not come to sit with you. I have come to you to tell you a tradition I heard from the Messenger of Allah (may peace be upon him). I heard him say: One who withdraws his band from obedience (to the Amir) will find no argument (in his defence) when he stands before Allah on the Day of Judgment, and one who dies without having bound himself by an oath of allegiance (to an Amir) will die the death of one belonging to the days of Jahillyya.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4563]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4563

It has been narrated on the authority of Abu 'Umar that he visited Ibn Muti', and related from the Holy Prophet (may peace be upon him) the tradition that has gone before.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4564]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4564

The same tradition has been transmitted by a different chain of narrators.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4565]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4565

It has been narrated on the authority of 'Arfaja who said: I have heard the Messenger of Allah (may peace be upon him) say: Different evils will make their appearance in the near future. Anyone who tries to disrupt the affairs of this Umma while they are united you should strike him with the sword whoever he be. (If remonstrance does not prevail with him and he does not desist from his disruptive activities, he is to be killed.)


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4566]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4566

In another version of the tradition narrated on the same authority through a different chains of transmitters we have the words:" Kill him."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4567]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4567

It has been narrated (through a still different chain of transmitters) on the Same authority (i. e. 'Arfaja) who said similarly-but adding:" Kill all of them." I heard the Messenger of Allah (may peace be upon him) say: When you are holding to one single man as your leader, you should kill who seeks to undermine your solidarity or disrupt your unity.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4568]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4568

It has been narrated on the authority of Aba Sa'id al-Khudri that the Messenger of Allah (may peace be upon him) said: When oath of allegiance has been taken for two caliphs, kill the one for whom the oath was taken later.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4569]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4569

It has been narrated on the authority of Umm Salama that the Messenger of Allah (may peace be upon him) said: In the near future there will be Amirs and you will like their good deeds and dislike their bad deeds. One who sees through their bad deeds (and tries to prevent their repetition by his band or through his speech), is absolved from blame, but one who hates their bad deeds (in the heart of his heart, being unable to prevent their recurrence by his hand or his tongue), is (also) fafe ( so far as God's wrath is concerned). But one who approves of their bad deeds and imitates them is spiritually ruined. People asked (the Holy Prophet): Shouldn't we fight against them? He replied: No, as long as they say their prayers.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4570]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4570

It has been narrated (through a different chain of tmnamitters) on the authority of Umm Salama (wife of the Holy Prophet) that he said: Amirs will be appointed over you, and you will find them doing good as well as bad deeds. One who hates their bad deeds is absolved from blame. One who disapproves of their bad deeds is (also) safe (so far as Divine wrath is concerned). But one who approves of their bad deeds and imitates them (is doomed). People asked: Messenger of Allah, shouldn't we fight against them? He replied: No, as long as they say their prayer. (" Hating and disapproving" refers to liking and disliking from the heart.)


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4571]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4571

Another version of the tradition narrated on the same authority attributes the same words to the Messenger of Allah (may peace be upon him) except that it replaces kariha with ankhara and vice versa.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4572]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4572

Another version omits a portion at the end of the tradition-a portion which begins with man radiya wa taba and ends with the last word of the tradition.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4573]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4573

It has been narrated on the authority of 'Auf b. Malik that the Messenger of Allah (may peace be upon him) said: The best of your rulers are those whom you love and who love you, who invoke God's blessings upon you and you invoke His blessings upon them. And the worst of your rulers are those whom you hate and who hate you and whom you curse and who curse you. It was asked (by those present): Shouldn't we overthrow them with the help of the sword? He said: No, as long as they establish prayer among you. If you then find anything detestable in them. You should hate their administration, but do not withdraw yourselves from their obedience.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4574]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4574

It has been narrated on the authority of Auf b. Malik al-Ashja'i who said that he heard the Messenger of Allah (may peace be upon him) say: The best of your rulers are those whom you love and who love you, upon whom you invoke God's blessings and who invoke His blessing upon you. And the worst of your rulers are those whom you hate and who hate you, who curse you and whom you curse. (Those present) said: Shouldn't we overthrow them at this? He said: No, as long as they establish prayer among you. No, as long as they establish prayer among you. Mind you! One who has a governor appointed over him and he finds that the governor indulges in an act of disobedience to God, he should condemn the governor's act, in disobedience to God, but should not withdraw himself from his obedience. Ibn Jabir said: Ruzaiq narrated to me this hadith. I asked him: Abu Miqdam, have you heard it from Muslim b. Qaraza or did he describe it to you and he heard it from 'Auf (b. Malik) and he transmitted this tradition of Allah's Messenger (may peace be upon him)? Upon this Ruzaiq sat upon his knees and facing the Qibla said: By Allah, besides Whom there is no other God, I heard it from Muslim b. Qaraza and he said that te had heard it from Auf (b. Malik) and he said that he had heard it from the Messenger of Allah (may peace be upon him).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4575]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4575

The above tradition has been narrated through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4576]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4576

It has been narrated on the authority of Jabir who said: We were one thousand and four hundred on the Day of Hudaibiya. We swore fealty to hiin (the Holy Prophet) and 'Umar was holding the latter's hand (when he was sitting) under the tree (called) Samura (to administer the oath to the Companions). The narrator added: We took oath to the effect that we would not flee (from the battlefield if there was an encounter with the Meccans), but we did not take oath to fight to death.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4577]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4577

It has been narrated (through a different chain of transmitters) on the authority of Jabir who said: While swearing fealty to the Holy Prophet (may peace be upon him) we did not take the oath to death but that we would not run away (from the battlefield).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4578]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4578

It has been narrated on the authority of Abu Zubair who heard Jabir being questioned as to how many people were there on the Day of Hudaibiya He replied: We wore fourteen hundred. We swore fealty to him, and Umar was holding his hand while he was sitting Under the tree (to administer the oath). The tree was Samura (a wild tree found in desers). All of as took tha oath of fealty at his hands except Jadd b. Qais al-Ansari who hid himself under the belly of his camel.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4579]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4579

It has been narrated (through a different chain of transmitters) on the authority of Abu Zubair who heard Jabir being questioned as to whether the Holy Prophet (may peace be upon him) took the oath of fealty at Dhu'l-Hulaifa. He said: No! But he offered his prayers at that place, and he administered the oath of fealty nowhere except near the tree in (the plain oo Hudaibiya. Ibn Juraij said that he was informed by Abu Zabair who heard Jabir b. Abdullah say: The Holy Prophet (may peace be upon him) prayed over the well at Hudaibiya (as a result of which its scanty water rose up and increased so as to be sufficient for the 1400 or 1500 men who had encamped at the place).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4580]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4580

It has been narrated (through a different chain of transmitters) on the authority of Jabir who said: We were one thousand and four hundred on the Day of Hudaibiya when the Holy Prophet (may peace be upon him) said to us: Today you are the best people on the earth. And Jabir said: If I had the eyesight, I could show you the place of the tree.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4581]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4581

It has been narrated on the authority of Salim b. Abu al-Ja'd who said: I asked Jabir b. 'Abdullah about the number of the Companions (of the Holy Prophet who took the oath of fealty under) the tree. He said: If we were a hundred thousand, it (i. e. the water in the well at Hudaibiya) would have sufficed us, but actually we were one thousand and five hundred.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4582]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4582

It has been narrated on the authority of Jabir who said: If we had been a hundred thousand in number, it (the water) would have sufficed us, but actually we were fifteen hundred.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4583]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4583

It has been narrated (through a different chain of transmitters) on the authority of Salim b. al-Ja'd who said: I asked Jabir: How many were you on the Day of Hudaibiya? He said: One thousand and four hundred.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4584]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4584

It has been narrated on the authority of 'Abdullah b. Abu Aufa who said: The Companions of the Tree (i e. those who swore fealty under the tree) were one thousand and three hundred, and the people of Aslam tribe were one-eighth of the Muhajirs.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4585]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4585

The same tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4586]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4586

It has been narrated on the authority of Ma'qil b. Yasar who aaid: I remember being present on the Day of the Tree, and the Holy Prophet (may peace be upon him) was taking the oath of the people and I was holding a twig of the tree over his head. We were fourteen hundred (in number). We did not take oath to the death, but to the effect that we would not run away from the battlefield.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4587]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4587

This hadith has been narrated on the authority of Yunus with the same chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4588]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4588

It has been narrated on the authority of Sa'id b. Musayyab who said: My father was one of those who swore fealty to the Messenger of Allah (may peace be upon him) near the tree. When we passed that way next year intending to perform the Hajj, the place of the tree was hidden to us. If you could point out clearly, you would (certainly) be knowing better.

It has also been narrated on the authority of Sa'id b. Musayyib who learnt from his father that they were with the Messenger of Allah (may peace be upon him) in the year of the Tree (i. e. in the year of the fealty of God's pleasure sworn under the tree at Hudaibiya), but next year they forgot the spot of the tree.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4589]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4589

The tradition has been narrated on the authority of Sa'id b. Musayyib who learnt it from his father. The latter said: I had seen the tree. When I came to the spot afterwards, I could not recognise it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4590]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4590

It has been narrated on the authority of Yazid b. Abu Ubaid (the freed slave of Salama b. al-Akwa') who said: 1 asked Salama as to what effect he had sworn fealty to the Messenger of Allah (may peace be upon him) on the Day of Hudaibiya. He said: To the effect that we will die fighting.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4591]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4591

The above tradition has also been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4592]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4592

It has been narrated on the authority of Abdullah b. Zaid who said: A person came to him and said: Here is Ibn Hanzala who is making people swear allegiance to him. He (, Abdullah) asked: To what effect? He replied: To the effect that they will die for him. 'Abdullah said: I will never swear allegiance to this effect after the Messenger of Allah (may peace be upon him).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4593]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4593

It has been narrated by Salama b. al-Akwa' that he visited al-Hajjaj who said to him: O son of al-Akwa', you have turned apostate and have come to live again in the desert with the Bedouins (after your migration). He said: No, but the Messenger of Allah (may peace be upon him) has permitted me to live in the desert.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4594]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4594

It has been reported on the authority of Mujashi' b. Mas'ud as-Sulami who said: I came to the Holy Prophet (may peace be upon him) to offer him my pledge of migration. He said: The period of migration has expired (and those who wereto get the reward for this great act of devotion have got it). You may now give your pledge to serve the cause of Islam, to strive in the way of Allah and to follow the path of virtue.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4595]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4595

It has been reported on the authority of Mujashi' b. Mas'ud who said: I brought my brother Abu Ma'bad to the Messenger of Allah (may peace he upon him) after the conquest of Mecca and said: Messenger of Allah, allow him to swear his pledge of migration at your hand. He said: The period of migration is over with those who had to do it (and now nobody can get this meritorious distinctions) I said: For what actions will you allow him to bind himself in oath? He said: (He can do so) for serving the cause of Islam, for fighting in the way of Allah and for fighting in the cause of virtue. Abd Uthman said: I met Abd Ma'bad and told him what I had heard from Mujashi'. He said: He has told the truth.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4596]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4596

Another version of the tradition transmitted on the authority of Asim has the same wording but does not mention the name of Abu Ma'bad.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4597]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4597

It has been narrated on the authority of Ibn 'Abbas that the Messenger of Allah (may peace be upon him) said on the day of the Conquest of Mecca: There is no Hijra now, but (only) Jihad (fighting for the cause of Islam) and sincerity of purpose (have great reward) ; when you are asked to set out (on an expedition undertaken for the cause of Islam) you should (readily) do so.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4598]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4598

The above tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4599]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4599

'A'isha reported that the Messenger of Allah (may peace be upon him) was asked about migration, whereupon he said: There is no migration after the Conquest (of Mecca), but Jihad and sincere intention. When you are asked to set out (for the cause of Islam), you should set out,


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4600]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4600

It has been narrated on the authority of Abu Sa'id al-Khudari that a Bedouin asked the Messenger of Allah (may peace be upon him) about Migration. He replied: Do you talk of Hijra? The affair of Hijra is very difficult. But have you got camels? The bedouin said: Yes. He asked: Do you pay the poor-rate payable on their account? He replied: Yes. He (the Holy Prophet) said: Go on doing good deeds (across the seas), for surely God will not leave any of your deeds unrewarded.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4601]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4601

This tradition has been handed down through a different chain of transmitter with the addition of the following words at the end:" Do you milk them on the day they arrive at the water? He replied: Yes."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4602]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4602

It has been narrated on the authority of 'A'isha, the wife of the Holy Prophet (may peace be upon him). She said: When the believing women migrated (to Medina) and came to the Messenger of Allah (may peace be upon him), they would be tested in accordance with the following words of Allah. the Almighty and Exalted:" O Prophet, when believing women come to thee to take the oath of fealty to thee that they will not associate in worship anything with God, that they will not steal. that, they will not commit adultery..." to the end of the verse (lx. 62).

Whoso from the believing women accepted these conditions and agreed to abide by them were considered to have offered themselves for swearing fealty. When they had (formally) declared their resolve to do so, the Messenger of Allah (may peace he upon him) would say to them: You may go. I have confirmed your fealty. By God, the hand of the Messenger of Allah (may peace be upon him) never touched the hand of a woman. He would take the oath of fealty from them by oral declaration. By God, the Messenger of Allah (may peace be upon him) never took any vow from women except that which God had ordered him to take, and his palm never touched the palm of a woman. When he had taken their vow, he would tell them that he had taken the oath from them orally.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4603]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4603

It has been narrated on the authority of 'Urwa that 'A'isha described to him the way the Holy Prophet (may peace be upon him) took the oath of fealty from women. She said: The Messenger of Allah (may peace be upon him) never touched a woman with his hand. He would only take a vow from her and when he had taken the (verbal) vow, he would say: You may go. I have accepted your fealty.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4604]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4604

It has been narrated on the authority of Abdullah b. 'Umar who said: We used to take oath to the Messenger of Allah (may peace be upon him) that we would listen to and obey his orders. He would tell us (to say in the oath): As far as it lies in my power.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4605]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4605

It has been narrated on the authority of Ibn 'Umar who said: The Messenger of Allah (may peace be upon him) inspected me on the battlefield on the Day of Uhud, and I was fourteen years old. He did not allow me (to take part in the fight). He inspected me on the Day of Khandaq-and I was fifteen yearsold, and he permitted me (to fight), Nafi' said: I came to 'Umar b. 'Abd al-'Aziz who was then Caliph, and narrated this tradition to him. He said: Surely, this is the demarcation between a minor and a major. So he wrote to his governors that they should pay subsistence allowance to one who was fifteen years old, but should treat those of lesser age among children.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4606]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4606

This tradition has been handed down through a different chain Of transmitters with the following change in the wording:" I was fourteen years old and he thought me too young (to participate in the fight)."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4607]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4607

It has been narrated on the authority of Ibn 'Umar who said: The Messenger of Allah (may peace be upon him) forbade that one should travel to the land of the enemy taking the Qur'an with him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4608]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4608

It has been narrated on the authority of Abdullah b. Umar that the Messenger of Allah (may peace be upon him) used to forbid that one should travel to the land of the enemy taking the Qur'an (with him) lest it should fall into the hands of the enemy.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4609]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4609

It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) said: Do not take the Qur'an on a journey with you, for I am afraid lost it should fall into the hands of the enemy. Ayyub (one of the narrators in the chain of transmitters) said: The enemy may seize it and may quarrel with you over it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4610]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4610

It has been narrated on the authority of Ibn 'Umar that the Messenger of Allah (may peace be upon him) had a race of the horses which had been especially prepared for the purpose from Hafya' to Thaniyyat al-Wada' (the latter being the winning post), and of those which had not been trained from Thaniyya to the mosque of Banu Zuraiq, and Ibn Umar was among those who took part in this race.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4611]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4611

This tradition has been handed down through another chain of transmitters with the addition of the following words from Abdullah b. 'Umar:" I came first in the race and my horse jumped into the mosque with me."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4612]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4612

It has been narrated on the authority of Ibn Umar that the Messenger of Allah (may peace be upon him) said: There will be great benefit in the forelock of the horses until the Day of judgment.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4613]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4613

The same tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4614]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4614

It has been narrated on the authority of Jarir b. Abdullah who said: I saw that the Messenger of Allah (may peace be upon him) was twisting the forelock of a horse with his fingers and he was saying: (A great) benefit. i. e. reward (for rearing them for Jihad) and spoils of war, has been tied to the forelocks of horses until the Day of Judgment.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4615]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4615

The above tradition has also been narrated on the authority of Yunus through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4616]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4616

The same tradition has been narrated on the authority of Urwat al-Bariqi who said that the Prophet (may peace be upon him) said: Great good is attached to the forelock of the horses until the Day of Judgment.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4617]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4617

'Urwat al-Bariqi reported Allah's Messenger (may peace be upon him) having said this: Good is tied to the forelock of the horses. It Was said to him: Messenger of Allah, why is it so? He (the Holy Prophet said): For reward and booty until the Day of Judgment.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4618]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4618

This hadith has been narrated with the same chain of transmitters with the difference that here instead of" Urwat al-Bariqi" there is" Urwa b. ja'd."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4619]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4619

A version of the tradition narrated on the authority of 'Urwat al-Bariqi does not mention (the words):" reward and booty".


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4620]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4620

A version of the tradition transmitted on the authority of 'Urwa b. al-ja'd does not mention" reward and booty".


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4621]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4621

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: There is a blessing in the forelocks of the war horses.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4622]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4622

A hadith like this has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4623]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4623

It has been narrated on the authority of Abn Huraira that the Messenger of Allah (may peace be upon him) used to dislike the Shikal horse.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4624]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4624

This tradition has been narrated on the authority of Sufyan with the addition from Abd ar-Razzaq (one of the narrators) explaining the meaning of shikal as a bone whose right back foot and left front foot or left back foot and right front foot are white.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4625]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4625

The tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4626]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4626

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace upon him) said: Allah has undertaken to look after the affairs of one who goes out to fight in His way believing in Him and affirming the truth of His Apostles. He is committed to His care that Re will either admit him to Paradise or bring him back to his home from where he set out with a reward or (his share of) booty. By the Being in Whose Hand is the life of Muhammad. If a person gets wounded in the way of Allah, he will come on the Day of Judgment with his wound in the same condition as it was when it was first inflicted; its colour being the colour of blood but its smell will be the smell of musk. By, the Being in Whose Hand is Muhammad's life, if it were not to be too hard upon the Muslime. I would not lag behind any expedition which is going to fight in the cause of Allah. But I do not have abundant means to provide them (the Mujahids) with riding beasts, nor have they (i. e. all of them) abundant means (to provide themselves with all the means of Jihad) so that they could he left behind. By the Being in Whose Hand is Mubammgls lac, I love to fight in the way of Allah and be killed, to fight and again be killed and to fight again and be killed.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4627]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4627

The same tradition has been melted through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4628]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4628

It has been narrated on the authority of Abu Huraira who said: Allah has undertaken to provide for one who leaves his home (only) to fight for His cause and to affirm the truth of His word; Allah will either admit him to Paradise or will bring him back home from where he had come out, with his reward and booty.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4629]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4629

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who is wounded in the way of Allah-and Allah knows better who is wounded in His way-will appear on the Day of Judgment with his wound bleediing. The colour (of its discharge) will be the colour of blood, (but) its smell will be the smell of musk.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4630]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4630

It has been narrated on the authority of Abu Haraira that the Messenger of Allah (may peace be upon him) said: Every wound received by a Muslim in the way of Allah will appear on the Day of Judgment in the same condition as it was when it was inflicted, and would be bleeding profusely. The colour (of its discharge) will be the colour of blood, but its smell will be the smell of musk. By the Being in Whose Hand is Muhammad's life, if it were not hard upon the Muslims, I would not lag behind any expedition undertaken for Jihad, but I do not possess abundant means to provide the Mujahids with riding animals, nor do they (i. e. all of them) have abundant means (to provide themselves with all the means of Jihad) to follow me, nor would it please their hearts to stay behind me.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4631]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4631

It has been narrated on the authority of Abu Huraira who said: I heard the Messenger of Allah (may peace be upon him) say: I would not stay behind (when) an expedition (for Jihad was being mobilised) if it were going to be too hard upon the believers.... This is followed by the same words as have appeared in the previous tradition, but this tradition has the same ending as the previous hadith with a slight difference in the wording:" By the Being in Whose Hand is my life, I love that I should be killed in the way of Allah; then I should be brought back to life and be killed again in His way...."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4632]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4632

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If it were not hard upon my Umma (to follow my example), I would not lag behind any expedition-as in the traditions gone before.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4633]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4633

Another version of the tradition narrated through a different chain of transmitters on the authority of Abu Huraira has the same wording as the previous tradition:" Allah takes care of one who goes out in the way of Allah" but ends in the words:" I would not lag behind any expedition which is undertaken to fight in the way of Allah, the Exalted."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4634]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4634

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said:" Nobody who dies and has something good for him with Allah will (ever like to) return to this world even though he were offered the whole world and all that is in its (as an inducement), except the martyr who desires to return and be killed in the world for the (great) merit of martyrdom that he has seen.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4635]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4635

It has been narrated on the authority of Anas b. Malik (through a different chain of transmitters) that the Messenger of Allah (may peace be upon him) said: Nobody who enters Paradise will (ever like to) return to this world even if he were offered everything on the surface of the earth (as an inducement) except the martyr who will desire to return to this world and be killed ten times for the sake of the great honour that has been bestowed upon him.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4636]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4636

It has been narrated on the authority of Abu Huraira who said: The Messenger of Allah (may peace be upon him) was asked: What deed could be an equivalent of Jihad in the way of Allah, the Almighty and Exalted? He answered: You do not have the strength to do that deed. The narrator said: They repeated the question twice or thrice. Every time he answered: You do not have the strength to do it. When the question was asked for the third time, he said: One who goes out for Jibad is like a person who keeps fasts, stands in prayer (constantly), (obeying) Allah's (behests contained in) the verses (of the Qur'an), and does not exhibit any lassitude in fasting and prayer until the Mujihid returns from Jihad in the way of Allah, the Exalted.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4637]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4637

This tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4638]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4638

It has been narrated on the authority of Nu'man b. Bashir who said: As I was (sitting) near the pulpit of the Messenger of Allah (may peace be upon him), a man said: I do not care if, after embracing Islam, I do not do any good deed (except) distributing drinking water among the pilgrims. Another said: I do not care if, after embracing Islam, I do not do any good deed beyond maintenance service to the Sacred Mosque. Another said: Jihad in the way of Allah is better than what you have said. 'Umar reprimanded them and said: Don't raise your voices near the pulpit of the Messenger of Allah (may peace be upon him) on Friday. When prayer was over, I entered (the apartment of the Holy Prophet) and asked his verdict about the matter in which they had differed. (It was upon this that) Allah, the Almighty and Exalted, revealed the Qur'anic verse:" Do you make the giving of drinking water to the pilgrims and the maintenance of the Sacred Mosque equal to (the service of those) who believe in Allah and the Last Day and strive hard in the cause of Allah. They are not equal in the sight of God. And Allah guides not the wrongdoing people" (ix. 20). This tradition has been narrated on the authority of Nu'man b. Bashir through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4639]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4639

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) said: Leaving (for Jihad) in the way of Allah in the morning or in the evening (will merit a reward) better than the world and all that is in it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4640]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4640

It has been narrated on the authority of Sahl b. Sa'd as-Sa'idi that the Messenger of Allah (may peace be upon him) said: The journey undertaken by a person in the morning (for Jihad) in the way of Allah (will merit a reward) better than the world and all that is in it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4641]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4641

It has been narrated on the authority of Sahl b. Sa'd as-Sa'idi that the Messenger of Allah (may peace be upon him) said: A journey undertaken in the morning or evening (fond Jihad) in the way of Allah (will merit a reward) better than the world and all that is in it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4642]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4642

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: If some persons of my Umma (were not to undertake the hardships of Jihad), and he (Abu Huraira) then narrated the rest of the hadith and then said: A journey undertaken for jihad in the evening or morning merits a reward better than the world and all that is in it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4643]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4643

It has been narrated on the authority of Abu Ayyub that the Messenger of Allah (may peace be upon him) said: A journey undertaken in the morning or evening (for Jihad) in the way of Allah is better than (anything) on which the sun rises or sets.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4644]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4644

This tradition has been narrated on the authority of Abu Ayyub through a different chain of transmitters having the same wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4645]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4645

It has been narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah (may peace be upon him) said (to him): Abu Sa'id, whoever cheerfully accepts Allah as his Lord, Islam as his religion and Mubammad as his Apostle is necessarily entitled to enter Paradise. He (Abu Sa'id) wondered at it and said: Messenger of Allah, repeat it for me. He (the Messenger of Allah) did that and said: There is another act which elevates the position of a man in Paradise to a grade one hundred (higher), and the elevation between one grade and the other is equal to the height of the heaven from the earth. He (Abu Sa'id) said: What is that act? He replied: Jihad in the way of Allah! Jihad in the way of Allah!


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4646]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4646

It has been narrated on the authority of Abu Qatada that the Messenger of Allah (may peace be upon him) stood up among them (his Companions) to deliver his sermon in which he told them that Jihad in the way of Allah and belief in Allah (with all His Attributes) are the most meritorious of acts. A man stood up and said: Messenger of Allah, do you think that if I am killed in the way of Allah, my sins will be blotted out from me? The Messenger of Allah (may peace be upon him) said: Yes, in case you are killed in the way of Allah and you were patient and sincere and you always fought facing the enemy, never turming your back upon him. Then he added: What have you said (now)? (Wishing to have further assurance from him for his satisfaction), he asked (again): Do you think if I am killed in the way of Allah, all my sins will be obliterated from me? The Messenger of Allah (may peace be upon him) said: Yes, it you were patient and sincere and always fought facing the enemy and never turning your back upon him, (all your lapses would be forgiven) except debt. Gabriel has told me this.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4647]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4647

The tradition has been narrated through a different chain of transmitters on the authority of Abu Qatada who said: A man came to the Messenger of Allah (may peace be upon him) while he was on the pulpit and said: Do you think if I am killed in the way of Allah... (except this difference in its beginning, the rest of the tradition is the same as the previous one).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4648]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4648

Another version of the tradition differently transmitted begins with the words:" A man came to the Messenger of Allah (may peace be upon him) and he was sitting on the pulpit.... He said: What do you find if I strike with the sword?" (The rest of the tradition is the same as the previous one.)


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4649]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4649

It has been reported on the authority of 'Amr b. al-'As that the Messenger of Allah (may peace be upon him) said: All the sins of a Shahid (martyr) are forgiven except debt.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4650]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4650

It has been reported on the authority of Amr b. al-'As through a different chain of transmitters that the Messenger of Allah (may peace be upon him) said: Death in the way of Allah blots out everything except debt.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4651]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4651

It has been narrated on the authority of Masruq Who said: We asked 'Abdullah about the Qur'anic verse:" Think not of those who are slain in Allah's way as dead. Nay, they are alive, finding their sustenance in the presence of their Lord.." (iii. 169). He said: We asked the meaning of the verse (from the Holy Prophet) who said: The souls, of the martyrs live in the bodies of green birds who have their nests in chandeliers hung from the throne of the Almighty. They eat the fruits of Paradise from wherever they like and then nestle in these chandeliers. Once their Lord cast a glance at them and said: Do ye want anything? They said: What more shall we desire? We eat the fruit of Paradise from wherever we like. Their Lord asked them the same question thrice. When they saw that they will continue to be asked and not left (without answering the question). they said: O Lord, we wish that Thou mayest return our souls to our bodies so that we may be slain in Thy way once again. When He (Allah) saw that they had no need, they were left (to their joy in heaven).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4652]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4652

It has been narrated on the authority of Abu Sa'id Khudri that a man came to the Holy Prophet (may peace he upon him) and said: Who is the best of men? He replied: A man who fights in the way of Allah spending his wealth and staking his life. The man then asked: Who is next to him (in excellence)? He said: Next to him is a believer who lives in a mountain gorge worshipping hid Lord and sparing men from his mischief.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4653]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4653

It has been narrated (through a diferent chain of transmetters) on the same authority (i. e. Abu Sa'id Khadri) who said: A man asked: Messenger of Allah, which of men is the best? He said: A believer who fights staking his life and spending his wealth in the way of Allah. He asked: Who is next to him (in excellence)? He said: Next to him is a man who lives an isolated life in a mountain gorge, worshipping his Lord and sparing men from his mischief.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4654]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4654

A version of the tradition narrated on the authority of Ibn Shihab has a little differently worded ending. i. e." A man in a mountain valley." but did not mention" next to him a man who...."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4655]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4655

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: Of the men he lives the best life who holds the reins of his horse (ever ready to march) in the way of Allah, flies on its back whenever he hears a fearful shriek, or a call for help, flies to it seeking death at places where it can be expected. (Next to him) is a man who lives with his sheep at a hill-top or in a valley, says his prayers regularly, gives Zakat and worships his Lord until death comes to him. There is no better person among men except these two.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4656]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4656

This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4657]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4657

Two more versions of the tradition narrated by 'Abdullah b. Badr and Abu Huraira, respectively, have been handed down through different chains of transmitters with negligible difference in the wording.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4658]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4658

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: God laughs at the two men both of whom will enter Paradise (though) one of them kills the other. They said: Messenger of Allah, how is it? He said: One of them fights in the way of Allah, the Almighty and Exalted. and dies a martyr. Then God turns in mercy to the murderer who embraces Islam, fights in the way of Allah, the Almighty and Exalted, and dies a martyr.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4659]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4659

The same tradition has been narrated on the authority of Abu Zinad (with the same chain of transmitters).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4660]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4660

It has been reported on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: God laughs at the two men one of whom kills the other; both of them will enter Paradise. They (the Companions) said: How, Messenger of Allah? He said: One is slain (in the way of Allah) and enters Paradise. Then God forgives the other and guides him to Islam; then he fights in the way of Allah and dies a martyr.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4661]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4661

It has been narrated on the authority of Abu Huraira that the Messenger Allah (may peace be upon him) said: A disbeliever and a believer who killed him will never be gathered together in Hell.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4662]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4662

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: No two such persons shall be together in Hell as if one of them is such that his presence hurts the other. It was asked: Messenger of Allah, who are they? He said: A believer who killed a disbeliever and (then) kept to the right path."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4663]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4663

It has been narrated on the authority of Abu Mas'ud al-Ansari who said A man brought a muzzled she-camel and said: It is (offered) in the way of Allah. The Messenger of Allah (may peace be upon him) said: For this you will have seven hundred she-camels on the Day of Judgment all of which will be muzzled.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4664]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4664

A similar tradition has been narrated on the authority of al-A'mash.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4665]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4665

It has been narrated on the authority of Abu Mas'ud al-Ansari who said: A man came to the Messenger of Allah (may peace be upon him) and said: My riding beast has been killed, so give me some animal to ride upon. He (the Holy Prophet) said: I have none with me. A man said: Messenger of Allah, I can guide him to one who will provide him with a riding beast. The Messenger of Allah (may peace be upon him) said: One who guides to something good has a reward similar to that of its doer.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4666]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4666

The above tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4667]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4667

It has been narrated on the authority of Anas b. Malik that a young man from Aslam tribe said: Messenger of Allah, I wish to fight (in the way of Allah) but I don't have anything to equip myself with for fighting. He (the Holy Prophet) said: Go to so and so, for he had equipped himself (for fighting) but he fell ill. So, he (the young man) went to him and said: The Messenger of Allah (may peace be upon him) sends you his greetings and says that you should give me the equipage that you have provided yourself with. The man said (to his wife or maidservant): So and so, give him the equipage I have collected for myself and do not withhold anything from him. Do not withhold anything from him so that you may be blessed therein.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4668]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4668

It has been narrated on the authority of Zaid b. Kbalid al-Juhani that the Messenger of Allah (may peace be upon him) said: Anybody who equips a warrior (going to fight) in the way of Allah (is like one who actually) fights. And anybody who looks well after his family in his absence (is also like one who actually) fights.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4669]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4669

The above tradition has been narrated on the authority of Khalid al- Juhani who said: The Prophet of Allah (may peace be upon him) said: He who equips a warrior in the way of Allah (is like one who dctually fights) aud he who looks after the family of a warrior in the way of Allah in fact participated in the battle.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4670]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4670

It has been narrated on the authority of Abu Sa'id Khudri that the Messenger of Allah (may peace be upon him) sent a force to Banu Lihyan (who are from Banu Hudhail, and said: One man from every two and the reward (will be divided) between the two.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4671]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4671

The above tradition has also been narrated through two different chains of transmitters on the authority of Abu Sa'id Khudri and Yahya, respectively.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4672]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4672

It has been narrated (through a still different chain of transmitters) on the authority of Abu Sa'id Khudrl that the Messenger of Allah (may peace be upon him) despatched a force to Banu Lihyan. (and said: ) One man from every two should join the force. Then he said to those who stayed behind: Those of you who will look well after the family and wealth of those who are going on the expedition will be getting half the reward of the warriors.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4673]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4673

It has been narrated on the authority of Sulaimin b. Buraida who learnt the tradition from his father. The latter said that the Messenger of Allah (may peace be upon him) said: The sanctity of the wives of Mujahids is like the sanctity of their mothers for those who sit at home (i. e do not go out for Jihad). Anyone who stays behind looking after the family of a Mujahid and betrays his trust will be made to stand on the Day of judgment before the Mujahid who will take away from his meritorious deeds whatever he likes. So what do you think (will he leave anything)?


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4674]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4674

This tradition has been narrated by the same authority through different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4675]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4675

A version of the tradition narrated on the authority of 'Alqama b. Murthad has a differently worded end: It will be said to the Mujahid: Take from his noble deeds whatever you like. Then the Messenger of Allah (may peace be upon him) turned to us and asked: What do you think (will he leave anything)? - (i. e. he will take away everything).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4676]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4676

It has been narrated on the authority of Abu Ishaq, that he heard Bara' talking about the Qur'anic verse:" Those who sit (at home) from among the believers and those who go out for Jihad in the way of Allah are not aqual" (iv. 95). (He said that) the Messenger of Allah (may peace be upon him) ordered Zaid (to write the verse). He brought a shoulder-blade (of a slaughtered camel) and inscribed it (the verse) thereon. The son of Umm Maktum complained of his blindness to the Holy Prophet (may peace be upon him). (At this) descended the revelation:" Those of the believers who sit (at home) without any trouble (illness, incapacity, disability)" (iv. 95). The tradition has been handed down through two other chains of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4677]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4677

It has been narrated on the authority of Bara' who said: When the Qur'anic verse:" Those who sit (at home) from among mu'min" (iv. 94) was revealed, the son of Umm Maktum spoke to him (the Holy Prophet). (At this). the words:" other than those who have a trouble (illness)" were revealed.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4678]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4678

It has been reported on the authority of Jabir that a man said: Messenger of Allah, where shall I be if I am killed? He replied: In Paradise. The man threw away the dates he had in his hand and fought until he was killed (i. e. he did not wait until he could finish the dates).

In the version of the tradition narrated by Suwaid we have the words:" A man said to the Holy Prophet (may peace be upon him). on the day of Uhud......"


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4679]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4679

It has been reported on the authority of Bara! ' who stated: A man from Banu Nabit (one of the Ansar tribes) came to the Holy Prophet (may peace be upon him) and said: I testify that there is no god except Allah and that thou art His bondman and Messenger. Then he went forward and fought until he was killed. The Holy Prophet (may peace be upon him) said: He has done a little but shall be given a great reward.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4680]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4680

It has been reported on the authority of Anas b. Malik who said: The Messenger of Allah (may peace be upon him) sent Busaisah as a scout to see what the caravan of Abu Sufyan was doing. He came (back and met the Holy Prophet in his house) where there was nobody except myself and the Messenger of Allah. I do not remember whether he (Hadrat Anas) made an exception of some wives of the Holy Prophet (may peace be upon him) or not and told him the news of the caravan. (Having heard the news), the Messenger of Allah (may peace be upon him) came out (hurriedly), spoke to the people and said: We are in need (of men) ; whoever has an animal to ride upon ready with him should ride with us. People began to ask him permission for bringing their riding animals which were grazing on the hillocks near Medina. He said: No. (I want) only those who have their riding animals ready. So the Messenger of Allah (may peace be upon him) and his Companions proceeded towards Badr and reached there forestalling the polytheists (of Mecca). When the polytheists (also) reached there, the Messenger of Allah (may peace be upon him) said: None of you should step forward to (do) anything unless I am ahead of him. The polytheists (now) advanced (towards us), and the Messenger of Allah (may peace be upon him) said. Get up to enter Paradise which is equal in width to the heavens and the earth. 'Umair b. al- Humam al-Ansari said: Messenger of Allah, is Paradise equal in extent to the heavens and the earth? He said: Yes. 'Umair said: My goodness! The Messenger of Allah (may peace be upon him) asked him: What prompted you to utter these words (i. e. my goodness! ')? He said: Messenger of Allah, nothing but the desire that I be among its residents. He said: Thou art (surely) amona its residents. He took out dates from his bag and began to eat them. Then he said: If I were to live until I have eaten all these dates of mine, it would be a long life. (The narrator said): He threw away all the dates he had with him. Then he fought the enemies until he was killed.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4681]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4681

The tradition has been narrated on the authority of 'Abdullah b. Qais. He heard it from his father who, while facing the enemy, reported that the Messenger of Allah (may peace be upon him) said: Surely, the gates of Paradise are under the shadows of the swords. A man in a shabby condition got up and said; Abu Musa, did you hear the Messenger of Allah (may peace be upon him) say this? He said: Yes. (The narrator said): He returned to his friends and said: I greet you (a farewell greeting). Then he broke the sheath of his sword, threw it away, advanced with his (naked) sword towards the enemy and fought (them) with it until he was slain.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4682]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4682

It has been reported on the authority of Anas b. Malik that some people came to the Messenger of Allah (may peace be upon him) and said to him: Send with us some men who may teach us the Qur'an and the Sunnah. Accordingjy, he sent seventy men from the Ansar. They were called the Reciters and among them was my maternal uncle. Haram. They used to recite the Qur'an, discuss and ponder over its meaning at night. In the day they brought water and poured it (in pitchers) in the mosque, collected wood and sold it, and with the sale proceeds bought food for the people of the Suffa and the needy. The Holy Prophet (may peace be upon him) sent the Reciters with these people, but these (treacherous people) fell upon them and killed thern before they reached their destination (While dying), they said: O Allah, convey from us the news to our Prophet that we have met Thee (in a way) that we are pleased with Thee and Thou art pleased with us. (The narrator said): A man attacked Haram (maternal uncle of Anas) ) from behind and smote him with a spear which pierced him. (While dying), Haram said: By the Lord of the Ka'ba, I have met with success. The Messenger of Allah (may peace be upon him) said to his Companions: Your brethren have been slain grid they were saying: O Allah, convey from us to our Prophet the news that we have met Thee in a way that we are pleased with Thee and Thou art pleased with us.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4683]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4683

It has been Deported on the authority of Anas who said: My uncle and I have been named after him was not present with the Messenger of Allah (mav peace be upon him) on the Day of Badr. He felt distressed about it. He would say: I have missed the first battle fought by the Messenger of Allah (may peace be upon him), and if God now gives me an opportunity to see a battlefield with the Messenger of Allah (may peace be upon him), God will see what I do therein. He was afraid to say more than this (lest he be unable to keep his word with God). He was present with the Messenger of Allah (may peace be upon him) on the Day of Uhud. He met Sa'd b. Mu'adh (who was retreating). Anas said to him: O Abu 'Amr, where (are you going)? Woe (to thee)! I find the smell of Paradise beside the Uhud mountain. (Reprimanding Sa'd in these words) he went forward and fought thein (the enemy) until he was killed. (The narrator says). More than eighty wounds inflicted with swords, spears and arrows were found on his body. His sister, my aunt, ar-Rubayyi', daughter of Nadr, said: I could not recognise my brother's body (it was so badly mutilated) except from his finger-tips. (It was on this occasion that) the Qur'anic verse:" Among the Believers are men who have been true to their covenant with God. Of them some have completed their vow (to the extreme), and some still wait: but they have never changed (their determination) in the least" (xxxiii. 23).

The narrator said that the verse had been revealed about him (Anas b. Nadr) and his Companions.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4684]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4684

It has been narrated on the authority of Abu Musa Ash'ari that a desert Arab came to the Holy Prophet (may peace be upon him) and said: Messenger of Allah, one man fights fgr the spoils of war; another fights that he may be remembered, and another fights that he may see his (high) position (achieved as a result of his valour in fighting). Which of these is fighting in the cause of God? The Messenger of Allah (may peace be upon him) said: Who fights so that the word of Allah is exalted is fighting in the way of Allah.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4685]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4685

It has been narrated (through another chain of transmitters) on the authority of Abu Musa who said. The Messenger of Allah (may peace be upon him) was asked which of the men fights in the way of Allah: (one who fights) for displaying his valour; (a man who) fights out of his family pride and (a man who) fights for the sake of show, who amongst these fights in the way of Allah? The Messenger of Allah (may peace be upon him) said: Who fights that the word of Allah be exalted fights in the way of Allah.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4686]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4686

It has been narrated (through yet another chain of transmitters) on the same authority, i. e. Abu Musa, who said: We, came to the Messenger of Allah (may peace be upon him) and said: Messenger of Allah, one of us hho fights to display his valour... (followed by the same words as we have in the previous tradition).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4687]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4687

It has been narrated through a different chain of transmitters on the same authority, i. e. Abu Musa Ash'ari, that a man asked the Messenger of Allah (may peace be upon him) about fighting in the way of Allah, the Exalted and Majestic, a man who fights out of rage or out of family pride. He raised his head towards him-and he did so because the man was standing and said: Who fights that the word of Allah be exalted fights in the way of Allah.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4688]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4688

It has been narrated on the authority of Sulaiman b. Yasar who said: People dispersed from around Abu Huraira, and Natil, who was from the Syrians. said to him: O Shaikh, relate (to us) a tradition you have heard from the Messenger of Allah (may peace be upon him). He said: Yes. I heard the Messenger of Allah (may peace be upon him) say: The first of men (whose case) will be decided on the Day of Judgment will be a man who died as a martyr. He shall be brought (before the Judgment Seat). Allah will make him recount His blessings (i. e. the blessings which He had bestowed upon him) and he will recount them (and admit having enjoyed them in his life). (Then) will Allah say: What did you do (to requite these blessings)? He will say: I fought for Thee until I died as a martyr. Allah will say: You have told a lie. You fought that you might be called a" brave warrior". And you were called so. (Then) orders will be passed against him and he will be dragged with his face downward and cast into Hell. Then will be brought forward a man who acquired knowledge and imparted it (to others) and recited the Qur'an. He will be brought And Allah will make him recount His blessings and he will recount them (and admit having enjoyed them in his lifetime). Then will Allah ask: What did you do (to requite these blessings)? He will say: I acquired knowledge and disseminated it and recited the Qur'an seeking Thy pleasure. Allah will say: You have told a lie. You acquired knowledge so that you might be called" a scholar," and you recited the Qur'an so that it might be said:" He is a Qari" and such has been said. Then orders will be passed against him and he shall be dragged with his face downward and cast into the Fire. Then will be brought a man whom Allah had made abundantly rich and had granted every kind of wealth. He will be brought and Allah will make him recount His blessings and he will recount them and (admit having enjoyed them in his lifetime). Allah will (then) ask: What have you done (to requite these blessings)? He will say: I spent money in every cause in which Thou wished that it should be spent. Allah will say: You are lying. You did (so) that it might be said about (You):" He is a generous fellow" and so it was said. Then will Allah pass orders and he will be dragged with his face downward and thrown into Hell.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4689]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4689

This tradition has been handed down through a different chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4690]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4690

It has been narrated on the authority of 'Abdullah b. 'Amr that the Messenger of Allah (may peace be upon him) said: A troop of soldiers who fight in tile way of Allah and get their share of the booty receive in advance two-thirds of their reward in the Hereafter and only one-third will remain (to their credit). If they do not receive any booty, they will get their full reward.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4691]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4691

It has been narrated on the authority of Abdullah b. Amr (through a different chain of transmitters) that the Messenger of Allah (may peace be upon him) said: A troop of soldiers, large or small, who fight (in the way of Allah), get their share of the booty and return safe and sound, receive in advance two-thirds of their reward (only one-third remaining to their credit to be received in the Hereafter) ; and a troop of soldiers, large or small, who return empty-handed and are afflicted or wounded, will receive their full reward (in the Hereafter).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4692]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4692

It has been narrated on the authority of Umar b. al-Khattab that the Messenger of Allah (may peace be upon him) said: (The value of) an action depends on the intention behind it. A man will be rewarded only for what he intended. The emigration of one who emigrates for the sake of Allah and His Messenger (may peace be upon him) is for the sake of Allah and His Messenger (may peace be upon him) ; and the emigration of one who emigrates for gaining a worldly advantage or for marrying a woman is for what he has emigrated.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4693]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4693

It has been narrated through a different chain of transmitters on the authority of Sufyan who said that he heard 'Umar b. al-Khattab relate (this tradition) from the Holy Prophet (may peace be upon him) while he was delivering a sermon from the pulpit.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4694]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4694

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace he upon him) said: Who seeks martyrdom with sincerity shall get its reward, though he may not achieve it.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4695]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4695

It has been reported on the authority of Sahl b. Aba Umama b. Sahl b. Hunaif who learned the tradition from his father who (in turn) learned it from his grandfather-that the Messenger of Allah (may peace be upon him) said: Who sought martyrdom with sincerity will be ranked by Allah among the martyrs even if he died on his bed. In his version of the tradition Abd Tahir did not mention the words:" with sincerity".


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4696]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4696

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: One who died but did not fight in the way of Allah nor did he express any desire (or determination) for Jihid died the death of a hypocrite.

'Abdullah b. Mubarak said: We think the hadith pertained to the time of the Messenger of Allah (may peace be upon him).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4697]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4697

It has been narrated on the authority of Jabir who said: We were with the Holy Prophet (may peace be upon him) on an expedition. He said: There are some people in Medina. They are with you whenever you cover a distance or cross a valley. They have been detained by illness.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4698]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4698

In a version of the tradition narrated on the authority of A'mash, we have the words:" They will share with you the reward (for Jihid)."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4699]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4699

It has been reported on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) used to visit Umm Haram daughter of Milhan (who was the sister of his foster-mother or his father's aunt). She was the wife of 'Ubada b. Samit, One day the Messenger of Allah (may peace be upon him) paid her a visit. She entertained him with food and then sat down to rub his head. The Messenger of Allah (may peace be upon him) dozed off and when he woke up (after a while), he was laughing. She asked: What made you laugh. Messenger of Allah? He said: Some people from my Umma were presented to me who were fighters in the way of Allah and were sailing in this sea. (Gliding smoothly on the water), they appeared to be kings or like kings (sitting) on thrones (the narrator has a doubt about the actual expression used by the Holy Prophet). She said: Messenger of Allah, pray to Allah that He may include me among these warriors. He prayed for her. Then he placed his head (down) and dozed off (again). He woke up laughing, as before. (She said) I said: Messenger of Allah, what makes you laugh? He replied: A people from my Umma were presented to me. They were fighters in Allah's way. (He described them in the same words as he had described the first warriors.) She said: Messenger of Allah, pray to God that He may include me among these warriors. He said: You are among the first ones.

Umm Haram daughter of Milhan sailed in the aea in the time of Mu'awiya. When she came out of the sea and (was going to mount a riding animal) she fell down and died.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4700]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4700

It has been narrated on the authority of Umm Haram (and she was the aunt of Anas) who said: The Holy Prophet (may peace be upon him) came to us one day and had a nap in our house. When he woke up, he was laughing. I said: Messenger of Allah, what made you laugh? He said: I saw a people from my followers sailing on the surface of the sea (looking) like kings (sitting) on their thrones. I said: Pray to Allah that He may include me among them. He said: You will hip among them. He had a (second) ntip, woke up and was laughing. I asked him (the reason for his laughter). He gave the same reply. I said: Pray to Allah that He may include me among them. He said: You are among the first ones. Anas said: 'Ubada b. Samit married her. He joined a naval expedition and took her along with him. When she returned, a mule was brought for her. While mounting it she fell down, broke her neck (and died).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4701]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4701

It has been reported on the authority of Umm Haram daughter of Milhan (through another chain of transmitters). She said: One day the Messenger of Allah (may peace be upon him) slept (at a place) near me. He woke up smiling. She said: Messenger of Allah. what made thee laugh? He said: A people from my followers were presented to me. They were sailing on the surface of this green sea... (here follows the tradition that has gone before).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4702]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4702

It has been reported by 'Abdullah b. 'Abd al-Rahman that he heard Anas b. Malik say: The Messenger of Allah (may peace be upon him) paid a visit to Milhan's daughter, maternal aunt of Anas (and the sister of the Holy Prophet's foster-mother). He placed his head near her (from this point onward, the narrator carried on the previous tradition to its end).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4703]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4703

It has been narrated on the authority of Salman who said: I heard the Messenger of Allah (may peace be upon him) say: Keeping watch for a day and a night is better (in point of reward) than fasting for a whole month and standing in prayer every night. If a person dies (while, performing this duty), his (meritorious) activity will continue and he will go on receiving his reward for it perpetually and will be saved from the torture of the grave.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4704]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4704

This tradition has been handed down on the authority of Salman al-Khair through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4705]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4705

It has been narrated on the authority of Abu Huraira that the, Messenger of Allah (may peace be upon him) said: While a man walks along a path, finds a thorny twig lying on the way and puts it aside, Allah would appreciate it and forgive him The Holy Prophet (may peace be upon him) said: The martyrs are of five kinds: one who dies of plague; one who dies of diarrhoea (or cholera) ; one who is drowned; one who is buried under debris and one who dies fighting in the way of Allah.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4706]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4706

It has been narrated on the authority of Abu Huraira (through another chain of transmitters) that the Messenger of Allah (may peace be upon him) said: Whom do you consider to be a martyr among you? They (the Companions) said: Messenger, of Allah, one who is slain in the way of Allah is a martyr. He said: Then (if this is the definition of a martyr) the martyrs of my Umma will be small in number. They asked: Messenger of Allah, who are they? He said: One who is slain in the way of Allah is a martyr; one who dies in the way of Allah, is a martyr; one who dies of plague is a martyr; one who dies of cholera is a martyr.

Ibn Miqsam said: I testify the truth of your father's statement (with regard to this tradition) that the Holy Prophet (may peace be upon him) said: One who is drowned is a martyr.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4707]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4707

A version of the tradition narrated on the authority of Suhail contains the additional words:" And one who is drowned is a martyr."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4708]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4708

Another version of the tradition narrated on the authority of Suhail thouch a different chain of transmitters contains the additional words:" A drowned person is a martyr."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4709]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4709

It has been narrated on the authority of Hafsa daughter of Sirin who said: Anas b. Malik asked me the cause of death of Yahya b. 'Abu 'Amra. I said: (He died) of plague. He said: The Messenger of Allah (may peace be upon him) said that death by plague is martyrdom for a Muslim.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4710]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4710

This hadith has been narrated on the authority of 'Asim through the same chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4711]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4711

It has been narrated on the authority of Ibn Amir who said: I heard the Messenger of Allah (may peace be upon him) say-and he was delivering a sermon from the pulpit: Prepare to meet them with as much strength as you can afford. Beware, strength consists in archery. Beware, strength consists in archery. Beware, strength consists in archery.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4712]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4712

It has been narrated on the authority of Uqba b. Amir who said: I heard the Messenger of Allah (may peace be upon him) say: Lands shall be thrown open to you and Allah will suffice you (against your enemies), but none of you should give up playing with his arrows.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4713]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4713

This tradition has also been narrated on the same authority through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4714]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4714

It has been reported by 'Abd al-Rahman b. Shamasa that Fuqaim al- Lakhmi said to Uqba b. Amir: You frequent between these two targets and you are an old man, so you will be finding it very hard. 'Uqba said: But for a thing I heard from the Holy Prophet (may peace be upon him), I would not strain myself. Harith (one of the narrators in the chain of transmitters) said: I asked Ibn Shamasa: What was that? He said that he (the Holy Prophet) said: Who learnt archery and then gave it up is not from us. or he has been guilty of disobedience (to Allah's Apostle).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4715]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4715

It has been narrated on the authority of Thauban that the Messenger of Allah (may peace be upon him) said: A group of people from mv Umma will always remain triumphant on the right path and continue to be triumphant (against their opponents). He who deserts them shall not be able to do them any harm. They will remain in this position until Allah's. Command is executed (i. e. Qayamah is established). In Qutaiba's version of the tradition, we do not have the words:" They will remain in this position."


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4716]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4716

It has been narrated on the authority of Mughira who said: I heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to be triumphant over the people until the Command of Allah overtakes them while they are still triumphant. The same tradition has been narrated through another chain of transmitters on the same authority.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4717]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4717

It has been narrated on the authority of Jabir b. Samura that the Holy Prophet (may peace be upon him) said: This religion will continue to exist, and a group of people from the Muslims will continue to fight for its protection until the Hour is established.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4718]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4718

It has been narrated on the authority of Jabir b. 'Abdullah who said: I heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to fight In defence of truth and remain triumphant until the Day of judgment.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4719]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4719

It his been narrated on the authority of Umair b. Umm Hani who said: I heard Mu'awiya say (while delivering a sermon from the pulpit) that he heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to obey Allah's Command, and those who desert or oppose them shall not be able to do them any harm. They will be dominating the peeple until Allah's Command is executed (i. e. Resurrection is established).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4720]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4720

It has been related by, Yazid b. al-Asamm that he heard Mu'awiya b. Abu Sfyan quote a tradition from the Holy Prophet (may peace be upon him) which he related from the Prophet (mail peace he upon him) -and he did not hear him quote from the Holy Prophet (masy peace be upon him) any tradition other than this in the course of his sermon from the pulpit-that whom Allah wants to do a favour, He grants him an understanding of religion. A group of people from the Muslims will remain on the Right Path and continue until the Day of Judgment to triumph over those who oppose them.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4721]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4721

It has been narrated on the authority of 'Abd al-Rahman b. Shamasa al- Mahri who said: I was in the company of Maslama b. Mukhallad, and 'Abdullah b. 'Amr b. 'As was with him. 'Abdullah said: The Hour shall some oniy when the worst type of people are left on the earth. They will be worse than the people of pre-Islamic days. They will get whatever they ask of Allah. While we were yet sitting when 'Uqba b. 'Amir came, and Maslama said to him: 'Uqba, listen to what 'Abdullah says. 'Uqba said: He knows better; so far as I am concerned, I heard the Messenger of Allah (may peace be upon him) say: A group of people from my Umma will continue to fight in obedience to the Command of Allah, remaining dominant over their enemies. Those who will oppose them shall not do them any harm. They will remain ill this condition until the Hour overtakes them. (At this) 'Abdullah said: Yes. Then Allah will raise a wild which will be fragrant like musk and whose touch will be like the touch of silk; (but) it will cause the death of all (faithful) persons, not leaving behind a single person with an iota of faith in his heart. Then only the worst of men will remain to be overwhelmed by the Hour.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4722]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4722

It has been narrated by Sa'd b. Abu Waqqas that the Messenger of Allah (may peace be upon him) said: The people of the West will continue to triumphantly follow the truth until the Hour is established.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4723]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4723

It has been narrated on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you journey through a fertile land, you should (go slow and) give the camels a chance to graze in the land. When you travel In an arid (land) where there is scarcity of vegetation, you should quicken their pace (lest your camels grow feeble and emaciated for lack of fodder). When you halt for the night, avoid (pitching your tent on) the road, for it is the abode of noxious little animals at night.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4724]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4724

It has been narrated (through another chain of transmitters) on the authority of Abu Huraira that the Messenger of Allah (may peace be upon him) said: When you travel (through a land) where there is plenty of vegetation, you should (go slow and) give the camels a chance to enjoy the benefit of the earth. When you travel (through a land) where there is scarcity of vegetation, you should hasten with them (so that you may be able to cross that land while your animals ore still in a good condition of health). When you make a halt for the night, avoid (doing so on) the road, for the tracks are the pathways of wild beasts or the abode of noxious little animals.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4725]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4725

On the authority of Abu Huraira that the Prophet (may peace be upon him) said: Travelling is a tortuous experience. It deprives a person of his sleep. his food and drink. When one of you has accomplished his purpose, he should hasten his return to his family.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4726]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4726

It has been narrated on the authority of Anas b. Malik that the Messenger of Allah (may peace be upon him) would not come (back) to his family by night. He would come to them in the morning or in the evening. Another version of the tradition narrated on the some authority is a little difierently worded. It says: (He) would not enter (upon his household at night).


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4727]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4727

It has been narrated on the authority of Jabir b. 'Abdullah who said: We accompanied the Messenger of Allah (may peace be upon him) on an expedition. When we came (back) to Medina and were going to enter our houses, he said: Wait and enter (your houses) in the later part of the evening so that a woman with dishevelled hair may have used the comb, and a woman whose husband has been away from home may have removed the hair from her private parts.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4728]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4728

It has been narrated on the authority of Jabir that the Messenger of Allah (may peace be upon him) said: If one of you comes (back from a journey) at night. he should not enter his house as a night visitor (but should wait) until a woman whose husband has been away from house has removed the hair from her private parts and a woman with dishevelled hair has combed her hair.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4729]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4729

This tradition has been handed down through another chain of transmitters.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4730]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4730

It has been narrated (through a different chain of tranmitten) on the authority of Jabir who said: The Messenger of Allah (may peace be upon him) forbade that a man should come to his family like (an unexpected) night visitor doubting their fidelity and spying into their lapses.


Muslim :: The Book on Government (Kitab Al-Imara) :: [20.4731]

The Book on Government (Kitab Al-Imara)

Muslim :: Book 20 : Hadith 4731

A version of the tradition narrated on the authority of Jabir (but through a different chain of transmitters) mentions the undesirability of coining to one's house like a night visitor, but does not contain the words:" Doubting their fidelity or spying into their lapses."


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4732]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4732

'Adi b. Hatim reported: I said: Messenger of Allah, I set off trained dogs and they catch for me (the game) and I recite the came of Allah over it (I slaughter the game by reciting Bismillah-i-Allah-o-Akbar), whereupon he said: When you set off your trained dogs and you recited the name of Allah (while setting them off), then eat (the game). I said: Even if them (the trained dogs) kill that (the game)? He (the Holy Prophet) said: Even if these kill, but (on the condition) that no other dog, which you did not set off (along with your dogs), participates (in catching the game). I said to him: I throw Mi'rad, a heavy featherless blunt arrow, for hunting and killing (the game). Thereupon he said: When you throw Mi'rad, and it pierces, then eat, but if it falls flatly (and beats the game to death), then do not eat that.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4733]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4733

'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) saying: We are a people who hunt with these (trained) dogs, then (what should we do)? Thereupon he (the Holy Prophet) said: When you set of your trained dogs having recited the name of Allah, then eat what these (hounds) have caught for you, oven if it (the game) is killed, provided (the hunting dog) has not eaten (any part of the game). If it has eaten (the game), then you don't eat it as I fear that it might have caught for its own self. And do not eat in case other dogs have joined your trained dogs.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4734]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4734

'Adi b. Hatim reported that he asked the Messenger of Allah (may peace be upon him) about (hunting) with the help of an arrow having a stub end. He said: If it strikes (the game) with its point, then eat, but if it strikes flatly and it dies, that is Waqidh (beaten into death), do not eat that. I asked the Messenger of Allah (may peace be upon him) about (hunting with the help of) dogs, whereupon he said. When you send your dog (for hunting) reciting the name of Allah, then eat (the game), but if some part of it is eaten (by the dogs, then do not eat that, for it (your dog) has caught that (the-game) for itself. I (again) said: If I find along with my dog another dog, and do not know which of (the dogs) has caught (the game). then (what should I do)? Thereupon he ('Allah's Messenger) said: Then don't eat that, for you recited the name of Allah on your dog and not on the other one.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4735]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4735

Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about Mi'rad (i. e. hunting with the help of arrow having a stub end, and he stated the same (as we find in the previous hadith).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4736]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4736

This hadith has been transmitted on the authority of 'Adi b. Hatim with a slight variation of words.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4737]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4737

'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about hunting the game with the help of Mi'rad, whereupon he said: If it strikes (the game) with its point, then eat it, but if it strikes flat, that is (the game is) beaten (into death), (then do not eat that) 'Adi further said: I asked him about hunting with the help of a dog, whereupon he said: If that (the dog) catches it (the game) for you and does not eat out of that, then you eat (the game) for Dhakat (slaughtering) of that is its being caught by it (by the dog). But if you find another dog besides it, and you fear that that dog (the second one) had caught it (the game) along with that (your dog) and killed it. then don't eat; for you recited the name of Allah on your dog and did not recite that on the other one (which joined your dog incidentally).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4738]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4738

This hadith has been narrated on the authority of Zakariya b. Abu Za'ida with the same chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4739]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4739

Sha'bi reported: I heard Adi b. Hatim say-and he was our neighbour, and our partner and co worker at Nahrain-that he asked Allah's Apostle (may peace he upon him) saying: I let off my dog and find another dog along with my dog and that (any one of them) catches the (game), but I do not know which one had caught it, whereupon he (the Holy Prophet) said: Then don't eat that, for you recited the name of Allah while letting off your dog and did not recite on the other.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4740]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4740

This hadith has been narrated oif the authority of 'Adi b. Hatim through another chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4741]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4741

Adi b. Hatim reported: Allah's Messenger (way peace be upon him) said to me: When you let off your dog, recite the name of Allah, and if it catches (game for you) and you find it alive, then slaughter it; if you find it killed and that (your dog) has eaten nothing out of that, (even then) you may eat it; but if you find along with your dog another dog, and (the game an) dead, then don't eat, for you do not know which of the two has killed it. And if you shoot your arrow, recite the name of Allah, but if it (game) goes out of your sight for a day and you do not find on that but the mark of your arrow, then eat that it you so like, but if you find it drowned in water, then don't eat that.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4742]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4742

'Adi b. Hatim reported: I asked Allah's Messenger (may peace be upon him) about hunting. He said: When you shoot your arrow, recite the name of Allah, and if you find it (the arrow) killed (that). then eat, except when you find it fallen into water, for in that case you do not know whether it is water that caused its death or your arrow.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4743]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4743

Abu Tha'laba al-Khushani reported: I came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, we are in the land of the People of the Book, (so) we eat in their utensils, and (live) in a hunting region. where I hunt with, the help of my bow, and hunt with my trained dog, or with my dog which is not trained. So inform me what is lawful (Halal) for us out of that. He (the Holy Prophet) said: Regarding what you have mentioned of the fact that you live in the land belonging to the People of the Book and so you eat in their utensils, but if you can get utensils other than theirs, then don't eat in them; but if you do not find any, then wash them and eat in them. And regarding what you have mentioned about (your living) in a hunting region, what you hunt, (strike) with the help of your bow, recite the name of Allah (while shooting an arrow) and then eat; and what you catch with the help of your trained dog, recite the name of Allah (while letting oil) the dog and then eat it, and what you get with the help of your untrained dog, (if you find it alive) and slaughter it (according to the law of the Shari'ah), eat it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4744]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4744

This hadith has been narrated on the authority of Haiwa with the same chain of transmitters, but with a slight variation of words.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4745]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4745

Abu Tha'laba reported Allah's Messenger (may peace be upon him) having said this: If you shoot with your arrow and (the game) goes out of your sight and you find it (later on), then eat that if it has not gone rotten.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4746]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4746

Abu Tha'laba reported Allah's Apostle (may peace be upon him) as saying about one who comes three days later on the game he has shot: Eat it, provided it has not gone rotten.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4747]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4747

This hadith has been transmitted on the authority of Abu Tha'laba al- Khushani with a slight variation of (words): He (the Holy Prophet) said in regard to the game killed by (a trained) dog: Eat after three days provided it has not gone rotten.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4748]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4748

Abu Tha'laba reported that Allah's Apostle (may peace be upon prohibited the eating of every fanged beast of prey. Zuhri added: We did not bear of it until we came to Syria.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4749]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4749

Abu Tha'laba al-Khushani reported that Allah's Messenger (may peace be upon him) prohibited the eating of all fanged beasts. Ibn Shihab said: I did not bear of this from our 'Ulama' in the Hijaz, until Abu Idris narrated that to me and he was one of the jurists of Syria.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4750]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4750

Abu Tha'laba al-Khushani reported Allah's Messenger (may peace be upon him) having prohibited the eating of all fanged beasts of prey. This hadith has been narrated through another chain of transmitters, but with a slight variation of words.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4751]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4751

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The eating of all fanged beasts of prey is unlawful. This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4752]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4752

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) prohibited the eating of all fanged beasts of prey, and all the birds having talons.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4753]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4753

This hadith has been transmitted on the authority of Shu'ba.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4754]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4754

Ibn Abbas reported that Allah's Messenger (may peace be upon him) forbade (the eating) of all the fanged beasts of prey, and of all the birds having talons.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4755]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4755

This hadith has been narrated on the authority of Ibn 'Abbas through a different chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4756]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4756

Jabir reported: Allah's Messenger (may peace he upon him) sent us (on an expedition) and appointed Abu 'Ubaida our chief that we might intercept a caravan of the Quraish and provided us with a bag of dates. And he found for us nothing besides it. Abu Ubaida gave each of us one date (everyday). I (Abu Zubair, one of the narrators) said: What did you do with that? He said: We sucked that just as a baby sucks and then drank water over that, and it sufficed us for the day until night. We beat off leaves with the help of our staffs, then drenched them with water and ate them. We then went to the coast of the sea, and there rose before us on the coast of the sea something like a big mound. We came near that and we found that it was a beast, called al-'Anbar (spermaceti whale). Abu 'Ubaida said. It is dead. He then said: No (but it does not matter), we have been sent by the Messenger of Allah (may peace be upon him) in the path of Allah and you are hard pressed (on account of the scarcity of food), so you eat that. We three hundred in number stayed there for a month, until we grew bulky. He (Jabir) said: I saw how we extracted pitcher after pitcher full of fat from the cavity of its eye, and sliced from it compact piece of meat equal to a bull or like a bull. Abu 'Ubaida called forth thirteen men from us and he made them sit in the cavity of its eye, and he took hold of one of the ribs of its chest and made it stand and then saddled the biggest of the camels we had with us and it passed under it (the arched rib), and we provided ourselves with pieces of boiled meat (especially for use in our journey). When we came back to Medina, we went to Allah's Messenger (may peace be upon him) and made a mention of that to him, whereupon he said: That was a provision which Allah had brought forth for you. Is there any piece of meat (left) with you, so tnat you give to us that? He (Jabir) said: We sent to Allah's Messenger (may peace be upon him) tome of that (a piece of meat) and he ate it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4757]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4757

Jabir b. 'Abdullah reported: Allah's Messenger (may peace he upon him) sent us (on an expedition). We were three hundred riders and our chief (leader) was 'Ubaida b. al-Jarrah. We were on the look out for a caravan of the Quraish. So we stayed on the coast for half a month, and were so much afflicted by extreme hunger that we (were obliged) to eat leaves. That is why it was called the Detachment of the Leaves. The ocean cast out for us an animal which was called al-'Anbar (whale). We ate of that for half of the month and rubbed its fat on our (bodies) until our bodies became stout. Abu 'Ubaida caught hold of one of its ribs and fixed that up. He then cast a glance at the tallest man of the army and the highest of the camels. and then made him ride over that, and that-tnan passed beneath it (the rib), and many a man could sit in its eye-socket, and we extracted many pitchers of fat from the cavity of its eye. We had small bags containing dates with us (before finding the whale). 'Ubaida gave every person amongst us a handful of dates (and when the provision ran short), he then gave each one of us one date. And when that (stock) was exhausted, we felt its loss.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4758]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4758

'Amr reported on the authority of Jabir that in the expedition of Khabat (leaves) a person slaughtered three camels, then three, then three, then Abu 'Ubaida forbade him (to do so fearing that the rides may become short).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4759]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4759

Jabir b. 'Abdullah reported: Allah's Apostle (may peace be upon him) sent us (on an expedition), and we were three hundred in number, and we were carrying our bags of provisions around our necks.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4760]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4760

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) sent on in expedition a detachment consisting of three hundred (persons) and appointed Abu 'Ubaida b. Jarrah as their chief. Their provisions ran short: 'Abu 'Ubaida collected their provisions in the provision bag. and he fed us (for some time). Later on when the provisions ran short he gave us one date every day.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4761]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4761

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) sent an expedition to the sea coast and I was one among them. The rest of the hadith is the same with a slight variation of wording that in the hadith transmitted on the authority of Wahb b. Kaisan (the words are):" The army ate out of that (the whale) for eighteen days."


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4762]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4762

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) sent an expedition to the land of the tribe of Juhaina, and appointed a person as a chief over them.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4763]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4763

'Ali b. Abi Talib reported that Allah's Messenger (may peace be upon him) forbade on the Day of Khaibar temporary marriage (Muta') with women and the eating of the flesh of domestic asses.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4764]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4764

This hadith has been narrated on the authority of Zuhri through a different chain of transmitters with a slight variation of wording.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4765]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4765

Abu Tha'laba reported that Allah's Messenger (may peace be upon him) prohibited (the eating) of the flesh of domestic asses.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4766]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4766

Ibn Umar reported that Allah's Messenger (way peace be upon him) forbade the eating of the flesh of domestic asses.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4767]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4767

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade the eating of the (flesh) of domestic asses on the Day of Khaibar in spite of the fact that people needed that.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4768]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4768

Shaibani reported: I asked 'Abdullah b. Abu Aufa about (the lawfulness or unlawfulness of) the flesh of the domestic asses. He said: We experienced hunger on the Day of Khaibar as we were with the Messenger of Allah (may peace be upon him). We found domestic asses in the exterior of Medina. We slaughtered them and our earthen pots were boiling when the announcer of the Messenger of Allah (may peace be upon him) made an announcement that the earthen pots should be turned upside down and nothing of the flesh of the domestic asses should be eaten. I said: What kind of prohibition is it that he (the Holy Prophet) has made? He said: We discussed it amongst -ourselves. Some of us aaid that it has been declared unlawful for ever, (whereas others said) it has been declared unlawful since one-fifth (of the booty) has not been given (to the treasury, as is legally required).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4769]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4769

Sulaiman Shaibini reported: I heard Abdullah b. Abu Aufa say: We were smitten with hunger during the nights of Khaibar. On the Day of Khaibar, we fell upon domestic asses and we slaughtered them, and when our earthen pots boiled with them, the announcer of Allah's Messenger (may peace be upon him) made an annoancement that the earthen pots should be turned over, and nothing should be eaten of the flesh of the domestic asses. Some of the people said that Allah's Messenger (may peace be upon him) had forbidden (the use of this flesh) for one-fifth (due to the State) has not been paid, while others said: He prohibited it for ever.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4770]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4770

'Adi (he was the son of Thabit) said: I heard al-Bara' and 'Abdullah b. Abu Aufa say: We found domestic asses and we cooked them. Then the announcer of Allah's Messenger (may peace be upon him) made an announcement that the earthen pots should be turned over.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4771]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4771

Al-Bara' said: We found on the Day of Khaibar domestic asses, and the announcer of the Messenger of Allah (may peace be upon him) made an announcement that the earthen pots should be turned over.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4772]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4772

Bara was heard saying: We were forbidden (to eat) the flesh of the domestic asses.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4773]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4773

Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) commanded us to throw away the flesh of domestic asses whether uncooked or cooked; he then never commanded us to eat that. This hadith has been narrated on the authority of 'Asim with the same chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4774]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4774

Ibn 'Abbas reported: I do not know whether Allah's Messenger (may peace be upon him) prohibited (the eating of the domestic ass) due to the fact that they were the beasts of burden for the people, so he (the Holy Prophet) did not like their beasts of burden to be destroyed (as a matter of expediency), or he prohibited the use of the flesh of domestic asses (not as an expediency but as a law of the Shari'ah) on the Day of Khaibar.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4775]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4775

Salama b. Akwa' reported: We went to Khaibar with Allah's Messenger (may peace be upon him). Then Allah granted (us) victory over them. On that very evening of the day when they had been granted victory, they lit many fires. Thereupon Allah's Messenger (may peace be upon him) said: What are those fires and what for those have been lit? They said: (These have been lit) for (cooking) the flesh. Thereupon he said: Of what flesh? They said: For the flesh of the domestic asses. Thereupon Allah's Messenger (may peace bo upon him) said: Throw that away and break them (the earthen pots in which the fiesa was being cooked). A person said: Messenger of Allah, should we throw it away and wash them (the cooking pots)? He said: You may do so.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4776]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4776

This hadith has been transmitted on the authority of Yazid b. Abu Ubaid.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4777]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4777

Anas reported: When Allah's Messenger (may peace be upon him) conquered Khaibar, we caught hold of the asses outside the village. We cooked them (their flesh). Then the announcer of Allah's Messenger (may peace be upon him) made the announcement: Listen, verily Allah and His Messenger have prohibited you (the eating of) their (flesh), for it is a loathsome evil of Satan's doing. Then the earthen pots were turned over along with what was in them, and these were brimming (with flesh) at that time.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4778]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4778

Anas b. Malik reported: When it was the Day of Khaibar a visitor came and said: Messenger of Allah, the asses have been eaten. Then another came and said: Messenger of Allah, the asses are being destroyed. Then Allah's Messenger (may peace be upon him) commanded Abu Talha to make an announcement that Allah and His Messenger have prohibited you (from eating) of the flesh of (domestic) asses, for these are loathsome or impure. He (the narrator) said: The earthein pots were turned over along with what was in them.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4779]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4779

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) prohibited eating of the flesh of domestic asses on the Day of Khaibar, and permitted the cooking of the flesh of horses.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4780]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4780

Jabir b. 'Abdullah is reported to have said: We ate during the time of Khaibar the (flesh) of horses and of wild asses, but Allah's Messenger (may peace be upon him) prohibited us (to eat) the flesh of domestic asses. This hadith has hen transmitted on the authority of Ibn Juraij.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4781]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4781

Asma' reported: We slaughtered a horse and ate it during the lifetime of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4782]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4782

This hadith has been transmitted on the authority of Hisham.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4783]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4783

Ibn 'Umar reported: Allah's Messenger (may peace be upon him) was asked about the eating of (the flesh) of the lizard, whereupon he said: I am neither the eater of it nor its prohibitor.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4784]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4784

Ibn 'Umar reported: A person asked Allah's Messenger (may peace be upon him) about the eating of the lizard, whereupon he said. I neither eat it, nor do I prohibit it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4785]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4785

Ibn 'Umar reported that a person asked Allah's Messenger (may peace be upon him) as he was sitting on the pulpit about the eating of the lizard, whereupon he said: I neither eat it, nor do I prohibit it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4786]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4786

This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4787]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4787

A hadith pertaining to the eating of the lizard is transmitted from the Holy Prophet (may peace be upon him) on the authority of Ibn 'Umar, but in this very hadith narrated through a different chain of transmitters there is a slight variation of wording (and the words are):" A lizard was brought to Allah's Messenger (may peace be upon him) but he neither ate that nor declared it unlawful." And in the hadith transmitted through Usama (the words are):" The man (inquirer) was standing in the mosque and Allah's Messenger (may peace be upon him) was sitting on the pulpit."


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4788]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4788

Ibn 'Umar reported that there were some persons with Allah's Apostle (may peace be upon him) from among his Companions, Sa'd being one of them. There was brought to them the flesh of the lizard when a lady amongst the wives of Allah's Apostle (may peace be upon him) said: It is the flesh of the lizard. Thereupon Allah's Messenger (way peace be upon him) &aid: Eat, for it is lawful, but it is not my diet.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4789]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4789

Taubat Al-'Anbari reported: Al-Sha'bi (one of the narrators) asked me if I had heard the hadith transmitted on the authority of Hasan from the Prophet (may peace be upon him). He said: I sat in the company if Ibn 'Umar for two years or a year and a half but I did not hear narrated from Allah's Apostle (may peace be upon him) but this one (pertaining to the flesh of the lizard) as narrated by Mu'adh.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4790]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4790

'Abdullah b. 'Abbas reported: I and Khalid b. Walid went to the apartment of Maimuna along with Allah's Messenger (may peace be upon him), and there was presented to him a roasted lizard. Allah's Messenger (may peace be upon him) stretched his hand towards It, whereupon some of the women who had been in the house of Maimuna said: Inform Allah's Messenger (may peace be upon him) what he intends to eat. Allah's Messenger (may peace be upon him) lifted his hand. I said: Messenger of Allah, Is it forbidden? He said: No. It is not found in the land of my people, and I feel that I have no liking for it. Khalid said: I then chewed and ate it, while, Allah's Messenger (may peace be upon him) was looking (at me).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4791]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4791

'Abdullah b. 'Abbas reported that Khalid b. Walid who is called the Sword of Allah had informed him that he visited Maimuna, the wife of Allah's Apostle (may peace be upon him), in the company of Allah's Messenger (may peace be upon him), and she was the sister of his mother (that of Khalid) and that of 'Ibn Abbas, and he found with her a roasted lizard which her sister Hufaida the daughter of al-Harith had brought from Najd, and she presented that lizard to Allah's Messenger (may peace be upon him). It was rare that some food was presented to the Holy Prophet (may peace be upon him) and it was not mentioned or named. While Allah's Messenger (may peace be upon him) was about to stretch forth his hand towards the lizard, a woman from amongst the women present there informed the Messenger of Allah (may peace be upon him) what they had presented to him. They said: Messenger of Allah, it is a lizard. Allah's Messenger (may peace be upon him) withdrew his hand, whereupon Khalid b. Walid said: Messenger of Allah, is a lizard forbidden? There opon he said: No, but it is not found in the land of my people, and I feel that I have no liking for it. Khalid said: I then chewed and ate it, and Allah's Messenger (may peace be upon him) was looking at me and he did not forbid (me to eat it).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4792]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4792

Khalid b. Walid reported that he visited Maimuna daughter of al-Harith with the Messenger of Allah (may peace be upon him), and she was the sister of his mother. She presented to Allah's Messenger (may peace be upon him) the flesh of a lizard which Umm Hufaid daughter of al-Harith had brought from Najd, and she had been married to a person belonging to Banu Ja'far. It was the habit of Allah's Messenger (may peace be upon him) not to eat anything until he knew what that was. The rest of the hadith is the same but with this (addition):" Ibn al-Asamm narrated it from Maimuna and he was under her care."


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4793]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4793

Ibn 'Abbas reported: While we were in the house of Maimuna there were brought to Allah's Messenger two roasted lizards. Here no mention is made of al- 'Asamm narrating from Maimuna.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4794]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4794

Ibn 'Abbas reported that there had been brought to Allah's Messenger (may peace be upon him) the flesh of a lizard and Khalid b. Walid was also present there. The rest of the hadith is the same.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4795]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4795

Sa'id b. Jubair reported that he heard Ibn 'Abbas says: The sister of my mother Umm Hufaid presented to Allah's Messenger (may peace be upon him) clarified butter (ghee), cheese and some lizards. He ate out of the clarified butter and cheese, but lett the lizard finding no liking for it. But it was eaten on the table of Allah's Messenger (may peace be upon him). Had it been forbidden (haram), it could not be eaten on the table of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4796]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4796

Yazid b. al-Asamm reported: A newly wedded person of Medina invited us to a wedding feast, and he served us thirteen lizards. There were those who ate it and those who abandoned it. I met Ibn 'Abbas the next day, and informed him (about this) in the presence of many persons. Some of them said that the Messenger of Allah (may peace be upon him) had observed: I neither eat it nor forbid (anyone) from eating it, nor declare it to be unlawful. Thereupon Ibn 'Abbas said: Sad it is what you say! Allah's Apostle (may peace be upon him) has not been sent, but (to declare in clear words) the lawful and the unlawful (things). We were once with Allah's Messenger (may peace be. upon him) as he was with Maimuna, and there were with him al-Fadl b. 'Abbas, Khalid b. Walid and some women (also) when a tray of food containing flesh was presented to him. As Allah's Apostle (may peace be upon him) was about to eat that, Maimuna said: It is the flesh of the lizard. He withdrew his hand saying: That is the flesh which I never eat; but he said to them (those who were present there): You may eat. Al-Fadl ate out of that, so did Khalid b Walid, and the women. Maimuna (however) said: I do not eat anything but that which Allah's Messenger (may peace be upon him) eats.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4797]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4797

Abu Zubair reported that he heard Jabir b. 'Abdullah saying that there was presented to Allah's Messenger (the flesh) of the lizard, but he refused to eat that, saying: I do not know; perhaps it (lizard) might (be one of those natives of) the distant past whose (forms) had beer, distorted.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4798]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4798

Abu Zubair reported: I asked Jabir about ithe eating) of the lizard, whereupon he said: Don't eat that as he (the Holy Prophet) felt disgust. He (the narrator) said that Umar b. al-Khattab reminded: Allah's Apostle (may peace be upon him) did not declare it to be unlawful. Allah, the Exalted and Majestic, has (made it a source) of benefit for more than one (persons). It is a common diet of the shepherds. Had it been with me, I would have eaten that.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4799]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4799

Abu Sa'id reported that a person said: Messenger of Allah, we live in a land abounding in lizards, so what do you command or what verdict you give (about eating of it)? Thereupon he said: It was mentioned to me that a people from among Bani Isra'il were distorted (so there is a likelihood that those people might have been distorted in the shape of lizards). So he neither commanded (us to eat that) nor forbade (us). Abu Sa'id said: After some time Umar said: Allah, the Exalted and Majestic, has made it (a source of) benefit for more than one (person), for it is the common diet of shepherds. Had it been with me, I would have eaten that. Allah's Messenger (may peace be upon him) disliked it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4800]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4800

Abu Sa'id reported that an Arab of the desert came to Allah's Messenger (may peace be upon him) and said: I live in a low land abounding in lizards, and these are the common diet of my family, but he (the Holy Prophet) did not make any reply. We said to him: Repeat it (your problem) and so he repeated it, but he did not make any reply. (It was repeated thrice ) Then Allah's Messenger (may peace be upon him) called him out at the third time saying: O man of the desert, verily Allah cursed or showed wrath to a tribe of Bani Isra'il and distorted them to beasts which move on the earth. I do not know, perhaps this (lizard) may be one of them. So I do not eat it, nor do I prohibit the eating of it.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4801]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4801

Ibn Abu Aufa reported: We went on seven expeditions with Allah's Messenger (may peace be upon him) and ate locusts.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4802]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4802

This hadith has been narrated on the authority of Abu Ya'fur with the same chain of transmitters. Abu Bakr (one of the narrators) said" seven expeditions," whereas Ishaq said" six," and Ibn Umar said" six" or" seven".


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4803]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4803

This hadith is narrated on the authority of Abu Ya'fur with the same chain of transmitters, and he mentioned seven expeditions.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4804]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4804

Anas b. Malik reported: We chased a hare at Marr az-Zahrin (a valley near Mecca). They (my companions) ran, but felt exhausted; I also tried until I caught hold of it. I brought it to Abu Talha. He slaughtered it and sent its haunch and two hind legs to Allah's Messenger (may peace be upon him) through me; and he accepted them. This hadith has been transmitted on the authority of Yahya with a slight change of wording.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4805]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4805

Ibn Buraida reported that Abdullah b. al-Mughaffal saw a person from amongst his companions throwing small pebbles, whereupon he said: Don't throw pebbles. for Allah's Messenger (may peace be upon him) did not like it, or he forbade flinging of pebbles since neither the game is taken thereby, nor an enemy defeated. but it may break a tooth or put out an eye. He, afterwards, again saw him flinging pebbles, and said to him: I inform you that the Messenger of Allah (may peace be upon him) did not approve or he forbade flinging of pebbles, but if I see you again flinging pebbles. I will not speak with you.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4806]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4806

This hadith has been transmitted on the authority of Kahmas.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4807]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4807

'Abdullah b. Mughaffal reported that Allah's Messenger (may peace be upon him) prohibited throwing of pebbles. Ibn Ja'far reported (in the narration transmitted by him) that he (the Holy Prophet) said: It neither inflicts defeat to the enemy nor kills the game but breaks the tooth and puts the eye out. This hadith has been transmitted on the authority of Ibn Mahdi with a slight variation of wording.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4808]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4808

Sa'id b. Jubair reported that. a near one of 'Abdullah b. Mughaffal threw pebbles. He prohibited him (to do so). He said that Allah's Messenger (may peace be upon him) had prohibited the throwing of pebbles by saying: It does not catch the game, nor does it inflict defeat on the enemy, but breaks the tooth and puts the eye out. He (the near one of Abdullah b. Mughadal) again repeated it (the act of throwing of pebbles) whereupon he said: I narrate to you that Allah's Messenger (may peace be upon hish) disliked and prohibited throwing of pebbles, but I see you again throwing pebbles; I (would therefore) not speak with you.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4809]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4809

This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4810]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4810

Shaddid b. Aus said: Two are the things which I remember Allah's Messenger (may peace be upon him) having said: Verily Allah has enjoined goodness to everything; so when you kill, kill in a good way and when you slaughter, slaughter in a good way. So every one of you should sharpen his knife, and let the slaughtered animal die comfortably.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4811]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4811

This hadith has been narrated on the authority of Khalid al-Hadhdha' through different chains o transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4812]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4812

Hishim b. Zaid b. Anas b. Milik reported: I visited the house of al-Hakam b. Ayyub along with my grandfather Anas b. Milik, (and there) some people had made a hen a target and were shooting arrows at her. Thereupon Asas said that Allah's Messenger (may peace be upon him) had forbidden tying of the animals (and making them the targets of arrows, etc.). This hadith has been narrated on the authority of Shu'ba through other chains of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4813]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4813

Ibn 'Abbas reported Allah's Messenger (may peace be upon him) having said this: Do not make anything having life as a target.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4814]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4814

This hadith has been narrated on the authority of Shu'ba through a different chain of transmitters.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4815]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4815

Sa'id b. Jubair reported that Ibn 'Umar happened to pass by a party of men who had tied a hen and were shooting arrows at it. As soon as they saw Ibn 'Umar, they scattered from it. Thereupon Ibn Umar said: Who has done this? Verily Allah's Messenger (may peace be upon him) has invoked curse upon him who does this.


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4816]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4816

Sa'id b. Jubair reported that Ibn 'Umar happened to pass by some young men of the Quraish who had tied a bird (and th, is made it a target) at which they had been shooting arrows Every arrow that they missed came into the possession of the owner of the bird. So no sooner did they see Ibn 'Umar they went away. Thereupon Ibn 'Umar said: Who has done this? Allah has cursed him who does this. Verily Allah's Messenger (may peace be upon him) invoked curse upon one who made a live thing the target (of one's marksmanship).


Muslim :: The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan) :: [21.4817]

The Book of Games and the Animals which May be Slaughtered and the Aninals that Are to be Eaten (Kitab-us-Said wa'l-Dhaba'ih wa ma Yu'kalu min Al-Hayawan)

Muslim :: Book 21 : Hadith 4817

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) forbade that any beast should be killed after it has been tied.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4818]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4818

Jundab b. Sufyan reported: I was with Allah's Messenger (may peace be upon him) on the day of 'Id al-Adha. While he had not returned after having offered (the Id prayer) and finished it, he saw the flesh of the sacrificial animals which had been slaughtered before he had completed the prayer. Thereupon he (the Holy Prophet) said: One who slaughtered his sacrificial animal before his prayer or our prayer ('Id), he should slaughter another one in its stead, and he who did not slaughter, he should slaughter by reciting the name of Allah.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4819]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4819

Jundab b. Sufyan reported: I was with Allah's Messenger (may peace be upon him) (on the occasion) of 'Id al-Adha. After he had completed the prayer with people, he found that the goats had been slaughtered, whereupon he said: He who slaughtered sacrificial animal before the prayer should slaughter a goat (again) in its stead and he who has not slaughtered he should slaughter it by reciting the name of Allah.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4820]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4820

This hadith has been narrated on the authority of al-Aswad b. Qais with the same chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4821]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4821

Jundab al-Bajali reported: I saw Allah's Messenger (may peace be upon him) observing ('Id) prayer on the Day of Sacrifice (10th of Dhu'l-Hijja) and then delivering a sermon and he said: He who sacrificed the (animal) before offering ('Id) prayer, he should offer again in its stead, and he who did not sacrifice the animal should slaughter it by reciting the name of Allah.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4822]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4822

This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4823]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4823

Al-Bara' reported: My maternal uncle Abu Burda sacrificed his animal before ('Id) prayer. Thereupon Allah's Messenger (may peace be upon him) said: That is a goat (slaughtered for the sake of) flesh (and not as a sacrifice on the day of Adha). He said: I have a lamb of six months. Thereupon he said: Offer it as a sacrifice, but it will not justify for anyone except you, and then said: He who sacrificed (the animal) before ('Id) prayer, he in fact slaughtered it for his own self, and he who slaughtered after prayer, his ritual of sacrifice became complete and he in fact observed the religious practice of the Muslims.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4824]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4824

Al-Bara' b. 'Azib reported that his maternal'uncle Abu Burda b. Niyar sacrificed his animal earlier than the Holy Prophet (may peace be upon him) had sacrificed. Thereupon he said: Apostle of Allah, it is the day of meat and it is not desirable (to have longing for it and not to make use of it immediately), so I hastened in offering my animal as a sacrifice, so that I might feed my family and neighbours and my kith and kin. Thereupon Allah's Messenger (may peace be upon him) said: Offer again your sacrifice. He said: Messenger of Allah, I have a small milch goat of less than one year, and that is better than two dry goats (from which only) meat (can be acquired). Thereupon he said: That is better than the two animals of sacrifice on your behalf, and the sacrifice of a goat, of less than six months shall not be accepted as a sacrifice on behalf of anyone after your (sacrifice).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4825]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4825

Al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) delivered an address on the day (of Nahr) in which he said: None of you should offer sacrifice of animals until he has completed the ('Id) prayer. Thereupon my maternal uncle said: Messenger of Allah, it is the day of meat, so it is not desirable (to keep my family in the state of longing). The rest of the hadith is the same.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4826]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4826

Al-Bara' reported Allah's Messenger (may peace be upon him) having said: He who observes prayer like our prayer and turns his face towards our Qibla (in prayer) and who offers sacrifices (of animals) as we do, he must not slaughter the (animal as a sacrifice) until he has completed the prayer. Thereupon my maternal uncle said: Messenger of Allah, I have sacrificed the animal on behalf of my son. The Messenger of Allah (may peace be upon him) said: This is the thing in which you have made haste for your family. He said: I have a goat with me better than two goats. Thereupon he said: Sacrifice it for that is the best.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4827]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4827

Al-Bara' b. 'Azib reported Allah's Messenger (may peace be upon him) having said: The first (act) with which we started our day (the day of 'Id-ul Adha) was that we offered prayer. We then returned and sacrificed the animals and he who did that in fact adhered to our Sunnah (practice). And he who slaughtered the (animal on that day before the 'Id prayer), for him (the slaughtering of animal was directed to the acquiring of) meat for his family, and there is nothing of the sort of sacrifice in it. It was Abu Burda b. Niyar who had slaughtered (the animal before the 'Id prayer). He said: I have a small lamb, of less than one year, but better than that of more than a year. Thereupon Allah's Messenger (may peace be upon him) qaid: Sacrifice it, but it will not suffice (as a sacrifice) for anyone after you.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4828]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4828

A hadith like this has been narrated on the authority of al-Bara' b. 'Azib through another chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4829]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4829

al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) addressed us on the day of Nahr after the ('Id) prayer. The rest of the hadith is the same.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4830]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4830

Al-Bara' b. 'Azib reported: Allah's Messenger (may peace be upon him) addressed us on the day of Nahr and said: None should sacrifice the animal unless he has completed the ('Id) prayer. A person said: I have a milch goat of less than one year, better than two fat goats. Thereupon he said: Sacrifice it, and no goat of less than a year of age will be accepted as sacrifice after you.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4831]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4831

Al-Bara' b. 'Azib reported that Abu Burda slaughtered the animal as a sacrifice before the ('Id) prayer. Thereupon Allah's Apostle (may peace be upon him) said: Offer a substitute for it (since it does not absolve you of the responsibility of sacrifice). Thereupon he said: Allah's Messenger. I have nothing with me but a goat of less than six months. Shu'ba (one of the narrators) said: I think he (al-Bara' b. 'Azib also) said: And it is better than a goat of one year. Thereupon Allah's Messenger (may peace be upon him) said: Make it a substitute for that (and sacrifice it), but it will not suffice for anyone (as a sacrifice) after you.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4832]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4832

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters, but did not mention tht doubt (expressed in his statement) That is (the goat of less than a year) is better than a goat of more than one year.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4833]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4833

Anas (b. Malik) reported Allah's Messenger (may peace be upon him) having said on the day of Nahr (Sacrifice): He who slaughtered (the animal as a sacrifice) before the ('Id) prayer. should repeat it (i. e. offer another animal). Thereupon a person stood up and said: Messenger of Allah, that is the day when meat is much desired, and he also made a mention of the need of his neighbour, and perhaps Allah's Messenger (may peace be upon him) attested it. He (the person who had sacrificed the animal before the 'Id prayer) said: I have a goat of less than one year of age with me and I like it more than two fleshy goats; should I offer it as a sacrifice? He permitted him to do so. He (the narrator) said: I do not know whether this permission was granted to anyone else besides him or not. Allah's Messenger (may peace be upon him) then turned towards two rams. and he slaughtered them, and the people' came to the goats and got them distributed amongst themselves (for offering them as sacrifice).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4834]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4834

Anas b. Malik reported that Allah's Messenger (may peace be upon him) offered the 'Id prayer and then delivered the sermon giving the command: He who slaughtered the animal before prayer should slaughter (another animal as a sacrifice). The rest of the hadith is the same.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4835]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4835

Anas b. Malik reported: Allah's Messenger (may peace be upon him) addressed us on the day of 'Id al-Adha. He smelt the odour of flesh and he prohibited thern from slaughtering (the animals before the 'Id prayer), saying: He who slaughtered the animals (before the 'Id prayer) should do that again (as it is not valid as a sacrifice).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4836]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4836

Jabir reported Allah's Messenger (may peace be upon him) as saying: Sacrifice only a grown-up animal, unless it is difficult for you, in which case sacrifice a ram (of even less than a year, but more than six months' age).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4837]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4837

Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) led us in the 'Id prayer in Medina on the Day of Sacrifice. Some persons slaughtered their animals ahead of him under the impression that Allah's Apostle (may peace be upon him) had-already offered sacrifice. Thereupon Allah's Apostle (may peace be upon him) said: Those who had slaughtered their animals ahead of him should slaughter the other ones in their stead. And they should not sacrifice the animal before Allah's Messenger (may peace be upon him) had sacrificed (his animal)


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4838]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4838

Uqba b. 'Amir reported that Allah's Messenger (may peace be upon him) gave the gifts of goats to be distributed amongst his Companions. They sacrificed them, but a lamb of one year of age was left. (Someone) made a mention of that to the Messenger of Allah (may peace be upon him), whereupon he said: You sacrifice it.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4839]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4839

Amir al-Juhani reported: Allah's Messenger (may peace be upon him) distributed sacrificial animals (amongst us for sacrificing them on 'Id al-Adha). So we sacrificed them. There fell to my lot a lamb of less than one year I said: Allah's Messenger, there has fallen to my lot a lamb (Jadha'a), whereupon he said: Sacrifice that.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4840]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4840

This hadith has been transmitted on the authority of 'Uqba b. 'Amir al-Juhan with a slight change of wording.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4841]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4841

Anas reported that Allah's Messenger (may peace be upon him) sacrificed with his own hands two horned rams which were white with black markings reciting the name of Allah and glorifying Him (saying Allah-o-Akbar). He placed his foot on their sides (while sacrificing).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4842]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4842

Anas reported that Allah's Messenger (may peace be upon him) sacrificed two horned rams of white colour with black markings over them. He also stated: I saw him sacrificing them with his own hand and saw him placing his foot on their sides, and recited the name of Allah and Glorified Him.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4843]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4843

Shu'ba reported: Qatada informed me that he had heard Anas saying that Allah's Messenger (may peace be npon him) sacrificed (the horned rams) and like that. I said: Did you (Qatada) hear from Anas? He said. Yes.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4844]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4844

This hadith has been transmitted on the authority of Anas with a slight variation of wording.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4845]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4845

'A'isha reported that Allah's Messenger (may peace be upon him) commanded that a ram with black legs, black belly and black (circles) round the eyes should be brought to him, so that he should sacrifice it. He said to 'A'isha: Give me the large knife, and then said: Sharpen it on a stone. She did that. He then took it (the knife) and then the ram; he placed it on the ground and then sacrificed it, saying: Bismillah, Allah-humma Taqabbal min Muhammadin wa Al-i-Muhammadin, wa min Ummati Muhammadin (In the name of Allah," O Allah, accept [this sacrifice] on behalf of Muhammad and the family of Muhammad and the Umma of Muhammad" ).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4846]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4846

Rafi' b. Khadij is reported to have said: Allah's Messenger, we are going to encounter the enemy tomorrow, but we have no knives with us. Thereupon Allah's Messenger (may peace be upon him) said: Make haste or be careful (in making arrangements for procuring knives) which would let the blood flow (and along with it) the name of Allah is also to be recited. Then eat, but not the tooth or nail. And I am going to tell you why it is not permissible to slaughter the animal with the help of tooth and bone; and as for the nail. it is a bone, and the bone is the knife of Abyssinians. He (the narrator) said: There fell to our lot as spoils of war camels and goats, and one of the camels among them became wild. A person (amongst usl struck It with an arrow which brought it under control. whereupon Allah's Messenger (may peace be upon him) said: This camel became wild like wild animals, so if you find any animal getting wild, you do the same with that


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4847]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4847

Rafi' b. Khadij reported: While we were with Allah's Messenger (may peace he upon him) in Dhu'I-Hulaifa in Tihama, we got hold of goats and camels. Some persons (amongst us) made haste and boiled (the flesh of goats and camels) in their earthen pots. He then commanded and these were turned over; then he equalised ten goats for a camel. The rest of the hadith is the same.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4848]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4848

Rafi' b. Khadij reported from his grandfather that he said: Allah's Messenger, we are going to encounter the enemy tomorrow, but we do not have long knives with us, should we then slaughter them with the peel of the reed? The rest of the hadith is the same. (And at the end the words are):" A camel became wild (and got out of our control). We attacked it with arrows until we made it fall down." This hadith has been narrated on the authority of Sa'id b. Masruq with the same chain of transmitters with a slight variation of words.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4849]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4849

Rafi' b. Khadij reported that he said: Allah's Messenger, we are going to encounter the enemy tomorrow. and we do not have large knives with us. The rest of the hadith is the same, but no mention is made of this:" The people hastened and they boiled (flesh) in the earthen pots. He (the Holy Prophet), cammanded and these were turned over and the narrator narrated the whole event.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4850]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4850

Abu Ubaid reported: I was with 'Ali b. Abi Talib on the occasion of the 'Id day. He started with the 'Id prayer before delivering the sermon, and said: Allah's Messenger (may peace be upon him) forbade us to eat the flesh of our sacrificial animals beyond three days.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4851]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4851

Abu 'Ubaid, the freed slave of Ibn Azhar, reported that he said 'Id (prayer) with Umar b. al-Khattab, and then said the 'Id (prayer) with 'Ali b. Abu Talib. He (the narrator further) reported: He led us in prayer before delivering the sermon and then addressed the people saying: Allah's Messenger (may peace be upon him) has forbidden you to eat the flesh of your sacrificial animals beyond three nights, so do not eat that.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4852]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4852

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4853]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4853

Ibn 'Umar reported kllah's Apostle (may peace be upon him) having said: None of you shculd eat the flesh of his sacrificial animal beyond three days.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4854]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4854

This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4855]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4855

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade that the flesh of sacrificial animals be eaten beyond three (days) Salim (son of Ibn Umar) said: Ibn 'Umar did not eat the flesh of the sacrificial animals beyond three (days). Ibn Abu 'Umar said:" Beyond three days."


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4856]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4856

Abdullah b. Waqid reported: Allah's Messenger (may peace be upon him) forbade (people) to cat the flesh of sacrificed animals beyond three days. Abdullah b. Abu Bakr said, I made a mention of that to 'Amra, whereupon she said: He has told the truth, for I heard 'A'isha say: The poor among the people of the desert come (to the towns) on the occasion of Id al-Adha during the lifetime of Allah's Messenger (may peace be upon him). Upon this Allah's Messenger (may peace be upon him) said: Retain with you (the flesh) sufficing for three (days), and whatever is left out of that give in charity. After this. they (the Muslims) said: Allah's Messenger, the people make waterskins with the (hides) of their sacrificed animals and they melt fat out of them. Thereupon he said. What the then? They said: You forbade (us) to eat the flesh of sacrificial animals beyond threoq (days), whereupon he said: I forbade you for those (poor persons) who flocked (to the towns on this occasion for getting meat) but now when (this situation has improved) you may eat, preserve and give -in charity.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4857]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4857

Jabir reported that Allah's Apostle (may peace be upon him) forbade eating of the flesh of sacrificed animals beyond three (days). but afterwards said: Eat, make a provision, and keep it.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4858]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4858

Jabir b. Abdullah reported: We did not eat the flesh of our sacrificial animals beyond three days in Mina. Then Allah's Messenger (may peace be upon him) permitted us saying: Eat and make it a provision (for journey). I asked 'Ata' whether Jabir had also said: Till we came to Medina. He said: Yes.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4859]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4859

Jabir b. 'Abdullah reported: We did not eat the flesh of sacrificed animals beyond three (days), but then Allah's Messenger (may peace be upon him) commanded us to make it a provision for journey and cat it (beyond three days).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4860]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4860

Jabir reported: We made provision (out of the flesh of sacrificed animals for our journey) to Medina during the lifetime of Allah's Messenger (may peace be upon him).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4861]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4861

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) having said: O people of Medina, do not eat the flesh of sacrificed animals beyond three days. Ibn al-Muthanni said: Three days. They (the Companions of the Holy Prophet) complained to the Messenger of Allah (may peace he upon him) that they had children and servants of theirs (to feed), whereupon he said: Eat, and feed others, and store, and make it a provision of food.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4862]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4862

Salama b. al-Akwa' reported Allah's Messenger (way peace be upon him) having said: He who sacrifices (animal) among you nothing should be left in his house (out of its flesh) on the morning of the third day. When it was the next year they (his Companions) said: Should we do this year as we did daring the previous year? Thereupon he said: Don't do that, for that was a year when the people were hard pressed (on account of poverty). so I wanted that the (flesh) might be distributed amongst them.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4863]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4863

Thauban reported that Allah's Messenger (way peace be upon him) slaughtered his sacrificial animal and then said: Thauban, make his meat usable (for journey), and I continuously served him that until he arrived in Medina.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4864]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4864

This hadith has been narrated on the authority of Mu'awiya b. Salih with the same chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4865]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4865

Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported: Allah's Messenger (may peace be upon him) said to me on the occasion of Hajjat-al-Wada' (the Farewell Pilgrimage): Make the flesh usable. So I made it usable (for him) and he ate it constantly until he reached Medina. This hadith has been narrated on the authority of Yabya b. Hamza with the same chain of transmitters, but he did not say: On the occasion of Hajjat-al-Wada'.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4866]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4866

Abdullah b. Buraida reported on the authority of his father that Allah's Messenger (may peace be upon him) said this: I prohibited you from visiting the graves, but (now) you may visit them, and I prohibited you (from eating) the flesh of sacrific- ed animals beyond three days, but now keep it as long as you like. I prohibited you from the use of Nabidh except (that preoared) in dry waterskins. Now drink (Nabidh prepared in any utensil), but do not drink when it becomes intoxicant.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4867]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4867

Ibn Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said this: I used to forbid you. The rest of the hadith is the same.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4868]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4868

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: (The sacrifice of Fara' and 'Atira) has no (sanction in Islam). Ibn Rafi' made this addition in his narration that Fara' means the first-born young one of a camel.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4869]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4869

Umm Salama reported Allah's Messenger (may peace be upon him) having said this: When any one of you intending to sacrifice the animal enters in the month (of Dhu'l-Hijja) he should not get his hair or nails touched (cut). It was said to Sufyan that some of the (scholars) did not deem this hadith to be Maffu'. He said: But I deem it as Marfu' (i. e. chain of narration traceable right up to the Holy Prophet).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4870]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4870

Umm Salama reported Allah's Apostle (may peace be upon him) as saying: If anyone of you intends to offer sacrifice he should not get his hair cut or nails trimmed.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4871]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4871

Umm Salama reported (these words) directly from Allah's Messenger (may peace be upon him): If anyone has in his possession a sacrificial animal to offer as a sacrifice (on 'Id al-Adha), he should not get his hair cut and nails trimmed after he has entered the first days of Dhu'l Hijja


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4872]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4872

This hadith has been narrated on the authority of 'Amr b. Muslim with the same chain of transmitters.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4873]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4873

Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported Allah's Messenger (may peace be upon him) to have said: He who has a sacrificial animal with him whom (he intends) to offer as sacrifice, and he enters the month of Dhu'I-Hijja, he should not get his hair cut or nails trimmed until he has sacrificed the animal.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4874]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4874

'Amr b. Muslim b. 'Ammar al-Laithi reported: While we were in a bathroom just before 'Id al-Adha some of the persons tried to remove the hair with the help of hair-removing chemicals. Thereupon some of the people owning the bath (or some of the people sitting therein) said that Sa'id b. Musayyib did not approve of it, or he prohibited it. Then I met Sa'id b. Musayyib and made a mention of that to him, whereupon he said: O my nephew, this is the hadith which has been forgotten, and abandoned. Umm Salama, the wife of Allah's Apostle (may peace be upon him), narrated to me Allah's Messenger (may peace be upon him) having said as narrated above.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4875]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4875

Amr b. Muslim al-Jundani reported that Ibn Musayyib had told him that it was Umm Salama, the wife of Allah's Apostle (may peace be upon him), who had informed him of that as narrated above.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4876]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4876

Abu Tufail 'Amir b. Withila reported: I was in the company of 'Ali b. Abi Talib, when a person came to him, and said: What was it that Allah's Apostle (may peace be upon him) told you in secret? Thereupon he (liadrat 'All) was enraged and said: Allah's Apostle (may peace be upon him) did not tell me anything in secret that he hid from people, except that he told me four things. He said: Com- mader of Faithful, what are these? He said: Allah cursed him who cursed his father; Allah cursed him who sacrificed for anyone besides Allah; and Allah cursed him who accommodates an innovator (in religion) ; and Allah cursed him who changed the minarets (the boundary lines) of the land.


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4877]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4877

Abu Tufail reported: We said to 'Ali b. Abi Talib: Inform us about something which Allah's Messenger (may peace be upon him) told you in secret, whereupon he said: He told me nothing in secret which he bid from people, but I heard him say: Allah cursed him who sacrificed for anyone besides Allah; and cursed him who accommodated an innovator; and Allah cursed him who cursed his parents and Allah cursed him who changed the boundary lines (of the land possessed by him).


Muslim :: The Book of Sacrifices (Kitab Al-Adahi) :: [22.4878]

The Book of Sacrifices (Kitab Al-Adahi)

Muslim :: Book 22 : Hadith 4878

Abu Tufail reported: 'Ali was asked whether Allah's Messenger (may peace be upon him) had showed special favour (by disclosing to him) a thing (which he kept secret from others). Thereupon he said: Allah's Messenger (may peace be upon him) singled us not for (disclosing to us) anything (secret) which he did not make public, (but those few things) which lie in the sheath of my sword. He drew out the written document contained in it and on that (it was mentioned): Allah cursed him who sacrificed for anyone else besides Allah; and Allah cursed him who stole the signposts (demarcating the boundary lines of the) land; and Allah cursed him who cursed his father; and Allah cursed him who accommodated an innovator (in religion).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4879]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4879

'Ali b. Abu Talib reported; There fell to my lot along with Allah's Messenger (may peace be upon him) an old she-camel from the spoils of Badr. Allah's Messenger (may peace be upon him) granted me another camel. I made them kneel down one day at the door of an Ansari, and I wanted to carry on them Idhkhir (a kind of grass) in order to sell that. There was with me a goldsmith of the tribe of Qainuqa'. I saught to give a wedding feast (on the occasion of marriage with) Fatima with the help of that (the price accrued from the sale of this grass). And Hamza b. 'Abd al-Muttalib was busy in drinking in that house in the company of a singing girl who was singing to him. She said: Hamza, get up for slaughtering the fat she-camels. Hamza attacked them with the sword and cut off their humps and ripped their haunches, and then took out their livers. I said to Ibn Shihab: Did he take out anything from the hump? He said: He cut off the humps altogether. Ibn Shihab reported 'Ali having said: I saw this (horrible) sight and it shocked me, and I came to Allah's Apostle (may peace be upon him) and there was Zaid b, Haritha with him and communicated to him this news. He came in the company of Zaid and I also went along with him and he went to Hamza and he expressed anger with him. Hamza raised his eyes and said: Are you (not) but the servants of my father? Allah's Messenger (may peace be upon him) turned back on his heels (on hearing this) until he went away from them.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4880]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4880

This hadith has been narrated on the authority of Juraij with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4881]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4881

Husain b. 'Ali reported 'Ali having said: There fell to my lot a she-camel out of the spoils of war on the Day of Badr, and Allah's Messenger (may peace be upon him) gave me (another) she-camel on that day out of the Khums (one-fifth reserved for Allah and His Messenger). When I made up my mind to consummate my marriage with Fatima, the daughter of Allah's Messenger (may peace be upon him), I prevailed upon a goldsmith of the tribe of Qainuqa' to go along with me so that we might bring Idhkhir wishing to sell that to the goldsmiths and thus I should be able to arrange my wedding feast. While I was arranging the equipments. i. e. litters, sacks and ropes, my two she-camels were sitting down at the side of the apartment of a person of the Ansar. I collected (the different articles of equipment) and found to my surprise that their humps had been chopped off and their haunches had been cut off and their livers had been taken out. I could not help weeping when I saw that plight of theirs. I said: Who has done that? They said: Hamza b. 'Abd al-Muttalib has done this. and he is in this house dead drunk in the company of some of the Ansair with asinging girl singing before him and his companions. She said in her song: O Hamza. get up and attack these falty she-camels. Thereupon Hamza stood up with a sword (in his hand) and cut off their humps and ripped their haunches and tore out their livers. 'Ali said: I went away until I came to Allah's Messenger (may peace be upon him) and there was with him Zaid b. Haritha. Allah's Messenger (may peace be upon him) recognised from my face what I had experienced, whereupon Allah's Messenger (may peace be upon him) said: What has happened to you? I said: Messenger of Allah, by Allah, I have never seen (such an unfortunate day) as this day. Hamza has committed aggression to my she-camels, and has cut off their humps. and ripped their haunches, and he is in a house in the company of some drunkards. (Hearing this) Allah's Messenger (may peace be upon him) sent for his mantle and, putting it on him, he proceeded, and I and Zaid b. Haritha followed him, until he came to the door (of the house) in which there was Hamza. He (the Holy Prophet) sought permission which they granted him. and they were all drunk. Allah's Messenger (may peace be upon him) began to reprimand Hamza for what he had done. Hamza's eyes were red. He cast a glance at Allah's Messenger (may peace be upon him) and then looked towards his knees. and then lifted his eyes and cast a glance at his waist and then lifted his eyes and saw his face. And then Hamza said: Are you anything but the slaves of my father? Alah's Messenger (may peace be upon him) came to know that he was intoxicated, and he thus turned upon his heels, and came out, and we also came out along with him.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4882]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4882

Anas b. Malik reported: I was the cup-bearer of some people in the house of Abu Talha on the day when liquor was forbidden. Their liquor had been prepared from dry dates or fresh dates when the announcer made the announcement. He (Abu Talha) said to me: Go out and find out (what the announcement is). I got out (and found) an announcer making this announcement: Behold, liquor has been declared unlawful. He said: The liquor (was spilt and) flawed in the lanes of Medina. Abu Talha said to me: Go out and Spill it, and I spilt it. They said or some of them said: Such and such were killed, such and such were killed for (the wine) had been in their stomachs. He (the narrator) said. I do not know whether it is the narration transmitted by Anas, (or by someone else). Then Allah, the Exalted and Majestic, revealed:" There shall be no sin (imputed) unto those who have believed and done good works for what they may have eaten as long as they fear (Allah) and believe and do good works" (v. 93).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4883]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4883

'Abd al-Aziz b. Suhaib reported: They (some persons) asked Anas b. Malik, about Fadikh (that is, a wine prepared from fresh dates), whereupon he said: There was no liquor with us except this Fadikih of yours. It was only this Fadikh that I had been serving to Abu Talha and Abu Ayyub and some persons from amongst the Companions of the Messenger of Allah (may peace be upon him) in our house. When a person came and said: Has the news reached you? We said, No. He said: Verily liquor has been declared forbidden. Thereupon, Abd Talha said: Anas, spill these large pitchers. He (the narrator) said: They then never reverted to it, nor even asked about this after the announcement by that person.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4884]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4884

Anas b. Malik reported: I was standing amongst the uncles of my tribe serving them Fadikh while I was the youngest of them, when a person came and said: Verily the use of liqour has been prohibited. They said: Anas, spill it away. So I spilt it. He (one of the narrators. Sulaiman Taimi) said that he asked Anas what that was (the Fadikh). He said: It had been prepared from unripe and ripe dates. Abu Bakr b. Anas said: It was their liquor in those days. Sulaiman said: A person narrated it to me from Anas b. Malik that he had said so.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4885]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4885

Anas reported: I was standing amongst the members of my (tribe) and serving them liquor. The rest of the hadith is the same, but with this variation that Abu Bakr b. Anas said: It was their liquor in those days (prepared from dates), and Anas was present there and he did not deny this (fact) Mu'tamir reported on the authority of his father: A person who was with me told me that he had heard Anas saying that that was their liquor in those days.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4886]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4886

Anas b. Malik reported I was serving wine to Abu Talha, and Abu Dujana. and Mu'adh b. jabal admidst a group of Ansar when a visitor came to us and said There is a fresh news; the (verses) concerning the prohibition of liquor have been revealed. So we spilt it on that day; and it was a mixture of dry dates and fresh dates. Anas b. Malik said: Whil Khamr was declared unlawful, the common liquor of theirs was then a mixture of dry dates and fresh dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4887]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4887

Anas b. Malik said: I was serving wine to Abu Talha, Abu Dujana, and Suhail b. Baida' from a waterskin which contained the mixture of unripe dates and fresh dates. The rest of the hadith is the same.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4888]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4888

Anas b. Malik is reported to have said that Allah's Messenger (may peace be upon him) had forbidden to mixture fresh dates and unripe dates and then drinking (the wine prepared out of it), and that was their common intoxicant when liquor was prohibited.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4889]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4889

Anas b. Malik reported: I was serving drink to Abu 'Ubaida b. jarrah, Abu Talha and Ubayy b. Ka'b prepared from unripe dates and fresh dates when a visitor came and he said: Verily liquor has been prohibited. Thereupon, Abu Talha said: Anas, stand up and break this pitcher. I stool up and (took hold) of a pointed stone and struck the pitcher with its lower part until it broke into pieces.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4890]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4890

Anas b. Malik reported: Allah revealed the verse in which Allah prohibited the use of liquor. In those days no other liquor was drunk but that prepared from dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4891]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4891

Anas reported that Allah's Messenger (may peace be upon him) was asked about the use of Khamr from which vinegar is prepared. He said: No (it is prohibited).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4892]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4892

Wa'il al-Hadrami reported that Tariq b. Suwaid a-Ju'fi asked Allah's Apostle (may peace be upon him) about liquor. He forbade (its use) and he expressed hatred that it should be prepared. He (Tariq) said: I prepare it as a medicine, whereupon he (the Holy Prophet) said: It is no medicine, but an ailment.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4893]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4893

Abu Huraira reported Allah's Messenger (may peace be upon him) having said: Wine is prepared from the (fruit) of these two trees-date-palm and vine.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4894]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4894

This hadith has been narrated on the authority of Abu Huraira through a different chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4895]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4895

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Wine comes from vine and date-palms. Abu Kuraib has narrated it with a slight variation of words.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4896]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4896

Jabir b. 'Abdullah al-Ansari reported that Allah's Messenger (may peace upon him) prohibited the mixing of grapes and fresh dates, and dry dates and fresh dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4897]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4897

Jabir b. 'Abdullah al-Ansari reported that Allah's Messenger (may peace be upon him) prohibited the (preparation of) Nabidh by mixing together fresh dates and grapes, and he prohibited the preparation of Nabidh by mixing the fresh dates and unripe dates together.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4898]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4898

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Do not mix fresh dates and dry dates, and grapes and fresh dates for preparing Nabidh.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4899]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4899

Jabir b. Abdullah al-Ansari reported that Allah's Messenger (may peace be upon him) Prohibited the preparation of Nabidh by mixing grapes and fresh dates. and he forbade the preparation of Nabidh by mixing unripe dates with fresh dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4900]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4900

Abu Sa'id reported that Allah's Apostle (may peace be upon him) prohibited that fresh dates and grapes be mixed together and that fresh dates and unripe dates be mixed together.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4901]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4901

Abu Sa'id reported that Allah's Messenger (may peace be upon him) prohibited us to mix grapes and dry dates together and unripe dates and dry dates (to prepare Nabidh.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4902]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4902

This hadith is narrated on the authority of Abi Maslama with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4903]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4903

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: He who amongst you drinks Nabidh should drink that (prepared either from) grapes alone, or from dates alone, or from unripe dates alone (and not by mixing them with one another).

Isma'il b. Muslim al-'Abadi reported on the authority of the same chain of transmitters: Allah's Messenger (may peace be upon him) prohibited us that we should mix dry dates with unripe dates or (mix) grapes with dry dates (and prepare Nabidh). He also said: He who amongst you drinks-the rest of the hadith is the same.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4904]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4904

Abu Qatada, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said this: Do not prepare Nabidh by mixing nearly ripe dates and fresh dates together, and do not prepare Nabidh by mixing grapes and dates together, but prepare Nabidh from each (one of them) separately.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4905]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4905

This hadith has been narrated on the authority of Yahya b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4906]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4906

Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: Do not prepare Nabidh by mixing nearly ripe and fresh dates and do not prepare Nabidh by mixing together fresh dates and grapes, but prepare Nabidh out of each (one of them) separately. Yahya stated that he had met 'Abdullah b. Abu Qatada and he narrated it on the authority of his father that Allah's Apostle (may peace be upon him) said this. This hadith has been narrated on the authority of Yahya b. Abu Kathir through these two chains of transmitters but with a slight variation of words.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4907]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4907

'Abdullah b. Abu Qatada, on the authority of his father, reported Allah's Apostle (may peace be upon him) forbidding the preparation of the mixture of ripe dates and unripe dates, and the mixture of grapes and dates, and that of nearly ripe dates and fresh dates but the Prophet said: Prepare the Nabidh from each one of them separately.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4908]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4908

This hadith is narrated on the authority of Abu Qatada through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4909]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4909

Abu Huraira reported that Allah's Messenger (may peace be upon him) forbade (the preparation of Nabidh) from grapes and dates, and unripe dates and dry dates (by mixing them together). He (the Holy Prophet also) said: Prepare Nabidh from each one of them separately. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4910]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4910

Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) forbade the mixing of dates and grapes together, and mixing of unripe dates and ripe dates together (for preparing Nabidh), and he wrote to the people of Jurash (in Yemen) forbidding them to prepare the mixture of dates and grapes. This hadith has been narrated through another chain of transmitters with a slight variation of words.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4911]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4911

Ibn Umar reported that he was forbidden to prepare Nabidh by mixing unripe dates and fresh dates, and dates with grapes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4912]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4912

Ibn 'Umar reported that they were forbidden to prepare Nabidh by mixing dry dates and fresh dates and dates and grapes together.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4913]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4913

Anas b. Malik reported that Allah's Messenger (may peace be upon him) forbade the preparation of Nabidh in gourd or varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4914]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4914

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not prepare Nabidh in gourd or jar or in a pitcher besmeared with pitch (known as green pitcher).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4915]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4915

Abu Huraira reported that Allah's Apostle (may peace be upon him) forbade (the preparation of Nabidh) in varnished jar, pitcher besmeared with green pitch and hollow stump. It was said to Abu Huraira: What that Hantama was? He said: It is green pitcher (besmeared with pitch).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4916]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4916

Abu Huraira reported that Allah's Apostle (may peace be upon him) said to the group of Abd al-Qais: I forbid you (to prepare Nabidh) in gourd. and green pitcher, hollow stump and varnished jar and the waterskin having its upper end cut, but (prepare it) in your small waterskin, and tie its mouth


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4917]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4917

'Ali reported that Allah's Messenger (may peace be upon him) forbade to prepare Nabidh in gourd and varnished jar. This hadith has been narrated through another chain of transmitters with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4918]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4918

Ibrahim reported: I said to Aswad if he had asked the Mother of the Believers (in which utensils) he (the Holy Prophet) disapproved the preparation of Nabidh. He (Aswad) said: Yes. I said: Mother of the Believers, inform me about the utensils in which) Allah's Apostle forbade to prepare Nabidh. She (Hadrat 'A'isha) said: He forbade us, the members of his family, to prepare Nabidh in gourd, or varnished jar. I said to him: Do you remember green pitcher, and pitcher? He said: I narrated to you what I have heard; should I narrate to you which I did not hear?


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4919]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4919

'A'isha reported that Allah's Apostle (may peace be upon him) forbade (the preparation) of Nabidh in gourd and varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4920]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4920

Thumama b. Hazn Al-Qushairi reported: I met 'A'isha and asked her (about the utensils in which) Nabidh (may be prepared). She narrated to me that a group of 'Abd al-Qais came to Allah's Apostle (may peace be upon him) and asked: Allah's Apostle (may peace be upon him) about Nabidh. He (the Holy Prophet) forbade them to prepare Nabidh in varnished jar, hollow stumps and gourd and green pitcher.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4921]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4921

'A'isha reported Allah's Messenger (may peace be upon him) forbidding (the preparation of Nabidh) in varnished jar, green pitcher, gourd, and hollow stump,


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4922]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4922

This hadith has been narrated on the authority of Ishaq b. Suwaid, with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4923]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4923

Ishaq b. Suwaid reported through the same chain of transmitters but for the difference that he substituted the word" gourd" for" waterskin" (meant for preserving wine).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4924]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4924

Ibn 'Abbas reported that there came to Allah's Messenger (may peace be upon him) a group of people from the tribe of 'Abd al-Qais. Allah's Messenger (may peace be upon him) said to them: I forbid you to prepare Nabidh in gourd, in pitcher besmeared with pitch, in hollow stump and in waterskin (meant for preserving wine). In the hadith transmitted on the authority of Hammad the word." gourd" has been used in place of" waterskin".


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4925]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4925

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) forbade the (preparation of Nabidh) in gourd in pitcher besmeared with pitch, in varnished jar, and in hollow stumps.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4926]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4926

Ibn Abbas reported that Allah's Messenger (may peace be upon him) forbade, the preparation of Nabidh in gourd, in varnished jar, hollow stump and from mixing up ripe dates with nearly ripe dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4927]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4927

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) forbade (preparation) of Nabidh in gourd, in hollow stump and in varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4928]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4928

Abu Sa'id reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in a green pitcher (besmeared with pitch).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4929]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4929

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in gourd, in pitcher besmeared with green pitch, in hollow stump and in varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4930]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4930

This hadith has been reported on the authority of Qatada with the same chain of transmitters that Allah's Apostle (may peace be upon him) forbade (the preparation of) Nabidh, the rest of the hadith is the same.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4931]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4931

Abu Sa'id reported that Allah's Messenger (may peace be upon him) forbade drinking in green pitcher, in gourd and in the hollow stump.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4932]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4932

Sa'id b. Jubair reported: I bear testimony to the fact that Ibn 'Umar and Ibn 'Abbas testified to the fact that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in gourd in vessel besmeared with pitch and hollow stump.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4933]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4933

Sa'id b. Jubair reported: I asked Ibn 'Umar about (the preparation of) Nabidh in a green pitcher (besmeared with pitch), whereupon he said that Allah's Messenger (may peace be upon him) forbade the (preparation of) Nabidh in green pitcher (besmeared with pitch). I then came to Ibn Abbas and said: Do you hear what Ibn 'Umar has said? Thereupon he said: What does he say? I said: He stated that Allah's Messenger (may peace be upon him) has forbidden the (preparation of) Nabidh in a green pitcher (besmeared with pitch), whereupon he said: Ibn 'Umar has told the truth. Allah's Messenger (may peace be upon him) declared unlawful the preparation of Nabidh in a green pitcher (besmeared with pitch). I said: What is this thing, the Nabidh of a pitcher (Nabidh prepared in a pitcher)? Thereupon, he said: Everything that is prepared in earthen pitcher.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4934]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4934

Ibn 'Umar reported: Allah's Messenger (may peace be upon him) addressed people in one of his expeditions. Ibn 'Umar said: I went forward to him but he went away before I reached him. I asked (the people present there): What did he say? They said that he (the Holy Prophet) had forbidden the preparation of Nabidh in gourd and varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4935]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4935

This hadith has been reported on the authority of Ibn 'Umar with different chains of transmitters but they have not mentioned:" In one of his expeditions" except Malik and Usama.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4936]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4936

Thabit reported: I said to Ibn 'Umar that Allah's Messenger (may peace be upon him) had forbidden the preparation of Nabidh in the green pitcher (besmeared with pitch). He said: This is what they stated. I said: Did Allah's Messenger (may peace be upon him) forbid this? He said: They said so.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4937]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4937

A person asked Ibn 'Umar if the Apostle of Allah (may peace be upon him) forbade the preparation of Nabidh in a green pitcher (besmeared with pitch). He said: Yes. Then Tawus said: By Allah, I heard it from him.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4938]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4938

Ibn 'Umar reported that a person came to him and said: Did Allah's Apostle (may peace be upon him) forbid the preparation of Nabidh in a green pitcher (besmeared with pitch and) in varnished jar? He said: Yes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4939]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4939

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in a green pitcher (besmeared with pitch) and in varnished jar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4940]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4940

Ibrahim b. Maisarah reported that he heard Tawus as saying: I was sitting with Ibn 'Umar when a man came to him, and said: Did Allah's Messenger (may peace be upon him) forbid the preparation of Nabidh in a green pitcher (besmeared with pitch), in varnished jar and in gourd? Thereupon he said: Yes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4941]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4941

Muharib b. Dithar reported: I heard Ibn 'Umar say: Allah's Messenger (may peace be upon him) forbade (the preparation of Nabidh) in a pitcher besmeared with pitch, in gourd, in varnished jar. He said, I heard it from him more than once.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4942]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4942

Muharib b. Dithar reported a hadith like this on the authority of Ibn 'Umar through a different chain of transmitters. He (the narrator) said: I think he also made a mention of hollow stump.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4943]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4943

'Uqba b. Huraith said: I heard Ibn 'Umar saying: The Messenger of Allah (may peace be upon him) forbade (the preparation of Nabidh) in a green pitcher (besmeared with pitch), in varnished jar, and in gourd, and he said: Prepare Nabidh in small waterskins.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4944]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4944

Jabalah reported: I heard Ibn 'Umar narrating that Allah's messenger (may peace be upon him) had forbidden (the preparation of Nabidh) in the pitcher besmeared with pitch. I said to him: What is Huntama? He said: It is a pitcher (besmeared with pitch).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4945]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4945

Zadhan reported: I said to Ibn 'Umar: Tell me in your own language and then explain it to me in any language because your language is different from our language (about the vessels) in which Allah's Apostle (may peace be upon him) has forbidden (us) to drink. He said: Allah's Messenger (may peace be upon him) has forbidden (the preparation) of Nabidh in Hantama and that is a pitcher (besmeared with pitch), in gourd and that is pumpkin, in the varnished jar, in hollow stump and in wooden vessels. This Naqir is the wood of date-palm from which the vessel is fashioned out or hollowed out, but he commanded us to prepare Nabidh in waterskins.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4946]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4946

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4947]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4947

Sa'id b. Musayyib reported: I heard 'Abdullah b 'Umar saying this near the pulpit while pointing towards the pulpit of Allah's Messenger (may peace be upon him): A group of the tribe of 'Abd al-Qais came to Allah's Messenger (may peace be upon him) and asked him about (vessels) which might (be used for preparing Nabidh and) drinking in them. He (the Holy Prophet) forbade them (to use) gourd, hollow stump, vessel besmeared with pitch. I said to him: Abu Muhammad, (what about) varnished jar? and we think he had forgotten to mention the word 'varnished jar". Thereupon he said: I did not hear it from him on that day, i. e. from 'Abdullah b. 'Umar, and he hated that (i. e. preparation of Nabidh in gourd).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4948]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4948

It is reported on the authority of Jabir and Ibn Umar that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in hollow stump and varnished jar and gourd.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4949]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4949

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in green pitcher, in varnished jar, in hollow stump, and when Allah's Messenger (may peace be upon him) did not find anything to prepare Nabidh in that (i. e. waterskin), it was prepared for him in a big bowl made of stone.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4950]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4950

This hadith is reported on the authority of Jabir b. Abdullah that Nabidh was prepared for him in a big bowl of stone.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4951]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4951

Jabir reported that Nabidh was prepared for Allan's Messenger (may peace be upon him) in a waterskin, but if they did not find waterskin it was prepared in a big bowl of stone. One of the persons and I had heard from Abu Zubair that it was Biram (a vessel made of stone).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4952]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4952

'Abdullah b. Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: I had forbidden you from the preparation of Nabidh except in a waterskin. But now you may drink in all vessels, but do not drink what is intoxicant.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4953]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4953

Ibn Buraida, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: I had forbidden you (from the preparation of Nabidh) and drinking it in certain vessels, (but now you may do so if you like) for it is not vessels or a vessel that makes a thing lawful or unlawful. It is every intoxicant that is unlawful.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4954]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4954

Ibn Buraida, on the authority of his father, reported Allah's Messenger (may Peace be upon him) as saying: I had forbidden you from the drinking (and preparation of) Nabidh in the vessels made out of leather, but (now) you may drink in all vessels, but you do not drink an intoxicant.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4955]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4955

'Abdullah b. 'Amr reported that when Allah's Messenger (may peace be upon him) forbade (the preparation) of Nabidh in vessels, they said all the people cannot (afford to have) them. He (the Holy Prophet) then granted them permission (to prepare) Nabidh in a green pitcher, but not in those besmeared with pitch.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4956]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4956

'A'isha reported: Allah's Messenger (may peace be upon him) was asked about Bit, whereupon he said: Every drink that causes intoxication is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4957]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4957

'A'isha reported that Allah's Messenger (may peace be upon him) was asked about it, whereupon he said that everything that causes intoxication is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4958]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4958

This hadith has been reported on the authority of Zuhri with this chain of transmitters but in the hadith transmitted on the authority of Sufyan and Salih (these words are not found)" she was asked about Bit". (These words are found in the hadith) transmitted on the authority of Ma'mar and in the hadith transmitted on the authority of Salih (only these words are found) that she (Hadrat 'A'isha) had heard Allah's Messenger (may peace be upon him) say: Every intoxicating drink is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4959]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4959

Abu Musa reported: Allah's Apostle (may peace be upon him) sent me and Mu'adh b. Jabal to Yemen. I said: Allah's Messenger, there is prepared in our land a wine out of barley which is known as Mizr (beer of our times) and a wine from honey which is known as Bit, (are these also forbidden? ), whereupon he said: Every intoxicant is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4960]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4960

Abu Burda reported on the authority of his grandfather that Allah's Messenger (may peace be upon him) sent him and Mu'adh b. Jabal to Yemen and said to them: Give good tidings to the (people). and make things easy (for them), teach (them), and do not repel (them) ; and I think he also said: Cooperate cheerfully with each other. When he (the Holy Prophet) turned his back, Abu Musa returned to him and said: Allah's Messenger, they (the people of Yemen) have a drink which is (made) from honey and which is prepared by cooking it until it coagulates, and Mizr is prepared from barley, whereupon Allah's Messenger (may peace be upon him) said: Every intoxicant that detains you from prayer is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4961]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4961

Abu Burda reported on the authority of his father: Allah's Messenger (may peace be upon him) sent me and Mu'adh to Yemen saying: Call people (to the path of righteousness) and give good tidings to the (people), and do not repel them, make things easy for them and do not make things difficult. I (Burda) said: Allah's Messenger, give us a religious verdict about two kinds of drinks which we prepare in Yemen. One is Bit' which is prepared from honey; it is a fermented Nabidh and is strong and turns into wine, and (the second is) Mizr which is prepared from millet and barley. Thereupon, Allah's Messenger (may peace be upon him), who had been gifted with the most eloquent and pithy expressions, said: I forbid you from every intoxicant that keeps you away from prayer.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4962]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4962

Jabir reported that a person came from Jaishan, a town of Yemen, and he asked Allah's Apostle (may peace be upon him) about the wine which was drunk in their land and which was prepared from millet and was called Mizr. Allah's Messenger (may peace be upon him) asked whether that was intoxicating. He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said: Every intoxicant is forbidden. Verily Allah the Exalted and Majestic, made a covenant to those who drank intoxicants to make their drink Tinat al-Khabal. They said: Allah's Messenger, what is Tinat a]-Khabal? He said: It is the sweat of the denizens of Hell or the discharge of the denizens of Hell.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4963]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4963

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Every intoxicant is Khamr and every intoxicant is forbidden. He who drinks wine in this world and dies while he is addicted to it, not having repented, will not be given a drink in the Hereafter.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4964]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4964

Ibn 'Umar, through another chain of transmitters; reported Allah's Messenger (may peace be upon him) having said this: Every intoxicant is Khamr and every intoxicant is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4965]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4965

This hadith has been narrated on the authority of Musa b. Uqba with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4966]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4966

Nafi' reported Ibn 'Umar as saying: I do not know this but from Allah's Apostle (may peace be upon him) who said: Every intoxicant is Khamr and every Khamr is forbidden.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4967]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4967

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who drank (wine) in this world would be deprived of it in the Hereafter.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4968]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4968

Ibn 'Umar said: He who drank wine in the world and did not repent would be deprived of it (the pure drink) in the Hereafter. It was said to Malik: Is this hadith Marfu'? He said: Yes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4969]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4969

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: He who drank wine in this world will not be provided with pure drink in the Hereafter, except in case he repents.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4970]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4970

Ibn 'Umar reported this hadith from Allah's Messenger (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4971]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4971

Ibn 'Abbas reported that Nabidh was prepared for Allah's Messenger (may peace be upon him) in the beginning of the night and he would drink it in the morning and the following night and the following day and the night after that up to the afternoon. If anything was left out of that he gave it to his servant, or gave orders for it to be poured out.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4972]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4972

Ibn 'Abbas reported that Nabidh was prepared for Allah's Messenger (may peace be upon him) in the waterskin, Shu'ba said: It was the night of Monday. He drank it on Monday and on Tuesday up to the afternoon, and If anything was left out of it he gave it to his servant or poured it out.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4973]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4973

Ibn Abbas reported that raisins were steeped in water for the Messenger of Allah (may peace be upon him) and he would drink it on that day and on the next day and on the following day until the evening of the third day. He would then order it to be drunk by (other people) or to be thrown away.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4974]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4974

Ibn Abbas reported that Nabidh was prepared from raisins for Allah's Messenger (may peace be upon him) in the waterskin and he would drink it on that day and on the next day and the day following and when It was the evening of the third day, and he would drink it and give it to (his Companions) and if something was left over, he threw that away.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4975]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4975

Yahya Abu 'Umar al-Nakhai reported that some people asked Ibn Abbas about the sale and purchase of wine and its commerce. He asked (them): Are you Muslims? They said, Yes. Thereupon he said: Its sale and purchase and its trade are not permissible. They then asked him about Nabidh and he said: Allah's Messenger (may peace be upon him) went out on a journey and then came back and some persons amongst his Companions prepared Nabidh for him in green pitcher, hollow stump and gourd. He commanded it to be thrown away, and it was done accordingly. He then ordered them (to prepare it.) in a waterskin and it was prepared in that by steeping raisins in water, and it was prepared in the night. In the morning he drank out of that and on that day and then the next night, and then on the next day until the evening. He drank and gave others to drink. When it was morning (of the third night) he commanded what was left of that to be thrown away.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4976]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4976

Thumama (i. e. Ibn Hazn al-Qushairi) reported: I met 'A'isha and asked her about Nabidh (that was served to the Holy Prophet). 'A'isha called an Abyssinian maid (servant) and said: Ask her (about it) for it was he, who prepared the Nabidh for the Messenger of Allah (may peace be upon him). The Abyssinian (maid-servant) said: I prepared Nabidh for him in a waterskin in the night and tied its mouth and then suspended it; and when it was morning he (the Holy Prophet) drank from it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4977]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4977

'A'isha reported: We prepared Nabidh for Allah's Messenger (may peace be upon him) in a waterskin, the upper part of which was tied and it (the waterskin) had a hole (in its lower part). We prepared the Nabidh in the morning and he drank it in the evening and we prepared the Nabidh in the night, and he would drink it in the morning.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4978]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4978

Sahl b. Sa'd reported that Abu Usaid al-Sa'idi invited Allah's Messenger (may peace be upon him) to his wedding feast, and his wife had been serving them on that day while yet a bride. Sahl said ' Do you know what she served as a drink to Allah's Messenger (may peace be upon him)? She steeped the dates in water during the night in a big bowl, and when he (the Holy Prophet) had eaten food she served him this drink.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4979]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4979

Sahl reported that Abu Usaid al-Sa'idi came to Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same, but he did not mention this: when he had eaten (the food) she gave him this to drink".


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4980]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4980

Sahl b. Sa'd reported (this hadith through another chain of transmitters) and he said (these words):" In a big bowl of stone, and when Allah's Messenger (may peace be upon him) had taken the food, she drenched the dates and served (this) especially to him."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4981]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4981

Sahl b. Sa'd reported: An Arab woman was mentioned before Allah's Messenger (may peace be upon him). He commanded Abu Usaid to send a message to her and he (accordingly) sent a message to her. She came and stayed in the fortresses of Banu Sa'idah. Allah's Messenger (may peace be upon him) went out until he came to her while she was (at that time) sitting with her head downcast. When Allah's Messenger (may peace be upon him) talked to her, she said: I seek refuge with Allah from you. Thereupon he said: I (have decided to) keep you away from me. They (the people near her) said: Do you know who he is? She said: No. They said: He is the Messenger of Allah (may peace be upon him). He came to you in order to give you the proposal of marriage. She said: Then I am the most unfortunate woman because of this (i. e. my defiance). Sahl said: Allah's. Messenger (may peace be upon him) then set forth on that day until he sat in the Saqifa of Banu Sa'idah along with his Companions. He then said to Sahl: Serve us drink. He (Sahl) said: I brought out for them this bowl (containing drink) and served them this. Abu Hazim said: Sahl brought out this cup for us and we also drank from that. Then 'Umar b. 'Abd al-'Aziz asked him to give that (cup) as a gift to him and he gave (it to) him as a gift. In the narration of Abu Bakr b. Ishaq (the words) are:" Sahl, serve us drink."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4982]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4982

Anas reported: I served drink to Allah's Messenger (may peace be upon him) in this cup of mine: honey, Nabidh, water and milk.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4983]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4983

Abu Bakr Siddiq reported: As we went along with Allah's Messenger (may peace be upon him) from Mecca to Medina, we passed by a shepherd and Allah's Messenger (may peace be upon him) was feeling thirsty. He (Abu Bakr Siddiq) said: I milked for him a small quantity of milk (from his goat) and brought it to him (the Holy Prophet), and he drank it and I was very happy.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4984]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4984

Al-Bara' reported: When Allah's Messenger (may peace be upon him) went forth from Mecca to Medina, Suraqa b. Malik b. Ju'shum pursued him. Allah's Messenger (may peace be upon him) invoked curse upon him, and his horse sank (in the desert). He (Suraqa) said: (Allah's Messenger), invoke blessings for me and I will do no harm to you. He (the Holy Prophet) then supplicated Allah. (At that time) he (the Holy Prophet) felt thirsty, and they happened to pass by a shepherd. Abu Bakr Siddiq said: I took hold of a bowl and milked some milk into it for Allah's Messenger (may peace be upon him) and gave it to him. He drank it and I was pleased.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4985]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4985

Abu Huraira reported that Allah's Messenger (may peace be upon him) was presented two cups at Bait al-Maqdis on the night of Heavenly Journey, one containing wine and the other containing milk. He looked at both of them, and be took the one containing milk, whereupon Gabriel (peace be upon him) said: Praise is due to Allah Who guided you to the true nature; had you taken the one containing wine, Your Umma would have gone astray.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4986]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4986

This hadith is narrated on the authority of Abu Huraira through another chain of transmitters, but he did not mention Aelia (Capitolina. i. e. Bait al-Maqdis).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4987]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4987

Abu Humaid Sa'idi reported: I came to Allah's Messenger (may peace be upon him) with a cup of milk from Naqi' which had no cover over it, whereupon he said: Why did you not cover it? - even if you had covered it only with a stick. Abu Humaid said that he had been ordered that waterskins be tied during the night, and the doors be closed during the night.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4988]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4988

Abu Humaid Sa'idi reported through another chain of transmitters that he brought to Allah's Messenger (may peace be upon him) a cup containing milk, but there is no mention of the word" in the night


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4989]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4989

Jabir b 'Abdullah reported: We were with Allah's Messenger (may peace be upon him) and lie asked for water. A person said: Allah's Messenger, may we not give you Nabidh to drink? He (the Holy Prophet) said: Yes (you may). He (the narrator) said: Then that person went out speedily and brought a cup containing Nabidh, whereupon Allah's Messenger (may peace be upon him) said: Why did you not cover it? - even if it is with a wood. He said that then he drank it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4990]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4990

Jabir reported that a person who was known as Abu Humaid brought for him (the Holy Prophet) a cup of milk from al-Naqi'. Allah's Messenger (may peace be upon him) said to him: Why did you not cover it even with a wood across it?


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4991]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4991

Jabir reported Allah's Messenger (may peace be upon him) as saying: Cover vessels, waterskins, close the doors and extinguish the lamps, for the Satan does not loosen the waterskin, does not open the door and does not uncover the vessels. And if one amongst you fails to find (something) to cover it well, he should cover it by placing (a piece of) wood across it. Qutaiba did not mention the closing of the doors in the hadith transmitted by him.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4992]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4992

This hadith is reported on the authority of Jabir but with a slight change of wording, and he did not mention the words:" Putting a stick across the vessel."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4993]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4993

Jabir reported Allah's Messenger (may peace be upon him) as saying: Shut the doors; the rest of the hadith is the same but with a slight variation of wording: Cover the utensils, and further said: It (the mouse) may set fire to the clothes of the residents of the house.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4994]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4994

This hadith has been reported on the authority of Jabir through another chain of transmitters but with a slight variation of words:" The mouse may set the house on fire over its inhabitants."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4995]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4995

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) having said: When the wings of the night (spread) or it is night, restrain your children (from going out), for the Satan is abroad at that time, and when a part of the night is passed, free them and shut the doors. making mention of God's name, for the Satan does not open a closed door; and tighten the (mouths of waterskins and mention the name of Allah, cover your utensils and mention the name of Allah even though you should just put something on them, and extinguish your lamps.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4996]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4996

This hadith has been narrated on the authority of Jabir b. Abdullah through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4997]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4997

This hadith has been transmitted on the authority of Ibn Juraij.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4998]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4998

Jabir reported Allah's Messenger (may peace be upon him) as saying: Do not let your animals and children go out when the sun sets until the first and the darkest part of the night is over, for the Satan is let loose with the sinking of the sun until the darkest part of the night is over.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.4999]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 4999

Jabir b. Abdullah reported this hadith through another chain of transmitters,


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5000]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5000

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Cover the vessels and tie the waterskin, for there is a night in a year when pestilence descends, and it does not pass an uncovered vessel or an untied waterskin but some of that pestilence descending into it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5001]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5001

This hadith is reported on the authority of Laith b. Sa'd with the same chain of transmitters, but with a slight variation in wording (and that is that) he (the Holy Prophet) said: There is a day in a year when descends the pestilence; at the end of the hadith Laith said that the non Arabs save themselves from it in Kanun Awwal (this is the month of December).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5002]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5002

Salim, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said: Do not leave the fire burning in your houses when you go to sleep.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5003]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5003

Abu Musa reported that a house was burnt down in Medina during the night over its inhabitants. When their matter was reported to Allah's Messenger (may peace be upon him), he said; This fire is an enemy of yours. So when you go to sleep, extinguish it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5004]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5004

Hudhaifa reported: When we attended a dinner along with the Messenger of Allah (may peace be upon him) we did not lay our hands on the food until Allah's Messenger (may peace be upon him) had laid his hand and commenced eating (the food). Once we went with him to a dinner when a girl came rushingly as it someone had been pursuing her. She was about to lay her hand on the food, when Allah's Messenger (may peace be upon him) caught her hand. Then a desert Arab came there (rushingly) as if someone had been pursuing him. He (the Holy Prophet) caught his hand; and then Allah's Messenger (may peace be upon him) said: Satan considers that food lawful on which Allah's name is not mentioned. He had brought this girl so that the food might be made lawful for him and I caught her hand. And he had brought a desert Arab so that (the food) might be lawful for him. So I caught his hand. By Him, in Whose hand is my life, it was (Satan's) hand that was in my hand along with her hand.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5005]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5005

Hudhaifa b. al-Yaman reported: When we were invited to a dinner with Allah's Messenger (may peace be upon him) ; the rest of hadith is the same but there is a slight variation of wording (and the variation is) that in that hadith the desert Arab precedes the arrival of that girl, and at the conclusion there is an addition (to this effect):" He (the Holy Prophet) then mentioned the name of Allah and ate." This hadith is reported on the authority of A'mash with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5006]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5006

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: When a person enters his house and mentions the name of Allah at the time of entering it and while eating the food, Satan says (addressing himself: You have no place to spend the night and no evening meal; but when he enters without mentioning the name of Allah, the Satan says: You have found a place to spend the night, and when he does not mention the name of Allah while eating food, he (the Satan) says: You have found a place to spend the night and evening meal. This hadith has been narrated on the authority of Jabir b. Abdullah through the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5007]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5007

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) having said: Do not eat with your left hand, for the Satan eats with his left hand.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5008]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5008

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When any one of you intends to eat (meal), he should eat with his right hand. and when he (intends) to drink he should drink with his right hand, for the Satan eats with his left hand and drinks with his left hand.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5009]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5009

This hadith is reported by Zuhri on the authority of Sufyan with a different chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5010]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5010

Salim, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: None of you should eat with his left hand and drink with that (left hand), for the Satan eats with left hand and drinks with that (hand). Nafi' has made this addition in that:" Do not take up anything with that (left hand) and do not give anything with that" ; and in the narration transmitted on the authority of Abu Tahir there is a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5011]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5011

Salama b. Akwa' reported on the authority of his father that a person ate in the presence of Allah's Messenger (may peace be upon him) with his left hand, whereupon he said: Eat with your right hand. He said: I cannot do that, whereupon he (the Holy Prophet) said: May you not be able to do that. It was vanity that prevented him from doing it, and he could not raise it (the right hand) up to his mouth.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5012]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5012

'Umar b. Abu Salama reported: I was under the care of Allah's Messenger (way peace be upon him), and as my hand used to roam about in the dish he said to me: Boy, mention the name of Allah, and eat with your right hand and eat from what is near to you.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5013]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5013

Umar b. Abu Salama reported: I (had the opportunity) one day to dine with Allah's Messenger (may peace be upon him), and I picked up flesh from around the dish. Thereupon Allah's Messenger (may peace be upon him) said: Eat from that which is near to you.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5014]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5014

Abu Sa'id (Khudri) reported that Allah's Messenger (may peace be upon him) forbade from turning the waterskins upside down and drinking from its mouth.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5015]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5015

Abu Sa'id Khudri reported that Allah's, Messenger (may peace he upon him) forbade from turning the waterskins upside down and drinking from their mouths.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5016]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5016

This hadith has been reported from Zuhri with the same chain of transmitters, but he also said that Ikhtinath means that its head (i. e., of the waterskin) be turned upside down and then (water) be drank from that.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5017]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5017

Anas reported Allah's Apostle (may peace be upon him) disapproved the drinking of water while standing.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5018]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5018

Anas reported that Allah's Apostle (may peace be upon him) forbade that a person should drink while standing. Qatada reported: We said to him: What about eating? Thereupon he (Anas) said: That is even worse and more detestable (abominable).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5019]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5019

This hadith is reported on the authority of Anas with a different chain of transmitters, but no mention is mane of the words of Qatada.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5020]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5020

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) warned against drinking while standing.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5021]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5021

Abu Sa'id Khudri reported this hadith through another chain of transmitters but with a slight, variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5022]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5022

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should drink while standing; and if anyone forgets, he must vomit.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5023]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5023

Ibn Abbas reported: I served. (water of) Zamzam to Allah's Messenger (may peace be upon him), and he drank it while standing.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5024]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5024

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) drank (water) from Zamzam in a bucket while he was standing.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5025]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5025

Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) drank (water) from Zamzam while he was standing.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5026]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5026

Ibn 'Abbas reported: I served (water from) Zamzam to Allah's Messenger (may peace be upon him), and he drank while standing, and he asked for it while he was near the House (i. e. House of Allah-Ka'ba).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5027]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5027

This hadith is reported on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5028]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5028

Abu Qatada reported on the authority of his father that Allah's Apostle (may peace be upon him) forbade breathing in a vessel.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5029]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5029

Anas reported that Allah's Messenger (may peace be upon him) used to breathe three times in the course of a drink (i. e. he drank in three gulps).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5030]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5030

Anas reported that Allah's Messenger (may peace be upon him) breathed three times (outside the vessel) in the course of a drink and said: It is more thirst- quenching, healthier and more wholesome. Anas said: So I also breathe three times in the course of a drink.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5031]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5031

This hadith is reported on the authority of Anas with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5032]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5032

Anas b. Malik reported that there was brought to Allah's Messenger (may peace be upon him) a cup of milk mixed with water, while there was on his right a desert Arab and on his left Abu Bakr. He (the Holy Prophet) drank; he then gave it to the desert Arab and said: (Give to one) who is on the right, then again who is on the right.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5033]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5033

Anas reported: The Apostle of Allah (may peace he upon him) came to Medina when I was ten years old and he died when I was twenty years old. My mother exhorted me to serve him. He (the Holy Prophet) came to our house, and we ruined a flabby goat for him and mixed it (the milk) with water from the well of the house. Allah's Messenger (may peace be upon him) drank that. Umar and Abu Bakr on his left side said to him: Allah's Messenger, give it to Abu Bakr, but he (the Holy Prophet) gave it to the desert Arab who was on his right. Allah's Messenger (may peace be upon him) said: He who is on the right, then he who is on the right.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5034]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5034

Anas b. Malik reported: Allah's Messenger (may peace be upon him) came to our house and he asked for a drink. We milked a goat for him and then mixed it (the milk) with the water of this well of mine. I gave it to Allah's Messenger (may peace be upon him) and he drank it, while Abu Bakr was on his left and 'Umar was in front of him, and a desert Arab was on his right. When Allah's Messenger (may peace be upon him) had finished the drink, Umar said: Allah's Messenger, here is Abu Bakr, give him to drink; but Allah's Messenger (may peace be upon him) gave it to the desert Arab and he left out Abu Bakr and Umar. And Allah's Messenger (may peace be upon him) said: Those on the right, those on the right, those on the right (deserve preference). Anas said: This is the Sunnah, this is the Sunnah, this is the Sunnah.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5035]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5035

Sahl b. Sa'd Sa'idi reported that Allah's Messenger (may peace be upon him) was given a drink, and he drank from that, and there was on his right side a boy. and on his left some old men. He said to the boy: Do you permit me to give it to them (the old men), but that boy said: by God. I will not give preference at your hand over me in my share. He (the narrator) said that Allah's Messenger (may peace be upon him) then gave it in his hand.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5036]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5036

This hadith is reported on the authority of Sahl b. Sa'd with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5037]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5037

Ibn 'Abbas reported Allah's Messenger (may peace be upon him.) as saying: When any one of you eats food he should not wipe his hand until he has licked it himself or has given it to someone else to lick.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5038]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5038

Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: When any one of you eats food he should not wipe his hand until he has licked it or got it licked by (someone else).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5039]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5039

Ibn Ka'b b. Malik reported on the authority of his father that he saw Allah's Messenger (may peace be upon him) licking his three fingers (after having finished the food). Ibn Hatim made no mention of" three". This hadith is also narrated through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5040]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5040

Ibn Ka'b b. Malik reported on the authority of his father that the Messenger of Allah (may peace be upon him) used to eat (food) with three fingers and he licked his hand before wiping it (with towel).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5041]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5041

'Abdullah b. Ka'b reported that his father Ka'b narrated to him that Allah's Messenger (may peace be upon him) used to eat with three fingers and when he had finished (eating), he licked them.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5042]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5042

A hadith like this has been reported on the authority of Ka'b b. Malik through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5043]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5043

Jabir reported that Allah's Messenger (may peace be upon him) commanded the licking of fingers and the dish, saying: You do not know in what portion the blessing lies."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5044]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5044

Jabir reported Allah's Messenger (may peace be upon him) as saying: When any one of you drops a mouthful he should pick it up and remove any of the filth on it, and then eat it, and should not leave it for the Satan, and should not wipe his hand with towel until he has licked his fingers, for he does not know in what portion of the food the blessing lies.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5045]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5045

This hadith has been narrated on the authority of Sufyan with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5046]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5046

Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying: The Satan is present with any one of you in everything he does; he is present even when he eats food; so if any one of you drops a mouthful he should remove away anything filthy on it and eat it and not leave for the devil; and when he finishes (food) he should lick his fingers, for he does not know in what portion of his food the blessing lies.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5047]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5047

This hadith is reported on the authority of A'mash with the same chain of transmitters but with a slight variation of words but no mention is made of the first part of the hadith, i. e. the Satan is present with any one of you.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5048]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5048

Jabir reported from Allah's Messenger. (may peace be upon him) about mentioning the licking (of fingers) and the (falling of) the mouthful.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5049]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5049

Anas reported that when Allah's Messenger (may peace be upon him) ate food he licked his three fingers, and he said: When any one of you drops a mouthful he should remove anything filthy from it and then eat it, and should not leave it for the Satan. He also commanded us that we should wipe the dish saying: You do not know in what portion of your food the blessing lies.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5050]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5050

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you cats food he should lick his fingers, for hen does not know in what part of the food sticking to his fingers the blessing lies. This hadith has been reported on the authority of Hammad with the same chain of transmitters, but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5051]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5051

Abu Mas'ud Ansari reported that a person from the Ansar who was called Abu Shu'aib had a slave who was a butcher (by profession). He (Abu Mas'ud) saw Allah's Messenger (may peace be upon him) and found signs of hunger on his face. He said to the servant: 0 ye, prepare for us food sufficient for five persons, for I intend to invite Allah's Apostle (may peace be upon him) who would be the fifth amongst the five. He (the narrator) reported that he then prepared the food and came to Allah's Apostle (may peace be upon him) and invited all the five (including him) who was the fifth amongst them to the feast. A man followed him and when Allah's Apostle (may peace be upon him) reached the door, he said: This man has followed us; if you like you may permit him (to join the meal) and if you like he can go back. Thereupon the person said: Allah's Messenger, I permit him.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5052]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5052

This hadith has been reported on the authority of Abu Mas'ud Ansari through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5053]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5053

This hadith has been transmitted on the authority of Jabir also.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5054]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5054

Anas reported that Allah's Messenger (may peace be upon him) had a neighbour who was Persian (by descent), and he was expert in the preparation of soup. He prepared (soup) for Allah's Messenger (may peace be upon him) and then came to him to invite him (to that feast). He (Allah's Messenger) said: Here is 'A'isha also (and you should also invite her to the food). He said: No. Thereupon Allah's Messenger (may peace be upon him) also said: No (then I cannot join the feast). He returned inviting him, and Allah's Messenger (may peace be upon him) said: She is also there (i. e. 'A'isha should also be invited). He said: No. Thereupon Allah's Messenger (may peace be upon him) also said: No (and declined his offer). He returned again to invite him and Allah's Messenger (may peace be upon him) again said: She is also there. He (the host) said:" Yes" for the third time. Then he accepted his invitation, and both of them set out until they came to his house.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5055]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5055

Abu Huraira reported that Allah's Messenger (may peace be upon him) went out (of his house) one day or one night, and there he found Abu Bakr and 'Umar also. He said: What has brought you out of your houses at this hour? They said: Allah's Messenger, it is hunger. Thereupon he said: By Him in Whose Hand is my life, what has brought you out has brought me out too; get up. They got up along with him. and (all of them) came to the house of an Ansari, but he was not at home. When his wife saw him she said: Most welcome, and Allah's Messenger (may peace be Upon him) said to her: Where is so and so? She said: He has gone to get some fresh water for us. When the Ansari came and he saw Allah's Messenger (may peace be upon him) and his two Companions, he said: Praise be to Allah, no one has more honourable guests today than I (have). He then went out and brought them a bunch of ripe dates, dry dates and fresh dates, and said: Eat some of them. He then took hold of his long knife (for slaughtering a goat or a sheep). Allah's Messenger (may peace be upon him) said to him: Beware of killing a milch animal. He slaughtered a sheep for them and after they had eaten of it and of the bunch and drank, and when they had taken their fill and had been fully satisfied with the drink, Allah's Messenger (may peace be upon him) said to Abu Bakr and Umar: By Him in Whose Hand is my life, you will certainly be questioned about this bounty on the Day of judgment. Hunger brought you out of your house, then you did not return until this bounty came to you.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5056]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5056

Abu Huraira reported: One day while Abu Bakr was sitting and there was with him Umar also there came to them Allah's Messenger (may peace be upon him) and he said: What makes you stay here? They said: It is hunger that has brought us out from our houses. By Him Who has stint you with Truth; the rest of the hadith is the same.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5057]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5057

Jabir b. 'Abdullah reported: When the ditch was dug, I saw Allah's Messenger (may peace he upon him) feeling very hungry. I came to my wife and said to her: Is there anything with you? I have seen Allah's Messenger (may peace be upon him) feeling extremely hungry. She brought out a bag of provisions which contained a sa', of barley. We had also with us a lamb. I slaughtered it. She ground the flour. She finished (this work) along with me. I cut it into pieces and put it in the earthen pot and then returned to Allah's Apostle (may peace be upon him) (for inviting him). She said: Do not humiliate me in the presence of Allah's Messenger (may peace be upon him) and those who are with him. When I came to him I whispered to him saying: Allah's Messenger, we have slaughtered a lamb for you and she has ground a sa' of barley which we had with us. So you come along with a group of people with you. Thereupon Allah's Messenger (may peace be upon him) said loudly: O people of the ditch, Jabir has arranged a feast for you, so (come along). Allah's Messenger (may peace be upon him) said: Do not remove your earthen pot from the hearth and do not bake the bread from the kneaded flour until I come. So I came and Allah's Messenger (may peace be upon him) came and he was ahead of the people; and I came to my wife and she said (to me): You will be humbled. I said: I did what you had asked me to do. She (his wife) said: I brought out the kneaded flour and Allah's Messenger (may peace be upon him) put some saliva of his in that and blessed It. He then put saliva in the earthen pot and blessed it and then said. Call another baker who can bake with you. and bring out the soup from it, but do not remove it from the hearth, and the guests were one thousand. (Jabir said): I take an oath by Allah that all of them ate (the food to their fill) until they left it and went away and our earthen pot was brimming over as before, and so was the case with our flour, or as Dahhak (another narrator) said: It (the flour) was in the same condition and loaves had been prepared from that.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5058]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5058

Anas b. Malik reported that Abu Talha said to Umm Sulaim: I felt some feebleness in the voice of Allah's Messenger (may peace be upon him) and perceived that it was due to hunger; so have you anything with you? She said: Yes. She brought out barley loaves, then took out a head-covering of hers, in a part of which she wrapped those loaves and then put them beneath my mantle and covered me with a part of it. She then sent me to Allah's Messenger (may peace be upon him). I set forth and found Allah's Messenger (may peace be upon him) sitting in the mosque in the company of some persons. I stood near them, whereupon Allah's Messenger (may peace be upon him) said: Has Abu Talha sent you? I said, Yes. He said: Is it for a feast? I said. Yes. Thereupon Allah's messenger (may peace be upon him) said to'those who were with him to get up He went forth and so I did before them, until I came to Abu Talha and informed him. Abu Talba said: Umm Sulaim, here comes Allah's Messenger (may peace be upon him) along with people and we do not have enough (food) to feed them. She said: Allah and His Messenger know best. Abu Talha went out (to receive him) Until he met Allah's Messenger (may peace be upon him) and Allah's Apostle (may peace be upon him) came forward along with him until they both (Allah's Messenger, along with Abu Talha) came in. Then Allah's Messenger (may peace be upon him) said: Umm Sulaim. bring forth that which you have with you. She brought the bread. Allah's Messenger (may peace be upon him) commanded that the bread be broken into small pieces, and when Umm Sulaim had squeezed a small waterskin and put seasoning on it, Allah's Messenger (may peace be upon him) recited something regarding it what Allah wished him to say. He then said: Allow ten (guests to come in and have their meals). He permitted them; they ate until they had their fill. They then went out. He (the Holy Prophet) again said: Permit ten (more) and he (the host gave permission to them. They ate until they had enough. Then they went out. he again said: Permit ten (more) until all the people had eaten to their fill, and they were seventy or eighty persons.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5059]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5059

Anas b. Malik reported: Abu Talha sent me to Allah's Messenger (may peace be upon him) in order to invite him (for meal). She had prepared a meal. So I came and found Allah's Messenger (may peace be upon him) along with some people. He looked at me, and I felt shy and said: Accept the invitation of Abu Talha. He (the Holy Prophet) asked the people to get up. Thereupon Abu Talha said: Allah's Messenger, I have prepared something for you. Allah's Messenger (may peace be upon him) touched (the food) and invoked blessings upon it, and then said: Let ten persons from my Companions enter (the house). He then said: Eat, and (in the meanwhile) brought out something from between his fingers for them. They then began to eat until they had their fill and then went out. He then asked ten more men (to have the meal) and they ate to their fill, and the ten persons went on getting in (and eating the food) and then getting out until none was left amongst them who had not got in and eaten to his fill. He then collected (the remaining part of the food) and it (the quantity of the food) was the same (as it had been prior to the serving of guests).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5060]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5060

Anas b Malik reported: Abu Talha sent me to Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same, but 'there is a slight variation of wording that he said at the end (The Holy Prophet) took what was left (of the food) and collected it and then invoked blessings upon it and it returned to its original state. He (the Holy Prophet) then said Take this.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5061]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5061

Anas b. Malik reported: Abu Talha ordered Umm Sulaim to prepare a meal specially for Allah's Apostle (may peace be upon him). He then sent me to him (to the Holy Prophet) ; the rest of the hadith is the same (but there is a slight variation of wording):" Allah's Messenger (may peace be upon him) placed his hand and mentioned the name of Allah upon that, and then said: Admit ten men. He (Abu Talha) admitted them and they got in. He (the Holy Prophet) said: Eat while mentioning the name of Allah upon it (the meal). They ate until eighty persons had taken the food. Then Allah's Apostle (may peace be upon him) had his meal and so the members of the household, and still they left some food."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5062]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5062

Anas b. Malik reported this incident pertaining to the feast given by Abu Talha to Allah's Apostle (may peace be upon him) with the addition of these words:" Abu Talha stood at the door (to welcome the honourable guest) until Allah's Messenger (may peacec be upon him) came there, He (Abu Talha) said to him: Allah's Messenger, the thing (we intend to offer you as a meal) is small in quantity. Thereupon he (the Holy Prophet) said: Bring that, for Allah will soon bless it (and increase it).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5063]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5063

Anas b. Malik reported this hadith (with a slight variation of wording) Then AlIah's Messenger (may peace be upon him) ate and the people of his house also ate. but (still) there was left a surplus, which they sent to their neighbours.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5064]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5064

Anas b. Malik reported: Abu Talha saw Allah's Messenger (may peace be upon him) lying down upon his belly in the mosque. He came to Umm Sulaim and said: I saw Allah's Messenger (may peace be upon him) lying down upon the belly in the mosque, and I think he is hungry. The rest of the hadith is the same (but with the addition of these words) that Allah's messenger (may peace be upon him) ate (the food) and so did Abu Talha, Umm Sulaim and Anas b. Malik, but there was left some. thing which we presented to our neighbours.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5065]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5065

Anas b. Malik reported: I visited Allah's Messenger (may peace be upon him) one day and found him sitting in the company of his Companions and talking to them, and he had tied his belly with a bandage. Usama said: I am in doubt whether there was stone on that (his belly) or not. I asked some of his Companions why Allah's Messenger (may peace be upon him) had bandaged his belly. They said: (He has done that to relieve) his hunger. I went to Abu Talha, the husband of Umm Sulaim, the daughter of Milhan, and said to him: Father, I saw Allah's Messenger (may peace be upon him) having bandaged his belly. I asked some of his Companions (the reason of it) and they said that it was due to hunger. Abu Talha came to mv mother and said: Is there anything? She said: Yes, I have some pieces of bread with me and some dates. If Allah's Messenger (may peace be upon him) comes to us alone we can feed him to his fill, but if someone comes along with him this would be insufficient for them. The rest of the hadith is the same.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5066]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5066

Anas b. Malik reported this hadith pertaining to the entertainment of Allah's Messenger (may peace be upon him) by Abu Talha through another chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5067]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5067

Anas b. Malik reported: A tailor invited Allah's Messenger (may peace be upon him) to a meal which he had prepared. Anas b. Malik said: I went along with Allah's Messenger (may peace be upon him) to that feast. He presented to Allah's Messenger (may peace be upon him) barley bread and soup containing pumpkin, and sliced pieces of meat. Anas said: I saw Allah's Messenger (may peace be upon him) going after the pumpkin round the dish, so I have always liked the pumpkin since that day.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5068]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5068

Anas b. Malik reported that a person invited Allah's Messenger (may peace be upon him) to a meal. I also went along with him. He brought soup containing pumpkin. Allah's 'messenger (may peace be upon him) ate that pumpkin with relish. He (Anas) said: When I saw that I began to place it before him, and did not eat it (myself). Anas said: It was since then that pumpkin was always my favourite (food).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5069]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5069

Anas b. Malik rdported that a tailor invited Allah's Messenger (may peace be upon him) to a feast. There has been an addition to this that Thabit said: I heard Anas saying that any meal that was prepared for me after that I tried that it should contain pumpkin.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5070]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5070

'Abdullah b. Busr reported: AUah's Messenger (may peace be upon him) came to my father and we brought to him a meal and a preparation from dates, cheese and butter. He ate out of that. He was then given dates which he ate but he placed their stones between his fingers, and he joined his forefinger and middle finger. Shu'ba reported: I think that this hadith God's willing also contains (these words): Putting of date stones between two fingers. Then a drink was brought for him and he drank it, and then gave it to one who was on his right side. He (the narrator) said: My father took hold of the rein of his riding animal and requested him to supplicate for us. Thereupon he said: O Allah. bless them in what Thou hast provided them as a sustenance; and forgive them and have mercy upon them.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5071]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5071

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters and they did not doubt about keeping the dates between his fingers (as is expressed in the previous hadith).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5072]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5072

'Abdullah b. Ja'far reported: I saw Allah's Messenger (may peace be upon him) eating cucumber with fresh dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5073]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5073

Anas b. Malik reported: I saw Allah's Apostle (may peace be upon him) squatting and eating dates.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5074]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5074

Anas reported that there were brought to Allah's Messenger (may peace be upon him) dates. He distributed them in the state that he had been sitting upright (in an easy posture) and he had also been eating them a (bit) quickly.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5075]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5075

Jabala b. Suhaim reported: Ibn Zubair used to provide us with dates during the time that the people were hard pressed because of famine (Once) as we were busy in eating there happened to appear before us Ibn 'Umar. He said: Don't eat two dates together, for Allah's Messenger (may peace be upon him) forbade eating them together but only after seeking permission from his brother (partner). Shu'ba said: I do not think these words pertaining to seeking permission but from the words of Ibn 'Urnar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5076]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5076

This hadith has been reported on the authority of Shu'ba with the same chain of transmitters but these words of his (are not found):" The people were hard pressed because of the famine during those days."


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5077]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5077

Jabala b. Suhaim reported: I heard Ibn 'Umar as saying that Allah's Messenger (may peace be upon him) forbade anyone taking two dates together without seeking the consent of his companions.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5078]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5078

'A'isha reported Allah's Messenger (may peace be upon him) as saying: A family which has dates will not be hungry.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5079]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5079

'A'isha reported Allah's Messenger (may peace be upon him) as saying: 'A'isha a family which has no dates (in their house) its members will be hungry; (or) 'A'isha the family which has no dates its members may be hungry. He said this twice or thrice.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5080]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5080

Amir b. Sa'd b. Abu Waqqas, on the authority of his father, reported Allah's Messenger (may peace be upon him) having said: He who ate seven dates (of the land situated) between these two lava plains in the morning, no poison will harm him until it is evening.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5081]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5081

'Amir b. Sa'd b. Abu Waqqas reported Allah's Messenger (may peace be upon him) as saying: He who ate seven 'ajwa' dates in the morning, poison and magic will not harm him on that day.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5082]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5082

This hadith has been reported on the authority of Ibn Hashim with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5083]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5083

'A'isha reported Allah's Messenger (may peace be upon him) as saying: The 'ajwa' dates of 'Aliya' contain heating effects and these are antidote in the early morning.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5084]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5084

Sa'id b. Zaid b. 'Amr b. Nufail reported: I heard Allah's Apostle (may peace be upon him) as saying: Truffles are a kind of 'Manna' and their juice is a medicine for the eyes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5085]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5085

Sa'id b. Zaid reported: I heard Allah's Messenger (may peace be upon him) as saying: Truffles are a kind of blessing and their juice is a medicine for the eyes. Shu'ba said: When Hakam narrated this hadith to me, I did not deem it as a Munkar hadith because of the narration of Abd al-Malik.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5086]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5086

Sa'id b. Zaid b. 'Amr b. Nufail reported Allah's Messenger (may peace be upon him) as saying: Truffles are a kind of 'Manna' which Allah the Glorious and Exalted, sent down upon the people of Israil, and its juice is a medicine for the eyes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5087]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5087

Sa'id b. Zaid reported Allal a Messenger (may peace be upon him) as saying: Truffles are a kind of 'Manna' which Allah sent down upon Moses and their juice is a medicine for the eyes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5088]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5088

Sa'id b. Zaid reported Allah's Messenger (may peace be upon him) as saying: Truffles are 'Manna' which Allah, the Exalted the Majestic, sent to the people of Israil, and its juice is a medicine for the eyes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5089]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5089

Sa'id b. Zaid reported Allah's Messenger (may peace be upon him) as saying: Truffles are 'Manna' and its juice is the medicine for the eyes.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5090]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5090

Jabir b. Abdullah reported: We were with the Apostle of Allah (may peace be upon him) at Marr az-Zahran, and we were plucking the fruit of the Arak tree, whereupon Allah's Messenger (may peace he upon him) said: Pluck only its black ones (for they are the most pleasant). We said: Allah's Messenger, it seems you shepherded the flock. He said: Yes. Has there been a prophet who did not shepherd it (or some words like it)?


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5091]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5091

'A'isha reported Allah's Apostle (may peace be upon him) as saying: The best of condiments or condiment is vinegar.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5092]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5092

This hadith has been reported on the authority of Sulaiman b. Bilal with the same chain of transmitters and he is reported to have said:" The best condiment." And he did not doubt (about this word).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5093]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5093

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) asked his family for condiment. They (the members of his household) said: We have nothing with us but vinegar. He asked for it, he began to eat it, and then said: Vinegar is a good condiment, vinegar is a good condiment.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5094]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5094

Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) took hold of my hand one day (and led me) to his residence. There was presented to him some pieces of bread, whereupon he said: Is there no condiment? They (the members of his household) said: No, except some vinegar. He (the Holy Prophet) said: Vinegar is a good condiment. Jabir said: I have always loved vinegar since I heard it trom Allah's Apostle (may peace be upon him). Talha said: I have always loved vinegar since I heard about it from Jabir.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5095]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5095

This hadith is reported on the authority of Jabir b. 'Abdullah that Allah's Messenger (may peace be upon him) took hold of his hand and led him to his residence as narrated above up to the words:" Vinegar is a good condiment." But in the hadith transmitted through this chain of transmitters, there is no mention of the subsequent part.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5096]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5096

Jabir b. 'Abdullah reported: While I was sitting in my house there happened to pass by me Allah's Messenger (may peace be upon him). He made a gesture to me and I stood up for him. He took hold of my hand until we came to one of the apartments of his wives. He entered and then asked me to get in. So I entered and there was hanging a curtain beside her. He (the Holy Prophet) said: Is there any food (with you)? They (the members of the household) said: Yes And then there were brought three loaves of bread for him (the Holy Prophet) and placed in the basket of palm leaves. Allah's Messenger (may peace be upon him) picked up one loaf and placed that before him, and then picked up another one and placed it before me. He then picked up the third one and broke it into two parts, and kept the one-half before him and the other half before me, and then said: Is there any condiment? They (the members of the household) said: There is nothing (in the form of condiment) but some vinegar only. He said: Bring that, for vinegar is a good condiment.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5097]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5097

Abd Ayydb Ansari reported that when food was brought to Allah's Messenger (may peace be upon him) he ate out of that, and sent the remaining part to me, and one day he sent to me the left-over; (I found that he) had not taken from it at all for it included garlic. I asked him whether that was forbidden, whereupon he said: No, but I do not like it because of its odour. He (Abu Ayyub Ansiri) said: Then I also do not like what you do not like.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5098]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5098

This Hadith is narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5099]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5099

Aflah, the freed slave of Abu Ayyub Ansiri, reported: Allah's Messnger (may peace be upon him) had alighted in his house (viz. of Abu Ayyub Ansari at the time of his emigration to Medina) and he occupied the lower storey, whereas Abu Ayyub Ansari lived in the upper storey. One night, Abu Ayyub Ansari got up and said (to himself): (How unfortunate it is) that we walk above the head of Allah's Messenger (may peace be upon him), so they went aside and spent the night in a nook and then told Allah's Apostle (may peace be upon him) about it whereupon Allah's Apostle (may peace be upon him) said: The lower storey is more comfortable (for me). but he (Abu Ayyub Ansari) said: We (would not live) over the roof under which you live. So Allah's Messenger (may peace be upon him) shifted to the upper storey, whereas Abu Ayyub Ansari shifted to the lower storey; and he (Abu Ayyub Ansari) used to prepare food for Allah's Apostle (may peace be upon him) ; and when it was brought (back) to him he asked (to locate) the part, where his fingers had touched (the food), and he followed his fingers on that part where his fingers (those of the Holy Prophet) had touched it. (One day) he prepared food which contained garlic, and when it was returned to him he asked (to locate) the part which the fingers of Allah's Apostle (may peace be upon him) had touched. It was said to him that he had not eaten (the food). He (Abd Ayyub Ansari) was distressed and went up to him (to the Holy Prophet) and said: Is it forbidden? But Allah's Messenger (may peace be upon him) said: No, (it is not forbidden), but I do not like it. and he (Abu Ayyub Ansari) said: I also do not like what you do not like or which you did not like. He (Abu Ayyub Ansari) said: (The Holy Prophet did not eat garlic) as Allah's Apostle (may peace be upon him) was visited (by angels) and brought him the message of Allah.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5100]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5100

Abu Huraira reported that a person came to Allah's Messenger (may peace be upon him) and said: I am hard pressed by hunger. He sent (message) to one of his wives (to procure food for him). but she said: By Him Who has sent you with Truth, thrre is nothing with me (to serve him) but only water. He (the Holy Prophet) then sent the (same) message to another, and she gave the same reply, until all of them gave the same reply: By Him Who has sent thee with the Truth, there is nothing with me but only water, whereupon he (the Holy Prophet) said: Allah would show mercy to him who will entertain this guest tonight. A person from the Ansar stood up and said: Messenger of Allah, I (am ready to entertain). He took him to his house and said to his wife: Is there anything with you (to serve the gdest)? She said: No, but only a subsistence for our children. He said: Distract their attention with something, and when the guest enters extinguish the lamp and give him the impression that we are eating. So they sat down. and the guest had his meal. When it was morning he went to Allah's Apostle (may peace be upon him) who said: Allah was well pleased with what you both did for your guest this night.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5101]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5101

Abu Huraira reported that a guest spent the night with a person from the Ansar who had nothing with him but food (sufficient) for his own self and his children. He said to his wife: (Lull) the children to sleep, and put out the lamp, and serve the guest with what you have with you. It was on this occasion that this verse was revealed:" Those who prefer the needy to their own selves in spite of the fact that they are themselves in pressing need" (Lix. 9).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5102]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5102

Abu Huraira reported that a man came to Allah's Messenger (may peace be upon him) so that he should entertain him as a guest, but he had nothing with which he could entertain him. He, therefore, asked if there was any person who would entertain him (assuring the audience) that Allah would show mercy to him. A person from the Ansar who was called Abu Talha stood up and he took him to his house. The rest of the hadith is the same and mention is (also) made in that about the revelation of the verse as narrated by Waki'.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5103]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5103

Miqdad reported: I and two of my companions were so much afflicted by hunger that we had lost our power of seeing and hearing. We presented ourselves (as guests) to the Companions of the Holy Prophet (may peace be upon him), but none amongst them would entertain us. So we came to Allah's Apostle (may peace be upon him), and he took us to his residence and there were three goats. Allah's Apostle (may peace be upon him) said: Milk these for us. So we milked them and every person amongst us drank his share and we set aside the share of Allah's Apostle (may peace be upon him). (It was his habit) to come during the night and greet (the people present there) in a manner that would not wake up one in sleep but make one who was awake hear it. He would then go to the mosque and say prayer, then go to the milk and drink it. Miqdad added: One night the Satan came to me when I had taken my share, and he said: Muhammad has gone to the Ansar, who would offer him hospitality and he would get what is with them, and he has no need for this draught (of milk). So I took (that milk) and drank it, and when it had penetrated deeply in my stomach and I was certain that there was no way out (but to digest it), the Satan aroused (my sense of) remorse and said: Woe be to thee! what have you done? You have taken the drink reserved for Muhammad! When he would come and he would not find it, he would curse you, and you would be ruined, and thus there would go (waste) this world and the Hereafter (for) you. There was a sheet over me; as I placed (pulled) it upon my feet, my head was uncovered and as I placed it upon my head, my feet were uncovered, and I could not sleep, but my two companions had gone to sleep for they had not done what I had done. There came Allah's Apostle (may peace be upon him), and he greeted as he used to greet (by saying as-Salamu 'Alaikum). He then came to the mosque and observed prayer and then came to his drink (milk) and uncovered it, but did not find anything in it. He raised his head towards the sky, and I said (to myself) that he (the Holy Prophet) was going to invoke curse upon me and I would be thus ruined; but he (the Holy Prophet) said: Allah, feed him who fed me and give drink to him who provided me drink. I held tight the sheet upon myself (and when he had supplicated), I took hold of the knife and went to the goats (possessed by the Holy Prophet) so that I may slauhter one for Allah's Messenger (may peace be upon him) which was the fattest amongst them, and in fact all of them were milch goats; then I took hold of the vessel which belonged to the family of Allah's Messenger (may peace be upon him) in which they used to milk and drink therefrom, and milked them in that until it swelled up with foam. I came to Allah's Messenger (may peace be upon him) and he said: Have you taken your share of the milk during the night? I said: Drink it. and he drank it; he then handed over (the vessel) to me and I said: Allah's Messenger, drink it, and he drank it and handed over (the vessel) to me again, I then perceived that Allah's Apostle (may peace be upon him) had been satiated and I had got his blessings. I burst into laughter (so much) so that I fell upon the ground, whereupon Allah's Messenger (may peace be upon him) said: Miqdad, it must be one of your mischiefs. I said: Allah's Messenger, this affair of mind is like this and this. and I have done so. Thereupon. Allah's Apostle (may peace be upon him) said: This is nothing but a mercy from Allah. Why is it that you did not give me an opportunity so that we should have awakened our two friends and they would have got their share (of the milk)? I said: By Him Who has sent you with Truth. I do not mind whatever you give (to them), and whatever the (other) people happen to get, when I had got it along with you from among the people.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5104]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5104

This hadith has been reported on the authority of Mughira with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5105]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5105

'Abd al-Rahman b. Abu Bakr reported: We were one hundred and thirty (persons) with Allah's Apostle (may peace be upon him). Allah's Apostle (may peace be upon him) said: Does any one of You possess food? There was a person with (us) who had a sa' of flour or something about that, and it was kneaded. Then a tall polytheist with dishevelled hair came driving his flock of sheep. Thereupon Allah's Apostle (may peace be upon him) said: Would you like to sell it (any one of these goats) or offer it as a gift or a present? He said: No, (I am not prepared to offer as a gift), but I would sell it. He (the Holy Prophet) bought a sheep from him, and it was slaughtered and its meat was prepared, and Allah's Messenger (may peace be upon him) commanded that its liver should be roasted. He (the narrator) said: By Allah, none among one hundred and thirty persons was left whom Allah's Messenger (may peace be upon him) had not given a part out of her liver; if anyone was present he gave it to him. but if he was absent it was set aside for him. And he (the Holy Prophet) filled two bowls (one with soup and the other with mutton) and we all ate out of them to our hearts' content, but (still) some part was (left) in (those) two bowls, and I placed it on the camel- (or words to the same effect).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5106]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5106

'Abd al-Rabman b. Abu Bakr reported that the people of Suffa were very poor. Once the Messenger of Allah (may peace be upon him) said (to his Companions): He who amongst you has food for two persons should take three (guests with him). and he who has with him food for four persons should take five or six (guests with him for entertaining them). It was (in accordance with these instructions of the Holy Prophet) that Abu Bakr brought three persons, and the Apostle of Allah (may peace be upon him) brought ten persons (as guests to their respective houses). Abu Bakr had brought three persons (he himself, and myself), my father and my mother (along with therm). He (the narrator) said: I do not know whether he also said: My wife and one servant who was common between our house and that of Abu Bakr. Abu Bakr had had his evening meal with Allah's Apostle (may peace be upon him). He stayed here until night prayer had been offered. He then came back (to the house of Allah's Apostle) and stayed there until Allah's Messenger (may peace be upon him) felt drowsy and (Abu Bakr) then came (back to his own house) when (a considerable) part of the night had been over, as Allah had desired. His wife said to him: What held you back from your guests? He said: Oh! have you not served them the evening meal (by this time)? She said: It was in fact served to them. but they refused to eat until you came. He ('Abd al-Rahman) said: I slunk away and bid myself. He (Abu Bakr) said: O, you stupid fellow, and he reprimanded me, and said to the guests: Eat, though it may not be pleasant now. He said: By Allah. I will never eat it He ('Abd al-Rahman) said: By Allah. we did not take a morsel when from beneath that (there appeared) more until they had eaten to their fill, and lo! it was more than what it was before. Abu Bakr saw that and found that it was so or more than that. He said to his wife: Sister of Band Firis, what is th-is? She said: By the coolness of my eyes. it is in excess by three times over the previous one. Then Abu Bakr ate saying: That was from the Satan (viz. his vow for not eating the food). He then took a morsel out of that and then took it (the rest) to the Messenger of Allah (may peace be upon him), and it was kept there until morning, and during (those days) there was a covenant between us and some other people, and the period of covenant was over, and we had appointed twelve officials with every person amongst them. It is Allah only Who knows as to how many people were there with each of them. He sent (this food to them) and all of them ate out of it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5107]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5107

'Abd al-Rahman b. Abd Bakr reported: There came to our house some guests. It was a common practice with my father to (go) and talk to Allah's Messenger (may peace be upon him) during the night. While going he said: 'Abd al-Rahman, entertain the guests. When it was evening we served the food to them, but they refused saying: So long as the owner of the house does not come and join us, we would not take the meal. I said to them: He ('Abd Bakr) is a stern person, and if you would not do that (if you do not take the food). I fear, I may be harmed by him, but they refused. As he (my father) came, the first thing he asked was: Have you served the guests? They (the peopleof the household) said: We have not served them sofar. He said: Did I not command 'Abd al-Rahman (to do this)? He ('Abd al-Rahman) said: I slunk away and kept myself away by that time. He again said: O stupid fellow, I ask you on oath that In case you hear my voice you come to me. I came and said: By Allah, there is no fault of mine. These are your guests; you may ask them. I provided them with food but they refused to eat until you came. He said to them: Why is it that you did not accept our food? By Allah, I shall not even take food tonight (as you have not taken). They said: By Allah, we would not take until you join us. Thereupon he Abu Bakr) said: I have never seen a more unfortunate night than this. Woe be to thee! that you do not accept from us food prepared for you. He again said: What I did first (that is the taking of vow for not eating the food) was prompted by the Satan. Bring the food. The food was brought, and he ate by reciting the name of Allah and they also ate, and when it was morning he came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, their oath (that of the guests) came to be true, but mine was not true, and after that he informed him of the whole incident. He said: Your oath came to be the most true and you are the best of them. He (the narrator) said. I do not know whether he made an atonement for it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5108]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5108

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Food for two persons suffices three persons and food for three persons suffices four persons.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5109]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5109

Jabir b. 'Abdullah reported: I heard Allah'. s Messenger (may peace be upon him) as saying: Food for one person suffices two persons and food for two persons suffices four persons, and food for four persons suffices eight persons; and in the tradition transmitted on the authority of Ishaq there is no mention of the fact that he heard it directly (from the Holy Prophet).


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5110]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5110

A hadith like this is reported on the authority of Jabir but with a different chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5111]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5111

Jabir reported Allah's Messenger (may peace be upon him) as saying: Food for one suffices two and food for two suffices for tour.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5112]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5112

Jabir reported Allah's Messenger (may peace be upon him) as saying: Food for one (person) sqffices two, and food for two (persons) suffices four persons and food for four persons suffices eight persons.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5113]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5113

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying that a non-Muslim eats in seven intestines whereas a Muslim eats in one intestine.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5114]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5114

This hadith has been reported on the authority of Ibn 'Umar but with a different chain oi transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5115]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5115

Nafi' reported that Ibn 'Umar saw a poor man. He placed food before him and he ate much. He (Ibn 'Umar) said: He should not come to me. for I heard Allah's Messenger (may peace be upon him) as saying that the non-Muslim eats in seven intestines.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5116]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5116

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: A believer eats in one intestine, whereas a non-believer eats in seven intestines.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5117]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5117

This hadith has been transmitted on the authority of Jabir.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5118]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5118

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: A believer eats in one intestine, whereas a non-believer eats in seven intestines.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5119]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5119

This hadith has been narrated on the authority of Abu Huraira with a different chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5120]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5120

Abu Huraira reported that Allah's Messenger (may peace be upon him) invited a non-Muslim. Allah's Messenger (may peace be upon him) commanded that a goat be milked for him. It was milked and he drank its milk. Then the second one was milked and he drank its milk, and then the other one was milked and he drank its milk. till he drank the milk of seven goats. On the next morning he embraced Islam. And Allah's Messenger (may peace be upon him) commanded that a goat should be milked for him and he drank its milk and then another was milked but he did not finish it, whereupon Allah's Messenger (may peace be upon him) said: A believer drinks In one intestine whereas a non-believer drinks in seven intestines.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5121]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5121

Abu Huraira reported that Allah's Messenger (may peace be upon him) never found fault with food (served to him). If he liked anything, he ate it and if he did not like it he left it.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5122]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5122

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5123]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5123

A hadith like this has been narrated on the authority of A'mash.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5124]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5124

Abu Huraira reported: I never saw Allah's Messenger (may peace be upon him) finding fault with food (served to him) ; if he liked it he ate it, and if did not like it he kept silent.


Muslim :: The Book of Drinks (Kitab Al-Ashriba) :: [23.5125]

The Book of Drinks (Kitab Al-Ashriba)

Muslim :: Book 23 : Hadith 5125

This hadith has been narrated on the authority of Abu Huraira through a different chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5126]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5126

Umm Salama, the wife of Allah's Apostle (may peace be upon him), said: He who drinks in the vessel of silver in fact drinks down in his belly the fire of Hell.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5127]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5127

This hadith has been narrated on the authority of 'Ubaidullah through other chains of transmitters: He who eats or drinks in the vessel of silver and gold, - but there is no mention in any one of them of the words pertaining to eating and gold.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5128]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5128

Abd al-Rahman reported on the authority of his mother's sister Umm Salama who said that Allah's Messenger (may peace be upon him) said: He who drank in vessels of gold or silver he in fact drank down in his belly the fire of Hell.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5129]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5129

Mu'awiya b. Suwaid b. Muqarrin reporxed: I visited al-Bara' b. 'Azib and heard him say: Allah's Messenger (may peace be upon him) commanded us to do seven things and forbade us to do seven (things). He commanded us to visit the sick, to follow the funeral procession, to answer the sneezer, to fulfil the vow, to help the poor, to accept the invitation and to greet everybody, and he forbade us to wear rings or gold rings, to drink in silver (vessels), and to use the saddle cloth made of red silk, and to wear garments made of Qassi material, or garments made of silk or brocade and velvet.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5130]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5130

This hadith has been reported on the authority of Ash'ath b. Sulaim with the same chain of transmitters but with a slight change of wording that he made no mention of:" to fulfil the vows" but substituted these words:" finding of the lost articles".


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5131]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5131

This hadith has been narrated on the authority of Ash'ath b. Abu ashSha'tha' with the same chain of transmitters (and with these words): There is no doubt about the words: To fulfil the vows were mentioned and this addition had been made in the. hadith: (The Holy Prophet) forbade drinking in silver vessels, for one who drinks (in them) in this world would not drink (in them) in the Hereafter.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5132]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5132

This hadith has been narrated on the authority of Ash'ath b. Sulaim with the same chain of transmitters but with this difference that instead of the words: Ifsha as-Salam (spreading the salutations), he substituted the words Radd as-Saldm (i. e. responding to the words of salutation) and he said: He forbade (the use of) gold ring.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5133]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5133

This hadith has been narrated on the auttiniity of Ash'ath b. Sulaim with the same chain of transmitters but the words (pertaining to) Ifsha as-Salam and the (use) of gold ring have been reported without doubt.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5134]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5134

'Abdullah b. Ukaim reported: While we were with Hudhaifa in Mada'in he asked for water. A villager brought a drink for him in a silver vessel. He (Hudhaifa) threw it away saying: I inform you that I have already conveyed to him that he should not serve me drink in it (silver vessel) for Allah's Messenger (may peace be upon him) had said: Do not drink in gold and silver vessels, and do not wear brocade or silk, for these are meant for them (the non-believers) in this world, but they are meant for you in the Hereafter on the Day, of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5135]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5135

This badith has been reported on the authority of 'Abdullah b. Ukaim with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5136]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5136

This hadith has been narrated on the authority of lbn 'Ukaim through another chain of transmitters, but in this hadith no mention is made of the words:, On the Day of Resurrection"


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5137]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5137

Shu'ba reported from al-Hakam that he heard 'Abd al-Rahmin (i. e. Ibn Abu Laila) as saying: I personally saw Hudhaifa asking for water in Mada'in and a man giving it to him in a silver vessel. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5138]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5138

This badith has been narrated on the authority of Shu'ba through another chain of transmitters. but there is no mention of the fact: ', I personally saw him" in this hadith.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5139]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5139

This hadith has been reported on the authority of Hudhaila with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5140]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5140

'Abd al-Rahmin b. Abu Laili reported that Hudhaifa asked for water and a Magian gave him water in a silver vessel, whereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: Do not wear silk or brocade and do not drink ifi vessels of gold and silver, and do not eat in the dishes made of them (i. e. gold and silver), for these are for them (the non-believers) in this world.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5141]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5141

Ibn Umar reported that Umar b. Khattab saw (some one selling) the garments of silk at the door of the mosque, whereupon he said: Allah's Messenger, would that you buy it and wear it for the people on Friday and for (receiving) the delegations when they come to you? Upon this. Allah's Messenger (may peace be upon him) said: go who wears it has no share (of reward) in the Hereafter. Then these garments were sent to Allah" s Messenger (may peace be upon him), and he presented one of these silk garment to Umar. Thereupon Umar said: You make me wear (this silk garment) Whereas you said about the silk garment of Utarid (the person who had been busy selling this garment at the door of the mosque) what you had to say, whereupon Allah's Messenger (may peace be upon him) said: I have not presented you this for wearing it (but to make use of its price) ; so 'Umar presented it to his polytheist brother in Mecca.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5142]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5142

This hadith has been narrated by Ibn Umar through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5143]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5143

Ibn Umar reported that Umar saw Utarid al-Tamimi standing in the market (and selling) the silk garments, and he was the person who went to (courts of) kings and got (high prices) for these garments from them. Umar said: Allah's Messenger I saw 'Utarid standing in the market with a silk garment; would that you buy and wear it for (receiving) the delegations of Arabs when they visit you? I (the narrator) said: I think he ('Umar) also said: You may wear it on Friday (also). Thereupon, Allah's Messenger (may peace he upon him) said: He who wears silk in this world has no share in the Hereafter. Later on when these silk garments were presented to Allah's Massenger (may peace be upon him) he presented one silk garment to 'Umar and presented one also to Usama b. Zaid and gave one to 'Ali b. Abu 'Talib. saying: Tear them and make head coverings for your ladies. 'Umar came carrying his garment and said: Allah's Messenger, you have sent it to me, whereas you had said yesterday about the (silk) garment of Utarid what you had to say. He (the Holy Prophet) said: I have not sent it to you that you wear it, but I have sent It to you so that you may derive benefit out of it; and Usama (donned) the garment (presented to him) and appeared to be brisk, whereupon Allah's Apostle (may peace be upon him) looked at him with a look by which he perceived that the Messenger of Allah (may peace be upon him) did not like what he had done. He said: Allah's Messenger. why is it that you look at me like this. whereas you yourself presented it to me? He said: I never sent it to you to wear it, but I sent It to you so that you may tear it and make out head covering for your ladies.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5144]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5144

Abdullah b. Umar reported: 'Umar b. at-Khattab found a silk garment being sold in the market; he purchased it and brought it to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, get it and adorn yourself (by wearing it) on the 'Id (days) and for the delegation. Thereupon, Allah's Messenger (may peace be upon him) said: That is the dress of one who has no share (in the Hereafter). 'Umar stayed there so long as Allah wished. Then Allah's Messenger (may peace be upon him) sent him a silk cloak. 'Umar came back with that to Allah's Messenger (may peace be upon him) and said: Allah's Messenger. you said that it is the dress of one who has no share in the Hereafter, but then you sent it to me. Thereupon, Allah's Messenger (may peace be upon him) said: You sell it and meet your need (with its proceeds).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5145]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5145

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5146]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5146

lbn 'Umar reported that 'Umar saw a person of the tribe of 'Utirid selling a garment made of brocade or silk and said to Allah's Messenger (may peace be upon him): Would that you buy it? Thereupon he (the Holy Prophet) said: He who wears it has no share for him in the Hereafter. Then Allah's Messenger (may peace be upon him) was presented with a striped silk garment and he sent it to him ('Umar). He (, Umar) said: You sent it to me whereas I heard from you about it what you had to say, whereupon he (Allah's Messenger) said: I sent it to you so that you may benefit by it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5147]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5147

This hadith has been narrated on the authority of Ibn Umar through another chain of transmitters but with a slight variation of wording (and the words are that the Holy Prophet) said: I sent it to you so that you might derive benefit from it. but I did not send it to you to wear it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5148]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5148

Ibn 'Umar reported that 'Umar saw a person with a garment of brocade and he brought it to Allah's Apostle (may peace he upon him) -the rest of the hadith is the same, except for the words that he (the Holy Prophet) said: I sent it to you that you might get money thereby.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5149]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5149

Abdullah. the freed slave of Asma' (the daughter of Abu Bakr). the maternal uncle of the son of 'Ata, reported: Asma' sent me to 'Abdullah b. 'Umar saying: The news has reached me that you prohibit the use of three things: the striped robe. saddle cloth made of red silk. and the fasting in the holy month of Rajab. 'Abdullah said to me: So far as what you say about fasting in the month of Rajab, how about one who observes continuous fasting? -and so far as what you say about the striped garment, I heard Umar b. Khatab say that he had heard from Allah's Messenger (may peace be upon him): He who wears silk garment has no share for him (in the Hereafter), and I am afraid it may not be that striped garment; and so far as the red saddle clotb is concerned that is the saddle cloth of Abdullah and it is red. I went back to Asma' and informed her. whereupon she said: Here is the cloak of Allah's Messenger (may peace be upon him). and she brought out to me that cloak made of Persian cloth with a hem of brocade, and its sleeves bordered with brocade and said: This wall Allah's Messenger's cloak with 'A'isha until she died, and when she died. I got possession of it. The Apostle of Allah (may peace be upon him) used to wear that, and we waslied it for the sick and sought cure thereby.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5150]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5150

Khalifa b. Ka'b AbCi Dhubyan reported: I heard 'Abdullah b. Zubair addressing the people and saying: Behold! do not dress yuor women with silk clothes for I heard 'Umar b. Khattab as sayinp that he had heard Allah's messenger (may peace be upon him) as saying: Do not wear silk, for one who wear it in this world will not wear it in the Hereafter.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5151]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5151

'Asim al-Abwal reported on the authority Abu Uthman saying: 'Umar wrote to us when we were in Adharba'ijan saying: 'Utba b. Farqad, this wealth is neither the result of your own labour nor the result of the labour of your father, nor the result of the labour of your mother, so feed Muslims at their own places as you feed (members of your family and yourselves at your own residence), and beware of the life of pleasure, and the dress of the polytheists and wearing of silk garments, for Allah's Messenger (may peace be upon him) forbade the wearing of silk garments, but only this much, and Allah's Messenger (may peace be upon him) raised his. forefinger and middle finger and he joined. them (to indicate that only this much silk can be allowed in the dress of a man). 'Asim said also: This is what is recorded in the lette., (sent to us), and Zuhair raised his two fingers (to give an idea of the extent to which silk may be used).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5152]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5152

This hadith has been transmitted on the authority of 'Asim.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5153]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5153

Abu 'Uthman reported: While we were with 'Utba b. Farqad there came a letter of 'Umar (containing the instructions) that Allah's Messenger (may peace be upon him) had said: None should wear silk (with the exception of so much) but he will have nothing of it in the Hereafter. Abu 'Uthman said: To the extent of two fingers which are close to the thumb, and I was shown the (silk) borders of the Tayalisa mantle (which were about two fingers in breadth and I saw them.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5154]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5154

Qatada reported: I heard Abe 'Uthman al-Nahdi as saying: There came to us a letter of 'Umar as we were in Adharba'ijan or in Syria in the company of 'Utba b. Farqad (and the letter ran thus): After (usual praise and glorification of Allah) it is stated that Allah's Messenger (may peace be upon him) has forbidden the use of silk btit to the extent of these two fingers, and Abu Uthman said: We at once understood by these words that he meant (silk) patterns on (the cloth).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5155]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5155

This hadith has been reported on the authority of Qatada but there is no mention of the words of Abd Uthman.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5156]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5156

Suwaid b. Ghafala said: 'Umar addressed us at a place known as Jabiya (Syria) and he said: Allah's Apostle (may peace be upon him) forbade us the wearing of silk but to the extent of two or three fingers or four fingers.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5157]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5157

This hadith has been narrated on the authority of Qatada with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5158]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5158

Jabir b. Abdullah reported that one day Allah's Apostle (may peace be upon him) put on a cloak made of brocade, which had been presented to him. He then quickly put it off and sent it to 'Umar b. Khattab, and it was said to him: Messenger of Allah. why is it that you put it of immediately. whereupon he said: Gabriel forbade me from it (i. e. wearing of Ods garment), and 'Umar came to him weeping and said: Messenger of Allah you disapproved a thing but you gave it to me. What about me, then? Thereupon be (the Holy Prophet) Wd: I did not give it to you to wear it, but I gave you that you might sell it; and so he (Hadrat Umar) sold it for two thousand dirhams.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5159]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5159

'Ali reported: A silk cloak was presented to Allah's Messenger (may peace be upon him). and he sent it to me and I wore it. but then found some sign of disapproval upon his face, whereupon he said: I did not send it to you that you wear it, but I sent it to you so that you might tear it and make out head dream for your women.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5160]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5160

This hadith has been narrated on the authority of Mubammad b. Ja'far but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5161]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5161

'Ali reported that Ukaidir of Duma presented to Allah's Apostle (may peace be upon him) a silk garment, and he presented it to 'Ali. and said: Tear it to make head covering for Fitimas out of it. This tradition is transmitted on the authority of Abu Bakr, and Abu Kuraib said: Among the women.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5162]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5162

'Ali b. Abu Talib reported that Allah's Messenger (may peace be upon him) gave me to wear a garment in the form of silk cloak. I went out wearing it, but saw signs of anger on his face, so I tore it and distributed it amongst my women.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5163]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5163

Anas b. Malik reported that Allah's Messenger (may Peace be upon him) sent a silk gown to 'Umar, whereupon 'Umar said: You sent it to me whereas you said what you had to, say (i. e. it is forbidden for men). Thereupon he (the Holy Prophet) said: I did not send it to you so that you might wear it, but I sent it to you so that you might derive benefit from its price.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5164]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5164

Anas reported that Allah's Messenger (may peace be upon him) said: He who wore silk in this world would not wear it in the Hereafter.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5165]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5165

Abu Umama reported Allah's Messenger (may peace be upon him) having said: He who wore silk in this world would not wear it in the Hereafter.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5166]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5166

Uqba b. 'Amir said: A silk go vn was presented to Allah's Messenger (may peace be upon him) and he wore it and observed prayer in it and then returned and put it off so violently as if he despised it. He then said: It does not befit the Godfearing persons.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5167]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5167

This hadith has been narrated on the authority of azid b. Abu Habib with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5168]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5168

Anas b. Malik reported to them (his companions) that Allah's Messnger (may peace be upon him) had granted concession to Abd al-Rahman b. *Anf and Zubair b. 'Awwam for the wearing of a silk shirt during the journey and because of itch which they both had or any other disease from which both of them had been suffering.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5169]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5169

This hadith has been narrated on the authority of Sa'd with the same chain of transmitters but there is no mention of the word" journey".


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5170]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5170

Anas reported that Allah's Messenger (may peace be upon him) granted concession, or Zubair b. Awwam and 'Abd Al-Rahman b. Auf were granted concession, for the wearing of silk because of the itch that they both had.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5171]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5171

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5172]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5172

Anas b. Malik reported that 'Abd al-Rahman b. Auf and Zu'bair. b. 'Awwam complained to Allah's Messenger (may peace be upon him) about lice; he granted them concession to wear shirts of silk.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5173]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5173

'Abdullah b. 'Amr b. al-As reported: Allah's Messenger (may peace be upon him) saw me wearing two clothes dyed in saffron. whereupon he said: These are the clothes (usually worn by) the non-believers, so do not wear them.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5174]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5174

This hadith has been reported on the authority of Yahya b. Abu Kathir with the same chain of trarnmitteis.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5175]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5175

'Abdullah b. 'Amr reported: Allah's Apostle (may peace be upon him) saw me in two clothes dyed in saffron, whereupon he said: Has your mother ordered you to do so? And I said: I will wash them. He said: But burn them.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5176]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5176

'Ali b. Abu Talib reported that Allah's Messenger (may peace be upon him) forbade wearing of silk and yellow clothes, and the gold ring, and the reciting of the Qur'an in the ruku' (state of kneeling in prayer).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5177]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5177

Ali b. Abu Talib reported: Allah's Apostle (may peace be upon him) forbade me to recite the Qur'an while I am in ruku; and the wearing of gold and clothes dyed in saffron.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5178]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5178

'Ali b. Abu Talib reported: Allah's Meisenger (may peace be upon him) forbade me to use gold rings. to wear silk clothes and to recite the Qur'an in ruku' and sajda (prostration), and to wear yellow garments.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5179]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5179

Qatada said: We asked Anas b. Malik which garment did Allah's Messenger may peace be upon him) love or like (to wear). He said: The mantle of Yemen.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5180]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5180

Anas reported that the garment most liked by Allah's Messenger (may peace be upon him) was the mantle of Yemen.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5181]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5181

Abu Burda reported: I visited A'isha and she brought out for us the coarse lower garfnent (of Allah's Messenger) made in Yemen and clothes made out of Mulabbada cloth, and she swore in the name of Allah that Allah's Messenger (may peace be upon him) died in these two clothes.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5182]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5182

Abu Burda reported that A'isha brought out for us the lower garment and the upper garment made of the Mulabbada cloth and said: It was in these (clothes) that Allah's Messenger (may peace be upon him) died. Ibn Hatim (one of the narrators) in his narration Wd: The lower garment of coarse cloth.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5183]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5183

This hadith has been reported on the authority of Ayyub with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5184]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5184

A'isha reported that Allah's Apostle (may peace be upon him) went out one morning wearing a blanket made of (camel's or sheep's) black hair with patterns of camel saddles upon it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5185]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5185

A'isha reported that the pillow on which Allah's Messenger (may peace be upon him) reclined was of leather stuffed with palm fibre.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5186]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5186

A'isha reported that the bedding on which. Allah's Messenger (may peace be upon him) slept was made of leather stuffed with palm fibre.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5187]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5187

This hadith has been reported on the authority of Hisham b. 'Urwa with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5188]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5188

Jabir reported: When I was married, Allah's Messenger (may peace he upon him) asked me if I had got the carpet. I said: How can we have carpets? (i. e. I am so poor that I cannot even think of carpets). whereupon he said: You shall soon possess them.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5189]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5189

Jabir b. Abdullah reported: When I was married. Allah's Messenger (may peace be upon him) asked me if I had got carpets. I said: How can we have carpets? Thereupon he Wd: You will soon have. Jabir said: My wife had possessed a carpet. and I said to her to remove that away from me, but she would say! Allah's Messenger (may peace be npon him) had said: Yon will soon have. This hadith has been narrated on the authority of Sufyin with the saule chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5190]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5190

Jabir b. 'Abdullah reported that Allah's Messengor (may peace be upon him) said: There should be a bedding for a man. a bedding for his wife and the third one for the guest, and the fourth one is for the Satan.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5191]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5191

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: Allah will not look upon him who trails his garment out of pride.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5192]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5192

This hadith has been narrated on the authority of Ibn 'Umar through other chains of transmitters also with the addition of these words:" On the Day of Resurrection."


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5193]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5193

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: He who trails his (lower) garment out of pride, Allah will not look toward him on the Day of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5194]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5194

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5195]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5195

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: He who trailed his garment out of pride, Allah would not look toward him on the Day of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5196]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5196

Salim reported: I heard Ibn Umar as saying that he had heard Allah's Messenger (may peace be upon him) as saying like this (as mentioned above) but with a slight variation of wording [that instead of the word thaub (cloth) there is the word thiyab (the clothes) ].


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5197]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5197

Muslim b. Yannaq reported that Ibn Umar saw a person trailing his lower garment, whereupon he said: From whom do you come? He described his relationship (with the tribe he belonged) and it was found that he belonged to the tribe of Laith. Ibn. Umar recognised him and said: I heard Allah's Messenger (may peace be upon him) with these two ears of mine saying: He who trailed his lower garment with no other intention but pride, Allah would not look toward him on the Day of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5198]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5198

This hadith has been narrated on the authority of Muslim b. Yannaq through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5199]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5199

Mubammad b. 'Abbad b. ja'far reported: I ordered Muslim b. Yasar, the freed slave of Nafi' b. 'Abd al-Harith, while I was sitting between them, that he should ask Ibn 'Umar if he had heard anything from Allah's Messenger (may peace be upon him) pertaining to one who trails his lower garment out of pride. He said: I heard him (the Holy Prophet) as saying: Allah will not look toward him on the Day of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5200]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5200

Ibn 'Umar reported: I happened to pass before Allah's Messenger (may peace be upon bin) with my lower garment trailing (upon the ground). He said: 'Abdullah, tug up your lower garment,, I tugged it up, and he again said: Tug it still further, and I tugged it still further and I went on tugging it afterward, whereupon some of the people said: To what extent? Thereupon he said: To the middle of the shanks.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5201]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5201

Abu Huraire reported that he saw a person whose lower garment bad been trailin. and he was striking the ground with his foot (conceitedly). He was the Amir of Bahrain and it was being said: Here comes the Amir, here comes the Amir. He (Abu Huraira) reported that Allah's Messenger (may peace be upon him) said: Allah will not look toward him who trails his lower garment out of pride.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5202]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5202

This hadith has been reported on the authority of Shu'ba with the same chain of transmitters and in the hadith transmitted on the authority of Ibn ja'far (the words are): Marwan had made Abu Huraira as his deputy. and in the hadith transmitted on the authority of Ibn Muthanna (the words are). Abu Huraira was the Governor of Medina.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5203]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5203

Abu Huraira reported that Allah's Messenger (may peace be upon him) said that there was a person who used to walk with pride because of his thick hair and fine mantles. He was made to sink in the earth and he would go on sinking in the earth until the Last Hour would come.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5204]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5204

This hadith has been narrated on the authority of Abu Huraira but with a different chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5205]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5205

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was a person who walked with pride because of his (fine) mantles and well pleased with his personality. Allah made him sink in the earth and he would go on sinking in that until the Day of Resurrection.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5206]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5206

This hadith has been transmitted on the authority of Abu Huraira but with a slight variation of wording: While there was a man who strutted in his two mantles.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5207]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5207

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was a person (living before you) who took pride in his cloak. the rest of the hadith is the same.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5208]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5208

Abu Huraira reported that Allah's Apostle (may peace be upon him) forbade the wearing of gold signet ring.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5209]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5209

Abdullah b. 'Abbas reported that Allah's Messenger (may peace be upon him) saw a person wearing a gold signet ring in his hand. He (the Holy Prophet) pulled it off and threw it away, saying: One of you is wishing live coal from Hell. and putting it on his hand. It was said to the person after Allah's Messenger (may peace be upon him) had left: Take your signet ring (of gold) and derive benefit out of it. whereupon he said: No, by Allah, I would never take it when Allah's Messenger (may peace be upon him) has thrown it away.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5210]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5210

'Abdullah reported that Allah's Messenger (may peace be upol him) got fashioned a signet ring of gold but he kept its stone on the inner side of his palm as he wore it, so the people (following his example) got fashioned (such rings). Then one day as he sat on the pulpit he pulled it away saying: I wore this ring and kept its stone towards the inner side. He then threw it away, and said: By Allah, I will never wear it; so the people threw their rings away.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5211]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5211

This hadith has been narrated on the authority of Ibn 'Umar through other chains of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5212]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5212

Ibn Umar reported that Allah's Messenger (may peace be upon him) had made for himself a ring of silver, and he (wore it in his finger). then it was in Abu Bakr's finger. then it was in'Umar's finger. then it was in 'Uthman's finger. until it fell into the well of Aris and it had these words engraved upon it (Muhammad, Messenger of Allah). Ibn Numair narrated it with a slight variation of words.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5213]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5213

Ibn Umar reported that Allah's Apostle (may peace be upon hirn) had made for himself a gold ring; then lie discarded it. and then made for himself a silver ring. and had these words engraved upon it (Mubamrnad, Messenger of Allah), and said: No one should engrave anything like the engraving of this signet ring of mine. and when he Wore it. he kept its stone towards the inside of his palm, and it was this which fell down (from the hands) of Mu'ayqib into the well of Aris.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5214]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5214

Anas b. Malik reported that Allah's Apostle (may peace be upon him) had made for him a silver ring. and got engraved on it (Mubamrnad, Messenger of Allah) and said to the people I have got made a ring of silver and engraved in it (these words) (Mubamrnad, Messenger of Allah). So none should engrave these (words) like this engravement.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5215]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5215

This hadith nas been reported on the authority of Anas through another chain of transmitters but there is no mention of the words (Mubamrnad, Messenger of Allah) in it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5216]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5216

Anas b. Malik reported that when Allah's Messenger (may peace be upon him) decided to write letters to the Byzantine (Emperor) they (his Companions) told him that they would not read a letter unless it is sealed. (Then) Allah's Messenger (may peace be upon him) had a silver ring made (for himealf), (its shape is to vivid in my mind) as if I see its brightness in the band of Allah's Messenger (may peace be upon him) and its engravement was (Mubamrnad, Messenger of Allah).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5217]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5217

Anas reported that when Allah's Apostle (may peace be upon him) decided to write (letters) to non-Arabs (i. e. Persian and Byzantine Emperors) it was said to him that the non-Arabs would not accept a letter but that having a seal over it; so he (the Holy Prophet) got a silver ring made. He (Anas) said: I perceive as if I am looking at its brightness in his hand.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5218]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5218

Anas reported that when Allah's Apostle (may peace be upon him) decided to write to the Kisri (the King of Persia), Caesar (Emperor of Rome), and the Negus (the Emperor of Abyssinia), it was said to him that they would not accept the letter without the seal over it; so Allah's Messenger (may peace be upon him) got a seal made, the ring of which was made of silver and there was engraved on it. (Mubammad. the Messenger of Allab).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5219]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5219

Anas b. Malik reported: I saw one day on the finger of Allah's Messenger (may peace be Upon him) a silver ring; so the people also got silver rings made and wore them Then Allah's Apostle (may peace be upon him) discarded his ring, and the people also discarded their rings.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5220]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5220

Anas b. Malik reported that one day he saw on the finger of Allah's Messenger (may peace be upon him) a silver ring, and the people also made silver rings and put them on. Then Allah's Apostle (may peace be upon him) threw his ring away, and so the people also threw away their rings.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5221]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5221

A hadith like this has been reported on the authority of Ibn Juraij with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5222]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5222

Anas b. Malik reported that the ring of Allah's Messenger (may peace be upon him) was made of silver and it had an Abyssinian stone in it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5223]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5223

Anas b. Malik reported that Allah's Messenger (may peace be upon him) wore a silver ring on his right hand which had an Abyssinian stone in it, and he kept its stone towards the palm.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5224]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5224

This hadith has been narrated on the authority of Yunus b. Yazid with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5225]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5225

Anas reported that the ring of Allah's Apostle (may peace be upon him) was on this, and he pointed toward the little finger of his left hand.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5226]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5226

Ali reported: He the Holy Prophet (may peace be upon him), forbade me that I should wear my ring in this (forefinger) or in that near it. 'Asim (one of the narrators in the chain of transmitters) said: He did not remember which of the two (fingers) he pointed out; and he forbade to wear Qassi material (silk garments), and to sit on the silk saddle cloth, and he said: As regards Qassi, it is a variegated garment which was brought from Egypt and Syria which had figures upon it, and as regards Mayathir, it is something which women prepared for their husbands as red cloths for their saddles.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5227]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5227

A hadith like this has been reported on the authority of 'Ali through a different chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5228]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5228

'Ali b. Abu Talib reported that he (Allah'. s Apostle) forbade or forbade me. the rest of the hadith is the same.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5229]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5229

'Ali reported: Allah's Messenger (may peace be upon him) forbade me that I should wear a ring in this and that finger of mine, and he pointed to the middle finger and the next one.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5230]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5230

Jabir reported: I heard Allah's Apostle (may peace be upon him) saying during an expedition in which we also participated: Make a general practice of wearing sandals, for a man is riding as it were when he wears sandals.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5231]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5231

Abu Huraire reported Allah's Messenger (may peace be upon him) as saying: When one of you puts on sandals, he should first put in the right foot, and when he takes off he should take off the left one first, or he should put them on together or take them off together.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5232]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5232

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should walk in one sandal; either he should wear the two or should take off the two.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5233]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5233

Abu Razin reported: Abu Huraira came to us and he struck his forehead with his hand and said: Behold I you talk amongst yourself that I attribute wrongly to Allah's Messenger (may peace be upon him) (certain things) in order to guide you to the right path. In such a case, I would myself go astray. Listen. I bear testimony to the fact that I heard Allah's Messenger (may peace be upon him) saying: When the thong of any one of you is broken, he should not walk in the second one until he has got it repaired. This hadith has been reported on the authority of Abu Huraira with a different chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5234]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5234

Jabir reported that Allah's Messenger (may peace be upon him) forbade that a man should eat with the left hand or walk with one sandal or wrap himself completely leaving no opening for the arms (to draw out) or support himself when sitting with a single garment wrapped round his knees which may expose his private parts.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5235]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5235

Jabir reported Allah's Messenger (may peace be upon him) as saying: When the thong of the shoe of any one of you is cut off. he should not walk with one sandal until he has got the thong repaired, and he should not walk with one shoe and he should not eat with his left hand and should not wrap his cloth round his knees or wrap himself completely leaving no room for the arins.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5236]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5236

Jabir reported that Allab's Messenger (may peace be upon him) forbade the wrapping of oneself completely leaving no room for the arm and supporting oneself when sitting with a single garment wrapped round one's knees and a person raising one of his feet and placing it on the other while lying on his back. 2512


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5237]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5237

Jabir. b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Do not walk in one sandal and do not wrap the lower garment round your knees and do not eat with your left hand and do not wrap yourself completely leaving no room for the arms (to draw out) and do not place one of your feet upon the other while lying on your back.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5238]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5238

Jalbir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: None of you should lie on his back and place one of his feet upon the other.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5239]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5239

'Abbad b. Tamim reported from his uncle that he saw Allah's Messenger (may peace be upon him) lying in the mosque and placing his one foot upon the other.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5240]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5240

This hadith has been narrated on the authority of Zuhri with the same chain of transmitter.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5241]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5241

Anas b. Malik reported that Allah's Apostle (may peace he upon him) forbade dyeing (one's cloth or hair) in saffron. Hammad said that it pertains to men only.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5242]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5242

Anas reported that Allah's Messenger (may peace be upon him) forbade that a person should (wear) clothes dyed in saffron.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5243]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5243

Jabir reported that when Abu Qubafa (father of Abu Bakr) came in the yeu of Victory or on the Day of Victory (to the Holy Prophet to pledge his allegiance to him) his head and his beard were white like hyssop. He (the Holy Prophet) commaded or the women were commanded by him that they should change this with something (that the colour of his hair should be changed).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5244]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5244

Jabir b. 'Abdullah reported that Abu Qubafa was led (to the andience of the Holy Prophet) on the day of the Conquest of Mecca and his head and beard were white like hyssop, whereupon Allah's Messenger (may peace be upon him) said: Change it with something but avoid black.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5245]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5245

Abu Horaira reported Allah's Messenger (may peace be upon him) as saying: The Jews and the Christians do not dye (their hair), so oppose them.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5246]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5246

A'isha reported that Gabriel (peace be upon him) made a promise with Allah's Messenger (may peace be upon him) to come at a definite hour; that hour came but he did not visit him. And there was in his hand (in the hand of Allah's Apostle) a staff. He threw it from his hand and said: Never has Allah or His messengers (angels) ever broken their promise. Then he cast a glance (and by chance) found a puppy under his cot and said: 'A'isha, when did this dog enter here? She said: BY Allah, I don't know He then commanded and it was turned out. Then Gabriel came and Allah's Messenger (may peace be upon him) said to him: You promised me and I waited for you. but you did not come, whereupon he said: It was the dog in your house which prevented me (to come), for we (angels) do not enter a house in which there is a dog or a picture.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5247]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5247

This hadith has been narrated on the authority of Abu Hazim with the same chain of transmitters that Gabriel had promised Allah's Messenger (may peace be upon him) that he would come; the rest of the hadith is the same, but it is not so lengthy as the other one.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5248]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5248

Maimuna reported that one morning Allah's Messenger (may peace be upon him) was silent with grief. Maimuna said: Allah's Messenger, I find a change in your mood today. Allah's Messenger (may peace be upon him) said: Gabriel had promised me that he would meet me tonight, but he did not meet me. By Allah, he never broke his promises, and Allah's Messenger (may peace be upon him) spent the day in this sad (mood). Then it occurred to him that there had been a puppy under their cot. He commanded and it was turned out. He then took some water in his hand and sprinkled it at that place. When it was evening Gabriel met him and he said to him: you promised me that you would meet me the previous night. He said: Yes, but we do not enter a house in which there is a dog or a picture. Then on that very morning he commanded the killing of the dogs until he announced that the dog kept for the orchards should also be killed, but he spared the dog meant for the protection of extensive fields (or big gardens).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5249]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5249

Abu Talha reported Allah's Apostle (may peace be upon him) having said: Angels do not enter a house in which there is a dog or a picture.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5250]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5250

Abu Talha reported: I heard Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there is a dog or a statue.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5251]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5251

This hadith has been reported on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5252]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5252

Abu Tilha, the Companion of Allah's Messenger (may peace be upon him), reported Allah's Messenger (may peace be upon him) having said: Verily, angels do not enter the house in which there is a picture. Busr reported: Zaid fell ill and we went to inquire after his health and (found) that there was hanging at his door a curtain with a picture on it. I said to 'Ubaidullah Khaulani who had been under the patronage of Maimuna, the wife of Allah's Apostle (may peace be upon him): Did not Zaid himself inform us before about (the Holy Prophet's command pertaining to the pictures), whereupon 'Ubaidullah said: Did you not hear when he said:" Except the prints on the cloth"?


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5253]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5253

Abu Talha reported that Allah's Messenger (may peace be upon him) said: Angels do not enter a house in which there is a picture. Busr said: Zaid b. Khalid fell sick and we visited him to inquire after his health. As we were in his house (we saw) a curtain having pictures on it. I said to 'Ubaidullah Khaulani: Did he not narrate to us (the Holy Prophet's command pertaining to pictures)? Thereupon he said: He in fact did that (but he also said): Except the prints upon the cloth. Did you not hear this? I said: No, whereupon He said: He had in fact made a mention of this.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5254]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5254

Abu Talha Ansari reported Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there is a picture or portraits. I came to 'A'isha and said to her: This is a news that I have received that Allah's Apostle (may peace be upon him) had said: Angels do not enter the house in which there is a picture or a dog, (and further added) whether she had heard Allah's Messenger (may peace be upon him) making a mention of it. She said: No (I did not hear this myself), but I narrate to you what I saw him doing. I bear testimony to the fact that he (the Holy Prophet) set out for an expedition. I took a carpet and screened the door with it. When he (the Holy Prophet) came back he saw that carpet and I perceived signs of disapproval on his face. He pulled it until it was torn or it was cut (into pieces) and he said: God has not commanded us to clothe stones and clay. We cut it (the curtain) and prepared two pillowa out of it by stuffing them with the fibre of date-palms and he (the Holy Prophet) did not find fault with it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5255]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5255

A'isha reported: We had a curtain with us which had portraits of birds upon it. Whenever a visitor came, he found them in front of him. Thereupon Allah's Messenger (may peace be upop him) said to me: Change them, for whenever I enter the room) I see them and it brings to my mind (the pleasures) of worldly life. She said: We had with us a sheet which had silk badges upon it and we used to wear it. This hadith has been transmitted on the authority of Ibn Muthanna but with this addition: 'Allah's Messenger (may peace be upon him) did not command us to tear that."


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5256]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5256

A'isha reported: Allah's Messenger (may peace be upon him) came back from the journey and I had screened my door with a curtain having portraits of winged horses upon it. He commanded me and I pulled it away.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5257]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5257

This hadith has been narrpted on the authority of Waki' with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5258]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5258

A'isha reported that Allah's Messenger (may peace be upon him) entered (my apartment) and I had hung (on the door of my apartment) a thin curtain having pictures on it. The colour of his face underwent a change. He then took hold of that curtain and tore it and then said: The most grievous torfnent for the people on the Day of Resurrection would be for those who try to imitate Allah in the act of creation.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5259]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5259

This hadith has been narrated on the authority of A'isha through another chain of transmitters but with a slight variation of wording (and the variation is that the narrator is reported to have said): He (the Holy Prophet) inclined towards that curtain and tore it with his hand.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5260]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5260

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5261]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5261

A'isha reported: Allah's Messenger (may peace be upon him) visited me. and I had a shelf with a thin cloth curtain hangin. over it and on which there were portraits. No sooner did he see it than he tore it and the colour of his face underwent a change and he said: A'isha, the most grievous torment from the Hand of Allah on the Day of Resurrection would be for those who imitate (Allah) in the act of His creation. A'isha said: We tore it into pieces and made a cushion or two cushions out of that.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5262]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5262

A'isha reported she had a cloth havinc, pictures upon it and it was hanging upon the shelf and Allah's Messenger (may peace be upon him) said: Take it (away) from me (from my sight), so I removed it and made cushions from that.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5263]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5263

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5264]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5264

A'isha reported: Allah's Apostle (may peace be upon him) visited me when I had screened (my door) with a carpet having pictures on it. He removed it and we made cushions out of that.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5265]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5265

A'isha, the wife of Allah's Messenger (may peace be upon him), reported that she had hung a curtain which had pictures upon it. Allah's Messenger (may peace be upon him) entered (the room) and he pulled it. A'isha said: I then tore it and prepared two cushions out of that. A person who was then in that company and whose name was Rabi'a b. 'Ata, the freed slave of Banu Zuhra, asked: Did you hear Abu Mabammad making a mention of A'isha having stated that Allah's Messenger (may peace be upon him) used to recline upon them? lbn al-Qasim said: No, but I heard Qasim b. Muhammad saying so.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5266]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5266

A'isha reported that she bought a carpet which had pictures on it. When Allah's Messenger (may peace be upon him) saw that, he stayed at the door and did not get in. I perceived or I was made to perceive upon his face signs of disgust. She said: Allah's Messenger, I offer repentance to Allah and His Messenger. (but tell me) what is the sin that I have committed. Thereupon Allah's Messenger (may peace be upon him) said: What is this carpet? She said: I bought it for you so that you might sit on it and take rest. Thereupon Allah's Messenger (may peace be upon him) said: The owners of these pictures would be tormented and they would be asked to bring to life what they tried to create. He then said: Angels do not enter the house in which there is a picture.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5267]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5267

This hadith has been narrated on the authority of A'isha through another chain of transmitters also. Some of the other ahadith narrated through other chains of transmitters are more complete and there is an addition in them (transmitted through other chains of transmitters). In the hadith transmitted on the authority of the nephew of Majishun she (A'isha) is reported to have said: I took it and prepared two cushions out of that and he (the Holy Prophet) used to recline against them in the house.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5268]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5268

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: Those who paint pictures would be punished on the Day of Resurrection and it would be said to them: Breathe soul into what you. have created.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5269]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5269

Ibn 'Umar reported a hadith like this through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5270]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5270

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Verity the most grievously tormented people on the Day of Resurrection would be the painters of pictures. Ashajj (one of the narrators) in the hadith narrated by him did not make mention of the word" verity".


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5271]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5271

This haditli has been reported on the authority of Abu Mu'awiya through another chain of tranmitters (and the words are):" Verity, the most grievously tormented people amongest the denizens of Hall on the Day of Resurrection would be the painters of pictures. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5272]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5272

Muslim b. Subaih reported: I was with Masriuq in the house which had the portrayals of Mary (hadrat Maryan). Thereupon Masriuq said: These are portraits of Kisra. I said: No, these are of Mary. Masruq said: I heard Abdullah b, Mas'ud as saying Allah's Messenger (may peace be upon him) had said: The most grievously tormented people on the Day of Resurrection would be the painters of pictures. (Muslim said): I read this before Nasr b. 'Ali at-Jahdami and he read it before other narrators, the last one being Ibn Sa'id b Abl at Hasan that a person came to Ibn 'Abbas and said: I am the person who paints pictures; give me a religious verdict about them. He (Ibn 'Abbas) said to him: Come near me (still further). He came near him so much so that he placed his hand upon his head and said: I am going to narrate to yor what I heard from Allah's Messenger (may peace be upon him). I heard him say: All the painters who make pictures would be in the fire of Hell. The soul will be breathed in every picture prepared by him and it shall punish him in the Hell, and he (Ibn 'Abbas) said: If you have to do it at all, then paint the pictures of trees and lifeless things; and Nasr b. 'Ali confirmed it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5273]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5273

Anas b. Malik said: I was sitting with Ibn Ahbas when he gave religious verdicts but he did not say that it was Allah's Messenger (may peace be upon him) who had said that. However when a man said to him (Ibn 'Abbas): I am the painter of these pictures. Ibn 'Abbas said: I heard Allah's Messenger (may peace be upon him) as saying: He who painted pictures in the world would be compelled to breathe soal in them on the Day of Resurrection, but he would not be able to breathe soul (in them).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5274]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5274

Nadr b. Anas reported that a person came to Ibn 'Abbas and he narrated (the above menlioned hadith) from Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5275]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5275

Abu Zur'a reported: I visited the house of Marwan in the company of Abu Huraira and he found pictures there. whereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: Allah, the Glorious and Exalted, said: Who is a more wrongdoer than one who tries to create creation like Mine creation. Let him create an atom or a grain of wheat or that of barley. This hadith has been transmitted on the authority of Abu Zur'a and he said: Abu Huraira went to the house of Sa'ld or Marwan which they had built in Medina and he (Abu Huraira) saw a painter who had been painting pictures in his house, whereupon he told that Allah's Messenger (may peace be upon him) had said like this, but he made no mention of the words:" Let him create the grain of barley."


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5276]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5276

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels do not enter the house in which there are portrayals or pictures.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5277]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5277

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Angels do not accompany the travellers who have with them a dog and a bell.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5278]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5278

This hadith has been reported on the authority of Suhail with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5279]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5279

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The bell is the musical instrument of the Satan.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5280]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5280

Abu Bashir Ansari reported that he had had (the opportunity of accompanying Allah's Messenger (may peace be upon him) in some of his journeys. Allah's Messenger (may peace be upon him) sent one of his messengers 'Abdullah b Abi Bakr said: I think he said (these words) when the people were at the places of rest: No necklace of strings be left on the necks of the camels or the necklace kept unbroken. Imam Malik said: To my mind (this practice) of wearing necklace round the necks of camels or animals was because of the fact that they (wanted to save them) from the influence of the evil eye.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5281]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5281

Jabir reported that Allah's Messenger (may peace be upon him) forbade (the animals to be beaten) on the face or cauterisation on the face.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5282]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5282

This hadith has been reported on the authority of Jabir b. 'Abdullah through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5283]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5283

Jabir reported that there happened to pass before Allah's Apostle (may peace be upon him) an ass the face of which had been cauterised, whereupon he said: Allah has cursed one who has cauterised it (on the face).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5284]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5284

Ibn Abbas reported that Allah's Messenger (may peace be upon him) saw an ass which had been cauterised on the face. He disapproved of it saying: By Allah, I do not cauterise (the animal) but on a part at a distance from the face, and commanded (for the cauterisation) of his ass and it was cauterised on the buttocks and he was the first to cauterise on the buttocks.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5285]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5285

Anas reported that Umm Sulaim gave birth to a child. She said to him: Anas, see that nothing is given to this child until he is brought to Allah's Apostle (may peace be upon him) in the morning, so that he should chew some dates and touch his palate with it. I went to him in the morning and he was in the garden at that time having the mantle of Jauniyya over him and he was bus in cauterising (the camels) which had been brought to him (as spoils of war) in victory (over the enemy).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5286]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5286

Anas reported that when his mother gave birth to a child they brought that child to Allah's Messenger (may peace be upon him) so that he might chew some dates and touch his palate with them. and Allah's Apostle (may peace be upon him) was at that time in the fold busy in cauterising the animals Shu'ba said: So far as I know (he was cauterising) their ears.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5287]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5287

Anas reported: We went to Allah's Messenger (may peace be upon him) as he was in the fold and he was cauterising the animals of the flock and I think (he was cauterising them) on their ears. This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5288]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5288

Anas b. Malik reported: I saw in the hand of Allah's Messenger (may peace be upon him) an instrument for cauterisation and he was cauterising the caracia collected as Zakat.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5289]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5289

Ibn Umar reported that Allah's Messenger (may peace be upon him) forbade Qaza. I said to Nafi: What is Qaza'? He said: This means having a part of a boy's head shaved and leaving a part unshaven.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5290]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5290

This hadith has been reported on the authority of 'Ubaidullah with the same chain of transmitters. and the exposition of Qaza' is the same as that of Abu Usama.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5291]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5291

This hadith has been narrated on the authority of 'Umar b. Nafi' with the same chain of transmitters and Muhammad b. Muthanna as well as 'Umar b. Nafi have given the same exposition (of the word Qaza') in their narration.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5292]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5292

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5293]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5293

Abu Sa'id Kbudri reported Allah's Apostle (may peace be upon him) as saying: Avoid sitting on the paths. They (his Companions) said: Allah's Messenger. there is no other help to it (but to sit here as we) hold our meetings and discuss matters there. Thereupon Allah's Messenger (may peace be upon him) said: If you have to sit at all, theg fulfil the rights, of the path. They said: What are their rights? Thereupon he said: Keeping the eye downward (so that you may not stare at the women), refraining from doing some harm to the other and exchanging mutual greetings (saying as-Salamu 'Alaikum to one another) and commanding the good and forbidding the evil.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5294]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5294

This hadith has been reported on the authority of Zaid b. Aslam with the same chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5295]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5295

Asma', daughter of Abu Bakr, reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have a daughter who has been newly wedded. She had an attack of smallpox and thus her hair had fallen; should I add false hair to her head? Thereupon Allah's Messenger (may peace be upon him) said: Allah has cursed the woman who adds some false hair and the woman who asks for it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5296]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5296

This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5297]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5297

Asma', daughter of Abu Bakr, reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have married my daughter (whose) hair of head have fallen. Her spouse likes them (the long hair). Allah's Messenger (may add false hair to her head? He forbade her to do this.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5298]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5298

A'isha reported that a girl of the Ansar who had fallen ill and had lost the hair was married. They (her relatives) thought of adding false hair (to her head). so they asked Allah's Messenger (may peace be upon him) about it, whereupon he cursed the woman who adds false hair and the woman who asks for it.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5299]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5299

A'isha reported that a woman from the Ansar married her daughter who had lost her hair because of illness. She came to Allah's Apostle (may peace be upon him) and said: Her husband wants that false hair should be aaded to her head. Thereupon Allah's Messenger (may peace be upon him) said: The woman who adds false hair has been cursed. This hadith has been narrated on the authority of Nafi' with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5300]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5300

Ibn Umar reported Allah's Messenger (may peace be upon him) cursing the woman who added false hair and the woman who asked for tattoos. This hadith has been reported on the authority of Abdullah through another chain of transmitters.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5301]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5301

'Abdullah reported that Allah had cursed those women who tattooed and who have themselves tattooed, those who pluck hair from their faces and those who make spaces between their teeth for beautification changing what God has created. This news reached a woman of the tribe of Asad who was called Umm Ya'qub and she used to recite the Holy Qur'an. She came to him and said: What is this news that has reached me from you that you curse those women who tattooed and those women who have themselves tattooed, the women who pluck hair from their faces and who make spaces between their teeth for beautification changing what God has created? Thereupon 'Abdullah said: Should I not curse one upon whom Allah's Messenger (may peace be upon him) has invoked curse and that is in the Book also. Thereupon that woman said: I read the Qur'an from cover to cover, but I did not find that in it. whereupon he said: If you had read (thoroughly) you would have definitely found this in that (as) Allah, the Exalted and Glorious, has said:" What Allah's Messenger brings for you accept that. and what he has forbidden you. refrain from that." That woman said: I find this thing in your wife even now. Thereupon he said: Go and see her. She reported: I went to the wife of 'Abdullah but found nothing of this sort in her. She came back to him and said: I have not seen anything. whereupon he said: Had there been anything like it in her, I would have never slept with her in the bed.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5302]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5302

This hadith has been reported on the authority of Mansur with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5303]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5303

This hadith has been narrated on the authority of Mansur without the story pertaining to Umm Ya'qub.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5304]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5304

This hadith has been transmitted on the authority of Abdullah.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5305]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5305

Jabir b. Abdullah reported that Allah's Apostle (may peace be upon him) reprimanded that a woman should add anything to her head (in the form of artificial hair).


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5306]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5306

Abd al-Rahman b. 'Auf said that he heard Mu'awiya b Sufyin during the season of Hajj. (saying) as he sat upon the pulpit holding a bunch of hair in his hand which was (previously) in the hand of his sentinel: O people of Medina, where are your scholars? I heard Allah's Messenger (may peace be upon him) forbidding this and saying: That the people of Bani Isra'il were ruined at the time when their women wore shuch hair.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5307]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5307

This hadith has been transmitted on the authority of Zuhri but with a slight variation of wording.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5308]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5308

Sa'id b. Musayyib reported: Mu'awiya came to Medina and he addressed us and he took out a bunch of hair and said: What do I see that one of you does but that what the Jews did? (I can well recall) that when this act (adding of artificial hair) reached Allah's Messenger (may peace be upon him), he named it as cheating.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5309]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5309

Sa, id b. Musayyib reported that Mu'awiya said one day: Should I narrate to you the evil make-up. Allah's Apostle (may peace be upon him) forbade cheating. It was during that time that a person came with a staff and there was a cloth on its head, whereupon Mu, awiya said: Behold, that is cheating. Qatada said: This implies how women artificially increase their hair with the help of rags.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5310]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5310

AbU Huraira reported Allah's Messenger (may peace be upon him) having said this: Two are the types of the denizens of Hell whom I did not see: people having flogs like the tails of the ox with them and they would be beating people, and the women who would be dressed but appear to be naked, who would be inclined (to evil) and make their husbands incline towards it. Their heads would be like the humps of the bukht camel inclined to one side. They will not enter Paradise and they would not smell its odour whereas its odour would be smelt from such and such distance.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5311]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5311

A'isha reported that a woman said: Allah's Messenger, may I say to my (co-wife) that my husband has given me (such and such) a thing but which he has not in fact gives me? 'Thereupon Allah's Messenger (may peace be upon him) said: The one who makes a false statement of that which one has not been given is like one who wears a garment of falsehood.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5312]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5312

Asma' reported that a woman came to Allah's Apostle (may peace be upon him) and said: I have a co-wife. Is there any harm for me if I give her the false impression (of getting something from my husband which he has not in fact given me)? Thereupon Allah's Messenger (may peace be upon him) said: The one who creates such a (false impression) of receiving what one has not been given is like one who wears the garment of falsehood.


Muslim :: The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah) :: [24.5313]

The Book Pertaining to Clothes and Decoration (Kitab Al-Libas wa'l-Zinah)

Muslim :: Book 24 : Hadith 5313

This hadith has been reported on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5314]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5314

Anas reported that person at Baqi' called another person as" Abu'l- Qasim," and Allah's Messenger (may peace be upon him) turned towards him. He (the person who had uttered these words) said: Messenger of Allah, I did not mean you, but I called such and such (person), whereupon Allah's Messenger (may peace be upon him) said: You may call yourself by my name, but not by my kunya.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5315]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5315

Ibn Umar reported that Allah's Messenger (may peace be upon him) said: The names dearest to Allah are 'Abdullah and 'Abd al-Rahman.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5316]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5316

Jabir b. 'Abdullah reported that a child was born to a perfon amongst us and he gave him the name of Muhammad. Thereupon his people said: We will not allow You to give the name of Muhammad (to your child) after the name of Allah's Messenger (may peace be upon him). He set forth with his son carrying him on his back and came to Allah's Apostle (may peace be upon him', and said: Allah's Messenger a son has been born to me and I havegiven him the name after the name of Allah's Messenger (may peace be upon him), whereupon Allah's Messenger (may peace be upon him) said: Give him my name but do not give him my kunya, for I am Qasim in the sense that I distribute (the spoils of war) and the dues of Zakat amongst you.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5317]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5317

Jabir b. 'Abdullah reported that a child was born to one of the persons amongst us and he decided to give him the name of Muhammad We said: We will not allow you to give the name after the name of Allah's Messenger (may peace be upon him) until you ask him (the Holy Prophet). So he (that person) came and said (to the Holy Prophet): A child was born in my house and I wanted to give him the name (of Muhammad) after the name of Allah's Messenger, whereas my people did not allow me that I should name him after that (sacred) name until I have asked Allah's Apostle (may peace be upon him) in this connection, whereupon he said: Give him the name after my name, but do not call him by my kunya, for I have been sent as a Qasim as I distribute amongst you.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5318]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5318

This hadith has been reported on the authority of Husain With the same chain of transmitters but no mention is made of these words:" (I have been sent as a distributor), so I distribute amongst you."


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5319]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5319

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: Give the name after my name, but do not give (the kunya of Abu'l-Qasim after my) kunya, for I am Abu'l-Qasim (in the sense) that I distribute amongst you (the spoils of war) and disseminate the knowledge (of revelation). This hadith has been transmitted on the authority of Abu Bakr but with a slight variation of wording.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5320]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5320

This hadith has been reported on the authority of A'mash with the same chain of transmitters but there is a slight variation (of wording) that, instead of the word Bu'ithat (I have been sent), the word ju'ilat (I have been made) has been used.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5321]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5321

Jabir b. 'Abdullah reported that a child was born to a person from the Ansar and he made up his mind to give him the name of Muhammad. He came to Allah's Apostle (may peace be upon him) and, asked him (about it), whereupon he said: The Ansar have done well to give the name (to your children) after my name, but do nct give them the kunya after my kunya.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5322]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5322

This hadith has been narrated through different chains of transmitters on the authority of Shu'ba with a slight variation of wording.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5323]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5323

Jabir b. 'Abdullah reported: A child was born in the house of a person amongst us, and he gave him the name of Qasim. We said: We will not allow you (to give the name) to your child as Qasim (and thus adopt the kunya of Abu'l-Qasim) and coal your eyes. He (that person) came to Allah's Apostle (may peace be upon him) and made a mention of that to him, whereupon he said: Call your son 'Abd al-Rahman.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5324]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5324

This hadith has been reported on the authority of Ibn Uyaina, but there is no mention of this:" We will not allow you to cool your eyes."


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5325]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5325

Abu Huraira reported that Abu'l-Qasim (may peace be upon him) said: Give name (to your children) after my name but do not give the kunya (of Abu'l- Qasim) after my kunya. 'Amr reported from Abu Huraira that he did not say that he had heard it directly from Allah's Apostle (may peace be upon him).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5326]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5326

Mughira b. Shu'ba reported: When I came to Najran, they (the Christians of Najran) asked me: You read" O sister of Harun" (i. e. Hadrat Maryam) in the Qur'an, whereas Moses was born much before Jesus. When I came back to Allah's Messenger (may peace be upon him) I asked him about that, whereupon he said: The (people of the old age) used to give names (to their persons) after the names of Apostles and pious persons who had gone before them.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5327]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5327

Samura b. Jundub reported: Allah's Messenger (may peace be upon him) forbade us to give names to our servants as these four names: Aflah (Successful), Rabdh (Profit), Yasar (Wealth), and Nafi' (Beneficial).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5328]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5328

Samura b. Jundub reported AUah's Messenger (may peace be upon him) as saying: Don't give names to your servants as Rabdh, 'Ya ar, Aflah and Nafi'.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5329]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5329

Samura b. Jundub reprted: The dearest words to Allah are four: Subhan Allah (Hallowed be Allah), Al-Hamdulillah (Praise be to Allah), Wa la ilaha illa-Allah (There is no god but Allah), Allah-o-Akbar (God is the Greatest). There is no harm for you in which order you begin (them while remembering Allah), and he also said: Do not give these names to your servants, Yasar and Rabah and Nafi and Najth.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5330]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5330

This hadith has been reported on the authority of Shu'ba and there is no mention but of the fact about giving the name to the servant and there is no mention of the four expressions (of remembrance) and he did not mention the four words


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5331]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5331

Jabir b. 'Abdullah reported: Allah's Messenger (may peace be upon him) decided to forbid (his followers) to name persons as Ya'la (Elevated), Baraka (Blessing), Aflah (Successful), Yasar and Nafi', but I saw that he kept silent after that and he did not say anything until Allah's Messenger (may peace be upon him) died. And he did not forbid (his followers to do this), then 'Umar decided to prohibit (people) from giving these names, but later on gave up the idea.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5332]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5332

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) changed the name of 'Asiya (Disobedient) and said: You are Jamila (i. e. good and handsome). Ahmad (one of the narrators) narrated it with a slight variation of wording.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5333]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5333

Ibn 'Umar reported that 'Umar had a daughter who was called 'Asiya. Allah's Messenger (may peace be upon him) gave her the name of Jamila.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5334]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5334

Ibn Abbas reported that the name of Juwairlya (the wife of the Holy Prophet) was Barra (Pious). Allah's Messenger (may peace be upon him) changed her name to Juwairiya and said: I did not like that it should be said: He had come out from Barra (Pious). The hadith transmitted on the authority of Ibn Abi 'Umar is slightly different from it.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5335]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5335

Abu Huraira reported that the name of Zainab was Barra. It was said of her: She presents herself to be innocent. Allah's Messenger (may peace be upon him) gave her the name of Zainab.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5336]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5336

Zainab, daughter of Umm Salama, reported: My name first was Barra. Allah's Messenger (may peace be upon him) gave me the name of Zainab. Then there entered (into the house of Allah's Prophet as a wife) Zainab, daughter of Jahsh, and her name was also Barra, and he gave her the name of Zainab.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5337]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5337

Muhammad b. 'Amr b. 'Ata' reported: I had given the name Barra to my daughter. Zainab, daughter of Abu Salama, told me that Allah's' Messenger (may peace be upon him) had forbidden me to give this name. (She said): I was also called Barra, but Allah's Messenger (may peace be upon him) said: Don't hold yourself to be pious. It is God alone who knows the people of piety among you. They (the Companions) said: Then, what name should we give to her? He said: Name her as Zainab.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5338]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5338

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The vilest name in Allah's sight is Malik al-Amidh (King of Kings). The narration transmitted on the authority of Shaiba (contains these words): There is no king but Allah, the Exalted and Glorious. Sufyan said: Similarly, the word Shahinshah (is also the vilest appellation). Ahmad b. Hanbal said: I asked Abu 'Amr about the meaning of Akhna. He said: The vilest.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5339]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5339

Abu Huraira reported from Allah's Messenger (may peace be upon him) so many ahadith and one of them was this that Allah's Messenger (may peace be upon him) said: The most wretched person in the sight of Allah on the Day of Resurrection and the worst person and target of His wrath would of the person who is called Malik al-Amlak (the King of Kings) for there is no king but Allah.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5340]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5340

Anas b. Malik reported: I took 'Abdullah b. Abi Talha Ansari to Allah's Messenger (may peace be upon him) at the time of his birth. Allah's Messenger (may peace be upon him) was at that time wearing a woollen cloak and besmearing the camels with tar. He said: Have you got with you the dates? I said: Yes. He took hold of the dates and put them in his mouth and softened them, then opened the mouth of the infant and put that in it and the child began to lick it. Thereupon Allah's Messenger (may peace be upon him) said: The Ansar have a liking for the dates, and he (the Holy Prophet) gave him the name of 'Abdullah.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5341]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5341

Anas b. Malik reported that the son of Abu Talha had been ailing. Abu Talha set out (on a journey) and his son breathed his last (in his absence). When Abu Talha came back, he said (to his wife): What about my child? Umm Sulaim (the wife of Abu Talha) said: He is now in a more comfortable state than before. She served him the evening meal and he took it. He then came to her (and had sexual intercourse with her) and when it was all over she said: Make arrangements for the burial of the child. When it was morning. Abu Talha came to Allah's Messenger (may peace be upon him) and informed him, whereupon he said: Did you spend the night with her. He said: Yes. He (the Holy Prophet) then said: O Allah, bless both of them (and as a result of blessing) she gave birth to a child. Abu Talha said to me (Anas b. Malik) to take the child, (so I took him) and came to Allah's Messenger (may peace be upon him). She (Umm Sulaim) also had sent some dates (along with the child). Allah's Apostle (may peace be upon him) took him (the child) (in his lap) and said: Is there anything with you (for Tahnik). They (the Companions) said: Yes. Allah's Apostle (may peace be upon him) took hold of them (dates and chewed them). He then put them (the chewed dates) in the mouth of the child and then rubbed his palate and gave him the name of 'Abdullah.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5342]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5342

This hadith has been reported on the authority of Anas through another chain of transmit ters.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5343]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5343

Abu Musa reported: A child was born in my house and I brought him to Allah's Apostle (may peace be upod him) and he gave him the name of Ibrahim and he rubbed his palate with dates.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5344]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5344

'Urwa b. Zubair and Fatima daughter of Mandhir b. Zubair, reported that Asma' daughter of Abu Bakr was at the time of migration in the family way with 'Abdullah b. Zubair (in her womb). She came to Quba' and gave birth to 'Abdullah at that place and then sent him to Allah's Messenger (may peace be upon him) so that he should rub his palate with chewed dates. Allah's Messenger (may peace he upon him) took hold of him (the child) and he placed him in his lap and then called for dates. 'A'isha said: Some time was spent before we were able to find them. He (the Holy Prophet) chewed them and then put his saliva in his mouth. The first thing that entered his stomach, was the saliva of Allah's Messenger (may peace be upon him). Asma' said: He then rubbed him and blessed him and gave him the name of Abdullah. He ('Abdullah) went to him (the Holy Prophet) when he had attained the age of seven or eight years in order to pledge allegiance to Allah's Messenger (may peace be upon him) as Zubair had commanded him to do. Allah's Messenger (may peace be upon him) smiled when he saw him coming towards him and then accepted his allegiance.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5345]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5345

Asma' reported that she had become pregnant at Mecca with Abdullah b. Zubair (in her womt) and she (further) said: I set out (for migration to Medina) as I was in the advanced stage of pregnancy. I came to Medina and got down at the place known as Quba' and gave birth to a child there. Then I came to Allah's Messenger (may peace he upon him). He placed him (the child) in his lap and then commanded for the dates to be brought. He chewed them and then put the saliva in his mouth. The first thing which went into his stomach was the saliva of Allah's Messenger (may peace be upon him). He then rubbed his palate with dates and then invoked blessings for him and blessed him. He was the first child who was born in Islam (after Migration).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5346]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5346

Asma', daughter of Abu Bakr, reported that when she migrated to Allah's Messenger (may peace be upon him) in Medina she was in the family way with Abdullah b. Zubair in her womb.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5347]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5347

'A'isha reported that the new-born infants were brought to Allah's Messenger (may peace be upon him). He blessed them and rubbed their palates with dates.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5348]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5348

'A'isha reported: We took 'Abdullah b. Zubair to Allah's Apostle (may peace be upon him) so that he should put saliva in his mouth and we had to make a good deal of effort in order to procure them.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5349]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5349

Sahl b. Sa'd reported that Mundhir b. Aba Usaid was brought to Allah's Messenger (may peace be upon him) at the time of his birth Allah's. Apostle (may peace be upon him) placed him on his thigh and Abfi Usaid kept sitting there. Allah's Apostle (may peace be upon him) had been occupied with something else before him. Abu Usaid commanded his child to be lifted from the lap of Allah's Messenger (may peace be upon him) and so he was lifted. When Allah's Messenger (may peace be upon him) had finished the work he said: Where is the child? Abd Usaid said: Allah's Messenger, we took him away. He said: What is his name? He said; Allah's Messenger, it is so and so, whereupon he (the Holy Prophet) said: Nay, his name is Mundhir, and named him Mundhir on that day.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5350]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5350

Anas b. Malik reported that Allah's Messenger (may peace be upon him) had the sublimest character among mankind. I had a brother who was called Abd 'Umair. I think he was weaned. When Allah's Messenger (may peace he upon him) came to our house he saw him, and said: Abu 'Umair, what has the sparrow done? He (Anas) said that he had been playing with that.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5351]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5351

Anas b Malik reported that Allah's Messenger (may peace be upon him) addressed me: O My Son.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5352]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5352

Mughira b. Shu'ba reported that none else had asked more questions from Allah's Messenger (may peace be upon him) about the Dajjal than I, but he simply said in a slight mood): O, myson, why are you worried because of him? He will not harm you. I said: The people think that he would have with him rivers of water and mountains of bread, whereupon he said: He would be more insignificant in the sight of Allah than all these things (belonging to him).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5353]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5353

This hadith has been reported on the authority of Ismail, with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5354]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5354

Abu Sa'id Khudri reported: I wins sitting in Medina in the company of the Ansar that Abu Musa came trembling with fear. We said to him: What is the matter? He said: 'Umar (Allah be pleated with him) sent for me. I went to him and paid him salutation thrice at (his) door but he made no response to me and so I came back Thereupon he ('Umar) said: What stood in your way that you did not turn up? I said: I did come to you and paid you salutations at your door three times but I was not given any response, so I came back as the Messenger of Allah (may peace be upon him) has said: When any one of you seeks permission three times and he i. e not granted permission, he should come back. Umar said: Bring a witness to support that you say, otherwise I shall take you to task. Ubayy b. Ka'b said: None should stand with him (as a witness) but the youngest amongst the people. Abu Sa'id said: I am the youngest amongst the people, whereupon he said: Then you go with him (to support his contention).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5355]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5355

This hadith has been narrated on the authority of Yazid b. Khusaifa with the same chain of transmitters but with this addition: Abu Sa'id said: So I stood up, and went to 'Umar and gave witness (to what Abu Musa had said).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5356]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5356

Abd Sa'id Khudri reported: We were in the company of Ubayy b. Ka'b that Abu Musa Ash'ari came there in a state of anger. He stood (before us) and said: I ask you to bear witness in the name of Allah whether anyone amongst you heard Allah's Messenger (may peace be upon him) as saying: Permission (for entering the house) should be sought three times and if permission is granted to you (then get in). otherwise go back. Ubayy b. Ka'b said: What is the iiiatter? He said: I sought permission yesterday from 'Umar b. Khattab three times but he did not permit me, so I came back; then I went to him today and visited him and informed him that I had come to him yesterday and greeted him thrice, then came back, whereupon he said: Yes, we did hear you but be were at that time busy, but why did you not seek permission (further and you must have never gone back until you were permitted to do so). He said: I sought permission (in the manner) that I heard Allah's Messenger (may peace be upon him) having said (in connection 'With the seeking of permission for entering the house of a stranger). Thereupon he (Hadrat Umar) said: By Allah, I shall torture your back and your stomach unless you bring one who may bear witness to what you state. 'Ubayy b. Ka'b said: By Allah, none should stand with you (to bear testimony) but the youngest amongst us. And he therefore, said to Abu Sa'id: Stand up. So I stood up until I came to Umar and said: I heard Allah's Messenger (may peace be upon him) say this.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5357]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5357

Abu Sa'id reported that Abu Musa al-Ash'ari came to the door of 'Umar and sought his permission (to get into his house). Umar said: That is once. He again sought permission for the second time and 'Umar said: It is twice. He again sought permission for the third time and Umar said: It is thrice. He (Abu Musa) then went back. He (Hadrat 'Umar) (sent someone) to pursue him so that he should be brought back. Thereupon he (Hadrat Umar) said: If this act (of yours is in accordance with the command of Allah's Messenger (may peace be upon him) you have preserved in your mind, then it is all right, otherwise (I shall give you such a severe punishment) that it will serve as an example to others. Abu Sa'id said: Then he (Abu Musa) came to us and said: Do you remember Allah's Messenger (may peace be upon him) having said this:" Permission is for three times"? They (Companions sitting in that cothpany) began to laugh, whereupon he (Abu Musa) said: There comes to you your Muslim brother who had been perturbed and you laugh. Abu Sa'id said: (Well), you go forth. I shall be your participant in this trouble of yours. So he came to him (Hadrat Umar) and said: Here is Abu Sa'id (to support my statement).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5358]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5358

This hadith bu been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5359]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5359

'Ubaid b. Umair reported that Abu Musa brought permission from Umar (to enter the house) three times, and finding him busy came back, whereupon Umar said (to the Inmates of his house): Did you not hear the voice of 'Abdullah b. Qais (the Kunya of Abu Musa Ash'ari)? He was called back. and he (Hadrat 'Umar) said: What did prompt you to do it? Thereupon, he said: This is how we have been commanded to act. He (Hadrat 'Umar) said: Bring evidence (in support of) it, otherwise I shall deal (strictly) with you. So he (Abu Musa) set out and came to the meeting of the Ansar and asked them to bear witness before hadrat Umar about this. They (the Companions present there) said: None but the youngest amongst us would bear out this fact. So Abu Sa'id Khudri (who was the youngest one in that company) said: We have been commanded to do so (while visiting the house of other people). Thereupon 'Umar said: This command of Allah's Messenger (may peace be upon him) had remained hidden from me up till now due to (my) business in the market.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5360]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5360

This hadith has been transmitted on the authority of Ibn Juraij, but there is no mention of the words" business in the market".


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5361]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5361

Abu Musa Ash'ari reported that he went to 'Umar b. Khattab and greeted him by saying: As-Salamu-'Alaikum, here is 'Abdullah b. Qais, but he did not permit him (to get in). He (Abu Musa Ash'ari) again greeted him with as-Salamu-'Alaikum and said: Here is Abu Musa, but he (Hadrat 'Umar) did not permit him (to get in). He again said: As-Salam-u-'Alaikum, (and said) here is Ash'ari, (then receiving no response he came back). He (Hadrat 'Umar) said: Bring him back to me, bring him back to me So he went there (in the presence of Hadrat 'Umar) and he said to him: Abu Musa, what made you go back, while we were busy in some work? He said: I heard Allah's Messenger (may. peace be upon him) as saying: Permission should be sought thrice. And if you are permitted, (then get in), otherwise go back. He said: Bring witness to this fact, otherwise I shall do this and that, i. e. I shall punish you. Abu Musa went away and 'Umar said to him (on his departure): It he (Abu Musa) finds a witness he should meet him by the side of the pulpit in the evening and it he does not find a witness you would not find him there. When it was evening he (Hadrat 'Umar) found him (Abu Musa) there. He (Hadrat 'Umar) said: Abu Musa, have you been able to find a witness to what you have said? He said: Yes. Here is Ubayy bin Ka'b, whereupon he (Hadrat 'Umar) said: Yes, he is an authentic (witness). He (Hadrat 'Umar) said: Abu Tufail (the kunya of Ubayy b. Ka'b), what does he (Abu Musa say? Thereupon he said: Ibn Khattab, I heard Allah's Messenger (may peace be upon him) as saying so. Do not prove to be a hard (task-master) for the Companions of Allah's Messenger (may peace be upon him), whereupon he Hadrat 'Umar said: Hallowed be Allah. I had heard something (in this connection), but I wished it to be established (as an undeniable fact).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5362]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5362

This hadith has been narrated on the authority of Talha b. Yahya with the same chain of transmitters but with this variation of wording: He (Hadrat 'Umar) said: Abu Mundhir (the Kunya of Ubayy b. Ka'b), did you hear this from Allah's Messenger (may peace be upon him)? Thereupon he said: Yes. and he further said: Ibn Khattab, do not be a torment for the Companions of Allah's Messenger (may peace he upon him). No mention has, however, been made of the words of 'Umar:" Hallowed be Allah" and what follows subsequently.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5363]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5363

Jabir b. Abdullah reported: I came to Allah's Apostle (may peace be upon him) and called him (with a view to seeking permission). whereupon Allah's Apostle (may peace be upon him) said: Who is it? I said: It is I. Thereupon he (the Holy Prophet) came out saying: It is I. it is I.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5364]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5364

Jabir b. Abdullah reported: I sought permission from Allah's Messenger (may peace be upoh him) to see him. He said: Who is it? I said: It is I. Thereupon Allah's Messenger (may peace be upon him) said: It is I. it is I (these words lead me to no conclusion).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5365]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5365

This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording and that is: The Holy Prophet (may peace be upon him) uttered these words: It is I. it is I." in the manner as if he disapproved of this.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5366]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5366

Sahl b. Sa'd as-Sa'id reported that a person peeped through the hole of the door of Allah's Messenger (may peace be upon him), and at that time Allah's Messenger (may peace be upon him) had with him a scratching instrument with which he had been scratching his head. When Allah's Messenger (may peace be upon him) saw him. he said: If I were to know that you had been peeping through the door, I would have thrust that into your eyes, and Allah's Messenger (may peace be upon him) said: Permission is needed as a protection against glance.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5367]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5367

Sahl b. Sa'd as-Sa'idi reported that a person peeped through the hole of the door of Allah's Messenger (may peace be upon him) and he had with him some pointed thing with which he had been adjusting (the hair of his head). Allah's Messenger (may peace be upon him) said to him: If I were to know that you had been peeping. I would have thrust it in your eyes. Allah has prescribed seeking permission because of protection against glance.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5368]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5368

This hadith has been transmitted on the authority of Sahl b. Sa'd as-Sa'idi with a slight variation of wording.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5369]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5369

Anas b. Malik reported that a person peeped in some of the holes (in the doors) of Allah's Messenger (may peace be upon him) (and he found him) standing up (lifting) an arrow or some arrows. The narrator said: I perceived as if Allah's Messenger (may peace be upon him) was going to pierce (his eyes).


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5370]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5370

Abu Huraira reported having heard Allah's Messenger (may peace be upon him) say: He who peeped into the house of people without their consent, it is permissible for them to put out his eyes.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5371]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5371

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If a person were to cast a glance in your (house) without permission, and you had in your hand a staff and you would have thrust that in his eyes, there is no harm for you.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5372]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5372

Jarir b. 'Abdullah reported: I asked Allah's Messenger (may peace be upon him) about the sudden glance (that is cast) on the face (of a non-Mahram). He commanded me that I should turn away my eyes.


Muslim :: The Book on General Behaviour (Kitab Al-Adab) :: [25.5373]

The Book on General Behaviour (Kitab Al-Adab)

Muslim :: Book 25 : Hadith 5373

This hadith has been narrated on the authority of Yunus through another chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5374]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5374

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The rider should first greet the pedestrian, and the pedestrian the one who is seated and a small group should greet a larger group (with as-Salam-u-'Alaikum).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5375]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5375

Abu Talha reported: While We were sitting in front of the houses and talking amongst ourselves, Allah's Messenger (may peace be upon him) happened to come there. He stood by us and said: What about you apd your meetings on the paths? Avoid these meetings on the paths. We said: We were sitting here without (any intention of doing harm to the passers-by) ; we are sitting to discuss matters and to hold conversation amongst ourselves. Thereupon he said: If there is no help (for you but to sit on these paths), then give the paths their rights and these are lowering of the gaze, exchanging of greetings and good conversation.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5376]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5376

Abu Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying: Avoid sitting on the paths. They (the Companions) said: Allah's Messenger, we cannot help but holding our meetings (in these paths) and discuss matters (there). Thereupon Allah's Messenger (may peace be upon him) said: If you insist on holding meetings, then give the path its due right. They said: What are its due rights? Upon this he said: Lowering the gaze, refraining from doing harm, exchanging of greetings. commanding of good and forbidding from evil.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5377]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5377

This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5378]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5378

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Five are the rights of a Muslim over his brother: responding to salutation, saying Yarhamuk Allah when anybody sneezes and says al-Hamdulillah, visiting the sick. following the bier. ' Abd al-Razzaq said that this hadith has been transmitted as mursal hadith from Zuhri and he then substantiated it on the authority of Ibn Musayyib.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5379]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5379

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Six are the rights of a Muslim over another Muslim. It was said to him: Allah's Messenger, what are these? Thereupon he said: When you meet him, offer him greetings;when he invites you to a feast accept it. when he seeks your council give him, and when he sneezes and says:" All praise is due to Allah," you say Yarhamuk Allah (may Allah show mercy to you) ; and when he fails ill visit him; and when he dies follow his bier.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5380]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5380

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: When the People of the Book offer you salutations, you should say: The same to you.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5381]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5381

Anas reported that the Companions of Allah's Apostle (may peace be upon him) said to him: The People. of the Book offer us salutations (by saying as-Salamu- 'Alaikum). How should we reciprocate them? Thereupon he said: Say: Wa 'Alaikum (and upon you too).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5382]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5382

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: When the Jews offer you salutations, tome of them say as-Sam-u-'Alaikum (death be upon you). You should say (in response to it): Let it be upon you.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5383]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5383

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5384]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5384

'A'isha reported that a group of Jews came to Allah's Messenger (may peace be upon him) and sought his audience and said: As-Sam-u-'Alaikum. A'isha said in response: As-Sim-u-'Alaikum (death be upon you) and curse also, whereupon Allah's Messenger (may peace be upon him) said: 'A'isha, verily Allah loes kindness in every matter. She said: Did you bear what they said? Thereupon he said: Did you not hear that I said (to them): Wa 'Alaikum.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5385]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5385

This hadith has been transmitted on the authority of Zuhri that Allah's Messenger (may peace be upon him) said: I said 'Alaikam, and the transmitter did not make mention of the word" and".


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5386]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5386

'A'isha reported that some Jews came to Allah's Apostle (may peace be upon him) and they said: Abu'l-Qasim (the Kunya of the Holy Prophet), as-Sam-u-'Alaikum, whereupon he (the Holy Prophet) said: Wa 'Alaikum. A'isha reported: In response to these words of theirs, I said: But let there be death upon you and disgrace also, whereupon Allah's Messenger (may peace be upon him) said: 'A'isha, do not use harsh words. She said: Did you hear what they said? Thereupon he (the Holy Prophet) said: Did I not respond to them when they said that; I said to them: Wa'Alaikum (let it be upon you).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5387]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5387

This hadith has been reported on the authority of A'znash with a slight variation of wording. 'A'isha understood their meaning and cursed them and Allah's Messenger (may peace be upon him) said: 'A'isha. (do not do that) for Allah does not like the use of harsh words, and it was at this stage that this verse of Allah. the Exalt. ed and Glorious. was revealed:" And when they come to thee, they greet thee with a greeting with which Allah greets thee not" (Iviii. 8) to the end of the verse.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5388]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5388

Jabir b. Abdullah reported that some people from amongst the Jews said to Allah's Messenger (may peace be upon him) Abu'l-Qasim. as-Sam-u-'Alaikum, whereupon he said: Wa 'Alaikum, A'isha was enraged and asked him (Allah's Apostle) whether he had not heard what they had said. He said, I did hear and I retorted to them (and the curse that I invoked upon them would receive response from Allah), but (the curse that they invoked upon us) would not be responded.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5389]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5389

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not greet the Jews and the Christians before they greet you and when you meet any one of them on the roads force him to go to the narrowest part of it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5390]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5390

This hadith has been narrated on the authority of Suhail with the same chain of transmitters but with a slight variation of wording. The hadith transmitted on the authority of Waki', the words are 'When you meet the Jews." And in the hadith transmitted on the authority of Shu'ba, the words are: 'When you meet the People of the Book." And in the hadith transmitted on the authority of Jarir the words are:" When you meet them," but none amongst the polytheists has been mentioned explicitly by name.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5391]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5391

Anas b. Malik reported that when Allah's Messenger (may peace be upon him) happened to pass by young boys he would great them. This hadith has been narrated on the authority of Sayyar with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5392]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5392

Sayyar reported: I was walking with Thibit al-Bunani that he happened to pass by children and he greeted them. And Thibit reported that he walked with Anas and he happened to pass by children and he greeted them. and Anas reported that he walked with Allah's Apostle (may peace be upon. him) and he happened, to pass by children and he greeted them.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5393]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5393

Ibn Mas'ud reported: The Messenger of Allah (may peace be upon him) said to me: The sign that you have been permitted to come in is that the curtain is raised or that you hear me speaking quietly until I forbid you.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5394]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5394

This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5395]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5395

A'isha reported that Sauda (Allah he pleated with her) went out (in the fields) in order to answer the call of nature even after the time when veil had been prescribed for women. She had been a bulky lady, significant in height amongst the women, and she could not conceal herself from him who had known her. 'Umar b. Khattab saw her and said: Sauda, by Allah, you cannot conceal from us. Therefore, be careful when you go out. She ('A'isha) said: She turned back. Allah's Messenger (may peace be upon him) was at that time in my house having his evening meal and there was a bone in his hand. She (Sauda) cline and said: Allah's Messenger. I went out and 'Umar said to me so and so. She ('A'isha) reported: There came the revelation to him and then it was over; the bone was then in his hand and he had not thrown it and he said:" Permission has been granted to you that you may go out for your needs."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5396]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5396

This hadith has been narrated on the authority of Hisham with the same chain of transmitters, and the words are: She (Sauda) was a woman who looked to be significant amongst the people (so far as the bulk of her) body was concerned. The rest of the hadith is the same.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5397]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5397

'A'isha reported that the wives of Allah's Messenger (may peace be upon him) used to go out in the cover of night when they went to open fields (in the outskirts of Medina) for easing themselves. 'Umar b Khattab used to say: Allah's Messenger, ask your ladies to observe veil, but Allah's Messenger (may peace be upon him) did not do that. So there went out Sauda, daughter of Zarn'a, the wife of Allah's Messenger (may peace be upon him), during one of the nights when it was dark. She was a tall statured lady. 'Umar called her saying: Sauda, we recognise you. (He did this with the hope that the verses pertaining to veil would be revealed.) 'A'isha said: Allah, the Exalted and Glorious, then revealed the verses pertaining to veil.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5398]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5398

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5399]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5399

Jabir reported Allah's Messenger (may peace be upon him) as saying: Behold, no person should spend the night with a married woman, but only in case he is married to her or he is her Mahram.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5400]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5400

'Uqba b. Amir reported Allah's Messenger (may peace be upon him) as saying: Beware of getting, into the houses and meeting women (in seclusion). A person from the Ansir said: Allah's Messenger, what about husband's brother, whereupon he said: Husband's brother is like death.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5401]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5401

This hadith has been narrated on the authority of Yazid b. Abu Habib with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5402]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5402

Ibn Wahb reported: I heard Laith b. Said as saying: Al-Hamv means the brother of husband or like it from amongst the relatives of the husband, for example, cousin, etc.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5403]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5403

'Abdullah b. 'Amr. b. al-'As reported that some persons from Banu Hisham entered the house of Asma' daughter of 'Umais when Abu Bakr also entered (and she was at that time his wife). He (Abu Bakr) saw it and disapproved of it and he made a mention of that to Allah's Messenger (may peace be upon him) and said: I did not see but good only (in my wife). Thereupon Allah's Messenger (may peace be upon him) said: Verily Allah has made her immune from all this. Then Allah's Messenger (may peace be upon him) stood on the pulpit and said: After this day no man should enter the house of another person in his absence, but only when he is accompanied by one person or two persons.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5404]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5404

Anas reported that when Allah's Messenger (may peace be upon him) was in the company of one of his wives a person happened to pass by them. He called him and when he came, he said to him: 0 so and so, she was my such and such wife. Thereupon he said, Allah's Messenger, if I were to doubt at all, I would have entertained no doubt about you at least. Thereupon Allah's Messenger (may peace be upon him) said: Verily Satan circulates in the body like blood.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5405]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5405

Safiyya daughter of Huyyay (the wife of Allah's Apostle) reported that while Allah's Messenger (may peace be. upon him) had been observing I'tikaf, I came to visit him one night and talked with him for some time. Then I stood up to go back and he (Allah's Apostle) also stood up with me in order to bid me good-bye. She was at that time residing in the house of Usama b. Zaid. The two persons from the Ansar happened to pass by him. When they saw Allah's Apostle (may peace be upon him). they began to walk swiftly, thereupon Allah's Messenger (may peace be upon him) said to them: Walk calmy, she is Safiyya daughter of Huyyay... Both of them said: Messenger, hallowed be Allah, (we cannot conceive of ab., ug doubtful even in the remotest corners of our minds), whereupon he said: Satan circulates in the body of man like the circulation of blood and I was afraid lest it should instill any evil in your heart or anything. This hadith has been reported on the authority of Safiyya, the wife of Allah's Apostle (may peace be upon him), through another chain of transmitters (and the words) are:" She went to Allah's Apostle (may peace be upon him) to visit him as he was observing I'tikaf in the mosque during Ramadan. She talked with him for some time and then stood up to go back and Allikh's Apostle (may peace be upon him) stood up in order to bid her good-bye." The rest of the hadith is the same except with the variation of the words that Allah's Apostle (may peace be upon him) said:" Satan penetrates in man like the penetration of blood (in every part of body)."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5406]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5406

Abu Waqid al-Laith reported that Allah's Messenger (may peace be upon him) was sitting in the mosque along wish tome people when there came to him three persons; two of them stepped forward to the direction of Allah's Messenger (may peace be upon him), and one of them went away. The two stood by the side of Allah's Messenger (may peace be upon him), and one of them found a space in his circle and he sat in that; and the other one sat behind him and the third one went away. When Allah's Messenger (may peace be upon him) had finished his work, he said. Should I not inform you about these three persons? One of them sought refuge with Allah and Allah gave him refuge and the second one felt shy and Allah showed kindness to has shyness (and so he was accommodated in that meeting), and the last one reverted and Allah turned away His attention from him.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5407]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5407

This hadith has been reported on the authority of Ishaq b. 'Abdullah b. Talha with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5408]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5408

Ibn 'Umar reported Allah's Messenger (may peace be upon him) having said: None of you should make another one stand in the meeting and then occupy his place.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5409]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5409

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: No person should ask another person to stand at his place and then he should himself sit there, but he should simply say: Make room and accommodate.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5410]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5410

This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters. but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5411]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5411

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: None should make one'& brother stand and then sit at his place (and it was common with) Ibn Umar that when any person stood in the company (with a view to making room for him) he did not sit there.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5412]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5412

This hadith hilt been reported on the authority of Ma'mar with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5413]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5413

Jabir reported Allah's Apostle (may peace he upon him) as saying: None amongst you should make his brother stand on Friday (during the congregational prayer) and then occupy his-place. but he should only say to him (Accommodate me).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5414]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5414

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When anyone amongst you stands up, and in the badltb transmitted on the authority of Abu 'Awina, the words are:" He who stands in his place and (goes away) and then comes back to it, he his the greatest right (to occupy that).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5415]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5415

Umm Salama reported that she had a eunuch (as a slave) in her house. Allah's Messenger imay peace be upon him) was once in the house that he (the eunuch) said to the brother of Umm Salama: Abdullahb. Aba Umayya. if Allah grants you victory in Ta'if on the next day, I will show you the daughter of Ghailan for she has four folds (upon her body) on the front side of her stomach and eight folds on the back. Allah's Messenger (may peace be upon him) heard this and he said: Such (people) should not visit you.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5416]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5416

'A'isha reported that a eunuch used to come to the wives of Allah's Apostle (may peace be upon him) and they did not And anything objectionable in his visit considering him to be a male without any sexual desire. Allah's Apostle (may peace be upon him) one day came as he was sitting with some of his wives and he was busy in describing the bodily characteristics of a lady and saying: As the comes in front tour folds appear on her front side and as she turns her back eight folds appear on the back side. Thereupon Allah's Apostle (may peace be upon him) said: I me that he knows these things; do not, therefore. allow him to cater. She (" A'isha) said: Then they began to observe veil from him.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5417]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5417

Asma' daughter of Abu Bakr reported that the was married to Zubair. He had neither land nor wealth nor slave nor anything else like it except a bom. She further said: I grazed his horse. provided fodder to it and looked after it, and ground dates for his camel. Besides this, I grazed the camel, made arrangements for providing it with water and patched up the leather bucket and kneaded the flour. But I was not proficient in baking the bread, so my female neighbours used to bake bread for me and they were sincere women. She further said: I was carrying on my head the stones of the dates from the land of Zubair which Allah's Messenger (may peace be upon him) had endowed him and it was at a distance of two miles (from Medina). She add: As I was one day carrying the atones of dates upon my head I happened to meet Allah's Messenger (may peace be upon him) along with a group of his Companions. He called me and said (to the camel) to sit down so that he should make cite ride behind hirn. (I told my husband: ) I felt shy and remembered your jealousy, whereupon he said: By Allah. the carrying of the stone dates upon your bead is more severe a burden than riding with him. She said: (I led the life of hardship) until Abu Bakr sent afterwards a female servant who took upon herself the responsibility of looking after the horse and I felt as it she had emancipated me.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5418]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5418

Asma' reported: I performed the household duties of Zubair and he had a horse; I used to look after it. Nothing was more burdensome for me than looking after the horse I used to bring grass for it and looked after it, then I got a servant as Allah's Apustle (may peace be upon him) had some prisoners of war in his possession. He gave me a female servant. She (the female servant) then began to look after the horse and thus relieved me of this burden. A person came and he said: Mother of 'Abdullah, I am a destitute person and I intend that I should start business under the shadow of your house. I (Asma') said: If I grant you permission, Zubair may not agree to that, so you come and make a demand of it when Zubair is also present there. He came accordingly find said: Mother of 'Abdullah. I am a destitute person. I intend to start t mall business in the shadow of your house. I said: Is there not in Medina (any place for starting the business) except my house? Zubair said: Why is it that you prohibit the destitute man to start business here? So he started business and he (earned so much) that we sold our slave-girl to him There came Zubair to me while the money was in my lap. He said: Give this to me. I said: (I intend) to spend it as charity.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5419]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5419

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: When there are three (persons), two should not converse secretly between themselves to the exclusion of the (third) one.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5420]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5420

This hadith has been reported on the authority of lbn 'Umar through two different chains of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5421]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5421

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If you are three, two amongst you should not converse secretly between yourselves to the exclusion of the other (third one), unti some other people join him (and dispel his loneliness), for it may hurt his feelings.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5422]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5422

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If you are three, two should not converse secretly to the exclusion of your companion for that hurts his feelings.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5423]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5423

This hadith has been reported on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5424]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5424

'A'isha (the wife of Allah's Apostle) said: When Allah's Messenger (may peace be upon him) fell ill. Gabriel used to recite these verses." In the name of Allah. He may cure you from all kinds of illness and safeguard vou from the evil of a jealous one when he feels jealous and from the evil influence of eye."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5425]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5425

Abu Sa'id reported that Gabriel came to AJlah's Messenger (may peace be upon him) and said: Muhammad, have you fallen ill? Thereupon he said: Yes. He (Gabriel) said:" In the name of Allah I exercise you from everything and safeguard you from every evil that may harm you and from the eye of a jealous one. Allah would cure you and I invoke the name of Allah for you."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5426]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5426

Abu Huraira reported so many abidith from Allah's Messenger (may peace be upon him) and he reported Allah's Messenger (may peace be upon him) as saying: The influence of an evil eye is a fact.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5427]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5427

Ibn 'Abbas reported Allah's Messenger (may peace be upon him) as saying: The influence of an evil eye is a fact; if anything would precede the destiny it would be the influence of an evil eye, and when you are asked to take bath (as a cure) from the influence of an evil eye, you should take bath.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5428]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5428

A'isha reported that a Jew from among the Jews of Banu Zuraiq who was called Labid b. al-A'sam cast spell upon Allah's Messenger (may peace be upon him) with the result that he (under the influence of the spell) felt that he had been doing something whereas in fact he had not been doing that. (This state of affairs lasted) until one day or during one night Allah's Messenger (may peace be upon him) made supplication (to dispel its effects). He again made a supplication and he again did this and said to 'A'isha: Do you know that Allah has told me what I had asked Him? There came to me two men and one amongst them sat near my head and the other one near my feet and he who sat near my head said to one who sat near my feet or one who sat near my feet said to one who sat near my head: What is the trouble with the man? He said: The spell has affected him. He said: Who has cast that? He (the other one) said: It was Labid b. A'sam (who has done it). He said: What is the thing by which he transmitted its effect? He said: By the comb and by the hair stuck to the comb and the spathe of the date-palm. He said: Where is tbap He replied: In the well of Dhi Arwan. She said: Allah's Messenger (may peace be upon him) sent some of the persons from among his Companions there and then said: 'A'isha. by Allah, its water was yellow like henna and its trees were like heads of the devils. She said that she asked Allah's Messenger (may peace be upon him) as to why he did not burn that. He said: No, Allah has cured me and I do not like that I should induce people to commit any high-handedness in regard (to one another), but I only commanded that it should be buried.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5429]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5429

'A'isha reported that Allah's Messenger (may peace be upon him) was affected with a spell, the rest of the hadith is the same but with this variation of wording:" Allah's Messenger (may peace be upon him) went to the well and looked towards it and there were trees of date-palm near it. I ('A'isha) said: I asked Allah'& Messenger (may peace be upon him) to bring it out, and 1 did not say: Why did not you burn it?" And there is no mention of these words:" I commanded (to bury them and they buried."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5430]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5430

Anas reported that a Jewess came to Allah's Messenger (may peace be upon him) with poisoned mutton and he took of that what had been brought to him (Allah's Messenger). (When the effect of this poison were felt by him) he called for her and asked her about that, whereupon she said: I had determined to kill you. Thereupon he said: Allah will never give you the power to do it. He (the narrator) said that they (the Companion's of the Holy Prophet) said: Should we not kill her? Thereupon he said: No. He (Anas) said: I felt (the affects of this poison) on the uvula of Aitah's Messenger.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5431]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5431

Anas b. Malik reported that a Jewess brought poisoned meat and then served it to Allah's Messenger (may peace be upon him)


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5432]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5432

'A'isha reported: When any person amongst us fell ill, Allah's Messenger (may peace he upon him) used to rub him with his right band and then say: O Lord of the people, grant him health, heal him, for Thou art a Greet Healer. There is no healere, but with Thy healing Power one is healed and illness is removed. She further added: When Allah's Messenger (may peace be upon him) fell ill, and his illness took a serious turn I took hold of hie hand to that I should do with it what he ward to do with that (i. e. I would rub his body with his sacred hand). But he withdrew his hand from my hand and then said: O Allah, pardon me and make me join the companion. ship on She said. I was gazing at him constantly whereas he had passed away.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5433]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5433

This. hadith has been reported on the authority of Shu'ba through another chain of transmitters (and the words are):" He rubbed him with his hand" and (in) the hadith transmitted on the authority of Thauri (the words are)." He used to rub with his right hand." This hadith has been reported through another chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5434]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5434

'A'isha reported Allah's Messenger (may peace be upon him) as saying: When Allah's Messenger (may peace be upon him) visited the sick he would say: Lord of the people. remove the disease, cure him, for Thou art the great Curer, there is no cure but through Thine healing Power, which leaves nothing of the disease.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5435]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5435

'A'isha reported that when Allah's Messenger (may peace be upon him) came to visit any sick he supplicated for him and said: Lord of the people, remove the malady, cure him for Thou art a great Curer. There is no cure but through Thine healing Power which leaves no trouble, and in the narration transmitted on the authority of Abu Bakr there is a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5436]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5436

This hadith has been reported on the authority of 'A'isha through another chain of transmitters with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5437]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5437

'A'isha reported: Allah's Messenger (may peace be upon him) used to recite (this supplication) as the words of incantation:" Lord of the people, remove the trouble for in Thine Hand is the cure; none is there to relieve him (the burden of disease) but only Thou.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5438]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5438

This hadith has been reported on the authority of Hisham with the same chain of transmitted.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5439]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5439

'A'isha reported that when any of the members of the household fell ill Allah's Messenger (may peace be upon him) used to blow over him by reciting Mu'awwidhatan, and when he suffered from illness of which he died I used to blow over him and rubbed his body with his hand for his hand had greater healing power than my hand.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5440]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5440

'A'isha reported that when Allah's Messenger (may peace be upon him) fell ill, he recited over his body Mu'awwidhatan and blew over him and when his sickness was aggravated I used to recite over him and rub him with his band with the hope that it was more blessed.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5441]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5441

This hadith has been narrated through some other chains of transmitters but with a slight variation of wording. In the hadith transmitted on the authority of Yanus and Ziyari (the words are):" When Allah's Apostle (may peace be upon him) fell ill, he blew over his body by reciting Mu'awwidhatan and rubbed him with his hand.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5442]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5442

'Abd al-Rahman b. al-Aswad reported on the authority of his father: I asked 'A'isha about incantation. She said: Allah's Messenger (may peace be upon him) had granted its sanction to the members of a family of the Ansir for incantation in curing every type of poison.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5443]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5443

'A'isha reported that Allah's Messenger (may peace be upon him) granted sanction to the members of a family of the Ansir for incantation (for removing the effects) of the poison of the scorpion.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5444]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5444

'A'isha reported that when any person fell ill with a disease or he had any ailment or he had any injury, the Apostle of Allah (may peace be upon him) placed his forefinger upon the ground and then lifted it by reciting the name of Allah. (and said): The dust of our ground with the saliva of any one of us would serve as a means whereby our illness would be cured with the sanction of Allab. This hadith has been transmitted on the authority of Ibn Abu Shaiba and Zubair with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5445]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5445

'A'isha reported that Allah's Messenger (may peace be upon him) commanded the use of incantation for curing the influence of an evil eye.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5446]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5446

This hadith has been narrated on the authority of Mis'ar with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5447]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5447

'A'isha reported: Allah's Messenger (may peace he upon him) commanded me that I should make use of incantation for curing the influence of an evil eye.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5448]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5448

Anas b. Malik reported in connection with incantation that he had been granted sanction (to use incantation as a remedy) for the sting of the scorpion and for curing small pustules and dispelling the influence of an evil eye.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5449]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5449

Anas reported that Allah's Messenger (may peace be upon him) granted him sanction to use incantation (as a cure) for the, influence of an evil eye, the sting of the scorpion and small pustules.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5450]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5450

Umm Salama, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said to a small girl in the house of Umm Salama that he had been seeing on her face black stains and told her that that was due to the infiluence of an evil eye, and he asked that she should be cured with the help of incantation (hoping) that her face should become spotles.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5451]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5451

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) granted sanction to the family of Hazm for incantation (in mitigating the effect of the poison of) the snake, and, he said -to Asma' daughter of 'Umais: What is this that I see the children of my brother lean? Are they not fed properly? She said: No, but they fall under the influence of an evil eve. He said: Use incantation She recited (the words of incantation before him), whereupon he (by approving them) said: Yes, use this incantation for them.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5452]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5452

Jabir b. 'Abdullah reported that Allah's Apostle (may peace be upon him) granted a special sanction for incantation in case of the snake poison to a tribe of 'Amr. Abu Zubair said: I heard Jabir b. 'Abdullah as saying that the scorpion stung one of us as we were sitting with Allah's Messenger (may peace upon him). A person said: Allah's Messenger, I use incantation (for curing the effect. of sting), whereupon he said: He who is competent amongst you to benefit his brother should do so.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5453]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5453

This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5454]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5454

Jabir b. 'Abdullah reported I had a maternal uncle who treated the sting of the scorpion with the help of incantation. Allah's Messenger (may peace be upon him) forbade incantation. He came to him and said: Allah's Messenger, you forbade to practise incantation, whereas I employ it for curing the sting of the scorpion, whereupon he said: He who amongst you is capable of employing it as a means to do good should do that.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5455]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5455

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5456]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5456

Jabir reported Allah's Messenger (may peace be upon him) prohibited incantation. Then the people of Amr b. Hazm came to Allah's Messenger (may peace be upon him) and said: We know an incantation which we use for curing the sting of the scorpion but you have prohibited it. They recited (the words of incantation) before him, whereupon he said: I do not see any harm (in it), so he who amongst you is competent to do good to his brother should do that.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5457]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5457

'Auf b. Malik Ashja'i reported We practised incantation in the pre-Islamic days and we said: Allah's Messenger. what is your opinion about it? He said: Let me know your incantation and said: There is no harm in the incantation which does not smack of polytheism.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5458]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5458

Abu Sa'id Khudri reported that some persons amongst the Companions of Allah's Messenger (may peace be upon him) set out on a journey and they happened to pass by a tribe from the tribes of Arabia. They demanded hospitality from the members of that tribe, but they did not extend any hospitality to them. They said to them: Is there any incantator amongst you, at the chief of the tribe has bgen stung by a scorpion? A person amongst us said: 'Yes. So he came to him and he practised incan- tation with the help of Sura al-Fatiha and the person became all right. He was given a flock of sheep (as recompense), but he refused to accept that, saying: I shall make a mention of it to Allah's Apostle (may peace be upon him), and if he approves of it. then I shall accept it. So we came to Allah's Apostle (may peace be upon him) and made a mention of that to him and he (that person) said: Allah's Messenger by Allah, I did not practice incantation but with the help of Sura al-Fatiha of the Holy Book. He (the Holy Prophet) smiled and said: How did you come to know that it can be used (as incactation)? - and then said: Take out of that and allocate a share for me along with your share.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5459]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5459

This hadith has been reported on the authority of Abu Bishr with the same the same chain of transmitters (with these words): That he recited Umm-ul-Qur'an (Sura Fatiha), and he collected his spittle and he applied that and the person became all right.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5460]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5460

Abu Sa'id al-Khudri reported. We landed at a place where a woman came to us and said: A scorpiorn has bitten the chief of the tribe. Is there any incantator amongst you? A person amongst us stood up (and went with her). We had no idea that he had been a good incantator but he practised incantation with the help of Sura al -Fatiha and the (the chief) was all right. They gave him a flock of sheep and served us milk. We said (to him): Are you a good incantatory Thereupon he said: I did not do it but by the help of Sura al-Fitiha. He caid: Do not drive (these goats) until we go to Allah's Messenger (may peace be upon him) and find out (whether it is permissible to accept ( this reward of incantation). So we came to Allah's Apostle (may peace be upon hin) and made a rrention of that to him, whereupon he said: How did you come to know that this (Sura al-Fatiha) could be used as an incantation? So distribute them (amongst those who had been present there with him) and allocate a share of mine also.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5461]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5461

This hadith has been narrated on the authority of Hisham with the same chain of transmitters and he said: There stood up with her a person amongst us whom we did not know before as an incantator.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5462]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5462

Uthman b. Abu al-'As Al-Thaqafi reported that he nade a complaint of pain to Allah's Messenger (may peace be upon him) that he felt in his body at the time he had become Muslim. Thereupon Allah's Messenger (may peace be upon him) said: Place your hand at the place where you feel pain in your body and say Bismillah (in the name of Allah) three times and seven times A'udhu billahi wa qudratihi min sharri ma ajidu wa ukhdhiru (I seek refuge with Allah and with His Power from the evil that I find and that I fear).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5463]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5463

Uthman b. Abu al-'As reported that he came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, the Satan intervenes between me and my prayer and my reciting of the Qur'an and he confounds me. Thereupon Allah's Messenger (may peace be upon him) said:, That is (the doing of the Satan) who is known as Khinzab, and when you perceive its effect, seek refuge with Allah from it and spit three times to your left. I did that and Allah dispelled that from me.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5464]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5464

'Uthman b. Abu al-'As reported that he came to Allah's Apostle (may peace be upon him) and he narrated like this. In the hadith transmitted on the authority of Salam b. Nuh there is no mention of three times,


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5465]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5465

This hadith has been transmitted on the authority of 'Uthman b. Abu al-'As with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5466]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5466

Jabir reported Allah's Messenger (may peace be upon him) as saying: There is a remedy for every malady, and when the remedy is applied to the disease it is cured with the permission of Allah, the Exalted and Glorious.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5467]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5467

Jabir reported that he visited Muqanna' and then said: I will not go away unless you get yourself cupped, for I heard Allah's Messenger (may peace be upon him) say: It is a remedy.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5468]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5468

'Asim b. 'Umar b. Qatada reported: There came to our house 'Abdullah and another person from amongst the members of the household who complained of a wound. Jabir said: What ails you? He said: There is a wound which is very painful for me, whereupon he said: Boy, bring to me a cupper. He said: 'Abdullah, what do you intend to do with the cupper? I said: I would get this wound cupped. He said: By Allah. oven the touch of fly or cloth causes me pain (and cupping) would thus cause me (unbearable) pain. And when he saw him feeling pain (at the idea of cupping), he said: I heard Allah's Messenger (may peace be upon him) as saying: If there is any effective remedy amongst your remedies, these are (three): Cupping, drinking of honey and cauterisation with the help of fire. Allah's Messenger (may peace be upon him) had said: As for myself I do not like cauterisation. The cupper was called and he cupped him and he was all right.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5469]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5469

Jabir reported that Umm Salama sought permission from Allah's messenger (may Allah's peace upon him) tor getting herself cupped. The Apostle of Allah (may peace be upon him) asked Abu Taiba to cup her. He (Jabir) said: I think he (Abu Taiba) was her faster brother or a young boy before entering upon the adolescent period.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5470]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5470

Jabir reported that Allah's Messenger (may peace be upon him) sent a phystian to Ubayy b. Ka'b. He cut the vein and then cauterised it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5471]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5471

A'mash reported this with the same chain of transmitters and he made no mention of the fact that he cut one of his veins.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5472]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5472

Jabir b. 'Abdillah reported that on the day of Ahzab Ubayy received the wound of an arrow in his medial arm vein. Allah's Messenger (may peace be upon him) cauterised it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5473]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5473

Jabir reported that Sa'd b. Mu'adh received a wound of the arrow in his vein. Allah's Messenger (may peace be upon him) cauterised it with a rod and it was swollen, to the Messenger of Allah (may peace be upon him) did it for the second time.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5474]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5474

Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) got himself cupped and gave to the cupper his wages and he put the medicine in the nostril.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5475]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5475

Anas b. Malik reported that Allah's Messenger (may peace be upon him) got himself cupped and never withheld the wages of anyone.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5476]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5476

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: The fever from the vehement raging of the (heat of Hell), so cool it with the help of water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5477]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5477

Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: Fever is due to vehemence of the beat of Hell, so cool it with water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5478]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5478

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Fever is from the vehement raging of the fire of Hell, so extinguish it with water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5479]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5479

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Fever is from the vehement Paging of the Hell-fire, so cool it with water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5480]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5480

'A'isha reported Allah's messenger (may peace be upon him) as saying: Fever is from the vehement raging of the Hell-fire, so cool it with water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5481]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5481

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5482]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5482

Asma' reported that a woman running high fever was brought to her. She asked water to be brought and then sprinkled it in the opening of a shirt at the uppermost part of the chest and said that Allah's Messenger (may peace be upon him) had said: Cool (the fever) with water. for it is because of the vehemence of the beat of Hell.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5483]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5483

Hisham reported this hadith with the same chain of transmitters. In the hadith transmitted on the authority of Ibn Numair (the words are):" She poured water on her sides and in the opening of the shirt at the uppermost part of the chest." There is no mention of these words:" It is from the vehemence of the heat of the Hell." This hadith has been narrated on the authority of Abu Usama with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5484]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5484

Rafi' b. Khadij reported: I heard Allah's messenger (may peace be upon him) as saying: The fever is due to the intense heat of the Hell, so cool it with water.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5485]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5485

Rafi' b. Khadij reported: I heard Allah's Messenger (may peace be upon him) as saying: The fever is due to the intense heat of Hell, so cool it down in your (bodies) with water. Aba Bakr has made no mention of the word" from you" ('ankum), but he said that Rafi' b. Khadij had informed him of it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5486]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5486

'A'isha reported: we (intended to pour) medicine in the mouth of Allah's Messenger (may peace be upon him) in his illness, but he pointed out (with the gesture of his hand) that it should not be poured into the mouth against his will. We said: (It was perhaps due to the natural) aversion of the patient against medicine. When he recovered, he said: Medicine should be poured into the mouth of every one of you except Ibn 'Abbas, for he was not present amongst you.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5487]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5487

Umm Qais, daughter of Mihsan, the sister of 'Ukasha b. Mihsan said: I visited Allah's Messenger (may peace be upon him) along with my son who had not, by that time, been weaned and he pissed over his (clothes). He ordered water to be brought and sprinkled (it) over them. She (further) said: I visited him (Allah's Apostle) along with my son and I had squeezed the swelling in the uvula, whereupon he said: Why do you afflict your children by compressing like this? Use this Indian aloeswood, for it contains seven types of remedies, one among them being a remedy for pleurisy. It is applied through the nose for a swelling of the uvula and poured into the side of the mouth for pleurisy.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5488]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5488

Umm Qais, daughter of Mihsan, was one of the earlier female emigrants who had pledged allegiance to Allah's Messenger (may peace be upon him). She was the sister of Ukisha b. Mihsan, one of the posterity of Asad b. Khuzaima. She reported that she came to Allah's messenger (may peace be upon him) along with her son who had not attained the age of weaning and she had compressed the swelling of his uvula. (Yunus said: She compressed the uvula because she was afraid that there might be swelling of uvula.) Thereupon Allah's Messenger (may peace be upon him) said: Why do you afflict your children by compressing in this way? You should use Indian aloeswood, for it has seven remedies in it, one of them being the remedy for pleurisy. Ubaidullah reported that she had told that that was the child who pissed in the lap of Allah's Messenger (may peace be upon him), and Allah's Messenger (may peace be upon him) called for water and sprinkled it on his imrine, but he did not wash it well.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5489]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5489

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: Nigella seed is a remedy for every disease except death. This hadith has been narrated through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5490]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5490

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no disease for which Nigella seed does not provide remedy.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5491]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5491

'A'isha the wife of Allah's Apostle (may peace be upon him) said: When there was any bereavement in her family the women gathered there for condolence and they departed except the members of the family and some selected persons. She asked to prepare talbina in a small couldron and it was cooked and then tharid was prepared and it was poured over talbina, then she said: Eat it, for I heard Allah's Messenger (may peade be upon him) as saying: Talbina gives comfort to the aggrieved heart and it lessens grief.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5492]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5492

Abu Sa'id Khudri reported that a person came to Allah's Apostle (may peace be upon him) and told him that his brother's bowels were loose. Thereupon Allah's Messenger (may peace be upon him) said: Give him honey. So he gave him that and then came and said: I gave him honey but it has only made his bowels more loose. He said this three times; and then he came the fourth time, and he (the Holy Prophet) said: Give him honey. He said: I did give him, but it has only made his bowels more loose, whereupon Allah's Messenger (may peace be upon him) said: Allah has spoken the truth and your brother's bowels are in the wrong. So he made him drink (honey) and he was recovered. This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5493]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5493

'Amir b. Sa'd b. Abu Waqqas reported on the authority of his father that he asked Usama b. Zaid: What have you heard from Allah's Messenger (may peace be upon him) about plague? Thereupon Usama said: Allah's Messenger (may peace be upon him) said: Plague is a calamity which was sent to Bani Isra'il or upon those who were before you. So when you hear that it has broken out in a land, don't go to it, and when it has broken out in the land where you are, don't run out of it. In the narration transmitted on the authority of Abu Nadr there is a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5494]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5494

Usama b. Zaid reported that Allah's Messenger (may peace be upon him) had said: Plague is the sign of a calamity with which Allah, the Exalted and Glorious, affects people from His servants. So when you hear about it, don't enter there (where it has broken out), and when it has broken out in a land and you are there, then don't run away from it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5495]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5495

Usama reported Allah's Messenger (may peace be upon him) as saying: Plague is a calamity which was inflicted on those who were before you, or upon Bani Isra'il. So when it has broken out in a land, don't run out of it, and when it has spread in a land, then don't enter it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5496]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5496

'Amir b. Sa'd reported that a person asked Sa'd b. Abu Waqqas about the plague, whereupon Usama b. Zaid said: I would inform you about it. The Messenger of Allah (may peace be upon him) said: It is a calamity or a disease which Allah sent to a group of Bani Isra'il, or to the people who were before you; so when you hear of it in land, don't enter it and when it has broken out in your land, don't run away from it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5497]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5497

This hadith has been narrated on the authority of Ibn Juraij through another chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5498]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5498

Usama b. Zaid reported Allah's Messenger (may peace be upon him) having said this: This calamity or illness was a punishment with which were punished some of the nations before you. Then it was left upon the earth. It goes away once and comes back again. He who heard of its presence in a land should not go towards it, and he who happened to be in a land where it had broken out should not fly from it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5499]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5499

This hadith has been narrated on the authority of Zuhri with a different chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5500]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5500

Shu'ba reported from Habib: While we were in Medina we heard of plague having broken out in Kufa. 'Ata b. Yasir and others said to me that Allah's Messenger (may peace be upon him) had said. If you are in a land where it (this scourge) has broken out, don't get out of it, and if you were to know that it had broken (in another land, then don't enter it. I said to him: From whom (did you hear it)? They said: 'Amir b. Sa'd has narrated it. So I came to him. They said that he was not present there. So I met his brother Ibrahim b. Sa'd and asked him. He said: I bear testimony to the fact that Usama narrated it to Sa'd saying: I heard Allah's Messenger (may peace be upon him) as saying that it is a God-sent punishment from the calamity or from the remnant of the calamity with which people were afflicted before you. So when it is in a land and you are there, don't get out of it, and if (this news reaches you) that it has broken out in a land, then don't enter therein. Habib said: I said to Ibrahim: Did you hear Usama narrating it to Sa'd and he was not denying it. He said: Yes.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5501]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5501

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters except for the fact that no mention has been made of the account of 'Ata b. Yasir as in the previous hadith.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5502]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5502

This hadith has been transmitted on the authority of Sa'd b. Malik, Khuzaima b. Thabit and Usama b. Zaid.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5503]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5503

Ibrahim b. Sa'd b. Abu Waqqas reported: Usama b. Zaid and Sa'd had been sitting and they had been conversing and they said this: This hadith has been transmitted by Ibrahim b. Sa'd b. Malik on the authority of his father.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5504]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5504

'Abdullah b. 'Abbas reported: Umar b. Khattab set out for Syria. As he came at Sargh (a town by the side of Hijaz on the way to Syria), there met him the commander of the forces, Abu Ubaida b. Jandb, and his companions. They informed him that a scourge had broken out in Syria. Ibn 'Abbas further reported that 'Umar said: Call to me tile earliest emigrants. So I called them. He (Hadrat 'Umar) sought their advice, and they told him that the scourge had broker, out in Syria. There was a difference of opinion (whether they should proceed further or go back to their homes in such a situation). Some of them said: You ('Umar) have set forth for a task, and, therefore, we would not advise you to go back, whereas some of them said: You have along with you the remnants (of the sacred galaxy) of men and (the blessed) Companions of Allah's Messenger (may peace be upon him), so we would not advise you to go forth towards this calamity (with such eminent persons and thus expose them deliberately to a danger). He (Hadrat 'Umar) said: You can now go away. He said: Call to me the Ansar. So I called them to him, and he consulted them, and they trod the same path as was trodden by the Muhajirin, and they differed in their opinions as they had differed. He said: Now, you can go. He again said: Call to me the old persons of the Quraish who had migrated before the Victory (that is the Victory of Mecca), so I called them (and Hadrat 'Umar consulted them) and not even two persons differed (from the opinion held by the earlier delegates). They said: Our opinion is that you better go back along with the people and do not make them go to this scourge, So 'Umar made announcement to the people: In the morning I would be on the back of my side. So they (set forth in the morning), whereupon Abu 'Ubaida b. Jarrah said: Are you going to run away from the Divine Decree? Thereupon 'Umar said: Had it been someone else to say this besides you! 'Umar (in fact) did not approve of his opposing (this decision) and he said: Yes, we are running from the Divine Decree (to the) Divine Decree. You should think if there had been camels for you and you happened to get down in a valley having two sides, one of them covered with verdure and the other being barren, would you not (be doing) according to the Divine Decree if you graze them in verdure? And in case you graze them in the barren land (even then you would be grazing them) according to the Divine Decree.

There happened to come 'Abd al-Rahman b. 'Auf and he had been absent in connection with some of his needs. He said: I have with me a knowledge of it, that I heard Allah's Messenger (may peace be upon him) as saying: If you hear of its presence (the presence of plague) in a land, don't enter it, but if it spreads in the land where you are, don't fly from it. Thereupon 'Umar b. Khattab praised Allah and then went back?


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5505]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5505

This hadith has been reported on the authority of Ma'mar with the same chain of transmitters but with this addition:" Do you think that he would graze in the barren land but would abandon the green land? Would you not attribute it to be a failing on his part? He said: Yes. He said: Then proceed. And he moved on until he came to Medina. And he said to me: This is the right place, or he said: That is the destination if Allah so wills." This hadith has been transmitted on the authority of 'Abdullah b. Harith with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5506]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5506

'Amir b. Rabi'ah reported: 'Umar went to Syria and as he came to Sargh, information was given to him that an epidemic had broken out in Syria. 'Abd al-Rahman b. 'Auf narrated to him that Allah's Messenger (may peace be upon him) had said: When you hear of its presence in a land, don't move towards it, and when it breaks out in a land and you are therein, then don't run away from it. So 'Umar b. Khattab came back from Sargh. Salim b. 'Abdullah reported that 'Umar went back, along with people on hearing the hadith reported on the authority of 'Abd al-Rahman b. 'Auf.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5507]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5507

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no infection, no safar, no hama. A desert Arab said: Allah's Messenger, how is it that when the camel is in the sand it is like a deer-then a camel afflicted with scab mixes with it and it is affected by sub? He (the Holy Prophet) said: Who infected the first one?


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5508]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5508

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no evil omen, no safar, no hama. A desert Arab said: Allah's, Messenger.... The rest of the hadith is the same.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5509]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5509

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no trahsitive disease. Thereupon a desert Arab stood up. The rest of the hadith is the same and in the hadith transmitted on the authority of Zuhri' the Prophet (may peace be upon him) is reported to have said: There is no transitive disease, no safar, no hama.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5510]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5510

Abu Salama h. 'Abd al-Rahman b. 'Auf reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, but he is also reported to have said: A sick person should not be taken to one who is healthy. Abu Salama said that Abu Huraira used to narrate these two (different ahadith) from Allah's Messenger (may peace be upon him), but afterwards Abu Huraira became silent on these words:" There is no transitive disease," but he stuck to this that the sick person should not be taken to one who is healthy. Harith b. Abu Dhubab (and he was the first cousin of Abu Huraira) said: Abu Huraira, I used to hear from you that you narrated to us along with this hadith and the other one also (there is no transitive disease), but now you observe silence about it. You used to say that Allah's Messenger (may peace be upon him) said: There is no transitive disease. Abu Huraira denied having any knowledge of that, but he said that the sick camel should not be taken to the healthy one. Harith, however, did not agree with him, which irritated Abu Huraira and he said to him some words in the Abyssinian language. He said to Harith: Do you know what I said to you? He said: No. Abu Huraira said: I simply denied having said it. Abu Salama sad: By my life, Abu Huraira in fact used to report Allah's Messenger (may peace be upon him) having said: There is no transitive disease. I do not know whether Abu Huraira has forgotten it or he deemed it an abrogated statement in the light of the other one.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5511]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5511

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease and he also reported along with it: The ill should not be taken to the healthy.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5512]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5512

This hadith has been reported on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5513]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5513

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no huma, no star promising rain, no safar.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5514]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5514

Jabir reported Allal's Messenger (may peace be upon him) as saying: There is no transitive disease, no ill omen, no ghoul.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5515]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5515

Jabir reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no ghoul, no safar.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5516]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5516

Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: There is no transitive disease, no safar, no ghoul. He (the narrator) said: I heard Abu Zubair say: Jabir explained for them the word safar. Abu Zubair said: safar means belly. It was said to Jabir: Why is it so? He said that it was held that safar implied the worms of the belly, but he gave no explanation of ghoul. Abu Zubair said: Ghoul is that which kills the travellers.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5517]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5517

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: There is no divination but the best type is the good omen. It was said to Allah's Messenger (may peace be upon him): What is good omen? Thereupon he said: A good word which one of you hears.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5518]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5518

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5519]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5519

Anas reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but good omen pleases me, i. e. the good word or a good word.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5520]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5520

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but good omen pleases me. It was said: What is good omen? He said: Sacred words.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5521]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5521

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no divination, but I like good words.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5522]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5522

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is no transitive disease, no hama, no divination, but I like good omen.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5523]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5523

'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: If there be bad luck, it is in the house, and the wife, and the horse.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5524]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5524

'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying. There is no transitive disease, no ill omen, and bad luck is lound in the house, or wife or horse.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5525]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5525

This hadith has been reported on the authority of Zuhri with other chains of transmitters but with slight variations of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5526]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5526

'Umar b. Muhammad b. Zaid reported that he heard his father narrating from Ibn 'Umar that Allah's Messenger (may peace be upon him) had said. If bad luck is a fact, then it is in the horse, the woman and the house.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5527]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5527

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but there is no mention of the word" Haqq"" (fact).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5528]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5528

'Abdullah b. 'Umar reported on the authority of his father that Allah's Messenger (may peace be upon him) said: If there is bad luck in anything, it is the horse, the abode and the woman.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5529]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5529

Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: If bad luck were to be in anything, it is found in the woman, the horse and the abode.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5530]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5530

This hadith has been narrated on the authority of Sahl b. Sa'd with a difterent chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5531]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5531

Jabir reported Allah's Messenger (may peace be upon him) as saying: If bad luck were to be in anything, it is found in the land, in the servant and in the horse.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5532]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5532

Mu'awiya b. al-Hakam as-Sulami reported: I said: Messenger of Allah, there were things we used to do in the pre-Islamic days. We used to visit Kahins, whereupon he said: Don't visit Kahins. I said: We used to take omens. He said: That is a sort of personal whim of yours, so let it not prevent you (from doing a thing).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5533]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5533

This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5534]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5534

This hadith has been narrated on the authority of Mu'awiya b. Hakam as-Sulami through another chain of transmitters. The hadith transmitted on the authority of Yahya b. Abu Kathir (there is an addition of these words): I said: Among us there are men who draw lines and thus make divination. What about this? Thereupon he (the Holy Prophet) said: There was a Prophet who drew lines, so whose lines agree with his line for him it is allowable.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5535]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5535

'A'isha reported: I said: Allah's Messenger, the kahins used to tell us about things (unseen) and we found them to be true. Thereupon he said: That is a word pertaining to truth which a jinn snatches and throws into the ear of his friend, and makes an addition of one hundred lies to it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5536]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5536

'Urwa reported from 'A'isha that she said that people asked Allah's Messenger (may peace be upon him) about the kahins. Allah's Messenger (may peace be upon him) said to them: It is nothing (i. e. it is a mere superstition). They said: Allah's Messenger, they at times narrate to us things which we find true. Thereupon Allah's Messenger (may peace be upon him) said: That is a word pertaining to truth which a jinn snatches away and then cackles into the ear of his friend as the hen does. And then they mix in it more than one hundred lies.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5537]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5537

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5538]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5538

'Abdullah. Ibn 'Abbas reported: A person from the Ansar who was amongst the Companions of Allah's Messenger (may peace be upon him) reported to me: As we were sitting during the night with Allah's Messenger (may peace be upon him), a meteor shot gave a dazzling light. Allah's Messenger (may peace be upon him) said: What did you say in the pre-Islamic days when there was such a shot (of meteor)? They said: Allah and His Messenger know best (the actual position), but we, however, used to say that that very night a great man had been born and a great man had died, whereupon Allah's Messenger (may peace be upon him) said: (These meteors) are shot neither at the death of anyone nor on the birth of anyone. Allah, the Exalted and Glorious, issues Command when He decides to do a thing. Then (the Angels) supporting the Throne sing His glory, then sing the dwellers of heaven who are near to them until this glory of God reaches them who are in the heaven of this world. Then those who are near the supporters of the Throne ask these supporters of the Throne: What your Lord has said? And they accordingly inform them what He says. Then the dwellers of heaven seek information from them until this information reaches the heaven of the world. In this process of transmission (the jinn snatches) what he manages to overhear and he carries it to his friends. And when the Angels see the jinn they attack them with meteors. If they narrate only which they manage to snatch that is correct but they alloy it with lies and make additions to it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5539]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5539

The hadith has been narrated on the authority of Zuhri through the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5540]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5540

Safiyya reported from some of the wives of Allah's Apostle (may peace be upon him) Allah's Apostle (may peace be upon him) having said: He who visits a divner ('Arraf) and asks him about anything, his prayers extending to forty nights will not be accepted.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5541]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5541

'Amr b. Sharid reported on the authority of his father that there was in the delegation of Thaqif a leper. Allah's Apostle (may peace be upon him) sent a message to him: We have accepted your allegiance, so you may go.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5542]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5542

'A'isha reported that Allah's Messenger (may peace be upon him) commanded the killing of a snake having stripes over it, for it affects eyesight and miscarries pregnancy.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5543]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5543

This hadith has been transmitted on the authority of Hisham. He said: The short-tailed snake and the snake having stripes over it should be killed.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5544]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5544

Salim, on the authority of his father. reported Allah's Apostle (may peace be upon him) as saying: Kill the snakes having stripes over them and short-tailed snakes, for these two types cause miscarriage (of a pregnant woman) and they affect the eyesight adversely. So Ibn 'Umar used to kill every snake that he found. Abu Lubaba b. 'Abd al-Mundhir and Zaid b. Khattab saw him pursuing a snake, whereupon he said: They were forbidden (to kill) those snakes who live in houses.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5545]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5545

Ibn 'Umar reported: I heard Allah's Messenger (may peace be upon him) commanding the killing of dogs and the killing of the striped and the short-tailed snakes, for both of them affect the eyesight adversely and cause miscarriage. Zuhri said: We thought of their poison (the pernicious effects of these two). Allah, however, knows best. 'Abdullah b. 'Umar said: I did not spare any snake. I rather killed everyone that I saw. One day as I was pursuing a snake from amongst the snakes of the house, Zaid b. Khattab or Abu Lubaba happened to pass by me and found me pursuing it. He said: 'Abdullah, wait. I said: Allah's Messenger (may peace be upon him) commanded (us) to kill them, whereupon he said that Allah's Messenger (may peace be upon him) forbade the killing of the snakes of the houses. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5546]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5546

Nafi' reported that Abu Lubaba talked to Ibn 'Umar to open a door in his house which would bring them nearer to the mosque and they found a fresh slough of the snake, whereupon 'Abdullah said: Find it out and kill it. Abu Lubaba said: Don't kill them, for Allah's Messenger (may peace be upon him) forbade the killing of the snakes found in houses.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5547]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5547

Nafi' reported that Ibn 'Urnar used to kill all types of snakes until Abu Lubaba b. 'Abd al-Mundhir Badri reported that Allah's Messenger (may peace be upon him) had forbidden the killing of the snakes of the houses, and so he abstained from it.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5548]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5548

Nafi' reported that he heard Abu Lubaba informing Ibn 'Umar that Allah's Messenger (may peace be upon him) had forbidden the killing of domestic snakes.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5549]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5549

'Abdullah reported that Abu Lubaba had informed him that Allah's Messenger (may peace be upon him) had forbidden the killing of the snakes found in the house.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5550]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5550

Nafi' reported that Abu Lubaba b. 'Abd al-Mundhir al-Ansari (first) lived in Quba. He then shifted to Medina and as he was in the company of 'Abdullah b. 'Umar opening a window for him, he suddenly saw a snake in the house. They (the inmates of the house) attempted to kill that. Thereupon Abu Lubaba said: They had been forbidden to make an attempt to kill house snakes and they had been commanded to kill the snakes having small tails, small snakes and those having streaks over them, and it was said: Both of them affect the eyes and cause miscarriage to women.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5551]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5551

Nafi' reported on the authority of his father that as 'Abdullah b. 'Umar saw one day (standing) near the ruin (of his house) the slough of a snake and said (to the people around him): Pursue this snake and kill it. Abu Lubaba Ansari said: I heard Allah's Messenger (may peace be upon him). He forbade the killing of snakes found in the houses except the short-tailed snakes and those having streaks upon them, for both of them obliterate eyesight and affect that which is in the wombs of (pregnant) women.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5552]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5552

Nafi' reported that Abu Lubaba happened to pass by Ibn 'Umar who lived in the fortified place near the house of 'Umar b. Khattab and was busy in keeping his eyes upon a snake and killing it, the rest of the hadith is the same.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5553]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5553

'Abdullah reported: We were with Allah's Messenger (may peace be upon him) in a cave when there was revealed to him (the Sura al-Mursalat, i. e. Sura lxxvii.:" By those sent forth to spread goodness" ) and we had just heard (it) from his lips that there appeared before us a snake. He said: Kill it. We hastened to kill it, but it slipped away from us, thereupon Allah's Messenger (may peace be upon him) said: Allah saved it from your harm just as he saved you from its evil.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5554]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5554

This hadith has been narrated on the authority of al-A'mash with the same chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5555]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5555

'Abdullah reported that Allah's Messenger (may peace be upon him) commanded a Muhrim (one who is in the state of pilgrimage) to kill the snake at Mina.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5556]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5556

'Abdullah reported: While we were with the Messenger of Allah (may peace be upon him) in the cave, the rest of the hadith is the same as the one narrated above.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5557]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5557

Abu as-Sa'ib, the freed slaved of Hisham b. Zuhra, said that he visited Abu Sa'id Khudri in his house, (and he further) said: I found him saying his prayer, so I sat down waiting for him to finish his prayer when I heard a stir in the bundles (of wood) lying in a comer of the house. I looked towards it and found a snake. I jumped up in order to kill it, but he (Abu Sa'id Khudri) made a gesture that I should sit down. So I sat down and as he finished (the prayer) he pointed to a room in the house and said: Do you see this room? I said: Yes. He said: There was a young man amongst us who had been newly wedded. We went with Allah's Messenger (may peace be upon him) (to participate in the Battle) of Trench when a young man in the midday used to seek permission from Allah's Messenger (may peace be upon him) to return to his family. One day he sought permission from him and Allah's Messenger (may peace be upon him) (after granting him the permission) said to him: Carry your weapons with you for I fear the tribe of Quraiza (may harm you). The man carried the weapons and then came back and found his wife standing between the two doors. He bent towards her smitten by jealousy and made a dash towards her with a spear in order to stab her. She said: Keep your spear away and enter the house until you see that which has made me come out. He entered and found a big snake coiled on the bedding. He darted with the spear and pierced it and then went out having fixed it in the house, but the snake quivered and attacked him and no one knew which of them died first, the snake or the young man. We came to Allah's Apostle (may peace be upon him) and made a mention to him and said: Supplicate to Allah that that (man) may be brought back to life. Thereupon he said: Ask forgiveness for your companion and then said: There are in Medina jinns who have accepted Islam, so when you see any one of them, pronounce a warning to it for three days, and if they appear before you after that, then kill it for that is a devil.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5558]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5558

Asma' b. 'Ubaid reported about a person who was called as-Sa'ib having said: We visited Abu Sa'id Khudri. When we had been sitting (with him) we heard a stir under his bed. When we looked we found a big snake, the rest of the hadith is the same. And in this Allah's Messenger (may peace be upon him) is reported to have said: Verily in these houses there live aged (snakes), so when you see one of them, make life hard for it for three days, and if it goes away (well and good), otherwise kill it for (in that case) it would be a nonbeliever. And he (the Holy Prophet) said (to his Companions): Go and bury your companion (who had died by the snake bite).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5559]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5559

Abu Sa'id Khudri reported Allah's Messenger having said: There is a group of jinns in Medina who accepted Islam, so he who would see anything from these occupants should warn him three times; and if he appears after that, he should kill him for he is a satan.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5560]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5560

Umm Sharik reported that Allah's Messenger (may peace be upon him) commanded her to kill geckos. This hadith has been transmitted on the authority of Ibn Abi Shaiba with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5561]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5561

Umm Sharik reported that she consulted Allah's Apostle (may peace be upon him) in regard to killing of geckos, and he commanded to kill them and Umm Sharik is one of the women of Bani 'Amir b. Luwayy. This hadith has been reported through another chain of transmitters with the same meaning.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5562]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5562

'Amir b. Sa'd reported on the authority of his father that Allah's Apostle (may peace be upon him) commanded the killing of geckos, and he called them little noxious creatures.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5563]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5563

'A'isha reported that Allah's Messenger (may peace be upon him) said about the gecko as a noxious creature". Harmala made this addition that she said: I did not hear that he had commanded to kill them.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5564]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5564

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who killed a gecko with the first stroke for him is such and such a reward, and he who killed it with a second stroke for him is such and such reward less than the first one, and he who killed it with the third stroke for him is such and such a reward less than the second one.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5565]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5565

This hadith has been reported on the authority of Abu Huraira through another chain of transmitters (and the words are): - He who killed a gecko with the first stroke for him are ordained one hundred virtues, and with the second one less than that and with the third one less than that.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5566]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5566

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying (that he who kills a gecko) with the first stroke there are seventy rewards for him.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5567]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5567

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An ant had bitten a Prophet (one amongst the earlier Prophets) and he ordered that the colony of the ants should be burnt. And Allah revealed to him:" Because of an ant's bite you have burnt a community from amongst the communities which sings My glory."


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5568]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5568

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: An Apostle from amongst the Apostles of Allah encamped under a tree, and an ant bit him, and he commanded his belongings to be removed from underneath the tree. He then commanded and it was burnt, and Allah revealed to bin):" Why one ant (which had bitten you) was not killed?"


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5569]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5569

Abu Huraira reported so many ahadith and one of them was this that Allah' Messenger (may peace be upon him) said: When an Apostle from amongst the Apostles of Allah came to sit under a tree an ant bit him. He commanded his luggage to be removed from under the tree and he commanded it to be burnt in the fire and Allah revealed to him:" Why one ant (which had bitten you) was not killed (and why did you burn the others)?


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5570]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5570

Nafi' reported from 'Abdullah that Allah's Messenger (may peace be upon him) said: A woman was punished because she had kept a cat tied until it died, and (as a punishment of this offence) she was thrown into the Hell. She had not provided it with food, or drink, and had not freed her so that she could eat the insects of the earth.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5571]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5571

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5572]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5572

This hadith has been transmitted on the authority of Ibn 'Umar also.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5573]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5573

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A woman was punished because of a cat. She had neither provided her with food nor drink, nor set her free so that she might eat the insects of the earth.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5574]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5574

This hadith has been narrated on the authority of Hisham with the same chain of transmitters, but with a slight variation of wording.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5575]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5575

Abu Huraira reported this hadith through another chain of transmitters.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5576]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5576

Hammam b. Manabbih reported this hadith on the authority of Abu Huraira.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5577]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5577

Abu Huraira reported Allah's Messenger (may peace be upon him) as sayings: A person suffered from intense thirst while on a journey, when he found a well. He climbed down into it and drank (water) and then came out and saw a dog lolling its tongue on account of thirst and eating the moistened earth. The person said: This dog has suffered from thirst as I had suffered from it. He climbed down into the well, filled his shoe with water, then caught it in his mouth until he climbed up and made the dog drink it. So Allah appreciated this act of his and pardoned him. Then (the Companions around him) said: Allah's Messenger, is there for us a reward even for (serving) such animals? He said: Yes, there is a reward for service to every living animal.


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5578]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5578

Abu Huraira reported Allah's Messenger (may pace be upon him) as saying: A prostitute saw a dog moving around a well on a hot day and hanging out its tongue because of thirst. She drew water for it in her shoe and she was pardoned (for this act of hers).


Muslim :: The Book on Salutations and Greetings (Kitab As-Salam) :: [26.5579]

The Book on Salutations and Greetings (Kitab As-Salam)

Muslim :: Book 26 : Hadith 5579

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was a dog moving around a well whom thirst would have killed. Suddenly a prostitute from the prostitutes of Bani Isra'il happened to see it and she drew water in her shoe and made it drink, and she was pardoned because of this.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5580]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5580

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam abuses Dahr (the time), whereas I am Dahr since in My hand are the day and the night.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5581]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5581

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam displeases Me by abusing Dahr (time), whereas I am Dahr--I alternate the night and the day.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5582]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5582

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: The son of Adam causes Me pain as he says: Woe be upon the Time. None of you should say this: Woe be upon the Time, as I am the Time (because) I alternate the day and the night, and when I wish I can finish them up.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5583]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5583

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: Woe be upon the Time, for verily Allah is the Time.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5584]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5584

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Do not abuse Time, for it is Allah Who is the Time.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5585]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5585

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should abuse Time for it is Allah Who is the Time, and none of you should call 'Inab (grape) as al-karm, for karm is a Muslim person.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5586]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5586

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not use the word karm (for wine) for worthy of respect is the heart of a believer.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5587]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5587

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not name grape as karm, for worthy of respect is a Muslim.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5588]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5588

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should use the word al-harin (for grape) for the heart of a believer is karm (worthy of respect).


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5589]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5589

Abu Huraira reported from Allah's Messenger (may peace be upon him) various ahadith, one of which is this that he said: None of you should use the word al-karm for 'Inab, for karm (worthy of respect) is a Muslim person.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5590]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5590

'Alqama b. Wa'il reported, from his father, Allah's Apostle (may peace be upon him) having said: Do not say al-karm (for the word vine) but say al-habala (that is grape). This hadith has been reported by Alqama b. Wa'il on the authority of his father with a different chain of transmitters and with a slight variation of wording.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5591]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5591

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: My bondman and my slave-girl, for all of you are the bondmen of Allah, and all your women are the slave-girls of Allah; but say: My servant, my girl, and my young man and my young girl.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5592]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5592

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say: My bondman, for all of you are the bondmen of Allah, but say: My young man, and the servant should not say: My Lord, but should say: My chief.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5593]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5593

This hadith has been reported on the authority of al-A'mash with the same chain of transmitters, and the words are that the servant should not say to his chief: My Lord, and Abu Mu'awiya made an addition:" For it is Allah, the Exalted and Glorious, Who is your Lord."


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5594]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5594

Abu Huraira reported Allah's Messenger (may peace be upon him) so many ahadith and one of them is this that Allah's Messenaer (may peace be upon him) said: None of you should say: Supply drink to your lord, feed your lord, hell) your lord in performing ablution, and none of you should say: My Lord. He should say: My chief, my patron; and none of you should say: My bondman, my slave-girl, but simply say: My boy, my girl, my servant.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5595]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5595

'A'isha reported Allah's Messenger (may peace be upon him) having said: None of you should say:" My soul has become evil," but he should say:" My soul has become remorseless." This hadith has been transmitted on the authority of Abfl Bakr with a slight variation of wording.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5596]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5596

This hadith has been narrated on the authority of Abia Mu'iwiya with the same chain of transmitters.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5597]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5597

Abu Umama b. Sahl b. Hunaif, on the authority of his father, reported Allah's Messenger (may peace be upon him) as saying: None of you should say:" My soul has become evil," but he should say:" My soul has become remorseless."


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5598]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5598

Abd Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying: There was a woman from Bani Isra'il who was short-statured and she walked in the company of two tall women with wooden sandals in her feet and a ring of gold made of plates with musk filled in them and then looked up, and musk is the best of scents; then she walked between two women and they (the people) did not recognise her, and she made a gesture with her hand like this, and Shu'ba shook his hand in order to give an indication how she shook her hand.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5599]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5599

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) made a mention of a woman of Bana Isra'il who had filled her ring with musk and musk is the most fragrant of the scents.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5600]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5600

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who is presented with a flower should not reject it, for it is light to carry and pleasant in odour.


Muslim :: The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha) :: [27.5601]

The Book Concerning the Use of Correct Words (Kitab Al-Alfaz min Al-Adab wa Ghairiha)

Muslim :: Book 27 : Hadith 5601

Nafi' reported that when Ibn Umar wanted fumigation he got it from aloeswood without mixing anything with it, or he put camphor along with aloeswood and then said: This is how Allah's Messenger (may peace be upon him) fumigated.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5602]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5602

'Amr b. Sharid reported his father as saying: One day when I rode ehind Allah's Messenger (may peace be upon him), he said (to me): Do you remember any Poetry of Umayya b. Abu Salt. I said: Yes. He said: Then go on. I recited a couplet, and he said: Go on. Then I again recited a couplet and he said: Go on. I recited one hundred couplets (of his poetry). This hadith has been reported on the authority of Sharid through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5603]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5603

'Amr b. Sharid reported on the authority of his father that Allah's Messeniger (may peace be upon him) asked him to recite poetrv, the rest of the hadith is the same, out with this addition:" He (that is Umayya b. Abu Sharid was about to become a muslim and in the hadith transmitted on the authority, of Ibn Mahdi (the words are)" He was almost a Muslim in his poetry."


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5604]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5604

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The truest word spoken by an Arab (pre-Islamic) in poetry is this verse of Labid:" Behold! apart from Allah everything is vain."


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5605]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5605

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The truest word uttered by a poet is this verse of Labid:" Behold! apart from Allah everything is vain," and Umayya b. Abu Salt was almost a Muslim.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5606]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5606

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The truest verse recited by a poet is: Beliold! apart from Allah everything is vain," and Ibn Abu Salt was almost a Muslim.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5607]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5607

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The truest couplet recited by a poet is:" Behold! apart from Allah everything is vain," and he made no addition to it.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5608]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5608

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: The truest word which the poet stated is the word of Labid:" Behold! apart from Allah everything is vain."


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5609]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5609

Abu Huraira reported Allah's Messenger (may peace be opon him) as saying: It is better for a man's belly to be stuffld with pus which corrodes it than to stuff) one's mind with frivolous poetry. Abd Bakr has reported it with a slight variation Of wording.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5610]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5610

Sa'd reported Allah's Apostle (may peace be upon him) as saying: It is better for the belly of any one of you to be stuffed with pus rather than to stuff (one's mind) with poetry.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5611]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5611

Abu Sa`id Khudri reported: We were going with Allah's Messenger (may peace be upon him). As we reached the place (known as) Arj there met (us) a poet who had been reciting poetry. Thereupon Allah's Messanger (may peace be upon him) said: Catch the satan or detain the satan, for filling the belly of a man with pus is betting than stuffing his brain with poetry.


Muslim :: The Book of Poetry (Kitab Al-Sh`ir) :: [28.5612]

The Book of Poetry (Kitab Al-Sh`ir)

Muslim :: Book 28 : Hadith 5612

Buraida reported on the authority of his father that Allah's Apostle (may peace be upon him) said: He who played chess is like one who dyed his hand with the flesh and blood of swine.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5613]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5613

Abu Salama reported: I used to see dreams (and was so much perturbed) that I began to quiver and have temperature, but did not cover myself with a mantle. I met Abu Qatada and made a mention of that to him. He said: I heard Allali's Messenger (may peace be upon him) as saying: A good vision comes from Allah and a (bad) dream (hulm) from devil. So when one of. you sees a bad dream (hulm) which he does not like, he should spit on his left side thrice and seek refuge with Allah from its evil; then it will not harm him.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5614]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5614

This hadith has been narrated on the authority of Abu Qatada, but there is no mention of the words of Abu Salama:" I saw dreams (which perturbed me) but I did not cover myself with a mantle."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5615]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5615

This hadith has been reported on the authority of Zuhri with the same chain of transmitters, but it does not contain the words:" I felt disturbed because of that," and there is an addition of these words in the hadith transmitted on the authority of Yunus:" Then spit thrice on the left side when you get up from sleep."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5616]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5616

Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: A good vision is from Allah and a bad dream (hulm) is from the satan; so if one of you sees anything (in a dream which he dislikes, he should spit on his left side thrice and seek refuge with Allah from its evil, and then it will never harm him. Abu Salama said: I used to see dreams weighing more heavily upon me than a mountain; but since I heard this hadith I don't care for it (its burden).


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5617]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5617

Abu Salama reported Allah's Messenger (may peace be upon him) as saying: I used to see dreams, but the hadith transmitted on the authority of Laith b. Nu'man, the words of Abu Salama at the concluding part of the hadith are not mentioned. Ibn Rumh has reported in the hadith:" He (one who sleeps) should change the side on which he had been lying before."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5618]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5618

Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: The good vision are from Allah and the evil dreams are from the satan. If one sees a dream which one does not like, one should spit on one's left side and seek the refuge of Allah from the satan; it will not do one any harm, and one should not disclose it to anyone and if one sees a good vision one should feel pleased but should not disclose it to anyone but whom one loves.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5619]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5619

Abu Salama replied: I used to see (such horrible dreams) that I fell ill. I saw Abu Qatada who also said: I used to see dreams which made me sick until I heard Allah's Messenger (may peace be upon him) as saying: Good dreams are from Allah, so if any one of you sees which he likes he should not disclose it to one but whow he loves, but if he sees something which he does not like he should spit on his left side thrice and seek refuge with Allah from the mischief of the satan and its mischief (i. e. of the dream), and he should not relate it to anyone, then it would not harm him.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5620]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5620

Jabir reported Allah's Messenger (may peace be upon him) as saying: If anyone sees a dream which he does not like, lie should spit on his left side.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5621]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5621

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When the time draws near (when the Resurrection is near) a believer's dream can hardly be false. And the truest vision will be of one who is himself the most truthful in speech, for the vision of a Muslim is the forty-fifth part of Prophecy, and dreams are of three types: one good dream which is a sort of good tidings from Allah; the evil dream which causes pain is from the satan; and the third one is a suggestion of one's own mind; so if any one of you sees a dream which he does not like he should stand tip and offer prayer and he should not relate it to people, and he said: I would love to see fetters (in the dream), but I dislike wearing of necklace, for the fetters is (an indication of) one's steadfastness in religion. The narrator said: I do not know whether this is a part of the hadith or the words of Ibn Sirin.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5622]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5622

Abu Huraira reported: I love to see fetters but I hate necklace (in a dream), for fetters signifies one's steadfastness in religion, and he also reported Allah's Messenger (may peace be upon him) as saying: The vision of a believer is forty-sixth part of Prophecy.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5623]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5623

This hadith has been transmitted on the authority of Abu Huraira and the words are:" When the time draws near," the rest of the hadith is the same.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5624]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5624

Muhammad b. Sirin reported from Abu Huraira a hadith from Allah's Apostle (may peace be upon him) and he mentioned in his hadith his words:" I dislike shackles," up to the end of his statement, but he made no mention of this:" A vision is a forty-sixth part of Prophecy."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5625]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5625

Ubida b. as-Samit reported Allah's Messenger (may peace be upon him) as saying: The vision of a believer is the forty-sixth part of Prophecy.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5626]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5626

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5627]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5627

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily the vision of a believer is one of the forty-sixth part of Prophecy.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5628]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5628

Allah's Messenger (may peace; be upon him) said: The vision of a Muslim which he sees or which is shown to him, and in the hadith transmitted on the authority of Ibn Alushir (the words are):" The pious dream is the forty-sixth part of Prophecy."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5629]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5629

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The vision Qf a pious man is the forty-sixth part of Prophecy.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5630]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5630

This hadith has been narrated on the authority of Yahyi b. Abu Kathir with the same chain of transmitters.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5631]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5631

This hadith has been narrated on the authority of Abu Huiaira through another chain of transmitters.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5632]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5632

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: The pious dreams are the seventieth part of Prophecy.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5633]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5633

This hadith has been reported on tile authority of 'Ubaidullah with the same chain of transmitters.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5634]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5634

A hadith like this has been reported on the authority of Nafi' with the same chain of transmitters (and the words are):" I think Ibn 'Uniar said: The seventieth part from Prophecy."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5635]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5635

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream in fact saw me, for the satan does not appear in my form.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5636]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5636

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream would soon see me in the state of wakefulness, or as if he saw me in a state of wakefulness, for the satan does not appear in my form.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5637]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5637

Abu Qatada reported Allah's Messenger (may peace be upon him) as saying: He who saw me in dream in fact saw the truth (what is true).


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5638]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5638

Jabir reported Allah's Messenger (may peace be upon him) as saying: He who saw me in sleep in fact saw me, for it is not possible for the satan to appear in my form; and he also said: When any one of you sees a hulm he should not inform anyone, for it is a sort of vain sport of devil in the state of sleep.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5639]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5639

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who saw me in a dream in fact saw me, for the satan cannot assume my form.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5640]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5640

Jabir reported Allah's Messenger (may peace be upon him) as saying: There came to him (the Holy Prophet) a desert Arab and said: I saw in a dream that I had been beheaded and I had been following it (the severed head). Allah's Apostle (may peace be upon him) reprimanded him saying: Do not inform about the vain sporting of devil with you during the night.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5641]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5641

Jabir reported that there came to Allah's Apostle (may peace be upon him) a desert Arab and said: Allah's Messenger, I saw in the state of steep as if my head had been cut off and I had been moving on haltingly after it. Thereupon Allah's Messenger (may peace be upon him) said to that desert Arab: Do not narrate to the people the vain sporting of satan with you in your sleep and (the narrator) also said: I heard Allah's Messenger (may peace be upon him) in his subsequent address: None amongst you should narrate the vain sporting of devil with him in the dream.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5642]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5642

Jabir reported that a'person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, I have seen in the state of sleep as if my head had been cut off. Thereupon Allah's Apostle (may peace be upon him) laughed and said: When the satan plays with any one of you in the state of steep, do not inention it to the people; and in the hadith transmitted by Abu Bakr (the words are):" If one of you is played with, and he did not make any mention of the word:" Satan."


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5643]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5643

It is reported eithfr on the authority of Ibn Abbas or on the authority of Abu Huraira that a person came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I saw while I was sleeping during the night (this vision) that there was a canopy from which butter and honey were trickling and I also saw people collecting them in the palms of their hands, some more, some less, and I also saw a rope connecting the earth with the sky and I saw you catching hold of it and rising towards the heaven; then another person after you catching hold of it and rising towards (Heaven) ; then another person catching hold of it, but it was broken while it was rejoined for him and he also climbed up. Abu Bakr said: Allah's Messenger, may my father be sacrificed for you, by Allah, allow me to interpret it. Allah's Messenger (may peace be upon him) sail: Well, give its interpretation. Thereupon Abu Bakr said: The canopy signifies the canopy of Islam and that what it trickles out of it in the form of butter and honey is the Holy Qur'an and its sweetness and softness and what the people get hold of it in their palms implies major portion of the Qur'an or the small portion; and so far as the rope joining the sky with the earth is concerned, it is the Truth by which you stood (in the worldly life) and by which Allah would raise you (to Heaven). Then the person after you would take hold of it and he would also climb up with the help of it. Then another person would take hold of it and climb up with the help of it. Then another person would take hold of it and it would be broken; then it would be rejoined for him and he would climb up with the help of it. Allah's Messenger, may my father be taken as a ransom for you, tell me whether I have interpreted it currectly or I have made an error. Allah's Messenger (may peace be upon him) said: You have interpreted a part of it correctly and you have erred in interpreting a part of it. Thereupon he said: Allah's Messenger, by Allah, tell me that part where I have committed an error. Thereupon he said: Don't take oath.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5644]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5644

Ibn 'Abbas reported that there came to Allah's Apostle (may peace be upon him) a person as he was returning from Uhud and lie 'said: Allah's Messenger, I saw in sleep during the night a canopy trickling butter and honey; the rest of the hadith is the same.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5645]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5645

It is reported either on the authority of Ibn 'Abbas or on that of Abu Huraira that a person came to Allah's Messenger (may peace be upon him) and said: Verily I saw during the night a canopy; the rest of the hadith is the same.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5646]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5646

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) used to say to his Companions: He who amongst you sees a vision should narrate it and I would interpret it for him, and a person came and said: Allah's Messenger, I saw a canopy. The rest of the hadith is the same.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5647]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5647

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: I saw during the night that which a person sees during the sleep as if we are in the house of 'Uqba b. Rafi' that there was brought to us the fresh dates of Ibn Tab. I interpreted it as the sublimity for us in the world and good ending in the Hereafter and that our religion is good.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5648]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5648

Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: I saw in a dream that I was using miswak and the two persons contended to get it from me, the one being older than the other one. I gave the miswak to the younger one. It was said to me to give that to the older one and I gave it to the older one.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5649]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5649

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: I saw in sleep that I was about to migrate from Mecca to a land abounding in palmtrees and I guessed that it would be Yamama or Hajar, but it was the city of Yathrib (the old name of Medina), and I saw in this dream of mine that I was brandishing a sword and its upper end was broken and this is what fell (in the form of misfortune to the believers on the Day of Ubud). I brandished (the sword) for the second time and it became all right and this is what came to be true when Allah granted us victory and solidarity of the believers. And I saw therein cows also and Allah is the Doer of good. These meant the group from amongst the believers on the Day of Ubud and the goodness which Allah brought after that and the reward of attestation of his Truth which Allah brought to us after the Day of Badr.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5650]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5650

Ibn Abbas reported that Musailima al-Kadhdhab (the greater liar) (who claimed prophethood after the death of the Holy Prophet) came during the lifetime of Allah's Apostle (may peace be upon him) to Medina and said: If Muhammad assigns his caliphate to me after him I would follow, and there came along with him a large body of persons of his tribe and there came to him Allah's Apostle (may peace be upon him) along with Thabit b. Qais b. Shammas and the Prophet of Allah (may peace be upon him) had a piece of wood in his hand until he came in front of Musailima in the company of his companions and said: If you were to ask even this (wood), I would never give it to you. I am not going to do anything against the will of God in your case, and if you turn away (from what I say) Allah will destroy you. And I find you in the same state which I was shown (in the dream) and here is Thabit and he would answer you on my behalf. He (the Holy Prophet) then went back. Ibn 'Abbas said: I asked the (meanings of the) words of Allah's Apostle (may peace be upon him):" You are the same what I was made to see about you in my dream." and Abu Huraira reported that Allah's Messenger. (may peace be upon him) said: While I was sleeping I saw in my hands two gold bangles. This had a disturbing effect upon me and I was given a suggestion in the sleep that I should blow over them, so I blew over them and they were no more. And I interpreted these (two bangles) as the two great liars who would appear after me and the one amongst them was 'Anasi the inhabitant of San'a' and the other one Musailima the inhabitant of Yamama.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5651]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5651

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was sleeping, the treasures of the earth were presented to me and I was made to wear in my hands two gold bangles. I felt a sort of burden upon me and I was disturbed and it was suggested to me that I should blow over them, so I blew and both of them disappeared. I interpreted them as two great liars who would appear at any time, one is the inhabitant of Sana' and the other is that of Yamama.


Muslim :: The Book of Vision (Kitab Al-Ruya) :: [29.5652]

The Book of Vision (Kitab Al-Ruya)

Muslim :: Book 29 : Hadith 5652

Samura b. Jundab reported that when Allah's Messenger (may peace be upon him) had performed his dawn prayer he turned his face towards them (that is towards his Companions) and said: Did any one of you see any vision last night?


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5653]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5653

Wathila b. al-Asqa' reported: I heard Allah's Messenger (may peace be upon him) as saying: Verily Allah granted eminence to Kinana from amongst the descendants of Isma'il and he granted eminence to the Quraish amongst Kinana and he granted eminence to the Quraish amongst Banu Hashim and he granted me eminencece from the tribe of Banu Hashim.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5654]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5654

Jabir b. Samura reported Allah's Messenger (may peace be upon him) as saying: I recognise the stone in Mecca which used to pay me salutations before my advent as a Prophet and I recognise that even now.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5655]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5655

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I shall be pre-eminent arriongst the descendants of Adam on the Day of Resurrection and I will be the first intercessor and the first whose intercession will be accepted (by Allah).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5656]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5656

Anas reported that Allah's Apostle (may peace be upon him) called for water and he was given a vessel and the people began to perform ablution in that and I counted (the persons) and they were between fifty and eighty and I saw water which was spouting from his fingers.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5657]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5657

Anas b. Malik reported: I saw Allah's Messenger (may peace be upon him) during the time of the afternoon prayer and the people asking for water for performing ablution which they did not find. (A small quantity) of water was brought to Allah's Messenger (may peace be upon him) and he placed his hand in that vessel and com- manded people to perform ablution. I raw water spouting from his fingers and the people performing ablution until the last amongst them performed it.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5658]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5658

Anas b. Malik reported that Allah's Apostle (may peace be upon him) and his Companions were at a place known as az-Zaura' (az-Zaurd' is a place in the bazar of Medina near the mosque) that he called for a vessel containing water. He put his hand in that. And there began to spout (water) between his fingers and all the Companions performed ablution. Qatada, one of the narrators in the chain of narrators, said: Abu Hamza (the kunya of Hadrat Anas b. Malik), how many people were they? He said: They were about three hundred.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5659]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5659

Anas reported Allah's Apostle (may peace be upon him) was at az-Zaura' and a vessel containing water was brought to him in which his finger could not be completely dipped or completely covered; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5660]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5660

Jabir reported that Umm Malik used to send clarified butter in a small skin to the Apostle of Allah (may peace be upon him). Her sons would come to her and ask for seasoning when they had nothing with them (in the form of condiments) and she would go to that (skin) in which she offered (clarified butter) to Allah's Apostle (may peace be upon him), and she would find in that clarified butter and it kept providing her with seasoning for her household until she had (completely) squeezed it. She came to Allah's Apostle (may peace be upon him) and (informed him about it). Thereupon, he (the Holy Prophet) said: Did you squeeze it? She said: Yes. Thereupon he said: If you had left it in that very state, it would have kept on provid- ing you (the clarified butter) on end.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5661]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5661

Jabir reported that a person came to Allah's Apostle (may peace be upon him) and asked for food. And he gave him half a wasq of barley, and the person and his wife and their guests kept on making use of it (as a food) until he weighed it (in order to find out the actual quantity, and it was no more). He came to Allah's Apostle (may peace be upon him) (and informed him about it). He said: Had you not weighed it, you would be eating out of it and it would have remained intact for you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5662]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5662

Mu'adh b. Jabal reported that he went along with Allah's Apostle (may peace be upon him) in the expedition of Tabuk and he (the Holy Prophet) combined the prayers. He offered the noon and afternoon prayers together and the sunset and night prayers together and on the other day he deferred the prayers; he then came out and offered the noon and afternoon prayers together. He then went in and (later on) came out and then after that offered the sunset and night prayers together and then said: God willing, you would reach by tomorrow the fountain of Tabuk and you should not come to that until it is dawn, and he who amongst you happens to go there should not touch its water until I come. We came to that and two persons (amongst) us reached that fountain ahead of us. It was a thin flow of water like the shoelace. Allah's Messenger (may peace be upon him) asked them whether they had touched the water. They said: Yes. Allah's Apostle (may peace be upon him) scolded them, and he said to them what he had to say by the will of God. The people then took water of the fountain in their palms until it became somewhat significant and Allah's Messenger (may peace be upon him) washed his hands and his face too in it, and then, took it again in that (fountain) and there gushed forth abundant water from that fountain, until all the people drank to their fill. He then said: Mu'adh, it is hoped that if you live long you would see its water irrigating well the gardens.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5663]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5663

Abu Humaid as-Sa'idi reported: We went out with Allah's Messenger (may peace be upon him) on the expedition to Tabuk and we came to a wadi where there was a garden belonging to a woman. Allah's Apostle (may peace be upon him) said. Make an assessment (of the price of its fruit). And Allah's Messenger (may peace be upon him) also made an assessment and it was ten wasqs. He asked that lady (to calculate the amount) until they would, God willing, come back to her. So we proceeded on until we came to Tabuk and Allah's Messenger (may peace be upon him) said: The violent storm will overtake you during the night, so none amongst you should stand up and he who has a camel with him should hobble it firmly. A violent storm blew and a person who had stood up was carried away by the storm and thrown between the mountains of Tayy. Then the messenger of the son of al 'Alma', the ruler of Aila, came to Allah's Messenger (may peace be upon him) with a letter and a gift of a white mule. Allah's Messenger (may peace be upon him) wrote him (the reply) and presented him a cloak. We came back until we halted in the Wadi al-Qura. Allah's Messenger (may peace be upon him) asked that lady about her garden and the price of the fruits in that. She said: Ten wasqs. Thereupon Allah's Messenger (may peace be upon him) said: I am going to depart, and he who amongst you wishes may depart with me but he who wants to stay may stay. We resumed the journey until we came to the outskirts of Medina. (It was at this time) that Allah's Messenger (may peace be upon him) said: This is Taba, this is Uhud, that is a mountain which loves us and we love it, and then said: The best amongst the houses of the Ansar is the house of Bani Najjar. Then the house of Bani Abd al-Ashhal, then the house of Bani Abd al-Harith b. Khazraj, then the house of Bani Sa'ida, and there is goodness in all the houses of the Ansar. Said b. Ubada came to us and Abu Usaid said to him: Did you not see that Allah's Messenger (may peace be upon him) has declared the houses of the Ansar good and he has kept us at the end. Said met Allah's Messenger (may peace be upon him) and said: Allah's Messenger, you have declared the house of the Ansar as good and have kept us at the end, whereupon he said: Is it not enough for you that you have been counted amongst the good.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5664]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5664

This hadith has been narrated on the authority of 'Amr b. Yahya with the same chain of transmitters up to the words: There is good in all the houses of the Ansar, and there is no mention of the subsequent event pertaining to Sa'd b. 'Ubada.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5665]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5665

Jabir b. Abdullah reported: We went along with Allah's Messenger (may peace be upon him) on an expedition towards Najd and Allah's Messenger (may peace be upon him) found us in a valley abounding in thorny trees. Allah's Messenger (may peace be upon him) stayed for rest under a tree and he suspended his sword by one of its branches under which he was taking rest. The persons scattered in the valley and they also began to take rest under the shade of trees, and Allah's Messenger (may peace be upon him) said: A person came to me while I was asleep and he took hold of the sword. I woke up and found him standing upon my head and I had hardly become alert (and saw) that the sword was in his hand. And he said: Who can protect you from me? I said: Allah. He again said: Who can protect you from me? I said: Allah. He put his sword in the sheath (and you can see) this man sitting here. Allah's Messenger (may peace be upon him) did not in any way touch him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5666]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5666

Jabir b. 'Abdullah al-Ansiri, who was one amongst the Companions of Allah's Apostle (may peace be upon him), reported that he went on an expedition along with Allah's Messenger (may peace be upon him) towards Najd and Allah's Messenger (may peace be upon him) stayed there, and when Allah's Messenger (may peace be upon him) came back he also came back along with him. They, for one day, stayed for rest; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5667]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5667

Jabir b. 'Abdullah reported: We went along with Allah's Messenger (may peace be upon him) and as we reached the place Dhat-ur-Riqa'; the rest of the hadith is the same, but there is no mention of the word that Allah's Messenger (may peace be upon him) did not harm him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5668]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5668

Abu Musa reported Allah's Apostle (may peace be upon him) as saying: The similitude of that guidance and knowledge with which Allah, the Exalted and Glorious, has sent me is that of rain falling upon the earth. There is a good piece of land which receives the rainfall (eagerly) and as a result of it there is grown in it herbage and grass abundantly. Then there is a land hard and barren which retains water and the people derive benefit from it and they drink it and make the animals drink. Then there is another land which is barren. Neither water is retained in it, nor is the grass grown in it. And that is the similitude of the first one who develops the understanding of the religion of Allah and it becomes a source of benefit to him with which Allah sent me. (The second one is that) who acquires the knowledge of religion and imparts it to others. (Then the other type is) one who does not pay attention to (the revealed knowledge) and thus does not accept guidance of Allah with which I have been sent.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5669]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5669

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and of that with which Allah sent me is that of a person who came to us and said: O people, I have seen an army with my eyes and I am a plain warner (and issue you warning) that you should immediately manage to find an escape. A group of people from amongst them paying heed (to his warning) fled to a place of protection and a group amongst them belied him and the morning overtook them in their houses and the army attacked them and killed them and they were routed. And that is the similitude of the one who obeyed me, followed with which I had been sent and the similitude of the other is of one who disobeyed and belied me and the Truth with which I have been sent.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5670]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5670

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of my Umma is that of a person who lit fire and there began to fall into it insects and moths. And I am there to hold you back, but you plunge into it.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5671]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5671

Hammam b. Munabbih reported: Abu Huraira reported us some ahadith from Allah's Messenger (may peace be upon him) amongst many, (and) one is this that Allah's Messenger (may peace be upon him) said: A person lit fire and when the atmosphere was aglow, moths and insects began to fall into the fire, but I am there to hold them back, but they are plunging into it despite my efforts, and he further added: That is your example and mine. I am there to hold you back from fire and to save you from it, but you are plunging into it despite my efforts.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5672]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5672

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying. My example and your example is that of a person who lit the fire and insects and moths began to fall in it and he would be making efforts to take them out, and I am going to hold you back from fire, but you are slipping from my hand.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5673]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5673

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles (before me) is that of a person who constructed a building and he built it fine and well and the people went round it saying: Never have we seen a building more imposing than this. but for one brick, and I am that brick (with which you give the finishing touch to the building).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5674]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5674

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles before me is that of a person who built a house quite imposing and beautiful and he made it complete but for one brick in one of its corners. People began to walk round it, and the building pleased them and they would say: But for this brick your building would have been perfect. Muhammad (may peace be upon him) said: And I am that final brick.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5675]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5675

Abu Hurairh reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles before me is that of a person who built a house quite imposing and beautiful, but for one brick in one of its corners. People would go round it, appreciating the building, but saying: Why has the brick not been fixed here? He said: I am that brick and I am the last of the Apostles.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5676]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5676

Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5677]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5677

Jabir reported Allah's Messenger (may peace be upon him) as saying: The similitude of mine and that of the Apostles is like that of a person who built a house and he completed it and made it perfect but for the space of a brick. People entered therein and they were surprised at it and said: Had there been a brick (it would have been complete in all respects). Allah's Messenger (may peace be upon him) said: I am that place where the brick (completing the building is to be placed), and I have come to finalise the chain of Apostles.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5678]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5678

This hadith has been narrated through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5679]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5679

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: When Allah, the Exalted and Glorious, intends to show mercy to an Umma from amongst His servants He calls back His Apostle to his eternal home and makes him a harbinger and recompense in the world to come; and when He intends to cause destruction to an Umma, He punishes it while its Apostle is alive and He destroys it as he (the Apostle) witnesses it and he cools his eyes by destruction as they had belied him and disobeyed his command.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5680]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5680

Jundab reported: I heard Allah's Messenger (may peace be upon him) as saying: I shall be there at the Cistern before you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5681]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5681

This hadith has been narrated on the authority of Jundab through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5682]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5682

Sahl (b. Sa'd) reported: I heard Allah's Apostle (may peace be upon him) as saying: I shall go to the Cistern before you and he who comes would drink and he who drinks would never feel thirsty, and there would come to me people whom I would know and who would know me. Then there would be intervention between me and them. Abu Hazim said that Nu'man b. Abu 'Ayyash heard it and I narrated to them this hadith, and said: Is it this that you heard Sahl saying? He said: Yes, and I bear witness to the fact that I heard it from Abu Sa'id Khudri also, but he made this addition that he (the Holy Prophet) would say: They are my followers, and it would be said to him: You do not know what they did after you and I will say to them: Woe to him who changes (his religion) after me.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5683]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5683

This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5684]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5684

Abdullah b. 'Amr al-'As, reported Allah's Messenger (may peace be upon him) as saying: My Cistern (is as wide and broad that it requires) a motith's journey (to go round it) all, and its sides are equal and its water is whiter than silver, and its odour is more fragrant than the fragrance of musk, and its jugs (placed round it) are like stars in the sky; and he who would drink from it would never feel thirsty after that. Asma', daughter of Abu Bakr said: Allah's Messenger (may peace be upon him) said: I would be on the Cistern and so that I would be seeing those who would be coming to me from you, but some people would be detained (before reaching me). I would say: My Lord, they are my followers and belong to my Umma, and it would be said to me: Do you know what they did after you? By Allah, they did not do good after you, and they turned back upon their heels. He (the narrator) said: lbn Abu Mulaika used to say (in supplication): O Allah, I seek refuge with Thee that we should turn back upon our heels or put to any trial about our religion.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5685]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5685

'A'isha reported: I heard Allah's Messenger (may peace be upon him) say in the company of his Companions: I would be on the Cistern waiting for those who would be coming to me from amongst you. By Allah, some persons would be prevented from coming to me, and I would say: My Lord, they are my followers and people of my Umma. And He would say,: You don't know what they did after you; they had been constantly turning back on their heels (from their religion).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5686]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5686

Umm Salama, the wife of Allah's Apostle (may peace be upon him), said I used to hear from people making a mention of the Cistern, but I did not hear about it from Allah's Messenger (may peace be upon him). One day while a girl was combing me I heard Allah's Messenger (may peace be upon him) say:" O people." I said to that girl: Keep away from me. She said: He (the Holy Prophet) has addressed the men only and he has not invited the attention of the women. I said: I am amongst the people also (and have thus every right to listen to the things pertaining to religion). Allah's Messenger (may peace be upon him) said: I shall be your harbinger on the Cistern; therefore, be cautious lest one of you should come (to me) and may be driven away like a stray camel. I would ask the reasons, and it would be said to me: You don't know what innovations they made after you. And I would then also say: Be away.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5687]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5687

Umm Salama reported that she heard Allah's Apostle (may peace be upon him) saying this as he was sitting on the pulpit and she was getting her hair combed. (He uttered these words):" O people." And she said to one who was combing: Leave my head; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5688]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5688

Uqba b. 'Amir reported that Allah's Messenger (may peace be upon him) one day went out and he offered prayer over the martyrs of Uhud just as prayer is offered over the dead. He then came back and sat on pulpit and said: I shall be present there (at the Cistern) before you. I shall be your witness and, by Allah, I perceive as if I am seeing with my own eyes my Cistern at this very state and I have been given the keys of the treasures of the earth or the keys of the earth and, by Allah, I am not afraid concerning you that you would associate anything (with Allah after me), but I am afraid that you would be vying with one another (for the possession of) the treasures of the earth.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5689]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5689

Uqba b. 'Amir reported Allah's Messenger (may peace be upon him) as saying: Allah's Messenger offered prayer over those who had fallen matyrs at Uhud. He then climbed the pulpit as if someone is saying good-bye to the living and the dead, and then said: I shall be there as your predecesor on the Cistern before you, and it is as wide as the distance between Aila and Juhfa (Aila is at the top of the gulf of 'Aqaba). I am not afraid that you would associate anything with Allah after me, but I am afraid that you may be (allured) by the world and (vie) with one another (in possessing material wealth) and begin killing one another, and you would be destroyed as were destroyed those who had gone before you. 'Uqba said that that was the last occasion that he saw Allah's Massenger on the pulpit.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5690]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5690

'Abdullah reported Allah's Messenger (may peace be upon him) as saying; I shall be there at the Cistern before you, and I shall have to contend for some people, but I shall have to yield. I would be saying: My Lord, they are my friends, they are my friends, and it would be said: You don't know what innovations they made after you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5691]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5691

The hadith has been narrated on the authority ot al-A'mash with the same chain of transmitters but no mention is made of:" They are my companions; they are my companions."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5692]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5692

This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5693]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5693

This hadith has been narrated on the authority of Hudhaifa through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5694]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5694

Haritha reported that he heard Allah's Messenger (may peace be upon him) as saying: His Cistern would be as extensive as the distance between San'a' and Medina. Mustaurid (one of the narrators) said: Did you not hear anything about the utensils? Thereupon he said. No. Mustaurid said: You would find that the utensils would be like stars.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5695]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5695

Haritha b. Wahb al-Khuza'i reported Allah's Messeiiger's (may peace be upon him) words concerning the Cistern like it, but he made no mention of the words of Mustaurid.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5696]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5696

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: There is before you a Cistern and the distance between its two sides is as it is between Jarba' and Adhruh.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5697]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5697

This hadith has been transmitted on the authority of Ibn 'Umar and the words are: That he said there would be before you a Cistern extending from jarba' and Adhruh and the same has been transmitted on the authority of Ibn Muthanna and the wording is:" My Cistern."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5698]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5698

A hadith like this has been transmitted on the authority, of 'Ubaidullah with this addition: Ubaidullah was asked (about these two names, i. e. Jarba' and Adhruh). He said: These are the two towns of Syria and there is between them the distance which can be covered in three nights, and the hadith transmitted on the authority of Ibn Bishr (the words are)." Three days."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5699]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5699

A hadith like this has been narrated on the authority of Ibn Umar through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5700]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5700

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: There would be before you a Cistern (as extensive) as there is the distance between Jarba' and Adhruh and there would be jugs like stars in the sky; he who would come to that and drink from it would never feel thirsty after that.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5701]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5701

Abu Dharr said: Allah's Messenger, what about the vessels of that Cistern? He said: By Him in Whose Hand is the life of Muhammad, the vessels would outnumber the stars in the sky and its planets shining on a dark cloudless night. These would be the vessels of Paradise. He who drinks out of it (the Cistern) would never feel thirsty. There would flow in it two spouts from Paradise and he who would drink out of it would not feel thirsty; and the distance between its (two corners) is that between 'Amman and Aila, and its water is whiter than milk and sweeter than honey.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5702]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5702

Thauban reported Allah's Apostle (may peace be upon him) as saying: I would be pushing back from my Cistern the crowd of people. I would strike away from it (the Cistern) with my staff the people of Yemen until the water (of the Haud) would spout forth upon them. He was asked about its breadth. He said: From this place of mine to 'Amman, and he was asked about the drink and he said: It is whiter than milk and sweeter than honey. There would spout into it two streamlets having their sources in Paradise. the one is from gold and the other is from silver. This hadith has been narrated on the authority of Hisham with the same chain of transmitters and the words are:" I would be on the Day of Resurrection near the bank of the Cistern."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5703]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5703

Thaubin reported this hadith pertaining to the Cistern. Muhammad b. Bashshar said: I said to Yahya b. Hammad: This is the hadith that I heard from Abu 'Awana and he said: I also heard it from Shu'ba. I said: Narrate that to me and he narrated that to me.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5704]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5704

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: I will drive away from my Cistern people just as the stray camels are driven away. This hadith has been narrated on the authority of Abu Huraira through another chain ot transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5705]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5705

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: My Cistern would be as extensive as the distance between Aila and San'a, of Yemen, and there would be in it jugs like stars in the sky.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5706]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5706

Anas b. Malik reported Allah's Apostle (may peace be upon him) as saying: Some persons from amongst my associates would turn to my Cistern; when I would see them and they would be presented to me, they would be detained in the way while coming to me. I would say: My Lord, they are my companions, they are my companions, and it would be said to me: You don't know what innovations they made after you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5707]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5707

Anas reported a hadith like this from Allah's Apostle (may peace be upon him) and he made this addition:" The vessels would be as numerous as the number of stars.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5708]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5708

Anas b. Milik reported Allah's Messenger (may peace be upon him) as saying: There would be such a vast distance between the sides of my Cistern as it is between Sana' and Medina.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5709]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5709

Anas reported this hadith with this change that there was some doubt between (places mentioned) and there is a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5710]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5710

Anas reported Allah's Apostle (may peace be upon him) as saying: You would be shown in it jugs of gold and silver (as numerous) as the number of stars in the sky. This hadith has been transmitted on the authority of Anas b. Malik with this addition:" More numerous than stars in the sky."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5711]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5711

Jabir b. Samura reported Allah's Messenger (may peace be upon him) as saying: Behold, I shall be present ahead of you on the Cistern, and the distance between its different sides would be like that between Sana' and Aila, and its jugs would be like stars in the sky.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5712]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5712

'Amir b. Sa'd b. Abu Waqqas reported: I wrote (a letter) to Jabir b. Samura (and it was sent) through my servant Nafi' asking him to inform me about something (pertaining to the Haud Kauthar). He wrote to me: I heard him (the Holy Prophet) say: I shall be there ahead of you at the Haud Kauthar.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5713]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5713

Sa'd reported that on the Day of Ubud I saw on the right side of Allah's Messenger (may peace be upon him) and on his left side two persons dressed in white clothes and whom I did not see before nor after that, and they were Gabriel and Michael (Allah be pleased with both of them).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5714]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5714

Sa'd b. Abu Waqqas reported: I saw on the right side of Allah's Messenger (may peace be upon him) and on his left side two persons with white clothes on the Day of Uhtid fighting a desperate fight, and I saw them neither before nor after that.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5715]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5715

Anas b. Malik reported that Allah's Messenger (may peace be upon him) was the sublimest among people (in character) and the most generous amongst them and he was the bravest of men. One night the people of Medina felt disturbed and set forth in the direction of a sound when Allah's Messenger (may peace be upon him) met them on his way back as he had gone towards that sound ahead of them. He was on the horse of Abu Talha which had no saddle over it, and a sword was slung round his neck, and he was saying: There was nothing to be afraid of, and he also said: We found it (this horse) like a torrent of water (indicating its swift-footedness), whereas the horse had been slow before that time.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5716]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5716

Anas reported that there was consternation in Medina. The Messenger of Allah (may peace be upon him) borrowed the horse from Abu Talha which was called Mandub. He rode it and said: We have found no reason for consternation, and we have found it to be (as quick as a torrent) of water.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5717]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5717

This hadith has been transmitted on the authority of Anas with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5718]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5718

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) was the most generous of people in charity, but he was generous to the utmost in the month of Ramadan. Gabriel (peace be upon him) would meet him every year during the month of Ramadin until it ended, and Allah's Messenger (may peace be upon him) recited to him the Qur'an; and when Gabriel met him Allah's Messenger (may peace be upon him) was most generous in giving charity like the blowing wind.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5719]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5719

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5720]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5720

Anas b. Malik reported: I served the Messenger of Allah (may peace be upon him) for ten years, and, by Allah, he never said to me any harsh word, and he never said to me about a thing as to why I had done that and as to why I had not done that. Abu Rabi' has made this addition (in this narration):" The work which a servant should do." There is no mention of his words" By Allah".


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5721]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5721

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5722]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5722

Anas reported: When Allah's Messenger (may peace be upon him) came to Medina, Abla Talha took hold of my hand and brought me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, Anas is a prudent young boy, and he will serve you. He (Anas) said: I served him in journey and at home, but, by Allah, he never asked me about a thing which I did as to why I did so, nor about a thing which I did not do as to why I had not done that.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5723]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5723

Anas reported Allah's Messenger (may peace be upon him) as saying: I served the Messenger of Allah (may peace be upon him) for nine years, and I do not know (of any instance) when he said to me: Why you have done this and that, and he never found fault with me in anything.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5724]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5724

Anas reported that Allah's Messenger (may peace be upon him) had the best disposition amongst people. He sent me on an errand one day, and I said: By Allah, I would not go. I had, however, this idea in my mind that I would do as Allah's Apostle (may peace be upon him) had commanded me to do. I went out until I happened to come across children who had been playing in the street. In the meanwhile, Allah's Messenger (may peace be upon him) came there and he caught me by the back of my neck from behind me. As I looked towards him I found him smiling and he said: Unais, did you go where I commanded you to go? I said: Allah's Messenger, yes, I am going. Anas further said: I served him for nine years but I know not that he ever said to me about a thing which I had done why I did that, or about a thing I had left as to why I had not done that.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5725]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5725

Anas b. Malik reported that Allah's Messenger (may peace be upon him) was the best amongst people in disposition and behaviour.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5726]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5726

Jabir b. 'Abdullah reported: It never happened that Allah's Messenger (may peace be upon him) was asked for anything and he said: No.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5727]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5727

This hadith has been narrated on the authority of Jabir b. 'Abdullah through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5728]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5728

Musa b. Anas reported on the authority of his father: It never happened that Allah's Messenger (may peace be upon him) was asked anything for the sake of Islam and he did not give that. There came to him a person and he gave him a large flock (of sheep and goats) and he went back to his people and said: My people, embrace Islam, for Muhammad gives so much charity as if he has no fear of want.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5729]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5729

Anas 'b. Malik reported that a person requested Allah's Apostle (may peace be upon him) to give him a very large flock and he gave that to him. He came to his tribe and said: O people, embrace Islam. By Allah, Muhammad donates so much as if he did not fear want. Anas said that the person embraced Islam for the sake of the world but later he became Muslim until Islam became dearer to him than the world and what it contains.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5730]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5730

Ibn Shihab reported that Allah's Messenger (may peace be upon him) went on the expedition of Victory, i. e. the Victory of Mecca, and then he went out along with the Muslims and they fought at Hunain, and Allah granted victory to his religion and to the Muslims, and Allah's Messenger (may peace be upon him) gave one hundred camels to Safwan b. Umayya. He again gave him one hundred camels, and then again gave him one hundred camels. Sa'id b. Musayyib said that Safwan told him: (By Allah) Allah's Messenger (may peace be upon him) gave me what he gave me (and my state of mind at that time was) that he was the most detested person amongst people in my eyes. But he continued giving to me until now he is the dearest of people to me.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5731]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5731

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: In case we get wealth from Bahrain, I would give you so much and so much; he made an indication of it with both his hands. Allah's Apostle (may peace be upon him) died before wealth from Bahrain came, and it fell to the lot of Abu Bakr after him. He commanded the announcer to make announcement to the effect that he to whom Allah's Apostle (may peace be upon him) had held out promise or owed any debt should come (to him). I came and said: Allah's Apostle (may peace be upon him) had said to me: In case there comes to us the wealth of Bahrain I shall give you so much, and so much. Abu Bakr took a handful (of the coins) and gave that to me once and asked me to count them I counted them as five hundred dinars and he said: Here is double of this for you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5732]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5732

Jabir b. 'Abdullah reported: When Allah's Apostle (may peace be upon him) died, there came to Abfi Bakr wealth from al-'Ala' b. al-Hadrami. Abu Bakr said: He to whom Allah's Apostle (may peace be upon him) owed any debt or held out any promise should come to us; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5733]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5733

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: A child was born into me this night and I named him after the name of my father Ibrihim. He then sent him to Umm Saif, the wife of a blacksmith who was called Abu Saif. He (the Holy Prophet) went to him and I followed him until we reached Abu Saif and he was blowing fire with the help of blacksmith's bellows and the house was filled with smoke. I hastened my step and went ahead of Allah's Messenger (may peace be upon him) and said: Abu Saif, stop it, as there comes Allah's Messenger (may peace he upon him). He stopped and Allah's Apostle (may peace be upon him) called for the child. He embraced him and said what Allah had desired. Anas said: I saw that the boy breathed his last in the presence of Allah's Messenger (may peace be upon him). The eyes of Allah's Messenger (may peace be upon him) shed tears and he said: Ibrahim, our eyes shed tears and our hearts are filled with grief, but we do not say anything except that by which Allah is pleased. O Ibrahim, we are grieved for you.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5734]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5734

Anas b. Malik reported: I have never seen anyone more kind to one's family than Allah's Messenger (may peace be upon him), and Ibrahim was sent to the suburb of Medina for suckling. He used to go there and we accompanied him. He entered the house, and it was filled with smoke as his foster-father was a bricksmith. He took him (his son Ibrihim) and kissed him and then came back. 'Amr said that when Ibrihim died. Allah's LMessenger (may peace be upon him) said: Ibrihim is my son and he dies as a suckling babe. He has now two foster-mothers who would complete his suckling period in Paradise.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5735]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5735

'A'isha (Allah be pleased with her) reported that there came a few desert Arabs to Allah's Messenger (may peace be upon him) and said: Do you kiss your children? He said: Yes. Thereupon they said: By Allah but we do not kiss our children. Thereupon Allah's Messenger (may peace be upon him) said: Then what can I do if Allah has deprived you of mercy? Ibn Numair said: (We has deprived) your heart of mercy.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5736]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5736

Abu Huraira reported that al-Aqra' b. Habis saw Allah's Apostle (may peace be upon him) kissing Hasan. He said: I have ten children, but I have never kissed any one of them, whereupon Allah's Messenger (may peace be upon him) said: He who does not show mercy (towards his children), no mercy would be shown to him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5737]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5737

This hadith has been narrated on the authority of Jabir b. 'Abdullah through different chains of transmitters and the words are:" That the Messenger of Allah (may peace be upon him) said: He who shows no mercy to the people, Allah, the Exalted and Glorious, does not show mercy to him."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5738]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5738

This hadith has been narrated on the authority of Jabir through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5739]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5739

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) was more modest than the virgin behind the curtain (or in the apartment), and when he disliked anything, we recognised that from his face.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5740]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5740

Masruq reported: We went to Abdullah b. 'Amr when Mu'dwiya came to Kufa, and he made a mention of Allah's Messenger (may peace be upon him) and said: He was never immoderate in his talk and he never reviled others. Allah's Messenger (may peace be upon him) also said: The best amongst you are those who are best in morals. Uthman said: When he came to Kufa along with Mu'awiya... (The rest of the hadith is the same).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5741]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5741

This hadith had been narrated on the authority of al-A'mash through another chain of transmitters also.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5742]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5742

Simak b. Harb reported: I said to Jabir b. Samura: Did you have the privilege of sitting in the company of Allah's Messenger (may peace be upon him)? He said: Yes, very frequently, and added: He did not stand up (and go) from the place where he offered the dawn prayer until the sun rose, and after the rising of the sun he stood up, and they (his Companions) entered into conversation with one another and they talked of the things (that they did during the Days of Ignorance), and they laughed (on their unreasonable and ridiculous acts). Allah's Messenger (may peace be upon him) smiled only.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5743]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5743

Anas reported that Allah's Messenger (may peace be upon him) had in one of his journeys his black slave who was called Anjasha along with him. He goaded by singing the songs of camel-driver. Thereupon Allah's Messenger (may peace be upon him) said: Anjasha, drive slowly as you are driving (the mounts who are carrying) glass vessels


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5744]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5744

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5745]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5745

Anas reported that Allah's Apostle (may peace be upon him) came to his wives as the camel-driver who was called Anjasha had been, driving (the camels) on which (they were riding). Thereupon he said: Anjasha, be careful, drive slowly for you are driving the mounts who carry vessels of glass. Abu Qilaba said that Allah's Messenger (may peace be upon him) uttered words which if someone had uttered amongst you, you would have found fault with him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5746]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5746

Anas b. Malik reported that Umm Sulaim was with the wives of Allah's Apostle (may peace be upon him) and a camel-driver had been driving (the camels) oil which they were riding. Thereupon Allah's Apostle (may peace be upon him) said: Anjasha, drive slowly, for you are carrying (on the camels) vessels of glass.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5747]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5747

Anas reported that Allah's Messenger (may peace be upon him) had a camel-driver who had a very melodious voice. Allah's Messenger (may peace be upon him) said to him: Anjasha, drive slowly; do not break the vessels of glass, meaning the weak women.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5748]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5748

Anas reported this hadith through another chain of transmitters, but he made no mention of a camel-driver having a melodious voice.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5749]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5749

Anas b. Malik reported that when Allah's Messenger (may peace be upon him) had completed his dawn prayer, the servants of Medina came to him with utensils containing water, and no utensil was brought in which he did not dip his hand; and sometime they came in the cold dawn (and he did not feel reluctant in acceding to their request even in the cold weather) and dipped his hand in them.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5750]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5750

Anas reported: I saw when the Messenger of Allah (may peace be upon him) got his hair cut by the barber, his Companions came round him and they eagerly wanted that no hair should fall but in the hand of a person.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5751]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5751

Anas reported that a woman had a partial derangement in her mind, so she said. Allah's Messellaer, I want something from you. He said: Mother of so and so, see on which side of the road you would like (to stand and talk) so that I may do the needfull for you. He stood aside with her on the roadside until she got what she needed.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5752]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5752

'A'isha, the wife of Allah's Apostle (may peace be upon him), said that whenever he had to choose between two things he adopted the easier one, provided it was nor sin, but if it was any sin he was the one wio was the farthest from it of the people; and Allah's Messenger (may peace be upon him) never took revenge from anyone because of his personal grievance, unless what Allah, the Exalted and Glorious, had made inviolable had been violated.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5753]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5753

This hadith has been narrated on the authority of Ibn Shibab through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5754]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5754

'A'isha reported: Never did Allah's Messenger (may peace be upon him) make a choice between two things but adopting the easier one as compared to the difficult one, but his choice for the easier one was only in case it did not involve any sin, but if it involved sin he was the one who was the farthest from it amongst the people.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5755]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5755

This hadith has been narrated on the authority of Hisham through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5756]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5756

'A'isha reported that Allah's Messenger (may peace be upon him) never beat anyone with his hand, neither a woman nor a servant, but only, in the case when he had been fighting in the cause of Allah and he never took revenge for anything unless the things made inviolable by Allah were made violable; he then took revenge for Allah, the Exalted and Glorious.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5757]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5757

This hadith has been narrated on the authority of Hisham through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5758]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5758

Jabir b. Samura reported: I prayed along with Allah's Messenger (may peace be upon him) the first prayer. He then went to his family and I also went along with him when he met some children (on the way). He began to pat the cheeks of each one of them. He also patted my cheek and I experienced a coolness or a fragrance of his hand as if it had been brought out from the scent bag of a perfumer.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5759]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5759

Anas reported: I never smelt ambergris or musk as fragrant as the fragrance of the body of Allah's Messenger (may peace be upon him) and I never touched brocade or silk and found it as soft as the body of Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5760]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5760

Anas reported that Allah's Messenger (may peace be upon him) had a very fair complexion and (the drops) of his perspiration shone like pearls, and when he walked he walked inclining forward, and I never touched brocade and silk (and found it) as soft as the softness of the palm of Allah's Messenger (may peace be upon him) and I never smelt musk or ambergris and found its fragrance as sweet as the fragrance of Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5761]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5761

Anas b. Malik reported that Allah's Apostle (may peace be upon him) used to come to our house and there was perspiration upon his body. My mother brought a bottle and began to pour the sweat in that. When Allah's Apostle (may peace be upon him) got up he said: Umm Sulaini, what is this that you are doing? Thereupon she said: That is your sweat which we mix in our perfume and it becomes the most fragrant perfume.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5762]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5762

Anas b. Malik reported that Allah's Apostle (may peace be upon him) came to the house of Umm Sulaim and slept in her bed while she was away from her house. On the other day too he slept in her bed. She came and it was said to her: It is Allah's Apostle (may peace be upon him) who is having siesta in your house, lying in your bed. She came and found him sweating and his sweat falling on the leather cloth spread on her bed. She opened her scent-bag and began to fill the bottles with it. Allah's Apostle (may peace be upon him) was startled and woke up and said: Umm Sulaim, what are you doing? She said: Allah's Messenger, we seek blessings for our children through it. Thereupon he said: You have done something right.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5763]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5763

Umm Sulaim reported that Allah's Apostle (may peace be upon him) visited her house and (took rest) and she spread a piece of cloth for him and he had had a siesta on it. And he sweated profusely and she collected his sweat and put it in a perfume and in bottles. Allah's Apostle (may peace be upon him) said: Umm Sulaim, what is this? She said: It is your sweat, which I put in my perfume. Allah's Apostle (may peace be upon him) sweated in cold weather when revelation descended upon him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5764]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5764

'A'isha reported: When revelation descended upon Allah's Messenger (may peace be upon him) even during the cold days, his forehead perspired.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5765]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5765

'A'isha reported that Harith b. Hisham asked Allah's Apostle (may peace be upon him): How does the the wahi (inspiration) come to you? He said: At times it comes to me like the ringing of a bell and that is most severe for me and when it is over I retain that (what I had received in the form of wahi), and at times an Angel in the form of a human being comes to me (and speaks) and I retain whatever he speaks.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5766]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5766

'Ubida b. Samit reported that when wahi (inspiration) descended upon Allah's Messenger (may peace be upon him), he felt a burden on that account and the colour of his face underwent a change.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5767]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5767

'Ubida b. Samit reported that when wahi descended upon Allah's Apostle (may peace be upon him), he lowered his head and so lowered his Companions their heads, and when (this state) was over, he raised his head.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5768]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5768

Ibn Abbas reported that the People of the Book used to let their hair fall (on their foreheads) and the polytheists used to part them on their heads, and Allah's Messenger (may peace be upon him) liked to conform his behaviour to the People of the Book in matters in which he received no command (from God) ; so Allah's Messenger (may peace be upon him) let fall his hair upon his forehead, and then he began to part it after this.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5769]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5769

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5770]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5770

Al-Bara' reported that Allah's Messenger (may peace be upon him) was of medium height, having broad shoulders, with his hair hanging down on the lobes of his ears. He put on a red mantle over him, and never have I seen anyone more handsome than Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5771]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5771

Al-Bara' reported: Never did I see anyone more handsome than Allah's Apostle (may peace be upon him) in the red mantle. His hair had been hanging down on the shoulders and his shoulders were very broad, and he was neither very tall nor short-statured. Ibn Kuraib said he had hair.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5772]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5772

Al-Bara' reported that Allah's Messenger (may peace be upon him) had the most handsome face amongst men and he had the best disposition and he was neither very tall nor short-statured.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5773]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5773

Qatada reported: I asked Anas b. Malik: How was the hair of Allah's Messenger (may peace be upon him)? Thereupon he said: His hair was neither very curly nor very straight, and they hung over his shoulders and earlobes.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5774]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5774

Anas reported that the hair of Allah's Messenger (may. peace be upon him) came upon his shoulders.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5775]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5775

Anas reported that the hair of Allah's Apostle (may peace be upon him) reached half of the earlobe.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5776]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5776

Jabir b. Samura reported that Allah's Messenger (may peace be upon him) had a broad face with reddish (wide) eyes, and lean heels. Shu'ba reported: I said to Simak: What does this dali-ul-fam mean? And he said: This means broad face. I said: What does this ashkal mean? He said: Long in the slit of the eye. I said: What is this manhus-ul-aqibain? He said: It implies little flesh at the heels.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5777]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5777

Jurairi reported: I said to Abu Tufail: Did you see Allah's Messenger (may peace be upon him)? He said: Yes, he had a white handsome face. Muslim b. Hajjaj said: Abu Tufail who died in 100 Hijra was the last of the Companions of Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5778]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5778

Abu Tufail reported: I saw Allah's Messenger (may peace be upon him) and there is one amongst the people of the earth who (are living at the present time and) had seen him except me. I said to him: How did you find him? He said: He had an elegant white color, and he was of an average height.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5779]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5779

Ibn Sirin reported: Anas b. Malik was asked whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had not become old enough to have white hair. Ibn Idris said that he had a few white hair. Abu Bakr and Umar, however, dyed hair with hina' (henna).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5780]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5780

Ibn Sirin reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had not reached the stage when (he needed) dyeing (of his white hair). He had a few white hair in his beard. I said to him: Did Abu Bakr dye his hair? He said: Yes, with hina' (henna).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5781]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5781

Muhammad b. Sirin reported: I asked Anas b. Malik whether Allah's Messenger (may peace be upon him) dyed his hair. He said: He had but little white hair.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5782]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5782

Thabit reported that Anas b. Malik was asked about the dyeing (of the hair of) Allah's Apostle (may peace be upon him). Thereupon he said.: (They were so few) that if I so liked I could count their number in his head, and he further said: (That is) he did not dye. Abu Bakr, however, dyed them and so did 'Umar dye them with pure henna.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5783]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5783

Anas b. Malik did not like that a person should pick out his white hair from his head or beard, and Allah's Messenger (may peace be upon him) did not dye, and there was some whiteness in his hair at his chin, on his temples and very little on his head. This hadith has been narrated on the authority of Muthanna through the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5784]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5784

Anas (b. Malik) was asked about the old age of Allah's Apostle (may peace be upon him). He said: Allah did not blemish him with white hair.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5785]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5785

Abu Juhaifa reported: I saw Allah's Messenger (may peace be upon him) having some whiteness (in hair) at this place, and Zuhair placed one of his fingers at his chin. Juhaifa was asked how old he had been at that time. He said: I made arrows and put feathers to them (i. e. I had passed my childhood).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5786]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5786

Abu Juhaifa reported: I saw Allah's Messenger (may peace be upon him) that he had white complexion and had some white hair, and Hasan b. 'Ali resembled him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5787]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5787

This hadith has been transmitted on the authority of Abu Juhaifa with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5788]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5788

Jabir b. Samura was asked about the old age of Allah's Apostle (may peace be upon him). He said: When he oiled his head nothing was seen (as a mark of old age) and when he did not apply oil something (of the old age) became visible.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5789]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5789

Jabir b. Samura reported that there had appeared some whiteness on the front part of the head and beard of Allah's Messenger (may peace be upon him). When he applied oil, it did not become visible, but when he did not (apply) oil, it became apparent. And he had a thick beard. A person said: His face was as (bright) as the sword. Thereupon he (Jabir) said: No, it was round and like the sun and the moon. And I saw the seal near his shoulder of the size of a pigeon's egg and its color was the same as that of his body.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5790]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5790

Jabir. Samura reported: I saw the seal on his back as if it were a pigeon's egg.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5791]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5791

This hadith has been narrated on the authority of Simak with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5792]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5792

As-Sa'ib b. Yazid reported: My mother's sister took me to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, here is the son of my sister and he is ailing. He touched my head and invoked blessings upon me. He then performed ablution and I drank the water left from his ablution; then I stood behind him and I saw the seal between his shoulders.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5793]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5793

Abdullah b. Sarjis reported: I saw Allah's Apostle (may peace be upon him) and ate with him bread and meat, or he said Tharid (bread soaked in soup). I said to him: Did Allah's Apostle (may peace be upon him) seek forgiveness for you? He said: Yes, and for you, and he then recited this verse:" Ask forgiveness for thy sin and for the believing men and believing women" (xlvii. 19). I then went after him and saw the Seal of Prophethood between his shoulders on the left side of his shoulder having spots on it like moles.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5794]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5794

Anas b. Malik reported that Allah's Messenger (may peace be upon him) was neither very conspicuously tall nor short-statured, and his color was neither glaringly white nor brown; his hair was neither very curly nor very straight; Allah commissioned him (as a Prophet) when he had reached the age of forty years, and he stayed in Mecca for ten years and for ten years in Medina; Allah took him away when he had just reached the age of sixty, and there had not been twenty white hair in his head and beard.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5795]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5795

This hadith has been transmitted on the authority of Anas b. Malik with this addition that instead of the word al-Amhaq there is the word Azhar.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5796]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5796

Anas b. Malik reported that Allah's Messenger (may peace be upon him) died when he was sixty-three years old, and so was the case with Abu Bakr, and so was the case with Umar who was also sixty-three (when he died).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5797]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5797

'A'isha reported that Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-three. And a hadith like this had been transmitted on the authority of Sa'id b. Musayyib.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5798]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5798

This hadith has been narrated on the authority of Ibn Shihab through the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5799]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5799

'Amr reported: I said to 'Urwa: How long did Allah's Apostle - (may peace be upon him) stay in Mecca? He said: For ten years. I said: Ibn 'Abbas says (that he stayed in Mecca) for thirteen years.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5800]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5800

'Amr reported: I said to 'Urwa: How long did Allah's Apostle (may peace be upon him) stay in Mecca? He said: For ten years. I said: Ibn Abbas says it is some years above ten. He ('Urwa) sought forgiveness for him and said: His statement is based on the verse of a poet.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5801]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5801

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for thirteen years and he died when he had attained the age of sixty three years.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5802]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5802

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for thirteen years (after he had received revelation) and stayed in Medina for ten years, and he was sixty-three when he died.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5803]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5803

Abu Ishaq reported: I was sitting with 'Abdullah b. 'Utba and there was a discussion about the age of the Messenger of Allah (may peace be upon him). Some of the persons said: Abu Bakr was older than Allah's Messenger (may peace be upon him). 'Abdullah said: Allah's Messenger (may peace be upon him) died when he was sixty-three, and Abu Bakr died when he was sixty-three and so 'Umar fell as a martyr when he was sixty-three. A person from the people who was called 'Amir b. Sa'd reported that Jabir had said: We were sitting with Mu'awiya that there was a discussion about the age of Allah's Messenger (may peace be upon him). Thereupon Mu'awiya said: Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-three, and Abu Bakr died when he had attained the age of sixty-three, and Umar fell as a martyr when he had attained the age of sixty-three.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5804]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5804

Jabir reported that he heard Mu'awiya say in his address that Allah's Messenger (may peace be upon him) died at the age of sixty-three, so was the case with Abu Bakr and 'Umar, and I (am now) sixty-three.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5805]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5805

'Ammar, the freed slave of Banu Hashim, reported: I asked Ibn 'Abbas how old was he when death overtook the Messenger of Allah (may peace be upon him). He said: I little know that such a thing is not known to a man like you who belong to his people. He said: I asked people about it but they differed with me, and I liked to know your opinion about it. He said: Do you know counting? He said: Yes. He then said: Bear this in mind very well that he was commissioned (as a Prophet) at the age of forty, and he stayed in Mecca for fifteen years; sometime in peace and sometime in dread, and (lived) for ten years after his migration to Medina.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5806]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5806

This hadith has been narrated on the authority of Yunus with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5807]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5807

Ammar, the freed slave of Banu Hashim, reported that Ibn 'Abbas said that Allah's Messenger (may peace be upon him) died when he had attained the age of sixty-five.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5808]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5808

This hadith has been narrated on the authority of Khalid with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5809]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5809

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stayed in Mecca for fifteen years (after his advent as a Prophet) and he heard the voice of Gabriel and saw his radiance for seven years but did not see any visible form, and then received revelation for ten years, and he stayed in Medina for ten years.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5810]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5810

Jubair b. Mut'im reported on the authority of his father that he heard Allah's Messenger (may peace be upon him) as saying: I am Muhammad and I am Ahmad, and I am al-Mahi (the obliterator) by whom unbelief would be obliterated, and I am Hashir (the gatherer) at whose feet mankind will be gathered, and I am 'Aqib (the last to come) after whom there will be no Prophet.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5811]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5811

Jubair b. Mut'im reported on the authority of his father that he heard Allah's Messenger (may peace be upon him) as saying: I have many names: I am Muhammad, I am Ahmad, I am al-Mahi through whom Allah obliterates unbelief, and I am Hashir (the gatherer) at whose feet people will be gathered, and I am 'Aqib (after whom there would be none), and Allah has named him as compassionate and merciful.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5812]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5812

This hadith has been transmitted on the authority of Ma'mar (and the words are): I said to Zuhri: What does (the word) al-'Aqib imply? He said: One after whom there is no Prophet, and in the hadith transmitted on the authority of Ma'mar and 'Uqail there is a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5813]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5813

Abu Musa Ash'ari reported that Allah's Messenger (may peace be upon him) mentioned many names of his and said: I am Muhammad, Ahmad. Muqaffi (the last in succession), Hashir, the Prophet of repentance, and the Prophet of Mercy.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5814]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5814

'A'isha reported Allah's Messenger (may peace be upon him) did an act, and held it to be valid. This news reached some persons amongst his Companions (and it was felt) that they did not approve of it and avoided (it). This reaction of theirs was conveyed to him. He stood to deliver an address; and said: What has happened to the people to whom there was conveyed on my behalf a matter for which I granted permission and they disapproved it and avoided it? By Allah, I have the best knowledge of Allah amongst them, and I fear Him most amongst them.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5815]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5815

This hadith has been narrated on the authority of A'mash through a different chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5816]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5816

'A'isha reported that Allah's Messenger (may peace be upon him) granted permission for doing a thing, but some persons amongst the people avoided it. This was conveyed to Allah's Apostle (may peace be upon him), and he was so much annoyed that the sign of his anger appeared on his face. He then said: What has happened to the people that they avoid that for which permission has been granted to me? By Allah, I have the best knowledge of Allah amongst them, and fear Him most amongst them.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5817]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5817

'Urwa b. Zubair reported that 'Abdullah b. Zubair had narrated to him that a person from the Ansar disputed with Zubair in the presence of Allah's Messenger (may peace be upon him) in regard to the watering places of Harra from which they watered the date-palms. The Ansari said: Let the water flow, but he (Zubair) refused to do this and the dispute was brought to Allah's Messenger (may peace be upon him) and he said to Zubair: Zubair, water (your date-palms), then let the water flow to your neighbor. The Ansari was enraged and said: Allah's Messenger, (you have given this decision) for he is the son of your father's sister. The face of Allah's Apostle (may peace be upon him) underwent a change, and then said: Zubair, water (your date-palms), then hold it until it rises up to the walls. Zubair said: I think, by Allah, that this verse:" Nay, by the Lord, they will not (really) (believe) until they make thee a judge of what is in dispute among them, and find in this no dislike of what thou decidest and submit with full submission" (iv. 65).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5818]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5818

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: Avoid that which I forbid you to do and do that which I command you to do to the best of your capacity. Verily the people before you went to their doom because they had put too many questions to their Prophets and then disagreed with their teachings.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5819]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5819

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5820]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5820

This hadith has been narrated by Abu Huraira through a different chain of transmitters (and the words are) that he reported Allah's Messenger (may peace be upon him) having said: Abandon that which I have asked you to abandon, for the people before you went to their doom (for asking too many questions).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5821]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5821

Amir b. Sa'd reported on the authority of his father that Allah's Messenger (may peace be upon him) said: The greatest sinner amongst the Muslims is one who asked about a thing (from Allah's Apostle) which had not been forbidden for the Muslims and it was forbidden for them because of his persistently asking about it.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5822]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5822

This hadith has been transmitted on the authority of 'Amir b. Sa'd and the words are. Allah's Messenger (may peace be upon him) said: The greatest sinner of the Muslims amongst Muslims is one who asked about a certain thing which had not been prohibited and it was prohibited because of his asking about it. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters and with this addition:" A person asked about a thing from Allah's Apostle (may peace be upon him) and he indulged in hair-splitting."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5823]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5823

Anas b. Malik reported that something was conveyed to him (the Holy prophet) about his Companions, so he addressed them and said: Paradise and Hell were presented to me and I have never seen the good and evil as (I did) today. And if you were to know you would have wept more and laughed less. He (the narrator) said: There was nothing more burdensome for the Companions of Allah's Messenger (may peace be upon him) than this. They covered their heads and the sound of weeping was heard from them. Then there stood up 'Umar and he said: We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as our Apostle, and it was at that time that a person stood up and he said: Who is my father? Thereupon he (the Holy Prophet) said: Your father is so and so; and there was revealed the verse:" O you who believe, do not ask about matters which, if they were to be made manifest to you (in terms of law), might cause to you harm" (v. 101).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5824]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5824

Anas b. Malik reported that a person said: Allah's Messenger, who is my father? And he said: Your father is so and so, and there was revealed this verse:" Do not ask about matters which, if they were to be made manifest to you, might cause you harm" (v. 101).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5825]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5825

Anas b. Malik reported that Allah's Messenger (may peace be upon him stood when the sun had passed the meridian and he led them noon prayer and after observing salutations (completing the prayer) he stood upon the pulpit and talked about the Last Hour and made a mention of the important facts prior to it and then said: He who desires to ask anything from me let him ask me about it. By Allah, I shall not move from this place so long as I do not inform you about that which you ask. Anas b. Malik said: People began to shed tears profusely when they heard this from Allah's Messenger (may peace be upon him) and Allah's Messenger (may peace be upon him) said it repeatedly: You ask me. Thereupon 'Abdullah b. Hudhafa stood up and said: Allah's Messenger, who is my father? He said: Your father is Hudhafa, and Allah's Messenger (may peace be upon him) said repeatedly: Ask me, and (it was at this juncture that 'Umar knelt down and said): We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as the Messenger (of Allah). Allah's Messenger (may peace be upon him) kept quiet so long as 'Umar spoke. Then Allah's Messenger (may peace be upon him) said: (The Doom) is near; by Him, in Whose Hand is the life of Muhammad, there was presented to me the Paradise and Hell in the nook of this enclosure, and I did not see good and evil like that of the present day. Ibn Shihab reported: Ubaidullah b. 'Abdullah b. 'Utba told me that the mother of 'Abdullah b. Hudhafa told 'Abdullah b. Hudhafa: I have never heard of a son more disobedient than you. Do you feel yourself immune from the fact that your mother committed a sin which the women in the pre-Islamic period committed and then you disgrace her in the eyes of the people? 'Abdullah b. Hudhafa said: If my fatherhood were to be attributed to a black slave I would have connected myself with him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5826]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5826

This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5827]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5827

Anas b. Malik reported that the people asked Allah's Apostle (may peace be upon him) until he was hard pressed. He went out one day and he occupied the pulpit and said: Ask me and I shall leave no question of yours unanswered for you, and when the people heard about it they were overawed, as if (something tragic) was going to happen. Anas said: I began to look towards the right and the left and (found) that every person was weeping wrapping his head with the cloth. Then a person in the mosque broke the ice and they used to dispute with him by attributing his fatherhood to another man than his own father. He said: Allah's Apostle, who is my father? He said: Your father is Hudhafa. Then 'Umar b. Khattab (Allah be pleased with him) dared say something and said: We are well pleased with Allah as our Lord, with Islam as our code of life and with Muhammad as our Messenger, seeking refuge with Allah from the evil of Turmoil. Thereupon Allah's Messenger (may peace be upon him) said: Never did I see the good and evil as today. Paradise and Hell were given a visible shape before me (in this worldly life) and I saw both of them near this well.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5828]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5828

This hadith has been transmitted on the authority of Qatada.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5829]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5829

Abu Musa reported that Allah's Apostle (may peace be upon him) was asked such things which he disapproved and when they persisted on asking him he felt enraged and then said to the people: Ask me what you wish to ask. Thereupon a person said: Who is my father? He said: Your father is Hudhafa. Then another person stood up and said: Allah's Messenger, who is my father? He said: Your father is Salim, the freed slave of Shaiba. When 'Umar saw the signs of anger upon the face of Allah's Apostle (may peace be upon him), he said: Allah's Messenger, we ask repentance from Allah. And in the hadith transmitted on the authority of Abu Kuraib (the words are):" Allah's Messenger, who is my father? He said: Your father is Salim, the freed slave of Shaiba."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5830]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5830

Musa b. Talha reported: I and Allah's Messenger (may peace be upon him) happened to pass by people near the date-palm trees. He (the Holy Prophet) said: What are these people doing? They said: They are grafting, i. e. they combine the male with the female (tree) and thus they yield more fruit. Thereupon Allah's Messenger (may peace be upon him) said: I do not find it to be of any use. The people were informed about it and they abandoned this practice. Allah's Messenger (may peace be upon him) (was later) on informed (that the yield had dwindled), whereupon he said: If there is any use of it, then they should do it, for it was just a personal opinion of mine, and do not go after my personal opinion; but when I say to you anything on behalf of Allah, then do accept it, for I do not attribute lie to Allah, the Exalted and Glorious.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5831]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5831

Rafi' b. Khadij reported that Allah's Messenger (may peace be upon him) came to Medina and the people had been grafting the trees. He said: What are you doing? They said: We are grafting them, whereupon he said: It may perhaps be good for you if you do not do that, so they abandoned this practice (and the date-palms) began to yield less fruit. They made a mention of it (to the Holy Prophet), whereupon he said: I am a human being, so when I command you about a thing pertaining to religion, do accept it, and when I command you about a thing out of my personal opinion, keep it in mind that I am a human being. 'Ikrima reported that he said something like this.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5832]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5832

Anas reported that Allah's Messenger (may peace be upon him) happened to pass by the people who had been busy in grafting the trees. Thereupon he said: If you were not to do it, it might be good for you. (So they abandoned this practice) and there was a decline in the yield. He (the Holy Prophet) happened to pass by them (and said): What has gone wrong with your trees? They said: You said so and so. Thereupon he said: You have better knowledge (of a technical skill) in the affairs of the world.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5833]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5833

Abu Huraira reported so many 'ahadith from Allah's Messenger (may peace be upon him) and one among them was that Allah's Messenger (may peace be upon him) is reported to have said: By Him in Whose Hand is the life of Muhammad, a day would come to you when you would not be able to see me, and the glimpse of my face would be dearer to one than one's own family, one's property and in fact everything. This hadith has been transmitted on the authority of Ishaq with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5834]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5834

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I am most akin to the son of Mary among the whole of mankind and the Prophets are of different mothers, but of one religion, and no Prophet was raised between me and him (Jesus Christ).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5835]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5835

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I am most akin to Jesus Christ among the whole of mankind, and all the Prophets are of different mothers but belong to one religion and no Prophet was raised between me and Jesus.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5836]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5836

Abu Huraira reported many ahadith from Allah's Messenger (may peace be upon him) and one is that Allah's Messenger (may peace be upon him) said: I am most close to Jesus, son of Mary, among the whole of mankind in this worldly life and the next life. They said: Allah's Messenger how is it? Thereupon he said: Prophets are brothers in faith, having different mothers. Their religion is, however, one and there is no Apostle between us (between I and Jesus Christ).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5837]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5837

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No child is born but he is pricked by the satan and he begins to weep because of the pricking of the satan except the son of Mary and his mother. Abu Huraira then said: You may recite if you so like (the verse):" I seek Thy protection for her and her offspring against satan the accursed" (iii. 36). This hadith has been narrated on the authority of Zuhri with the same chain of transmitters (and the words are):" The newborn child is touched by the satan (when he comes in the world) and he starts crying because of the touch of satan." In the hadith transmitted on the authority of Shu'aib there is a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5838]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5838

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The satan touches every son of Adam on the day when his mother gives birth to him with the exception of Mary and her son.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5839]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5839

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The crying of the child (starts) when the satan begins to prick him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5840]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5840

Abu Huraira reported ahadith from the Messenger of Allah (may peace be upon him) (and one of them was) that Allah's Messenger (may peace be upon him) said Jesus son of Mary saw a person committing theft; thereupon Jesus said to him: You committed theft. He said: Nay. By Him besides Whom there is no god (I have not committed theft). Thereupon Jesus said: I affirm my faith in Allah It is my ownself that deceived me.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5841]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5841

Anas b. Malik reported that a person came to Allah's Messenger (may peace be upon him) and said: O, the best of creation; thereupon Allah's Messenger (may peace be upon him) said: He is Ibrahim (peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5842]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5842

This hadith has been narrated on the authority of Anas through a different chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5843]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5843

Anas reported a hadith like this from Allah's Apostle (may peace be upon him) through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5844]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5844

Abu Huraira reported Allah's Messenger (may peace be upon him) having said that Ibrahim circumcised himself with the help of adz when he was eiclhty years old.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5845]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5845

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: We have more claim to doubt than Ibrahim (peace be upon him) when he said, My Lord, show me how thou wilt quicken the dead. He said: Believeth thou not? He said: Yes, but that my heart rest at ease (the Holy Qur'an. 260). May Lord have mercy on Lot that he wanted a strong support and had I stayed in the prison as long as Yusuf stayed I would have responded to him who invited me.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5846]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5846

This hadith has been narrated on the authority of Zuhri through another chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5847]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5847

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5848]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5848

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying Prophet Ibrahim (peace be upon him) never told a lie but only thrice: two times for the sake of Allah (for example, his words):" I am sick," and his words:" But it was the big one amongst them which has done that" and because of Sara (his wife). He had come in a land inhabited by haughty and cruel men along with Sara. She was very good-looking amongst the people, so he said to her: If these were to know that you are my wife they would snatch you away from me, so if they ask you tell that you are my sister and in fact you are my sister in Islam, and I do not know of any other Muslim in this land besides I and you. And when they entered that land the tyrants came to see her and said to him (the king): 'there comes to your land a woman, whom you alone deserve to possess, so he (the kings sent someone (towards her) and she was brought and Ibrahim (peace be upon him) stood in preyer, and when she visited him (the tyrant king came) he could help but stretch his hand towards her and his hand was tied up. He said: Supplicate Allah so that He may release my hand and I will do no harm to you. She did that and the man repeated (the same highhandedness) and his hand was again tied up more tightly than on the first occasion and he said to her like that and she again did that (supplicated), but he repeated (the same highhandedness and his hands were tied up more tightly than on the previous occasion). He then again said: Supplicate your Lord so that He may set my hand free; by. @ llah I shall do no harm to you. She did and his hand was freed. Then he called the person who had brought her and said to him: You have brought to me the satan and you have not brought to me a human being, so turn them out from my land, and he gave Hajira as a gift to her. She returned (along with Hajira) and when Ibrahim (peace be upon him) saw her, he said: How have you returned? She said: With full safety (have I returned). Allah held the hand of that debauch and he gave me a maid-servant. Abu Hiaraira said: O sons of the rain of the sky, she is your mother.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5849]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5849

Hammam b. Munabbih reported that Abu Huraira reported many ahadith from Allah's Messenger (may peace be upon him) and one, of them speaks that Allah's Messenger (may peace be upon him) is reported to have said: Banu Isra'il used to take bath (together) naked and thus saw private parts of one another, but Moses (peace be upon him) used to take bath alone (in privacy), and they said: By Allah, nothing prevents Moses to take bath along with us; but scrotal hernia. One day when he (Moses) was taking bath (alone) he placed his clothes upon a stone, but the stone began to move along with his clothes. Moses raced after it saying: My garment, stone; until (some of the people) of Banu Isra'il looked at the private parts of Moses, and they said: By Allah, there is no trouble with Moses. The stone stopped after he (Moses) had been seen. He took hold of his garments and struck the stone. Abu Huraira said: I swear by Allah that there were six or seven scars on the stone because of the striking of stone by Moses (peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5850]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5850

Abu Huraira reported that Moses was a modest person. He was never seen naked and Banu Isra'iI said: (He was afraid to expose his private part) because he had been suffering from scrotal hernia. He (one day) took bath in water and placed his garments upon a stone. The stone began to move on quickly. He followed that and struck it with the help of a stone (saying): O stone, my garment; O stone, my garments, O stone; until it stopped near the big gathering of Isrii'll, and this verse was revealed (pertaining to the incident):" O you who believe, be not Iike those who maligned Moses, but Allah cleared him of what they said, and he was worthy of regard with Allah" (xxxiii. 69).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5851]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5851

Abu Huraira reported that the Angel of Death was sent to Moses (peace be upon him) to inform of his Lord's summons. When he came, he (Moses) boxed him and his eye was knocked out. He (the Angel of Death) came back to the Lord and said: You sent me to a servant. who did not want to die. Allah restored his eye to its proper place (and revived his eyesight), and then said: Go back to him and tell him that if he wants life he must place his hand on the back of an ox, and he would be granted as many years of life as the number of hair covered by his hand. He (Moses) said: My Lord what would happen then He said: Then you must court death. He said: Let it be now. And he supplicated Allah to bring him close to the sacred land. Thereupon Allah's Messenger (may peace be upon him) said: If I were there, I would have shown you his grave beside the road at the red mound.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5852]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5852

Abu Huraira reported Allah's Messenger (may peace be upon him) having said that the Angel of Death came to Moses and said: Respond (to the call) of Allah (i. e. be prepared for death). Moses (peace be upon him) gave a blow at the eye of the Angel of Death and knocked it out. The Angel went back to Allah (the Exalted) and said: You sent me to your servant who does not like to die and he knocked out my eye. Allah restored his eye to its proper place (and revived his eyesight) and said: Go to My servant and say: Do you want life? And in case you want life, keep your hand on the body of the ox and you would live such number of years as the (number of) hair your hand covers. He (Moses) said: What, then? He said: Then you would die, whereupon he (Moses) said: Then why not now? (He then prayed): Allah, cause me to die close to the sacred land. Allah's Messenger (may peace be upon him) said: Had I been near that place I would have shown his grave by the side of the path at the red mound. This hadith has been transmitted on the authority of Ma'mar.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5853]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5853

Abu Huraira reported: While a Jew was selling goods, he was given something which he did not accept or he did not agree (to accept) that 'Abdul 'Azlz (one of the narrators) is doubtful about it. He (the Jew) said: By Allah, Who chose Moses (peace be upon him) among mankind. A person from the Ansar heard it and gave a blow at his face saying: (You have the audacity) to say: By Him Who chose Moses amongst mankind, whereas Allah's Messenger (may peace be upon him) is living amongst us. The Jew went to Allah's Messenger (may peace be upon him) and said: Abu'l-Qasim, I am a Dhimmi and (thus need your protection) by a covenant, and added: Such and such person has given a blow upon my face. Thereupon Allah's Messenger (may peace be upon him) said: Why did you give a blow on his face? He said: Allah's Messenger, this man said: By Him Who chose Moses (peace be upon him) amongst mankind, whereas you are living amongst us. Allah's Messenger (may peace be upon him) became angry and signs of anger could be seen on his face, and then said: Don't make distinction amongst the Prophets of Allah. When the horn will be blown and whatever is in the heavens and the earth would swoon but he whom Allah grants exception, then another horn will be blown and I would be the first amongst those who would recover and Moses (peace be upon him) would be catching hold of the Throne and I do not know whether it is a compensation for that when he swooned on the Day of Tur or he would be resurrected before me and I do not say that anyone is more excellent than Yunus son of Matta (peace he upon him). This hadith has been narrated on the authority of Abu Salama with the same chain of transmitters.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5854]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5854

Abu Fluraira reported that two persons, one from amongst the Jews and the other from amongst the Muslims, fell into dispute and began to abuse one another. The Muslim said: By Him Who chose Muhammad (may peace be upon him) in the worlds. And the Jew said: By Him Who chose Moses in the worlds. Thereupon the Muslim lifted his hand and slapped at the face of the Jew. The Jew went to Allah's Messenger (may peace be upon him) and told him about his affair and the affair of the Muslim. Thereupon Allah's Messenger (may peace be upon him) laid: Don't make me superior to Moses for mankind will swoon and I would be the 'first to recover from it and Moses would be at that time seizing the side of the Throne and I do not know (whether) he would swoon and would recover before me or Allah would make an exception for him.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5855]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5855

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person from amongst the Muslims and a person from amongst the Jews fell into dispute and reviled each other. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5856]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5856

Abu Sa'id Khudri reported that a Jew who had received a blow at his face came to Allali', ; Messenger (may peace be upon him) ; the rest of the hadith is the same, up to the hand (where the words are): That he (the Holy Prophet) said: I do not know whether he would be one who would fall into swoon and would recover before me or he would be compensated for his swooning at Tur (and thus he would not swoon on this occasion) of Resurrection.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5857]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5857

Abu Sa'id Kudari reported Allah's Messenger (may peace be upon him) having, said this: Don't make distinction amongst the Apostles. This hadith has been narrated through another chain of transmitters also.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5858]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5858

Anas b. malik reported Allah's Messenger (may peace be upon him) as saying: I came. And in the narration transmitted on the authority of Haddib (the words are): I happened to pass by Moses on the occasion of the Night journey near the red mound (and found him) saying his prayer in his grave.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5859]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5859

Anas reported Allah's Messenger (may peace be upon him) as saying: I happened to pass by Moses as he was busy in saying prayer in his grave, and in the hadith transmitted on the authority of 'Isa there is an addition of these words:, I happened to pass on the occasion of the Night journey." In the hadith pertaining to Yunus (peace be upon him) the words of the Holy Prophet (may peace be upon him) are:" It is not meet for a, servant that he should say:" I am better than Yunus (jonah) son of Matta."


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5860]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5860

Abu Huraira reported Allah's Messenger (may prace be upon him) as saying that Allah, the Exalted and Majestic, said: It is not meet for a servant of Mine that he should say: I am better than Yunus b. Matta (peace be upon him).


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5861]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5861

Abu al-Aliya said: The son of the uncle of your Prophet (may peace be upon him), i. e. Ibn Abbas, reported Allah's Messenger (may peace be upon him) as saying: It is not meet for a servant that he should say: I am better than Yunus b. Matta (and this Matta) is the name of his father.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5862]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5862

Abu Huraira reported: It was said to Allah's Messenger (may peace be upon him) as to who was the most worthy of respect amongst people. He said: The most God-conscious amongst you They said: It is not this that we are asking about, whereupon he said: Then he is Yusuf, the Apostle of Aliah and the son of Allah's Apostle, Ya'qub, who was also the son of Allah's Apostle, the friend of Allah (Ibrahim) They said: This is not what we are asking you. He said: You mean the tribes of Arabia? Those who are good in pre-Islamic days are good in Islam (after embracing Islam) when they get an understanding of it.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5863]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5863

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Zakariyya (peace be upon him) was a carpenter.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5864]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5864

Sa'id b. jubair reported: I said to Ibn Abbas that Nauf al-Bikali was of the opinion that Moses (peace be upon him), the Apostle of Bani Isra'il, was not the same who accompanied Khadir, whereupon he said: The enemy of Allah tells a lie. I heard Ubayy b. Ka'b say: Moses (peace be upon him) stood up to give sermon to the people of Isra'il. He was asked as to who amongst the people has the best knowledge, whereupon he said: I have the best knowledge. Thereupon Allah was annoyed with him that he did not attribute (the best knowledge) to Him. He revealed to him: A servant amongst My servants is at the junction of two rivers who has more knowledge than yours. Moses said: How can I meet him? It was said to him: Carry a fish in the large basket and the place where you find it missing there you will find him. Thereupon Moses proceeded forth along with a young man (Yusha'). Joshua b. Nan and Moses (peace be upon him) put the fish in the basket and there went along with him the young man (Yusha') until they came to a certain rock and Moses and his companion went to sleep and the fish stirred in that basket and fell into the ocean and Allah stopped the current of water like a vault until the way was made for the fish. Moses and his youn. companion were astonished and they walked for the rest of the day and the night and the friend of Moses forgot to inform him of this incident. When it was morning, Moses (peace be upon him) said to the young man: Bring for us the breakfast for we are dead tired because of this journey, and they did not feel exhausted until they had passed that place where they had been commanded (to stay). He said: Don't you know that when we reached the Sakhra (rock) I forgot the fisii and noth ng made me forget it but the satan that I. could nit remember it? How strange is it that the fish found a way in the river? Moses said: That was what we had been aiming at. Then both of them retraced their steps until they reached Sakhra; there they saw a man covered with a cloth. Moses greeted him. Khadir said to him: Where is as-Salam in our country.? He said: I am Moses, whereupon he (Khadir) said: You mean the Moses of Bani Isra'il? He said: Yes. He (Khadir) said: You have a knowledge out of the knowledge of Allah which in fact Allah imparted to you and about that I know nothing and I have knowledge out of Allah's knowledge which He imparted to me and about that you do not know. Moses (peace be upon him) said to him: May I follow you so that you may teach me that with which you have been taught righteousness. He said: You will not be able to bear with me; how you will be able to bear that about which you do not know? Moses said: Thou wilt find me patient, nor shalt I disobey you in aught. Khadir said to him: If you were to follow me, then do not ask me about anything until I myself speak to you about it. He said: Yes. So Khadir and Moses set forth on the bank of the river that there came before them a boat. Both of theni talked to them (the owners of the boat) so that they might carry both of them.

They had recognised Khadir and they carried them free. Khadir thereupon took hold of a plank in the boat and broke it away. Moses said: These people have carried us without any charge and you attempt to break their boat so that the people sailing in the boat may drown. This is (something) grievous that you have done. He said: Did I not say that you would not bear with me? He said: Blame me not for what I forgot and be not hard upon what I did. Then both of them got down from the boat and began to walk along the coastline that they saw a boy who had been playing with other boys. Khadir pulled up his head and killed him. Moses said: Have you killed an innocent person who is in no way guilty of slaying another? You have done something horrible. Thereupon he said: Did I not say to you that you will not be able to bear with me? He (Moses) said: This (act) is more grievous than the first one. He (Moses) further said. If I ask you about anything after this, keep not company with me, then you would no doubt find (a plausible) excuse for this. Then they both walked on until they reached the inhabitants of a village. They asked its inhabitants for food but they refused to entertain them as their guests. They found in it a wall which had been bent on one side and was about to fall. Khadir set it right with his own hand. Moses, said to him: It is the people to whom we came but they showed us no hospitality and they did not serve us food. If you wish you can get wages for it. He (Khadir) said: This is the parting of ways between mt and you. Now I wish to reveal to you the significance of that for which you could not bear with me. Allah's Messenger (may peace be upon him) said. May Allah have mercy upon Moses! I wish if Moses could show patience and a (fuller) story of both of them could have been told. Allah's Messenger (may peace be upon him) said that the first thing which Moses said was out of forgetfulness. Then there came a sparrow until it perched on the wall of the boat and took water from the ocean. Thereupon, Khadir said: My knowledge and your knowledge in comparison with the knowledge of Allah is even less than the water taken by the sparrow in its beak in comparison to the water of the ocean, and Sa'id b. jubair used to recite (verses 79 and 80 of Sura Kahf) in this way: There was before them a king who used to seize every boat by force which was in order, the boy was an unbeliever.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5865]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5865

Sa, id b. jubair reported that it was said to Ibn 'Abbas that Nauf al-Bikali was of the opinion that Moses who went in search of knowledge was not the Moses of Bani Isra'il. He said: Sa'id, did you hear it from him? I said: Yes. Thereupon he said that Nauf had not stated the fact. Ubayy b. Ka'b narrated to us that he had heard Allah's Messenger (may peace be upon him) as saying: Moses had been delivering sermons to his people. And he made this remark: No person upon the earth has better knowledge than I or nothing better than mine. Thereupon Allah revealed to him: I know one who is better than you (in knowledge) or there is a person on the earth having more knowledge than you. Thereupon he said: My Lord, direct me to him. It was said to him: Keep a salted fish as a provision for journey. The place where that fish would be lost (there you will find that man). So he set forth and a young slave along with him until they came to a place Sakhra. but he did not find any clue. So he proceeded on and left that young man there. The fish began to stir in water and the water assumed the form of an ark over the fish. The young man said: I should meet Allah's Apostle (peace be upon him) and inform him, but he was made to forget and when they had gone beyond that place, he (Moses) said to the young man: Bring breakfast. We have been exhausted because of the journey, and he (Moses) was not exhausted until he had crossed that (particular) place (where he had) to meet Khadir, and the youth was reminded and said: Did you not see that as we reached Sakhra I forgot the fish and it is satan alone who has made me forgetful of it'? It is strange that he has been able to find way in the ocean too. He said: This is what we sought for us.

They returned retracing their steps, and he (his companion) pointed to him the location (where) the fish (had been lost). Moses began to search him there. He suddenly saw Khadir wrapped in a cloth and lying on his back. He said to him: As-Salamu-'Alaikum. He removed the cloth from his face and said: Wa 'Alaikum-us-Salam! Who are you? He said: I am Moses. He said: Who Moses? He said: Moses Of Bani Isra'il. He said: What brought you here? He said: I have come so that you may teach me what you have been taught of righteousness. He said: You shall have to bear with me, and how can you have patience about a thing of which you have no comprehensive knowledge? You will not have patience when you see me doing a thing I have been ordered to do. He said: If Allah pleases, you will find me patient, nor shall I disobey you in aught. Khadir said: If you follow me, don't ask me about anything until I explain it to you. So they went on until they embarked upon a boat. He (Khadir) made a hole in that. Thereupon he (Moses) said: You have done this so that you may drown the persons sitting in the boat. You have done something grievous. Thereupon he said: Did I not tell you that you will not be able to bear with me? Thereupon he (Moses) said: Blame me not for what I forgot and be not hard upon me for what I did. (Khadir gave him another chance.) So they went on until they reached a place where boys were playing. He went to one of them and caught hold'of one (apparently) at random and killed him. Moses (peace be upon him) felt agitated and said: You have killed an innocent person not guilty of slaying another. You have done something aboininable.

Thereupon Allah's Messenger (may peace be upon him) said: May Allah have mercy upon us and Moses. Had he shown patience he would have seen wonderful things, but fear of blame, with respect to his companion, seized him and he said: If I ask anything after this, keep not company with me. You will then have a valid excuse in my case, and had he (Moses) shown patience he would have seen many wonderful things. He (the narrator) said: Whenever he (the Holy Prophet) made mention of any Prophet, he always said: May there be mercy of Allah upon us and upon my brother so and so. They, however, proceeded on until they came to the inhabitants of a village who were very miserly. They went to the meeting places and asked for hospitality but they refused to show any hospitality to them. They both found in that village a wall which was about to fall. He (Khadir) set it right. Thereupon he (Moses) said: If you so liked. you could get wages for it. Thereupon he said: This is the partince, of ways between me and you, and, taking hold of his cloth, he said: Now I will explain to you the real significance (of all these acts) for which you could not show patience. As for the boat, it belonged to the poor people working on the river and I intended to damage it for there was ahead of them (a king) who seized boats by force. (When he came) to catch hold of it he found it a damaged boat, so he spared it (and later on) it was set right with wood. So far as the boy is concerned, he has been, by very nature, an unbeliever, whereas his parents loved him very much. Had he grown up he would have involved them in wrongdoing and unbelief, so we wished that their Lord should give them in its place one better in purity and close to mercy. And as for the wall it belonged to two orphan boys in the city and there was beneath it a (treasure) belongin to them,... up to the last verse. This hadith has been transmitted on the authority of Abu Ishaq.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5866]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5866

Ibn 'Abbas has reported this hadith on the authority of Ubayy b. ka'b that Allah's Apostle (may peace be upon him) used to recite this.


Muslim :: The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il) :: [30.5867]

The Book Pertaining to the Excellent Qualities of the Holy Prophet (may Peace be upon them) and His Companions (Kitab Al-Fada'il)

Muslim :: Book 30 : Hadith 5867

'Utba b. Mas, ud reported that 'Abdullah b. 'Abbas contended with Hurr b. Qais b. Hisn al-Fazari aboat the companion of Moses (peace be upon hiin). Ibn 'Abbas said that he was Khadir. There happened to pass Ubayy b. Ka'b Ansari. Ibn Abbas called him and said: Abu Tufail, come to us. There has been a difference of opinion between me and my friend about the companion of Moses whom he wanted to meet on the way. Did hear anything from Allah's meesenger (may peace be upon him) making a mention of anything? Ubayy said: I heard Allah's Messenger (may Peace be upon him) as saying: As Moses was amongst the group of Bani Isra'il, there came to him a person and he said to him: Do you know anyone having better knowledge than you? Moses said: No. Thereupon Allah revealed to Moses: Of course, there is amongst Our servants Khadir (who has better knowledge) than you. Moses asked the way of meeting him. Allah made the fish a sign and it was said to him: Where you miss the fish return to that (place) and you will soon find him. So Moses moved on as Allah wished him to move on. He then said to his young companion: Bring for us the breakfast. Thereupop that young man said to Moses. when he asked him for the breakfast: Don't you see that as we had reached the Sakhra I forgot the fish and nobody made it forget (in our mind) but the satan that I should remind you of it? Mosed said to that young man: This was what we wanted. So they retraced their steps and met Khadir and the events which followed have been described in His Book except that Yunus (the narrator) said that he followed the traces of fish in the ocean.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5868]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5868

Anas b. Malik reported that Abu Bakr Siddiq reported him thus: I saw the feet of the polytheists very close to us as we were in the cave. I said: Allah's Messenger, if one amongst them were to see at his feet he would have surely seen us. Thereupon he said: Abu Bakr, what can befall twain who have Allah as the third One with them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5869]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5869

Abu Sa'id reported that Allah's Messenger (may peace be upon him) sat on the pulpit and said: Allah gave a choice to His servant that he may opt the beauties of the world or that which is with Him and the servant chose that which was with Him. Thereupon Abu Bakr wept and he wept bitterly and said: Let our fathers and our mothers be taken as ransom for you. It was Allah's Messenger (may peace be upon him) who had been given the choice and Abu Bakr knew it better than us, and Allah's Messenger (may peace be upon him) is reported to have said: Behold, of all people the most generous toward me in regard to his companionship and his property was Abu Bakr and were I to choose anyone as my bosom friend, I would have chosen Abu Bakr as my dear friend, but (for him) I cherish Islamic brotherliness and love. There shall be left open no window in the mosque except Abu Bakr's window.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5870]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5870

This hadith has been narrated on the authority of Abu Sa'id Khudri through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5871]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5871

'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: If I were to choose a bosom friend I would have definitely chosen Abu Bakr as my bosom friend, but he is my brother and my companion and Allah, the Exalted and Gliorious. has taken your brother and companion (meaning Prophet himself) as a friend.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5872]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5872

Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose from my Umma anyone as my bosom friend, I would have chosen Abu Bakr.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5873]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5873

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose as my bosom friend I would have chosen the son of Abu Quhafa (Abu Bakr) as my bosom friend.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5874]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5874

Abdullah reported Allah's Messenger (may peace be upon him) as saying: If I were to choose amongst the people of earth someone as my bosom friend, I would have chosen the son of Abu Quhafa as my friends but God has taken your companion as a friend.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5875]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5875

This hadith has been narrated through another chain of transmitters and the one narrated on the authority of Abdullah (the words are):" Allah's Messenger (may peace be upon him) is reported to have said: Behold I am free from the dependence of all bosom friends and if I were to choose anyone as bosom friend I would have taken Abu Bakr as my bosom friend. Allah has taken your companion as a friend.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5876]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5876

'Amr b. al-'As reported that Allah's Messenger (may peace be upon him) sent him in command of the army despatched to Dhat-as-Salasil. When 'Amr b. al-'As came back to the Holy Prophet (may peace be upon him) he said: Who amongst people are dearest to you? He said: A'isha. He then said: Who amongst men? He said: Her father, and I said: And who next? He said: Umar. He then enumerated some other men.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5877]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5877

Ibn Abu Mulaika reported: I heard A'isha as saying and she was asked as to whom Allah's Messenger (may peace be upon him) would have nominated his successor if he had to nominate one at all. She said: Abu Bakr. It was said to her: Then whom after Abu Bakr? She said: Umar. It was said to her. Then whom after 'Umar? She said: Abu Ubaida b. Jarrab, and then she kept quiet at this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5878]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5878

Muhammad b. Jubair b. Mut'im reported on the authority of his father that a woman asked Allah's Messenger (may peace be upon him) about something but lit, told her to come to him on some other occasion, whereupon she said: What in your opinion (should I do) if I come to you but do not find you, and it seemed as if she meant that he might die. Thereupon he said: If you do not find me, then come to Abu Bakr.

This hadith has been narrated on the authority of Jubair b. Mut'im through another chain of transmitters (and the words are) that a woman came to Allah's Messenger (may peace be upon him) and discussed with him something and he gave a command as we find in the above-mentioned narration.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5879]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5879

A'isha reported that Allah's Messenger (may peace be upon him) in his (last) illness asked me to call Abu Bakr, her father, and her brother too, so that he might write a document, for he feared that someone else might be desirous (of succeeding him) and that some claimant may say: I have better claim to it, whereas Allah and the Faithful do not substantiate the claim of anyone but that of Abu Bakr.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5880]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5880

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: Who amongst you is observing fastthis day? Abu Bake said: It is I. He (again) said: Who amongst you has followed the bier today? Abu Bakr said: It is I. He (the Holy Prophet) again said: Who amongst you has served food to the needy? Abu Bakr said: It is I. He (again) said: Who amongst you has today visited the sick? Abu Bakr said: It is I. Thereupon Allah's Messenger (may peace be upon him) said: He must get into Paradise who combines in himself (all these noble qualities and virtues).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5881]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5881

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person had been driving an ox loaded with luggage. The ox looked towards him and said: I have not been created for this but for lands (i. e. for ploughing the land and for drawing out water from the wells for the purpose of irrigating the lands). The people said with surprise and awe: Hallowed be Allah, does the ox speak? Allah's Messenger (may peace be upon him) said: I believe it and so do Abu Bakr and 'Umar. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A shepherd was tendirig the flock when a wolf came there and took away one goat. Tile shepherd pursued it (the wolf) and rescued it (the goat) from that (wolf). The wolf looked towards him and said: Who would save it on the day when there will be no shepherd except me? Thereupon people said: Hallowed be Allah I Thereupon Allah's Messenger (may peace be upon him) said: I believe in it and so do Abu Bakr and Umar believe.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5882]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5882

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters, but there is no mention of the story pertaining to the ox.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5883]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5883

This hadith has been transmitted on the authority of Zuhri, and there is a clear mention of the stories of ox and goat (and the words are): I believe in it and so do Abu Bakr and Umar, but they were not at that time present there.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5884]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5884

This hadith has been narrated on the authority of Abu Huraira through another chain of transrritters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5885]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5885

Ibn Abu Mulaika reported: I heard Ibn 'Abbas as saying: Wlien 'Umar b. Khatab was placed in the coffin the people gathered around him. They praised him and supplicated for him before the bier was lifted up, and I was one amongst them. Nothing attracted my attention but a person who gripped my shoulder from behind. I saw towards him and found that he was 'All. He invoked Allah's mercy upon 'Umar and said: You have left none behind you (whose) deeds (are so enviable) that I love to meet Allah with them. By Allah, I hoped that Allah would keep you and your two associates together. I had often heard Allah's Messenger (may peace be upon him) as saying: I came and there came too Abu Bakr and 'Umar; I entered and there entered too Abu Bakr and 'Umar; I went out and there went out too Abu Bakr and 'Umar, and I hope and think that Allah will keep you along with them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5886]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5886

This hadith has been narrated on the authority of 'Umar b. Sa'id with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5887]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5887

Abu Sa'id Khudri reported Allah's Messenger (may peace be upon him) as say ing: While I was asleep I saw people being presented to me (in a dream) and they wore shirts and some of these reached up to the breasts and some even beyond them. Then there happened to pass 'Umar b. Khattab and his shirt had been trailing. They said: Allah's Messeneer, how do you interpret the dream? He said: (As strength of) faith.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5888]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5888

Hamza b. Abdullah b. 'Umar b. Khattab reported on the authority of his father that Allah's Messenger (may peace be upon him) said: While I was asleep I saw (in a dream) a cup containing milk bein. presented to me. I took out of that until I perceived freshness being reflected through my nails. Then I presented the leftover to 'Umar b. Khattab. They said: Allah's Messenger: Fow do you interpret it? He said: This implies knowledge.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5889]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5889

This hadith has beer. narrated on the authority of Yunus with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5890]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5890

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was asleep I saw myself on a well with a leathern bucket on a pulley. I drew (water) out of that as Allah wished me (to draw). Then the son of Abu Quhafa (Abu Bakr) drew from it one bucketful or two and there was some weakness in drawing that (may Allah forgive him). Then that bucket (changed into a large bucket) and Ibn Khattab drew it. I did not see any strongest man drawing it like 'Umar b. Khattab. He brought out so much water that the camels of the people had enough to drink and then laid down (for rest).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5891]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5891

This hadith has been narrated on the authority of Yunus through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5892]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5892

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I saw Ibn Abu Quhafa drawing (water) ; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5893]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5893

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While I was asleep I saw myself drawing water from my tank in order to quench the thirst of the people that there came to me Abu Bakr. He took hold of the leathern bucket from my hand so that he should serve water to the people. He drew two bucketfuls and there was some weakness in his drawing (Allah may forgive him). Then there came Ibn Khattab and he took hold of that, and I did not see a person stronger than he (drawing water) until the people went away with their thirst quenched and the tank filled with water.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5894]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5894

Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: I saw (in a dream) as if I was drawing water with a leathern bucket on a wooden pulley. There came Abu Bakr and he drew out a bucketful or two and as he drew out, some weakness (was perceived in it) (may Allah, the Exalted and Glorious, forgive him). Then Umar came in order to serve water -and the bucket was changed into a large leather bucket and I did not see such a wonderful man amongst persons (drawing water) and he went on serving water to the people until they were fully satisfied and then went to their resting places.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5895]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5895

Salim b. 'Abdullah reported on the authority of his father some of the dreams of Allah's Messenger (may peace be upon him) pertaining to Abu Bakr and Umar b. Khattab (Allah be pleased with them) and a hadith like this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5896]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5896

Jabir reported Allah's Messenger (may peace be upon him) as saying: I entered Paradise and saw in it a house or a palace. I said: For whom is it resersred? They (the Angels) said: It is for 'Umar b. Khattab. (The Holy Prophet said to 'Umar b. Khattab): I intenied to get into it but I thought of your feelings. Thereupon 'Umar wept and said: Apostle of Allah, could I feel any jealousy in your case?


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5897]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5897

This hadith has been narrated on the authority of Jabir through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5898]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5898

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Wtiile'l was asleep I saw myself in Paradise and a woman performing ablution by the side of a palace. I said: For whom is it meant? They said: It is meant for 'Umar b. Khattab. (The Holy Prophet) said: There came across my mind the feeling of Umar and so I turned back and went away. Abu Huraira said: 'Umar wept as we were present in that meeting with Allah's Messenger (may peace be upon him) amongst us and Umar said: Allah's Messenger, may my father and mother be taken as ransom for you. Could I at all feel any jealousy about you? This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5899]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5899

Sa'd b. Waqqas reported that Umar sought permission from Allah's Messenger (may peace be upon him) to visit him when some women of the Quraish were busy in talking with him and raising their voices above his Voiee. When'Umar sought permission they stood up and went hurriedly behind the curtain. Allah's Messenger (may peace be upon him) gave him permission smilingly. Thereupon 'Umar said: Allah's Messenger, may Allah keep you happy all your life. Then Allah's Messenger (may peace be upon him) said: I wonder at these women who were with me and no sooner did they hear your voice, they immediately went behind the curtain. Thereupon 'Umar said: Allah's Messenger, you have more right that they should fear you. Then Umar (addressing the women) said: O ye enemies of yourselves, do you fear me and fear not the Messenger of Allah (may peace be upon him)? They said: Yes, you are harsh and strict as compared to the Messenger of Allah (may peace be upon him). Thereupon, Allah's Messenger (maypeace be upon him) said: By Him in Whose Hand is my life, if satan would encounter you in the way he would certainly take a different way from that of yours.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5900]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5900

Abu Huraira reported that Umar b. Khattab came to Allah's Messenger (may peace be upon him) while there were some women with him and they were raising their voices above the voice of Allah's Messenger (may peace be upon him) and when Umar sought permission to get into the house they went behind the curtain hurriedly. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5901]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5901

A'isha reported Allah's Messenger (may peace be upon him) as saying: There had been among the people before you inspired persons and if there were any such among my Umma Umar b. Khattab would be one of them. Ibn Wahb explained the word Muhaddathun as those who receive hint from the High (Mulhamun).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5902]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5902

This hadith has been narrated on the authority of Sa'd b. Ibrahim with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5903]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5903

Ibn Umar reported Umar as saying: My lord concorded with (my judgments) on three occasions. In case of the Station of Ibrahim, in case of the observance of veil and in case of the prisoners of Badr.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5904]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5904

Ibn Umar reported that when 'Abdullah b. Ubayy b. Salul (the hypocrite) died, his son Abdullah b. Abdullah came to Allah's Messenger (may peace be upon -him) and asked him to give his shirt which should be used for the coffin of his father. He gave that to him. Allah's Messenger (may peace be upon him) stood up to say prayer over him Thereupon I Umar caught hold of the clothe of Allah's Messenger (may peace be upon him) and said: Allah's Messenger, are you going to offer prayer, whereas Allah has forbidden to offer prayer for him, whereupon Allah's Messenger (may peace be upon him) said: Allah has given me a choice saying: Ask forgiveness for them or you may not ask for them; even if you ask for them seventy times, I will make an addition to the seventy. He was a hypocrite and Allah's Messenger (may peace be upon him) said prayer over him that Allah, the Exalted and Glorious, revealed the verse:" And never pray over any one of them that has died and never should you stand by his grave" (ix. 84).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5905]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5905

This hadith has been narrated on the authority of 'Ubaidullah with the same chain of transmitter but with the addition of the words:" He abandoned saying prayer over the hypocrites who had died."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5906]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5906

A'isha reported: Allah's Messenger (may peace be upon him) was lying in the bed in my apartment with his thigh or his shank uncovered that Abu Bakr sought permission to get in. It was given to him and he conversed in the same very state (the Prophet's thigh or shank uncovered). Then 'Umar sought permission for getting in and it was given to him and he conversed in that very state. Then 'Uthman sought permission for getting in; Allah's Messenger (may peace be upon him) sat down and he set right his clothes. Mubammad (one of the narrators) said: I do not say that it happened on the same day. He ('Uthman) then entered and conversed and as he went out, A'isha said: Abu Bakr entered aind you did not stir and did not observe much care (in arranging your clothes), then 'Umar entered and you did not stir and did not arrange your clothes, then 'Uthman entered and you got up and set your clothes right, thereupon he said: Should I not show modesty to one whom even the Angels show modesty.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5907]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5907

A'isha, the wife of Allah's Apostle (mav peace be upon him), and Uthman both reported that Abu Bakr sought permission from Allah's Messenger (may peace be upon him) for entrance (in his apartment) as he had been lying on his bed covered with the bed-sheet of A'isha, and he gave permission to Abu Bakr in that very state and he, having his need fulfilled, went back. Then Umar sought permission and it was given to him in that very state and, after having his need fulfilled, he went back. And 'Uthman reported: Then I sought permission from him and he got up and raid to A'isha: Wrap yourself well with your cloth, then I got my need fulfilled and came back. And A'isha said: Allah's Messenger, why is it that I did not see you feeling any anxiety in case of dressing properly in the presence of Abu Bakr and 'Umar (Allah be pleased with them) as you showed in case of 'Uthman. Thereupon Allah's Messenger (may peace be upon him) said: Verily Uthman is a person who is very modest and I was afraid that if I permitted him to enter in this very state he would not inform me of his need.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5908]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5908

This hadith has been transmitted on the authority of Uthman and A'isha with the same wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5909]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5909

Abu Musa al-Ash'ari reported that while Allah's Messenger (may peace be upon him) was in one of the gardens of Medina, reclining against a pillow and fixing a stick in a mud, that a person came asking for the gate to be opened, whereupon he said: Open it for him and give him glad tidings of Paradise and, lo, it was Abu Bakr. I opened (the gate) for him and gave him the glad tidings of Paradise. Then another person asked for the door to be opened, whereupon he said: Open it and give him the glad tidings of Piradise. He said: I went away and, lo, it was 'Umar. I opened it for him and gave him the glad tidings of Paradise. Then still another man asked for the door to be opened, and thereupon Allah's Apostle (may peace be upon him) said: Open it and give him the glad tidings of Paradise after a trial would afflict him. I went and, lo, it was 'Uthman b. 'Affan. 1 opened the door and gave him the glad tidings of Paradise and informed him (what the Holy Prophet had said). Thereupon he said: O Allah, grant me steadfastness. Allah is one Whose help is to be sought.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5910]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5910

This hadith has been transmitted on the authority of Abu Musa al-Ash'ari with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5911]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5911

Abu Musa Ash'ari reported that he performed ablution in his house and then came out saying: I would remain with Allah's Messenger (may peace be upon him) the whole day long. He came to the mosque, and asked about Allah's Apostle (may peace be upon him). They (his Companions) said: He has gone in this direction. He (Abu Musa Ash'ari) said: I followed his steps asking about him until I came to Bi'r Aris (it is a well in the suburb of Medina). I sat by its wooden door until Allah's Messenger (may peace be upon him) had relieved himself and then performed ablution. I went to him and he was sitting with his shanks uncovered hp to the knees and his legs dangl- ing in that well. I offered him salutations. I then came back and sat at the door as if I had been a chamberlain at the door of Allah's Messenger (may peace be upon him) that day. There came Abu Bakr and knocked the door and I said: Who is it? He said: This is Abu Bakr. I said: Wait, please. I went and said: Allah's Messenger, here is Abu Bakr seeking permission. Thereupon he said: Admit him and give him glad tidings of Paradise. I came and I said to Abu Bakr to get in (and also told him) that Allah's Messenger (may peace be upon him) was giving him the glad tidings of Paradise. Abu Bakr got in and sat on the right side of Allah's Messenger (may peace be upon him) and dangled his feet in the well as Allah's Messenger (may peace be upon him) had done, and he uncovered his shanks. I then returned and sat there and I had left my brother as he had been performing ablution and he was to meet me and I said: If Allah would intend goodness for such and such he would intend goodness for his brother and He would bring him. I was thinking this that a person stirred the door. I said: Who is it. He said: This is Umar b., Khattab. I said: Wait. Then I came to Allah's Messenger (may peace be upon him), greeted him and said: Here is 'Umar seeking your. permission to get in. Thereupon he said: Let him come in and give him glad tid- ings of Paradise. I came to Umar and said: There is permission for you and glad tidings for you from Allah's Messenger (may peace be upon him) for Paradise. He got in and sat on the left side of Allah's Messenger (may peace be upon him) with his feet dangling in the well. I then returned and sat and said: If Allah would intend goodness for such and such (that is for his brother), He would bring him. And I was contemplat- ing over it that a man stirred the door and I said: Who is it? He said: This is Uthman b. Affan. I said: Wait, please. I then came to Allah's Messenger (may peace be upon him) and informed him. and he said: Admit him and give him glad tidings (and inform) him of the turmoil which he shall have to face. I came and said: Get in, Allah's Messenger (may peace be upon him) gives you the glad tidings of Paradise along with the trial which you shall have to face. He got in and saw the elevated plan round the well fully occupied. He sat on the other side. Sharik said that Sa'id b. al-Musayyib reported: I drew a conclusion from it that their groves would be (in this very state, the graves of Hadrat Abu Bakr, 'Umar Faruq by the tide of the Holy Prophet [may peace be upon him] and the grave of Hadrat 'Uthman away from their graves).

Abu Musa. reported: I set out with the intention (of meeting) Allah's Messenger (may peace be upon him) and came to know that he had gone to the gardens (in the suburb of Medina). I followed him and found him in a garden sitting upon an elevated place round the well with his shanks uncovered which had been dangling in the well. The rest of the hadith is the same but with this variation that there is no mention of the words of Sa'id: all drew a conclusion from it pertaining to their graves."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5912]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5912

Sa'id b. al-Musayyib reported Abu Musa Ash'ari having said that Allah's Messenger (may peace be upon him) set out one day to the suburbs of Medina for reliev- ing himself. I followed his steps. The rest of the hadith is the same. Ibn Musayyib said: I concluded (from the manner of their sitting) the (order) of their graves. (The three) would be together (the graves of the Holy Prophet, Hadrat Abu Bakr and Hadrat Umar) and that of 'Uthman would be separate (from them).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5913]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5913

Amir b Sa'd b. Abi Waqqas reporte (l on the authority of his father that Allah's Messenger (may peace be upon him) addressing 'All said: You are in the same position with relation to me as Aaron- (Harun) was in relation to Moses but with (this explicit difference) that there is no prophet after me. Sa'd said: I had an earnest desire to hear it directly from Sa'd, so I met him and narrated to him what (his son) Amir had narrated to me, whereupon he said: Yes, I did hear it. I said: Did you hear it yourself? Thereupon he placed his fingers upon his ears and said: Yes, and if not, let both my ears become deaf.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5914]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5914

Sa'd b. Abi Waqqas reported that Allah's Messenger (may peace be upon him) left 'Ali b. Abi Talib behind him (as he proceeded) to the expedition of Tabuk, whereupon he ('Ali) said: Allah's Messenger, are you leaving me behind amongst women 4nd children? Thereupon he (the Holy Prophet) said: Aren't you satisfied with being unto me what Aaron was unto Moses but with this exception that there would be no prophet after me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5915]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5915

This hadith has been narrated. on the authority of Shu'ba with the same chain of transmitters. Amir b. Sa'd b. Abi Waqqas reported on the authority of his father that Muawiya b. Abi Sufyin appointed Sa'd as the Governor and said: What prevents you from abusing Abu Turab (Hadrat 'Ali), whereupon be said: It is because of three things which I remember Allah's Messenger (may peace be upon him) having said about him that I would not abuse him and even if I find one of those three things for me, it would be more dear to me than the red camelg. I heard Allah's Messenger (may peace be upon him) say about 'Ali as he left behind hrin in one of his campaigns (that was Tabuk). 'All said to him: Allah's Messenger, you leave me behind along with women and children. Thereupon Allah's Messenger (may peace be upon him) said to him: Aren't you satisfied with being unto me what Aaron was unto Moses but with this exception that there is no prophethood after me. And I (also) heard him say on the Day of Khaibar: I would certainly give this standard to a person who loves Allah and his Messenger and Allah and his Messenger love him too. He (the narrator) said: We have been anxiously waiting for it, when he (the Holy Prophet) said: Call 'Ali. He was called and his eyes were inflamed. He applied saliva to his eyes and handed over the standard to him, and Allah gave him victory. (The third occasion is this) when the (following) verse was revealed:" Let us summon our children and your children." Allah's Messenger (may peace be upon him) called 'Ali, Fitima, Hasan and Husain and said: O Allah, they are my family.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5916]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5916

Sa'd reported Allah's Apostle (may peace be upon him) as saying to 'Ali: Aren't you satisfied with being unto me what Aaron was unto Moses?


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5917]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5917

Suhail reported on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said on the Day of Khaibar: I shall certainly give this standard in the hand of one who loves Allah and his Messenger and Allah will grant victory at his hand. Umar b. Khattab said: Never did I cherish for leadership but on that day. I came before him with the hope that I may be called for this, but Allah's Messenger (may peace be upon him) called 'Ali b. Abu Talib and he conferred (this honour) upon him and said: Proceed on and do not look about until Allah grants you victory, and 'Ali went a bit and then halted and did not look about and then said in a loud voice: Allah's Messenger, on what issue should I fight with the people? Thereupon he (the Prophet) said: Fight with them until they bear testimony to the fact that there is no god but Allah and Muhammad is his Messenger, and when they do that then their blood and their riches are inviolable from your hands but what is justified by law and their reckoning is with Allah.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5918]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5918

Sahl b. Sa'd reported that Allah's Messenger (may peace be upon him) said on the Day of Khaibar: I would certainly give this standard to a person at whose hand Allah would grant victory and who loves Allah and His Messenger and Allah and His Messenger love him also. The people spent the night thinking as to whom it would be given. When it was morning the people hastened to Allah's Messenger (may peace be upon him) all of them hoping that that would be given to him. He (the Holy Prophet) said: Where is 'Ali b. Abu Talib? They said: Allah's Messenger, his eyes are sore. He then sent for him and he was brought and Allah's Messenger (may peace be upon him) applied saliva to his eyes and invoked blessings and he was all right, as if he had no ailment at all, and coraferred upon him the standard. 'Ali said: Allah's Messenger, I will fight them until they are like us. Thereupon he (the Holy Prophet) said: Advance cautiously until you reach their open places, thereafter invite them to Islam and inform them what is obligatory for them from the rights of Allah, for, by Allah, if Allah guides aright even one person through you that is better for you than to possess the most valuable of the camels.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5919]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5919

Salama b. Akwa' reported that it was 'Ali whom Allah's Apostle (may peace be upon him) left behind him (in the charge of his family and the Islamic State) on the occasion of the campaign of Khaibar, and his eyes were inflamed and he said: Is it for me to remain behind Allah's Messenger (may peace be upon him)? So he went forth and rejoined Allah's Apostle (may peace be upon him) and on the evening of that night (after which) next morning Allah granted victory. Allah's Messenger (may peace be upon him) said: I will certainly give this standard to a man whom Allah and His Messenger love. or he said: Who loves Allah or His Messenger and Allah will grant him victory through him, and, lo, we saw 'Ali whom we least expected (to be present on that occasion). They (the Companions) said: Here is 'Ali. Thereupon Allah's Messenger (may peace be upon hin) gave him the standard. Allah granted victory at his hand.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5920]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5920

Yazid b. Hayyan reported, I went along with Husain b. Sabra and 'Umar b. Muslim to Zaid b. Arqam and, as we sat by his side, Husain said to him: Zaid. you have been able to acquire a great virtue that you saw Allah's Messenger (may peace be upon him) listened to his talk, fought by his side in (different) battles, offered prayer behind me. Zaid, you have in fact earned a great virtue. Zaid, narrate to us what you heard from Allah's Messenger (may peace be upon him). He said: I have grown old and have almost spent my age and I have forgotten some of the things which I remembered in connection with Allah's Messenger (may peace be upon him), so accept whatever I narrate to you, and which I do not narrate do not compel me to do that. He then said: One day Allah's Messenger (may peace be upon him) stood up to deliver sermon at a watering place known as Khumm situated between Mecca and Medina. He praised Allah, extolled Him and delivered the sermon and. exhorted (us) and said: Now to our purpose. O people, I am a human being. I am about to receive a messenger (the angel of death) from my Lord and I, in response to Allah's call, (would bid good-bye to you), but I am leaving among you two weighty things: the one being the Book of Allah in which there is right guidance and light, so hold fast to the Book of Allah and adhere to it. He exhorted (us) (to hold fast) to the Book of Allah and then said: The second are the members of my household I remind you (of your duties) to the members of my family. He (Husain) said to Zaid: Who are the members of his household? Aren't his wives the members of his family? Thereupon he said: His wives are the members of his family (but here) the members of his family are those for whom acceptance of Zakat is forbidden. And he said: Who are they? Thereupon he said: 'Ali and the offspring of 'Ali, 'Aqil and the offspring of 'Aqil and the offspring of Ja'far and the offspring of 'Abbas. Husain said: These are those for whom the acceptance of Zakat is forbidden. Zaid said: Yes.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5921]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5921

This hadith has been narrated on the authority of Zaid b. Arqam through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5922]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5922

This hadith has been transmitted on the authority of Abu Hayyan but with this addition:" The Book of Allah contains right guidance, the light, and whoever adheres to it and holds it fast, he is upon right guidance and whosoever deviates from it goes astray.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5923]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5923

Yazid b. Hayyan reported: We went to him (Zaid b. Arqam) and said to him. You have found goodness (for you had the honour) to live in the company of Allah's Messenger (may peace be upon him) and offered prayer behind him, and the rest of the hadith is the same but with this variation of wording that lie said: Behold, for I am leaving amongst you two weighty things, one of which is the Book of Allah, the Exalted and Glorious, and that is the rope of Allah. He who holds it fast would be on right guidance and he who abandons it would be in error, and in this (hadith) these words are also found: We said: Who are amongst the members of the household? Aren't the wives (of the Holy Prophet) included amongst the members of his house hold? Thereupon he said: No, by Allah, a woman lives with a man (as his wife) for a certain period; he then divorces her and she goes back to her parents and to her people; the members of his household include his ownself and his kith and kin (who are related to him by blood) and for him the acceptance of Zakat is prohibited.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5924]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5924

Sahl b. Sa'd reported that a person from the offspring of Marwan was appointed as the governor of Medina. He called Sahl b. Sa'd and ordered him to abuse All Sahl refused to do that. He (the governor) said to him: If you do not agree to it (at least) say: May Allah curse Abu Turab. Sahl said: There was no name dearer to All than Abu Turab (for it was given to him by the Holy Prophet himself) and he felt delighted when he was called by this name. He (the governor) said to him: Narrate to us the story of his being nanied as Abu Turab. He said: Allah's Messenger (may peace be upon him) came to the house of Fatima and he did not find 'Ali in the house; whereupon he said: Where is your uncle's son? She said: (There cropped up something) between me and him which had annoyed him with me. He went out and did not rest here. Allah's Messenger (may peace be upon him) said to a person to find out where he was. He came and said: Allah's Messenger, he is sleeping in the mosque. Allah's Messenger (may peace be upon him) came to him and found him lying in the mosque and saw that his mantle had slipped from his back and his back was covered with dust and Allah's Messenger (may peace be upon him) began to wipe it away from him (from the body of Hadrat 'Ali) saying: Get up, covered with dust; get up, covered with dust.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5925]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5925

'A'isha reported that Allah's Messenger (may peace he upon him) lay on bed during one night and said: Were there a pious person from amongst my companions who should keep a watch for me during the nightt? She said: We heard the noise of arms, whereupon Allah's Messenger (may peace be upon him) said: Who is it? And Sa'd b. Abi Waqqas said: Allah's MesseDger. I have come to serve as your sentinel. 'A'isha said: Allah' s Messenger (may peace be upon him) slept (such a sound sleep) that I heard the noise of his snoring.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5926]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5926

'A'isha reported that Allah's Messenger (may peace he upon him) laid down on bed during one night on his arrival at Medina and said: Were there a pious person from amongst my Companions who should keep a watch for me durin. the night? She (A'isha) reported: We were in this state that we heard the clanging noise of arms. lie (the Holy Prophet) said: Who is it? He said: This is Sa'd b. Abi Waqqas. Allah's Messenger (may peace be upon him) said to him: What brings you here? Thereupon he said: I harboured fear (lest any harm should come to) Allah's Messenger (may peace be upon him), so I came to serve as your sentinel. Allah's Messenger (may peace be upon him) invoked blessings upon him. He then slept. This hadith has been transmitted on the authority of Ibn Rumh with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5927]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5927

'Abdullah b. 'Amir b. Rabi reported A'isha as saying: Allah's Messenger (may peace be upon him) went to bed one night; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5928]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5928

'Abdullah b. Shaddad reported that he heard 'Allahs saying: Allah's Messenger (may peace be upon him) did not gather his parents except in case of Sa'd b. Malik that he said to him on the Day of Ubud: Shoot an arrow, may my father and mother be taken as ransom for you.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5929]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5929

This hadith has been narrated on the authority of 'Ali through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5930]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5930

Sa'd b Abi Waqqqs said: Allah's Messenger (may peace he upon him) gathered his parents for me on the Day of Uhud.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5931]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5931

This hadith has been narrated on the authority of Yabyl b. Sa'id with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5932]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5932

'Amir b. Sa'd reported oLi the authority of his father that Allah's Apostle (may peace be upon him) gathered for him on the Day of Uhud his parents when a polytheist had set fire to (i. e. attacked fiercely) the Muslims. Thereupon Allah's Apostle (may peace be upon him) said to him: (Sa'd), shoot an arrow, (Sa'd), may my mother and father be taken as ransom for you. I drew an arrow and I shot a featherless arrow at him aiming his side that lie fell down and his private parts were exposed. Allah's Messenger (may peace be upon him) laughed that I saw his front teeth.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5933]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5933

Mus'ab b. Sa'd reported on the authority of his father that many verses of the Qur'an had been revealed in connection with him. His mother Umm Sa'd had taken oath that she would never talk with him until he abandoned his faith and she neither ate nor drank and said: Allah has commanded you to treat well your parents and I am your mother and I command you to do this. She passed three days in this state until she fainted because of extreme hunger and at that time her son whose name was Umara stood up and served her drink and she began to curse Sa'd that Allah, the Exalted and Glorions, revealed these verses of the Holy Qur'an:" And We have enjoined upon a person goodness to his parents but if they contend with thee to associate (others) with Me of which you have no knowledge, then obey them not" (xxix. 8) ; Treat thein with customary good in this world" (xxxi. 15). He also reported that there fell to the lot of Allah's Messenger (may peace be upon him) huge spoils of war and there was one sword in them. I picked that up and came to Allah's Messenger (may peace be upon him) and said: Bestow this sword upon me (as my share in the spoils of war) and you know my state. Thereupon he said: Return it to the place from where you picked it up. I went back until I decided to throw it in a store but my soul repulsed me so I came back and asked him to give that sword to me. He said in a loud voice to return it to the place from where I had picked it up. It was on this occasion that this verse was revealed:" They asked about the spoils of war" (viii. 1). He further said: I once fell ill and sent a message to Allah's Apostle (may peace be upon him). He visited me and I said to him: Permit me to distribute (in charity) my property as much as I like. He did not agree. I said: (Permit me to distribute) half of it. He did not agree. I said: (Permit me to distribute) the third part, whereupon he kept quiet and it was after this (that the distribution of one's property in charity) to the extent of one-third was held valid. He further said: I came to a group of persons of the Ansir and Muhajirin and they said: Come, so that we may serve you wine, and it was before the use of wine had been prohibited. I went to them in a garden and there had been with them the roasted head of a camel and a small water-skin containing wine. I ate and drank along with them and there came under discussion the Ansr (Helpers) and Muhajirin (immigrants). I said: The immigrants are better than the Ansar, that a person picked up a portion of the head (of the camel and struck me with it that my nose was injured. I came to Allah's Messenger (may peace be upon him) and informed him of the situation that Aliah, the Exalted and Glorious, revealed verses pertaining to wine:" Intoxicants and the games of chance and (sacrificing to) stones set up and (divining by) arrows are only an uncleanliness, the devil's work" (v. 90).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5934]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5934

This hadith has been transmitted on the authority of Simak and the hadith transmitted on the authority of Shu'ba (the words are): When they intended to feed her (Sa'd'. s mother), they opened her mouth with the help of a stick and then put the feed in her mouth, and in the same hadith the words are: He struck the nose of Sa'd and it was injured and Sa'd had (the mark) of wound on his nose.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5935]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5935

Sa'd reported: This verse was revealed in relation to six persons and I and Ibn Mas'ud were amongst them. The polytheists said to him (the Holy Prophet): Do not keep such persons near you. It was upon this that (this verse was revealed):" Drive not away those who call upon their Lord morning and evening desiring only His pleasure" (vi. 52).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5936]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5936

Sa'd reported: We were six men in the company of Allah's Messenger (, nay peace be upon him) that the polytheists said to Allah's Apostle (may peace be upon him): Drive them away so that they may not be overbold upon us. He said: I, Ibn Mas'ud and a person from the tribe of Hudhail, Bilal and two other persons, whose names I do not know (were amongst such persons). And there occurred to Allah's Messenger (may peace be upon him) what. Allah wished and he talked with himself that Allah, the Exalted and Glorious, revealed:" Do not drive away those who call their Lord morning and evening desiring to seek His pleasure."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5937]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5937

Abu 'Uthman reported on one of the days when Allah's Messenger (may peace be upon him) was fighting and none remained with him save Talha and Sa'd.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5938]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5938

Jabir b. Abdullah reported: I heard Allah's Messenger (may peace be upon him) exhorting people on the Day of the Battle of the Ditch to fight. Zubair said: I am ready (to participate). He then again exhorted and he again said: I am ready to participate. Thereupon Allah's Messenger (may peace be upon him) said: Behold. for every Prophet there is a helper and my helper is Zubair.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5939]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5939

Jabir reported this hadith through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5940]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5940

'Abdullah b. Zubair reported on the Day of the Battle of the Trench: I and Umar b. Abu Salama were with women folk in the fort of Hassan (b. Thabit). He at one time leaned for me and I cast a glance and at anothertime I leaned for him and he would see and I recognised my father as he rode on his horse with his arms towards the tribe of Quraizah. 'Abdullah b. 'Urwa reported from Abdullah b. Zubair: I made a mention of that to my father, whereupon he said: My son, did you see me (on that occasion)? He said: Yes. Thereupon he said: By Allah, Allah's Messenger (may peace be upon him) addressed me saying: I would sacrifice for thee my father and my mother.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5941]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5941

'Abdullah b. Zubair reported: When it was the Day of the Battle of the Ditch I and 'Umar b. Salama were in the fort in which there were women, i. e. the wives of Allah's Apostle (may peace be upon him) ; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5942]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5942

Abu Huraira reported: Allah's Messenger (may peace be upon him) was upon the mountain of Hira, ' and there were along with him Abu Bakr, Umar, Uthman. 'Ali, Talha, 'Zubair, that the mountain stirred; thereupon Allah's Messenger (may peace be upon him) said: Be calm, there is none upon you but a Prophet, a Fiddle (the testifier of truth) and a Martyr.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5943]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5943

Abu Huraira reported that Allah's Messenger (may peace be upon him) was on the mountain of Hira' that it stirred; thereupon Allah's Messenger (may peace be upon him) said: Hira! be calm, for there is none upon you but a Prophet, a Siddiq, a Shahid, and there were upon it Allah's Prophet (may peace be upon him), Abu Bakr, 'Umar, Uthman, 'Ali, Talha, Zubair, Sa'd b. Abi Waqqas (Allah be pleased witli them).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5944]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5944

Hisham reported on the authority of his father ('Urwa b. Zubair) that A'isha said: BY Allah, both fathers of yours are amongst those who have been men. tioned in this verse:" Those who responded to the call of Allah and the Messenger after the misfortune had fallen upon thein".


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5945]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5945

This hadith has been narrated on the authority of Hishan through the same chain of transmitters but with this addition (that by both fathers of yours) he meant Abu Bakr and Zubair.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5946]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5946

'Urwa reported: 'Aisha said to me: Your fathers (Zubair and Abu Bakr) were amongst those about whom (it has been revealed):" Those who responded to the call of Allah and His Messenger after the misfortune had fallen upon them."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5947]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5947

Anas reported Allah's Messenger (may peace be upon him) as saying: For every Umma there is a man of trust and the man of trust of this Umma is Abu 'Ubaida b. Jarrah.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5948]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5948

Anas reported that the people of Yemen came to Allah's Messenger (may peace be upon him) and said: Send with us a person who should teach us Sunnah and al-Islam, whereupon he (the Holy Prophet) caught hold of the hand of Ubaida and said: He is a man of trust of this Umma.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5949]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5949

Hudhaifa reported that the people of Najran came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, send along with us a man of trust; whereupon he said: I would definitely send to you a man of trust, a man of trust in the true sense of the term. Thereupon his Companions looked up eagerly and he sent Abu Ubaida b. Jarrah.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5950]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5950

This hadith has been reported on the authority of Abu Ishaq with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5951]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5951

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying to Hasan: O Allah, behold, I love him. Thou too love him and love one who loves him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5952]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5952

Abu Huraira reported: I went along with Allalh's Messenger (may peace be upon him) at a time during the day but he did not talk to me and I did not talk to him until he reached Bazar of Banfi Qainuqal. He came back to the tent of Fatima and said: Is the little chap (meaning Hasan) there? We were under the impression that his mother had detained him in order to bathe him and dress him and garland him with a sweet garland. Not much time had passed that he (Hasan) came running until both of them embraced each other, thereupon Allah's Messenger (may peace be upon him) said: O Allah, I love him; love him Thou and love one who loves him (Hasan).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5953]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5953

Al-Bara' b. Azib reported: I saw Hasan b. 'Ali upon the shoulders of Allah's Apostle (may peace be upon him) and he was saying: O Allah, I love him, and love him Thou.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5954]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5954

Iyas reported on the authority of his father: I (had the honour of) leading the white mule on which rode Allah's Apostle (may peace be upon him) and with him were Hasan and Husain, till it reached the apartment of Allah's Apostle (may peace be upon him). The one amongst them was seated before him and the other one was seated behind him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5955]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5955

'A'isha reported that Allah's Apostle (may peace be upon him) went out one norning wearing a striped cloak of the black camel's hair that there came Hasan b. 'Ali. He wrapped hitn under it, then came Husain and he wrapped him under it along with the other one (Hasan). Then came Fatima and he took her under it, then came 'Ali and he also took him under it and then said: Allah only desires to take away any uncleanliness from you, O people of the household, and purify you (thorough purifying)


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5956]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5956

Salim b. 'Abdullah reported on the authority of his father: We were in the habit of calling Zaid b. Harith as Zaid b. Muhammad until it was revealed in the Qur'an:" Call them by the names of their fathers. This is more equitable with Allah" (This hadith has been transmitted on the authority of Qutaiba b. Sa'd)


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5957]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5957

This hadith has been narrated on the authority 'Abdullah through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5958]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5958

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) sent an expedition and appointed Usama b. Zaid as its chief. The people objected to his command, whereupon Allah's Messenger (may peace be upon him) stood up and said: You object to his command and before this you objected to the command of his father (Zaid). By Allah, he was fit as the commander and he was one of the dearest of persons to me and after him, behold! this one (Usama) is one of the dearest of persons to me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5959]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5959

Salim reported on the authority of his father that Allah's Messenger (may peace be upon him) said on the pulpit: You object to the command of Usima b. Zaid as you had objected before to the command of his father (Zaid). By Allah, he was most competent for it and, by Allah, he was dearest to me amongst people and, by Allah, the same is the case with Usama b. Zaid. He is most dear to me after him and I advise you to treat him well for he is pious amongst you.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5960]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5960

Abdullah b. Abu Mulaika reported that Abdullah b. Jafar said to Ibn Zubair: Do you remember (the occasion) when we three (i. e. I, you and lbn 'Abbas) met Allah's Messenger (may peace be upon him) and he mounted us (on his camel) but left you? He said: Yes.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5961]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5961

This hadith has been transmitted on the authority of Habib b. Ash-Shahid.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5962]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5962

Abdullah b. Ja'far reported that when Allah's Messenger (may peace be, upon him) came back from a journey, the children of his family used to accord him welcome. It was in this way that once he came back from a journey and I went to him first of all. He mounted me before him. Then there came one of the two sons of Fatima and he mounted him behind him and this is how we three entered Medina riding on a beast.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5963]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5963

Abdullah b. Ja'a'far reported that when Allah's Messenger (may peace be upon him) came back from a journey he met us. Once he met me, Hasan or Husain, and he mounted one of us before him and the other one behind him until we entered Medina.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5964]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5964

Abdullah b. Ja'far reported that one day Allah's Messenger (may peace be upon him) mounted me behind him and narrated to me something in secret which I would narrate to none amongst people.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5965]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5965

Abdullah b. Ja'far reported that he heard 'All say in Kulfa that Allah's Messenger (may peace be upon him) said: The best of the women of her time was Mary, daughter of 'Imran, and the best of the women of her time was Khadija, daughter of khuwailid. Abu Kuraib said that Wakil pointed towards the sky and the earth


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5966]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5966

Abu Musa reported Allali's Messenger (may peace be upon him) as saying: There are many persons amongst men who are quite perfect but there are not perfect amongst women except Mary, daughter of 'Imran, Asiya wife of Pharaoh, and the excellence of 'A'isha as compared to women is that of Tharid over all other foods.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5967]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5967

Abu Huraira reported that Gabriel came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, lo. Khadija is coming to you with a vessel of seasoned food or drink. When she comes to you, offer her greetings from her Lord, the Exalted and Glorious, and on my behalf and give her glad tidings of a palace of jewels in Paradise wherein there is no noise and no toil. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5968]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5968

Ismail reported: I said to 'Abdullah b. Abi Aufa: Did Allah's Messenger (may peace be upon him) give glad tidings of Paradise to Khadija? He said: Yes. He did give glad tidings to her of a palace of jewels in Paradise wherein there would be no noise and no toil.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5969]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5969

This hadith has been narrated on the a tliority of Ibn Abi Aufa through other chains of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5970]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5970

'A'isha reported that Allali's, Messenger (may peace he upon him) gave grid tidings to Khadija int Khuwailid of a palace in Paradise.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5971]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5971

'A'isha reported: Never did I feel jealous of any woman as I was jealous of Khadija. She had died three years before he (the Holy Prophet) married me. I often heard him praise her, and his lord, the Exalted and Glorious, had commanded him to give her the glad tidings of a palace of jewels in Paradise: and whenever he slaughtered a sheep he presented (its meat) to her female companions.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5972]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5972

'A'isha reported: Never did I feel jealous of the wives of Allah's Apostle (may peace be upon him) but in case of Khadija, although I did no, (have the privilege to) see her. She further added that whenever Allah's Messenger (may peace be upon him) slaughtered a sheep, he said: Send it to the companions of Khadija I annoyed him one day and said: (It is) Khadija only who always prevails upon your mind. Thereupon Allah's Messenger (may peace be upon him) said: Her love had been nurtured in my heart by Allah Himself.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5973]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5973

This hadith has been transmitted on the authority of Abu Usama up to the slaughtering of a sheep, but he. did not make mention of the subsequent words.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5974]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5974

'A'isha reported: Never did I feel jealous of any wife amongst the wives of Allah's Apostle (may peace be upon him) as I feel in case of Khadija (though I had never seen her), for he praised her very often.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5975]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5975

'A'isha reported that Allah's Apostle (may peace be upon him) did not marry any other woman till her (Khadija's) death.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5976]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5976

A'isha reported that Hala b. Khuwailid (sister of Khadija) sought permission from Allah's Messenger (may peace be upon him) to see him and he was reminded of Khadija's (manner of) asking leave to enter and (was overwhelmed) with emotions thereby and said: O Allah, it is Hala, daughter of Khuwailid, and I felt jealous and said: Why do you remember one of those old women of the Quraish with gums red and who is long dead-while Allah has given you a better one in her stead?


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5977]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5977

'A'isha reported Allah's Messenger (may peace be upon him) having said: I saw you in a dream for three nights when an angel brought you to me in a silk cloth and he said: Here is your wife, and when I removed (the cloth) from your face, lo, it was yourself, so I said: If this is from Allah, let Him carry it out.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5978]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5978

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5979]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5979

'A'isha reported: Allah's Messenger (may peace be upon him) said to me: I can well discern when you are pleased with me and when you are annoyed with me. I said: How do you discern it? Thereupon be said: When you are pleased with me you say;" No, by the Lord of Muhammad," and when you are annoyed with me, you say:" No, by the Lord of Ibrahim." I said: Allah's Messenger, by Allah, I in fact leave your name (when I am annoyed with you).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5980]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5980

This hadith has been reported on the authority of Hishim b. 'Urwa with the same chain of transmitters up to the words:" No, by the Lord of Ibrahim," and he did not make mention of what follows subsequently.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5981]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5981

'A'isha reported that she used to play with dolls in the presence of Allah's Messenger (may peace be upon him) and when her playmates came to her they left (the house) because they felt shy of Allah's Messenger (may peace be upon him), whereas Allah's Messenger (may peace be upon him) sent them to her.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5982]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5982

This hadith has been narrated on the authority of Hisham with the same chain of transmitters with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5983]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5983

'A'isha reported that people sent their gifts when it was the turn of 'A'isha seeking thereby the pleasure of Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5984]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5984

'A'isha, the wife of Allah's Apostle (may peace be upon him), said: The wives of Allah's Apostle (may peace be upon him) sent Fatima, the daughter of Allah's Messenger (may peace be upon him), to Allah's Apostle (may peace be upon him). She ouaht permission to get in as he had been lying with me in my mantle. He gave her permission and she said: Allah's Messenger, verily, your wives have sent me to you in order to ask you to observe equity in case of the daughter of Abu Quhafa. She ('A'isha) said: I kept quiet. Thereupon Allah's Messenger (may peace be upon him) said to her (Fatima): 0 daughter, don't you love whom I love? She said: Yes, (I do). Thereupon he said: I love this one. Fatima then stood up as she heard this from Allah's Messenger (may peace be upon him) and went to the wives of Allatt's Apostle (may peace be upon him) and informed them of what she had said to him and what Allah's messenger (may peace be upon him) had said to her. Thereupon they said to her: We think that you have been of no avail to us. You may again go to Allah's Messenger (may peace be upon him) and tell him that his wives seek equity in case of the daughter of Abu Quhafa. Fitima said: By Allah, I will never talk to him about this matter. 'A'isha (further) reported: The wives of Allah's Apostle (may peace be upon him) then sent Zainab b. jahsh, the wife of Allah's Apostle (may peace be upon him), and she was one who was somewhat equal in rank with me in the eyes of Allah's Messenger (may peace be upon him) and I have never seen a woman more advanced in religious piety than Zainab, more God-conscious, more truthful, more alive to the ties of blood, more generous and having more. sense of self-sacrifice in practical life and having more charitable disposition and thus more close to God, the Exalted, than her. She, however, lost temper very soon but was soon calm. Allah's Messenger (may peace be upon him) permitted her to enter as she ('A'isha) was along with Allah's Messenger (may peace be upon him) in her mantle, in the same very state when Fatima had entered. She said: Allah's Messenger, your wives have sent me to you seeking equity in case of the daughter of Abu Quhafa. She then came to me and showed harshness to me and I was seeing the eyes of Allah's Messenger (may peace be upon him) whether he would permit me. Zainab went on until I came to know that Allah's Messenger (may peace be upon him) would not disapprove if I retorted. Then I exchanged hot words until I made her quiet. Thereupon Allah's Messenger (may peace be upon him) smiled and said: She is the daughter of Abu Bakr. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters, but with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5985]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5985

'A'isha reported that Allah's Messenger (may peace be upon him) during his last illness) inquired: Where I would be tomorrow, where I would be tomorrow (thinking, that the turn of 'A'isha was not very near) and when it was my turn, Allah called him to his Heavenly Home and his head was between my neck and chest.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5986]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5986

A'isha reported that Allah's Messenger (may peace be upon him) at the time of breathing his last was reclining against her chest and she was leaning over him and listening to him as he was saying: O Allah, grant me pardon, show mercy to me, enjoin me to companions (on High).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5987]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5987

This hadith has been narrated on the authority of Hisham through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5988]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5988

'A'isha reported: I heard that never a prophet dies until he is given an option to opt the life of (this) world or that of the Hereafter. She further said: I heard Allah's Messenger (may peace be upon him) say in his last illness in which he' died. I heard him saying in gruffness of the voice: Along with those persons upon whom Allah bestowed favours from amongst the Apostles, the testifiers of truth, the martyrs, the pious and goodly company are they (iv. 69). (It was on bearing these words) that I thought that he had been given choice (and he opted to live with these pious persons in the Paradise).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5989]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5989

This hadith has been narrated on the authority of Sa'd with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5990]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5990

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that he used to say: Never a prophet dies in a state that he is not made to see his abode in Paradise, and then given a choice. 'A'isha said that when Allah's Messenger (may peace be upon him) was about to leave the world, his head was over her thigh and he had fallen into swoon three times. When he felt relief his eyes were fixed at the ceiling. He then said: O Allah, along with the high companions (i. e. along with the Apostles who live in the most elevated place of the Paradise). (On hearing these words), I then said (to myself) He is not going to opt us and I remembered a hadith which he had narrated to us as he was healthy and in which he said: No prophet dies until he sees his abode in Paradise, he is then given a choice. 'A'isha said: These were the last words which Allah's Messenger (may peace be upon him) spoke (the words are): O Allah, with companions on High.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5991]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5991

'A'isha reported that when Allah's Messenger (may peace be upon him) set ont on a journey, he used to cast lots amongst his wives. Once this lot came out in my favour and that of Hafsa. They (Hafsi, and 'A'isha) both went along with him and Allah's Messenger (may peace be upon him) used to travel (on camel) when it was night along with 'A'isha and talked with her. Hafsa said to 'A'isha: Would you like to ride upon my camel tonight and allow me to ride upon your camel and you would see (what you do not generally see) and I would see (what I do not see) generally? She said: Yes. So 'A'isha rode upon the camel of Hafsa and Hafsa rode upon the camel of 'A'isha and Allah's Messenger (may peace be upon him) came near the camel of 'A'isha. (whereas) Hafsa had been riding over that. He greeted her and then rode with her until they came down. She ('A'isha) thus missed (the company of the Holy Prophet) and when they sat down, 'A'isha felt jealous. She put her foot in the grass and said: O Allah, let the scorpion sting me or the serpent bite me. And so far as thy Messenger is concerned, I cannot say anything about him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5992]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5992

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: The excellence of 'A'isha over women is like the excellence of Tharid over all other foods.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5993]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5993

This hadith has been narrated on the authority of Anas b. Malik through other chains of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5994]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5994

'A'isha reported that Allah's Messenger (may peace be upon him) said to her: Gabriel offered you greetings and I said: So there should be peace and mercy of Allah upon him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5995]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5995

This hadith has been narrated on the authority of 'A'isha through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5996]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5996

This hadith has been narrated on the authority of Zakriyya' through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5997]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5997

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said: 'A'isha, here is Gabriel offering you greetings. She said: 1 made a reply: Let there be peace and blessings of Allah upon him, and added: He sees what I do not see.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5998]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5998

'A'isha reported that (one day) there sat together eleven women making an explicit promise amongst themselves that they would conceal nothing about their spouses. The first one said: My husband is a sort of the meat of a lean camel placed at the top of a hill, which it is difficult to climb up, nor (the meat) is good enough that one finds in oneself the urge to take it away (from the top of that mountain).

The second one said: My husband (is so bad) that I am afraid I would not be able to describe his faults-both visible and invisible completely.

The third one said: My husband is a long-statured fellow (i. e. he lacks intelligence). If I give vent to my feelings about him, he would divorce me, and if I keep quiet I would be made to live in a state of suspense (neither completely abandoned by him nor entertained as wife).

The fourth one said: My husband is like the night of Tihama (the night of Hijaz and Mecca), neither too cold nor hot, neither there is any fear of him nor grief.

The fifth one said: My husband is (like) a leopard as he enters the house, and behaves like a lion when he gets out, and he does not ask about that which he leaves in the house.

The sixth one said: So far as my husband is concerned, he eats so much that nothing is left back and when he drinks he drinks that no drop is left behind. And when he lies down he wraps his body and does not touch me so that he may know my grief.

The seventh one said: My husband is heavy in spirit, having no brightness in him, impotent, suffering from all kinds of conceivable diseases, heaving such rough manners that he may break my head or wound my body, or may do both.

The eighth one said: My husband is as sweet as the sweet-smelling plant, and as soft as the softness of the hare.

The ninth one said: My husband is the master of a lofty building, long-statured, having heaps of ashes (at his door) and his house is near the meeting place and the inn.

The tenth one said: My husband is Malik, and how fine Malik is, much above appreciation and praise (of mine). He has many folds of his camel, more in number than the pastures for them. When they (the camels) hear the sound of music they become sure that they are going to be slaughtered.

The eleventh one said: My husband is Abu Zara'. How fine Abu Zara' is! He has suspended in my ears heavy ornaments and (fed me liberally) that my sinews and bones are covered with fat. So he made me happy. He found me among the shepherds living in the side of the mountain, and he made me the owner of the horses, camels and lands and heaps of grain and he finds no fault with me. I sleep and get up in the morning (at my own sweet will) and drink to my heart's content. The mother of Abu Zara', how fine is the mother of Abu Zara'! Her bundles are heavily packed (or receptacles in her house are filled to the brim) and the house quite spacious. So far as the son of Abu Zara' is concerned, his bed is as soft as a green palm-stick drawn forth from its bark, or like a sword drawn forth from its scabbard, and whom just an arm of a lamb is enough to satiate. So far as the daughter of Abu Zara' is concerned, how fine is the daughter of Abu Zara', obedient to her father, obedient to her mother, wearing sufficient flesh and a source of jealousy for her co-wife. As for the slave-girl of Abu Zara', how fine is she; she does not disclose our affairs to others (outside the four walls of the house). She does not remove our wheat, or provision, or take it forth, or squander it, but she preserves it faithfully (as a sacred trust). And she does not let the house fill with rubbish. One day Abu Zara' went out (of his house) when the milk was churned in the vessels, that he met a woman, having two children like leopards playing with her pomegranates (chest) under her vest. He divorced me (Umm Zara') and married that woman (whom Abu Zara') met on the way. I (Umm Zara') later on married another person, a chief, who was an expert rider, and a fine archer: he bestowed upon me many gifts and gave me one pair of every kind of animal and said: Umm Zara', make use of everything (you need) and send forth to your parents (but the fact) is that even if I combine all the gifts that he bestowed upon me, they stand no comparison to the least gift of Abu Zara'.

'A'isha reported that Allah's Messenger (may peace be upon him) said to me: I am for you as Abu Zara' was for Umm Zara'.

This hadith has been transmitted on the authority of Hisham b. 'Urwa but with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.5999]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 5999

Miswar b. Makhramali reported that he heard Allah's Messenger (may peace be upon him) say, as he sat on the pulpit: The sons of Hisham b. Mughira have asked my permission to marry their daughter with 'Ali b. Abi Talib (that refers to the daughter of Abu Jahl for whom 'All had sent a proposal for marriage). But I would not allow them, I would not allow them, I would not allow them (and the only alternative possible is) that 'Ali should divorce my daughter (and then marry their daughter), for my daughter is part of me. He who disturbs her in fact disturbs me and he who offends her offends me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6000]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6000

Miswar b. Makhramah reported Allah's Messenger (may peace be upon him) as saying: Fatima is a part of me. He in fact tortures me who tortures her.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6001]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6001

(Imam Zain-ul-'Abidin) 'Ali b. Husain reported that when they came to Medina from Yazid b. Mu'awiya after the martyrdom of Husain b. 'Ali (Allah be pleased with him) Miswar b. Makhramah met him and said to him: Is there any work for me which you ask me to do? I said to him: No. He again said to me: Would you not give me the sword of Allah's Messenger (may peace be upon him) for I fear that the people may snatch it from you? By Allah, if you give that to me, no one would be able to take it away, so long as there is life in me. Verily 'Ali b. Abi Talib sent a proposal of marriage to the daughter of Abu Jahl in spite of (the fact that his wife) Fatima (had been living in his house). Thereupon I heard Allah's Messenger (may peace be upon him) say while addressing the people on the pulpit. I was adolescing in those days. He said: Fatima is a part of me and I fear that she may be put to trial in regard to religion. He then made a mention of his son-in law who had been from the tribe of 'Abd Shams and praised his behaviour as a son-in-law and said: Whatever he said to me he told the truth and whatever he promised he fulfilled it for me. I am not going to declare forbidden what is lawful and make lawful what is forbidden, but, by Allah, the daaghter of Allah's Messenger and the daughter of the enemy of Allah can never be combined at one place.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6002]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6002

'Ali b. Husain reported that Miswar b. Makhramah informed him that 'Ali b. Abi Talib sent the proposal of marriage to the daughter of Abu Jahl as he had Fatima, the daughter of Allah's Messenger (may peace be upon him), (as his wife). When Fatima heard about it, she came to Allah's Apostle (may peace be upon him) and said: The people say that you never feel angry on account of your daughters and now 'Ali is going to marry the daughter of Abu Jahl. Makhramah said: Thereupon Allah's Messenger (may peace be upon him) rose up and I heard him reciting Tashahhud and say: Now to the point. I gave a daughter of mine (Zainab) to Abu'l-'As b. Rabi, and he spoke to me and spoke the truth. Verily Fatima, the daughter of Muhammad, is a part of me and I do not approve that she may be put to any trial and by Allah, the daughter of Allah's Messenger cannot be combined with the daughter of God's enemy (as the co-wives) of one person. Thereupon 'Ali gave up (the idea of his intended) marriage. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6003]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6003

'A'isha reported that Allah's Messenger (may peace be upon him) called his daughter Fatima (during his last illness). He said. to her something secretly and she wept. He again said to her something secretly and she laughed. 'A'isha further reported that she said to Fatima: What is that which Allah's Messenger (may peace be upon him) said to you secretly and you wept and then said to you something secretly and you laughed? Thereupon she said: He informed me secretly of his death and so I wept. He then again informed me secretly that I would be the first amongst the members of his family to follow him and so I laughed.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6004]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6004

'A'isha reported: We, the wives of Allah's Apostle (may peace be upon him), were with him (during his last illness) and none was absent therefrom that Fatima, who walked after the style of Allah's Messenger (may peace be upon him), came there, and when he saw her he welcomed her saying: You are welcome, my daughter. He their made her sit on his right side or on his left side. Then he said something secretly to her and she wept bitterly and when he found her (plunged) in grief he said to her something secretly for the second time and she laughed. I ('A'isha) said to her: Allah's Messenger has singled you amongst the women (of the family) for talking (to you something secretly) and you wept. When Allah's Messenger (may peace be upon him) recovered from illness, I said to her. What did Allah's Messenger (may peace be upon him) say to you? Thereupon she said: I am not going to disclose the secret of Allah's Messenger (may peace be upon him). When Allah's Messenger (may peace be upon him) died, I said to her: I adjure you by the right that I have upon you that you should narrate to me what Allah's Messenger (may peace be upon him) said to you. She said: Yes, now I can do that (so listen to it). When he talked to me secretly for the first time he informed me that Gabirel was in the habit of reciting the Qur'an along with him once or twice every year, but this year it had been twice and so he perceived his death quite near, so fear Allah and be patient (and he told me) that he would be a befitting forerunner for me and so I wept as you saw me. And when he saw me in grief he talked to me secretly for the second time and said: Fatima, are you not pleased that you should be at the head of the believing women or the head of this Umma? I laughed and it was that laughter which you saw.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6005]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6005

'A'isha reported that all the wives of Allah's Apostle (may peace be upon him) had gathered (in her apartment) during the days of his (Prophet's) last illness and no woman was left behind that Fatima, who walked after the style of Allah's Messenger (may peace be upon him), came there. He welcomed her by saying: You are welcome, my daughter, and made her sit on his right side or on his left side, and then talked something secretly to her and Fitima wept. Then he talked something secretly to her and she laughed. I said to her: What makes you weep? She said; I am not going to divulge the secret of Allah's Messenger (may peace be upon him). I ('A'isha) said: I have not seen (anything happening) like today, the happiness being more close to grief (as I see today) when she wept. I said to her: Has Allah's Messenger (may peace be upon him) singled you out for saying something leaving us aside? She then wept and I asked her what he said, and she said: I am not going to divulge the secrets of Allah's Messenger (may peace be upon him). And when he died I again asked her and she said that he (the Holy Prophet) told her: Gabriel used to recite the Qur'an to me once a year and for this year it was twice and so I perceived that my death had drawn near, and that I ('A'isha) would be the first amongst the members of his family who would meet him (in the Hereafter). He shall be my good forerunner and it made me weep. He again talked to me secretly (saying): Arn't you pleased that you should be the sovereign amongst the believing women or the head of women of this Umma? And this made me laugh.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6006]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6006

Salman reported: In case it lies in your power don't be one to enter the bazar first and the last to get out of that because there is a bustle and the standard of Satan is set there. He said: I was informed that Gabriel (Allah be pleased with him) came to Allah's Apostle (may peace be upon him) and there was with him Umin Salama and he began to talk with him. He then stood up, whereupon Allah's Apostle (may peace be upon him) said to Umm Salama: (Do you know) who was he and what did he say? She said: He was Dihya (Kalbi). He reported Umm Salama having said: By Allah, I did not deem him but only he (Dihya) until I heard the address of Allah's Apostle (may peace be upon him) informing him about us. He (the narrator) said: I said to Uthman: From whom did you hear it? He said: From Usima b. Zaid.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6007]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6007

'A'isha, the Mother of the Faithful, reported that Allah's Messenger (may peace be upon him) said: One who has the longest hands amongst you would meet me most immediately. She farther said: They (the wives of Allah's Apostle) used to measure the hands as to whose hand was the longest and it was the hand of Zainab that was the longest amongst them, as she used to work with her hand and Spend (that income) on charity.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6008]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6008

Anas reported that Allah's Messenger (may peace be upon him) went to Umm Aiman and I went along with him and she served him a drink in a vessel and he reported that the narrator said: I do not know whether it was because of the fasting (or for any other reason) that he (the Holy Prophet) refused to accept that. She raised her voice and showed annoyance to him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6009]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6009

Anas reported that after the death of Allah's Messenger (may peace be upon him) Abu Bakr said to 'Umar: Let us visit Umm Aiman as Allah's Messenger (may peace be upon him) used to visit her. As we came to her, she wept. They (Abu Bakr and Umar) said to her: What makes you weep? What is in store (in the next world) for Allah's-Messenger (may peace be upon him) is better than (this worldly life). She said: I weep not because I am ignorant of the fact that what is in store for Allah's Messenger (may peace be upon him) (in the next world) is better than (this world), but I weep because the revelation which came from the Heaven has ceased to come. This moved both of them to tears and they began to weep along with her.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6010]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6010

Anas reported that Allah's Apostle (may peace be upon him) did not enter the house of any woman except that of his wives and that of Umm Sulaim. He used to visit her. It was said to him why it was so, whereupon he said: I feel great compassion for her. Her brother was killed while he was with me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6011]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6011

Anas reported that Allah's Apostle (may peace be upon him) said: I entered Paradise and heard the noise of steps. I said: Who is it? They said: She is Ghumaisa, daughter of Milhan, the mother of Anas b. Malik.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6012]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6012

Jabir b. 'Abdullah reported: I was shown Paradise and I saw the wife of Abu Talha (i. e. Umm Sulaim) and I heard the noise of steps before me and, lo, it was that of Bilal.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6013]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6013

Anas reported that the son of Abu Talba who was born of Umm Sulaim died. She (Umm Sulaim) said to the members of her family: Do not narrate to Abu Talha about his son until I narrate it to him. Abu Talha came (home) ; she presented to him the supper. He took it and drank water. She then embellished herself which she did not do before. He (Abu Talha) had a sexual intercourse with her and when she saw that he was satisfied after sexual intercourse with her, she said: Abu Talha, if some people borrow something from another family and then (the members of the family) ask for its return, would they resist its return? He said: No. She said: I inform you about the death of your son. He was annoyed, and said: You did not inform me until I had a sexual intercourse with you and you later on gave me information about my son. He went to Allah's Messenger (may peace be upon him) and informed him what had happened. Thereupon Allah's Messenger (may peace be upon him) said: May Allah bless both of you in the night spent by you! He (the narrator) said: She became pregnant. Allah's Messenger (may peace he upon him) was in the course of a journey and she was along with him and when Allah's Messenger (may peace be upon him) came back to Medina from the journey he did not enter (his house) (during the night). When the people came near Medina, she felt the pangs of delivery. He (Abu Talha) remained with her and Allah's Messenger (may peace be upon him) proceeded on. Abu Talha said: O Lord, you know that I love to go along with Allah's Messenger when he goes out and enter along with him when he enters and I have been detained as Thou seest. Umm Sulaim said: Abu Talha, I do not feel (so much pain) as I was feeling formerly, so better proceed on. So we proceeded on and she felt the pangs of delivery as they reached (Medina) and a child was born and my mother said to me: Anas, none should suckle him until you go to Allah's Messenger (may peace be upon him) tomorrow morning. And when it was morning I carried him (the child) and went along with him to Allah's Messenger (may peace beupon him). He said: I saw that he had in his hand the instrument for the cauterisation of the camels. When he saw me. he said: This is, perhaps, what Umm Sulaim has given birth to. I said: Yes. He laid down that instrument on the ground. I brought that child to him and placed it in his lap and Allah's Messenger (may peace be upon him) asked Ajwa dates of Medina to be brought and softened them in his month. When these had become palatable he placed them in the mouth of that child. The child began to taste them. Then Allah's Messenger (may peace be upon him) said: See what love the Ansar have for dates. He then wiped his face and named him 'Abdullah.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6014]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6014

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6015]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6015

Abu Huraira reported that Allah's Messenger (may peace be upon him) said to Bilal: Bilal, narrate to me which act at the time of morning prayer you did in Islam for which you hope to receive good reward, for I heard during the night the sound of your steps before me in Paradise. Bilal said: I did not do any act in Islam for which I hope to get any benefit but this that when I perform complete ablution during the night or day I observe prayer with that purification what Allah has ordained for me to pray.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6016]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6016

Abdullah reported that when this verse was revealed:" There is no harm on persons who believe and perform good acts, what they had eaten (formerly) when they avoided it (now) and they affirmed their faith" (v. 93) up to the end. Allah's Messenger (may peace be upon him) said to me: You are one amongst them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6017]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6017

Abu Musa reported: When I and my brother came from Yemen we used to consider Ibn Mas'ud and his mother amongst the members of the household. of Allah's Messenger (may peace be upon him) because of their visiting them frequently and staying there for long (periods of) time.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6018]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6018

Abu Musa. reported: I came to Allah's Messenger (may peace be upon him) and thought that 'Abdullah was amongst the members of the family, or like that.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6019]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6019

Abu Ishaq reported that he heard Abu'l-Ahwas say: I was along with Abu Musa and Abu Mas'ud as Ibn Mas'ud died and one of them said to the other: Do you find one like him besides him? Thereupon he said: Do you say this (no one can be his rival)? He was admitted (to the company of the Holy Prophet) whereas we were detained and he had been present in the company of Allah's Messenger (may peace be upon him) whereas we had been absent.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6020]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6020

Abu Ahwas reported: We were in the house of Abu Musa along with some of the companions of 'Abdullah and they were looking at the Holy Book. 'Abdullah stood up, whereupon Abu Mas'ud said: I do not know whether Allah's Messenger, (may peace be upon him) has left after him one having a better knowledge (of Islam) than the man who is standing. Abu Musa said: If you say this, that is correct, because he had been present when we had been absent and he was permitted when we were detained.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6021]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6021

Zaid b. Wahab reported: I was sitting along with Hudhaifa and Abu Musa, and the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6022]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6022

'Abdullah (b. Mas'ud) reported that he (said to his companions to conceal their copies of the Qur'an) and further said: He who conceals anything he shall have to bring that which he had concealed on the Day of judgment, and then said: After whose mode of recitation you command me to recite? I in fact recited before AIlah's Messenger (may peace be upon him) more than seventy chapters of the Qur'an and the Companions of Allah's Messenger (may peace be upon him) know it that I have better understanding of the Book of Allah (than they do), and if I were to know that someone had better understanding than I, I would have gone to him. Shaqiq said: I sat in the company of the Companions of Mubkmmad (may peace be upon him) but I did not hear anyone having rejected that (that is, his recitation) or finding fault with it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6023]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6023

Abdullah reported: By Him besides Whom there is no god, there is no chapter in the Book of Allah about which I do not know as to where it was revealed and there is no verse about which I do not know in what context it was revealed, and if I were to know of one having a better understanding of the Book of Allah than I (and I could reach him) on the back of the mule, I would have definitely gone to him on camel's back.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6024]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6024

Masruq reported: We used to go to Abdullah b. 'Amr and talk to him, Ibn Numair said: One day we made a mention of Abdullah b. Mas'ud, whereupon he said: You have made mention of a person whom I love more than anything else. I heard Allah's Messenger (may peace be upon him) as saying: Learn Qur'an from four persons: Ibn Umm 'Abd (i. e. 'Abdullah b. Mas'ud) he started from him-then Mu'adh b. Jabal and Ubayya b. Ka'b, then Salim the ally of Abu Hudhaifa.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6025]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6025

Masruq reported: We were in the company of Abdullah b 'Amr that we made a mention of a hadith from Abdullah b. Mas'ud; thereupon he said: That is a person whose love ever remains (fresh in my heart) after I heard Allah's Messenger (may peace be upon him) as saying: Learn Qur'an from four persons: Ibn Umm 'Abd, i e. Abdullah b. Mas'ud and he started from his name-then Ubayy b. Ka'b and Mu'adh b Jabal. Zuhri did not make a mention of the words yaquluhu in his narration


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6026]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6026

This hadith has been reported on the authority of Abu Bakr b. Abu Shaiba and Abu Kuraib, and both of them said: Abu Mu'awiya narrated to us from A'mash on the authority of Jarir and Waki', and in a narration of Abu Bakr transmitted on the authority of Abu Mu'awiya the mention of Mu'adh has preceded Ubayy's, and in the narration transmitted on the authority of Abu Kuraib, the name of Ubayy preceded Mu'ddh's. This tradition has been transmitted on the authority of Shulba through A'mash, but there is a difference of order of the four.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6027]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6027

Masruq reported: They made a mention of Ibn Mas'ud before 'Abdullah b. Amr, whereupon he said: He is a person whose love is always fresh in my heart after I heard Allah's Messenger (may peace be upon him) as saying: Learn the recita- tion of the Qur'an from four persons: from Ibn Mas'ud, Salim, the ally of Abu Hudhaifa, Ubayy b. Ka'b, Mu'adh b. Jabal.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6028]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6028

Ubaidullah b. Mu'adh reported it on the authority of his father Shu'ba with the same chain of transmitters and he made this addition. He made a mention of these two names but I do not know whose name he mentioned first.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6029]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6029

Anas is reported to have said: Four persons collected the Qur'an during the lifetime of Allah's Messenger (may peace be upon him) and all of them were Ansar: Mu'adh b. Jabal, Ubayy b. Ka'b, Zaid b. Thabit, Abu Zaid. Qatada said: Anas, who was Abu Zaid? He said: He was one of my uncles.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6030]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6030

Hammam said: I said to Anas b. Malik: Who collected the Qur'an during the lifetime of Allah's Messenger (may peace be upon him)? He said: Four (persons), all of them belonging to Ansir: Ubayy b. Ka'b, Mu'adh b. Jabal, Zaid b. Thabit and a person from the Ansar whose Kunya was Abu Zaid.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6031]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6031

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said to Ubayy: Verily Allah, the Exalted and Glorious, has commanded me to recite the Qur'an to you, whereupon he said: (Has) Allah mentioned my name to you? He said: Allah has mentioned your name to me. Thereupon he began to shed tears (of joy)


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6032]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6032

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said to Ubayy b. Ka'b: I have been commanded to recite to you the Sura (al- Bayyinah) which opens with these words (Lam Yakunil-ladhiyna Kafaruu) He said: Has he mentioned to you my name? He said: Yes; thereupon he shed tears of joy. This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6033]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6033

Jabir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying while the bier of Sa'd b. Mu'adh was placed before them: The Throne of the most Gracious shook at the death of Sa'd b. Mu'adh.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6034]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6034

Jabir reported that the Throne of the most Compassionate shook because of the death of Sa'd b. Mu'adh.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6035]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6035

Anas b. Malik reported Allah's Messenger (may peace be upon him) as say- ing: That his bier (that of Sa'd) was placed (before them) and the Throne of the most Compassionate shook.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6036]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6036

Al-Bara' reported that a garment of silk was presented to Allah's Messenger (may peace be upon him). His Companions touched it and admired its softness; there- upon he said: Do you admire the softness of this (cloth)? The handkerchiefs of Sa'd b. Mu'adh in Paradise are better than this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6037]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6037

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6038]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6038

This hadith has been reported on the authority of Shu'ba combining the two chains of transmitters. Anas b Malik reported that Allah's Messenger (may peace be upon him) was presented a garment of sundus and he prohibited the use of silk. The persons admired it, whereupon he said: By Him in Whose Hand is the life of Muhammad, the kerchiefs of Sa'd b. Mu'adh in Paradise are better than this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6039]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6039

Anas reported the king of Dumat al-Jandal presented to Allah's Messenger (may peace be upon him) the garment and lie made no mention (of the fact) that he prohibited the use of silk.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6040]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6040

Anas reported that Allah's Messenger (may peace be upon him) took hold of his sword on the Day of Uhud and said: Who would take it from me? All the persons stretched their hands saying: I would do it, I would do it. He (Allah's Apostle) said: Who would take it in order to fulfil its rights? Then the people withdrew their hands. Simak b. Kharasha Abu Dujana said: I am here to take it and fulfil its rights. He took it and struck the heads of the polytheists.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6041]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6041

Jabir b. 'Abdullah reported: The dead body of my father was brought and he was covered (with cloth) and it had been mutilated. I made an attempt to lift the cloth, but my people prohibited me to do so. I again made an attempt to lift the cloth, but my people prohibited me. Thereupon Allah's Messenger (may peace be upon him) lifted it or he commanded it to be lifted. He heard the noise (of a loud) weeping, or the noise of a woman mourner. He inquired who she was. They said: The daughter of 'Amr or the sister of Amr, whereupon he said: Why does she weep? The Angels provide him shade with the help of their Wings until he would be lifted (to his heavenly abode)


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6042]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6042

Jabir b. 'Abdullah reported: My father fell as a martyr on the Day of Uhud and I attempted to uncover his face and weep, but they (the Companions of the Holy Prophet) forbade me to do this, whereas Allah's Messenger (may peace be upon him) did not forbid me and Fatima bint Amr, the sister of my father, was also weeping There- upon Allah's Messenger (may peace be upon him) said: You may weep or you may not weep; the Angels provide him shade with the help of their wings until you lift him (to be buried in the grave).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6043]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6043

This hadith has been narrated on the authority of Jabir through another chain of transmitters, but with this difference that there is no mention of the Angels and the weeping of a female mourner.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6044]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6044

Jabir reported: My father was brought in a state that his ears had been cut off and (his dead body) was placed before Allah's Apostle (may peace be upon him), the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6045]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6045

Abu Barza reported that Allah's Apostle (may peace be upon him) was there in a battlefield that Allah conferred upon him the spoils of war. He said to his Companions: Is anyone missing amongst you? They said: So and so and so. He again said: Is there anyone missing amongst you? They said: So and so and so. He then said: Is there anyone missing amongst you? They said: No. Thereupon he (the Holy Prophet) said: But I am missing Julaibib. They (his Companions) searched him amongst those who had been killed and they found him by the side of seven (dead bodies) whom he had killed and he had been killed (by the oppoments). Allah's Apostle (may peace be upon him) came there and stood (by his side) and said: He killed seven (persons). Then (his opponents) killed him. He is mine and I am his. He then placed him upon his hands and there was none else to lift but Allah's Apostle (may peace be upon him). Then the grave was dug for him and he was placed in the grave and no mention is made of a bath.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6046]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6046

'Abdullah b. Samit reported that Abu Dharr said: We set out from our tribe Ghafir who look upon the prohibited months as permissible months. I and my brother Unais and our mother stayed with our maternal uncle who treated us well. The men of his tribe fell jealous and they said: When you are anay from your house, Unais commits adultery with your wife. Our -naternal uncle came and he accused us of the sin which was conveyed to him. I said: You have undone the good you did to us. We cannot stay with you after this. We came to our camels and loaded (our) luggage. Our maternal uncle began to weep covering himself with (a piece of) cloth. We proceeded on until we encamped by the side of Mecca. Unais cast lot on the camels (we had) and an equal number (above that). They both went to a Kahin and he made Unais win and Unais came with our camels and an equal number along with them. He (Abu Dharr) said: My nephew, I used to observe prayer three years before my meeting with Allah's Messenger (may peace be upon him). I said: For whom did you say prayer? He said: For Allah. I said: To which direction did you turn your face (for observing prayer)? He said: I used to turn my face as Allah has directed me to turn my face. I used to observe the night prayer at the time of the end of night and I fell down in prostration like the mantle until the sun rose over me. Unais said: I have a work in Mecca, so you better stay here.

Unais went until he came to Mecca and he came to me late. I said: What did you do? He said: I met a person in Mecca who is on your religion and he claims that verily it is Allah Who has sent him. I said: What do the people say about him? He said: They say that he is a poet or a Kahin or a magician. Unais who was himself one of the poets said. I have heard the words of a Kahin but his words in no way resemble his (words). And 1 also compared his words to the verses of poets but such words cannot be uttered by any poet. By Allah, he is truthful and they are liars. Then I said: you stay here, until I go, so that I should see him. He said: I came to Mecca and I selected an insignificant person from amongst them and said to him: Where is he whom you call as-Sabi? He pointed out towards me saying: He is Sabi. Thereupon the people of the valley attacked me with sods and bows until I fell down unconscious. I stood up after havin. regained my consciousness and I found as if I was a red idol. I came to Zamzarn and washed blood from me and drank water from it and listen, O son of my brother, I stayed there for thirty nights or days and there was no food for me but the water of Zamzarn. And I became so bulky that there appeared wrinkles upon my stomach, and I did not feel any hunger in my stomach. It was during this time that the people of Mecca slept in the moonlit night and none was there to eircumambulate the House but only two women who had been invoking the name of Isafa, and Na'ila (the two idols).

They came to me while in their circuit and I said: Marry one with the other, but they did not dissuade from their invoking. They came to me and I said to them: Insert wood (in the idols' private parts). (I said this to them in such plain words) as I could not express in metaphorical terms. These women went away crying and saying: Had there been one amongst our people (he would have taught a lesson to you for the obscene words used for our idols before us). These women met Allah's Messenger (may peace be upon him) and Abu Bakr who had also been coming down the hill. He asked them: What has happened to you? They said: There is Sabi, who has hidden himself between the Ka'ba and its curtain. He said: What did he say to you? They said: He uttered such words before us as we cannot express. Allah's Messenger (may peace be upon him) came and he kissed the Black Stone and circumambulated the House along with his Companion and then observed prayer, and when he had finished his prayer, Abu Dharr said: I was the first to greet him with the salutation of peace and uttered (these words) in this way; Allah's Messen- ger, may there be peace upon you, whereupon he said: It may be upon you too and the mercy of Allah. He then said: Who are you? I said: From the tribe of Ghifar. He leaned his hand and placed his finger on his forehead and I said to myself: Perhaps he has not liked it that I belong to the tribe of Ghifar.

I attempted to catch hold of his hand but his friend who knew about him more than I dissuaded me f rom doing so. He then lifted his head and said: Since how long have you been here? I said: I have been here for the last thirty nights or days. He said: Who has been feeding you? I said: There has been no food for me but the water of Zamzam. I have grown so bulky that there appear wrinkles upon my stomach and I do not feel any hunger. He said: It is blessed (water) and it also serves as food. Thereupon Abu Bakr said: Allah's Messenger, let me serve as a host to him for tonight, and then Allah's Messenger (may peace be upon him) proceeded forth and so did Abu Bakr and I went along with them. Abu Bakr opened the door and then he brought for us the raisins of Ta'if and that was the first food which I ate there. Then I stayed as long as I had to stay. I then came to Allah's Messenaer (may peace be upon him) and he said: I have been shown the land abound- ing in trees and I think it cannot be but that of Yathrib (that is the old name of Medina). You are a preacher to your people on my behalf. I hope Allah would benefit them through you and He would reward you. I came to Unais and he said: What have you done? I said: I have done that I have embraced Islam and I have testified (to the prophethood of Allah's Messenger). He said: I have no aversion for your religion and I also embrace Islam and testify (to the prophethood of Muhammad). Then both of us came to our mother and she said: I have no aversion for your religion and I also embrace Islam and testify to the prophethood of Muhammad. We then loaded our camels and came to our tribe Ghifir and half of the tribe embraced Islam and their chief was Aimi' b. Rahada Ghifirl and he was their leader and hall of the tribe said: We will embrace Islam when Allah's Messenger (may p,. ace be upon him) would come to Medina, and when Allah's Messenger (may peace be upon him) came to Medina the remaining half also embraced Islam. Then a tribe Aslam came to the Holy Prophet (may peace be upon him) and said: Allah's Messenger, we also embrace Islam like our brothers who have embraced Islam. And they also embraced Islam. Thereupon Allah's Messenger (may peace be upon him) said: Allah granted pardon to the tribe of Ghifar and Allah saved (from destruction) the tribe of Aslam.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6047]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6047

This hadlth has been narrated on the authority of Humaid b. Hilal with the same chain of transmitters but with this addition:" As I came to Mecca, Unais said: (Well), go but be on your guard against the Meccans for they are his enemies and are annoyed with him."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6048]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6048

Abdullah b. Samit reported that Abu Dharr said: Son of my brother, I used to observe prayer two years before the advent of Allah's Apostle (may peace be upon him). I said: To which direction did you turn your face? He said: To which Allah directed me to turn my face. The rest of the hadith is the same but with this addition that they went to a Kahin and his brother Unais began to praise him until he (in verses declared) him (Unais) as winner (in the contest of poetry), and so we got his camels, mixed them with our camels, and there is in this hadith also these words that Allah's Apostle (may peace be upon him) came there and he circumambulated the House and observed two Rak'ahs of prayer behind the Station (of Ibrahim). I came to him and I was the first amongst persons to greet him with Assalam-o-'Alaikum, and I said to Allah's Messenger Let there be peace upon you. And he said: Let there be peace upon you too; who are you? And in the hadith (these words are) also found: Since how long have you been here? And Abu Bakr said: Let him be my guest tonight.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6049]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6049

Ibn 'Abbas reported that when Abu Dharr heard of the advent of the Apostle (may peace be upon him) in Mecca he said: Brother, ride in this valley and bring information for me about the person who claims that there comes to him information from the Heavens. Listen to his words and then come to me. So he rode on until he came to Mecca and he heard his words (the sacred words of the Holy Prophet) and then came back to Abu Dharr and said: I have seen him exhorting (people) to develop good morals and his expressions can in no way be termed as poetry. He (Abu Dharr) said: I have not been satisfied with it regarding that which I had in my mind (as I sent you). So he took up provisions for the journey and a small water-skin con- taining water (and set forth) until he came to Mecca. He came to the mosque (Ka'ba) and began to find out Allah's Apostle (may peace be upon him) and he did not re- cognise him (the Holy Prophet) and he did not even like that he should ask about him from anyone until it was night, and he slept. 'All saw him and found him to be a stranger. So he went with him. He followed hive but one did not make any inquiry from the other about anything until it was morning. He then brought the water and his provisions to the mosque and spent a day there, but he did not see Allah's Apostle (may peace be upon him) until it was night. He then returned to his bed that there happened to pass 'Ali and he said: This man has not been able to find his destination until this time. He made him stand and he went with him and no one made an in- quiry from his companion about anything. And when it was the third day he did the same. 'Ali made him stand up and brought him along with him. He said: By Him, besides Whom there is no god, why don't you tell me (the reason) which brought you here to this town? He said: (I shall do this) provided you hold me promise and a covenant that you would guide me aright. He then did that. He ('Ali) said: Verily, he Is truthful and he is a Messenger of Allah (may peace be upon him) and when it is morning, follow me and if I would say anything from which I would sense fear about you I would stand (in a manner) as if I was throwing water and if I move on, you then follow me until I get in (some house). He did that and I followed him until he came to Allah's Messenger (may peace be upon him). He entered (the house) of Allah's Apostle (may peace be upon him) along with him and listened to his words and embraced Islam at his very place. Allah's Apostle (may peace be upon him) said to him: Go to your people and inform them until my command reaches you. Thereupon he said: By Him in Whose Hand is my life, I shall say to the people of Mecca this thing at the top of my voice So he set forth until he came to the mosque and then spoke at the top of his voice (saying): I bear testimony to the fact that there is no god but Allah and that Muhammad is the Messenger of Allah. The people attacked him and made him fall down when 'Abbas came and he leaned over him and said: Woe be upon you, don't you know that he is from amongst the tribe of Ghifar and your trad- ing route to Syria passes through (the settlements of this tribe), and he rescued him. He (Abu Dharr) did the same on the next day and they (the Meccans) again attacked him and Abbas leaned upon him and he rescued him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6050]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6050

(6050) Jarir b. 'Abdullah said: Allah's Messenger (may peace be upon him) never refused me permission to see him since I embraced Islam and never looked at me but with a smile.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6051]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6051

Jarir reported: Since I embraced Islam Allah's Messenger (may peace be upon him) never refused to see me and he did not see me but with a smile on his face. Ibn Numair has made this addition to this hadith which has been reported on the authority of Ibn Idris that he (Jarir) made this complaint to him (to the Holy Prophet): I cannot sit upon the horse with firmness, whereupon he (Allah's Apostle) struck his chest with his hand and prayed: O Allah, make him steadfast and rightly-guided.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6052]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6052

Jabir reported that there was in pre-Islamic days a temple called Dhu'l- Khalasah and it was called the Yamanite Ka'ba or the northern Ka'ba. Allah's Messenger (may peace be upon him) said unto me: Will you rid me of Dhu'l-Khalasah and so I went forth at the head of 350 horsemen of the tribe of Ahmas and we destroyed it and killed whomsoever we found there. Then we came back to him (to the Holy Prophet) and informed him and he blessed us and the tribe of Ahmas.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6053]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6053

Jarir b. 'Abdullah al-Bajali said: Allah's Messenger (may peace be upon him) said to me: Can't on rid me of Dhu'I-Khalasah, the idol-house of Khath'am, and this idol-house was called the Yamanite Ka'ba. So I went along with 150 horsemen and I could not sit with steadfastness upon the horse. I made the mention of it to Allah's Messenger (may peace be upon him) and he struck his hand on my chest and said: O Allah, grant him steadfastness and make him the guide of righteousness and the rightly-guided one. So he went away and he set fire to it. Then Jarir sent some person to Allah's Messenger (may peace be upon him) whose Kunya was Abu Arta to give him the happy news about that. He came to Allah's Messenger (may peace be upon him) and said: I have not come to you (but with the news) that we have left Dhu'l-Khalasah as a scabed camel. Thereupon Allah's Messenger (may peace be upon him) blessed the horses of Ahmas and the men of their tribe five times.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6054]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6054

This hadith has been narrated on the authority of Ismail with different chains of transmitters and in the badith transmitted on the authority of Marwan (the words are):" A person giving the glad tidings on behalf of Jarir came or Abu Husain b. Rabi'a came in order to give glad tidings to Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6055]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6055

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) came to privy and I placed for him water for ablution, When he came out he said: Who placed it here? And in a version of Zuhair they (the Companions) said, and in the version of Abu Bakr (the words are): I said: It is Ibn 'Abbas (who has done that), whereupon he (the Holy Prophet) said: May Allah grant him deep understanding of religion.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6056]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6056

Ibn 'Umar reported: I saw in a state of sleep as if I have in my hand a piece of silk cloth and there is no place in the Paradise where I intend to reach but that piece of cloth does not fly towards it. I made a mention of it to Hafsa (the sister of Ibn 'Umar) and Hafsa made a mention of it to Allah's Apostle (may peace be upon him), whereupon Allah's Apostle (may peace be upon him) said: I find 'Abdullah b 'Umar a pious person.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6057]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6057

Ibn 'Umar reported that when a person saw anything in sleep during the lifetime of Allah's Messenger (may peace he upon him) he narrated it to Allah's Messenger, and I also had a longing that I should also see in a dream something which I should narrate to Allah's Apostle (may peace be upon him) and I was at that time an unmarried young man. I was sleeping in the mosque during the lifetime of Allah's Messenger (may peace be upon him) tl) at I saw in a dream as if two Angels have taken hold of me and they have carried me to the fire, and, lo, it was built like the easing of a well and had two pillars like those of a well; and, lo, there were people in it whom I knew and I cried out: I seek refuge with Allah from Hell-fire; I seek refuge with Allah from Hell-fire. Then another Angel joined the two others, and said unto me: You need not fear I narrated this dream to llafsa and she narrated it to Allah's Messenger, whereupon Allah's Apostle said: Worthy is this man Abdullah, O that he would pray at night, and Silim added that Abdullah afterwards slept only but for a small part of the night.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6058]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6058

Ibn Umar reported: I used to spend nights in the mosque and by that time I had no wife and children. I saw in a dream as if I am being taken to a well. I made a mention of it to Allah's Messenger (may peacebe upon him). The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6059]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6059

Anas reported that Umm Sulaim said (to the Holy Prophet) Allah's Messenger, here is your servant Anas, invoke blessings of Allah upon him. Thereupon he (the Holy Prophet) said: O Allah, make an increase in his wealth, and progeny, and confer blessings upon him in everything Thou hast bestowed upon him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6060]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6060

Anas reported (that his mother) Umm Sulaim said (to the Holy Prophet) Allah's Messenger, here is your servant Anas. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6061]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6061

This hadith has been reported on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6062]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6062

Anas reportedAllah's Apostle (may peace be upon him) visited us and there was none else (in the house) but I, my mother and my mother's sister Umm Haram. My mother said to him: Allah's Messenger, here is a small servant of yours, invoke blessings of Allah upon him. And he invoked blessings for me (that I should be bestowed upon) every good and this was what he (said) at the end of what be supplicated for me: O Allah, make an increase in his wealth, and progeny, and cqnfer blessings (upon him) in (each one) of them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6063]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6063

Anas reported: My mother Umm Anas came to Allah's Messenger (may peace be upon him). And she prepared my lower garment out of the half of her headdress and (with the other half) she covered my upper body and said: Allah's Messenger, here is my son Unais; I have brought him to you for serving you. Invoke blessings of Allah upon him. Thereupon he (the Holy Prophet) said: O Allah, make an increase in his wealth, and progeny. Anas said: By Allah, my fortune is huge and my children, and grand-children are now more than one hundred.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6064]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6064

Anas b. Malik said: Allah's Messenger (may peace be upon him) passed (by our house) that my mother Umm Sulaim listened to his voice and said: Allah's Messenger, let my father and mother be sacrificed for thee, here is Unais (and requested him to invoke blessings upon me). So Allah's Messenger (may peace be upon him) invoked three blessings upon me. I have seen (the results) of the two in this very world (in regard to wealth and progeny) and I hope to see (the result) of the third one in the Hereafter.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6065]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6065

Anas reported: Allah's Messenger (may peace be upon him) came to me as I was playing with playmates. He greeted and sent me on an errand and I made delay in going to my mother. When I came to her she said: What detained you? I said: Allah's Messenger (may peace be upon him) sent me on an errand. She said: What was the purpose? I said: It is something secret. Therupon she said: Do not then divulge the secret of Allah's Messenger (may peace be upon him) to anyone. Anas said: By Allah, if I were to divulge it to anyone, then, O Thabit, I would have divulged it to you.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6066]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6066

Anas b. Malik reported that Allah's Apostle (may peace be upon him) told me something secretly. I informed none about that and Umm Sulaim asked me about it, but I did not tell her even.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6067]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6067

'Amir b. Sa'd reported that he heard his father (Sa'd b. Abi Waqqas) say: never heard Allah's Messenger (may peace be upon him) say unto one living and moving about that he was in Paradise except to 'Abdullah b. Salim.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6068]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6068

Qais b. 'Ubada reported: I was in the company of some persons, amongst whom some were the Companions of Allah's Apostle (may peace be upon him) in Medina, that there came a person whose face depicted the fear (of Allah). Some people said: He is a person from amongst the people of Paradise; he is a person from amongst the people of Paradise. He observed two short rak'ahs of prayer and then went out. I followed him and he got into his house and I also got in and we began to converse with each other. And when he became familiar (with me) I said to Him: When you entered (the mosque) before (your entrance in the house) a person said so and so (that you are amongst the people of Paradise), whereupon he said: It is not meet for anyone to say anything which he does not know. I shall (now) tell you why they (say) this. I saw a dream during the lifetime of Allah's Messenger (may peace be upon him) and narrated it to him. I seemed to be in a garden [he described its vastness, its rich fructification and its verdure]; in the midst of it, there stood an iron pillar, with its base in the earth and its summit in the sky: and upon its summit there was a handhold. It was said to me: Climb up this (pillar). I said to him (visitant in the dream): I am unable to do it. Thereupon a helper came to me, and he (supported) me (by catching hold of my) garment from behind and thus helped me with his hand and so I climbed up till I was at the summit of the pillar, and grasped the handhold. It was said to me: Ho d it tightly. It was at this that I woke up when (the handhold) was in fthe grip) of my hand. I narrated it (the dream) to Allah's Apostle (may peace be upon him), whereupon he said: That garden implies al-Islam and that pillar implies the pillar of Islam. And that handhold is the firmest faith (as refered to in the Qur'an). And you will remain attached to Islam until you shall die. And that man was 'Abdullah b. Salim.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6069]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6069

Qais b. 'Ubaida reported: I was (sitting) in a company in which there were (besides others) Sa'd b. Malik and Ibn 'Umar that 'Abdullah b. Saliim happened to pass (by that side). They (the people sitting in that company) said: He is a person from amongst the dwellers of Paradise. I stood up and said to him: They say such and such (thing about you), whereupon he said: Hallowed be Allah, it is not meet for them to say (anything) of which They have no knowledge. Verily I saw as if a pillar had been raised in a green garden and there had been fixed at its (upper) end a handhold and there was a helper at its base. It was said to me: Climb up. So I climbed up and caught hold of the haildhold. I narrated (the contents of this dream) to Allah's Messenger (may peace be upon him), whereupon he said: 'Abdullah would die in a state that he would be catching hold of the firmest handhold (he would die holding fast to the faith).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6070]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6070

Kharasha b. Hurr reported: I was sitting in a circle in the mosque of Medina and there was an old man, quite handsome. He was 'Abdullah b. Salim. He was telling good things to them (to the people sitting in that company). As he stood up (to depart) the people said: He who is desirous of looking at a person from amongst the people of Paradise should see him. I said: By Allah, I will follow him, and would try to know his residence. So I followed him and he walked on until he reached the outskirts of Medina. He then entered his house. I sought permission from him to get in, and he granted me the permission, saying: My nephew, what is the need (that has brought you here)? I said to him: As you stood up, I heard people say about you: He who is desirous of seeing a person from among the people of Paradise should look at him. So I became desirous of accompanying you. He ('Abdullah b. Salim) said: It is Allah Who knows best about the people of Paradise. I would, however, narrate to you as to why they said like it. (The story is) that while I was asleep (one night) there came to me a person (in the dream) who asked me to stand up. (So I stood up) and he caught hold of my hand and I walked along with him, and, lo, I found some paths on my left and I was about to set out upon them. Thereupon he said to me Do not set yourself on (them) for these are the paths of the leftists (denizens of Hell-fire). Then there were paths leading to the right side, whereupon he said: Set yourself on these paths. We came across a hill and he said to me: Climb up, and I attempted to climb up that I fell upon my buttocks. I made several attempts (but failed to succeed). He led until he came to a pillar (so high) that its upper end touched the sky and its base was in the earth. And there was a handhold at its upper end. He said to me Climb over it. I said: How can I climb upon it, as its upper end touches the sky? He cought hold of my hand and pushed me up and I found myself suspended with the handhold. He then struck the pillar and it fell down, but I remained attached to that handhold until it was morning (and the dream was thus over). I came to Allah's Apostle (may peace be upon him) and narrated it to him. He said: So far as the paths which you saw on your left are concerned, these are paths of the leftists (denizens of Hell) and the paths which you saw on your right, these are the paths of the rightists (the dwellers of Paradise) and the mountain represents the destination of the martyrs which you would not be able to attain. The pillar implies the pillar of Islam. and so far as the handhold is concerned, it implies the handhold of Islam, and you would hold to it fastly until you would meet death.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6071]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6071

Abu Huraira reported that 'Umar happened to pass by Hassan as he was reciting verses in the mosque. He (Hadrat 'Umar) looked towards him (meaningfully), whereupon he (gassin) said: I used to recite (verses) when one better than you (the Holy Prophet) had been present (here). He then looked towards Abu Huraira and said to him: I adjure you by Allah (to tell) if you had not heard Allah's Messenger (may peace be upon him) as saying: (Hassan), give a reply on my behalf; Allah I help him with Ruh-ul-Qudus. He (Abu Huraira) said: By Allah, it is so (i. e. the Holy Prophet actually said these words).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6072]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6072

Ibn Musayyib reported that Hassan said to a circle in which there was also Abu Huraira: Abu Huraira, I adjure you by Allah (to tell) whether you-had not heard Allah's Messenger (may peace be upon him) saying like this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6073]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6073

'Abd al-Rahman reported that he heard Hassin b. Thabit al-Ansari call Abu Huraira to bear witness by saying: I adjure you by Allah if you had not heard Allah's Apostle (may peace be upon him) saying: Hassin, give a reply on behalf of the Messenger of Allah. O Allah, help him with Ruh-ul-Qudus. Abu Huraira said: Yes, it is so.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6074]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6074

Al-Bari' b. 'Azib reported: I heard Allah's Messenger (may peace be upon him) as saying: Hassan b. Thibit, write satire (against the non-believers) ; Gabriel is with you. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6075]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6075

Hisham reported on the authority of his father that Hassan b. Thabit talked much about 'A'isha. I scolded him, whereupon she said: My nephew, leave him for he defended Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6076]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6076

This hadith has been narrated on the authority of Hishim with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6077]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6077

Masruq reported: I visited 'A'isha when Hassin was sitting there and reciting verses from his compilation: She is chaste and prudent. There is no calumny against her and she rises up early in the morning without eating the meat of the un- mindful. 'A'isha said: But you are not so. Masruq said: I said to her: Why do you permit him to visit you, whereas Allah has said:" And as for him among them who took upon himself the main part thereof, he shall have a grievous punishment" (XXIV. ll)? Thereupon she said: What tornient can be more severe than this that he has become blind? He used to write satire as a rebuttal on behalf of Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6078]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6078

This hadith has been reported on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6079]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6079

'A'isha reported that Hassin said: Allah's Messenger, permit me to write satire against Abu Sufyan, whereupon he said: How can it be because I am also related to him? Thereupon he (Hassan) said: By Him Who has honoured you. I shall draw you out from them (their family) just as hair is drawn out from the fermented (flour). Thereupon Hassan said: The dignity and greatness belongs to the tribe of Bint Makhzum from amongst the tribe of Hisham, whereas your father was a slave.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6080]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6080

'Urwa reported on the same chain of transmitters that Hassan b. Thabit sought permission from Allah's Apostle (may peace be upon him) to satirise against the polytheists, but he did not mention Abu Sufyan. And instead of the word al- Khamir, the word al-'Ajin was used.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6081]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6081

'A'isha reported that Allah's Messenger (may peace be uport him) said. Satirise against the (non-believing amongst the) Quraish, for (the satire) is more grievous to them than the hurt of an arrow. So he (the Holy Prophet) sent (someone) to Ibn Rawiha and asked him to satirise against them, and he composed a satire, but it did not appeal to him (to the Holy Prophet). He then sent (someone) to Ka'b b. Malik (to do the same, but what he composed did not appeal to the Holy Prophet). He then sent one to Hassan b. Thabit. As he got into his presence, Hassan said: Now you have called for this lion who strikes (the enemies) with his tail. He then brought out his tongue and began to move it and said: By Him Who has sent you with Truth, I shall tear them with my tongue as the leather is torn. Thereupon Allah's Messenger (may peace be upon him) said: Don't be hasty; (let) Abu Bakr who has the best know- ledge of the lineage of the Quraish draw a distinction for you in regard to my lineage, as my lineage is thesame as theirs. Hassan then came to him (Abu Bakr) and after making inquiry (in regard to the lineage of the Holy Prophet) came back to him (the holy Prophet) and said: Allah's Messenger, he (Abu Bakr) has drawn a distinction in vour lineage (and that of the Quraish) By Him Who has sent you with Truth, I shall draw out from them (your name) as hair is drawn out from the flour. 'A'isha said: I heard Allah's Messenger (may peace be upon him) as saying to Hassin: Verily Ruh-ul- Qudus would continue to help you so long as you put up a defence on behalf of Allah and His Messenger. And she said: I heard Allah's Messenger (may peace be upon him) saying: Hassan satirised against them and gave satisfaction to the (Muslims) and disquieted (the non-Muslims).

You satirised Muhammad, but I replied on his behalf,

And there is reward with Allah for this.

You satirised Muhammad. virtuous, righteous,

The Apostle of Allah, whose nature is truthfulness.

So verily my father and his father and my honour

Are a protection to the honour of Muhammad;

May I lose my dear daughter, if you don't see her,

Wiping away the dust from the two sides of Kada',

They pull at the rein, going upward;

On their shoulders are spears thirsting (for the blood of the enemy) ;

our steeds are sweating-our women wipe them with their mantles.

If you had not interfered with us, we would have performed the 'Umra,

And (then) there was the Victory, and the darkness cleared away.

Otherwise wait for the fighting on the day in which Allah will honour whom He pleases.

And Allah said: I have sent a servant who says the Truth in which there is no ambiguity;

And Allah said: I have prepared an army-they are the Ansar whose object is fighting (the enemy),

There reaches every day from Ma'add abuse, or fighting or satire;

Whoever satirises the Apostle from amongst you, or praises him and helps it is all the same,

And Gabriel, the Apostle of Allah is among us, and the Holy Spirit who has no match.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6082]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6082

Abu Huraira reported: I invited my mother, who was a polytlieist, to Islam. I invited her one day and she said to me something about Allah's Messenger (may peace be upon him) which I hated. I came to Allah's Messenger (may peace be upon him) weeping and said: Allah's Messenger, I invited my mother to Islam but she did not accept (my invitation). I invited her today but she said to me something which I did not like. (Kindly) supplicate Allah that He may set the mother of Abu Huraira right. Thereupon Allah's Messenger (may peace be upon him) said: O Allah, set the mother of Abu Huraira on the right path. I came out quite pleased with the supplication of Allah's Apostle (may peace be upon him) and when I came near the door it was closed from within. My mother heard the noise of my footsteps and she said: Abu Huraira, just wait, and I heard the noiee of falling of water. She took a bath and put on the shirt and quickly covered her head with a headdress and opened the door and then said: Abu Huraira, I bear witness to the fact that there is no god but Allah and Mubammad is His bondsman and His Messenger. He (Abu Huraira) said: I went back to Allah's Messenger (may peace be upon him) and (this time) I was shedding the tears of joy. I said: Allah's Messenger, be happy, for Allah has responded to your supplication and He has set on the right path the mother of Abu Huraira. He (the Holy Prophet) praised Allah, and extolled Him and uttered good words. I said: Allah's Messenger, supplicate to Allah so that He may instil love of mine and that of my mother too in the believing servants and let our hearts be filled with their love, whereupon Allah's Messenger (may peace be upon him) said: O Allah, let there be love of these servants of yours, i. e. Abu Huraira and his mother, in the hearts of the believing servants and let their hearts be filled with the love of the believing servants. (Abu Huraira said: This prayer) was so well granted by Allah that no believer was ever born who heard of me and who saw me but did not love me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6083]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6083

Al-A'raj reported that he heard Abu Huraira as saying: You are under the impression that Abu Huraira transmits so many ahadith from Allah's Messenger (may peace up upon him) ; (bear in mind) Allah is the great Reckoner. I was a poor man and I served Allah's Messenger (may peace be upon him) being satisfied with bare subsistence, whereas the immigrants remained busy with transactions in the bazar; while the Ansar had been engaged in looking after their properties. (He further reported) that Allah's Messenger (may peace be upon him) said: He who spreads the cloth would not forget anything that he would hear from me. I spread my cloth until he narrated something. I then pressed it against my (chest), so I never forgot anything that I heard from him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6084]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6084

This hadith has been transmitted on the authority of Abu Huraira but with the variation that the hadith transmitted on the authority of Malik conclude with the words of Abu Huraira and there is no mention of a transmission of these from Allah's Apostle (may peace be upon him):" who spreads his cloth," to the end.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6085]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6085

'A'isha reported: Don't you feel surprised at Abu Huraira? He came (one day) and sat beside the nook of my apartment and began to narrate (the hadith of Allah's Apostle). I was hearing while I was engaged in extolling Allah (reciting Subhan Allah) constantly. He stood up before I finished my repetition of Subhan Allah. if I were to meet him I would have warned him in stern words that Allah's Messenger (may peace be upon him) did not speak so quickly as you talk. Ibn Shihab transmitted on the authority of Ibn Musayyib that Abu Huraira said: People say that Abu Huraira transmits so many ahadith, whereas Allah is the Reckoner, and they say: How is it with Muhajirs and the Ansar that they do not narrate ahadith like him (like Abu Huraira)? Abu Huraira said: I tell you that my brothers from Ansar remained busy with their lands and my brothers Muhajirs were busy in transactions in the bazars, but I always kept myself attached to Allah's Messenger (may peace be upon him) with bare subsistence. I remained present (in the company of the Holy Prophet), whereas they had been absent. I retained in my mind (what the Holy Prophet said), whereas they forgot it. One day Allah's Messenger (may peace be upon him) said: He who amongst you spreads the cloth and listens to my talk and would then press it against his chest would never forget anything heard from me. So I spread my mantle and when he had concluded his talk I then pressed it against my chest and so I never forgot after that day anything that he (the Holy Prophet) said. And if these two verses would not have been revealed in the Book I would have never transmitted anything (to anybody):" Those who conceal the clear evidence and the guidance that We revealed" (ii. 159) tip to the last verse.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6086]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6086

This hadith has been transmitted on the authority of Abu Huraira (and the words are): You say that Abu Huraira narrates so many ahadith from Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6087]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6087

Ubaidullah b. Rafi', who was the scribe of 'All, reported: I heard 'Ali (Allah be pleased with him) as saying: Allah's Messenger (may peace be upon him) sent me and Zubair and Miqdad saying: Go to the garden of, Khakh [it is a place between Medina and Mecca at a distance of twelve miles from Medina] and there you will find a woman riding a camel. She would be in possession of a letter, which you must get from her. So we rushed on horses and when we met that woman, we asked her to deliver that letter to us. She said: There is no letter with me. We said: Either bring out that letter or we would take off your clothes. She brought out that letter from (the plaited hair of) her head. We delivered that letter to Allah's Messenger (may peace be upon him) in which Hatib b. Abu Balta'a had informed some people amongst the polytheists of Mecca about the affairs of Allah's Messenger (may peace be upon him). Allah's Messenger (may peace be upon him) said: Hatib, what is this? He said: Allah's messenger, do not be hasty in judging my intention. I was a person attached to the Quraish. Sufyan said: He was their ally but had no relationship with them. (Hatib further said): Those who are with you amongst the emigrants have blood-relationship with them (the Quraish) and thus they would protect their families. I wished that when I had no blood-relationship with them I should find some supporters from (amongst them) who would help my family. I have not done this because of any unbelief or apostasy and I have no liking for the unbelief after I have (accepted) Islam. Thereupon Allah's Apostle (may peace be upon him) said: You have told the truth. 'Umar said: Allah's Messenger, permit me to strike the neck of this hypocrite. But he (the Holy Prophet) said: He was a participant in Badr and you little know that Allah revealed about the people of Badr: Do what you like for there is forgiveness for you. And Allah, the Exalted and Glorious, said:" O you who believe, do not take My enemy and your enemy for friends" (lx. 1). And there is no mention of this verse in the hadith transmitted on the authority of Abu Bakr and Zubair and Ishaq has in his narration made a mention of the recitation of this verse by Sufyan.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6088]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6088

'Ali reported that Allah's Messenger (may peace be upon him) sent me and Abu Marthad al-Ghitnavi and Zubair b. 'Awwam and we were all riders, and he said: Ride on until you reach the garden of Khakh for there is a woman amongst the polytheists and there is a letter with her sent by Hatib to the polytheists; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6089]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6089

Jabir reported that a slave of Hatib came to Allah's Messenger (may peace be upon him) complaining against Hatib and said: Hatib will definitely go to Hell. (But) Allah's Messenger (may peace be upon him) said: You tell a lie; he would not get into that for he had taken part in Badr and in (the expedition of) Hudaibiya.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6090]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6090

Umm Mubashshir reported that she heard Allah's Apostle (may peace be upon him) as saying in presence of Hafsa: God willing, the people of the Tree would never enter the fire of Hell one amongst those who owed allegiance under that. She said: Allah's Messenger, why not? He scolded her. Hafsa said: And there is none amongst you but shall have to pass over that (narrow Bridge). Thereupon Allah's Apostle (may peace be upon him) said: Allah, the Exalted and Glorious, has said: We would rescue those persons who are God-conscious and we would leave the tyrants to their fate there (xix. 72).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6091]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6091

Abu Musa reported: I was in the company of Allah's Apostle (may peace be upon him) as he had been sitting in Ji'rana (a place) between Mecca and Medina and Bilal was also there, that there came to Allah's Apostle (may peace be upon him) a desert Arab, and he said: Muhammad, fulfill your promise that you made with me. Allah's Messenger (may peace be upon him) said to him: Accept glad tidings. Thereupon the desert Arab said: You shower glad tidings upon me very much; then Allah's Messenger (may peace be upon him) turned towards Abu Musa and Bilal seemingly in a state of annoyance and said: Verily he has rejected glad tidings but you two should accept them. We said: Allah's Messenger, we have readily accepted them. Then Allah's Messenger (may peace be upon him) called for a cup of water and washed his hands in that and face too and put the saliva in it and then said: Drink out of it and pour it over your faces and over your chest and gladden yourselves. They took hold of the cup and did as Allah's Messenger (may peace be upon him) had commanded them to do. Thereupon Umm Salama called from behind the veil: Spare some water in your vessel for your mother also, and they also gave some water which had been spared for her.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6092]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6092

Abu Burda reported on the authority of his father that when Allah's Apostle (may peace be upon him) had been free from the Battle of Hunain, he sent Abu 'Amir as the head of the army of Autas. He had an encounter with Duraid b. as_Simma. Duraid was killed and Allah gave defeat to his friends. Abu Musa said: He (the Holy Prophet) sent me along with Abu 'Amir and Abu 'Amir received a wound in his knee from the arrow, (shot by) a person of Bani Jusham. It stuck in his knee. I went to him and said: Uncle, who shot an arrow upon you? Abu 'Amir pointed out to Abu Musa and said: Verily that one who shot an arrow upon me in fact killed me. Abu Musa said: I followed him with the determination to kill him and overtook him and when he saw me he turned upon his heels. I followed him and I said to him: Don't you feel ashamed (that you run), aren't you an Arab? Why don't you stop? He stopped and I had an encounter with him and we exchanged the strokes of (swords). I struck him with the sword and killed him. Then I came back to Abu Amir and said: Verily Allah has killed the one who killed you. And he said: Now draw out this arrow. I drew out the arrow and there came out from that (wound) water. Abu 'Amir said: My nephew, go to Allah's Messenger (may peace be upon him) and convey my greetings to him and tell him that Abu Amir begs you to ask forgiveness for him. And Abu Amir appointed me as the chief of the people and he died after a short time. When I came to Allah's Apostle (may peace be upon him) I visited him and he had been lying on the cot woven by strings and there was (no) bed over it and so there had been marks of the strings on the back of Allah's Messenger (may peace be upon him) and on his sides. I narrated to him what had happened to us and narrated to him about Abu Amir and said to him that he had made a request to the effect that forgiveness should be sought for him (from Allah). Thereupon Allah's Messenger (may peace be. upon him) called for water and performed ablution with it. He then lifted his hands and said. O Allah, grant pardon to Thy servant Abu Amir. (The Holy Prophet had raised his hands so high for supplication) that I saw the whiteness of his armpits. He again said: O Allah, grant him distinction amongst the majority of Thine created beings or from amongst the people. I said: Allah's Messenger, ask forgiveness for me too. Thereupon Allah's Apostle (may peace be upon him) said: Allah, forgive the sins of Abdullah b. Qais (Abu Musa Ash'ari) and admit him to an elevated place on the Day of Resurrection. Abu Burda said: One prayer is for abu 'Amir and the other is tor Abu Musa.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6093]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6093

Abu Musa reported that Allah's Messenger (may peace be upon him) said: I recognise the voice of the Ash'arites while they recite the Qur'an as they arrive during the night and I also recognise their station from the recital of the Qur'an during the night time, although I have not seen their encampments as they encamp during the day time. And there is a person amongst them, Hakim; when he encounters the horsemen or the enemies he says to them: My friends command you to wait for them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6094]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6094

Abu Musa reported that Allah's Messenger (may peace be upon him) said: When the Ash'arites run short of provisions in the campaigns or run short of food for their children in Medina they collect whatever is with them in the cloth and then partake equally from one vessel. They are from me and I am from them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6095]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6095

Ibn Abbas reported that the Muslims neither looked to Abu Sufyan (with respect) nor did they sit in his company. he (Abu Sufyan) said to Allah's Apostle (may peace be upon him): Allah's Apostle, confer upon me three things. He replied in the affirmative. He (further) said: I have with me the most handsome and the best (woman) Umm Habiba, daughter of Abu Sufyan; marry her, whereupon he said: Yes. And he again said: Accept Mu'awiya to serve as your scribe. He said: Yes. He again said: Make me the commander (of the Muslim army) so that I should fight against the unbelievers as I fought against the Muslims. He said: Yes. Abu Zumnail said: If he had not asked for these three things from Allah's Apostle (may peace be upon him), he would have never conferred them upon him, for it was (his habit) to accede to everybody's (earnest) request.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6096]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6096

Abu Musa reported: We were in Yemen when we heard of the migration of Allah's Messenger (may peace be upon him). We also set out as immigrants to him. And I was accompanied by two brothers of mine, I being the youngest of them; one of them was Abu Burda and the other one was Abu Ruhm, and there were some other persons with them. Some say they were fifty-three or fifty-two persons of my tribe. We embarked upon a boat, and the boat sailed away to the Negus of Abyssinia. There we met Ja'far b. Abu Talib and his companions. Ja'far said: Allall's Messenger (may peace be upon him) has sent us here and has commanded us to stay here and you should also stay with us. So we stayed with him and we came back (to Medina) and met Allah's Messenger (may peace be upon him) when Khaibar had been conquered. He (the Holy Prophet) allocated a share to us and in the ordinary course he did not allocate the share to one who had been absent on the occasion of the conquest of Khaibar but conferred (a share) upon him only who had been present there with him. He, however, made an exception for the people of the boat, viz. for Ja'far and his companions. He allocated a share to them, and some persons from amongst the people said to us, viz. the people of the boat: We have preceded you in migration. Asma' bint 'Umais who had migrated to Abyssinia and had come back along with them (along with immigrants) visited Hafsa, the wife of Allah's Apostle (may peace be upon him). (Accordingly), Umar had been sitting with her (Hafsa). As 'Umar saw Asma, he said: Who is she? She (Hafsa) said: She is Asma, daughter of 'Umais. He said: She is an Abyssinian and a sea-woman. Asma said: Yes, it is so. Thereupon 'Umar said: We preceded you in migration and so we have more right to Allah's Messenger (may peace be upon him) as compared with you. At this she felt annoyed and said: 'Umar, you are not stating the fact; by Allah, you had the privilege of being in the company of the Messenger (may peace be upon him) who fed the hungry among you and instructed the ignorant amongst you, whereas we had been far (from here) in the land of Abyssinia amongst the enemies and that was all for Allah and Allah's Messenger (may peace be upon him) and, by Allah, I would never take food nor take water unless I make a mention to Allah's Messenger (may peace be upon him) of what you have said. We remained in that country in constant trouble and dread and I shall talk about it to Allah's Messenger (way peace be upon him) and ask him (about it). By Allah, I shall not tell a lie and deviate (from the truth) and add anything to that. So, when Allah's Apostle (may peace be upon him) came, she said: Allah's Apostle, 'Umar says so and so. Upon this Allah's Messenger (may peace be upon him) said: His right is not more than yours, for him and his companions there is one migration, but for you, i. e. for the people of the boat, there are two migrations. She said: I saw Abu Musa and the people of the boat coming to me in groups and asking me about this hadith, because there was nothing more pleasing and more significant for them than this. Abu Burda reported that Asma said: I saw Abu Musa, asking me to repeat this hadith to him again and again.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6097]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6097

'A'idh b. Amr reported that Abu Sufyan came to Salman, Suhaib and Bilal in the presence of a group of persons. They said: By Allah, the sword of Allah did not reach the neck of the enemy of Allah as it was required to reach. Thereupon Abu Bakr said: Do you say this to the old man of the Quraish and their chief? Then he came to Allah's Apostle (may peace be upon'him) and informed him of this. Thereupon he (the Holy Prophet) said: Abu Bakr, you have perhaps annoyed them and if you annoyed them you have in fact annoyed your Lord. So Abu Bakr came to them and said: O my brothers, I have annoyed you. They said: No, our brother, may Allah forgive you


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6098]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6098

Jabir b. Abdullah reported that it was concerning them (the Ansar) that this verse was revealed, that when the two groups amongst you were about to lose heart and Allah was the Guardian of them both. This concerned Banu Salama and Banu Haritha and we did not like that Allah, the Exalted and Glorious, should not have revealed this verse for the fact that Allah (gave an assurance) of being the Guardian of both.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6099]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6099

Zaid b. Arqam reported that Allah's Messenger (may peace be upon him) said: O Allah,, grant forgiveness to the Ansar, the offspring of the Ansar and the offspring of the offspring of the Ansar. This hadith has been narrated on the authority of Shulba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6100]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6100

Anas reported that Allah's Messenger (may peace be upon him) sought forgiveness for the Ansar and he said: I think (he also sought forgiveness) for the children of the Ansar and the slaves and the freed men of the Ansar. I have no doubt about it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6101]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6101

Anas reported that Allah's Messenger (may peace be upon him) saw children and women of the Ansar coming back from a wedding feast. Allah's Apostle (may peace be upon him) stood up motionless (as a mark of respect) and said: O Allah, (bear witness) (and addressing the Ansar), said: You are dearest to me amongst people, (and said: O Allah (bear witness) (and addressing the Ansar), said: You are dearest to me amongst people. And he meant Ansar.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6102]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6102

Anas b. Malik reported that a woman from the Ansar came to Allah's Messenger (may peace be upon him) and Allah's Messenger (may peace be upon him) stood aside with her and said: By Him in Whose Hand is my life, you are dearest to me amongst the people. He repeated it thrice. This hadith has been reported on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6103]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6103

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: The Ansar are my family and my trusted friends. and the people would increase in number whereas they (the Ansar) would become less and less, so appreciate the deeds of those from amongst them who do good and overlook their failings.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6104]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6104

Abu Usaid reported Allah's Messenger (may peace be upon him) as saying: The worthiest clans of the Ansar are Banu Najjar, thereafter Banu al-Ashhal; thereafter Banu Harith b. Banu Khazraj; thereafter Banu Sa'idah and there is goodness in all clans of the Ansar. Sa'd said: I see that he (the Holy Prophet) has placed others above us. It was said to (him): He has placed you above many others.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6105]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6105

Abu Usaid Ansari has reported this hadith through another chain of transmitters. When the Holy Prophet (may peace be upon him) was marching towards Badr in order


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6106]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6106

Anas reported a hadith like this from Allah's Apostle (may peace be upon him) but he has made no mention in the hadith of the words of Sa'd.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6107]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6107

Ibrahim b. Muhammad b. Talha reported: I heard Abu Sa'ld delivering an address in the presence of Abu 'Utba that the Messenger of Allah (may peace be upon him) said: The worthiest settlements of the Ansar are those of Banu Najjar, then of Banu 'Abu al-Ashhal and then of Banu Harith and then of Banu Khazraj and then of the clan of Banu Sa'idah, and if I were to give preference to anyone besides them I would have given preference to my relatives.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6108]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6108

Abu Usaid Ansar reported: I bear witness to the fact that Allah's Messenger (may peace be upon him) said: The best settlements of the Ansar are of those of Banu Najjar, then of Banu 'Abu al-Aslihal and then of Banu Harith b. Khazraj, then of Banu Sa'ida and there is in every settlement of the Ansar good. Abu Salama reported that Abu Usaid said: Can I tell a Iie about Allah's Messenger (may peace be upon him)? And if I were a liar, I would have started with my tribe Banu Sa'ida. This was conveyed to Sa'd b. 'Ubida and he found (rankling) in his mind and said: We have been left behind (in the sense) that we have been (mentioned) last of the four. He (Sa'd) sid: Saddle my pony so that I should go to Allah's Messenger (may peace be upon him). His nephew saw him and said: Are you going to contradict (the order of) precedence set by Allah's Messenger (may peace be upon him), whereas Allah's Messenger (may peace be upon him) has the best knowledge of it? Is it not sufficient for you that you are the fourth amongst the four (best tribes of the Ansar)? So he returned and said: Allah and His Messenger know best, and he commanded that his pony should be unsaddled.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6109]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6109

Abu Usaid Ansari reported that he heard Allah's Messenger (may peace be upon him) as saying: The worthiest of the Ansar or the worthiest of the settlements and the clans of Ansar; the rest of the hadith is the same, but there is no mention of the story of Sa'd b. 'Ubida (Allah be pleased with him).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6110]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6110

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying in a large gathering of the Muslims: Should I not tell you of the best clans of the Ansar? They said: Allah's Messenger, (kindly) do this. Thereupon Allah's Messenger said: That is Banu Abd al-Ashhal. They said: Allah's Messenger, then next? He said: Banu Najjar. They again said: Allah's Messenger, then next? He said: Then of Banu Harith b. Khazraj. They then said: Allah's Messenger, then next? He said. Then of Banu Sa'ida. They said: Allah's Messenger, then next? He said: There is good in all the clans of the Ansar. It was upon this that Sa'd b. Ubida stood up in annoyance and said: Are we the last of the four as Allah's Messenger (may peace be upon him) has determined (the order of precedence) of their clans? He decided to talk with Allah's Messenger (may peace be upon him) on this issue, but the people Of his tribe said to him: Be seated, are you not happy with this that Allah's Messenger' (may peace be upon him) has mentioned your clan as one of the four (best) clans and those whom he left and did not mention (the order of their precedence) are more than those whom he mentioned? And Sa'd b. 'Ubada dropped the idea of talking to Allah's Messenger (may peace be upon him) (on this issue).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6111]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6111

Anas b. Malik reported: I set out along with Jabrir b. 'Abdullah al-Bajali on a journey and he used to serve me. I said to him: Don't do that. Thereupon he said: I have seen Ansar doing this with Allah's Messenger (may peace be upon him). I swore by Allah whenever I accompany any one of the Ansar, I would serve him and Ibn Muthanni, and Ibn Bashshir made this addition in their narrations: Jarir was older than Anas, and Ibn Bashshir said: He was of a more advanced age as compared with Anas. Allah's Apostle (may peace be upon him) invoked blessings for the tribes of Ghifar and Aslam.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6112]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6112

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Go to your people and say that the Messenger of Allah (may peace be upon him) says: Ghifar (is a tribe) to whom Allah granted pardon, and Aslam (is the tribe) to whom Allah granted safety.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6113]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6113

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6114]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6114

This hadith has been reported on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6115]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6115

This hadith has been narrated through other chains of transmitters but all of them narrated on the authority of Jabir that Allah's Apostle (may peace be upon him) said: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6116]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6116

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: To the tribe of Aslam Allah has granted safety and to the tribe of Ghifar Allah has granted pardon. Verily it is not I that say this, but (it is) Allah the Exalted and Glorious. (who) says this.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6117]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6117

Khufaf b. Jura' reported that Allah's Messenger (may peace be upon him) said in prayer: O Allah, hurl curse upon the tribe of Lihyan and Ri'l aid Dhakwan and Usayya for they disobeyed Allah and His Messenger, (and for) Ghifar Allah has granted pardon and for the tribe of Aslam Allah has granted safety.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6118]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6118

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: Allah has granted pardon to the tribe of Ghifar and to the tribe of Aslam Allah has granted safety and as for Usayya tribe, they disobeyed Allah and His Messenger.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6119]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6119

This hadith has been transmitted on the authority of Ibn Umar with a slight variation of wording (and the wording) that Allah's Messenger (may peace be upon him) said this on the pulpit. This hadith has been reported on the authority of Ibn Umar but through another chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6120]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6120

Abu Ayyub reported Allah's Messenger (may peace be upon him) as saying: The tribes of Ansar, Muzaina and Juhaina and Ghifar and Ashja' and those from Banu 'Abdullah, they are my friends amongst the people and Allah and His Messenger are their protectors.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6121]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6121

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Quraish, Ansar, Muzaina, Juhaina and Ghifar, they are my friends and there is no friend of theirs besides Allah and His Messenger.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6122]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6122

This hadith has been transmitted on the authority of Sa'd b. Ibrahim with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6123]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6123

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The tribes of Ashja', Ghifar and Muzaina and from the tribe of Juhaina they are better than Banu Tamim, Banu Amir and the allies of Asad and Ghatfan.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6124]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6124

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is the life of Muhammad, (the tribes of) Ghifar, Aslam, Muzaina, or from the tribe of Juhaina or from the tribe of Muzaina, they would be better in the eye of Allah than Asad, Tayyi, and Ghatfan on the Day of Resurrection.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6125]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6125

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Aslam, Ghifar or some people from Muzaina, Juhaina (with the variation of words) are better in the eye of Allah than Asad, Ghatfan, Hawizin and Tamim. The narrator said: I think he also said:" On the Day of Resurrection."


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6126]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6126

Abu Bakra reported from his father that al-Aqra' b. Habis reported that he came to Allah's Messenger (may peace be upon him) and said to him: How did the tribes of Aslam, Ghifar, Muzaina (and I think he also said Juhaina and the narrator is in doubt about it) owe allegiance to you, whereas they plundered the pilgrims? Thereupon Allah's Messenger (may peace be upon him) said:" you were to say that Aslam, Ghifar, Muzaina and I think Juhaina are better than Banu Tamim, Banu 'Amir and Asad, Ghatfan, then would these people (of latter group of tribes) be in loss? He said: Yes. Thereupon he (the Holy Prophet) said: By Him in Whose Hand is my life, these people are better than Banu Tamim, Banu Amir, Asad and Ghatfan, and in this hadith of Abu Shaiba (these words are not found) that Muhammad (the narrator) had a doubt about.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6127]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6127

This hadith has been narrated on the authority of Abu Ya'qub Dabbi with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6128]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6128

Abu Bakra reported from the Messenger of Allah (may peace be upon him) that Aslam, Ghifar, Muzaina and Juhaina are better than Banu Tamim, Banu Amir and their allies Banu Asad and Ghatfan.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6129]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6129

This hadith has been reported on the authority of Abu Bishr with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6130]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6130

Abu Bakra reported on the authority of his father that Allah's Messenger (may peace be upon him) said: What is your view if Juhaina, Aslam, Ghifar were better than Banu Tamim, Banu 'Abdullah b. Ghatfan and 'Amir b. Sa'sa'a' respectively (then what would be status of the latter one)? He said this in a loud voice. They said: Allah's Messenger, they would be definitely at a loss and disadvantage. Thereupon he said: They (the first group) are decidedly better than the others; and in the hadith transmitted on the authority of Abu Kuraib the words are: It you were to find that Juhaina, Muzaina and Aslam and Ghifar (are better than...).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6131]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6131

'Adi b. Hatim reported: I came to Umar b. Khattab and he said to me: The first consignment of Sadaqa brought to Allah's Messenger (may peace be upon him) which brightened the face of Allah's Messenger (may peace be upon him) and the faces of his Companions was that of Tayyi.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6132]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6132

Abu Huraira reported that Tufail and his companions said: Allah's Messenger, the tribe of Daws has disbelieved and has belied you, so invoke curse upon them. It was said: Let Daws be destroyed, whereupon he (Allah's Messenger) said: Allah guide aright the tribe of Daws and direct them to me.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6133]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6133

Abu Huraira reported: Since I heard three things from Allah's Messenger (may peace be upon him) my love for Banu Tamim is never on the decline (and these things are): I heard Allah's Messenger (may peace be upon him) as saying about them that they would put up stout resistance against Dajjal amongst my Umma. And he (the narrator) said: (When) the consignment of Zakat was brought to him, Allah's Messenger (may peace be upon him) said: This is the charity of our people, and there was one slave-girl in the house of 'A'isha and she was from the tribe of Banu Tamim; thereupon Allah's Messenger (may peace be upon him) said: Set her free, for she is from the offspring of Isma'il. The other hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6134]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6134

Abu Huraira reported: There are some distinguishing features of Banu Tamim which I heard from Allah's Messenger (may peace be upon him) and my love for them is never on the decline after that and the words are: They are the bravest amongst people in the battlefield and there is no mention of (the word)" Dajjal".


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6135]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6135

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You would find people like those of mine, the good amongst you in the Days of Ignorance would be good amongst you in the days of Islam, provided they have an understanding of it and you will find good amongst people the persons who would be averse to position of authority until it is thrust upon them, and you will find the worst amongst persons one who has double face. He comes with one face to them and with the other face to the others.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6136]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6136

This hadith has been transmitted on the authority of Abu Zur'a with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6137]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6137

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Good amongst the women are those who ride camels. One of them said: They are pious women of the Quraish, and the other one said: The women of the Quraish are kind to the orphans in their childhood and look after the wealth of their spouses.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6138]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6138

This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording and there is no word" orphan".


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6139]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6139

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: The women of the Quraish are good amongst the womenfolk. They ride camels and show affection to their children and zealously guard the wealth of their husbands. Abu Huraira said at the end of this narration that Mary, the daughter of Imran, never rode the camel.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6140]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6140

Abu Huraira reported that Allah's Messenger (may peace be upon him) gave a proposal of marriage to Umm Hani, the daughter of Abu Talib, whereupon she said: Allah's Messenger, I am of an advanced age with a (large) family. Thereupon Allah's Messenger (may peace be upon him) said: The best women are those who ride (the camels) ; the rest of the hadith is the same but with this difference that, instead of the word Ar'a the word Ahna has been used (and the complete sentence is like this): That they treat children in their childhood with affection.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6141]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6141

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The best women who ride the camels are the pious women of the Quraish; they treat with affection children in their childhood and keep a strict watch on the wealth of their spouses.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6142]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6142

This hadith has been reported on the authority of Abu Huraira with the same chain of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6143]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6143

Anas reported that Allah's Messenger (may peace be upon him) established fraternity between Abu Ubaida b. Jarrah and Abu Talha.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6144]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6144

It was said to Anas b. Malik: You must have heard this that Allah's Messenger (may peace be upon him) said: There is no alliance (hilf) of brotherhood in Islam. Anas said: Allah's Messenger (may peace be upon him) established the bond of fraternity between the Quraish and the Ansar in his home.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6145]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6145

Anas reported Allah's Messenger (may peace be upon him) established fraternity between the Quraish and the Ansar in his house at Medina.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6146]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6146

Jubair b. Mut'im reported Allah's Messenger (may peace be upon him) as saying: There is no alliance (hilf) in Islam but (the hilf) established in the pre-Islamic days (for good). Islam intensifies and strengthens it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6147]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6147

Abu Burda reported on the authority of his father: We offered the sunset prayer along with Allah's Apostle (may peace be upon him). We then said: If we sit (along with Allah's Messenger) and observe night prayer with him it would be very good, so we sat down and he came to us and said: You are still sitting here. I said: Allah's Messenger, we observed evening prayer with you, then we said: Let us sit down and observe night prayer along with you, whereupon he said: You have done well or you have done right. He then lifted his head towards the sky and it often happened that as he lifted his head towards the sky, he said: The stars are a source of security for the sky and when the stars disappear there comes to the sky, i. e. (it meets the same fate) as it has been promised (it would plunge into darkness). And I am a source of safety and security to my Companions and when I would go away there would fall to the lot (of my Companions) as they have been promised with and my Companions are a source of security for the Umma and as they would go there would fall to the lot of my Umma as (its people) have been promised.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6148]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6148

Abu Sa'id Khudri reported Allah's Apostle (may peace be upon him) as saying: A time would come for the people when groups of people would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw Allah's Messenger (may peace be upon him)? And they would say: Yes, and they would be victorious. Then the people would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw those (who have had the privilege of sitting in the company of Allah's Messenger (may peace be upon him)? And they would say: Yes, and victory would be granted to them. Then a group of persons would set out for fighting in the cause of Allah and it would be said to them: Is there one amongst you who saw one of those who saw those who (had the privilege) of sitting in the company of Allah's Messenger (may peace be upon him)? And they would say: Yes, and the Victory would be granted to them.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6149]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6149

Abu Sa'id Khudri reported Allah's Messenger (may peace be upon him) as saying: There would come to the people a time when a detachment would be sent for fighting in the cause of Allah and they would say: See, if you can find amongst them someone from amongst the Companions of Allah's Apostle (may peace be upon him). They would find a person and they would be granted victory because of him. Then a second detachment would be sent to them and they would say: Do you find amongst them one who had had the privilege of seeing the Companions of the Apostle of Allah (may peace be upon him)? -and the victory would be granted to them because of him. Then the third detachment would be sent and it would be said to them: See, if you find amongst them (who had had the honour of seeing one) who saw those who saw the Companions of Allah's Apostle (may peace be upon him). Then the fourth detachment would be sent and it would be said to them: See it you find amongst them one who had the privilege (of seeing) one who saw those who saw those who saw the Companions of Allah's Apostle (may peace be upon him), and a person would be found and they would be granted victory because of him.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6150]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6150

Abdullah reported Allah's Messenger (may peace be upon him) as saying: The best of my Umma would be those of the generation nearest to mine. Then those nearest to them, then those nearest to them, then people would come whose witness would precede the oath and the oath will precede the witness. Hannad has not made the mention of Qarn in his narration. Qutaiba said that, instead of the word Qaum, the word Aqwam has been used.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6151]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6151

Abdullah reported: It was asked from Allah's Apostle (may peace be upon him) who amongst the people were the best. He said: (People) of my generation, then those next to them, then those next to them, then there would come a people whose evidence would precede their oath and their oath would precede their evidence. Ibrahim said: They forbade us to make vows and bear witness when we were too young.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6152]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6152

This hadith has been transmitted by Mansur on the authority of Abu al-Ahwas and Jarir with a slight variation of wording.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6153]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6153

'Abdullah (b. Mas'ud) reported Allah's Apostle (may peace be upon him) as saying: The best among people are of my generation, then those next to them. (The narrator said): I do not know whether (he said) it three times or four times. Then there would fellow after them such persons whose evidence would precede the oath, and in case of some others, the oath (would precede) the evidence.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6154]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6154

Abu Huraira reported Allah's Messenger (may, peace be upon him) as saying: The best age of my Umma is one in which I was sent (by Allah as an Apostle), then the one next to that. (The narrator said): And Allah knows best whether he stated this third (time) or not. Then there would come people who would love (to look) bulky and they would hasten to the witness box before they are asked to bear witness.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6155]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6155

This hadith has been reported on the authority of Abu Huraira through another chain of transmitters (but with this variation) that Abu Huraira said: I do not know whether he (the Holy Prophet) said (these words:" Then next" ) twice or thrice.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6156]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6156

Imran b. Husain reported Allah's-Messenger (may peace be upon him) as saying: The best among you (are) the people (who belong to) my age. Then those next to them, then those next to them, then those next to them. 'Imran said: I do not know whether Allah's Messenger (may peace be upon him) said twice or thrice (the words:" Then next" ) after (saying) about his (own age but he then said): Then after them (after successors or those who would succeed them) would come a people who would give evidence before they are asked for it, and would be dishonest and not trustworthy, who would make vows but would not fulfil them, and would be significant in being bulky.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6157]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6157

This hadith has been reported on the authority of Shu'ba with the same chain of transmitters (and the words are): I do not know whether he made a mention of two generations after his generation or of the third one too. Shababa said: I heard this from Zahdam b. Mudarrib as he came to me riding a horse for some need and he narrated it to me that he had heard it from 'Imran b. Husain, and in the hadith transmitted on the authority of Yahya and Shababa (the words are): They take an oath but they do not fulfil it, and in the hadith transmitted on the authority of Bahz there the word is Yafun as transmitted on the authority of Ibn Ja'far.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6158]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6158

This hadith has been narrated on the authority of 'Imran b. Husain through another chain of transmitters (and the words are): The best generation of this Umma is the generation to which I have been sent, then the next one, and there is an addition in the hadith transmitted on the authority of Abu 'Awana (and the words are): And Allah knows best whether he made a mention of the third (generation) or not; the rest of the hadith is the same as transmitted by Zahdam on the authority of 'Imran. And in the hadith transmitted by Hisham on the authority of Qatada there is an addition of these words: They take an oath whereas they are not asked to take.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6159]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6159

'A'isha reported that a person asked Allah's Apostle (may peace be upon him) as to who amongst the people were the best. He said: Of the generation to which I belong, then of the second generation (generation adjacent to my generation), then of the third generation (generation adjacent to the second generation).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6160]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6160

'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) led us 'Isha' prayer at the latter part of the night and when he had concluded it by salutations he stood up and said: Have you seen this night of yours? At the end of one hundred years after this none would survive on the surface of the earth (from amount my Companions). Ibn Umar said: People were (not understanding) these words of the Messenger of Allah (may peace be upon him) which had been uttered pertaining to one hundred years. Allah's Messenger (may peace be upon him) in fact meant (by these words) that on that day none from amongst those who had been living upon the earth (from amongst his Companions) would survive (after one hundred years) and that would be the end of this generation.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6161]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6161

This hadith has been transmitted by Zuhri on the authority of Ma'mar.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6162]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6162

Jabir b. 'Abdullah reported: I heard Allah's Messenger (may peace be upon him) as saying this one month before his death: You asked me about the Last Hour whereas its knowledge is with Allah. I, however, take an oath and say that none upon the earth, the created beings (from amongst my Companions), would survive at the end of one hundred years. This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters, but there is no mention of the words:" one month before his death".


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6163]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6163

Jabir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying one mouth before his death (or something like it): None amongst the created beings who had been living by that time (during the lifetime of Allah's Apostle).... 'Abd al-Rahman has interpreted these words of Allah's Apostle (may peace be upon him) as: The ages (of the people) would be diminished.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6164]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6164

This hadith has been reported on the authority of Sulaiman Taimi through other chains of transmitters.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6165]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6165

Abu Sa'id reported that when Allah's Apostle (may peace be upon him) came back from Tabuk they (his Companions) asked about the Last Hour. Thereupon Allah's Messenger (may peace be upon him) said: There would be none amongst the created beings living on the earth (who would survive this century).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6166]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6166

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) said: None amongst the created beings (from my Companions) would survive after one hundred years. Salim said: We made a mention of it to him (Jabir), whereupon he said: It means those who had been living on that day.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6167]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6167

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do not revile my Companions, do not revile my Companions. By Him in Whose Hand is my life, if one amongst you would have spent as much gold as Uhud it would not amount to as much as one much on behalf of one of them or half of it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6168]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6168

Abu Sa'id reported there was some altercation between Khalid b. Walid and Abd al-Rahman b. 'Auf and Khalid reviled him. Thereupon Allah's Messwger (may peace be upon him) said: None should revile my Companions. for if one amongst you were to spend as much gold as Uhud, it would not amount to as much as one mudd of one of them or half of it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6169]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6169

This hadith has been transmitted on the authority of al-A'mash and there is no mention by Shu'ba and Waki' of 'Abd al-Rahman b. Auf and Khalid.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6170]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6170

Usair b. Jabir reported that a delegation from Kufa came to 'Umar and there was a person amongst them who jeered at Uwais. Thereupon Umar said: Is there amongst us one from Qaran? That person came and Umar said: Verily Allah's Messenger (may peace be upon him) has said: There would come to you a person from Yemen who would be called Uwais and he would leave none in Yemen (behind him) except his mother, and he would have the whiteness (due to leprosy) and he supplicated Allah and it was cured except for the size of a dinar or dirham. He who amongst you meets him should ask him to supplicate for forgiveness (from Allah) for you.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6171]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6171

'Umar b. Khattab reported: I heard Allah's Messenger (may peace be upon him) as saying: Worthy amongst the successors would be a person who would be called Uwais. He would have his mother (living with him) and he would have (a small) sign of leprosy. Ask him to beg pardon for you (from Allah).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6172]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6172

Usair b. Jabir reported that when people from Yemen came to help (the Muslim army at the time of jihad) he asked them: Is there amongst you Uwais b. 'Amir? (He continued finding him out) until he met Uwais. He said: Are you Uwais b., Amir? He said: Yes. He said: Are you from the tribe of Qaran? He said: Yes. He (Hadrat) 'Umar (again) said: Did you suffer from leprosy and then you were cured from it but for the space of a dirham? He said: Yes. He ('Umar) said: Is your mother (living)? He said: Yes. He ('Umar) said: I heard Allah's Messenger (may peace be upon him) say: There would come to you Uwais b. Amir with the reinforcement from the people of Yemen. (He would be) from Qaran, (the branch) of Murid. He had been suffering from leprosy from which he was cured but for a spot of a dirham. His treatment with his mother would have been excellent. If he were to take an oath in the name of Allah, He would honour that. And if it is possible for you, then do ask him to beg forgiveness for you (from your Lord). So he (Uwais) begged forgiveness for him. Umar said: Where do you intend to go? He said: To Kufa. He ('Umar) said: Let me write a letter for you to its governor, whereupon he (Uwais) said: I love to live amongst the poor people. When it was the next year, a person from among the elite (of Kufa) performed Hajj and he met Umar. He asked him about Uwais. He said: I left him in a state with meagre means of sustenance. (Thereupon) Umar said: I heard Allah's Messenger (may peace be upon him) as saying: There would come to you Uwais b. 'Amir, of Qaran, a branch (of the tribe) of Murid, along with the reinforcement of the people of Yemen. He had been suffering from leprosy which would have been cured but for the space of a dirham. His treatment with his mother would have been very kind. If he would take an oath in the name of Allah (for something) He would honour it. Ask him to beg forgiveness for you (from Allah) in case it is possible for you. So he came to Uwais and said.: Beg forgiveness (from Allah) for me. He (Uwais) said: You have just come from a sacred journey (Hajj) ; you, therefore, ask forgiveness for me. He (the person who had performed Hajj) said: Ask forgiveness for me (from Allah). He (Uwais again) said: You have just come from the sacred journey, so you ask forgiveness for me. (Uwais further) said: Did you meet Umar? He said: Yes. He (Uwais) then begged forgiveness for him (from Allah). So the people came to know about (the status of religious piety) of Uwais. He went away (from that place). Usair said: His clothing consisted of a mantle, and whosoever saw him said: From where did Uwais get this mantle?


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6173]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6173

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: You would soon conquer a land where people are in the habit of using foul language. They have a right of kinship upon you. And when you see two persons fighting for the space of a brick, then get out of that. He (Abu Dharr) then happened to pass by Rabila and 'Abd al-Rahman, the two sons of Shurahbil b. Hasana, and they had been disputing for the space of a brick. So he left the land.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6174]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6174

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: You would soon conquer Egypt and that is a land which is known (as the land of al-qirat). So when you conquer it, treat its inhabitants well. For there lies upon you the responsibility because of blood-tie or relationship of marriage (with them). And when you see two persons falling into dispute amongst themselves for the space of a brick, than get out of that. He (Abu Dharr) said: I saw Abd al-Rahman b. Shurahbil b. Hasana and his brother Rabi'a disputing with one another for the space of a brick. So I left that (land).


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6175]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6175

Abu Barza reported that Allah's Messenger (may peace be upon him) sent a person to a tribe amongst the tribes of Arabia. They reviled him and beat him. He came to Allah's Messenger (may peace be upon him) and narrated to him (the story of atrocities perpetrated upon him by the people of the tribe). Thereupon he (the Holy Prophet) said: If you were to come to the people of 'Uman, they would have neither reviled you nor beaten you.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6176]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6176

Abu Naufal reported: I saw (the dead body) of Abdullah b. Zubair hanging on the road of Medina (leading to Mecca). The Quraish passed by it and other people too, that Abdullah b. Umar happened to pass by it. He stood up there and said: May there be peace upon you, Abu Khubaib (the Kunya of Hadrat 'Abdullah b. Zubair), may there be peace upon you Abu Khubaib, may there be peace upon you, Abu Khubaib! By Allah, I used to forbid you from this; by Allah, I used to forbid you from this, by Allah I used to forbid you from this. By Allah, so far as I know, you had been very much devoted to fasting and prayer and you had been paying very much care to cementing the ties of blood. By Allah, the group to which you belong (are labelled) as (a) wicked (person) is indeed a fine group. Then 'Abdullah b. 'Umar went away. The stand 'Abdullah (b. 'Umar) took in regard to the inhuman treatment (meted out to 'Abdullah b. Zubair) and his words (in that connection) were conveyed to Hajjaj (b. Yusuf) and (as a consequence of that) he (the body of Abdullah b. Zubair) was brought down from the stump (the scaffold) by which it was hanging and thrown into the graves of the Jews. He (Hajjaj) sent (his messenger) to Asma' (bint Abu Bakr, 'Abdullah's mother). But she refused to come. He again sent the messenger to her with the message that she must come, otherwise he would bring her forcibly catching hold of her hair. But she again refused and said: By Allah, I will not come to you until you send one to me who would drag me by pulling my hair. Thereupon he said: Bring me my shoes. He put on his shoes and walked on quickly swollen with vanity and pride until he came to her and said: How do you find what I have done with the enemy of Allah? She said: I find that you wronged him in this world, whereas he has spoiled your next life. It has been conveyed to me that you used to call him ('Abdullah b. Zubair) as the son of one having two belts. By Allah, I am indeed (a woman) of two belts. One is that with the help of which I used to suspend high the food of Allah's Messenger (may peace be upon him) and that of Abu Bakr (making it out of the reach) of animals and, so far as the second belt is concerned, that is the belt which no woman can dispense with. Verily Allah's Messenger (may peace be upon him) told us that in Thaqif, there would be born a great liar and great murderer. The liar we have seen, and as far as the murderer is concerned, I do not find anyone else besides you. 'Thereupon he (Hajjaj) stood up and did not give any reply to her.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6177]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6177

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If the din were at the Pleiades, even then a person from Persia would have taken hold of it, or one amongst the Persian descent would have surely found it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6178]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6178

Abu Huraira reported: We were sitting in the company of Allah's Apostle (may peace be upon him) that Sura al-Jumu'a was revealed to him and when he recited (these words):" Others from amongst them who have not yet joined them," a person amongst them (those who were sitting there) said: Allah's Messenger! But Allah's Apostle (may peace be upon him) made no reply, until he questioned him once, twice or thrice. And there was amongst us Salman the Persian. The Apostle of Allah (may peace be upon him) placed his hand on Salman and then said: Even if faith were near the Pleiades, a man from amongst these would surely find it.


Muslim :: The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah) :: [31.6179]

The Book Pertaining to the Merits of the Companions (Allah Be Pleased With Them) of the Holy Prophet (May Peace Be Upon Him) (Kitab Al-Fada'il Al-Sahabah)

Muslim :: Book 31 : Hadith 6179

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: You would find people like one hundred camels and you would not find even one (camel) fit for riding.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6180]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6180

Abu Huraira reported that a person came to Allah, 's Messenger (may peace be upon him) and said: Who among the people is most deserving of a fine treatment from my hand? He said: Your mother. He again said: Then who (is the next one)? He said: Again it is your mother (who deserves the best treatment from you). He said: Then who (is the next one)? He (the Holy Prophet) said: Again, it is your mother. He (again) said: Then who? Thereupon he said: Then it is your father. In the hadith transmitted on the authority of Qutalba, there is no mention of the word" the people".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6181]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6181

Abu Huraira reported that a person said: Allah's Messenger, who amongst the people is most deserving of my good treatment? He said: Your mother, again your mother, again your mother, then your father, then your nearest relatives according to the order (of nearness).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6182]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6182

Abu Huraira reported: A person came to Allah's Apostle (may peace be upon him). The rest of the hadith is the same as transmitted by jarir but with this addition: By your father, you would get the information.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6183]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6183

This hadith has been narrated on the authority of Ibn Shubruma with the same chain of transmitters and the hadith transmitted on the authority of Wuhaib there is a slight variation of wording. Same is the case with the hadith transmitted on the authority of Muhammad b. Talha (and the words are):" Who amongst the people deserves the best treatment from me".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6184]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6184

Abdullah b. 'Anir reported that a person came to Allah's Apostle (may peace be upon him) and sought permission (to participate) in Jihad, whereupon he (the Holy Prophet) said: Are your parents living? He said: Yes. Thereupon he (the Holy Prophet) said: You should put in your best efforts (in their) service.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6185]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6185

This hadith has been narrated on the authority of Habib with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6186]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6186

Yazid b. Abu Habib reported that Na'im, the freed slave of Umm Salama, reported to him that 'Abdullah b. 'Amr b. 'As said: There came to Allah's Apostle (may peace be upon him) a person and said: I owe allegiance to you for migration and Jihad seeking reward only from Allah. He (the Holy Prophet) said: Is one from amongst your parents living? He said: Yes, of course, both are living. He further asked: Do you want to seek reward from Allah? He said: Yes. Thereupon Allah's Messenger (may peace be upon him) said: Go back to your parents and accord them benevolent treatment.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6187]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6187

Abu Huraira reported that Juraij was one who was devoted to (prayer) in the temple. His mother came to him. Humaid said that Abu Rafi' demonstrated before us like the demonstration made by abu Huraira to whom Allah's Messenger (may peace be upon him) had demonstrated as his mother called him placing her palms upon the eyebrows and lifting her head for calling him and said: Juraij, it is your mother, so talk to her. She found him at that time absorbed in prayer, so he said (to himself): O Lord, my mother (is calling me) (whereas I am absorbed) in my prayer. He opted for prayer. She (his mother) went back, then came again for the second time and said: O Juraij, it is your mother (calling you), so talk to me. He said: O Allah. there is my mother also and my prayer, and he opted for prayer. She said: O Allah, this Juraij is my son. I pray to talk to him but he refuses to talk to me. O Allah, don't bring death to him unless he has seen the prostitutes, and had she invoked the curse upon him (from the heart of her heart) he would have been involved in some turmoil. There was a shepherd living near by his temple (the temple where Juraij was engaged in prayer). It so happened that a woman of that village came there and that shepherd committed fornication with her and she became pregnant and gave birth to a child. It was said to her: Whose child is this? She said: He is the child of one who is living in this temple. So there came persons with hatchets and spades. They called Juraij. He was absorbed in prayer and he did not talk to them and they were about to demolish that temple that he saw them and then came to them and they said: Ask her (this woman) what she says. He smiled and then touched the head of the child and said: Who is your father? He (the child) said: My father is the shepherd of the sheep, and when they heard this, they said: We are prepared to rebuild with gold and silver what we have demolished from your temple. He said: No, rebuild it with clay as it had been before. He then went up (to his room and absorbed himself in prayer).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6188]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6188

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: None spoke in the cradle but only three (persons), Christ son of Mary, the second one the companion of Juraij. Juraij had got constructed a temple and confined himself in that. His mother came to him as he was busy in prayer and she said: Juraij. He said: My Lord, my mother (is calling me while I am engaged in) my prayer. He continued with the prayer. She returned and she came on the next day and he was busy in prayer, and she said: Juraij. And he said: My Lord, my mother (is calling me while I am engaged) in prayer, and he continued with the prayer and she went back, and then on the next day she again came and he was busy in prayer and she said: Juraij. And he said: My Lord, my mother (is calling me while I am engaged in my prayer, and he continued with the prayer, and she said: My Lord, don't give him death unless he has seen the fate of the prostitutes. The story of Juraij and that of his meditation and prayer gained currency amongst Bani Isra'il. There was a prostitute who had been a beauty incarnate. She said (to the people): If you like I can allure him to evil. She presented herself to him but he paid no heed (to her). She came to a shepherd who lived near the temple and she offered herself to him and he had a sexual intercourse with her and so she became pregnant arid when she gave birth to a child she said: This is from Juraij. So they came and asked him to get down and demolished the temple and began to beat him. He said: What is the matter? They said: You have committed fornication with this prostitute and she has given birth to a child from your loins. He said: Where is the child? They brought him (the child) and he said: just leave me so that I should observe prayer. And he observed prayer and when he finished, he came to the child. He struck his stomach and said: O boy, who is your father? lie said: He is such shepherd. So they turned towards Juraij, kissed him and touched him (for seeking blessing) and said: We are prepared to construct your temple with gold. He said. No, just rebuild it with mud as it had been, and they did that. Then there was a babe who was sucking his mother that a person dressed in fine garment came riding upon a beast. His mother said: O Allah, make my child like this one. He (the babe) left sucking and began to see towards him, and said: O Allah, don't make me like him. He then returned to the chest and began to suck the milk of his mother. He (Abu Huraira) said: I perceived as if I am seeing Allah's Messenger (may peace be upon him) as he is explaining the scene of his sucking milk with his forefinger in his mouth and sucking that. He (Abu Huraira) further reported Allah's Apostle (may be peace upon him) as saying: There happened to pass by him a girl who was being beaten and they were saying: You have committed adultery and you have committed theft and she was saying: Allah is enough for me and He is my good Protector, and his mother said: O Allah, don't make my child like her and he left sucking the milk, and looked towards her and said: O Allah, make me like her, and there was a talk between them. She said: O with shaven head, a good-looking person happened to pass by and I said: O Allah, make my child like him, and you said: O Allah, don't make me like him, and they passed by a girl while they were beating her and saying: You committed fornication and you committed theft, and I said: O Allah, don't make my child like her, and you said: O Allah, make me like her. Thereupon he said: That person was a tyrant, and I said: O Allah, don't make me like him, and they were saying about her: You committed fornication whereas in fact she had not committed that and they were saying: You have committed theft whereas she had not committed theft, so I said: O Allah, make me like her.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6189]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6189

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Let him be humbled into dust; let him be humbled into dust. It was said: Allah's Messenger, who is he? He said: He who sees either of his parents during their old age or he sees both of them, but he does not enter Paradise.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6190]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6190

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let him be humbled, let him be humbled. It was said: Allah's Messenger, who is he? He said. He who finds his parents in old age, either one or both of them, and does not enter Paradise.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6191]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6191

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Let him be humbled thrice, and the rest of the hadith is the same.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6192]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6192

Ibn Dinar reported that a desert Arab met Abdullah b. 'Umar on the way to Mecca. 'Abdullah greeted him and mounted him upon the donkey on which he had been riding and gave him the turban that he had on his head. Ibn Dinar (further) reported: We said to him ('Abdullah b. 'Umar): May Allah do good to you, these are desert Arabs and they are satisfied even with meagre (things). Thereupon Abdullah said: His father was loved dearly by 'Umar b. Khattib and I heard Allah's Messenger (may peace be upon him) as saying: The finest act of goodness on the part of a son is to treat kindly the loved ones of his father.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6193]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6193

'Abdullah b. Umar reported Allah's Apostle (may peace be upon him) as saying: The finest act of goodness is that a person should treat kindly the loved ones of his father.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6194]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6194

Abdullah b. Dinar reported that when 'Abdullah b. 'Umar set out to Mecea, 'he kept a donkey with him which he used as a diversion from the tedium of journey on the camel's back and had a turban which he tied round his head. One day, as he was riding the donkey a desert Arab happened to pass by him. He ('Abdullah b. 'Umar) said: Arn't you so and so? He said: Yes He gave him his donkey and said: Ride it, and tie the turban round your head. Some of his companions said: May Allah pardon you, you gave to this desert Arab the donkey on which you enjoyed ride for diversion and the turban which you tied round your. head. Thereupon he said: Verily I heard Allah's Messenger (may peace be upon him) as saying: The finest act of goodness is the kind treatment of a person to the loved ones of his father after his death and the father of this person was a friend of 'Umar.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6195]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6195

Nawwas b. Sim'an al-Ansiri reported: I asked Allah's Messenger (may peace be upon him) about virtue and vice. He said: Virtue is a kind disposition and vice is what rankles in your heart and that you disapprove that people should come to know of it.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6196]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6196

Nawwis b. Sim'in reported: I stayed with Allah's Messenger (may peace be upon him) for one year. What obstructed me to migrate was (nothing) but (persistent) inquiries from him (about Islam). (It was a common observation) that when anyone of us migrated (to Medina) he ceased to ask (too many questions) from Allah's Messenger (may peace be upon him). So I asked him about virtue and vice. Thereupon Allah's Messenger (may peace be upon him) said: Virtue is a kind disposition and vice is what rankles in your mind and that you disapprove of its being known to the people.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6197]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6197

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: Verily Allah created the universe and when He had finished that, ties of relationship came forward and said This is the place for him who seeks refuge from severing (of blood-relationship). He said: Yes. Are you not satisfied that I should keep relationship with one who joins your ties of relationship and sever it with one who severs your (ties of relationship)? They (the ties of blood) said: Certainly so. Thereupon He said: Well, that is how things are for you. Allah's Messenger (may peace be upon him) then said: Recite if you like:" But if you turn away you are sure to make mischief in the land and cut off the ties of kinship. Those it is whom Allah has cursed, so He has made them deaf and blinded their eyes. Do they not reflect on the Qur'an? Or, are there locks on their hearts?".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6198]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6198

'A'isha reported Allah's Messenger (may peace be upon him) as saying: The tie of kinship is suspended to the Throne and says: He who unites me Allah would unite him and he who severed me Allah would sever him.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6199]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6199

Jubair b. Mut'im reported on the authority of his father that Allah's Messenger (may peace be upon him) said: The severer would not enter Paradise. Ibn Umar said that Sufyan (explained it as): One who severs the tie of kinship would not enter Paradise.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6200]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6200

Jubair b. Mutlim reported that his father narrated to him that Allah's Messenger (may peace be upon him) said: The severer of the tie of kinship would not get into Paradise.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6201]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6201

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6202]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6202

Anas b. Malik reported: I heard Allah's Messenger (may peace be upon him) as saying: He who is desirous that his means of sustenance should be expanded for him or his age may be lengthened, should join the tie of relationship.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6203]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6203

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: He who likes that his sustenance should be expanded and his age may be lengthened should join the tie of kinship.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6204]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6204

Abu Huraira reported that a person said: Allah's Messenger, I have relatives with whom I try, to have close relationship, but they sever (this relation). I treat them well, but they treat me ill. I am sweet to them but they are harsh towards me. Upon this he (the Holy Prophet) said: If it is so as you say, then you in fact throw hot ashes (upon their faces) and there would always remain with you on behalf of Allah (an Angel to support you) who would keep you dominant over them so long as you adhere to this (path of righteousness).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6205]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6205

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Neither nurse mutual hatred, nor jealousy, nor enmity, and become as fellow. brothers and servants of Allah. It is not lawful fora Muslim that he should keep his relations estranged with his brother beyond three days.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6206]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6206

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying like this. This hadith has been narrated through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6207]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6207

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters with the addition of Ibn Uyaina (and the words are):" Do not cut off (mutual relations)."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6208]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6208

This hadith has been narrated through another chain of transmitters and the hadith transmitted on the authority of Abd al-Razziq (the words are):" Neither nurse grudge nor sever (the ties of kinship), nor nurse enmity."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6209]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6209

Anas reported Allah's Apostle (may peace be upon him) as saying: Nurse no grudge, nurse no aversion and do not sever ties of kinship and live like fellow-brothers as servants of Allah. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with this addition:" As Allah has commanded you."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6210]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6210

Abu Ayyub Ansiri reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a Muslim to have estranged relations with his brother beyond three nights, the one turning one way and the other turning the other way when they meet; the better of the two is one who is the first to give a greeting.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6211]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6211

This hadith has been transmitted on the authority of Zuhri with a slight variation of wording (and the words are):" The one turning away and the other turning away when they meet and one avoids the other and the other also avoids him."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6212]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6212

'Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: It is not permissible for a Muslim to have estranged relations with his brother beyond three days.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6213]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6213

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There should be no estranged relations beyond three days.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6214]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6214

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Avoid suspicion, for suspicion is the gravest lie in talk and do not be inquisitive about one another and do not spy upon one another and do not feel envy with the other, and nurse no malice, and nurse no aversion and hostility against one another. And be fellow-brothers and servants of Allah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6215]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6215

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't have estranged relations (with the others) and don't nurse enmity and don't enter into a transaction when the other (has already entered) and be fellow-brothers and servants of Allah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6216]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6216

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying. Don't nurse malice against one another, don't nurse aversion against one another and don't be inquisitive about one another and don't outbid one another (with a view to raising the price) and be fellow-brothers and servants of Allah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6217]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6217

This hadith has been narrated on the authority of A'mash with the same chain of transmit ters (and the words are):" Don't sever relations of kinship, don't bear enmity against one another, don't bear aversion against one another and don't feel envy against the other and live as fellow-brothers as Allah has commanded you.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6218]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6218

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't bear aversion against one another and don't be jealous of one another and be servants of Allah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6219]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6219

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Don't nurse grudge and don't bid him out for raising the price and don't nurse aversion or enmity and don't enter into a transaction when the others have entered into that transaction and be as fellow-brothers and servants of Allah. A Muslim is the brother of a Muslim. He neither oppresses him nor humiliates him nor looks down upon him. The piety is here, (and while saying so) he pointed towards his chest thrice. It is a serious evil for a Muslim that he should look down upon his brother Muslim. All things of a Muslim are inviolable for his brother in faith: his blood, his wealth and his honour.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6220]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6220

This hadith has been transmitted on the authority of Abu Huraira with some addition (and it is this):" Verily Allah does not look to your bodies nor to your faces but He looks to your hearts," and he pointed towards the heart with his fingers.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6221]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6221

Abu Huraira reported Allah's Messenger (may peace be upqn him) as saying: Verily Allah does not look to your faces and your wealth but He looks to your heart and to your deeds.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6222]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6222

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The gates of Paradise are not opened but on two days, Monday and Thursday. and then every servant (of Allah) is granted pardon who does not associate anything with Allah except the person in whose (heart) there is rancour against his brother. And it would be said: Look towards both of them until there is reconciliation; look toward both of them until there is reconciliation; look towards both of them until there is reconciliation. This hadith has been narrated on the authority of Suhail who narrated it on the authority of his father with the chain of transmitters of MaIik, but with this variation of wording:, (Those would not be granted pardon) who bycott each other."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6223]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6223

Abu Huraira reported it as a marfu' hadith (and the words are): The deeds are presented on every Thursday and Friday and Allah, the Exalted and Glorious. grants pardon to every person who does not associate anything with Allah except the person in whose (heart) there is rancour against his brother. It would be said: Put both of them off until they are reconciled.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6224]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6224

Abu Huraim reported Allah's Messenger (may peace be upon him) as saying The deeds of people would be presented every week on two days, viz. Monday and Thursday, and every believing servant would be granted pardon except the one in whose (heart) there is rancour against his brother and it would he said: Leave them and put them off until they are turned to reconciliation.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6225]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6225

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily. Allah would say on the Day of Resurrection: Where are those who have mutual love for My Glory's sake? Today I shall shelter them in My shadow when there is no other shadow but the shadow of Mine.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6226]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6226

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: A person visited his brother in another town and Allah deputed an Angel to wait for him on his way and when he came to him he said: Where do you intend to go? He said: I intend to go to my brother in this town. He said: Have you done any favour to him (the repayment of which you intend to get)? He said: No, excepting this that I love Mm for the sake of Allah, the Exalted and Glorious. Thereupon he said: I am a meesenger to you from, Allah: (to inform you) that Allah loves you as you love him (for His sake) This hadith has been narrated on the authority of Hammid b. Salama with the same of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6227]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6227

Abu Rabi' reported directly from Allah's Apostle (may peace upon him) as saying: The one who visits the sick is in fact like one who is in the fruit garden of Paradise so long as he does not return.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6228]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6228

Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said: He who visits the sick continues to remain in the fruit garden of Paradise until he returns.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6229]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6229

Thauban reported Allah's Apostle (may peace be upon him) as saying: Verily, when a Muslim visits his brother in Islam he is supposed to remain in the fruit garden of Paradise until he returns.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6230]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6230

Thauban, the freed slave of Allah's Messenger (may peace be upon him), reported Allah's Messenger (may peace be upon him) as saying: He who visits the sick is supposed to remain in the fruit garden of Paradise. It was said: Allah's Messenger, what is this Khurfat-ul-jannah? He said: It is a place abounding in fruits.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6231]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6231

This hadith has been narrated on the authority of Asim al-Ahwal with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6232]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6232

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Verily, Allah, the Exalted and Glorious, would say on the Day of Resurrection: O son of Adam, I was sick but you did not visit Me. He would say: O my Lord; how could I visit Thee whereas Thou art the Lord of the worlds? Thereupon He would say: Didn't you know that such and such servant of Mine was sick but you did not visit him and were you not aware of this that if you had visited him, you would have found Me by him? O son of Adam, I asked food from you but you did not feed Me. He would say: My Lord, how could I feed Thee whereas Thou art the Lord of the worlds? He said: Didn't you know that such and such servant of Mine asked food from you but you did not feed him, and were you not aware that if you had fed him you would have found him by My side? (The Lord would again say: ) O son of Adam, I asked drink from you but you did not provide Me. He would say: My Lord, how could I provide Thee whereas Thou art the Lord of the worlds? Thereupon He would say: Such and such of servant of Mine asked you for a drink but you did not provide him, and had you provided him drink you would have found him near Me.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6233]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6233

'A'isha reported, I did not see anyone else being afflicted with more severe illness than Allah's Messenger (may peace be upon him). In the narration transmitted by 'Uthman there is a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6234]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6234

This hadith has been narrated on the authority of A'mash through other chains of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6235]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6235

'Abdullah reported: I visited Allah's Messenger (may peace be upon him) as he was running high temperature. I touched his body with my bard and said to him: Allah's Messenger, you are running high temperature, whereupon Allah's Messenger (may peace be upon him) said: Yes, it is so. I comparatively have a more severe fever than any one of you. I said: Is it because there is a double reward in store for you? Thereupon Allah's Messenger (may peace be upon him) said: Yes, it is so. And Allah's Messenger (may peace be upon him) again said: When a Muslim falls ill, his compensation is that his minor sins are obliterated just as leaves tall (in autumn). In the hadith transmitted on the authority of Zubair there is (no mention of these words):" I touched his body with my hands."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6236]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6236

This hadith has been transmitted on the authority of jarir and the hadith transmitted on the authority of Abu Mu'awiya there is an addition of these words: He said: Yes, by Him in Whose Hand is my life, there is no Muslim upon the earth." The rest of the hadith is the same.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6237]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6237

Aswad reported that some young men from the Quraish visited 'A'isha as she was in Mina and they were laughing. She said: What makes you laugh? They said: Such and such person stumbled against the rope of the tent and he was about to break his neck or lose his eyes. She said: Don't laugh for I heard Allah's Messenger (may peace be upon him) as saying: If a Muslim runs a thorn or (gets into trouble) severe than this, there is assured for him (a higher) rank and his sins are obliterated.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6238]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6238

'A'isha reported Allah's Messenger (may peace be upon him) as saying: A believer does not receive (the trouble) of running a thorn or more than that but Allah elevates him in rank or effaces his sins because of tbat.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6239]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6239

'A'isha reported Allah's Messenger (may peace be upon him) as saying: A believer does not undergo (the trouble) of running a thorn or more than that when Allah effaces his sins.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6240]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6240

'A'isha said: No trouble comes to a believer even if it is the pricking of a thorn that it becomes (the means) whereby his sins are effaced or his sins are obliterated. Yazid says: He does not know which word 'Urwa said (whether he said Qussa or Kuffira).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6241]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6241

'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: There is nothing (in the form of trouble) that comes to a believer even if it is the pricking of a thorn that there is decreed for him by Allah good or his sins are obliterated.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6242]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6242

Abu Sa'id and abu Huraira reported that they heard Allah's Messenger (may peace be upon him) as saying: Never a believer is stricken with discomfort, hardship or illness, grief or even with mental worry that his sins are not expiated for him.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6243]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6243

Abu Huraira reported that when this verse was revealed:" Whoever does evil will be requited for it", and when this was conveyed to the Muslims they were greatly perturbed. Thereupon Allah's Messenger (may peace be upon him) said: Be moderate and stand firm in trouble that falls to the lot of a Muslim (as that) is an expiation for him; even stumbling on the path or the prickin of a thorn (are an expiation for him). Muslim said that 'Umar b. Abd al-Rahman Muhaisin was from amongst the people of Mecca.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6244]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6244

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) visited Umm Sa'ib or Umm Musayyib and said: Umm Sa'ib or Umm Musayyib. why is it that you are shivering? She said:" It is fever and may it not be blessed by Allah, whereupon he (the Holy Prophet) said: Don't curse fever for it expiates the sir of the posterity of Adam just as furnace removes the alloy of iron.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6245]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6245

'Ata' b. Abi Rabih said: Ibn Abbas said to me: May I show you a woman of Paradise? I said: Yes. He said: Here is this dark-complexioned woman. She came to Allah's Apostle (may peace be upon him) and said: I am suffering from falling sickness and I become naked; supplicate Allah for me, whereupon he (the Holy Prophet) said: Show endurance as you can do and there would be Paradise for you and, if you desire, I supplicate Allah that He may cure you. She said: I am prepared to show endurance (but the unbearable trouble is) that I become naked, so supplicate Allah that He should not let me become naked, so he supplicated for her.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6246]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6246

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, said: My servants, I have made oppression unlawful for Me and unlawful for you, so do not commit oppression against one another. My servants, all of you are liable to err except one whom I guide on the right path, so seek right guidance from Me so that I should direct you to the right path. O My servants, all of you are hungry (needy) except one whom I feed, so beg food from Me, so that I may give that to you. O My servants, all of you are naked (need clothes) except one whom I provide garments, so beg clothes from Me, so that I should clothe you. O My servants, you commit error night and day and I am there to pardon your sins, so beg pardon from Me so that I should grant you pardon. O My servants, you can neither do Me any harm nor can you do Me any good. O My servants, even if the first amongst you and the last amongst you and even the whole of human race of yours, and that of jinns even, become (equal in) God-conscious like the heart of a single person amongst you, nothing would add to My Power. O My servants, even if the first amongst you and the last amongst you and the whole human race of yours and that of the Jinns too in unison become the most wicked (all beating) like the heart of a single person, it would cause no loss to My Power. O My servants, even if the first amongst you and the last amongst you and the whole human race of yours and that of jinns also all stand in one plain ground and you ask Me and I confer upon every person what he asks for, it would not. in any way, cause any loss to Me (even less) than that which is caused to the ocean by dipping the needle in it. My servants, these for you I shall reward you for thern, so he who deeds of yours which I am recording finds good should praise Allah and he who does not find that should not blame anyone but his ownself. Sa'id said that when Abu Idris Khaulini narrated this hadith he knelt upon his knees.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6247]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6247

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that he reported it from his Lord, the Exalted and Glorious: Verily I have made oppression unlawful for Me and for My servants too, so do not commit oppression. The rest of the hadith is the same.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6248]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6248

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: Be on your guardagainst committing oppression, for oppression is a darkness on the Day of Resurrection, and be on your guard against pettimindedness for pettimindedness destroyed those who were before you, as it incited them to shed blood and make lawful what was unlawful for them.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6249]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6249

Ibu 'Umar reported Allah's Messenger (may peace be upon him) as saying: Oppression is the darkness on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6250]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6250

Salim reported on the authority of his father that Allah's Messenger (may peace be upon him) said: A Muslim is the brother of a fellow-Muslim. He should neither commit oppression upon him nor ruin him, and he who meets the need of a brot'ier, Allah would meet big needs, and he who relieved a Muslim from hardship Allah would relieve him from the hardships to which he would be put on the Day of Resurrection, and he who did not expose (the follies of a Muslim) Allah would conceal his follies on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6251]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6251

Abu Huraira. reported Allah's Messenger (may peace be upon him) as saying: Do you know who is poor? They (the Companions of the Holy Prophet) said: A poor man amongst us is one who has neither dirham with him nor wealth. He (the Holy Prophet) said: The poor of my Umma would be he who would come on the Day of Resurrecton with prayers and fasts and Zakat but (he would find himself bankrupt on that day as he would have exhausted his funds of virtues) since he hurled abuses upon others, brought calumny against others and unlawfully consumed the wealth of others and shed the blood of others and beat others, and his virtues would be credited to the account of one (who suffered at his hand). And if his good deeds fall short to clear the account, then his sins would be entered in (his account) and he would be thrown in the Hell-Fire.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6252]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6252

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The claimants would get their claims on the Day of Ressurection so much so that the hornless sheep would get its claim from the horned sheep.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6253]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6253

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, grants respite to the oppessor. But when He lays Hand upon him, He does not then let him off. Re (the Holy Prophet) then recited this verse:" Such is the chastisement of thy Lord when He chastises the towns (inhabited by) wrongdoing persons. Surely, His punishment is painful, severe" (xi. 103).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6254]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6254

Jabir b. Abdullah reported that two young men, one from the Muhajirin (emigrants) and the other one from the Angr (helpers) fell into dispute and the Muhajir called his fellow Muhajirin, and the Ansari (the helper) called the Ansar (for help). In the meanwhile, Allah's Messenger (may peace be upon him) came there and said: What is this, the proclamation of the days of jahiliya (ignorance)? They said: Allah's Messenger, there is nothing serious. The two young men fell into dispute and the one struck at the back of the other. Thereupon he (the Holy Prophet) said: Well, a person should help his brother whether he is an oppressor or an oppressed. If he is the oppressor he should prevent him from doing it, for that is his help; and if he is the oppressed he should be helped (against oppression).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6255]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6255

Jabir b. Abdullah reported: We were along with Allah's Messenger (may peace be upon him) in an expedition that a person from amongst the emigrants struck at the back of a person from the Ansir. The Ansiri said: O Ansar! And the Muhijir said: O Emigrants! Thereupon Allah's Messenger (may peace be upon him) said: What are these proclamations of the Days of Ignorance? They said: Allah's Messenger, a person from the emigrants struck at the back of an Ansari, whereupon he said: It is something disgusting. 'Abdullah b. Ubayy heard it and said: They have indeed done it. By Allah, when we would return to Medina the respectable amongst them (the Ansar) would turn away the mean (the emigrants). Thereupon 'Umar said: Permit me so that I should strike the neck of this hypocrite. But he (the Holy Prophet) said: Leave him, the people may not say that Muhammad kills his companions.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6256]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6256

Jabir b. 'Abdullah reported that a person from the emigrants struck the back of an Ansari. He came to Allah's Apostle (may peace be upon him) and asked for compensation. Thereupon Allah's Apostle (may peace be upon him) said: Leave it. for it is something disgusting. Ibn Mansur said that in the narration transmitted on the authority of Amr (these words are also found):" I heard Jabir."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6257]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6257

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: A believer is like a brick for another believer, the one supporting the other.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6258]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6258

Nu'man b. Bashir reported Allah's Messenger (may peace be upon him) as saying: The similitude of believers in regard to mutual love, affection, fellow-feeling is that of one body; when any limb of it aches, the whole body aches, because of sleeplessness and fever.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6259]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6259

Nu'man b. Bashir reported a hadith like this from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6260]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6260

Nu'man b. Bashir reported Allah's Messenger (may peace be upon him) as saying: The believers are like one person; if his head aches, the whole body aches with fever and sleeplessness.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6261]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6261

Nu'man b. Bashir reported that Muslims are like one body of a person; if the eye is sore, the whole body aches, and if the head aches, the whole body aches.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6262]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6262

A hadith like this has been narrated on the authority of Nu'man b. Bashir through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6263]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6263

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When two persons indulge in hurling (abuses) upon one another, it would be the first one who would be the sinner so long as the oppressed does not transgress the limits.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6264]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6264

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Charity does not in any way decrease the wealth and the servant who forgives Allah adds to his respect, and the one who shows humility Allah elevates him in the estimation (of the people).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6265]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6265

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Do you know what is backbiting? They (the Companions) said: Allah and His Messenger know best. Thereupon he (the Holy Prophet) said: Backbiting implies your talking about your brother in a manner which he does not like. It was said to him: What is your opinion about this that if I actually find (that failing) in my brother which I made a mention of? He said: If (that failing) is actually found (in him) what you assert, you in fact backbited him, and if that is not in him it is a slander.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6266]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6266

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The servant (whose fault) Allah conceals in this world, Allah would also conceal (his faults) on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6267]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6267

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The servant (who conceals) the faults of others in this world, Allah would conceal his faults on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6268]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6268

A'isha reported that a person sought permission from Allah's Apostle (may peace be upon him) to see him. He said: Grant him permission. (and also added: ) He is a bad son of his tribe or he is a bad person of his tribe. When he came in he used kind words for him. 'A'isha reported that she said: Allah's Messenger, you said about him what you had to say and then you treated him with kindness. He said: A'isha, verily in the eye of Allah, worst amongst the person in rank on the Day of Resurrection is one whom the people abandon or desert out of the fear of indecency.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6269]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6269

This hadith has been reported on the authority of Ibn Munkadir with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6270]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6270

Jarir reported from Allah's Messenger (may peace be upon him): He who is deprived of tenderly feelings is in fact deprived of good.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6271]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6271

Jarir reported Allah's Messenger (may peace be upon him) as saying: He who is deprived of tenderly feelings is in fact deprived of good.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6272]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6272

Jarir b. 'Abdullah reported Allah's Apostle (may peace be upon him) as saying: He who is deprived of tenderly feelings is in fact deprived of good and he who is deprived of tenderly feelings is in fact deprived of good.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6273]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6273

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) said: 'A'isha, verily Allah is kind and He loves kindness and confers upon kindness which he does not confer upon severity and does not confer upon anything else besides it (kindness).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6274]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6274

'A'isha, the wife of Allah's Apostle (may peace be upon him), reported Allah's Apostle (may peace be upon him) as saying: Kindness is not to be found in anything but that it adds to its beauty and it is not withdrawn from anything but it makes it defective.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6275]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6275

This hadith has been reported by Miqdam b. Shuraih b. Hani with the same chain of transmitters but with this addition:" 'A'isha mounted upon a wild camel and she began to make that go round and round. Thereupon Allah's Messenger (may peace be upon him) said: You should show kindness, and then he made a mention of this hadith.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6276]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6276

'Imran b. Husain reported: We were with Allah's Messenger (may peace be upon him) in some of his journeys and there was a woman from the Ansar riding a she-camel that it shied and she invoked curse upon that. Allah's Messenger (may peace be upon him) heard it and said: Unload that and set it free for it is accursed. 'Imran said: I still perceive that (dromedary) walking amongst people and none taking any notice of that.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6277]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6277

'Imran reported: I perceive as if I am looking towards that dromedary, and in the hadith transmitted on the authority of Thaqafi (the words are):" Unload it and make its back bare for it is accursed."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6278]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6278

Abu Burza al-Aslami reported that a slave-girl was riding a dromedary and there was also the luggage of people upon it. that she suddenly saw Allah's Apostle (may peace be upon him). The way of the mountain was narrow and she said (to that dromedary): Go ahead (but that dromedary did not move). She (that slave-girl), out of anger, said: O Allah, let that (dromedary) be damned. Thereupon Allah's Apostle (may peace be upon him) said: Let the dromedary on which the curse has been invoked not proceed with us.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6279]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6279

This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters but with a variation of words (and that is):" By Allah, let that accompany us not which has been damned, or he said like it."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6280]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6280

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It does not seem proper for Siddiq that he should be an invoker of curse. This hadith has been narrated on the authority of Abu Kuraib with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6281]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6281

Zaid b. Aslam reported that 'Abd al-Malik b. Marwan sent some domestic goods for decoration to Umm Darda' on his own behalf, and when it was night 'Abd al-Malik got up and called for the servant. It seemed as if he (the servant) was late (in responding to his call), so he ('Abd al-Malik) invoked curse upon him, and when it was morning Umm Darda' said to him: I heard you cursing your servant during the night when you called him, and she said: I heard Abu Darda' as saying that Allah's Messenger (may peace be upon him) said: The invoker of curse would neither be intercessor nor witness on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6282]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6282

This hadith has been narrated on the authority of Zaid b. Aslam with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6283]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6283

Umm Darda' reported on the authority of Abu Darda' as saying: I heard Allah's Messenger (may peace be upon him) as saying: The invoker of curse would neither be witness nor intercessor on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6284]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6284

Abu Huraira reported it was said to Allah's Messenger (may peace be upon him): Invoke curse upon the polytheists, whereupon he said: I have not been sent as the invoker of curse, but" I have been sent as mercy."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6285]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6285

A'isha reported that two persons visited Allah's Messenger (may peace be upon him) and both of them talked about a thing, of which I am not aware, but that annoyed him and he invoked curse upon both of them and hurled malediction, and when they went out I said: Allah's Messenger, the good would reach everyone but it would not reach these two. He said: Why so? I said: Because you have invoked curse and hurled malediction upon both of them. He said: Don't you know that I have made condition with my Lord saying thus: O Allah, I am a human being and that for a Muslim upon whom I invoke curse or hurl malediction make it a source of purity and reward.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6286]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6286

This hadith has been reported on the authority of A'mash with the same chain of transmitters and the hadith transmitted on the authority of 'Isa (the words are):" He had a private meeting with them and hurled malediction upon them and cursed them and sent them out."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6287]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6287

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: O Allah, I am a human being and for any person amongst Muslims upon whom I hurl malediction or invoke curse or give him whipping make it a source of purity and mercy.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6288]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6288

Jabir reported Allah's Apostle (may peace be upon him) a hadith like it but with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6289]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6289

This hadith has been transmitted on the authority of A'mash and in the hadith transmitted on the authority of 'Isa the words are: Make it a source of reward, and in the hadith transmitted on the authority of Abu Huraira (the words are):" Make it a source of mercy."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6290]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6290

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: O Allah, I make a covenant with Thee against which Thou wouldst never go. I am a human being and thus for a Muslim whom I give any harm or whom I scold or upon whom I invoke curse or whom I beat, make this a source of blessing, purification and nearness to Thee on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6291]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6291

This hadith has been transmitted on the authority of Abu Zinad with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6292]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6292

A hadith like this has been reported on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6293]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6293

Salim, the freed slave of Nasriyyin, said: I heard Abu Huraira as saying that he heard Allah's Messenger (may peace be upon him) as saying: O Allah, Muhammad is a human being. I lose my temper just as human beings lose temper, and I have held a covenant with Thee which Thou wouldst not break: For a believer whom I give any trouble or invoke curse or beat, make that an expiation (of his sins and a source of) his nearness to Thee on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6294]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6294

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: O Allah, for any believing servant whom I curse make that as a source of nearness to Thee on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6295]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6295

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: I have held covenant with Thee which Thou wouldst not break, so for any believer whom I curse or beat, make that an expiation on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6296]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6296

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: I am a human being and I have made this term with my Lord, the Exalted and Glorious: For any servant amongst Muslims whom I curse or scold, make that a source of purity and reward. This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6297]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6297

Anas b. Malik reported that there was an orphan girl with Umm Sulaim (who was the mother of Anas). Allah's Messenger (may peace be upon him) saw that orphan girl and said: O, it is you; you have grown young. May you not advance in years! That slave-girl returned to Umm Sulaim weeping. Umm Sulaim said: O daughter, what is the matter with you? She said: Allah's Apostle (may peace be upon him) has invoked curse upon me that I should not grow in age and thus I would never grow in age, or she said, in my (length) of life. Umm Sulaim went out wrapping her head-dress hurriedly until she met Allah's Messenger (may peace be upon him). He said to her: Umm Sulaim, what is the matter with you? She said: Allah's Apostle, you invoked curse upon my orphan girl. He said: Umm Sulaim, what is that? She said: She (the orphan girl) states you have cursed her saying that she might not grow in age or grow in life. Allah's Messenger (may peace be upon him) smiled and then said: Umm Sulaim, don't you know that I have made this term with my Lord. And the term with my Lord is that I said to Him: 1 am a human being and I am pleased just as a human being is pleased and I lose temper just as a human being loses temper, so for any person from amongst my Ummah whom I curse and he in no way deserves it, let that, O Lord, be made a source of purification and purity and nearness to (Allah) on the Day of Resurrection.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6298]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6298

Ibn Abbas reported: I was playing with children that Allah's Messenger (may peace be upon him) happened to pass by (us). I hid myself behind the door. He (the Holy Prophet) came and he patted upon my shoulders and said: Go and call Mu'awiya. I returned and said: He is busy in taking food. He again asked me to go and call Mu'swiya to him. I went (and came back) and said that he was busy in taking food, whereupon he said: May Allah not fill his belly! Ibn Muthanna, said: I asked Umm Umayya what he meant by the word Hatani. He said: It means" he patted my shoulders".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6299]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6299

This hadith has been transmitted on the authority of Ibn Abbas with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6300]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6300

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The worst amongst the people is the double-faced one; he comes to some people with one face and to others with the other face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6301]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6301

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: The worst amongst people is one with the double face. He comes to some people with one face and to others with the other face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6302]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6302

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You will find the worst amongst the people one having double face. He comes to some people with one face and to the others with the other face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6303]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6303

Humaid b. 'Abd al-Rahman b. 'Auf reported that his mother Umm Kulthum daughter of 'Uqba b. Abu Mu'ait, and she was one amongst the first emigrants who pledged allegiance to Allah's Apostle (may peace be upon him), as saying that she heard Allah's Messenger (may peace be upon him) as saying: A liar is not one who tries to bring reconciliation amongst people and speaks good (in order to avert dispute), or he conveys good. Ibn Shihab said he did not hear that exemption was granted in anything what the people speak as lie but in three cases: in battle, for bringing reconciliation amongst persons and the narration of the words of the husband to his wife, and the narration of the words of a wife to her husband (in a twisted form in order to bring reconciliation between them).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6304]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6304

This hadith has been narrated on the authority of Ibn Shihab with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6305]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6305

This hadith has been transmitted on the authority of Zuhri with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6306]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6306

'Abdullah b. Mas'ud reported that Muhammad (may peace be upon him) said: Should I inform you that slandering, that is in fact a tale-carrying which creates dissension amongst people, (and) he (further) said: The person tells the truth until he is recorded as truthful, and lie tells a lie until lie is recorded as a liar.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6307]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6307

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Truth leads one to Paradise and virtue leads one to Paradise and the person tells the truth until he is recorded as truthful, and lie leads to obscenity and obscenity leads to Hell, and the person tells a lie until he is recorded as a liar.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6308]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6308

'Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Telling of truth is a virtue and virtue leads to Paradise and the servant who endeavours to tell the truth is recorded as truthful, and lie is obscenity and obscenity leads to Hell-Fire, and the servant who endeavours to tell a lie is recorded as a liar. Ibn Abu Shaiba reported this from Allah's Apostle (may peace be upon him).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6309]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6309

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: It is obligatory for you to tell the truth, for truth leads to virtue and virtue leads to Paradise, and the man who continues to speak the truth and endeavours to tell the truth is eventually recorded as truthful with Allah, and beware of telling of a lie for telling of a lie leads to obscenity and obscenity leads to Hell-Fire, and the person who keeps telling lies and endeavours to tell a lie is recorded as a liar with Allah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6310]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6310

This hadith has been reported on the authority of A'mash with the same chain of transmitters and no mention is made in the hadith transmitted on the authority of 'Isa (of these words):" He who endeavours to tell the truth and endeavours to tell a lie," and in the hadith transmitted on the authority of Mushir (the words are):" Until Allah records it".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6311]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6311

Abdullah b. Mas'ud reported Allah's Messenger (may peace be upon him) as saying: Whom do you count as" Raqub" amongst you? They (his Companions) said: One who has no children (the children are born unto him but they do not survive). Thereupon he (the Holy Prophet) said: He is not a Raqub but Raqub is one who does not find his child as the forerunner (in Paradise). He then said: Whom do you count as a wrestler amongst you? We said: He who wrestles with persons. He said: No, it is not he but one who controls himself when in a fit of rage.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6312]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6312

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6313]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6313

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The strong-man is not one who wrestles well but the strong man is one who controls himself when he is in a fit of rage.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6314]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6314

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: One is not strong because of one's wrestling skillfully. They said: Allah's Messenger, then who is strong? He said: He who controls his anger when he is in a fit of rage.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6315]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6315

This hadith has been reported on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6316]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6316

Sulaiman b. Surad reported that two persons abused each other in the presence of Allah's Apostle (may peace be upon him) and the eyes of one of them became red as embers and the veins of his neck were swollen. Thereupon Allah's Messenger (may peace be upon him) said: I know of a wording, if he were to utter that, his fit of rage (would be no more and that wording is): I seek refuge with Allah from Satan the accursed. The person said: Do you find any madness in me? Ibn al-'Ala' said: Do you see it? And he made no mention of the person.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6317]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6317

Sulaiman b. Surad reported that two persons abused each other in the presence of Allah's Apostle (may peace be upon him) and one of them fell into a rage and his face became red. Allah's Apostle (may peace be upon him) saw him and said: I know of a wording; if he were to utter that, he would get out (of the fit of anger) (and the wording is): I seek refuge with Allah from Satan, the accursed. Thereupon, a person went to him who had heard that from Allah's Apostle (may peace be upon him) and said to him: Do you know what Allah's Messenger (may peace be upon him) said? He (the Holy Prophet) said: I know of a wording; if he were to say that, (the fit) would be no more (and the words are): I seek refuge with Allah from Satan, the accursed. And the person said to him: Do you find me mad?


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6318]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6318

This hadith has been reported on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6319]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6319

Anas reported Allah's Messenger (may peace be upon him) as saying: When Allah fashioned Adam in Paradise, He left him as He liked him to leave. Then Iblis roamed round him to see what actually that was and when he found him hollow from within, he recognised that he had been created with a disposition that he would not have control over himself.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6320]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6320

A hadith like this has been narrated on the authority of Humaid with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6321]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6321

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother he should avoid striking at the face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6322]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6322

This hadith has been transmitted on the authority of Abu Zinad and he said:" When one amongst you strikes (at the face)."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6323]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6323

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: When any one of you fights with his brother, he should spare his face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6324]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6324

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother, he should not slap at the face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6325]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6325

This hadith has been transmitted on the authority of Abu Huraira and in the hadith transmitted on the authority of Ibn Hatim Allah's Apostle (may peace be upon him) is reported to have said: When any one of you fights with his brother, he should avoid his face for Allah created Adam in His own image.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6326]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6326

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When any one of you fights with his brother, he should avoid the face.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6327]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6327

'Urwa reported on the authority of his father that Hisham b. Hakim b. Hizam happened to pass by some people in Syria who had been made to stand in the sun and olive-oil was being poured upon their heads. He said: What is this? It was said: They are being punished for (not paying) the Kharaj (the government revenue). Thereupon he said: Allah would punish those who torment people in this world (without any genuine reason).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6328]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6328

Hisham reported on the authority of his father that Hisham b. Hakim b. Hizam happened to pass by people, the farmers of Syria, who had been made to stand in the sun. He said: What is the matter with them? They said: They have been detained for Jizya. Thereupon Hisham said: I bear testimony to the fact that I heard Allah's Messenger (may peace be upon him) as saying: Allah would torment those who torment people in the world.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6329]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6329

This hadith has been narrated on the authority of Hisham with the same chain of transmitters and he made this addition of Jarir that (Hisham b. Hakim) went to Umair b. Sa'd who was then ruler in Palestine and he narrated to him this hadith and he (submitting before the words of the Prophet) commanded that they should be let off and so they were let off.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6330]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6330

'Urwa b. Zubair reported that Hisham b. Hakim found a person (the ruler of Hims) who had been detaining some Nabateans in connection with the dues of Jizya. He said: What is this? I heard Allah's Messenger (may peace be upon him) as saying: Allah would torment those persons who torment people in the world.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6331]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6331

'Amr heard Jabir as saying: A person happened to come to the mosque with an arrow; thereupon Allah's Messenger (may peace be upon him) said to him: Take hold of its pointed head.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6332]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6332

Jabir b. Abdullah reported that a person happened to come to the mosque with arrows and their iron-ends were exposed, so he was commanded that he should grasp the pointed heads so that these might not do any harm to a Muslim.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6333]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6333

Jabir reported that Allah's Messenger (may peace be upon him) commanded a person who had been distributing arrows freely in the mosque that he should not move about in the mosque but by catching hold of their iron-heads. Ibn Rumh narrated this with a slight variation of wording.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6334]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6334

Abd Musa reported that Allah's Messenger (may peace be upon him) said: When any one of you happens to go to a meeting or the bazar with an arrow in his hand he must grasp its pointed head; then (he again said): He must grasp its pointed head. Abu Musa said: By Allah, we did not court death until some of us had flung arrows upon the faces of one another.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6335]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6335

Abu Musa reported Allah's Apostle (may peace be upon him) assaying: He who amongst you moves in the mosque or in the bazar and there is an arrow with him he should take hold of its iron-head in his palm, so that none amongst the Muslims should receive any injury from it, or he said, should catch its iron-head.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6336]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6336

Abu Huraira reported: Abu'l-Qasim (the kunya of Allah's Messenger, may peace be upon him), said: He who pointed a weapon towards his brother the angels invoke curse upon him even if he is his real brother so long as he does not abandon it (the pointing of weapon towards one's brother Muslim).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6337]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6337

Abu Huraira reported a hadith like this from Allah's Apostle (may peace be upon him) through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6338]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6338

Abu Huraira reported a hadith from Allah's Messenger (may peace be upon him) ; (one of them was this) that Allah's Messenger (may peace be upon him) said: None amongst you should point a weapon towards his brother, for he does not know that Satan might cause the weapon (to slip) from his hand and (he may injure anyone) and thus he may fall into Hell-Fire.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6339]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6339

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: While a person was going along the path he found a thorny branch upon it. He pushed it to a side and Allah approved (this action) of his and (as a mark of appreciation) granted him pardon.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6340]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6340

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A person while walking along the path saw the branches of a tree lying there. He said: By Allah, I shall remove these from this so that these may not do harm to the Muslims, and he was admitted to Paradise.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6341]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6341

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that he saw a person enjoying himself in Paradise because of the tree that he cut from the path which was a source of inconvenience to the people.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6342]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6342

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that there was a tree which caused inconvenience to the Muslims; a person came there and cut that (tree) (and thus entered ) Paradise).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6343]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6343

Abu Barza reported: I said: Allah's Messenger, teach me something so that I may derive benefit from it. He said: Remove the troublesome thing from the paths of the Muslims.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6344]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6344

Abu Barza reported that he said to Allah's Messenger (may peace be upon him): Allah's Messenger, I do not know whether I would survive after you, so confer upon me something by which Allah should benefit me. Thereupon Allah's Messenger (may peace be upon him) said: Do this and that and remove the troublesome things from the paths.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6345]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6345

Abdullah reported that Allah's Messenger (may peace be upon him) said: A woman was tormented because of a cat which she had confined until it died and she had to get into Hell. She did not allow it either to eat or drink as it was confined, nor did she free it so that it might eat the insects of the earth.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6346]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6346

This hadith has been reported on the authority of Ibn 'Umar through another chain of transmitters. And Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: A woman was tormented because of a cat which she had tied and thus allowed it neither to eat or drink nor set it free so that it might eat the insects of the earth.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6347]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6347

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6348]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6348

Abu Huraira reported from Allah's Messenger (may peace be upon him) A hadith out of which one was this that Allah's Messenger (may peace be upon him) said: A woman got into Hell-Fire because of a cat whom she had tied, and thus it could not eat, and she did not let it free so that it could devour the insects of the earth, until it died.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6349]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6349

Abu Sa'id Khudri and Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: Glory is His lower garment and Majesty is His cloak and (Allah says, ) He who contends with Me in regard to them I shall torment him.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6350]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6350

Jundub reported that Allah's Messenger (may peace be upon him) stated that a person said: Allah would not forgive such and such (person). Thereupon Allah the Exalted and Glorious, said: Who is he who adjures about Me that I would not grant pardon to so and so; I have granted pardon to so and so and blotted out his deeds (who took an oath that I would not grant pardon to him).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6351]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6351

Abu Huraira reported Allah's Messenger (may peace he upon him) as saying: Many a person with disheveled hair and covered with dust is turned away from the doors (whereas he is held in such a high esteem by Allah) that if he were to adjure in the name of Allah (about anything) Allah would fulfil that.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6352]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6352

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When a person says that people are ruined he is himself ruined. Abu Ishaq said: I do not know whether he said" ahlakahum or ahlakuhum.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6353]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6353

This hadith has been narrated on the authority of Suhail with the same chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6354]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6354

'A'isha reported Allah's Messenger (may peace be upon him) as saying: Gabriel impressed upon me (kind treatment) towards the neighbour (so much) that I thought as if he would confer upon him the (right) of inheritance.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6355]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6355

This hadith has been narrated on the authority of 'A'isha through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6356]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6356

Ibn Umar reported Allah's Messenger (may peace be upon him) as saying: Gabriel impressed upon me (the kind treatment) towards the neighbour (so much) that I thought as if he would soon confer upon him the (right) of inheritance.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6357]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6357

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying: Abu Dharr, when you prepare the broth, add water to that and give that (as a present) to your neighbour.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6358]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6358

Abu Dharr reported Allah's Messenger (may peace be upon him) commanded me thus: Whenever you prepare a broth, add water to it, and have in your mind the members of the household of your neighbours and then give them out of this with courtesy.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6359]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6359

Abu Dharr reported: Allah's Apostle (may peace be upon him) said to me: Don't consider anything insignificant out of good things even if it is that you meet your brother with a cheerful countenance.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6360]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6360

Abu Musa reported that when any needy (person) came to Allah's Messenger (may peace be upon him) with a need he commanded him to his Companions, saying: Make a recommendation for him, and you would get the reward. Allah, however, gives the verdict through the tongue of His Apostle what He likes most.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6361]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6361

Abu Musa reported Allah's Messenger (may peace be upon him) as saying: The similitude of good company and that of bad company is that of the owner of musk and of the one (iron-smith) blowing bellows, and the owner of musk would either offer you free of charge or you would buy it from him or you would. smell its pleasant odour, and so far as one who blows the. bellows is concerned, he would either burn your clothes or you shall have to smell its repugnant smell.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6362]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6362

'A'isha, the wife of Allah's Apostle (may peace be upon him), said: A woman came to me along with her two daughters. She asked me for (charity) but she found nothing with me except one date, so I gave her that. She accepted it and then divided it between her two daughters and herself ate nothing out of that. She then got up and went out, and so did her two daughters. (In the meanwhile) Allah's Apostle (may peace be upon him) visited me and I narrated to him her story. Thereupon Allah's Apostle (may peace be upon him) said: He who is involved (in the responsibility) of (bringing up) daughters, and he accords benevolent treatment towards them, there would be protection for him against Hell-Fire.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6363]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6363

'A'isha reported: A poor woman came to me along with her daughters. I gave her three dates. She gave a date to each of them and then she took up one date and brought that to her mouth in order to eat that, but her daughters expressed desire to eat it. She then divided the date that she intended to eat between them. This (kind) treatment of her impressed me and I mentioned that which she did to Allah's Messenger (may peace be upon him). Thereupon he said: Verily Allah has assured Paradise for her, because of (this act) of her, or He has rescued her from Hell-Fire.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6364]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6364

Malik reported Allah's Messenger (may peace be upon him) as saying: He, who brought up two girls properly till they grew up, he and I would come (together) (very closely) on the Day of Resurrection, and he interlaced his fingers (for explaining the point of nearness between him and that person).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6365]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6365

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Anyone amongst the Muslims, three of whose children die, and he resigns himself calmly to the will of God, Fire will not touch him but for the fulfilment of the oath.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6366]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6366

This hadith has been reported by Zuhri on the authority of Malik, and in the hadith transmitted on the authority of Sufyan (the words are):" He would enter into Fire, except for the fulfilment of the oath."


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6367]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6367

Abu Huraira reported that Allah's Messenger (may peace be upon him) said to a woman of the Ansar: In case anyone amongst you sees the sad demise of three children of (hers) and she resigns herself to the will of God hoping to get reward, she would be admitted to Paradise. A woman from amongst them said: Allah's Messenger, even if they (the children who die) are two. Thereupon, he (the Holy Prophet, ) said: Even if they are two.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6368]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6368

Abu Sa'id Khudri reported that a woman came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, men receive your instructions; kindly allocate at your convenience a day for us also, on which we would come to you and you would teach us what Allah has taught you. He said: You assemble on such and such a day. They assembled and Allah's Messenger (may peace be upon him) came to them and taught them what Allah had taught him and he then said: No woman amongst you who sends her three children as her forerunners (in the Hereafter) but they would serve him as a protection against Hell-Fire. A woman said: What about two and two and two? Thereupon Allah's Messenger (may peace be upon him) said: Even if they are two and two and two.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6369]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6369

Abu Huraira reported that he (the Holy Prophet) said: Three (children) who die in childhood.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6370]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6370

Abu Hassan reported: I said to Abu Huraira that my two children had died. Would you narrate to me anything from Allah's Messenger (may peace be upon him) a hadith which would soothe our hearts in our bereavements? He said: Yes. Small children are the fowls of Paradise. If one of them meets his father (or he said his parents) he would take hold of his cloth, or he said with his hand as I take hold of the hem of your cloth (with my hand). And he (the child) would not take off (his hand) from it until Allah causes his father to enter Paradise. This hadith has been narrated on the authority of Tamim with the same chain of transmitters. And he is reported to have said: Did you hear from Allah's Messenger (may peace be upon him) anything which may soothe our heart in our bereavements? He said: Yes.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6371]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6371

Abu Huraira reported that a woman came to Allah's Apostle (may peace be upon him) with her child and said: Allah's Apostle, invoke Allah's blessing upon him for I have already buried three. He said: You have buried three! She said: Yes. Thereupon he (the Holy Prophet) said: You have, indeed, safeguarded yourself against the torment of Hell with a strong safeguard. 'Umar has made a mention of his father, whereas others have not made a mention of his father.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6372]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6372

Abu Huraira reported that a woman came to Allah's Apostle (may peace be upon him) with her child and said: Allah's Messenger, he is ailing, and I am afraid (that he may die), as I have already buried three. Thereupon he said: It (their sad demise) would be a protection against Hell-Fire for you. Zuhair has not mentioned the kunya of Abu Ghiyath; he has mentioned his name.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6373]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6373

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When Allah loves a servant, He calls Gabriel and says: Verily, I so and so; you should also love him, and then Gabriel begins to love him. Then he makes an announcement in the heaven saying: Allah loves so and so and you also love him, and then the inhabitants of the Heaven (the Angels) also begin to love him and then there is conferred honour upon him in the earth; and when Allah is angry with any servant He calls Gabriel and says: I am angry with such and such and you also become angry with him, and then Gabriel also becomes angry and then makes an announcement amongst the inhabitants of heaven: Verily Allah is angry with so-and so, so you also become angry with him, and thus they also become angry with him. Then he becomes the object of wrath on the earth also.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6374]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6374

This hadith has been reported on the authority of Suhail with the same chain of transmitters except with this variation that in the hadith transmitted on the authority of 'Ali' b. Musayyib, there is no mention of (the word)" Anger".


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6375]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6375

Suhail b. Abi Salih, reported: We were in Arafa that there happened to pass Umar b. Abd al-'Aziz and he was the Amir of Hajj. People stood up in order to catch a glimpse of him. I said to my father: Father, I think that Allah loves Umar b. Abd al- 'Aziz. He said: How is it? I said: It is because of the love in people's heart for him. Thereupon he said: By One Who created your father, I heard Abu Huraira narrating from Allah's Messenger (may peace be upon him) a hadith like one transmitted on the authority of Suhail.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6376]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6376

Abu Huraira reported Allah's Messenger (may peace be upon him) Saying: Souls are troops collected together and those who familiarised with each other (in the heaven from where these come) would have affinity, with one another (in the world) and those amongst them who opposed each other (in the Heaven) would also be divergent (in the world).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6377]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6377

Abu Huraira narrated directly from Allah's Messenger (may peace be upon him) that he said: People are like mines of gold and silver; those who were excellent in Jahiliya (during the days of ignorance) are excellent In Islam, when they have, an understanding, and the souls are troops collected together and those who had a mutual familiarity amongst themselves in the store of prenatal existence would have affinity amongst them, (in this world also) and those who opposed one of them, would be at variance with one another.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6378]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6378

Anas b. Malik reported that a desert Arab said to Allah's Messenger (may peace be upon him): When would be the Last Hour? Allah's Messenger (may peace be upon him) said: What preparation have you made for that? Thereupon he said: The love of Allah and of His Messenger (that is my preparation for the Last Hour) (for the Day of Resurrection). Thereupon he (the Holy Prophet) said: You would be along with one whom you love.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6379]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6379

Anas reported that a person said to Allah's Messenger (may peace be upon him): When would be the Last Hour? He (the Holy Prophet) said: What preparation have you made for that? And he gave no details, but said: I love Allah and His Messenger. Thereupon he (the Holy Prophet) said: You would be along with one whom you love. Anas b. Malik reported through another chain of transmitters that a desert Arab came to Allah's Messenger (may peace be upon, him), the rest of the hadith is the same but with this variation that he said: I have not made much preparations which merit appreciation for myself.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6380]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6380

Anas b. Malik reported that a person came to Allah's Messenger (may peace be upon him) and said to Allah's Messenger: When would be the Last Hour? Thereupon he (the Holy Prophet) said: What preparation have you made for the Last Hour? He said: The love of Allah and of His Messenger (is my only preparation). Thereupon he (the Holy Prophet) said: You would be along with one whom you love. Anas said: Nothing pleased us more after accepting Islam than the words of Allah's Apostle: You would be along with one whom you love. And Anas said. I love Allah and His Messenger and Abu Bakr and Umar, and I hope that I would be along with them although I have not acted like them.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6381]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6381

Anas b. Malik reported Allah's Apostle (may peace be upon him) this hadith through another chain of transmitters but he did not make mention of the words of Anas: I love, and what follows subsequently.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6382]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6382

Anas b. Malik reported: Allah's Messenger (may peace be upon him) and I were coming out of the mosque that we met a person on the threshold of the mosque and he said to Allah's Messenger (may peace be upon him): When would be the Last Hour? Allah's Messenger (may peace be upon him) said: What preparation have you made for that? The man became silent and then said: Allah's Messenger, I have made no significant preparation with prayer and fasting and charity but I, however, love Allah and His Messenger. Thereupon (the Holy Prophet) said: You would be along with one whom you love.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6383]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6383

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6384]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6384

This hadith has been reported on the authority of Anas with a different chain of transmitters.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6385]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6385

'Abdullah reported that a person came to Allah's Messenger (may peace be upon him) and said to Allah's Messenger (may peace be upon him): What is your opinion about the person who loves the people but his (acts or deeds are not identical to theirs)? Thereupon Allah's Messenger (may peace be upon him) said: A person would be along with one whom he loves.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6386]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6386

A hadith like this has been transmitted on the authority of 'Abdullah.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6387]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6387

Abu Musa, reported that a person came to Allah's Messenger (may peace be upon him) ; the rest of the hadith is the same.


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6388]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6388

Abu Dharr reported: It was said to Allah's Messenger (may peace be upon him): What is your opinion about the person who has done good deeds and the people praise him? He said: It is glad tidings for a believer (which he has received in this mortal world).


Muslim :: The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab) :: [32.6389]

The Book of Virtue, Good Manners and Joining of the Ties of Relationship (Kitab Al-Birr was-Salat-I-wa'l-Adab)

Muslim :: Book 32 : Hadith 6389

This hadith has been narrated through another chain of transmitters also and the one transmitted on the authority of Shu'ba (the words are):" People love him." In the hadith transmitted on the authority of 'Abd-us-Samad (the words are):" People praise him as stated by Hammad."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6390]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6390

Abdullah (b. Mas'ud) reported that Allah's Messenger (may peace be upon him) who is the most truthful (of the human beings) and his being truthful (is a fact) said: Verily your creation is on this wise. The constituents of one of you are collected for forty days in his mother's womb in the form of blood, after which it becomes a clot of blood in another period of forty days. Then it becomes a lump of flesh and forty days later Allah sends His angel to it with instructions concerning four things, so the angel writes down his livelihood, his death, his deeds, his fortune and misfortune. By Him, besides Whom there is no god, that one amongst you acts like the people deserving Paradise until between him and Paradise there remains but the distance of a cubit, when suddenly the writing of destiny overcomes him and he begins to act like the denizens of Hell and thus enters Hell, and another one acts in the way of the denizens of Hell, until there remains between him and Hell a distance of a cubit that the writing of destiny overcomes him and then he begins to act like the people of Paradise and enters Paradise.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6391]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6391

This hadith has been reported on the authority of A'mash with the same chain of transmitters and in the hadith transmitted on the authority of Waki' (the words are):" The creation of any one of you is like this that (semen) is collected in the womb of the mother for forty nights," and in the hadith transmitted on the authority of Shu'ba (the words are):" Forty nights and forty days." And in the hadith transmitted on the authority of Jarir and 'Isa (the words are):" Forty days."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6392]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6392

Hudhaifa b. Usaid reported directly from Allah's Messenger (may peace be upon him) that lie said: When the drop of (semen) remains in the womb for forty or fifty (days) or forty nights, the angel comes and says: My Lord, will he be good or evil? And both these things would be written. Then the angel says: My Lord, would he be male or female? And both these things are written. And his deeds and actions, his death, his livelihood; these are also recorded. Then his document of destiny is rolled and there is no, addition to and subtraction from it.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6393]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6393

'Abdullah b. Mas'ud reported: Evil one is he who is evil in the womb of his mother and the good one is he who takes lesson from the (fate of) others. The narrator came to a person from amongst the Companion of Allah's Me ssenger (may peace be upon him) who was called Hudhaifa b. Usaid Ghifari and said: How can a person be an evil one without (cornmittilng an evil) deed? Thereupon the person said to him: You are surprised at this, whereas I have heard Allah's Messenger (may peace be upon him) as saving: When forty nights pass after the semen gets into the womb, Allah sends the angel and gives him the shape. Then he creates his sense of hearing, sense of sight, his skin, his flesh, his bones, and then says: My Lord, would he be male or female? And your Lord decides as He desires and the angel then puts down that also and then says: My Lord, what about his age? And your Lord decides as He likes it and the angel puts it down. Then he says: My Lord, what about his livelihood? And then the Lord decides as He likes and the angel writes it down, and then the angel gets out with his scroll of destiny in his hand and nothing is added to it and nothing is subtracted from it.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6394]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6394

This hadith has been narrated on the authority of 'Abdullah b. Mas'ud through another chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6395]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6395

Abu Tufail reported: I visited Abu Sariha Hudhaifa b. Usaid al-Ghifari who said: I listened with these two ears of mine Allahs Messenger (may peace be upon him) as saying: The semen stays in the womb for forty nights, then the angel, gives it a shape. Zubair said: I think that he said: One who fashions that and decides whether he would be male or female. Then he (the angel) says: Would his limbs be full or imperfect? And then the Lord makes thein full and perfect or otherwise as He desires. Then he says: My Lord, what about his livelihood, and his death and what about his disposition? And then the Lord decides about his misfortune and fortune.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6396]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6396

Hadhaifa b. Usaid Ghifari, a Companion of Allah's Messenger (may peace be upon him), reported it directly from Allah's Messenger (may peace upon him). as he said: There is an angel who looks after the womb when Allah decides to create any- thing after more than forty nights are over; the rest of the hadith is the same.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6397]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6397

Anas b. Malik reported directly from Allah's Messenger (may peace be upon him) that he said: Allah, the Exlated and Glorious, has appointed an angel as the caretaker of the womb, and he would say: My Lord, it is now a drop of semen; my Lord, It is now a clot of blood; my Lord, it has now become a lump of flesh, and when Allah decides to give it a final shape, the angel says: My Lord, would it be male or female or would he be an evil or a good person? What about his livelihood and his age? And it is all written as he is in the womb of his mother.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6398]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6398

All reported: We were in a funeral in the graveyard of Gharqad that Allah's Messenger (may peace be upon him) came to us and we sat around him. He had a stick with him. He lowered his head and began to scratch the earth with his stick, and then raid: There is not one amongst you whom a scat in Paradise or Hell has not been allotted and about whom it has not been written down whether he would be an evil person or a blessed person. A person said: Allah's Messenger, should we not then depend npon our destiny and abandon our deeds? Thereupon he said: Acts of everyone will be facilitated in, that which has been created for him so that whoever belongs to the com. pany of the blessed will have good works made easier for himand whoever belongs to the unfortunate ones will have evil acts made easier for him. He then recited this verse (from the Qur'an):" Then, who gives to the needy and guardsagainst evil and accepts the excellent (the truth of Islam and the path of righteousness it prescribes), We shall make easy for him the easy end and who is miserly and considers himself above need, We shall make easy for him the dificult end". (XCii. 5-10).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6399]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6399

This hadith has been narrated on the authority of Mansur with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6400]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6400

'Ali reported that one day Allah's Messenger (may peace be upon him) was sitting with a wood in his hand and he was scratching the ground. He raised his head and said: There is not one amongst you who has not been allotted his seat in Paradise or Hell. They said: Allah's Messenger. then, why should we perform good deeds, why not depend upon our destiny? Thereupon he said. No, do perform good deeds, for everyone is facilitated in that for which he has been created; then he recited this verse:" Then, who gives to the needy and guards against evil and accepts the excellent (the truth of Islam and the path of righteousness it prescribes), We shall make easy for him the easy end..." (xcii. 5-10).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6401]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6401

This hadith has been narrated on the authority of 'Ali through another chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6402]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6402

Jabir reported that Suriqa b. Malik b. Ju'shuin came and said: Allah's Messenger, explain our religion to us (in a way) as if we have been created just now. Whosoever deeds we do today, is it because of the fact that-the pens have dried (after recording them) and the destitiles have began to operate or these have effects in future? Thereupon he said: The pens have dried tmd destinies have begun to operate. (Suraqa b. Malik) said: If it Is so, then what is the use of doing good deeds? Zuhair said: Then Abu Zubair said something but I could not understand that and I said. What did he say? Thereupon he said: Act, for everyone is facilitated what he intends to do.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6403]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6403

This hadith has been transmitted on the authority of Jabir b. Abdullah with the same wording (and includes these words):" Allah's Messenger (may peace be upon him) said: Every doer of deed is facilitated in his action."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6404]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6404

'Imran b. Husain repotted that it was said to Allah's Messenger (may peace be upon him): Has there been drawn a distinction between the people of Paradise and the denizens of hell? He said: Yes. It was again said: (If it is so), then What is the use of doing good deeds? Thereupon he said: Everyone is facilitated in what has been created for him.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6405]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6405

This hadith has been narrated through other chains of transmiters with slight variations of wording.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6406]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6406

Abu al-Aswad reported that 'Imran b Husain asked him: What is your view, what the people do today in the world, and strive for, is it something decreed for them or preordained for them or will their fate in the Hereafter be deterrained by the fact that their Prophets brought them teaching which they did not act upon? I said: Of course, it is something which is predetermined for them and preordained for them. He (further) said: Then, would it not be an injustice (to punish them)? I felt greatly disturbed because of that, and said: Everything is created by Allah and lies in His Power. He would not be questioned as to what He does, but they would be questioned; thereupon he said to me: May Allah have mercy upon you, I did not mean to ask you but for testing your intelligence. Two men of the tribe of Muzaina came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, what is your opinion that the people do in the world and strive for, is something decreed for them; something preordained for them and will their fate in the Hereafter be determined by the fact that their Prophets brought them teachings which they did not act upon. and thus they became deserving of punishment? Thereupon, he said: Of course, it happens as it is decreed by Destiny and preordained for them, and this view is confirmed by this verse of the Book of Allah, the Exalted and Glorious:" Consider the soul and Him Who made it perfect, then breathed into it its sin and its piety" (xci. 8).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6407]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6407

Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: Verily, a person performs deeds for a long time like the deeds of the people of Paradise. Then his deeds are terminated like the deeds of the people of Hell and, verily, a person performs deeds like the denizens of Fire for a long time, and then this deed of his is ultimately followed by the deeds of the people of Paradise.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6408]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6408

Sahl b. Sa'd reported it from Allah's Messenger (may peace be upon him) that a person performs deeds like the deeds of the people of Paradise apparently before people and he would be amongst the dwellers of Hell and a person acts apparently like the people of Hell, but (in fact) he would be among the dwellers of Paradise.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6409]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6409

Abu Huraira reported Allah's Messenger (way peace be upon him) as saying: There was argument between Adam and Moses. Moses said to Adam: You are our father. You did us harm and caused us to get out of Paradise. Adam said to him: You are Moses. Allah selected you (for direct conversation with you) and wrote with His own Hand the Book (Torah) for you. Despite this you blame me for an act which Allah had ordained for me forty years before He created me. Allah's Apostle (may peace be upon him) said:. This is how Adam came the better of Moses and Adam came the better of Moses.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6410]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6410

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was argument between Adam and Moses, and Adam came the better of Moses. Moses said to him: You are the same Adam who misled people, and caused them to get out of Paradise. Adam said: You are the same (Moses) whom Allah endowed the knowledge of everything and selected him amongst the people as His Messenger. He said: Yes. Adam then again said: Even then you blame me for an affair which had been ordained for me before I was created.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6411]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6411

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was an argument between Adam and Moses (peace be upon both of them) in the presence of their Lord. Adam came the better of Moses. Moses said: Are you that Adam whom Allah created with His Hand and breathed into himHis sprit, and commanded angels to fall in prostration before him and He made you live in Paradise with comfort and ease. Then you caused the people to get down to the earth because of your lapse. Adam said: Are you that Moses whom Allah selected for His Messengership and for His conversation with him and conferred upon you the tablets, in which everything was clearly explained and granted you the audience in order to have confidential talk with you. What is your opinion, how long Torah would haye been written before I was created? Moses said: Forty years before. Adam said: Did you not see these words: Adam committed an error and he was enticed to (do so). He (Moses) said: Yes. Whereupon, he (Adam) said: Do you then blame me for an act which Allah had ordained for me forty years before He created me? Allah's Messenger (may peace be upon him) said: This is how Adam came the better of Moses.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6412]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6412

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There was an argument between Adam and Moses. Moses said: Are you that Adam whose lapse caused you to get out of Paradise? Adam said to him: Are you that Moses whom Allah selected for His Messengership, for His conversation and you blame me for an affair which had been ordained for me before I was created? This is how Adam came the better of Moses.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6413]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6413

Abu Huraira narrated a hadith like this through another chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6414]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6414

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6415]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6415

Abu Huraira reported a hadith like this through another chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6416]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6416

Abdullah b. 'Amr b. al-'As reported: I heard Allah's Messenger (may peace be upon him) as saying: Allah ordained the measures (of quality) of the creation fifty thousand years before He created the heavens and the earth, as His Throne was upon water.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6417]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6417

This hadith has been narrated on the authority of Abu Hani with the same chain of transmitters, but there is no mention of" His Throne was upon water."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6418]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6418

Abdullah b. Amr b. al-'As reported that he heard Allah's Messenger (may peace be upon him) as saying: Verily, the hearts of all the sons of Adam are between the two fingers out of the fingers of the Compassionate Lord as one heart. He turns that to any (direction) He likes. Then Allahs Messenger (may peace be upon him) said: 0 Allah, the Turner of the hearts, turn our hearts to Thine obedience.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6419]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6419

Tawus reported: I found some Companions of Allah's Messenger (may peace be upon him) as saying: Everything is by measure. And he further said: I heard Abdullah b. 'Umar as saying: There is a neasure for everything-even for incapacity and-capability.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6420]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6420

Abu Huraira reported that the polytheists of the Quraish came to have an argument with Allah's Messenger (may peace be upon him) in regard to Destiny and then this verse was revealed:" On the day when they are dragged into the Fire upon their faces, taste the touch of Fire. Surely, We have created everything according to a measure" (liv. 48).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6421]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6421

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Verily Allah has fixed the very portion of adultery which a man will indulge in, and which he of necessity must comrriit. The adultery of the eye is the lustful look, and the adultery of the tongue is the licentious speech, the heart desires and yearns, which the parts may or may not put into effect.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6422]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6422

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying. Allah fixed the very portion of adultery which a man will indulge in. There would be no escape from it. The adultery of the eye is the lustful look and the adultery of the ears is listening to voluptuous (song or talk) and the adultery of the tongue is licentious speech and the adultery of the hand is the lustful grip (embrace) and the adultery of the feet is to walk (to the place) where he intends to commit adultery and the heart yearns and desires which he may or may not put into effect.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6423]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6423

There is none born but is created to his true nature (Islam). It is his parents who make him a Jew or a Christian or a Magian quite as beasts produce their young with their limbs perfect. Do you see anything deficient in them? Then he quoted the Qur'an., The nature made by Allah in which He has created men there is no altering of Allah's creation; that is the right religion" (xxx. 33)


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6424]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6424

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters and there is no mention of his deficiency in limbs.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6425]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6425

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No child is born but upon Fitra. He then said. Recite: The nature made by Allah in which He created man, there is no altering of Allah's nature; that is the right religion."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6426]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6426

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: No babe is born but upon Fitra. It is his parents who make him a Jew or a Christian or a Polytheist. A person said: Allah's Messenger, what is your opinion if they were to die before that (before reaching the age of adolescence when they can distinguish between right and wrong)? He said: It is Allah alone Who knows what they would be doing.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6427]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6427

It is reported on the authority of Abu Mu'awiya that (the Holy Prophet) said: Every new-born babe is born on the millat (of Islam and he) remains on this until his tongue is enabled to express himself.

This hadith has been narratted on the authority of Abu Mu'awiya through another chain of transmitters (and the words are):" Every child is born but on this Fitra so long as he does not express himself with his tongue."


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6428]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6428

Abu Huraira reported from Allah's Messenger (may peace be upom him) many ahadith and one amongst them is that he is reported to have said: An infant is born according to his (true) nature. It is his parents Who make him a Jew, a Christian, just as a she-camel gives birth to its young ones. Do you find any deficiency in their limbs? You cut their ears (i. e. after birth). They (the Companions of the Holy Prophet) said: What is your opinion about him who dies in infancy? Thereupon Allah's Apostle (may peace be upon him) said: It is Allah alone Who knows best what they would be doing.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6429]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6429

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The mother of every person gives him birth according to his true nature. It is subsequently his parents who make him a Jew or a Christian or a Magian. Had his parents been Muslim he would have also remained a Muslim. Every person to whom his mother gives birth (has two aspects of his life) ; when his mother gives birth Satan strikes him but it was not the case with Mary and her son (Jesus Christ).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6430]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6430

Abu Huraira reported that Allah's Messenger (may peace be upon him) was asked about the children of the polytheists, whereupon he said: It is Allah Who knows best what they would be doing.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6431]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6431

This hadith has been transmitted on the authority of Shu'aib and Ma'qil with a slight variation of wording.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6432]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6432

Abu Huraira reported that Allahs Messenger (way peace be upon him) was asked about the children of the polytheists who die young. Thereupon Allah's Apostle (may peace be upon him) said: It is Allah Who knows what they would be doing.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6433]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6433

Ibn Abbas reported that Allah's Messenger (may peace be upon him) was asked about the children of the polytheists, whereupon he said: It is Allah alone Who knows what they would be doing according to their creation.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6434]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6434

Ubayy b. Ka'b reported that AUah's Messenger (may peace be upon him) said: The young man whom Khadir killed was a non-believer by his very nature and had he survived he would have involved his parents in defiance and unbelief.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6435]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6435

'A'isha, the mother of the believers, reported that a child died and I said: There is happiness for this child who is a bird from amongst the birds of Paradise. Thereupon Allah's Messenger (may peace be upon him) said: Don't you know that Allah created the Paradise and He created the Hell and He created the dwellers for this (Paradise) and the denizens for this (Hell)?


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6436]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6436

'A'isha, the mother of the believers, said that Allah's Messenger (may peace be upon him) was called to lead the funeral prayer of a child of the Ansar. I said: Allah's Messenger, there is happiness for this child who is a bird from the birds of Paradise for it committed no sin nor has he reached the age when one can commit sin. He said: 'A'isha, per adventure, it may be otherwise, because God created for Paradise those who are fit for it while they were yet in their father's loins and created for Hell those who are to go to Hell. He created them for Hell while they were yet in their father's loins.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6437]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6437

This hadith has been narrated on the authority of Yahya with the same chain of transmitters.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6438]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6438

Abdullah reported that Umm Habiba, the wife of Allah's Apostle (may peace be upon him), said: 0 Allah, enable me to derive benefit from my husband, the Messenger of Allah (may peace be upon him), and from my father Abu Sufyan and from my brother Mu'awiya. Allah's Apostle (may peace be upon him) said: You have asked from Allah about durations of life already set, and the length of days already allotted and the sustenances the share of which has been fixed. Allah would not do anything earlier before its due time, or He would not delay anything beyond its due time. And if you were to ask Allah to provide you refuge from the torment of the HellFire, or from the torment of the grave, it would have good in store for you and better for you also. He (the narrator) further said: Mention was made before him about monkeys, and Mis'ar (one of the narrators) said: I think that (the narrator) also (made a mention) of the swine, which had suffered metamorphosis. Thereupon he (the Holy Prophet) said: Verily, Allah did not cause the race of those which suffered metamorphosis to grow or they were not survived by young ones. Monkeys and swine had been in existence even before (the metamorphosis of the human beings).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6439]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6439

This hadith has been reported on the authority of Mis'ar with the same chain of transmitters but with this variation that the hadith transmitted on the authority of Ibn Bishr and Waki', the torment of the Hell-Fire and the torment of grave have been mentioned together (and there is no conjunction" iw" or" between them).


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6440]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6440

Ibn Mas'dd reported that Umm Habiba said: 0 Allah, enable me to derive benefit from my husband, Allah's Messenger (may peace be upon him), and from my father Abu Sufyan, and from my brother Mu'awiya. Allah's Messenger (may peace be upon him) said to her: Verily, you have asked Allah about the durations of life already set, and the steps which you would take, and the sustenances the share of which is fixed. Nothing would take place earlier than its due time, and nothing would be deferred beyond that when it is due. So, if you were to ask Allah about your safety from the torment of Hell-Fire and from the torment of the grave, it would have been better for you. A person said: Allah's Messenger, what about those apes and swine which suffered metamorphosis? Thereupon Allah's Apostle (may peace be upon him) said: Verily, Allah, the Exalted and Glorious, did not destroy a people or did not torment a people, and let their race grow. Apes and swine had been even before that (when the deniers of truth were tormented and suffered metamorphosis). This hadith has been narrated on the authority of Sufyin through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Destiny (Kitab-ul-Qadr) :: [33.6441]

The Book of Destiny (Kitab-ul-Qadr)

Muslim :: Book 33 : Hadith 6441

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A strong believer is better and is more lovable to Allah than a weak believer, and there is good in everyone, (but) cherish that which gives you benefit (in the Hereafter) and seek help from Allah and do not lose heart, and if anything (in the form of trouble) comes to you, don't say: If I had not done that, it would not have happened so and so, but say: Allah did that what He had ordained to do and your" if" opens the (gate) for the Satan.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6442]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6442

'A'isha reported that Allah's Messenger (may peace be upon him) recited (these verses of the Qur'an):" He it is Who revealed to thee (Muhammad) the Book (the Qur'an) wherein there are clear revelations-these are the substance of the Book and others are allegorical (verses). And as for those who have a yearning for error they go after the allegorical verses seeking (to cause) dissension, by seeking to explain them. And none knows their implications but Allah, and those who are sound in knowledge say: We affirm our faith in everything which is from our Lord. It is only the persons of understanding who really heed" (iii. 6). 'A'isha (further) reported that Allah's Messenger (may peace be upon him) said (in connection with these verses): When you see such verses, avoid them, for it is they whom Allah has pointed out (in the mentioned verses).


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6443]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6443

'Abdullah b. 'Umar reported: I went to Allah's Messenger (may peace be upon him) in the morning and he heard the voice of two persons who had an argumenta- tion with each other about a verse. Allah's Apostle (may peace be upon him) came to us (and) the (signs) of anger could be seen on his face. He said: Verily, the (peoples) before you were ruined because of their disputation in the Book.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6444]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6444

Jundub b. 'Abdullah al-Bajali reported Allah's Messenger (may peace be upon him) as saying: Recite the Qur'an as long as your hearts agree to do so, and when you feel variance between them (between your hearts and tongues), then get up (and leave its recital for the time being).


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6445]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6445

Jundub (i. e. Ibn 'Abdullah) reported that Allah's Messenger (may peace be upon him) said: Recite the Qur'an as long as your hearts agree to do so and when you find variance between them, then stand up.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6446]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6446

Abu Imran reported that Jundub told us as we we-re young boys living in Kilfa, that Allah's Messenger (may peace be upon him) had said: Recite the Qur'an. The rest of the hadith is the same.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6447]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6447

'A'isha reported Allah's Messenger (may peace be upon him) as saying: The most despicable amongst persons in the eye of Allah is one who tries to fall into dispute with others (for nothing but only to display his knowledge and power of argumentation).


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6448]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6448

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: You would tread the same path as was trodden by those before you inch by inch and step by step so much so that if they had entered into the hole of the lizard, you would follow them in this also. We said: Allah's Messenger, do you mean Jews and Christians (by your words)" those before you"? He said: Who else (than those two religious groups)?


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6449]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6449

This hadith has been narrated on the authority of 'Ata' b. Yasir through another chain of transmitters.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6450]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6450

Abdullah reported Allah's Messenger (may peace be upon him) as saying: Ruined, were those who indulged in hair-splitting. He (the Holy Prophet) repeated this thrice.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6451]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6451

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: It is from the conditions of the Last Hour that knowledge would be taken away and ignorance would prevail (upon the world), the liquor would be drunk, and adultery would become rainpant.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6452]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6452

Qatida reported that Anas b. Malik said: May I not narrate to you a hadith which I heard from Allah's Messenger (may peace be upon him) which no one would narrate to you after me who would have personally heard it from him (the Holy Prophet) (as I have the good fortune to do so)? -" It is from the signs of the Last Hour that knowledge would be taken away, ignorance would prevail upon (the world), adultery would become common, wine would be drunk, the number of men will fall short and the women would survive (and thus such a disparity would arise in the number of men and women) that there would be one man to look after fifty women.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6453]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6453

This hadith has been transmitted on the authority of Anas b. Malik through another chain of narrators, but with a slight variation of wording.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6454]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6454

Abu Wa'il reported: I was sitting with 'Abdullah and Abu Musa that they reported Allah's Messenger (may peace be upon him) having said: Prior to the Last Hour, there would be a time when knowledge would be taken away, and ignorance would take its place and there would be bloodshed on a large scale.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6455]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6455

This hadith has been narrated on the authority of 'Abdullah (b. Mas'ud) and Abu Musa (al-Asha'ri) through other chains of transmitters.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6456]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6456

A hadith like this has been narrated on the authority of Abu Musa through another chain of transmitters.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6457]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6457

Abu Wa'il reported: I was sitting with Abu Musa and 'Abdullah and they were conversing with each other and Abu Musa reported Allah's Messenger (may peace be upon him) as saying (that we find in the above-mentioned ahadith).


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6458]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6458

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: (When) the time would draw close to the Last Hour, knowledge would be snatched away, turmoil would be rampant, miserliness would be put (in the hearts of the people) and therewould be much bloodshed. They said: What is al-harj? Thereupon he said: It is bloodshed.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6459]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6459

This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6460]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6460

Abu Huraira reported Allah's Messenger (may peace be upon him) having said: The time would draw close to the Last Hour and knowledge would decrease. The rest of the hadith is the same.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6461]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6461

This hadith has been transmitted on the authority of Abu Huraira through other chains of narrators and there is no mention of:" Miserliness would be put (in the hearts of the people)."


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6462]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6462

'Abdullah b. 'Amr b. al-'As reported Allah's Messenger (may peace be upon him) as saying: Verily, Allah does nit take away knowledge by snatching it from the people but Re takes away knowledge by taking away the scholars, so that when He leaves no learned person, people turn to ignorant as their, leaders; then they are asked to deliver religious verdicts and they deliver them without knowledge, they go astray, and lead others astray.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6463]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6463

This hadith has been narrated on the authority of 'Abdullah b. Umar through other chains of transmitters, but in the hadith transmitted by Umar b. 'Ali there is an addition of these words:, I met 'Abdullah b. 'Amr at the end of the year and I asked him about it, and he narrated to us the hadith as he had narrated before that he had heard Allah's Messenger (may peace be upon him) as saying.... (The rest of the hadith is the same).


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6464]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6464

This hadith has been narrated on the authority of 'Abdullah b. Amr b. al-'As through another chain of transmitters.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6465]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6465

'Urwa b. Zubair reported that 'A'isha said to him: This news has reached me that 'Abdullah b. 'Amr al-'As would pass by us during the Hajj season, so you meet him and ask him (about religious matters) as he has acquired great knowledge from Allah's Messenger (may peace be upon him). I thus met him and asked him about things which he narrated from Allah's Messenger (may peace be upon him). And amongst these the one he mentioned was that Allah's Apostle (may peace be upon him) said: Verily, Allah does not take away knowledge from people directly but he takes away the scholars and consequently takes away (knowledge) along with them and leaves amongst persons the ignorant as their leaders who deliver religious verdicts without (adequate) knowledge and themselves go astray and lead others astray. 'Urwa said: When I narrated this to 'A'isha, she deemed it too much (to believe) and thus showed reluctance to accept that (as perfectly true) and said to, 'Urwa: Did he ('Abdullah b. 'Amr) say to you that he had heard Allah's Apostle (may peace be upon him) as saying: ('Urwa had forgotten to ask this from 'Abdullah b. 'Amr). So when it was the next year, she ('A'isha) said to him ('Urwa): Ibn Amr has come (for Hajj), so meet him. talk to him and ask him about this hadith that he narrated to You (last year on the occasion of the Hajj) pertaining to knowledge. He ('Urwa), said: So I met him, and asked about it and he narrated to me exactly like one that he had narrated (to me) for the first time. So when I informed her ('A'isha) about that, she said: I do not think but this that he has certainly told the truth and I find that be has neither made any addition to it, nor missed anything from it.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6466]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6466

Jarir b. Abdullah reported that some desert Arabs clad in woollen clothes came to Allah's Messenger (may peace be upon him). He saw them in sad plight as they had been hard pressed by need. He (the Holy Prophet) exhorted people to give charity, but they showed some reluctance until (signs) of anger could be seen on his face. Then a person from the Ansar came with a purse containing silver. Then came another person and then other persons followed them in succession until signs of happiness could be seen on his (sacred) face. Thereupon Allah's Messenger (may peace be upon him) said: He who introduced some good practice in Islam which was followed after him (by people) he would be assured of reward like one who followed it, without their rewards being diminished in any respect. And he who introduced some evil practice in Islam which had been followed subsequently (by others), he would be required to bear the burden like that of one who followed this (evil practice) without their's being diminished in any respect.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6467]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6467

Jarir reported that Allah's Messenger (may peace be upon him) delivered an address in which he exhorted people to give charity.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6468]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6468

Jarir b. 'Abdullah reported Allah's Messenger (may peace be upon him) as saying: The servant does not introduce good practice which is followed after him.... The rest of the hadith is the same.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6469]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6469

Jarir transmitted this hadith from his father through another chain of narrators.


Muslim :: The Book of Knowledge (Kitab Al-`Ilm) :: [34.6470]

The Book of Knowledge (Kitab Al-`Ilm)

Muslim :: Book 34 : Hadith 6470

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who called (people) to righteousness, there would be reward (assured) for him like the rewards of those who adhered to it, without their rewards being diminished in any respect. And he who called (people) to error, he shall have to carry (the burden) of its sin, like those who committed it, without their sins being diminished in any respect.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6471]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6471

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, thus stated: I am near to the thought of My servant as he thinks about Me, and I am with him as he remembers Me. And if he remembers Me in his heart, I also remember him in My Heart, and if he remembers Me in assembly I remember him in assembly, better than his (remembrance), and if he draws near Me by the span of a palm, I draw near him by the cubit, and if he draws near Me by the cubit I draw near him by the space (covered by) two hands. And if he walks towards Me, I rush towards him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6472]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6472

This hadith has been narrated on the authority of A'mash with the same chain of transmitters, but there is no mention of these words:" He draws near Me by the space of a hand, I draw near him by the space (covered) by two hands."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6473]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6473

Hammam b. Munabbih reported so many ahadith from Abu Huraira and one out of them is this that Allah's Messenger (may peace be upon him) said that Allah thus stated: When My servant draws close to me by the span of a palm, I draw close to him by the space of a cubit, and when he draws close to Me by the space of a cubit, I draw close to him by the space (covered) by two hands, and when he draws close to Me by the space (covered by) two hands, I go in hurry towards him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6474]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6474

Abu Huraira reported that Allah's Messenger (may peace be upon him) was travelling along the path leading to Mecca that he happened to pass by a mountain called Jumdan. He said: Proceed on, it is Jumdan, Mufarradun have gone ahead. They (the Companions of the Holy Prophet) said: Allah's Messenger, who are Mufarradun? He said: They are those males and females who remember Allah much.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6475]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6475

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There are ninety-nine names of Allah; he who commits them to memory would get into Paradise. Verily, Allah is Odd (He is one, and it is an odd number) and He loves odd number. And in the narration of Ibn 'Umar (the words are):" He who enumerated them."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6476]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6476

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Verily, there are ninety-nine names for Allah, i. e. hundred excepting one. He who enumerates them would get into Paradise. And Hammam has made this addition on the authority of Abu Huraira who reported it from Allah's Apostle (may peace be upon him) that he said:" He is Odd (one) and loves odd number."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6477]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6477

Anas reported Allah's Messenger (may peace be upon him) as saying: When one of you makes supplication, he should supplicate with a will and should not say: O Allah, confer upon me if Thou likest, for there is none to coerce Allah.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6478]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6478

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When one of you makes a supplication (to his Lord) one should not say: O Allah, grant me pardon, if Thou so likest, but one should beg one's (Lord) with a will and full devotion, for there is nothing so great in the eye of Allah which He cannot grant.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6479]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6479

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None of you should say to Allah (like this): O Allah, grant me mercy, if thou so likest. The supplication (of his) should (be permeated with) conviction (that it would be accepted by the Lord), for Allah is the Doer of (everything) He likes to do, and there is none to force Him (to do or not to do this or that).


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6480]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6480

Anas (b. Malik) reported Allah's Messenger (may peace be upon him) as saying. None of you should make a request for death because of the trouble in which he is involved, but if there is no other help to it, then say: O Allah, keep me alive as long as there is goodness in life for me and bring death to me when there is goodness in death for me.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6481]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6481

This hadith has been narrated on the authority of Anas through another chain of transmitters, but with a small variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6482]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6482

Nadr b. Anas reported, as when Anas was alive, that he said: Had Allah's Messenger (may peace be upon him) not stated this.." None should make a request for death," I would have definitely done that.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6483]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6483

Abu Hazim reported: I visited Khabbab who bad seven cauteries on his stomach and he s aid: Had Allah's Messenger (may peace be upon him) not forbidden us to call for death, I would have done so.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6484]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6484

This hadith has been transmitted on the authority of Isma'il through other chains of narrators.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6485]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6485

Hammam b. Munabbih said: Abu Huraira narrated to us ahadith from Allah's Messenger (may peace be upon him) and out of these one is that Allah's Messenger (may peace be upon him) said: None amongst you should make a request for death, and do not call for it before it comes, for when any one of you dies, he ceases (to do good) deeds and the life of a believer is not prolonged but for goodness.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6486]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6486

Ubida b. Samit reported Allah's Messenger (may peace be upon him) as saying: He who loves to meet Allah, Allah also loves to meet him, and he who dislikes to meet Allah, Allah also abhors to meet him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6487]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6487

This hadith has been narrated on the authority of 'Ubada b. Samit through another chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6488]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6488

A'isha reported that Allah's Messenger (may peace be upon him) said: He who loves to meet Allah, Allah loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him. I ('A'isha) said: Allah's Apostle, so far as the feeling of aversion against death is concerned, we all have this feeling. Thereupon he (the Holy Prophet) said: It is not that (which you construe), but (this) that when a believer (at the time of death) is given the glad tidings of the mercy of Allah, His Pleasure, and of Paradise, he loves to meet Allah, and Allah also loves to meet him, and when an unbeliever is given the news of the torment at the Hand of Allah, and Hardship to be imposed by Him, he dislikes to meet Allah and Allah also abhors to meet him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6489]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6489

This hadith has been reported on the authority of Qatida with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6490]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6490

'A'isha reported Allah's Messenger (may peace be upon him) as saying: He who loves to meet Allah, Allah also loves to meet him, and who dislikes to meet Allah, Allah abhors to meet him. There is death before (one is able to) meet Allah.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6491]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6491

A hadith like this has been narrated on the authority of A'isha through another chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6492]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6492

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who loves meeting Allah, Allah loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him. I (Shuraih b. Hani, one of the narrators) came to A'isha and said to her: Mother of the faithful, I heard Abu Huraira narrate from Allah's Messenger (may peace be upon him) which, if it is actually so, is a destruction to us. Thereupon she said: Those are in fact ruined who are ruined at the words of Allah's Messenger (may peace be upon him). What are (the words which in your opinion would cause your destruction)? He said that Allah's Messenger (may peace be upon him) had stated: He who loves to meet Allah, Allah too loves to meet him, and he who dislikes to meet Allah, Allah too abhors to meet him, and there is none amongst us who dons not hate death. Thereupon she said: Allah's Messenger (may peace be upon him) has in fact stated this, but it does not mean what you construe, but it implies (the time) when one loses the lustre of the eye, and there is rattling in the throat, shudder in the body and convulsion in fingers (at the time of death). (It is about this time) that it has been said: He who loves to meet Allah, Allah would love to meet him, and he who dislikes to meet Allah, Allah would abhor to meet him


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6493]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6493

This hadith has been reported on the authority of Mutarrif with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6494]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6494

Abu Musa reported Allah's Apostle (may peace be upon him) as saying: He who loves to meet Allah, Allah too loves to meet him, and he who dislikes to meet Allah, Allah abhors to meet him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6495]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6495

Abu Huraira reported Allah's Messenger (may peace be upon him as saying that Allah thus stated: I live in the thought of My servant as he thinks of Me and with him as he calls Me.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6496]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6496

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that Allah, the Exalted and Glorious, said: When My servant draws close to Me by the span of a palm, I draw close to him by the cubit and when he draws close to Me by the cubit, I draw close to him by the space (covered) by two hands, and when he draws close to Me by the space (covered) by two hands, I go in hurry towards him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6497]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6497

This hadith has been narrated on the authority of Mu'tamar from his father with the same chain of transmitters, with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6498]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6498

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, thus stated: I live in the thought of My servant as he thinks about Me, and I am with him, as he remembers Me And if he remembers Me in his heart, I also remember him in My Heart, and if he remembers Me in assembly I remember him in the assembly, better than he (does that), and if he draws near Me by the span of a palm I draw near him by the cubit, and if he draws near Me by the cubit I draw near him by the space (covered by) two hands. And it he walks towards Me, I rush towards him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6499]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6499

Abu Dharr reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, stated:" He who comes with goodness, there are in store for him ten like those and even more than those: 'And he who comes with vice, ' it is only for that that he is called to account. I even forgive him (as I like) and he who draws close to Me by the span of a palm I draw close to him by the cubit, and he who draws close to Me by the cubit I draw close to him by the space (covered) by two hands, and he who walks towards Me I rush towards him, and he who meets Me in the state that his sins fill the earth, but not associating anything with Me, I would meet Him with the same (vastness) of pardon (on My behalf)." This hadith has been transmitted on the authority of Waki'.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6500]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6500

A hadith like this has been transmitted on the authority of A'mash with the same chain of transmitters and he (further) said: There is for him ten like that (the good he performed) or more than that.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6501]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6501

Anas reported that Allah's Messenger (may peace be upon him) visited a person from amongst the Muslims in order to inquire (about his health) who had grown feeble like the chicken. Allah's Messenger (may peace be upon him) said: Did you supplicate for anything or beg of Him about that? He said: Yes. I used to utter (these words): Impose punishment upon me earlier in this world, what Thou art going to impose upon me in the Hereafter. Thereupon Allah's Messenger (may peace be upon him) said: Hallowed be Allah, you have neither the power nor forbearance to take upon yourself (the burden of His Punishment). Why did you not say this: O Allah, grant us good in the world and good in the Hereafter, and save us from the torment of Fire. He (the Holy Prophet) made this supplication (for him) and he was all right.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6502]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6502

This hadith has been narrated on the authority of Humaid with the same chain of transmitters, but with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6503]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6503

Anas reported that Allah's Messenger (may peace be upon him) visited a person from amongst his Companions who had grown as feeble as the chicken. The rest of the hadith is the same, but with this variation that he (the Holy Prophet) said: You have not power enough to undergo the torment imposed by Allah. And there is no mention of: He supplicated Allah for him and He cured him.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6504]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6504

This hadith had been transmitted on the authority of Anas through another chain of narrators.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6505]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6505

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying Allah has mobile (squads) of angels, who have no other work (to attend to but) to follow the assemblies of Dhikr and when they find such assemblies in which there is Dhikr (of Allah) they sit in them and some of them surround the others with their wings till the space between them and the sky of the world is fully covered, and when they disperse (after the assembly of Dhikr is adjourned) they go upward to the heaven and Allah, the Exalted and Glorious, asks them although He is best informed about them: Where have you come from? They say: We come from Thine servants upon the earth who had been glorifying Thee (reciting Subhan Allah), uttering Thine Greatness (saying Allah o-Akbar) and uttering Thine Oneness (La ilaha ill Allah) and praising Thee (uttering al-Hamdu Lillah) and begging of Thee. Be would say: What do they beg of Me? They would say: They beg of Thee the Paradise of Thine. He (God) would say: Have they seen My Paradise? They said: No, our Lord. He would say: (What it would be then) if they were to see Mine Paradise? They (the angels) said: They seek Thine protection. He (the Lord) would say: Against what do they seek protection of Mine? They (the angels) would say: Our Lord, from the Hell-Fire. He (the Lord) would say: Have they seen My Fire? They would say: No. He (the Lord) would say: What it would be if they were to see My Fire? They would say: They beg of Thee forgiveness. He would say: I grant pardon to them, and confer upon them what they ask for and grant them protection against which they seek protection. They (the angels) would again say: Our Lord, there is one amongst them such and such simple servant who happened to pass by (that assembly) and sat there along with them (who had been participating in that assembly). He (the Lord) would say: I also grant him pardon, for they are a people the seat-fellows of whom are in no way unfortunate.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6506]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6506

Qatada asked Anas which Supplication Allah's Apostle (may peace be upon him) frequently made. He said: The supplication that he (the Holy Prophet made very frequently is this:" O Allah, grant us the good in this world and the good in the Hereafter and save us from the torment of Hell-Fire." He (Qatada) said that whenever Anas had to supplicate he made this very supplication, and whenever he (intended) to make another supplication he (inserted) this very supplication in that.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6507]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6507

Anas reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words):" Our Lord, grant us the good in this world and the good in the Hereafter and save us from the torment of Hell Fire."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6508]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6508

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who uttered these words:" There is no god but Allah, the One, having no partner with Him. Sovereignty belongs to Him and all the praise is due to Him, and He is Potent over everything" one hundred times every day there is a reward of emancipating ten slaves for him, and there are recorded hundred virtues to his credit, and hundred vices are blotted out from his scroll, and that is a safeguard for him against the Satan on that day till evening and no one brings anything more excellent than this, except one who has done more than this (who utters these words more than one hundred times and does more good acts) and he who utters:" Hallowed be Allah, and all praise is due to Him," one hundred times a day, his sins are obliterated even if they are equal to the extent of the foam of the ocean.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6509]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6509

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who recites in the morning and in the evening (these words):" Hallowed be Allah and all praise is due to Him" one hundred times, he would not bring on the Day of Resurrection anything excellent than this except one who utters these words or utters more than these words.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6510]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6510

'Amr b. Maimun reported: He who uttered:" There is no god but Allah, the One, having no partner with Him, His is the Sovereignty and all praise is due to Him and He is Potent over everything" ten times, he is like one who emancipated four slaves from the progeny of Isma'il. Rabi' b. Khuthaim narrated a hadith like this. Sha'bi reported: I said to Rabi': From whom did you hear it? He said: From 'Amr b. Maimun. I came to 'Amr b. Maimun and said to him: From whom did you hear this hadith? He said: from Ibn Abi Laila. I came to Ibn Abi Laila and said to him: From whom did you hear this hadith? He said: From Abu Ayyub Ansari, who narrated from Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6511]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6511

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Two are the expressions which are light on the tongue, but heavy in scale, dear to the Compassionate One:" Hallowed be Allah and praise is due to Him" ;" Hallowed be Allah, the Great."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6512]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6512

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The uttering of (these words):" Hallowed be Allah; all praise is due to Allah, there is no god but Allah and Allah is the Greatest," is dearer to me than anything over which the sun rises.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6513]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6513

Mu'sab b. Sa'd reported on the authority of his father that a desert Arab came to Allah's Messenger (may peace be upon him) and said to him: Teach me the words which I should (often) utter. He said: Utter," There is no god but Allah, the One, having no partner with Him. Allah is the Greatest of the great and all praise is due to Him. Hallowed be Allah, the Lord of the worlds, there is no Might and Power but that of Allah, the All-Powerful and the Wise." He (that desert Arab) said: These all (glorify) my Lord. But what about me? Thereupon he (the Holy Prophet) said: You should say:" O Allah, grant me pardon, have mercy upon me, direct me to righteousness and provide me sustenance." Musa (one of the narrators) said: I think he also said:" Grant me safety." But I cannot say for certain whether he said this or not. Ibn Abi Shaiba has not made a mention of the words of Musa in his narration.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6514]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6514

Abu Malik Ashaja'i reported on the authority of his father that whenever a person embraced Islam, Allah's Messenger (may peace be upon him) instructed him to recilte:" O Allah, grant me pardon, have mercy upon me, direct me to the path of righteousness and provide me sustenance."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6515]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6515

Abu Malik reported on the authority of his father that when a person embraced Islam, Allah's Messenger (may peace be upon him) used to teach him how to observe prayer and then commanded him to supplicate in these words:" O Allah, grant me pardon, have mercy upon me, direct me to the path of righteousness, grant me protection and provide me sustenance."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6516]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6516

Abu Malik reported on the authority Of his father that he heard Allah's Messenger (may peace be upon him) as saying to the person who bad come to him and asked him as to how he should beg his Lord, that he should utter these words:" O Allah, grant me pardon, have mercy upon me, protect me, provide me sustenance," and he collected his fingers together except his thumb and said: It is in these words (that there is supplication) which sums up for you (the good) of this world and that of the Hereafter.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6517]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6517

Mus'ab b. Sa'd reported that his father told him that he had been in the company of Allah's Messenger (may peace be upon him) that he said: Is one amongst you powerless to get one thousand virtues every day. Amongst those who had been sitting there, one asked: How one amongst us can get one thousand virtues every day? He said: Recite:" Hallowed be Allah" one hundred times for (by reciting them) one thousand virtues are recorded (to your credit) and one tbousand vices are blotted out.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6518]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6518

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: He who alleviates the suffering of a brother out of the sufferings of the world, Allah would alleviate his suffering from the sufferings of the Day of Resurrection, and he who finds relief for one who is hard pressed, Allah would make things easy for him in the Hereafter, and he who conceals (the faults) of a Muslim, Allah would conceal his faults in the world and in the Hereafter. Allah is at the back of a servant so long as the servant is at the back of his brother, and he who treads the path in search of know- ledge, Allah would make that path easy, leading to Paradise for him and those persons who assemble in the house among the houses of Allah (mosques) and recite the Book of Allah and they learn and teach the Qur'an (among themselves) there would descend upon them the tranquillity and mercy would cover them and the angels would surround them and Allah makes a mention of them in the presence of those near Him, and he who is slow-paced in doing good deeds, his (high) descent does not make him go ahead.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6519]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6519

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6520]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6520

Agharr Abi Muslim reported: I bear witness to the fact that both Abu Huraira and Abu Sa'id Khudri were present when Allah's Messenger may peace be upon him) said: The people do not sit but they are surrounded by angels and covered by Mercy, and there descends upon them tranquillity as they remember Allah, and Allah makes a mention of them to those who are near Him. This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6521]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6521

Abu Sa'id Khudri reported that Mu'awiya went to a circle in the mosque and said: What makes you sit here? They said: We are sitting here in order to re- member Allah. He said: I adjure you by Allah (to tell me whether you are sitting here for this very purpose)? They said: By Allah, we are sitting here for this very purpose. Thereupon, he said: I have not demanded you to take an oath, because of any allegation against you and none of my rank in the eye of Allah's Messenger (may peace be upon him) is the narrator of so few ahadith as I am. The fact is that Allah's Messenger (may peace be upon him) went out to the circle of his Companions and said: What makes you sit? They said: We are sitting here in order to remember Allah and to praise Him for He guided us to the path of Islam and He conferred favours upgn us. Thereupon he adjured by Allah and asked if that only was the purpose of their sitting there. They said: By Allah, we are not sitting here but for this very purpose, whereupon he (the Messenger) said: I am not asking you to take an oath because of any allegation against you but for the fact that Gabriel came to me and he informed me that Allah, the Exalted and Glorious, was talking to the angels about your magnificence.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6522]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6522

Al-Agharr al-Muzani, who was one amongst the Companions (of the Holy Prophet) reported that Allah's Messenger (may peace be upon him) said: There is (at times) some sort of shade upon my heart, and I seek forgiveness from Allah a hundred times a day.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6523]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6523

Al-Agharr al-Muzani who was from amongst the Companions of Allah's Apostle (may peace be upon him) reported that Ibn 'Umar stated to him that Allah's Messenger (may peace 'be upon him) said: O people, seek repentance from Allah. Verily, I seek repentance from Him a hundred times a day.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6524]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6524

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6525]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6525

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: He who seeks repentance (from the Lord) before the rising of the sun from the west (before the Day of Resurrection), Allah turns to him with Mercy.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6526]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6526

Abu Musa reported: We were along with Allah's Apostle (may peace be upon him) on a journey when the people began to pronounce Allah-o-Akbar in a loud voice. Thereupon Allah's Messenger (may peace be upon him) said: O people, sh mercy to yourselves for you are not calling One Who is deaf or absent. Verily, you are calling One Who is All-Hearing (and) Near to you and is with you. Abu Musa told that he had been behind him (the Holy Prophet) and reciting:" There is neither might nor power but that of Allah." He (the Holy Prophet), while addressing 'Abdullah b. Qais, said: Should I not direct you to a treasure from amongst the treasurers of Para- dise? I ('Abdullah b. Qais) said: Allah's Messenger, do it, of course. Thereupon he (the Holy Prophet) said: Then recite:" There is no might and no power but that of Allah."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6527]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6527

This hadith has been narrated on the authority of 'Asim with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6528]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6528

Abu Musa reported that he (and his other companions) were climbing upon the hillock along with Allah's Messenger (may peace be upon him) and when any person climbed up, he pronounced (loudly):" There is no god but Allah, Allah is the Greatest." Thereupon Allah's Apostle (may peace be upon him) said: Verily, you are not supplicating One Who is deaf or absent. He said: Abu Musa or Abdullah b Qais, should I not direct you to the words (which form) the treasure of Paradise? I said: Allah's Messenger, what are these? He said:" There is no might and no power but that of Allah."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6529]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6529

This hadith has been transmitted on the authority of Abu Musa with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6530]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6530

Abu Musa reported: We were along with Allah's Apostle (may peace be upon him) on a journey; the rest of the hadith is the same as transmitted by A'sim.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6531]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6531

Abu Musa, reported. We were along with Allah's Messenger (may peace be upon him) in an expedition. The rest of the hadith is the same (and there is an addi- tion of these words in that):" He (the Holy Prophet) said: He Whom you are sup- plicating is nearer to every one of you than the neck of his camel." And there is no mention of these words:" There is no might and no power but that of Allah."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6532]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6532

Abu Musa Ash'ari reported that Allah's Messenger (may peace be upon him) said to him: Should I not direct you to the words from the treasures of Paradise, or he said: Like a treasure from the treasures of Paradise? I said: Of course, do that. Thereupon he said:" There is no might and no power but that of Allah."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6533]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6533

Abu Bakr reported that he said to Allah's Messenger (may peace be upon him): Teach me a supplication which I should recite in my prayer. Thereupon he (the Holy Prophet) said: Recite:" O Allah, I have done great wrong to myself." According to Qutaiba (the words were: ) much (wrong) -there is none to forgive the sins but Thou only, say:" Grant me pardon from Thyself, have mercy upon me for Thou art much Forgiving and Compassionate." This hadith has been transmitted on the authority of 'Amr b. al-'As that Abu Bakr Siddiq said to Allah's Messenger (may peace be upon him): Allah's Messenger. teach me a supplication which I should make in my prayer and in my house. The rest of the hadith is the same except with this variation that he said: Much wrong (Zulman Kathira).


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6534]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6534

'A'isha reported that Allah's Messenger (may peace be upon him) used to make these supplications:" O Allah, I seek refuge in Thee from the trial of Hell-Fire; and from the torment of Hell-Fire; and from the trial of the grave and torment of the grave; and from the evil of the trial of the affluence and from the evil of the trial of poverty and I seek refuge in Thee from the evil of the turmoil of the Dajjal. O Allah, wash away my sins with snow and hail water, purify my heart from the sins as is purified the white garment from the dirt, and keep away at a distance the sins from me as yawns the distance between the East and the West; O Allah, I seek refuge in Thee from sloth, from senility, from sin, and from debt."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6535]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6535

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6536]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6536

Anas b. Malik reported that Allah's Messenger (may peace be upon him) used to say:" O Allah, I seek refuge in Thee from incapacity, from indolence, from cowardice, from senility, from miserliness, and I seek refuge in Thee from the torment of the grave and from trial of the life and death."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6537]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6537

Anas reported from Allah's Messenger (may peace be upon him) (this suppli- cation) but with this variation that these words are not found in that supplication:" From the trial of life and death."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6538]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6538

Anas b. Malik reported that Allah's Apostle (may peace be upon him) used to seek refuge in Allah from such things as mentioned in the above-mentioned hadith and from 'miserliness" too.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6539]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6539

Anas reported that Allah's Messenger (may peace he upon him) wed to make this supplication:" O Allah, I seek refuge in Thee from miserliness, from sloth and from decrepitude."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6540]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6540

Abu Huraira reported that Allah's Apostle (may peace be upon him) used to seek refuge (in Allah) from the evil of destiny and from falling into the hand of calamity and from the mockery of (triumphant) enemies and from the hardship of misery. Abu Sufyan reported: I am in doubt that I have made an addition of one word in this supplication.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6541]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6541

Khaula bint Hakim Sulamiyya reported: I heard Allah's Messenger (may peace be upon him) as saying: When anyone lands at a place, and then says:" I seek refuge in the Perfect Word of Allah from the evil of what He has created," nothing would harm him until he marches from that stopping place.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6542]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6542

Khaula bint Hakim Sulamiyya reported: I heard Allah's Messenger (may peace be upon him) as saying: When any one of you stays at a place, he should say:" I seek refuge in the Perfect Word of Allah from the evil of that He created." Nothing would then do him any harm until he moves from that place. Abu Huraira reported that a person came to Allah's Messenger (may peace be upon him) and said:" Allah's Messenger, I was stung by a scorpion during the night. Thereupon he said: Had you recited these words in the evening:" I seek refuge in the Perfect Word of Allah from the evil of what He created," it would not have done any harm to you.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6543]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6543

This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6544]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6544

Al-Bara' b. 'Azib reported that Allah's, Messenger (may peace be upon said: When you go to bed, perform ablution as is done for prayer; then lie down pn the right side and recite:" O Allah, I turn my face towards Thee and entrust my affair to Thee. I retreat unto Thee for protection with hope in Thee and fear of Thee. There is no resort and no deliverer (from hardship) but Thou only. I affirm my faith in Thine books which Thou revealed and in Thine Apostles whom Thou sent." Make this as the last word of yours (when you go to sleep) and in case you die during that night, you would die upon Fitra (upon Islam). And as I repeated these words in order to commit them to memory, I said:" I affirm my faith in Thy Messenger (Rasul) whom Thou sent." He said: Say:" I affirm my faith in the Apostle (Nabi) whom Thou sent."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6545]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6545

This hadith has been transmitted on the authority of al-Bara' b. 'Azib with a slight variation of wording and there is this addition in the hadith transmitted on the authority of Husain:" In case you get up in the morning, you will get up with bliss."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6546]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6546

Al-Bara' b. 'Azib reported that Allah's Messenger (in may peace be upon him) commanded a person (in these words): When you go to bed during night, you should say:" O Allah, I surrender myself to Thee and entrust my affair to Thee, with hope in Thee and fear of Thee. There is no resort and no deliverer (from hardship but Thou). I affirm my faith in the Book which Thou revealed and in the Messengers whom Thou sent." If you die in this state you would die on Fitra, and Ibn Bashshdr did not make a mention of" night" in this hadith.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6547]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6547

This hadith has been transmitted on the authority of al-Bara' b. 'Azib that Allah's Messenger (may peace be upon him) said to a person: O, so and so, as you go to your bed; the rest of the hadith is the same but with this variation of wording that he said:" Thine Apostle whom Thou sent." If you die that night you would die on Fitra and if you get up in the morning you would get up with a bliss.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6548]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6548

This hadith has been transmitted on the authority of al-Bara' b. 'Azib that Allah's Messenger (may peace be upon him) commanded a person (in these words) and there is no mention of this:" if you get up in the morning you would get up with a bliss."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6549]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6549

Al-Bara' reported that whenever Allah's Messenger (may peace be upon him) went to bed, he said:" O Allah, it is with Thine Name that I live and it is with Thine Name that I die." And when he got up he used to say:" Praise is due to Allah, Who gave us life after our death (sleep) and unto Thee is resurrection."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6550]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6550

Abdullah b. 'Umar commanded a person that as he went to bed, he should say:" O Allah, Thou created my being and it is for Thee to take it to its ultimate goal. And its death and life is due to Thee, and if Thou givest it life, safeguard it; and if Thou bringst death, grant it pardon. O Allah, I beg of Thee safety." A person said to him: Did you hear it from Umar? Thereupon he said: (I have heard from one) who is better than Umar, viz. from Allah's Messenger (may peace be upon him). Ibn Nafi, reported this on the authority of Abdullah b. Harith but he did not make mention of this" that he heard it himself".


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6551]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6551

Suhail reported that Abu Salih used to command us (in these words): When any one of you intends to go to sleep, he should lie on the bed on his right side and then say:" O Allah. the Lord of the Heavens and the Lord of the Earth and Lord of the Magnificent Throne, our Lord, and the Lord of evervthina, the Splitter of the grain of corn and the datestone (or fruit kernal), the Revealer of Torah and Injil (Bible) and Criterion (the Holy Qur'an), I seek refuge in Thee from the evil of every- thing Thou art to sieze by the forelock (Thou hast perfect control over it). O Allah, Thou art the First, there is naught before Thee, and Thou art the Last and there is naught after Thee, and Thou art Evident and there is nothing above Thee, and Thou art Innermost and there is nothing beyond Thee. Remove the burden of debt from us and relieve us from want." Abu Salih used to narrate it from Abu Huraira who narrated it from Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6552]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6552

Abu Huraira reported that Allah's Messenger (may peace be upon him) used to command us that as we go to our bedo, we should utter the words (as mention- ed above) and he also said (these words):" From the evil of every animal, Thou hast hold upon its forelock (Thou bast full control over it)."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6553]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6553

Abu Huraira reported that Fatima (the daughter of the Holy Prophet) came to Allah's Apostle (may peace be upon him) and asked for a servant. He said to her: Say:" O Allah, the Lord of the seven heavens" ; the rest of the hadith is the same.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6554]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6554

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: When any one of you goes to bed, he should take hold of the hem of his lower garment and then should clean (his bed) with the help of that and then should recite the name of Allah for he himself does tiot know what he left behind him on his bed, and when he intends to lie on bed, he should lie on his right side and utter these words:" Hallowed be Allah, my Lord. It is with Thine (grace) that I place my side (upon the bed) and it is with Thee that I take it up (after sleep), and in case Thou withholdst my being (if thou causest me to die), then grant pardon to my being, and if Thou keepst (this process of breathing on), then protect it with that with which Thou protected Thine pious servants."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6555]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6555

This hadith has been narrated on the authority of Ubaidullah b. Umar with the same chain of transmitters and he said: Then utter:" My Lord. with Thine name I place my side and if Thou keepest me alive have mercy upon myself"


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6556]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6556

Anas reported Allah's Messenger (may peace be upon him) as saying: When you go to bed, say:" Praise is due to Allab Who fed us, provided us drink, sufficed us and provided us with shelter, for many a people there is none to suffice and none to provide shelter."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6557]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6557

Farwa' b. Naufal Ashja'i reported: I asked: 'A'isha, in what words did Allah's Messenger (may peace be upon him) supplicate Allah? She said that he used to utter:" I seek refuge in Thee from the evil of what I did and from the evil of what I did not."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6558]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6558

Farwa' b. Naufal reported: I asked 'A'isha about the supplication that Allah's Messenger (may peace be upon him) made. She said that he used to say:" O Allah, I seek refuge in Thee from the evil of what I have done and from the evil of what I have not done."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6559]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6559

This hadith has been narrated on the authority of Muhammad b. ja'far through another chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6560]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6560

Farwa' b. Naufal reported on the authority of 'A'isha that Allah's Mes- senger (may peace be upon him) used to supplicate (in these words):" O Allah, I seek refuge in Thee from the evil of what I did and from the evil of what I did not."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6561]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6561

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) used to say:" O Allah, it is unto Thee that I surrender myself. I affirm my faith in Thee and repose my trust in Thee and turn to Thee in repentance and with Thy help fought my adversaries. O Allah, I seek refuge in Thee with Thine Power; there is no god but Thou, lest Thou leadest me astray. Thou art ever-living that dieth not, while the Jinn and mankind die."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6562]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6562

Abu Huraira reported that when Allah's Messenger (may peace be upon him) set out on a journey in the morning, he used to say:" A listener listened to our praising Allah (for) His goodly trial of us. Our Lord! acompany us, guard us and bestow upon us Thy grace. I am seeker of refuge in Allah from the Fire."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6563]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6563

Abu Musa Ash'ari reported on the authority of his father that Allahs Apostle (may peace be upon him) used to supplicate in these words:" O Allah, forgive me my faults, my ignorance, my immoderation in my concerns. And Thou art better aware (of my affairs) than myself. O Allah, grant me forgiveness (of the faults which I committed) seriously or otherwise (and which I committed inadvertently and de- liberately. All these (failings) are in me. O Allah, grant me forgiveness from the fault which I did in haste or deferred, which I committed in privacy or in public and Thou art better aware of (them) than myself. Thou art the First and the Last and over all things Thou art Omnipotent."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6564]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6564

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6565]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6565

Abu Huraira reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words):" O Allah, set right for me my religion which is the safeguard of my affairs. And set right for me the affairs of my world wherein is my living. And set right for me my Hereafter on which depends my after-life. And make the life for me (a source) of abundance for every good and make my death a source of comfort for me protecting me against every evil."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6566]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6566

Abdullah reported that Allah's Messenger (may peace be upon him) used to supplicate (in these words):" O Allah. I beg of Thee the right guidance, safeguard against evils, chastity and freedom from want."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6567]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6567

This hadith has been narrated on the authority of Abu Ishaq with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6568]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6568

Zaid b. Alqam reported: I am not going to say anything but only that which Allah's Messenger (may peace be upgn him) used to say. He used to supplicate:" O Allah, I seek refuge in Thee from incapacity, from sloth, from cowardice, from miserliness, decrepitude and from torment of the grave. O Allah, grant to my soul the sense of righteousness and purify it, for Thou art the Best Purifier thereof. Thou art the Protecting Friend thereof, and Guardian thereof. O Allah, I seek refuge in Thee from the knowledge which does not benefit, from the heart that does not entertain the fear (of Allah), from the soul that does not feel contented and the supplication that is not responded."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6569]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6569

Abdullah b. Mas'ud reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate:" We entered upon evening and the whole Kingdom of Allah also entered upon evening and praise is due to Allah. There is no god but Allah, the One Who has no partner with Him." Hasan said that Zubaid reported to him that he memorised it from Ibrahim in these very words." His is the Sovereignty and Praise is due to Him, and He is Potent over everything. O Allah, I beg of Thee the good of this night and I seek refuge in Thee from the evil of this night and the evil which follows it. O Allah, I seek refuge in Thee from sloth, from the evil of vanity. O Allah, I seek refuge in Thee from torment in the Hell-Fire and from torment in the grave."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6570]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6570

Abdullah reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate:" We have entered upon evening and so, too, the whole Kingdom of Allah has entered upon evening. Praise is due to Allah. There is no god but Allah, the One having no partner with Him." He (the narrator) said: I think that he also uttered (in this supplication these words):" His is tne Sovercignty and to Him is praise due and He is Potent over everything. My Lord, I beg of Thee good that lies in this night and good that follows it and I seek refuge in Thee from the evil that lies in this night and from the evil of that which follows it. My Lord, I seek refuge in Thee from sloth, from the evil of vanity. My Lord, I seek refuge in Thee from torment of the Hell-Fire and from torment of the grave." And when it was morning he said like this:" We entered upon morning and the whole Kingdom of Allah enter ed upon morning."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6571]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6571

Abdullah reported that when it was evening Allah's Messenger (may peace be upon him) used to supplicate:" We have entered upon evening and so has the Kingdom of Allah entere d upon evening; praise is due to Allah, there is no god but Allah the One, and there is no partner with Him. O Allah, I beg of Thee the blessing of this night and the blessing of that which lies in it. I seek refuge in Thee from the evil of it and what lies in it. O Allah, I seek refuge in Thee from sloth, from decrepitude, from the evil of vanity, from trial of the world, and from torment of the grave." Zubaid, through another chain of transmitters, has narrated on the authority of Abdullah directly this addition:" There is no god but Allah, the One, there is no partner with Him, His is the Sovereignty and to Him is praise due and He is Potent over everything."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6572]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6572

This hadith has been transmitted on the authority of Abu Huraira that Allah's Messenge; (may peace be upon him) used to supplicate thus:" There is no god but Allah, the One Who conferred upon His armies the honour of victory and helped His servant rout the clans; there is nothing after that."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6573]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6573

'Ali reported that Allah's Messenger (may peace be upon him) said to him: Say," O Allah, direct me to the right path and make me adhere to the straight path," and when you make a mention of right guidance, keep in mind the right path and when you consider of the straight (path), keep in mind the straightness of the arrow.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6574]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6574

This hadith has been narrated on the authority of 'Asim b. Kulaib with the same chain of transmitters that Allah's Messenger (may peace be upon him) said to me: Say:" O Allah, I beg of Thee righteousness and adhering to the straight path."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6575]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6575

Juwairiya reported that Allah's Messenger (may peace be upon him) came out from (her apartment) in the morning as she was busy in observing her dawn prayer in her place of worship. He came back in the forenoon and she was still sitting there. He (the Holy Prophet) said to her: You have been in the same seat since I left you. She said: Yes. Thereupon Allah's Apostle (may peace be upon him) said: I recited four words three times after I left you and if these are to be weighed against what you have recited since morning these would outweigh them and (these words) are:" Hallowed be Allah and praise is due to Him according to the number of His creation and according to the pleasure of His Self and according to the weight of His Throne and according to the ink (used in recording) words (for His Praise)."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6576]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6576

Juwairiya reported that Allah's Messenger (may peace be upon him) happened to pass by her as she was observing her dawn prayer; or after she had observed her dawn prayer. The rest of the hadith is the same but with this variation that he said:" Hallowed be Allah according to the number of His creation, hallowed be Allah according to the pleasure of His Self, hallowed be Allah according to the weight of His Throne, hallowed be Allah according to the ink used in recording His words."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6577]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6577

It is reported on the authority of Ali that Fatima had corns in her hand because of working at the hand-mill. There had fallen to the lot of Allah's Apostle (may peace be upon him) some prisoners of war. She (Fatima) came to the Holy Prophet (may peace be upon him) but she did not find him (in the house). She met A'isha and informed her (about her hardship). When Allah's Apostle (may peace be upon him) came, she ( A'isha) informed him about the visit of Fatima. ABah's Messenger (may peace be upon him) came to them (Fitima and her family). They had gone to their beds. 'Ali further (reported): We tried to stand up (as a mark of respect) but Allah's Messenger (may peace be upon him) said: Keep to your beds, and he sat amongst us and I felt coldness of his feet upon my chest. He then said: May I not direct you to something better than what you have asked for? When you go to your bed, you should recite Takbir (Allah-o-Akbar) thirty-four times and Tasbih (Subhdn Allah) thirty-three times and Tahmid (al-Hamdu li-Allah) thirty-three times, and that is better than the servant for you.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6578]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6578

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but. with a slight variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6579]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6579

This hadith has been transmitted on the authority of Ibn Abi Laili but with this addition:" Ali said: Ever since I heard this (supplication) from Allah's Apostle (may peace be upon him), I never abandoned it. It was said to him, Not even in the night of Siffin (battle of Siffin)? He sad: Yes, not even in the night of Siffin,"


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6580]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6580

Abu Huraira reported that Fatima came to Allah's Apostle (may peace be upon him) and asked for a servant and told him of the hardship of household work. He said: You would not be able to get a servant from us. May I not direct you to what is better than the servant for you? Recite Subhaana Allah thirty-three times, al- Hamdu li-Allah thirty-three times and Allah-o-Akbar thirty-four times as you go to bed. This hadith has been narrated on the authority of Suhail with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6581]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6581

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing. When you listen to the crowing of the cock, ask Allah for His favour as it sees Angels and when you listen to the braying of the donkey, seek refuge in Allah from the Satan for it sees Satan.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6582]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6582

Ibn 'Abbas reported that Allah's Apostle (may peace be upon him) used to supplicate during the time of trouble (in these words):" There is no god but Allah, the Great, the Tolerant, there is no god but Allah, the Lord of the Magnificent Throne There is no god but Allah, the Lord of the Heaven and the earth, the Lord of the Edifying Throne."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6583]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6583

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6584]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6584

Ibn Abbas reported that Allah's Messenger (may peace be upon him) used to supplicate (with these words) and he (uttered these words) at the time of trouble; the rest of the hadith is the same except with this difference that insted of saying:" The Lord of heaven and the earth," he said:" The Lord of the heaven and that of the earth."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6585]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6585

Ibn 'Abbas reported this hadith through another chain of transmitters with a sliglit variation of wording.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6586]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6586

Abu Dharr reported that Allah's Messenger (may peace be upon him) was asked as to which words were the best. He said: Those for which Allah made a choice for His Angels and His servants (and the words are):" Hallowed be Allah and praise is due to Him."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6587]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6587

Abu Dharr reported that Allah's Messenger (may peace be upon him) said: Should I not inform you about the words liked most by Allah? I said: Allah's Mes- senger, do inform me about the words liked most by Allah. He said: Verily, the words liked most by Allah are:" hallowed be Allah and praise is due to Him."


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6588]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6588

Abu Dharr reported that Allah's Messenger (may peace be upon him) said: There is no believing servant who supplicates for his brother behind his back (in his absence) that the Angels do not say: The same be for you too.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6589]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6589

Umm Darda' reported: My husband reported that he heard Allah's Mes- senger (may peace be upon him) as saying: He who supplicates for his brother behind his back (in his absence), the Angel commissioned (for carrying supplication to his Lord) says: Amen, and it is for you also.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6590]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6590

Safwan (and he was Ibn 'Abdullah b. Safwan, and he had been married to Umm Darda') reported: I visited Abu Darda's house in Syria. I did not find him there but Umm Darda' (was present at the house). She said: Do you intend to perform Hajj during this year? I said: Yes. She said: Do supplicate Allah for blessings upon us, for Allah's Apostle (may peace be upon hiin) used to say: The supplication of a Muslim for his brother at his back (in his absence) is responded so long as he makes a supplica- tion for blessings for his brother and the commissioned Angel says: Amen, and says: May it be for you too I I went to the bazar and met Abfi Dardi' and he narrated like this from Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6591]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6591

This hadith has been narrated on the authority of Safwan b. 'Abdullah b. Safwan with the same chain of transmitters.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6592]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6592

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is pleased with His servant who says: Al-Hamdu lillah While taking a morsel of food tnd while drinking.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6593]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6593

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: The supplication of every one of you is granted if he does not grow impatient and says: I supplicated but it was not granted.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6594]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6594

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The supplication of one of you is granted if he does not grow impatient and say- I supplicated my Lord but it was not granted.


Muslim :: The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr) :: [35.6595]

The Book Pertaining to the Remembrance of Allah, Supplication, Repentance and Seeking Forgiveness (Kitab Al-Dhikr)

Muslim :: Book 35 : Hadith 6595

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The supplication of the servant is granted in case he does not supplicate for sin or for severing the ties of blood, or he does not become impatient. It was said: Allah's Messenger, what does:" If he does not grow impatient" imply? He said: That he should say like this: I supplicated and I supplicated but I did not find it being responded. and theu he becomes frustrated and abandons supplication.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6596]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6596

Usama b. Zaid reported that Allah's Messenger (way peace be upon him) said: I stood at the door of Paradise and I found that the overwhelming majority of those who entered therein was that of poor persons and the wealthy persons were detained to get into that. The denizens of Hell were commanded to get into Hell, and I stood upon the door of Fire and the majority amongst them who entered there was that of women.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6597]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6597

Ibn Abbas reported that Allah's Messenger (may peace be upon him) said: I had a chance to look into the Paradise and I found that majority of the people was poor and I looked into the Fire and there I found the majority constituted by women.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6598]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6598

This hadith has been narrated on the authority of Ibn 'Abbas through another chain of transmitters.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6599]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6599

Ibn 'Abbas reported that Allah's Messenger (may peace be upon him) stated like this: Re looked into the Fire of Hell. The rest of the hadith is the same.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6600]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6600

Imran b. Husain reported that Allah's Messenger (may peace be upon him) said: Amongst the inmates of Paradise the women would form a minority.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6601]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6601

This hadith has been narrated on the authority of Mutarrif through another chain of transmitters.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6602]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6602

'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) supplicated in these words:" O Allah, I seek refuge in Thee from the withdrawal of Thine blessing and the change of Thine protection (from me) and from the sudden wrath of Thine, and from every displeasure of Thine."


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6603]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6603

Usama b. Zaid reported Allah's Messenger (may peace be upon him) as saying: I have not left after me any (chance) of turmoil more injurious to men than the harm done to the men because of women.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6604]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6604

Usama b. Zaid b. Harith and Sa'id b. Zaid b. 'Amr b. Naufal both reported Allah's Messenger (may peace be upon him) as saying: I have not left after me turmoil for the people but the harm done to men by women.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6605]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6605

This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6606]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6606

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said: The world is sweet and green (alluring) and verily Allah is going to install you as vicegerent in it in order to see how you act. So avoid the allurement of women: verily, the first trial for the people of Isri'll was caused by women. And in the hadith transmitted on the authority of Ibn Bashshar the words are:" So that He should see how you act."


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6607]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6607

'Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) said: Three persons set out on a journey. They were overtaken by rain and they had to find protection in a mountain cave where at its mouth there fell a rock of that mountain and thus blocked them altogether. One of them said to the others: Look to your good deeds that you performed for the sake of Allah and then supplicate Allah, the Exalted, that He might rescue you (from this trouble). One of them said: 0 Allah, I had my parents who were old and my wife and my small children also. I tended the flock and when I came back to them in the evening, I milked them (the sheep, goats, cows, etc.) and first served that milk to my parents. One day I was obliged to go out to a distant place in search of fodder and I could not come back before evening and found them (the parents) asleep. I milked the animals as I used to milk and brought milk to them and stood by their heads avoiding to disturb them from sleep and I did not deem it advisable to serve milk to my children before serving them. My children wept near my feet. I remained there in that very state and my parents too until it was morning. And (0 Allah) if Thou art aware that I did this in order to seek Thine pleasure, grant us riddance from this trouble. (The rock slipped a bit) that they could see the sky. The second one said: 0 Allah, I had a female cousin whom I loved more than the men love the women. I wanted to have sexual intercourse with her; she refused but on the condition of getting one hundred dinirs. It was with very great difficulty that I could collect one hundred dinirs and then paid them to her and when I was going to have a sexual intercourse with her, that she said: Servant of Allah, fear Allah and do not break the seal (of chastity) but by lawful means. I got up. 0 Allah, if Thou art aware that I did this in order to seek Thine pleasure, rid us from this trouble. The situation was somewhat eased for them. The third one said: Allah, I employed a workman for a measure of rice. After he had finished his work I gave him his dues (in the form of) a measure of rice, but he did not accept them. I used these rice as seeds, and that gave a bumper crop and I became rich enough to have cows and flocks (in my possession). He came to me and said: Fear Allah, and commit no crueltv upon me in regard to my dues. I said to him: Takeaway this flock of cows and sheep. He said: Fear Allah and do not make a fun of me. I said: I am not making a fun of you. You take the cows and the flocks. So he took them. 0 Allah, if Thou art aware that I did it for Thine pleasure, case the situation for us. And Allah relieved them from the rest of the trouble.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6608]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6608

This hadith has been transmitted on the authority of Musa b. 'Uqba but with a slight variation of wording.


Muslim :: The Book of Heart-Melting Traditions (Kitab Al-Riqaq) :: [36.6609]

The Book of Heart-Melting Traditions (Kitab Al-Riqaq)

Muslim :: Book 36 : Hadith 6609

Abdullah b 'Umar reported: I heard Allah's Alessenger (may peace be upon him) as saying: Three persons belonging to the earlier Ummahs set out on a journey until they had to spend a night in a cave. The rest of the hadith is the same and the additional words are:" A person amongst them said: 0 Allah, I had my aged parents and I served them milk before I (served that) to my wife, children and my servants." And in case of the second one, the words are:" She avoided me until she was hard pressed because of famine and she came to me and I gave her one hundred and twenty diiiirs" And in cease of the third one (the words are):" I invested his wages, and it brought profit and, as a result thereof, the merchandise increased and there was abundance of goods." And he (the narrator said) that they got out of the cave and began to walk.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6610]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6610

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: I live in the thought of My servant and I am with him as he remembers Me. (The Holy Prophet) further said: By Allah, Allah is more pleased wth the repentance of His servant than what one of you would do on finding the lost camel in the waterless desert. When he draws near Me by the span of his hand. I draw near him by the length of a cubit and when he draws near Me by the length of a cubit. I draw near him by the length of a fathom and when he draws near Me walking I draw close to him hurriedly.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6611]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6611

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of His servant when he turns penitently towards Him than one of you would be on finding the lost camel.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6612]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6612

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6613]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6613

Harith b. Suwaid said: I went to see 'Abdullah to inquire about his health as he was sick and he narrated to us a hadith of Allahs Messenger (may peace be upon him). He heard Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of His believing servant than a person who loses his riding beast carrying food and drink. He sleeps (being disappointed of its recovery) and then gets up and goes in search for that, until he is stricken with thirst. then comes back to the place where he had been before and goes to sleep completely exhausted placing his head upon his hands waiting for death. And when he gets up, lot there is before him his riding beast and his provisions of food and drink. Allah is more pleased with the repentance of His servant than the recovery of this riding beast along with the provisions (of food and drink).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6614]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6614

This hadith has been narrated on the authority of A'mash through another chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6615]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6615

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Allah is more pleased with the repentance of a believing man. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6616]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6616

Nu'man b. Bashir reported: Allah is more pleased with the repentance of a believing servant than of a person who set out on a journey with a provision of food and drink on the back of his camel. He went on until he came to a waterless desert and he felt like sleeping. So he got down under the shade of a tree and was overcome by sleep and his camel ran away. As he got up he tried to see (the camel) standing upon a mound. but did not find it. He then got upon the other mound, but could not see anything. He then climbed upon the third mound but did not see anything until he came back to the place where he had been previously. And as he was sitting (in utter disappointment) there came to him the camel, till that (camel) placed its nosestring in his hand. Allah is more pleased with the repentance of His servant than the person who found (his lost camel) in this very state. Simak reported that Sha'bi was of the opinion that Nu'min traced it to Allah's Apostle (may peace be upon him). Simak, however, did not hear that himself.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6617]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6617

Al-Bara' b. 'Azib reported Allah's Messenger (may peace be upon him) as saying that Allah's Messenger (may peace be upon him) said: What is your opinion about the delight of a person whose camel loaded with the provisions of food and drink is lost and that moves about with its nosestring trailing upon the waterless desert in which there is neither food nor drink, and lie wanders about in search of that until he is completely exhausted and then accidentally it happens to pass by the trunk of a tree and its nosestring gets entangled in that and he finds it entangled therein? He (in response to the question of the Holy Prophet) said: Allah's Messenger, he would feel highly delighted. Thereupon Allah's Messenger (may peace be upon him) said. By Allah, Allah is more delighted at the repentance of His servant than that person (as he finds his lost) camel.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6618]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6618

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is more pleased with the repentance of a servant as he turns towards Him for repentance than this that one amongst you is upon the camel in a waterless desert and there is upon (that camel) his provision of food and drink also and it is lost by him, and he having lost all hope (to get tbat) lies down in the shadow and is disappointed about his camel and there he finds that camel standing before him. He takes hold of his nosestring and then out of boundless joy says: 0 Lord, Thou art my servant and I am Thine Lord. He commits this mistake out of extreme delight.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6619]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6619

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Allah is more pleased with the repentance of His servant than if one of you gets up and he finds his camel missing in a waterless desert (and then he accidentally finds it). This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6620]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6620

Abu Sirma reported that when the time of the death of Abu Ayyub Ansari drew near, he said: I used to conceal from you a thing which I heard from Allah's Messenger (may peace be upon him) and I heard Allah's Messenger (may peace be upon him) as sayirig: Had you not committed sins, Allah would have brought into existence a creation that would have committed sin (and Allah) would have forgiven them.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6621]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6621

Abu Ayyub Ansari reported that Allah's Messenger (may peace be upon him) said: If you were not to commit sins, Allah would have swept you out of existence and would have replaced you by another people who have committed sin, and then asked forgiveness from Allah, and He would have granted them pardon.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6622]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6622

Abu Huraira reported Allah's Messenger (may peace be upon him) having said: By Him in Whose Hand is my life, if you were not to commit sin, Allah would sweep you out of existence and He would replace (you by) those people who would commit sin and seek forgiveness from Allah, and He would have pardoned them.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6623]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6623

Hanzala Usayyidi, who was amongst the scribes of Allah's Messenger (may peace be upon him). reported: I met Abu Bakr. He said: Who are you? He (Hanzala) said: Hanzala has turned to be a hypocrite. He (Abu Bakr) said: Hallowed be Allah, what are you saying? Thereupon he said: I say that when we are in the company of Allah's Messenger (may peace be upon him) we ponder over Hell-Fire and Paradise as if we are seeing them with our very eyes and when we are away from Allah's Messenger (may peace be upon him) we attend to our wives, our children, our business; most of these things (pertaining to After-life) slip out of our minds. Abu Bakr said: By Allah, I also experience the same. So I and Abu Bakr went to Allah's Messenger (may peace be upon him) and said to him: Allah's Messenger, Hanzala has turned to be a hypocrite. Thereupon Allah's Messenger (may peace be upon him) said: What has happened to you? I said: Allah's Messenger, when we are in your company, we are reminded of Hell-Fire and Paradise as if we are seeing them with our own eyes, but whenever we go away from you and attend to our wives, children and business, much of these things go out of our minds. Thereupon Allah's Messenger (may peace be upon him) said: By Him in Whose Hand is my life, if your state of mind remains the same as it is in my presence and you are always busy in remembrance (of Allah), the Angels will shake hands with you in your beds and in your paths but, Hanzala, time should be devoted (to the worldly affairs) and time (should be devoted to prayer and meditation). He (the Holy Prophet) said this thrice.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6624]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6624

Hanzala reported: We were in the company of Allah's Messenger (may peace be upon him) and he delivered to us a sermon and made a mention of Hell-Fire. Then I came to my house and began to laugh with my children and sport with my wife. (Hanzala) further reported: I went out and met Abu Bakr and made a mention of that to him. Thereupon he said: I have done the same as you have mentioned. So we went to see Allah's Messenger (way peace be upon him) and said to him: Allah's Messenger, Hanzala has turned to he a hypocrite. And he (the Holy Prophet) said Show respite. And then I narrated to him the story, and Abu Bakr said: I have done the same as he has done. Thereupon he (the Holy Prophet) said: Hanzala, there is a time for worldly affairs and a time for (worship and devotion), and if your state of mind is always the same as it is at the time of remembrance of Allah, the Angels would shake hands with you and would greet you on the path by saying: As-Salamu-Alaikum.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6625]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6625

Hanzala Taimi Ufayyidi, the scribe of Allah's Messenger (may peace be upon him), reported: We were in the presence of Allah's Messenger (may peace be upon him) and he brought to our minds the problems pertaining to Paradise and Hell-Fire. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6626]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6626

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When Allah created the creation as He was upon the Throne, He put down in His Book: Verily, My mercy predominates My wrath.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6627]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6627

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, said: My mercy excels My wrath.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6628]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6628

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: When Allah created the creation, He ordained for Himself and this document is with Him: Verily, My mercy predominates Mv wrath.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6629]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6629

Abu Huraira reported: I heard Allah's Messenger (may peace be upon him) as saying: Allah created mercy in one hundred parts and He retained with Him ninety-nine parts, and He has sent down upon the earth one part, and it is because of this one part that there is mutual love among the creation so much so that the animal lifts up its hoof from its younc, one, fearing that it might harm it.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6630]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6630

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah created one hundred (parts of mercy) and He distributed one amongst His creation and kept this one hundred excepting one with Himself (for the Day of Resurrection).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6631]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6631

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There are one hundred (parts of) mercy for Allah and He has sent down out of these one part of mercy upon the jinn and human beings and the insects and it is because of this (one part) that they love one another, show kindness to one another and even the beast treats its young one with affection, and Allah has reserved ninetynine parts of mercy with which He would treat His servants on the Day of Resurrection.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6632]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6632

Salman Farisi reported Allah's Messenger (may peace be upon him) as saying: Verily, there are one hundred (parts of) mercy for Allah, and it is one part of this mercy by virtue of which there is mutual love between the people and ninety-nine reserved for the Day of Resurrection.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6633]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6633

This hadith has been transmitted on the authority of Mu'tamir, reported on the authority of his father.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6634]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6634

Salman reported that Allah's Messenger (may peace be upon him) said: Verily, Allah created, on the same very day when He created the heavens and the earth, one hundred parts of mercy. Every part of mercy is coextensive with the space between the heavens. and the earth and He out of this mercy endowed one part to the earth and it is because of this that the mother shows affection to her child and even the beasts and birds show kindness to one another and when there would be the Day of Resurrection, Allah would make full (use of Mercy).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6635]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6635

'Umar b. Khattab reported that there were brought some prisoners to Allah's Messenger (may peace be upon him) amongst whom there was also a woman, who was searching (for someone) and when she found a child amongst the prisoners, she took hold of it, pressed it against her chest and provided it suck. Thereupon Allah's Messenger (may peace be upon him) said: Do you think this woman would ever afford to throw her child in the Fire? We said: By Allah, so far as it lies in her power, she would never throw the child in Fire. ' Thereupon Allah's Messenger (may peace be upon him) said: Allah is more kind to His servants than this woman is to her child.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6636]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6636

'Ala' reported on the authority of his father who reported on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said: If a believer were to know the punishment (in Hell) none would have the audacity to aspire for Paradise (but he would earnestly desire to be rescued from Hell), and if a non-believer were to know what is there with Allah as a mercy. none would have been disappointed in regard to Paradise.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6637]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6637

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a person who had never done any good deed asked the members of his family to burn his dead body when he would die and to scatter half of its ashes over the land and half in the ocean. By Allah, if Allah finds him in His grip, He would torment him with a torment with which He did not afflict anyone amongst the people of the world; and when the person died, it was done to him as he had commanded (his family) to do. Allah commanded the land to collect (the ashes scattered on it) and He commanded the ocean and that collected (ashes) contained in it. Allah questioned him why he had done. that He said: My Lord, it is out of Thine fear that I have done it and Thou art well aware of it, and Allah granted him pardon:.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6638]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6638

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a person committed sin beyond measure and when he was going to die, he left this will: (When I die), bum my dead body and then cast them (the ashes) to the wind and in the ocean. By Allah, if my Lord takes hold of me, He would torment me as He has not tormented anyone else. They did as he had asked them to do. He (the Lord) said to the earth: Return what you have taken. And he was thus restored to his (original form). He (Allah) said to him: What prompted you to do this? He said: My Lord, it was Thine fear or Thine awe, and Allah pardoned him because of this. Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a woman was thrown into Hell-Fire because of a cat whom she had tied and did not provide it with food. nor did she set it free to cat insects of the euth until it died inch by inch. Zuhri said: (These two ahidith) show that a person rhould neither feel confident (of getting into Paradise) because of his deeds, nor should he lose (all hopes) of getting into Paradise.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6639]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6639

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying that a servant transgressed the litnit in committing sins. The rest of the hadith is the same but there is no mention of the story of the cat in it and in the hadith transmitted on the authority of Ziibaidl (the words are):" Allah, the Exalted and Glorious, said to everything which had taken a part of lies ashes to return what it had taken."


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6640]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6640

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said that a person amongst the earlier nations before you was conferred property and children by Allah, He said to his children: 'You must do as I command you to do, otherwise I will make others besides you as my inheritors. As I die, burn my body and blow my ashes in the wind as I do not find any merit of mine which would please Allah, and if Allah were to take hold of me, He would punish me. He took a pledge from them and they did as he commanded thein to do. Allah said: What prompted you to do this? He said: My Lord. Thine fear, and Allah did not punish him at all.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6641]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6641

This hadith has been narrated on the authority of Shu'ba with the chain of transmitters but with a slight variation of wording and Qatada explained the word" lam yasiru" as:" I find no good in store for rxie in the eye of Allah."


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6642]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6642

Abu Huraira reported from Allah's Messenger (may peace be upon him) that his Lord, the Exalted and Glorious, thus said. A servant committed a sin and he said: O Allah, forgive me my sins, and Allah (the Exalted and Glorious) said: My servant commited a sin and then he came to realise that he has a Lord Who forgives the sins and takes to account (the sinner) for the sin. He then again committed a sin and said: My Lord, forgive me my sin, and Allah, the Exalted and High, said: My servant committed a sin and then came to realise that he has a Lord Who would forgive his sin or would take (him) to account for the sin. He again committed a sin and said: My Lord, forgive me for my sin, and Allah (the Exalted and High) said: My servant sas committed a sin and then came to realise that he has a Lord Who forgives the sins or takes (him) to account for sin. 0 servant, do what you like. I have granted you forgiveness.

'Abd al-A'la said: I do not know whether he said thrice or four times to do" what you desire". The hadlth has been narrated on the authority of 'Abd al-A'la b. Hammad with the same chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6643]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6643

Abu Huraira reported lie heard Allah's Messenger (may peace be upon him) as saying that a servant committed a sin. The rest of the hadith is the same, but there is a slight variation of wording.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6644]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6644

Abu Mu'sa reported Allah's Messenger (may peace be upon him) as saying that Allah, the Exalted and Glorious, Stretches out His Hand during the night so that the people repent for the fault committed from dawn till dusk and He stretches out His Hand daring the day so that the people may reprint for the fault committed from dusk to dawn. (He would accept repentance) before the sun rises in the west (before the Day of Resurrection). A hadith like this has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6645]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6645

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: Nothing is more loveable to Allah than His praise as He has praised Himself and no one is more self-respecting than Allah Himself and it As because of this that He has prohibited abominable acts.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6646]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6646

'Abdullah reported Allah's Messenger (may peace be upon him) as saying: None is more self-respectidg than Allah and it is because of this that He has prohibited abominable acts-both visible and invisible-and none loves His praise more than Allah Himself.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6647]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6647

'Abdullah b. Mas'ud reported it directly from Allah's Messenger (may peace be upon him) that he said: None is more self-respecting than Allah and it is because of this that He has prohibited abominable acts-both visible and invisible and nothing is loved by Allah more than the praise of His Ownself and it is because of this that He has praised Himself.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6648]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6648

Abdullah b. Mas'ud reported that Allah's Messenger (may peace be upon him) said: None loves one's own praise more than Allah, the Exalted and Glurious, does. It is because of this that He has praised Himself, and none is more self-respecting than Allah and it is because of this that He has prohibited abominable acts and there is none who is more anxious to accept the apologies of the people than Allah Himself and it is because of this that He has revealed the Book and sent the Messengers.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6649]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6649

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah is self-respecting and a believer is also self-respecting and the respect of Allah is injured if a believer does what He has forbidden him to do.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6650]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6650

This hadith has been narrated on the authority of Asma' daughter of Abu Bakr, through another chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6651]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6651

Abu Salama reported from Abu Huraira that he narrated that Allah's Messenger (may peace be upon hin) said: There is none more self-respecting than Allah, the Exalted and Glorious There is no mention of the narration of Asma'.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6652]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6652

Asma' reported that Allah's Apostle (may peace be upon him) said: There is none more self-respecting than Allah, the Exalted and Glorious.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6653]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6653

Abu Huraira reported Allah's Messenger (may peace be upon him ) as saying: A believer is self-respecting and Allah is extremely self-respecting.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6654]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6654

This hadith has been narrated on the authority of Shu'ba through another chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6655]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6655

'Abdullah b. Mas'ud reported that a person kissed a woman and he came to Allah's Apostle (may peace be upon him) and made a mention of that to him. It was (on this occasion) that this verse was revealed:" And observe prayer at the (two) ends of the day and in the first hours of the night. Surely, good deeds take away evil deeds. That is a reminder for the mindful" (xi. 115). That person said: Allah's Messenger, does it concern me only? He (the Holy Prophet) said: It concerns every one of my Unimah, who acts according to it.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6656]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6656

Ibn Mas'ud reported that a person came to Allah's Messenger (may peace be upon him) and told him that he had kissed a woman or touched her with his hand or did something like this. He inquired of him about its expiation. It was (on this occasion) that Allah, the Exalted and Glorious, revealed this verse (as mentioned above).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6657]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6657

This hadith has been narrated on the authority of Sulaiman Taimi with the same chain of transmitters that a person had taken liberty with a woman less than fomication. He came to 'Umar b. Khattab and he took it to be a serious offence. Then he came to Abu Bakr and he also took it to be a serious offence. Then he came the Allahs Apostle (may peace be upon him) and he made a mention of this to him. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6658]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6658

'Abdullah reported that a person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, I sported with a woman in the outskirts of Medina, and I have committed an offence short of fornication. Here I am (before you), kindly deliver verdict about me which you deem fit. Unar said: Allah concealed your fault. You had better conceal it yourself also. Allah's Apostle (may peace be upon him), however, gave no reply to him. The man stood up and went away and Allah's Apostle (may peace be upon him) sent a person after him to call him and be recited this verse:" And observe prayer at the ends of the day and in the first hours of the night. Surely, good deeds take away evil deeds. That is a reminder for the mindful" (xi. 115). A person amongst the people said: Allah's Apostle, does it concern this marn only? Thereupon he (the Holy Prophet) said: No, but the people at large.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6659]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6659

This hadith has been transmitted by Abu al-Ahwas and in this (these words are) also found: Mu'adh said: Allah's Messenger, does it concern this particular case or to all of us? And he (the Holy Prophet) said: Of course, to all of you.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6660]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6660

Anas reported that a person came to Allah's Apostle (may peace be upon him) said: Allah's Messenger, I have committed an offence which deserves imposition of haad, so impose it upon me according to the Book of Allah. Thereupon he said: Were you not present with us at the time of prayer? He said: Yes. Thereupon he said: You have been granted pardon.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6661]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6661

Abu Umama reported: We were sitting in the mosque in the company of Allah's Messenger (may peace be upon him). A person came there and said: Allah's Messenger, I have committed an offence which deserves the imposition of hadd upon me, so impose it upon me. Allah's Messenger (may peace be upon him) kept silent. He repeated it and said: Allah's Messenger, I have committed an offence which deserves the imposition of hadd upon me, so impose it upon me. He (the Holy Prophet) kept silent, and it was at this time that Iqama was pronounced for prayer (and the prayer was observed). And when Allah's Apostle (may peace be upon him) had concluded the payer that person followed Allah's Messenger (may peace be upon him). Abu Umama said: I too followed Allah's Messenger (may peace be upon him) after he had concluded the prayer, so that I should know what answer he would give to that person. That person remained attached to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I have committed an offence which deserves imposition of hadd upon me, so impose it upon me. Abu Umama reported that Allah's Messenger (may peace be upon him) said to him: Didn't you see that as you got out of the house, you performed ablution perfectly well. He said: Allah's Messenger, of course. I did it. He again said to him: Then you observed prayer along with us. He said: Allah's Messenger, yes, it is so. Thereupon Allah's Messenger (may peace be upon him) said to him: Verily, Allah has exempted you from the imposition of hadd, or he said. From your sin.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6662]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6662

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: There was a person before you who had killed ninety-nine persons and then made an inquiry about the learned persons of the world (who could show him the way to salvation). He was directed to a monk. He came to him and told him that he had killed ninety-nine persons and asked him whether there was any scope for his repentance to be accepted. He said: No. He killed him also and thus completed one hundred. He then asked about the learned persons of the earth and he was directed to a scholar, and he told him that he had killed one hundred persons and asked him whether there was any scope for his repentance to be accepted. He said: Yes; what stands between you and the repentance? You better go to such and such land; there are people devoted to prayer and worship and you also worship along with them and do not come to the land of yours since it was an evil land (for you). So he went away and he had hardly covered half the distance when death came to him and there was a dispute between the angels of mercy and the angels of punishment. The angels of mercy said: This man has come as a penitant and remorseful to Allah and the angels of punishment said: He has done no good at all. Then there came another angel in the form of a human being in order to decide between them. He said: You measure the land to which he has drawn near. They measured it and found him nearer to the land where he intended to go (the land of piety), and so the angels of mercy took possession of it. Qatada said that Hasan told him that it was said to them that as death approached him, he crawled upon his chest (and managed) to slip in the land of mercy.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6663]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6663

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying that a man killed ninety-nine persons and then he began to make an inquiry whether there was any way left for him for repentance. He came to a monk and asked him about that, and he said: There is no chance for repentance for you. He killed the monk also and then began to make an inquiry and moved from one village to another village where there lived pious persons, and as he had covered some distance, he was overtaken by death, but he managed to crawl upon his chest (to the side nearer to the place where the pious men lived). He died and then there was a dispute between the angels of mercy and the angels of punishment and (when it was measured) he was found to be nearer to the village where pious persons were living equal to the Space of a span and he was thus included among them.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6664]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6664

This hadith has been narrated on the authority of Qatida with the same chain of transmitters but (with this variation of wording):" Allah commanded the earth (from where) he wanted to come out to move itself away and to the other earth (where he wanted to go) to draw nearer."


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6665]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6665

Abu Musa' reported that Allah's Messenger (may peace be upon him) said: When it will be the Day of Resurrection Allah would deliver to every Muslim a Jew or a Christian and say: That is your rescue from Hell-Fire.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6666]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6666

Abu Burda reported on the authority of his father that Allah's Apostle (may peace be upon him) said: No Muslim would die but Allah would admit in his stead a Jew or a Christian in Hell-Fire. 'Umar b. Abd al-'Aziz took an oath: By One besides Whom there is no god but He, thrice that his father had narrated that to him from Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6667]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6667

This hadith has been transmitted on the authority of 'Aun b. Utba.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6668]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6668

Abu Burda reported Allah's Messenger (may peace be upon him) as saying: There would come people amongst the Muslims on the Day of Resurrection with as heavy sins as a mountain, and Allah would forgive them and He would place in their stead the Jews and the Christians. (As far as I think), Abu Raub said: I do not know as to who is in doubt. Abu Burda said: I narrated it to 'Umar b. 'Abd al-'Aziz, whereupon he said: Was it your father who narrated it to you from Allah's Apostle (may peace be upon him)? I said: Yes.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6669]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6669

Safwan b. Muhriz reported that a person said to Ibn 'Umar: How did you hear Allah's Messenger (may peace be upon him) as saying something about intimate conversation? He said: I heard him say: A believer will be brought to his Lord, the Exalted and Glorious, on the Day of Resurrection and He would place upon him His veil (of Light) and make him confess his faults and say: Do you recognise (your faults)? He would say: My Lord, I do recognise (them). He (the Lord) would say: I concealed them for you in the world. And today I forgive them. And he would then be given the Book containing (the account of his) good deeds. And so far as the non-believers and hypocrites are concerned, there would be general announcement about them before all creation telling them that these (people, i. e. non-believers and hypocrites) told a lie about Allah.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6670]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6670

Ibn Shihab reported that Allah's Messenger (may peace be upon him) made an expedition to Tabuk and he (the Holy Prophet) had in his mind (the idea of threatening the) Christians of Arabia in Syria and those of Rome. Ibn Shihab (further) reported that 'Abd al-Rahman b. 'Abdullah b. Ka'b informed him that Abdullah b. Ka'b who served as the guide of Ka'b b. 'Malik as he became blind that he heard Ka'b b. Malik narrate the story of his remaining behind Allah's Messenger (may peace be upon him) from the Battle of Tabuk. Ka'b b. Malik said: I never remained behind Allah's Messenger (may peace be upon him) from any expedition which he undertook except the Battle of Tabuk and that of the Battle of Badr. So far as the Battle of Badr is concerned, nobody was blamed for remaining behind as Allah's Messenger (may peace be upon him) and the Muslims (did not set out for attack but for waylaying) the caravan of the Quraish, but it was Allah Who made them confront their enemies without their intention (to do so). I had the honour to be with Allah's Messenger (may peace be upon him) on the night of 'Aqaba when we pledged our allegiance to Islam and it was more dear to me than my participation in the Battle of Badr, although Badr was more popular amongst people as compared with that (Tabuk). And this is my story of remaining back from Allah's Messenger (may peace be upon him) on the occasion of the Battle of Tabuk. Never did I possess means enough and (my circumstances) more favourable than at the occasion of this expedition. And, by Allah, I had never before this expedition simultaneously in my possession two rides. Allah's Messenger (may peace be upon him) set out for this expedition in extremely hot season; the journey was long and the land (which he and his army had to cover) was waterless and he had to confront a large army, so he informed the Muslims about the actual situation (they had to face), so that they should adequately equip themselves for this expedition, and he also told them the destination where he intended to go. And the Muslims who accompanied Allah's Messenger (may peace be upon him) at that time were large in numbers but there was no proper record of them. Ka'b (further) said: Few were the persons who wanted to absent themselves, and were under the impression that they could easily conceal themselves (and thus remain undetected) until revelations from Allah, the Exalted and Glorious (descended in connection with them).

And Allah's Messenger (may peace be upon him) set out on an expedition when the fruits were ripe and their shadows had been lengthened. I had weakness for them and it was during this season that Allah's Messenger (may peace be upon him) made preparations and the Muslims too along with them. I also set out in the morning so that I should make preparations along with them but I came back and did nothing and said to myself: I have means enough (to make preparations) as soon as I like. And I went on doing this (postponing my preparations) until people were about to depart and it was in the morning that Allah's Messenger (may peace be upon him) set out and the Muslims too along with him, but I made no preparations. I went early in the morning and came back, but I made no decision. I continued to do so until they (the Muslims) hastened and covered a good deal of distance. I also made up my mind to march on and to meet them. Would that I had done that but perhaps it was not destined for me. After the departure of Allah's Messenger (may peace be upon him) as I went out amongst people, I was shocked to find that I did not find anyone like me but people who were labelled as hypocrites or the people whom Allah granted exemption because of their incapacity and Allah's Messenger (may peace be upon him) took no notice of me until he had reached Tabuk. (One day as he was sitting amongst the people in Tabuk) he said: What has happened to Ka'b b. Malik? A person from Banu' Salama said: Allah's Messenger, the (beauty) of his cloak and his appreciation of his sides have allured him and he was thus detained. Mua'dh b. Jabal said: Woe be upon that what you contend. Allah's Messenger, by Allah, we know nothing about him but good. Allah's Messenger (may peace be upon him), however, kept quiet. It was during that time that he (the Holy Prophet) saw a person (dressed in all white (garment) shattering the illusion of eye (mirage).

Thereupon Allah's Messenger (may peace be upon him) said: May he be Abu Khaithama and, lo, it was Abu Khaithama al-Ansari and he was that person who contributed a sa' of dates and was scoffed at by the hypocrites. Ka'b b. Malik farther said: When this news reached me that Allah's Messenger (may peace be upon him) was on his way back from Tabuk I was greatly perturbed. I thought of fabricating false stories and asked myself how I would save myself from his anger on the following day. In this connection, I sought the help of every prudent man from amongst the members of my family and when it was said to me that Allah's Messenger (may peace be upon him) was about to arrive, all the false ideas banished (from my mind) and I came to the conclusion that nothing could save me but the telling of truth, so I decided to speak the truth and it was in the morning that Allah's Messenger (may peace be upon him) arrived (in Medina). And it was his habit that as he came back from a journey he first went to the mosque and observed two Rak'ahs of nafl prayer (as a mark of gratitude) and then sat amongst people. And as he did that, those who had remained behind him began to put forward their excuses and take an oath before him and they were more than eighty persons. Allah's Messenger (may peace be upon him) accepted their excuses on the very face of them and accepted their allegiance and sought forgiveness for them and left their secret (intentions) to Allah, until I presented myself to him. I greeted him and he smiled and there was a tinge of anger in that. He (the Holy Prophet) then said to me: Come forward. I went forward until I sat in front of him. He said to me: What kept you back? Could you not afford to go in for a ride? I said: Allah's Messenger, by Allah, if I were to sit in the presence of anybody else from amongst the worldly people I would have definitely saved myself from his anger on one pretext (or the other) and I have also the knack to fall into argumentation, but, by Allah, I am fully aware of the fact that if I were to put forward before you a false excuse to please you Allah would definitely provoke your wrath upon me, and if I speak the truth you may be annoyed with me, but I hope that Allah would make its end well and, by Allah, there is no valid excuse for me. By Allah, I never possessed so good means, and I never had such favourable conditions for me as I had when I stayed behind you (failed to join the expedition).

Thereupon, Allah's Messenger (may peace be upon him) said: This man told the truth, so get up until Allah gives a decision in your case. I stood up and some people of Banu' Salama followed me in hot haste, and they said to me: By Allah, we do not know about you that you committed a sin prior to this. You, however, showed inability to put forward an excuse before Allah's Messenger (may peace be upon him) as those who stayed behind him have put forward excuses. It would have been enough for the forgiveness of your sin that Allah's Messenger (may peace be upon him) would have sought forgiveness for you. By Allah, they continued to incite me until I thought of going back to Allah's Messenger (may peace be upon him) and contradict myself. Then I said to them: Has anyone else also met the same fate? They said: Yes, two persons have met the same fate as has fallen to you and they have made the sane statement as you have made, and the same verdict has been delivered in their case as it has been delivered in your case. I said: Who are they? They said: Murara b. ar-Rabi'a 'Amiri and Hilal b. Umayya al-Waqafi. They made a mention of these two pious persons to me who had participated in the Battle of Badr and there was an example for me in them. I went away when they named these two persons. Allah's Messenger (may peace be upon him) forbade the Nluslims to talk with three of us from amongst those (persons) who had stayed behind him. The people began to avoid us and their attitude towards us underwent a change and it seemed as if the whole atmosphere had turned (hostile) against us and it was in fact the same atmosphere ot which I was fully aware and in which I had lived (for a fairly long time). We spent fifty nights in this very state and my two friends confined themselves withen their houses and spent (most of the) time in weeping, but as I was young and strong amongst them I got (out of my house), participated in congregational prayers, moved about in the bazar; but none spoke to me. I came to Allah's Messenger (may peace be upon him) as he sat amongst (people) after the prayer, greeted him and asked myself whether his lips stirred in response to my greetings (or not).

Then I observed prayer beside him and looked at him with stealing glances and when I attended to my prayer, he looked at me and when I cast a glance at him he turned away his eyes from me. And when the harsh treatment of the Muslims towards me extended to a (considerable) length of time, I walked until I climbed upon the wall of the garden of Abu Qatada, and he was my cousin, and I had the greatest love for him. I greeted him but, by Allah, he did not respond to my greetings. I said to him: Abu Qatada, I adjure you by Allah, arn't you well aware of the fact that I love Allah and His Messenger (may peace be upon him) the most. He kept quiet. I again repeated saying: I adjure you by Allah. arn't you well aware of the fact that I love Allah and His Messenger (may peace be upon him) the most. He kept quiet. I again adjured him, whereupon he said: Allah and the Messenger (may peace be upon him) are best aware of it. My eyes began to shed tears and I came back climbing down from the wall and as I was walking in the bazar of Medina a Nabatean from amongst the Nabateans of Syria, who had come to sell foodgrains in Medina, asked people to direct him to Ka'b b. Malik. People gave him the indication by pointing towards me. He came to me and delivered to me a letter of the King of Ghassan and as I was a scribe I read that letter and it was written like this:" Coming to my point, it has been conveyed to us that your friend (the Holy Prophet) is subjecting you to cruelty and Allah has not created you for a place where you are to be degraded and where you cannot find your right place, so you come to us that we should accord you honour. As I read that letter I said: This is also a calamity, so I burnt it in the oven. When out of the fifty days, forty days had passed and Allah's Messenger (may peace be upon him) received no revelation, there came the messenger of Allah's Messenger (may peace be upon him) to me and said: Verily, Allah's Messenger (may peace be upon him) has commanded you to remain separate from your wife. I said: Should I divorce her or what (else) should I do? He said: No, but only remain separate from her and don't have sexual contact with her.

The same message was sent to my companions. So I said to my wife: You better go to your parents and stay there with them until Allah gives the decision in my case. The wife of Hilal b. Umayya came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, Hilal b. Umayya is a senile person, he has no servant. Do you disapprove of my serving him? He said: No, but don't go near him. She said: By Allah, he has no such instinct in him. By Allah, he spends his time in weeping from that day to this day. Some of the members of my family said to me: Were you to seek permission from Allah's Messenger (may peace be upon him) in regard to your wife as he has granted permission to the wife of Hilal b. Umayya to serve him. I said: I would not seek permission from Allah's Messenger (may peace be upon him), for I cannot say what Allah's Apostle may say in response to seeking my permission. Moreover, I am a young man. It was in this state that I spent ten more nights and thus fifty nights had passed that (people) had observed boycott with us. It was on the morning of the fiftieth night that I observed my dawn prayer and was sitting on one of the roofs of our houses. And I was in fact sitting in that very state which Allah, the Exalted and Glorious, has described about us in these words:" Life had become hard for myself and the earth had compressed despite its vastness," that I heard the noise of an announcer from the peak of the hill of Sal' saying at the top of his voice: Ka'b b. Malik, there is glad tidings for you. I fell down in prostration and came to realise that there was (a message of) relief for me. Allah's Messenger (may peace be upon him) had informed the people of the acceptance of our repentance by Allah as he offered the dawn prayer. So the people went on to give us glad tidings and some of them went to my friends in order to give them the glad tidings and a person galloped his horse and came from the tribe of Aslam and his horse reached me more quickly than his voice. And when he came to me whose sound I heard, he gave me the glad tidings. I took off my clothes and clothed him with them because of his bringing good news to me and, by Allah, I possessed nothing else (in the form of clothes) than these two on that occasion, and I asked one to lend me two clothes and dressed myself in them.

I came to Allah's Messenger (may peace be upon him) and on my way I met groups of people who greeted me because of (the acceptance of) repentance and they said: Here is a greeting for you for your repentance being accepted by Allah. (I moved on) until I came to the mosque and Allah's Messenger (may peace be upon him) had been sitting there amongst persons. So Talha b. 'Ubaidullah got up and rushed towards me and he shook hands with me and greeted me and, by Allah, no person stood up (to greet me) from amongst the emigrants except he. Ka'b said that he never forgot (this good gesture of) Talha. Ka'b further said: I greeted Allah's Messenger (may peace be upon him) with Assalam-o-'Alaikam and his face was glistening because of delight, and he said: Let there be glad tidings and blessings for you, the like of which (you have neither found nor you will find, as you find today) since your mother gave your birth. I said: Allah's Messenger. is this acceptance of repentance from you or from Allah? He said: No, (it is not from ma), it is from Allah, and it was common with Allah's Messenger (may peace be upon him) that as he was happy his face brightened up and it looked like a part of the moon and it was from this that we recognised it (his delight). As I sat before him, I said: Allah's Messenger, am I allowed to give in charity my wealth for Allah's sake and for the sake of His Messenger (may peace be upon him)? Thereupon Allah's Messenger (may peace be upon him) said: Keep some property with you as it is better for you. I said: I shall keep with me that part (of my property) which fell to my lot (on the occasion of the expedition of) Khaibar. I said: Allah's Messenger, verily, Allah has granted me salvation because of truth and, therefore, (I think) that repentance implies that I should not speak anything but truth as long as I live. He said: By Allah, I do not know whether anyone amongst the Muslims was put to more severe trial than I by Allah because of telling the truth. And since I made a mention of this to Allah's Messenger (may peace be upon him) up to this day I have not told any lie and, by Allah, I have decided not to tell a lie and I hope that Allah would save me (from trials) for the rest of my life and Allah, the Exalted and Glorious, revealed these verses:"

Certainly, Allah has turned in Mercy to the Prophet and the emigrants and the helpers who followed him in the hour of hardship after the hearts of a part of them were about to deviate; then He turned to them in mercy. Surely, to them He is Compassionate, Merciful and (He turned in Mercy) to the three who were left behind until the earth despite its vastness became strait for them and their souls were also straitened to them." And this revelation reached up to the (words):" O you who believe, develop God consciousness, and be with the truthful" (ix. 117-118). Ka'b said: By Allah, since Allah directed me to Islam there has been no blessing more significant for me than this truth of mine which I spoke to Allah's Messenger (may peace be upon him) and if I were to tell a lie I would have been ruined as were ruined those who told lies, for in regard to those who told lies Allah used harshest words used for anyone as He descended revelation (and the words of Allah are):" They will swear by Allah to you when you return to them so that you may leave them alone. So leave them alone. Surely, they are unclean and their resort is Hell, recompense for what they earned. They will swear to you that you may be pleased with them but if you are pleased with them, yet surely Allah is not pleased with the transgressing people" (ix. 95-96). K'ab said that the matter of us three persons was deferred as compared with those who took an oath in the presence of Allahs Messenger (may peace be upon him) and he accepted their allegiance and sought forgiveness for them and Allah did not give any decision in regard to us. It was Allah, the Exalted and Glorious, Who gave decisions in our case, three who remained behind. (The words of the Qur'an)" the three who were left behind" do not mean that we remained back from Jihad but these imply that He kept our matter behind them who took oath and presented excuse before Him. This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6671]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6671

'Abdullah b. K'ab, who was his (Ka'b's) guide as he became blind, reported that he heard from Ka'b b. Malik the story of his staying behind Allah's Messenger (may peace be upon him) from the expedition of Tabuk. The rest of the hadith is the same (but with this variation) that in the narration transmitted on the authority of Yunus (the words are): When Allah's Messenger (may. peace be upon him) intended to set on an expedition he kept It as a secret, but. be did not do so in thic. expedition. And in the narration transmitted on the authority of Muhammad b. Abdullah b. Muslim, there is no mention of Abu Khaithana (Allah be pleased with him) and no mention of his meeting with Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6672]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6672

It is reported on the authority of Abdullah b. K'ab and he was the guide of Ka'b as he lost his eyesight and he was the greatest scholar amongst his people and he retained in his mind many ahadith of the Companions of Allah's Messenger (may peace be upon him). He said: I heard my father Ka'b b. Malik, and he fas one of those three whose repentance was accepted (by Allah). He transmitted that He never lagged behind Allah's Messenger (may peace be upon him) from any expedition that he undertook except two expeditions; the rest of the hadith is the same, and in the tradition narrated through another chain of transmitters the words are:" That Allah's Messenger (may peace be upon him) set out on an expedition with a large number of persons more than ten thousand and this could not be recorded in the census register."


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6673]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6673

Sa'id b. Musayyib, 'Urwa b. Zubair, 'Alqama b. Waqqas and 'Ubaidullah b. Abdullah b. 'Utba b. Mas'ud--all of them reported the story of the false allegation against 'A'isha, the wife of Allah's Apostle (may peace be upon him). And they (the slanderers) said what they had to say, but Allah exonerated her of this charge and all of them reported a part of the hadith and some of them who had better memories reported more and with better retention, and I tried to retain this hadith (listening) from every one of them that they reported to me and some of them attested the other. (The sumaried substance of the false allegation is this): 'A'isha said: Whenever Allah's Messenger (may peace be upon him) intended to set out on a journey he cast lots amongst his wives and he took one with him in whose favour the lot was cast. It so happened that he cast lots amongst us while setting out on a battle and it was cast in my favour, so I set out along with Allah's Messenger (may peace be upon him). This relates to the period when the revelation concerning the commands of veil had been made. I was carried in a haudaj and I was brought down where we had to stay. In short, when we set out for return journey from the expedition and our caravan was near Medina, Allah's Messenger (may peace be upon him) commanded one night to march forward. I also got up when the command for the march was given and moved on until I went out of the encampments of the army and after relieving myself I came to my place. I touched my chest and found that my necklace which had been made of the stones of zafar had been broken. I retraced my steps and tried to search my necklace and this detained me there. The group of people who saddled my ride and placed my haudaj carrying me upon the camels marched on. They were under the impression that I was in it. The women in those days were light of weight and they did not wear much flesh, as they ate less food; so they did not perceive the weight of my haudaj as they placed it upon the camel as I was a young girl at that time. So they drove the camel and Eet out and I found my necklace after the army had marched. I came to my place and there was none to call and none to respond (the call).

I waited at my place under the impression that when the people would riot find me they would come back. So I kept sitting at my place. I was overpowered by sleep and slept. Safwan b. Mu'attal Sulami Dhakwini, who had lagged behind the army because of taking rest came to my place walking in the latter part of the night and he saw the body of a person who was asleep. He came to me and recognised me as he had seen rue before it was enjoined to observe purda. I got ap by his voice as he recited Inna lillahi wa inna ilaihi raji'un [we are for Allah and to Him we have to return. ] and I covered my head with my headdress. By Allah, he did not speak to me a word and I did not hear a word from him except Inna lillahi. He made his camel kneel down and I amounted the camel as he pressed tLe camel's foreleg and he moved on leaning the camel by the nose string on which I was riding until we came to the army where it had encamped for rest because of extreme heat. Woe be upon those who harboured doubts about me and the most notorious among them was 'Abdullah b. Ubayy, the great hypocrite. We came to Medina and I fell sick for a month. The people had been deliberating over the statements of those who had brought these calumnies against me. I was absolutely unaware of anything concerning that. This, however, caused doubt in my mind that I did not see Allah's Messenger (may peace be upon him.) treating me with such kindness with which he treated me as I fell ill before this. The Holy Prophet (may peace be upon him) would coome and greet me with Assalam-o-'Alaikum and only ask me how I was. This caused doubt in my mind, but I was unaware of the evil. I wept outside despite my failing health and there went along with me Umm Mistah and she said the daughter of Abu Rhm b. Muttalib b. 'Abd Manaf and his mother was the daughter of Sakhr b. 'Amir, the sister of the mother of Abu Bakr Sidiq and his son was Mistah b. Uthatha b. 'Abbad b. Muttalib. I and the daughter of Abu Rahm set towards the direction of my house. Something got into the head dress of Umm Mistah and she said: Woe be upon Mistah. And I said. Woe be upon what you say. Do you curse people who had participated in Badr? She said: Innocent woman, have you not heard what he said? I said: What did he say? She conveyed to me the statement of those who had brought false allegations against me. So my illness was aggravated.

I went to my house and Allah's Messenger (may peace be upon him) came to me and he greeted me and then said: How is that woman? I said: Do you permit me to go to the (house) of my parents? She (further) said: I had at that time made up my mind to confirm this news from them. Allah's Messenger (may peace be upon him) permitted me. So I came to (the house of) my parents and said to my mother: Mother, do you know what the people are talking about? She said: My daughter, you should not worry. By Allah, if there is a handsome woman who is loved by her husband and he has co-wives also they talk many a thing about her. I said: Hallowed be Allah, what are the people talking about? I wept during the whole night until it was morning and I did not have a wink of sleep and I wept even in the morning. As the revelation was delayed (in regard to this matter), so Allah's Messenger (may peace be upon him) called 'Ali ibn Abi 'Talib and Usama b. Zaid in order to seek their advice in regard to the separation of his wife. Usama b. Zaid told Allah's Messenger (may peace be apen him) about the innocence of his wives and what he knew about his love for them. He said: Allah's Messenger, they are your wives and we know nothing else about thembut goodness. And as for 'Ali b. Abu Talib, he said: Allah has not put any unnecessary burden upon you (in regard to your wives). There are a number of women besides her and if you ask that maidservant (Barira) she will tell you the truth. So, Allah's Messenger (may peace be upon him) called Bailra and said: Barira, did you see anything in 'A'isha which can cause doubt about her? Barira said: By Him Who sent thee with the truth, I have seen nothing objectionable in her but only this much that she is a young girl and she goes to sleep while kneading the flour and the lamb eats that. Thereupon Allah's Messenger (may peace be upon him) mounted the pulpit and sought vindication against 'Abdullah b. Ubayy b. Salul, and he further said: Who would exonerate me from imputations of that person who has troubled (me) in regard to my family? By Allah, I find nothing in my wife but goodness and the person whom the people have mentioned in this connection is, according to my knowledge, a thoroughly pious person, and he did never get into my house but along with me. Sa'd b. Mu'adh stood up and said: Allah's Messenger, I defend your honour against him. If he belong to the tribe of Aus we would strike his neck and if he belongs to the tribe of our brother Khazraj and you order us we would comply with your order.

Then Sa'd b. 'Ubada stood up. He was chief of the Khazraj tribe. He was otherwise a pioas man but he had some what tribal partisanship in him and he said to Sa'd b. Mu'adh: By the everlasting existence of Allah. you are not stating the fact, you will not be able to kill him and you will not have the power to do so. Thereupon, Usaid b. Hudair stood up, and he was the first cousin of Sa'd b. Mu'adh and said to Sa'd b. 'Ubada: By the everlasting existence of Allah, you are not stating the fact. We would kill him. You are a hypocrite and so you argue in defence of the hypocrites, and thus both the tribes Aus and Khazraj were flared up, until they were about to fall upon one another and Allah's Messenger (may peace be upon him) kept standing upon the pulpit and Allah's Messenger (may peace be upon him) tried to subside their anger until they became silent and thus there was silence. 'A'isha further reported: I spent the whole day in weeping and even the night and could not have a wink of sleep even next night. My parents thought that this constant weeping of mine would break my heart. I wept and they sat beside me. In the meanwhile a woman of the Ansar came to see me. I permitted her to see me and she also began to weep. And we were in this very state that Allah's Messenger (may peace be upon him) came and he greeted me and then sat down. He had never sat with me since a month when this rumour was afloat, and there was no revelation (to clarity) my case. Allah's Messenger (may peace be upon him) recited Tashahhud (there is no god but Allah and Muhammad is His Apostle) and then said: Coming to the point, 'A'isha, this is what has reached me about you and if you are innocent, Allah would Himself vindicate your honour, and if accidentally there has been a lapse on your part sock forgiveness of Allah; He will pardon thee for when a servant makes a confession of his fault and turns (to Him) penitently, Allah also turns to him (mercifully) accepting his repentance.

When Allah's Messenger (may peace be upon him) talked, my tears dried up and not even a single drop of tear was perceived by me (rolling out of my eyes). I said to my father: You give a reply to Allah's Messenger (may peace be upon him) on my behalf. He said: By Allah, I do not know what I should say to Allah's Messenger (may peace be upon him). I then said to my mother: Give a reply to Allah's Messenger (may peace be upon him) on my behalf, but she said: By Allah, I do not know what I should say to Allah's Messenger (may peace be upon him). I was a small girl at that time and I had not read much of the Qur'an (but I said): By Allah, I perceive that you have heard about this and it has settled down in your mind and you have taken it to be true, so if I say to you that I am quite innocent, and Allah knows that I am innocent, you would never believe me to be true, and if I confess to (the alleged) lapse before you, whereas Allah knows that I am completely innocent (and I have not committed this sin at all), in that case You will take me to be true and, by Allah, I, therefore, find no other alternative for me and for you except that what the father of Yousuf said:, (My course is) comely patience. And Allah it is Whose help is to be sought for in that (predicament) which ye describe" (xii 18). After this I turned my face to the other side and lay down on my bed. By Allah, I was fully aware of this fact that I was innocent but I did not expect that Allah would descend Wahy Matlu (Qur'anic Wahy) in my case as I did not think myself so much important that Allah, the Exalted and Glorious, would speak in this matter in words to be recited. I only hoped that Allah would in vision give an indication of my innocence to Allah's Messenger (may peace be upon him) during his sleep. And, by Allah, Allah's Messenger (may peace be upon him) had not moved an inch from where he had been sitting and none from the members of my family had gone that Allah, the Exalted and Glorious, descended revelation upon Allah's Messenger (may peace be upon him) there and then and he felt the burden which he used to feel at the time of receiving revelation. He began to perspire because of the burden of words of Allah as they descended upon him even during the winter season and there fell the drops of his sweat like silvery beads. When this state of receiving revelation was over, the Messenger of Allah (may peace be upon him) smiled and the first words which he spoke to me were that he said: 'A'isha, there is glad tidings for you. Verily, Allah has vindicated your honour, and my mother who had been standing by me said: Get up (and thank him, i. e. the Holy Prophet). I said: By Allah, I shall not thank him and laud him but Allah Who has descended revelation vindicating my honour. She ('A'isha) said: Allah, the Exalted and Glorious, revealed:" 'Verily, those who spread the slander are a gang among you" (and) ten (subsequent) verses in regard to my innocence. She further said: Abu Bakr used to give to Mistah (some stipend) as a token of kinship with him and for his poverty and he (Abu Bakr) said: By Allah, now I would not spend anything for him. 'A'isha said: It was upon this that Allah the Exalted and Glorious revealed this verse:" And let not those who possess dignity and ease among you swear to give to the near of the kin" up to" Yearn ye not that Allah may forgive you?" Hibban b. Musa' said that 'Abdullah b. Mubarak used to say: It is a verse contained in the Book which most (eminently) brightens the hope.

Abu Bakr said: By Allah, I wish that Allah should pardon me. I shall never stop this stipend. So he continued to give him the stipend which he had withdrawn. 'A'isha said that Allah's Messenger (way peace be upon him) asked Zainab, daughter of Jahsh, the wife of Allah's Apostle (may peace be upon him), about me what she knew or what she had seen in me, and she said: Allah's Messenger, I shall not say anything without hearing (with my ears) and seeing with my eyes. By Allah, I find nothing in her but goodness. (And she stated this in spite of the fact) that she was the only lady who amongst the wives of Allah's Apostle (may peace be upon him) used to vie with me but Allah saved her in bringing false allegation against me because of her God-consciousness. Her sister Hamna bint Jahsh, however, opposed her and she was undone along with others.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6674]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6674

This hadith has been narrated on the authority of Zuhri through other chains of transmitters but with a slight variation of wording. In the hadith transmitters on the authority of 'Urwa, there is an addition of these words:" 'A'isha did not like that Hassan should be rebuked in her presence and she used to say: It was he who wrote this verse also:" 'Verily, my father and my mother and my honour, those are all meant for defending the honour of Muhammad against you." And 'Urwa further reported that 'A'isha said: By Allah, the person, about whom the allegation was trade used to say: Hallowed be Allah, by One, in Whose hand is my life, I have never unveiled any woman, and then he die, & as a martyr in the cause of Allah, and in the narration transmitted on the authority of Ya'qub b. Ibrahim., the word is Mu'irin and in the narration transmitted on the'authority of 'Abd al-Razzaq it is Mughirin. 'Abd b. Humaid said: I said to 'Abd al-Razzaq: What does this word Mughirin mean? And he said: Al- waghra means intense heat.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6675]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6675

'A'Isha reported: When I came under discussion what the people had to say about me, Allah's Messenger (may peace be upon him) stood up for delivering an address and he recited tashahhud (I bear witness to the fact that iheie is no god but Allah) and praised Allah, lauded Him what He rightly deserves and then said: Coming to the point. Give me an advice about them who have brought false charge about my family. By Allah, I know no evil in the members of my family and the person in connection with whom the false charge is being levelled, I know no evil in him too. And he never entered my house but in my presence and when I was away on a journey, he remained with me even in that. The rest of the hadith is the same but with this change that Allah's Messenger (may peace be upon him) came to my house and asked my maidservant and she said: By Allah, I know no fault in her but this that she sleeps, and goat comes and eats the kneaded flour. Some of the Companions (of the Holy Prophet) scolded her and said: State the fact before Allah's Messenger (may peace be upon him) and they even made a pointed reference (to this incident). She said: gallowed be Allah. By Allah, I know about her as does the jeweller know about the pure piece of gold. And when this news reached the person in connection with whom the allegation was made he said: Hallowed be Allah. By Allah, I have never unveiled any woman. 'A'isha said: He fell as a martyr in the cause of Allah, and there is this addition in this hadith that the people who had brought false allegation amongst them were Mistah and Hamna and Hassan. And so far as the hypocrite 'Abdullah b. Ubayy is concerned, he was one who tried his best to gather the false news and then gave them the wind. And he was in fact a fabricator and there was Hamna, daughter of Jahsh with him.


Muslim :: The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba) :: [37.6676]

The Book Pertaining to Repentance and Exhortation to Repentance (Kitab Al-Tauba)

Muslim :: Book 37 : Hadith 6676

Anas reported that a person was charged with fornication with the slavegirl of Allah's Messenger (may peace be upon him). Thereupon Allah's Messenger (may peace be upon him) said to 'Ali: Go and strike his neck. 'Ali came to him and he found him in a well making his body cool. 'Ali said to him: Come out, and as he took hold of his hand and brought him out, he found that his sexual organ had been cut. Hadrat 'Ali refrained from striking his neck. He came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger, he has not even the sexual organ with him.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6677]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6677

Zaid b. Arqam reported: We set out on a journey along with Allah's Messenger (may peace be upon him) in which we faced many hardships. 'Abdullah b. Ubayy said to his friends: Do not give what you have in your possession to those who are with Allah's Messenger (may peace be upon him) until they desert him. Zubair said: That is the reciting of that person who recited as min haulahu (from around him) and the other reciting is man haulahia (who are around him). And in this case when we would return to Medina the honourable would drive out the meaner therefrom (lxiv. 8). I came to Allah's Apostle (may peace be upon him) and informed him about that and he sent someone to 'Abdullah b. Ubayy and he asked him whether he had said that or not. He took an oath to the fact that he had not done that and told that it was Zaid who had stated a lie to Allah's Messenger (may peace be upon him). Zaid said: I was much perturbed because of this until this verse was revealed attesting my truth:" When the hypocrites come" (lxiii. 1). Allah's Apostle (may peace be upon him) then called them in order to seek forgiveness for them, but they turned away their heads as if they were hooks of wood fixed in the wall (lxiii. 4), and they were in fact apparently good-looking persons.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6678]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6678

Jabir reported Allah's Apostle (may peace be upon him) came to the grave of 'Abdullah b. Ubayy, brought him out from that, placed him on his knee and put his saliva in his mouth and shrouded him in his own shirt and Allah knows best.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6679]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6679

Jabir b. 'Abdullah reported that Allah's Messenger (may peace be upon him) came to the grave of 'Abdullah b. Ubayy as he was placed in that. The rest of the hadith is the same.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6680]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6680

Ibn 'Umar reported that when 'Abdullah b. Ubayy b. Salul died. His son 'Abdullah b. 'Abdullah (b. Ubayy) came to Allah's Messenger (may peace be upon him) and begged him that he should give him his shirt which he would use as a coffin for his father, he gave him that. He then begged that he should conduct funeral prayer for him. Allah's Messenger (may peace be upon him) had hardly got up to observe the prayer for him that 'Umar stood up and caught hold of the garment of Allah's Messenger (may peace be upon him) and said: Allah's Messenger, are you going to conduct prayer for this man, whereas Allah has forbidden you to offer prayer for him? Thereupon Allah's Messenger (may peace be upon him) said: Allah has given me an option as He has said:" You may beg pardon for them or you may not beg pardon for them, and even if you beg pardon for them, seventy times" (ix. 80), and I am going to make an addition to the seventy. He was a hypocrite and Allah's Messenger (may peace be upon him) offered prayer for him and Allah, the Exalted and Glorious, revealed this verse:" Do not offer prayer for any one of them at all and do not stand upon their graves for (offering prayer over them)" (ix. 84).


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6681]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6681

This hadith has been narrated on the authority of 'Abdullah with the same chain of transmitters but with this addition:" He then abandoned offering (funeral) prayer for them."


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6682]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6682

Ibn Mas'ud reported that there gathered near the House three persons amongst whom two were Quraishi and one was a Thaqafi or two were Thaqafis and one was a Quraishi. They lacked understanding but wore more flesh. One of them said: Do you think that Allah hears as we speak? The other one said: He does hear when we speak loudly and He does not hear when we speak in undertones, and still the other one said: If He listens when we speak loudly, He also listens when we speak in undertones. It was on this occasion that this verse was revealed:" You did not conceal yourselves lest your ears, your eyes and your skins would stand witness against you" (xli. 22).


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6683]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6683

This hadith has been narrated on the authority of 'Abdullah through another chain of transmitters.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6684]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6684

Zaid b. Thabit reported that Allah's Apostle (may peace be upon him) set out for Uhud. Some of those persons who were with them came back. The Companions of Allah's Apostle (may peace be upon him) were divided in two groups. One group said: We would kill them, and the other one said: No, this should not be done, and it was on this occasion that this verse was revealed:" Why should you, then, be two parties in relation to hypocrites?" (iv. 88).


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6685]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6685

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6686]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6686

Abu Sa'id Khudri reported that during the lifetime of Allah's Messenger (may peace be upon him) the hypocrites behaved in this way that when Allah's Apostle (may peace be upon him) set out for a battle, they kept themselves behind, and they became happy that they had managed to sit in the house contrary to (the act of) Allah's Messenger (may peace be upon him), and when Allah's Apostle (may peace he upon him) came back, they put forward excuses and took oath and wished that people should laud them for the deeds which they had not done. It was on this occasion that this verse was revealed:" Think not that those who exult in what they have done, and love to be praised for what they have not done-think not them to be safe from the chastisement; and for them is a painful chastisement" (iii. 18).


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6687]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6687

Humaid b. 'Abd al-Rahman b. 'Auf reported that Marwan said to Rafi', his chamberlain, that he should go to Ibn 'Abbas and ask him: If every one of us be punished for his being happy upon his deed and for his being praised for what he has not done, nobody would be saved from the torment. Ibn 'Abbas said: What you have to do with this verse? It has been in fact revealed in connection with the people of the Book." Then Ibn Abbas recited this verse:" When Allah took a covenant from those who had been given the Book: You shall explain it to people and shall not conceal this" (iii. 186), and then Ibn 'Abbas recited this verse:" Think not that those who exult in what they have done and love to be praised for what they have not done" (iii. 186). Ibn 'Abbas (further) said: Allah's Apostle (may peace be upon him) asked them about something and then they concealed that and they told him something else and they went out and they thought that they had informed him as lie had asked them and they felt happy of what they had concealed.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6688]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6688

Qais reported: I said to 'Ammar: What is your opinion about that which you have done in case (of your siding with Hadrat 'Ali)? Is it your personal opinion or something you got from Allah's Messenger (may peace be upon him)? 'Ammar said: We have got nothing from Allah's Messenger (may peace be upon him) which people at large did not get, but Hudhaifa told me that Allah's Apostle (may peace be upon him) had especially told him amongst his Companion, that there would be twelve hypocrites out of whom eight would not get into Paradise, until a camel would be able to pass through the needle hole. The ulcer would be itself sufficient (to kill) eight. So far as four are concerned, I do not remember what Shu'ba said about them.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6689]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6689

Qais b. 'Ubad reported: We said to 'Ammar: Was your fighting (on the side of 'Ali in the Battle of Siffin) a matter of your own choice or you got its hints from Allah's Messenger (may peace be upon him) for it, is likely for one to err in one's own discretion or was it because of any covenant that Allah's Messenger (may peace be upon him) got from you? He said: It was not because of any covenant that Allah's Messenger (may peace be upon him) got from us which he did get from other people, and he further said that Allah's Messenger (may peace be upon him) said:" In my Ummah." And I think that Hudhaifa reported to me and according to Ghundar (the words are) that he said: In my Ummah, there would be twelve hypocrites and they would not be admitted to Paradise and they would not smell its odour, until the camel would pass through a needle's hole. Dubaila (ulcer) would be enough to (torment them) -a kind of flame of Fire which would appear in their shoulders and it would protrude from their chest.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6690]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6690

Abu Tufail reported that there was a dispute between Hudhaifa and one from the people of Aqaba as it happens amongst people. He said: I adjure you by Allah to tell me as to how many people from Aqaba were. The people said to him (Hudhaifa) to inform him as he had asked. We have been informed that they were fourteen and If you are to be counted amongst them, then they would be fifteen and I state by Allah that twelve amongst them were the enemies of Allah and of His Messenger (may peace be upon him) in this world. The rest of the three put forward this excuse: We did not hear the announcement of Allah's Messenger (may peace be upon him) and we were not aware of the intention of the people as he (the Holy Prophet) had been in the hot atmosphere. He (the Holy Prophet) then said: The water is small in quantity (at the next station). So nobody should go ahead of me, but he found people who had gone ahead of him and he cursed them on that day.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6691]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6691

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: He who climbed this hill, the hill of Murar, his sins would be obliterated as were obliterated the sins of Bani Isra'il. So the first to take their horses were the people of Banu Khazraj. Then there was a ceaseless flow of persons and Allah's Messenger (may peace be upon him) said to them: All of you are those who have been pardoned except the owner of a red camel. We came to him and said to him: You also come on, so that Allah's Messenger (may peace be upon him) may seek forgiveness for you. But he said: By Allah, so far as I am concerned, the finding of something lost is dearer to me than seeking of forgiveness for me by your companion (the Holy Prophet), and he remained busy in finding out his lost thing.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6692]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6692

Jabir b. Abdullah reported Allah's Messenger (may peace be upon him) as saying: He who would climb this hill of Murar. The rest of the hadith is the same but with this variation that it was a desert Arab who was finding out his lost thing.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6693]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6693

Anas b. Malik reported: There was a person amongst us who belonged to the tribe of Bani Najjar and he recited Sura al-Baqarah and Surat Al-i-'Imran and he used to transcribe for Allah's Messenger (may peace be upon him). He ran away as a rebel and joined the People of the Book. They gave it much importance and said: He is the person who used to transcribe for Muhammad and they were much pleased with him. Time rolled on that Allah caused his death. They dug the grave and buried him therein, but they found to their surprise that the earth had thrown him out over the surface. They again dug the grave for him and buried him but the earth again threw him out upon the surface. They again dug the grave for him and buried him but the earth again threw him out upon the surface. At last they left him unburied.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6694]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6694

Jabir reported that Allah's Messenger (may peace be upon him) came back from a journey and as he was near Medina, there was such a violent gale that the mountain seemed to be pressed. Allah's Messenger (may peace be upon him) said: This wind has perhaps been made to blow for the death of a hypocrite, and as he reached Medina a notorious hypocrite from amongst the hypocrites had died.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6695]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6695

Iyas reported on the authority of his father: We went along with Allah's Messenger (may peace be upon him) to visit a person suffering from fever. When I placed my hand upon him, I said: By Allah, I have never seen, till this day, a person running higher temperature than he. Thereupon Allah's Apostle (may peace be upon him), turning his face to his companions, said: May I not inform you of a severer temperature than this which these two persons would run on the Day of Resurrection? And they were two hypocrites riding upon the camel turning their back towards (the Muslims).


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6696]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6696

Ibn Umar reported Allah's Apostle (may peace be upon him) as saying: The similitude of a hypocrite is that of a sheep which roams aimlessly between two flocks. She goes to one at one time and to the other at another time.


Muslim :: Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim) :: [38.6697]

Pertaining To The Charateristics Of The Hypocrites And Command Concerning Them (Kitab Sifat Al-Munafiqin Wa Ahkamihim)

Muslim :: Book 38 : Hadith 6697

Ibn Umar reported Allah's Apostle (may peace be upon him) saying like this but with this change of words:" She sometimes finds a way in one flock and then in another flock."


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6698]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6698

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A bulky person would be brought on the Day of judgment and he would not carry the weight to the eye of Allah equal even to that of a gnat. Nor shall We set up a balance for them on the Day of Resurrection" (xviii. 105).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6699]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6699

Abdullah b. Mas'ud reported that a Jew scholar came to Allah's Apostle (may peace he upon him) and said. Muhammad, or Abu al-Qasim, verify, Allah, the Exalted and Glorious. would carry the Heavens on the Day of Judgment upon one finger and earths upon one finger and the mountains and trees upor one finger and the ocean and moist earth upon one finger-in fact the whole of the creation upon one finger, and then He would stir them and say: I am your Lord, I am your Lord. Thereupon Allah's Messenger (may peace be upon him) smiled testifying what that scholar had said. He then recited this verse:" And they honour not Allah with the honour due to Him; and the whole earth will be in His grip on the Day of Resurrection and the heaven* r*Utd up in His right hand. Glory be to Him I and highly Exalted is Re above what they associate (with Him)" (xxxix. 67).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6700]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6700

This hadlth has been narrated on the authority of Mansur with the same chain of truemittm (and the words are): A Jew scholar came to Allah's Messenger (may peace be upon him). The rest of the hadith is the same, but there is no mention of" then He would stir them." But there is this addition:" I saw Allah's Messengcr (may peace be upon him) smiling so much that his front teeth appeared and testifying him (th Jew scholar) ; then Allah's Messenger (may peace be upon him) recited the verse:" And they honour not Allah with the honour due to Him" (xxxix. 67).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6701]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6701

Abdullah reported that a person from the People of the Book came to Allah's Apostle (may peace he upon him) and said: Abu al-Qasim, verify, Allah would carry tho Reavmo upon one finger and the earths upon one finger and the trees and moist earth upon one finger and in fact the whole of the creation upon one finger and then say: I am your Lord. I an your Lord. And he (the narrator) further said: I saw Allah's Massenger (may peace be upon him) fooling so much hppy that his front teeth became visible and then he recited the Yeife:" And they honour not Allah with the honour due to Him" (xxxix. 67).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6702]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6702

This hadith has been narrated on the authority of A'mash with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6703]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6703

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Allan, the Exalted and Glorious, will take in His grip the earth ou the Day of Judgment and He would roll up the sky in His right hand and would say: I am the Lord; wbere are the sovereigns of the world?


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6704]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6704

Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) saying: Allah, the Exalted and Glorious, would fold the Heavens on the Day of Judgment and then He would place them on His tight hand and say: I am the Lord; where are the haughty and where are the proud (today)? He would fold the' earth (placing it) on the lef t hand and say: I am the Lord; where are the haughty and where are the proud (today)?


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6705]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6705

Abdullah b. Miqsam reported that he saw Abdullah b. Umar as he narrated Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, would take in His hand His Heavens and His Earth, and would say: I am Allah. And He would clench His fingers and then would open them (and say): I am your Lord. I saw the pulpit in commotion from underneath because of something (vib-ating) there. And (I felt this commotion so much) that I said (to myself): It may not fall with Allah's Massenger (may peace be upon him) upon it.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6706]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6706

Abdullah b. Miqsam reported that 'Abdullah b. 'Umar reported: I saw Allah'h Messenger (may peace be upon him) upon the pulpit and he was saying that the Mighty Lord, the Exalted and Glorious would take hold of the Heavens and earth in His hand. The rest of the hadith is the same,


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6707]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6707

Abu Haraira reported that Allah's Messenger (may peace be upon him) took hold of my hands and said: Allah, the Exalted and Glorious, created the clay on Saturday and He created the mountains on Sunday and He created the trees on Monday and He created the things entailing labour on Tuesday and created light on Wednesday and lie caused the animals to spread on Thursday and created Adam (peace be upon him) after 'Asr on Friday;the last creation at the last hour of the hours of Friday, i. e. between afternoon and night.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6708]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6708

Sahl b. Sa'd reported that Allah's Messenger (may peace be upon him) said: The people will be assembled on tee Day of Resurrection on a white plain with a reddish tinge like the loaf of white bread with no marks set up for anyone.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6709]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6709

'A'isha reported: I asked Allah's Messenger (may peace be upon him) about the words of Allah, the Exalted and Glorious:" The day when the earth would be changed for another earth and Heaven would be changed for another Heaven (XiV. 48), (and inquired: ) (Allah's Messenger), where would the people be on tnat day? He said: They would be on the Sirit.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6710]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6710

Abu al-Sa'id Khudri reported Allah's Messenger (may peace be upon him) as saying that the earth would turn to be one single bread on the Day of Resurrection and the Almighty would turn it in His hand as one of you turns a loaf while on a journey. It would be a feast arranged in the honour of the people of Paradise. He (the narrator) further narrated that a person from among the Jews came and he said: Abu al-Qasim, may the Compassionate Lord be pleased with you! May I inform you about the feast arranged in honour of the people of Paradise on the Day of Resurrection? He said: Do it, of course. He said: The earth would become one single bread. Then Allah's Messenger (may peace be upon him) looked towards us and laughed until his molar teeth became visible. He then again said: May I inform you about that with which they would season it? He said: Do it, of course. He said: Their seasoning would be balim and fish. The Companions of the Holy Prophet (may peace be upon him) said: What is this balam? He said: Ox and fish from whose excessive livers seventy thousand people would be able to eat.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6711]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6711

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If ten scholars of the Jews would follow me, no Jew would be left upon the surface of the earth who would not embrace Islam.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6712]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6712

'Abdullah (b. Mas'ud) reported: As I was going aloog with Allah's Apostle (may peace be upon him) in a cultivable land and he (the Holy Prophet) was walking with the support of a wood, a group of Jews happened to meet him. Some of them said to the others: Ask him about the Soul. They said: Wbat is your doubt about it? There is a possibility that you may ask him about anything (the answer of) which you may not like. They said: Ask him. So one amongst them asked him about the Soul. Allah's Messenger (may peace be upon him) kept quiet and he gave no reply and I came to know that revelation was being sent to him, so I stood at my place and thus this revelation descended upon him:" They ask thee 'about Soul. Say: The Soul is by the Commandment of my Lord, and of Knowledge you are given but a little" (xvii. 58).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6713]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6713

Abdullah reported: I was walking along with Allah's Apostle (may peace be upon him) in a field of Medina. The rest of the hadith is the same, but there is a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6714]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6714

Abdullah reported that Allah's Apostle (may peace be upon h@) was reclining against a tree in the garden. The rest of the hadith is the same. but there is a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6715]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6715

Khabbab reported that al-As b. Wa'il owed debt to me. I came to him in order to demand that. He said: I will never repay you unless you belie Mubammad. I said: I would never belie Mubammad until you die and you are again raised up. He said: When I would be raised up after death, I would repay your debt when I would get my property and children back. Waki' said: This is how Almash has narrated and it was on this occasion that this verse was revealed:" Hast thou seen him who dis. believes in Our message and says: I shall certainly be given wealth and children' (xis, 77) up to" he would come to Us alone" (xiX. 80).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6716]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6716

This hadith has been narrated on the authority of Khabbib through another chain of transmitters and the words are. I in the pre-Islamic days used to work as an iron-smith. I did some work for 'As b. Wa'il and came to him for getting the remuneration of my wages.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6717]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6717

Anas b. Malik reported that Abu Jahl said: O Allah, if he is true, then shower upon us the volley of stones from the sky or inflict upon us a grievous torment, and it was on this occasion that this verse was revealed:" 'Allah would never torment them so long as you are amongst them. And Allah is not going to torment them as long as they seek forgiveness. And why is it that Allah should not torment them and they prevent people from coming to the sacred mosque...." (viii. 34) to the end.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6718]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6718

Abu Huraira reported that Abu Jahl asked (people) whether Mubammad placed his face (on the ground) in their presence. It was said to him: Yes. He said: By Lit and Uzza. If I were to see him do that, I would trample his neck, or I would beamear his face with dust. He came to Allah's Messenger (may peace be upon him) as he was engaged in prayer and thought of trampling his neck (and the people say) that he came near him but turned upon his heels and tried to repulse something with his hands. It was said to him: What is the matter with you? He said: There is between me and him a ditch of fire and terror and wings. Thereupon Allah's Messenger (may peace he upon him) said: If he were to come near me the angels would have torn him to pieces. Then Allah, the Exalted and Glorious, revealed this verse- (the narrator) said: We do not whether it is the hadith transmitted te Abu Huraira or something conveyed to him from another source:" Nay, man is surely inordinate, because he looks upon himself as self-sufficient. Surely to thy Lord is the return. Hast thou seen him who forbids a servant when he prays? Seest thou if he is on the right way, or enjoins observance of piety? Seest thou if he [Abu Jah]] denies and turns away? Knowest he not that Allah sees? Nay. if he desists not, We will seize him by the forelock-a lying, sinful forelock. Then let him summon his council. We will summon the guards of the Hell. Nay! Obey not thou him" (Icvi. 6-19). (Rather prostrate thyself.) Ubaidullah made this addition: It was after this that (prostration) was enjoined upon and Ibn Abd al-Ala made this addition that by Nadia he meant his people.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6719]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6719

Masruq reported: We were sitting in the company of Abdullah and he was lying on the bed that a person came and said: Abd Abd al-Rabmin, a story-teller at the gates of Kinda says that the verse (of the Qur'an) which deals with the" smoke" implies that which is about to come and it would hold the breath of the infidels and would inflict the believers with cold. Thereupon Abdullah got up and said in anger. O people, fear Allah and say only that which one knows amongst you and do not say which he does not know and he should simply say: Allah has the best knowledge for He has the best knowledge amongst all of you. It does not behove him to say that which he does not know. Allah has the best knowledge of it. Verily Allah, the Exalted and Glorious, said to His Prophet (may peace be upon him) to state:" I do not ask from you any remuneration and I am not the one to put you in trouble," and when Allah's Mesqenger (may peace be upon him) saw people turning back (from religion) he said: O Allah, afflict thern with seven famines as was done in the case of Yusuf, so they were afflicted with famine by which they were forced to eat everything until they were obliged to eat the hides and the dead bodies because of hunger, and every one of them looked towards the sky and he found a smoke. And Abu Sufyan came and he said: Muhammad, you have come to command us to obey Allah and cement the ties of blood- relation whereas your people are undone; supplicate Allah for tlicm. Thereupon Allah, the Exalted and Glorious, said:" Wait for the day when there would be clear smoke from the sky which would envelop people and that would be grievous torivent" up to the words:" you are going to return to (evil)." (if this verse implied the torment of the next life) could the chastisement of the next (life) be averted (as the Qur'an states): On the day when We seize (them) with the most violent seizing; surely We shall exact retribution" (xliv. 16)? The seizing (in the hadith) implies that of the Day of Badr. And so far as the sign of smoke, seizing, inevitability and signs of Rome are concern- ed, they have become things of the past now.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6720]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6720

Masruq reported that there came to Abdullah a person and said: I have left behind in the mosque a man who explains the Qur'an according to his personal discretion and he explained this verse:" So wait for the day when the Heaven brings a clear smoke." He says that a smoke would come to the people on the Day of Resurrection anl it will withhold breath and they would be inflicted with cold. 'Abdullah said: He who has knowledge should say something and he who has no knowledge should simply say: Allah is best aware. This reflects the understanding of a person that he should say about that which he does not know that it is Allah who knows best. The fact is that when the Quraish disobeyed Allah's Apostle (may peace be upon him) he supplicated Allah that they should be afflicted with famine and starvation as was done in case of Yusuf. And they were so much hard pressed that a person would ace the sky and he would see between him and the sky something like smoke and they were so much hard pressed that they began to cat the bones, and a person came to Allah's Apostle (may peace be upon him) and said: Allah's Messenger. seek forgiveness for the tribe of Mudar for (its people) have been undone. The Messenger (may peace be upon him) said: For Mudar? You are overbold, but he supplicated Allah for them. It was upon this that this verse was revealed:" We shall remove the chastisement a little, but they will surely return to evil" (xliv. 15). lie (the narrator) said: There was a downpoor of rain upon them. When there was some relief for them they returned to the same position as they had been before, and Allah, the Exalted and Glorious, revealed this verse:" So wait for the day when the heaven brings a clear smoke enveloping people. This is a grievous torment on the day when We seize them with the most violent seizing; surely, We shall exact retribution." And this (seizing) implied (Battle) of Badr.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6721]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6721

Abdullah said that five signs have (become things) of the past (and have proved the truth of the Holy Prophet): (Enveloping) by the smoke, inevitable (punishment to the Meccans at Badr), (the victory of) Rome, (violent) seizing (of the Meccans at Badr) and (the splitting up of) the Moon.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6722]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6722

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6723]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6723

Ubayy b. Ka'b reported that the words of Allah, the Exalted and Glorious:" We will, surely, make them taste the lesser punishment before the severer punishment (that haply they may return)" (xxxii. 21) imply the torments of the world. (victory of) Rome, seizing (of the Meccans), or smoke. And Shalba was in doubt about seizing or smoke.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6724]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6724

Abu Ma'mar reported on the authority of Abdullah that the moon was split up during lifetime by Allah's Messenger (may peace be upon him) in two parts and Allah's Messenger (may peace be upon him) said: Bear testimony to this.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6725]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6725

This hadith has been transmitted on the authority of Abdullah b. Mas'ud (who said): We were along with Allah's Messenger (may peace be upon him) at Mina, that moon was split up into two. One of its parts was behind the mountain and the other one was on this side of the mountain. Allah's Messenger (may peace be upbn him) said to us: Bear witness to this.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6726]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6726

'Abdullah b. Mas'ud reported that the moon was split up in two parts during the lifetime of Allah's Messenger (may peace be upon him). The mountain covered one of its parts and one part of it was above the mountain and Allah's Messenger (may peace be upon him) said: Bear witness to this.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6727]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6727

This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6728]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6728

Anas reported that the people of Mecca demanded from Allah's Messenger (may peace be upon him) that he should show them (some) signs (miracles) and he showed tlicin the splitting of the moon. This hadlth has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6729]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6729

Anas reported that the moon was split up in two parts and in the hadith recorded in Abu Dawud, the words are:" The moon was split up into two parts during the life of Allah's Messenger (may peace be upon him)."


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6730]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6730

Ibn 'Abbas reported that the moon was split up during the lifetime of Allah's Messenger (may peace he upon him).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6731]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6731

AbU Musa reported that Allah's Messenger (may peace be upon him) said: There is none to show more patience at listening to the most irksome things than Allah, the Exalted and Glorious. ' Partnership is associated to Him (polytheism). and (fatherhood) of a child is attributed to HiM, but in spite of this He protects them (people) and provides them sustenance. This hadith has been transmitted on the authority of Abu Muas with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6732]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6732

Abdullah b. Qais reported from Allah's Messenger (may peace be upon him) that none is more forbearing in listening to the most irksome things than Allah, the Exalted. They associate rivals with him, attribute sonhood to Him, but in spite of this He provides them sustenance, grants them safety, confers upon them so many things.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6733]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6733

Anas b. Malik reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and High, would say to one who shall have to undergo the least torture (on the Day of Resurrection): Would you like to go as ransom if you had all worldly riches; he would say: Yes. Allah would say to him: When you were in the loins of Adam, I demadded from you something easier than this that you should not associate anything with Me. (The narrator says): I think He also said: I would not cause you to enter Hell-Fire but you defied and attributed Divinity (to others besides Me).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6734]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6734

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters, but with a slight variation of wording (and the words are): I shall cause him to enter Hell." (The words subsequent to these) have not been mentioned.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6735]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6735

Anas b. Malik reported that Allah's Messenger (may peace be u n him) said: It would be said to the non-believers on the Day of Resurrection: If you were to possess gold, filling the whole earth, would you like to secure your freedom by paying that? He would say: Yes. Thereupon it would be said to him: Something easier (than this) was demanded from you (but you paid no heed to it).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6736]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6736

Anas reported this hadlth through another chain of transmitters and the words are:" It would be said to him: You have told a lie; what had been demanded from you was quite easier than this (the belief in the Oneness of Allah)."


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6737]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6737

Anas b. Malik reported that a person said: Allah's Messenger, how the non-believers would be made to assemble on the Day of Resurrection (by crawling) on their faces? Thereupon he said: Is He Who is powerfnl to make them walk on their feet is not powerful enough to make them (crawl) upon their faces on the Day of Resurrection? Qatada said: Of conrse, it is so. (He adjured): By the might of our Lord.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6738]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6738

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said that one amongst the denizens of Hell who had led a life of ease and plenty amongst the people of the world would be made to dip in Fire only once on the Day of Resurrection and then it would be said to him: O, son of Adam, did you find any comfort, did you happen to get any material blessing? He would say: By Allah, no, my Lord. And then that person from amongst the persons of the world be brought who had led the most miserable life (in the world) from amongst the inmates of Paradise. and he would be made to dip once in Paradise and it would be said to him. 0, son of Adam, did you face, any hardship? Or had any distress fallen to your lot? And he would say: By Allah, no,0 my Lord, never did I face any hardship or experience any distress.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6739]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6739

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Verily, Allah does nut treat a believer unjustly in regard to his virtues. He would confer upon him (His blessing) in this world and would give him reward in the Hereafter. And as regards a non-believer. he would be made to taste the reward (of virtue in this world) what as has done for himself so much that when it would be the Hereafter. he would find no virtue for which he should be rewarded.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6740]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6740

Anas b. Malik reported that Allah's Messenger (may peace be upon him) thus told him: When a non-believer does good he is made to taste Its reward in this world. And so far as the believer is concerned, Allah stores (the reward) of his virtues for the Hereafter and provides him sustenance in accordance with his obedience to Him.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6741]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6741

This hadith has been narrated on the authority of Anas b. Malik through another chain of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6742]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6742

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Similitude of a believer is that of (a standing) crop which the air continues to toss from one side to another; in the same way a believer always (receives the strokes) of misfortune. The similitude of a hypocrite is that of a cypress tree which does not move until it is uprooted.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6743]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6743

This badith has been narrated on the authority of Zuhri with the same chain of transmitters, but with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6744]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6744

Ka'b reported that Allah's Messenger (may peace be upon him) said that the similitude of a believer is that of a standing crop in a field which is shaken by wind and then it comes to its original position but it stands at its roots. The similitude of a non-believer is that of a cypress tree which stands on its roots and nothing shakes it but it is uprooted (with) one (violent stroke).


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6745]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6745

Ka'b b. Malik reported on the authority of his father that the similitude of a believer is that of a standing crop. The wind sometimes shakes it and sometimes raises it up and then it comes to its destined end. And the similitude of a hypocrite is that of a cypress tree which is not affected by anything but is uprooted once for all. This badith has been narrated through another chain, of transmitters also.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6746]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6746

This hadith has been narrated on the authority of Ibn Ka'b through another chain of transmitters but with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6747]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6747

'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said: There is a tree amongst trees, the leaves of which do not wither and that is like a Muslim; tell me which that (tree) can be? The people began to think of the trees of the forest. Abdullah said: I thought that it could be the date-palm tree, but I felt hesitant (to say that). They (the Companions) then said: Allah's Messenger, (kindly) tell us which that can be? Thereupon he said: It is the date-palm tree. I made a mention of that to 'Umar, whereupon he said: Had you said that it meant the date-palin tree, this statement of yours (would have been dearer to me) than such and such things.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6748]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6748

Ibn Umar reported that Allah's Messenger (may peace be upon him) one day said to his Companions: Tell me about a tree which has resemblance with a believer. The people began to mention (different) trees of the forest. Ibn 'Umar said: It was instilled in my mind or in my heart and it stuck therein that it implied the date- palm tree. I made up my mind to make a mention of that but could not do that because of the presence of the elderly people there. When there was a hush amongst them (after they had expressed their views), Allah's Messenger (may peace be upon him) said: It Is the date-palm tree.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6749]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6749

Mujahid said: (I have had the privilege) of accompanying Ibn 'Umar up to Medina but I did not hear him narrate anything from Allah's Messenger (may peace be upon him) except one hadith. And he said: We were in the presence of Allah's Messenger (may peace be upon him) that there was brought to him the kernel of a date. The rest of the hadith is the same.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6750]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6750

Mujahid reported: I heard Ibn 'Umar as saying: There was brought to Allah's Messenger (may peace be upon him) the kernel. The rest of the hadith is tile same.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6751]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6751

Ibn Umar reported: We were'in the company of Allah's Messenger (may peace be upon him) that he said: Tell me of a tree which has resemblance to a Muslim and the leaves of which do not wither. Ibrahim said that perhaps Imam Muslim had stated like this: It constantly bears fruit but I have, however, seen [It does not bear fruit constantly]. Ibn Umar said: It crossed my mind that it could be the date-palm tree, but as I saw Aba Bakr and Umar observe silence, I did not deem it fit that I should speak or I should say something. 'Umar said: Had you said so, it would have been dearer to me than such and such thing.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6752]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6752

Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying: Verily, the Satan has lost all hopes that the worshippers would ever worship (him) in the peninsula of Arabia, but he (is hopeful) that he would sow the seed of dissension amongst them.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6753]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6753

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6754]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6754

Jabir reported: I heard Allah's Messenger (way peace be upon him) as saying: The throne of Iblis is upon the ocean and he sends detachments (to different parts) inorder to put people to trial and the most important figure in his eyes is one who is most notorious in sowing the seed of dissension.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6755]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6755

Jabir reported that Allah's Messenger (may peace be upon him) said: Iblis places his throne upon water; he then sends detachments (for creating dissension) ; the nearer to him in tank are those who are most notorious in creating dissension. One of them comes and says: I did so and so. And he says: You have done nothing. Then one amongst them comes and says: I did not spare so and so until I sowed the seed of discord between a husband and a wife. The Satan goes near him and says: 'You have done well. A'mash said: He then embraces him.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6756]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6756

Jabir reported that Allah's Apostle (may peace be upqn him) said: The Satan sends detachments of his own in order to put people to trial and the highest in rank, in his eyes, is one who is most notorious in sowing the seed of dissension.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6757]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6757

Abdullah b. Mas'ud reported that Allah's Messenger (may peace be upon him) said: There is none amongst you with whom is not an attache from amongst the jinn (devil). They (the Companions) said: Allah's Messenger, with you too? Thereupon he said: Yes, but Allah helps me against him and so I am safe from his hand and he does not command me but for good.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6758]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6758

This hadith has been narrated on the authority of Mansiir with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6759]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6759

A'isha the wife of Allah's Apostle (may peace be upon him), reported that one day Allah's Messenger (may peace be upon him) came out of her (apartment) during the night and she felt jealous. Then he came and he saw me (in what agitated state of mind) I was. He said: A'isha, what has happened to you? Do you feel jealous? Thereupon she said: How can it he (that a woman like me) should not feel jealous in regard to a husband like you. Thereupon Allah's Messenger (may peace be upon him) said: It was your devil who had come to you, and she said: Allah's Mes- senger, is there along with me a devil? He said: Yes. I said: Is devil attached to everyone? He said: Yes. I (Aisha) again said: Allah's Messenger, is it with you also? He said: Yes, but my Lord has helped me against him and as such I am ab solutely safe from his mischief.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6760]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6760

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None amongst you would attain salvation purely because of his deeds. A person said: Allah's Messenger, even you also. Thereupon he said: Yes. Not even I, but that Allah wraps me in Mercy, but you should act with moderation. This badith has been transmitted on the authority of Bukair b. al-Ashajj with a slight variation of wording.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6761]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6761

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none whose deeds alone would entitle him to get into Paradise. It was said to him: And, Allah's Messenger, not even you? Thereupon he said: Not even I, but that my Lord wraps me in Mercy.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6762]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6762

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none amongst you whose deeds alone would attain salvation for him. They (the Companions) said: Allah's Messenger, not even you? He (the Holy Prophet) said: Not even I, but that Allah wraps me in Mercy and He grants me pardon. Ibn 'Aun pointed towards his head with his hand saying: Not even I, but that Allah wraps me in His Forgiveness and Mercy.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6763]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6763

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There is none whose deeds alone can'secure salvation for him. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that, the Mercy of Allah should take hold of me.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6764]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6764

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: None amongst you can get. into Paradise by virtue of his deeds alone. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that Allah should wrap me in His Grace and Mercy.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6765]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6765

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Observe moderation in deeds (and if it is not possible, try to be near moderation) and understand that none amongst you can attain salvation because of his deeds alone. They said: Allah's Messenger, not even you? Thereupon he said: Not even I, but that Allah should wrap me in His Mercy and Grace.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6766]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6766

This hadith has been narrated on the authority of Jabir through another chain of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6767]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6767

A hadith like this has been narrated on the authority of A'mash through two other chains of transmitters. The wording is, however, the same.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6768]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6768

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with this addition:" Give them glad tidings".


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6769]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6769

Jabir reported: I heard Allah's Apoetle (may peace be upon him) as saying: None of you would get into Paradise because of his good deeds alone, and he would not be rescued from Fire, not even I, but because of the Mercy of Allah.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6770]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6770

A'isha, the wife of Allah's Apostle (may peace be upon him), reported that Allah's Messenger (may peace be upon him) used to say: Observe moderation (in doing deeds), and if yciu fail to observe it perfectly, try to do as much as you can do (to live up to this ideal of moderation) and be happy for none would be able to get into Paradise because of his deeds alone. They (the Companions of the Holy Prophet) said: Allah's Messenger, not even thou? Thereupon he said: Not even I, but that Allah wraps me in His Mercy, and bear this in mind that the deed loved most by Allah is one which is done constantly even though it is insignificant.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6771]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6771

This badith has been narrated on the authority of Musa b. 'Uqba with the same chain of transmitters and he did not make a mention of:" Be happy".


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6772]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6772

Mughira b. Shu'ba reported that Allah's Apostle (may peace be upon him) worshipped so much that his feet were swollen. It was said to him: (Why do you undergo so much hardship despite the fact that) Allah has pardoned for you your earlier and later sins? Thereupon he said: May I not (prove myself) to be a grateful servant (of Allah)?


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6773]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6773

This hadith has been transmitted on the authority of Mughira b. Shu'ba and the words are: Allah's Apostle (may peace be upon him) kept standing in prayer (for such long hours) that his feet were swollen. They (his Companions) said: Verily, Allah has pardoned for thee the earlier and the later of thine sins. Thereupon he said: Should I not prove myself to be a grateful servant (of Allah)?


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6774]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6774

A'isha reported that when Allah's Messenger (may peace be upon him) occupied himself in prayer, he observed such a (long) qiylm (posture of standing in prayer) that his feet were swollen. A'isha said: Allah's Messenger you do this (in spite of the fact) that your earlier and later sins have been pardoned for you? Thereupon, he said. A'isha should I not prove myself to be a thanksgiving servant (of Allah)?


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6775]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6775

Shaqiq reported: We were sitting at the door of Abdullah (b. Mas'ud) waiting for him (to come out and deliver a sermon to us). It was at this time that there happened to pass by us Yazid b. Mu'awiya an-Nakha'i. We said: Inform him ('Abdullah b. Mas'ud) of our presence here. He went in and Abdullah b. Mas'ud lost no time in coming out to us and said: I was informed of your presence here but nothing hindered me to come out to you but the fact that I did not like to bore you (by stuffing your minds with sermons) as Allah's Messenger (may peace be upon him) did not deliver us sermon on certain days fearing that it might prove to be boring for us.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6776]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6776

This hadith has been narrated on the authority of 'Abdullah through other chains of transmitters.


Muslim :: The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar) :: [39.6777]

The Book Giving Description of the Day of Judgement, Paradise and Hell (Kitab Sifat Al-Qiyamah wa'l Janna wa'n-Nar)

Muslim :: Book 39 : Hadith 6777

Shaqiq b. Wi'il reported that 'Abdullah used to give us sermon on every Thursday. A person said: Abu 'Abd al-Rahman, we love your talk and so we yearn (to listen to you) and earnestly desire that you should deliver us lecture every day. Thereupon he said: There is nothing to hinder me in giving you talk (every day) but the fact that you may be bored. Allah's Messenger (may peace be upon him) did not deliver sermons on certain days (fearing that we might be bored).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6778]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6778

Anas b. Malik reported: The Paradise is surrounded by hardships and the Hell-Fire is surrounded by temptations.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6779]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6779

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6780]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6780

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying that: Allah the Exalted and Glorious, said: I have prepared for My pious servants which no eye has ever seen, and no ear has ever heard, and no human heart has ever perceived but it is testified by the Book of Allah. He then recited:" No soul knows what comfort has been concealed from them, as a reward for what they did". (xxxii. 17)


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6781]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6781

Abu Huraira reported that Allah's Apostle (may peace be upon him) said: Allah, the Exalted and Glorious, said: I have prepared for My pious servants which no eye (has ever) seen, no ear has (ever) heard and no human heart has ever perceived those bounties leaving apart (those bounties) about which Allah has informed you.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6782]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6782

Abu Huraira reported Allah's Messenger (may peace be upon him) said that Allah, the Exalted and Glorious, said: I have prepared for My pious servants which the eye has seen not, and the ear has heard not and no human heart has ever perceived such bounties leaving aside those about which Allah has informed you. He then recited:" No soul knows what comfort has been hidden for thein".


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6783]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6783

Sahl b. Sa'd as-Sa'idi reported: I was in the company of Allah's Messenger (may peace be upon him) that he gave a description of Paradise and then Allah's Apostle (may peace be upon him) concluded with these words: There would be bounties which the eye has not seen and the ear has not heard and no human heart has ever perceived them. He then recited this verse:" They forsake (their) beds, calling upon their Lord in fear and in hope, and spend out of what We have given them. So no soul knows what refreshment of the eyes is hidden for them: a reward for what they did" (xxxii. 16-17)


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6784]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6784

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: In Paradise, there is a tree under the shadow of which a rider can travel for a hundred years.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6785]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6785

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters with the addition of these words:" He will not be able to cover this distance."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6786]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6786

Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: In Paradise, there is a tree under the shadow of which a rider can travel for a hundred years without covering (the distance) completely. This hadith has also been transmitted on the authority of Abu Sa'id al-Khudri that Allah's Apostle (may peace be upon him) is reported to have said: In Paradise, there is a tree under the shadow of which a rider of a fine and swift-footed horse would travel for a hundred years without covering the distance completely. There would be the pleasure of Allah for the inmates of Paradise and He would never be annoyed with them.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6787]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6787

Abu Sa'id al-Khudri reported that Allah's Apostle (may peace be upon him) said that Allah would say to the inmates of Paradise: O, Dwellers of Paradise, and they would say in response: At thy service and pleasure, our Lord, the good is in Thy Hand. He (the Lord) would say: Are you well pleased now? They would say: Why should we not be pleased, O Lord, when Thou hast given us what Thou hast not given to any of Thy creatures? He would, however, say: May I not give you (something) even more excellent than that? And they would say: 0 Lord, what thing can be more excellent than this? And He would say: I shall cause My pleasure to alight upon you and I shall never be afterwards annoyed with you.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6788]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6788

Sahl b. Sa'd reported Allah's Messenger (may peace be upon him) as saying: The inmates of Paradise will look to the upper apartment of Paradise as you see the planets in the sky. I narrated this hadith to Nu'man b. Abi 'Ayyash and he said: I heard Abu Sa'id al-Khudri as saying: As you see the shining planets in the eastern and western (sides of) horizon.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6789]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6789

This hadith has been narrated on the authority of Abu Hazim through another chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6790]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6790

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: The inmates of Paradise would see the inmates of the apartment over them just as you see the shining planets which remain in the eastern and the western horizon because of the superiority some have over others. They said: Allah's Messenger, would in these abodes of Apostles others besides them not be able to reach? He said: Yes, they will, by Him, in Whose hand is my life, those who believe in God and acknowledge the Truth, will reach them.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6791]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6791

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The people most loved by me from amongst my Ummah would be those who would come after me but everyone amongst them would have the keenest desire to catch a glimpse of me even at the cost of his family and wealth.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6792]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6792

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: In Paradise there is a street to which they would come every Friday. The north wind will blow and would scatter fragrance on their faces and on their clothes and would add to their beauty and loveliness, and then they would go back to their family after having an added lustre to their beauty and loveliness, and their family would say to them: By Allah, you have been increased in beauty and loveliness after leaving us, and they would say: By Allah, you have also increased in beauty and loveliness after us.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6793]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6793

Muhammad reported that some (persons) stated with a sense of pride and some discussed whether there would be more men in Paradise or more women. It was upon this that Abu Huraira reported that Abu'l Qasim (the Holy Prophet) (may peace be upon him) said: The (members) of the first group to get into Paradise would have their faces as bright as full moon during the night, and the next to this group would have their faces as bright as the shining stars in the sky, and every person would have two wives and the marrow of their shanks would glimmer beneath the flesh and there would be none without a wife in Paradise.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6794]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6794

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6795]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6795

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters that Allah's Messenger (may peace be upon him) said: The (members of the) first group which would get into Paradise will have their faces as bright as stars in the sky. They would neither pass water, nor void excrement, nor will they suffer from catarrh, nor will they spit, and their combs would be made of gold, and their sweat will be musk, the fuel of their brazier will be aloes, and their wives will be large-eyed maidens and their form would be alike as one single person after the form of their father (Adam) sixty cubits tall.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6796]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6796

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The first group of my Ummah to get into Paradise would be like a full moon in the night. Then those who would be next to them; they would be like the most significantly glittering stars in regard to brightness, then after them (others) in ranks. They would neither void excrement, nor pass water, nor suffer from catarrh, nor would they spit. And their combs would be made of gold, and the fuel of their braziers would be aloes and their sweat would be musk and their form would be the form of one single person according to the length of their father sixty cubits tall. This hadith has been transmitted on the authority of Ibn Abi Shaiba with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6797]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6797

Hammam b. Munabbih reported: These are some of the ahidith which Abu Huraira reported from Allah's Messenger (may peace be upon him) and one is this that he is reported to have said: The (members of the) first group that would be admitted to Paradise would have their faces as bright as full moon during the night. They would neither spit nor suffer catarrh, nor void excrement. They would have their utensils and their combs made of gold and silver and the fuel of their braziers would be aloes and their sweat would be musk and every one of them would have two spouses (so beautiful) that the marrow of their shanks would be visible through the flesh. There would be no dissension amongst them and no enmity in their hearts. Their hearts would be like one heart, glorifying Allah morning and evening.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6798]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6798

Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying that the inmates of Paradise would eat and drink but would neither spit, nor pass water, nor void excrement, nor suffer catarrah. It was said: Then, what would happen with food? Thereupon he said: They would belch and sweat (and it would be over with their food), and their sweat would be that of musk and they would glorify and praise Allah as easily as you breathe.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6799]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6799

This hadith has been transmitted on the authority of A'mash with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6800]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6800

Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said that the inmates of Paradise would eat therein and they would also drink, but they would neither void excrement, nor suffer catarrh, nor pass water, and their eating (would be digested) in the form of belching and their sweat would be musk aged they would glorify and praise Allah as easily ai you breathe.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6801]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6801

This hadith has been transmitted on the authority of Jabir with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6802]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6802

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: He who would get into Paradise (would be made to enjoy such an everlasting) bliss that he would neither become destitute, nor would his clothes wear out, nor his youth would decline.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6803]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6803

Abu Sa'id al-Khudri and Abu Huraira both reported Allah's Messenger (may peace be upon him) as saying: There would be an announcer (in Paradise) who would make this announcement: Verily I there is in store for you (everlasting) health and that you should never fall ill and that you live (for ever) and do not die at all. And that you would remain young and never grow old. And that you would always live in affluent circumstances and never become destitute, as words of Allah, the Exalted and Glorious, are:" And it would be announced to them: This is the Paradise. You have been made to inherit it for what you used to do". (VII; 43)


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6804]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6804

Abu Bakr b. Abdullah b. Qais reported on the authority of his father that Allah's Messenger (may peace be upon him) said that in Paradise there would be for a believer a tent of a single hollowed pearl the breadth of which would be sixty miles. It would be meant for a believer and the believers would go around it and none would be able to see the others.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6805]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6805

Abu Bakr b. Abdullah b. Qais reported on the authority of his father that Allah's Messenger (may peace be upon him) said that in Paradise there would be a tent made of a single hollowed pearl, the breadth of which would be sixty miles from all sides and there would live a family in each corner and the other would not be able to see the believer who goes around them.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6806]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6806

This hadith has been transmitted on the authority of Abu Bakr b. Abu Musa b. Qais who, on the authority of his father, reported the Apostle (may peace be upon him) to have said that there would be a tent made of a pearl whose height towards the sky would be sixty miles. In each corner, there would be a fanaily of the believer, out of sight for the others.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6807]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6807

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Saihan, Jaihan, Euphrates and Nile are all among the rivers of Paradise.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6808]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6808

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There would enter Paradise people whose hearts would be like those of the hearts of birds.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6809]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6809

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Allah, the Exalted and Glorious, created Adam in His own image with His length of sixty cubits, and as He created him He told him to greet that group, and that was a party of angels sitting there, and listen to the response that they give him, for it would form his greeting and that of his offspring. He then went away and said: Peace be upon you! They (the angels) said: May there be peace upon you and the Mercy of Allah, and they made an addition of" Mercy of Allah". So he who would get into Paradise would get in the form of Adarn, his length being sixty cubits, then the people who followed him continued to diminish in size up to this day.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6810]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6810

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Hell would he brought on that da (the Day of judgment) with seventy bridles and every bridle would be controlled by seventy angels.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6811]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6811

Abil Huraira reported Allah's Apostle (may peace be upon him) as seying: The fire which sons of Adam burn is only one-seventieth part of the Fire of Hell. His Companions said: By Allah, even ordinary fire would have been enough (to burn people). Thereupon he said: It is sixty-nine parts in excess of (the heat of) fire in this world each of them being equivalent to their heat.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6812]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6812

This hadith has been narrated on the authority of Abn Huraira through another chain of transmitters with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6813]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6813

Abu Huraira reported: We were in the company of Allah's Messenger (may peace be upon him) that we heard a terrible sound. Thereupon Allah's Apostle (may peace be upon him) said: Do you know what (sound) is this? We said: Allah and His Messenger know best. Thereupon he said: That is a stone which was thrown seventy years before in Hell and it has'been constantly slipping down and now it has reached its base.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6814]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6814

This hadith has been narrated on the authority of Abfi Huraira with the same chain of transmitters but with this change of wording that the Holy Prophet (may. peace be upon him) said: It reached at its base and you heard its sound.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6815]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6815

Samura b. Jundub reported Allah's Apostle (may peace -be upon him) as saying: There will be some to whose ankels the fire will reach, some to whose knees, some to whose waist the fire will reach, and some to whose collar-bone the fire will reach.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6816]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6816

Samura b. Jundub reported Allah's Messenger (may peace be upon him) as saying: There would be among them those to whom the fire will reach up to their ankels and to some of them the fire would reach their knees and to some it would reach their waists and to some it would reach up to their collar-bones.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6817]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6817

This hadith has been narrated on the authority of Sa'id with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6818]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6818

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: There was a dispute between the Hell and the Paradise and it (the Hell) said: The haughty and the proud would find abode in me. And the Paradise said: The meek and the humble would find their abode in me. Thereupon Allah, the Exalted and Glorious, (addressing the Hell) said: You are (the means) of My punishment by which I punish those of My servants whom I wish. (And addressing the Paradise) He said: You are only My Mercy by means of which 1 shall show mercy to those whom I wish, but each one of you would be full.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6819]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6819

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: The Hell and the Paradise fell into dispute and the Hell said: I have been dis- tinguished by the proud and the haughty. And the Paradise said: What is the matter with me that the meek and the humble amongst people and the downtrodden and the simple enter me? Thereupon Allah said to the Paradise: You are (the means) of My Mercy whereby I show mercy to those of My servants whom 1 wish, and He said to the Hell: You are (the means) of punishment whereby 1 punish those of My servants whoml wish. Both of you will be full. The Hell will riot be filled up until Allah puts down His foot in it. The Hell would say: Enough, enough, enough, and at that time it will be filled up, all its parts integrated together.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6820]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6820

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: The Paradise and the Hell disputed with each other. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6821]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6821

Hammam b. Munabbih reported that Abu Huraira narrated to them some ahadith of Allah's Messenger (may peace be upon him) and one of them is this that Allah's Messenger (may peace be upon him) said: The Paradise and the Hell fell into dispute and the Hell said: 1 have been distinguished for accommodating (the haughty and proud in me), and the Paradise said: What is the matter that the meek and the humble and the downtrodden and simple would find an abode in me? Thereupon Allah said to Paradise: You are a (means) of My Mercy. 1 shall show mercy through you to one whom I will from amongst My servants. And lie said to the Hell: You are a (sign) of My chastisement and I shall chastise through you anyone whom I will from amongst My servants and both of you, would be full. And as regards the Hell it would not be full until Allah, the Exalted and Glorious, places His foot therein, and it would say: Enough, enough, enough, and it would be then full and the one part would draw very close to the other one and Allah would not treat unjustly anyone amongst His creation and He would create another creation for the Paradise (to accommodate it).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6822]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6822

Abu Sa'id al-Khudri reported that Allah's Messenger (may peace be upon him) said: The Paradise and the Hell disputed with each other. The rest of the hadith is the same as transmitted by Abu Huraira up to the words'." It is essential for Me to fill up both of you."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6823]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6823

Anas b. Malik reported that Allah's Apostle (may peace be upon him) said that the Hell would continue to say: Is there anything more, until Allah, the Exalted and High, would place His foot therein and that would say: Enough, enough, by Your Honour, and some parts of it would draw close to the other.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6824]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6824

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6825]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6825

'Abd al-Wahhab b. Ata' reported in connection with the words of Allah, the Exalted and the Glorious: We would say to Hell on the Day of Ressurection: Have you been completely filled up? and it would say: Is there anything -more? And he stated on the authority of Anas b. Malik that Allah's Apostle (may peace be upon him) said: (The sinners) would be thrown therein and it would continue to say: Is there anything more, until Allah, the Exalted and Glorious, would keep His foot there- in and some of its part would draw close to the other and it would say: Enough, enough, by Thy Honour and by Thy Dignity, and there would be enough space in Paradise until Allah would create a new creation and He would make them accommo- date that spare place in Paradise.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6826]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6826

Anas reported Allah's Apostle (may peace be upon him) as saying: There would be left some space in Paradise as Allah would like that to be left. Then Allah would create another creation as He would like.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6827]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6827

Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: Death would be brought on the Day of Resurrection. in the form of a white-coloured ram. Abu Kuraib made this addition: Then it would be made to stand between the Paradise and the Hell. So far as the rest of the hadith is concerned there is perfect agreement (between the two narrators) and it would be said to the inmates of Paradise: Do you recognise this? They would raise up their necks and look towards it and say: Yes, ' it is death. Then it would be said to the inmates of Hell-Fire.. Do you recognise this? And they would raise up their necks and look and say: Yes, it is death. Then command would be given for slaughtering that and then it would be said: 0 inmates of Paradise,, there is an everlasting life for you and no death. And then (addressing) to the inmates of the Hell-Fire, it would be said: 0 inmates of Hell-Fire, there is an everlasting living for you and no death. Allah's Messenger (may peace be u@on him) then recited this verse pointing with his hand to this (material) world:" Warn them, this Day of dismay, and when their affairs would be decided and they would be un- mindful and they believe not" (xix. 39).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6828]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6828

Abu Sa'id reported Allah's Messenger (may peace be upon him) as saying: When the inmates of Paradise would be admitted to Paradise and the inmates of Hell would be admitted to Hell, it would be said (to the inmates of Paradise): 0 inmates of Paradise. The rest of the hadith is the same but with this variation (that he only) said. That is the word of Allah, the Exalted. And he did not say: Then Allah's Mes- senger (may peace be upon him) recited, and he did not make a mention of his having pointed with his hand towards the (material) world.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6829]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6829

Abdullah reported that Allah's Messenger (may peace be upon him) said: Allah would admit the inmates of Paradise into Paradise and the inmates of Hell into Hell. Then the announcer would stand between them and say: 0 inmates of Paradise, there is no death for you,0 inmates of Hell, there is no death for you. You would live for ever therein.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6830]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6830

Umar b. Muhammad b. Zaid b. 'Abdullah b. 'Umar b. al-Khattab reported on the authority of his father Abdullah b. Umar that Allah's Messenger (may peace big upon him) said: When the inmates of Paradise would go to Paradise and the inmates of Hell would go to Hell, death would be called and it would be placed between the Paradise and the Hell and then slaughtered and then the announcer would announce: 0 inmates of Paradise, no death 0 Inmates of Hell-Fire, no death. And it would in. crease the delight of the inmates of Paradise and it would increase the grief of the inmates of Hell-Fire.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6831]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6831

It is transmitted on the authority of Abu Huraira that Allah's Messenger (may peace be upon him) said: The molar tooth of an unbeliever or the canine teeth of an unbeliever will be like Ubud and the thickness of his skin a three night's journey.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6832]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6832

Abu Huraira reported directly from Allah's Messenger (may peace be upon him) that he said: The distance of the two shoulders of the non-believer in Hell will be a three-day journey for a swift rider.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6833]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6833

Haritha b. Wahb reported that he heard Allah's Apostle (may peace be upon him) as saying: May I not inform you about the inmates of Paradise? They said: Do this, of course. Thereupon Allah's Apostle (may peace be upon him) said: Every humble person who is considered to be humble if he were to adjure In the name of Allah, He would fulfil it. He then said: May I not inform you about the denizens of Hell-Fire? They said: Yes. And he said: Every haughty, fat and proud (person).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6834]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6834

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6835]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6835

Haritha b. Wahb al-KhuzaIi reported Allah's Messenger (may peace be upon him) as saying: May I not inform you about the inmates of Paradise? (And then informing about them) said: Every meek person who is considered to be humble and if they were to adjure in the name of Allah, Allah would certainly fulfil it. May I not inform you about the inmates of Hell-Fire? They are all proud, mean and haughty.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6836]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6836

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: Many a people with dishevelled hair are driven away from the door (but they are so pious) that if they are to swear in the name of Allah, He would definitely fulfil that.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6837]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6837

'Abdullah b. Zam'a reported that Allah's Messenger (may peace be upon him) delivered an address and he made a mention of the dromedary and also made a mention of one (base person) who cut off Its hind legs, and he recited:" When the basest of them broke forth with mischief" (xei. 12). When A mischievous person, strong even because of the strength of a family like Abu Zam'a, broke forth. He then delivered instruction in regard to the women saying: There is amongst you who beats his woman, and in the narration on the authority of Abu Bakr, the words are: He flogs her like a slave-girl. And in the narration of Abu Kuraib (the words are): He flogs like a slave and then comforts his bed with the help of that at the end of the day, and he then advised in regard to laughing of people at the breaking of wind and said: One of you laughs at that which you yourself do.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6838]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6838

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: I saw 'Amr b. Luhayy b. Qam'a b. Khindif, brother of Bani Ka'b, dragging his Intestines in Fire.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6839]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6839

Sa'id b. Musayyib explained" al-bahira" as that animal which is not milked but for the idols. and none amongst the people milks them, and" as-sa'iba" as that animal which is let loose for the deities. Nothing is loaded over it, and Ibn Musayyib narrated that Abu Huraira stated that Allah's Messenger (may peace be upon him) said: I saw 'Amr b. 'Amir al-Khuzili dragging his intestines in fire and he was the first who devoted animals to deity.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6840]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6840

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Two are the types amongst the denizens of Hell, the one possessing whips like the tail of an ox and they flog people with their help. (The second one) the women who would be naked in spite of their being dressed, who are seduced (to wrong paths) and seduce others with their hair high like humps. These women would not get into Paradise and they would not perceive the odour of Paradise, although its frag- rance can be perceived from such and such distance (from great distance).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6841]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6841

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you survive for a time you would certainly see people who would have whips in their hands like the tail of an ox. They would get up in the morning under the wrath of Allah and they would get into the evening with the anger of Allah.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6842]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6842

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: If you live for a time, you would certainly see people get up (in the morning) in the wrath of Allah and getting into the evening under the curse of Allah, and there would be in their hands (whips) like the tail of an ox.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6843]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6843

This hadith has been narrated through five different chains of transmitters and all of them are narrated on the authority of Mustaurid, brother of Bani Fihr, that Allah's Messenger (may peace be upon him) said: By Allah, this world (is so insigni- ficant in comparison) to the Hereafter that if one of you should dip his finger- (and wnile saying this Yahyg pointed with his forefinger) -in the ocean and then he should see as to what has stuck to it. This hadith has been narrated through another chain of transmitters also but with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6844]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6844

'A'isha reported that she beard Allah's Messenger (may peace be upon him) as saying: The people would be assembled on the Day of Resurrection barefooted, naked and uncircumcised. I said: Allah's Messenger, will the male and the female be together on the Day and would they be looking at one another? Upon this Allah's Messenger (may peace be upon him) said: 'A'isha, the matter would be too serious for them to look to one another.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6845]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6845

This hadith has been narrated on the authority of Hatim b. Abi Saghira with the same chain of transmitters and there is no mention of the word" uncircum- cised."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6846]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6846

Ibn Abbas reported that he heard Allah's Messenger (may peace be upon him) deliver an address and he was saying that they would meet Allah barefooted, naked and uncircumcised.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6847]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6847

This hadith has been narrated through other chains of transmitters on the authority of Ibn Abbas, (and) the words are: While Allah's Messenger (may peace be upon him) stood up to deliver a sermon, he said: 0 people, Allah would make you assemble barefooted, naked and uncircumcised (and then recited the words of the Qur'an):" As We created you for the first time, We shall repeat it. (It is) a promise (binding) upon us. Lo! We are to perform it, and the first person who would be clothed on the Day of Resurrection would be (Hadrat) Ibrahim (peace be upon him)" and, behold! some persons of my Ummah would be brought and taken to the left and I would say: My Lord, they are my companions, and it would be said: You do not know what they did after you, and I would say just as the pious servant (Hadrat 'Isa) said:, I was a witness regarding them as I remained among them and Thou art a witness over everything, so if Thou chastisest them, they are Thy servants and if Thou for- givest them, Thou art Mighty, Wise" (v. 117-118). And it would be said to him: They constantly turned to their heels since you left them. This hadith has been transmitted on the authority of Waki' and Mu'adh (and the words are):" What new things they fabricated."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6848]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6848

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying, The people will be assembled in three categories. Those desirous (of Paradise), fearing (Hell), coming two upon the came], three upon the camel, four upon the camel, ten upon the camel and the rest will be assembled, Hell-Fire being with them when they are at midday where they would spend the night and where they would spend the morning and where they would spend the evening.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6849]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6849

Ibn 'Umar reported Allah's Apostle (may peace be upon him) as saying: When the people would stand before Allah. the Lord of the worlds, each one of them would stand submerged into perspiration up to half of his ears, and there is no mention of the" day" in the badlth transmitted on the authority of Ibn Muthanni.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6850]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6850

This hadith has been transmitted on the authority of Ibn 'Umar but with a slight variation of wording (and the words are):" One of them would be completely submerged in perspiration up to half of his ears."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6851]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6851

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: The perspiration would spread on the Day of Resurrection upon the earth to the extent of seventy cubits and it would reach up to their mouths or up to their ears. Thaur is not sure (which words) he used (mouth or ears).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6852]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6852

Miqdad b. Aswad reported: I heard Allah's Messenger (may peace he upon him) as saying: On the Day of Resurrection, the sun would draw so close to the people that there woum be left only a distance of one mile. Sulaim b. Amir said: By Allah, I do not know whether he meant by" mile" the mile of the (material) earth or dn instrument used for applying collyrium to the eye. (The Holy Prophet is, however, reported to have said): The people would be submerged in perspiration according to their deeds, some up to their. knees, Some up to the waist and some would have the bridle of perspiration and, while saying this, Allah's Apostle (may peace be upon him) pointed his hand towards his mouth.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6853]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6853

'Iyad b. Him-ar reported that Allah's Messenger (may peace be upon him), while delivering a sermon one day, said: Behold, my Lord commanded me that I should teach you which you do not know and which He has taught me today. (He has instructed thus): The property which I have conferred upon them is lawful for them. I have created My servants as one having a natural inclination to the worship of Allah but it is Satan who turns them away from the right religion and he makes unlawful what has been declared lawful for them and he commands them to ascribe partnership with Re, although he has no justification for that. And verily, Allah looked towards the people of the world and He showed hatred for the Arabs and the non-Arabs, but with the exception of some remnants from the People of the Book. And He (further) said: I have sent thee (the Holy Prophet) in order to put you to test and put (those to test) through you. And I sent the Book to you which cannot be washed away by water, so that you may recite it while in the state of wakefulness or sleep. Verily, Allah commanded me to burn (kill) the Quraish. I said: My Lord, they would break my head (like the tearing) of bread, and Allah said: You turn them out as they turned you out, you fight against them and We shall help you in this, you should spend and you would be conferred upon. You send an army and I would send an army five times greater than that. Fight against those who disobey you along with those who obey you. The inmates of Paradise are three: One who wields authority and is just and fair, one who Is truthful and has been endowed with power to do good deeds. And the person who is merciful and kind hearted towards his relatives and to every pious Muslim, and one who does not stretch his hand in spite of having a large family to support. And He said: The inmates of Hell are five: the weak who lack power to (avoid evil), the (carefree) who pursue (everything irrespective of the fact that it is good or evil) and who do not have any care for their family or for their wealth. And those dishonest whose greed cannot be concealed even in the case of minor things. And the third. who betray you. morning and evening, in regard to your family and your property. He also made a mention of the miser and the liar and those who are in the habit of abusing people and using obscene and foul language. Abu Ghassan in his narration did not make mention of" Spend and there would be spent for you."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6854]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6854

This hadith has been narrated on the authority of Qatada with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6855]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6855

This hadith has been transmitted on the authority of 'Iyad b. Himar that Allah's Messenger (may peace be upon him) gave an address one day. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6856]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6856

Iyad. b. Himar reported tbat, while Allah's Messenger (may peace be upon him) was delivering an address, he stated that Allah commanded me The rest of the hadith is the same, and there is an addition in it:" Allah revealed to me that we should be humble amongst ourselves and none should show pride upon the others, And it does not behove one to do so, and He also said: There are among you people to follow not caring a bit for their family and property. Qatada said: Abu Abdullah, would this happen? Thereupon he said: Yes. By Allah, I found this in the days of ignorance that a person grazed the goat of a tribe and did not find anyone but their slave-girl (and he did not spare her) but committed adultery with her.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6857]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6857

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as say- ing: When any one of you dies, he is shown his seat (in the Hereafter) morning and evening; if he is amongst the inmates of Paradise (he is shown the seat) from amongst the inmates of Paradise and if he is one from amongst the denizens of Hell (he is shown the seat) from amongst the denizens of Hell, and it would be said to him: That is your seat until Allah raises you on the Day of Resurrection (and sends you to your proper seat).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6858]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6858

Ibn Umar reported that Allah's Apostle (may peace be upon him) said: When a person dies, he is shown his seat morning and evening. If he is one amongst the inmates of Paradise (he is shown his seat) in Paradise and if he is one amongst the denizens of Hell-Fire (he is shown his seat) in the Hell-Fire. Then it is said to him: That is your seat where you would be sent on the Day of Resurrection.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6859]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6859

Abu Sa'id al-Khudri reported: I did not hear this badith from Allah's Apostle (may peace be upon him) directly but it was Zaid b. Thibit who narrated it from him. As Allah's Apostle (may peace be upon him) was going along with us towards the dwellings of Bani an-Najjar, riding upon his pony, it shied and he was about to fall. He found four, five or six graves there. He said: Who amongst you knows about those lying in the graves? A person said: It is I. Thereupon he (the Holy Prophet) said: In what state did they die? He said: They died as polytheists. He said: These people are passing through the ordeal in the graves. If it were not the reason that you would stop burying (your dead) in the graves on listening to the torment in the grave which I am listening to, I would have certainly made you hear that. Then turning his face towards us, he said: Seek refuge with Allah from the torment of Hell. They said: We seek refuge with Allah from the torment of Hell. He said: Seek refuge with Allah from the torment of the grave. They said: We seek refuge with Allali from the torment of the grave. He said: Seek refuge with Allah from turmoil, its visible and invisible (aspects), and they said: We seek refuge with Allah from turmoil and its visible and invisible aspects and he said: Seek refuge with Allah from the turmoil of the Dajjal, and they said We seek refuge with Allah from the turmoil of the Dajjal.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6860]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6860

Anas reported Allah's Apostle (may peace be upon him) as saying: If you were not (to abandon) the burying of the dead (in the grave), I would have certainly supplicated Allah that He should make you listen the torment of the grave.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6861]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6861

This hadith has been narrated on the authority of Abu Ayyub through some other chains of transmitters (and the words are):" Allah's Messenger (may peace be upon him) went out after the sun had set and he heard some sound and said: It is the Jews who are being tormented in their graves.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6862]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6862

Anas b. Malik reported Allah's Apostle (may peace be upon him) having said: When the servant is placed in his grave and his companions retrace their steps arid he hears the noise of the footsteps, then two angels come to him and make him sit and say to him: What you have to say about this person (the Holy Prophet)? If he is d believer, lie would say: I bear testimony to the fact that he is a servant of Allali and His Messenger. Then it would be said to him: Look to your seat in the Hell- Fire, for Allah has substituted (the seat of yours) with a seat in Paradise. Allah's Messenger (may peace be upon him) said: He would be shown both the seats. Qatada said: It was mentioned to us that his grave (the grave of a believer) expands to seventy cubits and is full with verdure until the Day when they would be resurrected.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6863]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6863

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: When the dead body. is placed in the grave, he listens to the sound of the shoes (as his friends and relatives return after burying him).


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6864]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6864

Anas b. Malik reported that Allah's Apostle (may peace be upon him) said: When the servant is placed in his grave and his friends retrace their steps. The rest of the liadith is the same as transmitted by Qatada.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6865]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6865

Al-Bara' b. 'Azib reported Allah's Apostle (may peace be upon him) as saying: This verse:" Allah grants steadfastness to those who believe with firm word," was rereaied in connection with the torment of the grave. It would be said to him: Who is your Lord? And he would say: Allah is my Lord and Muhammad is my Apostle (may peace be upon him), and that is (what is implied) by the words of Allah, the Exalted:" Allah keeps steadfast those who believe with firm word in this world and in the Hereafter."


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6866]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6866

Al-Bara' b. 'Azib reported that this verse:" Allah keeps steadfast those who believe with firm word in th;s world and the Hereafter," was revealed in con- nection with the torment of the grave.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6867]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6867

Abu Huraira reported: When the soul of a believer would go out (of his body) it would be received bv two angels who would take it to the sky. Hammad (one of the narrators in the chain of transmitters) mentioned the swetness of its odour, (and further said) that the dwellers of the sky say: Here comes the pious soul from the side of the earth Let there be blessings of Allah upon the body in which it resides. And it is carried (by the angels) to its Lord, the Exalted and Glorious. He would say: Take it to its destined end. And if he is a nonbeliever and as it (the soul) leaves the body-Hammad made a mention of its foul smell and of its being cursed-the dwellers of the sky say: There comes a dirty soul from the side of the earth, and it would be said: Take it to its destined end. Abu Huraira reported that Allah's Messenger (may peace be upon him) put a thin cloth which was with him upon his nose while making a mention (of the foul smell) of the soul of a non-believer.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6868]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6868

Anas b. Malik reported: We were along with Umar between Mecca and Medina that we began to look for the new moon. And I was a man with sharp eye- sight, so I could see it, but none except me saw it. I began to say to 'Umar: Don't you see it? But he would not see it. Thereupon Umar said: I would soon be able to see it (when it will shine more brightly). I lay upon bed. He then made a mention of the people of Badr to us and said: Allah's Messenger (may peace be upon him) showed us one day before (the actual battle) the place of death of the people (participating) in (the Battle) of Badr and he was saying: This would be the place of death of so and so tomorrow, if Allah wills. Umar said: By Him Who sent him with truth, they did not miss the places (of their death) which Allah's Messenger (may peace be upon him) had pointed for them. Then they were all thrown in a well one after another. Allah's Messenger (may peace be upon him) then went to them and said: O, so and so, the son of so and so; O so and so, the son of so and so, have you found correct what Allah and His Messenger had promised you? I have, however, found absolutely true what Allah had promised with me. Umar said: Allah's Messenger, how are you talking with the bodies without soul in them. Thereupon he said: You cannot hear more distinctly than (their hearing) of what I say, but with this exception that they have not power to make any reply.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6869]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6869

Anas b. Malik reported that Allah's Messenger (may peace be upon him) let the dead bodies of the unbelievers who fought in Badr (lie unburied) for three days. He then came to them and sat by their side and called them and said: O Abu Jahl b. Hisham, O Umayya b. Khalaf, O Utba b. Rab'ila, O Shaiba b. Rabi'a, have you not found what your Lord had promised with you to be correct? As for me, I have found the promises of my Lord to be (perfectly) correct. Umar listened to the words of Allah's Apostle (may peace be upon him) and said: Allah's Messenger, how do they listen and respond to you? They are dead and their bodies have decayed. Thereupon he (the Holy Prophet) said: By Him in Whose Hand is my life, what I am saying to them, even you cannot hear more distinctly than they, but they lack the power to reply. Then'he commanded that they should be buried in the well of Badr.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6870]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6870

Aba Talha reported: When it was the Day of Badr and Allah's Apostle (may peace be upon him) had gained victory over them (the Meccans), he commanded more than twenty persons, and in another hadith these are counted as twenty-four persons, from the non-believers of the Quraish to be thrown into the well of Badr. The rest of the hadith is the same.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6871]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6871

'A'isha reported that Allah's Messenger (may peace be upon him) said: He who is taken to account on the Day of Resurrection is in fact put to torment. I said: Has Allah, the Exalted and Glorious, not said this: 'He will be made subject to an easy reckoning" (Ixxxiv. 8)? Thereupon he said: (What it implies) is not the actual reckoning, but only the presentation of one's deeds to Him. He who is thoroughly examined in reckoning is put to torment.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6872]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6872

This hadith has been narrated on the authority of Ayyub with the same chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6873]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6873

'A'isha reported Allah's Apostle (may peace be upon him) as saying: Everyone who is reckoned thoroughly is undone. I said: Allah's Messenger, has Allah not called (reckoning) as easy reckoning? Thereupon he said.. It implies only presenta- tion of (one's deeds to Him), but if one is thoroughly examined in reckoning, he in fact is undone.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6874]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6874

'A'isha reported Allah's Apostle (may peace be upon him) as saying: He who is examined thoroughly In reckoning is undone.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6875]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6875

Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying three days before his death: None of you should court death but only hoping good from Allah


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6876]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6876

This hadith has been narrated on the authority of A'mash with the same chain of transmitters.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6877]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6877

Jabir b. 'Abdullah al-Ansari reported: I heard Allah's Messenger (may peace be upon him) say three days before his death: None of you should die but hoping only good from Allah, the Exalted and Glorious.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6878]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6878

Jabir reported: I heard Allah's Apostle (may peace be upon him) as saying. Every servant would be raised (in the same very state) in which he dies.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6879]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6879

This hadith has been transmitted on the authority of A'mash but with a slight variation of wording.


Muslim :: The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha) :: [40.6880]

The Book Pertaining to Paradise, Its Description, Its Bounties and Its Intimates (Kitab Al-Jannat wa Sifat Na'imiha wa Ahliha)

Muslim :: Book 40 : Hadith 6880

Abdullah b. Umar reported: I heard Allah's Messenger (may peace be upon him) as saying: When Allah intends to chastise a people, He chastises all of them then they would be raised according to their deeds.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6881]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6881

Zainab bint Jahsh reported that Allah's Apostle (may peace be upon him) got up from sleep saying: There is no god but Allah; there is a destruction in store for Arabia because of turmoil which is at hand, the barrier of Gog and Magog has opened so much. And Sufyan made a sign of ten with the help of his hand (in order to indicate the width of the gap) and I said: Allah's Messenger, would we be perished in spite of the fact that there would be good people amongst us? Thereupon he said: Of course, but only when the evil predominates.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6882]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6882

This hadith has been narrated on the authority of Zainab bint Jahsh with a slight variation in the chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6883]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6883

Zainab bint Jahsh, the wife of Allah's Apostle (may peace be upon him), reported that one day Allah's Messenger (may peace be upon him) came out in a state of excitement with his face quite red. And he was saying: There is no god but Allah; there is a destruction in store for Arabia beciuse of the turmoil which is near at hand as the barrier of Gog and Magog has been opened like it, and he (in order to explain it) made a ring with the help o his thumb and forefinger. I said: Allah's Messenger, would we be destroyed despite the fact that there would be pious people amongst us? He said: Yes, when the evil would predominate.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6884]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6884

This hadith has been narrated oil the authority of Zuhri with a different chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6885]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6885

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: Today the wall (barrier) of Gog and Magog has been opened so much, and WUhaib (in order to explain it) made the figure of ninety with the help of his hand.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6886]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6886

Harith b Abi Rabi'a and 'Abdullah b. Safwan both went to Umm Salama, the Mother of the Faithful, and they asked her about the army which would be sunk in the earth, and this relates to the time when Ibn Zubair (was the governor of Mecca). She reported that Allah's Messenger (may peace be upon him) had said that a seeker of refuge would seek refuge in the Sacred House and an army would be sent to him (in order to kill him) and when it would enter a plain ground, it would be made to sink. I said: Allah's Messenger, what about him who would be made to accompany this army willy nilly? Thereupon he said: He would be made to sink along with them buf he would be raised on the Day of Resurrection on the basis of his intention. Abu Ja'far said. ' This plain, ground means the plain ground of Medina.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6887]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6887

This hadith has been narrated on the authority of 'Abdullah b. Rufai, with the same chain of transmitters (but with the addition of these words):" When I met Abu Ja'far I told him that she (simply) meant the plain ground. Thereupon Abu Ja'far said: No, by God, she meant the plain ground of Medina.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6888]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6888

Abdullah b. Safwan reported that Hafsa told him that she had heard Allah's Apostle (may peace be upon him) as saying: An army would attack this House in order to fight against the inhabitants of this House and when it would be at the plain ground the ranks in the centre of the army would be sunk and the vanguard would call the rear flanks of the army and they would also be sunk and no flank would be left except some people who would go to inform them (their kith and kin). A person (who had been listening to this badith from Abdullah b. Safwan) said: I bear testimony in regard to you that you are not imputing a lie to Hafsa. And I bear testimony to the fact that Hafsa is not telling a lie about Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6889]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6889

Abdullah b. Safwan reported the Mother of the Faithful as saying that Allah's Messenger (may peace be upon him) said: They would soon seek protection in this House, viz. Ka'ba (the defenceless), people who would have nothing to protect themselves in the shape of weapons or the strength of the people. An army would be sent to fight (and kill) them and when they would enter a plain ground the army would be sunk in it. Yiisuf (one of the narrators) said: It was a people of Syria (hordes of Hajjaj) who had been on that day comin. towards Mecca for an attack (on 'Abdulllah b. Zubair) and Abdullah b. Safwan said: By God, it does not imply this army.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6890]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6890

'A'isha reported that Allah's Messenger (may peace be upon him) was startled in the state of sleep. We said: Allah's Messenger, you have done something in the state of your sleep which you never did before, Thereupon he said: Strange it is that some, people of my Ummah would attack the House (Ka'ba) (for killing) a person who would belong to the tribe of the Quraish and he would try to seek protection in the House. And when they would reach the plain ground they would be sunk. We said: Allah's Messenger, all sorts of people throng the path. Thereupon he said: Yes, there would be amongst them people who would come with definite designs and those who would come under duress and there would be travellers also, but they would all be destroyed through one (stroke) of destruction. though they would be raised in different states (on the Day of Resurrection). Allah would, however, raise them according to their intention.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6891]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6891

Usama reported that Allah's Messenger (may peace be upon him) climbed up a battlement amongst the battlements of Medina and then said: You do not see what I am seeing and I am seeing the places of turmoil between your houses as tile places of rainfall.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6892]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6892

This hadith has been narrated on the authority of Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6893]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6893

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: There will be soon a period of turmoil in which the one who sits will be better than one who stands and the one who stands will be better than one who walks and the one who walks will be better than one who runs. He who would watch them will be drawn by them. So he who finds a refuge or shelter against it should make it as his resort.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6894]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6894

This hadith has been transmitted on the authority of Abu Huraira but with this variation of wording that in the hadith transmitted on the authority of Abu Bakr, there is an addition of these words:" There is a prayer among prayers ('Asr) and one who misses it is as if his family and property have been ruined."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6895]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6895

Abu Huraira reported Allah's Apostle (may peace be upon him) as saying: There would be turmoil and the one who would sleep would be better than who would be awake and the one who would be awake would be better than one who would stand and one who would stand would be better than one who would run. So he who finds refuge or shelter should take that refuge or shelter.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6896]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6896

Abu Bakra reported Allah's Messenger (may peace be upon him) as saying: There would soon be turmoil. Behold! there would be turmoil in which the one who would be seated would be better than one who would stand and the one who would stand would be better than one who would run. Behold! when the turmoil comes or it appears, the one who has camel should stick to his camel and he who has sheep or goat should stick to his sheep and goat and he who has land should stick to the land. A person said: 'Allah's Messenger, what is your opinion about one who has neither camel nor sheep nor land? Thereupon, he said: He should take hold of his sword and beat its edge with the help of stone and then try to find a way of escape. O Allah, I have conveyed (Thy Message) ; O Allah, I have conveyed (Thy Message) ; O Allah, I have conveyed (Thy Message). A person said: Allah's Messenger, what is your opinion it I am drawn to a rank in spite of myself, or in one of the groups and made to march and a man strikes with his sword or there comes an arrow and kills me? Thereupon he said: He will bear the punishment of his sin and that of yours and he would be one amongst the denizens of Hell.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6897]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6897

This hadith has been transmitted on the authority of Waki' with a slight variation of wording.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6898]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6898

Ahnaf b. Qais reported: I set out with the intention of helping this person (Hadrat 'Ali) that Abu Bakra met me. He said: Ahnaf, where do you intend to go? I said: I intend to help the cousin of Allah's Messenger (may peace be upon him), viz. 'Ali. Thereupon he said to me: Ahnaf, go back, for I heard Allah's Messenger (may peace be upon him) as saying: When two Muslims confront one another with swords (in hands) both the slayer and the slain would be in Fire. He (Ahnaf) said: I said, or it was said: Allah's Messenger, it may be the case of one who kills. but what about the slain (why he would be put in Hell-Fire)? Thereupon he said: He also intended to kill his companion.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6899]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6899

Ahnaf b. Qais reported on the authority of Abu Bakra that Allah's Messenger (may peace be upon him) said: When two Muslims confront each other with their swords, both the slayer and the slain are doomed to Hell-Fire.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6900]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6900

This hadith has been narrated on the authority of Hammad through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6901]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6901

Abu Bakra reported Allah's Messenger (may peace be upon him) as saying: When two Muslims (confront each other) and the one amongst them attacks his brother with a weapon, both of them are at the brink of Hell-Fire. And when one of them kills his companion, both of them get into Hell-Fire.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6902]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6902

Abu Huraira reported Allah's Messenger (may peace be upon him) many ahadith and one of them was this: The last Hour will not come until the two parties (of Muslims) confront each other and there is a large-scale massacre amongst them and the claim of both of them is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6903]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6903

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The last Hour will not come unless there is much bloodshed. They said: What is harj? Thereupon he said: Bloodshed. bloodshed.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6904]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6904

Thauban reported that Allah's Messenger (may peace be upon him) said: Allah drew the ends of the world near one another for my sake. And I have seen its eastern and western ends. And the dominion of my Unimah would reach those ends which have been drawn near me and I have been granted the red and the white trea- sure and I begged my Lord for my Ummah that it should not be destroyed because of famine, nor be dominated by an enemy who is not amongst them to take their lives and destroy them root and branch, and my Lord said: Muhammad, whenever I make a decision, there is none to change it. Well, I grant you for your Ummah that it would not be destroyed by famine and it would not be dominated by an enemy who would not be amongst it and would take their lives and destroy them root and branch even if all the people from the different parts of the world join hands together (for this purpose), but it would be from amongst them, viz. your Ummah, that some people would kill the others or imprison the others.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6905]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6905

Thauban reported that Allah's Messenger (may peace be upon him) said. Verily, Allah drew the ends of the world near me until I saw its cast and west an He bestowed upon me two treasures, the red and the white. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6906]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6906

'Amir b. Sa'd reported on the authority of his father that one day Allah's Messenger (may peace be upon him) came from a high, land. He passed by the mosque of Banu Mu'awiya, went in and observed two rak'ahs there and we also observed prayer along with him and he made a long supplication to his Lord. He then came to us and said: I asked my Lord three things and He has granted me two but has withheld one. I begged my Lord that my Ummah should not be destroyed because of famine and He granted me this. And I begged my Lord that my Ummah should not be destroyed by drowning (by deluge) and He granted me this. And I begged my Lord that there should be no bloodshed among the people of my Ummah. but He did not grant it.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6907]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6907

Amir b. Sa'd reported on the authority of his father that Allah's Messenger (may peace be upon him) came with a group of his Companions and he passed by the mosque of Banu Mu'awiya. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6908]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6908

Hudhaifa b. al-Yaman reported: By Allah, I have the best knowledge amongst people about every turmoil which is going to appear in the period intervening me and the Last Hour; and it is not for the fact that Allah's Messenger (may peace be upon him) told me something confidentially pertaining to it and he did not tell anybody else about it, but it is because of the fact that I was present in the assembly in which he had been describing the turmoil. and he especially made a mention of three turmoils which would not spare anything and amongst these there would be turmoils like storms in the hot season. Some of them would be violent and some of them would be comparatively mild. Hudhaifa said: All (who were present) except I have gone (to the next world).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6909]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6909

Hudhaifa reported that Allah's Messenger (may peace be upon him) stood before us one day and he did not leave anything unsaid (that he had to say) at that very spot which would happen (in the shape of turmoil) up to the Last Hour. Those who had to remember them preserved them in their minds and those who could not remember them forgot them. My friends knew them and there are certain things which slip out of my mind, but I recapitulate them when anyone makes a mention of them just as a person is lost from one's mind but is recalled to him on seeing his face.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6910]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6910

This hadith has been narrated on the authority of A'mash with the same chain of transmitters up to the words: And he forgot who had to forget that and. he did not make a mention of what follows after this.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6911]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6911

Hudhaifa reported: Allah's Messenger (may peace be upon him) informed me of what is going to happen before the approach of the Last Hour. And there is nothing that I did not ask him in this connection except this that I did not ask him as to what would turn the people of Medina out from Medina.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6912]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6912

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6913]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6913

Abu Zaid (viz. Amr b. Akhtab) reported: Allah's Messenger (may peace be upon him) led us in the dawn prayer and then mounted the pulpit and addressed us until it was (time for the) noon prayer. He then came down the pulpit and observed prayer and then again mounted the pulpit and again addressed us until it was time for the 'Asr prayer. He then again came down and observed the prayer and again mointed the pulpit and addressed us until the sun was set and he informed (about) everything (pertaining to turmoil) that lay hidden in the past and what lies in (the womb) of) the future and the most learned amongst us is one who remembers them well


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6914]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6914

Hudhaifa repotted: We were one day in the company of 'Umar that he said: Who amongst you has preserved in his mind most perfectly the hadith of Allah's Messenger (may peace be upon him) in regard to the turmoil as he told about it? I said: It is I. Thereupon he said: You are bold (enough to make this claim). And he further said: How? I said: I heard Allah's Messenger (may peace be upon him) as saying: There would (first) be turmoil for a person in regard to his family, his property, his own self, his children, his neighbours (and the sins comnaitted in their connection) would be expiated by fasting, prayer, charity, enjoining good and prohibiting evil. Thereupon 'Umar said: I do not mean (that turmoil on a small scale) but that one which would eme-ge like the mounting waves of the ocean. I said: Commander of the Faithful, you have nothing to do with it, for the door is closed between you and that. He said: Would that door be broken or opened? I said: No, it would be broken. Thereupon he said: Then it would not be closed despite best efforts. We said to Hudhaifa: Did Umar know the door? Thereupon he said: Yes, he knew it (for certain) just as one knows that night precede the next day. And I narrated to him something in which there was nothing fabricated. Shaqiq (one of the narrators) said: We dared not ask Hudhaifa about that door. So we requested Masrdq to ask him. So he asked him and he said: (By that door, he meant) 'Umar.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6915]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6915

This hadith has been narrated on the authority of Hudhaifa through other chains of transmitters also.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6916]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6916

Hudhaifa reported that Umar said: Who would narrate to us (the ahadith pertaining to turmoil) and he reported a badith similar to these ahadith.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6917]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6917

Jundub reported: I came on the day of Jara'a that a person was (found) sitting. I said: They would shed their blood today. That person said: By Allah. not at all. I said: By Allah, of course, they would do it. He said: By Allah, they would not do it. I said: By Allah, of course, they would do it. He said: By Allah, they would not do it, and I have heard a hadith of Allah's Messenger (may peace be upon him) which I am narrating to you in this connection. I said: You are a bad seat fellow. I have been opposing you since morning and you are listening to me in spite of the fact that you have heard a hadith from Allah's Apostle (may peace be upon him) (contrary to ray statement). I myself felt that there was no use of this annoyance. (He could tell me earlier that it was a hadith of the Holy Prophet (may peace be upon him], and I would not have opposed him at all.) I turned my face toward him and asked him and he was Hadrat Hudhaifa.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6918]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6918

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come before the Euphrates uncovers a mountain of gold, for which people would fight. Ninety-nine out of each one hundred would die but every man amongst them would say that perhaps he would be the one who would be saved (and thus possess this gold).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6919]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6919

This hadith has been narrated on the authority of Suhail with the same chain of transmitters but with this addition:" My father said: If you see that, do not even go near it."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6920]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6920

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come unless the Euphrates would uncover a treasure of gold, so he who finds it should not take anything out of that.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6921]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6921

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Euphrates would soon uncover a mountain of gold but he who is present there should not take anything from that.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6922]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6922

'Abdullah b. Harith b. Naufal reported: I was standing along with Ubayy b. Ka, b and he said: The opinions of the people differ in regard to the achievement of worldly ends. I said: Yes, of course. Thereupon he said: I heard Allah's Messenger (may peace be upon him) as saying: The Euphrates would soon uncover a mountain of gold and when the people would bear of it they would flock towards it but the people who would possess that (treasure) (would say): If we allow these persons to take out of it they would take away the whole of it. So they would fight and ninety-nine out of one hundred would be killed. Abu Kamil in his narration said: I and Abu Ka'b stood under the shade of the battlement of Hassan.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6923]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6923

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Iraq would withhold its dirhams and qafiz; Syria would withhold its mudd and dinar and Egypt would withhold its irdab and dinar and you would recoil to that position from where you started and you would recoil to that position from where you started and you would recoil to that position from where you started, the bones and the flesh of Abu Huraira would bear testimony to it.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6924]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6924

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the Romans would land at al-A'maq or in Dabiq. An army consisting of the best (soldiers) of the people of the earth at that time will come from Medina (to counteract them). When they will arrange themselves in ranks, the Romans would say: Do not stand between us and those (Muslims) who took prisoners from amongst us. Let us fight with them; and the Muslims would say: Nay, by Allah, we would never get aside from you and from our brethren that you may fight them. They will then fight and a third (part) of the army would run away, whom Allah will never forgive. A third (part of the army). which would be constituted of excellent martyrs in Allah's eye, would be killed ani the third who would never be put to trial would win and they would be conquerors of Constantinople. And as they would be busy in distributing the spoils of war (amongst themselves) after hanging their swords by the olive trees, the Satan would cry: The Dajjal has taken your place among your family. They would then come out, but it would be of no avail. And when they would come to Syria, he would come out while they would be still preparing themselves for battle drawing up the ranks. Certainly, the time of prayer shall come and then Jesus (peace be upon him) son of Mary would descend and would lead them in prayer. When the enemy of Allah would see him, it would (disappear) just as the salt dissolves itself in water and if he (Jesus) were not to confront them at all, even then it would dissolve completely, but Allah would kill them by his hand and he would show them their blood on his lance (the lance of Jesus Christ).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6925]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6925

Mustaurid al-Qurashi reported: I heard Allah's Messenger (may peace be upon him) as saying: The Last Hour would come (when) the Romans would form a majority amongst people. 'Amr said to him (Mustaurid Qurashi): See what you are saying? He said: I say what I heard from Allah's Messenger (may peace be upon him). Thereupon he said: If you say that, it is a fact for they have four qualities. They have the patience to undergo a trial and immediately restore themselves to sanity after trouble and attack again after flight. They (have the quality) of being good to the destitute and the orphans, to the weak and, fifthly, the good quality in them is that they put resistance against the oppression of kings.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6926]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6926

Mustaurid Qurashi reported: I heard Allah's Messenger (may peace be upon him) as saying: The Last Hour would come when the Romans would form a majority amongst people. This reached 'Amr b. al-'As and he said: What are these ahadith which are being transmitted from you and which you claim to have heard from Allah's Messenger (may peace be upon him)? Mustaurid said to him: I stated only that which I heard from Allah's Messenger (may peace be upon him). Thereupon 'Amr said: If you state this (it is true), for they have the power of tolerance amongst people at the time of turmoil and restore themselves to sanity after trouble, and are good amongst people so far as the destitute and the weak are concerned.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6927]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6927

Yusair b. Jabir reported: Once there blew a red storm in Kufah that there came a person who had nothing to say but (these words): Abdullah b. Mas'ud, the Last Hour has come. He ('Abdullah b. Mas'ud) was sitting reclining against something, and he said: The Last Hour would not come until the people divide in- heritance and rejoice over booty, and then said pointing towards Syria, with the gesture of his hand like this: The enemy shall muster strength against Muslims and the Muslims will muster strength against them (Syrians). I said: You mean Rome? And he said: Yes, and there would be a terrible fight and the Muslims would prepare a detachment (for fighting unto death) which would not return but victorious. They will fight until night will intervene them; both the sides will return without being victorious and both will be wiped out. The Muslims will again prepare a detachment for fighting unto death so that they may not return but victorious. When it would be the fourth day, a new detachment out of the remnant of the Muslims would be prepared and Allah will decree that the enemy should be routed. And they would fight such a fight the like of which would not be seen, so much so that even if a bird were to pass their flanks, it would fall down dead before reaching the end of them. (There would be such a largescale massacre) that when counting would be done, (only) one out of a hundred men related to one another would be found alive. So what can be the joy at the spoils of such war and what inheritance would be divided! They would be in this very state that they would hear of a calamity more horrible than this. And a cry would reach them: The Dajjil has taken your place among your off- spring. They will, therefore, throw away what would be in their hands and go forward sending ten horsemen, as a scouting party. Allah's Messenger (may peace be upon him) said: I know their names and the names of their forefathers and the colour of their horses. They will be best horsemen on the surface of the earth on that day or amongst the best horsemen on the surface of the earth on that day.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6928]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6928

Jabir reported: I was in the company of Ibn Mas'ud that there blew a red storm. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6929]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6929

Jabir reported: I was in the house of 'Abdullah b. Mas'ud and the house was fully packed that a red storm blew in Kufah.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6930]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6930

Nafi' b. Utba reported: We were with Allah's Messenger (may peace be upon him) in an expedition that there came a people to Allah's Apostle (may peace be upon him) from the direction of the west. They were dressed in woollen clothes and they stood near a hillock and they met him as Allah's Messenger (may peace be upon him) was sitting. I said to myself: Better go to them and stand between him and them that they may not attack him. Then I thought that perhaps there had been going on secret negotiation amongst them. I however, went to them and btood between them and him and I remember four of the words (on that occasion) which I repeat (on the fingers of my hand) that he (Allah's Messenger) said: You will attack Arabia and Allah will enable you to conquer it, then you would attack Persia and He would make you to Conquer it. Then you would attack Rome and AllgLh will enable you to conquer it, then you would attack the Dajjal and Allah will enable you to conquer him. Nafi' said: Jabir, we thought that the Dajjal would appear after Rome (Syrian territory) would be conquered.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6931]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6931

Hudhaifa b. Usaid Ghifari reported: Allah's Messenger (may peace be upon him) came to us all of a sudden as we were (busy in a discussion). He said: What do you discuss about? They (the Companions) said. We are discussing about the Last Hour. Thereupon he said: It will not cone until you see ten signs before and (in this connection) he made a mention of the smoke, Dajjal, the beast, the rising of the sun from the west, the descent of Jesus son of Mary (Allah be pleased with him), the Gog and Magog, and land-slidings in three places, one in the east, one in the west and one in Arabia at the end of which fire would burn forth from the Yemen, and would drive people to the place of their assembly.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6932]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6932

Hudhaifa b. Usaid reported: Allah's Apostle (may peace be upon him) was in an apartment and we were beneath that that he peeped in and said to us: What are you discussing about? We said: (We are discussing about the Last) Hour. Thereupon he said: The Last Hour would not come until the ten signs dppear: land-sliding in the east, and land-sliding in the west, and land-sliding in the peninsula of Arabia, the smoke, the Dajjal, the beast of the earth, Gog and Magog, the rising of the sun from the west and the fire which would emit from the lower part of 'Adan. Shu'ba said that 'Abd al-'Aziz b. Rufai' reported on the authority of Abu Tufail who reported on the authority of Abu Sariha a hadith like this that Allah's Apostle (may peace be upon him) did not make a mention of (the tenth sign) but he said that out of the ten one was the descent of Jesus Christ, son of Mary (peace be upon him), and in another version it is theb lowing of the violent gale which would drive the people to the ocean.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6933]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6933

Abu Sariha reported: Allah's Messenger (may peace be upon him) was in an (upper) apartment and we were standing lower to him and discussing (about the Last Hour). The rest of the hadith is the same, and Shu'ba said: I think he also said these words: The fire would descend along with them where they would land and where they would take rest (during midday (it would also cool down for a while). Shu'ba said: This hadith has been transmitted to me through Abu Tufail and Abu Sariha and none could trace it back directly to Allah's Apostle (may peace b.. upon him). However, there is a mention of the descent of Jesus Christ son of Mary in one version and in the other there is a mention of the blowing of a violent would drive them to the ocean.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6934]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6934

Abu Sariha reported: We were discussing the Last Hour) that Allah's Apostle (may peace be upon him) looked towards us. The rest of the hadith is the same and the tenth (sign) was the descent of Jesus Christ son of Mary, and Shu'ba said: 'Abd al-'Aziz did not trace it directly to Allah's Apostle (may peace be upon him).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6935]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6935

Abu Huraira reported that Allah's Messenger may peace be upon him) said: The Last Hour would not come until fire emits from the earth of Hijaz which would illuminate the necks of the camels of the Busra.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6936]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6936

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: (The Last Hour would not come) until the habitations of Medina would extend to Ihab or Yahab. Zubair said: I said to Suhail how far these were from Medina. He said: So and so miles.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6937]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6937

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The famine would not break otit because of drought, but there would be famine despite heavy rainfall as nothing would grow from the earth.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6938]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6938

Ibn 'Umar reported that he heard Allah's Messenger (may peace be upon him) as saying (in a state) that he had turned his face towards the east: Behold, turmoil would appear from this side, from where the horns of Satan would appear.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6939]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6939

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) stood by the door (of the apartment of) gafsa and, pointing towards the east, he said: The turmoil would appear from this side, viz. where the horns of Satan would appear, and he uttered these words twice or thrice and Ubaidullah b. Sa'ld in his narration said. The Messenger of Allah (may peace be upon him) had been standing by the door of 'A'isha.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6940]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6940

Salim b. Abdullah reported on the authority of his father that Allah's Messenger (may peace be upon him), while turning his face towards the east, said: The turmoil would appear from this side; verily, the turmoil would appear from this side; verily, the turmoil. would appear from this side-the side where appear the horns of Satan.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6941]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6941

Ibn Umar reported that Allah's Messenger (may peace be upon him) came out from the house of 'A'isha and said: It would be from this side that there would appear the height of unbelief, viz. where appear the horns of Satan. i. e. cast.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6942]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6942

Ibn Umar reported: I heard Allah's Messenger (may peace be upon him) as saying while pointing his hands towards the east: The turmoil would appear from this side; verily, the turmoil would appear from this side (he repeated it thrice) where appear the horns of Satan.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6943]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6943

Ibn Fudail reported on the authority of his father that he heard Salim b. 'Abdullah b. 'Umar as saying: O people of Iraq, how strange it is that you ask about the minor sins but commit major sins? I heard from my father 'Abdullah b. 'Umar, narrating that he heard Allah's Messenger (may peace be upon him) as saying while pointing his hand towards the east: Verily. the turmoil would come from this side, from where appear the horns of Satan and you would strike the necks of one another; and Moses killed a person from among the people of Pharaoh unintentionally and Allah, the Exalted and Glorious, said:" You killed a person but We relieved you from the grief and tried you with (many a) trial" (xx. 40). Ahmad b. Umar reported this hadith from Salim, but he did not make a mention of the words:" I heard".


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6944]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6944

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the women of the tribe of Daus would be seen going round Dhi al-Khalasa (for worship) and Dhi al-Khalasa is a place in Tabala, where there was a temple in which the people of the tribe of Daus used to worship the idol.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6945]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6945

'A'isha reported: I heard Allah's Messenger (may peace be upon him) as saying: The (system) of night and day would not end until the people have taken to the worship of Lat and 'Uzza. I said: Allah's Messenger, I think when Allah has revealed this verse:" He it is Who has sent His Messenger with right guidance, and true religion, so that He may cause it to prevail upon all religions, though the polytheists are averse (to it)" (ix. 33), it implies that (this promise) is going to be fulfilled. Thereupon he (Allah's Apostle) said: It would happen as Allah would like. Then Allah would send the sweet fragrant air by which everyone who has even a mustard grain of faith in Him would die and those only would survive who would have no goodness in them. And they would revert to the religion of their forefathers.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6946]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6946

This hadith has been narrated on the authority of Ibn Ja'far with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6947]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6947

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until a person would pass by a grave of another person and he would say: I wish it had been my abode.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6948]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6948

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him, in Whose hand is my life, the world would not come to an end until a person would pass by a grave, would roll over it and express the desire that he should be in the place of the occupant of that grave not because of religious reasons but because of this calamity.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6949]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6949

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: By Him in Whose Hand is my life, a time would come when the murderer would not know why he has committed the murder, and the victim would not know why he has been killed.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6950]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6950

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The world would not come to an end until a day would come to the people on which the murderer would not know as to why he has killed and the slain would not know as to why he has been murdered. It would be said: Why would It happen? To which he replied: It would be because of general massacre and bloodshed. And the slaughterers and the slain would be in Fire, and in the narration of Ibn Aban, the name of Abu Isma'il has been mentioned.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6951]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6951

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Ka'ba would be destroyed by an Abyssinian having two small shanks.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6952]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6952

(The above mentioned) hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6953]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6953

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: It would be an Abyssinian having two small shanks who would destroy the House ol Allah, the Exalted and Glorious.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6954]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6954

Abu Huraira reported Allah's Messengar (may peace be upon him) as saying: The Last Hour would not come before a person of Qahtan comes forth driving people with his stick.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6955]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6955

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The day and the night would not come to an end before a man called al-Jahjah would occupy the throne.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6956]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6956

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come unless you fight with people whose faces are like hammered shields and the Last Hour would not come until you would fight against those wearing the shoes of hair.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6957]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6957

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until a people wearing shoes of hair fight against you having their faces like hammered shields.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6958]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6958

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until you fight with a people wearing shoes of hair and the Last Hour would not come until you fight with a people having small eyes and broad snub noses.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6959]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6959

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until the Muslims fight with the Turks-a people whose faces would be like hammered shields wearing clothes of hair and walking (with shoes) of hair.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6960]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6960

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: You shall fight in the hours to come against a nation wearing shoes made of hair and faces like hammered shields, with red complexion and small eyes.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6961]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6961

Abu Nadra reported:" We were in the company of Jabir b. 'Abdulldh that he said it may happen that the people of Iraq may not send their qafiz and dirhams (their measures of food stuff and their money). We said: Who would be respolisible for it? He said: The non_Arabs would prevt them. He again said: There is the possibility that the people of Syria may not send their dinar and mudd. We said: Who would be responsible for it? He said This prevention would be made by the Romans. He (Jabir b. Abdullab) kept quiet for a while and then reported Allah', s Messengdt (may peas be upon him) having said There would be a caliph in the last (period) of my Ummah who would freely give handfuls of wealth to thd people wiothout counting it. I said to Abu Nadra and Abu al-'Ala: DO you mean 'Umarb. 'Abd al-Aziz? They said: No (he would be Imam Mahdi.).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6962]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6962

This hadith hab been narrated by Sa'id with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6963]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6963

Abu Sa'id reported that Allah's Messenger (may peace he upon him) I said: There would be amongest your caliphs a caliph who would give handfuls of wealth to the, but wbuld not count it. In. the narration transmitted on the authority of Ibn Hujr, there is a slight variation of wording.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6964]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6964

Abu Sa'id and Jabir b. Abdullah reported that Allah's Messenger (may peace be upon him) said: There would be in the last phase of the time a caliph who would distribute wealth but would not count.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6965]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6965

This hadith has been narrated on the authority of Abu Sa'id through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6966]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6966

Abu Sa'id Khudri reported: One who Is better than I informed me, that Allah's Messenger (may peace be upon him) said to 'Ammar as he was digging the ditch (on the ocasion of the Battle of the Ditch) wiping over his head: O son of Summayya you will be involved in trouble and a group of the rebels would kill you.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6967]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6967

This hadith has been transmitted on the same authority but with this variation that the hadith trarismitted on the authority of Nabra (the words are): One Who is better than I informed me, and he was Abu Qatatda, and in the hadith transmitted on the authority of Khalid instead of the word 'bu_us' there is 'dys' or 'yadis', i. e.:" how sad it is".


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6968]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6968

This hadith has been transmitted on the authority of Umm Salama that Allah's Messenger (may peace be upon him) said to 'Ammar: A group of rebels would kill you.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6969]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6969

This hadith has been narrated on the authority of Umm Salam through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6970]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6970

Unmm Salama reported that Allah's Messenger (may peace be upon him) said: A band of rebels would kill 'Ammar.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6971]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6971

Abu Huraira reported that Allah's Apostle (may peace be upon him) as saying: This tribe of the Quraish would kill (people) of wy Ummah. They (the Companions) said: What us to do (in such a situations)? Thereupon he said: Would that the people remain aside from them (and not besmear their hand with the blood of the Muslim).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6972]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6972

This hadith has been narrated on the authority of Shu'ba with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6973]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6973

Abu Huraira reported that Allh's Messenger (may peace be upon him) said: (Khusrau king of Persia) would die and Qaisar (Ceasar King of Rome) would die; there would be no Qaisar after him, but, by one in Whose Hand is my life, you would spend their treasures in the cause of Allah.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6974]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6974

This hadith has been transmitted on the authority of Zuhri.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6975]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6975

Hammam b. Munabbih reported: This is what Abu Huraira reported from Allah's messenger (may peace be upon him) and in this connection he reported so many hadith (and one of them was this): Allah's Messenger (may peace be upon him) said: Kisra would die and then there would be no Kisra after him. Qaisar would die and there would be no Qaisar after him, but you will distribute their threasuers in thecause of Allah.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6976]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6976

Jabir b. Samura reported that Allah's Messenger (may peace be upon him) said: When Kisra would die there would be no Kisra after him; the rest of the hadith is the same as Abu Huraira reported.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6977]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6977

Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) (as sayingt There would lie open for a group of Muslims, or for a group of believers, the treasures of the family of Kisra which would be in the whit (palace). In a version of Qutaiba there is definitely the word" Muslim".


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6978]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6978

Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) a hadith like this.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6979]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6979

Abu Huraira reported Allah's Apostle (may peace he upon him) saying: You have heard about a city the one side of which is in the land and the other is in the sea (Constantinople). They said: Allall's Messenger, yes. Thererupon he said: The Last Hour would not cmoe unlesss seventy thousand persons from Bani lsra'il would attack it. When they would land there, they will neither fight with weapons nor would shower arrows but would only say:" There is no god but Allah and Allah is the Greatest," that one side of it would fall. Thaur (one of the narrators) said: I think that he said: The part by the side of the ocean. Then they would say for the second time:" There is no god but Allah and Allah is the Greatest" that the second side would also fall, and they would say:" There is no god but Allah and Allah is the Greatest," that the gates would be opened for them and they would enter therein and, they would be collecting spoils of war and distributing them amongst themselves that a noise would be heard and It would be said: Verily, Dajjal has come. And thus they would leave everything there and would turn to him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6980]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6980

Thaur b. Zaid has narrated this hadith with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6981]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6981

Ibn 'Umar reported Allah's Messenger (may peace be upon him) as saying: You will fight against the Jews and you will kill them until even a stone would say: Come here, Muslim, there is a Jew (hiding himself behind me) ; kill him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6982]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6982

Ubaidullah has reported this hadith with this chain of transmitters (and the Words are):" There is a Jew behind me."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6983]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6983

Abdullah b. 'Umar reported Allah's Messenger (may peace be upon him) as saying: You and the Jews would fight against one another until a stone would say: Muslim, here is a Jew behind me; come and kill him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6984]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6984

Abdullah b. 'Umar reported that Allah's Messenger (may peace be upon him) said: The Jews will fight against you and you will gain victory over them until the stone would say: Muslim, here is a Jew behind me; kill him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6985]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6985

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The last hour would not come unless the Muslims will fight against the Jews and the Muslims would kill them until the Jews would hide themselves behind a stone or a tree and a stone or a tree would say: Muslim, or the servant of Allah, there is a Jew behind me; come and kill him; but the tree Gharqad would not say, for it is the tree of the Jews.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6986]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6986

Jabir b. Samura reported: I heard Allah's Messenger (may peace be upon him) as saying: Before the Last Hour there would be many liars, and there is an addition in the badith transmitted on the authority of Abu Ahwas of these words:" I said to him: Did you hear it from Allah's Messenger (may peace be upon him)? He said: Yes."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6987]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6987

This hadith has been narrated on the authority of Simak with the same chain of transmitters. and Simak said: I heard my brother say that jabir had stated: Be on your guard against them.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6988]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6988

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would not come until there would arise about thirty impostors, liars, and each one of them would claim that he is a messenger of Allah.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6989]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6989

This hadith has been transmitted on the authority of Abu Huraira with a slight variation of wording.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6990]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6990

'Abdullah reported: We were along with Allah's Messenger (may peace be upon him) that we happened to pass by children amongst whom there was Ibn Sayyad. The children made their way but Ibn Sayyad kept sitting there (and it seemed) as if Allah's Messenger (may peace be upon him) did not like it (his sitting with the children) and said to him: May your nose he besmeared with dust, don't you bear testimony to the fact that I am the Messenger of Allah? Thereupon he said: No, but you should bear testimony that I am the messenger of Allah. Thereupon 'Umar b. Khattab said: Allah's Messenger, permit me that I should kill him. Thereupon Allah's Messenger (may peace be upon him) said: If he is that person who is in your mind (Dajjal ), you will not be able to kill him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6991]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6991

'Abdullah reported: We were walking with Allah's Messenger (may peace be upon him) that Ibn Sayyad happened to pass by him. Allah's Messenger (may peace be upon him) said to him: I have concealed for you (something to test you, so tell me that). He said: It is Dukh. Thereupon Allah's Messenger (may peace be upon him) said to him: Be off. You cannot get farther than your rank, whereupon 'Umar said: Allah's Messenger, permit me to strike his neck. Thereupon Allah's Messenger (may peace be upon him) said: Leave him; if he is that one (Dajjal) whom you apprehend, you will not be able to kill him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6992]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6992

Abu Sa'id reported that Allah's Messenger (may peace be upon him) met him (Ibn Sayyad) and so did Abu Bakr and 'Umar on some of the roads of Medina. Allah's Messenger (may peace be upon him) said: Do you bear testimony to the fact that I am the Messenger of Allah? Thereupon he said: Do you bear testimony to the fact that I am the messenger of Allah? Thereupon Allah's Messenger (may peace be upon him) said: I affirm my faith in Allah and in His Angels and in His Books, and what do you see? He said: I see the throne over water. Whereupon Allah's Messenger (may peace be upon him) said: You see the throne of Iblis upon the water, and what else do you see? He said: I see two truthfuls and a liar or two liars and one truthful. Thereupon Allah's Messenger (may peace be upon him) said: Leave him He has been confounded.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6993]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6993

Jabir b 'Abdullah reported that Allah's Messenger (may peace be upon him) met Ibn Sa'id (Sayyad) and there were with him Abu Bakr and 'Umar and Ibn Sayyad was in the company of children. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6994]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6994

Abu Sa'id reported: I accompanied Ibn Sayyad to Mecca and he said to me: What I have gathered from people is that theu think that I am Dajjal. Have you not hearde Allah's Messenger (may peace upon him) as saying: He will have no no children, I said: Yes, of course. Thereupon he said: But I have children. Have you not heard Allah's Messenger (may peace be upon him) as saying: He would not enter Mecca and Medina? I said: Yes, of course. Thereupon he said I have been once in Medina and now I intend to go to Mecca. And he said to me at the end of his talk: By Allah: I know his place of birth his abode where he is just now. He (Abu Sa'id) said: This caused confusion in my mind (in regard to his identity).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6995]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6995

Abu Sa'id Khudri reported: Ibn Sa'id said to me somethhing for which I felt ashamed. He said: I can excuse others; but what has gone wrong with you, O Companions of Muhammad, that you take me as Dajjal? Has Allah's Apostle (may peace be upon him) not said that he would be a Jew whereas I am a Muslim and he also said that he would not have children, whereas I have children, and he also said: veryly, Allah has prohibited him to enter Mecca whereas I have performed Pilgrimage, atid. he went on saying this that I was about to be impressed by his tallk. He (however) said this also: I know where he (Dajjal) is and I know his father abd I mother, and it was said to him: Won't you feel pleased if you would be the same person? Thereupon he said: If this offer is made to me, I would noT resent that.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6996]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6996

Abu Sa'id Khudri reported: We came back after having pewrformed Pilgrimage or 'Umra and lbn Sa'id was along with us. And w, e encamped at a place and the people dispersed and I and he were left behind. I felt terribly frightend from him as it was said about him that he was the Dajjal. He brought his goods and placed them by my luggage and I said: It is intense heat. Would you not place that under that tree? And he did that. Then ther appeared before us a flock of sheep. He went and brought a cup of milk and said: Abu Sa'id, drink that. I said it is intense heat and the milk is also hot (whereas the fact was) that I did not like to drink from his hands or to opr to take it from his hand and he said: Abu Sa'id, I think that I should take a rope and suspend it by the tree and then coimmit sucide because of the talks of the people, and he furtlier said. Abu Sa'id he who is ingnoran of the saying of Allah's Messenger (may peace be upon him) (he is to be pardoned), but O people of Ansar, is this hadith of Allah's Messengern (may peace be upon him) concealed from you whereas you have the best konowledge of t this hadith of Allah's Messenger (may peace be upon him) amongst people? Did Allalt's Messenger (may peace be upon him) not say that he (Dajjal) would be a non believer whereas I am a believer? did Allah's Messenger (may peace be upon him) not say he would be barren and no child would be born to hirn, whereas I have left my children in Medina? Did Allh's Messenger (may peace upon him) not say: He would not get into Medina and Mecca whereas I have been coming from Medina and now I intend to go to Mecca? Abu Sa'id said: I was about to accept the excuse put forward by him. that he said: I know the place where he would be born and where he is now. So I said to him: May your whole dayb be spent


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6997]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6997

This hadith has transmitted on the authority of Abu Sa'id that Allah's Messenger (may peace be upon him) asked Ibn Sa'id about the earth of Paradise. Thereupon he said: Abu'l-Qasim, It is like a fine white musk, whereupon he (the Holy Prophet) said: 'You have told the the truth.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6998]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6998

Abu Sa'id reported that Ibn Sayyad asked Allah's Messenger (may peace be upon him) about the earth of Paradise. Whereupon he said: It is like white shining pure musk.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.6999]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 6999

'Muhammad b. Munkadir reported: As I saw Jabir b. 'Abdullah taking an oath in the name of Allah that it was Ibn Sa'id who was the Dajjal I said: Do you take an oath in the name of Allah? Thereupon he said: I heard 'Umar taking an oath in the presence of Allah's Apostle (may peace be upon him) to this effect but Allah's Apostle (may peace be upon him) did not disapprove of it.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7000]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7000

'Abdullah b. Umar reported: 'Umar b. Khattab went along with Allah's Messenger (may peace be upon him) in the company of some persons toIbn Sayyad that he found him playing with children near the bettlement of Bani Maghala and Ibn Sayyad was at that time just at the threshold of adolescence and he did not perceive (the presence of Holy Prophet) until Allah's Messenger (may peace be upon him) struck his back with his hands. Allah's Messenger (may peace be upon him) said: Ibn Sayyad, don't you bear witness that I am the messenger of Allah? Ibn Sayyad looked toward him and he said: I bear witness to the fact that you the messenger of the unlettered. Ibn Sayyad said to the Allah's Messenger (may peace be upon him): Do you bear witness to the fact that I am the messenger of Allah? Allah's Messenger (may peace be upon him) rejected this and said: I affirm my faith in Allah and in His messengers. Then Allah's Messenger (may peace be upon him) said to him: What do you see? Ibn Sayyad said: It us a Dukh. Thereupon Allah's Messenger (may peace be upon him) said: May you be disgraced and dishonoured, you would not not be able to go beyond your rank. 'Umar b. Khattab said: Allah's Messenger, permit me that I should strike his neck. Therupon Allah's Messenger (may peace be upon him) said: If he is the same (Dajjal) who would appear near the Last Hour, you would not be able to overpower him, and he is not that ther is no good for you to kill him. 'Abdullah b. 'Umar further narrated that after some time Allah's Messenger (may peace be upon him) and Ubayy b. Ka'b went towards the palm trees where Ibn Sayyad was. When Allah's Messenger (may peace be upon him) went near the tree he hid himself behind a tree with the intention of hearing something from Ibn sayyad before Ibn Sayyad could see him, but Allah's Messenger (may pcxce be upon him) saw him on a bed with a blanket around him from which a murmuring sound was being heard and Ibn Sayyad's mother saw Allah's Messenger (may peace be upon him) behind the trunk of the palm tree. She said to Ibn Sayyad: Saf (that being his name), here is Muhammad. Thereupon Ibn Sayyad jumped up murmuring and Allah's Messenger (may peace be upon him) said: If she had left him alone he would have made things clear. Abdullah b. Umar told that Allah's Messenger (may peace be upon him) stood up amongst the people and lauded Allah as He deserved, then he made a mention of the Dajjal and said: I warn you of him and there is no Prophet who has not warned his people against the Dajjal. Even Noah warned (against him) but I am going to tell you a thing which no Prophet told his people. You must know that he (the Dajjal) is one-eyed and Allah, the Exalted and Glorious, is not one-eyed. Ibn Shihab said: 'Umar b. Thabit al-Ansari informed me that some of the Companions of Allah's Messenger (may peace be upon him) informed him that the day when Allah's Messenger (may peace be upon him) warned people against the Dajjal, he also said: There would be written between his two eyes (the word) Kafir (infidel) and everyone who would resent his deeds would be able to read or every Muslim would be about to read, and he also said: Bear this thing in mind that none amongst you would be able to see Allah, the Exalted and Glorious, until he dies.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7001]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7001

Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) went along with him in the company of some persons and there was Umar b. Khattab also amongst them till they saw Ibn Sayyad as a young boy just on the threshold of adolescence playing with children near the battlement of Bani Mu'awiya; the rest of the hadith is the same but with these concluding words:" Had his mother left him (to murmur) his matter would have become clear."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7002]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7002

Ibn 'Umar reported that Allah's Messenger (may peace be upon him) happened to pass by Ibn Sayyad along with his Companions including 'Umar b. Khattab as he was playing with children near the battlement of Bani Maghala and he was also a child by that time. The rest of the hadith is the same as narrated by Ibn Umar (in which there is a mention of) setting out of Allah's Apostle (may peace be upon him) along with Ubayy b. Ka'b towards the date-palm trees.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7003]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7003

Nafi' reported that Ibn 'Umar met Ibn Si'id on some of the paths of Medina and he said to him a word which enraged him and he was so much swollen with anger that the way was blocked. Ibn 'Umar went to Hafsa and informed her about this. Thereupon she said: May Allah have mercy upon you, why did you incite Ibn Sayyad in spite of the fact that you knew it would be the extreme anger which would make Dajjal appear in the world?


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7004]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7004

Nafi' reported that Ibn 'Umar said: I met lbn Sayyad twice and said to some of them (his friends): You state that it was he (the Dajjal). He said: By Allah, it is not so. I said: You have not told me the truth; by Allah some of you informed me that he would not die until he would have the largest number of offspring and huge wealth and it is he about whom it is thought so. Then Ibn Sayyad talked to us. I then departed and met him again for the second time and his eye had been swollen. I said: What has happened to your eye? He said: I do not know. I said: This is in your head and you do not know about it? He said: If Allah so wills He can create it (eye) in your staff. He then produced a sound like the braying of a donkey. Some of my companions thought that I had struck him with the staff as he was with me that the staff broke into pieces, but, by Allah, I was not conscious of it. He then came to the Mother of the Faithful (Hafsa) and narrated it to her and she said: What concern you have with him? Don't you know that Allah's Apostle (may peace be upon him) said that the first thing (by the incitement of which) he would come out before the public would be his anger?


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7005]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7005

Ibn Umar reported that Allah's Messenger (may peace be upon him). made a mention of Dajjil in the presence of the people and said: Allah is not one-eyed and behold that Dajjal is blind of the right eye and his eye would be like a floating grape.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7006]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7006

This hadith has been narrated on the authority of Ibn 'Umar through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7007]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7007

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There is never a prophet who has not warned the Ummah of that one-eyed liar; behold he is one-eyed and your Lord is not one-eyed. On his forehead are the letters k f. r. (Kafir).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7008]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7008

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There would be written three letters k. f. r., i. e. Kafir, between the eyes of the Dajjal.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7009]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7009

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: Dajjal is blind of one eye and there is written between his eyes the word" Kafir". He then spelled the word as k. f. r., which every Muslim would be able to read.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7010]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7010

Hudhalfa reported that Allah's Messenger (may peace be upon him) said: Dajjal is blind of left eye with thick hair and there would be a garden and fire with him and his fire would be a garden and his garden would be fire.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7011]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7011

Hudhaifa reported Allah's Messenger (may peace be upon him) as saying: the Dajjal would have with him water and fire and his fire would bays the effect of cold water and his water would have the effect of fire, so don't put yourself to ruin. Abu Mas'ud reported: I also heard it from Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7012]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7012

'Uqba b. 'Amr Abu Mas'ud al-Ansari reported: I went to Hudhaifa b. Yaman and said to him: Narrate what you have heard from Allah's Messenger (may peace be upon him) pertaining to the Dajjal. He said that the Dajjal would appear and there would be along with him water ant fire and what the people would see as water that would be fire and that would burn and what would appear as fire that would be water and any one of you who would see that should plunge in that which he sees as fire for it would be sweet, pure water, and 'Uqba said: I also heard it, testifying Hudhaifa.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7013]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7013

Hudhaifa and Ibn Mas'ud met together. Hudhaifa said: I know more than you as to what there would be along with the Dajjal. There would be along with him two canals (one flowing with water) and the other one (having) fire (within it), and what you would see as fire would be water and what you would see as water would be fire. So he who amongst you is able to see that and is desirous of water should drink out of that which he sees as fire.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7014]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7014

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: May I not inform you about the Dajjal what no Apostle of Allah narrated to his people? He would be blind and he would bring along with him an Image of Paradise and Hell-Fire and what he would call as Paradise that would be Hell-Fire and I warn you as Noah warned his people.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7015]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7015

An-Nawwas b. Sam'an reported that Allah's Messenger (may peace be upon him) made a mention of the Dajjal one day in the morning. He sometimes described him to be insignificant and sometimes described (his turmoil) as very significant rand we felt) as if he were in the cluster of the date-palm trees. When we went to him (to the Holy Prophet) in the evening and he read (the signs of fear) in our faces, he said: What is the matter with you? We said: Allah's Messenger, you made a mention of the Dajjal in the morning (sometimes describing him) to be insignificant and sometimes very important, until we began to think as if he were present in some (near) part of the cluster of the datpalm trees. Thereupon he said: I harbour fear in regard to you in so many other things besides the Dajjal. If he comes forth while I am among on, I shall contend with him on your behalf, but if he comes forth while I am not amongst you, a man must contend on his own behalf and Allah would take care of every Muslim on my behalf (and safeguard him against his evil). He (Dajjal) would be a young man with twisted, contracted hair, and a blind eye. I compare him to 'Abd-ul-'Uzza b. Qatan. He who amongst you would survive to see him should recite over him the opening verses of Sura Kahf (xviii.). He would appear on the way between Syria and Iraq and would spread mischief right and left. O servant of Allah! adhere (to the path of Truth). We said: Allah's Messenger, how long would he stay on the earth? He said.. For forty days, one day like a year and one day like a month and one day like a week and the rest of the days would be like your days. We said: Allah's Messenger, would one day's prayer suffice for the prayers of day equal to one year? Thereupon he said: No, but you must make an estimate of time (and then observe prayer). We said: Allah's Messenger, how quickly would he walk upon the earth? Thereupon he said: Like cloud driven by the wind. He would come to the people and invite them (to a wrong religion) and they would affirm their faith in him and respond to him. He would then give command to the sky and there would be rainfall upon the earth and it would grow crops. Then in the evening, their posturing animals would come to them with their humps very high and their udders full of milk and their flanks stretched. He would then come to another people and invite them. But they would reject him and he would go away from them and there would be drought for them and nothing would be lef t with them in the form of wealth.

He would then walk through the waste, land and say to it: Bring forth your treasures, and the treasures would come out and collect (themselves) before him like the swarm of bees. He would then call a person brimming with youth and strike him with the sword and cut him into two pieces and (make these pieces lie at a distance which is generally) between the archer and his target. He would then call (that young man) and he will come forward laughing with his face gleaming (with happiness) and it would at this very time that Allah would send Christ, son of Mary, and he will descend at the white minaret in the eastern side of Damscus wearing two garments lightly dyed with saffron and placing his hands on the wings of two Angels. When he would lower his head, there would fall beads of perspiration from his head, and when he would raise it up, beads like pearls would scatter from it. Every non-believer who would smell the odour of his self would die and his breath would reach as far as he would be able to see. He would then search for him (Dajjal) until he would catch hold of him at the gate of Ludd and would kill him. Then a people whom Allah had protected would come to Jesus, son of Mary, and he would wipe their faces and would inform them of their ranks in Paradise and it would be under such conditions that Allah would reveal to Jesus these words: I have brought forth from amongst My servants such people against whom none would be able to fight; you take these people safely to Tur, and then Allah would send Gog and Magog and they would swarm down from every slope. The first of them would pass the lake of Tibering and drink out of it. And when the last of them would pass, he would say: There was once water there. Jesus and his companions would then be besieged here (at Tur, and they would be so much hard pressed) that the head of the ox would be dearer to them than one hundred dinirs and Allah's Apostle, Jesus, and his companions would supplicate Allah, Who would send to them insects (which would attack their necks) and in the morning they would perish like one single person. Allah's Apostle, Jesus, and his companions would then come down to the earth and they would not find in the earth as much space as a single span which is not filled with their putrefaction and stench. Allah's Apostle, Jesus, and his companions would then again beseech Allah, Who would send birds whose necks would be like those of bactrin camels and they would carry them and throw them where God would will.

Then Allah would send rain which no house of clay or (the tent of) camels' hairs would keep out and it would wash away the earth until it could appear to be a mirror. Then the earth would be told to bring forth its fruit and restore its blessing and, as a result thereof, there would grow (such a big) pomegranate that a group of persons would be able to eat that, and seek shelter under its skin and milch cow would give so much milk that a whole party would be able to drink it. And the milch camel would give such (a large quantity of) milk that the whole tribe would be able to drink out of that and the milch sheep would give so much milk that the whole family would be able to drink out of that and at that time Allah would send a pleasant wind which would soothe (people) even under their armpits, and would take the life of every Muslim and only the wicked would survive who would commit adultery like asses and the Last Hour would come to them.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7016]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7016

This hadith has been narrated on the authority of Jabir with the same chain of transmitters but with this addition that Gog and Magog would walk until they would reach the mountain of al-Khamar and it is a mountain of Bait-ul-Maqdis and they would say: We have killed those who are upon the earth. Let us now kill those who are In the sky and they would throw their arrows towards the sky and the arrows would return to them besmeared with blood. And in the narration of Ibn Hujr (the words are):" I have sent such persons (Gog and Magog) that none would dare fight against them.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7017]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7017

Abu Sa'id al-Khudri reported that Allah's Messenger (may peace be upon him) one day gave a detailed account of the Dajjal and in that it was also included: He would come but would not be allowed to ether the mountain passes to Medina. So he will alight at some of the barren tracts near Medina, and a person who would be the best of men or one from amongst the best of men would say to him: I bear testimony to the fact that you are Dajjal about whom Allah's Messenger (may peace be upon him) had informed us. The Dajjal would say: What is your opinion if I kill this (person), then I bring him back to life; even then will you harbour doubt in this matter? They would say: No. He would then kill (the man) and then bring him back to life. When he would bring tha@ person to life, he would say: By Allah, I had no better proof of the fact (that you are a Dajjal) than at the present time (that you are actually so). The Dajjal would then make an attempt to kill him (again) but he would not be able to do that. Abu Ishaq reported that it was said: That person would be Khadir (Allah be pleased with him).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7018]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7018

This hadith has been narrated by Zuhri with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7019]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7019

Abu Sa'id al-Khudri reported Allah's Messenger (may peace be upon him) as saying: The Dajjal would come forth and a person from amongst the believers would go towards him and the armed men of the Dajjal would meet him and they would say to him: Where do you intend to go? He would say: I intend to go to this one who is coming forth. They would say to him: Don't you believe in our Lord? He would say: There is nothing hidden about our Lord. They would say: Kill him. Then some amongst them would say: Has your master (Dajjal) not forbidden you to kill anyone without (his consent)? And so they would take him to the Dajjal and when the believer would see him, he would say: O people. he is the Dajjil about whom Allah's Messenger (may peace be upon him) has informed (us). The Dajjal would then order for breaking his head and utter (these words): Catch hold of him and break his head. He would be struck even on his back and on his stomach. Then the Dajjal would ask him: Don't you believe in me? He would say: You are a false Masih. He would then order him to be torn (into pieces) with a saw from the parting of his hair up to his legs. After that the Dajjal would walk between the two pieces. He would then say to him: Stand, and he would stand erect. He would then say to him: Don't you believe in me? And the person would say: It has only added to my insight concerning you (that you are really the Dajjal). He would then say: O people, he would not behave with anyone amongst people (in such a manner) after me. The Dajjal would try to catch hold of him so that he should kill him (again). The space between his neck and collar bone would be turned into copper and he would find no means to kill him. So he would catch hold of him by his hand and feet and throw him (into the air) and the people would think as if he had been thrown in the Hell-Fire whereas he would be thrown in Paradise. Thereupon Allah's Messenger (may peace be upon him) said: He would be the most eminent amongst persons in regard to martyrdom in the eye of the Lord of the world.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7020]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7020

Mughira b. Shu'ba reported: No one asked Allah's Messenger (may peace be upon him) more about Dajjil than I asked him. He said: He should not be a source of worry to you for he would not be able to do any harm to you. I said: Allah's Messenger, it is alleged that he would have along with him (abundance of) food and water. Thereupon he said: He would be very insignificant in the eye of Allah (even) with all this.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7021]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7021

Mughira b. Shu'ba reported that none asked Allah's Apostle (may peace be upon him) about Dajjal more than I asked him. I (one of the narrators other than Mughlra b. Shu'ba) said: What'did you ask? Mughira replied: I said that the people alleged that he would have a mountain load of bread and mutton and rivers of water. Thereupon he said: He would be more insignificant in the eye of Allah compared with all this.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7022]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7022

This hadith has been narrated on the authority of Isma'il through other chains of transmitters with a slight variation of wording.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7023]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7023

'Abdullah b. 'Amr reported that a person came to him and said: What is this hadith that you narrate that the Last Hour would come at such and such time? Thereupon he said: Hallowed be Allah, there is no god but Allah (or the words to the same effect). I have decided that I would not narrate anything to anyone now. I had only said that you would see after some time an important event that the (sacred) House (Ka'ba) would be burnt and it would happen and definitely happen. He then reported that Allah's Messenger (may peace be upon him) said: The Dajjal would appear in my Ummah and he would stay (in the world) for forty-I cannot say whether he meant forty days, forty months or forty years. And Allah would then send Jesus son of Mary who would resemble 'Urwa b Mas'ud. He (Jesus Christ) would chase him and kill him. Then people would live for seven years that there would be no ran. cour between two persons. Then Allah would send cold wind from the side of Syria that none would survive upon the earth having a speck of good in him or faith in him but he would die, so much so that even if some amongst you were to enter the innermost part of the mountain, this wind would reach that place also and that would cause his heath. I heard Allah's Messenger (may peace be upon him) as saying: Only the wicked people would survive and they would be as careless as birds with the charactertistics of beasts. They would never appreciate the good nor condemn evil. Then the Satan would come to them in human form and would say: Don't you respond? And they would say: What do you order us? And he would command them to worship the idols but, in spite of this, they would have abundance of sustenance and lead comfortable lives. Then the trumpet would be blown and no one would hear that but he would bend hfs neck to one side and raise it from the other side and the first one to hear that trumpet would be the person who would be busy in setting right the tank meant for providing water to the camels. He would swoon and the other people would also swoon, then Allah would send or He would cause to send rain which would be like dew and there would grow out of it the bodies of the people. Then the second trumpet would be blown and they would stand up and begin to look (around). Then it would be said: O people, go to your Lord, and make them stand there. And they would be questioned. Then it would be said: Bring out a group (out of them) for the Hell-Fire. And then it would be asked: How much? It would be said: Nine hundred and ninty-nine out of one thousand for the Hell-Fire and that would be the day which would make the children old because of its terror and that would be the day about which it has been said:" On the day when the shank would be uncovered" (lxviii. 42).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7024]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7024

Ya'qub b. 'Asim b. Urwa b. Mas'ud reported: I heard a person saying to 'Abdullah b. Amr: You say that the Last Hour would come at such and such time, whereupon he said: I had made up my mind that I would not narrate anything to you. I only said: But you would soon see after some time a very significant affair, for example the burning of the House (Ka'ba). Shu'ba said like this and 'Abdullah b Amr reported Allah's Messenger (may peace be upon him) having said: The Dajjal would appear in my Ummah. And in another hadith (the words are): None would survive who would have even a speck of faith in his heart, but he would be dead. Muhammad b. ja'far reported that Shu'ba narrated to him this hadith many a time and I also read it out to him many a time.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7025]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7025

Abdullah b. 'Amr reported: I committed to memory a hadith from Allah's Messenger (may peace be upon him) and I did not forget it after I had heard Allah's Messenger (may peace be upon him) as saying: The first sign (nut of the signs of the appearance of the Dajjal) would be the appearance of the sun from the west, the appearance of the beast before the people in the forenoon and whkch of the two hap- pens first, the second one would follow immediately after that.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7026]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7026

Abu Zur'a reported that three persons amongst Muslims had been sitting in Medina in the presence of Marwan b. Hakam and they heard him narrate these signs from him and the first amongst them was the appearance of the Dajjal. 'Abdullah b. 'Amr reported that Marwin said nothing (particular in this connection). I, however, heard a hadith from Allah's Messenger (may peace be upon him) and I did not forget that after I had heard that from Allah's Apostle (may peace be upon him) and he reported a hadith like the foregoing.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7027]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7027

Abu Zur'a reported that there was a discussion in the presence of Marwan about the Last Hour, and Abdullah b. 'Amr said: I heard Allah's Messenger (may peace be upon him) as saying. The rest of the hadith is the same, but there is no mention of forenoon.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7028]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7028

Amir b. Sharahil Sha'bi Sha'b Hamdan reported that he asked Fatima, daughter of Qais and sister of ad-Dahhak b. Qais and she was the first amongst the emigrant women: Narrate to me a hadith which you had heard directly from Allah's Messenger (may peace be upon him) and there is no extra link in between them. She said: Very well, if you like, I am prepared to do that, and he said to her: Well, do It and narrate that to me. She said: I married the son of Mughira and he was a chosen young man of Quraish at that time, but he fell as a martyr in the first Jihad (fighting) on the side of Allah's Messenger (may peace be upon him). When I became a widow, 'Abd al-Rahman b. Auf, one amongst the group of the Companions of Allah's Messenger (may peace be upon him), sent me the proposal of marriage. Allah's Messenger (may peace be upon him) also sent me such a message for his freed slave Usama b. Zaid. And it had been conveyed to me that Allah's Messenger (way peace be upon him) had said (about Usama): He who loves me should also love Usima. When Allah's Messenger (may peace be upon him) talked to me (about this matter), I said: My affairs are in your hand. You may marry me to anyone whom you like. He said: You better shift now to the house of Umm Sharik, and Umm Sharik was a rich lady from amongst the Anqir. She spent generously for the cause of Allah and entertained guests very hospitably. I said: Well, I will do as you like. He said: Do not do that for Umm Sharik is a woman who is very frequently vizited by guests and I do not like that your head may be uncovered or the cloth may be removed from your shank and the strangers may catch sight of them which you abhor. You better shift to the house of your cousin 'Abdullah b. 'Amr b. Umm Maktum and he is a person of the Bani Fihr branch of the Quraish, and he belonged to that tribe (to which Fatima) belonged. So I shifted to that house, and when my period of waiting was over, I heard the voice of an announcer making an announcement that the prayer would be observed in the mosque (where) congregational prayer (is observed).

So I set out towards that mosque and observed prayer along with Allah's Messenger (may peace be upon him) and I was in the row of the women which was near the row of men. When Allah's Messenger (may peace be upon him) had finished his prayer, he sat on the pulpit smiling and said: Every worshipper should keep sitting at his place. He then said: Do you know why I had asked you to assemble? They said: Allah and His Messenger know best. He said: By Allah. I have not made you assemble for exhortation or for a warning, but I have detained you here, for Tamim Dari, a Christian, who came and accepted Islam, told me something, which agrees with what I was-telling, yuu about the Dajjal. He narrated to me that he had sailed in a ship along with thirty men of Bani Lakhm and Bani Judham and had been tossed by waves in the ocean for a month. Then these (waves) took them (near) the land within the ocean (island) at the time of sunset. They sat in a small side-boat and entered that Island. There was a beast with long thick hair (and because of these) they could not distinguish his face from his back. They said: Woe to you, who can you be? Thereupon it said: I am al-Jassasa. They said: What is al-Jassasa? And it said: O people, go to this person in the monastery as he is very much eager to know about you. He (the narrator) said: When it named a person for us we were afraid of it lest it should be a Devil. Then we hurriedly went on till we came to that monastery and found a well-built person there with his hands tied to his neck and having iron shackles between his two legs up to the ankles. We said: Woe be upon thee, who are you? And he said: You would soon come to know about me. but tell me who are you. We said: We are people from Arabia and we embarked upon a boat but the sea-waves had been driving us for one month and they brought as near this island. We got Into the side-boats and entered this island and here a beast met us with profusely thick hair and because of the thickness of his hair his face could not be distinguished from his back. We said: Woe be to thee, who are you? It said: I am al- Jassasa. We said: What is al-Jassasa? And it said: You go to this very person in the monastery for he is eagerly waiting for you to know about you. So we came to you in hot haste fearing that that might be the Devil. He (that chained person) said: Tell me about the date-palm trees of Baisan. We &aid: About what aspect of theirs do you seek information? He said: I ask you whether these trees bear fruit or not.

We said: Yes Thereupon he said: I think these would not bear fruits. He said: Inform me about the lake of Tabariyya? We said: Which aspect of it do you want to know? He said: Is there water in it? They said: There is abundance of water in it. Thereupon he said: I think it would soon become dry. He again said: Inform me about the spring of Zughar. They said: Which aspect of it you want to know? He (the chained person) said: Is there water in it and does it irrigate (the land)? We said to him: Yes, there is abundance of water in it and the inhabitants (of Medina) irrigate (land) with the help of it, He said: Inform me about the unlettered Prophet; what has he done? We said: He has come out from Mecca and has settled In Yathrib (Medina). He said: Do the Arabs fight against him? We said: Yes. He said: How did he deal with him? We informed him that he had overcome those in his neighbourhood and they had submitted themselves before him. Thereupon he said to us: Had it actually happened? We said: Yes. Thereupon he said: If it is so that is better for them that they should show obedience to him. I am going to tell you about. myself and I am Dajjal and would be soon permitted to get out and so I shall get out and travel in the land, and will not spare any town where I would not stay for forty nights except Mecca and Medina as these two (places) are prohibited (areas) for me and I would not make an attempt to enter any one of these two. An angel with a sword in his hand would confront me and would bar my way and there would be angels to guard every passage leading to it; then Allah's Messenger (may peace be upon him) striking the pulpit with the help of the end of his staff said: This implies Taiba meaning Medina. Have I not, told you an account (of the Dajjal) like this? 'The people said: Yes, and this account narrated by Tamim Dari was liked by me for it corroborates the account which I gave to you in regard to him (Dajjal) at Medina and Mecca. Behold he (Dajjal) is in the Syrian sea (Mediterranian) or the Yemen sea (Arabian sea). Nay, on the contrary, he As In the east, he is in the east, he is in the east, and he pointed with his hand towards the east. I (Fatima bint Qais) said: I preserved It In my mind (this narration from Allah's Messenger (may peace be upon him).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7029]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7029

Al-Sha'bi reported: We visited Fatima b. Qais and she served us fresh dates which are called rutab and she also served us barley. I asked her about that woman in whose case three divorces had been pronounced as to how much time she should count as the waiting period. She said: My husband pronounced three divorces in my case and Allah's Messenger (may peace be upon him) permitted me to spend any waiting period in my family. (It was during this period) that announcement was made for the people to observe prayer in the bigger Mosque. I went there along with people and I was in the front row meant for women and it was adjacent to the last row of men and I heard Allah's Messenger (may peace be upon him) deliver sermon sitting on the pulpit. He said: The cousin of Tamim (Dari) sailed in the ocean. The rest of the hadith is the same but with this addition:" (I see) as if I am looking to Allah's Apostle (may peace be upon him) pointing his rod towards the land (and saying): It is Taiba, i. e. Medina."


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7030]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7030

Tamim Dari came to Allah's Messenger (may peace be upon him) and informed Allah's Messenger (may peace be upon him) that he sailed in an ocean and his ship lost direction and thus landed at an island. They moved about in that land in search of water. There they saw a person who had been pulling his hair. The rest of the hadith is the same. And he (Dajjal) said: If I were to be permitted to set out I would have covered all the lands except Taiba. Then Allah's Messerger (may peace be upon him) brought (Tamim Dari) before the public and he narrated to them and said: That is Taiba and that is the Dajjal.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7031]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7031

Fatima b. Qais reported that Allah's Messenger (may peace be upon him) sat on the pulpit and said: O people, Tamim Dari has reported to me that some persons of his tribe sailed in the ocean in a boat and it capsised and then some of them travelled on one of the planks of the boat and they went to an island in the ocean. The rest of the hadith is the same.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7032]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7032

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: There will be no land which would not be covered by the Dajjal but Mecca and Medina, and there would no passage out of the passages leading to them which would not be guarded by angels arranged in rows. Then he (the Dajjal) would appear in a barren place adjacent to Medina and it would rock three times that every unbeliever and hypocrite would get out of it towards him.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7033]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7033

This hadith has been transmitted on the authority of Anas that Allah's Messenger (may peace be upon him) said this but with this addition that (the Dajjal would come) and pitch his tent in the waste-land of Juruf and thus there would come out of (the city) every hypocrite, man and woman.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7034]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7034

Anas b. Malik reported that Allah's Messenger (may peace be upon him) said: The Dajjal would be followed by seventy thousand Jews of Isfahan wearing Persian shawls.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7035]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7035

Umm Sharik reported: I heard Allah's Messenger (may peace be upon him) as saying: The people would run away from the Dajjal seeking shelter in the mountains. She said: Where would be the Arabs then in that day? He said: They would be small in number.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7036]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7036

This hadith has been narrated on the authority of Ibn Juraij with the same chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7037]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7037

Abu Qatada reported: We used to go to Imran b. Husain passing in front of Hisham b. 'Amir. He, one day, said: You pass by me (in order) to go to some per- sons but (amongst ttie living persons) none remained in the company of Allah's Messenger (may peace be upon him) more than I and none knows more ahadith than I. I heard Allah's Messenger (may peace be upon him) as saying: There would be no creation (creating more trouble) than the Dajjal right from the creation of Adam to the Last Hour.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7038]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7038

This hadith has been transmitted on the authority of 'Imran b. Husain with a slight variation of wording.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7039]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7039

Abu Huraira reported Allah's Messenger (may peace be upon him) having said: Hasten to do good deeds before six things happen: the rising of the sun from the west, the smoke, the Dajjal, the beast and (the death) of one of you or the general turmoil.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7040]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7040

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Hasten in performing these good deeds (before these) six things (happen): (the appearance) of tribe Dijjal, the smoke, the beast of the earth, the rising of the sun from the west, the general turmoil (leadina to large-scale massacre) and death of masses and individuals.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7041]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7041

This hadith has been narrated on the authority of Qatada through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7042]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7042

Ma'qil b. Yasar reported Allah's Apostle (may peace be upon him) as saying: Worshiping during the period of widespread turmoil is like emigration towards me.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7043]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7043

Abdullah reported Allah's Apostle (may peace be upon him) as saying: The Last Hour would affect (most terribly) the wicked persons.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7044]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7044

This hadith has been reported by Sahl b. Sa'd that he heard Allah's Messenger (may peace be upon him) as saying: I and the Last Hour are (close to each other) like this (and he, in order to explain it) pointed (by joining his) forefinger, (one) next to the thumb and the middle finger (together).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7045]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7045

Anas b. Malik reported that Allah's Messenger (way peace be upon him) said: I and the Last Hour have been sent like this. Shu'ba said: I heard Qatada as saying in his narration: The excellence of one over the other. And I do not know whether he narrated it from Anas or Qatada himself said so.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7046]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7046

Shu'ba reported: I heard Qatada and Abu Tayyab narrating that both of them heard Anas as narrating that Allah's Messenger (may peace be upon him) said: I and the Last Hour have been sent like this, and Shu'ba drew his forefinger and middle finger near each other while narrating it.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7047]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7047

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7048]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7048

Anas reported Allah's Apostle (may peace be upon him) as saying like this, but he narrated it through another chain of transmitters.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7049]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7049

Anas reported Allah's Messenger (may peace be upon him) as saying: I and the Last Hour have been sent like this and (he while doing it) joined the forefinger with the middle finger.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7050]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7050

'A'isha reported that when the desert Arabs came to Allable Messenger (may peace be upon him) they asked about the Last Hour as to when that would come. And he looked towards the youngest amongst them and said: If he lives he would not grow very old that he would find your Last Hour coming to you the would see you dying).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7051]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7051

Anas reported that a person asked Allah's Messenger (may peace be upon him) as to when the Last Hour would come. He had in his presence a young boy of the Ansar who was called Mabammad. Allah's Messenger (may peace be upon bion) said: If this young boy lives. he may not grow very old till (he would see) the Last Hour coming to you.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7052]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7052

Anas b. Malik reported that a person asked Allah's Apostle (may peace be upon him): When would the Last Hour come? Thereupon Allah's Messenger (way peace be upon him) kept quiet for a while. then looked at a young boy in his presence belonging to the tribe of Azd Shanilwa and he said: If this boy lives he would not grow very old till the Last Hour would come to you. Anas said that this young boy was of our age daring those days.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7053]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7053

Anas reported: A young boy of Mughira b. Shu'ba happened to pass by (the Holy Prophet) and he was of my age Thereupon Allah's Apostle (may peace be apon him) said: If he lives long he would not grow very old till the Last Hour would come (to the old People of this generation).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7054]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7054

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The Last Hour would come (so sudden) that a person would be milking the she- camel and the (milk) would not reach the brim of the vessel that the Last Hour would come, and the two persons would be engaged in buying and selling of the clothes and their bargain would not be struck before the Last Hour would come. And someone would be setting his tank in order and he would have hardly set it right when the Last Hour would come.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7055]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7055

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Between the two blowiings of the trumpet (there would be an interval of forty). They said: Abu Huraira, do you mean forty days? He said: I cannot say anything. They said: Do you mean fortv months? He said: I cannot say anything They said: Do you mean forty years? He said: I cannot say anything. Then Allah would cause the water to, descend from the sky and they (people) will sprout like vegetable The only thing in a man which would not decay would be one bone (spinal chord) from which the whole frame would be reconstituted on the Day of Resurrection.


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7056]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7056

Abu Huraira reported Allah's Messenger (may peace be upon him) as say- ing: The earth would consume every son of Adam except his spinal chord from which his body would be reconstituted (on the Day of Resurrection).


Muslim :: The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah) :: [41.7057]

The Book Pertaining to the Turmoil and Portents of the Last Hour (Kitab Al-Fitan wa Ashrat As-Sa`ah)

Muslim :: Book 41 : Hadith 7057

Abu Huraira reported so many ahadith from Allah's Apostle (may peace be upon him) and amongst these one was this that Allah's Messenger (may peace be upon him) said: There is a bone in the human being which the earth would never consume and it is from this that new bodies would be reconstituted (on the Day of Resurrection). They said: Allah's Messenger, which bone is that? Thereupon he said: It is the spinal bone.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7058]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7058

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The world is a prison-house for a believer and Paradise for a non-believer.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7059]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7059

Jabir b. Abdullah reported that Allah's Apostle (may p (-ace be upon him) happened to walk through the bazar coming from the side of 'Aliya and the people were on both his sides. There he found a dead lamb with very short ears. He took hold of his ear and said: Who amongst you would like to have this for a dirham? They said: We do not like to have it even for less than that as it is of no use to us. He said: Do you wish to have it (free of any cost)? They said: By Allah, even if it were alive (we would not have liked to possess that), for there is detect in it as its ear is very short; now it is dead also. Thereupon Allah's Messenger (may peace be upon him) said: By Allah, this world is more insignificant in the eye of Allah as it (this dead lamb) is in your eye.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7060]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7060

Jabir reported Allah's Apostle (may peace be upon him) narrating a hadith like this with a slight variation of wording.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7061]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7061

Mutarrif reported on the authority of his father: I came to Allah's Apostle (may peace be upon him) as he was reciting:" Abundance diverts you" (cii. 1). He said: The son of Adam claims: My wealth, my wealth. And he (the Holy Prophet) said: O son of Adam. is there anything as your belonging except that which you consumed, which you utilised, or which you wore and then it was worn out or you gave as charity and sent it forward?


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7062]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7062

Mutarrif reported on the authority of his father: I went to Allah's Apostle (may peace be upon him). The rest of the hadith is the same.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7063]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7063

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: A servant says, My wealth. my wealth, but out of his wealth three things are only his: whatever he eats and makes use of or by means of which he dresses himself and it wears out or he gives as charity, and this is what he stored for himself (as a reward for the Hereafter), and what is beyond this (it is of no use to you) because you are to depart and leave it for other people. This hadith has been narrated on the authority of al-'Ala' b. 'Abd al-Rahman with the same chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7064]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7064

Anas b. Malik reported Allah's Messenger (way peace be upon him) as saying: Three things follow the bier of a dead man. two of them come back and one is left with him: the members of his family. wealth and his-good deeds. The members of his family and wealth come back and the deeds alone are left with him.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7065]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7065

'Amr b. 'Auf, who was an ally of Banu 'Amir b. Luwayy (and he was one amongst them) who participated in Badr along with Allah's Messenger (way peace be upon him). reported that, Allah's Messenger (may peace be upon him) sent Abu Ubaida b. Jarrah to Bahrain for collecting Jizya and Allah's Messenger (may peace be upon him) had made a truce with the people of Bahrain and had appointed 'Ala' b. Hadrami and Abu Ubaida (for this purpose). They came with wealth from Bahrain and the Ansar beard about the arrival of Abu Ubaida and they had observed the dawn prayer along with Allah's Messenger (may peace be upon him), and when Allah's Messenger (may peace be upon him) had finished the prayer they (the Ansar) came before him and Allah's Messenger (may peace be upon him) smiled as he saw them and then said: I think you have heard about the arrival of Abu Ubaida with goods from Bahrain. They said: Allah's Messenger. yes, it is so. Thereupon he said: Be happy and be hopeful of that what gives you delight. By Allah, it is not the poverty about which I fear in regard to you but I am afraid in your case that (the worldly) riches way be given to you as were given to those who had gone before you and you begin to vie with one another for them as they vied for them. and these may destroy you as these destroyed them.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7066]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7066

This hadith has been narrated on the authority of Zuhri as reported by Yunus with a slight variation of wording.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7067]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7067

'Abdullah b. 'Amr b. al-As reported that Allah's Messenger (may peace be upon him) said: How would you be,0 people. when Persia and Rome would be conquered for you? 'Abd at-Rahman b Auf said: We would say as Allah has commanded us and we would express our gratitude to Allah Thereupon Allah's Messenger (may peace be upon him) said: Nothing else besides it? You would (in fact) vie with one another, then you would feel jealous. then your relations would be estranged and then you will bear enmity against one another. or something to the same effect. Then you would go to the poor emigrants and would make some the masters of the others.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7068]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7068

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: When one of you looks at one who stands at a higher level than you in regard to wealth and physical structure he should also see one who stands at a lower level than you in regard to these things (in which he stands) at a hi-her level (as compared to him).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7069]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7069

This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7070]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7070

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: Look at those who stand at a lower level than you but don't look at those who stand at a higher level than you, for this would make the favours (conferred upon you by Allah) insignificant (in your eyes). Abu Mu'awiya said: Upon you.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7071]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7071

Abu Huraira, narrated that he beard Allah's Messenger (may peace be upon him) as saying: There were three persons in Bani Isra'il, one suffering from leprosy, the other bald-headed and the third one blind. Allah decided to test them. So He sent an angel who came to one who was suffering from leprosy and said: Which thing do you like most? He said: Beautiful colour and fine skin and removal of that which makes me detestable in the eye of people. He wiped him and his illness was no more and he was conferred upon beautiful colour and beautiful skin. He (the angel) again said: Which property do you like most? He said: Camels, or he said: The cow the narrator is, however, doubtful about it, but (out of the persons) suffering from leprosy or baldness one of them definitely said: The came]. And the other one said: Cow. And he (one who demanded came]) was bestowed upon a she-camel, in an advanced stage of pregnancy, and while giving he said: May Allah bless you in this I Then he came to the bald-headed person and said: Which thing do you like most? He said: Beautiful hair and that (this baldness) may be removed from me because of which people hate me He wiped his body and his illness was removed and he was bestowed upon beautiful hair, and the angel said: Which wealth do you like most? He said: The cow. And he was given a pregnant cow and while handing it over to him he (the angel) said: May Allah bless you in this I Then he came to the blind man and he said: Which thing do you like most? He said: Allah should restore my eyesight so that I should be able to see people with the help of that. He wiped his body and Allah restored to him his eyesight, and he (the angel) also said: Which wealth do you like most? He said. The flock of sheep. And he was given a pregnant goat and that gave birth to young ones and it so happened that one valley abounded in camels and the other one in goats and the third one in sheep. He then came to one suffering from leprosy in his (old) form and shape and he said: I am a poor person and my provision has run short in my journey and there is none to take me to my destination except with the help of Allah and your favour. I beg of you in His name Who gave you fine colour and fine skin, and the camel in the shape of wealth (to confer upon me) a camel which should carry me in my journey. He said: I have many responsibilities to discharge. Thereupon he said: I perceive as if I recognise you. Were you not suffering from leprosy whom people hated and you were a destitude and Allah conferred upon you (wealth) He said: I have inherited this property from my forefathers. Thereupon he said: If you are a liar may Allah change you to that very position in which you had been. He then came to the one who was bald-headed in his (old) form and said to him the same what he had said to him (one suffering from leprosy) and he gave him the same reply as he had given him and he said: If you 'are a liar, may Allah turn you to your previous position in which you had been. And then he came to the blind man in his (old) form and shape and he said: I am a destitute person and a wayfarer. My provision have ran short and today there is no way to reach the destination but with the help of Allah and then with your help and I beg of you in the (name) of One Who restored your eyesight and gave you the flock of sheep to give me a sheep by which I should be able to make my provisions for the journey. He said: I was blind and Allah restored to me my eyesight; you take whatever you like and leave whatever you like. By Allah. I shall not stand in your way today for what you take in the name of God. Thereupon, he said: You keep with you what you have (in your possession). The fact is that you three were put to test and Allah is well pleased with you and He is annoyed with your companions.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7072]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7072

It is reported on the authority of Amir b. Sa'd that Sa'd b. Abi Waqqas was in the fold of his camels that his son 'Umar came to him. When Sa'd saw him he said: I seek refuge with Allah from the mischief of this rider. And as he got down he said to him: You are busy with your camels and your sheep and you have abandoned people who are contending with one another for kingdom. Sa'd struck his chest and said: Keep quite. I heard Allah's Messenger (may peace be upon him) as saying: Allah loves the servant who is God-conscious and is free from want and is hidden (from the view of people).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7073]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7073

Sa'd b. Abu Waqqas is reported to have, said: By Allah, I am the first person amongst the Arabs to throw an arrow in the cause of Allah and we used to go with Allah's Messenger (may peace be upon him) and there was no food for us to eat but only the leaves of hubla and samur trees (they are wild trees) and as a result thereof one amongst us would relieve himself as does the goat. (How strange it is) that now the people of Banu Asad (the progeny of Zubair) instruct me in religion and try to impose punishment upon me (in regard to it). If it is so (that I am so ignorant of religion), then indeed, I am undone and my deeds have been lost. Ibn Numair, however, did not make a mention of the word (idhan) thus? (in his narration).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7074]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7074

This hadith has been narrated on the authority of Isma'il b. Khalid with the same chain of transmitters and the words are:" One amongst us would relieve himself as the goats do without anything mixing with its excrement."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7075]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7075

'Umair al-'Adawi reported: 'Utba b. Ghazwan delivered us a sermon and he praised Allah and lauded Him, then said: Now coming to the point, verily the world has been given the news of its end and that too quite early. Nothing would be left out of it but only water left in the utensil which its owner leaves, and you are going to shift to an abode which knows no end, and you should shift with the good before you, for we have been told that a stone would be thrown at one side of the Hell and it would go down even for seventy years but would not be able to reach its bottom. By Allah, it would be fully packed. Do you find it something strange, and it has been mentioned that there yawns a distance which one would be able to cover in forty years from one end to another of Paradise, and a day would come when it would be fully packed and you must be knowing that I was the seventh amongst seven who had been with Allah's Messenger (may peace be upon him) and we had nothing to eat but the leaves of the tree until the corners of the mouth were injured. We found a sheet which we tore in two and divided between myself and Sa'd b. Malik. I made the lower garment with halt of it and so did Sa'd make the lower garment with half of it and today there is none amongst us who has not become the governor of a city from amongst the cities (of the Islamic Commonwealth) and I seek refuge with Allah that I should consider myself great whereas I am insignificant in the eye of Allah. Prophethood does not remain for ever and its impact fades with the result that it changes eventually into kingship, and you would soon come to know and experience those rulers who would come after us and see (how far they are from religion).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7076]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7076

Khalid b. 'Umair reported and he had seen the pre-Islamic days also, that 'Uqba b. Ghazwan delivered this address and he was the governor of Basra. The rest of the hadith is the same as transmitted by Shaiban.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7077]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7077

Khalid b. Umair reported: I heard Uqba b. Ghazwan as saving: I found myself as the seventh amongst the seven who had been along with Allah's Messenger (may peace be upon him). We had nothing to eat but the leaves of hubla (a wild tree) until the corners of our mouths were injured.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7078]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7078

Abu Huraira reported that they (the Companions of the Holy Prophet) said: Allah's Messenger, will we be able to see our Lord on the Day of Judgment? He said: Do you feel any difficulty in seeing the sun in the noon when there is no cloud over it? They said: No. He again said: Do you feel any difficulty in seeing the moon on the fourteenth night when there is no cloud over it? They said: No. Thereupon he said: By Allah Who is One in Whose Hand is my life. you will not face any difficulty in seeing your Lord but only so much as you feel in seeing one of them. Then Allah would sit in judgment upon the servant and would say: O, so and so, did I not honour you and make you the chief and provide you the spouse and subdue for you horses, camels, and afforded you an opportunity to rule over your subjects? He would say: Yes. And then it would be said: Did you not think that you would meet Us? And he would say: No. Thereupon He (Allah) would say: Well, We forget you as you forgot Us. Then the second person would be brought for judgment. (And Allah would) say: 0, so and so. did We not honour you and make you the chief and make you pair and subdue for you horses and camels and afford you an opportunity to rule over your subjects? He would say: Yes, my Lord. And He (the Lord) would say: Did you not think that you would be meeting Us? And he would say: No. And then He (Allah) would say: Well, I forget you today as you forgot Us. Then the third -one would be brought and He (Allah) would say to him as He said before. And he (the third person) would say: O, my Lord, I affirmed my faith in Thee and in Thy Book and in Thy Messenger and I observed prayer and fasts and gave charity, and he would speak in good terms like this as he would be able to do. And He (Allah) would say: Well, We will bring our witnesses to you. And the man would think in his mind who would bear witness upon him and then his mouth would be sealed and it would be said to his thighs, to his flesh and to his bones to speak and his thighs. flesh and bones would bear witness to his deeds and it would be done so that he should not be able to make any excuse for himself and he would be a hypocrite and Allah would be annoyed with him.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7079]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7079

Anas b. Malik reported: We were in the company of Allah's Messenger (way peace be upon him) that he smiled and said: Do you know why I laughed? We said: Allah and His Messenger, know best. Thereupon he said: It was because of the (fact that there came to my mind the) talk which the servant would have with his Lord. (on the Day of judgment). He would say: My Lord, have you not guaranteed me protection against injustice? He would say: Yes. Then the servant would say: I do not deem valid any witness against me but my own self, and He would say: Well, enough would he the witness of your self against you and that of the two angels who had been appointed to record your deeds. Then the seal would be set upon his mouth and it would be said to his hands and feet to speak and they would speak of his deeds. Then the mouth would be made free to talk, he would say (to the bands and feet): Be away, let there be curse of Allah upon you. It was for your safety that I contended.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7080]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7080

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: O Allah, make for the family of Muhammad the provision which is a bare subsistence.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7081]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7081

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: 0 Allah, provide for the, family of Muhammad their subsistence, and in the narration transmitted on the authority of 'Amr (the words are):" O Allah, provide us subsistence"


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7082]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7082

'Umara b. al-Qa'qa' reported this hadith with the same chain of transmitters but instead of the word" qut" (bare subsistence) there has been used the word" Kafaf" (adequate means to meet the needs).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7083]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7083

'A'isha reported: Never had the family of Muhammad (may peace be upon him) eaten to the fill since their, arrival in Medina with the bread of wheat for three successive nights until his (Holy Prophet's) death.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7084]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7084

'A'isha reported Allah's Messenger (may peace be upon him) as saying: Never did Allah's Messenger (may peace be upon him) eat to his fill the bread of wheat for three successive days until he had run the course of his life.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7085]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7085

'A'isha reported: Never did the family of Muhammad (may peace be upon him) eat to the fill the bread of barley for two successive days until Allah's Messenger (may peace be upon him) died.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7086]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7086

'A'isha reported: Never could the family of Muhammad (may peace be upon him) (afford to cat to the fill) the bread of wheat beyond three days (successively).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7087]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7087

'A'isha reported: Never could the family of Muhammad (may peace. be upon him) (afford to eat) the bread of wheat for three (successive days) until he ran the course of his life.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7088]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7088

'A'isha reported: Never could the family of Muhammad (may peace be upon him) (afford to eat) the bread of wheat for two days successively. Even (out of these two days) one (was such wherein he could get) only a date.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7089]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7089

'A'isha reported: We the family of Muhammad (may peace be upon him) used to spend (the whole) month in which we (did not need to) kindle the fire as (we had nothing to cook) ; we had only dates and water (to fill our bellies).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7090]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7090

This hadith has been narrated on the authority of 'Urwa with the same chain of transmitters (and the words are):" We used to spend-" And he did not make a mention of the family of Muhammad (may peace be upon him), and Abu Kuraib made this addition to his hadith which was transmitted on the authority of Ibn Numair (and the words are):" But this that there was brought to us some meat."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7091]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7091

'A'isha reported that Allah's Messenger (way peace be upon him) died (in such a state) that there had been nothing in my wooden tub which a living being could afford to eat but a handful of barley therein. I had been eating out of that for a fairly long duration when I thought of measuring it and it was almost finished.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7092]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7092

'A'isha used to say to 'Urwa: Son of my sister, by Allah, I used to see the new moon, then the new moon, then the new moon, i. e. three moons in two months, and fire was not kindled in the house of Allah's Messenger (may peace be upon him). I ('Urwa) said: Auntie, then what were your means of sustenance? She said: Dates and water. But it (so happened) that Allah's Messenger (may peace be upon him) had some Ansar as his neighbours and they had milch animals and they used to send to Allah's Messenger (may peace be upon him) some milk of their (animals) and he served that to us.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7093]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7093

'Urwa b. Zubair reported on the authority of 'A'isha, the wife of Allah's Apostle (may peace be upon him), that she said: Allah's Messenger (may peace be upon him) died (in a state) that it never happened that he could eat to his fill the bread with olive oil twice during a day.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7094]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7094

'A'isha reported this hadith through other chains of transmitters also (and the words are) that Allah's Messenger (may peace be upon him) died (in a state) when the people could afford to eat only the dates and water.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7095]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7095

'A'isha reported that Allah's Messenger (may peace be upon him) had died in a state that they could afford to cat two things only: water and dates.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7096]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7096

This hadith has been transmitted on the authority of Sufyan and the words are:" We could not afford to eat to the fill even dates and water."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7097]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7097

Abu Huraira reported: By Him in Whose Hand is my life and Ibn 'Abbad also said: By One in Whose hand is the life of Abu Huraira, Allah's Messenger (may peace be upon him) could not afford to provide adequate food to his family which could (fill their bellies) with bread and wheat for three days successively until he left the world.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7098]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7098

Abu Hazim reported: I saw Abu Huraira point with his finger many a time and saying: By One in Whose Hand is the life of Abu Huraira, Allah's Apostle (may peace be upon him) could not eat to his fill and provide his family bread of wheat beyond three days successively until he left the world.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7099]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7099

Nu'man b. Bashir said: Don't you eat and drink according to your heart's desire, whereas I saw that your Prophet (may peace be upon him) (at times) could not find even an inferior quality of the dates with which he could fill his belly? Qutaiba, however, did not make a mention of It.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7100]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7100

This hadith has been narrated on the authority of Simak with the same chain of transmitters, with this addition of words:" You are not satisfied with the qualities of dates and butter."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7101]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7101

Simak b. Barb reported: I heard Nu'man deliver an address in which he said that (Hadrat) Umar made a mention of what had fallen to the lot of people out of the material world and he said: I saw Allah's Messenger (may peace be upon him) spend the whole day being upset because of hunger and he could not get even an interior quality of dates with which he could fill his belly.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7102]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7102

'Abd al-Rahman al-Hubuli reported: I heard that a person asked 'Abdullah b. 'Amr b. 'Asas saying: Are we not amongst the destitute of the emigrants? Abdullah said to him: Have you a spouse with whom you live? He said: Yes. He again said: Then you are amongst the rich. He said: I have a servant also. Thereupon he (Abdullah b. 'Amr b. 'As) said: Then you are amongst the kings.

Abu 'Abdal-Rahman reported that three persons came to 'Abdullah b. Amr b. 'As while I was sitting with him and they said: By Allah, we have nothing with us either in the form of provision, riding animals or wealth. Thereupon he said to them: I am prepared to do whatever you like. If you come to us, we would give you what Allah would make available for you. and if you like I would make a mention of your case to the ruler, and if you like you can show patience also. for I have beard Allah's Messenger (may peace be upon him) as saying: Destitute amongst the emigrants would precede the rich emigrants by forty years in getting into Paradise on the Day of Resurrection. Thereupon they said: We then, show patience and do not ask for anything.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7103]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7103

'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said in connection with the people of Hijr (Thamud): Do not enter but weepingly (the habitations) of these people who bad been punished by (Allah), and in case you do not feel inclined to weep, then do not enter (these habitations) that you may not meet the same calamity as had fallen to their lot.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7104]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7104

Ibn Shihab reported, and he had been talking about the stony abodes of Thamud, and he said: Salim b. 'Abdullah reported that 'Abdullah b. Umar said: We were passing along with Allah's Messenger (may peace be upon him) through the habitations of Hijr, and Allah's Messenger (may peace be upon him) said: Do not enter but weepingly the habitations of these persons who committed tyranny among themselves, lest the same calamity should fall upon you as it fell upon them. He then urged his mount to proceed quickly and pass through that valley hurriedly.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7105]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7105

Abdullah b. 'Umar reported that the people encamped along with Allah's Messenger (may peace be upon him) in the valley of Hijr, the habitations of Thamud, and they quenched their thirst from the wells thereof and kneaded the flour with it. Thereupon Allah's Messenger (may peace be upon him) commanded that the water collected for drinking should be spilt and the flour should be given to the camels and commanded them that the water for drinking should be taken from that well where the she-camel (of Hadrat Salih) used to come.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7106]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7106

This hadith has been narrated on the authority of 'Abdullah with the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7107]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7107

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: One who makes efforts (for earning to be spent) on a widow and the destitute is like a striver in the cause of Allah, and I think he also said: He is like one who constantly stands for prayer and observes fast without breaking it.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7108]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7108

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: One who looks after the orphan whether he is his relative or not, I and he would be together in Paradise like this, and Malik (explained it) with the gesture by drawing his index finger and middle finger close together.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7109]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7109

Abdullah al-Khaulani reported that when Uthman b. 'Affan tried to rebuild the mosque of Allah's Messenger (may peace be upon him) the people began to talk about this. Uthman b. 'Affan said: You discuss it very much whereas I have heard Allah's Messenger (may peace be upon him) as saying: He who builds a mosque-- and the narrator Bukair said: I think he also said: (for) seeking the pleasure of Allah- Allah would build (a similar house for him in Paradise). and in the narration of Harun (the words are):" A house for him in Paradise."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7110]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7110

Mahmud b. Labid reported that 'Uthman b. 'Affan decided to rebuild the mosque (of Allah's Apostle in Medina) but the people did not like this idea and they wished that it should be preserved in the same (old) form. Thereupon he (Hadrat 'Uthman) said: I heard Allah's Messenger (may peace be upon him) as saying: He who builds a mosque for Allah, Allah would build for him (a house) in Paradise like it.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7111]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7111

This hadith has been narrated on the authority of Ja'far with the same chain of transmitters with this variation (that the words are):" Allah would build for him a house in Paradise."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7112]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7112

Abu Huraira reported: While a person was in the wilderness he heard a voice from the cloud (commanding it thus): Irrigate the garden of so and so. (After that the clouds slinked aside and poured water on a stony ground. It filled a channel amongst the channels of that land and that person followed that water and he found a person standing in the garden busy in changing the course of water with the help of a hatchet. He said to him: Servant of Allah, what is your name? he said: So and so. And it was that very name which he had heard from the clouds. and he said to him: Servant of Allah, why do you ask me my name? He said: I beard a voice from the clouds of which It is the downpour, saying: Water the garden of so and to. like your name. What do you do (for the favour) shown to you by Allah in this matter? He said: Now as you state so. I look what yield I get from it. and I give one-third as charity out of it and I and my children eat one-third of it and one-third I return to it as investment.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7113]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7113

This hadith has been narrated on the authority of Wahb b. Kaisan with the same chain of transmitters but with this change that he said:" I earmark one-third for the poor, the needy and the wayfarers."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7114]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7114

Abu Huraira reported Allah's Messenger (may peace be upon him) as stating that Allah the Most High and Exalted said: I am the One, One Who does not stand in need of a partner. If anyone does anything in which he associates anyone else with Me, I shall abandon him with one whom he associates with Allah.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7115]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7115

Ibn Abbas reported Allah's Messenger (may peace be upon him) as saying: If anyone wants to have his deeds widely publicised, Allah will publicise (his humiliation). And if anyone makes a hypocritical display (of his deeds) Allah will make a display of him.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7116]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7116

Jundub reported Allah's Messenger (may peace be upon him) as saying: He who wants to publicise (his deeds), Allah will publicise (his humility), and he who makes a hypocritical display (of his deeds), Allah will make a display of him.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7117]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7117

Sufyan reported this hadith with the same chain of transmitters and he made this addition:" I did not hear anyone saying besides him that it was Allah's Messenger (may peace be upon him) who had said so."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7118]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7118

Salama b. Kuhail reported: I heard from Jundub but I did not hear him say like this:" I beard Allah's Messenger (way peace be upon him) as saying this."


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7119]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7119

Abu Sufyan reported like that as as-Saduq al-Amin al-Walid b. Harb narrated with the same chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7120]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7120

Abu Huraira reported that he heard Allah's Messenger (may peace be upon him) as saying: The servant speaks words for which he is sent down to the Hell-Fire farther than the distance between the cast and the west.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7121]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7121

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The servant speaks words that he does not understand its repercussions but he sinks down in Hell-Fire farther than the distance between the east and the west.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7122]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7122

Shaqiq reported that it was said to Usama b. Zaid: Why don't you visit 'Uthman and talk to him? Thereupon he said: Do you think that I have not talked to him but that I have made you hear? By Allah. I have talked to him (about things) concerning me and him and I did not like to divulge those things about which I had to take the initiative and I do not say to my ruler:" You are the best among people," after I beard Allah's Messenger (may peace be upon him) as saying: A man will be brought on the Day of Resurrection and thrown in Hell-Fire and his intestines will pour forth in Hell and he will go round along with them, as an ass goes round the mill. stone. The denizens of Hell would gather round him and say: 0, so and so, what has happened to you? Were you not enjoining us to do what was reputable and forbid us to do what was disreputable? He will say: Of course, it is so; I used to enjoin (upon people) to do what was reputable but did not practise that myself. I had been forbidding people to do what was disreputable, but practised it myself.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7123]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7123

Abu Wa'il reported: I was in the company of Usama b. Zaid that a person said: What prevents you to visit Uthman and talk to him for what he does? The rest of the hadith is the same.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7124]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7124

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: All the people of my Ummah would get pardon for their sins except those who publicise them. And (it means) that a servant should do a deed during the night and tell the people in the morning that he has done so and so, whereas Allah has concealed it. And he does a deed during the day and when it is night he tells the people, whereas Allah has concealed it. Zuhair has used the word hijar for publicising.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7125]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7125

Anas b. Malik reported that two persons sneezed in the presence of Allah's Messenger (may peace be upon him). He (the Messenger of Allah) invoked mercy for one, and did not invoke for the other. The one for whom he had not prayed said: So and so sneezed and you said: May Allah have mercy upon you. I also sneezed but you did not utter these words for me. Thereupon he (the Holy Prophet) said: That person praised Allah, and you did not praise Allah.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7126]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7126

This hadith has been narrated on the authority of Anas through another chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7127]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7127

Abu Burda reported: I visited Abu Musa, as he was in the house of the daughter of Fadl b. 'Abbas. I sneezed but he did not respond to it (by saying): Allah may have mercy upon you. Then she sneezed and he (Fadl b. 'Abbas) said: May Allah have mercy upon you. I came back to my mother and informed her about it, and when he came to her she said: My son sneezed in your presence and you did not say:" Allah may have mercy upon you, and she sneezed and you said for her:" May Allah have mercy upon you." Thereupon he said: Your son sneezed but he did not praise Allah and I did not beg mercy of Allah for him and she sneezed and she praised Allah and so I said: May Allah have mercy upon you, as I heard Allah's Messenger (may peace be upon him) as saying: When any one of you sneezes he should praise Allah and the other should say: May Allah have mercy upon you, and if he does not praise Allah, no mercy should be begged for him.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7128]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7128

Iyas b. Salama b. al-Akwa reported that his father reported to him that he heard Allah's Apostle (may peace be upon him) as saying: A person sneezed in his presence and he said to him: May Allah have mercy upon you. And he then sneezed for the second time and Allah's Messenger (may peace be upon him) said to him: He is suffering from cold (and no response is necessary).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7129]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7129

Abu Huraira reported Allah's Messenger (may peace be upon him) as saying: The yawning as from the devil. So when one of you yawns he should try to restrain it as far as it lies in his power.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7130]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7130

The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said: When one of you yawns, he should keep his mouth shut with the help of his hand, for it is the devil that enters therein.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7131]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7131

The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said: When one of you yawns, he should try to restrain it with cue help of his hand since it is the Satan that enters therein.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7132]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7132

The son of Abu Said al-Khudri reported on the authority of his father that Allah's Messenger (may peace be upon him) said. When one of you yawns while engaged in prayer, he should try to restrain so far as it lies in his power, since it is the Satan that enter therein.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7133]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7133

Abu Said al-Khudri reported Allah's Messenger (may peace be upon him) a hadith like this through another chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7134]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7134

'A'isha reported that Allah's Messenger (may peace be upon him) said: The Angels were born out of light and the Jinns were born out of the spark of fire and Adam was born as he has been defined (in the Qur'an) for you (i. e. he is fashioned out of clay).


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7135]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7135

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: A group of Bani Isra'il was lost. I do not know what happened to it, but I think (that it 'underwent a process of metamorphosis) and assumed the shape of rats. Don't you see when the milk of the camel is placed before them, these do not drink and when the milk of goat is placed before them, these do drink. Abu Huraira said: I narrated this very hadith to Ka'b and he said: Did you hear this from Allah's Messenger (may peace be upon him)? I (Abu Huraira) said: Yes. He said this again and again, and I said: Have I read Torah? This hadith has been transmitted on the authority of Ishaq with a slight variation of wording.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7136]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7136

Abu Huraira reported that the rat (is the result of) metamorphosis (of a group of Bani Isra'il) and the proof of this is that when the milk of goat is placed before it, it drinks it, and when the milk of the camel is placed before it, it would not taste it at all. Ka'b said: Did you hear it from Allah's Messenger (may peace be upon him)? Thereupon he said: Has Torah been revealed to me?


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7137]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7137

Abu Huraira reported that Allah's Messenger (may peace be upon him) said: The believer does not allow to be stung twice from one (and the same) hole. This hadith has been narrated on the authority of Abu Huraira through another chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7138]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7138

Suhaib reported that Allah's Messenger (may peace be upon him) said: Strange are the ways of a believer for there is good in every affair of his and this is not the case with anyone else except in the case of a believer for if he has an occasion to feel delight, he thanks (God), thus there is a good for him in it, and if he gets into trouble and shows resignation (and endures it patiently), there is a good for him in it.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7139]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7139

'Abd al-Rahman b. Abu Bakra reported on the authority of his father that a person praised another person in the presence of Allah's Apostle (may peace be upon him), whereupon he said: Woe be to thee, you have broken the neck of your friend, you have broken the neck of your friend-he said this twice. If one of you has to praise his friend at all, he should say: I think (him to be) so and Allah knows it well and I do not know the secret of the heart and Allah knows the destined end, and I cannot testify his purity against Allah but (he appears) to be so and so.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7140]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7140

Abd al-Rahman b. Abu Bakra reported on the authority of his father that a person was mentioned in the presence of Allah's Apostle (may peace be upon him), and a person said: Allah's Messenger, no person is more excellent than he after Allah's Messenger (may peace be upon him). Thereupon Allah's Apostle (may peace be upon him) said: Woe be to thee, you have broken the neck of your friend, and he said this twice. Then Allah's Messenger (may peace be upon him) said: If anyone has to praise his brother at all, he should say: I think him to be so and so, and even on this he should say: I do not consider anyone purer than Allah (considers). This hadith has been transmitted on the authority of Shu'ba with a slight variation of wording.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7141]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7141

Abu Musa reported Allah's Messenger (may peace be upon him) saw a person lauding another person or praising him too much. Thereupon he said: You killed him, or you sliced the back of a person.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7142]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7142

Abu Ma'mar reported that a person lauded a ruler amongst the rulers and Miqdad began to throw dust upon him and he said: Allah's Messenger (may peace be upon him) commanded us that we should throw dust upon the faces of those who shower too much praise.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7143]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7143

Hammam b. al-Harith reported that a person began to praise 'Uthman and Miqdad sat upon his knee; and he was a bulky person and began to throw pebbles upon his (flatterer's) face. Thereupon 'Uthman said: What is the matter with you? And he said: Verily, Allah's Messenger (may peace be upon him) said: When you see those who shower (undue) praise (upon others), throw dust upon their faces.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7144]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7144

This hadith has been narrated on the authority of Miqdad through another chain of transmitters.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7145]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7145

'Abdullah b. Umar reported that Allah's Messenger (may peace be upon him) said: It was shown in a vision that I was rinsing my mouth with miswak and two persons began to contend with one another for getting that miswak. One was older than the other. I gave the miswak to the younger one amongst them, but it was said to me: (Let it be given) to the older one. So I gave it to the older one.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7146]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7146

It was reported that Abu Huraira used to say: Listen to me, inmate of the apartment; listen to me, inmate of the apartment, while 'A'isha (Allah be pleased with her) had been busy in observing prayer. As she finished prayer, she said to" Urwa: Did you hear his words? And this is how Allah's Messenger (may peace be upon him) used to utter (so distinctly) that if one intended to count (the words uttered) he would be able to do so.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7147]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7147

Abu Sa'id Khudri reported that Allah's Messenger (may peace be upon him) said: Do not take down anything from me, and he who took down anything from me except the Qur'an, he should efface that and narrate from me, for there is no harm in it and he who attributed any falsehood to me-and Hammam said: I think he also said:" deliberately" -he should in fact find his abode in the Hell-Fire.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7148]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7148

Suhaib reported that Allah's Messenger (may peace be upon him) thus said: There lived a king before you and he had a (court) magician. As he (the magician) grew old, he said to the king: I have grown old, send some young boy to me so that I should teach him magic. He (the king) sent to him a young man so that he should train him (in magic). And on his way (to the magician) he (the young man) found a monk sitting there. He (the young man) listened to his (the monk's) talk and was impressed by it. It became his habit that on his way to the magician he met the monk and set there and he came to the magician (late). He (the magician) beat him because of delay. He made a complaint of that to the monk and he said to him: When you feel afraid of the magician, say: Members of my family had detained me. And when you feel afraid of your family you should say: The magician had detained me. It so happened that there came a huge beast (of prey) and it blocked the way of the people, and he (the young boy) said: I will come to know today whether the magician is superior or the monk is superior. He picked up a stone and said: O Allah, if the affair of the monk is dearer to Thee than the affair of the magician, cause death to this animal so that the people should be able to move about freely. He threw that stone towards it and killed it and the people began to move about (on the path freely). He (the young man) then came to that monk and Informed him and the monk said: Sonny, today you are superior to me. Your affair has come to a stage where I find that you would be soon put to a trial, and in case you are put to a trial don't give my clue. That young man began to treat the blind and those suffering from leprosy and he in fact began to cure people from (all kinds) of illness. When a companion of the king who had gone blind heard about him, he came to him with numerous gifts and said: If you cure me all these things collected together here would be yours. Be said: I myself do not cure anyone. It is Allah Who cures and if you affirm faith in Allah, I shall also supplicate Allah to cure you.

He affirmed his faith in Allah and Allah cured him and he came to the king and sat by his side as he used to sit before. The king said to him: Who restored your eyesight? He said: My Lord. Thereupon he said: It means that your Lord is One besides me. He said: My Lord and your Lord is Allah, so he (the king) took hold of him and tormented him till he gave a clue of that boy. The young man was thus summoned and the king said to him: O boy, it has been conveyed to me that you have become so much proficient in your magic that you cure the blind and those suffering from leprosy and you do such and such things. Thereupon he said: I do not cure anyone; it is Allah Who cures, and he (the king) took hold of him and began to torment him. So he gave a clue of the monk. The monk was thus summoned and it was said to him: You should turn back from your religion. He, however, refused to do so. He (ordered) for a saw to be brought (and when it was done) he (the king) placed it in the middle of his head and tore it into parts till a part fell down. Then the courtier of the king was brought and it was said to him: Turn back from your religion. Arid he refused to do so, and the saw was placed in the midst of his head and it was torn till a part fell down. Then that young boy was brought and it was said to him: Turn back from your religion. He refused to do so and he was handed over to a group of his courtiers. And he 'said to them: Take him to such and such mountain; make him climb up that mountain and when you reach its top (ask him to renounce his faith) but if he refuses to do so, then throw him (down the mountain). So they took him and made him climb up the mountain and he said: O Allah, save me from them (in any way) Thou likest and the mountain began to quake and they all fell down and that person came walking to the king. The king said to him: What has happened to your companions? He said: Allah has saved me from them. He again handed him to some of his courtiers and said: Take him and carry him in a small boat and when you reach the middle of the ocean (ask him to renounce) his religion, but if he does not renounce his religion throw him (into the water).

So they took him and he said: O Allah, save me from them and what they want to do. It was quite soon that the boat turned over and they were drowned and he came walking to the king, and the king said to him: What has happened to your companions? He said: Allah has saved me from them, and he said to the king: You cannot kill me until you do what I ask you to do. And he said: What is that? He said: You should gather people in a plain and hang me by the trunk (of a tree). Then take hold of an arrow from the quiver and say: In the name of Allah, the Lord of the worlds; then shoot an arrow and if you do that then you would be able to kill me. So he (the king) called the people in an open plain and tied him (the boy) to the trunk of a tree, then he took hold of an arrow from his quiver and then placed the arrow in the bow and then said: In the name of Allah, the Lord of the young boy; he then shot an arrow and it bit his temple. He (the boy) placed his hands upon the temple where the arrow had bit him and he died and the people said: We affirm our faith in the Lord of this young man, we affirm our faith in the Lord of this young man, we affirm our faith in the Lord of this young man. The courtiers came to the king and it was said to him: Do you see that Allah has actually done what you aimed at averting. They (the people) have affirmed their faith in the Lord. He (the king) commanded ditches to be dug at important points in the path. When these ditches were dug, and the fire was lit in them it was said (to the people): He who would not turn back from his (boy's) religion would be thrown in the fire or it would be said to them to jump in that. (The people courted death but did not renounce religion) till a woman came with her child and she felt hesitant in jumping into the fire and the child said to her: 0 mother, endure (this ordeal) for it is the Truth.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7149]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7149

'Ubadab. Walid b. Samit reported: I and my father set out in search of knowledge to a tribe of the Ansar before their death (i. e. before the Companions of the Holy Prophet left the world) and I was the first to meet Abu Yasar, a Companion of Allah's Messenger (may peace be upon him) and there was a young man with him who carried the record of letters with him and there was a mantle prepared by the tribe of Ma'afiri upon him. And his servant too had a Ma'afiri mantle over him. My father said to him: My uncle, I see the signs of anger or that of agony on your face. He said: Yes, such and such person, the son of so and so, of the tribe of Harami owed me a debt. I went to his family, extended salutations and said: Where is he? They said: He is not here. Then came out to me his son who was at the threshold of his youth. I said to him: Where is your father? He said: No sooner did he hear your sound than he hid himself behind my mother's bedstead. I said to him: Walk out to me, for I know where you are. He came out. I said to him: What prompted you to hide yourself from me? He said: By God, whatever I would say to you would not be a lie. By Allah, I fear that I should tell a lie to you and in case of making promise with you I should break it, as you are the Companion of Allah's Messenger (may peace be upon him). The fact is that I was hard up in regard to money. I said: Do you adjure by Allah? He said: I adjure by Allah. I said: Do you adjure by Allah? He said: I adjure by Allah. I said: Do you adjure by Allah? He said: I adjure by Allah. Then he brought his promissory note and he wrote off (the debt) with his hand and said: Make payment when you find yourself solvent enough to pay me back; if you are not, then there is no liability upon you. These two eyes of mine saw, and he (Abu'I-Yasar) placed his fingers upon his eyes and these two ears of mine heard and my heart retained, and he pointed towards his heart that Allah's Messenger (may peace be upon him) said: He who gives time to one who is financially hard up (in the payment of debt) or writes off his debt, Allah will provide him His shadow. I said to him: My uncle, if you get the cloak of your servant and you give him your two clothes, or take his two clothes of Ma'afir and give him your cloak, then there would be one dress for you and one for him.

He wiped my head and said: O Allah, bless the son of my brother. O, son of my brother, these two very eyes of mine saw and these two ears of mine listened to and this heart of mine retained this, and he pointed towards the heart that Allah's Messenger (may peace be upon him) said: Feed them (the servants) and clothe them (the servants) what you wear, and if I give him the goods of the world, it is easy for me than this that he should take my virtues on the Day of Resurrection. We went on till we came to Jabir b. Abdullah in the mosque and he was busy in observing prayer in one cloth which he had joined at its opposite ends. I made my way through the people till I sat between him and the Qibla and I said: May Allah have mercy upon you. Do you observe prayer with one cloth on your body whereas your mantle is lying at your side? He pointed me with his hand towards my breast just like this and he separated his fingers and bent them in the shape of a bow. And (he said): I thought that a fool like you should come to me so that he should see me as I do and he should then also do like it. Allah's Messenger (may peace be upon him) came to us in this very mosque and he had in his hand the twig of the palm-tree and he saw mucus towards the Qibla of the mosque and he erased it with the help of the twig. He then came to us and said: Who amongst you likes that Allah should turn His face away from him? We were afraid. He then again said: Who amongst you likes that Allah should turn His face away from him? We were afraid. He again said: Who amongst you likes that Allah should turn His face away from him? We said: Allah's Messenger, none of us likes it. And he said: If one amongst you stands for prayer, Allah, the Exalted and Glorious, is before him he should not spit in front of him, or on his right side, but should spit on his left side beneath his left foot and if he is impelled to do so all of a sudden (in spite of himself) he should then spit in his cloth and fold it in some part of it. (and he further said: ) Bring some sweet-smelling thing. A young man who belonged to our tribe stood up, went and brought scent in his palm. Allah's Messenger (may peace be upon him) took that and applied it to the end of that twig and then touched the place where there had been mucus. Jabir said: This is why you should apply scent to your mosques.

It is reported on the same authority: We set out along with Allah's Messenger (may peace be upon him) on an expedition of Batn Buwat. He (the Holy Prophet) was in search of al-Majdi b. 'Amr al-Juhani. (We had so meagre equipment) that five. six or seven of us had one camel to ride and so we mounted it turn by turn. Once there wan. the turn of an Ansari to ride upon the camel. He made it kneel down to ride over it (and after having. mounted it), he tried to raise it up but it hesitated. So he said. May there be curse of Allah upon you! Thereupon Allah's Messenger (may peace be upon him) said: Who is there to curse his camel? He said: Allah's Messenger, it' is I. Thereupon he said: Get down from the camel and let us not have in our company the cursed one. Don't curse your own selves, nor your children. nor your belongings. There is the possibility that your curse may synchronies with the time when Allah is about to confer upon you what you demand and thus your prayer may be readily responded.

It is reported on the same authority: We set out on an expedition along with Allah's Messenger (may peace be upon him) until it was evening, and we had been near a. water reservoir of Arabia. Allah's Messenger (may peace be upon him) said: Who would be the person who would go ahead and set right the reservoir and drink water himself and serve us with it? Jabir said: I stood up and said: Allah's Messenger, it is I who am ready to do that. Thereupon Allah's Messenger (may peace be upon him) said: Who is the person to accompany Jabir? And then Jabbar b. Sakhr stood up. So we went to that well and poured in that tank a bucket or two of water and plastered it with clay and then began to fill it (with water) until it was filled to the brim. Allah's Messenger (may peace be upon him) was the first who appeared before us, and he said: Do you (both) permit me to drink water out of it? We said: Yea, Allah's Messenger. He led his camel to drink water and it drank. He then pulled its rein and it stretched its legs and began to urinate. He then took it aside and made it kneel down at another place and then came to the tank and performed ablution. I then got up and performed ablution like the ablution of Allah's Messenger (may peace be upon him), and Jabbar b. Sakhr went in order to relieve himself and Allah's Messenger (may peace be upon him) got up to observe prayer and there was a mantle over me. I tried to invert its ends but it was too short (to cover my body easily). It had its borders. I then inverted it (the mantle) and drew its opposite ends and then tied them at my neck. I then came and stood upon the left side of Allah's Messenger (may peace be upon him). He caught hold of me and made me go round behind him, until he made me stand on his right side. Then Jabbar b. Sakhr came. He performed ablution and then came and stood on the left side of Allah's Messenger (may peace be upon him). Then Allah's Messenger (may peace be upon him) caught hold of our hands together, pushed us back and made us stand behind him. Then Allah's Messenger (may peace be upon him) began to look upon me with darting looks, but I did not perceive that. After that I became aware of it and he pointed with the gesture of his hand that I should wrap my loin-cloth. When Allah's Messenger (may peace be upon him) had finished the prayer, he said: Jabir! I said: Allah's Messenger, at thy beck and call. He said: When the cloth around you is inadequate, then tie the opposite ends but when it is small, tie it over the lower body.

Jabir reported: We set out on an expedition with Allah's Messenger (may peace be upon him) and the only means of sustenance for every person amongst us was only one date for a day and we used to chew it. And we struck the leaves with the help of our bow and ate them until the sides of our mouths were injured. It so happened one day that a person was overlooked and not given a date. We carried that person and bore witness to the fact that he had not been given that date so he was offered that and he got up and received that.

Jabir reported: We set out on an expedition along with Allah's Messenger (may peace be upon him) until we got down at a spacious valley and Allah's Messenger (may peace be upon him) went to relieve himself. I followed him with a bucket full of water and Allah's Messenger (may peace be upon him) looked about and he found no privacy but two trees at the end of the valley and Allah's Messenger (may. peace be upon him) went to one of them and took hold of one of its twigs and said: Be thou under my control by the permission of Allah, and so it came under his control like the camel who has its nosestring in the hand of its rider, and then he came to the second tree and took hold of a twig and said: Be thou under my control with the permission of Allah, and it came under his control, and when he came in the middle of the two trees he joined together the two twigs and said: join with the permission of Allah. Jabir said: I was afraid lest Allah's Messenger (may peace be upon him) should be aware of my nearness and go still farther. And Muhammad b. Abbad has used the word" faitab'd" and I began to talk to myself. And as I saw, I suddenly found Allah's Messenger (may peace be upon him) before me and the two trees were separated and each one of them was standing at its place. I saw Allah's Messenger (may peace be upon him) standing for a short time, nodding his head towards right and left. Isma'il pointed towards the right and left with the help of his head (in order to demonstrate how the Holy Prophet had pointed). Then he (the Holy Prophet) came to me and said: Jabir did you see my place where I was standing? I said: Allah's Messenger, yes. He then said: Then you should go to those two trees and cut a twig from each of them and go to that place with them where I was standing and stand there where I was standing and place a twig on the right and a twig on the left. Jabir said: I set out and took hold of a stone and broke it and sharpened it and then I came to those trees and cut a twig from each one of them.

I then came dragging them until I stood at the place where Allah's Messenger (may peace be upon him) had been standing and placed a twig on the right and a twig on the left. Then I met him and said: Allah's Messenger, I have done that, but (kindly) explain to me the reason for it. Thereupon he said: I passed by two graves the occupants of which had been undergoing torment. I liked to make intercession for them so that the might be relieved of this torment y as long as these twigs remain fresh. Jabir said: We came back to the (camp of the) army and Allah's Messenger (may peace be upon him) said: Jabir, call people for per- forming wudu. I cried: Come and perform wudu, come and perform wudu, come and perform wudu. I said: Allah's Messenger, there is not even a drop of water in the army camp, and there. was a person who used to cool the water for Allah's Messenger (may peace be upon him) in the old water-skin which kept hanging by the twig. He asked me to go to such and such Ansari and ask him to see if there was any water in that skin. I went to him and cast a glance in it but did not find anything but a drop in the mouth of that water-skin and if I were to draw that, the water-skin's,. dried part would suck it up. I came to Allah's Messenger (may peace be upon him) and said: Allah's Messenger, I have not found anything in it but a drop of water in the mouth of the water-skin and now if I were to draw that, it would be absorbed. He said: Go and bring that to me. I brought that to him. He took hold of it -and began to utter something which I could not understand and then pressed it with his hand and gave that to me and said: Jabir, announce for the tub to be brought. So I announced that the tub of the army (be brought). It was brought accordingly and I placed it before him (the Holy Prophet). Thereupon Allah's Messenger (may peace be upon him) placed his hands in the tub like this: with his fingers stretched out, and then he placed his fingers at the bottom of the tub and said: Jabir, take it (that waters-skin) and pour water over me, by reciting Bismillah, and I poured water and I said: Bismillah, and found water sprouting out between the fingers of Allah's Messenger (may peace be upon him). Then that tub gushed forth until it was filled up and the Messenger (may peace be upon him) said: Jabir, make an announcement to the effect: He who needs water should take that. Jabir said: The people came and got water until they were all satiated. I said: Is there anyone left who wants to get it? And Allah's Messenger (may peace be upon him) then lifted up his hand from that tub and it was still full. Then the people made a complaint to Allah's Messenger (may peace be upon him) about hunger and he said: May Allah provide you food! We came to the bank of the ocean and the ocean was tossing and it threw out a big animal and we lit fire and cooked it and took it until we had eaten to our heart's content. Jabir said: I and such and such five persons entered Its socket and nobody could see us until we had come out, and we took hold of one of its ribs and twisted it into a sort of arch, then we called the tallest of the persons of the army and the hugest of the camels of the army and it had the big saddle over it, and it could easily pass through it without the rider having need to bend down.


Muslim :: The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq) :: [42.7150]

The Book Pertaining to Piety and Softening of Hearts (Kitab Al-Zuhd wa Al-Raqa'iq)

Muslim :: Book 42 : Hadith 7150

Al-Bara' b. 'Azib reported that Abu Bakr Siddlq came to the residence of my father ('Azib) and bought a haudaj from him and said to 'Azib: Send your son to my residence (to carry this haudaj), and my father said to me: Carry it (for him). So I carried it and there went along with him (with Abu Bakr) my father in order to fetch its price and he ('Azib) said to Abu Bakr: Abu Bakr, narrate to me what you both did on the night when you set out on a journey along with Allah's Messenger (may peace be upon him). He said: We set out during the night and went on walking until it was noon, and the path was vacant and so none passed by that (until) there appeared prominently before us a large rock. It had its shade and the rays of the sun did not reach that place. So we got down at that place. I then went to the rock and levelled the ground with my hands at the place where the Holy Prophet (may peace be upon him) would take rest under its shade. I then set the bedding and said: Allah's Messenger, go to sleep and I shall keep a watch around you. I went out and watched around him. There we saw a shepherd moving towards that rock with his flock and he intended what we intended (i. e. taking rest). I met him and said to him: Young boy, to which place do you belong? He said: I am a person from Medina. I said, is there any milk in the udders of your sheep and goats? He said: Yes. He took hold of a goat, and I said to him: Clean the udder well so that it should be free from hair, dust and impurity. I saw al-Bara' striking his hand upon the other (to give an indication) how he did that. He milked the goat for me in a wooden cup which he had with him and I had with me a bucket in which I kept water for drinking and for performing ablution. I came to Allah's Apostle (may peace be upon him) and did not like to awaken him from sleep but he was accidentally startled from the sleep. I poured water upon the milk (till It was cold) and I said: Allah's Messenger, take this milk. He then took It and I was delighted and he (the Holy Prophet) said: Is now not the time to march on? I said: Of course. So he marched on after the sun had passed the meridian and Suraqa b. Malik pursued us and we had been walking on soft, level ground. I said: Allah's Messenger, we are about to be overtaken by them. Thereupon he said: Be not grieved. Verily, Allah is with us. Then Allah's Messenger (may peace be upon him) cursed him and his horse sank into the earth. I think he also said: I know you have hurled curse upon me. So supplicate Allah for me and I take an oath that I shall turn everyone away who would come in search of you. So he (Allah's Messenger) supplicated Allah and he was rescued and he came back and to everyone he met, he said: I have combed all this side. In short, he diverted everyone whom he met and he in fact fulfilled his promise.

Al-Bara' reported: Abu Bakr purchased a saddle from me for thirteen dirhams; the rest of the hadith is the same, and in the narration of Uthman b. 'Umar, the words are: He (Suraqa b. Malik) drew near Allah's Messenger (may peace be upon him), and he (the Holy Prophet) cursed him and his camel sank in the earth up to the belly and he jumped from that and said: Muhammad, I am fully aware of It that it is your doing. Supplicate Allah that He should rescue me from it in which I am (pitchforked) and I give you a solemn pledge that I shall keep this as a secret from all those who are coming after me. Take hold of an arrow out of it (quiver) for you will find my camels and my slaves at such and such place and you can get whatever you need (on showing this arrow). He (the Holy Prophet) said: I don't need your camels. And we (the Holy Prophet and Abu Bakr) came to Medina during the night and the people began to contend as to where Allah's Messenger (may peace be upon him) should reside and he encamped in the tribe of Najjar who were related to 'Abd ul-Muttalib from the side of mother. Allah's Messenger (may peace be upon him) honoured them, then people climbed upon house-top and women also and boys scattered in the way, and they were all crying: Muhammad, Messenger of Allah, Muhammad, Messenger of Allah.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7151]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7151

Hammim b. Munabbih reported: This is what Abu Huraira reported to us from Allah's Messenger (may peace be upon him) and in this connection he narrated some of the ahadith and Allah's Messenger (may peace be upon him) said: It was said to people of Israel: Enter this land saying Hitta (Remove Thou from us the burden of our sins), whereupon We would forgive you your sins, but they twisted (this statement) and entered the gate dragging upon their breech and said: The" grain in the ear."


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7152]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7152

Anas b. Malik reported that Allah, the Exalted and Glorious, sent revelation to Allah's Messenger (may peace be upon him) just before his death in quick succession until he left for his heavenly home, and the day when he died, he received the revelation profusely.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7153]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7153

Tariq b. Shihab reported that a Jew said to'Umar: You recite a verse which, if it had been revealed in relation to us, we would have taken that day as the day of rejoicing. Thereupon 'Umar said: I know where it was revealed and on the day when it was revealed and where Allah's Messenger (may peace be upon him) had been at that time when it was revealed. It was revealed on the day of 'Arafa (ninth of Dhu'l Hijjah) and Allah's Messenger (may peace be upon him) had been staying in 'Arafat. Sufyan said: I doubt, whether it was Friday or not (and the verse referred to) is this:" Today I have perfected your religion for you and completed My favours upon you" (v. 4).


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7154]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7154

Tariq b. Shihab reported that a Jew said to 'Umar: If this verse were revealed in relation to the Jews (i. e." This day I have perfected your religion for you and have completed My favours for you and have chosen for you al-Islam as religion" ) we would have taken the day of rejoicing on which this verse was revealed. Thereupon 'Umar said: I know the day on which it was revealed and the hour when it was revealed and where Allah's Messenger (may peace be upon him) had been when it was revealed. It was revealed on the night of Friday and we were in 'Arafat with Alleh's Messenger (may peace be upon him) at that time.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7155]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7155

Tariq b. Shihab reported that a Jew came to 'Umar and said: Commander of the Faithful, there is a verse in your Book, which you recite. Had it been revealed in connection with the Jews, we would have taken it as the day of rejoicing. Thereupon he said: Which verse do you mean? He replied:" This day I have perfected your religion for you and I have completed My favours upon you and I have chosen al-Islam as religion for you." Umar said, I know the day when it was revealed and the place where it was revealed. It was revealed to Allah's Messenger (may peace be upon him) at 'Arafat on Friday.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7156]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7156

'Urwa b. Zubair reported that he asked 'A'isha about the words of Allah:" If you fear that you will not be able to maintain equity amongst the orphan girls, then marry (those) you like from amongst the women two, three or four." She said: O, the son of my sister, the orphan girl is one who is under the patronage of her guardian and she shares with him in his property and her property and beauty fascinate him and her guardian makes up his mind to marry her without giving her due share of the wedding money and is not prepared (to pay so much amount) which anyone else is prepared to pay and so Allah has forbidden to marry these girls but in case when equity is observed as regards the wedding money and they are prepared to pay them the full amount of the wedding money and Allah commanded to marry other women besides them according to the liking of their heart. 'Urwa reported that 'A'isha said that people began to seek verdict from Allah's Messenger (may peace be upon him) after the revelation of this verse about them (orphan girls) and Allah, the Exalted and Glorious, revealed this verse:" They asked thee verdict about women; say: Allah gives verdict to you in regard to them and what is recited to you in the Book about orphan woman, whom you give not what is ordained for them while you like to marry them" (iv. 126). She said: The wording of Allah" what is recited to you" in the Book means the first verse, i. e." if you fear that you may not be able to observe equity in case of an orphan woman, marry what you like in case of woman" (iv. 3). 'A'isha said: (And as for this verse [iv. 126], i. e. and you intend" to marry one of them from amongst the orphan girls" it pertains to one who is in charge (of orphans) having small amount of wealth and less beauty and they have been forbidden that they should marry what they like of her wealth and beauty out of the orphan girls, but with equity, because of their disliking for them.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7157]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7157

'Urwa reported that he asked 'A'isha about the words of Allah:" If you fear that you will not be able to observe equity in case of orphan girls" ; the rest of the hadith is the same but with a slight variation of wording.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7158]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7158

'A'isha said that as for the words of Allah:" If you fear that you would not be able to observe equity in case of orphan girls)," it was revealed in reference to a person who had an orphan girl (as his ward) and he was her guardian, and her heir, and she possessed property, but there was none to contend on her behalf except her ownself. And he (her guardian) did not give her in marriage because of her property and he tortured her and ill-treated her, it was in relation to her that (Allah said: )" If you fear that you would not be able to observe equity in case of orphan girls, then marry whom you like among women," i. e. whatever I have made lawful for you and leave her whom you are putting to torture.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7159]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7159

'A'isha said in connection with His words (those of Allah):" What is recited to you in the Book about orphan women whom you give not what is ordained for them, while you like to marry them," these were revealed in connection with an orphan girl who was in the charge of the person and she shared with him in his property and he was reluctant to marry her himself and was also unwilling to marry her to someone else (fearing) that (that person) would share in his property (as the husband of that girl), preventing her to marry, neither marrying her himself nor marrying her to another person.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7160]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7160

Hisham reported that 'A'isha said in connection with the words of Allah:" They ask thee the religious verdict about women, say: Allah gives you the verdict about them" (iv. 126), that these relate to an orphan girl who is in charge of the person and she shares with him in his property (as a heir) even in the date-palm trees and he is reluctant to give her hand in marriage to any other person lest he (her husband) should partake of his property, and thus keep her in a lingering state.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7161]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7161

Hisham reported on the authority of his father that 'A'isha said in connection with His (Allah's) words:" And whoever is poor let him take reasonably (out of it)" that it was revealed in connection with the custodian of the property of an orphan, who is in charge of her and looks after her; In case he is poor, he is allowed to eat out of that.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7162]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7162

'A'isha reported in connection with the words of Allah, the Exalted:" He who is rich should abstain, and he who is poor may reasonably eat (out of it)" that this was revealed in relation to the guardian of an orphan who is poor; he may get out of that what is reasonable keeping in view his own status of solvency.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7163]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7163

This hadith has been narrated on the authority of Hisham with the same chain of transmitters.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7164]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7164

'A'isha reported that these words of Allah:" When they came upon you from above you and from below you and when the eyes turned dull and the hearts rose up to the throats" (xxxiii. 10) pertain to the day of Ditch.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7165]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7165

'A'isha said in connection with the verse:" And if a woman has reason to fear ill-treatment from her husband or that he might turn away from her" (iv. 128) that it was revealed in case of a woman who had long association with a person (as his wife) and now he intends to divorce her and she says: Do not divorce me, but retain me (as wife in your house) and you are permitted to live with another wife. It is in this context that this verse was revealed.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7166]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7166

'A'isha said in connection with these words of Allah, the Exalted and Glorious:" And if a woman has reason to fear ill-treatment from her husband or that he might turn away from her" that it was revealed in case of a woman who lived with a person and perhaps he does not want to prolong (his relationship with her) whereas she has had sexual relationship with him (and as a result thereof) she got a child from him and she does not like that she should be divorced, so she says to him: I permit you to live with the other wife.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7167]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7167

'Urwa reported on the authority of his father that 'A'isha said to him: O, the son of my sister, the Muslims were commanded to seek forgiveness for the Companions of Allah's Apostle (may peace be upon him) but they reviled him.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7168]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7168

This hadith has been transmitted on the authority of Abu Usama with the same chain of narrators.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7169]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7169

Sa'id b. Jubair reported: The inhabitants of Kufa differed in regard to this verse:" But whoever slays another believer intentionally, his requital shall be Hell" (iv. 92), so I went to Ibn 'Abbas and asked him about it, whereupon he said: This has been revealed and nothing abrogated it.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7170]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7170

This hadith has been transmitted on the authority of Shu'ba with the same chain of narrators but with a slight variation of wording.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7171]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7171

Sa'id b. Jubair reported: 'Abd al Rahman b. Abzi commanded me that I should ask Ibn 'Abbas about these two verses:" He who slays a believer intentionally his requital shall be Hell where he would abide for ever" (iv. 92). So, I asked him and he said: Nothing has abrogated it. And as for this verse:" And they who call not upon another god with Allah and slay not the soul which Allah has forbidden, except in the cause of justice" (xxv. 68), he (Ibn Abbas) said: This has been revealed in regard to the polytheists."


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7172]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7172

Ibn 'Abbas said: This verse was revealed in Mecca:" And they who call not upon another god with Allah and slay not the soul which Allah has forbidden except in the cause of justice" up to the word Muhdana (abased). Thereupon the polytheists said: Islam is of no avail to us for we have made peer with Allah and we killed the soul which Allah had forbidden to do and we committed debauchery, and it was (on this occasion) that Allah, the Exalted and Glorious, revealed this verse:" Except him who repents and believes and does good deeds" up to the end Ibn 'Abbis says: He who enters the fold of Islam and understands its command and then kills the soul there is no repentance for him.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7173]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7173

Sa'id b. Jubair reported: I said to Ibn Abbas: Will the repentance of that person be accepted who kills a believer intentionally? He said: No. I recited to him this verse of Sura al-Furqan (xix.):" And those who call not upon another god with Allah and slay not the soul which Allah has forbidden except in the cause of justice" to the end of the verse. He said: This is a Meccan verse which has been abrogated by a verse revealed at Medina:" He who slays a believer intentionally, for him is the requital of Hell-Fire where he would abide for ever," and in the narration of Ibn Hisham (the words are): I recited to him this verse of Sura al-Furqan:" Except one who made repentance."


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7174]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7174

Ubaidullah b. 'Abdullah b. 'Utba reported: Ibn Abbas said to me: Do you know-and in the words of Harun (another narrator): Are you aware of-the last Sura which was revealed in the Qur'an as a whole? I said: Yes," When came the help from Allah and the victory" (cx.). Thereupon, he said: You have told the truth. And in the narration of Abu Shaiba (the words are): Do you know the Sura? And he did not mention the words" the last one".


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7175]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7175

This hadith has been reported on the authority of Abu 'Umais through the same chain of transmitters but with a slight variation of wording.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7176]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7176

Ibn Abbas reported that some Muslims met a person with a small flock of sheep. He said: As-Salam-o-'Alaikum. They caught hold of him and killed him and took possession of his flock. Then this verse was revealed:" He who meets you and extends you salutations, don't say: You are not a Muslim" (iv. 94). Ibn 'Abbas, however, recited the word as-Salam instead of" as-Salam".


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7177]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7177

Bara' reported: When the Ansar performed the Pilgrimage, they did not enter their houses but from behind. A person from the Ansar came and he began to enter from his door but it was said to him (why he was doing something in contravention to the common practice of coming to the houses from behind). Then this verse was revealed." Piety is not that you come to the doors from behind" (ii. 189).


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7178]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7178

Ibn Mas'ud said: Since our acceptance of Islam and the revelation of this verse in which Allah has shown annoyance to us:" Has not the time yet come for the believers that their hearts should be humble for the remembrance of Allah?" (lvii. 16), there was a gap of four years.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7179]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7179

Ibn Abbas reported: During the pre-Islamic days women circumambulated the Ka'ba nakedly, and said: Who would provide cloth to cover the one who is circumambulating the Ka'ba so that she would cover her private parts? And then she would say: Today will be exposed the whole or the part and what is exposed I shall not make it lawful. It was in this connection that the verse was revealed:" Adorn yourself at every place of worship" (vii. 31).


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7180]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7180

Jabir reported that 'Abdullah b. Ubayy b. Salul used to say to his slave-girl: Go and fetch something for us by committing prostitution. It was in this connection that Allah, the Exalted and Glorious, revealed this verse:" And compel not your slave-girls to prostitution when they desire to keep chaste in order to seek the frail goods of this world's life, and whoever compels them, then surely after their compulsion Allah is Forgiving, Merciful" (xxiv. 33).


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7181]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7181

Jabir reported that 'Abdullah b. Ubayy b. Salul had two slave-girls; one was called Musaika and the other one was called Umaima and he compelled them to prostitution (for which'Abdullah b. Ubayy b. Salul compelled them). They made a complaint about this to Allah's Messenger (may peace be upon him) and it was upon this that this verse was revealed:" And compel not your slave-girls to prostitute" up to the words:" Allah is Forgiving, Merciful."


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7182]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7182

Abdullah b. Mas'ud reported in connection with the words of Allah, the Exalted and Glorious:" Those to whom they call upon, themselves seek the means or access to their Lord as to whoever of them becomes nearest" (xvii. 57) that it related to a party of Jinn who were being worshipped and they embraced Islam but those who worshipped them kept on worshipping them (though the Jinn whom the misguided people worshipped had become Muslims). It was then that this verse was revealed.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7183]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7183

Abdullah b. Mas'ud reported in connection with the verse:" Those whom they call upon, themselves seek the means of access to their Lord," that it related to a group of people who worshipped a party amongst the Jinn. The group from amongst the Jinn embraced Islam, but the people kept worshipping them as they did before, and it was (on this occasion) that the verse was revealed:" Those whom they call upon, themselves seek the means of access to their Lord." This hadith has been narrated on the authority of Sulaimin with the same chain of transmitters.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7184]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7184

Abdullah b. Mas'ud said in connection with the verse:" Those whom they call upon, themselves seek the means of access to their Lord," that that verse was revealed in connection with a party of Arabs who used to worship a group amnogst the jinn; the jinn embraced Islam but the people kept worshipping them without being conscious of it. Then this verse was revealed:" Those whom they call upon, themselves seek the means of access to their Lord."


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7185]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7185

Sa'id b. Jubair reported: I said to Ibn 'Abbas about Sura Tauba, whereupon he said: As for Sura Tauba, it is meant to humiliate (the non-believers and the hypocrites). There is constantly revealed in it (the pronoun) minhum (of them) and minhom (of them, i. e. such is the condition of some of them) till they (the Muslims) thought that none would be left unmentioned out of them who would not be blamed (for one fault or the other). I again said: What about Sura Anfal? He said: It pertains to the Battle of Badr. I again asked him about Sura al-Hashr. He said: It was revealed in connection with (the tribe) of Banu Nadir.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7186]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7186

Ibn 'Umar reported that Umar delivered a sermon on the pulpit of Allah's Messenger (may peace be upon him) and he praised Allah and lauded Him and then said: Now coming to the point. Behold I when the command pertaining to the prohibition of wine was revealed, it was prepared from five things: from wheat, barley, date, grape, honey; and wine is that which clouds the intellect; and O people, I wish Allah's Messenger (may peace be upon him) could have explained to us in (more) detail the laws pertaining to the inheritance of the grandfather, about one who dies leaving no issue, and some of the problems pertaining to interest.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7187]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7187

Ibn 'Umar reported: I heard 'Umar b. Khattab delivering sermon on the pulpit ol Allah's messenger (may peace be upon him) and saying': Now, coming to the point, O people, there was revealed (the command pertaining to the prohibition of wine) and it was prepared (at that time) out of five things: grape, date, honey, wheat, barley, and wine is that which clouds the intellect, and, O people, I wish Allah's Messenger (may peace be upon him) had explained to us in greater detail three things: the inheritance of the grandfather, of one who dies without leaving any issue, and some of the problems of interest.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7188]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7188

This hadith has been transmitted on the same authority but with a slight variation of wording.


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7189]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7189

Abu Dharr took an oath that this verse:" These two adversaries who dispute about their Lord" (xxii. 19) was revealed in connection with those who on the Day of Badr came out (of rows to fight against the non-believers and they were) Hamza, 'Ali, 'Ubaida b. Harith (from the side of the Muslims) and 'Utba and Shaiba, both of them the sons of Rabi'a and Walid b. 'Utba (from the side of the non-believers of Mecca).


Muslim :: The Book of Commentary (Kitab Al-Tafsir) :: [43.7190]

The Book of Commentary (Kitab Al-Tafsir)

Muslim :: Book 43 : Hadith 7190

This hadith has been narrated on the authority of Abu Dharr through another chain of transmitters.


Malik :: The Times of Prayer :: [1-1.1.1]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.1

He said, "Yahya ibn Yahya al-Laythi related to me from Malik ibn Anas from Ibn Shihab that one day Umar ibn Abdal-Aziz delayed the prayer. Urwa ibn az-Zubayr came and told him that al-Mughira ibn Shuba had delayed the prayer one day while he was in Kufa and Abu Masud al-Ansari had come to him and said, 'What's this, Mughira? Don't you know that the angel Jibril came down and prayed and the Messenger of Allah, may Allah bless him and grant him peace, prayed.' Then he prayed again, and the Messenger of Allah, may Allah bless him and grant him peace, prayed. Then he prayed again, and the Messenger of Allah, may Allah bless him and grant him peace, prayed. Then he prayed again, and the Messenger of Allah, may Allah bless him and grant him peace, prayed. Then he prayed again, and the Messenger of Allah, may Allah bless him and grant him peace, prayed. Then Jibril said, 'This is what you have been ordered to do.' Umar ibn Abd al-Aziz said, 'Be sure of what you relate, Urwa. Was it definitely Jibril who established the time of the prayer for the Messenger of Allah?' " Urwa said, "That's how it was related to Bashir ibn Abi Masud al-Ansari by his father."


Malik :: The Times of Prayer :: [1-1.1.2]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.2

Urwa said that A'isha, the wife of the Prophet, may Allah bless him and grant him peace used to pray asr while the sunlight was pouring into her room, before the sun itself had become visible (i.e. because it was still high in the sky).


Malik :: The Times of Prayer :: [1-1.1.3]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.3

Yahya related to me from Malik from Zayd ibn Aslam that Ata ibn Yasar said, "A man came to the Messenger of Allah, may Allah bless him and grant him peace, and asked him about the time of the subh prayer. The Messenger of Allah, may Allah bless him and grant him peace, did not answer him, but in the morning he prayed subh at first light. The following morning he prayed subh when it was much lighter, and then said, 'Where is the man who was asking about the time of the prayer?' The man replied, 'Here I am, Messenger of Allah.' He said,'The time is between these two.' "


Malik :: The Times of Prayer :: [1-1.1.4]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.4

Yahya related to me from Malik from Yahya ibn Said from Amra bint Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, used to pray subh and the women would leave wrapped in their garments and they could not yet be recognised in the darkness."


Malik :: The Times of Prayer :: [1-1.1.5]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.5

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar and from Busr ibn Said and from al-Araj-all of whom related it from Abu Hurayra - that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever manages to do a raka of subh before the sun has risen has done subh in time, and whoever manages to do a raka of asr before the sun has set has done asr in time."


Malik :: The Times of Prayer :: [1-1.1.6]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.6

Yahya related to me from Malik from Nafi from the mawla of Abdullah ibn Umar that Umar ibn al-Khattab wrote to his governors, saying, "The most important of your affairs in my view is the prayer. Whoever protects it and observes it carefully is protecting his deen, while whoever is negligent about it will be even more negligent about other things." Then he added, "Pray dhuhr any time from when the afternoon shade is the length of your forearm until the length of your shadow matches your height. Pray asr when the sun is still pure white, so that a rider can travel two or three farsakhs before the sun sets. Pray maghrib when the sun has set. Pray isha any time from when the redness in the western sky has disappeared until a third of the night has passed - and a person who sleeps, may he have no rest, a person who sleeps, may he have no rest. And pray subh when all the stars are visible and like a haze in the sky."


Malik :: The Times of Prayer :: [1-1.1.7]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.7

Yahya related to me from Malik, from his uncle Abu Suhayl from his father that Umar ibn al-Khattab wrote to Abu Musa saying that he should pray dhuhr when the sun had started to decline, asr when the sun was still pure white before any yellowness had entered it maghrib when the sun had set, and to delay isha as long as he did not sleep, and to pray subh when the stars were all visible and like a haze in the sky and to read in it two long suras from the mufassal.


Malik :: The Times of Prayer :: [1-1.1.8]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.8

Yahya related to me from Malik from Hisham ibn Urwa from his father that Umar ibn al-Khattab wrote to Abu Musa al-Ashari that he should pray asr when the sun was still pure white so that a man could ride threefarsakhs (before maghrib) and that he should pray isha during the first third of the night, or, if he delayed it, then up until the middle of the night, and he warned him not to be forgetful.


Malik :: The Times of Prayer :: [1-1.1.9]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.9

Yahya related to me from Malik from Yazid ibn Ziyad that Abdullah ibn Rafi, the mawla of Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, asked Abu Hurayra about the time of the prayer. Abu Hurayra said, "Let me tell you. Pray dhuhr when the length of your shadow matches your height, asr when your shadow is twice your height, maghrib when the sun has set, isha in the first third of the night, and subh in the very first light of dawn," i.e. when the dawn has definitely come.


Malik :: The Times of Prayer :: [1-1.1.10]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.10

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik said, "We would pray asr and anyone who then went to the Bani Amr ibn Awf would find them praying asr."


Malik :: The Times of Prayer :: [1-1.1.11]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.11

Yahya related to me from Malik from Ibn Shihab that Anas ibn Malik said, "We would pray asr and anyone who then went to Quba would arrive there while the sun was still high."


Malik :: The Times of Prayer :: [1-1.1.12]

The Times of Prayer

Malik :: Book 1 : Hadith 1.1.12

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that al Qasim ibn Muhammad said, "None of the companions that I met prayed dhuhr until well after noon,"(i.e.until when the sun had lost its fierceness).


Malik :: The Times of Prayer :: [1-1.2.13]

The Times of Prayer

Malik :: Book 1 : Hadith 1.2.13

Yahya related to me from Malik from his uncle Abu Suhayl ibn Malik that his father said, "I used to see a carpet belonging to Aqil ibn Abi Talib spread out on the day of jumua up to the west wall of the mosque. When the shadow of the wall covered the whole carpet, Umar ibn al-Khattab would come out and pray the jumua prayer."

Malik, Abu Suhayl's father, added, "We would then return after the jumua prayer and take our midday sleep."


Malik :: The Times of Prayer :: [1-1.2.14]

The Times of Prayer

Malik :: Book 1 : Hadith 1.2.14

Yahya related to me from Malik from Amr ibn Yahya ibn Yahya al-Mazini from Ibn Abi Salit that Uthman ibn Affan prayed jumua in Madina and asr in Malal (a place seventeen miles from Madina).

Malik commented, "That was by praying jumua just past midday and then travelling fast."


Malik :: The Times of Prayer :: [1-1.3.15]

The Times of Prayer

Malik :: Book 1 : Hadith 1.3.15

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abdar-Rahman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said "Whoever catches a raka of the prayer has caught the prayer."


Malik :: The Times of Prayer :: [1-1.3.16]

The Times of Prayer

Malik :: Book 1 : Hadith 1.3.16

Yahya related to me from Malik from Nafi that Abdullah ibn Umar ibn al-Khattab used to say, "If the ruku has passed you by, so has the sajda."


Malik :: The Times of Prayer :: [1-1.3.17]

The Times of Prayer

Malik :: Book 1 : Hadith 1.3.17

Yahya related to me from Malik that he had heard that Abdullah ibn Umar and Zayd ibn Thabit used to say, "Whoever catches the ruku has caught the sajda."


Malik :: The Times of Prayer :: [1-1.3.18]

The Times of Prayer

Malik :: Book 1 : Hadith 1.3.18

Yahya related to me from Malik that he had heard that Abu Hurayra used to say, "Whoever catches the ruku has caught the sajda and whoever misses the recitation of the umm al-Qur'an has missed much good."


Malik :: The Times of Prayer :: [1-1.4.19]

The Times of Prayer

Malik :: Book 1 : Hadith 1.4.19

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Duluk ash-shams begins from when the sun passes the meridian."


Malik :: The Times of Prayer :: [1-1.4.20]

The Times of Prayer

Malik :: Book 1 : Hadith 1.4.20

Yahya related to me from Malik that Da'ud ibn al-Husayn said that someone had told him Abdullah ibn Abbas used to say, "Duluk ash-shams begins from when the sun passes the meridian. Ghasaq al-layl is the gathering of the night and its darkness."


Malik :: The Times of Prayer :: [1-1.5.21]

The Times of Prayer

Malik :: Book 1 : Hadith 1.5.21

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "If someone misses the asr prayer it is as if he has suffered a great misfortune in his family and wealth ."


Malik :: The Times of Prayer :: [1-1.5.22]

The Times of Prayer

Malik :: Book 1 : Hadith 1.5.22

Yahya related to me from Malik from Yahya ibn Said that once Umar ibn al-Khattab left after doing the asr prayer and met a man who had not been there. Umar asked him what had kept him from the prayer and eventhough the man gave a good reason, Umar said, "You have given yourself short measure."

Yahya added that Malik commented, "It is said that everything has a short measure and a full measure."


Malik :: The Times of Prayer :: [1-1.5.23]

The Times of Prayer

Malik :: Book 1 : Hadith 1.5.23

Yahya related to me from Malik thatYahya ibn Said used to say, "Even if someone manages to pray before the time of the prayer has passed, the time that has passed him by is more important, or better, than his family and wealth."

Yahya said that Malik said, "If the time for a prayer comes and a traveller delays a prayer through neglect or forgetfulness until he reaches his family, he should do that prayer in full if he arrives within the time. But if he arrives when the time has past, he should do the travelling prayer. That way he only repays what he owes."

Malik said, "This is what I have found the people and men of knowledge doing in our community." Malik explained that shafaq was the redness in the sky after the sun had set, and said, "When the redness has gone then the isha prayer is due and you have left the time of maghrib."


Malik :: The Times of Prayer :: [1-1.5.24]

The Times of Prayer

Malik :: Book 1 : Hadith 1.5.24

Yahya related to me from Malik from Nafi that one time Abdullah ibn Umar fainted and lost his senses and he did not make up the prayer.

Malik commented, "We consider that that was because, and Allah knows best, the time had passed. Someone who recovers within the time has to pray."


Malik :: The Times of Prayer :: [1-1.6.25]

The Times of Prayer

Malik :: Book 1 : Hadith 1.6.25

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, travelled by night on the way back from Khaybar.Towards the end of the night he stopped for a rest and told Bilal to stay awake to keep watch for the subh prayer. The Messenger of Allah, may Allah bless him and grant him peace, and his companions slept. Bilal stayed on guard as long as was decreed for him and then he leant against his riding camel facing the direction of the dawn and sleep overcame him and neither he nor the Messenger of Allah nor any of the party woke up until the sun's rays had struck them. The Messenger of Allah, may Allah bless him and grant him peace, was alarmed. Bilal excused himself, saying, "Messenger of Allah! The One who took your self was the One who took myself. "The Messenger of Allah, may Allah bless him and grant him peace, ordered the party to move on and so they roused thei r mounts and rode on a short distance. The Messenger of Allah, may Allah bless him and grant him peace, ordered Bilal to give the iqama and then led them in the subh prayer. When he had finished he said, "Anyone who forgets a prayer should pray it when he remembers. Allah theBlessed and Exalted says in His book, 'Establish the prayer to remember Me.'"


Malik :: The Times of Prayer :: [1-1.6.26]

The Times of Prayer

Malik :: Book 1 : Hadith 1.6.26

Yahya related to me from Malik that Zayd ibn Aslam said, "The Messenger of Allah, may Allah bless him and grant him peace, stopped for a rest one night on the way to Makka and appointed Bilal to wake them up for the prayer. Bilal slept and everyone else slept and none of them woke up until the sun had risen. When they did wake up they were all alarmed. The Messenger of Allah, may Allah bless him and grant him peace, ordered them to ride out of the valley, saying that there was a shaytan in it. So they rode out of the valley and the Messenger of Allah, may Allah bless him and grant him peace, ordered them to dismount and do wudu and he told Bilal either to call the prayer or to give the iqama. The Messenger of Allah, may Allah bless him and grant him peace, then led them in the prayer. Noticing their uneasiness, he went to them and said, 'O people! Allah seized our spirits (arwah) and if He had wished He would have returned them to us at a time other than this. So if you sleep through the time for a prayer or forget it and then are anxious about it, pray it as if you were praying it in its time.' The Messenger of Allah, may Allah bless him and grant him peace, turned to Abu Bakr and said, 'Shaytan came to Bilal when he was standing in prayer and made him lie down and lulled him to sleep like a small boy.' The Messenger of Allah, may Allah bless him and grant him peace, then called Bilal and told him the same as he had told Abu Bakr. Abu Bakr declared, 'I bear witness that you are the Messenger of Allah.' "


Malik :: The Times of Prayer :: [1-1.7.27]

The Times of Prayer

Malik :: Book 1 : Hadith 1.7.27

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Scorching heat is a part of the blast of Jahannam. So, when the heat is fierce, delay the prayer until it gets cooler."

He added in explanation, "The Fire complained to its Lord and said, 'My Lord, part of me has eaten another part,' so He allowed it two breaths in every year, a breath in winter and a breath in summer."


Malik :: The Times of Prayer :: [1-1.7.28]

The Times of Prayer

Malik :: Book 1 : Hadith 1.7.28

Malik related to us from Abdullah ibn Yazid the mawla of al-Aswad ibn Sufyan, from Abu Salama ibn Abd ar-Rahman from Muhammad ibn Abd ar-Rahman ibn Thawban from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the heat is fierce delay the prayer until it gets cooler, for scorching heat is a part of the blast of Jahannam."

He added, "The Fire complained to its Lord, so He allowed it two breaths in each year, a breath in winter and a breath in summer."


Malik :: The Times of Prayer :: [1-1.7.29]

The Times of Prayer

Malik :: Book 1 : Hadith 1.7.29

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the heat is fierce, wait until it gets cooler before you do the prayer, for scorching heat is from the blast of Jahannam."


Malik :: The Times of Prayer :: [1-1.8.30]

The Times of Prayer

Malik :: Book 1 : Hadith 1.8.30

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, said, "Anyone who eats this plant should not come near our mosques. The smell of the garlic will offend us."


Malik :: The Times of Prayer :: [1-1.8.31]

The Times of Prayer

Malik :: Book 1 : Hadith 1.8.31

Yahya related to me from Malik from Abd ar-Rahman ibn al-Mujabbar that he used to see Salim ibn Abdullah pull the cloth away fiercely from the mouth of any man he saw covering his mouth while praying.


Malik :: Purity :: [2-2.1.1]

Purity

Malik :: Book 2 : Hadith 2.1.1

Yahya related to me from Malik from Amr ibn Yahya al-Mazini that his father once asked Abdullah ibn Zayd ibn Asim, who was the grandfather of Amr ibn Yahya al-Mazini and one of the companions of the Messenger of Allah, may Allah bless him and grant him peace, if he could show him how the Messenger of Allah, may Allah bless him and grant him peace, did wudu. Abdullah ibn Zayd ibn Asim agreed to do so and asked for water to do wudu. He poured some out on to his hand and washed each hand twice and then rinsed his mouth and snuffed water up his nose and blew it out three times.Then he washed hisface three times and both of his arms up to the elbows twice. He then wiped his head with both hands, taking his hands from hisforehead to the nape of his neck and then bringing them back to where he had begun. Then he washed his feet.


Malik :: Purity :: [2-2.1.2]

Purity

Malik :: Book 2 : Hadith 2.1.2

Yahya related to me from Malik from Abu'zZinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you do wudu, snuff water into your nose and blow it out, and if you use stones to clean your private parts use an odd number."


Malik :: Purity :: [2-2.1.3]

Purity

Malik :: Book 2 : Hadith 2.1.3

Yahya related to me from Ibn Shihab from Abu Idris al-Khawlani from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The person doing wudu should snuff water up his nose and blow it out again."


Malik :: Purity :: [2-2.1.4]

Purity

Malik :: Book 2 : Hadith 2.1.4

Yahya said that he heard Malik say that there was no harm in washing the mouth and cleaning the nose with only one handful of water.


Malik :: Purity :: [2-2.1.5]

Purity

Malik :: Book 2 : Hadith 2.1.5

Yahya related to me from Malik that he had heard that Abd ar-Rahman ibn Abi Bakr was visiting A'isha, the wife of the Prophet, may AIIah bless him and grant him peace, on the day that Sad ibn Abi Waqqas died, and he asked for some water to do wudu. A'isha said to him, ''Abd ar-Rahman! Perform your wudu fully, for I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Woe to the heels in the fire.' "


Malik :: Purity :: [2-2.1.6]

Purity

Malik :: Book 2 : Hadith 2.1.6

Yahya related to me from Malik from Yahya ibn Muhammad ibn Talhafrom Uthman ibn Abd ar-Rahman that his father related to him that he had heard that Umar ibn al-Khattab used to wash what was beneath his waist wrapper with water.


Malik :: Purity :: [2-2.1.7]

Purity

Malik :: Book 2 : Hadith 2.1.7

Yahya said that Malik was asked what a man should do if, when he did wudu, he forgot and washed his face before he had rinsed his mouth, or washed his forearms before he had washed his face. He said, "If someone washes his face before rinsing his mouth, he should rinse his mouth and not wash his face again. If someone washes his forearms before his face, however, he should wash his forearms again so that he has washed them after his face. This is if he is still near the place (of wudu)."


Malik :: Purity :: [2-2.1.8]

Purity

Malik :: Book 2 : Hadith 2.1.8

Yahya said that Malik was asked about what a man should do if he had forgotten to rinse his mouth and nose until he had prayed, and he said, "He does not have to repeat the prayer, but should rinse his mouth and nose if he wishes to do any more prayers after that."


Malik :: Purity :: [2-2.2.9]

Purity

Malik :: Book 2 : Hadith 2.2.9

Yahya related to me from Malik from Abu'zZinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you wake up from sleep to pray, wash your hands before you put them in the wudu water, for you do not know where your hands have spent the night."


Malik :: Purity :: [2-2.2.10]

Purity

Malik :: Book 2 : Hadith 2.2.10

Yahya related to me from Malik from Zayd ibn Aslam that Umar ibn al-Khattab said, "If you fall asleep Iying down you must do wudu ( before you pray) . "

Yahya related to me from Malik from Zayd ibn Aslam that the ayat "You who believe! When you rise for prayer wash your faces, and your arms to the elbows, and wipe over your heads and your feet up to the ankles," refers to rising from bed, meaning sleep.

Yahya said that Malik said, "The situation with us is that one does not have to do wudu for a nose-bleed, or for blood, or for pus issuing from the body. One only has to do wudu for impurities which issue from the genitals or the anus, or for sleep."

Yahya related to me from Malik from Nafithat Ibn Umar used to sleep sitting and then would pray without doing wudu.


Malik :: Purity :: [2-2.3.12]

Purity

Malik :: Book 2 : Hadith 2.3.12

Yahya related to me from Malik from Safwan ibn Sulaym from Said ibn Salama of the Bani Azraq from al-Mughira ibn Abi Burda of the tribe of Bani Abd ad-Dar that he had heard Abu Hurayra speak about a man who came to the Messenger of Allah, may Allah bless him and grant him peace, and said, "Messenger of Allah! We travel by sea and we do not carry much fresh water with us so if we do wudu with it we go thirsty. Can we do wudu with seawater?" The Messenger of Allah, may Allah bless him and grant him peace, replied, "lts water is pure, and its dead creatures are halal."


Malik :: Purity :: [2-2.3.13]

Purity

Malik :: Book 2 : Hadith 2.3.13

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha from Humayda bint Abi Ubayda ibn Farwa that her maternal aunt Kabsha bint Kab ibn Malik, who was the wife of the son of Abu Qatada al-Ansari, told her that once Abu Qatada was visiting her and she poured out some water for him to do wudu with. Just then a cat came to drink from it, so he tilted the vessel towards it to let it drink. Kabsha continued, "He saw me looking at him and said, 'Are you surprised, daughter of my brother?' I said, 'Yes.' He replied that the Messenger of Allah, may Allah bless him and grant him peace, said, cats are not impure. They intermingle with you .' "

Yahya said that Malik said, "There is no harm in that unless one sees impurities on the cat's mouth."


Malik :: Purity :: [2-2.3.14]

Purity

Malik :: Book 2 : Hadith 2.3.14

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Ibrahim ibn alHarith at-Taymi from Yahya ibn Abd ar-Rahman ibn Hatib that Umar ibn al-Khattab set out on one occasion with a party of riders, one of whom was Amr ibn al-As. They came to a watering place and Amr ibn al-As asked the man who owned it whether wild beasts drank from it. Umar ibn al-Khattab told the owner of the watering place not to answer, since the people drank after the wild beasts and the wild beasts drank after them.


Malik :: Purity :: [2-2.3.15]

Purity

Malik :: Book 2 : Hadith 2.3.15

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say that men and their wives used to do wudu together in the time of the Messenger of Allah.


Malik :: Purity :: [2-2.4.16]

Purity

Malik :: Book 2 : Hadith 2.4.16

Yahya related to me from Malik from Muhammad ibn Umara from Muhammad ibn Ibrahim that the mother of the son of Ibrahim ibn Abd ar-Rahman ibn Awf questioned Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, and said, "I am a woman who wears a long skirt and (sometimes) I walk in dirty places." Umm Salama replied, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'What follows (i.e. clean places) purifies it.' "


Malik :: Purity :: [2-2.4.17]

Purity

Malik :: Book 2 : Hadith 2.4.17

Yahya related to me from Malik that he saw Rabia ibn Abd ar-Rahman vomit several times when he was in the mosque and he did not leave, nor did he do wudu before he prayed.

Yahya said that Malik was asked whether a man who vomited food had to do wudu and he said, "He does not have to do wudu, but he should rinse the inside of his mouth and wash his mouth out."


Malik :: Purity :: [2-2.4.18]

Purity

Malik :: Book 2 : Hadith 2.4.18

Yahya related to me from Malik from Nafi that Abdullah ibn Umar prepared the body of one of Said ibn Zayd's sons for burial and carried it and then entered the mosque and prayed without doing wudu.

Yahya said that Malik was asked whether it was necessary to do wudu because of regurgitating undigested food and he said, "No, wudu is not necessary, but the mouth should be rinsed."


Malik :: Purity :: [2-2.5.19]

Purity

Malik :: Book 2 : Hadith 2.5.19

Yahya related to me from Malik from Zayd Aslam from Ata ibn Yasar from Abdullah Abbas that the Messenger of Allah, may Allah bless him and grant him peace, ate a shoulder of lamb and then prayed without doing wudu.


Malik :: Purity :: [2-2.5.20]

Purity

Malik :: Book 2 : Hadith 2.5.20

Yahya related to me from Malik from Yahya ibn Said from Bushayr ibn Yasar, the mawla of the Bani Haritha, that Suwayd ibn anNuman told him that he went with the Messenger of Allah, may Allah bless him and grant him peace, on the expedition to Khaybar. When they reached as Suhba, which was near Khaybar, the Messenger of Allah, may Allah bless him and grant him peace, stopped and prayed asr. He asked for provisions but only parched barley was brought, so he asked for it to be moistened. The Messenger of Allah, may Allah bless him and grant him peace, ate and the people ate with him. Then he got up to do maghrib and rinsed his mouth out and they rinsed out theirs. Then he prayed without doing wudu.


Malik :: Purity :: [2-2.5.21]

Purity

Malik :: Book 2 : Hadith 2.5.21

Yahya related to me from Malik that both Muhammad ibn al-Munkadir and Safwan ibn Sulaym transmitted to him from Muhammad ibn Ibrahim ibn al-Harith at-Taymi from Rabia ibn Abdullah ibn al-Hudayr that he had eaten an evening meal with Umar ibn al-Khattab who then prayed without doing wudu.


Malik :: Purity :: [2-2.5.22]

Purity

Malik :: Book 2 : Hadith 2.5.22

Yahya related to me from Malik from Damra ibn Said al-Mazini from Aban ibn Uthman that Uthman ibn Affan ate bread and meat, rinsed his mouth out, washed his hands and wiped his face with them, and then prayed without doing wudu.


Malik :: Purity :: [2-2.5.23]

Purity

Malik :: Book 2 : Hadith 2.5.23

Yahya related to me from Malik that he had heard that Ali ibn Abi Talib and Abdullah ibn Abbas did not do wudu after eating cooked food.


Malik :: Purity :: [2-2.5.24]

Purity

Malik :: Book 2 : Hadith 2.5.24

Yahya related to me from Malik from Yahya ibn Said that he asked Abdullah ibn Amir ibn Rabia whether a man who did wudu for prayer and then ate cooked food had to do wudu again. He said, "I saw my father do that without doing wudu ."


Malik :: Purity :: [2-2.5.25]

Purity

Malik :: Book 2 : Hadith 2.5.25

Yahya related to me from Malik from Abu Nuaym Wahb ibn Kaysan that he heard Jabir ibn Abdullah al-Ansari saying, "I saw Abu Bakr as-Siddiq eat meat and then pray without doing wudu."


Malik :: Purity :: [2-2.5.26]

Purity

Malik :: Book 2 : Hadith 2.5.26

Yahya related to me from Malik from Muhammad ibn al-Munkadir that the Messenger of Allah, may Allah bless him and grant him peace, was invited to eat, and some bread and meat was brought to him. He ate some of it, and then did wudu and prayed. Then more of the same food was brought and he ate some more and then prayed without doing wudu.


Malik :: Purity :: [2-2.5.27]

Purity

Malik :: Book 2 : Hadith 2.5.27

It was related to me from Malik from Musa ibn Uqba from Abd ar-Rahman ibn Yazid al-Ansari that when Anas ibn Malik came back from Iraq, Abu Talha and Ubayy ibn Kab visited him. He brought them some cooked food and they ate, and then Anas got up and did wudu. Abu Talha and Ubayy ibn Kab asked, "What's this, Anas? Is it an Iraqi custom?" and Anas said, "I wish I had not done it." (i.e. wudu). Abu Talha and Ubayy ibn Kab both got up and prayed without doing wudu.


Malik :: Purity :: [2-2.6.28]

Purity

Malik :: Book 2 : Hadith 2.6.28

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, was asked about cleaning after excretion. He replied, "Are any of you unable to find three stones?"


Malik :: Purity :: [2-2.6.29]

Purity

Malik :: Book 2 : Hadith 2.6.29

Yahya related to me from Malik from al-Ala ibn Abd ar-Rahman from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, went to the burial grounds and said, "Peace be upon you, home of a people who believe! We shall be among you, Allah willing. I wish that I had seen our brothers!" The people with him said, "Messenger of Allah! Are we not your brothers?" "No," he said, "You are my companions. Our brothers are those who have not yet come. And I will precede them to the Hawd. (The Hawd: the watering place of the Prophet, may Allah bless him and grant him peace, from which he will give to the people of his community on the day of rising.)" They asked him, "Messenger of Allah! How will you recognise those of your community who come after you?"

He said, "Doesn't a man who has horses with white legs and white blazes on their foreheads among totally black horses recognise which ones are his own?" They said, "Of course, Messenger of Allah." He went on, "Even so will they come on the day of rising with white marks on their foreheads, hands and feet from wudu, and I will precede them to the Hawd. Some men will be driven away from the Hawd as if they were straying camels and I shall call out to them, 'Will you not come? Will you not come? Will you not come?' and someone will say, 'They changed things after you,' so I shall say, 'Then away with them, away with them, away with them!' "


Malik :: Purity :: [2-2.6.30]

Purity

Malik :: Book 2 : Hadith 2.6.30

Yahya related to me from Malik from Hisham ibn Urwa from his father from Humran, the mawla of Uthman ibn Affan, that Uthman ibn Affan was once sitting on the Maqaid (the benches surrounding the Madina Mosque, or else a stone near Uthman ibn Affan's house where he sat to discuss with people), when the muadhdhin came and told him that it was time for the asr prayer. He called for water and did wudu. Then he said, "By Allah, I shall tell you something which I would not tell you if it were not in the Book of Allah. I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'If a man does wudu, and makes sure he does it correctly, and then does the prayer, he will be forgiven everything that he does between then and the time when he prays the next prayer.' "

Yahya said that Malik said, "I believe he meant this ayat - 'Establish prayer at the two ends of the day and in some watches of the night. Good actions take away wrong actions. That is a reminder for those who remember.' " (Sura 11 ayat 114).


Malik :: Purity :: [2-2.6.31]

Purity

Malik :: Book 2 : Hadith 2.6.31

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar from Abdullah as-Sanabihi that the Messenger of Allah, may Allah bless him and grant him peace, said, "A trusting slave does wudu and as he rinses his mouth the wrong actions leave it. As he cleans his nose the wrong actions leave it. As he washes his face, the wrong actions leave it, even from underneath his eyelashes. As he washes his hands the wrong actions leave them, even from underneath his fingernails. As he wipes his head the wrong actions leave it, even from his ears. And as he washes his feet the wrong actions leave them, even from underneath the toenails of both his feet." He added, "Then his walking to the mosque and his prayer are an extra reward for him."


Malik :: Purity :: [2-2.6.32]

Purity

Malik :: Book 2 : Hadith 2.6.32

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A muslim slave (or a trusting slave) does wudu and as he washes his face every wrong action he has seen with his eyes leaves with the water (or the last drop of water). As he washes his hands every wrong action he has done with his hands leaves with the water (orthe last drop of water). And as he washes his feet every wrong action his feet have walked to leaves with the water (or the last drop of water) so that he comes away purified of wrong actions."


Malik :: Purity :: [2-2.6.33]

Purity

Malik :: Book 2 : Hadith 2.6.33

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik said, "I saw the Messenger of Allah, may Allah bless him and grant him peace, on one occasion when the asr prayer was at hand . Everyone was looking for water for wudu but no-one could find any. Then the Messenger of Allah, may Allah bless him and grant him peace, brought some water in a vessel . He put his hand into the vessel and then he told them all to do wudu from it." Anas added, "I saw water coming out from his fingers. Then all of them to the last man did wudu."


Malik :: Purity :: [2-2.6.34]

Purity

Malik :: Book 2 : Hadith 2.6.34

Yahya related to me from Malik from Nuaym ibn Abdullah al-Madani al-Mujmir that he heard Abu Hurayra say, "If someone does wudu and does it correctly and then goes off intending to do the prayer, then he is in prayer as long as he intends to do the prayer. A good action is written for every alternate step he makes and a wrong action is erased for the second. When you hear the iqama do not lengthen your stride, and the one who has the greatest reward is the one whose house is farthest away." They said, "Why, Abu Hurayra?" He replied, "Because of the greater number of steps."


Malik :: Purity :: [2-2.6.35]

Purity

Malik :: Book 2 : Hadith 2.6.35

Yahya related to me from Malik from Yahya ibn Said that he heard someone ask Said ibn al-Musayyab about washing off excreta with water. Said said, "That is the way women wash."


Malik :: Purity :: [2-2.6.36]

Purity

Malik :: Book 2 : Hadith 2.6.36

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If a dog drinks from your vessel, wash it seven times."


Malik :: Purity :: [2-2.6.37]

Purity

Malik :: Book 2 : Hadith 2.6.37

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "Try to go straight, although you will not be able to do so. Act, and the best of your actions is the prayer. And only a mumin is constant in his wudu."


Malik :: Purity :: [2-2.7.38]

Purity

Malik :: Book 2 : Hadith 2.7.38

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used two fingers to take water to his ears.


Malik :: Purity :: [2-2.7.39]

Purity

Malik :: Book 2 : Hadith 2.7.39

Yahya related to me from Malik that he had heard that Jabir ibn Abdullah al-Ansari was asked about wiping over a turban. He said, "Not unless you have wiped over your hair with water."


Malik :: Purity :: [2-2.7.40]

Purity

Malik :: Book 2 : Hadith 2.7.40

Yahya related to me from Malik from Hisham ibn Urwa that Abu Urwa ibn az-Zubayr used to take off his turban and wipe his head with water.


Malik :: Purity :: [2-2.7.41]

Purity

Malik :: Book 2 : Hadith 2.7.41

Yahya related to me from Malik from Nafi that she saw Safiyya bint Abi Ubayd, the wife of Abdullah ibn 'Umar, take off her head-covering and wipe her head with water. Nafi was a child at the time.

Malik was asked about a man who did wudu but forgot to wipe his head until the water had dried. He said, "I consider that he should wipe his head and then repeat the prayer if he has already performed it."

Malik was asked about a man who did wudu but forgot to wipe his head until the water had dried. He said, "I consider that he should wipe his head and then repeat the prayer if he has already performed it."


Malik :: Purity :: [2-2.8.42]

Purity

Malik :: Book 2 : Hadith 2.8.42

Yahya related to me from Malik from Ibn Shihab from Abbad ibn Ziyad, a descendant of al-Mughira ibn Shuba from his father from al Mughira ibn Shuba that the Messenger of Allah, may Allah bless him and grant him peace, went to relieve himself during the expedition of Tabuk. Mughira said, "I went with him, taking water. Then the Messenger of Allah, may Allah bless him and grant him peace, came back and I poured out the water for him. He washed his hands and then went to push his hands out of the sleeves of his garment, but could not do so because of their narrowness. So he brought them out from underneath his garment. Then he washed his arms, wiped his head and wiped over his leather socks. The Messenger of Allah, may Allah bless him and grant him peace, returned and Abdar Rahman ibn Awf was leading the people in prayer, and he had already finished one raka with them. The Messenger of Allah, may Allah bless him and grant him peace, prayed the remaining raka with them to everyone's concern. When the Messenger of Allah, may Allah bless him and grant him peace, finished he said, 'You have acted correctly.' "


Malik :: Purity :: [2-2.8.43]

Purity

Malik :: Book 2 : Hadith 2.8.43

Yahya related to me from Malik that Nafi and Abdullah ibn Dinar told him that Abdullah ibn Umar arrived at Kufa and went to Sad ibn Abi Waqqas, who was the Amir of Kufa at that time. Abdullah ibn Umar saw him wiping over his leather socks and disapproved of it. So Sad said to him, "Ask your father when you get back." Abdullah returned but forgot to ask Umar about the matter until Sad arrived and said, "Have you asked your father?" and he said, "No."

Abdullah then asked Umar and Umar replied, "If your feet are ritually pure when you put them in the leather socks then you can wipe over the socks." Abdullah said ,"What about if we have just come from relieving ourselves?" Umar said, "Yes, even if you have just come from relieving yourself."


Malik :: Purity :: [2-2.8.44]

Purity

Malik :: Book 2 : Hadith 2.8.44

Yahya related to me from Malik from Nafi that Abdullah ibn Umar urinated in the market place and then did wudu, washing his face and hands and wiping his head. Then as soon as he had come into the mosque, he was called to pray over a dead person, so he wiped over his leather socks and prayed.


Malik :: Purity :: [2-2.8.45]

Purity

Malik :: Book 2 : Hadith 2.8.45

Yahya related to me from Malik that Said ibn Abd ar-Rahman ibn Ruqash said, "I saw Anas ibn Malik come and squat and urinate.Then water was brought and he did wudu. He washed his face, then his arms to the elbows, and then he wiped his head and wiped over his leather socks. Then he came to the mosque and prayed."

Yahya said that Malik was asked whether a man who did wudu for prayerand then put on his leather socks, and then urinated and took them off and put them back on again, should begin wudu afresh.

Malik replied, "He should take off his socks and wash his feet. Only someone who puts on leather socks when his feet are (already) ritually purified by wudu can wipe over them. Someone who puts on leather socks when his feet are not ritually purified by wudu, should not wipe over them."

Yahya said that Malik was asked about a man who did wudu with his leather socks on and forgot to wipe over them until the water was dry and he had prayed, and he said, "He should wipe over his socks and repeat the prayer but not repeat wudu."

Malik was asked about a man who washed his feet and put on his leather socks and then started doing wudu, and he said, "He should take off his socks and do wudu and wash his feet."


Malik :: Purity :: [2-2.9.46]

Purity

Malik :: Book 2 : Hadith 2.9.46

Yahya related to me from Malik from Hisham ibn Urwa that he saw his father wiping over his leather socks. He said, "When he wiped over his socks he would never do more than wipe the tops and he would not wipe the bottoms."


Malik :: Purity :: [2-2.9.47]

Purity

Malik :: Book 2 : Hadith 2.9.47

Yahya related to me that Malik had asked Ibn Shihab how to wipe over leather socks. Ibn Shihab had put one hand under the sock and his other hand above the sock and then passed them over it.

Yahya said that Malik said, "Out of all that I have heard about the matter I like what Ibn Shihab said the most."


Malik :: Purity :: [2-2.10.48]

Purity

Malik :: Book 2 : Hadith 2.10.48

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would leave and do wudu if he had a nose-bleed and then return and complete his prayer without saying anything.


Malik :: Purity :: [2-2.11.49]

Purity

Malik :: Book 2 : Hadith 2.11.49

Yahya related to me from Malik from Nafi that Abdullah ibn Abbas used to have nose-bleeds and would leave to wash off the blood. He would then return and complete his prayer.


Malik :: Purity :: [2-2.11.50]

Purity

Malik :: Book 2 : Hadith 2.11.50

Yahya related to me from Malik from Yazid ibn Abdullah Qusayt al-Laythi that he saw Said ibn al-Musayyab having a nose-bleed while praying. He went off to the room of Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, and water was brought to him and he did wudu. He then returned and completed his prayer.


Malik :: Purity :: [2-2.12.51]

Purity

Malik :: Book 2 : Hadith 2.12.51

Yahya related to me that Abd ar-Rahman ibn Harmala al-Aslami said, "I saw Said ibn al-Musayyab with his nose bleeding and blood poured out of it so that his fingers were all red from the blood coming out of his nose, and he prayed without doing wudu."


Malik :: Purity :: [2-2.12.52]

Purity

Malik :: Book 2 : Hadith 2.12.52

Yahya related to me from Malik from Abd ar Rahman ibn al-Mujabbar that he saw Salim ibn Abdullah with blood running from his nose so that his fingers were all coloured red. Then he rubbed it and prayed without doing wudu.


Malik :: Purity :: [2-2.13.53]

Purity

Malik :: Book 2 : Hadith 2.13.53

Yahya related to me from Hisham ibn Urwa from his father that al-Miswar ibn Makhrama told him that he had visited Umar ibn al Khattab on the night he was stabbed and had woken him up for the subh prayer and Umar had said, ''Yes. Whoever stops doing the prayer will get nothing from Islam," and he did the prayer with blood pouring from his wound.


Malik :: Purity :: [2-2.13.54]

Purity

Malik :: Book 2 : Hadith 2.13.54

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab was asked, "What do you say about someone who is afflicted by a nose-bleed which does not stop? "Malik said that Yahya ibn Said said that Said ibn al Musayyab said, "I say that he should signal with his head." (i.e. instead of doing sajda or ruku.)

Yahya said that Malik said, "That is what I like most out of what I have heard about the matter."


Malik :: Purity :: [2-2.14.55]

Purity

Malik :: Book 2 : Hadith 2.14.55

Yahya related to me from Malik from Abu'n Nadr, the mawla of Abdullah ibn Ubaydullah, from Sulayman ibn Yasar from alMiqdad ibn al-Aswad that Ali ibn Abi Talib told him to ask the Messenger of Allah, may Allah bless him and grant him peace, what a man should do, who, when close to his wife, had a flow of prostatic fluid. Ali explained that the daughter of the Messenger of Allah, may Allah bless him and grant him peace, was living with him then and he was too shy to ask for himself. Al-Miqdad said, "I asked the Messenger of Allah, may Allah bless him and grant him peace, about it, and he said, 'When you find that, wash your genitals with water and do wudu as for prayer.' "


Malik :: Purity :: [2-2.14.56]

Purity

Malik :: Book 2 : Hadith 2.14.56

Yahya related to me from Zayd ibn Aslam from his father that Umar ibn al-Khattab said, "I find it dropping from me like small beads. When you find that, wash your penis and do wudu as for prayer."


Malik :: Purity :: [2-2.14.57]

Purity

Malik :: Book 2 : Hadith 2.14.57

Yahya related to me from Malik from Zayd ibn Aslam from his father that Jundub, the mawla of Abdullah ibn Ayyash, said, "I asked Abdullah ibn Umar about prostatic fluid and he said, 'When you find it, wash your genitals and do wudu as for prayer.' "


Malik :: Purity :: [2-2.15.58]

Purity

Malik :: Book 2 : Hadith 2.15.58

Yahya related to me from Malik from Yahya ibn Said that he was listening to Said ibn al-Musayyab and a man questioned him saying, "I discover a liquid when I am praying. Should I leave?"

Said ibn al-Musayyab said to him, "Even if it were to flow on my leg I would not leave until I had finished the prayer."


Malik :: Purity :: [2-2.15.59]

Purity

Malik :: Book 2 : Hadith 2.15.59

Yahya related to me from Malik that as-Salt ibn Zuyayd said, "I asked Sulayman ibn Yasar about a liquid I discovered. He said, 'Wash what is under your garments with water and forget about it.' "


Malik :: Purity :: [2-2.16.60]

Purity

Malik :: Book 2 : Hadith 2.16.60

Yahya related to me from Malik that Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazim heard Urwa ibn az-Zubayr saying, "I went to see Marwan ibn al-Hakam and we talked about what you had to do wudu for, and Marwan said, 'You have to do wudu if you touch your penis.' Urwa said, 'I didn't know that.' Marwan ibn al-Hakam said that Busra bint Safwan had told him that she heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'If any of you touches his penis he should do wudu.' "


Malik :: Purity :: [2-2.16.61]

Purity

Malik :: Book 2 : Hadith 2.16.61

Yahya related to me from Malik from Ismail ibn Muhammad ibn Sad ibn Abi Waqqas that Musab ibn Sad ibn Abi Waqqas said, "I was holding the Book for Sad ibn Abi Waqqas and I rubbed myself. Sad said, 'Did you touch your penis?' I replied, 'Yes,' and he said, 'Get up and do wudu.' So I got up and did wudu and then returned."


Malik :: Purity :: [2-2.16.62]

Purity

Malik :: Book 2 : Hadith 2.16.62

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "If you touch your penis you have to do wudu."


Malik :: Purity :: [2-2.16.63]

Purity

Malik :: Book 2 : Hadith 2.16.63

Yahya related to me from Malik from Hisham ibn Urwa that his father used to say, "If any of you touches his penis he has to do wudu."


Malik :: Purity :: [2-2.16.64]

Purity

Malik :: Book 2 : Hadith 2.16.64

Yahya related from Malik from Ibn Shihab that Salim ibn Abdullah said, "I saw my father Abdullah ibn Umar, do ghusl and then do wudu. I said to him, 'Father, isn't ghusl enough for you?' He said, 'Of course, but sometimes I touch my penis, so I do wudu.' "


Malik :: Purity :: [2-2.16.65]

Purity

Malik :: Book 2 : Hadith 2.16.65

Yahya related to me from Malik from Nafi that Salim ibn 'Abdullah said, "I was with Abdullah ibn Umar on a journey and after the sun had risen I saw him do wudu and then pray. So I said to him, 'This isn't a prayer that you normally do. 'He said, 'After I had done wudu for the subh prayer, I touched my genitals. Then I forgot to do wudu. So I did wudu again and repeated my prayer.' "


Malik :: Purity :: [2-2.17.66]

Purity

Malik :: Book 2 : Hadith 2.17.66

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that his father Abdullah ibn Umar used to say, "A man's kissing his wife and fondling her with his hands are part of intercourse. Someone who kisses his wife or fondles her with his hand must do wudu."


Malik :: Purity :: [2-2.17.67]

Purity

Malik :: Book 2 : Hadith 2.17.67

Yahya related to me from Malik that he had heard that Abdullah ibn Masud used to say, "Wudu is necessary if a man kisses his wife."


Malik :: Purity :: [2-2.17.68]

Purity

Malik :: Book 2 : Hadith 2.17.68

Yahya related to me from Malik that Ibn Shihab used to say, "Wudu is necessary if a man kisses his wife." Nafi said that Malik said, "That is what I like most out of what I have heard."


Malik :: Purity :: [2-2.18.69]

Purity

Malik :: Book 2 : Hadith 2.18.69

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, umm al-muminin, that whenever the Messenger of Allah, may Allah bless him and grant him peace, did ghusl for major ritual impurity, he would begin by washing his hands, and then do wudu as for prayer. He would then put his fingers in the water and rub the roots of his hair with them. Then he would pour as much water as two hands can hold on to his head three times, and over the entire surface of his skin.


Malik :: Purity :: [2-2.18.70]

Purity

Malik :: Book 2 : Hadith 2.18.70

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha, umm al-muminin, that the Messenger of Allah, may Allah bless him and grant him peace, used to do ghusl for major ritual impurity from a vessel which contained a faraq.


Malik :: Purity :: [2-2.18.71]

Purity

Malik :: Book 2 : Hadith 2.18.71

Yahya related to me from Malik from Nafi that when Abdullah ibn Umar used to do ghusl for major ritual impurity he would begin by pouring water on his right hand and washing it. Then, in order, he would wash his genitals, rinse his mouth, snuff water in and out of his nose, wash his face and splash his eyes with water. Then he would wash his right arm and then his left, and after that he would wash his head. He would finish by having a complete wash and pouring water all over himself.


Malik :: Purity :: [2-2.18.72]

Purity

Malik :: Book 2 : Hadith 2.18.72

Yahya related to me from Malik that he had heard that A'isha was asked about how a woman should do ghusl for major ritual impurity. She said, "She should scoop water over her head with both hands three times and rub the roots of her hair with her hands."


Malik :: Purity :: [2-2.19.73]

Purity

Malik :: Book 2 : Hadith 2.19.73

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that Umar ibn al-Khattab and Uthman ibn Affan and A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "When the circumcised part touches the circumcised part, ghusl is obligatory."


Malik :: Purity :: [2-2.19.74]

Purity

Malik :: Book 2 : Hadith 2.19.74

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Abdullah that Abu Salamaibn Abdar-Rahman ibn Awf related that he had asked A'isha, the wife of the Prophet, may Allah bless him and grant him peace, what made ghusl obligatory. She said, "Do you know what you are like, Abu Salama? You are like a chick when it hears the cocks crowing and so crows with them. When the circumcised part passes the circumcised part, ghusl is obligatory."


Malik :: Purity :: [2-2.19.75]

Purity

Malik :: Book 2 : Hadith 2.19.75

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that Abu Musa al-Ashari came to A'isha, the wife of the Prophet, may Allah bless him and grant him peace, and said to her, "The disagreement of the companions in a matter which I hate to bring before you has distressed me." She said, "What is that? You did not ask your mother about it, so ask me." He said, "A man penetrates his wife, but becomes listless and does not ejaculate. "She said, "When the circumcised part passes the circumcised part ghusl is obligatory." Abu Musa added, "I shall never ask anyone about this after you."


Malik :: Purity :: [2-2.19.76]

Purity

Malik :: Book 2 : Hadith 2.19.76

Yahya related to me from Malik from Yahya ibn Said from Abdullah ibn Kab, the mawla of Uthman ibn Affan that Mahmud ibn Labid al-Ansari asked Zayd ibn Thabit about a man who penetrated his wife but became listless and did not ejaculate. Zayd ibn Thabit said, "He does ghusl." Mahmud said to him, "Ubayy ibn Kab used not to think that ghusl was necessary," but Zayd ibn Thabit said, "Ubayy ibn Kab drew away from that before he died."


Malik :: Purity :: [2-2.19.77]

Purity

Malik :: Book 2 : Hadith 2.19.77

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "When the circumcised part passes the circumcised part, ghusl is obligatory."


Malik :: Purity :: [2-2.20.78]

Purity

Malik :: Book 2 : Hadith 2.20.78

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar related that Umar ibn al-Khattab mentioned to the Messenger of Allah, may Allah bless him and grant him peace, that he would sometimes become junub in the night. The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Do wudu and wash your penis, and then sleep."


Malik :: Purity :: [2-2.20.79]

Purity

Malik :: Book 2 : Hadith 2.20.79

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "If you have intercourse with your wife and then wish to go to sleep before doing ghusl, do not sleep until you have done wudu as for prayer."


Malik :: Purity :: [2-2.20.80]

Purity

Malik :: Book 2 : Hadith 2.20.80

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, if he wished to sleep or eat while junub, would wash his face, and his arms to the elbows, and wipe his head. Then he would eat or sleep.

2.20 The Repetition of the Prayer by a Person in a State of Major Ritual Impurity, his Doing Ghusl, when He has Prayed without Remembering it, and his Washing his Garments.


Malik :: Purity :: [2-2.21.81]

Purity

Malik :: Book 2 : Hadith 2.21.81

Yahya related to me from Malik from Ismail ibn Abi Hakim that Ata ibn Yasar told him that the Messenger of Allah, may Allah bless him and grant him peace, said the takbir in one of the prayers and then indicated to them with his hand to stay in place. He left and then returned with traces of water on his skin.


Malik :: Purity :: [2-2.21.82]

Purity

Malik :: Book 2 : Hadith 2.21.82

Yahya related to me from Malik from Hisham ibn Urwa that Zuyayd ibn as-Salt said, "I went with Umar ibn al-Khattab to Juruf and he looked down and noticed that he had had a wet dream and had prayed without doing ghusl. He exclaimed, 'By Allah I realise that I have had a wet dream and did not know it and have not done ghusl.' So he did ghusl and washed off whatever he saw on his garment, and sprinkled with water whatever he did not see.Then he gave the adhan or the iqama and prayed in the midmorning."


Malik :: Purity :: [2-2.21.83]

Purity

Malik :: Book 2 : Hadith 2.21.83

Yahya related to me from Malik from Ismail ibn Abi Hakim from Sulayman ibn Yasar that Umar ibn al-Khattab went out early in the morning to his land in al-Juruf and found semen on his garment. He said, "I have been tried with wet dreams since I have been entrusted with governing the people." He did ghusl and washed his garment of what he saw of the semen, and then prayed after the sun had risen.


Malik :: Purity :: [2-2.21.84]

Purity

Malik :: Book 2 : Hadith 2.21.84

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Umar ibn al-Khattab led the people in the subh prayer and then went out to his land in Juruf and found semen on his clothes. He said, "Since we have been eating rich meat our veins have become fulsome." He did ghusl, washed the semen from his clothing, and did his prayer again.


Malik :: Purity :: [2-2.21.85]

Purity

Malik :: Book 2 : Hadith 2.21.85

Yahya related to me from Malik from Hisham ibn Urwa from his father fromYahyaibn Abd ar-Rahman ibn Ha ib that he had set off for Mumra with Umar ibn al-Khattab in a party of riders, among whom was Amr ibn al-As. Umar ibn al-Khattab dismounted for a rest late at night on a certain road near a certain oasis. Umar had a wet dream when it was almost dawn and there was no water among the riding party. He rode until he came to some water and then he began to wash off what he saw of the semen until it had gone. Amr ibn al-As said to him, "It is morning and there are clothes with us, so allow your garment to be washed. ''Umar ibn al-Khattab said to him, "I am surprised at you, Amr ibn al-As! Even if you could find clothes, would everybody be able to find them? By Allah, if I were to do it, it would become a sunna. No, I wash what I see, and I sprinkle with water what I do not see."

Malik spoke about a man who found traces of a wet dream on his clothes and did not know when it had occurred and did not remember anything he had seen in his sleep. He said, "Let the intention of his ghusl be from the time when he last slept, and if he has prayed since that last sleep he should repeat it. This is because often a man has a wet dream and sees nothing, and often he sees something but does not have an emission. But, if he finds liquid on his garment he must do ghusl. This is because Umar repeated what he had prayed after the time he had last slept and not what was before it."


Malik :: Purity :: [2-2.22.86]

Purity

Malik :: Book 2 : Hadith 2.22.86

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that Umm Sulayman said to the Messenger of Allah, may Allah bless him and grant him peace, "Should a woman do ghusl when she experiences the same as a man in her sleep?" The Messenger of Al lah said to her, "Yes, she should do ghusl. "A'isha said to her, "Shame on you! Does a woman see that?" (i.e. a liquid.) The Messenger of Allah, may Allah bless him and grant him peace, said to her, "May your right hand be full of dust. From where does family resemblance come?"


Malik :: Purity :: [2-2.22.87]

Purity

Malik :: Book 2 : Hadith 2.22.87

Yahya related to me from Malik from Hisham ibn Urwa from his father from Zaynab bint Abi Salama that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said, "Umm Salama, the wife of Abu Talha al-Ansari, came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah! Allah is not ashamed of the truth-does a woman have to do ghusl if she has had an erotic dream?' He said, 'Yes, if she sees any liquid.' "


Malik :: Purity :: [2-2.23.88]

Purity

Malik :: Book 2 : Hadith 2.23.88

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "There is no harm in doing ghusl with water that has been used by one's wife as long as she is not menstruating or in a state of major ritual impurity (junub)."


Malik :: Purity :: [2-2.23.89]

Purity

Malik :: Book 2 : Hadith 2.23.89

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to sweat in a garment while he was junub and then pray with it on.


Malik :: Purity :: [2-2.23.90]

Purity

Malik :: Book 2 : Hadith 2.23.90

Yahya related to me from Malik from Nafi that the slave girls of Abdullah ibn Umar used to wash his feet and bring him a mat of palm leaves while they were menstruating.

Malik was asked whether a man who had women and slavegirlscould have intercourse with all of them before he did ghusl. He said, "There is no harm in a man having intercourse with two of his slave girls before he does ghusl. It is disapproved of, however, to go to a freewoman on another's day. There is no harm in making love first to one slave girl and then to another when one is junub."

Malik was asked about a man who was junub and water was put down for him to do ghusl with.Then he forgot and put his finger into it to find out whether it was hot or cold. Malik said, "If no filth has soiled his fingers, I do not consider that that makes the water impure."


Malik :: Purity :: [2-2.24.91]

Purity

Malik :: Book 2 : Hadith 2.24.91

Yahya related to me from Malik from Abd arRahman ibn al-Qasim from his father that A'isha umm al-muminin said, "We went out on a journey with the Messenger of Allah, may Allah bless him and grant him peace, and, when we came to Bayda' or Dhat al-Jaysh, a necklace of mine broke. The Messenger of Allah, may Allah bless him and grant him peace, stopped to look for it and the people stopped with him. There was no water nearby and the people were not carrying any with them, so they came to Abu Bakr as-Siddiq and said, 'Don't you see what A'isha has done? She has made the Messenger of Allah, may Allah bless him and grant him peace, and the people stop when there is no water nearby and they are not carrying any with them.' "

A'isha continued, "Abu Bakr came and the Messenger of Allah, may Allah bless him and grant him peace, had fallen asleep with his head on my thigh . Abu Bakr said, 'You have made the Messenger of Allah, may Allah bless him and grant him peace, and the people stop when there is no water nearby and they are not carrying any with them ' "

She continued, "Abu Bakr remonstrated with me and said whatever Allah willed him to say, and began to poke me in the waist. The only thing that stopped me from moving was that the Messenger of Allah, may Allah bless him and grant him peace, had his head on my thigh. The Messenger of Allah, may Allah bless him and grant him peace, slept until morning found him with no water. Allah, the Blessed and Exalted, sent down the ayat of tayammum and so they did tayammum. Usayd ibn Hudayr said, 'This is not the first baraka from you, O family of Abu Bakr.'"

A'isha added, "We roused the camel I had been on and found the necklace under it."

Malik was asked whether a man who did tayammum for one prayer should do tayammum when the time of the next prayer came or whether the first tayammum was enough. He said, "No, he does tayammum for every prayer, because he has to look for water for every prayer. If he looks for it and does not find it then he does tayammum."

Malik was asked whether a man who did tayammum could lead others in prayer if they were in wudu. He said, "I prefer that someone else should lead them. However, I see no harm in it if he does lead them in prayer."

Yahya said that Malik said that a man who did tayammum because he could not find any water, and then stood and said the takbir and entered into the prayer, and then someone came with some water, did not stop his prayer but completed it with tayammum and did wudu for future prayers.

Yahya said that Malik said, "Whoever rises for prayer and does not find water and so does what Allah has ordered him to do of tayammum has obeyed Allah. Someone who does find water is neither purer than him nor more perfect in prayer, because both have been commanded and each does as Allah has commanded. What Allah has commanded as far as wudu is concerned is for the one who finds water, and tayammum is for the one who does not find water before he enters into the prayer."

Malik said that a man who was in a state of major ritual impurity could do tayammum and read his portion of Qur'an and do voluntary prayers as long as he did not find any water. This applied only to circumstances in which it was allowable to pray with tayammum.


Malik :: Purity :: [2-2.25.92]

Purity

Malik :: Book 2 : Hadith 2.25.92

Yahya related to me from Malik from Nafi that Abdullah ibn Umar and he were approaching Juruf. When they got to Mirbad, Abdullah got down and did tayammum with some good earth. He wiped his face, and his arms to the elbows, and then prayed.


Malik :: Purity :: [2-2.25.93]

Purity

Malik :: Book 2 : Hadith 2.25.93

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to do tayammum up to his elbows.

Malik was asked about how tayammum was done and what parts were covered and he said, "Strike the ground once for the face and once for the arms and wipe them to the elbows."


Malik :: Purity :: [2-2.26.94]

Purity

Malik :: Book 2 : Hadith 2.26.94

Yahya related to me from Malik from Abd arRahman ibn Harmala that a man asked Said ibn al-Musayyab about what a man who was junub and had done tayammum should do when he came across water. Said said, "When he comes across water he must do ghusl for what comes after."

Malik said about some one who had a wet dream while he was on a journey and there was only enough water for wudu and he was not thirsty and so he did not need to use it for that, "Let him wash his genitals, and whatever the semen has fallen on, with the water and then he does tayammum with good earth as Allah has ordered him."

Malik was asked whether a man who was junub and wished to do tayammum but could only find salty earth could do tayammum with that earth, and whether it was disapproved of to pray on salty earth. He said, "There is no harm in praying on salty earth or in using it to do tayammum, because Allah the Blessed and Exalted has said, '...and do tayammum with good earth.' One is purified by tayammum with everything that is earth, whether it is salty or otherwise."


Malik :: Purity :: [2-2.27.95]

Purity

Malik :: Book 2 : Hadith 2.27.95

Yahya related to me from Malik from Zayd ibn Aslam that a man questioned the Messenger of Allah, may Allah bless him and grant him peace, saying, "What is permitted me from my wife when she is menstruating?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Let her wrap her waist-wrapper round herself tightly, and then what is above that is your concern."


Malik :: Purity :: [2-2.27.96]

Purity

Malik :: Book 2 : Hadith 2.27.96

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that on one occasion A'isha, the wife of the Prophet, may Allah bless him and grant him peace, was sleeping with the Messenger of Allah, may Allah bless him and grant him peace, in one garment, when suddenly she jumped up sharply. The Messenger of Allah, may Allah bless him and grant him peace, said to her, "What's the matter with you? Are you losing blood?", meaning menstruating. She said, "Yes." He said, "Wrap your waist-wrapper tightly about you, and return to your sleeping-place."


Malik :: Purity :: [2-2.27.97]

Purity

Malik :: Book 2 : Hadith 2.27.97

Yahya related to me from Malik from Nafi that Ubaydullah ibn Abdullah ibn Umar sent a question to A'isha asking her, "May a man fondle his wife when she is menstruating?" She replied, "Let her wrap her waist-wrapper around her lower part and then he may fondle her if he wishes."


Malik :: Purity :: [2-2.27.98]

Purity

Malik :: Book 2 : Hadith 2.27.98

Yahya related to me from Malik that he had heard that Salim ibn Abdullah and Sulayman ibn Yasar were asked whether the husband of a menstruating woman could have sexual intercourse with her when she saw that she was pure but before she had had a ghusl. They said, "No, not until she has had a ghusl."


Malik :: Purity :: [2-2.28.99]

Purity

Malik :: Book 2 : Hadith 2.28.99

Yahya related to me from Malik from AIqama ibn Abi AIqama that his mother, the mawla of A'isha, umm al-muminin, said, "Women used to send little boxes to A'isha, umm al-muminin, with a piece of cotton cloth in each one on which was yellowness from menstrual blood, asking her about the prayer. She said to them, 'Do not be hasty until you see a white discharge." By that she meant purity from menses.


Malik :: Purity :: [2-2.28.100]

Purity

Malik :: Book 2 : Hadith 2.28.100

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his paternal aunt from the daughter of Zayd ibn Thabit that she had heard that women used to ask for lamps in the middle of the night to check their purity. She would criticise them for this saying, "Women never used to do this," i.e. in the time of the companions.


Malik :: Purity :: [2-2.28.101]

Purity

Malik :: Book 2 : Hadith 2.28.101

Malik was asked whether a woman whose period had finished could do tayammum to purify herself if she could not find waterand he said, "Yes, because she is like some one in a state of major ritual impurity, who, if he cannot find water, does tayammum."


Malik :: Purity :: [2-2.29.102]

Purity

Malik :: Book 2 : Hadith 2.29.102

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said that a pregnant woman who noticed bleeding left off from prayer.


Malik :: Purity :: [2-2.29.103]

Purity

Malik :: Book 2 : Hadith 2.29.103

Yahya related to me from Malik that he asked Ibn Shihab about a pregnant woman who noticed bleeding. Ibn Shihab replied, "She refrains from prayer."

Yahya said that Malik said, "That is what is done in our community."


Malik :: Purity :: [2-2.29.104]

Purity

Malik :: Book 2 : Hadith 2.29.104

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "I used to comb the head of the Messenger of Allah, may Allah bless him and grant him peace, while I was menstruating."


Malik :: Purity :: [2-2.29.105]

Purity

Malik :: Book 2 : Hadith 2.29.105

Yahya related to me from Malik from Hisham ibn Urwa from his father from Fatima bint al-Mundhir ibn az-Zubayr that Asma bint Abu Bakr as-Siddiq said, "A woman questioned the Messenger of Allah, may Allah bless him and grant him peace, saying, 'If menstrual blood gets onto our clothes how do you think we should deal with it?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'If menstrual blood gets onto your clothes you should wash them, and sprinkle them with water before you pray in them.' "


Malik :: Purity :: [2-2.30.106]

Purity

Malik :: Book 2 : Hadith 2.30.106

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Fatima bint Abu Hubaysh said, 'Messenger of Allah, I never become pure - am I permitted to pray?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'That is a vein, not menstruation. So when your period approaches, leave off from the prayer, and when its grip leaves, wash the blood from yourself and pray.' "


Malik :: Purity :: [2-2.30.107]

Purity

Malik :: Book 2 : Hadith 2.30.107

Yahya related to me from Malik from Nafi from Sulayman ibn Yasarfrom Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, that a certain woman in the time of the Messenger of Allah, may Allah bless him and grant him peace, used to bleed profusely, so Umm Salama consulted the Messenger of Allah, may Allah bless him and grant him peace, for her, and he said, "She should calculate the number of nights and days a month that she used to menstruate before it started happening, and she should leave off from prayerfor that much of the month. When she has completed that she should do ghusl, bind her private parts with a cloth, and then pray."


Malik :: Purity :: [2-2.30.108]

Purity

Malik :: Book 2 : Hadith 2.30.108

Yahya related to me from Malik from Hisham ibn Urwa from his father from Zaynab bint Abu Salama that she saw Zaynab bint Jahsh, the wife of Abd ar-Rahman ibn Awf, and she used to bleed as if menstruating. She would do ghusl and pray.


Malik :: Purity :: [2-2.30.109]

Purity

Malik :: Book 2 : Hadith 2.30.109

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman that al-Qaqa ibn Hakim and Zayd ibn Aslam sent him to Said ibn al-Musayyab to ask how a woman who was bleeding as if menstruating should do ghusl. Said said, "She does a ghusl to cover from the end of one period to the end of the next, and does wudu for every prayer, and if bleeding overtakes her she should bind her private parts."


Malik :: Purity :: [2-2.30.110]

Purity

Malik :: Book 2 : Hadith 2.30.110

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "A woman who bleeds as if menstruating only has to do one ghusl, and then after that she does wudu for each prayer."

Yahya said that Malik said, "The position with us is that when a woman who bleeds as if menstruating starts to do the prayer again, her husband can have sexual intercourse with her. Similarly, if a woman who has given birth sees blood after she has reached the fullest extent that bleeding normally restrains women, her husband can have sexual intercourse with her and she is in the same position as a woman who bleeds as if menstruating."

Yahya said that Malik said, "The position with us concerning a woman who bleeds as if menstruating is founded on the hadith of Hisham ibn Urwa from his father, and it is what I prefer the most of what I have heard about the matter."


Malik :: Purity :: [2-2.31.111]

Purity

Malik :: Book 2 : Hadith 2.31.111

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "An infant boy was brought to the Messenger of Allah, may Allah bless him and grant him peace, and it urinated on him. The Messenger of Allah, may Allah bless him and grant him peace, called for some water and rubbed over the urine with it."


Malik :: Purity :: [2-2.31.112]

Purity

Malik :: Book 2 : Hadith 2.31.112

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Umm Qays ibn Mihsan that she brought a baby boy of hers who was not yet eating food to the Messenger of Allah, may Allah bless him and grant him peace, and he sat it in his arms and it urinated on his garment, so the Messenger of Allah, may Allah bless him and grant him peace, called for some water and sprinkled over it but did not wash it.


Malik :: Purity :: [2-2.32.113]

Purity

Malik :: Book 2 : Hadith 2.32.113

Yahya related to me from Malik that Yahya ibn Said said, "A Bedouin came into the mosque and uncovered his private parts to urinate. The people called out to him and began to raise their voices but the Messenger of Allah, may Allah bless him and grant him peace, said ,'Let him be. 'So they let him be and he urinated. Then the Messenger of Allah, may Allah bless him and grant him peace, ordered a bucketful of water to be brought and it was poured on the place."


Malik :: Purity :: [2-2.32.114]

Purity

Malik :: Book 2 : Hadith 2.32.114

Yahya related to mefrom Malikthat Abdullah ibn Dinar said, "I saw Abdullah ibn Umar urinating while standing."

Yahya said that Malik was asked if any hadith had come down about washing the private parts of urine and faeces and he said, "I have heard that some of those who have passed away used to wash themselves of faeces. I like to wash my private parts of urine."


Malik :: Purity :: [2-2.33.115]

Purity

Malik :: Book 2 : Hadith 2.33.115

Yahya related to me from Malik from Ibn Shihab from Ibn as-Sabbaq that the Messenger of Allah, may Allah bless him and grant him peace, said in a jumua, "Muslims! Allah has made this day a festival day (id) so do ghusl, and it will not harm whoever has perfume to apply some of it, and use a tooth-stick . "


Malik :: Purity :: [2-2.33.116]

Purity

Malik :: Book 2 : Hadith 2.33.116

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Were it not that I would be overburdening my community I would have ordered them to use a tooth-stick."


Malik :: Purity :: [2-2.33.117]

Purity

Malik :: Book 2 : Hadith 2.33.117

Yahya related to me from Malik from Ibn Shihab from Humayd ibn Abdar-Rahman ibn Awf that Abu Hurayra said, "Were it not that he would be overburdening his community he (the Messenger of Allah, may Allah bless him and grant him peace,) would have ordered them to use a tooth-stick with each wudu."


Malik :: Prayer :: [3-3.1.1]

Prayer

Malik :: Book 3 : Hadith 3.1.1

Yahya related to me from Malik that Yahya ibn Said said, "The Messenger of Allah, may Allah bless him and grant him peace, had wanted to take two pieces of wood to strike them together to gather people for the prayer, and Abdullah ibn Zayd al-Ansari, then of the tribe of Harith ibn al-Khazraj, was shown two pieces of wood in his sleep. He said, 'These are close to what the Messenger of Allah, may Allah bless him and grant him peace, wants.' Then it was said, 'Do you not call to the prayer?', so when he woke up he went to the Messenger of Allah, may Allah bless him and grant him peace, and mentioned the dream to him. The Messenger of Allah, may Allah bless him and grant him peace, ordered the adhan."


Malik :: Prayer :: [3-3.1.2]

Prayer

Malik :: Book 3 : Hadith 3.1.2

Yahya related to me from Malik from Ibn Shihab from Ata ibn Yazid al-Laythi from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you hear the adhan, repeat what the muadhdhin says."


Malik :: Prayer :: [3-3.1.3]

Prayer

Malik :: Book 3 : Hadith 3.1.3

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If people knew what was in the adhan and the first row of the prayer and could only draw lots for it, they would draw lots. And if they knew what was in doing dhuhr early, they would race each other to it. And if they knew what was in isha and subh, they would go to them even if they had to crawl."


Malik :: Prayer :: [3-3.1.4]

Prayer

Malik :: Book 3 : Hadith 3.1.4

Yahya related to me from Malik from al-Ala ibn Abd ar-Rahman ibn Yaqub from his father and Ishaq ibn Abdullah that they informed him that they heard Abu Hurayra say, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'When the iqama is called for prayer, do not come to it running, but come with calmness. Pray what you catch and complete what you miss. You are in prayer as long as your aim is the prayer.' "


Malik :: Prayer :: [3-3.1.5]

Prayer

Malik :: Book 3 : Hadith 3.1.5

Yahya related to me from Malik from Abd arRahman ibn Abdullah ibn Abd ar-Rahman ibn Abu Sasaca al-Ansari, and later al-Mazini, that his father told him that Abu Said al-Khudri had said to him, "I see that you love sheep and the desert. When you are among your sheep or in your desert, call the prayer and raise your voice in the adhan, because I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'No jinn or man oranything within range hears the voice of the muadhdhin except that it bears witness for him on the day of rising.' "


Malik :: Prayer :: [3-3.1.6]

Prayer

Malik :: Book 3 : Hadith 3.1.6

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the call to prayer is made Shaytan retreats, passing wind, so that he will not hear the adhan. When the adhan is completed he comes back, until, when the iqama is said, he retreats again. When the iqama is completed, he comes back, until he comes between a man and his self and says, 'Think of such and such, think of such and such,' which he was not thinking about before, until the man does not know how much he has prayed."


Malik :: Prayer :: [3-3.1.7]

Prayer

Malik :: Book 3 : Hadith 3.1.7

Yahya related to me from Malik from Abu Hazim ibn Dinar that Sahl ibn Sad as-Saidi said, "There are two times when the gates of heaven are opened, and few who make supplication have it returned to them unanswered. They are at the timeof the adhan, and in a rank of people fighting in the way of Allah."

Malik was asked whether the adhan on the day of jumua was called before the time had come for the prayer and he said, "It is not called until after the sun has passed the meridian."

Malik was asked about doubling the adhan and the iqama, and at what point people had to stand when the iqama for the prayer was called. He said, "I have heard nothing about the adhan and iqama except what I have seen people do. As for the iqama, it is not doubled. That is what the people of knowledge in our region continue to do. As for people standing up when the iqama for the prayer is called, I have not heard of any definite point at which it is begun, and I consider it rather to be according to people's (individual) capacity, for some people are heavy and some are light, and they are not able to be as one man ."

Malik was asked about a gathering of people who wished to do the prescribed prayer calling the iqama and not the adhan, and he said, "lt is enough for them. The adhan is only obligatory in mosques where the prayer is said in congregation."

Malik was asked about the muadhdhin saying "Peace be upon you" to the imam and calling him to the prayer, and he was asked who was the first person to whom such a greeting was made. He replied, "I have not heard that this greeting occurred in the first community."

Yahya said that Malik was asked whether a muadhdhin who called the people to prayer and then waited to see if anyone would come and no one did, so he said the iqama and did the prayer by himself and then people came after he had finished, should repeat the prayer with them. Malik said, "He does not repeat the prayer, and whoever comes after he has finished should do the prayer by himself."

Yahya said that Malik was asked about a muadhdhin who called the adhan for a group of people, did voluntary prayers, and then the group of people wanted to do the prayer with some one else saying the iqama. He said, "There is no harm in that. His iqama or somebody else's are the same."

Yahya said that Malik said, "The subh prayer is still called before dawn. As for the other prayers, we believe that they should only be called after the time has started."


Malik :: Prayer :: [3-3.1.8]

Prayer

Malik :: Book 3 : Hadith 3.1.8

Yahya related to me from Malik that he had heard that the muadhdhin came to Umar ibn al-Khattab to call him to the subh prayer and found him sleeping, so he said, "Prayer is better than sleep," and Umar ordered him to put that in the adhan for subh .


Malik :: Prayer :: [3-3.1.9]

Prayer

Malik :: Book 3 : Hadith 3.1.9

Yahya related to me from Malik from his paternal uncle Abu Suhayl ibn Malik that his uncle's father said, "I recognise nothing nowadays of what I saw the people (i.e. the companions of the Messenger, may Allah bless him and grant him peace ) doing except the call to prayer."


Malik :: Prayer :: [3-3.1.10]

Prayer

Malik :: Book 3 : Hadith 3.1.10

Yahya related to me from Malik that Abdullah ibn Umar heard the iqama while he was in Baqi, so he increased his pace of walking to the mosque.


Malik :: Prayer :: [3-3.2.11]

Prayer

Malik :: Book 3 : Hadith 3.2.11

Yahya related to me from Malik from Nafi that Abdullah ibn Umar called the adhan on a cold and windy night and included the phrase, "Do the prayer in shelter." Then he said, "The Messenger of Allah, may Allah bless him and grant him peace, used to orderthe muadhdhin to say, 'Do the prayerin shelter' when it was a cold, rainy night "


Malik :: Prayer :: [3-3.2.12]

Prayer

Malik :: Book 3 : Hadith 3.2.12

Yahya related to me from Malik from Nafi that on a journey Abdullah ibn Umar did no more than the iqama, except for subh, when he called both the adhan and the iqama. Abdullah ibn Umar used to say, "The adhan is for an imam whom people join ."


Malik :: Prayer :: [3-3.2.13]

Prayer

Malik :: Book 3 : Hadith 3.2.13

Yahya related to me from Malik from Hisham ibn Urwa that his father said to him, "When you are on a journey you can, if you wish, call the adhan and the iqama, or, if you wish, the iqama and not the adhan."

Yahya said that he heard Malik say, "There is no harm in a man calling the adhan while riding."


Malik :: Prayer :: [3-3.2.14]

Prayer

Malik :: Book 3 : Hadith 3.2.14

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab used to say, "Whoever prays on waterless, desolate land - an angel prays on his right and an angel prays on his left. When he calls both the adhan and the iqama for the prayer, or calls out the iqama, angels like mountains pray behind him."


Malik :: Prayer :: [3-3.3.15]

Prayer

Malik :: Book 3 : Hadith 3.3.15

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Bilal calls the adhan whilst it is still night so eat and drink until Ibn Umm Maktum calls the adhan."


Malik :: Prayer :: [3-3.4.16]

Prayer

Malik :: Book 3 : Hadith 3.4.16

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, said, "Bilal calls the adhan in the night, so eat and drink until Ibn Umm Maktum calls the adhan." Ibn Umm Maktum was a blind man who did not call the adhan until someone said to him, "The morning has come. The morning has come."


Malik :: Prayer :: [3-3.5.17]

Prayer

Malik :: Book 3 : Hadith 3.5.17

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah from Abdullah ibn Umar that the Messengerof Allah, may Allah bless him and grant him peace, used to raise his hands to the level of his shoulders when he began the prayer and when he raised his head from the ruku he raised them in the same way, saying, "Allah hears whoever praises him, our Lord and praise belongs to You." He did not raise them in the sujud.


Malik :: Prayer :: [3-3.5.18]

Prayer

Malik :: Book 3 : Hadith 3.5.18

Yahya related to me from Malik from Ibn Shihab that AIi ibn Husayn ibn Ali ibn Abi Talib said, "The Messenger of Allah, may Allah bless him and grant him peace, used to say, 'Allah is greater' whenever he lowered himself and raised himself, and he continued to pray like that until he met Al lah ."


Malik :: Prayer :: [3-3.5.19]

Prayer

Malik :: Book 3 : Hadith 3.5.19

Yahya related to me from Malik from Yahya ibn Sa'id from Sulayman ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, used to raise his hands in the prayer.


Malik :: Prayer :: [3-3.5.20]

Prayer

Malik :: Book 3 : Hadith 3.5.20

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abdar-Rahman ibn Awf that Abu Hurayra used to lead them in prayer and would say "Allah is greater" whenever he lowered himself and raised himself. When he had finished he would say, "By Allah, I am the person whose prayer most resembles the prayer of the Messenger of Allah, may Allah bless him and grant him peace."


Malik :: Prayer :: [3-3.5.21]

Prayer

Malik :: Book 3 : Hadith 3.5.21

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar used to say "Allah is greater" in the prayer whenever he lowered himself and raised himself.

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to raise his hands to the level of his shoulders when he began the prayer and when he raised his head from the ruku he would raise them less than that.


Malik :: Prayer :: [3-3.5.22]

Prayer

Malik :: Book 3 : Hadith 3.5.22

Yahya related to me from Malik from Abu Nuaym Wahb ibn Kaysan that Jabir ibn Abdullah used to teach them the takbir in the prayer. Abu Nuaym said, "He used to tell us to say 'Allah is greater' whenever we lowered or raised ourselves."


Malik :: Prayer :: [3-3.5.23]

Prayer

Malik :: Book 3 : Hadith 3.5.23

Yahya related to me from Malik that Ibn Shihab used to say, "When a man catches the raka he says, 'Allah is greater' once, and that takbir is enough for him."

Malik added, "That is if he intended to begin the prayer by that takbir "

Malik was asked about a man who began with the imam but forgot the opening takbir and the takbir of the ruku until he had done one raka. Then he remembered that he had not said the takbir at the opening nor in the ruku,so he said the takbir in the second raka. He said, "I prefer that he start his prayer again, but if he forgets the opening takbir with the imam and says the takbir in the first ruku, I consider that enough for him if he intends by it the opening takbir."

Malik said, about some one who prayed by himself and forgot the opening takbir, "He begins his prayer afresh ."

Malik said, about an imam who forgot the opening takbir until he had finished his prayer, "I think that he should do the prayer again, and those behind him, even if they have said the takbir."


Malik :: Prayer :: [3-3.6.24]

Prayer

Malik :: Book 3 : Hadith 3.6.24

Yahya related to me from Malik from Ibn Shihab from Muhammad ibn Jubayr ibn Mutim that his father said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, recite at-Tur (Sura 52) in the maghrib prayer."


Malik :: Prayer :: [3-3.6.25]

Prayer

Malik :: Book 3 : Hadith 3.6.25

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Abdullah ibn Abbas that Umm al-Fadl bint al-Harith heard him reciting al Mursalat (sura 77) and she said to him, "My son, you have reminded me by reciting this sura that it was what I last heard the Messenger of Allah, may Allah bless him and grant him peace, recite in the maghrib prayer."


Malik :: Prayer :: [3-3.6.26]

Prayer

Malik :: Book 3 : Hadith 3.6.26

26 Yahya related to me from Malik from Abu Ubayd, the mawla of Sulayman ibn Abd alMalik, from Ubada ibn Nusayy from Qays ibn al Harith that Abu Abdullah as-Sunabihi said, "I arrived in Madina in the khalifate of Abu Bakr as-Siddiq, and I prayed maghrib behind him. He recited the umm al Qur'an and two suras from the shorter ones of the mufassal in the first two rakas. Then he stood up in the third and I drew so near to him that my clothes were almost touching his clothes. I heard him reciting the umm al-Qur'an and this ayat, 'Our Lord, do not make our hearts go astray after You have guided us, and give us mercy from Your presence. Surely You are the Giver. ' " (Sura 3 ayat 8)


Malik :: Prayer :: [3-3.6.27]

Prayer

Malik :: Book 3 : Hadith 3.6.27

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to recite in all four rakas as when he prayed alone - in every raka the umm al-Qur'an and another sura from the Qur'an. Sometimes he would recite two or three suras in one raka in the obligatory prayer. Similarly, he recited the umm al-Qur'an and two suras in the first two rakas of maghrib.


Malik :: Prayer :: [3-3.6.28]

Prayer

Malik :: Book 3 : Hadith 3.6.28

Yahya related to me from Malik from Yahya ibn Said from Adi ibn Thabit al-Ansari that al-Barra ibn Azib said, "I prayed isha with the Messenger of Allah, may Allah bless him and grant him peace, and he recited at-Tin (Sura 95) in it."


Malik :: Prayer :: [3-3.7.29]

Prayer

Malik :: Book 3 : Hadith 3.7.29

Yahya related to me from Malik from Nafi from Ibrahim ibn Abdullah ibn Hunayn from hisfatherfromAliibnAbiTalibthattheMessengerof Allah, may Allah bless him and grant him peace, forbade wearing the qassi (an Egyptian garment, stripedwithsilk),wearing gold rings, and reciting the Qur'an in ruku.


Malik :: Prayer :: [3-3.7.30]

Prayer

Malik :: Book 3 : Hadith 3.7.30

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Ibrahim ibn al Harith at-Taymi from Abu Hazim at-Tammar from al Bayadi that the Messenger of Allah, may Allah bless him and grant him peace, came out to the people while they were praying and their voices were raised in the recitation. He said, "When you pray you are talking confidentially to your Lord. So look to what you confide to Him, and do not say the Qur'an out loud so that others hear it."


Malik :: Prayer :: [3-3.7.31]

Prayer

Malik :: Book 3 : Hadith 3.7.31

Yahya related to me from Malik from Humayd at-Tawil that Anas ibn Malik said, "I stood behind Abu Bakr and Umar and Uthman and none of them used to recite 'In the name of Allah, the Merciful, the Compassionate' when they began the prayer."


Malik :: Prayer :: [3-3.7.32]

Prayer

Malik :: Book 3 : Hadith 3.7.32

Yahya related to me from Malik from his paternal uncle Abu Suhayl ibn Malik that his father said, "We heard the recitation of Umar ibn al-Khattab when we were at the home of Abu Jahmin al-Balat." (Al-Balat was a place in Madina between the mosque and the market.)


Malik :: Prayer :: [3-3.7.33]

Prayer

Malik :: Book 3 : Hadith 3.7.33

Yahya related to me from Malik from Nafi that when Abdullah ibn Umar missed anything of the prayer in which the imam recited out loud, he would stand up when the imam had said the taslim and recite what he owed out loud to himself.


Malik :: Prayer :: [3-3.7.34]

Prayer

Malik :: Book 3 : Hadith 3.7.34

Yahya related to me from Malik that Yazid ibn Ruman said, "I used to pray next to Nafi ibn Jubayr ibn Mutim and he would nudge me to prompt him while we were praying."


Malik :: Prayer :: [3-3.8.35]

Prayer

Malik :: Book 3 : Hadith 3.8.35

Yahya related to me from Malik from Hisham ibn Urwa from his father that Abu Bakr as-Siddiq prayed subh and recited suratal-Baqara in the two rak'as.


Malik :: Prayer :: [3-3.8.36]

Prayer

Malik :: Book 3 : Hadith 3.8.36

Yahya related to me from Malik from Hisham ibn Urwa that his father heard Abdullah ibn Amir ibn Rabia say, "We prayed subh behind Umar ibn al-Khattab and he recited suraYusuf (Sura 12) and surat al-Hajj (Sura 22) slowly." I (Hisham's father) said, "By Allah, then it must have been his habit to get up at the crack of dawn." He said, "Of course."


Malik :: Prayer :: [3-3.8.37]

Prayer

Malik :: Book 3 : Hadith 3.8.37

Yahya related to me from Malik from Yahya ibn Said and Rabia ibn Abi Abd arRahman from al-Qasim ibn Muhammad that al Furafisa ibn Umayral-Hanafi said, "I only learnt Sura Yusuf (Sura 12) from the recitation of it by Uthman ibn Affan in the subh prayer because of the great number of times he repeated it to us."


Malik :: Prayer :: [3-3.8.38]

Prayer

Malik :: Book 3 : Hadith 3.8.38

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to recite the first ten suras of the mufassal in the subh prayer, and on a journey he would recite the ummal-Qur'an and a sura in every raka.


Malik :: Prayer :: [3-3.9.39]

Prayer

Malik :: Book 3 : Hadith 3.9.39

Yahya related to me from Malik from al-Ala ibn Abd ar-Rahman ibn Yaqub that Abu Said, the mawla of Amir ibn Kuraz told him that the Messenger of Allah, may Allah bless him and grant him peace, called toUbayy ibn Kab while he was praying. When Ubayy had finished his prayer he joined the Messenger of Allah, may Allah bless him and grant him peace, and the Messenger of Allah put his hand upon his hand, and he was intending to leave by the door of the mosque, so the Messenger of Allah, may Allah bless him and grant him peace, said, "I hope that you will not leave the mosque until you know a sura whose like Allah has notsentdown in the Tawrah nor in the Injil nor in the Qur'an." Ubayysaid, "I began to slow down my pace in the hope of that. Then I said, 'Messenger of Allah, the sura you promised me!' He said, 'What do you recite when you begin the prayer?' I recited the Fatiha (Sura 1 ) until I came to the end of it, and the Messengerof Allah, may Allah bless him and grant him peace, said, 'It is this sura, and it is the "seven oft-repeated" and the Great Qur'an which I was given.' "


Malik :: Prayer :: [3-3.9.40]

Prayer

Malik :: Book 3 : Hadith 3.9.40

Yahya related to me from Malik from Abu Nuaym Wahb ibn Kaysan that he heard Jabir ibn Abdullah say, "Someone who prays a raka without reciting the umm al-Qur'an in it has not done the prayer except behind an imam."


Malik :: Prayer :: [3-3.10.41]

Prayer

Malik :: Book 3 : Hadith 3.10.41

Yahya related to me from Malik from al-Ala ibn Abd ar-Rahman ibn Ya'qub that he heard Abu's-Sa'ib, the mawla of Hisham ibn Zuhra, say he had heard Abu Hurayra say, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Whoever prays a prayer without reciting the umm al-Qur'an in it, his prayer is aborted, it is aborted, it is aborted, incomplete.' So I said, 'Abu Hurayra, sometimes I am behind the imam.'Hepulled my forearm and said, 'Recite it to yourself, O Persian, for I heard the Messenger of Allah, may Allah bless him and grant him peace, say that Allah the Blessed, the Exalted, said, "I have divided the prayer into two halves between me and my slave. One half of it is for Me and one half of it is for IVly slave, and My slave has what he asks." ' The Messenger of Allah, may Allah bless him and grant him peace, said, "Recite." The slave says, 'Praise be to AIIah, the Lord of theWorlds.' Allah the Blessed, the Exalted, says, 'My slave has praised Me.' The slave says, 'The Merciful, the Compassionate.' Allah says, 'My slave has spoken well of Me.' The slave says, 'Master of the Day of the Deen.' Allah says, 'My slave has glorified Me.' The slave says, 'You alone we worship and You alone we askforhelp.'Allahsays,'This ayat is between Me and My slave, and for My slave is what he asks. 'The slave says, 'Guide us in the straight Path, the Path of those whom You have blessed, not of those with whom You are angry, nor those who are in error. ' Allah says, 'These are for My slaves, and for my slave is what he asks . ' " ' "


Malik :: Prayer :: [3-3.10.42]

Prayer

Malik :: Book 3 : Hadith 3.10.42

Yahya related to me from Malik from Hisham ibn Urwa that his father used to recite behind the imam when the imam did not recite aloud.


Malik :: Prayer :: [3-3.10.43]

Prayer

Malik :: Book 3 : Hadith 3.10.43

Yahya related to me from Malik from Yahya ibn Said and from Rabia ibn Abi Abd ar Rahman that al-Qasim ibn Muhammad used to recite behind the imam when the imam did not recite aloud.


Malik :: Prayer :: [3-3.10.44]

Prayer

Malik :: Book 3 : Hadith 3.10.44

Yahya related to me from Malik from Yazid ibn Ruman that Nafi ibn Jubayr ibn Mutim used to recite behind the imam when hedid not recite aloud .

Malik said, "That is the most preferable to me of what I have heard about the matter."


Malik :: Prayer :: [3-3.11.45]

Prayer

Malik :: Book 3 : Hadith 3.11.45

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, when asked if anyone should recite behind an imam, said, "When you pray behind an imam then the recitation of the imam is enough for you and when you pray on your own you must recite." Nafi added, "Abdullah ibn 'Umar used not to recite behind the imam."

Yahya said that he heard Malik say, "The position with us is that aman recites behind the imam when the imam does not recite aloud and he refrains from reciting when the imam recites aloud."


Malik :: Prayer :: [3-3.11.46]

Prayer

Malik :: Book 3 : Hadith 3.11.46

Yahya related to me from Malik from Ibn Shihab from Ibn Ukayma al-Laythi from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, finished a prayer in which he had recited aloud and asked, "Did any of you recite with me just now?" One man said, "Yes, I did, Messenger of Allah." The Messenger of Allah, may Allah bless him and grant him peace, said, "I was saying to myself, 'Why am I distracted from the Qur'an?' " When the people heard the Messenger of Allah, may Allah bless him and grant him peace, say that, they refrained from reciting with the Messenger of Allah, may Allah bless him and grant him peace, when he recited aloud.


Malik :: Prayer :: [3-3.12.47]

Prayer

Malik :: Book 3 : Hadith 3.12.47

Yahya related to me from Malik from Ibn Shihab that Sa'id ibn al-Musayyab and Abu Salama ibn Abd ar-Rahman told him from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the imam says 'Amin', say 'Amin', for the one whose 'Amin' coincides with the 'Amin' of the angels - his previous wrong actions are forgiven him."

Ibn Shihab said, "The Messenger of Allah, may Allah bless him and grant him peace, used to say 'Aameen' (extending it)."


Malik :: Prayer :: [3-3.12.48]

Prayer

Malik :: Book 3 : Hadith 3.12.48

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, from Abu Salih as Samman, from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the imam has said, 'not of those with whom You are angry nor of those who are in error,' say 'Amin', for the previous wrong actions of the one whose utterance coincides with that of the angels, are forgiven him."


Malik :: Prayer :: [3-3.12.49]

Prayer

Malik :: Book 3 : Hadith 3.12.49

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When one of you says 'Amin' and the angels in the sky say 'Amin' so that one coincides with the other, his previous wrong actions are forgiven him."


Malik :: Prayer :: [3-3.12.50]

Prayer

Malik :: Book 3 : Hadith 3.12.50

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the imam says, 'Allah hears whoever praises Him,' say 'O Allah! Our Lord, praise be toYou, 'for the previous wrong actions done by the one whose utterance coincides with that of the angels are forgiven."


Malik :: Prayer :: [3-3.13.51]

Prayer

Malik :: Book 3 : Hadith 3.13.51

Yahya related to me from Malik from Muslim ibn Abi Maryam that AIi ibn Abd ar-Rahman al-Muawi said, "Abdullah ibn Umar saw me playing with some small pebbles in the prayer. When I finished he forbade me, saying, 'Do as the Messenger of Allah, may Allah bless him and grant him peace, did.' I said, 'What did the Messenger of Allah, may Allah bless him and grant him peace, do?' He said, 'When he sat in the prayer, he placed his right hand on his right thigh and he closed his fist and pointed his index finger, and he placed his left hand on his left thigh. That is what he used to do.' "


Malik :: Prayer :: [3-3.13.52]

Prayer

Malik :: Book 3 : Hadith 3.13.52

Yahya related to me from Malik from Abdullah ibn Dinar that he had seen Abdullah ibn Umar with a man praying at his side. When the man sat in the fourth raka, heput both feet to one side and crossed them. When Abdullah finished, he disapproved of that to him, and the man protested, "But you do the same." Abdullah ibn Umar said, "I am ill."


Malik :: Prayer :: [3-3.13.53]

Prayer

Malik :: Book 3 : Hadith 3.13.53

Yahya related to me from Malik from Sadaqa ibn Yasar that al-Mughira ibn Hakim saw Abdullah ibn Umar sit back from the two sajdas of the prayer onto the top of his feet. When he had finished, al-Mughira mentioned it to him, and Abdullah ibn Umar explained, "It is not a sunna of the prayer. I do it because I am ill."


Malik :: Prayer :: [3-3.13.54]

Prayer

Malik :: Book 3 : Hadith 3.13.54

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that Abdullah ibn Umar told him that he used to see Abdullah ibn Umar cross his legs in the sitting position of the prayer.He said, "So I did the same, and I was young at the time. Abdullah ibn Umar forbade me and said, 'The sunna of the prayer is that you keep your right foot vertical and lay your left foot down.' I said to him, 'But you do the same (as I did).' He said, 'My feet do not support me.' "


Malik :: Prayer :: [3-3.13.55]

Prayer

Malik :: Book 3 : Hadith 3.13.55

Yahya related to me from Malik from Yahya ibn Said that al-Qasim ibn Muhammad showed them how to sit in the tashahhud, and he kept his right foot vertical and laid his left foot down, and sat on his left haunch not on his foot. Then he said, "Abdullah ibn Abdullah ibn Umar saw me doing this and related to me that his father used to do the same thing."


Malik :: Prayer :: [3-3.14.56]

Prayer

Malik :: Book 3 : Hadith 3.14.56

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from Abd ar-Rahman ibn Abd al-Qari that he heard Umar ibn al-Khattab say, while he was teaching people the tashahhud from the mimbar, "Say, Greetings belong to Allah. Pure actions belong to Allah. Good words and prayers belong to Allah. Peace on you, Prophet, and the mercy of Allah and His blessings. Peace be upon us and on the slaves of Allah who are salihun. I testify that there is no god except Allah. And I testify that Muhammad is His slave and His messenger."

'At-tahiyatu lillah, az-zakiyatu lillah, at-tayibatu wa's-salawatu lillah. As-salamu alayka ayyuha'nnabiyyu wa rahmatu'llahi wa barakatuhu. As-salamu alayna wa ala ibadi'llahi s-salihin. Ash-hadu an la ilaha illa 'llah wa ash-hadu anna Muhammadan abduhu wa rasuluh."


Malik :: Prayer :: [3-3.14.57]

Prayer

Malik :: Book 3 : Hadith 3.14.57

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say the tashahhud saying, "In the name of Allah. Greetings belong to Allah. Prayers belong to Allah. Pure actions belong to Allah. Peace be on the Prophet and the mercy of Allah and His blessings. Peace be on us and on the slaves of Allah who are salihun. I testify that there is no god except Allah. I testify that Muhammad is the Messenger of Allah."

"Bismillah, at-tahiyatu lillah, as-salawatu lillah, az-zakiyatu lillah. As-salamu ala'n-nabiyyi wa rahmatullahi wa barakatuhu. As-salamu alayna wa ala ibadi'llahi's-salihin. Shahidtu an la ilaha illallah. Shahidtu anna Muhammadu'r-rasulu'llah."

He used to say this after the first two rakas and he would make supplication with whatever seemed fit to him when the tashahhud was completed. When he sat at the end of the prayer, he did the tashahhud in a similar manner, except that after the tashahhud he made supplication with whatever seemed fit to him. When he had completed the tashahhud and intended to say the taslim, he said, "Peace be on the Prophet and His mercy and blessings. Peace be upon us and on the slaves of Allah who are salihun."

"As-salamu ala'n-nabiyyi wa rahmatu'llahi wa barakatuhu. As-salamu alayna wa ala ibadi'llahi'ssalihin ."

He then said, "Peace be upon you" to his right, and would return the greeting to the imam, and if anyone said "Peace be upon you" from his left he would return the greeting to him.


Malik :: Prayer :: [3-3.14.58]

Prayer

Malik :: Book 3 : Hadith 3.14.58

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say in the tashahhud, "Greetings, good words, prayers, pure actions belong to Allah. I testify that there is no god except Allah, alone without partner, and that Muhammad is His slave and His Messenger. Peace be on you, Prophet, and the mercy of Allah and His blessings. Peace be on us and on the slaves of Allah who are salihun. Peace be upon you."

"At-tahiyatu, at-tayibatu, as-salawatu, az-zakiyatu lillah. Ash-hadu an la ilaha illa'llah, wahdahu la sharika lah wa anna Muhammadan abduhu wa rasuluhu. As-salamu alayka ayyuha-n-nabiyyu wa rahmatu-llahi wa barakatuhu. As-salamu alayna wa ala ibadi-llahi's-salihin. As-salamu alaykum."


Malik :: Prayer :: [3-3.14.59]

Prayer

Malik :: Book 3 : Hadith 3.14.59

Yahya related to me from Malik from Yahya ibn Said al-Ansari that al-Qasim ibn Muhammad ibn Muhammad told him that A'isha, the wife of the prophet, may Allah bless him and grant him peace, used to say in the tashahhud, "Greetings, good words, prayers, pure actions belong to Allah. I testify that there is no god except Allah, alone without partner, and I testify that Muhammad is the slave of Allah and His Messenger. Peace be upon you, Prophet, and the mercy of Allah and His blessings. Peace be upon us and on the slaves of Allah who are salihun . Peace be upon you . "

"At-tahiyatu, at-tayibatu, as-salawatu, az-zakiyatu lillah. Ash-hadu an la ilaha illa'llah, wahdahu la sharika llah wa ash-hadu anna Muhammadan abduhu wa rasuluhu. As-salamu alayka ayyuha-n-nabiyyu wa rahmatu-llahi wa barakatuhu. As-salamu alayna wa ala ibadi-llahi's-salihin. As-salamu alaykum."


Malik :: Prayer :: [3-3.14.60]

Prayer

Malik :: Book 3 : Hadith 3.14.60

Yahya related to me from Malik that he asked Ibn Shihab and Nafi, the mawla of Ibn Umar, whether a man who joined an imam who had already done a raka should say the tashahhud with the imam in the second and fourth rakas, even though these were odd for him? They said, "He should say tashahhud with him."

Malik said, "That is the position with us."


Malik :: Prayer :: [3-3.15.61]

Prayer

Malik :: Book 3 : Hadith 3.15.61

Yahya related to me from Malik from Muhammad ibn Amr ibn AIqama from Malik ibn Abdullah as-Sadi that Abu Hurayra said, "The one who raises his head and lowers it before the imam - his forelock is in the hand of a shaytan."

Malik said, concerning someone who forgot and raised his head before the imam in ruku or sujud, "The sunna of that is to return to bowing or prostrating and not to wait for the imam to come up. What he has done is a mistake, because the Messenger of Allah, may Allah bless him and grant him peace, said, 'The imam is appointed to be followed as a leader, so do not oppose him.' Abu Hurayra said, 'The one who raises his head and lowers it before the imam - his forelock is in the hand of a shaytan.' "


Malik :: Prayer :: [3-3.16.62]

Prayer

Malik :: Book 3 : Hadith 3.16.62

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani from Muhammad ibn Sirin from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, finished the prayer after two rakas and Dhu'l-Yadayn said to him, "Has the prayer been shortened or have you forgotten, Messenger of Allah?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Has Dhu'l-Yadayn spoken the truth?" The people said, "Yes," and the Messenger of Allah, may Allah bless him and grant him peace, stood and prayed the other two rakas and then said, "Peace be upon you." Then he said, "Allah is greater" and went into a sadja as long as his usual prostrations or longer. Then he came up and said, "Allah is greater" and went into a sajda as long as his usual prostrations or longer and then came up.


Malik :: Prayer :: [3-3.16.63]

Prayer

Malik :: Book 3 : Hadith 3.16.63

Yahya related to me from Malik from Da'ud ibn al-Husayn that Abu Sufyan, the mawla of Ibn Abi Ahmad, said that he heard Abu Hurayra say, "The Messenger of Allah, may Allah bless him and grant him peace, prayed asr and said the taslim after two rakas. Dhu'l-Yadayn stood up and said, 'Has the prayer been shortened, Messenger of Allah, or have you forgotten?' The Messenger of Allah, may Allah bless him and grant him peace, stood up and completed what remained of the prayer, and then, remaining sitting after saying the taslim, he made two prostrations."


Malik :: Prayer :: [3-3.16.64]

Prayer

Malik :: Book 3 : Hadith 3.16.64

Yahya related to me from Malik from Ibn Shihab that Abu Bakr ibn Sulayman ibn Abi Hathma said, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, prayed two rakas of one of the two day-ti me prayers, dhuhr or asr, and said the taslim after two rakas. Dhu'sh-Shamalayn said to him, 'Has the prayer been shortened, Messenger of Allah, or have you forgotten?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'The prayer has not been shortened and I have not forgotten.' Dhu'shShamalayn said, 'It was certainly one of those, Messenger of Allah.' The Messenger of Allah, may Allah bless him and grant him peace, approached the people and said, 'Has Dh u'sh-Shamalayn spoken the truth?' They said, 'Yes, Messenger of Allah,' and the Messenger of Allah, may Allah bless him and grant him peace, completed what remained of the prayer, and then said, 'Peace be upon you.' "


Malik :: Prayer :: [3-3.16.65]

Prayer

Malik :: Book 3 : Hadith 3.16.65

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab, and from Abu Salama ibn Abd ar-Rahman, the same as that.

Malik said, "Every forgetfulness which decreases from the prayer, prostrations for it come before the greeting, and every forgetfulness which is an addition to the prayer, prostrations for it come after the greeting."


Malik :: Prayer :: [3-3.17.66]

Prayer

Malik :: Book 3 : Hadith 3.17.66

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "If you are uncertain in the prayer and do not know whether you have prayed three or four rakas, then pray a raka and make two prostrations from the sitting position before the taslim. If the raka that you prayed was the fifth, then you make it even by these two sajdas, and if it was the fourth, then the two prostrations spite Shaytan."


Malik :: Prayer :: [3-3.17.67]

Prayer

Malik :: Book 3 : Hadith 3.17.67

Yahya related to me from Malik from Umar ibn Muhammad ibn Zayd from Salim ibn Abdullah that Abdullah ibn Umar used to say, "If you are uncertain in the prayer, estimate what you think you have forgotten of the prayer and repeat it, then do the two sajdas of forgetfulness from the sitting position."


Malik :: Prayer :: [3-3.17.68]

Prayer

Malik :: Book 3 : Hadith 3.17.68

Yahya related to me from Malik from Afif ibn Amr as-Sahmi that Ata ibn Yasar said, "I asked Abdullah ibn Amr ibn al-As and Kab al Ahbar about someone who was uncertain in his prayer, and did not know whether he had prayed three or four rakas. Both of them said, 'He should pray another raka and then do two sajdas from the sitting position.' "


Malik :: Prayer :: [3-3.17.69]

Prayer

Malik :: Book 3 : Hadith 3.17.69

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, when questioned about forgetfulness in the prayer, said, "If you think that you have forgotten part of the prayer, then pray it."


Malik :: Prayer :: [3-3.18.70]

Prayer

Malik :: Book 3 : Hadith 3.18.70

Yahya related to me from Malik from Ibn Shihab from al-Araj that Abdullah ibn Buhayna said, "The Messenger of Allah, may Allah bless him and grant him peace, prayed two rakas with us and then stood without sitting and the people stood with him. When he had finished the prayerand we had seen him say the taslim, he said 'Allah is greater' and did two sajdas from the sitting position and then said the taslim again."


Malik :: Prayer :: [3-3.18.71]

Prayer

Malik :: Book 3 : Hadith 3.18.71

Yahya related to me from Malik from Yahya ibn Said from Abd ar-Rahman ibn Hurmuz that Abdullah ibn Buhayna said, "The Messengerof Allah, may Allah bless him and grant him peace, prayed dhuhr with us and he stood straight up after two rakas without sitting. When he had finished the prayer, he did two sajdas and then said the taslim after that."

Malik said, concerning someone who forgot in his prayer and stood up after he had completed four rakas and recited and then went into ruku and then, when he raised his head from ruku, remembered that he had already completed (his prayer), "He returns to a sitting position and does not do any sajda. If he has already done one sajda I do not think he should do the other. Then when his prayer is finished he does two sajdas from the sitting position after saying the taslim."


Malik :: Prayer :: [3-3.19.72]

Prayer

Malik :: Book 3 : Hadith 3.19.72

Yahya related to me from Malik from AIqama ibn Abi AIqama from his mother that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Abu Jahm ibn Hudhayfa gave the Messenger of Allah, may Allah bless him and grant him peace, a fine striped garment from Syria and he did the prayer in it. When he had finished he said, 'Give this garment back to Abu Jahm. I lookedat its stripes in the prayer and they almost distracted me.' "


Malik :: Prayer :: [3-3.19.73]

Prayer

Malik :: Book 3 : Hadith 3.19.73

Malik related to me from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, wore a fine striped garment f rom Syria, and then gave it to Abu Jahm and took a plain, rough, garment in return. Abu Jahm asked, "Messenger of Allah! Why?" He said, "I looked at its stripes in the prayer."


Malik :: Prayer :: [3-3.19.74]

Prayer

Malik :: Book 3 : Hadith 3.19.74

Malik related to me from Abdullah ibn Abi Bakr that Abu Talha al-Ansari was praying in his garden when a wild pigeon flew in and began to fly to and fro trying to find a way out. The sight was pleasing to him and he let his eyes follow the bird for a time and then he went back to his prayer but could not remember how much he had prayed. He said, "A trial has befallen me in this property of mine." So he came to the Messenger of Allah, may Allah bless him and grant him peace, and mentioned the trial that had happened to him in his garden and said, "Messenger of Allah, it is a sadaqa for Allah, so dispose of it wherever you wish."


Malik :: Prayer :: [3-3.19.75]

Prayer

Malik :: Book 3 : Hadith 3.19.75

Yahya related to me from Malik from Abdullah ibn Abi Bakr that a man from the Ansar was praying in a garden of his in Quff, one of the valleys of Madina, during the date season and the palms' branches were weighed down with fruit on all sides. He looked at them and what he saw of their fruits amazed him. Then he went back to his prayer and he did not know how much he had prayed. He said, "A trial has befallen me in this property of mine." So he went toUthman ibn Affan, who was the khalifa at the time, and mentioned it to him and said, "It is sadaqa, so give it away in the paths of good." Uthman ibn Affan sold it for fifty thousand and so that property became known as the Fifty.


Malik :: Forgetfulness in Prayer :: [4-4.1.1]

Forgetfulness in Prayer

Malik :: Book 4 : Hadith 4.1.1

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abdar-Rahman ibn Awf from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you stand in prayer, Shaytan comes to you and confuses you until you do not know how much you have prayed. If you find that happening do two sajdas from the sitting position."


Malik :: Forgetfulness in Prayer :: [4-4.1.2]

Forgetfulness in Prayer

Malik :: Book 4 : Hadith 4.1.2

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "I forget or I am made to forget so that I may establish the sunna."


Malik :: Forgetfulness in Prayer :: [4-4.1.3]

Forgetfulness in Prayer

Malik :: Book 4 : Hadith 4.1.3

Yahya related to me from Malik that he had heard that a man questioned al-Qasim ibn Muhammad saying, "My imagination works in the prayer, and it happens to me a lot." Al-Qasim ibn Muhammad said, "Go on with your prayer, for it will not goaway from you until you goaway saying, 'I have not completed my prayer.' "


Malik :: Jumu'a :: [5-5.1.1]

Jumu'a

Malik :: Book 5 : Hadith 5.1.1

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, from Abu Salih as-Sammani from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If someone does ghusl for major ritual impurity on the day of jumua and then goes in the first part of the time, it is as if he had offered up a camel. If he goes in the second part of the time, it is as if he had offered up a cow. If he goes in the third part of the time, it is as if he had offered up a horned ram. If he goes in the fourth part of the time, it is as if he had offered up a hen. If he goes in the fifth part of the time, it is as if he had offered up an egg. And when the imam comes out, the angels settle down listening to the dhikr (remembrance of Allah)."


Malik :: Jumu'a :: [5-5.1.2]

Jumu'a

Malik :: Book 5 : Hadith 5.1.2

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi that Abu Hurayra used to say, "Doing ghusl as prescribed for major ritual impurity is incumbent (wajib) on the day of jumua on every male who has reached puberty."


Malik :: Jumu'a :: [5-5.1.3]

Jumu'a

Malik :: Book 5 : Hadith 5.1.3

Yahya related to me from Malik from Ibn Shihab that Salim ibn Abdullah said, "One of the companions of the Messenger of Allah, may Allah bless him and grant him peace, came into the mosque on the day of jumua and Umar ibn al Khattab was already giving the khutba. Umar said, 'What (kind of) time is this (to arrive)?' He said, Amir al-muminin, I returned from the market and heard the call to prayer, so I did no more than do wudu.' Umar said, 'You only did wudu as well? You know that the Messenger of Allah, may Allah bless him and grant him peace, used to tell people to do ghusl.' "


Malik :: Jumu'a :: [5-5.1.4]

Jumu'a

Malik :: Book 5 : Hadith 5.1.4

Yahya related to me from Malik from Safwan ibn Sulaym from Ata ibn Yasar from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, said, "Ghusl on the day of jumua is incumbent on every male who has reached puberty."


Malik :: Jumu'a :: [5-5.1.5]

Jumu'a

Malik :: Book 5 : Hadith 5.1.5

Yahya related to me from Malik from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you come to jumua, do ghusl."

Malik said, "It is not enough for someone to do a ghusl on the day of jumua and intend by it the ghusl for jumua unless he does the ghusl and then sets off. That is because the Messenger of Allah, may Allah bless him and grant him peace, said in the hadith related by Ibn Umar, 'When you come to jumua, do ghusl .' "

Malik said, "If someone does ghusl on the day of jumua and intends by it the ghusl of the day of jumua and then sets out, whether early or late, and does something which breaks his wudu, he only has to do wudu and his ghusl remains valid for him."


Malik :: Jumu'a :: [5-5.2.6]

Jumu'a

Malik :: Book 5 : Hadith 5.2.6

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Even saying to your companion 'Listen' while the imam is giving the khutba on the day of jumua, is to speak foolishly."


Malik :: Jumu'a :: [5-5.2.7]

Jumu'a

Malik :: Book 5 : Hadith 5.2.7

Yahya related to me from Malik from Ibn Shihab that Thalaba ibn Abi Malik al Quradhi informed him that in the time of Umar ibn al Khattab they used to pray on the day of jumua until Umar came out, and when Umar came out and sat on the mimbar and the muadhdhins called the adhan, they would sit and talk, and then when the muadhdhins were silent and Umar stood to give the khutba, they would pay attention and no-one would speak .

Ibn Shihab said, "The imam coming out stops prayer and his speaking stops conversation."


Malik :: Jumu'a :: [5-5.2.8]

Jumu'a

Malik :: Book 5 : Hadith 5.2.8

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah, from Malik ibn Abi Amir that Uthman ibn Affan used to say in khutbas, and he would seldom omit it if he was giving the khutba, "When the imam stands delivering the khutba on the day of jumua, listen and pay attention, for there is the same portion for someone who pays attention but cannot hear as for someone who pays attention and hears. And when the iqama of the prayer is called, straighten your rows and make your shoulders adjacent to each other, because the straightening of the rows is part of the completion of the prayer." Then he would not say the takbir until some men who had been entrusted with straightening the rows came and told him that they were straight. Then he would say the takbir.


Malik :: Jumu'a :: [5-5.2.9]

Jumu'a

Malik :: Book 5 : Hadith 5.2.9

Yahya related to me from Malik from Nafi that Abdullah ibn Umar saw two men talking while the imam was giving the khutba on the day of jumua and he threw pebbles at them to tell them to be quiet.


Malik :: Jumu'a :: [5-5.2.10]

Jumu'a

Malik :: Book 5 : Hadith 5.2.10

Yahya related to me from Malik that he had heard that a man sneezed on the day of jumua while the imam was giving the khutba, and a man by his side asked Allah to bless him. Said ibn al Musayyab was asked about it and he forbade the man to do what he had done and said, "Don't do it again."


Malik :: Jumu'a :: [5-5.2.11]

Jumu'a

Malik :: Book 5 : Hadith 5.2.11

Yahya related to me from Malik that he asked Ibn Shihab about talking in the jumua after the imam had come down from the mimbar but before he had said the takbir. Ibn Shihab said, "There is no harm in that."


Malik :: Jumu'a :: [5-5.3.12]

Jumu'a

Malik :: Book 5 : Hadith 5.3.12

Yahya related to me from Malik that Ibn Shihab used to say, "Some one who catches a raka of the jumua prayer should pray another one with it." Ibn Shihab said, "That is the sunna."

Malik said, "I saw the people of knowledge in our city doing that. That is because the Messenger of Allah, may Allah bless him and grant him peace, said, 'Whoever catches a raka of the prayer has caught the prayer.' "

Malik said, concerning some one who was in a crowd on the day of jumua and did the ruku but was not able to go into sajda until the imam had risen or finished his prayer, "If he is able to do the sajda and has already done the ruku then he should do the sajda when the people stand up. If he is unable to do thesajda until after the imam has finished the prayer, then I prefer that he begins the prayeragain and does the four rakas of dhuhr."


Malik :: Jumu'a :: [5-5.4.13]

Jumu'a

Malik :: Book 5 : Hadith 5.4.13

Malik said, "Someone who has a nosebleed on the day of jumua while the imam is giving the khutba and he leaves and does not come back until the imam has finished the prayer, should pray four rakas.''

Malik said that someone who prayed a raka with the imam on the day of jumua, then had a nosebleed and left and came back and the imam had prayed both rakas, should complete the prayer with another raka as long as he had not spoken.

Malik said, "If some one has a nosebleed, or something happens to him and he has no alternative but to leave, he does not have to ask permission of the imam if he wants to leave on the day of jumua."


Malik :: Jumu'a :: [5-5.5.14]

Jumu'a

Malik :: Book 5 : Hadith 5.5.14

Yahya related to me from Malik that he had asked Ibn Shihab about the word of Allah, the Majestic, the Mighty, "O you who accept, when the call is made for the prayer on the day of jumua, make haste to the remembrance of Allah."(Sura 62 ayat 9). Ibn Shihab said, ''Umar ibn al-Khattab used to recite, 'When the call is made for the prayer on the day of jumua, go to the remembrance of Allah.' "

Malik said, "Making haste in the Book of Allah is only deed and action. Allah the Blessed, the Exalted, says 'and when he turns away, he acts in the land' (Sura 2 ayat 205), and He, the Exalted, said, 'and as for the one who comes to you acting with fear' (Sura 80 ayat 8), and He said, 'then he turned his back, and acted' (Sura 79 ayat 22),and He said, 'Your deeds are diverse' " (Sura 92 ayat 4). Malik said, "Thus making haste which Allah mentions in His Book is not running on the feet or exertion. It only means deed and actions."


Malik :: Jumu'a :: [5-5.6.15]

Jumu'a

Malik :: Book 5 : Hadith 5.6.15

Malik said, "If the imam stops off on a journey in a town where jumua is obligatory and he gives a khutba and takes the jumua prayer for them, then the people of the town and any other people present do the jumua prayer with him."

Malik said, "If the imam gathers people for prayer while he is travelling in a town where the jumua prayer is not obligatory, then there is no jumua for him, nor for the people of the town, nor for anyone else who joins them for the prayer in congregation, and the people of the town and anyone else who is not travelling should complete the prayer."

Malik added, "A traveller does not have to do jumua "


Malik :: Jumu'a :: [5-5.7.16]

Jumu'a

Malik :: Book 5 : Hadith 5.7.16

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, mentioned the day of jumua and said, "There is a time in it when Allah gives to a muslim slave standing in prayer whatever he asks for," and the Messenger of Allah, may Allah bless him and grant him peace, indicated with his hand how small it was.


Malik :: Jumu'a :: [5-5.7.17]

Jumu'a

Malik :: Book 5 : Hadith 5.7.17

Yahya related to me from Malik from Yazid ibn Abdullah ibn al-Had from Muhammad ibn Ibrahim ibn al-Harith at-Taymi from Abu Salama ibn Abd ar-Rahman ibn Awf that Abu Hurayra said, "I went out to at-Tur (Mount Sinai) and met Kab al Ahbar and sat with him. He related to me things from the Tawrah and I related to him things from the Messenger of Allah, may Allah bless him and grant him peace. Among the things I related to him was that the Messenger of Allah, may Allah bless him and grant him peace, said, 'The best of days on which the sun rises is the day of jumua. In it Adam was created, and in it he fell from the Garden. In it he was forgiven, and in it he died. In it the Hour occurs, and every moving thing listens from morning till sunset in apprehension of the Hour except jinn and men. In it is a time when Allah gives toa muslim slave standing in prayer whatever he asks for.' Kab said, 'That is one day in every year.' I said, 'No, in every jumua.' Then Kab recited the Tawrah and said, 'The Messenger of Allah has spoken the truth.' "

Abu Hurayra continued, "I met Basra ibn Abi Basra al-Ghiffari and he said, 'Where have you come from?' I said, 'From at-Tur.' He said, 'If I had seen you before you left, you would not have gone. I heard the Messenger of Allah, may Allah bless him and grant him peace, say, "Only make a special journey to three mosques: the mosque of the Haram (Makka), this mosque (Madina), and the mosque of Ilya or the Bait al-Maqdis (two names of Jerusalem)." ' " (He was not sure which expression was used.)

Abu Hurayra continued, "Then I met Abdullah ibn Salam and I told him that I had sat with Kabal-Ahbar, and I mentioned what I had related to him about the day of jumua, and told him that Kab had said, 'That is one day in every year.' Abdullah ibn Salam said, 'Kab lied,' and I added, 'Kab then recited the Tawrah and said, "No, it is in every jumua.'' ' Abdullah ibn Salam said, 'Kab spoke the truth. 'Then Abdullah ibn Salam said, 'I know what time that is.' "

Abu Hurayra continued, "I said to him, 'Let me know it - don't keep it from me.' Abdullah ibn Salam said, 'It is the last period of time in the dayof jumua.' "

Abu Hurayra continued, "I said, 'How can it be the last period of time in the day of jumua, when the Messenger of Allah, may Allah bless him and grant him peace, said, "a muslim slave standing in prayer", and that is a time when there is no prayer?' Abdullah ibn Salam replied, 'Didn't the Messenger of Allah, may Allah bless him and grant him peace, say, "Whoever sits waiting for the prayer is in prayer until he prays?" "'

Abu Hurayra added, "I said, 'Of course.' He said, 'Then it is that.' "


Malik :: Jumu'a :: [5-5.8.18]

Jumu'a

Malik :: Book 5 : Hadith 5.8.18

Yahya related to me from Malik from Yahya ibn Said that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is nothing wrong in wearing two garments which are not work-clothes for jumua."


Malik :: Jumu'a :: [5-5.8.19]

Jumu'a

Malik :: Book 5 : Hadith 5.8.19

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would never go to jumua without wearing oil and perfume except when it was forbidden (i.e. when he was muhrim).


Malik :: Jumu'a :: [5-5.8.20]

Jumu'a

Malik :: Book 5 : Hadith 5.8.20

Yahya related to me from Malik from Nafi from Abdullah ibn Abi Bakr ibn Hazm from whoever related it to him that Abu Hurayra used to say, "It is better for a man to pray on the surface of al Harra (a rocky area in Madina) than for him to wait until the imam stands to give the khutba and then come and step over people's necks."

Malik said, "The sunna with us is that the people face the imam on the day of jumua when he intends to give the khutba, whether they are near the qibla or elsewhere."


Malik :: Jumu'a :: [5-5.9.21]

Jumu'a

Malik :: Book 5 : Hadith 5.9.21

Yahya related to me from Malik from Damra ibn Said al-Mazini from Ubaydullah ibn Abdullah ibn Utba ibn Masud that ad-Dahhak ibn Qays asked an-Numan ibn Bashir, "What did the Messenger of Allah, may Allah bless him and grant him peace, use to recite on the day of jumua after suratal-Jumua (Sura 62)?" He said, "He used to recite al-Ghashiya (Sura 88)."


Malik :: Jumu'a :: [5-5.9.22]

Jumu'a

Malik :: Book 5 : Hadith 5.9.22

Yahya related to me from Malik that Safwan ibn Sulaym said, "If anyone omits jumua three times without reason or illness, Allah will set a seal on his heart." (Malik said, "I don't know if it was from the Messenger of Allah, may Allah bless him and grant him peace, or not.")


Malik :: Jumu'a :: [5-5.9.23]

Jumu'a

Malik :: Book 5 : Hadith 5.9.23

Yahya related to me from Malik from Jafar ibn Muhammad from his father that the Messenger of Allah, may Allah bless him and grant him peace, gave two khutbas on the day of jumua and sat down between them.


Malik :: Prayer in Ramadan :: [6-6.1.1]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.1.1

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, prayed in the mosque one night and people prayed behind him. Then he prayed the next night and there were more people. Then they gathered on the third or fourth night and the Messenger of Allah, may Allah bless him and grant him peace, did not come out to them. In the morning, he said, "I saw what you were doing and the only thing that prevented me from coming out to you was that I feared that it would become obligatory (fard) for you." This happened in Ramadan.


Malik :: Prayer in Ramadan :: [6-6.1.2]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.1.2

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abd ar-Rahman ibn Awf from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, used to exhort people to watch the night in prayer in Ramadan but never ordered it definitely. He used to say, "Whoever watches the night in prayer in Ramadan with trust and expectancy, will be forgiven all his previous wrong actions."

Ibn Shihab said, "The Messenger of Allah, may Allah bless him and grant him peace, died while that wasstill the custom, and it continued to be the custom in the khalifate of Abu Bakr and at the beginning of the khalifate of Umar ibn al-Khattab."


Malik :: Prayer in Ramadan :: [6-6.2.3]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.3

Malik related to me from Ibn Shihab from Urwa ibn az-Zubayr that Abd ar-Rahman ibn Abd al-Qari said, "I went out with Umar ibn alKhattab in Ramadan to the mosque and the people there were spread out in groups. Some men were praying by themselves, whilst others were praying in small groups. Umar said, 'By Allah! It would be better in my opinion if these people gathered behind one reciter.' So he gathered them behind Ubayy ibn Kab. Then I went out with him another night and the people were praying behind their Qur'an reciter. Umar said, 'How excellent this new way is, but what you miss while you are asleep is better than what you watch in prayer.' He meant the end of the night, and people used to watch the beginning of the night in prayer."


Malik :: Prayer in Ramadan :: [6-6.2.4]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.4

Yahya related to me from Malik from Muhammad ibn Yusuf that as-Sa'ib ibn Yazid said, "Umar ibn al-Khattab ordered Ubayy ibn Kab and Tamim ad-Dari to watch the night in prayer with the people for eleven rakas.The reciterof the Qur'an would recite the Mi'in (a group of medium-sized suras) until we would be leaning on our staffs from having stood so long in prayer. And we would not leave until the approach of dawn."


Malik :: Prayer in Ramadan :: [6-6.2.5]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.5

Yahya related to me from Malik that Yazid ibn Ruman said, "The people used to watch the night in prayer during Ramadan for twenty-three rakas in the time of Umar ibn al-Khattab."


Malik :: Prayer in Ramadan :: [6-6.2.6]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.6

Yahya related to me from Malik from Da'ud ibn al-Husayn that he heard al-Araj say, "I never saw the people in Ramadan, but that they were cursing the disbelievers." He added, "The reciter of Qur'an used to recite surat al-Baqara in eight rakas and if he did it in twelve rakas the people would think that he had made it easy."


Malik :: Prayer in Ramadan :: [6-6.2.7]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.7

Yahya related to me from Malik that Abdullah ibn Abi Bakr said, "I heard my father say, 'We finished praying in Ramadan and the servants hurried with the food, fearing the approach of dawn.' "


Malik :: Prayer in Ramadan :: [6-6.2.8]

Prayer in Ramadan

Malik :: Book 6 : Hadith 6.2.8

Yahya related to me from Malik from Hisham ibn Urwa from his father that Dhakwan Abu Amr (a slave belonging to A'isha, the wife of the Prophet, may Allah bless him and grant him peace, who was freed by her after her death) used tostand in prayer and recite for her in Ramadan.


Malik :: Tahajjud :: [7-7.1.1]

Tahajjud

Malik :: Book 7 : Hadith 7.1.1

Yahya related to me from Malik from Muhammad ibn al-Munkadir from Said ibn al-Jubayr that a man who has approval (as a relater of hadith), told him that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "If a man prays in the night and sleep overcomes him during it, Allah writes for him the reward of his prayer, and his sleep is sadaqa for him."


Malik :: Tahajjud :: [7-7.1.2]

Tahajjud

Malik :: Book 7 : Hadith 7.1.2

Yahya related to me from Malik from Abu'nNadr, the mawla of Umar ibn 'Ubaydullah, from Abu Salama ibn Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "I was sleeping in front of the Messenger of Allah, may Allah bless him and grant him peace, and my feet were in his qibla. When he prostrated, he nudged me and I pulled up my feet,and when he stood up I spread them out." She added, "There were no lamps in the house at that time."


Malik :: Tahajjud :: [7-7.1.3]

Tahajjud

Malik :: Book 7 : Hadith 7.1.3

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "If you are drowsy in prayer, sleep until sleep leaves you, because if you pray while you are drowsy, you do not know whether you may intend to ask for forgiveness but (in fact) ask for harm."


Malik :: Tahajjud :: [7-7.1.5]

Tahajjud

Malik :: Book 7 : Hadith 7.1.5

Yahya related to me from Malik from Zayd ibn Aslam from his father that Umar ibn al-Khattab used to pray as much as Allah willed in the night until at the end of the night he would wake his family for the prayer. He used to say to them, "The prayer, the prayer." Then he would recite the ayat, "Enjoin prayer on your family and be constant in it. We do not ask you for your provision. We provide for you. And the end result is for taqwa." (Sura 20 ayat 132)


Malik :: Tahajjud :: [7-7.1.6]

Tahajjud

Malik :: Book 7 : Hadith 7.1.6

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab used to say, "Sleep is disapproved of before isha and conversation after it."


Malik :: Tahajjud :: [7-7.1.7]

Tahajjud

Malik :: Book 7 : Hadith 7.1.7

Yahya related to me from Malik that he had heard that Abdullah ibn Umar used to say, "(Voluntary) prayer in both the day and night is two at a time with a taslim after every raka.''

Malik said, "That is the custom among us. "


Malik :: Tahajjud :: [7-7.2.8]

Tahajjud

Malik :: Book 7 : Hadith 7.2.8

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, used to pray eleven rakas in the night, making them odd by a single one, and when he had finished he lay down on his right side.


Malik :: Tahajjud :: [7-7.2.9]

Tahajjud

Malik :: Book 7 : Hadith 7.2.9

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi from Abu Salama ibn Abd ar-Rahman ibn Awf that he asked A'isha, the wife of the Prophet, may Allah bless him and grant him peace, what the prayer of the Messenger of Allah, may Allah bless him and grant him peace, was like during Ramadan. She said, "The Messenger of Allah, may Allah bless him and grant him peace, did not go above eleven rakas in Ramadan or at any other time. He prayed four - do not ask me about their beauty or length. Then he prayed another four - do not ask me about their beauty and length. Then he prayed three."

A'isha continued, "I said, 'Messenger of Allah, are you sleeping before you do the witr?' He said, A'isha, my eyes sleep but my heart does not sleep.' "


Malik :: Tahajjud :: [7-7.2.10]

Tahajjud

Malik :: Book 7 : Hadith 7.2.10

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin said, "The Messenger of Allah, may Allah bless him and grant him peace, used to pray thirteen rakas in the night and then would pray two rakas when he heard the adhan for the subh prayer."


Malik :: Tahajjud :: [7-7.2.11]

Tahajjud

Malik :: Book 7 : Hadith 7.2.11

Yahya related to me from Malik from Makhrama ibn Sulayman from Kurayb, the mawla of Ibn Abbas, that Abdullah ibn Abbas told him that he had spent a night at the house of Maimuna, the wife of the Prophet, may Allah bless him and grant him peace, who was also Ibn Abbas' mother's sister. Ibn Abbas said, "I lay down with my head on the breadth of the cushion, and the Messenger of Allah, may Allah bless him and grant him peace, and his wife lay down with their heads on its length. The Messenger of Allah, may Allah bless him and grant him peace, slept, until, halfway through the night or a little before or after it, he awoke and sat up and wiped the sleep away from his face with his hand. Then he recited the last ten ayats of sura Ali Imran (Sura3). Then he got up and went over to a water-skin which was hanging up and did wudu from it, doing his wudu thoroughly, and then he stood in prayer."

Ibn Abbas continued, "I stood up and did the same and then went and stood by his side. The Messenger of Allah, may Allah bless him and grant him peace, put his right hand on my head and took my right ear and tweaked it. He prayed two rakas, then two rakas, then two rakas, then two rakas, then two rakas, then two rakas, and then prayed an odd raka. Then he lay down until the muadhdhin came to him, and then prayed two quick rakas, and went out and prayed subh ."


Malik :: Tahajjud :: [7-7.2.12]

Tahajjud

Malik :: Book 7 : Hadith 7.2.12

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his father that Abdullah ibn Qays ibn Makhrama told him that Zayd ibn Khalid al-Juhani said one night that he was going to observe the prayer of the Messenger of Allah, may Allah bless him and grant him peace. He said, "I rested my head on his threshold. The Messenger of Allah, may Allah bless him and grant him peace, got up and prayed two long, long, long rakas. Then he prayed two rakas which were slightly less long than the two before them. Then he prayed two rakas which were slightly less long than the two before them. Then he prayed two rakas which were slightly less long than the two before them. Then he prayed two rakas which were slightly less long than the two before them. Then he prayed two rakas which were slightly less long than the two before them. Then he prayed an odd raka, making thirteen rakas in all."


Malik :: Tahajjud :: [7-7.3.13]

Tahajjud

Malik :: Book 7 : Hadith 7.3.13

Yahya related to me from Malik from Nafi and Abdullah ibn Umar that a man asked the Messenger of Allah, may Allah bless him and grant him peace, about night prayers. The Messenger of Allah, may Allah bless him and grant him peace, said, "Night prayers are two by two, and when you are afraid that dawn is approaching, pray one raka to make what you have prayed odd."


Malik :: Tahajjud :: [7-7.3.14]

Tahajjud

Malik :: Book 7 : Hadith 7.3.14

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban from Ibn Muhayriz that a man from the Kinana tribe called al-Mukhdaji heard a man in Syria known as Abu Muhammad saying, "The witr is obligatory (fard)." Al-Mukhdaji said, "I went to Ubada ibn as-Samit and presented myself to him as he was going to the mosque, and told him what Abu Muhammad had said. Ubada said that Abu Muhammad had lied and that he had heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Allah the Majestic and Mighty has written five prayers for mankind, and whoever does them and does not waste anything of them by making light of what is due to them, there is a pact for him with Allah that He will admit him into the Garden.Whoever does not do them, there is no pact for him with Allah. If He wishes, He punishes him, and if He wishes, He admits him into the Garden.' "


Malik :: Tahajjud :: [7-7.3.15]

Tahajjud

Malik :: Book 7 : Hadith 7.3.15

Yahya related to me from Malik from Abu Bakr ibn Umar that Said ibn Yasar said, ''I was travelling with Abdullah ibn Umar on the road to Makka, and fearing that it was nearly dawn. I dismounted and prayed witr. Abdullah said, 'Is there not a model for you in the Messenger of Allah, may Allah bless him and grant him peace?' I said, 'Of course, by Allah!' He said, 'The Messenger of Allah, may Allah bless him and grant him peace, used to pray witr on his camel.' "


Malik :: Tahajjud :: [7-7.3.16]

Tahajjud

Malik :: Book 7 : Hadith 7.3.16

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "Abu Bakr as-Siddiq used to pray witr when he wished to go to bed, and Umar ibn al-Khattab used to pray witr at the end of the night. As for me, I pray witr when I go to bed."


Malik :: Tahajjud :: [7-7.3.17]

Tahajjud

Malik :: Book 7 : Hadith 7.3.17

Yahya related to me from Malik that he had heard that a man asked Abdullah ibn Umar whether the witr was obligatory and Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, prayed witr, and the muslims prayed witr." The man began repeating his question, and Abdullah ibn Umar kept saying, "The Messenger of Allah, may Allah bless him and grant him peace, prayed witr, and the muslims prayed witr."


Malik :: Tahajjud :: [7-7.3.18]

Tahajjud

Malik :: Book 7 : Hadith 7.3.18

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "If someone fears that he will sleep through till the morning, let him pray the witr before he sleeps, and if some one hopes to wake for the last part of the night, let him delay his witr."


Malik :: Tahajjud :: [7-7.3.19]

Tahajjud

Malik :: Book 7 : Hadith 7.3.19

Yahya related to me from Malik that Nafi said, "I was with Abdullah ibn Umar in Makka. The sky was clouded over and Abdullah feared that dawn was approaching so he prayed one raka for witr. Then the clouds cleared and he saw that it was still night, so he made his prayers even with one raka. Then he continued to pray two rakas at a time, until when he feared the approach of dawn, he prayed one raka for witr."


Malik :: Tahajjud :: [7-7.3.20]

Tahajjud

Malik :: Book 7 : Hadith 7.3.20

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say the taslim between the two rakas and the one raka of witr so that he could order something he needed.


Malik :: Tahajjud :: [7-7.3.22]

Tahajjud

Malik :: Book 7 : Hadith 7.3.22

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar used to say, "The maghrib prayer is the witr of the daytime prayers."

Malik said, "If someone prays witr at the beginning of the night, and goes to sleep, and then wakes up and it seems good to him to pray, let him pray, two rakas at a time. That is what I like most of what I have heard."


Malik :: Tahajjud :: [7-7.3.23]

Tahajjud

Malik :: Book 7 : Hadith 7.3.23

Yahya related to me from Malik from Abd al Karim ibn Abi'l-Mukhariq al-Basri from Said ibn Jubayr that Abdullah ibn Abbas slept, and when he woke up, he said to his servant, "Go and see what the people have done," (by that time his sight had gone.) The servant went out and returned saying, "The people have left from subh," so Abdullah ibn Abbas got up and prayed witr and then prayed subh.


Malik :: Tahajjud :: [7-7.3.24]

Tahajjud

Malik :: Book 7 : Hadith 7.3.24

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas and Ubada ibn as-Samit and al-Qasim ibn Muhammad and Abdullah ibn Amir ibn Rabia had all prayed witr after the break of dawn.


Malik :: Tahajjud :: [7-7.3.25]

Tahajjud

Malik :: Book 7 : Hadith 7.3.25

Yahya related to me from Malik from Hisham ibn Urwa from his father that Abdullah ibn Masud said, "I do not mind if the iqama for the subh prayer is called while I am still praying witr."


Malik :: Tahajjud :: [7-7.3.26]

Tahajjud

Malik :: Book 7 : Hadith 7.3.26

Yahya related to me from Malik that Yahya ibn Said said, ''Ubada ibn as-Samit used to lead the people in prayer. One day he came out for subh and the muadhdhin began to give the iqama for the subh prayer Ubada silenced him, prayed witr and then led them in subh."


Malik :: Tahajjud :: [7-7.3.27]

Tahajjud

Malik :: Book 7 : Hadith 7.3.27

Yahya related to me from Malik that Abd ar-Rahman ibn al-Qasim said, "I heard Abdullah ibn Amir ibn Rabia say, 'I sometimes pray witr while hearing the iqama, or after the break of dawn.' " Abd ar-Rahman was not certain which he said.


Malik :: Tahajjud :: [7-7.3.28]

Tahajjud

Malik :: Book 7 : Hadith 7.3.28

Malik related to me that Abd ar-Rahman ibn al-Qasim heard his father al-Qasim ibn Muhammad say, "I have prayed witr after dawn."

Malik said, "Only a person who oversleeps so that he does not do the witr prays it after dawn. No one should intentionally make his witr after dawn."


Malik :: Tahajjud :: [7-7.3.213]

Tahajjud

Malik :: Book 7 : Hadith 7.3.213

Yahya related to me from Malik from Ibn Shihab that Sad ibn Abi Waqqas used to pray witr after isha with one raka.

Malik said, "This is not the situation with us. Rather three is the minimum for witr."


Malik :: Tahajjud :: [7-7.4.29]

Tahajjud

Malik :: Book 7 : Hadith 7.4.29

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Hafsa, the wife of the Prophet, may Allah bless him and grant him peace, told him that the Messenger of Allah, may Allah bless him and grant him peace, used to pray two quick rakas when the muadhdhin had finished the adhan for the subh prayer, before the iqama was said for the prayer.


Malik :: Tahajjud :: [7-7.4.30]

Tahajjud

Malik :: Book 7 : Hadith 7.4.30

Malik related to me from Yahya ibn Said that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, used to pray the two rakas of the dawn (fajr) so quickly that I would say to myself 'Has he recited the umm al-Qur'an or not?' "


Malik :: Tahajjud :: [7-7.4.31]

Tahajjud

Malik :: Book 7 : Hadith 7.4.31

Yahya related to me from Malik from Sharik ibn Abdullah ibn Abi Namir that Abu Salama ibn Abd ar-Rahman said, "Some people heard the iqama and started to pray. The Messenger of Allah, may Allah bless him and grant him peace, came out and said, 'Are you doing two prayers at the same time? Are you doing two prayers at the same time?' That was about the subh prayer and the two rakas before subh."


Malik :: Tahajjud :: [7-7.4.32]

Tahajjud

Malik :: Book 7 : Hadith 7.4.32

Yahya related to me from Malik that he had heard that Abdullah ibn Umar missed the two rakas of dawn, and then did them after the sun rose.


Malik :: Tahajjud :: [7-7.4.33]

Tahajjud

Malik :: Book 7 : Hadith 7.4.33

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that al-Qasim ibn Muhammad had done the same as Ibn Umar.


Malik :: Prayer in Congregation :: [8-8.1.1]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.1.1

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Prayer in congregation is better than the prayer of a man by himself by twenty-seven degrees."


Malik :: Prayer in Congregation :: [8-8.1.2]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.1.2

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Prayer in congregation is better than the prayer of one of you on his own by twenty-five parts."


Malik :: Prayer in Congregation :: [8-8.1.3]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.1.3

Yahya related to me from Malik from Abu'zZinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "By Him in whose hand myself is! I had in mind to order firewood to be collected, then to order the prayer to be called, and to appoint a man to lead the people in prayer, and then to come up behind certain men and burn their houses down about them! By Him in whose hand myself is! If one of them knew that he would find a meaty bone or two good legs of meat, he would be present at isha.''


Malik :: Prayer in Congregation :: [8-8.1.4]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.1.4

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah from Yusr ibn Said that Zayd ibn Thabit said, "The most excellent prayer is your prayer in your house, except for the prescribed prayers."


Malik :: Prayer in Congregation :: [8-8.2.5]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.2.5

Yahya related to me from Malik from Abd ar-Rahman ibn Harmala al-Aslami from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, said, "What separates us from the hypocrites is being present at isha and subh. They cannot do it," or words to that effect.


Malik :: Prayer in Congregation :: [8-8.2.6]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.2.6

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman from Abu Salih from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If a man who is walking along a road finds a branch of thorns on the road and removes it, Allah thanks him for doing it and forgives him."

He also said, "Martyrs are five: the one killed by a plague, the one killed by a disease of the belly, the one who drowns, the one killed by a collapsing building, and the martyr in the path of Allah.'

He also said, "If people knew what there was in the call to prayer and the first row, and they could find no other way except to draw lots for it, they would draw lots for it. And if they knew what there was in doing dhuhr at its time, they would race each other to it. And if they knew what there was in the prayers of isha and maghrib, they would come to them even if they had to crawl .


Malik :: Prayer in Congregation :: [8-8.2.7]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.2.7

Yahya related to me from Malik from Ibn Shihab from Abu Bakr ibn Sulayman ibn Abi Hathma that Umar ibn al-Khattab missed Sulayman ibn Abi Hathma in the subh prayer. In the morning he went to the market, and Sulayman's house was between the market and the Prophet's mosque. He passed ash-Shifa, Sulayman's mother, and said to her, "I did not see Sulayman at subh." She replied, "He spent the night in prayer and his eyes overcame him. Umar said, "I would rather be present at subh than stand the whole night in prayer.


Malik :: Prayer in Congregation :: [8-8.2.8]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.2.8

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Ibrahim that Abd ar-Rahman ibn Abi Amra al-Ansari said that Uthman ibn Affan came to the isha prayer and seeing only a few people in the mosque, he lay down at the back of the mosque to wait for the number of people to increase. Ibn Abi Amra went and sat down beside him and Uthman asked him who he was, so he told him. Uthman said, "What have you memorised of the Qur'an?", and he told him. Uthman said, "If someone is present at isha, it is as if he had stood in prayer for half a night, and if some one is present at subh, it is as if he had stood in prayer for a whole night.


Malik :: Prayer in Congregation :: [8-8.3.9]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.3.9

Yahya related to me from Malik from Zayd ibn Aslam from a man of the Bani'd-Dil called Busr ibn Mihjan from his father Mihjan that he was in a gathering with the Messenger of Allah, may Allah bless him and grant him peace, and the call to prayer was made. The Messenger of Allah, may Allah bless him and grant him peace, rose and prayed and then returned. Mihjan remained sitting and did not pray with him. The Messenger of Allah, may Allah bless him and grant him peace, said, "What prevented you from praying with the people? Aren't you a muslim?" He said, "Of course, Messenger of Allah, but I have already prayed with my family." The Messenger of Allah, may Allah bless him and grant him peace, said, "When you come, pray with the people, even if you have prayed already."


Malik :: Prayer in Congregation :: [8-8.3.10]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.3.10

Yahya related to me from Malik from Nafi that a man asked Abdullah ibn Umar, "Sometimes I pray in my house, and then catch the prayer with the imam. Should I pray with him?" Abdullah ibn Umar said to him, "Yes," and the man said, "Which of them do I make my prayer?" Abdullah ibn Umar said, "Is that up to you? It is up to Allah. He will decide on whichever of them He wishes."


Malik :: Prayer in Congregation :: [8-8.3.11]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.3.11

Yahya related to me from Malik from Yahya ibn Said that a man asked Said ibn al-Musayyab, "I pray in my house, and then I come to the mosque and find the imam praying. Should I pray with him?" Said said, "Yes," and the man said, "Which of them is my prayer?" Said said, "Are you the one to decide that? That is up to Allah."


Malik :: Prayer in Congregation :: [8-8.3.12]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.3.12

Yahya related to me from Malik from Afif as-Sahmi that a man from the tribe of Bani Asad asked Abu Ayyub al-Ansari. "Sometimes I pray in my house, and then come to the mosque and find the imam praying. Should I pray with him?" Abu Ayyub said, "Yes, pray with him, for some one who does so has the reward of the group, or the equivalent of the reward of the group."


Malik :: Prayer in Congregation :: [8-8.3.13]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.3.13

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Someone who prays maghrib or subh and then catches them with the imam should not repeat them."

Malik said, "I do not see any harm in someone who has already prayed in his house praying with the imam, except for maghrib, because if he repeats it, he makes it even."


Malik :: Prayer in Congregation :: [8-8.4.14]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.4.14

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you lead people in the prayer, make it short, because there are among them some people who are weak, ill and old. But when you pray on your own, make it as long as you wish."


Malik :: Prayer in Congregation :: [8-8.4.15]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.4.15

Yahya related to me from Malik that Nafi said, "I stood behind Abdullah ibn Umar in one of the prayers when there was no one else with him, and he reached behind with his hand and placed me beside him."


Malik :: Prayer in Congregation :: [8-8.4.16]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.4.16

Yahya related to me from Malik from Yahya ibn Said that a man used to lead the people in prayer in al-Aqiq (a place near Madina), and Umar ibn Abd al-Aziz sent a message to him forbidding him to do so.

Malik said, "He only forbade him because his father was not known."


Malik :: Prayer in Congregation :: [8-8.5.17]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.5.17

Yahya related to me from Malik from Ibn Shihab from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, fell off his horse when riding, and his right side was scraped, so he did one of the prayers sitting, and we prayed behind him sitting. When he left, he said, "The imam is appointed to be followed. If he prays standing, then pray standing, and when he goes into ruku, go into ruku, and when he rises, rise, and when he says, 'Allah hears whoever praises him,' say, 'Our Lord, praise belongs to You,' and if he prays sitting, then all of you pray sitting."


Malik :: Prayer in Congregation :: [8-8.5.18]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.5.18

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, prayed while he was ill. He prayed sitting, and some people prayed behind him standing, and he indicated to them to sit down. When he left, he said, 'The imam is only appointed to be followed. When he goes into ruku, go into ruku and when he rises, rise and if he prays sitting, pray sitting .' "


Malik :: Prayer in Congregation :: [8-8.5.19]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.5.19

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, came out during his illness, and approached and found Abu Bakr standing, leading the people in prayer. Abu Bakr began to go back, but the Messenger of Allah, may Allah bless him and grant him peace, indicated to him to stay where he was. The Messenger of Allah, may Allah bless him and grant him peace, sat by the side of Abu Bakr, and Abu Bakr prayed following the prayer of the Messenger of Allah, may Allah bless him and grant him peace, who was sitting, and the people prayed following the prayer of Abu Bakr.


Malik :: Prayer in Congregation :: [8-8.6.20]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.6.20

Yahya related to me from Malik from Ismail ibn Muhammad ibn Said ibn Abi Waqqas from a mawla of Amr ibn al-As or of Abdullah ibn Amr ibn al-As that the Messenger of Allah, may Allah bless him and grant him peace, said, "The prayer of one of you sitting down is only equal to half the prayer of one of you when he is standing."


Malik :: Prayer in Congregation :: [8-8.6.21]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.6.21

Yahya related to me from Malik from Ibn Shihab that Abdullah ibn Amr ibn al As said, "When we arrived at Madina we were struck down by a severe epidemic which debilitated us greatly. The Messenger of Allah, may Allah bless him and grant him peace, came out to the people while they were praying nawafil prayers sitting down. The Messenger of Allah, may Allah bless him and grant him peace, said, 'The prayer of the one sitting is equal to only half the prayer of the one standing.' "


Malik :: Prayer in Congregation :: [8-8.7.22]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.7.22

Yahya related to me from Malik from Ibn Shihab from as-Sa'ib ibn Yazid from al Muttalib ibn Abi Wadaa as-Sahmi that Hafsa, the wife of the Prophet, may Allah bless him and grant him peace, said, "I never saw the Messenger of Allah, may Allah bless him and grant him peace, praying nawafil sitting, until a year before his death, when he began to pray them sitting. He would recite the sura with a measured slowness so that it would seem to be longer than other suras which were actually longer than it."


Malik :: Prayer in Congregation :: [8-8.7.23]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.7.23

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, told him that she had never seen the Messenger of Allah, may Allah bless him and grant him peace, doing night prayers sitting down until he was getting on in years. He would recite sitting down until when he wanted to go into ruku, he would stand up and recite about thirty or forty ayats and then go into ruku.


Malik :: Prayer in Congregation :: [8-8.7.24]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.7.24

Yahya related to me from Malik from Abdullah ibn Yazid al-Madani and from Abu'n Nadr from Abu Salama ibn Abd ar-Rahman from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, used to pray sitting. He would recite sitting, and then, when about thirty or forty ayats of what he was reciting remained, he would stand up and recite standing and then go into ruku and sajda. He would do the same in the second raka.


Malik :: Prayer in Congregation :: [8-8.7.25]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.7.25

Yahya related to me from Malik that he had heard that Urwa ibn az-Zubayr and Said ibn al-Musayyab used to pray voluntary prayers sitting.


Malik :: Prayer in Congregation :: [8-8.8.26]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.8.26

Yahya related to me from Malik from Zayd ibn Aslam from al-Qaqa ibn Hakim that Abu Yunus, the mawla of A'isha, umm al-muminin said, ''A'isha ordered me to write out a Qur'an for her. She said, 'When you reach this ayat, let me know, "Guard the prayers carefully and the middle prayer and stand obedient to Allah." ' When I reached it I told her, and she dictated to me, 'Guard the prayers carefully and the middle prayer and the asr prayer and stand obedient to Allah.' A'isha said, 'I heard it from the Messenger of Allah, may Allah bless him and grant him peace.' "


Malik :: Prayer in Congregation :: [8-8.8.27]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.8.27

Yahya related to me from Malik from Zayd ibn Aslam that Amr ibn Rafi said, "I was writing a Qur'an for Hafsa, umm al-muminin, and she said, 'When you reach this ayat, let me know, "Guard the prayers carefully and the middle prayer and stand obedient to Allah." When I reached it I told her and she dictated to me, 'Guard the prayers carefully and the middle prayer and the asr prayer and stand obedient to Allah.' "


Malik :: Prayer in Congregation :: [8-8.8.28]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.8.28

Yahya related to me from Malik from Da'ud ibn al-Husayn that Ibn Yarbu al-Makhzumi said, "I heard Zayd ibn Thabit say, 'The middle prayer is the prayer of dhuhr.' "


Malik :: Prayer in Congregation :: [8-8.8.29]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.8.29

Yahya related to me from Malik that he had heard that AIi ibn Abi Talib and Abdullah ibn Abbas used to say, "The middle prayer is the prayer of subh."

Malik said, "Out of all that I have heard about the matter, I prefer what Ali ibn Abi Talib and Abdullah ibn Abbas said."


Malik :: Prayer in Congregation :: [8-8.9.30]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.30

Yahya related to me from Malik from Hisham ibn Urwa from his father that Umar ibn Abi Salama saw the Messenger of Allah, may Allah bless him and grant him peace, praying in one garment in the house of Umm Salama. He was completely covered by it, and had put both ends over his shoulders.


Malik :: Prayer in Congregation :: [8-8.9.31]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.31

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab from Abu Hurayra that some one asked the Messenger of Allah, may Allah bless him and grant him peace about praying in one garment. The Messenger of Allah, may Allah bless him and grant him peace, said, "Do you all have two garments?"


Malik :: Prayer in Congregation :: [8-8.9.32]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.32

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said that Abu Hurayra was asked, "May a man pray in one garment?" He said, "Yes." The man then said to him "Do you do that?" and he replied, "Yes, I pray in one garment while my clothes are on the clothes-rack."


Malik :: Prayer in Congregation :: [8-8.9.33]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.33

Yahya related to me from Malik that he had heard that Jabir ibn Abdullah used to pray in one garment.


Malik :: Prayer in Congregation :: [8-8.9.34]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.34

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that Muhammad ibn Amr ibn Hazm used to pray in a single long shirt.


Malik :: Prayer in Congregation :: [8-8.9.35]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.9.35

Yahya related to me from Malik that he had heard from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, said, "Let anyone who cannot find two garments pray in one garment and wrap himself in it, and if the garment is short, let him wrap it around his waist."

Malik said, "In my view it is preferable for someone who prays in a single shirt to put a garment or a turban over his shoulders."


Malik :: Prayer in Congregation :: [8-8.10.36]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.10.36

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to pray in a shift and head-covering.


Malik :: Prayer in Congregation :: [8-8.10.37]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.10.37

Yahya related to me from Malik from Muhammad ibn Zayd ibn Qunfudh that his mother asked Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, "What clothes can a woman wear in prayer?" She said, "She can pray in a shift that reaches down and covers the top of her feet."


Malik :: Prayer in Congregation :: [8-8.10.38]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.10.38

Yahya related to me from Malik from a reliable source from Bukayr ibn Abdullah ibn al-Ashajj from Busr ibn Said that when Ubaydullah ibn al-Aswad al-Khawlani was in the room of Maimuna, the wife of the Prophet, may Allah bless him and grant him peace, she used to pray in a shift and head-covering, without a waist-wrapper.


Malik :: Prayer in Congregation :: [8-8.10.39]

Prayer in Congregation

Malik :: Book 8 : Hadith 8.10.39

Yahya related to me from Malik from Hisham ibn Urwa from his father that a woman asked him for a decision, saying, "Waist-wrappers are painful to me. Can I pray in a shift and head-covering?" He replied, "Yes, if the shift is long."


Malik :: Shortening the Prayer :: [9-9.1.1]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.1

Yahya related to me from Malik from Da'ud ibn al-Husayn from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, joined dhuhr and asr on his journey to Tabuk.


Malik :: Shortening the Prayer :: [9-9.1.2]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.2

Yahya related to me from Malik from Abu'z-Zubayr al-Makki from Abu't-Tufayl Amir ibn Wathila that Muadh ibn Jabal told him that they went out with the Messenger of Allah, may Allah bless him and grant him peace, in the year of Tabuk, and the Messenger of Allah, may Allah bless him and grant him peace, joined dhuhr with asr and maghrib with isha. Muadh said, "One day he delayed the prayer, and then came out and prayed dhuhr and asr together. Then he said, 'Tomorrow you will come, insha' llah, to the spring of Tabuk. But you will not get there until well into the morning. No one who arrives should touch any of its water until I come.' We came to it and two men had got to it before us and the spring was dripping with a little water. The Messenger of Allah, may Allah bless him and grant him peace, asked them, 'Have you touched any of its water?' They said, 'Yes.' The Messenger of Allah, may Allah bless him and grant him peace, reviled them and said what Allah wished him to say. Then they took water with their hands from the spring little by little until it had been collected in something. Then the Messenger of Allah, may Allah bless him and grant him peace, washed his face and hands in it. Then he put it back into the spring and the spring flowed with an abundance of water and the people drew water from it. The Messenger of Allah, may Allah bless him and grant him peace, said, 'If you live long enough, Muadh, you will soon see this place filled with gardens.' "


Malik :: Shortening the Prayer :: [9-9.1.3]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.3

3 Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, used to join maghrib and isha together when it was urgent to travel."


Malik :: Shortening the Prayer :: [9-9.1.4]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.4

Yahya related to me from Malik from Abu'z Zubayr al-Makki from Said ibn Jubayr that Abdullah ibn Abbas said, "The Messenger of Allah, may Allah bless him and grant him peace, prayed dhuhr and asr together and maghrib and isha together, and not out of fear nor because of travelling." Malik said, "I believe that was during rain."


Malik :: Shortening the Prayer :: [9-9.1.5]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.5

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to join the prayer along with the amirs if they joined maghrib and isha in the rain.


Malik :: Shortening the Prayer :: [9-9.1.6]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.6

Yahya related to me from Malik from Ibn Shihab that he had asked Salim ibn Abdullah, "Can you join dhuhr and asr when travelling?" He said, "Yes, there is no harm in that. Haven't you seen the people pray on Arafa?"


Malik :: Shortening the Prayer :: [9-9.1.7]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.1.7

Yahya related to me from Malik that he had heard that AIi ibn Husain used to say, "The Messenger of Allah, may Allah bless him and grant him peace, would join dhuhr and asr if he wished to travel the same day, and he would join maghrib and isha if he wished to travel the same night."


Malik :: Shortening the Prayer :: [9-9.2.8]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.2.8

Yahya related to me from Malik from Ibn Shihab from a man of the family of Khalid ibn Asid that he said to Abdullah ibn Umar, "Abu Abd ar-Rahman, we find the fear prayer and the prayer when settled mentioned in the Qur'an, but we do not find any mention of the travelling prayer in it." Ibn Umar said, "Son of my brother! Allah the Mighty and Majestic sent us Muhammad, may Allah bless him and grant him peace, and we know nothing. We only do as we saw him doing."


Malik :: Shortening the Prayer :: [9-9.2.9]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.2.9

Yahya related to me from Malik from Salih ibn Kaysan from Urwa ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The prayer was prescribed as two rakas, both when settled and when travelling. Then the travelling prayer was kept as it was, and an increase was made in the prayer when settled. "


Malik :: Shortening the Prayer :: [9-9.2.10]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.2.10

Yahya related to me from Malik from Yahya ibn Said that he said to Salim ibn Abdullah, "What is the latest you have seen your father delay maghrib while on a journey?" and Salim replied, "One time the sun set when we were at Dhat al-Jaysh and he prayed maghrib at al-Aqiq."


Malik :: Shortening the Prayer :: [9-9.3.11]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.11

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, shortened the prayer when he left for hajj or umra at Dhu'l Hulayfa.


Malik :: Shortening the Prayer :: [9-9.3.12]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.12

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that his father rode to Rim and shortened the prayer on the journey.

Malik said, "That was about four mail-stages." (approximately forty-eight miles).


Malik :: Shortening the Prayer :: [9-9.3.13]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.13

Yahya related to me from Malik from Nafi from Salim ibn Abdullah that Abdullah ibn Umar rode to Dhat an-Nusub and shortened the prayer on the journey.

Malik said, "There are four mail-stages between Dhat an-Nusub and Madina."


Malik :: Shortening the Prayer :: [9-9.3.14]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.14

Yahya related to me from Malik from Nafi from Ibn Umar that he used to travel to Khaybar and he would shorten the prayer.


Malik :: Shortening the Prayer :: [9-9.3.15]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.15

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar used to shorten the prayer when he travelled for a whole day.


Malik :: Shortening the Prayer :: [9-9.3.16]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.16

Yahya related to me from Malik from Nafi that he used to travel one mail-stage with Ibn Umar, and he would not shorten the prayer.


Malik :: Shortening the Prayer :: [9-9.3.17]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.3.17

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas used to shorten the prayer when he travelled a distance equivalent to that between Makka and Ta'if, and that between Makka and Usfan and that between Makka and Jedda.

Malik said, "That is four mail-stages, and to me that is the most preferable distance for shortening the prayer."

Malik said, "Someone who intends to travel does not shorten the prayer until he has left the houses of the village. And he does not do it in full until he comes to the first houses of the village, or is nearby."


Malik :: Shortening the Prayer :: [9-9.4.18]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.4.18

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar used to say, "I pray the prayerof a traveller as long as I am undecided whether to remain somewhere or not, even if I am detained for twelve nights."


Malik :: Shortening the Prayer :: [9-9.4.19]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.4.19

Yahya related to me from Malik from Nafi that Ibn Umar stayed in Makka for ten nights, shortening the prayer, except when he prayed it behind an imam, in which case he followed the imam's prayer.

9.5 Doing the Full Prayer when One Decides to Remain in a Place


Malik :: Shortening the Prayer :: [9-9.5.20]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.5.20

Yahya related to me from Malik from Ata al-Khurasani that he heard Said ibn al Musayyab say, "A traveller who has decided to remain somewhere for four nights does the prayer in full."

Malik said, "That is what I prefer most out of what I have heard."

Malik when asked about the prayer of a prisoner, said, "It is the same as the prayer of a person who remains in one place, except if he is travelling."


Malik :: Shortening the Prayer :: [9-9.6.21]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.6.21

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah from his father that Umar ibn al-Khattab, when he went to Makka, used to lead them in prayer and do two rakas and then say, "People of Makka,complete the prayer, we are a group travelling."

Yahya related the same as that to me from Malik from Zayd ibn Aslam from his father from Umar ibn al-Khattab.


Malik :: Shortening the Prayer :: [9-9.6.22]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.6.22

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pray four rakas behind the imam at Mina, and when he prayed by himself he would pray two rakas.


Malik :: Shortening the Prayer :: [9-9.6.23]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.6.23

Yahya related to me from Malik from Ibn Shihab that Safwan said, "Abdullah ibn Umar used to come and visit Abdullah ibn Safwan and he would pray two rakas with us, and when he went away we would stand and complete the prayer."


Malik :: Shortening the Prayer :: [9-9.7.24]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.24

Yahya related to me from Malik from Nafi that Abdullah ibn Umar never used to pray anything with the fard prayer, either before it or after it, while travelling, except in the depths of the night. He would pray on the ground or on his mount, whichever way it was facing.


Malik :: Shortening the Prayer :: [9-9.7.25]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.25

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad and Urwa ibn az-Zubayr and Abu Bakr ibn Abd ar Rahman used to pray nawafil when travelling.

Yahya said that Malik was asked about voluntary prayers when travelling and he said, "There is no harm in them, either at night or during the day. I have heard that some of the people of knowledge used to do that."


Malik :: Shortening the Prayer :: [9-9.7.26]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.26

Yahya related to me that Malik said, "I have heard from Nafi that Abdullah ibn Umar used to see his son, Ubaydullah ibn Abdullah, doing voluntary prayers on a journey,and he would not disapprove of it."


Malik :: Shortening the Prayer :: [9-9.7.27]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.27

Yahya related to me from Malik from Amr ibn Yahya al-Mazini from Abu'l-Hubab Said ibn Yasar that Abdullah ibn Umar said, "I saw the Messenger of Allah, may Allah bless him and grant him peace, praying on a donkey while heading towards Khaybar."


Malik :: Shortening the Prayer :: [9-9.7.28]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.28

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, used to pray on his mount while travelling, whichever way it was facing. Abdullah ibn Dinar said, "Abdullah ibn Umar would also do that."


Malik :: Shortening the Prayer :: [9-9.7.29]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.7.29

Yahya related to me from Malik that Yahya ibn Said said, "I saw Anas ibn Malik on a journey praying on a donkey facing away from the qibla. He did the raka and the sajda by motioning with his head, without putting his face on anything."


Malik :: Shortening the Prayer :: [9-9.8.30]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.8.30

Yahya related to me from Malik from Musa ibn Maysara from Abu Murra, the mawla of Aqil ibn Abi Talib, that Umm Hani bint Abi Talib told him that in the year of the conquest the Messenger of Allah, may Allah bless him and grant him peace, prayed eight rakas, covering himself with one garment.


Malik :: Shortening the Prayer :: [9-9.8.31]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.8.31

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah, that Abu Murra, the mawla of Aqil ibn Abi Talib, told him that he had heard Umm Hani bint Abi Talib say, "I went to the Messenger of Allah, may Allah bless him and grant him peace, in the year of the conquest and found him doing ghusl while his daughter Fatima, was screening him with a garment. I said to him, 'Peace be upon you' and he said, 'Who is that?' I replied, 'Umm Hani bint Abi Talib,' and he said, 'Welcome, Umm Hani!' When he had finished his ghusl, he stood and prayed eight rakas, covering himself with one garment, and then came away. I said, 'Messenger of Allah, the son of my mother, AIi, says that he is determined to kill so-and-so, son of Hubayra, a man I have placed under my protection.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'We give protection to whoever you have given protection to, Umm Hani.' "

Umm Hani related that this incident happened in the morning.


Malik :: Shortening the Prayer :: [9-9.8.32]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.8.32

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "I never once saw the Messenger of Allah, may Allah bless him and grant him peace, doing the voluntary prayer of duha, but I myself do it. Sometimes the Messenger of Allah, may Allah bless him and grant him peace, would refrain from a practice that he loved to do, fearing that people would do the same and it would become fard for them ."


Malik :: Shortening the Prayer :: [9-9.8.33]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.8.33

Yahya related to me from Malik from Zayd ibn Aslam from A'isha that she used to pray duha with eight rakas, and she would say, "I would never stop doing them even if my parents were to be brought back to life."


Malik :: Shortening the Prayer :: [9-9.9.34]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.9.34

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha from Anas ibn Malik that his grandmother, Mulayka, invited the Messenger of Allah, may Allah bless him and grant him peace, for food and he ate some of it. Then the Messenger of Allah, may Allah bless him and grant him peace, said, "Get up and I will lead you in prayer."

Anas said, "I stood up and took a woven mat belonging to us that had become black through long use and sprinkled it with water, and the Messengerof Allah, may Allah bless him and grant him peace, stood on it. The orphan and I formed a row behind him, and the old woman stood behind us. He prayed two rakas with us and then left."


Malik :: Shortening the Prayer :: [9-9.9.35]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.9.35

Yahya related to me from Malik from Ibn Shihab that Ubaydullah ibn Abdullah ibn Utba said, "I visited Umar ibn al-Khattab just before noon and found him praying a voluntary prayer. So I stood behind him, but he pulled me nearer and put me next to him, on his right hand side, and then Yarfa came and I moved back and we formed a row behind him."


Malik :: Shortening the Prayer :: [9-9.10.36]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.10.36

Yahya related to me from Malik from Zayd ibn Aslam from Abd ar-Rahman ibn Abi Said al-Khudri from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not let anyone pass in front of you when you are praying. Repel him as much as you can, and, if he refuses, fight him, for he is only a shaytan."


Malik :: Shortening the Prayer :: [9-9.10.37]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.10.37

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah from Busr ibn Said that Zayd ibn Khalid al-Juhani sent him to Abu Juhaym to ask him what he had heard from the Messenger of Allah, may Allah bless him and grant him peace, about passing in front of someone praying. Abu Juhaym said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'If the one who passes in front of a man praying knew what he was bringing upon himself it would be better for him to stop for forty than to pass in front of him.' "

Abu'n-Nadr said, "I do not know whether he said forty days or months or years."


Malik :: Shortening the Prayer :: [9-9.10.38]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.10.38

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that Kab al-Ahbar said, "If the person who passed in front of a man praying knew what he was bringing on himself, it would be better for him to sink into the ground than to pass in front of him."


Malik :: Shortening the Prayer :: [9-9.10.39]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.10.39

Yahya related to me from Malik that he had heard that Abdullah ibn Umar used to disapprove of passing in front of women while they were praying.


Malik :: Shortening the Prayer :: [9-9.10.40]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.10.40

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would neither pass in front of anyone, nor let anyone pass in front of him.


Malik :: Shortening the Prayer :: [9-9.11.41]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.11.41

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Abdullah ibn Abbas said, "I approached, riding on a donkey, while the Messenger of Allah, may Allah bless him and grant him peace, was leading the people in prayer at Mina, and I was, at that time, nearing puberty. I passed in front of part of the row, dismounted, sent the donkey off to graze, and then joined the row, and no one rebuked me for doing so."


Malik :: Shortening the Prayer :: [9-9.11.42]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.11.42

Yahya related to me from Malik that he had heard that Said ibn Abi Waqqas used to pass in front of some of the rows while the prayer was in progress.

Malik said, "I consider that it is permissible to do that if the iqama for the prayer has been said and the imam has said the initial takbir and a man cannot find any way into the mosque except by going between the rows."


Malik :: Shortening the Prayer :: [9-9.11.43]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.11.43

Yahya related to me from Malik that he had heard that Ali ibn Abi Talib said, "Things that pass in front of a man praying do not break his prayer."

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar used to say, "Things that pass in front of a man praying do not break his prayer."


Malik :: Shortening the Prayer :: [9-9.12.44]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.12.44

Yahya related to me from Malik that he had heard that Abdullah ibn Umar would use the animal he was riding as a sutra when he prayed.

Yahya related to me from Malik from Hisham ibn Urwa that his father used to pray in the desert without a sutra.


Malik :: Shortening the Prayer :: [9-9.13.45]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.13.45

Yahya related to me from Malik that Abu Jafar al-Qari said, "I saw Abdullah ibn Umar quickly brush away the small stones from the place where he was going to put his forehead as he was going down into sajda."


Malik :: Shortening the Prayer :: [9-9.13.46]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.13.46

Yahya related to me from Malik from Yahya ibn Said that he had heard that Abu Dharr used to say, "Brush away the small stones with one sweep, but if you leave them it is better than a red camel."


Malik :: Shortening the Prayer :: [9-9.14.47]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.14.47

Yahya related to me from Malik from Nafi that Umar ibn al-Khattab used to order the rows to be straightened, and when they had come to him and told him that the rows were straight he would say the takbir.


Malik :: Shortening the Prayer :: [9-9.14.48]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.14.48

Yahya related to me from Malik from his paternal uncle, Abu Suhayl ibn Malik, that his father said, "I was with Uthman ibn Affan when the iqama was said for the prayer and I was talking to him about being assigned a definite allowance by him. I continued talking to him while he was levelling some small stones with his sandals, and then some men that he had entrusted to straighten the rows came and told him that the rows were straight. He said to me, 'Line up in the row,' and then he said the takbir."


Malik :: Shortening the Prayer :: [9-9.15.49]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.15.49

Yahya related to me from Malik that Abd al-Karim ibn Abi'l-Mukhariq al-Basri said, "Among things the Prophet, may Allah bless him and grant him peace, said and did are: 'As long as you do not feel ashamed, do whatever you wish', the placing of one hand on the other in prayer (one places the right hand on the left), being quick to break the fast, and delaying the meal before dawn."


Malik :: Shortening the Prayer :: [9-9.15.50]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.15.50

Yahya related to me from Malik from Abu Hazim ibn Dinar that Sahl ibn Sad said, "People used to be ordered to place their right hands on their left forearms in the prayer."

Abu Hazim added, "I know for sure that Sahl traces that back to the Prophet, may Allah bless him and grant him peace."


Malik :: Shortening the Prayer :: [9-9.16.51]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.16.51

Yahya related to me from Malik from Nafi that Abdullah ibn Umar did not say qunut in any of the prayers.


Malik :: Shortening the Prayer :: [9-9.17.52]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.17.52

Yahya related to me from Malik from Hisham ibn Urwa from his father that Abdullah ibn al-Arqam used to lead his companions in prayer. The time for prayer came one day and he went to relieve himself. When he returned, he said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'If you wish to defecate, you should do so before the prayer.' "


Malik :: Shortening the Prayer :: [9-9.17.53]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.17.53

Yahya related to me from Malik from Zayd ibn Aslam that Umar ibn al-Khattab said, "You should not pray while you are holding your bowels."


Malik :: Shortening the Prayer :: [9-9.18.54]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.54

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The angels ask for blessings on each one of you as long as he is in the place where he has prayed and has not discharged anything. They say, 'Allah, forgive him. Allah have mercy on him.' "

Malik said, "I do not consider that his words, 'has not discharged anything' refer to anything other than the discharges that break wudu."


Malik :: Shortening the Prayer :: [9-9.18.55]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.55

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "You are in prayer as long as the prayer detains you and there is nothing that prevents you from returning to your family except the prayer."


Malik :: Shortening the Prayer :: [9-9.18.56]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.56

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, that Abu Bakr ibn Abd ar-Rahman used to say, "Someone who goes to the mosque in the morning or the afternoon with no intention of going anywhere else, either to learn good or teach it, is like someone who does jihad in the way of Allah and returns with booty."


Malik :: Shortening the Prayer :: [9-9.18.57]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.57

Yahya related to me from Malik from Nuaym ibn Abdullah al-Mujmir that he heard Abu Hurayra say, "If any one of you prays and then sits down in the spot where he has prayed, the angels ask blessings on him saying, 'Allah, forgive him. Allah, have mercy on him.' And if he moves from the spot where he has prayed and sits elsewhere in the mosque waiting for the prayer, he remains in prayer until he prays."


Malik :: Shortening the Prayer :: [9-9.18.58]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.58

Yahya related to me from Malik from al Ala ibn Abd ar-Rahman ibn Yaqub from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Shall I tell you the things by which Allah erases wrong actions and by which he raises ranks: the complete and correct performance of wudu in adverse conditions, a great number of steps towards the mosque,and waiting after one prayer for the next prayer. That is the firm hold, that is the firm hold, that is the firm hold."


Malik :: Shortening the Prayer :: [9-9.18.59]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.59

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab said, "It is said that no-one except a hypocrite leaves the mosque after the call to prayer, except for someone who intends to return."


Malik :: Shortening the Prayer :: [9-9.18.60]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.60

Yahya related to me from Malik from Amir ibn Abdullah ibn az-Zubayr from Amr ibn Sulaymaz-Zuraqi from Abu Qatadaal-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you enter the mosque, you should pray two rakas before you sit down."


Malik :: Shortening the Prayer :: [9-9.18.61]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.18.61

Yahya related to me from Malik from Abu'nNadr, the mawla of Umar ibn Ubaydullah, that Abu Salama ibn Abd ar-Rahman asked him, "Didn't I see your master sit down before praying after he had entered the mosque?"

Abu'n-Nadr said, "By that he meant Umar ibn Ubaydullah, and he was finding fault with him for sitting down before praying after he had come into the mosque."

Yahya said that Malik said, "It is good to do that but not obligatory."


Malik :: Shortening the Prayer :: [9-9.19.62]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.19.62

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to place his palms flat on the surface where he put his forehead. Nafi said, "I have seen him take his hands out from under his burnus on a very cold day and place them on the ground."


Malik :: Shortening the Prayer :: [9-9.19.63]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.19.63

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "When one of you puts his forehead on the ground he should put his palms on the place where he puts his forehead. Then, when he rises, he should raise them, for the hands prostrate just as the face prostrates."


Malik :: Shortening the Prayer :: [9-9.20.64]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.20.64

Yahya related to me from Malik from Abu Hazim Salama ibn Dinar from Sahl ibn Said as-Saidi that the Messenger of Allah, may Allah bless him and grant him peace, went to the tribe of Bani Amr ibn Awf to settle their disputes .The time for the prayer came and the muadhdhin came to Abu Bakr as-Siddiq and said, "Could you lead the people in prayer and I will say the iqama?" He said, "Yes," and Abu Bakr prayed. The Messenger of Allah, may Allah bless him and grant him peace, came back while the people were praying, and approached and joined the row. People clapped, but Abu Bakr did not turn round. The people increased their clapping, and Abu Bakr turned round and saw the Messenger of Allah, may Allah bless him and grant him peace, and the Messenger of Allah, may Allah bless him and grant him peace, indicated to him to stay in his place. Abu Bakr raised his hands and praised Allah that the Messenger of Allah, may Allah bless him and grant him peace, had told him to do that. Then he drew back until he was in the row, and the Messenger of Allah, may Allah bless him and grant him peace, stepped forward and led the prayer. When he had finished he said, "Abu Bakr, what stopped you from staying put like I told you?" Abu Bakr said, "It is not for Ibn Abi Quhafa to pray in front of the Messenger of Allah, may Allah bless him and grant him peace."

The Messenger of Allah, may Allah bless him and grant him peace, said, "Why did I see you all clapping so much? If something happens to you in the prayer you should say 'Subhana-llah' (Glory be to Allah), and when you say 'Subhana-llah' you will be heard. Clapping is only for women."


Malik :: Shortening the Prayer :: [9-9.20.65]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.20.65

Yahya related to me from Malik from Nafi that Ibn Umar would never turn around when praying.


Malik :: Shortening the Prayer :: [9-9.20.66]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.20.66

Yahya related to me from Malik that Abu Jafar al-Qari said, "I was praying, and Abdullah ibn Umar was behind me and I was not aware of it. Then I turned round and he prodded me (in disapproval)."


Malik :: Shortening the Prayer :: [9-9.21.67]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.21.67

Yahya related to me from Malik from Ibn Shihab that Abu Umama ibn Sahl ibn Hunayf said, "Zayd ibn Thabit entered the mosque and found the people in ruku, so he went into ruku and then moved slowly forward until he reached the row."


Malik :: Shortening the Prayer :: [9-9.21.68]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.21.68

Yahya related to me from Malik that he had heard that Abdullah ibn Masud used to move forward while in ruku.


Malik :: Shortening the Prayer :: [9-9.22.69]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.22.69

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazim from his father that Amr ibn Sulaym az-Zuraqi said, "Abu Humayd as-Saidi told me that they asked the Messenger of Allah, may Allah bless him and grant him peace, how they were to ask for blessings upon him and he replied that they should say, 'O Allah, bless Muhammad and his wives and his descendants asYou blessed the family of Ibrahim, and give baraka to Muhammad and his wives and his descendants as You gave baraka to the family of Ibrahim. You are worthy of Praise and Glorious.'"

Allahumma salli ala Muhammad wa azwajihi wa alihi kama sallaita ala ali Ibrahim, wa barakaala Muhammad wa azwajihi wa alihi kama baraktaalaali Ibrahim, innaka Hamidu'm - Majid.


Malik :: Shortening the Prayer :: [9-9.22.70]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.22.70

Yahya related to me from Malik from Nuaym ibn Abdullah al-Mujmirthat Muhammad ibn Abdullah ibn Zayd told him that Abu Masud al Ansari said, "The Messenger of Allah, may Allah bless him and grant him peace, came to us at the gathering of Sad ibn Ubada. Bashir ibn Sad said to him, 'Allah has ordered us to ask for blessings on you, Messenger of Allah. How should we do it?' The Messenger of Allah, may Allah bless him and grant him peace, remained silent until we wished we had not asked him. Then he told us to say, 'O Allah, bless Muhammad and the family of Muhammad as You blessed Ibrahim, and give baraka to Muhammad and the family of Muhammad as You gave baraka to the family of Ibrahim. In all the worlds You are worthy of Praise and Glorious,' and then give the taslim as you have learnt."

Allahumma salli ala Muhammad wa ali Muhammad kama sallaita Ibrahim, wa baraka ala Muhammad wa ali Muhammad kama baraktaala ali Ibrahim. Fi'l alamin, innaka Hamidu'm - Majid.


Malik :: Shortening the Prayer :: [9-9.22.71]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.22.71

Yahya related to me from Malik that Abdullah ibn Dinar said, "I saw Abdullah ibn Umar stop by the grave of the Prophet, may Allah bless him and grant him peace, and ask for blessings on the Prophet, may Allah bless him and grant him peace, and on Abu Bakr and Umar."


Malik :: Shortening the Prayer :: [9-9.23.72]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.72

Yahya related to me from Malik from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, used to pray two rakas before dhuhr and two rakas after it, two rakas after maghrib, in his house, and two rakas after isha. He did not pray after jumua until he had left, and then he prayed two rakas.


Malik :: Shortening the Prayer :: [9-9.23.73]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.73

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do you see the direction I am facing here? By Allah, neither your concentration nor your ruku is hidden from me. I can see you behind my back."


Malik :: Shortening the Prayer :: [9-9.23.74]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.74

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that when the Messenger of Allah, may Allah bless him and grant him peace, used to go to Quba (to pray), he would walk as well as ride.


Malik :: Shortening the Prayer :: [9-9.23.75]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.75

Yahya related to me from Malik from Yahya ibn Said from an-Numan ibn Murra that the Messenger of Allah, may Allah bless him and grant him peace, said,"What about drunkenness, stealing and adultery? "That was before anything had been revealed about them. They said, "Allah and His Messenger know best." He said, "They are excesses and in them is a punishment. And the worst of thieves is the one who steals his prayer." They said, "How does he steal his prayer, Messenger of Allah?" He replied, "He does not do ruku or sajda properly."


Malik :: Shortening the Prayer :: [9-9.23.76]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.76

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do some of the prayers in your houses."


Malik :: Shortening the Prayer :: [9-9.23.77]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.77

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "When a sick man is unable to prostrate he should motion with his head, and not raise anything to his forehead."


Malik :: Shortening the Prayer :: [9-9.23.78]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.78

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that if Abdullah ibn Umar arrived at the mosque and the people had already prayed, he would begin with the obligatory prayer and not pray anything before it.


Malik :: Shortening the Prayer :: [9-9.23.79]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.79

Yahya related to me from Malik from Nafi that Abdullah ibn Umar passed by a man who was praying and said, "Peace be upon you," and the man replied to him. Abdullah ibn Umar returned to him and said, "When someone says, 'Peace be upon you' to you while you are praying do not reply, but give a signal with your hand."


Malik :: Shortening the Prayer :: [9-9.23.80]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.80

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Someone who only remembers that he has forgotten a prayer when he is praying the next prayer behind an imam, should pray the prayer he has forgotten after the imam has said the taslim, and then pray the other one again."


Malik :: Shortening the Prayer :: [9-9.23.81]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.81

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban that his paternal uncle Wasi ibn Habban said, "I was praying, and Abdullah ibn Umar was resting his back on the wall of the qibla. When I had finished the prayer I turned towards him on my left hand side. Abdullah ibn Umar said, 'What stopped you from turning away to your right?' I replied, 'I saw you and turned towards you.' Abdullah said, 'You have spoken correctly. People say that you should turn away to your right, but when you pray, you can turn whichever way you wish. If you like, to your right, and if you like, to your left.' "


Malik :: Shortening the Prayer :: [9-9.23.82]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.82

Yahya related to me from Malik from Hisham ibn Urwa from his father that one of the muhajirun in whom he saw no harm asked Abdullah ibn Amr ibn al-As, "Can I pray in a place where camels are watered?" Abdullah replied, "No, but you can pray in a sheep-pen."


Malik :: Shortening the Prayer :: [9-9.23.83]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.23.83

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "Which prayer is it when you remain in the sitting position in every raka?'' Said said, "It is maghrib when you miss one raka, and that is the sunna in all the prayers."


Malik :: Shortening the Prayer :: [9-9.24.84]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.84

Yahya related to me from Malik from Amir ibn Abdullah ibn az-Zubayr from Amr ibn Sulaym az-Zuraqi from Abu Qutada al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, used to pray carrying Umama, who was the daughter of his daughter Zaynab by Abu'l As ibn Rabia ibn Abd Shams. When he prostrated, he put her down, and when he got up he carried her.


Malik :: Shortening the Prayer :: [9-9.24.85]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.85

Yahya related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A group of angels in the night and a group of angels in the day alternate with each other among you, and gather together at the time of the asr and fajr prayers. Then those that have spent the night among you ascend, and He asks them, and He knows best, 'How did you leave my slaves?' and they say, 'When we left them they were praying, and when we came to them they were praying.' "


Malik :: Shortening the Prayer :: [9-9.24.86]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.86

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "Tell Abu Bakr to lead the people in prayer." A'isha said, "Messenger of Allah, when Abu Bakr stands in your place his voice does not reach the ears of the people because of his weeping, so tell Umar to lead the people in prayer." He said, "Tell Abu Bakr to lead the people in prayer." A'isha continued, "I told Hafsa to tell him that when Abu Bakr stood in his place his voice did not reach the ears of the people because of his weeping, and that he should tell Umar to lead the people in prayer. Hafsa did so, and the Messenger of Allah, may Allah bless him and grant him peace, said, 'You are the companions of Yusuf! (referring to the women who cut their hands when they saw the beauty of Yusuf). Tell Abu Bakr to lead the people in prayer!' "

A'isha added that Hafsa said to her, "I have never had anything good from you!"


Malik :: Shortening the Prayer :: [9-9.24.87]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.87

Yahya related to me from Malik from Ibn Shihab from Ata ibn Yazid al-Laythi that Ubaydullah ibn Adi ibnal-Khiyar said, "Once when the Messenger of Allah, may Allah bless him and grant him peace, was sitting with some people, a man came to him and spoke secretly to him. Nobody knew what he had said until the Messenger of Allah, may Allah bless him and grant him peace, disclosed that he had asked for permission to kill one of the hypocrites. When he disclosed this, the Messenger of Allah, may Allah bless him and grant him peace, said, 'Doesn't he testify that there is no god but Allah and that Muhammad is the Messenger of Allah?' The man replied, 'Of course, but he hasn't really done so.' He said, 'Doesn't he do the prayer?' and the man replied, 'Of course, but he doesn't really do the prayer.' He said, may Allah bless him and grant him peace, 'Those are the ones whom Allah has forbidden me (to kill).' "


Malik :: Shortening the Prayer :: [9-9.24.88]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.88

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "O Allah! Do not make my grave an idol that is worshipped. The anger on those who took the graves of their Prophets as places of prostration was terrible."


Malik :: Shortening the Prayer :: [9-9.24.89]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.89

Yahya related to me from Malik from Ibn Shihab from Mahmud ibn Rabi al-Ansari that Utban ibn Malik, who was a blind man, used to lead his people in prayer, and he said to the Messenger of Allah, may Allah bless him and grant him peace, "Sometimes it is dark and rainy and there is a lot of water around outside, and I am a man who has lost his sight. Messenger of Allah, pray in a certain place in my house so that I can take it as a place to pray." The Messenger of Allah, may Allah bless him and grant him peace, came to him and said, "Where would you like me to pray?" He indicated a place to him and the Messengerof Allah, may Allah bless him and grant him peace, prayed there.


Malik :: Shortening the Prayer :: [9-9.24.90]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.90

Yahya related to me from Malik from Ibn Shihab from Abbad ibn Tamim from his paternal uncle that he saw the Messenger of Allah, may Allah bless him and grant him peace, lying down in the mosque with one foot on top of the other.

Yahya related to me from Malik from Ibn Shihab from Said ihn al-Musayyab that Umar ibn al Khattab and Uthman ibn Affan, may Allah be pleased with them, used to do the same.


Malik :: Shortening the Prayer :: [9-9.24.91]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.91

Yahya related to me from Malik from Yahya ibn Said that Abdullah ibn Masud said to a certain man, "You are in a time when men of understanding (fuqaha) are many and Qur'an reciters are few, when the limits of behaviour defined in the Qur'an are guarded and its letters are lost, when few people ask and many give, when they make the prayer long and the khutba short, and put their actions before their desires. A time will come upon men when their fuqaha are few but their Qur'an reciters are many, when the letters of the Qur'an are guarded carefully but its limits are lost, when many ask but few give, when they make the khutba long but the prayer short, and put their desires before their actions."


Malik :: Shortening the Prayer :: [9-9.24.92]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.92

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The actions which the Messenger of Allah, may Allah bless him and grant him peace, loved most were those which were done most constantly."


Malik :: Shortening the Prayer :: [9-9.24.94]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.94

Yahya related to me from Malik that he had heard from Amir ibn Sad ibn Abi Waqqas that his father said, "There were two brothers, one of whom died forty nights before the other. The merit of the first was being mentioned in the presence of the Messenger of Allah, may Allah bless him and grant him peace, and he said, 'Wasn't the other one a muslim?' They said, 'Of course, Messenger of Allah, and there was no harm in him.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'What will make you realise what his prayer has brought him. The prayer is like a deep river of sweet water running by your door into which you plunge five times a day. How much of your dirtiness do you think that will leave? You do not realise what his prayer has brought him.' "


Malik :: Shortening the Prayer :: [9-9.24.95]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.95

Yahya related to me from Malik that he had heard that if some one passed by Ata ibn Yasar in the mosque with something to trade, he would call him and ask, "What is the matter with you? What do you want?" If the man said that he wished to trade with him, he would say, "You need the market of this world. This is the market of the next world."


Malik :: Shortening the Prayer :: [9-9.24.96]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.24.96

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab set aside an area near the mosque called al-Butayha and said, "Whoever wishes to talk nonsense or recite poetry or raise his voice should go to that area."


Malik :: Shortening the Prayer :: [9-9.25.97]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.25.97

Yahya related to me from Malik from his paternal uncle Abu Suhayl ibn Malik that his father heard Talha ibn Ubaydullah say, "Once one of the people of Najd came to the Messenger of Allah, may Allah bless him and grant him peace. He had dishevelled hair and although his voice could be heard we could not make out what he was saying until he drew nearer and then we found he was asking about Islam. The Messenger of Allah, may Allah bless him and grant him peace, said to him, 'There are five prayers during the day and the night.' He said, 'Do I have to do anything else besides that?' The Messenger of Allah, may Allah bless him and grant him peace, added, 'And fasting the month of Ramadan.' He said, 'Is there anything else I have to do?' He said, 'No, except what you do of your own accord.' The Messenger of Allah, may Allah bless him and grant him peace, mentioned zakat. The man said, 'Is there anything else that I have to do?' He said, 'No, except what you do of your own accord.'

He continued, "The man went away saying, 'By Allah, I won't do any more than this, nor will I do any less.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'That man will be successful, if he is telling the truth.'


Malik :: Shortening the Prayer :: [9-9.25.98]

Shortening the Prayer

Malik :: Book 9 : Hadith 9.25.98

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Shaytan ties three knots at the back of your head when you sleep, and he seals the place of each knot with 'You have a long night ahead, so sleep.' If you wake up and remember Allah, a knot is untied. If you do wudu, a knot is untied. If you pray, a knot is untied, and morning finds you lively and in good spirits, and if not, morning finds you in bad spirits and lazy."


Malik :: The Two 'Ids :: [10-10.1.1]

The Two 'Ids

Malik :: Book 10 : Hadith 10.1.1

Yahya related to me from Malik that he had heard more than one of their men of knowledge say, "There has been no call to prayer or iqama for the id al-Fitr or the id al-Adha since the time of the Messenger of Allah, may Allah bless him and grant him peace."

Malik said, "That is the sunna about which there is no disagreement among us."


Malik :: The Two 'Ids :: [10-10.1.2]

The Two 'Ids

Malik :: Book 10 : Hadith 10.1.2

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to do ghusl on the day of Fitr before going to the place of prayer.


Malik :: The Two 'Ids :: [10-10.2.3]

The Two 'Ids

Malik :: Book 10 : Hadith 10.2.3

Yahya related to me from Malik from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, used to pray on the day of Fitr and the day of Adha before the khutba.


Malik :: The Two 'Ids :: [10-10.2.4]

The Two 'Ids

Malik :: Book 10 : Hadith 10.2.4

Yahya related to me from Malik that he had heard that Abu Bakr and Umar used to do that.


Malik :: The Two 'Ids :: [10-10.2.5]

The Two 'Ids

Malik :: Book 10 : Hadith 10.2.5

Yahya related to me from Malik from Ibn Shihab that Abu Ubayd, the mawla of Ibn Azhar said, "I was present at an id with Umar ibn al-Khattab. He prayed, and then after he had prayed he gave a khutba to the people and said, 'The Messenger of Allah, may Allah bless him and grant him peace, forbade fasting on these two days - the day you break your fast (after Ramadan), and the day you eat from your sacrifice (after Hajj) .' "

Abu Ubaydcontinued,"Then I was present at an id with Uthman ibn Affan. He came and prayed, and when he had finished he gave a khutba and said, 'Two ids have been joined together for you on this day of yours. If any of the people of al-Aliyya (the hills outlying Madina) want to wait for the jumua they can do so, and if any of them want to return, I have given them permission.' Abu Ubayd continued, "Then I was present at an id with AIi ibn Abi Talib (at the time when Uthman was being detained). He came and prayed, and then after he had prayed he gave a khutba."


Malik :: The Two 'Ids :: [10-10.3.6]

The Two 'Ids

Malik :: Book 10 : Hadith 10.3.6

Yahya related to me from Malik from Hisham ibn Urwa from his father that he used to eat on the day of the id al-Fitr before going out.


Malik :: The Two 'Ids :: [10-10.3.7]

The Two 'Ids

Malik :: Book 10 : Hadith 10.3.7

Yahya related to me from Malik from Ibn Shihab that Said al-Musayyab told him that people used to be told to eat on the day of Fitr before setting out. Malik said that he did not consider that people had to do that for Adha.


Malik :: The Two 'Ids :: [10-10.4.8]

The Two 'Ids

Malik :: Book 10 : Hadith 10.4.8

Yahya related to me from Malik from Damra ibn Said al-Mazini from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Umar ibn al-Khattab asked Abu Waqid al-Laythi what the Messenger of Allah, may Allah bless him and grant him peace, used to recite in the prayers of Adha and Fitr. He said, "He used to recite Qaf (Sura 50) and al-lnshiqaq (Sura84)."


Malik :: The Two 'Ids :: [10-10.4.9]

The Two 'Ids

Malik :: Book 10 : Hadith 10.4.9

Yahya related to me from Malik that Nafi, the mawla of Abdullah ibn Umar said, "I was at Adha and Fitr with Abu Hurayra and he said 'Allah is greater' seven times in the first raka, before the recitation, and five times in the second, before the recitation."


Malik :: The Two 'Ids :: [10-10.5.10]

The Two 'Ids

Malik :: Book 10 : Hadith 10.5.10

Yahya related to me from Malik from Nafi that Abdullah ibn Umar did not pray either before the prayer or after it on the day of Fitr.


Malik :: The Two 'Ids :: [10-10.5.11]

The Two 'Ids

Malik :: Book 10 : Hadith 10.5.11

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab used to go to the place of prayer after praying subh, and before the sun rose.


Malik :: The Two 'Ids :: [10-10.6.12]

The Two 'Ids

Malik :: Book 10 : Hadith 10.6.12

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father used to pray four rakas before he went to the place of prayer.


Malik :: The Two 'Ids :: [10-10.6.13]

The Two 'Ids

Malik :: Book 10 : Hadith 10.6.13

Yahya related to me from Hisham ibn Urwa that his father used to pray on the day of Fitr before the prayer in the mosque.

10.7 The Coming of the Imam on the Day of the Id and Waiting for the Khutba


Malik :: The Two 'Ids :: [10-10.7.14]

The Two 'Ids

Malik :: Book 10 : Hadith 10.7.14

Yahya related to me that Malik said, "The sunna concerning the time of prayer on the ids of Fitr and Adha - and there is no disagreement amongst us about it - is that the imam leaves his house and as soon as he has reached the place of prayer the prayer falls due."

Yahya said that Malik was asked whether a man who prayed with the imam could leave before the khutba, and he said, "He should not leave until the imam leaves."


Malik :: The Fear Prayer :: [11-11.1.1]

The Fear Prayer

Malik :: Book 11 : Hadith 11.1.1

Yahya related to me from Malik from Yazid ibn Ruman from Salih ibn Khawwat from someone who had prayed (the prayer of fear) with the Messenger of Allah, may Allah bless him and grant him peace, on the day of Dhat ar-Riqa that one group had formed a row with him and one group had formed a row opposite the enemy. He then prayed one raka with the group he was with, and then remained standing while they finished by themselves. They then left and formed a row opposite the enemy, and then the other group came and he prayed the remaining raka of his prayer with them, and then remained sitting while they finished by themselves. Then he said the taslim with them.


Malik :: The Fear Prayer :: [11-11.1.2]

The Fear Prayer

Malik :: Book 11 : Hadith 11.1.2

Yahya related to me from Malik from Yahya ibn Said from al-Qasim ibn Muhammad from Salih ibn Khawwat that Sahl ibn Abi Hathma related to him that the form of the prayer of fear was that the imam stood with a group of his companions, while another group faced the enemy. The imam prayed one raka with them, including the prostration, and then stood. He remained standing while they completed the remaining raka by themselves. They then said the taslim, left, and formed up opposite the enemy while the imam remained standing. Then the others who had not prayed came forward and said the takbir behind the imam and he prayed one raka with them, including the prostration. He then said the taslim, while they stood up and prayed the remaining raka by themselves. Then they said the taslim.


Malik :: The Fear Prayer :: [11-11.1.3]

The Fear Prayer

Malik :: Book 11 : Hadith 11.1.3

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, when asked about the fear prayer said, "The imam and a group of people go forward and the imam prays a raka with them, while another group, who have not yet prayed, position themselves between him and the enemy. When those who are with him have prayed a raka they draw back to where those who have not prayed are, and do not say the taslim. Then those who have not prayed come forward and pray a raka with him. Then the imam leaves, as he has now prayed two rakas. Everyone else in the two groups stands and prays a raka by himself after the imam has left. In this way each of the two groups will have prayed two rakas. If the fear is greater than that, then the men pray standing on their feet or mounted, either facing the qibla or otherwise."

Malik said that Nafi said, "I do not believe that Abdullah ibn Umar related it from anyone other than the Messenger of Allah, may Allah bless him and grant him peace."


Malik :: The Fear Prayer :: [11-11.1.4]

The Fear Prayer

Malik :: Book 11 : Hadith 11.1.4

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "The Messenger of Allah, may Allah bless him and grant him peace, did not pray dhuhr and asr on the day of the Trench until after the sun had set."

Malik said, "The hadith of al-Qasim ibn Muhammad from Salih ibn Khawwat is the one I like most out of what I have heard about the fear prayer."


Malik :: The Eclipse Prayer :: [12-12.1.1]

The Eclipse Prayer

Malik :: Book 12 : Hadith 12.1.1

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "There was an eclipse of the sun in the time of the Messenger of Allah, may Allah bless him and grant him peace, and the Messenger of Allah, may Allah bless him and grant him peace, led the people in prayer. He stood, and did so for a long time. Then he went into ruku, and made the ruku long. Then he stood again, and did so for a long time, though not as long as the first time. Then he went into ruku, and made the ruku long, though not as long as thefirst time. Then he rose, and went down into sajda. He then did the same in the second raka, and by the time he had finished the sun had appeared. He then gave a khutba to the people, in which he praised Allah and then said, 'The sun and the moon are two of Allah's signs. They do not eclipse for anyone's death nor for anyone's life. When you see an eclipse, call on Allah and say, "Allah is greater" and give sadaqa.' Then he said, 'O community of Muhammad! ByAllah, there is no-one more jealous than Allah of a male or female slave of his who commits adultery. O community of Muhammad! By Allah, if you knew what I knew, you would laugh little and weep much'."


Malik :: The Eclipse Prayer :: [12-12.1.2]

The Eclipse Prayer

Malik :: Book 12 : Hadith 12.1.2

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that Abdullah ibn Abbas said, "There was an eclipse of the sun and the Messenger of Allah, may Allah bless him and grant him peace, prayed, and the people prayed with him. He stood for a long time, nearly as long as (it takes to recite) Surat al-Baqara (Sura 2), and then went into ruku for a long time. Then he rose and stood for a long time, though less than the first time.Then he went into ruku for a long time, though less than the first time. Then he went down into sajda. Then he stood for a long time, though less than the first time. Then he went into ruku for a long time, though less than the first time. Then he rose and stood for a long time, though less than the firsttime. Then he went into ruku for a long time, though less than the first time. Then he went down into sajda, and by the time he had finished the sun had appeared. Then he said, 'The sun and the moon are two of Allah's signs. They do not eclipse for anyone's death nor for anyone's life. When you see an eclipse, remember Allah.' They said, 'Messenger of Allah, we saw you reach out for something while you were standing here and then we saw you withdraw.' He said, 'I saw the Garden and I reached out for a bunch of grapes from it, and if I had taken it you would have been able to eat from it for as long as this world lasted. Then I saw the Fire - and I have never seen anything more hideous than what I saw today - and I saw that most of its people were women.' They said, 'Why, Messenger of Allah?' He said, 'Because of their ungratefulness (kufr).' Someone said, 'Are they ungrateful toAllah?' He said, 'They are ungrateful to their husbands and they are ungrateful for good behaviour (towards them) . Even if you were to behave well towards one of them for a whole lifetime and then she were to see you do something (that she did not like) she would say that she had never seen anything good from you.' "


Malik :: The Eclipse Prayer :: [12-12.1.3]

The Eclipse Prayer

Malik :: Book 12 : Hadith 12.1.3

Yahya related to me from Malik from Yahya ibn Said from 'Amra bint Abd ar-Rahman from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that a jewish woman came to beg from her and said, "May Allah give you refuge from the punishment of the grave." So A'isha asked the Messenger of Allah, may Allah bless him and grant him peace, "Are people punished in their graves?", and the Messenger of Allah, may Allah bless him and grant him peace, took refuge in Allah from that. Then one morning the Messenger of Allah, may Allah bless him and grant him peace, went out on a journey and there was an eclipse of the sun, and he returned in the late morning and passed through his apartments. Then he stood and prayed, and the people stood behind him. He stood for a long time, and then went into ruku for a long time. Then he rose and stood for a long time, though less than the first time, and then went into ruku for a long time, though less than the first time. Then he rose, and went down into sajda. Then he stood for a long time, though less than the time before, and then went into ruku for a long time, though less than the time before. Then he rose and stood for a long time, though less than the time before, and then went into ruku for a long time, though less than the time before. Then he rose, and went down into sajda. When he had finished he said what Allah willed him to say, and then he told them to seek protection for themselves from the punishment of the grave."


Malik :: The Eclipse Prayer :: [12-12.2.4]

The Eclipse Prayer

Malik :: Book 12 : Hadith 12.2.4

Yahya related to me from Malik from Hisham ibn Urwa from Fatima bint al Mundhir that Asma bint Abi Bakr as-Siddiq said, "I went to A'isha, the wife of the Prophet, may Allah bless him and grant him peace, during an eclipse of the sun, and everybody was standing in prayer, and she too was standing praying. I said, 'What is everybody doing?' She pointed towards the sky with her hand and said, 'Glory be to Allah.' I said, 'A sign?' She nodded 'Yes' with her head."

She continued, "I stood until I had almost fainted, and I began to pour water over my head. The Messenger of Allah, may Allah bless him and grant him peace, praised Allah and spoke well of Him, and then said, 'There is nothing which I had previously not seen beforehand that I have not now seen while standing - even the Garden and the Fire. It has been revealed to me that you will be tried in your graves with a trial, like, or near to, the trial of the Dajjal (I do not know which one Asma said). Every one of you will have someone who comes to him and asks him, 'What do you know about this man?' A mumin, or one who has certainty (muqin) (I do not know which one Asma said), will say, 'He is Muhammad, the Messenger of Allah, may Allah bless him and grant him peace, who came to us with clear proofs and guidance, and we answered and believed and followed.' He will then be told, 'Sleep in a good state. We know now that you were a mumin.' A hypocrite, however, or one who has doubts (l do not know which one Asma said), will say, 'I do not know, I heard everybody saying something and I said it.' "


Malik :: Asking for Rain :: [13-13.1.1]

Asking for Rain

Malik :: Book 13 : Hadith 13.1.1

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Amr ibn Hazm that he had heard Abbad ibn Tamim say that he had heard Abdullah ibn Zayd al-Mazini say, "The Messenger of Allah, may Allah bless him and grant him peace, came out to the place of prayer and asked for rain, and when he faced the qibla he turned his cloak inside out."

Malik was asked how many rakas there were in the prayer of asking for rain and he said, "Two rakas, and the imam does the prayer before he gives the khutba. He prays two rakas, and then he gives a khutba and makes dua, facing the qibla and turning his cloak inside out. He recites out loud in both rakas, and when he turns his cloak inside out he puts what is on his right on his left, and what is on his left on his right, and all the people turn their cloaks inside out when the imam does so, and face the qibla, sitting."


Malik :: Asking for Rain :: [13-13.2.2]

Asking for Rain

Malik :: Book 13 : Hadith 13.2.2

Yahya related to me from Malik from Yahya ibn Said from Amr ibn Shuayb that the Messenger of Allah, may Allah bless him and grant him peace, said, when he asked for rain, "O Allah, give water to Your slaves and Your animals, and spread Your mercy, and give life to Your dead land."


Malik :: Asking for Rain :: [13-13.2.3]

Asking for Rain

Malik :: Book 13 : Hadith 13.2.3

Yahya related to me from Malik from Sharik ibn Abdullah ibn Abi Namir that Anas ibn Malik said, "A man came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, our animals are dying and our camels are too weak to travel, so make dua to Allah.' The Messenger of Allah, may Allah bless him and grant him peace, made dua, and it rained on us from one jumua to the next."

Anas continued, "Then a man came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, our houses have fallen down, the paths are blocked, and our flocks are dying.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'O Allah, (only) the mountain and hill-tops, the valley bottoms, and the places where trees grow.' "

Anas added, "It cleared away from Madina like a garment being removed."

Malik said, about a man who missed the prayer of asking for rain but caught the khutba, and wished to pray in the mosque, or in his house when he returned, "He is free to do so, or not, as he wishes."


Malik :: Asking for Rain :: [13-13.3.4]

Asking for Rain

Malik :: Book 13 : Hadith 13.3.4

Yahya related to me from Malik from Salih ibn Kaysan from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Zayd ibn Khalid al-Juhani said, "The Messenger of Allah, may Allah bless him and grant him peace, took the subh prayer with us at Hudaybiyya after it had rained in the night. When he had finished he went up to the people and said, 'Do you know what your Lord has said?' They said, 'Allah and His Messenger know best.' He said, 'Some of my slaves have begun the morning believing in Me, and others have begun it rejecting Me. As for those who say, 'We were rained on by the overflowing favour of Allah and His mercy,' they believe in Me and reject the stars. But as for those who say, 'We were rained on by such and such a star, they reject Me and believe in the stars.' "


Malik :: Asking for Rain :: [13-13.3.5]

Asking for Rain

Malik :: Book 13 : Hadith 13.3.5

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, used to say, "When a cloud appears from the direction of the sea and then goes towards ash-Sham, it will be an abundant source of rain."


Malik :: Asking for Rain :: [13-13.3.6]

Asking for Rain

Malik :: Book 13 : Hadith 13.3.6

Yahya related to me from Malik that he had heard that Abu Hurayra used to say, when morning came after it had rained on the people, "We have been rained upon by the rain of Allah's opening," and would then recite the ayat, "Whatever Allah opens to man of His mercy no-one can withhold, and whatever He withholds no-one can send forward after Him. " (Sura 35 ayat 2).


Malik :: The Qibla :: [14-14.1.1]

The Qibla

Malik :: Book 14 : Hadith 14.1.1

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Rafiibn Ishaq, a mawla of the family of ash-Shifa who was known as the mawla of Abu Talha, heard Abu Ayyub al-Ansari, one of the companions of the Messenger of Allah, may Allah bless him and grant him peace, say, while he was in Egypt, "By Allah! I don't know how to deal with these lavatories." The Messenger of Allah, may Allah bless him and grant him peace, said, "When you go to defecate or urinate, do not expose your genitals towards the qibla, and do not put your back to it."


Malik :: The Qibla :: [14-14.1.2]

The Qibla

Malik :: Book 14 : Hadith 14.1.2

Yahya related to me from Malik from one of the Ansar that the Messenger of Allah, may Allah bless him and grant him peace, forbade defecating or urinating while facing the qibla.

14.2 Permission to Face the Qibla when Urinating or Defecating


Malik :: The Qibla :: [14-14.2.3]

The Qibla

Malik :: Book 14 : Hadith 14.2.3

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban from his paternal uncle, Wasi ibn Habban, that Abdullah ibn Umar said, "People say, 'When you sit to relieve yourself, do not face the qibla or the Bayt al-Maqdis.' "

Abdullah continued, "I went upon top of a house of ours and saw the Messenger of Allah, may Allah bless him and grant him peace, (squatting) on two unfired bricks facing the Bayt al-Maqdis, relieving himself."

Ibn Umar added, "Perhaps you are one of those who pray folded on their haunches."

Wasi replied, "I don't know, by Allah!"

Malik said that he meant som one who, when he prostrated, kept his body close to the ground.


Malik :: The Qibla :: [14-14.3.4]

The Qibla

Malik :: Book 14 : Hadith 14.3.4

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, saw spittle on the wall of the qibla and scraped it off. Then he went up to the people and said, "Do not spit in front of you when you are praying, because Allah, the Blessed and Exalted, is in front of you when you pray."


Malik :: The Qibla :: [14-14.3.5]

The Qibla

Malik :: Book 14 : Hadith 14.3.5

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, mayAllah bless him and grant him peace, that the Prophet, may Allah bless him and grant him peace, saw spittle, or mucus or phlegm, on the wall of the qibla and scraped it off.


Malik :: The Qibla :: [14-14.3.6]

The Qibla

Malik :: Book 14 : Hadith 14.3.6

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar said, "On one occasion when the people were praying subhat Quba a man came to them and said, 'A piece of Qur'an was sent down to the Messenger of Allah, may Allah bless him and grant him peace, last night, and he was ordered to face the Kaba, so face it.' They had been facing ash-Sham, so they turned round and faced the Kaba.''


Malik :: The Qibla :: [14-14.3.7]

The Qibla

Malik :: Book 14 : Hadith 14.3.7

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "The Messenger of Allah, may Allah bless him and grant him peace, prayed towards the Baytal-Maqdis for sixteen months after arriving in Madina. Then the qibla was moved, two months before the battle of Badr. "


Malik :: The Qibla :: [14-14.3.8]

The Qibla

Malik :: Book 14 : Hadith 14.3.8

Yahya related to me from Malik from Nafi that Umar ibn al-Khattab said, "Any direction that is between east and west can be taken as a qibla if the person praying is face-on to the House."


Malik :: The Qibla :: [14-14.4.9]

The Qibla

Malik :: Book 14 : Hadith 14.4.9

Yahya related to me from Malik from Zayd ibn Rabah and Ubaydullah ibn Abi Abdullah Salman al-Agharr from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A prayer in this mosque of mine is better than a thousand prayers in any other mosque, except the Masjid al-Haram (in Makka)."


Malik :: The Qibla :: [14-14.4.10]

The Qibla

Malik :: Book 14 : Hadith 14.4.10

Yahya related to me from Malik from Khubayb ibn Abd ar-Rahman from Hafs ibn Asim from Abu Hurayra or from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, said, "What is between my house and my mimbar is one of the meadows of the Garden, and my mimbar is on my watering-place (al-Hawd)."


Malik :: The Qibla :: [14-14.4.11]

The Qibla

Malik :: Book 14 : Hadith 14.4.11

Yahya related to me from Malik from Abdullah ibn Abi Bakr from Abbad ibn Tamim from Abdullah ibn Zayd al-Mazini that the Messenger of Allah, may Allah bless him and grant him peace, said, "What is between my house and my mimbar is one of the meadows of the Garden."


Malik :: The Qibla :: [14-14.5.12]

The Qibla

Malik :: Book 14 : Hadith 14.5.12

Yahya related to me from Malik that he had heard that Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Do not forbid the female slaves of Allah from (going into) the mosques of Allah.' "


Malik :: The Qibla :: [14-14.5.13]

The Qibla

Malik :: Book 14 : Hadith 14.5.13

Yahya related to me from Malik that he had heard from Busr ibn Said that the Messenger of Allah, may Allah bless him and grant him peace, said, "None of you women should use perfume when you are present at the isha prayer."


Malik :: The Qibla :: [14-14.5.14]

The Qibla

Malik :: Book 14 : Hadith 14.5.14

Yahya related to me from Malik from Yahya ibn Said that Atika bint Zayd ibn Amr ibn Nufayl, the wife of Umar ibn al-Khattab, used to ask Umar ibn al-Khattab for permission to go to the mosque. He would keep silent, so she would say, "By Allah, I will go out, unless you forbid me," and he would not forbid her.


Malik :: The Qibla :: [14-14.5.15]

The Qibla

Malik :: Book 14 : Hadith 14.5.15

Yahya related to me from Malik from Yahya ibn Said from Amra bint Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "If the Messenger of Allah, may Allah bless him and grant him peace, had seen what women do now, he would have forbidden them to go into the mosques, just as the women of the Bani Israil were forbidden."

Yahya ibn Said said that he asked Amra, "Were the women of the Bani Israil forbidden to go into the mosques?" and she said, "Yes."


Malik :: The Qur'an :: [15-15.1.1]

The Qur'an

Malik :: Book 15 : Hadith 15.1.1

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazm that in a letter that the Messenger of Allah, may Allah bless him and grant him peace, sent to Amr ibn Hazm it said that no-one should touch the Qur'an unless he was pure.

Malik said, "No-one should carry the Qur'an by its strap, or on a cushion, unless he is pure. If it were permissible to do so, it would also have been permissible to carry it in its cover. This is not because there is something on the hands of the one who carries it by which the Qur'an will be soiled, but because it is disapproved of for someone to carry the Qur'an without being pure out of respect for the Qur'an, and in order to honour it."

Malik said, "The best thing that I have heard about this is the ayat 'None touch it except the purified.' (Sura 56 ayat 79) It ranks with the ayat in Surat Abasa (Sura 80), where Allah, the Blessed and Exalted, says, 'No, it is a reminder, and whoever wishes will remember it. Upon honoured pages, exalted and purified, by the hands of scribes, noble and obedient.' "


Malik :: The Qur'an :: [15-15.2.2]

The Qur'an

Malik :: Book 15 : Hadith 15.2.2

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani from Muhammad ibn Sirin that Umar ibn al-Khattab was with some people who were reciting Qur'an. He went to relieve himself and then came back and recited Qur'an. One of the men said to him, "Amir al muminin, are you reciting the Qur'an without being in wudu?" Umar replied, "Who gave you a verdict on this? Was it Musaylima?"'


Malik :: The Qur'an :: [15-15.3.3]

The Qur'an

Malik :: Book 15 : Hadith 15.3.3

Yahya related to me from Malik from Dawud ibn al-Husayn from al-Araj from Abd ar-Rahman ibn Abd al-Qari that Umar ibn al Khattab said, "Whoever misses reading his hizb at night and reads it from when the sun has passed the meridian until the dhuhr prayer has not missed it, or it is as if he has caught it."


Malik :: The Qur'an :: [15-15.3.4]

The Qur'an

Malik :: Book 15 : Hadith 15.3.4

Yahya related to me from Malik that Yahya ibn Said said, "Once Muhammad ibn Yahya ibn Habban and I were sitting down, and Muhammad called a man over to him and said to him, 'Tell me what you have heard from your father.' The man replied that his father had told him that he went to Zayd ibn Thabit and asked him, 'What do you think of reciting the whole Qur'an in seven days?' Zayd said, 'That's good, but I prefer to recite it in two weeks, or ten days. Ask me why that is.' He said, 'I ask you then.' Zayd said, 'So that I can reflect on it and pause in it.' "


Malik :: The Qur'an :: [15-15.4.5]

The Qur'an

Malik :: Book 15 : Hadith 15.4.5

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that Abd ar-Rahman ibn Abd al-Qari said that he had heard Umar ibn al-Khattab say, "I heard Hisham ibn Hakim ibn Hizam reciting Surat al-Furqan (Sura 25) differently from me, and it was the Messenger of Allah, may Allah bless him and grant him peace, who had recited it to me. I was about to rush up to him but I granted him a respite until he had finished his prayer. Then I grabbed him by his cloak and took him to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, I heard this man reciting Surat al-Furqan differently from the way you recited it to me.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Let him go.' Then he said, 'Recite, Hisham,' and Hisham recited as I had heard him recite. The Messenger of Allah, may Allah bless him and grant him peace, said, 'It was sent down like that.' Then he said to me, 'Recite' and I recited the sura, and he said, 'It was sent down like that. This Qur'an was sent down in seven (different) ways, so recite from it whatever is easy for you .' "


Malik :: The Qur'an :: [15-15.4.6]

The Qur'an

Malik :: Book 15 : Hadith 15.4.6

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "A man who knows the Qur'an well is like a man who has a hobbled camel. If he takes care of it, he keeps it, and if he lets it go, it gets away."


Malik :: The Qur'an :: [15-15.4.7]

The Qur'an

Malik :: Book 15 : Hadith 15.4.7

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that al-Harith ibn Hisham asked the Messenger of Allah, may Allah bless him and grant him peace, "How does the revelation come to you?" and the Messenger of Allah, may Allah bless him and grant him peace, said, "Sometimes it comes to me like the ringing of a bell, and that is the hardest for me, and when it leaves me I remember what it has said. And sometimes the angel appears to me in the likeness of a man and talks to me and I remember what he says."

A'isha added, "I saw it coming down on him on an intensely cold day, and when it had left him his forehead was dripping with sweat."


Malik :: The Qur'an :: [15-15.4.8]

The Qur'an

Malik :: Book 15 : Hadith 15.4.8

Yahya related to me from Malik from Hisham ibn Urwa that his father said that Abasa (Sura 80) was sent down about Abdullah ibn Umm Maktum. He came to the Prophet, may Allah bless him and grant him peace, and began to say, "O Muhammad, show me a place near you (where I can sit)," whilst one of the leading men of the idol worshippers was in audience with the Prophet, may Allah bless him and grant him peace. The Prophet, may Allah bless him and grant him peace, began to turn away from him and give his attention to the other man, and he said to him, "Father of so-and-so, do you see any harm in what I am saying?" and he said, "No, by the blood (of our sacrifices) I see no harm in what you are saying." And Abasa - "He frowned and turned away when the blind man came" - was sent down.


Malik :: The Qur'an :: [15-15.4.9]

The Qur'an

Malik :: Book 15 : Hadith 15.4.9

Yahya related to me from Malik from Zayd ibn Aslam from his father that the Messenger of Allah, may Allah bless him and grant him peace, was on one of his journeys, and one night Umar ibn al-Khattab, who was travelling with him, asked him about something, but he did not answer him. He asked him again, but he did not answer him. Then he asked him again, and again he did not answer him. Umar said, "May your mother be bereaved of you, Umar. Three times you have importuned the Messenger of Allah, may Allah bless him and grant him peace, with a question and he has not answered you at all."

Umar continued, "I got my camel moving until, when I was in f ront of the people, I feared that a piece of Qur'an was being sent down about me. It was not long before I heard a crier calling for me, and I said that I feared that a piece of Qur'an had been sent down about me." He continued, "I came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Peace be upon you' to him, and he said, 'A sura has been sent down to me this night that is more beloved to me than anything on which the sun rises.' Then he recited al-Fath (Sura 48).


Malik :: The Qur'an :: [15-15.4.10]

The Qur'an

Malik :: Book 15 : Hadith 15.4.10

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Ibrahim ibn al-Harith at-Taymi from Abu Salama ibn Abd ar Rahman that Abu Said said that he had heard the Messenger of Allah, may Allah bless him and grant him peace, say, "A group of people will appear among you whose prayer, fasting and deeds will make you think little of your own prayer, fasting and deeds. They will recite the Qur'an, but it wil not get past their throats, and they will pass through the deen like an arrow passes through game. You look at the arrowhead, and you see nothing, and you look at the shaft, and you see nothing, and you look at the flights, and you see nothing. And you are in doubt about the notch."


Malik :: The Qur'an :: [15-15.4.11]

The Qur'an

Malik :: Book 15 : Hadith 15.4.11

Yahya related to me from Malik that he had heard that it took Abdullah ibn Umar eight years to learn Surat al-Baqara. (Sura 2)

15.5 The Prostration of the Qur'an


Malik :: The Qur'an :: [15-15.5.12]

The Qur'an

Malik :: Book 15 : Hadith 15.5.12

Yahya related to me from Malik from Abdullah ibn Yazid, the mawla of al Aswad ibn Sufyan, from Abu Salama ibn Abd ar Rahman that Abu Hurayra recited al-Inshiqaq (Sura 84) to them and prostrated in it. When he had finished he told them that the Messenger of Allah, may Allah bless him and grant him peace, had prostrated in it.


Malik :: The Qur'an :: [15-15.5.13]

The Qur'an

Malik :: Book 15 : Hadith 15.5.13

Yahya related to me from Malik from Nafi, the mawla of Ibn Umar that a man from Egypt told him that Umar ibn al-Khattab recited Surat al-Hajj (Sura 22) and prostrated twice in it, and then said, "This sura has been given special preference by having two prostrations in it."


Malik :: The Qur'an :: [15-15.5.14]

The Qur'an

Malik :: Book 15 : Hadith 15.5.14

Yahya related to me from Malik that Abdullah ibn Dinar said, "I saw Abdullah ibn Umar prostrate twice in Surat al-Hajj (Sura 22)."


Malik :: The Qur'an :: [15-15.5.15]

The Qur'an

Malik :: Book 15 : Hadith 15.5.15

Yahya related to me from Malik from Ibn Shihab from al-Araj that Umar ibn al Khattab recited Surat an-Najm (Sura 53) and prostrated in it, and then got up and recited another sura.


Malik :: The Qur'an :: [15-15.5.16]

The Qur'an

Malik :: Book 15 : Hadith 15.5.16

Yahya related to me from Malik from Hisham ibn Urwa from his father that Umar ibn al-Khattab once recited a piece of Qur'an requiring a prostration while he was on the mimbar on the day of jumua, and he came down and prostrated, and everyone prostrated with him. Then he recited it again the next jumua and everybody prepared to prostrate but he said, "At your ease. Allah has not prescribed it for us, unless we wish." He did not prostrate, and he stopped them from prostrating.

Malik said, "The imam does not come down and prostrate when he recites a piece of Qur'an requiring a prostration while he is on the mimbar."

Malik said, "The position with us is that there are eleven prescribed prostrations in the Qur'an, none of which are in the mufassal."

Malik said, "No-one should recite any of the pieces of Qur'an that require a prostration after the prayers of subh and asr. This is because the Messenger of Allah, may Allah bless him and grant him peace, forbade prayer after subh until after the sun had risen, and after asr until the sun had set, and prostration is part of the prayer. So no-one should recite any piece of Qur'an requiring a prostration during these two periods of time."

Malik was asked whether a menstruating woman could prostrate if she heard some-one reciting a passage of Qur'an requiring a prostration, and he said, "Neither a man nor a woman should prostrate unless they are ritually pure."

Malik was asked whether a man in the company of a woman who was reciting a passage of Qur'an requiring a prostration should prostrate with her, and he said, "He does not have to prostrate with her. The prostration is only obligatory for people who are with a man who is leading them. He recites the piece and they prostrate with him. Some one who hears a piece of Qur'an that requires a prostration being recited by a man who is not leading him in prayer does not have to do the prostration."


Malik :: The Qur'an :: [15-15.6.17]

The Qur'an

Malik :: Book 15 : Hadith 15.6.17

Yahya related to me from Malik from Abd ar-Rahman ibn Abdullah ibn Sasaca from his father that Abu Said al-Khudri heard a man reciting Surat al-Ikhlas (Sura 112), repeating it over and over again. In the morning he went to the Messenger of Allah, may Allah bless him and grant him peace, and mentioned it to him, as if he thought little of it. The Messenger of Allah, may Allah bless him and grant him peace, said, "Bythe One in whose hand my self is, it is equal to one third of the Qur'an."


Malik :: The Qur'an :: [15-15.6.18]

The Qur'an

Malik :: Book 15 : Hadith 15.6.18

Yahya related to me from Malik from Ubaydullah ibn Abd ar-Rahman that Ubayd ibn Hunayn, the mawla of the family of Zayd ibn al Khattab, said that he had heard Abu Hurayra say, "I was going along with the Messenger of Allah, may Allah bless him and grant him peace, when he heard a man reciting Surat al-Ikhlas (Sura 112). The Messenger of Allah, may Allah bless him and grant him peace, said, 'It is obligatory,' and I asked him, 'What is, Messenger of Allah?' and he said, 'The Garden.' I wanted to tell the man the good news but I was afraid that I would miss the midday meal with the Messenger of Allah, may Allah bless him and grant him peace, and I preferred to eat with the Messenger of Allah, may Allah bless him and grant him peace. When I went to the man afterwards I found that he had gone."


Malik :: The Qur'an :: [15-15.6.19]

The Qur'an

Malik :: Book 15 : Hadith 15.6.19

Yahya related to me from Malik from Ibn Shihab that Humayd ibn Abd ar-Rahman ibn Awf had told him that Surat al-Ikhlas (Sura 112) was equal to a third of the Qur'an, and that Surat al-Mulk (Sura 67) pleaded for its owner.


Malik :: The Qur'an :: [15-15.7.20]

The Qur'an

Malik :: Book 15 : Hadith 15.7.20

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever says 'There is no god but Allah, alone, without any partner. The Kingdom and praise belong to Him and He has power over everything' (La ilaha illa'llah, wahdahu la sharika lah, lahu'l mulku wa lahu'l hamd, wa huwa ala kulli shay'in qadir) one hundred times a day, it is the same for him as freeing ten slaves. One hundred good actions are written for him and one hundred wrong actions are erased from him, and it is a protection from Shaytan for that day until the night. No-one does anything more excellent than what he does except someone who does more than that."


Malik :: The Qur'an :: [15-15.7.21]

The Qur'an

Malik :: Book 15 : Hadith 15.7.21

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever says, 'Glory be to Allah and with His praise' (Subhana'llah wa bi-hamdihi) one hundred times in a day will have his wrong actions taken away from him, even if they are as abundant as the foam on the sea."


Malik :: The Qur'an :: [15-15.7.22]

The Qur'an

Malik :: Book 15 : Hadith 15.7.22

Yahya related to me from Malik from Abu Ubayd, the mawla of Sulayman ibn Abd al-Malik, from Ata ibn Yazid al-Laythi that Abu Hurayra said, "Whoever says 'Glory be to Allah' (Subhana'llah) thirty-three times and 'Allah is Greater' (Allahu akbar) thirty-three times and 'Praise be to Allah' (al-hamdu lillah) thirty-three times, and seals the hundred with 'There is no god but Allah, alone without any partner. The Kingdom and praise belong to Him and He has power over everything' (La ilaha illa'llah, wahdahu la sharika lah, lahu'l mulku wa lahu'l hamd, wa huwa ala kulli shay'in qadir) after every prayer will have his wrong actions forgiven him even if they are abundant as the foam on the sea."


Malik :: The Qur'an :: [15-15.7.23]

The Qur'an

Malik :: Book 15 : Hadith 15.7.23

Yahya related to me from Malik that Umara ibn Sayyad had heard Said ibn al Musayyab say about abiding good deeds that they were a slave's saying 'Allah is greater' (Allahu akbar) and 'Glory be to Allah' (Subahana'llah) and 'Praise be to Allah' (al-hamdu lillah) and 'There is no god but Allah and there is no power and no strength except by Allah.'

La ilaha illa'llah wa la hawla wa la quwwata illa bi'llah.


Malik :: The Qur'an :: [15-15.7.24]

The Qur'an

Malik :: Book 15 : Hadith 15.7.24

Yahya related to me from Malik that Ziyad ibn Abi Ziyad said that Abu'd-Darda had said, "Shall I not tell you the best of your deeds, and those that give you the highest rank, and those that are the purest with your King, and are better for you than giving gold and silver, and better for you than meeting your enemy and striking their necks?" They said, "Of course." He said, "Remembrance (dhikr) of Allah ta ala."


Malik :: The Qur'an :: [15-15.7.25]

The Qur'an

Malik :: Book 15 : Hadith 15.7.25

Malik related to me from Nuaym ibn Abdullah ibn al-Mujmir from AIi ibn Yahya az-Zuraqi from his father that Rifaa ibn Rafi said, "One day we were praying behind the Messenger of Allah, may Allah bless him and grant him peace, when the Messenger of Allah, may Allah bless him and grant him peace, raised his head from ruku and said, 'Allah hears the one who praises Him' (Sami Allahu liman hamidah). A man behind him said, 'Our Lord, praise belongs to you - blessed, pure and abundant praise' (Rabbana wa laka'l hamd kathiran tayiban mubarakan fihi). When the Messenger of Allah, may Allah bless him and grant him peace, had finished, he said, 'Who was it who spoke just now?' The man said, 'I did, Messenger of Allah,' and the Messenger of Allah, may Allah bless him and grant him peace, said, 'I saw more than thirty angels rushing to it to see which one of them would record it first.' "


Malik :: The Qur'an :: [15-15.8.26]

The Qur'an

Malik :: Book 15 : Hadith 15.8.26

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Every prophet is given a supplication (dua), and I wish to preserve my dua as intercession for my community in the next world.


Malik :: The Qur'an :: [15-15.8.27]

The Qur'an

Malik :: Book 15 : Hadith 15.8.27

Yahya related to me from Malik from Yahya ibn Said that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, used to say the following dua, "O Allah, it is You who makes the dawn break and makes the night a time for rest and appoints the sun and moon to reckon by. Relieve me of debt and enrich me from poverty and let me enjoy my hearing, my sight and my strength in Your way."

Allahumma faliqa'l isbah, wa ja ila'l-layli sakana, wa'sh-shamsi wa'l-qamari husbana. Iqda anniy addayna, wa'ghnaniy mina'l faqr. Na'mti aniy bi samiy wa basariy, wa quwwatiy fi sabilik.


Malik :: The Qur'an :: [15-15.8.28]

The Qur'an

Malik :: Book 15 : Hadith 15.8.28

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, ''When you are making dua do not say; 'O Allah, forgive me if You wish. O Allah, forgive me if you wish.' You should be firm in your asking, for there is no compelling Him."


Malik :: The Qur'an :: [15-15.8.29]

The Qur'an

Malik :: Book 15 : Hadith 15.8.29

Yahya related to me from Malik from Ibn Shihab from Abu Ubayd, the mawla of Ibn Azhar, from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "You will be answered as long as you are not impatient and say, 'I have made a dua and I have not been answered .' "


Malik :: The Qur'an :: [15-15.8.30]

The Qur'an

Malik :: Book 15 : Hadith 15.8.30

Yahya related to me from Malik from Ibn Shihab from Abu Abdullah al-Agharr and from Abu Salama from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Our Lord, the Blessed and Exalted, descends every night to the heaven of this world when the last third of the night is still to come and says, 'Who will call on Me so that I may answer him? Who will ask Me so that I may give him? Who will ask forgiveness of Me so that I may forgive him?' "


Malik :: The Qur'an :: [15-15.8.31]

The Qur'an

Malik :: Book 15 : Hadith 15.8.31

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Ibrahim ibn al-Harith at-Taymi that A'isha, umm al-muminin said, "I was sleeping by the side of the Messenger of Allah, mayAllah bless him and grant him peace, and I missed him in the night, so I felt for him with my hand and I put my hand on his feet and he was in sajda saying, 'I seek refuge in Your pleasure from Your wrath, and in Your pardon from Your punishment, and in You from You. I cannot enumerate Your praises as You praise Yourself.' "

Audhu bi ridaka min sakhatika, wa bi muafatika min uqubatika wa bika minka, la uhsiy thana'an alayka, anta kama athnayta ala nafsika.


Malik :: The Qur'an :: [15-15.8.32]

The Qur'an

Malik :: Book 15 : Hadith 15.8.32

Yahya related to me from Malik from Ziyad ibn Abi Ziyad from Talha ibn Ubaydullah ibn Kariz that the Messenger of Allah, may Allah bless him and grant him peace, said, "The best dua is dua on the day of Arafa, and the best thing that I or the Prophets before me have said is 'There is no god but Allah, alone, without any partner' (La ilaha illa'llah, wahdahu la sharika lah.)"


Malik :: The Qur'an :: [15-15.8.33]

The Qur'an

Malik :: Book 15 : Hadith 15.8.33

Yahya related to me from Malik from Abu'zZubayr al-Makki from Tawus al-Yamani from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, used to teach this dua in the same way that he would teach them a sura of the Qur'an, "O Allah, I seek refuge in You from the torment of Jahannam, and I seek refuge in You from the trial of the Dajjal, and I seek refuge in You from the trial of life and death."

Allahumma inniy audhu bika min adhabi jahannama, wa audhu bika min adhabi'l-qabri, wa audhu bika min fitnati'l-mahya wa mamati.


Malik :: The Qur'an :: [15-15.8.34]

The Qur'an

Malik :: Book 15 : Hadith 15.8.34

Yahya related to me from Malik from Abu'z Zubayr al-Makki from Tawus al-Yamani from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, used to say, when he rose for prayer in the middle of the night, "O Allah, praise belongs to You. You are the light of the heavens and the earth and praise belongs toYou.You are the Sustainer of the heavens and the earth and praise belongs to You. You are the Lord of the heavens and the earth and whoever is in them. You are the Truth, and Your words are true. Your promise is true, and the meeting with You is true. The Garden is true and the Fire is true and the Hour is true. O Allah, I submit toYou and I accept You and I trust in You and I turn to You and I argue by You and I summon toYou for judgement. Forgive me what I have sent before me and what I have left behind, what I have kept secret and what I have proclaimed, You are my god - there is no god but You."

Allahumma laka'l-hamdu anta nuru's-samawati wa'l-ardi, wa laka'l-hamdu anta qayamu's-Samawati wa'l-ardi, wa laka'l-hamdu anta rabbu's-Samawati wa'l-ardi,wamanfihina.Anta'l-haqqu,waqawluka'lhaqqu, wa waduka'l-haqqu, wa liqa'uka haqqun, wa jannatu haqqun, wa naru haqqun, wa sactu haqqun. Allahumma laka aslamtu, wa bikaamantu, waalayka tawakaltu, wa ilayka anabtu, wa bika khasamtu, wa ilayka hakamtu, fa'ghfirliy ma qadamtu wa akhartu wa asrartu, wa alantu. Anta ilahiy, la ilaha illa ant.


Malik :: The Qur'an :: [15-15.8.35]

The Qur'an

Malik :: Book 15 : Hadith 15.8.35

Yahya related to me from Malik that Abdullah ibn Abdullah ibn Jabir ibn Atik said that Abdullah ibn Umar had come to them in Bani Muawiya, one of the villages of the Ansar, and said, "Do you know where the Messenger of Allah, may Allah bless him and grant him peace, prayed in this mosque of yours? "I told him, "Yes," and I pointed out a place near where he was. He said, "Do you know the three things for which he made dua here?" I said "Yes." He said, "Tell me them then." I said, "He asked that He would not make an enemy from among the non-believers triumph over the believers and that He would not destroy the believers by bad harvests, and he was given both these things. And he asked that He would not make the believers fight among themselves, and that was refused." Ibn Umar said, "You have told the truth," and he added, "Turmoil will not cease until the day of rising."


Malik :: The Qur'an :: [15-15.8.36]

The Qur'an

Malik :: Book 15 : Hadith 15.8.36

Yahya related to me from Malik that Zayd ibn Aslam used to say, "No-one makes a dua without one of three things happening. Either it is answered, or it is stored up for him, or wrong actions are atoned for by it."


Malik :: The Qur'an :: [15-15.9.37]

The Qur'an

Malik :: Book 15 : Hadith 15.9.37

Yahya related to me from Malik that Abdullah ibn Dinar said, "Abdullah ibn Umar saw me when I was making dua and I was pointing with two fingers, one from each hand, and he forbade me."


Malik :: The Qur'an :: [15-15.9.38]

The Qur'an

Malik :: Book 15 : Hadith 15.9.38

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab used to say, "A man is raised by the dua of his son after his death." He spoke with his hands turned upwards, and then lifted them up.


Malik :: The Qur'an :: [15-15.9.39]

The Qur'an

Malik :: Book 15 : Hadith 15.9.39

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "The following ayat was sent down about dua - 'And do not be loud in your prayer and do not be silent in it, but seek a way between these.' " (Sura 17 ayat 110)

Yahya said that Malik was asked about making dua in obligatory prayers and he said, "There is no harm in making dua in them."


Malik :: The Qur'an :: [15-15.9.40]

The Qur'an

Malik :: Book 15 : Hadith 15.9.40

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, used to make dua saying, "O Allah, I askYou for good actions and for leaving what is disapproved of and for love of the poor. And if You wish to try people, then bring me to You without being tried."

Allahumma inniy asa'luka fala'l-khayrati, wa tarqa'l-munqarati, wa hubba'l-masakin, wa idha aradta fi'n-nasi fitnatan fa'qbithni ilayka ghayra maftun.


Malik :: The Qur'an :: [15-15.9.41]

The Qur'an

Malik :: Book 15 : Hadith 15.9.41

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "No one calls to guidance without having the same reward as those who follow him without diminishing their rewards at all. And no one calls to error without having the same burdens as they do without diminishing their burdens at all."


Malik :: The Qur'an :: [15-15.9.42]

The Qur'an

Malik :: Book 15 : Hadith 15.9.42

Yahya related to me from Malik that he had heard that Abdullah ibn Umar said, "O Allah, make me one of the leaders of the people of taqwa ."

Allahumma jalniy min a'imati'l-mutaqin.


Malik :: The Qur'an :: [15-15.9.43]

The Qur'an

Malik :: Book 15 : Hadith 15.9.43

Yahya related to me from Malik that he had heard that Abu'd-Darda used to rise in the middle of the night and say, "Eyes have slept, and stars have set, and You are the Living and Self Subsistent."

Namat'l uyun wa ghariti'n-nujum wa anta'lhayyu-l-qayyum.


Malik :: The Qur'an :: [15-15.10.44]

The Qur'an

Malik :: Book 15 : Hadith 15.10.44

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar from Abdullah as-Sunabihi that the Messenger of Allah, may Allah bless him and grant him peace, said, "The sun rises and with it is a horn of Shaytan and when the sun gets higher the horn leaves it. Then when the sun reaches the meridian the horn joins it and when the sun declines the horn leaves it, and when the sun has nearly set it joins it again." The Messenger of Allah, may Allah bless him and grant him peace, forbade prayer at these times.


Malik :: The Qur'an :: [15-15.10.45]

The Qur'an

Malik :: Book 15 : Hadith 15.10.45

Yahya related to me from Malik from Hisham ibn Urwa that his father said that the Messenger of Allah, may Allah bless him and grant him peace, used to say, "Delay the prayer when the edge of the sun appears until it is completely in view, and delay the prayer when the edge of the sun is disappearing until it has completely disappeared."


Malik :: The Qur'an :: [15-15.10.46]

The Qur'an

Malik :: Book 15 : Hadith 15.10.46

Yahya related to me from Malik that al-Ala ibn Abd ar-Rahman said, "We visited Anas ibn Malik after dhuhr and he stood up and prayed asr. When he had finished his prayer, we mentioned doing prayers early in their time, or he mentioned it, and he said that he had heard the Messenger of Allah, may Allah bless him and grant him peace, say, the prayer of the hypocrites, the prayer of the hypocrites, the prayer of the hypocrites is that one of them sits until the sun becomes yellow and is between the horns of Shaytan, or on the horn of Shaytan, and then gets up and rattles off four rakas, hardly remembering Allah in them at all.' "


Malik :: The Qur'an :: [15-15.10.47]

The Qur'an

Malik :: Book 15 : Hadith 15.10.47

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "You should not intend to pray either at sunrise or sunset."


Malik :: The Qur'an :: [15-15.10.48]

The Qur'an

Malik :: Book 15 : Hadith 15.10.48

Yahya related to me from Malik from Muhammad ibn Yahya ibn Habban from al Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, forbade prayer after asr until the sun had set, and prayer after subh until the sun had risen.


Malik :: The Qur'an :: [15-15.10.49]

The Qur'an

Malik :: Book 15 : Hadith 15.10.49

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that Umar ibn al-Khattab used to say, "Do not intend to do your prayer at either sunrise or sunset, for the horns of Shaytan rise with the rising of the sun and set with its setting."

Umar used to beat people for that kind of prayer.


Malik :: The Qur'an :: [15-15.10.50]

The Qur'an

Malik :: Book 15 : Hadith 15.10.50

Yahya related to me from Malik from Ibn Shihab from as-Sa'ib ibn Yazid that he saw Umar ibn al-Khattab beating al-Munkadir for praying after asr.


Malik :: Burials :: [16-16.1.1]

Burials

Malik :: Book 16 : Hadith 16.1.1

Yahya related to me from Malik from Jafar ibn Muhammad from his father that the Messenger of Allah, may Allah bless him and grant him peace, was washed in a long shirt.


Malik :: Burials :: [16-16.1.2]

Burials

Malik :: Book 16 : Hadith 16.1.2

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani from Muhammad ibn Sirin that Umm Atiyya al-Ansariyya said, "The Messenger of Allah, may Allah bless him and grant him peace, came to us when his daughter died and said, 'Wash her three times, or five, or more than that if you think it necessary, with water and lotus leaves, and at the end put on some camphor, or a little camphor, and when you have finished let me know.' When we finished we told him, and he gave us his waist-wrapper and said, 'Shroud her with this.' "


Malik :: Burials :: [16-16.1.3]

Burials

Malik :: Book 16 : Hadith 16.1.3

Yahya related to me from Malik from Abdullah ibn Abi Bakr that Asma bint Umays washed Abu Bakr as-Siddiq when he died. Then she went out and asked some of the muhajirun who were there, "I am fasting and this is an extremely cold day. Do I have to do ghusl?" They said, "No."


Malik :: Burials :: [16-16.1.4]

Burials

Malik :: Book 16 : Hadith 16.1.4

Yahya related to me from Malik that he had heard people of knowledge say, "When a woman dies and there are no women with her to wash her and no man who has the right by blood ties to take charge of that for her and no husband to take charge of it for her, she should be purified by tayammum ,that is, by wiping her face and hands with earth."

Malik said, "When a man dies and there are only women with him, they also should purify him with earth ."

Malik said, "There is no particular way with us for washing the dead nor any recognised way to do it. They are just washed and purified."


Malik :: Burials :: [16-16.2.5]

Burials

Malik :: Book 16 : Hadith 16.2.5

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, was shrouded in three pure white cotton garments, none of which was a long shirt or a turban.


Malik :: Burials :: [16-16.2.6]

Burials

Malik :: Book 16 : Hadith 16.2.6

Yahya related to me from Malik that Yahya ibn Said said that he had heard that when Abu Bakr as-Siddiq was ill he asked A'isha, "How many shrouds did the Messenger of Allah, may Allah bless him and grant him peace, have?" and she replied, "Three pure white cotton garments." Abu Bakr said, "Take this garment (a garment he was wearing on which red clay or saffron had fallen) and wash it. Then shroud me in it with two other garments." A'isha said, "Why's that?", and Abu Bakr replied, "The living have greater need of the new than the dead. This is only for the body fluids that come out as the body decays."


Malik :: Burials :: [16-16.2.7]

Burials

Malik :: Book 16 : Hadith 16.2.7

Yahya related to me from Malik from Ibn Shihab from Humayd ibn Abdar-Rahman ibn Awf that Abdullah ibn Amr ibn al-As said, "A dead man is clothed in a shirt and a waist-wrapper and then wrapped in a third, and if he only has one garment he is shrouded in that."


Malik :: Burials :: [16-16.3.8]

Burials

Malik :: Book 16 : Hadith 16.3.8

Yahya related to me from Malik from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, and Abu Bakr and Umar as well as the khalifas up until this time and Abdullah ibn Umar, would walk in front of the bier.


Malik :: Burials :: [16-16.3.9]

Burials

Malik :: Book 16 : Hadith 16.3.9

Yahya related to me from Muhammad ibn alMunkadir that Rabia ibn Abdullah ibn alHadir told him that he had seen Umar ibn al-Khattab leading people in front of the bier at the funeral of Zaynab bint Jahsh.


Malik :: Burials :: [16-16.3.10]

Burials

Malik :: Book 16 : Hadith 16.3.10

Yahya related to me from Malik that Hisham ibn Urwa said, "I only ever saw my father in front of a funeral procession." He added, "Then he would come to al-Baqi and sit down until the procession passed him."


Malik :: Burials :: [16-16.3.11]

Burials

Malik :: Book 16 : Hadith 16.3.11

Yahya related to me from Malik that Ibn Shihab said, "Walking behind the bier is in contradiction to the sunna."

16.4 The Prohibition Against Following the Bier with a Burning Torch


Malik :: Burials :: [16-16.4.12]

Burials

Malik :: Book 16 : Hadith 16.4.12

Yahya related to me from Malik from Hisham ibn Urwa that Asma bint Abi Bakr said to her family, "Perfume my clothes with incense when I die and then embalm me. Do not put any of the embalming substance on my shroud, and do not follow me with a burning torch."


Malik :: Burials :: [16-16.4.13]

Burials

Malik :: Book 16 : Hadith 16.4.13

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi that Abu Hurayra forbade anyone to follow him with a burning torch after his death.

Yahya said, "I heard Malik disapprove of that."


Malik :: Burials :: [16-16.5.14]

Burials

Malik :: Book 16 : Hadith 16.5.14

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, announced the death of an Najashi to everyone on the day that he died, and went out with them to the place of prayer, and then formed them into rows and said "Allah is greater" four times.


Malik :: Burials :: [16-16.5.15]

Burials

Malik :: Book 16 : Hadith 16.5.15

Yahya related to me from Malik from Ibn Shihab that Abu Umama ibn Sahl ibn Hunayf told him that once a poor woman fell ill and the Messenger of Allah, may Allah bless him and grant him peace, was told of her illness, and the Messenger of Allah, may Allah bless him and grant him peace, used to visit poor people frequently and ask after them. The Messenger of Allah, may Allah bless him and grant him peace, said, "Let me know if she dies." Her bier was brought out at night-time and they did not want to wake up the Messenger of Allah, may Allah bless him and grant him peace. In the morning the Messenger of Allah, may Allah bless him and grant him peace, was told what had happened to her and he said, "Didn't I tell you to let me know if she died?" They replied, "Messenger of Allah, we did not want to wake you up and make you come out in the night." Then the Messenger of Allah, may Allah bless him and grant him peace, went out and formed everyone into rows by her grave and said "Allah is greater" four times.


Malik :: Burials :: [16-16.5.16]

Burials

Malik :: Book 16 : Hadith 16.5.16

Yahya related to me that Malik asked Ibn Shihab about a man who caught some of the takbirs said over the corpse and missed the rest, and Ibn Shihab said, "He completes what he has missed."


Malik :: Burials :: [16-16.6.17]

Burials

Malik :: Book 16 : Hadith 16.6.17

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi from his father that he had asked Abu Hurayra, "How do you pray over the dead?" and Abu Hurayra replied, "By the Life of Allah, I will tell you! I follow with the family and when the corpse is put down I say 'Allah is greater' and praise Allah and ask for blessings on His Prophet. Then I say, 'O Allah, he is Your slave and the son of Your male slave and Your female slave. He used to testify that there is no god but You and that Muhammad is Your slave and Your Messenger, and You know that best. O Allah, if he acted well, then increase for him his good action, and if he acted wrongly, then overlook his wrong actions. O Allah, do not deprive us of his reward, and do not try us after him.'"

Allahumma inna huwa abduka wa'bnu abdika wa'bnu amatika. Kana yash-hadu an la ilaha illa ant wa anna Muhammadan abduka wa rasooluka, wa anta alamu bihi. Allahumma in kana muhsinan zid fi ihsanihi, wa in kana musiyan fa tajawaz an sayatihi. Allahumma la tahrimna ajrahu wa lataftina badahu.


Malik :: Burials :: [16-16.6.18]

Burials

Malik :: Book 16 : Hadith 16.6.18

Yahya related to me from Malik that Yahya ibn Said said that he heard Said ibn al-Musayyab say, "I once prayed behind Abu Hurayra over a child who had never done a wrong action and I heard him say, 'O Allah, give him protection from the torment of the grave.' "


Malik :: Burials :: [16-16.6.19]

Burials

Malik :: Book 16 : Hadith 16.6.19

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used not to recite when praying over a dead person.


Malik :: Burials :: [16-16.7.20]

Burials

Malik :: Book 16 : Hadith 16.7.20

Yahya related to me from Malik from Muhammad ibn Abi Harmala, the mawla of Abd ar-Rahman ibn Abi Sufyan ibn Huwaytib, that Zaynab bint Abi Salama died during the time that Tariq was amir of Madina and her bier was brought out after subh and put in al-Baqi. He said that Tariq used to pray subh right at the beginning of its time. He added, "I heard Abdullah ibn Umar say to the family, 'You can either pray over your dead now or you can wait until the sun comes up.' "


Malik :: Burials :: [16-16.7.21]

Burials

Malik :: Book 16 : Hadith 16.7.21

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "The prayer for a dead person can be done after asr and subh if these have been prayed at their times."


Malik :: Burials :: [16-16.8.22]

Burials

Malik :: Book 16 : Hadith 16.8.22

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, ordered that the body of Sad ibn Abi Waqqas be brought past her in the mosque so that she could make dua for him. Some people disapproved of her doing that, and she said, "How hasty people are! The Messenger of Allah, may Allah bless him and grant him peace, only prayed over Suhayl ibn Bayda in the mosque."


Malik :: Burials :: [16-16.8.23]

Burials

Malik :: Book 16 : Hadith 16.8.23

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "The prayer over Umar ibn al-Khattab was done in the mosque."


Malik :: Burials :: [16-16.9.24]

Burials

Malik :: Book 16 : Hadith 16.9.24

Yahya related to me from Malik that he had heard that Uthman ibn Affan and Abdullah ibn Umar and Abu Hurayra used to pray over the dead, both men and women, in Madina. They would put the men nearer to the imam and the women nearer to the qibla.


Malik :: Burials :: [16-16.9.25]

Burials

Malik :: Book 16 : Hadith 16.9.25

Yahya related to me from Malik from Nafi that Abdullah ibn Umar, when he prayed over the dead, would say, "Peace be upon you" loud enough for whoever was near to him to hear.


Malik :: Burials :: [16-16.9.26]

Burials

Malik :: Book 16 : Hadith 16.9.26

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "No-one should pray over a dead person unless he is in wudu."

Yahya said that he heard Malik say, "I have not seen any person of knowledge disapproving of praying over either a child born of adultery or its mother."


Malik :: Burials :: [16-16.10.27]

Burials

Malik :: Book 16 : Hadith 16.10.27

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, died on Monday and was buried on Tuesday and people prayed over him individually with no one leading them. Some people said that he would be buried near the mimbar, and others said that he would be buried in al-Baqi. Abu Bakr as-Siddiq came and said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'No prophet was ever buried except in the place where he died.' "So a grave was dug for him there. When he was about to be washed they wished to take off his shirt but they heard a voice saying "Don't take off his shirt," so they did not take off his shirt and he was washed with it on, may Allah bless him and grant him peace.


Malik :: Burials :: [16-16.10.28]

Burials

Malik :: Book 16 : Hadith 16.10.28

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "There were two men in Madina, one of whom dug graves with a niche in the side wall for the body, and the other who did not, and they said, 'Whichever one comes first can do the job,' and the one who dug graves with a niche came first and dug the Messenger of Allah's grave, may Allah bless him and grant him peace."


Malik :: Burials :: [16-16.10.29]

Burials

Malik :: Book 16 : Hadith 16.10.29

Yahya related to me from Malik that he had heard that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "I did not believe that the Messenger of Allah, may Allah bless him and grant him peace, had died until I heard the pickaxes fall."


Malik :: Burials :: [16-16.10.30]

Burials

Malik :: Book 16 : Hadith 16.10.30

Yahya related to me from Malik from Yahya ibn Said that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "I saw three moons fall into my room, and I related my vision to Abu Bakr as-Siddiq. Then, when the Messenger of Allah died, may Allah bless him and grant him peace, and was buried in my house, Abu Bakr said to me, 'This is one of your moons, and he is the best of them.' "


Malik :: Burials :: [16-16.10.31]

Burials

Malik :: Book 16 : Hadith 16.10.31

Yahya related to me from Malik from more than one reliable source that Sad ibn Abi Waqqas and Said ibn Zayd ibn Amr ibn Nufayl died at al-Aqiq and were carried to Madina and buried there.


Malik :: Burials :: [16-16.10.32]

Burials

Malik :: Book 16 : Hadith 16.10.32

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "I would not want to be buried in al-Baqi. I would prefer to be buried elsewhere. The one who is buried in al-Baqi is one of two people. Either he is unjust (dhalim), and I would not like to be buried with him, or he is salih, and I would not like his bones to be disturbed for me."


Malik :: Burials :: [16-16.11.33]

Burials

Malik :: Book 16 : Hadith 16.11.33

Yahya related to me from Malik from Yahya ibn Said from Wafid ibn Amr ibn Said ibn Muadh from Nafi ibn Jubayr ibn Mutim from Masud ibn al-Hakam from AIi ibn Abi Talib that the Messenger of Allah, may Allah bless him and grant him peace, used to stand up when a funeral procession passed by, and then sit down again afterwards.


Malik :: Burials :: [16-16.11.34]

Burials

Malik :: Book 16 : Hadith 16.11.34

ahya related to me from Malik that he had heard that AIi ibn Abi Talib used to rest his head on graves and lie on them.

Malik said, "As far as we can see ,it is only forbidden to sit on graves to relieve oneself."


Malik :: Burials :: [16-16.11.35]

Burials

Malik :: Book 16 : Hadith 16.11.35

Yahya related to me from Malik from Abu Bakr ibn Uthman ibn Sahl ibn Hunayf that he had heard Abu Umama ibn Sahl ibn Hunayf say, "We used to attend funeral processions, and the last of the people would not sit until they had been given permission ."


Malik :: Burials :: [16-16.12.36]

Burials

Malik :: Book 16 : Hadith 16.12.36

Yahya related to me from Malik from Abdullah ibn Abdullah ibn Jabir ibn Atik that Atik ibn al-Harith, the grandfather of Abdullah ibn Abdullah ibn Jabir on his mother's side, told him that Jabir ibn Atik had told him that the Messenger of Allah, may Allah bless him and grant him peace, came to visit Abdullah ibn Thabit and found him in his death-throes. He called to him but he did not reply. The Messenger of Allah, may Allah bless him and grant him peace, said, "We belong to Allah, and to Him we are returning," and added, "You are being taken from us, Abu'r-Rabi.'' The women cried out and wept, and Jabir began to silence them. The Messenger of Allah, may Allah bless him and grant him peace, said, "Leave them, and when the necessary time comes, none of the women should cry." They said, "Messenger of Allah, what is the necessary time?", and he replied, "When he dies." The dying man's daughter said, "By Allah, I hope that you will be a martyr, for you have completed your preparations for battle," and the Messenger of Allah, may Allah bless him and grant him peace, said, "Allah has made his reward fall according to his intention. What do you consider dying a martyr to be?" They said, "Death in the way of Allah." The Messenger of Allah, may Allah bless him and grant him peace, said, "There are seven kinds of rnartyr other than those killed in the way of Allah. Someone who is killed by the plague is a martyr, someone who drowns is a martyr, someone who dies of pleurisy is a martyr, someone who dies of a disease of the belly is a martyr, someone who dies by fire is a martyr, someone who dies under a falling building is a martyr and a woman who dies in childbirth is a martyr."


Malik :: Burials :: [16-16.12.37]

Burials

Malik :: Book 16 : Hadith 16.12.37

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his father that Amra bint Abd ar-Rahman told him that she had heard A'isha, the umm al-muminin, say (when it was mentioned to her that Abdullah ibn Umar used to say, "The dead are tormented by the weeping of the living"), "May Allah forgive Abu Abd ar-Rahman. Of course he has not lied, but he has forgotten, or made a mistake. The Messenger of Allah, may Allah bless him and grant him peace, passed by a jewish woman whose family were crying over her and he said, 'You are crying over her, and she is being tormented in her grave. ' "


Malik :: Burials :: [16-16.13.38]

Burials

Malik :: Book 16 : Hadith 16.13.38

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "No muslim who has three children die will be touched by the Fire except to fulfil Allah's oath."


Malik :: Burials :: [16-16.13.39]

Burials

Malik :: Book 16 : Hadith 16.13.39

Yahya related to me from Malik from Muhammad ibn Abi Bakr ibn Amr ibn Hazm from his father from Abu'n-Nadr as-Salami that the Messenger of Allah, may Allah bless him and grant him peace, said, "If three of a muslim's children die, and he remains content with that, they will be a protection for him from the Fire." A woman who was with the Messenger of Allah, may Allah bless him and grant him peace, said, "Or two, Messengerof Allah?", and he said, "Or two."


Malik :: Burials :: [16-16.13.40]

Burials

Malik :: Book 16 : Hadith 16.13.40

Yahya related to me from Malik that he had heard from Abu'l-Hubab Said ibn Yasar from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The mumin continues to be struck by misfortune in his children and close friends until he meets Allah with no wrong actions."


Malik :: Burials :: [16-16.14.41]

Burials

Malik :: Book 16 : Hadith 16.14.41

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim ibn Muhammad ibn Abi Bakr that the Messenger of Allah, may Allah bless him and grant him peace, said, "Let the misfortune that befalls me be a comfort to the muslims in their misfortunes."


Malik :: Burials :: [16-16.14.42]

Burials

Malik :: Book 16 : Hadith 16.14.42

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman from Umm Salama, the wife of the Prophet may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "If a misfortune befalls some one and he says, as Allah has ordered, 'We belong to Allah and to Him we are returning. O Allah, reward me in my misfortune and give me better than it afterwards,' Allah will do that for him" (Inna lillahi wa inna ilayhi rajiun. Allahumma' jurniy fi musiybatiy, wa a qibhiy khayran minha, illa faala 'llahu dhalika bihi.).

Umm Salama said, "When Abu Salama died I said that, and then I said, 'Who is better than Abu Salama?' " And then Allah left her the Messenger of Allah, may Allah bless him and grant him peace, and he married her.


Malik :: Burials :: [16-16.14.43]

Burials

Malik :: Book 16 : Hadith 16.14.43

Yahya related to me from Malik from Yahya ibn Said that al-Qasim ibn Muhammad said, "One of my wives died and Muhammad ibn Kab al Quradhi came to console me about her. He told me of one among the Bani Israil who was a diligent, worshipping, knowing and understanding man who had a wife that he admired and loved, and she died. He grieved over her intensely and lamented her until he withdrew into a house and locked himself in, hidden from everyone, and no-one visited him. A woman heard about him and went to him, saying, 'I need him to give me an opinion. Nothing will satisfy me except what he says about it.' Everyone went away, but she stuck to his door and said, 'I must see him.' Someone said to him, 'There is a woman who wishes to ask your opinion about something,' and she insisted, 'I will only talk to him about it.' When everyone had gone away, and she still had not left his door, he said, 'Let her in.' So she went in and saw him and said, 'I have come to ask your opinion about something.' He said, 'What is it?' She said, 'I borrowed a piece of jewellery from a neighbour of mine, and I have worn it and used it for a long time. Then they sent to me for it. Should I let them have it back?' He said, 'Yes, by Allah.' She said, 'I have had it for a long time.' He said, 'It is more correct for you to return it to them, since they have lent it to you for such a long time.' She said, 'Yes. May Allah have mercy on you. Do you then grieve over what Allah has lent you and then taken from you, when He has a greater right to it than you?' Then he saw the situation he was in, and Allah helped him by her words."


Malik :: Burials :: [16-16.15.44]

Burials

Malik :: Book 16 : Hadith 16.15.44

Yahya related to me from Malik that Abu'r-Rijal Muhammad ibn Abd ar-Rahman heard his mother Amra bint Abd ar-Rahman say, "The Messenger of Allah, may Allah bless him and grant him peace, cursed both men and women who dug up," meaning those who dug up graves.


Malik :: Burials :: [16-16.15.45]

Burials

Malik :: Book 16 : Hadith 16.15.45

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "Breaking the bone of a muslim when he is dead is like breaking it when he is alive." She meant if done in wrong action.


Malik :: Burials :: [16-16.16.46]

Burials

Malik :: Book 16 : Hadith 16.16.46

Yahya related to me from Malik from Hisham ibn Urwa from Abbad ibn Abdullah ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, told him that she had heard the Messenger of Allah, may Allah bless him and grant him peace, say before he died, while he was leaning on her breast and she was listening to him, "O Allah, forgive me and have mercy on me and join me with the highest company."


Malik :: Burials :: [16-16.16.47]

Burials

Malik :: Book 16 : Hadith 16.16.47

Yahya related to me from Malik that he heard that A'isha said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'No prophet dies until he is given the choice.' " She continued, "I heard him say ,'O Allah, the highest company,' and I knew that he was going."


Malik :: Burials :: [16-16.16.48]

Burials

Malik :: Book 16 : Hadith 16.16.48

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you die, your place will be shown to you in the morning and the evening. If you are one of the people of the Garden, then you will be with the people of the Garden, and if you are one of the people of the Fire, then you will be with the people of the Fire. You will be told, 'This is your place of waiting until Allah raises you on the day of rising.' "


Malik :: Burials :: [16-16.16.49]

Burials

Malik :: Book 16 : Hadith 16.16.49

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The earth eats all of the son of Adam except the coccyx. He was created from it, and on it he is built."


Malik :: Burials :: [16-16.16.50]

Burials

Malik :: Book 16 : Hadith 16.16.50

Yahya related to me from Malik from Ibn Shihab that Abd ar-Rahman ibn Kab ibn Malik al-Ansari told him that his father, Kab ibn Malik, used to relate that the Messenger of Allah, may Allah bless him and grant him peace, said, "The ruh of the mumin is a bird that sits in the trees of the Garden until Allah returns it to his body on the day He raises him ."


Malik :: Burials :: [16-16.16.51]

Burials

Malik :: Book 16 : Hadith 16.16.51

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Allah, the Blessed and Exalted, said, 'If My slave longs to meet Me, I long to meet him, and if he is averse to meeting Me, I am averse to meeting him.' "


Malik :: Burials :: [16-16.16.52]

Burials

Malik :: Book 16 : Hadith 16.16.52

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A man said to his family that he had never done a good action, and that when he died they were to burn him and then scatter half of him on the land and half of him on the sea, and by Allah, if Allah destined it for him He would punish him with a punishment which He had not punished anyone else with in all the worlds. When the man died, they did as he had told them. Then Allah told the land to collect everything that was in it, and told the sea to collect everything that was in it, and then He said to the man, 'Why did you do this?' and he said, 'From fear of You, Lord, and You know best.' "

Abu Hurayra added, "And He forgave him."


Malik :: Burials :: [16-16.16.53]

Burials

Malik :: Book 16 : Hadith 16.16.53

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Every child is born on the fitra and it is his parents who make him a jew or a christian. Just as a camel is born whole - do you perceive any defect?" They said, "Messenger of Allah, what happens to people who die when they are (very) young?" He said, "Allah knows best what they used to do."


Malik :: Burials :: [16-16.16.54]

Burials

Malik :: Book 16 : Hadith 16.16.54

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The Hour will not come until a man passes by the grave of another and says, 'If only I were in his place.' "


Malik :: Burials :: [16-16.16.55]

Burials

Malik :: Book 16 : Hadith 16.16.55

Yahya related to me from Malik from Muhammad ibn Amr ibn Halhalaad-Dili from Mabad ibn Kab ibn Malik that Abu Qatada ibn Ribi used to relate that a funeral procession passed by the Messenger of Allah, may Allah bless him and grant him peace, and he said, "One is relieved and another others are relieved from." They said, "Who is the one relieved and the one from whom others are relieved?" He said, "A slave who is mumin is the one who is relieved from the exhaustion and suffering of this world to the mercy of Allah, and a wrong-acting slave is the one from whom people, towns, trees and animals are relieved."


Malik :: Burials :: [16-16.16.56]

Burials

Malik :: Book 16 : Hadith 16.16.56

Yahya related to me from Malik that Abu'n Nadr, the mawla of Umar ibn Ubaydullah, said that the Messenger of Allah, may Allah bless him and grant him peace, said, when Uthman ibn Madhun's funeral procession passed by him, "You have gone and you were not involved in any of it."


Malik :: Burials :: [16-16.16.57]

Burials

Malik :: Book 16 : Hadith 16.16.57

Malik related to me from AIqama ibn Abi Alqama that his mother said that she had heard A'isha, the wife of the Prophet, may Allah bless him and grant him peace, say, "The Messenger of Allah, may Allah bless him and grant him peace, rose one night and put on his clothes and then went out. I ordered my slave-girl, Barira, to follow him, and she followed him until he got to al-Baqi. He stood near it as long as Allah willed and then he left. Barira arrived back before him and told me and I did not say anything to him until morning, and then I mentioned it to him and he explained, 'I was sent out to the people of al-Baqi to pray for them.' "


Malik :: Burials :: [16-16.16.58]

Burials

Malik :: Book 16 : Hadith 16.16.58

Yahya related to me from Malik from Nafi that Abu Hurayra said, "Make your funerals speedy, for it is only good that you are advancing him towards, or evil that you are taking off your necks."


Malik :: Zakat :: [17-17.1.1]

Zakat

Malik :: Book 17 : Hadith 17.1.1

Yahya related to me from Malik from Amr ibn Yahya al-Mazini that his father said that he had heard Abu Said al-Khudri say that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is no zakat on less than five camels, there is no zakat on less than five awaq (two hundred dirhams of pure silver) and there is no zakat on less than five awsuq (three hundred sa)."


Malik :: Zakat :: [17-17.1.2]

Zakat

Malik :: Book 17 : Hadith 17.1.2

Yahya related to me from Malik from Muhammad ibn Abdullah ibn Abd arRahman ibn Abi Sasaca al-Ansari from al-Mazini from his father from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is no zakat on less than five awsuq of dates, there is no zakat on less than five awaq of silver and there is no zakat on less than five camels."


Malik :: Zakat :: [17-17.1.3]

Zakat

Malik :: Book 17 : Hadith 17.1.3

Yahya related to me from Malik that he had heard that Umar ibn Abd al-Aziz wrote to his governor in Damascus about zakat saying, "Zakat is paid on the produce of ploughed land, on gold and silver, and on livestock."

Malik said, "Zakat is only paid on three things: the produce of ploughed land, gold and silver, and livestock."


Malik :: Zakat :: [17-17.2.4]

Zakat

Malik :: Book 17 : Hadith 17.2.4

Yahya related to me from Malik that Muhammad ibn Uqba, the mawla of az Zubayr, asked al-Qasim ibn Muhammad whether he had to pay any zakat on a large sum given to him by his slave to buy his freedom. Al-Qasim said, "Abu Bakr as-Siddiq did not take zakat from anyone's property until it had been in his possession for a year."

Al-Qasim ibn Muhammad continued, "When Abu Bakr gave men their allowances he would ask them, 'Do you have any property on which zakat is due?' If they said, 'Yes,' he would take the zakat on that property out of their allowances. If they said, 'No,' he would hand over their allowances to them without deducting anything from them."


Malik :: Zakat :: [17-17.2.5]

Zakat

Malik :: Book 17 : Hadith 17.2.5

Yahya related to me from Malik from Urwa ibn Husayn from A'isha bint Qudama that her father said, "When I used to come to Uthman ibn Affan to collect my allowance he would ask me, 'Do you have any property on which zakat is due? 'If I said, 'Yes,' he would deduct the zakat on that property from my allowance, and if I said, 'No,' he would pay me my allowance (in full)."


Malik :: Zakat :: [17-17.2.6]

Zakat

Malik :: Book 17 : Hadith 17.2.6

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Zakat does not have to be paid on property until a year has elapsed over it."


Malik :: Zakat :: [17-17.2.7]

Zakat

Malik :: Book 17 : Hadith 17.2.7

Yahya related to me from Malik that Ibn Shihab said, "The first person to deduct zakat from allowances was Muawiya ibn Abi Sufyan." (i.e. the deduction being made automatically) .

Malik said, "The agreed sunna with us is that zakat has to be paid on twenty dinars (of gold coin), in the same way as it has to be paid on two hundred dirhams (of silver)."

Malik said, "There is no zakat to pay on (gold) that is clearly less than twenty dinars (in weight) but if it increases so that by the increase the amount reaches a full twenty dinars in weight then zakat has to be paid. Similarly, there is no zakat to pay on (silver) that is clearly less than two hundred dirhams (in weight), but if it increases so that by the increase the amount reaches a full two hundred dirhams in weight then zakat has to be paid. If it passes the full weight then I think there is zakat to pay, whether it be dinars or dirhams." (i.e. the zakat is assessed by the weight and not the number of the coins.)

Malik said, about a man who had one hundred and sixty dirhams by weight, and the exchange rate in his town was eight dirhams to a dinar, that he did not have to pay any zakat. Zakat had only to be paid on twenty dinars of gold or two hundred dirhams.

Malik said, in the case of a man who acquired five dinars from a transaction or in some other way which he then invested in trade, that, as soon as it increased to a zakatable amount and then a year elapsed, he had to pay zakat on it, even if the zakatable amount was reached one day before or one day after the passing of a year. There was then no zakat to pay on it from the day the zakat was taken until a year had elapsed over it.

Malik said, in the similar case of a man who had in his possession ten dinars which he invested in trade and which reached twenty dinars by the time one year had elapsed over them, that he paid zakat on them right then and did not wait until a year had elapsed over them, (counting) from the day when they actually reached the zakatable amount. This was because a year had elapsed over the original dinars and there were now twenty of them in his possession. After that there was no zakat to pay on them from the day the zakat was paid until another year had elapsed over them.

Malik said, "What we are agreed upon (here in Madina) regarding income from hiring out slaves, rent from property, and the sums received when a slave buys his freedom, is that no zakat is due on any of it, whether great or small, from the day the owner takes possession of it until a year has elapsed over it from the day when the owner takes possession of it."

Malik said, in the case of gold and silver which was shared between two co-owners, that zakat was due from any one whose share reached twenty dinars of gold, or two hundred dirhams of silver, and that no zakat was due from anyone whose share fell short of this zakatable amount. If all the shares reached the zakatable amount and the shares were not equally divided, zakat was taken from each man according to the measure of his share. This applied only when the share of each man among them reached the zakatable amount, because the Messenger of Allah, may Allah bless him and grant him peace, had said, "There is no zakat to pay on less than five awaq of silver."

Malik commented, "This is what I prefer most out of what I have heard about the matter."

Malik said, "When a man has gold and silver dispersed among various people he must add it all up together and then take out the zakat due on the total sum ."

Malik said, "No zakat is due from some one who acquires gold or silver until a year has elapsed over his acquisition from the day it became his."


Malik :: Zakat :: [17-17.3.8]

Zakat

Malik :: Book 17 : Hadith 17.3.8

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman from more than one source that the Messenger of Allah, may Allah bless him and grant him peace, assigned the mines of al Qabaliyya, which is in the direction of al-Fur, to Bilal ibn Harith al-Mazini, and nothing has been taken from them up to this day except zakat.

Malik said, "In my opinion, and Allah knows best, nothing is taken from what comes out of mines until what comes out of them reaches a value of twenty gold dinars or two hundred silver dirhams. When it reaches that amount there is zakat to pay on it where it is on the spot. Zakat is levied on anything over that, according to how much of it there is as long as there continues to be a supply from the mine. If the vein runs out, and then after a while more becomes obtainable, the new supply is dealt with in the same way as the first, and payment of zakat on it is begun on it as it was begun on the first.

Malik said, "Mines are dealt with like crops, and the same procedure is applied to both. Zakat is deducted from what comes out of a mine on the day it comes out, without waiting for a year, just as a tenth is taken from a crop at the time it is harvested, without waiting for a year to elapse over it."


Malik :: Zakat :: [17-17.4.9]

Zakat

Malik :: Book 17 : Hadith 17.4.9

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab and from Abu Salama ibn Abd ar-Rahman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace ,said, "There is a tax of a fifth on buried treasure."

Malik said, "The position which we are agreed upon, and which I have heard the people of knowledge mentioning, is that rikaz refers to treasure which has been found which was buried during the jahiliyya, as long as neither capital is required, nor expense, great labour or inconvenience incurred in recovering it. If capital is required or great labour is incurred, or on one occasion the mark is hit and on another it is missed, then it is not rikaz."


Malik :: Zakat :: [17-17.5.10]

Zakat

Malik :: Book 17 : Hadith 17.5.10

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to look after the orphaned daughters of her brother in her house. They had jewellery (which they wore) and she did not take zakat from this jewellery of theirs.


Malik :: Zakat :: [17-17.5.11]

Zakat

Malik :: Book 17 : Hadith 17.5.11

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to adorn his daughters and slave-girls with gold jewellery and he did not take any zakat from their jewellery.

Malik said, "Anyone who has unminted gold or silver, or gold and silver jewellery which is not used for wearing, must pay zakat on it every year. It is weighed and one-fortieth is taken, unless it falls short of twenty dinars of gold or two hundred dirhams of silver, in which case there is no zakat to pay. Zakat is paid only when jewellery is kept for purposes other than wearing. Bits of gold and silver or broken jewellery which the owner intends to mend to wear are in the same position as goods which are worn by their owner - no zakat has to be paid on them by the owner."

Malik said, "There is no zakat (to pay) on pearls, musk or amber."


Malik :: Zakat :: [17-17.6.12]

Zakat

Malik :: Book 17 : Hadith 17.6.12

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab said, "Trade with the property of orphans and then it will not be eaten away by zakat."


Malik :: Zakat :: [17-17.6.13]

Zakat

Malik :: Book 17 : Hadith 17.6.13

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father said, ''A'isha used to look after me and one of my brothers - we were orphans - in her house, and she would take the zakat from our property."


Malik :: Zakat :: [17-17.6.14]

Zakat

Malik :: Book 17 : Hadith 17.6.14

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to give the property of the orphans that were in her house to whoever would use it to trade with on their behalf.


Malik :: Zakat :: [17-17.6.15]

Zakat

Malik :: Book 17 : Hadith 17.6.15

Yahya related to me from Malik that Yahya ibn Said bought some property on behalf of his brother's sons who were orphans in his house, and that that property was sold afterwards for a great deal of profit.

Malik said, "There is no harm in using the property of orphans to trade with on their behalf if the one in charge of them has permission. Furthermore, I do not think that he is under any liability."


Malik :: Zakat :: [17-17.7.16]

Zakat

Malik :: Book 17 : Hadith 17.7.16

Yahya related to me that Malik said, "I consider that if a man dies and he has not paid zakat on his property, then zakat is taken from the third of his property (from which he can make bequests), and the third is not exceeded and the zakat is given priority over bequests. In my opinion it is the same as if he had a debt, which is why I think it should be given priority over bequests."

Malik continued, "This applies if the deceased has asked for the zakat to be deducted. If the deceased has not asked for it to be deducted but his family do so then that is good, but it is not binding upon them if they do not do it."

Malik continued, "The sunna which we are all agreed upon is that zakat is not due from someone who inherits a debt (i.e. wealth that was owed to the deceased), or goods, or a house, or a male or female slave, until a year has elapsed over the price realised from whatever he sells (i.e. slaves or a house, which are not zakatable) or over the wealth he inherits, from the day he sold the things, or took possession of them."

Malik said, "The sunna with us is that zakat does not have to be paid on wealth that is inherited until a year has elapsed over it."


Malik :: Zakat :: [17-17.8.17]

Zakat

Malik :: Book 17 : Hadith 17.8.17

Yahya related to me from Malik from Ibn Shihab from as-Sa'ib ibn Yazid that Uthman ibn Affan used to say, "This is the month for you to pay your zakat. If you have any debts then pay them off so that you can sort out your wealth and take the zakat from it."


Malik :: Zakat :: [17-17.8.18]

Zakat

Malik :: Book 17 : Hadith 17.8.18

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani that Umar ibn Abd al-Aziz, when writing about wealth that one of his governors had collected unjustly, ordered it to be returned to its owner and zakat to be taken from it for the years that had passed. Then shortly afterwards he revised his order with a message that zakat should only be taken from it once, since it was not wealth in hand.


Malik :: Zakat :: [17-17.8.19]

Zakat

Malik :: Book 17 : Hadith 17.8.19

Yahya related to me from Malik from Yazid ibn Khusayfa that he had asked Sulayman ibn Yasar whether zakat was due from a man who had wealth in hand but also owed a debt for the same amount, and he replied, "No."

Malik said, "The position that we are agreed upon concerning a debt is that the lender of it does not pay zakat on it until he gets it back. Even if it stays with the borrower for a number of years before the lender collects it, the lender only has to pay zakat on it once. If he collects an amount of the debt which is not zakatable, and has other wealth which is zakatable, then what he has collected of the debt is added to the rest of his wealth and he pays zakat on the total sum."

Malik continued, "If he has no ready money other than that which he has collected from his debt, and that does not reach a zakatable amount, then he does not have to pay any zakat. He must, however, keep a record of the amount that he has collected and if, later, he collects another amount which, when added to what he has already collected, brings zakat into effect, then he has to pay zakat on it."

Malik continued, "Zakat is due on this first amount, together with what he has further collected of the debt owed to him, regardless of whether or not he has used up what he first collected. If what he takes back reaches twenty dinars of gold, or two hundred dirhams of silver he pays zakat on it. He pays zakat on anything else he takes back afte rthat, whether it be a large or small amount, according to the amount."

Malik said, "What shows that zakat is only taken once from a debt which is out of hand for some years before it is recovered is that if goods remain with a man for trading purposes for some years before he sells them, he only has to pay zakat on their prices once. This is because the one who is owed the debt, or owns the goods, should not have to take the zakat on the debt, or the goods, from anything else, since the zakat on anything is only taken from the thing itself, and not from anything else."

Malik said, "Our position regarding some onewho owes a debt, and has goods which are worth enough to pay off the debt, and also has an amount of ready money which is zakatable, is that he pays the zakat on the ready money which he has to hand. If, however, he only has enough goods and ready money to pay off the debt, then he does not have to pay any zakat. But if the ready money that he has reaches a zakatable amount over and above the amount of the debt that he owes, then he must pay zakat on it."


Malik :: Zakat :: [17-17.9.20]

Zakat

Malik :: Book 17 : Hadith 17.9.20

Yahya related to me from Malik from Yahya ibn Said that Zurayq ibn Hayyan, who was in charge of Egypt in the time of al-Walid, Sulayman, and Umar ibn Abd al-'Aziz, mentioned that Umar ibn Abd al-Aziz had written to him saying, "Assess the muslims that you come across and take from what is apparent of their wealth and whatever merchandise is in their charge, one dinar for every forty dinars, and the same proportion from what is less than that down to twenty dinars, and if the amount falls short of that by one third of a dinar then leave it and do not take anything from it. As for the people of the Book that you come across, take from the merchandise in their charge one dinar for every twenty dinars, and the same proportion from what is less than that down to ten dinars, and if the amount falls short by one third of a dinar leave it and do not take anything from it. Give them a receipt for what you have taken f rom them until the same time next year."

Malik said, "The position among us (in Madina) concerning goods which are being managed for trading purposes is that if a man pays zakat on his wealth, and then buys goods with it, whether cloth, slaves or something similar, and then sells them before a year has elapsed over them, he does not pay zakat on that wealth until a year elapses over it from the day he paid zakat on it. He does not have to pay zakat on any of the goods if he does not sell them for some years, and even if he keeps them for a very long time he still only has to pay zakat on them once when he sells them."

Malik said, "The position among us concerning a man who uses gold or silver to buy wheat, dates, or whatever, for trading purposes and keeps it until a year has elapsed over it and then sells it, is that he only has to pay zakat on it if and when he sells it, if the price reaches a zakatable amount. This is therefore not the same as the harvest crops that a man reaps from his land, or the dates that he harvests from his palms."

Malik said, "A man who has wealth which he invests in trade, but which does not realise a zakatable profit for him, fixes a month in the year when he takes stock of what goods he has for trading, and counts the gold and silver that he has in ready money, and if all of it comes to a zakatable amount he pays zakat on it."

Malik said, "The position is the same for muslims who trade and muslims who do not. They only have to pay zakat once in any one year, whether they trade in that year or not."


Malik :: Zakat :: [17-17.10.21]

Zakat

Malik :: Book 17 : Hadith 17.10.21

Yahya related to me from Malik that Abdullah ibn Dinar said, "I heard Abdullah ibn Umar being asked what kanz was and he said, 'It is wealth on which zakat has not been paid.' "


Malik :: Zakat :: [17-17.10.22]

Zakat

Malik :: Book 17 : Hadith 17.10.22

Yahya related to me from Malik from Abdullah ibn Dinar from Abu's-Salih as-Samman that Abu Hurayra used to say, "Anyone who has wealth on which he has not paid zakat will, on the day of rising, find his wealth made to resemble a whiteheaded serpent with a sac of venom in each cheek which will seek him out until it has him in its power, saying, 'I am the wealth that you had hidden away.' "


Malik :: Zakat :: [17-17.11.23]

Zakat

Malik :: Book 17 : Hadith 17.11.23

Yahya related to me from Malik that he had read what Umar ibn al-Khattab had written about zakat, and in it he found:

"In the name of Allah, the Merciful, the ompassionate."

The Book of Zakat.

On twenty-four camels or less zakat is paid with sheep, one ewe for every five camels.

On anything above that, up to thirty-five camels, a she-camel in its second year, and, if there is no she camel in its second year, a male camel in its third year.

On anything above that, up to forty-five camels, a she-camel in its third year.

On anything above that, up to sixty camels, a she camel in its fourth year that is ready to be sired.

On anything above that, up to seventy-five camels, a she-camel in its fifth year.

On anything above that, up to ninety camels, two she-camels in their third year.

On anything above that, up to one hundred and twenty camels, two she-camels in their fourth year that are ready to be sired.

On any number of camels above that, for every forty camels, a she-camel in its third year, and for every fifty, a she-camel in its fourth year.

On grazing sheep and goats, if they come to forty or more, up to one hundred and twenty head, one ewe.

On anything above that, up to two hundred head, two ewes.

On anything above that, up to three hundred, three ewes.

On anything above that, for every hundred, one ewe.

A ram should not be taken for zakat. nor an old or an injured ewe, except as the zakat-collector thinks fit.

Those separated should not be gathered together nor should those gathered together be separated in order to avoid paying zakat.

Whatever belongs to two associates is settled between them proportionately.

On silver, if it reaches five awaq (two hundred dirhams), one fortieth is paid."


Malik :: Zakat :: [17-17.12.24]

Zakat

Malik :: Book 17 : Hadith 17.12.24

Yahya related to me from Malik from Humayd ibn Qays al-Makki from Tawus al Yamani that from thirty cows, Muadh ibn Jabal took one cow in its second year, and from forty cows, one cow in its third or fourth year, and when less than that (i.e. thirty cows) was brought to him he refused to take anything from it. He said, "I have not heard anything about it from the Messenger of Allah, may Allah bless him and grant him peace. When I meet him, I will ask him." But the Messenger of Allah, may Allah bless him and grant him peace, died before Muadh ibn Jabal returned.

Yahya said that Malik said, "The best that I have heard about some one who has sheep or goats with two or more shepherds in different places is that they are added together and the owner then pays the zakat on them. This is the same situation as a man who has gold and silver scattered in the hands of various people. He must add it all u p and pay whatever zakat there is to pay on the sum total."

Yahya said that Malik said, about a man who had both sheep and goats, that they were added up together for the zakat to be assessed, and if between them they came to a number on which zakat was due, he paid zakat on them. Malik added, "They are all considered as sheep, and in Umar ibn al-Khattab's book it says, 'On grazing sheep and goats, if they come to forty or more, one ewe.' "

Malik said, "If there are more sheep than goats and their owner only has to pay one ewe, the zakat collector takes the ewe from the sheep. If there are more goats than sheep, he takes it from the goats. If there is an equal number of sheep and goats, he takes the ewe from whichever kind he wishes."

Yahya said that Malik said, "Similarly, Arabian camels and Bactrian camels are added up together in order to assess the zakat that the owner has to pay. They are all considered as camels. If there are more Arabian camels than Bactrians and the owner only has to pay one camel, the zakat collector takes it from the Arabian ones. If, however, there are more Bactrian camels he takes it from those. If there is an equal number of both, he takes the camel from whichever kind he wishes."

Malik said, "Similarly, cows and water buffaloes are added up together and are all considered as cattle. If there are more cows than water buffalo and the owner only has to pay one cow, the zakat collector takes it from the cows. If there are more water buffalo, he takes it from them. If there is an equal number of both, he takes the cow from whichever kind he wishes. So if zakat is necessary, it is assessed taking both kinds as one group."

Yahya said that Malik said, "No zakat is due from anyone who comes into possession of livestock, whether camels or cattle or sheep and goats, until a year has elapsed over them from the day he acquired them, unless he already had in his possession a nisab of livestock. (The nisab is the minimum amount on which zakat has to be paid, either five head of camels, or thirty cattle, or forty sheep and goats). If he already had five head of camels, or thirty cattle, or forty sheep and goats, and he then acquired additional camels, or cattle, or sheep and goats, either by trade, or gift, or inheritance, he must pay zakat on them when he pays the zakat on the livestock he already has, even if a year has not elapsed over the acquisition. And even if the additional livestock that he acquired has had zakat taken from it the day before he bought it, or the day before he inherited it, he must still pay the zakat on it when he pays the zakat on the livestock he already has "

Yahya said that Malik said, "This is the same situation as some one who has some silver on which he pays the zakat and then uses to buy some goods with from somebody else. He then has to pay zakat on those goods when he sells them. It could be that one man will have to pay zakat on them one day, and by the following day the other man will also have to pay."

Malik said, in the case of a man who had sheep and goats which did not reach the zakatable amount, and who then bought or inherited an additional number of sheep and goats well above the zakatable amount, that he did not have to pay zakat on all his sheep and goats until a year had elapsed over them from the day he acquired the new animals, whether he bought them or inherited them.This was because none of the livestock that a man had, whether it be camels, or cattle, or sheep and goats, was counted as a nisab until there was enough of any one kind for him to have to pay zakat on it. This was the nisab which is used for assessing the zakat on what the owner had additionally acquired, whether it were a large or small amount of livestock.

Malik said, "If a man has enough camels, or cattle, or sheep and goats, for him to have to pay zakat on each kind, and then he acquires another camel, or cow, or sheep, or goat, it must be included with the rest of his animals when he pays zakat on them "

Yahya said that Malik said, "This is what I like most out of what I heard about the matter."

Malik said, in the case of a man who does not have the animal required of him for the zakat, "If it is a two-year-old she-camel that he does not have, a three-year-old male camel is taken instead. If it is a three- or four- or five-year-old she-camel that he does not have, then he must buy the required animal so that he gives the collector what is due. I do not like it if the owner gives the collector the equivalent value."

Malik said, about camels used for carrying water, and cattle used for working water-wheels or ploughing, "In my opinion such animals are included when assessing zakat."


Malik :: Zakat :: [17-17.13.25]

Zakat

Malik :: Book 17 : Hadith 17.13.25

Yahya said that Malik said, concerning two associates, "If they share one herdsman, one male animal, one pasture and one watering place then the two men are associates, as long as each one of them knows his own property from that of his companion If someone cannot tell his property apart from that of his fellow, he is not an associate, but rather, a co-owner "

Malik said, "It is not obligatory for both associates to pay zakat unless both of them have a zakatable amount (of livestock). If, for instance, one of the associates has forty or more sheep and goats and the other has less than forty sheep and goats, then the one who has forty has to pay zakat and the one who has less does not. If both of them have a zakatable amount (of livestock) then both of them are assessed together (i.e the flock is assessed as one) and both of them have to pay zakat. If one of them has a thousand sheep, or less, that he has to pay zakat on, and the other has forty, or more, then they are associates, and each one pays his contribution according to the number of animals he has - so much from the one with a thousand, and so much from the one with forty.

Malik said, "Two associates in camels are the same as two associates in sheep and goats, and, for the purposes of zakat, are assessed together if each one of them has a zakatable amount (of camels). That is because the Messenger of Allah, may Allah bless him and grant him peace, said, 'There is no zakat on less than five head of camels,' and Umar ibn al-Khattab said, 'On grazing sheep and goats, if they come to forty or more - one ewe.' "

Yahya said that Malik said, "This is what I like most out of what I have heard about the matter."

Malik said that when Umar ibn al-Khattab said, "Those separated should not be gathered together nor should those gathered together be separated in order to avoid paying zakat," what he meant was the owners of livestock.

Malik said, "What he meant when he said, 'Those separated should not be gathered together' is, for instance, that there is a group of three men, each of whom has forty sheep and goats, and each of whom thus has to pay zakat. Then, when the zakat collector is on his way ,they gather their flocks together so that they only owe one ewe between them. This they are forbidden to do. What he meant when he said, 'nor should those gathered together be separated,' is, for instance, that there are two associates, each one of whom has a hundred and one sheep and goats, and each of whom must therefore pay three ewes. Then, when the zakat collector is on his way, they split up their flocks so that they only have to pay one ewe each. This they are forbidden to do. And so it is said, 'Those separated should not be gathered together nor should those gathered together be separated in order to avoid paying zakat.' "

Malik said, "This is what I have heard about the matter."


Malik :: Zakat :: [17-17.14.26]

Zakat

Malik :: Book 17 : Hadith 17.14.26

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili from a son of Abdullah ibn Sufyan ath-Thaqafi from his grandfather Sufyan ibn Abdullah that Umar ibn al-Khattab once sent him to collect zakat. He used to include sakhlas (when assessing zakat), and they said, "Do you include sakhlas even though you do not take them (as payment)?" He returned to Umar ibn al-Khattab and mentioned that to him and Umar said, "Yes, you include a sakhla which the shepherd is carrying, but you do not take it. Neither do you take an akula, or a rubba, or a makhid, or male sheep and goats in their second and third years, and this is a just compromise between the young of sheep and goats and the best of them."

Malik said, "A sakhla is a newborn lamb or kid. A rubba is a mother that is looking after her offspring, a makhid is a pregnant ewe or goat, and an akula is a sheep or goat that is being fattened for meat."

Malik said, about a man who had sheep and goats on which he did not have to pay any zakat, but which increased by birth to a zakatable amount on the day before the zakat collector came to them, "If the number of sheep and goats along with their (newborn) offspring reaches a zakatable amount then the man has to pay zakat on them. That is because the offspring of the sheep are part of the flock itself. It is not the same situation as when some one acquires sheep by buying them, or is given them, or inherits them. Rather, it is like when merchandise whose value does not come to a zakatable amount is sold, and with the profit that accrues it then comes to a zakatable amount. The owner must then pay zakat on both his profit and his original capital, taken together. If his profit had been a chance acquisition or an inheritance he would not have had to pay zakat on it until one year had elapsed over it from the day he had acquired it or inherited it."

Malik said, "The young of sheep and goats are part of the flock, in the same way that profit from wealth is part of that wealth. There is, however, one difference, in that when a man has a zakatable amount of gold and silver, and then acquires an additional amount of wealth, he leaves aside the wealth he has acquired and does not pay zakat on it when he pays the zakat on his original wealth but waits until a year has elapsed over what he has acquired from the day he acquired it. Whereas a man who has a zakatable amount of sheep and goats, or cattle, or camels, and then acquires another camel, cow, sheep or goat, pays zakat on it at the same time that he pays the zakat on the others of its kind, if he already has a zakatable amount of livestock of that particular kind."

Malik said, "This is the best of what I have heard about this. "


Malik :: Zakat :: [17-17.15.27]

Zakat

Malik :: Book 17 : Hadith 17.15.27

Yahya said that Malik said, "The position with us concerning a man who has zakat to pay on one hundred camels but then the zakat collector does not come to him until zakat is due for a second timeand by that time all his camels have died except five, is that the zakat collector assesses from the five camels the two amounts of zakat that are due from the owner of the animals, which in this case is only two sheep, one for each year. This is because the only zakat which an owner of livestock has to pay is what is due from him on the day that the zakat is (actually) assessed. His livestock may have died or it may have increased, and the zakat collector only assesses the zakat on what he (actually) finds on the day he makes the assessment. If more than one payment of zakat is due from the owner of the livestock, he still only has to pay zakat according to what the zakat collector (actually) finds in his possession, and if his livestock has died, or several payments of zakat are due from him and nothing is taken until all his livestock has died, or has been reduced to an amount below that on which he has to pay zakat, then he does not have to pay any zakat, and there is no liability (on him) for what has died or for the years that have passed.


Malik :: Zakat :: [17-17.16.28]

Zakat

Malik :: Book 17 : Hadith 17.16.28

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban from al-Qasim ibn Muhammad that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Sheep from the zakat were brought past Umar ibn al-Khattab and he saw amongst them a sheep with a large udder, ready to give milk, and he said, 'What is this sheep doing here?' and they replied, 'It is one of the sheep from the zakat.' Umar said, 'The owners did not give this sheep willingly. Do not subject people to trials. Do not take from the muslims those of their animals which are the best food-producers.' "


Malik :: Zakat :: [17-17.16.29]

Zakat

Malik :: Book 17 : Hadith 17.16.29

Yahya related to me from Malik from Yahya ibn Said that Muhammad ibn Yahya ibn Habban said, "Two men from the Ashja tribe told me that Muhammad ibn Maslama al-Ansari used tocome to them to collect their zakat, and he would say to anyone who owned livestock, 'Select (the animal for) the zakat on your livestock and bring it to me,' and he would accept any sheep that was brought to him provided it met the requirements of what the man owed."

Malik said, "The sunna with us, and what I have seen the people of knowledge doing in our city, is that things are not made difficult for the muslims in their paying zakat, and whatever they offer of their livestock is accepted from them."


Malik :: Zakat :: [17-17.17.30]

Zakat

Malik :: Book 17 : Hadith 17.17.30

Yahya related to me from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Zakat is not permissible for someone who is not in need except for five: someone fighting in the way of Allah, someone who collects zakat, someone who has suffered (financial) loss (at the hands of debtors), someone who buys it with his own money, and some one who has a poor neighbour who receives some zakat and gives some as a present to the one who is not in need."

Malik said, "The position with us concerning the dividing up of zakat is that it is up to the individual judgement of the man in charge (wali). Whichever categories of people are in most need and are most numerous are given preference, according to how the man in charge sees fit. It is possible that that may change after one year, or two, or more, but it is always those who are in need and are most numerous that are given preference, whatever category they may belong to. This is what I have seen done by people of knowledge with which I am satisifed."

Malik said, "There is no fixed share for the collector of the zakat, except according to what the imam sees fit."


Malik :: Zakat :: [17-17.18.31]

Zakat

Malik :: Book 17 : Hadith 17.18.31

Yahya related to me from Malik that he had heard that Abu Bakr as-Siddiq said, "If they withhold even a hobbling cord I will fight them over it."


Malik :: Zakat :: [17-17.18.32]

Zakat

Malik :: Book 17 : Hadith 17.18.32

Yahya related to me from Malik that Zayd ibn Aslam said, ''Umar ibn al Khattab drank some milk which he liked (very much) and he asked the man who had given it to him, 'Where did this milk come from?' The man told him that he had come to a watering-place, which he named, and had found grazing livestock from the zakat watering there. He was given some of their milk, which he then put into his water-skin, and that was the milk in question. Umar ibn al-Khattab then put his hand into his mouth to make himself vomit."

Malik said, "The position with us is that if anyone refuses to honour one of the obligatory demands of Allah, and the muslims are unable to get it, then they have the right to fight him until they get itfrom him."


Malik :: Zakat :: [17-17.18.33]

Zakat

Malik :: Book 17 : Hadith 17.18.33

Yahya related to me from Malik that he had heard that one of the administrators of Umar ibn Abd al-'Aziz wrote to him mentioning that a man had refused to pay zakat on his property. Umar wrote to the administrator and told him to leave the man alone and not to take any zakat from him when he took it from the other muslims. The man heard about this and the situation became unbearable for him, and after that he paid the zakat on his property. The administrator wrote to Umar and mentioned that to him, and Umar wrote back telling him to take the zakat from him.


Malik :: Zakat :: [17-17.19.34]

Zakat

Malik :: Book 17 : Hadith 17.19.34

Yahya related to me from Malik from a reliable source from Sulayman ibn Yasar and from Busr ibn Said that the Messenger of Allah, may Allah bless him and grant him peace, said, "On land that is watered by rain or springs or any natural means there is (zakat to pay of) a tenth. On irrigated land there is (zakat of) a twentieth (to pay)."


Malik :: Zakat :: [17-17.19.35]

Zakat

Malik :: Book 17 : Hadith 17.19.35

Yahya related to me from Malik from Ziyad ibn Sad that Ibn Shihab said, "Neither jurur, nor musran al-fara, nor adhq ibn hubayq should be taken as zakat from dates. They should be included in the assessment but not taken as zakat. "

Malik said, "This is the same as with sheep and goats, whose young are included in the assessment but are not (actually) taken as zakat. There are also certain kinds of fruit which are not taken as zakat, such as burdi dates (one of the finest kinds of dates), and similar varieties.

Neither the lowest quality (of any property) nor the highest should be taken. Rather, zakat should be taken from average quality property."

Malik said, "The position that we are agreed upon concerning fruit is that only dates and grapes are estimated while on the tree. They are estimated when their usability is clear and they are halal to sell. This is because the fruit of date-palms and vines is eaten straightaway in the form of fresh dates and grapes, and so the assessment is done by estimation to make things easier for people and to avoid causing them trouble. Their produce is estimated and then they are given a free hand in using their produce as they wish, and later they pay the zakat on it according to the estimation that was made."

Malik said, "crops which are not eaten fresh, such as grains and seeds, which are only eaten after they have been harvested, are not estimated. The owner, after he has harvested, threshed and sifted the crop, so that it is then in the form of grain or seed, has to fulfil his trust himself and deduct the zakat he owes if the amount is large enough for him to have to pay zakat. This is the position that we are all agreed upon here (in Madina)."

Malik said, "The position that we are all agreed upon here (in Madina) is that the produce of date palms is estimated while it is still on the tree, after it has ripened and become halal to sell, and the zakat on it is deducted in the form of dried dates at the time of harvest. If the fruit is damaged after it has been estimated and the damage affects all the fruit then no zakat has to be paid. If some of the fruit remains unaffected, and this fruit amounts to five awsuq or more using the sa of the Prophet, may Allah bless him and grant him peace, then zakat is deducted from it. Zakat does not have to be paid, however, on the fruit that was damaged . Grapevines are dealt with in the same way.

If a man owns various pieces of property in various places, or is a co-owner of various pieces of property in various places, none of which individually comes to a zakatable amount, but which, when added together, do come to a zakatable amount, then he adds them together and pays the zakat that is due on them ."


Malik :: Zakat :: [17-17.20.36]

Zakat

Malik :: Book 17 : Hadith 17.20.36

Yahya related to me from Malik that he asked Ibn Shihab about olives and he said, "There is a tenth on them."

Malik said, "The tenth that is taken from olives is taken after they have been pressed, and the olives must come to a minimum amount of five awsuq and there must be at least five awsuq of olives. If there are less than five awsuq of olives, no zakat has to be paid.

Olive trees are like date palms insofar as there is a tenth on whatever is watered by rain or springs or any natural means, and a twentieth on whatever is irrigated. However, olives are not estimated while on the tree. The sunna with us as far as grain and seeds which people store and eat is concerned is that a tenth is taken from whatever has been watered by rain or springs or any natural means, and a twentieth from whatever has been irrigated, that is, as long as the amount comes to five awsuq or more using the aforementioned sa, that is, the sa of the Prophet, may Allah bless him and grant him peace. Zakat must be paid on anything above five awsuq according to the amount involved."

Malik said, "The kinds of grain and seeds on which there is zakat are: wheat, barley, sult (a kind of barley), sorghum, pearl millet, rice, lentils, peas, beans, sesame seeds and other such grains and seeds which are used for food. Zakat is taken from them after they have been harvested and are in the form of grai n or seed." He said, "People are entrusted with the assessment and whatever they hand over is accepted ."

Malik was asked whether the tenth or the twentieth was taken out of olives before they were sold or after and he said, "The sale is not taken into consideration. It is the people who produce the olives that are asked about the olives, just as it is the people who produce foodstuffs that are asked about it, and zakat is taken from them by what they say. Someone who gets five awsuq or more of olives from his olive trees has a tenth taken from the oil after pressing. Whereas someone who does not get five awsuq from his trees does not have to pay any zakat on the oil."

Malik said, "Someone who sells his crops when they are ripe and are ready in the husk has to pay zakat on them but the one who buys them does not. The sale of crops is not valid until they are ready in the husk and no longer need water."

Malik said, concerning the word of Allah the Exalted, "And give its due on the day of its harvesting," that it referred to zakat, and that he had heard people saying that.

Malik said, "If someone sells his garden or his land, on which are crops or fruit which have not yet ripened, then it is the buyer who has to pay the zakat. If, however, they have ripened, it is the seller who has to pay the zakat, unless paying the zakat is one of the conditions of the sale."


Malik :: Zakat :: [17-17.21.37]

Zakat

Malik :: Book 17 : Hadith 17.21.37

Malik said, "If a man has four awsuq of dates he has harvested, four awsuq of grapes he has picked, or four awsuq of wheat he has reaped or four awsuq of pulses he has harvested, the different categories are not added together, and he does not have to pay zakat on any of the categ ries - the dates, the grapes, the wheat or the pulses - until any one of them comes to five awsuq using the sa of the Prophet, may Allah bless him and grant him peace, as the Messenger of Allah, may Allah bless him and grant him peace, said, 'There is no zakat (to pay) on anything less than five awsuq of dates. 'lf any of the categories comes to five awsuq, then zakat must be paid. If none of the categories comes to five awsuq, then there is no zakat to pay. The explanation of this is that when a man harvests five awsuq of dates (from his palms), he adds them all together and deducts the zakat from them even if they are all of different kinds and varieties. It is the same with different kinds of cereal, such as brown wheat, white wheat, barley and sult, which are all considered as one category. If a man reaps five awsuq of any of these, he adds it all together and pays zakat on it. If it does not come to that amount he does not have to pay any zakat. It is the same (also) with grapes, whether they be black or red. If a man picks five awsuq of them he has to pay zakat on them, but if they do not come to that amount he does not have to pay any zakat. Pulses also are considered as one category, like cereals, dates and grapes, even if they are of different varieties and are called by different names. Pulses include chick-peas, lentils, beans, peas, and anything which is agreed by everybody to be a pulse. If a man harvests five awsuq of pulses, measuring by the aforementioned sa, the sa of the Prophet, may Allah bless him and grant him peace, he collects them all together and must pay zakat on them, even if they are of every kind of pulse and not just one kind."

Malik said, ''Umar ibn al-Khattab drew a distinction between pulses and wheat when he took zakat from the Nabatean christians. He considered all pulses to be one category and took a tenth from them, and from cereals and raisins he took a twentieth."

Malik said, "If some one asks, 'How can pulses be added up all together when assessing the zakat so that there is just one payment, when a man can barter two of one kind for one of another, while cereals can not be bartered at a rate of two to one?', then tell him, 'Gold and silver are collected together when assessing the zakat, even though an amount of gold dinars can be exchanged for many times tha tamount of silver dirhams.' "

Malik said, regarding date palms which are shared equally between two men, and from which eight awsuq of dates are harvested, "They do not have to pay any zakat on them. If one man owns five awsuq of what is harvested from one piece of land, and the other owns four awsuq or less, the one who owns the five awsuq has to pay zakat, and the other one, who harvested four awsuq or less, does not have to pay zakat. This is how things are done whenever there are associates in any crop, whether the crop is grain or seeds that are reaped, or dates that are harvested, or grapes that are picked . Any one of them that harvests five awsuq of dates, or picks five awsuq of grapes, or reaps five awsuq of wheat, has to pay zakat, and whoever's portion is less than five awsuq does not have to pay zakat. Zakat only has to be paid by someone whose harvesting or picking or reaping comes to five awsuq."

Malik said, "The sunna with us regarding anything from any of these categories, i.e. wheat, dates, grapes and any kind of grain o rseed, which has had the zakat deducted from it and is then stored by its owner for a number of years after he has paid the zakat on it until he sell sit, is that he does not have to pay any zakat on the price he sells it for until a year has elapsed over it from the day he made the sale, as long as he got it through (chance) acquisition or some other means and it was not intended for trading. Cereals, seeds and trade-goods are the same, in that if a man acquires some and keeps them for a number of years and then sells them for gold or silver, he does not have to pay zakat on their price until a year has elapsed over it from the day of sale. If, however, the goods were intended for trade then the owner must pay zakat on them when he sells them, as long as he has had them for a year from the day when he paid zakat on the property with which he bought them."


Malik :: Zakat :: [17-17.22.37]

Zakat

Malik :: Book 17 : Hadith 17.22.37

Malik said, "The sunna that we are all agreed upon here (in Madina) and which I have heard from the people of knowledge, is that there is no zakat on any kind of fresh (soft) fruit, whether it be pomegranates, peaches, figs or anything that is like them or not like them as long as it is fruit."

He continued, "No zakat has to be paid on animal fodder or herbs and vegetables of any kind, and there is no zakat to pay on the price realised on their sale until a year has elapsed over it from the day of sale which counts as the time the owner receives the sum."


Malik :: Zakat :: [17-17.23.38]

Zakat

Malik :: Book 17 : Hadith 17.23.38

Yahya related to me from Malik from Abdullah ibn Umar from Sulayman ibn Yasar from Irak ibn Malik from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A muslim does not have to pay any zakat on his slave or his horse."


Malik :: Zakat :: [17-17.23.39]

Zakat

Malik :: Book 17 : Hadith 17.23.39

Yahya related to me from Malik from Ibn Shihab from Sulayman ibn Yasar that the people of Syria said to Abu Ubayda ibn al-Jarrah, "Take zakat from our horses and slaves," and he refused. Then he wrote to Umar ibn al-Khattab and he (also) refused. Again they talked to him and again he wrote to Umar, and Umar wrote back to him saying, "If they want, take it from them and (then) give it back to them and give their slaves provision."

Malik said, "What he means, may Allah have mercy upon him, by the words 'and give it back to them' is, 'to their poor.' "


Malik :: Zakat :: [17-17.23.40]

Zakat

Malik :: Book 17 : Hadith 17.23.40

Yahya related to me from Malik that Abdullah ibn Abi Bakr ibn Amr ibn Hazim said, "A message came from Umar ibn Abd al-Aziz to my father when he was in Mina telling him not to take zakat from either honey or horses."


Malik :: Zakat :: [17-17.23.41]

Zakat

Malik :: Book 17 : Hadith 17.23.41

Yahya related to me from Malik that Abdullah ibn Dinar said, "I asked Said ibn al-Musayyab about zakat on work-horses, and he said, 'Is there any zakat on horses ?' "


Malik :: Zakat :: [17-17.24.42]

Zakat

Malik :: Book 17 : Hadith 17.24.42

Yahya related to me from Malik that Ibn Shihab said, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, took jizya from the magians of Bahrain, that Umar ibn al-Khattab took it from the magians of Persia and that Uthman ibn Affan took it from the Berbers."


Malik :: Zakat :: [17-17.24.43]

Zakat

Malik :: Book 17 : Hadith 17.24.43

Yahya related to me from Malik from Jafar ibn Muhammad ibn Ali from his father that Umar ibn al-Khattab mentioned the magians and said, "I do not know what to do about them." Abd ar-Rahman ibn Awf said, "I bear witness that I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Follow the same sunna with them that you follow with the people of the Book . ' "


Malik :: Zakat :: [17-17.24.44]

Zakat

Malik :: Book 17 : Hadith 17.24.44

Yahya related to me from Malik from Nafi from Aslam, the mawla of Umar ibn al-Khattab, that Umar ibn al-Khattab imposed a jizya tax of four dinars on those living where gold was the currency, and forty dirhams on those living where silver was the currency. In addition, they had to provide for the muslims and receive them as guests for three days.


Malik :: Zakat :: [17-17.24.45]

Zakat

Malik :: Book 17 : Hadith 17.24.45

Yahya related to me from Malik from Zayd ibn Aslam from his father that he said to Umar ibn al-Khattab, "There is a blind she-camel behind the house,'' soUmar said, "Hand it over to a household so that they can make (some) use of it." He said, "But she is blind." Umar replied, "Then put it in a line with other camels." He said, "How will it be able to eat from the ground?" Umar asked, "Is it from the livestock of the jizya or the zakat?" and Aslam replied, "From the livestock of the jizya." Umar said, "By AIIah, you wish to eat it." Aslam said, "It has the brand of the jizya on it." So Umar ordered it to be slaughtered. He had nine platters, and on each of the platters he put some of every fruit and delicacy that there was and then sent them to the wives of the Prophet, may Allah bless him and grant him peace, and the one he sent to his daughter Hafsa was the last of them all, and if there was any deficiency in any of them it was in Hafsa's portion.

"He put meat from the slaughtered animal on the platters and sent them to the wives of the Prophet, may Allah bless him and grant him peace, and he ordered what was left of the meat of the slaughtered animal to be prepared. Then he invited the Muhajirun and the Ansar to eat it."

Malik said, "I do not think that livestock should be taken from people who pay the jizya except as jizya."


Malik :: Zakat :: [17-17.24.46]

Zakat

Malik :: Book 17 : Hadith 17.24.46

Yahya related to me from Malik that he had heard that Umar ibn Abd al-Aziz wrote to his governors telling them to relieve any people who payed the jizya from paying the jizya if they became muslims.

Malik said, "The sunna is that there is no jizya due from women or children of people of the Book, and that jizya is only taken from men who have reached puberty. The people of dhimma and the magians do not have to pay any zakat on their palms or their vines or their crops or their livestock. This is because zakat is imposed on the muslims to purify them and to be given back to their poor, whereas jizya is imposed on the people of the Book to humble them. As long as they are in the country they have agreed to live in, they do not have to pay anything on their property except the jizya. If, however, they trade in muslim countries, coming and going in them, a tenth is taken from what they invest in such trade. This is because jizya is only imposed on them on conditions, which they have agreed on, namely that they will remain in their own countries, and that war will be waged for them on any enemy of theirs, and that if they then leave that land to go anywhere else to do business they will haveto pay a tenth. Whoever among them does business with the people of Egypt, and then goes to Syria, and then does business with the people of Syria and then goes to Iraq and does business with them and then goes on to Madina, or Yemen, or other similar places, has to pay a tenth.

People of the Book and magians do not have to pay any zakat on any of their property, livestock, produce or crops. The sunna still continues like that. They remain in the deen they were in, and they continue to do what they used to do. If in any one year they frequently come and go in muslim countries then they have to pay a tenth every time they do so, since that is outside what they have agreed upon, and not one of the conditions stipulated for them. This is what I have seen the people of knowledge of our city doing."


Malik :: Zakat :: [17-17.25.47]

Zakat

Malik :: Book 17 : Hadith 17.25.47

Yahya related to me from Ibn Shihab from Salim ibn Abdullah from his father that Umar ibn al-Khattab used to take a twentieth from the cereals and olive oil of the Nabatean christians, intending by that to increase the cargo to Madina. He would take a tenth from pulses.


Malik :: Zakat :: [17-17.25.48]

Zakat

Malik :: Book 17 : Hadith 17.25.48

Yahya related to me from Malik from Ibn Shihab that as-Sa'ib ibn Yazid said, "As a young man I used to work with Abdullah ibn Utba ibn Masud in the market of Madina in the time of Umar ibn al-Khattab and we used to take a tenth from the Nabateans."


Malik :: Zakat :: [17-17.25.49]

Zakat

Malik :: Book 17 : Hadith 17.25.49

Yahya related to me from Malik that he had asked Ibn Shihab why Umar ibn al Khattab used to take a tenth from the Nabateans, and Ibn Shihab replied, "It used to be taken from them in the jahiliyya, and Umar imposed it on them."


Malik :: Zakat :: [17-17.26.50]

Zakat

Malik :: Book 17 : Hadith 17.26.50

Yahya related to me from Zayd ibn Aslam that his father said that he had heard Umar ibn al-Khattab say, "I once gave a noble horse to carry somebody in the way of Allah, and the man neglected it. I wished to buy it back from him and I thought that he would sell it cheaply. I asked the Messenger of Allah, may Allah bless him and grant him peace, about it and he said, 'Do not buy it, even if he gives it to you for one dirham, for someone who takes back his sadaqa is like a dog swallowing its own vomit.' "


Malik :: Zakat :: [17-17.26.51]

Zakat

Malik :: Book 17 : Hadith 17.26.51

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umaribnal-Khattab gave a horse to carry some one in the way of Allah, and then he wished to buy it back. So he asked the Messenger of Allah, may Allah bless him and grant him peace, about it, and he said, "Do not buy or take back your sadaqa."

Yahya said that Malik was asked about whether a man who gave some sadaqa, and then found it being offered back to him for sale by some one other than the man to whom he had given it, could buy it or not, and he said, "I prefer that he leaves it."


Malik :: Zakat :: [17-17.27.52]

Zakat

Malik :: Book 17 : Hadith 17.27.52

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pay the zakat al-fitr for those slaves of his that were at Wadi'l-Qura and Khaybar.

Yahya related to me that Malik said, "The best that I have heard about the zakat al-fitr is that a man has to pay for every person that he is responsible for supporting and whom he must support. He has to pay forall his mukatabs, his mudabbars, and his ordinary slaves, whether they are present or absent, as long as they are muslim, and whether or not they are fortrade. However, he does not have to pay zakat on any of them that are not muslim."

Malik said, concerning a runaway slave, "I think that his master should pay the zakat fo rhim whether or not he knows where he is, if it has not been long since the slave ran away and his master hopes that he is still alive and will return. If it has been a long time since he ran away and his master has despaired of him returning then I do not think that he should pay zakat for him.'

Malik said, "The zakat al-fitr has to be paid by people living in the desert (i.e. nomadic people) just as it has to be paid by people living in villages (i.e. settled people), because the Messenger of Allah, may Allah bless him and grant him peace, made the zakat al-fitr at the end of Ramadan obligatory on every muslim, whether freeman or slave, male or female."


Malik :: Zakat :: [17-17.27.53]

Zakat

Malik :: Book 17 : Hadith 17.27.53

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, made the zakat of breaking the fast at the end of Ramadan obligatory on every muslim, whether freeman or slave, male or female, and stipulated it as a sa of dates or a sa of barley.


Malik :: Zakat :: [17-17.27.54]

Zakat

Malik :: Book 17 : Hadith 17.27.54

Yahya related to me from Malik from Zayd ibn Aslam from lyad ibn Abdullah ibn Sad ibn Abi Sarh al-Amiri that he had heard Abu Said al-Khudri say, "We used to pay the zakat al-fitr with a sa of wheat, or a sa of barley, or a sa of dates, or a sa of dried sour milk, or a sa of raisins, using the sa of the Prophet, may Allah bless him and grant him peace . "


Malik :: Zakat :: [17-17.27.55]

Zakat

Malik :: Book 17 : Hadith 17.27.55

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would always pay the zakat al-fitr in dates, except once, when he paid it in barley.

Maliksaid, "Payment of all types of kaffara, of zakat al-fitr and of the zakat on grains for which a tenth or a twentieth is due, is made using the smaller mudd, which is the mudd of the Prophet, may Allah bless him and grant him peace, except in the case of dhihar divorce, when the kaffara is paid using the mudd of Hisham, which is the larger mudd."


Malik :: Zakat :: [17-17.28.56]

Zakat

Malik :: Book 17 : Hadith 17.28.56

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to send the zakat al-fitr to the one with whom it was collected together two or three days before the day of breaking the fast.


Malik :: Zakat :: [17-17.28.57]

Zakat

Malik :: Book 17 : Hadith 17.28.57

Yahya related to me that Malik had seen that the people of knowledge used to like to pay the zakat al-fitr after dawn had broken on the day of the Fitr before they went to the place of prayer.

Malik said, "There is leeway in this, if Allah wills, in that it can be paid either before setting out (for the prayer) on the day of Fitr or afterwards."


Malik :: Zakat :: [17-17.29.58]

Zakat

Malik :: Book 17 : Hadith 17.29.58

Yahya related to me that Malik said, "A man does not have to pay zakat for the slaves of his slaves, or for some one employed by him, or for his wife's slaves, except for anyone who serves him and whose services are indispensable to him, in which case he must pay zakat. He does not have to pay zakat for any of his slaves that are kafir and have not become muslim, whether they be for trade or otherwise."


Malik :: Fasting :: [18-18.1.1]

Fasting

Malik :: Book 18 : Hadith 18.1.1

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, once mentioned Ramadan and said, "Do not begin the fast until you see the new moon, and do not break the fast (at the end of Ramadan) until you see it. If the new moon is obscured from you, then work out (when it should be)."


Malik :: Fasting :: [18-18.1.2]

Fasting

Malik :: Book 18 : Hadith 18.1.2

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "A month has twenty-nine days in it. Do not start the fast or break it until you see the new moon. If the new moon is obscured from you, then work out (when it should be)."


Malik :: Fasting :: [18-18.1.3]

Fasting

Malik :: Book 18 : Hadith 18.1.3

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, once mentioned Ramadan and said, "Do not start the fast or break it until you see the new moon. If the new moon is obscured from you, then complete a full thirty days."


Malik :: Fasting :: [18-18.1.4]

Fasting

Malik :: Book 18 : Hadith 18.1.4

Yahya related to me from Malik that he had heard that once in the time of Uthman ibn Affan the new moon had been seen in the afternoon and Uthman did not break his fast until evening had come and the sun had set.

Yahya said that he had heard Malik say that some one who sees the new moon of Ramadan when he is on his own should start the fast and not break it if he knows that that day is part of Ramadan. He added, "Some one who sees the new moon of Shawwal when he is on his own does not break the fast, because people suspect the reliability of someone among them who breaks the fast. Such people should say, when they sight the new moon, 'We have seen the new moon.' Whoever sees the new moon of Shawwal during the day should not break his fast but should continue fasting for the rest of that day. This is because it is really the new moon of the night that is coming ."

Yahya said that he heard Malik say, "If people are fasting on the day of Fitr thinking that it is still Ramadan and then definite evidence comes to them that the new moon of Ramadan had been seen one day before they began to fast and that they are now into the thirty-first day, then they should break the fast on that day at whatever time the news comes to them. However, they do not pray the id prayer if they hear the news after the sun has begun to decline."


Malik :: Fasting :: [18-18.2.5]

Fasting

Malik :: Book 18 : Hadith 18.2.5

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Only some one who makes the intention to fast before dawn (actually) fasts."

Yahya related to me from Malik from Ibn Shihab that A'isha and Hafsa, the wives of the Prophet, may Allah bless him and grant him peace, also said that.


Malik :: Fasting :: [18-18.3.6]

Fasting

Malik :: Book 18 : Hadith 18.3.6

Yahya related to me from Malik from Abu Hazim ibn Dinar from Sahl ibn Sad as Saidi that the Messenger of Allah, may Allah bless him and grant him peace, said, "People will remain in good as long as they are quick to break the fast."


Malik :: Fasting :: [18-18.3.7]

Fasting

Malik :: Book 18 : Hadith 18.3.7

Yahya related to me from Malik from Abd ar-Rahman ibn Harmala al-Aslami from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, said, "People will remain in good as long as they are quick to break the fast."


Malik :: Fasting :: [18-18.3.8]

Fasting

Malik :: Book 18 : Hadith 18.3.8

Yahya related to me from Malik from Ibn Shihab from Humayd ibn Abd ar-Rahman that Umar ibn al-Khattab and Uthman ibn Affan would pray maghrib when they saw the night darkening, before they broke their fast, and that was during Ramadan.


Malik :: Fasting :: [18-18.4.9]

Fasting

Malik :: Book 18 : Hadith 18.4.9

Yahya related to me from Malik from Abdullah ibn Abd ar-Rahman ibn Mamar al-Ansari from Abu Yunus, the mawla of A'isha, from A'isha that she overheard a man standing at the door saying to the Messenger of Allah, may Allah bless him and grant him peace, "Messenger of Allah, I get up in the morning junub, in a state of major ritual impurity, and want to fast," and the Messenger of Allah, may Allah bless him and grant him peace, said, "I too get up in the morning junub and want to fast, so I do ghusl and fast." The man said to him, "You are not the same as us. Allah has forgiven you all your wrong actions that have gone before and those that have come after." The Messenger of Allah, may Allah bless him and grant him peace, got angry and said, "By Allah, I hope that I am the most fearful of you with respect to Allah and the most knowledgeable of you in how I have taqwa."


Malik :: Fasting :: [18-18.4.10]

Fasting

Malik :: Book 18 : Hadith 18.4.10

Yahya related to me from Malik from Abd Rabbih ibn Said from Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham from A'isha and Umm Salama, the wives of the Prophet, may Allah bless him and grant him peace, that the Prophet, may Allah bless him and grant him peace, used to get up in the morning junub from intercourse, not a dream, in Ramadan, and then he would fast."


Malik :: Fasting :: [18-18.4.11]

Fasting

Malik :: Book 18 : Hadith 18.4.11

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham that he heard Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham say, "My father and I were with Marwan ibn al Hakam at the time when he was amir of Madina, and someone mentioned to him that Abu Hurayra used to say, 'If someone begins the morning junub, he has broken the fast for that day.' Marwan said, 'I swear to you, Abdar-Rahman, you must go to the two umm al muminin, A'isha and Umm Salama, and ask them about it.'

''Abd ar-Rahman went to visit A'isha and I accompanied him. He greeted her and then said, 'Umm al-muminin, we were with Marwan ibn al Hakam and someone mentioned to him that Abu Hurayra used to say that if some one had begun the morning junub, he had broken the fast for that day.' A'isha said, 'It is not as Abu Hurayra says Abd ar-Rahman. Do you dislike what the Messenger of Allah, may Allah bless him and grant him peace, used to do?', and Abd ar-Rahman said, 'No, by Allah.' A'isha said, 'I bear witness that the Messenger of Allah, may Allah bless him and grant him peace, used to get up in the morning junub from intercourse, not a dream, and would then fast for that day.' "

He continued, "Then we went and visited Umm Salama, and Abd ar-Rahman asked her about the same matter and she said the same as A'isha had said. Then we went off until we came to Marwan ibn al-Hakam Abd ar-Rahman told him what they had both said and Marwan said, 'I swear to you, Abu Muhammad, you must use the mount which is at the door, and go to Abu Hurayra, who is on his land at al Aqiq, and tell him this.' So Abd ar-Rahman rode off, and I went with him, until we came to Abu Hurayra. Abd ar-Rahman talked with him for a while, and then mentioned the matter to him, and Abu Hurayra said, 'I don't know anything about it. I was just told that by someone.'"


Malik :: Fasting :: [18-18.4.12]

Fasting

Malik :: Book 18 : Hadith 18.4.12

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr, from Abu Bakr ibn Abd ar-Rahman that A'isha and Umm Salama, the wives of the Prophet, may Allah bless him and grant him peace, said, "The Messengerof Allah, may Allah bless him and grant him peace, used to get up in the morning junub from intercourse, not a dream, and would then fast."


Malik :: Fasting :: [18-18.5.13]

Fasting

Malik :: Book 18 : Hadith 18.5.13

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that a certain man kissed his wife while he was fasting in Ramadan. This made him very anxious, and so he sent his wife to the Prophet, may Allah bless him and grant him peace, to ask him about that for him. She went in and saw Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, and mentioned the matter to her, and Umm Salama told her that the Messenger of Allah, may Allah bless him and grant him peace, used to kiss while he was fasting. So she went back and told her husband that, but it only made him find fault all the more and he said, "We are not like the Messenger of Allah, may Allah bless him and grant him peace. Allah makes permissible for the Messenger of Allah, may Allah bless him and grant him peace, whatever He wishes."

His wife then went back to Umm Salama and found the Messenger of Allah, may Allah bless him and grant him peace, with her. The Messenger of Allah, may Allah bless him and grant him peace, said, "What's the matter with this woman?", and Umm Salama told him. The Messenger of Allah, may Allah bless him and grant him peace, said, "Didn't you tell her that I do that myself?" and she said, "I told her, and she went to her husband and told him, but it only made him find fault all the more and say, 'We are not like the Messenger of Allah, may Allah bless him and grant him peace. Allah makes permissible for His Messenger, may Allah bless him and grant him peace, whatever He wishes.' " The Messenger of Allah, may Allah bless him and grant him peace, got angry and said, "By Allah, I am the one with the most taqwa of Allah of you all, and of you all the one who best knows His limits."


Malik :: Fasting :: [18-18.5.14]

Fasting

Malik :: Book 18 : Hadith 18.5.14

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin, may Allah be pleased with her, said, "The Messenger of Allah, may Allah bless him and grant him peace, used to kiss certain of his wives when fasting," and then she laughed.


Malik :: Fasting :: [18-18.5.15]

Fasting

Malik :: Book 18 : Hadith 18.5.15

Yahya related to me from Malik from Yahya ibn Said that Atika bint Zayd ibn Amr ibn Nufayl, the wife of Umar ibn al-Khattab, used to kiss Umar ibn al-Khattab's head while he was fasting, and he did not tell her not to.


Malik :: Fasting :: [18-18.5.16]

Fasting

Malik :: Book 18 : Hadith 18.5.16

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah that A'isha bint Talha told him that she was once with A'isha, the wife of the Prophet, may Allah bless him and grant him peace, and her husband, who was fasting, came and visited her there. (He was Abdullah ibn Abd ar-Rahman ibn Abi Bakras-Siddiq.) A'isha said to him, "What's stopping you from coming close to your wife and kissing her and joking with her?" He said, "Can I kiss her when I am fasting?" She said, "Yes."


Malik :: Fasting :: [18-18.5.17]

Fasting

Malik :: Book 18 : Hadith 18.5.17

Yahya related to me from Malik from Zayd ibn Aslam that Abu Hurayra and Sad ibn Abi Waqqas used to say that someone who was fasting was allowed to kiss.


Malik :: Fasting :: [18-18.6.18]

Fasting

Malik :: Book 18 : Hadith 18.6.18

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, would say, when she mentioned that the Messenger of Allah, used to kiss while fasting, "And who among you is more able to control himself than the Messenger of Allah, may Allah bless him and grant him peace?"

Yahya said that Malik said that Hisham ibn Urwa ibn az-Zubayr had said, "I do not think that kissing invites to good for people who are fasting."


Malik :: Fasting :: [18-18.6.19]

Fasting

Malik :: Book 18 : Hadith 18.6.19

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that Abdullah ibn Abbas was asked about people kissing while fasting and he said that he allowed it for old men but disapproved of it for young men.


Malik :: Fasting :: [18-18.6.20]

Fasting

Malik :: Book 18 : Hadith 18.6.20

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to forbid kissing and fondling for people who were fasting .


Malik :: Fasting :: [18-18.7.21]

Fasting

Malik :: Book 18 : Hadith 18.7.21

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, left for Makka in Ramadan during the year of the conquest, and fasted until he reached al-Kadid. He then broke the fast, and so everyone else did so as well. What people used to do was act according to whatever the Messenger of Allah, may Allah bless him and grant him peace, had done most recently.


Malik :: Fasting :: [18-18.7.22]

Fasting

Malik :: Book 18 : Hadith 18.7.22

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, from Abu Bakr ibn Abd ar-Rahman from one of the companions of the Messenger of Allah, that the Messenger of Allah, may Allah bless him and grant him peace, ordered everyone to break the fast on the journey he made in the year of the conquest saying, "Be strong for your enemy," while the Messenger of Allah, may Allah bless him and grant him peace, kept on fasting. Abu Bakr said that the one who related this to him said, "I saw the Messenger of Allah, may Allah bless him and grant him peace, pouring water over his head at al-Arj, either from thirst or from the heat. Then some one said to the Messenger of Allah, may Allah bless him and grant him peace, 'Messenger of Allah, a group of people kept on fasting when you did.' Then when the Messenger of Allah was at al-Kadid, he asked for a drinking-bowl and drank, and everyone broke the fast."


Malik :: Fasting :: [18-18.7.23]

Fasting

Malik :: Book 18 : Hadith 18.7.23

Yahya related to me from Malik from Humayd at-Tawil that Anas ibn Malik said, "We once travelled with the Messenger of Allah, may Allah bless him and grant him peace, in Ramadan, and those who were fasting did not find fault with those who were not, and those who were not fasting did not find fault with those who were."


Malik :: Fasting :: [18-18.7.24]

Fasting

Malik :: Book 18 : Hadith 18.7.24

Yahya related to me from Malik from Hisham ibn Urwa from his father that Hamza ibn Amr al-Aslami once said to the Messenger of Allah, may Allah bless him and grant him peace, "Messenger of Allah, I am a man who fasts. Can I fast when travelling?" The Messenger of Allah, may Allah bless him and grant him peace, said, "If you want you can fast, and if you want you can break the fast."


Malik :: Fasting :: [18-18.7.25]

Fasting

Malik :: Book 18 : Hadith 18.7.25

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used not to fast while travelling.


Malik :: Fasting :: [18-18.7.26]

Fasting

Malik :: Book 18 : Hadith 18.7.26

Yahya related to me from Malik that Hisham ibn Urwa said, "My father, Urwa, used to travel in Ramadan, and we would travel with him, and he used to fast while we would break the fast, and he would not tell us to fast."


Malik :: Fasting :: [18-18.8.27]

Fasting

Malik :: Book 18 : Hadith 18.8.27

27 Yahya related to me from Malik that he had heard that Umar ibn al-Khattab, if he was travelling in Ramadan and knew that he would reach Madina at the begining of the day ,would do so fasting.

Yahya said that Malik said, "Someone who is travelling and knows that he will be reaching his people in the first part of the day, and then dawn breaks before he gets there, should be fasting when he gets there."

Malik said, "Someone who intends to go away (on a journey) in Ramadan, and then dawn breaks while he is still on his land before he has left, should fast that day."

Malik said that a man who returns from a journey in Ramadan and is not fasting may have sexual intercourse with his wife if he wishes, if she is not fasting and she has just become pure after her menses.


Malik :: Fasting :: [18-18.9.28]

Fasting

Malik :: Book 18 : Hadith 18.9.28

Yahya related to me from Malik from Ibn Shihab from Hunayd ibn Abd arRahman ibn Awf from Abu Hurayra that a man broke the fast in Ramadan and the Messenger of Allah, may Allah bless him and grant him peace, ordered him to make kaffara by freeing a slave, or fasting two consecutive months, or feeding sixty poor people, and he said, "I can't do it." Someone brought a large basket of dates to the Messenger of Allah, may Allah bless him and grant him peace, and he said, "Take this and give it away as sadaqa." He said, "Messenger of Allah, there is no-ne more needy than I am." The Messenger of Allah, may Allah bless him and grant him peace, laughed until his eye-teeth appeared, and then he said, "Eat them."


Malik :: Fasting :: [18-18.9.29]

Fasting

Malik :: Book 18 : Hadith 18.9.29

Yahya related to me from Malik from Ata ibn Abdullah al-Khurasani that Said ibn al-Musayyab said, "A bedouin came to the Messenger of Allah, may Allah bless him and grant him peace, beating his breast and tearing out his hair and saying, 'I am destroyed.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Why is that?', and he said, 'I had intercourse with my wife while fasting in Ramadan.' The Messenger of Allah, may Allah bless him and grant him peace, asked him, 'Are you able to free a slave?', and the man said, 'No.' Then he asked him, 'Are you able to give away a camel?', and the man replied, 'No.' He said, 'Sit own,' and someone brought a large basket of dates to the Messenger of Allah, may Allah bless him and grant him peace, and he said to the man, 'Take this and give it away as sadaqa.' The man said, 'There is no one more needy than me,' and (the Messenger of Allah, may Allah bless him and grant him peace), said, 'Eat them, and fast one day for the day when you had intercourse.' "

Malik said that Ata said that he had asked Said ibn al-Musayyab how many dates there were in that basket, and he said, "Between fifteen and twenty sas.''

Malik said, "I have heard people of knowledge saying that the kaffara specified by the Messenger of Allah, may Allah bless him and grant him peace, for a man who has intercourse with his wife during the day in Ramadan is not due from someone who, on a day when he is making up the fast of Ramadan, breaks his fast by having intercourse with his wife, or whatever. He only has to make up for that day."

Malik said, "This is what I like most out of what I have heard about the matter."


Malik :: Fasting :: [18-18.10.30]

Fasting

Malik :: Book 18 : Hadith 18.10.30

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to be cupped while he was fasting. Nafi said, "He later stopped doing that, and would not be cupped when he was fasting until he had broken the fast."


Malik :: Fasting :: [18-18.10.31]

Fasting

Malik :: Book 18 : Hadith 18.10.31

Yahya related to me from Malik from Ibn Shihab that Sad ibn Abi Waqqas and Abdullah ibn Umar used to be cupped while they were fasting.


Malik :: Fasting :: [18-18.10.32]

Fasting

Malik :: Book 18 : Hadith 18.10.32

Yahya related to me from Malik from Hisham ibn Urwa that his father used to be cupped while he was fasting and he would not then break his fast. Hisham added, "I only ever saw him being cupped when he was fasting."

Malik said, "Cupping is only disapproved of for some one who is fasting out of fear that he will become weak and if it were not for that, it would not be disapproved of. I do not think that a man who is cupped in Ramadan and does not break his fast, owes anything, and I do not say that he has to make up for the day on which he was cupped, because cupping is only disapproved of for someone fasting if his fast is endangered. I do not think that someone who is cupped, and is then well enough to keep the fast until evening, owes anything, nor does he have to make up for that day."


Malik :: Fasting :: [18-18.11.33]

Fasting

Malik :: Book 18 : Hadith 18.11.33

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The day of Ashura was a day the Quraysh used to fast in the jahiliyya, and the Messenger of Allah, may Allah bless him and grant him peace, used also to fast it during the jahiliyya. Then when the Messenger of Allah, may Allah bless him and grant him peace, came to Madina he fasted it and ordered that it be fasted. Then Ramadan was made obligatory, and that became the fard instead of Ashura, but whoever wanted to, fasted it, and whoever did not want to, did not fast it."


Malik :: Fasting :: [18-18.11.34]

Fasting

Malik :: Book 18 : Hadith 18.11.34

Yahya related to me from Malik from Ibn Shihab that Humayd ibn Abd ar-Rahman ibn Awf heard Muawiya ibn Abi Sufyan say from the mimbar on the day of Ashura in the year in which he made the hajj, "People of Madina, where are your learned men? I heard the Messenger of Allah, may Allah bless him and grant him peace, say about this day, 'This is the day of Ashura, and fasting it has not been prescribed for you. I am fasting it, and whoever of you wants to fast it can do so, and whoever does not want to, does not have to.' "


Malik :: Fasting :: [18-18.11.35]

Fasting

Malik :: Book 18 : Hadith 18.11.35

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab had sent (the following message) to al-Harith ibn Hisham, ''Tomorrow is the day of Ashura, so fast (it) and tell your family to fast (also)."


Malik :: Fasting :: [18-18.12.36]

Fasting

Malik :: Book 18 : Hadith 18.12.36

Yahya related to me from Malik from Muhammad ibn Yahya ibn Habban from alAraj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, forbade fasting on two days, the day of Fitr and the day of Adha.


Malik :: Fasting :: [18-18.12.37]

Fasting

Malik :: Book 18 : Hadith 18.12.37

Yahya related to me from Malik that he used to hear the people of knowledge say,"There is no harm in fasting continuously as long as one breaks the fast on the days on which the Messenger of Allah, may Allah bless him and grant him peace, forbade fasting, namely, the days of Mina, the day of Adha and the day of Fitr, according to what we have heard."

Malik said, "This is what I like most out of what I have heard about the matter."


Malik :: Fasting :: [18-18.13.38]

Fasting

Malik :: Book 18 : Hadith 18.13.38

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade fasting for two days or more without breaking the fast in between. They said, "But Messenger of Allah, you practise wisal." He replied, "I am not the same as you. I am fed and given to drink."


Malik :: Fasting :: [18-18.13.39]

Fasting

Malik :: Book 18 : Hadith 18.13.39

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Beware of wisal. Beware of wisal." They said, "But you practise wisal, Messenger of Allah." He replied, "I am not the same as you. My Lord feeds me and gives me to drink."


Malik :: Fasting :: [18-18.14.40]

Fasting

Malik :: Book 18 : Hadith 18.14.40

Yahya related to me, and I (myself) heard Malik say, "The best that I have heard about some one who has to fast for two consecutive months because of having killed someone by mistake or having pronounced the dhihar form of divorce, becoming very ill and having to break his fast, is that if he recovers from his illness and is strong enough to fast, he must not delay doing so. He continues his fast from where he left off.

Similarly, a woman who has to fast because of having killed some one by mistake should not delay resuming her fast when she has become pure after her period. She continues her fast from where she left off.

No one who, by the Book of Allah, has to fast for two consecutive months may break his fast except for a reason - illness or menstruation. He must not travel and break his fast."

Malik said, "This is the best that I have heard about the matter."


Malik :: Fasting :: [18-18.15.41]

Fasting

Malik :: Book 18 : Hadith 18.15.41

Yahya said that he heard Malik say, "What I have heard from the people of knowledge is that if a man succumbs to an illness which makes fasting very difficult for him and exhausts him and wears him out, he can break his fast. This is the same as with a sick man in the prayer, who finds standing to be too difficult and exhausting, (and Allah knows better than the slave that it is an excuse for him and that it really cannot be described). If the man is in such a condition he prays sitting, and the deen of Allah is ease.

Allah has permitted a traveller to break the fast when travelling, and he has more strength for fasting than a sick man. Allah, the Exalted, says in His book, 'Whoever among you is ill or on a journey (must fast) a number of other days,' and Allah has thus permitted a traveller to break his fast when on a journey, and he is more capable of fasting than a sick man.


Malik :: Fasting :: [18-18.16.42]

Fasting

Malik :: Book 18 : Hadith 18.16.42

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab was asked whether a man who had vowed to fast a month could fast voluntarily, and Said said, "He should fulfil his vow before he does any voluntary fasting."

Malik said, "I have heard the same thing from Sulayman ibn Yasar."

Malik said, "If someone dies with an unfulfilled vow to free a slave or to fast or to give sadaqa or to give away a camel, and makes a bequest that his vow should be fulfilled from his estate, then the sadaqa or the gift of the camel are taken from one third of his estate. Preference is given to it over other bequests, except things of a similar nature, because by his vow it has become incumbent on him, and this is not the case with something he donates voluntarily. They (vows and voluntary donations) are settled from a limited one-third of his estate, and not from the whole of it, since if the dying man were free to dispose of all of his estate, he might delay settling what had become incumbent on him (i.e. his vows), so that when death came and the estate passed into the hands of his heirs, he would have bequeathed such things (i.e. his vows) that were not claimed by anyone (like debts). If that (i.e. to dispose freely of his property) were allowed him, he would delay these things (i.e. his vows) until when he was near death, he would designate them and they might take up all of his estate. He must not do that."


Malik :: Fasting :: [18-18.16.43]

Fasting

Malik :: Book 18 : Hadith 18.16.43

Yahya related to me from Malik that he had heard that Abdullah ibn Umar used to be asked, "an some one fast for some one else, or do the prayer for some one else?" and he would reply, "No one can fast or do the prayer for anyone else."


Malik :: Fasting :: [18-18.17.44]

Fasting

Malik :: Book 18 : Hadith 18.17.44

Yahya related to me from Malik from Zayd ibn Aslam from his brother Khalid ibn Aslam that Umar ibn al-Khattab once broke thefast on a cloudy day thinking that evening had come and the sun had set. Then a man came to him and said, "Amir al-muminin, the sun has come out,'' and Umar said, "That's an easy matter. It was our deduction (ijtihad)."

Malik said, "According to what we think, and Allah knows best, what he was referring to when he said, 'That's an easy matter' was making up the fast, and how slight the effort involved was and how easy it was. He was saying (in effect), 'We will fast another day in its place.' "


Malik :: Fasting :: [18-18.17.45]

Fasting

Malik :: Book 18 : Hadith 18.17.45

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Someone who breaks the fast in Ramadan because he is ill or travelling should make up the days he has missed consecutively."


Malik :: Fasting :: [18-18.17.46]

Fasting

Malik :: Book 18 : Hadith 18.17.46

Yahya related to me from Malik from Ibr Shihab that Abdullah ibn Abbas and Abu Hurayra differed about making up days missed in Ramadan. One of them said that they were done separately and the other said that they were done consecutively. He did not know which one of them it was who said that they were done separately.


Malik :: Fasting :: [18-18.17.47]

Fasting

Malik :: Book 18 : Hadith 18.17.47

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "If some one makes himself vomit while he is fasting he has to make up a day, but if he cannot help vomiting he does not have to make up anything."


Malik :: Fasting :: [18-18.17.48]

Fasting

Malik :: Book 18 : Hadith 18.17.48

Yahya related to me from Malik from Yahya ibn Said that he heard Said ibn al Musayyab being asked about making up days missed in Ramadan, and Said said, "What I like best is for days missed in Ramadan to be made up consecutively, and not separately."

Yahya said that he had heard Malik say, about some one who made up the days he had missed in Ramadan separately, that he did not have to repeat them. (What he had done) was enough for him. It was, however, preferable, if he did them consecutively.

Malik said, "Whoever eats or drinks thoughtlessly or forgetfully in Ramadan or during any other obligatory fast that he must do, has to fast another day in its place."


Malik :: Fasting :: [18-18.17.49]

Fasting

Malik :: Book 18 : Hadith 18.17.49

Yahya related to me from Malik that Humayd ibn Oays al-Makki told him, "I was with Mujahid while he was performing tawaf around the Kaba, and a man came to him and asked whether the days (of fasting) for kaffara had to be fasted consecutively, or could they be split up. I said to him, 'Yes, they can be split up, if the person so wishes.' Mujahid said, 'He should not split them up, because in Ubayy ibn Kab's recitation they are referred to as three consecutive days.' "

Malik said, "What I like most is what Allah has specified in the Qur'an, that is, that they are fasted consecutively."

Malik was asked about a woman who began the day fasting in Ramadan and though it was outside of the time of her period, fresh blood (i.e. not menstrual blood) flowed from her. She then waited until evening to see the same, but did not see anything.Then, on the next day in the morning she had anotherflow, though less than the first. Then, some days before her period, the flow stopped completely. Malik was asked what she should do about her fasting and prayer, and he said, "This blood is like menstrual blood. When she sees it she should break her fast, and then make up the days she has missed. Then, when the blood has completely stopped, she should do ghusl and fast."

Malik was asked whether someone who became muslim on the last day of Ramadan had to make up all of Ramadan or whether he just had to make up the day when he became muslim, and he said, "He does not have to make up any of the days that have passed. He begins fasting from that day onwards. What I like most is that he makes up the day on which he became muslim."


Malik :: Fasting :: [18-18.18.50]

Fasting

Malik :: Book 18 : Hadith 18.18.50

Yahya related to me from Malik from Ibn Shihab that A'isha and Hafsa, the wives of the Prophet, may Allah bless him and grant him peace, began fasting voluntarily one morning and then food was given to them and they broke their fast with it. Then the Messenger of Allah, may Allah bless him and grant him peace, came in. A'isha said, "Hafsa asked, anticipating me in speech - she took after her father Umar - 'Messenger of Allah, A'isha and I began the morning fasting voluntarily and then food was given us and we broke the fast with it.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Fast another day in its place.' "

Yahya said that he heard Malik say, "Someone who eats or drinks out of neglect or forgetfulness during a voluntary fast does not have to repeat his fast, but he should continue fasting for the rest of the day in which he eats or drinks while voluntarily fasting, and not stop fasting. Someone to whom something unexpected happens which causes him to break his fast while he is fasting voluntarily does not have to repeat his fast if he has broken it for a reason, and not simply because he decided to break his fast. Just as I do not think that someone has to repeat a voluntary prayer if he has had to stop it because of some discharge which he could prevent and which meant that he had to repeat his wudu."

Malik said, "Once a man has begun doing any of the right actions (al-amal as-saliha) such as the prayer, the fast and the hajj, or similar right actions of a voluntary nature, he should not stop until he has completed it according to what the sunna for that action is. If he says the takbir he should not stop until he has prayed two rakas. If he is fasting he should not break his fast until he has completed that day's fast. If he goes into ihram he should not return until he has completed his hajj, and if he begins doing tawaf he should not stop doing so until he has gone around the Kaba seven times. He should not stop doing any of these actions once he has started them until he has completed them, except if something happens such as illness or some other matter by which a man is excused. This is because Allah, the Blessed and Exalted, says in His Book, 'And eat and drink until the white thread becomes clear to you from the black thread of dawn, (and) then complete the fast until night-time,' (Sura 2 ayat 187), and so he must complete his fast as Allah has said. Allah, the Exalted, (also) says, 'And complete the hajj and the umra forAllah,' and so if a man were to go into ihram for a voluntary hajj having done his one obligatory hajj (on a previous occasion), he could not then stop doing his hajj having once begun it and leave ihram while in the middle of his hajj. Anyone that begins a voluntary act must complete it once he has begun doing it, just as an obligatory act must be completed . This is the best of what I have heard."


Malik :: Fasting :: [18-18.19.51]

Fasting

Malik :: Book 18 : Hadith 18.19.51

Yahya related to me from Malik that he had heard that Anas ibn Malik used to pay fidya when he had grown old and could no longer manage to do the fast.

Malik said, "I do not consider that to do so is obligatory, but what I like most is that a man does the fast when he is strong enough. Whoever pays compensation gives one mudd of food in place of every day, using the mudd of the Prophet, may Allah bless him and grant him peace."


Malik :: Fasting :: [18-18.19.52]

Fasting

Malik :: Book 18 : Hadith 18.19.52

Yahya related to me from Malik that he had heard that Abdullah ibn Umar was asked about what a pregnant woman should do if the fast became difficult for her and she feared for her child, and he said, "She should break the fast and feed a poor man one mudd of wheat in place of every day, using the mudd of the Prophet, may Allah bless him and grant him peace."

Malik said, "The people of knowledge consider that she has to make up for each day of the fast that she misses as Allah, the Exalted and Glorified, says, 'And whoever of you is sick or on a journey should fast an equal number of other days, ' and they consider her pregnancy and her concern for her child as a sickness."


Malik :: Fasting :: [18-18.19.53]

Fasting

Malik :: Book 18 : Hadith 18.19.53

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father used to say, "If someone has to make up for days not fasted in Ramadan and does not do them before the next Ramadan comes although he is strong enough to do so, he should feed a poor man with a mudd of wheat for every day that he has missed, and he has to fast the days he owes as well."

Yahya related to me from Malik that he had heard the same thing from Said ibn Jubayr.


Malik :: Fasting :: [18-18.20.54]

Fasting

Malik :: Book 18 : Hadith 18.20.54

Yahya related to me from Malik from Yahya ibn Said from Abu Salama ibn Abd ar-Rahman that he heard A'isha, the wife of the Prophet, may Allah bless him and grant him peace, say, "I used to have to make up days from Ramadan and not be able to do them until Shaban came."


Malik :: Fasting :: [18-18.21.55]

Fasting

Malik :: Book 18 : Hadith 18.21.55

Yahya related to me from Malik that he had heard the people of knowledge telling people not to fast on the day in Shaban when there was doubt (about whether it was Shaban or Ramadan), if they intended by it the fast of Ramadan . They considered that whoever fasted on that day without having seen (the new moon) had to make up that day if it later became clear that it was part of Ramadan. They did not see any harm in voluntary fasting on that day.

Malik said, "This is what we do, and what I have seen the people of knowledge in our city doing."


Malik :: Fasting :: [18-18.22.56]

Fasting

Malik :: Book 18 : Hadith 18.22.56

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah, from Abu Salama ibn Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, used to fast for so long that we thought he would never stop fasting, and he would go without fasting for so long that we thought he would never fast again. I never saw the Messenger of Allah, may Allah bless him and grant him peace, fast for a complete month except for Ramadan, and I never saw him do more fasting in any one month than he did in Shaban.'


Malik :: Fasting :: [18-18.22.57]

Fasting

Malik :: Book 18 : Hadith 18.22.57

Yahya related to me from Malik from Abu'z Zinad from al-A'raj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Fasting is a protection for you, so when you are fasting, do not behave obscenely or foolishly, and if any one argues with you or abuses you, say, 'I am fasting. I am fasting.' "


Malik :: Fasting :: [18-18.22.58]

Fasting

Malik :: Book 18 : Hadith 18.22.58

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "By the One in Whose hand my self is, the smell of the breath of a man fasting is better with Allah than the scent of musk.' He leaves his desires and his food and drink for My sake. Fasting is for Me and I reward it. Every good action is rewarded by ten times its kind, up to seven hundred times, except fasting, which is for Me, and I reward it.' "


Malik :: Fasting :: [18-18.22.59]

Fasting

Malik :: Book 18 : Hadith 18.22.59

Yahya related to me from Malik from his paternal uncle Abu Suhayl ibn Malik from his father that Abu Hurayra said, "When Ramadan comes the gates of the Garden are opened and the gates of the Fire are locked, and the shayatin are chained."


Malik :: Fasting :: [18-18.22.60]

Fasting

Malik :: Book 18 : Hadith 18.22.60

Yahya related to me from Malik that he had heard that the people of knowledge did not disapprove of people fasting using tooth-sticks at any hour of the day in Ramadan, whether at the beginning or the end, nor had he heard any of the people of knowledge disapproving of or forbidding the practice.

Yahya said that he heard Malik say, about fasting for six days after breaking the fast at the end of Ramadan, that he had never seen any of the people of knowledge and fiqh fasting them. He said, "I have not heard that any of our predecessors used to do that, and the people of knowledge disapprove of it and they are afraid that it might become a bida and that common and ignorant people might join to Ramadan what does not belong to it, if they were to think that the people of knowledge had given permission for that to be done and were seen doing it.

Yahya said that he heard Malik say, "I have never heard any of the people of knowledge and fiqh and those whom people take as an example forbidding fasting on the day of jumua. Fasting on it is good, and I have seen one of the people of knowledge fasting it, and it seemed to me that he was keen to do so."


Malik :: I'tikaf in Ramadan :: [19-19.1.1]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.1.1

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from Amra bint Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said,"When the Messenger of Allah, may Allah bless him and grant him peace, did itikaf he would bring his head near to me and I would comb it. He would only go into the house to relieve himself."


Malik :: I'tikaf in Ramadan :: [19-19.1.2]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.1.2

Yahya related to me from Malik from Ibn Shihab from Amra bint Abd ar-Rahman that when A'isha was doing itikaf she would only ask after sick people if she was walking and not if she was standing still.

Malik said, "A person doing itikaf should not carry out obligations of his, nor leave the mosque for them, nor should he help anyone. He should only leave the mosque to relieve himself. If he were able to go out to do things for people, visiting the sick, praying over the dead and following funeral processions would be the things with the most claim on his coming out."

Malik said, "A person doing itikaf is not doing itikaf until he avoids what some one doing itikaf should avoid, namely, visiting the sick, praying over the dead, and entering houses, except to relieve himself."


Malik :: I'tikaf in Ramadan :: [19-19.1.3]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.1.3

Yahya related to me from Malik that he had asked Ibn Shihab whether someone doing itikaf could go into a house to relieve himself, and he said, "Yes, there is no harm in that."

Malik said, "The situation that we are all agreed upon here is that there is no disapproval of anyone doing itikaf in a mosque where jumua is held. The only reason I see for disapproving of doing itikaf in a mosque where jumua is not held is that the man doing itikaf would have to leave the mosque where he was doing itikaf in order to go to jumua, or else not go there at all. If, however, he is doing itikaf in a mosque where jumua is not held, and he does not have to go to jumua in any other mosque, then I see no harm in him doing itikaf there, because Allah, the Blessed and Exalted, says, 'While you are doing itikaf in mosques,' and refers to all mosques in general, without specifying any particular kind."

Malik continued, "Accordingly, it is permissiblefor a man to do itikaf in a mosque where jumua is not held if he does not have to leave it to go to a mosque where jumua is held."

Malik said, "A person doing itikaf should spend the night only in the mosque where he is doing itikaf, except if his tent is in one of the courtyards of the mosque. I have never heard that someone doing itikaf can put up a shelter anywhere except in the mosque itself or in one of the courtyards of the mosque.

Part of what shows that he must spend the night in the mosque is the saying of A'isha, 'When the Messenger of Allah, may Allah bless him and grant him peace, was doing itikaf, he would only go into the house to relieve himself.' Nor should he do itikaf on the roof of the mosque or in the minaret."

Malik said, "The person who is going to do itikaf should enter the place where he wishes to do itikaf before the sun sets on the night when he wishes to begin his itikaf, so that he is ready to begin the itikaf at the beginning of the night when he is going to start his itikaf. A person doing itikaf should be occupied with his itikaf, and not turn his attention to other things which might occupy him, such as trading or whatever. There is no harm, however, if some one doing itikaf tells some one to do something for him regarding his estate, or the affairs of his family, or tells someone to sell some property of his, or something else that does not occupy him directly. There is no harm in him arranging for someone else to do that for him if it is a simple matter."

Malik said, "I have never heard any of the people of knowledge mentioning any modification as far as how to do itikaf is concerned. Itikaf is an act of ibada like the prayer, fasting, the hajj, and such like acts, whether they are obligatory or voluntary. Anyone who begins doing any of these acts should do them according to what has come down in the sunna. He should not start doing anything in them that the muslims have not done, whether it is a modification that he imposes on others, or one that he begins doing himself. The Messenger of Allah, may Allah bless him and grant him peace, practised itikaf, and the muslims know what the sunna of itikaf is."

Malik said, "Itikaf and jiwar are the same, and Itikaf is the same for a village-dweller as it is for a nomad."


Malik :: I'tikaf in Ramadan :: [19-19.2.4]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.2.4

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad and Nafi, the mawla of Abdullah ibn Umar said, "You cannot do itikaf unless you are fasting, because of what Allah, the Blessed and Exalted, says in His Book, 'And eat and drink until the white thread becomes clear to you from the black thread of dawn, then complete the fast until night-time, and do not have intercourse with them while you are doing itikaf in mosques,' (Sura 2 ayat 187). Allah only mentions itikaf together with fasting."

Malik said, "That is what we go by here."


Malik :: I'tikaf in Ramadan :: [19-19.3.5]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.3.5

Yahya related to me that Ziyad ibn Abd ar-Rahman said, "Malik related to us from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, that Abu Bakr ibn Abd ar-Rahman was once doing itikaf and he would go out to relieve himself in a closed room under a roofed passage in Khalid ibn Walid's house. Otherwise he did not leave his place of itikaf until he went to pray at the Id with the muslims."


Malik :: I'tikaf in Ramadan :: [19-19.3.6]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.3.6

Yahya related to me from Ziyad from Malik that he saw some of the people of knowledge who, when they did itikaf in the last ten days of Ramadan, would not go back to their families until they had attended the Id al-Fitr with everybody.

Ziyad said that Malik said, "I heard this from the people of excellence who have passed away, and it is what I like most out of what I have heard about the matter."


Malik :: I'tikaf in Ramadan :: [19-19.4.7]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.4.7

Ziyad related to me from Malik from Ibn Shihab from Amra bint Abd ar-Rahman from A'isha that the Messenger of Allah, may Allah bless him and grant him peace, once wanted to do itikaf, and when he went off to the place where he wanted to do itikaf he found some tents there, which were A'isha's tent, Hafsa's tent, and Zaynab's tent. When he saw them he asked about them and someone told him that they were the tents of A'isha, Hafsa and Zaynab. The Messenger of Allah, may Allah bless him and grant him peace, said, "Do you think them devout?" Then he left, and did not do itikaf until Shawwal, when he then did it for ten days.


Malik :: I'tikaf in Ramadan :: [19-19.4.8]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.4.8

Malik was asked whether someone who went into a mosque to do itikaf for the last ten days of Ramadan and stayed there for a day or two but then became ill and left the mosque, had to do itikaf for the number of days that were left from the ten, or not, and if he did have to do so, then what month should he do it in, and he replied, "He should make up whatever he has to do of the itikaf when he recovers, whether in Ramadan or otherwise. I have heard that the Messenger of Allah, may Allah bless him and grant him peace, once wanted to do itikaf in Ramadan, but then came back without having done so, and then when Ramadan had gone, he did itikaf for ten days in Shawwal.

Some one who does itikaf voluntarily in Ramadan and some one who has to do itikaf are in the same position regarding what is halal for them and what is haram. I have not heard that the Messenger of Allah, may Allah bless him and grant him peace, ever did itikaf other than voluntarily."

Malik said, that if a woman did itikaf and then menstruated during her itikaf, she went back to her house, and, when she was pure again she returned to the mosque, at whatever time it was that she became pure. She then continued her itikaf from where she left off. This was the same situation as with a woman who had to fast two consecutive months, and who menstruated and then became pure. She then continued the fast from where she had left off and did not delay doing so.


Malik :: I'tikaf in Ramadan :: [19-19.4.9]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.4.9

Ziyad related to me from Malik from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, used to go to relieve himself in houses.

Malik said, "Someone doing itikaf should not leave for his parents' funeral or for anything else."


Malik :: I'tikaf in Ramadan :: [19-19.5.9]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.5.9

Malik said, "There is no harm in someone who is in itikaf entering into a marriage contract as long as there is no physical relationship. A woman in itikaf may also be betrothed as long as there is no physical relationship. What is haram for someone in itikaf in relation to his womenfolk during the day is haram for him during the night."

Yahya said that Ziyad said that Malik said, "It is not halal for a man to have intercourse with his wife while he is in itikaf, nor for him to take pleasure in her by kissing her, or whatever. However, I have not heard anyone disapproving of a man, or woman, in itikaf getting married as long as there is no physical relationship. Marriage is not disapproved of for someone fasting."

"There is, however, a distinction between the marriage of someone in itikaf and that of someone who is muhrim, in that some one who is muhrim can eat, drink, visit the sick and attend funerals, but cannot put on perfume, whilst a man or woman in itikaf can put on oil and perfume and groom their hair, but cannot attend funerals or pray over the dead or visit the sick. Thus their situations with regard to marriage are different."

"This is the sunna as it has come down to us regarding marriage for those who are muhrim, doing itikaf, or fasting.


Malik :: I'tikaf in Ramadan :: [19-19.6.10]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.10

Yahya related to me from Malik from Yazid ibn Abdullah ibn al-Hadi from Muhammad ibn Ibrahim al-Harith at-Taymi from Abu Salama ibn Abd ar-Rahman that Abu Said al-Khudri said, "The Messenger of Allah, may Allah bless him and grant him peace, used to do itikaf in the middle ten days of Ramadan. One year he was doing itikaf and then, when it came to the night of the twenty-first, which was the night before the morning when he would normally have finished his itikaf, he said, 'Whoever has done i'tikaf with me should continue doing itikaf for the last ten days. I saw a certain night and then I was made to forget it. I saw myself prostrating the following morning in water and clay. Look for it in the last ten days, and look for it on the odd days.' "

Abu Said continued, "The sky poured with rain that night and the mosque had a roof (made of palm fronds) and the mosque was soaked. With my own eyes I saw the Messenger of Allah, may Allah bless him and grant him peace, leave with traces of water and clay on his forehead and nose, in the morning after the night of the twenty-first."


Malik :: I'tikaf in Ramadan :: [19-19.6.11]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.11

Ziyad related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "Search for Laylat al-Qadr in the last ten days of Ramadan."


Malik :: I'tikaf in Ramadan :: [19-19.6.12]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.12

Ziyad related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said. "Search for Laylat al-Qadr in the last seven days."


Malik :: I'tikaf in Ramadan :: [19-19.6.13]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.13

Ziyad related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah, that Abdullah ibn Unays al-Juhani said to the Messenger of Allah, may Allah bless him and grant him peace, "Messenger of Allah, I am a man whose house is a long way away. Tell me one night so that I can stop my journey for it." The Messenger of Allah, may Allah bless him and grant him peace, said, "Stop on the twenty-third night of Ramadan."


Malik :: I'tikaf in Ramadan :: [19-19.6.14]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.14

Ziyad related to me from Malik from Humayd at-Tawil that 'Anas ibn Malik said, "The Messenger of Allah, may Allah bless him and grant him peace, came out to us in Ramadan and said, 'I was shown a certain night in Ramadan and then two men abused each other and it was taken away. Look for it on the ninth and the seventh and the fifth.' "


Malik :: I'tikaf in Ramadan :: [19-19.6.15]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.15

Ziyad related to me from Malik from Nafi from Ibn 'Umar that some of the companions of the Messenger of Allah, may Allah bless him and grant him peace, were shown Laylat al-Qadr in their sleep during the last seven days. The Messenger of Allah, may Allah bless him and grant him peace, said, "I see that your visions agree about the last seven days, so whoever is searching for it should do so in the last seven days."


Malik :: I'tikaf in Ramadan :: [19-19.6.16]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.16

Ziyad related to me from Malik that he had heard a man he trusted of the people of knowledge say, "The Messenger of Allah, may Allah bless him and grant him peace, was shown the lifespans of the people (who had gone) before him, or what Allah willed of that, and it was as if the lives of the people of his community had become too short for them to be able to do as many good actions as others before them had been able to do with their long lives, so Allah gave him Laylat al-Qadr, which is better than a thousand months."


Malik :: I'tikaf in Ramadan :: [19-19.6.17]

I'tikaf in Ramadan

Malik :: Book 19 : Hadith 19.6.17

Ziyad related to me from Malik that he had heard that Said ibn al-Musayyab used to say, "Whoever is present at isha on Laylat al-Qadr has taken his portion from it."


Malik :: Hajj :: [20-20.1.1]

Hajj

Malik :: Book 20 : Hadith 20.1.1

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father from Asma bint Umays that she gave birth to Muhammad ibn Abi Bakr at al-Bayda. Abu Bakr mentioned this to the Messenger of Allah, may Allah bless him and grant him peace, and he said, "Tell her to do ghusl and then enter ihram."


Malik :: Hajj :: [20-20.1.2]

Hajj

Malik :: Book 20 : Hadith 20.1.2

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that Asma bint Umays gave birth to Muhammad ibn Abi Bakr at Dhu'l-Hulayfa and Abu Bakr told her to do ghusl and then enter ihram.


Malik :: Hajj :: [20-20.1.3]

Hajj

Malik :: Book 20 : Hadith 20.1.3

Yahya related to me from Malik from Nafi' that 'Abdullah ibn Umar used to do ghusl for ihram before he entered ihram, and for entering Makka, and for standing on the afternoon of 'Arafa.


Malik :: Hajj :: [20-20.2.4]

Hajj

Malik :: Book 20 : Hadith 20.2.4

Yahya related to me from Malik from Zayd ibn Aslam from Ibrahim ibn Abdullah ibn Hunayn from his father Abdullah ibn Hunayn that Abdullah ibn Abbas and al-Miswar ibn Makhrama once had a disagreement at al-Abwa. Abdullah said that some one in ihram could wash his head, and al Miswar ibn Makhrama maintained that some one in ihram could not wash his head.

Abdullah ibn Hunayn continued, "Abdullah ibn Abbas sent me to Abu Ayyub al-Ansari, and I found him doing ghusl between the posts of a well, screened by a garment. I greeted him and hesaid, 'Who is that?' I replied, 'I am 'Abdullah ibn Hunayn. 'Abdullah ibn Abbas sent me to you to ask how the Messenger of Allah, may Allah bless him and grant him peace, used to wash his head when he was in ihram.' "

He continued, "Abu Ayyub put his hand on the garment and pulled it down until I could see his head. He said to the man who was pouring out the water for him, 'Pour,' and he poured some over his head. Then he passed his hands over his head from the front to the back and then to the front again, and then said, 'I saw the Messenger of Allah, may Allah bless him and grant him peace, doing it like this.' "


Malik :: Hajj :: [20-20.2.5]

Hajj

Malik :: Book 20 : Hadith 20.2.5

Malik related to me from Humayd ibn Qays from Ata ibn Abi Rabah that 'Umar ibn alKhattab once asked Yala ibn Munya, who was pouring out water for him while he was having a ghusl, to pour some on his head. Ya'la said, "Are you trying to make me responsible? I will only pour it out if you tell me to do so." Umar ibn al-Khattab said, "Pour. It will only make (my head) more unkempt."


Malik :: Hajj :: [20-20.2.6]

Hajj

Malik :: Book 20 : Hadith 20.2.6

Malik related to me from Nafi that Abdullah ibn Umar would spend the night between the two trails in the valley of Dhu Tuwa when he was approaching Makka. Then he would pray subh, and after that he would enter Makka by the trail which is at the highest part of Makka. He would never enter Makka, if he was coming for hajj or umra, without doing ghusl beforehand when he was near Makka at Dhu Tuwa, and he would tell whoever was with him to do likewise.


Malik :: Hajj :: [20-20.2.7]

Hajj

Malik :: Book 20 : Hadith 20.2.7

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would never wash his head while he was in ihram except if he had to do ghusl because of a wet dream.

Malik said, "I have heard the people of knowledge say that there is no harm in someone who is in ihram rubbing his head with certain kinds of plants after he has stoned the Jamrat al-Aqaba but before he has shaved his head, because once he has finished stoning the Jamrat al-Aqaba it is halal for him to kill lice, to shave his head, to clean himself of body hair, and to wear normal clothes."


Malik :: Hajj :: [20-20.3.8]

Hajj

Malik :: Book 20 : Hadith 20.3.8

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that a man once asked the Messenger of Allah, may Allah bless him and grant him peace, what clothes someone in ihram could wear, and the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not wear shirts, turbans, trousers, burnouses, or leather socks, except if you cannot find sandals. In that case you can wear leather socks, but cut them off below the ankles. Do not wear any clothes that have been touched by saffron or yellow dye."

Yahya said that Malik was asked about the hadith attributed to the Prophet, may Allah bless him and grant him peace, "Whoever cannot find a waist wrapper should wear trousers," and he said, "I have never heard this, and I do not think that some one who is in ihram can wear trousers, because among the things which the Prophet, may Allah bless him and grant him peace, forbade some one in ihram to wear were trousers, and he did not make any exception for them although he did make an exception for leather socks."

20.4 Wearing Clothes when in Ihram


Malik :: Hajj :: [20-20.4.9]

Hajj

Malik :: Book 20 : Hadith 20.4.9

Yahya related to me from Malik from 'Abdullah ibn Dinar that Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, forbade anyone in ihram to wear a garment which had been dyed with saffron or yellow dye, and said, 'Anyone that cannot find sandals can wear leather socks, but he should cut them off below the ankles.' "


Malik :: Hajj :: [20-20.4.10]

Hajj

Malik :: Book 20 : Hadith 20.4.10

Yahya related to me from Malik from Nafi that he had heard Aslam, the mawla of Umar ibn al-Khattab, telling 'Abdullah ibn Umar that Umar ibn al-Khattab once saw a dyed garment on Talha ibn Ubaydullah while he was in ihram and Umar said, "What is this dyed garment, Talha?", and Talha said, "Amir al-muminin, it is only mud.'' Umar said, "You and your like are taken by people as imams, and if an ignorant man were to see this garment he would say that Talha ibn Ubaydullah used to wear a dyed robe while he was in ihram. So do not wear any form of dyed clothes."


Malik :: Hajj :: [20-20.4.11]

Hajj

Malik :: Book 20 : Hadith 20.4.11

Yahya related to me from Malik from Hisham ibn Urwa from his father that Asma bint Abi Bakr had worn clothes that were completely dyed with safflower while she was in ihram, though there was not any saffron in them.

Yahya said that Malik was asked if a garment which had been perfumed could be used for ihram if the smell of the perfume had gone, and he said, "Yes, as long as there is no saffron or yellow dye in it."


Malik :: Hajj :: [20-20.4.12]

Hajj

Malik :: Book 20 : Hadith 20.4.12

Yahya related to me from Malik from Nafi that 'Abdullah ibn 'Umar used to disapprove of anybody wearing a belt or girdle while in ihram.


Malik :: Hajj :: [20-20.4.13]

Hajj

Malik :: Book 20 : Hadith 20.4.13

Yahya related to me from Malik from Yahya ibn Sa'id that he heard Said ibn al Musayyab say, about the girdle worn by some one in ihram under his clothes, "There is no harm in it if he ties the ends together as a belt."

Malik said, "This is what I like most out of what I have heard about the matter."


Malik :: Hajj :: [20-20.5.13]

Hajj

Malik :: Book 20 : Hadith 20.5.13

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say that a man in ihram should not veil anything above his chin .


Malik :: Hajj :: [20-20.5.14]

Hajj

Malik :: Book 20 : Hadith 20.5.14

Yahya related to me from Malik from Nafi that Abdullah ibn Umar shrouded his son Waqid ibn Abdullah, who had died at al-Juhfa while in ihram, and he veiled his head and face and said, "If we had not been in ihram we would have perfumed him. "

Malik said, "A man can only do things while he is alive. When he is dead, his actions stop."


Malik :: Hajj :: [20-20.5.15]

Hajj

Malik :: Book 20 : Hadith 20.5.15

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say that a woman in ihram should wear neither a veil nor gloves.


Malik :: Hajj :: [20-20.5.16]

Hajj

Malik :: Book 20 : Hadith 20.5.16

Yahya related to me from Malik from Hisham ibn Urwa that Fatima bint al-Mundhir said, "We used to veil our faces when we were in ihram in the company of Asma bint Abi Bakr as-Siddiq."

20.7 Wearing Perfume during Hajj.


Malik :: Hajj :: [20-20.5.17]

Hajj

Malik :: Book 20 : Hadith 20.5.17

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "I perfumed the Messenger of Allah, may Allah bless him and grant him peace, for his ihram before he entered ihram, and when he came out of ihram before he did tawaf of the House."


Malik :: Hajj :: [20-20.5.18]

Hajj

Malik :: Book 20 : Hadith 20.5.18

Yahya related to me from Malik from Humayd ibn Qays from Ata ibn Rabah that a bedouin came to the Messenger of Allah, may Allah bless him and grant him peace, when he was at Hunayn, and he was wearing a shirt with traces of yellow on it. He said, "Messenger of Allah, I have entered ihram for umra. What should I do?" The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Take off your shirt and wash off this yellowness and do in umra as you would do on hajj."


Malik :: Hajj :: [20-20.5.19]

Hajj

Malik :: Book 20 : Hadith 20.5.19

Yahya related to me from Malik from Nafi from Aslam, the mawla of Umar ibn al Khattab, that Umar ibn al-Khattab discovered the smell of perfume while he was at ash-Shajara, and he asked, "Who is this smell of perfume coming from?" Muawiya ibn Abi Sufyan answered, "From me, amir al-muminin." Umar said, "From you? By the life of Allah!" Muawiya explained, "Umm Habiba perfumed me, amir al-muminin. "'Umar then said, "You must go back and wash it off."


Malik :: Hajj :: [20-20.5.20]

Hajj

Malik :: Book 20 : Hadith 20.5.20

Yahya related to me from Malik from as-Salt ibn Zubayd from more than one of his family that Umar ibn al-Khattab discovered the smell of perfume while he was at ash-Shajara. Kathir ibn as-Salt was at his side, and Umar asked, "Who is this smell of perfume coming from?", and Kathir said, "From me, amir al-muminin. I matted my hair with perfume and I intended not to shave it.'' Umar said, "Go to a sharaba and rub your head until it is clean," and Kathir did so.

Malik explained, "A sharaba is the ditch at the base of a date-palm."


Malik :: Hajj :: [20-20.5.21]

Hajj

Malik :: Book 20 : Hadith 20.5.21

Yahya related to me from Malik from Yahya ibn Said and 'Abdullah ibn Abi Bakr and Rabia ibn Abi Abd ar-Rahman that al-Walid ibn Abd al-Malik asked Salim ibn Abdullah and Kharija ibn Zayd ibn Thabit if he could use perfume after he had stoned the jamra and shaved his head, but before he had left for the tawafal-ifada. Salim forbade him to do so, but Kharija ibn Zayd ibn Thabit said that he could.

Malik said, "There is no harm in a man oiling himself with an oil which does not have any perfume in it, either before he enters ihram, or before he leaves Mina for the tawaf al-ifada, if he has stoned the jamra."

Yahya said that Malik was asked whether someone in ihram could eat food with saffron in it, and he said, "There is no harm in some one in ihram eating it if it has been cooked. If, however, it has not been cooked he should not eat it."


Malik :: Hajj :: [20-20.6.22]

Hajj

Malik :: Book 20 : Hadith 20.6.22

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "The people of Madina should enter ihram at Dhu'l-Hulayfa, the people of Syria should do so at al-Juhfa, and the people of Najd should do so at Qarn."

Abdullah ibn Umar added, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, said, 'The people of Yemen should enter ihram at Yalamlam.' "


Malik :: Hajj :: [20-20.6.23]

Hajj

Malik :: Book 20 : Hadith 20.6.23

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, told the people of Madina to enter ihram at Dhu'l-Hulayfa, the people of Syria to do so at al-Juhfa, and the people of Najd to do so at Qarn.'


Malik :: Hajj :: [20-20.6.24]

Hajj

Malik :: Book 20 : Hadith 20.6.24

Abdullah ibn Umar said, "I heard these three from the Messenger of Allah, may Allah bless him and grant him peace. I was also told that the Messenger of Allah, may Allah bless him and grant him peace, said, 'The people of Yemen should enter ihram at Yalamlam.' "


Malik :: Hajj :: [20-20.6.25]

Hajj

Malik :: Book 20 : Hadith 20.6.25

Yahya related to me from Malik from Nafi that Abdullah ibn Umar once entered ihram at al-Fur.


Malik :: Hajj :: [20-20.6.26]

Hajj

Malik :: Book 20 : Hadith 20.6.26

Yahya related to me from Malik from a reliable source that Abdullah ibn Umar once entered ihram at Ilya (Jerusalem).


Malik :: Hajj :: [20-20.6.27]

Hajj

Malik :: Book 20 : Hadith 20.6.27

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, once entered ihram at al-Jiirrana (near Makka) for an umra.


Malik :: Hajj :: [20-20.7.28]

Hajj

Malik :: Book 20 : Hadith 20.7.28

Yahya related to me from Malik from Abdullah ibn Umar that the talbiya of the Messenger of Allah, may Allah bless him and grant him peace, was, "I am at Your service, O Allah, I am at Your service. You have no partner. I am at Your service. Praise and blessing belong to You, and the Kingdom. You have no partner."

Labayk, Allahumma labayk, la sharika laka labayk. Inna'l-hamda wa'n-nimata laka wa'l-mulk, la sharika lak.

Malik said that Abdullah ibn Umar used to add, "I am at Your service, I am at Your service. I am at Your service and at Your call. Good is in Your hands, and I am at Your service. Our desire is for You, and our action ."

Labayk, labayk, labayk wa sadayka wa'l-khayr biyadayka labayk wa'r-raghba'u ilayka wa'l-amalu.


Malik :: Hajj :: [20-20.7.29]

Hajj

Malik :: Book 20 : Hadith 20.7.29

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, used to pray two rakas in the mosque at Dhu'l-Hulayfa, and then, when he had got on to his camel and it had stood up, he would begin doing talbiya.


Malik :: Hajj :: [20-20.7.30]

Hajj

Malik :: Book 20 : Hadith 20.7.30

Yahya related to me from Malik from Musa ibn Uqba that Salim ibn Abdullah heard his father say, "Your claim that the Messenger of Allah, may Allah bless him and grant him peace, entered ihram from this desert of yours is not true, because he only entered ihram from the mosque, i.e. the mosque of Dhu'l-Hulayfa."


Malik :: Hajj :: [20-20.7.31]

Hajj

Malik :: Book 20 : Hadith 20.7.31

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi that Ubayd ibn Jurayj once said to Abdullah ibn Umar, "Abu Abd ar-Rahman, I have seen you doing four things which I have never seen any of your companions doing." He said, "What are they, Ibn Jurayj?" and he replied, "I have seen you touching only the twoYamani corners, I have seen you wearing hairless sandals, I have seen you using yellow dye, and, when you were at Makka and everybody had started doing talbiya after seeing the new moon, I saw that you did not do so until the eighth of Dhu'l-Hijja."

Abdullah ibn Umar replied, "As for the corners, I only ever saw the Messenger of Allah, may Allah bless him and grant him peace, touching the two Yamani corners. As for the sandals, I saw the Messenger of Allah, may Allah bless him and grant him peace, wearing hairless sandals and doing wudu in them, and I like wearing them. As for using yellow dye, I saw the Messenger of Allah, may Allah bless him and grant him peace, using it, and I also like to use it for dyeing things with. As for doing talbiya, I never saw the Messenger of Allah, may Allah bless him and grant him peace, begin doing so until he had set out on the animal he was riding on (i.e. for Mina and Arafa)."


Malik :: Hajj :: [20-20.7.32]

Hajj

Malik :: Book 20 : Hadith 20.7.32

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pray in the mosque of Dhu'l-Hulayfa, and then go outside and get on his camel and when his camel had stood up he would begin to do talbiya.


Malik :: Hajj :: [20-20.7.33]

Hajj

Malik :: Book 20 : Hadith 20.7.33

Yahya related to me from Malik that he had heard that Abd al-Malik ibn Marwan had started to do talbiya at the mosque of Dhu'l-Hulayfa, after the animal he was riding on had stood up, and that Aban ibn Uthman had told him to do this.


Malik :: Hajj :: [20-20.8.34]

Hajj

Malik :: Book 20 : Hadith 20.8.34

Yahya related to me from Malik from 'Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from Abd al-Malik ibn Abi Bakr ibn al-Harith ibn Hisham from Khallad ibn as-Sa'ib al-Ansari from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "Jibril came to me and told me to tell my companions, or whoever was with me, to raise their voices when doing talbiya."


Malik :: Hajj :: [20-20.8.35]

Hajj

Malik :: Book 20 : Hadith 20.8.35

Yahya related to me from Malik that he had heard the people of knowledge say, "Women do not have to raise their voices when they are doing talbiya, and a woman should only speak loudly enough to hear herself."

Malik said, "Some one who is in ihram should not raise his voice when doing talbiya if he is in a mosque where there are groups of people. He should only speak loudly enough for himself and those who are near him to be able to hear, except in the Masjid alHaram and the mosque at Mina, where he should raise his voice."

Malik said, "I have heard some of the people of knowledge recommending (people to do) talbiya at the end of every prayer and at every rise on the route."


Malik :: Hajj :: [20-20.9.36]

Hajj

Malik :: Book 20 : Hadith 20.9.36

Yahya related to me from Malik, from Abu'l-Aswad Muhammad ibn Abd ar-Rahman, fromUrwa ibn az-Zubayr, that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "We set out with the Messenger of Allah, may Allah bless him and grant him peace, in the year of the farewell hajj, and some of us went into ihram to do umra, some of us went into ihram to do hajj and umra, and some of us went into ihram to do hajj on its own. The Messenger of Allah, may Allah bless him and grant him peace, went into ihram to do hajj on its own. Those who had gone into ihram to do umra came out of ihram (after doing umra). Those who had gone into ihram to do hajj (on its own), or to do both hajj and umra, did not come out of ihram until the day of the sacrifice."


Malik :: Hajj :: [20-20.9.37]

Hajj

Malik :: Book 20 : Hadith 20.9.37

Yahya related to me from Malik, from Abd ar-Rahman ibn al-Qasim, from his father, from A'isha, umm al-muminin, that the Messenger of Allah, may Allah bless him and grant him peace, did hajj on its own.


Malik :: Hajj :: [20-20.9.38]

Hajj

Malik :: Book 20 : Hadith 20.9.38

Yahya related to me from Malik, from Abu'l-Aswad Muhammad ibn 'Abd ar-Rahman, from Urwa ibn az-Zubayr, from A'isha, umm al-muminin, that the Messenger of Allah, may Allah bless him and grant him peace, did hajj on its own.


Malik :: Hajj :: [20-20.9.39]

Hajj

Malik :: Book 20 : Hadith 20.9.39

Yahya related to me from Malik that he had heard the people of knowledge say, "If someone goes into ihram to do hajj on its own, he cannot then go into ihram to do umra.''

Malik said, "This is what I have found the people of knowledge in our city doing."


Malik :: Hajj :: [20-20.10.40]

Hajj

Malik :: Book 20 : Hadith 20.10.40

Yahya related to me from Malik, from Jafar ibn Muhammad, from his father, that al-Miqdad ibn al-Aswad once went to see AIi ibn Abi Talibat as-Suqya, where he was feeding some young camels of his with a mash of meal and leaves, and he said to him, "This man Uthman ibn Affan is telling people that they cannot do hajj and umra together."

Al-Miqdad said, "Ali ibn Abi Talib went off with bits of meal and leaves on his forearms - and I shall never forget the sight of the meal and the leaves on his arms - and went to see Uthman ibn Affan and asked him, 'Are you saying then that people cannot do hajj and umra together?' Uthman replied, 'That is my opinion.' Whereupon AIi got angry and went out saying, 'I am at your service, O Allah, I am at your service for a hajj and an umra together.' "

Malik said, "Our position (here in Madina) is that someone who does hajj and umra together should not remove any of his hair, nor should he come out of ihram in any way until he has sacrificed an animal, if he has one. He should come out of ihram at Mina, on the day of the sacrifice."


Malik :: Hajj :: [20-20.10.41]

Hajj

Malik :: Book 20 : Hadith 20.10.41

Yahya related to me from Malik, from Muhammad ibn Abd ar-Rahman, from Sulayman ibn Yasar, that when the Messenger of Allah, may Allah bless him and grant him peace, set out for hajj in the year of the farewell hajj, some of his companions went into ihram to do hajj on its own, some of them combined hajj and umra, and some went into ihram to do umra on its own. Those who had gone into ihram to do hajj, or hajj and umra together, did not come out of ihram, whils tthose who had gone into ihram to doumra (on its own) came out of ihram.


Malik :: Hajj :: [20-20.10.42]

Hajj

Malik :: Book 20 : Hadith 20.10.42

Yahya related to me from Malik that he had heard some of the people of knowledge say, "If someone goes into ihram to do umra and then wants to go into ihram to do hajj as well, he can do so, as long as he has not done tawaf of the House and s'ay between Safa and Marwa. This is what Abdullah ibn 'Umar did when he said, 'If I am blocked from the House we shall do what we did when we were with the Messenger of Allah, may Allah bless him and grant him peace.' He then turned to his companions and said, 'It is the same either way. I call you to witness that I have decided in favour of hajj and umra together. ' "

Malik said, "The companions of the Messenger of Allah, may Allah bless him and grant him peace, went into ihram to do umra in the year of the farewell hajj, and the Messenger of Allah, may Allah bless him and grant him peace, said to them, 'Anyone that has a sacrificial animal with him should go into ihram to do hajj and umra together, and he should not come out of ihram until he has finished both.' "


Malik :: Hajj :: [20-20.11.43]

Hajj

Malik :: Book 20 : Hadith 20.11.43

Yahya related to me from Malik that Muhammad ibn Abi Bakr ath-Thaqafi once asked Anas ibn Malik, while the two of them were going from Mina to Arafa, "What did you use to do on this day when you were with the Messenger of Allah, may Allah bless him and grant him peace?" He said, "Those of us who were saying the talbiya would continue doing so, and no-one disapproved of it, and those of us who were saying 'Allahu akbar' would continue doing so, and no-one disapproved of that either."


Malik :: Hajj :: [20-20.11.44]

Hajj

Malik :: Book 20 : Hadith 20.11.44

Yahya related to me from Malik, from Jafar ibn Muhammad, from his father, that AIi ibn Abi Talib used to say the talbiya while on hajj until after noon on the day of Arafa, when he would stop doing so.

Yahya said that Malik said, "This is what the people of knowledge in our city are still doing."


Malik :: Hajj :: [20-20.11.45]

Hajj

Malik :: Book 20 : Hadith 20.11.45

Yahya related to me from Malik, from Abd ar-Rahman ibn al-Qasim, from his father, that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, would stop saying the talbiya when she arrived at the place of standing (i.e. Arafa) .


Malik :: Hajj :: [20-20.11.46]

Hajj

Malik :: Book 20 : Hadith 20.11.46

Yahya related to me from Malik, from Nafi, that when 'Abdullah ibn Umar was doing hajj he would keep saying the talbiya until he reached the Haram and did tawaf of the House and say between Safa and Marwa. He would then say the talbiya until he left Mina to go to Arafa, at which point he would stop doing so. If he was doing umra he would stop saying the talbiya on entering the Haram.


Malik :: Hajj :: [20-20.11.47]

Hajj

Malik :: Book 20 : Hadith 20.11.47

Yahya related to me from Malik that Ibn Shihab used to say, "Abdullah ibn Umar would never say the talbiya while he was doing tawaf of the House."


Malik :: Hajj :: [20-20.11.48]

Hajj

Malik :: Book 20 : Hadith 20.11.48

Yahya related to me from Malik, from AIqama ibn Abi AIqama, from his mother, that A'isha, umm al-muminin, used to camp on the plain of Arafa at a place called Namira, and then later she changed to another place called al-Arak.

She said, ''A'isha, and those who were with her, would say the talbiya while she was at the place where they were camping, and then, when she had mounted and set out towards the place of standing, she would stop doing so."

She continued, ''A'isha used to do umra when she was in Makka after the hajj was over, in the month of Dhu'l-Hijja.Then she stopped doing that, and instead would set out before the new moon of Muharram for al-J uhfa, where she would stay until she saw the new moon, and then, when she had seen the new moon, she would go into ihram to do umra."


Malik :: Hajj :: [20-20.11.49]

Hajj

Malik :: Book 20 : Hadith 20.11.49

Yahya related to me from Malik, from Yahya ibn Said, that Umar ibn Abd alAziz was once going from Mina (to Arafa) on the day of Arafa and heard the takbir being said loudly, so he sent the guard to shout out to the people, "O people, you should be saying the talbiya."


Malik :: Hajj :: [20-20.12.50]

Hajj

Malik :: Book 20 : Hadith 20.12.50

Yahya related to me from Malik, from Abd ar-Rahman ibn al-Qasim, from his father, that Umar ibn al-Khattab said, "People of Makka, why is it that people arrive dishevelled while you still have oil on your hair? Go into ihram when you see the new moon."


Malik :: Hajj :: [20-20.12.51]

Hajj

Malik :: Book 20 : Hadith 20.12.51

Yahya related to me from Malik, from Hisham ibn Urwa, that Abdullah ibn az-Zubayr stayed in Makka for nine years. He would go into ihram for hajj at the beginning of Dhu'l-Hijja, and Urwa ibn az-Zubayr, who was with him, would do likewise.

Yahya said that Malik said, "The people of Makka and whoever else is living there besides them should go into ihram for hajj if they are in Makka, and anyone that is living in the centre of Makka and is not one of the people of Makka should not leave the Haram."

Yahya said that Malik said, "Someone who goes into ihram for hajj in Makka should delay tawaf of the House and the sa'y between Safa and Marwa until he has come back from Mina, which is what Abdullah ibn Umar used to do."

Malik was asked what the people of Madina, or anybody else, should do about tawaf if they went into ihram in Makka at the beginning of Dhu'l-Hijja, and he said, "They should delay the obligatory tawaf, which is the one they combine with the say between Safa and Marwa, but they can do whatever other tawaf they want to, and they should pray two rakas every time they complete seven tawafs, which is what the companions of the Messenger of Allah, may Allah bless him and grant him peace, did when they had gone into ihram to do hajj. They delayed the tawaf of the House and the sa'y between Safa and Marwa until they had come back from Mina. Abdullah ibn Umar also did this, going into ihram for hajj in Makka at the beginning of Dhu'l-Hijja, and then delaying tawaf of theHouse and the say between Safa and Marwa until he had come back from Mina."

Malik was asked whether one of the people of Makka could go into ihram to do umra in the centre of Makka, and he said, "No. He should go outside the Haram and go into ihram there."


Malik :: Hajj :: [20-20.13.52]

Hajj

Malik :: Book 20 : Hadith 20.13.52

Yahya related to me from Malik, from 'Abdullah ibn Abi Bakr ibn Muhammad, that Amra bint 'Abd ar-Rahman told him that Ziyad ibn Abi Sufyan once wrote to A'isha, the wife of the Prophet, may Allah bless him and grant him peace, saying, "'Abdullah ibn Abbas said that whatever was haram for some one doing hajj was also haram for some one who sent a sacrificial animal until the animal was sacrificed. I have sent one, so write and tell me what you say about this, or tell the man in charge of the animal what to do.

Amra said that A'isha said, "It is notas Ibn Abbas has said. I once plaited the garlands for the sacrificial animal of the Messenger of Allah, may Allah bless him and grant him peace, with my own two hands. Then after that the Messenger of Allah, may Allah bless him and grant him peace, himself put the garlands on the animal and then sent it with my father. And there was nothing that Allah had made halal forthe Messenger of Allah, may Allah bless him and grant him peace, that was haram for him until such time as the animal had been sacrificed."


Malik :: Hajj :: [20-20.13.53]

Hajj

Malik :: Book 20 : Hadith 20.13.53

Yahya related to me from Malik that Yahya ibn Said said, "I asked Amra bint Abd ar-Rahman if there was anything that was haram for someone who sent a sacrificial animal (to Makka) but did not go there himself, and she told me that she had heard A'isha say, 'It is only some one who goes into ihram for hajj and begins saying the talbiya for whom things are haram.' "


Malik :: Hajj :: [20-20.13.54]

Hajj

Malik :: Book 20 : Hadith 20.13.54

Yahya related to me from Malik, from Yahya ibn Said, from Muhammad ibn Ibrahim ibn al-Harith at-Taymi, that Rabia ibn Abdullah ibn al-Hudayr once saw a man in a state of ihram in Iraq. So he asked people about him and they said, "He has given directions for his sacrificial animal to be garlanded, and it is for that reason that he has put on ihram ."

Rabia said, "I then met Abdullah ibn az-Zubayr and so I mentioned this to him and he said, 'By the Lord of the Kaba, an innovation.' "

Malik was asked about some one who set out with his own sacrificial animal and marked it and garlanded it at Dhu'l-Hulayfa, but did not go into ihram until he had reached al-Juhfa,and hesaid, "I do not like that, and whoever does so has not acted properly. He should only garland his sacrificial animal, or mark it, when he goes into ihram, unless it is someone who does not intend to do hajj, in which case he sends it off and stays with his family."

Malik was asked if somone who was not in ihram could set out with a sacrificial animal, and he said, "Yes. There is no harm in that."

He was also asked to comment on the different views people had about what became haram for some one who garlanded a sacrificial animal but did not intend to do either hajj or umra, and he said, "What we go by as far as this is concerned is what A'isha, umm al-muminin said, 'The Messenger of Allah, may Allah bless him and grant him peace, sent his sacrificial animal off and did not go there himself, and there was nothing that Allah had made halal for him that was haram for him until the animal had been sacrificed.' "


Malik :: Hajj :: [20-20.14.55]

Hajj

Malik :: Book 20 : Hadith 20.14.55

Yahya related to me from Malik, from Nafi, that Abdullah ibn Umar used to say, "A menstruating woman who wants to go into ihram to do either hajj or umra can do so if she so wishes, but she cannot do tawaf of the House, nor the say between Safa and Marwa. She can participate in all the rituals along with everybody else, except that she cannot do tawaf of the House, nor the say between Safa and Marwa, nor can she come near the mosque until she is pure."


Malik :: Hajj :: [20-20.15.56]

Hajj

Malik :: Book 20 : Hadith 20.15.56

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, did umra three times: in the year of Hudaybiya, in the year of al-Qadiyya, and in the year of al-Jiirrana.


Malik :: Hajj :: [20-20.15.57]

Hajj

Malik :: Book 20 : Hadith 20.15.57

Yahya related to me from Malik from Hisham ibn Urwa, from his father, that the Messenger of Allah, may Allah bless him and grant him peace, only did three umras, one of them in Shawwal, and two in Dhu'l-Qada.


Malik :: Hajj :: [20-20.15.58]

Hajj

Malik :: Book 20 : Hadith 20.15.58

Yahya related to me from Malik, from Abd ar-Rahman ibn Harmala al-Aslami, that somebody asked Said ibn al-Musayyab, "Can I do umra before I do hajj?", and Said said, "Yes, the Messenger of Allah, may Allah bless him and grant him peace, did umra before doing hajj."


Malik :: Hajj :: [20-20.15.59]

Hajj

Malik :: Book 20 : Hadith 20.15.59

Yahya related to me from Malik, from Ibn Shihab, from Said ibn al-Musayyab, that Umar ibn Abi Salama once asked Umar ibn alKhattab for permission to do umra in Shawwal. He gave him permission, so he did umra and then went back to his family, and he did not do hajj.


Malik :: Hajj :: [20-20.16.60]

Hajj

Malik :: Book 20 : Hadith 20.16.60

Yahya related to me from Malik, from Hisham ibn 'Urwa, that his father would stop saying the talbiya when he entered the Haram, if he was doing 'umra.

Malik said that someone who went into ihram at at-Tanim should stop saying the talbiya when he saw the House.

Yahya said that Malik was asked where a man from the people of Madina, or elsewhere, who had begun doing umra at one of the mawaqit, should stop saying the talbiya, and he said, "Someone who goes into ihram at one of the mawaqit should stop saying the talbiya when he arrives at the Haram."

Malik added, "I have heard that Abdullah ibn Umar used to do that."


Malik :: Hajj :: [20-20.17.61]

Hajj

Malik :: Book 20 : Hadith 20.17.61

Yahya related to me from Malik, from Ibn Shihab, that Muhammad ibn Abdullah ibn al-Harith ibn Nawfal ibn Abd al-Muttalib told him that he had heard Sad ibn Abi Waqqas and ad-Dahhak ibn Qays discussing tamattu in between umra and hajj. Ad-Dahhak ibn Qays said, "Only someone who is ignorant of what Allah, the Exalted and Glorified, says would do that." Whereupon Sad said, "How wrong is what you have just said, son of my brother!" Ad-Dahhak said, ''Umar ibn al-Khattab forbade that," and Sad said, "The Messenger of Allah, may Allah bless him and grant him peace, did it, and we did it with him."


Malik :: Hajj :: [20-20.17.62]

Hajj

Malik :: Book 20 : Hadith 20.17.62

Yahya related to me from Malik, from Sadaqa ibn Yasar, that Abdullah ibn Umar said, "By Allah, I would rather do umra before hajj and sacrifice an animal than do umra after hajj in the month of Dhu'l-Hijja."


Malik :: Hajj :: [20-20.17.63]

Hajj

Malik :: Book 20 : Hadith 20.17.63

Yahya related to me from Malik, from Abdullah ibn Dinar, that Abdullah ibn Umar used to say, "Anyone that does umra in the months of hajj, that is, in Shawwal, Dhu'l-Qada, or in Dhu'l-Hijja before the hajj, and then stays in Makka until the time for hajj, is doing tamattu if he then does hajj. He must sacrifice whatever animal it is easy for him to obtain, and if he cannot find one then he must fast three days during hajj and seven days when he returns."

Malik said, "This is only the case if he stays until the hajj and does hajj in that same year."

Malik said that if someone who was from Makka but had stopped living there and gone to live elsewhere, came back to do umra in the months of the hajj and then stayed in Makka to begin hajj there, he was doing tamattu, and had to offer up a sacrificial animal, or fast if he could not find one. He was not the same as the people of Makka.

Malik was asked whether someone who was not from Makka and entered Makka to do umra in the months of hajj with the intention of staying on to begin his hajj there was doing tamattu or not, and he said, "Yes, he is doing tamattu, and he is not the same as the people of Makka, even if he has the intention of staying there. This is because he has entered Makka, and is not one of its people, and making a sacrifice or fasting is incumbent on anyone who is not from Makka, and, although he intends to stay, he does not know what possibilities might arise later. He is not one of the people of Makka."


Malik :: Hajj :: [20-20.17.64]

Hajj

Malik :: Book 20 : Hadith 20.17.64

Yahya related to me from Malik that Yahya ibn Said used to hear Said ibn al-Musayyab say, "Anyone that does umra in Shawwal, Dhu'l-Qada or Dhu l-Hijja, and then stays in Makka until it is time for the hajj, is doing tamattu if he then does hajj. He must sacrifice whatever animal it is easy for him to obtain, and if he cannot find one then he must fast three days during hajj and seven days when he returns."


Malik :: Hajj :: [20-20.18.65]

Hajj

Malik :: Book 20 : Hadith 20.18.65

Malik said, "Someone who does umra in Shawwal, Dhu'l-Qada or Dhu'l-Hijja and then goes back to his people, and then returns and does hajj in that same year does not have to sacrifice an animal. Sacrificing an animal is only incumbent on some one who does umra in the months of hajj, and then stays in Makka and then does hajj. A person not from Makka who moves to Makka and establishes his home there and does umra in the months of the hajj and then begins his hajj there is not doing tamattu. He does not have to sacrifice an animal nor does he have to fast. He is in the same position as the people of Makka if he is one of those who are living there."

Malik was asked whether a man from Makka who had gone to live in another town or had been on a journey and then returned to Makka with the intention of staying there, regardless of whether he had a family there or not, and entered it to do umra in the months of the hajj, and then began his hajj there, beginning his umra at the miqat of the Prophet, may Allah bless him and grant him peace, or at a place nearer than that, was doing tamattu or not?

Malik answered, "He does not have to sacrifice an animal or fast as someone who is doing tamattu has to do. This is because Allah, the Blessed and Exalted, says in His Book, 'That is for someone whose family are not present at Masjid al-Haram. '


Malik :: Hajj :: [20-20.19.66]

Hajj

Malik :: Book 20 : Hadith 20.19.66

Yahya related to me from Malik, from Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, from Abu Salih as-Samman, from Abu Hurayra, that the Messenger of Allah, may Allah bless him and grant him peace ,said, "Umra is an expiation for what is between it and the next umra, and the only reward for an accepted hajj is the Garden."


Malik :: Hajj :: [20-20.19.67]

Hajj

Malik :: Book 20 : Hadith 20.19.67

Yahya related to me from Malik that Sumayy, the mawla of Abu Bakr ibn Abd ar-Rahman, heard Abu Bakribn Abd ar-Rahman say, "A woman came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'I had arranged to do hajj, but I was prevented,' and the Messenger of Allah, may Allah bless him and grant him peace, said, 'Do umra in Ramadan, for doing umra in it is like doing hajj.' "


Malik :: Hajj :: [20-20.19.68]

Hajj

Malik :: Book 20 : Hadith 20.19.68

Yahya related to me from Malik, from Nafi, from Abdullah ibn Umar, that Umar ibn al-Khattab said, "Keep your hajj separate from your umra. That way your hajj will be more complete. And your umra will be more complete if you do it outside of the months of the hajj."


Malik :: Hajj :: [20-20.19.69]

Hajj

Malik :: Book 20 : Hadith 20.19.69

Yahya related to me from Malik that he had heard that Uthman ibn Affan would sometimes never get down from the animal he was riding on when he was doing umra, until he had returned .

Malik said, ''Umra is a sunna, and we do not know of any muslim who has ever said that it is permissible not to do it."

Malik said, "I do not think that anyone can do more than one umra in any one year."

Malik said that someone doing umra who had sexual intercourse with his wife had to sacrifice an animal and do a second umra, which he had to begin when he had finished the one that he had spoiled. He should go into ihram at the same place where he went into ihram for the umra which he had spoiled, except if he had entered into ihram at a place further away than his miqat. This was because he only had to go into ihram from his miqat.

Malik said, "Someone who entered Makka to do umra, and does tawaf of the House and say between Safa and Marwa while he is junub, or not in wudu, and afterwards has intercourse with his wife, and then remembers, should do ghusl, or wudu, and then go back and do tawaf around the House and say between Safa and Marwa and do another umra and sacrifice an animal. A woman should do the same if her husband has intercourse with her while she is in ihram. "

Malik said, "As for beginning umra at at-Tanim, (it is not the only alternative). It is permissible if Allah wills for some one to leave the Haram and go into ihram if he wishes, but the best way is for him to go into ihram at the miqat which the Messenger of Allah, may Allah bless him and grant him peace, used (i.e. at-Tanim), or one which is further away."


Malik :: Hajj :: [20-20.20.70]

Hajj

Malik :: Book 20 : Hadith 20.20.70

Yahya related to me from Malik, from Rabia ibn Abi Abd ar-Rahman, from Sulayman ibn Yasar, that the Messenger of Allah, may Allah bless him and grant him peace, sent Abu Rafi and a man of the Ansar to arrange his marriage to Maymuna bint al-Harith, and the Messenger of Allah, may Allah bless him and grant him peace, was in Madina before he had left for umra.


Malik :: Hajj :: [20-20.20.71]

Hajj

Malik :: Book 20 : Hadith 20.20.71

Yahya related to me from Malik, from Nafi, from Nubayh ibn Wahb, who was from the tribe of Bani Abd ad-Dar, that Umar ibn Ubaydullah sent a message to Aban ibn Uthman (who was amir of the hajj at the time), while both of them were in ihram, saying, "I want to marry Bint Shayba ibn Jubayr to Talha ibn Umar and I want you to be present." Aban told him that he should not do that and said, "I heard Uthman ibn Affan say that the Messenger of Allah, may Allah bless him and grant him peace, said, 'A man in ihram should not marry, or give in marriage, or get betrothed.' "


Malik :: Hajj :: [20-20.20.72]

Hajj

Malik :: Book 20 : Hadith 20.20.72

Yahya related to me from Malik, from Da'ud ibn al-Husayn, that Abu Ghatafan ibn Tarif al-Murri told him that his father Tarif had married a woman while he was in ihram, and Umar ibn al-Khattab had rescinded the marriage.


Malik :: Hajj :: [20-20.20.73]

Hajj

Malik :: Book 20 : Hadith 20.20.73

Yahya related to me from Malik, from Nafi, that Abdullah ibn Umar used to say, "Someone in ihram may neither get married, nor arrange a marriage for himself or others."


Malik :: Hajj :: [20-20.20.74]

Hajj

Malik :: Book 20 : Hadith 20.20.74

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab, Salim ibn Abdullah and Sulayman ibn Yasar were asked about whether someone in ihram could get married, and they said, "Some one in ihram may neither get married nor give some one in marriage."

Malik said that a man who was in ihram could return to his wife if he wanted to, if she was still in her idda after she had been divorced from him.


Malik :: Hajj :: [20-20.21.75]

Hajj

Malik :: Book 20 : Hadith 20.21.75

Yahya related to me from Malik, from Yahya ibn Sa'id, from Sulayman ibn Yasar, that the Messenger of Allah, may Allah bless him and grant him peace, was once cupped on the top of his head while he was in ihram, at Lahyay Jamal, which is a place on the road to Makka.


Malik :: Hajj :: [20-20.21.76]

Hajj

Malik :: Book 20 : Hadith 20.21.76

Yahya related to me from Malik, from Nafi, that Abdullah ibn Umar used to say, "Someone in ihram should not be cupped, except when there is no other alternative."

Malik said, "Someone who is in ihram should not be cupped except when it is necessary."


Malik :: Hajj :: [20-20.22.77]

Hajj

Malik :: Book 20 : Hadith 20.22.77

Yahya related to me from Malik, from Abu'n-Nadr, the mawla of 'Umar ibn 'Ubaydullah at-Taymi, from Nafi, the mawla of Abu Qatada al-Ansari, that Abu Qatada was once with the Messenger of Allah, may Allah bless him and grant him peace. When they got to one of the roads to Makka he fell behind with some companions of his who were muhrim, while he was not. Then he saw a wild ass, so he got on his mount and asked his companions to give him his whip but they refused. Then he asked them for his spear and they refused to give it to him. So he took hold of it and attacked the ass and killed it. Some of the companions of the Messenger of Allah, may Allah bless him and grant him peace, ate from it, and others refused. When they had caught up with the Messenger of Allah, may Allah bless him and grant him peace, they asked him about it and he said, "It is food that Allah has fed you with."


Malik :: Hajj :: [20-20.22.78]

Hajj

Malik :: Book 20 : Hadith 20.22.78

Yahya related to me from Malik, from Hisham ibn Urwa, from his father, that az-Zubayr ibn al-Awwam used to take dried gazelle meat (safif adh-dhiba) as provisions while he was in ihram.

Malik said, "Safif are dried strips of meat."


Malik :: Hajj :: [20-20.22.79]

Hajj

Malik :: Book 20 : Hadith 20.22.79

Yahya related to me from Malik, from Zayd ibn Aslam, that Ata ibn Yasar had told him, from Abu Qatada, the same hadith about the wild ass as that of Abu'n-Nadr, except that in the hadith of Zayd ibn Aslam the Messenger of Allah, may Allah bless him and grant him peace, said, "Do you still have any of its meat?"


Malik :: Hajj :: [20-20.22.80]

Hajj

Malik :: Book 20 : Hadith 20.22.80

Yahya related to me from Malik that Yahya ibn Said al-Ansari said that Muhammad ibn Ibrahim ibn al-Harith at-Taymi told him from Isa ibn Talha ibn Ubaydullah, fromUmayr ibn Salama ad-Damri, from al-Bahzi, that the Messenger of Allah, may Allah bless him and grant him peace, set out once for Makka while in ihram. When they had reached ar-Rawha, they unexpectedly came upon a wounded wild ass. Someone mentioned it to the Messenger of Allah, may Allah bless him and grant him peace, and hesaid, "Leave it. The man to whom it belongs is about to come." Then al-Bahzi, who was the man, came to the Prophet, may Allah bless him and grant him peace, and said, "Messenger of Allah, do whatever you want with this ass,' and the Messenger of Allah, may Allah bless him and grant him peace, told Abu Bakr to divide it up among the company. Then they went on until they came to the well of al-Uthaba, which was between ar-Ruwaytha and al-Arj (between Makka and Madina), where they unexpectedly came upon a gazelle with an arrow in it, Iying on its side in some shade. He claimed that the Messenger of Allah, may Allah bless him and grant him peace, told someone to stand by it to make sure no one disturbed it until everyone had passed by.


Malik :: Hajj :: [20-20.22.81]

Hajj

Malik :: Book 20 : Hadith 20.22.81

Yahya related to me from Malik, from Yahya ibn Said, that he heard Said ibn al-Musayyab relating from Abu Hurayra that he was once coming back from Bahrayn, and, when he reached ar-Rabadha, he found a caravan of people from Iraq in ihram, who asked him whether they could eat the meat of some game which they had found with the people of ar-Rabadha, and he told them they could eat it. He said, "Afterwards I had doubts about what I had told them to do, so when I got back to Madina I mentioned the matter to Umar ibn al-Khattab and he said, 'What did you tell them to do?' I said, ' I told them to eat it.' Umar ibn al-Khattab said, threatening me, 'If you had told them to do anything else I would have done something to you.' "


Malik :: Hajj :: [20-20.22.82]

Hajj

Malik :: Book 20 : Hadith 20.22.82

Yahya related to me from Malik, from Ibn Shihab, that Salim ibn Abdullah heard Abu Hurayra relating to Abdullah ibn Umar how a group of three people in ihram had passed him at ar-Rabadha and had asked him for a fatwa about eating game which people who were not in ihram were eating, and he told them that they could eat it. He said, "Then I went to Umar ibn al-Khattab in Madina and asked him about it, and he said, 'What did you say to them?' and I said, 'I told them that they could eat it.' Umar said, 'If you had told them anything else I would have done you an injury.' "


Malik :: Hajj :: [20-20.22.83]

Hajj

Malik :: Book 20 : Hadith 20.22.83

Yahya related to me from Malik, from Zayd ibn Aslam, from Ata ibn Yasar, that Kab al-Ahbar was once coming back from Syria with a group of riders, and at a certain point along the road they found some game-meat and Kab said they could eat it. When they got back to Madina they went to Umar ibn al-Khattab and told him about that, and he said, "Who told you you could do that?", and they said, ''Kab.'' He said, "He was indeed the one I made amir over you until you should return."

Later, when they were on the road to Makka, a swarm of locusts passed them by and Kab told them to catch them and eat them. When they got back to Umar ibn al-Khattab they told him about this, and he said (to Kab), "What made you tell them they could do that?" Kab said, "It is game of the sea." He said, "How do you know?", and Kab said, "Amir al-muminin, by the One in whose hand my self is, it is only the sneeze of a fish which it sneezes twice every year."

Malik was asked whether a muhrim could buy game that he had found on the way. He replied, "Game that is only hunted to be offered to people performing Hajj I disapprove of and forbid, but there is no harm in game that a man has which he does not intend for those in ihram, but which a muhrim finds and buys."

Malik said, about someone who had some game with him that he had hunted or bought at the time when he had entered into ihram, that he did not have to get rid of it, and that there was no harm in him giving it to his family.

Malik said that it was halal for some one in ihram to fish in the sea or in rivers and lakes, etc.


Malik :: Hajj :: [20-20.23.84]

Hajj

Malik :: Book 20 : Hadith 20.23.84

Yahya related to me from Malik, from Ibn Shihab, from Ubaydullah ibn Abdullah ibn Utba ibn Masud, from Abdullah ibn Abbas, that as-Sab ibn Jaththama al-Laythi once gave a wild ass to the Messenger of Allah, may Allah bless him and grant him peace, while he was at al-Abwa, or Waddan, and the Messenger of Allah, may Allah bless him and grant him peace, gave it back to him. However, when the Messenger of Allah, may Allah bless him and grant him peace, saw the expression on the man's face he said, "We only gave it back to you because we are in ihram."


Malik :: Hajj :: [20-20.23.85]

Hajj

Malik :: Book 20 : Hadith 20.23.85

Yahya related to me from Malik, from Abdullah ibn Abi Bakr, that Abd ar-Rahman ibn Amir ibn Rabia said, "I once saw Uthman ibn Affan in ihram on a hot summer's day at al-Arj,and he had covered his face with a red woollen cloth. Some game-meat was brought to him and he told his companions to eat. They said, 'Will you not eat then?', and he said, 'I am not in the same position as you. It was hunted for my sake.' "


Malik :: Hajj :: [20-20.23.86]

Hajj

Malik :: Book 20 : Hadith 20.23.86

Yahya related to me from Malik, from Hisham ibn Urwa, from his father, that A'isha, umm al-muminin, said to him, "Son of my sister, it is only for ten nights, so if you get an urge to do something, leave it," by which she meant eating game-meat.

Malik said that if game was hunted forthe sake of a man who is in ihram and it was prepared for him and he ate some of it knowing that it had been hunted for his sake, then he had to pay a forfeit for all of the game that had been hunted on his behalf.

Malik was asked about whether someone who was forced to eat carrion while he was in ihram should hunt game and then eat that rather than the carrion, and he said, "It is better for him to eat the carrion, because Allah, the Blessed and Exalted, has not given permission for someone in ihram to either eat game or take it in any situation, but He has made allowances for eating carrion when absolutely necessary."

Malik said, "It is not halal for anyone, whether in ihram or not, to eat game which has been killed or sacrificed by some one in ihram, because, whether it was killed deliberately or by mistake, it was not done in a halal manner, and so eating it is not halal. I have heard this from more than one person. Somebody who kills game and then eats it only has to make a single kaffara, which is the same as for somebody who kills game but does not eat any of it."


Malik :: Hajj :: [20-20.24.87]

Hajj

Malik :: Book 20 : Hadith 20.24.87

Malik said, "It is not halal to eat any game that has been hunted in the Haram, or has had a dog set after it in the Haram and then been killed outside the Haram. Anyone that does that has to pay a forfeit for what has been hunted. However, some one that sets his dog after game outside the Haram and then follows it until it is hunted down in the Haram does not have to pay any forfeit, unless he set the dog after the game near to the Haram. The game should not be eaten, however. If he set the dog loose near the Haram then he has to pay a forfeit for the game."


Malik :: Hajj :: [20-20.25.88]

Hajj

Malik :: Book 20 : Hadith 20.25.88

Malik said, "Allah, the Blessed and Exalted, says, 'O you who trust, do not kill game while you are in ihram. Whoever of you kills game intentionally has to pay a forfeit commensurate with what he has killed in cattle which two men from among you shall judge, a sacrificial animal which reaches the Kaba, or else he makes a kaffara of either feeding poor people or the equivalent of that in fasting, so that he may taste the consequences of what he has done.' " (Sura 5 ayat 95).

Malik said, "Someone who hunts game when he is not in ihram and then kills it while he is in ihram is in the same position as someone who buys game while he is in ihram and then kills it. Allah has forbidden killing it, and so a man who does so has to pay a forfeit for it. The position that we go by in this matter is that a forfeit is assessed for anyone who kills game while he is in ihram."

Yahya said that Malik said, "The best that I have heard about someone who kills game and is assessed for it is that the game which he has killed is assessed and its value in food is estimated and with that food he feeds each poor man a mudd, or fasts a day in place of each mudd. The number of poor men is considered, and if it is ten then he fasts ten days, and if it is twenty he fasts twenty days, according to how many people there are to be fed, even if there are more than sixty."

Malik said, "I have heard that a forfeit is assessed for someone who kills game in the Haram while he is not in ihram in the same way that it is assessed for some one who kills game in the Haram while he is in ihram ."


Malik :: Hajj :: [20-20.26.89]

Hajj

Malik :: Book 20 : Hadith 20.26.89

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "There are five kinds of animal which it is not wrong for some one in ihram to kill: crows, kites, scorpions, rats and mice, and wild dogs."


Malik :: Hajj :: [20-20.26.90]

Hajj

Malik :: Book 20 : Hadith 20.26.90

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace,said,"There are five (kinds of) animal which it is not wrong for some one in ihram to kill: scorpions, rats and mice, crows, kites and wild dogs. "


Malik :: Hajj :: [20-20.26.91]

Hajj

Malik :: Book 20 : Hadith 20.26.91

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "There are five trespassers that can be killed in the Haram: rats and mice, scorpions, crows, kites and wild dogs."


Malik :: Hajj :: [20-20.26.92]

Hajj

Malik :: Book 20 : Hadith 20.26.92

Yahya related to me from Malik from Ibn Shihab that Umar ibn al-Khattab told people to kill snakes in the Haram.

Malik said, about the "wild dogs" which people were told to kill in the Haram, that any animals that wounded, attacked, or terrorised men, such as lions, leopards, Iynxes and wolves, were counted as"wild dogs." However, someone who was in ihram should not kill beasts of prey that did not attack (people), such as hyenas, foxes, cats and anything else like them, and if he did then he had to pay a forfeit for it. Similarly, someone in ihram should not kill any predatory birds except the kinds that the Prophet, may Allah bless him and grant him peace, specified, namely crows and kites. If someone in ihram killed any other kind of bird he had to pay a forfeit for it.


Malik :: Hajj :: [20-20.27.93]

Hajj

Malik :: Book 20 : Hadith 20.27.93

Yahya related to me from Yahya ibn Said from Muhammad ibn Ibrahim ibn alHarith at-Taymi from Rabia ibn Abi Abdullah ibn alHudayr that he saw Umar ibn al-Khattab taking the ticks off a camel of his at as-Suqya while he was in ihram .

Malik said that he disapproved of that.


Malik :: Hajj :: [20-20.27.94]

Hajj

Malik :: Book 20 : Hadith 20.27.94

Yahya related to me from Malik from Alqama ibn Abi Alqama that his mother said, "I heard A'isha, the wife of the Prophet, may Allah bless him and grant him peace, being asked whether some one in ihram could scratch their body or not, and she said, 'Yes, he can scratch it and do so as hard as he pleases. I would scratch even if my hands were tied and I could only use my feet.' "


Malik :: Hajj :: [20-20.27.95]

Hajj

Malik :: Book 20 : Hadith 20.27.95

Yahya related to me from Malik from Ayyub ibn Musa that Abdullah ibn Umar once looked in the mirror for something that was irritating him while he was in ihram.


Malik :: Hajj :: [20-20.27.96]

Hajj

Malik :: Book 20 : Hadith 20.27.96

Yahya related to me from Malik from Nafi that Abdullah ibn Umar did not like people who were in ihram removing mites or ticks from their camels.

Malik said, "This is what I like most out of what I have heard about the matter."


Malik :: Hajj :: [20-20.27.97]

Hajj

Malik :: Book 20 : Hadith 20.27.97

Yahya related to me from Malik that Muhammad ibn Abdullah ibn Abi Maryam once asked Said ibn al-Musayyab about (what to do with) a nail of his that had broken while he was in ihram and Said said, "cut it off."

Malik was asked whether some one in ihram who had an ear-complaint could use medicinal oil which was not perfumed for dropping into his ears, and he said, "I do not see any harm in that, and even if he were to put it into his mouth I still would not see any harm in it."

Malik said that there was no harm in some one in ihram lancing an abscess that he had, or a boil, or cutting a vein, if he needed to do so.


Malik :: Hajj :: [20-20.28.98]

Hajj

Malik :: Book 20 : Hadith 20.28.98

Yahya related to me from Malik from Ibn Shihab from Sulayman ibn Yasar that Abdullah ibn Abbas said, "Al-Fadl ibn Abbas was riding behind the Messenger of Allah, may Allah bless him and grant him peace, when a woman from the Khathama tribe came to him to ask him for a fatwa. Al-Fadl began to look at her, and she at him, and the Messenger of Allah, may Allah bless him and grant him peace, turned Fadl's face away to the other side. The woman said, 'Messenger of Allah, Allah's making the hajj obligatory finds my father a very old man, unable to stay firm on his riding-beast. Can I do hajj for him?', and he said, 'Yes.' This was during the farewell hajj."


Malik :: Hajj :: [20-20.29.99]

Hajj

Malik :: Book 20 : Hadith 20.29.99

Yahya related to me that Malik said, "Someone whose passage to the House is blocked by an enemy is freed from every restriction of ihram, and should sacrifice his animal and shave his head wherever he has been detained, and there is nothing for him to make up afterwards."

Yahya related to me from Malik that he had heard that when the Messenger of Allah, may Allah bless him and grant him peace, and his companions came out of ihram at al-Hudaybiya they sacrificed their sacrificial animals and shaved their heads, and were freed from all the restrictions of ihram without having done tawaf of the House and without their sacrificial animals reaching the Kaba.

There is nothing known about the Messenger of Allah, may Allah bless him and grant him peace, ever telling any of his companions, or anybody else that was with him, to make up for anything they had missed or to go back to doing anything they had not finished doing.


Malik :: Hajj :: [20-20.29.100]

Hajj

Malik :: Book 20 : Hadith 20.29.100

Yahya related to me from Malik from Nafi that when Abdullah ibn Umar set out for Makka during the troubles (between al-Hajjaj ibn Yusuf and Zubair ibn al-Awwam) he said, "If I am blocked from going to the House we shall do what we did when we were with the Messenger of Allah, may Allah bless him and grant him peace," and he went into ihram for umra, because that was what the Messenger of Allah, may Allah bless him and grant him peace, did in the year of al-Hudaybiya.

But afterwards, he reconsidered his position and said, "It is the same either way." After that he turned to his companions and said, "It is the same either way. I call you to witness that I have decided in favour of hajj and umra together."

He then got through to the House (without being stopped) and did one set of tawaf, which he considered to be enough for himself, and sacrificed an animal.

Malik said, "This is what we go by if someone is hindered by an enemy, as the Prophet, may Allah bless him and grant him peace, and his companions were. If some one is hindered by anything other than an enemy, he is only freed from ihram by tawaf of the House. "


Malik :: Hajj :: [20-20.30.101]

Hajj

Malik :: Book 20 : Hadith 20.30.101

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar said, "Someone who is held back from going to the House by illness can only come out of ihram after he has done tawaf of the House and say between Safa and Marwa. If it is absolutely necessary for him to wear any ordinary clothes, or undergo medical treatment, he should do that and pay compensation for it."


Malik :: Hajj :: [20-20.30.102]

Hajj

Malik :: Book 20 : Hadith 20.30.102

Yahya related to me from Malik from Yahya ibn Said that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, used to say, "Only the House frees a person in ihram from ihram."


Malik :: Hajj :: [20-20.30.103]

Hajj

Malik :: Book 20 : Hadith 20.30.103

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani that a very old man from Basra once said to him, "I set out for Makka but on the way there I broke my thigh, so I sent a message on to Makka Abdullah ibn Abbas and Abdullah ibn Umar and the people were there, but no-one allowed me to leave ihram, and I stayed there for seven months until I left ihram by doing an umra.''


Malik :: Hajj :: [20-20.30.104]

Hajj

Malik :: Book 20 : Hadith 20.30.104

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar said, "Some one who is detained by sickness before he has got to the House cannot leave ihram until he has done tawaf of the House and say between Safa and Marwa."

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Said ibn Huzaba al-Makhzumi was thrown off his mount while he was in ihram on the road to Makka. He asked after the person in charge of the relay station where he was injured and he found Abdullah ibn Umar, Abdullah ibn az-Zubayr and Marwan ibn al-Hakam there. He told them what had happened to him and all of them said that he should take whatever medicine he had to take and pay compensation for it. Then, when he got better again, he should do umra and come out of his ihram, after which he had to do hajj another year and to offer whatever sacrificial animal he was able to in the future.

Malik said, "This is what we do here (in Madina) if someone is detained by something other than an enemy. And when Abu Ayyub al-Ansari and Habbar ibn al-Aswad came to the day of the sacrifice and had missed the hajj, Umar ibn al-Khattab told them to come out of ihram by doing umra and then to go home free of ihram and do hajj some time in the future and to sacrifice an animal, or, if they could not find one, to fast three days during the hajj and seven days after they had returned to their families."

Malik said, "Anyone who is detained from doing hajj after he has gone into ihram, whether by illness or otherwise, or by an error in calculating the month or because the new moon is concealed from him is in the same position as some one who is hindered from doing the hajj and must do the same as he does."

Yahya said that Malik was asked about the situation of someone from Makka who went into ihram for hajj and then broke a bone or had severe stomach pain, or of a woman who was in labour, and he said, "Someone to whom this happens is in the same situation as one who is hindered from doing the hajj, and he must do the same as people from outlying regions do when they are hindered from doing the hajj."

Malik said, about someone who arrived in the months of the hajj with the intention of doing umra, and completed his umra and went into ihram in Makka to do hajj, and then broke a bone or something else happened to him which stopped him from being present at Arafa with everybody else, "I think that he should stay where he is until he is better and then go outside the area of the Haram, and then return to Makka and do tawaf of the House and say between Safa and Marwa, and then leave ihram. He must then do hajj again another year and offer a sacrificial animal ."

Malik said, about someone who left ihram in Makka, and then did tawaf of the House and say between Safa and Marwa, and then fell ill and was unable to be present with everybody at Arafa, "If the hajj passes someone by he should, if he can, go out of the area of the Haram and then come back in again to do umra and do tawaf of the House and say between Safa and Marwa, because he had not intended his initial tawaf to be for an umra, and so for this reason he does it again. He must do the next hajj and offer a sacrificial animal.

If he is not one of the people of Makka, and something happens to him which stops him from doing the hajj, but he does tawaf of the House and say between Safa and Marwa, he should come out of ihram by doing an umra and then do tawaf of the House a second time, and say between Safa and Marwa, because his initial tawaf and say were intended for the hajj. He must do the next hajj and offer a sacrificial animal."


Malik :: Hajj :: [20-20.31.105]

Hajj

Malik :: Book 20 : Hadith 20.31.105

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Muhammad ibn Abi Bakras-Siddiq told Abdullah ibn Umar from A'isha, that the Prophet, may Allah bless him and grant him peace, said, "Don't you see that when your people built the Kaba they fell short of the foundations of Ibrahim?" A'isha said, "Messenger of Allah, won't you return it to the foundations of Ibrahim?" and the Messenger of Allah, may Allah bless him and grant him peace, said, "If it were not that your people have only recently left kufr, I would have done so."

Salim ibn Abdullah said that Abdullah ibn Umar said, "If A'isha heard this from the Messenger of Allah, may Allah bless him and grant him peace, then I consider that the Messenger of Allah, may Allah bless him and grant him peace, only refrained from greeting the two corners which are adjacent to the Hijr because the House had not been completed on the foundations of Ibrahim." (i.e. the corners he did not touch were not the original corners of the Kaba) .


Malik :: Hajj :: [20-20.31.106]

Hajj

Malik :: Book 20 : Hadith 20.31.106

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin, said, "I do not mind whether I pray in the Hijr or in the House." (i.e. praying in the Hijr is the same as praying in the House).


Malik :: Hajj :: [20-20.31.107]

Hajj

Malik :: Book 20 : Hadith 20.31.107

Yahya related to me from Malik that he heard Ibn Shihab say that he had heard one of the people of knowledge say that the Hijr was only enclosed so that people would go beyond it as they were making tawaf, and their tawaf would therefore encompass the original House.


Malik :: Hajj :: [20-20.32.108]

Hajj

Malik :: Book 20 : Hadith 20.32.108

Yahya related to me from Malik from Jafar ibn Muhammad from his father that Jabir ibn Abdullah said, "I saw the Messenger of Allah, may Allah bless him and grant him peace, hastening from the Black Stone until he reached it again, three times."

Malik said, "This is what is still done by the people of knowledge in our city."


Malik :: Hajj :: [20-20.32.109]

Hajj

Malik :: Book 20 : Hadith 20.32.109

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to hasten from the Black Stone round to the Black Stone three times and then would walk four circuits normally.


Malik :: Hajj :: [20-20.32.110]

Hajj

Malik :: Book 20 : Hadith 20.32.110

Yahya related to me from Malik from Hisham ibn Urwa that when his father did tawaf of the House he would hasten in the first three circuits and say in a low voice, "O Allah, there is no god but You, and You bring to life after You have made to die."

Allahumma la ilaha illa anta, wa anta tuhyi badama amatta.


Malik :: Hajj :: [20-20.32.111]

Hajj

Malik :: Book 20 : Hadith 20.32.111

Yahya related to me from Malik from Hisham ibn Urwa from his father that he saw Abdullah ibn az-Zubayr go into ihram for umra at at-Tanim.

He said, "Then I saw him hasten around the House for three circuits."


Malik :: Hajj :: [20-20.32.112]

Hajj

Malik :: Book 20 : Hadith 20.32.112

Yahya related to me from Malik from Nafi that Abdullah ibn Umar never used to do tawaf of the House or say between Safa and Marwa if he went into ihram in Makka until he had returned from Mina, nor would he hasten when doing tawaf of the House if he went into ihram in Makka.


Malik :: Hajj :: [20-20.33.113]

Hajj

Malik :: Book 20 : Hadith 20.33.113

Yahya related to me from Malik that he had heard that when the Messenger of Allah, may Allah bless him and grant him peace, had finished his tawaf of the House, prayed two rakas, and wanted to go to Safa and Marwa, he would salute the corner of the Black Stone before he left.


Malik :: Hajj :: [20-20.33.114]

Hajj

Malik :: Book 20 : Hadith 20.33.114

Yahya related to me from Malik from Hisham ibn Urwa that his father said that the Messenger of Allah, may Allah bless him and grant him peace, once said to Abd ar-Rahman ibn Awf, "What do you do, Abu Muhammad, when saluting the corner?" and Abd ar-Rahman said, "Sometimes I salute it, and sometimes I don't." The Messenger of Allah, may Allah bless him and grant him peace, said, "You are right."


Malik :: Hajj :: [20-20.33.115]

Hajj

Malik :: Book 20 : Hadith 20.33.115

Yahya related to me from Malik from Hisham ibn Urwa that his father used to salute all the corners when he did tawaf of the House and did not omit the Yamani corner unless he was prevented from it.


Malik :: Hajj :: [20-20.34.116]

Hajj

Malik :: Book 20 : Hadith 20.34.116

Yahya related to me from Malik from Hisham ibn Urwa from his father that Umar ibn al-Khattab said to the corner of the Black Stone while he was doing tawaf of the House, "You are only a stone, and if I had not seen the Messenger of Allah, may Allah bless him and grant him peace, kiss you, I would not do so." Then he kissed it.

Malik said, "I have heard some of the people of knowledge recommending someone doing tawaf of the House to put his hand to his mouth when he takes it from the Yamani corner."


Malik :: Hajj :: [20-20.35.117]

Hajj

Malik :: Book 20 : Hadith 20.35.117

Yahya related to me from Malik from Hisham ibn Urwa that his father would never do two sets of seven tawafs together without praying between them. After every seven tawafs he would pray two rakas, sometimes at the maqam of Ibrahim, and sometimes elsewhere.

Malik was asked whether a man doing voluntary tawaf could, to make it easier on himself, join two or more sets of seven circuits and then pray whatever he owed for those sets of seven, and he said, "He should not do that. The sunna is that he does two rakasafter every seven circuits."

Malik said, about someone who began doing tawaf and then forgot how many he had done and did eightor nine circuits, "He should stop when he knows that he has done more than the right number and then pray two rakas,and he should not count the ones that he has done in excess. Neither should he build on the nine that he has done and then pray the rakas for the two sets of seven circuits together, because the sunna is that you pray two rakas after every seven circuits."

Malik said that someone who was in doubt about his tawaf after he had prayed the two rakas of tawaf should go back and complete his tawaf until he was certain of how much he had done. He should then repeat the two rakas, because prayer when doing tawaf was only valid after completing seven circuits.

"If some one breaks his wudu either while he is doing tawaf, or when he has finished tawaf but before he has prayed the two rakas of tawaf, he should do wudu and begin the tawaf and the two rakas afresh. Breaking wudu does not interrupt say between Safa and Marwa, but a person should not begin say unless he is pure by being in wudu."


Malik :: Hajj :: [20-20.36.118]

Hajj

Malik :: Book 20 : Hadith 20.36.118

Yahya related to me from Malik from Ibn Shihab from Humayd ibn Abd ar-Rahman ibn Awf that Abd ar-Rahman ibn Abd al-Qari mentioned to him that he once did tawaf of the House with Umar ibn al-Khattab after subh and when Umar had finished his tawaf he looked and saw that the sun had not yet risen, so he rode on until he made his camel kneel at Dhu Tuwa, and he prayed two rakas.


Malik :: Hajj :: [20-20.36.119]

Hajj

Malik :: Book 20 : Hadith 20.36.119

Yahya related to me from Malik that Abu'z Zubayr al-Makki said, "I saw Abdullah ibn Abbas doing tawaf after asr. Then he went into his room and I do not know what he did."


Malik :: Hajj :: [20-20.36.120]

Hajj

Malik :: Book 20 : Hadith 20.36.120

Yahya related to me from Malik that Abu'z-Zubayr al-Makki said, "I saw the House deserted both after subh and asr, with no-one doing tawaf."

Malik said, "If someone does some of his circuits and then the subh or asr prayer is begun, he should pray with the imam and then complete the rest of his circuits but should not pray at all until the sun has either risen or set "

He added, "There is no harm in delaying the two rakas until after he has prayed maghrib."

Malik said, "There is no harm in someone doing a single tawaf after subh or after asr, not to do more than one group of seven circuits, and then as long as he delays the two rakas until after the sun has risen, as Umar ibn al-Khattab did, or he delays them until after the sun has set if it is after asr. Then when the sun has set he can pray them if he wants, or, if he wants, he can delay them until after he has prayed maghrib. There is no harm in that."


Malik :: Hajj :: [20-20.37.121]

Hajj

Malik :: Book 20 : Hadith 20.37.121

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab said, "No-one should leave the hajj until he has done tawaf of the House, and tawaf of the House is the final rite."

Malik said, commenting about Umar ibn al-Khattab's saying 'tawaf of the House is the final rite,' "In our opinion, and Allah knows best, that is because Allah, the Blessed and Exalted, says, 'Whoever exalts the rituals of Allah - that is from the taqwa of the hearts' (Sura 22 ayat 32), and He says, 'Then their halal place (of sacrifice) is at the Ancient House,' and the place of all the rituals and where they end is therefore at the Ancient House."


Malik :: Hajj :: [20-20.37.122]

Hajj

Malik :: Book 20 : Hadith 20.37.122

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab refused to let one man who had not taken leave of the House pass adh-Dhahran, (a valley eighteen miles from Makka) until he had taken leave of it.


Malik :: Hajj :: [20-20.37.123]

Hajj

Malik :: Book 20 : Hadith 20.37.123

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "Allah has completed the hajj of anyone who does the tawaf al-ifada. It is fitting that tawaf of the House be the last of his contract, as long as nothing prevents him, and if something prevents him, or an obstacle arises, then Allah has completed his hajj."

Malik said, "I do not think that a man who does not know that the last of his contract is tawaf of the House until he has left owes anything, unless he is nearby and can return, do tawaf, and then leave having done the tawaf al-ifada."


Malik :: Hajj :: [20-20.38.124]

Hajj

Malik :: Book 20 : Hadith 20.38.124

Yahya related to me from Malik from Abu'l-Aswad Muhammad ibn Abd ar-Rahman ibn Nawfal from Urwa ibn az-Zubayr from Zaynab bint Abi Salama that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said, "I once complained to the Messenger of Allah, may Allah bless him and grant him peace, that I was ill and he said, 'Do tawaf riding behind the people.' So I did tawaf riding my camel, while the Messenger of Allah, may Allah bless him and grant him peace, was praying by the side of the House, reciting Surat at-Tur."


Malik :: Hajj :: [20-20.38.125]

Hajj

Malik :: Book 20 : Hadith 20.38.125

Yahya related to me from Malik from Abu'z Zubayr al-Makki that Abu Maiz al-Aslami Abdullah ibn Sufyan told him that once, when he was sitting with Abdullah ibn Umar, a woman came to ask him for an opinion. She said, "I set out intending to do tawaf of the House, but then, when I got to the gate of the Mosque, I started bleeding, so I went back until it had left me. Then I set out again, and then, when I got to the gate of the mosque, I started bleeding, so I went back until it had left me. Then I set off again, and then, when I got to the gate of the mosque, I started bleeding." Abdullah ibn Umar said, "That is only an impulse from Shaytan. Do ghusl, then bind your private parts with a cloth and do tawaf."


Malik :: Hajj :: [20-20.38.126]

Hajj

Malik :: Book 20 : Hadith 20.38.126

Yahya related to me from Malik that he had heard that if Sad ibn Abi Waqqas entered Makka late, he would go to Arafa before doing tawaf of the House and say between Safa and Marwa, and then do tawaf when he got back.

Malik said, "The leeway is broad, if Allah wills."

Malik was asked whether somebody that was doing obligatory tawaf could stop and talk with another man, and he said, "I do not like him to do that."

Malik said, "Only someone who is pure (by being in wudu) should do tawaf of the House or say between Safa and Marwa."


Malik :: Hajj :: [20-20.39.127]

Hajj

Malik :: Book 20 : Hadith 20.39.127

Yahya related to me from Malik from Jafar ibn Muhammad ibn AIi from his father that Jabir ibn Abdullah said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say as he left the mosque, intending to go to Safa, 'We begin with that with which Allah began,' and he began with Safa."


Malik :: Hajj :: [20-20.39.128]

Hajj

Malik :: Book 20 : Hadith 20.39.128

Yahya related to me from Malik from Jafar ibn Muhammed ibn AIi from his father from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, used to say, "Allah is greater" three times when he stopped on Safa, and "There is no god but Allah, alone, without any partner. To Him belong the Kingdom and praise, and He has power over everything" three times, and make dua. He would then do the same on Marwa.


Malik :: Hajj :: [20-20.39.129]

Hajj

Malik :: Book 20 : Hadith 20.39.129

Yahya related to me from Malik from Nafi that he heard Abdullah ibn Umar making dua on Safa saying, "O Allah, You have said, 'call on Me - I will answer you' and You do not break Your promise. So I am askingYou, in the same way that You have guided me to Islam, not to take it away from me, and that You make me die while I am muslim."


Malik :: Hajj :: [20-20.40.130]

Hajj

Malik :: Book 20 : Hadith 20.40.130

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "Once when I was young I said to A'isha, umm al-muminin, 'Have you seen the saying of Allah, the Blessed and Exalted, "Safa and Marwa are among the waymarks of Allah, so whoever does hajj or umra to the House, there is no harm in his going between them," so it follows that there should be no harm for some one who does not go between them.'

A'isha said, 'No. If it were as you say, there would be no harm in his not going between them. This ayat was only revealed about the Ansar. They used to make pilgrimage to Manat, and Manat was an idol near Qudayd, and they used to avoid going between Safa and Marwa, and when Islam came they asked the Messenger of Allah, may Allah bless him and grant him peace, about this and Allah, the Blessed and Exalted, revealed, "Safa and Marwa are among the waymarks of Allah, so whoever does hajj or umra to the House, there is no harm in his going between them. " ' "


Malik :: Hajj :: [20-20.40.131]

Hajj

Malik :: Book 20 : Hadith 20.40.131

Yahya related to me from Malik from Hisham ibn Urwa that Sawda bint Abdullah ibn Umar, who was in the household of Urwa ibn az-Zubayr, set off walking between Safa and Marwa when doing either hajj or an umra. She was a heavy woman and she began when everybody was leaving after the isha prayer, and she still had not completed her circuits when the first call was given for subh, but finished them between the two calls to prayer.

If Urwa saw people doing circuits on riding beasts he would tell them in very strong terms not to do so, and they would pretend to be ill, out of awe of him.

Hisham added, "He used to say to us about them 'These are unsuccessful and have lost.' "

Malik said, "Someone who forgets say between Safa and Marwa in an umra, and does not remember until he is far from Makka, should return and do say. If, in the meantime, he has had intercourse with a woman, he should return and do say between Safa and Marwa so as to complete what remains of that umra, and then after that he has to do another umra and offer a sacrificial animal."

Malik was asked about someone who met another man when doing say between Safa and Marwa and stopped to talk with him, and he said, "I do not like anyone to do that."

Malik said, "If anyone forgets some of his tawaf or is uncertain about it and remembers only when he is doing say between Safa and Marwa, he should stop the say and complete his tawaf of the House apart from that about which he is certain. After that he prays the two rakas of the tawaf, and then begins his say between Safa and Marwa."


Malik :: Hajj :: [20-20.40.132]

Hajj

Malik :: Book 20 : Hadith 20.40.132

Yahya related to me from Malik from Jafar ibn Muhammad from his father from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, walked when he came down from Safa and Marwa and then, when he reached the middle of the valley, he broke into a light run until he had left it.

Malik said, about a man who, out of ignorance, did the say between Safa and Marwa before he had done tawaf of the House, "He should go back and do tawaf of the House and then do say between Safa and Marwa. If he does not learn about this until he has left Makka and is far away, he should return to Makka and do tawaf of the House and say between Safa and Marwa. If in the meantime he has had intercourse with a woman he should return, and do tawaf of the House and say between Safa and Marwa so that he completes what he owes of that umra. Then, after that, he has to do another umra and offer a sacrificial animal ."


Malik :: Hajj :: [20-20.41.133]

Hajj

Malik :: Book 20 : Hadith 20.41.133

Yahya related to me from Malik from Abu'n Nadr, the mawla of Umar ibn Ubaydullah, from Umayr, the mawla of Abdullah ibn Abbas, from Umm al-Fadl bint al-Harith, that she was present when some people were arguing on the day of Arafa about whether the Messenger of Allah, may Allah bless him and grant him peace, was fasting or not. Some of them said he was fasting, and some of them said he was not. So she sent a bowl of milk to him while his camel was standing still and he drank.


Malik :: Hajj :: [20-20.41.134]

Hajj

Malik :: Book 20 : Hadith 20.41.134

Yahya related to me from Malik from Yahya ibn Said from al-Qasim ibn Muhammad that A'isha, umm al-muminin, used to fast on the day of Arafa .

Al-Qasim said, "I saw her, when the imam began moving away (after sunset) on the afternoon of Arafa, stay where she was until the ground between her and the people became clear. Then she asked for something to drink and broke her fast."


Malik :: Hajj :: [20-20.42.135]

Hajj

Malik :: Book 20 : Hadith 20.42.135

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah, from Sulayman ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, forbade fasting on the days of Mina.


Malik :: Hajj :: [20-20.42.136]

Hajj

Malik :: Book 20 : Hadith 20.42.136

Yahya related to me from Malik from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, sent Abdullah ibn Hudhayfa out on the days of Mina to circulate among the people to tell them those days were for eating and drinking and remembrance of Allah.


Malik :: Hajj :: [20-20.42.137]

Hajj

Malik :: Book 20 : Hadith 20.42.137

Yahya related to me from Malik from Muhammad ibn Yahya ibn Habban from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, forbade fasting on two days - the day of the Id al-Fitr and the day of the Id al-Adha.


Malik :: Hajj :: [20-20.42.138]

Hajj

Malik :: Book 20 : Hadith 20.42.138

Yahya related to me from Malik from Yazid ibn Abdullah ibn al-Hadi from Abu Murra, the mawla of Umm Hani, the sister of Aqil ibn Abi Talib, that Abdullah ibn Amr ibn al-As told him that he had visited his father Amr ibn al-As and found him eating. His father had invited him to eat, and when he replied that he was fasting, his father said, "These are the days on which the Messenger of Allah, may Allah bless him and grant him peace, forbade us to fast, and told us to break the fast on them."

Malik said, "These days are the days of tashriq."


Malik :: Hajj :: [20-20.43.139]

Hajj

Malik :: Book 20 : Hadith 20.43.139

Yahya related to me from Malik from Nafi from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm that the Messenger of Allah, may Allah bless him and grant him peace, sacrificed a camel, which had belonged to Abu Jahl ibn Hisham, in either a hajj or an umra.


Malik :: Hajj :: [20-20.43.140]

Hajj

Malik :: Book 20 : Hadith 20.43.140

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, saw a man driving forward a camel which he was going to sacrifice, and he told him to ride it. The man said, "Messenger of Allah, it is an animal that I am going to sacrifice," and he replied, "Ride it, woe on you," either the second or the third time.


Malik :: Hajj :: [20-20.43.141]

Hajj

Malik :: Book 20 : Hadith 20.43.141

Yahya related to me from Malik from Abdullah ibn Dinar that he used to see Abdullah ibn Umar sacrificing animals two at a time during hajj and one at a time during umra. He said, "I saw him sacrifice an animal during an umra outside the house of Khalid ibn Usayd, where he was staying. I saw him stick his spear in the throat of the animal he was going to sacrifice until the spear came out under its shoulder."'


Malik :: Hajj :: [20-20.43.142]

Hajj

Malik :: Book 20 : Hadith 20.43.142

Yahya related to me from Malik from Yahya ibn Said that Umar ibn Abd al-Aziz once sacrificed a camel during a hajj or an umra.


Malik :: Hajj :: [20-20.43.143]

Hajj

Malik :: Book 20 : Hadith 20.43.143

Yahya related to me from Malik from Abu Jafar al-Qari that Abdullah ibn Ayyash ibn Abi Rabia al-Makhzumi sacrificed two camels, one of them a Bactrian.


Malik :: Hajj :: [20-20.43.144]

Hajj

Malik :: Book 20 : Hadith 20.43.144

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "If a she-camel that is being driven as a sacrificial animal gives birth, the offspring should be carried along as well and they are sacrificed together with her, and if there is no place where they can be carried, they should be carried on the mother until they are all sacrificed."


Malik :: Hajj :: [20-20.43.145]

Hajj

Malik :: Book 20 : Hadith 20.43.145

ahya related to me from Malik from Hisham ibn Urwa that his father said, "If necessary, ride on your sacrificial animal, without burdening it, and if necessary, drink its milk after its young one has drunk its fill, and when you sacrifice it, sacrifice the young one with it."


Malik :: Hajj :: [20-20.44.146]

Hajj

Malik :: Book 20 : Hadith 20.44.146

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that when he brought an animal to be sacrificed from Madina he would garland it and brand it at Dhu'l-Hulayfa, doing the garlanding before the branding, but doing both in the same place, while facing the qibla. He would garland the animal with two sandals and brand it on its left side. It would then be driven with him until he observed the standing together with everybody at Arafa. Then he would drive it on with him when everybody else moved on, and then when he arrived at Mina on the morning of the sacrifice, he would sacrifice the animal, before he shaved his head. He would sacrifice the animals with his own hands ,lining them up standing and facing the qibla. He would then eat some of the meat, and give some of it away.


Malik :: Hajj :: [20-20.44.147]

Hajj

Malik :: Book 20 : Hadith 20.44.147

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, when nicking the hump of his sacrificial animal to brand it, "In the name of Allah, and Allah is greater."


Malik :: Hajj :: [20-20.44.148]

Hajj

Malik :: Book 20 : Hadith 20.44.148

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "A sacrificial animal is what has been garlanded, branded, and stood with on Arafa."


Malik :: Hajj :: [20-20.44.149]

Hajj

Malik :: Book 20 : Hadith 20.44.149

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to drape his sacrificial animals in fine Egyptian linen, saddlecloths and sets of clothing, which he would afterwards send to the Kaba and have the Kaba draped with them.


Malik :: Hajj :: [20-20.44.150]

Hajj

Malik :: Book 20 : Hadith 20.44.150

Yahya related to me from Malik that he asked Abdullah ibn Dinar what Abdullah ibn Umar used to do with the drapings of his animals when the Kaba began to be draped with the kiswa, and he said, "He gave them away as sadaqa."


Malik :: Hajj :: [20-20.44.151]

Hajj

Malik :: Book 20 : Hadith 20.44.151

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, about sacrificial animals, "Six-year-old camels, three-year-old cows and sheep, or older than these."


Malik :: Hajj :: [20-20.44.152]

Hajj

Malik :: Book 20 : Hadith 20.44.152

Yahya related to me from Malik from Nafi that Abdullah ibn Umar never used to tear the drapes of his sacrificial animals, and he would not drape them until he went from Mina to Arafa.


Malik :: Hajj :: [20-20.44.153]

Hajj

Malik :: Book 20 : Hadith 20.44.153

Yahya related to me from Malik from Hisham ibn Urwa that his father used to say to his sons, "My sons, let none of you sacrifice any animal which he would be ashamed to sacrifice for a noble woman, for surely Allah is the noblest of noble ones, and the most deserving of those for whom things are chosen."


Malik :: Hajj :: [20-20.45.154]

Hajj

Malik :: Book 20 : Hadith 20.45.154

Yahya related to me from Malik from Hisham ibn Urwa from his father that the man who was in charge of the sacrificial animal of the Messenger of Allah, may Allah bless him and grant him peace, said, "Messenger of Allah, what should I do with a sacrificial animal that gets injured?" The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Slaughter any sacrificial animal that is injured. Then throw the garlands in its blood, and then give the people a free hand in eating it.


Malik :: Hajj :: [20-20.45.155]

Hajj

Malik :: Book 20 : Hadith 20.45.155

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "If someone dedicates an animal voluntarily and then it is injured and he kills it and gives everyone a free hand in eating it, he owes nothing. If, however, he eats some of it himself, or tells certain other people to eat it, then he owes compensation."


Malik :: Hajj :: [20-20.45.156]

Hajj

Malik :: Book 20 : Hadith 20.45.156

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili from Abdullah ibn Abbas the same as that.


Malik :: Hajj :: [20-20.45.157]

Hajj

Malik :: Book 20 : Hadith 20.45.157

Yahya related to me from Malik that Ibn Shihab said, "If someone dedicates an animal as compensation, or for a vow, or as the sacrifice for tamattu, and misfortune befalls it on the road, he must provide a substitute."


Malik :: Hajj :: [20-20.45.158]

Hajj

Malik :: Book 20 : Hadith 20.45.158

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "If someone dedicates an animal and then it goes astray or dies, he should provide a substitute, if it was for a vow. If, however, it was voluntary, then he can either provide a substitute for it or not, as he wishes."


Malik :: Hajj :: [20-20.45.159]

Hajj

Malik :: Book 20 : Hadith 20.45.159

Yahya related to me from Malik that he had heard the people of knowledge say, "Someone who dedicates a sacrificial animal for compensation or as part of the hajj should not eat from it."


Malik :: Hajj :: [20-20.46.160]

Hajj

Malik :: Book 20 : Hadith 20.46.160

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab and AIi ibn Abi Talib and Abu Hurayra were asked about a man who had intercourse with his wife while he was in ihram on hajj. They said, "The two of them should carry on and complete their hajj. Then they must do hajj again in another year, and sacrifice an animal."

Malik added that AIi ibn Abi Talib said, "When they then go into ihram for hajj in a future year they should keep apart until they have completed their hajj."


Malik :: Hajj :: [20-20.46.161]

Hajj

Malik :: Book 20 : Hadith 20.46.161

Yahya related to me from Malik from Yahya ibn Said that he heard Said ibn al-Musayyab asking a group of people, "What do you think about someone who has intercourse with his wife while he is in ihram?" and none of them answered him. Said said, "There is a man who has had intercourse with his wife while in ihram who has sent a message to Madina asking about it." Some of them said, "They should be kept apart until a future year," and Said ibn al-Musayyab said, "They should carry on and complete the hajj which they have spoiled, and then return home when they have finished. If another hajj comes upon them, they must do hajj and sacrifice an animal. They should go into ihram at the same place where they went into ihram for the hajj that they spoiled, and they should keep apart until they have finished their hajj."

Malik said, "They should both sacrifice an animal."

Malik said, about a man who had intercourse with his wife during hajj after he had come down from Arafa but before he had stoned the Jamra, "He must sacrifice an animal and do hajj again in another year. If, however, he had intercourse with his wife after he stoned the Jamra, he only has to do an umra and sacrifice an animal and he does not have to do another hajj."

Malik said, "What spoils a hajj or an umra and makes sacrificing an animal and repeating the hajj necessary is the meeting of the two circumcised parts, even if there is no emission. It is also made necessary by an emission if it is the result of bodily contact. I do not think that a man who remembers something and has an emission owes anything, and if a man were to kiss his wife and no emission were to occur from that, he would only have to sacrifice an animal. A woman in ihram who has intercourse with her husband several times during hajj or umra out of obedience to him only has to do another hajj and sacrifice an animal. That is if her husband has intercourse with her while she is doing hajj. If he has intercourse with her while she is doing umra, she must repeat the umra she has spoiled and sacrifice an animal."


Malik :: Hajj :: [20-20.47.162]

Hajj

Malik :: Book 20 : Hadith 20.47.162

Yahya related to me from Malik that Yahya ibn Said said that Sulayman ibn Yasar told him that Abu Ayyub al-Ansari once set off to do hajj and then, when he reached an-Naziya, on the road to Makka, his riding beasts strayed. He reached Umar ibn al-Khattab on the day of sacrifice and told him what had happened and Umar said, "Do what someone doing umra would do, and then you can leave ihram, and then when the hajj next comes upon you, do it and sacrifice whatever animal is easy for you ."


Malik :: Hajj :: [20-20.47.163]

Hajj

Malik :: Book 20 : Hadith 20.47.163

Malik related to me from Nafi from Sulayman ibn Yasar that Habbar ibn al-Aswad arrived on the day of sacrifice while Umar ibn al-Khattab was sacrificing his animal and said, "Amir al-muminin, we made a mistake in our reckoning and we thought that today was the day of Arafa." Umar said, "Go to Makka, you and whoever else is with you, and do tawaf and sacrifice your animal if you have one with you. Then shave or cut your hair and return home. Then, in another year, do hajj and sacrifice an animal, and if you cannot find one, fast three days on hajj and seven when you return home."

Malik said, "Someone who intends to do hajj and umra together and then misses the hajj must do hajj again in another year, doing hajj with umra, and offer two sacrificial animals, one for doing the hajj with umra, and one for the hajj that he has missed."


Malik :: Hajj :: [20-20.48.164]

Hajj

Malik :: Book 20 : Hadith 20.48.164

Yahya related to me from Malik from Abu'z-Zubayr al-Makki from Ata ibn Abi Rabah that Abdullah ibn Abbas was asked about a man who had had intercourse with his wife while at Mina before he had done the tawaf al-ifada, and he told him to sacrifice an animal.


Malik :: Hajj :: [20-20.48.165]

Hajj

Malik :: Book 20 : Hadith 20.48.165

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili that lkrama, the mawla of Ibn Abbas, said, (and Thawr believed it to be from Abdullah ibn Abbas), "Someone who has intercourse with his wife before he has done the tawaf al-ifada should do an umra and sacrifice an animal."


Malik :: Hajj :: [20-20.48.166]

Hajj

Malik :: Book 20 : Hadith 20.48.166

Yahya related to me from Malik that he had heard Rabia ibn Abi Abd ar-Rahman saying the same about that as what Ikrama related from Ibn Abbas.

Malik said, "That is what I like most out of what I have heard about the matter."

Malik was asked about a man who forgot the tawaf al-ifada until he had left Makka and returned to his community and he said, "I think that he should go back and do the tawaf al-ifada, as long as he has not had sexual relations with women. If, however, he has had sexual relations with women, then he should not only return and do the tawaf al-ifada, but he should also do an umra and sacrifice an animal. He should not buy theanimal in Makka and sacrifice it there, but if he has not brought one with him from wherever it was he set out to do umra, he should buy one in Makka and then take it outside the limits of the Haram and drive it from there to Makka and sacrifice it there."


Malik :: Hajj :: [20-20.49.167]

Hajj

Malik :: Book 20 : Hadith 20.49.167

Yahya related to me from Malik from Jafar ibn Muhammad from his father that Ali ibn Abi Talib used to say, "The least difficult thing acceptable as a sacrificial animal is a sheep."


Malik :: Hajj :: [20-20.49.168]

Hajj

Malik :: Book 20 : Hadith 20.49.168

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas used to say, "The least difficult thing acceptable as a sacrificial animal is a sheep."

Malik said, "That is what I like most out of what I have heard about the matter, because Allah, the Blessed and Exalted, says in His Book, 'O you who trust, do not kill game while you are in ihram. Whoever of you kills it intentionally, there shall be repayment the like of what he has slain, from livestock, as shall be judged by two men of justice among you, a sacrificial animal which will reach the Kaba, or food for poor people, or the equivalent of that in fasting,' (Sura 5 ayat 95) and a sheep is one of the animals which is judged to be acceptable as a sacrifice. Allah has called it a sacrificial animal, and there is no dispute among us about the matter. How, indeed, could anyone be in doubt about the matter? A sheep is the kaffara for anything which does not reach the extent of something for which a camel or a cow would be the kaffara, and the kaffara for something which does not reach the extent of something for which a sheep would be the kaffara is fasting, or feeding poor people."


Malik :: Hajj :: [20-20.49.169]

Hajj

Malik :: Book 20 : Hadith 20.49.169

Yahya related to me from Malik from Nafi that Abdullah ibn Urnar used to say, "The least thing that is acceptable as a sacrificial animal is a camel or a cow."


Malik :: Hajj :: [20-20.49.170]

Hajj

Malik :: Book 20 : Hadith 20.49.170

Yahya related to me from Malik fromAbdullah ibn Abi Bakr that a mawla of Amir bint Abd ar-Rahman called Ruqayya told him that she once set out with Amra bint Abd ar-Rahman to go to Makka. She said, ''Amra entered Makka on the eighth of Dhu'l-Hijja, and I was with her. She did tawaf of the House, and say between Safa and Marwa, and then entered the back of the mosque. She asked me, 'Do you have a pair of scissors with you?' and I said, 'No.' She said, 'Then try and find some for me.' I went and looked for some and brought them back and she cut some hair from the tresses of her head.Then, on the day of sacrifice, she slaughtered a sheep."


Malik :: Hajj :: [20-20.50.171]

Hajj

Malik :: Book 20 : Hadith 20.50.171

Yahya related to me from Malik from Sadaqa ibn Yasar al-Makki that a man from the people of Yemen, who had his hair braided, came to Abdullah ibn Umar and said, "Abu Abd arRahman, I have come to do just umra. ''Abdullah ibn Umar said to him, "If I had been with you or you had asked me I would have told you to do hajj and umra together." The Yemeni answered, "I am doing what I am doing," and Abdullah ibn Umar said to him, "Cut off the locks that are hanging from your head and offer a sacrificial animal." A woman from Iraq said, "What should his sacrificial animal be, Abu Abd ar-Rahman?" and he said, "His sacrificial animal?" and she said to him, "What should his sacrificial animal be?" Abdullah ibn Umar said, "If I could only find a sheep to sacrifice, I would prefer to do that than to fast."


Malik :: Hajj :: [20-20.50.172]

Hajj

Malik :: Book 20 : Hadith 20.50.172

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "A woman in ihram should not comb her hair when she leaves ihram until she has cut some of the tresses of her hair, and if she has an animal for sacrifice with her she should not cut off any of her hair until the animal has been killed."


Malik :: Hajj :: [20-20.50.173]

Hajj

Malik :: Book 20 : Hadith 20.50.173

Yahya related to me from Malik that he had heard one of the people of knowledge say, "A man and wife should not share in one sacrificial animal. Each should sacrifice an animal separately."

Malik was asked about whether someone who had been entrusted with an animal for him to sacrifice on hajj, who went into ihram for umra, should sacrifice it when he came out of ihram or postpone it so that he sacrificed it at the time of the hajj while in the meantime he came out of ihram from his umra. He said, "He should postpone it so that he may sacrifice it at the time of the hajj, and meanwhile come out of ihram from his umra."

Malik said, "If it is judged that some-one must offer an animal for having killed game, or for any other reason, this animal can only be sacrificed at Makka, since Allah, the Blessed and Exalted, says, 'a sacrificial animal which will reach the Kaba.' The fasting or sadaqa that is considered equivalent to offering a sacrifice can be done outside Makka, and the person who is doing it can do it wherever he likes."


Malik :: Hajj :: [20-20.50.174]

Hajj

Malik :: Book 20 : Hadith 20.50.174

Yahya related to me from Malik from Yahya ibn Said from Yaqub ibn Khalid al-Makhzumi that Abu Asma, the mawla of Abdullah ibn Jafar, told him that he was with Abdullah ibn Jafar when they set out once from Madina. At as-Suqya they passed by Husayn ibn Ali, who was ill at the time. Abdullah ibn Jafar stayed with him and then, when he feared that he was late (for the hajj) he left, and sent for Ali ibn Abi Talib and Asma bint Umays in Madina, and they came to Husayn. Then Husayn pointed to his head, and AIi told someone to shave his head. Then he sacrificed an animal for him at as-Suqya, killing a camel for him.

Yahya ibn Said added, "Husayn had set out with Uthman ibn Affan on that particular journey to Makka. "


Malik :: Hajj :: [20-20.51.175]

Hajj

Malik :: Book 20 : Hadith 20.51.175

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "The whole of Arafa is a mawqif, except the middle of Urana, and the whole of Muzdalifa is a standing-place, except for the middle of Muhassir."


Malik :: Hajj :: [20-20.51.176]

Hajj

Malik :: Book 20 : Hadith 20.51.176

Yahya related to me from Malik from Hisham ibn Urwa that Abdullah ibn az-Zubayr used to say, "Know that the whole of Arafa is a standing-place except for the middle of Urana, and that the wholeof Muzdalifa is a standing-place except for the middle of Muhassir."

Malik said, "Allah, the Blessed and Exalted says, 'There is to be no rafath, no fusuq and no jidal during the hajj.' " (Sura 2 ayat 197).

He added, "Rafath is sexual relations with women, and Allah knows best. Allah, the Blessed and Exalted says, 'Rafath with your women is permitted to you on the night of the fast.' (Sura 2 ayat 197). Fusuq are sacrifices made to idols, and Allah knows best. Allah, the Blessed and Exalted, says, 'Or a fisq offered up to other than Allah.' (Sura 2 ayat 197) Jidal (arguing) during the hajj refers to when the Quraysh used to stand near the mashar al-haram at Quzah in Muzdalifa, while the Arabs and others would stand at Arafa, and they would argue about who was the more correct. Allah, the Blessed and Exalted, says, 'And we appointed a method of sacrifice for every nation, which they followed, so let them not dispute with you about the matter, and call to your Lord. Surely you are on a straight guidance.' (Sura 22 ayat 67) This is what jidal refers to in our opinion, and Allah knows best. This I have heard from the people of knowledge."


Malik :: Hajj :: [20-20.52.177]

Hajj

Malik :: Book 20 : Hadith 20.52.177

Malik was asked about whether a man could stand at Arafa, or at Muzdalifa, or stone the Jamras, or do say between Safa and Marwa if he was not in wudu, and he said, "Every practice in the hajj that a menstruating woman can take part in can be taken part in by a man who is not in wudu and there is nothing due from him for that. However, it is better for him to be in wudu for all those things, and he should not make a general practice of it."

Malik was asked whether a man who was riding should get down to do the standing at Arafa or if he could stand while mounted, and he said, "He can stand while mounted, unless he or his riding beast have an illness, in which case Allah is the one who most often accepts an excuse."


Malik :: Hajj :: [20-20.53.178]

Hajj

Malik :: Book 20 : Hadith 20.53.178

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Someone who does not stand at Arafa on the night of Muzdalifa before the dawn breaks has missed the hajj, and someone who stands at Arafa on the night of Muzdalifa before the dawn breaks has caught the hajj."


Malik :: Hajj :: [20-20.53.179]

Hajj

Malik :: Book 20 : Hadith 20.53.179

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "Someone who does not stand at Arafa on the night of Muzdalifa

before the dawn breaks has missed the hajj, and some one who stands at Arafa on the night of Muzdalifa before the dawn breaks has caught the hajj.

Malik said, about a slave freed during the wuquf at Arafa, "His standing does not fulfil for him the hajj of Islam, except if he was not in ihram and then he went into ihram after he was freed and he stood at Arafa that same night before the dawn broke in which case that is enough for him. If, however, he did not go into ihram until after the dawn had broken, he is in the same position as someone who misses the hajj by not catching the standing at Arafa before the breaking of the dawn on the night of Muzdalifa, and he will have to do the hajj of Islam later."


Malik :: Hajj :: [20-20.54.180]

Hajj

Malik :: Book 20 : Hadith 20.54.180

Yahya related to me from Malik from Nafj from Salim and Ubaydullah, two sons of Abdullah ibn Umar, that their father Abdullah ibn Umar used to send his family and children from Muzdalifa to Mina ahead of him so that they could pray subh at Mina and throw the stones before everyone (else) arrived.


Malik :: Hajj :: [20-20.54.181]

Hajj

Malik :: Book 20 : Hadith 20.54.181

Yahya related to me from Malik from Yahya ibn Said from Ata ibn Abi Rabah that a mawla of Asma bint Abi Bakr told him, "We arrived at Mina with Asma bint Abi Bakr at the end of the night, and I said to her, 'We have arrived at Mina at the end of the night,' and she said, 'We used to do that with one who was better than you.' "


Malik :: Hajj :: [20-20.54.182]

Hajj

Malik :: Book 20 : Hadith 20.54.182

Yahya related to me from Malik that he had heard that Talha ibn Ubaydullah used to send his family and children from Muzdalifa to Mina ahead of him.


Malik :: Hajj :: [20-20.54.183]

Hajj

Malik :: Book 20 : Hadith 20.54.183

Yahya related to.me from Malik that he had heard one of the people of knowledge disapproving of stoning the jamra until after dawn on the day of sacrifice, as it was halal for whoever had thrown the stones to sacrifice.


Malik :: Hajj :: [20-20.54.184]

Hajj

Malik :: Book 20 : Hadith 20.54.184

Yahya related to me from Malik from Hisham ibn Urwa that Fatima bint al-Mundhir told him that she used to see Asma bint Abi Bakrat Muzdalifa telling whoever led the subh prayer for her and her companions to pray it as soon as the dawn broke, after which she would mount and go to Mina without stopping at all.


Malik :: Hajj :: [20-20.55.185]

Hajj

Malik :: Book 20 : Hadith 20.55.185

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "I was sitting with Usama ibn Zayd when some one asked him, 'How did the Messenger of Allah, may Allah bless him and grant him peace, travel when he went from Arafa to Muzdalifa during the farewell hajj?' and he replied, 'He went at a medium pace, but when he found a gap (in the crowds) he speeded up.' "


Malik :: Hajj :: [20-20.55.186]

Hajj

Malik :: Book 20 : Hadith 20.55.186

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to spur on his mount in the middle of Muhassir over the distance of a stone's throw.


Malik :: Hajj :: [20-20.56.187]

Hajj

Malik :: Book 20 : Hadith 20.56.187

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said once at Mina, "This place (where I have just sacrificed), and the whole of Mina, is a place of sacrifice," and he said once during umra, "This place of sacrifice" meaning Marwa, "and all the pathways of Makka and its roads are a place of sacrifice."


Malik :: Hajj :: [20-20.56.188]

Hajj

Malik :: Book 20 : Hadith 20.56.188

Yahya related to me from Malik that Yahya ibn Said said that Amra bint Abd ar-Rahman told him that she had heard A'isha, umm al-muminin, saying, "We set out with the Messenger of Allah, may Allah bless him and grant him peace, when there were five nights left in Dhu'l-Qada and we assumed that we must be setting out for hajj. When we got near to Makka, the Messenger of Allah, may Allah bless him and grant him peace, told everyone that did not have a sacrificial animal with them to leave ihram after they had done tawaf of the House and say between Safa and Marwa."

A'isha added, "We were sent some beef on the day of sacrifice. I asked what it was and they said that the Messenger of Allah, may Allah bless him and grant him peace, had sacrificed for his wives."

Yahya ibn Said said, "I mentioned this hadith to Qasim ibn Muhammad and he said, 'She has given you the complete hadith, by Allah.' "


Malik :: Hajj :: [20-20.56.189]

Hajj

Malik :: Book 20 : Hadith 20.56.189

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Hafsa, umm al-muminin, once said to the Messenger of Allah, may Allah bless him and grant him peace, "Why is it that everyone has left ihram and you still have not left ihram from your umra?" and he replied, "I have matted my hair and garlanded my sacrificial animal and will not leave ihram until I have sacrificed the animal."


Malik :: Hajj :: [20-20.57.190]

Hajj

Malik :: Book 20 : Hadith 20.57.190

190 Yahya related to me from Malik from Jafar ibn Muhammad from his father from Ali ibn Abi Talib that the Messenger of Allah, may Allah bless him and grant him peace, killed some of his sacrificial animals himself, and someone else killed the rest.


Malik :: Hajj :: [20-20.57.191]

Hajj

Malik :: Book 20 : Hadith 20.57.191

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "Someone who vows to sacrifice a camel or a cow to Allah should garland it with two sandals about its neck, and brand it by causing blood to flow from its side. He should then sacrifice it either at the House or at Mina on the day of sacrifice. There are no other correct places apart from those. However, someone who vows to slaughter a camel or a cow simply as a sacrifice can sacrifice it wherever he wishes."


Malik :: Hajj :: [20-20.57.192]

Hajj

Malik :: Book 20 : Hadith 20.57.192

Yahya related to me from Malik from Hisham ibn Urwa that his father used to kill his sacrificial animals while they were standing.

Malik said, "No-one is permitted to shave his head until he has killed his sacrificial animal, and no-one must sacrifice before dawn on the day of sacrifice. The things that should be done on the day of sacrifice are slaughtering, donning clothes, grooming the body generally (at-tafath) and shaving the head, and none of this may be done before the day of sacrifice."


Malik :: Hajj :: [20-20.58.193]

Hajj

Malik :: Book 20 : Hadith 20.58.193

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "O Allah, have mercy on those who shave their hair." They said, "And those who shorten (their hair), Messenger of Allah." He said, "O Allah, have mercy on those who shave." They said, "And those who shorten, Messenger of Allah." He said, "And those who shorten."


Malik :: Hajj :: [20-20.58.194]

Hajj

Malik :: Book 20 : Hadith 20.58.194

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father used to go into Makka by night when he was doing umra and do tawaf of the House and say between Safa and Marwa and delay the shaving until the morning, but he would not go back to the House and do tawaf again until he had shaved his head.

Abd ar-Rahman added, "Sometimes he would enter the mosque and do the witr prayer there without actually going near the House."

Malik said, "At-tafath is shaving the head, putting on normal clothes and things of that nature."

Yahya said that Malik was asked whether a man who forgot to shave (his head) at Mina during the hajj could shave in Makka, and he said, "That is permissible, but I prefer the shaving to be done at Mina."

Malik said, "What we are all agreed upon here (in Madina) is that no-one should shave his head or cut his hair until he has killed his sacrificial animal, if he has one, and things that are haram for him do not become halal for him until he leaves ihram at Mina on the day of sacrifice. This is because Allah, the Blessed and Exalted, says, 'Do not shave yourheads until the sacrificial animal has reached its destination. ' "


Malik :: Hajj :: [20-20.59.195]

Hajj

Malik :: Book 20 : Hadith 20.59.195

Yahya related to me from Malik from Nafi that if Abdullah ibn Umar had finished the fast of Ramadan and intended to do hajj, he would not cut his hair or beard at all until he had done hajj.

Malik said, "It is not necessary for people to do the same."


Malik :: Hajj :: [20-20.59.196]

Hajj

Malik :: Book 20 : Hadith 20.59.196

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to trim his beard and moustache when he shaved at the end of a hajj or umra.


Malik :: Hajj :: [20-20.59.197]

Hajj

Malik :: Book 20 : Hadith 20.59.197

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that a man came to Qasim ibn Muhammad and said, "I did the tawaf al-ifada along with my wife, and then I went off onto a mountain path and approached my wife to make love to her, and she said, 'I have not cut my hair yet.' So I bit some of her hair off with my teeth and then had intercourse with her." Qasim laughed and said, "Tell her to cut her hair with some scissors."

Malik said, "To my liking an animal should be sacrificed in an instance such as this, because Abdullah ibn Abbas said, 'Whoever forgets any of his rites on hajj should sacrifice an animal.' "


Malik :: Hajj :: [20-20.59.198]

Hajj

Malik :: Book 20 : Hadith 20.59.198

Yahya related to me from Malik from Nafi that Abdullah ibn Umar once met a relative of his called al-Mujabbar who had done the tawaf al-ifada but, out of ignorance, had not shaved his head or cut his hair. Abdullah told him to go back and shave his head or cut his hair, and then go back and do the tawaf al-ifada.


Malik :: Hajj :: [20-20.59.199]

Hajj

Malik :: Book 20 : Hadith 20.59.199

Yahya related to me from Malik that he had heard that when Salim ibn Abdullah intended to go into ihram he would call for some scissors and trim his moustache and beard before setting off and before going into ihram.


Malik :: Hajj :: [20-20.60.200]

Hajj

Malik :: Book 20 : Hadith 20.60.200

Yahya related to me from Malik from Nafi from 'Abdullah ibn 'Umar that Umar ibn al-Khattab said, "Someone who puts plaits in his hair should shave his head, and do not plait your hair in such a way that it seems you have matted it."


Malik :: Hajj :: [20-20.60.201]

Hajj

Malik :: Book 20 : Hadith 20.60.201

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that Umar ibn al-Khattab said, "Anyone who has braided his hair, or plaited it or matted it must shave his head."


Malik :: Hajj :: [20-20.61.202]

Hajj

Malik :: Book 20 : Hadith 20.61.202

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, entered the Kaba with Usama ibn Zayd, Bilal ibn Rabah and Uthman ibn Talha al-Hajabi and locked it behind him and stayed there for some time.

Abdullah said that he asked Bilal when he came out what the Messenger of Allah had done there and he said, "He positioned himself with one support to his left, two supports to his right, and three behind him (the house had six supports at that time) and then he prayed."


Malik :: Hajj :: [20-20.61.203]

Hajj

Malik :: Book 20 : Hadith 20.61.203

Yahya related to me from Malik from Ibn Shihab that Salim ibn Abdullah said, ''Abd al-Malik ibn Marwan wrote to al-Hajjaj ibn Yusuf telling him not to disagree with Abdullah ibn Umar about anything to do with the hajj. Then, when the day of Arafa came Abdullah ibn Umar went to him just after noon, and I went with him. He called out to him outside his tent, 'Where is this man?' and a-lHajjaj came out to him, wearing a blanket dyed with safflower, and said to him, 'What's up with you, Abu Abd ar-Rahman?' He said, 'Hurry up, if you want to follow the sunna.' Al-Hajjaj said, 'At this hour?' and he said, 'Yes.' Al-Hajjaj said, 'Wait until I have poured some water over myself, and then I will come out.' So Abdullah dismounted and waited until al-Hajjaj came out. He passed between me and my father and I said to him, 'If you want to accord with the sunna today, then make the khutba short, do not delay the prayer and do the prayer quickly.' Then he began looking at Abdullah ibn Umar to see if he would say the same thing, and when Abdullah saw that, he said, 'What Salim is saying is true.' "

20.64 Doing the Prayer at Mina on the Eighth Day of Dhu-l-Hijja, and the Jumua at Mina and Arafa


Malik :: Hajj :: [20-20.61.204]

Hajj

Malik :: Book 20 : Hadith 20.61.204

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pray dhuhr, asr, maghrib, isha and subh at Mina. Then in the morning, after the sun had risen, he would go to Arafa .

Malik said, "What we are all agreed upon here (in Madina) is that the imam does not recite the Qur'an out loud in dhuhr on the day of Arafa, and that he gives a khutba to the people on that day, and that the prayer on the day of Arafa is really a dhuhr prayer, and even if it coincides with a jumua it is still a dhuhr prayer, but one which has been shortened because of travelling."

Malik said that the imam of the pilgrims should not pray the jumua prayer if the day of Arafa, the day of sacrifice or one of the three days after the day of sacrifice, was a Friday.


Malik :: Hajj :: [20-20.62.205]

Hajj

Malik :: Book 20 : Hadith 20.62.205

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, prayed maghrib and isha together at Muzdalifa.


Malik :: Hajj :: [20-20.62.206]

Hajj

Malik :: Book 20 : Hadith 20.62.206

Yahya related to me from Malik from Musa ibn Uqba that Kurayb, the mawla of Ibn 'Abbas, heard Usama ibn Zayd say, "The Messenger ofAllah, may Allah bless him and grant him peace, left Arafa and then, when he reached ash-Shib, he dismounted and urinated and then did wudu, though not thoroughly. I said to him, 'It is time for the prayer, Messenger of Allah,' and he said 'The prayer is ahead of you,' and then mounted. When we arrived at Muzdalifa he dismounted and did wudu thoroughly. Then the iqama was said for the prayer and he prayed maghrib. After that everyone settled his camel in its resting-place, and then the iqama for isha was said and he prayed it, without having prayed anything between the two."


Malik :: Hajj :: [20-20.62.207]

Hajj

Malik :: Book 20 : Hadith 20.62.207

Yahya related to me from Malik from Yahya ibn Said from Adi ibn Thabit al-Ansari that Abdullah ibn Yazid al-Khatmi told him that Abu Ayyub al-Ansari told him that he prayed maghrib and isha together at Muzdalifa during the farewell hajj, with the Messenger of Allah, may Allah bless him and grant him peace.


Malik :: Hajj :: [20-20.62.208]

Hajj

Malik :: Book 20 : Hadith 20.62.208

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pray maghrib and isha together at Muzdalifa.


Malik :: Hajj :: [20-20.63.209]

Hajj

Malik :: Book 20 : Hadith 20.63.209

Malik said that the people of Makka who are doing hajj should shorten the prayer to two rakas when at Mina until they go back to Ma ka.


Malik :: Hajj :: [20-20.63.210]

Hajj

Malik :: Book 20 : Hadith 20.63.210

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, prayed four raka prayers with only two rakas when at Mina, and that Abu Bakr prayed them at Mina with only two rakas, and that Umar ibn al-Khattab prayed them at Mina with only two rakas, and that Uthman prayed them at Mina with only two rakas for half of his khalifate, and then later completed them.


Malik :: Hajj :: [20-20.63.211]

Hajj

Malik :: Book 20 : Hadith 20.63.211

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that Umar ibn al-Khattab prayed two rakas with everybody when he arrived in Makka. Then, when he had finished, he said, "People of Makka, complete your prayer, because we are a group of travellers." Later, Umar ibn al-Khattab prayed two rakas with them at Mina, but we have not heard that he said anything to them on that occasion.


Malik :: Hajj :: [20-20.63.212]

Hajj

Malik :: Book 20 : Hadith 20.63.212

Yahya related to me from Malik from Zayd ibn Aslam from his father that Umar ibn al-Khattab prayed two rakas with the people of Makka, and then, when he had finished, he said, "People of Makka, complete your prayer, becausewe are a group of travellers." Later, Umar prayed two rakas with them at Mina, but we have not heard that he said anything to them on that occasion.

Malik was asked whether the people of Makka should pray two rakas at Arafa or four, and whether the amir of the hajj, if he was a Makkan, should pray dhuhr and asr with four rakas or two, and also how the people of Makka who were living (at Mina) should pray, and he said, "The people of Makka should pray only two rakas at Arafa and Mina for as long as they stay there, and should shorten the prayer until they return to Makka. The amir of the hajj, if he is a Makkan, should also shorten the prayer at Arafa and during the days of Mina. Anyone who is living at Mina as a resident should do the full prayer at Mina, and similarly anyone who lives at Arafa and is a resident there should do the full prayer at Arafa."


Malik :: Hajj :: [20-20.64.213]

Hajj

Malik :: Book 20 : Hadith 20.64.213

Yahya related to me that Malik said, "Someone who comes to Makka at or before the new moon of Dhu'l-Hij ja and goes into ihram for the hajj should do the full prayer until he leaves Makka for Mina, and then he should shorten the prayer. This is because he has decided to stay there for more than four nights."


Malik :: Hajj :: [20-20.65.214]

Hajj

Malik :: Book 20 : Hadith 20.65.214

Yahya related to me from Malik from Yahya ibn Said that he had heard that on the day after the day of sacrifice Umar ibn al-Khattab went out a little after the sun had risen and said the takbir, and everyone repeated it after him. Then he went out a second time the same day when the sun was well up and said the takbir, and everyone repeated it after him. Then he went out a third time after mid-day and said the takbir, and everyone repeated it after him until it resounded from group to group until it reached the House and people knew that Umar had left to throw the stones.

Malik said, "What we do here (in Madina) is to say the takbir during the days of tashriq after each prayer. The first time is when the imam and everyone with him says the takbir after the dhuhr prayer on the day of sacrifice, and the last is when the imam and everyone with him says the takbir after subh on the last of the days of tashriq, after which he stops saying the takbir."

Malik said, "The takbirs during the days of tashriq should be done by both men and women, whether they are in a group or by themselves, at Mina or elsewhere, and all of the takbirs should be done. In this everyone follows the imam of the hajj and the people at Mina, because when everyone returns (to Makka) and comes out of ihram they keep the same people as imams while out of ihram (as they did when they were in ihram). Some one who is not doing hajj does not follow them except for the takbirs during the days of tashriq."

Malik said, "The 'limited number of days' are the days of tashriq."


Malik :: Hajj :: [20-20.66.215]

Hajj

Malik :: Book 20 : Hadith 20.66.215

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, made his camel kneel down at al-Batha, which is at Dhu'l-Hulayfa, and prayed there. Nafi said, "Abdullah ibn Umar used to do that."

Malik said, "No-one should go past al-Muarras when he is returning from hajj without praying there. If he passes it at a time when prayer is not permissible he should stay there until prayer is permissible and then pray whatever he feels is appropriate. (This is) because I have heard that the Messenger of Allah, may Allah bless him and grant him peace, stopped there to rest, and that Abdullah ibn Umar stopped his camel there also."


Malik :: Hajj :: [20-20.66.216]

Hajj

Malik :: Book 20 : Hadith 20.66.216

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to pray dhuhr, asr, maghrib and isha at al-Muhassab, and then enter Makka at night and do tawaf of the House.


Malik :: Hajj :: [20-20.67.217]

Hajj

Malik :: Book 20 : Hadith 20.67.217

Yahya related to me from Malik that Nafi said, "They say that Umar ibn al-Khattab used to send men out to bring people in from beyond al-Aqaba."


Malik :: Hajj :: [20-20.67.218]

Hajj

Malik :: Book 20 : Hadith 20.67.218

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab said, "No-one doing hajj should spend the nights of Mina beyond al-Aqaba."


Malik :: Hajj :: [20-20.67.219]

Hajj

Malik :: Book 20 : Hadith 20.67.219

Yahya related to me from Malik from Hisham ibn Urwa that his father said, talking about spending the nights of Mina at Makka, "No-one must spend the night anywhere except Mina."


Malik :: Hajj :: [20-20.68.220]

Hajj

Malik :: Book 20 : Hadith 20.68.220

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab used to stop at the first two jamras for such a long time that someone standing up would get tired.


Malik :: Hajj :: [20-20.68.221]

Hajj

Malik :: Book 20 : Hadith 20.68.221

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to stop for a long time at the first two jamras saying, "Allah is greater", "Glory be to Allah", "Praise be to Allah", and making duas to Allah, but he did not stop at the jamrat al-Aqaba.


Malik :: Hajj :: [20-20.68.222]

Hajj

Malik :: Book 20 : Hadith 20.68.222

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say "Allah is greater" whenever he threw a pebble while stoning the jamra.


Malik :: Hajj :: [20-20.68.223]

Hajj

Malik :: Book 20 : Hadith 20.68.223

Yahya related to me from Malik that he had heard some of the people of knowledge saying, "The pebbles used for stoning the jamras should be like the stones used as slingshot."

Malik said, "I like it better if they are a little larger than that."

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "Someone who is at Mina when the sun sets in the middle of the days of tashriq must not leave until he has stoned the jamras on the following day."


Malik :: Hajj :: [20-20.68.224]

Hajj

Malik :: Book 20 : Hadith 20.68.224

Yahya related to me from Malik from Abd ar-Rahman ibn Qasim from his father that when people went to stone the jamras they would walk both going there and coming back. The first one to ride was Muawiya ibn Abi Sufyan.


Malik :: Hajj :: [20-20.68.225]

Hajj

Malik :: Book 20 : Hadith 20.68.225

Yahya related to me from Malik that he asked Abd ar-Rahman ibn Qasim, "From where did Qasim stonethe jamrat al-Aqaba?"and he replied, "From wherever it was possible."

Yahya said that Malik was asked whether some one else could throw the stones for a child or a sick man and he said, "Yes, and a sick man should inquire as to when the stones will be thrown for him and then say the takbir while he is in the place where he is staying, bleeding. If a sick man regains his health during the days of tashriq, he should stone whatever stoning has been done for him and he must offer a sacrificial animal."

Malik said, "I do not consider that someone who stones the jamras or does say between Safa and Marwa without being in wudu has to repeat anything, but he should not make a general practice of it."


Malik :: Hajj :: [20-20.68.226]

Hajj

Malik :: Book 20 : Hadith 20.68.226

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to say, "The jamras should not be stoned during the three days until after the sun has passed the meridian."


Malik :: Hajj :: [20-20.69.227]

Hajj

Malik :: Book 20 : Hadith 20.69.227

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazm from his father that Abu'l-Baddah ibn Asim ibn Adi told him from his father that the Messenger of Allah, may Allah bless him and grant him peace, allowed the camel-herders to spend the night outside of Mina, and they threw the stones (once) on the day of sacrifice, and (once) for the following day and the day after that, and (once) on the day when they left Mina.


Malik :: Hajj :: [20-20.69.228]

Hajj

Malik :: Book 20 : Hadith 20.69.228

Yahya related to me from Malik that

Yahya ibn Said heard Ata ibn Abi Rabah mentioning that the camel-herders were allowed to throw the stones at night, and saying that this was in the early period (of Islam).

Malik said, "The explanation of the hadith where the Messenger of Allah, may Allah bless him and grant him peace, allowed the camel-herders to delay the stoning of the jamras is, in our view, and Allah knows best, that they threw stones on the day of sacrifice, and then threw again two days later, which was the first possible day for leaving, and this throwing was for the day which had passed. They then threw again for the day itself, because it is only possible for someone to make up for something which is obligatory for him, and when something obligatory passes someone by (without him doing it) he must necessarily make it up afterwards (and not beforehand). So (in the case of the camel-herders), if it seemed appropriate for them to leave that day, they would have done all that they were supposed to do, and if they were to stay until the following day, they would throw stones with everybody else on the second and last day for leaving, and then leave."


Malik :: Hajj :: [20-20.69.229]

Hajj

Malik :: Book 20 : Hadith 20.69.229

Yahya related to me from Malik from Abu Bakr ibn Nafi from his father that the daughter of one of Safiyya bint Abi Ubayd's brothers was bleeding after she had given birth to a child at Muzdalifa. She and Safiyya were delayed and did not arrive at Mina until after the sun had set on the day of sacrifice. Abdullah ibn Umar told them both to stone the jamra at the time they arrived and he did not think that they owed anything.

Yahya said that Malik was asked about some one who forgot to stone one of the jamras on one of the days of Mina until it was evening and he said, "He should throw the stones at whatever time of day or night he remembers, just as he would pray the prayer if he forgot it and then remembered it at any time of day or night. If he remembers (that he has not done the stoning) after he has returned to Makka, or after he has left, he must sacrifice an animal."


Malik :: Hajj :: [20-20.69.230]

Hajj

Malik :: Book 20 : Hadith 20.69.230

Yahya related to me from Malik from Nafi and Abdullah ibn Dinar from Abdullah ibn Umar that Umar ibn al-Khattab gave a khutba to the people at Arafa and taught them the conduct of the hajj, and one of the things he said to them in his speech was, "When you get to Mina and have stoned the jamra then whatever is haram for someone doing the hajj becomes halal, except women and scent. No-one should touch women or scent until he has done tawaf of the House."


Malik :: Hajj :: [20-20.69.231]

Hajj

Malik :: Book 20 : Hadith 20.69.231

Yahya related to me from Malik from Nafi and Abdullah ibn Dinar from Abdullah ibn Umar that Umar ibn al-Khattab said, "When someone has stoned the jamra and shaved his head or cut off some of his hair and sacrificed an animal, whatever was haram for him becomes halal, except women and scent, (which remain haram for him) until he has done tawaf of the House."


Malik :: Hajj :: [20-20.70.232]

Hajj

Malik :: Book 20 : Hadith 20.70.232

Yahya related to me from Abd ar-Rahman ibn al-Qasim, from his father that A'isha, umm al-muminin, said, "We set out with the Messenger of Allah, may Allah bless him and grant him peace, in the year of the farewell hajj and we went into ihram for umra. Afterwards, the Messenger of Allah, may Allah bless him and grant him peace, said, 'Whoever has a sacrificial animal with him should go into ihram for hajj and umra together, and he should not leave ihram without leaving ihram for both of them at the same time.' "

She continued "I was menstruating when I got to Makka, so I did not do tawaf of the House or say between Safa and Marwa. I complained to the Messenger of Allah, may Allah bless him and grant him peace, and he said, 'Undo your hair and comb it and leave the umra and go back into ihram for the hajj.' "

She said, "I did so, and when we had completed the hajj, the Messenger of Allah, may Allah bless him and grant him peace, sent me with Abd ar-Rahman ibn Abi Bakr as-Siddiq to at-Tanim and I performed an umra and he said, 'This is in place of your umra.' "

"Those who had entered ihram for the umra did tawaf of the House and say between Safa and Marwa, then left ihram. Then they did another tawaf after returning from Mina for their hajj, whereas those who entered ihram for the hajj or combined the hajj and the umra, only did one tawaf."

Yahya related the same as that to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha.


Malik :: Hajj :: [20-20.70.233]

Hajj

Malik :: Book 20 : Hadith 20.70.233

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha said, "I came to Makka at the time of my period so I did not do tawaf of the House or go between Safa and Marwa. I complained to the Messenger of Allah, may Allah bless him and grant him peace, and he said, 'Do what the people doing hajj do except do not do tawaf of the House and go between Safa and Marwa until you are pure.' "

Malik said, concerning a woman who entered ihram for umra at the time of hajj, and she arrived in Makka during her period and so could not do tawaf of the House, "When she fears that the time (for hajj) is getting close, she gets into ihram for the hajj and sacrifices an animal. She is like someone who combines the hajj and the umra. One tawaf is enough for her. If a women starts her period after she has already done tawaf of the House and prayed, she does say between Safa and Marwa and stops at Arafa and Muzdalifa and stones the jamras but she does not do the tawaf al-ifada until she is pure and has finished her menses."


Malik :: Hajj :: [20-20.71.234]

Hajj

Malik :: Book 20 : Hadith 20.71.234

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father from A'isha umm al-muminin that Safiyya bint Huyy began menstruating and so she mentioned it to the Messenger of Allah, may Allah bless him and grant him peace, and he asked, "Will she delay us?" and he was told, "She has already done the tawaf al-ifada," and he said, "Then she will not delay us. "


Malik :: Hajj :: [20-20.71.235]

Hajj

Malik :: Book 20 : Hadith 20.71.235

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazm from his father from Amra bint Abd ar-Rahman that A'isha umm al-muminin said to the Messenger of Allah, may Allah bless him and grant him peace, "Messenger of Allah, Safiyya bint Huyy has begun her period," and the Messenger of Allah, may Allah bless him and grant him peace, said, "Perhaps she will delay us. Has she done tawaf of the House with you?" They said, "Of course." He said, "So you are free to leave."


Malik :: Hajj :: [20-20.71.236]

Hajj

Malik :: Book 20 : Hadith 20.71.236

Yahya related to me from Malik from AbuRijal Muhammad ibn Abd ar-Rahman from Amra bint Abd ar-Rahman that when A'isha umm al-muminin was doing hajj with women who were expecting their periods, she would hurry them to do the tawaf al-ifada on the Day of Sacrifice. If they started to menstruate after the tawaf al-ifada she did not stop for them but left with them while they were menstruating.


Malik :: Hajj :: [20-20.71.237]

Hajj

Malik :: Book 20 : Hadith 20.71.237

Yahya related to me from Malik from Hisham ibn Urwa from his father from A'isha umm al-muminin that the Messenger of Allah, may Allah bless him and grant him peace, mentioned Safiyya bint Huyy and he was told that she had started her period. The Messenger of Allah, may Allah bless him and grant him peace, said, "Perhaps she will delay us." They said, "Messenger of Allah, she has done tawaf," and the Messenger of Allah, may Allah bless him and grant him peace, said, "Then she will not delay us."

Malik said that Hisham said that Urwa said that A'isha said, "We have publicized that, so why do people make their women stay on to their inconvenience? If it were as they say, more than six thousand menstruating women would still be in Mina in the morning, all of them having already done the tawaf al-ifada.' "


Malik :: Hajj :: [20-20.71.238]

Hajj

Malik :: Book 20 : Hadith 20.71.238

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his father that Abu Salama ibn Abd ar-Rahman told him that Umm Sulaym bint Milhan asked the Messenger of Allah, may Allah bless him and grant him peace, for advice one time when she had begun menstruating, or had given birth to a child after she had done tawaf al-ifada on the Day of Sacrifice. The Messenger of Allah, may Allah bless him and grant him peace, gave her permission to leave.

Malik said, "A woman menstruating at Mina stays until she has done tawaf of the House. There is no escape from that for her. If she has already done the tawaf al-ifada and she starts to menstruate afterwards, she may leave for her country, since permission for the menstruating women to leave has been transmitted to us from the Messenger of Allah, may Allah bless him and grant him peace."

He added, "If a woman starts her period at Mina before she does the tawaf al-ifada, and the period lasts longer than usual, she has to stay longer than the time that bleeding would usually detain women."


Malik :: Hajj :: [20-20.72.239]

Hajj

Malik :: Book 20 : Hadith 20.72.239

Yahya related to me from Malik from Abu'z-Zubayr that Umar ibn al-Khattab gave the judgement of a ram for a hyena, a female goat for a gazelle, a she-goat less than one year old for a rabbit, and a four month old kid for a jerboa.


Malik :: Hajj :: [20-20.72.240]

Hajj

Malik :: Book 20 : Hadith 20.72.240

Yahya related to me from Malik from Abd al-Malik ibn Qurayr from Muhammad ibn Sirin that a man came to Umar ibn al-Khattab and said, "I was racing a friend on horseback towards a narrow mountain trail and we killed a gazelle accidently and we were in ihram. What is your opinion?" Umar said to a man by his side, "Come, so that you and I may make an assessment." They decided on a female goat for him, and the man turned away saying, "This amir al-muminin cannot even make an assessment in the case of a gazelle until he calls a man to decide with him." Umar overheard the man's words and called him and asked him, "Do you recite surat al-Ma'ida?" and he said, "No." He said, "Then do you recognize this man who has taken the decision with me?" and he said, "No." He said, "If you had told me that you did recite surat al-Ma'ida, I would have dealt you a blow." Then he said, "Allah the Blessed, the Exalted says in His Book, 'as shall be judged by two men of justice among you, a sacrificial animal to reach the Kaba' (Sura 5 ayat 95), and this is Abd ar-Rahman ibn Awf."


Malik :: Hajj :: [20-20.72.241]

Hajj

Malik :: Book 20 : Hadith 20.72.241

Yahya related to me from Malik from Hisham ibn Urwa that his father used to say, "For the female of wild animals a cow is given and for the female of gazelles a sheep."


Malik :: Hajj :: [20-20.72.242]

Hajj

Malik :: Book 20 : Hadith 20.72.242

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab used to say, "For the pigeon of Makka, when it is killed, a sheep is due."

Malik said, that if a man of the people of Makka were to enter ihram for hajj or umra and there was a flock of Makkan pigeons in his house and they were shut in and died, "I think that he should pay for that with a sheep for each bird."


Malik :: Hajj :: [20-20.72.243]

Hajj

Malik :: Book 20 : Hadith 20.72.243

Malik said, I still hear that when a person in ihram kills an ostrich, a camel is due."

Malik said, "I think that for an ostrich egg, one tenth of the price of a camel is due in the same way that there is a newly-born male or female slave for the unborn child of a free woman. The value of the newly-born slave is fifty dinars, and that is one-tenth of what the blood-money for the mother would be.

"Birds from the eagle family, eagles or falcons or vultures count as game for which a price is paid just as a price is paid for any game which a person in ihram kills. For everything for which a penalty is paid, the assessment is the same, whether the animal is old or young. The analogy of that is that the blood-money for the young and the old freeman, are considered to be the same."


Malik :: Hajj :: [20-20.73.244]

Hajj

Malik :: Book 20 : Hadith 20.73.244

Yahya related to me from Malik from Zayd ibn Aslam that a man came to Umar ibn al-Khattab and said, "Amir al-muminin, I killed some locusts with my whip when I was in ihram," and Umar said to him, "Give a handful of food."


Malik :: Hajj :: [20-20.73.245]

Hajj

Malik :: Book 20 : Hadith 20.73.245

Yahya related to me from Malik from Yahya ibn Said that a man came to Umar ibn al-Khattab and asked him about some locusts he had killed while he was in ihram. Umar said to Kab, "Come, let's decide." Kab said, "A dirham," and Umar said to Kab, "You can find dirhams. A date is better than a locust."


Malik :: Hajj :: [20-20.73.246]

Hajj

Malik :: Book 20 : Hadith 20.73.246

Yahya related to me from Malik from Abd al-Karim ibn Malik al-Jazari from Abd ar-Rahman ibn Abi Layla from Kab ibn Ujra that one time he was with the Messenger of Allah, may Allah bless him and grant him peace, in ihram, and he was suffering from lice on his head. The Messenger of Allah, may Allah bless him and grant him peace, told him to shave his head, saying, "Fast three days, or feed six poor people, two mudds for each person, or sacrifice a sheep. If you do any of those it will be enough for you."


Malik :: Hajj :: [20-20.73.247]

Hajj

Malik :: Book 20 : Hadith 20.73.247

Yahya related to me from Malik from Humayd bin Qays from Mujahid Abu'l Hajjaj from Ibn Abi Layla from Kab ibn Ujra that the Messenger of Allah, may Allah bless him and grant him peace, said to him, "Perhaps your pests are troubling you?" He replied that indeed they were, and the Messenger of Allah, may Allah bless him and grant him peace, said, "Shave your head and fast three days or feed six poor men or sacrifice a sheep."


Malik :: Hajj :: [20-20.73.248]

Hajj

Malik :: Book 20 : Hadith 20.73.248

Yahya related to me from Malik that Ata ibn Abdullah al-Khurasani said that an old man from Suq al-Buram in Kufa had related to him that Kab ibn Ujra said, "The Messenger of Allah, may Allah bless him and grant him peace, came to me while I was blowing under a cooking pot belonging to my companions and my head and beard were full of lice. He took my forehead and said, 'Shave your hair and fast three days or feed six poor people.' The Messenger of Allah, may Allah bless him and grant him peace, was aware that I did not have anything with me to sacrifice.'"

Malik said, concerning paying compensation (fidya) for the relief of physical discomfort, "The custom concerning it is that no one pays compensation until he has done something which makes it obligatory to pay compensation just as making amends (kaffara) is only done when it has become obligatory for the one who owes it. The person can pay the compensation wherever he wishes, regardless of whether he has to sacrifice an animal or fast or give sadaqa -- in Makka or in any other town."

Malik said, "It is not correct for a person in ihram to pluck out any of his hair or to shave it or cut it until he has left ihram, unless he is suffering from an ailment of the head, in which case he owes the compensation Allah the Exalted has ordered. It is not correct for a person in ihram to cut his nails, or to kill his lice, or to remove them from his head or from his skin or his garment to the ground. If a person in ihram removes lice from his skin or his garment, he must give away the quantity of food that he can scoop up with both hands. "

Malik said,"Anyone who, while in ihram, plucks out hairs from his nose or armpit or rubs his body with a depilatory agent or shaves the hair from around a head wound out of necessity or shaves his neck for the place of the cupping glasses, regardless of whether it is in forgetfulness or in ignorance, owes compensation in all these instances, and he must not shave the place of the cupping glasses. Someone, who, out of ignorance, shaves his head before he stones the jamra. must also pay compensation."


Malik :: Hajj :: [20-20.74.249]

Hajj

Malik :: Book 20 : Hadith 20.74.249

Yahya related to me from Malik from Ayyub ibn Abi Tamima as-Sakhtayani from Said ibn Jubayr that Abdullah ibn Abbas said, "If someone forgets anything of the rituals or omits them intentionally, he must slaughter an animal." Ayyub added "I do not know if he said 'Omits' or 'forgets'."

Malik said, "If it is a hady that has to be slaughtered it may only be done in Makka, but if it is a sacrifice, it may be slaughtered wherever the one who owes the sacrifice prefers."


Malik :: Hajj :: [20-20.75.250]

Hajj

Malik :: Book 20 : Hadith 20.75.250

Malik said, concerning someone who wishes to wear clothes that a person in ihram must not wear, or cut his hair, or touch perfume without necessity, because he finds it easy to pay the compensation, "No-one must do such things. They are only allowed in cases of necessity, and compensation is owed by whoever does them."

Malik was asked whether the culprit could choose for himself the method of compensation he makes, and he was asked what kind of animal was to be sacrificed, and how much food was to be given, and how many days were to be fasted, and whether the person could delay any of these, or if they had to be done immediately. He answered, 'Whenever there are alternatives in the Book of Allah for the kaffara, the culprit can choose to do whichever of the alternatives he prefers. As for the sacrifice - a sheep, and as for the fasting - three days. As for the food - feeding six poor men, for every poor man two mudds, by the first mudd, the mudd of the Prophet, may Allah bless him and grant him peace."

Malik said, "I have heard one of the people of knowledge saying, 'When a person in ihram throws something and hits game unintentionally and kills it, he must pay compensation. In the same way, someone outside the Haram who throws anything into the Haram and hits game he did not intend to, killing it, has to pay compensation, because the intentional and the mistaken are in the same position in this matter.' "

Malik said, concerning people who kill game together while they are muhrim or in the Haram, "I think that each one of them owes a full share. If a sacrificial animal is decided for them, each one of them owes one, and if fasting is decided for them, the full fasting is owed by each one of them. The analogy of that is a group of people who kill a man by mistake and the kaffara for that is that each person among them must free a slave or fast two consecutive months."

Malik said, "Anyone who stones or hunts game after stoning the jamra and shaving his head but before he has performed the tawaf al-ifada, owes compensation for that game, because Allah the Blessed, the Exalted said, 'And when you leave ihram, then hunt,' and restrictions still remain for someone who has not done the tawaf al-ifada about touching perfume and women."

Malik said, "The person in ihram does not owe anything for plants he cuts down in the Haram and it has not reached us that anyone has given a decision of anything for it, but O how wrong is what he has done! "

Malik said, concerning some one who was ignorant of, or who forgot the fast of three days in the hajj, or who was ill during them and so did not fast them until he had returned to his community, "He must offer a sacrificial animal (hady) if he can find one and if not he must fast the three days among his people and the remaining seven after that."


Malik :: Hajj :: [20-20.75.251]

Hajj

Malik :: Book 20 : Hadith 20.75.251

Yahya related to me from Malik from Ibn Shihab from clsa ibn Talha that Abdullah ibn Amr ibn al-As said, "The Messenger of Allah, may Allah bless him and grant him peace, stopped for the people at Mina, and they questioned him and a man came and said to him, 'Messenger of Allah, I was unclear about what to do and I shaved before sacrificing,' and the Messenger of Allah, may Allah bless him and grant him peace, said, 'Sacrifice, and don't worry.' Then another came to him and said 'Messenger of Allah, I was unclear about what to do and I sacrificed before throwing the stones.' He advised, 'Throw, and don't worry.' "

Amr continued, saying that the Messenger of Allah, may Allah bless him and grant him peace, was not asked about anything done before or after without his saying, "Do it, and don't worry."


Malik :: Hajj :: [20-20.76.252]

Hajj

Malik :: Book 20 : Hadith 20.76.252

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that when the Messenger of Allah, may Allah bless him and grant him peace, returned from a military expedition or a hajj or an umra, he used to say three takbirs on every elevated part of the land, and then he used to say, "There is no god but Allah, alone, without partner. To Him belongs the Kingdom and to Him belongs the praise and He has power over everything. Returning, making tawba, serving, prostrating, praising our Lord. Allah has promised truly and given His slave victory and defeated the tribes alone."


Malik :: Hajj :: [20-20.76.253]

Hajj

Malik :: Book 20 : Hadith 20.76.253

Yahya related to me from Malik from Ibrahim ibn Uqba from Kurayb the mawla of Abdullah ibn Abbas from Ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, passed a woman in a litter and it was said to her, "This is the Messenger of Allah, may Allah bless him and grant him peace," and she took the forearms of a young boy who was with her and said, "Does this one have a hajj, Messenger of Allah?" and he said, "Yes, and you have a reward."


Malik :: Hajj :: [20-20.76.254]

Hajj

Malik :: Book 20 : Hadith 20.76.254

Yahya related to me from Malik from Ibrahim ibn Abi Abla from Talha ibn Ubaydullah ibn Kariyz that the Messenger of Allah, may Allah bless him and grant him peace, said, "Shaytan is not considered more abased or more cast out or more contemptible or more angry on any day than on the Day of Arafa. That is only because he sees the descent of the Mercy and Allah's disregard for great wrong actions. That is except from what he was shown on the Day of Badr." Someone said, "What was he shown on the Day of Badr, Messenger of Allah?" He said, "Didn't he see Jibril arranging the ranks of the angels?"


Malik :: Hajj :: [20-20.76.255]

Hajj

Malik :: Book 20 : Hadith 20.76.255

Yahya related to me from Malik from Zihad ibn Abi Ziyad the mawla of Abdullah ibn Ayyash ibn Abi Rabia from Talha ibn Ubaydullah ibn Kariyz that the Messenger of Allah, may Allah bless him and grant him peace, said, "The most excellent dua is the dua on the Day of Arafa, and the best of what I and the prophets before me have said, is 'There is no god but Allah, alone, without partner.'"


Malik :: Hajj :: [20-20.76.256]

Hajj

Malik :: Book 20 : Hadith 20.76.256

Yahya related to me from Malik from Ibn Shihab from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, entered Makka, in the Year of Victory, wearing a helmet, and when he took it off a man came to him and said, "Messenger of Allah, Ibn Khatal is clinging to the covers of the Kaba,'' and the Messenger of Allah, may Allah bless him and grant him peace, said, "Kill him."

Malik commented, "The Messenger of Allah, may Allah bless him and grant him peace, was not in ihram at the time, and Allah knows best."


Malik :: Hajj :: [20-20.76.257]

Hajj

Malik :: Book 20 : Hadith 20.76.257

Yahya related to me from Malik from Nafi that Abdullah ibn Umar was coming from Makka and when he was at Qudayd, news came to him from Madina and he returned and entered Makka without ihram.

Yahya related the same as that to me from Malik from Ibn Shihab.


Malik :: Hajj :: [20-20.76.258]

Hajj

Malik :: Book 20 : Hadith 20.76.258

Yahya related to me from Malik from Muhammad ibn Amr ibn Halhala ad-Dili from Muhammad ibn lmran al-Ansari that his father said that Abdullah ibn Umar came upon him while he stopped for a rest under a tall tree on the road to Makka, and he said, "What has made you stop under this tall tree?" He replied that he sought it's shade. Abdullah ibn Umar said, "Anything besides that?" and he said, "No, that was the only. reason he stopped for a rest," and Abdullah ibn Umar said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'If you are between al-Akhshabayn (which are two mountains) near Mina,' indicating the east with his outspread hand, 'you will find a valley called as-Surar with a tree in it beneath which the umbilical cords of seventy prophets have been cut.' "


Malik :: Hajj :: [20-20.76.259]

Hajj

Malik :: Book 20 : Hadith 20.76.259

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazm from Ibn

Abi Mulayka that Umar ibn al-Khattab passed a leprous woman doing tawaf of the House, and he said to her, "Slave of Allah, do not make people uneasy. Better that you stay in your house," so she did so. A man passed by her after that and said to her, "The one who forbade you has died, so come out," and she replied, "I am not going to obey him when he is alive and disobey him when he is dead."


Malik :: Hajj :: [20-20.76.260]

Hajj

Malik :: Book 20 : Hadith 20.76.260

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas used to say that the area between the corner of the Black Stone and the door of the Kaba was called al-Multazam.


Malik :: Hajj :: [20-20.76.261]

Hajj

Malik :: Book 20 : Hadith 20.76.261

Yahya related to me from Malik that Yahya ibn Said heard Muhammad ibn Yahya ibn Habban mentioning that a certain man passed Abu Dharr at ar-Rabadha (which was about 30 miles from Madina) and Abu Dharr asked him, "Where are you heading to?" and he replied, "I am intending to do hajj." Abu Dharr questioned, "Has anything else brought you out?" and he said, "No," so Abu Dharr said "Resume what you are doing wholeheartedly."

The man related, "I went on till I came to Makka and I stayed as long as Allah willed. Suddenly, one time, I was with a crowd of people thronging about a man and I pushed through the people to him and it was the old man that I had come across at ar-Rabadha. When he saw me, he recognized me and said, 'Ah, you have done what I told you.' "


Malik :: Hajj :: [20-20.76.262]

Hajj

Malik :: Book 20 : Hadith 20.76.262

Yahya related to me from Malik that he asked Ibn Shihab about making a condition in the hajj that one could leave ihram at any place where an obstacle befell one and he said, "Does anyone do that?' and disapproved of it.

Malik was asked whether a man could cut plants from the Haram for his mount, and he said, "No."


Malik :: Hajj :: [20-20.77.263]

Hajj

Malik :: Book 20 : Hadith 20.77.263

Malik said, concerning a woman who had never been on hajj, "If she doesn't have a mahram, or if she has, but he cannot come with her, she does not abandon Allah's making of the hajj obligatory for her. Let her go in a group of women."


Malik :: Hajj :: [20-20.78.264]

Hajj

Malik :: Book 20 : Hadith 20.78.264

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that A'isha umm al-muminin used to say, "Someone performing hajj at-tamattu who does not have a sacrificial animal fasts (three days) from the time he enters ihram for the hajj till the Day of Arafa, and if he does not fast then, he fasts the days of Mina."

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar used to say the same concerning that, as the words of A'isha, may Allah the Exalted be pleased with her.


Malik :: Jihad :: [21-21.1.1]

Jihad

Malik :: Book 21 : Hadith 21.1.1

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said "Someone who does jihad in the way of Allah is like someone who fasts and prays constantly and who does not slacken from his prayer and fasting until he returns."


Malik :: Jihad :: [21-21.1.2]

Jihad

Malik :: Book 21 : Hadith 21.1.2

Yahya related to me from Malik from Abu'z Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Allah guarantees either the Garden or a safe return to his home with whatever he has obtained of reward or booty, for the one who does jihad in His way, if it is solely jihad and trust in his promise that brings him out of his house."


Malik :: Jihad :: [21-21.1.3]

Jihad

Malik :: Book 21 : Hadith 21.1.3

Yahya related to me from Malik from Zayd ibn Aslam from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Horses are a reward for one man, a protection for another, a burden for another. The one who has them as a reward is the one who dedicates them for use in the way of Allah, and tethers them in a meadow or grassland. Whatever the horse enjoys of the grassland or meadow in the length of its tether are good deeds for him. If it breaks its tether and goes over a hillock or two, its tracks and droppings are good deeds for him. If it crosses a river and drinks from it while he did not mean to allow it to drink it, that counts as good deeds for him, and the horse is a reward for him.

Another man uses his horse to gain self reliance and up-standingness and does not forget Allah's right on their necks and backs (i.e. he does not ill treat or over-work them). Horses are a protection for him .

Another man uses them out of pride to show them off and in hostility to the people of Islam. They are a burden on that man."

The Messenger of Allah, may Allah bless him and grant him peace, was asked about donkeys, and he said, "Nothing has been revealed to me about them except this single all-inclusive ayat, 'Whoever does an atom of good will see it, and whoever does an atom of evil, will see it.' " (Sura 99 Ayats 7,8) .


Malik :: Jihad :: [21-21.1.4]

Jihad

Malik :: Book 21 : Hadith 21.1.4

Yahya related to me from Abdullah ibn Abd ar-Rahman ibn Mamar al-Ansari that Ata ibn Yasar said that the Messenger of Allah, may Allah bless him and grant him peace, said, "Shall I tell you who has the best degree among people? A man who takes the rein of his horse to do jihad in the way of Allah. Shall I tell you who has the best degree among people after him? A man who lives alone with a few sheep, performs the prayer, pays the zakat, and worships Allah without associating anything with him."


Malik :: Jihad :: [21-21.1.5]

Jihad

Malik :: Book 21 : Hadith 21.1.5

Yahya related to me from Malik that Yahya ibn Said said, ''Ubada ibn al-Walid ibn Ubada ibn as-Samit informed me from his father that his grandfather (Ubada) said, 'We made a contract with the Messenger of Allah, may Allah bless him and grant him peace, to hear and obey in ease and hardship, enthusiasm and reluctance, and not to dispute with people in authority and to speak or establish the truth wherever we were without worrying about criticism.'"


Malik :: Jihad :: [21-21.1.6]

Jihad

Malik :: Book 21 : Hadith 21.1.6

Yahya related to me from Malik that Zayd ibn Aslam had said that Ubayda ibn al-Jarrah had written to Umar ibn al-Khattab mentioning to him a great array of Byzantine troops and the anxiety they were causing him. Umar ibn al-Khattab wrote in reply to him, "Whatever hardship befalls a believing slave, Allah will make an opening for him after it, and a hardship will not overcome two eases. Allah the Exalted says in His Book, 'O you who trust, be patient, and vie in patience; be steadfast and fear Allah, perhaps you will profit.' " (Sura 3 ayat 200).


Malik :: Jihad :: [21-21.2.7]

Jihad

Malik :: Book 21 : Hadith 21.2.7

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said that the Messenger of Allah, may Allah bless him and grant him peace, forbade travelling with a Qur'an in the land of the enemy. Malik commented, "That is out of fear that the enemy will get hold of it."


Malik :: Jihad :: [21-21.3.8]

Jihad

Malik :: Book 21 : Hadith 21.3.8

Yahya related to me from Malik from Ibn Shihab that a son of Kab ibn Malik (Malik believed that ibn Shihab said it was Abd ar-Rahman ibn Kab) said, "The Messenger of Allah, may Allah bless him and grant him peace, forbade those who fought ibn Abi Huqayq (a treacherous jew from Madina) to kill women and children. He said that one of the men fighting had said, 'The wife of ibn Abi Huqayq began screaming and I repeatedly raised my sword against her. Then I would remember the prohibition of the Messenger of Allah, may Allah bless him and grant him peace, so I would stop. Had it not been for that, we would have been rid of her.' "


Malik :: Jihad :: [21-21.3.9]

Jihad

Malik :: Book 21 : Hadith 21.3.9

Yahya related to me from Malik from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, saw the corpse of a woman who had been slain in one of the raids, and he disapproved of it and forbade the killing of women and children.


Malik :: Jihad :: [21-21.3.10]

Jihad

Malik :: Book 21 : Hadith 21.3.10

Yahya related to me from Malik from Yahya ibn Said that Abu Bakr as-Siddiq was sending armies to ash-Sham. He went for a walk with Yazid ibn Abi Sufyan who was the commander of one of the battalions. It is claimed that Yazid said to Abu Bakr, "Will you ride or shall I get down?" Abu Bakrsaid, "I will not ride and you will not get down. I intend these steps of mine to be in the way of Allah."

Then Abu Bakr advised Yazid, "You will find a people who claim to have totally given themselves to Allah. Leave them to what they claim to have given themselves. You will find a people who have shaved the middle of their heads, strike what they have shaved with the sword.

"I advise you ten things: Do not kill women or children or an aged, infirm person. Do not cut down fruit-bearing trees. Do not destroy an inhabited place. Do not slaughter sheep or camels except for food. Do not burn bees and do not scatter them. Do not steal from the booty, and do not be cowardly."


Malik :: Jihad :: [21-21.3.11]

Jihad

Malik :: Book 21 : Hadith 21.3.11

Yahya related to me from Malik that he had heard that Umar ibn Abd al-Aziz wrote to one of his governors, "It has been passed down to us that when the Messenger of Allah, may Allah bless him and grant him peace, sent out a raiding party, he would say to them, 'Make your raids in the name of Allah in the way of Allah. Fight whoever denies Allah. Do not steal from the booty, and do not act treacherously. Do not mutilate and do not kill children.' Say the same to your armies and raiding parties, Allah willing. Peace be upon you."


Malik :: Jihad :: [21-21.4.12]

Jihad

Malik :: Book 21 : Hadith 21.4.12

Yahya related to me from Malik from a man of Kufa that Umar ibn al-Khattab wrote to a lieutenant of an army which he had sent out, "I have heard that it is the habit of some of your men to chase an unbeliever till he takes refuge in a high place. Then one man tells him in Persian not to be afraid, and when he comes up to him, he kills him. By He in whose hand my self is, if I knew someone who had done that, I would strike off his head."

Yahya said, I heard Malik say, "This tradition is not unanimously agreed upon, so one does not act on it."

Malik when asked whether safe conduct promised by gesture had the same status as that promised by speech, said, "Yes. I think that one can request an army not to kill someone by gesturing for safe conduct, because as far as I am concerned, gesture has the same status as speech. I have heard that Abdullah ibn Abbas said, 'There is no people who betray a pledge, but that Allah gives their enemies power over them.' "


Malik :: Jihad :: [21-21.5.13]

Jihad

Malik :: Book 21 : Hadith 21.5.13

Yahya related to me from Malik from Nafi that when Abdullah ibn Umar gave something in the way of Allah, he would say to its owner, "When you reach Wadi'l-Qura, (on the outskirts of Madina) then it is your affair."


Malik :: Jihad :: [21-21.5.14]

Jihad

Malik :: Book 21 : Hadith 21.5.14

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab used to say, "When a man is given something to use in a military expedition, and he brings it to the battlefield, it is his."

Malik was asked about a man who pledged himself to go on a military campaign, equipped himself,and when he wanted to go out, one or both of his parents prevented him. He said, "He should not contradict them. Let him put it off for another year. As for the equipment, I think that he should store it until he needs it. If he fears that it will spoil, let him sell it and keep its price so that he can readily buy what is needed fora military expedition. If he is well-to-do, he will find the like of his equipment when he goes out, so let him do what he likes with his equipment."


Malik :: Jihad :: [21-21.6.15]

Jihad

Malik :: Book 21 : Hadith 21.6.15

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, sent a raiding party which included Abdullah ibn Umar near Najd. They plundered many camels and their portions were twelve or eleven camels each. They divided it up camel by camel.


Malik :: Jihad :: [21-21.6.16]

Jihad

Malik :: Book 21 : Hadith 21.6.16

Yahya related to me from Malik from Yahya ibn Said that he heard Said ibn al-Musayyab say, "When people in military expeditions divided the spoils, they made a camel equal to ten sheep."

Malik said about the paid labourer in military expeditions, "If he is present at the battle and is with the people in the battle and he is a free man, he has his share. If he is not present, he has no share."

Malik summed up, "I think that the booty is only divided among free men who have been present at the battle. "


Malik :: Jihad :: [21-21.7.16]

Jihad

Malik :: Book 21 : Hadith 21.7.16

Malik said about enemy soldiers who were found on the seashore of a Muslim land, and they claimed that they were merchants and that the sea had driven them ashore, while the Muslims were not able to verify any of that except that their ships were damaged, or they were thirsty and had disembarked without the permission of the Muslims, "I think that it is up to the imam to give his opinion about them, and I do not think that the tax of one fifth is taken from them."


Malik :: Jihad :: [21-21.8.16]

Jihad

Malik :: Book 21 : Hadith 21.8.16

Malik said, "I do not see that there is any harm in the Muslims eating whatever food they come across in enemy territory before the spoils are divided."

Malik said, "I think that any camels, cattle and sheep (taken as booty) are considered as food which the Muslims can eat in enemy territory. If they could not be eaten until the people had gathered for the division and the spoils had been distributed among them, that would be harmful for the army. I do not see any objection to eating such things within acceptable limits. I do not think, however, that anyone should store up any of it to take back to his family."

Malik was asked whether it was proper for a man who obtained food in enemy territory and ate some of it and made provision so that there was some of it left over to keep and eat with his family, or to sell before he had come to his country and make use of its price. He said, "If he sells it while he is on a military expedition, I think that he should put its price into the booty of the Muslims. If he takes it back to his country, I see no objection to his eating it and using it if it is a small insignificant thing."


Malik :: Jihad :: [21-21.9.17]

Jihad

Malik :: Book 21 : Hadith 21.9.17

Yahya related to me from Malik that it reached him that a slave of Abdullah ibn Umar escaped and one of his horses wandered off, and the idol worshippers seized them. Then the Muslims recaptured them, and they were returned to Abdullah ibn Umar, before the division of the spoils took place.

I heard Malik say about muslim property that had been seized by the enemy, "If it is noticed before the distribution, then it is returned to itsowner. Whatever has already been distributed is not returned to anyone."

Malik, when asked about a man whose young male slave was taken by the idol worshippers and then the Muslims re-captured him, said, "The owner is more entitled to him without having to pay his price or value or having to incur any loss before the distribution takes place. If the distribution has already taken place then I think that the slave belongs to his master for his price if the master wants him back."

Regarding an umm walad of a Muslim man who has been taken by the idol worshippers and then recaptured by the Muslims and allotted in the distribution of spoils and then recognised by her master after the distribution, Malik said, "She is not to be enslaved. I think that the Imam should pay a ransom for her for her master. If he does not do it, then her master must pay a ransom for her and not leave her. I do not think that she should be made a slave by whoever takes her and intercourse with her is not halal. She is in the position of a free woman because her master would be required to pay compensation if she injured somebody and so she is in the same position (as a wife). He must not leave the mother of his son to be enslaved nor may intercourse with her be made halal."

Malik was asked about a man who went to enemy territory to pay ransom or to trade, and he bought a free man or a slave, or they were given to him. He said, "As for the free man, the price he buys him for is a debt against the man and he is not made a slave. If the captive is given to him freely, he is free and owes nothing unless the man gave something in recompense for him. That is a debt against the free man, the same as if a ransom had been paid for him. As for a slave, his former master can choose to take him back and pay his price to the man who bought him or he can choose to leave him, as he wishes. If he was given to the man, the former master is more entitled to him, and he owes nothing for him unless the man gave something for him in recompense. Whatever he gave for him is a loss against the master if he wants him back."


Malik :: Jihad :: [21-21.10.18]

Jihad

Malik :: Book 21 : Hadith 21.10.18

Yahya related to me from Malik from Yahya ibn Said from Amr ibn Kathir ibn Aflah from Abu Muhammad, the mawla of Abu Qatada that Abu Qatada ibn Ribi said, "We went out with the Messenger of Allah, may Allah bless him and grant him peace, in the year of Hunayn. When the armies met, the Muslims were put in disarray. I saw a man from the idol worshippers who had got the better of one of the Muslims, so I circled round and came up behind him, and struck him with a sword on his shoulder-blade. He turned to me and grabbed me so hard that I felt the smell of death in it. Then death overcame him, and he let go of me."

He continued, "I met Umar ibn al-Khattab and said to him, 'What's going on with the people?' He replied, 'The Command of Allah.' Then the people took hold of the battle and the Messenger of Allah, may Allah bless him and grant him peace, said, 'Whoever has killed one of the dead and can prove it, can strip him of his personal effects.' I stood up and said, 'Who will testify for me?' and then I sat down. The Messenger of Allah repeated, 'Whoever has killed one of the dead and can prove it, can strip him of his personal effects.' I stood up and said, 'Who will testify for me?' then I sat down. Then he repeated his statement a third time, so I stood up, and the Messenger of Allah, may Allah bless him and grant him peace, said, 'What's the matter with you, Abu Qatada?' So I related my story to him. A man said, 'He has spoken the truth, Messenger of Allah. I have the effects of that slain person with me, so give him compensation for it, Messenger of Allah.'

Abu Bakr said, 'No, by Allah! He did not intend that one of the lions of Allah should fight for Allah and His Messenger and then give you his spoils.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'He has spoken the truth, hand it over to him.' He gave it to me, and I sold the breast-plate and I bought a garden in the area of the Banu Salima with the money. It was my first property, and I acquired it in Islam."


Malik :: Jihad :: [21-21.10.19]

Jihad

Malik :: Book 21 : Hadith 21.10.19

Yahya related to me from Malik from Ibn Shihab that al-Qasim ibn Muhammad said that he had heard a man asking ibn Abbas about booty. Ibn Abbas said, "Horses are part of the booty and personal effects are as well."

Then the man repeated his question, and Ibn Abbas repeated his answer. Then the man said, "What are the spoils which He, the Blessed, the Exalted, mentioned in His Book?" He kept on asking until Ibn Abbas was on the verge of being annoyed, then Ibn Abbas said, "Do you know who this man is like? Ibn Sabigh, who was beaten by Umar ibn al-Khattab because he was notorious for asking foolish questions."

Yahya said that Malik was asked whether someone who killed one of the enemy could keep the man's effects without the permission of the Imam. He said, "No one can do that without the permission of the Imam. Only the Imam can make ijtihad. I have not heard that the Messenger of Allah, may Allah bless him and grant him peace, ever said, 'Whoever kills someone can have his effects,' on any other day than the day of Hunayn."

3


Malik :: Jihad :: [21-21.11.20]

Jihad

Malik :: Book 21 : Hadith 21.11.20

Yahya related to me from Malik from Abu'z-Zinad that Said ibn al-Musayyab said, "People used to be given bonuses from the Khumus."

Malik said, "That is the best of what I have heard on the matter."

Malik was asked about bonuses and whether they were taken from the first of the spoils, and he said, "That is only decided according to the ijtihad of the Imam. We do not have a known reliable command about that other than it is up to the ijtihad of the Sultan. I have not heard that the Messenger of Allah, may Allah bless him and grant him peace, gave bonuses in all his raids. I have only heard that he gave bonuses in one of them, namely the day of Hunayn. It depends on the ijtihad of the Imam whether they are taken from the first of the spoils or what is after it."


Malik :: Jihad :: [21-21.12.21]

Jihad

Malik :: Book 21 : Hadith 21.12.21

Yahya related to me that Malik said that he had heard that Umar ibn Abd al-Aziz used to say, "The man on horse-back has two shares, and the man on foot has one."

Malik added, "I continue to hear the same."

Malik, when asked whether a man who was present with several horses took a share for all of them, said, "I have never heard that. I think that there is only a share for the horse on which he fought."

Malik said, "I think that foreign horses and half-breeds are considered as horses because Allah, the Blessed, the Exalted, said in His Book, 'All horses, and mules, and asses, for you to ride, and as an adornment.' (Sura16 ayat 8). He said, the Mighty, the Majestic, 'Make ready for them whatever force and strings of horses you can, to terrify thereby the enemy of Allah and your enemy.' (Sura 8 ayat 60). I think that foreign breeds and half-breeds are considered as horses if the governor accepts them."

Said ibn al-Musayyab was asked about working horses, and whether there was zakat on them. He said, "Is there any zakat on horses.?"


Malik :: Jihad :: [21-21.13.22]

Jihad

Malik :: Book 21 : Hadith 21.13.22

Yahya related to me from Malik from Abd ar-Rahman ibn Said from Amr ibn Shuayb that when the Messenger of Allah, may Allah bless him and grant him peace, came back from Hunayn heading for al-Jiirrana, the people crowded around so much to question him that his she-camel backed into a tree, which became entangled in his cloak and pulled it off his back. The Messenger of Allah, may Allah bless him and grant him peace, said, "Return my cloak to me. Are you afraid that I will not distribute among you what Allah has given you as spoils. By He in whose hand my self is! Had Allah given you spoils equal to the number of acacia trees on the plain of Tihama, I would have distributed it among you. You will not find me to be miserly, cowardly, or a liar." Then the Messenger of Allah, may Allah bless him and grant him peace, got down and stood among the people, and said, "Hand over even the needle and thread, for stealing from the spoils is disgrace, fire, ignominy on the Day of Rising for people who do it." Then he took a bit of camel fluff or something from the ground and said, "By He in whose hand my self is! What Allah has made spoils for you is not mine - even the like of this! - except for the tax of one fifth, and the tax of one fifth is returned to you."


Malik :: Jihad :: [21-21.13.23]

Jihad

Malik :: Book 21 : Hadith 21.13.23

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban from Ibn Abi Amra that Zayd ibn Khalid al-Juhani said, "A man died on the day of Hunayn, and they mentioned him to the Messenger of Allah, may Allah bless him and grant him peace." Zayd claimed that the Messenger of Allah, may Allah bless him and grant him peace, said, "You pray over your companion." (i.e. he would not pray himself). The people's faces dropped at that. Zayd claimed that the Messenger of Allah, may Allah bless him and grant him peace, said, "Your companion stole from the spoils taken in the way of Allah." Zayd said, "So we opened up his baggage and found some Jews' beads worth about two dirhams."


Malik :: Jihad :: [21-21.13.24]

Jihad

Malik :: Book 21 : Hadith 21.13.24

Yahya related to me from Malik from Yahya ibn Said from Abdullah ibn al-Mughira ibn Abi Burda al-Kinani that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, came to the people in their tribes and made dua for them, but left out one of the tribes. Abdullah related, "The tribe found an onyx necklace in the saddle-bags of one of their men. The Messenger of Allah, may Allah bless him and grant him peace, came to them, and then did the takbir over them as one does the takbir over the dead."


Malik :: Jihad :: [21-21.13.25]

Jihad

Malik :: Book 21 : Hadith 21.13.25

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili from Abu'l-Ghayth Salim, the mawla of ibn Muti that Abu Hurayra said, "We went out with the Messenger of Allah, may Allah bless him and grant him peace, in the yearof Khaybar. We did not capture any gold or silver except for personal effects, clothes, and baggage. Rifaa ibn Zayd presented a black slave boy to the Messenger of Allah, may Allah bless him and grant him peace, whose name was Midam. The Messenger of Allah, may Allah bless him and grant him peace, made for Wadi'l-Qura, and when he arrived there, Midam was unsaddling the camel of the Messenger of Allah, may Allah bless him and grant him peace, when a stray arrow struck and killed him. The people said, 'Good luck to him! The Garden!' The Messenger of Allah said, 'No! By He in whose hand my self is! The cloak which he took from the spoils on the Day of Khaybar before they were distributed will blaze with fire on him.' When the people heard that, a man brought a sandal-strap or two sandal-straps to the Messenger of Allah, may Allah bless him and grant him peace. The Messenger of Allah, may Allah bless him and grant him peace, said, 'A sandal-strap or two sandal-straps of fire!' "


Malik :: Jihad :: [21-21.13.26]

Jihad

Malik :: Book 21 : Hadith 21.13.26

Yahya related to me from Malik from Yahya ibn Said that he had heard that Abdullah ibn Abbas said, "Stealing from the spoils does not appear in a people but that terror is cast into their hearts. Fornication does not spread in a people but that there is much death among them. A people do not lessen the measure and weight but that provision is cut off from them. A people do not judge without right but that blood spreads among them. A people do not betray the pledge but that Allah gives their enemies power over them."


Malik :: Jihad :: [21-21.14.27]

Jihad

Malik :: Book 21 : Hadith 21.14.27

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "By He in whose hand my self is! I would like to fight in the way of Allah and be killed, then be brought to life again so I could be killed, and then be brought to life again so I could be killed." Abu Hurayra said three times, "I testify to it by Allah!"


Malik :: Jihad :: [21-21.14.28]

Jihad

Malik :: Book 21 : Hadith 21.14.28

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Allah laughs at two men. One of them kills the other, but each of them will enter the Garden: one fights in the way of Allah and is killed, then Allah turns to the killer, so he fights (in the way of Allah) and also becomes a martyr."


Malik :: Jihad :: [21-21.14.29]

Jihad

Malik :: Book 21 : Hadith 21.14.29

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "By He in whose hand my self is! None of you is wounded in the way of Allah - and Allah knows best who is wounded in HisWay, but that when the Day of Rising comes, blood will gush forth from his wound. It will be the colour of blood, but its scent will be that of musk."


Malik :: Jihad :: [21-21.14.30]

Jihad

Malik :: Book 21 : Hadith 21.14.30

Yahya related to me from Malik from Zayd ibn Aslam that Umar ibn al-Khattab used to say, "O Allah! Do not let me be slain by the hand of a man who has prayed a single prostration to You with which he will dispute with me before You on the Day of Rising!"


Malik :: Jihad :: [21-21.14.31]

Jihad

Malik :: Book 21 : Hadith 21.14.31

Yahya related to me from Malik from Yahya ibn Said from Said al-Maqburi from Abdullah ibn Abi Qatada that his father had said that a man came to the Messenger of Allah, may Allah bless him and grant him peace, and said, "O Messenger of Allah! If I am killed in the way of Allah, expectant for reward, sincere, advancing, and not retreating, will Allah pardon my faults?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes." When the man turned away, the Messenger of Allah, may Allah bless him and grant him peace, called him - or commanded him and he was called to him. The Messenger of Allah, may Allah bless him and grant him peace, said to him, "What did you say?" He repeated his words to him, and the Prophet, may Allah bless him and grant him peace, said to him, "Yes, except for the debt. Jibril said that to me."


Malik :: Jihad :: [21-21.14.32]

Jihad

Malik :: Book 21 : Hadith 21.14.32

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said over the martyrs of Uhud, "I testify for them." Abu Bakr as-Siddiq said, "Messenger of Allah! Are we not their brothers? We entered Islam as they entered Islam and we did jihad as they did jihad." The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes, but I do not know what you will do after me." Abu Bakr wept profusely and said, "Are we really going to out-live you!"


Malik :: Jihad :: [21-21.14.33]

Jihad

Malik :: Book 21 : Hadith 21.14.33

Yahya related to me from Malik that Yahya ibn Said said, "The Messenger of Allah, may Allah bless him and grant him peace, was sitting by a grave which was being dug at Madina. A man looked into the grave and said, 'An awful bed for the mumin. 'The Messenger of Allah, may Allah blesshim and grant him peace, said, 'Evil? What you have said is absolutely wrong.'

The man said, 'I didn't mean that, Messenger of Allah. I meant being killed in the way of Allah.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Being killed in the way of Allah has no like! There is no place on the earth which I would prefer my grave to be than here (meaning Madina). He repeated it three times.' "


Malik :: Jihad :: [21-21.15.34]

Jihad

Malik :: Book 21 : Hadith 21.15.34

Yahya related to me from Malik from Zayd ibn Aslam that Umar ibn al-Khattab used to say, "O Allah! I ask you for martyrdom in Your way and death in the city of Your Messenger!"


Malik :: Jihad :: [21-21.15.35]

Jihad

Malik :: Book 21 : Hadith 21.15.35

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab said, "The nobility of the mumin is his taqwa. His deen is his noble descent. His manliness is his good character. Boldness and cowardice are but instincts which Allah places wherever He wills. The coward shrinks from defending even his father and mother, and the bold one fights for the sake of the combat not for the spoils. Being slain is but one way of meeting death, and the martyr is the one who gives himself, expectant of reward from Allah."


Malik :: Jihad :: [21-21.16.36]

Jihad

Malik :: Book 21 : Hadith 21.16.36

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab was washed and shrouded and prayed over, yet he was a martyr, may Allah have mercy on him .


Malik :: Jihad :: [21-21.16.37]

Jihad

Malik :: Book 21 : Hadith 21.16.37

Yahya related to me from Malik that he had heard the people of knowledge say that martyrs in the way of Allah were not washed, nor were any of them prayed over. They were buried in the garments in which they were slain.

Malik said, "That is the sunna for someone who is killed on the battleground and is not reached until he is already dead. Someone who is carried off and lives for as long as Allah wills after it, is washed and prayed over as was Umar ibn al-Khattab."


Malik :: Jihad :: [21-21.17.38]

Jihad

Malik :: Book 21 : Hadith 21.17.38

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab in one year gave 40,000 camels as mounts. Sometimes he would give one man a camel to himself. Sometimes he would give one camel between two men to take them to Iraq. A man from Iraq came to him and said, "Give Suhaym and I a mount.''Umar ibn al-Khattab said to him,"l demand from you, by Allah!, is Suhaym a water skin?" He said, "Yes."


Malik :: Jihad :: [21-21.18.39]

Jihad

Malik :: Book 21 : Hadith 21.18.39

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik had said that when the Messenger of Allah, may Allah bless him and grant him peace, went to Quba, he visited Umm Haram bint Milhan and she fed him. Umm Haram was the wife of Ubada ibn as-Samit. One day the Messenger of Allah, may Allah bless him and grant him peace, had called on her and she had fed him, and sat down to delouse his hair. The Messenger of Allah, may Allah bless him and grant him peace, had dozed and woke up smiling. Umm Haram said, "What is making you smile, Messenger of Allah?" He said, "Some of my community were presented to me, raiding in the way of Allah. They were riding in the middle of the sea, kings on thrones, or like kings on thrones." (Ishaq wasn't sure). She said, "O Messenger of Allah! Ask Allah to put me among them!" So he had made a dua for her, and put his head down and slept. Then he had woken up smiling, and she said to him, "Messenger of Allah, why are you smiling?" He said, "Some of my community were presented to me, raiding in the way of Allah. They were kings on thrones or like kings on thrones," as he had said in the first one. She said, "O Messenger of Allah! Ask Allah to put me among them!" He said, "You are among the first."

Ishaq added, "She travelled on the sea in the time of Muawiya, and when she landed, she was thrown from her mount and killed."


Malik :: Jihad :: [21-21.18.40]

Jihad

Malik :: Book 21 : Hadith 21.18.40

Yahya related to me from Malik from Yahya ibn Said from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Had I not been concerned for my community, I would have liked never to stay behind a raiding party going out in the way of Allah. However, I do not find the means to carry them to it, nor do they find anything on which to ride out and it is grievous for them that they should stay behind me. I would like to fight in the way of Allah and be killed, then brought to life so I could be killed and then brought to life so I could be killed."


Malik :: Jihad :: [21-21.18.41]

Jihad

Malik :: Book 21 : Hadith 21.18.41

Yahya related to me from Malik that Yahya ibn Said said, "On the Day of Uhud, The Messenger of Allah, may Allah bless him and grant him peace, said, 'Who will bring me news of Sad ibn al-Rabi al-Ansari?' a man said, 'Me, Messenger of Allah!' So the man went around among the slain, and Sad ibn al-Rabi said to him, 'What are you doing?' The man said to him, 'The Messenger of Allah, may Allah bless him and grant him peace, sent me to bring him news of you.' He said, 'Go to him, and give him my greetings, and tell him that I have been stabbed twelve times, and am mortally wounded. Tell your people that they will have no excuse with Allah if the Messenger of Allah, may Allah bless him and grant him peace, is slain while one of them is still alive.' "


Malik :: Jihad :: [21-21.18.42]

Jihad

Malik :: Book 21 : Hadith 21.18.42

Yahya related to me from Malik from Yahya ibn Said that the Messenger of Allah, may Allah bless him and grant him peace, stimulated people for jihad and mentioned the Garden. One of the Ansar was eating some dates in his hand, and said, "Am I so desirous of this world that I should sit until I finish them?" He threw aside what was in his hand and took his sword, and fought until he was slain .


Malik :: Jihad :: [21-21.18.43]

Jihad

Malik :: Book 21 : Hadith 21.18.43

Yahya related to me from Malik from Yahya ibn Said that Muadh ibn Jabal said, "There are two military expeditions. There is one military expedition in which valuables are spent, the contributor is willing, the authorities are obeyed, and corruption is avoided. That military expedition is all good. There is a military expedition in which valuables are not spent, the contributor is not willing, the authorities are not obeyed, and corruption is not avoided. The one who fights in that military expedition does not return with reward."


Malik :: Jihad :: [21-21.19.44]

Jihad

Malik :: Book 21 : Hadith 21.19.44

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Blessing is in the forelocks of horses until the Day of Rising."


Malik :: Jihad :: [21-21.19.45]

Jihad

Malik :: Book 21 : Hadith 21.19.45

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, held a race between horses which had been made lean by training, from al-Hafya to Thaniyatu-lWada. He held a race between horses which had not been made lean from the Thaniya (a mountain pass near Madina) to the mosque of the Banu Zurayq. Abdullah ibn Umar was among those who raced them .


Malik :: Jihad :: [21-21.19.46]

Jihad

Malik :: Book 21 : Hadith 21.19.46

Yahya related to me from Malik that Yahya ibn Said heard Said ibn al-Musayyab say, "There is no harm in placing stakes on horses if a third horse enters it. The winner takes the stake, and there is no fine against the loser."


Malik :: Jihad :: [21-21.19.47]

Jihad

Malik :: Book 21 : Hadith 21.19.47

Yahya related to me from Malik from Yahya ibn Said that the Messenger of Allah, may Allah bless him and grant him peace, was seen wiping the face of his horse with his cloak. He was questioned about it and said, "I was reproached in the night about horses." i.e. not taking care of them.


Malik :: Jihad :: [21-21.19.48]

Jihad

Malik :: Book 21 : Hadith 21.19.48

Yahya related to me from Malik from Humayd at-Tawil from Anas ibn Malik that when the Messenger of Allah, may Allah bless him and grant him peace, went out to Khaybar, he arrived there at night, and when he came upon a people by night, he did not attack until morning. In the morning, the jews came out with their spades and baskets. When they saw him, they said, "Muhammad! By Allah, Muhammad and his army!" The Messenger of Allah, may Allah bless him and grant him peace, said "Allah is greater! Khaybar is destroyed. When we come to a people, it is an evil morning for those who have been warned . "


Malik :: Jihad :: [21-21.19.49]

Jihad

Malik :: Book 21 : Hadith 21.19.49

Malik was asked whether, when an imam had accepted jizya from a people and they gave it, he thought that the land of one of them who surrendered belonged to him or whether his land and property belonged to the Muslims. Malik said, "That varies. As for the people of peace, if one of them surrenders, then he is entitled to his land and property. As for the people of force who use force, if one of them surrenders, his land and property belong to the Muslims because the people of force are overcome in their towns, and it becomes booty for the Muslims. As for the people of peace, their property and selves are protected so that they make peace for them. Only what they have made peace for is obliged of them."


Malik :: Jihad :: [21-21.20.50]

Jihad

Malik :: Book 21 : Hadith 21.20.50

Yahya related to me from Malik from Abd ar-Rahman ibn Abi Sasaca that he had heard that Amr ibn al-Jamuh al-Ansari and Abdullah ibn Umar al-Ansari, both of the tribe of Banu Salami, had their grave uncovered by a flood. Their grave was part of what was left after the flood. They were in the same grave, and they were among those martyred at Uhud. They were dug up so that they might be moved. They were found unchanged. It was as if they had died only the day before. One of them had been wounded, and he had put his hand over his wound and had been buried like that. His hand was pulled away from his wound and released, and it returned to where it had been. It was forty-six years between Uhud and the day they were dug up.

Malik said, "There is no harm in burying two or three men in the same grave due to necessity. The oldest one is put next to the qibla."


Malik :: Jihad :: [21-21.20.51]

Jihad

Malik :: Book 21 : Hadith 21.20.51

Yahya related to me from Malik that Rabia ibn Abi Abd ar-Rahman said, "Property was sent to Abu Bakr as-Siddiq from Bahrayn. He said, 'If someone had a promise or a pledge with the Messenger of Allah, may Allah bless him and grant him peace, let him come to me.' So Jabir ibn Abdullah came to him, and he gave him three times as much of it as would fill both hands.''


Malik :: Vows and Oaths :: [22-22.1.1]

Vows and Oaths

Malik :: Book 22 : Hadith 22.1.1

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Abdullah ibn Abbas that Sad ibn Ubada questioned the Messenger of Allah, may Allah bless him and grant him peace, and said,"My mother died while she still had a vow which she had not fulfilled." The Messenger of Allah, may Allah bless him and grant him peace, said, "Fulfill it for her."


Malik :: Vows and Oaths :: [22-22.1.2]

Vows and Oaths

Malik :: Book 22 : Hadith 22.1.2

Yahya related to me from Malik from

Abdullah ibn Abi Bakr that his paternal aunt related that her grandmother made a vow to walk to the Quba mosque. She died, and did not fulfill it, so Abdullah ibn Abbas asked her daughter to walk for her.

Yahya said that he had heard Malik say, "No one walks for anyone else."


Malik :: Vows and Oaths :: [22-22.1.3]

Vows and Oaths

Malik :: Book 22 : Hadith 22.1.3

Yahya related to me from Malik that Abdullah ibn Abi Habiba said, "I said to a man, when I was young, 'A man who only says that he must walk to the House of Allah and does not say that he has vowed to walk, does not have to walk.' A man said, 'Shall I give you this small cucumber?' and he had a small cucumber in his hand and you will say, 'I must walk to the house of Allah?' I said, 'Yes' and I said it, for at that time I was still immature. Then, when I came of age, some one said to me that I had to fulfill my vow. I went and asked Said ibn al-Musayyab about it, and he said to me, 'You must walk.' So I walked."

Malik said, "That is the custom among us."


Malik :: Vows and Oaths :: [22-22.2.4]

Vows and Oaths

Malik :: Book 22 : Hadith 22.2.4

Yahya related to me from Malik that Urwa ibn Udhayna al-Laythi said, "I went out with my grandmother who had vowed to walk to the House of Allah. When we had gone part of the way, she could not go on. I sent one of her mawlas to question Abdullah ibn Umar and I went with him. He asked Abdullah ibn Umar, and Abdullah ibn Umar said to him, 'Take her and let her ride, and when she has the strength let her ride back, and start to walk from the place from which she was unable to go on.'~

Yahya said that he had heard Malik say, "I think that she must sacrifice an animal."

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Abu Salama ibn Abd ar-Rahman said the same as Abdullah ibn Umar.


Malik :: Vows and Oaths :: [22-22.2.5]

Vows and Oaths

Malik :: Book 22 : Hadith 22.2.5

Yahya related to me from Malik that Yahya ibn Said said, "I vowed to walk, but I was struck by a pain in the kidney, so I rode until I came to Makka. I questioned Ata ibn Abi Rabah and others, and they said, 'You must sacrifice an animal.' When I came to Madina I questioned the ulama there, and they ordered me to walk again from the place from which I was unable to go on. So I walked."

Yahya said that he had heard Malik say, "What is done among us regarding someone who makes a vow to walk to the House of Allah, and then cannot do it and so rides, is that he must return and walk from the place from which he was unable to go on. If he cannot walk, he should walk what he can and then ride, and he must sacrifice a camel, a cow, or a sheep if that is all that he can find."

Malik, when asked about a man who said to another, "I will carry you to the House of Allah", answered, "If he intended to carry him on his shoulder, by that he meant hardship and exhaustion to himself, and he does not have to do that. Let him walk by foot and make sacrifice. If he did not intend anything, let him do hajj and ride, and take the man on hajj with him. That is because he said, 'I will carry you to the house of Allah.' If the man refuses to do hajj with him, then there is nothing against him, and what is demanded of him is cancelled."

Yahya said that Malik was asked whether it was enough for a man who had made a vow that he would walk to the House of Allah a certain (large) number of times, or who had forbidden himself from talking to his father and brother, if he did not fulfil a certain vow, and he had taken upon himself, by the oath, something which he was incapable of fulfilling in his lifetime, even though he were to try every year, to fulfil only one or a (smaller) number of vows by Allah? Malik said, "The only satisfaction for that that I know is fulfilling what he has obliged himself to do. Let him walk for as long as he is able and draw near Allah the Exalted by what he can of good."


Malik :: Vows and Oaths :: [22-22.3.5]

Vows and Oaths

Malik :: Book 22 : Hadith 22.3.5

Yahya related to me from Malik that what he preferred of what he had heard from the people of knowledge about a man or woman who vowed to walk to the House of Allah, was that they fulfilled the oath when performing umra, by walking until they had done say between Safa and Marwa. When they had done say it was finished. If they vowed to walk in the hajj, they walked until they came to Makka, then they walked until they had finished all the rites.

Malik said, "Walking is only for hajj or umra."


Malik :: Vows and Oaths :: [22-22.4.6]

Vows and Oaths

Malik :: Book 22 : Hadith 22.4.6

Yahya related to me from Malik that Humayd ibn Qays and Thawr ibn Zayd adDili both informed him that the Messenger of Allah, may Allah bless him and grant him peace, (and one of them gave more detail than the other),saw a man standing in the sun. The Messenger asked, "What's wrong with him?" The people said, "He has vowed not to speak or to seek shade from the sun or to sit and to fast." The Messenger of Allah, may Allah bless him and grant him peace, said, "Go and tell him to speak, seek shade, and sit, but let him complete his fast."

Malik said, "I have not heard that the Messenger of Allah, may Allah bless him and grant him peace, ordered the man in question to do any kaffara. The Messenger of Allah, may Allah bless him and grant him peace, only ordered him to complete that in which there was obedience to Allah and to abandon that in which there was disobedience to Allah."


Malik :: Vows and Oaths :: [22-22.4.7]

Vows and Oaths

Malik :: Book 22 : Hadith 22.4.7

Yahya related to me from Malik that Yahya ibn Said heard al-Qasim ibn Muhammad say, "A woman came to Abdullah ibn Abbas and said, 'I have vowed to sacrifice my son.' Ibn Abbas said, 'Do not sacrifice your son. Do kaffara for your oath.' An old man with Ibn Abbas said, 'What kaffara is there for this?' Ibn Abbas said, 'Allah the Exalted said, "Those of you who say, regarding their wives.'Be as my mother's back' (Sura58 ayat 2) and then He went on to oblige the kaffara for it as you have seen.' "


Malik :: Vows and Oaths :: [22-22.4.8]

Vows and Oaths

Malik :: Book 22 : Hadith 22.4.8

Yahya related to me from Malik from Talha ibn Abi al-Malik al-Ayli from al-Qasim ibn Muhammad ibn as-Siddiq from A'isha that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever vows to obey Allah, let him obey Him. Whoever vows to disobey Allah, let him not disobey Him."

Yahya said that he had heard Malik say, "The meaning of the statement of the Prophet, may Allah bless him and grant him peace, 'Whoever vows to disobey Allah, let him not disobey Him' is that for instance a man who vows that, if he speaks to such-and-such a person, he will walk to Syria, Egypt, or any other such things which are not considered as ibada, is not under any obligation by any of that, even if he did speak to the man or did break whatever it was he swore, because Allah does not demand obedience in such things. He should only fulfill those things in which there is obedience to Allah."

22.5 Rashness in Oaths


Malik :: Vows and Oaths :: [22-22.4.9]

Vows and Oaths

Malik :: Book 22 : Hadith 22.4.9

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin said, "Rashness in oaths is that a man says, 'By Allah, No! by Allah!' " i.e. out of habit.

Malik said, "The best of what I have heard on the matter is that rashness in oaths is that a man take an oath on something to show that he is certain that it is like he said, only to find that it is other than what he said. This is rashness."

Malik said, "The binding oath is for example, that a man says that he will not sell his garment for ten dinars, and then he sells it for that, or that he will beat his young slave and then does not beat him, and so on. One does kaffara for making such an oath, and there is no kaffara in rashness."

Malik said, "As for the one who swears to a thing which he knows is wicked, and he swears to a lie he knows to be a lie, in order to please someone with it or to excuse himself to someone by it or to gain money by it, no kaffara that he does for it can cover it."


Malik :: Vows and Oaths :: [22-22.5.10]

Vows and Oaths

Malik :: Book 22 : Hadith 22.5.10

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "Whoever swears by Allah and then says, 'Allah willing' and then does not do what he has sworn to, has not broken his oath."

Malik said, "The best I have heard on this reservation is that it belongs to the statement made if the speaker does not break the normal flow of speech before he is silent. If he is silent and breaks the flow of speech, he has no exception."

Yahya said, "Malik said that a man who said that he had disbelieved or associated something with Allah and then he broke his oath, had no kaffara, and he was not a disbeliever or one who associated something with Allah unless his heart concealed something of either of those. He should ask forgiveness of Allah and not return to it - for what he did was evil."


Malik :: Vows and Oaths :: [22-22.6.11]

Vows and Oaths

Malik :: Book 22 : Hadith 22.6.11

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever makes an oath and then sees that something else would be better than it, should do kaffara for his oath and do what is better."

Yahya said that he heard Malik say, "Anyone who says that he has a vow but does not mention the name of Allah, is still obliged to make the kaffara for an oath (if he breaks it)".

Malik said, "Emphasis is when a man swears one thing several times, repeating the oath in his speech time after time. For instance, the statement, 'By Allah, I will not decrease it from such-and-such,' sworn three times or more. The kaffara of that is like the kaffara of one oath. If a man swears, 'I will not eat this food or wear these clothes or enter this house,' that is all in one oath, and he is only obliged to do one kaffara. It is the same for a man who says to his wife, 'You are divorced if I clothe you in this garment or let you go to the mosque,' and it is one entire statement in the normal pattern of speech. If he breaks any of that oath, divorce is necessary, and there is no breaking of oath after that in whatever he does. There is only one oath to be broken in that."

Malik said, "What we do about a woman who makes a vow without her husband's permission is that she is allowed to do so and she must fulfill it, if it only concerns her own person and will not harm her husband. If, however, it will harm her husband, he may forbid her to fulfill it, but it remains an obligation against her until she has the opportunity to complete it."


Malik :: Vows and Oaths :: [22-22.7.12]

Vows and Oaths

Malik :: Book 22 : Hadith 22.7.12

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "If someone breaks an oath which he has stressed, he has to free a slave, or clothe ten poor people. If someone breaks an oath, but has not stressed it, he only has to feed ten poor people and each poor person is fed a mudd of wheat. Some one who does not have the means for that, should fast for three days."


Malik :: Vows and Oaths :: [22-22.7.13]

Vows and Oaths

Malik :: Book 22 : Hadith 22.7.13

Yahya related to me from Malik from Nafi that Abdullah ibn Umar used to do kaffara for a broken oath by feeding ten poor people. Each person got a mudd of wheat. He sometimes freed a slave if he had repeated the oath.

Yahya related to me from Malik from Yahya ibn Said that Sulayman ibn Yasar said, "I understood from people that when they made the kaffara for a broken oath, they gave a mudd of wheat according to the smaller mudd. They thought that that would compensate for them."

Malik said, "The best of what I have heard about the one who does kaffara for breaking his oath by clothing people is that if he clothes men he clothes them each in one garment. If he clothes women, he clothes them each in two garments, a long shift and a long scarf, because that is what is satisfactory for each of them in the prayer."


Malik :: Vows and Oaths :: [22-22.8.14]

Vows and Oaths

Malik :: Book 22 : Hadith 22.8.14

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that one time the Messenger of Allah, may Allah bless him and grant him peace, was speaking to Umar ibn al-Khattab while he was travelling with a troop and Umar swore by his father and he (the Messenger) said, "Allah forbids you to swear by your fathers. If anyone swears, let him swear by Allah or keep silent."


Malik :: Vows and Oaths :: [22-22.8.15]

Vows and Oaths

Malik :: Book 22 : Hadith 22.8.15

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, used tosay, "No, by the Overturner of hearts."


Malik :: Vows and Oaths :: [22-22.8.16]

Vows and Oaths

Malik :: Book 22 : Hadith 22.8.16

Yahya related to me from Malik from Uthman ibn Hafs ibn Umar ibn Khalda that Ibn Shihab had heard that Abu Lubaba ibn Abd al-Mundhir, when Allah turned to him said, "Messenger of Allah, should I leave my people's house in which I committed wrong action and keep your company, and give away all my property as sadaqa for Allah and His Messenger? "The Messenger of Allah, may Allah bless him and grant him peace, said, "Giving away a third of it is enough for you."


Malik :: Vows and Oaths :: [22-22.8.17]

Vows and Oaths

Malik :: Book 22 : Hadith 22.8.17

Yahya related to me from Malik from Ayyub ibn Musa from Mansur ibn Abd ar-Rahman al-Hajabi from his mother that A'isha, umm al-muminin, may Allah be pleased with her, was asked about a man who devoted his property to the door of Kaba. She said, "Let him do kaffara for it with the kaffara of the oath."

Malik said, that someone who devoted all his property in the way of Allah, and then broke his oath, should put a third of his property in the way of Allah, as that was what the Messenger of Allah, may Allah bless him and grant him peace, did in the case of Abu Lubaba.


Malik :: Sacrificial Animals :: [23-23.1.1]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.1.1

Yahya related to me from Malik from Amr ibn al-Harith from Ubayd ibn Fayruz from al-Bara ibn Azib that the Messenger of Allah, may Allah bless him and grant him peace, was asked what animals should be avoided as sacrifices. He indicated with his hand and said, "Four." Al-Bara pointed with his hand and said, "My hand is shorter than the hand of the Messenger of Allah, may Allah bless him and grant him peace. A lame animal whose lameness is evident, a one-eyed animal which is clearly one-eyed, an animal which is clearly ill, and an emaciated animal with no fat on it."


Malik :: Sacrificial Animals :: [23-23.1.2]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.1.2

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would guard against animals and camels which were young or had physical defects as sacrifices.

Malik said, "That is what I like best of what I have heard ."


Malik :: Sacrificial Animals :: [23-23.2.3]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.2.3

Yahya related to me from Malik from Nafi that one time Abdullah ibn Umar wanted to sacrifice an animal at Madina. Nafi said, "He told me to buy him an excellent horned ram, then to sacrifice it on the Day of Sacrifice in the place where the people prayed." Nafi continued, "I did so and when the ram was sacrificed, it was carried to Abdullah ibn Umar who shaved his head. He was ill, and did not attend the Id with the people." Nafi added, "Abdullah ibn Umar used to say, 'Shaving the head is not obligatory for someone who sacrifices an animal.' Ibn Umar would do so however."


Malik :: Sacrificial Animals :: [23-23.3.4]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.3.4

ahya related to me from Malik from Yahya ibn Said from Bushayr ibn Yasar that Abu Burda ibn Niyar sacrificed an animal before the Messenger of Allah, may Allah bless him and grant him peace, sacrificed on the Day of Sacrifice. He asserted that the Messenger of Allah, may Allah bless him and grant him peace, ordered him to sacrifice another animal, and he, Abu Burda, said, "What if I can only find an animal less than one year old, Messenger of Allah?" He had said, "If you can only find a young animal, then sacrifice it."


Malik :: Sacrificial Animals :: [23-23.3.5]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.3.5

Yahya related to me from Malik from Yahya ibn Said from Abbad ibn Tamin that one time Uwaymir ibn Ashqar sacrificed his animal before the prayer on the morning of the Day of Sacrifice, and he mentioned that the Messenger of Allah, may Allah bless him and grant him peace, had ordered him to sacrifice another animal.


Malik :: Sacrificial Animals :: [23-23.4.6]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.4.6

Yahya related to me from Malik from Abu'z-Zubayr al-Makki from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, forbade that the meat from sacrificial animals be eaten after three days. Then later he said, "Eat, give sadaqa, provide for yourselves and store up."


Malik :: Sacrificial Animals :: [23-23.4.7]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.4.7

Yahya related to me from Malik from Abdullah ibn Abi Bakr that Abdullah ibn Waqid said, "The Messengerof Allah, may Allah bless him and grant him peace, forbade eating the meat from sacrificial animals after three days."

Abdullah ibn Abi Bakr said, "I mentioned that to Amra bint Abd ar-Rahman, and she affirmed that he had spoken the truth as she had heard A'isha, the wife of the Prophet, may Allah bless him and grant him peace, say, 'Some people from the desert came at the time of the sacrifice in the time of the Messenger of Allah, may Allah bless him and grant him peace, so the Messenger of Allah, may Allah bless him and grant him peace, said, 'Store up for three days, and give what is left over as sadaqa.' "

She said that afterwards some one said to the Messenger of Allah, may Allah bless him and grant him peace, that people had been accustomed to make use of their sacrificial animals, melting the fat and curing the skins. The Messenger of Allah, may Allah bless him and grant him peace, said, "What about that?" They said, "You have forbidden the meat of sacrificial animals after three days." The Messenger of Allah, may Allah bless him and grant him peace, said, "I only forbade you for the sake of the people who were coming to you. Eat, give sadaqa and store up."

By these people, he meant the poor people who were coming to Madina.


Malik :: Sacrificial Animals :: [23-23.4.8]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.4.8

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that Abu Said alKhudri returned from a journey and his family gave him some meat. He asked whether it was meat from the sacrifice. They replied that it was. Abu Said said, "Didn't the Messenger of Allah, may Allah bless him and grant him peace, forbid that?" They said, "There has been a new command from the Messenger of Allah, may Allah bless him and grant him peace, since you went away." Abu Said went out and made enquiries about it and was told that the Messenger of Allah, may Allah bless him and grant him peace, had said,"I forbade you before to eat meat of the sacrifice after three days, but now eat, give sadaqa and store up. I forbade you before to make nabidh (by soaking raisins or dates in water), but now make nabidh, but remember every intoxicant is haram .I forbade you to visit graves, but now visit them, and do not use bad language."


Malik :: Sacrificial Animals :: [23-23.5.9]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.5.9

Yahya related to me from Malik from Abu'z-Zubayr al-Makki that Jabir ibn Abdullah said, "We sacrificed with the Messenger of Allah, may Allah bless him and grant him peace, in the year of Hudaybiya, a camel between seven people, and a cow between seven people."


Malik :: Sacrificial Animals :: [23-23.5.10]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.5.10

Yahya related to me from Malik from Umara ibn Yasar that Ata ibn Yasar told him that Abu Ayyub al-Ansari had told him, "We used to sacrifice one sheep, and a man sacrificed for himself and his family. Then later on people began to compete with each other and it became boasting."

Malik said, "The best that I have heard about a single camel, cow or sheep, is that a man should sacrifice a camel for himself and his family. He sacrifices a cow or sheep which he owns for his family, and shares with them in it. It is disapproved for a group of people to buy a camel, cow or sheep, to share for the ritual and sacrifices, each man giving a share of its price, and taking a share of its meat. We have heard the tradition that people do not share in the ritual. However, it may be that the people of one household can share."


Malik :: Sacrificial Animals :: [23-23.5.11]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.5.11

Yahya related to me from Malik that Ibn Shihab said, "The Messenger of Allah, may Allah bless him and grant him peace, only sacrificed one camel or one cow for himself and his family."

Malik said, "I do not know which of them Ibn Shihab said."


Malik :: Sacrificial Animals :: [23-23.6.12]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.6.12

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "The sacrifice can be done up to two days after the Day of Sacrifice."

Yahya related to me from Malik that he had heard the same from Ali ibn Abi Talib.


Malik :: Sacrificial Animals :: [23-23.6.13]

Sacrificial Animals

Malik :: Book 23 : Hadith 23.6.13

Yahya related to me from Malik from Nafi that Abdullah ibn Umar did not sacrifice for the child in the womb.

Malik said, "The sacrifice is sunna, and it is not obligatory. I prefer that anyone who has the price of the animal should not abandon it.''


Malik :: Slaughtering Animals :: [24-24.1.1]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.1.1

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "The Messenger of Allah, may Allah bless him and grant him peace, was asked, 'Messenger of Allah! Some people from the desert bring us meat, and we do not know whether the name of Allah has been mentioned over it or not.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Mention the name of Allah over it and eat.' "

Malik said, "That was in the beginning of Islam."


Malik :: Slaughtering Animals :: [24-24.1.2]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.1.2

Yahya related to me from Malik from Yahya ibn Said that Abdullah ibn Ayyash ibn Abi Rabia al-Makhzumi ordered one of his slaves to slaughter an animal. When he wanted to slaughter it, he said to him, "Mention Allah's name." The slave said to him, "I have mentioned the name!" He said to him, "Mention the name of Allah, bother you!" He said to him, "I have mentioned the name of Allah " Abdullah ibn Ayyash said, "By Allah, I shall never eat it!"


Malik :: Slaughtering Animals :: [24-24.2.3]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.2.3

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that a man from the Ansar of the tribe of Banu Haritha was herding a pregnant she-camel at Uhud. It was about to die, so he slaughtered it with a sharp stake. The Messenger of Allah was asked about that, and he said, "There is no harm in it, eat it."


Malik :: Slaughtering Animals :: [24-24.2.4]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.2.4

Yahya related to me from Malik from Nafi from a man of the Ansar from Muadh ibn Sad or Sad ibn Muadh that a slave-girl of Kab ibn Malik was herding some sheep at Sal (a mountain near Madina). One of the sheep was about to die, so she went over to it and slaughtered it with a stone. The Messenger of Allah, may Allah bless him and grant him peace, was asked about that, and he said, "There is no harm in it, so eat it."


Malik :: Slaughtering Animals :: [24-24.2.5]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.2.5

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili that Abdullah ibn Abbas was asked about animals slaughtered by the

Christian Arabs. He said, "There is no harm in them," but he recited this ayat, "Whoever takes them as friends is from them." (Sura 5 ayat 54).


Malik :: Slaughtering Animals :: [24-24.2.6]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.2.6

Yahya related to me from Malik that Abdullah ibn Abbas used to say, "You can eat anything that has had its jugular vein cut."

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "There is no harm in whatever you slaughter with a cutting edge, as long as you are forced to do it by necessity."


Malik :: Slaughtering Animals :: [24-24.3.7]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.3.7

Yahya related to me from Malik from Yahya ibn Said that Abu Murra, the mawla of Aqil ibn Abi Talib asked Abu Hurayra about a sheep which was slaughtered and then part of it moved. He ordered him to eat it. Then he asked Zayd ibn Thabit about it, and he said, "Does a corpse move?" and he forbade eating its meat.

Malik was asked about a sheep which fell down and injured itself badly and then its master reached it and slaughtered it. Blood flowed from it but it did not move. Malik said, "If he kills it and blood flows from it and its eyes blink, he should eat it."


Malik :: Slaughtering Animals :: [24-24.4.8]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.4.8

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "When a she-camel is slaughtered, what is in its womb is included in the slaughter if it is perfectly formed and its hair has begun to grow. If it comes out of its mother's womb, it is slaughtered so that blood flows from its heart."


Malik :: Slaughtering Animals :: [24-24.4.9]

Slaughtering Animals

Malik :: Book 24 : Hadith 24.4.9

Yahya related to me from Malik from Yazid ibn Abdullah ibn Qusayt al-Laythi that Said ibn al- Musayyab said, "The slaughter of what is in the womb is included in the slaughter of the mother if it is perfectly formed and its hair has begun to grow."


Malik :: Game :: [25-25.1.1]

Game

Malik :: Book 25 : Hadith 25.1.1

ahya related to me from Malik that Nafi said, "I was at al-Juruf (near Madina) and threw a stone at two birds, and hit them. One of them died, and Abdullah ibn Umar threw it away, and then went to slaughter the other one with an adze. It died before he could slaughter it, so Abdullah threw that one away as well."


Malik :: Game :: [25-25.1.2]

Game

Malik :: Book 25 : Hadith 25.1.2

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad disapproved of eating game that had been killed with throwing sticks and by clay pellets.


Malik :: Game :: [25-25.1.3]

Game

Malik :: Book 25 : Hadith 25.1.3

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab disapproved of killing domestic animals that had become wild by any means that game was slain such as arrows and the like.

Malik said, "I do not see any harm in eating game which is pierced by a throwing stick in a vital organ.

Allah, the Blessed, the Exalted! said, 'Oh you who believe! Allah will surely try you with something of the game that your hands and spears attain.' " (Sura 5 ayat 97).

Yahya said, "Any game that man obtains by his hand or by his spear or by any weapon which pierces it and reaches a vital organ, is acceptable as Allah, the Exalted, has said."


Malik :: Game :: [25-25.1.4]

Game

Malik :: Book 25 : Hadith 25.1.4

Yahya related to me from Malik that he had heard the people of knowledge say that when a man hit game and something else might have contributed to death, like water or an untrained dog, that game was not to be eaten unless it was beyond doubt that it was the arrow of the hunter that had killed it by reaching a vital organ, so that it did not have any life after that.


Malik :: Game :: [25-25.1.5]

Game

Malik :: Book 25 : Hadith 25.1.5

Yahya said that he heard Malik say that there was no harm in eating game when you did not see it die if you found the mark of your dog on it or your arrow in it as long as it had not remained overnight. If it had remained overnight, then it was disapproved of to eat it.


Malik :: Game :: [25-25.2.5]

Game

Malik :: Book 25 : Hadith 25.2.5

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said about a trained dog, "Eat whatever it catches for you whether it eats from it or not."


Malik :: Game :: [25-25.2.6]

Game

Malik :: Book 25 : Hadith 25.2.6

Yahya related to me from Malik that he heard Nafi say that Abdullah ibn Umar said, "Whether it eats from it or not."


Malik :: Game :: [25-25.2.7]

Game

Malik :: Book 25 : Hadith 25.2.7

Yahya related to me from Malik that he had heard that Sad ibn Abi Waqqas had said, when asked about a trained dog killing game, "Eat, even if only one piece of it remains."


Malik :: Game :: [25-25.2.8]

Game

Malik :: Book 25 : Hadith 25.2.8

Yahya related to me from Malik that he had heard some of the people of knowledge say that when falcons, eagles, and hawks and their like, understood as trained dogs understood, there was no harm in eating what they had killed in the course of hunting, if the name of Allah had been mentioned when they were sent out.

Malik said, "The best of what I have heard about retrieving game from the falcon's talons or from the dog's fangs and then waiting until it dies, is that it is not halal to eat it."

Malik said, "The same applies to anything which could have been slaughtered by the hunter when it was in the talons of the falcon or the fangs of the dog. If the hunter leaves it until the falcon or dog has killed it, it is not halal to eat it either". He continued, "The same thing applies to any game hit by a hunter and caught while still alive, which he neglects to slaughter before it dies."

Malik said, "It is generally agreed among us that it is halal to eat the game that a hunting-dog belonging to magians hunts or kills, if it is sent out by a muslim and the animal is trained. There is no harm in it even if the muslim does not actually slaughter it.

It is the same as a muslim using a magian's knife to slaughter with or using his bow and arrows to shoot and kill with. The game he shot and the animal he slaughters are halal. There is no harm in eating them. If a magian sends out a muslim's hunting dog for game, and it catches it, the game is not to be eaten unless it is slaughtered by a muslim. That is like a magian using a muslim's bow and arrow to hunt game with, or like his using a muslim's knife to slaughter with. It is not halal to eat anything killed like that.


Malik :: Game :: [25-25.3.9]

Game

Malik :: Book 25 : Hadith 25.3.9

Yahya related to me from Malik from Nafi that Abd ar-Rahman ibn Abi Hurayra asked Abdullah ibn Umar about eating what was cast up by the sea and he forbade him to eat it. Then Abdullah turned and asked for a Qur'an, and read, "The game of the sea and its flesh are halal for you." Nafi added, "Abdullah ibn Umar sent me to Abdar-Rahman Ibn Abi Hurayra to say that there was no harm in eating it."


Malik :: Game :: [25-25.3.10]

Game

Malik :: Book 25 : Hadith 25.3.10

Yahya related to me from Malik from Zayd ibn Aslam that Sad al-Jari, the mawla of Umar ibn al-Khattab asked Abdullah ibn Umar about fish which had killed each other or which had died from severe cold . He said, "There is no harm in eating them.'' Sad said,' 'I then asked Abdullah ibn Amr ibn al As and he said the same."


Malik :: Game :: [25-25.3.11]

Game

Malik :: Book 25 : Hadith 25.3.11

Yahya related to me from Malik from Abu'z-Zinad from Abu Salama ibn Abd ar-Rahman from Abu Hurayra and Zayd ibn Thabit that they saw no harm in eating what was cast up by the sea.


Malik :: Game :: [25-25.3.12]

Game

Malik :: Book 25 : Hadith 25.3.12

Yahya related to me from Malik from Abu'z-Zinad from Abu Salama ibn Abd ar-Rahman that some people from al-Jar came to Marwan ibn al-Hakam and asked him about eating what was cast up by the sea. He said, "There is no harm in eating it." Marwan said, "Go to Zayd ibn Thabit and Abu Hurayra and ask them about it, then come to me and tell me what they say." They went to them and asked them, and they both said, "There is no harm in eating it " They returned to Marwan and told him. Marwan said, "I told you."

Malik said that there was no harm in eating fish caught by magians, because the Messenger of Allah, may Allah bless him and grant him peace, said, "In the sea's water is purity, and that which is dead in it is halal. "

Malik said, "If it is eaten when it is dead, there is no harm in who catches it."


Malik :: Game :: [25-25.4.13]

Game

Malik :: Book 25 : Hadith 25.4.13

Yahya related to me from Malik from Ibn Shibab from Abu Idris al-Khawlani from Abu Tha~laba al-Khushani that the Messenger of Allah, may Allah bless him and grant him peace, said, "It is haram to eat animals with fangs "


Malik :: Game :: [25-25.4.14]

Game

Malik :: Book 25 : Hadith 25.4.14

Yahya related to me from Malik from Ismail ibn Abi Hakim from Abiyda ibn Sufyan al-Hadrami from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Eating animals with fangs is haram. "

Malik said, "This is the custom among us."


Malik :: Game :: [25-25.5.15]

Game

Malik :: Book 25 : Hadith 25.5.15

Yahya related to me from Malik that the best of what he had heard about horses, mules, and donkeys was that they were not eaten because Allah, the Blessed, the Exalted,said, "And horses, and mules and asses, for you to ride, and as an adornment. " (Sura 16 ayat 8) . He said, may He be Blessed and Exalted, "In cattle, some of them you ride, and some of them you eat." (Sura 6 ayat 79). He said, the Blessed, the Exalted, "Mention Allah's name over what He has provided you of cattle, and eat of them and feed the beggar (al-qani) and the suppliant (al-mutarr). (Sura 22 ayat 34).

Malik said "Allah mentioned horses, mules, and donkeys for riding and adornment, and He mentioned cattle for riding and eating."

Malik said, "Al-qani also means the poor."


Malik :: Game :: [25-25.6.16]

Game

Malik :: Book 25 : Hadith 25.6.16

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Abdullah ibn Abbas said, "The Messenger of Allah, may Allah bless him and grant him peace, passed by a dead sheep which had been given to a mawla of his wife, Maimuna. He said, ' Aren't you going to use its skin?' They said, 'Messenger of Allah, but it is carrion. 'The Messenger of Allah, may Allah bless him and grant him peace, said, 'Only eating it is haram.' "


Malik :: Game :: [25-25.6.17]

Game

Malik :: Book 25 : Hadith 25.6.17

Malik related to me from Zayd ibn Aslam from Ibn Wala al-Misri from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, said, "A skin when it is tanned is pure."


Malik :: Game :: [25-25.6.18]

Game

Malik :: Book 25 : Hadith 25.6.18

Yahya related to me from Malik from Yazid ibn Abdullah ibn Qusayt from Muhammad ibn Abd ar-Rahman ibn Thawban from his mother that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said that the Messenger of Allah, may Allah bless him and grant him peace, ordered that the skins of carrion be used after they had been tanned.


Malik :: Game :: [25-25.7.19]

Game

Malik :: Book 25 : Hadith 25.7.19

Yahya related to me from Malik that the best of what he had heard about a man who is forced by necessity to eat carrion is that he ate it until he was full and then he took provision from it. If he found something which would enable him to dispense with it, he threw it away.

Malik when asked whether or not a man who had been forced by necessity to eat carrion, should eat it when he also found the fruit, crops or sheep of a people in that place, answered, "If he thinks that the owners of the fruit, crops, or sheep will believe his necessity so that he will not be deemed a thief and have his hand cut off, then I think that he should eat from whatever he finds that which will remove his hunger but he should not carry any of it away. I prefer that he does that than that he eat carrion. If he fears that he will not be believed, and will be deemed a thief for what he has taken, then I think that it is better for him to eat the carrion, and he has leeway to eat carrion in this respect. Even so, I fear that someone who is not forced by necessity to eat carrion might exceed the limits out of a desire to consume other peoples' property, crops or fruit."

Malik said, "That is the best of what I have heard."


Malik :: The 'Aqiqa :: [26-26.1.1]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.1.1

Yahya related to me from Zayd ibn Aslam from a man of the Banu Damra that his father said, "The Messenger of Allah, may Allah bless him and grant him peace, was asked about the Aqiqa. He said, 'I do not like disobedience (uquq),' as if he disliked the name. He said, 'If anyone has a child born to him, and wants to sacrifice for his child, then let him do it.' "


Malik :: The 'Aqiqa :: [26-26.1.2]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.1.2

Yahya related to me from Malik from Jafar ibn Muhammad that his father said, "Fatima, the daughter of the Messenger of Allah, may Allah bless him and grant him peace, weighed the hair of Hasan, Husayn, Zaynab and Umm Kulthum, and gave away in sadaqa an equivalent weight of silver."


Malik :: The 'Aqiqa :: [26-26.1.3]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.1.3

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that Muhammad ibn Ali ibn al-Husayn said, "Fatima, the daughter of the Messenger of Allah, may Allah bless him and grant him peace, weighed the hair of Hasan and Husayn, and gave away in sadaqa the equivalent weight in silver."


Malik :: The 'Aqiqa :: [26-26.2.4]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.2.4

Yahya related to me from Malik from Nafi that if any of Abdullah ibn Umar's family asked him for an aqiqa, he would give it to them. He gave a sheep as aqiqa for both his male and female children.


Malik :: The 'Aqiqa :: [26-26.2.5]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.2.5

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that Muhammad ibn Ibrahim ibn al-Harith at-Taymi said, "I heard my father say that the aqiqa was desirable, even if it was only a sparrow."


Malik :: The 'Aqiqa :: [26-26.2.7]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.2.7

Yahya related to me from Malik from Hisham ibn Urwa that his father, Urwa ibn az-Zubayr made an aqiqa for his male and female children of a sheep each.

Malik said, "What we do about the aqiqa is that if someone makes an aqiqa for his children, he gives a sheep for both male and female. The aqiqa is not obligatory but it is desirable to do it, and people continue to come to us about it. If someone makes an aqiqa for his children, the same rules apply as with all sacrificial animals - one-eyed, emaciated, injured, or sick animals must not be used, and neither the meat or the skin is to be sold. The bones are broken and the family eat the meat and give some of it away as sadaqa. The child is not smeared with any of the blood .''


Malik :: The 'Aqiqa :: [26-26.2.64]

The 'Aqiqa

Malik :: Book 26 : Hadith 26.2.64

Yahya related to me from Malik that he heard that there had been an aqiqa for Hasan and Husayn, the sons of Ali ibn Abi Talib.


Malik :: Fara'id :: [27-27.1.0]

Fara'id

Malik :: Book 27 : Hadith 27.1.0

Yahya related to me from Malik, "The generally agreed upon way of doing things among us and what I have seen the people of knowledge doing in our city about the fixed shares of inheritance of children from the mother or father when one or other of them dies is that if they leave male and female children, the male takes the portion of two females. If there are only females, and there are more than two, they get two thirds of what is left between them. If there is only one, she gets a half. If someone shares with the children, who has a fixed share and there are males among them, the reckoner begins with the ones with fixed shares. What remains after that is divided among the children according to their inheritance.

"When there are no children, grandchildren through sons have the same position as children, so that grandsons are like sons and grand-daughters are like daughters. They inherit as they inherit and they overshadow as they overshadow. If there are both children and grandchildren through sons, and there is a male among the children, then the grandchildren through sons do not share in the inheritance with him.

"If there is no surviving male among the children, and there are two or more daughters, the granddaughters through a son do not share in the inheritance with them unless there is a male who is in the same position as them in relation to the deceased, or further than them. His presence gives access to whatever is left over, if any, to whoever is in his position and whoever is above him of the granddaughters through sons. If something is left over, they divide it among them, and the male takes the portion of two females. If nothing is left over, they have nothing.

"If the only descendant is a daughter, she takes half, and if there are one or more grand-daughters through a son who are in the same position to the deceased, they share a sixth. If there is a male in the same position as the granddaughters through a son in relation to the deceased, they have no share and no sixth .

"If there is a surplus after the allotting of shares to the people with fixed shares, the surplus goes to the male and whoever is in his position and whoever is above him of the female descendants through sons. The male has the share of two females. The one who is more distant in relationship than grandchildren through sons has nothing. If there is no surplus, they have nothing. That is because Allah, the Blessed, the Exalted, said in His Book, 'Allah charges you about your children that the male has the like of the portion of two females. If there are more than two women they have two thirds of what is left. If there is one, she has a half.' (Sura 4 ayat 10)


Malik :: Fara'id :: [27-27.2.0]

Fara'id

Malik :: Book 27 : Hadith 27.2.0

Malik said, "The inheritance of a husband from a wife when she leaves no children or grandchildren through sons is a half. If she leaves children or grandchildren through sons, male or female, by her present or previous husbands, the husband has a quarter after bequests or debts. The inheritance of a wife from a husband who does not leave children or grandchildren through sons is a quarter. If he leaves children or grandchildren through sons, male or female, the wife has an eighth after bequests and debts. That is because Allah, the Blessed, the Exalted! said in His Book, 'You have a half of what your wives leave if they have no children. If they have children, you have a fourth of what they leave after bequests and debts. They have a fourth of what you leave if you have no children. If you have children, they have an eighth after bequests or debts.' " (Sura4ayat 11).


Malik :: Fara'id :: [27-27.3.0]

Fara'id

Malik :: Book 27 : Hadith 27.3.0

Malik said, "The generally agreed on way of doing things among us about which there is no dispute and what I have seen the people of knowledge in our city doing is that when a father inherits from a son or a daughter and the deceased leaves children, or grandchildren through a son, the father has a fixed share of one sixth. If the deceased does leave any children or male grandchildren through a son, the apportioning begins with those with whom the father shares in the fixed shares. They are given their fixed shares. If a sixth or more is left over, the sixth and what is above it is given to the father, and if there is less than a sixth left, the father is given his sixth as a fixed share, (i.e. the other shares are adjusted.)

"The inheritance of a mother from her child, if her son or daughter dies and leaves children or male or female grandchildren through a son, or leaves two or more full or half siblings is a sixth. If the deceased does not leave any children or grandchildren through a son, or two or more siblings, the mother has a whole third except in two cases. One of them is if a man dies and leaves a wife and both parents. The wife has a fourth, the mother a third of what remains, (which is a fourth of the capital). The other is if a wife dies and leaves a husband and both parents. The husband gets half, and the mother a third of what remains, (which is a sixth of the capital). That is because Allah, the Blessed, the Exalted, says in His Book, 'His two parents each have a sixth of what he leaves if he has children. If he does not have children, and his parents inherit from him, his mother has a third. If he has siblings, the mother has a sixth.' (Sura 4 ayat 11). The sunna is that the siblings be two or more."


Malik :: Fara'id :: [27-27.4.0]

Fara'id

Malik :: Book 27 : Hadith 27.4.0

Malik said, "The generally agreed upon way of doing things among us is that maternal half-siblings do not inherit anything when there are children or grandchildren through sons, male or female. They do not inherit anything when there is a father or the father's father. They inherit in what is outside of that. If there is only one male or female, they are given a sixth. If there are two, each of them has a sixth. If there are more than that, they share in a third which is divided among them. The male does not have portion of two females. That is because Allah, the Blessed, the Exalted, says in His Book, 'If a man or woman has no direct heir, and he has a brother or sister, by the mother, each of them has a sixth. If there are more than two, they share equally in a third.' " (Sura 4 ayat 12).


Malik :: Fara'id :: [27-27.5.0]

Fara'id

Malik :: Book 27 : Hadith 27.5.0

Malik said, "The generally agreed on way of doing things among us is that full siblings do not inherit anything with sons nor anything with grandsons through a son, nor anything with the father. They do inherit with the daughters and the granddaughters through a son when the deceased does not leave a paternal grandfather. Any property that is left over, they are in it as paternal relations. One begins with the people who are allotted fixed shares. They are given their shares. If there is anything left over after that, it belongs to the full siblings. They divide it between themselves according to the Book of Allah, whether they are male or female. The male has a portion of two females. If there is nothing left over, they have nothing.

"If the deceased does not leave a father or a paternal grandfather or children or male or female grandchildren through a son, a single full sister gets a half. If there are two or more full sisters, they get two thirds. If there is a brother with them, sisters, whether one or more, do not have a fixed share. One begins with whoever shares in the fixed shares. They are given their shares. Whatever remains after that goes to the full siblings. The male has the portion of two females except in one case, in which the full siblings have nothing. They share in this case the third of the half-siblings by the mother. That case is when a woman dies and leaves a husband, a mother, half-siblings by her mother, and full siblings. The husband has a half. The mother has one sixth. The half-siblings by the mother have a third. Nothing is left after that, so the full siblings share in this case with the half-siblings by the mother in their third. The male has the portion of two females in as much as all of them are siblings of the deceased by the mother. They inherit by the mother. That is because Allah, the Blessed, the Exalted, said in His Book, 'If a man or a woman has no direct heir and he has a brother or a sister, each one of the two gets a sixth. If there are more than that, they share equally in the third. ' (Sura 4 ayat 12) . They therefore share in this case because all of them are siblings of the deceased by the mother."


Malik :: Fara'id :: [27-27.6.0]

Fara'id

Malik :: Book 27 : Hadith 27.6.0

Malik said, "The generally agreed on wayof doing things among us is that when there are no full siblings with them, half-siblings by the father take the position of full siblings. Their males are like the males of the full siblings, and their females are like their females except in the case where the half-siblings by the mother and the full siblings share, because they are not offspring of the mother who joins these."

Malik said, "If there are both full siblings and half-siblings by the father and there is a male among the full siblings none of the half-siblings by the father have any inheritance. If there is one or more females in the full siblings and there is no male with them, the one full sister gets a half, and the half sister by the father gets a sixth, completing the two-thirds. If there is a male with the half-sisters by the father, they have no share. The people of fixed shares are given their shares and if there is something left after that it is divided between the half-siblings by the father. The male has the portion of two females. If there is nothing left over, they get nothing. If the full siblings consist of two or more females, they get two-thirds, and the half-sisters by the father get nothing with them unless there is a half-brother by the father with them. If there is a half-brother by the father with them, the people of fixed shares are given their shares and if there is something left over after that, it is divided between the half-siblings by the father. The male gets the portion of two females. If there is nothing left over, they get nothing. Half-siblings by the mother, full-siblings, and half-siblings by the father, each have a sixth (when they are onlyone). Two and more share a third. The male has the same portion as the female. They are in the same position in it."


Malik :: Fara'id :: [27-27.7.1]

Fara'id

Malik :: Book 27 : Hadith 27.7.1

Yahya related to me from Malik from Yahya ibn Said that he had heard that Muawiya ibn Abi Sufyan wrote to Zayd ibn Thabit asking him about the grandfather. Zayd ibn Thabit wrote to him, "You have written to me asking me about the grandfather. Allah knows best. That is part of what is only determined by the amirs, i.e. the khalifs. I was present with two khalifs before you who gave the grandfather a half with one sibling, and a third with two. If there were more siblings, they did not decrease his third."


Malik :: Fara'id :: [27-27.7.2]

Fara'id

Malik :: Book 27 : Hadith 27.7.2

Yahya related to me from Malik from Ibn Shihab from Qabisa ibn Dhu'ayba that Umar ibn al-Khattab gave the grandfather "what people give him today."


Malik :: Fara'id :: [27-27.7.31]

Fara'id

Malik :: Book 27 : Hadith 27.7.31

Yahya related to me from Malik that he had heard that Sulayman ibn Yasar said, ''Umar ibn al-Khattab, Uthman ibn Affan, andZayd ibn Thabit gave the grandfather a third with full siblings". Malik said, "The generally agreed on way of doing things among us and what I have seen the people of knowledge in our city doing is that the paternal grandfather does not inherit anything at all with the father. He is given a sixth as a fixed share with the son and the grandson through a son. Other than that, when the deceased does not leave a mother or a paternal aunt, one begins with whoever has a fixed share, and they are given their shares. If there is a sixth of the property left over, the grandfather is given a sixth as a fixed share."

Malik said, "When someone shares with the grandfather and the full siblings in a specified share, one begins with whoever shares with them of the people of fixed shares. They are given their shares. What is left over after that belongs to the grandfather and the full siblings. Then one sees which is the more favourable of two alternatives for the portion of the grandfather. Either a third is allotted to him and the siblings to divide between them, and he gets a share as if he were one of the siblings, or else he takes a sixth from all the capital. Whichever is the best portion for the grandfather is given to him. What is left after that, goes to the full siblings. The male gets the portion of two females except in one particular case. The division in this case is different from the preceding one. This case is when a woman dies and leaves a husband, mother, full sister and grandfather. The husband gets a half, the mother gets a third, the grandfather gets a sixth, and the full sister gets a half. The sixth of the grandfather and the half of the sister are joined and divided into thirds. The male gets the share of two females. Therefore, the grandfather has two thirds, and the sister has one third."

Malik said, "The inheritance of the half-siblings by the father with the grandfather when there are no full siblings with them, is like the inheritance of the full siblings (in the same situation). The males are the same as their males and the females are the same as their females. When there are both full siblings and half-siblings by the father, the full siblings include in their number the number of half-siblings by the father, to limit the inheritance of the grandfather, i.e., if there was only one full sibling with the grandfather. They would share, after the allotting of the fixed shares, the remainder of the inheritance between them equally. If there were also two half-siblings by the father, their number is added to the division of the sum, which would then be divided four ways. A quarter going to the grandfather and three-quarters going to the full siblings who annex the shares technically allotted to the half-siblings by the father. They do not include the number of half-siblings by the mother, because if there were only half-siblings by the father they would not inherit anything with the grandfather and all the capital would belong to the grandfather, and so the siblings would not get anything after the portion of the grandfather.

"It belongs to the full siblings more than the half-siblings by the father, and the half-siblings by the father do not get anything with them unless the full siblings consist of one sister. If there is one full sister, she includes the grandfather with the half-siblings by her father in the division, however many. Whatever remains for her and these half-siblings by the father goes to her rather than them until she has had her complete share, which is half of the total capital. If there is surplus beyond half of all the capital in what she and the half-siblings by the father acquire it goes to them. The male has the portion of two females. If there is nothing left over, they get nothing."


Malik :: Fara'id :: [27-27.8.4]

Fara'id

Malik :: Book 27 : Hadith 27.8.4

Yahya related to me from Malik from Ibn Shihab from Uthman ibn Ishaq ibn Kharasha that Qabisa ibn Dhu'ayb said, "A grandmother came to Abu Bakr as-Siddiq and asked him for her inheritance. Abu Bakr said to her, 'You have nothing in the Book of Allah, and I do not know that you have anything in the sunna of the Messenger of Allah, may Allah bless him and grant him peace. Go away therefore, until I have questioned the people.' (i.e.the Companions). He questioned the people, and al-Mughira ibn Shuba said, 'I was present with the Messenger of Allah, may Allah bless him and grant him peace, when he gave the grandmother a sixth.' Abu Bakr said, 'Was there anybody else with you?' Muhammad ibn Maslama al-Ansari stood up and said the like of what al-Mughira said. Abu Bakr as-Siddiq gave it to her. Then the other grandmother came to Umar ibn al-Khattab and asked him for her inheritance. He said to her, "You have nothing in the Book of Allah, and what has been decided is only for other than you, and I am not one to add to the fixed shares, other than that sixth. If there are two of you together, it is between you. If eitherof you is left alone with it, it is hers."


Malik :: Fara'id :: [27-27.8.5]

Fara'id

Malik :: Book 27 : Hadith 27.8.5

Yahya related to me from Malik from Yahya ibn Said that al-Qasim ibn Muhammad said, "Two grandmothers came to Abu Bakr asSiddiq, and he wanted to give the sixth to the one who was from the mother's side, and a man of the Ansar said, 'What? Are you omitting the one from whom he would inherit if she died while he was alive?' Abu Bakr divided the sixth between them.~


Malik :: Fara'id :: [27-27.8.6]

Fara'id

Malik :: Book 27 : Hadith 27.8.6

Yahya related to me from Malik from Abdu Rabbih ibn Said that Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham only gave a fixed share to two grandmothers (together).

Malik said, "The generally agreed on way of doing things among us in which there is no dispute and which I saw the people of knowledge in our city doing, is that the maternal grandmother does not inherit anything at all with the mother. Outside of that, she is given a sixth as a fixed share. The paternal grandmotherdoes not inherit anything along with the mother or the father. Outside of that she is given a sixth as a fixed share." If both the paternal grandmother and maternal grandmother are alive, and the deceased does not have a father or mother outside of them, Malik said,."I have heard that if the maternal grandmother is the nearest of the two of them, then she has a sixth instead of the paternal grandmother. If the paternal grandmother is nearer, or they are in the same position in relation to the deceased, the sixth is divided equally between them."

Malik said, "None of the female grand-relations except for these two has any inheritance because I have heard that the Messenger of Allah, may Allah bless him and grant him peace, gave the grandmother inheritance, and then Abu Bakr asked about that until someone reliable related from the Messenger of Allah, may Allah bless him and grant him peace, that he had made the grandmother an heir and given a share to her. Another grandmother came to Umar ibn al-Khattab, and he said, 'I am not one to add to fixed shares. If there are two of you together, it is between you. If either of you is left alone with it, it is hers.' " Malik said, "We do not know of anyone who made other than the two grandmothers heirs from the beginning of Islam to this day."


Malik :: Fara'id :: [27-27.8.7]

Fara'id

Malik :: Book 27 : Hadith 27.8.7

Yahya related to me from Malik from Zayd ibn Aslam that Umar ibn al-Khattab asked the Messenger of Allah, may Allah bless him and grant him peace, about someone who died without parents or offspring, and the Messenger of Allah, may Allah bless him and grant him peace, said to him, "The ayat which was sent down in the summer at the end of the Surat an-Nisa (Sura 4) is enoughfor you."

Malik said, "The generally agreed on way of doing things among us, in which there is no dispute, and which I saw the people of knowledge in our city doing, is that the person who leaves neither parent or offspring can be of two types. As for the kind described in the ayat which was sent down at the beginning of the Surat an-Nisa in which Allah, the Blessed, the Exalted! said, 'If a man or a woman has no direct heir, but has a brother or a sister by the mother, each of the two has a sixth. If there are more than that, they share equally in a third.' (Sura 4 ayat 12) This heirless one does not have heirs among his mother's siblings since there are no children or parents. As for the other kind described in the ayat which comes at the end of the Surat an-Nisa, Allah, the Blessed, the Exalted, said in it, 'They will ask you for a decision. Say, "Allah gives you a decision about the indirect heirs. If a man perishes having no children, but he has a sister, she shall receive a half of what he leaves, and he is her heir if she has no children. If there are two sisters, they shall receive two-thirds of what he leaves. If there are brothers and sisters, the male shall receive the portion of two females. Allah makes clear to you that you might not go astray. Allah has knowledge of everything" ' " (Sura 4 ayat 176).

Malik said, "If this person without direct heirs (parents) or children has siblings by the father, they inherit with the grandfather from the person without direct heirs. The grandfather inherits with the siblings because he is more entitled to the inheritance than them. That is because he inherits a sixth with the male children of the deceased when the siblings do not inherit anything with the male children of the deceased. How can he not be like one of them when he takes a sixth with the children of the deceased? How can he not take a third with the siblings while the brother's sons take a third with them? The grandfather is the one who overshadows the half-siblings by the mother and keeps them from inheriting. He is more entitled to what they have because they are omitted for his sake. If the grandfather did not take that third, the half-siblings by the mother would take it and would take what does not return to the half-siblings by the father. The half-siblings by the mother are more entitled to that third than the half-siblings by the father while the grandfather is more entitled to that than the half-siblings by the mother."


Malik :: Fara'id :: [27-27.9.8]

Fara'id

Malik :: Book 27 : Hadith 27.9.8

Yahya related to me from Malik from Muhammad ibn Abi Bakr ibn Muhammad ibn Amribn Hazm that Abdar-Rahman ibn Hanthala az-Zurqi was informed by a mawla of Quraysh,who used to be known as Ibn Mursi, that he was sitting with Umar ibn al-Khattab, and when they had prayed dhuhr, he said, "Yarfa! Bring that letter! (a letter which he had written about the paternal aunt.) We asked about her and asked for information about her." Yarfa brought it to him. He called for a small vessel or a drinking-bowl in which there was water. He erased the letter in it. Then he said, "Had Allah approved of you as an heir, we would have confirmed you. Had Allah approved of you, we would have confirmed you."


Malik :: Fara'id :: [27-27.9.9]

Fara'id

Malik :: Book 27 : Hadith 27.9.9

Yahya related to me from Malik that Muhammad ibn Abi Bakr ibn Hazm heard his father say many times, ''Umar ibn al-Khattab used to say, 'It is a wonder that the paternal aunt is inherited from and does not inherit.' "


Malik :: Fara'id :: [27-27.10.9]

Fara'id

Malik :: Book 27 : Hadith 27.10.9

Malik said, "The generally agreed on way of doing things among us, in which there is no dispute, and which I saw the people of knowledge in our city doing, about paternal relations is that full brothers are more entitled to inherit than half-brothers by the father and half-brothers by the father are more entitled to inherit than the children of the full brothers. The sons of the full brothers are more entitled to inherit than the sons of the half-brothers by the father. The sons of the half-brothers by the father are more entitled to inherit than the sons of the sons of the full brothers. The sons of the sons of the half-brothers by the father's side are more entitled to inherit than the paternal uncle, the full brother of the father. The paternal uncle, the full brother of the father, is more entitled to inherit than the paternal uncle, the half-brotherof the father on the father's side. The paternal uncle, the half-brother of the father on the father's side is more entitled to inherit than the sons of the paternal uncle, the full brother of the father. The son of the paternal uncle on the father's side is more entitled to inherit than the paternal great uncle, the full brother of the paternal grandfather."

Malik said, "Everything about which you are questioned concerning the inheritance of the paternal relations is like this. Trace the genealogy of the deceased and whoever among the paternal relations contends for inheritance. If you find that one of them reaches the deceased by a father and none of them except him reaches him by a father, then make his inheritance to the one who reaches him by the nearest father, rather than the one who reaches him by what is above that. If you find that they all reach him by the same father who joins them, then see who is the nearest of kin. If there is only one half-brother by the father, give him the inheritance rather than more distant paternal relations. If there is a full brother and you find them equally related from a number of fathers or to one particular father so that they all reach the genealogy of the deceased and they are all half-brothers by the father or full brothers, then divide the inheritance equally among them. If the parent of one of them is an uncle (the full-brother of the father of the deceased) and whoever is with him is an uncle (the paternal half brother of the father of the deceased), the inheritance goes to the sons of the full brother of the father rather than the sons of the paternal half-brother of the father. That is because Allah, the Blessed, the Exalted, said, 'Those related by blood are nearer to one another in the Book of Allah, surely Allah has knowledge of everything.' "

Malik said, "The paternal grandfather, is more entitled to inherit than sons of the full-brother, and more entitled than the uncle, the full brother of the father. The son of the father's brother is more entitled to inherit from mawali retainers (freed slaves) than the grandfathers."


Malik :: Fara'id :: [27-27.11.9]

Fara'id

Malik :: Book 27 : Hadith 27.11.9

Malik said, "The generally agreed on way of doing things among us in which there is no dispute and which I saw the people of knowledge in our citydoing, is that the child of the half-sibling by the mother, the paternal grandfather, the paternal uncle who is the maternal half-brother of the father, the maternal uncle, the great-grandmother who is the mother of the mother's father, the daughter of the full-brother, the paternal aunt, and the maternal aunt do not inherit anything by their kinship."

Malik said, "The woman who is the furthest relation of the deceased of those who were named in this book, does not inherit anything by her kinship, and women do not inherit anything apart from those that are named in the Qur'an. Allah, the Blessed, the Exalted, mentioned in His Book the inheritance ofthe mother from her children, the inheritance of the daughters from their father, the inheritance of the wife from her husband, the inheritance of the full sisters, the inheritance of the half-sisters by the father and the inheritance of the half-sisters by the mother. The grandmother is made an heir by the example of the Prophet, may Allah bless him and grant him peace, made about her. A woman inherits from a slave she frees herself because Allah, the Blessed, the Exalted, said in His Book, 'They are your brothers in the deen and your mawali.' "


Malik :: Fara'id :: [27-27.12.10]

Fara'id

Malik :: Book 27 : Hadith 27.12.10

Yahya related to me from Malik from Ibn Shihab from Ali ibn Husayn ibn Ali from Umar ibn Uthman ibn Affan from Usama ibn Zayd that the Messenger of Allah, may Allah bless him and grant him peace, said, "A muslim does not inherit from a kafir."


Malik :: Fara'id :: [27-27.12.11]

Fara'id

Malik :: Book 27 : Hadith 27.12.11

Yahya related to me from Malik from Ibn Shihab that Ali ibn Husayn ibn Ali ibn Abi Talib told him that Aqil and Talib inherited from Abu Talib, and Ali did not inheritfrom him. Ali said, "Because of that, we have given up our portion of ash Shab." (A house belonging to Banu Hashim).


Malik :: Fara'id :: [27-27.12.12]

Fara'id

Malik :: Book 27 : Hadith 27.12.12

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Muhammad ibn al-Ashath told him that he had a christian or jewish paternal aunt who died. Muhammad ibn al-Ashath mentioned that to Umar ibn al-Khattab and said to him, "Who inherits from her?" Umar ibn al-Khattab said to him, "The people of her deen inherit from her." Then he went to Uthman ibn Affan, and asked him about that. Uthman said to him, "Do you think that I have forgotten what Umar ibn al-Khattab said to you? The people.of her deen inherit from her."


Malik :: Fara'id :: [27-27.12.13]

Fara'id

Malik :: Book 27 : Hadith 27.12.13

Yahya related to me from Malik from Yahya ibn Said from Ismail ibn Abi Hakim that Umar ibn Abd al-Aziz freed a christian who then died. Ismail said, ''Umar ibn Abd al-Aziz ordered me to put his property in the bayt al-mal."


Malik :: Fara'id :: [27-27.12.14]

Fara'id

Malik :: Book 27 : Hadith 27.12.14

Yahya related to me from Malik from a reliable source of his who had heard Said ibn al-Musayyab say, ''Umar ibn al-Khattab refused to let anyone inherit from the non-arabs except for one who was born among the arabs."

Malik said, "If a pregnant woman comes from the land of the enemy and gives birth in arab land so that he is her (an arab) child, he inherits from her if she dies, and she inherits from him if he dies, by the Book of Allah."

Malik said, "The generally agreed on way of doing things among us and the sunna in which there is no dispute, and what I saw the people of knowledge in our city doing, is that a Muslim does not inherit from a kafir by kinship, clientage (wala'), or maternal relationship, nor does he (the Muslim) overshadow any (of the kafirs) from his inheritance.

Malik said, "Similarly, someone who forgoes his inheritance when he is the chief heir does not overshadow anyone from his inheritance."


Malik :: Fara'id :: [27-27.13.15]

Fara'id

Malik :: Book 27 : Hadith 27.13.15

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman from more than one of the people of knowledge of that time, that those who were killed on the Day of the Camel, the Day of Siffin, the Day of al-Harra, and the Day of Qudayd did not inherit from each other. None of them inherited anything from his companion unless it was known that he had been killed before his companion.

Malik said, "That is the way of doing things about which there is no dispute, and which none of the people of knowledge in our city doubt. The procedure with two mutual heirs who are drowned, or killed in another way, when it is not known which of them died first is the same - neither of them inherits anything from his companion. Their inheritance goes to whoever remains of their heirs. They are inherited from by the living."

Malik said, "No one should inherit from anyone else when there is doubt, and one should only inherit from the other when there is certainty of knowledge and witnesses. That is because a man and his mawla whom his father has freed might die at the same time. The sons of the free man could say, 'Our father inherited from the mawla.' They should not inherit from the mawla without knowledge or testimony that he died first. The living people most entitled to his wala' inherit from him."

Malik said, "Another example is two full brothers who die. One of them has children and the other does not. They have a half-brother by their father. It is not known which of them died first, so the inheritance of the childless one goes to his half-brother by the father. The children of the full-brother get nothing."

Malik said, "Another example is when a paternal aunt and the son of her brother die, or else the daughter of the brother and her paternal uncle. It is not known which of them died first. The paternal uncle does not inherit anything from the daughter of his brother, and the son of the brother does not inherit anything from his paternal aunt."


Malik :: Fara'id :: [27-27.14.16]

Fara'id

Malik :: Book 27 : Hadith 27.14.16

Yahya related to me from Malik that he had heard that Urwa ibn az-Zubayr said about the child of lian and the child of fornication, that if they died, the mother inherited her right from them according to the Book of Allah, the Mighty, the Majestic! The siblings by the mother had their rights. The rest was inherited by the former masters of the mother if she was a freed slave. If she was a free woman by origin, she inherited her due and the siblings by the mother inherited their due, and the rest went to the Muslims.

Malik said, "I heard the same as that from Sulayman ibn Yasar."

Malik said, "That is what I saw the people of knowledge in our city doing."


Malik :: Marriage :: [28-28.1.1]

Marriage

Malik :: Book 28 : Hadith 28.1.1

Yahya related to me from Malik from Muhammad ibn Yahya ibn Habban from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not ask for a woman in marriage when another muslim has already done so."


Malik :: Marriage :: [28-28.1.2]

Marriage

Malik :: Book 28 : Hadith 28.1.2

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not ask for a woman in marriage when another muslim has already done so."

Malik said, "The explanation of the statement of the Messenger of Allah, may Allah bless him and grant him peace, according to what we think - and Allah knows best - is that 'Do not ask for a woman in marriage when another muslim has already done so' means that when a man has asked for a woman in marriage, and she has inclined to him and they have agreed on a bride-price, which she has suggested and with which they are mutually satisfied, it is forbidden for another man to ask for that woman in marriage. It does not mean that when a man has asked for a woman in marriage, and his suit does not agree with her and she does not incline to him that no one else can ask for her in marriage. That is a door to misery for people."


Malik :: Marriage :: [28-28.1.3]

Marriage

Malik :: Book 28 : Hadith 28.1.3

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father said about the word of Allah, the Blessed, the Exalted, "There is no fault in you about the proposal you offer to women, or hide in yourselves. Allah knows that you will be mindful of them; but do not make troth with them secretly without honourable words," (Sura 2 ayat 235) that it referred to a man saying to a woman while she was still in her idda after the death of her husband, "You are dear to me, and I desire you, and Allah brings provision and blessing to you," and words such as these.


Malik :: Marriage :: [28-28.2.4]

Marriage

Malik :: Book 28 : Hadith 28.2.4

Malik related to me from Abdullah ibn al-Fadl from Nafi ibn Jubayr ibn Mutim from Abdullah ibn Abbas that the Messenger of Allah, may Allah bless him and grant him peace, said, "A woman who has been previously married is more entitled to her person than her guardian, and a virgin must be asked for her consent for herself, and her consent is her silence "


Malik :: Marriage :: [28-28.2.5]

Marriage

Malik :: Book 28 : Hadith 28.2.5

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab had said that Umar ibn al-Khattab said, "A woman is only married with the consent of her guardian, someone of her family with sound judgement or the Sultan.


Malik :: Marriage :: [28-28.2.6]

Marriage

Malik :: Book 28 : Hadith 28.2.6

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad and Salim ibn Abdullah were marrying off their daughters and they did not consult them.

Malik said, "That is what is done among us about the marriage of virgins."

Malik said, "A virgin has no right to her property until she enters her house and her state (competence, maturity etc.) is known for sure."


Malik :: Marriage :: [28-28.2.7]

Marriage

Malik :: Book 28 : Hadith 28.2.7

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad and Salim ibn Abdullah and Sulayman ibn Yasar said about the virgin given by her father in marriage without her permission, "That is binding on her."


Malik :: Marriage :: [28-28.3.8]

Marriage

Malik :: Book 28 : Hadith 28.3.8

Yahya related to me from Malik from Malik from Abu Hazim ibn Dinar from Sahl ibn Sad as-Saidi that a woman came to the Messenger of Allah, may Allah bless him and grant him peace, and said, "Messenger of Allah! I have given myself to you." She stood for a long time, and then a man got up and said, "Messenger of Allah, marry her to me if you have no need of her." The Messenger of Allah, may Allah bless him and grant him peace, said, "Do you have anything to give her as a bride-price?" He said, "I possess only this lower garment of mine." The Messenger of Allah, may Allah bless him and grant him peace, said, "If you give it to her you will not have a garment to wear so look for something else." He said, "I have nothing else." He said, "Look for something else, even if it is only an iron ring." He looked, and found that he had nothing. The Messenger of Allah, may Allah bless him and grant him peace, said, "Do you know any of the Qur'an?" He said, "Yes. I know such-and-such a sura and such-and-such a sura," which he named. The Messengerof Allah, may Allah bless him and grant him peace, said to him, "I have married her to you for what you know of the Qur'an."


Malik :: Marriage :: [28-28.3.9]

Marriage

Malik :: Book 28 : Hadith 28.3.9

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab had said that Umar ibn al-Khattab said, "If a man marries a woman who is insane, or has leprosy or white leprosy, without being told of her condition by her guardian, and he has sexual relations with her, she keeps her bride-price in its entirety. Her husband has damages against her guardian."

Malik said, "The husband has damages against her guardian when the guardian is her father, brother, or one who is deemed to have knowledge of her condition. If the guardian who gives her in marriage is a nephew, a mawla or a member of her tribe who is not deemed to have knowledge of her condition, there are no damages against him, and the woman returns what she has taken of her bride-price, and the husband leaves her whatever amount is thought to be fair."


Malik :: Marriage :: [28-28.3.10]

Marriage

Malik :: Book 28 : Hadith 28.3.10

Yahya related to me from Malik from Nafi that the daughter of Ubaydullah ibn Umar whose mother was the daughter of Zayd ibn al-Khattab, married the son of Abdullah ibn Umar. He died and had not yet consummated the marriage or specified her bride-price. Her mother wanted the bride-price, and Abdullah ibn Umar said, "She is not entitled to a bride-price. Had she been entitled to a bride-price, we would not have kept it and we would not do her an injustice. "The mother refused to accept that. Zayd ibn Thabit was brought to adjudicate between them and he decided that she had no bride-price, but that she did inherit.


Malik :: Marriage :: [28-28.3.11]

Marriage

Malik :: Book 28 : Hadith 28.3.11

Yahya related to me from Malik that he had heard that Umar ibn Abd al-Aziz during his khalifate, wrote to one of his governors, "Whatever a father, or guardian, who gives someone in marriage, makes a condition in the way of unreturnable gift or of favour, belongs to the woman if she wants it."

Malik spoke about a woman whose father gave her in marriage and made an unreturnable gift a condition of the bride-price which was to be given. He said, "Whatever is given as a condition by which marriage occurs belongs to the woman if she wants it. If the husband parts from her before the marriage is consummated, the husband has half of the unreturnable gift by which the marriage occurred."

Malik said about a man who married off his young son and the son had no wealth at all, that the bride-price was obliged of the father if the young man had no property on the day of marriage. If the young man did have property the bride-price was taken from his property unless the father stipulated that he would pay the bride-price. The marriage was affirmed for the son if he was a minor only if he was under the guardianship of his father.

Malik said that if a man divorced his wife before he had consummated the marriage and she was a virgin, her father returned half of the bride-price to him. That half was permitted to the husband from the father to compensate him for his expenses.

Malik said that that was because Allah, the Blessed, the Exalted, said in His Book, "Unless they (women with whom he had not consummated marriage) make remission or he makes remission to him in whose hand is the knot of marriage." (Sura 2 ayat 237). (He being the father of a virgin daughter or the master of a female slave.)

Malik said, "That is what I have heard about the matter, and that is how things are done among us."

Malik said that a jewish or christian woman who was married to a jew or christian and then became muslim before the marriage had been consummated, did not keep anything from the bride-price.

Malik said, "I do not think that women should be married for less than a quarter of a dinar. That is the lowest amount for which cutting off the hand is obliged ."


Malik :: Marriage :: [28-28.4.12]

Marriage

Malik :: Book 28 : Hadith 28.4.12

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that 'Umar ibn al-Khattab decided about the woman who was married by a man and the marriage had been consummated, that the bride-price was obligatory.


Malik :: Marriage :: [28-28.4.13]

Marriage

Malik :: Book 28 : Hadith 28.4.13

Yahya related to me from Malik from Ibn Shihab that Zayd ibn Thabit said, "When a man takes his wife to his house and co-habits with her then the bride-price is obliged."

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab said, "When a man comes to his wife in her room, he is believed. When she comes to him in his room, she is believed."

Malik commented, "I think that this refers to sexual intercourse. When he comes in to her in her room and she says, 'He has had intercourse with me' and he says, 'I have not touched her', he is believed. When she comes in to him in his room and he says, 'I have not had intercourse with her' and she says, 'He had intercourse with me', she is believed."

28.5 Wedding Nights of Virgins and Women Previously Married


Malik :: Marriage :: [28-28.5.14]

Marriage

Malik :: Book 28 : Hadith 28.5.14

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from Abd al-Malik ibn Abi Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham al-Makhzumi from his father that when the Messenger of Allah, may Allah bless him and grant him peace, married Umm Salama and then spent the night with her, he said to her, "You are not being humbled in your right. If you wish, I will stay with you for seven nights as I stayed seven nights with the others. If you wish, I will stay with you for three nights, and then visit the others in turn." She said, "Stay three nights."


Malik :: Marriage :: [28-28.5.15]

Marriage

Malik :: Book 28 : Hadith 28.5.15

Yahya related to me from Malik from Humayd at-Tawil that Anas ibn Malik said, "A virgin has seven nights, and a woman who has been previously married has three nights."

Malik affirmed, "That is what is done among us."

Malik added, "If the man has another wife, he divides his time equally between them after the wedding nights. He does not count the wedding nights against the one he has just married."


Malik :: Marriage :: [28-28.6.16]

Marriage

Malik :: Book 28 : Hadith 28.6.16

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab was asked about a woman who made a stipulation on her husband not to take her away from her town. Said ibn al-Musayyab said, "He takes her away if he wishes."

Malik said, "The custom among us is that when a man marries a woman, and he makes a condition in the marriage contract that he will not marry after her or take a concubine, it means nothing unless there is an oath of divorce or setting-free attached to it. Then it is obliged and required of him."


Malik :: Marriage :: [28-28.7.17]

Marriage

Malik :: Book 28 : Hadith 28.7.17

Yahya related to me from Malik from al-Miswar ibn Rifaa al-Quradhi from az-Zubayr ibn Abd ar-Rahman ibn az-Zubayr that Rifaa ibn Simwal divorced his wife, Tamima bint Wahb, in the time of the Messenger of Allah, may Allah bless him and grant him peace, three times. Then she married Abd ar-Rahman ibn az-Zubayr and he turned from her and could not consummate the marriage and so he parted from her. Rifaa wanted to marry her again and it was mentioned to the Messenger of Allah, may Allah bless him and grant him peace, and he forbade him to marry her. He said, "She is not halal for you until she has tasted the sweetness of intercourse."


Malik :: Marriage :: [28-28.7.18]

Marriage

Malik :: Book 28 : Hadith 28.7.18

Yahya related to me from Malik from Yahya ibn Said from al-Qasim ibn Muhammad that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said when asked whether it was permissible for a man to marry again a wife he had divorced irrevocably if she had married another man who divorced her before consummating the marriage, "Not until she has tasted the sweetness of intercourse."


Malik :: Marriage :: [28-28.7.19]

Marriage

Malik :: Book 28 : Hadith 28.7.19

Yahya related to me from Malik that he had heard that when asked whether it was permissible for a man to return to his wife if he had divorced her irrevocably and then another man had married her after him and died before consummating the marriage, al-Qasim ibn Muhammad said, "It is not halal for the first husband to return to her."

Malik said, about the muhallil, that he could not remain in the marriage until he undertook a new marriage. If he had intercourse with her in that marriage, she had her dowry.


Malik :: Marriage :: [28-28.8.20]

Marriage

Malik :: Book 28 : Hadith 28.8.20

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said "One cannot be married to a woman and her paternal aunt, or a woman and her maternal aunt at the same time."


Malik :: Marriage :: [28-28.8.21]

Marriage

Malik :: Book 28 : Hadith 28.8.21

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "It is forbidden to be married to a woman and her paternal or maternal aunt at the same time, and for a man to have intercourse with a female slave who is carrying another man's child."


Malik :: Marriage :: [28-28.9.22]

Marriage

Malik :: Book 28 : Hadith 28.9.22

Yahya related to me from Malik from Yahya ibn Said that Zayd ibn Thabit asked whether it was halal for a man who married a woman and then separated from her before he had cohabited with her, to marry her mother. Zayd ibn Thabit said, "No. The mother is prohibited unconditionally. There are conditions, however about foster-mothers."


Malik :: Marriage :: [28-28.9.23]

Marriage

Malik :: Book 28 : Hadith 28.9.23

Yahya related to me from Malik from more than one source that when Abdullah ibn Masud was in Kufa, he was asked for an opinion about marrying the mother after marrying the daughter when the marriage with the daughter had not been consummated. He permitted it. When Ibn Masud came to Madina, he asked about it and was told that it was not as he had said, and that this condition referred to foster-mothers. Ibn Masud returnedto Kufa,and he had just reached his dwelling when the man who had asked him for the opinion came to visit and he ordered him to separate from his wife.

Malik said that if a man married the mother of a woman who was his wife and he had sexual relations with the mother then his wife was haram for him, and he had to separate from both of them. They were both haram to him forever, if he had had sexual relations with the mother. If he had not had relations with the mcther, his wife was not haram for him, and he separated from the mother.

Malik explained further about the man who married a woman, and then married her mother and cohabited with her, "The mother will never be halal for him, and she is not halal for his father or his son, and any daughters of hers are not halal for him and so his wife is haram for him."

Malik said, "Fornication however, does not make any of that haram because Allah, the Blessed, the Exalted, mentioned 'the mothers of your wives,' as one whom marriage made haram, and he didn't mention the making haram by fornication. Every marriage in a halal manner in which a man cohabits with his wife, is a halal marriage. This is what I have heard, and this is how things are done among us."


Malik :: Marriage :: [28-28.10.23]

Marriage

Malik :: Book 28 : Hadith 28.10.23

Malik said that a man who had committed fornication with a woman and the hadd-punishment had been applied to him for it, could marry that woman's daughter and his son could marry the woman herself if he wished. That was because he had haram relations with her, and the relations Allah had made haram were from the relations made in a halal manner or in a manner resembling marriage. Allah, the Blessed, the Exalted, said, "Do not marry the women your fathers have married. " (Sura 4 ayat 21)

Malik said, "If a man were to marry a woman in her idda-period in a halal marriage and have relations with her, it would be haram for his son to marry the woman. That is because the father married her in a halal manner, and the hadd-punishment would not have been applied to him. Any child who was born to him would be attached to him as the father. Just as it would be haram for the son to marry a woman whom his father had married in her idda-period and had relations with, so the woman's daughter would be haram for the father if he had had sexual relations with her."


Malik :: Marriage :: [28-28.11.24]

Marriage

Malik :: Book 28 : Hadith 28.11.24

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade shighar, which meant one man giving his daughter in marriage to another man on the condition that the other gave his daughter to him in marriage without either of them paying the bride-price.


Malik :: Marriage :: [28-28.11.25]

Marriage

Malik :: Book 28 : Hadith 28.11.25

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father from Abd ar-Rahman and Mujamma the sons of Yazid ibn Jariya al-Ansari from Khansa bint Khidam al-Ansariya that her father gave her in marriage and she had been previously married. She disapproved of that, and went to the Messenger of Allah, may Allah bless him and grant him peace, and he revoked the marriage.


Malik :: Marriage :: [28-28.11.26]

Marriage

Malik :: Book 28 : Hadith 28.11.26

Yahya related to me from Malik from Abu'z-Zubayr al-Makki that a case was brought to Umar about a marriage which had only been witnessed by one man and one woman . He said, "This is a secret marriage and I do not permit it. Had I been the first to come upon it, I would have ordered them to be stoned."


Malik :: Marriage :: [28-28.11.27]

Marriage

Malik :: Book 28 : Hadith 28.11.27

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab and from Sulayman ibn Yasar that Tulayha al-Asadiya was the wife of Rushayd ath-Thaqafi. He divorced her, and she got married in her idda-period. Umar ibn al-Khattab beat her and her husband with a stick several times, and separated them. Then Umar ibn al-Khattab said, "If a woman marries in her idda-period, and the new husband has not consummated the marriage, then separate them, and when she has completed the idda of her first husband, the other becomes a suitor. If he has consummated the marriage then separate them. Then she must complete her idda from her first husband, and then the idda from the other one, and they are never to be reunited."

Malik added, ''Said ibn al-Musayyab said that she had her dowry because he had consummated the marriage."

Malik said,"The practice with us concerning a free woman whose husband dies, is that she does an idda of four months and ten days and she does not marry if she doubts her period until she is free of any doubt or if she fears that she is pregnant."


Malik :: Marriage :: [28-28.12.28]

Marriage

Malik :: Book 28 : Hadith 28.12.28

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas and Abdullah ibn Umar were asked about a man who had a free woman as a wife and then wanted to marry a slave-girl. They disapproved that he should combine the two of them.


Malik :: Marriage :: [28-28.12.29]

Marriage

Malik :: Book 28 : Hadith 28.12.29

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "The slave girl is not married when there is a free woman who is a wife unless the free woman wishes it. If the free woman complies, she has two-thirds of the division of time."

Malik said, "A free man must not marry a slave-girl when he can afford to marry a free-woman, and he should not marry a slave-girl when he cannot afford a free woman unless he fears fornication. That is because Allah, may he be Blessed and Exalted, says in His Book, 'If you are not affluent enough to marry believing women, who are muhsanat, take slave-girls who are believing women that your right hands own.' (Sura 4 ayat 24) He says, 'That is for those of you who fear al-anat.' "

Malik said, "Al-anat is fornication."


Malik :: Marriage :: [28-28.13.30]

Marriage

Malik :: Book 28 : Hadith 28.13.30

Yahya related to me from Malik from Ibn Shihab from Abu Abd ar-Rahman that Zayd ibn Thabit said that if a man divorced his slave-girl three times and then bought her, she was not halal for him until she had married another husband.


Malik :: Marriage :: [28-28.13.31]

Marriage

Malik :: Book 28 : Hadith 28.13.31

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar were asked whether, when a man married a slave of his to a slave-girl and the slave divorced her irrevocably, and then her master gave her to the slave, she was then halal for the slave by the possession of the right hand. They said, "No. She is not halal until she has married another husband."


Malik :: Marriage :: [28-28.13.32]

Marriage

Malik :: Book 28 : Hadith 28.13.32

Yahya related to me from Malik that he had asked Ibn Shihab about a man who had a slave-girl as a wife, and then he bought her, and divorced her once. He said, "She is halal for him by the possession of the right hand as long as he does not make his divorce irrevocable. If he irrevocably divorces her, she is not halal for him by the possession of the right hand until she has married another husband."

Malik said that if a man rnarried a female slave and then she had a child by him, and then he bought her, she was not an umm walad for him because of the child born to him while she belonged to another, until she had had a child by him while she was in his possession after he had purchased her.

Malik said, "If he buys her and she is pregnant by him and she then gives birth while she belongs to him, she is his umm walad by that pregnancy, according to what we think, and Allah knows best."


Malik :: Marriage :: [28-28.14.33]

Marriage

Malik :: Book 28 : Hadith 28.14.33

Yahya related to me from Malik from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from his father that Umar ibn al-Khattab was asked about a woman and her daughter who were in the possession of the right hand, and whether one could have intercourse with one of them after the other Umar said, "I dislike both being permitted together." He then forbade that.


Malik :: Marriage :: [28-28.14.34]

Marriage

Malik :: Book 28 : Hadith 28.14.34

Yahya related to me from Malik from Ibn Shihab from Qabisa ibn Dhu'ayb that a man asked Uthman ibn Affan whether one could have intercourse with two sisters who one owned. Uthman said, "One ayat makes them halal, and one ayat makes them haram. As for me, I wouldn't like to do it." The man left him and met one of the companions of the Messenger of Allah, may Allah bless him and grant him peace, and asked him about it, and he said, "Had I any authority and I found someone who had done it, I would punish him as an example."

Ibn Shihab added, "I think that it was Ali ibn Abi Talib. "


Malik :: Marriage :: [28-28.14.35]

Marriage

Malik :: Book 28 : Hadith 28.14.35

Yahya related to me from Malik that he had heard that az-Zubayr ibn al-Awwam said the like of that.

Malik said that if a man had sexual relations with a female slave that he owned, and then he wanted to also have relations with her sister, the sister was not halal for a man until intercourse with the slave-girl had been made haram for him by marriage, setting free, kitaba, or the like of that - for instance, if he had married her to his slave or someone other than his slave.


Malik :: Marriage :: [28-28.15.36]

Marriage

Malik :: Book 28 : Hadith 28.15.36

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab gave his son a slave-girl and said, "Do not touch her, for I have uncovered her."

Yayha related to me from Malik that Abd arRahman ibn al-Mujabbir said that Salim ibn Abdullah gave his son a slave-girl and said, "Do not go near her, for I wanted her, and did not act towards her."


Malik :: Marriage :: [28-28.15.37]

Marriage

Malik :: Book 28 : Hadith 28.15.37

Yahya related to me from Malik from Yahya ibn Said that Abu Nahshal ibn al-Aswad said to al-Qasim ibn Muhammad,"I saw a slave-girl of mine uncovered in the moonlight, and so I sat on her as a man sits on a woman. She said that she was menstruating, so I stood up and have not gone near her after that. Can I give her to my son to have intercourse with?" Al-Qasim forbade that.


Malik :: Marriage :: [28-28.15.38]

Marriage

Malik :: Book 28 : Hadith 28.15.38

Yahya related to me from Malik from Ibrahim ibn Abi Abla from Abd al-Malik ibn Marwan that he gave a slave-girl to a friend of his, and later asked him about her. He said, "I intended to give her to my son to do such-and-such with her." Abd al-Malik said, "Marwan was more scrupulous than you. He gave a slave-girl to his son, and then he said, 'Do not go near her, for I have seen her leg uncovered .' "


Malik :: Marriage :: [28-28.16.38]

Marriage

Malik :: Book 28 : Hadith 28.16.38

Malik said, "It is not halal to marry a christian or jewish slave-girl because Allah the Blessed, the Exalted, said in His Book, 'Believing women who are muhsanat and women of those who were given the Book before you who are muhsanat', (sura 5 ayat 6) and they are free women from the Christians and Jews. Allah, the Blessed, the Exalted, said in His Book, 'If you are not affluent enough to marry believing women who are muhsanat, take believing slave-girls whom your right hands own.' " (Sura 4 ayat 24)

Malik said, "In our opinion, Allah made marriage to believing slave-girls halal, and He did not make halal marriage to christian and jewish slave-girls from the People of the Book."

Malik said, "The christian and jewish slave-girl are halal for their master by right of possession, but intercourse with a magian slave-girl is not halal by the right of possession."


Malik :: Marriage :: [28-28.17.39]

Marriage

Malik :: Book 28 : Hadith 28.17.39

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "The muhsanat among women are those who have husbands." That referred to the fact that Allah has made fornication haram.


Malik :: Marriage :: [28-28.17.40]

Marriage

Malik :: Book 28 : Hadith 28.17.40

Yahya related to me from Malik from Ibn Shihab, and he had heard from al-Qasim ibn Muhammad that they said, "When a free man marries a slave-girl and consummates the marriage, she makes him muhsan."

Malik said, "All (of the people of knowledge) I have seen said that a slave-girl makes a free man muhsan when he marries her and consummates the marriage."

Malik said, "A slave makes a free woman muhsana when he consummates a marriage with her and a free woman only makes a slave muhsan when he is freed and he is her husband and has had sexual relations with her after he has been set free. If he parts from her before he is free, he is not a muhsan unless he marries her after having been set free and he consummates the marriage."

Malik said, "When a slave-girl is married to a free man and then he separates from her before she is set free, his marriage to her does not make her muhsana. She is not muhsana until she has married after she has been set free and she has had intercourse with her husband. That gives her ihsan. If she is the wife of a freeman and then she is set free while she is his wife before he separates from her, the man makes her muhsana if he has intercourse with her after she has been set free."

Malik said, "The christian and jewish free women and the muslim slave-girl all make a muslim free man muhsan when he marries one of them and has intercourse with her."


Malik :: Marriage :: [28-28.18.41]

Marriage

Malik :: Book 28 : Hadith 28.18.41

Yahya related to me from Malik from Ibn Shihab from Abdullah and Hasan, the sons of Muhammad ibn Ali ibn Abi Talib from their ather, mayAllah be pleased with him, that the Messenger of Allah, may Allah bless him and grant him peace, forbade temporary marriage with women and the flesh of domestic donkeys on the Day of Khaybar.


Malik :: Marriage :: [28-28.18.42]

Marriage

Malik :: Book 28 : Hadith 28.18.42

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that Khawla ibn Hakim came to Umar ibn al-Khattab and said, ''Rabia ibn Umayya made a temporary marriage with a woman and she is pregnant by him.'' Umar ibn al-Khattab went out in dismay dragging his cloak, saying, "This temporary marriage, had I come across it, I would have ordered stoning and done away with it! "


Malik :: Marriage :: [28-28.19.43]

Marriage

Malik :: Book 28 : Hadith 28.19.43

Yahya related to me from Malik that he heard Rabia ibn Abd ar-Rahman say that a slave could marry four women.

Malik said, "This is the best of what I have heard about the matter."

Malik said, "The slave differs with the muhallil if the slave is given permission by his master for his ex-wife. If his master does not give him permission, he separates them. The muhallil is separated in any case if he intends to make the woman halal by marriage."

Malik said, "When a slave is owned by his wife or a husband owns his wife, the possession of each of them is rendered void without divorce. If a man, for instance, is married to a slave-girl, and then he buys her, he must divorce her as a matter of course. They can then re-marry. If they re-marry afterwards, that separation was not divorce."

Malik said, "When a slave is freed by his wife who owns him and she is in the idda-period from him, they can only return to each other after she has made another marriage."


Malik :: Marriage :: [28-28.20.44]

Marriage

Malik :: Book 28 : Hadith 28.20.44

Malik related to me from Ibn Shihab that he had heard that in the time of the Messenger of Allah, may Allah bless him and grant him peace, women were becoming muslim in their own lands and they did not do hijra while their husbands were still kafirun although they themselves had become muslim. Among them was the daughter of al-Walid ibn al-Mughira and she was the wife of Safwan ibn Umayya. She became muslim on the day of the conquest (of Makka), and her husband, Safwan ibn Umayya fled from Islam. The Messenger of Allah, may Allah bless him and grant him peace, sent Safwan's paternal cousin, Wahb ibn Umayr with the cloak of the Messenger of Allah, may Allah bless him and grant him peace, as a safe-conduct for Safwan ibn Umayya, and the Messenger of Allah, may Allah bless him and grant him peace, called him to Islam and asked for him to come to him and if he was pleased with the matter to accept it. If not he would have a respite for two months.

When Safwan came to the Messenger of Allah, may Allah bless him and grant him peace, with his cloak, he called out to him over the heads of the people, "Muhammad! Wahb ibn Umayr brought me your cloak and claimed that you had summoned me to come to you and if I was pleased with the matter, I should accept it and if not, you would give me a respite for two months. "The Messenger of Allah, may Allah bless him and grant him peace, said, "Come down, Abu Wahb." He said, "No, by Allah! I will not come down until you make it clear to me." The Messenger of Allah, may Allah bless him and grant him peace, said, "You have a respite of four months." The Messenger of Allah, may Allah bless him and grant him peace, went out toward Hawazin at Hunayn. He sent to Safwan ibn Umayya to borrow some equipment and arms that he had. Safwan said, "Willingly or unwillingly?" He said, "Willingly." Therefore he lent him the equipment and arms which he had. Then Safwan went out with the Messenger of Allah, may Allah bless him and grant him peace, while he was still a kafir. He was present at the battles of Hunayn and at-Ta'if while he was still a kafir and his wife was a muslim. The Messenger of Allah, may Allah bless him and grant him peace, did not separate Safwan and his wife until he had become muslim, and his wife was settled with him by that marriage.


Malik :: Marriage :: [28-28.20.45]

Marriage

Malik :: Book 28 : Hadith 28.20.45

Yahya related to me from Malik that Ibn Shihab said, "Between the Islam of Safwan and the Islam of his wife there was about one month."

Ibn Shihab said, "We have not heard about any woman doing hijra for Allah and His Messenger while her husband was a kafir abiding in the land of kufr, but that her hijra separated her and her husband unless her husband came in hijra before her period of idda had been completed."


Malik :: Marriage :: [28-28.20.46]

Marriage

Malik :: Book 28 : Hadith 28.20.46

Yahya related to me from Malik from Ibn Shihab that Umm Hakim bint al-Harith ibn Hisham who was the wife of Ikrima ibn Abi Jahl became muslim on the day of the conquest of Makka, and her husband Ikrima fled from Islam as far as the Yemen. Umm Hakim set out after him until she came to him in the Yemen and she called him to Islam, and he became muslim. He went to the Messenger of Allah, may Allah bless him and grant him peace, in the year of the conquest. When the Messenger of Allah, may Allah bless him and grant him peace, saw him, he rushed to him in joy and did not bother to put on his cloak until he had made the pledge with him. They were confirmed in their marriage.

Malik said, "If a man becomes muslim before his wife, a separation occurs between them when he presents Islam to her and she does not become muslim, because Allah, the Blessed, the Exalted, said in His Book, 'Do not hold fast to the ties of women who are kafirun.' "


Malik :: Marriage :: [28-28.21.47]

Marriage

Malik :: Book 28 : Hadith 28.21.47

Yahya related to me from Malik from Humayd at-Tawil from Anas ibn Malik that Abd ar-Rahman ibn Awf came to the Messenger of Allah, may Allah bless him and grant him peace, and he had a traceof yellow on him. The Messenger of Allah, may Allah bless him and grant him peace, asked about it. He told him that he had just been married. The Messenger of Allah, may Allah bless him and grant him peace, said, "How much did you hand over to her?" He said, "The weight of a date pit in gold." The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Hold a feast, even if it is only with a sheep.


Malik :: Marriage :: [28-28.21.48]

Marriage

Malik :: Book 28 : Hadith 28.21.48

Yahya related to me from Malik that Yahya ibn Said said, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, held a wedding feast in which there was neither meat nor bread."


Malik :: Marriage :: [28-28.21.49]

Marriage

Malik :: Book 28 : Hadith 28.21.49

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you are invited to a wedding feast, you must go to it."


Malik :: Marriage :: [28-28.21.50]

Marriage

Malik :: Book 28 : Hadith 28.21.50

Yahya related to me from Malik from Ibr. Shihab from al-Araj that Abu Hurayra said, "The worst food is the food of a wedding feast to which the rich are invited and the poor are left out. If anyone rejects an invitation, he has rebelled against Allah and His Messenger."


Malik :: Marriage :: [28-28.21.51]

Marriage

Malik :: Book 28 : Hadith 28.21.51

Yahya related to me from Malik that Ishaq ibn Abdullah ibn Abi Talha heard Anas ibn Malik say that a certain tailor invited the Messenger of Allah, may Allah bless him and grant him peace, to eat some food which he had prepared.

Anas said, "I went with the Messenger of Allah, may Allah bless him and grant him peace, to eat the food. He served barley bread and a soup with pumpkin in it. I saw the Messenger of Allah, may Allah bless him and grant him peace, going after the pumpkin around the dish, so I have always liked pumpkin since that day."


Malik :: Marriage :: [28-28.22.52]

Marriage

Malik :: Book 28 : Hadith 28.22.52

Yahya related to me from Malik from Zayd ibn Aslam that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you marry a woman or buy a slave-girl, take her by the forelock and ask for baraka. When you buy a camel, take the top of its hump, and seek refuge with Allah from Shaytan."


Malik :: Marriage :: [28-28.22.53]

Marriage

Malik :: Book 28 : Hadith 28.22.53

Yahya related to me from Malik from Abu'z-Zubayr al-Makki that somebody asked a man for his sister in marriage and the man mentioned that she had committed fornication. Umar ibn al-Khattab heard about it and he beat the man or almost beat him, and said, "What did you mean by giving him such information?"


Malik :: Marriage :: [28-28.22.54]

Marriage

Malik :: Book 28 : Hadith 28.22.54

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that al-Qasim ibn Muhammad and Urwa ibn az-Zubayr said that a man who had four wives and then divorced one of them irrevocably, could marry straightaway if he wished, and he did not have to wait for the completion of her idda.


Malik :: Marriage :: [28-28.22.55]

Marriage

Malik :: Book 28 : Hadith 28.22.55

Yahya related to me from Malik from Rabia ibn Abd ar-Rahman that al-Qasim ibn Muhammad and Urwa ibn az-Zubayr gave the same judgement to al-Walid ibn Abd al-Malik in the year of his arrival in Madina except that al-Qasim ibn Muhammad said that he divorced his wife on various occasions. (i.e. not at one time).


Malik :: Marriage :: [28-28.22.56]

Marriage

Malik :: Book 28 : Hadith 28.22.56

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "There are three things in which there is no jest: marriage, divorce, and setting free."


Malik :: Marriage :: [28-28.22.57]

Marriage

Malik :: Book 28 : Hadith 28.22.57

Yahya related to me from Malik from Ibn Shihab that Rafi ibn Khadij married the daughter of Muhammad ibn Maslama al-Ansari. She was with him until she grew older, and then he married a young girl and preferred the young girl to her. She begged him to divorce her, so he divorced her and then he gave her time until she had almost finished her idda period and then he returned and still preferred the young girl. She therefore asked him to divorce her. He divorced her once, and then returned to her, and still preferred the young girl, and she asked him to divorce her. He said, "What do you want? There is only one divorce left. If you like, continue and put up with what you see of preference, and if you like, I will separate from you." She said, "I will continue in spite of the preference." He kept her in spite of that. Rafi did not see that he had done any wrong action when she remained with him in spite of preference.


Malik :: Divorce :: [29-29.1.1]

Divorce

Malik :: Book 29 : Hadith 29.1.1

Yahya related to me from Malik that he had heard that a man said to Abdullah ibn Abbas, "I have divorced my wife by saying I divorce you a hundred times. What do you think my situation is?" Ibn Abbas said to him, "She was divorced from you by three pronouncements, and by the ninety-seven, you have mocked the ayat of Allah."


Malik :: Divorce :: [29-29.1.2]

Divorce

Malik :: Book 29 : Hadith 29.1.2

Yahya related to me from Malik that he had heard that a man came to Abdullah ibn Masud and said, "I have divorced my wife by saying I divorce you eight times." Ibn Masud said to him, "What have people told you?" He replied, "I have been told that I have to part absolutely from her." Ibn Masud said, "They have spoken the truth. A person who divorces as Allah has commanded, Allah makes it clear for him, and a person who obscures himself in error, we make stay by his error. So do not confuse yourselves and pull us into your confusion. It is as they have said."


Malik :: Divorce :: [29-29.1.3]

Divorce

Malik :: Book 29 : Hadith 29.1.3

Yahya related to me from Malik from Yahya ibn Said from Abu Bakr ibn Hazm thatUmar ibn Abd al-Aziz had asked him what people said about the 'irrevocable' divorce, and Abu Bakr had replied that Aban ibn Uthman had clarified that it was declared only once. Umar ibn Abd al-Aziz said, "Even if divorce had to be declared a thousand times, the'irrevocable' would use them all up. A person who says, 'irrevocably' has cast the furthest limit."


Malik :: Divorce :: [29-29.1.4]

Divorce

Malik :: Book 29 : Hadith 29.1.4

Yahya related to me from Malik from Ibn Shihab that Marwan ibn al-Hakam decided that if someone made three pronouncements of divorce, he had divorced his wife irrevocably.

Malik said, "That is what I like best of what I have heard on the subject."

29.2 Divorce by Euphemistic Statements


Malik :: Divorce :: [29-29.1.5]

Divorce

Malik :: Book 29 : Hadith 29.1.5

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab had heard in a letter from Iraq that a man said to his wife, "Your rein is on your withers (i.e. you have free rein)." Umar ibn al-Khattab wrote to his governor to order the man to come to him at Makka at the time of hajj. While Umar was doing tawaf around the House, a man met him and greeted him. Umar asked him who he was, and he replied that he was the man that he had ordered to be brought to him. Umar said to him, "I ask you by the Lord of this building, what did you mean by your statement, 'Your rein is on your withers.'?" The man replied, "Had you made me swear by other than this place, I would not have told you the truth. I intended separation by that." Umar ibn al- Khattab said, "It is what you intended."


Malik :: Divorce :: [29-29.1.6]

Divorce

Malik :: Book 29 : Hadith 29.1.6

Yahya related to me from Malik that he had heard that Ali ibn Abi Talib used to say that if a man said to his wife, "You are haram for me," it counted as three pronouncements of divorce.

Malik said, "That is the best of what I have heard on the subject."


Malik :: Divorce :: [29-29.1.7]

Divorce

Malik :: Book 29 : Hadith 29.1.7

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said that statements like "I cut myself off from you",or"You are abandoned", were considered as three pronouncements of divorce.

Malik said that any strong statements such as these or others were considered as three pronouncements of divorce for a woman whose marriage had been consummated. In the case of a woman whose marriage had not been consummated, the man was asked to make an oath on his deen, as to whether he had intended one or three pronouncements of divorce. If he had intended one pronouncement, he was asked to make an oath by Allah to confirm it, and he became a suitor among other suitors, because a woman whose marriage had been consummated, required three pronouncements of divorce to make her inaccessible for the husband, whilst only one pronouncement was needed to make a woman whose marriage had not been consummated inaccessible.

Malik added, "That is the best of what I have heard about the matter."


Malik :: Divorce :: [29-29.1.8]

Divorce

Malik :: Book 29 : Hadith 29.1.8

Yahya related to me from Malik from Yahya ibn Said from al-Qasim ibn Muhammad that a certain man had taken a slave-girl belonging to somebody else as a wife. He said to her people, "She is your concern," and people considered that to be one pronouncement of divorce.


Malik :: Divorce :: [29-29.1.9]

Divorce

Malik :: Book 29 : Hadith 29.1.9

Yahya related to me from Malik that he heard Ibn Shihab say that if a man said to his wife, "You are free of me, and I am free of you, " it counted as three pronouncements of divorce as if it were an 'irrevocable' divorce.

Malik said that if a man made any strong statement such as these to his wife, it counted as three pronouncements of divorce for a woman whose marriage had been consummated, or it was written as one of three for a woman whose marriage had not been consummated, whichever the man wished. If he said he intended only one divorce he swore to it and he became one of the suitors because, whereas a woman whose marriage had been consummated was made inaccessible by three pronouncements of divorce, the woman whose marriage had not been consummated was made inaccessible by only one pronouncement.

Malik said, "That is the best of what I have heard."


Malik :: Divorce :: [29-29.2.10]

Divorce

Malik :: Book 29 : Hadith 29.2.10

Yahya related to me from Malik that he had heard that a man came to Abdullah ibn Umar, and said, "Abu Abd ar-Rahman! I placed the command of my wife in her hand, and she divorced herself, what do you think?" Abdullah ibn Umar said, "I think that it is as she said." The man said, "Don't do it, Abu Abd ar-Rahman!" Ibn Umar said, "You did it, it has nothing to do with me."


Malik :: Divorce :: [29-29.2.11]

Divorce

Malik :: Book 29 : Hadith 29.2.11

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "When a man gives a woman command over herself, then the result is as she decides unless he denies it and says that he only meant to give her one divorce and he swears to it - then he has access to her while she is in her idda."


Malik :: Divorce :: [29-29.3.12]

Divorce

Malik :: Book 29 : Hadith 29.3.12

Yahya related to me from Malik from Said ibn Sulayman ibn Zayd ibn Thabit that Kharija ibn Zayd ibn Thabit told him that he was sitting with Zayd ibn Thabit when Muhammad ibn Abi Atiq came to him with his eyes brimming with tears. Zayd asked him what the matter was. He said, "I gave my wife command of herself, and she separated from me." Zayd said to him, "What made you do that?" He said, "The Decree." Zayd said, "Return to her if you wish for it is only one pronouncement, and you have access to her."


Malik :: Divorce :: [29-29.3.13]

Divorce

Malik :: Book 29 : Hadith 29.3.13

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that a man of Thaqif gave his wife command over herself, and she said, "You are divorced." He was silent. She said, "You are divorced." He said, "May a stone be in your mouth." She said, "You are divorced." He said, "May a stone be in your mouth." They argued and went to Marwan ibn al-Hakam. He took an oath that he had only given her control over one pronouncement, and then she returned to him.

Malik said that Abd ar-Rahman declared that this decision had amazed al-Qasim, who thought it the best that he had heard on the subject.

Malik added, "That is also the best of what I have heard on the subject."


Malik :: Divorce :: [29-29.4.14]

Divorce

Malik :: Book 29 : Hadith 29.4.14

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha, umm al-muminin, proposed to Qurayba bint Abi Umayya on behalf of Abd ar-Rahman ibn Abi Bakr. They married her to him and her people found fault with Abd ar-Rahman and said, "We only gave in marriage because of A'isha." A'isha therefore sent for Abd ar-Rahman and told him about it. He gave Qurayba authority over herself and she chose her husband and so there was no divorce.


Malik :: Divorce :: [29-29.4.15]

Divorce

Malik :: Book 29 : Hadith 29.4.15

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, gave Hafsa bint Abd arRahman in marriage to al-Mundhir ibn az-Zubayr while Abd ar-Rahman was away in Syria. When Abd ar-Rahman arrived, he said, "Shall someone like me have this done to him? Am I the kind of man to have something done to him without his consent?" A'isha spoke to al-Mundhir ibn az-Zubayr, and al-Mundhir said, "It is in the hands of Abd ar-Rahman." Abd ar-Rahman said, "I won't oppose something that you have already completed." Hafsa was confirmed with al-Mundhir, and there was no divorce.


Malik :: Divorce :: [29-29.4.16]

Divorce

Malik :: Book 29 : Hadith 29.4.16

Yahya related to me from Malik that he had heard that Abdullah ibn Umar and Abu Hurayra were asked about a man who gave his wife power over herself, and she returned it to him without doing anything with it. They said that there was no divorce. (i.e. The man's giving his wife power over herself was not interpreted as a desire for divorce on his part.)

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "If a man gives his wife authority over herself, and she does not separate from him and remains with him, there is no divorce."

Malik said that a woman whose husband gave her power over herself and they separated while she was unwilling, had no power to revoke the divorce. She only had power over herself as long as they remained together.


Malik :: Divorce :: [29-29.5.17]

Divorce

Malik :: Book 29 : Hadith 29.5.17

Yahya related to me from Malik from Jafar ibn Muhammad from his father that Ali ibn Abi Talib said, "When a man takes a vow to abstain from intercourse, divorce does not occur immediately. If four months pass, he must declare his intent and either he is divorced or he revokes his vow . "

Malik said, "That is what is done among us."


Malik :: Divorce :: [29-29.5.18]

Divorce

Malik :: Book 29 : Hadith 29.5.18

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "When a man makes a vow to abstain from intercourse with his wife and four months have passed he must declare his intent and either he is divorced or he revokes his vow. Divorce does not occur until four months have passed and he continues to abstain."

Yahya related to me from Malik from Ibn Shihab that Said al-Musayyab and Abu Bakr ibn Abd ar-Rahman said about a man who made a vow to abstain from intercourse with his wife, "If four months pass it is a divorce. The husband can go back to his wife as long as she is in her idda."


Malik :: Divorce :: [29-29.5.19]

Divorce

Malik :: Book 29 : Hadith 29.5.19

Yahya related to me from Malik that he had heard that Marwan ibn al-Hakam decided about a man who had made a vow to abstain from intercourse with his wife, that when four months had passed, it was a divorce and he could return to her as long as she was in her idda.

Malik added, "That was also the opinion of Ibn Shihab."

Malik said that if a man made a vow to abstain from intercourse with his wife and at the end of four months he declared his intent to continue to abstain, he was divorced. He could go back to his wife, but if he did not have intercourse with her before the end of her idda, he had no access to her and he could not go back to her unless he had an excuse - illness, imprisonment, or a similar excuse. His return to her maintained her as his wife. If her idda passed and then he married her after that and did not have intercourse with her until four months had passed and he declared his intent to continue to abstain, divorce was applied to him by the first vow. If four months passed, and he had not returned to her, he had no idda against her nor access because he had married her and then divorced her before touching her.

Malik said that a man who made a vow to abstain from intercourse with his wife and continued to abstain after four months and so divorced her, but then returned and did not touch her and four months were completed before her idda was completed, did not have to declare his intent and divorce did not befall him. If he had intercourse with her before the end of her idda, he was entitled to her. If her idda passed before he had intercourse with her, he had no access to her. This is what Malik preferred of what he had heard on the subject.

Malik said that if a man made a vow to abstain from intercourse with his wife and then divorced her, and the four months of the vow were completed before completion of the idda of the divorce, it counted as two pronouncements of divorce. If he declared his intention to continue to abstain and the idda of the divorce finished before the four months the vow of abstention was not a divorce. That was because the four months had passed and she was not his on that day.

Malik said, "If someone makes a vow not to have intercourse with his wife for a day or a month and then waits until more than four months have passed, it is not ila. Ila only applies to someone who vows more than four months. As for the one who vows not to have intercourse with his wife for four months or less than that, I do not think that it is ila because when the term enters into it at which it stops, he comes out of his oath and he does not have to declare his intention."

Malik said, "If someone vows to his wife not to have intercourse with her until her child has been weaned, that is not ila. I have heard that Ali ibn Abi Talib was asked about that and he did not think that it was ila."


Malik :: Divorce :: [29-29.6.19]

Divorce

Malik :: Book 29 : Hadith 29.6.19

Yahya related to me from Malik that he had asked Ibn Shihab about the ila of the slave. He said that it was like the ila of the free man, and it put an obligation on him. The ila of the slave was two months.


Malik :: Divorce :: [29-29.7.20]

Divorce

Malik :: Book 29 : Hadith 29.7.20

Yahya related to me from Malik from Said ibn Amr ibn Sulaym az-Zuraqi that he asked al-Qasim ibn Muhammad about a man who made divorce conditional on his marrying a woman i.e. if he married her he would automatically divorce her. Al-Qasim ibn Muhammad said, "If a man marries a woman whom he has made as his mother's back, i.e. has made haram for him, Umar ibn al-Khattab ordered him not to go near her if he married her until he had done the kaffara for pronouncing dhihar."


Malik :: Divorce :: [29-29.7.21]

Divorce

Malik :: Book 29 : Hadith 29.7.21

Yahya related to me from Malik that he had heard that a man asked al-Qasim ibn Muhammad and Sulayman ibn Yasar about a man who pronounced dhihar from his wife before he had married her. They said, "If he marries her, he must not touch her until he has done the kaffara for pronouncing dhihar."


Malik :: Divorce :: [29-29.7.22]

Divorce

Malik :: Book 29 : Hadith 29.7.22

Yahya related to me from Malik from Hisham ibn Urwa that his father said that a man who pronounced a dhihar from his four wives in one statement, had only to do one kaffara. Yahya related the same as that to me from Malik from Rabia ibn Abi Abd ar-Rahman.

Malik said, "That is what is done among us. Allah, the Exalted said about the kaffara for pronouncing dhihar, 'It is to free a slave before they touch one another. If he does not find the means to do that, then fasting for two consecutive months before they touch one another. If he cannot do that, it is to feed sixty poor people. ' " (Sura 58 ayats 4,5).

Malik said that a man who pronounced dhihar from his wife on various occasions had only to do one kaffara. If he pronounced dhihar, and then did kaffara, and then pronounced dhihar after he had done the kaffara, he had to do kaffara again.

Malik said, "Some one who pronounces dhihar from his wife and then has intercourse with her before he has done kaffara, only has to do one kaffara. He must abstain from her until he does kaffara and ask forgiveness of Allah. That is the best of what I have heard. "

Malik said, "It is the same with dhihar using any prohibited relations of fosterage and ancestry."

Malik said, "Women have no dhihar."

Malik said that he had heard that the commentary on the word of Allah, the Blessed, the Exalted, "Those of you who pronounce the dhihar about their wives, and then retract what they have said," (Sura 56 ayat 3), was that a man pronounced dhihar on his wife and then decided to keep her and have intercourse with her. If he decided on that, he must do kaffara. If he divorced her and did not decide to retract his dhihar of her and to keep her and have intercourse with her, there would be no kaffara incumbent on him.

Maliksaid, "If he marries her after that, he does not touch her until he has completed the kaffara of pronouncing dhihar."

Malik said that if a man who pronounced dhihar from his slave-girl wanted to have intercourse with her, he had to do the kaffara of the dhihar before he could sleep with her.

Malik said, "There is no ila in a man's dhihar unless it is evident that he does not intend to retract his dhihar."


Malik :: Divorce :: [29-29.7.23]

Divorce

Malik :: Book 29 : Hadith 29.7.23

Yahya related to me from Malik from Hisham ibn Urwa that he heard a man ask Urwa ibn az-Zubayr about a man who said to his wife, "Any woman I marry along with you as long as you live will be like my mother's back to me." Urwa ibn az-Zubayr said, "The freeing of slaves is enough to release him from that."


Malik :: Divorce :: [29-29.8.24]

Divorce

Malik :: Book 29 : Hadith 29.8.24

ahya related to me from Malik that he asked Ibn Shihab about the dhihar of a slave. He said, "It is like the dhihar of a free man."

Malik said, "He meant that the same conditions were applied in both cases."

Malik said, "The dhihar of the slave is incumbent on him, and the fasting of the slave in the dhihar is two months. "

Malik said that there was no ila for a slave who pronounced a dhihar from his wife. That was because if he were to fast the kaffara for pronouncing a dhihar, the divorce of the ila would come to him before he had finished the fast.


Malik :: Divorce :: [29-29.9.25]

Divorce

Malik :: Book 29 : Hadith 29.9.25

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman from al-Qasim ibn Muhammad that A'isha umm al-muminin, said, "There were three sunnas established in connection with Barira: firstly was that when she was set free she was given her choice about her husband, secondly, the Messenger of Allah, may Allah bless him and grant him peace, said about her, 'The right of inheritance belongs to the person who has set a person free,' thirdly, the Messenger of Allah, may Allah bless him and grant him peace, came in and there was a pot with meat on the boil. Bread and condiments were brought to him from the stock of the house. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Didn't I see a pot with meat in it?' They said, 'Yes, Messenger of Allah. That is meat which was given as sadaqa for Barira, and you do not eat sadaqa.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'It is sadaqa for her, and it is a gift for us.' "


Malik :: Divorce :: [29-29.9.26]

Divorce

Malik :: Book 29 : Hadith 29.9.26

ahya related to me from Malik from Nafi that Abdullah ibn Umar said that a female slave who was the wife of a slave and then was set free, had the right of choice as long as he did not have intercourse with her.

Malik said, "If her husband has intercourse with her and she claims that she did not know, she still has the right of choice. If she is suspect and one does not believe her claim of ignorance, then she has no choice after he has had intercourse with her."


Malik :: Divorce :: [29-29.9.27]

Divorce

Malik :: Book 29 : Hadith 29.9.27

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that a mawla of the tribe of Banu Adi called Zabra told him that she had been the wife of a slave when she was a slave-girl. Then she was set free and she sent a message to Hafsa, the wife of the Prophet, may Allah bless him and grant him peace. Hafsa called her and said, "I will tell you something., but I would prefer that you did not act upon it. You have authority over yourself as long as your husband does not have intercourse with you. If he has intercourse with you, you have no authority at all." Therefore she pronounced her divorce from him three times.


Malik :: Divorce :: [29-29.9.28]

Divorce

Malik :: Book 29 : Hadith 29.9.28

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab said that if a man married a woman, and he was insane or had a physical defect, she had the right of choice. If she wished she could stay, and if she wished she could separate from him.


Malik :: Divorce :: [29-29.9.29]

Divorce

Malik :: Book 29 : Hadith 29.9.29

Malik said that if a slave-girl, who was the wife of a slave, was set free before he had consummated the marriage, and she chose herself, then she had no bride-price and it was a pronouncement of divorce. That was what was done among them.


Malik :: Divorce :: [29-29.9.30]

Divorce

Malik :: Book 29 : Hadith 29.9.30

Yahya related to me that Malik heard Ibn Shihab say, "When a man gives his wife the right of choice, and she chooses him, that is not divorce."

Malik added, "That is the best of what I have heard."

Malik said that if a woman who had been given the right of choice by her husband chose herself, she was divorced trebly. If her husband said, "But I only gave her the right of choice in one," he had none of that. That was the best of what he had heard.

Malik said, "If the man gives his wife the right of choice and she says, 'I accept one', and he says, 'I did not mean that, I have given the right of choice in all three together,' then if she only accepts one, she remains with him in her marriage, and that is not separation if Allah, the Exalted wills."


Malik :: Divorce :: [29-29.10.31]

Divorce

Malik :: Book 29 : Hadith 29.10.31

Yahya related. to me from Malik from Yahya ibn Said that Amra bint Abd ar-Rahman told him from Habiba bint Sahl al-Ansari that she had been the wife of Thabit ibn Qays ibn Shammas. The Messenger of Allah, may Allah bless him and grant him peace, went out for the dawn prayer, and found Habiba bint Sahl at his door in the darkness. The Messenger of Allah, may Allah bless him and grant him peace, said to her, "Who is this?" She said, "I am Habiba bint Sahl, Messenger of Allah." He said, "What do you want?" She said, "That Thabit ibn Qays and I separate." When her husband, Thabit ibn Qays came, the Messenger of Allah, may Allah bless him and grant him peace, said to him, "This is Habiba bint Sahl. She mentioned what Allah willed that she mention." Habiba said, "Messenger of Allah, all that he has given me is with me!" The Messenger of Allah, may Allah bless him and grant him peace, said to Thabit ibn Qays, "Take it from her," and he took it from her, and she stayed in the house of her family.


Malik :: Divorce :: [29-29.10.32]

Divorce

Malik :: Book 29 : Hadith 29.10.32

Yahya related to me from Malik from Nafi from a mawla of Safiyya bint Abi Ubayd that she gave all that she possessed to her husband as compensation for her divorce from him, and Abdullah ibn Umar did not disapprove of that.

Malik said that divorce was ratified for a woman who ransomed herself from her husband, when it was known that her husband was detrimental to her and was oppressive for her, and it was known that he wronged her, and he had to return her property to her. Malik added, "This is what I have heard, and it is what is done among us."

Malik said, "There is no harm if a woman ransoms herself from her husband for more than he gave her."


Malik :: Divorce :: [29-29.11.33]

Divorce

Malik :: Book 29 : Hadith 29.11.33

Yahya related to me from Malik from Nafi that Rubayyi bint Muawwidh ibn Afra came with her paternal uncle to Abdullah ibn Umar and told him that she had divorced her husband for a compensation in the time of Uthman ibn Affan, and he heard about it and did not disapprove. Abdullah ibn Umar said, "Her idda is the idda of a divorced woman."

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar and Ibn Shihab all said that a woman who divorced for a compensation had the same idda as a divorced woman - three periods.

Malik said that a woman who ransomed herself could not return to her husband except by a new marriage. If someone married her and then separated from her before he had intercourse with her, there was no idda against her from the recent marriage, and she rested on her first idda.

Malik said, "That is the best that I have heard on the matter."

Malik said, "If, when a woman offers to compensate her husband, he divorces her straightaway, then that compensation is confirmed for him. If he makes no response, and then at a later date, does divorce her, he is not entitled to that compensation."


Malik :: Divorce :: [29-29.12.34]

Divorce

Malik :: Book 29 : Hadith 29.12.34

Yahya related to me from Malik from Ibn Shihab that Sahl ibn Sad as-Saidi told him that Uwaymir al-Ajlani came to Asim ibn Adi al-Ansari and said to him, "Asim! What do you think a man who finds another man with his wife should do? Should he kill him and then be killed himself, or what should .he do? Asim! ask the Messenger of Allah, may Allah bless him and grant him peace, about that for me." Asim asked the Messenger of Allah, may Allah bless him and grant him peace, about it. The Messenger of Allah, may Allah bless him and grant him peace, was revolted by the questions and reproved them until what he heard from the Messenger of Allah, may Allah bless him and grant him peace. was intolerable for Asim. When Asim returned to his people, Uwaymir came to him and said, " Asim! what did the Messenger of Allah, may Allah bless him and grant him peace, say to you?" Asim said to Uwaymir, "You didn't bring me any good. The Messenger of Allah, may Allah bless him and grant him peace, was revolted by the question which I asked him." Uwaymir said, "By Allah! I will not stop until I ask him about it!" Uwaymir stood up and went to the Messenger of Allah, may Allah bless him and grant him peace, in the middle of the people and said, "Messenger of Allah! What do you think a man who finds another man with his wife should do? Should he kill him and then be killed himself, or what should he do?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Something has been sent down about you and your wife, so go and bring her."

Sahl continued, "They mutually cursed one another in the presence of the Messenger, may Allah bless him and grant him peace, and I was present with the people. When they finished cursing each other, Uwaymir said, 'I shall have lied about her, Messenger of Allah, if I keep her,' and pronounced the divorce three times before the Messenger of Allah, may Allah bless him and grant him peace, ordered him to do it."

Malik said that Ibn Shihab said, "That was how the sunna of a couple mutually cursing each other was established (lian)."


Malik :: Divorce :: [29-29.12.35]

Divorce

Malik :: Book 29 : Hadith 29.12.35

Yahya related to me from Malik from Nafic from Abdullah ibn Umar that a man cursed his wife in the time of the Messenger of Allah, may Allah bless him and grant him peace, and disowned her child. The Messenger of Allah, may Allah bless him and grant him peace, separated them and gave the child to the woman.

Malik said, "Allah the Blessed, the Exalted, said, 'The testimony of men who accuse their wives but do not have any witnesses except themselves is to testify by Allah four times that he is being truthful, and a fifth time, that the curse of Allah will be upon him, if he should be a liar. She will avoid punishment if she testifies by Allah four times that he is a liar, and a fifth time, that the wrath of Allah shall be upon her, if he should be telling the truth. ' "(Sura 24 ayat 6).

Malik said, "The sunna with us is that those who curse each other are never to be remarried. If the man calls himself a liar, (i.e. takes back his accusation), he is flogged with the hadd-punishment, and the child is given to him, and his wife can never return to him. There is no doubt or dispute about this sunna among us. "

Malik said, "If a man separates from his wife by an irrevocable divorce by which he cannot return to her, and then he denies the paternity of the child she is carrying, whilst she claims that he is the father, and it is possible by the timing, that he be so, he must curse her, and the child is not recognised as his."

Malik said, "That is what is done among us, and it is what I have heard from the people of knowledge."

Malik said that a man who accused his wife after he had divorced her trebly while she was pregnant, and he had at first accepted being the father but then claimed that he had seen her committing adultery before he separated from her, was flogged with the hadd-punishment, and did not curse her.

If he denied the paternity of her child after he had divorced her trebly, and he had not previously accepted it, then he cursed her.

Malik said, "This is what I have heard."

Malik said, "The slave is in the same position as the free man as regards making accusations and invoking mutual curses (lian). He acts in the lian as the free man acts although there is no hadd applied for slandering a female-slave."

Malik said, "The muslim slave-girl and the christian and jewish free woman also do lian when a free muslim marries one of them and has intercourse with her. That is because Allah - may He be blessed and Exalted, said in His Book, 'As for those who accuse their wives,' and they are their wives. This is what is done among us.

Malik said that a man who did the lian with his wife, and then stopped and called himself a liar after one or two oaths and he had not cursed himself in the fifth one, had to be flogged with the hadd-punishment, but they did not have to be separated.

Malik said that if a man divorced his wife and then after three months the woman said, "I am pregnant," and he denied paternity, then he had to do lian.

Malik said that the husband of a female slave who pronounced the lian on her and then bought her, was not to have intercourse with her, even if he owned her. The sunna which had been handed down about a couple who mutually cursed each other in the lian was that they were never to return to each other.

Malik said that when a man pronounced the lian against his wife before he had consummated the marriage, she only had half of the bride price.


Malik :: Divorce :: [29-29.13.36]

Divorce

Malik :: Book 29 : Hadith 29.13.36

Yaha related to me from Malik that he had heard that Urwa ibn az-Zubayr said that if the child of the woman against whom lian had been pronounced or the child of fornication, died, his mother inherited from him her right in the Book of Allah the Exalted, and his maternal half-brothers had their rights. The rest was inherited by the owners of his mother's wala' if she was a freed slave. If she was an ordinary free woman, she inherited her right, his maternal brothers inherited their rights, and the rest went to the muslims.

Malik said,"I heard the same as that from Sulayman ibn Yasar, and it is what I saw the people of knowledge in our city doing."


Malik :: Divorce :: [29-29.14.37]

Divorce

Malik :: Book 29 : Hadith 29.14.37

Yahya related to me from Malik from Ibn Shihab from Muhammad ibn Abd ar-Rahman ibn Thawban that Muhammad ibn Iyas ibn al-Bukayr said, "A man divorced his wife three times before he had consummated the marriage, and then it seemed good to him to marry her. Therefore, he wanted an opinion, and I went with him to ask Abdullah ibn Abbas and Abu Hurayra on his behalf about it, and they said, 'We do not think that you should marry her until she has married another husband.' He protested that his divorcing her had been only once. Ibn Abbas said, 'You threw away what you had of blessing.' "


Malik :: Divorce :: [29-29.14.38]

Divorce

Malik :: Book 29 : Hadith 29.14.38

Yahya related to me from Malik from Yahya ibn Said that Bukayr ibn Abdullah al-Ashajj informed him that Muawiya ibn Abi Ayyash al-Ansari told him that he was sitting with Abdullah ibn az-Zubayr and Asim ibn Umar ibn al-Khattab when Muhammad ibn Iyas ibn al-Bukayr came up to them and said, "A man from the desert has divorced his wife three times before consummating the marriage, what do you think?" Abdullah ibn az-Zubayr said "This is something about which we have no statement. Go to Abdullah ibn Abbas and Abu Hurayra. I left them with A'isha. Ask them and then come and tell us." He went and asked them. Ibn Abbas said to Abu Hurayra, "Give an opinion, Abu Hurayra! A difficult one has come to you." Abu Hurayra said, "One pronouncement separates her and three makes her haram until she has married another husband." Ibn Abbas said the like of that.

Malik said, "That is what is done among us, and when a man marries a woman who has been married before, and he has not had intercourse with her, she is treated as a virgin - one pronouncement separates her and three make her haram until she has married another husband."


Malik :: Divorce :: [29-29.15.40]

Divorce

Malik :: Book 29 : Hadith 29.15.40

Yahya related to me from Malik from Ibn Shihab that Talha ibn Abdullah ibn Awf said, and he knew that better than them, from Abu Salama ibn Abd ar-Rahman ibn Awf that Abd ar-Rahman ibn Awf divorced his wife irrevocably while he was terminally ill, and Uthman ibn Affan made her an heir after the end of her idda.


Malik :: Divorce :: [29-29.15.41]

Divorce

Malik :: Book 29 : Hadith 29.15.41

Yahya related to me from Malik from Abdullah ibn al-Fadl from al-Araj that Uthman ibn Affan made the wives of ibn Mukmil inherit from him, and he had divorced them while he was terminally ill.


Malik :: Divorce :: [29-29.15.42]

Divorce

Malik :: Book 29 : Hadith 29.15.42

Yahya related to me from Malik that he heard Rabia ibn Abi Abd ar-Rahman say, ''I heard that the wife of Abd ar-Rahman ibn Awf asked him to divorce her. He said, 'When you have menstruated and are pure, then come to me.' She did not menstruate until Abd ar-Rahman ibn Awf was ill. When she was purified, she told him and he divorced her irrevocably or made a pronouncement of divorce which was all that he had left over her Abd arRahman ibn Awf was terminally ill at the time, so Uthman ibn Affan made her one of the heirs after the end of her idda."


Malik :: Divorce :: [29-29.15.43]

Divorce

Malik :: Book 29 : Hadith 29.15.43

Yahya related to me from Malik from Yahya ibn Said that Muhammad ibn Yahya ibn Habban said, "My grandfather Habban had two wives, one from the Hashimites and one from the Ansars. He divorced the Ansariyya while she was nursing, and a year passed and he died and she had still not yet menstruated. She said, 'I inherit from him. I have not menstruated yet.' The wives quarrelled and went to Uthman ibn Affan. He decided that she did inherit, and the Hashimiyya rebuked Uthman. He said, 'This is the practice of the son of your paternal uncle. He pointed this out to us.' He meant Ali ibn Abi Talib."


Malik :: Divorce :: [29-29.15.44]

Divorce

Malik :: Book 29 : Hadith 29.15.44

Yahya related to me from Malik that he had heard Ibn Shihab say, "When a man who is terminally ill divorces his wife three times, she inherits from him."

Malik said, "If he divorces her while he is terminally ill before he has consummated the marriage, she has half of the bride-price and inherits, and she does not have to do an idda. If he consummated the marriage, she has all the dowry and inherits. The virgin and the previously married woman are the same in this situation according to us."


Malik :: Divorce :: [29-29.16.45]

Divorce

Malik :: Book 29 : Hadith 29.16.45

Yahya related to me from Malik that he had heard that Abd ar-Rahman ibn Awf divorced his wife, and gave her compensation in the form of a slave-girl.

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "Every divorced woman has compensation except for the one who is divorced and is allocated a bride-price and has not been touched. She has half of what was allocated to her."


Malik :: Divorce :: [29-29.16.46]

Divorce

Malik :: Book 29 : Hadith 29.16.46

Yahya related to me from Malik that Ibn Shihab said, "Every divorced woman has compensation."

Malik said, "I have also heard the same as that from al-Qasim ibn Muhammad."

Malik said, "There is no fixed limit among us as to how small or large the compensation is."


Malik :: Divorce :: [29-29.17.47]

Divorce

Malik :: Book 29 : Hadith 29.17.47

Yahya related to me from Malik from Abu'z-Zinad from Sulayman ibn Yasar that Nufay, a mukatab of Umm Salama the wife of the Prophet, may Allah bless him and grant him peace, or her slave, had a free woman as a wife. He divorced her twice, and then he wanted to return to her. The wives of the Prophet, may Allah bless him and grant him peace, ordered him to go to Uthman ibn Affan to ask him about it. He found him at ad-Daraj with Zayd ibn Thabit. He asked them, and they both anticipated him and said, "She is haram for you. She is haram for you."


Malik :: Divorce :: [29-29.17.48]

Divorce

Malik :: Book 29 : Hadith 29.17.48

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that Nufay, a mukatab of Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, divorced his free wife twice, so he asked Uthman ibn Affan for an opinion, and he said, "She is haram for you."


Malik :: Divorce :: [29-29.17.49]

Divorce

Malik :: Book 29 : Hadith 29.17.49

Yahya related to me from Malik from Abdu Rabbih ibn Said from Muhammad ibn Ibrahim ibn al-Harith at-Taymi that Nufay, a mukatab of Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, asked Zayd ibn Thabit for an opinion. He said, "I have divorced my free wife twice." Zayd ibn Thabit said, "She is haram for you."


Malik :: Divorce :: [29-29.17.50]

Divorce

Malik :: Book 29 : Hadith 29.17.50

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "When the slave divorces his wife twice, she is haram for him until she has married another husband, whether she is free or a slave. The idda of a free woman is three menstrual periods, and the idda of a slave-girl is two periods.


Malik :: Divorce :: [29-29.17.51]

Divorce

Malik :: Book 29 : Hadith 29.17.51

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "If a man gives his slave permission to marry, the divorce is in the hand of the slave, and nobody else has any power over his divorce. Nothing is held against a man who takes the slave-girl of his male slave or the slave-girl of his female-slave."


Malik :: Divorce :: [29-29.18.51]

Divorce

Malik :: Book 29 : Hadith 29.18.51

Malik said, "Neither a free man nor a slave who divorces a slave-girl nor a slave who divorces a free woman, in an irrevocable divorce, is obliged to pay maintenance even if she is pregnant, and he cannot return to her."

Malik said, "A free man is not obliged to pay for the suckling of his son when he is a slave of other people, nor is a slave obliged to spend his money for what his master owns except with the permission of his master."


Malik :: Divorce :: [29-29.19.52]

Divorce

Malik :: Book 29 : Hadith 29.19.52

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that Umar ibn al-Khattab said, "The woman who loses her husband and does not know where he is, waits for four years, then she does idda for four months, and then she is free to marry."

Malik said, "If she marries after her idda is over, regardless of whether the new husband has consummated the marriage or not, her first husband has no means of access to her."

Malik said, "That is what is done among us and if her husband reaches her before she has remarried, he is more entitled to her."

Malik said that he had seen people disapproving of someone who said that one of the people (of knowledge) attributed to Umar ibn al-Khattab that he said, "Her first husband chooses when he comes either her bride-price or his wife."

Malik said, "I have heard that Umar ibn al-Khattab, speaking about a woman whose husband divorced her while he was absent from her, and then he took her back and the news of his taking her back had not reached her, while the news of his divorcing her had, and so she had married again, said, 'Her first husband who divorced her has no means of access to her whether or not the new husband has consummated the marriage.' "

Malik said, "This is what I like the best of what I heard about the missing man."


Malik :: Divorce :: [29-29.20.53]

Divorce

Malik :: Book 29 : Hadith 29.20.53

Yahya related to me from Malik from Nafi that Abdullah ibn Umar divorced his wife while she was menstruating in the time of the Messenger of Allah, may Allah bless him and grant him peace, Umar ibn al-Khattab asked the Messenger of Allah, may Allah bless him and grant him peace, about it. The Messenger of Allah, may Allah bless him and grant him peace, said, "Go and tell him to take her back and keep her until she is purified and then has a period and then is purified. Then if he wishes, he an keep her, and if he wishes he should divorce her before he has intercourse with her. That is the idda which Allah has commanded for women who are divorced."


Malik :: Divorce :: [29-29.20.54]

Divorce

Malik :: Book 29 : Hadith 29.20.54

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha, umm al-muminin, that she took Hafsa ibn Abd ar-Rahman ibn Abi Bakr as-Siddiq into her house when she had entered the third period of her idda. Ibn Shihab said, "That was mentioned to Amra bint Abd ar-Rahman, and she said that Urwa had spoken the truth and people had argued with A'isha about it. They said that Allah, the Blessed, the Exalted, said in His Book, 'Three quru.' A'isha said, 'You spoke the truth. Do you know what quru are? Quru are times of becoming pure after menstruation .' "


Malik :: Divorce :: [29-29.20.55]

Divorce

Malik :: Book 29 : Hadith 29.20.55

Yahya related to me from Malik that Ibn Shihab said that he heard Abu Bakr ibn Abd ar-Rahman say, "I have never seen any of our fuqaha who did not say that this was what the statement of A'isha meant."


Malik :: Divorce :: [29-29.20.56]

Divorce

Malik :: Book 29 : Hadith 29.20.56

Yahya related to me from Malik from Nafi and Zayd ibn Aslam from Sulayman ibn Yasar that al-Ahwas died in Syria when his wife had begun her third menstrual period after he had divorced her. Muawiya ibn Abi Sufyan wrote and asked Zayd ibn Thabit about that. Zayd wrote to him, "When she began her third period, she was free from him and he was free from her, and he does not inherit from her nor she from him."


Malik :: Divorce :: [29-29.20.57]

Divorce

Malik :: Book 29 : Hadith 29.20.57

Yahya related to me from Malik that he had heard that Abu Bakr ibn Abd ar-Rahman and Sulayman ibn Yasar and Ibn Shihab used to say, "When the divorced woman enters the beginning of her third period, she is clearly separated from her husband and there is no inheritance between them and he has no access to her."


Malik :: Divorce :: [29-29.20.58]

Divorce

Malik :: Book 29 : Hadith 29.20.58

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "When a man divorces his wife and she begins her third period, she is free from him and he is free from her."

Malik said, "This is how things are done among us."


Malik :: Divorce :: [29-29.20.59]

Divorce

Malik :: Book 29 : Hadith 29.20.59

Yahya related to me from Malik from al-Fudayl ibn Abi Abdullah, the mawla of al-Mahri that al-Qasim ibn Muhammad and Salim ibn Abdullah said, "When a woman is divorced and begins her third period, she is clearly separated from him and is free to marry again."


Malik :: Divorce :: [29-29.20.60]

Divorce

Malik :: Book 29 : Hadith 29.20.60

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Ibn Shihab and Sulayman ibn Yasar all said, "The idda of the woman with a khul divorce is three periods."


Malik :: Divorce :: [29-29.20.61]

Divorce

Malik :: Book 29 : Hadith 29.20.61

Yahya related to me from Malik that he heard Ibn Shihab say, "The idda of the divorced woman is reckoned by the menstrual cycles even if she is estranged ." (The reason the idda is normally reckoned by the menstrual cycle is to see whether the woman is pregnant or not.)


Malik :: Divorce :: [29-29.20.62]

Divorce

Malik :: Book 29 : Hadith 29.20.62

Yahya related to me from Malik from Yahya ibn Said from a man of the Ansar that his wife asked him for a divorce, and he said to her, "When you have had your period, then tell me." When she had her period, she told him. He said, "When you are purified then tell me." When she was purified, she told him and he divorced her.

Malik said, "This is the best of what I have heard about it."


Malik :: Divorce :: [29-29.21.63]

Divorce

Malik :: Book 29 : Hadith 29.21.63

Yahya related to me from Malik thal Yahya ibn Said heard al-Qasim ibn Muhammad and Sulayman ibn Yasar both mention that Yahya ibn Said ibn al-As divorced the daughter of Abd ar-Rahman ibn al-Hakam irrevocably, so Abd ar-Rahman ibn al-Hakam took her away A'isha umm al-muminin sent to Marwan ibn al-Hakam who was the Amir of al-Madina at that time. She said, "Fear Allah and make him return the woman to her house." Marwan said in what Sulayman related, ''Abd ar-Rahman has the upper hand over me." Marwan said in what al-Qasim related, "Hasn't the affair of Fatima bint Qays reached you?" A'isha said, "You are forced to mention the story of Fatima " Marwan said, "If you know that evil, whatever evil there was between those two is enough for you." (See hadith 67.)


Malik :: Divorce :: [29-29.21.64]

Divorce

Malik :: Book 29 : Hadith 29.21.64

Yahya related to me from Malik from Nafi that the daughter of Said ibn Zayd ibn Amr ibn Nufayl was the wife of Abdullah ibn Umar ibn Uthman ibn Affan, and he divorced her irrevocably and she moved out. Abdullah ibn Umar rebuked her for that.


Malik :: Divorce :: [29-29.21.65]

Divorce

Malik :: Book 29 : Hadith 29.21.65

Yahya related to me from Malik from Nafi that Abdullah ibn Umar divorced one of his wives in the house of Hafsa, the wife of the Prophet, may Allah bless him and grant him peace, while he was on the way to the mosque. He went another route from behind the houses being averse to ask permission to enter until he returned to her.


Malik :: Divorce :: [29-29.21.66]

Divorce

Malik :: Book 29 : Hadith 29.21.66

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab was asked who was obliged to pay the rent for a woman whose husband divorced her while she was in a leased house. Said ibn al-Musayyab said, "Her husband is obliged to pay it." Someone asked, "what if her husband does not have it?" He said, "Then she must pay it." Someone asked, "And if she does not have it?" He said, "Then the Amir must pay it."


Malik :: Divorce :: [29-29.22.67]

Divorce

Malik :: Book 29 : Hadith 29.22.67

Yahya related to me from Malik from Abdullah ibn Yazid, the mawla of al-Aswad ibn Sufyan from Abu Salama ibn Abd ar-Rahman ibn Awf from Fatima bint Qays that Abu Amr ibn Hafs divorced her absolutely while he was away in Syria. His agent sent her some barley and she was displeased with it, saying, "By Allah, I don't expect anything from you." She went to the Messenger of Allah, may Allah bless him and grant him peace, and mentioned it to him. He said, "You have no maintenance." He then ordered her to spend her idda in the house of Umm Sharik. Then he said, "This is a woman whom my companions visit. Spend the idda in the house of Ibn Umm Maktum. He is a blind man and you can undress at his home. When you are free to remarry, tell me."

She continued, "When I was free to remarry, I mentioned to him that Muawiya ibn Abi Sufyan and Abu Jahm ibn Hisham had asked for me in marriage. The Messenger of Allah, may Allah bless him and grant him peace, said, 'As for Abu Jahm, he never puts down his stick from his shoulder (i.e. he is always travelling), and as for Muawiya he is a poor man with no property. Marry Usama ibn Zayd.' I objected to him and he said, 'Marry Usama ibn Zayd,' so I married him, and Allah put good in it and I was content with him."


Malik :: Divorce :: [29-29.22.68]

Divorce

Malik :: Book 29 : Hadith 29.22.68

Yahya related to me from Malik that he heard Ibn Shihab say, "The woman who is absolutely divorced does not leave her house until she is free to remarry. She has no maintenance unless she is pregnant. In that circumstance the husband spends on her until she gives birth."

Malik said, "This is what is done among us."


Malik :: Divorce :: [29-29.23.69]

Divorce

Malik :: Book 29 : Hadith 29.23.69

Malik said, "What is done among us when a slave divorces a slave-girl when she is a slave and then she is set free, is that her idda is the idda of a slave-girl, and her being set free does not change her idda whether or not he can still return to her. Her idda is not altered."

Malik added, "The hadd-punishment which a slave incurs is the same as this. When he is freed after he has incurred but before the punishment has been executed, his hadd is the hadd of the slave."

Malik said, "When a free man divorces a slave-girl three times, her idda is two periods. When a slave divorces a free woman twice, her idda is three periods."

Malik said about a man who had a slave-girl as a wife, and he bought her and set her free, ''Her idda is the idda of a slave-girl, i.e. two periods, as long as he has not had intercourse with her. If he has had intercourse with her after buying her and before he set her free, she only has to wait until one period has passed . "


Malik :: Divorce :: [29-29.24.70]

Divorce

Malik :: Book 29 : Hadith 29.24.70

Yahya related to me from Malik from Yahya ibn Said and from Yazid ibn Abdullah ibn Qusayt al-Laythi that Said ibn al-Musayyab said, ''Umar ibn al-Khattab said, 'If a woman is divorced and has one or two periods and then stops menstruating, she must wait nine months. If it is clear that she is pregnant, that is that. If not, she must do an idda of three months after the nine, and then she is free to marry.' "

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "Divorce belongs to men, and women have the idda."


Malik :: Divorce :: [29-29.24.71]

Divorce

Malik :: Book 29 : Hadith 29.24.71

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "The idda of the woman who bleeds constantly is a year."

Malik said, "What is done among us about a divorced woman whose periods stop when her husband divorces her is that she waits nine months. If she has not had a period in them, she has an idda of three months. If she has a period before the end of the three months, she accepts the period. If another nine months pass without her having a period, she does an idda of three months. If she has a second period before the end of those three months, she accepts the period. If nine months then pass without a period, she does an idda of three months. If she has a third period, the idda of the period is complete. If she does not have a period, she waits three months, and then she is free to marry. Her husband can return to her before she becomes free to marry unless he made her divorce irrevocable."

Malik said, "The sunna with us is that when a man divorces his wife and has the option to return to her, and she does part of her idda and then he returns to her and then parts from her before he has had intercourse with her, she does not add to what has passed of her idda. Her husband has wronged himself and erred if he returned to her and had no need of her."

Malik said, "What is done among us is that if a woman becomes a muslim while her husband is a kafir and then he becomes muslim, he is entitled to her as long as she is in her idda. If her idda is finished, he has no access to her. If he remarries her after the end of her idda, however, that is not counted as divorce. Islam removed her from him without divorce."


Malik :: Divorce :: [29-29.25.72]

Divorce

Malik :: Book 29 : Hadith 29.25.72

Yahya related to me from Malik that he had heard that Ali ibn Abi Talib said about the two arbiters about whom Allah, the Exalted, said,"If you fear a breach between the two, appoint an arbiter from his people, and an arbiter from her people. If they desire to set things aright, Allah will make peace between them, surely Allah is Knowing, Aware," (Sura 4 ayat 35), that the separation and the joining were overseen by the two of them.

Malik said, "That is the best of what I have heard from the people of knowledge. Whatever the two arbiters say concerning separation or joining is taken into consideration "


Malik :: Divorce :: [29-29.26.73]

Divorce

Malik :: Book 29 : Hadith 29.26.73

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab, Abdullah ibn Umar, Abdullah ibn Masud, Salim ibn Abdullah, al-Qasim ibn Muhammad, Ibn Shihab,and Sulayman ibn Yasar all said, "If a man has vowed to divorce his wife before marrying her and then he breaks his vow, divorce is obligatory for him when he marries her."

Yahya related to me from Malik that he had heard that Abdullah ibn Masud said that there was nothing binding on someone who said, "Every woman I marry is divorced," if he did not name a specific tribe or woman.

Malik said, "That is the best of what I have heard."

Malik said about a man saying to his wife, "You are divorced, and every woman I marry is divorced," or that all his property would be sadaqa if he did not do such-and-such, and he broke his oath: "As for his wives, it is divorce as he said, and as for his statement, 'Every woman I marry is divorced', if he did not name a specific woman, tribe, or land, or such, it is not binding on him and he can marry as he wishes. As for his property, he gives a third of it away as sadaqa."


Malik :: Divorce :: [29-29.27.74]

Divorce

Malik :: Book 29 : Hadith 29.27.74

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "If someone marries a woman and cannot have intercourse with her, there is a deadline of a year set for him to have intercourse with her. If he does not, they are separated."


Malik :: Divorce :: [29-29.27.754]

Divorce

Malik :: Book 29 : Hadith 29.27.754

Yahya related to me from Malik that he had asked Ibn Shihab about whether the deadline was set from the day he had married her, or from the day she raised the question before the Sultan. He said. 'It is from the day she presents it before the Sultan.'

Malik said, "As for someone who has intercourse with his wife and then is prevented from intercourse with her, I have not heard that there is a deadline set for him or that they are separated."


Malik :: Divorce :: [29-29.28.76]

Divorce

Malik :: Book 29 : Hadith 29.28.76

Yahya related to me from Malik that Ibn Shihab said, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, said to a man from Thaqif who had ten wives when he became muslim, 'Take four and separate from the rest.' "


Malik :: Divorce :: [29-29.28.77]

Divorce

Malik :: Book 29 : Hadith 29.28.77

Yahya related to me from Malik that Ibn Shihab said that he had heard Said ibn al-Musayyab, Humayd ibn Abd ar-Rahman ibn Awf, Ubaydullah ibn Abdullah ibn Utba ibn Masud, and Sulayman ibn Yasarall say, that they had heard Abu Hurayra say that he had heard Umar ibn al-Khattab say, "If a woman is divorced by her husband once or twice, and he leaves her until she is free to marry and she marries another husband and he dies or divorces her, and then she marries her first husband, she is with him according to what remains of her divorce."

Malik said, "That is what is done among us and there is no dispute about it."


Malik :: Divorce :: [29-29.28.78]

Divorce

Malik :: Book 29 : Hadith 29.28.78

Yahya related to me from Malik from Thabit ibn al-Ahnaf that he married an umm walad of Abd ar-Rahman ibn Zayd ibn al-Khattab. He said, "Abdullah ibn Abd ar-Rahman ibn Zayd ibn al-Khattab summoned me and I went to him. I came in upon him and there were whips and two iron fetters placed there, and two of his slaves whom he had made to sit there. He said, 'Divorce her, or by He by whom one swears, I will do such-and-such to you!' I said, 'It is divorce a thousand times.' Then I left him and I saw Abdullah ibn Umar on the road to Makka and I told him about my situation. Abdullah ibn Umar was furious, and said, 'That is not divorce, and she is not haram for you, so return to your home.' I was still not at ease so I went to Abdullah ibn az-Zubayr who was the Amir of Makka at that time. I told him about my situation and what Abdullah ibn Umar had said to me. Abdullah ibn az-Zubayr said to me, 'She is not haram for you, so return to your home,' and he wrote to Jabir ibn al-Aswad az-Zuhra who was the Amir of Madina and ordered him to punish Abdullah ibn Abdar-Rahman and to have him leave me and my family alone. I went to Madina, and Safiyya, the wife of Abdullah ibn Umar fitted out my wife so that she could bring her to my house with the knowledge of Abdullah ibn Umar. Then I invited Abdullah ibn Umar on the day of my wedding to the wedding feast and he came."


Malik :: Divorce :: [29-29.28.79]

Divorce

Malik :: Book 29 : Hadith 29.28.79

Yahya related to me from Malik that Abdullah ibn Dinar said, "I heard Abdullah ibn Umar recite from the Qur'an, 'Prophet! When you divorce women, divorce them at the beginning of their idda.'"

Malik said, "He meant by that, to make one pronouncement of divorce at the beginning of each period of purity."


Malik :: Divorce :: [29-29.28.80]

Divorce

Malik :: Book 29 : Hadith 29.28.80

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "It used to be that a man would divorce his wife and then return to her before her idda was over, and that was alright, even if he divorced her a thousand times. The man went to his wife and then divorced her and when the end of her idda was in sight, he took her back and then divorced her and said, 'No! By Allah, I will not go to you and you will never be able to marry again.' Allah, the Blessed, the Exalted, sent down, 'Divorce is twice, then honourable retention or setting free kindly.' People then turned towards divorce in a new light from that day whether or not they were divorced or not divorced."


Malik :: Divorce :: [29-29.28.81]

Divorce

Malik :: Book 29 : Hadith 29.28.81

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili that Allah, the Blessed, the Exalted, sent down about a man who divorced his wife and then returned to her while he had no need of her and did not mean to keep her so as to make the idda period long for her by that in order to do her harm, "Do not retain them by force, to transgress. Whoever does that has wronged himself." (Sura 2 ayat 231). Allah warns them by that ayat.


Malik :: Divorce :: [29-29.28.82]

Divorce

Malik :: Book 29 : Hadith 29.28.82

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar were asked about a man who divorced when he was drunk. They said, "When a drunk man divorces, his divorce is allowed. If he kills, he is killed for it."

Malik said, "That is what is done among us."

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab said, "If a man does not find the means to spend on his wife, they are to be separated . "

Malik said, "That is what I saw the people of knowledge in our city doing."

29.30 Idda of Widows when Pregnant


Malik :: Divorce :: [29-29.29.83]

Divorce

Malik :: Book 29 : Hadith 29.29.83

Yahya related to me from Malik from Abdu Rabbih ibn Said ibn Qays that Abu Salama ibn Abd ar-Rahman said that Abdullah ibn Abbas and Abu Hurayra were asked when a pregnant woman whose husband had died could remarry. Ibn Abbas said, "At the end of two periods." Abu Hurayra said, "When she gives birth, she is free to marry." Abu Salama ibn Abd ar-Rahman visited Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, and asked her about it Umm Salama said, ''Subaya al-Aslamiya gave birth half a month after the death of her husband, and two men asked to marry her. One was young and the other was old. She preferred the young man and so the older man said, 'You are not free to marry yet.' Her family were away and he hoped that when her family came, they would give her to him. She went to the Messenger of Allah, may Allah bless him and grant him peace, and he said, 'You are free to marry, so marry whomever you wish.' "


Malik :: Divorce :: [29-29.29.84]

Divorce

Malik :: Book 29 : Hadith 29.29.84

Yahya related to me from Malik from Nafi that Abdullah ibn Umar was asked about a woman whose husband died while she was pregnant, and he said, "When she gives birth, she is free to marry." A man of the Ansar who was with him told him that Umar ibn al-Khattab had said, "Had she given birth while her husband was still on his bed, unburied, she would be free to marry."


Malik :: Divorce :: [29-29.29.85]

Divorce

Malik :: Book 29 : Hadith 29.29.85

Yahya related to me from Malik from Hisham ibn 'Urwa from his father that al-Miswar ibn Makhrama told him that Subaya al-Aslamiya gave birth a few nights after the death of her husband. The Messenger of Allah, may Allah bless him and grant him peace, said to her, "You are free to marry, so marry whomever you wish."


Malik :: Divorce :: [29-29.29.86]

Divorce

Malik :: Book 29 : Hadith 29.29.86

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Abdullah ibn Abbas and Abu Salama ibn Abd ar-Rahman ibn Awf differed on the question of a wornan who gave birth a few nights after the death of her husband. Abu Salama said, "When she gives birth to the child she is carrying, she is free to marry." Ibn Abbas said, "At the end of two periods." Abu Hurayra came and said, "I am with my nephew", meaning Abu Salama. They sent Kurayb, a mawla of Abdullah ibn Abbas to Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, to ask her about it. He came back and told them that she had said that Subaya al-Aslamiya had given birth a few nights after the death of her husband, and she had brought the matter to the Messenger of Allah, may Allah bless him and grant him peace, and he had said, "You are free to marry, so marry whomever you wish."

Malik said, "This is how the people of knowledge here continue to act."

29.31 Widows Remaining in Their Houses until Free to Marry


Malik :: Divorce :: [29-29.29.87]

Divorce

Malik :: Book 29 : Hadith 29.29.87

Yahya related to me from Malik from Said ibn Ishaq ibn Kab ibn Ujra from his paternal aunt, Zaynab bint Kab ibn Ujra that al-Furaya bint Malik ibn Sinan, the sister of Abu Said al-Khudri, informed her that she went to the Messenger of Allah, may Allah bless him and grant him peace, and asked to be able to return to her people among the Banu Khudra since her husband had gone out in search of some of his slaves who had run away and he had caught up with them near al-Qudum, (which is 6 miles from Madina), and they had killed him.

She said, "I asked the Messenger of Allah, may Allah bless him and grant him peace, if I could return to my people in the Banu Khudra, as my husband had not left me in a dwelling which belonged to him, and had left me no maintenance. The Messenger of Allah, may Allah bless him and grant him peace, said,'Yes.' So I left. When I was in the courtyard, the Messenger of Allah, may Allah bless him and grant him peace, called me or summoned me, and I answered him. He said, 'What did you say?' I repeated the story about my husband. He said, 'Stay in your house until what is written reaches its term.' I did the idda in the house for four months and ten days."

She added, "When Uthman ibn Affan sent for me, I told him that, and he followed it and made decisions by it."


Malik :: Divorce :: [29-29.29.88]

Divorce

Malik :: Book 29 : Hadith 29.29.88

Yahya related to me from Malik from Humayd ibn Qays al-Makki from Amr ibn Shuayb from Said ibn al-Musayyab that Umar ibn al-Khattab sent back widows from the desert and prevented them from doing the hajj.

Yahya related to me from Malik from Yahya ibn Saqd that he had heard that as-Sa'ib ibn Khabbab died, and his wife went to Abdullah ibn Umar and mentioned to him that her husband had died and mentioned some land which they had at Qanah, (a district on the outskirts of Madina), and asked him if it would be alright for her to stay overnight there. He forbade her to do so. So, she went out before dawn from Madina and spent the whole day on their land, but when evening came, she spent the night in her house.


Malik :: Divorce :: [29-29.29.89]

Divorce

Malik :: Book 29 : Hadith 29.29.89

Yahya related to me from Malik that Hisham ibn Urwa said about a Bedouin woman whose husband died, that she was to stay where her people stayed.

Malik said, "This is what is done among us."


Malik :: Divorce :: [29-29.29.90]

Divorce

Malik :: Book 29 : Hadith 29.29.90

Yahya related to me from Malik from Nafi that Abdullan ibn Umar said, "The only place a woman whose husband has died and a woman who is absolutely divorced can spend the night is in their houses."


Malik :: Divorce :: [29-29.30.91]

Divorce

Malik :: Book 29 : Hadith 29.30.91

Yahya related to me from Malik that Yahya ibn Said said that he had heard al-Qasim ibn Muhammad say that Zayd ibn Abd al-Malik separated some men and their wives who were slave-girls who had borne children to men who had died, because they had married them after one or two menstrual periods. He separated them until they had done an idda of four months and ten days. Al-Qasim ibn Muhammad said, "Glory be to Allah! Allah says in His Book, 'Those of you who die, leaving wives, they are not wives.' "


Malik :: Divorce :: [29-29.30.92]

Divorce

Malik :: Book 29 : Hadith 29.30.92

Malik related to me from Nafi that Abdullah ibn Umar said, "The idda of an umm walad when her master dies is one menstrual period."

Yahya related to me from Malik from Yahya ibn Said that al-Qasim ibn Muhammad said, "The idda of an umm walad when her master dies is one menstrual period."

Malik said, "This is what is done among us."

Malik added, "If she does not have a menstrual period, her idda is three months."


Malik :: Divorce :: [29-29.31.93]

Divorce

Malik :: Book 29 : Hadith 29.31.93

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar said, "The idda of a slave-girl when her husband dies is two months and five days."


Malik :: Divorce :: [29-29.31.94]

Divorce

Malik :: Book 29 : Hadith 29.31.94

Yahya related to me the like of that from Malik from Ibn Shihab.

Malik said, about a slave who divorced a slave-girl but did not make it absolute, "He can return to her. If he then dies while she is still in the idda from her divorce, she does the idda of a slave-girl whose husband dies, and it is two months and five days. If she has been set free and he can return to her, and she does not choose to separate after she has been set free, and he dies while she is in the idda from the divorce, she does the idda of a free woman whose husband has died, four months and ten days. That is because the idda of widowhood befell her while she was free, so her idda is the idda of a free woman."

Malik said, "That is what is done among us."


Malik :: Divorce :: [29-29.32.95]

Divorce

Malik :: Book 29 : Hadith 29.32.95

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman from Muhammad ibn Yahya ibn Habban that Ibn Muhayriz said, "I went into the mosque and saw Abu Said al-Khudri and so I sat by him and asked him about coitus interruptus. Abu Said al-Khudri said, 'We went out with the Messenger of Allah, may Allah bless him and grant him peace, on the expedition to the Banu al-Mustaliq. We took some Arabs prisoner, and we desired the women as celibacy was hard for us. We wanted the ransom, so we wanted to practise coitus interruptus. We said, 'Shall we practise coitus interruptus while the Messenger of Allah, may Allah bless him and grant him peace, is among us before we ask him?' We asked him about that and he said, 'You don't have to not do it. There is no self which is to come into existence up to the Day of Rising but that it will come into existence.' "


Malik :: Divorce :: [29-29.32.96]

Divorce

Malik :: Book 29 : Hadith 29.32.96

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah from Amir ibn Sad ibn Abi Waqqas from his father that he used to practise coitus interruptus.


Malik :: Divorce :: [29-29.32.97]

Divorce

Malik :: Book 29 : Hadith 29.32.97

Yahya related to me from Malik from Abu'n-Nadr, the mawla of Umar ibn Ubaydullah from Ibn Aflah, the mawla of Abu Ayyub al-Ansari from an umm walad of Abu Ayyubal-Ansari that he practised coitus interruptus.


Malik :: Divorce :: [29-29.32.98]

Divorce

Malik :: Book 29 : Hadith 29.32.98

Yahya related to me from Malik from Nafi that Abdullah ibn Umar did not practise coitus interruptus and thought that it was disapproved.


Malik :: Divorce :: [29-29.32.99]

Divorce

Malik :: Book 29 : Hadith 29.32.99

Yahya related to me from Malik from Damra ibn Said al-Mazini from al-Hajjaj ibn Amr ibn Ghaziya that he was sitting with Zayd ibn Thabit when Ibn Fahd came to him. He was from the Yemen. He said, "Abu Said! I have slave-girls. None of the wives in my keep are more pleasing to me than them, and not all of them please me so much that I want a child by them, shall I then practise coitus interruptus?" Zayd ibn Thabit said, "Give an opinion, Hajjaj!" "I said, 'May Allah forgive you! We sit with you in order to learn from you!' He said, 'Give an opinion! 'I said, 'She is your field, if you wish, water it, and if you wish, leave it thirsty. I heard that from Zayd.' Zayd said, 'He has spoken the truth.' "


Malik :: Divorce :: [29-29.32.100]

Divorce

Malik :: Book 29 : Hadith 29.32.100

Yahya related to me from Malik from Humayd ibn Qays al-Makki that a man called Dhafif said that Ibn Abbas was asked about coitus interruptus. He called a slave-girl of his and said, "Tell them." She was embarrassed. He said, "It is alright, and I do it myself."

Malik said, "A man does not practise coitus interruptus with a free woman unless she gives her permission. There is no harm in practising coitus interruptus with a slave-girl without her permission. Someone who has someone else's slave-girl as a wife, does not practise coitus interruptus with her unless her people give him permission."


Malik :: Divorce :: [29-29.33.101]

Divorce

Malik :: Book 29 : Hadith 29.33.101

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from Humayd ibn Nafi that Zaynab bint Abi Salama related these three traditions to him. Zaynab said, "I visited Umm Habiba, the wife of the Prophet, may Allah bless him and grant him peace, when her father Abu Sufyan ibn Harb had died. Umm Habiba called for a yellowy perfume perhaps khaluq or something else. She rubbed the perfume first on a slave-girl and she then wiped it on the sides of her face and said, 'By Allah! I have no need of perfume but I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'It is not halal for a woman who trusts in Allah and the Last Day to abstain from adornment in mourning for someone who has died, for more than three nights, except for four months and ten days for a husband.' "


Malik :: Divorce :: [29-29.33.102]

Divorce

Malik :: Book 29 : Hadith 29.33.102

Zaynab said, "I went to the house of Zaynab bint Jahsh, the wife of the Prophet, may Allah bless him and grant him peace, when her brother had died. She called for perfume and put some on and said, 'By Allah! I have no need of perfume, but I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'It is not halal for a woman who trusts in Allah and the Last Day to abstain from adornment in mourning for someone who has died for more than three nights, except for four months and ten days for a husband.' "


Malik :: Divorce :: [29-29.33.103]

Divorce

Malik :: Book 29 : Hadith 29.33.103

Zaynab said, "I heard my mother, Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, say that a woman came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah! My daughter's husband died, and her eyes are troubling her, can she put kohl on them?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'No' two or three times. Then he said, 'It is only four months and ten days. In the Jahiliyya, none of you threw away the piece of dung until a year had passed.' "

Humayd ibn Nafi said, "I asked Zaynab to explain what 'throwing away the piece of dung at the end of a year' meant. Zaynab said, 'In the Jahiliyya when a woman's husband died, she went into a small tent and dressed in the worst of clothes. She did not touch perfume or anything until a year had passed. Then she was brought an animal - a donkey, a sheep, or a bird, and she would break her idda with it, by rubbing her body against it (taftaddu). Rarely did she break her idda with anything (by rubbing herself against it) but that it died. Then she would come out and would be given a piece of dung. She would throw it away and then return to whatever she wished of perfumes or whatever.' "

Malik explained, 'Taftaddu' means to wipe her skin with it in the same way as with a healing charm."


Malik :: Divorce :: [29-29.33.104]

Divorce

Malik :: Book 29 : Hadith 29.33.104

Yahya related to me from Malik from Nafi from Safiyya bint Abi Ubayd from A'isha and Hafsa, the wives of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "It is not halal for a woman in mourning for someone who has died, if she trusts in Allah and the Last Day, to abstain from adornment for more than three nights, except for a husband."


Malik :: Divorce :: [29-29.33.105]

Divorce

Malik :: Book 29 : Hadith 29.33.105

Yahya related to me from Malik that he had heard that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said to a woman in mourning for her husband whose eyes were troubling her and the pain had become very strong, "Apply jala kohl at night and wipe it off in the day."


Malik :: Divorce :: [29-29.33.106]

Divorce

Malik :: Book 29 : Hadith 29.33.106

Yahya related to me from Malik that he had heard that Salim ibn Abdullah and Sulayman ibn Yasar said that if a woman whose husband had died feared that an inflammation of her eyes might affect her sight or that some complaint might befall her, she should put kohl on and seek a remedy with kohl or some other cure even if it had perfume in it.

Malik said, "If there is a necessity, the deen of Allah is ease."


Malik :: Divorce :: [29-29.33.107]

Divorce

Malik :: Book 29 : Hadith 29.33.107

Yahya related to me from Malik from Nafic that Saffiyya bint Abi Ubayd suffered from an eye-complaint while she was in mourning for her husband, Abdullah ibn Umar. She did not apply kohl until her eyes almost had ramas (a dry white secretion in the corners of the eye).

Malik said, "A woman whose husband has died should anoint her eyes with olive oil and sesame oil and the like of that since there is no perfume in it."

Malik said, "A woman in mourning for her husband should not put on any jewellery - rings, anklets, or such-like, neither should she dress in any sort of colourful, striped garment unless it is coarse. She should not wear any cloth dyed with anything except black, and she should only dress her hair with things like lotus-tree leaves which do not dye the hair."


Malik :: Divorce :: [29-29.33.108]

Divorce

Malik :: Book 29 : Hadith 29.33.108

108 Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, visited Umm Salama while she was in mourning for Abu Salama and she had put aloes on her eyes. He said, "What is this, Umm Salama?" She said, "It is only aloes, Messenger of Allah." He said, "Put it on at night and wipe it off in the daytime."

Malik said, "The mourning of a young girl who has not yet had a menstrual period takes the same form as the mourning of one who has had a period. She avoids what a mature woman avoids if her husband dies."

Malik said, "A slave-girl mourns her husband when he dies for two months and five nights like her idda.''

Malik said, "An umm walad does not have to mourn when her master dies, and a slave-girl does not have to mourn when her master dies. Mourning is for those with husbands."


Malik :: Divorce :: [29-29.33.109]

Divorce

Malik :: Book 29 : Hadith 29.33.109

Yahya related to me from Malik that he had heard that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said, "A mourning woman can rub her head with lotus leaves and olive oil.''


Malik :: Suckling :: [30-30.1.1]

Suckling

Malik :: Book 30 : Hadith 30.1.1

Yahya related to me from Malik from Abdullah ibn Abi Bakr from Amra bint Abd ar-Rahman that A'isha, umm al-muminin informed her that the Messenger of Allah, may Allah bless him and grant him peace, was with her and she heard the voice of a man asking permission to enter the room of Hafsa. A'isha said that she had said, "Messenger of Allah! There is a man asking permission to enter your house!" The Messenger of Allah, may Allah bless him and grant him peace, said, "I think it is so-and-so" (referring to a paternal uncle of Hafsa by suckling). A'isha said, "Messenger of Allah! If so-and-so were alive (referring to her paternal uncle by suckling) could he enter where I am?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes. Suckling makes haram as birth makes haram."


Malik :: Suckling :: [30-30.1.2]

Suckling

Malik :: Book 30 : Hadith 30.1.2

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin said, "My paternal uncle by suckling came to me and I refused to give him permission to enter until I had asked the Messenger of Allah, may Allah bless him and grant him peace, about it. The Messenger of Allah, may Allah bless him and grant him peace, came and I asked him about it. He said, 'He is your paternal uncle, so give him permission.' So I said, 'Messenger of Allah! The woman nursed me not the man.' He said, 'He is your paternal uncle, so let him enter.' "

A'isha said, "That was after the veil had been imposed on us."

A'isha added, "What is haram by birth is made haram by suckling."


Malik :: Suckling :: [30-30.1.3]

Suckling

Malik :: Book 30 : Hadith 30.1.3

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that A'isha umm al-muminin told him that Aflah, the brother of Abu'l-Quays came and asked permission to visit her after the veil had been lowered, and he was her paternal uncle by suckling. She said, "I refusedto give him permission to enter. When the Messenger of Allah, may Allah bless him and grant him peace, came, I told him about what I had done, and he ordered me to give him permission to enter."


Malik :: Suckling :: [30-30.1.4]

Suckling

Malik :: Book 30 : Hadith 30.1.4

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili that Abdullah ibn Abbas said, "The milk which a child under two years old sucks, even if it is only one suck, makes the foster relatives haram."


Malik :: Suckling :: [30-30.1.5]

Suckling

Malik :: Book 30 : Hadith 30.1.5

Yahya related to me from Malik from Ibn Shihab from Amr ibn ash-Sharid that Abdullah ibn Abbas was asked whether, if a man had two wives, and one of them nursed a slave-boy, and the other had nursed a slave-girl, could the slave-boy marry the slave-girl. He said, "No. The husband is the same."


Malik :: Suckling :: [30-30.1.6]

Suckling

Malik :: Book 30 : Hadith 30.1.6

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "There is no kinship by suckling except for a person who is nursed when he is small. There is no kinship by suckling over the age of two years."


Malik :: Suckling :: [30-30.1.7]

Suckling

Malik :: Book 30 : Hadith 30.1.7

Yahya related to me from Malik from Nafi that Salim ibn Abdullah ibn Umar informed him that A'isha umm al-muminin sent him away while he was being nursed to her sister Umm Kulthum bint Abi Bakr as-Siddiq and said, "Suckle him ten times so that he can come in to see me."

Salim said, "Umm Kulthum nursed me three times and then fell ill, so that she only nursed me three times. I could not go in to see A'isha because Umm Kulthum did not finish for me the ten times."


Malik :: Suckling :: [30-30.1.8]

Suckling

Malik :: Book 30 : Hadith 30.1.8

Yahya related to me from Malik from Nafi that Safiyya bint Abi Ubayd told him that Hafsa, umm al-muminin, sent Asim ibn Abdullah ibn Sad to her sister Fatima bint Umar ibn al-Khattab for her to suckle him ten times so that he could come in to see her. She did it, so he used to come in to see her.


Malik :: Suckling :: [30-30.1.9]

Suckling

Malik :: Book 30 : Hadith 30.1.9

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim that his father told him that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, admitted those whom her sisters and the daughters of her brother had nursed, and she did not admit those who were nursed by the wives of her brothers.


Malik :: Suckling :: [30-30.1.10]

Suckling

Malik :: Book 30 : Hadith 30.1.10

Yahya related to me from Malik that Ibrahim ibn Uqba asked Said ibn al-Musayyab about suckling. Said said, "All that occurs in the first two years, even if it is only a drop, makes haram. Whatever is after two years, is only food that is eaten."

Ibrahim ibn Uqba said, ''Then I asked Urwa ibn az-Zubayr and he told me the same as what Said ibn al-Musayyab said."


Malik :: Suckling :: [30-30.1.11]

Suckling

Malik :: Book 30 : Hadith 30.1.11

Yahya related to me from Malik that Yahya ibn Said said that he heard Said ibn al-Musayyab say, "Suckling is only while the child is in the cradle. If not, it does not cause flesh and blood relations."

Yahya related to me from Malik from Ibn Shihab that he said, "Suckling however little or much, makes haram. Kinship by suckling makes men mahram."

Yahya said that he had heard Malik say, "Suckling, however little or much when it is in the first two years, makes haram. As for what is after the first two years, little or much, it does not make anything haram. It is like food."


Malik :: Suckling :: [30-30.2.12]

Suckling

Malik :: Book 30 : Hadith 30.2.12

Yahya related to me from Malik from Ibn Shihab that he was asked about the suckling of an older person. He said, ''Urwa ibn az-Zubayr informed me that Abu Hudhayfa ibn Utba ibn Rabia, one of the companions of the Messenger of Allah, may Allah bless him and grant him peace, who was present at Badr, adopted Salim (who is called Salim, the mawla of Abu Hudhayfa) as the Messenger of Allah, may Allah bless him and grant him peace, adopted Zayd ibn Haritha. He thought of him as his son, and Abu Hudhayfa married him to his brother's sister, Fatima bint al-Walid ibn Utba ibn Rabia, who was at that time among the first emigrants. She was one of the best unmarried women of the Quraysh. When Allah the Exalted sent down in His Book what He sent down about Zayd ibn Haritha, 'Call them after their true fathers. That is more equitable in the sight of Allah. If you do not know who their fathers were then they are your brothers in the deen and your mawali,' (Sura 33 ayat 5) people in this position were traced back to their fathers. When the father was not known, they were traced to their mawla.

"Sahla bint Suhayl who was the wife of Abu Hudhayfa, and one of the tribe of Amr ibn Luayy, came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah! We think of Salim as a son and he comes in to see me while I am uncovered. We only have one room, so what do you think about the situation?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Give him five drinks of your milk and he will be mahram by it.' She then saw him as a foster son. A'isha umm al-muminin took that as a precedent for whatever men she wanted to be able to come to see her. She ordered her sister, Umm Kulthum bint Abi Bakr as-Siddiq and the daughters of her brother to give milk to whichever men she wanted to be able to come in to see her. The rest of the wives of the Prophet, may Allah bless him and grant him peace, refused to let anyone come in to them by such nursing. They said, 'No! By Allah! We think that what the Messenger of Allah, may Allah bless him and grant him peace, ordered Sahla bint Suhayl to do was only an indulgence concerning the nursing of Salim alone. No! By Allah! No one will come in upon us by such nursing!'

"This is what the wives of the Prophet, may Allah bless him and grant him peace, thought about the suckling of an older person."


Malik :: Suckling :: [30-30.2.13]

Suckling

Malik :: Book 30 : Hadith 30.2.13

Yahya related to me from Malik that Abdullah ibn Dinar said, "A man came to Abdullah ibn Umar when I waswith him at the place where judgments were given and asked him about the suckling of an older person. Abdullah ibn Umar replied, 'A man came to Umar ibn al-Khattab and said, 'I have a slave-girl and I used to have intercourse with her. My wife went to her and suckled her. When I went to the girl, my wife told me to watch out, because she had suckled her!' Umar told him to beat his wife and to go to his slave-girl because kinship by suckling was only by the suckling of the young.' "


Malik :: Suckling :: [30-30.2.14]

Suckling

Malik :: Book 30 : Hadith 30.2.14

Yahya related to me from Malik from Yahya ibn Said that a man said to Abu Musa al-Ashari, "I drank some milk from my wife's breasts and it went into my stomach." Abu Musa said, "I can only but think that she is haram for you." Abdullah ibn Masud said, "Look at what opinion you are giving the man." Abu Musa said, "Then what do you say?" Abdullah ibn Masud said, "There is only kinship by suckling in the first two years."

Abu Musa said, "Do not ask me about anything while this learned man is among you."


Malik :: Suckling :: [30-30.3.15]

Suckling

Malik :: Book 30 : Hadith 30.3.15

Yahya related to me from Malik from Abdullah ibn Dinar from Sulayman ibn Yasar and from Urwa ibn az-Zubayr from A'isha umm al-muminin, that the Messenger of Allah, may Allah bless him and grant him peace, said, " What is haram by birth is haram by suckling."


Malik :: Suckling :: [30-30.3.16]

Suckling

Malik :: Book 30 : Hadith 30.3.16

Yahya related to me from Malik that Muhammad ibn Abd ar-Rahman ibn Nawfal said, ''Urwa ibn az-Zubayr informed me from A'isha umm al-muminin that Judama bint Wahb al-Asadiyya informed her that she heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'I intended to prohibit ghila but I remembered that the Greeks and Persians do that without it causing any injury to their children.' "

Malik explained, "Ghila is that a man has intercourse with his wife while she is suckling."


Malik :: Suckling :: [30-30.3.17]

Suckling

Malik :: Book 30 : Hadith 30.3.17

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazm from Amra bint Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Amongst what was sent down of the Qur'an was 'ten known sucklings make haram' - then it was abrogated by 'five known sucklings'. When the Messenger of Allah, may Allah bless him and grant him peace, died, it was what is now recited of the Qur'an."

Yahya said that Malik said, "One does not act on this."


Malik :: Business Transactions :: [31-31.1.1]

Business Transactions

Malik :: Book 31 : Hadith 31.1.1

Yahya related to me from Malik from a reliable source from Amr ibn Shuayb from his father from his father's father that the Messenger of Allah, may Allah bless him and grant him peace, forbade transactions in which nonrefundable deposits were paid.

Malik said, "That is, in our opinion, but Allah knows best, that for instance, a man buys a slave or slave-girl or rents an animal and then says to the person from whom he bought the slave or leased the animal, 'I will give you a dinar or a dirham or whatever on the condition that if I actually take the goods or ride what I have rented from you, then what I have given you already goes towards payment of the goods or hire of the animal. If I do not purchase the goods or hire the animal, then what I have given you is yours without liability on your part.' "

Malik said, "According to the way of doing things with us there is nothing wrong in bartering an arabic speaking merchant slave for abyssinian slaves or any other type that are not his equal in eloquence, trading, shrewdness, and know-how. There is nothing wrong in bartering one slave like this for two or more other slaves with a stated delay in the terms if he is clearly different. If there is no appreciable difference between the slaves, two should not be bartered for one with a stated delay in the terms even if their racial type is different."

Malik said, "There is nothing wrong in selling what has been bought in such a transaction before taking possession of all of it as long as you receive the price for it from some one other than the original owner."

Malik said, "An addition to the price must not be made for a foetus in the womb of its mother when she is sold because that is gharar (an uncertain transaction). It is not known whether the child will be male or female, good-looking or ugly, normal or handicapped, alive or dead. All these things will affect the price."

Malik said that in a transaction where a slave or slave-girl was bought for one hundred dinars with a stated credit period that if the seller regretted the sale there was nothing wrong in him asking the buyer to revoke it for ten dinars which he would pay him immediately or after a period and he would forgo his right to the hundred dinars which he was owed.

Malik said, "However, if the buyer regrets and asks the seller to revoke the sale of a slave or slave-girl in consideration of which he will pay an extra ten dinars immediately or on credit terms, extended beyond the original term, that should not be done. It is disapproved of because it is as if, for instance, the seller is buying the one hundred dinars which is not yet due on a year's credit term before the year expires for a slave-girl and ten dinars to be paid immediately or on credit term longer than the year. This falls into the category of selling gold for gold when delayed terms enter into it."

Malik said that it was not proper for a man to sell a slave-girl to another man for one hundred dinars on credit and then to buy her back for more than the original price or on a credit term longer than the original term for which he sold her. To understand why that was disapproved of in that case, the example of a man who sold a slave-girl on credit and then bought her back on a credit term longer than the original term was looked at. He might have sold her for thirty dinars with a month to pay and then buy her back for sixty dinars with a year or half a year to pay. The outcome would only be that his goods would have returned to him just like they were and the other party would have given him thirty dinars on a month's credit against sixty dinars on a year or half a year's credit. That was not to be done.


Malik :: Business Transactions :: [31-31.2.2]

Business Transactions

Malik :: Book 31 : Hadith 31.2.2

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab said, "If a slave who has wealth is sold, that wealth belongs to the seller unless the buyer stipulates its inclusion."

Malik said, "The generally agreed upon way of doing things among us is that if the buyer stipulates the inclusion of the slave's property whether it be cash, debts, or goods of known or unknown value, then they belong to the buyer, even if the slave possesses more than that for which he was purchased, whether he was bought for cash, as payment for a debt, or in exchange for goods. This is possible because a master is not asked to pay zakat on his slave's property. If a slave has a slave-girl, it is halal for him to have intercourse with her by his right of possession. If a slave is freed or put under contract (kitaba) to purchase his freedom, then his property goes with him. If he becomes bankrupt, his creditors take his property and his master is not liable for any of his debts."


Malik :: Business Transactions :: [31-31.3.3]

Business Transactions

Malik :: Book 31 : Hadith 31.3.3

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm that Aban ibn Uthman and Hisham ibn Ismail used to mention in their khutbas built-in liability agreements in the sale of slaves, to cover both a three day period and a similar clause covering a year. Malik explained, "The defects a lave or slave-girl are found to have from the time they are bought until the end of the three days are the responsibility of the seller. The year agreement is to cover insanity, leprosy, and loss of limbs due to disease. After a year, the seller is free from any liability."

Malik said,"An inheritor or someone else who sells a slave or slave-girl without any such built-in guarantee is not responsible for any fault in the slave and there is no liability agreement held against him unless he was aware of a fault and concealed it. If he was aware of a fault, the lack of guarantee does not protect him. The purchase is returned. In our view, built-in liability agreements only apply to the purchase of slaves."


Malik :: Business Transactions :: [31-31.4.4]

Business Transactions

Malik :: Book 31 : Hadith 31.4.4

Yahya related to me from Malik from Yahya ibn Said from Salim ibn Abdullah that Abdullah ibn Umar sold one of his slaves for eight hundred dirhams with the stipulation that he was not responsible for defects. The person who bought the slave complained to Abdullah ibn Umar that the slave had a disease which he had not told him about. They argued and went to Uthman ibn Affan for a decision . The man said, "He sold me a slave with a disease which he did not tell me about." Abdullah said, "I sold to him with the stipulation that I was not responsible." Uthman ibn Affan decided that Abdullah ibn Umar should take an oath that he had sold the slave without knowing that he had any disease. Abdullah ibn Umar refused to take the oath, so the slave was returned to him and recovered his health in his possession. Abdullah sold him afterwards for 1500 dirhams.

Malik said, "The generally agreed upon way of doing things among us about a man who buys a female slave and she becomes pregnant, or who buys a slave and then frees him, or if there is any other such matter which has already happened so that he cannot return his purchase, and a clear proof is established that there was a fault in that purchase when it was in the hands of the seller or the fault is admitted by the seller or someone else, is that the slave or slave-girl is assessed for its value with the fault it is found to have had on the day of purchase and the buyer is refunded,from what he paid,the difference between the price of a slave who is sound and a slave with such a defect.

Malik said, "The generally agreed upon way of doing things among us regarding a man who buys a slave and then finds out that the slave has a defect for which he can be returned and meanwhile another defect has happened to the slave whilst in his possession, is that if the defect which occurred to the slave in his possession has harmed him, like loss of a limb, loss of an eye, or something similar, then he has a choice. If he wants, he can have the price of the slave reduced commensurate with the defect (he bought him with ) according to the prices on the day he bought him, or if he likes, he can pay compensation for the defect which the slave has suffered in his possession and return him. The choice is up to him. If the slave dies in his possession, the slave is valued with the defect which he had on the day of his purchase. It is seen what his price would really have been. If the price of the slave on the day of purchase without fault was 100 dinars, and his price on the day of purchase with fault would have been 80 dinars, the price is reduced by the difference. These prices are assessed according to the market value on the day the slave was purchased . "

Malik said, "The generally agreed upon way of doing things among us is that if a man returns a slave girl in whom he has found a defect and he has already had intercourse with her, he must pay what he has reduced of her price if she was a virgin. If she was not a virgin, there is nothing against his having had intercourse with her because he had charge of her."

Malik said, "The generally agreed upon way of doing things among us regarding a person, whether he is an inheritor or not, who sells a slave, slave-girl, or animal without a liability agreement is that he is not responsible for any defect in what he sold unless he knew about the fault and concealed it. If he knew that there was a fault and concealed it, his declaration that he was free of responsibility does not absolve him, and what he sold is returned to him."

Malik spoke about a situation where a slave-girl was bartered for two other slave-girls and then one of the slave-girls was found to have a defect for which she could be returned. He said, "The slave-girl worth two other slave-girls is valued for her price. Then the other two slave-girls are valued, ignoring the defect which the one of them has. Then the price of the slave-girl sold for two slave-girls is divided between them according to their prices so that the proportion of each of them in her price is arrived at - to the higher priced one according to her higher price, and to the other according to her value. Then one looks at the one with the defect, and the buyer is refunded according to the amount her share is affected by the defect, be it little or great. The price of the two slave-girls is based on their market value on the day that they were bought."

Malik spoke about a man who bought a slave and hired him out on a long-term or short-term basis and then found out that the slave had a defect which necessitated his return. He said that if the man returned the slave because of the defect, he kept the hire and revenue. "This is the way in which things are done in our city. That is because, had the man bought a slave who then built a house for him, and the value of the house was many times the price of the slave, and he then found that the slave had a defect for which he could be returned, and he was returned, he would not have to make payment for the work the slave had done for him. Similarly, he would keep any revenue from hiring him out, because he had charge of him. This is the way of doing things among us."

Malik said, "The way of doing things among us when someone buys several slaves in one lot and then finds that one of them has been stolen, or has a defect, is that he looks at the one he finds has been stolen or the one in which he finds a defect. If he is the pick of those slaves, or the most expensive, or it was for his sake that he bought them, or he is the one in whom people see the most excellence, then the whole sale is returned. If the one who is found to be stolen or to have a defect is not the pick of the slaves, and he did not buy them for his sake, and there is no special virtue which people see in him, the one who is found to have a defect or to have been stolen is returned as he is, and the buyer is refunded his portion of the total price."


Malik :: Business Transactions :: [31-31.5.5]

Business Transactions

Malik :: Book 31 : Hadith 31.5.5

Yahya related to me from Malik from Ibn Shihab that Ubaydullah ibn Abdullah ibn Utba ibn Masud told him that Abdullah ibn Masud bought a slave-girl from his wife, Zaynab Ath Thaqafiyya. She made a condition to him, that if he bought her, she could always buy her back for the price that he paid. Abdullah ibn Masud asked Umar ibn al-Khattab about that and Umar ibn al-Khattab said, "Do not go near her while anyone has a condition concerning her over you."


Malik :: Business Transactions :: [31-31.5.6]

Business Transactions

Malik :: Book 31 : Hadith 31.5.6

Yahya related to me from Malik from Nafi that Abdullah ibn Umar would say, "A man should not have intercourse with a slave girl except one whom, if he wished, he could sell, if he wished, he could give away, if he wished, he could keep, if he wished, he could do with her what he wanted ."

Malik said that a man who bought a slave-girl on condition that he did not sell her, give her away, or do something of that nature, was not to have intercourse with her. That was because he was not permitted to sell her or to give her away, so if he did not own that from her, he did not have complete ownership of her because an exception had been made concerning her by the hand of someone else. If that sort of condition entered into it, it was a messy situation, and the sale was not recommended.


Malik :: Business Transactions :: [31-31.6.7]

Business Transactions

Malik :: Book 31 : Hadith 31.6.7

Yahya related to me from Malik from Ibn Shihab that Abdullah ibn Amir gave Uthman ibn Affan a slave-girl who had a husband whom he had purchased at Basra. Uthman said, "I will not go near her until her husband separates from her." Ibn Amir compensated the husband and he separated from her.


Malik :: Business Transactions :: [31-31.6.8]

Business Transactions

Malik :: Book 31 : Hadith 31.6.8

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abd ar-Rahman ibn Awf that Abd ar-Rahman ibn Awf bought a slave-girl and found that she had a husband, so he returned her.


Malik :: Business Transactions :: [31-31.7.9]

Business Transactions

Malik :: Book 31 : Hadith 31.7.9

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "If palm trees are sold after they have been pollinated, the fruit belongs to the seller unless the buyer makes a stipulation about its inclusion."


Malik :: Business Transactions :: [31-31.8.10]

Business Transactions

Malik :: Book 31 : Hadith 31.8.10

Yahya related to me from Malik from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade selling fruit until it had started to ripen. He forbade the transaction to both buyer and seller.


Malik :: Business Transactions :: [31-31.8.11]

Business Transactions

Malik :: Book 31 : Hadith 31.8.11

Yahya related to me from Malik from Humayd at-Tawil from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, forbade selling fruit until it had become mellow. He was asked, "Messenger ofAllah! What do you mean by become mellow?" He said, "When it becomes rosy."

The Messenger of Allah, may Allah bless him and grant him peace, added, "Allah may prevent the fruit from maturing, so how can you take payment from your brother for it."


Malik :: Business Transactions :: [31-31.8.12]

Business Transactions

Malik :: Book 31 : Hadith 31.8.12

Yahya related to me from Malik from Abu'r-Rijal Muhammad ibn Abd ar-Rahman ibn Haritha from his mother, Amra bint Abd ar-Rahman that the Messenger of Allah, may Allah bless him and grant him peace, forbade selling fruit until it was clear of blight. Malik said, "Selling fruit before it has begun to ripen is an uncertain transaction (gharar) ."


Malik :: Business Transactions :: [31-31.8.13]

Business Transactions

Malik :: Book 31 : Hadith 31.8.13

Yahya related to me from Malik from Abu'z-Zinad from Kharija ibn Zayd ibn Thabit that Zayd ibn Thabit did not sell fruit until the Pleiades were visible, at the end of May.

Malik said, "The way of doing things among us about selling melons, cucumbers, water-melons, and carrots is that it is halal to sell them when it is clear that they have begun to ripen. Then the buyer has what grows until the season is over. There is no specific timing laid down for that because the time is well known with people, and it may happen that the crop will be affected by blight and put a premature end to the season. If blight strikes and a third or more of the crop is damaged, an allowance for that is deducted from the price of purchase."


Malik :: Business Transactions :: [31-31.9.14]

Business Transactions

Malik :: Book 31 : Hadith 31.9.14

Yahya related to me from Malik from Nafi from Abdullah ibn Umar from Zayd ibn Thabit that the Messenger of Allah, may Allah bless him and grant him peace, allowed the holder of an ariya to barter the dates on the palm for the amount of dried dates it was estimated that the palms would produce.

Yahya related to me from Malik from Da'ud ibn al-Husayn from Abu Sufyan, the mawla of Ibn Abi Ahmad, from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, allowed the produce of an ariya to be bartered for an estimation of what the produce would be when the crop was less than five awsuq or equal to five awsuq. Da'ud wasn't sure whether he said five awsuq or less than five.

Malik said, ''Ariyas can be sold for an estimation of what amount of dried dates will be produced. The crop is examined and estimated while still on the palm. This is allowed because it comes into the category of delegation of responsibility, handing over rights, and involving a partner. Had it been like a form of sale, no one would have made someone else a partner in the produce until it was ready nor would he have renounced his right to any of it or put someone in charge of it until the buyer had taken possession."


Malik :: Business Transactions :: [31-31.10.15]

Business Transactions

Malik :: Book 31 : Hadith 31.10.15

Yahya related to me from Malik that Abu'r-Rijal Muhammad ibn Abd ar-Rahman heard his mother, Amra bint Abd ar-Rahman say, "A man bought the fruit of an enclosed orchard in the time of the Messenger of Allah, may Allah bless him and grant him peace, and he tended it while staying on the land. It became clear to him that there was going to be some loss. He asked the owner of the orchard to reduce the price for him or to revoke the sale, but the owner made an oath not to do so. The mother of the buyer went to the Messenger of Allah, may Allah bless him and grant him peace, and told him about it. The Messengerof Allah, may Allah bless him and grant him peace, said, 'By this oath, he has sworn not to do good.' The owner of the orchard heard about it and went to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, the choice is his.' "


Malik :: Business Transactions :: [31-31.10.16]

Business Transactions

Malik :: Book 31 : Hadith 31.10.16

Yahya related to me from Malik that he had heard that Umar ibn Abd al-Aziz decided in a case to make a reduction for crop damage.

Malik said, "That is what we do in the situation."

Malik added, "Crop damage is whatever causes loss of a third or more for the purchaser. Anything less is not counted as crop damage."


Malik :: Business Transactions :: [31-31.11.17]

Business Transactions

Malik :: Book 31 : Hadith 31.11.17

Yahya related to me from Malik from Rabia ibn Abd ar-Rahman that al-Qasim ibn Muhammad would sell produce from his orchard and keep some of it aside.


Malik :: Business Transactions :: [31-31.11.18]

Business Transactions

Malik :: Book 31 : Hadith 31.11.18

Yahya related to me from Malik from Abdullah ibn Abi Bakr that his grandfather, Muhammad ibn Amr ibn Hazm sold the fruit of an orchard of his called al-Afraq, for 4,000 dirhams, and he kept aside 800 dirhams' worth of dry dates.


Malik :: Business Transactions :: [31-31.11.19]

Business Transactions

Malik :: Book 31 : Hadith 31.11.19

Yahya related to me from Malik from Abu'r-Rijal, Muhammad ibn Abdar-Rahman ibn Haritha that his mother, Amra bint Abd ar-Rahman used to sell her fruit and keep some of it aside.

Malik said, "The generally agreed upon way of doing things among us is that when a man sells the fruit of his orchard, he can keep aside up to a third of the fruit, but that is not to be exceeded. There is no harm in what is less than a third."

Malik added that he thought there was no harm for a man to sell the fruit of his orchard and keep aside only the fruit of a certain palm-tree or palm-trees which he had chosen and whose number he had specified, because the owner was only keeping aside certain fruit of his own orchard and everything else he sold.


Malik :: Business Transactions :: [31-31.12.20]

Business Transactions

Malik :: Book 31 : Hadith 31.12.20

Yahya related to me from Malik from Zayd ibn Aslam that Ata ibn Yasar said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Dried dates for dried dates is like for like.' It was said to him, 'Your agent in Khaybar takes one sa for two.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'all him to me.' So he was called for. The Messenger of Allah, may Allah bless him and grant him peace, asked, 'Do you take one sa for two?' He replied, 'Messengerof Allah! Why should they sell me good dates for assorted low quality dates, sa for sa!' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Sell the assorted ones for dirhams, and then buy the good ones with those dirhams.' "


Malik :: Business Transactions :: [31-31.12.21]

Business Transactions

Malik :: Book 31 : Hadith 31.12.21

Yahya related to me from Malik from Abd al-Hamid ibn Suhayl ibn Abd ar-Rahman ibn Awf from Said ibn al-Musayyab from Abu Said al-Khudri and from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, appointed a man as an agent in Khaybar, and he brought him some excellent dates. The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Are all the dates of Khaybar like this?" He said,"No. By Allah, Messenger of Allah! We take a sa of this kind for two sa or two sa for three." The Messenger of Allah, may Allah bless him and grant him peace, said, "Do not do that. Sell the assorted ones for dirhams and then buy the good ones with the dirhams."


Malik :: Business Transactions :: [31-31.12.22]

Business Transactions

Malik :: Book 31 : Hadith 31.12.22

Yahya related to me from Malik from Abdullah ibn Yazid that Zayd ibn Ayyash told him that he had once asked Sad ibn Abi Waqqas about selling white wheat for a type of good barley. Sad asked him which was the better and when he told him the white wheat, he forbade the transaction. Sad said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, being asked about selling dried dates for fresh dates, and the Messenger of Allah, may Allah bless him and grant him peace, said, 'Do the dates diminish in size when they become dry?' When he was told that they did, he forbade that."


Malik :: Business Transactions :: [31-31.13.23]

Business Transactions

Malik :: Book 31 : Hadith 31.13.23

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade muzabana. Muzabana was selling fresh dates for dried dates by measure, and selling grapes for raisins by measure.


Malik :: Business Transactions :: [31-31.13.24]

Business Transactions

Malik :: Book 31 : Hadith 31.13.24

Yahya related to me from Malik from Da'ud ibn al-Husayn from Abu Sufyan, the mawla of Ibn Abi Ahmad, from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, forbade muzabana and muhaqala. Muzabana was selling fresh dates for dried dates while they were still on the trees. Muhaqala was renting land in exchange for wheat.


Malik :: Business Transactions :: [31-31.13.25]

Business Transactions

Malik :: Book 31 : Hadith 31.13.25

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, forbade muzabana and muhaqala. Muzabana was selling fresh dates for dried dates. Muhaqala was buying unharvested wheat in exchange for threshed wheat and renting land in exchange for wheat.

Ibn Shihab added that he had asked Said ibn al-Musayyab about renting land for gold and silver. He said, "There is no harm in it."

Malik said, "The Messenger of Allah, may Allah bless him and grant him peace, forbade muzabana. The explanation of muzabana is that it is buying something whose number, weight and measure is not known with something whose number, weight or measure is known, for instance, if a man has a stack of food whose measure is not known, either of wheat, dates, or whatever food, or the man has goods of wheat, date kernels, herbs, safflower, cotton, flax, silk, and does not know its measure or weight or number and then a buyer approaches him and proposes that he weigh or measure or count the goods, but, before he does, he specifies a certain weight, or measure, or number and guarantees to pay the price for that amount, agreeing that whatever falls short of that amount is a loss against him and whatever is in excess of that amount is a gain for him. That is not a sale. It is taking risks and it is an uncertain transaction. It falls into the category of gambling because he is not buying something from him for something definite which he pays. Everything which resembles this is also forbidden."

Malik said that another example of that was, for instance, a man proposing to another man, "You have cloth. I will guarantee you from this cloth of yours so many hooded cloaks, the measureof each cloak to be such-and-such, (naming a measurement). Whatever loss there is, is against me and I will fulfill you the specified amount and whatever excess there is, is mine." Or perhaps the man proposed, "I will guarantee you from this cloth of yours so many shirts, the measurement of each shirt to be such-and-such, and whatever loss there is, is against me and I will fulfill the specified amount and whatever excess there is, is mine." Or perhaps a man proposed to a man who had cattle or camel hides, "I will cut up these hides of yours into sandals on a pattern I will show you. Whatever falls short of a hundred pairs, I will make up its loss and whatever is over is mine because I guaranteed you." Another example was that a man say to a man who had ben-nuts, "I will press these nuts of yours. Whatever falls short of such-and-such a weight by the pound, I will make it up, and whatever is more than that is mine."

Malik said that all this and whatever else was like it or resembled it was in the category of muzabana, which was neither good nor permitted. It was also the same case for a man to say to a man, who had fodder leaves, date kernels, cotton, flax, herbs or safflower, "I will buy these leaves from you in exchange for such-and-such a sa, (indicating leaves which are pounded like his leaves) . . or these date kernels for such-and-such a sa of kernels like them, and the like of that in the case of safflower, cotton, flax and herbs."

Malik said, "All this is what we have described of muzabana."


Malik :: Business Transactions :: [31-31.14.26]

Business Transactions

Malik :: Book 31 : Hadith 31.14.26

Malik said, "There is no harm in buying dates from specified trees or a specified orchard or buying milk from specified sheep when the buyer starts to take them as soon as he has payed the price. That is like buying oil from a container. A man buys some of it for a dinar or two and gives his gold and stipulates that it be measured out for him. There is no harm in that. If the container breaks and the oil is wasted, the buyer has his gold back and there is no transaction between them."

Malik said, "There is no harm in everything which is taken right away as it is, like fresh milk and fresh picked dates which the buyer can take on a day-to-day basis. If the supply runs out before the buyer has what he has paid for in full, the seller gives him back the portion of the gold that is owed to him, or else the buyer takes other goods from him to the value of what he is owed and which they mutually agree about. The buyer should stay with the seller until he has taken it. It is disapproved of for the seller to leave because the transaction would then come into the forbidden category of a debt for a debt. If a stated time period for payment or delivery enters into the transaction, it is also disapproved. Delay and deferment are not permitted in it, and are only acceptable when it is standard practice on definite terms by which the seller guarantees it to the buyer, but this is not to be from one specific orchard or from any specific ewes."

Malik was asked about a man who bought an orchard from another man in which there were various types of palm-trees - excellent ajwa palms, good kabis palms, adhq palms and othertypes. The seller kept aside from the sale the produce of a certain palm of his choice. Malik said, "That is not good because if he does that, and keeps aside, for instance, dates of the ajwa variety whose yield would be 15 sa, and he picks the dates of the kabis in their place, and the yield of their dates is 10 sa or he picks the ajwa which yield 15 sa and leaves the kabis which yield 10 sa, it is as if he bought the ajwa for the kabis making allowances for their difference of quality. This is the same as if a man dealing with a man who has heaps of dates before him - a heap of 15 sa of ajwa, a heap of 10 sa of kabis, and a heap of 12 sa of cadhq, gives the owner of the dates a dinar to let him choose and take whichever of the heaps he likes." Malik said, "That is not good."

Malik was asked what a man who bought fresh dates from the owner of an orchard and advanced him a dinar was entitled to if the crop was spoilt. Malik said, "The buyer makes a reckoning with the owner of the orchard and takes what is due to him of the dinar. If the buyer has taken two-thirds of a dinar's worth of dates, he gets back the third of a dinar which is owed him. If the buyer has taken three-quarters of a dinar's worth of dates, then he gets back the quarter which is owed to him, or they come to a mutual agreement, and the buyer takes what is owed him from his dinar from the owner of the orchard in something else of his choosing. If, for instance, he prefers to take dry dates or some other goods, he takes them according to what is due. If he takes dry dates or some other goods, he should stay with him until he has been paid in full."

Malik said, "This is the same situation as hiring out a specified riding-camel or hiring out a slave tailor, carpenter or some other kind of worker or letting a house and taking payment in advance for the hire of the slave or the rent of the house or camel. Then an accident happens to what has been hired resulting in death or something else. The owner of the camel, slave or house returns what remains of the rent of the camel, the hire of the slave or the rent of the house to the one who advanced him the money, and the owner reckons what will settle that up in full. If, for instance, he has provided half of what the man paid for, he returns the remaining half of what he advanced, or according to whatever amount is due." Malik said, "Paying in advance for something which is on hand is only good when the buyer takes possession of what he has paid for as soon as he hands over the gold, whether it be slave, camel, or house, or in the case of dates, he starts to pick them as soon as he has paid the money."

It is not good that there be any deferment or credit in such a transaction.

Malik said, "An example illustrating what is disapproved of in this situation is that, for instance, a man may say that he will pay someone in advance for the use of his camel to ride in the hajj, and the hajj is still some time off, or he may say something similar to that about a slave or a house. When he does that, he only pays the money in advance on the understanding that if he finds the camel to be sound at the time the hire is due to begin, he will take it by virtue of what he has already paid. If an accident, or death, or something happens to the camel, then he will get his money back and the money he paid in advance will be considered as a loan."

Malik said, "This is distinct from someone who takes immediate possession of what he rents or hires, so that it does not fall into the category of 'uncertainty,' or disapproved payment in advance. That is following a common practice. An example of that is that a man buys a slave, or slave-girl, and takes possession of them and pays their price. If something happens to them within the period of the year indemnification contract, he takes his gold back from the one from whom he bought it. There is no harm in that. This is the precedent of the sunna in the matter of selling slaves."

Malik said, "Someone who rents a specified slave, or hires a specified camel, for a future date, at which time he will take possession of the camel or slave, has not acted properly because he did not take possession of what he rented or hired, nor is he advancing a loan which the person is responsible to pay back."


Malik :: Business Transactions :: [31-31.15.27]

Business Transactions

Malik :: Book 31 : Hadith 31.15.27

Malik said, "The generally agreed on way of doing things among us is that some one who buys some fruit, fresh or dry, should not resell it until he gets full possession of it. He should not barter things of the same type, except hand to hand. Whatever can be made into dry fruit to be stored and eaten, should not be bartered for its own kind, except hand to hand, like for like, when it is the same kind of fruit. In the case of two different kinds of fruit, there is no harm in bartering two of one kind for one of another, hand to hand on the spot. It is not good to set delayed terms. As for produce which is not dried and stored but is eaten fresh like water melon, cucumber, melon, carrots, citron, medlars, pomegranates, and soon, which when dried no longer counts as fruit, and is not a thing which is stored up as is fruit, I think that it is quite proper to barter such things two for one of the same variety hand to hand. If no term enters into it, there is no harm in it."


Malik :: Business Transactions :: [31-31.16.28]

Business Transactions

Malik :: Book 31 : Hadith 31.16.28

Yahya related to me from Malik that Yahya ibn Said said, "The Messenger of Allah, mayAllah bless him and grant him peace, ordered the two Sads to sell a vessel made of either gold or silver from the booty. They either sold each three units of weight for four units of weight of coins or each four units of weight for three units of weight or coins. The Messenger of Allah, may Allah bless him and grant him peace, said to them, 'You have taken usury, so return it.' "


Malik :: Business Transactions :: [31-31.16.29]

Business Transactions

Malik :: Book 31 : Hadith 31.16.29

Yahya related to me from Malik from Musa ibn Abi Tamim from Abu'l Hubab Said ibn Yasar from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A dinar for a dinar, a dirham for a dirham, no excess between the two."


Malik :: Business Transactions :: [31-31.16.30]

Business Transactions

Malik :: Book 31 : Hadith 31.16.30

Yahya related to me from Malik from Nafi from Abu Said al-Khudri that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not sell gold for gold except like for like and do not increase one part over another part. Do not sell silver for silver, except like for like and do not increase one part over another part. Do not sell some of it which is not there for some of it which is."


Malik :: Business Transactions :: [31-31.16.31]

Business Transactions

Malik :: Book 31 : Hadith 31.16.31

Yahya related to me from Malik from Humayd ibn Qays al-Makki that Mujahid said, "I was with Abdullah ibn Umar and an artisan came to him and said, 'Abu Abd ar-Rahman - I fashion gold and then sell what I have made for more than its weight. I take an amount equivalent to the work of my hand.' Abdullah forbade him to do that, so the artisan repeated the question to him, and Abdullah continued to forbid him until he came to the door of the mosque or to an animal that he intended to mount. Then Abdullah ibn Umar said, 'A dinar for a dinar, and a dirham for a dirham. There is no increase between them. This is the command of ourProphet to us and our advice to you.' "


Malik :: Business Transactions :: [31-31.16.32]

Business Transactions

Malik :: Book 31 : Hadith 31.16.32

Yahya related to me from Malik that he had heard from his grandfather, Malik ibn Abi Amir that Uthman ibn Affan said, "The Messenger of Allah, may Allah bless him and grant him peace, said to me, 'Do not sell a dinar for two dinars nor a dirham for two dirhams.' "


Malik :: Business Transactions :: [31-31.16.33]

Business Transactions

Malik :: Book 31 : Hadith 31.16.33

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that Muawiya ibn Abi Sufyan sold a gold or silver drinking-vessel for more than its weight. Abu'dDarda said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, forbidding such sales except like for like." Muawiya said to him, "I don't see any harm in it." Abu'd-Darda said to him, "Who will excuse me from Muawiya? I tell him something from the Messenger of Allah, may Allah bless him and grant him peace, and he gives me his own opinion! I will not live in the same land as you!" Then Abu'd-Darda went to Umar ibn al-Khattab and mentioned that to him. Umar ibn al-Khattab therefore wrote to Muawiya, "Do not sell it except like for like, weight for weight."


Malik :: Business Transactions :: [31-31.16.34]

Business Transactions

Malik :: Book 31 : Hadith 31.16.34

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab said, "Do not sell gold for gold except like for like, and do not increase one part over another part. Do not sell silver for silver except like for like, and do not increase one part over another part. Do not sell silver for gold, one of them at hand and the other to be given later. If someone seeks to delay paying you until he has been to his house, do not leave him. I fear rama for you." Rama is usury.


Malik :: Business Transactions :: [31-31.16.35]

Business Transactions

Malik :: Book 31 : Hadith 31.16.35

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that Umar ibn al-Khattab said, "Do not sell gold for gold except like for like. Do not increase part of it over another part. Do not sell silver for silver except like for like, and do not increase part of it over another part. Do not sell some of it which is there for some of it which is not. If someone asks you to wait for payment until he has been to his house, do not leave him. I fear rama for you." Rama is usury.


Malik :: Business Transactions :: [31-31.16.36]

Business Transactions

Malik :: Book 31 : Hadith 31.16.36

Yahya related to me from Malik that he had heard that al-Oasim ibn Muhammad said, ''Umar ibn al-Khattab said, 'A dinar for a dinar, and a dirham for adirham, and a sa for a sa. Something to be collected later is not to be sold for something at hand. ' "


Malik :: Business Transactions :: [31-31.16.37]

Business Transactions

Malik :: Book 31 : Hadith 31.16.37

Yahya related to me from Malik that Yahya ibn Said heard Said ibn al-Musayyab say, "Keeping gold and silver out of circulation is part of working corruption in the land."

Malik said, "There is no harm in buying gold with silver or silver with gold without measuring if it is unminted or a piece of jewellery which has been made. Counted dirhams and counted dinars should not be bought without reckoning until they are known and counted. To abandon number and buy them at random would only be to speculate. That is not part of the business transactions of Muslims. As for what is weighed of unminted objects and jewellery, there is no harm in buying such things without measuring. To buy them without measuring is like buying wheat, dried dates, and such food-stuffs, which are sold without measuring, even though things like them are measured "

Malik spoke about buying a Qur'an, a sword or a signet ring which had some gold or silver work on it with dinars or dirhams. He said, "The value of the object bought with dinars, which has gold in it is looked at. If the value of the gold is up to one-third of the price, it is permitted and there is no harm in it if the sale is hand to hand and there is no deferment in it. When something is bought with silver which has silver in it, the value is looked at. If the value of the silver is one-third, it is permitted and there is no harm in it if the sale is hand to hand. That is still the way of doing things among us."


Malik :: Business Transactions :: [31-31.17.38]

Business Transactions

Malik :: Book 31 : Hadith 31.17.38

Yahya related to me from Malik from Ibn Shihab from Malik ibn Aus ibn al-Hadathan an-Nasri that one time he asked to exchange 100 dinars. He said, "Talha ibn Ubaydullah called me over and we made a mutual agreement that he would make an exchange for me. He took the gold and turned it about in his hand, and then said, 'I can't do it until my treasurer brings the money to me from al-Ghaba.' Umar ibn al-Khattab was listening and Umar said, 'By Allah! Do not leave him until you have taken it from him!' Then he said, 'The Messenger of Allah, may Allah bless him and grant him peace, said, "Gold for silver is usury except hand to hand. Wheat for wheat is usury except hand to hand. Dates for dates is usury except hand to hand. Barley for barley is usury except hand to hand." "'

Malik said, "When a man buys dirhams with dinars and then finds a bad dirham among them and wants to return it, the exchange of the dinars breaks down, and he returns the silver and takes back his dinars. The explanation of what is disapproved of in that is that the Messenger of Allah, may Allah bless him and grant him peace, said, 'Gold for silver is usury except hand to hand.' and Umar ibn al-Khattab said, 'If someone asks you to wait to be paid until he has gone back to his house, do not leave him.' When he returns a dirham to him from the exchange after he has left him, it is like a debt or something deferred. For that reason, it is disapproved of, and the exchange collapses. Umar ibn al-Khattab wanted that all gold, silver and food should not be sold for goods to be paid later. He did not want there to be any delay or deferment in any such sale, whether it involved one commodity or different sorts of commodities."


Malik :: Business Transactions :: [31-31.18.39]

Business Transactions

Malik :: Book 31 : Hadith 31.18.39

Yahya related to me from Malik that Yazid ibn Abdullah ibn Qusayt saw Said ibn al-Musayyab sell gold counterpoising for gold. He poured his gold into one pan of the scales, and the man with whom he was counterpoising put his gold in the other pan of the scale and when the tongue of the scales was balanced, they took and gave.

Malik said, "According to the way things are done among us there is no harm in selling gold for gold, and silver for silver by counterpoising weight, even if 11 dinars are taken for 10 dinars hand to hand, when the weight of gold is equal, coin for coin, even if the number is different. Dirhams in such a situation are treated the same way as dinars."

Malik said, "If, when counterpoising gold for gold or silver for silver, there is a difference of weight, one party should not give the other the value of the difference in silver or something else. Such a transaction is ugly and a means to usury because if one of the parties were permitted to take the difference for a separate price, it could be as if he had bought it separately, so he would be permitted. Then it would be possible for him to ask for many times the value of the difference in order to permit the completion of the transaction between the two parties.

Malik said, "If he had really been sold the difference without anything else with it, he would not have taken it for a tenth of the price for which he took it in order to put a 'legal front' on the transaction. This leads to allowing what is forbidden . The matter is forbidden."

Malik said that it was not good when counterpoising to give good old gold coins and put along with them unminted gold in exchange for worn kufic gold, which was unpopular and to then treat the exchange as like for like.

Malik said, "The commentary on why that is disapproved is that the owner of the good gold uses the excellence of his old gold coins as an excuse to throw in the unminted gold with it. Had it not been for the superiority of his (good) gold over the gold of the other party, the other party would not have counterpoised the unminted gold for his kufic gold, and the deal would have been refused.

"It is like a man wanting to buy three sa of ajwa dried dates for two sa and a mudd of kabis dates, and on being told that it was not good, then offering two sa of kabis and a sa of poor dates desiring to make the sale possible. That is not good because the owner of the ajwa should not give him a sa of ajwa for a sa of poor dates. He would only give him that because of the excellence of kabis dates.

"Or it is like a man asking some one to sell him three sa of white wheat for two and a half sa of Syrian wheat, and being told that it was not good except like for like, and so offering two sa of wheat and one sa of barley intending to make the sale possible between them. That is not good because no one would have given a sa of barley for a sa of white wheat had that sa been by itself. It was only given because of the excellence of Syrian wheat over the white wheat. This is not good. It is the same as the case of the unminted gold."

Malik said, "Where gold, silver and food, things which should only be sold like for like, are concerned, something disliked and of poor quality should not be put with something good and desirable in order to make the sale possible and to make a bad situation halal. When something of desirable quality is put with something of poor quality and it is only included so that its excellence in quality is noticed, something is being sold which if it had been sold on its own, would not have been accepted and to which the buyer would not have paid any attention. It is only accepted by the buyer because of the superiority of what comes with it over his own goods. Transactions involving gold, silver, or food, must not have anything of this description enter into them. If the owner of the poor quality goods wants to sell them, he sells them on their own, and does not put anything with them. There is no harm if it is like that."


Malik :: Business Transactions :: [31-31.19.40]

Business Transactions

Malik :: Book 31 : Hadith 31.19.40

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Someone who buys food, must not resell it until he takes delivery of it all."


Malik :: Business Transactions :: [31-31.19.41]

Business Transactions

Malik :: Book 31 : Hadith 31.19.41

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Someone who buys food, must not sell it until he takes possession of it."


Malik :: Business Transactions :: [31-31.19.42]

Business Transactions

Malik :: Book 31 : Hadith 31.19.42

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said, "In the time of the Messenger of Allah, may Allah bless him and grant him peace, we used to buy food. He sent orders for us to move our purchases from the place in which we purchased them to another place before we re-sold them."


Malik :: Business Transactions :: [31-31.19.43]

Business Transactions

Malik :: Book 31 : Hadith 31.19.43

Yahya related to me from Malik from Nafi that Hakim ibn Hizam traded in food for people as Umar ibn al-Khattab had ordered him to do. Hakim re-sold the food before he had taken delivery of it. That reached Umar ibn al-Khattab and he revoked the sale and said, "Do not sell food which you have purchased until you take delivery of it."


Malik :: Business Transactions :: [31-31.19.44]

Business Transactions

Malik :: Book 31 : Hadith 31.19.44

Yahya related to me from Malik that he had heard that receipts were given to people in the time of Marwan ibn al-Hakam for the produce of the market at al-Jar. People bought and sold the receipts among themselves before they took delivery of the goods. Zayd Thabit and one of the Companions of the Messenger of Allah, may Allah bless him and grant him peace, went to Marwan ibn al-Hakam and said, "Marwan! Do you make usury halal?" He said, "I seek refuge with Allah! What is that?" He said, "These receipts which people buy and sell before they take delivery of the goods." Marwan therefore sent a guard to follow them and to take them from people's hands and return them to their owners.


Malik :: Business Transactions :: [31-31.19.45]

Business Transactions

Malik :: Book 31 : Hadith 31.19.45

Yahya related to me from Malik that he had heard that a man wanted to buy food from a man in advance. The man who wanted to sell the food to him went with him to the market, and he began to show him heaps, saying, "Which one would you like me to buy for you." The buyer said to him, "Are you selling me what you do not have?" So they came to Abdullah ibn Umarand mentioned that to him. Abdallah ibn Umar said to the buyer, "Do not buy from him what he does not have." He said to the seller, "Do not sell what you do not have."


Malik :: Business Transactions :: [31-31.19.46]

Business Transactions

Malik :: Book 31 : Hadith 31.19.46

Yahya related to me from Malik that Yahya ibn Said heard Jamil ibn Abd ar-Rahman the Muadhdhin say to Said ibn al-Musayyab, "I am a man who buys whatever Allah wills of the receipts for the provisions which people are offered at al-Jar. I want to take payment for goods that I guarantee to deliver at a future date." Said said to him, "Do you intend to settle these things with receipts for provisions you have bought?" He said, "Yes." So he forbade that.

Malik said, "The generally agreed on way of doing things among us in which there is no dispute, about buying food - wheat, barley, durra-sorghum, pearl millet, or any pulse or anything resembling pulses on which zakat is obliged, or condiments of any sort - oil, ghee, honey, vinegar, cheese, sesame oil, milk and so on, is that the buyer should not re-sell any of that until he has taken possession and complete delivery of it.


Malik :: Business Transactions :: [31-31.20.47]

Business Transactions

Malik :: Book 31 : Hadith 31.20.47

Yahya related to me from Malik that Abu'z-Zinad heard Sa'id ibn al-Musayyab andSulayman ibn Yasar forbid a man to sell wheat for gold on delayed terms and then to buy dried dates with the gold before he had taken delivery of the gold.


Malik :: Business Transactions :: [31-31.20.48]

Business Transactions

Malik :: Book 31 : Hadith 31.20.48

Yahya related to me from Malik that Kathir ibn Farqad asked Abu Bakr ibn Muhammad ibn Amr ibn Hazm about a man who sold food to be delivered at a future date to a man for gold and then with the gold, he bought dates before he had taken delivery of the gold. He disapproved of that and forbade it.

Yahya related to me from Malik from Ibn Shihab the like of that.

Malik said, ''Said ibn al-Musayyab, Sulayman ibn Yasar, Abu Bakr ibn Muhammad ibn Amr ibn Hazm, and Ibn Shihab forbade that a man sell wheat for gold and then buy dates with that gold before he had received the gold from the transaction in which he sold the wheat. There is no harm for someone to buy dates on delayed terms, on the strength of the gold for which he sold the wheat, from someone other than the person to whom he sold the wheat before taking possession of the gold, and to refer the one from whom he bought the dates to his debtor who bought the wheat, for the gold he is owed for the dates."

Malik said, "I asked more than one of the people of knowledge about that and they did not see any harm in it."


Malik :: Business Transactions :: [31-31.21.49]

Business Transactions

Malik :: Book 31 : Hadith 31.21.49

Yahya related to me from Malik from Nafi that Abdullah ibn Umar said that there was no harm in a man making an advance to another man for food, with a set description and price until a set date, as long as it was not in crops, or dates which had not begun to ripen.

Malik said, "The way of doing things among us concerning someone who makes an advance for foodstuffs at a known rate until a stated date, and the date arrives and he finds that there is not enough of what he was sold with the seller to fulfill his order, and so he revokes the sale, is that he must only take back the silver, gold, or price which he paid exactly. He does not buy anything else from the man for the same price until he has got back what he paid. That is because if he took something else besides the price which he paid him or exchanged it for goods other than the goods which he bought from him, it would be selling food before getting delivery of it."

Malik said, "The Messenger of Allah, may Allah bless him and grant him peace, forbade selling food before getting delivery of it."

Malik said that it was not good if the buyer regretted his purchase and asked the seller to revoke the sale for him and he would not press him immediately for what he had paid. The people of knowledge forbade that. That was because when the food was made ready for the buyer by the seller, the buyer deferred his due from the seller in order that he might revoke the sale for him. That was the sale of food with delayed terms before taking delivery of the food.

Malik said, "The explanation of that is that when the date of delivery comes and the buyer dislikes the food, the seller takes by it money to be paid later and so it is not revocation. Revocation is that in which neither the buyer nor the seller is increased. When increase occurs by deferment of payment for a time period, or by anything which increases one of them over the other or anything which gives one of them profit, it is not revocation. When either of them do that, revocation becomes a sale. There is an indulgence for revocation, partnership, and transfer, as long as i ncrease, decrease, or deferment does not come into them. If increase, decrease, or deferment comes into it, it becomes a sale. Whatever makes a sale halal makes it halal and whatever makes a sale haram makes it haram."

Malik said, "If someone pays in advance for Syrian wheat, there is no harm if he takes a load after the term falls due."

Malik said, "It is the same with whoever advances for any kind of thing. There is no harm in him taking better than whatever he has made an advance for or worse than it after the agreed delivery date. The explanation of that is that if, for instance, a man advances for a certain weight of wheat. There is no harm if he decides to take some barley or Syrian wheat. If he has made an advance for good dates, there is no harm if he decides to take poor quality dates. If he paid in advance for red raisins, there is no harm if he takes black ones, when it happens after the agreed delivery date, and when the measure of what he takes is like the measure of what he paid for in advance."


Malik :: Business Transactions :: [31-31.22.50]

Business Transactions

Malik :: Book 31 : Hadith 31.22.50

Yahya related to me from Malik that he had heard that Sulayman ibn Yasar said, "The fodder of the donkeys of Saad ibn Abi Waqqas ran out and so he told his slave to take some of the family's wheat and buy barley with it, and to only take a like quantity."


Malik :: Business Transactions :: [31-31.22.51]

Business Transactions

Malik :: Book 31 : Hadith 31.22.51

Yahya related to me from Malik from Nafi that Sulayman ibn Yasar told him that one time the fodder of the animals of Abd ar-Rahman ibn al-Aswad ibn Abd Yaghuth was finished so he said to his slave, "Take some of your family's wheat as food and buy with it barley, and take only a like quantity.' "


Malik :: Business Transactions :: [31-31.22.52]

Business Transactions

Malik :: Book 31 : Hadith 31.22.52

Yahya related to me from Malik that he had heard the same as that from al-Qasim ibn Muhammad from Ibn Muayqib ad-Dawsi.

Malik said, "This is the way of doing things among us . "

Malik said, "The generally agreed on way of doing things among us is that wheat is not sold for wheat, dates for dates, wheat for dates, dates for raisins, wheat for raisins, nor any kind of food sold for food at all, except from hand to hand. If there is any sort of delayed terms in the transaction, it is not good. It is haram. Condiments are not bartered except from hand to hand."

Malik said, "Food and condiments are not bartered when they are the same type, two of one kind for one of the other. A mudd of wheat is not sold for two mudds of wheat, nor a mudd of dates for two mudds of dates, nor a mudd of raisins for two mudds of raisins, nor is anything of that sort done with grains and condiments when they are of one kind, even if it is hand to hand.

"This is the same position as silver for silver and gold for gold. No increase is halal in the transaction, and only like for like, from hand to hand is halal."

Malik said, "If there is a clear difference in foodstuffs which are measured and weighed, there is no harm in taking two of one kind for one of another, hand to hand. There is no harm in taking a sa of dates for two sa of wheat, and a sa of dates for two sa of raisins, and a sa of wheat for two sa of ghee. If the two sorts in the transaction are different, there is no harm in two for one or more than that from hand to hand. If delayed terms enter into the sale, it is not halal ."

Malik said, "It is not halal to trade a heap of wheat for a heap of wheat. There is no harm in a heap of wheat for a heap of dates, from hand to hand. That is because there is no harm in buying wheat with dates without precise measurement."

Malik said, "With kinds of foods and condiments that differ from each other, and the difference is clear, there is no harm in bartering one kind for another, without precise measurement from hand to hand. If delayed terms enter into the sale, there is no good in it. Bartering such things without precise measurement is like buying it with gold and silver without measuring precisely."

Malik said, "That is because you buy wheat with silver without measuring precisely, and dates with gold without measuring precisely, and it is halal. There is no harm in it."

Malik said, "It is not good for someone to make a heap of food, knowing its measure and then to sell it as if it had not been measured precisely, concealing its measure from the buyer. If the buyer wants to return that food to the seller, he can, because he concealed its measure and so it is an uncertain transaction. This is done with any kind of food or other goods whose measure and number the seller knows, and which he then sells without measurement and the buyer does not know that. If the buyer wants to return that to the seller, he can return t. The people of knowledge still forbid such a transaction."

Malik said, "There is no good in selling one round loaf of bread for two round loaves, nor large for small when some of them are bigger than others. When care is taken that they are like for like, there is no harm in the sale, even if they are not weighed."

Malik said, "It is not good to sell a mudd of butter and a mudd of milk for two mudds of butter. This is like what we described of selling dates when two sa of kabis and a sa of poor quality dates were sold for three sa of ajwa dates after the buyer had said to the seller, 'Two sa of kabis dates for three sa of ajwa dates is not good,' and then he did that to make the transaction possible. The owner of the milk puts the milk with his butter so that he can use the superiority of his butter over the butter of the other party to put his milk in with it."

Malik said, "Flour for wheat is like for like, and there is no harm in that. That is if he does not mix up anything with the flour and sell it for wheat, like for like. Had he put half a mudd of flour and half of wheat, and then sold that for a mudd of wheat, it would be like what we described, and it would not be good because he would want to use the superiority of his good wheat to put flour along with it. Such a transaction is not good."


Malik :: Business Transactions :: [31-31.23.53]

Business Transactions

Malik :: Book 31 : Hadith 31.23.53

Yahya related to me from Malik that Muhammad ibn Abdullah ibn Abi Maryam asked Said ibn al-Musayyab's advice. "I am a man who buys food with receipts from al-Jar. Perhaps I will buy something for a dinar and half a dirham, and will be given food for a half." Said said, "No. You give a dirham, and take the rest in food." (A half dirham did not exist as a coin.)


Malik :: Business Transactions :: [31-31.23.54]

Business Transactions

Malik :: Book 31 : Hadith 31.23.54

Yahya related to me from Malik that he had heard that Muhammad Sirin used to say, "Do not sell grain on the ears until it is white."

Malik said, "If someone buys food for a known price to be delivered at a stated date, and when the date comes, the one who owes the food says, 'I do not have any food, sell me the food which I owe you with delayed terms.' The owner of the food says, 'This is not good, because the Messenger of Allah, may Allah bless him and grant him peace, forbade selling food until the deal was completed.' The one who owes the food says to his creditor, 'Sell me any kind of food on delayed terms until I discharge the debt to you.' This is not good because he gives him food and then he returns it to him. The gold which he gave him becomes the price of that which is his right against him and the food which he gave him becomes what clears what is between them. If they do that, it becomes the sale of food before the deal is complete."

Malik spoke about a man who was owed food which he had purchased from a man and this man was owed the like of that food by another man. The one who owed the food said to his creditor, "I will refer you to my debtor who owes me the same amount of food as I owe you, so that you may obtain the food which I owe you ."

Malik said, "If the man who had to deliver the food, had gone out, and bought the food to pay off his creditor, that is not good. That is selling food before taking possession of it. If the food is an advance which falls due at that particular time, there is no harm in paying off his creditor with it because that is nota sale. It is not halal to sell food before receiving it in full since the Messenger of Allah, may Allah bless him and grant him peace, forbade that. However, the people of knowledge agree that there is no harm in partnership, transfer of responsibility and revocation in sales of food and other goods."

Malik said, "That is because the people of knowledge consider it as a favour rendered. They do not consider it as a sale. It is like a man lending light dirhams. He is then paid back in dirhams of full weight, and so gets back more than he lent. That is halal for him and permitted. Had a man bought defective dirhams from him as being the full weight, that would not be halal. Had it been stipulated to him that he lend full weight in dirhams, and then he gave faulty ones, that would not be halal for him."


Malik :: Business Transactions :: [31-31.23.55]

Business Transactions

Malik :: Book 31 : Hadith 31.23.55

Malik said, "Another example of that is that the Messenger of Allah, may Allah bless him and grant him peace, forbade the sale called muzabana and granted an indulgence in the ariya for computing the equivalent in dates. It was distinguished between them that the muzabana-sale was based on shrewdness and trade, and the ariya sale was based on a favour rendered, and there was no shrewdness in it."

Malik said, "A man must not buy food for a fourth, a third, or a fraction of a dirham on the basis that he be given that food on credit. There is no harm in a man buying food for a fraction of a dirham on credit and then he gives a dirham and takes goods with what remains of his dirham because he gave the fraction he owed as silver, and took goods to make up the rest of his dirham. There is no harm in that transaction."

Malik said, "There is no harm in a man placing a dirham with another man and then taking from him known goods for a fourth, third, or a known fraction. If there was not a known price on the goods and the man said, 'I will take them from you for the price of each day,' this is not halal because there is uncertainty. It might be less one time, and more another time, and they would not part with a known sale."

Malik said, "If someone sells some food without measuring precisely and does not exclude any of it from the sale and then it occurs to him to buy some of it, it is not good for him to buy any of it except what it would be permitted for him to exclude from it. That is a third or less. If it is more than a third, it becomes muzabana and is disapproved. He must only purchase from what he would be permitted to exclude, and he is only permitted to exclude a third or less than that. This is the way of doing things in which there is no dispute with us."


Malik :: Business Transactions :: [31-31.24.56]

Business Transactions

Malik :: Book 31 : Hadith 31.24.56

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab said, "There is no hoarding in our market, and men who have excess gold in their hands should not buy up one of Allah's provisions which he has sent to our courtyard and then hoard it up against us. Someone who brings imported goods through great fatigue to himself in the summer and winter, that person is the guest of Umar. Let him sell what Allah wills and keep what Allah wills."


Malik :: Business Transactions :: [31-31.24.57]

Business Transactions

Malik :: Book 31 : Hadith 31.24.57

Yahya related to me from Malik from Yunus ibn Yusuf from Said ibn al-Musayyab that Umar ibn al-Khattab passed by Hatab ibn Abi Baltaa who was underselling some of his raisins in the market. Umar ibn al-Khattab said to him, "Either increase the price or leave our market."


Malik :: Business Transactions :: [31-31.24.58]

Business Transactions

Malik :: Book 31 : Hadith 31.24.58

Yahya related to me from Malik that he had heard that Uthman ibn Affan forbade hoarding .


Malik :: Business Transactions :: [31-31.25.59]

Business Transactions

Malik :: Book 31 : Hadith 31.25.59

Yahya related to me from Malik from Salih ibn Kaysan from Hasan ibn Muhammad ibn Ali ibn Abi Talib that Ali ibn Abi Talib sold one of his camels called Usayfir for 20 camels to be delivered later.


Malik :: Business Transactions :: [31-31.25.60]

Business Transactions

Malik :: Book 31 : Hadith 31.25.60

Yahya related to me from Malik from Nafi that Abdullah ibn Umar bought a female riding-camel for four camels and he guaranteed to give them in full to the buyer at ar-Rabadha.


Malik :: Business Transactions :: [31-31.25.61]

Business Transactions

Malik :: Book 31 : Hadith 31.25.61

Yahya related to me that Malik asked Ibn Shihab about selling animals, two for one with delayed terms. He said, "There is no harm in it."

Malik said, "The generally agreed on way of doing things among us is that there is no harm in bartering a camel for a camel like it and adding some dirhams to the exchange, from hand to hand. There is no harm in bartering a camel for a camel like it with some dirhams on top of the exchange, the camels to be exchanged from hand to hand, and the dirhams to be paid within a period." He said, "There is no good however in bartering a camel for a camel like it with some dirhams on top of it, with the dirhams paid in cash and the camel to be delivered later. If both the camel and the dirhams are deferred there is no good in that either."

Malik said, "There is no harm in buying a riding camel with two or more pack-camels, if they are from inferior stock. There is no harm in bartering two of them for one with delayed terms, if they are different and their difference is clear. If they resemble each other whether their species are different or not, two are not to be taken for one with delayed terms."

Malik said, "The explanation of what is disapproved of in that, is that a camel should not be bought with two camels when there is no distinction between them in speed or hardiness. If this is according to what I have described to you, then one does not buy two of them for one with delayed terms. There is no harm in selling those of them you buy before you complete the deal to somebody other than the one from whom you bought them if you get the price in cash."

Malik said, "It is permitted for someone to advance something on animals for a fixed term and describe the amount and pay its price in cash. Whatever the buyer and seller have described is obliged for them. That is still permitted behaviour between people and what the people of knowledge in our land do."


Malik :: Business Transactions :: [31-31.26.62]

Business Transactions

Malik :: Book 31 : Hadith 31.26.62

Yahya related to me from Malih from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade the transaction called habal alhabala. It was a transaction which the people of Jahiliya practised. A man would buy the unborn offspring of the unborn offspring of a she-camel.


Malik :: Business Transactions :: [31-31.26.63]

Business Transactions

Malik :: Book 31 : Hadith 31.26.63

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab said, "There is no usury in animals. There are three things forbidden in animals: al-madamin, al-malaqih and habal al-habala. Al-madamin is the sale of what is in the wombs of female camels. Al-malaqih is the sale of the breeding qualities of camels" (i.e. for stud).

Malik said, "No one should buy a specified animal when it is concealed from him or in another place, even if he has already seen it, very recently or not so recently, and was pleased enough with it to pay its price in cash."

Malik said, "That is disapproved of because the seller makes use of the price and it is not known whether or not those goods are found to be as the buyer saw them or not. For that reason, it is disapproved of. There is no harm in it if it is described and guaranteed."


Malik :: Business Transactions :: [31-31.27.64]

Business Transactions

Malik :: Book 31 : Hadith 31.27.64

Yahya related to me from Malik from Zayd ibn Aslam from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, forbade bartering live animals for meat.


Malik :: Business Transactions :: [31-31.27.65]

Business Transactions

Malik :: Book 31 : Hadith 31.27.65

Yahya related to me from Malik from Da'ud ibn al-Husayn that he heard Said ibn alMusayyab say, "Part of the gambling of the people of Jahiliya was bartering live animals for slaughtered meat, for instance one live sheep for two slaughtered sheep."


Malik :: Business Transactions :: [31-31.27.66]

Business Transactions

Malik :: Book 31 : Hadith 31.27.66

Yahya related to me from Malik from Abu'z-Zinad that Said ibn al-Musayyab said, "Bartering live animals for dead meat is forbidden." Abu'z-Zinad said, "I said to Said ibn Musayyab, 'What do you think of a man buying an old camel for 10 sheep?' " Said said, "If he buys it to slaughter it, there is no good in it." Abu'z-Zinad added, "All the people (i.e. companions) that I have seen forbade bartering live animals for meat."

Abu'z-Zinad said, "This used to be written in the appointment letters of governors in the time of Aban ibn Uthman and Hisham ibn Ismail."


Malik :: Business Transactions :: [31-31.28.67]

Business Transactions

Malik :: Book 31 : Hadith 31.28.67

Malik said, "It is the generally agreed on way of doing things among us that the meat of camels, cattle, sheep and so on is not to be bartered one for one, except like for like, weight for weight, from hand to hand. There is no harm in that. If it is not weighed, then it is estimated to be like for like from hand to hand."

Malik said, "There is no harm in bartering the meat of fish for the meat of camels, cattle, and sheep and so on two or more for one, from hand to hand. If delayed terms enter the transaction however, there is no good in it."

Malik said, "I think that poultry is different from the meat of cattle and fish. I see no harm in selling some of it for something different, more of one than another, from hand to hand. None of that is to be sold on delayed terms."


Malik :: Business Transactions :: [31-31.29.68]

Business Transactions

Malik :: Book 31 : Hadith 31.29.68

Yahya related to me from Malik from Ibn Shihab from Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham from Abu Masud al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, forbade the sale price of a dog, the earnings of a prostitute and the earnings of a fortune teller.

By the earnings of a prostitute he meant what a woman was given for fornication. The earnings of a fortune teller were what he was given to tell a fortune.

Malik said, "I disapprove of the price of a dog, whether it is a hunting dog or otherwise because the Messenger of Allah, may Allah bless him and grant him peace, forbade the price of a dog."


Malik :: Business Transactions :: [31-31.30.69]

Business Transactions

Malik :: Book 31 : Hadith 31.30.69

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, forbade 'selling and lending.'

Malik said, "The explanation of what that meant is that one man says to another, 'I will take your goods for such-and-such if you lend me such-and-such.' If they agree to a transaction in this manner, it is not permitted. If the one who stipulates the loan abandons his stipulation, then the sale is permitted."

Malik said, "There is no harm in exchanging linen from Shata, for garments from Itribi, or Qass, or Ziqa. Or the cloth of Herat or Merv for Yemeni cloaks and shawls and such like as one for two or three, from hand to hand or with delayed terms. If the goods are of the same kind, and deferment enters into the transaction, there is no good in it."

Malik said, "It is not good unless they are different, and the difference between them is clear. When they resemble each other, even if the names are different, do not take two for one with delayed terms, for instance two garments of Herat for one from Merv or Quhy with delayed terms, ortwo garments of Furqub for one from Shata. All these sorts are of the same description, so do not buy two for one, on delayed terms."

Malik said, "There is no harm in selling what you buy of things of this nature, before you complete the deal, to some one other than the person from whom you purchased them if the price was paid in cash."


Malik :: Business Transactions :: [31-31.31.70]

Business Transactions

Malik :: Book 31 : Hadith 31.31.70

Yahya related to me from Malik from Yahya ibn Said that al-Qasim ibn Muhammad said, ''I heard Abdullah ibn Abbas say, when a man asked him about a man making an advance on some garments and then wanting to sell them back before taking possession of them, 'That is silver for silver,' and he disapproved of it."

Malik said, "Our opinion is - and Allah knows best that was because he wanted to sell them to the person from whom he had bought them for more than the price for which he bought them. Had he sold them to some one other than the person from whom he had purchased them, there would not have been any harm in it."

Malik said, "The generally agreed on way of doing things among us concerning making an advance for slaves, cattle or goods is that when all of what is to be sold is described and an advance is made for them for a date, and the date falls due, the buyer does not sell any of that to the person from whom he has purchased it for more than the price which he advanced for it before he has taken full possession of what he has advanced for. It is usury if he does. If the buyer gives the seller dinars or dirhams and he profits with them, then, when the goods come to the buyer and he does not take them into his possession but sells them back to their owner for more than what he advanced for them, the outcome is that what he has advanced has returned to him and has been increased for him."

Malik said, "If someone advances gold or silver for described animals or goods which are to be delivered before a named date, and the date arrives, or it is before or after the date, there is no harm in the buyer selling those goods to the seller, for other goods, to be taken immediately and not delayed, no matter how extensive the amount of those goods is, except in the case of food because it is not halal to sell it before he has full possession of it. The buyer can sell those goods to some one other than the person from whom he purchased them for gold or silver or any goods. He takes possession of it and does not defer it because if he defers it, that is ugly and there enters into the transaction what is disapproved of: delay for delay. Delay for delay is to sell a debt against one man for a debt against another man."

Malik said, "If someone advances for goods to be delivered after a time, and those goods are neither something to be eaten nor drunk, he can sell them to whomever he likes for cash or goods, before he takes delivery of them, to some one other than the person from whom he purchased them. He must not sell them to the person from whom he bought them except in exchange for goods which he takes possession of immediately and does not defer."

Malik said, "If the delivery date for the goods has not arrived, there is no harm in selling them to the original owner for goods which are clearly different and which he takes immediate possession of and does not defer."

Malik spoke about the case of a man who advanced dinars or dirhams for four specified pieces of cloth to be delivered before a specified time and when the term fell due, he demanded delivery from the seller and the seller did not have them. He found that the seller had cloth but inferior quality, and the seller said that he would give him eight of those cloths. Malik said, "There is no harm in that if he takes the cloths which he offers him before they separate. It is not good if delayed terms enter into the transaction. It is also not good if that is before the end of the term, unless he sells him cloth which is notthetypeof cloth for which he made an advance.


Malik :: Business Transactions :: [31-31.32.71]

Business Transactions

Malik :: Book 31 : Hadith 31.32.71

Malik said, "The generally agreed on way of doing things among us about whatever is weighed but is not gold or silver, i.e. copper, brass, lead, black lead, iron, herbs, figs, cotton, and any such things that are weighed, is that there is no harm in bartering all those sorts of things two for one, hand to hand. There is no harm in taking a ritl of iron for two ritls of iron, and a ritl of brass for two ritls of brass."

Malik said, "There is no good in two for one of one sort with delayed terms. There is no harm in taking two of one sort for one of another on delayed terms, if the two sorts are clearly different. If both sorts resemble each other but their names are different, like lead and black lead, brass and yellow brass, I disapprove of taking two of one sort for one of the other on delayed terms."

Malik said, "When buying something of this nature, there is no harm in selling It beforetaking possession of it to some one other than the person from whom it was purchased, if the price is taken immediately and if it was bought originally by measure or weight. If it was bought without measuring, it should be sold to someone other than the person from whom it was bought, for cash or with delayed terms. That is because goods have to be guaranteed when they are bought without measuring, and they cannot be guaranteed when bought by weight until they are weighed and the deal is completed. This is the best of what I have heard about all these things. It is what people continue to do among us."

Malik said, "The way of doing things among us with what is measured or weighed of things which are not eaten or drunk, like safflower, date-stones, fodder leaves, indigo dye and the like of that is that there is no harm in bartering all those sort of things two for one, hand to hand. Do not take two for one from the same variety with delayed terms. If the types are clearly different, there is no harm in taking two of one for one of the other with delayed terms. There is no harm in selling whatever is purchased of all these sorts, before taking delivery of them if the price is taken from someone other than the person from whom they were purchased."

Malik said, "Anything of any variety that profits people, like gravel and gypsum, one quantity of them for two of its like with delayed terms is usury. One quantity of both of them for its equal plus any increase with delayed terms, is usury."


Malik :: Business Transactions :: [31-31.33.72]

Business Transactions

Malik :: Book 31 : Hadith 31.33.72

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, forbade two sales in one sale.


Malik :: Business Transactions :: [31-31.33.73]

Business Transactions

Malik :: Book 31 : Hadith 31.33.73

Yahya related to me from Malik that he had heard that a man said to another, "Buy this camel for me immediately so that I can buy him from you on credit." Abdullah ibn Umar was asked about that and he disapproved of it and forbade it.


Malik :: Business Transactions :: [31-31.33.74]

Business Transactions

Malik :: Book 31 : Hadith 31.33.74

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad was asked about a man who bought goods for 10 dinars cash or fifteen dinars on credit. He disapproved of that and forbade it.

Malik said that if a man bought goods from a man for either 10 dinars or 15 dinars on credit, that one of the two prices was obliged on the buyer. It was not to be done because if he postponed paying the ten, it would be 15 on credit, and if he paid the ten, he would buy with it what was worth fifteen dinars on credit.

Malik said that it was disapproved of for a man to buy goods from someone for either a dinar cash or for a described sheep on credit and that one of the two prices was obliged on him. It was not to be done because the Messenger of Allah, may Allah bless him and grant him peace, forbade two sales in one sale. This was part of two sales in the one sale.

Malik spoke about a man saying to another, "'I will either buy these fifteen sa of ajwa dates from you, or these ten sa of sayhani dates or I will buy these fifteen sa of inferior wheat or these ten sa of Syrian wheat for a dinar, and one of them is obliged to me.' Malik said that it was disapproved of and was not halal. That was because he obliged him ten sa of sayhani, and left them and took fifteen sa of ajwa, or he was obliged fifteen sa of inferior wheat and left them and took ten sa of Syrian wheat. This was also disapproved of, and was not halal. It resembled what was prohibited in the way of two sales in one sale. It was also included under the prohibition against buying two for one of the same sort of food."


Malik :: Business Transactions :: [31-31.34.75]

Business Transactions

Malik :: Book 31 : Hadith 31.34.75

Yahya related to me from Malik from Abu Hazim ibn Dinar from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, forbade the sale with uncertainty in it.

Malik said, "An example of one type of uncertain transaction and risk is that a man intends the price of a stray animal or escaped slave to be fifty dinars. A man says, 'I will take him from you for twenty dinars.' If the buyer finds him, thirty dinars goes from the seller, and if he does not find him, the seller takes twenty dinars from the buyer."

Malik said, "There is another fault in that. If that stray is found, it is not known whether it will have increased or decreased in value or what defects may have befallen it. This transaction is greatly uncertain and risky."

Malik said, "According to our way of doing things, one kind of uncertain transaction and risk is selling what is in the wombs of females - women and animals - because it is not known whether or not it will come out, and if it does come out, it is not known whether it will be beautiful or ugly, normal or disabled, male or female. All that is disparate. If it has that, its price is such-and-such, and if it has this, its price is such-and-such."

Malik said, "Females must not be sold with what is in their wombs excluded. That is that, for instance, a man says to another, 'The price of my sheep which has much milk is three dinars. She is yours for two dinars while I will have her future offspring.' This is disapproved because it is an uncertain transaction and a risk."

Malik said, "It is not halal to sell olives for olive oil or sesame for sesame oil, or butter for ghee because muzabana comes into that, because the person who buys the raw product for something specified which comes from it, does not know whether more or less will come out of that, so it is an uncertain transaction and a risk."

Malik said, "A similar case is the selling of ben-nuts for ben-nut oil. This is an uncertain transaction because what comes from the ben-nut is ben-oil. There is no harm in selling ben-nuts for perfumed ben because perfumed ben has been perfumed, mixed and changed from the state of raw ben-nut oil."

Malik, speaking about a man who sold goods to a man on the provision that there was to be no loss for the buyer, (i.e. if the buyer could not re-sell the goods they could go back to the seller), said, "This transaction is not permitted and it is part of risk. The explanation of why it is so, is that it is as if the seller hired the buyer for the profit if the goods make a profit. If he sells the stock at a loss, he has nothing, and his efforts are not compensated. This is not good. In such a transaction, the buyer should have a wage according to the work that he has contributed. Whatever there is of loss or profit in those goods is for and against the seller. This is only when the goods are gone and sold. If they do not go, the transaction between them is null and void."

Malik said, "As for a man who buys goods from a man and he concludes the sale and then the buyer regrets and asks to have the price reduced and the seller refuses and says, 'Sell it and I will compensate you for any loss.' There is no harm in this because there is no risk. It is something he proposes to him, and their transaction was not based on that. That is what is done among us."


Malik :: Business Transactions :: [31-31.35.76]

Business Transactions

Malik :: Book 31 : Hadith 31.35.76

Yahya related to me from Malik from Muhammad ibn Yahya ibn Habban and from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, forbade mulamasa and munabadha.

Malik said, "Mulamasa is when a man can feel a garment but is not allowed to unfold it or examine what is in it, or he buys by night and does not know what is in it. Munabadha is that a man throws his garment to another, and the other throws his garment without either of them making any inspection. Each of them says, 'this is for this. 'This is what is forbidden of mulamasa and munabadha."

Malik said that selling bundles with a list of their contents was different from the sale of the cloak concealed in a bag or the cloth folded up and such things. What made it different was that it was a common practice and it was what people were familiar with, and what people had done in the past, and it was still among the permitted transactions and trading of people in which they saw no harm because in the sale of bundles with a list of contents without undoing them, an uncertain transaction was not intended and it did not resemble mulamasa.


Malik :: Business Transactions :: [31-31.35.77]

Business Transactions

Malik :: Book 31 : Hadith 31.35.77

Yahya related to me, that Malik said, "The generally agreed on way of doing things among us about a man buying cloth in one city, and then taking it to another city to sell as a murabaha, is that he is not reckoned to have the wage of an agent, or any allowance for ironing, folding, straightening, expenses, or the rent of a house. As for the cost of transporting the drapery, it is included in the basic price, and no share of the profit is allocated to it unless the agent tells all of that to the investor. If they agree to share the profits accordingly after knowledge of it, there is no harm in that."

Malik said, "As for bleaching, tailoring, dyeing, and such things, they are treated in the same way as drapery. The profit is reckoned in them as it is reckoned in drapery goods. So if he sells the drapery goods without clarifying the things we named as not getting profit, and if the drapery has already gone, the transport is to be reckoned, but no profit is given. If the drapery goods have not gone the transaction between them is null and void unless they make a new mutual agreement on what is to be permitted between them ."

Malik spoke about an agent who bought goods for gold or silver, and the exchange rate on the day of purchase was ten dirhams to the dinar. He took them to a city to sell murabaha, or sold them where he purchased them according to the exchange rate of the day on which he sold them. If he bought them for dirhams and he sold them for dinars, or he bought them for dinars and he sold them for dirhams, and the goods had not gone then he had a choice. If he wished, he accepted to sell the goods and if he wished, he left them. If the goods had been sold, he had the price for which the salesman bought them, and the salesman was reckoned to have the profit on what they were bought for, over what the investor gained as profit.

Malik said, "If a man sells goods worth one hundred dinars for one hundred and ten, and he hears after that they are worth ninety dinars, and the goods have gone, the seller has a choice. If he likes, he has the price of the goods on the day they were taken from him unless the price is more than the price for which he was obliged to sell them in the first place, and he does not have more than that - and it is one hundred and ten dinars. If he likes, it is counted as profit against ninety unless the price his goods reached was less than the value. He is given the choice between what his goods fetch and the capital plus the profit, which is ninety-nine dinars."

Malik said, "If someone sells goods in murabaha and he says, 'It was valued at one hundred dinars to me.' Then he hears later on, that it was worth one hundred and twenty dinars, the customer is given the choice. If he wishes, he gives the salesman the value of the goods on the day he took them, and if he wishes, he gives the price for which he bought them according to the reckoning of what profit he gives him, as far as it goes, unless that is less than the price for which he bought them, for he should not give the owner of the goods a loss from the price for which he bought them because he was satisfied with that. The owner of the goods came to seek extra, so the buyer has no argument against the salesman in that to make a reduction from the first price for which he bought it according to the list of contents."


Malik :: Business Transactions :: [31-31.36.79]

Business Transactions

Malik :: Book 31 : Hadith 31.36.79

Malik spoke about what was done among them in the case of a group of people who bought goods, drapery or slaves, and a man heard about it and said to one of the group, "I have heard the description and situation of the drapery goods you bought from so-and-so. Shall I give you such-and-such profit to take over your portion?" This person agreed, and the man gave him the profit and became a partner in his place. When he looked at the purchase, he saw that it was ugly and found it too expensive.

Malik said, "It is obliged on him and there is no choice in it for him if he bought it according to a list of contents and the description was well-known."

Malik spoke about a man who had drapery goods sent to him, and salesmen came to him and he read to them his list of contents and said, "In each bag is such-and-such a wrap from Basra and such-and-such a light wrap from Sabir. Their size is such-and-such," and he named to them types of drapery goods by their sort, and he said, "Buy them from me according to this description." They bought the bags according to what he described to them, and then they bought them and found them too expensive and regretted it. Malik said, "The sale is binding on them, if the goods agree with the list of contents on which he sold them."

Malik said, "This is the way of doing things which people still use today. They permit the sale among them when the goods agree with the list of contents and are not different from it. "


Malik :: Business Transactions :: [31-31.37.80]

Business Transactions

Malik :: Book 31 : Hadith 31.37.80

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Both parties in a business transaction have the right of withdrawal as long as they have not separated, except in the transaction called khiyar."

Malik said, "There is no specified limit nor any matter which is applied in this case according to us."


Malik :: Business Transactions :: [31-31.37.81]

Business Transactions

Malik :: Book 31 : Hadith 31.37.81

Malik related to me that he had heard that Abdullah ibn Masud used to relate that the Messenger of Allah, may Allah bless him and grant him peace, said, "When two parties dispute about a business transaction, the seller's word is taken, or they make an agreement among themselves.

Malik spoke about someone who sold goods to a man, and said at the contracting of the sale, 'I will sell to you provided I consult so-and-so. If he is satisfied, the sale is permitted. If he dislikes it, there is no sale between us.' They made the transaction on that basis. Then the buyer regretted before the seller consulted the person.

Malik said, "That sale is binding on them according to what they described. The buyer has no right of withdrawal, and it is binding on him, if the person whom the seller stipulated to him, permits it."

Malik said, "The way of doing things among us about a man who buys goods from another and they differ about the price, and the seller says, 'I sold them to you for ten dinars,' and the buyer says, 'I bought them from you for five dinars,' is that it is said to the seller, 'If you like, give them to the buyer for what he said. If you like, swear by Allah that you only sold your goods for what you said.' If he swears it is said to the buyer, 'Either you take the goods for what the seller said, or you swear by Allah that you bought them only for what you said.' If he swears, he is free to return the goods. That is when each of them testifies against the other."


Malik :: Business Transactions :: [31-31.38.82]

Business Transactions

Malik :: Book 31 : Hadith 31.38.82

Yahya related to me from Malik from Abu'z-Zinad from Busr ibn Said from Ubayd, Abu Salih, the mawla of as-Saffah that he said, "I sold drapery to the people of Dar Nakhla on credit. Then I wanted to go to Kufa, so they proposed that I reduce the price for them and they would pay me immediately . I asked Zayd ibn Thabit about that, and he said, 'I order you not to accept increase or to give to anybody.' "


Malik :: Business Transactions :: [31-31.38.83]

Business Transactions

Malik :: Book 31 : Hadith 31.38.83

Yahya related to me from Malik from Uthman ibn Hafs ibn Khalda from Ibn Shihab from Salim ibn Abdullah that Abdullah ibn Umar was asked about a man who took a loan from another man for a set term. The creditor reduced the debt, and the man paid it immediately Abdullah ibn Umar disliked that, and forbade it.


Malik :: Business Transactions :: [31-31.38.84]

Business Transactions

Malik :: Book 31 : Hadith 31.38.84

Malik related to me that Zayd ibn Aslam said, "Usury in the Jahiliyya was that a man would give a loan to a man for a set term. When the term was due, he would say, 'Will you pay it off or increase me?' If the man paid, he took it. If not, he increased him in his debt and lengthened the term for him ."

Malik said, "The disapproved of way of doing things about which there is no dispute among us, is that a man should give a loan to a man for a term, and then the demander reduce it and the one from whom it is demanded pay it in advance. To us that is like someone who delays repaying his debt after it is due to his creditor and his creditor increases his debt." Malik said, "This is nothing else but usury. No doubt about it."

Malik spoke about a man who loaned one hundred dinars to a man for two terms. When it was due, the person who owed the debt said to him, "Sell me some goods, whose price is one hundred dinars in cash for one hundred and fifty on credit." Malik said, "This transaction is not good, and the people of knowledge still forbid it."

Malik said, "This is disapproved of because the creditor himself gives the debtor the price of what the man sells him, and he defers repayment of the hundred of the first transaction for the debtor for the term which is mentioned to him in the second transaction, and the debtor increases him with fifty dinars for his deferring him. That is disapproved of and it is not good. It also resembles the hadith of Zayd ibn Aslam about the transactions of the people of the Jahiliyya. When their debts were due, they said to the person with the debt, 'Either you pay in full or you increase it.' If they paid, they took it, and if not they increased debtors in their debts, and extended the term for them."


Malik :: Business Transactions :: [31-31.39.85]

Business Transactions

Malik :: Book 31 : Hadith 31.39.85

Yahya related to me from Malik from Abu'z-Zinad from al Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Delay in payment by a rich man is injustice, but when one of you is referred for payment to a wealthy man, let him be referred."


Malik :: Business Transactions :: [31-31.39.86]

Business Transactions

Malik :: Book 31 : Hadith 31.39.86

86 Malik related to me from Musa ibn Maysara that he heard a man ask Said ibn al-Musayyab, "I am a man who sells for a debt." Said said, "Do not sell except for what you take to your camel."

Malik spoke about a person who bought goods from a man provided that he provide him with those goods by a specific date, either in time for a market in which he hoped for their saleability, or to fulfil a need at the time he stipulated. Then the seller failed him about the date, and the buyer wanted to return those goods to the seller. Malik said, "The buyer cannot do that, and the sale is binding on him. If the seller does bring the goods before the completion of the term, the buyer cannot be forced to take them."

Malik spoke about a person who bought food and measured it. Then some one came to him to buy it and he told him that he had measured it for himself and taken it in full. The new buyer wanted to trust him and accept his measure. Malik said, "Whatever is sold in this way for cash has no harm in it but whatever is sold in this way on delayed terms is disapproved of until the new buyer measures it out for himself. The sale with delayed terms is disapproved of because it leads to usury and it is feared that it will be circulated in this way without weight or measure. If the terms are delayed it is disapproved of and there is no disagreement about that with us."

Malik said, "One should not buy a debt owed by a man whether present or absent, without the confirmation of the one who owes the debt, nor should one buy a debt owed to a man by a dead person even if one knows what the deceased man has left. That is because to buy that is an uncertain transaction and one does not know whether the transaction will be completed or not completed."

He said, "The explanation of what is disapproved of in buying a debt owed by someone absent or dead, is that it is not known what unknown debtor may be connected to the dead person. If the dead person is liable for another debt, the price which the buyer gave on strength of the debt may become worthless."

Malik said, "There is another fault in that as well. He is buying something which is not guaranteed for him, and so if the deal is not completed, what he paid becomes worthless. This is an uncertain transaction and it is not good."

Malik said, "One distinguishes between a man who is only selling what he actually has and a man who is being paid in advance for something which is not yet in his possession. The man advancing the money brings his gold which he intends to buy with. The seller says, 'This is 10 dinars. What do you want me to buy for you with it?' It is as if he sold 10 dinars cash for 15 dinars to be paid later. Because of this, it is disapproved of. It is something leading to usury and fraud."


Malik :: Business Transactions :: [31-31.40.87]

Business Transactions

Malik :: Book 31 : Hadith 31.40.87

Malik said there was no harm if a man who sold some drapery and excluded some garments by their markings, stipulated that he chose the marked ones from that. If he did not stipulate that he would choose from them when he made the exclusion, I think that he is partner in the number of drapery goods which were purchased from him. That is because two garments can be alike in marking and be greatly different in price.

Malik said, "The way of doing things among us is that there is no harm in partnership, transferring responsibility to an agent, and revocation when dealing with food and other things, whether or not possession was taken, when the transaction is with cash, and there is no profit, loss, or deferment of price in it. If profit or loss or deferment of price from one of the two enters any of these transactions, it becomes sale which is made halal by what makes sale halal, and made haram by what makes sale haram, and it is not partnership, transferring responsibility to an agent, or revocation."

Malik spoke about some one who bought drapery goods or slaves, and the sale was concluded, then a man asked him to be his partner and he agreed and the new partner paid the whole price to the seller and then something happened to the goods which removed them from their possession. Malik said, "The new partner takes the price from the original partner and the original partner demands from the seller the whole price unless the original partner stipulated on the new partner during the sale and before the transaction with the seller was completed that the seller was responsible to him. If the transaction has ended and the seller has gone, the pre-condition of the original partner is void, and he has the responsibility."

Malik spoke about a man who asked another man to buy certain goods to share between them, and he wanted the other man to pay for him and he would sell the goods for the other man. Malik said, "That is not good. When he says, 'Pay for me and I will sell it for you,' it becomes a loan which he makes to him in order that he sell it for him and if those goods are destroyed, or pass, the man who paid the price will demand from his partner what he put in for him. This is part of the advance which brings in profit."

Malik said, "If a man buys goods, and they are settled for him, and then a man says to him, 'Share half of these goods with me, and I will sell them all for you,' that is halal, there is no harm in it. The explanation of that is that this is a new sale and he sells him half of the goods provided that he sells the whole lot."


Malik :: Business Transactions :: [31-31.41.88]

Business Transactions

Malik :: Book 31 : Hadith 31.41.88

Yahya related to me from Malik from Ibn Shihab from Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whenever a man sells wares and then the buyer becomes bankrupt and the seller has not taken any of the price and he finds some of his property intact with the buyer, he is more entitled to it than anyone else. If the buyer dies, then the seller is the same as other creditors with respect to it."


Malik :: Business Transactions :: [31-31.41.89]

Business Transactions

Malik :: Book 31 : Hadith 31.41.89

Malik related to me from Yahya ibn Said from Abu Bakr ibn Muhammad ibn Amr ibn Hazm from Umar ibn Abdal-Aziz from Abu Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If anyone goes bankrupt, and a man finds his own property intact with him, he is more entitled to it than anyone else."

Malik spoke about a man who sold a man wares, and the buyer went bankrupt. He said, "The seller takes whatever of his goods he finds. If the buyer has sold some of them and distributed them, the seller of the wares is more entitled to them than the creditors. What the buyer has distributed does not prevent the seller from taking whatever of it he finds. It is the seller's right if he has received any of the price from the buyer and he wants to return it to take what he finds of his wares, and in what he does not find, he is like the creditors."

Malik spoke about some one who bought spun wool or a plot of land, and then did some work on it, like building a house on the plot of land or weaving the spun wool into cloth. Then he went bankrupt after he had bought it, and the original owner of the plot said, "I will take the plot and whatever structure is on it." Malik said, "That structure is not his. However, the plot and what is in it that the buyer has improved is appraised. Then one sees what the price of the plot is and how much of that value is the price of the structure. They are partners in that. The owner of the plot has as much as his portion, and the creditors have the amount of the portion of the structure."

Malik said, "The explanation of that is that the value of it all is fifteen hundred dirhams. The value of the plot is five hundred dirhams, and the value of the building is one thousand dirhams. The owner of the plot has a third, and the creditors have two-thirds."

Malik said, "It is like that with spinning and other things of the same nature in these circumstances and the buyer has a debt which he cannot pay. This is the behaviour in such cases."

Malik said, "As for goods which have been sold and which the buyer does not improve, but those goods sell well and have gone up in price, so their owner wants them and the creditors also want to seize them, then the creditors choose between giving the owner of the goods the price for which he sold them and not giving him any loss and surrendering his goods to him.

"If the price of the goods has gone down, the one who sold them has a choice. If he likes, he can take his goods and he has no claim to any of his debtor's property, and that is his right. If he likes, he can be one of the creditors and take a portion of his due and not take his goods. That is up to him."

Malik said about someone who bought a slave-girl or animal and she gave birth in his possession and the buyer went bankrupt, "The slave-girl or the animal and the offspring belong to the seller unless the creditors desire it. In that case they give him his complete due and they take it."


Malik :: Business Transactions :: [31-31.42.90]

Business Transactions

Malik :: Book 31 : Hadith 31.42.90

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that Abu Rafi, the mawla of the Messenger of Allah, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, borrowed a young camel and then the camels of sadaqa came to him." Abu Rafi said, "He ordered me to repay the man his young camel. I said, 'I can only find a good camel in its seventh year in the camels.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Give it to him. The best of people are those who discharge their debts in the best manner.' "


Malik :: Business Transactions :: [31-31.42.91]

Business Transactions

Malik :: Book 31 : Hadith 31.42.91

Malik related to me from Humayd ibn Qays al-Makki that Mujahid said, "Abdullah ibn Umar borrowed some dirhams from a man, then he discharged his debt with dirhams better than them. The man said, 'Abu Abdar-Rahman. These are better than the dirhams which I lent you.' Abdullah ibn Umar said, 'I know that. But I am happy with myself about that.' "

Malik said, "There is no harm in a person who has borrowed gold, silver, food, or animals, taking to the person who lent it, something better than what he lent, when that is not a stipulation between them nor a custom. If that is by a stipulation or promise or custom, then it is disapproved, and there is no good in it."

He said, "That is because the Messenger of Allah, may Allah bless him and grant him peace, discharged his debt with a good camel in its seventh year in place of a young camel which he borrowed, and Abdullah ibn Umar borrowed some dirhams, and repaid them with better ones. If that is from the goodness of the borrower, and it is not by a stipulation, promise, or custom, it is halal and there is no harm in it."


Malik :: Business Transactions :: [31-31.43.92]

Business Transactions

Malik :: Book 31 : Hadith 31.43.92

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab said that he disapproved of one man lending another food on the provision that he gave it back to him in another city. He said, "Where is the transport?"


Malik :: Business Transactions :: [31-31.43.93]

Business Transactions

Malik :: Book 31 : Hadith 31.43.93

And Malik related to me that he had heard that a man came to Abdullah ibn Umar and said, "Abu Abd ar-Rahman, I gave a man a loan and stipulated that he give me better than what I lent him." Abdullah ibn Umar said, "That is usury." Abdullah said, "Loans are of three types: A free loan which you lend by which you desire the pleasure of Allah, and so you have the pleasure of Allah. A free loan which you lend by which you desire the pleasure of your companion, so you have the pleasure of your companion, and a free loan which you lend by which you take what is impure by what is pure, and that is usury." He said, "What do you order me to do, Abu Abd ar-Rahman?" He said, "I think that you should tear up the agreement. If he gives you the like of what you lent him, accept it. If he gives you less than what you lent him, take it and you will be rewarded. If he gives you better than what you lent him, of his own good will, that is his gratitude to you and you have the wage of the period you gave him the loan."


Malik :: Business Transactions :: [31-31.43.94]

Business Transactions

Malik :: Book 31 : Hadith 31.43.94

Yahya related to me from Malik from Nafi that he heard Abdullah ibn Umar say, "If someone lends something, let the only condition be that it is repaid."


Malik :: Business Transactions :: [31-31.43.95]

Business Transactions

Malik :: Book 31 : Hadith 31.43.95

Malik related to me that he had heard that Abdullah ibn Masud used to say, "If someone makes a loan, they should not stipulate better than it. Even if it is a handful of grass, it is usury."

Malik said, "The generally agreed on way of doing things among us is that there is no harm in borrowing any animals with a set description and itemisation, and one must return the like of them. This is not done in the case of female slaves. It is feared about that that it will lead to making halal what is not halal, so it is not good. The explanation of what is disapproved of in that, is that a man borrow a slave-girl and have intercourse with her as seems proper to him. Then he returns her to her owner. That is not good and it is not halal. The people of knowledge still forbid it and do not give an indulgence to any one in it."


Malik :: Business Transactions :: [31-31.44.96]

Business Transactions

Malik :: Book 31 : Hadith 31.44.96

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not let any of you bid against each other."


Malik :: Business Transactions :: [31-31.44.97]

Business Transactions

Malik :: Book 31 : Hadith 31.44.97

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not go out to meet the caravans for trade, do not bid against each other, outbidding in order to raise the price, and a townsman must not buy on behalf of a man of the desert, and do not tie up the udders of camels and sheep so that they appear to have a lot of milk, for a person who buys them after that has two recourses open to him after he milks them. If he is pleased with them, he keeps them and if he is displeased with them, he can return them along with a sa of dates."

Malik said, "The explanation of the words of the Messenger of Allah, may Allah bless him and grant him peace, according to what we think - and Allah knows best - 'do not bid against each other,' is that it is forbidden for a man to offer a price over the price of his brother when the seller has inclined to the bargainer and made conditions about the weight of the gold and he has declared himself not liable for faults and such things by which it is recognised that the seller wants to make a transaction with the bargainer. This is what he forbade, and Allah knows best."

Malik said, "There is no harm, however, in more than one person bidding against each other over goods put up for sale."

He said, "Were people to leave off haggling when the first person started haggling, an unreal price might be taken and the disapproved would enter into the sale of the goods. This is still the way of doing things among us."


Malik :: Business Transactions :: [31-31.44.98]

Business Transactions

Malik :: Book 31 : Hadith 31.44.98

Malik said, from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade najsh.

Malik said, "Najsh is to offer a man more than the worth of his goods when you do not mean to buy them and someone else follows you in bidding."


Malik :: Business Transactions :: [31-31.45.99]

Business Transactions

Malik :: Book 31 : Hadith 31.45.99

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that a man mentioned to the Messenger of Allah, may Allah bless him and grant him peace, that he was always being cheated in business transactions. The Messenger of Allah, may Allah bless him and grant him peace, said, "When you enter a transaction, say, 'No trickery.' So whenever that man entered a transaction, he would say, 'No trickery.' "


Malik :: Business Transactions :: [31-31.45.100]

Business Transactions

Malik :: Book 31 : Hadith 31.45.100

Malik related to me that Yahya ibn Said heard Said ibn al-Musayyab say, "When you come to a land where they give full measure and full weight, stay there. When you come to a land where they shorten the measure and weight, then do not stay there very long."


Malik :: Business Transactions :: [31-31.45.101]

Business Transactions

Malik :: Book 31 : Hadith 31.45.101

Malik related to me from Yahya ibn Said that he heard Muhammad ibn al-Munkadir say, "Allah loves his slave who is generous when he sells, and generous when he buys, generous when he repays, and generous when he is repaid."

Malik said about a man who bought camels or sheep or dry goods or slaves or any goods without measuring precisely, "There is no buying without measuring precisely in anything which can be counted . "

Malik said about a man who gave a man goods to sell for him and set their price saying, "If you sell them for this price as I have ordered you to do, you will have a dinar (or something which he has specified, which they are both satisfied with), if you do not sell them, you will have nothing," "There is no harm in that when he names a price to sell them at and names a known fee. If he sells the goods, he takes the fee, and if he does not sell them, he has nothing."

Malik said, "This is like saying to another man, 'If you capture my runaway slave or bring my stray camel, you will have such-and-such.' This is from the category of reward, and not from the category of giving a wage. Had it been from the category of giving a wage, it would not be good."

Malik said, "As for a man who is given goods and told that if he sells them he will have a named percentage for every dinar, that is not good because whenever he is a dinar less than the price of the goods, he decreases the due which was named for him. This is an uncertain transaction. He does not know how much he will be given."


Malik :: Business Transactions :: [31-31.45.102]

Business Transactions

Malik :: Book 31 : Hadith 31.45.102

Malik related to me that he asked Ibn Shihab about a man who hired an animal, and then re-hired it out for more than what he hired it for. He said, "There is no harm in that."


Malik :: Qirad :: [32-32.1.1]

Qirad

Malik :: Book 32 : Hadith 32.1.1

Malik related to me from Zayd ibn Aslam that his father said, "Abdullah and Ubaydullah, the sons of Umar ibn al-Khattab went out with the army to Iraq. On the way home, they passed by Abu Musa al-Ashari who was the amir of Basra. He greeted them and made them welcome, and told them that if there was anything he could do to help them, he would do it. Then he said, 'There is some of the property of Allah which I want to send to the amir al-muminin, so I will lend it to you, and you can buy wares from Iraq and sell them in Madina. Then give the principal to the amir al-muminin, and you keep the profit.' They said that they would like to do it, and so he gave them the money and wrote to Umar ibn al-Khattab to take the money from them. When they came to sell they made a profit, and when they paid the principal to Umar he asked, 'Did he lend everyone in the army the like of what he lent you?' They said, 'No.' Umar ibn al-Khattab said, 'He made you the loan, because you are the sons of the amir al-muminin, so pay the principal and the profit.' Abdullah was silent. Ubaydullah said, 'You do not need to do this, amir al-muminin. Had the principal decreased or been destroyed, we would have guaranteed it.' Umar said, 'Pay it.' Abdullah was silent, and Ubaydullah repeated it. A man who was sitting with Umar said, 'Amir al-muminin, better that you make it a qirad. 'Umar said, 'I have made it qirad.' Umar then took the principal and half of the profit, and Abdullah and Ubaydullah, the sons of Umar ibn al-Khattab took half of the profit."


Malik :: Qirad :: [32-32.1.2]

Qirad

Malik :: Book 32 : Hadith 32.1.2

Malik related to me from al-Ala ibn Abd ar-Rahman from his father from his father that Uthman ibn Affan gave him some money as qirad to use provided the profit was shared between them.


Malik :: Qirad :: [32-32.2.3]

Qirad

Malik :: Book 32 : Hadith 32.2.3

Malik said, "The recognised and permitted form of qirad is that a man take capital from an associate to use. He does not guarantee it and in travelling pays out of the capital for food and clothes and what he makes good use of, according to the amount of capital. That is, when he travels to do the work and the capital can support it. If he remains with his people, he does not have expenses or clothing from the capital."

Malik said, "There is no harm in the two parties in a qirad helping each other by way of a favour when it is acceptable to them both."

Malik said, "There is no harm in the investor of the capital buying some of the goods from the agent in the qirad if that is acceptable and without conditions."

Malik spoke about an investor making a qirad loan to a man and his slave, to be used by both. He said, "That is permitted, and there is no harm in it because the profit is property for his slave, and the profit is not for the master until he takes it from him. It is like the rest of his earnings."


Malik :: Qirad :: [32-32.3.4]

Qirad

Malik :: Book 32 : Hadith 32.3.4

Malik said, "When a man owes money to another man and he asks him to let it stay with him as a quirad, that is disapproved of until the creditor receives his property. Then he can make it a qirad loan or keep it. That is because the debtor may be in a tight situation, and want to delay it to increase it for him."

Malik spoke about an investor who made a qirad loan to a man, and some of the principal was lost before he used it, and then he used it and made a profit. The agent wanted to make the principal the remainder of the money after what was lost from it. Malik said, "His statement is not accepted, and the principal is made up to its original amount from his profit. Then they divide what remains after the principal has been repaid according to the conditions of the qirad."

Malik said, "Qirad loan is only good in gold or silver coin and it is never permitted in any kind of wares or goods or articles."

Malik said, "There are certain transactions which if a long span of time passes after the transaction takes place, its revocation becomes unacceptable. As for usury, there is never anything except its rejection whether it is a little or a lot. What is permitted in other than it is not permitted in it because Allah, the Blessed and the Exalted, said in His Book, 'If you repent, you have your capital back, not wronging and not wronged. ' "

32.4 Conditions Permitted in Qirad


Malik :: Qirad :: [32-32.3.5]

Qirad

Malik :: Book 32 : Hadith 32.3.5

Yahya said that Malik spoke about an investor who made a qirad loan and stipulated to the agent that only certain goods should be bought with his money or he forbade certain goods which he named to be bought. He said, "There is no harm in an investor making a condition on an agent in qirad not to buy a certain kind of animal or goods which he specifies. It is disapproved of for an investor to make as a condition on an agent in qirad that he only buy certain goods unless the goods which he orders him to buy are in plentiful supply and do not fail either in winter or summer. There is no harm in that case."

Malik spoke about an investor who loaned qirad money and stipulated that something of the profit should be his alone without the agent sharing in it. He said, "That is not good, even if it is only one dirham unless he stipulates that half the profit is his and half the profit is the agent's or a third or a fourth or whatever. When he names a percentage, whether great or small, everything specified by that is halal. This is the qirad of the muslims."

He said, "It is also not good if the investor stipulates that one dirham or more of the profit is purely his, with out the agent sharing it and then what remains of the profit is to be divided in half between them. That is not the qirad of the Muslims."


Malik :: Qirad :: [32-32.4.6]

Qirad

Malik :: Book 32 : Hadith 32.4.6

Yahya said that Malik said, "The person who puts up the principal must not stipulate that he has something of the profit alone without the agent sharing in it, nor must the agent stipulate that he has something of the profit alone without the investor sharing. In qirad, there is no sale, no rent, no work, no advance, and no convenience which one party specifies to himself without the other party sharing unless one party allows it to the other unconditionally as a favour and that is alright to both. Neither of the parties should make a condition over the other which increases him in gold or silver or food over the other party."

He said, "If any of that enters the qirad, it becomes hire, and hire is only good with known and fixed terms. The agent should not stipulate when he takes the principal that he repay or commission anyone with the goods, nor that he take any of them for himself. When there is a profit, and it is time to separate the capital, then they divide the profit according to the terms of the contract. If the principal does not increase or there is a loss, the agent does not have to make up for what he spent on himself or for the loss. That falls to the investor from the principal. Qirad is permitted upon whatever terms the investor and the agent make a mutual agreement, of half the profit, or a third or a fourth or whatever."

Malik said, "It is not permitted for the agent to stipulate that he use the qirad money for a certain number of years and that it not be taken from him during that time."

He said, "It is not good for the investor to stipulate that the qirad money should not be returned for a certain number of years which are specified, because the qirad is not for a term. The investor loans it to an agent to use for him. If it seems proper to either of them to abandon the project and the money is coin, and nothing has been bought with it, it can be abandoned, and the investor takes his money back. If it seems proper to the investor to take the qirad loan back after goods have been purchased with it, he cannot do so until the buyer has sold the goods and they have become money. If it seems proper to the agent to return the loan, and it has been turned to goods he cannot do so until he has sold them. He returns the loan in cash as he took it."

Malik said, "It is not good for the investor to stipulate that the agent pay any zakat due from his portion of the profit in particular, because the investor by stipulating that, stipulates fixed increase for himself from the profit because the portion of zakat he would be liable for by his portion of the profit, is removed from him.

"It is not permitted for the investor to stipulate to the agent to only buy from so-and-so, referring to a specific man. That is not permitted because by doing so he would become his hireling for a wage."

Malik spoke about an investor in qirad who stipulated a guarantee for an amount of money from the agent, "The investor is not permitted to stipulate conditions about his principal other than the conditions on which qirad is based or according to the precedent of the sunna of the Muslims. If the principal is increased by the condition of guarantee, the investor has increased his share of the profit because of the position of the guarantee. But the profit is only to be divided according to what it would have been had the loan been given without the guarantee. If the principal is destroyed, I do not think that the agent has a guarantee held against him because the stipulation of guarantees in qirad is null and void."

Malik spoke about an investor who gave qirad money to a man and the man stipulated that he would only buy palms or animals with it because he sought to eat the dates or the offspring of the animals and he kept them for some time to use for himself. He said, "That is not permitted. It is not the sunna of the Muslims in qirad unless he buys it and then sells it as other goods are sold."

Malik said, "There is no harm in the agent stipulating on the investor a slave to help him provided that the slave stands to gain along with him out of the investment, and when the slave only helps him with the investment, not with anything else."


Malik :: Qirad :: [32-32.5.7]

Qirad

Malik :: Book 32 : Hadith 32.5.7

Yahya said that Malik said, "No one should make a qirad loan except in coin, because the loan must not be in wares, since loaning wares can only be worked in one of two ways: Either the owner of the wares says to the borrower, 'Take these wares and sell them. Buy and sell with the capital realized according to qirad.' The investor stipulates increase for himself from the sale of his goods and what relieves him of expenses in selling it. Or else he says, 'Barter with these goods and sell. When you are through, buy for me the like of my goods which I gave you. If there is increase, it is between you and me. 'It may happen that the investor gives the goods to the agent at a time in which they are in demand and expensive, and then the agent returns them while they are cheap and he might have bought them for only a third of the original price or even less than that. The agent then has a profit of half the amount by which the price of the wares has decreased as his portion of the profit. Or he might take the wares at a time when their price is low, and make use of them until he has a lot of money. Then those wares become expensive and their price rises when he returns them, so he buys them for all that he has so that all his work and concern have been in vain. This is an uncertain transaction and is not good. If, however, that is not known until it has happened, then the wage an agent in qirad would be paid for selling that, is looked at and he is given it for his concern. Then the money is qirad from the day the money became cash and collected as coin and it is returned as a qirad like that."


Malik :: Qirad :: [32-32.6.8]

Qirad

Malik :: Book 32 : Hadith 32.6.8

Yahya said that Malik spoke about a man who made a qirad loan to a man and he bought wares with it and transported them to a commercial centre. It was not profitable to sell them and the agent feared a loss if he sold them, so he hired transport to take them to another city, and he sold them there and made a loss, and the cost of the hire was greater than the principal.

Malik said, "If the agent can pay the cost of the hire from what the capital realized, his way is that. Whatever portion of the hire is not covered by the principal, the agent must pay it. The investor is not answerable for any of it. That is because the investor only ordered him to trade with the principal. The investor is not answerable for other than the principal. Had the investor been liable, it would have been an additional loss to him on top of the principal which he invested. The agent cannot put that on to the investor."


Malik :: Qirad :: [32-32.7.9]

Qirad

Malik :: Book 32 : Hadith 32.7.9

Yahya said that Malik spoke about an investor who made a qirad loan to a man, who used it and made a profit. Then the man bought with all the profit a slave-girl and he had intercourse with her and she became pregnant by him, and so the capital decreased. Malik said, "If he has money, the price of the slave-girl is taken from his property, and the capital is restored by it. If there is something left over after the money is paid, it is divided between them according to the first qirad. If he cannot pay it, the slave-girl is sold so that the capital is restored from her price."

Malik spoke about an investor who made a qirad loan to a man, and the agent spent more than the amount of the qirad loan when buying goods with it and paid the increase from his own money. Malik said, "The investor has a choice if the goods are sold for a profit or loss or if they are not sold. If he wishes to take the goods, he takes them and pays the agent back what he put in for them. If the agent refuses, the investor is a partner for his share of the price in increase and decrease according to what the agent paid extra for them from himself."

Malik spoke about an agent who took qirad money from a man and then gave it to another man to use as a qirad without the consent of the investor. He said, "The agent is responsible for the property. If it is decreased, he is responsible for the loss. If there is profit, the investor has his stipulation of the profit, and then the agent has his stipulation of what remains of the money."

Malik spoke about an agent who exceeded and borrowed some of what he had of qirad in money and he bought goods for himself with it. Malik said, "If he has a profit, the profit is divided according to the condition between them in the qirad. If he has a loss, he is responsible for the loss."

Malik said about an investor who paid qirad money to a man, and the agent borrowed some of the cash and bought goods for himself with it, "The investor of the capital has a choice. If he wishes, he shares with him in the goods according to the qirad, and if he wishes, he frees himself of them, and takes all of the principal back from the agent. That is what is done with some one who oversteps."


Malik :: Qirad :: [32-32.8.10]

Qirad

Malik :: Book 32 : Hadith 32.8.10

Yahya said that Malik spoke about an investor who made a qirad loan to a man.

He said, "When the investment is large, the travelling expenses of the agent are taken from it. He can use it to eat and clothe himself in an acceptable fashion according to the size of the investment. If it saves him trouble, he can take a wage from some of the capital, if it is large, and he cannot support himself. There are certain jobs which an agent or his like are not responsible for, amongst them are collecting debts, transporting the goods, loading up and so forth. He can hire from the capital someone to do that for him. The agent should not spend from the capital nor clothe himself from it while he resides with his family. It is only permitted for him to have expenses when he travels for the investment. The expenses are taken from the capital. If he is only trading with the property in the city in which he resides, he has no expenses from the capital and no clothing."

Malik spoke about an investor who paid qirad money to a man, and the agent went out with it and with his own capital. He said, "The expenses come from the qirad and from his own capital according to their proportions."


Malik :: Qirad :: [32-32.9.11]

Qirad

Malik :: Book 32 : Hadith 32.9.11

Yahya said that Malik spoke about an agent who had qirad money with him and he spent from it and clothed himself. He said, "He cannot give away any of it, and neither a beggar nor anyone else is to be given any of it and he does not pay anyone compensation from it. If he meets some people, and they bring out food and he brings out food, I hope that that will be permitted to him if he does not intend to bestow something on them. If he intends that or what is like that without the permission of the investor, he must get the sanction of the investor for it. If he sanctions it, there is no harm. If he refuses to sanction it, he must repay it with like if he has something which is suitable as compensation."


Malik :: Qirad :: [32-32.10.12]

Qirad

Malik :: Book 32 : Hadith 32.10.12

Yahya said that Malik said, "The generally agreed on way of doing things among us about an investor who pays qirad money to an agent to buy goods, and the agent then sells the goods for a price to be paid later, and has a profit in the transaction, then the agent dies before he has received payment, is that if his heirs want to take that money, they have their father's stipulated portion from the profit. That is theirs if they are trustworthy to take the payment. If they dislike to collect it from the debtor and they refer him to the investor, they are not obliged to collect it and there is nothing against them and nothing for them by their surrendering it to the investor. If they do collect it, they have a share of it and expenses like their father had. They are in the position of their father. If they are not trustworthy to do so, they can bring someone reliable and trustworthy to collect the money. If he collects all the capital and all the profit, they are in the position of their father."

Malik spoke about an investor who paid qirad money to a man provided that he used it and was responsible for any delayed payment for which he sold it. He said, "This is obligatory on the agent. If he sells it for delayed payment, he is responsible for it."


Malik :: Qirad :: [32-32.11.13]

Qirad

Malik :: Book 32 : Hadith 32.11.13

Yahya said that Malik spoke about an investor who gave qirad money to a man, and then the man sought a loan from the investor or the investor borrowed money from the agent, or the investor left goods with the agent to sell for him, or the investor gave the agent dinars to buy goods with. Malik said, "There is no harm if the investor leaves his goods with him knowing that if the agent did not have his money and he had asked a similar thing of him, he would have still done it because of the brotherhood between them or because it would have been no bother to him and that had the agent refused that, he would not have removed his capital from him. Or if the agent had borrowed from the investor or carried his goods for him and he knew that if the investor had not had his capital with him, he would have still done the same for him, and had he refused that to him, he would not have returned his capital to him. If that is true between both of them and it is in the way of a favour between them and it is not a condition in the terms of the qirad, it is permitted and there is no harm in it. If a condition comes into it, or it is feared that the agent is only doing it for the investor in order to safeguard the capital in his possession, or the investor is only doing it because the agent has taken his capital and will not return it to him, that is not permitted in qirad and it is part of what the people of knowledge forbid.' "


Malik :: Qirad :: [32-32.12.14]

Qirad

Malik :: Book 32 : Hadith 32.12.14

Yahya said that Malik spoke about a man who loaned another man money and then the debtor asked him to leave it with him as a qirad. Malik said, "I do not like that unless he takes his money back from him, and then pays it to him as a qirad if he wishes or if he wishes keep it."

Malik spoke about an investor who paid a man qirad money and the man told him that it was collected with him and asked him to write it for him as a loan. He said, "I do not like that unless he takes his money from him and then lends it to him or keeps it as he wishes. That is only out of fear that he has lost some of it, and wants to defer it so that he can make up what has been lost of it. That is disapproved of and is not permitted and it is not good."


Malik :: Qirad :: [32-32.13.15]

Qirad

Malik :: Book 32 : Hadith 32.13.15

Yahya said that Malik spoke about an investor paying qirad money to an agent who made a profit and then wanted to take his share of the profit and the investor was away. He said, "He should not take any of it unless the investor is present. If he takes something from it, he is responsible for it until it is accounted for in the division of the capital."

Malik said, "It is not permitted for the parties involved in a qirad to account and divide property which is away from them until the capital is present, and the investor is given the principal in full. Then they divide the profit into their agreed portions."

Malik spoke about a man taking qirad money, and buying goods with it while he had a debt. His creditors sought and found him while he was in a city away from the investor, and he had profitable merchandise whose good quality was clear. They wanted him to sell the merchandise for them so that they could take his share of the profit. Malik said, "None of the profit of the qirad is taken until the investor is present. He takes his principal and then the profit is divided mutually between them."

Malik spoke about an investor who put qirad money with an agent and he used it and had a profit. Then the principal was set aside and the profit divided. He took his share and added the share of the investor to his principal in the presence of witnesses he had called. Malik said, "It is not permitted to divide the profit unless the investor is present. If he has taken something here turns it until the investor has received the principal in full. Then what remains is divided into their respective portions."

Malik spoke about an investor who put qirad money with an agent. The agent used it and then came to the investor and said, "This is your portion of the profit, and I have taken the like of it for myself, and I have retained your principal in full." Malik said, "I do not like that, unless all the capital is present, the principal is there and he knows that it is complete and he receives it. Then they divide the profit between them. He returns the principal to him if he wishes, or he keeps it. The presence of the principal is necessary out of fear that the agent might have lost some of it, and so may want it not to be removed from him and to keep it in his hand."


Malik :: Qirad :: [32-32.14.16]

Qirad

Malik :: Book 32 : Hadith 32.14.16

Yahya said that Malik spoke about an investor who put qirad money with an agent who bought goods with it, and the investor told him to sell them. The agent said that he did not see any way to sell at that time and they quarrelled about it. He said, "One does not look at the statement of either of them. The people of experience and insight concerning such goods are asked about these goods. If they can see anyway of selling them they are sold for them. If they think it is time to wait, they should wait."

Malik spoke about a man who took qirad money from an investor and used it and when the investor asked him for his money, he said that he had it in full. When he held him to his settlement he admitted that "Such-and-such of it was lost with me," and he named an amount of money. "I told you that so that you would leave it with me." Malik said, "He does not benefit by denying it after he had confirmed that he had it all . He is answerable by his confession against himself unless he produces evidence about the loss of that property which confirms his statement. If he does not produce an acceptable reason he is answerable by his confession, and his denial does not avail him."

Malik said, "Similarly, had he said, 'I have had such-and-such a profit from the capital,' and then the owner of the capital asked him to pay him the principal and his profit, and he said that he had not had any profit in it and had said that only so it might be left in his possession, it does not benefit him. He is taken to account for what he affirmed unless he brings acceptable proof of his word, so that the first statement is not binding on him."

Malik spoke about an investor who put qirad money with an agent who made a profit with it. The agent said, "I took the qirad from you provided that I would have two-thirds." The owner of the capital says, "I gave you a qirad provided that you had a third." Malik said, "The word is the word of the agent, and he must take an oath on that if what he says resembles the known practice of qirad or is close to it. If he brings a matter which is unacceptable and people do not make qirads like that, he is not believed, and it is judged to be according to how a qirad like it would normally be."

Malik spoke about a man who gave a man one hundred dinars as a qirad. He bought goods with it and then went to pay the one hundred dinars to the owner of the goods and found that they had been stolen. The investor says, "Sell the goods. If there is anything over, it is mine. If there is a loss, it is against you because you lost it." The agent says, "Rather you must fulfil what the seller is owed. I bought them with your capital which you gave me." Malik said, "The agent is obliged to pay the price to the seller and the investor is told, 'If you wish, pay the hundred dinars to the agent and the goods are between you. The qirad is according to what the first hundred was based on. If you wish, you are free of the goods.' If the hundred dinars are paid to the agent, it is a qirad according to the conditions of the first qirad. If he refuses, the goods belong to the agent and he must pay their price."

Malik spoke about two people in a qirad who settled up and the agent still had some of the goods which he used - threadbare cloth or a waterskin or the like of that. Malik said, "Any of that which is insignificant is of no importance and belongs to the agent. I have not heard anyone give a decision calling for the return of that. Anything which has a price is returned. If it is something which has value like an animal, camel, coarse cloth or the like of that which fetches a price, I think that he should return what he has remaining of such things unless the owner overlooks it."


Malik :: Sharecropping :: [33-33.1.1]

Sharecropping

Malik :: Book 33 : Hadith 33.1.1

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, said to the jews of Khaybar on the day of the conquest of Khaybar, "I confirm you in it as long as Allah, the Mighty, the Majestic, establishes you in it, provided that the fruits are divided between us and you." Said continued, "The Messenger of Allah, may Allah bless him and grant him peace, used to send Abdullah ibn Rawaha, to assess the division of the fruit crop between him and them, and he would say, 'If you wish, you can buy it back, and if you wish, it is mine.' They would take it."


Malik :: Sharecropping :: [33-33.1.2]

Sharecropping

Malik :: Book 33 : Hadith 33.1.2

Malik related to me from Ibn Shihab from Sulayman ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, used to send Abdullah ibn Rawaha to Khaybar, to assess the division of the fruit crop between him and the jews of Khaybar.

The jews collected for Abdullah pieces of their women's jewellery and said to him, "This is yours. Go light on us and don't be exact in the division!"

Abdullah ibn Rawaha said, "O tribe of jews! By Allah! You are among the most hateful to me of Allah's creation, but it does not prompt me to deal unjustly with you. What you have offered as a bribe is forbidden. We will not touch it." They said, "This is what supports the heavens and the earth."

Malik said, "If a share-cropper waters the palms and between them there is some uncultivated land, whatever he cultivates in the uncultivated land is his."

Malik said, "If the owner of the land makes a condition that he will cultivate the uncultivated land for himself, that is not good because the sharecropper does the watering for the owner of the land and so he increases the owner of the land in property (without any return for himself)."

Malik said, "If the owner stipulates that the fruit crop is to be shared between them, there is no harm in that if all the maintenance of the property - seeding, watering and case, etc. - are the concern of the sharecropper.

If the share-cropper stipulates that the seeds are the responsibility of the owner of the property - that is not permitted because he has stipulated an outlay against the owner of the property. Share-cropping is conducted on the basis that all the care and expense is outlayed by the share-cropper, and the owner of the property is not obliged anything. This is the accepted method of share-cropping."

Malik spoke about a spring which was shared between two men, and then the water dried up and one of them wanted to work on the spring and the other said, "I don't have the means to work on it." He said, "Tell the one who wants to work on the spring, 'Work and expend. All the water will be yours. You will have its water until your companion brings you half of what you have spent. If he brings you half of what you have spent, he can take his share of the water.' The first one is given all the water, because he has spent on it, and if he does not reach anything by his work, the other has not incurred any expense."

Malik said, "It is not good for a share-cropper not to expend anything but his labour and to be hired for a share of the fruit while all the expense and work is incurred by the owner of the garden, because the share-cropper does not know what the exact wage is going to be for his labour, whether it will be little or great."

Malik said, "No-one who lends a qirad or grants a share-cropping contract, should exempt some of the wealth, or some of the trees from his agent, because, by that, the agent becomes his hired man. He says, 'I will grant you a share-crop provided that you work for me on such-and-such a palm - water it and tend it. I will give you a qirad for such-and-such money provided that you work for me with ten dinars. They are not part of the qirad I have given you.' That must not be done and it is not good. This is what is done in our community."

Malik said, "The sunna about what is permitted to an owner of a garden in share-cropping is that he can stipulate to the share-cropper the maintenance of walls, cleaning the spring, sweeping the irrigation canals, pollinating the palms, pruning branches, harvesting the fruit and such things, provided that the share-cropper has a share of the fruit fixed by mutual agreement. However, the owner cannot stipulate the beginning of new work which the agent will start digging a well, raising the source of a well, instigating new planting, or building a cistern whose cost is great. That is as if the owner of the garden said to a certain man, 'Build me a house here or dig me a well or make a spring flow for me or do some work for me for half the fruit of this garden of mine,' before the fruit of the garden is sound and it is halal to sell it. This is the sale of fruit before its good condition is clear. The Messenger of Allah, may Allah bless him and grant him peace, forbade fruit to be sold before its good condition became clear."

Malik said, "If the fruits are good and their good condition is clear and selling them is halal and then the owner asks a man to do one of those jobs for him, specifying the job, for half the fruit of his garden, for example, there is no harm in that. He has hired the man for something recognised and known. The man has seen it and is satisfied with it.

"As for share-cropping, if the garden has no fruit or little or bad fruit, he has only that. The labourer is only hired for a set amount, and hire is only permitted on these terms. Hire is a type of sale. One man buys another man's work from him. It is not good if uncertainty enters into it because the Messenger of Allah, may Allah bless him and grant him peace, forbade uncertain transactions."

Malik said, "The sunna in share-cropping with us is that it can be practised with any kind of fruit tree, palm, vine, olive tree, pomegranate, peach, and soon. It is permitted, and there is no harm in it provided that the owner of the property has a share of the fruit: a half or a third or a quarter or whatever."

Malik said, "Share-cropping is also permitted in any crop which emerges from the earth if it is a crop which is picked, and its owner cannot water, work on it and tend it.

"Share-cropping becomes reprehensible in anything in which share-cropping is normally permitted if the fruit is sound and the good condition is clear and it is halal to sell it. He must share-crop in it the next year. If a man waters fruit whose good condition is clear and it is halal to sell it, and he picks it for the owner, for a share of the crop, it is not sharecropping. It is similar to him being paid in dirhams and dinars. Share-cropping is what is between pruning the palms and when the fruit becomes sound and its sale is halal."

Malik said, "If some one makes a share-cropping contract for fruit trees before the condition becomes clear and its sale is halal, it is share-cropping and is permitted . "

Malik said, "Uncultivated land must not be involved in a share-cropping contract. That is because it is halal for the owner to rent it for dinars and dirhams or the equivalent for an accepted price."

Malik said, "As for a man who gives his uncultivated earth for a third or a fourth of what comes out of it, that is an uncertain transaction because crops may be scant one time and plentiful another time. It may perish completely and the owner of the land will have abandoned a set rent which would have been good for him to rent the land for. He takes an uncertain situation, and does not know whether or not it will be satisfactory. This is disapproved. It is like a man having someone travel for him for a set amount, and then saying, 'Shall I give you a tenth of the profit of the journey as your wage?' This is not halal and must not be done."

Malik summed up,"A man must not hire out himself or his land or his ship unless for a set amount."

Malik said, "A distinction is made between sharecropping in palms and in cultivated land because the owner of the palms cannot sell the fruit until its good condition is clear. The owner of the land can rent it when it is uncultivated with nothing on it."

Malik said, "What is done in our community about palms is that they can also be share-cropped for three and four years, and less or more than that."

Malik said, "That is what I have heard. Any fruit trees like that are in the position of palms. Contracts for several years are permissible for the sharecropper as they are permissible in the palms."

Malik said about the owner, "He does not take anything additional from the share-cropper in the way of gold or silver or crops which increases him. That is not good. The share-cropper also must not take from the owner of the garden anything additional which will increase him of gold, silver, crops or anything. Increase beyond what is stipulated in the contract is not good. It is also not good for the lender of a qirad to be in this position. If such an increase does enter share-cropping or quirad, it becomes by it hire. It is not good when hire enters it. Hire must never occur in a situation which has uncertainty in it."

Malik spoke about a man who gave land to another man in a share-cropping contract in which there were palms, vines, or the like of that of fruit trees and there was also uncultivated land in it. He said, "If the uncultivated land is secondary to the fruit trees, either in importance or in size of land, there is no harm in share-cropping. That is if the palms take up two-thirds of the land or more, and the uncultivated land is a third or less. This is because when the land that the fruit trees take up is secondary to the uncultivated land and the cultivated land in which the palms, vines or the like is a third or less, and the uncultivated land is two-thirds or more, it is permitted to rent the land and share-cropping in it is haram."

"One of the practices of people is to give out sharecropping contracts on property with fruit trees when there is uncultivated land in it, and to rent land while there are fruit trees on it, just as a Qur'an or sword which has some embellishment on it of silver is sold for silver, or a necklace or ring which have stones and gold in them are sold for dinars. These sales continue to be permitted. People buy and sell by them. Nothing described or instituted has come on that which if exceeded, makes it haram, and if fallen below makes it halal. What is done in our community about that is what people practise and permit among themselves. That is, if the gold or silver is secondary to what it is incorporated in, it is permitted to sell it. That is, if the value of the blade, the Qur'an, or the stones is two-thirds or more, and the value of the decoration is one-third or less."


Malik :: Sharecropping :: [33-33.2.3]

Sharecropping

Malik :: Book 33 : Hadith 33.2.3

Yahya said that Malik said, "The best of what has been heard about a sharecropper stipulating on the owner of the property the inclusion of some slave workers, is that there is no harm in that if they are workers that come with the property. They are like the property. There is no profit in them for the share-cropper except to lighten some of his burden. If they did not come with the property, his toil would be harder. It is like share-cropping land with a spring or land with a watering trough. You will not find anyone who receives the same share for share-cropping two lands which are equal in property and yield, when one property has a constant plentiful spring and the other has a watering trough, because of the lightness of working land with a spring, and the hardship of working land with a watering trough."

Malik added, "That is what is done in our community."

Malik said, "A share-cropper cannot employ workers from the property in other work, and he cannot make that a stipulation with the one who gives him the share-cropping contract. Nor is it permitted to one who share-crops to stipulate on the owner of the property inclusion of slaves for use in the garden who are not in it when he makes the share-cropping contract."

"Nor must the owner of the property stipulate on the one who uses his property for share-cropping that he take any of the slaves of the property and remove him from the property. The share-cropping of property is based on the state which it is currently in."

"If the owner of the property wants to remove one of the slaves of the property, he removes him before the share-cropping, or if he wants to put someone into the property, he does it before the share-cropping. Then he grants the share-cropping contract after that if he wishes. If any of the slaves die or go off or become ill, the owner of the property must replace them."


Malik :: Renting Land :: [34-34.1.1]

Renting Land

Malik :: Book 34 : Hadith 34.1.1

Yahya related to me from Malik from Rabia ibn Abd ar-Rahman from Handhala ibn Qays az-Zuraqi from Rafi ibn Khadij that the Messenger of Allah, may Allah bless him and grant him peace, forbade renting out fields.

Handhala said, "I asked Rafi ibn Khadij, about paying in gold and silver, and he said, 'There is no harm in it.' "


Malik :: Renting Land :: [34-34.1.2]

Renting Land

Malik :: Book 34 : Hadith 34.1.2

Malik related to me that Ibn Shihab said, "I asked Said ibn al-Musayyab about renting land for gold or silver, and he said, 'There is no harm in it.' "


Malik :: Renting Land :: [34-34.1.3]

Renting Land

Malik :: Book 34 : Hadith 34.1.3

Malik related to me from Ibn Shihab that he asked Salim ibn 'Abdullah ibn Umar about renting out fields. He said, "There is no harm in it for gold or silver." Ibn Shihab said, "I said to him, 'What do you think of the hadith which is mentioned from Rafi ibn Khadij?'" He said, ''Rafi has exaggerated. If I had a field, I would rent it out."


Malik :: Renting Land :: [34-34.1.5]

Renting Land

Malik :: Book 34 : Hadith 34.1.5

Malik related to me from Hisham ibn Urwa that his father used to rent out his land for gold and silver.

Malik was asked about a man who rented his field for 100 sa of dates or part of its produce of wheat or from other than its produce. He disapproved of that.


Malik :: Renting Land :: [34-34.1.41]

Renting Land

Malik :: Book 34 : Hadith 34.1.41

Malik related to me that he had heard that Abd ar-Rahman ibn Awf rented land, and he continued to have it in his possession until he died. His son said, "I thought that it was ours because of the length of time which it had remained in his hands, until he mentioned it to us at his death. He ordered us to pay some rent which he owed in gold or silver."


Malik :: Pre-emption in Property :: [35-35.1.1]

Pre-emption in Property

Malik :: Book 35 : Hadith 35.1.1

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab and from Abu Salama ibn Abd ar-Rahman ibn Awf that the Messenger of Allah, may Allah bless him and grant him peace, decreed for partners the right of preemption in property which had not been divided up. When boundaries had been fixed between them, then there was no right of pre-emption.

Malik said, "That is the sunna about which there is no dispute among us."


Malik :: Pre-emption in Property :: [35-35.1.2]

Pre-emption in Property

Malik :: Book 35 : Hadith 35.1.2

Malik said that he heard that Said ibn al-Musayyab, when asked about pre-emption and whether there was a sunna in it, said, "Yes. Pre-emption is in houses and land, and it is only between partners."


Malik :: Pre-emption in Property :: [35-35.1.3]

Pre-emption in Property

Malik :: Book 35 : Hadith 35.1.3

Malik related to me that he heard the like of that from Sulayman ibn Yasar.

Malik spoke about a man who bought out one of the partners in a shared property, by paying the man with an animal, a slave, a slave-girl, or the equivalent of that in goods. Then another partner decided to exercise his right of pre-emption after that, and he found that the slave or slave-girl had died, and no one knew what her value had been. The buyer claimed, "The value of the slave or slave-girl was 100 dinars." The partner with the right of pre-emption claimed, "The value was 50 dinars."

Malik said, "The buyer takes an oath that the value of what he payed was 100 dinars. Then if the one with the right of pre-emption wishes, he can compensate him, or else he can leave it, unless he can bring a clear proof that the slave or slave-girl's value is less than what the buyer said. If someone gives away his portion of a shared house or land and the recipient repays him for it by cash or goods, the partners can take it by pre-emption if they wish and pay off the recipient the value of what he gave in dinars or dirhams. If someone makes a gift of his portion of a shared house or land, and does not take any remuneration and does not seek to, and a partner wants to take it for its value, he cannot do so as long as the original partner has not been given recompense for it. If there is any recompense, the one with the right of pre-emption can have it for the price of the recompense."

Malik spoke about a man who bought into a piece of shared land for a price on credit, and one of the partners wanted to possess it by right of pre-emption . Malik said, "If it seems likely that the partner can meet the terms, he has right of pre-emption for the same credit terms. If it is feared that he will not be able to meet the terms, but he can bring a wealthy and reliable guarantor of equal standing to the one who bought into the land, he can also take possession."

Malik said, "A person's absence does not sever his right of pre-emption. Even if he is a way for a long time, there is no time limit after which the right of preemption is cut off."

Malik said that if a man left land to a number of his children, then one of them who had a child died and the child of the deceased sold his right in that land, the brother of the seller was more entitled to pre-empt him than his paternal uncles, the partners of his father.

Malik said, "This is what is done in our community."

Malik said, "Pre-emption is shared between partners according to their existing shares. Each of them takes according to his portion. If it is small, he has little. If it is great, it is according to that. That is if they are tenacious and contend with each other about it."

Malik said, "As for a man who buys out the share of one of his partners, and one of the other partners says, 'I will take a portion according to my share,' and the first partner says, 'If you wish to take all the preemption, I will give it up to you. If you wish to leave it, then leave it.' If the first partner gives him the choice and hands it over to him, the second partner can only take all the pre-emption or give it back. If he takes it, he is entitled to it. If not, he has nothing."

Malik spoke about a man who bought land, and developed it by planting trees or digging a well etc., and then someone came, and seeing that he had a right in the land, wanted to take possession of it by pre-emption. Malik said "He has no right of preemption unless he compensates the other for his expenditure. If he gives him the price of what he has developed, he is entitled to pre-emption . If not, he has no right in it."

Malik said that someone who sold off his portion of a shared house or land and then, on learning that some one with a right of pre-emption was to take possession by that right, asked the buyer to revoke the sale, and he did so, did not have the right to do that. The pre-emptor has more right to the property for the price for which he sold it.

In the case of some one who bought along with a section of a shared house or land, an animal and goods (that were not shared), so that when any one demanded his right of pre-emption in the house or land he said, "Take what I have bought altogether, for I bought it altogether," Malik said, "The pre-emptor need only take possession of the house or land. Each thing the man bought is assessed according to its share of the lump sum the man paid. Then the pre-emptor takes possession of his right for a price which is appropriate on that basis. He does not take any animals or goods unless he wants to do that."

Malik said, "If someone sells a section of shared land, and one of those who have the right of preemption surrenders it to the buyer and another refuses to do other than take his pre-emption, the one who refuses to surrender has to take all the preemption, and he cannot take according to his right and leave what remains.

In the case where one of a number of partners in one house sold his share when all his partners were away except for one man, the one present was given the choice of either taking the pre-emption or leaving it, and he said, 'I will take my portion and leave the portions of my partners until they are present. If they take it, that is that. If they leave it, I will take all the pre-emption,' Malik said, 'He can only take it all or leave it. If his partners come, they can take from him or leave it as they wish. If this is offered to him and he does not accept, I think that he has no pre-emption.' "


Malik :: Pre-emption in Property :: [35-35.2.4]

Pre-emption in Property

Malik :: Book 35 : Hadith 35.2.4

Yahya said that Malik related from Muhammad ibn Umara from Abu Bakr ibn Hazm that Uthman ibn Affan said, "When boundaries are fixed in land, there is no pre-emption in it. There is no pre-emption in a well or in male palm trees. "

Malik said, "This is what is done in our community."

Malik said, "There is no pre-emption in a road, whether or not it is practical to divide it."

Malik said, "What is done in our community is that there is no pre-emption in the courtyard of a house, whether or not it is practical to divide it."

Malik spoke about a man who bought into a shared property provided that he had the option of withdrawal and the partners of the seller wanted to take what their partner was selling by pre-emption before the buyer had exercised his option. Malik said, "They cannot do that until the buyer has taken possession and the sale is confirmed for him. When the sale is confirmed, they have the right of pre-emption."

Malik spoke about a man who bought land and it remained in his hands for some time. Then a man came and saw that he had a share of the land by inheritance. Malik said, "If the man's right of inheritance is established, he also has a right of preemption. If the land has produced a crop, the crop belongs to the buyer until the day when the right of the other is established, because he has tended what was planted against being destroyed or being carried away by a flood."

Malik continued, "If the time has been long, or the witnesses are dead or the seller has died, or the buyer has died, or they are both alive and the basis of the sale and purchase has been forgotten because of the length of time, pre-emption is discontinued. A man only takes his right by inheritance which has been established for him. If his situation differs from this, because the sale transaction is recent and he sees that the seller has concealed the price in order to sever his right of pre-emption, the value of the land is estimated, and he buys the land for that price by his right of pre-emption. Then the buildings, plants, or structures which are extra to the land are looked at, so he is in the position of some one who bought the land for a known price, and then after that built on it and planted. The owner of pre-emption takes possession after that is included."

Malik said, "Pre-emption is applied to the property of the deceased as it is applied to the property of the living. If the family of the deceased fear to break up the property of the deceased, then they share it and sell it, and they have no pre-emption in it."

Malik said, "There is no pre-emption among us in a slave or a slave-girl or a camel, a cow, sheep, or any animal, nor in clothes or a well which does not have any uncultivated land around it. Pre-emption is in what can be usefully divided, and in land in which boundaries occur. As for what cannot be usefully divided, there is no pre-emption in it."

Malik said, "Some one who buys land in which people who are present have a right of pre-emption, refers them to the Sultan and either they claim their right or the Sultan surrenders it to him. If he were to leave them, and not refer their situation to the Sultan and they knew about his purchase, and then they left it until a long time had passed and then came demanding their pre-emption, I do not think that they would have it."


Malik :: Judgements :: [36-36.1.1]

Judgements

Malik :: Book 36 : Hadith 36.1.1

Yahya related to me from Malik from Hisham ibn Urwa from his father from Zaynab bint Abi Salama from Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "I am but a man to whom you bring your disputes. Perhaps one of you is more eloquent in his proof than the other, so I give judgement according to what I have heard from him. Whatever I decide for him which is part of the right of his brother, he must not take any of it, for I am granting him a portion of the Fire."


Malik :: Judgements :: [36-36.1.2]

Judgements

Malik :: Book 36 : Hadith 36.1.2

Malik related to me from Yahya ibn Said from Said ibn al-Musayyab that Umar ibn al-Khattab had a dispute brought to him between a muslim and a jew. Umar saw that the right belonged to the jew and decided in his favour. The jew said to him, "By Allah! You have judged correctly.'' So Umar ibn al-Khattab struck him with a whip and said, "How can you be sure." The jew said to him, "We find that there is no judge who judges correctly but that there is an angel on his right side and an angel on his left side who guide him and give him success in the truth as long as he is with the truth. When he leaves the truth, they rise and leave him."


Malik :: Judgements :: [36-36.2.3]

Judgements

Malik :: Book 36 : Hadith 36.2.3

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from his father from Abdullah ibn Amr ibn Uthman from Abu Amra al-Ansari from Zayd ibn Khalid al-Juhani that the Messenger of Allah, may Allah bless him and grant him peace, said, "Shall I not tell you who is the best of witnesses? The one who brings his testimony before he is asked for it, or tells his testimony before he is asked for it."


Malik :: Judgements :: [36-36.2.4]

Judgements

Malik :: Book 36 : Hadith 36.2.4

Malik related to me that Rabia ibn Abi Abd ar-Rahman said, "An Iraqi man came before Umar ibn al-Khattab and said, 'I have come to you because of a matter which has no beginning and no end.' Umar said, 'What is it?' The man said, 'False testimony has appeared in our land.' Umar said, 'Is that so?' He said, 'Yes.' Umar said, 'By Allah! A man is not detained in Islam without just witnesses.' "

Malik related to me that Umar ibn al-Khattab said, "The testimony of some one known to bear a grudge or to be unreliable is not accepted."


Malik :: Judgements :: [36-36.3.4]

Judgements

Malik :: Book 36 : Hadith 36.3.4

Yahya said from Malik that he heard from Sulayman ibn Yasar and others that when they were asked whether the testimony of a man flogged for a hadd crime was permitted, they said, "Yes, when repentance (tawba) appears from him."

Malik related to me that he heard Ibn Shihab being asked about that and he said the like of what Sulayman ibn Yasar said.

Malik said, "That is what is done in our community. It is by the word of Allah, the Blessed, the Exalted, 'And those who accuse women who are muhsan, and then do not bring four witnesses, flog them with eighty lashes, and do not accept any testimony of theirs ever. They indeed are evil-doers, save those who turn in tawba after that and make amends. Allah is Forgiving, Merciful.' " (Sura 24 ayat 4).


Malik :: Judgements :: [36-36.4.5]

Judgements

Malik :: Book 36 : Hadith 36.4.5

Yahya said, "Malik said from Jafar ibn Muhammad from his father that the Messenger of Allah, may Allah bless him and grant him peace, pronounced judgement on the basis of an oath with one witness."


Malik :: Judgements :: [36-36.4.6]

Judgements

Malik :: Book 36 : Hadith 36.4.6

From Malik from Abu'z-Zinad that Umar ibn Abd al-Aziz wrote to Abd al-Hamid ibn Abd ar-Rahman ibn Zayd ibn al-Khattab who was the governor of Kufa, "Pronounce judgement on the basis of an oath with one witness."


Malik :: Judgements :: [36-36.4.7]

Judgements

Malik :: Book 36 : Hadith 36.4.7

Malik related to me that he heard that Abu Salama ibn Abd ar-Rahman and Sulayman ibn Yasar were both asked, "Does one pronounce judgement on the basis of an oath with one witness?" They both said, "Yes."

Malik said, "The precedent of the sunna in judging by an oath with one witness is that if the plaintiff takes an oath with his witness, he is confirmed in his right. If he draws back and refuses to take an oath, the defendant is made to take an oath. If he takes an oath, the claim against him is dropped. If he refuses to take an oath, the claim is confirmed against him."

Malik said, "This procedure pertains to property cases in particular. It does not occur in any of the hadd-punishments, nor in marriage, divorce, freeing slaves, theft or slander. If some one says, 'Freeing slaves comes under property,' he has erred. It is not as he said. Had it been as he said, a slave could take an oath with one witness, if he could find one, that his master had freed him.

"However, when a slave lays claim to a piece of property, he can take an oath with one witness and demand his right as the freeman demands his right."

Malik said, "The sunna with us is that when a slave brings somebody who witnesses that he has been set free, his master is made to take an oath that he has not freed him, and the slave's claim is dropped."

Malik said, "The sunna about divorce is also like that with us. When a woman brings somebody who witnesses that her husband has divorced her, the husband is made to take an oath that he has not divorced her. If he takes the oath, the divorce does not proceed . "

Malik said, "There is only one sunna of bringing a witness in cases of divorce and freeing a slave. The right to make an oath only belongs to the husband of the woman, and the master of the slave. Freeing is a hadd matter, and the testimony of women is not permitted in it because when a slave is freed, his inviolability is affirmed and the hadd punishments are applied for and against him. If he commits fornication and he is a muhsan, he is stoned. If he kills a slave, he is killed for it. Inheritance is established for him, between him and whoever inherits from him. If somebody disputes this, arguing that if a man frees his slave and then a man comes to demand from the master of the slave payment of a debt, and a man and two women testify to his right, that establishes the right against the master of the slave so that his freeing him is cancelled if he only has the slave as property, inferring by this case that the testimony of women is permitted in cases of setting free. The case is not as he suggests (i.e. it is a case of property not freeing). It is like a man who frees his slave, and then the claimant of a debt comes to the master and takes an oath with one witness, demanding his right. By that, the freeing of the slave would be cancelled. Or else a man comes who has frequent dealings and transactions with the master of the slave. He claims that he is owed money by the master of the slave. Someone says to the master of the slave, 'Take an oath that you don't owe what he claims'. If he draws back and refuses to take an oath, the one making the claim takes an oath and his right against the master of the slave is confirmed. That would cancel the freeing of the slave if it is confirmed that property is owed by the master."

Malik said, "It is the same case with a man who marries a slave-girl and then the master of the slave-girl comes to the man who has married her and claims, 'You and so-and-so have bought my slave-girl from me for such an amount of dinars. The husband of the slave-girl denies that. The master of the slave-girl brings a man and two women and they testify to what he has said. The sale is confirmed and his claim is considered true. So the slave-girl is haram for her husband and they have to separate, even though the testimony of women is not accepted in divorce."

Malik said, "It is also the same case with a man who accuses a free man, so the hadd falls on him. A man and two women come and testify that the one accused is a slave. That would remove the hadd from the accused after it had befallen him, even though the testimony of women is not accepted in accusations involving hadd punishments."

Malik said, "Another similar case in which judgement appears to go against the precedent of the sunna is that two women testify that a child is born alive and so it is necessary for him to inherit if a situation arises where he is entitled to inherit, and the child's property goes to those who inherit from him, if he dies, and it is not necessary that the two women witnesses should be accompanied by a man or an oath even though it may involve vast properties of gold, silver, live-stock, gardens and slaves and other properties. However, had two women testified to one dirham or more or less than that in a property case, their testimony would not affect anything and would not be permitted unless there was a witness or an oath with them."

Malik said, "There are people who say that an oath is not acceptable with only one witness and they argue by the word of Allah the Blessed, the Exalted, and His word is the Truth, 'And call in to witness two witnesses, men; or if the two be not men, then one man and two women, such witnesses as you approve of.' (Sura 2 ayat 282). Such people argue that if he does not bring one man and two women, he has no claim and he is not allowed to take an oath with one witness."

Malik said, "Part of the proof against those who argue this, is to reply to them, 'Do you think that if a man claimed property from a man, the one claimed from would not swear that the claim was false?' If he swears, the claim against him is dropped. If he refuses to take an oath, the claimant is made to take an oath that his claim is true, and his right against his companion is established. There is no dispute about this with any of the people nor in any country. By what does he take this? In what place in the Book of Allah does he find it? So if he confirms this, let him confirm the oath with one witness, even if it is not in the Book of Allah, the Mighty, the Majestic! It is enough that this is the precedent of the sunna. However, man wants to recognise the proper course of action and the location of the proof. In this there is a clarification for what is obscure about that, if Allah ta'ala wills."


Malik :: Judgements :: [36-36.5.7]

Judgements

Malik :: Book 36 : Hadith 36.5.7

Yahya said that Malik spoke about a man who died and had a debt owing to him and there was one witness, and some people had a debt against him and they had only one witness, and his heirs refused to take an oath on their rights with their witness. He said, "The creditors take an oath and take their rights. If there is anything left over, the heirs do not take any of it. That is because the oaths were offered to them before and they abandoned them, unless they say, 'We did not know that our companion had extra,' and it is known that they only abandoned the oaths because of that. I think that they should take an oath and take what remains after his debt."


Malik :: Judgements :: [36-36.6.8]

Judgements

Malik :: Book 36 : Hadith 36.6.8

Yahya said, "Malik said about Jamil ibn Abd ar-Rahman al-Muadhdin that he was present with Umar ibn Abd al-Aziz when he was judging between people. If a man came to him with a claim against a man, he examined whether or not there were frequent transactions and dealings between them. If there were, the defendant could make an oath. If there was nothing of that nature he did not accept an oath from him."

Malik summed up, "What is done in our community is that if some one makes a claim against a man, it is examined. If there are frequent transactions and dealings between them, the defendant is made to take an oath. If he takes an oath, the claim against him is dropped. If the defendant refuses to take an oath, and returns the oath to the claimant, the one claiming his right takes an oath and takes his due."


Malik :: Judgements :: [36-36.7.9]

Judgements

Malik :: Book 36 : Hadith 36.7.9

Yahya said, "Malik said from Hisham ibn Urwa that Abdullah ibn az-Zubayr gave judgment based on the testimony of children concerning the injuries between them."

Malik said, "The generally agreed on way of doing things in our community is that the testimony of children is permitted concerning injuries between them. It is not accepted about anything else. It is only permitted between them if they testify before they leave the scene of the incident and have been deceived or instructed. If they leave the scene, they have no testimony unless they call just witnesses to witness their testimony before they leave."


Malik :: Judgements :: [36-36.8.10]

Judgements

Malik :: Book 36 : Hadith 36.8.10

Yahya said, Malik related to us from Hisham ibn Hisham ibn Utba ibn Abi Waqqas from Abdullah ibn Nistas from Jabir ibn Abdullah al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, said, 'If someone swears a false oath near this mimbar of mine, he will take his seat in the fire.' "


Malik :: Judgements :: [36-36.8.11]

Judgements

Malik :: Book 36 : Hadith 36.8.11

Malik related to me from al-Ala ibn Abd ar-Rahman from Mabad ibn Kab as-Salami from his brother Abdullah ibn Kab ibn Malik al-Ansari from Abu Umama that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever cuts off the right of a muslim man by his oath, Allah forbids him the Garden and obliges the Fire for him." They said, "Even if it is something insignificant, Messenger of Allah?" He said, "Even if it is a tooth-stick, even if it is a tooth-stick," repeating it three times.


Malik :: Judgements :: [36-36.9.12]

Judgements

Malik :: Book 36 : Hadith 36.9.12

Yahya said that Malik had said from Da'ud ibn al-Husayn that he heard Abu Ghatafan ibn Tarif al-Muriyi say, "Zayd ibn Thabit al-Ansari and Ibn Muti had a dispute about a house which they shared. They went to Marwan ibn al-Hakam who was the Amir of Madina. Marwan decided that Zayd ibn Thabit must take an oath on the mimbar. Zayd ibn Thabit said, 'I swear to it where I am.' Marwan said, 'No, by Allah! only in the place of sorting out claims (i.e. the mimbar).' Zayd ibn Thabit began to take an oath that his right was true, and he refused to take an oath near the mimbar. Marwan ibn al-Hakam began to wonder at that."

Malik said, "I do not think that anyone should be made to take an oath near the mimbar for less than a fourth of a dinar, and that is three dirhams."


Malik :: Judgements :: [36-36.10.13]

Judgements

Malik :: Book 36 : Hadith 36.10.13

Yahya said, "Malik related to us from Ibn Shihab from Sa'id ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, said, 'The pledge given as security is not forfeited.' "

Malik said, "The explanation of that according to what we think - and Allah knows best - is that a man gives a pledge to somebody in security for something. The pledge is superior to that for which he pawned it. The pledger says to the pawn-broker, 'I will bring you your due, after such-and-such a time. If not, the pledge is yours for what it was pawned for.' "

Malik said, "This transaction is not good and it is not halal. This is what was forbidden. If the owner brings what he pledged it for after the period, it is his. I think that the time condition is void."


Malik :: Judgements :: [36-36.11.13]

Judgements

Malik :: Book 36 : Hadith 36.11.13

Yahya said, "I heard Malik say that if a man pledges his garden for a stated period and the fruits of that garden are ready before the end of that period, the fruits are not included in the pledge with the real estate, unless it is stipulated by the pledger in his pledge. However, if a man receives a slave-girl as a pledge and she is pregnant or she becomes pregnant after his taking her as a pledge, her child is included with her.

"A distinction is made between the fruit and the child of the slave-girl. The Messenger of Allah, may Allah bless him and grant him peace, said, 'If someone sells a palm which has been pollinated, the fruit belongs to the seller unless the buyer stipulates its inclusion.' The undisputed way of doing things in our community is that if a man sells a slave-girl or an animal with a foetus in its womb, the foetus belongs to the buyer, whether or not the buyer stipulates it. The palm is not like the animal. Fruit is not like the foetus in its mother's womb. Part of what clarifies that is also that it is the usage of people to have a man pawn the fruit of the palm apart from the palm. No one pawns the foetus in its mother's womb whether of slaves or animals."


Malik :: Judgements :: [36-36.12.13]

Judgements

Malik :: Book 36 : Hadith 36.12.13

Yahya said that he had heard Malik say, "The undisputed way of doing things in our community concerning pledges is that in cases where land or a house or an animal are known to have been destroyed whilst in the possession of the broker of the pledge, and the circumstances of the loss are known, the loss is against the pledger. There is no deduction made from what is due to the broker at all. Any pledge which perishes in the possession of the broker and the circumstances of its loss are only known by his word, the loss is against the broker and he is liable for its value. He is asked to describe whatever was destroyed and then he is made to take an oath about that description and what he loaned on security for it. "Then people of discernment evaluate the description. If the pledge was worth more than what the broker loaned, the pledger takes the extra. If the assessed value of the pledge is less than what he was loaned, the pledger is made to take an oath as to what the broker loaned and he does not have to pay the extra which the broker loaned above the assessed value of the pledge. If the pledger refuses to take an oath, he has to give the broker the extra above the assessed value of the pledge. If the broker says that he doesn't know the value of the pledge, the pledger is made to take an oath on the description of the pledge and that is his if he brings a matter which is not disapproved of."

Malik said, "All this applies when the broker takes the pledge and does not put it in the hands of another."


Malik :: Judgements :: [36-36.13.13]

Judgements

Malik :: Book 36 : Hadith 36.13.13

Yahya said that he heard Malik speak about two men who had a pledge between them. One of them undertook to sell his pledge, and the other one had asked him to wait a year for his due. He said, "If it is possible to divide the pledge, and the due of the one who asked him to wait will not be decreased, half the pledge which is between them is sold for him and he is given his due. If it is feared that his right will be decreased, all the pledge is sold, and the one who undertook to sell his pledge is given his due from that. If the one who asked him to wait for his due is pleased in himself, half of the price is paid to the pledger. If not, the pledgee is made to take an oath that he only asked him to wait so that he could transfer my pledge to me in its form.' Then he is given his due immediately."

Yahya said that he heard Malik say about a slave whose master had pledged him and the slave had property of his own, "The property of the slave is not part of the pledge unless the broker stipulates that."


Malik :: Judgements :: [36-36.14.13]

Judgements

Malik :: Book 36 : Hadith 36.14.13

Yahya said that he heard Malik speak about someone who pledged goods as security for a loan, and they perished with the broker. The one who took out the loan confirmed its specification. They agreed on the amount of the loan, but challenged each other about the value of the pledge, the pledger saying that it had been worth twenty dinars, whilst the broker said that it had been worth only ten, and that the amount loaned on security was twenty dinars. Malik said, "It is said to the one in whose hand the pledge is, 'describe it.' If he describes it he is made to take an oath on it and then the people of experience evaluate that description. If the value is more than what was loaned on security for it, it is said to the broker, 'Return the rest of his due to the pledger.' If the value is less than what was loaned on security for it, the broker takes the rest of his due from the pledger. If the value is the exact amount of the loan, the pledge is compensated for by the loan."

Yahya said that he heard Malik say, "What is done in our community about two men who have a dispute about an amount of money loaned on the security of a pledge - the pledger claiming that he pledged it for ten dinars and the broker insisting that he took the pledge as security for twenty dinars, and the pledge is clearly in the possession of the broker - is that the broker is made to take an oath when the value of the pledge is fully known. If the value of the pledge is exactly what he swore that he had loaned on security for it, the broker takes the pledge as his right. He is more entitled to take precedence with an oath since he has possession of the pledge. If the owner of the pledge wants to give him the amount which he swore that he was owed, he can take the pledge back. If the pledge is worth less than the twenty dinars he loaned, then it is said to the pledger, 'Either you give him what he has sworn to and take your pledge back, or you swear to what you said you pledged it for.' If the pledger takes the oath, then what the broker has increased over the value of the pledge will become invalid. If the pledger does not take an oath, he must pay what the broker swore to."

Malik said, "If a pledge given on security for a loan perishes, and both parties deny each other's rights, with the broker who is owed the loan saying that he gave twenty dinars, and the pledger who owes the loan saying that he was given only ten, and with the broker who is owed the loan saying the pledge was worth ten dinars, and the broker who owes the loan saying it was worth twenty, then the broker who is owed the loan is asked to describe the pledge. If he describes it, he must take an oath on its description. Then people with experience of it evaluate that description. If the value of the pledge is estimated to be more than what the broker claims it was, he takes an oath as to what he claimed, and the pledger is given what is over from the value of the pledge. If its value is less than what the broker claims of it, he is made to take an oath as to what he claims is his. Then he demands settlement according to the actual value of the pledge. The one who owes the loan is then made to take an oath on the extra amount which remains owing against him to the claimant after the price of the pledge is reached. That is because the broker becomes a claimant against the pledger. If he takes an oath, the rest of what the broker swore to of what he claimed above the value of the pledge is invalidated. If he draws back, he is bound to pay what remains due to the broker after the value of the pledge."


Malik :: Judgements :: [36-36.15.13]

Judgements

Malik :: Book 36 : Hadith 36.15.13

Yahya said that he heard Malik say, "What is done in our community about a man who rents an animal for a journey to a specified place and then he goes beyond that place and further, is that the owner of the animal has a choice. If he wants to take extra rent for his animal to cover the distance overstepped, he is given that on top of the first rent and the animal is returned. If the owner of the animal likes to sell the animal from the place where he over-steps, he has the price of the animal on top of the rent. If, however, the hirer rented the animal to go and return and then he overstepped when he reached the city to which he rented him, the owner of the animal only has half the first rent. That is because half of the rent is going, and half of it is returning. If he oversteps with the animal, only half of the first rent is obliged for him. Had the animal died when he reached the city to which it was rented, the hirer would not be liable and the renter would only have half the rent."

Malik said, "That is what is done with people who overstep and dispute about what they took the animal for."

Malik said, "It is also like that with some one who takes qirad-money from his companion. The owner of the property says to him, 'Do not buy such-and-such animals or such-and-such goods.' He names them and forbids them and disapproves of his money being invested in them. The one who takes the money then buys what he was forbidden. By that, he intends to be liable for the money and take the profit of his companion. When he does that, the owner of the money has an option. If he wants to enter with him in the goods according to the original stipulations between them about the profit, he does so. If he likes, he has his capital guaranteed against the one who took the capital and over stepped the mark."

Malik said, "It is also like that with a man with whom another man invests some goods. The owner of the property orders him to buy certain goods for him which he names. He differs, and buys with the goods something other than what he was ordered to buy. He exceeded his orders. The owner of the goods has an option. If he wants to take what was bought with his property, he takes it. If he wants the partner to be liable for his capital he has that."


Malik :: Judgements :: [36-36.16.14]

Judgements

Malik :: Book 36 : Hadith 36.16.14

Malik related to me from Ibn Shihab that Abd al-Malik ibn Marwan gave a judgment that the rapist had to pay the raped woman her bride-price.

Yahya said that he heard Malik say, "What is done in our community about the man who rapes a woman, virgin or non-virgin, if she is free, is that he must pay the bride-price of the like of her. If she is a slave, he must pay what he has diminished of her worth. The hadd-punishment in such cases is applied to the rapist, and there is no punishment applied to the raped woman. If the rapist is a slave, that is against his master unless he wishes to surrender him."


Malik :: Judgements :: [36-36.17.14]

Judgements

Malik :: Book 36 : Hadith 36.17.14

Yahya said that he heard Malik say, "What is done in our community about someone who consumed an animal without the permission of its owner, is that he must pay its price on the day he consumed it. He is not obliged to replace it with a similar animal nor does he compensate the owner with any kind of animal. He must pay its price on the day it was consumed, and giving the value is more equitable in compensation for animals and goods."

Yahya said that he heard Malik say about someone who consumes some food without the permission of its owner, "He returns to the owner a like weight of the same kind of food. Food is in the position of gold and silver. Gold and silver are returned with gold and silver. The animal is not in the position of gold in that. What distinguishes between them is the sunna and the behaviour which is in force.

Yahya said that he heard Malik say, "If a man is entrusted with some wealth and then trades with it for himself and makes a profit, the profit is his because he is responsible for the property until he returns it to its owner. "


Malik :: Judgements :: [36-36.18.15]

Judgements

Malik :: Book 36 : Hadith 36.18.15

Yahya related to me from Malik from Zayd ibn Aslam that the Messenger of Allah, may Allah bless him and grant him peace, said, "If someone changes his deen - strike his neck!"

The meaning of the statement of the Prophet, may Allah bless him and grant him peace, in our opinion and Allah knows best, is that "if someone changes his deen, strike his neck!" refers to those who leave Islam for other than it - like the heretics and their like, about whom it is known. They are killed without being called to tawba because their tawba is not recognised. They were hiding their kufr and publishing their Islam, so I do not think that one calls such people to tawba, and one does not accept their word. As for the one who goes out of Islam to something else and divulges it, one calls him to tawba. If he does not turn in tawba, he is killed. If there are people in that situation, I think that one should call them to Islam and call them to tawba. If they turn in tawba, that is accepted from them. If they do not turn in tawba, they are killed. That does not refer as we see it, and Allah knows best, to those who come out of Judaism to Christianity or from Christianity to Judaism, nor to someone who changes his deen from the various forms of deen except for Islam. Whoever comes out of Islam to other than it and divulges that, that is the one who is referred to, and Allah knows best!


Malik :: Judgements :: [36-36.18.16]

Judgements

Malik :: Book 36 : Hadith 36.18.16

Malik related to me from Abd ar-Rahman ibn Muhammad ibn Abdullah ibn Abd al-Qari that his father said, "A man came to Umar ibn al-Khattab from Abu Musa al-Ashari. Umar asked after various people, and he informed him. Then Umar inquired, 'Do you have any recent news?' He said, 'Yes. A man has become a kafir after his Islam.' Umar asked, 'What have you done with him?' He said, 'We let him approach and struck off his head.' Umar said, 'Didn't you imprison him for three days and feed him a loaf of bread every day and call on him to tawba that he might turn in tawba and return to the command of Allah?' Then Umar said, 'O Allah! I was not present and I did not order it and I am not pleased since it has come to me!' "


Malik :: Judgements :: [36-36.19.17]

Judgements

Malik :: Book 36 : Hadith 36.19.17

Yahya related to me from Malik from Suhayl ibn Abi Salih as-Samman from his father from Abu Hurayra that Sad ibn Ubada said to the Messenger of Allah, may Allah bless him and grant him peace, "What do you think if I find a man with my wife? Shall I grant him a respite until I bring four witnesses?" The Messenger of Allah, may Allah bless him and grant him peace, replied, "Yes."


Malik :: Judgements :: [36-36.19.18]

Judgements

Malik :: Book 36 : Hadith 36.19.18

Malik related to me from Yahya ibn Said from Said ibn al-Musayyab that a Syrian man called Ibn Khaybari found a man with his wife and killed him, or killed them both. Muawiya ibn Abi Sufyan found it difficult to make a decision and he wrote to Abu Musa al-Ashari to ask Ali ibn Abi Talib for him about that. So Abu Musa asked Ali ibn Abi Talib and AIi said to him, "Is this thing in my land? I adjure you, you must tell me." Abu Musa explained to him how Muawiya ibn Abi Sufyan had written him to ask Ali about it. Ali said, "I am Abu Hasan. If he does not bring four witnesses, then let him be completely handed over," (to the relatives of the murdered man).


Malik :: Judgements :: [36-36.20.19]

Judgements

Malik :: Book 36 : Hadith 36.20.19

Yahya said that Malik related from Ibn Shihab that Sunayn Abi Jamila, a man from the Banu Sulaym, found an abandoned child in the time of Umar ibn al-Khattab. Sunayn took him to Umar ibn al-Khattab. He asked, "What has induced you to take this person?" He answered, "I found him lost, so I took him.'' Umar's advisor said to him,' 'Amir al-Muminin! He is a man who does good." Umar inquired of him, "Is it so?" He replied, "Yes." Umar ibn al-Khattab said, "Go, he is free, and you have his wala' inheritance, and we will provide for him."

Yahya said that he heard Malik say, "What is done in our community about an abandoned child is that he is free, and his wala' inheritance belongs to the muslims, and they inherit from him and pay his blood money."


Malik :: Judgements :: [36-36.21.20]

Judgements

Malik :: Book 36 : Hadith 36.21.20

Yahya said from Malik from Ibn Shihab from Urwa ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, ''Utba ibn Abi Waqqas disclosed to his brother, Sad ibn Abi Waqqas, that he was the father of the son of the slave-girl of Zama, and made him promise to look after him (after his death). In the year of the conquest, Sad took him and said, 'He is the son of my brother. He covenanted with me about him.' Abd ibn Zama stood up and said, 'He is my brother and the son of my father's slave-girl. He was born on his bed.' They went to the Messenger of Allah, may Allah bless him and grant him peace. Sad said, 'Messenger of Allah! He is the son of my brother, he made a covenant with me about him.' Abd ibn Zama said, 'He is my brother and the son of my father's slave-girl and was born on my father's bed.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'He is yours, Abd ibn Zama.' Then the Messenger of Allah, may Allah bless him and grant him peace, said, 'A child belongs to the household (where he was born) and the adulterer is stoned.' Then he told Sawda bint Zama, 'Veil yourself from him,' since he saw in him a resemblance to Utba ibn Abi Waqqas." A'isha added, "He did not see her until he met Allah, the Mighty, the Majestic!"


Malik :: Judgements :: [36-36.21.21]

Judgements

Malik :: Book 36 : Hadith 36.21.21

Malik related to me from Yazid ibn Abdullah ibn al-Hadi from Muhammad ibn Ibrahim ibn al-Harith at-Taymi from Sulayman ibn Yasar from Abdullah ibn Abi Umayya that a woman's husband died, and she did the idda of four months and ten days. Then she married when she was free to marry. She stayed with her husband for four and a half months, then gave birth to a fully developed child. Her husband went to Umar ibn al-Khattab and mentioned that to him, so Umar called some of the old women of the Jahiliyya and asked them about that. One of the women said, "I will tell you what happened with this woman. When her husband died, she was pregnant by him, but then the blood flowed from her because of his death and the child became dry in her womb. When her new husband had intercourse with her and the water reached the child, the child moved in the womb and grew." Umar ibn al-Khattab believed her and separated them (until she had completed her idda). Umar said, "Only good has reached me about you two," and he connected the child to the first husband.


Malik :: Judgements :: [36-36.21.22]

Judgements

Malik :: Book 36 : Hadith 36.21.22

Malik related to me from Yahya ibn Said from Sulayman ibn Yasar that Umar ibn al-Khattab used to attach the children of the Jahiliyya to whoever claimed them in Islam. Two men came and each of them claimed a woman's child. Umar ibn al-Khattab summoned a person who scrutinized features and he looked at them. The scrutinizer said, "They both share in him." Umar ibn al-Khattab hit him with a whip. Then he summoned the woman, and said, "Tell me your tale." She said, "It was this one (indicating one of the two men) who used to come to me while I was with my people's camels. He did not leave me until he thought and I thought that I was pregnant. Then he left me, and blood flowed from me, and this other one took his place. I do not know from which of them the child is." The scrutinizer said, "Allah is greater." Umar said to the child, "Go to whichever of them you wish."


Malik :: Judgements :: [36-36.21.23]

Judgements

Malik :: Book 36 : Hadith 36.21.23

Malik related to me that he had heard that Umar ibn al-Khattab or Uthman ibn Affan gave a judgement about a slave woman who misled a man about herself and said that she was free. He married her and she bore children. It was decided that he should ransom his children with their like of slaves.

Yahya said that he heard Malik say, "To ransom them with their price is more equitable in this case, Allah willing."


Malik :: Judgements :: [36-36.22.23]

Judgements

Malik :: Book 36 : Hadith 36.22.23

Yahya said that he heard Malik say, "The way of doing things generally agreed upon in our community in the case of a man who dies and has sons and one of them claims, 'My father confirmed that so-and-so was his son,' is that the relationship is not established by the testimony of one man, and the confirmation of the one who confirmed it is only permitted as regards his own share in the division of his father's property. The one testified for is only given his due from the share of the testifier."

Malik said, "An example of this is that a man dies leaving two sons, and 600 dinars. Each of them takes 300 dinars. Then one of them testifies that his deceased father confirmed that so-and-so was his son. The one who testifies is obliged to give 100 dinars to the one thus connected. This is half of the inheritance of the one thought to be related, had he been related. If the other confirms him, he takes the other 100 and so he completes his right and his relationship is established. His position is similar to that of a woman who confirms a debt against her father or her husband and the other heirs deny it. She must pay to the person whose debt she confirms, the amount according to her share of the full debt, had it been confirmed against all the heirs. If the woman inherits an eighth, she pays the creditor an eighth of his debt. If a daughter inherits a half, she pays the creditor half of his debt. Whichever women confirm him, pay him according to this.

Malik said, "If a man's testimony is in agreement with what the woman testified to, that so-and-so had a debt against his father, the creditor is made to take an oath with one witness and he is given all his due. This is not the position with women because a man's testimony is allowed and the creditor must take an oath with the testimony of his witness, and take all his due. If he does not take an oath, he only takes from the inheritance of the one who confirmed him according to his share of the debt, because he confirmed his right and the other heirs denied it. It is permitted for him to confirm it."


Malik :: Judgements :: [36-36.23.24]

Judgements

Malik :: Book 36 : Hadith 36.23.24

Yahya said that Malik related from Ibn Shihab from Salim ibn Abdullah ibn Umar from his father that Umar ibn al-Khattab said, "What's the matter with men who have intercourse with their slave-girls and then dismiss them? No slave-girl comes to me whose master confesses that he has had intercourse with her but that I connect her child to him, whether or not he has practised coitus interruptus or stopped having intercourse with her."


Malik :: Judgements :: [36-36.23.25]

Judgements

Malik :: Book 36 : Hadith 36.23.25

Malik related to me from Nafi that Safiyya bint Abi Ubayd informed him that Umar ibn al-Khattab said, "What is the matter with men who have intercourse with their slave-girls and then leave them to go? No slave-girl comes to me whose master confesses that he has had intercourse with her but that I connect her child to him, whether or not he has practised coitus interruptus or left off from intercourse with her."

Yahya said that he heard Malik say, "What is done in our community about an umm walad who commits a crime is that her master is liable for what she has done up to her value. He does not have to surrender her, and he cannot be made to bear more than her value for her crime."


Malik :: Judgements :: [36-36.24.26]

Judgements

Malik :: Book 36 : Hadith 36.24.26

Yahya related from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "If anyone revives dead land, it belongs to him, and the unjust root has no right."

Malik explained, "The unjust root is whatever is taken, or planted without right."


Malik :: Judgements :: [36-36.24.27]

Judgements

Malik :: Book 36 : Hadith 36.24.27

Malik related to me from Ibn Shihab from Salim ibn Abdullah from his father that Umar ibn al-Khattab said, "Whoever revives dead land, it belongs to him."

Malik said, "That is what is done in our community."


Malik :: Judgements :: [36-36.25.28]

Judgements

Malik :: Book 36 : Hadith 36.25.28

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm that he heard that the Messenger of Allah, may Allah bless him and grant him peace, said about the flood-channels of Mahzur and Mudhaynib (in Madina), "Dam them systematically, so that the water is diverted into each property in turn up to ankle level, starting upstream."


Malik :: Judgements :: [36-36.25.29]

Judgements

Malik :: Book 36 : Hadith 36.25.29

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Excess water is not withheld in order to prevent herbage from growing."


Malik :: Judgements :: [36-36.25.30]

Judgements

Malik :: Book 36 : Hadith 36.25.30

Malik related to me from Abu'r-Rijal Muhammad ibn Abd ar-Rahman from his mother Amra bint Abd ar-Rahman that she informed him that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not withhold the surplus water of a well from people."


Malik :: Judgements :: [36-36.26.31]

Judgements

Malik :: Book 36 : Hadith 36.26.31

Yahya related to me from Malik from Amr ibn Yahya al-Mazini from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is no injury nor return of injury."


Malik :: Judgements :: [36-36.26.32]

Judgements

Malik :: Book 36 : Hadith 36.26.32

Malik related to me from Ibn Shihab from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "No one should prevent his neighbour from fixing a wooden peg in his wall." Then Abu Hurayra said, "Why do I see you turning away from it? By Allah! I shall keep on at you about it."


Malik :: Judgements :: [36-36.26.33]

Judgements

Malik :: Book 36 : Hadith 36.26.33

Malik related to me from Amr ibn Yahya al-Mazini from his father that ad-Dahhak ibn Khalifa watered his irrigation ditch from a large source of water. He wanted to have it pass through the land of Muhammad ibn Maslama, and Muhammad refused. Ad-Dahhak said to him, "Why do you prevent me? It will benefit you. You can drink from it first and last and it will not harm you." Muhammed refused so ad-Dahhak spoke about it to Umar ibn al-Khattab, and Umar ibn al-Khattab summoned Muhammad ibn Maslama and ordered him to clear the way. Muhammad said, "No." Umar said, "Why do you prevent your brother from what will benefit him and is also useful for you? You will take water from it first and last and it will not harm you."

Muhammad said, "No, by Allah!" Umar said, "By Allah, he will pass it through, even if it is over your belly!" Umar ordered him to allow its passage and ad-Dahhak did so.


Malik :: Judgements :: [36-36.26.34]

Judgements

Malik :: Book 36 : Hadith 36.26.34

Malik related to me from Amr ibn Yahya al-Mazini that his father said, "There was a stream in my grand-father's garden belonging to Abd ar-Rahman ibn Awf Abd ar-Rahman ibn Awf wanted to transfer it to a corner of the garden nearer to his land, and the owner of the garden prevented him. Abd ar-Rahman ibn Awf spoke to Umar ibn al-Khattab about it, and he gave a judgement to Abd ar-Rahman ibn Awf that he should transfer it."


Malik :: Judgements :: [36-36.27.35]

Judgements

Malik :: Book 36 : Hadith 36.27.35

Yahya related to me from Malik that Thawr ibn Zayd ad-Dili said, "I heard that the Messenger of Allah, may Allah bless him and grant him peace, said, 'A house or land that has been divided in the Jahiliyya, it is according to the division of the Jahiliyya. A house or land which has not been divided before the coming of Islam is divided according to Islam.' "


Malik :: Judgements :: [36-36.27.36]

Judgements

Malik :: Book 36 : Hadith 36.27.36

Yahya said that he heard Malik speak about a man who died and left properties in Aliya and Safila (outlying districts of Madina). He said, "Unirrigated naturally watered land is not in the same category as irrigated land unless the family are satisfied with that. Unirrigated land is only in the same category as land with a spring when it resembles it. When the properties are in one land, and are close together, each individual property is evaluated and then divided between the heirs. Dwellings and houses are in the same position."


Malik :: Judgements :: [36-36.28.37]

Judgements

Malik :: Book 36 : Hadith 36.28.37

Yahya related to me from Malik from Ibn Shihab from Haram ibn Sad ibn Muhayyisa that a female camel of al-Bara ibn Azib entered the garden of a man and it did some damage to it. The Messenger of Allah, may Allah bless him and grant him peace, gave a judgement that the people of the garden were responsible for guarding it in the day, and the owner of the animals was liable for what the animals destroyed at night.


Malik :: Judgements :: [36-36.28.38]

Judgements

Malik :: Book 36 : Hadith 36.28.38

Malik related to me from Hisham ibn Urwa from his father from Yahya ibn Abd ar-Rahman ibn Hatib that some slaves of Hatib stole a she-camel belonging to a man from the Muzayna tribe and they slaughtered it. The case was brought before Umar ibn al-Khattab, and Umar ordered Kathir ibn as-Salt to cut off their hands. Then Umar said to Habib, "I think you must be starving them," and he added, "By Allah! I will make you pay such a fine that it will be heavy for you." He enquired of the man from the Muzayna tribe, "What was the price of your camel?" The Muzayni said, "By Allah, I refused to sell her for 400 dirhams.'' Umar said, ''Give him 800 dirhams."

Yahya said that he heard Malik say, "Doubling the price is not the behaviour of our community. What people have settled on among us is that the man is obliged to pay the value of the camel or animal on the day he took it."


Malik :: Judgements :: [36-36.29.38]

Judgements

Malik :: Book 36 : Hadith 36.29.38

Yahya said that he heard Malik say, "What is done in our community about injury to a domestic animal, is that the one who injures it must pay the amount by which he has diminished the animal's price."

Yahya said that he heard Malik speak about a camel who attacked a man and he feared for himself and killed it or hamstrung it. He said, "If he has a clear proof that it was heading for him and had attacked him, there are no damages against him. If there is no clear proof except his word, he is responsible for the camel."


Malik :: Judgements :: [36-36.30.38]

Judgements

Malik :: Book 36 : Hadith 36.30.38

Yahya related that he heard Malik say that if a man gave a washer a garment to dye and he dyed it, and then the owner of the garment said, "I did not order you to use this dye," and the washer protested that he had done so, then the washer was to be believed. It was the same with the tailor and the gold-smith. They took an oath about it unless they produced something they would not normally have been employed to do. In that situation their statement was not allowed and the owner of the garment had to take an oath . If he rejected it and refused to swear, then the dyer was made to take an oath.

Yahya said, "I heard Malik speak about a dyer who was given a garment and he made a mistake and gave it to another man and the one to whom he gave it wore it. He said, 'The one who wore it has no damages against him, and the washer pays damages to the owner of the garment. That is when the man wears the garment which was given him without recognizing that it is not his. If he wears it knowing that it is not his garment, he is responsible for it.' "


Malik :: Judgements :: [36-36.31.38]

Judgements

Malik :: Book 36 : Hadith 36.31.38

Yahya said that he heard Malik say, "What is done in our community about a man who refers a creditor to another man for the debt he owes him is that if the one referred to goes bankrupt or dies, and does not leave enough to pay the debt, then the creditor has nothing against the one who referred him and the debt does not return to the first party."

Malik said, "This is the way of doing things about which there is no dispute in our community."

Malik said, "If a man has his debt to somebody taken on for him by another man and then the man who took it on dies or goes bankrupt, then whatever was taken on by him returns to the first debtor."


Malik :: Judgements :: [36-36.32.38]

Judgements

Malik :: Book 36 : Hadith 36.32.38

Yahya said that he heard Malik say, "If a man buys a garment which has a defect, a burn or something else, which the seller knows about and that is testified against him or he confirms it, and the man who has bought it causes a new tear which decreases the price of the garment, and then he learns about the original defect, he can return it to the seller and he is not liable for his tearing it.

"If a man buys a garment which has a defect of a burn or flaw, and the one who sold it to him claims that he did not know about it, and the buyer has cut the garment or dyed it, then the buyer has an option . If he wishes, he can have a reduction according to what the burn or flaw detracts from the price of the garment and he can keep the garment, or if he wishes to pay damages for what the cutting or dyeing has decreased of the price of the garment and return it, he can do so.

"If the buyer has dyed the garment with a dye which increases the value, the buyer has an option. If he wishes, he has a reduction from the price of the garment according to what the defect diminishes or if he wishes to become a partner with the one who sold the garment he does so. The price of the garment with a burn or flaw is looked at. If the price is ten dirhams, and the amount by which the dyeing increased the value is five dirhams, then they are partners in the garment, each according to his share. In this reckoning is the amount by which the dyeing increases the price of the garment."


Malik :: Judgements :: [36-36.33.39]

Judgements

Malik :: Book 36 : Hadith 36.33.39

Yahya related to us from Malik from Ibn Shihab from Humayd ibn Abd ar-Rah man ibn Awf and from Muhammad ibn an-Numan ibn Bashir that they related to him that an-Numan ibn Bashir said that his father Bashir brought him to the Messenger of Allah, may Allah bless him and grant him peace, and said, "I have given this son of mine one of my slaves." The Messenger of Allah, may Allah bless him and grant him peace, said, "Have you given each of your children the same as this?" He said, "No." The Messenger of Allah, may Allah bless him and grant him peace, said, "Then take the slave back."


Malik :: Judgements :: [36-36.33.40]

Judgements

Malik :: Book 36 : Hadith 36.33.40

Malik related to me from Ibn Shihab from Urwa ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Abu Bakr as-Siddiq gave me palm trees whose produce was twenty awsuq from his property at al-Ghaba. When he was dying, he said, 'By Allah, little daughter, there is no one I would prefer to be wealthy after I die than you. There is no one it is more difficult for me to see poor after I die than you. I gave you palm-trees whose produce is twenty awsuq. Had you cut them and taken possession of them, they would have been yours, but today they are the property of the heirs, and they are your two brothers and your two sisters, so divide it according to the Book of Allah.' A'isha continued, "I said, 'My father! By Allah, even if it had been more, I would have left it. There is only Asma. Who is my other sister?" Abu Bakr replied, 'What is in the womb of Kharija? (Kharija was the wife of Abu Bakr's 'brother' from the Ansar.) I think that it is going to be a girl.' "


Malik :: Judgements :: [36-36.33.41]

Judgements

Malik :: Book 36 : Hadith 36.33.41

Malik related to me from Ibn Shihab from Urwa ibn az-Zubayr from Abd ar-Rahman ibn Abd al-Qari that Umar ibn al-Khattab said, "What is wrong with men who give their sons gifts and then keep them and if the son dies, they say, 'My property is in my possession and I did not give it to anyone.' But if they themselves are dying, they say, 'It belongs to my son, I gave it to him.' Whoever gives a gift, and does not hand it over to the one to whom it was given, the gift is invalid, and if he dies it belongs to the heirs in general."


Malik :: Judgements :: [36-36.34.41]

Judgements

Malik :: Book 36 : Hadith 36.34.41

Yahya said that he heard Malik say, "What is done in our community about some one who gives a gift not intending a reward is that he calls witnesses to it. It is affirmed for the one to whom it has been given unless the giver dies before the one to whom it was given receives the gift."

He said, "If the giver wants to keep the gift after he has had it witnessed, he cannot. If the recipient claims it from him, he takes it."

Malik said, "If some one gives a gift and then withdraws it and the recipient brings a witness to testify for him that he was given the gift, be it goods, gold, silver or animals, the recipient is made to take an oath. If he refuses, the giver is made to take an oath. If he also refuses to take an oath, he gives to the recipient what he claims from him if he has at least one witness. If he does not have a witness, he has nothing . "

Malik said, "If someone gives a gift not expecting anything in return and then the recipient dies, the heirs are in his place. If the giver dies before the recipient has received his gift, the recipient has nothing. That is because he was given a gift which he did not take possession of. If the giver wants to keep it, and he has called witnesses to the gift, he cannot do that. If the recipient claims his right he takes it."


Malik :: Judgements :: [36-36.35.42]

Judgements

Malik :: Book 36 : Hadith 36.35.42

Malik related to me from Da'ud ibn al-Husayn from Abu Ghatafan ibn Tarif al-Muriyi that Umar ibn al-Khattab said, "If someone gives a gift to strengthen ties with a relative or as sadaqa, he cannot have it returned. If some one, however, gives a gift seeking by it favour or reward, he has his gift and can reclaim it if he does not have satisfaction from it."

Yahya said that he heard Malik say, "The generally agreed-on way of doing things in our community is that if the gift is returned to the one who gave it for recompense, and its value has been either increased or decreased, the one to whom it has been given gives the owner its value on the day he received it."


Malik :: Judgements :: [36-36.36.42]

Judgements

Malik :: Book 36 : Hadith 36.36.42

Yahya said that he heard Malik say, "The way of doing things in our community about which there is no dispute, is that if a man gives sadaqa to his son - sadaqa which the son takes possession of or which is in the father's keeping and the father has had his sadaqa witnessed, he cannot take back any of it because he cannot reclaim any sadaqa."

Yahya said that he heard Malik say, "The generally agreed-on way of doing things in our community in the case of someone who gives his son a gift or grants him a gift which is not sadaqa is that he can take it back as long as the child does not start a debt, which people claim from him, and which they trust him for on the strength of the gift his father has given him. The father cannot take back anything from the gift after debts are started against it.

"If a man gives his son or daughter something and a woman marries the man, and she only marries him for the wealth and the property which his father has given him and so the father wants to take that back, or, if a man marries a woman whose father has given her a gift and he marries her with an increased bride-price because of the wealth and property that her father has given, then the father says, 'I will take that back,' then the father cannot take back any of that from the son or daughter if it is as I have described to you."


Malik :: Judgements :: [36-36.37.43]

Judgements

Malik :: Book 36 : Hadith 36.37.43

Malik related to me from Ibn Shihab from Abu Salama ibn Abd ar-Rahman ibn Awf from Jabir ibn Abdullah al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, said, "If someone is given a life pension, for him and his posterity, it belongs to the person to whom it has been given. It never reverts to the one who gave it because he gave a gift and the rules of inheritance apply to it."


Malik :: Judgements :: [36-36.37.44]

Judgements

Malik :: Book 36 : Hadith 36.37.44

Malik related to me from Yahya ibn Said that Abd ar-Rahman ibn al-Qasim ibn Muhammad heard Makhul ad-Dimashqi ask al-Qasim ibn Muhammad about the life pension and what people said about it. Al-Qasim ibn Muhammad said, "I have only come upon people who keep to the conditions they make about their property and what they are given."

Yahya said that he heard Malik say, "What is done in our community is that the life pension reverts to the one who makes it a life pension unless he says, 'It belongs to you and your posterity.' "


Malik :: Judgements :: [36-36.37.45]

Judgements

Malik :: Book 36 : Hadith 36.37.45

Malik related to me from Nafi that Abdullah ibn Umar inherited the house of Hafsa bint Umar. He said, "Hafsa gave lodging to the daughter of Zayd ibn al-Khattab for as long as she lived. When the daughter of Zayd died, Abdullah ibn Umar took possession of the dwelling and considered that it was his."


Malik :: Judgements :: [36-36.38.46]

Judgements

Malik :: Book 36 : Hadith 36.38.46

Malik related to me from Rabia ibn Abi Abd ar-Rahman from Yazid, the mawla of al-Munbaith that Zayd ibn Khalid al-Juhani said, "A man came to the Messenger of Allah, may Allah bless him and grant him peace, and asked him about finds. He said, 'Memorize the characteristics of the object found, then publicise it for a year. If the owner comes, give it to him. If not, then it is your business.' He said, 'What about lost sheep, Messenger of Allah?' He said, 'They are yours, your brother's or the wolf's.' He said, 'And the lost camel?' He said, 'It's none of your concern. It has its water and its feet. It will reach water and eat trees until its owner finds it.' "


Malik :: Judgements :: [36-36.38.47]

Judgements

Malik :: Book 36 : Hadith 36.38.47

Malik related to me from Ayyub ibn Musa from Muawiya ibn Abdullah ibn Badr al-Juhani that his father informed him that he stopped with a people on the way to Syria and he found a purse which had eighty dinars in it. He mentioned that to Umar ibn al-Khattab. Umar said to him, "Announce it at the doors of the mosques and mention it to everyone who comes from Syria for a year. When a year passes, it is your business."


Malik :: Judgements :: [36-36.38.48]

Judgements

Malik :: Book 36 : Hadith 36.38.48

Malik related to me from Nafi that a man found something and went to Abdullah ibn Umar and said to him, "I have found something. What do you think I should do about it?" Abdullah ibn Umar said to him, "Publicise it!" He said, "I have done so." He said, "Do it again." He said, "I have done so." Abdullah said, "I do not order you to use it. If you wished, you could have left it."


Malik :: Judgements :: [36-36.39.48]

Judgements

Malik :: Book 36 : Hadith 36.39.48

Yahya said that he heard Malik say, "What is done in our community about a slave who finds something and uses it before the term which is set for finds has been reached, and that is a year, is that it is against his person. Either his master gives the price of what his slave has used, or he surrenders his slave to them as compensation. If he withheld it until the term was reached which is set for finds and he used it, it is a debt against him which follows him and it is not against his person and there is nothing against his master in it."


Malik :: Judgements :: [36-36.40.49]

Judgements

Malik :: Book 36 : Hadith 36.40.49

Malik related to me from Yahya ibn Said from Sulayman ibn Yasar that Thabit ibn ad-Dahhak al-Ansari told him that he had found a camel at Harra, so he hobbled it and mentioned it to Umar ibn al-Khattab and Umar ordered him to make it known three times. Thabit said to him, "That would distract me from the running of my estate." Umar said to him, "Then let it go where you found it."


Malik :: Judgements :: [36-36.40.50]

Judgements

Malik :: Book 36 : Hadith 36.40.50

Malik related to me from Yahya ibn Said from Said ibn al-Musayyab that Umar ibn al-Khattab said while he was leaning his back against the Kaba, "Whoever takes a stray is astray."


Malik :: Judgements :: [36-36.40.51]

Judgements

Malik :: Book 36 : Hadith 36.40.51

Malik related to me that he heard Ibn Shihab say, "The stray camels in the time of Umar ibn al-Khattab were numerous and left alone. No one touched them until the time of Uthman ibn Affan. He ordered that they be publicised and then sold, and if the owner came afterwards, he was given their price."


Malik :: Judgements :: [36-36.41.52]

Judgements

Malik :: Book 36 : Hadith 36.41.52

Malik related to me from Said ibn Amr Shurahbil ibn Said ibn Sad ibn Ubada from his father that his father said, ''Sad ibn Ubada went out with the Messenger of Allah, may Allah bless him and grant him peace, in one of his raids and his mother was dying in Madina. Someone said to her, 'Leave a testament.' She said, 'In what shall I leave a testament? The property is Sad's property.' Then she died before Sad returned. When Sad ibn Ubada returned, that was mentioned to him. Sad said,

'Messenger of Allah! Will it help her if I give sadaqa for her?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Yes' Sad said, 'Such-and-such a garden is sadaqa for her,' naming the garden."


Malik :: Judgements :: [36-36.41.53]

Judgements

Malik :: Book 36 : Hadith 36.41.53

Malik related to me from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that a man said to the Messenger of Allah, may Allah bless him and grant him peace, "My mother died suddenly, and I think that had she spoken, she would have given sadaqa. Shall I give sadaqa for her?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes."


Malik :: Judgements :: [36-36.41.54]

Judgements

Malik :: Book 36 : Hadith 36.41.54

Malik related to me that he heard that a man of the Ansar from the tribe of Banu al-Harith ibn al-Khazraj, gave sadaqa to his parents and then they died. Their son inherited the property he had given them and it was palm-trees. He asked the Messenger of Allah, may Allah bless him and grant him peace, about it and he said, "You are rewarded for your sadaqa, and take it as your inheritance."


Malik :: Wills and Testaments :: [37-37.1.1]

Wills and Testaments

Malik :: Book 37 : Hadith 37.1.1

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "It is the duty of a muslim man who has something to be given as a bequest not to spend two nights without writing a will about it."

Malik said, "The generally agreed-on way of doing things in our community is that when the testator writes something in health or illness as a bequest, and it has freeing slaves or things other than that in it, he can alter it in any way he chooses, until he is on his deathbed. If he prefers to abandon a bequest or change it, he can do so unless he has made a slave mudabbar (to be freed after his death). If he has made him mudabbar, there is no way to change what he has made mudabbar. He is allowed to change his testament because the Messenger of Allah, may Allah bless him and grant him peace, said, "It is the duty of a muslim man who has something to be given as a bequest not to spend two nights without writing a will about it."

Malik explained, "Had the testator not been able to change his will nor what was mentioned in it about freeing slaves, each testator might withhold making bequests from his property, whether in freeing slaves or other than it. A man gives a bequest in his health and in his travelling." (i.e. he does not wait till his death bed ) .

Malik summed up, "The way of doing things in our community about which there is no dispute is that he can change whatever he likes of that except for the mudabbar."


Malik :: Wills and Testaments :: [37-37.2.2]

Wills and Testaments

Malik :: Book 37 : Hadith 37.2.2

Malik related to me from Abdullah ibn Abi Bakr ibn Hazm that Amr ibn Sulaym az-Zuraqi informed his father that it had been said to Umar ibn al-Khattab, "There is here an adolescent boy who has not yet reached puberty. He is from the Ghassan tribe and his heir is in ash-Sham. He has property. Here he only has the daughter of one of his paternal uncles." Umar ibn al-Khattab instructed, "Let him leave her a bequest." He willed her a property called the well of Jusham.

Malik added, "That property was sold for 30,000 dirhams, and the daughter of the paternal uncle to whom he willed it was the mother of Amr ibn Sulaym az-Zuraqi."


Malik :: Wills and Testaments :: [37-37.2.3]

Wills and Testaments

Malik :: Book 37 : Hadith 37.2.3

Malik related to me from Yahya ibn Said from Abu Bakr ibn Hazm that a boy from Ghassan was dying in Madina while his heir was in Syria. That was mentioned to Umar ibn al-Khattab. It was said to him, "So-and-so is dying. Shall he make a bequest?" He said, "Let him make a bequest."

Yahya ibn Said said that Abu Bakr had said, "He was a boy of ten or twelve years." Yahya said, "He willed the well of Jusham, and his people sold it for 30,000 dirhams."

Yahya said that he heard Malik say, "The generally agreed-on way of doing things in our community is that a simpleton, an idiot, or a lunatic who recovers at times, can make wills if they have enough of their wits about them to recognise what they will. Someone who has not enough wits to recognise what he wills, and is overcome in his intellect, cannot make a bequest."


Malik :: Wills and Testaments :: [37-37.3.4]

Wills and Testaments

Malik :: Book 37 : Hadith 37.3.4

Malik related to me from Ibn Shihab from Amir ibn Sad ibn Abi Waqqas that his father said, "The Messenger of Allah, may Allah bless him and grant him peace, came to me to treat me for a pain which became hard to bear in the year of the farewell hajj. I said, 'Messenger of Allah, you can see how far the pain has reached me. I have property and only my daughter inherits from me. Shall I give two thirds of my property as sadaqa?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'No.' I said, 'Half?' He said, 'No.' Then the Messenger of Allah, may Allah bless him and grant him peace, said, 'A third, and a third is a lot. Leaving your heirs rich is better than leaving them poor to beg from people. You never spend anything on maintenance desiring the Face of Allah by it, but that you are rewarded for it, even what you appoint for your wife.' Sad said, 'Messenger of Allah, will I be left here in Makka after my companions have departed for Madina?' The Messenger of Allah, may Allah bless him and grant him peace, said, 'If you are left behind, and do sound deeds you will increase your degree and elevation by them. Perhaps you will be left behind so that some people may benefit by you and others may be harmed by you. O Allah! complete their hijra for my companions, and do not turn them back on their heels. The unfortunate one is Said ibn Khawla.' The Messenger of Allah, may Allah bless him and grant him peace, was distressed on his account for he had died at Makka."

Yahya said that he heard Malik speak about a man who willed a third of his property to a man and said as well, "My slave will serve so-and-so (another man) for as long as he lives, then he is free," then that was looked into, and the slave was found to be a third of the property of the deceased. Malik said, "The service of the slave is evaluated. Then the two of them divide it between them. The one who was willed a third takes his third, as a share, and the one who was willed the service of the slave takes what was evaluated for him of the slave's service. Each of them takes, from the service of the slave or from his wage if he has a wage, according to his share. If the one who was given the service of the slave for as long as he lived dies, then the slave is freed."

Yahya said that he heard Malik speak about someone who willed his third and said "So-and-so has such-and-such, and so-and-so has such-and-such," naming some of his property, and his heirs protested that it was more than a third." Malik said, "The heirs then have an option between giving the beneficiaries their full bequests and taking the rest of the property of the deceased, or between dividing among the beneficiaries the third of the property of the deceased and surrendering to them their third. If they wish, their rights in it reach as far as they reach."


Malik :: Wills and Testaments :: [37-37.4.4]

Wills and Testaments

Malik :: Book 37 : Hadith 37.4.4

Yahya said that he heard Malik say, "The best of what I have heard about the testament of a pregnant woman and about what settlements she is permitted in her property is that the pregnant woman is like the sick person. When the illness is light, and one does not fear for the sick person, he does with his property what he likes. If the illness is such that his life is feared for, he can only dispose of a third of his estate."

He said, "It is the same with a woman who is pregnant. The beginning of pregnancy is good news and joy. It is not illness and no fear because Allah the Blessed, the Exalted, said in His Book, 'We gave her good news of Ishaq and after Ishaq, Yaqub.' (Sura ll ayat 71). And He said, 'She bore a light burden and passed by with it, but when she became heavy, they called upon Allah, their Lord, "If you give us a good-doing son, we will be among the thankful." '(Sura 7 ayat 189).

"When a pregnant woman becomes heavy, she is only permitted to dispose of a third of her estate. The beginning of this restriction is after six months. Allah, the Blessed, the Exalted, said in His Book, 'Mothers suckle their children for two complete years.' And He said, 'his bearing and weaning are thirty months.' (Sura 2 ayat 233).

"When six months have passed for the pregnant woman from the day she conceived, she is only permitted to dispose of a third of her property."

Yahya said that he heard Malik say, "A man who is advancing in the row for battle, can only dispose of a third of his property. He is in the same position as a pregnant woman or an ill person who is feared for, as long as he is in that situation."


Malik :: Wills and Testaments :: [37-37.5.4]

Wills and Testaments

Malik :: Book 37 : Hadith 37.5.4

Yahya said that he heard Malik say, "This ayat is abrogated. It is the word of Allah, the Blessed, the Exalted, 'If he leaves goods, the testament is for parents and kinsmen.' What came down about the division of the fixed shares of inheritance in the Book of Allah, the Mighty, the Exalted, abrogated it."

Yahya said that he heard Malik say, "The established sunna with us, in which there is no dispute, is that it is not permitted for a testator to make a bequest (in addition to the fixed share) in favour of an heir, unless the other heirs permit him. If some of them permit him and others refuse, he is allowed to diminish the share of those who have given their permission. Those who refuse take their full share from the inheritance.

Yahya said that he heard Malik speak about an invalid who made a bequest and asked his heirs to give him permission to make a bequest when he was so ill that he only had command of a third of his property, and they gave him permission to leave some of his heirs more than his third. Malik said, "They cannot revoke that. Had they been permitted to do so, every heir would have done that, and then, when the testator died, they would take that for themselves and prevent him from bequeathing his third and what was permitted to him with respect to his property."

Malik said, "If he asks permission of his heirs to grant a bequest to an heir while he is well and they give him permission, that is not binding on them. The heirs can rescind that if they wish. That is because when a man is well, he is entitled to all his property and can do what he wishes with it. If he wishes, he can spend all of it. He can spend it and give sadaqa with it or give it to whomever he likes. His asking permission of his heirs is permitted for the heirs, when they give him permission when authority over all his property is closed off from him and nothing outside of the third is permitted to him, and when they are more entitled to the two-thirds of his property than he is himself. That is when their permission becomes relevant. If he asks one of the heirs to give his inheritance to him when he is dying, and the heir agrees and then the dying man does not dispose of it at all, it is returned to the one who gave it unless the deceased said to him, 'So-and-so - (one of his heirs) - is weak, and I would like you to give him your inheritance.' So he gives it to him. That is permitted when the deceased specified it for him."

Malik said, "When a man gives the dying man free use of his share of the inheritance, and the dying man distributes some of it and some remains, it is returned to the giver, after the man has died."

Yahya said that he heard Malik speak about someone who made a bequest and mentioned that he had given one of his heirs something which he had not taken possession of, so the heirs refused to permit that. Malik said, "That gift returns to the heirs as inheritance according to the Book of Allah because the deceased did not mean that to be taken out of the third and the heirs do not have a portion in the third (which the dying man is allowed to bequeath)."


Malik :: Wills and Testaments :: [37-37.6.5]

Wills and Testaments

Malik :: Book 37 : Hadith 37.6.5

Malik said from Hisham ibn Urwa from his father that an effeminate man was with Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace. He said to Abdullah ibn Abi Umayya while the Messenger of Allah, may Allah bless him and grant him peace, was listening. "Abdullah! If Allah grants you victory over Ta'if tomorrow, I will lead you to the daughter of Ghailan. She has four folds on her front and eight folds on her back." The Messenger of Allah, may Allah bless him and grant him peace, said, "This sort of man should not enter freely with you." (It was customary to allow men with no sexual inclination to enter freely where there were women).


Malik :: Wills and Testaments :: [37-37.6.6]

Wills and Testaments

Malik :: Book 37 : Hadith 37.6.6

Malik related to me that Yahya ibn Said said that he heard al-Qasim ibn Muhammad say, "A woman of the Ansar was married to Umar ibn al-Khattab. She bore Asim ibn Umar to him, and then he separated from her. Umar came to Quba and found his son Asim playing in the courtyard of the mosque. He took him by the arm and placed him before him on his mount. The grandmother of the child saw him and argued with Umar about the child so they went to Abu Bakr as-Siddiq. Umar said, 'My son.' The woman said, 'My son.' Abu Bakr said, 'Do not interfere between a child and its mother.' Umar did not repeat his words."

Yahya said that he heard Malik say, "This is what I would have done in that situation."


Malik :: Wills and Testaments :: [37-37.7.6]

Wills and Testaments

Malik :: Book 37 : Hadith 37.7.6

Yahya said that he heard Malik speak about a man who bought goods - animals or clothes or wares, and the sale was found not to be permitted so it was revoked and the one who had taken the goods was ordered to return the owner his goods. Malik said, "The owner of the goods only has their value on the day they were taken from him, and not on the day they are returned to him. That is because the man is liable for them from the day he took them and whatever loss is in them after that is against him. For that reason, their increase and growth are also his. A man may take the goods at a time when they are selling well and are in demand, and then have to return them at a time when they have fallen in price and no one wants them. For instance, the man may take the goods from the other man, and sell them for ten dinars or keep them while their price is that. Then he may have to return them while their price is only a dinar. He should not go off with nine dinars from the man's property. Or perhaps they are taken by the man, and he sells them for a dinar or keeps them, while their price is only a dinar, then he has to return them, and their value on the day he returns them is ten dinars. The one who took them does not have to pay nine dinars from his property to the owner. He is only obliged to pay the value of what he took possession of on the day it was taken ."

He said, "Part of what clarifies this is that when a thief steals goods, only their price on the day he stole them is looked at. If cutting off the hand is necessary because of it, that is done. If the cutting off is delayed, either because the thief is imprisoned until his situation is examined or he flees and then is caught, the delay of the cutting off of the hand does not make the hadd, which was obliged for him on the day he stole, fall from him even if those goods become cheap after that. Nor does delay oblige cutting off the hand if it was not obliged on the day he took those goods, even if they become expensive after that."


Malik :: Wills and Testaments :: [37-37.8.7]

Wills and Testaments

Malik :: Book 37 : Hadith 37.8.7

Malik related to me from Yahya ibn Said that Abu'd-Darda wrote to Salman al-Farsi, "Come immediately to the holy land." Salman wrote back to him, "Land does not make anyone holy. Man's deeds make him holy. I have heard that you were put up as a doctor to treat and cure people. If you are innocent, then may you have delight! If you are a quack, then beware lest you kill a man and enter the Fire!" When Abu'd-Darda judged between two men, and they turned from him to go, he would look at them and say, "Come back to me, and tell me your story again. A quack! By Allah!"

Yahya said that he heard Malik say, "If someone makes use of a slave, without permission of its master, in anything important to him, whose like has a fee, he is liable for what befalls the slave if anything befalls him. If the slave is safe and his master asks for his wage for what he has done, that is the master's right. This is what is done in our community."

Yahya said that he heard Malik say about a slave who is part free and part enslaved, "His property is suspended in his hand and he cannot begin anything with it. He eats from it and clothes himself in an approved fashion. If he dies, his property belongs to the one to whom he is in slavery."

Yahya said that he heard Malik say, "The way of doing things in our community is that a parent can take his child to account for what he spends on him from the day the child has property, cash or goods, if the parent wants that."


Malik :: Wills and Testaments :: [37-37.8.8]

Wills and Testaments

Malik :: Book 37 : Hadith 37.8.8

Malik related to me from Umar ibn Abd ar-Rahman ibn Dalaf al-Muzani from his father that a man from the Juhayna tribe used to buy camels before people set out for hajj and sell them at a higher price. Then he travelled quickly and used to arrive in Makka before the others who set out for hajj. He went bankrupt and his situation was put before Umar ibn al-Khattab, who said, "O People! al-Usayfi, al-Usayfi of the Juhayna, was satisfied with his deen and his trust because it was said of him that he arrived before the others on hajj. He used to incur debts which he was not careful to repay, so all of his property has been eaten up by it. Whoever has a debt against him, let him come to us tomorrow and we will divide his property between his creditors. Beware of debts! Their beginning is a worry and their end is destitution. "


Malik :: Wills and Testaments :: [37-37.9.8]

Wills and Testaments

Malik :: Book 37 : Hadith 37.9.8

Yahya said that he heard Malik say, "The sunna with us about the crime of slaves is that the hand is not cut off for any harm that a slave causes a man, or something he pilfers, or something guarded which he steals, or hanging dates he cuts down or ruins, or steals. That is against the slave's person and does not exceed the price of the slave whether it is little or much. If his master wishes to give the value of what the slave took or ruined, or pay the blood-price for the injury, he pays it and keeps his slave. If he wishes to surrender him, he surrenders him, and none of that is against him. The master has the option in that."


Malik :: Wills and Testaments :: [37-37.10.9]

Wills and Testaments

Malik :: Book 37 : Hadith 37.10.9

Malik related to me from Ibn Shihab from Said ibn al-Musayyab that Uthman ibn Affan said, "If someone gives something to his small child who is not old enough to look after it himself, and in order that his gift might be permitted he makes the gift public and has it witnessed, the gift is permitted, even if the father keeps charge of it."

Malik said, "What is done in our community is that if a man gives his small child some gold or silver and then dies and he has it in his own keeping, the child has none of it unless the father set it aside in coin or placed it with a man to keep for the son. If he does that, it is permitted for the son."


Malik :: Setting Free and Wala' :: [38-38.1.1]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.1.1

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace,said, "If a man frees his share of a slave and has enough money to cover the full price of the slave justly evaluated for him, he must buy out his partners so that the slave is completely freed. If he doesn't have the money, he partially frees him.

Malik said, "The generally agreed-on way of doing things among us in the case of slave whose master makes a bequest to free part of him - a third, a fourth, a half, or any share after his death, is that only the portion of him is freed that his master has named. This is because the freeing of that portion is only obliged to take place after the death of the master because the master has the option to withdraw the bequest as long as he lives. When the slave is freed from his master, the master is a testator and the testator only has access to free what he can take from his property, being the third of the property he is allowed to bequeath, and the rest of the slave is not free because the man's property has gone out of his hands. How can the rest of the slave which belongs to other people be free when they did not initiate the setting free and did not confirm it and they do not have the wala' established for them? Only the deceased could do that. He was the one who freed him and the one for whom the wala' was confirmed. That is not to be borne by another's property unless he bequeaths within the third of his property what remains of a lave to be freed. That is a request against his partners and inheritors and the partners must not refuse the slave that when it is within the third of the dead man's property because there is no harm in that to the inheritors."

Malik said, "If a man frees a third of his slave while he is critically ill, he must complete the emancipation so all of him is free from him, if it is within the third of his property that he has access to, because he is not treated in the same way as a man who frees a third of a slave after his death, because had the one who freed a third of his slave after his death lived, he could have cancelled it and the slave's being set free would be of no effect. The master who made the freeing of the third of the slave irrevocable in his illness, would still have to free all of him if he lived. If he died, the slave would be set free within the third of the bequest. That is because the command of the deceased is permissible in his third as the command of the healthy is permissible in all his property."


Malik :: Setting Free and Wala' :: [38-38.2.2]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.2.2

Malik said, "A master who frees a slave of his and settles his emancipation so that his testimony is permitted, his inviolability complete, and his right to inherit confirmed, cannot impose stipulations on him like what he imposes on a slave about property or service, nor get him to do anything of slavery, because the Messenger of Allah, may Allah bless him and grant him peace, said, "If a man frees his share of a slave and has enough money to cover the full price of the slave justly evaluated for him, he must give his partners their shares so the slave is completely free."

Malik commented, "If he owns the slave completely, it is more proper to free him completely and not mingle any slavery with it."


Malik :: Setting Free and Wala' :: [38-38.3.3]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.3.3

Malik related to me from Yahya ibn Said and somebody else from al-Hasan ibn Abi al-Hasan al-Basri and from Muhammad ibn Sirin that a man in the time of the Messenger of Allah, may Allah bless him and grant him peace, freed six of his slaves while he was dying. The Messenger of Allah, may Allah bless him and grant him peace, drew lots between them and freed a third of those slaves.

Malik added that he had heard that the man did not have any property other than them.


Malik :: Setting Free and Wala' :: [38-38.3.4]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.3.4

Malik related to me from Rabia ibn Abi Abd ar-Rahman that a man in the time of Aban ibn Uthman's amirate freed all of his slaves and did not have other property than them. Aban ibn Uthman took charge of the slaves and they were divided into three groups. Then he drew lots on the basis that which ever group drew the dead man's arrow would be free. The arrow fell to one of the thirds, and that third was freed.


Malik :: Setting Free and Wala' :: [38-38.4.5]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.4.5

Malik related to me that he heard Ibn Shihab say, "The precedent of the sunna is that when a slave is freed, his property follows him."

Malik said, "One thing which makes clear that the property of a slave follows him when he is freed is that when the contract (mukatab) is written for his freedom, his property follows him even if he did not stipulate it. That is because the bond of kitaba is the bond of wala' when it is complete. The property of a slave and a mukatab is not treated in the same way as any children they may have. Their children are only treated in the same way as their own slaves, not in the same way as their property. This is because the sunna, in which there is no dispute, is that when a slave is freed, his property follows him and his children do not follow him, and when a mukatab writes the contract for his freedom, his property follows him and his children do not follow him."

Malik said, "One thing which makes that clear is that when a slave or a mukatab are bankrupt, their property is taken but the mothers of their children and their children are not taken because they are not their property."

Malik said, "Another thing which makes it clear is that when a slave is sold and the person who buys him stipulates the inclusions of his property, his children are not included in his property."

Malik said, "Another thing which makes it clear is that when a slave does injure some one, he and his property are taken, and his children are not taken."


Malik :: Setting Free and Wala' :: [38-38.5.6]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.5.6

Malik related to me from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab said, "If a slave-girl gives birth to a child by her master, he must not sell her, give her away, or bequeath her. He enjoys her and when he dies she is free ."


Malik :: Setting Free and Wala' :: [38-38.5.7]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.5.7

Malik related to me that he had heard that a slave-girl came to Umar ibn al-Khattab (who had been beaten by her master with a red hot iron) and he set her free.

Malik said, "The generally agreed-on way of doing things among us is that a man is not permitted to be freed while he has a debt against him which exceeds his property. A boy is not allowed to be set free until he has reached puberty. The young person whose affairs are managed cannot set free in his property, even when he reaches puberty, until he manages his property."


Malik :: Setting Free and Wala' :: [38-38.6.8]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.6.8

Malik related to me from Hilal ibn Usama from Ata ibn Yasar that Umar ibn al-Hakam said, "I went to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, a slave girl of mine was tending my sheep. I came to her and one of the sheep was lost. I asked her about it and she said that a wolf had eaten it, so I became angry and I am one of the children of Adam, so I struck her on the face. As it happens, I have to set a slave free, shall I free her?' The Messenger of Allah, may Allah bless him and grant him peace, questioned her, 'Where is Allah?' She said, 'In heaven.' He said, 'Who am I?' She said, 'You are the Messenger of Allah.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Free her.' "


Malik :: Setting Free and Wala' :: [38-38.6.9]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.6.9

Malik related to me from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud that one of the Ansar came to the Messenger of Allah, may Allah bless him and grant him peace, with a black slave-girl of his. He said, "Messenger of Allah, I must set a slave free who is a mumina. If you think that she is mumina, I will free her." The Messenger of Allah, may Allah bless him and grant him peace, questioned her, "Do you testify that there is no god but Allah?" She said, "Yes." "Do you testify that Muhammad is the Messenger of Allah?" She said, "Yes." "Are you certain about the rising after death?" She said, "Yes." The Messenger of Allah, may Allah bless him and grant him peace, said, "Free her."


Malik :: Setting Free and Wala' :: [38-38.6.10]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.6.10

Malik related to me that he had heard that al-Maqburi said that Abu Hurayra was asked whether a man who had to free a slave, could free an illegitimate child to fulfil that obligation. Abu Hurayra said, "Yes. That will give satisfaction for him."


Malik :: Setting Free and Wala' :: [38-38.6.11]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.6.11

Malik related to me that he had heard that Fadala ibn Ubayd al-Ansari who was one of the companions of the Messenger of Allah, may Allah bless him and grant him peace, was asked whether it was permissible for a man who had to free a slave to free an illegitimate child. He said, "Yes, That will give satisfaction for him."


Malik :: Setting Free and Wala' :: [38-38.7.12]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.7.12

Malik related to me that he had heard that Abdullah ibn Umar was asked whether a slave could be bought on the specific condition that it was to be used to fulfil the obligation of freeing a slave, and he said, "No."

Malik said, "That is the best of what I have heard on the obligation of freeing slaves. Someone who has to set a slave free because of an obligation on him, may not buy one on the condition that he sets it free because if he does that, whatever he buys is not completely a slave because he has reduced its price by the condition he has made of setting it free."

Malik added, "There is no harm, however, in someone buying a person expressly to set him free."

Malik said, "The best of what I have heard on the obligation of freeing slaves is that it is not permitted to free a christian or a jew to fulfil it, and one does not free a mukatab or a mudabbar or an umm walad or a slave to be freed after a certain number of years, or a blind person. There is no harm in freeing a christian, jew, or magian voluntarily, because Allah, the Blessed, the Exalted, said in His Book, 'either as a favour then or by ransom,' (Sura 47 ayat 4) The favour is setting free."

Malik said, "As for obligations of freeing slaves which Allah has mentioned in the Book, one only frees a mumin slave for them."

Malik said, "It is like that in feeding poor people for kaffara. One must only feed muslims and one does not feed anyone outside of the deen of Islam."


Malik :: Setting Free and Wala' :: [38-38.8.13]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.8.13

13 Malik related to me from Abd ar-Rahman ibn Abi Amra al-Ansari that his mother had wanted to make a bequest, but she delayed until morning and died. She had intended to set someone free, so Abd ar-Rahman said, 'I said to al-Qasim ibn Muhammad, 'Will it help her if I free a slave for her?' Al-Qasim replied, 'Sad ibn Ubada said to the Messenger of Allah, may Allah bless him and grant him peace, 'My mother died, will it help her if I set a slave free for her?' The Messenger of Allah, may Allah bless him and grant him peace, said "Yes." "'


Malik :: Setting Free and Wala' :: [38-38.8.14]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.8.14

Malik related to me that Yahya ibn Said said, ''Abd ar-Rahman ibn Abi Bakr died in his sleep, and A'isha, the wife of the Prophet, may Allah bless him and grant him peace, set free many slaves for him." Malik said, "This is what I like best of what I have heard on the subject."


Malik :: Setting Free and Wala' :: [38-38.9.15]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.9.15

Malik related to me from Hisham ibn Urwa from his father from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, was asked what was the most excellent kind of slave to free. The Messenger of Allah, May Allah bless him and grant him peace, answered, "The most expensive and the most valuable to his master."


Malik :: Setting Free and Wala' :: [38-38.9.16]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.9.16

Malik related to me from Nafi that Abdullah ibn Umar freed an illegitimate child and its mother.


Malik :: Setting Free and Wala' :: [38-38.10.17]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.10.17

Malik related to me from Hisham ibn Urwa from his father that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "Barira came to me and said, 'I have written myself as mukatab for my people for nine uqiyas, one uqiya per year, so help me.' A'isha said, 'If your people agree that I pay it all to them for you, and that if I pay it, your wala' is mine, then I will do it.' Barira went to her masters and told them that and they didn't agree. She came back from her masters while the Messenger of Allah, may Allah bless him and grant him peace, was sitting. She said to A'isha, 'I offered that to them and they refused me unless they had the wala'.' The Messenger of Allah, may Allah bless him and grant him peace, heard that and asked her about it A'isha told him and the Messenger of Allah, may Allah bless him and grant him peace, said, 'Take her and stipulate that the wala' is yours, for the wala' is for the one who sets free.' So A'isha did that and then the Messenger of Allah, may Allah bless him and grant him peace, stood up in front of the people, and praised Allah and gave thanks to Him. Then he said, 'What is wrong with the people who make conditions which are not in the Book of Allah? Any condition which is not in the Book of Allah is invalid even if it is a hundred conditions. The decree of Allah is truer and the conditions of Allah are firmer, and the wala' only belongs to the one who sets free.' "


Malik :: Setting Free and Wala' :: [38-38.10.18]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.10.18

Malik related to me from Nafi from Abdullah ibn Umar that A'isha umm al-muminin wanted to buy a slave-girl and set her free. Her people said, "We will sell her to you provided that her wala' is ours." She mentioned that to the Messenger of Allah, may Allah bless him and grant him peace, and he said, "Don't let that hinder you, for the wala' only belongs to the one who sets free."


Malik :: Setting Free and Wala' :: [38-38.10.19]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.10.19

Malik related to me from Yahya ibn Said from Amra bint Abd ar-Rahman that Barira came asking the help of A'isha, umm al-muminin. A'isha said, "If your masters agree that I pay them your price in one lump sum and set you free I will do it." Barira mentioned that to her masters and they said, "No, not unless your wala' is ours." Yahya ibn Said added that Amra bint Abd ar-Rahman claimed that A'isha mentioned that to the Messenger of Allah, may Allah bless him and grant him peace, and the Messenger of Allah, may Allah bless him and grant him peace said, "Buy her and set her free. The wala' only belongs to the one who sets free."


Malik :: Setting Free and Wala' :: [38-38.10.20]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.10.20

Malik related to me from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, forbade selling or giving away the wala'.

Malik said that it was not permissible for a slave to buy himself from his master on the provision that he could give the wala' to whomever he wished as the wala' was for the one who set him free, and that had a man given permission to his mawla to give the wala' to whomever he wished, that would not have been permitted, because the Messenger of Allah, may Allah bless him and grant him peace, had said, "The wala' is for the one who sets free. " The Messenger of Allah, may Allah bless him and grant him peace, forbade selling or giving away the wala'. For if it was permitted to the master to stipulate that for him and to give him permission to give the wala' to whomever he liked, that would be a gift.


Malik :: Setting Free and Wala' :: [38-38.11.21]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.11.21

Malik related to me from Rabia ibn Abd ar-Rahman that az-Zubayr ibn al-Awwam bought a slave and set him free. The slave had children by a free woman. When az-Zubayr freed him, he said, "They are my mawali." The man argued, "They are the mawali of their mother. Rather, they are our mawali." They took the dispute to Uthman ibn Affan, and Uthman gave a judgement that az-Zubayr had their wala'.

Malik related to me that he had heard that Said ibn al-Musayyab was asked who had the wala' of the children whom a slave had by a free woman. Said said, "If their father dies and he is a slave who was not set free, their wala' belongs to the mawali of their mother."

Malik said, "That is like the child of a woman who is a mawla who has been divorced by lian; the child is attached to the mawali of his mother and they are his mawali. If he dies, they inherit from him. If he commits a crime, they pay the blood-money for him. If his father acknowledges him, he is given a kinship to him and his wala' goes to the mawali of his father. They are his heirs, they pay his blood-money and his father is punished with the hadd-punishment."

Malik said, "It is like that with a free-born woman divorced by lian. If her husband who curses her by lian does not acknowledge her child, the child is dealt with in the same way except that the rest of his inheritance after the inheritance of his mother and his brothers from his mother goes to all the muslims as long as he was not given kinship to his father. The child of the lian is attached to the patronage of the mawali of his mother until his father acknowledges him because he does not have a lineage or paternal relations. If his lineage is confirmed, it goes to his paternal relations."

Malik said, "The generally agreed-on way of doing things among us about a child of a slave by a free woman, while the father of the slave is free, is that the grandfather (the father of the slave), attracts the wala' of his son's free children by a free woman. They leave their inheritance to him as long as their father is a slave. If the father becomes free, the wala' returns to his mawali. If he dies and he is still a slave, the inheritance and the wala' go to the grandfather. If the slave has two free sons, and one of them dies while the father is still a slave, the grandfather, the father of the father, attracts the wala' and the inheritance."

Malik spoke about a slave-girl who was set free while she was pregnant and her husband was a slave and then her husband became free before she gave birth, or after she gave birth. He said, "The wala' of what is in her womb goes to the person who set the mother free because slavery touched the child before the mother was set free. It is not treated in the same way as a child conceived by its mother after she has been set free because the wala' of such a child, is attracted by the father when he is set free."

Malik said that if a slave asked his master's permission to free a slave of his and his master gave permission, the wala' of the freed slave went to the master of his master, and his wala' did not return to the master who had set him free, even if he were to become free himself."


Malik :: Setting Free and Wala' :: [38-38.12.22]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.12.22

Malik related to me from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from Abd al-Malik ibn Abi Bakr ibn Abd ar-Rahman ibn al-Harith ibn Hisham that his father told him that al-Asi ibn Hisham had died and left three sons, two by one wife and one by another wife. One of the two with the same mother died and left property and mawali. His full brother inherited his property and the wala' of his mawali. Then he also died, and left as heirs his son and his paternal half brother. His son said, "I obtain what my father inherited of property and the wala' of the mawali." His brother said, "It is not like that. You obtain the property. As for the wala' of the mawali, it is not so. Do you think that had it been my first brother who died today, I would not have inherited from him?" They argued and went to Uthman ibn Affan. He gave a judgement that the brother had the wala' of the mawali.


Malik :: Setting Free and Wala' :: [38-38.12.23]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.12.23

Malik related to me from Abdullah ibn Abi Bakr ibn Hazm that his father told him that he was sitting with Aban ibn Uthman, and an argument was brought to him between some people from the Juhayna tribe and some people from the Banu al-Harith ibn al-Khazraj. A woman of the Juhayna tribe was married to a man from the Banu al-Harith ibn al-Khazraj, called Ibrahim ibn Kulayb. She died and left property and mawali, and her son and husband inherited them from her. Then her son died and his heirs said, "We have the wala' of the mawali. Her son obtained them." Those of the Juhayna said, "It is not like that. They are the mawali of our female associate. When her child died, we have their wala' and we inherit them." Aban ibn Uthman gave a judgement that the people from the Juhayna tribe did indeed have the wala' of the mawali.


Malik :: Setting Free and Wala' :: [38-38.12.24]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.12.24

Malik related to me that he had heard that Said ibn al-Musayyab spoke about a man who died and left three sons and left mawali whom he had freed. Then two of his sons died and left children. He said, "The third remaining son inherits the mawali. When he dies, his children and the children of his brothers share equally in the wala' of the mawali."


Malik :: Setting Free and Wala' :: [38-38.13.25]

Setting Free and Wala'

Malik :: Book 38 : Hadith 38.13.25

Malik related to me that he had asked Ibn Shihab about a slave who was released. He said, "He gives his wala' to whomever he likes. If he dies and has not given his wala' to anyone, his inheritance goes to the muslims and his blood-money is paid by them."

Malik said, "The best of what has been heard about a slave who is released is that no one gets his wala', and his inheritance goes to the muslims, and they pay his blood-money."

Malik said that when the slave of a jew or christian became muslim and he was freed before being sold, the wala' of the freed slave went to the muslims. If the jew or christian became muslim afterwards, the wala' did not revert to him. "

He said, "However, if a jew or christian frees a slave from their own deen, and then the freed one becomes muslim before the jew or christian who freed him becomes muslim and then the one who freed him has become muslim, his wala' reverts to him because the wala' was confirmed for him on the day he freed him."

Malik said that the muslim child of a jew or christian inherited the mawali of his jewish or christian father when the freed mawla became muslim before the one who freed him became muslim. If the freed one was already muslim when he was freed, the muslim children of the christian or jew had nothing of the wala' of a muslim slave because the jew and the christian did not have the wala'. The wala' of a muslim slave went to the community of muslims.


Malik :: The Mukatab :: [39-39.1.1]

The Mukatab

Malik :: Book 39 : Hadith 39.1.1

Malik related to me from Nafi that Abdullah ibn Umar said, "A mukatab is a slave as long as any of his kitaba remains to be paid."


Malik :: The Mukatab :: [39-39.1.2]

The Mukatab

Malik :: Book 39 : Hadith 39.1.2

Malik related to me that he had heard that Urwa ibn az-Zubayr and Sulayman ibn Yasar said, "The mukatab is a slave as long as any of his kitaba remains to be paid."

Malik said, "This is my opinion as well."

Malik said, "If a mukatab dies and leaves more property than what remains to be paid of his kitaba and he has children who were born during the time of his kitaba or whose kitaba has been written as well, they inherit any property that remains after the kitaba has been paid."


Malik :: The Mukatab :: [39-39.1.3]

The Mukatab

Malik :: Book 39 : Hadith 39.1.3

Malik related to me from Humayd ibn Qays al-Makki that a son of al-Mutawakkil had a mukatab who died at Makka and left (enough to pay) the rest of his kitaba and he owed some debts to people. He also left a daughter. The governor of Makka was not certain about how to judge in the case, so he wrote to Abd al-Malik ibn Marwan to ask him about it. Abd al-Malik wrote to him, "Begin with the debts owed to people, and then pay what remains of his kitaba. Then divide what remains of the property between the daughter and the master."

Malik said, "What is done among us is that the master of a slave does not have to give his slave a kitaba if he asks for it. I have not heard of any of the Imams forcing a man to give a kitaba to his slave. I heard that one of the people of knowledge, when someone asked about that and mentioned that Allah the Blessed, the Exalted, said, 'Give them their kitaba, if you know some good in them' (Sura 24 ayat 33) recited these two ayats, 'When you are free of the state of ihram, then hunt for game.' (Sura 5 ayat 3) 'When the prayer is finished, scatter in the land and seek Allah's favour.' " (Sura 62 ayat 10)

Malik commented, "It is a way of doing things for which Allah, the Mighty, the Majestic, has given permission to people, and it is not obligatory for them." Malik said, "I heard one of the people of knowledge say about the word of Allah, the Blessed, the Exalted, 'Give them of the wealth which Allah has given you,' that it meant that a man give his slave a kitaba and then reduce the end of his kitaba for him by some specific amount."

Malik said, "This is what I have heard from the people of knowledge and what I see people doing here."

Malik said, "I have heard that Abdullah ibn Umar gave one of his slaves his kitaba for 35,000 dirhams, and then reduced the end of his kitaba by 5,000 dirhams."

Malik said, "What is done among us is that when a master gives a mukatab his kitaba, the mukatab's property goes with him but his children do not go with him unless he stipulates that in his kitaba."

Yahya said, "I heard Malik say that if a mukatab whose master had given him a kitaba had a slave-girl who was pregnant by him, and neither he nor his master knew that on the day he was given his kitaba, the child did not follow him because he was not included in the kitaba. He belonged to the master. As for the slave-girl, she belonged to the mukatab because she was his property."

Malik said that if a man and his wife's son (by another husband) inherited a mukatab from the wife and the mukatab died before he had completed his kitaba, they divided his inheritance between them according to the Book of Allah. If the slave paid his kitaba and then died, his inheritance went to the son of the woman, and the husband had nothing of his inheritance.

Malik said that if a mukatab gave his own slave a kitaba, the situation was looked at. If he wanted to do his slave a favour and it was obvious by his making it easy for him, that was not permitted. If he was giving him a kitaba from desire to find money to pay off his own kitaba, that was permitted for him.

Malik said that if a man had intercourse with a mukataba of his and she became pregnant by him, she had an option. If she liked she could be an umm walad. If she wished, she could confirm her kitaba. If she did not conceive, she still had her kitaba.

Malik said, "The generally agreed on way of doing things among us about a slave who is owned by two men is that one of them does not give a kitaba for his share, whether or not his companion gives him permission to do so, unless they both write the kitaba together, because that alone would effect setting him free. If the slave were to fulfil what he had agreed on to free half of himself, and then the one who had given a kitaba for half of him was not obliged to complete his setting free, that would be in opposition to the words of the Messenger of Allah, may Allah bless him and grant him peace. 'If someone frees his share in a slave and has enough money to cover the full price of the slave, justly evaluated for him, he must give his partners their shares, so the slave is completely free . ' "

Malik said, "If he is not aware of that until the mukatab has met the terms or before he has met them the owner who has written him the kitaba returns what he has taken from the mukatab to him, and then he and his partner divide him according to their original shares and the kitaba is invalid. He is the slave of both of them in his original state."

Malik spoke about a mukatab who was owned by two men and one of them granted him a delay in the payment of the right which he was owed, and the other refused to defer it, and so the one who refused to defer the payment exacted his part of the due. Malik said that if the mukatab then died and left property which did not complete his kitaba, "They divide it according to what they are still owed by him. Each of them takes according to his share. If the mukatab leaves more than his kitaba, each of them takes what remains to them of the kitaba, and what remains after that is divided equally between them. If the mukatab is unable to pay his kitaba fully and the one who did not allow him to defer his payment has exacted more than his associate did, the slave is still divided equally between them, and he does not return to his associates the excess of what he has exacted, because he only exacted his right with the permission of his associate. If one of them remits what is owed to him and then his associate exacts part of what he is owed by him and then the mukatab is unable to pay, he belongs to both of them. And the one who has exacted something does not return anything because he only demanded what he was owed. That is like the debt of two men in one writing against one man. One of them grants him time to pay and the other is greedy and exacts his due. Then the debtor goes bankrupt. The one who exacted his due does not have to return any of what he took."


Malik :: The Mukatab :: [39-39.2.4]

The Mukatab

Malik :: Book 39 : Hadith 39.2.4

Malik said, "The generally agreed on way of doing things among us is that when slaves write their kitaba together in one kitaba, and some are responsible for others, and they are not reduced anything by the death of one of the responsible ones, and then one of them says, 'I can't do it,' and gives up, his companions can use him in whatever work he can do and they help each other with that in their kitaba until they are freed, if they are freed, or remain slaves if they remain slaves."

Malik said, "The generally agreed on way of doing things among us is that when a master gives a slave his kitaba, it is not permitted for the master to let anyone assume the responsibility for the kitaba of his slave if the slave dies or is incapable. This is not part of the sunna of the muslims. That is because when a man assumes responsibility to the master of a mukatab for what the mukatab owes of his kitaba, and then the master of the mukatab pursues that from the one who assumes the responsibility, he takes his money falsely. It is not as if he is buying the mukatab, so that what he gives is part of the price of something that is his, and neither is the mukatab being freed so that the price established for him buys his inviolability as a free man. If the mukatab is unable to meet the payments he reverts to his master and is his slave. That is because kitaba is not a fixed debt which can be assumed by the master of the mukatab. It is something which, when it is paid by the mukatab, sets him free. If the mukatab dies and has a debt, his master is not one of the creditors for what remains unpaid of the kitaba. The creditors have precedence over the master. If the mukatab cannot meet the payments, and he owes debts to people, he reverts to being a slave owned by his master and the debts to the people are the liability of the mukatab. The creditors do not enter with the master into any share of the price of his person."

Malik said, "When people are written together in one kitaba and there is no kinship between them by which they inherit from each other, and some of them are responsible for others, then none of them are freed before the others until all the kitaba has been paid. If one of them dies and leaves property and it is more than all of what is against them, it pays all that is against them . The excess of the property goes to the master, and none of those who have been written in the kitaba with the deceased have any of the excess. The master's claims are overshadowed by their claims for the portions which remain against them of the kitaba which can be fulfilled from the property of the deceased, because the deceased had assumed their responsibility and they must use his property to pay for their freedom. If the deceased mukatab has a free child not born in kitaba and who was not written in the kitaba, it does not inherit from him because the mukatab was not freed until he died."


Malik :: The Mukatab :: [39-39.3.5]

The Mukatab

Malik :: Book 39 : Hadith 39.3.5

Malik related to me that he heard that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, made a settlement with her mukatab for an agreed amount of gold and silver.

Malik said, "The generally agreed on way of doing things among us in the case of a mukatab who is shared by two partners, is that one of them cannot make a settlement with him for an agreed price according to his portion without the consent of his partner. That is because the slave and his property are owned by both of them, and so one of them is not permitted to take any of the property except with the consent of his partner. If one of them settled with the mukatab and his partner did not, and he took the agreed price, and then the mukatab died while he had property or was unable to pay, the one who settled would not have anything of the mukatab's property and he could not return that for which he made settlement so that his right to the slave's person would return to him. However, when someone settles with a mukatab with the permission of his partner and then the mukatab is unable to pay, it is preferable that the one who broke with him return what he has taken from the mukatab for the severance and he can have back his portion of the mukatab. He can do that. If the mukatab dies and leaves property, the partner who has kept hold of the kitaba is paid in full the amount of the kitaba which remains to him against the mukatab from the mukatab's property. Then what remains of property of the mukatab is between the partner who broke with him and his partner, according to their shares in the mukatab. If one of the partners breaks off with him and the other keeps the kitaba, and the mukatab is unable to pay, it is said to the partner who settled with him, 'If you wish to give your partner half of what you took so the slave is divided between you, then do so. If you refuse, then all of the slave belongs to the one who held on to possession of the slave.' "

Malik spoke about a mukatab who was shared between two men and one of them made a settlement with him with the permission of his partner. Then the one who retained possession of the slave demanded the like of that for which his partner had settled or more than that and the mukatab could not pay it. He said, "The mukatab is shared between them because the man has only demanded what is owed to him. If he demands less than what the one who settled with him took and the mukatab can not manage that, and the one who settled with him prefers to return to his partner half of what he took so the slave is divided in halves between them, he can do that. If he refuses then all of the slave belongs to the one who did not settle with him. If the mukatab dies and leaves property, and the one who settled with him prefers to return to his companion half of what he has taken so the inheritance is divided between them, he can do that. If the one who has kept the kitaba takes the like of what the one who has settled with him took, or more, the inheritance is between them according to their shares in the slave because he is only taking his right."

Malik spoke about a mukatab who was shared between two men and one of them made a settlement with him for half of what was due to him with the permission of his partner, and then the one who retained possession of the slave took less than what his partner settled with him for and the mukatab was unable to pay. He said, "If the one who made a settlement with the slave prefers to return half of what he was awarded to his partner, the slave is divided between them. If he refuses to return it, the one who retained possession has the portion of the share for which his partner made a settlement with the mukatab."

Malik said, "The explanation of that is that the slave is divided in two halves between them. They write him a kitaba together and then one of them makes a settlement with the mukatab for half his due with the permission of his partner. That is a fourth of all the slave. Then the mukatab is unable to continue, so it is said to the one who settled with him, 'If you wish, return to your partner half of what you were awarded and the slave is divided equally between you.' If he refuses, the one who held to the kitaba takes in full the fourth of his partner for which he made settlement with the mukatab. He had half the slave, so that now gives him three-fourths of the slave. The one who broke off has a fourth of the slave because he refused to return the equivalent of the fourth share for which he settled."

Malik spoke about a mukatab whose master made a settlement with him and set him free and what remained of his severance was written against him as debt, then the mukatab died and people had debts against him. He said, "His master does not share with the creditors because of what he is owed from the severance. The creditors begin first."

Malik said, "A mukatab cannot break with his master when he owes debts to people. He would be set free and have nothing because the people who hold the debts are more entitled to his property than his master. That is not permitted for him."

Malik said, "According to the way things are done among us, there is no harm if a man gives a kitaba to his slave and settles with him for gold and reduces what he is owed of the kitaba provided that only the gold is paid immediately. Whoever disapproves of that does so because he puts it in the category of a debt which a man has against another man for a set term. He gives him a reduction and he pays it immediately. This is not like that debt. The breaking of the mukatab with his master is dependent on his giving money to speed up the setting free. Inheritance, testimony and the hudud are obliged for him and the inviolability of being set free is established for him. He is not buying dirhams for dirhams or gold for gold. Rather it is like a man who having said to his slave, 'Bring me such-and-such an amount of dinars and you are free', then reduces that for him, saying, 'If you bring me less than that, you are free.' That is not a fixed debt. Had it been a fixed debt, the master would have shared with the creditors of the mukatab when he died or went bankrupt. His claim on the property of the mukatab would join theirs."


Malik :: The Mukatab :: [39-39.4.6]

The Mukatab

Malik :: Book 39 : Hadith 39.4.6

Malik said, "The best of what I have heard about a mukatab who injures a man so that blood-money must be paid, is that if the mukatab can pay the blood-money for the injury with his kitaba, he does so, and it is against his kitaba. If he cannot do that, and he cannot pay his kitaba because he must pay the blood-money of that injury before the kitaba, and he cannot pay the blood-money of that injury, then his master has an option. If he prefers to pay the blood-money of that injury, he does so and keeps his slave and he becomes an owned slave. If he wishes to surrender the slave to the injured, he surrenders him. The master does not have to do more than surrender his slave."

Malik spoke about people who were in a general kitaba and one of them caused an injury which entailed blood-money. He said, "If any of them does an injury involving blood-money, he and those who are with him in the kitaba are asked to pay all the blood-money of that injury. If they pay, they are confirmed in their kitaba. If they do not pay, and they are incapable then their master has an option. If he wishes, he can pay all the blood-money of that injury and all the slaves revert to him. If he wishes, he can surrender the one who did the injury alone and all the others revert to being his slaves since they could not pay the blood-money of the injury which their companion caused."

Malik said, "The way of doing things about which there is no dispute among us, is that when a mukatab is injured in some way which entails blood-money or one of the mukatab's children who is written with him in the kitaba is injured, their blood-money is the blood-money of slaves of their value, and what is appointed to them as their blood-money is paid to the master who has the kitaba and he reckons that for the mukatab at the end of his kitaba and there is a reduction for the blood-money that the master has taken for the injury."

Malik said, "The explanation of that is say, for example, he has written his kitaba for three thousand dirhams and the blood-money taken by the master for his injury is one thousand dirhams. When the mukatab has paid his master two thousand dirhams he is free. If what remains of his kitaba is one thousand dirhams and the blood-money for his injury is one thousand dirhams, he is free straightaway. If the blood-money of the injury is more than what remains of the kitaba, the master of the mukatab takes what remains of his kitaba and frees him. What remains after the payment of the kitaba belongs to the mukatab. One must not pay the mukatab any of the blood-money of his injury in case he might consume it and use it up. If he could not pay his kitaba completely he would then return to his master one eyed, with a hand cut off, or crippled in body. His master only wrote his kitaba against his property and earnings, and he did not write his kitaba so that he would take the blood-money for what happened to his child or to himself and use it up and consume it. One pays the blood-money of injuries to a mukatab and his children who are born in his kitaba, or their kitaba is written, to the master and he takes it into account for him at the end of his kitaba."


Malik :: The Mukatab :: [39-39.5.7]

The Mukatab

Malik :: Book 39 : Hadith 39.5.7

Malik said, "The best of what is said about a man who buys the mukatab of a man is that if the man wrote the slave's kitaba for dinars or dirhams, he does not sell him unless it is for merchandise which is paid immediately and not deferred, because if it is deferred, it would be a debt for a debt. A debt for a debt is forbidden."

He said, "If the master gives a mukatab his kitaba for certain merchandise of camels, cattle, sheep, or slaves, it is more correct that the buyer buy him for gold, silver, or different goods than the ones his master wrote the kitaba for, and that must be paid immediately, not deferred."

Malik said, "The best of what I have heard about a mukatab when he is sold is that he is more entitled to buy his kitaba than the one who buys him if he can pay his master the price for which he was sold in cash. That is because his buying himself is his freedom, and freedom has priority over what bequests accompany it. If one of those who have written the kitaba for the mukatab sells his portion of him, so that a half, a third, a fourth, or whatever share of the mukatab is sold, the mukatab does not have the right of pre-emption in what is sold of him. That is because it is like the severance of a partner, and a partner can only make a settlement for a partner of the one who is mukatab with the permission of his partners because what is sold of him does not give him complete rights as a free man and his property is barred from him, and by buying part of himself, it is feared that he will become incapable of completing payment because of what he had to spend. That is not like the mukatab buying himself completely unless whoever has some of the kitaba remaining due to him gives him permission. If they give him permission, he is more entitled to what is sold of him."

Malik said, "Selling one of the instalments of a mukatab is not halal. That is because it Is an uncertain transaction. If the mukatab cannot pay it, what he owes is nullified. If he dies or goes bankrupt and he owes debts to people, then the person who bought his instalment does not take any of his portion with the creditors. The person who buys one of the instalments of the mukatab is in the position of the master of the mukatab. The master of the mukatab does not have a share with the creditors of the mukatab for what he is owed of the kitaba of his slave. It is also like that with the kharaj, (a set amount deducted daily from the slave against his earnings), which accumulates for a master from the earnings of his slave. The creditors of his slave do not allow him a share for what has accumulated for him from those deductions."

Malik said, "There is no harm in a mukatab paying off his kitaba with coin or merchandise other than the merchandise for which he wrote his kitaba if it is identical with it, on time (for the instalment) or delayed. "

Malik said that if a mukatab died and left an umm walad and small children by her or by someone else and they could not work and it was feared that they would be unable to fulfil their kitaba, the umm walad of the father was sold if her price would pay all the kitaba for them, whether or not she was their mother. They were paid for and set free because their father did not forbid her sale if he feared that he would be unable to complete his kitaba. If her price would not pay for them and neither she nor they could work, they all reverted to being slaves of the master.

Malik said, "What is done among us in the case of a person who buys the kitaba of a mukatab, and then the mukatab dies before he has paid his kitaba, is that the person who bought the kitaba inherits from him. If, rather than dying, the mukatab cannot pay, the buyer has his person. If the mukatab pays his kitaba to the person who bought him and he is freed, his wala' goes to the person who wrote the kitaba and the person who bought his kitaba does not have any of it."


Malik :: The Mukatab :: [39-39.6.8]

The Mukatab

Malik :: Book 39 : Hadith 39.6.8

Malik related to me that he heard that Urwa ibn az-Zubayr and Sulayman ibn Yasar when asked whether the sons of a man, who had a kitaba written for himself and his children and then died, worked for the kitaba of their father or were slaves, said, "They work for the kitaba of their father and they have no reduction at all for the death of their father."

Malik said, "If they are small and unable to work, one does not wait for them to grow up and they are slaves of their father's master unless the mukatab has left what will pay their instalments for them until they can work. If there is enough to pay for them in what he has left, that is paid for on their behalf and they are left in their condition until they can work, and then if they pay, they are free. If they cannot do it, they are slaves."

Malik spoke about a mukatab who died and left property which was not enough to pay his kitaba, and he also left a child with him in his kitaba and an umm walad, and the umm walad wanted to work for them. He said, "The money is paid to her if she is trustworthy with it and strong enough to work. If she is not strong enough to work and not trustworthy with property, she is not given any of it and she and the children of the mukatab revert to being slaves of the master of the mukatab."

Malik said, "If people are written together in one kitaba and there is no kinship between them, and some of them are incapable and others work until they are all set free, those who worked can claim from those who were unable, the portion of what they paid for them because some of them assumed the responsibility for others."


Malik :: The Mukatab :: [39-39.7.9]

The Mukatab

Malik :: Book 39 : Hadith 39.7.9

Malik related to me that he heard Rabia ibn Abi Abd ar-Rahman and others mention that al-Furafisa ibn Umar al-Hanafi had a mukatab who offered to pay him all of his kitaba that he owed. Al-Furafisa refused to accept it and the mukatab went to Marwan ibn al-Hakam who was the amir of Madina and brought up the matter. Marwan summoned al-Furafisa and told him to accept. He refused. Marwan then ordered that the payment be taken from the mukatab and placed in the treasury. He said to the mukatab "Go, you are free." When al-Furafisa saw that, he took the money.

Malik said, "What is done among us when a mukatab pays all the instalments he owes before their term, is that it is permitted to him. The master cannot refuse him that. That is because payment removes every condition from the mukatab as well as service and travel. The setting free of a man is not complete while he has any remaining slavery, and neither would his inviolability as a free man be complete and his testimony permitted and inheritance obliged and such things in that situation. His master must not make any stipulation of service on him after he has been set free."

Malik said that it was permitted for a mukatab who became extremely ill and wanted to pay his master all his instalments because his heirs who were free would then inherit from him and he had no children with him in his kitaba, to do so, because by that he completed his inviolability as a free man, his testimony was permitted, and his admission of what he owed of debts to people was permitted. His bequest was permitted as well. His master could not refuse him that by saying, "He is escaping from me with his property."


Malik :: The Mukatab :: [39-39.8.10]

The Mukatab

Malik :: Book 39 : Hadith 39.8.10

Malik related to me that he had heard that Said ibn al-Musayyab was asked about a mukatab who was shared between two men. One of them freed his portion and then the mukatab died and left a lot of money. Said replied, "The one who kept his kitaba is paid what remains due to him, and then they divide what is left between them both equally."

Malik said, "When a mukatab who fulfils his kitaba and becomes free dies, he is inherited from by the people who wrote his kitaba and their children and paternal relations - whoever is most deserving."

He said, "This is also for whoever is set free when he dies after being set free - his inheritance is for the nearest people to him of children or paternal relations who inherit by means of the wala'."

Malik said, "Brothers, written together in the same kitaba, are in the same position as children to each other when none of them have children written in the kitaba or born in the kitaba. When one of them dies and leaves property, he pays for them all that is against them of their kitaba and sets them free. The money left over after that goes to his children rather than his brothers."


Malik :: The Mukatab :: [39-39.9.11]

The Mukatab

Malik :: Book 39 : Hadith 39.9.11

Malik spoke to me about a man who wrote a kitaba for his slave for gold or silver and stipulated against him in his kitaba a journey, service, sacrifice or similar, which he specified by its name, and then the mukatab was able to pay all his instalments before the end of the term.

He said, "If he pays all his instalments and he is set free and his inviolability as a free man is complete, but he still has this condition to fulfil, the condition is examined, and whatever involves his person in it, like service or a journey etc., is removed from him and his master has nothing in it. Whatever there is of sacrifice, clothing, or anything that he must pay, that is in the position of dinars and dirhams, and is valued and he pays it along with his instalments, and he is not free until he has paid that along with his instalments."

Malik said, "The generally agreed-on way of doing things among us about which there is no dispute, is that a mukatab is in the same position as a slave whom his master will free after a service of ten years. If the master who will free him dies before ten years, what remains of his service goes to his heirs and his wala' goes to the one who contracted to free him and to his male children or paternal relations."

Malik spoke about a man who stipulated against his mukatab that he could not travel, marry, or leave his land without his permission, and that if he did so without his permission it was in his power to cancel the kitaba. He said, "If the mukatab does any of these things it is not in the man's power to cancel the kitaba. Let the master put that before the Sultan. The mukatab, however, should not marry, travel, or leave the land of his master without his permission, whether or not he stipulates that. That is because the man may write a kitaba for his slave for 100 dinars and the slave may have 1000 dinars or more than that. He goes off and marries a woman and pays her bride-price which sweeps away his money and then he cannot pay. He reverts to his master as a slave who has no property. Or else he may travel and his instalments fall due while he is away. He cannot do that and kitaba is not to be based on that. That is in the hand of his master. If he wishes, he gives him permission in that. If he wishes, he refuses it."


Malik :: The Mukatab :: [39-39.10.12]

The Mukatab

Malik :: Book 39 : Hadith 39.10.12

Malik said, "When a mukatab sets his own slaves free, it is only permitted for a mukatab to set his own slaves free with the consent of his master. If his master gives his consent and the mukatab sets his slave free, his wala' goes to the mukatab . If the mukatab then dies before he has been set free himself, the wala' of the freed slave goes to the master of the mukatab. If the freed one dies before the mukatab has been set free, the master of the mukatab inherits from him."

Malik said, "It is like that also when a mukatab gives his slave a kitaba and his mukatab is set free before he is himself. The wala' goes to the master of the mukatab as long as he is not free. If this one who wrote the kitaba is set free, then the wala' of his mukatab who was freed before him reverts to him. If the first mukatab dies before he pays, or he cannot pay his kitaba and he has free children, they do not inherit the wala' of their father's mukatab because the wala' has not been established for their father and he does not have the wala' until he is free."

Malik spoke about a mukatab who was shared between two men and one of them forewent what the mukatab owed him and the other insisted on his due. Then the mukatab died and left property.

Malik said, "The one who did not abandon any of what he was owed, is paid in full. Then the property is divided between them both just as if a slave had died because what the first one did was not setting him free. He only abandoned a debt that was owed to him ."

Malik said, "One clarification of that is that when a man dies and leaves a mukatab and he also leaves male and female children and one of the children frees his portion of the mukatab, that does not establish any of the wala' for him. Had it been a true setting free, the wala' would have been established for whichever men and women freed him."

Malik said, "Another clarification of that is that if one of them freed his portion and then the mukatab could not pay, the value of what was left of the mukatab would be altered because of the one who freed his portion. Had it been a true setting-free, his estimated value would have been taken from the property of the one who set free until he had been set completely free as the Messenger of Allah, may Allah bless him and grant him peace, said, 'Whoever frees his share in a slave and has money to cover the full price of the slave, justly evaluated for him, gives his partners their shares. If not, he frees of him what he frees.' " (See Book 37 hadith 1).

He said, "Another clarification of that is that part of the sunna of the muslims in which there is no dispute, is that whoever frees his share of a mukatab, the mukatab is not set fully free using his property. Had he been truly set free, the wala' would have been his alone rather than his partners. Part of what will clarify that also is that part of the sunna of the muslims is that the wala' belongs to whoever writes the contract of kitaba. The women who inherit from the master of the mukatab do not have any of the wala' of the mukatab. If they free any of their share, the wala' belongs to the male children of the master of the mukatab or his male paternal relations."


Malik :: The Mukatab :: [39-39.11.13]

The Mukatab

Malik :: Book 39 : Hadith 39.11.13

Malik said, "If people are together in one kitaba, their master cannot free one of them without consulting his companions who are with him in the kitaba and obtaining their consent. If they are young, however, their consultation means nothing and it is not permitted to them. That is because a man might work for all the people and he might pay their kitaba for them to complete their freedom. Their master approaches the one who will pay for them and their rescue from slavery is through him. He frees him and so makes those who remain unable to pay. He does it intending benefit and increase for himself. It is not permitted for him to do that to those of them who remain. The Messenger of Allah, may Allah bless him and grant him peace, said, 'There must be no harm nor return of harm.' This is the most severe harm."

Malik said about slaves who wrote a kitaba together that it was permitted for their master to free the old and exhausted of them and the young when neither of them could pay anything, and there was no help nor strength to be had from any of them in their kitaba.


Malik :: The Mukatab :: [39-39.11.14]

The Mukatab

Malik :: Book 39 : Hadith 39.11.14

Malik said about a man who had his slave in a kitaba and then the mukatab died and left his umm walad, and there remained for him some of his kitaba to pay and he left what would pay it, "The umm walad is a slave since the mukatab was not freed until he died and he did not leave children that were set free by his paying what remained, so that the umm walad of their father was freed by their being set free."

Malik said about a mukatab who set free a slave of his or gave sadaqa with some of his property and his master did not know that until he had set the mukatab free, "That has been performed by him and the master does not rescind it. If the master of the mukatab knows before he sets the mukatab free, he can reject that and not permit it. If the mukatab is then freed and it becomes in his power to do so, he does not have to free the slave, nor give the sadaqa unless he does it voluntarily from himself."


Malik :: The Mukatab :: [39-39.12.15]

The Mukatab

Malik :: Book 39 : Hadith 39.12.15

Malik said, The best of what I have heard about a mukatab whose master frees him at death, is that the mukatab is valued according to what he would fetch if he were sold. If that value is less than what remains against him of his kitaba, his freedom is taken from the third that the deceased can bequeath. One does not look at the number of dirhams which remain against him in his kitaba. That is because had he been killed, his killer would not be in debt for other than his value on the day he killed him. Had he been injured, the one who injured him would not be liable for other than the blood-money of the injury on the day of his injury. One does not look at how much he has paid of dinars and dirhams of the contract he has written because he is a slave as long as any of his kitaba remains. If what remains in his kitaba is less than his value, only whatever of his kitaba remains owing from him is taken into account in the third of the property of the deceased. That is because the deceased left him what remains of his kitaba and so it becomes a bequest which the deceased made."

Malik said, "The illustration of that is that if the price of the mukatab is one thousand dirhams, and only one hundred dirhams remain of his kitaba, his master leaves him the one hundred dirhams which complete it for him. It is taken into account in the third of his master and by it he becomes free."

Malik said that if a man wrote his slave a kitaba at his death, the value of the slave was estimated. If there was enough to cover the price of the slave in one third of his property, that was permitted for him.

Malik said, "The illustration of that is that the price of the slave is one thousand dinars. His master writes him a kitaba for two hundred dinars at his death. The third of the property of his master is one thousand dinars, so that is permitted for him. It is only a bequest which he makes from one third of his property. If the master has left bequests to people, and there is no surplus in the third after the value of the mukatab, one begins with the mukatab because the kitaba is setting free, and setting free has priority over bequests. When those bequests are paid from the kitaba of the mukatab, they follow it. The heirs of the testator have a choice. If they want to give the people with bequests all their bequests and the kitaba of the mukatab is theirs, they have that. If they refuse and hand over the mukatab and what he owes to the people with bequests they can do that, because the third commences with the mukatab and because all the bequests which he makes are as one."

If the heirs then say, "What our fellow bequeathed was more than one third of his property and he has taken what was not his," Malik said, "His heirs choose. It is said to them, 'Your companion has made the bequests you know about and if you would like to give them to those who are to receive them according to the deceased's bequests, then do so. If not, hand over to the people with bequests one third of the total property of the deceased.' "

Malik continued, "If the heirs surrender the mukatab to the people with bequests, the people with bequests have what he owes of his kitaba. If the mukatab pays what he owes of his kitaba, they take that in their bequests according to their shares. If the mukatab cannot pay, he is a slave of the people with bequests and does not return to the heirs because they gave him up when they made their choice, and because when he was surrendered to the people with bequests, they were liable. If he died, they would not have anything against the heirs. If the mukatab dies before he pays his kitaba and he leaves property which is more than what he owes, his property goes to the people with bequests. If the mukatab pays what he owes, he is free and his wala' returns to the paternal relations of the one who wrote the kitaba for him."

Malik spoke about a mukatab who owed his master ten thousand dirhams in his kitaba, and when he died he remitted one thousand dirhams from it. He said, "The mukatab is valued and his value is taken into consideration. If his value is one thousand dirhams and the reduction is a tenth of the kitaba, that portion of the slave's price is one hundred dirhams. It is a tenth of the price. A tenth of the kitaba is therefore reduced for him. That is converted to a tenth of the price in cash. That is as if he had had all of what he owed reduced for him. Had he done that, only the value of the slave - one thousand dirhams - would have been taken into account in the third of the property of the deceased. If that which he had remitted is half of the kitaba, half the price is taken into account in the third of the property of the deceased. If it is more or less than that, it is according to this reckoning."

Malik said, "When a man reduces the kitaba of his mukatab by one thousand dirhams at his death from a kitaba of ten thousand dirhams, and he does not stipulate whether it is from the beginning or the end of his kitaba, each instalment is reduced for him by one tenth."

Malik said, "If a man remits one thousand dirhams from his mukatab at his death from the beginning or end of his kitaba, and the original basis of the kitaba is three thousand dirhams, the mukatab's cash value is estimated. Then that value is divided. That thousand which is from the beginning of the kitaba is converted into its portion of the price according to its proximity to the term and its precedence and then the thousand which follows the first thousand is according to its precedence also until it comes to its end, and every thousand is paid according to its place in advancing and deferring the term because what is deferred of that is less in respect of its price. Then it is placed in the third of the deceased according to whatever of the price befalls that thousand according to the difference in preference of that, whether it is more or less, then it is according to this reckoning."

Malik spoke about a man who willed a man a fourth of a mukatab or freed a fourth, and then the man died and the mukatab died and left a lot of property, more than he owed. He said, "The heirs of the first master and the one who was willed a fourth of the mukatab are given what they are still owed by the mukatab. Then they divide what is left over, and the one willed a fourth has a third of what is left after the kitaba is paid. The heirs of his master gets two-thirds. That is because the mukatab is a slave as long as any of his kitaba remains to be paid. He is inherited from by the possession of his person."

Malik said about a mukatab whose master freed him at death, "If the third of the deceased will not cover him, he is freed from it according to what the third will cover and his kitaba is decreased according to that. If the mukatab owed five thousand dirhams and his value is two thousand dirhams cash, and the third of the deceased is one thousand dirhams, half of him is freed and half of the kitaba has been reduced for him." Malik said about a man who said in his will, "My slave so-and-so is free and write a kitaba for so-and-so", that the setting free had priority over the kitaba.


Malik :: Hudud :: [40-40.1.1]

Hudud

Malik :: Book 40 : Hadith 40.1.1

Yahya related to me that Malik said, "What is done in our community in the case of a man who makes his slave-girl a mudabbara and she gives birth to children after that, and then the slave-girl dies before the one who gave her a tadbir is that her children are in her position. The conditions which were confirmed for her are confirmed for them. The death of their mother does not harm them. If the one who made her mudabbara dies, they are free if their value is less than one third of his total property."

Malik said, "For every mother by birth as opposed to mother by suckling, her children are in her position. If she is free and she gives birth after she is free, her children are free. If she is a mudabbara or mukataba, or freed after a number of years in service, or part of her is free or pledged or she is an umm walad, each of her children are in the same position as their mother. They are set free when she is set free and they are slaves when she is a slave."

Malik said about the mudabbara given a tadbir while she was pregnant, "Her children are in her position. That is also the position of a man who frees his slave-girl while she is pregnant and does not know that she is pregnant."

Malik said, "The sunna about such women is that their children follow them and are set free by their being set free."

Malik said, "It is the same as if a man had bought a slave-girl while she was pregnant. The slave-girl and what is in her womb belong to the one who bought her whether or not the buyer stipulates that."

Malik continued, "It is not halal for the seller to make an exception about what is in her womb because that is an uncertain transaction. It reduces her price and he does not know if that will reach him or not. That is as if one sold the foetus in the womb of the mother. That is not halal because it is an uncertain transaction ."

Malik said about the mukatab or mudabbar who bought a slave-girl and had intercourse with her and she became pregnant by him and gives birth, "The children of both of them by a slave-girl are in his position. They are set free when he is set free and they are slaves when he is a slave."

Malik said, "When he is set free, the umm walad is part of his property which is surrendered to him when he is set free."


Malik :: Hudud :: [40-40.2.2]

Hudud

Malik :: Book 40 : Hadith 40.2.2

Malik spoke about a mudabbar who said to his master, "Free me immediately and I will give fifty dinars which I will have to pay in instalments." His master said, "Yes. You are free and you must pay fifty dinars, and you will pay me ten dinars every year." The slave was satisfied with this. Then the master dies one, two or three days after that. He said, "The freeing is confirmed and the fifty dinars become a debt against him. His testimony is permitted, his inviolability as a free man is confirmed, as are his inheritance and his liability to the full hudud punishments. The death of his master, however, does not reduce the debt for him at all."

Malik said that if a man who made his slave a mudabbar died and he had some property at hand and some absent property, and in the property at hand there was not enough (in the third he was allowed to bequeath) to cover the value of the mudabbar, the mudabbar was kept there together with this property, and his tax (kharaj) was gathered until the master's absent property was clear. Then if a third of what his master left would cover his value, he was freed with his property and what had gathered of his tax. If there was not enough to cover his value in what his master had left, as much of him was freed as the third would allow, and his property was left in his hands.


Malik :: Hudud :: [40-40.3.3]

Hudud

Malik :: Book 40 : Hadith 40.3.3

Malik said, "The generally agreed-on way of doing things in our community is that any setting-free which a man makes in a bequest that he wills in health or illness can be rescinded by him when he likes and changed when he likes as long as it is not a tadbir. There is no way to rescind a tadbir once he has made it.

"As for every child born to him by a slave-girl who he wills to be set free but he does not make mudabbara, her children are not freed with her when she is freed. That is because her master can change his will when he likes and rescind it when he likes, and being set free is not confirmed for her. She is in the position of a slave-girl whose master says, 'If so-and-so remains with me until I die, she is free.' " (i.e. he does not make a definite contract.)

Malik said, "If she fulfils that, that is hers. If he wishes, before that, he can sell her and her child because he has not entered her child into any condition he has made for her.

"The bequest in setting free is different from the tadbir. The precedent of the sunna makes a distinction between them. Had a bequest been in the position of a tadbir, no testator would be able to change his will and what he mentioned in it of setting free. His property would be tied up and he would not be able to use it."

Malik said about a man who made all his slaves mudabbar while he was well and they were his only property, "If he made some of them mudabbar before the others, one begins with the first until the third of his property is reached. (i.e. their value is matched against the third, and those whose value is covered are free.) If he makes the mall mudabbar in his illness, and says in one statement, 'So-and-so is free. So-and-so is free. So-and-so is free if my death occurs in this illness,' or he makes them all mudabbar in one statement, they are matched against the third and one does not begin with any of them before the others. It is a bequest and they have a third of his property divided between them in shares. Then the third of his property frees each of them according to the extent of his share.

"No single one of them is given preference when that all occurs in his illness."

Malik spoke about a master who made his slave a mudabbar and then he died and the only property he had was the mudabbar slave and the slave had property. He said, "A third of the mudabbar is freed and his property remains in his possession."

Malik said about a mudabbar whose master gave him a kitaba and then the master died and did not leave any property other than him, "A third of him is freed and a third of his kitaba is reduced, and he owes two-thirds."

Malik spoke about a man who freed half of his slave while he was ill and made irrevocable his freeing half of him or all of him, and he had made another slave of his mudabbar before that. He said, "One begins with the slave he made mudabbar before the one he freed while he was ill. That is because the man cannot revoke what he has made mudabbar and cannot follow it with a matter which will rescind it. When this mudabbar is freed, then what remains of the third goes to the one who had half of him freed so as to complete his setting-free entirely in the third of the property of the deceased. If what is left of the third does not cover that, whatever is covered by what is left of the third is freed after the first mudabbar is freed . "


Malik :: Hudud :: [40-40.4.4]

Hudud

Malik :: Book 40 : Hadith 40.4.4

Malik related to me from Nafi that Abdullah ibn Umar made two of his slave-girls mudabbara, and he had intercourse with them while they were mudabbara.


Malik :: Hudud :: [40-40.4.5]

Hudud

Malik :: Book 40 : Hadith 40.4.5

Malik related to me from Yahya ibn Said that Said ibn al-Musayyab used to say, "When a man makes his slave-girl mudabbara, he can have intercourse with her. He cannot sell her or give her away and her children are in the same position as her."


Malik :: Hudud :: [40-40.5.6]

Hudud

Malik :: Book 40 : Hadith 40.5.6

Malik said, "The generally agreed on way of doing things in our community about a mudabbar is that the owner cannot sell him or change the position in which he has put him. If a debt overtakes the master, his creditors cannot sell the mudabbar as long as the master is alive. If the master dies and has no debts, the mudabbar is included in the third (of the bequest) because he expected his work from him as long as he lived. He cannot serve him all his life, and then he frees him from his heirs out of the main portion of his property when he dies. If the master of the mudabbar dies and has no property other than him, one third of him is freed, and two thirds of him belong to the heirs. If the master of the mudabbar dies and owes a debt which encompasses the mudabbar, he is sold to meet the debt because he can only be freed in the third (which is allowed for bequest) ."

He said, "If the debt only includes half of the slave, half of him is sold for the debt. Then a third of what remains after the debt is freed. "

Malik said, "It is not permitted to sell a mudabbar and it is not permitted for anyone to buy him unless the mudabbar buys himself from his master. He is permitted to do that. Or else some one gives the master of the mudabbar money and his master who made him a mudabbar frees him. That is also permitted for him."

Malik said, "His wala' belongs to his master who made him a mudabbar."

Malik said, "It is not permitted to sell the service of a mudabbar because it is an uncertain transaction since one does not know how long his master will live. That is uncertain and it is not good."

Malik spoke about a slave who was shared between two men, and one of them made his portion mudabbar. He said, "They estimate his value between them. If the one who made him mudabbar buys him, he is all mudabbar. If he does not buy him, his tadbir is revoked unless the one who retains ownership of him wishes to give his partner who made him mudabbar his value. If he gives him to him for his value, that is binding, and he is all mudabbar."

Malik spoke about the christian man who made a christian slave of his mudabbar and then the slave became muslim. He said, "One separates the master and the slave, and the slave is removed from his christian master and is not sold until his situation becomes clear. If the christian dies and has a debt, his debt is paid from the price of the slave unless he has in his estate what will pay the debt. Then the mudabbar is set free."


Malik :: Hudud :: [40-40.6.7]

Hudud

Malik :: Book 40 : Hadith 40.6.7

Malik related to me that he heard that Umar ibn Abd al-Aziz gave a judgement about the mudabbar who did an injury. He said, "The master must surrender what he owns of him to the injured person. He is made to serve the injured person and recompense (in the form of service) is taken from him as the blood-money of the injury. If he completes that before his master dies, he reverts to his master."

Malik said, "The generally agreed on way of doing things in our community about a mudabbar who does an injury and then his master dies and the master has no property except him is that the third (allowed to be bequeathed) is freed, and then the blood-money for the in jury is divided into thirds. A third of the blood-money is against the third of him which was set free, and two-thirds are against the two-thirds which the heirs have. If they wish, they surrender what they have of him to the party with the injury, and if they wish, they give the injured person two-thirds of the blood-money and keep their portion of the slave. That is because that injury is a criminal action by the slave and it is not a debt against the master by which whatever setting free and tadbir the master had done would be abrogated. If there were a debt to people held against the master of the slave, as well as the criminal action of the slave, part of the mudabbar would be sold in proportion to the blood-money of the injury and according to the debt. Then one would begin with the blood-money which was for the criminal action of the slave and it would be paid from the price of the slave. Then the debt of his master would be paid, and then one would look at what remained after that of the slave. His third would b be set free, and two-thirds of him would belong to the heirs. That is because the criminal action of the slave is more important than the debt of his master. That is because, if the man dies and leaves a mudabbar slave whose value is one hundred and fifty dinars, and the slave strikes a free man on the head with a blow that lays open the skull, and the blood-money is fifty dinars, and the master of the slave has a debt of fifty dinars, one begins with the fifty dinars which are the blood-money of the head wound, and it is paid from the price of the slave. Then the debt of the master is paid. Then one looks at what remains of the slave, and a third of him is set free and two-thirds of him remain for the heirs. The blood-money is more pressing against his person than the debt of his master. The debt of his master is more pressing than the tadbir which is a bequest from the third of the property of the deceased. None of the tadbir is permitted while the master of the mudabbar has a debt which is not paid. It is a bequest. That is because Allah, the Blessed, the Exalted, said, 'After any bequest that is made or any debt.' " (Sura 4 ayat 10)

Malik said, "If there is enough in the third property that the deceased can bequeath to free all the mudabbar, he is freed and the blood-money due from his criminal action is held as a debt against him which follows him after he is set free even if that blood-money is the full blood-money. It is not a debt on the master."

Malik spoke about a mudabbar who injured a man and his master surrendered him to the injured party, and then the master died and had a debt and did not leave any property other than the mudabbar, and the heirs said, "We surrender the mudabbar to the party," whilst the creditor said, "My debt exceeds that." Malik said that if the creditor's debt did exceed that at all , he was more entitled to it and it was taken from the one who owed the debt, according to what the creditor was owed in excess of the blood-money of the injury. If his debt did not exceed it at all, he did not take the slave.

Malik spoke about a mudabbar who did an injury and had property, and his master refused to ransom him. He said, "The injured party takes the property of the mudabbar for the blood-money of his injury. If there is enough to pay it, the injured party is paid in full for the blood-money of his injury and the mudabbar is returned to his master. If there is not enough to pay it, he takes it from the blood-money and uses the mudabbar for what remains of the blood-money."


Malik :: Hudud :: [40-40.7.8]

Hudud

Malik :: Book 40 : Hadith 40.7.8

Malik said in the case of an umm walad who injured someone, "The blood-money of that injury is the responsibility of her master from his property, unless the blood-money of the injury is greater than the value of the umm walad. Her master does not have to pay more than her value. That is because when the master of a slave or slave-girl surrenders his slave or slave-girl for an injury which one of them has done, he does not owe any more than that, even if the blood-money is greater. As the master of the umm walad cannot surrender her because of the precedent of the sunna, when he pays her price, it is as if he had surrendered her. He does not have to pay more than that. This is the best of what I have heard about the matter. The master is not obliged to assume responsibility for more than an umm walad's value because of her criminal action."


Malik :: The Mudabbar :: [41-41.1.1]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.1

Malik related to me from Nafi that Abdullah ibn Umar said, "The Jews came to the Messenger of Allah, may Allah bless him and grant him peace, and mentioned to him that a man and woman from among them had committed adultery. The Messenger of Allah, may Allah bless him and grant him peace, asked them, 'What do you find in the Torah about stoning?' They said, 'We make their wrong action known and flog them.' Abdullah ibn Salam said, 'You have lied! It has stoning for it, so bring the Torah.' They spread it out and one of them placed his hand over the ayat of stoning. Then he read what was before it and what was after it. Abdullah ibn Salam told him to lift his hand. He lifted his hand and there was the ayat of stoning. They said, 'He has spoken the truth, Muhammad. The ayat of stoning is in it.' So the Messenger of Allah, may Allah bless him and grant him peace, gave the order and they were stoned . "

Abdullah ibn Umar added, "I saw the man leaning over the woman to protect her from the stones."

Malik commented, "By leaning he meant throwing himself over her so that the stones fell on him."


Malik :: The Mudabbar :: [41-41.1.2]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.2

Malik related to me from Yahya ibn Said from Said ibn al-Musayyab that a man from the Aslam tribe came to Abu Bakr as-Siddiq and said to him, "I have committed adultery." Abu Bakr said to him, "Have you mentioned this to anyone else?" He said, "No." Abu Bakr said to him, "Then cover it up with the veil of Allah. Allah accepts tawba from his slaves." His self was still unsettled, so he went to Umar ibn al-Khattab. He told him the same as he had said to Abu Bakr, and Umar told him the same as Abu Bakr had said to him. His self was still not settled so he went to the Messenger of Allah, may Allah bless him and grant him peace, and said to him, "I have committed adultery," insistently. The Messenger of Allah, may Allah bless him and grant him peace, turned away from him three times. Each time the Messenger of Allah, may Allah bless him and grant him peace, turned away from him until it became too much. The Messenger of Allah, may Allah bless him and grant him peace, questioned his family, "Does he have an illness which affects his mind, or is he mad?" They said, "Messenger of Allah, by Allah, he is well." The Messenger of Allah, may Allah bless him and grant him peace, said, "Unmarried or married?" They said, "Married, Messenger of Allah." The Messenger of Allah, may Allah bless him and grant him peace, gave the order and he was stoned.


Malik :: The Mudabbar :: [41-41.1.3]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.3

Malik related to me from Yahya ibn Said that Said ibn al-Musayyab said, "I have heard that the Messenger of Allah, may Allah bless him and grant him peace, said to a man from the Aslam tribe called Hazzal, 'Hazzal, had you veiled him with your cloak, it would have been better for you.' "

Yahya ibn Said said, "I related this hadith in an assembly among whom was Yazid ibn Nuaym ibn Hazzal al-Aslami. Yazid said, 'Hazzal was my grandfather. This hadith is true.' "


Malik :: The Mudabbar :: [41-41.1.4]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.4

Malik related to me that Ibn Shihab informed him that a man confessed that he had committed adultery in the time of the Messenger of Allah, may Allah bless him and grant him peace, and he testified against himself four times, so the Messenger of Allah, may Allah bless him and grant him peace, gave the order and he was stoned.

Ibn Shihab said, "Because of this a man is to be taken for his own confession against himself."


Malik :: The Mudabbar :: [41-41.1.5]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.5

Malik related to me from Yaqub ibn Zayd ibn Talha from his father Zayd ibn Talha that Abdullah ibn Abi Mulayka informed him that a woman came to the Messenger of Allah, may Allah bless him and grant him peace, and informed him that she had committed adultery and was pregnant. The Messenger of Allah, may Allah bless him and grant him peace, said to her, "Go away until you give birth." When she had given birth, she came to him. The Messenger of Allah, may Allah bless him and grant him peace, said to her, "Go away until you have suckled and weaned the baby." When she had weaned the baby, she came to him. He said, "Go and entrust the baby to someone." She entrusted the baby to someone and then came to him. He gave the order and she was stoned.


Malik :: The Mudabbar :: [41-41.1.6]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.6

Malik related to me from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Abu Hurayra and Zayd ibn Khalid al-Juhani informed him that two men brought a dispute to the Messenger of Allah, may Allah bless him and grant him peace. One of them said, "Messenger of Allah! Judge between us by the Book of Allah!" The other said, and he was the wiser of the two, "Yes, Messenger of Allah. Judge between us by the Book of Allah and give me permission to speak." He said, "Speak." He said, "My son was hired by this person and he committed fornication with his wife. He told me that my son deserved stoning, and I ransomed him for one hundred sheep and a slave-girl. Then I asked the people of knowledge and they told me that my son deserved to be flogged with one hundred lashes and exiled for a year, and they informed me that the woman deserved to be stoned." The Messenger of Allah, may Allah bless him and grant him peace, said, "By him in whose Hand myself is, I will judge between you by the Book of Allah. As for your sheep and slave girl, they should be returned to you. Your son should have one hundred lashes and be exiled for a year." He ordered Unays al-Aslami to go to the wife of the other man and to stone her if she confessed . She confessed and he stoned her.


Malik :: The Mudabbar :: [41-41.1.7]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.7

Malik related to me from Suhayl ibn Abi Salih from his father from Abu Hurayra that Sad ibn Ubada said to the Messenger of Allah, may Allah bless him and grant him peace, "What do you think I should do if I were to find a man with my wife? Should I leave him there until I had brought four witnesses?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes."


Malik :: The Mudabbar :: [41-41.1.8]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.8

Malik related to me from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud that Abdullah ibn Abbas said, "I heard Umar ibn al-Khattab say, 'Stoning is in the Book of Allah for those who commit adultery, men or women when they are muhsan and when there is clear proof of pregnancy or a confession.' "


Malik :: The Mudabbar :: [41-41.1.9]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.9

Malik related to me from Yahya ibn Said from Sulayman ibn Yasar from Abu Waqid al-Laythi that a man came to Umar ibn al-Khattab while he was in ash-Sham . He mentioned to him that he had found a man with his wife Umar sent Abu Waqid al-Laythi to the wife to question her about that. He came to her while there were women around her and mentioned to her what her husband had mentioned to Umar ibn al-Khattab, and informed her that she would not be punished on his word and began to suggest to her by that, that she should retract. She refused to retract and held firm to confession. Umar gave the order and she was stoned.


Malik :: The Mudabbar :: [41-41.1.10]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.10

Malik related to me that Yahya ibn Said heard Said ibn al-Musayyab say, "When Umar ibn al-Khattab came from Mina, he made his camel kneel at al-Abtah, and then he gathered a pile of small stones and cast his cloak over them and dropped to the ground. Then he raised his hands to the sky and said, 'O Allah! I have become old and my strength has weakened. My flock is scattered. Take me to You with nothing missed out and without having neglected anything.' Then he went to Madina and addressed the people. He said, 'People! Sunan have been laid down for you. Obligations have been placed upon you. You have been left with a clear way unless you lead people astray right and left.' He struck one of his hands on the other and then said, 'Take care lest you destroy the ayat of stoning so that one will say, "We do not find two hadds in the Book of Allah." The Messenger of Allah, may Allah bless him and grant him peace, stoned, so we have stoned. By He in Whose Hand my self is, had it not been that people would say that Umar ibn al-Khattab has added to the Book of Allah ta-ala, we would have written it, "The full-grown man and the full-grown woman, stone them absolutely." We have certainly recited that.'"

Malik said, "Yahya ibn Said said Said ibn al-Musayyab said, 'Dhu'l-Hijja had not passed before Umar was murdered, may Allah have mercy on him.' "

Yahya said that he had heard Malik say, "As for his words 'The full-grown man and the full-grown woman' he meant, 'The man and the woman who have been married, stone them absolutely.' "


Malik :: The Mudabbar :: [41-41.1.11]

The Mudabbar

Malik :: Book 41 : Hadith 41.1.11

Malik related to me that he had heard that Uthman ibn Affan was brought a woman who had given birth after six months and he ordered her to be stoned. Ali ibn Abi Talib said to him, "She does not deserve that. Allah, the Blessed, the Exalted, says in His Book, 'Their carrying and weaning is thirty months,' (Sura 46 ayat 15) and he said, 'Mothers suckle their children for two full years for whoever wishes to complete the suckling.' (Sura 2 ayat 233) Pregnancy can then be six months, so she does not deserve to be stoned." Uthman ibn Affan sent for her and found that she had already been stoned.

Malik related to me that he asked Ibn Shihab about someone who committed sodomy. Ibn Shihab said, "He is to be stoned, whether or not he is muhsan."


Malik :: The Mudabbar :: [41-41.2.12]

The Mudabbar

Malik :: Book 41 : Hadith 41.2.12

Malik related to me from Zayd ibn Aslam that a man confessed to fornication in the time of the Messenger of Allah, may Allah bless him and grant him peace. The Messenger of Allah, may Allah bless him and grant him peace, called for a whip, and he was brought a broken whip. He said, "Above this," and he was brought a new whip whose knots had not been cut yet. He said, "Below this," and he was brought a whip which had been used and made flexible. The Messenger of Allah, may Allah bless him and grant him peace, gave the order and he was flogged. Then he said, "People! The time has come for you to observe the limits of Allah. Whoever has had any of these ugly things befall him should cover them up with the veil of Allah. Whoever reveals to us his wrong action, we perform what is in the Book of Allah against him."


Malik :: The Mudabbar :: [41-41.2.13]

The Mudabbar

Malik :: Book 41 : Hadith 41.2.13

Malik related to me from Nafi that Safiyya bint Abi Ubayd informed him that a man who had had intercourse with a virgin slave-girl and made her pregnant was brought to Abu Bakr as-Siddiq. He confessed to fornication, and he was not muhsan. Abu Bakr gave the order and he was flogged with the hadd punishment. Then he was banished to Fadak, (thirty miles from Madina).

Malik spoke about a person who confessed to fornication and then retracted it and said, "I didn't do it. I said that for such-and-such a reason," and he mentioned the reason. Malik said, "That is accepted from him and the hadd is not imposed on him. That is because the hadd is what is for Allah, and it is only applied by one of two means, either by a clear proof which establishes guilt or by a confession which is persisted in so that the hadd is imposed. If someone persists in his confession, the hadd is imposed on him."

Malik said, "I have not seen the people of knowledge exiling slaves who have committed adultery."


Malik :: The Mudabbar :: [41-41.3.14]

The Mudabbar

Malik :: Book 41 : Hadith 41.3.14

Malik related to me from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Abu Hurayra and Zayd ibn Khalid al-Juhani that the Messenger of Allah, may Allah bless him and grant him peace, was asked about a slave-girl who committed fornication and was not muhsana. He said, "If she commits fornication, then flog her. If she commits fornication again, then flog her, and if she commits fornication again, then sell her, if only for a rope."

Ibn Shihab added, "I don't know whether it was three or four times."


Malik :: The Mudabbar :: [41-41.3.15]

The Mudabbar

Malik :: Book 41 : Hadith 41.3.15

Malik related to me from Nafi that a slave was in charge of the slaves in the khumus and he forced a slave-girl among those slaves against her will and had intercourse with her. Umar ibn al-Khattab had him flogged and banished him, and he did not flog the slave-girl because the slave had forced her.


Malik :: The Mudabbar :: [41-41.3.16]

The Mudabbar

Malik :: Book 41 : Hadith 41.3.16

Malik related to me from Yahya ibn Said that Sulayman ibn Yasar informed him that Abdullah ibn Abbas ibn Abi Rabia al-Makhzumi said, "Umar ibn al-Khattab gave me orders about the slaves of Quraysh and we flogged some of the slave-girls of the muslim lands fifty times each for fornication."


Malik :: The Mudabbar :: [41-41.4.16]

The Mudabbar

Malik :: Book 41 : Hadith 41.4.16

Malik said, "The position with us about a woman who is found to be pregnant and has no husband and she says, 'I was forced,' or she says, 'I was married,' is that it is not accepted from her and the hadd is inflicted on her unless she has a clear proof of what she claims about the marriage or that she was forced or she comes bleeding if she was a virgin or she calls out for help so that someone comes to her and she is in that state or what resembles it of the situation in which the violation occurred." He said, "If she does not produce any of those, the hadd is inflicted on her and what she claims of that is not accepted from her."

Malik said, "A raped woman cannot marry until she has restored herself by three menstrual periods."

He said, "If she doubts her periods, she does not marry until she has freed herself of that doubt."


Malik :: The Mudabbar :: [41-41.5.17]

The Mudabbar

Malik :: Book 41 : Hadith 41.5.17

Malik related to me from Abu'z-Zinad that he said, ''Umar ibn Abd al-Aziz flogged a slave with eighty lashes for slander."

Abu'z-Zinad said, "I asked Abdullah ibn Amir ibn Rabia about that. He said, 'I saw Umar ibn al-Khattab, Uthman ibn Affan, the Khalifs, and so on, and I did not see any of them flog a slave more than forty lashes for slander.' "


Malik :: The Mudabbar :: [41-41.5.18]

The Mudabbar

Malik :: Book 41 : Hadith 41.5.18

Malik related to me from Zurayq ibn Hakim al-Ayli that a man called Misbah asked his son for help and he thought him unnecessarily slow. When the son came, his father said to him, "O fornicator." Zurayq said, "So the son asked me to help him against the father. When I wanted to flog him, his son said, 'By Allah, if you flog him, I will acknowledge that I have committed fornication.' When he said that, the situation was confused for me, so I wrote about it to Umar ibn Abd al-Aziz who was the governor at that time, and I mentioned it to him. Umar wrote me to permit his pardon."

Zurayq said, "I wrote to Umar ibn Abd al-Aziz also, 'What do you think about a man who is slandered or his parents are slandered and both or only one of them are dead?' He said, Umar wrote to me, 'If he forgives, his pardon is permitted for himself. If his parents are slandered and one or both of them are dead, take the judgement of the Book of Allah for it unless he wants to veil it.' "

Yahya said, "I heard Malik say, 'That is because the slandered man might fear that if that is unveiled about him, a clear proof might be established. If it is according to what we have described, his pardon is permitted."


Malik :: The Mudabbar :: [41-41.5.19]

The Mudabbar

Malik :: Book 41 : Hadith 41.5.19

Malik related to me from Hisham ibn Urwa that his father said that there was only one hadd against a man who slandered a group of people.

Malik said, "If they are on separate occasions there is still only one hadd against him."

Malik related to me from Abu'r-Rijal Muhammad ibn Abd ar-Rahman ibn Haritha ibn an-Numan al-Ansari, then from the Banu'n-Najar from his mother Amra bint Abd ar-Rahman that two men cursed each other in the time of Umar ibn al-Khattab. One of them said to the other, " By Allah, my father is not an adulterer and my mother is not an adulteress." Umar ibn al-Khattab asked advice about that. One person said, "He has praised his father and mother." Another said, "His father and mother have praise other than this. We think that he is to be flogged with the hadd." So Umar flogged him with the hadd of eighty lashes.

Malik said, "There is no hadd in our view except for slander, denial or insinuation, in which one sees that the speaker intends by that denial or slander. Then the hadd is completely imposed on the one who said it."

Malik said, "What is done in our community when a man denies that another man is from his father, is that he deserves the hadd. If the mother who is denied is a slave, then he deserves the hadd as well. '


Malik :: The Mudabbar :: [41-41.6.19]

The Mudabbar

Malik :: Book 41 : Hadith 41.6.19

Malik said, "The best of what is heard about a slave-girl whom a man has intercourse with while he has a partner in her is that the hadd is not inflicted on him and the child is connected to him. When the slave-girl becomes pregnant, her value is estimated and he gives his partners their shares of the price and the slave-girl is his. That is what is done among us."

Malik said about a man who made his slave-girl halal to a man that if the one for whom she was made halal had intercourse with her, her value was estimated on the day he had intercourse with her and he owed that to her owner whether or not she conceived. The hadd was averted from him by that. If she conceived the child was connected to him.

Malik said about a man who had intercourse with his son's or daughter's slave-girl, "The hadd is averted from him and he owes the estimated value of the slave-girl whether or not she conceives."


Malik :: The Mudabbar :: [41-41.6.20]

The Mudabbar

Malik :: Book 41 : Hadith 41.6.20

Malik related to me from Rabia ibn Abi Abd ar-Rahman that Umar ibn al-Khattab spoke about a man who went out with his wife's slave-girl on a journey and had intercourse with her and then the wife became jealous and mentioned that to Umar ibn al-Khattab. Umar questioned him about it. He said, "She gave her to me." Umar said, "Bring me a clear proof or I will stone you." Rabia added, "The wife confessed that she had given her to him."


Malik :: The Mudabbar :: [41-41.7.21]

The Mudabbar

Malik :: Book 41 : Hadith 41.7.21

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, cut off the hand of a man who stole a shield whose price was three dirhams.


Malik :: The Mudabbar :: [41-41.7.22]

The Mudabbar

Malik :: Book 41 : Hadith 41.7.22

Yahya related to me from Malik from Abdullah ibn Abd ar-Rahman abu Husayn al-Makki that the Messenger of Allah, may Allah bless him and grant him peace, said, "The hand is not cut off for fruit hanging on the tree and for sheep kept in the mountains. So when they are taken from the fold or the place where the fruit is dried, a hand is cut off for whatever reaches the price of a shield."


Malik :: The Mudabbar :: [41-41.7.23]

The Mudabbar

Malik :: Book 41 : Hadith 41.7.23

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his father from Amra bint Abd ar-Rahman that a thief stole a citron in the time of Uthman Uthman ibn Affan ordered its value to be estimated and it was estimated at three dirhams at the rate of exchange of twelve dirhams for the dinar, so Uthman cut off his hand.


Malik :: The Mudabbar :: [41-41.7.24]

The Mudabbar

Malik :: Book 41 : Hadith 41.7.24

Yahya related to me from Malik from Yahya ibn Said from Amra bint Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "It has not been a long time for me and I have not forgotten. A thief's hand is cut off for a quarter of a dinar and upwards."


Malik :: The Mudabbar :: [41-41.7.25]

The Mudabbar

Malik :: Book 41 : Hadith 41.7.25

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Hazim that Amra bint Abd ar-Rahman said, "A'isha, the wife of the Prophet, may Allah bless him and grant him peace, went out to Makka and she had two girl mawlas of hers and a slave belonging to the sons of Abdullah ibn Abi Bakr as-Siddiq . She sent a figured cloak with the two mawlas which was sewn up in a piece of green cloth."

Amra continued, "The slave took it and unstitched it and took out the cloak. In its place, he put some felt or skin and sewed it up again. When the mawla girls came to Madina, they gave it to his people. When they opened it, they found felt in it and did not find the cloak. They spoke to the two women and they spoke to A'isha, the wife of the Prophet, may Allah bless him and grant him peace, or they wrote to her and suspected the slave. The slave was asked about it and confessed. A'isha, the wife of the Prophet, may Allah bless him and grant him peace, gave the order and his hand was cut off. A'isha said, 'A thief's hand is cut off for a quarter of a dinar and upwards.' "

Malik said, "The limit I prefer above which cutting off the hand is obliged is three dirhams, whether the exchange is high or low. That is because the Messenger of Allah, may Allah bless him and grant him peace, cut off the hand of a thief for a shield whose value was three dirhams, and Uthman ibn Affan cut off the hand of a thief for a citron which was estimated at three dirhams. This is what I prefer of what I have heard on the matter."


Malik :: The Mudabbar :: [41-41.8.26]

The Mudabbar

Malik :: Book 41 : Hadith 41.8.26

Yahya related to me from Malik from Nafi that a slave of Abdullah ibn Umar stole while he was a runaway. Abdullah ibn Umar sent him to Said ibn al-As, who was the amir of Madina, to cut off his hand. Said refused to cut off his hand. He said, "The hand of a runaway slave is not cut off when he steals." Abdullah ibn Umar said to him, "In what Book of Allah did you find this?" Then Abdullah ibn Umar gave the order, and his hand was cut off.


Malik :: The Mudabbar :: [41-41.8.27]

The Mudabbar

Malik :: Book 41 : Hadith 41.8.27

Yahya related to me from Malik that Zurayq ibn Hakim informed him that he had a runaway slave who had stolen. He said, "The situation was obscure for me, so I wrote to Umar ibn Abd al-Aziz to ask him about it. He was the governor at that time. I informed him that I had heard that if a runaway slave stole while he was a fugitive, his hand was not cut off. 'Umar ibn Abd al-Aziz wrote to contradict my letter, 'You wrote to me that you have heard that when the runaway slave steals, his hand is not cut off. Allah, the Blessed, the Exalted, says in His Book, 'The thief, male and female, cut off the hands of both, as a recompense for what they have earned, and an exemplary punishment from Allah. Allah is Mighty, Wise.' (Sura 5 ayat 41) When his theft reaches a quarter of a dinar, and upwards, his hand is cut off.' "

Yahya related to me from Malik that he had heard that al-Qasim ibn Muhammad and Salim ibn Abdullah and Urwa ibn az-Zubayr said, "When a runaway slave steals something for which cutting off the hand is obliged, his hand is cut off."

Malik said, "The way of doing things amongst us about which there is no dispute is that when the runaway slave steals that for which cutting off the hand is obliged, his hand is cut off."


Malik :: The Mudabbar :: [41-41.9.28]

The Mudabbar

Malik :: Book 41 : Hadith 41.9.28

Yahya related to me from Malik from Ibn Shihab from Safwan ibn Abdullah ibn Safwan that it was said to Safwan ibn Umayya, "Whoever does not do hijra is ruined." So Safwan ibn Umayya went to Madina and slept in the mosque with his cloak as a pillow. A thief came and took his cloak and Safwan grabbed hold of the thief and brought him to the Messenger of Allah, may Allah bless him and grant him peace. The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Did you steal this cloak?" He said, "Yes." So the Messenger of Allah, may Allah bless him and grant him peace, ordered that his hand be cut off. Safwan said to him, "I did not intend this. It is his as sadaqa." The Messenger of Allah, may Allah bless him and grant him peace, said, "Why didn't you do it before bringing him to me?"


Malik :: The Mudabbar :: [41-41.9.29]

The Mudabbar

Malik :: Book 41 : Hadith 41.9.29

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that az-Zubayr ibn al-Awwam came across a man who had taken hold of a thief and was intending to take him to the Sultan. Az-Zubayr ibn al-Awwam interceded for him to let him go. He said, "No. Not until I take him to the Sultan." Az-Zubayr said, "When you reach the Sultan with him, Allah curses the one who intercedes and the one who accepts the intercession."


Malik :: The Mudabbar :: [41-41.10.30]

The Mudabbar

Malik :: Book 41 : Hadith 41.10.30

Yahya related to me from Malik from Abd ar-Rahman ibn al-Qasim from his father that a man from Yemen who had his hand and foot cut off came and went before Abu Bakr as-Siddiq and complained to him that the governor of the Yemen had wronged him, and the man used to pray part of the night. Abu Bakr said, "By your father, your night is not the night of a thief." Then they missed a necklace of Asma bint Umays, the wife of Abu Bakr as-Siddiq. The man came to go around with them looking for it. He said, "O Allah! You are responsible for the one who invaded the people of this good house by night!" They found the jewelry with a goldsmith. He claimed that the maimed man had brought it to him. The maimed man confessed or it was testified against him. Abu Bakr as-Siddiq ordered that his left hand be cut off. Abu Bakr said, "By Allah! His dua against himself is more serious, as far as I am concerned, than his theft."

Yahya said that Malik said, "What is done among us about the person who steals several times and is then called to reckoning, is that only his hand is cut off for all he stole when the hadd has not been applied againsthim. If the hadd has been applied against him before that, and he steals what obliges cutting off, then the next limb is cut off."


Malik :: The Mudabbar :: [41-41.10.31]

The Mudabbar

Malik :: Book 41 : Hadith 41.10.31

Yahya related to me from Malik that Abu'z-Zinad informed him that a governor of Umar ibn Abd al-Aziz took some people in battle and had not killed any of them. He wanted to cut off their hands or kill them, so he wrote to Umar ibn Abd al-Aziz about that Umar ibn Abd al-Aziz wrote to him, "Better to take less than that."

Yahya said that he heard Malik say, "What is done among us about a person who steals the goods of people which are placed under guard in the markets, and their owners put them in their containers and store them together is that if anyone steals any of that from where it is kept, and its value reaches that for which cutting off the hand is obliged, his hand must be cut off, whether or not the owner of the goods is with his goods and whether it is night or day."

Malik said about some one who stole something for which cutting off the hand was obliged and then what he stole was found with him and he returned it to its owner, "His hand is cut off."

Malik said, "If someon says, 'How can his hand be cut off when the goods have been taken from him and returned to their owner?', it is because he is in the same position as the wine drinker when the smell of the wine is found on his breath and he is not drunk. He is flogged with the hadd.

"The hadd is imposed for drinking wine even if it does not make the man intoxicated. That is because he drank it to become intoxicated. It is the same as that with cutting off the hand of the thief for theft when it is taken from him, even if he has not profited from it and it was returned to its owner. When he stole it, he stole it to take it away."

Malik said that if some people came to a house and robbed it together, and then they left with a sack or box or a board or basket or the like of that which they carried together, and when they took it out of its guarded place, they carried it together, and the price of what they took reached that for which cutting off the hand was obliged, and that was three dirhams and upwards, each of them had his hand cut off.

"If each of them takes out something by himself, whoever of them takes out something whose value reaches three dirhams and upwards must have his hand cut off. If any of them takes out something whose value does not reach three dirhams, he does not have his hand cut off."

Yahya said that Malik said, "What is done among us is that when a man's house is locked and he is the only one living in it, cutting off the hand is not obliged against the one who steals something from it until he takes it out of the house completely. That is because all of the house is a place of custody. If someone other than him lives in the house and each of them locks his door, and it is a place of custody for each of them, whoever steals anything from the apartments of that house must have his hand cut off when he leaves the apartment and goes into the main house. He has removed it from its place of custody to another place and he must have his hand cut off."

Malik said, "What is done in our community about a slave who steals from the property of his master is that if he is not in service and among those trusted in the house and he enters secretly and steals from his master something that for which cutting off the hand is obliged, his hand is not cut off. It is like that with a slave-girl when she steals from her master's property. Her hand is not cut off."

Malik then spoke about a slave who was not in service and not one of those trusted in the house, and he entered secretly and stole from the property of his master's wife that for which cutting off the hand was obliged. He said, "His hand is cut off."

"It is like that with the wife's slave-girl when she does not serve her or her husband nor is she trusted in the house and she enters secretly and steals from her mistress's property that for which cutting off the hand is obliged. Her hand is not cut off."

"It is like that with the wife's slave-girl who is not in her service and is not trusted in the house and she enters secretly and steals from the property of her mistress's husband something for which cutting off the hand is obliged. Her hand is cut off."

It is like that with the man who steals from his wife's goods or the wife who steals from her husband's goods something for which cutting off the hand is obliged. If the thing which one of them steals from his spouse's property is in a room other than the room which they both lock for themselves, or it is in a place of custody in a room other than the room which they are in, whichever of them steals something for which cutting off the hand is obliged, their hand should be cut off."

Malik spoke about a small child and a foreigner who does not speak clearly. He said, "If they are robbed of something from its place of custody or from under a lock, the one who stole it has his hand cut off. If the property is outside of its place of custody or locked room(when it is stolen), the one who robbed them does not have his hand cut off. It is then in the position of sheep stolen from the mountain and uncut fruit hanging on the trees "

Malik said, "What is done among us about a person who robs graves is that if what he takes from the grave reaches what cutting off the hand is obliged for, his hand is cut off . That is because the grave is a place of custody for what is in it just as houses are a place of custody for what is in them. "

Malik added, "Cutting off the hand is not obliged for him until he takes it out of the grave."


Malik :: The Mudabbar :: [41-41.11.32]

The Mudabbar

Malik :: Book 41 : Hadith 41.11.32

Yahya related to me from Malik from Yahya ibn Said from Muhammad ibn Yahya ibn Habban that a slave stole a small palm from a man's garden and planted it in the garden of his master. The owner of the palm went out looking for the palm and found it. He asked for help against the slave from Marwan ibn al-Hakam. Marwan jailed the slave and wanted to cut off his hand. The master of the slave rushed off to Rafi ibn Khadij and asked him about it. Rafi informed him that he heard the Messenger of Allah, may Allah bless him and grant him peace, say, "The hand is not cut off for fruit or palm pith." The man said, "Marwan ibn al-Hakam has taken a slave of mine and wants to cut off his hand. I would like you to go with me to him so you can tell him what you heard from the Messenger of Allah, may Allah bless him and grant him peace." So, Rafi went with him to Marwan ibn al-Hakam. He said, "Did you arrest a slave for this?" He said, "Yes." He said, "What will you do with him?" He said, "I want to cut off his hand." Rafi said to him, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'The hand is not cut off for dates or palm pith.' Marwan therefore ordered the slave to be released."


Malik :: The Mudabbar :: [41-41.11.33]

The Mudabbar

Malik :: Book 41 : Hadith 41.11.33

Yahya related to me from Malik from Ibn Shihab from as-Sa'ib ibn Yazid that Abdullah ibn Amr ibn al-Hadrami brought a slave of his to Umar ibn al-Khattab and said to him, "Cut off the hand of this slave of mine. He has stolen." Umar said to him, "What did he steal?" He said, "He stole a mirror belonging to my wife. Its value was sixty dirhams." Umar said, "Let him go. His hand is not to be cut off. He is your servant who has stolen your belongings."


Malik :: The Mudabbar :: [41-41.11.34]

The Mudabbar

Malik :: Book 41 : Hadith 41.11.34

Yahya related to me from Malik from Ibn Shihab that Marwan ibn al-Hakam was brought a man who had snatched some goods and he wanted to cut off his hand. He sent to Zayd ibn Thabit to ask him about it. Zayd ibn Thabit said to him, "The hand is not cut off for what is stolen by chance, openly, in haste."


Malik :: The Mudabbar :: [41-41.11.35]

The Mudabbar

Malik :: Book 41 : Hadith 41.11.35

Yahya related to me from Malik that Yahya ibn Said said that Abu Bakr ibn Muhammad ibn Amr ibn Hazm informed him that he had taken a Nabatean who had stolen some iron rings and jailed him in order to cut off his hand. Amra bint Abd ar-Rahman sent a girl mawla to him called Umayya. Abu Bakr said that she had come to him while he was among the people and said that his aunt Amra sent word to him saying, "Son of my brother! You have taken a Nabatean for something insignificant which was mentioned to me. Do you want to cut off his hand?" He had said, "Yes." She said, ''Amra says to you not to cut off the hand except for a quarter of a dinar and upwards."

Abu Bakr added, "So I let the Nabatean go."

Malik said, "The generally agreed on way of doing things among us about the confession of slaves is that if a slave confesses something against himself, the hadd and punishment for it is inflicted on his body. His confession is accepted from him and one does not suspect that he would inflict something on himself."

Malik said, "As for the one of them who confesses to a matter which will incur damages agains this master, his confession is not accepted against his master."

Malik said, "One does not cut off the hand of a hireling or a man who is with some people to serve them, if he robs them, because his state is not the state of a thief. His state is the state of a treacherous one. The treacherous one does not have his hand cut off."

Malik said about a person who borrows something and then denies it, "His hand is not cut off. He is like a man who owes a debt to another man and denies it. He does not have his hand cut off for what he has denied."

Malik said, "The generally agreed-on way of dealing among us, with the thief who is found in a house and has gathered up goods and has not taken them out, is that his hand is not cut off. That is like the man who places wine before him to drink it and does not do it. The hadd is not imposed on him. That is like a man who sits with a woman and desires to have haram intercourse with her and does not do it and he does not reach her. There is no hadd against that either."

Malik said, "The generally agreed-on way of doing things among us is that there is no cutting off the hand for what is taken by chance, openly and in haste, whether or not its price reaches that for which the hand is cut off."


Malik :: Drinks :: [42-42.1.1]

Drinks

Malik :: Book 42 : Hadith 42.1.1

Yahya related to me from Malik from Ibn Shihab that as-Sa'ib ibn Yazid informed him that Umar ibn al-Khattab came out to them. He said, "I have found the smell of wine on so-and-so, and he claimed that it was the drink of boiled fruit juice, and I am inquiring about what he has drunk. If it intoxicates, I will flog him." Umar then flogged him with the complete hadd.


Malik :: Drinks :: [42-42.1.2]

Drinks

Malik :: Book 42 : Hadith 42.1.2

Yahya related to me from Malik from Thawr ibn Zayd ad-Dili that Umar ibn al-Khattab asked advice about a man drinking wine. Ali ibn Abi Talib said to him, "We think that you flog him for it with eighty lashes. Because when he drinks, he becomes intoxicated, and when he becomes intoxicated, he talks confusedly, and when he talks confusedly, he lies." (80 lashes is the same amount as for slandering) Umar gave eighty lashes for drinking wine.


Malik :: Drinks :: [42-42.1.3]

Drinks

Malik :: Book 42 : Hadith 42.1.3

Yahya related to me from Malik from Ibn Shihab that he was asked about the hadd of the slave for wine. He said, "I heard that he has half the hadd of a freeman for drinking wine. Umar ibn al-Khattab, Uthman ibn Affan, and Abdullah ibn Umar flogged their slaves with half of the hadd of a freeman when they drank wine."


Malik :: Drinks :: [42-42.1.4]

Drinks

Malik :: Book 42 : Hadith 42.1.4

Yahya related to me from Malik from Yahya ibn Said that he heard Said ibn al-Musayyab say, "There is nothing that Allah does not like to be pardoned as long as it is not a hadd."

Yahya said that Malik said, "The sunna with us is that the hadd is obliged against anyone who drinks something intoxicating whether or not he becomes drunk."


Malik :: Drinks :: [42-42.2.5]

Drinks

Malik :: Book 42 : Hadith 42.2.5

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, addressed the people in one of his raids. Abdullah ibn Umar said, "I went towards him, but he finished before I reached him. I asked about what he had said. Someone said to me, 'He forbade preparing nabidh in a gourd or in a jug smeared with pitch.'"


Malik :: Drinks :: [42-42.2.6]

Drinks

Malik :: Book 42 : Hadith 42.2.6

Yahya related to me from Malik from al-Ala ibn Abd ar-Rahman ibn Yaqub from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, forbade preparing nabidh in a gourd or in a jug smeared with pitch.


Malik :: Drinks :: [42-42.3.7]

Drinks

Malik :: Book 42 : Hadith 42.3.7

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, forbade preparing nabidh from nearly ripe dates and fresh dates together, and from dates and raisins together.


Malik :: Drinks :: [42-42.3.8]

Drinks

Malik :: Book 42 : Hadith 42.3.8

Yahya related to me from Malik from a reliable source from Bukayr ibn Abdullah ibn al-Ashajj from Abd ar-Rahman ibn al-Hubab al-Ansari from Abu Qatada al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, forbade making nabidh from dates and raisins together, and nearly ripe dates and fresh dates together.

Malik said, "That is the way of doing things among us in which the people of knowledge in our city continue. It is disapproved of because the Messenger of Allah, may Allah bless him and grant him peace, forbade it."


Malik :: Drinks :: [42-42.4.9]

Drinks

Malik :: Book 42 : Hadith 42.4.9

Yahya related to me from Malik from ibn Shihab from Abu Salama ibn Abd ar-Rahman that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, was asked about mead, and he replied, 'Every drink which intoxicates is haram.' "


Malik :: Drinks :: [42-42.4.10]

Drinks

Malik :: Book 42 : Hadith 42.4.10

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, was asked about al-Ghubayra. He said, "There is no good in it," and forbade it. Malik said, "I asked Zayd ibn Aslam, 'What is al-Ghubayra?' He said, 'It is an intoxicant.' "


Malik :: Drinks :: [42-42.4.11]

Drinks

Malik :: Book 42 : Hadith 42.4.11

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said "Whoever drinks wine in this world and does not turn from it in tawba, it is haram for him in the Next World."


Malik :: Drinks :: [42-42.5.12]

Drinks

Malik :: Book 42 : Hadith 42.5.12

Yahya related to me from Malik from Zayd ibn Aslam that Ibn Wala al-Misri asked Abdullah ibn Abbas about what is squeezed from the grapes. Ibn Abbas replied, "A man gave the Messenger of Allah, may Allah bless him and grant him peace, a small water-skin of wine. The Messenger of Allah, may Allah bless him and grant him peace, said to him, 'Don't you know that Allah has made it haram?' He said, 'No.' Then a man at his side whispered to him. The Messenger of Allah, may Allah bless him and grant him peace, asked what he had whispered, and the man replied, 'I told him to sell it.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'The One who made drinking it haram has made selling it haram.' The man then opened the water-skins and poured out what was in them ."


Malik :: Drinks :: [42-42.5.13]

Drinks

Malik :: Book 42 : Hadith 42.5.13

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik said, "I was serving wine to Abu Ubayda ibn al-Jarrah and Abu Talha al-Ansari and Umayy ibn Kab. The wine had been prepared from crushed ripe dates and dried dates. Someone came to them and said, 'Wine has been made haram.' Abu Talha ordered me to go and take the jugs and break them. I stood up and went to a mortar of ours and I struck them with the bottom of it until they broke."


Malik :: Drinks :: [42-42.5.14]

Drinks

Malik :: Book 42 : Hadith 42.5.14

Yahya related to me from Malik from Da'ud ibn al-Husayn that Waqid ibn Amr ibn Sad ibn Muadh informed him from Mahmud ibn Labid al-Ansari that when Umar ibn al-Khattab went to ash-Sham, the people of ash-Sham complained to him about the bad air of their land and its heaviness. They said, "Only this drink helps." Umar said, "Drink this honey preparation." They said, "Honey does not help us." A man from the people of that land said, "Can we give you something of this drink which does not intoxicate?" He said, "Yes." They cooked it until two-thirds of it evaporated and one-third of it remained. Then they brought it to Umar. Umar put his finger in it and then lifted his head and extended it. He said, "This is fruit juice concentrated by boiling. This is like the distillation with which you smear the camel's scabs." Umar ordered them to drink it. Ubada ibn as-Samit said to him, "You have made it halal, by Allah!" Umar said, "No, by Allah! O Allah! I will not make anything halal for them which You have made haram for them! I will not make anything haram for them which You have made halal for them."


Malik :: Drinks :: [42-42.5.15]

Drinks

Malik :: Book 42 : Hadith 42.5.15

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that some men from Iraq said to him, "Abu Abd ar-Rahman, we buy the fruit of the palm and grapes and we squeeze them into wine and we sell it." Abdullah ibn Umar said, "I call on Allah and His angels and whoever hears of jinn and men to testify to you that I order you not to buy it nor sell it nor to press it nor to drink it nor to give it to people to drink. It is something impure from the work of Shaytan."


Malik :: Blood-Money :: [43-43.1.1]

Blood-Money

Malik :: Book 43 : Hadith 43.1.1

Yahya related to me from Malik from Abdullah ibn Abi Bakr ibn Muhammad ibn Amr ibn Hazm from his father that in a letter which the Messenger of Allah, may Allah bless him and grant him peace, sent to Amr ibn Hazm about blood-money he wrote that it was one hundred camels for a life, one hundred camels for a nose if completely removed, a third of the blood-money for a wound in the brain, the same as that for a belly wound, fifty for an eye, fifty for a hand, fifty for a foot, ten camels for each finger, and five for teeth, and five for a head wound which laid bare the bone.


Malik :: Blood-Money :: [43-43.2.2]

Blood-Money

Malik :: Book 43 : Hadith 43.2.2

Malik related to me that he had heard that Umar ibn al-Khattab estimated the full blood-money for the people of urban areas. For those who had gold, he made it one thousand dinars. and for those who had silver he made it ten thousand dirhams.

Malik said, "The people of gold are the people of ash-Sham and the people of Egypt. The people of silver are the people of Iraq "

Yahya related to me from Malik that he heard that the blood-money was divided into instalments over three or four years.

Malik said, "Three is the most preferable to me of what I have heard on that."

Malik said, "The generally agreed on way of doing things in our community is that camels are not accepted from the people of cities for blood-money nor is gold or silver accepted from the desert people. Silver is not accepted from the people of gold and gold is not accepted from the people of silver."


Malik :: Blood-Money :: [43-43.3.2]

Blood-Money

Malik :: Book 43 : Hadith 43.3.2

Yahya related to me from Malik that Ibn Shihab said, "The full blood-money for murder when it is accepted is twenty-five yearlings, twenty-five two-year-olds, twenty-five four-year-olds, and twenty-five five-year-olds."


Malik :: Blood-Money :: [43-43.3.3]

Blood-Money

Malik :: Book 43 : Hadith 43.3.3

Yahya related to me from Malik from Yahya ibn Said that Marwan ibn al-Hakam wrote to Muawiya ibn Abi Sufyan that a madman was brought to him who had killed a man. Muawiya wrote to him, "Tie him up and do not inflict any retaliation on him. There is no retaliation against a madman."

Malik said about an adult and a child when they murder a man together, "The adult is killed and the child pays half the full blood-money."

Malik said, "It is like that with a freeman and a slave when they murder a slave. The slave is killed and the freeman pays half of his value."


Malik :: Blood-Money :: [43-43.4.4]

Blood-Money

Malik :: Book 43 : Hadith 43.4.4

Yahya related to me from Malik from Ibn Shihab from Irak ibn Malik and Sulayman ibn Yasar that a man of the Banu Sad ibn Layth was running a horse and it trod on the finger of a man from the Juhayna tribe. It bled profusely, and he died. Umar ibn al-Khattab said to those against whom the claim was made. "Do you swear by Allah with fifty oaths that he did not die of it?" They refused and stopped themselves from doing it. He said to the others, "Will you take an oath?" They refused, so Umar ibn al-Khattab gave a judgement that the Banu Sad had to pay half the full blood-money.

Malik said, "One does not act on this."

Yahya related to me from Malik that Ibn Shihab, Sulayman ibn Yasar, and Rabia ibn Abi Abd ar-Rahman said, "The blood-money of manslaughter is twenty yearlings, twenty two-year-olds, twenty male two-year-olds, twenty four-year-olds, and twenty five-year-olds."

Malik said, "The generally agreed on way with us is that there is no retaliation against children. Their intention is accidental. The hudud are not obliged for them if they have not yet reached puberty. If a child kills someone it is only accidentally. Had a child and an adult killed a free man accidentally, each of them pays half the full blood-money."

Malik said, "A person who kills someone accidentally pays blood-money with his property and there is no retaliation against him. That money is like anything else from the dead man's property and his debt is paid with it and he is allowed to make a bequest from it. If he has a total property of which the blood-money is a third and then the blood-money is relinquished, that is permitted to him. If all the property he has is his blood-money, he is permitted to relinquish a third of it and to make that a bequest."


Malik :: Blood-Money :: [43-43.5.4]

Blood-Money

Malik :: Book 43 : Hadith 43.5.4

Malik related to me that the generally agreed on way of doing things amongst the community about an accident is that there is no blood-money until the victim is better. If a man's bone, either a hand, or a foot, or another part of his body, is broken accidentally and it heals and becomes sound and returns to its form, there is no blood-money for it. If the limb is impaired or there is a scar on it, there is blood-money for it according to the extent that it is impaired.

Malik said, "If that part of the body has a specific blood-money mentioned by the Prophet, may Allah bless him and grant him peace, it is according to what the Prophet, may Allah bless him and grant him peace, specified. If it is part of what does not have a specific blood-money for it mentioned by the Prophet, may Allah bless him and grant him peace, and if there is no previous sunna about it or specific blood-money, one uses ijtihad about it."

Malik said, "There is no blood-money for an accidental bodily injury when the wound heals and returns to its form. If there is any scar or mark in that, ijtihad is used about it except for the belly-wound. There is a third of the blood-money of a life for it. "

Malik said, "There is no blood-money for the wound which splinters a bone in the body, and it is like the wound to the body which lays bare the bone."

Malik said, "The generally agreed on way of doing things in our community is that when the doctor performs a circumcision and cuts off the glans, he must pay the full blood-money. That is because it is an accident which the tribe is responsible for, and the full blood money is payable for all that in which a doctor errs or exceeds, when it is not intentional."


Malik :: Blood-Money :: [43-43.6.4]

Blood-Money

Malik :: Book 43 : Hadith 43.6.4

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab said, "The blood-money for a woman is the same as for a man up to one third of the blood-money. Her finger is like his finger, her tooth is like his tooth, her injury which lays bare the bone is like his, and her head wound which splinters the bone is like his."

Yahya related to me from Malik that Ibn Shihab and also Urwa ibn az-Zubayr said the same as Said ibn al-Musayyab said about a woman. Her blood-money from a man is the same up to a third of the blood-money of a man. If what she is owed exceeds a third of the blood-money of the man, she is given up to half of the blood-money of a man.

Malik said, "The explanation of that is that she has blood-money for a head wound that lays bare the bone and one that splinters the bone and for what is less than the brain wound and the belly wound and the like of that of those which obliges a third of the blood-money or more. If the amount owed her exceeds that, her blood-money in that is half of the blood-money of a man."

Yahya related to me from Malik that he heard Ibn Shihab say, "The precedent of the sunna when a man injures a woman is that he must pay the blood-money for that injury and there is no retaliation against him."

Malik said, "That is an accidental injury, when a man strikes a woman and hits with a blow what he did not intend, for instance, if he struck her with a whip and cut her eye open and the like of that."

Malik said about a woman who has a husband and children who are not from her paternal relatives or her people, that since he is from another tribe, there is no blood-money against her husband for her criminal action, nor any against her children if they are not from her people, nor any against her maternal brothers when they are not from her paternal relations or her people. These are entitled to her inheritance but only the paternal relations have paid blood-money from since the time of the Messenger of Allah, may Allah bless him and grant him peace. Until today it is like that with the mawla of a woman. The inheritance they leave goes to the children of the woman even if they are not from her tribe, but the blood-money of the criminal act of the mawla is only against her tribe."


Malik :: Blood-Money :: [43-43.7.5]

Blood-Money

Malik :: Book 43 : Hadith 43.7.5

Yahya related to me from Malik from Ibn Shihab from Abu Salama ibn Abd ar-Rahman ibn Awf from Abu Hurayra that a woman from the Hudhayl tribe threw a stone at a woman from the same tribe, and she had a miscarriage. The Messenger of Allah, may Allah bless him and grant him peace, gave a judgement that a slave or slave-girl of fair complexion and excellence should be given to her.


Malik :: Blood-Money :: [43-43.7.6]

Blood-Money

Malik :: Book 43 : Hadith 43.7.6

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab that the Messenger of Allah, may Allah bless him and grant him peace, gave a judgement that the compensation for a foetus killed in its mother's womb was a slave or slave-girl of fair complexion and excellence. The one against whom the judgement was given said, "Why should I pay damages for that which did not drink or eat or speak or make any cry. The like of that is nothing." The Messenger of Allah, may Allah bless him and grant him peace, said, "This is only one of the brothers of the diviners." He disapproved of the rhyming speech of the man's declaration.

Yahya related to me from Malik that Rabia ibn Abi Abd ar-Rahman said, "The slave of fair complexion and excellence is estimated at fifty dinars or six hundred dirhams. The blood-money of a free muslim woman is five hundred dinars or six thousand dirhams."

Malik said, "The blood-money of the foetus of a free woman is a tenth of her blood-money. The tenth is fifty dinars or six hundred dirhams."

Malik said, "I have not heard anyone dispute that there is no slave in compensation for the foetus until it leaves its mother's womb and falls still-born from her womb . "

Malik said, "I heard that if the foetus comes out of its mother's womb alive and then dies, the full blood-money is due for it."

Malik said, "The foetus is not alive unless it cries at birth. If it comes out of its mother's womb and cries out and then dies, the complete blood-money is due for it. We think that the slave-girl's foetus has a tenth of the price of the slave-girl."

Malik said, "When a woman murders a man or woman, and the murderess is pregnant, retaliation is not taken against her until she has given birth. If a woman who is pregnant is killed intentionally or unintentionally, the one who killed her is not obliged to pay anything for her foetus. If she is murdered, then the one who killed her is killed and there is no blood-money for her foetus. If she is killed accidentally, the tribe obliged to pay on behalf of her killer pays her blood-money, and there is no blood-money for the foetus."

Yahya related to me, "Malik was asked about the foetus of the christian or jewish woman which was aborted. He said, 'I think that there is a tenth of the blood-money of the mother for it.' "


Malik :: Blood-Money :: [43-43.8.6]

Blood-Money

Malik :: Book 43 : Hadith 43.8.6

Yahya related to me from Malik from Ibn Shihab that Said ibn al-Musayyab used to say, "The full blood-money is payable for cutting off both lips, but when the lower one only is cut off, two-thirds of the blood-money is due for it."

Yahya related to me from Malik that he asked Ibn Shihab about the one-eyed man who gouged out the eye of a healthy person. Ibn Shihab said, "If the healthy person wants to take retaliation from him, he can have his retaliation. If he prefers, he has blood-money of one thousand dinars, twelve thousand dirhams."

Yahya related to me from Malik that he heard that full blood-money was payable for both of a pair of anything in a man that occurred in pairs, and the tongue had full blood-money. The ears, when their hearing departed, had full blood-money, whether or not they were cut off, and a man's penis had full blood-money and the testicles had full blood-money.

Yahya related to me from Malik that he heard that the breasts of a woman had full blood-money.

Malik said, "The least of that are the eyebrows and a man's breasts."

Malik said, "What is done in our community when a man is injured in his extremities to an extent that obliges payment of more than the amount of his full blood-money, is that it is his right. If his hands, feet, and eyes are all injured, he has three full blood-moneys."

Malik said about the sound eye of a one-eyed man when it is accidentally gouged out, "The full blood-money is payable for it."


Malik :: Blood-Money :: [43-43.9.6]

Blood-Money

Malik :: Book 43 : Hadith 43.9.6

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Zayd ibn Thabit used to say, "When the eye remains but the sight is lost, one hundred dinars are payable for it."

Yahya said, "Malik was asked about cutting off the lower lid of the eye and the bone around the eye. He said, 'There is only ijtihad in that unless the vision of the eye is impaired. He is entitled to an amount that is compatible to the extent the vision of the eye has been impaired."

Yahya said that Malik said, "What is done in our community about removing the bad eye of a one-eyed man when it has already been blinded and still remains there in its place and the paralyzed hand when it is cut off, is that there is only ijtihad in that, and there is no prescribed blood-money."


Malik :: Blood-Money :: [43-43.10.6]

Blood-Money

Malik :: Book 43 : Hadith 43.10.6

Yahya related to me from Malik that Yahya ibn Said heard Sulayman ibn Yasar mention that a face wound in which the bone was bared was like a head wound in which the bone was bared, unless the face was scarred by the wound. Then the blood-money is increased by one half of the blood-money of the head wound in which the skin was bared so that seventy five dinars are payable for it.

Malik said, "What is done in our community is that the head wound with splinters has fifteen camels." He explained, "The head wound with splinters is that from which pieces of bone fly off and which does not reach the brain. It can be in the head or the face."

Malik said, "The generally agreed on way of doing things in our community, is that there is no retaliation for a wound to the brain or a belly wound, and Ibn Shihab has said, 'There is no retaliation for a wound to the brain.' "

Malik explained, "The wound to the brain is what pierces the bones to the brain. This type of wound only occurs in the head. It is that which reaches the brain when the bones are pierced."

Malik said, "What is done in our community is that there is no blood-money paid on any head wound less than one which lays bare the skull. Blood-money is payable only for the head wound that bares the bone and what is worse than that. That is because the Messenger of Allah, may Allah bless him and grant him peace, stopped at the head wound which bared the bone in his letter to Amr ibn Hazm. He made it five camels. The imams, past and present, have not made any blood-money payable for injuries less than the head wound which bares the bone."

Yahya related to me from Malik from Yahya ibn Said, that Said ibn al-Musayyab said, "For every piercing wound in any of the organs or limbs of the body, one third of the blood-money of that limb is payable."

Malik related to me, "Ibn Shihab did not think and nor do I, that there is a generally agreed on way of doing things regarding a piercing wound in any of the organs or limbs of the body, but I think that there is ijtihad in the case. The imam uses ijtihad in it, and there is no generally agreed on way of doing things in our community about it."

Malik said, "What is done in our community about the wound to the brain and the wound which splinters the bone, and the wound that bares the bone is that they apply only to the head and face. Whatever of that occurs in the body only has ijtihad in it."

Malik said, "I do not think the lower jaw and the nose are part of the head in their injury because they are separate bones, and except for them the head is one bone."

Yahya related to me from Malik from Rabia ibn Abi Abd ar-Rahman that Abdullah ibn az-Zubayr allowed retaliation for a head wound which splintered the bone.


Malik :: Blood-Money :: [43-43.11.6]

Blood-Money

Malik :: Book 43 : Hadith 43.11.6

ibn Abi Abd ar-Rahman said, "I asked Said ibn al Musayyab, 'How much for the finger of a woman?' He said, 'Ten camels' I said, 'How much for two fingers?' He said, 'Twenty camels.' I said, 'How much for three?' He said, 'Thirty camels.' I said, 'How much for four?' He said, 'Twenty camels.' I said, 'When her wound is greater and her affliction stronger, is her blood-money then less?' He said, 'Are you an Iraqi?' I said, 'Rather, I am a scholar who seeks to verify things, or an ignorant man who seeks to learn.' Said said, 'It is the sunna, my nephew.' "

Malik said, "What is done in our community about all the fingers of the hand being cut off is that its blood-money is complete. That is because when five fingers are cut, their blood-money is the blood-money of the hand: fifty camels. Each finger has ten camels."

Malik said, "The reckoning of the fingers is thirty-three dinars for each fingertip, and that is three and a third shares of camels."


Malik :: Blood-Money :: [43-43.12.7]

Blood-Money

Malik :: Book 43 : Hadith 43.12.7

Yahya related to me from Malik from Zayd ibn Aslam from Muslim ibn Jundub from Aslam, the mawla of Umar ibn al-Khattab that Umar ibn al-Khattab decided on a camel for a molar, a camel for a collar-bone, and a camel for a rib.

Yahya related to me from Malik that Yahya ibn Said heard Said ibn al-Musayyab say, ''Umar ibn al-Khattab decided on a camel for each molar, and Muawiya ibn Abi Sufyan decided on five camels for each molar."

Said ibn al-Musayyab said, "The blood-money is less in the judgement of Umar ibn al-Khattab and more in the judgement of Muawiya. Had it been me, I would have made it two camels for each molar. That is the fair blood-money, and every one who strives with ijtihad is rewarded."

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyab used to say,' 'When a tooth is struck and becomes black, there is complete blood-money for it. If it falls out after it becomes black, there is also the complete blood-money for it."


Malik :: Blood-Money :: [43-43.13.8]

Blood-Money

Malik :: Book 43 : Hadith 43.13.8

Yahya related to me from Malik from Da'ud ibn al-Husayn that Abu Ghatafan ibn Tarif al-Murri informed him that Marwan ibn al-Hakam sent him to Abdullah ibn Abbas to ask him what there was for the molar. Abdullah ibn Abbas said, "There are five camels for it." He said, "Marwan sent me back again to Abdullah ibn Abbas.'' He said, "Do you make front teeth like molars?" Abdullah ibn Abbas said, "It is enough that you take the fingers as the example for that, their blood-moneys being all the same."

Yahya related to me from Malik from Hisham ibn Urwa that his father made all the teeth the same in the blood-money and did not prefer any kind over others.

Malik said, "What is done in our community is that the front teeth, molars, and eye-teeth have the same blood-money. That is because the Messenger of Allah, may Allah bless him and grant him peace, said, 'The tooth has five camels.' The molar is one of the teeth and he did not prefer any kind over the others."


Malik :: Blood-Money :: [43-43.14.8]

Blood-Money

Malik :: Book 43 : Hadith 43.14.8

Yahya related to me from Malik that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar said, "The head wound of the slave in which the bone is bared is a twentieth of his price."

Malik related to me that he had heard that Marwan ibn al-Hakam gave a decision about a slave who was injured that the person who injured him had to pay what he had diminished of the value of the slave.

Malik said, "What is done in our community is that for the head wound of a slave that bares the bone, there is a twentieth of his price. The head wound which splinters the bone is three twentieths of his price. Both the wound to the brain and the belly wound are a third of his price. Besides these four, any other types of injury that decrease the price of the slave are considered after the slave is better and well, and one sees what the value of the slave is after his injury and what his value whole was before he had the injury. Then the one who injured him pays the difference between the two values."


Malik :: Blood-Money :: [43-43.15.8]

Blood-Money

Malik :: Book 43 : Hadith 43.15.8

Yahya related to me from Malik that he heard that Umar ibn Abd al-Aziz gave a decision that when a jew or christian was killed, his blood-money was half the blood-money of a free muslim.

Malik said, "What is done in our community, is that a muslim is not killed for a kafir unless the muslim kills him by deceit. Then he is killed for it."

Yahya related to me from Malik from Yahya ibn Said that Sulayman ibn Yasar said, "The blood-money of a magian is eight hundred dirhams."

Malik said, "This is what is done in our community."

Malik said, "The blood-monies of the jew, christian, and magian in their injuries, is according to the injury of the muslims in their blood-moneys. The head wound is a twentieth of his full blood-money. The wound that opens the head is a third of his blood-money. The belly-wound is a third of his blood-money. All their injuries are according to this calculation."


Malik :: Blood-Money :: [43-43.16.8]

Blood-Money

Malik :: Book 43 : Hadith 43.16.8

Yahya related to me from Malik from Hisham ibn Urwa that his father said, "The tribe is not obliged to pay blood-money for intentional murder. They pay blood-money for accidental killing."

Yahya related to me from Malik that Ibn Shihab said, "The precedent of the sunna is that the tribe are not liable for any blood-money of an intentional killing unless they wish that."

Yahya related to me from Malik from Yahya ibn Said the same as that.

Malik said that Ibn Shihab said, "The precedent of the sunna in the intentional murder is that when the relatives of the murdered person relinquish retaliation, the blood-money is owed by the murderer from his own property unless the tribe helps him with it willingly."

Malik said, "What is done in our community is that the blood-money is not obliged against the tribe until it has reached a third of the full amount and upwards. Whatever reaches a third is against the tribe, and whatever is below a third, is against the property of the one who did the injury."

Malik said, "The way of doing things about which there is no dispute among us, in the case of someone who has the blood-money accepted from him in intentional murder or in any injury in which there is retaliation, is that that blood-money is not due from the tribe unless they wish it. The blood-money for that is from the property of the murderer or the injurer if he has property. If he does not have any property, it is a debt against him, and none of it is owed by the tribe unless they wish."

Malik said, "The tribe does not pay blood-money to anyone who injures himself, intentionally or accidentally. This is the opinion of the people of fiqh in our community. I have not heard that anyone has made the tribe liable for any blood-money incurred by intentional acts. Part of what is well-known of that is that Allah, the Blessed, and the Exalted, said in His Book, 'Whoever has something pardoned him by his brother, should follow it with what is accepted and pay it with good will' (Sura 2 ayat 178) The commentary on that - in our view - and Allah knows best, is that whoever gives his brother something of the blood-money, should follow it with what is accepted and pay him with good will."

Malik spoke about a child who had no property and a woman who had no property. He said, "When one of them causes an injury below a third of the blood-money, it is taken on behalf of the child and woman from their personal property, if they have property from which it may be taken. If not, the injury which each of them has caused is a debt against them. The tribe does not have to pay any of it and the father of a child is not liable for the blood-money of an injury caused by the child and he is not responsible for it."

Malik said, "The way of doing things in our community about which there is no dispute, is that when a slave is killed, the value for him is that of the day on which he was killed. The tribe of the murderer is not liable for any of the value of the slave, great or small. That is the responsibility of the one who struck him from his own personal property as far as it covers. If the value of the slave is the blood-money or more, that is against him in his property. That is because the slave is a certain type of goods."


Malik :: Blood-Money :: [43-43.17.9]

Blood-Money

Malik :: Book 43 : Hadith 43.17.9

Yahya related to me from Malik from Ibn Shihab that Umar ibn al-Khattab demanded of the people at Mina, "If anyone has knowledge of blood-money, let him inform me." Ad-Dahhak ibn Sufyan al-Kilabi stood up and said, "The Messenger of Allah, may Allah bless him and grant him peace, wrote to me that the wife of Ashyam ad-Dibabi inherited from the blood-money of her husband." Umar ibn al-Khattab said to him, "Go into the tent until I come to you." When Umar ibn al-Khattab came in, ad-Dahhak told him about it and Umar ibn al-Khattab gave a decision based on that.

Ibn Shihab said, "The killing of Ashyam was accidental."


Malik :: Blood-Money :: [43-43.17.10]

Blood-Money

Malik :: Book 43 : Hadith 43.17.10

Malik related to me from Yahya ibn Said from Amr ibn Shuayb that a man of the Banu Mudlij called Qatada threw a sword at his son and it struck his thigh. The wound bled profusely and he died. Suraqa ibn Jusham came to Umar ibn al-Khattab and mentioned that to him Umar said to him, "At the watering place of Qudayd count one hundred and twenty camels and wait until I come to you." When Umar ibn al-Khattab came to him, he took thirty four-year-old camels, thirty five-year-old camels, and forty pregnant camels from them. Then he said, "Where is the brother of the slain man?" He said, "Here." He said, "Take them. The Messenger of Allah, may Allah bless him and grant him peace, said, 'The killer gets nothing.' "

Malik said that he had heard that Said ibn al-Musayyab and Sulayman ibn Yasar were asked, "Does one deal more harshly in taking the blood-money in the sacred month?" They said, "No. But it is increased in it because of violating the month." It was said to Said, "Does one increase for the wound as one increases for the life?" He said, "Yes."

Malik added, "I think that they meant the same as what Umar ibn al-Khattab did with respect to the blood-money of the Mudliji when he struck his son." (i.e. giving 120 camels instead of 100).


Malik :: Blood-Money :: [43-43.17.11]

Blood-Money

Malik :: Book 43 : Hadith 43.17.11

11 Malik related to me from Yahya ibn Said from Urwa ibn az-Zubayr that a man of the Ansar called Uhayha ibn al-Julah had a young paternal uncle who was younger than him and who was living with his maternal uncles. Uhayha took him and killed him. His maternal uncles said, "We brought him up from a baby to a youth till he stood firm on his feet, and we have had the right of a man taken from us by his paternal uncle." Urwa said, "For that reason a killer does not inherit from the one he killed."

Malik said, "The way of doing things about which there is no dispute is that the intentional murderer does not inherit anything of the blood-money of the person he has murdered or any of his property. He does not stop anyone who has a share of inheritance from inheriting. The one who kills accidentally does not inherit anything of the blood-money and there is dispute as to whether or not he inherits from the dead person's property because there is no suspicion that he killed him for his inheritance and in order to take his property. I prefer that he inherit from the dead person's property and not inherit from the blood-money."


Malik :: Blood-Money :: [43-43.18.12]

Blood-Money

Malik :: Book 43 : Hadith 43.18.12

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab and Abu Salama ibn Abd ar-Rahman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The wound of an animal is of no account and no compensation is due for it. The well is of no account and no compensation is due for it. The mine is of no account and no compensation is due for it and a fifth is due for buried treasures." (Al-kanz: see Book 17).

Malik said, "Everyone leading an animal by the halter, driving it, and riding it is responsible for what the animal strikes unless the animal kicks out without anything being done to it to make it kick out. Umar ibn al-Khattab imposed the blood-money on a person who was exercising his horse."

Malik said, "It is more fitting that a person leading an animal by the halter, driving it, or riding it incur a loss than a person who is exercising his horse." (See hadith 4 of this book).

Malik said, "What is done in our community about a person who digs a well on a road or ties up an animal or does the like of that on a road used by muslims, is that since what he has done is included in that which he is not permitted to do in such a place, he is liable for whatever injury or other thing arises from that action. The blood-money of that which is less than a third of the full blood-money is owed from his own personal property. Whatever reaches a third or more, is owed by his tribe. Any such things that he does which he is permitted to do on the muslims' road are something for which he has no liability or loss. Part of that is a hole which a man digs to collect rain, and the beast from which the man alights for some need and leaves standing on the road. There is no penalty against anyone for this."

Malik spoke about a man who went down a well, and another man followed behind him, and the lower one pulled the higher one and they fell into the well and both died He said, "The tribe of the one who pulled him in is responsible for the blood-money."

Malik spoke about a child whom a man ordered to go down into a well or to climb a palm tree and he died as a result. He said, "The one who ordered him is liable for whatever befalls him, be it death or something else."

Malik said, "The way of doing things in our community about which there is no dispute is that women and children are not obliged to pay blood-money together with the tribe in the blood-moneys which the tribe must pay. The blood-money is only obligatory for a man who has reached puberty."

Malik said that the tribe could bind themselves to the blood-money of mawali if they wished. If they refused, they were people of the diwan or were cut off from their people. In the time of the Messenger of Allah, may Allah bless him and grant him peace, people paid the blood-money to each other as well as in the time of Abu Bakr as-Siddiq before there was a diwan. The diwan was in the time of Umar ibn al-Khattab. No one other than one's people and the ones holding the wala' paid blood-money for one because the wala' was not transferable and because the Prophet, may Allah bless him and grant him peace, said, "The wala' belongs to the one who sets free."

Malik said, "The wala' is an established relationship."

Malik said, "What is done in our community about animals that are injured is that the person who causes the injury pays whatever of their value has been diminished."

Malik said about a man condemned to death and one of the other hudud befell him, "He is not punished for it. That is because the killing overrides all of that, except for slander. The slander remains hanging over the one to whom it was said because it will be said to him, 'Why do you not flog the one who slandered you?' I think that the condemned man is flogged with the hadd before he is killed, and then he is killed. I do not think that any retaliation is inflicted on him for any injury except killing because killing overrides all of that."

Malik said, "What is done in our community is that when a murdered person is found among the main body of a people in a village or other place, the house or place of the nearest people to him is not responsible. That is because the murdered person can be slain and then cast at the door of some people to shame them by it. No one is responsible for the like of that."

Malik said about a group of people who fight with each other and when the fight is broken up, a man is found dead or wounded, and it is not known who did it, "The best of what is heard about that is that there is blood-money for him, and the blood-money is against the people who argued with him. If the injured or slain person is not from either of the two parties, his blood-money is against both of the two parties together."


Malik :: Blood-Money :: [43-43.19.13]

Blood-Money

Malik :: Book 43 : Hadith 43.19.13

Yahya related to me from Malik from Yahya ibn Said from Said ibn al-Musayyab that Umar ibn al-Khattab killed five or seven people for one man whom they had killed secretly by trickery. Umar said, "Had all the people of Sana joined forces against him, I would have killed them all."


Malik :: Blood-Money :: [43-43.19.14]

Blood-Money

Malik :: Book 43 : Hadith 43.19.14

Yahya related to me from Malik from Muhammad ibn Abd ar-Rahman ibn Sad ibn Zurara that he had heard that Hafsa, the wife of the Prophet, may Allah bless him and grant him peace, killed one of her slave-girls who had used sorcery against her. She was a mudabbara. Hafsa gave the order, and she was killed.

Malik said, "The sorcerer is the one who uses sorcery for himself and no one else uses that for him. It is like the one about whom Allah, the Blessed, the Exalted, said in His Book, 'They know the one who devotes himself to it will have no share in the Next World.' (Sura 2 ayat 102) I think that that person is killed if he does that himself."


Malik :: Blood-Money :: [43-43.20.15]

Blood-Money

Malik :: Book 43 : Hadith 43.20.15

Yahya related to me from Malik from Umar ibn Husayn, the mawla of A'isha bint Qudama, that Abd al-Malik ibn Marwan imposed retaliation against a man who killed a mawla with a stick and so the mawla's patron killed the man with a stick.

Malik said, "The generally agreed on way of doing things in our community about which there is no dispute is that when a man strikes another man with a stick or hits him with a rock or intentionally strikes him causing his death, that is an intentional injury and there is retaliation for it."

Malik said, "Intentional murder with us is that a man intentionally goes to a man and strikes him until his life goes. Part of intentional injury also is that a man strikes a man in a quarrel between them. He leaves him while he is alive, and he bleeds to death and so dies. There is retaliation for that."

Malik said, "What is done in our community is that a group of free men are killed for the intentional murder of one free man, and a group of women for one woman, and a group of slaves for one slave."


Malik :: Blood-Money :: [43-43.21.15]

Blood-Money

Malik :: Book 43 : Hadith 43.21.15

Yahya related to me from Malik that he had heard that Marwan ibn al-Hakam wrote to Muawiya ibn Abi Sufyan to mention to him that a drunkard was brought to him who had killed a man. Muawiya wrote to him to kill him in retaliation for the dead man.

Yahya said that Malik said, "The best of what I have heard on the interpretation of this ayat, the word of Allah, the Blessed, the Exalted, 'The free man for the free man and the slave for the slave - these are men and the woman for the woman,' (Sura 2 ayat 178) is that retaliation is between women as it is between men. The free woman is killed for the free woman as the free man is killed for the free man. The slave-girl is slain for the slave-girl as the slave is slain for the slave. Retaliation is between women as it is between men. That is because Allah, the Blessed, the Exalted, said in His Book, 'We have written for them in it that it is a life for a life and an eye for an eye, a nose for a nose, and an ear for an ear, and a tooth for a tooth, and for wounds there is retaliation.' (Sura 5 ayat 48) Allah, the Blessed, the Exalted, mentioned that it is a life for a life. It is the life of a free woman for the life of a free man, and her injury for his injury."

Malik said about a man who held a man fast for another man to hit, and he died on the spot, "If he held him and he thought that he meant to kill him, the two of them are both killed for him. If he held him and he thought that he meant to beat him as people sometimes do, and he did not think that he meant to kill him, the murderer is slain and the one who held him is punished with a very severe punishment and jailed for a year. There is no killing against him."

Malik said about a man who murdered a man intentionally or gouged out his eye intentionally, and then was slain or had his eye gouged out himself before retaliation was inflicted on him, "There is no blood-money nor retaliation against him. The right of the one who was killed or had his eye gouged out goes when the thing which he is claiming as retaliation goes. It is the same with a man who murders another man intentionally and then the murderer dies. When the murderer dies, the one seeking blood-revenge has nothing of blood-money or anything else. That is by the word of Allah, the Blessed the Exalted, 'Retaliation is written for you in killing. The free man for the free man and the slave for the slave.' "

Malik said, "He only has retaliation against the one who killed him. If the man who murdered him dies, he has no retaliation or blood-money."

Malik said, "There is no retaliation held against a free man by a slave for any injury. The slave is killed for the free man when he intentionally murders him. The free man is not slain for the slave, even if he murders him intentionally. It is the best of what I have heard."


Malik :: Blood-Money :: [43-43.22.15]

Blood-Money

Malik :: Book 43 : Hadith 43.22.15

Yahya related to me from Malik that he saw whomever he was satisfied with among the people of knowledge say about a man who willed that his murderer be pardoned when he murdered him intentionally, "That is permitted for him. He is more entitled to the man's blood than any of his relatives after him."

Malik said about a man who pardoned murder, after he had claimed his right and it was obliged for him, "There is no blood-money against the murderer unless the one who pardons him stipulates that when he pardons him."

Malik said about the murderer when he was pardoned, "He is flogged one hundred lashes and jailed for a year."

Malik said, "When a man murders intentionally and there is a clear proof of that, and the murdered man has sons and daughters and the sons pardon and the daughters refuse to pardon, the pardon of the sons is permitted in opposition to the daughters and there is no authority for the daughters with the sons in demanding blood and pardoning."


Malik :: Blood-Money :: [43-43.23.15]

Blood-Money

Malik :: Book 43 : Hadith 43.23.15

Yahya said that Malik said, "The generally agreed on way of doing things in our community is that retaliation is taken from someone who breaks someone's hand or foot intentionally and not blood-money."

Malik said, "Retaliation is not inflicted on anyone until the wound of the injured party has healed. Then retaliation is inflicted on him. If the wound of the person on whom the retaliation has been inflicted is like the first person's wound when it heals, it is retaliation. If the wound of the one on whom the retaliation has been inflicted becomes worse or he dies, there is nothing held against the one who has taken retaliation. If the wound of the person on whom the retaliation has been inflicted heals and the injured party is paralysed or his injury has healed but he has a scar, defect, or blemish, the person on whom the retaliation has been inflicted does not have his hand broken again and further retaliation is not taken for his injury."

He said, "But there is blood-money from him according to what he has impaired or maimed of the hand of the injured party. The bodily injury is also like that."

Malik said, "When a man intentionally goes to his wife and gouges out her eye or breaks her hand or cuts off her finger or such like, and does it intentionally, retaliation is inflicted on him. As for a man who strikes his wife with a rope or a whip and hits what he did not mean to hit or does what he did not intend to do, he pays blood-money for what he has struck according to this principle, and retaliation is not inflicted on him."

Yahya related to me from Malik that he had heard that Abu Bakr ibn Muhammd ibn Amr ibn Hazm took retaliation for the breaking of a leg.


Malik :: Blood-Money :: [43-43.24.15]

Blood-Money

Malik :: Book 43 : Hadith 43.24.15

Yahya related to me from Malik from Abu'z-Zinad from Sulayman ibn Yasar that a slave was set free by one of the people on hajj and his master had abandoned the right to inherit from him. The ex-slave then killed a man from the Banu A'idh tribe. An A'idhi, the father of the slain man came to Umar ibn al-Khattab seeking the blood-money of his son. Umar said, "He has no blood-money." The A'idhi said, "What would you think if it had been my son who killed him?" Umar said, "Then you would pay his blood-money." He said, "He is then like the black and white Arqam snake. If it is left, it devours and if it is killed, it takes revenge."


Malik :: The Oath of Qasama :: [44-44.1.1]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.1.1

Yahya related to me from Malik from Abu Layla ibn Abdullah ibn Abd ar-Rahman ibn Sahl from Sahl ibn Abi Hathma that some of the great men of his people informed him that Abdullah ibn Sahl and Muhayyisa went out to Khaybar because extreme poverty had overtaken them. Muhayyisa returned and said that Abdullah ibn Sahl had been killed and thrown in a shallow well or spring. The jews came and he said, "By Allah! You have killed him." They said, "By Allah! We have not killed him!" Then he made for his people and mentioned that to them. Then he, his brother Huwayyisa, who was older than him, and Abd ar-Rahman, set out. Muhayyisa began to speak, as he had been at Khaybar. The Messenger of Allah, may Allah bless him and grant him peace, said to him, "The greater first, the greater first," meaning in age. So Huwayyisa spoke and then Muhayyisa spoke. The Messenger of Allah, may Allah bless him and grant him peace, said, "Either they pay your companion's blood-money or we will declare war against them." The Messenger of Allah, may Allah bless him and grant him peace, wrote that to them and they wrote, "By Allah, we did not kill him!" The Messenger of Allah, may Allah bless him and grant him peace, said to Huwayyisa, Muhayyisa, and Abd ar-Rahman, "Do you swear and claim the blood of your companion?" They said, "No." He said, "Shall the jews swear to you?" They said, "But they are not muslims." The Messenger of Allah, may Allah bless him and grant him peace, gave blood-money from his own property, and sent them one hundred camels to their house.

Sahl added, "A red camel among them kicked me."


Malik :: The Oath of Qasama :: [44-44.1.2]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.1.2

Yahya said from Malik from Yahya ibn Said that Bushayr ibn Yasar informed him that Abdullah ibn Sahl al-Ansari and Muhayyisa ibn Masud went out to Khaybar, and they separated on their various businesses and Abdullah ibn Sahl was killed. Muhayyisa, and his brother Huwayyisa and Abd ar-Rahman ibn Sahl went to the Prophet, may Allah bless him and grant him peace, and Abd ar-Rahman began to speak before his brother. The Messenger of Allah, may Allah bless him and grant him peace, said, "The older first, the older first.

Therefore Huwayyisa and then Muhayyisa spoke and mentioned the affair of Abdullah ibn Sahl. The Messenger of Allah, may Allah bless him and grant him peace, said to them, "Do you swear with fifty oaths and claim the blood-money of your companion or the life of the murderer?" They said, "Messenger of Allah, we did not see it and we were not present." The Messenger of Allah, may Allah bless him and grant him peace, said, "Will you acquit the jews for fifty oaths?' They said, "Messenger of Allah, how can we accept the oaths of a people who are kafirun?"

Yahya ibn Said said, "Bushayr ibn Yasar claimed that the Messenger of Allah, may Allah bless him and grant him peace, paid the blood-money from his own property."

Malik said, "The generally agreed on way of doing things in our community and that which I heard from whoever I am content with, concerning the oath of qasama, and upon which the past and present imams agree, is that those who claim revenge begin with the oaths and swear. The oath for revenge is only obligatory in two situations. Either the slain person says, 'My blood is against so-and-so,' or the relatives entitled to the blood bring a partial proof of it that is not irrefutable against the one who is the object of the blood-claim. This obliges taking an oath on the part of those who claim the blood against those who are the object of the blood-claim. With us, swearing is only obliged in these two situations."

Malik said, "That is the sunna in which there is no dispute with us and which is still the behaviour of the people. The people who claim blood begin the swearings, whether it is an intentional killing or an accident."

Malik said, "The Messenger of Allah, may Allah bless him and grant him peace, began with Banu Harith in the case of the killing of their kinsman murdered at Khaybar."

Malik said, "If those who make the claim swear, they deserve the blood of their kinsman and whoever they swear against is slain. Only one man can be killed in the qasama. Two cannot be killed in it. Fifty men from the blood-relatives must swear fifty oaths. If their number is less or some of them draw back, they can repeat their oaths, unless one of the relatives of the murdered man who deserves blood and who is permitted to pardon it, draws back. If one of these draws back, there is no way to revenge."

Yahya said that Malik said, "The oaths can be made by those of them who remain if one of them draws back who is not permitted to pardon. If one of the blood-relatives draws back who is permitted to pardon, even if he is only one, more oaths can not be made after that by the blood-relatives. If that occurs, the oaths can be on behalf of the one against whom the claim is made. So fifty of the men of his people swear fifty oaths. If there are not fifty men, more oaths can be made by those of them who already swore. If there is only the defendant, he swears fifty oaths and is acquitted."

Yahya said that Malik said, "One distinguishes between swearing for blood and oaths for one's rights. When a man has a money-claim against another man, he seeks to verify his due. When a man wants to kill another man, he does not kill him in the midst of people. He keeps to a place away from people. Had there only been swearing in cases where there is a clear proof and had one acted in it as one acts about one's rights (i.e. needing witnesses), the right of blood retribution would have been lost and people would have been swift to take advantage of it when they learned of the decision on it. However, the relatives of the murdered man were allowed to initiate swearing so that people might restrain themselves from blood and the murderer might beware lest he was put into a situation like that (i.e. qasama) by the statement of the murdered man.' "

Yahya said, "Malik said about a people of whom a certain number are suspected of murder and the relatives of the murdered man ask them to take oaths and they are numerous, so they ask that each man swears fifty oaths on his own behalf. The oaths are not divided out between them according to their number and they are not acquitted unless each man among them swears fifty oaths on his own behalf."

Malik said, "This is the best I have heard about the matter."

He said, "Swearing goes to the paternal relatives of the slain. They are the blood-relatives who swear against the killer and by whose swearing he is killed."


Malik :: The Oath of Qasama :: [44-44.2.2]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.2.2

Yahya said that Malik said, "The way of doing things in our community about which there is no dispute is that women do not swear in the swearing for the intentional act. If the murdered man only has female relatives, the women have no right to swear for blood and no pardon in murder."

Yahya said that Malik said about a man who is murdered, "If the paternal relatives of the murdered man or his mawali say, 'We swear and we demand our companion's blood,' that is their right."

Malik said, "If the women want to pardon him, they cannot do that. The paternal relatives and mawali are entitled to do that more than them because they are the ones who demand blood and swear for it."

Malik said, "If the paternal relatives or mawali pardon after they demand blood and the women refuse and say, 'We will not abandon our right against the murderer of our companion,' the women are more entitled to that because whoever takes retaliation is more entitled than the one who leaves it among the women and paternal relatives when the murder is established and killing obliged."

Malik said, "At least two claimants must swear in murder. The oaths are repeated by them until they swear fifty oaths, then they have the right to blood. That is how things are done in our community."

Malik said, "When people beat a man and he dies in their hands, they are all slain for him. If he dies after their beating, there is swearing. If there is swearing, it is only against one man and only he is slain. We have never known the swearing to be against more than one man."

Malik spoke about a slave who had his hand or foot broken and then the break mended . He said, "The one who injured him is not obliged to pay anything. If that break causes him loss or scar, the one who injured him must pay according to what he diminished of the value of the slave."

Malik said, "What is done in our community about retaliation between slaves is that it is like retaliation between freemen. The life of the slave-girl for the life of the slave, and her injury for his injury. When a slave intentionally kills a slave, the master of the murdered slave has a choice. If he wishes, he kills him, and if he wishes, he takes the blood-money. If he takes the blood-money, he takes the value of his slave. If the owner of the slave who killed wishes to give the value of the murdered slave, he does it. If he wishes, he surrenders his slave. If he surrenders him, he is not obliged to do anything other than that. When the owner of the murdered slave takes the slave who murdered and is satisifed with him, he must not kill him. All retaliations between slaves for cutting off of the hand and foot and such things are dealt with in the same way as in the murder."

Malik said about a muslim slave who injures a jew or christian, "If the master of the slave wishes to pay blood-money for him according to the injury, he does it. Or else he surrenders him and he is sold, and the jew or christian is given the blood-money of the injury or all the price of the slave if the blood-money is greater than his price. The jew or christian is not given a muslim slave."


Malik :: The Oath of Qasama :: [44-44.3.2]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.3.2

Yahya said that Malik said, "The way of doing things in our community about Yahya said that Malik said, "The procedure in swearing in manslaughter is that those who claim blood swear and it becomes due by their swearing. They swear fifty oaths, and there is blood-money for them according to the division of their inheritances. If it is not possible to divide up the oaths which they swear between them evenly, one looks to the one who has most of those oaths against him, and that oath is obliged against him."

Malik said, "If the slain man only has female heirs, they swear and take the blood-money. If he only has one male heir, he swears fifty oaths and takes the blood-money. That is only in the accidental killing, not in the intentional one."


Malik :: The Oath of Qasama :: [44-44.4.2]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.4.2

Yahya said that Malik said, "When the relatives of the deceased accept the blood-money then it is inherited according to the Book of Allah. Daughters of the dead man inherit and so do sisters, and whichever women would inherit from him ordinarily.

If the women do not take all his inheritance, then what remains goes to the agnatic relations who most deserve to inherit from him in conjunction with the women."

Malik said, "When one of the heirs of a man killed by mistake attempts to take his due from the blood-money while his companions are absent, he may not do that, and he has no right to any of the blood-money, however large or small, unless the qasama has been completed by him. If he swears fifty oaths then he has the right to his portion of the blood-money. That is because the blood-money is not established as due without there being fifty oaths, and the blood-money is not established as due unless the responsibility for the blood is established. If any one of the heirs comes after that he swears a number of the oaths commensurate with his fraction of the inheritance and takes his right until all the heirs exact their complete right. If a maternal uncle comes he has one sixth and must swear one sixth of the fifty oaths. So whoever swears may take his due from the blood-money and whoever abstains annuls his right. If one of the heirs is absent or is a child who has not reached puberty, those who are present swear fifty oaths and if the one who was absent comes after that or the child reaches puberty, they swear. and they swear according to their due of the blood-money and according to their shares of inheritance from it."

Yahya said that Malik said, "This is the best I have heard on the matter."


Malik :: The Oath of Qasama :: [44-44.5.2]

The Oath of Qasama

Malik :: Book 44 : Hadith 44.5.2

Yahya said that Malik said, "What is done in our community about slaves is that when a slave is struck intentionally or accidentally and the master brings a witness, he swears with his witness one oath and then he has the value of the slave. There is no swearing for revenge in slaves, accidentally or intentionally, and I have not heard any of the people of knowledge say that there was."

Malik said, "If a slave is killed intentionally or accidentally, the master of the slave who is slain has no swearing or oath. The master cannot demand his right except with a fair proof or a witness if he swears with one witness."

Yahya said that Malik said, "This is the best of what I have heard on the matter.''


Malik :: Madina :: [45-45.1.1]

Madina

Malik :: Book 45 : Hadith 45.1.1

Yahya ibn Yahya related to me from Ishaq ibn Abdullah ibn Abi Talha al-Ansari from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, said, "O Allah! Bless them in their measure, and bless them in their sa and mudd." He meant the people of Madina.


Malik :: Madina :: [45-45.1.2]

Madina

Malik :: Book 45 : Hadith 45.1.2

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father that Abu Hurayra said, "When people saw the first fruits of the season, they brought them to the Messenger of Allah, may Allah bless him and grant him peace. The Messenger of Allah, may Allah bless him and grant him peace, took them and said, 'O Allah! Bless us in our fruits. Bless us in our city. Bless us in our sa and bless us in our mudd. O Allah! Ibrahim is Your slave, Your Khalil and Your Prophet. I am Your slave and Your Prophet. He prayed to You for Makka. I pray to You for Madina for the like of what He prayed to You for Makka, and the like of it with it.' Then he called the smallest child he saw and gave him the fruits."


Malik :: Madina :: [45-45.2.3]

Madina

Malik :: Book 45 : Hadith 45.2.3

Yahya related to me from Malik from Qatan ibn Wahb ibn Umayr ibn al-Ajda that Yuhannas, the mawla of az-Zubayr ibn al-Awwam informed him that he was sitting with Abdullah ibn Umar during the troubles (at the time of al-Hajaj ibn Yusuf) . A female mawla of his came and greeted him. She said, "I want to leave, Abu Abd ar-Rahman. The time is harsh for us." Abdullah ibn Umar said to her, "Sit down, O you with little knowledge, for I have heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'No one will be patient in hunger and hardship in it (Madina) except that I will be a witness or intercede for him on the Day of Rising.' "


Malik :: Madina :: [45-45.2.4]

Madina

Malik :: Book 45 : Hadith 45.2.4

Yahya related to me from Malik from Muhammad ibn al-Munkadir from Jabir ibn Abdullah that a Bedouin took an oath of allegiance in Islam with the Messenger of Allah, may Allah bless him and grant him peace. A fever befell the Bedouin at Madina. He came to the Messenger of Allah, and said, "Messenger of Allah, release me from my pledge." The Messenger of Allah, may Allah bless him and grant him peace, refused. Then he came to him again and said, "Release me from my pledge." The Messenger of Allah may Allah bless him and grant him peace, refused. Then he came again and said, "Release me from my pledge." He refused. Then he came again and said, "Release me from my pledge." He refused. The Bedouin left and the Messenger of Allah, may Allah bless him and grant him peace, said, "Madina is like the blacksmith's furnace. It removes the impurities and purifies the good."


Malik :: Madina :: [45-45.2.5]

Madina

Malik :: Book 45 : Hadith 45.2.5

Malik related to me that Yahya ibn Said said, "I heard Abu'l-Hubab Said ibn Yasar say that he heard Abu Hurayra say that he heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'I was ordered to a town which will eat up towns. They used to say, 'Yathrib,' but it is Madina. It removes the bad people like the blacksmith's furnace removes impurities from the iron.' "


Malik :: Madina :: [45-45.2.6]

Madina

Malik :: Book 45 : Hadith 45.2.6

Malik related to me from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "No one leaves Madina preferring to live elsewhere, but that Allah will give it better than him in place of him ."


Malik :: Madina :: [45-45.2.7]

Madina

Malik :: Book 45 : Hadith 45.2.7

Malik related to me from Hisham ibn Urwa from his father from Abdullah ibn az-Zubayr that Sufyan ibn Abi Zuhayr said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Yemen will be conquered and the people will be attracted to it, taking their families and whoever obeys them. Madina would have been better for them, had they but known. Ash-Sham will be conquered and people will be attracted to it, taking their families and whoever obeys them. Madina would have been better for them, had they but known. Iraq will be conquered and people will be attracted to it, taking their families and whoever obeys them. Madina would have been better for them, had they but known.' "


Malik :: Madina :: [45-45.2.8]

Madina

Malik :: Book 45 : Hadith 45.2.8

Yahya related to me from Malik from Ibn Himas from his paternal uncle from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Madina will be left in the best way that it is until a dog or wolf enters it and urinates on one of the pillars of the mosque or on the mimbar." They asked, "Messenger of Allah! Who will have the fruit at that time?" He replied, "Animals seeking food, birds and wild beasts."


Malik :: Madina :: [45-45.2.9]

Madina

Malik :: Book 45 : Hadith 45.2.9

Malik related to me that he had heard that when Umar ibn Abd al-Aziz left Madina, he turned towards it and wept. Then he said, "O Muzahim! Do you fear that we might be among those that Madina casts off?"


Malik :: Madina :: [45-45.3.10]

Madina

Malik :: Book 45 : Hadith 45.3.10

Yahya related to me from Malik from Amr, the mawla of al-Muttalib from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, saw Uhud and said, "This is a mountain which loves us and we love it. O Allah! Ibrahim made Makka Haram, and I will make what is between the two tracts of black stones (in Madina) a Haram."


Malik :: Madina :: [45-45.3.11]

Madina

Malik :: Book 45 : Hadith 45.3.11

Malik related to me from Ibn Shihab from Said ibn al-Musayyab that Abu Hurayra said, "Had I seen a gazelle at Madina, I would have left it to graze and would not have frightened it. The Messenger of Allah, may Allah bless him and grant him peace, said, 'What is between the two tracts of black stones is a Haram.' "


Malik :: Madina :: [45-45.3.12]

Madina

Malik :: Book 45 : Hadith 45.3.12

Malik related to me from Yunus ibn Yusuf from Ata ibn Yasar that Abu Ayyub al-Ansari found some boys who had driven a fox into a corner, and he chased them away from it.

Malik said, "I only know that he said, 'Is this done in the Haram of the Messenger of Allah, may Allah bless him and grant him peace?' "


Malik :: Madina :: [45-45.3.13]

Madina

Malik :: Book 45 : Hadith 45.3.13

Yahya related to me from Malik from a man who said, "Zayd ibn Thabit came across me while I was at al-Aswaf (on the outskirts of Madina). I had captured a hawk. He took it from my hands and set it free."


Malik :: Madina :: [45-45.4.14]

Madina

Malik :: Book 45 : Hadith 45.4.14

Yahya related to me from Malik from Hisham ibn Urwa from his father that A'isha, umm al-muminin said, "When the Messenger of Allah, may Allah bless him and grant him peace, came to Madina, Abu Bakr and Bilal came down with a fever. I visited them and said, 'Father, how are you? Bilal, how are you?'" She continued, "When Abu Bakr's fever worsened he would say, 'Every man is struck down among his people in the morning - death is nearer than the strap of his sandal.'"

When it left Bilal, he raised his voice and said, 'Would that I knew whether I will spend a night at the valley of Makka with the idhkhir herb and jalil herb around me. Will I go one day to the waters of Majinna? Will the mountains of Shama and Tafil appear to me?' " '

A'isha continued, "I went to the Messenger of Allah, may Allah bless him and grant him peace, and informed him. He said, 'O Allah! Make us love Madina as much as we love Makka or even more. Make it sound and bless us in our sa and mudd. Remove its fever and put it in al-Juhfa.' "


Malik :: Madina :: [45-45.4.15]

Madina

Malik :: Book 45 : Hadith 45.4.15

Malik said that Yahya ibn Said had related to him that A'isha said that Amir ibn Fuhayra had said at the time of the epidemic, "I have seen death before tasting it, the coward's destination is from above him."


Malik :: Madina :: [45-45.4.16]

Madina

Malik :: Book 45 : Hadith 45.4.16

Yahya related to me from Malik from Nuaym ibn Abdullah al-Mujmir that Abu Hurayra said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'There are angels at the entries of Madina, and neither plague nor the Dajjal will enter it.' "


Malik :: Madina :: [45-45.5.17]

Madina

Malik :: Book 45 : Hadith 45.5.17

Yahya related to me from Malik from Ismail ibn Abi Hakim that he heard Umar ibn Abd al-Aziz say, "One of the last things that the Messenger of Allah, may Allah bless him and grant him peace, said was, 'May Allah fight the jews and the christians. They took the graves of their Prophets as places of prostration . Two deens shall not co-exist in the land of the Arabs.' "


Malik :: Madina :: [45-45.5.18]

Madina

Malik :: Book 45 : Hadith 45.5.18

Yahya related to me from Malik from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, said, "Two deens shall not co-exist in the Arabian Peninsula."

Malik said that Ibn Shihab said, ''Umar ibn al-Khattab searched for information about that until he was absolutely convinced that the Messenger of Allah, may Allah bless him and grant him peace, had said, 'Two deens shall not co-exist in the Arabian Peninsula,' and he therefore expelled the jews from Khaybar."


Malik :: Madina :: [45-45.5.19]

Madina

Malik :: Book 45 : Hadith 45.5.19

Malik said, ''Umar ibn al-Khattab expelled the jews from Najran (a jewish settlement in the Yemen) and Fadak (a jewish settlement thirty miles from Madina). When the jews of Khaybar left, they did not take any fruit or land. The jews of Fadak took half the fruit and half the land, because the Messenger of Allah, may Allah bless him and grant him peace, had made a settlement with them for that. So Umar entrusted to them the value in gold, silver, camels, ropes and saddle bags of half the fruit and half the land, and handed the value over to them and expelled them."


Malik :: Madina :: [45-45.6.20]

Madina

Malik :: Book 45 : Hadith 45.6.20

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, came in view of Uhud and said, "This is a mountain which loves us and we love it."


Malik :: Madina :: [45-45.6.21]

Madina

Malik :: Book 45 : Hadith 45.6.21

Yahya related to me from Malik from Yahya ibn Said from Abd ar-Rahman ibn al-Qasim that Aslam, the mawla of Umar ibn al-Khattab informed him that he had visited Abdullah ibn Ayyash al-Makhzumi. He saw that he had some nabidh with him and he was at that moment on the way to Makka. Aslam said to him, ''Umar ibn al-Khattab loves this drink." Abdullah ibn Ayyash therefore carried a great drinking bowl and brought it to Umar ibn al-Khattab and placed it before him. Umar brought it near to him and then raised his head. Umar said, "This drink is good," so he drank some of it and then passed it to a man on his right. When Abdullah turned to go, Umar ibn al-Khattab called him and asked, "Are you the person who says that Makka is better than Madina?" Abdullah said, "I said that it was the Haram of Allah, and His place of security, and His House was in it." Umar said, "I am not saying anything about the House of Allah or His Haram." Then Umar repeated "Are you the person who says that Makka is better than Madina?" He replied, "I said that it was the Haram of Allah and His place of security, and His House was in it." Umar said, "I am not saying anything about the House of Allah and His Haram." Then Abdullah left.


Malik :: Madina :: [45-45.7.22]

Madina

Malik :: Book 45 : Hadith 45.7.22

Yahya related to me from Malik from Ibn Shihab from Abd al-Hamid ibn Abd ar-Rahman ibn Zayd ibn al-Khattab from Abdullah ibn Abdullah ibn al-Harith ibn Nawfal from Abdullah ibn Abbas that Umar ibn al-Khattab set out for ash Sham and when he was at Sargh, near Tabuk, the commanders of the army, Abu Ubayda ibn al-Jarrah and his companions, met him and told him that the plague had broken out in ash-Sham. Ibn Abbas said, "Umar ibn al-Khattab said, 'all the first Muhajir unto me.' He assembled them and asked them for advice, informing them that the plague had broken out in ash Sham. They disagreed. Some said, 'You have set out for something, and we do not think that you should leave it.' Others said, 'You have the companions of the Prophet, may Allah bless him and grant him peace, and the rest of the people with you, and we do not think that you should send them towards this plague.' Umar said, 'Leave me.'

Then he said, 'Summon the Ansar to me.' They were summoned and he asked them for advice. They acted as the Muhajirun had and disagreed as they had disagreed. He said, 'Leave me.' "Then he said, 'Summon to me whoever is here of the aged men of Quraysh from the Muhajirun of the conquest.' He summoned them and not one of them differed. They said, 'We think that you should withdraw the people and not send them towards the plague.' Umar called out to the people, 'I am leaving by camel in the morning,' so they set out. Abu Ubayda said, 'Is it flight from the decree of Allah?' Umar said, 'Better that someone other than you had said it, Abu Ubayda. Yes. We flee from the decree of Allah to the decree of Allah. What would you think if these camels had gone down into a valley which had two slopes, one of them fertile, and the other barren. If you pastured in the fertile part, wouldn't you pasture them by the decree of Allah? If you pastured them in the barren part, wouldn't you pasture them by the decree of Allah?'

''Abd ar-Rahman ibn Awf arrived and he had been off doing something and he said, 'I have some knowledge of this. I heard the Messenger of Allah, may Allah bless him and grant him peace, say, "If you hear about it in a land, do not go forward to it. If it comes upon a land and you are in it, then do not depart in flight from it." ' Umar praised Allah and then set off."


Malik :: Madina :: [45-45.7.23]

Madina

Malik :: Book 45 : Hadith 45.7.23

Yahya related to me from Malik from Muhammad ibn al-Munkadir and from Salim ibn Abi'n-Nadr, the mawla of Umar ibn Ubaydullah that Amir ibn Sad ibn Abi Waqqas heard his father ask Usama ibn Zayd, "Have you heard anything from the Messenger of Allah, may Allah bless him and grant him peace, about the plague?" Usama said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'The plague is a punishment that was sent down on a party of the Banu Israil or whoever was before them. When you hear of it in a land, do not enter it. If it comes upon a land and you are in it, do not depart in flight from it.' "

Malik said that Abu'n-Nadr said, "That is, do not depart with no other intention but flight."


Malik :: Madina :: [45-45.7.24]

Madina

Malik :: Book 45 : Hadith 45.7.24

Yahya related to me from Malik from Ibn Shihab from Abdullah ibn Amir ibn Rabia that Umar ibn al-Khattab went out to ash-Sham. When he came to Sargh, near Tabuk, he heard that the plague had broken out in ash-Sham. Abd ar-Rahman ibn Awf told him that the Messenger of Allah, may Allah bless him and grant him peace, said, "If you hear that a land has a plague in it, do not go forward to it. If it comes upon a land which you are in, do not depart in flight from it." Umar ibn al-Khattab came back from Sargh.


Malik :: Madina :: [45-45.7.25]

Madina

Malik :: Book 45 : Hadith 45.7.25

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah that Umar ibn al-Khattab turned people back at Sargh according to the hadith of Abd ar-Rahman ibn Awf.


Malik :: Madina :: [45-45.7.26]

Madina

Malik :: Book 45 : Hadith 45.7.26

Yahya related to me that Malik said, "I heard that Umar ibn al-Khattab said, 'A night in Rukba (a valley near Taif,) is more preferable to me than ten nights in ash-Sham.' "

Malik said, "He meant to lengthen and preserve their lives because of the severity of the plague in ash-Sham ."


Malik :: The Decree :: [46-46.1.1]

The Decree

Malik :: Book 46 : Hadith 46.1.1

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Adam and Musa argued and Adam got the better of Musa. Musa rebuked Adam, 'You are Adam who led people astray and brought them out of the Garden.' Adam said to him, 'You are Musa to whom Allah gave knowledge of everything and whom he chose above people with His message.' He said, 'Yes.' He said, 'Do you then censure me for a matter which was decreed for me before I was created?' "


Malik :: The Decree :: [46-46.1.2]

The Decree

Malik :: Book 46 : Hadith 46.1.2

Yahya related to me from Malik from Zayd ibn Abi Unaysa that Abd al-Hamid ibn Abd ar-Rahman ibn Zayd ibn al-Khattab informed him from Muslim ibn Yasar al-Juhani that Umar ibn al-Khattab was asked about this ayat - "When your Lord took their progeny from the Banu Adam from their backs and made them testify against themselves. 'Am I not your Lord?' They said, 'Yes, we bear witness'

Lest you should say on the Day of Rising, 'We were heedless of that.'" (Sura 7 ayat 172) Umar ibn al-Khattab said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, being asked about it. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Allah, the Blessed, the Exalted, created Adam. Then He stroked his back with His right hand, and progeny issued from it. He said, "I created these for the Garden and they will act with the behaviour of the people of the Garden." Then He stroked his back again and brought forth progeny from him. He said, "I created these for the Fire and they will act with the behaviour of the people of the Fire." 'A man said, 'Messenger of Allah! Then of what value are deeds?' The Messenger of Allah, may Allah bless him and grant him peace, answered, 'When Allah creates a slave for the Garden, he makes him use the behaviour of the people of the Garden, so that he dies on one of the actions of the people of the Garden and by it He brings him into the Garden. When He creates a slave for the Fire, He makes him use the behaviour of the people of the Fire, so that he dies on one of the actions of the people of the Fire, and by it, He brings him into the Fire.' "


Malik :: The Decree :: [46-46.1.3]

The Decree

Malik :: Book 46 : Hadith 46.1.3

Yahya related to me from Malik that he heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "I have left two matters with you. As long as you hold to them, you will not go the wrong way. They are the Book of Allah and the Sunna of His Prophet."


Malik :: The Decree :: [46-46.1.4]

The Decree

Malik :: Book 46 : Hadith 46.1.4

Yahya related to me from Malik from Ziyad ibn Sad from Amr ibn Muslim that Tawus al-Yamani said, "I found some of the companions of the Messenger of Allah, may Allah bless him and grant him peace, saying 'Everything is by decree.' " Tawus added, "I heard Abdullah ibn Umar say that The Messenger of Allah, may Allah bless him and grant him peace. said, 'Everything is by decree - even incapacity and ability,' (or 'ability and incapacity')."


Malik :: The Decree :: [46-46.1.5]

The Decree

Malik :: Book 46 : Hadith 46.1.5

Malik related to me from Ziyad ibn Sad that Amr ibn Dinar said, "I heard Abdullah ibn az-Zubayr say in a khutba, 'Allah - He is the Guider and the One Who Tempts Away.' "


Malik :: The Decree :: [46-46.1.6]

The Decree

Malik :: Book 46 : Hadith 46.1.6

Yahya related to me from Malik that his paternal uncle, Abu Suhayl ibn Malik said, "I was a prisoner with Umar ibn Abd al-Aziz. He said, 'What do you think about these Qadariyya (fatalists)?' I said, 'My opinion is that one should ask them to turn from wrong action, if they will do so. If not, subject them to the sword.' Umar ibn Abd al-Aziz said, 'That is my opinion.

Malik added, "That is my opinion also."


Malik :: The Decree :: [46-46.2.7]

The Decree

Malik :: Book 46 : Hadith 46.2.7

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A woman should not ask for the divorce of her sister to make her plate empty and in order to marry. She has what is decreed for her."


Malik :: The Decree :: [46-46.2.8]

The Decree

Malik :: Book 46 : Hadith 46.2.8

Yahya related to me from Malik from Yazid ibn Ziyad that Muhammad ibn Kab al-Quradhi said, ''Muawiya ibn Abi Sufyan said from the mimbar, 'O people! Nothing keeps away what Allah gives and nothing gives what Allah keeps away. The earnestness of the earnest one does not profit him. When Allah desires good for him, he gives him understanding in the deen.' Then Muawiya said, 'I heard these words from the Messenger of Allah, may Allah bless him and grant him peace, on these blocks of wood.' "


Malik :: The Decree :: [46-46.2.9]

The Decree

Malik :: Book 46 : Hadith 46.2.9

Yahya related to me from Malik that he had heard that this was said "Praise be to Allah who created everything as is necessary, who does not hasten anything He defers and determines. Allah is enough for me and sufficient. Allah hears whoever makes dua to him. Allah does not have a goal."


Malik :: The Decree :: [46-46.2.10]

The Decree

Malik :: Book 46 : Hadith 46.2.10

Yahya related to me from Malik that he heard that this was said "No one will die until his provision is completed for him, so behave correctly in your seeking it."


Malik :: Good Character :: [47-47.1.1]

Good Character

Malik :: Book 47 : Hadith 47.1.1

Yahya related to me from Malik that Muadh ibn Jabal said, "The last advice the Messenger of Allah, may Allah bless him and grant him peace, gave me when I put my foot in the stirrup was that he said, 'Make your character good for the people, Muadh ibn Jabal!' "


Malik :: Good Character :: [47-47.1.2]

Good Character

Malik :: Book 47 : Hadith 47.1.2

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, did not have to choose between two matters, but that he chose the easier of them as long as it was not a wrong action. If it was a wrong action, he was the furthest of people from it. The Messenger of Allah, may Allah bless him and grant him peace, did not take revenge for himself unless the limits of Allah were violated. Then he took revenge for it for Allah."


Malik :: Good Character :: [47-47.1.3]

Good Character

Malik :: Book 47 : Hadith 47.1.3

Yahya related to me from Malik from Ibn Shihab from Ali ibn Husayn ibn Ali ibn Abi Talib that the Messenger of Allah, may Allah bless him and grant him peace, said, "Part of the excellence of a man's Islam is that he leaves what does not concern him."


Malik :: Good Character :: [47-47.1.4]

Good Character

Malik :: Book 47 : Hadith 47.1.4

Yahya related to me from Malik that he had heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, said, "A man asked permission to come in to see the Messenger of Allah, may Allah bless him and grant him peace. I was with him in the house and the Messenger of Allah, may Allah bless him and grant him peace, said, 'He is an evil member of his tribe.' Then the Messenger of Allah, may Allah bless him and grant him peace, gave him permission."

A'isha continued, "It was not long before I heard the Messenger of Allah, may Allah bless him and grant him peace, laughing with him. When the man left, I said, 'Messenger of Allah, you said what you said about him, and then before long you were laughing with him.' The Messenger of Allah, may Allah bless him and grant him peace, replied, 'Among the most evil of people is the one whom people are cautious with because of his evil.' "


Malik :: Good Character :: [47-47.1.5]

Good Character

Malik :: Book 47 : Hadith 47.1.5

Yahya related to me from Malik from his paternal uncle, Abu Suhayl ibn Malik from his father that Kab al-Ahbar said, "If you want to know what a slave has with his Lord, then look at whatever good praise follows him."


Malik :: Good Character :: [47-47.1.6]

Good Character

Malik :: Book 47 : Hadith 47.1.6

Yahya related to me from Malik that Yahya ibn Said said, "I have heard that by his good character a man can reach the degree of the one who stands in prayer at night and the one who is thirsty from fasting in the heat of the day."


Malik :: Good Character :: [47-47.1.7]

Good Character

Malik :: Book 47 : Hadith 47.1.7

Yahya related to me from Malik that Yahya ibn Said said that he heard Said ibn al-Musayyab say, "Shall I tell you what is better than much prayer and sadaqa?" They said, "Yes." He said, "Mending discord. And beware of hatred - it strips you (of your deen)."


Malik :: Good Character :: [47-47.1.8]

Good Character

Malik :: Book 47 : Hadith 47.1.8

Yahya related to me from Malik that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "I was sent to perfect good character."


Malik :: Good Character :: [47-47.2.9]

Good Character

Malik :: Book 47 : Hadith 47.2.9

Yahya related to me from Malik from Salama ibn Safwan ibn Salama az-Zuraqi that Zayd ibn Talha ibn Rukana, who attributed it to the Prophet, may Allah bless him and grant him peace, said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Every deen has an innate character. The character of Islam is modesty.' "


Malik :: Good Character :: [47-47.2.10]

Good Character

Malik :: Book 47 : Hadith 47.2.10

Yahya related to me from Malik from Ibn Shihab from Salim ibn Abdullah from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, passed by a man who was chiding his brother about modesty. The Messenger of Allah, may Allah bless him and grant him peace, said, "Leave him. Modesty is part of iman."


Malik :: Good Character :: [47-47.3.11]

Good Character

Malik :: Book 47 : Hadith 47.3.11

Malik related to me from Ibn Shihab from Humayd ibn Abd ar-Rahman ibn Awf that a man came to the Messenger of Allah, may Allah bless him and grant him peace, and said, "Messenger of Allah, teach me some words which I can live by. Do not make them too much for me, lest I forget." The Messenger of Allah, may Allah bless him and grant him peace, said, "Do not be angry."


Malik :: Good Character :: [47-47.3.12]

Good Character

Malik :: Book 47 : Hadith 47.3.12

Yahya related to me from Malik from Ibn Shihab from Said ibn al-Musayyab from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A strong person is not the person who throws his adversaries to the ground. A strong person is the person who contains himself when he is angry."


Malik :: Good Character :: [47-47.4.13]

Good Character

Malik :: Book 47 : Hadith 47.4.13

Yahya related to me from Malik from Ibn Shihab from Ata ibn Yazid al-Laythi from Abu Ayyub al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, said, "It is not halal for a muslim to shun his brother for more than three nights, that is they meet, and this one turns away and that one turns away. The better of the two is the one who says the greeting first."


Malik :: Good Character :: [47-47.4.14]

Good Character

Malik :: Book 47 : Hadith 47.4.14

Yahya related to me from Malik from Ibn Shihab from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not be angry with each other and do not envy each other and do not turn away from each other, and be slaves of Allah, brothers. It is not halal for a muslim to shun his brother for more than three nights."


Malik :: Good Character :: [47-47.4.15]

Good Character

Malik :: Book 47 : Hadith 47.4.15

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Beware of suspicion. Suspicion is the most untrue speech. Do not spy and do not eavesdrop. Do not compete with each other and do not envy each other and do not hate each other and do not shun each other. Be slaves of Allah, brothers."


Malik :: Good Character :: [47-47.4.16]

Good Character

Malik :: Book 47 : Hadith 47.4.16

Yahya related to me from Malik from Ata ibn Abi Muslim that Abdullah al-Khurasani said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Shake hands and rancour will disappear. Give presents to each other and love each other and enmity will disappear.' "


Malik :: Good Character :: [47-47.4.17]

Good Character

Malik :: Book 47 : Hadith 47.4.17

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The doors of the Garden are opened on Monday and Thursday. Every muslim slave who does not associate anything with Allah is forgiven except for the man who has enmity between him and his brother. It is said, 'Leave these two until they have made a reconciliation. Leave these two until they have made a reconciliation.' "


Malik :: Good Character :: [47-47.4.18]

Good Character

Malik :: Book 47 : Hadith 47.4.18

Yahya related to me from Malik from Muslim ibn Abi Maryam from Abu Salih as-Samman that Abu Hurayra said, "The actions of people are presented twice each week, on Monday and Thursday. Every trusting slave is forgiven except for a slave who has enmity between him and his brother. It is said, 'Leave these two until they turn in tawba. Leave these two until they turn in tawba.' ''


Malik :: Dress :: [48-48.1.1]

Dress

Malik :: Book 48 : Hadith 48.1.1

Yahya related to me from Malik from Zayd ibn Aslam that Jabir ibn Abdullah al-Ansari said, "We went out with the Messenger of Allah, may Allah bless him and grant him peace, in the raid on the Banu Ammar tribe." Jabir said, "I was resting under a tree when the Messenger of Allah, may Allah bless him and grant him peace, came. I said, 'Messenger of Allah; come to the shade.' So the Messenger of Allah, may Allah bless him and grant him peace, sat down, and I stood up and went to a sack of ours. I looked in it for something and found a small cucumber and broke it. Then I brought it to the Messenger of Allah, may Allah bless him and grant him peace. He said, 'From where did you get this?' I said, 'We brought it from Madina, Messenger of Allah.' "

Jabir continued, "We had a friend of ours with us whom we used to equip to go out to guard our mounts. I gave him what was necessary and then he turned about to go to the mounts and he was wearing two threadbare cloaks of his. The Messenger of Allah, may Allah bless him and grant him peace, looked at him and said, 'Does he have two garments other than these?' I said, 'Yes, Messenger of Allah. He has two garments in the bag.' I gave them to him. He said, 'Let him go and put them on.' I let him go to put them on. As he turned to go, the Messenger of Allah, may Allah bless him and grant him peace, exclaimed, 'May Allah strike his neck. Isn't that better for him?' He said (taking him literally), 'Messenger of Allah, in the way of Allah.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'In the way of Allah.' " Jabir added, "The man was killed in the way of Allah."


Malik :: Dress :: [48-48.1.2]

Dress

Malik :: Book 48 : Hadith 48.1.2

Yahya related to me from Malik that he heard that Umar ibn al-Khattab said, "I love to look at a Qur'an reader in white garments."


Malik :: Dress :: [48-48.1.3]

Dress

Malik :: Book 48 : Hadith 48.1.3

Yahya related to me from Malik from Ayyub ibn Abi Tamim that Ibn Sirin said, ''Umar ibn al-Khattab said, 'Allah has been generous to you, so be generous to yourselves. Let a man wear a combination of his garments.' "


Malik :: Dress :: [48-48.2.4]

Dress

Malik :: Book 48 : Hadith 48.2.4

Yahya related to me from Malik from Nafi that Abdullah ibn Umar wore garments dyed with red earth and dyed with saffron.

Yahya said that he heard Malik say, "I disapprove of youths wearing any gold because I heard that the Messenger of Allah, may Allah bless him and grant him peace, forbade wearing gold rings, and I disapprove of it for males old or young."

Yahya said, "I heard Malik say about men wearing wraps dyed with safflower in their houses and courtyards, 'I do not know that any of that is haram but I prefer other garments than that.' "


Malik :: Dress :: [48-48.3.5]

Dress

Malik :: Book 48 : Hadith 48.3.5

Malik related to me from Hisham ibn Urwa from his father that A'isha the wife of the Prophet, may Allah bless him and grant him peace, dressed Abdullah ibn az-Zubayr in a shawl of silk which A'isha used to wear.


Malik :: Dress :: [48-48.4.6]

Dress

Malik :: Book 48 : Hadith 48.4.6

Yahya related to me from Malik from Alqama ibn Abi Alqama that his mother said, "Hafsa bint Abd ar-Rahman visited A'isha, the wife of the Prophet, may Allah bless him and grant him peace, and Hafsa was wearing a long thin head scarf A'isha tore it in two and made a wide one for her."


Malik :: Dress :: [48-48.4.7]

Dress

Malik :: Book 48 : Hadith 48.4.7

Yahya related to me from Malik from Muslim ibn Abi Maryam from Abu Salih that Abu Hurayra said, "Women who are naked even though they are wearing clothes, go astray and make others go astray, and they will not enter the Garden and they will not find its scent, and its scent is experienced from as far as the distance travelled in five hundred years."


Malik :: Dress :: [48-48.4.8]

Dress

Malik :: Book 48 : Hadith 48.4.8

Yahya related to me from Malik from Yahya ibn Said from Ibn Shihab that the Messenger of Allah, may Allah bless him and grant him peace, stood up in the night and looked at the horizon of the sky. He said, "What treasures has the night opened? What trials have occurred? How many are dressed in this world and will be naked on the Day of Rising. Warn the women in their rooms."


Malik :: Dress :: [48-48.5.9]

Dress

Malik :: Book 48 : Hadith 48.5.9

Yahya related to me from Malik from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "A person who drags his garment in arrogance will not be looked at by Allah on the Day of Rising."


Malik :: Dress :: [48-48.5.10]

Dress

Malik :: Book 48 : Hadith 48.5.10

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "On the Day of Rising, Allah the Blessed, the Exalted, will not look at a person who drags his lower garment in arrogance."


Malik :: Dress :: [48-48.5.11]

Dress

Malik :: Book 48 : Hadith 48.5.11

Yahya related to me from Malik from Nafi and Abdullah ibn Dinar and Zayd ibn Aslam that all of them informed him from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "On the Day of Rising, Allah will not look at a person who drags his garment in arrogance."


Malik :: Dress :: [48-48.5.12]

Dress

Malik :: Book 48 : Hadith 48.5.12

Yahya related to me from Malik from al Ala ibn Abd ar-Rahman that his father said, "I asked Abu Said al-Khudri about the lower garment. He said that he would inform me with knowledge and that he had heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'The lower garment of the mumin should reach to the middle of his calves. There is no harm in what is between that and the ankles. What is lower than that is in the Fire. What is lower than that is in the Fire. On the Day of Rising, Allah will not look at a person who trails his lower garment in arrogance.' "


Malik :: Dress :: [48-48.6.13]

Dress

Malik :: Book 48 : Hadith 48.6.13

Yahya related to me from Malik from Abu Bakr ibn Nafi from his father Nafi, the mawla of Ibn Umar that Safiyya bint Abi Ubayd informed him that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said that when the lower garment of women was mentioned to the Messenger of Allah, he said, "She lets it down a handspan." Umm Salama said, "If it leaves her uncovered?" He said, "Then the length of a forearm and let her not increase it."


Malik :: Dress :: [48-48.7.14]

Dress

Malik :: Book 48 : Hadith 48.7.14

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Do not wear one sandal. Wear both of them or go with both feet bare."


Malik :: Dress :: [48-48.7.15]

Dress

Malik :: Book 48 : Hadith 48.7.15

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you put on sandals, begin with the right foot. When you take them off, begin with the left foot. The right foot is the first to be put in the sandal and the last to be taken out."


Malik :: Dress :: [48-48.7.16]

Dress

Malik :: Book 48 : Hadith 48.7.16

Yahya related to me from Malik from his paternal uncle Abu Suhayl ibn Malik from his father that Kab al-Ahbar said to a man who took off his sandals, "Why have you taken off your sandals? Perhaps you have interpreted this ayat, 'Remove your sandals. You are in the pure valley of Tuwa?' (Sura 20 ayat 12) Do you know what the sandals of Musa were?"

Malik (the father of Abu Suhayl) said, "I do not know what the man answered." Kab said, "They were made from the skin of a dead donkey."


Malik :: Dress :: [48-48.8.17]

Dress

Malik :: Book 48 : Hadith 48.8.17

Yahya related to me from Malik from Abu'z-Zinad from al-Araj that Abu Hurayra said, "The Messenger of Allah, may Allah bless him and grant him peace, forbade two sales. Mulamasa, in which a man is obliged to buy whatever he touches without any choice in the matter, and munabadha, in which two men throw their garment to each other without either seeing the other's garment. He also forbade two ways of dressing. One in which a man sits with his legs drawn up to his chest wrapped in one garment that does not cover his genitals, and the other in which a man wraps a single garment over one arm and shoulder restricting them."


Malik :: Dress :: [48-48.8.18]

Dress

Malik :: Book 48 : Hadith 48.8.18

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that Umar ibn al-Khattab saw a silk robe at the door of the mosque. He said, "Messenger of Allah, would you buy this robe and wear it on jumua and when envoys come to you?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Only a person who has no portion in the next world wears this." Then the Messenger of Allah, may Allah bless him and grant him peace, was brought some robes of the same material and gave Umar ibn al-Khattab one of the robes. Umar said, "Messenger of Allah, do you clothe me in it when you said what you said about the robe of Utarid?" The Messenger of Allah, may Allah bless him and grant him peace, said, "I did not give it to you to wear." Umar gave it to a brother of his in Makka who was still an idolater.


Malik :: Dress :: [48-48.8.19]

Dress

Malik :: Book 48 : Hadith 48.8.19

Yahya related to me from Malik that Ishaq ibn Abdullah ibn Abi Talha said, "Anas ibn Malik said, 'I saw Umar ibn al-Khattab when he was the amir of Madina. Three patches were sewn between his shoulders, one patched over the other.' ''


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.1.1]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.1.1

Yahya related to me from Malik that Rabia ibn Abi Abd ar-Rahman heard Anas ibn Malik say, "The Messenger of Allah, may Allah bless him and grant him peace, was not excessively tall or short. He was not very pallid nor dark. He did not have curly hair or lank hair. Allah commissioned him at the age of forty. He stayed in Makka ten years and at Madina for ten years and Allah the Mighty, the Majestic made him die when he was sixty. There were not twenty white hairs in his hair or beard, may Allah bless him and grant him peace."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.2.2]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.2.2

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "I dreamt at night that I was at the Kaba, and I saw a dark man like the most handsome of dark men you have ever seen. He had hair reaching to between his ears and his shoulders like the most excellent of such hair that you have seen. He had combed his hair, and water was dripping from it. He was leaning on two men or on the shoulders of two men doing tawaf around Kaba. I asked, 'Who is this?' It was said, 'al-Masih ibn Maryam.' Then we were with a man with wiry hair and blind in his right eye, as if it was a floating grape. I asked 'Who is this?' It was said to me, 'This is al-Masih ad-Dajjal.' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.3.3]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.3.3

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi from his father that Abu Hurayra said, "There are five things from the fitra: cutting the nails, trimming the moustache, removing the hair from the armpit, shaving the pubic region and circumcision."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.3.4]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.3.4

Yahya related to me from Malik from Yahya ibn Said that Said ibn al-Musayyub said, "Ibrahim, may Allah bless him and grant him peace, was the first to give hospitality to the guest and the first person to be circumcised and the first person to trim the moustache and the first person to see grey hair. He said, 'O Lord! What is this?' Allah the Blessed, the Exalted, said, 'It is dignity, Ibrahim.' He said, 'Lord, increase me in dignity!' "

Yahya said that he had heard Malik say, "One takes from the moustache until the edge of the lip appears, that is the rim. One does not cut if off completely so that one mutilates oneself."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.4.5]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.4.5

Yahya related to me from Malik from Abu'z-Zubayr from Jabir ibn Abdullah as-Salami that the Messenger of Allah, may Allah bless him and grant him peace, forbade a man to eat with his left hand or walk in one sandal or wrap a single garment around his drawn-up legs exposing his genitals.


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.4.6]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.4.6

Yahya related to me from Malik from Ibn Shihab from Abu Bakr ibn Ubaydullah ibn Abdullah ibn Umar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you eat, eat with your right hand and drink with your right hand. Shaytan eats with his left hand and drinks with his left hand."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.5.7]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.5.7

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The very poor are not the people who constantly walk from person to person and are given one or two morsels, and one or two dates." They said, "Who are the very poor, Messenger of Allah?" He said, "People who do not find enough for themselves and other people are not aware of them to give sadaqa to them, and they do not start begging from other people."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.5.8]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.5.8

Yahya related to me from Malik from Zayd ibn Aslam from Ibn Bujayd (formerly al-Ansari) from his grandmother that the Messenger of Allah, may Allah bless him and grant him peace, said, "Give to the very poor, if only a roasted hoof."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.6.9]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.6.9

Yahya related to me from Malik from Abu'z-Zinad from al-Araj that Abu Hurayra said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'The muslim eats in one intestine, and the kafir eats in seven!' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.6.10]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.6.10

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, gave hospitality to a kafir guest. The Messenger of Allah, may Allah bless him and grant him peace, ordered a sheep to be brought for him and it was milked. He drank its milk. Then another came, and he drank it. Then another came and he drank it until he had drunk the milk of seven sheep. In the morning he became muslim, and the Messenger of Allah, may Allah bless him and grant him peace, ordered a sheep for him. It was milked and he drank its milk. Then he ordered another for him and he could not finish it. The Messenger of Allah, may Allah bless him and grant him peace, said, "The mumin drinks in one intestine, and the kafir drinks in seven intestines."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.7.11]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.7.11

Yahya related to me from Malik from Nafi from Zayd ibn Abdullah ibn Umar ibn al-Khattab from Abdullah ibn Abd ar-Rahman ibn Abi Bakras-Siddiq from Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, said, "A person who drinks from a silver vessel brings the fire of Jahannam into his belly."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.7.12]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.7.12

Yahya related to me from Malik from Ayyub ibn Habib, the mawla of Sad ibn Abi Waqqas that Abu'l-Muthanna al-Juhani said, "I was with Marwan ibn al-Hakam and Abu Said al-Khudri came to him. Marwan ibn al-Hakam said to him, 'Have you heard that the Messenger of Allah, may Allah bless him and grant him peace, forbade blowing into drinks?' Abu Said said to him, 'Yes.' A man said to him, 'Messenger of Allah, I am not quenched from one breath.' The Messenger of Allah, may Allah bless him and grant him peace, said to him, 'Remove the cup from your mouth and then breathe.' He said, 'Sometimes I see something floating in it?' He said, 'Then pour it out.'"


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.8.13]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.8.13

Yahya related to me from Malik that he had heard that Umar ibn al-Khattab and Ali ibn Abi Talib and Uthman ibn Affan drank while standing.


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.8.14]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.8.14

Yahya related to me from Malik from Ibn Shihab that A'isha, umm al-muminin and Sad ibn Abi Waqqas did not see any harm in a man drinking while standing.


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.8.15]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.8.15

Yahya related to me from Malik that Abu Jafar al-Qari said, "I saw Abdullah ibn Umar drink while standing."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.8.16]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.8.16

Yahya related to me from Malik from Amir ibn Abdullah ibn az-Zubayr that his father used to drink while standing.


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.9.17]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.9.17

Yahya related to me from Malik from Ibn Shihab from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, was brought some milk which was mixed with well-water. There was a Bedouin at his right side and Abu Bakr as-Siddiq on his left. He drank and then gave it to the Bedouin and said, "The right-hand to the right-hand."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.9.18]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.9.18

Yahya related to me from Malik from Abu Hazim ibn Dinar from Sahl ibn Sad al-Ansari that the Messenger of Allah, may Allah bless him and grant him peace, was brought a drink and he drank some of it. There was a boy at his right and some old men on his left. He said to the boy, "Will you give me permission to give it to these people?" The boy said, "No, Messenger of Allah, I will not prefer anyone to get my portion from you." He said, "So the Messenger of Allah, may Allah bless him and grant him peace, placed it in his hand."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.19]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.19

Yahya related to me from Malik that Ishaq ibn Abdullah ibn Abi Talha heard Anas ibn Malik say that Abu Talha had said to Umm Sulaym, "I have just been listening to the Messenger of Allah, may Allah bless him and grant him peace, and his voice was very weak. I recognised hunger in it, so, do you have anything?" She replied, "Yes," and brought out some barley loaves. She took her long head scarf and wrapped up the bread with part of it and put it into my (Anas's) hand and gave me part of it to wear. Then she sent me to the Messenger of Allah, may Allah bless him and grant him peace."

Anas continued, "I took it, and I found the Messenger of Allah, may Allah bless him and grant him peace, sitting in the mosque with some people. I watched them. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Did Abu Talha send you?' I replied, 'Yes.' He said, 'For food?' I said, 'Yes.' The Messenger of Allah, may Allah bless him and grant him peace, said to those with him, 'Let us go.' He set off and I went among them until I came to Abu Talha and told him. Abu Talha said, 'Umm Sulaym! The Messenger of Allah, may Allah bless him and grant him peace, has brought people and we have no food. What shall we give them to eat?' She said, 'Allah and His Messenger know best.' "

Anas continued, "Abu Talha went out and met the Messenger of Allah, may Allah bless him and grant him peace, and the Messenger of Allah, may Allah bless him and grant him peace, approached with Abu Talha until they entered. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Come now, Umm Sulaym, what have you got?' She brought out bread. The Messenger of Allah, may Allah bless him and grant him peace, ordered it to be broken into pieces, and Umm Sulaym squeezed out onto it a container of clarified butter which she had seasoned. Then the Messenger of Allah, may Allah bless him and grant him peace, said whatever Allah wished him to say, and said, 'Will you give permission for ten of them to come in?' He gave them permission, and they ate until they were full and then left. He said, 'Give permission to ten more.' He gave them permission, and they ate until they were full and left. Then he said, 'Give permission to ten more.' He gave them permission and they ate until they were full and left. Then he said, 'Give permission to ten more.' He gave permission and they ate until they were full and left. There were seventy or eighty men."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.20]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.20

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The food of two is enough for three, and the food of three is enough for four."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.21]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.21

Yahya related to me from Malik from Abu'z-Zubayr al-Makki from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, said, "Lock the door, tie the waterskin, turn the vessel over or cover it, and put out the lamp. Shaytan does not open a locked door or untie a tied knot, or uncover a vessel. A mouse may set fire to people's houses about them."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.22]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.22

Yahya related to me from Malik from Said ibn Abi Said al-Maqburi from Abu Shurayh al-Kabi that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever believes in Allah and the Last Day should speak good or be silent. Whoever believes in Allah and the Last Day should be generous to his neighbour. Whoever believes in Allah and the Last Day, should be generous to his guest. His welcome is for a day and a night, and his hospitality is for three days. Whatever is more than that is sadaqa. It is not halal for a guest to stay with a man until he becomes a burden."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.23]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.23

Yahya related to me from Malik from Sumayy, the mawla of Abu Bakr from Abu Salih as-Samman from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "A man was walking on a road when he became very thirsty. He found a well and went into it and drank and came out. There was a dog panting and eating earth out of thirst. The man said, 'This dog has become as thirsty as I was.' He went down into the well and filled his shoe and then held it in his mouth until he climbed out and gave the dog water to drink. Allah thanked him for it and forgave him." They said, "Messenger of Allah, do we have a reward for taking care of beasts?" He said, "There is a reward for every one with a moist liver."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.24]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.24

Yahya related to me from Malik from Wahb ibn Kaysan that Jabir ibn Abdullah said, "The Messenger of Allah, may Allah bless him and grant him peace, sent a delegation to the coast. Abu Ubayda ibn al-Jarrah was in command of them. There were 300 people and I was among them. We went out until we had gone part of the way and our provisions were finished. Abu Ubayda ordered that the provisions of the army be gathered up and they amounted to two containers of dates. He used to give us a little provision from it each day until it was finished, and we used to have only a single date each. I said, 'What use is one date?' He said, 'We will certainly feel its loss when they are finished.' "

Jabir continued, "Then we reached the sea and there was a fish like a small mountain. The army ate from it for eighteen nights. Then Abu Ubayda ordered two ribs from it to be set up. Then he commanded that a camel be ridden underneath them and it did not touch them."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.25]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.25

Yahya related to me from Malik from Zayd ibn Aslam from Amr ibn Sad ibn Muadh from his grandmother that the Messenger of Allah, may Allah bless him and grant him peace, said, "O trusting women, none of you must consider even a roasted sheep's trotter too small to give to her neighbour."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.26]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.26

Yahya related to me from Malik that Abdullah ibn Abi Bakr said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'May Allah curse the jews! They were forbidden to eat fat, so they sold it and ate its price.' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.27]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.27

Yahya related to me from Malik that he had heard that Isa ibn Maryam used to say, "O Banu Israil! You must drink pure water and the green things of the land and barley bread . Beware of wheat bread, for you will not be grateful enough for it."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.28]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.28

Yahya related to me from Malik that he heard that the Messenger of Allah, may Allah bless him and grant him peace, entered the mosque and found Abu Bakr as-Siddiq and Umar ibn al-Khattab there. He questioned them and they said, "Hunger has driven us out." The Messenger of Allah, may Allah bless him and grant him peace, said, "And hunger has brought me out." They went to Abu'l-Haytham ibn at-Tayyihan al-Ansari. He ordered that some barley that was in the house be prepared and he got up to slaughter a sheep for them. The Messenger of Allah, may Allah bless him and grant him peace, said, "Leave the one with milk." He slaughtered a sheep for them and brought them sweet water and it was hung on a palm-tree. Then they were brought the food and ate it and drank the water. The Messenger of Allah, may Allah bless him and grant him peace, recited, "Then, on that day, you will be asked concerning pleasure." (Sura 102 ayat 8).


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.29]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.29

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab was eating bread with ghee. He summoned one of the desert people and he began to eat and follow the grease in the dish with a morsel of bread. Umar said, "It is as if you were poor." He said, "By Allah. I have not eaten ghee nor have I seen food with it since such-and-such a time." Umar declared, "I shall not eat clarified butter until people are given life again like they were first given life," (i.e. on the Day of Rising.)


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.30]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.30

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik said, "I saw Umar ibn al-Khattab when he was amir al-muminin being given a sa of dates, and he ate all of them, even the inferior ones."

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar said, ''Umar ibn al-Khattab was asked about locusts. He said, 'I would like to have a basket of them, from which we could eat.' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.31]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.31

Yahya related to me from Malik from Muhammad ibn Amr ibn Halhala that Humayd ibn Malik ibn Khu'haym said, "I was sitting with Abu Hurayra on his land at al-Aqiq. Some people rode out from Madina to call upon Abu Hurayra. He told me to go to his mother, sending his greetings and asking her to prepare some food." Humayd continued, "She set down three loaves on a plate and some oil and salt. Then she put it on my head and I carried it to them. When I set it before them, Abu Hurayra said, 'Allah is greater' and added, 'Praise be to Allah who has filled us with bread after our food had previously been only water and dates,' as the people did not touch any of the food.

When they left, he said, 'O son of my brother, be good to your sheep and wipe the mucus from them and clean their pen. Pray in their quarter for they are among the animals of the Garden. By He in Whose Hand my self is, a time is about to come upon people when a small group of sheep will be more beloved to their owner than the house of Marwan . ' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.32]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.32

Yahya related to me from Malik from Abu Nuaym that Wahb ibn Kaysan said, "The Messenger of Allah, may Allah bless him and grant him peace, was brought food while his stepson Umar ibn Salama was with him. The Messenger of Allah, may Allah bless him and grant him peace, said to him, 'Say "Bismillah," and eat what is in front of you.' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.33]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.33

Yahya related to me from Malik that Yahya ibn Said said that he had heard al-Qasim ibn Muhammad say that a man came to Abdullah ibn Abbas and said to him, "I have an orphan and he has camels. Can I drink from the camels' milk?" Ibn Abbas said, "If you search for the lost camels of his and treat the camels' mange and fill in the cracks in their water basin and give it water on the day it drinks, then drink it without doing harm to the suckling camels by milking them excessively."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.34]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.34

Yahya related to me from Malik from Hisham ibn Urwa that his father never brought food or drink, nor even a remedy which he ate or drank but that he said, "Praise be to Allah who has guided us and fed us and given us to drink and blessed us. Allah is greater. O Allah! We have found Your blessing with every evil, give us every good in the morning and evening. We ask You for its completion and its gratitude. There is no good except Your good. There is no god other than You, the God of the salihun and the Lord of the Worlds. Praise be to Allah. There is no god but Allah. What Allah wills. There is no power except in Allah. O Allah! Bless us in what You have provided us with and protect us from the punishment of the Fire!"

Al-hamdu lillahi-lladhi hadana wa at amana wa saqana wa naamana. Allahu akbar. Allahumma'l fatna nimatik bi-kulli sharr. Fa asbahna minha wa amsayna bi-kulli khayr. Nasaluka tamamaha wa shukraha. La khayr illa khayruk. Wa la ilaha ghayruk. Ilaha'-saliheen wa rabba'l-alameen. Al-hamdu lillah. Wa la ilaha illa'llah. Ma sha'Allah. Wa la quwwata illa billah. Allahumma barik lana fima razaqtana. Waqina adhaba'n-nar.


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.35]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.35

Yahya said that Malik was asked, "Can a woman eat with other than her relative or slave?" Malik said, "There is no harm in that if it is in a manner which is accepted for a woman to eat with men."

Malik said, "A woman sometimes eats with her husband and with others he dines with or with her brother in the same way. It is disapproved of for a woman to be alone with a man when there is no relationship between them by blood, marriage or suckling that would prevent him marrying her."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.10.36]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.10.36

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab said, "Beware of meat. It has addictiveness like the addictiveness of wine."

Yahya related to me from Malik from Yahya ibn Said that Umar ibn al-Khattab saw Jabir ibn Abdullah carrying some meat. He said, "What is this?" He said, "Amir al-muminin. We desired meat and I bought some meat for a dirham." Umar said, "Does one of you want to fill his belly apart from his neighbour or nephew? How can you overlook this ayat? 'You squandered your good things in the life of this world and sought comfort in them.' " (Sura 46 ayat 20).


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.11.37]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.11.37

Yahya related to me from Malik from Abdullah ibn Dinar from 'Abdullah ibn 'Umar that the Messenger of Allah, may Allah bless him and grant him peace, used to wear a gold ring. Then the Messenger of Allah, may Allah bless him and grant him peace, stood up and threw it away and said, "I will never wear it." He said, "So the people threw away their rings."


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.11.38]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.11.38

Yahya related to me from Malik that Sadaqa ibn Yasar said, "I asked Said ibn al-Musayyab about wearing a ring. He said, 'Wear it, and tell people that I gave you that decision.' "


Malik :: The Description of the Prophet, may Allah Bless Him and Grant Him Peace :: [49-49.12.39]

The Description of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 49 : Hadith 49.12.39

Yahya related to me from Malik from Abdullah ibn Abi Bakr from Abbad ibn Tamim that Abu Bashir al-Ansari told him that he was with the Messenger of Allah, may Allah bless him and grant him peace, on one of his journeys. He related, "The Messenger of Allah, may Allah bless him and grant him peace, sent a messenger." (Abdullah ibn Abi Bakr said, (I think that he said it was while the people were in their resting place.) He said, "Do not let a single-string necklace, or any necklace, remain unbroken on the neck of a camel."

Yahya said, "I heard Malik say, 'I think that was because of the evil eye.' ''


Malik :: The Evil Eye :: [50-50.1.1]

The Evil Eye

Malik :: Book 50 : Hadith 50.1.1

Yahya related to me from Malik that Muhammad ibn Abi Umama ibn Sahl ibn Hunayf heard his father say, "My father, Sahl ibn Hunayf did a ghusl at al-Kharrar. He removed the jubbah he had on while Amir ibn Rabia was watching, and Sahl was a man with beautiful white skin. Amir said to him, 'I have never seen anything like what I have seen today, not even the skin of a virgin.' Sahl fell ill on the spot, and his condition grew worse. Somebody went to the Messenger of Allah, may Allah bless him and grant him peace, and told him that Sahl was ill, and could not go with him. The Messenger of Allah, may Allah bless him and grant him peace, came to him, and Sahl told him what had happened with Amir. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Why does one of you kill his brother? Why did you not say, "May Allah bless you?" (ta baraka-llah) The evil eye is true. Do wudu from it.' Amir did wudu from it and Sahl went with the Messenger of Allah, may Allah bless him and grant him peace, and there was nothing wrong with him."


Malik :: The Evil Eye :: [50-50.1.2]

The Evil Eye

Malik :: Book 50 : Hadith 50.1.2

Malik related to me from Ibn Shihab that Abu Umama ibn Sahl ibn Hunayf said, ''Amir ibn Rabia saw Sahl ibn Hunayf doing a ghusl and said, 'I have not seen the like of what I see today, not even the skin of a maiden who has never been out of doors.' Sahl fell to the ground. The Messenger of Allah, may Allah bless him and grant him peace, was approached and it was said, 'Messenger of Allah, can you do anything about Sahl ibn Hunayf? By Allah, he can not raise his head.' He said, 'Do you suspect anyone of it?' They said, 'We suspect Amir ibn Rabia.' "

He continued, "The Messenger of Allah, may Allah bless him and grant him peace, summoned Amir and was furious with him and said, 'Why does one of you kill his brother? Why did you not say, "May Allah bless you?" Do ghusl for it.' Amir washed his face, hands, elbows, knees, the end of his feet, and inside his lower garment in a vessel. Then he poured it over him, and Sahl went off with the people, and there was nothing wrong with him."


Malik :: The Evil Eye :: [50-50.2.3]

The Evil Eye

Malik :: Book 50 : Hadith 50.2.3

Yahya related to me from Malik that Humayd ibn Qays al-Makki said, "A man came to the Messenger of Allah, may Allah bless him and grant him peace, with the two sons of Jafar ibn Abi Talib. He said to their nursemaid, 'Why do I see them so thin?' Their nursemaid said, 'Messenger of Allah, the evil eye goes quickly to them. Nothing stops us from asking someone to make incantations (using ayats of Qur'an) for them, except that we do not know what of that would agree with you.' The Messenger of ,Allah, may Allah bless him and grant him peace, said, 'Make incantations for them. Had anything been able to precede the decree, the evil eye would precede it.' "


Malik :: The Evil Eye :: [50-50.2.4]

The Evil Eye

Malik :: Book 50 : Hadith 50.2.4

Yahya related to me from Malik from Yahya ibn Said from Sulayman ibn Yasar that Urwa ibn az-Zubayr told him that the Messenger of Allah, may Allah bless him and grant him peace, entered the house of Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace. There was a child weeping in the house, and they told him that it was from the evil eye. Urwa said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Why do you not find someone to make an incantation to protect it from the evil eye?' "


Malik :: The Evil Eye :: [50-50.3.5]

The Evil Eye

Malik :: Book 50 : Hadith 50.3.5

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "When the slave is ill, Allah ta'ala sends two angels to him." He said, "They look at what he says to his visitors. If he praises Allah and lauds Him, when they come to him, they take that up to Allah, the Mighty, the Majestic, and He knows best, and He says, 'If I make my slave die, I will make him enter the Garden. If I heal him, I will replace his flesh with better flesh and his blood with better blood and I will efface his evil actions.'"


Malik :: The Evil Eye :: [50-50.3.6]

The Evil Eye

Malik :: Book 50 : Hadith 50.3.6

Yahya related to me from Malik from Yazid ibn Khusayfa that Urwa ibn az-Zubayr said that he heard A'isha, the wife of the Prophet, may Allah bless him and grant him peace, say, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'When a mumin is afflicted by something, even a thorn, it removes (or effaces) his wrong actions.' " Yazid did not know which of them Urwa said.


Malik :: The Evil Eye :: [50-50.3.7]

The Evil Eye

Malik :: Book 50 : Hadith 50.3.7

Yahya related to me from Malik that Muhammad ibn Abdullah ibn Abi Sasaca said that he heard Abu'l-Hubab Said ibn Yasar say that he had heard Abu Hurayra say, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Allah afflicts the one for whom He desires good.'"


Malik :: The Evil Eye :: [50-50.3.8]

The Evil Eye

Malik :: Book 50 : Hadith 50.3.8

Yahya related to me from Malik from Yahya ibn Said that death came to a man in the time of the Messenger of Allah, may Allah bless him and grant him peace. A man said, "He was fortunate," as he had died without being tried by illness. The Messenger of Allah, may Allah bless him and grant him peace, said, "Alas for you, what will let you know that if Allah had tried him with illness, He would have wiped out his wrong actions."


Malik :: The Evil Eye :: [50-50.4.9]

The Evil Eye

Malik :: Book 50 : Hadith 50.4.9

Yahya related to me from Malik from Yazid ibn Khusayfa that Amr ibn Abdullah ibn Kab as-Salami told him that Nafi ibn Jubayr told him that Uthman ibn Abi al-As came to the Messenger of Allah, may Allah bless him and grant him peace. Uthman said that he had a pain which was enough to kill him. The Messenger of Allah, may Allah bless him and grant him peace, said, "Rub it with your right hand seven times and say, 'I take refuge with the might of Allah and His power from the evil of what I feel.' "

Uthman added, "I said that, and Allah removed what I had. I still command my family and others to say it."


Malik :: The Evil Eye :: [50-50.4.10]

The Evil Eye

Malik :: Book 50 : Hadith 50.4.10

Yahya related to me from Malik from Ibn Shihab from Urwa ibn az-Zubayr from A'isha that the Messenger of Allah, may Allah bless him and grant him peace, when he had a complaint, would recite the last three suras of Qur'an, over himself and blow. She said, "When his pain was great, I would recite it over him and wipe him with his right hand hoping for its blessing."


Malik :: The Evil Eye :: [50-50.4.11]

The Evil Eye

Malik :: Book 50 : Hadith 50.4.11

Yahya related to me from Malik from Yahya ibn Said from Amra bint Abd ar-Rahman that Abu Bakr as-Siddiq visited A'isha while she had a [health] complaint and a jewish woman was making incantation (ruqya) for her. Abu Bakr said, "Do it (incantation) with the Book of Allah."


Malik :: The Evil Eye :: [50-50.5.12]

The Evil Eye

Malik :: Book 50 : Hadith 50.5.12

Yahya related to me from Malik from Zayd ibn Aslam that a man received a wound in the time of the Messenger of Allah, may Allah bless him and grant him peace. The blood clotted in the wound and the man called two men from the Banu Ammar tribe. They looked at it and claimed that the Messenger of Allah, may Allah bless him and grant him peace, said to them, "Which of you is the better doctor?" They said, "Is there any good in medicine, Messenger of Allah?" Zayd claimed that the Messenger of Allah, may Allah bless him and grant him peace, said, "The one who sent down the disease sent down the remedy."


Malik :: The Evil Eye :: [50-50.5.13]

The Evil Eye

Malik :: Book 50 : Hadith 50.5.13

Yahya related to me from Malik that Yahya ibn Said said, "I heard that Sad ibn Zurara cauterized himself because of a pain in the throat accompanied by blood and he died."


Malik :: The Evil Eye :: [50-50.5.14]

The Evil Eye

Malik :: Book 50 : Hadith 50.5.14

Yahya related to me from Malik from Nafi that Abdullah ibn Umar cauterized for the palsy and he had a talisman made for a scorpion sting.


Malik :: The Evil Eye :: [50-50.6.15]

The Evil Eye

Malik :: Book 50 : Hadith 50.6.15

Yahya related to me from Malik from Hisham ibn Urwa from Fatima bint al-Mundhir that whenever a woman who had a fever, was brought to Asma bint Abi Bakr, she made dua for her and took water and poured it inside her collar. She said, "The Messenger of Allah, may Allah bless him and grant him peace, ordered us to cool it with water."


Malik :: The Evil Eye :: [50-50.6.16]

The Evil Eye

Malik :: Book 50 : Hadith 50.6.16

Yahya related to me from Malik from Hisham ibn Urwa from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "Fever is from the vehemence of the heat of Jahannam, so cool it with water."

Malik related to me from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Fever is from the vehemence of the heat of Jahannam, so put it out with water."


Malik :: The Evil Eye :: [50-50.7.17]

The Evil Eye

Malik :: Book 50 : Hadith 50.7.17

Yahya related to me from Malik that he had heard from Jabir ibn Abdullah that the Messenger of Allah, may Allah bless him and grant him peace, said, "When a man visits an invalid, he plunges into mercy to the extent that when he sits with him, it settles in him," or the like of that.


Malik :: The Evil Eye :: [50-50.7.18]

The Evil Eye

Malik :: Book 50 : Hadith 50.7.18

Yahya related to me from Malik that he had heard from Bukayr ibn Abdullah ibn al-Ashajj from Ibn Atiya that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is no contagion, no hama and no serpent in a hungry belly. However, the possessor of sick livestock must not stop at the same place as the possessor of healthy livestock, but the possessor of healthy livestock may stop wherever he wishes."

They said, "Messenger of Allah, Why is that?" The Messenger of Allah, may Allah bless him and grant him peace, said, "It is harmful."


Malik :: Hair :: [51-51.1.1]

Hair

Malik :: Book 51 : Hadith 51.1.1

Yahya related to me from Malik from Abu Bakr ibn Nafi from his father Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, ordered the moustache to be trimmed and the beard to be left.


Malik :: Hair :: [51-51.1.2]

Hair

Malik :: Book 51 : Hadith 51.1.2

Yahya related to me from Malik from Ibn Shihab that Humay ibn Abd ar-Rahman ibn Awf heard Muawiya ibn Abi Sufyan say from the mimbar in the year that he performed the hajj, holding a lock of hair (i.e. a hairpiece) which he took from one of his guards, "People of Madina! Where are your learned men? I heard the Messenger of Allah, may Allah bless him and grant him peace, forbid the like of this, saying, 'The Banu Israil were destroyed when their women started to use this.' "


Malik :: Hair :: [51-51.1.3]

Hair

Malik :: Book 51 : Hadith 51.1.3

Yahya related to me from Malik that Ziyad ibn Sad heard Ibn Shihab say, "The Messenger of Allah, may Allah bless him and grant him peace, let his hair hang down his forehead as Allah willed, and afterwards he parted it."

Malik said, "There is no harm in a man's looking at the hair of his son's wife or the hair of his wife's mother."


Malik :: Hair :: [51-51.1.4]

Hair

Malik :: Book 51 : Hadith 51.1.4

Yahya related to me from Malik from Nafi that Abdullah ibn Umar disapproved of castration and said, "The completeness of the created form is in the testicles."


Malik :: Hair :: [51-51.1.5]

Hair

Malik :: Book 51 : Hadith 51.1.5

Yahya related to me from Malik that Safwan ibn Sulaym heard that the Prophet, may Allah bless him and grant him peace, said, "I and the one who guards the orphan, whether for himself or for someone else, will be like these two in the Garden, when he has taqwa," indicating his middle and index fingers.


Malik :: Hair :: [51-51.2.6]

Hair

Malik :: Book 51 : Hadith 51.2.6

Yahya related to me from Malik from Yahya ibn Said that Abu Qatada al-Ansari said to the Messenger of Allah, may Allah bless him and grant him peace, "I have a lot of hair which comes down to my shoulders, shall I comb it?'' The Messenger of Allah. may Allah bless him and grant him peace, said, "Yes, and honour it." Sometimes Abu Qatada oiled it twice in one day because the Messenger of Allah, may Allah bless him and grant him peace, said to him. "Honour it."


Malik :: Hair :: [51-51.2.7]

Hair

Malik :: Book 51 : Hadith 51.2.7

Yahya related to me from Malik from Zayd ibn Aslam that Ata ibn Yasar told him that the Messenger of Allah, may Allah bless him and grant him peace, was in the mosque when a man came in with dishevelled hair and beard. The Messenger of Allah. may Allah bless him and grant him peace, motioned with his hand that he should be sent out to groom his hair and beard. The man did so and then returned. The Messenger of Allah, may Allah bless him and grant him peace, said, "Isn't this better than that one of you should come with his head dishevelled, as if he were a shaytan?"


Malik :: Hair :: [51-51.3.8]

Hair

Malik :: Book 51 : Hadith 51.3.8

Yahya related to me from Malik that Yahya ibn Said said that Muhammad ibn Ibrahim at-Taymi had informed him that Abu Salama ibn Abd ar-Rahman said "Abd ar-Rahman ibn al-Aswad ibn Abdal-Yaghuth used to sit with us and he had a white beard and hair. One day he came to us and he had dyed them red, and the people said to him, 'This is better.' He said. 'A'isha the wife of the Prophet, may Allah bless him and grant him peace, sent her slave girl Nukhayla to me yesterday. She swore that my hair would be dyed and she informed me that Abu Bakr as-Siddiq used to dye his hair.' "

Yahya said that he heard Malik say about dyeing the hair black, 'I have not heard anything certain on that, and other colours than that are preferable to me."

Yahya said, "Not to dye at all is permitted, Allah willing, and there is no constraint on people concerning it."

Yahya said that he had heard Malik say, "There is no clear indication in this hadith that the Messenger of Allah, may Allah bless him and grant him peace, did not dye his hair. Had the Messenger of Allah, may Allah bless him and grant him peace, dyed his hair, A'isha would have sent a message to that effect to Abd ar-Rahman ibn al-Aswad."


Malik :: Hair :: [51-51.4.9]

Hair

Malik :: Book 51 : Hadith 51.4.9

Yahya related to me from Malik that Yahya ibn Said said that he had heard that Khalid ibn al-Walid said to the Messenger of Allah, may Allah bless him and grant him peace, "I have nightmares." The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Say, 'I seek refuge with the complete words of Allah from His anger and His punishment and the evil of His slaves, and from the evil suggestions of the shayatin and from their being present (at death).' "

Audhu bi kalimati' llahi't-tammati min ghadabihi wa iqabihi wa sharri ibadihi wa min hamazati' sh-shayatin wa an yahdurun.


Malik :: Hair :: [51-51.4.10]

Hair

Malik :: Book 51 : Hadith 51.4.10

Yahya related to me from Malik that Yahya ibn Said said, "When the Messenger of Allah, may Allah bless him and grant him peace, was taken on the Night Journey, he saw an evil jinn seeking him with a torch of fire. Whenever the Messenger of Allah, may Allah bless him and grant him peace, turned, he saw him. Jibril said to him, 'Shall I teach you some words to say? When you say them, his torch will be put out and will fall from him.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Yes, indeed.' Jibril said, 'Say, 'I seek refuge with the Noble Face of Allah and with the complete words of Allah which neither the good person nor the corrupt can exceed, from the evil of what descends from the sky and the evil of what ascends in it, and from the evil of what is created in the earth and the evil of what comes out of it, and from the trials of the night and day, and from the visitations of the night and day, except for one that knocks with good, O Merciful!" "'

Audhu bi wajhi'llahi' l-karim wa bi kalimati'llahi't-tammati. Allati la yujawazu hunna barra wa la fajir, min sharri ma yanzil min as-sama, wa sharri ma yaruju fiha, wa sham ma dhara' fi'l-ard, wa sharri ma yakhruju minha, wa min fitani'l-layli wa'n-nahar, wa min tawariqi'l-layli wa'n-nahar illa tariqan yatruq bikhayr ya Rahman!


Malik :: Hair :: [51-51.4.11]

Hair

Malik :: Book 51 : Hadith 51.4.11

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that a man of the Aslam tribe said, "I did not sleep last night." The Messenger of Allah, may Allah bless him and grant him peace, said to him, "For what reason?" He said, "A scorpion bit me." The Messenger of Allah, may Allah bless him and grant him peace, said, "Had you said in the evening, 'I seek refuge with the complete words of Allah from the evil of what He has created, 'it would not have happened."

Audhu bi kalimati'llahi't-tammati min sharri ma khalaq .


Malik :: Hair :: [51-51.4.12]

Hair

Malik :: Book 51 : Hadith 51.4.12

Yahya related to me from Malik from Summayy, the mawla of Abu Bakr from al-Qa'qa ibn Hakim that Kab al-Ahbar said, "Had it not been for some words which I said, the jews would have made me into a donkey." Someone asked him what they were. He said, "I seek refuge with the immense Face of Allah - there is nothing greater than it - and with the complete words of Allah which neither the good person nor the corrupt can exceed and with all the most beautiful names of Allah, what I know of them and what I do not know, from the evil of what He has created and originated and multiplied."

Audhu bi wajhi'llahi l-adheem aladhee laysa shay'un adham minh, wa bi kalimati'llahi't-tammati, alatee la yujawizu hunna barra wa la fajir, wa bi asma'illahi'l-husna kulliha ma alamtu minha wa ma lam alam, min sharri ma khalaqa wa bara'a wa dhara'a.


Malik :: Hair :: [51-51.5.13]

Hair

Malik :: Book 51 : Hadith 51.5.13

Yahya related to me from Malik from Abdullah ibn Abd ar-Rahman ibn Mamar from Abu'l-Hubab Said ibn Yasar that Abu Hurayra said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'Allah, the Blessed, the Exalted, will say on the Day of Rising, "Where are those who loved each other for My majesty? Today I will shade them in My shade on the day when there is no shade except My shade." "'


Malik :: Hair :: [51-51.5.14]

Hair

Malik :: Book 51 : Hadith 51.5.14

Yahya related to me from Malik from Khubayb ibn Abd ar-Rahman al-Ansari from Hafs ibn Asim that either Abu Said al-Khudri or Abu Hurayra said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'There are seven whom Allah will shade in His shade on the day on which there is no shade except His shade: a just imam, a youth who grows up worshipping Allah, a man whose heart is attached to the mosque when he leaves it until he returns to it, two men who love each other in Allah and meet for that and part for that, a man who remembers Allah when he is alone and his eyes overflow with tears, a man who refuses the approaches of a noble, beautiful woman, saying "I fear Allah," and a man who gives sadaqa and conceals it so that his left hand does not know what his right hand gives.' "


Malik :: Hair :: [51-51.5.15]

Hair

Malik :: Book 51 : Hadith 51.5.15

Yahya related to me from Malik from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "If Allah loves a slave, he says to Jibril, 'I love so-and-so, so love him,' so Jibril loves him and then calls out to the people of heaven, 'Allah loves so-and-so, so love him,' and the people of heaven love him, and then acceptance is placed in the Earth for him." When Allah is angry with a slave, Malik said, "I consider that he says the like of that about His anger."

Yahya related to me from Malik from Abu Hazim ibn Dinar that Abu Idris al-Khawlani said, "I entered the Damascus mosque and there was a young man with a beautiful mouth and white teeth sitting with some people. When they disagreed about something, they referred it to him and proceeded from his statement. I inquired about him, and it was said, 'This is Muadh ibn Jabal.' The next day I went to the noon-prayer, and I found that he had preceded me to the noon prayer and I found him praying."

Abu Idris continued, "I waited for him until he had finished the prayer. Then I came to him from in front of him and greeted him and said, 'By Allah! I love you for Allah!' He said, 'By Allah?' I said, 'By Allah.' He said, 'By Allah?' I said, 'By Allah.' He said, 'By Allah?' I said, 'By Allah.' "

He continued, "He took me by the upper part of my cloak and pulled me to him and said, 'Rejoice! I heard the Messenger of Allah, may Allah bless him and grant him peace, say, "Allah, the Blessed and Exalted, said, 'My love is obliged for those who love each other in Me, and those who sit with each other in Me, and those who visit each other in Me, and those who give to each other generously in Me.' " ' "


Malik :: Hair :: [51-51.5.16]

Hair

Malik :: Book 51 : Hadith 51.5.16

Yahya related to me from Malik that he had heard that Abdullah ibn Abbas said, "Equanimity, gentleness, and good behaviour are one twenty-fifth of prophecy."


Malik :: Visions :: [52-52.1.1]

Visions

Malik :: Book 52 : Hadith 52.1.1

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha al-Ansari from Anas ibn Malik that the Messenger of Allah, may Allah bless him and grant him peace, said, "The good dream of a man who is salih is a forty-sixth part of prophecy."

Yahya related the like of that to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra from the Messenger of Allah, may Allah bless him and grant him peace.


Malik :: Visions :: [52-52.1.2]

Visions

Malik :: Book 52 : Hadith 52.1.2

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha from Zufar ibn Sasaca from his father from Abu Hurayra that when the Messenger of Allah, may Allah bless him and grant him peace, left the morning prayer, he would say, "Has any of you had a dream last night? All that will remain of prophecy after me will be the true dream ."


Malik :: Visions :: [52-52.1.3]

Visions

Malik :: Book 52 : Hadith 52.1.3

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "All that will be left of prophecy after me are the mubashshirat." They said, "What are the mubashshirat, Messenger of Allah?" He said, "The true dream which a man who is salih sees - or which is shown to him - is a forty-sixth part of prophecy."


Malik :: Visions :: [52-52.1.4]

Visions

Malik :: Book 52 : Hadith 52.1.4

Yahya related to me from Malik from Yahya ibn Said that Abu Salama ibn Abd ar-Rahman said, "I heard Abu Qatada ibn Ribiyy say that he heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'The good dream is from Allah, and the bad dream is from shaytan. When you see what you dislike, spit to your left side three times when you wake up, and seek refuge with Allah from its evil. It will not harm you then, Allah willing.' " Abu Salama said, "I would see dreams which weighed on me more heavily than a mountain. When I heard this hadith, I was not concerned about it."


Malik :: Visions :: [52-52.1.5]

Visions

Malik :: Book 52 : Hadith 52.1.5

Yahya related to me from Malik from Hisham ibn Urwa that his father said about this ayat, "You have good news in the life of this world and the next world," (Sura 10 ayat 64), that it was the good dream which the man who was salih saw or which was shown to him.


Malik :: Visions :: [52-52.2.6]

Visions

Malik :: Book 52 : Hadith 52.2.6

Yahya related to me from Malik from Musa ibn Maysara from Said ibn Abi Hind from Abu Musa al-Ashari that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever plays games of dice has disobeyed Allah and His Messenger. "

Yahya related to me from Malik from Alqama from his mother that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, heard that the people who lived in a room in her house had some dice. She sent a message to them, "If you do not remove them, I will remove you from my house," and she reproached them for it.


Malik :: Visions :: [52-52.2.7]

Visions

Malik :: Book 52 : Hadith 52.2.7

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that when he found one of his family playing dice he beat him and destroyed the dice.

Yahya said that he heard Malik say, "There is no good in chess, and he disapproved of it." Yahya said, "I heard him disapprove of playing it and other worthless games. He recited this ayat, 'What is there after the truth except going the wrong way.' " (Sura l0 ayat 32).


Malik :: Greetings :: [53-53.1.1]

Greetings

Malik :: Book 53 : Hadith 53.1.1

Yahya related to me from Malik from Zayd ibn Aslam that the Messenger of Allah, may Allah bless him and grant him peace, said, "The one riding greets the one walking, and when one of a group of people gives a greeting, it is enough for all of them."


Malik :: Greetings :: [53-53.1.2]

Greetings

Malik :: Book 53 : Hadith 53.1.2

Yahya related to me from Malik from Wahb ibn Kaysan that Muhammad ibn Amr ibn Ata said, "I was sitting with Abdullah ibn Abbas when a Yemeni man came in. He said, 'Peace be upon you, and the mercy of Allah and His blessing' (as-salamu alaykum wa rahmatullahi wa barakatuhu), and then he added something more to that. Ibn Abbas said (and at that time his eyesight had gone), 'Who is this?' People said, 'This is a Yemeni who has come to see you,' and they introduced him. Ibn Abbas said, 'The greeting ends with the word blessing.' "

Yahya said that Malik was asked, "Does one greet a woman?" He said, "As for an old woman, I do not disapprove of it. As for a young woman, I do not like it."


Malik :: Greetings :: [53-53.2.3]

Greetings

Malik :: Book 53 : Hadith 53.2.3

Yahya related to me from Malik from Abdullah ibn Dinar that Abdullah ibn Umar said that the Messenger of Allah, may Allah bless him and grant him peace, said, "When a jew greets you, and says 'Death to you' (as-samu alaykum) say, 'And to you.' "

Yahya said, "Malik was asked whether a person who greeted a jew or christian, should apologise for it. He said, 'No'."


Malik :: Greetings :: [53-53.3.4]

Greetings

Malik :: Book 53 : Hadith 53.3.4

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha from Abu Murra, the mawla of Aqil ibn Abi Talib from Abu Waqid al-Laythi that the Messenger of Allah, may Allah bless him and grant him peace, was sitting in the mosque with some people when three people came in. Two came toward the Messenger of Allah, may Allah bless him and grant him peace, and one went away. When the two stopped at the assembly of the Messenger of Allah, may Allah bless him and grant him peace, they gave the greeting. One of them saw a gap in the circle and sat in it. The other sat down behind the circle. The third turned away and left. When the Messenger of Allah, may Allah bless him and grant him peace, finished, he said, "Shall I tell you about three people? One of them sought shelter with Allah, so Allah gave him shelter. The other was shy, so Allah was shy to him. The other turned away, so Allah turned away from him."


Malik :: Greetings :: [53-53.3.5]

Greetings

Malik :: Book 53 : Hadith 53.3.5

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik heard Umar ibn al-Khattab return the greeting of a man who greeted him. Then Umar asked the man, "How are you?" He said, "I praise Allah to you." (Ahmadu ilayka Allah) Umar said, "That is what I wanted from you."


Malik :: Greetings :: [53-53.3.6]

Greetings

Malik :: Book 53 : Hadith 53.3.6

Yahya related to me from Malik from Ishaq ibn Abdullah ibn Abi Talha that at-Tufayl ibn Ubayy ibn Kab told him that he visited Abdullah ibn Umar one morning and went out with him to the market, and when they were out, Abdullah ibn Umar did not pass by anyone selling poor merchandise or selling commodities or a needy person or anyone but that he greeted them.

At-Tufayl said, "I came to Abdullah ibn Umar one day and he asked me to follow him to the market. I said to him, 'What will you do in the market if you will not stop to sell nor seek any goods or barter with them or sit in any of the assemblies or market?' Abdullah ibn Umar said that we should sit down and talk, and then he explained, 'Abu Batni, (lit. father of the belly, at-Tufayl had a prominent stomach), we go out in the morning only for the sake of the greeting. We greet whomever we meet.' "


Malik :: Greetings :: [53-53.3.7]

Greetings

Malik :: Book 53 : Hadith 53.3.7

Yahya related to me from Malik from Yahya ibn Said that a man greeted Abdullah ibn Umar. He said, "Peace be upon you and the mercy of Allah and his barakat, on and on." Abdullah ibn Umar said to him, "And on you, a thousand times," as if he disliked that.


Malik :: Greetings :: [53-53.3.8]

Greetings

Malik :: Book 53 : Hadith 53.3.8

Yahya related to me from Malik that he heard that when one entered an unoccupied house, one should say, "Peace be upon us and on the slaves of Allah, who are salih." (As-salamu alayna wa ala ibadillahi's-saliheen).O


Malik :: General Subjects :: [54-54.1.1]

General Subjects

Malik :: Book 54 : Hadith 54.1.1

Malik related to me from Safwan ibn Sulaym from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, was questioned by a man who said, "Messenger of Allah, shall I ask permission of my mother to enter?" He said, "Yes " The man said, "I live with her in the house". The Messenger of Allah, may Allah bless him and grant him peace, said "Ask her permission." The man said, "I am her servant." The Messenger of Allah. may Allah bless him and grant him peace, said, "Ask her permission. Do you want to see her naked?" He said, "No." He said, "Then ask her permission."


Malik :: General Subjects :: [54-54.1.2]

General Subjects

Malik :: Book 54 : Hadith 54.1.2

Malik related to me from a reliable source of his from Bukayr ibn Abdullah ibn al-Ashajj from Basr ibn Said from Abu Said al-Khudri that Abu Musa al-Ashari said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'One asks permission three times. If you are given permission, then enter. If not, go away.' "


Malik :: General Subjects :: [54-54.1.3]

General Subjects

Malik :: Book 54 : Hadith 54.1.3

Malik related to me from Rabia ibn Abi Abd ar-Rahman from another of the ulama of that time that Abu Musa al-Ashari came and asked permission from Umar ibn al-Khattab to enter. He asked permission three times, and then went away Umar ibn al-Khattab sent after him and said, "What's wrong with you? Why didn't you come in?" Abu Musa said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Ask permission to enter three times. If you are given permission, then enter. If not, go away.' ''Umar said, "Who can confirm this? If you do not bring me someone to confirm it, I will do such-and-such to you."

Abu Musa went out until he came to an assembly in the mosque which was called the Majlis-al-Ansar. He said, "I told Umar ibn al-Khattab that I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'Ask permission three times. If you are given permission, then enter. If not, go away.' Umar said, 'If you do not bring me someone who can confirm it, I will do such-and-such to you'. If any of you have heard that, let him come with me.' " They said to Abu Said al-Khudri, "Go with him". Abu Said was the youngest of them. He went with him and told Umar ibn al-Khattab about that."

Umar ibn al-Khattab said to Abu Musa, "I did not suspect you, but I feared lest people forge sayings of the Messenger of Allah, may Allah bless him and grant him peace."


Malik :: General Subjects :: [54-54.2.4]

General Subjects

Malik :: Book 54 : Hadith 54.2.4

Malik related to me from Abdullah ibn Abi Bakr from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "If a man sneezes, invoke a blessing on him. Then if he sneezes, invoke a blessing on him. Then if he sneezes, invoke a blessing on him. Then if he sneezes, say, 'You have a cold'." Abdullah ibn Abi Bakr said, "I don't know whether it was after the third or fourth."


Malik :: General Subjects :: [54-54.2.5]

General Subjects

Malik :: Book 54 : Hadith 54.2.5

Malik related to me from Nafi that when Abdullah ibn Umar sneezed and someone said to him, "May Allah have mercy on you," (Yarhamuka'llah), he said, "May Allah have mercy on us and you, and forgive us and you." (Yarhamuna'llah wa yaghfirlana wa lakum).


Malik :: General Subjects :: [54-54.3.6]

General Subjects

Malik :: Book 54 : Hadith 54.3.6

Malik related to me from Ishaq ibn Abdullah ibn Abi Talha that Rafi ibn Ishaq, the mawla of ash-Shifa informed him that he and Abdullah ibn Abi Talha had gone to visit Abu Said al-Khudri while he was ill. Abu Said said to them, "The Messenger of Allah, may Allah bless him and grant him peace, informed us, 'The angels do not enter a house which contains pictures or images.' " Ishaq was not sure which of them Abu Said said.


Malik :: General Subjects :: [54-54.3.7]

General Subjects

Malik :: Book 54 : Hadith 54.3.7

Malik related to me from Abu'n-Nasr that Ubaydullah ibn Abdullah ibn Utba ibn Masud went to visit Abu Talha al-Ansari when he was ill. He said, "I found Sahl ibn Hunayf with him. Abu Talha summoned a man and removed a rug which was under him. Sahl ibn Hunayf said to him, 'Why did you remove it?' He said, 'Because there were pictures on it, and the Messenger of Allah, may Allah bless him and grant him peace, said what you know about them.' Sahl replied, 'Didn't the Messenger of Allah, may Allah bless him and grant him peace, say, "except for markings on a garment?"' (A rug was considered a garment). He said, 'Yes, but it is more pleasing to myself.' "


Malik :: General Subjects :: [54-54.3.8]

General Subjects

Malik :: Book 54 : Hadith 54.3.8

Malik related to me from Nafi from al-Qasim ibn Muhammad from A'isha, the wife of the Prophet, may Allah bless him and grant him peace, that she bought a cushion which had pictures on it. When the Messenger of Allah, may Allah bless him and grant him peace, saw it, he stopped at the door and did not enter. She recognised disapproval on his face and said, "Messenger of Allah, I turn in repentance to Allah and His Messenger. What have I done wrong?" The Messenger of Allah, may Allah bless him and grant him peace, said, "What is the meaning of this cushion?" She said, "I bought it for you to sit and recline on." The Messenger of Allah, may Allah bless him and grant him peace, said, "Those who make such pictures will be punished on the Day of Rising. It will be said to them, 'Bring to life what you have created'. Then he said, 'The angels do not enter a house in which there are pictures.' "


Malik :: General Subjects :: [54-54.4.9]

General Subjects

Malik :: Book 54 : Hadith 54.4.9

Malik related to me from Abd ar-Rahman ibn Abdullah ibn Abd ar-Rahman ibn Abi Sasaca that Sulayman ibn Yasar said, "The Messenger of Allah, may Allah bless him and grant him peace, entered the house of Maimuna bint al-Harith and there was a lizard in which there were eggs to eat. Abdullah ibn Abbas and Khalid ibn al-Walid were with him. He said, 'From where did you get this?' She replied, 'My sister, Huzayla bint al-Harith, gave it to me.' He then told Abdullah ibn Abbas and Khalid to eat. They said, 'Won't you eat, Messenger of Allah?' He said, 'There are those who visit me from Allah.' Maimuna said, 'Messenger of Allah, shall we give you some milk to drink which we have?' He said, 'Yes.' When he drank, he said, 'From where did you get this?' She said, 'My sister, Huzayla gave it to me.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Do you see your slave-girl whom you asked me for permission to free? Give her to your sister and bring her to your maternal relatives to take care of her. That is better for you.' "


Malik :: General Subjects :: [54-54.4.10]

General Subjects

Malik :: Book 54 : Hadith 54.4.10

Malik related to me from Ibn Shihab from Abu Umama ibn Sahl ibn Hunayf from Abdullah ibn Abbas that Khalid ibn al-Walid ibn al-Mughira entered the house of Maimuna, the wife of the Prophet, may Allah bless him and grant him peace, with the Messenger of Allah, may Allah bless him and grant him peace, and he was brought a roasted lizard. The Messenger of Allah, may Allah bless him and grant him peace, stretched his hand toward it. One of the women who was in Maimuna's house said, "Tell the Messenger of Allah, may Allah bless him and grant him peace, what he means to eat." Someone said, "It is a lizard, Messenger of Allah." He withdrew his hand. Khalid said, "Is it haram, Messenger of Allah?" He said, "No, but there were none in my people's land, and I find that I dislike them."

Khalid added, "I chewed and ate it while the Messenger of Allah, may Allah bless him and grant him peace, was looking."


Malik :: General Subjects :: [54-54.4.11]

General Subjects

Malik :: Book 54 : Hadith 54.4.11

Malik related to me from Abdullah ibn Dinar from Abdullah ibn Umar that a man called the Messenger of Allah and said, "Messenger of Allah, what do you think about lizards?" The Messenger of Allah, may Allah bless him and grant him peace, said, "I do not eat them, and I do not forbid them."


Malik :: General Subjects :: [54-54.5.12]

General Subjects

Malik :: Book 54 : Hadith 54.5.12

Malik related to me from Yazid ibn Khusayfa that as-Sa'ib ibn Yazid informed him that he heard Sufyan ibn Abi Zuhayr who was from the Azd Shanua tribe and among the companions of the Messenger of Allah, may Allah bless him and grant him peace, speaking with some people who were with him at the door of the mosque. He said, "I heard the Messenger of Allah, may Allah bless him and grant him peace, say, 'If anyone acquires a dog which he does not use as a sheepdog or for hunting, a qirat will be deducted from the reward of his good deeds each day.' " He was asked, "Did you hear this from the Messenger of Allah, may Allah bless him and grant him peace?" He said, "Yes, by the Lord of this mosque."


Malik :: General Subjects :: [54-54.5.13]

General Subjects

Malik :: Book 54 : Hadith 54.5.13

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever acquires a dog other than a sheepdog or hunting dog, will have two qirats deducted from the reward of his good actions every day."

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, ordered dogs to be killed.


Malik :: General Subjects :: [54-54.6.15]

General Subjects

Malik :: Book 54 : Hadith 54.6.15

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The head of kufr is towards the east. Boasting and price is among people who have horses and camels. The loud-voiced people are the people of tents (the Bedouins). Tranquillity is with the people who have sheep."


Malik :: General Subjects :: [54-54.6.16]

General Subjects

Malik :: Book 54 : Hadith 54.6.16

Malik related to me from Abd ar-Rahman ibn Abd ar-Rahman ibn Sasaca from his father that Abu Said al-Khudri said that the Messenger of Allah, may Allah bless him and grant him peace, said, "It will soon happen that the best property of a muslim will be sheep which he takes to the peaks of the mountains and the valleys, fleeing with his deen from trials."


Malik :: General Subjects :: [54-54.6.17]

General Subjects

Malik :: Book 54 : Hadith 54.6.17

Malik related to me from Nafi from Ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "No one should milk someone else's cow without his permission. Would any of you like someone to come to his apartment, break into his larder, and take his food? The udders of cows guard their food for their owners, so no one should milk someone else's cow without his permission."


Malik :: General Subjects :: [54-54.6.18]

General Subjects

Malik :: Book 54 : Hadith 54.6.18

Malik related to me that he had heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "There is no Prophet who has not herded sheep," and someone asked, "You as well, Messenger of Allah?" He said, "Myself as well."


Malik :: General Subjects :: [54-54.7.19]

General Subjects

Malik :: Book 54 : Hadith 54.7.19

Malik related to me from Nafi that one time as Ibn Umar was served his evening meal, he heard the recitation of the Imam while he was in his house and he did not hurry from his food until he had finished what he needed.


Malik :: General Subjects :: [54-54.7.20]

General Subjects

Malik :: Book 54 : Hadith 54.7.20

Malik related to me from Ibn Shihab from Ubaydullah ibn Abdullah ibn Utba ibn Masud from Abdullah ibn Abbas from Maimuna, the wife of the Prophet, may Allah bless him and grant him peace, that the Messenger of Allah, may Allah bless him and grant him peace, was asked about a mouse falling into clarified butter. He said, "Remove it and throw away what is around it "


Malik :: General Subjects :: [54-54.8.21]

General Subjects

Malik :: Book 54 : Hadith 54.8.21

Malik related to me from Abu Hazim ibn Dinar from Sahl ibn Sad as-Saidi that the Messenger of Allah, may Allah bless him and grant him peace, said, "If it exists, it is in a horse, a woman, and a house," meaning ill luck.


Malik :: General Subjects :: [54-54.8.22]

General Subjects

Malik :: Book 54 : Hadith 54.8.22

Malik related to me from Malik from Ibn Shihab from Hamza and Salim the sons of Abdullah ibn Umar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Ill luck is in a house, a woman and a horse."


Malik :: General Subjects :: [54-54.8.23]

General Subjects

Malik :: Book 54 : Hadith 54.8.23

Malik related to me that Yahya ibn Said said, "A woman came to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah, we moved into a house when our number was great and our wealth was abundant. Now our number has dwindled and the wealth has gone.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'Leave it as blameworthy.' "


Malik :: General Subjects :: [54-54.9.24]

General Subjects

Malik :: Book 54 : Hadith 54.9.24

Malik related to me from Yahya ibn Said that the Messenger of Allah, may Allah bless him and grant him peace, asked about a milk camel about to be milked, "Who milks this camel?" A man stood up. The Messenger of Allah, may Allah bless him and grant him peace, said, "What is your name?" The man said, "Murra (bitterness)." The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Sit down." Then he said, "Who milks this one?" A man stood up and the Messenger of Allah, may Allah bless him and grant him peace, said, "What is your name?" He said, "Harb (war)." The Messenger of Allah, may Allah bless him and grant him peace, said, "Sit down." Then he said, "Who milks this camel?" A man stood up, and the Messenger of Allah, may Allah bless him and grant him peace, said to him, "What is your name?" The man said, ''Yaish (he lives)." The Messenger of Allah, may Allah bless him and grant him peace, said to him, "Milk!"


Malik :: General Subjects :: [54-54.9.25]

General Subjects

Malik :: Book 54 : Hadith 54.9.25

Yahya related to me from Yahya ibn Said that Umar ibn al-Khattab asked a man what his name was. He said, "Jamra (live coal)." "The son of who?" He said, "Ibn Shihab (meteor, flame)." "From whom?" He said, "From al-Huraqa (burning)." "Where do you live?" He said, "At Harrat an-Nar (lava field of the fire). "At which one of them?" He said, "At Dhati Ladha (one with flames)." Umar said, "Go and look at your family - they have been burned."

Yahya added, "It was as Umar ibn al-Khattab, may Allah be pleased with him, said."


Malik :: General Subjects :: [54-54.10.26]

General Subjects

Malik :: Book 54 : Hadith 54.10.26

Malik related to me from Humayd at-Tawil that Anas ibn Malik said, "The Messenger of Allah, may Allah bless him and grant him peace, was cupped. Abu Tayba cupped him, and the Messenger of Allah, may Allah bless him and grant him peace, ordered him to be given a sa of dates and ordered his family to lessen what he paid them for his kitaba or kharaj."


Malik :: General Subjects :: [54-54.10.27]

General Subjects

Malik :: Book 54 : Hadith 54.10.27

Malik related to me that he heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "If there is a remedy that will reach the disease, then cupping will reach it."


Malik :: General Subjects :: [54-54.10.28]

General Subjects

Malik :: Book 54 : Hadith 54.10.28

Malik related to me from Ibn Shihab from Ibn Muhayyisa al-Ansari, one of the Banu Haritha, that he asked permission from the Messenger of Allah, may Allah bless him and grant him peace, to give payment for cupping, and he forbade him to do it. He continued to ask and seek his permission until he said, "Feed the ones who drive your water-carrying camels," meaning "your slaves."


Malik :: General Subjects :: [54-54.11.29]

General Subjects

Malik :: Book 54 : Hadith 54.11.29

Malik related to me from Abdullah ibn Dinar that Abdullah ibn Umar said, "I saw the Messenger of Allah, may Allah bless him and grant him peace, pointing at the east and saying, 'The cause of dissension is here. The cause of dissension is here, from where the helpers of shaytan arise.' "


Malik :: General Subjects :: [54-54.11.30]

General Subjects

Malik :: Book 54 : Hadith 54.11.30

Malik related to me that he heard that Umar ibn al-Khattab wanted to go to Iraq, and Kabal-Ahbar said to him, "Do not go there, amir al-muminin. There is nine-tenths of sorcery there and it is the place of the rebellious jinn and the disease which the doctors are unable to cure."


Malik :: General Subjects :: [54-54.12.31]

General Subjects

Malik :: Book 54 : Hadith 54.12.31

Malik related to me from Nafi from Abu Lubaba that the Messenger of Allah, may Allah bless him and grant him peace, forbade killing snakes which were in the houses.


Malik :: General Subjects :: [54-54.12.32]

General Subjects

Malik :: Book 54 : Hadith 54.12.32

Malik related to me from Nafi from Sa'iba, the female mawla of A'isha, that the Messenger of Allah, may Allah bless him and grant him peace, forbade killing the snakes which were in the houses except those with two white stripes on their back and the short ones. They made one go blind and caused miscarriages in women.


Malik :: General Subjects :: [54-54.12.33]

General Subjects

Malik :: Book 54 : Hadith 54.12.33

Malik related to me from Safiyy, the mawla of Ibn Aflah that Abu's-Saib, the mawla of Hisham ibn Zuhra said, "I went to Abu Said al-Khudri and found him praying. I sat to wait for him until he finished the prayer. I heard a movement under a bed in his room, and it was a snake. I stood up to kill it, and Abu Said gestured to me to sit. When he was finished he pointed to a room in the house and said, 'Do you see this room?' I said, 'Yes.' He said, 'There was a young boy in it who had just got married. He went out with the Messenger of Allah, may Allah bless him and grant him peace, to al-Khandaq, (the ditch which the muslims dug in the 5th year of the Hijra to defend Madina against the Quraysh and their allies).

When he was there, the youth came and asked his permission, saying, "Messenger of Allah. Give me permission to return to my family." The Messenger of Allah, may Allah bless him and grant him peace, gave him permission and said, "Take your weapons with you, for I fear the Banu Quraydha tribe. They may harm you." The youth went to his family and found his wife standing between the two doors. He lifted his spear to stab her as jealousy had been aroused in him. She said, "Don't be hasty until you go in and see what is in your house." He entered and found a snake coiled up on his bed. He transfixed it with his spear and then went out with it and pitched it into the house. The snake stirred on the end of the spear and the youth fell dead. No one knew which of them died first, the snake or the youth. That was mentioned to the Messenger of Allah, may Allah bless him and grant him peace, and he said, "There are jinn in Madina who have become muslim. When you see one of them, call out to it for three days. If it appears after that, then kill it, for it is a shaytan." "'


Malik :: General Subjects :: [54-54.13.34]

General Subjects

Malik :: Book 54 : Hadith 54.13.34

Malik related to me that he heard that when the Messenger of Allah, may Allah bless him and grant him peace, set foot in the stirrup intending to travel, he would say, "In the name of Allah. O Allah! You are my companion in the journey and the Khalifa of my family. O Allah! Spread out the earth for us and make the journey easy for us. O Allah! I seek refuge with You from the hardship of the journey and from returning to sorrow and a distressing sight regarding property and family."

Malik related to me from a reliable source of his from Yaqub ibn Abdullah al-Ashajj from Bushr ibn Said from Sad ibn Abi Waqqas from Khawla bint Hakim that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever dismounts to rest in a place should say, 'I seek refuge with the complete words of Allah from the evil of what he created,' (audhu bi kalimati-llahi at-tammati min sharri ma khalaqa), and nothing will harm him until he remounts."


Malik :: General Subjects :: [54-54.14.35]

General Subjects

Malik :: Book 54 : Hadith 54.14.35

Malik related to me from Abd ar-Rahman ibn Harmala from Amr ibn Shuayb from his father from his father that the Messenger of Allah, may Allah bless him and grant him peace, said, "One rider is a shaytan. Two riders are two shaytans, and three are a riding-party."


Malik :: General Subjects :: [54-54.14.36]

General Subjects

Malik :: Book 54 : Hadith 54.14.36

Malik related to me from Abd ar-Rahman ibn Harmala that Said ibn al-Musayyab heard the Messenger of Allah, may Allah bless him and grant him peace, say, "Shaytan concerns himself with one and two. When there are three, he does not concern himself with them."


Malik :: General Subjects :: [54-54.14.37]

General Subjects

Malik :: Book 54 : Hadith 54.14.37

Malik related to me from Said ibn Abi Said al-Maqburi from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "It is not halal for a woman who believes in Allah and the Last Day to travel the distance of a day and night without a man who is her mahram."


Malik :: General Subjects :: [54-54.15.38]

General Subjects

Malik :: Book 54 : Hadith 54.15.38

Malik related to me from Abu Ubayd, the mawla of Sulayman ibn Abd al-Malik from Khalid ibn Madan who attributed it to the Prophet, may Allah bless him and grant him peace, "Allah, the Blessed and Exalted is kind and loves kindness. He is pleased with it and helps you with it as long as it is not misplaced. When you ride dumb beasts, stop them in their stopping places, and quicken their pace when the land is barren. Travel by night, because the land is travelled faster at night than it is during the day. Beware of pitching tents on the road, for it is the path of animals and the abode of snakes."


Malik :: General Subjects :: [54-54.15.39]

General Subjects

Malik :: Book 54 : Hadith 54.15.39

Malik related to me from Sumayy, the mawla of Abu Bakr from Abu Salih from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Travelling is a portion of the torment. It denies you your sleep, food, and drink. When you have accomplished your purpose, you should hurry back to your family."


Malik :: General Subjects :: [54-54.16.40]

General Subjects

Malik :: Book 54 : Hadith 54.16.40

Malik related to me that he heard that Abu Hurayra said that the Messenger of Allah, may Allah bless him and grant him peace, said, "A slave has his food and clothing in the normal manner, and he is only obliged to do such work as he is capable of doing."


Malik :: General Subjects :: [54-54.16.41]

General Subjects

Malik :: Book 54 : Hadith 54.16.41

Malik related to me that he heard that Umar ibn al-Khattab went to the villages every Saturday. If he found a slave doing work which he was not capable of doing, he lightened it for him.


Malik :: General Subjects :: [54-54.16.42]

General Subjects

Malik :: Book 54 : Hadith 54.16.42

Malik related to me from his paternal uncle, Abu Suhayl ibn Malik, that his father heard Uthman ibn Affan say in a khutba, "Do not oblige the slave-girl to earn money unless she has a skill. When you oblige her to do that, she will earn money by prostitution. Do not oblige the child to earn money. If he does not find it, he will steal. Have integrity since Allah has integrity with you, and you must feed them good food."


Malik :: General Subjects :: [54-54.17.43]

General Subjects

Malik :: Book 54 : Hadith 54.17.43

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "When a slave gives good counsel to his master and worships Allah correctly, he has his reward twice over. "


Malik :: General Subjects :: [54-54.17.44]

General Subjects

Malik :: Book 54 : Hadith 54.17.44

Malik related to me that he heard that Umar ibn al-Khattab saw a female slave belonging to Abdullah ibn Umar ibn al-Khattab. She was dressed up in silks. He went to his daughter Hafsa and said, "Didn't I see your brother's slave-girl dressed up in silks walking among the people and causing trouble?" Umar disapproved of that.


Malik :: The Oath of Allegiance :: [55-55.1.1]

The Oath of Allegiance

Malik :: Book 55 : Hadith 55.1.1

Malik related to me from Abdullah ibn Dinar that Abdullah ibn Umar said, "When we took an oath of allegiance with him to hear and obey, the Messenger of Allah, may Allah bless him and grant him peace, said to us, 'In what you are able.' "


Malik :: The Oath of Allegiance :: [55-55.1.2]

The Oath of Allegiance

Malik :: Book 55 : Hadith 55.1.2

Malik related to me from Muhammad ibn al-Munkadir that Umayma bint Ruqayqa said, "I went to the Messenger of Allah, may Allah bless him and grant him peace, with the women who took an oath of allegiance with him in Islam. They said, 'Messenger of Allah! We take a pledge with you not to associate anything with Allah, not to steal, not to commit adultery, not to kill our children, nor to produce any lie that we have devised between our hands and feet, and not to disobey you in what is known.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'In what you can do and are able.' "

Umayma continued, "They said, 'Allah and His Messenger are more merciful to us than ourselves. Come, let us give our hands to you, Messenger of Allah!' The Messenger of Allah, may Allah bless him and grant him peace, said, 'I do not shake hands with women. My word to a hundred women is like my word to one woman.' "


Malik :: The Oath of Allegiance :: [55-55.1.3]

The Oath of Allegiance

Malik :: Book 55 : Hadith 55.1.3

Malik related to me from Abdullah ibn Dinar that Abdullah ibn Umar wrote to Abd al-Malik ibn Marwan, making an oath of allegiance. He wrote, "In the name of Allah, the Merciful, the Compassionate. To the slave of Allah, Abd al-Malik, the amir al-muminin, Peace be upon you. I praise Allah to you. There is no god but Him. I acknowledge your right to my hearing and my obedience according to the sunna of Allah and the sunna of His Prophet, in what I am able."


Malik :: Speech :: [56-56.1.1]

Speech

Malik :: Book 56 : Hadith 56.1.1

Malik related to me from Abdullah ibn Dinar from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "If a man says to his muslim brother, 'O kafir!' it is true about one of them."


Malik :: Speech :: [56-56.1.2]

Speech

Malik :: Book 56 : Hadith 56.1.2

Malik related to me from Suhayl ibn Abu Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "When you hear a man say, 'The people are ruined,' he himself is the most ruined of them all."


Malik :: Speech :: [56-56.1.3]

Speech

Malik :: Book 56 : Hadith 56.1.3

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Let none of you complain about time, for Allah is time.'


Malik :: Speech :: [56-56.1.4]

Speech

Malik :: Book 56 : Hadith 56.1.4

Malik related to me from Yahya ibn Said that Isa ibn Maryam encountered a pig on the road. He said to it, "Go in peace." Somebody asked, "Do you say this to a pig?" Isa said, "I fear lest I accustom my tongue to evil speech."


Malik :: Speech :: [56-56.2.5]

Speech

Malik :: Book 56 : Hadith 56.2.5

Malik related to me from Muhammad ibn Amr ibn Alqama from his father from Bilal ibn al-Harith al-Muzani that the Messenger of Allah, may Allah bless him and grant him peace, said, "A man speaks what is pleasing to Allah and he does not suspect that it will have the result that it does, and Allah will write for him His good pleasure for it until the day when he meets Him. And a man speaks what excites the wrath of Allah and he does not suspect that it will have the result that it does, and Allah will write His wrath for him for it until the day when he meets Him."


Malik :: Speech :: [56-56.2.6]

Speech

Malik :: Book 56 : Hadith 56.2.6

Malik related to me from Abdullah ibn Dinar that Abu Salih as-Samman informed him that Abu Hurayra said, "Truly a man utters words to which he attaches no importance, and by them he falls into the fire of Jahannam, and truly a man utters words to which he attaches no importance, and by them Allah raises him into the Garden."


Malik :: Speech :: [56-56.3.7]

Speech

Malik :: Book 56 : Hadith 56.3.7

Malik related to me from Zayd ibn Aslam that Abdullah ibn Umar said, "Two men from the east stood up and spoke, and people were amazed at their eloquence. The Messenger of Allah, may Allah bless him and grant him peace, said, 'Some eloquence is sorcery,' or he said, 'Part of eloquence is sorcery.' "


Malik :: Speech :: [56-56.3.8]

Speech

Malik :: Book 56 : Hadith 56.3.8

Malik related to me that he heard that Isa ibn Maryam used to say, "Do not speak much without the mention of Allah for you will harden your hearts. A hard heart is far from Allah, but you do not know. Do not look at the wrong actions of people as if you were lords. Look at your wrong actions as if you were slaves. Some people are afflicted by wrong action and some people are protected from it. Be merciful to the people of affliction and praise Allah for His protection."


Malik :: Speech :: [56-56.3.9]

Speech

Malik :: Book 56 : Hadith 56.3.9

Malik related to me that he heard that A'isha, the wife of the Prophet, may Allah bless him and grant him peace, sent a message to one of her family after the evening prayer, saying, "Will you not allow the recording angel to rest?"


Malik :: Speech :: [56-56.4.10]

Speech

Malik :: Book 56 : Hadith 56.4.10

Malik related to me from al-Walid ibn Abdullah ibn Sayyad that al-Muttalib ibn Abdullah ibn Hantab al-Makhzumi informed him that a man asked the Messenger of Allah, may Allah bless him and grant him peace, "What is backbiting?" The Messenger of Allah, may Allah bless him and grant him peace, said, "It is to mention about a man what he does not want to hear." He said, "Messenger of Allah! Even if it is true?" The Messenger of Allah, may Allah bless him and grant him peace, said, "If you utter something false, then it is slander."


Malik :: Speech :: [56-56.5.11]

Speech

Malik :: Book 56 : Hadith 56.5.11

Malik related to me from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whomever Allah protects from the evil of two things will enter the Garden." A man said, "Messenger of Allah, do not tell us!" The Messenger of Allah, may Allah bless him and grant him peace, was silent. Then the Messenger of Allah, may Allah bless him and grant him peace, repeated what he had said the first time. The man said to him, "Do not tell us, Messenger of Allah!" The Messenger of Allah, may Allah bless him and grant him peace, was silent. Then the Messenger of Allah, may Allah bless him and grant him peace, said the same thing again. The man said, "Do not tell us, Messenger of Allah!" Then the Messenger of Allah, may Allah bless him and grant him peace, said the same thing again. Then the man began to say what he had said previously and a man at his side silenced him. The Messenger of Allah, may Allah bless him and grant him peace, said, "Whomever Allah protects from the evil of two things will enter the Garden. They are what is between his jaws and what is between his legs, what is between his jaws and what is between his legs, what is between his jaws and what is between his legs."


Malik :: Speech :: [56-56.5.12]

Speech

Malik :: Book 56 : Hadith 56.5.12

Malik related to me from Zayd ibn Aslam from his father that Umar ibn al-Khattab came upon Abu Bakr as-Siddiq pulling his tongue. Umar said to him, "Stop, may Allah forgive you!" Abu Bakr replied, "This has brought me to dangerous places."


Malik :: Speech :: [56-56.6.13]

Speech

Malik :: Book 56 : Hadith 56.6.13

Malik related to me from Abdullah ibn Dinar saying, "Abdullah ibn Umar and I were at the house of Khalid ibn Uqba who was away at the market. A man came who wanted to speak to Abdullah ibn Umar and I was the only other person present Abdullah ibn Umar called another man so that we were four and said to me and the man whom he had called, 'Go a little way off together, because I heard the Messenger of Allah, may Allah bless him and grant him peace, say, "Two do not converse secretly to the exclusion of another.' "'


Malik :: Speech :: [56-56.6.14]

Speech

Malik :: Book 56 : Hadith 56.6.14

Malik related to me from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Two must not converse secretly to the exclusion of another person."


Malik :: Speech :: [56-56.7.15]

Speech

Malik :: Book 56 : Hadith 56.7.15

Malik related to me from Safwan ibn Sulaym that a man asked the Messenger of Allah, may Allah bless him and grant him peace, "Can I lie to my wife, Messenger of Allah?" The Messenger of Allah, may Allah bless him and grant him peace, said, "There is no good in lying." The man said, "Messenger of Allah! Shall I make her a promise and tell her?" The Messenger of Allah, may Allah bless him and grant him peace, said, "It will not be held against you."


Malik :: Speech :: [56-56.7.16]

Speech

Malik :: Book 56 : Hadith 56.7.16

Malik related to me that he heard that Abdullah ibn Masud used to say, "You must tell the truth. Truthfulness leads to right action. Right action leads to the Garden. Beware of lying. Lying leads to corruption, and corruption leads to the Fire. Don't you see that it is said, 'He speaks the truth and acts rightly,' and, 'He lies and is corrupt.' "


Malik :: Speech :: [56-56.7.17]

Speech

Malik :: Book 56 : Hadith 56.7.17

Malik related to me that he heard that someone said to Luqman, "What has brought you to what we see?" meaning his high rank. Luqman said, "Truthful speech, fulfilling the trust, and leaving what does not concern me."


Malik :: Speech :: [56-56.7.18]

Speech

Malik :: Book 56 : Hadith 56.7.18

Malik related to me that he heard that Abdullah ibn Masud used to say, "The slave continues to lie and a black spot grows in his heart until all his heart becomes black. Then he is written, in Allah's sight, among the liars."


Malik :: Speech :: [56-56.7.19]

Speech

Malik :: Book 56 : Hadith 56.7.19

Malik related to me that Safwan ibn Sulaym said, "The Messenger of Allah, may Allah bless him and grant him peace, was asked, 'Can the mumin be a coward?' He said, 'Yes.' He was asked, 'Can the mumin be a miser?' He said, 'Yes.' He was asked, 'Can the mumin be a liar?' He said, 'No.' "


Malik :: Speech :: [56-56.8.20]

Speech

Malik :: Book 56 : Hadith 56.8.20

Malik related to me from Suhayl ibn Abi Salih from his father from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "Allah is pleased with three things from you, and He is angry with three things from you. He is pleased that you worship Him and do not associate anything with Him, and that you take hold of the rope of Allah altogether, and that you give good counsel to the one to whom Allah gives command over you. He is angry with you for gossip, squandering property, and asking too many questions."


Malik :: Speech :: [56-56.8.21]

Speech

Malik :: Book 56 : Hadith 56.8.21

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "One of the most evil of people is the two-faced person who shows one face to these people and another face to those people."


Malik :: Speech :: [56-56.9.22]

Speech

Malik :: Book 56 : Hadith 56.9.22

Malik related to me that he had heard that Umm Salama, the wife of the Prophet, may Allah bless him and grant him peace, said, "Messenger of Allah! Shall we be destroyed while there are people who are salih among us?" The Messenger of Allah, may Allah bless him and grant him peace, said, "Yes, if there is much wickedness."


Malik :: Speech :: [56-56.9.23]

Speech

Malik :: Book 56 : Hadith 56.9.23

Malik related to me that Ismail ibn Abi Hakim heard Umar ibn Abd al-Aziz say, "Some say that Allah the Blessed, the Exalted, will not punish the many for the wrong action of the few. However, when the objectionable action is committed openly, then they all deserve to be punished."


Malik :: Speech :: [56-56.10.24]

Speech

Malik :: Book 56 : Hadith 56.10.24

Malik related to me from Ishaq ibn Abdullah ibn Abi Talha that Anas ibn Malik said, "I heard Umar ibn al-Khattab, when I was going out with him to visit an orchard, say to himself, and there was a wall between him and me and he was inside the garden, 'Umar ibn al-Khattab, amir al-muminin! Well done! Well done! By Allah, fear Allah or he will punish you.' "


Malik :: Speech :: [56-56.10.25]

Speech

Malik :: Book 56 : Hadith 56.10.25

Malik said, "I heard that al-Qasim ibn Muhammad used to say, 'I have seen the people, (i.e. the companions), and they were not impressed by speech.' " Malik said, "He meant that only action and deeds would be looked at, not words."


Malik :: Speech :: [56-56.11.26]

Speech

Malik :: Book 56 : Hadith 56.11.26

Malik related to me that Amir ibn Abdullah ibn az-Zubayr would stop speaking when he heard thunder and say, "Glory be to Allah whom the thunder glorifies with His praise and the angels from the fear of Him." (Subhana-aladhee yusabihu ar-radu bi hamdihi wa mala'ikatu min khiyfatihi.) Then he would say, "This is a severe warning to the people of the earth."


Malik :: Speech :: [56-56.12.27]

Speech

Malik :: Book 56 : Hadith 56.12.27

Malik related to me from Ibn Shihab from Urwa ibn az-Zubayr from A'isha, umm al-muminin that when the Messenger of Allah, may Allah bless him and grant him peace, died, the wives of the Prophet, may Allah bless him and grant him peace, wanted to send Uthman ibn Affan to Abu Bakr as-Siddiq to ask him about their inheritance from the Messenger of Allah, may Allah bless him and grant him peace A'isha said to them, "Didn't the Messenger of Allah, may Allah bless him and grant him peace, say, 'No one inherits from us. What we leave is sadaqa.' "


Malik :: Speech :: [56-56.12.28]

Speech

Malik :: Book 56 : Hadith 56.12.28

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "My inheritance is not divided up by the dinar. What I leave apart from the maintenance of my wives and provision for my servant is sadaqa."


Malik :: Jahannam :: [57-57.1.1]

Jahannam

Malik :: Book 57 : Hadith 57.1.1

Malik related to me from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "The fire of the children of Adam which they kindle is a seventieth part of the fire of Jahannam." They said, "Messenger of Allah, this fire is certainly enough." He said, "That fire is sixty-nine times greater."


Malik :: Jahannam :: [57-57.1.2]

Jahannam

Malik :: Book 57 : Hadith 57.1.2

Malik related to me from his paternal uncle Abu Suhayl ibn Malik from his father that Abu Hurayra said, "Do you think that it is red like this fire of yours? It is blacker than tar."


Malik :: Sadaqa :: [58-58.1.1]

Sadaqa

Malik :: Book 58 : Hadith 58.1.1

Malik related to me from Yahya ibn Said from Abu'l-Hubab Said ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, said, "Whoever gives sadaqa from good earning - and Allah only accepts the good - it is as if he placed it in the palm of the Merciful to raise it, as one of you raises his foal or young camel until it is like the mountain "


Malik :: Sadaqa :: [58-58.1.2]

Sadaqa

Malik :: Book 58 : Hadith 58.1.2

Malik related to me that Ishaq ibn Abdullah ibn Abi Talha heard Anas ibn Malik say, "Abu Talha had the greatest amount of property in palm-trees among the Ansar in Madina. The dearest of his properties to him was Bayruha which was in front of the mosque. The Messenger of Allah, may Allah bless him and grant him peace, used to go into it and drink from the pleasant water which was in it."

Anas continued, "When this ayat was sent down 'You will not obtain rightness of action until you expend of what you love,' (Sura 2 ayat l76), Abu Talha went to the Messenger of Allah, may Allah bless him and grant him peace, and said, 'Messenger of Allah! Allah, the Blessed, the Exalted, has said, "You will not obtain until you expend of what you love." The property which I love the best is Bayruha. It is sadaqa for Allah. I hope for its good and for it to be stored up with Allah. Place it wherever you wish, Messengerof Allah. ' "

"The Messenger of Allah, may Allah bless him and grant him peace, said, 'Well done! That is property which profits! That is property which profits. I have heard what you have said about it and I think that you should give it to your relatives.' Abu Talha said, 'I will do it, Messenger of Allah!' Abu Talha therefore divided it among his relatives and the children of his paternal uncle."


Malik :: Sadaqa :: [58-58.1.3]

Sadaqa

Malik :: Book 58 : Hadith 58.1.3

Malik related to me from Zayd ibn Aslam that the Messenger of Allah, may Allah bless him and grant him peace, said, "Give to a beggar even if he comes on a horse."


Malik :: Sadaqa :: [58-58.1.4]

Sadaqa

Malik :: Book 58 : Hadith 58.1.4

Malik related to me from Zayd ibn Aslam from Amr ibn Muadh al-Ashali al-Ansari that his grandmother said, "The Messenger of Allah, may Allah bless him and grant him peace, said, 'O trusting women! Let none of you despise giving to her neighbour even if it is only a roasted sheep's trotter.'


Malik :: Sadaqa :: [58-58.1.5]

Sadaqa

Malik :: Book 58 : Hadith 58.1.5

Yahya related to me from Malik that he heard that a beggar asked A'isha, the wife of the Prophet, may Allah bless him and grant him peace, for something while she was fasting and there was only a loaf of bread in her house. She said to her female mawla, "Give it to him." The mawla protested, "You will not have anything to break your fast with." A'isha repeated, "Give it to him," so she did so. When evening came, the people of a house or a man who did not usually give to them, gave them a sheep and some food to go with it. A'isha, umm al-muminin, called her mawla and said, "Eat from this. This is better than your loaf of bread."


Malik :: Sadaqa :: [58-58.1.6]

Sadaqa

Malik :: Book 58 : Hadith 58.1.6

Yahya related to me that Malik said, "I heard that a beggar asked for food from A'isha, umm al-muminin, while she had some grapes. She told some one to take him one grape. He began to look in amazement. A'isha said, 'Are you amazed? How many atoms' weights do you see in this grape?' " (referring to Sura 99 ayat 7).


Malik :: Sadaqa :: [58-58.2.7]

Sadaqa

Malik :: Book 58 : Hadith 58.2.7

Malik related to me from Malik from Ibn Shihab from Ata ibn Yazid al-Laythi from Abu Said al-Khudri that some people of the Ansar asked the Messenger of Allah, may Allah bless him and grant him peace, and he gave to them. Then they asked him again, and he gave to them until he used up what he had. Then he said, "What wealth I have, I will not hoard from you. Whoever has forbearance, Allah will help him. Whoever tries to be independent, Allah will enrich him. Whoever tries to be patient, Allah will give him patience, and no one is given a better or vaster gift than patience."


Malik :: Sadaqa :: [58-58.2.8]

Sadaqa

Malik :: Book 58 : Hadith 58.2.8

Yahya related to me from Malik from Nafi from Abdullah ibn Umar that the Messenger of Allah, may Allah bless him and grant him peace, said from the mimbar when mentioning sadaqa and refraining from asking, "The upper hand is better than the lower hand. The upper hand is the one which expends, and the lower one is the one which asks."


Malik :: Sadaqa :: [58-58.2.9]

Sadaqa

Malik :: Book 58 : Hadith 58.2.9

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that the Messenger of Allah, may Allah bless him and grant him peace, sent a gift to Umar ibn al-Khattab, and Umar returned it. The Messenger of Allah, may Allah bless him and grant him peace, said, "Why did you return it?" He said, "Messenger of Allah, didn't you tell us that it is better for us not to take anything from anyone?" The Messenger of Allah, may Allah bless him and grant him peace, said, "That is by asking. Provision which Allah gives you is different from asking." Umar ibn al-Khattab said, "By the One in whose hand my self is, I will not ask anything from anyone, and anything that comes to me without my asking for it, I will accept."


Malik :: Sadaqa :: [58-58.2.10]

Sadaqa

Malik :: Book 58 : Hadith 58.2.10

Yahya related to me from Malik from Abu'z-Zinad from al-Araj from Abu Hurayra that the Messenger of Allah, may Allah bless him and grant him peace, said, "By Him in whose hand myself is! To take your rope and gather firewood on your back is better for you than that you come to a man to whom Allah has given some of His favour and ask him, so he gives to you or refuses."


Malik :: Sadaqa :: [58-58.2.11]

Sadaqa

Malik :: Book 58 : Hadith 58.2.11

Yahya related to me from Malik from Zayd ibn Aslam from Ata ibn Yasar that a man of the Banu Asad said, "My family and I dismounted to rest at Baqi. My family said to me, 'Go to the Messenger of Allah, may Allah bless him and grant him peace, and ask him for something that we can eat,' and they began to mention their need. I went to the Messenger of Allah, may Allah bless him and grant him peace, and found that a man was asking for something, and the Messenger of Allah, may Allah bless him and grant him peace, was saying, 'I do not have anything to give you.' The man turned away from him in anger, saying, 'By my life! You give to whomever you wish.' The Messenger of Allah, may Allah bless him and grant him peace, said, 'He is angry with me because I do not have anything to give him. Whoever asks of you while he has an uqiya or its like, has asked with importunity.' "

The man continued, "I said to myself about a camel that we had, 'It is better than an uqiya.' (Malik explained that an uqiya was forty dirhams.) So I returned and did not ask him for anything, and the Messenger of Allah, may Allah bless him and grant him peace, sent me barley and raisins after that. He gave us from his share until Allah, the Mighty, the Majestic gave us relief."


Malik :: Sadaqa :: [58-58.2.12]

Sadaqa

Malik :: Book 58 : Hadith 58.2.12

Yahya related that Malik heard al-Ala ibn Abd ar-Rahman say, "Sadaqa does not decrease property, and Allah only increases a slave in worth for his restraint, and no slave is humble but that Allah raises him."

Malik said, "I do not know whether this hadith goes back to the Prophet, may Allah bless him and grant him peace, or not."


Malik :: Sadaqa :: [58-58.3.13]

Sadaqa

Malik :: Book 58 : Hadith 58.3.13

Yahya related to me from Malik that he heard that the Messenger of Allah, may Allah bless him and grant him peace, said, "Sadaqa to the family of Muhammad is not halal. It is only people's impurities."


Malik :: Sadaqa :: [58-58.3.14]

Sadaqa

Malik :: Book 58 : Hadith 58.3.14

Yahya related to me from Malik from Abdullah ibn Abi Bakr from his father that the Messenger of Allah, may Allah bless him and grant him peace, gave a man from the Banu Abd al-Ashal charge over some sadaqa. When he came to ask him for some camels from the sadaqa, the Messenger of Allah, may Allah bless him and grant him peace, was so angry that the anger showed in his face. One way in which anger could be recognised in his face was that his eyes became red. Then he said, "This man has asked me for what is not good for me or him. If I refuse it, I hate to refuse. If I give it to him, I will give him what is not good for me or him." The man said, "Messenger of Allah! I will never ask you for any of it!"


Malik :: Sadaqa :: [58-58.3.15]

Sadaqa

Malik :: Book 58 : Hadith 58.3.15

Yahya related to me from Malik from Zayd ibn Aslam that his father said, "Abdullah ibn al-Arqam said, 'Show me a riding-camel which the amir al-muminim can give me to use.' I said, 'Yes. One of the sadaqa camels.' Abdullah ibn al-Arqam said, 'Would you want a stout man on a hot day to wash for you what is under his lower garment and its folds, and then give it to you to drink?' I was angry and said, 'May Allah forgive you! Why do you say such things to me?' Abdullah ibn al-Arqam said, 'Sadaqa is the impurities of people which they wash off themselves.' "


Malik :: Knowledge :: [59-59.1.1]

Knowledge

Malik :: Book 59 : Hadith 59.1.1

Yahya related to me from Malik that he heard that Luqman al-Hakim made his will and counselled his son, saying, "My son! Sit with the learned men and keep close to them. Allah gives life to the hearts with the light of wisdom as Allah gives life to the dead earth with the abundant rain of the sky."


Malik :: The Supplication of the Unjustly Wronged :: [60-60.1.1]

The Supplication of the Unjustly Wronged

Malik :: Book 60 : Hadith 60.1.1

Yahya related to me from Malik from Zayd ibn Aslam from his father that Umar ibn al-Khattab gave a mawla of his called Hunayy charge over the hima. He said, "Hunayy! Do not harm the people. Fear the supplication of the wronged, for the supplication of the wronged is answered. Let the one with a small herd of camels and the one with a small herd of sheep enter, but be wary of the livestock of Ibn Awf and the livestock of Ibn Affan. If their livestock are destroyed, they will return to palm-trees and agriculture. If the livestock of the one with a small herd of camels and the one with a small herd of sheep are destroyed, he will bring his children to me crying, 'Amir al-muminin! Amir al-Muminin!' Shall I neglect them? Water and pasturage are of less value to me than gold and silver. By Allah, they think that I have wronged them. This is their land and their water. They fought for it in the jahiliyya and became muslims on it in Islam. By He in whose hand my self is! Were it not for the mounts which I give to be ridden in the way of Allah, I would not have turned a span of their land into hima."


Malik :: The Names of the Prophet, may Allah Bless Him and Grant Him Peace :: [61-61.1.1]

The Names of the Prophet, may Allah Bless Him and Grant Him Peace

Malik :: Book 61 : Hadith 61.1.1

Malik related to me from Ibn Shihab from Muhammad ibn Jubayr ibn Mutim that the Prophet, may Allah bless him and grant him peace, said, "I have five names. I am Muhammad. I am Ahmad. I am al-Mahi (the effacer), by whom Allah effaces kufr. I am al-Hashir (the gatherer), before whom people are gathered. I am al-Aqib (the last)."


Dawud :: Purification (Kitab Al-Taharah) :: [1.1]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 1

Narrated Mughirah ibn Shu'bah:

When the Prophet (peace_be_upon_him) went (outside) to relieve himself, he went to a far-off place.


Dawud :: Purification (Kitab Al-Taharah) :: [1.2]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 2

Narrated Jabir ibn Abdullah:

When the Prophet (peace_be_upon_him) felt the need of relieving himself, he went far off where no one could see him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.3]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 3

Narrated AbuMusa:

AbutTayyah reported on the authority of a shaykh (an old man): When Abdullah ibn Abbas came to Basrah, people narrated to him traditions from AbuMusa. Therefore Ibn Abbas wrote to him asking him about certain things. In reply AbuMusa wrote to him saying: One day I was in the company of the Apostle of Allah (peace_be_upon_him). He wanted to urinate. Then he came to a soft ground at the foot of a wall and urinated. He (the Prophet) then said: If any of you wants to urinate, he should look for a place (like this) for his urination.


Dawud :: Purification (Kitab Al-Taharah) :: [1.6]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 6

Narrated Zayd ibn Arqam:

The Apostle of Allah (peace_be_upon_him) said: These privies are frequented by the jinns and devils. So when anyone amongst you goes there, he should say: "I seek refuge in Allah from male and female devils."


Dawud :: Purification (Kitab Al-Taharah) :: [1.7]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 7

Narrated Salman al-Farsi:

It was said to Salman: Your Prophet teaches you everything, even about excrement. He replied: Yes. He has forbidden us to face the qiblah at the time of easing or urinating, and cleansing with right hand, and cleansing with less than three stones, or cleansing with dung or bone.


Dawud :: Purification (Kitab Al-Taharah) :: [1.10]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 10

Narrated Ma'qil ibn AbuMa'qil al-Asadi:

The Apostle of Allah (peace_be_upon_him) has forbidden us to face the two qiblahs at the time of urination or excretion.


Dawud :: Purification (Kitab Al-Taharah) :: [1.11]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 11

Narrated Abdullah ibn Umar:

Marwan al-Asfar said: I saw Ibn Umar make his camel kneel down facing the qiblah, then he sat down urinating in its direction. So I said: AbuAbdurRahman, has this not been forbidden? He replied: Why not, that was forbidden only in open country; but when there is something between you and the qiblah that conceals you , then there is no harm.


Dawud :: Purification (Kitab Al-Taharah) :: [1.13]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 13

Narrated Jabir ibn Abdullah:

The Prophet of Allah (peace_be_upon_him) forbade us to face the qiblah at the time of making water. Then I saw him facing it (qiblah) urinating or easing himself one year before his death.


Dawud :: Purification (Kitab Al-Taharah) :: [1.14]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 14

Narrated Abdullah ibn Umar:

When the Prophet (peace_be_upon_him) wanted to relieve himself, he would not raise his garment, until he lowered himself near the ground.


Dawud :: Purification (Kitab Al-Taharah) :: [1.15]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 15

Narrated AbuSa'id al-Khudri:

I heard the Apostle of Allah (peace_be_upon_him) say: When two persons go together for relieving themselves uncovering their private parts and talking together, Allah, the Great and Majestic, becomes wrathful at this (action).


Dawud :: Purification (Kitab Al-Taharah) :: [1.17]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 17

Narrated Muhajir ibn Qunfudh:

Muhajir came to the Prophet (peace_be_upon_him) while he was urinating. He saluted him. The Prophet (peace_be_upon_him) did not return the salutation to him until he performed ablution. He then apologised to him, saying: I disliked remembering Allah except in the state of purification.


Dawud :: Purification (Kitab Al-Taharah) :: [1.19]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 19

Narrated Anas ibn Malik:

When the Prophet (peace_be_upon_him) entered the privy, he removed his ring.


Dawud :: Purification (Kitab Al-Taharah) :: [1.22]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 22

Narrated Amr ibn al-'As:

AbdurRahman ibn Hasanah reported: I and Amr ibn al-'As went to the Prophet (peace_be_upon_him). He came out with a leather shield (in his hand). He covered himself with it and urinated. Then we said: Look at him. He is urinating as a woman does. The Prophet (peace_be_upon_him), heard this and said: Do you not know what befell a person from amongst Banu Isra'il (the children of Israel)? When urine fell on them, they would cut off the place where the urine fell; but he (that person) forbade them (to do so), and was punished in his grave.


Dawud :: Purification (Kitab Al-Taharah) :: [1.24]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 24

Narrated Umaymah daughter of Ruqayqah:

The Prophet (peace_be_upon_him) had a wooden vessel under his bed in which he would urinate at night.


Dawud :: Purification (Kitab Al-Taharah) :: [1.26]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 26

Narrated Mu'adh ibn Jabal:

The Apostle of Allah (peace_be_upon_him) said: Be on your guard against three things which provoke cursing: easing in the watering places and on the thoroughfares, and in the shade (of the tree).


Dawud :: Purification (Kitab Al-Taharah) :: [1.27]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 27

Narrated Abdullah ibn Mughaffal:

The Apostle of Allah (peace_be_upon_him) said: No one of you should make water in his bath and then wash himself there (after urination).

The version of Ahmad has: Then performs ablution there, for evil thoughts come from it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.28]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 28

Narrated A Man from the Companions:

Humayd al-Himyari said: I met a man (Companion of the Prophet) who remained in the company of the Prophet (peace_be_upon_him) just as AbuHurayrah remained in his company. He then added: The Apostle of Allah (peace_be_upon_him) forbade that anyone amongst us should comb (his hair) every day or urinate in the place where he takes a bath.


Dawud :: Purification (Kitab Al-Taharah) :: [1.29]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 29

Narrated Abdullah ibn Sarjis:

The Prophet (peace_be_upon_him) prohibited to urinate in a hole.


Dawud :: Purification (Kitab Al-Taharah) :: [1.30]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 30

Narrated Aisha, Ummul Mu'minin:

When the Prophet (peace_be_upon_him) came out of the privy, he used to say: "Grant me Thy forgiveness."


Dawud :: Purification (Kitab Al-Taharah) :: [1.32]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 32

Narrated Hafsah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used his right hand for taking his food and drink and used his left hand for other purposes.


Dawud :: Purification (Kitab Al-Taharah) :: [1.33]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 33

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used his right hand for getting water for ablution and taking food, and his left hand for his evacuation and for anything repugnant.


Dawud :: Purification (Kitab Al-Taharah) :: [1.35]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 35

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone applies collyrium, he should do it an odd number of times. If he does so, he has done well; but if not, there is no harm. If anyone cleanses himself with pebbles, he should use an odd number. If he does so, he has done well; but if not, there is no harm.

If anyone eats, he should throw away what he removes with a toothpick and swallow what sticks to his tongue. If he does so, he has done well; if not, there is no harm. If anyone goes to relieve himself, he should conceal himself, and if all he can do is to collect a heap of send, he should sit with his back to it, for the devil makes sport with the posteriors of the children of Adam. If he does so, he has done well; but if not, there is no harm.


Dawud :: Purification (Kitab Al-Taharah) :: [1.36]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 36

Narrated Ruwayfi' ibn Thabit:

Shayban al-Qatbani reported that Maslamah ibn Mukhallad made Ruwayfi' ibn Thabit the governor of the lower parts (of Egypt). He added: We travelled with him from Kum Sharik to Alqamah or from Alqamah to Kum Sharik (the narrator doubts) for Alqam.

Ruwayfi' said: Any one of us would borrow a camel during the lifetime of the Prophet (peace_be_upon_him) from the other, on condition that he would give him half the booty, and the other half he would retain himself.

Further, one of us received an arrowhead and a feather, and the other an arrow-shaft as a share from the booty.

He then reported: The Apostle of Allah (peace_be_upon_him) said: You may live for a long time after I am gone, Ruwayfi', so, tell people that if anyone ties his beard or wears round his neck a string to ward off the evil eye, or cleanses himself with animal dung or bone, Muhammad has nothing to do with him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.39]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 39

Narrated Abdullah ibn Mas'ud:

A deputation of the jinn came to the Prophet (peace_be_upon_him) and said: O Muhammad, forbid your community to cleans themselves with a bone or dung or charcoal, for in them Allah has provided sustenance for us. So the Prophet (peace_be_upon_him) forbade them to do so.


Dawud :: Purification (Kitab Al-Taharah) :: [1.40]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 40

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: When any of you goes to relieve himself, he should take with him three stones to cleans himself, for they will be enough for him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.41]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 41

Narrated Khuzaymah ibn Thabit:

The Prophet (peace_be_upon_him) was asked about cleansing (after relieving oneself). He said: (One should cleanse oneself) with three stones which should be free from dung.


Dawud :: Purification (Kitab Al-Taharah) :: [1.42]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 42

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) urinated and Umar was standing behind him with a jug of water. He said: What is this, Umar? He replied: Water for you to perform ablution with. He said: I have not been commanded to perform ablution every time I urinate. If I were to do so, it would become a sunnah.


Dawud :: Purification (Kitab Al-Taharah) :: [1.44]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 44

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The following verse was revealed in connection with the people of Quba': "In it are men who love to be purified" (ix.108). He (AbuHurayrah) said: They used to cleanse themselves with water after easing. So the verse was revealed in connection with them.


Dawud :: Purification (Kitab Al-Taharah) :: [1.47]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 47

Narrated Zayd ibn Khalid al-Juhani:

I heard the Apostle of Allah (peace_be_upon_him) say: Were it not hard on my ummah, I would order them to use the tooth-stick at the time of every prayer. AbuSalamah said: Zayd ibn Khalid used to attend the prayers in the mosque with his tooth-stick on his ear where a clerk carries a pen, and whenever he got up for prayer he used it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.48]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 48

Narrated Abdullah ibn Hanzalah ibn AbuAmir:

Muhammad ibn Yahya ibn Habban asked Abdullah ibn Abdullah ibn Umar about the reason for Ibn Umar's performing ablution for every prayer, whether he was with or without ablution.

He replied: Asma', daughter of Zayd ibn al-Khattab, reported to me that Abdullah ibn Hanzalah ibn AbuAmir narrated to her that the Apostle of Allah (peace_be_upon_him) was earlier commanded to perform ablution for every prayer whether or not he was with ablution.

When it became a burden for him, he was ordered to use tooth-stick for every prayer. As Ibn Umar thought that he had the strength (to perform the ablution for every prayer), he did not give up performing ablution for every prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.50]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 50

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) was using the tooth-stick, when two men, one older than the other, were with him. A revelation came to him about the merit of using the tooth-stick. He was asked to show proper respect and give it to the elder of the two.


Dawud :: Purification (Kitab Al-Taharah) :: [1.52]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 52

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Ten are the acts according to fitrah (nature): clipping the moustache, letting the beard grow, using the tooth-stick, cutting the nails, washing the finger joints, plucking the hair under the arm-pits, shaving the pubes, and cleansing one's private parts (after easing or urinating) with water. The narrator said: I have forgotten the tenth, but it may have been rinsing the mouth.


Dawud :: Purification (Kitab Al-Taharah) :: [1.55]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 55

Narrated Aisha, Ummul Mu'minin:

Ablution water and tooth-stick were placed by the side of the Prophet (peace_be_upon_him). When he got up during the night (for prayer), he relieved himself, then he used the tooth-stick.


Dawud :: Purification (Kitab Al-Taharah) :: [1.56]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 56

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) did not get up after sleeping by night or by day without using the tooth-stick before performing ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.59]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 59

Narrated AbulMalih:

The Prophet (peace_be_upon_him) said: Allah does not accept charity from goods acquired by embezzlement as He does not accept prayer without purification.


Dawud :: Purification (Kitab Al-Taharah) :: [1.61]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 61

Narrated Ali ibn AbuTalib:

The key to prayer is purification; its beginning is takbir and its end is taslim.


Dawud :: Purification (Kitab Al-Taharah) :: [1.62]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 62

Narrated Abdullah ibn Umar:

AbuGhutayf al-Hudhali reported: I was in the company of Ibn Umar. When the call was made for the noon (zuhr) prayer, he performed ablution and said the prayer. When the call for the afternoon ('asr) prayer was made, he again performed ablution. Thus I asked him (about the reason of performing ablution). He replied: The Apostle of Allah (peace_be_upon_him) said: For a man who performs ablution in a state of purity, ten virtuous deeds will be recorded (in his favour).

AbuDawud said: This is the tradition narrated by Musaddad, and it is more perfect.


Dawud :: Purification (Kitab Al-Taharah) :: [1.63]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 63

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him), was asked about water (in desert country) and what is frequented by animals and wild beasts. He replied: When there is enough water to fill two pitchers, it bears no impurity.


Dawud :: Purification (Kitab Al-Taharah) :: [1.66]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 66

Narrated AbuSa'id al-Khudri:

The people asked the Messenger of Allah (peace_be_upon_him): Can we perform ablution out of the well of Buda'ah, which is a well into which menstrual clothes, dead dogs and stinking things were thrown? He replied: Water is pure and is not defiled by anything.


Dawud :: Purification (Kitab Al-Taharah) :: [1.67]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 67

Narrated AbuSa'id al-Khudri:

I heard that the people asked the Prophet of Allah (peace_be_upon_him): Water is brought for you from the well of Buda'ah. It is a well in which dead dogs, menstrual clothes and excrement of people are thrown. The Messenger of Allah (peace_be_upon_him) replied: Verily water is pure and is not defiled by anything.


Dawud :: Purification (Kitab Al-Taharah) :: [1.68]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 68

Narrated Abdullah ibn Abbas:

One of the wives of the Prophet (peace_be_upon_him) took a bath from a large bowl. The Prophet (peace_be_upon_him) wanted to perform ablution or take from the water left over. She said to him: O Prophet of Allah, verily I was sexually defiled. The Prophet said: Water not defiled.


Dawud :: Purification (Kitab Al-Taharah) :: [1.70]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 70

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: None amongst you should urinate in standing water, then wash in it after sexual defilement.


Dawud :: Purification (Kitab Al-Taharah) :: [1.75]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 75

Narrated AbuQatadah:

Kabshah, daughter of Ka'b ibn Malik and wife of Ibn AbuQatadah, reported: AbuQatadah visited (me) and I poured out water for him for ablution. A cat came and drank some of it and he tilted the vessel for it until it drank some of it. Kabshah said: He saw me looking at him; he asked me: Are you surprised, my niece? I said: Yes. He then reported the Messenger of Allah (peace_be_upon_him) as saying: It is not unclean; it is one of those (males or females) who go round among you.


Dawud :: Purification (Kitab Al-Taharah) :: [1.76]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 76

Narrated Aisha, Ummul Mu'minin:

Dawud ibn Salih ibn Dinar at-Tammar quoted his mother as saying that her mistress sent her with some pudding (harisah) to Aisha who was offering prayer. She made a sign to me to place it down. A cat came and ate some of it, but when Aisha finished her prayer, she ate from the place where the cat had eaten. She stated: The Messenger of Allah (peace_be_upon_him) said: It is not unclean: it is one of those who go round among you. She added: I saw the Messenger of Allah (peace_be_upon_him) performing ablution from the water left over by the cat.


Dawud :: Purification (Kitab Al-Taharah) :: [1.78]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 78

Narrated Aisha, Ummul Mu'minin:

My hands and the hands of the Messenger of Allah (peace_be_upon_him) alternated into one vessel while we performed ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.81]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 81

Narrated Humayd al-Himyari:

Humayd al-Himyari reported: I met a person (among the Companion of Prophet) who remained in the company of the Prophet (peace_be_upon_him)for four years as AbuHurayrah remained in his company. He reported: The Apostle of Allah (peace_be_upon_him) forbade that the female should wash with the water left over by the male, and that the male should wash with the left-over of the female.

The version of Musaddad adds: "That they both take the handful of water together."


Dawud :: Purification (Kitab Al-Taharah) :: [1.82]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 82

Narrated Hakam ibn Amr:

The Prophet (peace_be_upon_him) forbade that the male should perform ablution with the water left over by the female.


Dawud :: Purification (Kitab Al-Taharah) :: [1.83]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 83

Narrated AbuHurayrah:

A man asked the Apostle of Allah (peace_be_upon_him): Messenger of Allah, we travel on the sea and take a small quantity of water with us. If we use this for ablution, we would suffer from thirst. Can we perform ablution with sea water? The Messenger (peace_be_upon_him) replied: Its water is pure and what dies in it is lawful food.


Dawud :: Purification (Kitab Al-Taharah) :: [1.84]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 84

Narrated Abdullah ibn Mas'ud:

AbuZayd quoted Abdullah ibn Mas'ud as saying that on the night when the jinn listened to the Qur'an the Prophet (peace_be_upon_him) said: What is in your skin vessel? He said: I have some nabidh. He (the Holy Prophet) said: It consists of fresh dates and pure water.

Sulayman ibn Dawud reported the same version of this tradition on the authority of AbuZayd or Zayd. But Sharik said that Hammad did not mention the words "night of the jinn".


Dawud :: Purification (Kitab Al-Taharah) :: [1.88]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 88

Narrated Abdullah ibn al-Arqam:

Urwah reported on the authority of his father that Abdullah ibn al-Arqam travelled for performing hajj (pilgrimage) or umrah. He was accompanied by the people whom he led in prayer. One day when he was leading them in the dawn (fajr) prayer, he said to them: One of you should come forward. He then went away to relieve himself. He said: I heard the Messenger of Allah (peace_be_upon_him) say: When any of you feels the need of relieving himself while the congregational prayer is ready, he should go to relieve himself.


Dawud :: Purification (Kitab Al-Taharah) :: [1.90]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 90

Narrated Thawban:

The Messenger of Allah (peace_be_upon_him) said: Three things one is not allowed to do: supplicating Allah specifically for himself and ignoring others while leading people in prayer; if he did so, he deceived them; looking inside a house before taking permission: if he did so, it is as if he entered the house, saying prayer while one is feeling the call of nature until one eases oneself.


Dawud :: Purification (Kitab Al-Taharah) :: [1.91]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 91

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: It is not permissible for a man who believes in Allah and in the Last Day that he should say the prayer while he is feeling the call of nature until he becomes light (by relieving himself).


Dawud :: Purification (Kitab Al-Taharah) :: [1.92]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 92

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used to wash himself with a sa' (of water) and perform ablution with a mudd (of water).


Dawud :: Purification (Kitab Al-Taharah) :: [1.93]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 93

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) used to take a bath with a sa' (of water) and perform ablution with a mudd (of water)


Dawud :: Purification (Kitab Al-Taharah) :: [1.94]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 94

Narrated Umm Umarah:

Habib al-Ansari reported: I heard Abbad ibn Tamim who reported on the authority of my grandmother, Umm Umarah, saying: The Prophet (peace_be_upon_him) wanted to perform ablution. A vessel containing 2/3 mudd of water was brought to him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.96]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 96

Narrated Abdullah ibn Mughaffal:

Abdullah heard his son praying to Allah: O Allah, I ask Thee a white palace on the right of Paradise when I enter it. He said: O my son, ask Allah for Paradise and seek refuge in Him from Hell-Fire, for I heard the Messenger of Allah (peace_be_upon_him) say: In this community there will be some people who will exceed the limits in purification as well as in supplication.


Dawud :: Purification (Kitab Al-Taharah) :: [1.98]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 98

Narrated Aisha, Ummul Mu'minin:

I and the Messenger of Allah (peace_be_upon_him) used to take bath with a brass vessel.


Dawud :: Purification (Kitab Al-Taharah) :: [1.100]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 100

Narrated Abdullah ibn Zayd:

The Messenger of Allah (peace_be_upon_him) came upon us. We brought water for him in a brass vessel and he performed ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.101]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 101

Narrated AbuHurayrah:

The Messenger of Allah (peace_be_upon_him) said: The prayer of a person who does not perform ablution is not valid, and the ablution of a person who does not mention the name of Allah (in the beginning) is not valid.


Dawud :: Purification (Kitab Al-Taharah) :: [1.111]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 111

Narrated Ali ibn AbuTalib:

Abdu Khayr said: Ali came upon us and he had already offered prayer. He called for water. We asked: What will you do with water when you have already offered prayer? - Perhaps to teach us. A utensil containing water and a wash-basin were brought (to him).

He poured water from the utensil on his right hand and washed both his hands three times, rinsed the mouth, snuffed up water and cleansed the nose three times. He then rinsed the mouth and snuffed up water with the same hand by which he took water. He then washed his face three times, and washed his right hand three times and washed his left hand three times. He then put his hand in water and wiped his head once.

He then washed his right foot thrice and left foot thrice, then said: If one is pleased to know the method of performing ablution of the Apostle of Allah, this is how he did it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.121]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 121

Narrated Al-Miqdam ibn Ma'dikarib al-Kindi:

The ablution water was brought to the Messenger (peace_be_upon_him) and he performed ablution; he washed his hands up to wrists three times, then washed his forearms three times. He then rinsed his mouth and snuffed up water three times; then he wiped his head and ears inside and outside.


Dawud :: Purification (Kitab Al-Taharah) :: [1.124]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 124

Narrated Mu'awiyah:

AbulAzhar al-Mughirah ibn Farwah and Yazid ibn AbuMalik reported: Mu'awiyah performed ablution before the people, as he saw the Apostle of Allah (peace_be_upon_him) performed ablution. When he reached the stage of wiping his head, he took a handful of water and poured it with his left hand over the middle of his head so much so that drops of water came down or almost came down. Then he wiped (his head) from its front to its back and from its back to its front.


Dawud :: Purification (Kitab Al-Taharah) :: [1.126]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 126

Narrated Ar-Rubayyi' daughter of Mu'awwidh ibn Afra':

The Messenger of Allah (peace_be_upon_him) used to come to us. He once said: Pour ablution water on me. She then described how the Prophet (peace_be_upon_him) performed ablution saying: He washed his hands up to wrist three times and washed his face three times, and rinsed his mouth and snuffed up water once. Then he washed his forearms three times and wiped his head twice beginning from the back of his head, then wiped its front. He wiped his ears outside and inside. Then he washed his feet three times.


Dawud :: Purification (Kitab Al-Taharah) :: [1.131]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 131

Narrated Ar-Rubayyi' daughter of Mu'awwidh ibn Afra':

The Prophet (peace_be_upon_him) performed ablution. He inserted his two fingers in the ear-holes.


Dawud :: Purification (Kitab Al-Taharah) :: [1.132]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 132

Narrated Talhah ibn Musarrif:

I saw the Apostle of Allah (peace_be_upon_him) wiping his head once up to his nape.


Dawud :: Purification (Kitab Al-Taharah) :: [1.133]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 133

Narrated Abdullah ibn Abbas:

Sa'id ibn Jubayr reported: Ibn Abbas saw the Apostle of Allah (peace_be_upon_him) performed ablution. He narrated the tradition which says that he (the Prophet) performed each detail of ablution three times. He wiped his head and ears once.


Dawud :: Purification (Kitab Al-Taharah) :: [1.134]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 134

Narrated AbuUmamah:

AbuUmamah mentioned how the Messenger of Allah (peace_be_upon_him) performed ablution, saying that he used to wipe the corners of his eyes, and he said that the ears are treated as part of the head.


Dawud :: Purification (Kitab Al-Taharah) :: [1.135]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 135

Narrated Abdullah ibn Amr ibn al-'As:

A man came to the Prophet (peace_be_upon_him) and asked him: Messenger of Allah, how is the ablution (to performed)?

He (the Prophet) then called for water in a vessel and washed his hands up to the wrists three times, then washed his face three times, and washed his forearms three times. He then wiped his head and inserted both his index fingers in his ear-holes; he wiped the back of his ears with his thumbs and the front of his ears with the index fingers. He then washed his feet three times.

Then he said: This is how ablution should be performed. If anyone does more or less than this, he has done wrong and transgressed, or (said) transgressed and done wrong.


Dawud :: Purification (Kitab Al-Taharah) :: [1.136]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 136

Narrated AbuHurayrah:

The Prophet (my peace be upon him) washed the limbs in ablution twice.


Dawud :: Purification (Kitab Al-Taharah) :: [1.139]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 139

Narrated Grandfather of Talhah:

I entered upon the Prophet (peace_be_upon_him) while he was performing ablution, and the water was running down his face and beard to his chest. I saw him rinsing his mouth and snuffing up water separately.


Dawud :: Purification (Kitab Al-Taharah) :: [1.141]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 141

Narrated Abdullah ibn Abbas:

The Messenger of Allah (peace_be_upon_him) said: Cleanse your nose well (after snuffing up water) twice or thrice.


Dawud :: Purification (Kitab Al-Taharah) :: [1.142]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 142

Narrated Laqit ibn Sabirah:

I was the leader of the delegation of Banu al-Muntafiq or (the narrator doubted) I was among the delegation of Banu al-Muntafiq that came to the Messenger of Allah (peace_be_upon_him). When we reached the Prophet, we did not find him in his house. We found there Aisha, the Mother of the Believers. She ordered that a dish called Khazirah should be prepared for us. It was then prepared. A tray containing dates was then presented to us. (The narrator Qutaybah did not mention the word qina', tray).

Then the Messenger of Allah (peace_be_upon_him) came. He asked: Has anything been served to you or ordered for you? We replied: Yes, Messenger of Allah. While we were sitting in the company of the Messenger of Allah (peace_be_upon_him) we suddenly saw that a shepherd was driving a herd of sheep to their fold. He had with him a newly-born lamb that was crying.

He (the Prophet) asked him: What did it bear, O so and so? He replied: A ewe. He then said: Slaughter for us in its place a sheep. Do not think that we are slaughtering it for you. We have one hundred sheep and we do not want their number to increase. Whenever a ewe is born, we slaughter a sheep in its place.

(The narrator says that the Prophet (peace_be_upon_him) used the word la tahsabanna, do not think).

I (the narrator Laqit) then said: Messenger of Allah, I have a wife who has something (wrong) in her tongue, i.e. she is insolent. He said: Then divorce her. I said: Messenger of Allah, she had company with me and I have children from her. He said: Then ask her (to obey you). If there is something good in her, she will do so (obey); and do not beat your wife as you beat your slave-girl.

I said: Messenger of Allah, tell me about ablution. He said: Perform ablution in full and make the fingers go through the beard and snuff with water well except when you are fasting.


Dawud :: Purification (Kitab Al-Taharah) :: [1.145]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 145

Narrated Anas ibn Malik:

Whenever the Messenger of Allah (peace_be_upon_him) performed ablution, he took a handful of water, and, putting it under his chin, made it go through his beard, saying: Thus did my Lord command me.


Dawud :: Purification (Kitab Al-Taharah) :: [1.146]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 146

Narrated Thawban:

The Messenger of Allah (peace_be_upon_him) sent out an expedition. They were affected by cold. When they returned to the Messenger of Allah (peace_be_upon_him), he commanded them to wipe over turbans and stockings.


Dawud :: Purification (Kitab Al-Taharah) :: [1.147]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 147

Narrated Anas ibn Malik:

I saw the Messenger (peace_be_upon_him) perform ablution. He had a Qutri turban. He inserted his hand beneath the turban and wiped over the forelock, and did not untie the turban.


Dawud :: Purification (Kitab Al-Taharah) :: [1.148]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 148

Narrated Al-Mustawrid ibn Shaddad:

I saw the Messenger of Allah (peace_be_upon_him) rubbing his toes with his little finger when he performed ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.155]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 155

Narrated AbuMusa al-Ash'ari:

Negus presented to the Messenger of Allah (peace_be_upon_him) two black and simple socks. He put them on; then he performed ablution and wiped over them.


Dawud :: Purification (Kitab Al-Taharah) :: [1.157]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 157

Narrated Khuzaymah ibn Thabit:

The Prophet (peace_be_upon_him) said: The time limit for wiping over the socks for a traveller is three days (and three nights) and for a resident it is one day and one night.


Dawud :: Purification (Kitab Al-Taharah) :: [1.158]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 158

Narrated Ubayy ibn Umarah:

I asked: Messenger of Allah (peace_be_upon_him) may I wipe over the socks? He replied: Yes. He asked: For one day? He replied: For one day. He again asked: And for two days? He replied: For two days too. He again asked: And for three days? He replied: Yes, as long as you wish.


Dawud :: Purification (Kitab Al-Taharah) :: [1.159]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 159

Narrated Al-Mughirah ibn Shu'bah:

The Messenger of Allah (peace_be_upon_him) performed ablution and wiped over the stockings and shoes.


Dawud :: Purification (Kitab Al-Taharah) :: [1.160]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 160

Narrated Aws ibn AbuAws ath-Thaqafi:

The Messenger of Allah (peace_be_upon_him) performed ablution and wiped over his shoes and feet.

Abbad (a sub-narrator) said: The Messenger of Allah (peace_be_upon_him) came to the well of a people. Musaddad did not mention the words Midat (a place where ablution is performed), and Kazamah (well). Then both agreed on the wording:"He performed ablution and wiped over his shoes and feet."


Dawud :: Purification (Kitab Al-Taharah) :: [1.161]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 161

Narrated Al-Mughirah ibn Shu'bah:

The Messenger of Allah (peace_be_upon_him) wiped over the socks.


Dawud :: Purification (Kitab Al-Taharah) :: [1.162]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 162

Narrated Ali ibn AbuTalib:

If the religion were based on opinion, it would be more important to wipe the under part of the shoe than the upper but I have seen the Messenger of Allah (peace_be_upon_him) wiping over the upper part of his shoes.


Dawud :: Purification (Kitab Al-Taharah) :: [1.165]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 165

Narrated Al-Mughirah ibn Shu'bah:

I poured water while the Prophet (peace_be_upon_him) performed ablution in the battle of Tabuk. He wiped over the upper part of the socks and their lower part.


Dawud :: Purification (Kitab Al-Taharah) :: [1.166]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 166

Narrated Hakam ibn Sufyan ath-Thaqafi:

When the Messenger of Allah (peace_be_upon_him) urinated, he performed ablution and sprinkled water on private parts of the body.


Dawud :: Purification (Kitab Al-Taharah) :: [1.175]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 175

Narrated Some Companions of the Prophet:

The Prophet (peace_be_upon_him) saw a person offering prayer, and on the back of his foot a small part equal to the space of a dirham remained unwashed; the water did not reach it. The Prophet (peace_be_upon_him) commanded him to repeat the ablution and prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.178]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 178

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) kissed me and did not perform ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.181]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 181

Narrated Busrah daughter of Safwan:

Abdullah ibn AbuBakr reported that he heard Urwah say: I entered upon Marwan ibn al-Hakam. We mentioned things that render the ablution void. Marwan said: Does it become void by touching the penis? Urwah replied: This I do not know. Marwan said: Busrah daughter of Safwan reported to me that she heard the Messenger of Allah (peace_be_upon_him) say: He who touches his penis should perform ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.182]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 182

Narrated Talq:

We came upon the Prophet of Allah (peace_be_upon_him). A man came to him: he seemed to be a bedouin. He said: Prophet of Allah, what do you think about a man who touches his penis after performing ablution? He (peace_be_upon_him) replied: That is only a part of his body.


Dawud :: Purification (Kitab Al-Taharah) :: [1.184]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 184

Narrated Al-Bara' ibn Azib:

The Messenger of Allah (peace_be_upon_him) was asked about performing ablution after eating the flesh of the camel. He replied: Perform ablution, after eating it. He was asked about performing ablution after eating meat. He replied: Do not perform ablution after eating it. He was asked about saying prayer in places where the camels lie down. He replied: Do not offer prayer in places where the camels lie down. These are the places of Satan. He was asked about saying prayer in the sheepfolds. He replied: You may offer prayer in such places; these are the places of blessing.


Dawud :: Purification (Kitab Al-Taharah) :: [1.185]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 185

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) passed by a boy who was skinning a goat. The Messenger of Allah (peace_be_upon_him) said: Give it up until I show you. He (the Prophet) inserted his hand between the skin and the flesh until it reached the armpit. He then went away and led the people in prayer and he did not perform ablution. The version of Amr added that he did not touch water.


Dawud :: Purification (Kitab Al-Taharah) :: [1.188]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 188

Narrated Al-Mughirah ibn Shu'bah:

One night I became the guest of the Prophet (peace_be_upon_him). He ordered that a piece of mutton be roasted, and it was roasted. He then took a knife and began to cut the meat with it for me. In the meantime Bilal came and called him for prayer. He threw the knife and said: What happened! may his hands be smeared with earth! He then stood for offering prayer. Al-Anbari added: My moustaches became lengthy. He trimmed them by placing a took-stick; or he said: I shall trim your moustaches by placing the tooth-stick there.


Dawud :: Purification (Kitab Al-Taharah) :: [1.189]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 189

Narrated Abdullah ibn Abbas:

The Messenger of Allah (peace_be_upon_him) took a shoulder (of goat's meat) and after wiping his hand with a cloth on which he was sitting, he got up and prayed.


Dawud :: Purification (Kitab Al-Taharah) :: [1.193]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 193

Narrated Abdullah ibn Harith ibn Jaz':

One of the Companions of the Prophet (may peace be upon), came upon us in Egypt. When he was narrating traditions in the Mosque of Egypt, I heard him say: I was the seventh or the sixth person in the company of the Messenger of Allah ( peace be upon him) in the house of a person.

In the meantime Bilal came and called him for prayer. He came out and passed by a person who had his fire-pan on the fire. The Messenger of Allah (peace_be_upon_him) said to him: Has the food in the fire-pan been cooked? He replied: Yes, my parents be sacrificed upon you. He then took a piece out of it and continued to chew it until he uttered the first takbir (AllahuAkbar) of the prayer. All this time I was looking at him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.195]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 195

Narrated Umm Habibah:

AbuSufyan ibn Sa'id ibn al-Mughirah reported that he entered upon Umm Habibah who presented him a glass of sawiq (a drink prepared with flour and water) to drink. He called for water and rinsed his mouth. She said: O my cousin, don't you perform ablution? The Prophet (peace_be_upon_him) said: Perform ablution after eating anything cooked with fire, or he said: anything touched by fire.


Dawud :: Purification (Kitab Al-Taharah) :: [1.197]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 197

Narrated Anas ibn Malik:

The Messenger of Allah (peace_be_upon_him) drank some milk and he did not rinse his mouth nor did he perform ablution, and he offered the prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.198]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 198

Narrated Jabir ibn Abdullah:

We proceeded in the company of the Messenger of Allah (peace_be_upon_him) for the battle of Dhat ar-Riqa. One of the Muslims killed the wife of one of the unbelievers. He (the husband of the woman killed) took an oath saying: I shall not rest until I kill one of the companions of Muhammad.

He went out following the footsteps of the Prophet (peace_be_upon_him). The Prophet (peace_be_upon_him) encamped at a certain place. He said: Who will keep a watch on us? A person from the Muhajirun (Emigrants) and another from the Ansar (Helpers) responded. He said: Go to the mouth of the mountain-pass. When they went to the mouth of the mountain-pass the man from the Muhajirun lay down while the man from the Ansar stood praying.

The man (enemy) came to them. When he saw the person he realised that he was the watchman of the Muslims. He shot him with an arrow and hit the target. But he (took the arrow out and) threw it away. He (the enemy) then shot three arrows. Then he (the Muslim) bowed and prostrated and awoke his companion. When he (the enemy) perceived that they (the Muslims) had become aware of his presence, he ran away.

When the man from the Muhajirun saw the (man from the Ansar) bleeding, he asked him: Glory be to Allah! Why did you not wake me up the first time when he shot at you.

He replied: I was busy reciting a chapter of the Qur'an. I did not like to leave it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.202]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 202

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) used to prostrate and sleep (in prostration) and produce puffing sounds (during sleep). Then he would stand and pray and would not perform ablution. I said to him: you prayed but did not perform ablution though you slept (in prostration). He replied: Ablution is necessary for one who sleeps while he is lying down. Uthman and Hannad added: For when he lies down, his joints are relaxed.


Dawud :: Purification (Kitab Al-Taharah) :: [1.203]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 203

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) said: The eyes are the leather strap of the anus, so one who sleeps should perform ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.204]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 204

Narrated Abdullah ibn Mas'ud:

We would not wash our feet after treading on something unclean, nor would we hold our hair and garments (during prayer).


Dawud :: Purification (Kitab Al-Taharah) :: [1.205]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 205

Narrated Ali ibn Talq:

The Apostle of Allah (peace_be_upon_him) said: When any of you breaks wind during the prayer, he should turn away and perform ablution and repeat the prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.207]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 207

Narrated Al-Miqdad ibn al-Aswad:

Ali ibn AbuTalib commanded him to ask the Apostle of Allah (peace_be_upon_him) what a man should do when he wants to have intercourse with his wife and the prostatic fluid comes out (at this moment). (He said): I am ashamed of consulting him because of the position of his daughter. Al-Miqdad said: I asked the Apostle of Allah (peace_be_upon_him) about it. He said: When any of you finds, he should wash his private part, and perform ablution as he does for prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.210]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 210

Narrated Sahl ibn Hunayf:

I felt greatly distressed by the frequent flowing of prostatic fluid. For this reason I used to take a bath very often. I asked the apostle of Allah (peace_be_upon_him) about this. He replied: Ablution will be sufficient for you because of this. I asked: Apostle of Allah, what should I do if it smears my clothes. He replied: It is sufficient if you take a handful of water and sprinkle it on your clothe when you find it has smeared it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.211]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 211

Narrated Abdullah ibn Sa'd al-Ansari:

I asked the Apostle of Allah (peace_be_upon_him) as to what makes it necessary to take a bath and about the (prostatic) fluid that flows after taking a bath. He replied: that is called madhi (prostatic fluid). It flows from every male. You should wash your private parts and testicles because of it and perform ablution as you do for prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.212]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 212

Narrated Abdullah ibn Sa'd al-Ansari:

Abdullah asked the Apostle of Allah (peace_be_upon_him): What is lawful for me to do with my wife when she is menstruating? He replied: What is above the waist-wrapper is lawful for you.

The narrator also mentioned (the lawfulness of) eating with a woman in menstruation, and he transmitted the tradition in full.


Dawud :: Purification (Kitab Al-Taharah) :: [1.213]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 213

Narrated Mu'adh ibn Jabal:

I asked the Apostle of Allah (peace_be_upon_him): What is lawful for a man to do with his wife when she is menstruating? He replied: What is above the waist-wrapper, but it is better to abstain from it, too.


Dawud :: Purification (Kitab Al-Taharah) :: [1.219]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 219

Narrated AbuRafi':

One day the Prophet (peace_be_upon_him) had intercourse with all his wives. He took a bath after each intercourse. I asked him: Apostle of Allah, why don't you make it a single bath? He replied: This is more purifying, better and cleaning.


Dawud :: Purification (Kitab Al-Taharah) :: [1.225]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 225

Narrated Ammar ibn Yasir:

The Prophet (peace_be_upon_him) granted permission to a person who was sexually defiled to eat or drink or sleep after performing ablution.


Dawud :: Purification (Kitab Al-Taharah) :: [1.226]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 226

Narrated Aisha, Ummul Mu'minin:

Ghudayf ibn al-Harith reported: I asked Aisha: Have you seen the Apostle of Allah (peace_be_upon_him) washing (because of defilement) at the beginning of the night or at the end?

She replied: Sometimes he would take a bath at the beginning of the night and sometimes at the end.

Thereupon I exclaimed: Allah is most Great. All Praise be to Allah Who made this matter accommodative.

I again asked her: What do you think, did the Apostle of Allah (peace_be_upon_him) say the witr prayer (additional prayer after obligatory prayer at night) in the beginning of the night or at the end?

She replied: Sometimes he would say the witr prayer at the beginning of the night and sometimes at the end.

I exclaimed: Allah is most Great. All praise be to Allah Who made the matter accommodative.

Again I asked her: What do you think, did the Apostle of Allah (peace_be_upon_him) recite the Qur'an (in the prayer) loudly or softly?

She replied: Sometimes he would recite loudly and sometimes softly.

I exclaimed: Allah is most Great. All praise be to Allah Who made the matter flexible.


Dawud :: Purification (Kitab Al-Taharah) :: [1.227]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 227

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: Angels do not enter the house where there is a picture, or a dog, or a person who is sexually defiled.


Dawud :: Purification (Kitab Al-Taharah) :: [1.228]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 228

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) would sleep while he was sexually defiled without touching water.


Dawud :: Purification (Kitab Al-Taharah) :: [1.229]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 229

Narrated Ali ibn AbuTalib:

Abdullah ibn Salamah said: I, accompanied by other two persons, one from us and the other from Banu Asad, called upon Ali. He sent them to a certain territory (on some mission) saying: You are sturdy and vigorous people; hence display your power for religion. He then stood and entered the toilet. He then came out and called for water and took a handful of it. Then he wiped (his hands) with it and began to recite the Qur'an. They were surprised at this (action).

Thereupon he said: The Apostle of Allah (peace_be_upon_him) came out from the privy and taught us the Qur'an and took meat with us. Nothing prevented him; or the narrator said: Nothing prevented him from (reciting) the Qur'an except sexual defilement.


Dawud :: Purification (Kitab Al-Taharah) :: [1.232]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 232

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) came and saw that the doors of the houses of his Companions were facing the mosque. He said: Turn the direction of the houses from the mosque. The Prophet (peace_be_upon_him) then entered (the houses or the mosque), and the people did take any step in this regard hoping that some concession might be revealed. He the Prophet) again came upon them and said: Turn the direction of these (doors) from the mosque I do not make the mosque lawful for a menstruating woman and for a person who is sexually defiled.


Dawud :: Purification (Kitab Al-Taharah) :: [1.233]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 233

Narrated AbuBakrah:

The Apostle of Allah (peace_be_upon_him) began to lead (the people) in the dawn prayer. He then signalled with his hand: (Stay) at your places. (Then he entered his home). He then returned while drops of water were coming down from him (from his body) and he led them in prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.236]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 236

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) was asked about a person who found moisture (on his body or clothes) but did not remember the sexual dream. He replied: He should take a bath. He was asked about a person who remembered that he had a sexual dream but did not find moisture. He replied: Bath is not necessary for him. Umm Salamah then asked: Is washing necessary for a woman if she sees that (in her dream)? He replied: Yes. Woman are counterpart of men.


Dawud :: Purification (Kitab Al-Taharah) :: [1.241]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 241

Narrated Aisha, Ummul Mu'minin:

Jumay' ibn Umayr, one of the sons of Banu Taym Allah ibn Tha'labah, said: Accompanied by my mother and aunt I entered upon Aisha. One of them asked her: How did you do while taking a bath? Aisha replied: The Apostle of Allah (peace_be_upon_him) performed ablution (in the beginning) as he did for prayer. He then poured (water) upon his head three times. But we poured water upon our heads five times due to plaits.


Dawud :: Purification (Kitab Al-Taharah) :: [1.244]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 244

Narrated Aisha, Ummul Mu'minin:

If you want, I can certainly show you the marks of the hand of the Apostle of Allah (peace_be_upon_him) on the wall where he took a bath because of sexual defilement.


Dawud :: Purification (Kitab Al-Taharah) :: [1.247]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 247

Narrated Abdullah ibn Umar:

There were fifty prayers (obligatory in the beginning); and (in the beginning of Islam) washing seven times because of sexual defilement (was obligatory); and washing the urine from the cloth seven times (was obligatory).

The Apostle of Allah (peace_be_upon_him) kept on praying to Allah until the number of prayers was reduced to five and washing because of sexual defilement was allowed only once and washing the urine from the clothe was also permitted only once.


Dawud :: Purification (Kitab Al-Taharah) :: [1.248]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 248

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: There is sexual defilement under every hair; so wash the hair and cleanse the skin.


Dawud :: Purification (Kitab Al-Taharah) :: [1.249]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 249

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) said: If anyone who is sexual defiled leaves a spot equal to the breadth of a hair without washing, such and such an amount of Hell-fire will have to be suffered for it. Ali said: On that account I treated my head (hair) as an enemy, meaning I cut my hair. He used to cut the hair (of his head). May Allah be pleased with him.


Dawud :: Purification (Kitab Al-Taharah) :: [1.250]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 250

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) took a bath and offered two rak'ahs of prayer and said the dawn prayer. I do not think he performed ablution afresh after taking a bath.


Dawud :: Purification (Kitab Al-Taharah) :: [1.255]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 255

Narrated Thawban:

Shurayh ibn Ubayd said: Jubayr ibn Nufayr gave me a verdict about the bath because of sexual defilement that Thawban reported to them that they asked the Prophet (peace_be_upon_him) about it. He (the Prophet) replied: As regards man, he should undo the hair of his head and wash it until the water should reach the roots of the hair. But there is no harm if the woman does not undo it (her hair) and pour three handfuls of water over her head.


Dawud :: Purification (Kitab Al-Taharah) :: [1.264]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 264

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said about a person who had intercourse with his wife while she was menstruating: He must give one dinar or half a dinar in alms.


Dawud :: Purification (Kitab Al-Taharah) :: [1.269]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 269

Narrated Aisha, Ummul Mu'minin:

Khallas al-Hujari reported: Aisha said: I and the Apostle of Allah (peace_be_upon_him) used to pass night in one (piece of) cloth (on me) while I menstruated profusely. If anything from me (i.e. blood) smeared him (i.e. his body), he would wash that spot and would not exceed it (in washing), then he would offer prayer with it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.270]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 270

Narrated Aisha, Ummul Mu'minin:

Umarah ibn Ghurab said that his paternal aunt narrated to him that she asked Aisha: What if one of us menstruates and she and her husband have no bed except one? She replied: I relate to you what the Apostle of Allah (peace_be_upon_him) had done.

One night he entered (upon me) while I was menstruating. He went to the place of his prayer, that is, to the place of prayer reserved (for this purpose) in his house. He did not return until I felt asleep heavily, and he felt pain from cold. And he said: Come near me. I said: I am menstruating. He said: Uncover your thighs. I, therefore, uncovered both of my thighs. Then he put his cheek and chest on my thighs and I lent upon he until he became warm and slept.


Dawud :: Purification (Kitab Al-Taharah) :: [1.271]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 271

Narrated Aisha, Ummul Mu'minin:

When I menstruated, I left the bed and lay on the reed-mat and did not approach or come near the Apostle of Allah (peace_be_upon_him) until we were purified.


Dawud :: Purification (Kitab Al-Taharah) :: [1.272]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 272

Narrated One of the Wives of the Prophet:

Ikrimah reported on the authority of one of the wives of the Prophet (peace_be_upon_him) saying: When the Prophet (peace_be_upon_him) wanted to do something (i.e. kissing, embracing) with (his) menstruating wife, he would put a garment on her private part.


Dawud :: Purification (Kitab Al-Taharah) :: [1.274]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 274

Narrated Umm Salamah, Ummul Mu'minin:

In the time of the Apostle of Allah (peace_be_upon_him) there was a woman who had an issue of blood. So Umm Salamah asked the Apostle of Allah (peace_be_upon_him) to give a decision about her. He said: She should consider the number of nights and days during which she used to menstruate each month before she was afflicted with this trouble and abandon prayer during that period each month. When those days and nights are over, she should take a bath, tie a cloth over her private parts and pray.


Dawud :: Purification (Kitab Al-Taharah) :: [1.280]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 280

Narrated Fatimah daughter of AbuHubaysh:

Urwah ibn az-Zubayr said that Fatimah daughter of AbuHubaysh narrated to him that she asked the Apostle of Allah (peace_be_upon_him) and complained to him about the flowing of (her) blood. The Apostle of Allah (peace_be_upon_him) said to her: That is only (due to) a vein: look, when your menstruation comes, do not pray; and when your menstruation ends, wash yourself and then offer prayer during the period from one menstruation to another.


Dawud :: Purification (Kitab Al-Taharah) :: [1.284]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 284

Narrated Aisha, Ummul Mu'minin:

Bahiyyah said: I heard a woman asking Aisha about the woman whose menses became abnormal and she had an issue of blood. The Apostle of Allah (peace_be_upon_him) asked me to advise her that she should consider the period during which she used to menstruate every month, when her menstruation was normal. Then she should count the days equal to the length of time (of her normal menses); then she should abandon prayer during those days or equal to that period. She should then take a bath, tie a cloth on her private parts a pray.


Dawud :: Purification (Kitab Al-Taharah) :: [1.286]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 286

Narrated Fatimah daughter of AbuHubaysh:

Urwah ibn az-Zubayr reported from Fatimah daughter of AbuHubaysh that her blood kept flowing, so the Prophet (peace_be_upon_him) said to her: When the blood of the menses comes, it is black blood which can be recognised; so when that comes, refrain from prayer; but when a different type of blood comes, perform ablution and pray, for it is (due only to) a vein.


Dawud :: Purification (Kitab Al-Taharah) :: [1.287]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 287

Narrated Hamnah daughter of Jahsh:

Hamnah said my menstruation was great in quantity and severe. So I came to the Apostle of Allah (peace_be_upon_him) for a decision and told him. I found him in the house of my sister, Zaynab, daughter of Jahsh.

I said: Apostle of Allah, I am a woman who menstruates in great quantity and it is severe, so what do you think about it? It has prevented me from praying and fasting.

He said: I suggest that you should use cotton, for it absorbs the blood. She replied: It is too copious for that. He said: Then take a cloth. She replied: It is too copious for that, for my blood keeps flowing. The Apostle of Allah (peace_be_upon_him) said: I shall give you two commands; whichever of them you follow, that will be sufficient for you without the other, but you know best whether you are strong enough to follow both of them.

He added: This is a stroke of the Devil, so observe your menses for six or seven days, Allah alone knows which it should be; then wash. And when you see that you are purified and quite clean, pray during twenty-three or twenty-four days and nights and fast, for that will be enough for you, and do so every month, just as women menstruate and are purified at the time of their menstruation and their purification.

But if you are strong enough to delay the noon (Zuhr) prayer and advance the afternoon ('Asr) prayer, to wash, and then combine the noon and the afternoon prayer; to delay the sunset prayer and advance the night prayer, to wash, and then combine the two prayers, do so: and to wash at dawn, do so: and fast if you are able to do so if possible;

The Apostle of Allah (peace_be_upon_him) said: Of the two commands this is more to my liking.


Dawud :: Purification (Kitab Al-Taharah) :: [1.293]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 293

Narrated Zaynab daughter of AbuSalamah:

AbuSalamah said: Zaynab daughter of AbuSalamah reported to me that a woman had a copious flow of blood. She was the wife of AbdurRahman ibn Awf. The Apostle of Allah (peace_be_upon_him) commanded her to take a bath at the time of every prayer, and then to pray. He reported to me that Umm Bakr told him that Aisha said: The Apostle of Allah (peace_be_upon_him) said about a woman who was doubtful of her menstruation after purification that it was a vein or veins.


Dawud :: Purification (Kitab Al-Taharah) :: [1.294]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 294

Narrated Aisha, Ummul Mu'minin:

A woman had a prolonged flow of blood in the time of the Apostle of Allah (peace_be_upon_him). She was commanded to advance the afternoon prayer and delay the noon prayer, and to take a bath for them only once; and to delay the sunset prayer and advance the night prayer and to take a bath only once for them; and to take a bath separately for the dawn prayer.

I (Shu'bah) asked AbdurRahman: (Is it) from the Prophet (peace_be_upon_him)? I do not report to you anything except from the Prophet (peace_be_upon_him).


Dawud :: Purification (Kitab Al-Taharah) :: [1.295]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 295

Narrated Aisha, Ummul Mu'minin:

Sahlah daughter of Suhayl had a prolonged flow of blood. She came to the Prophet (peace_be_upon_him). He commanded her to take a bath for every prayer. When it became hard for her, he commanded her to combine the noon and afternoon prayers with one bath and the sunset and night prayer with one bath, and to take a bath (separately) for the dawn prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.297]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 297

Narrated Grandfather of Adi ibn Thabit ?:

The Prophet (peace_be_upon_him) said about the woman having a prolonged flow of blood: She should abandon prayer during her menstrual period: then she should take a bath and pray. She should perform ablution for every prayer.


Dawud :: Purification (Kitab Al-Taharah) :: [1.298]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 298

Narrated Aisha, Ummul Mu'minin:

Fatimah daughter of AbuHubaysh came to the Prophet (peace_be_upon_him) and narrated what happened with her. He said: Then take a bath and then perform ablution for every prayer and pray.


Dawud :: Purification (Kitab Al-Taharah) :: [1.302]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 302

Narrated Ali ibn AbuTalib:

The woman who has a prolonged flow of blood should wash herself every day when her menstrual period is over and take a woollen cloth greased with fat or oil (to tie over the private parts).


Dawud :: Purification (Kitab Al-Taharah) :: [1.305]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 305

Narrated Umm Habibah daughter of Jahsh:

Ikrimah said: Umm Habibah daughter of Jahsh had a prolonged flow of blood. The Prophet (peace_be_upon_him) commanded her to refrain (from prayer) during her menstrual period; then she should wash and pray, if she sees anything (which renders ablution void) she should perform ablution and pray.


Dawud :: Purification (Kitab Al-Taharah) :: [1.311]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 311

Narrated Umm Salamah, Ummul Mu'minin:

The woman having bleeding after delivery (puerperal haemorrhage) would refrain (from prayer) for forty days or forty nights; and we would anoint our faces with an aromatic herb called wars to remove dark spots.


Dawud :: Purification (Kitab Al-Taharah) :: [1.313]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 313

Narrated Woman of Banu Ghifar:

Umayyah, daughter of AbusSalt, quoted a certain woman of Banu Ghifar, whose name was mentioned to me, as saying: The Apostle of Allah (peace_be_upon_him) made me ride behind him on the rear of the camel saddle. By Allah, the Apostle of Allah (peace_be_upon_him) got down in the morning. He made his camel kneel down and I came down from the back of his saddle. There was a mark of blood on it (saddle) and that was the first menstruation that I had. I stuck to the camel and felt ashamed.

When the Apostle of Allah (peace_be_upon_him) saw what had happened to me and saw the blood, he said: Perhaps you are menstruating.

I said: Yes. He then said: Set yourself right (i.e. tie some cloth to prevent bleeding), then take a vessel of water and put some salt in it, and then wash the blood from the back of the saddle, and then return to your mount. When the Apostle of Allah (peace_be_upon_him) conquered Khaybar, he gave us a portion of the booty. Whenever the woman became purified from her menses, she would put salt in water. And when she died, she left a will to put salt in the water for washing her (after death).


Dawud :: Purification (Kitab Al-Taharah) :: [1.317]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 317

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) sent Usayd ibn Hudayr and some people with him to search the necklace lost by Aisha. The time of prayer came and they prayed without ablution. When they returned to the Prophet (peace_be_upon_him) and related the fact to him, the verse concerning tayammum was revealed.

Ibn Nufayl added: Usayd said to her: May Allah have mercy upon you! Never has there been an occasion when you were beset with an unpleasant matter but Allah made the Muslims and you come out of that.


Dawud :: Purification (Kitab Al-Taharah) :: [1.318]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 318

Narrated Ammar ibn Yasir:

They (the Companions of the Prophet) wiped with pure earth (their hands and face) to offer the dawn prayer in the company of the Apostle of Allah (peace_be_upon_him). They struck the ground with their palms and wiped their faces once. Then they repeated and struck the ground with their palms once again and wiped their arms completely up to the shoulders and up to the armpits with the inner side of their hands.


Dawud :: Purification (Kitab Al-Taharah) :: [1.320]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 320

Narrated Ammar ibn Yasir:

The Apostle of Allah (peace_be_upon_him) encamped at Ulat al-Jaysh and Aisha was in his company. Her necklace of onyx of Zifar was broken (and fell somewhere). The people were detained to make a search for that necklace until the dawn broke. There was no water with the people. Therefore AbuBakr became angry with her and said: You detained the people and they have no water with them.

Thereupon Allah, the Exalted, sent down revelation about it to His Apostle (peace_be_upon_him) granting concession to purify themselves with pure earth. Then the Muslims stood up with the Apostle of Allah (peace_be_upon_him) and struck the ground with their hands and then they raised their hands, and did not take any earth (in their hands). Then they wiped with them their faces and hands up to the shoulders, and from their palms up to the armpits.


Dawud :: Purification (Kitab Al-Taharah) :: [1.334]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 334

Narrated Amr ibn al-'As:

I had a sexual dream on a cold night in the battle of Dhat as-Salasil. I was afraid, if I washed I would die. I, therefore, performed tayammum and led my companions in the dawn prayer. They mentioned that to the Apostle of Allah (peace_be_upon_him). He said: Amr, you led your companions is prayer while you were sexually defiled? I informed him of the cause which impeded me from washing. And I said: I heard Allah say: "Do not kill yourself, verily Allah is merciful to you." The Apostle of Allah (peace_be_upon_him) laughed and did not say anything.


Dawud :: Purification (Kitab Al-Taharah) :: [1.337]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 337

Narrated Abdullah ibn Abbas:

A man was injured during the lifetime of the Apostle of Allah (peace_be_upon_him); he then had a sexual dream, and he was advised to wash and he washed himself. Consequently he died. When this was reported to the Apostle of Allah (peace_be_upon_him) he said: They killed him; may Allah kill them! Is not inquiry the cure of ignorance?


Dawud :: Purification (Kitab Al-Taharah) :: [1.342]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 342

Narrated Hafsah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: It is necessary for every adult (person) to go for (saying) Friday (prayer), and for everyone who goes for Friday (prayer) washing is necessary.


Dawud :: Purification (Kitab Al-Taharah) :: [1.345]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 345

Narrated Aws ibn Aws ath-Thaqafi:

I heard the apostle of Allah (peace_be_upon_him) say: If anyone makes (his wife) wash and he washes himself on Friday, goes out early (for Friday prayer), attends the sermon from the beginning, walking, not riding, takes his seat near the imam, listens attentively, and does not indulge in idle talk, he will get the reward of a year's fasting and praying at night for every step he takes.


Dawud :: Purification (Kitab Al-Taharah) :: [1.348]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 348

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) would take a bath because of sexual defilement on Friday, after opening a vein and after washing a dead body.


Dawud :: Purification (Kitab Al-Taharah) :: [1.354]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 354

Narrated Samurah:

If any one of you performs ablution (on Friday) that is all right; and if any of you takes a bath, that is better.


Dawud :: Purification (Kitab Al-Taharah) :: [1.355]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 355

Narrated Qays ibn Asim:

I came to the Prophet (peace_be_upon_him) with the intention of embracing Islam. He commanded me to take a bath with water (boiled with) the leaves of the lote-tree.


Dawud :: Purification (Kitab Al-Taharah) :: [1.359]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 359

Narrated Umm Salamah, Ummul Mu'minin:

Bakkar ibn Yahya said that his grandmother narrated to him: I entered upon Umm Salamah. A woman from the Quraysh asked her about praying with the clothes which a woman wore while she menstruated.

Umm Salamah said: We would menstruate in the lifetime of the Apostle of Allah (peace_be_upon_him). Then each one of us refrained (from prayer) during menstrual period. When she was purified, she would look at the clothe in which she menstruated. If it were smeared with blood, we would wash it and pray with it; if there were nothing in it, we would leave it and that would not prevent us from praying with it (the same clothe).

As regards the woman who had plaited hair - sometimes each of us had plaited hair - when she washed, she would not undo the hair. She would instead pour three handfuls of water upon her head. When she felt moisture in the roots of her hair, she would rub them. Then she would pour water upon her whole body.


Dawud :: Purification (Kitab Al-Taharah) :: [1.363]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 363

Narrated Umm Qays daughter of Mihsan:

I asked the Prophet (peace_be_upon_him) about the blood of menstruation on the clothe. He said: Erase it off with a piece of wood and then wash it away with water and the leaves of the lote-tree.


Dawud :: Purification (Kitab Al-Taharah) :: [1.366]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 366

Narrated Umm Habibah:

Mu'awiyah ibn AbuSufyan asked his sister Umm Habibah, the wife of the Prophet (peace_be_upon_him): Would the apostle of Allah (peace_be_upon_him) pray in the clothe in which he had an intercourse? She said: Yes, when he would not see any impurity in it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.367]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 367

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) would not pray in our wrappers or in our quilts.

Ubaydullah said: My father (Mu'adh) doubted this.


Dawud :: Purification (Kitab Al-Taharah) :: [1.375]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 375

Narrated Lubabah daughter of al-Harith:

Al-Husayn ibn Ali was (sitting) in the lap of the Apostle of Allah (peace_be_upon_him). He passed water on him. I said: Put on (another) clothe, and give me your wrapper to wash. He said: The urine of a female child should be washed (thoroughly) and the urine of a male child should be sprinkled over.


Dawud :: Purification (Kitab Al-Taharah) :: [1.376]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 376

Narrated AbusSamh:

I used to serve the Prophet (peace_be_upon_him). Whenever he intended to wash himself, he would say: Turn your back towards me, So I would turn my back and hide him. (Once) Hasan or Husayn (may Allah be pleased with them) was brought to him and he passed water on his chest. I came to wash it. He said: It is only the urine of a female which should be washed; the urine of a male should be sprinkled over.


Dawud :: Purification (Kitab Al-Taharah) :: [1.377]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 377

Narrated Ali ibn AbuTalib:

The urine of a female (child) should be washed and the urine of a male (child) should be sprinkled over until the age of eating.


Dawud :: Purification (Kitab Al-Taharah) :: [1.379]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 379

Narrated Umm Salamah, Ummul Mu'minin:

Al-Hasan reported on the authority of his mother that she was Umm Salamah pouring water on the urine of the male child until the age when he did not eat food. When he began to eat food, she would wash (his urine). And she would wash the urine of the female child.


Dawud :: Purification (Kitab Al-Taharah) :: [1.381]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 381

Narrated Abdullah ibn Ma'qil ibn Muqarrin:

A bedouin prayed with the Prophet (peace_be_upon_him). He then narrated the tradition (No 0380) about urinating of that bedouin.

This version adds: The Prophet (peace_be_upon_him) said: Remove the earth where he urinated and throw it away and pour water upon the place.


Dawud :: Purification (Kitab Al-Taharah) :: [1.383]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 383

Narrated Umm Salamah, Ummul Mu'minin:

The slave-mother of Ibrahim ibn AbdurRahman ibn Awf asked Umm Salamah, the wife of the Prophet (peace_be_upon_him): I am a woman having a long border of clothe and I walk in filthy place; (then what should I do?). Umm Salamah replied: The Apostle of Allah ( peace be upon him) said: What comes after it cleanses it.


Dawud :: Purification (Kitab Al-Taharah) :: [1.384]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 384

Narrated A woman of the Banu AbdulAshhal:

She reported: I said Apostle of Allah, our road to the mosque has an unpleasant stench; what should we do when it is raining? He asked: Is there not a cleaner part after the filthy part of the road? She replied: Why not (there is one)! He said: It makes up for the other.


Dawud :: Purification (Kitab Al-Taharah) :: [1.389]

Purification (Kitab Al-Taharah)

Dawud :: Book 1 : Hadith 389

Narrated AbuNadrah:

The Apostle of Allah (peace_be_upon_him) spat on his clothe and scrubbed with a part of it.


Dawud :: Prayer (Kitab Al-Salat) :: [2.393]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 393

Narrated Abdullah Ibn Abbas:

The Apostle of Allah (peace_be_upon_him) said: Gabriel (peace_be_upon_him) led me in prayer at the House (i.e. the Ka'bah). He prayed the noon prayer with me when the sun had passed the meridian to the extent of the thong of a sandal; he prayed the afternoon prayer with me when the shadow of everything was as long as itself; he prayed the sunset prayer with me when one who is fasting breaks the fast; he prayed the night prayer with me when the twilight had ended; and he prayed the dawn prayer with me when food and drink become forbidden to one who is keeping the fast.

On the following day he prayed the noon prayer with me when his shadow was as long as himself; he prayed the afternoon prayer with me when his shadow was twice as long as himself; he prayed the sunset prayer at the time when one who is fasting breaks the fast; he prayed the night prayer with me when about the third of the night had passed; and he prayed the dawn prayer with me when there was a fair amount of light.

Then turning to me he said: Muhammad, this is the time observed by the prophets before you, and the time is anywhere between two times.


Dawud :: Prayer (Kitab Al-Salat) :: [2.399]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 399

Narrated Jabir ibn Abdullah:

I would offer my noon prayer with the Apostle of Allah (peace_be_upon_him) and took a handful of gravels so that they might become cold in my hand and I placed them (before me) so that I may put my forehead on them at the time when I would prostrate. I did this due to the intensity of heat.


Dawud :: Prayer (Kitab Al-Salat) :: [2.400]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 400

Narrated Abdullah ibn Mas'ud:

The extent of the shadow when the Apostle of Allah prayed (the noon prayer) was three to five feet in summer and five to seven feet in winter.


Dawud :: Prayer (Kitab Al-Salat) :: [2.408]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 408

Narrated Ali ibn Shayban:

We came upon the Apostle of Allah (peace_be_upon_him) in Medina. He would postpone the afternoon prayer as long as the sun remained white and clear.


Dawud :: Prayer (Kitab Al-Salat) :: [2.418]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 418

Narrated AbuAyyub:

Marthad ibn Abdullah said: When AbuAyyub came upon us to fight the infidels and in those days Uqbah ibn Amir was the Governor of Egypt, he (Uqbah) delayed the sunset prayer. Hence AbuAyyub stood and said: What kind of prayer is this, Uqbah? He said: We were busy. He said: Did you not hear the Apostle of Allah (peace_be_upon_him) say: My community will remain well, or he said: will remain on its natural condition, so long as it would not delay the evening prayer until the stars shine brightly just like a network.


Dawud :: Prayer (Kitab Al-Salat) :: [2.419]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 419

Narrated An-Nu'man ibn Bashir:

I am the one who is best informed of the time of this prayer, i.e. the night prayer. The Apostle of Allah (peace_be_upon_him) used to offer it at the hour when the moon went down on its third night.


Dawud :: Prayer (Kitab Al-Salat) :: [2.421]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 421

Narrated Mu'adh ibn Jabal:

We waited for the Prophet (peace_be_upon_him) to offer the night prayer. He delayed until people thought that he would not come out and some of us said that he had offered the prayer. At the moment when we were in this condition the Prophet (peace_be_upon_him) came out. People said to him as they were already saying. He said: Observe this prayer when it is dark, for by it you have been made superior to all the peoples, no people having observed it before you.


Dawud :: Prayer (Kitab Al-Salat) :: [2.422]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 422

Narrated AbuSa'id al-Khudri:

We observed the prayer after nightfall with the Apostle of Allah (peace_be_upon_him), and he did not come out till about half the night had passed. He then said: Take your places. We then took our places. Then he said: The people have prayed and gone to bed, but you are still engaged in prayer as long as you wait for the prayer. Were it not for the weakness of the weak and for the sickness of the sick. I would delay this prayer till half the night had gone.


Dawud :: Prayer (Kitab Al-Salat) :: [2.425]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 425

Narrated Abdullah ibn Sunabihi:

AbuMuhammad fancies that witr prayer is essential. (Hearing this) Ubadah ibn as-Samit said: AbuMuhammad was wrong. I bear witness that I heard the Apostle of Allah (peace_be_upon_him) say: Allah, the Exalted, has made five prayers obligatory. If anyone performs ablution for them well, offers them at their (right) time, and observes perfectly their bowing and submissiveness in them, it is the guarantee of Allah that He will pardon him; if anyone does not do so, there is no guarantee for him on the part of Allah; He may pardon him if He wills, and punish him if He wills.


Dawud :: Prayer (Kitab Al-Salat) :: [2.426]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 426

Narrated Umm Farwah:

The Apostle of Allah (peace_be_upon_him) was asked: Which of the actions is best? He replied: Observing prayer early in its period.

Al-Khuza'i narrated in his version from his aunt named Umm Farwah who took the oath of allegiance to the Prophet (peace_be_upon_him): He was questioned.


Dawud :: Prayer (Kitab Al-Salat) :: [2.427]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 427

Narrated Umarah ibn Ruwaybah:

A man from Basrah said: Tell me what you heard from the Apostle of Allah (peace_be_upon_him). He said: I heard the Apostle of Allah (peace_be_upon_him) say: No one will enter Hell who has prayed before the rising of the sun and before its setting (meaning the dawn and the afternoon prayers). He said three times: Have you heard it from him? He replied: Yes, each time saying: My ears heard it and my heart memorised it. The man then said: And I heard him (the Prophet) say that.


Dawud :: Prayer (Kitab Al-Salat) :: [2.428]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 428

Narrated Fudalah:

The Apostle of Allah (peace_be_upon_him) taught me and what he taught me is this: Observe the five prayers regularly. He said: I told (him): I have many works at these times; so give me a comprehensive advice which, if I follow, should be enough for me. He said: Observe the two afternoon prayers (al-asrayn). But the term al-asrayn (two afternoon prayers) was not used in our language. Hence I said: What is al-asrayn? He said: A prayer before the sunrise and a prayer before the sunset (i.e. the dawn and the afternoon prayers).


Dawud :: Prayer (Kitab Al-Salat) :: [2.430]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 430

Narrated AbuQatadah ibn Rab'i:

Allah , the Exalted said: I made five times' prayers obligatory on your people, and I took a guarantee that if anyone observes them regularly at their times, I shall admit him to Paradise; if anyone does not offer them regularly, there is no such guarantee of Mine for him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.432]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 432

Narrated Abdullah ibn Mas'ud:

Amr ibn Maymun al-Awdi said: Mu'adh ibn Jabal, the Messenger of the Apostle of Allah (peace_be_upon_him) came to us in Yemen, I heard his takbir (utterance of AllahuAkbar) in the dawn prayer. He was a man with loud voice. I began to love him. I did depart from him until I buried him dead in Syria (i.e. until his death).

Then I searched for a person who had deep understanding in religion amongst the people after him. So I came to Ibn Mas'ud and remained in his company until his death. He (Ibn Mas'ud) said: The Apostle of Allah (peace_be_upon_him) said to me: How will you act when you are ruled by rulers who say prayer beyond its proper time? I said: What do you command me, Apostle of Allah, if I witness such a time? He replied: Offer the prayer at its proper time and also say your prayer along with them as a supererogatory prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.433]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 433

Narrated Ubadah ibn as-Samit:

After me you will come under rulers who will be detained from saying prayer at its proper time by (their) works until its time has run out, so offer prayer at its proper time. A man asked him: Apostle of Allah, may I offer prayer with them? He replied: Yes, if you wish (to do so).

Sufyan (another narrator through a different chain)said: May I offer prayer with them if I get it with them? He said: Yes, if you wish to do so.


Dawud :: Prayer (Kitab Al-Salat) :: [2.434]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 434

Narrated Qabisah ibn Waqqas:

The Apostle of Allah (peace_be_upon_him) said: After me you will be ruled by rulers who will delay the prayer and it will be to your credit but to their discredit. So pray with them so long as they pray facing the qiblah.


Dawud :: Prayer (Kitab Al-Salat) :: [2.444]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 444

Narrated Amr ibn Umayyah ad-Damri:

We were in the company of the Apostle of Allah (peace_be_upon_him) during one of his journeys. He overslept abandoning the morning prayer until the sun had arisen. The Apostle of Allah (peace_be_upon_him) awoke and said: Go away from this place.

He then commanded Bilal to call for prayer. He called for prayer. They (the people) performed ablution and offered two rak'ahs of the morning prayer (sunnah prayer). He then commanded Bilal (to utter the iqamah, i.e. to summon the people to attend the prayer). He announced the prayer (i.e. uttered the iqamah) and he led them in the morning prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.447]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 447

Narrated Abdullah ibn Mas'ud:

We proceeded with the Apostle of Allah (peace_be_upon_him) on the occasion of al-Hudaybiyyah. The Apostle of Allah (peace_be_upon_him) said: Who will keep watch for us? Bilal said: I (shall do). The overslept till the sun arose. The Prophet (peace_be_upon_him) awoke and said: Do as you used to do (i.e. offer prayer as usual). Then we did accordingly. He said: Anyone who oversleeps or forgets (prayer) should do similarly.


Dawud :: Prayer (Kitab Al-Salat) :: [2.448]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 448

Narrated Abdullah ibn Abbas:

I was not commanded to build high mosques. Ibn Abbas said: You will certainly adorn them as the Jews and Christians did.


Dawud :: Prayer (Kitab Al-Salat) :: [2.449]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 449

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: The Last Hour will not come until people vie with one another about mosques.


Dawud :: Prayer (Kitab Al-Salat) :: [2.450]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 450

Narrated Uthman ibn Abul'As:

The Prophet (nay peace be upon him) commanded him to build a mosque at Ta'if where the idols were placed.


Dawud :: Prayer (Kitab Al-Salat) :: [2.455]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 455

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) commanded us to build mosques in different localities (i.e. in the locality of each tribe separately) and that they should be kept clean and be perfumed.


Dawud :: Prayer (Kitab Al-Salat) :: [2.457]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 457

Narrated Maymunah ibn Sa'd:

I said: Apostle of Allah, tell us the legal injunction about (visiting) Bayt al-Muqaddas (the dome of the Rock at Jerusalem). The Apostle of Allah (peace_be_upon_him) said: go and pray there. All the cities at that time were effected by war. If you cannot visit it and pray there, then send some oil to be used in the lamps.


Dawud :: Prayer (Kitab Al-Salat) :: [2.461]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 461

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: The rewards of my people were presented before me, so much so that even the reward for removing a mote by a person from the mosque was presented to me. The sins of my people were also presented before me. I did not find a sin greater than that of a person forgetting the Qur'anic chapter or verse memorised by him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.478]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 478

Narrated Abdullah al-Muharibi:

The Apostle of Allah (peace_be_upon_him) said: When a man stands with the intention of saying prayer, or if any of you says prayer, he should not spit before him, nor at his right side; but he should do so at his left side, if there is a place for it; or he should spit under his left foot and then rub it off.


Dawud :: Prayer (Kitab Al-Salat) :: [2.481]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 481

Narrated Ubadah ibn as-Samit:

We came to Jabir ibn Abdullah who was sitting in his mosque. He said: The Apostle of Allah (peace_be_upon_him) came to us in this mosque and he had a twig of date-palm of the kind of Ibn Tab. He looked and saw phlegm on the wall towards qiblah. He turned to it and scraped it with the twig.

He then said: Who of you likes that Allah turns His face from him? He further said: When any of you stands for praying, Allah faces him. So he should not spit before him, nor on his right side. He should spit on his left side under his left foot. If he is in a hurry (i.e. forced to spit immediately), he should do with his cloth in this manner. He then placed the cloth on his mouth and rubbed it off.

He then said: Bring perfume. A young man of the tribe stood and hurried to his house and returned with perfume in his palm. The Apostle of Allah (peace_be_upon_him) took it and put it at the end of the twig. He then stained the mark of phlegm with it.

Jabir said: This is the reason you use perfume in your mosques.


Dawud :: Prayer (Kitab Al-Salat) :: [2.482]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 482

Narrated AbuSahlah as-Sa'ib ibn Khallad:

A man led the people in prayer. He spat towards qiblah while the Apostle of Allah (peace_be_upon_him) was looking at him. The Apostle of Allah said to the people when he finished his prayer: He should not lead you in prayer (henceforth).

Thenceforth he intended to lead them in prayer, but they forbade him and informed him of the prohibition of the Apostle of Allah (peace_be_upon_him). He mentioned it to the Apostle of Allah (peace_be_upon_him) who said to him: Yes.

The narrator said: I think he (the Prophet) said: You did harm to Allah and His Apostle.


Dawud :: Prayer (Kitab Al-Salat) :: [2.485]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 485

Narrated Wathilah ibn al-Asqa':

AbuSa'id said: I saw Wathilah ibn al-Asqa' in the mosque of Damascus. He spat at the mat and then rubbed it with his foot. He was asked: Why did you do so? He said: Because I saw the Apostle of Allah (peace_be_upon_him) doing so.


Dawud :: Prayer (Kitab Al-Salat) :: [2.489]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 489

Narrated AbuDharr:

The earth has been made for me purifying and as a mosque (place for prayer).


Dawud :: Prayer (Kitab Al-Salat) :: [2.490]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 490

Narrated Ali ibn AbuTalib:

AbuSalih al-Ghifari reported: Ali (once) passed by Babylon during his travels. The mu'adhdhin (the person who calls for prayer) came to him to call for the afternoon prayer. When he passed by that place, he commanded to announce for the prayer. After finishing the prayer he said: My affectionate friend (i.e. the Prophet) prohibited me to say prayer in the graveyard. He also forbade me to offer prayer in Babylon because it is accursed.


Dawud :: Prayer (Kitab Al-Salat) :: [2.492]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 492

Narrated Sa'id:

and the narrator Musa said: As far as Amr thinks, the Prophet (peace_be_upon_him) said: The whole earth is a place of prayer except public baths and graveyards.


Dawud :: Prayer (Kitab Al-Salat) :: [2.494]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 494

Narrated As-Saburah:

The Prophet (peace_be_upon_him) said: Command a boy to pray when he reaches the age of seven years. When he becomes ten years old, then beat him for prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.495]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 495

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: Command your children to pray when they become seven years old, and beat them for it (prayer) when they become ten years old; and arrange their beds (to sleep) separately.


Dawud :: Prayer (Kitab Al-Salat) :: [2.497]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 497

Narrated Mu'adh ibn Abdullah ibn Khubayb al-Juhani:

Hisham ibn Sa'd reported: We entered upon Mu'adh ibn Abdullah ibn Khubayb al-Juhani. He said to his wife: When (at what age) should a boy pray? She replied: Some person of us reported: The Apostle of Allah (peace_be_upon_him) was asked about it; he said: When a boy distinguishes right hand from the left hand, then command him to pray.


Dawud :: Prayer (Kitab Al-Salat) :: [2.498]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 498

Narrated AbuUmayr ibn Anas:

AbuUmayr reported on the authority of his uncle who was from the Ansar (the helpers of the Prophet): The Prophet (peace_be_upon_him) was anxious as to how to gather the people for prayer.

The people told him: Hoist a flag at the time of prayer; when they see it, they will inform one another. But he (the Prophet) did not like it. Then someone mentioned to him the horn.

Ziyad said: A horn of the Jews. He (the Prophet) did not like it. He said: This is the matter of the Jews. Then they mentioned to him the bell of the Christians. He said: This is the matter of the Christians. Abdullah ibn Zayd returned anxiously from there because of the anxiety of the Apostle (peace_be_upon_him). He was then taught the call to prayer in his dream. Next day he came to the Apostle of Allah (peace_be_upon_him) and informed him about it.

He said: Apostle of Allah, I was between sleep and wakefulness; all of a sudden a newcomer came (to me) and taught me the call to prayer. Umar ibn al-Khattab had also seen it in his dream before, but he kept it hidden for twenty days.

The Prophet (peace_be_upon_him) said to me (Umar): What did prevent you from saying it to me?

He said: Abdullah ibn Zayd had already told you about it before me: hence I was ashamed.

Then the Apostle of Allah (peace_be_upon_him) said: Bilal, stand up, see what Abdullah ibn Zayd tells you (to do), then do it. Bilal then called them to prayer.

AbuBishr reported on the authority of AbuUmayr: The Ansar thought that if Abdullah ibn Zayd had not been ill on that day, the Apostle of Allah (peace_be_upon_him) would have made him mu'adhdhin.


Dawud :: Prayer (Kitab Al-Salat) :: [2.507]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 507

Narrated Mu'adh ibn Jabal:

Prayer passed through three stages and fasting also passed through three stages. The narrator Nasr reported the rest of the tradition completely. The narrator, Ibn al-Muthanna, narrated the story of saying prayer facing in the direction of Jerusalem.

He said: The third stage is that the Apostle of Allah (peace_be_upon_him) came to Medina and prayed, i.e. facing Jerusalem, for thirteen months.

Then Allah, the Exalted, revealed the verse: "We have seen thee turning thy face to Heaven (for guidance, O Muhammad). And now verily We shall make thee turn (in prayer) toward a qiblah which is dear to thee. So turn thy face toward the Inviolable Place of Worship, and ye (O Muslims), wherever ye may be, turn your face (when ye pray) toward it" (ii.144). And Allah, the Reverend and the Majestic, turned (them) towards the Ka'bah. He (the narrator) completed his tradition.

The narrator, Nasr, mentioned the name of the person who had the dream, saying: And Abdullah ibn Zayd, a man from the Ansar, came. The same version reads: And he turned his face towards the qiblah and said: Allah is most great, Allah is most great; I testify that there is no god but Allah, I testify that there is no god but Allah; I testify that Muhammad is the Apostle of Allah, I testify that Muhammad is the Apostle of Allah; come to prayer (he pronounced it twice), come to salvation (he pronounced it twice); Allah is Most Great, Allah is most great. He then paused for a while, and then got up and pronounced in a similar way, except that after the phrase "Come to salvation" he added. "The time for prayer has come, the time for prayer has come."

The Apostle of Allah (peace_be_upon_him) said: Teach it to Bilal, then pronounce the adhan (call to prayer) with the same words. As regards fasting, he said: The Apostle of Allah (peace_be_upon_him) used to fast for three days every month, and would fast on the tenth of Muharram. Then Allah, the Exalted, revealed the verse: ".......Fasting was prescribed for those before you, that ye may ward off (evil)......and for those who can afford it there is a ransom: the feeding of a man in need (ii.183-84). If someone wished to keep the fast, he would keep the fast; if someone wished to abandon the fast, he would feed an indigent every day; it would do for him. But this was changed. Allah, the Exalted, revealed: "The month of Ramadan in which was revealed the Qur'an ..........(let him fast the same) number of other days" (ii.185).

Hence the fast was prescribed for the one who was present in the month (of Ramadan) and the traveller was required to atone (for them); feeding (the indigent) was prescribed for the old man and woman who were unable to fast. (The narrator, Nasr, further reported): The companion Sirmah, came after finishing his day's work......and he narrated the rest of the tradition.


Dawud :: Prayer (Kitab Al-Salat) :: [2.510]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 510

Narrated Abdullah ibn Umar:

The words of adhan were pronounced from the time of the Apostle of Allah (peace_be_upon_him) twice in pairs (i.e. four times) each, and the words of iqamah were pronounced once in pairs (twice each), except that the phrase "The time for prayer has come" would be pronounced twice. When we heard iqamah, we would perform ablution, and go out for prayer. Shu'bah said: I did not hear AbuJa'far narrating any other tradition except this one.


Dawud :: Prayer (Kitab Al-Salat) :: [2.512]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 512

Narrated Abdullah ibn Zayd:

The Prophet (peace_be_upon_him) intended to do many things for calling (the people) to prayer, but he did not do any of them. Then Abdullah ibn Zayd was taught in a dream how to pronounce the call to prayer. He came to the Prophet (peace_be_upon_him) and informed him. He said: Teach it to Bilal. He then taught him, and Bilal made a call to prayer. Abdullah said: I saw it in a dream and I wished to pronounce it, but he (the Prophet) said: You should pronounce iqamah.


Dawud :: Prayer (Kitab Al-Salat) :: [2.514]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 514

Narrated Ziyad ibn al-Harith as-Suda'i:

When the adhan for the dawn prayer was initially introduced, the Prophet (peace_be_upon_him) commanded me to call the adhan and I did so. Then I began to ask: Should I utter iqamah, Apostle of Allah? But he began to look at the direction of the east, (waiting) for the break of dawn, and said: No.

When the dawn broke, he came down and performed ablution and he then turned to me. In the meantime his Companions joined him. Then Bilal wanted to utter the iqamah, but the Prophet (peace_be_upon_him) said to him: The man of Suda' has called the adhan, and he who calls the adhan utters the iqamah.


Dawud :: Prayer (Kitab Al-Salat) :: [2.515]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 515

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The mu'adhdhin will receive forgiveness to the extent to which his voice reaches, and every moist and dry place will testify on his behalf; and he who attends (the congregation of) prayer will have twenty-five prayers recorded for him and will have expiation for sins committed between every two times of prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.517]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 517

Narrated AbuHurayrah:

The imam is responsible and the mu'adhdhin is trusted, O Allah, guide the imams and forgive the mu'adhdhins.


Dawud :: Prayer (Kitab Al-Salat) :: [2.519]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 519

Narrated A woman from Banu an-Najjar:

Urwah ibn az-Zubayr reported on the authority of a woman from Banu an-Najjar. She said: My house was the loftiest of all the houses around the mosque (of the Prophet at Medina). Bilal used to make a call to the morning prayer from it. He would come there before the break of dawn and wait for it. When he saw it, he would yawn and say: O Allah, I praise you and seek Your assistance for the Quraysh so that they might establish Thine religion. He then would make the call to prayer.

She (the narrator) said: By Allah, I do not know whether he ever left saying these words on any night.


Dawud :: Prayer (Kitab Al-Salat) :: [2.521]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 521

Narrated Anas ibn Malik:

The supplication made between the adhan and the iqamah is not rejected.


Dawud :: Prayer (Kitab Al-Salat) :: [2.524]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 524

Narrated Abdullah ibn Amr ibn al-'As:

A man said: Apostle of Allah, the mu'adhdhins excel us. The Apostle of Allah (peace_be_upon_him) said: Say (the same words) as they say, and when you come to the end, make a petition and that will be granted to you.


Dawud :: Prayer (Kitab Al-Salat) :: [2.528]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 528

Narrated AbuUmamah, or one of the Companion of the Prophet:

Bilal began the Iqamah, and when he said: "The time for prayer has come," the Prophet (peace_be_upon_him) said: "May Allah establish it and cause it to continue."


Dawud :: Prayer (Kitab Al-Salat) :: [2.530]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 530

Narrated Umm Salamah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) taught me to say when the adhan for the sunset prayer was called; "O Allah, this is the time when Thy night comes on, Thy day retires, and the voices of Thy summoners are heard, so forgive me."


Dawud :: Prayer (Kitab Al-Salat) :: [2.531]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 531

Narrated Uthman ibn Abul'As:

Apostle of Allah, appoint me the leader of the tribe in prayer. He said: You are their leader, but you should follow on who is the weakest of them: and appoint a mu'adhdhin who does not charge for the calling of adhan.


Dawud :: Prayer (Kitab Al-Salat) :: [2.532]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 532

Narrated Abdullah ibn Umar:

Bilal made a call to prayer before the break of dawn; the Prophet (peace_be_upon_him), therefore, commanded him to return and make a call: Lo! the servant of Allah (i.e. I) had slept (hence this mistake).

The version of Musa has the addition: He returned and made a call: Lo! the servant of Allah had slept.


Dawud :: Prayer (Kitab Al-Salat) :: [2.534]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 534

Narrated Bilal:

The Apostle of Allah (peace_be_upon_him) said to Bilal: Do not call adhan until the dawn appears clearly to you in this way, stretching his hand in latitude.


Dawud :: Prayer (Kitab Al-Salat) :: [2.538]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 538

Narrated Abdullah ibn Umar:

Mujahid reported: I was in the company of Ibn Umar. A person invited the people for the noon or afternoon prayer (after the adhan had been called). He said: Go out with us (from this mosque) because this is an innovation (in religion).


Dawud :: Prayer (Kitab Al-Salat) :: [2.547]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 547

Narrated AbudDarda':

I heard the Apostle of Allah (peace_be_upon_him) say: If there are three men in a village or in the desert among whom prayer is not offered (in congregation), the devil has got the mastery over them. So observe (prayer) in congregation), for the wolf eats only the straggling animal. Sa'ib said: By the word Jama'ah he meant saying prayer in company or in congregation.


Dawud :: Prayer (Kitab Al-Salat) :: [2.551]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 551

Narrated Abdullah ibn Abbas:

If anyone hears him who makes the call to prayer and is not prevented from joining the congregation by any excuse--he was asked what an excuse consisted of and replied that it was fear or illness--the prayer he offers will not be accepted from him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.552]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 552

Narrated Amr ibn Za'dah, Ibn Umm Maktum:

Ibn Umm Maktum asked the Prophet (peace_be_upon_him) saying: Apostle of Allah, I am a blind man, my house is far away (from the mosque), and I have a guide who does not follow me. Is it possible that permission be granted to me for saying prayer in my house? He asked: Do you hear summons (adhan)? He said: Yes. He said: I do not find any permission for you.


Dawud :: Prayer (Kitab Al-Salat) :: [2.553]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 553

Narrated Ibn Umm Maktum:

Apostle of Allah, there are many venomous creatures and wild beasts in Medina (so allow me to pray in my house because I am blind). The Prophet (peace_be_upon_him) said: Do you hear the call, "Come to prayer," "Come to salvation"? (He said: Yes.) Then you must come.


Dawud :: Prayer (Kitab Al-Salat) :: [2.554]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 554

Narrated Ubayy ibn Ka'b:

The Apostle of Allah (peace_be_upon_him) led us in the dawn prayer one day. And he said: Is so and so present? They said: No. He (again) asked: Is so and so present? They replied: No. He then said: These two prayers are the ones which are most burdensome to hypocrites. If you knew what they contain (i.e. blessings), you would come to them, even though you had to crawl on your knees. The first row is like that of the angels, and if you knew the nature of its excellence, you would race to join it.

A man's prayer said along with another is purer than his prayer said alone, and his prayer with two men is purer than his prayer with one, but if there are more it is more pleasing to Allah, the Almighty, the Majestic.


Dawud :: Prayer (Kitab Al-Salat) :: [2.556]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 556

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The further one is from the mosque , the greater will be one's reward.


Dawud :: Prayer (Kitab Al-Salat) :: [2.558]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 558

Narrated AbuUmamah:

The Apostle of Allah (peace_be_upon_him) said: If anyone goes out from his house after performing ablution for saying the prescribed prayer in congregation (in the mosque), his reward will be like that of one who goes for hajj pilgrimage after wearing ihram (robe worn by the hajj pilgrims).

And he who goes out to say the mid-morning (duha) prayer, and takes the trouble for this purpose, will take the reward like that of a person who performs umrah. And a prayer followed by a prayer with no worldly talk during the gap between them will be recorded in Illiyyun.


Dawud :: Prayer (Kitab Al-Salat) :: [2.560]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 560

Narrated AbuSa'id al-Khudri:

Prayer in congregation is equivalent to twenty-five prayers (offered alone). If he prays in a jungle, and performs its bowing and prostrations perfectly, it becomes equivalent to fifty prayers (in respect of reward).


Dawud :: Prayer (Kitab Al-Salat) :: [2.561]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 561

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: Give good tidings to those who walk to the mosques in darkness for having a perfect light on the Day of Judgment.


Dawud :: Prayer (Kitab Al-Salat) :: [2.562]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 562

Narrated Ka'b ibn Ujrah:

AbuThumamah al-Hannat said that Ka'b ibn Ujrah met him while he was going to the mosque; one of the two (companions) met his companion (on his way to the mosque) And he met crossing the fingers of my both hands. He prohibited me to do so, and said: The Apostle of Allah (peace_be_upon_him) has said: If any of you performs ablution, and performs his ablution perfectly, and then goes out intending for the mosque, he should not cross the fingers of his hand because he is already in prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.563]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 563

Narrated A person from the Ansar:

Sa'id ibn al-Musayyab said: An Ansari was breathing his last. He said: I narrate to you a tradition, and I narrate it with the intention of getting a reward from Allah.

I heard the Apostle of Allah (peace_be_upon_him) say: If any one of you performs ablution and performs it very well, and goes out for prayer, he does not take his right step but Allah records a good work (or blessing) for him, and he does not take his left step but Allah remits one sin from him. Any one of you may reside near the mosque or far from it; if he comes to the mosque and prays in congregation, he will be forgiven (by Allah).

If he comes to the mosque while the people had prayed in part, and the prayer remained in part, and he prays in congregation the part he joined, and completed the part he had missed, he will enjoy similarly (i.e. he will be forgiven). If he comes to the mosque when the people had finished prayer, he will enjoy the same.


Dawud :: Prayer (Kitab Al-Salat) :: [2.564]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 564

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: whoever performs ablution, and performs his ablution perfectly, and then goes to the mosque and finds that the people had finished the prayer (in congregation), Allah will give him a reward like one who prayed in congregation and attended it; The reward of those who prayed in congregation will not be curtailed.


Dawud :: Prayer (Kitab Al-Salat) :: [2.565]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 565

Narrated AbuHurayrah:

Do not prevent the female servants of Allah from visiting the mosques of Allah, but they may go out (to the mosque) having no perfumed themselves.


Dawud :: Prayer (Kitab Al-Salat) :: [2.574]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 574

Narrated Sa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) saw a person praying alone. He said: Is there any man who may do good with this (man) and pray along with him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.575]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 575

Narrated Yazid ibn al-Aswad:

Yazid prayed along with the Apostle of Allah (peace_be_upon_him) when he was a young boy. When he (the Prophet) had prayed there were two persons (sitting) in the corner of the mosque; they did not pray (along with the Prophet). He called for them. They were brought trembling (before him). He asked: What prevented you from praying along with us? They replied: We have already prayed in our houses. He said: Do not do so. If any of you prays in his house and finds that the imam has not prayed, he should pray along with him; and that will be a supererogatory prayer for him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.577]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 577

Narrated Yazid ibn Amir:

I came while the Prophet (peace_be_upon_him) was saying the prayer. I sat down and did not pray along with them. The Apostle of Allah (peace_be_upon_him) turned towards us and saw that Yazid was sitting there. He said: Did you not embrace Islam, Yazid? He replied: Why not, Apostle of Allah; I have embraced Islam. He said: What prevented you from saying prayer along with the people? He replied: I have already prayed in my house, and I thought that you had prayed (in congregation). He said: When you come to pray (in the mosque) and find the people praying, then you should pray along with them, though you have already prayed. This will be a supererogatory prayer for you and that will be counted as obligatory.


Dawud :: Prayer (Kitab Al-Salat) :: [2.579]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 579

Narrated Abdullah ibn Umar:

Sulayman, the freed slave of Maymunah, said: I came to Ibn Umar at Bilat (a place in Medina) while the people were praying. I said: Do you not pray along with them? He said: I heard the Apostle of Allah (peace_be_upon_him) say: Do not say a prayer twice in a day.


Dawud :: Prayer (Kitab Al-Salat) :: [2.580]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 580

Narrated Uqbah ibn Amir:

I heard the Apostle of Allah (peace_be_upon_him) say: He who leads the people in prayer, and he does so at the right time, will receive, as well as those who are led (in prayer) will get (the reward). He who delays (prayer) from the appointed time will be responsible (for this delay) and not those who are led in prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.581]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 581

Narrated Sulamah daughter of al-Hurr:

I heard the Apostle of Allah (peace_be_upon_him) say: One of the signs of the Last Hour will be that people in a mosque will refuse to act as imam and will not find an imam to lead them in prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.590]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 590

Narrated Abdullah ibn Abbas:

Let the best among you call the adhan for you, and the Qur'an-readers act as your imams.


Dawud :: Prayer (Kitab Al-Salat) :: [2.591]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 591

Narrated Umm Waraqah daughter of Nawfal:

When the Prophet (peace_be_upon_him) proceeded for the Battle of Badr, I said to him: Apostle of Allah allow me to accompany you in the battle. I shall act as a nurse for patients. It is possible that Allah might bestow martyrdom upon me. He said: Stay at your home. Allah, the Almighty , will bestow martyrdom upon you.

The narrator said: Hence she was called martyr. She read the Qur'an. She sought permission from the Prophet (peace_be_upon_him) to have a mu'adhdhin in her house. He, therefore, permitted her (to do so).

She announced that her slave and slave-girl would be free after her death. One night they went to her and strangled her with a sheet of cloth until she died, and they ran away.

Next day Umar announced among the people, "Anyone who has knowledge about them, or has seen them, should bring them (to him)."

Umar (after their arrest) ordered (to crucify them) and they were crucified. This was the first crucifixion at Medina.


Dawud :: Prayer (Kitab Al-Salat) :: [2.593]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 593

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: There are three types of people whose prayer is not accepted by Allah: One who goes in front of people when they do not like him; a man who comes dibaran, which means that he comes to it too late; and a man who takes into slavery an emancipated male or female slave.


Dawud :: Prayer (Kitab Al-Salat) :: [2.595]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 595

Narrated Malik ibn al-Huwayrith:

AbuAtiyyah a freed slave of us, said: Malik ibn al-Huwayrith came to this place of prayer of ours, and the iqamah for prayer was called. We said to him: Come forward and lead the prayer. He said to us: Put one of your own men forward to lead you in prayer. I heard the Apostle of Allah (peace_be_upon_him) say: If anyone visits people, he should not lead them in prayer, but some person of them should lead the prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.602]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 602

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) rode a horse in Medina. It threw him off at the root of a date-palm. His foot was injured. We visited him to inquire about his illness. We found him praying sitting in the apartment of Aisha. We, therefore, stood, (praying) behind him. He kept silent.

We again visited him to inquire about his illness. He offered the obligatory prayer sitting. We, therefore, stood (praying) behind him; he made a sign to us and we sat down. When he finished the prayer, he said: When the imam prays sitting, pray sitting; and when the imam prays standing, pray standing, and do not act as the people of Persia used to act with their chiefs (i.e. the people stood and they were sitting).


Dawud :: Prayer (Kitab Al-Salat) :: [2.603]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 603

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The imam is appointed only to be followed; when he says "Allah is most great," say "Allah is most great" and do not say "Allah is most great" until he says "Allah is most great." When he bows; bow; and do not bow until he bows. And when he says "Allah listens to him who praise Him," say "O Allah, our Lord, to Thee be the praise."

The version recorded by Muslim goes: "And to Thee be the praise: And when he prostrate; and do not prostrate until he prostrates. When he prays standing, pray standing, and when he prays sitting, all of you pray sitting.


Dawud :: Prayer (Kitab Al-Salat) :: [2.604]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 604

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The imam is appointed only to be followed. This version adds: When he recites (the Qur'an), keep silent."


Dawud :: Prayer (Kitab Al-Salat) :: [2.613]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 613

Narrated Abdullah ibn Mas'ud:

Alqamah and al-Aswad sought permission from Abdullah (ibn Mas'ud) for admission, and we remained sitting at his door for a long time. A slave-girl came out and gave them permission (to enter). He (Ibn Mas'ud) then got up and prayed (standing) between me (al-Aswad) and him (Alqamah). He then said: I witnessed the Apostle of Allah (peace_be_upon_him) doing similarly.


Dawud :: Prayer (Kitab Al-Salat) :: [2.614]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 614

Narrated Yazid ibn al-Aswad:

Jabir ibn Yazid ibn al-Aswad reported on the authority of his father: I prayed behind the Apostle of Allah (peace_be_upon_him). When he finished the prayer, he would turn (his face from the direction of the Ka'bah).


Dawud :: Prayer (Kitab Al-Salat) :: [2.615]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 615

Narrated Al-Bara' ibn Azib:

When we would pray behind the Apostle of Allah (peace_be_upon_him), we liked to be on his right side. He (the Prophet) would sit turning his face towards us (and back towards the Ka'bah) (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat) :: [2.616]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 616

Narrated Mughirah ibn Shu'bah:

The Prophet (peace_be_upon_him) said: The Imam should not pray at the place where he led the prayer until he removes (from there).


Dawud :: Prayer (Kitab Al-Salat) :: [2.617]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 617

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: When the Imam completes the prayer and sits (for reciting tashahhud), and then becomes defiled (i.e. his ablution becomes void) before he speaks (to someone), his prayer becomes complete. And those who prayed behind him also complete the prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.618]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 618

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: The key of prayer is purification; takbir (saying "Allah is most great") makes (all acts which break prayer) unlawful and taslim (uttering the salutation) makes (all such acts) lawful.


Dawud :: Prayer (Kitab Al-Salat) :: [2.619]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 619

Narrated Mu'awiyah ibn AbuSufyan:

The Prophet (peace_be_upon_him) said: Do not try to outstrip me in bowing and prostrating because however earlier I bow you will join me when I raise (my head from bowing); I have become bulky.


Dawud :: Prayer (Kitab Al-Salat) :: [2.629]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 629

Narrated Talq ibn Ali al-Hanafi:

We came to the Prophet (peace_be_upon_him), and a man came and said: Prophet of Allah, what do you say if one prays in a single garment? The Apostle of Allah (peace_be_upon_him) then took off his wrapper and combined it with his sheet, and put it on them. He got up and the Prophet of Allah (peace_be_upon_him) led us in prayer. When he finished the prayer, he said: Does every one of you have two garments?


Dawud :: Prayer (Kitab Al-Salat) :: [2.632]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 632

Narrated Salamah ibn al-Akwa':

I said: Apostle of Allah, I am a man who goes out hunting; may I pray in a single shirt? He replied: Yes, but fasten it even if it should be with a thorn.


Dawud :: Prayer (Kitab Al-Salat) :: [2.636]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 636

Narrated Buraydah ibn al-Hasib:

The Apostle of Allah (peace_be_upon_him) prohibited us to pray in a sheet of cloth without crossing both its ends, and he also prohibited us to pray in a wrapper without putting on a sheet.


Dawud :: Prayer (Kitab Al-Salat) :: [2.637]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 637

Narrated Abdullah ibn Mas'ud:

I heard the Apostle of Allah (peace_be_upon_him) say: He who lets his garment trail during prayer out of pride, Allah, the Almighty, has nothing to do with pardoning him and protecting him from Hell.


Dawud :: Prayer (Kitab Al-Salat) :: [2.641]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 641

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: Allah does not accept the prayer of a woman who has reached puberty unless she wears a veil.


Dawud :: Prayer (Kitab Al-Salat) :: [2.643]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 643

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) forbade trailing garments during prayer and that a man should cover his mouth.


Dawud :: Prayer (Kitab Al-Salat) :: [2.646]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 646

Narrated AbuRafi':

Sa'id ibn AbuSa'id al-Maqburi reported on the authority of his father that he saw AbuRafi' the freed slave of the Prophet (peace_be_upon_him), passing by Hasan ibn Ali (Allah be pleased with them) when he was standing offering his prayer. He had tied the back knot of his hair. AbuRafi' untied it. Hasan turned to him with anger, AbuRafi' said to him: Concentrate on your prayer and do not be angry: I heard the Apostle of Allah (peace_be_upon_him) say: This is the seat of the devil, referring to the back knot of the hair.


Dawud :: Prayer (Kitab Al-Salat) :: [2.647]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 647

Narrated Abdullah ibn Abbas:

Kurayb the freed slave of Ibn Abbas reported: Abdullah ibn Abbas saw Abdullah ibn al-Harith praying having the back knot of the hair. He stood behind him and began to untie it. He remained standing unmoved (stationary). When he finished his prayer he came to Ibn Abbas and said to him: What were you doing with my head? He said: I heard the Apostle of Allah (peace_be_upon_him) say: A man who prays with the black knot of hair tied is the one praying pinioned.


Dawud :: Prayer (Kitab Al-Salat) :: [2.648]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 648

Narrated Abdullah ibn as-Sa'ib:

I saw the Prophet (peace_be_upon_him) praying on the day of the conquest of Mecca and he had placed his shoe at his left side.


Dawud :: Prayer (Kitab Al-Salat) :: [2.650]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 650

Narrated AbuSa'id al-Khudri:

While the Apostle of Allah (peace_be_upon_him) was leading his Companions in prayer, he took off his sandals and laid them on his left side; so when the people saw this, they removed their sandals. When the Apostle of Allah (peace_be_upon_him) finished his prayer, he asked: What made you remove your sandals? The replied: We saw you remove your sandals, so we removed our sandals.

The Apostle of Allah (peace_be_upon_him) then said: Gabriel came to me and informed me that there was filth in them. When any of you comes to the mosque, he should see; if he finds filth on his sandals, he should wipe it off and pray in them.


Dawud :: Prayer (Kitab Al-Salat) :: [2.652]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 652

Narrated Aws ibn Thabit al-Ansari:

The Apostle of Allah (peace_be_upon_him) said: Act differently from the Jews, for they do not pray in their sandals or their shoes.


Dawud :: Prayer (Kitab Al-Salat) :: [2.653]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 653

Narrated Abdullah ibn Amr ibn al-'As:

I saw the Apostle of Allah (peace_be_upon_him) praying both barefooted and wearing sandals.


Dawud :: Prayer (Kitab Al-Salat) :: [2.654]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 654

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When any of you prays, he should not place his sandals on his right side or on his left so as to be on the right side of someone else, unless no one is at his left, but should place them between his feet.


Dawud :: Prayer (Kitab Al-Salat) :: [2.659]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 659

Narrated Al-Mughirah ibn Shu'bah:

The Apostle of Allah (peace_be_upon_him) used to pray on a mat and on a tanned skin.


Dawud :: Prayer (Kitab Al-Salat) :: [2.664]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 664

Narrated Al-Bara' ibn Azib:

The Apostle of Allah (peace_be_upon_him) used to pass through the row from one side to the other; he used to set out chests and shoulders in order, and say: Do not be irregular. And he would say: Allah and His angels bless those who are near the first rows.


Dawud :: Prayer (Kitab Al-Salat) :: [2.665]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 665

Narrated An-Nu'man ibn Bashir:

The Apostle of Allah (peace_be_upon_him) used to straighten our rows when we stood up to pray, and when we were straight, he said: Allah is most great (takbir).


Dawud :: Prayer (Kitab Al-Salat) :: [2.666]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 666

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Set the rows in order, stand shoulder to shoulder, close the gaps, be pliant in the hands of your brethren, and do not leave openings for the devil. If anyone joins up a row, Allah will join him up, but if anyone breaks a row, Allah will cut him off.


Dawud :: Prayer (Kitab Al-Salat) :: [2.667]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 667

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Stand close together in your rows, bring them near one another, and stand neck to neck, for by Him in Whose hand my soul is, I see the devil coming in through openings in the row just like a small black sheep.


Dawud :: Prayer (Kitab Al-Salat) :: [2.671]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 671

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Complete the front row, then the one that comes next, and if there is any incompleteness, let it be in the last row.


Dawud :: Prayer (Kitab Al-Salat) :: [2.672]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 672

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The best of you are those whose shoulders are soft in prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.673]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 673

Narrated AbdulHamid ibn Mahmud:

I offered the Friday prayer along with Anas ibn Malik. We were pushed to the pillars (due to the crowd of people). We, therefore, stopped forward and backward. Anas then said: We used to avoid it (setting a row between the pillars) during the time of the Apostle of Allah (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat) :: [2.676]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 676

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Allah and His angels bless those who are on the right flanks of the rows.


Dawud :: Prayer (Kitab Al-Salat) :: [2.677]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 677

Narrated AbuMalik al-Ash'ari:

Should I not tell you how the Apostle of Allah (peace_be_upon_him) led the prayer? He said: He had the iqamah announced, drew the men up in line and drew up the youths behind them, then led them in prayer. He then mentioned how he conducted it. and said: Thus is the prayer of......AbdulA'la said: I think he must have said: My people.


Dawud :: Prayer (Kitab Al-Salat) :: [2.681]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 681

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Have the imam in the centre and close up the gaps.


Dawud :: Prayer (Kitab Al-Salat) :: [2.682]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 682

Narrated Wabisah:

The Apostle of Allah (peace_be_upon_him) saw a man praying alone behind the row. He ordered him to repeat. Sulayman ibn Harb said: The prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.689]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 689

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When one of you prays, he should put something in front of his face, and if he can find nothing , he should set up his staff; but if he has no staff, he should draw a line; then what passes in front of him will not harm him.


Dawud :: Prayer (Kitab Al-Salat) :: [2.693]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 693

Narrated Al-Miqdad ibn al-Aswad:

I never saw the Apostle of Allah (peace_be_upon_him) praying in front of a stick, a pillar, or a tree, without having it opposite his right or left eyebrow, and not facing it directly.


Dawud :: Prayer (Kitab Al-Salat) :: [2.694]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 694

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Do not pray behind a sleeping or a talking person.


Dawud :: Prayer (Kitab Al-Salat) :: [2.695]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 695

Narrated Sahl ibn AbuHathmah:

The Prophet (peace_be_upon_him) said: When one of you prays facing a sutrah he should keep close to it, and not let the devil interrupt his prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.703]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 703

Narrated Abdullah ibn Abbas:

Qatadah said: I heard Jabir ibn Zayd who reported on the authority of Ibn Abbas; and Shu'bah reported the Prophet (peace_be_upon_him) as saying: A menstruating woman and a dog cut off the prayer.


Dawud :: Prayer (Kitab Al-Salat) :: [2.704]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 704

Narrated Abdullah ibn Abbas:

Ikrimah reported on the authority of Ibn Abbas, saying: I think the Apostle of Allah (peace_be_upon_him) said: When one of you prays without a sutrah, a dog, an ass, a pig, a Jew, a Magian, and a woman cut off his prayer, but it will suffice if they pass in front of him at a distance of over a stone's throw.


Dawud :: Prayer (Kitab Al-Salat) :: [2.710]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 710

Narrated Aisha, Ummul Mu'minin:

I was sleeping in front of the Prophet (peace_be_upon_him) with my legs between him and the qiblah. Shu'bah said: I think she said: I was menstruating.


Dawud :: Prayer (Kitab Al-Salat) :: [2.713]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 713

Narrated Aisha, Ummul Mu'minin:

I used to sleep lying between the Apostle of Allah (peace_be_upon_him) and the qiblah. The Apostle of Allah (peace_be_upon_him) used to pray when I (was lying) in front of him. When he wanted to offer the witr prayer - added by the narrator Uthman - he pinched me - then the narrators are agreed - and said: Set aside.


Dawud :: Prayer (Kitab Al-Salat) :: [2.714]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 714

Narrated Abdullah ibn Abbas:

I came riding a donkey. Another version has: Ibn Abbas said: When I was near the age of the puberty I came riding a she-ass and found the Apostle of Allah (peace_be_upon_him) leading the people in prayer at Mina. I passed in front of a part of the row (of worshippers), and dismounting left my she-ass for grazing in the pasture, and I joined the row, and no one objected to that.


Dawud :: Prayer (Kitab Al-Salat) :: [2.715]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 715

Narrated Abdullah ibn Abbas:

AbusSahba' said: We discussed the things that cut off the prayer according to Ibn Abbas. He said: I and a boy from Banu AbdulMuttalib came riding a donkey, and the Apostle of Allah (peace_be_upon_him) was leading the people in prayer. He dismounted and I also dismounted. I left the donkey in front of the row (of the worshippers). He (the Prophet) did not pay attention to that. Then two girls from Banu AbdulMuttalib came and joined the row in the middle, but he paid no attention to that.


Dawud :: Prayer (Kitab Al-Salat) :: [2.717]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 717

Narrated Al-Fadl ibn Abbas:

The Apostle of Allah (peace_be_upon_him) came to us accompanied by Abbas when we were in open country belonging to us. He prayed in a desert with no sutrah in front of him, and a she-ass and a bitch of ours were playing in front of him, but he paid no attention to that.


Dawud :: Prayer (Kitab Al-Salat) :: [2.718]

Prayer (Kitab Al-Salat)

Dawud :: Book 2 : Hadith 718

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: Nothing interrupt prayer, but repulse as much as you can anyone who passes in front of you, for he is just a devil.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.725]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 725

Narrated Wa'il ibn Hujr:

I purposely looked at the prayer of the Apostle of Allah (peace_be_upon_him), how he offered it. The Apostle of Allah (peace_be_upon_him) stood up, faced the direction of the qiblah and uttered the takbir (Allah is most great) and then raised his hands in front of his ears, then placed his right hand on his left (catching each other).

When he was about to bow, he raised them in the same manner. He then placed his hands on his knees. When he raised his head after bowing, he raised them in the like manner. When he prostrated himself he placed his forehead between his hands.

He then sat down and spread his left foot and placed his left hand on his left thigh, and kept his right elbow aloof from his right thigh. He closed his two fingers and made a circle (with the fingers).

I (Asim ibn Kulayb) saw him (Bishr ibn al-Mufaddal) say in this manner. Bishr made the circle with the thumb and the middle finger and pointed with the forefinger.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.727]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 727

Narrated Wa'il ibn Hujr:

I witnessed the Prophet (peace_be_upon_him) raise his hands in front of his ears when he began to pray. I then came back and saw them (the people) raising their hands up to their chest when they began to pray. They wore long caps and blankets.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.736]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 736

Narrated Wa'il ibn Hujr:

I saw the Apostle of Allah (peace_be_upon_him) raising his thumbs in prayer up to the lobes of his ears.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.737]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 737

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) uttered the takbir (Allah is most great) for prayer (in the beginning), he raised his hands opposite to his shoulders; and when he bowed, he did like that; and when he raised his head to prostrate, he did like that; and when he got up at the end of two rak'ahs, he did like that.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.738]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 738

Narrated Abdullah ibn Abbas:

Maymun al-Makki said: that he saw Abdullah ibn az-Zubayr leading in prayer. He pointed with his hands (i.e. raised his hands opposite to the shoulders) when he stood up, when he bowed and when he prostrated, and when he got up after prostration, he pointed with his hands (i.e. raised his hands).

The I went to Ibn Abbas and said (to him) I saw Ibn az-Zubayr praying that I never saw anyone praying. I then told him about the pointing with his hands (raising his hands). He said: If you like to see the prayer of the Apostle of Allah (peace_be_upon_him) follower the prayer as offered by Abdullah ibn az-Zubayr.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.739]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 739

Narrated Abdullah ibn Abbas:

Nadr ibn Kathir as-Sa'di said: Abdullah ibn Tawus prayed at my side in the mosque of al-Khayf. When he made the first prostration, he raised his head after it and raised his hands opposite to his face. This came as something strange for me. I, therefore, said it to Wuhayb ibn Khalid.

Then Wuhayb ibn Khalid said to him: You are doing a thing that I did not see anyone do. Ibn Tawus then replied: I saw my father doing it, and my father said: I saw Ibn Abbas doing it. I do not know but he said: The Prophet (peace_be_upon_him) used to do it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.743]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 743

Narrated Ali ibn AbuTalib:

When the Apostle of Allah (peace_be_upon_him) stood for offering the obligatory prayer, he uttered the takbir (Allah is most great) and raised his hands opposite to his shoulders; and he did like that when he finished recitation (of the Qur'an) and was about to bow; and he did like that when he rose after bowing; and he did not raise his hands in his prayer while he was in his sitting position.

When he stood up from his prostrations (at the end of two rak'ahs), he raised his hands likewise and uttered the takbir (Allah is most great) and raised his hands so as to bring them up to his shoulders, as he uttered the takbir in the beginning of the prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.745]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 745

Narrated AbuHurayrah:

If I were in front of the Prophet (peace_be_upon_him), I would see his armpits. Ibn Mu'adh added that Lahiq said: Do you not see, AbuHurayrah could not stand in front of the Prophet (peace_be_upon_him) while he was praying. Musa added: When he uttered the takbir, he raised his hands.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.746]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 746

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) taught us how to pray. He then uttered the takbir (Allah is most great) and raised his hands; when he bowed, he joined his hands and placed them between his knees. When this (report) reached Sa'd, he said: My brother said truly. We used to do this; then we were later on commanded to do this, that is, to place the hands on the knees.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.747]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 747

Narrated Abdullah ibn Mas'ud:

Alqamah said: Abdullah ibn Mas'ud said: Should I pray in the way the Apostle of Allah (peace_be_upon_him) had performed it? He said: He prayed, raising his hands only once.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.749]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 749

Narrated Al-Bara' ibn Azib:

When the Apostle of Allah (peace_be_upon_him) began prayer, he raised his hands up to his ears, then he did not repeat.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.751]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 751

Narrated Al-Bara' ibn Azib:

I saw that the Apostle of Allah (peace_be_upon_him) raised his hands when he began prayer, but he did not raise them until he finished (prayer).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.752]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 752

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) began his prayer, he raised his hands extensively.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.754]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 754

Narrated Abdullah ibn Mas'ud:

AbuUthman an-Nahdi said: When Ibn Mas'ud prayed he placed his left hand on the right. The Prophet (peace_be_upon_him) saw him and placed his right hand on his left one.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.755]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 755

Narrated Ali ibn AbuTalib:

AbuJuhayfah said: Ali said that it is a sunnah to place one hand on the other in prayer below the navel.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.756]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 756

Narrated Ali ibn AbuTalib:

Jarir ad-Dabbi reported: I saw Ali (Allah be pleased with him) catching hold of his left hand) by his right hand on the wrist above the navel.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.757]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 757

Narrated AbuHurayrah:

(The established way of folding hands is) to hold the hands by the hands in prayer below the navel.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.758]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 758

Narrated Tawus:

The Apostle of Allah (peace_be_upon_him) used to place his right hand on his left hand, then he folded them strictly on his chest in prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.763]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 763

Narrated Jubayr ibn Mut'im:

Jabir saw the Apostle of Allah (peace_be_upon_him) observing prayer. (The narrator Amr said: I do not know which prayer he was offering.)

He (the Prophet) said: Allah is altogether great; Allah is altogether great; Allah is altogether great; and praise be to Allah in abundance; and praise be to Allah is abundance; and praise be to Allah in abundance. Glory be to Allah in the morning and after (saying it three times). I seek refuge in Allah from the accursed devil, from his puffing up (nafkh), his spitting (nafth) and his evil suggestion (hamz).

He (Amr) said: His nafth it poetry, his nafkh is pride, and his hamz is madness.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.765]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 765

Narrated Aisha, Ummul Mu'minin:

Asim ibn Humayd said: I asked Aisha: By what words the Apostle of Allah (peace_be_upon_him) would begin his supererogatory prayer at night?

She replied: You ask me about a thing of which no one asked me before you. When he stood up, be uttered the takbir (Allah is most great) ten times, and uttered "Praise be to Allah" ten times, and uttered "Glory be to Allah " ten times, and uttered "There is no god but Allah" ten times, and sought forgiveness ten times, and said: O Allah, forgive me, and guide me, and give me sustenance, and keep me well, and he sought refuge in Allah from the hardship of standing before Allah on the Day of Judgment.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.772]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 772

Narrated Rifa'ah ibn Rafi':

I offered prayer behind the Apostle of Allah (peace_be_upon_him). Rifa'ah sneezed. The narrator Qutaybah did not mention the name Rifa'ah (but he said: I sneezed). So I said: Praise be to Allah, praise much, good and blessed therein, blessed thereupon, as our Lord likes and is pleased. When the Apostle of Allah (peace_be_upon_him) finished his prayer, he turned and said: Who was the speaker in prayer? He then narrated the rest of the tradition like that of Malik and completed it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.774]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 774

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) got up to pray at night (for tahajjud prayer) he uttered the takbir and then said: "Glory be to Thee, O Allah," and "Praise be to Thee" and "Blessed is Thy name," and Exalted is Thy greatness." and "There is no god but Thee." He then said: "There is no god but Allah" three times; he then said: "Allah is altogether great" three times: "I seek refuge in Allah, All-Hearing and All-Knowing from the accursed devil, from his evil suggestion (hamz), from his puffing up (nafkh), and from his spitting (nafth)" He then recited (the Qur'an).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.775]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 775

Narrated Aisha, Ummul Mu'minin:

When the Apostle of Allah (peace_be_upon_him) began his prayer, he said: "Glory be to Thee, O Allah," and "Praise be to Thee" and "Blessed is Thy name, and Exalted is Thy greatness, sand there is no god but Allah."


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.776]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 776

Narrated Samurah ibn Jundub:

I remember two period of silence in prayer, one when the imam said the takbir; and one when he finished reciting the Fatihah and the surah when he was about to bow. But Imran ibn Husayn took it as something strange. So they wrote about it to Ubayy (ibn Ka'b) in Medina. He verified the statement of Samurah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.778]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 778

Narrated Samurah ibn Jundub; Ubayy ibn Ka'b:

Samurah ibn Jundub and Imran ibn Husayn had a discussion (about the periods of silence in prayer). Samurah then said that he remembered two periods of silence from the Apostle of Allah (peace_be_upon_him); one when he uttered the takbir and the other when he finished reciting: "Not of those with whom Thou art angry, nor of those who go astray" (i.7).

Samurah remembered that, but Imran ibn Husayn rejected it.

Then they wrote about it to Ubayy ibn Ka'b. He wrote a letter to them and gave a reply to them that Samurah remembered correctly.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.779]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 779

Narrated Samurah ibn Jundub:

I remember from the Apostle of Allah (peace_be_upon_him) two periods of silence. Sa'id said: We asked Qatadah: What are those two periods of silence? He said: (one) when he began his prayer, and (one) when he finished the recitation. Then he added: When he finished reciting (the closing verse of the Fatihah): "Not of those with whom Thou art angry, nor of who go astray."


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.785]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 785

Narrated Uthman ibn Affan::

Yazid al-Farisi said: I heard Ibn Abbas say: I asked Uthman ibn Affan: What moved you to put the (Surah) al-Bara'ah which belongs to the mi'in (surahs) (containing one hundred verses) and the (Surah) al-Anfal which belongs to the mathani (Surahs) in the category of as-sab'u at-tiwal (the first long surah or chapters of the Qur'an), and you did not write "In the name of Allah, the Compassionate, the Merciful" between them?

Uthman replied: When the verses of the Qur'an were revealed to the Prophet (peace_be_upon_him), he called someone to write them down for him and said to him: Put this verse in the surah in which such and such has been mentioned; and when one or two verses were revealed, he used to say similarly (regarding them). (Surah) al-Anfal is the first surah that was revealed at Medina, and (Surah) al-Bara'ah was revealed last in the Qur'an, and its contents were similar to those of al-Anfal. I, therefore, thought that it was a part of al-Anfal. Hence I put them in the category of as-sab'u at-tiwal (the seven lengthy surahs), and I did not write "In the name of Allah, the Compassionate, the Merciful" between them.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.792]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 792

Narrated Some Companions of the Prophet:

AbuSalih reported on the authority of some Companions of the Prophet (peace_be_upon_him): The Prophet (peace_be_upon_him) said to a person: what do you say in prayer?

He replied: I first recite tashahhud (supplication recited in sitting position), and then I say: O Allah, I ask Thee for Paradise, and I seek refuge in Thee from Hell-Fire, but I do not understand your sound and the sound of Mu'adh (what you say or he says in prayer). The Prophet (peace_be_upon_him) said: We too go around it (paradise and Hell-fire).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.804]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 804

Narrated Jabir ibn Samurah:

The Apostle of Allah (peace_be_upon_him) used to recite in the noon and afternoon prayer: "By the Heaven and the Morning Star" (Surah 86) and "By the Heaven , holding mansions of the stars" (Surah 85) and similar surahs of equal length.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.807]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 807

Narrated Abdullah ibn Abbas:

Abdullah ibn Ubaydullah said: I went to Ibn Abbas accompanying some youths of Banu Hashim. We said to one of them: Ask Ibn Abbas: Did the Apostle of Allah (peace_be_upon_him) recite (the Qur'an) in the noon and afternoon prayers? He replied: No. People said to him: Perhaps he might recite the Qur'an quietly. He said: May your face be scratched (a kind of curse)! This (statement) is worse than the former.

He was only a servant (of Allah) receiving Commands from Him. He preached (the divine) message which he brought with him. He did not command anything to us (Banu Hashim) specially excluding other people except three points: he commanded us to perform ablution perfectly, and not to accept charity (sadaqah) and not to make pairing of donkey with horse.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.808]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 808

Narrated Abdullah ibn Abbas:

I do not know whether the Apostle of Allah (peace_be_upon_him) would recite the Qur'an at the noon and afternoon prayer or not.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.815]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 815

Narrated Mu'adh ibn Abdullah al-Juhani:

A man of Juhaynah told him that he had heard the Prophet (peace_be_upon_him) reciting "When the earth is shaken" (Surah 99) in both rak'ahs of the morning prayer. But I do not know whether he had forgotten, or whether he recited it on purpose.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.822]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 822

Narrated Ubadah ibn as-Samit:

We were behind the Apostle of Allah (peace_be_upon_him) at the dawn prayer, and he recited (the passage), but the recitation became difficult for him. Then when he finished, he said: Perhaps you recite behind your imam? We replied: Yes, it is so, Apostle of Allah. He said: Do not do so except when it is Fatihat al-Kitab, for he who does not recite it is not credited with having prayed.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.825]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 825

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) finished a prayer in which he had recited (the Qur'an) loudly, he asked: Did any of you recite along with me just now? A man replied: Yes, Apostle of Allah. He said: I am wondering what is the matter with me that I have been contended with reciting the Qur'an. He said: When the people heard that from the Apostle of Allah (peace_be_upon_him) they ceased reciting (the Qur'an) along with him at the prayers in which he recited aloud.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.827]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 827

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) led (us) in the noon prayer, and a man came and recited behind him "Glorify the name of thy Lord, the Most High" (Surah 87). When he finished (the prayer), he said: Which of you recited? They (the people) said: A man (recited). He said: I knew that some one of you confused me in it (in the recitation of the Qur'an).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.829]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 829

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) came to us while we were reciting the Qur'an, and there were among us bedouins and the non-Arabs. He said: Recite, all is well. In the near future there will appear people who will straighten it (the Qur'an) as an arrow is straightened. They will recite it quickly and not slowly (or it means that they will get the reward in this world and not in the Hereafter).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.831]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 831

Narrated Abdullah ibn AbuAwfa:

A man came to the Prophet (peace_be_upon_him) and said: I cannot memorise anything from the Qur'an: so teach me something which is sufficient for me. He said: Say Glory be to Allah, and praise be to Allah, and there is no god but Allah, and Allah is most great, and there is no might and no strength but in Allah.

:He said: Apostle of Allah, this is for Allah, but what is for me? He said: Say: O Allah have mercy on me, and sustain me, and keep me well, and guide me. When he stood up, he made a sign with his hand (indicating that he had earned a lot).

The Apostle of Allah (peace_be_upon_him) said: He filed up his hand with virtues.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.837]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 837

Narrated Wa'il ibn Hujr:

I saw that the Prophet (peace_be_upon_him) placed his knees (on the ground) before placing his hands when he prostrated himself. And when he stood up, he raised his hands before his knees.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.840]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 840

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: (Does) one of you kneel down in his prayer as a camel kneels down (i.e. put his knees before his hands).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.849]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 849

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) used to say between the two prostrations: "O Allah, forgive me, have mercy on me, guide me, heal me, and provide for me."


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.850]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 850

Narrated Asma' daughter of AbuBakr:

I heard the Apostle of Allah (peace_be_upon_him) say: One of you who believes in Allah and in the Last Day should not raise her head until the men raise their heads (after prostration) lest they should see the private parts of men.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.854]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 854

Narrated AbuMas'ud al-Badri:

The Prophet (peace_be_upon_him) said: A man's prayer does not avail him unless he keeps his back steady when bowing and prostrating.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.856]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 856

Narrated Rifa'ah ibn Rafi':

A man entered the mosque...... He then narrated the tradition like the one narrated in (No.855).

This version is as follows: The Prophet (peace_be_upon_him) said: The prayer of anyone is not perfect unless he performs ablution perfectly; he should then utter the takbir, and praise Allah, the Exalted, and admire Him; he should then recite the Qur'an as much as he desires. He should then say: "Allah is Most Great". Next he should bow so that all his joints return to their proper places. Then he should say: "Allah listens to the one who praises Him", and stand erect. He should then say:"Allah is most great," and should prostrate himself so that all his joints are completely at rest. Then he should say: "Allah is most great"; he should raise his head (at the end of prostration) till he sits erect. Then he should say: "Allah is most great"; then he should prostrate himself till all his joints return to their proper places. Then he should raise his head and say the takbir. When he does so, then his prayer is completed.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.857]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 857

Narrated Rifa'ah ibn Rafi':

This version (of Hadith No 856) adds: The Apostle of Allah (peace_be_upon_him) said: The prayer of any of you is not complete until he performs ablution perfectly, as Allah, the Exalted, has ordered you. He should wash his face and hands up to the elbows, and wipe his head and (wash) his feet up to the ankles. Then he should exalt Allah and praise Him. Then he should recite the Qur'an as much as it is convenient for him.

(Narrator then narrated the tradition like Hammad's, No. 856). He said: He then utter the takbir and prostration himself so that his face is at rest.

Hammam (sub-narrator) said: Sometimes he reported: So that his forehead is at rest on the ground, and his joints return to their places and are loosened. Then he should say the takbir and then sit right on his hips and erect his back. He described the nature of prayer in this way by offering four rak'ahs until he finished it. The prayer of any of you is not complete unless he does so.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.861]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 861

Narrated AbdurRahman ibn Shibl:

The Apostle of Allah (peace_be_upon_him) prohibited to peck like a crow, and to spread (the forearms) like a wild beast, and to fix a place in the mosque like a camel which fixes its place. These are the wordings of Qutaybah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.862]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 862

Narrated Uqbah ibn Amr al-Ansari:

Salim al-Barrad said: We came to AbuMas'ud Uqbah ibn Amr al-Ansari and said to him: Tell us about the prayer of the Apostle of Allah (peace_be_upon_him).

He stood up before us in the mosque and said the takbir. When he bowed, he placed his hands upon his knees and put his fingers below, and kept his elbows (arms) away from his sides, so everything returned properly to its place. Then he said: "Allah listens to him who praises Him"; then he stood up so that everything returned properly to its place; then he said the takbir and prostrated and put the palms of his hands on the ground; he kept his elbow (arms) away from his sides, so that everything returned to its proper place. Then he raised his head and sat so that everything returned to its place; he then repeated it in a similar way. Then he offered four rak'ahs of prayer like this rak'ah and completed his prayer.

Then he said: Thus we witnessed the Apostle of Allah (peace_be_upon_him) offering his prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.863]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 863

Narrated AbuHurayrah:

Anas ibn Hakim ad-Dabbi said that he feared Ziyad or Ibn Ziyad; so he came to Medina and met AbuHurayrah. He attributed his lineage to me and I became a member of his lineage.

AbuHurayrah said (to me): O youth, should I not narrate a tradition to you? I said: Why not, may Allah have mercy on you?

(Yunus (a narrator) said: I think he narrated it (the tradition) from the Prophet (peace_be_upon_him):) The first thing about which the people will be called to account out of their actions on the Day of Judgment is prayer. Our Lord, the Exalted, will say to the angels - though He knows better: Look into the prayer of My servant and see whether he has offered it perfectly or imperfectly. If it is perfect, that will be recorded perfect.

If it is defective, He will say: See there are some optional prayers offered by My servant. If there are optional prayer to his credit, He will say: Compensate the obligatory prayer by the optional prayer for My servant. Then all the actions will be considered similarly.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.865]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 865

Narrated Tamim ad-Dari:

Tamim reported this tradition from the Prophet (peace_be_upon_him) as (Hadith No 863). This version adds: Then zakat will be considered in a similar way. Then all the actions will be considered accordingly.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.868]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 868

Narrated Uqbah ibn Amir:

When "Glorify the name of your mighty Lord" was revealed, the Apostle of Allah (peace_be_upon_him) said: Use it when bowing, and when "Glorify the name of your most high Lord" was revealed, he said: Use it when prostrating yourself.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.869]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 869

Narrated Uqbah ibn Amir:

The above (No 868) tradition has also been reported through a different chain of narrators by Uqbah ibn Amir to the same effect. This version adds: When the Apostle of Allah (peace_be_upon_him) bowed, he said: "Glory and praise be to my mighty Lord" three times, and when he prostrated himself, he said: "Glory and praise be to my most high Lord" three times.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.872]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 872

Narrated Awf ibn Malik al-Ashja'i:

I stood up to pray along with the Apostle of Allah (peace_be_upon_him); he got up and recited Surat al-Baqarah (Surah 2).

When he came to a verse which spoke of mercy, he stopped and made supplication, and when he came to verse which spoke of punishment, he stopped and sought refuge in Allah, then he bowed and paused as long as he stood (reciting Surah al-Baqarah), and said while bowing, "Glory be to the Possessor of greatness, the Kingdom, grandeur and majesty."

:Then he prostrated himself and paused as long as he stood up and recited Surat Aal Imran (Surah 3) and then recited many surahs one after another.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.873]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 873

Narrated Hudhayfah:

Hudhayfah saw the Apostle of Allah (peace_be_upon_him) praying at night. He said: Allah is most great" three times, "Possessor of kingdom, grandeur, greatness and majesty."

He then began (his prayer) and recited Surah al-Baqarah; then he bowed and he paused in bowing as long as he stood up; he said while bowing, "Glory be to my mighty Lord," "Glory be to my mighty Lord" ; then he raised his head, after bowing: then he stood up and he paused as long as he paused in bowing and said, "Praise be to my Lord" ; then he prostrated and paused in prostration as long as he paused in the standing position; he said while prostrating: "Glory be to my most high Lord"; then he raised his head after prostration, and sat as long as he prostrated, and said while sitting: "O my Lord forgive me."

He offered four rak'ahs of prayer and recited in them Surah al-Baqarah, Aal Imran, an-Nisa, al-Ma'idah, or al-An'am. The narrator Shu'bah doubted.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.879]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 879

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to make supplication during the prayer saying: "O Allah, I seek refuge in Thee from the punishment of the grave; I seek refuge in Thee from the trial of the Antichrist; I seek refuge in Thee from the trial of life and the trial of death; O Allah, I seek refuge in Thee from sin and debt." Someone said to him: How often you seek refuge from debt! He replied: When a man is in debt, he talks and tells lies, makes promises and breaks them.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.880]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 880

Narrated AbuLayla al-Ansari:

I prayed by the side of the Apostle of Allah (peace_be_upon_him) in the supererogatory prayer and I heard him say: "I refuge in Allah from the Hell-Fire; woe to the inmates of the Hell-fire!"


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.885]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 885

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: When one of you bows, he should say three time,:"Glory be to my mighty Lord," and when he prostrates, he should say: "Glory be to my most high Lord" three times. This is the minimum number.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.886]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 886

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: When one of you recites "By the fig and the olive" (Surah 95) and comes to its end "Is not Allah the best judge?" (verse 8), he should say: "Certainly, and I am one of those who testify to that." When one recites "I swear by the Day of Resurrection" (Surah 75) and comes to "Is not that one able to raise the dead to life? (verse 40), he should say: "Certainly." And when one recites "By those that are sent" (Surah 77), and comes to "Then in what message after that will they believe? " (Surah 50), he should say: "We believe in Allah."

The narrator Isma'il (ibn Umayyah) said: I beg to repeat (this tradition) before the Bedouin (who reported this tradition) so that I might see whether he (was mistaken).

He said: My nephew, do you think that I did not remember it? I performed sixty hajj (pilgrimages); there is no hajj but I recognize the came on which I performed it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.887]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 887

Narrated Anas ibn Malik:

I did not offer behind anyone after the Apostle of Allah (peace_be_upon_him) a prayer like the prayer offered by the Apostle of Allah (peace_be_upon_him) than this youth, i.e. Umar ibn AbdulAziz. We estimated reciting glorification ten times in his bowing, and in his prostration ten times.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.888]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 888

Narrated Abdullah ibn Abbas:

Ibn Abbas reported the Prophet (peace_be_upon_him) as saying: I have been commanded - according to the version of Hammad: Your Prophet (peace_be_upon_him) was commanded - to prostrate on seven (bones), and not to fold back the hair or the clothing.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.891]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 891

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Both hands prostrate as the face prostrates. When one of you puts his face (on the ground) he should put his hands too (on the ground). And when he raises it, he should raise them too.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.895]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 895

Narrated Al-Bara' ibn Azib:

Al-Bara' described to us (the nature of prostration). He placed his hands (palms), reclined on his knees, and raised his hips; he said: This is how the Apostle of Allah (peace_be_upon_him) used to prostrate himself.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.898]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 898

Narrated Abdullah ibn Abbas:

I came to the Prophet (peace_be_upon_him) from behind. I saw the whiteness of his armpits and he kept his arms away from his sides and raised his stomach (from the ground).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.899]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 899

Narrated Ahmar ibn Jaz':

When the Apostle of Allah (peace_be_upon_him) prostrated himself, he kept his arms far away from his sides so much so that we took pity on him.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.901]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 901

Narrated AbuHurayrah:

The Companions of the Prophet (peace_be_upon_him) complained to the Prophet (peace_be_upon_him) about the hardship when they kept their forearms far away from their sides while prostrating. He said: Take help with the elbows (by spreading them on the ground and sticking them to the sides).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.902]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 902

Narrated Abdullah ibn Umar:

Sa'id ibn Ziyad ibn Subayh al-Hanafi said: I prayed by the side of Ibn Umar and I put my hands on my waist. When he finished his prayer, He said: This is a cross in prayer; the Apostle of Allah (peace_be_upon_him) used to forbid it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.903]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 903

Narrated Abdullah ibn ash-Shikhkhir:

I saw the Apostle of Allah (peace_be_upon_him) praying and a sound came from his breast like the rumbling of a mill owing to weeping.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.906]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 906

Narrated Al-Miswar ibn Yazid al-Maliki:

The Apostle of Allah (peace_be_upon_him) recited - Yahya (sub narrator) said: Sometimes al-Miswar said: I prayed along with the Apostle of Allah (peace_be_upon_him) and witnessed that he recited - the Qur'an during the prayer and omitted something (i.e. some verses inadvertently) which he did not recite.

A man said to him: Apostle of Allah, you omitted such-and-such verse. The Apostle of Allah (peace_be_upon_him) said: Why did you not remind me of it?

The narrator Sulayman said in his version: He (the man) said: I thought that it (the verse) was repealed.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.908]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 908

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) said: Ali, do not instruct the imam during the prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.909]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 909

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: Allah, the Most High, continues to turn favourably towards a servant while he is engaged in prayer as long as he does not look to the side (by turning the neck), but if he does so, He turns away from him.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.916]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 916

Narrated Sahl ibn al-Hanzaliyyah:

The iqamah for the morning prayer was pronounced and the Apostle of Allah (peace_be_upon_him) began to offer prayer while he was looking at the mountain-pass.

(AbuDawud elaborated that the Prophet had sent a horseman to the mountain-pass at night in order to keep watch.)


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.918]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 918

Narrated AbuQatadah:

We were sitting in the mosque when the Apostle of Allah (peace_be_upon_him) came upon us carrying Umamah daughter of Abul'As ibn ar-Rabi'. Her mother was Zaynab daughter of the Apostle of Allah (peace_be_upon_him). She (Umamah) was a child and he (the Prophet) was carrying her on his shoulder.

The Apostle of Allah (peace_be_upon_him) led (the people) in prayer while she was on his shoulder. When he bowed he put her down and took her up when he got up. He kept on doing so until he finished his prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.921]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 921

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Kill the two black things during prayer, the snake and scorpion.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.922]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 922

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) was praying with his door bolted. I came and asked to have the door opened. He walked and opened the door for me. He then returned to his place for prayer. He (the narrator Urwah) mentioned that the door faced the qiblah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.924]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 924

Narrated Abdullah ibn Mas'ud:

We used to salute during prayer and talk about our needs. I came to the Apostle of Allah (peace_be_upon_him) and found him praying. I saluted him, but he did not respond to me. I recalled what happened to me in the past and in the present.

When the Apostle of Allah (peace_be_upon_him) finished his prayer, he said to me: Allah, the Almighty, creates new command as He wishes, and Allah, the Exalted, has sent a fresh command that you must not talk during prayer. He then returned my salutation.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.925]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 925

Narrated Suhayb:

I passed by the Apostle of Allah (peace_be_upon_him) who was praying. I saluted him and he returned it by making a sign.

The narrator said: I do not know but that he said: He made a sign with his finger. This is the version reported by Qutaybah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.927]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 927

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) went to Quba to offer prayer. Then the Ansar (the Helpers) came to him and gave him a salutation while he was engaged in prayer.

I asked Bilal: How did you find the Apostle of Allah (peace_be_upon_him) responding to them when they gave him a salutation while he was engaged in prayer. He replied: In this way, and Ja'far ibn Awn demonstrated by spreading his palm, and keeping its inner side below and its back side above.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.932]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 932

Narrated Wa'il ibn Hujr:

When the Apostle of Allah (peace_be_upon_him) recited the verse "Nor of those who go astray" (Surah al-Fatihah, verse 7), he would say Amin; and raised his voice (while uttering this word).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.934]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 934

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) recited the verse "Not of those with whom Thou art angry, nor of those who go astray," he would say Amin so loudly that those near him in the first row would hear it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.938]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 938

Narrated AbuZuhayr an-Numayri:

AbuMisbah al-Muqra'i said: We used to sit in the company of AbuZuhayr an-Numayri. He was a companion of the Prophet (peace_be_upon_him), and he used to narrate good traditions. Once a man from among us made a supplication. He said: End it with the utterance of Amin, for Amin is like a seal on the book.

AbuZuhayr said: I shall tell you about that. We went out with the Apostle of Allah (peace_be_upon_him) one night and came upon a man who made supplication with persistence. The Prophet (peace_be_upon_him) waited to hear him. The Prophet (peace_be_upon_him) said: He will have done something which guarantees (Paradise for him) if he puts a seal to it. One of the people asked: What should he use as a seal? He replied: Amin, for if he ends it with Amin, he will do something which guarantees (Paradise for him).

Then the man who questioned the Prophet (peace_be_upon_him) came to the man who was supplicating, and said to him: So-and-so, end it with Amin and receive the good news. These are the words of Mahmud.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.943]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 943

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) used to make a sign during prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.944]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 944

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Saying Tasbih applies to men during prayer and clapping applies to women. Anyone who makes a sign during his prayer, a sign which is intelligible by implication, should repeat it (i.e. his prayer).

(AbuDawud commented on the Hadith saying, this is a result of confusion.)


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.945]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 945

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: When one of you gets up to pray, he must not remove pebbles, for mercy is facing him.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.948]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 948

Narrated Umm Qays bint Mihsan:

Hilal ibn Yasaf said: I came to ar-Raqqah (a place in Syria). One of my companions said to me: Do you want to see any of the Companions of the Prophet (peace_be_upon_him)? I said: A good opportunity. So we went to Wabisah.

I said to my friend: Let us first see his mode of living. He had a cap with two ears stuck (to his head), and wearing a brown silken robe. He was resting on a staff during prayer. We asked him (about resting on the staff) after salutation; He said: Umm Qays daughter of Mihsan said to me that when the Apostle of Allah (peace_be_upon_him) became aged and the flesh grew increasingly on him, he took a prop at his place of prayer and rested on it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.957]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 957

Narrated Wa'il ibn Hujr:

I said that I should look at the prayer of the Apostle of Allah (peace_be_upon_him) how he prays. The Apostle of Allah (peace_be_upon_him) stood up and faced the qiblah (i.e. the direction of Ka'bah) and uttered the takbir (Allah is most great); then he raised his hands till he brought them in front of his ears; then he caught hold of his left hand with his right hand (i.e. folded his hands).

When he was about to bow, he raised them (his hands) in a like manner. Then he sat, stretched out his left foot (to sit on it), placed his left hand on his left thigh, and kept away the tip of his right elbow from his right thigh, joined two fingers, formed a ring, to do so. And the narrator Bishr made a ring with the thumb and the middle finger.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.964]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 964

Narrated Abdullah ibn Mas'ud:

We did not know what we should say when we sat during prayer. The Apostle of Allah (peace_be_upon_him) was taught (by Allah). He then narrated the tradition to the same effect. Sharik reported from Jami', from AbuWa'il on the authority of Abdullah ibn Mas'ud something similar.

He said: He used to teach us also some other words, but he did not teach them as he taught us the tashahhud: O Allah, join our hearts, mend our social relationship, guide us to the path of peace, bring us from darkness to light, save us from obscenities, outward or inward, and bless our ears, our eyes, our hearts, our wives, our children, and relent toward us; Thou art the Relenting, the Merciful. And make us grateful for Thy blessing and make us praise it while accepting it and give it to us in full.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.965]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 965

Narrated Abdullah ibn Mas'ud:

Alqamah said that Abdullah ibn Mas'ud caught hold of his hand saying that the Apostle of Allah (peace_be_upon_him) caught hold of his (Ibn Mas'ud's) hand and taught him the tashahhud during prayer.

He then narrated the (well known ) tradition (of tashahhud). This version adds: When you say this or finish this, then you have completed your prayer. If you want to stand up, then stand, and if you want to remain sitting, then remain sitting.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.967]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 967

Narrated AbuMusa al-Ash'ari:

Hittan ibn Abdullah ar-Ruqashi said: AbuMusa al-Ash'ari led us in prayer.

When he sat at the end of his prayer, one of the people said: Prayer has been established by virtue and purity.

When AbuMusa returned (from his prayer or finished his prayer), he gave his attention to the people, and said: Which of you is the speaker of such and such words? The people remained silent. Which of you is the speaker of such and such words? The people remained silent. He said: You might have said them, Hittan. He replied: I did not say them. I was afraid you might punish me. One of the people said: I said them and I did not intend by them (anything) except good.

AbuMusa said: Do you not know how you utter (them) in your prayer? The Apostle of Allah (peace_be_upon_him) addressed us, and taught us and explained to us our way of doing and taught us our prayer.

He said: When you pray a (congregational) prayer, straighten your rows, then one of you should lead you in prayer. When he says the takbir (Allah is Most Great), say the takbir, and when he recites verses "Not of those upon whom is Thy anger, nor of those who err" (i.e. the end of Surah i.), say Amin; Allah will favour you. When he says "Allah is most great," and bows, say "Allah is most great" and bow, for the imam will bow before you, and will raise (his head) before you.

The Apostle of Allah (peace_be_upon_him) said: This is for that. When he says "Allah listens to the one who praises Him," say: "O Allah, our Lord, to Thee be praise, Allah be praised," Allah will listen to you, for Allah, the Exalted, said by the tongue of His Prophet (peace_be_upon_him): "Allah listens to the one who praises Him." When he says "Allah is most great" and prostrates, say: "Allah is most great" and prostrate, for the imam prostrates before you and raises his head before you.

The Apostle of Allah (peace_be_upon_him) said: This is for that. When he sits, each one of you should say "The adorations of the tongue, all good things, and acts of worship are due to Allah. Peace be upon you, O Prophet, and Allah's mercy and His blessings. Peace be upon us and upon Allah's upright servants. I testify that there is no god but Allah, and I testify that Muhammad is His servant and Apostle."


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.970]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 970

Narrated Samurah ibn Jundub:

The Apostle of Allah (peace_be_upon_him) commanded us (to recite) when we sit in the middle of the prayer or at its end before the salutation: The adorations of the tongue, all good things, acts of worship, and the Kingdom are due to Allah. Then give salutation to the right side; then salute your reciter (i.e. the imam) and yourselves.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.979]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 979

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) used to say after the tashahhud: "O Allah, I seek refuge in Thee from the punishment in Hell, and I seek refuge in Thee from the punishment in the grave, and I seek refuge in Thee from the trial of antichrist, and I seek refuge in Thee from the trial of life and death."


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.980]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 980

Narrated Mihjan ibn al-Adra':

The Apostle of Allah (peace_be_upon_him) entered the mosque and saw a man who had finished his prayer, and was reciting the tashahhud saying: O Allah, I ask you, O Allah, the One, the eternally besought of all, He begetteth not, nor was He begotten, and there is none comparable unto Him, that you may forgive me my sins, you are Most Forgiving, Merciful.

He (the Prophet) said: He was forgiven (repeating three times.)


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.981]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 981

Narrated Abdullah ibn Mas'ud:

It pertains to the sunnah to utter the tashahhud quietly.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.984]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 984

Narrated Abdullah ibn az-Zubayr:

The Prophet (peace_be_upon_him) used to point with his finger (at the end of the tashahhud) and he would not move it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.986]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 986

Narrated AbuMalik Numayr al-Khuza'i:

I saw the Prophet (peace be upon him placing his right hand on his right thigh and raising his forefinger curving it a little.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.987]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 987

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) prohibited, according to the version of Ahmad ibn Hanbal, that a person should sit during prayer while he is leaning on his hand.

According to the version of Ibn Shibwayh, he prohibited that a man should lean on his hand during prayer.

According to the version of Ibn Rafi', he prohibited that a man should pray while he is leaning on his hand, and he mentioned this tradition in the chapter on "Raising the head after prostration."

According to the version of Ibn AbdulMalik, he prohibited that a man should lean on his hand when he stands up after prostration.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.990]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 990

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) was in the first two rak'ahs as though he were on heated stones.

The narrator Shu'bah said: We said: Till he (the Prophet) got up.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.991]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 991

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) used to give the salutation to his left and right sides until the whiteness of his cheek was seen, (saying: "Peace be upon you, and mercy of Allah" twice.

AbuDawud said: This is a version of the tradition reported by AbuSufyan. The version of Isra'il did not explain it. AbuDawud said: This tradition has been narrated by Zubayr from AbuIshaq and Yahya ibn Adam from Isra'il from AbuIshaq from AbdurRahman ibn al-Aswad from his father from Alqamah on the authority of Abdullah ibn Mas'ud. AbuDawud said: Shu'bah used to reject this tradition, the tradition narrated by AbuIshaq as coming from the Prophet (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.992]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 992

Narrated Wa'il ibn Hujr:

I offered prayer along with the Prophet (peace_be_upon_him). He would give the salutation to his right side (saying): Peace be upon you and mercy of Allah; and to his left side (saying): Peace be upon you and mercy of Allah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.996]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 996

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) commanded us to respond to the salutation of the imam. and to love each other, and to salute each other.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.999]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 999

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Shortening the salutation is sunnah (commendable).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1001]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1001

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Cannot any one of you (according to the version of the narrator AbdulWarith) step forward or backward or at his right or left. The version of Hammad added: during prayer; that is, in supererogatory prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1002]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1002

Narrated Al-Azraq ibn Qays:

An imam of ours, whose kunyah (surname) was AbuRimthah, led us in prayer and said: I prayed this prayer, or one like it, with the Prophet (peace_be_upon_him). AbuBakr and Umar were standing in the front row on his right and there was a man who had been present at the first takbir in the prayer. The Prophet of Allah (peace_be_upon_him) offered the prayer, then gave the salutation to his right and his left so that we saw the whiteness of his cheeks, then turned away as AbuRimthah (meaning himself) had done.

The man who has been present with him at the first takbir in the prayer then got up to pray another prayer, whereupon Umar leaped up and, seizing him by the shoulders, shook him and said: Sit down, for the People of the Book perished for no other reason than that there was no interval between their prayers.

The Prophet (peace_be_upon_him) raised his eyes and said: Allah has made you say what is right, son of al-Khattab.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1010]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1010

Narrated AbuHurayrah:

When the Prophet (peace_be_upon_him) finished two rak'ahs of an obligatory prayer, a man asked him: Apostle of Allah, has the prayer been shortened, or have you forgotten? he replied: I did not do all that. The people said: Apostle of Allah, you did that. Therefore, he offered another two rak'ahs or prayer and did not make two prostrations due to forgetfulness.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1015]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1015

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) offered prayer. The version of the narrator Ibrahim goes: I do not know whether he increased or decreased (the rak'ahs of prayer).

When he gave the salutation, he was asked: Has something new happened in the prayer, Apostle of Allah? He said: What is it? They said: You prayed so many and so many (rak'ahs). He then relented his foot and faced the Qiblah and made two prostrations. He then gave the salutation. When he turned away (finished the prayer), he turned his face to us and said: Had anything new happened in prayer, I would have informed you. I am only a human being and I forget just as you do; so when I forget, remind me, and when any of you is in doubt about his prayer he should aim at what is correct, and complete his prayer in that respect, then give the salutation and afterwards made two prostrations.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1018]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1018

Narrated Mu'awiyah ibn Khudayj:

One day the Apostle of Allah (peace_be_upon_him) prayed and gave the salutation while a rak'ah of the prayer remained to be offered. A man went to him and said: You forgot to offer one rak'ah of prayer. Then he returned and entered the mosque and ordered Bilal (to utter the Iqamah). He uttered the Iqamah for prayer. He then led the people in one rak'ah of prayer. I stated it to the people. They asked me: Do you know who he was? I said: No, but I can recognise him if I see him. Then the man passed by me, I said: It is he. The people said: This is Talhah ibn Ubaydullah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1020]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1020

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) named the two prostrations of forgetfulness disgraceful for the devil.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1021]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1021

Narrated Ata' ibn Yasar:

The Prophet (peace_be_upon_him) said: When one of you is in doubt about his prayer, and does not know how much he has prayed, three or four rak'ahs, he should pray one (additional) rak'ah and make two prostrations while sitting before giving the salutation. If the (additional) rak'ah which he prayed is the fifth one, he will make it an even number by these two prostrations. If it is the fourth one, the two prostrations will be a disgrace for the devil.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1022]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1022

Narrated Ata' ibn Yasar:

The Prophet (peace_be_upon_him) said: If one of you is in doubt about his prayer, and if he is sure that he has prayed three rak'ahs, he should stand and complete one rak'ah along with its prostrations. Then he should sit and recite the tashahhud. When he finishes the prayer, and there remains nothing except salutation, he should make two prostrations while he is sitting and afterwards should give the salutation.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1023]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1023

Narrated Abdullah ibn Mas'ud:

AbuUbaydah reported, on the authority of his father Abdullah (ibn Mas'ud), the Apostle of Allah (peace_be_upon_him) as saying: When you offer the prayer, and you are in doubt about the number of rak'ahs whether offered three or four, and you have prayed four rak'ahs in all probability in your opinion, you should recite tashahhud and make two prostrations while you are sitting before giving the salutation. afterwards you should recite the tashahhud and give the salutation again.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1024]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1024

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: When one of you prays, and he does not know whether he prayed more or less rak'ahs (than those prescribed by the Shari'ah), he should perform two prostrations while he is sitting. If the devil comes to him, and tells him (suggests him): "You have been defiled," he should say: "You have told a lie," except that he feels smell with his nose, or sound with his ears (then his ablution will break). These are the wording; of the tradition reported by Aban.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1028]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1028

Narrated Abdullah ibn Ja'far:

The Prophet (peace_be_upon_him) said: Anyone who is in doubt in his prayer should make two prostrations after giving the salutation.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1029]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1029

Narrated Abdullah ibn Buhaynah:

The Apostle of Allah (peace_be_upon_him) led us in prayer praying two rak'ahs. When he stood up and did not sit (at the end of two rak'ahs) the people stood up along with him. When he finished the prayer and we expect him to give the salutation, he said: "Allah is most great." While sitting and made two prostrations before giving the salutation. Then he gave it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1031]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1031

Narrated Al-Mughirah ibn Shu'bah:

The Prophet (peace_be_upon_him) said: When an imam stands up at the end of two rak'ahs , if he remembers before standing straight up, he should sit down, but if he stands straight up, he must not sit down, but perform the two prostrations of forgetfulness.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1032]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1032

Narrated Al-Mughirah ibn Shu'bah:

Ziyad ibn Ilaqah said: Al-Mughirah ibn Shu'bah led us in prayer and he stood up at the end of two rak'ahs. We said: Glory be to Allah; he also said: Glory be to Allah, and he proceeded. When he finished the prayer and gave the salutation, he made two prostrations of forgetfulness. When he turned (to us) he said: I saw the Apostle of Allah (peace_be_upon_him) doing so as I did.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1033]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1033

Narrated Thawban:

The Prophet (peace_be_upon_him) said: For each forgetfulness there are two prostrations after giving the salutation.

No one except Amr (ibn Uthman) mentioned the words "from his father" (in the chain AbdurRahman ibn Jubayr ibn Nufayr from Thawban).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1034]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1034

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) led them in prayer and forgot something, so he made prostrations and uttered the tashahhud, then gave the salutation.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1036]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1036

Narrated Hulb (Yazid) at-Ta'i:

Hulb prayed along with the Prophet (peace_be_upon_him). He used to turn to both his sides (sometimes to the left and sometimes to the right).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1039]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1039

Narrated Zayd ibn Thabit:

The Prophet (peace_be_upon_him) said: The prayer a man offers in his house is more excellent than his prayer in this mosque of mine except obligatory prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1041]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1041

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: The best day on which the sun has risen is Friday; on it Adam was created, on it he was expelled (from Paradise), on it his contrition was accepted, on it he died, and on it the Last Hour will take place. On Friday every beast is on the lookout from dawn to sunrise in fear of the Last Hour, but not jinn and men, and it contains a time at which no Muslim prays and asks anything from Allah but He will give it to him. Ka'b said: That is one day every year. So I said: It is on every Friday. Ka'b read the Torah and said: The Apostle of Allah (peace_be_upon_him) has spoken the truth. AbuHurayrah said: I met Abdullah ibn Salam and told him of my meeting with Ka'b. Abdullah ibn Salam said: I know what time it is. AbuHurayrah said: I asked him to tell me about it. Abdullah ibn Salam said: It is at the very end of Friday. I asked: How can it be when the Apostle of Allah (peace_be_upon_him) has said: "No Muslim finds it while he is praying...." and this is the moment when no prayer is offered. Abdullah ibn Salam said: Has the Apostle of Allah (peace_be_upon_him) not said: "If anyone is seated waiting for the prayer, he is engaged in the prayer until he observes it." I said: Yes, it is so.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1042]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1042

Narrated Aws ibn Aws:

The Prophet (peace_be_upon_him) said: Among the most excellent of your days is Friday; on it Adam was created, on it he died, on it the last trumpet will be blown, and on it the shout will be made, so invoke more blessings on me that day, for your blessings will be submitted to me. The people asked: Apostle of Allah, how can it be that our blessings will be submitted to you while your body is decayed? He replied: Allah, the Exalted, has prohibited the earth from consuming the bodies of Prophets.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1043]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1043

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Friday is divided into twelve hours. Amongst them there is an hour in which a Muslim does not ask Allah for anything but He gives it to him. So seek it in the last hour after the afternoon prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1046]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1046

Narrated Ali ibn AbuTalib:

Ali said on the pulpit in the mosque of Kufah: When Friday comes, the devils go to the markets with their flags, and involve people in their needs and prevent them from the Friday prayer. The angels come early in the morning, sit at the door of the mosque, and record that so-and-so came at the first hour, and so-and-so came at the second hour until the imam comes out (for preaching).

When a man sits in a place where he can listen (to the sermon) and look (at the imam), where he remains silent and does not interrupt, he will receive a double reward. If he stays away, sits in a place where he cannot listen (to the sermon), silent, and does not interrupt, he will receive the reward only once. If he sits in a place where he can listen (to the sermon) and look (at the imam), and he does not remain silent, he will have the burden of it. If anyone says to his companion sitting besides him to be silent (while the imam is preaching), he is guilty of idle talk. Anyone who interrupts (during the sermon) will receive nothing (no reward) on that Friday.

Then he (the narrator) says in the end of this tradition: I heard the Apostle of Allah (peace_be_upon_him) say so.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1047]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1047

Narrated Al-Ja'd ad-Damri:

The Prophet (peace_be_upon_him) said: He who leaves the Friday prayer (continuously) for three Friday on account of slackness, Allah will print a stamp on his heart.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1048]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1048

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: If anyone omits the Friday prayer without excuse, he must give a dinar in alms, or if he does not have as much, then half a dinar.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1049]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1049

Narrated Qudamah ibn Wabirah:

The Prophet (peace_be_upon_him) said: If anyone omits the Friday prayer without excuse, he must give one dirham or half a dirham, or one sa' or half a sa' of wheat, in alms.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1051]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1051

Narrated Abdullah ibn Amr:

The Prophet (peace_be_upon_him) said: The Friday prayer is obligatory on him who hears the call.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1052]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1052

Narrated Usamah ibn Umayr al-Huzali:

The rain was falling on the day when the Battle of Hunayn took place. The Prophet (peace_be_upon_him), therefore, commanded that the people should offer their prayer in their camps.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1054]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1054

Narrated Usamah ibn Umayr al-Huzali:

Usamah attended the Prophet (peace_be_upon_him) on the occasion of the treaty of al-Hudaybiyyah on Friday. The rain fell as little as the soles of the shoes of the people were not set. He (the Prophet) commanded them to offer Friday prayer in their dwellings.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1056]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1056

Narrated Abdullah ibn Umar:

Nafi' reported: Ibn Umar made the call to prayer at Dajnan (a place between Mecca and Medina). Then he announced: "Offer prayer in your dwellings:" He then narrated a tradition from the Apostle of Allah (peace_be_upon_him). He used to command an announcer who made the call to prayer. He then announced: "Pray in your dwellings" on a cold or rainy night during journey.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1057]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1057

Narrated Abdullah ibn Umar:

Nafi' said: Ibn Umar made the call to prayer at Dajnan (a place between Mecca and Medina), on a cold and windy night. He added the words at the end of the call: "Lo! pray in your dwellings. Lo! pray in the dwellings." He then said: The Apostle of Allah (peace_be_upon_him) used to command the mu'adhdhin to announce, "Lo! pray in your dwellings." on a cold or rainy night during journey.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1062]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1062

Narrated Tariq ibn Shihab:

The Prophet (peace_be_upon_him) said: The Friday prayer in congregation is a necessary duty for every Muslim, with four exceptions; a slave, a woman, a boy, and a sick person.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1064]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1064

Narrated Ka'b ibn Malik:

AbdurRahman ibn Ka'b ibn Malik said: When Ka'b ibn Malik heard the call to prayer on Friday, he prayed for As'ad ibn Zurarah. I asked him: What is the matter that when you hear the call to prayer, you pray for As'ad ibn Zurarah? He replied: This is because he held the Friday prayer for the first time for us at Hazm an-Nabit of Harrah belonging to Banu Bayadah in Naqi', called Naqi' al-Khadumat.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1065]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1065

Narrated Zayd ibn Arqam:

Ilyas ibn AbuRamlah ash-Shami said: I witnessed Mu'awiyah ibn AbuSufyan asking Zayd ibn Arqam: Did you offer along with the Apostle of Allah (peace_be_upon_him) the Friday and 'Id prayers synchronised on the same day? He said: Yes. He asked: How did he do? He replied: He offered the 'Id prayer, then granted concession to offer the Friday prayer, and said: If anyone wants to offer it, he may offer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1066]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1066

Narrated Abdullah ibn Abbas:

Ata' ibn AbuRabah said: Ibn az-Zubayr led us in the 'Id prayer on Friday early in the morning. When we went to offer the Friday, he did not come out to us. So we prayed ourselves alone. At that time Ibn Abbas was present in at-Ta'if. When he came to us, we mentioned this (incident) to him. He said: He followed the sunnah.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1068]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1068

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Two festivals ('Id and Friday) have synchronised on this day. If anyone does not want to offer the Friday prayer, the 'Id prayer is sufficient for him. But we shall offer the Friday prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1073]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1073

Narrated Muhammad ibn Yahya ibn Habban:

The Apostle of Allah (peace_be_upon_him) said: What is the harm if any of you has two garments, if he can provide them, for Friday (prayer) in addition to the two garments for his daily work? Amr reported from Ibn Habib from Musa ibn Sa'd from Ibn Habban from Ibn Salam who heard this (tradition) from the Apostle of Allah (peace_be_upon_him) on the pulpit.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1074]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1074

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) prohibited buying and selling in the mosque, announcing aloud about a lost thing, the recitation of a poem in it, and prohibited sitting in a circle (in the mosque) on Friday before the prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1078]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1078

Narrated AbuQatadah:

The Prophet (peace_be_upon_him) disapproved of the offering of prayer at the meridian except on Friday. The Hell-fire is kindled except on Friday.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1091]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1091

Narrated al-Hakam ibn Hazn al-Kulafi:

Shu'ayb ibn Zurayq at-Ta'ifi said: I sat with a man who had been in the company of the Apostle of Allah (peace_be_upon_him). He was called al-Hakam ibn Hazn al-Kulafi. He began to narrate a tradition to us saying: I came to the Apostle of Allah (peace_be_upon_him) in a delegation consisting of seven or nine persons. We entered upon him and said: Apostle of Allah, we have visited you, so pray Allah what is good for us. He ordered to give us some dates. The Muslims in those days were weak. We stayed there for several days and offered the Friday prayer along with the Apostle of Allah (peace_be_upon_him). He stood leaning on a staff or a bow. He praised Allah and exalted Him in light, pure and blessed words. Then he said: O people, you have no power to obey or you cannot obey what you are ordered. But be straight and give good tidings.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1092]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1092

Narrated Abdullah ibn Mas'ud:

When the Apostle of Allah (peace_be_upon_him) addressed, he would say: Praise be to Allah, from Whom we seek help and pardon,and we seek refuge in Allah from the evils of our souls. He whom Allah guide has no one who can lead him astray, and he whom He leads astray has no one to guide him. And I bear witness that there is no god but Allah, and I bear witness that Muhammad is His servant and apostle. He sent him before the coming of the last hour with truth giving good tidings and warning. He who obeys Allah and His Apostle follows the right path; and he who disobeys them shall harm none except himself, and he will not harm Allah in the least.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1093]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1093

Narrated Ibn Shihab:

Yunus asked Ibn Shihab about the address of the Apostle of Allah (peace_be_upon_him) on Friday. He mentioned it in like manner. He added: Anyone who disobeys them (Allah and His Apostle) goes astray. We beseech Allah, our Lord, to make us from those who obey Him and obey His Apostle, and follow what He likes, and abstain from His anger; we are due to Him and we belong to Him.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1100]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1100

Narrated Sahl ibn Sa'd:

I never saw the Apostle of Allah (peace_be_upon_him) raising his hands and praying on the pulpit or otherwise. But I saw him saying (doing) this way, and he would point with his forefinger making a circle by joining the middle finger with his thumb.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1101]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1101

Narrated Ammar ibn Yasir:

The Apostle of Allah (peace_be_upon_him) commanded us to shorten the speeches.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1102]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1102

Narrated Jabir ibn Samurah as-Suwa'i:

The Apostle of Allah (peace_be_upon_him) would not lengthen the sermon on Friday. He would say a few words.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1103]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1103

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: Attend the sermon (on Friday) and sit near the imam, for a man keeps himself away until he will be left behind at the time of entering Paradise though he enters it.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1104]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1104

Narrated Buraydah ibn al-Hasib:

The Apostle of Allah (peace_be_upon_him) delivered a speech to us; meanwhile al-Hasan and al-Husayn came upon there stumbling, wearing red shirts. He came down from the pulpit, took them and ascended it with them. He then said: Allah truly said: "Your property and your children are only trial" (Ixiv.15). I saw both of them, and I could not wait. Afterwards he resumed the speech.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1105]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1105

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) prohibited to sit on hips by erecting feet, sticking them to the stomach and holding them with hands on Friday while the imam is delivering the sermon.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1108]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1108

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Three types of people attend Friday prayer; One is present in a frivolous way and that is all he gets from it; another comes with a supplication, Allah may grant or refuse his request as He wishes; another is present silently and quietly with-out stepping over a Muslim or annoying anyone, and that is an atonement for his sins till the next Friday and three days more, the reason being that Allah, the Exalted, says: "He who does a good deed will have ten times as much" (vi.160).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1109]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1109

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: When one of you becomes defiled during prayer, he should hold his nose and then turn away.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1114]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1114

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: When any of you dozes in the mosque (on Friday), he should change his place.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1115]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1115

Narrated Anas ibn Malik:

I saw the Apostle (peace_be_upon_him) would descend from the pulpit and a man stop him for his need. He would remain standing with him until his need was fulfilled. Then he would stand and pray.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1120]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1120

Narrated Samurah ibn Jundub:

The Apostle of Allah (peace_be_upon_him) used to recite in the Friday prayer: "Glorify the name of your most high Lord" (Surah 87) and Has the story of the overwhelming event reached you? (Surah 88).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1123]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1123

Narrated Abdullah ibn Umar:

Nafi' said: Ibn Umar used to lengthen his prayer before the Friday prayer and would offer two rak'ahs after it in his house. He used to say that the Apostle of Allah (peace_be_upon_him) would do that.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1127]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1127

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) used to pray two rak'ahs in his house after the Friday prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1128]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1128

Narrated Abdullah ibn Umar:

Ibn Jurayj said: Ata' told me that he saw Ibn Umar pray after the Friday prayer. He moved a little from the place where he offered the Friday prayer. Then he would pray two rak'ahs. He then walked far away from that place and would offer four rak'ahs. I asked Ata': How many times did you see Ibn Umar do that? He replied: Many times. AbuDawud said: This has been narrated by AbdulMalik ibn AbuSulayman, but did not narrate it completely.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1130]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1130

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) came to Medina, the people had two days on which they engaged in games. He asked: What are these two days (what is the significance)? They said: We used to engage ourselves on them in the pre-Islamic period. The Apostle of Allah (peace_be_upon_him) said: Allah has substituted for them something better than them, the day of sacrifice and the day of the breaking of the fast.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1131]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1131

Narrated Abdullah ibn Busr:

Yazid ibn Khumayr ar-Rahbi said: Abdullah ibn Busr, the Companion of the Apostle of Allah (peace_be_upon_him) came out along with the people on the day of the breaking of the fast or on the day of sacrifice (to offer the prayer). He disliked the delay of the imam, and said: We would finish (our 'Id prayer) at this moment, that is, at the time of forenoon.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1137]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1137

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) stood on the day of the breaking of the fast ('Id) and offered prayer. He began the prayer before the sermon. He then addressed the people. When the Prophet (peace_be_upon_him) finished the sermon, he descended (from the pulpit) and went to women. He gave them an exhortation while he was leaning on the hand of Bilal. Bilal was spreading his garment in which women were putting alms; some women put their rings and others other things.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1138]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1138

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) came out on 'Id (the festival day). He first offered the prayer and then delivered the sermon . He then went to women, taking Bilal with him. The narrator Ibn Kathir said: The probable opinion of Shu'bah is that he commanded them to give alms. So they began to put (their jewellery).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1143]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1143

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) offered the 'Id prayer without the adhan and the iqamah. AbuBakr and Umar or Uthman also did so. The narrator Yahya is doubtful about Uthman.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1145]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1145

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) would say the takbir (Allah is most great) seven times in the first rak'ah and five times in the second rak'ah on the day of the breaking of the fast and on the day of sacrifice (on the occasion of both the 'Id prayers, the two festivals).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1148]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1148

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) used to say on the day of the breaking of the fast seven takbirs in the first rak'ah and then recite the Qur'an, and utter the takbir (Allah is most great). Then he would stand, and utter the takbir four times. Thereafter he would recite the Qur'an and bow.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1151]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1151

Narrated Abdullah ibn as-Sa'ib:

I attended the 'Id prayer along with the Apostle of Allah (peace_be_upon_him). When he finished the prayer, he said: We shall deliver the sermon; he who likes to sit for listening to it may sit and he who likes to go away may go away.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1152]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1152

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) went out by one road on the day of the 'Id (festival) and returned by another.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1153]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1153

Narrated AbuUmayr ibn Anas:

AbuUmayr reported on the authority of some of his paternal uncles who were Companions of the Prophet (peace_be_upon_him): Some men came riding to the Prophet (peace_be_upon_him) and testified that they had sighted the new moon the previous day. He (the Holy Prophet), therefore, commanded the people to break the fast and to go out to their place of prayer in the morning.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1154]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1154

Narrated Bakr ibn Mubashshir al-Ansari:

I used to go to the place of prayer on the day of the breaking of the fast, and on the day of sacrifice along with the Companions of the Apostle of Allah (peace_be_upon_him). We would walk through a valley known as Batn Bathan till we came to the place of prayer. Then we would pray along with the Apostle of Allah (peace_be_upon_him) and return through Batn Bathan to our house.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1156]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1156

Narrated AbuHurayrah:

The rain fell on the day of 'Id (festival) , so the Prophet (peace_be_upon_him) led them (the people) in the 'Id prayer in the mosque.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1163]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1163

Narrated Abdullah ibn Abbas:

Ishaq ibn Abdullah ibn Kinanah reported: Al-Walid ibn Utbah or (according to the version of Uthman) al-Walid ibn Uqbah, the then governor of Medina, sent me to Ibn Abbas to ask him about the prayer for rain offered by the Apostle of Allah (peace_be_upon_him). He said: The Apostle of Allah (peace_be_upon_him) went out wearing old clothes in a humble and lowly manner until he reached the place of prayer. He then ascended the pulpit, but he did not deliver the sermon as you deliver (usually). He remained engaged in making supplication, showing humbleness (to Allah) and uttering the takbir (Allah is most great). He then offered two rak'ahs of prayer as done on the 'Id (festival).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1164]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1164

Narrated Umayr, the client of AbulLahm:

Umayr saw the Prophet (peace_be_upon_him) praying for rain at Ahjar az-Zayt near az-Zawra', standing, making supplication, praying for rain and raising his hands in front of his face, but not lifting them above his head.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1165]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1165

Narrated Jabir ibn Abdullah:

The people came to the Prophet (peace_be_upon_him) weeping (due to drought). He said (making supplication): O Allah! give us rain which will replenish us, abundant, fertilising and profitable, not injurious, granting it now without delay. He (the narrator) said: Thereupon the sky became overcast.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1169]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1169

Narrated Aisha, Ummul Mu'minin:

The people complained to the Apostle of Allah (peace_be_upon_him) of the lack of rain, so he gave an order for a pulpit. It was then set up for him in the place of prayer. He fixed a day for the people on which they should come out.

Aisha said: The Apostle of Allah (peace_be_upon_him), when the rim of the sun appeared, sat down on the pulpit, and having pronounced the greatness of Allah and expressed His praise, he said: You have complained of drought in your homes, and of the delay in receiving rain at the beginning of its season. Allah has ordered you to supplicate Him has and promised that He will answer your prayer.

Then he said: Praise be to Allah, the Lord of the Universe, the Compassionate, the Merciful, the Master of the Day of Judgment. There is no god but Allah Who does what He wishes. O Allah, Thou art Allah, there is no deity but Thou, the Rich, while we are the poor. Send down the rain upon us and make what Thou sendest down a strength and satisfaction for a time.

He then raised his hands, and kept raising them till the whiteness under his armpits was visible. He then turned his back to the people and inverted or turned round his cloak while keeping his hands aloft. He then faced the people, descended and prayed two rak'ahs.

Allah then produced a cloud, and the storm of thunder and lightning came on. Then the rain fell by Allah's permission, and before he reached his mosque streams were flowing. When he saw the speed with which the people were seeking shelter, he (peace_be_upon_him) laughed till his back teeth were visible.

Then he said: I testify that Allah is Omnipotent and that I am Allah's servant and apostle.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1170]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1170

Narrated Anas ibn Malik:

The people of Medina had a drought during the time of the Prophet (peace_be_upon_him).

While he was preaching on a Friday, a man stood up and said: Apostle of Allah, the horses have perished, the goats have perished, pray to Allah to give us water. He spread his hands and prayed.

Anas said: The sky was like a mirror (there was no cloud). Then the wind rose; a cloud appeared (in the sky) and it spread : the sky poured down the water. We came out (from the mosque after the prayer) passing through the water till we reached our homes. The rain continued till the following Friday. The same or some other person stood up and said: Apostle of Allah, the houses have been demolished, pray to Allah to stop it.

The Apostle of Allah (peace_be_upon_him) smiled and said: (O Allah), the rain may fall around us but not upon us. Then I looked at the cloud which dispersed around Medina just like a crown.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1172]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1172

Narrated Abdullah ibn Amr ibn al-'As:

When the Apostle of Allah (peace_be_upon_him) prayed for rain, he said: O Allah! Provide water for Thy servants and Thy cattle, display Thy mercy and give life to Thy dead land.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1180]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1180

Narrated Samurah ibn Jundub:

When, a boy from the Ansar and I were shooting (arrows) towards two of our targets, the sun was sighted by the people at the height of two or three lances above the horizon. It became black like the black herb called tannumah.

One of us said to his companion: Let us go to the mosque; by Allah, this incident of the sun will surely bring something new in the community of the Apostle of Allah (peace_be_upon_him).

As we reached it, we suddenly saw that he (the Prophet) had already come out (of his house). He stepped forward for a long time as much as he could do so in the prayer. But we did not hear his voice. He then performed a bowing and prolonged it as much as he could do in the prayer. But we did not hear his voice. He then prostrated himself with us and prolonged it which he never did in the prayer before. But we did not hear his voice. He then did similarly in the second rak'ah. The sun became bright when he sat after the second rak'ah. Then he uttered the salutation. He then stood up, praised Allah, and extolled Him, and testified that there was no god but Allah and testified that he was His servant and apostle. Ahmad ibn Yunus then narrated the address of the Prophet (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1181]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1181

Narrated Qabisah al-Hilali:

There was an eclipse of the sun in the time of the Apostle of Allah (peace_be_upon_him). He came out bewildered pulling his garment, and I was in his company at Medina. He prayed two rak'ahs and stood for a long time in them. He then departed and the sun became bright. He then said: There are the signs by means of which Allah, the Exalted, produces dread (in His servants). When you see anything of this nature, then pray as you are praying a fresh obligatory prayer.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1189]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1189

Narrated An-Nu'man ibn Bashir:

There was an eclipse of the sun in the time of the Prophet (peace_be_upon_him). He began to pray a series of pairs of rak'ahs enquiring about the sun (at the end of them) till it became clear.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1190]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1190

Narrated Abdullah ibn Amr ibn al-'As:

There was an eclipse of the sun in the time of the Apostle of Allah (peace_be_upon_him). The Apostle of Allah (peace_be_upon_him) stood up and he was not going to perform bowing till he bowed; and he was not going to raise his head till he raised (after bowing); and he was not going to prostrate himself till he prostrated himself; and he was not going to raise his head till he raised (at the end of prostration); he did similarly in the second rak'ah, he then puffed in the last prostration saying; Fie, Fie! He then said: My Lord, didst Thou not promise me that Thou wouldst not punish them so long as I will remain among them? Didst Thou not promise me that Thou will not punish them so long as they continue to beg pardon of Thee. The Apostle of Allah (peace_be_upon_him) finished the prayer, and the sun was clear. The narrator then narrated the tradition (in full).


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1192]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1192

Narrated Anas ibn Malik:

Ubaydullah ibn an-Nadr reported on the authority of his father: Darkness prevailed in the time of Anas ibn Malik, I came to Anas and said (to him): AbuHamzah, did anything like this happen to you in the time of the Apostle of Allah (peace_be_upon_him)? He replied: Take refuge in Allah. If the wind blew violently, we would run quickly towards the mosque for fear of the coming of the Day of Judgment.


Dawud :: Prayer (Kitab Al-Salat): Details of Commencing Prayer :: [3.1193]

Prayer (Kitab Al-Salat): Details of Commencing Prayer

Dawud :: Book 3 : Hadith 1193

Narrated Ibn Abbas:

Ikrimah said: Ibn Abbas was informed that so-and-so, a certain wife of the Prophet (peace_be_upon_him), had died. He fell down prostrating himself. He was questioned: Why do you prostrate yourself this moment? He said: The Apostle of Allah (peace_be_upon_him) said: When you see a portent (an accident), prostrate yourselves. And which portent (accident) can be greater than the death of a wife of the Prophet (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1194]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1194

Narrated Aisha, Ummul Mu'minin:

The prayer was prescribed as consisting of two rak'ahs both when one was resident and when travelling. The prayer while travelling was left according to the original prescription and the prayer of one who was resident was enhanced.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1199]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1199

Narrated Uqbah ibn Amir:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah is pleased with a shepherd of goats who calls to prayer at the peak of a mountain, and offers prayer, Allah, the Exalted, says: Look at this servant of Mine; he calls to prayer and offers it and he fears Me. So I forgive him and admit him to paradise.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1201]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1201

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) halted at a certain place (while on a journey), he would not leave that place till he offered the noon prayer. A man said to him: Even if in the middle of the day? He replied: Even if in the middle of the day.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1203]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1203

Narrated Abdullah ibn Umar:

Ibn Umar was informed about the death of Safiyyah (the wife of the Prophet) when he was at Mecca. He proceeded till the sun set and the stars shined. He said: When the Prophet (peace_be_upon_him) was in a hurry about something while on a journey, he would combine both these prayers. He proceed till twilight had disappeared. He then combined both of them (the prayers).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1204]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1204

Narrated Mu'adh ibn Jabal:

On the expedition to Tabuk if the sun had passed the meridian before the apostle of Allah (peace_be_upon_him) moved off, he combined the noon and the afternoon prayers; but if he moved off before the sun had passed the meridian, he delayed the noon prayer till he halted for the afternoon prayer. He acted similarly for the sunset prayer; if the sun set before he moved off, he combined the sunset and the night prayers, but if he moved off before sunset, he delayed the sunset prayer till he halted for the night prayer and then combined them.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1208]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1208

Narrated Abdullah ibn Umar:

Abdullah ibn Waqid said: The mu'adhdhin of Ibn Umar said: prayer (i.e. the time of prayer has come). He said: Go ahead. He then alighted before the disappearance. He then offered the night prayer. He then said: When the Apostle of Allah (peace_be_upon_him) was in a hurry about something, he would do as I did. Then he travelled and covered a distance of three days' journey on the day.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1211]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1211

Narrated Jabir ibn Abdullah:

When the sun set at Mecca, the Apostle of Allah (peace_be_upon_him) combined the two prayers at Sarif.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1213]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1213

Narrated Abdullah ibn Umar:

Abdullah ibn Dinar said: The sun set when I was with Abdullah ibn Umar. We proceeded, and when we saw that the evening came, we said prayer. He went on travelling until the twilight disappeared and the stars became thick. He then slighted and combined the two prayers. Then he said: I saw the Apostle of Allah (peace_be_upon_him); when he hastened his travelling, he would pray like this prayer of mine. He said: He would combine the two prayers after the passing of a part of night. AbuDawud said: This has been transmitted by Asim ibn Muhammad from his brother on the authority of Salim and this has also been narrated by Ibn AbuNajih from Isma'il ibn AbdurRahman ibn Dhuwayb saying that Ibn Umar would combine the two prayers after the disappearance of twilight.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1216]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1216

Narrated Mu'adh ibn Jabal:

The Prophet (peace_be_upon_him) was engaged in the Battle of Tabuk. If he moved off before the sun had declined, he would delay the noon prayer till he would combine it with the afternoon prayer and would offer them together. If he moved off after the sun had declined, he would combine the noon and afternoon prayers, and then he proceeded; if he moved off before the evening prayer, he would delay the evening prayer; he would offer it along with the night prayer, he would delay the evening prayer; he would offer it along with the night prayer. If he moved off after the evening prayer, he would offer the night prayer earlier and offer it along with the evening prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1218]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1218

Narrated Al-Bara' ibn Azib:

I accompanied the Apostle of Allah (peace_be_upon_him) on eighteen journeys and I never saw him fail to pray two rak'ahs when the sun had passed the meridian before offering the noon prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1221]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1221

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) was on a journey and wished to say voluntary prayer, he made his she-camel face the qiblah and uttered the takbir (Allah is most great), then prayed in whatever direction his mount made his face.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1223]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1223

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) sent me on some business, and when I came to him he was praying on (the back of) his riding beast (moving) towards the east and making the prostration lower than the bowing.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1224]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1224

Narrated Aisha, Ummul Mu'minin:

Ata' ibn AbuRabah asked Aisha: Can women offer prayer on a riding beast? She replied: They were not permitted to do so in hardship or comfort. Muhammad ibn Shu'ayb said: This (prohibition) applies to the obligatory prayers.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1225]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1225

Narrated Imran ibn Husayn:

I went on an expedition with the Apostle of Allah (peace_be_upon_him), and I was present with him at the conquest. He stayed eighteen days in Mecca and prayed only two rak'ahs (at each time of prayer). And he said: You who live in the town must pray four; we are travellers.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1226]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1226

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) had a stop of seventeen days in Mecca and he shortened the prayer (i.e. prayed two rak'ahs at each time of prayer). Ibn Abbas said: He who stays seventeen days should shorten the prayer; and who stays more than that should offer complete prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1227]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1227

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) stayed fifteen days in Mecca in the year of Conquest. Shortening the prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1230]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1230

Narrated Ali ibn AbuTalib ; Anas ibn Malik:

Muhammad reported from his father, Umar, on the authority of his grandfather, Ali ibn AbuTalib: When Ali travelled, he continued to travel till it became nearly dark. He then alighted and offered the sunset prayer. Then he would call for his dinner and eat it. Then he prayed the night prayer and then moved off.

He would say: This is how the Apostle of Allah (peace_be_upon_him) used to do.

Usamah ibn Zayd reported from Hafs ibn Ubaydullah, the son of Anas ibn Malik: Anas would combine them (the evening and night prayer) when the twilight disappeared.

He said: The Prophet (peace_be_upon_him) used to do so. Az-Zuhri also reported similarly on the authority of Anas from the Prophet (peace_be_upon_him).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1231]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1231

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) stayed at Tabuk twenty days; he shortened the prayer (during his stay).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1232]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1232

Narrated AbuAyyash az-Zuraqi:

We accompanied the Apostle of Allah (peace_be_upon_him) at Usfan, and Khalid ibn al-Walid was the chief of unbelievers. We offered the noon prayer.

Thereupon, the unbelievers said: We suffered from negligence; we became careless. We should have attacked them while they were praying. Thereupon the verse was revealed, relating to the shortening of the prayer (in time of danger) between the noon and afternoon (prayer).

When the time of the afternoon prayer came, the Apostle of Allah (peace_be_upon_him) stood facing the qiblah, and the unbelievers were standing in front of him. The people stood in a row behind the Apostle of Allah (peace_be_upon_him) and there was another row behind this row. The Apostle of Allah (peace_be_upon_him) bowed and all of them bowed. He then prostrated and also the row near him prostrated. The other people in the second row remained standing and stood guard over them. When they performed two prostrations and stood up, those who were behind them prostrated. The people in the front row near him then stepped backward taking the place of the people in the second row and the second row took the place of the first row.

The Apostle of Allah (peace_be_upon_him) then bowed and all of them bowed together. Then he and the row near him prostrated themselves. The other people in the second row remained standing and stood guard over them. When the Apostle of Allah (peace_be_upon_him) and the row near him (i.e. the front row) were seated, the people in the second row behind them prostrated themselves. Then all of them were seated. (He (the Prophet) then uttered the salutation upon all of them. He prayed in his manner at Usfan as well as at the territory of Banu Sulaym.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1236]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1236

Narrated AbuHurayrah:

Urwah ibn az-Zubayr reported that Marwan ibn al-Hakam asked AbuHurayrah: Did you pray in time of danger with the Apostle of Allah (peace_be_upon_him)?

AbuHurayrah replied: Yes. Marwan then asked: When? AbuHurayrah said: On the occasion of the Battle of Najd. The Apostle of Allah (peace_be_upon_him) stood up to offer the afternoon prayer. One section stood with him (to pray) and the other was standing before the enemy, and their backs were towards the qiblah. The Apostle of Allah (peace_be_upon_him) uttered the takbir and all of them too uttered the takbir, i.e. those who were with him and those who were facing the enemy. Then the Apostle of Allah (peace_be_upon_him) offered one rak'ah and the section that was with him also prayed one rak'ah. He then prostrated himself and those who were with him also prostrated, while the other section was standing before the enemy.

The Apostle of Allah (peace_be_upon_him) then stood up and the section with him also stood up. They went and faced the enemy and the section that was previously facing the enemy stepped forward. They bowed and prostrated while the Apostle of Allah (peace_be_upon_him) was standing in the same position. Then they stood up and the Apostle of Allah (may peace be upon) prayed another rak'ah and all of them bowed and prostrated along with him. After that the section that was standing before the enemy came forward and they bowed and prostrated, while the Apostle of Allah (peace_be_upon_him) remained seated and also those who were with him. The salutation then followed. The Apostle of Allah (peace_be_upon_him) uttered the salutation and all of them uttered it together. The Apostle of Allah (peace_be_upon_him) prayed two rak'ahs and each of the two sections prayed one rak'ah with him (and the other by themselves).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1237]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1237

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) uttered the takbir and the section that was in the same row with him also uttered the takbir. He then bowed and they also bowed, and he prostrated and they also prostrated. Then he raised his head and they also raised (their heads). The Apostle of Allah (peace_be_upon_him) then remained seated. They prostrated alone and stood up and retraced their footsteps and stood behind them.

Then the other section came; they stood up and uttered the takbir and bowed by themselves. The Apostle of Allah (peace_be_upon_him) prostrated himself and they also prostrated with him. Then the Apostle of Allah (peace_be_upon_him) stood up and they performed the second prostration by themselves. Then both the sections stood up and prayed with the Apostle of Allah (peace_be_upon_him). He bowed and they also bowed, and then he prostrated himself and they also prostrated themselves. Then he returned and performed the second prostration and they also prostrated with him as quickly as possible, showing no slackness in quick prostration. The Apostle of Allah (peace_be_upon_him) then uttered the salutation. After that the Apostle of Allah (peace_be_upon_him) stood up. Thus everyone participated in the entire prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1239]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1239

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) led us in prayer in the time of danger. They (the people) stood in two rows. One row was behind the Apostle of Allah (peace_be_upon_him) and the other faced the enemy. The Apostle of Allah (peace_be_upon_him) led them in one rak'ah,and then the other section came and took their place; they went and faced the enemy. The Prophet (peace_be_upon_him) led them in one rak'ah and uttered the salutation. They stood up and prayed the second rak'ah by themselves and uttered the salutation and went away; they took the place of the other section facing the enemy. They came back and took their place. They prayed one rak'ah by themselves and then uttered the salutation.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1241]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1241

Narrated Hudhayfah:

Tha'labah ibn Zahdam said: We accompanied Sa'd ibn al-'As at Tabaristan. He stood and said: Which of you prayed along with the Apostle of Allah (peace_be_upon_him) in time of danger? Hudhayfah said: I then he led one section in one rak'ah and the other section in one rak'ah. They did not pray the second rak'ah by themselves.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1243]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1243

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) offered the noon prayer in time of danger. Some of the people formed a row behind him and others arrayed themselves against the enemy. He led them in two rak'ahs and then he uttered the salutation. Then those who were with him went away and took the position of their companions before the enemy. Then they came and prayed behind him. He led them in two rak'ahs and uttered the salutation. Thus the Apostle of Allah (peace_be_upon_him) offered four rak'ahs and his companions offered two rak'ahs.

Al-Hasan used to give legal verdict on the authority of this tradition.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1252]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1252

Narrated Bilal:

Ziyadah al-Kindi reported on the authority of Bilal that he (Bilal) came to the Apostle of Allah (peace_be_upon_him) to inform him about the dawn prayer. Aisha kept Bilal engaged in a matter which she asked him till the day was bright and it became fairly light. Bilal then stood up and called him to prayer and called him repeatedly. The Apostle of Allah (peace_be_upon_him) did not yet come out. When he came out, he led the people in prayer and he (Bilal) informed him that Aisha had kept him engaged in a matter which she asked him till it became fairly light; hence he became late in reaching him (in time). He (Bilal) said: Apostle of Allah, the dawn became fairly bright. He said: If the dawn became brighter than it is now, I would pray them (the two rak'ahs of the sunnah prayer), offer them well and in a more beautiful manner.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1253]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1253

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Do not omit them (the two rak'ahs before the dawn prayer) even if you are driven away by the horses.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1256]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1256

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If any of you prays two rak'ahs before the dawn prayer, he should lie at his right side.

Marwan ibn al-Hakam said to him: Is it not enough that one of us walks to the mosque until he lies at his right side? According to the version of Ubaydullah, he (AbuHurayrah) replied: No.

This statement (of AbuHurayrah) reached Ibn Umar. He said: AbuHurayrah exceed limits on himself. He was asked: Do you look askance at what he says? He replied: No, but he dared and we showed cowardice. This (criticism of Ibn Umar) reached AbuHurayrah. He said: What is my sin if I remembered and they forgot?


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1258]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1258

Narrated Aisha, Ummul Mu'minin:

When the Prophet (peace_be_upon_him) prayed the two rak'ahs of the dawn prayer, he would lie down if I was asleep; in case I was awake, he would talk to me.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1259]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1259

Narrated AbuBakrah:

I came out with the Prophet (peace_be_upon_him) to offer the dawn prayer. When he passed by a sleeping man he called him for prayer or moved him with his foot. The narrator Ziyad said: This tradition has been reported to us by AbulFadl.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1262]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1262

Narrated Qays ibn Amr:

The Apostle of Allah (peace_be_upon_him) saw a person praying after the congregational prayer at dawn was over. The Apostle of Allah (peace_be_upon_him) said: There are two rak'ahs of the dawn prayer (i.e. the prescribed rak'ahs). The man replied: I did not pray the two rak'ahs before the dawn prayer. Hence I offered them now. The Apostle of Allah (peace_be_upon_him) kept silent.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1264]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1264

Narrated Umm Habibah:

The Prophet (peace_be_upon_him) said: If anyone keeps on praying regularly four rak'ahs before and four after the noon prayer, he will not enter the Hell-fire.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1265]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1265

Narrated AbuAyyub:

The Prophet (peace_be_upon_him) said: The gates of heaven are opened for four rak'ahs containing no taslim (salutation) before the noon prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1266]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1266

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: May Allah show mercy to a man who prays four rak'ahs before the afternoon prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1269]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1269

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) prohibited to offer prayer after the afternoon prayer except at the time when the sun is high up in the sky.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1270]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1270

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) would offer two rak'ahs after every obligatory prayer except the dawn and the afternoon prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1271]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1271

Narrated Abdullah ibn Abbas:

Some reliable people testified before me, and among them was Umar ibn al-Khattab, and most reliable in my eyes was Umar: The Prophet of Allah (peace_be_upon_him) said: There is no prayer after the dawn prayer until the sun rises; and there is no prayer after the afternoon prayer until the sun sets.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1272]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1272

Narrated Amr ibn Anbasah as-Sulami:

I asked: Apostle of Allah, in which part of night the supplication is more likely to be accepted?

He replied: In the last part: Pray as much as you like, for the prayer is attended by the angels and it is recorded till you offer the dawn prayer; then stop praying when the sun is rising till it has reached the height of one or two lances, for it rises between the two horns of the Devil, and the infidels offer prayer for it (at that time). Then pray as much as you like, because the prayer is witnessed and recorded till the shadow of a lance be- comes equal to it. Then cease prayer, for at that time the Hell-fire is heated up and doors of Hell are opened.

When the sun declines, pray as much as you like, for the prayer is witnessed till you pray the afternoon prayer; then cease prayer till the sun sets, for it sets between the horns of the Devil, and (at that time) the infidels offer prayer for it. He narrated a lengthy tradition.

Abbas said: AbuSalam narrated this tradition in a similar manner from AbuUmamah. If I have made a mistake unintentionally, I beg pardon of Allah and repent to Him.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1273]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1273

Narrated Abdullah ibn Umar:

Yasar, the client of Ibn Umar, said: Ibn Umar saw me praying after the break of dawn. He said: O Yasar, the Apostle of Allah (peace_be_upon_him) came to us while we were offering this prayer. He (the Prophet) said: Those who are present should inform those who are absent: Do not offer any prayer after (the break of) dawn except two rak'ahs.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1275]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1275

Narrated Aisha, Ummul Mu'minin:

Dhakwan, the client of Aisha, reported on the authority of Aisha: The Apostle of Allah (peace_be_upon_him) used to pray after the afternoon prayer but prohibited others from it; and he would fast continuously but forbid others to do so.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1282]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1282

Narrated Mu'adh ibn Anas al-Juhani:

The Prophet (peace_be_upon_him) said: If anyone sits in his place of prayer when he finishes the dawn prayer till he prays the two rak'ahs of the forenoon, saying nothing but what is good, his sins will be forgiven even if they are more than the foam of the sea.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1283]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1283

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: Prayer followed by a prayer with no idle talk between the two is recorded in Illiyyun.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1284]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1284

Narrated Nu'aym ibn Hammar:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah, the Exalted, says: Son of Adam, do not be helpless in performing four rak'ahs for Me at the beginning of the day: I will supply what you need till the end of it.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1285]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1285

Narrated Umm Hani ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) prayed on the day of the Conquest (of Mecca) eight rak'ahs saluting after every two rak'ahs.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1290]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1290

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Prayer by night and day should consist of pairs of rak'ahs.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1291]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1291

Narrated Muttalib:

The Prophet (peace_be_upon_him) said: Prayer is to be offered in two rak'ahs; and you should recite the tashahhud at the end of two rak'ahs, and express your distress and humility and raise your hands and say praying: O Allah, O Allah. He who does not do so does not offer a perfect prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1292]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1292

Narrated Abdullah Ibn Abbas:

The Apostle of Allah (peace_be_upon_him) said to al-Abbas ibn AbdulMuttalib: Abbas, my uncle, shall I not give you, shall I not present to you, shall I not donate to you, shall I not produce for you ten things? If you act upon them, Allah will forgive you your sins, first and last, old and new, involuntary and voluntary, small and great, secret and open.

These are the ten things: you should pray four rak'ahs, reciting in each one Fatihat al-Kitab and a surah. When you finish the recitation of the first rak'ah you should say fifteen times while standing: "Glory be to Allah", "Praise be to Allah", "There is no god but Allah", "Allah is most great". Then you should bow and say it ten times while bowing. Then you should raise your head after bowing and say it ten times. Then you should kneel down in prostration and say it ten times while prostrating yourself. Then you should raise your head after prostration and say it ten times. Then you should prostrate yourself and say it ten times. Then you should raise your head after prostrating and say it ten times in every rak'ah. You should do that in four rak'ahs.

If you can observe it once daily, do so; if not, then once weekly; if not, then once a month; if not, then once a year; if not, then once in your lifetime.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1293]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1293

Narrated Abdullah ibn Amr:

AbulJawza' said: A man who attended the company of the Prophet (peace_be_upon_him) narrated to me (it is thought that he was Abdullah ibn Amr): The Prophet (peace_be_upon_him) said to me: Come to me tomorrow; I shall give you something, I shall give you something, I shall reward you something, I shall donate something to you. I thought that he would give me some present.

He said (to me when I came to him): When the day declines, stand up and pray four rak'ahs. He then narrated something similar.

This version adds: Do not stand until you glorify Allah ten times, and praise Him ten times, and exalt Him ten times, and say, "There is no god but Allah" ten times. Then you should do that in four rak'ahs. If you are the greatest sinner on earth, you will be forgiven (by Allah) on account of this (prayer).

I asked: If I cannot pray this the appointed hour, (what should I do)? He replied: Pray that by night or by day (at any time).


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1295]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1295

Narrated Ka'b ibn Ujrah:

The Prophet (peace_be_upon_him) came to the mosque of Banu AbdulAshhal. He prayed the sunset prayer there. When they finished the prayer, he saw them praying the supererogatory prayer after it. He said: This is the prayer to be offered in the houses.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1296]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1296

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) used to prolong the recitation of the Qur'an in the two rak'ahs after the sunset prayer until the people praying in the mosque dispersed.


Dawud :: Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey :: [4.1298]

Prayer (Kitab Al-Salat): Detailed Rules of Law about the Prayer during Journey

Dawud :: Book 4 : Hadith 1298

Narrated Aisha, Ummul Mu'minin:

Shurayh ibn Hani said: I asked Aisha about the prayer of the Apostle of Allah (peace_be_upon_him). She said: The Apostle of Allah (peace_be_upon_him) never offered the night prayer and thereafter came to me but he offered four or six rak'ahs of prayer. One night the rain fell, so we spread a piece of leather (for his prayer), and now I see as if there is a hole in it from which the water is flowing. I never saw him protecting his clothes from the earth (as he did on that occasion).


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1299]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1299

Narrated Abdullah Ibn Abbas:

In Surat al-Muzzammil (73), the verse: "Keep vigil at night but a little, a half thereof" (2-3) has been abrogated by the following verse: "He knoweth that ye count it not, and turneth unto you in mercy. Recite then of the Qur'an that which is easy for you" (v.20). The phrase "the vigil of the night" (nashi'at al-layl) means the early hours of the night. They (the companions) would pray (the tahajjud prayer) in the early hours of the night.

He (Ibn Abbas) says: It is advisable to offer the prayer at night (tahajjud), prescribed by Allah for you (in the early hours of the night). This is because when a person sleeps, he does not know when he will awake. The words "speech more certain" (aqwamu qilan) means that this time is more suitable for the understanding of the Qur'an. He says: The verse: "Lo, thou hast by day a chain of business" (v.7) means engagement for long periods (in the day's work).


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1302]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1302

Narrated Aisha, Ummul Mu'minin:

Do not give up prayer at night, for the Apostle of Allah (peace_be_upon_him) would not leave it. Whenever he fell ill or lethargic, he would offer it sitting.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1303]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1303

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: May Allah have mercy on a man who gets up at night and prays, and awakens his wife; if she refuses, he should sprinkle water on her face. May Allah have mercy on a woman who gets up at night and prays, and awakens her husband; if he refuses, she would sprinkle water on his face.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1304]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1304

Narrated AbuSa'id ; AbuHurayrah:

The Prophet (peace_be_upon_him) said: If a man awakens his wife at night, and then both pray or both offer two rak'ahs together, the (name of the )man will be recorded among those who mention the name of Allah, and the (name of the) woman will be recorded among those who mention the name of Allah. Ibn Kathir did not narrate this tradition as a statement of the Prophet (peace_be_upon_him), but he reported it as a statement of AbuSa'id.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1309]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1309

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: Any person who offers prayer at night regularly but (on a certain night) he is dominated by sleep will be given the reward of praying. His sleep will be almsgiving.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1320]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1320

Narrated Abdullah ibn Habashi al-Khath'ami:

The Prophet (peace_be_upon_him) was asked: which is the best action? He replied: To stand in prayer for a long time.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1322]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1322

Narrated Abdullah ibn Abbas:

The Prophet's (peace_be_upon_him) recitation was loud enough for one who was in the inner chamber to hear it when he was in the house.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1324]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1324

Narrated AbuQatadah:

The Prophet (peace_be_upon_him) went out at night and found AbuBakr praying in a low voice, and he passed Umar ibn al-Khattab who was raising his voice while praying.

When they both met the Prophet (peace_be_upon_him) together, the Prophet (peace_be_upon_him) said: I passed by you, AbuBakr, when you were praying in a low voice. He replied: I made Him hear with Whom I was holding intimate converse, Apostle of Allah. He (the Prophet) said to Umar: I passed by you when you were praying in a loud voice. He replied: Apostle of Allah, I was awakening the drowsy and driving away the Devil.

Al-Hasan added in his version: The Prophet (peace_be_upon_him) said: Raise your voice a little, AbuBakr, and he said to Umar: Lower your voice a little.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1327]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1327

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) retired to the mosque. He heard them (the people) reciting the Qur'an in a loud voice. He removed the curtain and said: Lo! every one of you is calling his Lord quietly. One should not trouble the other and one should not raise the voice in recitation or in prayer over the voice of the other.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1328]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1328

Narrated Uqbah ibn Amir al-Juhani:

The Prophet (peace_be_upon_him) said: One who recites the Qur'an in a loud voice is like one who gives alms openly; and one who recites the Qur'an quietly is one who gives alms secretly.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1341]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1341

Narrated Aisha, Ummul Mu'minin:

Zurarah ibn Awfa said that Aisha was asked about the midnight prayer of the Apostle of Allah (peace_be_upon_him).

She said: He used to offer his night prayer in congregation and then return to his family (in his house) and pray four rak'ahs. Then he would go to his bed and sleep, but the water for his ablution was placed covered near his head and his tooth-stick was also kept there until Allah awakened him at night.

He then used the tooth-stick, performed ablution perfectly then came to the place of prayer and would pray eight rak'ahs, in which he would recite Surah al-Fatihah, and a surah from the Qur'an as Allah willed. He would not sit during any of them but sit after the eighth rak'ah, and would not utter the salutation, but recite (the Qur'an) during the ninth rak'ah. Then he would sit and supplicate as long as Allah willed, and beg Him and devote his attention to Him; He would utter the salutation once in such a loud voice that the inmates of the house were almost awakened by his loud salutation. He would then recite Surah al-Fatihah while sitting, bow while sitting, and then recite the Qur'an during the second rak'ah, and would bow and prostrate while sitting. He would supplicate Allah as long as He willed, then utter the salutation and turn away.

This amount of prayer of the Apostle of Allah (peace_be_upon_him) continued till he put a weight. During that period he retrenched two rak'ahs from nine and began to pray six and seven rak'ahs standing and two rak'ahs sitting. This continued till he died.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1347]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1347

Narrated Aisha, Ummul Mu'minin:

Sa'd ibn Hisham said: I came to Medina and called upon Aisha, and said to her: Tell me about the prayer of the Apostle of Allah (peace_be_upon_him).

She said: The Apostle of Allah (peace_be_upon_him) used to lead the people in the night prayer, and then go to his bed and sleep. When midnight came he got up, went to answer the call of nature and to perform ablution with water. Having performed ablution, he entered the mosque and prayed eight rak'ahs.

To my mind he performed the recitation of the Qur'an, bowing and prostrating equally. He then observed witr with one rak'ah and prayed two rak'ahs sitting. Then he lay down on the ground. Sometimes Bilal came to him and called him for prayer. He then dozed, and sometimes I doubted whether he dozed or not, till he (Bilal) called him for prayer.

This is the prayer he offered till he grew old or put on weight. She then mentioned how he put on weight as Allah wished.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1358]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1358

Narrated Aisha, Ummul Mu'minin:

Al-Aswad ibn Yazid said that he entered upon Aisha and asked her about the prayer of the Apostle of Allah (peace_be_upon_him) during the night. She said: He used to pray thirteen rak'ahs during the night. Then he began to pray eleven rak'ahs and left two rak'ahs. When he died, he would pray nine rak'ahs during the night. His last prayer during the night was witr.


Dawud :: Prayer (Kitab Al-Salat): Prayer at Night :: [5.1360]

Prayer (Kitab Al-Salat): Prayer at Night

Dawud :: Book 5 : Hadith 1360

Narrated Abdullah ibn Abbas:

I spent a night with my maternal aunt Maymunah. The Prophet (peace_be_upon_him) got up to pray at night. He prayed thirteen rak'ahs including two rak'ahs of the dawn prayer. I guessed that he stood in every rak'ah as long as one could recite Surah al-Muzzammil (73).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1370]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1370

Narrated AbuDharr:

We fasted with the Apostle of Allah (peace_be_upon_him) during Ramadan, but he did not make us get up at night for prayer at any time during the month till seven nights remained; then he made us get up for prayer till a third of the night had passed. When the sixth remaining night came, he did not make us get up for prayer. When the fifth remaining night came, he made us stand in prayer till a half of the night had gone.

So I said: Apostle of Allah, I wish you had led us in supererogatory prayers during the whole of tonight.

He said: When a man prays with an imam till he goes he is reckoned as having spent a whole night in prayer. On the fourth remaining night he did not make us get up. When the third remaining night came, he gathered his family, his wives, and the people and prayed with us till we were afraid we should miss the falah (success).

I said: What is falah? He said: The meal before daybreak. Then he did not make us get up for prayer during the remainder of the month.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1374]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1374

Narrated Abdullah ibn Unays:

I was present at the gathering of Banu Salamah, and I was the youngest of them.

They (the people) said: Who will ask the Apostle of Allah (peace_be_upon_him) for us about Laylat al-Qadr? That was the twenty-first of Ramadan. I went out and said the sunset prayer along with the Apostle of Allah (peace_be_upon_him). I then stood at the door of his house.

He passed by me and said: Come in. I entered (the house) and dinner was brought for him. I was prevented from taking food as it was scanty.

When he finished his dinner, he said to me: Give me my shoes. He then stood up and I also stood up with him. He said: Perhaps you have some business with me.

I said: Yes. Some people of Banu Salamah have sent me to you to ask you about Laylat al-Qadr. He asked: Which night: Is it tonight?

I said: Twenty-second. He said: This is the very night. He then withdrew and said: Or the following night, referring to the twenty-third night.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1375]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1375

Narrated Abdullah ibn Unays al-Juhani:

I said to the Apostle of Allah: I have a place in the desert where I live and in which I pray, with the praise of Allah; but give me command about a night when I come to this mosque.

He replied: Come on the twenty third night.

I (a sub-narrator, Muhammad ibn Ibrahim) said to his (Abdullah ibn Unays's) son: How would your father act?

He replied: He used to enter the mosque when he had offered the afternoon prayer, and did not leave it for any purpose till he prayed the morning prayer. Then when he had prayed the morning prayer, he found his riding beast at the door of the mosque, mounted it and got back to his desert.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1378]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1378

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: Seek it (laylat al-Qadr) in the last ten days of Ramadan. Seek it on the ninth, seventh and fifth night. I (AbuNadrah) said: You know counting better than us, AbuSa'id. He said: Yes. I asked: What do you mean by the ninth, seventh and fifth night? He said: When the twenty-first night passes, the night which follows it is the night; when the twenty-third night passes, the night which follows it is the seventh; when the twenty-fifth passes, the night which follows it is the fifth.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1379]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1379

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) said to us: Seek it (laylat al-Qadr) on the seventeenth night of Ramadan, and on the twenty first night, and on the twenty-third night. He then kept silence.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1385]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1385

Narrated Abdullah ibn Amr ibn al-'As:

Yazid ibn Abdullah said that Abdullah ibn Amr asked the Prophet (peace_be_upon_him): In how many days should I complete the recitation of the whole Qur'an, Apostle of Allah?

He replied: In one month.

He said: I am more energetic to complete it in a period less than this. He kept on repeating these words and lessening the period until he said: Complete its recitation in seven days.

He again said: I am more energetic to complete it in a period less than this.

The Prophet (peace_be_upon_him) said: He who finishes the recitation of the Qur'an in less than three days does not understand it.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1388]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1388

Narrated Aws ibn Hudhayfah:

We came upon the Apostle of Allah (peace_be_upon_him) in a deputation of Thaqif. The signatories of the pact came to al-Mughirah ibn Shu'bah as his guests. The Apostle of Allah (peace_be_upon_him) made Banu-Malik stay in a tent of his.

Musaddad's version says: He was in the deputation of Thaqif which came to the Apostle of Allah (peace_be_upon_him). He used to visit and have a talk with us every day after the night prayer.

The version of AbuSa'id says: He remained standing for such a long time (talking to us) that he put his weight sometimes on one leg and sometimes on the other due to his long stay. He mostly told us how his people, the Quraysh, behaved with him.

He would say: We were not equal; we were weak and degraded at Mecca (according to Musaddad's version). When we came over to Medina the fighting began between us; sometimes we overcome them and at other times they overcome us. One night he came late and did not come at the time he used to come.

We asked him: You came late tonight? He said: I could not recite the fixed part of the Qur'an that I used to recite every day. I disliked to come till I had completed it.

Aws said: I asked the companions of the Apostle of Allah (peace_be_upon_him): How do you divide the Qur'an for daily recitation? They said: Three surahs, five surahs, eleven surahs, thirteen surahs' mufassal surahs.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1389]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1389

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: He who recites the Qur'an in a period less than three days does not understand it.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1390]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1390

Narrated Abdullah ibn Amr ibn al-'As:

Wahb ibn Munabbih said: Abdullah ibn Amr asked the Prophet (peace_be_upon_him); In how many days should one complete the recitation of the Qur'an? He said: In forty days. He then said: In one month. He again said: In twenty days. He then said: In fifteen days. He then said: In ten days. Finally he said: In seven days.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1391]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1391

Narrated Ibn Mas'ud:

Alqamah and al-Aswad said: A man came to Ibn Mas'ud. He said: I recite the mufassal surahs in one rak'ah. You might recite it quickly as one recites verse (poetry) quickly, or as the dried dates fall down (from the tree).

But the Prophet (peace_be_upon_him) used to recite two equal surahs in one rak'ah; he would recite (for instance) surahs an-Najm (53) and ar-Rahman (55) in one rak'ah, surahs Iqtarabat (54) and al-Haqqah (69) in one rak'ah, surahs at-Tur (52) and adh-Dhariyat (51) in one rak'ah, surahs al-Waqi'ah (56) and Nun (68) in one rak'ah, surahs al-Ma'arij (70) and an-Nazi'at (79) in one rak'ah, surahs al-Mutaffifin (83) and Abasa (80) in one rak'ah, surahs al-Muddaththir (74) and al-Muzzammil (73) in one rak'ah, surahs al-Insan (76) and al-Qiyamah (75) in one rak'ah, surahs an-Naba' (78) and al-Mursalat (77) in one rak'ah, and surahs ad-Dukhan (44) and at-Takwir (81) in one rak'ah.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1393]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1393

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: If anyone prays at night reciting regularly ten verses, he will not be recorded among the negligent; if anyone prays at night and recites a hundred verses, he will be recorded among those who are obedient to Allah; and if anyone prays at night reciting one thousand verses, he will be recorded among those who receive huge rewards.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1394]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1394

Narrated Abdullah ibn Amr:

A man came to the Apostle of Allah (peace_be_upon_him) and said: Teach me to read the Qur'an, Apostle of Allah.

He said: Read three surahs which begin with A.L.R. He said: My age is advanced, my mind has become dull (i.e. memory has grown weak), and my tongue has grown heavy). So he said: Then read three surahs which begin with H.M. He repeated the same words. So he said: Read three surahs which begin with the "Glorification of Allah". But he repeated the same excuse. The man then said: Teach me a comprehensive surah, Apostle of Allah. The Prophet (peace_be_upon_him) taught him Surah (99). "When the Earth is shaken with her earthquake". When he finished it, the man said: By Him Who sent you with truth, I shall never add anything to it. Then man then went away.

The Prophet (peace_be_upon_him) said twice: The man received salvation.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan :: [6.1395]

Prayer (Kitab Al-Salat): Detailed Injunctions about Ramadan

Dawud :: Book 6 : Hadith 1395

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A surah of the Qur'an containing thirty verses will intercede its reader till he will be forgiven. That is: "Blessed is He in Whose Hand is the sovereignty" (Surah 67).


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1396]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1396

Narrated Amr ibn al-'As:

The Prophet (peace_be_upon_him) taught me fifteen prostrations while reciting the Qur'an, including three in al-Mufassal and two in Surah al-Hajj.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1397]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1397

Narrated Uqbah ibn Amir:

I said to the Apostle of Allah (peace_be_upon_him): Are there two prostrations in Surah al-Hajj? He replied: Yes; if anyone does not make two prostrations, he should not recite them.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1398]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1398

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) did not make a prostration at any verse in al-Mufassal from the time he moved to Medina.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1405]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1405

Narrated Ali ibn AbuTalib:

When the Prophet (peace_be_upon_him) uttered the salutation at the end of the prayer, he used to say: "O Allah, forgive me my former and latter sins, what I have kept secret and what I have done openly, and what I have done extravagance; and what Thou knowest better than I do. Thou art the Advancer, the Delayer, there is no god but Thou"


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1406]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1406

Narrated Abdullah ibn Umar:

In the year of Conquest the Apostle of Allah (peace_be_upon_him) recited a verse at which a prostration should be made and all the people prostrated themselves. Some were mounted, and some were prostrating themselves on the ground, and those who were mounted prostrated themselves on their hands.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1408]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1408

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) used to recite the Qur'an to us. When he came upon the verse containing prostration, he would utter the takbir (Allah is most great) and we would prostrate ourselves along with him.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1409]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1409

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) prostrated himself at night when reciting the Qur'an. He said repeatedly: My face prostrates itself to Him Who created it and brought forth its hearing and seeing by His might and power.


Dawud :: Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an :: [7.1410]

Prayer (Kitab Al-Salat): Prostration while reciting the Qur'an

Dawud :: Book 7 : Hadith 1410

Narrated Abdullah ibn Umar:

AbuTamimah al-Hujaymi said: When we came to Medina accompanying the caravan, I used to preach after the dawn prayer, and prostrate on account of the recitation of the Qur'an. Ibn Umar prohibited me three times, but I did not cease doing that. He then repeated (his prohibition) saying: I prayed behind the Apostle of Allah (peace_be_upon_him), AbuBakr, Umar and Uthman, they would not prostrate (on account of the recitation of the Qur'an) till the sun had risen.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1411]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1411

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: Allah is single (witr) and loves what is single, so observe the witr, you who follow the Qur'an.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1413]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1413

Narrated Kharijah ibn Hudhafah al-Adawi:

The Apostle of Allah (peace_be_upon_him) came out to us and said: Allah the Exalted has given you an extra prayer which is better for you then the red camels (i.e. high breed camels). This is the witr which Allah has appointed for you between the night prayer and the daybreak.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1414]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1414

Narrated Buraydah ibn al-Hasib:

I heard the Apostle of Allah (peace_be_upon_him) say: The witr is a duty, so he who does not observe it does not belong to us; the witr is a duty, so he who does not observe it does not belong to us; the witr is a duty, so he who does not observe it does not belong to us.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1415]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1415

Narrated Ubadah ibn as-Samit:

Ibn Muhayriz said: A man from Banu Kinanah, named al-Makhdaji, heard a person called AbuMuhammad in Syria, saying: The witr is a duty (wajib).

Al-Makhdaji said: So I went to Ubadah ibn as-Samit and informed him.

Ubadah said: AbuMuhammad told a lie. I heard the Apostle of Allah (peace_be_upon_him) say: There are five prayers which Allah has prescribed on His servants. If anyone offers them, not losing any of them, and not treating them lightly, Allah guarantees that He will admit him to Paradise. If anyone does not offer them, Allah does not take any responsibility for such a person. He may either punish him or admit him to Paradise.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1417]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1417

Narrated AbuAyyub al-Ansari:

The Prophet (peace_be_upon_him) said: The witr is a duty for every Muslim so if anyone wishes to observe it with five rak'ahs, he may do so; if anyone wishes to observe it with three, he may do so, and if anyone wishes to observe it with one, he may do so.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1418]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1418

Narrated Ubayy ibn Ka'b:

The Apostle of Allah (peace_be_upon_him) used to observe witr with (reciting) "Glorify the name of thy Lord, the most High" (Surah 87), "Say O disbelievers" (Surah 109), and "Say, He is Allah, the One, Allah, the eternally besought of all" (112).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1419]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1419

Narrated Aisha, Ummul Mu'minin:

AbdulAziz ibn Jurayj said: I asked Aisha, mother of the believers: With which (surah) the Apostle of Allah (peace_be_upon_him) used to observe witr? (She reported same as in the Hadith of Ubayy ibn Ka'b, No. 1418)

This version adds: In the third rak'ah he would recite: "Say, He is Allah, the One" (Surah 112), and "Say, I seek refuge in the Lord of daybreak" (Surah 113), and "Say, I seek refuge in the Lord of mankind" (Surah 114).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1420]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1420

Narrated Al-Hasan ibn Ali:

The Apostle of Allah (peace_be_upon_him) taught me some words that I say during the witr. (The version of Ibn Jawwas has: I say them in the supplication of the witr.) They were: "O Allah, guide me among those Thou hast guided, grant me security among those Thou hast granted security, take me into Thy charge among those Thou hast taken into Thy charge, bless me in what Thou hast given, guard me from the evil of what Thou hast decreed, for Thou dost decree, and nothing is decreed for Thee. He whom Thou befriendest is not humbled. Blessed and Exalted art Thou, our Lord."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1422]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1422

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) used to say at the end of his witr: "O Allah, I seek refuge in Thy good pleasure from Thy anger, and in Thy forgiveness from Thy punishment, and I seek refuge in Thy mercy from Thy wrath. I cannot reckon the praise due to Thee. Thou art as Thou hast praised Thyself."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1424]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1424

Narrated Ubayy ibn Ka'b:

Al-Hasan reported: Umar ibn al-Khattab gathered the people (in tarawih prayer) behind Ubayy ibn Ka'b (who led them). He used to lead them for twenty days (during Ramadan, and would not recite the supplication except in the second half of it (i.e. Ramadan). When the last ten days remained, he kept away from them, and prayed in his house. They used to say: Ubayy ran away.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1425]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1425

Narrated Ubayy ibn Ka'b:

When the Apostle of Allah (peace_be_upon_him) offered salutation in the witr prayer, he said: Glorify be to the king most holy.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1426]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1426

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: If anyone oversleeps and misses the witr, or forgets it, he should pray when he remembers.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1429]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1429

Narrated AbuQatadah:

The Prophet (peace_be_upon_him) asked AbuBakr: When do you observe the witr?

He replied: I observe the witr prayer in the early hours of the night.

The Prophet (peace_be_upon_him) asked Umar: When do you observe the witr?

He replied: At the end of the night.

He then said to AbuBakr: This has followed it with care; and he said to Umar: He has followed it with strength.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1434]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1434

Narrated Talq ibn Ali:

Qays ibn Talq said: Talq ibn Ali visited us on a certain day during Ramadan. He remained with us till evening and broke fast with us. He then stood up and led us in the witr prayer.

He then went to his mosque and led them in prayer. When the witr remained, he put forward another man and said: Lead your companions in the witr prayer, for I heard the Apostle of Allah (peace_be_upon_him) as saying: There are no two witrs during one night.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1438]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1438

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) recited the supplication (Qunut) daily for a month at the noon, afternoon, sunset, night and morning prayers. When he said: "Allah listens to him who praises Him" in the last rak'ah, invoking a curse on some clans of Banu Sulaym, Ri'l, Dhakwan and Usayyah, and those who were standing behind him said: Amen.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1441]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1441

Narrated Someone who prayed with the Prophet:

Muhammad ibn Sirin said: Someone who prayed the morning prayer along with the Prophet (peace_be_upon_him) narrated to me: When he raised his head after the second rak'ah, he remained standing for a short while.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1445]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1445

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: May Allah show mercy to a man who gets up during the night and prays, who wakens his wife and she prays; if she refuses, he sprinkles water on her face. May Allah show mercy to a woman who gets up during the night and prays, who wakens her husband and he prays; if he refuses she sprinkles water on his face.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1446]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1446

Narrated AbuSa'id ; AbuHurayrah:

The Prophet (peace_be_upon_him) said: When a man himself wakes at night and wakens his wife and they pray two rak'ahs together, they are recorded among the men and women who make much mention of Allah.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1448]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1448

Narrated Mu'adh al-Juhani:

The Prophet (peace_be_upon_him) said: If anyone recites the Qur'an and acts according to its contents, on the Day of Judgment his parents will be given to wear a crown whose light is better than the light of the sun in the dwellings of this world if it were among you. So what do you think of him who acts according to his.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1454]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1454

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) was given seven repeated long surahs, while Moses was given six, When he threw the tablets, two of them were withdrawn and four remained.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1457]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1457

Narrated Uqbah ibn Amir:

I was driving the she-camel of the Apostle of Allah (peace_be_upon_him) during a journey. He said to me: Uqbah, should I not teach you two best surahs ever recited? He then taught me: "Say, I seek refuge in the Lord of the dawn," and "Say, I seek refuge in the Lord of men." He did not see me much pleased (by these two surahs).

When he alighted for prayer, he led the people in the morning prayer and recited them in prayer. When the Apostle of Allah (peace_be_upon_him) finished his prayer, he turned to me and said: O Uqbah, how did you see.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1458]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1458

Narrated Uqbah ibn Amir:

White I was travelling with the Apostle of Allah (peace_be_upon_him) between al-Juhfah and al-Abwa', a wind and intense darkness enveloped us, whereupon the Apostle of Allah (peace_be_upon_him) began to seek refuge in Allah, reciting: "I seek refuge in the Lord of the dawn," and "I seek refuge in the Lord of men."

He then said: Uqbah, use them when seeking refuge in Allah, for no one can use anything to compare with them for the purpose.

Uqbah added: I heard him reciting them when he led the people in prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1459]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1459

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: One who was devoted to the Qur'an will be told to recite, ascend and recite carefully as he recited carefully when he was in the world, for he will reach his abode when he comes to the last verse he recites.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1461]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1461

Narrated Umm Salamah, Ummul Mu'minin:

Ya'la ibn Mumallak said that he asked Umm Salamah about the recitation and prayer of the Apostle of Allah (peace_be_upon_him).

She said: What have you to do with his prayer? He would pray, then sleep as long as he had prayed, till morning. She then described his recitation and did so with an exposition word by word.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1463]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1463

Narrated Al-Bara' ibn Azib:

The Prophet (peace_be_upon_him) said: Beautify the Qur'an with your voices.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1464]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1464

Narrated Sa'd ibn AbuWaqqas:

The Apostle of Allah (peace_be_upon_him) said: He who does not chant the Qur'an is not one of us.

(Sub-narrator Qutaybah said: This Hadith according to my collection is on the authority of Sa'id ibn AbuSa'id.)


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1466]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1466

Narrated AbuLubabah:

Ubaydullah ibn Yazid said: AbuLubabah passed by us and we followed him till he entered his house, and we also entered it.

There was a man in a rusty house and in shabby condition. I heard him say: I heard the Apostle of Allah (peace_be_upon_him) say: He is not one of us who does not chant the Qur'an.

I (the narrator AbdulJabbar) said to Ibn AbuMulaykah: AbuMuhammad, what do you think if a person does not have pleasant voice? He said: He should recite with pleasant voice as much as possible.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1469]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1469

Narrated Sa'd ibn Ubadah:

The Prophet (peace_be_upon_him) said: No man recites the Qur'an, then forgets it, but will meet Allah on the Day of Judgment in a maimed condition (or empty-handed, or with no excuse).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1474]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1474

Narrated An-Nu'man ibn Bashir:

The Prophet (peace_be_upon_him) said: Supplication (du'a') is itself the worship.

(He then recited:) "And your Lord said: Call on Me, I will answer you" (xI.60).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1475]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1475

Narrated Sa'd ibn AbuWaqqas:

Ibn Sa'd said: My father (Sa'd ibn AbuWaqqas) heard me say: O Allah, I ask Thee for Paradise, its blessings, its pleasure and such-and-such, and such-and-such; I seek refuge in Thee from Hell, from its chains, from its collars, and from such-and-such, and from such-and-such. He said: I heard the Apostle of Allah (peace_be_upon_him) say: There will be people who will exaggerate in supplication. You should not be one of them. If you are granted Paradise, you will be granted all what is good therein; if you are protected from Hell, you will be protected from what is evil therein.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1476]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1476

Narrated Fudalah ibn Ubayd,:

The Apostle of Allah (peace_be_upon_him) heard a person supplicating during prayer. He did not mention the greatness of Allah, nor did he invoke blessings on the Prophet (peace_be_upon_him).

The Apostle of Allah (peace_be_upon_him) said: He made haste.

He then called him and said either to him or to any other person: If any of you prays, he should mention the exaltation of his Lord in the beginning and praise Him; he should then invoke blessings on the Prophet (peace_be_upon_him); thereafter he should supplicate Allah for anything he wishes.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1480]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1480

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Do not cover the walls. He who sees the letter of his brother without his permission, sees Hell-fire.

Supplicate Allah with the palms of your hands; do not supplicate Him with their backs upwards. When you finish supplication, wipe your faces with them.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1481]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1481

Narrated Malik ibn Yasar as-Sakuni, al-Awfi:

The Prophet (peace_be_upon_him) said: When you make requests to Allah, do so with the palms of your hands, and not backs, upwards.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1482]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1482

Narrated Anas ibn Malik:

I saw the Apostle of Allah (peace_be_upon_him) supplicating Allah in this manner with the palms of his hands and also with their backs upwards.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1483]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1483

Narrated Salman al-Farsi:

The Prophet (peace_be_upon_him) said: Your Lord is munificent and generous, and is ashamed to turn away empty the hands of His servant when he raises them to Him.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1484]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1484

Narrated Abdullah ibn Abbas:

Ikrimah quoted Ibn Abbas as saying: When asking for something you should raise your hands opposite to your shoulders; when asking for forgiveness you should point with one finger; and when making an earnest supplication you should spread out both your hands.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1487]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1487

Narrated Yazid ibn Sa'id al-Kindi:

When the Prophet (peace_be_upon_him) made supplication (to Allah) he would raise his hands and wipe his face with his hands.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1488]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1488

Narrated Buraydah ibn al-Hasib:

The Apostle of Allah (peace_be_upon_him) heard a man saying: O Allah, I ask Thee, I bear witness that there is no god but Thou, the One, He to Whom men repair, Who has not begotten, and has not been begotten, and to Whom no one is equal, and he said: You have supplicated Allah using His Greatest Name, when asked with this name He gives, and when supplicated by this name he answers.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1490]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1490

Narrated Anas ibn Malik:

I was sitting with the Apostle of Allah (peace_be_upon_him) and a man was offering prayer. He then made supplication: O Allah, I ask Thee by virtue of the fact that praise is due to Thee, there is no deity but Thou, Who showest favour and beneficence, the Originator of the Heavens and the earth, O Lord of Majesty and Splendour, O Living One, O Eternal One.

The Prophet (peace_be_upon_him) then said: He has supplicated Allah using His Greatest Name, when supplicated by this name, He answers, and when asked by this name He gives.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1492]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1492

Narrated Aisha, Ummul Mu'minin:

Ata' said: The quilt of Aisha was stolen. She began to curse the person who had stolen it. The Prophet (peace_be_upon_him) began to tell her: Do not lighten him.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1493]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1493

Narrated Umar ibn al-Khattab:

I sought permission of the Prophet (peace_be_upon_him) to perform umrah. He gave me permission and said: My younger brother, do not forget me in your supplication.

He (Umar) said: He told me a word that pleased me so much so that I would not have been pleased if I were given the whole world.

The narrator Shu'bah said: I then met Asim at Medina. He narrated to me this tradition and reported the wordings: "My younger brother, share me in your supplication."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1494]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1494

Narrated Sa'd ibn AbuWaqqas:

The Prophet (peace_be_upon_him) passed by me while I was supplicating by pointing with two fingers of mine. He said: Point with one finger; point with one finger. He then himself pointed with the forefinger.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1495]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1495

Narrated Sa'd ibn AbuWaqqas:

Once Sa'd, with the Apostle of Allah (peace_be_upon_him), visited a woman in front of whom were some date-stones or pebbles which she was using as a rosary to glorify Allah. He (the Prophet) said: I tell you something which would be easier (or more excellent) for you than that. He said (it consisted of saying): "Glory be to Allah" as many times as the number of that which He has created in Heaven; "Glory be to Allah" as many times as the number of that which He has created on Earth; "Glory be to Allah" as many times as the number of that which He has created between them; "Glory be to Allah" as many times as the number of that which He is creating; "Allah is most great" a similar number of times; "Praise (be to Allah)" a similar number of times; and "There is no god but Allah" a similar number of times; "There is no might and no power except in Allah" a similar number of times.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1496]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1496

Narrated Yusayrah, mother of Yasir:

The Prophet (peace_be_upon_him) commanded them (the women emigrants) to be regular (in remembering Allah by saying): "Allah is most great"; "Glory be to the King, the Holy"; "there is no god but Allah"; and that they should count them on fingers, for they (the fingers) will be questioned and asked to speak.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1497]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1497

Narrated Abdullah ibn Amr ibn al-'As:

I saw the Apostle of Allah (peace_be_upon_him) counting the glorification of Allah on fingers.

Ibn Qudamah said (in his version: "With his right hands".


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1498]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1498

Narrated Abdullah Ibn Abbas:

The Apostle of Allah (peace_be_upon_him) went out from Juwayriyyah (wife of the Prophet). Earlier her name was Barrah, and he changed it. When he went out she was in her place of worship, and when he returned she was in her place of worship.

He asked: Have you been in your place of worship continuously? She said: Yes. He then said: Since leaving you I have said three times four phrases which, if weighed against all that you have said (during this period), would prove to be heavier: "glory be to Allah", and I begin with praise of Him to the number of His creatures, in accordance with His good pleasure, to the weight of His throne and to the ink (extent) of His words.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1499]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1499

Narrated AbuHurayrah:

AbuDharr said: Prophet of Allah. The wealthy people have all the rewards; they pray as we pray; they fast as we fast; and they have surplus wealth which they give in charity; but we have no wealth which we may give in charity.

The Apostle of Allah (peace_be_upon_him) said: AbuDharr, should I not teach you phrases by which you acquire the rank of those who excel you? No one can acquire your rank except one who acts like you.

He said: Why not, Apostle of Allah? He said: Exalt Allah (say: Allah is Most Great) after each prayer thirty-three times; and praise Him (say: Praise be to Allah) thirty-three times; and glorify Him (say: Glory be to Allah) thirty-three times, and end it by saying, "There is no god but Allah alone, there is no partner, to Him belongs the Kingdom, to Him praise is due and He has power over everything". His sins will be forgiven, even if they are like the foam of the sea.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1503]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1503

Narrated Zayd ibn Arqam:

I heard the Apostle of Allah (peace_be_upon_him) saying (the version of Sulayman has: The Apostle of Allah (peace_be_upon_him) used to say) after his prayer:-

"O Allah, our Lord and Lord of everything, I bear witness that Thou art the Lord alone Who hast no partner; O Allah, Our Lord and Lord of everything, I bear witness that Muhammad is Thy servant and Thy apostle ; O Allah, our Lord and Lord of everything, I bear witness that all the servants are brethren; O Allah, our Lord and Lord of everything make me sincere to Thee, and my family too at every moment, in this world and in the world hereafter, O Possessor of glory and honour, listen to me and answer. Allah is incomparably great. O Allah, Light of the heavens and of the earth".


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1505]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1505

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) used to supplicate Allah: "My Lord, help me and do not give help against me; grant me victory, and do not grant victory over me; plan on my behalf and do not plan against me; guide me, and made my right guidance easy for me; grant me victory over those who act wrongfully towards me; O Allah, make me grateful to Thee, mindful of Thee, full of fear towards Thee, devoted to Thy obedience, humble before Thee, or penitent. My Lord, accept my repentance, wash away my sin, answer my supplication, clearly establish my evidence, guide my heart, make true my tongue and draw out malice in my breast."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1509]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1509

Narrated AbuBakr as-Siddiq:

The Prophet (peace_be_upon_him) said: He who asks pardon is not a confirmed sinner, even if he returns to his sin seventy times a day.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1511]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1511

Narrated Abdullah ibn Umar:

We counted that the Apostle of Allah (peace_be_upon_him) would say a hundred times during a meeting: "My Lord, forgive me and pardon me; Thou art the Pardoning and forgiving One".


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1512]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1512

Narrated Zayd, the client of the Prophet:

The Prophet (peace_be_upon_him) said: If anyone says: "I ask pardon of Allah than Whom there is no deity, the Living, the eternal, and I turn to Him in repentance," he will be pardoned, even if he has fled in time of battle.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1513]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1513

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone continually asks pardon, Allah will appoint for him a way out of every distress, and a relief from every anxiety, and will provide for him from where he did not reckon.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1516]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1516

Narrated AbuBakr as-Siddiq:

Asma' bint al-Hakam said: I heard Ali say: I was a man; when I heard a tradition from the Apostle of Allah (peace_be_upon_him), Allah benefited me with it as much as He willed. But when some one of his companions narrated a tradition to me I adjured him. When he took an oath, I testified him.

AbuBakr narrated to me a tradition, and AbuBakr narrated truthfully. He said: I heard the apostle of Allah (peace_be_upon_him) saying: When a servant (of Allah) commits a sin, and he performs ablution well, and then stands and prays two rak'ahs, and asks pardon of Allah, Allah pardons him. He then recited this verse: "And those who, when they commit indecency or wrong their souls, remember Allah" (iii.134).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1518]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1518

Narrated Uqbah ibn Amir:

The Apostle of Allah (peace_be_upon_him) commanded me to recite Mu'awwidhatan (the last two surahs of the Qur'an) after every prayer.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1519]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1519

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) liked to supplicate three times and to ask pardon (of Allah) three times.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1520]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1520

Narrated Asma' daughter of Umays:

The Apostle of Allah (peace_be_upon_him) said to me: May I not teach you phrases which you utter in distress? (These are:) "Allah , Allah is my Lord, I do not associate anything as partner with Him."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1521]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1521

Narrated AbuMusa al-Ash'ari:

Once we accompanied the Apostle of Allah (peace_be_upon_him) on a journey. When we reached near Medina, the people began to say aloud: "Allah is most great," and they raised their voice.

The Apostle of Allah (peace_be_upon_him) said: O people, you are not supplicating one who is deaf and absent, but you are supplicating One Who is nearer to you than the neck of your riding beast.

The Apostle of Allah (peace_be_upon_him) then said: AbuMusa, should I not point out to you one of the treasures of Paradise?

I asked: What is that?

He replied: "There is no might and there is no power except in Allah"


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1525]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1525

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone invokes blessings on me once, Allah will bless him ten times.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1528]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1528

Narrated Jabir ibn Abdullah:

A woman said to the Prophet (peace_be_upon_him): Invoke blessing on me as well as on my husband. The Prophet (peace_be_upon_him) said: May Allah send blessing on you and your husband.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1530]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1530

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: The supplication which gets the quickest answer is that made by one distant Muslim for another.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1531]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1531

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Three supplications are answered, there being no doubt about them; that of a father, that of a traveller and that of one who has been wronged.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1532]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1532

Narrated AbuMusa al-Ash'ari:

When the Prophet (peace_be_upon_him) feared a (group of) people, he would say: "O Allah, we make Thee our shield against them, and take refuge in Thee from their evils."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1534]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1534

Narrated Umar ibn al-Khattab:

The Prophet (peace_be_upon_him) used to seek refuge in Allah from five things; cowardliness, niggardliness, the evils of old age, evil thoughts, and punishment in the grave.


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1539]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1539

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) used to say: "O Allah, I seek refuge in Thee from poverty", lack and abasement, and I seek refuge in Thee lest I cause or suffer wrong."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1541]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1541

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to supplicate by saying: "O Allah, I seek refuge in Thee from divisiveness, hypocrisy, and evil character."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1542]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1542

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to say: "O Allah, I seek refuge in Thee from hunger, for it is an evil bed-fellow; and I seek refuge in Thee from treachery, for it is an evil hidden trait."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1543]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1543

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to say: "O Allah, I seek refuge in Thee from four things: Knowledge which does not profit, a heart which is not submissive, a soul which has an insatiable appetite, and a supplication which is not heard."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1546]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1546

Narrated Shakl ibn Humayd:

I said: Apostle of Allah, teach me a supplication.

He said: Say: "O Allah, I seek refuge in Thee from the evil of what I hear, from the evil of what I see, from the evil of what I speak, from the evil of what I think, and from the evil of my semen" (i.e. sexual passion).


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1547]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1547

Narrated AbulYusr:

The Apostle of Allah (peace_be_upon_him) used to supplicate: "O Allah, I seek refuge in Thee from my house falling on me, I seek refuge in Thee from falling into an abyss, I seek refuge in Thee from drowning burning and decrepitude. I seek refuge in Thee from the devil harming me at the time of my death, I seek refuge in Thee from dying in Thy path while retreating, and I seek refuge in Thee from dying of the sting of a poisonous creature."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1549]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1549

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) used to say: "O Allah, I seek refuge in Thee from leprosy, madness, elephantiasis, and evil diseases."


Dawud :: Prayer (Kitab Al-Salat): Detailed Injunctions about Witr :: [8.1550]

Prayer (Kitab Al-Salat): Detailed Injunctions about Witr

Dawud :: Book 8 : Hadith 1550

Narrated AbuSa'id al-Khudri:

One day the Apostle of Allah (peace_be_upon_him) entered the mosque. He saw there a man from the Ansar called AbuUmamah.

He said: What is the matter that I am seeing you sitting in the mosque when there is no time of prayer?

He said: I am entangled in cares and debts, Apostle of Allah.

He replied: Shall I not teach you words by which, when you say them, Allah will remove your care, and settle your debt?

He said: Why not, Apostle of Allah?

He said: Say in the morning and evening: "O Allah, I seek refuge in Thee from care and grief, I seek refuge in Thee from incapacity and slackness, I seek refuge in Thee from cowardice and niggardliness, and I seek in Thee from being overcome by debt and being put in subjection by men."

He said: When I did that Allah removed my care and settled my debt.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1554]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1554

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: There is no zakat payable (on grain or dates) on less than five camel-loads. The wasq (one camel-load) measures sixty sa' in weight.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1556]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1556

Narrated Imran ibn Husayn:

Habib al-Maliki said: A man said to Imran ibn Husayn: AbuNujayd, you narrate to us traditions whose basis we do not find in the Qur'an.

Thereupon, Imran got angry and said to the man: Do you find in the Qur'an that one dirham is due on forty dirhams (as Zakat), and one goat is due on such-and-such number of goats, and one camel will be due on such-and-such number of camels?

He replied: No.

He said: From whom did you take it? You took it from us, from the Apostle of Allah (peace_be_upon_him).

He mentioned many similar things.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1557]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1557

Narrated Samurah ibn Jundub:

The Apostle of Allah (peace_be_upon_him) used to order us to pay the sadaqah (zakat) on what we prepared for trade.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1558]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1558

Narrated Abdullah ibn Amr ibn al-'As:

A woman came to the Apostle of Allah (peace_be_upon_him) and she was accompanied by her daughter who wore two heavy gold bangles in her hands. He said to her: Do you pay zakat on them? She said: No. He then said: Are you pleased that Allah may put two bangles of fire on your hands?

Thereupon she took them off and placed them before the Prophet (peace_be_upon_him) saying: They are for Allah and His Apostle.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1559]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1559

Narrated Umm Salamah, Ummul Mu'minin:

I used to wear gold ornaments. I asked: Is that a treasure (kanz), Apostle of Allah? He replied: whatever reaches a quantity on which zakat is payable is not a treasure (kanz) when the zakat is paid.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1563]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1563

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) wrote a letter about sadaqah (zakat) but he died before he could send it to his governors. He had kept it with his sword. So AbuBakr acted upon it till he died, and then Umar acted upon it till he died.

It contained: "For five camels one goat is to be given; for ten camels two goats are to be given; for fifteen camels three goats are to be given; for twenty camels four goats are to be given; for twenty-five to thirty-five camels a she-camel in her second year is to be given. If the number exceeds by one up to seventy camels, a she-camel in her fourth year is to be given; if they exceed by one up to seventy-five camels, a she-camel in her fifth year is to be given; if they exceed by one up to ninety camels, two she-camels in their third year are to be given; if they exceed by one up to one hundred and twenty, two she-camels in their fourth year are to be given. If the camels are more than this, a she-camel in her fourth year is to be given for every fifty camels, and a she-camel in her third year is to be given for every forty camels.

For forty to one hundred and twenty goats one goat is to be given; if they exceed by one up to two hundred, two goats are to be given. If they exceed by one up to three hundred, three goats are to be given; if the goats are more than this, one goat for every hundred goats is to be given. Nothing is payable until they reach one hundred. Those which are in one flock are not to be separated, and those which are in separate flocks are not be brought together from fear of sadaqah (zakat). Regarding that which belongs to two partners, they can make claims for restitution from each other with equity. An old goat and a defective one are not to be accepted as sadaqah (zakat)."

Az-Zuhri said: When the collector comes, the goats will be apportioned into three flocks: one containing bad, the second good, and the third moderate. The collector will take zakat from the moderate. Az-Zuhri did not mention the cows (to be apportioned in three flocks).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1567]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1567

Narrated Ali ibn AbuTalib:

Al-Harith al-A'war reported from Ali. Zuhayr said: I think, the Prophet (peace_be_upon_him) said: "Pay a fortieth. A dirham is payable on every forty, but you are not liable for payment until you have accumulated two hundred dirhams. When you have two hundred dirhams, five dirhams are payable, and that proportion is applicable to larger amounts.

"Regarding sheep, for every forty sheep up to one hundred and twenty, one sheep is due. But if you possess only thirty-nine, nothing is payable on them." He further narrated the tradition about the sadaqah (zakat) on sheep like that of az-Zuhri.

"Regarding cattle, a yearling bull calf is payable for every thirty, and a cow in her third year for forty, and nothing is payable on working animals.

Regarding (the zakat on) camels, he mentioned the rates that az-Zuhri mentioned in his tradition. He said: "For twenty-five camels, five sheep are to be paid. If they exceed by one, a she-camel in her second year is to be given. If there is no she-camel in her second year, a male camel in its third year is to be given, up to thirty-five. If they exceed by one a she-camel in her third year is to be given, up to forty-five. If they exceed by one, a she-camel in her fourth year which is ready to be covered by a bull-camel is to be given." He then transmitted the rest of the tradition like that of az-Zuhri.

He continued: If they exceed by one, i.e. they are ninety-one to hundred and twenty, two she-camels in their fourth year, which are ready to be covered by a bull-camel, are to be given. If there are more camels than that, a she-camel in her fourth year is to be given for every fifty. Those which are in one flock are not to be separated, and those which are separate are not to be brought together. An old sheep, one with a defect in the eye, or a billy goat is not to be accepted as a sadaqah unless the collector is willing.

As regards agricultural produce, a tenth is payable on that which is watered by rivers or rain, and a twentieth on that which is watered by draught camels."

The version of Asim and al-Harith says: "Sadaqah (zakat) is payable every year." Zuhayr said: I think he said "Once a year".

The version of Asim has the words: "If a she-camel in her second year is not available among the camels, nor is there a bull-camel in its third year, ten dirhams or two goats are to be given."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1568]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1568

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: "When you possess two hundred dirhams and one year passes on them, five dirhams are payable. Nothing is incumbent on you, that is, on gold, till it reaches twenty dinars. When you possess twenty dinars and one year passes on them, half a dinar is payable. Whatever exceeds, that will be reckoned properly."

(The narrator said: I do not remember whether the words "that will be reckoned properly" were uttered by All himself or he attributed them to the Prophet (peace_be_upon_him).

No zakat is payable on property till a year passes on it.

But Jarir said: Ibn Wahb (sub-narrator) added to this tradition from the Prophet (peace_be_upon_him): "No zakat is payable on property until a year passes away on it."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1569]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1569

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: I have given exemption regarding horses and slaves; with regard to coins, however, you must pay a dirham for every forty (dirhams), but nothing is payable on one hundred and ninety. When the total reaches two hundred, five dirhams are payable.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1570]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1570

Narrated Mu'awiyah ibn Haydah:

The Apostle of Allah (peace_be_upon_him) said: For forty pasturing camels, one she-camel in her third year is to be given. The camels are not to be separated from reckoning. He who pays zakat with the intention of getting reward will be rewarded. If anyone evades zakat, we shall take half the property from him as a due from the dues of our Lord, the Exalted. There is no share in it (zakat) of the descendants of Muhammad (peace_be_upon_him).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1571]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1571

Narrated Mu'adh ibn Jabal:

When the Prophet (peace_be_upon_him) sent him to the Yemen, he ordered him to take a male or a female calf a year old for every thirty cattle and a cow in its third year for every forty, and one dinar for every adult (unbeliever as a poll-tax) or cloths of equivalent value manufactured in the Yemen.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1574]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1574

Narrated Someone who accompanied the collector of the Prophet:

Suwayd ibn Ghaflah said: I went myself or someone who accompanied the collector of the Prophet (peace_be_upon_him) told me: It was recorded in the document written by the Apostle of Allah (peace_be_upon_him) not to accept a milking goat or she-camel or a (suckling) baby (as zakat on animals); and those which are in separate flocks are not to be brought together, and those which are in one flock are not to be separated.

The collector used to visit the water-hole when the sheep went there and say: Pay the sadaqah (zakat) on your property. The narrator said: A man wanted to give him his high-humped camel (kawma'). The narrator (Hilal) asked: What is kawma', AbuSalih? He said: A camel a high hump.

The narrator continued: He (the collector) refused to accept it. He said: I wish you could take the best of my camels. He refused to accept it. He then brought another camel lower in quality than the previous one. He refused to accept it too. He then brought another camel lower in quality than the previous one. He accepted it, saying: I shall take it, but I am afraid the Apostle of Allah (peace_be_upon_him) might be angry with me, saying to me: You have purposely taken from a man a camel of your choice.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1576]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1576

Narrated Sa'r ibn Disam:

Muslim ibn Shu'bah said: Nafi' ibn Alqamah appointed my father as charge d'affaires of his tribe, and commanded him to collect sadaqah (zakat) from them. My father sent me to a group of them; so I came to an aged man called Sa'r ibn Disam

I said: My father has sent me to you to collect zakat from you. He asked: What kind of animals will you take, my nephew? I replied: We shall select the sheep and examine their udders. He said: My nephew, I shall narrate a tradition to you. I lived on one of these steppes during the time of the Apostle of Allah (peace_be_upon_him) along with my sheep. Two people riding a camel came to me.

They said to me: We are messengers of the Apostle of Allah (peace_be_upon_him), sent to you so that you may pay the sadaqah (zakat) on your sheep.

I asked: What is due from me for them?

They said: One goat. I went to a goat which I knew was full of milk and fat, and I brought it to them.

They said: This is a pregnant goat. The Apostle of Allah (peace_be_upon_him) prohibited us to accept a pregnant goat.

I asked: What will you take then? They said: A goat in its second year or a goat in its third year. I then went to a goat which had not given birth to any kid, but it was going to do so. I brought it to them.

They said: Give it to us. They took it on the camel and went away.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1577]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1577

Narrated Abdullah ibn Mu'awiyah al-Ghadiri:

AbuDawud said: I read in a document possessed by Abdullah ibn Salim at Hims: Abdullah ibn Mu'awiyah al-Ghadiri reported the Prophet (peace_be_upon_him) as saying: He who performs three things will have the taste of the faith. (They are:) One who worships Allah alone and one believes that there is no god but Allah; and one who pays the zakat on his property agreeably every year. One should not give an aged animal, nor one suffering from itch or ailing, and one most condemned, but one should give animals of medium quality, for Allah did not demand from you the best of your animals, nor did He command you to give the animals of worst quality.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1578]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1578

Narrated Ubayy ibn Ka'b:

The Apostle of Allah (peace_be_upon_him) commissioned me as a collector of zakat. I visited a man. When he had collected his property of camels, I found that a she-camel in her second year was due from him.

I said to him: Pay a she-camel in her second year, for she is to be paid as sadaqah (zakat) by you.

He said: That one is not worthy of milking and riding. Here is another she-camel which is young, grand and fat. So take it.

I said to him: I shall not take an animal for which I have not been commanded. The Apostle of Allah (peace_be_upon_him) is here near to you. If you like, go to him, and present to him what you presented to me. Do that; if he accepts it from you, I shall accept it; if he rejects it, I shall reject it.

He said: I shall do it. He accompanied me and took with him the she-camel which he had presented to me. We came to the Apostle of Allah (peace_be_upon_him). He said to him: Prophet of Allah, your messenger came to me to collect zakat on my property. By Allah, neither the Apostle of Allah nor his messenger has ever seen my property before. I gathered my property (camels), and he estimated that a she-camel in her second year would be payable by me. But that has neither milk nor is it worth riding. So I presented to him a grand young she-camel for acceptance as zakat. But he has refused to take her. Look, she is here; I have brought her to you, Apostle of Allah. Take her.

The Apostle of Allah (peace_be_upon_him) said: That is what is due from you. If you give voluntarily a better (animal) Allah will give a reward to you for it. We accept her from you.

She is here, Apostle of Allah; I have brought her to you. So take her. The Apostle of Allah (peace_be_upon_him) then ordered me to take possession of it, and he prayed for a blessing on his property.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1580]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1580

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: He who collects more sadaqah than is due is like him who refuses to pay it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1581]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1581

Narrated Bashir ibn al-Khasasiyyah:

(Ibn Ubayd said in the version of his tradition that his name was not Bashir, but (it was) the Apostle of Allah (peace_be_upon_him) (who had) named him Bashir)

We said: (to the Apostle of Allah): The collectors of sadaqah collect more than is due; can we hide our property to that proportion? He replied: "No."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1583]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1583

Narrated Jabir ibn Atik:

The Prophet (peace_be_upon_him) said: Riders who are objects of dislike to you will come to you, but you must welcome them when they come to you, and give them a free hand regarding what they desire. If they are just, they will receive credit for it, but if they are unjust, they will be held responsible. Please them, for the perfection of your zakat consists in their good pleasure, and let them ask a blessing for you .


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1587]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1587

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: There is to be no collecting of sadaqah (zakat) from a distance, nor must people who own property remove it far away, and their sadaqahs are to be received in their dwelling.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1590]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1590

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: No sadaqah is due on a horse or a slave except that given at the breaking of the fast (at the end of Ramadan).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1595]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1595

Narrated Mu'adh ibn Jabal:

When the Apostle of Allah (peace_be_upon_him) sent him to the Yemen, he said (to him): Collect corn from the corn, sheep from the sheep, camel from the camels, and cow from the cows.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1596]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1596

Narrated Abdullah ibn Amr Ibn al-'As:

Hilal, a man from the tribe of Banu Mat'an brought a tenth of honey which he possessed in beehives to the Apostle of Allah (peace_be_upon_him). He asked him (the apostle of Allah) to give the wood known as Salabah as a protected (or restricted) land.

The Apostle of Allah (peace_be_upon_him) gave him that wood as a protected land.

When Umar ibn al-Khattab succeeded, Sufyan ibn Wahb wrote to Umar asking him about this wood. Umar ibn al-Khattab wrote to him: If he (Hilal) pays you the tithe on honey what he used to pay to the Apostle of Allah (peace_be_upon_him), leave the protected land of Salabah in his possession; otherwise those bees are like those of any wood; anyone can take the honey as he likes.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1597]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1597

Narrated Abdullah ibn Amr ibn al-'As:

Banu Shababah were a sub-clan of the tribe Fahm. (They used to pay) one bag (of honey) out of ten bags. Sufyan ibn Abdullah ath-Thaqafi gave them two woods as protected lands. They used to give as much honey (as zakat) as they gave to the Apostle of Allah (peace_be_upon_him). He (Sufyan) used to protect their woods.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1599]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1599

Narrated Attab ibn Usayd:

The Apostle of Allah (peace_be_upon_him) commanded to estimate vines (for collecting zakat) as palm-trees are estimated. The zakat is to be paid in raisins as the zakat on palm trees is paid in dried dates.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1601]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1601

Narrated Sahl ibn AbuHathmah:

AbdurRahman ibn Mas'ud said: Sahl ibn AbuHathmah came to our gathering. He said: The Apostle of Allah (peace_be_upon_him) commanding us said: When you estimate take them leaving a third, and if you do not leave or find a third, leave a quarter.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1602]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1602

Narrated Aisha, Ummul Mu'minin:

Describing the conquest of Khaybar Aisha said: The Prophet (peace_be_upon_him) used to send Abdullah ibn Rawahah to the Jews of Khaybar, and he would make an estimate of the palm trees when the fruit was in good condition before any of it was eaten.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1603]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1603

Narrated Sahl ibn Hunayf:

The Apostle of Allah (peace_be_upon_him) prohibited to accept ja'rur and habiq dates as zakat. Az-Zuhri said: These are two kinds of the dates of Medina.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1604]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1604

Narrated Awf ibn Malik:

The Apostle of Allah (peace_be_upon_him) entered upon us in the mosque, and he had a stick in his hand. A man hung there a bunch of hashaf. He struck the bunch with the stick, and said: If the owner of this sadaqah (alms) wishes to give a better one than it, he would give. The owner of this sadaqah will eat hashaf on the Day of Judgment.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1605]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1605

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) prescribed the sadaqah (alms) relating to the breaking of the fast as a purification of the fasting from empty and obscene talk and as food for the poor. If anyone pays it before the prayer (of 'Id), it will be accepted as zakat. If anyone pays it after the prayer, that will be a sadaqah like other sadaqahs (alms).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1610]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1610

Narrated Abdullah ibn Umar:

The people during the lifetime of the Apostle of Allah (peace_be_upon_him) used to bring forth the sadaqah at the end of Ramadan when closing the fast one sa' of barley whose straw is removed, or of raisins. Abdullah said: When Umar (Allah be pleased with him) succeeded, and the wheat became abundant, Umar prescribed half a sa' of wheat instead of all these things.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1614]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1614

Narrated AbuSa'id al-Khudri:

I shall always pay one sa'. We used to pay during the lifetime of the Apostle of Allah (peace_be_upon_him) one sa' of dried dates or of barley, or of cheese, or of raisins. This is the version of Yahya. Sufyan added in his version: "or one sa' of flour." The narrator Hamid (ibn Yahya) said: The people objected to this (addition); Sufyan then left it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1615]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1615

Narrated Tha'labah ibn Su'ayr:

The Apostle of Allah (peace_be_upon_him) said: One sa' of wheat is to be taken from every two, young or old, freeman or slave, male or female. Those of you who are rich will be purified by Allah, and those of you who are poor will have more than they gave returned by Him to them. Sulayman added in his version: "rich or poor"


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1616]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1616

Narrated Tha'labah ibn Su'ayr:

The Apostle of Allah (peace_be_upon_him) stood and gave a sermon; he commanded to give sadaqah, at the end of Ramadan when the fasting is closed, one sa' of dried dates or of barley payable by every person. The narrator Ali added in his version: "or one sa' of wheat to be taken from every two." Both the chains of narrators are then agreed upon the version: "payable by young and old, freeman and slave."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1618]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1618

Narrated Abdullah ibn Abbas:

Al-Hasan said: Ibn Abbas preached towards the end of Ramadan on the pulpit (in the mosque) of al-Basrah. He said: Bring forth the sadaqah relating to your fast. The people, as it were, could not understand. Which of the people of Medina are present here? Stand for your brethren, and teach them, for they do not know.

The Apostle of Allah (peace_be_upon_him) prescribed this sadaqah as one sa' of dried dates or barley, or half a sa' of wheat payable by every freeman or slave, male or female, young or old. When Ali came (to Basrah), he found that price had come down. He said: Allah has given prosperity to you, so give one sa' of everything (as sadaqah).

The narrator Humayd said: Al-Hasan maintained that the sadaqah at the end of Ramadan was due on a person who fasted.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1620]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1620

Narrated Ali ibn AbuTalib:

Al-Abbas asked the Prophet (peace_be_upon_him) about paying the sadaqah (his zakat) in advance before it became due, and he gave permission to do that.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1621]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1621

Narrated Imran ibn Husayn:

Ibrahim ibn Ata, the client of Imran ibn Husayn, reported on the authority of his father: Ziyad, or some other governor, sent Imran ibn Husayn to collect sadaqah (i.e. zakat). When he returned, he asked Imran: Where is the property? He replied: Did you send me to bring the property? We collected it from where we used to collect in the lifetime of the Apostle of Allah (peace_be_upon_him), and we spent it where we used to spend during the time of the Apostle of Allah (peace_be_upon_him).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1622]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1622

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: He who begs (from people) when he is affluent will come on the Day of Resurrection with scrapes, scratchings, or lacerations on his face. He was asked: What constitutes affluence, Apostle of Allah? He replied:It is fifty dirhams or its value in gold. The narrator Yahya said: Abdullah ibn Sufyan said to Sufyan: I remember that Shu'bah does not narrate from Hakim ibn Jubayr. Sufyan said: Zubayr transmitted to us this tradition from Muhammad ibn AbdurRahman ibn Yazid.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1624]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1624

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: If anyone begs when he has something equivalent to an uqiyah in value, he has begged immoderately. So I said: My she-camel, Yaqutah, is better than an uqiyah. The version of Hisham goes: "better than forty dirhams. So I returned and did not beg anything from him." Hisham added in his version: "An uqiyah during the time of the Apostle of Allah (peace_be_upon_him) was equivalent to forty dirhams."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1625]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1625

Narrated Sahl ibn Hanzaliyyah:

Uyaynah ibn Hisn and Aqra' ibn Habis came to the Apostle of Allah (peace_be_upon_him). They begged from him. He commanded to give them what they begged. He ordered Mu'awiyah to write a document to give what they begged. Aqra' took his document, wrapped it in his turban, and went away.

As for Uyaynah, he took his document and came to the Prophet (peace_be_upon_him) at his home, and said to him: Muhammad, do you see me? I am taking a document to my people, but I do not know what it contains, just like the document of al-Mutalammis. Mu'awiyah informed the Apostle of Allah (peace_be_upon_him) of his statement.

Thereupon the Apostle of Allah (peace_be_upon_him) said: He who begs (from people) when he has sufficient is simply asking for a large amount of Hell-fire. (An-Nufayl (a transmitter) said elsewhere: "embers of Hell".)

They asked: Apostle of Allah, what is a sufficiency? (Elsewhere an-Nufayl said: What is a sufficiency which makes begging unfitting?)

He replied: It is that which would provide a morning and an evening meal. (Elsewhere an-Nufayl said: It is when one has enough for a day and night, or for a night and a day.) He (an-Nufayl) narrated to us this tradition briefly in the words that I have mentioned.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1626]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1626

Narrated Ziyad ibn al-Harith as-Suda'i:

I came to the Apostle of Allah (peace_be_upon_him) and swore allegiance to him, and after telling a long story he said: Then a man came to him and said: Give me some of the sadaqah (alms). The Apostle of Allah (peace_be_upon_him) said: Allah is not pleased with a Prophet's or anyone else's decision about sadaqat till He has given a decision about them Himself. He has divided those entitled to them into eight categories, so if you come within those categories, I shall give you what you desire.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1628]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1628

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said something similar as mentioned in the preceding tradition. This version adds: But the poor man (miskin) who abstains from begging from the people is one (according to the version of Musaddad who does not get enough so that he may not beg from the people, nor is his need known to the people, so that alms be given to him. This is the one who has been deprived.

Musaddad did not mention the words "one who avoids begging from the people."


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1629]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1629

Narrated Ubaydullah ibn Adl ibn al-Khiyar:

Two men informed me that they went to the Prophet (peace_be_upon_him) when he was at the Farewell Pilgrimage while he was distributing the sadaqah and asked him for some of it. He looked us up and down, and seeing that we were robust, he said: If you wish, I shall give you something, but there is nothing spare in it for a rich man or for one who is strong and able to earn a living.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1630]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1630

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Sadaqah may not be given to a rich man or to one who has strength and is sound in limbs.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1631]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1631

Narrated Ata ibn Yasar:

The Prophet (peace_be_upon_him) said: Sadaqah may not be given to rich man, with the exception of five classes: One who fights in Allah's path, or who collects it, or a debtor, or a man who buys it with his money, or a man who has a poor neighbour who has been given sadaqah and gives a present to the rich man.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1635]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1635

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: Acts of begging are lacerations with which a man disfigures his face, so he who wishes may preserve his self-respect, and he who wishes may abandon it; but this does not apply to one who begs from a ruler, or in a situation which makes it necessary.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1637]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1637

Narrated Anas ibn Malik:

A man of the Ansar came to the Prophet (peace_be_upon_him) and begged from him.

He (the Prophet) asked: Have you nothing in your house? He replied: Yes, a piece of cloth, a part of which we wear and a part of which we spread (on the ground), and a wooden bowl from which we drink water.

He said: Bring them to me. He then brought these articles to him and he (the Prophet) took them in his hands and asked: Who will buy these? A man said: I shall buy them for one dirham. He said twice or thrice: Who will offer more than one dirham? A man said: I shall buy them for two dirhams.

He gave these to him and took the two dirhams and, giving them to the Ansari, he said: Buy food with one of them and hand it to your family, and buy an axe and bring it to me. He then brought it to him. The Apostle of Allah (peace_be_upon_him) fixed a handle on it with his own hands and said: Go, gather firewood and sell it, and do not let me see you for a fortnight. The man went away and gathered firewood and sold it. When he had earned ten dirhams, he came to him and bought a garment with some of them and food with the others.

The Apostle of Allah (peace_be_upon_him) then said: This is better for you than that begging should come as a spot on your face on the Day of Judgment. Begging is right only for three people: one who is in grinding poverty, one who is seriously in debt, or one who is responsible for compensation and finds it difficult to pay.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1641]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1641

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: If one who is afflicted with poverty refers it to me, his poverty will not be brought to an end; but if one refers it to Allah, He will soon give him sufficiency, either by a speedy death or by a sufficiency which comes later.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1642]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1642

Narrated Ibn al-Firasi:

Al-Firasi asked the Apostle of Allah (peace_be_upon_him): May I beg, Apostle of Allah? The Prophet (peace_be_upon_him) said: No, but if there is no escape from it, beg from the upright.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1645]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1645

Narrated Malik ibn Nadlah:

The Prophet (peace_be_upon_him) said: Hands are of three types: Allah's hand is the upper one; the bestower's hand is the one near it; the beggar's hand is the lower one. So bestow what is surplus, and do not submit yourself to the demand of your soul.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1646]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1646

Narrated AbuRafi':

The Prophet (peace_be_upon_him) sent a man of the Banu Makhzum to collect sadaqah. He said to AbuRafi': Accompany me so that you may get some of it. He said: (I cannot take it) until I go to the Prophet (peace_be_upon_him) and ask him. Then he went to him and asked him. He said: The sadaqah is not lawful for us, and the client of a people is treated as one of them.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1649]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1649

Narrated Abdullah ibn Abbas:

My father sent me to the Prophet (peace_be_upon_him) to take the camels which he had given him from among those of sadaqah.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1653]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1653

Narrated Abdullah ibn Mas'ud:

During the time of the Apostle of Allah (peace_be_upon_him) we used to consider ma'un (this of daily use) lending a bucket and cooking-pot.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1656]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1656

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) as saying something similar to this tradition. He (the narrator) said to AbuHurayrah: What is due on camels? He replied: That you should give the best of your camels (in the path of Allah), that you lend a milch she-camel, you lend your mount for riding, that you lend the stallion for covering, and that you give the milk (to the people) for drinking.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1660]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1660

Narrated Abdullah ibn Abbas:

When this verse was revealed: "And those who hoard gold and silver," the Muslims were grieved about it. Umar said: I shall dispel your care. He, therefore, went and said: Prophet of Allah, your Companions were grieved by this verse. The Apostle of Allah (peace_be_upon_him) said: Allah has made zakat obligatory simply to purify your remaining property, and He made inheritances obligatory that they might come to those who survive you. Umar then said: Allah is most great. He then said to him: Let me inform you about the best a man hoards; it is a virtuous woman who pleases him when he looks at her, obeys him when he gives her a command, and guards his interests when he is away from her.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1661]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1661

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: A beggar has the right though he may be riding (a horse).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1663]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1663

Narrated Umm Bujayd:

She took the oath of allegiance to the Apostle of Allah (peace_be_upon_him) and said to him: Apostle of Allah, a poor man stands at my door, but I find nothing to give him. The Apostle of Allah (peace_be_upon_him) said to her: If you do not find anything to give him, put something in his hand, even though it should be a burnt hoof.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1665]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1665

Narrated Buhaysah al-Fazariyyah:

My father sought permission from the Prophet (peace_be_upon_him). (When permission was granted and he came near him) he lifted his shirt, and began to kiss him and embrace him (out of love for him). He asked: Apostle of Allah, what is the thing which it is unlawful to refuse? He replied: Water. He again asked: Prophet of Allah, what is the thing which it is unlawful to refuse? He replied: Salt. He again asked: Prophet of Allah, what is the thing which it is unlawful to refuse? He said: To do good is better for you.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1667]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1667

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Nothing but Paradise must be begged for Allah's sake.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1668]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1668

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: If anyone seeks protection in Allah's name, grant him protection; if anyone begs in Allah's name, give him something; if anyone gives you an invitation, accept it; and if anyone does you a kindness, recompense him; but if you have not the means to do so, pray for him until you feel that you have compensated him.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1669]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1669

Narrated Jabir ibn Abdullah:

While we were sitting with the Apostle of Allah (peace_be_upon_him) a man brought him some gold equal in weight to an egg, and said: Apostle of Allah, I have got this from a mine; take it; it is sadaqah. I have no more than this. The Apostle of Allah (peace_be_upon_him) turned his attention from him. Then he came to him from his right side and repeated the same words. But he (the Prophet) turned his attention from him. He then came to him from his left side and repeated the same words. But he (again) turned his attention from him. He then came to him from behind. The Apostle of Allah (peace_be_upon_him) took it and threw it away. Had it hit him, it would have hurt him or wounded him. The Apostle of Allah (peace_be_upon_him) said: One of you brings all that he possesses and says: This is sadaqah. Then he sits down and spreads his hand before the people. The best sadaqah is that which leaves a competence.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1671]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1671

Narrated AbuSa'id al-Khudri:

A man entered the mosque. The Prophet (peace_be_upon_him) commanded the people to throw their clothes as sadaqah. Thereupon they threw their clothes (as sadaqah). He then asked him to take two clothes from them. He reprimanded him and said: Take your clothe.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1674]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1674

Narrated Umar ibn al-Khattab:

The Apostle of Allah (peace_be_upon_him) commanded us one day to give sadaqah. At that time I had some property. I said: Today I shall surpass AbuBakr if I surpass him any day. I, therefore, brought half my property. The Apostle of Allah (peace_be_upon_him) asked: What did you leave for your family? I replied: The same amount. AbuBakr brought all that he had with him. The Apostle of Allah (peace_be_upon_him) asked him: What did you leave for your family? He replied: I left Allah and His Apostle for them. I said: I shall never compete you in anything.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1677]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1677

Narrated Sa'd ibn Ubadah:

Sa'd asked: Apostle of Allah, Umm Sa'd has died; what form of sadaqah is best? He replied: Water (is best). He dug a well and said: It is for Umm Sa'd.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1678]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1678

Narrated AbuSa'id (al-Khudri):

The Prophet (peace_be_upon_him) said: If any Muslim clothes a Muslim when he is naked, Allah will clothe him with some green garments of Paradise; if any Muslim feeds a Muslim when he is hungry, Allah will feed him with some of the fruits of Paradise; and if any Muslim gives a Muslim drink when he is thirsty, Allah will give him some of the pure wine which is sealed to drink.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1679]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1679

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: There are forty characteristics; the highest of them is to give a goat on loan (for benefiting from its milk). If any man carries out any of those characteristics with the hope of getting a reward and testifying to the promise for it, Allah will admit him to Paradise for it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1687]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1687

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) commanded to give sadaqah. A man said: Apostle of Allah, I have a dinar. He said: Spend it on yourself. He again said: I have another. He said: Spend it on your children. He again said: I have another. He said: Spend it on your wife. He again said: I have another. He said: Spend it on your servant. He finally said: I have another. He replied: You know best (what to do with it).


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1690]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1690

Narrated AbdurRahman ibn Awf:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah the Exalted has said: I am Compassionate, and this has been derived from mercy. I have derived its name from My name. If anyone joins it, I shall join him, and if anyone cuts it off, I shall cut him off.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1694]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1694

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) preached and said: Abstain from avarice, for those who had been before you were annihilated due to avarice. It (avarice) commanded them to show niggardliness; it commanded them to cut off their relationship with their nearest relatives, so they cut off. It commanded them to show profligacy, so they showed it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1696]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1696

Narrated Aisha, Ummul Mu'minin:

AbuMulaykah reported: Aisha counted a number of indigents. AbuDawud said: The other version has: She counted a number of sadaqahs. The Apostle of Allah (peace_be_upon_him) said: Give and do not calculate, so calculation will be made against you.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1697]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1697

Narrated Ubayy ibn Ka'b:

Suwayd ibn Ghaflah said: I fought along with Zayd ibn Suhan and Sulayman ibn Rabi'ah. I found a whip. They said to me: Throw it away. I said: No; if I find its owner (I shall give it to him); if not, I shall use it. Then I performed hajj; and when I reached Medina, I asked Ubayy ibn Ka'b.

He said: I found a purse which contained one hundred dinars; so I came to the Prophet (peace_be_upon_him). He said to me: Make the matter known for a year. I made it known for a year and then came to him. He then said to me: Make the matter known for a year. So I made it known for a year. I then (again) came to him. He said to me: Make the matter known for a year. Then I came to him and said: I did not find anyone who realises it. He said: Remember, its number, its container and its tie. If its owner comes, (give it to him), otherwise use it yourself.

He (the narrator Shu'bah) said: I do not know whether he said the word "make the matter known" three times or once.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1702]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1702

Narrated Zayd ibn Khalid al-Juhani:

The Apostle of Allah (peace_be_upon_him) was asked about a find. He said: Make it known for a year. If its seeker comes, deliver it to him, otherwise note its container and its string. Then use it; if its seeker comes, deliver it to him.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1705]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1705

Narrated Iyad ibn Himar:

The Prophet (peace_be_upon_him) said: He who finds something should call one or two trusty persons as witnesses and not conceal it or cover it up; then if he finds its owner he should return it to him, otherwise it is Allah's property which He gives to whom He will.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1706]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1706

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) was asked about the hanging fruit. He replied: If a needy person takes some and does not take a supply away in his garment, he is not to be blamed, but he who carries any of it away is to be find twice the value and punished, and he who steals any of it after it has been put in the place where dates are dried is to have his hand cut off if its value reaches the price of a shield. Regarding stray camels and sheep he mentioned the same as others have done. He said: He was asked about finds and replied: If it is in a frequented road and a large town, make the matter known for a year, and if its owner comes, give it to him, but if he does not, it belongs to you. If it is in a place which has been a waste from ancient time, or if it is a hidden treasure (belonging to the Islamic period), it is subject to the payment of the fifth.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1710]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1710

Narrated AbuSa'id al-Khudri:

Ali ibn AbuTalib found a dinar and he took it to Fatimah. She asked the Apostle of Allah (peace_be_upon_him) about it. He said: This is Allah's provision. Then the Apostle of Allah (peace_be_upon_him) ate out of the food (bought with it), and Ali and Fatimah also ate out of that food. But afterwards a woman came crying out about the dinar. The Prophet (peace_be_upon_him) said: Pay the dinar, Ali.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1711]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1711

Narrated Ali ibn AbuTalib:

Bilal ibn Yahya al-Absi said: Ali found a dinar and purchased some flour with it. The seller of the flour recognised him and returned the dinar to him. Ali took it, deducted two qirat (carat) from it, and purchased meat with it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1713]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1713

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) gave us licence to use (for our purpose) a stick, a rope, a whip and things of that type which a man picked up; he may benefit from them.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1714]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1714

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who hides a stray camel shall pay a fine, and a like compensation with it.


Dawud :: Zakat (Kitab Al-Zakat) :: [9.1716]

Zakat (Kitab Al-Zakat)

Dawud :: Book 9 : Hadith 1716

Narrated Al-Mundhir ibn Jarir:

I accompanied Jarir at Bawazij. The shepherd brought the cows. Among them there was a cow that was not one of them. Jarir asked him: What is this? He replied: This was mixed with the cows and we do not know to whom it belongs. Jarir said: Take it out. I heard the Apostle of Allah (peace_be_upon_him) say: No one mixes a stray animal (with his animals) but a man who strays from right path.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1717]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1717

Narrated Aqra' ibn Habib:

Ibn Abbas said: Aqra' ibn Habis asked the Prophet (peace_be_upon_him) saying: Apostle of Allah hajj is to be performed annually or only once? He replied: Only once, and if anyone performs it more often, he performs a supererogatory act.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1718]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1718

Narrated AbuWaqid al-Laythi:

I heard the Apostle of Allah (peace_be_upon_him) saying to his wives during the Farewell Pilgrimage: This (is the pilgrimage for you); afterwards stick to the surface of the mats (i.e. should stay at home).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1725]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1725

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Islam does not allow for failure to perform the hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1727]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1727

Narrated Abdullah ibn Abbas:

Ibn Abbas recited this verse: 'It is no sin for you that you seek the bounty of your Lord', and said: The people would not trade in Mina (during the hajj), so they were commanded to trade when they proceeded from Arafat.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1728]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1728

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: He who intends to perform hajj should hasten to do so.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1729]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1729

Narrated Abdullah ibn Umar:

AbuUmamah at-Taymi said: I was a man who used to give (riding-beasts) on hire for this purpose (for travelling during the pilgrimage) and the people would tell (me): Your hajj is not valid. So I met Ibn Umar and told him: AbuAbdurRahman, I am a man who gives (riding-beast) on hire for this purpose (i.e. for hajj), and the people tell me: Your hajj is not valid. Ibn Umar replied: Do you not put on ihram (the pilgrim dress), call the talbiyah (labbayk), circumambulate the Ka'bah, return from Arafat and lapidate jamrahs? I said: Why not? Then he said: Your hajj is valid. a man came to the Prophet (peace_be_upon_him) and asked him the same question you have asked me. The Apostle of Allah (peace_be_upon_him) kept silence and did not answer him till this verse came down: "It is no sin for you that you seek the bounty of your Lord." The Apostle of Allah (peace_be_upon_him) sent for him and recited this verse to him and said: Your hajj is valid.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1730]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1730

Narrated Abdullah ibn Abbas:

The people used to trade, in the beginning, at Mina, Arafat, the market place of Dhul-Majaz, and during the season of hajj. But (later on) they became afraid of trading while they were putting on ihram. So Allah, glory be to Him, sent down this verse: "It is no sin for you that you seek the bounty of your Lord during the seasons of hajj." Ubayd ibn Umayr told me that he (Ibn Abbas) used to recite this verse in his codex.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1735]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1735

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) appointed Dhat Irq as the place for putting on ihram for the people of Iraq.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1736]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1736

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) appointed al-Aqiq as the place for putting on ihram for the people of East.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1737]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1737

Narrated Umm Salamah, Ummul Mu'minin:

She heard the Apostle of Allah (peace_be_upon_him) say: If anyone puts on ihram for hajj or umrah from the Aqsa mosque to the sacred mosque , his former and latter sins will be forgiven, or he will be guaranteed Paradise. The narrator Abdullah doubted which of these words he said.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1738]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1738

Narrated Al-Harith ibn Amr as-Sahmi:

I came to the Apostle of Allah (peace_be_upon_him) when he was at Mina, or at Arafat. He was surrounded by the people. When the bedouins came and saw his face, they would say: This is a blessed face. He said: He (the Prophet) appointed Dhat Irq as the place of putting on ihram for the people of Iraq.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1740]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1740

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: A menstruating woman and the one who delivered a child should take a bath, put on ihram and perform all the rites of hajj except circumambulation of the House (Ka'bah) when they came to the place of wearing ihram. AbuMa'mar said in his version: "till she is purified". The narrator Ibn Isa did not mention the names of Ikrimah and Mujahid, but he said: from Ata on the authority of Ibn Abbas. Ibn Isa also did not mention the word "all (rites of hajj)." He said in his version: All the rites of hajj except circumambulation of the House (the Ka'bah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1745]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1745

Narrated Abdullah ibn Abbas:

In the year of al-Hudaybiyyah, the Apostle of Allah (peace_be_upon_him) included among his sacrificial animals a camel with a silver nose-ring (Ibn Minhal's version has gold) which had belonged to AbuJahl (the version of an-Nufayli added) "thereby enraging the polytheists".


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1746]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1746

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) sacrificed a cow for his wives at the Farewell Pilgrimage.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1747]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1747

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) sacrificed a cow for his wives who had performed umrah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1752]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1752

Narrated Abdullah ibn Umar:

Umar ibn al-Khattab named a bukhti camel for sacrifice (at hajj). He was offered three hundred dinars for it (as its price). He came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, I named a bukhti camel for sacrifice and I was offered for it three hundred dinars. May I sell it and purchase another one for its price? No, sacrifice it.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1758]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1758

Narrated Najiyah al-Aslami:

The Apostle of Allah (peace_be_upon_him) sent sacrificial camels with him (as offering to the Ka'bah). He then said: If any one of them becomes fatigued, slaughter it, dip its shoes in its blood, and leave it for the people (to eat).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1760]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1760

Narrated Ali ibn AbuTalib:

When the Apostle of Allah (peace_be_upon_him) sacrificed the camels, he sacrificed thirty of them with his own hand, and then commanded me (to sacrifice them), so I sacrificed the rest of them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1761]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1761

Narrated Abdullah ibn Qurt:

The Prophet (peace_be_upon_him) said: The greatest day in Allah's sight is the day of sacrifice and next the day of resting which Isa said on the authority of Thawr is the second day. Five or six sacrificial camels were brought to the Apostle of Allah (peace_be_upon_him) and they began to draw near to see which he would sacrifice first. When they fell down dead, he said something in a low voice, which I could not catch. So I asked: What did he say? He was told that he had said: Anyone who wants can cut off a piece.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1762]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1762

Narrated Arfah ibn al-Harith al-Kandi:

I was present with the Apostle of Allah (peace_be_upon_him) at the Farewell Pilgrimage. When the sacrificial camels were brought to him, he said: Call AbulHasan (Ali) to me. Ali was then called for and he (the Prophet) said to him: Catch hold of the lower end of the lance, and the Apostle of Allah (peace_be_upon_him) himself caught hold of the upper end. He then pierced the camels with it. When he finished slaughtering, he rode on his mule and mounted Ali behind him.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1766]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1766

Narrated Abdullah ibn Abbas:

Sa'id ibn Jubayr said: I said to Abdullah ibn Abbas: AbulAbbas, I am surprised to see the difference of opinion amongst the companions of the Apostle (peace_be_upon_him) about the wearing of ihram by the Apostle of Allah (peace_be_upon_him) when he made it obligatory.

He replied: I am aware of it more than the people. The Apostle of Allah (peace_be_upon_him) performed only one hajj. Hence the people differed among themselves. The Apostle of Allah (peace_be_upon_him) came out (from Medina) with the intention of performing hajj. When he offered two rak'ahs of prayer in the mosque at Dhul-Hulayfah, he made it obligatory by wearing it.

At the same meeting, he raised his voice in the talbiyah for hajj, when he finished his two rak'ahs. Some people heard it and I retained it from him. He then rode (on the she-camel), and when it (the she-camel) stood up, with him on its back, he raised his voice in the talbiyah and some people heard it at that moment. This is because the people were coming in groups, so they heard him raising his voice calling the talbiyah when his she-camel stood up with him on its back, and they thought that the Apostle of Allah (peace_be_upon_him) had raised his voice in the talbiyah when his she-camel stood up with him on its back.

The Apostle of Allah (peace_be_upon_him) proceeded further; when he ascended the height of al-Bayda' he raised his voice in the talbiyah. Some people heard it at that moment. They thought that he had raised his voice in the talbiyah when he ascended the height of al-Bayda'. I swear by Allah, he raised his voice in the talbiyah at the place where he prayed, and he raised his voice in the talbiyah when his she-camel stood up with him on its back, and he raised his voice in the talbiyah when he ascended the height of al-Bayda'.

Sa'id (ibn Jubayr) said; He who follows the view of Ibn Abbas raises his voice in talbiyah (and ihram) at the place of is prayer after he finishes two rak'ahs of his prayer.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1768]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1768

Narrated Abdullah ibn Umar:

Ubayd ibn Jurayj said to Abdullah ibn Umar: AbuAbdurRahman, I saw you doing things which I did not see being done by your companions.

He asked: What are they, Ibn Jurayj? He replied: I saw you touching only the two Yamani corners; and I saw you wearing shoes having no hair; I saw you dyeing in yellow colour; and I saw you wearing ihram on the eighth of Dhul-Hijjah, whereas the people had worn ihram when they sighted the moon.

Abdullah ibn Umar replied: As regards the corners, I have not seen the Apostle of Allah (peace_be_upon_him) touching anything (in the Ka'bah) but the two Yamani corners. As for the tanned leather shoes, I have seen the Apostle of Allah (peace_be_upon_him) wearing tanned leather shoes, and he would wear them after ablution. Therefore I like to wear them. As regards wearing yellow, I have seen the Apostle of Allah (peace_be_upon_him) wearing yellow, so I like to wear with it. As regards shouting the talbiyah, I have seen the Apostle of Allah (peace_be_upon_him) raising his voice in talbiyah when his she-camel stood up with him on its back.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1770]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1770

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) offered the noon prayer, and then rode on his mount. When he came to the hill of al-Bayda', he raised his voice in talbiyah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1771]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1771

Narrated Sa'd ibn AbuWaqqas:

When the Prophet of Allah (peace be upon him0 undertook his journey by the way of al-Far', he shouted talbiyah when his mount stood up with him on its back. But when he travelled by the way of Uhud, he raised his voice in Talbiyah when he ascended the hill of al-Bayda'.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1788]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1788

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) raised his voice in talbiyah for hajj. When he came (to Mecca) he went round the House (the Ka'bah) and ran between as-Safa and al-Marwah. The narrator Ibn Shawkar said: He did not clip his hair, nor did he take off his ihram due to sacrificial animals. But he commanded those who did not bring sacrificial animals with them to go round the Ka'bah, to run between as-Safa and al-Marwah, to clip their hair, and then put off their ihram. The narrator Ibn Mani' added: Or shave their heads, then take off their ihram."


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1789]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1789

Narrated Sa'id ibn al-Musayyab:

A man from the Companions of the Prophet (peace_be_upon_him) came to Umar ibn al-Khattab (may Allah be pleased with him). He bore witness before him that when he (the Prophet) was suffering from a disease of which he died he heard the Apostle of Allah (peace_be_upon_him) prohibiting performing of umrah before hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1790]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1790

Narrated Mu'awiyah ibn AbuSufyan:

Mu'awiyah said to the Companions of the Prophet (peace_be_upon_him): Do you know that the Apostle of Allah (peace_be_upon_him) prohibited from doing so and so (and he prohibited from) riding on the skins of leopards? They said: Yes.

He again said: You know that he prohibited combining hajj and umrah. They replied: This we do not (know). He said: This was prohibited along with other things, but you forgot.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1793]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1793

Narrated Al-Bara' ibn Azib:

I was with Ali (may Allah be pleased with him) when the Apostle of Allah (peace_be_upon_him) appointed him to be the governor of the Yemen. I collected some ounces of gold during my stay with him.

When Ali returned from the Yemen to the Apostle of Allah (peace_be_upon_him) he said: I found that Fatimah had put on coloured clothes and the smell of the perfume she had used was pervading the house. (He expressed his amazement at the use of coloured clothes and perfume.)

She said: What is wrong with you? The Apostle of Allah (peace_be_upon_him) has ordered his companions to put off their ihram and they did so.

Ali said: I said to her: I raised my voice in talbiyah for which the Prophet (peace_be_upon_him) raised his voice (i.e. I wore ihram for qiran). Then I came to the Prophet (peace_be_upon_him).

He asked (me): How did you do? I replied: I raised my voice in talbiyah, for which the Prophet (peace_be_upon_him) raised his voice. He said: I have brought the sacrificial animals with me and combined umrah and hajj. He said to me: Sacrifice sixty-seven or sixty-six camels (for me) and withhold for yourself thirty-three or thirty-four, and withhold a piece (of flesh) for me from every camel.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1794]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1794

Narrated Umar ibn al-Khattab:

As-Subayy ibn Ma'bad said: I raised my voice in talbiyah for both of them (i.e. umrah and hajj). Thereupon Umar said: You were guided to the practice (sunnah) of your Prophet (peace_be_upon_him).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1795]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1795

Narrated As-Subayy ibn Ma'bad:

I was a Christian Bedouin; then I embraced Islam. I came to a man of my tribe, who was called Hudhaym ibn Thurmulah. I said to him. O brother, I am eager to wage war in the cause of Allah (i.e. jihad), and I find that both hajj and umrah are due from me. How can I combine them?

He said: Combine them and sacrifice the animal made easily available for you. I, therefore, raised my voice in talbiyah for both of them (i.e. umrah and hajj). When I reached al-Udhayb, Salman ibn Rabi'ah and Zayd ibn Suhan met me while I was raising my voice in talbiyah for both of them.

One of them said to the other: This (man) does not have any more understanding than his camel. Thereupon it was as if a mountain fell on me.

I came to Umar ibn al-Khattab (may Allah be pleased with him) and said to him: Commander of the Faithful, I was a Christian Bedouin, and I have embraced Islam. I am eager to wage war in the cause of Allah (jihad), and I found that both hajj and umrah were due from me. I came to a man of my tribe who said to me: Combine both of them and sacrifice the animal easily available for you. I have raised my voice in talbiyah for both of them.

Umar thereupon said to me: You have been guided to the practice (sunnah) of your Prophet) (peace_be_upon_him).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1797]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1797

Narrated Saburah:

Ar-Rabi' ibn Saburah said on the authority of his father (Saburah): We went out along with the Apostle of Allah (peace_be_upon_him) till we reached Usfan, Suraqah ibn Malik al-Mudlaji said to him: Apostle of Allah, explain to us like the people as if they were born today. He said: Allah, the Exalted, has included this umrah in your hajj. When you come (to Mecca), and he who goes round the House (the Ka'bah), and runs between as-Safa and al-Marwah, is allowed to take off ihram except he who has brought the sacrificial animals with him.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1799]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1799

Narrated Mu'awiyah:

Ibn Abbas said that Mu'awiyah told him: do you not know that I clipped the hair of the head of the Apostle of Allah (peace_be_upon_him) with a broad iron arrowhead at al-Marwah? Al-Hasan added in his version: "during his hajj."


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1804]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1804

Narrated Bilal ibn al-Harith al-Muzani:

I asked: Apostle of Allah, is the (command of) cancelling hajj meant exclusively for us, or for others too? He replied: No, this is meant exclusively for you.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1806]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1806

Narrated AbuRazin:

A man of Banu Amir said: Apostle of Allah, my father is very old, he cannot perform hajj and umrah himself nor can be ride on a mount. He said: Perform hajj and umrah on behalf of your father.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1807]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1807

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) heard a man say: Labbayk (always ready to obey) on behalf of Shubrumah. He asked: Who is Shubrumah? He replied: A brother or relative of mine. He asked: Have you performed hajj on your own behalf? He said: No. He said: perform hajj on your own behalf, then perform it on behalf of Shubrumah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1809]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1809

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) raised his voice in talbiyah; he then mentioned the wordings of talbiyah like the tradition narrated by Ibn Umar. The people used to add the words dhal-ma'arij (the Possessor of ladders) and similar other words (to talbiyah) while the Prophet (peace_be_upon_him) heard them utter these words, but he did not say anything to them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1810]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1810

Narrated as-Sa'ib al-Ansari:

Khalid ibn as-Sa'ib al-Ansari on his father's authority reported the Apostle of Allah (peace_be_upon_him) as saying: Gabriel came to me and commanded me to order my Companions to raise their voices in talbiyah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1813]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1813

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: A person who performs umrah should shout talbiyah till he touches the Black Stone.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1814]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1814

Narrated Asma' bint AbuBakr:

We came out for performing hajj along with the Apostle of Allah (peace_be_upon_him). When we reached al-Araj, the Apostle of Allah (peace_be_upon_him) alighted and we also alighted. Aisha sat beside the Apostle of Allah (peace_be_upon_him) and I sat beside my father (AbuBakr). The equipment and personal effects of AbuBakr and of the Apostle of Allah (peace_be_upon_him) were placed with AbuBakr's slave on a camel. AbuBakr was sitting and waiting for his arrival. He arrived but he had no camel with him. He asked:

Where is your camel? He replied: I lost it last night. AbuBakr said: There was only one camel, even that you have lost. He then began to beat him while the Apostle of Allah (peace_be_upon_him) was smiling and saying: Look at this man who is in the sacred state (putting on ihram), what is he doing?

Ibn AbuRizmah said: The Apostle of Allah (peace_be_upon_him) spoke nothing except the words: Look at this man who is in the sacred state (wearing ihram), what is he doing? He was smiling (when he uttered these words).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1815]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1815

Narrated Ya'la ibn Umayyah:

A man came to the Prophet (peace_be_upon_him) when he was at al-Ji'ranah. He was wearing perfume or the mark of saffron was on him and he was wearing a tunic.

He said: Apostle of Allah, what do you command me to do while performing my Umrah. In the meantime, Allah, the Exalted, sent a revelation to the Prophet (peace_be_upon_him).

When he (the Prophet) came to himself gradually, he asked: Where is the man who asking about umrah? (When the man came) he (the Prophet) said: Wash the perfume which is on you, or he said: (Wash) the mark of saffron (the narrator is doubtful), take off the tunic, then do in your umrah as you do in your hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1826]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1826

Narrated Aisha, Ummul Mu'minin:

We were proceeding to Mecca along with the Prophet (peace_be_upon_him). We pasted on our foreheads the perfume known as sakk at the time of wearing ihram. When one of us perspired, it (the perfume) came down on her face. The Prophet (peace_be_upon_him) saw, but did not forbid it.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1827]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1827

Narrated Aisha, Ummul Mu'minin:

Salim ibn Abdullah said: Abdullah ibn Umar used to do so, that is to say, he would cut the shoes of a woman who put on ihram; then Safiyyah, daughter of AbuUbayd, reported to him that Aisha (may Allah be pleased with her) narrated to her that the Apostle of Allah (peace_be_upon_him) gave licence to women in respect of the shoes (i.e. women are not required to cut the shoes). He, therefore, abandoned it.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1829]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1829

Narrated Aisha, Ummul Mu'minin:

Riders would pass us when we accompanied the Apostle of Allah (peace_be_upon_him) while we were in the sacred state (wearing ihram). When they came by us, one of us would let down her outer garment from her head over her face, and when they had passed on, we would uncover our faces.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1832]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1832

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) had himself cupped in his head when he was in the sacred state (wearing ihram due to a disease from which he was suffering.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1833]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1833

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) had himself cupped on the surface of his foot because of a pain in it while he was in the sacred state (wearing ihram).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1844]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1844

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) was asked which of the creatures a pilgrim in sacred state could kill. He replied: The snake, the scorpion, the rat; he should drive away the pied crow, but should not kill it; the biting dog, the kite, and any wild animal which attacks (man).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1845]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1845

Narrated Ali ibn AbuTalib:

Abdullah ibn al-Harith reported on the authority of his father al-Harith: (My father) al-Harith was the governor of at-Ta'if under the caliph Uthman. He prepared food for Uthman which contained birds and the flesh of wild ass. He sent it to Ali (may Allah be pleased with him). When the Messenger came to him he was beating leaves for camels and shaking them off with his hand. He said to him: Eat it. He replied: Give it to the people who are not in sacred state; we are wearing ihram. I adjure the people of Ashja' who are present here. Do you know that a man presented a wild ass to the Apostle of Allah (peace_be_upon_him) while he was in ihram? But he refused to eat from it. They said: Yes.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1847]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1847

Narrated Jabir ibn Abdullah:

I heard the Apostle of Allah (peace_be_upon_him) say: The game of the land is lawful for you (when you are wearing ihram) as long as you do not hunt it or have it hunted on your behalf.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1854]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1854

Narrated Ka'b ibn Ujrah:

The Apostle of Allah (peace_be_upon_him) came upon him (during their stay) at al-Hudaybiyyah. He then narrated the rest of the tradition. This version adds: "He asked: Do you have a sacrificial animal? He replied: No. He then said: Fast three days or give three sa's of dates to six poor people, giving one sa' to every two persons."


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1855]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1855

Narrated Ka'b ibn Ujrah:

A man from the Ansar said on the authority of Ka'b ibn Ujrah that he was feeling pain in his head (due to lice); so he shaved his head. The Prophet (peace_be_upon_him) ordered him to sacrifice a cow as offering.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1858]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1858

Narrated al-Hajjaj ibn Amr:

The Prophet (peace_be_upon_him) said: If anyone breaks (a leg) or becomes lame or falls ill. He then narrated the tradition to the same effect. The narrator Salamah ibn Shabib said: Ma'mar narrated (this tradition) to us.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1859]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1859

Narrated Abdullah Ibn Abbas:

Maymun ibn Mahran said: I came out to perform umrah in the year when the people of Syria besieged Ibn az-Zubayr at Mecca. Some people of my tribe sent sacrificial animals with me as an offering. When we reached the people of Syria, they stopped us from entering the sacred territory. I, therefore, sacrificed the animals at the same spot. I then took off ihram and returned.

Next year I came out to make an atonement for my umrah. I came to Ibn Abbas and asked him (about it). He said: Bring a new sacrificial animal, for the Apostle of Allah (peace_be_upon_him) ordered his companions to bring fresh sacrificial animals for the umrah of atonement in lieu of the animals they had sacrificed in the year of al-Hudaybiyyah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1865]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1865

Narrated Jabir ibn Abdullah:

was asked about a man who looks at the House (the Ka'bah) and raises his hands (for prayer). He replied: I did not find anyone doing this except the Jews. We performed hajj along with the Apostle of Allah (peace_be_upon_him), but he did not do so.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1867]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1867

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) came an entered Mecca, and after the Apostle of Allah (peace_be_upon_him) had gone forward to the Stone, and touched it, he went round the House (the Ka'bah). He then went to as-Safa and mounted it so that he could look at the House. Then he raised his hands began to make mention of Allah as much as he wished and make supplication. The narrator said: The Ansar were beneath him. The narrator Hashim said: He prayed and praised Allah and asked Him for what he wished to ask.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1870]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1870

Narrated Aisha, Ummul Mu'minin:

Ibn Umar was informed about the statement of Aisha that a part of al-Hijr is included in the magnitude of the Ka'bah. Ibn Umar said: By Allah, I think that she must have heard it from the Apostle of Allah (peace_be_upon_him). I think that the Apostle of Allah (peace_be_upon_him) had not given up touching both of them but for the reason that they were not on the foundation of the House (the Ka'bah), nor did the people circumambulate (the House) beyond al-Hijr for this reason.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1873]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1873

Narrated Safiyyah, daughter of Shaybah:

When the Apostle of Allah (peace_be_upon_him) had some rest at Mecca in the year of its Conquest, he performed circumambulation on a camel and touched the corner (black Stone) with a crooked stick in his hand. She said: I was looking at him.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1878]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1878

Narrated Ya'la:

The Apostle of Allah (peace_be_upon_him) went round the House (the Ka'bah) wearing a green Yamani mantle under his right armpit with the end over his left shoulder.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1879]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1879

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) and his Companions performed umrah from al-Ji'ranah. They went quickly round the House (the Ka'bah) moving their shoulders) proudly. They put their upper garments under their armpits and threw the ends over their left shoulders.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1882]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1882

Narrated Umar ibn al-Khattab:

Aslam said: I heard Umar ibn al-Khattab say: What is the need of walking proudly (ramal) and moving the shoulders (while going round the Ka'bah)? Allah has now strengthened Islam and obliterated disbelief and the infidels. In spite of that we shall not forsake anything that we used to do during the time of the Apostle of Allah (peace_be_upon_him).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1883]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1883

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Going round the House (the Ka'bah), running between as-Safa and lapidation of the pillars are meant for the remembrance of Allah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1884]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1884

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) wore the mantle under his right armpit with the end over his left shoulder, and touched the corner (Black Stone), then uttered "Allah is most great" and walked proudly in three circuits of circumambulation. When they (the Companions) reached the Yamani corner, and disappeared from the eyes of the Quraysh, they walked as usual; When they appeared before them, they walked proudly with rapid strides. Thereupon the Quraysh said: They look to be the deer (that are jumping). Ibn Abbas said: Hence this became the sunnah (model behaviour of the Prophet).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1885]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1885

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) and his Companions performed umrah from al-Ji'ranah and walked proudly with rapid strides round the House (the Ka'bah) in three circuits and walked as usual in four circuits.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1887]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1887

Narrated Abdullah ibn as-Sa'ib:

I heard the Apostle of Allah (peace_be_upon_him) say between the two corners: O Allah, bring us a blessing in this world and a blessing in the next and guard us from punishment of Hell.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1889]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1889

Narrated Jubayr ibn Mut'im:

The Prophet (peace_be_upon_him) said: Do not prevent anyone from going round this House (the Ka'bah) and from praying any moment he desires by day or by night. The narrator Fadl (ibn Ya'qub) said: The Apostle of Allah (peace_be_upon_him) said: Banu Abdu Munaf, do not stop anyone.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1891]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1891

Narrated Aisha, Ummul Mu'minin:

The Companions of the Apostle of Allah (peace_be_upon_him) who accompanied him did not go round the Ka'bah till they threw pebbles at the Jamrah (pillar at Mina).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1893]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1893

Narrated AbdurRahman ibn Safwan:

When the Apostle of Allah (peace_be_upon_him) conquered Mecca, I said (to myself): I shall put on my clothes, and my house lay on the way, I shall watch how the Apostle of Allah (peace_be_upon_him) behaves. So I went out. I saw that the Prophet (peace_be_upon_him) and his Companions had come out from the Ka'bah and embraced the House (the Ka'bah) from its entrance (al-Bab) to al-Hatim. They placed their cheek on the House (the Ka'bah) while the Apostle of Allah (peace_be_upon_him) was amongst them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1894]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1894

Narrated Abdullah ibn Amr ibn al-'As:

Shu'ayb ibn Abdullah said: I went round the Ka'bah along with Abdullah ibn Amr. When we came behind the Ka'bah I asked: Do you not seek refuge? He uttered the words: I seek refuge in Allah from the Hell-fire. He then went (farther) and touched the Black Stone, and stood between the corner (Black Stone) and the entrance of the Ka'bah. He then placed his breast, his face, his hands and his palms in this manner, and he spread them, and said: I saw the apostle of Allah (peace_be_upon_him) doing like this.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1895]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1895

Narrated Abdullah ibn Abbas:

Abdullah ibn as-Sa'ib reported on the authority of his father as-Sa'ib that he used to lead Ibn Abbas (when he become blind) and make him stand in the third corner that was adjacent to the corner (Black Stone) near the entrance of the Ka'bah. Ibn Abbas used to say: Has it been reported to you that the Apostle of Allah (peace_be_upon_him) would pray in this place. He would reply: Yes. He then used to stand (there) and pray.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1899]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1899

Narrated Abdullah ibn Umar:

Kathir ibn Jamhan said: A man asked Abdullah ibn Umar between as-Safa and al-Marwah: AbdurRahman, I see you walking while the people are running (between as-Safa and al-Marwah)? He replied: If I walk, I saw the Apostle of Allah (peace_be_upon_him) running. I am too old.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1906]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1906

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) offered the noon prayer on the 8th of Dhul-Hijjah (Yawm at-Tarwiyah) and dawn prayer on the 9th of Dhul-Hijjah (Yawm al-Arafah) in Mina.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1909]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1909

Narrated Abdullah ibn Umar:

When al-Hajjaj killed Ibn Zubayr, he sent a message to Ibn Umar asking him: At which moment the Apostle of Allah (peace_be_upon_him) used to proceed (to Arafat) this day? He replied: When it happens so, we shall proceed. When Ibn Umar intended to proceed, the people said: The sun did not decline. He (Ibn Umar) asked: Did it decline? They replied: It did not decline. When they said that the sun had declined, he proceeded.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1911]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1911

Narrated Nubayt:

Nubayt had seen the Prophet (peace_be_upon_him) in Arafat.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1912]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1912

Narrated Khalid ibn Hudhah:

Al-Adda' ibn Khalid ibn Hudhah said: I saw the Apostle of Allah (peace_be_upon_him) on 9 Dhul-Hijjah on a camel standing at the stirrups.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1914]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1914

Narrated Ibn Mirba' al-Ansari:

Yazid ibn Shayban said: We were in a place of stationing at Arafat which Amr (ibn Abdullah) thought was very far away from where the imam was stationing, when Ibn Mirba' al-Ansari came to us and told (us): I am a messenger for you from the Apostle of Allah (peace_be_upon_him). He tells you: Station where you are performing your devotions for you are an heir to the heritage of Abraham.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1917]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1917

Narrated Ali ibn AbuTalib:

The Prophet then took up Usamah behind him (on the camel), and drove the camel at a quick pace. The people were beating their camels right and left, but he did not pay attention to them; he was saying: O people, preserve a quiet demeanour. He proceeded (from Arafat) when the sun had set.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1924]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1924

Narrated Abdullah ibn Umar:

Abdullah ibn Malik said: I offered three rak'ahs of the sunset prayer and two rak'ahs of the night prayer along with Ibn Umar. Thereupon Malik ibn al-Harith said: What is this prayer? He said: I offered these prayers along with the Apostle of Allah (peace_be_upon_him) in this place with a single iqamah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1930]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1930

Narrated Ali ibn AbuTalib:

When the morning came, the Prophet (peace_be_upon_him) stood at the mountain Quzah and said: This is Quzah, and this is a place of stationing, and the whole of al-Muzdalifah is a place of stationing. I sacrificed the animals here, and the whole of Mina is a place of sacrifice. So sacrifice in your dwellings.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1933]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1933

Narrated Umar ibn al-Khattab:

The Arabs in the pre-Islamic period did not return from al-Muzdalifah till they saw sunlight at the mountain Thabir. The Prophet (peace_be_upon_him) opposed them and returned before the sunrise.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1935]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1935

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) sent ahead some boys from Banu AbdulMuttalib on donkeys on the night of al-Muzdalifah. He began to pat our thighs (out of love) and said: O young! boys do not throw pebbles at the jamrah till the sun rises.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1936]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1936

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) used to send ahead the weak members of his family in darkness (to Mina), and command them not to throw pebbles at jamrahs until the sun rose.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1937]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1937

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) sent Umm Salamah on the night before the day of sacrifice and she threw pebbles at the jamrah before dawn. She hastened (to Mecca) and performed the circumambulation. That day was the one the Apostle of Allah (peace_be_upon_him) spent with her.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1938]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1938

Narrated Asma:

Ata' said: A reporter reported to me about Asma' that she threw pebbles at the jamrah at night. I said: We threw pebbles (at the jamrah) at night. She said: We used to do so in the lifetime of the Apostle of Allah (peace_be_upon_him).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1939]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1939

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) hastened from al-Muzdalifah with a quite demeanour and ordered them (the people) to throw small pebbles and he hastened in the valley (wadi) of Muhassir.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1940]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1940

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) halted on the day of sacrifice between the jamrahs (pillars at Mina) during hajj which he performed. He asked: Which is this day? They replied: This is the day of sacrifice. He said: This is the day of greater hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1942]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1942

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) gave a sermon during his hajj and said: Time has completed a cycle and assumed the form of the day when Allah created the heavens and the earth. The year contains twelve months of which four are sacred, three of them consecutive, viz. Dhul-Qa'dah, Dhul-Hijjah and Muharram and also Rajab of Mudar which comes between Jumadah and Sha'ban.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1944]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1944

Narrated AbdurRahman Ya'mar ad-Dayli:

I came to the Holy Prophet (peace_be_upon_him) when he was in Arafat. Some people or a group of people came from Najd. They commanded someone (to ask the Prophet about hajj).

So he called the Apostle of Allah (peace_be_upon_him), saying: How is the hajj done? He (the Prophet) ordered a man (to reply). He shouted loudly: The hajj, the hajj is on the day of Arafah. If anyone comes over there before the dawn prayer on the night of al-Muzdalifah, his hajj will be complete. The period of halting at Mina is three days. Then whoever hastens (his departure) by two days, it is no sin for him, and whoever delays it there is no sin for him.

The narrator said: He (the Prophet) then put a man behind him on the camel. He began to proclaim this loudly.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1945]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1945

Narrated Urwah ibn Mudarris at-Ta'i:

I came to the Apostle of Allah (peace_be_upon_him) at the place of halting, that is, al-Muzdalifah. I said: I have come from the mountains of Tayy. I fatigued my mount and fatigued myself. By Allah, I found no hill (on my way) but I halted there. Have I completed my hajj? The Apostle of Allah (peace_be_upon_him) said: Anyone who offers this prayer along with us and comes over to Arafat before it by night or day will complete his hajj and he may wash away the dirt (of his body).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1946]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1946

Narrated A man from the Companions of the Prophet:

AbdurRahman ibn Mu'adh said that he heard a man from the Companions of the Prophet (peace_be_upon_him) say: The Prophet (peace_be_upon_him) addressed the people at Mina and he made them stay in their dwellings. He then said: The Muhajirun (Emigrants) should stay here, and he made a sign to the right side of the qiblah, and the Ansar (the Helpers) here, and he made a sign to the left side of the qiblah; the people should stay around them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1947]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1947

Narrated Two men from Banu Bakr:

Ibn AbuNajih reported from his father on the authority of two men from Banu Bakr who said: We saw the Apostle of Allah (peace_be_upon_him) addressing (the people) in the middle of the tashriq days when we were staying near his mount. This is the address of the Apostle of Allah (peace_be_upon_him) which he gave at Mina.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1948]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1948

Narrated Sarra' daughter of Nabhan:

She was mistress of a temple in pre-Islamic days. She said: The prophet (peace_be_upon_him) addressed us on the second day of sacrifice (yawm ar-ru'us) and said: Which is this day? We said: Allah and His Apostle are better aware. He said: Is this not the middle of the tashriq days?


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1949]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1949

Narrated Harmas ibn Ziyad al-Bahili:

I saw the Prophet (peace_be_upon_him) addressing the people on his she-camel al-Adba', on the day of sacrifice at Mina.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1951]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1951

Narrated Rafi' ibn Amr al-Muzani:

I saw the Apostle of Allah (peace_be_upon_him) addressing the people at Mina (on the day of sacrifice) when the sun rose high (i.e. in the forenoon) on a white mule, and Ali (Allah be pleased with him) was interpreting on his behalf; some people were standing and some sitting.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1952]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1952

Narrated AbdurRahman ibn Mu'adh at-Taymi:

The Apostle of Allah (peace_be_upon_him) addressed us when we were at Mina. Our ears were open and we were listening to what he was saying, while we were in our dwellings. He began to teach them the rites of hajj till he reached the injunction of throwing pebbles at the Jamrahs (pillars at Mina). He put his forefingers in his ears and said: (Throw small pebbles. He then commanded the Emigrants (Muhajirun) to station themselves. They stationed themselves before the mosque. He then commanded the Helpers (Ansar) to encamp. They encamped behind the mosque. Thereafter the people encamped.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1953]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1953

Narrated Abdullah ibn Umar:

Ibn Jurayj asked Ibn Umar: We sell the property of the people; so one of us goes to Mecca and passes the night there with the property (during the stay at Mina). He said: The Apostle of Allah (peace_be_upon_him) used to pass night and day at Mina.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1956]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1956

Narrated Az-Zuhri:

Uthman prayed four rak'ahs at Mina because he resolved to stay there after hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1957]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1957

Narrated Ibrahim:

Uthman prayed four rak'ahs (at Mina) for he made it his home (for settlement).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1958]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1958

Narrated Az-Zuhri:

When Uthman placed his property at at-Ta'if and intended to settle there, he prayed four rak'ahs. The rulers after him followed the same practice.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1959]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1959

Narrated Az-Zuhri:

Uthman offered complete prayer at Mina for the sake of bedouins who attended (hajj) in large numbers that year. He led the people four rak'ahs in prayer in order to teach them that the prayer (i.e. noon or afternoon prayer) essentially contained four rak'ahs.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1960]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1960

Narrated Harithah ibn Wahb al-Khuza'i,:

I prayed along with the Apostle of Allah (peace_be_upon_him) at Mina and the people gathered there in large numbers. He led us two rak'ahs in prayer in the Farewell Pilgrimage.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1962]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1962

Narrated Umm Jandab al-Azdiyyah:

I saw the Apostle of Allah (peace_be_upon_him) near the Jamrat al-Aqabah (the third or last pillar) riding (on a camel) and I saw a pebble between his fingers. He threw the pebbles and the people also threw (stones at the Jamrah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1963]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1963

Narrated Umm Jandab al-Azdiyyah:

The aforesaid tradition (No 1963) has also been transmitted by Yazid ibn AbuZiyad with a different chain of narrators.

This version adds the words: He (the Prophet) did not stand near it (the jamrah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1964]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1964

Narrated Abdullah ibn Umar:

Nafi' reported on the authority of Ibn Umar. He (ibn Umar) used to come (to Mina) and threw pebbles three days after the day of sacrifice walking when arriving and returning (both ways). He reported that the Prophet (peace_be_upon_him) used to do so.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1970]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1970

Narrated Asim ibn Adi:

The Apostle of Allah (peace_be_upon_him) gave permission to the herdsmen of the camels not to pass night at Mina and asked them to throw pebbles on the day of sacrifice, and to throw pebbles at the jamrahs the next day and the following two days, and on the day of their return.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1971]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1971

Narrated Asim ibn Adi:

The Apostle of Allah (peace_be_upon_him) permitted the herdsmen of the camel to lapidate the the jamrahs one day and omit one day.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1972]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1972

Narrated Abdullah ibn Abbas:

AbuMijlaz said: I asked Ibn Abbas about a thing concerning the throwing of stones at the jamrahs. He said: I do not know whether the Apostle of Allah (peace_be_upon_him) threw six or seven pebbles.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1973]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1973

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: When one of you throws pebbles at the last jamrah (Jamrat al-Aqabah), everything becomes lawful for him except women (sexual intercourse).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1979]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1979

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Shaving is not a duty laid on women; only clipping the hair is incumbent on them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1980]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1980

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Shaving is not a duty laid on women; only clipping the hair is incumbent on them.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1982]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1982

Narrated Abdullah ibn Abbas:

By Allah, the Apostle of Allah (peace_be_upon_him) did not make Aisha perform umrah during Dhul-Hijjah but to discontinue the practice of the idolaters (in Arabia before Islam), for this clan of Quraysh and those who followed them used to say: When the fur of the camel abounds, and the wounds on the back of the camels are recovered and the month of Safar begins, umrah becomes lawful for one who performs umrah. They considered performing umrah unlawful till the months of Dhul-Hijjah and al-Muharram passed away.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1983]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1983

Narrated Umm Ma'qil:

AbuBakr ibn AbdurRahman said: The messenger of Marwan whom he sent to Umm Ma'qil reported to me.

She said: AbuMa'qil accompanied the Apostle of Allah (peace_be_upon_him) during hajj. When he came (to her) she said: You know that hajj is incumbent on me. They walked until they visited him (i.e. the Prophet) and she asked (him): Apostle of Allah, hajj is due from me, and AbuMa'qil has a camel.

AbuMa'qil said: She spoke the truth, I have dedicated it to the cause of Allah.

The Apostle of Allah (peace_be_upon_him) said: Give it to her, that is in the cause of Allah. So he gave the camel to her.

She then said: Apostle of Allah, I am a woman who has become aged and ill. Is there any action which would be sufficient for me as my hajj?

He replied: umrah performed during Ramadan is sufficient as hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1984]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1984

Narrated Umm Ma'qil:

When the Apostle of Allah (peace_be_upon_him) performed the Farewell Pilgrimage, and we had a camel, AbuMa'qil dedicated it to the cause of Allah. Then we suffered from a disease, and AbuMa'qil died. The Prophet (peace_be_upon_him) went out (for hajj). When he finished the hajj, I came to him.

He said (to me): Umm Ma'qil, what prevented you from coming out for hajj along with us?

She said: We resolved (to do so), but AbuMa'qil died. We had a camel on which we could perform hajj, but AbuMa'qil had bequeathed it to the cause of Allah.

He said: Why did you not go out (for hajj) upon it, for hajj is in the cause of Allah? If you miss this hajj along with us, perform umrah during Ramadan, for it is like hajj.

She used to say: hajj is hajj, and umrah is umrah. The Apostle of Allah (peace_be_upon_him) said it to me: I do not know whether it was peculiar to me.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1985]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1985

Narrated Abdullah Ibn Abbas:

The Apostle of Allah (peace_be_upon_him) intended to perform hajj.

A woman said to her husband: Let me perform hajj along with the Apostle of Allah (peace_be_upon_him).

He said: I have nothing on which I can let you perform hajj. She said: You may perform hajj on your such-and-such camel. He said: That is dedicated to the cause of Allah, the Exalted. He then came to the Apostle of Allah (peace_be_upon_him) and said: My wife has conveyed her greetings and the blessings of Allah to you. She has asked about performing hajj along with you. She said (to me): Let me perform hajj with the Apostle of Allah (peace_be_upon_him). I said (to her): I have nothing upon which I can let you perform hajj. She said: Let me perform hajj on your such-and-such camel. I said: That is dedicated to the cause of Allah, The Exalted.

He replied: If you let her perform hajj on it, that would be in the cause of Allah.

He said: She has also requested me to ask you: What is that action which is equivalent to performing hajj with you?

The Apostle of Allah (peace_be_upon_him) said: Convey my greetings, the mercy of Allah and His blessings to her and tell her that umrah during Ramadan is equivalent to performing hajj along with me.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1986]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1986

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) performed two umrahs: one umrah in Dhul-Qa'dah, and the other in Shawwal.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1988]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1988

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) performed four umrahs, viz. umrah al-Hudaybiyyah; the second is the one when they (the Companions) were agreed upon performing umrah next year; the third is umrah performed from al-Ji'ranah; the fourth is the one which he combined with his hajj.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1990]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1990

Narrated AbdurRahman ibn AbuBakr:

Hafsah, daughter of AbdurRahman ibn AbuBakr, reported on the authority of her father: The Apostle of Allah (peace_be_upon_him) said to AbdurRahman: AbdurRahman, put your sister Aisha on the back of the camel behind you and make her perform umrah from at-Tan'im. When you come down from the hillock (in at-Tan'im), she must wear (ihram for umrah), for this is an umrah accepted (by Allah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1991]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1991

Narrated Muharrish al-Ka'bi:

The Prophet (peace_be_upon_him) entered al-Ji'ranah. He came to the mosque (there) and prayed as long as Allah desired; he then wore ihram. Then he rode his camel and faced Batn Sarif till he reached the way which leads to Medina. He returned from Mecca (at night to al-Ji'ranah) as if he had passed the night at Mecca.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1992]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1992

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) stayed (at Mecca) for three days during umrah for atonement ('Umrat al-Qada')


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1994]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1994

Narrated Umm Salamah, Ummul Mu'minin:

The night which the Apostle of Allah (peace_be_upon_him) passed with me was the one that followed the day of sacrifice. He came to me and Wahb ibn Zam'ah also visited me. A man belonging to the lineage of AbuUmayyah accompanied him. Both of them were wearing shirts.

The Apostle of Allah (peace_be_upon_him) said to Wahb: Did you perform the obligatory circumambulation (Tawaf az-Ziyarah), AbuAbdullah?

He said: No, by Allah Apostle of Allah.

He (the Prophet) said: Take off your shirt. He then took it off over his head, and his companion too took his shirt off over his head.

He then asked: And why (this), Apostle of Allah? He replied: On this day you have been allowed to take off ihram when you have thrown the stones at the jamrahs, that is, everything prohibited during the state of ihram is lawful except intercourse with a woman. If the evening comes before you go round this House (the Ka'bah) you will remain in the sacred state (i.e. ihram), just like the state in which you were before you threw stones at the jamrahs, until you perform the circumambulation of it (i.e. the Ka'bah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1995]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1995

Narrated Aisha, Ummul Mu'minin ; Abdullah Ibn Abbas:

The Prophet (peace_be_upon_him) postponed the circumambulation on the day of sacrifice till the night.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1996]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1996

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) did not walk quickly (ramal) in the seven rounds of the last circumambulation (Tawaf al-Ifadah).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.1999]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 1999

Narrated Umar ibn al-Khattab:

Al-Harith ibn Abdullah ibn Aws said: I came to Umar ibn al-Khattab and asked him about a woman who has performed the (obligatory) circumambulation on the day of sacrifice, and then she menstruates. He said: She must perform the last circumambulation of the House (the Ka'bah). Al-Harith said: The Apostle of Allah (peace_be_upon_him) told me the same thing. Umar said: May your hands fall down! You asked me about a thing that you had asked the Apostle of Allah (peace_be_upon_him) so that I might oppose him.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2000]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2000

Narrated Aisha, Ummul Mu'minin:

I put on ihram for umrah at at-Tan'im and I entered (Mecca) and performed my umrah as an atonement. The Apostle of Allah (peace_be_upon_him) waited for me at al-Abtah till I finished it. He commanded the people to depart. The Apostle of Allah (peace_be_upon_him) came to the House (the Ka'bah), went round it and went out (i.e. left for Medina).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2002]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2002

Narrated AbdurRahman ibn Tariq:

AbdurRahman reported on the authority of his mother: When the Apostle of Allah (peace_be_upon_him) passed any place from the house of Ya'la,--the narrator Ubaydullah forgot its name--he faced the House (the Ka'bah) and supplicated.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2011]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2011

Narrated Al-Muttalib ibn AbuWida'ah:

Al-Muttalib saw that the Prophet (peace_be_upon_him) was praying at the place adjacent to the gate of Banu Sahm and the people were passing before him, and there was no covering (sutrah) between them. The narrator Sufyan said: There was no covering between him and the Ka'bah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2014]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2014

Narrated Aisha, Ummul Mu'minin:

I said: Apostle of Allah, should we not build a house or a building which shades you from the sun? He replied: No, it is a place for the one who reaches there earlier.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2015]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2015

Narrated Ya'la ibn Umayyah:

The Prophet (peace_be_upon_him) said: Hoarding up food (to sell it at a high price) in the sacred territory is a deviation (from right to wrong).


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2023]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2023

Narrated Aisha, Ummul Mu'minin:

I liked to enter the House (the Ka'bah) and pray therein. The Apostle of Allah (peace_be_upon_him) caught me by hand and admitted me to al-Hijr. He then said: Pray in al-Hijr when you intend to enter the House (the Ka'bah), for it is a part of the House (the Ka'bah). Your people shortened it when they built the Ka'bah, and they took it out of the House.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2024]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2024

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) went out from me, while he was happy, but he returned to me while he was sad. He said: I entered the Ka'bah, I know beforehand about my affair what I have come to know later I would not have entered it. I am afraid I have put my community to hardship.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2025]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2025

Narrated Uthman (ibn Talhah al-Hajabi):

Al-Aslamiyyah said: I said to Uthman ibn Talhah al-Hajabi): What did the Apostle of Allah (peace_be_upon_him) say to you when he called you? He said: (The Prophet said:) I forgot to order you to cover the two horns (of the lamb), for it is not advisable that there should be anything in the House (the Ka'bah) which diverts the attention of the man at prayer. Ibn as-Sarh said: The name of my maternal uncle is Musafi' ibn Shaybah.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2027]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2027

Narrated Az-Zubayr:

When we came along with the Apostle of Allah (peace_be_upon_him) from Liyyah and we were beside the lote tree, the Apostle of Allah (peace_be_upon_him) stopped at the end of al-Qarn al-Aswad opposite to it. He then looked at Nakhb or at its valley. He stopped and all the people stopped. He then said: The game of Wajj and its thorny trees are unlawful made unlawful for Allah. This was before he alighted at at-Ta'if and its fortress for Thaqif.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2030]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2030

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: Its (Medina's) fresh grass is not to be cut, its game is not to be driven away, and things dropped in it are to be picked up by one who publicly announces it, and it is not permissible for any man to carry weapons in it for fighting, and it is not advisable that its trees are cut except what a man cuts for the fodder of his camel.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2032]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2032

Narrated Sa'd ibn AbuWaqqas:

Sulayman ibn AbuAbdullah said: I saw Sa'd ibn AbuWaqqas seized a man hunting in the sacred territory of Medina which the Apostle of Allah (peace_be_upon_him) had declared to be sacred. He took away his clothes from him. His patrons came to him and spoke to him about it, but he replied: The Apostle of Allah (peace_be_upon_him) declared this territory to be sacred, saying: If anyone catches someone hunting in it he should take away from him his clothes. So I shall not return to you a provision which the Apostle of Allah (peace_be_upon_him) has given me, but if you wish I shall pay you its price.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2034]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2034

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: The leaves should not be beaten off and the trees should not be cut in the protected land of the Apostle of Allah (peace_be_upon_him), but the leaves can be beaten off softly.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2036]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2036

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If any one of you greets me, Allah returns my soul to me and I respond to the greeting.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2037]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2037

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Do not make your houses graves, and do not make my grave a place of festivity. But invoke blessings on me, for your blessings reach me wherever you may be.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2038]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2038

Narrated Talhah ibn Ubaydullah:

Rabi'ah ibn al-Hudayr said: I did not hear Talhah ibn Ubaydullah narrating any tradition from the Apostle of Allah (peace_be_upon_him) except one tradition. I (Rabi'ah ibn AbuAbdurRahman) asked: What is that? He said: We went out along with the Apostle of Allah (peace_be_upon_him) who was going to visit the graves of the martyrs. When we ascended Harrah Waqim, and then descended from it, we found there some graves at the turning of the valley. We asked: Apostle of Allah, are these the graves of our brethren? He replied: Graves of our companions. When we came to the graves of martyrs, he said: These are the graves of our brethren.


Dawud :: The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj) :: [10.2040]

The Rites of Hajj (Kitab Al-Manasik Wa'l-Hajj)

Dawud :: Book 10 : Hadith 2040

Narrated Malik:

One should not exceed al-Mu'arras when one returns to Medina until one prays there as much as one wishes, for I have been informed that the Apostle of Allah (peace_be_upon_him) halted there at night.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2044]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2044

Narrated Abdullah ibn Abbas:

A man came to the Prophet (peace_be_upon_him), and said: My wife does not prevent the hand of a man who touches her. He said: Divorce her. He then said: I am afraid my inner self may covet her. He said: Then enjoy her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2045]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2045

Narrated Ma'qil ibn Yasar:

A man came to the Prophet (peace_be_upon_him) and said: I have found a woman of rank and beauty, but she does not give birth to children. Should I marry her? He said: No. He came again to him, but he prohibited him. He came to him third time, and he (the Prophet) said: Marry women who are loving and very prolific, for I shall outnumber the peoples by you.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2046]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2046

Narrated Abdullah ibn Amr ibn al-'As:

Marthad ibn AbuMarthad al-Ghanawi used to take prisoners (of war) from Mecca (to Medina). At Mecca there was a prostitute called Inaq who had illicit relations with him. (Marthad said:) I came to the Prophet (peace_be_upon_him) and said to him: May I marry Inaq, Apostle of Allah? The narrator said: He kept silence towards me. Then the verse was revealed:"....and the adulteress none shall marry save and adulterer or an idolater." He called me and recited this (verse) to me, and said: Do not marry her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2047]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2047

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The adulterer who has been flogged shall not marry save the one like him. AbuMa'mar said: Habib al-Mu'allim narrated (this tradition) to us on the authority of Amr ibn Shu'ayb.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2050]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2050

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: What is unlawful by reason of consanguinity is unlawful by reason of fosterage.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2052]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2052

Narrated Aisha, Ummul Mu'minin:

Aflah ibn AbulQu'ays entered upon me. I hid myself from him. He said: You are hiding yourself from me while I am your paternal uncle. She said: I said: From where? He said: The wife of my brother suckled you. She said: The woman suckled me and not the man. Thereafter the Apostle of Allah (peace_be_upon_him) entered upon me and I told him this matter. He said: He is your paternal uncle; he may enter upon you.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2059]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2059

Narrated Hajjaj ibn Malik al-Aslami:

I asked: Apostle of Allah, what will remove from me the obligation due for fostering a child? He said: A slave or a slave-woman.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2062]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2062

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) abominated the combination of paternal and maternal aunts and the combination of two maternal aunts and two paternal aunts in marriage.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2068]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2068

Narrated Saburah ibn Ma'bad al-Juhani:

The Apostle of Allah (peace_be_upon_him) prohibited temporary marriage with women.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2070]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2070

Narrated Mu'awiyah:

AbdurRahman ibn Hurmuz al-A'raj said: Al-Abbas ibn Abdullah ibn al-Abbas married his daughter to AbdurRahman ibn al-Hakam, and AbdurRahman married his daughter to him. And they made this (exchange) their dower. Mu'awiyah wrote to Marwan commanding him to separate them. He wrote in his letter: This is the shighar which the Apostle of Allah (peace_be_upon_him) has forbidden.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2071]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2071

Narrated Ali ibn AbuTalib:

(The narrator Isma'il said: I think ash-Sha'bi attributed this tradition to the Prophet)

The Prophet (peace_be_upon_him) said: Curse be upon the one who marries a divorced woman with the intention of making her lawful for her former husband and upon the one for whom she is made lawful.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2073]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2073

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If any slave marries without the permission of his masters, he is a fornicator.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2076]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2076

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: One of you must not ask a woman in marriage when his brother has done so already, and one of you must not sell (his own goods) when his brother has already sold (his goods) except with his permission.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2077]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2077

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: When one of you asked a woman in marriage, if he is able to look at what will induce him to marry her, he should do so. He (Jabir) said: I asked a girl in marriage, I used to look at her secretly, until I looked at what induced me to marry her. I, therefore, married her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2078]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2078

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: The marriage of a woman who marries without the consent of her guardians is void. (He said these words) three times. If there is cohabitation, she gets her dower for the intercourse her husband has had. If there is a dispute, the sultan (man in authority) is the guardian of one who has none.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2080]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2080

Narrated AbuMusa:

The Prophet (peace_be_upon_him) said: There is no marriage without the permission of a guardian.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2081]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2081

Narrated Umm Habibah:

Ibn Az-Zubayr reported on the authority of Umm Habibah that she was the wife of Ibn Jahsh, but he died, He was among those who migrated to Abyssinia. Negus then married her to the Apostle of Allah (peace_be_upon_him).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2083]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2083

Narrated Samurah:

The Prophet (peace_be_upon_him) said: Any woman who is married by two guardians (to two different men) belongs to the first woman who is married by two guardians (to two different men) belongs to the first of them and anything sold by a man to two persons belongs to the first of them.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2084]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2084

Narrated Abdullah ibn Abbas:

About the Qur'anic verse: "It is not lawful for you forcibly to inherit the woman (of your deceased kinsmen), nor (that) ye should put constraint upon them. When a man died, his relatives had more right to his wife then her own guardian. If any one of them wanted to marry her, he did so; or they married her (to some other person), and if they did not want to marry her, they did so. So this verse was revealed about the matter.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2088]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2088

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: An orphan virgin girl should be consulted about herself; if she says nothing that indicates her permission, but if she refuses, the authority of the guardian cannot be exercised against her will. The full information rest with the tradition narrated by Yazid.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2090]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2090

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Consult women about (the marriage of) their daughters.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2091]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2091

Narrated Abdullah ibn Abbas:

A virgin came to the Prophet (peace_be_upon_him) and mentioned that her father had married her against her will, so the Prophet (peace_be_upon_him) allowed her to exercise her choice.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2095]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2095

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: A guardian has no concern with a woman previously married and has no husband, and an orphan girl (i.e. virgin) must be consulted, her silence being her acceptance.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2097]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2097

Narrated AbuHurayrah:

AbuHind cupped the Prophet (peace_be_upon_him) in the middle of his head. The Prophet (peace_be_upon_him) said: Banu Bayadah, marry AbuHind (to your daughter), and ask him to marry (his daughter) to you. He said: The best thing by which you treat yourself is cupping.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2098]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2098

Narrated Maymunah, daughter of Kardam:

I went out along with my father during the hajj performed by the Apostle of Allah (peace_be_upon_him). I saw the Apostle of Allah (peace_be_upon_him). My father came near him; he was riding his she-camel. He stopped there and listened to him. He had a whip like the whip of the teachers. I heard the Bedouin and the people saying: Keep away from the whip. My father came up to him. He caught hold of his foot and acknowledged him (his Prophethood). He stopped and listened to him.

He then said: I participated in the army of Athran (in the pre-Islamic days).

The narrator, Ibn al-Muthanna, said: Army of Gathran. Tariq ibn al-Muraqqa' said: Who will give me a lance and get a reward?

I asked: What is its reward? He replied: I shall marry him to my first daughter born to me. So I gave him my lance and then disappeared from him till I knew that a daughter was born to him and she came of age.

I then came to him and said: Send my wife to me. He swore that he would not do that until I fixed a dower afresh other than that agreed between me and him, and I swore that I should not give him the dower other than that I had given him before.

The Apostle of Allah (peace_be_upon_him) said: How old is she now?

He said: She has grown old. He said: I think you should leave her. He said: This put awe and fear into me, and I looked at the Apostle of Allah (peace_be_upon_him).

When he felt this in me, he said: You will not be sinful, nor will your companion be sinful.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2101]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2101

Narrated Umar ibn al-Khattab:

AbulAjfa' as-Sulami said: Umar (Allah be pleased with him) delivered a speech to us and said: Do not go to extremes in giving women their dower, for if it represented honour in this world and piety in Allah's sight, the one of you most entitled to do so would have been the Prophet (peace_be_upon_him). The Apostle of Allah (peace_be_upon_him) did not marry any of his wives or gave any of his daughters in marriage for more than twelve uqiyahs.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2102]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2102

Narrated Umm Habibah:

Urwah reported on the authority of Umm Habibah that she was married to Abdullah ibn Jahsh who died in Abyssinia, so the Negus married her to the Prophet (peace_be_upon_him) giving her on his behalf a dower of four thousand (dirhams). He sent her to the Apostle of Allah (peace_be_upon_him) with Shurahbil ibn Hasanah. AbuDawud said: Hasanah is his mother.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2103]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2103

Narrated Umm Habibah daughter of AbuSufyan:

Az-Zuhri said: The Negus married Umm Habibah daughter of AbuSufyan to the Apostle of Allah (peace_be_upon_him) for a dower of four thousand dirhams. He wrote it to the Apostle of Allah (peace_be_upon_him) who accepted it.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2105]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2105

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If anyone gives as a dower to his wife two handfuls of flour or dates he has made her lawful for him.

AbuDawud said: This tradition has been narrated by AbdurRahman ibn Mahdi, from Salih ibn Ruman, from AbuzZubayr on the authority of Jabir as his own statement (not going back to the Prophet). It has also been transmitted by AbuAsim from Salih ibn Ruman , from AbuzZubayr on the authority of Jabir who said: During the lifetime of the Apostle of Allah (peace_be_upon_him) we used to contract temporary marriage for a handful of grain.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2109]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2109

Narrated Abdullah ibn Mas'ud:

Masruq said on the authority of Abdullah ibn Mas'ud: Abdullah (ibn Mas'ud ) was asked about a man who had married a woman without cohabiting with her or fixing any dower for her till he died. Ibn Mas'ud said: She should receive the full dower (as given to women of her class), observe the waiting period ('Iddah), and have her share of inheritance. Thereupon Ma'qil ibn Sinan said: I heard the Apostle of Allah (peace_be_upon_him) giving the same decision regarding Birwa' daughter of Washiq (as the decision you have given).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2111]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2111

Narrated Abdullah ibn Mas'ud:

Abdullah ibn Utbah ibn Mas'ud said: Abdullah ibn Mas'ud was informed of this story of a man. The people continued to visit him for a month or visited him many times (the narrator was not sure).

He said: In this matter I hold the opinion that she should receive the type of dower given to women of her class with no diminution or excess, observe the waiting period ('iddah) and have her share of inheritance. If it is erroneous, that is from me and from Satan. Allah and His Apostle are free from its responsibility. Some people from Ashja' got up; among them were al-Jarrah and AbuSinan.

They said: Ibn Mas'ud, we bear witness that the Apostle of Allah (peace_be_upon_him) gave a decision for us regarding Birwa', daughter of Washiq, to the same effect as the decision you have given. Her husband was Hilal ibn Murrah al-Ashja'i. Thereupon Abdullah ibn Mas'ud was very pleased when his decision agreed with the decision of the Apostle of Allah (peace_be_upon_him).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2112]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2112

Narrated Uqbah ibn Amir:

The Prophet (peace_be_upon_him) said to a man: Would you like me to marry you to so-and-so?

He said: Yes. He also said to the woman: Would you like me to marry you to so-and-so?

She said: Yes. He then married one to the other. The man had sexual intercourse with her, but he did not fix any dower for her, nor did he give anything to her. He was one of those who participated in the expedition to al-Hudaybiyyah. One part of the expedition to al-Hudaybiyyah had a share in Khaybar.

When he was nearing his death, he said: The Apostle of Allah (peace_be_upon_him) married me to so-and-so, and I did not fix a dower for her, nor did I give anything to her. I call upon you as witness that I have given my share in Khaybar as her dower. So she took the share and sold it for one lakh (of dirhams).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2113]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2113

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) taught us the address in case of some need:

Praise be to Allah from Whom we ask help and pardon, and in Whom we take refuge from the evils within ourselves. He whom Allah guides has no one who can lead him astray, and he whom He leads astray has no one to guide him. I testify that there is no god but Allah, and I testify that Muhammad is His servant and Apostle.

"You who believe,...fear Allah by Whom you ask your mutual rights, and reverence the wombs. Allah has been watching you." ..."you who believe, fear Allah as He should be feared, and die only as Muslims" ...."you who believe, fear Allah as He should be feared, and die only as Muslims"....."you who believe, fear Allah and say what is true. He will make your deeds sound, and forgive your sins. He who obeys Allah and His Apostle has achieved a mighty success."

The narrator, Muhammad ibn Sulayman, did mention the word "inna" (verily).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2114]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2114

Narrated Abdullah ibn Mas'ud:

When the Apostle of Allah (peace_be_upon_him) recited the tashahhud....He then narrated the same tradition. In this version after the word "and His Apostle" he added the words: "He has sent him in truth as a bearer of glad tidings and a warner before the Hour. He who obeys Allah and His Prophet is on the right path, and he who disobeys them does not harm anyone except himself, and he does not harm Allah to the least.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2120]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2120

Narrated Abdullah ibn Abbas:

When Ali married Fatimah, the Prophet (peace_be_upon_him) said to him: Give her something. He said: I have nothing with me. He said: Where is your Hutamiyyah (coat of mail).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2121]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2121

Narrated A man from the Companion of the Prophet:

Muhammad ibn AbdurRahman ibn Thawban reported on the authority of a man from the Companions of the Prophet (peace_be_upon_him): When Ali married Fatimah, daughter of the Apostle of Allah (peace_be_upon_him), he intended to have intercourse with her. The Apostle of Allah (peace_be_upon_him) prohibited him to do so until he gave her something. Ali said: I have nothing with me, Apostle of Allah. The Prophet (peace_be_upon_him) said: Give her your coat of mail. So he gave her his coat of mail, and then cohabited with her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2123]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2123

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) commanded me to send a woman to her husband before he gave something to her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2124]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2124

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: A woman who marries on a dower or a reward or a promise before the solemnisation of marriage is entitled to it; and whatever is fixed for her after solemnisation of marriage belongs to whom it is given. A man is more entitled to receive a thing given as a gift on account of his daughter or sister (than other kinds of gifts).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2125]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2125

Narrated AbuHurayrah:

When the Prophet (peace_be_upon_him) congratulated a man on his marriage, he said: May Allah bless for you, and may He bless on you, and combine both of you in good (works).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2126]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2126

Narrated Basrah:

A man from the Ansar called Basrah said: I married a virgin woman in her veil. When I entered upon her, I found her pregnant. (I mentioned this to the Prophet). The Prophet (peace_be_upon_him) said: She will get the dower, for you made her vagina lawful for you. The child will be your slave. When she has begotten (a child), flog her (according to the version of al-Hasan). The version of Ibn AbusSari has: You people, flog her, or said: inflict hard punishment on him.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2128]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2128

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When a man has two wives and he is inclined to one of them, he will come on the Day of resurrection with a side hanging down.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2129]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2129

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to divide his time equally and said: O Allah, this is my division concerning what I possess, so do not blame me concerning what Thou possessest and I do not.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2135]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2135

Narrated Qays ibn Sa'd:

I went to al-Hirah and saw them (the people) prostrating themselves before a satrap of theirs, so I said: The Apostle of Allah (peace_be_upon_him) has most right to have prostration made before him. When I came to the Prophet (peace_be_upon_him), I said: I went to al-Hirah and saw them prostrating themselves before a satrap of theirs, but you have most right, Apostle of Allah, to have (people) prostrating themselves before you. He said: Tell me , if you were to pass my grave, would you prostrate yourself before it? I said: No. He then said: Do not do so. If I were to command anyone to make prostration before another I would command women to prostrate themselves before their husbands, because of the special right over them given to husbands by Allah.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2137]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2137

Narrated Mu'awiyah al-Qushayri:

Mu'awiyah asked: Apostle of Allah, what is the right of the wife of one of us over him? He replied: That you should give her food when you eat, clothe her when you clothe yourself, do not strike her on the face, do not revile her or separate yourself from her except in the house.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2138]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2138

Narrated Mu'awiyah ibn Haydah:

I said: Apostle of Allah, how should we approach our wives and how should we leave them? He replied: Approach your tilth when or how you will, give her (your wife) food when you take food, clothe when you clothe yourself, do not revile her face, and do not beat her.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2139]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2139

Narrated Mu'awiyah al-Qushayri:

I went to the Apostle of Allah (peace_be_upon_him) and asked him: What do you say (command) about our wives? He replied: Give them food what you have for yourself, and clothe them by which you clothe yourself, and do not beat them, and do not revile them.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2141]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2141

Narrated Abdullah ibn AbuDhubab:

Iyas ibn Abdullah ibn AbuDhubab reported the Apostle of Allah (peace_be_upon_him) as saying: Do not beat Allah's handmaidens, but when Umar came to the Apostle of Allah (peace_be_upon_him) and said: Women have become emboldened towards their husbands, he (the Prophet) gave permission to beat them. Then many women came round the family of the Apostle of Allah (peace_be_upon_him) complaining against their husbands. So the Apostle of Allah (peace_be_upon_him) said: Many women have gone round Muhammad's family complaining against their husbands. They are not the best among you.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2142]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2142

Narrated Umar ibn al-Khattab:

The Prophet (peace_be_upon_him) said: A man will not be asked as to why he beat his wife.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2144]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2144

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: to Ali: Do not give a second look, Ali, (because) while you are not to blame for the first, you have no right to the second.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2153]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2153

Narrated Ruwayfi' ibn Thabit al-Ansari:

Should I tell you what I heard the Apostle of Allah (peace_be_upon_him) say on the day of Hunayn: It is not lawful for a man who believes in Allah and the last day to water what another has sown with his water (meaning intercourse with women who are pregnant); it is not lawful for a man who believes in Allah and the Last Day to have intercourse with a captive woman till she is free from a menstrual course; and it is not lawful for a man who believes in Allah and the Last Day to sell spoil till it is divided.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2155]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2155

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: If one of you marries a woman or buys a slave, he should say: "O Allah, I ask Thee for the good in her, and in the disposition Thou hast given her; I take refuge in Thee from the evil in her, and in the disposition Thou hast given her." When he buys a camel, he should take hold of the top of its hump and say the same kind of thing.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2157]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2157

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who has intercourse with his wife through her anus is accursed.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2159]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2159

Narrated Abdullah Ibn Abbas:

Ibn Umar misunderstood (the Qur'anic verse, "So come to your tilth however you will")--may Allah forgive him. The fact is that this clan of the Ansar, who were idolaters, lived in the company of the Jews who were the people of the Book. They (the Ansar) accepted their superiority over themselves in respect of knowledge, and they followed most of their actions. The people of the Book (i.e. the Jews) used to have intercourse with their women on one side alone (i.e. lying on their backs). This was the most concealing position for (the vagina of) the women. This clan of the Ansar adopted this practice from them. But this tribe of the Quraysh used to uncover their women completely, and seek pleasure with them from in front and behind and laying them on their backs.

When the muhajirun (the immigrants) came to Medina, a man married a woman of the Ansar. He began to do the same kind of action with her, but she disliked it, and said to him: We were approached on one side (i.e. lying on the back); do it so, otherwise keep away from me. This matter of theirs spread widely, and it reached the Apostle of Allah (peace_be_upon_him).

So Allah, the Exalted, sent down the Qur'anic verse: "Your wives are a tilth to you, so come to your tilth however you will," i.e. from in front, from behind or lying on the back. But this verse meant the place of the delivery of the child, i.e. the vagina.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2161]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2161

Narrated Aisha, Ummul Mu'minin:

I and the Apostle of Allah (peace_be_upon_him) used to lie in one cloth at night while I was menstruating. If anything from me smeared him, he washed the same place (that was smeared), and did not wash beyond it. If anything from him smeared his clothe, he washed the same place and did not wash beyond that, and prayed with it (i.e. the clothe).


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2163]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2163

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said about a man who has sexual intercourse with a menstruating woman: He should give one or half dinar as sadaqah.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2164]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2164

Narrated Abdullah ibn Abbas:

If a man has sexual intercourse (with menstruating woman) during her bleeding, he should give one dinar as sadaqah, and if he does so when bleeding has stopped, he should give half a dinar as sadaqah.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2166]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2166

Narrated AbuSa'id al-Khudri:

A man said: Apostle of Allah, I have a slave-girl and I withdraw the penis from her (while having intercourse), and I dislike that she becomes pregnant. I intend (by intercourse) what the men intend by it.

The Jews say that withdrawing the penis (azl) is burying the living girls on a small scale. He (the Prophet) said: The Jews told a lie. If Allah intends to create it, you cannot turn it away.


Dawud :: Marriage (Kitab Al-Nikah) :: [11.2169]

Marriage (Kitab Al-Nikah)

Dawud :: Book 11 : Hadith 2169

Narrated AbuHurayrah:

AbuNadrah reported: An old man of Tufawah said to me: I was a guest of AbuHurayrah at Medina. I did not find any one of the companions of the Prophet (peace_be_upon_him) more devoted to worship and more hospitable than AbuHurayrah.

One day I was with him when he was sitting on his bed. He had a purse which contained pebbles or kernels. A black slave-girl of his was sitting below. Counting them he was glorifying Allah. When the pebbles or the kernels in the purse were finished, she gathered them and put them again in the purse, and gave it to him. He said: Should I not tell you about me and about the Apostle of Allah (peace_be_upon_him)?

I said: Yes. He said: Once when I was laid up with fever in the mosque, the Apostle of Allah (peace_be_upon_him) came and entered the mosque, and said: Who saw the youth of ad-Daws. He said this three times.

A man said: Apostle of Allah, there he is, laid up with fever on one side of the mosque. He moved, walking forward till he reached me. He placed his hand on me. He had a kind talk with me, and I rose. He then began to walk till he reached the place where he used to offer his prayer. He paid his attention to the people. There were two rows of men and one row of women, or two rows of women and one row of men (the narrator is doubtful).

He then said: If Satan makes me forget anything during the prayer, the men should glorify Allah, and the women should clap their hands. The Apostle of Allah (peace_be_upon_him) then prayed and he did not forget anything during the prayer.

He said: Be seated in your places, be seated in your places. The narrator, Musa, added the word "here". He then praised Allah and exalted Him, and said: Now to our topic.

The agreed version begins: He then said: Is there any man among you who approaches his wife, closes the door, covers himself with a curtain, and he is concealed with the curtain of Allah?

They replied: Yes. He said: later he sits and says: I did so-and-so; I did so-and-so. The people kept silence. He then turned to the women and said (to them): Is there any woman among you who narrates it? They kept silence. Then a girl fell on one of her knees. The narrator, Mu'ammil, said in his version: a buxom girl. She raised her head before the Apostle of Allah (peace_be_upon_him) so that he could see her and listen to her.

She said: Apostle of Allah, they (the men) describe the secrets (of intercourse) and they (the women) also describe the secrets (of intercourse) to the people.

He said: Do you know what the similitude is? He said: The likeness of this act is the likeness of a female Satan who meets the male Satan on the roadside; he fulfils his desire with her while the people are looking at him. Beware! The perfume of men is that whose smell becomes visible and its colour does not appear. Beware! The perfume of women is that whose colour becomes visible and whose smell is not obvious.

AbuDawud said: From here I remembered this tradition from Mu'ammil and Musa: Beware! No man should lie with another man, no woman should lie with another woman except with one's child or father. He also mentioned a third which I have forgotten. This has been mentioned in the version of Musaddad, but I do not remember it as precisely as I like.

The narrator, Musa, said: Hammad narrated this tradition from al-Jarir from AbuNadrah from at-Tufawi.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2170]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2170

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Anyone who incites a woman against her husband or a slave against his master is not one of us.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2172]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2172

Narrated Muharib:

The Prophet (peace_be_upon_him) said: Allah did not make anything lawful more abominable to Him than divorce.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2173]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2173

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Of all the lawful acts the most detestable to Allah is divorce.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2180]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2180

Narrated Abdullah ibn Umar:

AbdurRahman ibn Ayman, the client of Urwah, asked Ibn Umar and AbuzZubayr was was listening: What do you think if a man divorces his wife while she is menstruating? He said: Abdullah ibn Umar divorced his wife while she was menstruating during the time of the Apostle of Allah (peace_be_upon_him).So Umar asked the Apostle of Allah (peace_be_upon_him) saying: Abdullah ibn Umar divorced his wife while she was menstruating. Abdullah said: He returned her to me and did not count it (the pronouncement) anything. He said: When she is purified, he may divorce her or keep her with him. Ibn Umar said: The Prophet (peace_be_upon_him) recited the Qur'anic verse: O Prophet, when you divorce women, divorce them in the beginning of their waiting period."


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2181]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2181

Narrated Imran ibn Husayn:

Mutarrif ibn Abdullah reported:Imran ibn Husayn was asked about a person who divorces his wife, and then has intercourse with her, but he does not call any witness to her divorce nor to her restoration. He said: You divorced against the sunnah and took her back against the sunnah. Call someone to bear witness to her divorce, and to her return in marriage, and do not repeat it.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2182]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2182

Narrated Abdullah ibn Abbas:

Umar ibn Mu'tab reported: AbuHasan, a client of Banu Nawfal asked Ibn Abbas: A slave had a wife who was a slave-girl. He divorced her by two pronouncements. Afterwards both of them were freed. Is it permissible for him to ask her in marriage again? He said: Yes. This is a decision given by the Apostle of Allah (peace_be_upon_him).


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2183]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2183

Narrated Abdullah ibn Abbas:

The aforesaid tradition (No. 2182) has also been transmitted by Ali (ibn al-Mubarak) through a different chain of narrators to the same effect.

This version adds: Ibn Abbas said: There remained one more pronouncement of divorce for you. The Apostle of Allah (peace_be_upon_him) took the same decision.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2184]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2184

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: The divorce of a slave-woman consists in saying it twice and her waiting period is two menstrual courses (qur') AbuAsim said: A similar tradition has been narrated to me by Muzahir and al-Qasim on the authority of Aisha from the Prophet (peace_be_upon_him), except that he said: And her waiting period ('iddah) is two courses.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2185]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2185

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: There is no divorce except in what you possess; there is no possession, there is no sale transaction till you possess. The narrator Ibn as-Sabbah added: There is no fulfilling a vow till you possess.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2188]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2188

Narrated Aisha, Ummul Mu'minin:

Muhammad ibn Ubayd ibn AbuSalih who lived in Ayliya said: I went out with Adi ibn Adi al-Kindi till we came to Mecca. He sent me to Safiyyah daughter of Shaybah who remembered a tradition (that she had heard) from Aisha. She said: I heard Aisha say: I heard the Apostle of Allah (peace_be_upon_him) say: There is no divorce or emancipation in case of constraint or duress (ghalaq).


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2189]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2189

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: There are three things which, whether undertaken seriously or in jest, are treated as serious: Marriage, divorce and taking back a wife (after a divorce which is not final)


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2190]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2190

Narrated Abdullah ibn Abbas:

Divorced women shall wait concerning themselves for three monthly periods. Nor is it lawful for them to hide what Allah hath created in their wombs. This means that if a man divorced his wife he had the right to take her back in marriage though he had divorced her by three pronouncements. This was then repealed (by a Qur'anic verse). Divorce is only permissible twice.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2191]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2191

Narrated Abdullah ibn Abbas:

Abdu Yazid, the father of Rukanah and his brothers, divorced Umm Rukanah and married a woman of the tribe of Muzaynah. She went to the Prophet (peace_be_upon_him) and said: He is of no use to me except that he is as useful to me as a hair; and she took a hair from her head. So separate me from him. The Prophet (peace_be_upon_him) became furious. He called on Rukanah and his brothers. He then said to those who were sitting beside him. Do you see so-and-so who resembles Abdu Yazid in respect of so-and-so; and so-and-so who resembles him in respect of so-and-so? They replied: Yes. The Prophet (peace_be_upon_him) said to Abdu Yazid: Divorce her. Then he did so. He said: Take your wife, the mother of Rukanah and his brothers, back in marriage. He said: I have divorced her by three pronouncements, Apostle of Allah. He said: I know: take her back. He then recited the verse: "O Prophet, when you divorce women, divorce them at their appointed periods."


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2194]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2194

Narrated Abdullah ibn Abbas:

Tawus said: AbusSahba' said to Ibn Abbas: Do you know that a divorce by three pronouncements was made a single one during the time of the Prophet (peace_be_upon_him), and of AbuBakr and in the early days of the caliphate of Umar? He replied: Yes.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2198]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2198

Narrated AbuHurayrah:

Hammad ibn Zayd said: I asked Ayyub: Do you know anyone who narrates the tradition narrated by Al-Hasan about uttering the words (addressing wife). "Your matter is in your hand"? He replied: No, except something similar transmitted by Qatadah from Kathir, the client of Samurah, from AbuSalamah on the authority of AbuHurayrah from the Prophet (peace_be_upon_him). Ayyub said: Kathir then came to us; so I asked him (about this matter). He replied: I never narrated it. I mentioned it to Qatadah who said: Yes (he narrated it) but he forgot.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2202]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2202

Narrated Rukanah ibn Abdu Yazid:

(Rukanah) divorced his wife absolutely; so he came to the Apostle of Allah (peace_be_upon_him). He asked (him): What did you intend? He said: A single utterance of divorce. He said: Do you swear by Allah? He replied: I swear by Allah. He said: It stands as you intended.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2204]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2204

Narrated Tamimah al-Hujayni:

A man said to his wife: O my younger sister! The Apostle of Allah (peace_be_upon_him)said: Is she your sister? He (the Prophet disliked it and prohibited saying so.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2207]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2207

Narrated Salamah ibn Sakhr al-Bayadi:

I was a man who was more given than others to sexual intercourse with women. When the month of Ramadan came, I feared lest I should have intercourse with my wife, and this evil should remain with me till the morning. So I made my wife like my mother's back to me till the end of Ramadan. But one night when she was waiting upon me, something of her was revealed. Suddenly I jumped upon her. When the morning came I went to my people and informed them about this matter.

I said: Go along with me to the Apostle of Allah (peace_be_upon_him).

They said: No, by Allah. So I went to the Prophet (peace be upon him and informed him of the matter.

He said: Have you really committed it, Salamah? I said: I committed it twice, Apostle of Allah. I am content with the Commandment of Allah, the Exalted; so take a decision about me according to what Allah has shown you.

He said: Free a slave. I said: By Him Who sent you with truth, I do not possess a neck other than this: and I struck the surface of my neck.

He said: Then fast two consecutive months. I said: Whatever I suffered is due to fasting.

He said: Feed sixty poor people with a wasq of dates.

I said: By Him Who sent you with truth, we passed the night hungry; there was no food in our house.

He said: Then go to the collector of sadaqah of Banu Zurayq; he must give it to you. Then feed sixty poor people with a wasq of dates; and you and your family eat the remaining dates. Then I came back to my people, and said (to them): I found with you poverty and bad opinion; and I found with the Prophet (peace_be_upon_him) prosperity and good opinion. He has commanded me to give alms to you.

Ibn al-Ala' added: Ibn Idris said: Bayadah is a sub-clan of Banu Zurayq.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2208]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2208

Narrated Khuwaylah, daughter of Malik ibn Tha'labah:

My husband, Aws ibn as-Samit, pronounced the words: You are like my mother. So I came to the Apostle of Allah (peace_be_upon_him), complaining to him about my husband.

The Apostle of Allah (peace_be_upon_him) disputed with me and said: Remain dutiful to Allah; he is your cousin.

I continued (complaining) until the Qur'anic verse came down: "Allah hath heard the words of her who disputeth with thee concerning her husband...." till the prescription of expiation.

He then said: He should set free a slave. She said: He cannot afford it. He said: He should fast for two consecutive months. She said: Apostle of Allah, he is an old man; he cannot keep fasts. He said: He should feed sixty poor people. She said: He has nothing which he may give in alms. At that moment an araq (i.e. date-basket holding fifteen or sixteen sa's) was brought to him.

I said: I shall help him with another date-basked ('araq). He said: You have done well. Go and feed sixty poor people on his behalf, and return to your cousin. The narrator said: An araq holds sixty sa's of dates.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2212]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2212

Narrated Urwah:

Khawlah was the wife of Aws ibn as-Samit; he was a man immensely given to sexual intercourse. When his desire for intercourse was intensified, he made his wife like his mother's back. So Allah, the Exalted, sent down Qur'anic verses relating to expiation for zihar.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2214]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2214

Narrated Ikrimah:

A man made his wife like the back of his mother. He then had intercourse with her before he atoned for it. He came to the Prophet (peace_be_upon_him) and informed him of this matter. He asked (him): What moved you to the action you have committed? He replied: I saw the whiteness of her shins in moon light. He said: Keep away from her until you expiate for your deed.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2218]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2218

Narrated Thawban:

The Prophet (peace_be_upon_him) said: If any woman asks her husband for divorce without some strong reason, the odour of Paradise will be forbidden to her.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2219]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2219

Narrated Habibah, daughter of Sahl al-Ansariyyah:

Amrah, daughter of AbdurRahman ibn Sa'd ibn Zurarah, reported on the authority of Habibah, daughter of Sahl al-Ansariyyah: She (Habibah) was the wife of Thabit ibn Qays ibn Shimmas. The Apostle of Allah (peace_be_upon_him) came out one morning and found Habibah by his door.

The Apostle of Allah (peace_be_upon_him) said: Who is this? She replied: I am Habibah, daughter of Sahl. He asked: What is your case? She replied: I and Thabit ibn Qays, referring to her husband, cannot live together.

When Thabit ibn Qays came, the Apostle of Allah (peace_be_upon_him) said to him: This is Habibah, daughter of Sahl, and she has mentioned (about you) what Allah wished to mention.

Habibah said: Apostle of Allah, all that he gave me is with me.

The Apostle of Allah (peace_be_upon_him) said to Thabit ibn Qays: Take it from her. So he took it from her, and she lived among her people (relatives).


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2220]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2220

Narrated Aisha, Ummul Mu'minin:

Habibah daughter of Sahl was the wife of Thabit ibn Qays Shimmas He beat her and broke some of her part. So she came to the Prophet (peace_be_upon_him) after morning, and complained to him against her husband. The Prophet (peace_be_upon_him) called on Thabit ibn Qays and said (to him): Take a part of her property and separate yourself from her. He asked: Is that right, Apostle of Allah? He said: Yes. He said: I have given her two gardens of mine as a dower, and they are already in her possession. The Prophet (peace_be_upon_him) said: Take them and separate yourself from her.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2221]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2221

Narrated Abdullah ibn Abbas:

The wife of Thabit ibn Qays separated herself from him for a compensation. The Prophet (peace_be_upon_him) made her waiting period a menstrual course.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2228]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2228

Narrated Aisha, Ummul Mu'minin:

Barirah was emancipated, and she was the wife of Mughith, a slave of Aal AbuAhmad. The Apostle of Allah (peace_be_upon_him) gave her choice, and said to her: If he has intercourse with you, then there is no choice for you.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2229]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2229

Narrated Aisha, Ummul Mu'minin:

Al-Qasim said: Aisha intended to set free two slaves of her who were spouses. She, therefore, asked the Prophet (peace_be_upon_him) about this matter. He commanded to begin with the man before the woman. The narrator Nasr said: AbuAli al-Hanafi reported it to me on the authority of Ubaydullah.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2230]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2230

Narrated Abdullah ibn Abbas:

A man came after embracing Islam during the time of the Apostle of Allah (peace_be_upon_him). Afterwards his wife came after embracing Islam. He said: Apostle of Allah, she embraced Islam along with me; so restore her to me.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2231]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2231

Narrated Abdullah ibn Abbas:

A woman embraced Islam during the time of the Apostle of Allah (peace_be_upon_him); she then married. Her (former) husband then came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, I have already embraced Islam, and she had the knowledge about my Islam. The Apostle of Allah (peace_be_upon_him) took her away from her latter husband and restored her to her former husband.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2232]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2232

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) restored his daughter Zaynab to Abul'As on the basis of the previous marriage, and he did not do anything afresh.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2233]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2233

Narrated Al-Harith ibn Qays al-Asadi:

I embraced Islam while I had eight wives. So I mentioned it to the Prophet (peace_be_upon_him). The Prophet (peace_be_upon_him) said: Select four of them.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2235]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2235

Narrated Fayruz ad-Daylami al-Yamani:

I said: Apostle of Allah, I have embraced Islam and two sisters are my wives. He said: Divorce any one of them you wish.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2236]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2236

Narrated Rafi' ibn Sinan:

AbdulHamid ibn Ja'far reported from his father on the authority of his grandfather Rafi' ibn Sinan that he (Rafi' ibn Sinan) embraced Islam and his wife refused to embrace Islam. She came to the Prophet (peace_be_upon_him) and said: My daughter; she is weaned or about to wean. Rafi' said: My daughter. The Prophet (peace_be_upon_him) said to him: Be seated on a side. And he said to her: Be seated on a side. He then seated the girl between them, and said to them: Call her. The girl inclined to her mother. The Prophet (peace_be_upon_him) said: O Allah! guide her. The daughter then inclined to her father, and he took her.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2247]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2247

Narrated Abdullah Ibn Abbas:

Hilal ibn Umayyah was one of three people whose repentance was accepted by Allah. One night he returned from his land and found a man with his wife. He witnessed with his eyes and heard with his ears. He did not threaten him till the morning.

Next day he went to the Apostle of Allah (peace_be_upon_him) in the morning, and said: Apostle of Allah! I came to my wife at night and found a man with her. I saw with my own eyes and heard with my own ears. The Apostle of Allah (peace_be_upon_him) disliked what he described and he took it seriously.

Thereupon the following Qur'anic verse came down: "And those who make charges against their spouses but have no witnesses except themselves, let the testimony of one of them...."

When the Apostle of Allah (peace_be_upon_him) came to himself (after the revelation ended), he said: Glad tidings for you, Hilal. Allah, the Exalted, has made it easy and, a way out for you.

Hilal said: I expected that from my Lord. The Apostle of Allah (peace_be_upon_him) said: Send for her. She then came. The Apostle of Allah (peace_be_upon_him) recited (the verses) to them that the punishment in the next world was more severe than that in this world.

Hilal said: I swear by Allah, I spoke the truth against her. She said: He told a lie.

The Apostle of Allah (peace_be_upon_him) said: Apply the method of invoking curses on each other. Hilal was told: Bear witness. So he bore witness before Allah four times that he spoke the truth.

When he was about to utter a fifth time, he was told: Hilal, fear Allah, for the punishment in this world is easier than that in the next world; and this is the deciding one that will surely cause punishment to you.

He said: I swear by Allah. Allah will not punish me for this (act), as He did not cause me to be flogged for this (act). So he bore witness a fifth time invoking the curse of Allah on him if he was one of those who told lies.

Then the people said to her: Testify. So she gave testimony before Allah that he was a liar.

When she was going to testify a fifth time, she was told: Fear Allah, for the punishment in this world is easier than that in the next world. This is the deciding one that will surely cause punishment to you.

She hesitated for a moment, and then said: By Allah, I shall not disgrace my people. So she testified a fifth time invoking the curse of Allah on her if he spoke the truth.

The Apostle of Allah (peace_be_upon_him) separated them from each other, and decided that the child would not be attributed to its father. Neither she nor her child would be accused of adultery. He who accused her or her child would be liable to punishment. He also decided that there would be no dwelling and maintenance for her (from the husband), as they were separated without divorce.

He then said: If she gives birth to a child with reddish hair, light buttocks, wide belly and light shins, he will be the child of Hilal. If she bears a dusky child with curly hair, fat limbs, fat shins and fat buttock he will be the child of the one who was accused of adultery. She gave birth to a dusky child with curly hair, fat limbs, fat shins and fat buttocks.

The Apostle of Allah (peace_be_upon_him) said: Had there been no oaths I should have dealt with her severely.

Ikrimah said: Later on he became the chief of the tribe of Mudar. He was not attributed to his father.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2255]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2255

Narrated AbuHurayrah:

A bedouin came to the Prophet (peace_be_upon_him), and said: My wife has given birth to a black son, and I disown him. He then narrated the rest of the tradition to the same effect.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2256]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2256

Narrated AbuHurayrah:

AbuHurayrah heard the Apostle of Allah (peace_be_upon_him) say when the verse about invoking curses came down: Any woman who brings to her family one who does not belong to it has nothing to do with Allah (i.e. expects no mercy from Allah), and Allah will not bring her into His Paradise.

Allah, the Exalted, will veil Himself from any man who disowns his child when he looks at him, and disgrace him in the presence of all creatures, first and last.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2257]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2257

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: There is no prostitution in Islam. If anyone practised prostitution in pre-Islamic times, the child will be attributed to the master (of the slave-woman). He who claims his child without a valid marriage or ownership will neither inherit nor be inherited.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2258]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2258

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) decided regarding one who was treated as a member of a family after the death of his father, to whom he was attributed when the heirs said he was one of them, that if he was the child of a slave-woman whom the father owned when he had intercourse with her, he was included among those who sought his inclusion, but received none of the inheritance which was previously divided; he, however, received his portion of the inheritance which had not already been divided; but if the father to whom he was attributed had disowned him, he was not joined to the heirs.

If he was a child of a slave-woman whom the father did not possess or of a free woman with whom he had illicit intercourse, he was not joined to the heirs and did not inherit even if the one to whom he was attributed is the one who claimed paternity, since he was a child of fornication whether his mother was free or a slave.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2260]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2260

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) entered upon me. The version of Musaddad and Ibn as-Sarh has: one day looking pleased". The version of Uthman has: "The lines of his forehead were realised." He said: O Aisha, are you not surprised to hear that Mujazziz al-Mudlaji saw that Zayd and Usamah had a rug over them concerning their heads and letting their feet appear. He said: These feet are related.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2262]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2262

Narrated Zayd ibn Arqam:

I was sitting with the Prophet (peace_be_upon_him). A man came from the Yemen, and said: Three men from the people of the Yemen came to Ali, quarrelling about a child, asking him to give a decision. They had had sexual intercourse with a woman during a single state of purity.

He said to two of them: Give this child to this man (the third person) with pleasure. But they (refused and) cried loudly. Again he said to two of them: Give the child to the man (the third person) willingly. But they (refused and) cried loudly. He then said: You are quarrelsome partners. I shall cast lots among you; he who receives the lot, will acquire the child, and he shall pay two-thirds of the blood-money to both his companions. He then cast lots among them, and gave the child to the one who received the lot. The Apostle of Allah (peace_be_upon_him) laughed so much that his canine or molar teeth appeared.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2263]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2263

Narrated Zayd ibn Arqam:

Three persons were brought to Ali (Allah be pleased with him) when he was in the Yemen. They and sexual intercourse with a woman during a single state of purity. He asked two of them: Do you acknowledge this child for this (man)? They replied: No. He then put this (question) to all of them. Whenever he asked two of them, they replied in the negative. He, therefore, cast a lot among them, and attributed the child to the one who received the lot. He imposed two-third of the blood-money (i.e. the price of the mother) on him. This was then mentioned to the Prophet (peace_be_upon_him) and he laughed so much that his molar teeth appeared.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2267]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2267

Narrated Abdullah ibn Amr ibn al-'As:

A man got up and said: Apostle of Allah, so-and-so is my son; I had illicit intercourse with his mother in the pre-Islamic period. The Apostle of Allah (peace_be_upon_him) said: There is no unlawful claiming of paternity in Islam. What was done in pre-Islamic times has been annulled. The child is attributed to the one on whose bed it is born, and the fornicator is deprived of any right.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2268]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2268

Narrated Uthman ibn Affan:

Rabah said: My people married me to a Roman slave-girl of theirs. I had intercourse with her, and she gave birth to a black (male) child like me. I named it Abdullah. I again had intercourse with her, and she gave birth to a black (male) child like me. I named it Ubaydullah. Then a Roman slave of my people, called Yuhannah, incited her, and spoke to her in his own unintelligible language. She gave birth to a son like a chameleon (red).

I asked her: What is this? She replied: This belongs to Yuhannah. We then brought the case to Uthman (for a decision). I think Mahdi said these words. He inquired from both of them, and they acknowledged (the facts).

He then said to them: Do you agree that I take the decision about you, which the Apostle of Allah (peace_be_upon_him) had taken? The Apostle of Allah (peace_be_upon_him) decided that the child was to attributed to the one on whose bed it was born. And I think he said: He flogged her and flogged him, for they were slaves.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2269]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2269

Narrated Abdullah ibn Amr ibn al-'As:

A woman said: Apostle of Allah, my womb is a vessel to this son of mine, my breasts, a water-skin for him, and my lap a guard for him, yet his father has divorced me, and wants to take him away from me. The Apostle of Allah (peace_be_upon_him) said: You have more right to him as long as you do not marry.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2270]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2270

Narrated AbuHurayrah:

Hilal ibn Usamah quoted AbuMaymunah Salma, client of the people of Medina, as saying: While I was sitting with AbuHurayrah, a Persian woman came to him along with a son of hers. She had been divorced by her husband and they both claimed him.

She said: AbuHurayrah, speaking to him in Persian, my husband wishes to take my son away.

AbuHurayrah said: Cast lots for him, saying it to her in a foreign language.

Then her husband came and asked: Who is disputing with me about my son?

AbuHurayrah said: O Allah, I do not say this, except that I heard a woman who came to the Apostle of Allah (peace_be_upon_him) while I was sitting with him, and she said: My husband wishes to take away my son, Apostle of Allah, and he draws water for me from the well of AbuInabah, and he has been good to me.

The Apostle of Allah (peace_be_upon_him) said: Cast lots for him. Her husband said: Who is disputing with me about my son? The Prophet (peace_be_upon_him) said: This is your father and this your mother, so take whichever of them you wish by the hand. So he took his mother's hand and she went away with him.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2271]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2271

Narrated Ali ibn AbuTalib:

Zayd ibn Harithah went out to Mecca and brought the daughter of Hamzah with him. Then Ja'far said: I shall take her; I have more right to her; she is my uncle's daughter and her maternal aunt is my wife; the maternal aunt is like mother. Ali said: I am more entitled to take her. She is my uncle's daughter. The daughter of the Apostle of Allah (peace_be_upon_him) is my wife, and she has more right to her. Zayd said: I have more right to her. I went out and journeyed to her, and brought her with me. The Prophet (peace_be_upon_him) came out.

The narrator mentioned the rest of the tradition. He (i.e. the Prophet) said: As for the girl, I decided in favour of Ja'far. She will live with her maternal aunt. The maternal aunt is like mother.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2273]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2273

Narrated Ali ibn AbuTalib:

When we came out from Mecca, Hamzah's daughter pursued us crying: My uncle. Ali lifted her and took her by the hand. (Addressing Fatimah he said:) Take your uncle's daughter. She then lifted her. The narrator then transmitted the rest of the tradition. Ja'far said: She is my uncle's daughter. Her maternal aunt is my wife. The Prophet (peace_be_upon_him) decided in favour of her maternal aunt, and said: The maternal aunt is like mother.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2274]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2274

Narrated Asma bint Yazid al-Ansariyyah:

Amr ibn Muhajir reported on the authority of his father: Asma', daughter of Yazid ibn as-Sakan al-Ansariyyah, was divorced in the time of the Apostle of Allah (peace_be_upon_him). No waiting period was prescribed for a divorced woman (at that time). When Asma' was divorced, Allah, the Exalted, sent down the injunction of waiting period for divorce. She is the first of the divorced women about whom the verse relating to waiting period was sent down.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2275]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2275

Narrated Abdullah ibn Abbas:

Women who are divorced shall wait, keeping themselves apart, three monthly courses; and then said: And for such of your women as despair of menstruation, if ye doubt, their period (of waiting) shall be three months. This was abrogated from the former verse. Again he said: (O ye who believe, if ye wed believing women) and divorce them before ye have touched them, then there is no period that ye should reckon."


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2276]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2276

Narrated Umar ibn al-Khattab:

The Prophet (peace_be_upon_him) divorced Hafsah, but he took her back in marriage.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2282]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2282

Narrated Fatimah daughter of Qays:

AbuSalamah reported on the authority of Fatimah daughter of Qays who said to him that she was the wife of AbuHafs ibn al-Mughirah who divorced her by three pronouncements. She said that she came to the Apostle of Allah (peace_be_upon_him) and sought his opinion about her going out from her house. He commanded her to shift to (the house of )Ibn Umm Maktum who was blind. Marwan denied to confirm the tradition of Fatimah about the going out of a divorced woman from her house. Urwah said: Aisha objected to Fatimah daughter of Qays.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2285]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2285

Narrated Aisha, Ummul Mu'minin:

Urwah said: Aisha (Allah be pleased with her) severely objected to the tradition of Fatimah daughter of Qays. She said: Fatimah lived in a desolate house and she feared for her loneliness there. Hence the Apostle of Allah (peace_be_upon_him) accorded permission to her (to leave the place).


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2286]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2286

Narrated Aisha, Ummul Mu'minin:

Urwah ibn az-Zubayr said: Aisha was asked: Did you not see (i.e. known) the statement of Fatimah? She replied: It is not good for her to mention it (to others).


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2288]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2288

Narrated Aisha, Ummul Mu'minin:

Al-Qasim ibn Muhammad and Sulayman ibn Yasar reported: Yahya ibn Sa'id ibn al-'As divorced the daughter of AbdurRahman ibn al-Hakam absolutely. AbdurRahman shifted her (from there). Aisha sent a message to Marwan ibn al-Hakam who was the governor of Medina, and said to him: Fear Allah, and return the woman to her home. Marwan said (according to Sulayman's version): AbdurRahman forced me. Marwan said (according to the version of al-Qasim): Did not the case of Fatimah daughter of Qays reach you? Aisha replied: There would be no harm to you if you did not make mention of the tradition of Fatimah. Marwan said: If you think that it was due to some evil (i.e. reason), then it is sufficient for you to see that there is also an evil between the two.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2292]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2292

Narrated Umm Salamah ; Umm Habibah ; Zaynab bint Jahsh:

Humayd ibn Nafi' reported the following three traditions on the authority of Zaynab, daughter of AbuSalamah:

Zaynab said: I visited Umm Habibah when her father AbuSufyan, died. She asked for some yellow perfume containing saffron (khaluq) or something else. Then she applied it to a girl and touched her cheeks.

She said: I have no need of perfume, but I heard the Apostle of Allah (peace_be_upon_him) say: It is not lawful for a woman who believes in Allah and the Last Day to observe mourning for one who has died, more than three nights, except for four months and ten days in the case of a husband.

Zaynab said: I also visited Zaynab, daughter of Jahsh, when her brother died. She asked for some perfume and used it upon herself.

She then said: I have no need of perfume, but I heard the Apostle of Allah (peace_be_upon_him) say when he was on the pulpit: It is not lawful for a woman who believes in Allah and the Last Day to observe mourning for one who has died, more than three nights, except for four months and ten days in the case of a husband.

Zaynab said: I heard my mother, Umm Salamah, say: A woman came to the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah, the husband of my daughter has died, and she is suffering from sore eyes; may we put antimony in her eyes?

The Apostle of Allah (peace_be_upon_him) said: No. He said this twice or thrice. Each time he said: No. The Apostle of Allah (peace_be_upon_him) said: The waiting period is now four months and ten days. In pre-Islamic days one of you used to throw away a piece of dung at the end of a year.

Humayd said: I asked Zaynab: What do you mean by throwing away a piece of dung at the end of a year.

Zaynab replied: When the husband of a woman died, she entered a small cell and put on shabby clothes, not touching perfume or any other thing until a year passed. Then an animal such as donkey or sheep or bird was provided for her. She rubbed herself with it. The animal with which she rubbed herself rarely survived. She then came out and was given a piece of dung which she threw away. She then used perfume or something else which she desired.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2293]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2293

Narrated Furay'ah, daughter of Malik ibn Sinan:

Zaynab, daughter of Ka'b ibn Ujrah narrated that Furay'ah daughter of Malik ibn Sinan, told her that she came to the Apostle of Allah (peace_be_upon_him) and asked him whether she could return to her people, Banu Khidrah, for her husband went out seeking his slaves who ran away. When they met him at al-Qudum, they murdered him.

So I asked the Apostle of Allah (peace_be_upon_him): "Should I return to my people, for he did not leave any dwelling house of his own and maintenance for me?

She said: The Apostle of Allah (peace_be_upon_him) replied: Yes. She said: I came out, and when I was in the apartment or in the mosque, he called for me, or he commanded (someone to call me) and, therefore, I was called.

He said: what did you say? So I repeated my story which I had already mentioned about my husband. Thereupon he said: Stay in your house till the term lapses. She said:

So I passed my waiting period in it (her house) for four months and ten days. When Uthman ibn Affan became caliph, he sent for me and asked me about that; so I informed him, and he followed it and decided cases accordingly.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2297]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2297

Narrated Umm Salamah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: A woman whose husband has died must not wear clothes dyed with safflower (usfur) or with red ochre (mishq) and ornaments. She must not apply henna and collyrium.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2298]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2298

Narrated Umm Salamah, Ummul Mu'minin:

Umm Hakim, daughter of Usayd, reported on the authority of her mother that her husband died and she was suffering from sore eyes. She therefore applied collyrium (jala'). Ahmad said: The correct version is "glittering collyrium (kuhl al-jala'). She sent her slave-girl to Umm Salamah, and she asked her about the use of glittering collyrium (kuhl al-jala').

She said: Do not apply it except in the case of dire need which is troubling you. In that case you can use it at night, but you should remove it in the daytime. Then Umm Salamah said: The Apostle of Allah (peace_be_upon_him) came to visit me when AbuSalamah died, and I had put the juice of aloes in my eye.

He asked : What is this, Umm Salamah? I replied: It is only the juice of aloes and contains no perfume. He said: It gives the face a glow, so apply it only at night and remove it in daytime, and do not comb yourself with scent or henna, for it is a dye. I asked: What should I use when I comb myself, Apostle of Allah? He said: Use lote-tree leaves and smear your head copiously with them.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2300]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2300

Narrated Abdullah ibn Mas'ud:

I can invoke the curse of Allah on anyone who wishes: The smaller surat an-Nisa (i.e. Surat at-Talaq) was revealed after the verse regarding the waiting period of four months and ten days had been revealed.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2301]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2301

Narrated Amr ibn al-'As:

Do not confuse us about his Sunnah. Ibn al-Muthanna said: The Sunnah of our Prophet (peace_be_upon_him) is that the waiting period of a slave-mother whose husband has died is four months and ten days.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2302]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2302

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) was asked about a man who divorced his wife three times, and she married another who entered upon her, but divorced her before having intercourse with her, whether she was lawful for the former husband. She said: The Prophet (peace_be_upon_him) replied: She is not lawful for the first (husband) until she tastes the honey of the other husband and he tastes her honey.


Dawud :: Divorce (Kitab Al-Talaq) :: [12.2304]

Divorce (Kitab Al-Talaq)

Dawud :: Book 12 : Hadith 2304

Narrated Jabir ibn Abdullah:

Musaykah, a slave-girl of some Ansari, came and said: My master forces me to commit fornication. Thereupon the following verse was revealed: "But force not your maids to prostitution (when they desire chastity)."


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2306]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2306

Narrated Abdullah ibn Abbas:

Ibn Abbas explained the following Qur'anic verse: "O ye who believe! fasting is prescribed for you as it was prescribed for those before you" During the lifetime of the Prophet (peace_be_upon_him), when the people offered night prayer, they were asked to abstain from food and drink and (intercourse with) women, they kept fast till the next night. A man betrayed himself and had intercourse with his wife after he had offered the night prayer, and he did not break his fast. So Allah, the Exalted, intended to make it (fasting) easy for those who survived, thus providing a concession and utility. Allah, the Glorified, said: "Allah knoweth what ye used to do secretly among yourselves." By this Allah benefited the people and provided concession and ease to them.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2311]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2311

Narrated Abdullah ibn Abbas:

Explaining the verse; "For those who can do it (with hard-ship) is a ransom, the feeding of one, that is indigent," he said: This was a concession granted to the aged man and woman who were able to keep fast; they were allowed to leave the fast and instead feed an indigent person for each fast; (and a concession) to pregnant and suckling woman when they apprehended harm (to themselves).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2312]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2312

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: The month consists of twenty-nine days, but do not fast till you sight it (the moon) and do not break your fast till you sight it. If the weather is cloudy, calculate it thirty days. When the twenty-ninth of Sha'ban came, Ibn Umar would send someone (who tried) to sight the moon for him. If it was sighted, then well and good; in case it was not sighted, and there was no cloud and dust before him (on the horizon), he would not keep fast the next day. If there appeared (on the horizon) before him cloud or dust, he would fast the following day. Ibn Umar would end his fasting alone with the people, and did not follow this calculation.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2315]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2315

Narrated Abdullah ibn Mas'ud:

We kept fast for twenty-nine days along with the Prophet (peace_be_upon_him) more often than we kept fast for thirty days.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2317]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2317

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The end of Ramadan is on the day when you end it, and the 'Id (festival) of sacrifice is on the day when you sacrifice. The whole of Arafah is the place of staying, and the whole of Mina is the place of sacrifice, and all the roads of Mecca are the place of sacrifice, and the whole of Muzdalifah is the place of staying.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2318]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2318

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to count the days in Sha'ban in a manner he did not count any other month; then he fasted when he sighted the new moon of Ramadan; but if the weather was cloudy he counted thirty days and then fasted.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2319]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2319

Narrated Hudhayfah:

The Prophet (peace_be_upon_him) said: Do not fast (for Ramadan) before the coming of the month until you sight the moon or complete the number (of thirty days); then fast until you sight the moon or complete the number (of thirty days).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2320]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2320

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Do not fast one day or two days just before Ramadan except in the case of a man who has been in the habit or observing a fast (on that day); and do not fast until you sight it (the moon). Then fast until you sight it. If a cloud appears on that day (i.e. 29th of Ramadan) then complete the number thirty (days) and then end the fasting: a month consists of twenty-nine days.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2322]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2322

Narrated Mu'awiyah:

AbulAzhar al-Mughirah ibn Farwah said: Mu'awiyah stood among the people at Dayr Mustahill lying at the gate of Hims. He said: O people, we sighted the moon on such-and-such day. We shall fast in advance. Anyone who likes to do so may do it. Malik ibn Hubayrah as-Saba'i stood up and asked: Mu'awiyah, did you hear the Apostle of Allah (peace_be_upon_him) say something (about this matter), or is this something on the basis of your opinion? He replied: I heard the Apostle of Allah (peace_be_upon_him) as saying: Fast the month (in the beginning) and in the last.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2327]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2327

Narrated Ammar:

AbuIshaq reported on the authority of Silah: We were with Ammar on the day when the appearance of the moon was doubtful. (The meat of) goat was brought to him. Some people kept aloof from (eating) it. Ammar said: He who keeps fast on this day disobeys AbulQasim (i.e. the Prophet) (peace_be_upon_him).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2329]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2329

Narrated Umm Salamah, Ummul Mu'minin:

She never saw the Prophet (peace_be_upon_him) fasting the whole month except Sha'ban which he combined with Ramadan.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2330]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2330

Narrated AbuHurayrah:

AbdulAziz ibn Muhammad said: Abbad ibn Kathir came to Medina and went to the assembly of al-Ala'. He caught hold of his hand and made him stand and said: O Allah, he narrates a tradition from his father on the authority of AbuHurayrah who reported the Apostle of Allah (peace_be_upon_him) as saying: When the middle of Sha'ban comes, do not fast. Al-Ala' said: O Allah, my father narrated this tradition on the authority of AbuHurayrah from the Prophet (peace_be_upon_him)


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2331]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2331

Narrated Abdullah ibn Umar:

Husayn ibn al-Harith al-Jadli from the tribe of Jadilah Qays said: The governor of Mecca delivered a speech and said: The Apostle of Allah (peace_be_upon_him) took a pledge from us that we should perform the rites of hajj after sighting the moon. If we do not sight it and two reliable persons bear witness, we should perform the rites of hajj on the basis of their witness.

I then asked al-Husayn ibn al-Harith: Who was the governor of Mecca? He replied: I do not know. He then met me later on and told me: He was al-Harith ibn Hatib, brother of Muhammad ibn Hatib. The governor then said: There is among you a man who is more acquainted with Allah and His Apostle than I. He witnessed this from the Apostle of Allah (peace_be_upon_him). He then pointed with his hand to a man. Al-Husayn said: I asked an old man beside me: Who is that man to whom the governor has alluded?

He said: "This is Abdullah ibn Umar, and he spoke the truth. He was more acquainted with Allah than he. He (Abdullah ibn Umar) said: For this is what the Apostle of Allah (peace_be_upon_him) commanded us (to do).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2333]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2333

Narrated Abdullah ibn Abbas:

A bedouin came to the Prophet (peace_be_upon_him) and said: I have sighted the moon. Al-Hasan added in his version: that is, of Ramadan. He asked: Do you testify that there is no god but Allah? He replied: Yes. He again asked: Do you testify that Muhammad is the Apostle of Allah? He replied: Yes. and he testified that he had sighted the moon. He said: Bilal, announce to the people that they must fast tomorrow.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2334]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2334

Narrated Ikrimah:

Once the people doubted the appearance of the moon of Ramadan, and intended neither to offer the tarawih prayer nor to keep fast. A bedouin came from al-Harrah and testified that he had sighted the moon. He was brought to the Prophet (peace_be_upon_him). He asked: Do you testify that there is no god but Allah, and that I am the Apostle of Allah? He said: Yes; and he testified that he had sighted the moon. He commanded Bilal who announced to the people to offer the tarawih prayer and to keep fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2335]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2335

Narrated Abdullah ibn Umar:

The people looked for the moon, so I informed the Apostle of Allah (peace_be_upon_him) that I had sighted it. He fasted and commanded the people to fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2337]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2337

Narrated Al-Irbad ibn Sariyyah:

The Apostle of Allah (peace_be_upon_him) invited me to a meal shortly before dawn in Ramadan saying: Come to the blessed morning meal.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2341]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2341

Narrated Talq ibn Ali al-Yamami:

The Apostle of Allah (peace_be_upon_him) said: Eat and drink; let not the white and ascending light prevent you from (eating and drinking); so eat and drink until the red light spreads horizontally.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2343]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2343

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When any of you hears the summons to prayer while he has a vessel in his hand, he should not lay it down till he fulfils his need.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2346]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2346

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Religion will continue to prevail as long as people hasten to break the fast, because the Jews and the Christians delay doing so.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2348]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2348

Narrated Salman ibn Amir:

The Prophet (peace_be_upon_him) said: When one of you is fasting, he should break his fast with dates; but if he cannot get any, then (he should break his fast) with water, for water is purifying.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2349]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2349

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) used to break his fast before praying with some fresh dates; but if there were no fresh dates, he had a few dry dates, and if there were no dry dates, he took some mouthfuls of water.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2350]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2350

Narrated Abdullah ibn Umar:

Marwan ibn Salim al-Muqaffa' said: I saw Ibn Umar holding his bread with his hand and cutting what exceeded the handful of it. He (Ibn Umar) told that the Prophet (peace_be_upon_him) said when he broke his fast: Thirst has gone, the arteries are moist, and the reward is sure, if Allah wills.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2351]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2351

Narrated Mu'adh ibn Zuhrah:

The Prophet of Allah (peace_be_upon_him) used to say when he broke his fast: O Allah, for Thee I have fasted, and with Thy provision I have broken my fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2357]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2357

Narrated Amir ibn Rabi'ah:

I have seen the Apostle of Allah (peace_be_upon_him) using a tooth-stick while he was fasting. Musaddad added in his version: "more often than I could count."


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2358]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2358

Narrated A Companion of the Prophet:

AbuBakr ibn AbdurRahman reported on the authority of a Companion of the Prophet (peace_be_upon_him): I saw the Prophet (peace_be_upon_him) commanding the people while he was travelling on the occasion of the conquest of Mecca not to observe fast. He said: Be strong for your enemy. The Apostle of Allah (peace_be_upon_him) fasted himself.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2359]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2359

Narrated AbuBakr:

A man who narrated his tradition to me said: I have seen the Apostle of Allah (peace_be_upon_him) in al-Arj pouring water over his head while he was fasting, either because of thirst or because of heat.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2360]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2360

Narrated Laqit ibn Saburah:

The Prophet (peace_be_upon_him) said: Snuff up water freely unless you are fasting.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2361]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2361

Narrated Thawban:

The Prophet (peace_be_upon_him) said: A man who cupped and a man who has himself cupped broke their fast. The narrator Shayban said in his version: AbuQilabah told me that AbuAsma' ar-Rahbi told him that Thawban, the client of the Apostle of Allah (peace_be_upon_him), told him that he heard the Prophet (peace_be_upon_him) say this.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2362]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2362

Narrated Shaddad ibn Aws:

The tradition mentioned above (No. 2361) has also been transmitted by Shaddad ibn Aws through a different chain of narrators.

This version adds: While Shaddad ibn Aws was walking along with the Prophet (peace_be_upon_him)....The narrator then transmitted the rest of the tradition to the same effect.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2367]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2367

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) had himself cupped when he was fasting and wearing ihram (pilgrim garb).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2370]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2370

Narrated A man from the Companions:

The Apostle of Allah (peace_be_upon_him) said: Neither vomiting, nor emission, nor cupping breaks the fast of the one who is fasting.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2374]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2374

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: if one has a sudden attack of vomiting while one is fasting, no atonement is required of him, but if he vomits intentionally he must make atonement.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2378]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2378

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to kiss me when he was fasting and when I was fasting.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2379]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2379

Narrated Umar ibn al-Khattab:

I became gay and happy, so I kissed while I was fasting, I then said: Apostle of Allah, I have done a big deed; I kissed while I was fasting. He said: What do you think if you rinse your mouth with water while you are fasting. The narrator Isa ibn Hammad said in his version: I said to him: There is no harm in it. Then both of them agreed on the version: He said: Then what?


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2380]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2380

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used to kiss her and suck her tongue when he was fasting.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2381]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2381

Narrated AbuHurayrah:

A man asked the Prophet (peace_be_upon_him) whether one who was fasting could embrace (his wife) and he gave him permission; but when another man came to him, and asked him, he forbade him. The one to whom he gave permission was an old man and the one whom he forbade was a youth.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2390]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2390

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone breaks his fast one day in Ramadan without a concession granted to him by Allah, a perpetual fast will not atone for it.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2402]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2402

Narrated Anas ibn Malik:

A man from Banu Abdullah ibn Ka'b brethren of Banu Qushayr (not Anas ibn Malik, the well-known Companion), said: A contingent from the cavalry of the Apostle of Allah (peace_be_upon_him) raided us. I reached (for he said went) to the Apostle of Allah (peace_be_upon_him) who was taking his meals. He said: Sit down, and take some from this meal of ours. I said: I am fasting, he said: Sit down, I shall tell you about prayer and fasting. Allah has remitted half the prayer to a traveller, and fasting to the traveller, the woman who is suckling an infant and the woman who is pregnant, I swear by Allah, he mentioned both (i.e. suckling and pregnant women) or one of them. I was grieved for not taking the food of the Apostle of Allah (peace_be_upon_him).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2404]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2404

Narrated Salamah ibn al-Muhabbaq al-Hudhali:

The Apostle of Allah (peace_be_upon_him) said: If anyone has a riding beast which carries him to where he can get sufficient food, he should keep the fast of Ramadan wherever he is when it comes.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2406]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2406

Narrated AbuBusrah al-Ghifari,:

Ja'far ibn Jubayr said: I accompanied AbuBusrah al-Ghifari, a Companion of the Apostle of Allah (peace_be_upon_him), in a boat proceeding from al-Fustat (Cairo) during Ramadan. He was lifted (to the boat), then his meal was brought to him. The narrator Ja'far said in his version: He did not go beyond the houses (of the city) but he called for the dining sheet. He said (to me): Come near. I said: Do you not see the houses? AbuBusrah said: Do you detest the sunnah (practice) of the Apostle of Allah (peace_be_upon_him)? The narrator Ja'far said in his version: He then ate (it).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2407]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2407

Narrated Dihyah:

Mansur al-Kalbi said: Dihyah ibn Khalifah once went out from a village of Damascus at as much distance as it measures between Aqabah and al-Fustat during Ramadan; and that is three miles. He then broke his fast and the people broke their fast along with him. But some of them disliked to break their fast. When he came back to his village, he said: I swear by Allah, today I witnessed a thing of which I could not even think to see. The people detested the way of the Apostle of Allah (peace_be_upon_him) and his Companions. He said this to those who fasted. At this moment he said: O Allah, make me die.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2409]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2409

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) said: One of you should not say: I fasted the whole of Ramadan, and I prayed during the night in the whole of Ramadan. I do not know whether he disliked the purification; or he (the narrator) said: He must have slept a little and taken rest.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2413]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2413

Narrated Uqbah ibn Amir:

The Prophet (peace_be_upon_him) said: The day of Arafah, the day of sacrifice, the days of tashriq are (the days of) our festival, O people of Islam. These are the days of eating and drinking.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2415]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2415

Narrated As-Samma' sister of Abdullah ibn Busr:

The Prophet (peace_be_upon_him) said: Do not fast on Saturday except what has been made obligatory on you; and if one of you can get nothing but a grape skin or a piece of wood from a tree, he should chew it.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2419]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2419

Narrated AbuQatadah:

A man came to the Prophet (peace_be_upon_him) and said: How do you fast, Apostle of Allah? The Apostle of Allah (peace_be_upon_him) became angry at what he said.

When Umar observed this (his anger), he said: We are satisfied with Allah as Lord, with Islam as religion, and with Muhammad as Prophet. We seek refuge in Allah from the anger of Allah, and from the anger of His Apostle. Umar continued to repeat these words till his anger cooled down. He then asked: Apostle of Allah, what is the position of one who observes a perpetual fast?

He replied: May he not fast or break his fast. Musaddad said in his version: He has neither fasted nor broken his fast. The narrator, Ghaylan, doubted the actual wordings.

He asked: What is the position of one who fasts two days and does not fast one day?

He said: Is anyone able to do that? He asked: What is the position of one who fasts every second day (i.e. fasts one day and does not fasts the next day)?

He (the Prophet) said: This is the fast that David observed.

He asked: Apostle of Allah, what is the position of one who fasts one day and breaks it for two days? He replied: I wish I were given the power to observe that. Then the Apostle of Allah (peace_be_upon_him) said: The observance of three days' fast every month and of one Ramadan to the other (i.e. the fast of Ramadan every year) is (equivalent to) a perpetual fast. I seek from Allah that fasting on the day of Arafah may atone for the sins of the preceding and the coming year, and I seek from Allah that fasting on the day of Ashura' may atone for the sins of the preceding year.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2422]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2422

Narrated Abdullah ibn al-Harith ; or Uncle of Mujibah al-Bahiliyyah:

The father or Uncle of Mujibah al-Bahiliyyah visited the Apostle of Allah (peace_be_upon_him). He then went away and came to him (again) after one year when his condition and appearance had changed.

He said: Apostle of Allah, do you not recognize me? He asked: Who are you? He replied: I am al-Bahili who came to you last year. He said: What has changed you? You were looking well, then you were good in appearance? He said: I have only food at night since I departed from you.

Thereupon the Apostle of Allah (peace_be_upon_him) said: Why did you torment yourself? Fast during Ramadan (the month of patience) and fast for one day every month. He said: Increase it for me, for I have (more) strength. He said: Fast two days. He again said: Increase it for me. He said: Fast three days. He again said: Increase it for me. He said: Fast during the inviolable months and then stop; fast during the inviolable months and then stop; fast during the inviolable months and then stop. He indicated by his three fingers, and joined them and then opened them.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2425]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2425

Narrated Aisha, Ummul Mu'minin:

The month most liked by the Apostle of Allah (peace_be_upon_him) for fasting was Sha'ban. He then joined it with Ramadan.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2426]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2426

Narrated Muslim al-Qurashi:

I asked or someone asked the Prophet (peace_be_upon_him) about perpetual fasting. He replied: You have a duty to your family. Fast during Ramadan and the following month, and every Wednesday and Thursday. You will then have observed a perpetual fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2430]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2430

Narrated Usamah ibn Zayd:

The client of Usamah ibn Zayd said that he went along with Usamah to Wadi al-Qura in pursuit of his camels. He would fast on Monday and Thursday. His client said to him: Why do you fast on Monday and Thursday, while you are an old man? He said: The Prophet of Allah (peace_be_upon_him) used to fast on Monday and Thursday. When he was asked about it, he said: The works of the servants (of Allah) are presented (to Allah) on Monday and Thursday.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2431]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2431

Narrated One of the wives of the Prophet:

Hunaydah ibn Khalid narrated from his wife on the authority of one of the wives of the Prophet (peace_be_upon_him) who said: The Apostle of Allah (peace_be_upon_him) used to fast the first nine days of Dhul-Hijjah, Ashura' and three days of every month, that is, the first Monday (of the month) and Thursday.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2434]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2434

Narrated AbuHurayrah:

Ikrimah said: We were with AbuHurayrah in his house when he narrated to us: The Apostle of Allah (peace_be_upon_him) prohibited fasting on the day of Arafah at Arafah.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2441]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2441

Narrated AbdurRahman ibn Maslamah:

AbdurRahman reported on the authority of his uncle that the people of the tribe Aslam came to the Prophet (peace_be_upon_him). He said (to them): Did you fast on this day? They replied: No. He said: Complete the rest of your day, and make atonement for it.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2443]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2443

Narrated Qatadah Ibn Malhan al-Qaysi:

The Apostle of Allah (peace_be_upon_him) used to command us to fast the days of the white (nights): thirteenth, fourteenth and fifteenth of the month. He said: This is like keeping perpetual fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2444]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2444

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) used to fast three days every month.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2445]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2445

Narrated Hafsah, Ummul Mu'minin:

The apostle of Allah (peace_be_upon_him) used to fast three days every month: Monday, Thursday and Monday in the next week.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2446]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2446

Narrated Aisha, Ummul Mu'minin:

According to the version of an-Nufayli, Aisha said: The Property (peace_be_upon_him) used to pass by a patient while he was observing i'tikaf (in the mosque), but he passed as usual, and did not stay asking about him. According to the version of Ibn Isa she said: The Prophet (peace_be_upon_him) would visit a patient while he was observing i'tikaf.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2448]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2448

Narrated Hafsah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: He who does not determine to fast before dawn does not fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2450]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2450

Narrated Umm Hani:

On the days of the conquest of Mecca, when Mecca was captured, Fatimah came and sat on the left side of the Apostle of Allah (peace_be_upon_him), and Umm Hani was on his right side. A slave-girl brought a vessel which contained some drink; she gave it to him and he drank of it. He then gave it to Umm Hani who drank of it. She said: Apostle of Allah, I have broken my fast; I was fasting. He said to her: Were you making atonement for something? She replied: No. He said: Then it does not harm you if it was voluntary (fast).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2451]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2451

Narrated Aisha, Ummul Mu'minin:

Some food was presented to me and Hafsah. We were fasting, but broke our fast. Then the Apostle of Allah (peace_be_upon_him) entered upon us. We said to him: A gift was presented to us; we coveted it and we broke our fast. The Apostle of Allah (peace_be_upon_him) said: There is no harm to you; keep a fast another day in lieu of it.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2453]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2453

Narrated AbuSa'id al-Khudri:

A woman came to the Prophet (peace_be_upon_him) while we were with him.

She said: Apostle of Allah, my husband, Safwan ibn al-Mu'attal, beats me when I pray, and makes me break my fast when I keep a fast, and he does not offer the dawn prayer until the sun rises.

He asked Safwan, who was present, about what she had said. He replied: Apostle of Allah, as for her statement "he beats me when I pray", she recites two surahs (during prayer) and I have prohibited her (to do so).

He (the Prophet) said: If one surah is recited (during prayer), that is sufficient for the people.

(Safwan continued:) As regards her saying "he makes me break my fast," she dotes on fasting; I am a young man, I cannot restrain myself.

The Apostle of Allah (peace_be_upon_him) said on that day: A woman should not fast except with the permission of her husband.

(Safwan said:) As for her statement that I do not pray until the sun rises, we are a people belonging to a class, and that (our profession of supplying water) is already known about us. We do not awake until the sun rises. He said: When you awake, offer your prayer.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2457]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2457

Narrated Ubayy ibn Ka'b:

The Prophet (peace_be_upon_him) used to observe i'tikaf during the last ten days of Ramadan. One year he did not observe i'tikaf. When the next year came, he observed i'tikaf for twenty nights (i.e. days).


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2467]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2467

Narrated Aisha, Ummul Mu'minin:

The sunnah for one who is observing i'tikaf (in a mosque) is not to visit a patient, or to attend a funeral, or touch or embrace one's wife, or go out for anything but necessary purposes. There is no i'tikaf without fasting, and there is no i'tikaf except in a congregational mosque.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2468]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2468

Narrated Abdullah ibn Umar:

Umar (may Allah be pleased with him) took a vow in the pre-Islamic days to spend a night or a day in devotion near the Ka'bah (in the sacred mosque). He asked the Prophet (peace_be_upon_him) about it. He said: Observe i'tikaf (i.e. spend a night or a day near the Ka'bah) and fast.


Dawud :: Fasting (Kitab Al-Siyam) :: [13.2469]

Fasting (Kitab Al-Siyam)

Dawud :: Book 13 : Hadith 2469

Narrated Abdullah ibn Umar:

The tradition mentioned above (No. 2468) has also been transmitted by Abdullah ibn Budayl through a different chain of narrators in a similar way.

This version adds: While he (Umar) was observing i'tikaf (in the sacred mosque), the people uttered (loudly): "Allah is most great." He said: What is this, Abdullah? He said: These are the captives of the Hawazin whom the Apostle of Allah (peace_be_upon_him) has set free. He said: This slave-girl too? He sent her along with them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2473]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2473

Narrated Mu'awiyah:

I heard the Apostle of Allah (peace_be_upon_him) say: Migration will not end until repentance ends, and repentance will not end until the sun rises in the west.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2477]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2477

Narrated Ibn Hawalah:

The Prophet (peace_be_upon_him) said: It will turn out that you will be armed troops, one is Syria, one in the Yemen and one in Iraq. Ibn Hawalah said: Choose for me, Apostle of Allah, if I reach that time. He replied: Go to Syria, for it is Allah's chosen land, to which his best servants will be gathered, but if you are unwilling, go to your Yemen, and draw water from your tanks, for Allah has on my account taken special charge of Syria and its people.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2478]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2478

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: A section of my community will continue to fight for the right and overcome their opponents till the last of them fights with the Antichrist.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2480]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2480

Narrated AbuUmamah:

A man said: Apostle of Allah, allow tourism for me. The Prophet (peace_be_upon_him) said: The tourism of my people is striving in the path of Allah, the Exalted.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2481]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2481

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Returning home is like going on an expedition.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2482]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2482

Narrated Thabit ibn Qays:

A woman called Umm Khallad came to the Prophet (peace_be_upon_him) while she was veiled. She was searching for her son who had been killed (in the battle) Some of the Companions of the Prophet (peace_be_upon_him) said to her: You have come here asking for your son while veiling your face? She said: If I am afflicted with the loss of my son, I shall not suffer the loss of my modesty. The Apostle of Allah (peace_be_upon_him) said: You will get the reward of two martyrs for your son. She asked: Why is that so, Apostle of Allah? He replied: Because the people of the Book have killed him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2483]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2483

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: No one should sail on the sea except the one who is going to perform hajj or umrah, or the one who is fighting in Allah's path for under the sea there is a fire, and under the fire there is a sea.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2492]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2492

Narrated Mu'adh ibn Jabal:

The Apostle of Allah (peace_be_upon_him) said: (The reward of) prayer, fasting and remembrance of Allah is enhanced seven hundred times over (the reward of) spending in Allah's path.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2493]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2493

Narrated AbuMalik al-Ash'ari:

AbuMalik heard the Apostle of Allah (peace_be_upon_him) say: He who goes forth in Allah's path and dies or is killed is a martyr, or has his neck broken through being thrown by his horse or by his camel, or is stung by a poisonous creature, or dies on his bed by any kind of death Allah wishes is a martyr and will go to Paradise.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2494]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2494

Narrated Fadalah ibn Ubayd:

The Prophet (peace_be_upon_him) said: Everyone who dies will have fully complete his action, except one who is on the frontier (in Allah's path), for his deeds will be made to go on increasing till the Day of Resurrection, and he will be safe from the trial in the grave.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2495]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2495

Narrated Sahl ibn al-Hanzaliyyah:

On the day of Hunayn we travelled with the Apostle of Allah (peace_be_upon_him) and we journeyed for a long time until the evening came. I attended the prayer along with the Apostle of Allah (peace_be_upon_him).

A horseman came and said: Apostle of Allah, I went before you and climbed a certain mountain where saw Hawazin all together with their women, cattle, and sheep, having gathered at Hunayn.

The Apostle of Allah (peace_be_upon_him) smiled and said: That will be the booty of the Muslims tomorrow if Allah wills. He then asked: Who will be on guard tonight?

Anas ibn AbuMarthad al-Ghanawi said: I shall , Apostle of Allah. He said: Then mount your horse. He then mounted his horse, and came to the Apostle of Allah (peace_be_upon_him).

The Apostle of Allah said to him: Go forward to this ravine till you get to the top of it. We should not be exposed to danger from your side. In the morning the Apostle of of Allah (peace_be_upon_him) came out to his place of prayer, and offered two rak'ahs. He then said: Have you seen any sign of your horseman?

They said: We have not, Apostle of Allah. The announcement of the time for prayer was then made, and while the Apostle of Allah (peace_be_upon_him) was saying the prayer, he began to glance towards the ravine. When he finished his prayer and uttered salutation, he said: Cheer up, for your horseman has come. We therefore began to look between the trees in the ravine, and sure enough he had come.

He stood beside the Apostle of Allah (peace_be_upon_him), saluted him and said: I continued till I reached the top of this ravine where the Apostle of Allah (peace_be_upon_him) commanded me, and in the morning I looked down into both ravines but saw no one.

The Apostle of Allah (peace_be_upon_him) asked him: Did you dismount during the night?

He replied: No, except to pray or to relieve myself. The Apostle of Allah (peace_be_upon_him) said: You have ensured your entry to (Paradise). No blame will be attached to you supposing you do not work after it.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2497]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2497

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: He who does not join the warlike expedition (jihad), or equip, or looks well after a warrior's family when he is away, will be smitten by Allah with a sudden calamity. Yazid ibn Abdu Rabbihi said in his tradition: 'before the Day of Resurrection".


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2498]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2498

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Use your property, your persons any your tongues in striving against the polytheists.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2505]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2505

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) say: What is evil in a man are alarming niggardliness and unrestrained cowardice.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2506]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2506

Narrated AbuAyyub:

AbuImran said: We went out on an expedition from Medina with the intention of (attacking) Constantinople. AbdurRahman ibn Khalid ibn al-Walid was the leader of the company. The Romans were just keeping their backs to the walls of the city. A man (suddenly) attacked the enemy.

Thereupon the people said: Stop! Stop! There is no god but Allah. He is putting himself into danger.

AbuAyyub said: This verse was revealed about us, the group of the Ansar (the Helpers). When Allah helped His Prophet (peace_be_upon_him) and gave Islam dominance, we said (i.e. thought): Come on! Let us stay in our property and improve it.

Thereupon Allah, the Exalted, revealed, "And spend of your substance in the cause of Allah, and make not your hands contribute to (your destruction)". To put oneself into danger means that we stay in our property and commit ourselves to its improvement, and abandon fighting (i.e. jihad).

AbuImran said: AbuAyyub continued to strive in the cause of Allah until he (died and) was buried in Constantinople.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2507]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2507

Narrated Uqbah ibn Amir:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah, Most High, will cause three persons to enter Paradise for one arrow: the maker when he has a good motive in making it, the one who shoots it, and the one who hands it; so shoot and ride, but your shooting is dearer to me than your riding. Everything with which a man amuses himself is vain except three (things): a man's training of his horse, his playing with his wife, and his shooting with his bow and arrow. If anyone abandons archery after becoming an adept through distaste for it, it is a blessing he has abandoned; or he said: for which he has been ungrateful.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2509]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2509

Narrated Mu'adh ibn Jabal:

The Prophet (peace_be_upon_him) said: Fighting is of two kinds: The one who seeks Allah's favour, obeys the leader, gives the property he values, treats his associates gently and avoids doing mischief, will have the reward for all the time whether he is asleep or awake; but the one who fights in a boasting spirit, for the sake of display and to gain a reputation, who disobeys the leader and does mischief in the earth will not return credit or without blame.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2510]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2510

Narrated AbuHurayrah:

A man said: Apostle of Allah, a man wishes to take part in jihad in Allah's path desiring some worldly advantage? The Prophet (peace_be_upon_him) said: He will have not reward. The people thought it terrible, and they said to the man: Go back to the Apostle of Allah (peace_be_upon_him), for you might not have made him understand well. He, therefore, (went and again) asked: Apostle of Allah, a man wishes to take part in jihad in Allah's path desiring some worldly advantage? He replied: There is no reward for him. They again said to the man: Return to the Apostle of Allah. He, therefore, said to him third time. He replied: There is no reward for him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2513]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2513

Narrated Abdullah ibn Amr ibn al-'As:

Apostle of Allah, tell me about jihad and fighting. He replied: Abdullah ibn Amr, if you fight with endurance seeking from Allah your reward, Allah will resurrect you showing endurance and seeking your reward from Him, but, if you fight for vain show seeking to acquire much, Allah will resurrect you making a vain show and seeking to acquire much. In whatever you fight or are killed, Abdullah ibn Amr, in that state Allah will resurrect you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2514]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2514

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: When your brethren were smitten at the battle of Uhud, Allah put their spirits in the crops of green birds which go down to the rivers of Paradise, eat its fruit and nestle in lamps of gold in the shade of the Throne. Then when they experienced the sweetness of their food, drink and rest, they asked: Who will tell our brethren about us that we are alive in Paradise provided with provision, in order that they might not be disinterested in jihad and recoil in war? Allah Most High said: I shall tell them about you; so Allah sent down; "And do not consider those who have been killed in Allah's path." till the end of the verse.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2515]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2515

Narrated Hasana' daughter of Mu'awiyah:

She reported on the authority of her paternal uncle: I asked the Prophet (peace_be_upon_him): Who are in Paradise? He replied: Prophets are in Paradise, martyrs are in Paradise, infants are in Paradise and children buried alive are in Paradise.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2516]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2516

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: The intercession of a martyr will be accepted for seventy members of his family.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2517]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2517

Narrated Aisha, Ummul Mu'minin:

When Negus died, we were told that a light would be seen perpetually at his grave.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2518]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2518

Narrated Ubaydullah ibn Khalid as-Sulami:

The Apostle of Allah (peace_be_upon_him) made a brotherhood between two men, one of whom was killed (in Allah's path), and a week or thereabouts later the other died, and we prayed at his funeral). The Apostle of Allah (peace_be_upon_him) asked: What did you say? We replied: We prayed for him and said: O Allah, forgive him, and join him to his companion. The Apostle of Allah (peace_be_upon_him) said: What about his prayers since the time the other died, and his fasting since the time the other died--the narrator Shu'bah doubted the words, "his fasting--and his deeds since the time the other died. The distance between them is just like the distance between heaven and earth.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2519]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2519

Narrated AbuAyyub al-Ansari:

AbuAyyub heard the Apostle of Allah (peace_be_upon_him) say: Capitals will be conquered at your hands, and you will have to raise companies in large armies. A man will be unwilling to join a company, so he will escape from his people and go round the tribes offering himself to them, saying: Whose place may I take in such and such expedition? Whose place may I take in such and such expedition? Beware: That man is a hireling to the last drop of his blood.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2520]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2520

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: The warrior gets his reward, and the one who equips him gets his own reward and that of the warrior.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2521]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2521

Narrated Ya'la ibn Munyah:

The Apostle of Allah (peace_be_upon_him) announced an expedition, and I was a very old man and I had no servant. I, therefore, sought a hireling who would serve instead of me, and I would give him his portion. So I found a man. When the time of departure arrived, he came to me and said: I do not know what would be the portions, and how much would be my portion. So offer something (as wages) to me, whether there would be any portion or not. I offered three dinars (as his wages) for him. When some booty arrived, I wanted to offer him his portion. But I remembered the dinars, so I went to the Prophet (peace_be_upon_him) and mentioned the matter to him. He said: All I can find for him regarding this expedition of his in this world and the next is three dinars which were offered him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2522]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2522

Narrated Abdullah ibn Amr ibn al-'As:

A man came to the Apostle of Allah (peace_be_upon_him) and said: I came to you to take the oath of allegiance to you on emigration, and I left my parents weeping. He (the Prophet) said: Return to them and make them laugh as you made them weep.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2524]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2524

Narrated AbuSa'id al-Khudri:

A man emigrated to the Apostle of Allah (peace_be_upon_him) from the Yemen. He asked (him): Have you anyone (of your relatives) in the Yemen? He replied: My parents. He asked: Did they permit you? He replied: No. He said: Go back to them and ask for their permission. If they permit you, then fight (in the path of Allah), otherwise be devoted to them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2525]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2525

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) went on an expedition, he took Umm Sulaym, and he had some women of the Ansar who supplied water and tended the wounded.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2526]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2526

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Three things are the roots of faith: to refrain from (killing) a person who utters, "There is no god but Allah" and not to declare him unbeliever whatever sin he commits, and not to excommunicate him from Islam for his any action; and jihad will be performed continuously since the day Allah sent me as a prophet until the day the last member of my community will fight with the Dajjal (Antichrist). The tyranny of any tyrant and the justice of any just (ruler) will not invalidate it. One must have faith in Divine decree.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2527]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2527

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Striving in the path of Allah (jihad) is incumbent on you along with every ruler, whether he is pious or impious; the prayer is obligatory on you behind every believer, pious or impious, even if he commits grave sins; the (funeral) prayer is incumbent upon every Muslim, pious and impious, even if he commits major sins.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2528]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2528

Narrated Jabir ibn Abdullah:

Once the Apostle of Allah (peace_be_upon_him) intended to go on an expedition. He said: O group of the emigrants (Muhajirun) and the helpers (Ansar), among your brethren there are people who have neither property nor family. So one of you should take with him two or three persons; with me. I also rode on my camel by turns like one of them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2529]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2529

Narrated Abdullah ibn Hawalah al-Azdi:

The Apostle of Allah (peace_be_upon_him) sent us on foot to get spoil, but we returned without getting any. When he saw the signs of distress on our faces, he stood up on our faces and said: O Allah, do not put them under my care, for I would be too weak to care for them; do not put them in care of themselves, for they would be incapable of that, and do not put them in the care of men, for they would choose the best things for themselves. He then placed his hand on my head and said: Ibn Hawalah, when you see the caliphate has settled in the holy land, earthquakes, sorrows and serious matters will have drawn near and on that day the Last Hour will be nearer to mankind than this hand of mine is to your head.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2530]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2530

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: Our Lord Most High is pleased with a man who fights in the path of Allah, the Exalted; then his companions fled away (i.e. retreated). But he knew that it was a sin (to flee away from the battlefield), so he returned, and his blood was shed. Thereupon Allah, the Exalted, says to His angels: Look at My servant; he returned seeking what I have for him (i.e. the reward), and fearing (the punishment) I have, until his blood was shed.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2531]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2531

Narrated AbuHurayrah:

Amr ibn Uqaysh had given usurious loans in pre-Islamic period; so he disliked to embrace Islam until he took them. He came on the day of Uhud and asked: Where are my cousins? They (the people) replied: At Uhud. He asked: Where is so-and-so? They said: At Uhud. He asked: Where is so-and-so? They said: At Uhud. He then put on his coat of mail and rode his horse; he then proceeded towards them. When the Muslims saw him, they said: Keep away, Amir. He said: I have become a believer. He fought until he was wounded. He was then taken to his family wounded. Sa'd ibn Mu'adh came to his sister: Ask him (whether he fought) out of partisanship, out of anger for them, or out of anger for Allah. He said: Out of anger of Allah and His Apostle. He then died and entered Paradise. He did not offer any prayer for Allah.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2533]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2533

Narrated AbuSalam:

AbuSalam reported on the authority of a man from the companion of the Prophet (peace_be_upon_him). He said: We attacked a tribe of Juhaynah. A man from the Muslims pursued a man of them, and struck him but missed him. He struck himself with the sword. The Apostle of Allah (peace_be_upon_him) said: Your brother, O group of Muslims. The people hastened towards him, but found him dead. The Apostle of Allah (peace_be_upon_him) wrapped him with his clothes and his blood, and offered (funeral) prayer for him and buried him. They said: Apostle of Allah, is he a martyr? He said: Yes, and I am witness to him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2534]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2534

Narrated Sahl ibn Sa'd:

The Prophet (peace_be_upon_him) said: Two (prayers) are not rejected, or seldom rejected: Prayer at the time of the call to prayer, and (the prayer) at the time of fighting, when the people grapple with each other. Musa said: Rizq ibn Sa'id ibn AbdurRahman reported from AbuHazim on the authority of Sahl ibn Sa'd from the Prophet (peace_be_upon_him) as saying: And while it is raining.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2535]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2535

Narrated Mu'adh ibn Jabal:

The Apostle of Allah (peace_be_upon_him) said: If anyone fights in Allah's path as long as the time between two milkings of a she-camel, Paradise will be assured for him. If anyone sincerely asks Allah for being killed and then dies or is killed, there will be a reward of a martyr for him. Ibn al-Musaffa added from here: If anyone is wounded in Allah's path, or suffers a misfortune, it will come on the Day of resurrection as copious as possible, its colour saffron, and its odour musk; and if anyone suffers from ulcers while in Allah's path, he will have on him the stamp of the martyrs.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2536]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2536

Narrated Utbah ibn AbdusSulami:

Utbah heard the Apostle of Allah (peace_be_upon_him) say: Do not cut the forelocks, manes, or tails of horse, for their tails are their means of driving flies, their manes provide them with warmth, and blessing is tide to their forelocks.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2537]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2537

Narrated AbuWahb al-Jushami,:

The Apostle of Allah (peace_be_upon_him) said: Keep to every dark bay horse with a white blaze and white on the legs, or sorrel with a white blaze and white on the legs , or black with a white blaze and white on the legs.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2538]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2538

Narrated AbuWahb:

The Prophet (peace_be_upon_him) said: Keep to every sorrel horse with a white blaze and white on the legs, or dark bay with a white blaze. He then mentioned something similar. Muhammad ibn al-Muhajir said: I asked him: Why was a sorrel horse preferred? He replied: Because the Prophet (peace_be_upon_him) had sent a contingent, and the man who first brought the news of victory was the rider of a sorrel horse.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2539]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2539

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The most favoured horses are the sorrel.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2540]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2540

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to name a mare a horse.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2542]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2542

Narrated Sahl ibn al-Hanzaliyyah:

The Apostle of Allah (peace_be_upon_him) came upon an emaciated camel and said: Fear Allah regarding these dumb animals. Ride them when they are in good condition and feed them when they are in good condition.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2545]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2545

Narrated Anas ibn Malik:

When we alighted at a station (for stay), we did not pray until we united the saddles of the camels.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2547]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2547

Narrated AbuWahb al-Jushami,:

The Apostle of Allah (peace_be_upon_him) said: Tie the horses, rub down their forelocks and their buttocks (or he said: Their rumps), and put things on their necks, but do not put bowstrings.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2548]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2548

Narrated Umm Habibah:

The Prophet (peace_be_upon_him) said: The angels do not go with a travelling company in which there is a bell.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2551]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2551

Narrated Abdullah ibn Umar:

It has been prohibited to ride the beast which eats dung.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2552]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2552

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) prohibited to ride a camel which eats dung.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2554]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2554

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) named our cavalry "the Cavalry of Allah," when we were struck with panic, and when panic overtook us, the Apostle of Allah (peace_be_upon_him) commanded us to be united, to have patience and perseverance; and to be so when we fought.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2556]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2556

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) prohibited to provoke the beasts for fighting.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2559]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2559

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) was present with a she-mule which he rode, so Ali said: If we made asses cover mares we would have animals of this type. The Apostle of Allah (peace_be_upon_him) said: Only those who do not know do that.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2566]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2566

Narrated Buraydah ibn al-Hasib:

While the Apostle of Allah (peace_be_upon_him) was walking a man who had an ass came to him and said: Apostle of Allah, ride; and the man moved to the back of the animal. The Apostle of Allah (peace_be_upon_him) said: No, you have more right to ride in front on your animal than me unless you grant that right to me. He said: I grant it to you. So he mounted.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2567]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2567

Narrated Abbad ibn Abdullah ibn az-Zubayr:

My foster-father said to me - he was one of Banu Murrah ibn Awf, and he was present in that battle, the battle of Mu'tah: By Allah, as if I am seeing Ja'far who jumped from his reddish horse and hamstrung it; he then fought with the people until he was killed.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2568]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2568

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Wagers are allowed only for racing camels, or horses or shooting arrows.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2570]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2570

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) used to make lean by training horses which he employed in the race.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2571]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2571

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) used to hold a race between horses and kept the one in the fifth year at a long distance.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2572]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2572

Narrated Aisha, Ummul Mu'minin:

while she was on a journey along with the Apostle of Allah (peace_be_upon_him): I had a race with him (the Prophet) and I outstripped him on my feet. When I became fleshy, (again) I had a race with him (the Prophet) and he outstripped me. He said: This is for that outstripping.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2573]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2573

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If one enters a horse with two others when he is not certain that it cannot be beaten, it is not gambling; but when one enters a horse with two others when he is certain it cannot be beaten, it is gambling.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2575]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2575

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: There must be no shouting or leading another horse at one's side. Yahya added in his tradition: When racing for a wager.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2577]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2577

Narrated Anas ibn Malik:

The pommel of the sword of the Apostle of Allah (peace_be_upon_him) was of silver.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2578]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2578

Narrated Sa'id ibn AbulHasan:

The pommel of the sword of the Apostle of Allah (peace_be_upon_him) was of silver.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2582]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2582

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) prohibited to hand the drawn sword.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2583]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2583

Narrated Samurah ibn Jundub:

The Apostle of Allah (peace_be_upon_him) prohibited to cut a piece of leather between two fingers.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2584]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2584

Narrated As-Sa'ib ibn Yazid:

As-Sa'ib reported on the authority of a man whom he named: The Apostle of Allah (peace_be_upon_him) put on two coats of mail during the battle of Uhud as a double protection. (The narrator is doubtful about the word zahara or labisa.)


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2585]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2585

Narrated Al-Bara' ibn Azib:

Yunus ibn Ubayd, client of Muhammad ibn al-Qasim, said that Muhammad ibn al-Qasim sent to al-Bara' ibn Azib to ask him about the standard of the Apostle of Allah (peace_be_upon_him). He said: It was black and square, being made of a woollen rug.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2586]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2586

Narrated Jabir ibn Abdullah:

When the Prophet (peace_be_upon_him) entered Mecca his banner was white.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2587]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2587

Narrated Simak ibn Harb:

Simak reported on the authority of a man from his people, on the authority of another man from them: I saw that the standard of the Apostle of Allah (peace_be_upon_him) was yellow.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2588]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2588

Narrated AbudDarda':

I heard the Apostle of Allah (peace_be_upon_him) say: Seek for me weak persons, for you are provided means of subsistence and helped through your weaklings.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2591]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2591

Narrated A man who heard the Prophet:

Al-Muhallab ibn AbuSufrah said: A man who heard the Prophet (peace_be_upon_him) say: If the enemy attacks you at night, let your war cry be Ha-Mim. They will not be helped.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2592]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2592

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) proceeded on journey, he would say: O Allah, Thou art the Companion in the journey, and the One Who looks after the family; O Allah, I seek refuge in Thee from the difficulty of travelling, finding harm when I return, and unhappiness in what I see coming to my family and property. O Allah, make the length of his journey short for us, and the journey easy for us.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2593]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2593

Narrated Abdullah ibn Umar:

When the Apostle of Allah (peace_be_upon_him) sat on his camel to go out on a journey, he said: "Allah is Most Great" three times. Then he said: "Glory be to Him Who has made subservient to us, for we had not the strength for it, and to our Lord do we return. O Allah, we ask Thee in this journey of ours, uprightness, piety and such deeds as are pleasing to Thee. O Allah, make easy for us this journey of ours and make its length short for us. O Allah, Thou art the Companion in the journey, and the One Who looks after the family and property in our absence." When he returned, he said these words adding: "Returning, repentant, serving and praising our Lord." The Prophet (peace_be_upon_him) and his armies said: "Allah is Most Great" when they went up to high ground; and when armies said: "Allah is most Great" when they went up to high ground; and when they descended, they said: "Glory be to Allah." So the prayer was patterned on that.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2595]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2595

Narrated Abdullah al-Khutami:

When the Prophet (peace_be_upon_him) wanted to say farewell to an army, he would say: I entrust to Allah your religion, what you are responsible for, and your final deeds.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2596]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2596

Narrated Ali ibn AbuTalib:

Ali ibn Rabi'ah said: I was present with Ali while a beast was brought to him to ride. When he put his foot in the stirrup, he said: "In the name of Allah." Then when he sat on its back, he said: "Praise be to Allah." He then said: "Glory be to Him Who has made this subservient to us, for we had not the strength, and to our Lord do we return." He then said: "Praise be to Allah (thrice); Allah is Most Great (thrice): glory be to Thee, I have wronged myself, so forgive me, for only Thou forgivest sins." He then laughed. He was asked: At what did you laugh? He replied: I saw the Apostle of Allah (peace_be_upon_him) do as I have done, and laugh after that. I asked: Apostle of Allah , at what are you laughing? He replied: Your Lord, Most High, is pleased with His servant when he says: "Forgive me my sins." He know that no one forgives sins except Him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2597]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2597

Narrated Abdullah ibn Amr:

When the Apostle of Allah (peace_be_upon_him) was travelling and night came on, he said: O earth, my Lord and your Lord is Allah; I seek refuge in Allah from your evil, the evil of what you contain, the evil of what has been created in you, and the evil of what creeps upon you; I seek refuge in Allah from lions, from large black snakes, from other snakes, from scorpions, from the evil of jinn which inhabit a settlement, and from a parent and his offspring.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2599]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2599

Narrated Ka'b ibn Malik:

It was rarely that the Apostle of Allah (peace_be_upon_him) set out on a journey on any day but on a Thursday.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2600]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2600

Narrated Sakhr al-Ghamidi:

The Prophet (peace_be_upon_him) said: "O Allah, bless my people in their early mornings." When he sent out a detachment or an army, he sent them at the beginning of the day. Sakhr was a merchant, and he would send off his merchandise at the beginning of the day; and he became rich and had much wealth.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2601]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2601

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: A single rider is a devil, and a pair of riders are a pair of devils, but three are a company of riders.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2602]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2602

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: When three are on a journey, they should appoint one of them as their commander.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2603]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2603

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When three are on a journey, they should appoint one of them as their commander. Nafi' said: We said to AbuSalamah: You are our commander.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2605]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2605

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The best number of companions is four, the best number in expeditions four hundred, and the best number in armies four thousand; and twelve thousand will not be overcome through smallness of numbers.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2608]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2608

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Go in Allah's name, trusting in Allah, and adhering to the religion of Allah's Apostle. Do not kill a decrepit old man, o a young infant, or a child, or a woman; do not be dishonest about booty, but collect your spoils, do right and act well, for Allah loves those who do well.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2610]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2610

Narrated Usamah:

The Apostle of Allah (peace_be_upon_him) enjoined upon him to attack Ubna in the morning and burn the place.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2613]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2613

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: When one of you comes to the cattle, he should seek permission of their master if he is there; if he permits, he should milk (the animals) and drink. If he is not there, he should call three times. If he responds, he should seek his permission; otherwise, he may milk (the animals) and drink, but should not carry (with him).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2614]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2614

Narrated Abbad ibn Shurahbil:

I suffered from drought; so I entered a garden of Medina, and rubbed an ear-corn. I ate and carried in my garment. Then its master came, he beat me and took my garment. He came to the Apostle of Allah (peace_be_upon_him) who said to him: You did not teach him if he was ignorant; and you did not feed him if he was hungry. He ordered him, so he returned my garment to me, and gave me one or half a wasq (sixty or thirty sa's) of corn.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2616]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2616

Narrated The uncle of AbuRafi ibn Amr al-Ghifari:

I was a boy. I used to throw stones at the palm-trees of the Ansar. So I was brought to the Prophet (peace_be_upon_him) who said: O boy, why do you throw stones at the palm-trees? I said: eat (dates). He said: Do not throw stones at the palm trees, but eat what falls beneath them. He then wiped his head and said: O Allah, fill his belly.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2621]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2621

Narrated Uqbah ibn Malik:

The Prophet (peace_be_upon_him) sent a detachment. I gave a sword to a man from among them. When he came back, he said: Would that you saw us how the Apostle of Allah (peace_be_upon_him) rebuked us, saying: When I sent out a man who does not fulfil my command, are you unable to appoint in his place one who will fulfil my command.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2622]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2622

Narrated AbuTha'labah al-Khushani:

When the people encamped, (the narrator Amr ibn Uthman al-Himsi) said: When the Apostle of Allah (peace_be_upon_him) encamped, the people scattered in the glens and wadis. The Apostle of Allah (peace_be_upon_him) said: Your scattering in these glens and wadis is only of the devil. They afterwards kept close together when they encamped to such an extent that it used to be said that if a cloth were spread over them, it would cover them all.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2623]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2623

Narrated Mu'adh ibn Anas al-Juhani:

I fought along with the Prophet (peace_be_upon_him) in such and such battles. The people occupied much space and encroached on the road. The Prophet (peace_be_upon_him) sent an announcer to announce among the people: Those who occupy much space or encroach on the road will not be credited with jihad.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2626]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2626

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) went on an expedition, he said: O Allah, Thou art my aider and helper; by Thee I move, by Thee I attack, and by Thee I fight.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2629]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2629

Narrated Isam al-Muzani:

The Apostle of Allah (peace_be_upon_him) sent us in a detachment and said (to us): If you see a mosque or hear a mu'adhdhin (calling to prayer), do not kill anyone.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2631]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2631

Narrated Ka'b ibn Malik:

When the Prophet (peace_be_upon_him) intended to go on an expedition, he always pretended to be going somewhere else, and he would say: War is deception.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2632]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2632

Narrated Salamah ibn al-Akwa':

The Apostle of Allah (peace_be_upon_him) appointed AbuBakr our commander and we fought with some people who were polytheists, and we attacked them at night, killing them. Our war-cry that night was "put to death; put to death." Salamah said: I killed that night with my hand polytheists belonging to seven houses.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2633]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2633

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) used to keep to the rear when travelling and urge on the weak. He would take someone up behind him and make supplication for them all.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2635]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2635

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: I am commanded to fight with men till they testify that there is no god but Allah, and that Muhammad is His servant and His Apostle, face our qiblah (direction of prayer), eat what we slaughter, and pray like us. When they do that, their life and property are unlawful for us except what is due to them. They will have the same rights as the Muslims have, and have the same responsibilities as the Muslims have.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2639]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2639

Narrated Jarir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) sent an expedition to Khath'am. Some people sought protection by having recourse to prostration, and were hastily killed. When the Prophet (peace_be_upon_him) heard that, he ordered half the blood-wit to be paid for them, saying: I am not responsible for any Muslim who stays among polytheists. They asked: Why, Apostle of Allah? He said: Their fires should not be visible to one another.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2641]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2641

Narrated Abdullah ibn Umar:

Ibn Umar was sent with a detachment of the Apostle of Allah (peace_be_upon_him). The people wheeled round in flight. He said: I was one of those who wheeled round in flight. When we stopped, we said (i.e. thought): How should we do? We have run away from the battlefield and deserve Allah's wrath. Then we said (thought): Let us enter Medina, stay there, and go there while no one sees us. So we entered (Medina) and thought: If we present ourselves before the Apostle of Allah (peace_be_upon_him), and if there is a change of repentance for us, we shall stay; if there is something else, we shall go away. So we sat down (waiting) for the Apostle of Allah (peace_be_upon_him) before the dawn prayer. When he came out, we stood up to him and said: We are the ones who have fled. He turned to us and said: No, you are the ones who return to fight after wheeling away. We then approached and kissed his hand, and he said; I am the main body of the Muslims.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2646]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2646

Narrated Furat ibn Hayyan:

The Apostle of Allah (peace_be_upon_him) commanded to kill him: he was a spy of AbuSufyan and an ally of a man of the Ansar. He passed a circle of the Ansar and said: I am a Muslim. A man from the Ansar said, Apostle of Allah, he is saying that he is a Muslim. The Apostle of Allah (peace_be_upon_him) said: There are people among you in whose faith we trust. Furat ibn Hayyan is one of them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2649]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2649

Narrated An-Nu'man ibn Muqarrin:

I was present at fighting along with the Apostle of Allah (peace_be_upon_him), and when he did not fight at the beginning of the day, he waited till the sun had passed the meridian, the winds blew, and help came down.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2650]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2650

Narrated Qays ibn Abbad:

The Companions of the Prophet (peace_be_upon_him), disliked shouting while fighting.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2653]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2653

Narrated Jabir ibn Atik:

The Prophet (peace_be_upon_him) said: There is jealousy which Allah loves and jealousy which Allah hates. That which Allah loves is jealousy regarding a matter of doubt, and that which Allah hates is jealousy regarding something which is not doubtful. There is pride which Allah hates and pride which Allah loves. That which Allah loves is a man's pride when fighting and when giving sadaqah and that which Allah hates is pride shown by oppression. The narrator Musa said: "by boasting."


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2658]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2658

Narrated AbuUsayd as-Sa'idi:

The Prophet (peace_be_upon_him) said at the battle of Badr: When they come near you shoot arrows at them; and do not draw swords at them until they come near you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2659]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2659

Narrated Ali ibn AbuTalib:

(At the battle of Badr) Utbah ibn Rabi'ah came forward followed by his son and his brother and cried out: Who will be engaged in single combat? Some young men of the Helpers responded to his call. He asked: Who are you? They told him. He said: We do not want you; we, in fact, want only our cousins. The Prophet (peace_be_upon_him) said: Get up Hamzah get up Ali; get up Ubaydah ibn al-Harith. Hamzah went forward to Utbah, I went forward to Shaybah; and after two blows had been exchanged between Ubaydah and al-Walid, they wounded one another severely; so we turned against al-Walid and killed him, and we carried Ubaydah away.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2660]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2660

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: The most merciful of the people in respect of killing are believers (in Allah).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2661]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2661

Narrated Samurah ibn Jundub:

Al-Hayyaj ibn Imran ibn Husayn reported that a slave of Imran ran away. He took a vow to Allah that if he overpowers him, he will cut off his head. He then sent me (to Samurah ibn Jundub) to ask him about this question for him. I came to Samurah ibn Jundub and asked him. He said: The Apostle of Allah (peace_be_upon_him) used to exhort us to give alms (sadaqah) and forbid us to mutilate (a slain). I then came to Imran ibn Husayn and asked him. He said: The Apostle of Allah (peace_be_upon_him) used to exhort us to give alms (sadaqah) and forbid us to mutilate (a slain).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2663]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2663

Narrated Rabah ibn Rabi':

When we were with the Apostle of Allah (peace_be_upon_him) on an expedition, he saw some people collected together over something and sent a man and said: See, what are these people collected around? He then came and said: They are round a woman who has been killed. He said: This is not one with whom fighting should have taken place. Khalid ibn al-Walid was in charge of the van; so he sent a man and said: Tell Khalid not to kill a woman or a hired servant.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2664]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2664

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: Kill the old men who are polytheists, but spare their children.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2665]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2665

Narrated Aisha, Ummul Mu'minin:

No woman of Banu Qurayzah was killed except one. She was with me, talking and laughing on her back and belly (extremely), while the Apostle of Allah (peace_be_upon_him) was killing her people with the swords. Suddenly a man called her name: Where is so-and-so? She said: I I asked: What is the matter with you? She said: I did a new act. She said: The man took her and beheaded her. She said: I will not forget that she was laughing extremely although she knew that she would be killed.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2667]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2667

Narrated Hamzah al-Aslami:

The Apostle of Allah (peace_be_upon_him) appointed him commander over a detachment. He said: I went out along with it. He (the Prophet) said: If you find so-and-so, burn him with the fire. I then turned away, and he called me. So I returned to him, and he said: If you find so-and-so, kill him, and do not burn him, for no one punishes with fire except the Lord of the fire.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2669]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2669

Narrated Abdullah ibn Mas'ud:

We were with the Apostle of Allah (peace_be_upon_him) during a journey. He went to ease himself. We saw a bird with her two young ones and we captured her young ones. The bird came and began to spread its wings. The Apostle of Allah (peace_be_upon_him) came and said: Who grieved this for its young ones? Return its young ones to it. He also saw an ant village that we had burnt. He asked: Who has burnt this? We replied: We. He said: It is not proper to punish with fire except the Lord of fire.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2670]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2670

Narrated Wathilah ibn al-Asqa:

The Apostle of Allah (peace_be_upon_him) announced to go on expedition for Tabuk. I went to my family and then proceeded (on journey). The vanguard of the Companions of the Apostle of Allah (peace_be_upon_him) had already proceeded. So I began to announce loudly in Medina: Is there anyone who takes a man on his ride, and he will get his share (from the booty? An old man from the Ansar (Helpers) spoke loudly: We shall have his share if we take him with us on our mount by turns, and he will have his meal with us. I said: Yes. He said: So go on journey with Allah's blessing. I then proceeded along with my best companion and Allah gave us booty. Some she-camels were given to me as my share of booty. I drove them till I reached him. He came out and sat on the rear part of the saddle of his camel. He then said: Drive them backward. He again said: Drive them forward. He then said: I find your she-camels very gentle. He said: This is your booty which I stipulated for you. He replied: Take your she-camels, my nephew; we did not intend (to get) your portion.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2672]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2672

Narrated Jundub ibn Makith:

The Apostle of Allah (peace_be_upon_him) sent Abdullah ibn Ghalib al-Laythi along with a detachment and I was also with them. He ordered them to attach Banu al-Mulawwih from all sides at al-Kadid. So we went out and when we reached al-Kadid we met al-Harith ibn al-Barsa al-Laythi, and seized him. He said: I came with the intention of embracing Islam, and I came out to go to the Apostle of Allah (peace_be_upon_him). We said: If you are a Muslim, there is no harm if we keep you in chains for a day and night; and if you are not, we shall tie you with chains. So we tied him with chains.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2674]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2674

Narrated Sawdah daughter of Zam'ah:

Yahya ibn Abdullah said: When the captives (of the battle of Badr) were brought, Sawdah daughter of Zam'ah was present with the children of Afra' at the halting place of their camels, that is, Awf and Mu'awwidh sons of Afra'.

This happened before the prescription of veil for them. Sawdah said: I swear by Allah, I was with them when I came (from there to the people) and I was told: These are captives recently brought (here). I returned to my house, and the Apostle of Allah (peace_be_upon_him) was there, and AbuZayd Suhayl ibn Amr was in the corner of the apartment and his hands were tied up on his neck with a rope. He then narrated the rest of the tradition.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2676]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2676

Narrated Abdullah ibn Abbas:

When the children of a woman (in pre-Islamic days) did not survive, she took a vow on herself that if her child survives, she would convert it a Jew. When Banu an-Nadir were expelled (from Arabia), there were some children of the Ansar (Helpers) among them. They said: We shall not leave our children. So Allah the Exalted revealed; "Let there be no compulsion in religion. Truth stands out clear from error."


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2677]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2677

Narrated Sa'd:

On the day when Mecca was conquered, the Apostle of Allah (peace_be_upon_him) gave protection to the People except four men and two women and he named them. Ibn AbuSarh was one of them.

He then narrated the tradition. He said: Ibn AbuSarh hid himself with Uthman ibn Affan. When the Apostle of Allah (peace_be_upon_him) called the people to take the oath of allegiance, he brought him and made him stand before the Apostle of Allah (peace_be_upon_him). He said: Apostle of Allah, receive the oath of allegiance from him. He raised his head and looked at him thrice, denying him every time. After the third time he received his oath. He then turned to his Companions and said: Is not there any intelligent man among you who would stand to this (man) when he saw me desisting from receiving the oath of allegiance, and kill him? They replied: We do not know, Apostle of Allah, what lies in your heart; did you not give us an hint with your eye? He said: It is not proper for a Prophet to have a treacherous eye.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2678]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2678

Narrated Sa'id ibn Yarbu' al-Makhzumi:

The Prophet (peace_be_upon_him) said: on the day of the conquest of Mecca: There are four persons whom I shall not give protection in the sacred and non-sacred territory. He then named them. There were two singing girls of al-Maqis; one of them was killed and the other escaped and embraced Islam.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2680]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2680

Narrated Abdullah ibn Mas'ud:

Ibrahim said: Ad-Dahhak ibn Qays intended to appoint Masruq as governor. Thereupon Umarah ibn Uqbah said to him: Are you appointing a man from the remnants of the murderers of Uthman? Masruq said to him: Ibn Mas'ud narrated to us, and he was trustworthy in respect of traditions, that when the Prophet (peace_be_upon_him) intended to kill your father, he said: Who will look after my children? He replied: Fire. I also like for you what the Apostle of Allah (peace_be_upon_him) liked for you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2681]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2681

Narrated AbuAyyub al-Ansari:

AbuDawud said: The narrators other than Sa'id reported from Ibn Wahb in this tradition: "(Killed him) with arrows in confinement." When AbuAyyub al-Ansari was informed about it, he said: I heard the Apostle of Allah (peace_be_upon_him) prohibiting to kill in confinement. By Him in Whose hands my soul is, if there were a hen, I would not kill it in confinement. AbdurRahman ibn Khalid ibn al-Walid was informed about it (the Prophet's prohibition). He set four slaves free.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2685]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2685

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) fixed the ransom of the people of pre-Islamic Arabia at four hundred dirhams per head on the day of the battle of Badr.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2686]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2686

Narrated Aisha, Ummul Mu'minin:

When the people of Mecca sent about ransoming their prisoners Zaynab sent some property to ransom Abul'As, sending among it a necklace of hers which Khadijah had had, and (which she) had given to her when she married Abul'As. When the Apostle of Allah (peace_be_upon_him) saw it, he felt great tenderness about it and said: If you consider that you should free her prisoner for her and return to her what belongs to her, (it will be well). They said: Yes. The Apostle of Allah (peace_be_upon_him) made an agreement with him that he should let Zaynab come to him, and the Apostle of Allah (peace_be_upon_him) sent Zayd ibn Harithah and a man of the Ansar (the Helpers) and said: Wait in the valley of Yajij till Zaynab passes you, then you should accompany her and bring her back.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2688]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2688

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) then said: Return to them (Hawazin) their women and their sons. If any of you withholds anything from this booty, we have six camels for him from the first booty which Allah gives us. The Prophet (peace_be_upon_him) then approached a camel, and taking a hair from its hump said: O people, I get nothing of this booty, not even this (meanwhile raising his two fingers) but the fifth, and the fifth is returned to you, so hand over threads and needles. A man got up with a ball of hair in his hand and said: I took this to repair the cloth under a pack-saddle. The Apostle of Allah (peace_be_upon_him) said: You can have what belongs to me and to the Banu al-Muttalib. He said: If it produces the result that I now realise, I have no desire for it.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2690]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2690

Narrated Ali ibn AbuTalib:

Ali separated between a slave-girl and her child. The Prophet (peace_be_upon_him) prohibited it and made the sale transactions withdrawn.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2692]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2692

Narrated Abdullah ibn Umar:

Nafi' said that a slave of Ibn Umar ran away to the enemy, and then the Muslims overpowered them. The Apostle of Allah (peace_be_upon_him) returned him to Ibn Umar and that was not distributed (as a part of booty).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2694]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2694

Narrated Ali ibn AbuTalib:

Some slaves (of the unbelievers) went out to the Apostle of Allah (peace_be_upon_him) on the day of al-Hudaybiyyah before treaty. Their masters wrote to him saying: O Muhammad, they have not gone out to you with an interest in your religion, but they have gone out to escape from slavery. Some people said: They have spoken the truth, Apostle of Allah, send them back to them. The Apostle of Allah (peace_be_upon_him) became angry and said: I do not see your restraining yourself from this action), group of Quraysh, but that Allah send someone to you who strike your necks. He then refused to return them, and said: They are emancipated (slaves) of Allah, the Exalted.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2695]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2695

Narrated Abdullah ibn Umar:

In the time of the Apostle of Allah (peace_be_upon_him) an army got food and honey and a fifth was not taken from them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2697]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2697

Narrated AbdurRahman ibn Samurah ibn Kabul:

AbuLabid said: We were with AbdurRahman ibn Samurah ibn Kabul. The people got booty and plundered it. He stood and addressed (the people): I heard the Apostle of Allah (peace_be_upon_him) prohibiting getting property from the booty before its distribution. Therefore, they returned what they had taken, He then distributed it among them.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2698]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2698

Narrated Abdullah ibn AbuAwfa:

Muhammad ibn AbulMujahid reported Abdullah ibn AbuAwfa as saying: I asked: Did you set aside the fifth of the food in the time of the Apostle of Allah (peace_be_upon_him)? He replied: On the day of Khaybar we captured food and a man would come and take as much food of it as needed and then go away.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2699]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2699

Narrated A man of the Ansar:

Kulayb reported from a man of the Ansar. He said: We went out with the Apostle of Allah (peace_be_upon_him) on a journey. The people suffered from intense need and strain. They gained booty and then plundered it. While our pots were boiling the Apostle of Allah (peace_be_upon_him) came walking with his bow touching the ground. He turned over our pots with his bow and smeared the meat with the soil, and said: "Plunder is more unlawful than carrion," or he said: "Carrion is more unlawful than plunder." The narrator Hannad was doubtful.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2700]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2700

Narrated One of the Companion:

Al-Qasim, the client of AbdurRahman, quoted one of the Companion of the Prophet (peace_be_upon_him) as saying: We would eat a camel on an expedition without dividing it, and when we returned to our dwellings our saddle-bags would be full with its flesh.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2701]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2701

Narrated Mu'adh ibn Jabal:

AbdurRahman ibn Ghanam said: We were stationed at the frontiers of the city of Qinnisrin with Shurahbil ibn as-Simt. When he conquered it, he got sheep and cows there. He distributed some of them amongst us, and deposited the rest of them in the spoils of war. I met Mu'adh ibn Jabal and mentioned it to him. Mu'adh said: we went on an expedition of Khaybar along with the Apostle of Allah (peace_be_upon_him) and we got spoils there. The Apostle of Allah (peace_be_upon_him) divided them among us and placed the rest of them in the booty.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2702]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2702

Narrated Ruwayfi' ibn Thabit al-Ansari:

The Prophet (peace_be_upon_him) said: He who believes in Allah and the Last Day must not ride on packhorse belonging to the booty of the Muslims and put it back when he has emaciated it; and he who believes in Allah and the Last Day must not wear a garment belonging to the booty of the Muslims and put it back when he made it threadbare.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2703]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2703

Narrated Abdullah ibn Mas'ud:

I passed when AbuJahl had fallen as his foot was struck (with the swords). I said: O enemy of Allah, AbuJahl, Allah has disgraced a man who was far away from His mercy. I did not fear him at that moment. He replied: It is most strange that a man has been killed by his people. I struck him with a blunt sword. But it did not work, and then his sword fell down from his hand, I struck him with it until he became dead.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2704]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2704

Narrated Zayd ibn Khalid al-Juhani:

A man from the Companions of the Prophet (peace_be_upon_him) died on the day of Khaybar. They mentioned the matter to the Apostle of Allah. He said: Offer prayer over your companion. When the faces of the people looked perplexed, he said: Your companion misappropriated booty in the path of Allah. We searched his belongings and found some Jewish beads not worth two dirhams.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2706]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2706

Narrated Abdullah ibn Amr ibn al-'As:

When the Apostle of Allah (peace_be_upon_him) gained booty he ordered Bilal to make a public announcement. He made a public announcement, and when the people brought their booty, he would take a fifth and divide it. Thereafter a man brought a halter of hair and said: Apostle of Allah, this is a part of the booty we got. He asked: Have you heard Bilal making announcement three times? He replied: Yes. He asked: What did prevent you from bringing it? He made some excuse, to which he said: Be (as you are), you may bring it on the Day of Judgment, for I shall not accept it from you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2707]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2707

Narrated Umar ibn al-Khattab:

Salih ibn Muhammad ibn Za'idah (AbuDawud said: This Salih is AbuWaqid) said: We entered the Byzantine territory with Maslamah. A man who had been dishonest about booty was brought.

He (Maslamah) asked Salim about him. He said: I heard my father narrating from Umar ibn al-Khattab from the Prophet (peace_be_upon_him). He said: When you find a man who has been dishonest about booty, burn his property, and beat him. He beat him. He said: We found in his property a copy of the Qur'an. He again asked Salim about it. He said: Sell it and give its price in charity.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2709]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2709

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him), AbuBakr and Umar burned the belongings of anyone who had been dishonest about booty and beat him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2710]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2710

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: To begin with, anyone who conceals one who has been dishonest about booty is like him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2715]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2715

Narrated Awf ibn Malik al-Ashja'i ; Khalid ibn al-Walid:

The Apostle of Allah (peace_be_upon_him) gave judgement that the killer should have what was taken from the man he killed, and did not make this subject to division into fifths.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2716]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2716

Narrated Abdullah ibn Mas'ud:

At the battle of Badr the Apostle of Allah gave me AbuJahl's sword, as I had killed him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2717]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2717

Narrated Sa'id ibn al-'As:

The Apostle of Allah (peace_be_upon_him) sent AbuSa'id ibn al-'As with an expedition from Medina towards Najd. Aban ibn Sa'id and his companions came to the Apostle of Allah (peace_be_upon_him) at Khaybar after it had been captured. The girths of their horses were made of palm fibres. Aban said: Give us a share (from the booty), Apostle of Allah. AbuHurayrah said: I said: Do not give them a share, Apostle of Allah. Aban said: Why are you talking so, Wabr. You have come to us from the peak of Dal. The Prophet (peace_be_upon_him) said: Sit down, Aban. The Apostle of Allah (peace_be_upon_him) did not give any share to them (from the booty).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2720]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2720

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) stood up, i.e. on the day of Badr, and said: Uthman has gone off on the business of Allah and His Apostle, and I shall take the oath of allegiance on his behalf. The Apostle of Allah (peace_be_upon_him) then allotted him a share, but did not do so for anyone else who was absent.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2721]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2721

Narrated Abdullah ibn Abbas:

Yazid ibn Hurmuz said: Najdah wrote to Ibn Abbas asking him about such-and-such, and such-and-such, and he mentioned some things; he (asked) about a slave whether he would get something from the spoils; and he (asked) about women whether they used to go out (on expeditions) along with the Apostle of Allah (peace_be_upon_him), and whether they would be allotted a share, Ibn Abbas said: Had I not apprehended a folly, I would not have written (a reply) to him. As for the slave, he was given a little of the spoils (as a reward from the booty); as to the women, they would treat the wounded and supply water.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2723]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2723

Narrated Umm Ziyad:

Hashraj ibn Ziyad reported on the authority of his grandmother that she went out with the Apostle of Allah (peace_be_upon_him) for the battle of Khaybar. They were six in number including herself.

(She said): When the Apostle of Allah (peace_be_upon_him) was informed about it, he sent for us. We came to him, and found him angry.

He said: With whom did you come out, and by whose permission did you come out?

We said: Apostle of Allah, we have come out to spin the hair, by which we provide aid in the cause of Allah. We have medicine for the wounded, we hand arrows (to the fighters), and supply drink made of wheat or barley.

He said: Stand up. When Allah bestowed victory of Khaybar on him, he allotted shares to us from spoils that he allotted to the men. He (Hashraj ibn Ziyad) said: I said to her: Grandmother, what was that? She replied: Dates.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2724]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2724

Narrated Umayr, client of AbulLahm:

I was present at Khaybar along with my masters who spoke about me to the Apostle of Allah (peace_be_upon_him). He ordered about me, and a sword was girded on me and I was trailing it. He was then informed that I was a slave. He, therefore, ordered that I should be given some inferior goods.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2725]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2725

Narrated Jabir ibn Abdullah:

I supplied water to my companions on the day of Badr.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2728]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2728

Narrated AbuUmrah (al-Ansari?):

We four persons, came to the Apostle of Allah (peace_be_upon_him), and we (i.e. each one of us) had horses. He therefore, allotted one portion for each of us, and two portions for his horse.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2730]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2730

Narrated Mujammi' ibn Jariyah al-Ansari:

Mujammi' was one of the Qur'an-reciters (qaris), and he said: We were present with the Apostle of Allah (peace_be_upon_him) at al-Hudaybiyyah. When we returned, the people were driving their camels quickly.

The people said to one another: What is the matter with them?

They said: Revelation has come down to the Prophet (peace_be_upon_him). We also proceeded with the people, galloping (our camels). We found the Prophet (peace_be_upon_him) standing on his riding-animal at Kura' al-Ghamim.

When the people gathered near him, he recited: "Verily We have granted thee a manifest victory.

A man asked: Is this a victory, Apostle of Allah? He replied: Yes. By Him in Whose hands the soul of Muhammad is, this is a victory. Khaybar was divided among those who had been at al-Hudaybiyyah, and the Apostle of Allah (peace_be_upon_him) divided it into eighteen portions. The army consisted of one thousand five hundred men, of which three hundred were cavalry, and he gave two shares to a horseman and one to a foot-soldier.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2731]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2731

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) said on the day of Badr: He who does such-and-such, will have such-and such. The young men came forward and the old men remained standing near the banners, and they did not move from there. When Allah bestowed victory on them, the old men said: We were support for you. If you had been defeated, you would have returned to us. Do not take this booty alone and we remain (deprived of it). The young men refused (to give), and said: The Apostle of Allah (peace_be_upon_him) has given it to us. Then Allah sent down: "They ask thee concerning (things taken as) spoils of war, Say: (Such) spoils are at the disposal of Allah and the Apostle......Just as they Lord ordered thee out of thy house in truth, even though a party among the believers disliked it." This proved good for them. Similarly obey me. I know the consequence of this better than you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2732]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2732

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) said on the day of Badr: He who kills a man will get such-and-such, and he who captivates a man will get such-and-such. The narrator then transmitted the rest of the tradition in a similar manner. The tradition of Khalid is more perfect.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2735]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2735

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) sent us along with an army towards Najd, and he sent a detachment of that army (to face the enemy). The whole army got twelve camels per head as their portion, but he gave the detachment one additional camel (apart from the division made to the army). Thus they got thirteen camels each (as a reward).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2737]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2737

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) sent a detachment to Najd. I went out along with them, and got abundant riches. Our commander gave each of us a camel as a reward. We then came upon the Apostle of Allah (peace_be_upon_him) and he divided the spoils of war among us. Each of us received twelve camels after taking a fifth of it. The Apostle of Allah (peace_be_upon_him) did not take account of our companion (i.e. the commander of the army), nor did he blame him for what he had done. Thus each man of us had received thirteen camels with the reward he gave.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2740]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2740

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) used to give to some of the detachments he sent out (something extra) for themselves in particular apart from the division made to the whole army. The fifth is necessary in all that.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2741]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2741

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) went out on the day of Badr along with three hundred and fifteen (men). The Apostle of Allah (peace_be_upon_him) said: O Allah, they are on foot, provide mount for them; O Allah , they are naked, clothe them; O Allah, they are hungry, provide food for them. Allah then bestowed victory on them. They returned when they were clothed. There was no man of them but he returned with one or two camels; they were clothed and ate to their fill.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2742]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2742

Narrated Habib ibn Maslamah al-Fihri:

The Apostle of Allah (peace_be_upon_him) would give a third of the spoils after he would keep off the fifth.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2743]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2743

Narrated Habib ibn Maslamah:

The Apostle of Allah (peace_be_upon_him) used to give a quarter of the booty as reward after the fifty had been kept off, and a third after the fifth had been kept off when he returned.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2744]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2744

Narrated Habib ibn Maslamah al-Fihri:

Makhul said: I was the slave of a woman of Banu Hudhayl; afterwards she emancipated me. I did not leave Egypt until I had acquired all the knowledge that seemed to me to exist there.

I then came to al-Hijaz and I did not leave it until I had acquired all the knowledge that seemed to be available.

Then I came to al-Iraq, and I did not leave it until I had acquired all the knowledge that seemed to be available.

I then came to Syria, and besieged it. I asked everyone about giving rewards from the booty. I did not find anyone who could tell me anything about it.

I then met an old man called Ziyad ibn Jariyah at-Tamimi. I asked him: Have you heard anything about giving rewards from the booty? He replied: Yes. I heard Maslamah al-Fihri say: I was present with the Prophet (peace_be_upon_him).

He gave a quarter of the spoils on the outward journey and a third on the return journey.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2745]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2745

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: Muslims are equal in respect of blood. The lowest of them is entitled to give protection on behalf of them, and the one residing far away may give protection on behalf of them. They are like one hand over against all those who are outside the community. Those who have quick mounts should return to those who have slow mounts, and those who got out along with a detachment (should return) to those who are stationed. A believer shall not be killed for an unbeliever, nor a confederate within the term of confederation with him.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2747]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2747

Narrated Ma'an ibn Yazid:

AbulJuwayriyyah al-Jarmi said: I found a red pitcher containing dinars in Byzantine territory during the reign of Mu'awiyah. A man from the Companions of the Prophet (peace_be_upon_him) belonging to Banu Sulaym was our ruler. He was called Ma'an ibn Yazid. I brought it to him. He apportioned it among the Muslims. He gave me the same portion which he gave to one of them. He then said: Had I not heard the Apostle of Allah (peace_be_upon_him) say: There is no reward except after taking the fifth (from the booty), I would have given you (the reward). He then presented his own share to me, but I refused.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2749]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2749

Narrated Amr ibn Abasah:

The Apostle of Allah (peace_be_upon_him) led us in prayer facing a camel which had been taken in booty, and when he had given the salutation, he took a hair from the camel's side and said: I have no right as much as this of your booty, but only to the fifth. and the fifth is returned to you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2752]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2752

Narrated AbuRafi':

The Quraysh sent me to the Apostle of Allah (peace_be_upon_him), and when I saw the Apostle of Allah (peace_be_upon_him), Islam was cast into my heart, so I said: Apostle of Allah, I swear by Allah, I shall never return to them. The Apostle of Allah (peace_be_upon_him) replied: I do not break a covenant or imprison messengers, but return, and if you feel the same as you do just now, come back. So I went away, and then came to the Prophet (peace_be_upon_him) and accepted Islam.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2753]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2753

Narrated Amr ibn Abasah:

Sulaym ibn Amir, a man of Himyar, said: There was a covenant between Mu'awiyah and the Byzantines, and he was going towards their country, and when the covenant came to an end, he attacked them. A man came on a horse, or a packhorse saying, Allah is Most Great, Allah is Most Great; let there be faithfulness and not treachery. And when they looked they found that he was Amr ibn Abasah. Mu'awiyah sent for him and questioned him (about that). He said: I heard the Apostle of Allah (peace_be_upon_him) say: When one has covenant with people he must not strengthen or loosen it till its term comes to an end or he brings it to an end in agreement with them (to make both the parties equal). So Mu'awiyah returned.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2754]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2754

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) said: If anyone kills a man whom he grants protection prematurely, Allah will forbid him to enter Paradise.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2755]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2755

Narrated Nu'aym ibn Mas'ud:

I heard the Apostle of Allah (peace_be_upon_him) say when he read the letter of Musaylimah: What do you believe yourselves? They said: We believe as he believes. He said: I swear by Allah that were it not that messengers are not killed, I would cut off your heads.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2756]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2756

Narrated Abdullah ibn Mas'ud:

Harithah ibn Mudarrib said that he came to Abdullah ibn Mas'ud and said (to him): There is no enmity between me and any of the Arabs. I passed a mosque of Banu Hanifah. They (the people) believed in Musaylimah. Abdullah (ibn Mas'ud) sent for them. They were brought, and he asked them to repent, except Ibn an-Nawwahah. He said to him: I heard the Apostle of Allah (peace_be_upon_him) say: Were it not that you were not a messenger, I would behead you. But today you are not a messenger. He then ordered Qarazah ibn Ka'b (to kill him). He beheaded him in the market. Anyone who wants to see Ibn an-Nawwahah slain in the market (he may see him).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2758]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2758

Narrated Aisha, Ummul Mu'minin:

A woman would give security from the believers and it would be allowed.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2761]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2761

Narrated Dhu Mikhbar:

Hassan ibn Atiyyah said: Makhul and Ibn Zakariyya went to Khalid ibn Ma'dan, and I also went along with them. He reported a tradition on the authority of Jubayr ibn Nufayr. He said: Go with us to Dhu Mikhbar, a man from the Companions of the Prophet (peace_be_upon_him). We came to him and Jubayr asked him about peace. He said: I heard the Apostle of Allah (peace_be_upon_him) say: You will make a secure peace with the Byzantines, then you and they will fight an enemy behind you.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2763]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2763

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Faith prevented assassination. A believer should not assassinate.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2768]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2768

Narrated AbuBakrah:

When anything came to the Prophet (peace_be_upon_him) which caused pleasure (or, by which he was made glad), he prostrated himself in gratitude to Allah.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2769]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2769

Narrated Sa'd ibn AbuWaqqas:

We went out with the Apostle of Allah (peace_be_upon_him) from Mecca making for Medina. When we were near Azwara', he alighted, then raised his hands, and made supplication to Allah for a time, after which he prostrated himself, remaining a long time in prostration. Then he stood up and raised his hands for a time, after which he prostrated himself, remaining a long time in prostration.

He then stood up and raised his hands for a time, after which he prostrated himself. Ahmad mentioned it three times.

He then said: I begged my Lord and made intercession for my people, and He gave me a third of my people, so I prostrated myself in gratitude to my Lord. Then I raised my head and begged my Lord for my people, and He gave me a third of my people, so I prostrated myself in gratitude to my Lord. Then I raised my head and begged my Lord for my people and He gave me the remaining third, so I prostrated myself in gratitude to my Lord.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2770]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2770

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) disapproved that a man should come to his family during the night (after returning from a journey).


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2771]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2771

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: The best time for a man to go in to his family on return from a journey is at the beginning of the night.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2776]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2776

Narrated Abdullah ibn Umar:

When the Apostle of Allah (peace_be_upon_him) arrived from his hajj, he entered Medina, and made (his camel) kneel down at the gate of his mosque; and he entered it and offered two rak'ahs of prayer; he then returned to his home. Nafi' said: Ibn Umar also used to do so.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2777]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2777

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) said: Beware of the wages of a distributor of booty (qusamah). We asked: What is qusamah (wages of a distributor)? He said: It means a thing which is shared by the people, and then it is reduced.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2778]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2778

Narrated Ata' ibn Yasar:

Ata' reported a similar tradition (to No 2777) from the Prophet (peace_be_upon_him).

This version adds: a man is appointed on groups of people, and takes (wages) from the share of this, and from the share of this.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2779]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2779

Narrated A man from the Companions of the Prophet:

Ubaydullah ibn Salman reported on the authority of a man from the Companions of the Prophet (peace_be_upon_him): When we conquered Khaybar, they (the people) took out their spoils which contained equipment and captives. The people began to buy and sell their spoils. When the Apostle of Allah (peace_be_upon_him) prayed, a man came to him and said: Apostle of Allah, I have gained today so much so that no one gained from this valley. He asked: Woe unto you, how much did you gain? He replied: I kept on selling and buying until I gained three hundred uqiyahs. The Apostle of Allah (peace_be_upon_him) said: I tell you a man who gained better than you. He asked: What is that, Apostle of Allah? He replied! Two rak'ahs (of supererogatory prayer) after the (obligatory) prayer.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2780]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2780

Narrated Dhul-Jawshan:

A man of ad-Dabab, said: When the Prophet (peace_be_upon_him) became free from the people of Badr I brought to him a colt of my mare called al-Qarha' I said: Muhammad, I have brought a colt of a al-Qarha' , so that you may take it. He said: I have no need of it. If you wish that I give you a select coat of mail from (the spoils of) Badr, I shall do it. I said: I cannot give you today a colt in exchange. He said: Then I have no need of it.


Dawud :: Jihad (Kitab Al-Jihad) :: [14.2781]

Jihad (Kitab Al-Jihad)

Dawud :: Book 14 : Hadith 2781

Narrated Samurah ibn Jundub:

To proceed, the Apostle of Allah (peace_be_upon_him) said: Anyone who associates with a polytheist and lives with him is like him.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2782]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2782

Narrated Mikhnaf ibn Sulaym:

We were staying with the Apostle of Allah (peace_be_upon_him) at Arafat; he said: O people, every family must offer a sacrifice and an atirah. Do you know what the atirah is? It is what you call the Rajab sacrifice.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2783]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2783

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: I have been commanded to celebrate festival ('Id) on the day of sacrifice, which Allah, Most High, has appointed for this community. A man said: If I do not find except a she-goat or a she-camel borrowed for milk or other benefits, should I sacrifice it? He said: No, but you should clip your hair , and nails, trim your moustaches, and shave your pubes. This is all your sacrifice in the eyes of Allah, Most High.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2784]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2784

Narrated Ali ibn AbuTalib:

Hanash said: I saw Ali sacrificing two rams; so I asked him: What is this? He replied. The Apostle of Allah (peace_be_upon_him) enjoined upon me to sacrifice on his behalf, so that is what I am doing.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2789]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2789

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) sacrificed two horned rams which were white with black markings and had been castrated. When he made them face the qiblah, he said: I have turned my face towards Him. Who created the heavens and the earth, following Abraham's religion, the true in faith, and I am not one of the polytheists. My prayer, and my service of sacrifice, my life and my death are all for Allah, the Lord of the Universe, Who has no partner. That is what I was commanded to do, and I am one of the Muslims. O Allah it comes from Thee and is given to Thee from Muhammad and his people. In the name of Allah, and Allah is Most Great. He then made sacrifice.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2790]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2790

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) used to sacrifice a choice, horned ram with black round the eyes, the mouth and the feet.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2792]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2792

Narrated Zayd ibn Khalid al-Juhani:

The Apostle of Allah (peace_be_upon_him) distributed sacrificial animals among his Companions. He gave me a kid (of less than a year). I took it to him and said: This is a kid. He said: Sacrifice it. so I sacrificed it.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2795]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2795

Narrated Al-Bara' ibn Azib:

A maternal uncle of mine called AbuBurdah sacrificed before the prayer (for 'Id). The Apostle of Allah (peace_be_upon_him) said: Your goat is meant for flesh. He said: Apostle of Allah, I have a domestic kid with me. He said: Sacrifice it, but it is not valid for any man other than you.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2796]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2796

Narrated Al-Bara' ibn Azib:

Ubayd ibn Firuz said: I asked al-Bara' ibn Azib: What should be avoided in sacrificial animals? He said: The Apostle of Allah (peace_be_upon_him) stood among us, and my fingers are smaller than his fingers, and my fingertips are smaller than his fingertips. He said (pointing with his fingers): Four (types of animals) should be avoided in sacrifice: A One-eyed animal which has obviously lost the sight of one eye, a sick animal which is obviously sick, a lame animal which obviously limps and an animal with a broken leg with no marrow. I also detest an animal which has defective teeth. He said: Leave what you detest, but do not make it illegal for anyone.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2797]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2797

Narrated Utbah ibn AbdusSulami:

Yazid Dhu Misr said: I came to Utbah ibn AbdusSulami and said: AbulWalid, I went out seeking sacrificial animals. I did not find anything which attracted me except an animal whose teeth have fallen. So I abominated it. What do you say (about it)? He said: Why did you not bring it to me? He said: Glory be to Allah: Is if lawful for you and not lawful for me? He said: Yes, you doubt and I do not doubt. The Apostle of Allah (peace_be_upon_him) has forbidden an animal whose ear has been uprooted so much so that its hole appears (outwardly), and an animal whose horn has broken from the root, and an animal which has totally lost the sight of its eye, and an animal which is so thin and weak that it cannot go with the herd, and an animal with a broken leg.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2798]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2798

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) enjoined upon us to pay great attention to the eye and both ears, and not to sacrifice a one-eyed animal, and an animal with a slit which leaves something hanging at the front or back of the ear, or with a lengthwise slit with a perforation in the ear. I asked AbuIshaq: Did he mention an animal with broken horns and uprooted ears? He said: No.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2799]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2799

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) prohibited to sacrifice an animal with a slit ear and broken horn.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2802]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2802

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: A cow serves for seven, and a camel serves for seven.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2803]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2803

Narrated Jabir ibn Abdullah:

We sacrificed along with the Apostle of Allah (peace_be_upon_him) at al-Hudaybiyyah a camel for seven and a cow for seven people.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2804]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2804

Narrated Jabir ibn Abdullah:

I witnessed sacrificing along with the Apostle of Allah (peace_be_upon_him) at the place of prayer. When he finished his sermon, he descended from his pulpit, and a ram was brought to him. The Apostle of Allah (peace_be_upon_him) slaughtered it with his hand, and said: In the name of Allah, Allah, is Most Great. This is from me and from those who did not sacrifice from my community.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2807]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2807

Narrated Nubayshah:

The Prophet (peace_be_upon_him) said: We forbade you to eat their meat for more than three days in order that you might have abundance; now Allah has produced abundance, so you may eat, store up and seek reward. Beware, these days are days of eating, drinking and remembrance of Allah, Most High.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2812]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2812

Narrated Abdullah ibn Abbas:

explaining the verse "But the evil ones ever inspire their friend to contend with you" They used to say: Do not eat which Allah killed, but eat which you slaughtered. So Allah revealed the verse: "Eat not of (meats) on which Allah's name hath not been pronounced"...to the end of the verse.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2813]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2813

Narrated Abdullah ibn Abbas:

The Jews came to the Prophet (peace_be_upon_him) and said: We eat which we kill but we do not eat which Allah kills? So Allah revealed: "Eat not of (meats) on which Allah's name hath not been pronounced." to the end of the verse.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2814]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2814

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) forbade to eat (the meat of animals) slaughtered by the bedouins for vainglory and pride.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2816]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2816

Narrated Muhammad ibn Safwan or Safwan ibn Muhammad:

I hunted two hares and slaughtered them with a flint. I asked the Apostle of Allah (peace_be_upon_him) about them. He permitted me to eat them.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2817]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2817

Narrated Ata' ibn Yasar:

A man of Banu Harith was pasturing a pregnant she-camel in one of the ravines of Uhud, (he saw that) it was about to die; he could find nothing to slaughter it; he took a stake and stabbed it in the upper part of its breast until he made its blood flow.

He then came to the Prophet (peace_be_upon_him) and informed him about that, and he ordered him to eat it.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2818]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2818

Narrated Adi ibn Hatim:

I said: Apostle of Allah, tell me when one of us catches game and has no knife; may he slaughter with a flint and a splinter of stick. He said: Cause the blood to flow with whatever you like and mention Allah's name.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2819]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2819

Narrated AbulUshara' (Usamah ibn Malik?):

AbulUshara' reported on the authority of his father: He asked: Apostle of Allah, is the slaughtering to be done only in the upper part of the breast and the throat? The Apostle of Allah (peace_be_upon_him) replied: If you pierced its thigh, it would serve you.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2820]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2820

Narrated Abdullah ibn Abbas:

Ibn Isa added: (Ibn Abbas) and AbuHurayrah said: The Apostle of Allah (peace_be_upon_him) forbade the devil's sacrifice. AbuIsa added in his version: This refers to the slaughtered animal whose skin cut off, and is then left to die without its jugular veins being severed.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2821]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2821

Narrated AbuSa'id al-Khudri:

I asked the Apostle of Allah (peace_be_upon_him) about the embryo. He replied: Eat it if you wish.

Musaddad's version says: we said: Apostle of Allah, we slaughter a she-camel, a cow and a sheep, and we find an embryo in its womb. Shall we throw it away or eat it? He replied: Eat it if you wish for the slaughter of its mother serves its slaughter.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2822]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2822

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: The slaughter of embryo is included when its mother is slaughtered.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2824]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2824

Narrated Nubayshah:

A man called the Apostle of Allah (peace_be_upon_him): We used to sacrifice Atirah in pre-Islamic days during Rajab; so what do you command us? He said: Sacrifice for the sake of Allah in any month whatever; obey Allah, Most High, and feed(the people). He said: We used to sacrifice a Fara' in pre-Islamic days, so what do you command us? He said: On every pasturing animal there is a Fara' which is fed by your cattle till it becomes strong and capable of carrying load.

The narrator Nasr said (in his version): When it becomes capable of carrying load of the pilgrims, you may slaughter it and give its meat as charity (sadaqah).

The narrator Khalid's version says: You (may give it) to the travellers, for it is better. Khalid said: I asked AbuQilabah: How many pasturing animals? He replied: One hundred.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2828]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2828

Narrated Umm Kurz al-Ka'biyyah:

I heard the Apostle of Allah (peace_be_upon_him) say: Two resembling sheep are to be sacrificed for a boy and one for a girl.

AbuDawud said: I heard Ahmad (ibn Hanbal) say: The Arabic word mukafi'atani means equal (in age) or resembling each other.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2829]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2829

Narrated Umm Kurz:

I heard the Prophet (nay peace be upon him) say: Let the birds stay in their roosts. She said: I also heard him say: Two sheep are to be sacrificed for a boy and one for a girl, but it does you no harm whether they are male or female.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2830]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2830

Narrated Umm Kurz:

The Apostle of Allah (peace_be_upon_him) said: Two sheep which resemble each other are to be sacrificed for a boy and one for a girl.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2831]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2831

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: A boy is in pledge for his Aqiqah. Sacrifice is made for him on the seventh day, his head is shaved and is smeared with blood.

When Qatadah was asked about smearing with blood, how that should be done, he said: When you cut the head (i.e. throat) of the animal (meant for Aqiqah), you may take a few hair of it, place them on its veins, and then place them in the middle of the head of the infant, so that the blood flows on the hair (of the infant) like a threat. Then its head may be washed and shaved off.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2832]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2832

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: A boy is in pledge for his Aqiqah, Sacrifice is made for him on the seventh day, his head is shaved and he is given name.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2835]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2835

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) sacrificed a ram for both al-Hasan and al-Husayn each (Allah be pleased with them).


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2836]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2836

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) was asked about the aqiqah. He replied: Allah does not like the breaking of ties (uquq), as though he disliked the name. And he said: If anyone has a child born to him and wishes to offer a sacrifice on its behalf, he may offer two resembling sheep for a boy and one for a girl. And he was asked about fara'. He replied: Fara' is right. If you leave it (i.e. let it grow till it becomes a healthy camel of one year or two years, then you give it to a widow or give it in the path of Allah for using it as a riding beast, it is better than slaughtering it at the age when its meat is stuck to its hair, and you turn over your milking vessel and annoy your she-camel.


Dawud :: Sacrifice (Kitab Al-Dahaya) :: [15.2837]

Sacrifice (Kitab Al-Dahaya)

Dawud :: Book 15 : Hadith 2837

Narrated Buraydah ibn al-Hasib:

When a boy was born to one of us in the pre-Islamic period, we sacrificed a sheep and smeared his head with its blood; but when Allah brought Islam, we sacrificed a sheep, shaved his head and smeared his head with saffron.


Dawud :: Game (Kitab Al-Said) :: [16.2839]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2839

Narrated Abdullah ibn Mughaffal:

The Prophet (peace_be_upon_him) said: Were dogs not a species of creature I should command that they all be killed; but kill every pure black one.


Dawud :: Game (Kitab Al-Said) :: [16.2840]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2840

Narrated Jabir ibn Abdullah:

The Prophet of Allah (peace_be_upon_him) ordered to kill dogs, and we were even killing a dog which a woman brought with her from the desert. Afterwards he forbade to kill them, saying: Confine yourselves to the type which is black.


Dawud :: Game (Kitab Al-Said) :: [16.2845]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2845

Narrated Adi ibn Hatim:

The Prophet (peace_be_upon_him) said: Eat what ever is caught for you by a dog or a hawk you have trained and set off when you have mentioned Allah's name. I said: (Does this apply) if it killed (the animal)? He said: When it kills it without eating any of it, for it caught it only for you.


Dawud :: Game (Kitab Al-Said) :: [16.2846]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2846

Narrated AbuTha'labah al-Khushani:

The Apostle of Allah (peace_be_upon_him) said about the game hunted by a dog: If you set off your dog and have mentioned Allah's name, eat (it), even if it eats any of it; and eat what your hands return you.


Dawud :: Game (Kitab Al-Said) :: [16.2847]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2847

Narrated Adi ibn Hatim:

Apostle of Allah, one of us shoots at the game, and follows its mark for two or three days, and then finds it dead, and there is his arrow (pierced) in it, may he eat it? He said: Yes, if he wishes, or he said: he may eat if he wishes.


Dawud :: Game (Kitab Al-Said) :: [16.2850]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2850

Narrated AbuTha'labah al-Khushani:

The Apostle of Allah (peace_be_upon_him) said to me: AbuTha'labah, eat what returns to you by your bow and your dog.

Ibn Harb's version adds: "The trained (dog), and your hand, then eat, whether it has been slaughtered or not slaughtered".


Dawud :: Game (Kitab Al-Said) :: [16.2851]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2851

Narrated Abdullah ibn Amr ibn al-'As:

There was a bedouin called AbuTha'labah. He said: Apostle of Allah, I have trained dogs, so tell me your opinion about (eating) the animal they hunt. The Prophet (peace_be_upon_him) said: If you have trained dogs, then eat what they catch for you. He asked: Whether it is slaughtered or not? He replied: Yes. He asked: Does it apply even if it eats any of it? He replied: Even if it eats any of it. He again asked: Apostle of Allah, tell me your opinion about my bow (i.e. the game hunted by arrow). He said: Eat what your bow returns to you, whether it is slaughtered or not. He asked: If it goes out of my sight? He replied: Even if it goes out of your sight, provided it has no stench, or you find a mark on it other than the mark of your arrow.

He asked: Tell me about the use of the vessels of the Magians when we are forced to use them. He replied: Wash them and eat in them.


Dawud :: Game (Kitab Al-Said) :: [16.2852]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2852

Narrated AbuWaqid:

The Prophet (peace_be_upon_him) said: Whatever is cut off of an animal when it is alive is dead.


Dawud :: Game (Kitab Al-Said) :: [16.2853]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2853

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: (the narrator Sufyan said: I do not know but that it [the tradition] has been transmitted from the Prophet (peace_be_upon_him): He who lives in the desert will become rude; he who pursues the game will be negligent, and he who visits a king will be perverted.


Dawud :: Game (Kitab Al-Said) :: [16.2854]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2854

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He said: He who sticks to a king is perverted. This version adds: The nearer a servant (of Allah) goes to a king, the farther he keeps away from Allah.


Dawud :: Game (Kitab Al-Said) :: [16.2855]

Game (Kitab Al-Said)

Dawud :: Book 16 : Hadith 2855

Narrated AbuTha'labah al-Khushani:

The Prophet (peace_be_upon_him) said: When you shoot your arrow (and the animal goes out of your sight) and you come three days later on it, and in it there is your arrow, then eat provided it has not stench.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2860]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2860

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: A man giving a dirham as sadaqah (charity) during his life is better than giving one hundred dirhams as sadaqah (charity) at the moment of his death.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2861]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2861

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A man or a woman acts in obedience to Allah for sixty years, then when they are about to die they cause injury by their will, so they must go to Hell. Then AbuHurayrah recited: "After a legacy which you bequeath or a debt, causing no injury...that will be the mighty success.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2864]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2864

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah has appointed for everyone who has a right what is due to him, and no bequest must be made to an heir.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2865]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2865

Narrated Abdullah ibn Abbas:

When Allah, Most High, revealed the verses: "Come not nigh to the orphan's property except to improve it". And "Those who unjustly eat up the property of orphans", everyone who had an orphan with him went and separated his food from his (orphan's) food, and his drink from his drink, and began to detain the remaining food which he (the orphan) himself ate or spoiled.

This fell heavy on them, and they mentioned this to the Apostle of Allah (peace_be_upon_him). So Allah, Most High, revealed the verse: "They ask thee concerning orphans. Say: The best thing to do is what is for their good; if ye mix their affairs with yours, they are your brethren." Then they mixed their food with his food and their drink with his drink.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2866]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2866

Narrated Abdullah ibn Amr ibn al-'As:

A man came to the Prophet (peace_be_upon_him) and said: I am poor, I have nothing (with me), and I have an orphan. He said: Use the property of your orphan without spending it lavishly, hurrying and taking it as your own property.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2867]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2867

Narrated Ali ibn AbuTalib:

I memorised (a tradition) from the Apostle of Allah (peace_be_upon_him): There is no orphanhood after puberty, and there is no silence for the whole day till the night.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2869]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2869

Narrated Umar ibn al-Khattab:

A Companion of the Prophet (peace_be_upon_him) said: A man asked him (the Prophet): Apostle of Allah, what are the grave sins? He replied: They are nine. He then mentioned the tradition to the same effect. This version adds: "And disobedience to the Muslim parents, and to violate the sacred House, your qiblah (direction of prayer), in your life and after death.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2875]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2875

Narrated Aisha, Ummul Mu'minin:

A woman said: Apostle of Allah, my mother suddenly died; if it had not happened, she would have given sadaqah (charity) and donated (something). Will it suffice if I give sadaqah on her behalf? The Prophet (peace_be_upon_him) said: Yes, give sadaqah on her behalf.


Dawud :: Wills (Kitab Al-Wasaya) :: [17.2877]

Wills (Kitab Al-Wasaya)

Dawud :: Book 17 : Hadith 2877

Narrated Abdullah ibn Amr ibn al-'As:

Al-'As ibn Wa'il left his will that a hundred slaves should be emancipated on his behalf. His son Hisham emancipated fifty slaves and his son Amr intended to emancipate the remaining fifty on his behalf, but he said: I should ask first the Apostle of Allah (peace_be_upon_him). He, therefore, came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, my father left in his will that a hundred slaves should be emancipated on his behalf and Hisham has emancipated fifty on his behalf and fifty remain. Shall I emancipate them on his behalf? The Apostle of Allah (peace_be_upon_him) said: Had he been a Muslim and you had emancipated slaves on his behalf, or given sadaqah on his behalf, or performed the pilgrimage, that would have reached him.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2879]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2879

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Knowledge has three categories; anything else is extra; a precise verse, or an established sunnah (practice), or a firm obligatory duty.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2881]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2881

Narrated Jabir ibn Abdullah:

I fell ill, and I had seven sisters. The Apostle of Allah (peace_be_upon_him) came to me and blew on my face. So I became conscious. I said: Apostle of Allah, may I not bequeath one-third of my property to my sisters? He replied: Do good. I asked: Half? He replied: Do good. He then went out and left me, and said: I do not think, Jabir, you will die of this disease. Allah has revealed (verses) and described the share of your sisters. He appointed two-thirds for them. Jabir used to say: This verse was revealed about me: "They ask thee for a legal decision. Say: Allah directs (thus) about those who leave no descendants or ascendants as heirs.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2883]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2883

Narrated Al-Bara' ibn Azib:

A man came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, they ask thee for a legal decision about a kalalah. What is meant by kalalah? He replied: The verse revealed in summer is sufficient for you.

I asked AbuIshaq: Does it mean a person who dies and leaves neither children nor father? He said: This is so. The people think it is so.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2885]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2885

Narrated Jabir ibn Abdullah:

We went out with the Apostle of Allah (peace_be_upon_him) and came to a woman of the Ansar in al-Aswaf. The woman brought her two daughters, and said: Apostle of Allah, these are the daughters of Thabit ibn Qays who was killed as a martyr when he was with you at the battle of Uhud, their paternal uncle has taken all their property and inheritance, and he has not left anything for them. What do you think, Apostle of Allah? They cannot be married unless they have some property. The Apostle of Allah (peace_be_upon_him) said: Allah will decide regarding the matter. Then the verse of Surat an-Nisa was revealed: "Allah (thus) directs you as regards your children's (inheritance)." Apostle of Allah (peace_be_upon_him) said: Call to me the woman and her husband's brother. He then said to their paternal uncle: Give them two-thirds and their mother an eighth, and what remains is yours.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2888]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2888

Narrated al-Mughirah ibn Shu'bah:

Qabisah ibn Dhuwayb said: A grandmother came to AbuBakr asking him for her share of inheritance. He said: There is nothing prescribed for you in Allah's Book, nor do I know anything for you in the Sunnah of the Prophet of Allah (peace_be_upon_him) Go home till I question the people. He then questioned the people, and al-Mughirah ibn Shu'bah said: I had been present with the Apostle of Allah (peace_be_upon_him) when he gave grandmother a sixth. AbuBakr said: Is there anyone with you? Muhammad ibn Maslamah stood and said the same as al-Mughirah ibn Shu'bah had said. So AbuBakr made it apply to her. Another grandmother came to Umar ibn al-Khattab asking him for her share of inheritance. He said: Nothing has been prescribed for you in Allah's Book. The decision made before you was made for a grandmother other than you. I am not going to add in the shares of inheritance; but it is that sixth. If there are two of you, it is shared between you, but whichever of you is the only one left gets it all.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2889]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2889

Narrated Buraydah:

The Prophet (peace_be_upon_him) appointed a sixth to a grandmother if no mother is left to inherit before her.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2890]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2890

Narrated Imran ibn Husayn:

A man came to the Prophet (peace_be_upon_him) and said: My son has died; what do I receive from his estate? He replied: You receive a sixth. When he turned away he called him and said: You receive another sixth. When he turned away, he called him and said: The other sixth is an allowance (beyond what is due).

Qatadah said: They (the Companions) did not know the heirs with whom he was given (a sixth). Qatadah said: The minimum share given to the grandfather was a sixth.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2891]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2891

Narrated Ma'qil ibn Yasar:

Al-Hasan reported that Umar asked: Which of your knows what share the Apostle of Allah (peace_be_upon_him) had given to the grandfather from the estate? Ma'qil ibn Yasar said: The Apostle of Allah (peace_be_upon_him) gave him a sixth. He asked: Along with whom? He replied: I do not know. He said: You do not know; what is the use then?


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2892]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2892

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Divide the property among those whose share have been prescribed in the Book of Allah, and what remains from the prescribed shares goes to the nearest male heirs.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2893]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2893

Narrated Al-Miqdam al-Kindi:

The Prophet (peace_be_upon_him) said: If anyone leaves a debt or a helpless family I shall be responsible-and sometimes the narrator said: Allah and His Apostle will be responsible-but if anyone leaves property, it goes to his heirs. I am the heirs of him who has none, paying blood-wit for him and inheriting from him; and a maternal uncle is the heir of him who has none, paying blood-wit for him and inheriting from him.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2894]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2894

Narrated Al-Miqdam al-Kindi:

The Prophet (peace_be_upon_him) said: I am nearer to every believer than himself, so if anyone leaves a debt or a helpless family, I shall be responsible, but if anyone leaves property, it goes to his heirs. I am patron of him who has none, inheriting his property and freeing him from his liabilities. A maternal uncle is patron of him who has none, inheriting his property and freeing him from his liabilities.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2895]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2895

Narrated Al-Miqdam:

I heard the Apostle of Allah (peace_be_upon_him) say: I am the heirs of Him who has none, freeing him from his liabilities, and inheriting what he possesses. A maternal uncle is the heir of Him who has none, freeing him from his liabilities, and inheriting his property.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2896]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2896

Narrated Aisha, Ummul Mu'minin:

A client of the Prophet (peace_be_upon_him) died and left some property, but he left no child or relative. The Apostle of Allah (peace_be_upon_him) said: Give what he has left to a man belonging to his village.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2897]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2897

Narrated Buraydah ibn al-Hasib:

A man came to the Apostle of Allah (peace_be_upon_him) and said: I have property left by a man of Azd. I do not find any man of Azd to give it to him. He said: Go and look for man of Azd for a year. He then came to him after one year and said: Apostle of Allah, I did not find any man of Azd to give it to him. He said: Look for a man of Khuza'ah whom you meet first and give it to him. When he turned away, he said; Call the man to me. When he came to him, he said: Look for the leading man of Khuza'ah and give it to him.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2898]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2898

Narrated Buraydah ibn al-Hasib:

A man of Khuza'ah died and his estate was brought to the Prophet (peace_be_upon_him). He said: Look for his heir or some relative. But they found neither heir nor relative. The Apostle of Allah (peace_be_upon_him) said: Give it to the leading man of Khuza'ah. The narrator Yahya said: Sometimes I heard him (al-Husayn ibn Aswad) say in this tradition: Look for the greatest man of Khuza'ah.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2899]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2899

Narrated Abdullah ibn Abbas:

A man died leaving no heir but a slave whom he had emancipated. The Apostle of Allah (peace_be_upon_him) asked: Has he any heir? They replied: No, except a slave whom he had emancipated. The Apostle of Allah (peace_be_upon_him) assigned his estate to him (the emancipated slave).


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2900]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2900

Narrated Wathilah ibn al-Asqa':

The Prophet (peace_be_upon_him) said: A woman gets inheritance from the three following: one she has set free, a foundling, and her child about whom she has invoked a curse on herself if she was untrue in declaring he was not born out of wedlock.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2901]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2901

Narrated Makhul:

The Apostle of Allah (peace_be_upon_him) assigned the estate of a child of a woman about whom she had invoked a curse to her mother, and to her heirs after her.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2905]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2905

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: people of two different religions would not inherit from one another.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2906]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2906

Narrated Mu'adh ibn Jabal:

I heard the Apostle of Allah (peace_be_upon_him) say: Islam increases and does not diminish. He, therefore, appointed a Muslim heir (of a non-Muslim).


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2908]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2908

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: An estate which was divided in pre-Islamic period may follow the division in force then, but any estate in Islamic times must follow the division laid down by Islam.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2911]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2911

Narrated Umar ibn al-Khattab:

Amr ibn Shu'ayb reported: Rabab ibn Hudhayfah married a woman and three sons were born to him from her. Their mother then died. They inherited her houses and had the right of inheritance of her freed slaves.

Amr ibn al-'As was the agnate of her sons. He sent them to Syria where they died. Amr ibn al-'As then came. A freed slave of hers died and left some property. Her brothers disputed with him and brought the case to Umar ibn al-Khattab.

Umar reported the Apostle of Allah (peace_be_upon_him) as saying: Whatever property a son or a father receives as an heir will go to his agnates, whoever they may be. He then wrote a document for him, witnessed by AbdurRahman ibn Awf, Zayd ibn Thabit and one other person. When AbdulMalik became caliph, they presented the case to Hisham ibn Isma'il or Isma'il ibn Hisham (the narrator is doubtful).

He sent them to AbdulMalik who said: This is the decision which I have already seen.

The narrator said: So he (AbdulMalik) made the decision on the basis of the document of Umar ibn al-Khattab, and that is still with us today.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2912]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2912

Narrated Tamim ad-Dari:

Tamim asked: Apostle of Allah), what is the sunnah about a man who accepts Islam by advice and persuasion of a Muslim? He replied: He is the nearest to him in life and in death.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2914]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2914

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When an infant has raised its voice (and then dies), it will be treated as an heir.


Dawud :: Shares of Inheritance (Kitab Al-Fara'id) :: [18.2921]

Shares of Inheritance (Kitab Al-Fara'id)

Dawud :: Book 18 : Hadith 2921

Narrated Umar ibn al-Khattab:

Sa'id said: Umar ibn al-Khattab said: Blood-money is meant for the clan of the slain, and she will not inherit from the blood-money of her husband. Ad-Dahhak ibn Sufyan said: The Apostle of Allah (peace_be_upon_him) wrote to me that I should give a share to the wife of Ashyam ad-Dubabi from the blood-money of her husband. So Umar withdrew his opinion.

Ahmad ibn Salih said: AbdurRazzaq transmitted this tradition to us from Ma'mar, from az-Zuhri on the authority of Sa'id. In this version he said: The Prophet (peace_be_upon_him) made him governor over the bedouins.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2926]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2926

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: When Allah has a good purpose for a ruler, He appoints for him a sincere minister who reminds him if he forgets and helps him if he remembers; but when Allah has a different purpose from that for him. He appoints for him an evil minister who does not remind him if he forgets and does not help him if he remembers.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2927]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2927

Narrated Al-Miqdam ibn Ma'dikarib:

The Apostle of Allah (peace_be_upon_him) struck him on his shoulders and then said: You will attain success, Qudaym, if you die without having been a ruler, a secretary, or a chief.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2928]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2928

Narrated Ghalib al-Qattan:

Ghalib quoted a man who stated on the authority of his father that his grandfather reported: They lived at one of the springs. When Islam reached them, the master of the spring offered his people one hundred camels if they embraced Islam. So they embraced Islam, and he distributed the camels among them. But it occurred to him that he should take the camels back from them.

He sent his son to the Prophet (peace_be_upon_him) and said to him: Go to the Prophet (peace_be_upon_him) and tell him: My father extends his greetings to you. He asked his people to give them one hundred camels if they embraced Islam, and they embraced Islam. He divided the camels among them. But it occurred to him then that he should withdraw his camels from them. Is he more entitled to them or we? If he says: Yes or no, then tell him: My father is an old man, and he is the chief of the people living at the water. He has requested you to make me chief after him.

He came to him and said: My father has extended his greetings to you. He replied: On you and you father be peace. He said: My father asked his people to give them one hundred camels if they embraced Islam. So they embraced Islam, and their belief in Islam is good. Then it occurred to him that he should take his camels back from them. Is he more entitled to them or are they?

He said: If he likes to give them the camels, he may give them; and if he likes to take them back, he is more entitled to them than his people. If they embraced Islam, then for them is their Islam. If they do not embrace Islam, they will be fought against in the cause of Islam.

He said: My father is an old man; he is the chief of the people living at the spring. He has asked you to appoint me chief after him.

He replied: The office of a chief is necessary, for people must have chiefs, but the chiefs will go to Hell.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2930]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2930

Narrated Rafi' ibn Khadij:

I heard the Apostle of Allah (peace_be_upon_him) say: The official who collects sadaqah (zakat) in a just manner is like him who fights in Allah's path till he returns home.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2931]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2931

Narrated Uqbah ibn Amir:

I heard the Apostle of Allah (peace_be_upon_him) as saying: One who wrongfully takes an extra tax (sahib maks) will not enter Paradise.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2939]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2939

Narrated Al-Mustawrid ibn Shaddad:

Al-Mustawrid heard the Prophet (peace_be_upon_him) say: He who acts as an employee for us must get a wife; if he has not a servant, he must get one, and if he has not a dwelling, he must get one. He said that AbuBakr reported: I was told that the Prophet (peace_be_upon_him) said: He who takes anything else he is unfaithful or thief.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2941]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2941

Narrated AbuMas'ud al-Ansari:

The Prophet (peace_be_upon_him) appointed me to collect sadaqah and then said: Go, AbuMas'ud, I should not find you on the Day of Judgment carrying a camel of sadaqah on your back, which rumbles, the one you have taken by unfaithful dealing in sadaqah. He said: If it is so, I will not go. He said: Then I do not force you.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2942]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2942

Narrated AbuMaryam al-Azdi:

When I entered upon Mu'awiyah, he said: How good your visit is to us, O father of so-and-so. (This is an idiom used by the Arabs on such occasions). I said: I tell you a tradition which I heard (from the Prophet). I heard the Apostle of Allah (peace_be_upon_him) say: If Allah puts anyone in the position of authority over the affairs of the Muslims, and he secludes himself (from them), not fulfilling their needs, wants, and poverty, Allah will keep Himself away from him, not fulfilling his need, want and poverty. He said: He (Mu'awiyah) appointed a man to fulfil the needs of the people.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2943]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2943

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: It is not on my own that I give you or withhold from you: I am just a treasure, putting it where I have been commanded.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2944]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2944

Narrated Umar ibn al-Khattab:

Malik ibn Aws ibn al-Hadthan said: One day Umar ibn al-Khattab mentioned the spoils of war and said: I am not more entitled to this spoil of war than you; and none of us is more entitled to it than another, except that we occupy our positions fixed by the Book of Allah, Who is Great and Glorious, and the division made by the Apostle of Allah (peace_be_upon_him), people being arranged according to their precedence in accepting Islam, the hardship they have endured their having children and their need.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2945]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2945

Narrated Abdullah ibn Umar:

Zayd ibn Aslam said: Abdullah ibn Umar entered upon Mu'awiyah. He asked: (Tell me) your need, AbuAbdurRahman. He replied: Give (the spoils) to those who were set free, for I saw the first thing the Apostle of Allah (peace_be_upon_him) did when anything came to him was to give something to those who had been set free.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2946]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2946

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) was brought a pouch containing bead and divided it among free women and slave women. Aisha said: My father used to divide things between free men and slave.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2948]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2948

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: I am nearer to the believers than themselves, so if anyone leaves property, it goes to his heirs, and if anyone leaves debt and dependants, let the matter come to me and I shall be responsible.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2952]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2952

Narrated A man:

Sulaym ibn Mutayr reported on the authority of his father that Mutayr went away to perform hajj.

When he reached as-Suwaida', a man suddenly came searching for medicine and ammonium anthorhizum extract, and he said: A man who heard the Apostle of Allah (peace_be_upon_him) addressing the people commanding and prohibiting them, told me that he said: O people, accept presents so long as they remain presents; but when the Quraysh quarrel about the rule, and the presents are given for the religion of one of you, then leave them alone.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2953]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2953

Narrated Dhul-Zawa'id:

Mutayr said: I heard a man say: I heard the Apostle of Allah (peace_be_upon_him) in the Farewell Pilgrimage. He was commanding and prohibiting them (the people). He said: O Allah, did I give full information? They said: Yes. He said: When the Quraysh quarrel about the rule among themselves, and the presents become bribery, them leave them. The people were asked: Who was he (who narrated this tradition)? They said: This was Dhul-Zawa'id, a Companion of the Apostle of Allah (peace_be_upon_him).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2955]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2955

Narrated Umar ibn al-Khattab:

A son of Adi ibn Adi al-Kindi said that Umar ibn AbdulAziz wrote (to his governors): If anyone asks about the places where spoils (fay') should be spent, that should be done in accordance with the decision made by Umar ibn al-Khattab (Allah be pleased with him). The believers considered him to be just, according to the saying of the Prophet (peace_be_upon_him): Allah has placed truth upon Umar's tongue and heart. He fixed stipends for Muslims, and provided protection for the people of other religions by levying jizyah (poll-tax) on them, deducting no fifth from it, nor taking it as booty.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2956]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2956

Narrated AbuDharr:

I heard the Apostle of Allah (peace_be_upon_him) say: Allah, the Exalted, has placed truth on Umar's tongue and he speaks it.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2961]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2961

Narrated Umar ibn al-Khattab:

Malik ibn Aws al-Hadthan said: One of the arguments put forward by Umar was that he said that the Apostle of Allah (peace_be_upon_him) received three things exclusively to himself: Banu an-Nadir, Khaybar and Fadak. The Banu an-Nadir property was kept wholly for his emergent needs, Fadak for travellers, and Khaybar was divided by the Apostle of Allah (peace_be_upon_him) into three sections: two for Muslims, and one as a contribution for his family. If anything remained after making the contribution of his family, he divided it among the poor Emigrants.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2963]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2963

Narrated Aisha, Ummul Mu'minin:

Fatimah was demanding (the property of) sadaqah of the Apostle of Allah (peace_be_upon_him) at Medina and Fadak, and what remained from the fifth of Khaybar. Aisha quoted AbuBakr as saying: The Apostle of Allah (peace_be_upon_him) said: We are not inherited; whatever we leave is sadaqah. The family of Muhammad will eat from this property, that is, from the property of Allah. They will not take more then their sustenance.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2966]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2966

Narrated Umar ibn AbdulAziz:

Al-Mughirah (ibn Shu'bah) said: Umar ibn AbdulAziz gathered the family of Marwan when he was made caliph, and he said: Fadak belonged to the Apostle of Allah (peace_be_upon_him), and he made contributions from it, showing repeated kindness to the poor of the Banu Hashim from it, and supplying from it the cost of marriage for those who were unmarried. Fatimah asked him to give it to her, but he refused. That is how matters stood during the lifetime of the Apostle of Allah (peace_be_upon_him) till he passed on (i.e. died).

When AbuBakr was made ruler he administered it as the Prophet (peace_be_upon_him) had done in his lifetime till he passed on. Then when Umar ibn al-Khattab was made ruler he administered it as they had done till he passed on. Then it was given to Marwan as a fief, and it afterwards came to Umar ibn AbdulAziz.

Umar ibn AbdulAziz said: I consider I have no right to something which the Apostle of Allah (peace_be_upon_him) refused to Fatimah, and I call you to witness that I have restored it to its former condition; meaning in the time of the Apostle of Allah (peace_be_upon_him).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2967]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2967

Narrated AbuBakr:

AbutTufayl said: Fatimah came to AbuBakr asking him for the inheritance of the Prophet (peace_be_upon_him). AbuBakr said: I heard the Apostle of Allah (peace_be_upon_him) say: If Allah, Most High, gives a Prophet some means of sustenance, that goes to his successor.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2969]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2969

Narrated Umar ibn al-Khattab:

AbulBakhtari said: I heard from a man a tradition which I liked. I said to him: Write it down for me. So he brought it clearly written to me.

(It says): Al-Abbas and Ali entered upon Umar when Talhah, az-Zubayr, AbdurRahman and Sa'd were with him. They (Abbas and Ali) were disputing.

Umar said to Talhah, az-Zubayr, AbdurRahman and Sa'd: Do you not know that the Apostle of Allah (peace_be_upon_him) said: All the property of the Prophet (peace_be_upon_him) is sadaqah (alms), except what he provided for his family for their sustenance and their clothing. We are not to be inherited.

They said: Yes, indeed. He said: The Apostle of Allah (peace_be_upon_him) used to spend from his property on his family, and give the residue as sadaqah (alms). The Apostle of Allah (peace_be_upon_him) then died, and AbuBakr ruled for two years. He would deal with it in the same manner as the Apostle of Allah (peace_be_upon_him) did. He then mentioned a little from the tradition of Malik ibn Aws.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2976]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2976

Narrated Abdullah ibn Abbas:

Yazid ibn Hurmuz said that when Najdah al-Haruri performed hajj during the rule of Ibn az-Zubayr, he sent someone to Ibn Abbas to ask him about the portion of the relatives (in the fifth). He asked: For whom do you think? Ibn Abbas replied: For the relatives of the Apostle of Allah (peace_be_upon_him). The Apostle of Allah (peace_be_upon_him) divided it among them. Umar presented it to us but we found it less than our right. We, therefore returned it to him and refused to accept it.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2978]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2978

Narrated Ali ibn AbuTalib:

I, al-Abbas, Fatimah and Zayd ibn Harithah gathered with the Prophet (peace_be_upon_him) and I said: Apostle of Allah, if you think to assign us our right (portion) in this fifth ( of the booty) as mentioned in the Book of Allah, and this I may divide during your lifetime so that no one may dispute me after you, then do it. He said: He did that. He said: I divided it during the lifetime of the Apostle of Allah (peace_be_upon_him). AbuBakr then assigned it to me. During the last days of the caliphate of Umar a good deal of property came to him and took out our portion. I said to him: We are well to do this year; but the Muslims are needy, so return it to them. He, therefore, returned it to them. No one called me after Umar. I met al-Abbas when I came out from Umar. He said: Ali, today you have deprived us of a thing that will never be returned to us. He was indeed a man of wisdom.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2979]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2979

Narrated AbdulMuttalib ibn Rabi'ah ibn al-Harith:

AbdulMuttalib ibn Rabi'ah ibn al-Harith said that his father, Rabi'ah ibn al-Harith, and Abbas ibn al-Muttalib said to AbdulMuttalib ibn Rabi'ah and al-Fadl ibn Abbas: Go to the Apostle of Allah (peace_be_upon_him) and tell him: Apostle of Allah, we are now of age as you see, and we wish to marry. Apostle of Allah, you are the kindest of the people and the most skilled in matchmaking. Our fathers have nothing with which to pay our dower. So appoint us collector of sadaqah (zakat), Apostle of Allah, and we shall give you what the other collectors give you, and we shall have the benefit accruing from it. Ali came to us while we were in this condition.

He said: The Apostle of Allah (peace_be_upon_him) said: No, I swear by Allah, he will not appoint any of you collector of sadaqah (zakat).

Rabi'ah said to him: This is your condition; you have gained your relationship with the Apostle of Allah (peace_be_upon_him) by marriage, but we did not grudge you that. Ali then put his cloak on the earth and lay on it.

He then said: I am the father of Hasan, the chief. I swear by Allah, I shall not leave this place until your sons come with a reply (to the question) for which you have sent them to the Prophet (peace_be_upon_him).

AbdulMuttalib said: So I and al-Fadl went towards the door of the apartment of the Prophet (peace_be_upon_him). We found that the noon prayer in congregation had already started. So we prayed along with the people. I and al-Fadl then hastened towards the door of the apartment of the Prophet (peace_be_upon_him). He was (staying) with Zaynab, daughter of Jahsh, that day. We stood until the Apostle of Allah (peace_be_upon_him) came. He caught my ear and the ear of al-Fadl.

He then said: Reveal what you conceal in your hearts. He then entered and permitted me and al-Fadl (to enter). So we entered and for a little while we asked each other to talk. I then talked to him, or al-Fadl talked to him (the narrator, Abdullah was not sure).

He said: He spoke to him concerning the matter about which our fathers ordered us to ask him. The Apostle of Allah (peace_be_upon_him) remained silent for a moment and raised his eyes towards the ceiling of the room. He took so long that we thought he would not give any reply to us. Meanwhile we saw that Zaynab was signalling to us with her hand from behind the veil, asking us not to be in a hurry, and that the Apostle of Allah (peace_be_upon_him) was (thinking) about our matter.

The Apostle of Allah (peace_be_upon_him) then lowered his head and said to us: This sadaqah (zakat) is a dirt of the people. It is legal neither for Muhammad nor for the family of Muhammad. Call Nawfal ibn al-Harith to me. So Nawfal ibn al-Harith was called to him.

He said: Nawfal, marry AbdulMuttalib (to your daughter). So Nawfal married me (to his daughter).

The Prophet (peace_be_upon_him) then said: Call Mahmiyyah ibn Jaz'i to me. He was a man of Banu Zubayd, whom the Apostle of Allah (peace_be_upon_him) had appointed collector of the fifths.

The Apostle of Allah (peace_be_upon_him) said to Mahmiyyah: Marry al-Fadl (to your daughter). So he married him to her. The Apostle of Allah (peace_be_upon_him) said: Stand up and pay the dower from the fifth so-and-so on their behalf. Abdullah ibn al-Harith did not name it (i.e. the amount of the dower).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2984]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2984

Narrated Mujja'ah ibn Mirarah al-Yamani:

Mujja'ah went to the Prophet (peace_be_upon_him) asking him for the blood-money of his brother whom Banu Sadus from Banu Dhuhl had killed.

The Prophet (peace_be_upon_him) said: Had I appointed blood-money for a polytheist, I should have appointed it for your brother. But I shall give you compensation for him. So the Prophet (peace_be_upon_him) wrote (a document) for him that he should be given a hundred camels which were to be acquired from the fifth taken from the polytheists of Banu Dhuhl. So he took a part of them, for Banu Dhuhl embraced Islam.

He then asked AbuBakr for them later on, and brought to him the document of the Prophet (peace_be_upon_him). So AbuBakr wrote for him that he should be given one thousand two hundred sa's from the sadaqah of al-Yamamah; four thousand (sa's) of wheat, four thousand (sa's) of barley, and four thousand (sa's) of dates.

The text of the document written by the Prophet (peace_be_upon_him) for Mujja'ah was as follows: "In the name of Allah, the Beneficent, the Merciful. This document is from Muhammad, the Prophet, to Mujja'ah ibn Mirarah of Banu Sulma. I have given him one hundred camels from the first fifth acquired from the polytheist of Banu Dhuhl as a compensation for his brother."


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2993]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2993

Narrated Yazid ibn Abdullah:

We were at Mirbad. A man with dishevelled hair and holding a piece of red skin in his hand came.

We said: You appear to be a bedouin. He said: Yes. We said: Give us this piece of skin in your hand. He then gave it to us and we read it. It contained the text: "From Muhammad, Apostle of Allah (peace_be_upon_him), to Banu Zuhayr ibn Uqaysh. If you bear witness that there is no god but Allah, and that Muhammad is the Apostle of Allah, offer prayer, pay zakat, pay the fifth from the booty, and the portion of the Prophet (peace_be_upon_him) and his special portion (safi), you will be under by the protection of Allah and His Apostle."

We then asked: Who wrote this document for you? He replied: The Apostle of Allah (peace_be_upon_him).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2996]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2996

Narrated Muhayyisah:

The Apostle of Allah (peace_be_upon_him) said: If you gain a victory over the men of Jews, kill them. So Muhayyisah jumped over Shubaybah, a man of the Jewish merchants. He had close relations with them. He then killed him. At that time Huwayyisah (brother of Muhayyisah) had not embraced Islam. He was older than Muhayyisah. When he killed him, Huwayyisah beat him and said: O enemy of Allah, I swear by Allah, you have a good deal of fat in your belly from his property.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.2998]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 2998

Narrated A man from the companions of the Prophet:

AbdurRahman ibn Ka'b ibn Malik reported on the authority of a man from among the companions of the Prophet (peace_be_upon_him): The infidels of the Quraysh wrote (a letter) to Ibn Ubayy and to those who worshipped idols from al-Aws and al-Khazraj, while the Apostle of Allah (peace_be_upon_him) was at that time at Medina before the battle of Badr.

(They wrote): You gave protection to our companion. We swear by Allah, you should fight him or expel him, or we shall come to you in full force, until we kill your fighters and appropriate your women.

When this (news) reached Abdullah ibn Ubayy and those who were worshippers of idols, with him they gathered together to fight the Apostle of Allah (peace_be_upon_him).

When this news reached the Apostle of Allah (peace_be_upon_him), he visited them and said: The threat of the Quraysh to you has reached its end. They cannot contrive a plot against you, greater than what you yourselves intended to harm you. Are you willing to fight your sons and brethren? When they heard this from the Prophet (peace_be_upon_him), they scattered. This reached the infidels of the Quraysh.

The infidels of the Quraysh again wrote (a letter) to the Jews after the battle of Badr: You are men of weapons and fortresses. You should fight our companion or we shall deal with you in a certain way. And nothing will come between us and the anklets of your women. When their letter reached the Prophet (peace_be_upon_him), they gathered Banu an-Nadir to violate the treaty.

They sent a message to the Prophet (peace_be_upon_him): Come out to us with thirty men from your companions, and thirty rabbis will come out from us till we meet at a central place where they will hear you. If they testify to you and believe in you, we shall believe in you. The narrator then narrated the whole story.

When the next day came, the Apostle of Allah (peace_be_upon_him) went out in the morning with an army, and surrounded them.

He told them: I swear by Allah, you will have no peace from me until you conclude a treaty with me. But they refused to conclude a treaty with him. He therefore fought them the same day.

Next he attacked Banu Quraysh with an army in the morning, and left Banu an-Nadir. He asked them to sign a treaty and they signed it.

He turned away from them and attacked Banu an-Nadir with an army. He fought with them until they agreed to expulsion. Banu an-Nadir were deported, and they took with them whatever their camels could carry, that is, their property, the doors of their houses, and their wood. Palm-trees were exclusively reserved for the Apostle of Allah (peace_be_upon_him). Allah bestowed them upon him and gave them him as a special portion.

He (Allah), the Exalted, said: What Allah has bestowed on His Apostle (and taken away) from them, for this ye made no expedition with either camel corps or cavalry." He said: "Without fighting." So the Prophet (peace_be_upon_him) gave most of it to the emigrants and divided it among them; and he divided some of it between two men from the helpers, who were needy, and he did not divide it among any of the helpers except those two. The rest of it survived as the sadaqah of the Apostle of Allah (peace_be_upon_him) which is in the hands of the descendants of Fatimah (Allah be pleased with her).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3000]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3000

Narrated Abdullah Ibn Umar:

The Prophet fought with the people of Khaybar, and captured their palm-trees and land, and forced them to remain confined to their fortresses. So they concluded a treaty of peace providing that gold, silver and weapons would go to the Apostle of Allah (peace_be_upon_him), and whatever they took away on their camels would belong to them, on condition that they would not hide and carry away anything. If they did (so), there would be no protection for them and no treaty (with Muslims).

They carried away a purse of Huyayy ibn Akhtab who was killed before (the battle of) Khaybar. He took away the ornaments of Banu an-Nadir when they were expelled.

The Prophet (peace_be_upon_him) asked Sa'yah: Where is the purse of Huyayy ibn Akhtab?

He replied: The contents of this purse were spent on battles and other expenses. (Later on) they found the purse. So he killed Ibn AbulHuqayq, captured their women and children, and intended to deport them.

They said: Muhammad, leave us to work on this land; we shall have half (of the produce) as you wish, and you will have half. The Apostle of Allah (peace_be_upon_him) used to make a contribution of eighty wasqs of dates and twenty wasqs of wheat to each of his wives.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3001]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3001

Narrated Abdullah ibn Umar:

Umar said: The Apostle of Allah (peace_be_upon_him) had transaction with the Jews of Khaybar on condition that we should expel them when we wish. If anyone has property (with them), he should take it back, for I am going to expel the Jews. So he expelled them.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3006]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3006

Narrated A Group of Companions of the Prophet:

Bashir ibn Yasar, the client of the Ansar, reported on the authority of a group of the Companions of the Prophet (peace_be_upon_him): When the Apostle of Allah (peace_be_upon_him) conquered Khaybar, he divided it into thirty-six lots, each lot comprising one hundred portions. One half of it was for the Apostle of Allah (peace_be_upon_him) and for the Muslims; and he separated the remaining half for the deputations which came to him, other matters and emergent needs of the people.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3008]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3008

Narrated Bashir ibn Yasar:

When Allah bestowed Khaybar on the Apostle of Allah (peace_be_upon_him) as fay' (spoils of war without fighting), he divided the whole into thirty six lots. He put aside a half, i.e. eighteen lots, for the Muslims. Each lot comprised one hundred shares, and the Prophet (peace_be_upon_him) was with them. He received a share like the share of one of them.

The Apostle of Allah (peace_be_upon_him) separated eighteen lots, that is, half, for his future needs and whatever befell the Muslims. These were al-Watih, al-Kutaybah, as-Salalim and their colleagues. When all this property came in the possession of the Prophet (peace_be_upon_him) and of the Muslims, they did not have sufficient labourers to work on it. The Apostle of Allah (peace_be_upon_him) called Jews and employed them on contract.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3009]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3009

Narrated Mujammi' ibn Jariyah al-Ansari,:

Khaybar was divided among the people of al-Hudaybiyyah. The Apostle of Allah (peace_be_upon_him) divided it into eighteen portions. The army contained one thousand and five hundred people. There were three hundred horsemen among them. He gave double share to the horsemen, and a single to the footmen.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3010]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3010

Narrated Abdullah ibn AbuBakr:

Abdullah ibn AbuBakr and some children of Muhammad ibn Maslamah said: There remained some people of Khaybar and they confined themselves to the fortresses. They asked the Apostle of Allah (peace_be_upon_him) to protect their lives and let them go. He did so. The people of Fadak heard this; they also adopted a similar way. (Fadak) was, therefore, exclusively reserved for the Apostle of Allah (peace_be_upon_him), for it was not captured by the expedition of cavalry and camelry.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3013]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3013

Narrated Ibn Shihab:

The Apostle of Allah (peace_be_upon_him) took out his fifth from the booty of Khaybar, and divided the rest of it among those who attended the battle and among those who were away from it but attend the expedition of al-Hudaybiyyah.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3015]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3015

Narrated Abdullah ibn Abbas:

Al-Abbas ibn AbdulMuttalib brought AbuSufyan ibn Harb to the Apostle of Allah (peace_be_upon_him) in the year of the conquest (of Mecca). So he embraced Islam at Marr az-Zahran. Al-Abbas said to him: Apostle of Allah, AbuSufyan is a man who likes taking this pride, if you may do something for him. He said: Yes, he who enters the house of AbuSufyan is safe, and he who closes his door is safe.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3016]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3016

Narrated Abdullah Ibn Abbas:

When the Prophet (peace_be_upon_him) alighted at Marr az-Zahran, al-Abbas said: I thought, I swear by Allah, if the Apostle of Allah (peace_be_upon_him) enters Mecca with the army by force before the Quraysh come to him and seek protection from him, it will be their total ruin. So I rode on the mule of the Apostle of Allah (peace_be_upon_him) and thought, Perhaps I may find a man coming for his needs who will to the people of Mecca and inform them of the position of the Apostle of Allah (peace_be_upon_him), so that they may come to him and seek protection from him. While I was on my way, I heard AbuSufyan and Budayl ibn Warqa' speaking.

I said: O AbuHanzalah! He recognized my voice and said: AbulFadl? I replied: Yes. He said: who is with you, may my parents be a sacrifice for you? I said: Here are the Apostle of Allah (peace_be_upon_him) and his people (with him).

He asked: Which is the way out? He said: He rode behind me, and his companion returned. When the morning came, I brought him to the Apostle of Allah (peace_be_upon_him) and he embraced Islam.

I said: Apostle of Allah, AbuSufyan is a man who likes this pride, do something for him. He said: Yes, he who enters the house of AbuSufyan is safe; he who closes the door upon him is safe; and he who enters the mosque is safe. The people scattered to their houses and in the mosque.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3019]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3019

Narrated Jabir ibn Abdullah:

Wahb said: I asked Jabir about the condition of Thaqif when they took the oath of allegiance. He said: They stipulated to the Prophet (peace_be_upon_him) that there would be no sadaqah (i.e. zakat) on them nor Jihad (striving in the way of Allah). He then heard the Prophet (peace_be_upon_him) say: Later on they will give sadaqah (zakat) and will strive in the way of Allah when they embrace Islam.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3020]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3020

Narrated Uthman ibn Abul'As:

When the deputation of Thaqif came to the Apostle of Allah (peace_be_upon_him), he made them stay in the mosque, so that it might soften their hearts. They stipulated to him that they would not be called to participate in Jihad, to pay zakat and to offer prayer. The Apostle of Allah (peace_be_upon_him) said: You may have the concession that you will not be called to participate in jihad and pay zakat, but there is no good in a religion which has no bowing (i.e. prayer).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3021]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3021

Narrated Amir ibn Shahr:

When the Apostle of Allah (peace_be_upon_him) appeared as a prophet, Hamdan said to me: Will you go to this man and negotiate for us (with him)? If you accept something, we shall accept it, and if you disapprove of something, we shall disapprove of it.

I said: Yes. So I proceeded until I came to the Apostle of Allah (peace_be_upon_him). I liked his motive and my people embraced Islam. The Apostle of Allah (peace_be_upon_him) wrote the document for Umayr Dhu Marran. He also sent Malik ibn Murarah ar-Rahawi to all the (people of) Yemen. So Akk Dhu Khaywan embraced Islam.

Akk was told: Go to the Apostle of Allah (peace_be_upon_him), and obtain his protection for your town and property. He therefore came (to him) and the Apostle of Allah (peace_be_upon_him) wrote a document for him:

"In the name of Allah, Most Beneficent, Most Merciful. From Muhammad, the Apostle of Allah, to Akk Dhu Khaywan. If he is true his land, property and slave, he has the security and the protection of Allah, and Muhammad, the Apostle of Allah. Written by Khalid ibn Sa'id ibn al-'As."


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3022]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3022

Narrated Abyad ibn Hammal:

Abyad spoke to the Apostle of Allah (peace_be_upon_him) about sadaqah when he came along with a deputation to him.

He replied: O brother of Saba', sadaqah is unavoidable. He said: We cultivated cotton, Apostle of Allah. The people of Saba' scattered, and there remained only a few at Ma'arib.

He therefore concluded a treaty of peace with the Apostle of Allah (peace_be_upon_him) to give seventy suits of cloth, equivalent to the price of the Yemeni garments known as al-mu'afir, to be paid every year on behalf of those people of Saba' who remained at Ma'arib.

They continued to pay them till the Apostle of Allah (peace_be_upon_him) died.

The governors after the death of the Apostle of Allah (peace_be_upon_him) broke the treaty concluded by Abyad by Hammal with the Apostle of Allah (peace_be_upon_him) to give seventy suits of garments.

AbuBakr then revived it as the Apostle of Allah (peace_be_upon_him) had done till AbuBakr died. When AbuBakr died, it was discontinued and the sadaqah was levied.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3026]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3026

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Two qiblahs in one land are not right.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3031]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3031

Narrated Anas ibn Malik ; Uthman ibn AbuSulayman:

The Prophet (peace_be_upon_him) sent Khalid ibn al-Walid to Ukaydir of Dumah. He was seized and they brought him to him (i.e. the Prophet). He spared his life and made peace with him on condition that he should pay jizyah (poll-tax).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3032]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3032

Narrated Mu'adh ibn Jabal:

When the Prophet (peace_be_upon_him) sent him to the Yemen, he ordered to take from everyone who had reached puberty one dinar or its equivalent in Mu'afiri garment of Yemen origin.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3035]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3035

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) concluded peace with the people of Najran on condition that they would pay to Muslims two thousand suits of garments, half of Safar, and the rest in Rajab, and they would lend (Muslims) thirty coats of mail, thirty horses, thirty camels, and thirty weapons of each type used in battle. Muslims will stand surely for them until they return them in case there is any plot or treachery in the Yemen. No church of theirs will be demolished and no clergyman of theirs will be turned out. There will be no interruption in their religion until they bring something new or take usury. Isma'il said: They took usury.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3037]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3037

Narrated Umar ibn al-Khattab:

Amr ibn Aws and AbulSha'tha' reported that Bujalah said: I was secretary to Jaz' ibn Mu'awiyah, the uncle of Ahnaf ibn Qays.

A letter came to us from Umar one year before his death, saying: Kill every magician, separate the relatives of prohibited degrees from the Magians, and forbid them to murmur (before eating). So we killed three magicians in one day, and separated from a Magian husband his wife of a prohibited degree according to the Book of Allah.

He prepared abundant food and called them, and placed the sword on his thigh. They ate (the food) but did not murmur. They threw (on the ground) one or two mule-loads of silver. Umar did not take jizyah from Magians until AbdurRahman ibn Awf witnessed that the Apostle of Allah (peace_be_upon_him) had taken jizyah from the Magians of Hajar.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3038]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3038

Narrated Abdullah ibn Abbas:

A man belonging to Usbadhiyin of the people of Bahrayn, who were the Magians of Hajar, came to the Apostle of Allah (peace_be_upon_him) and remained with him (for some time), and then came out. I asked him: What have Allah and His Apostle of Allah decided for you? He replied: Evil. I said: Silent. He said: Islam or killing. AbdurRahman ibn Awf said: He accepted jizyah from them. Ibn Abbas said: The people followed the statement of AbdurRahman ibn Awf, and they left that which I heard from the Usbadhi.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3040]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3040

Narrated Ubaydullah:

Harb ibn Ubaydullah told on the authority of his grandfather, his mother's father, that he had it on the authority of his father that the Apostle of Allah (peace_be_upon_him) said: Tithes are to be levied on Jews and Christians, but not on Muslims.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3043]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3043

Narrated A man of Banu Taghlib:

Harb ibn Ubaydullah ibn Umayr ath-Thaqafi told on the authority of his grandfather, a man of Banu Taghlib: I came to the Prophet (peace_be_upon_him), embraced Islam, and he taught me Islam. He also taught me how I should take sadaqah from my people who had become Muslim. I then returned to him and said: Apostle of Allah, I remembered whatever you taught me except the sadaqah. Should I levy tithe on them? He replied: No, tithes are to be levied on Christians and Jews.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3044]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3044

Narrated Al-Irbad ibn Sariyah as-Sulami:

We alighted with the Prophet (peace_be_upon_him) at Khaybar, and he had his companions with him. The chief of Khaybar was a defiant and abominable man.

He came to the Prophet (peace_be_upon_him) and said: Is it proper for you, Muhammad, that you slaughter our donkeys, eat our fruit, and beat our women?

The Prophet (peace_be_upon_him) became angry and said: Ibn Awf, ride your horse, and call loudly: Beware, Paradise is lawful only for a believer, and that they (the people) should gather for prayer.

They gathered and the Prophet (peace_be_upon_him) led them in prayer, stood up and said: Does any of you, while reclining on his couch, imagine that Allah has prohibited only that which is to be found in this Qur'an? By Allah, I have preached, commanded and prohibited various matters as numerous as that which is found in the Qur'an, or more numerous. Allah has not permitted you to enter the houses of the people of the Book without permission, or beat their women, or eat their fruits when they give you that which is imposed on them.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3045]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3045

Narrated A man of Juhaynah:

The Prophet (peace_be_upon_him) said: Probably you will fight with a people, you will dominate them, and they will save themselves and their children by their property. The version of Sa'id has You will then conclude peace with them. The agreed version goes: Then do no take anything from them more than that, for it is not proper for you.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3046]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3046

Narrated A number of Companions of the Prophet:

Safwan reported from a number of Companions of the Apostle of Allah (peace_be_upon_him) on the authority of their fathers who were relatives of each other. The Apostle of Allah (peace_be_upon_him) said: Beware, if anyone wrongs a contracting man, or diminishes his right, or forces him to work beyond his capacity, or takes from him anything without his consent, I shall plead for him on the Day of Judgment.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3047]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3047

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Jizyah is not to be levied on a Muslim.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3049]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3049

Narrated Abdullah al-Hawzani:

I met Bilal, the Mu'adhdhin of the Apostle of Allah (peace_be_upon_him) at Aleppo, and said: Bilal, tell me, what was the financial position of the Apostle of Allah (peace_be_upon_him)?

He said: He had nothing. It was I who managed it on his behalf since the day Allah made him Prophet of Allah (peace_be_upon_him) until he died. When a Muslim man came to him and he found him naked, he ordered me (to clothe him). I would go, borrow (some money), and purchase a cloak for him. I would then clothe him and feed him.

A man from the polytheists met me and said: I am well off, Bilal. Do not borrow money from anyone except me. So I did accordingly. One day when I performed ablution and stood up to make call to prayer, the same polytheist came along with a body of merchants.

When he saw me, he said: O Abyssinian. I said: I am at your service. He met me with unpleasant looks and said harsh words to me. He asked me: Do you know how many days remain in the completion of this month? I replied: The time is near. He said: Only four days remain in the completion of this month. I shall then take that which is due from you (i.e. loan), and then shall return you to tend the sheep as you did before. I began to think in my mind what people think in their minds (on such occasions). When I offered the night prayer, the Apostle of Allah (peace_be_upon_him) returned to his family. I sought permission from him and he gave me permission.

I said: Apostle of Allah, may my parents be sacrificed for you, the polytheist from whom I used to borrow money said to me such-and-such. Neither you nor I have anything to pay him for me, and he will disgrace me. So give me permission to run away to some of those tribes who have recently embraced Islam until Allah gives His Apostle (peace_be_upon_him) something with which he can pay (the debt) for me. So I came out and reached my house. I placed my sword, waterskin (or sheath), shoes and shield near my head. When dawn broke, I intended to be on my way.

All of a sudden I saw a man running towards me and calling: Bilal, return to the Apostle of Allah (peace_be_upon_him). So I went till I reached him. I found four mounts kneeling on the ground with loads on them. I sought permission.

The Apostle of Allah (peace_be_upon_him) said to me: Be glad, Allah has made arrangements for the payment (of your debt). He then asked: Have you not seen the four mounts kneeling on the ground?

I replied: Yes. He said: You may have these mounts and what they have on them. There are clothes and food on them, presented to me by the ruler of Fadak. Take them away and pay off your debt. I did so.

He then mentioned the rest of the tradition. I then went to the mosque and found that the Apostle of Allah (peace_be_upon_him) was sitting there. I greeted him.

He asked: What benefit did you have from your property? I replied: Allah Most High paid everything which was due from the Apostle of Allah (peace_be_upon_him). Nothing remains now.

He asked: Did anything remain (from that property)? I said: Yes. He said: Look, if you can give me some comfort from it, for I shall not visit any member of my family until you give me some comfort from it. When the Apostle of Allah (peace_be_upon_him) offered the night prayer, he called me and said: What is the position of that which you had with you (i.e. property)?

I said: I still have it, no one came to me. The Apostle of Allah (peace_be_upon_him) passed the night in the mosque.

He then narrated the rest of the tradition. Next day when he offered the night prayer, he called me and asked: What is the position of that which you had (i.e. the rest of the property)?

I replied: Allah has given you comfort from it, Apostle of Allah. He said: Allah is Most Great, and praised Allah, fearing lest he should die while it was with him. I then followed him until he came to his wives and greeted each one of them and finally he came to his place where he had to pass the night. This is all for which you asked me.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3051]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3051

Narrated Iyad ibn Himar:

I presented a she-camel to the Prophet (peace_be_upon_him). He asked: Have you embraced Islam? I replied: No. The Prophet (peace_be_upon_him) said: I have been prohibited to accept the present of polytheists.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3052]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3052

Narrated Alqamah ibn Wa'il:

The Prophet (peace_be_upon_him) bestowed land in Hadramawt as fief.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3054]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3054

Narrated Amr ibn Hurayth:

The Apostle of Allah (peace_be_upon_him) demarcated a house with a bow at Medina for me. He said: I shall give you more. I shall give you more.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3055]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3055

Narrated Rabi'ah ibn AbuAbdurRahman:

Rabi'ah reported on the authority of more than one person saying: The Apostle of Allah (peace_be_upon_him) assigned as a fief to Bilal ibn al-Harith al-Muzani the mines of al-Qabaliyyah which is in the neighbourhood of al-Fur', and only zakat is levied on those mines up to the present day.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3056]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3056

Narrated Amr ibn Awf al-Muzani:

The Prophet (peace_be_upon_him) assigned as a fief to Bilal ibn al-Muzani the mines of al-Qabaliyyah both which lay on the upper side and which lay on the lower side, and (the land) which was suitable for cultivation at Quds. He did not give him (the land which involved) the right of a Muslim. The Prophet (peace_be_upon_him) wrote a document for him. It goes: "In the name of Allah, the Compassionate, the Merciful. This is what the Apostle of Allah (peace_be_upon_him) assigned to Bilal ibn Harith al-Muzani. He gave him the mines of al-Qabaliyyah, both which lay on the upper side and which lay on the lower side, and (the land) which is suitable for cultivation at Quds. He did not give him the right of any Muslim."


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3057]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3057

Narrated Amr ibn Awf al-Muzani:

The Prophet (peace_be_upon_him) assigned as a fief to Bilal ibn Harith al-Muzani the mines of al-Qabaliyyah, both those which lay on the upper side those and which lay on the lower side. The narrator, Ibn an-Nadr, added: "also Jars and Dhat an-Nusub." The agreed version reads: "and (the land) which is suitable for cultivation at Quds". He did not assign to Bilal ibn al-Harith the right of any Muslim. The Prophet (peace_be_upon_him) wrote a document to him:

"This is what the Apostle of Allah (peace_be_upon_him) assigned to Bilal ibn al-Harith al-Muzani. He gave him the mines of al-Qabaliyyah both those which lay on the upper and lower side, and that which is fit for cultivation at Quds. He did not give him the right of any Muslim."

The narrator AbuUways said: A similar tradition has been transmitted to me by Thawr ibn Zayd from Ikrimah on the authority of Ibn Abbas from the Prophet (peace_be_upon_him). Ibn an-Nadr added: Ubayy ibn Ka'b wrote it.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3058]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3058

Narrated Abyad ibn Hammal:

Abyad went to the Apostle of Allah (peace_be_upon_him) and asked him for assigning him (the mines of) salt as fief. (The narrator Ibn al-Mutawakkil said: which was in Ma'arib.)

So he assigned it to him as a fief. When he returned, a man in the meeting asked: Do you know what you have assigned him as a fief? You have assigned him the perennial spring water. So he took it back from him. He asked him about protecting land which had arak trees growing in it. He replied: He could have such as was beyond the region where the hoofs (of camels) went.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3060]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3060

Narrated Abyad ibn Hammal:

He asked the Apostle of Allah (peace_be_upon_him) for giving him some land which had arak trees growing in it. The Apostle of Allah (peace_be_upon_him) said: There is no (permission for) protecting a land which has arak trees growing in it. He said: These arak trees are within the boundaries of my field. The Prophet (peace_be_upon_him) said: There is no (permission for) protecting a land which has arak trees growing in it.

The narrator Faraj said: By the phrase 'within the boundaries of my field' he meant the land which had crop growing in it and was surrounded on four sides.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3061]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3061

Narrated Sakhr ibn al-Ayla al-Ahmasi:

The Apostle of Allah (peace_be_upon_him) raided Thaqif. When Sakhr heard this, he proceeded on his horse along with some horsemen to support the Prophet (peace_be_upon_him). He found the Prophet of Allah (peace_be_upon_him) had returned and he did not conquer (Ta'if).

On that day Sakhr made a covenant with Allah and had His protection that he would not depart from that fortress until they (the inhabitants) surrendered to the command of the Apostle of Allah (peace_be_upon_him). He did not leave them until they had surrendered to the command of the Apostle of Allah (peace_be_upon_him).

Sakhr then wrote to him: To proceed: Thaqif have surrendered to your command, Apostle of Allah, and I am on my way to them. They have horses with them.

The Apostle of Allah (peace_be_upon_him) then ordered prayers to be offered in congregation. He then prayed for Ahmas ten times: O Allah, send blessings the horses and the men of Ahmas.

The people came and Mughirah ibn Shu'bah said to him: Prophet of Allah, Sakhr took my paternal aunt while she embraced Islam like other Muslims.

He called him and said: Sakhr, when people embrace Islam, they have security of their blood and property. Give back to Mughirah his paternal aunt.

So he returned his aunt to him and asked the Prophet of Allah (peace_be_upon_him): What about Banu Sulaym who have run away for (fear of) Islam and left that water? He said: Prophet of Allah, allow me and my people to settle there.

He said: Yes. So he allowed him to settle there. Banu Sulaym then embraced Islam, and they came to Sakhr. They asked him to return their water to them. But he refused.

So they came to the Prophet (peace_be_upon_him) and said: Prophet of Allah, we embraced Islam and came to Sakhr so that he might return our water to us. But he has refused.

He (the Prophet) then came to him and said: When people embrace Islam, they secure their properties and blood. Return to the people their water.

He said: Yes, Prophet of Allah. I saw that the face of the Apostle of Allah (peace_be_upon_him) was reddening at that moment, being ashamed of taking back from him the slave-girl and the water.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3062]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3062

Narrated Saburah ibn Ma'bad al-Juhani:

The Prophet (peace_be_upon_him) alighted at a place where a mosque has been built under a large tree. He tarried there for three days, and then proceeded to Tabuk. Juhaynah met him on a wide plain. He asked them: who are the people of Dhul-Marwah? They replied: Banu Rifa'ah of Juhaynah. He said: I have given this (land) to Banu Rifa'ah as a fief. Therefore, they divided it. Some of them sold (their share) and others retained and worked on it.

(Sub-narrator Ibn Wahab said: I then asked AbdulAziz about this tradition. He narrated a part of it to me and did not narrate it in full.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3063]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3063

Narrated Asma' daughter of AbuBakr:

The Apostle of Allah (peace_be_upon_him) assigned to az-Zubayr palm-trees as a fief.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3064]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3064

Narrated Qaylah bint Makhramah:

Abdullah ibn Hasan al-Anbari said: My grandmothers, Safiyyah and Duhaybah, narrated to me, that hey were the daughters of Ulaybah and were nourished by Qaylah, daughter of Makhramah. She was the grandmother of their father.

She reported to them, saying: We came upon the Apostle of Allah (peace_be_upon_him). My companion, Hurayth ibn Hassan, came to him as a delegate from Bakr ibn Wa'il. He took the oath of allegiance of Islam for himself and for his people.

He then said: Apostle of Allah (peace_be_upon_him), write a document for us, giving us the land lying between us and Banu Tamim at ad-Dahna' to the effect that not one of them will cross it in our direction except a traveller or a passer-by.

He said: Write down ad-Dahna' for them, boy. When I saw that he passed orders to give it to him, I became anxious, for it was my native land and my home.

I said: Apostle of Allah, he did not ask you for a true border when he asked you. This land of Dahna' is a place where the camels have their home, and it is a pasture for the sheep. The women of Banu Tamim and their children are beyond it.

He said: Stop, boy! A poor woman spoke the truth: a Muslim is a brother of a Muslim. Each one of them may benefit from water and trees, and they should cooperate with each other against Satan.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3065]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3065

Narrated Asmar ibn Mudarris:

I came to the Prophet (peace_be_upon_him), and took the oath of allegiance to him. He said: If anyone reaches a water which has not been approached before by any Muslim, it belongs to him. The people, therefore, went out running and marking (on the land).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3066]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3066

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) gave az-Zubayr the land as a fief up to the reach of his horse when he runs. He, therefore, made his horse run until it stopped. He then threw his flog. Thereupon he said: Give him (the land) up to the point where his flog has reached.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3067]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3067

Narrated Sa'id ibn Zayd:

The Prophet (peace_be_upon_him) said: If anyone brings barren land into cultivation, it belongs to him, and the unjust vein has no right.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3068]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3068

Narrated Urwah:

The Prophet (peace_be_upon_him) said: If anyone brings barren land into cultivation, it belong to him. He then transmitted a similar tradition mentioned above (No. 3067).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3070]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3070

Narrated Urwah:

I testify that the Apostle of Allah (peace_be_upon_him) decided that the land is the land of Allah, and the servants are the servants of Allah. If anyone brings barren land into cultivation, he has more right to it.

This tradition has been transmitted to us from the Prophet (peace_be_upon_him) by those who transmitted the traditions about prayer from him.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3071]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3071

Narrated Samurah:

The Prophet (peace_be_upon_him) said: If anyone surrounds a land with a wall, it belongs to him.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3074]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3074

Narrated Zaynab:

She was picking lice from the head of the Apostle of Allah (peace_be_upon_him) while the wife of Uthman ibn Affan and the immigrant women were with him. They complained about their houses that they had been narrowed down to them and they were evicted from them. The Apostle of Allah (peace_be_upon_him) ordered that the houses of the Immigrants should be given to their wives. Thereafter Abdullah ibn Mas'ud died, and his wife inherited his house in Medina.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3075]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3075

Narrated Mu'adh ibn Jabal:

He who put the necklace of jizyah in his neck abandoned the way followed by the Apostle of Allah (peace_be_upon_him).


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3076]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3076

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: If anyone takes land by (paying) its jizyah, he renounces his immigration; and if anyone takes off the disgrace of an unbeliever from his neck he turns away his back from Islam. He (the narrator) said: Thereafter Khalid ibn Ma'dan heard this tradition from me, and he said: Has Shubayb narrated it to you? I said: Yes. He said! When you come to him, ask him to write this tradition to me. He said: He then wrote it for him. When I came, Khalid ibn Ma'dan asked me for the paper and I gave it to him. When he read (the paper), he abandoned the lands he had in his possession the moment he heard this.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3078]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3078

Narrated As-Sa'b ibn Jaththamah:

The Prophet (peace_be_upon_him) protected Naqi and said: There is no (permission for) protected land except for Allah Most High.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3079]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3079

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A fifth is payable on buried treasure.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3081]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3081

Narrated Duba'ah daughter of az-Zubayr ibn AbdulMuttalib:

Al-Miqdad went to Baqi' al-Khabkhabah for a certain need. He found a mouse taking out a dinar from a hole. It then continued to take out dinars one by one until it took out seventeen dinars. It then took out a red purse containing a dinar. There were thus eighteen dinars. He took them to the Prophet (peace_be_upon_him), informed him and said to him: Take its sadaqah. The Prophet (peace_be_upon_him) asked him: Did you extend your hand toward the hole? He replied: No. The Apostle of Allah (peace_be_upon_him) then said: May Allah bless you in it.


Dawud :: Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah) :: [19.3082]

Tribute, Spoils, and Rulership (Kitab Al-Kharaj, Wal-Fai' Wal-Imarah)

Dawud :: Book 19 : Hadith 3082

Narrated Abdullah ibn Amr ibn al-'As:

When we went out along with the Apostle of Allah (peace_be_upon_him) to at-Ta'if we passed a grave. I heard the Apostle of Allah (peace_be_upon_him) say: This is the grave of AbuRighal. He was in this sacred mosque (sanctuary) protecting himself (from punishment). When he came out, he suffered the same punishment which his people suffered at this place, and he was buried in it. The sign of it is that a golden bough was buried with him. If you dig it out, you will find it with him. The people hastened to it and took out the bough.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3083]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3083

Narrated Amir ar-Ram:

We were in our country when flags and banners were raised. I said: What is this?

The (the people) said: This is the banner of the Apostle of Allah (peace_be_upon_him). So I came to him. He was (sitting) under a tree. A sheet of cloth was spread for him and he was sitting on it. His Companions were gathered around him. I sat with them.

The Apostle of Allah (peace_be_upon_him) mentioned illness and said: When a believer is afflicted by illness and Allah cures him of it, it serves as an atonement for his previous sins and a warning to him for the future.

But when a hypocrite becomes ill and is then cured, he is like a camel which has been tethered and then let loose by its owners, but does not know why they tethered it and why they let it loose.

A man from among those around him asked: Apostle of Allah, what are illnesses? I swear by Allah, I never fell ill.

The Apostle of Allah (peace_be_upon_him) said: Get up and leave us. You do not belong to our number. When we were with him, a man came to him. He had a sheet of cloth and something in his hand.

He turned his attention to him and said: Apostle of Allah, when I saw you, I turned towards you. I saw a group of trees and heard the sound of fledglings. I took them and put them in my garment. Their mother then came and began to hover round my head. I showed them to her, and she fell on them. I wrapped them with my garment. They are now with me.

He said: Put them away from you. So I put them away, but their mother stayed with them.

The Apostle of Allah (peace_be_upon_him) said to his companions: Are you surprised at the affection of the mother for her young?

They said: Yes, Apostle of Allah. He said: I swear by Him Who has sent me with the Truth, Allah is more affectionate to His servants than a mother to her young ones. Take them back put them and where you took them from when their mother should have been with them. So he took them back.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3084]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3084

Narrated Muhammad ibn Khalid as-Sulami:

As-Sulami's grandfather, who was a Companion of the Apostle of Allah (peace_be_upon_him) said: I heard the Apostle of Allah (peace_be_upon_him) say: When Allah has previously decreed for a servant a rank which he has not attained by his action, He afflicts him in his body, or his property or his children.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3086]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3086

Narrated Umm al-Ala:

The Apostle of Allah (peace_be_upon_him) visited me while I was sick. He said: Be glad, Umm al-Ala' for Allah removes the sins of a Muslim for his illness as fire removes the dross of gold and silver.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3091]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3091

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: If anyone performs ablution well and pays a sick-visit to his brother Muslim seeking his reward from Allah, he will be removed a distance of sixty years (kharif) from Hell. I asked: What is kharif, AbuHamzah? He replied: A year.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3096]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3096

Narrated Zayd ibn Arqam:

The Apostle of Allah (peace_be_upon_him) visited me while I was suffering from pain in my eyes.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3100]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3100

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone visits a sick whose time (of death) has not come, and says with him seven times: I ask Allah, the Mighty, the Lord of the mighty Throne, to cure you, Allah will cure him from that disease.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3101]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3101

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: When a man comes to visit a sick person, he should say: O Allah, cure Thy servant, who may then wreak havoc on an enemy for Thy sake, or walk at a funeral for Thy sake.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3104]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3104

Narrated Ubayd ibn Khalid as-Sulami,:

A man from the Companions of the Prophet (peace_be_upon_him), said: The narrator Sa'd ibn Ubaydah narrated sometimes from the Prophet (peace_be_upon_him) and sometimes as a statement of Ubayd (ibn Khalid): The Prophet (peace_be_upon_him) said: Sudden death is a wrathful catching.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3105]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3105

Narrated Jabir ibn Atik:

The Apostle of Allah (peace_be_upon_him) came to visit Abdullah ibn Thabit who was ill. He found that he was dominated (by the divine decree). The Apostle of Allah (peace_be_upon_him) called him loudly, but he did not respond.

He uttered the Qur'anic verse "We belong to Allah and to Him do we return" and he said: We have been dominated against you, AburRabi'. Then the women cried and wept, and Ibn Atik began to silence them. The Apostle of Allah (peace_be_upon_him) said: Leave them, when the divine decree is made, no woman should weep.

They (the people) asked: What is necessary happening, Apostle of Allah? He replied: Death. His daughter said: I hope you will be a martyr, for you have completed your preparations for jihad. The Apostle of Allah (peace_be_upon_him) said: Allah Most High gave him a reward according to his intentions. What do you consider martyrdom?

They said: Being killed in the cause of Allah.

The Apostle of Allah (peace_be_upon_him) said: There are seven types of martyrdom in addition to being killed in Allah's cause: one who dies of plague is a martyr; one who is drowned is a martyr; one who dies of pleurisy is a martyr; one who dies of an internal complaint is a martyr; one who is burnt to death is a martyr; who one is killed by a building falling on him is a martyr; and a woman who dies while pregnant is a martyr.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3108]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3108

Narrated AbuSa'id al-Khudri:

When the time of his death came, he called for new clothes and put on them. He then said: I heard the Apostle of Allah (peace_be_upon_him) say: A deceased will be raised in the clothes in which he died.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3115]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3115

Narrated Ma'qil ibn Yasar:

The Prophet (peace_be_upon_him) said: Recite Surah Ya-Sin over your dying men. This is the version of Ibn al-Ala'


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3117]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3117

Narrated Abdullah ibn Amr ibn al-'As:

We buried a deceased person in the company of the Apostle of Allah (peace_be_upon_him). When we had finished, the Apostle of Allah (peace_be_upon_him) returned and we also returned with him. When he approached his door, he stopped, and we saw a woman coming towards him.

He (the narrator) said: I think he recognized her. When she went away, we came to know that she was Fatimah.

The Apostle of Allah (peace_be_upon_him) said to her: What brought you out of your house, Fatimah?

She replied: I came to the people of this house, Apostle of Allah, and I showed pity and expressed my condolences to them for their deceased relation.

The Apostle of Allah (peace_be_upon_him) said: You might have gone to the graveyard with them.

She replied: I seek refuge in Allah! I heard you referring to what you mentioned.

He said: If you had gone to the graveyard...He then mentioned severe words about it.

I then asked Rabi'ah (a narrator of this tradition) about al-kuda (stony land). He replied: I think it means the graves.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3122]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3122

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) cursed the wailing woman and the woman who listens to her.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3124]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3124

Narrated AbuMusa:

Yazid ibn Aws said: I entered upon AbuMusa while he was at the point of death. His wife began to weep or was going to weep. AbuMusa said to her: Did you not hear what the Apostle of Allah (peace_be_upon_him) said? She said: Yes. The narrator said: She then kept silence. When AbuMusa died, Yazid said: I met the woman and asked her: What did AbuMusa mean when he said to you: Did you not hear what the Apostle of Allah (peace_be_upon_him) and the you kept silence? She replied: The Apostle of Allah (peace_be_upon_him) said: He who shaves (his head), shouts and tears his clothing does not belong to us.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3125]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3125

Narrated A woman who took oath of allegiance:

Usayd ibn AbuUsayd, reported on the authority of a woman who took oath of allegiance (to the Prophet): One of the oaths which the Apostle of Allah (peace_be_upon_him) received from us about the virtue was that we would not disobey him in it (virtue): that we would not scratch the face, nor wail, nor tear the front of the garments nor dishevel the hair.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3126]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3126

Narrated Abdullah ibn Ja'far:

The Apostle of Allah (peace_be_upon_him) said: Prepare food for the family of Ja'far for there came upon them an incident which has engaged them.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3127]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3127

Narrated Jabir ibn Abdullah:

A man had a shot of arrow in his chest or throat (the narrator is doubtful). So he died. He was shrouded in his clothes as he was. The narrator said: We were with the Apostle of Allah (peace_be_upon_him).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3128]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3128

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) commanded to remove weapons and skins from the martyrs of Uhud, and that they should be buried with their blood and clothes.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3129]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3129

Narrated Anas ibn Malik:

The martyrs of Uhud were not washed, and they were buried with their blood. No prayer was offered over them.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3130]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3130

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) passed Hamzah who was killed and disfigured. He said: If Safiyyah were not grieved, I would have left him until the birds and beasts of prey would have eaten him, and he would have been resurrected from their bellies. The garments were scanty and the slain were in great number. So one, two and three persons were shrouded in one garment. The narrator Qutaybah added: They were then buried in one grave. The Apostle of Allah (peace_be_upon_him) asked: Which of the two learnt the Qur'an more? He then advanced him toward the qiblah (direction of prayer).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3131]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3131

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) passed by Hamzah who was disfigured (after being killed). He did not offer prayer over any martyr except him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3134]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3134

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: Do not unveil your thigh, and do not look at the thigh of the living and the dead.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3135]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3135

Narrated Aisha, Ummul Mu'minin:

By Allah, we did not know whether we should take off the clothes of the Apostle of Allah (peace_be_upon_him) as we took off the clothes of our dead, or wash him while his clothes were on him. When they (the people) differed among themselves, Allah cast slumber over them until every one of them had put his chin on his chest.

Then a speaker spoke from a side of the house, and they did not know who he was: Wash the Prophet (peace_be_upon_him) while his clothes are on him. So they stood round the Prophet (peace_be_upon_him) and washed him while he had his shirt on him. They poured water on his shirt, and rubbed him with his shirt and not with their hands. Aisha used to say: If I had known beforehand about my affair what I found out later, none would have washed him except his wives.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3144]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3144

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: When one of you dies, and he possesses something, he should be shrouded in the garment of the Yemeni stuff.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3145]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3145

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) was shrouded in three garments of white Yemeni stuff, among which was neither a shirt nor a turban.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3146]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3146

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) was shrouded in three garments of cotton.

The narrator said: Aisha was told that the people said that he was shrouded in two garments and one cloak. She replied: A cloak was brought but they returned it and did not shroud him in it.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3147]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3147

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) was shrouded in three garments made in Najran: two garments and one shirt in which he died.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3148]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3148

Narrated Ali ibn AbuTalib:

Do not be extravagant in shrouding, for I heard the Apostle of Allah (peace_be_upon_him) say: Do not be extravagant in shrouding, for it will be quickly decayed.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3150]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3150

Narrated Ubadah ibn as-Samit:

The Prophet (peace_be_upon_him) said: The best shroud is a lower garment and one which covers the whole body, and the best sacrifice is a horned ram.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3151]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3151

Narrated Layla daughter of Qa'if ath-Thaqafiyyah:

I was one of those who washed Umm Kulthum, daughter of the Prophet (peace_be_upon_him), when she died. The Apostle of Allah (peace_be_upon_him) first gave us lower garment, then shirt, then head-wear, then cloak (which covers the whole body), and then she was shrouded in another garment. She said: The Apostle of Allah (peace_be_upon_him) was sitting at the door, and he had shroud with him. He gave us the garments one by one.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3153]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3153

Narrated Al-Husayn ibn Wahwah:

Talhah ibn al-Bara' fell ill and the Prophet (peace_be_upon_him) came to pay him a sick-visit. He said: I think Talhah has died; so tell me (about his death), and make haste, for it is not advisable that the corpse of a Muslim should remain withheld among his family.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3154]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3154

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used to take a bath on account of sexual defilement, on Friday, for cupping and washing the dead.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3155]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3155

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: He who washes the dead should take a bath, and he who carries him should perform ablution.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3157]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3157

Narrated Aisha, Ummul Mu'minin:

I saw the Apostle of Allah (peace_be_upon_him) that he kissed Uthman ibn Maz'un while he was dead, and I saw that tears were flowing (from his eyes).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3158]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3158

Narrated Jabir ibn Abdullah:

The people saw fire (light) in the graveyard and they went there. They found that the Apostle of Allah (peace_be_upon_him) was in a grave and he was saying: Give me your companion. This was a man who used to raise his voice while mentioning the name of Allah.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3159]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3159

Narrated Jabir ibn Abdullah:

On the day of Uhud we brought the martyrs to bury them (at another place), but the crier of the Prophet (peace_be_upon_him) came and said: The Apostle of Allah (peace_be_upon_him) has commanded you to bury the martyrs at the place where they fell. So we took them back.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3160]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3160

Narrated Malik ibn Hubayrah:

The Prophet (peace_be_upon_him) said: If any Muslim dies and three rows of Muslims pray over him, it will assure him (of Paradise). When Malik considered those who accompanied a bier to be a few, he divided them into three rows in accordance with this tradition.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3165]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3165

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A bier should not be followed by a loud voice (of wailing) or fire.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3170]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3170

Narrated Ubadah ibn as-Samit:

The Apostle of Allah (peace_be_upon_him) used to stand up for a funeral until the corpse was placed in the grave. A learned Jew (once) passed him and said: This is how we do. The Prophet (peace_be_upon_him) sat down and said: Sit down and act differently from them.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3171]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3171

Narrated Thawban:

An animal was brought to the Apostle of Allah (peace_be_upon_him) while he was going with a funeral. He refused to ride on it. When the funeral was away, the animal was brought to him and he rode on it. He was asked about it. He said: The angels were on their feet. I was not to ride while they were walking. When they went away, I rode.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3173]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3173

Narrated Abdullah ibn Umar:

I saw the Prophet (peace_be_upon_him) and AbuBakr and Umar walking before the funeral.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3174]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3174

Narrated Al-Mughirah ibn Shu'bah:

(I think that the people of Ziyad informed me that he reported on the authority of the Prophet (peace_be_upon_him): A rider should go behind the bier, and those on foot should walk behind it, in front of it, on its right and on its left keeping near it. Prayer should be offered over an abortion and forgiveness and mercy supplicated for its parents.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3176]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3176

Narrated AbuBakrah:

Uyaynah ibn AbdurRahman reported on the authority of his father that he attended the funeral of Uthman ibn Abul'As. He said: We were walking slowly. AbuBakrah then joined us and he raised his flog at us and said: You have seen us when we were with the Apostle of Allah (peace_be_upon_him). We were walking quickly.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3177]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3177

Narrated AbuBakrah:

Uyaynah also reported the aforementioned tradition (No. 3176) through a different chain of transmitters. This version goes: We attended the funeral of AbdurRahman ibn Samurah and he said: He (AbuBakrah) made his mule run quickly and pointed with the flog.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3178]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3178

Narrated Abdullah ibn Mas'ud:

We asked the Prophet (peace_be_upon_him) about walking with the funeral. He replied: Not running (but walking quickly). If he (the dead person) was good, send him to it quickly; if he was otherwise, keep away the people of Hell. The bier should be followed and should not follow. Those who go in front of it are not accompanying it.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3179]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3179

Narrated Jabir ibn Samurah:

A man fell ill and a cry was raised (for his death). So his neighbour came to the Apostle of Allah (peace_be_upon_him) and said to him: He has died. He asked: Who told you? He said: I have seen him. The Apostle of Allah (peace_be_upon_him) said: He has not died. He then returned.

A cry was again raised (for his death). He came to the Apostle of Allah (peace_be_upon_him) and said: He has died. The Prophet (peace_be_upon_him) said: He has not died. He then returned.

A cry was again raised over him. His wife said: Go to the Apostle of Allah (peace_be_upon_him) and inform him. The man said: O Allah, curse him.

He said: The man then went and saw that he had killed himself with an arrowhead. So he went to the Prophet (peace_be_upon_him) and informed him that he had died.

He asked: Who told you? He replied: I myself saw that he had killed himself with arrowheads. He asked: Have you seen him? He replied: Yes. He then said: Then I shall not pray over him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3180]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3180

Narrated AbuBarzah al-Aslami:

The Apostle of Allah (peace_be_upon_him) did not pray over Ma'iz ibn Malik, and he did not prohibit to pray over him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3181]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3181

Narrated Aisha, Ummul Mu'minin:

Ibrahim, the son of the Prophet (peace_be_upon_him), died when he was eighteen months old. The Apostle of Allah (peace_be_upon_him) did not pray over him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3182]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3182

Narrated Ata':

AbuDawud said: I recited to Sa'id ibn Ya'qub at-Taliqani saying: Ibn al-Mubarak transmitted to you from Ya'qub ibn al-Qa'qa' on the authority of Ata' that the Prophet (peace_be_upon_him) prayed over his son Ibrahim when he was seventy days old.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3185]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3185

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone prays over the dead in the mosque, there is nothing on him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3187]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3187

Narrated Abdullah Ibn Abbas; AbuSa'id al-Khudri; AbuQatadah; AbuHurayrah:

Yahya ibn Subayh said: Ammar client of al-Harith ibn Nawfal told me that he attended the funeral of Umm Kulthum, and her son. The body of the boy was placed near the imam. I objected to it. Among the people there were Ibn Abbas, AbuSa'id al-Khudri, AbuQatadah and AbuHurayrah. They said: This is the sunnah (established practice of the Prophet).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3188]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3188

Narrated Anas ibn Malik:

Nafi' AbuGhalib said: I was in the Sikkat al-Mirbad. A bier passed and a large number of people were accompanying it.

They said: Bier of Abdullah ibn Umayr. So I followed it. Suddenly I saw a man, who had a thin garment on riding his small mule. He had a piece of cloth on his head to protect himself from the sun. I asked: Who is this important man? People said: This is Anas ibn Malik.

When the bier was placed, Anas stood and led the funeral prayer over him while I was just behind him, and there was no obstruction between me and him. He stood near his head, and uttered four takbirs (Allah is Most Great). He neither lengthened the prayer nor hurried it. He then went to sit down. They said: AbuHamzah, (here is the bier of) an Ansari woman. They brought her near him and there was a green cupola-shaped structure over her bier. He stood opposite her hips and led the funeral prayer over her as he had led it over the man. He then sat down.

Al-Ala' ibn Ziyad asked: AbuHamzah, did the Apostle of Allah (peace_be_upon_him) say the funeral prayer over the dead as you have done, uttering four takbirs (Allah is Most Great) over her, and standing opposite the head of a man and the hips of a woman?

He replied: Yes. He asked: AbuHamzah, did you fight with the Apostle of Allah? He replied: Yes. I fought with him in the battle of Hunayn. The polytheists came out and invaded us so severely that we saw our horses behind our backs. Among the people (i.e. the unbelievers) there was a man who was attacking us, and striking and wounding us (with his sword). Allah then defeated them. They were then brought and began to take the oath of allegiance to him for Islam.

A man from among the companions of the Prophet (peace_be_upon_him) said: I make a vow to myself that if Allah brings the man who was striking us (with his sword) that day, I shall behead him. The Apostle of Allah (peace_be_upon_him) kept silent and the man was brought (as a captive).

When he saw the Apostle of Allah (peace_be_upon_him), he said: Apostle of Allah, I have repented to Allah. The Apostle of Allah (peace_be_upon_him) stopped (for a while) receiving his oath of allegiance, so that the other man might fulfil his vow. But the man began to wait for the order of the Apostle of Allah (peace_be_upon_him) for his murder. He was afraid of the Apostle of Allah (peace_be_upon_him) to kill him. When the Apostle of Allah (peace_be_upon_him) saw that he did not do anything, he received his oath of allegiance. The man said: Apostle of Allah, what about my vow? He said: I stopped (receiving his oath of allegiance) today so that you might fulfil your vow. He said: Apostle of Allah, why did you not give any signal to me? The Prophet (peace_be_upon_him) said: It is not worthy of a Prophet to give a signal.

AbuGhalib said: I asked (the people) about Anas standing opposite the hips of a woman. They told me that this practice was due to the fact that (in the days of the Prophet) there were no cupola-shaped structures over the biers of women. So the imam used to stand opposite the hips of a woman to hide her from the people.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3193]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3193

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When you pray over the dead, make a sincere supplication for him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3194]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3194

Narrated AbuHurayrah:

Ali ibn Shammakh said: I was present with Marwan who asked AbuHurayrah: Did you hear how the Apostle of Allah (peace_be_upon_him) used to pray over the dead? He said: Even with the words that you said. (The narrator said: They exchanged hot words between them before that.)

AbuHurayrah said: O Allah, Thou art its Lord. Thou didst create it, Thou didst guide it to Islam, Thou hast taken its spirit, and Thou knowest best its inner nature and outer aspect. We have come as intercessors, so forgive him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3195]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3195

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) prayed over a dead person, he said: O Allah, forgive those of us who are living and those of us who are dead, those of us who are present and those of us who are absent, our young and our old, our male and our female. O Allah, to whomsoever of us Thou givest life grant him life as a believer, and whomsoever of us Thou takest in death take him in death as a follower of Islam. O Allah, do not withhold from us the reward (of faith) and do not lead us astray after his death.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3196]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3196

Narrated Wathilah ibn al-Asqa':

The Apostle of Allah (peace_be_upon_him) led us in prayer over bier of a Muslim and I heard him say: O Allah, so and so, son of so and so, is in Thy protection, so guard him from the trial in the grave. (AbdurRahman in his version said: "In Thy protection and in Thy nearer presence, so guard him from the trial in the grave) and the punishment in Hell. Thou art faithful and worthy of praise. O Allah, forgive him and show him mercy. Thou art the forgiving and the merciful one." AbdurRahman said: "On the authority of Marwan ibn Janah."


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3200]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3200

Narrated Al-Muttalib:

When Uthman ibn Maz'un died, he was brought out on his bier and buried. The Prophet (peace_be_upon_him) ordered a man to bring him a stone, but he was unable to carry it. The Apostle of Allah (peace_be_upon_him) got up and going over to it rolled up his sleeves.

The narrator Kathir told that al-Muttalib remarked: The one who told me about the Apostle of Allah (peace_be_upon_him) said: I still seem to see the whiteness of the forearms of the Apostle of Allah (peace_be_upon_him) when he rolled up his sleeves. He then carried it and placed it at his head saying: I am marking my brother's grave with it, and I shall bury beside him those of my family who die.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3201]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3201

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Breaking a dead man's bone is like breaking it when he is alive.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3202]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3202

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The niche in the side of the grave is for us and the excavation in the middle is for others.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3203]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3203

Narrated Amir:

Ali, Fadl and Usamah ibn Zayd washed the Apostle of Allah (peace_be_upon_him) and they put him in his grave. Marhab or Ibn AbuMarhab told me that they also made AbdurRahman ibn Awf join them.

When Ali became free, he said: The People of the man serve him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3205]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3205

Narrated Abdullah ibn Yazid:

AbuIshaq said: Al-Harith left his will that Abdullah ibn Yazid should offer his funeral prayer; so he prayed over him. He then put him in the grave from the side of his legs and said: This is a Sunnah (model practice of the Prophet).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3206]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3206

Narrated Al-Bara' ibn Azib:

We went out with the Apostle of Allah (peace_be_upon_him) to the funeral of a man of the Ansar, but when we reached the grave, the niche in the side had not yet been made, so the Prophet (peace_be_upon_him) sat down facing the qiblah, and we sat down along with him.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3207]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3207

Narrated Abdullah ibn Umar:

When the Prophet (peace_be_upon_him) placed the dead in the grave, he said: In the name of Allah, and following the Sunnah of the Apostle of Allah (peace_be_upon_him).


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3208]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3208

Narrated Ali ibn AbuTalib:

I said to the Prophet (peace_be_upon_him): Your old and astray uncle has died. He said: Go and bury your father, and then do not do anything until you come to me. So I went, buried him and came to him. He ordered me (to take a bath), so I took a bath, and he prayed for me.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3209]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3209

Narrated Hisham ibn Amir:

The Ansar came to the Apostle of Allah (peace_be_upon_him) on the day of Uhud and said: We have been afflicted with wound and fatigue. What do you command us?

He said: Dig graves, make them wide, bury two or three in a single grave.

He was asked: Which of them should be put first?

He replied: The one who knew the Qur'an most.

He (Hisham) said: My father Amir died on the day and was buried with two or one.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3214]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3214

Narrated Al-Qasim ibn Muhammad ibn AbuBakr:

I said to Aisha! Mother, show me the grave of the Apostle of Allah (peace_be_upon_him) and his two Companions (Allah be pleased with them). She showed me three graves which were neither high nor low, but were spread with soft red pebbles in an open space.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3215]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3215

Narrated Uthman ibn Affan:

Whenever the Prophet (peace_be_upon_him) became free from burying the dead, he used to stay at him (i.e. his grave) and say: Seek forgiveness for your brother, and beg steadfastness for him, for he will be questioned now.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3216]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3216

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: There is no slaughtering (at the grave) in Islam.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3224]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3224

Narrated Bashir, the Client of the Apostle of Allah:

Bashir's name in pre-Islamic days was Zahm ibn Ma'bad. When he migrated to the Apostle of Allah (peace_be_upon_him). He asked: What is your name? He replied: Zahm. He said: No, you are Bashir.

He (Bashir) said: When I was walking with the Apostle of Allah (peace_be_upon_him) he passed by the graves of the polytheists. He said: They lived before (a period of) abundant good. He said this three times. He then passed by the graves of Muslims. He said: They received abundant good.

The Apostle of Allah (peace_be_upon_him) suddenly saw a man walking in shoes between the graves. He said: O man, wearing the shoes! Woe to thee! Take off thy shoes. So the man looked (round), When he recognized the Apostle of Allah (peace_be_upon_him), he took them off and threw them away.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3227]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3227

Narrated AbuHurayrah:

People with a bier passed by the Apostle of Allah (peace_be_upon_him). They (the companions) spoke highly of him. He said: Paradise is certain for him. Then some people with another (bier) passed by him. They spoke very badly of him. He said: Hell is certain for him. He then said: Some of you are witness to others.


Dawud :: Funerals (Kitab Al-Jana'iz) :: [20.3230]

Funerals (Kitab Al-Jana'iz)

Dawud :: Book 20 : Hadith 3230

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) cursed women who visit graves, those who built mosques over them and erected lamps (there).


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3236]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3236

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: If anyone swears a false oath in confinement, he should make his seat in Hell on account of his (act).


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3237]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3237

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) said: He who swears an oath in which he tells a lie to take the property of a Muslim by unfair means, will meet Allah while He is angry with him.

Al-Ash'ath said: I swear by Allah, he said this about me. There was some land between me and a Jew, but he denied it to me; so I presented him to the Prophet (peace_be_upon_him).

The Prophet (peace_be_upon_him) asked me: Have you any evidence? I replied: No. He said to the Jew: Take an oath. I said: Apostle of Allah, now he will take an oath and take my property. So Allah, the Exalted, revealed the verse, "As for those who sell the faith they owe to Allah and their own plighted word for a small price, they shall have no portion in the hereafter."


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3238]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3238

Narrated Al-Ash'ath ibn Qays:

A man of Kindah and a man of Hadramawt brought their dispute to the Prophet (peace_be_upon_him) about a land in the Yemen. Al-Hadrami said: Apostle of Allah, the father of this (man) usurped my land and it is in his possession.

The Prophet asked: Have you any evidence?

Al-Hadrami replied: No, but I make him swear (that he should say) that he does not know that it is my land which his father usurped from me.

Al-Kindi became ready to take the oath.

The Apostle of Allah (peace_be_upon_him) said: If anyone usurps the property by taking an oath, he will meet Allah while his hand is mutilated.

Al-Kindi then said: It is his land.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3240]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3240

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: One should not take a false oath at this pulpit of mine even on a green tooth-stick; otherwise he will make his abode in Hell, or Hell will be certain for him.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3242]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3242

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Do not swear by your fathers, or by your mothers, or by rivals to Allah; and swear by Allah only, and swear by Allah only when you are speaking the truth.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3245]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3245

Narrated Abdullah ibn Umar:

Sa'id ibn Ubaydah said: Ibn Umar heard a man swearing: No, I swear by the Ka'bah. Ibn Umar said to him: I heard the Apostle of Allah (peace_be_upon_him) say: He who swears by anyone but Allah is polytheist.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3247]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3247

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: He who swears by Amanah (faithfulness) is not one of our number.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3248]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3248

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said about the futile oath: It is man's speech in his house: No, by Allah, and Yes, by Allah.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3250]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3250

Narrated Suwayd ibn Hanzalah:

We went out intending (to visit) the Apostle of Allah (peace_be_upon_him) and Wa'il ibn Hujr was with us. His enemy caught him. The people desisted from swearing an oath, but I took an oath that he was my brother. So he left him. We then came to the Apostle of Allah (peace_be_upon_him), and I informed him that the people desisted from taking the oath, but I swore that he was my brother. He said: You spoke the truth: A Muslim is a brother of a Muslim.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3252]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3252

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: If anyone takes an oath and says: I am free from Islam; now if he is a liar (in his oath), he will not return to Islam with soundness.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3253]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3253

Narrated Yusuf ibn Abdullah ibn Salam:

I saw that the Prophet (peace_be_upon_him) put a date on a loaf and said: This is a thing eaten with bread (condiments).


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3255]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3255

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: If anyone says when swearing an oath: "If Allah wills," he makes an exception.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3256]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3256

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: If anyone swears an oath and makes an exception, he may fulfil it if he wishes and break it if he wishes without any accountability for breaking.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3258]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3258

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) swore an oath strongly, he said: No, by Him in Whose hand is the soul of AbulQasim.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3259]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3259

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) swore an oath, it was: No, and I beg forgiveness of Allah.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3260]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3260

Narrated Laqit ibn Amir:

We came to the Apostle of Allah (peace_be_upon_him) in a delegation. The Prophet (peace_be_upon_him) then said: By the age of thy god.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3261]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3261

Narrated Abdullah ibn Abbas:

AbuBakr adjured the Prophet (peace_be_upon_him). The Prophet (peace_be_upon_him) said: Do not adjure an oath.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3266]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3266

Narrated Umar ibn al-Khattab:

Sa'id ibn al-Musayyab said: There were two brothers among the Ansar who shared an inheritance. When one of them asked the other for the portion due to him, he replied: If you ask me again for the portion due to you, all my property will be devoted to the decoration of the Ka'bah.

Umar said to him: The Ka'bah does not need your property. Make atonement for your oath and speak to your brother. I heard the Apostle of Allah (peace_be_upon_him) say: An oath or vow to disobey the Lord, or to break ties of relationship or about something over which one has no control is not binding on you.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3267]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3267

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: A vow is binding in those things by which the pleasure of Allah is sought, and an oath to break ties of relationship is not binding.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3268]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3268

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: An oath or a vow about something over which a human being has no control, and to disobey Allah, and to break ties of relationship is not binding. If anyone takes an oath and then considers something else better than it, he should give it up, and do what is better, for leaving it is its atonement.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3269]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3269

Narrated Abdullah ibn Abbas:

Two men brought their dispute to the Prophet (peace_be_upon_him). The Prophet (peace_be_upon_him) asked the plaintiff to produce evidence, but he had no evidence. So he asked the defendant to swear. He swore by Allah "There is no god but He."

The Apostle of Allah (peace_be_upon_him) said: Yes, you have done it, but you have been forgiven for the sincerity of the statement: "There is no god but Allah."


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3273]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3273

Narrated Safiyyah bint Huyayy:

Ibn Harmalah said: Umm Habib gave us a sa' and told us narration from the nephew of Safiyyah on the authority of Safiyyah that it was the sa' of the Prophet (peace_be_upon_him).

Anas ibn Ayyad said: I tested it and found its capacity two and half mudd according to the mudd of Hisham.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3277]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3277

Narrated Ash-Sharid ibn Suwayd ath-Thaqafi:

Sharid's mother left a will to emancipate a believing slave on her behalf. So he came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, my mother left a will that I should emancipate a believing slave for her, and I have a black Nubian slave-girl. He mentioned a tradition about the test of the girl.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3279]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3279

Narrated Ikrimah ibn AbuJahl:

The Prophet (peace_be_upon_him) said: I swear by Allah, I shall fight against the Quraysh; I swear by Allah, I shall fight against the Quraysh; I swear by Allah, I shall fight against the Quraysh. He then said: "If Allah wills."


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3285]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3285

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) as saying: No vow must be taken to do an act of disobedience, and the atonement for it is the same as for an oath.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3287]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3287

Narrated Imran ibn Husayn:

The Apostle of Allah (peace_be_upon_him) said: No vow must be taken to do an act of disobedience, and the atonement for it is the same as for an oath.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3288]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3288

Narrated Uqbah ibn Amir:

Uqbah consulted the Prophet (peace_be_upon_him) about his sister who took a vow to perform hajj barefooted and bareheaded. So he said: Command her to cover her head and to ride, and to fast three days.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3290]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3290

Narrated Abdullah ibn Abbas:

A man came to Prophet (peace_be_upon_him) and said: Apostle of Allah, my sister has taken a vow to perform hajj on foot. The Prophet (peace_be_upon_him) said: Allah gets no good from the affliction your sister imposed on herself, so let her perform hajj riding and make atonement for her oath.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3297]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3297

Narrated Abdullah ibn Abbas:

The sister of Uqbah ibn Amir took a vow that she would perform hajj on foot, and she was unable to do so. The Prophet (peace_be_upon_him) said: Allah is not in need of the walking of your sister. She must ride and offer a sacrificial camel.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3298]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3298

Narrated Uqbah ibn Amir al-Juhani:

Uqbah said to the Prophet (peace_be_upon_him): My sister has taken a vow that she will walk to the House of Allah (the Ka'bah). Thereupon he said: Allah will not do anything of the walking of your sister to the House of Allah (i.e. the Ka'bah).


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3299]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3299

Narrated Jabir ibn Abdullah:

A man stood on the day of Conquest (of Mecca) and said: Apostle of Allah, I have vowed to Allah that if He grants conquest of Mecca at your hands, I shall pray two rak'ahs in Jerusalem.

He replied: Pray here.

He repeated (his statement) to him and he said: Pray here.

He again repeated (his statement) to him.

He (the Prophet) replied: Pursue your own course, then.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3300]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3300

Narrated AbdurRahman ibn Awf:

The tradition mentioned above (No.3299) has also been transmitted by Umar ibn AbdurRahman ibn Awf on the authority of his father and the Companions of the Prophet (peace_be_upon_him).

This version has: "The Prophet (peace_be_upon_him) said: By Him Who sent Muhammad with truth, if you prayed here, this would be sufficient for you like the prayer in Jerusalem."


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3302]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3302

Narrated Abdullah ibn Abbas:

A woman made a voyage and vowed that she would fast one month if Allah made her reach her destination with peace and security. Allah made her reach her destination with security but she died before she could fast. Her daughter or sister (the narrator doubted) came to the Apostle of Allah (peace_be_upon_him). So he commanded to fast on her behalf.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3306]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3306

Narrated Abdullah ibn Amr ibn al-'As:

A woman came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, I have taken a vow to play the tambourine over you.

He said: Fulfil your vow.

She said: And I have taken a vow to perform a sacrifice in such a such a place, a place in which people had performed sacrifices in pre-Islamic times.

He asked: For an Idol?

She replied: No.

He asked: For an image?

She replied: No.

He said: Fulfil your vow.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3307]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3307

Narrated Thabit ibn ad-Dahhak:

In the time of the Prophet (peace_be_upon_him) a man took a vow to slaughter a camel at Buwanah. So he came to the Prophet (peace_be_upon_him) and said: I have taken a vow to sacrifice a camel at Buwanah.

The Prophet (peace_be_upon_him) asked: Did the place contain any idol worshipped in pre-Islamic times?

They (the people) said: No.

He asked: Was any pre-Islamic festival observed there?

They replied: No.

The Prophet (peace_be_upon_him) said: Fulfil your vow, for a vow to do an act of disobedience to Allah must not be fulfilled, neither must one do something over which a human being has no control.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3308]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3308

Narrated Maymunah, daughter of Kardam:

I went out with my father to see the hajj performed by the Apostle of Allah (peace_be_upon_him). I saw the Apostle of Allah (peace_be_upon_him). I fixed my eyes on him. My father came near him while he was riding his she-camel. He had a whip like the whip of scribes. I heard the bedouin and the people say: The whip, the whip. My father came near him and held his foot. She said: He admitted his Prophethood and stood and listened to him.

He said: Apostle of Allah, I have made a vow that if a son is born to me, I shall slaughter a number of sheep at the end of Buwanah in the dale of hill.

The narrator said: I do not know (for certain) that she said: Fifty (sheep).

The Apostle of Allah (peace_be_upon_him) said: Does it contain any idol?

He said: No. Then he said: Fulfil your vow that you have taken for Allah. He then gathered them (i.e. the sheep) and began to slaughter them. A sheep ran away from them.

He searched for it saying: O Allah, fulfil my vow on my behalf. So he succeeded (in finding it) and slaughtered it.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3311]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3311

Narrated Ka'b ibn Malik:

I said: Apostle of Allah, to make my repentance complete I should divest myself of my property as sadaqah (alms) for Allah and His Apostle. The Apostle of Allah (peace_be_upon_him) said: Retain some of your property, for that will be better for you. So he said: I shall retain the portion I have at Khaybar.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3313]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3313

Narrated Ka'b ibn Malik:

Ka'b ibn Malik said to AbuLubabah; or someone else whom Allah wished; or to the Prophet (peace_be_upon_him): To make my repentance complete I should depart from the house of my people in which I fell into sin, and that I should divest myself of all my property as sadaqah (alms). He said: A third (of your property) will be sufficient for you.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3315]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3315

Narrated Ka'b ibn Malik:

I said: Apostle of Allah, to make my atonement complete I should divest myself of my all property as sadaqah (alms) for Allah and His apostle. He said: No. I said: The half of it. He said: No. I said: Then a third of it. He said: Yes. I said: I shall retain the portion I have at Khaybar.


Dawud :: Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur) :: [21.3316]

Oaths and Vows (Kitab Al-Aiman Wa Al-Nudhur)

Dawud :: Book 21 : Hadith 3316

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone takes a vow but does not name it, its atonement is the same as that for an oath, if anyone takes a vow to do an act of disobedience, its atonement is the same as that for an oath, if anyone takes a vow he is unable to fulfil, its atonement is the same as that for an oath, but if anyone takes a vow he is able to fulfil, he must do so.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3320]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3320

Narrated Qays ibn AbuGharazah:

In the time of the Apostle of Allah (peace_be_upon_him) we used to be called brokers, but the Prophet (peace_be_upon_him) came upon us one day, and called us by a better name than that, saying: O company of merchants, unprofitable speech and swearing takes place in business dealings, so mix it with sadaqah (alms).


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3322]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3322

Narrated Abdullah ibn Abbas:

A man seized his debtor who owed ten dinars to him. He said to him: I swear by Allah, I shall not leave you until you pay off (my debt) to me or bring a surety. The Prophet (peace_be_upon_him) stood as a surety for him.

He then brought as much (money) as he promised. The Prophet (peace_be_upon_him) asked: From where did you acquire this gold? He replied: From a mine. He said: We have no need of it; there is no good in it. Then the Apostle of Allah (peace_be_upon_him) paid (the debt) on his behalf.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3325]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3325

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A time is certainly coming to mankind when only the receiver of usury will remain, and if he does not receive it, some of its vapour will reach him. Ibn Isa said: Some of its dust will reach him.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3326]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3326

Narrated One of the Ansar:

Asim ibn Kulayb quoted his father's authority for the following statement by one of the Ansar: We went out with the Apostle of Allah (peace_be_upon_him) to a funeral, and I saw the Apostle of Allah (peace_be_upon_him) at the grave giving this instruction to the grave-digger:

Make it wide on the side of his feet, and make it wide on the side of his head. When he came back, he was received by a man who conveyed an invitation from a woman. So he came (to her), to it food was brought, and he put his hand (i.e. took a morsel in his hand); the people did the same and they ate. Our fathers noticed that the Apostle of Allah (peace_be_upon_him) was moving a morsel around his mouth.

He then said: I find the flesh of a sheep which has been taken without its owner's permission.

The woman sent a message to say: Apostle of Allah, I sent (someone) to an-Naqi' to have a sheep bought for me, but there was none; so I sent (a message) to my neighbour who had bought a sheep, asking him to send it to me for the price (he had paid), but he could not be found. I, therefore, sent (a message) to his wife and she sent it to me.

The Apostle of Allah (peace_be_upon_him) said: Give this food to the prisoners.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3327]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3327

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) cursed the one who accepted usury, the one who paid it, the witness to it, and the one who recorded it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3328]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3328

Narrated Amr ibn al-Ahwas al-Jushami:

I heard the Apostle of Allah (peace_be_upon_him) say in the Farewell Pilgrimage: "Lo, all claims to usury of the pre-Islamic period have been abolished. You shall have your capital sums, deal not unjustly and you shall not be dealt with unjustly.

Lo, all claims for blood-vengeance belonging to the pre-Islamic period have been abolished. The first of those murdered among us whose blood-vengeance I remit is al-Harith ibn AbdulMuttalib, who suckled among Banu Layth and killed by Hudhayl."

He then said: O Allah, have I conveyed the message? They said: Yes, saying it three times. He then said: O Allah, be witness, saying it three times.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3330]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3330

Narrated Suwayd ibn Qays:

I and Makhrafah al-Abdi imported some garments from Hajar, and brought them to Mecca. The Apostle of Allah (peace_be_upon_him) came to us walking, and after he had bargained with us for some trousers, we sold them to him. There was a man who was weighing for payment. The Apostle of Allah (peace_be_upon_him) said to him: Weigh out and give overweight.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3331]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3331

Narrated AbuSafwan ibn Umayrah:

(The tradition mentioned above (No. 3330) has also been transmitted by AbuSafwan ibn Umayrah through a different chain of narrators.)

This version has: AbuSafwan said: I came to the Apostle of Allah (peace_be_upon_him) at Mecca before his immigration. He then narrated the rest of the tradition, but he did not mention the words "who was weighing for payment".


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3334]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3334

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: (The standard) weight is the weight of the people of Mecca, and the (standard) measure is the measure of the people of Medina.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3335]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3335

Narrated Samurah:

The Apostle of Allah (peace_be_upon_him) addressed us and said: Is here any one of such and such tribe present? But no one replied.

He again asked: Is here any one of such and such tribe present? But no one replied.

He again asked: Is here any one of such and such tribe?

Then a man stood and said: I am (here), Apostle of Allah.

He said: What prevented you from replying the first two times? I wish to tell you something good.

Your companion has been detained (from entering Paradise) on account of his debt. Then I saw him that he paid off all his debt on his behalf and there remained no one to demand from him anything.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3336]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3336

Narrated AbuMusa al-Ash'ari:

The Prophet (peace_be_upon_him) said: After the grave sins which Allah has prohibited the greatest sin is that a man dies while he has debt due from him and does not leave anything to pay it off, and meets Him with it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3337]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3337

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) would not say funeral prayer over a person who died while the debt was due from him. A dead Muslim was brought to him and he asked: Is there any debt due from him? They (the people) said: Yes, two dirhams. He said: Pray yourselves over your companion.

Then AbuQatadah al-Ansari said: I shall pay them, Apostle of Allah. The Apostle of Allah (peace_be_upon_him) then prayed over him.

When Allah granted conquests to the Apostle of Allah (peace_be_upon_him), he said: I am nearer to every believer than himself, so if anyone (dies and) leaves a debt, I shall be responsible for paying it; and if anyone leaves property, it goes to his heirs.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3341]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3341

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) owed me a debt and gave me something extra when he paid it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3343]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3343

Narrated Ubadah ibn as-Samit:

The Apostle of Allah (peace_be_upon_him) said: Gold is to be paid for with gold, raw and coined, silver with silver, raw and coined (in equal weight), wheat with wheat in equal measure, barley with barley in equal measure, dates with dates in equal measure, salt by salt with equal measure; if anyone gives more or asks more, he has dealt in usury. But there is no harm in selling gold for silver and silver (for gold), in unequal weight, payment being made on the spot. Do not sell them if they are to be paid for later. There is no harm in selling wheat for barley and barley (for wheat) in unequal measure, payment being made on the spot. If the payment is to be made later, then do not sell them.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3345]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3345

Narrated Fudalah ibn Ubayd:

The Prophet (peace_be_upon_him) was brought a necklace in which there were gold and pearls.

(The narrators AbuBakr and (Ahmad) Ibn Mani' said: The pearls were set with gold in it, and a man bought it for nine or seven dinars.)

The Prophet (peace_be_upon_him) said: (It must not be sold) till the contents are considered separately. The narrator said: He returned it till the contents were considered separately. The narrator Ibn Asa said: By this I intended trade.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3348]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3348

Narrated Abdullah ibn Umar:

I used to sell camels at al-Baqi for dinars and take dirhams for them, and sell for dirhams and take dinars for them. I would take these for these and give these for these. I went to the Apostle of Allah (peace_be_upon_him) who was in the house of Hafsah. I said: Apostle of Allah , take it easy, I shall ask you (a question): I sell camels at al-Baqi'. I sell (them) for dinars and take dirhams and I sell for dirhams and take dinars. I take these for these, and give these for these. The Apostle of Allah (peace_be_upon_him) then said: There is no harm in taking them at the current rate so long as you do not separate leaving something to be settled.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3350]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3350

Narrated Samurah (ibn Jundub):

The Prophet (peace_be_upon_him) forbade selling animals for animals when payment was to be made at a later date.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3351]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3351

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) commanded him to equip an army, but the camels were insufficient. So he commanded him to keep back the young camels of sadaqah, and he was taking a camel to be replaced by two when the camels of sadaqah came.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3353]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3353

Narrated Sa'd ibn AbuWaqqas:

Zayd AbuAyyash asked Sa'd ibn AbuWaqqas about the sale of the soft and white kind of wheat for barley. Sa'd said: Which of them is better? He replied: Soft and white kind of wheat. So he forbade him from it and said: I heard the Apostle of Allah (peace_be_upon_him) say, when he was asked about buying dry dates for fresh. The Apostle of Allah (peace_be_upon_him) said: Are fresh dates diminished when they become dry? The (the people) replied: Yes. So the Apostle of Allah (peace_be_upon_him) forbade that.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3354]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3354

Narrated Sa'd ibn AbuWaqqas:

The Apostle of Allah (peace_be_upon_him) forbade to sell fresh dates for dry dates when payment is made at a later date.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3363]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3363

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) forbade to sell spoils of war till they are appointed, and to sell palm trees till they are safe from every blight, and a man praying without tying belt.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3365]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3365

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) forbade the sale of grapes till they became black and the sale of grain till it had become hard.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3366]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3366

Narrated Zayd ibn Thabit:

Yunus said: I asked AbuzZinad about the sale of fruits before they were clearly in good condition, and what was said about it.

He replied: Urwah ibn az-Zubayr reports a tradition from Sahl ibn AbuHathmah on the authority of Zayd ibn Thabit who said: The people used to sell fruits before they were clearly in good condition. When the people cut off the fruits, and were demanded to pay the price, the buyer said: The fruits have been smitten by duman, qusham and murad fruit diseases on which they used to dispute. When their disputes which were brought to the Prophet (peace_be_upon_him) increased, the Apostle of Allah (peace_be_upon_him) said to them as an advice: No, do not sell fruits till they are in good condition, due to a large number of their disputes and differences.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3367]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3367

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) forbade the sale of fruits till they were clearly in good condition , and (ordered that) they should not be sold but for dinar or dirham except Araya.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3368]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3368

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) forbade selling fruits years ahead, and commanded that unforeseen loss be remitted in respect of what is affected by blight.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3376]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3376

Narrated Ali ibn AbuTalib:

A time is certainly coming to mankind when people will bite each other and a rich man will hold fast, what he has in his possession (i.e. his property), though he was not commanded for that. Allah, Most High, said: "And do not forget liberality between yourselves." The men who are forced will contract sale while the Prophet (peace_be_upon_him) forbade forced contract, one which involves some uncertainty, and the sale of fruit before it is ripe.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3377]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3377

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) having said: Allah, Most High, says: "I make a third with two partners as long as one of them does not cheat the other, but when he cheats him, I depart from them."


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3378]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3378

Narrated Urwah ibn AbulJa'd al-Bariqi:

The Prophet (peace_be_upon_him) gave him a dinar to buy a sacrificial animal or a sheep. He bought two sheep, sold one of them for a dinar, and brought him a sheep and dinar. So he invoked a blessing on him in his business dealing, and he was such that if had he bought dust he would have made a profit from it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3380]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3380

Narrated Hakim ibn Hizam:

The Apostle of Allah (peace_be_upon_him) sent with him a dinar to buy a sacrificial animal for him. He bought a sheep for a dinar, sold it for two and then returned and bought a sacrificial animal for a dinar for him and brought the (extra) dinar to the Prophet (peace_be_upon_him). The Prophet (peace_be_upon_him) gave it as alms (sadaqah) and invoked blessing on him in his trading.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3382]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3382

Narrated Abdullah ibn Mas'ud:

I Ammar, and Sa'd became partners in what we would receive on the day of Badr. Sa'd then brought two prisoners, but I and Ammar did not bring anything.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3383]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3383

Narrated Ibn Abbad:

Amr ibn Dinar said: I heard Ibn Umar say: We did not see any harm in sharecropping till I heard Rafi' ibn Khadij say: The Apostle of Allah (peace_be_upon_him) has forbidden it. So I mentioned it to Tawus. He said: Ibn Abbas told me that the Apostle of Allah (peace_be_upon_him) had not forbidden it, but said: It is better for one of you to lend to his brother than to take a prescribed sum from him.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3384]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3384

Narrated Zayd ibn Thabit:

Zayd ibn Thabit said: May Allah forgive Rafi' ibn Khadij. I swear by Allah, I have more knowledge of Hadith than him. Two persons of the Ansar (according to the version of Musaddad) came to him who were disputing with each other. The Apostle of Allah (peace_be_upon_him) said: If this is your position, then do not lease the agricultural land. The version of Musaddad has: So he (Rafi' ibn Khadij) heard his statement: Do not lease agricultural lands.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3385]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3385

Narrated Sa'd:

We used to lease land for what grew by the streamlets and for what was watered from them. The Apostle of Allah (peace_be_upon_him) forbade us to do that, and commanded us to lease if for gold or silver.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3387]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3387

Narrated Rafi' ibn Khadij:

Hanzalah ibn Qays said that he asked Rafi' ibn Khadij about the lease of land. He replied: The Apostle of Allah (peace_be_upon_him) forbade the leasing of land. I asked: (Did he forbid) for gold and silver (i.e. dinars and dirhams)? He replied: If it is against gold and silver, then there is no harm in it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3391]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3391

Narrated Rafi' ibn Khadij:

Usayd ibn Zubayr said: Rafi' ibn Khadij came to us and said: The Apostle of Allah (peace_be_upon_him) forbids you from a work which is beneficial to you; and obedience to Allah and His Prophet (peace_be_upon_him) is more beneficial to you. The Apostle of Allah (peace_be_upon_him) forbids you from renting land for a share of its produce and he said: If anyone is not in need of his land he should lend it to his brother or leave it.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3393]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3393

Narrated Rafi' ibn Khadij:

AbuJa'far al-Khatmi said: My uncle sent me and his slave to Sa'id ibn al-Musayyab. We said to him, there is something which has reached us about sharecropping. He replied: Ibn Umar did not see any harm in it until a tradition reached him from Rafi' ibn Khadij. He then came to him and Rafi' told him that the Apostle of Allah (peace_be_upon_him) came to Banu Harithah and saw crop in the land of Zuhayr. He said: What an excellent crop of Zuhayr is! They said: It does not belong to Zuhayr. He asked: Is this not the land of Zuhayr? They said: Yes, but the crop belongs to so-and-so. He said: Take your crop and give him the wages. Rafi' said: We took our crop and gave him the wages. Sa'id (ibn al-Musayyab) said: Lend your brother or employ him for dirhams.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3394]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3394

Narrated Rafi' ibn Khadij:

The Apostle of Allah (peace_be_upon_him) forbade muhaqalah and muzabanah. Those who cultivate land are three: a man who has (his own) land and he tills it: a man who has been lent land and he tills the one lent to him; a man who employs another man to till land against gold (dinars) or silver (dirhams).


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3395]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3395

Narrated Rafi' ibn Khadij:

Rafi' had cultivated a land. The Prophet (peace_be_upon_him) passed him when he was watering it. So he asked him: To whom does the crop belong, and to whom does the land belong? He replied: The crop is mine for my seed and labour. The half (of the crop) is mine and the half for so-and-so. He said: You conducted usurious transaction. Return the land to its owner and take your wages and cost.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3396]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3396

Narrated Rafi' ibn Khadij:

The Prophet (peace_be_upon_him) said: If anyone sows in other people's land without their permission, he has no right to any of the crop, but he may have what it cost him.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3406]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3406

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) used to send Abdullah ibn Rawahah (to Khaybar), and he would assess the amount of dates when they began to ripen before they were eaten (by the Jews). He would then give choice to the Jews that they have them (on their possession) by that assessment or could assign to them (Muslims) by that assignment, so that the (amount of) zakat could be calculated before the fruit became eatable and distributed (among the people).


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3407]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3407

Narrated Jabir ibn Abdullah:

When Allah bestowed Khaybar on His Prophet (peace_be_upon_him) as fay' (as a result of conquest without fighting), the Apostle of Allah (peace_be_upon_him) allowed (them) to remain there as they were before, and apportioned it between him and them. He then sent Abdullah ibn Rawahah who assessed (the amount of dates) upon them.


Dawud :: Commercial Transactions (Kitab Al-Buyu) :: [22.3408]

Commercial Transactions (Kitab Al-Buyu)

Dawud :: Book 22 : Hadith 3408

Narrated Jabir ibn Abdullah:

Ibn Rawahah assessed them (the amount of dates) at forty thousand wasqs, and when Ibn Rawahah gave them option, the Jews took the fruits in their possession and twenty thousand wasqs of dates were due from them.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3409]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3409

Narrated Ubaydah ibn as-Samit:

I taught some persons of the people of Suffah writing and the Qur'an. A man of them presented to me a bow. I said: It cannot be reckoned property; may I shoot with it in Allah's path? I must come to the Apostle of of Allah (peace_be_upon_him) and ask him (about it). So I came to him and said : Apostle of Allah (peace_be_upon_him), one of those whom I have been teaching writing and the Qur'an has presented me a bow, and as it cannot be reckoned property, may I shoot with it in Allah's path? He said: If you want to have a necklace of fire on you, accept it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3413]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3413

Narrated Alaqah ibn Sahar at-Tamimi:

Alaqah passed by a clan (of the Arab) who came to him and said: You have brought what is good from this man. Then they brought a lunatic in chains. He recited Surat al-Fatihah over him three days, morning and evening. When he finished, he collected his saliva and then spat it out, (he felt relief) as if he were set free from a bond. They gave him something (as wages). He then came to the Prophet (peace_be_upon_him) and mentioned it to him. The Apostle of Allah (peace_be_upon_him) said: Accept it, for by my life, some accept it for a worthless charm, but you have done so far a genuine one.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3414]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3414

Narrated Rafi' ibn Khadij:

The Prophet (peace_be_upon_him) said: The earnings of a cupper are impure, the price paid for a dog is impure, and the hire paid to a prostitute is impure.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3415]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3415

Narrated Muhayyisah ibn Ka'b:

Muhayyisah asked permission of the Apostle of Allah (peace_be_upon_him) regarding hire of the cupper, but he forbade him. He kept on asking his permission, and at last he said to him: Feed your watering camel with it and feed your slave with it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3419]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3419

Narrated Rafi' ibn Rifa'ah:

Tariq ibn AbdurRahman al-Qarashi said: Rafi' ibn Rifa'ah came to a meeting of the Ansar and said: The Prophet of Allah (peace_be_upon_him) forbade us (from some things) today, and he mentioned some things. He forbade the earning of a slave-girl except what she earned with her hand. He indicated (some things) with his fingers such as baking, spinning, and ginning.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3421]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3421

Narrated AbuMas'ud:

The Prophet (peace_be_upon_him) forbade the price paid for a dog, the hire paid to a prostitute, and the gift given to a soothsayer.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3422]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3422

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) forbade (taking hire for) a stallion's covering.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3423]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3423

Narrated Umar ibn al-Khattab:

AbuMajidah said: I cut the ear of a boy, or he cut my ear (the narrator is doubtful). AbuBakr then came to us to perform hajj and we got together with him. But he referred us to Umar ibn al-Khattab. Umar (ibn al-Khattab) said: This reached the extent of retaliation. Call a cupper to me so that he may retaliate. When the cupper was called, he (Umar) said: I heard the Apostle of Allah (peace_be_upon_him) say: I gave a boy to my maternal aunt, and I hope that she will be blessed in respect of him. I said to her: Do not entrust him to a supper, nor to a goldsmith, nor to a butcher.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3428]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3428

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If anyone buys a slave who possesses property, his property belongs to the seller unless the buyer makes a proviso.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3433]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3433

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: A townsman must not sell for a man from the desert, even if he is his brother or father.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3434]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3434

Narrated Talhah ibn Ubaydullah:

Salim al-Makki said that a bedouin told him that he brought a milch she-camel in the time of the Apostle of Allah (peace_be_upon_him). He alighted with Talhah ibn Ubaydullah (and wanted to sell his milch animal to him). He said: The Prophet (peace_be_upon_him) forbade a townsman to sell for a man from the desert. But go to the market and see who buys from you. consult me thereafter, and then I shall ask you (to sell) or forbid you.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3437]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3437

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) forbade payment for cat.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3439]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3439

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: If anyone buys a sheep whose udders have been tied up, he has option for three days (for decision). If he returns it, he should return with it wheat equal to its milk or double of it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3442]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3442

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) forbade to break the coins of the Muslims current among them except for some defect.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3443]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3443

Narrated AbuHurayrah:

A man came and said: Apostle of Allah, fix prices. He said: (No), but I shall pray. Again the man came and said: Apostle of Allah, fix prices. He said: It is but Allah Who makes the prices low and high. I hope that when I meet Allah, none of you has any claim on me for doing wrong regarding blood or property.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3444]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3444

Narrated Anas ibn Malik:

The people said: Apostle of Allah , prices have shot up, so fix prices for us. Thereupon the Apostle of Allah (peace_be_upon_him) said: Allah is the one Who fixes prices, Who withholds, gives lavishly and provides, and I hope that when I meet Allah, none of you will have any claim on me for an injustice regarding blood or property.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3449]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3449

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Both parties in a business transaction have a right to annul it so long as they have not separated unless it is a bargain with the option to annul is attached to it; and it is not permissible for one of them to separate from the other for fear that one may demand that the bargain be rescinded.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3450]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3450

Narrated AbuBarzah:

AbulWadi', Abbad ibn Nasib said: We fought one of our battle, and encamped at a certain place. One of our companions sold a horse for a slave. After that they remained there for the rest of day and night. When the next morning came, they prepared themselves for departure. The buyer of the horse began to saddle it, but the seller was ashamed (of the transaction). He went to the man (buyer) and asked him to annul the transaction. The man refused to hand it over (the horse) to him.

He said: AbuBarzah, the companion of the Prophet (peace_be_upon_him), is to decide between me and you. They went to AbuBarzah in the corner of the army. They related this story to him.

He said: Do you agree that I make a decision between you on the basis of the decision of the Apostle of Allah (peace_be_upon_him)?

The Apostle of Allah (peace_be_upon_him) said: Both parties in a business transaction have an option (right) to annul it so long as they have not separated.

Hisham to Hassan said that Jamil said in his version: "I do not think that you separated."


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3451]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3451

Narrated AbuHurayrah:

When AbuZur'ah made a business transaction with a man, he gave him the right of option. He then would tell him: Give me the right of option (to annul the bargain). He said: I heard AbuHurayrah say: The Apostle of Allah (peace_be_upon_him) said: Two people must separate only by mutual consent.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3453]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3453

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone rescinds a sale with a Muslim, Allah will cancel his slip, on the Day of Resurrection.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3454]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3454

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone makes two transactions combined in one bargain, he should have the lesser of the two or it will involve usury.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3455]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3455

Narrated Abdullah ibn Umar:

I heard the Apostle of Allah, (peace_be_upon_him) say: When you enter into the inah transaction, hold the tails of oxen, are pleased with agriculture, and give up conducting jihad (struggle in the way of Allah). Allah will make disgrace prevail over you, and will not withdraw it until you return to your original religion.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3459]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3459

Narrated Abdullah ibn AbuAwfa ibn AbuAwfa al-Aslami:

We made a journey to Syria on an expedition along with the Apostle of Allah (peace_be_upon_him). The Nabateans of Syria came to us and we paid in advance to them (in a salam contract) in wheat and olive oil at a specified rate and for a specified time. He asked (by the people): you might have contracted with him who had these things in his possession? He replied: We did not ask them.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3460]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3460

Narrated Abdullah ibn Umar:

A man paid in advance for a palm-tree. It did not bear fruit that year. They brought their case for decision to the Prophet (peace_be_upon_him). He said: for which do you make his property lawful? He then said: Do not pay in advance for a palm-tree till they (the fruits) were clearly in good condition.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3461]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3461

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: If anyone pays in advance he must not transfer it to someone else before he receives it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3470]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3470

Narrated A man:

A man from the immigrants of the Companions of the Prophet (peace_be_upon_him) said: I participated in battle three times along with the Prophet (peace_be_upon_him). I heard him say: Muslims have common share in three (things). grass, water and fire.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3471]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3471

Narrated Iyas ibn Abd:

The Apostle of Allah (peace_be_upon_him) forbade the sale of excess water.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3472]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3472

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) forbade payment for dog and cat.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3475]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3475

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) forbade the price paid for a dog; if someone comes to ask for the price of a dog, fill his hand-palm with dust.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3477]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3477

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The price paid for a dog, the price given to a soothsayer, and the hire paid to a prostitute are not lawful.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3482]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3482

Narrated Al-Mughirah ibn Shu'bah:

The Prophet (peace_be_upon_him) said: He who sold wine should shear the flesh of swine.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3488]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3488

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) forbade to sell grain which one buys by measurement until one receives it in full.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3492]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3492

Narrated Zayd ibn Thabit:

Ibn Umar said: I bought olive oil in the market. When I became its owner, a man met me and offered good profit for it. I intended to settle the bargain with him, but a man caught hold of my hand from behind. When I turned I found that he was Zayd ibn Thabit. He said: Do not sell it on the spot where you have bought it until you take it to your house, for the Apostle of Allah (peace_be_upon_him) forbade to sell the goods where they are bought until the tradesmen take them to their houses.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3494]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3494

Narrated Anas ibn Malik:

During the time of the Apostle of Allah (peace_be_upon_him) a man used to buy (goods), and he was weak in his intellect. His people came to the Prophet of Allah (peace_be_upon_him) and said: Prophet of Allah, stop so-and-so (to make a bargain) for he buys (goods), but he is weak in his intellect. So the Prophet (peace_be_upon_him) called on him and forbade him to make a bargain. He said: Prophet of Allah, I cannot keep away myself from business transactions. Thereupon the Apostle of Allah (peace_be_upon_him) said: If you cannot give up making a bargain , then say: Take , and give, and there is no attempt to deceive.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3495]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3495

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) forbade the type of transactions in which earnest money was paid. Malik said: This means, as we think--Allah better knows-that a man buys a slave or hires an animal, and he says: I give you a dinar on condition that if I give up the transaction or hire, what I gave you is yours.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3496]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3496

Narrated Hakim ibn Hizam:

Hakim asked (the Prophet): Apostle of Allah, a man comes to me and wants me to sell him something which is not in my possession. Should I buy it for him from the market? He replied: Do not sell what you do not possess.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3499]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3499

Narrated Uqbah ibn Amir:

The Prophet (peace_be_upon_him) said: The contractual obligation of a slave is three days.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3501]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3501

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Profit follows responsibility.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3502]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3502

Narrated Aisha, Ummul Mu'minin:

Makhlad ibn Khufaf al-Ghifari said: I and some people were partners in a slave. I employed him on some work in the absence of one of the partners. He got earnings for me. He disputed me and the case of his claim to his share in the earnings to a judge, who ordered me to return the earnings (i.e. his share) to him. I then came to Urwah ibn az-Zubayr, and related the matter to him. Urwah then came to him and narrated to him a tradition from the Apostle of Allah (peace_be_upon_him) on the authority of Aisha: Profit follows responsibility.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3503]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3503

Narrated Aisha, Ummul Mu'minin:

A man bought a slave, and he remained with him as long as Allah wished him to remain. He then found defect in him. He brought his dispute with him to the Prophet (peace_be_upon_him) and he returned him to him. The man said: Apostle of Allah, my slave earned some wages. The Apostle of Allah (peace_be_upon_him) then said: Profit follows responsibility.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3504]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3504

Narrated Abdullah ibn Mas'ud:

Muhammad ibn al-Ash'ath said: Al-Ash'ath bought slaves of booty from Abdullah ibn Mas'ud for twenty thousand (dirhams. Abdullah asked him for payment of their price. He said: I bought them for ten thousand (dirhams). Abdullah said: Appoint a man who may adjudicate between me and you. Al-Ash'ath said: (I appoint) you between me and yourself. Abdullah said: I heard the Apostle of Allah (peace_be_upon_him) say: If both parties in a business transaction differ (on the price of an article), and they have witness between them, the statement of the owner of the article will be accepted (as correct) or they may annul the transaction.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3508]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3508

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When land has been divided and boundaries have been set up, there is no right of pre-emption in it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3510]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3510

Narrated Samurah:

The Prophet (peace_be_upon_him) said: A neighbour has the best claim to the house or land of the neighbour.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3511]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3511

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: The neighbour is most entitled to the right of pre-emption, and he should wait for its exercise even if he is absent, when the two properties have one road.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3513]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3513

Narrated AbuBakr ibn AbdurRahman ibn al-Harith ibn Hisham:

The Prophet (peace_be_upon_him) said: If a man sells (his) property and the man who buys it becomes insolvent, and the seller does not receive the price of the property he had sold, but finds his very property with him (i.e. the buyer), he is more entitled to it (than others). If the buyer dies, then the owner of the property is equal to the creditors.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3515]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3515

Narrated AbuHurayrah:

A similar tradition (to the No. 3513) has been transmitted by AbuHurayrah from the Prophet (peace_be_upon_him).

This version has: If he paid something from its price, then he will be equal to the creditors in the remaining price. If a man dies and he has the very property of a man (i.e. seller), he is equal to the creditors whether he (the buyer) pays him (the price) or not.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3516]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3516

Narrated AbuHurayrah:

Umar ibn Khaldah said: We came to AbuHurayrah who had become insolvent. He said: I shall decide between you on the basis of the decision of the Apostle of Allah (peace_be_upon_him): If anyone becomes insolvent or dies and the man (the seller) finds his very property with him, he is more entitled to it (than others).


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3517]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3517

Narrated Amir ash-Sha'bi:

The Prophet (peace_be_upon_him) said: If anyone finds an animal whose owners were helpless to provide fodder to it and so they turned it out (of their house), and he took it and looked after it, it will belong to him.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3518]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3518

Narrated ash-Sha'bi:

The Prophet (peace_be_upon_him) said: If anyone leaves an animal at a place of perishing and another man brings it to life, it belongs to him who brings it to life.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3520]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3520

Narrated Umar ibn al-Khattab:

reported the Prophet (peace_be_upon_him) as saying: There are people from the servants of Allah who are neither prophets nor martyrs; the prophets and martyrs will envy them on the Day of Resurrection for their rank from Allah, the Most High.

They (the people) asked: Tell us, Apostle of Allah, who are they? He replied: They are people who love one another for the spirit of Allah (i.e. the Qur'an), without having any mutual kinship and giving property to one. I swear by Allah, their faces will glow and they will be (sitting) in (pulpits of) light. They will have no fear (on the Day) when the people will have fear, and they will not grieve when the people will grieve.

He then recited the following Qur'anic verse: "Behold! Verily for the friends of Allah there is no fear, nor shall they grieve."


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3521]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3521

Narrated Aisha, Ummul Mu'minin:

The aunt of Umarah ibn Umayr asked Aisha: I have an orphan in my guardianship. May I enjoy from his property? She said: The Apostle of Allah (peace_be_upon_him) said: The pleasantest things a man enjoys come from what he earns, and his child comes from what he earns.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3522]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3522

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) Said: The children of a man come from what he earns, rather they are his pleasantest earning; so enjoy from their property.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3523]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3523

Narrated Abdullah ibn Amr ibn al-'As:

A man came to the Prophet (peace_be_upon_him) and said: Apostle of Allah, I have property and children, and my father finishes my property. He replied; You and your property belong to your father; your children come from the pleasantest of what you earn; so enjoy from the earning of your children.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3524]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3524

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: If anyone finds his very property with a man, he is more entitled to it (than anyone else), and the buyer should pursue the one who sold it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3527]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3527

Narrated Yusuf ibn Malik al-Makki:

I used to write (the account of) the expenditure incurred on orphans who were under the guardianship of so-and-so. They cheated him by one thousand dirhams and he paid these (this amount) to them. I then got double the property which they deserved. I said (to the man: Take one thousand (dirhams) which they have taken from you (by cheating). He said: No, my father has told me that he heard the Apostle of Allah (peace_be_upon_him) say: Pay the deposit to him who deposited it with you, and do not betray him who betrays you.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3528]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3528

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Pay the deposit to him who deposited it with you, and do not betray him who betrayed you.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3530]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3530

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: I swear by Allah, I shall not accept gift from anyone after this day except from an immigrant Qarashi, an Ansari a Dawsi or a Thaqafi.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3532]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3532

Narrated Abdullah Ibn Umar ; Abdullah Ibn Abbas:

The Prophet (peace_be_upon_him) said: It is not lawful for a man to make a donation or give a gift and then take it back, except a father regarding what he gives his child. One who gives a gift and then takes it back is like a dog which eats and vomits when it is full, then returns to its vomit.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3533]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3533

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: The similitude of the one who takes back what he gifted is like that of a dog which vomits and then it eats vomit. When a donor seeks to take back (his gift), it should be made known and he informed why he sought to take it back. Then whatever he donated should be returned to him.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3534]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3534

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: If anyone intercedes for his brother and he presents a gift to him for it and he accepts it, he approaches a great door of the doors of usury.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3537]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3537

Narrated An-Nu'man ibn Bashir:

The Prophet (peace_be_upon_him) said: Act equally between your children; Act equally between your sons.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3540]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3540

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: It is not permissible for a woman to present a gift (from her husband's property) except with the permission of her husband.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3544]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3544

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If anyone is given life-tenancy, it belongs to him and to his descendants. His descendants who inherit him will inherit from it.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3549]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3549

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Do not give property to go to the survivor and do not give life-tenancy. If anyone is given something to the survivor or given life-tenancy, it goes to his heirs.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3550]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3550

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) decided a case of a woman from the Ansar to whom an orchard of date-palms was given by her son. She then died. Her son said: I gave it to her for her life, and she has brothers. Thereupon the Apostle of Allah (peace_be_upon_him) said: It belongs to her during her life and after death. He then said: I gave a sadaqah (charity to her. He replied: It is more unexpected from you.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3551]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3551

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Life-tenancy is lawful for the one to whom it is given and donation of property to go to the survivor is lawful to whom it is given.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3552]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3552

Narrated Zayd ibn Thabit:

The Prophet (peace_be_upon_him) said: If anyone gives something in life-tenancy, it belongs to the one to whom it is given, in his life and after his death; and do not give property to go to the survivor, for if anyone gives something to to to the survivor, it belongs to him.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3555]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3555

Narrated Safwan ibn Umayyah:

The Apostle of Allah (peace_be_upon_him) borrowed coats of mail from him on the day of (the battle of) Hunayn. He asked: Are you taking them by force. Muhammad? He replied: No, it is a loan with a guarantee of their return.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3556]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3556

Narrated Some people:

AbdulAziz ibn Rufay' narrated on the authority of some people from the descendants of Abdullah ibn Safwan who reported the Apostle of Allah (peace_be_upon_him) as saying: Have you weapons, Safwan? He asked: On loan or by force? He replied: No, but on loan. So he lent him coats of mail numbering between thirty and forty! The Apostle of Allah (peace_be_upon_him) fought the battle of Hunayn. When the polytheists were defeated, the coats of mail of Safwan were collected. Some of them were lost. The Apostle of Allah (peace_be_upon_him) said to Safwan: We have lost some coats of mail from your coats of mail. Should we pay compensation to you? He replied: No. Apostle of Allah, for I have in my heart today what I did not have that day.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3558]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3558

Narrated AbuUmamah:

I heard the Apostle of Allah (peace_be_upon_him) Said: Allah , Most Exalted, has appointed for everyone who has a right what is due to him, and no will be made to an heir, and a woman should not spend anything from her house except with the permission of her husband. He was asked: Even foodgrain, Apostle of Allah? He replied: That is the best of our property. He then said: A loan must be paid back, a she-camel lent for a time for milking must be returned, a debt must be discharged, one who stands surety is held responsible.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3559]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3559

Narrated Ya'la ibn Umayyah:

The Apostle of Allah (peace_be_upon_him) said to me: When my messengers come to you, give them thirty coats of mail, and thirty camels. I asked: Apostle of Allah, is it a loan with a guarantee of its return, or a loan to be paid back? He replied : It is a loan to be paid back.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3561]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3561

Narrated Aisha, Ummul Mu'minin:

I saw no one cooking food like Safiyyah. She cooked food for the Apostle of Allah (peace_be_upon_him) and sent it. I became angry and broke the vessel. I then asked: Apostle of Allah, what is the atonement for what I have done? He replied: A vessel like (this) vessel and food like (this) food.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3562]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3562

Narrated Muhayyisah:

The she-camel of Bara' ibn Azib entered the garden of a man and did damage to it. The Apostle of Allah (peace_be_upon_him) gave decision that the owners of properties are responsible for guarding them by day, and the owners of animals are responsible for guarding them by night.


Dawud :: Wages (Kitab Al-Ijarah) :: [23.3563]

Wages (Kitab Al-Ijarah)

Dawud :: Book 23 : Hadith 3563

Narrated Al-Bara' ibn Azib:

Al-Bara' had a she-camel which was accustomed to graze the standing crop belonging to the people. She entered a garden and did damage to it. The Apostle of Allah (peace_be_upon_him) was informed about it.

So he gave decision that the owners of gardens are responsible for guarding them by day, and the owners of the animals are responsible for guarding them by night. Any damage done by animals during the night is a responsibility lying on their owners.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3564]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3564

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who has been appointed a judge has been killed without a knife.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3565]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3565

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who has been appointed a judge among the people has been killed without a knife.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3566]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3566

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: Judges are of three types, one of whom will go to Paradise and two to Hell. The one who will go to Paradise is a man who knows what is right and gives judgment accordingly; but a man who knows what is right and acts tyrannically in his judgment will go to Hell; and a man who gives judgment for people when he is ignorant will go to Hell.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3568]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3568

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone seeks the office of judge among Muslims till he gets it and his justice prevails over his tyranny, he will go to Paradise; but the man whose tyranny prevails over his justice will go to Hell.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3570]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3570

Narrated AbuMas'ud al-Ansari:

AbdurRahman ibn Bishr al-Ansari al-Azraq said: Two men from the locality of Kindah came while AbuMas'ud al-Ansari was sitting n a circle. They said: Is there any man who decides between us. A man from the circle said: I, AbuMas'ud took a handful of pebbles and threw at him, saying: Hush! It is disapproved to make haste in decision.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3571]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3571

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: If anyone desires the office of Judge and seeks help for it, he will be left to his own devices; if anyone does not desire it, nor does he seek help for it, Allah will send down an angel who will direct him aright.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3573]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3573

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) cursed the one who bribes and the one who takes bribe.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3574]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3574

Narrated Adi ibn Umayrah al-Kindi:

The Prophet (peace_be_upon_him) said: O people, if any of you is put in an administrative post on our behalf and conceals from us a needle or more, he is acting unfaithfully, and will bring it on the Day of Resurrection. A black man from the Ansar, as if I am seeing him, stood and said: Apostle of Allah, take back from me my post. He asked: What is that? He replied: I heard you say such and such. He said: And I say that. If we appoint anyone to an office, he must bring what is connected with it, both little and much. What he is given, he may take, and he must refrain from what is kept away from him.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3575]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3575

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) sent me to the Yemen as judge, and I asked: Apostle of Allah, are you sending me when I am young and have no knowledge of the duties of a judge? He replied: Allah will guide your heart and keep your tongue true. When two litigants sit in front of you, do not decide till you hear what the other has to say as you heard what the first had to say; for it is best that you should have a clear idea of the best decision. He said: I had been a judge (for long); or he said (the narrator is doubtful): I have no doubts about a decision afterwards.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3579]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3579

Narrated Umar ibn al-Khattab:

Umar said while he was (sitting) on the pulpit: O people, the opinion from the Apostle of Allah (peace_be_upon_him) was right, because Allah showed (i.e. inspired) him; but from us it is sheer conjecture and artifice.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3581]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3581

Narrated Abdullah ibn az-Zubayr:

The Apostle of Allah (peace_be_upon_him) gave the decision that the two adversaries should be made to sit in front of the judge.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3584]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3584

Narrated Abdullah ibn Abbas:

When this verse was revealed: "If they do come to thee, either judge between them, or decline to interfere....If thou judge, judge in equity between them." Banu an-Nadir used to pay half blood-money if they killed any-one from Banu Qurayzah. When Banu Qurayzah killed anyone from Banu an-Nadir, they would pay full blood-money. So the Apostle of Allah (peace_be_upon_him) made it equal between them.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3585]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3585

Narrated Mu'adh ibn Jabal:

Some companions of Mu'adh ibn Jabal said: When the Apostle of Allah (peace_be_upon_him) intended to send Mu'adh ibn Jabal to the Yemen, he asked: How will you judge when the occasion of deciding a case arises?

He replied: I shall judge in accordance with Allah's Book. He asked: (What will you do) if you do not find any guidance in Allah's Book? He replied: (I shall act) in accordance with the Sunnah of the Apostle of Allah (peace_be_upon_him).

He asked: (What will you do) if you do not find any guidance in the Sunnah of the Apostle of Allah (peace_be_upon_him) and in Allah's Book?

He replied: I shall do my best to form an opinion and I shall spare no effort.

The Apostle of Allah (peace_be_upon_him) then patted him on the breast and said: Praise be to Allah Who has helped the messenger of the Apostle of Allah to find something which pleases the Apostle of Allah.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3587]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3587

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Conciliation between Muslims is permissible. The narrator Ahmad added in his version: "except the conciliation which makes lawful unlawful and unlawful lawful." Sulayman ibn Dawud added: The Apostle of Allah (peace_be_upon_him) said: Muslims are on (i.e. stick to) their conditions.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3590]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3590

Narrated Abdullah ibn Umar:

Yahya ibn Rashid said: We were sitting waiting for Abdullah ibn Umar who came out to us and sat. He then said: I heard the Apostle of Allah (peace_be_upon_him) as saying: If anyone's intercession intervenes as an obstacle to one of the punishments prescribed by Allah, he has opposed Allah; if anyone disputes knowingly about something which is false, he remains in the displeasure of Allah till he desists, and if anyone makes an untruthful accusation against a Muslim, he will be made by Allah to dwell in the corrupt fluid flowing from the inhabitants of Hell till he retracts his statement.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3592]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3592

Narrated Khuraym Ibn Fatik:

The Apostle of Allah (peace_be_upon_him) offered the morning prayer. When he finished it, he stood up and said three times: False witness has been made equivalent to attributing a partner to Allah. He then recited: "So avoid the abomination of idols and avoid speaking falsehood as people pure of faith to Allah, not associating anything with Him.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3593]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3593

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) rejected the testimony of a deceitful man and woman, of one who harbours rancour against his brother, and he rejected the testimony of one who is dependent on a family, and he allowed his testimony for other.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3594]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3594

Narrated Sulayman ibn Musa:

The tradition mentioned above (No. 3593) has also been transmitted by Sulayman ibn Musa through a different chain of narrators.

This version has: The Apostle of Allah (peace_be_upon_him) said: The testimony of a deceitful man or woman, of an adulterer and adulteress, and of one who harbours rancour against his brother is not allowable.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3595]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3595

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The testimony of a nomad Arab against a townsman is not allowable.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3597]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3597

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: The proviso of a loan combined with a sale is not allowable, nor two conditions relating to one transaction, nor the profit arising from something which is not in one's charge, nor selling what is not in your possession.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3598]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3598

Narrated AbuMusa al-Ash'ari:

Ash-Sha'bi said: A Muslim was about to die at Daquqa', but he did not find any Muslim to call him for witness to his will. So he called two men of the people of the Book for witness. Then they came to Kufah, and approaching AbuMusa al-Ash'ari they informed him (about his) will. They brought his inheritance and will. Al-Ash'ari said: This is an incident (like) which happened in the time of the Apostle of Allah (peace_be_upon_him) and never occurred after him. So he made them to swear by Allah after the afternoon prayer to the effect that they had not misappropriated, nor told a lie, nor changed, nor concealed, nor altered, and that it was the will of the man and his inheritance. He then executed their witness.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3599]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3599

Narrated Abdullah Ibn Abbas:

A man from Banu Sahm went out with Tamim ad-Dari and Adi ibn Badda'. The man of Banu Sahm died in the land where no Muslim was present. When they returned with his inheritance, they (the heirs) did not find a silver cup with lines of gold (in his property). The Apostle of Allah (peace_be_upon_him) administered on oath to them. The cup was then found (with someone) at Mecca. They said: We have bought it from Tamim and Adi.

Then two men from the heirs of the man of Banu Sahm got up and swore saying: Our witness is more reliable than their witness. They said that the cup belonged to their man.

He (Ibn Abbas) said: The following verse was revealed about them: "O ye who believe! when death approaches any of you....."


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3600]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3600

Narrated Uncle of Umarah ibn Khuzaymah:

The Prophet (peace_be_upon_him) bought a horse from a Bedouin. The Prophet (peace_be_upon_him) took him with him to pay him the price of his horse. The Apostle of Allah (peace_be_upon_him) walked quickly and the Bedouin walked slowly. The people stopped the Bedouin and began to bargain with him for the horse as and they did not know that the Prophet (peace_be_upon_him) had bought it.

The Bedouin called the Apostle of Allah (peace_be_upon_him) saying: If you want this horse, (then buy it), otherwise I shall sell it. The Prophet (peace_be_upon_him) stopped when he heard the call of the Bedouin, and said: Have I not bought it from you? The Bedouin said: I swear by Allah, I have not sold it to you. The Prophet (peace_be_upon_him) said: Yes, I have bought it from you. The Bedouin began to say: Bring a witness. Khuzaymah ibn Thabit then said: I bear witness that you have bought it. The Prophet (peace_be_upon_him) turned to Khuzaymah and said: On what (grounds) do you bear witness?

He said: By considering you trustworthy, Apostle of Allah (peace_be_upon_him)! The Prophet (peace_be_upon_him) made the witness of Khuzaymah equivalent to the witness of two people.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3603]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3603

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) gave a decision on the basis of an oath and a single witness.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3605]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3605

Narrated Zubayb ibn Tha'labah al-Anbari:

The Apostle of Allah (peace_be_upon_him) sent an army to Banu al-Anbar. They captured them at Rukbah in the suburbs of at-Ta'if and drove them to the Holy Prophet (peace_be_upon_him).

I rode hurriedly to the Holy Prophet (peace_be_upon_him) and said: Peace be on you, Apostle of Allah, and the mercy of Allah and His blessings. Your contingent came to us and arrested us, but we had already embraced Islam and cut the sides of the ears of our cattle.

When Banu al-Anbar arrived, the Holy Prophet (peace_be_upon_him) said to me: Have you any evidence that you had embraced Islam before you were captured today?

I said: Yes. He said: Who is your witness? I said: Samurah, a man from Banu al-Anbar, and another man whom he named. The man testified but Samurah refused to testify. The Holy Prophet (peace_be_upon_him) said: He (Samurah) has refused to testify for you, so take an oath with your other witness. I said: Yes. He then dictated an oath to me and I swore to the effect that we had embraced Islam on a certain day, and that we had cut the sides of the ears of the cattle.

The Holy Prophet (peace_be_upon_him) said: Go and divide half of their property, but do not touch their children. Had Allah not disliked the wastage of action, we should not have taxed you even a rope.

Zubayb said: My mother called me and said: This man has taken my mattress. I then went to the Holy Prophet (peace_be_upon_him) and informed him.

He said to me: Detain him. So I caught him with a garment around his neck, and stood there with him . Then the Holy Prophet (peace_be_upon_him) looked at us standing there. He asked: What do you intend (doing) with your captive?

I said: I shall let him go free if he returns to this (man) the mattress of his mother which he has taken from her.

He said: Prophet of Allah (peace_be_upon_him), I no longer have it.

He said: The Holy Prophet (peace_be_upon_him) took the sword of the man and gave it to me, and said to him: Go and give him some sa's of cereal. So he gave me some sa's of barley.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3606]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3606

Narrated AbuMusa al-Ash'ari:

Two men claimed a camel or an animal and brought the case to the Holy Prophet (peace_be_upon_him). But as neither of them produced any proof, the Holy Prophet (peace_be_upon_him) declared that they should share it equally.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3609]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3609

Narrated AbuHurayrah:

Two men disputed about some property and brought the case to the Holy Prophet (peace_be_upon_him), but neither of them could produce any proof. So the Holy Prophet (peace_be_upon_him) said: Cast lots about the oath whatever it may be, whether they like it or dislike it.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3613]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3613

Narrated Abdullah ibn Abbas:

The Holy Prophet (peace_be_upon_him) said to a man whom he asked to take an oath: Swear by Allah except whom there is no god that you have nothing belonging to him, i.e. the plaintiff.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3619]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3619

Narrated Ikrimah:

The Holy Prophet (peace_be_upon_him) said to Ibn Suriya': I remind you by Allah Who saved you from the people of Pharaoh, made you cover the sea, gave you the shade of clouds, sent down to you manna and quails, sent down you Torah to Moses, do you find stoning (for adultery) in your Book? He said: You have reminded me by the Great. It is not possible for me to belie you. He then transmitted the rest of the tradition.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3620]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3620

Narrated Awf ibn Malik:

The Holy Prophet (peace_be_upon_him) gave a decision between two men, and the one against whom the decision was given turned away and said: For me Allah sufficeth, and He is the best dispenser of affairs. The Holy Prophet (peace_be_upon_him) said: Allah, Most High, blames for falling short, but apply intelligence, and when the matter gets the better of you, say; For me Allah sufficeth, and He is the best disposer of affairs.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3621]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3621

Narrated Ash-Sharid:

The Prophet (peace_be_upon_him) said: Delay in payment on the part of one who possesses means makes it lawful to dishonour and punish him. Ibn al-Mubarak said that "dishonour" means that he may be spoken to roughly and "punish" means he may be imprisoned for it.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3622]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3622

Narrated Grandfather of Hirmas ibn Habib:

I brought my debtor to the Holy Prophet (peace_be_upon_him). He said to me: Stick to him. He again said to me: O brother of Banu Tamim, what do you want to do with your prisoner.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3623]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3623

Narrated Mu'awiyah al-Qushayri:

The Prophet (peace_be_upon_him) imprisoned a man on suspicion.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3624]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3624

Narrated Mu'awiyah al-Qushayri:

Bahz ibn Hakim reported from his grandfather: (Ibn Qudamah's version has: His grandfather's brother or uncle reported:) - the narrator Mu'ammal said: - He (his grandfather Mu'awiyah) got up before the Holy Prophet (peace_be_upon_him) who was giving sermon: and he said: Why have your companions arrested my neighbours? He turned away from him twice. He (his grandfather Mu'awiyah) then mentioned something. The Holy Prophet (peace_be_upon_him) then said: Let his neighbours go.

(Mu'ammal did not mention the words "He was giving sermon.")


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3625]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3625

Narrated Jabir ibn Abdullah:

I intended to go (on expedition) to Khaybar. So I came to the Holy Prophet (peace_be_upon_him), greeted him and said: I am intending to go to Khaybar. He said: When you come to my agent, you should take from him fifteen wasqs (of dates). If he asks you for a sign, then place your hand on his collar-bone.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3626]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3626

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If you dispute over a pathway, leave the margin of seven yards.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3628]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3628

Narrated AbuSirmah:

The Prophet (peace_be_upon_him) said: If anyone harms (others), Allah will harm him, and if anyone shows hostility to others, Allah will show hostility to him.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3629]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3629

Narrated Samurah ibn Jundub:

Samurah had a row of palm-trees in the garden of a man of the Ansar. The man had his family with him. Samurah used to visit his palm-trees, and the man was annoyed by that and felt it keenly. So he asked him (Samurah) to sell them to him, but he refused. He then asked him to take something else in exchange, but he refused.

So he came to the Holy Prophet (peace_be_upon_him) and mentioned it to him. The Holy Prophet (peace_be_upon_him) asked him to sell it to him, but he refused. He asked him to take something else in exchange, but he refused.

He then said: Give it to him and you can have such and such, mentioning something with which he tried to please him, but he refused. He then said: You are a nuisance. The Apostle of Allah (peace_be_upon_him) then said to the Ansari: Go and uproot his palm-trees.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3630]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3630

Narrated Abdullah ibn az-Zubayr:

A man disputed with az-Zubayr about streamlets in the lava plain which was irrigated by them. The Ansari said: Release the water and let it run, but az-Zubayr refused. The Holy Prophet (peace_be_upon_him) said to az-Zubayr: Water (your ground), Zubayr, then let the water run to your neighbour. The Ansari then became angry and said: Apostle of Allah! it is because he is your cousin! Thereupon the face of the Apostle of Allah (peace_be_upon_him) changed colour and he said: Water (your ground), then keep back the water till it returns to the embankment. Az-Zubayr said: By Allah! I think this verse came down about that: "But no , by thy Lord! they can have no (real) faith, until they make thee judge....."


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3631]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3631

Narrated Tha'labah ibn AbuMalik:

Tha'labah heard his elders say that a man from the Quraysh had his share with Banu Qurayzah (in water). He brought the dispute to the Apostle of Allah (peace_be_upon_him) about al-Mahzur, a stream whose water they shared together. The Apostle of Allah (peace_be_upon_him) then decided that when water reached the ankles waters should not be held back to flow to the lower.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3632]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3632

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) decided regarding the stream al-Mahzur that its water should be held back till it reached the ankles, and that the upper waters should then be allowed to flow to the lower.


Dawud :: The Office of the Judge (Kitab Al-Aqdiyah) :: [24.3633]

The Office of the Judge (Kitab Al-Aqdiyah)

Dawud :: Book 24 : Hadith 3633

Narrated AbuSa'id al-Khudri:

Two men brought their dispute about the precincts of a palm-tree to the Apostle of Allah (peace_be_upon_him). According to a version of this tradition, he ordered to measure and it was measured. It was found seven yards. According to another version, it was found five yards. He made a decision according to that. AbdulAziz said: He ordered to measure with a branch of its branches. It was then measured.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3634]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3634

Narrated AbudDarda':

Kathir ibn Qays said: I was sitting with AbudDarda' in the mosque of Damascus.

A man came to him and said: AbudDarda, I have come to you from the town of the Apostle of Allah (peace_be_upon_him) for a tradition that I have heard you relate from the Apostle of Allah (peace_be_upon_him). I have come for no other purpose.

He said: I heard the Apostle of Allah (peace_be_upon_him) say: If anyone travels on a road in search of knowledge, Allah will cause him to travel on one of the roads of Paradise. The angels will lower their wings in their great pleasure with one who seeks knowledge, the inhabitants of the heavens and the Earth and the fish in the deep waters will ask forgiveness for the learned man. The superiority of the learned man over the devout is like that of the moon, on the night when it is full, over the rest of the stars. The learned are the heirs of the Prophets, and the Prophets leave neither dinar nor dirham, leaving only knowledge, and he who takes it takes an abundant portion.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3637]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3637

Narrated AbuNamlah al-Ansari:

When he was sitting with the Apostle of Allah (peace_be_upon_him) and a Jew was also with him, a funeral passed by him. He (the Jew) asked (Him): Muhammad, does this funeral speak? The Prophet (peace_be_upon_him) said: Allah has more knowledge. The Jew said: It speaks.

The Apostle of Allah (peace_be_upon_him) said: Whatever the people of the Book tell you, do not verify them, nor falsify them, but say: We believe in Allah and His Apostle. If it is false, do not confirm it, and if it is right, do not falsify it.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3638]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3638

Narrated Zayd ibn Thabit:

The Apostle of Allah (peace_be_upon_him) ordered me (to learn the writing of the Jews), so I learnt for him the writing of the Jews. He said: I swear by Allah, I do not trust Jews in respect of writing for me. So I learnt it, and only a fortnight passed that . I mastered it. I would write for him when he wrote (to them), and read to him when something was written to him.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3639]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3639

Narrated Abdullah ibn Amr ibn al-'As:

I used to write everything which I heard from the Apostle of Allah (peace_be_upon_him). I intended (by it) to memorise it. The Quraysh prohibited me saying: Do you write everything that you hear from him while the Apostle of Allah (peace_be_upon_him) is a human being: he speaks in anger and pleasure? So I stopped writing, and mentioned it to the Apostle of Allah (peace_be_upon_him). He signalled with his finger to him mouth and said: Write, by Him in Whose hand my soul lies, only right comes out from it.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3640]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3640

Narrated Zayd ibn Thabit:

Al-Muttalib ibn Abdullah ibn Hantab said: Zayd ibn Thabit entered upon Mu'awiyah and asked him about a tradition. He ordered a man to write it. Zayd said: The Apostle of Allah (peace_be_upon_him) ordered us not to write any of his traditions. So he erased it.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3644]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3644

Narrated Jundub:

The Prophet (peace_be_upon_him) said: If anyone interprets the Book of Allah in the light of his opinion even if he is right, he has erred.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3645]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3645

Narrated A man:

AbuSalam said on the authority of a man who served the Holy Prophet (peace_be_upon_him) that whenever he talked, he repeated it three times.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3647]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3647

Narrated Aisha, Ummul Mu'minin:

Are you not surprised at AbuHurayrah? He came and sat beside my apartment, and began to narrate traditions from the Apostle of Allah (peace_be_upon_him) making me hear them. I am saying supererogatory prayer. He got up (and went away) before I finished my prayer. Had I found him, I would have replied to him. The Apostle of Allah (peace_be_upon_him) did not narrate traditions quickly one after another as you narrate quickly.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3648]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3648

Narrated Mu'awiyah:

The Holy Prophet (peace_be_upon_him) forbade the discussion of thorny questions.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3649]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3649

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone is given a legal decision ignorantly, the sin rests on the one who gave it. Sulayman al-Mahri added in his version: If anyone advises his brother, knowing that guidance lies in another direction, he has deceived him. These are the wordings of Sulayman.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3650]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3650

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who is asked something he knows and conceals it will have a bridle of fire put on him on the Day of Resurrection.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3651]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3651

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: You hear (from me), and others will hear from you; and people will hear from them who heard from you.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3652]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3652

Narrated Zayd ibn Thabit:

I heard the Apostle of Allah (peace_be_upon_him) say: May Allah brighten a man who hears a tradition from us, gets it by heart and passes it on to others. Many a bearer of knowledge conveys it to one who is more versed than he is; and many a bearer of knowledge is not versed in it.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3654]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3654

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: relate traditions from the children of Isra'il; there is no harm.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3655]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3655

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) used to relate to us traditions from the children of Isra'il till morning came; he would not get up except for obligatory prayer.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3656]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3656

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone acquires knowledge of things by which Allah's good pleasure is sought, but acquires it only to get some worldly advantage, he will not experience the arf, i.e. the odour, of Paradise.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3657]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3657

Narrated Awf ibn Malik al-Ashja'i:

I heard the Apostle of Allah (peace_be_upon_him) say: Only a ruler, or one put in charge, or one who is presumptuous, gives instructions.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3658]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3658

Narrated AbuSa'id al-Khudri:

I was sitting in the company of the poor members of the emigrants. Some of them were sitting together because of lack of clothing while a reader was reciting to us. All of a sudden the Apostle of Allah (peace_be_upon_him) came along and stood beside us. When the Apostle of Allah (peace_be_upon_him) stood, the reader stopped and greeted him.

He asked: What were you doing? We said: Apostle of Allah! We had a reader who was reciting to us and we were listening to the Book of Allah, the Exalted.

The Apostle of Allah (peace_be_upon_him) then said: Praise be to Allah Who has put among my people those with whom I have been ordered to stay. The Apostle of Allah (peace_be_upon_him) then sat among us so as to be like one of us, and when he had made a sign with his hand they sat in a circle with their faces turned towards him.

The narrator said: I think that the Apostle of Allah (peace_be_upon_him) did not recognize any of them except me.

The Apostle of Allah (peace_be_upon_him) then said: Rejoice, you group of poor emigrants, in the announcement that you will have perfect light on the Day of Resurrection. You will enter Paradise half a day before the rich, and that is five hundred years.


Dawud :: Knowledge (Kitab Al-Ilm) :: [25.3659]

Knowledge (Kitab Al-Ilm)

Dawud :: Book 25 : Hadith 3659

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: That I sit in the company of the people who remember Allah the Exalted from morning prayer till the sun rises is clearer to me than that I emancipate four slaves from the children of Isra'il, and that I sit with the people who remember Allah from afternoon prayer till the sun sets is dearer to me than that I emancipate four slaves.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3662]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3662

Narrated Umar ibn al-Khattab:

When the prohibition of wine (was yet to be) declared, Umar said: O Allah, give us a satisfactory explanation about wine.

So the following verse of Surat al-Baqarah revealed; "They ask thee concerning wine and gambling. Say: In them is great sin...." Umar was then called and it was recited to him.

He said: O Allah, give us a satisfactory explanation about wine.

Then the following verse of Surat an-Nisa' was revealed: "O ye who believe! approach not prayers with a mind befogged...." Thereafter the herald of the Apostle of Allah (peace_be_upon_him) would call when the (congregational) prayer was performed: Beware, one who is drunk should not come to prayer. Umar was again called and it was recited to him).

He said: O Allah, give us a satisfactory explanation about wine. This verse was revealed: "Will ye not then abstain?" Umar said: We abstained.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3663]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3663

Narrated Ali ibn AbuTalib:

A man of the Ansar called him and AbdurRahman ibn Awf and supplied them wine before it was prohibited. Ali then led them in the evening prayer, and he recited; "Say: O ye who reject faith." He was confused in it. Then the following verse came down: "O ye who believe! approach not prayers with a mind befogged until you can understand all that ye say.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3665]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3665

Narrated Anas ibn Malik:

I was serving wine to the people in the house of AbuTalhah when it was prohibited and that day our wine was made from unripe dates. A man entered upon us and said: The wine has been prohibited, and the herald of the Apostle of Allah (peace_be_upon_him) made an announcement. We then said: This is the herald of the Apostle of Allah (peace_be_upon_him)


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3666]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3666

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Allah has cursed wine, its drinker, its server, its seller, its buyer, its presser, the one for whom it is pressed, the one who conveys it, and the one to whom it is conveyed.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3668]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3668

Narrated An-Nu'man ibn Bashir:

The Prophet (peace_be_upon_him) said: from grapes wine is made, from dried dates wine is made, from honey wine is made, from wheat wine is made, from barley wine is made.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3669]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3669

Narrated An-Nu'man ibn Bashir:

I heard the Apostle of Allah (peace_be_upon_him) say: Wine is made from grape-syrup, raisins, dried dates, wheat, barley, millet, and I forbid you from every intoxicant.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3672]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3672

Narrated Abdullah Ibn Abbas:

The Apostle of Allah (peace_be_upon_him) said: Every intoxicant is khamr (wine) and every intoxicant is forbidden. If anyone drinks wine, Allah will not accept prayer from him for forty days, but if he repents, Allah will accept his repentance. If he repeats it a fourth time, it is binding on Allah that He will give him tinat al-khabal to drink.

He was asked: What is tinat al-khabal, Apostle of Allah? He replied: Discharge of wounds, flowing from the inhabitants of Hell. If anyone serves it to a minor who does not distinguish between the lawful and the unlawful, it is binding on Allah that He will give him to drink the discharge of wounds, flowing from the inhabitants of Hell.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3673]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3673

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If a large amount of anything causes intoxication, a small amount of it is prohibited.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3675]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3675

Narrated Daylam al-Himyari:

I asked the Prophet (peace_be_upon_him) and said: Apostle of Allah! we live in a cold land in which we do heavy work and we make a liquor from wheat to get strength from if for our work and to stand the cold of our country. He asked: Is it intoxicating? I replied: Yes. He said: You must avoid it. I said: The people will not abandon it. He said: If they do not abandon it, fight with them.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3677]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3677

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) forbade wine (khamr), game of chance (maysir), drum (kubah), and wine made from millet (ghubayrah), saying: Every intoxicant is forbidden.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3678]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3678

Narrated Umm Salamah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) forbade every intoxicant and everything which produces languidness.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3679]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3679

Narrated Aisha, Ummul Mu'minin:

I heard the Apostle of Allah (peace_be_upon_him) say: Every intoxicant is forbidden; if a faraq of anything causes intoxication, a handful of it is forbidden.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3680]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3680

Narrated AbdurRahman ibn Ghanam:

Malik ibn AbuMaryam said: AbdurRahman ibn Ghanam entered upon us and we discussed tila' and he said: AbuMalik al-Ash'ari told me that he heard the Apostle of Allah (peace_be_upon_him) say: Some of my people will assuredly drink wine calling it by another name.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3685]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3685

Narrated Abdullah ibn Abbas:

In the story of the deputation of AbdulQays Ibn Abbas said: They (the people) asked: In which should we drink, Prophet of Allah? The Prophet (peace_be_upon_him) said: You should use those skin vessels that are tied at their mouths.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3686]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3686

Narrated Qays ibn an-Nu'man:

The Prophet (peace_be_upon_him) said: Do not drink from hollowed stumps, vessel smeared with pitch, pumpkins, and green jars, but drink from a skin which is tied with string. If the drink ferments, lighten it by infusing water. If you are helpless, then pour it away.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3688]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3688

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) forbade us the use of pumpkins, green jars, hollow stumps and wine made from barley.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3689]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3689

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: I forbade you three things, and now I command (permit) you for them. I forbade you to visit graves, now you may visit them, for in visiting them there is admonition. I forbade you drinks except from skin vessels, but now you may drink from any kind of vessels, but do not drink an intoxicant. I forbade you to eat the meat of sacrificial animals after three days, but now you may eat and enjoy it during your journeys.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3696]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3696

Narrated A man:

A man from among the Companions of the Prophet (peace_be_upon_him) said: The Prophet (peace_be_upon_him) forbade (mixing) unripe dates and dried dates, and (mixing) raisins and dried dates.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3697]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3697

Narrated Umm Salamah, Ummul Mu'minin:

Kabshah, daughter of AbuMaryam, asked Umm Salamah (Allah be pleased with her): What did the Prophet (peace_be_upon_him) prohibit? She replied: He forbade us to boil dates so much so that the kernels are spoiled, and to mix raisins and dried dates.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3698]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3698

Narrated Aisha, Ummul Mu'minin:

Raisins were steeped for the Apostle of Allah (peace_be_upon_him) and then dried dates were infused in them, or dried dates were steeped and then raisins were infused in them.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3699]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3699

Narrated Aisha, Ummul Mu'minin:

Safiyyah, daughter of Atiyyah, said: I entered upon Aisha with some women of AbdulQays, and asked her about mixing dried dates and raisins (for drink). She replied: I used to take a handful of dried dates and a handful or raisins and put them in a vessel, and then crush them (and soak in water). Then I would give it to the Prophet (peace_be_upon_him) to drink.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3701]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3701

Narrated Ad-Daylami:

We came to the Prophet (peace_be_upon_him) and said to him: Apostle of Allah, you know who we are, from where we are and to whom we have come. He said: To Allah and His Apostle. We said: Apostle of Allah, we have grapes; what should we do with them? He said: Make them raisins. We then asked: What should we do with raisins? He replied: Steep them in the morning and drink in the evening, and steep them in the evening and drink in the morning. Steep them in skin vessels and do not steep them in earthen jar, for it it is delayed in pressing, it becomes vinegar.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3703]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3703

Narrated Aisha, Ummul Mu'minin:

Amrah said on the authority of Aisha that she would steep dates for the Apostle of Allah (peace_be_upon_him) in the morning. When the evening came, he took his dinner and drank it after his dinner. If anything remained, she poured it out. She then would steep for him at night. When the morning came, he took his morning meal and drank it after his morning meal. She said: The skin vessel was washed in the morning and in the evening. My father (Hayyan) said to her: Twice a day? She said: Yes.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3707]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3707

Narrated AbuHurayrah:

I knew that the Apostle of Allah (peace_be_upon_him) used to keep fast. I waited for the day when he did not fast to present him the drink (nabidh) which I made in a pumpkin. I then brought it to him while it fermented. He said: Throw it to this wall, for this is a drink of the one who does not believe in Allah and the Last Day.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3708]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3708

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) forbade that a man should drink while standing.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3712]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3712

Narrated A man of the Ansar:

The Prophet (peace_be_upon_him) called for a skin-vessel on the day of the battle of Uhud. He then said: Invert the head of the vessel and he drank from its mouth.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3716]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3716

Narrated Abdullah ibn AbuAwfa:

The Prophet (peace_be_upon_him) said: The supplier of the people is the last (man) to drink.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3719]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3719

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) forbade blowing or breathing into a vessel.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3721]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3721

Narrated Abdullah ibn Abbas:

I was in the house of Maymunah. The Apostle of Allah (peace_be_upon_him) accompanied by Khalid ibn al-Walid entered. Two roasted long-tailed lizards (dabb) placed on the sticks were brought to him. The Apostle of Allah (peace_be_upon_him) spat. Khalid said: I think that you abominate it, Apostle of Allah. He said: Yes. Then the Apostle of Allah (peace_be_upon_him) was brought milk, and he drank (it). The Apostle of Allah (peace_be_upon_him) then said: When one of you eats food, he should say: O Allah, bless us in it, and give us food (or nourishment) better than it. When he is given milk to drink he should say: O Allah! bless us in it and give us more of it, for no food or drink satisfies like milk.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3722]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3722

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Shut your door and make mention of Allah's name, for the devil does not open a door which has been shut; extinguish your lamp and make mention of Allah's name, cover up your vessel even by a piece of wood that you just put on it and make mention of Allah's name, and tie up your water-skin mentioning Allah's name.


Dawud :: Drinks (Kitab Al-Ashribah) :: [26.3726]

Drinks (Kitab Al-Ashribah)

Dawud :: Book 26 : Hadith 3726

Narrated Aisha, Ummul Mu'minin:

The water from as-Suqya' was considered sweetest by the Prophet (peace_be_upon_him). Qutaybah said: it was a well on two days' journey from Medina.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3732]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3732

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: He who does not accept an invitation which he receives has disobeyed Allah and His Apostle of, and he who enters without invitation enters as a thief and goes out as a raider.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3735]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3735

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) held a wedding feast) for Safiyyah with meal and dates.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3736]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3736

Narrated Zubayr ibn Uthman:

The Prophet (peace_be_upon_him) said: The wedding feast on the first day is a duty, that on the second is a good practice, but that on the third day is to make men hear of it and show it to them. Qatadah said: A man told me that Sa'id ibn al-Musayyab was invited (to a wedding feast on the first day and he accepted it. He was again invited on the second day, and he accepted. When he was invited on the third day, he did not accept; he said: They are the people who make men hear of it and show it to them.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3738]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3738

Narrated Jabir ibn Abdullah:

When the Prophet (peace_be_upon_him) returned to Medina, he would slaughter a camel or a cow.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3740]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3740

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Hospitality extend for three days, and what goes beyond that is sadaqah (charity).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3741]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3741

Narrated AbuKarimah:

The Prophet (peace_be_upon_him) said: It is a duty of every Muslim (to provide hospitality) to a guest for a night. If anyone comes in the morning to his house, it is a debt due to him. If he wishes, he may fulfil it, and if he wishes he may leave it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3742]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3742

Narrated Al-Miqdam AbuKarimah:

The Prophet (peace_be_upon_him) said: If any Muslim is a guest of people and is given nothing, it is the duty of every Muslim to help him to the extent of taking for him from their crop and property for the entertainment of one night.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3744]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3744

Narrated Abdullah Ibn Abbas:

When the verse: "O ye who believe! eat not up your property among yourselves in vanities, but let there be amongst you traffic and trade by mutual good will" was revealed, a man thought it a sin to eat in the house of another man after the revelation of this verse.

Then this (injunction) was revealed by the verse in Surat an-Nur: "No blame on you whether you eat in company or separately."

When a rich man (after revelation) invited a man from his people to eat food in his house, he would say: I consider it a sin to eat from it, and he said: a poor man is more entitled to it than I. The Arabic word tajannah means sin or fault. It was then declared lawful to eat something on which the name of Allah was mentioned, and it was made lawful to eat the flesh of an animal slaughtered by the people of the Book.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3745]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3745

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) forbade that the food of two people who were rivalling on another should be eaten


Dawud :: Foods (Kitab Al-At'imah) :: [27.3746]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3746

Narrated Ali ibn AbuTalib:

Safinah AbuAbdurRahman said that a man prepared food for Ali ibn AbuTalib who was his guest, and Fatimah said: I wish we had invited the Apostle of Allah (peace_be_upon_him) and he had eaten with us. They invited him, and when he came he put his hands on the side-ports of the door, but when he saw the figured curtain which had been put at the end of the house, he went away. So Fatimah said to Ali: Follow him and see what turned him back. I (Ali) followed him and asked: What turned you back, Apostle of Allah? He replied: It is not fitting for me or for any Prophet to enter a house which is decorated.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3747]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3747

Narrated AbdurRahman al-Himyari:

A companion of the Prophet (peace_be_upon_him) reported him as saying: When two people come together to issue an invitation, accept that of the one whose door is nearer in neighbourhood, but if one of them comes before the other accept the invitation of the one who comes first.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3749]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3749

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Prayer should not be postponed for taking meals nor for any other thing.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3750]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3750

Narrated Abdullah ibn Umar:

Abdullah ibn Ubaydullah ibn Umayr said: I was with my father in the time of Ibn az-Zubayr sitting beside Abdullah ibn Umar. Then Abbad ibn Abdullah ibn az-Zubayr said: We have heard that the evening meal is taken just before the night prayer. Thereupon Abdullah ibn Umar said: Woe to you! what was their evening meal? Do you think it was like the meal of your father?


Dawud :: Foods (Kitab Al-At'imah) :: [27.3751]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3751

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) came out from the privy and was presented to him. They (the people) asked: Should we bring you water for ablution? He replied: I have been commanded to perform ablution when I get up for prayer.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3752]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3752

Narrated Salman al-Farsi:

I read in the Torah that the blessing of food consists in ablution before it. So I mentioned it to the Prophet (peace_be_upon_him). He said: The blessing of food consists in ablution before it and ablution after it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3753]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3753

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) came out from the valley of a mountain where he had eased himself. There were some dried dates on a shield before us. We called him and he ate with us. He did not touch water.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3755]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3755

Narrated Wahshi ibn Harb:

The Companions of the Prophet (peace_be_upon_him) said: Apostle of Allah (peace_be_upon_him) we eat but we are not satisfied. He said: Perhaps you eat separately. They replied: Yes. He said: If you gather together at your food and mention Allah's name, you will be blessed in it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3758]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3758

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: When one of you eats, he should mention Allah's name; if he forgets to mention Allah's name at the beginning, he should say: "In the name of Allah at the beginning and at the end of it."


Dawud :: Foods (Kitab Al-At'imah) :: [27.3759]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3759

Narrated Umayyah ibn Makhshi:

Umayyah was sitting and a man was eating. He did not mention Allah's name until there remained the last morsel. When he raised it to his mouth, he said: In the name of Allah at the beginning and at the end of it. The Prophet (peace_be_upon_him) laughed and said: The devil kept eating along with him, but when he mentioned Allah's name, he vomited what was in his belly.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3761]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3761

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) was never seen reclining while eating, nor walking with two men at his heels.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3763]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3763

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: When one of you eats, he must not eat from the top of the dish, but should eat from the bottom; for the blessing descends from the top of it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3764]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3764

Narrated Abdullah ibn Busr:

The Prophet (peace_be_upon_him) had a bowl called gharra'. It was carried by four persons. When the sun rose high, and they performed the forenoon prayer, the bowl in which tharid was prepared was brought, and the people gathered round it. When they were numerous, the Apostle of Allah (peace_be_upon_him) said: Allah has made me a respectable servant, and He did not make me an obstinate tyrant. The Apostle of Allah (peace_be_upon_him) said: Eat from it sides and leave its top, the blessing will be conferred on it


Dawud :: Foods (Kitab Al-At'imah) :: [27.3765]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3765

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) forbade two kinds of food: to sit at cloth on which wine is drunk, and to eat by a man while lying on his stomach.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3768]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3768

Narrated Umar ibn AbuSalamah:

The Prophet (peace_be_upon_him) said: Come near, my son, mention Allah's name, eat with your right hand and eat from what is next to you.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3769]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3769

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: Do not eat meat with a knife, for it is a foreign practice, but bite it, for it is more beneficial and wholesome.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3770]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3770

Narrated Safwan ibn Umayyah:

I was eating with the Prophet (peace_be_upon_him) and snatching the meat from the bone with my hand. He said: bring the bone near your mouth, for it is more beneficial and wholesome.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3771]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3771

Narrated Abdullah ibn Mas'ud:

The bone dearer to the Apostle of Allah (peace_be_upon_him) was the bone of sheep.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3772]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3772

Narrated Abdullah ibn Mas'ud:

The tradition mentioned above (No. 3771) has also been narrated by Ibn Mas'ud with a different chain of narrators.

This version has: The Prophet (peace_be_upon_him) liked the foreleg (of a sheep). Once the foreleg was poisoned, and he thought that the Jews had poisoned it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3774]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3774

Narrated Abdullah ibn Abbas:

The food the Apostle of Allah (peace_be_upon_him) liked best was tharid made from bread and tharid made from Hays.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3775]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3775

Narrated Qabisah ibn Halb:

A man asked the Apostle of Allah (peace_be_upon_him): Is there any food from which I should keep myself away? I heard the Apostle of Allah (peace_be_upon_him) say: Anything which creates doubt should not occur in your mind by which you resemble Christianity.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3776]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3776

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) prohibited eating the animal which feeds on filth and drinking its milk.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3777]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3777

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) prohibited to drink the milk of the animal which feeds on filth.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3778]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3778

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) forbade riding the camel which feeds on filth and drinking its milk.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3780]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3780

Narrated Jabir ibn Abdullah:

On the day of Khaybar we slaughtered horses, mules, and assess. The Apostle of Allah (peace_be_upon_him) forbade us (to eat) mules and asses, but he did not forbid horse-flesh.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3781]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3781

Narrated Khalid ibn al-Walid:

The Apostle of Allah (peace_be_upon_him) forbade us to eat horse-flesh, the flesh of mules and of asses. The narrator Haywah added: Every beast of prey with a fang.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3786]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3786

Narrated Thabit ibn Wadi'ah:

We were in an army with the Apostle of Allah (peace_be_upon_him). We got some lizards. I roasted one lizard and brought it to the Apostle of Allah (peace_be_upon_him) and placed it before him. He took a stick and counted its fingers. He then said: A group from the children of Isra'il was transformed into an animal of the land, and I do not know which animal it was. He did not eat it nor did he forbid (its eating).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3787]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3787

Narrated AbdurRahman ibn Shibl:

The Apostle of Allah (peace_be_upon_him) forbade to eat the flesh of lizard.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3788]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3788

Narrated Safinah:

I ate the flesh of a bustard along with the Prophet (peace_be_upon_him).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3789]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3789

Narrated at-Talabb ibn Tha'labah at-Tamimi:

I accompanied the Apostle of Allah (peace_be_upon_him), but I did not hear about the prohibition of (eating) insects and little creatures of land.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3790]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3790

Narrated Abdullah ibn Umar:

Numaylah said: I was with Ibn Umar. He was asked about eating hedgehog. He recited: "Say: I find not in the message received by me by inspiration any (meat) forbidden." An old man who was with him said: I heard AbuHurayrah say: It was mentioned to the Apostle of Allah (peace_be_upon_him). Noxious of the noxious. Ibn Umar said: If the Apostle of Allah (peace_be_upon_him) had said it, it is as he said that we did not know.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3791]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3791

Narrated Abdullah ibn Abbas:

The people of pre-Islamic times used to eat some things and leave others alone, considering them unclean. Then Allah sent His Prophet (peace_be_upon_him) and sent down His Book, marking some things lawful and others unlawful; so what He made lawful is lawful, what he made unlawful is unlawful, and what he said nothing about is allowable. And he recited: "Say: I find not in the message received by me by inspiration any (meat) forbidden to be eaten by one who wishes to eat it...." up to the end of the verse.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3792]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3792

Narrated Jabir ibn Abdullah:

I asked the Apostle of Allah (peace_be_upon_him) about the hyena. He replied: It is game, and if one who is wearing ihram (pilgrim's robe) hunts it, he should give a sheep as atonement.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3795]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3795

Narrated Al-Miqdam ibn Ma'dikarib:

The Prophet (peace_be_upon_him) said: Beware, the fanged beast of prey is not lawful, nor the domestic asses, nor the find from the property of a man with whom treaty has been concluded, except that he did not need it. If anyone is a guest of people who provide no hospitality for him, he is entitled to take from them the equivalent of the hospitality due to him.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3796]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3796

Narrated Abdullah ibn Abbas:

On the day of Khaybar the Apostle of Allah (peace_be_upon_him) prohibited eating every beast of prey, and every bird with a talon.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3797]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3797

Narrated Khalid ibn al-Walid:

I went with the Apostle of Allah (peace_be_upon_him) to fight at the battle of Khaybar, and the Jews came and complained that the people had hastened to take their protected property (as a booty), so the Apostle of Allah (peace_be_upon_him) said: The property of those who have been given a mules, every fanged beast of prey, and every bird with a talon are forbidden for you.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3798]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3798

Narrated Jabir ibn Abdullah:

AbuzZubayr quoted the authority of Jabir ibn Abdullah for the statement that the Prophet (peace_be_upon_him) forbade payment for a dog. Ibn AbdulMalik said: to eat a cat and to enjoy its price.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3800]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3800

Narrated Ghalib ibn Abjar:

We faced a famine, and I had nothing from my property which I could feed my family ex except a few asses, and the Prophet (peace_be_upon_him) forbade the flesh of domestic asses. So I came to the Prophet (peace_be_upon_him) and said: Apostle of Allah (may peace be upon) , we are suffering from famine, and I have no property which I feed my family except some fat asses, and you have forbidden the flesh of domestic asses. He said: Feed your family on the fat asses of yours, for I forbade them on account of the animal which feeds on the filth of the town, that is, the animal which feeds on filth.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3802]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3802

Narrated Abdullah ibn Amr ibn al-'As:

On the day of Khaybar the Apostle of Allah (may pease be upon him) forbade (eating) the flesh of domestic asses, and the animal which feeds on filth: riding it and eating its flesh.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3804]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3804

Narrated Salman al-Farsi:

The Apostle of Allah (peace_be_upon_him) was asked about (eating) locusts. He replied: They are the most numerous of Allah's hosts. I neither eat them nor declare them unlawful.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3806]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3806

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: What the sea throws up and is left by the tide you may eat, but what dies in the sea and floats you must not eat.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3807]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3807

Narrated Jabir ibn Samurah:

A man alighted at Harrah with his wife and children. A man said (to him): My she-camel has strayed; if you find it, detain it.

He found it, but did not find its owner, and it fell ill. His wife said: Slaughter it. But he refused and it died.

She said: Skin it so that we may dry its fat and flesh and then eat them.

He said: Let me ask the Apostle of Allah (peace_be_upon_him). So he came to him (the Prophet) and asked him. He said: Have you sufficient for your needs? He replied: No. He then said: Then eat it.

Then its owner came and he told him the story. He said: Why did you not slaughter it? He replied: I was ashamed (or afraid) of you.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3808]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3808

Narrated Al-Faji' ibn Abdullah al-Amiri:

Al-Faji' came to the Apostle of Allah (peace_be_upon_him) and asked: Is not dead meat lawful for us? He said: What is your food? We said: Some food in the evening and some in the morning. AbuNu'aym said: Uqbah explained it to me saying: a cup (of milk) in the morning and a cup in the evening; this does not satisfy the hunger. So made the carrion lawful for them in this condition.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3809]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3809

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: I wish I had a white loaf made from tawny and softened with clarified butter and milk. A man from among the people got up and getting one brought it. He asked: In which had it been? He replied: In a lizard skin. He said: Take it away.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3810]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3810

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) was brought a piece of cheese in Tabuk. He called for a knife, mentioned Allah's name and cut it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3814]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3814

Narrated AbuSa'id al-Khudri:

The garlic and onions were mentioned before the Apostle of Allah (peace_be_upon_him). He was told: The most severe of them is garlic. Would you make it unlawful? The Prophet (peace_be_upon_him) said: Eat it, and he who eats it should not come near this mosque until its odour goes away.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3815]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3815

Narrated Hudhayfah ibn al-Yaman:

Zirr ibn Hubaysh said: Hudhayfah traced, I think, to the Apostle of Allah (peace_be_upon_him) the saying: He who spits in the direction of the qiblah will come on the Day of Resurrection in the state that his saliva will be between his eyes; and he who eats from this noxious vegetable should not come near our mosque, saying it three times.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3816]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3816

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: He who eats from this plant should not come near the mosques.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3817]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3817

Narrated Al-Mughirah ibn Shu'bah:

I ate garlic and came to the place where the Prophet (peace_be_upon_him) was praying; one rak'ah of prayer had been performed when I joined. When I entered the mosque, the Prophet (peace_be_upon_him) noticed the odour of garlic.

When the Apostle of Allah (peace_be_upon_him) finished his prayer, he said: He who eats from this plant should not come near us until its odour has gone away.

When I finished the prayer, I came to the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah, do give me your hand. Then I put his hand in the sleeve of my shirt, carrying it to my chest to show that my chest was fastened with a belt. He said: You have a (valid) excuse.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3818]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3818

Narrated Mu'awiyah ibn Qurrah:

The Apostle of Allah (peace_be_upon_him) forbade these two plants (i.e. garlic and onions), and he said: He who eats them should not come near our mosque. If it is necessary to eat them, make them dead by cooking, that is, onions and garlic.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3819]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3819

Narrated Ali ibn AbuTalib:

It is forbidden to eat garlic unless it is cooked.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3820]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3820

Narrated Aisha, Ummul Mu'minin:

Khalid said: AbuZiyad Khiyar ibn Salamah asked Aisha about onions. She replied: The last food which the Apostle of Allah (peace_be_upon_him) ate was some which contained onions.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3821]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3821

Narrated Yusuf ibn Abdullah ibn Salam:

I saw that the Prophet (peace_be_upon_him) took a piece of break of barley and put a date on it and said: This is the condiment of this.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3823]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3823

Narrated Anas ibn Malik:

When the Prophet (peace_be_upon_him) was brought some old dates, he began to examine them and remove the worms from them.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3824]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3824

Narrated Abdullah ibn AbuTalhah:

The Prophet (peace_be_upon_him) was brought some dates which contained worms. He then mentioned the rest of the tradition to the same effect as the previous (No 3823).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3827]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3827

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to eat melon with fresh dates, and he used to say: The heat of the one is broken by the coolness of the other, and the coolness of the one by the heat of the other.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3828]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3828

Narrated Abdullah ibn Busr ibn Atiyyah ibn Busr:

The Apostle of Allah (peace_be_upon_him) came to visit us and we offered him butter and dates, for he liked butter and dates.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3829]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3829

Narrated Jabir ibn Abdullah:

I was on an expedition along with the Apostle of Allah (peace_be_upon_him). We got the vessels and skins of the polytheists and used them. But he did not object to them 9i.e. us) for that (action).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3833]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3833

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When a mouse falls into clarified butter, if it is sold, throw the mouse and what is around it away, but if it is in a liquid state, do not go near it. Al-Hasan said: AbdurRazzaq said: This tradition has been transmitted by Ma'mar, from az-Zuhri, from Ubaydullah ibn Abdullah ibn Abbas, from Maymunah, from the Prophet (peace_be_upon_him).


Dawud :: Foods (Kitab Al-At'imah) :: [27.3834]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3834

Narrated Abdullah ibn Abbas:

The tradition mentioned above (No. 3833) has also been transmitted by Ibn Abbas from Maymunah, from the Prophet (peace_be_upon_him) like the tradition narrated by az-Zuhri, from Ibn al-Musayyab.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3841]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3841

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) finished his food, he said: "Praise be to Allah Who has given us food and drink and made us Muslims."


Dawud :: Foods (Kitab Al-At'imah) :: [27.3842]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3842

Narrated AbuAyyub al-Ansari:

When the Apostle of Allah (peace_be_upon_him) ate or drank, he said: "Praise be to Allah Who has given food and drink and made it easy to swallow, and provided an exit for it.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3843]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3843

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone spends the night with grease on his hand which he has not washed away, he can blame only himself if some trouble comes to him.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3844]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3844

Narrated Jabir ibn Abdullah:

AbulHaytham ibn at-Tayhan prepared food for the Apostle of Allah (peace_be_upon_him), and he invited the Prophet (peace_be_upon_him) and his Companions. When they finished (food), the said: If some people enter the house of a man, his food is eaten and his drink is drunk, and they supplicate (to Allah) for him, this is his reward.


Dawud :: Foods (Kitab Al-At'imah) :: [27.3845]

Foods (Kitab Al-At'imah)

Dawud :: Book 27 : Hadith 3845

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) came to visit Sa'd ibn Ubaydah, and he brought bread and olive oil, and he ate (them). Them). Then the Prophet (peace_be_upon_him) said: May the fasting (men) break their fast with you, and the pious eat your food, and the angels pray for blessing on you.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3846]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3846

Narrated Usamah ibn Sharik:

I came to the Prophet (peace_be_upon_him) and his Companions were sitting as if they had birds on their heads. I saluted and sat down. The desert Arabs then came from here and there. They asked: Apostle of Allah, should we make use of medical treatment? He replied: Make use of medical treatment, for Allah has not made a disease without appointing a remedy for it, with the exception of one disease, namely old age.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3847]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3847

Narrated Umm al-Mundhar bint Qays al-Ansariyyah:

The Apostle of Allah (peace_be_upon_him) came to visit me, accompanied by Ali who was convalescing. We had some ripe dates hung up. The Apostle of Allah (peace_be_upon_him) got up and began to eat from them.

Ali also got up to eat, but the Apostle of Allah (peace_be_upon_him) said repeatedly to Ali: Stop, Ali, for you are convalescing, and Ali stopped.

She said: I then prepared some barley and beer-root and brought it. The Apostle of Allah (peace_be_upon_him) then said: Take some of this, Ali, for it will be more beneficial for you. AbuDawud said: The narrator Harun said: al-Adawiyyah (i.e. Umm al-Mundhar).


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3848]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3848

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The best medical treatment you apply is cupping.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3849]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3849

Narrated Salmah:

the maid-servant of the Apostle of Allah (peace_be_upon_him), said: No one complained to the Apostle of Allah (peace_be_upon_him) of a headache but he told him to get himself cupped, or of a pain in his legs but he told him to dye them with henna.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3850]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3850

Narrated AbuKabshah al-Ansari:

The Apostle of Allah (peace_be_upon_him) used to have himself cupped on the top of his head and between his shoulders, and that he used to say: If anyone pours out any of his blood, he will not suffer if he applies no medical treatment for anything.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3851]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3851

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) had himself cupped three times in the veins at the sides of the neck and on the shoulder. Ma'mar said: I got myself cupped, and I lost my memory so much so that I was instructed Surat al-Fatihah by others in my prayer. He had himself cupped at the top of his head.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3852]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3852

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone has himself cupped on the 17th, 19th and 21st it will be a remedy for every disease.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3853]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3853

Narrated Kabshah daughter of AbuBakrah:

(the narrator other than Musa said that Kayyisah daughter of AbuBakrah) She said that her father used to forbid his family to have themselves cupped on a Tuesday, and used to assert on the authority of the Apostle of Allah (peace_be_upon_him) that Tuesday is the day of blood in which there is an hour when it does not stop.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3854]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3854

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) had himself cupped above the thigh for a contusion from which he suffered.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3855]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3855

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) sent a physician to Ubayy (ibn Ka'b), and he cut his vein.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3856]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3856

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) forbade to cauterise; we cauterised but they (cauterisation) did not benefit us, nor proved useful for us.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3859]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3859

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) was asked about a charm for one who is possessed (nashrah). He replied: It pertains to the work of the devil.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3860]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3860

Narrated Abdullah ibn Amr ibn al-'As:

I heard the Apostle of Allah (peace_be_upon_him) say: If I drink an antidote, or tie an amulet, or compose poetry, I am the type who does not care what he does.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3861]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3861

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) prohibited unclean medicine.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3862]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3862

Narrated AbdurRahman ibn Uthman:

When a physician consulted the Prophet (peace_be_upon_him) about putting frogs in medicine, he forbade him to kill them.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3864]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3864

Narrated Tariq ibn Suwayd or Suwayd ibn Tariq:

Wa'il said: Tariq ibn Suwayd or Suwayd ibn Tariq asked the Prophet (peace_be_upon_him) about wine, but he forbade it. He again asked him, but he forbade him. He said to him: Prophet of Allah, it is a medicine. The Prophet (peace_be_upon_him) said: No it is a disease.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3865]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3865

Narrated AbudDarda:

The Prophet (peace_be_upon_him) said: Allah has sent down both the disease and the cure, and He has appointed a cure for every disease, so treat yourselves medically, but use nothing unlawful.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3866]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3866

Narrated Sa'd:

I suffered from an illness. The Apostle of Allah (peace_be_upon_him) came to pay a visit to me. He put his hands between my nipples and I felt its coolness at my heart. He said: You are a man suffering from heart sickness. Go to al-Harith ibn Kaladah, brother of Thaqif. He is a man who gives medical treatment. He should take seven ajwah dates of Medina and grind them with their kernels, and then put them into your mouth.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3869]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3869

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Wear your white garments, for they are among your best garments, and shroud your dead in them. Among the best types of collyrium you use is antimony (ithmid): it clears the vision and makes the hair sprout.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3871]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3871

Narrated Aisha, Ummul Mu'minin:

The man casting evil would be commanded to perform ablution, and then the man affected was washed with it.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3872]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3872

Narrated Asma', daughter of Yazid ibn as-Sakan,:

I heard the Apostle of Allah (peace_be_upon_him) as saying: Do not kill your children secretly, for the milk, with which a child is suckled while his mother is pregnant, overtakes the horseman and throws him from his horse.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3874]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3874

Narrated Abdullah ibn Mas'ud:

Zaynab, the wife of Abdullah ibn Mas'ud, told that Abdullah said: I heard the Apostle of Allah (peace_be_upon_him) saying: spells, charms and love-potions are polytheism.

I asked: Why do you say this? I swear by Allah, when my eye was discharging I used to go to so-and-so, the Jew, who applied a spell to me. When he applied the spell to me, it calmed down. Abdullah said:

That was just the work of the Devil who was picking it with his hand, and when he uttered the spell on it, he desisted. All you need to do is to say as the Apostle of Allah (peace_be_upon_him) used to say: Remove the harm, O Lord of men, and heal. Thou art the Healer. There is no remedy but Thine which leaves no disease behind.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3875]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3875

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: No spell is to be used except for the evil eye or a scorpion sting.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3876]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3876

Narrated Thabit ibn Qays ibn Shammas:

The Apostle of Allah (peace_be_upon_him) entered upon Thabit ibn Qays. The version of Ahmad (ibn Salih) has: When he was ill He (the Prophet) said: Remove the harm, O Lord of men, from Thabit ibn Qays ibn Shammas. He then took some dust of Bathan, and put it in a bowel, and then mixed it with water and blew in it, and poured it on him.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3878]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3878

Narrated Ash-Shifa', daughter of Abdullah,:

The Apostle of Allah (peace_be_upon_him) entered when I was with Hafsah, and he said to me: Why do you not teach this one the spell for skin eruptions as you taught her writing.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3879]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3879

Narrated Sahl ibn Hunayf:

I passed by a river. I entered it and took a bath in it. When I came out, I had fever. The Apostle of Allah (peace_be_upon_him) was informed about it. He said: Ask AbuThabit to seek refuge in Allah from that I asked: O my Lord, will the spell be useful? He replied: No, the spell is to be used except for the evil eye or a snake bite or a scorpion sting.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3883]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3883

Narrated AbudDarda':

I heard the Apostle of Allah (peace_be_upon_him) say: If any of you is suffering from anything or his brother is suffering, he should say: Our Lord is Allah Who is in the heaven, holy is Thy name, Thy command reigns supreme in the heaven and the earth, as Thy mercy in the heaven, make Thy mercy in the earth; forgive us our sins, and our errors; Thou art the Lord of good men; send down mercy from Thy mercy, and remedy, and remedy from Thy remedy on this pain so that it is healed up.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3884]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3884

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) sued to teach them the following words in the case of alarm: I seek refuge in Allah's perfect words from His anger, the evil of His servants, the evil suggestions of the devils and their presence. Abdullah ibn Amr used to teach them to those of his children who had reached puberty, and he wrote them down (on some material) and hung on the child who had not reached puberty.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3887]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3887

Narrated Alaqah ibn Sahar at-Tamimi:

Alaqah came to the Apostle of Allah (may peace be upon him) and embraced Islam. He then came back from him and passed some people who had a lunatic fettered in chains.

His people said: We are told that your companion has brought some good. Have you something with which you can cure him? I then recited Surat al-Fatihah and he was cured. They gave me one hundred sheep. I then came to the Apostle of Allah (peace_be_upon_him) and informed him of it.

He asked: Is it only this? The narrator, Musaddad, said in his other version: Did you say anything other than this? I said: No. He said: Take it, for by my life, some accept if for a worthless chain, but you have done so for a genuine one.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3889]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3889

Narrated AbuSalih Zakwan as-Samman:

A man from Aslam tribe said: I was sitting with the Apostle of Allah (peace_be_upon_him). A man from among his Companions came and said: Apostle of Allah! I have been stung last night, and I could not sleep till morning. He asked: What was that? He replied: A scorpion.

He said: Oh, had you said in the evening: "I take refuge in the perfect words of Allah from the evil of what He created," nothing would have harmed you, Allah willing.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3890]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3890

Narrated AbuHurayrah:

A man who was stung by a scorpion was brought to the Prophet (peace_be_upon_him). He said: Had he said the word: "I seek refuge in the perfect words of Allah from the evil of what He created, "he would not have been stung, or he said, "It would not have harmed him."


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3892]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3892

Narrated Alaqah ibn Sahar at-Tamimi:

We proceeded from the Apostle of Allah (peace_be_upon_him) and came to a clan of the Arabs.

They said: We have been told that you have brought what is good from this man. Have you any medicine or a charm, for we have a lunatic in chains?

We said: Yes. Then they brought a lunatic in chains. He said: I recited Surat al-Fatihah over him for three days, morning and evening. Whenever I finished it, I would collect my saliva and spit it out, and he seemed as if he were set free from a bond. He said: They gave me some payment, but I said: No, not until I ask the Apostle of Allah (peace_be_upon_him).

He (the Prophet) said: Accept it, for, by my life, some accept it for a worthless charm, but you have done so for a genuine one.


Dawud :: Medicine (Kitab Al-Tibb) :: [28.3894]

Medicine (Kitab Al-Tibb)

Dawud :: Book 28 : Hadith 3894

Narrated Aisha, Ummul Mu'minin:

My mother intended to make me fat to send me to the (house of) the Apostle of Allah (peace_be_upon_him). But nothing which he desired benefited me till she gave me cucumber with fresh dates to eat. Then I became fat as good (as she desired).


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3895]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3895

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone resorts to a diviner and believes in what he says (according) to the version of Musa), or has intercourse with his wife (according to the agreed version) when she is menstruating, or has intercourse with his wife through her anus, he has nothing to do with what has been sent down to Muhammad (peace_be_upon_him) - according to the version of Musaddad.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3896]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3896

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone acquires any knowledge of astrology, he acquires a branch of magic of which he gets more as long as he continues to do so.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3898]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3898

Narrated Qabisah:

I heard the Apostle of Allah (peace_be_upon_him) say: Augury from the flight of birds, taking evil omens and the practice of pressomancy pertain to divination. Tarq: It is used in the sense of divination in which women threw stones. 'Iyafah: It means geomancy by drawing lines.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3901]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3901

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: Taking omens is polytheism; taking omens is polytheism. He said it three times. Every one of us has some, but Allah removes it by trust (in Him).


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3904]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3904

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: There is no ghoul.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3907]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3907

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) heard a word, and he liked it, he said: We took your omen from your mouth.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3909]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3909

Narrated Urwah ibn Amir al-Qurashi:

When taking omens was mentioned in the presence of the Prophet (peace_be_upon_him), he said: The best type is the good omen, and it does not turn back a Muslim. If one of you sees anything he dislikes, he should say: O Allah, no one brings good things except Thee, and no one averts evil things except Thee and there is no might and power but in Allah.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3910]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3910

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) did not take omens from anything, but when he sent out an agent he asked about his name. If it pleased him, he was glad about it, and his cheerfulness on that account was visible in his face. If he disliked his name, his displeasure on that account was visible in his face. When he entered a village, he asked about its name, and if it pleased him, he was glad about it, and his cheerfulness on that account was visible in his face. But if he disliked its name, his displeasure on that account was visible in his face.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3911]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3911

Narrated Sa'd ibn Malik:

The Prophet (peace_be_upon_him) said: There is no hamah, no infection and no evil omen; if there is in anything an evil omen, it is a house, a horse, and a woman.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3912]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3912

Narrated Farwah ibn Musayk:

Yahya ibn Abdullah ibn Buhayr said that he was informed by one who had heard Farwah ibn Musayk tell that he said: Apostle of Allah! we have land called Abyan, which is the land where we have our fields and grow our crops, but it is very unhealthy. The Prophet (peace_be_upon_him) said: Leave it, for destruction comes from being near disease.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3913]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3913

Narrated Anas ibn Malik:

A man said: Apostle of Allah! we were in an abode in which our numbers and our goods were many and changed to an abode in which our numbers and our goods became few. The Apostle of Allah (peace_be_upon_him) said: Leave it, for it is reprehensible.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3914]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3914

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) took a man who was suffering from tubercular leprosy by the hand; he then put it along with his own hand in the dish and said: Eat with confidence in Allah and trust in Him.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3915]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3915

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: A slave who has entered into an agreement to purchase his freedom is a slave as long as a dirham of the agreed price remains to be paid.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3916]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3916

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: If any slave entered into an agreement to buy his freedom for one hundred uqiyahs and he pays them all but ten, he remains a slave (until he pays the remaining ten); and if a slave entered into an agreement to purchase his freedom for one hundred dinars, and he pays them all but ten dinars, he remains a slave (until he pays the remaining ten).


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3917]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3917

Narrated Umm Salamah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said to us: If one of you has a slave, and he enters into an agreement to purchase his freedom, and can pay the full price, she must veil herself from him.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3920]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3920

Narrated Aisha, Ummul Mu'minin:

Juwayriyyah, daughter of al-Harith ibn al-Mustaliq, fell to the lot of Thabit ibn Qays ibn Shammas, or to her cousin. She entered into an agreement to purchase her freedom. She was a very beautiful woman, most attractive to the eye.

Aisha said: She then came to the Apostle of Allah (peace_be_upon_him) asking him for the purchase of her freedom. When she was standing at the door, I looked at her with disapproval. I realised that the Apostle of Allah (peace_be_upon_him) would look at her in the same way that I had looked.

She said: Apostle of Allah, I am Juwayriyyah, daughter of al-Harith, and something has happened to me, which is not hidden from you. I have fallen to the lot of Thabit ibn Qays ibn Shammas, and I have entered into an agreement to purchase of my freedom. I have come to you to seek assistance for the purchase of my freedom.

The Apostle of Allah (peace_be_upon_him) said: Are you inclined to that which is better? She asked: What is that, Apostle of Allah? He replied: I shall pay the price of your freedom on your behalf, and I shall marry you.

She said: I shall do this. She (Aisha) said: The people then heard that the Apostle of Allah (peace_be_upon_him) had married Juwayriyyah. They released the captives in their possession and set them free, and said: They are the relatives of the Apostle of Allah (peace_be_upon_him) by marriage. We did not see any woman greater than Juwayriyyah who brought blessings to her people. One hundred families of Banu al-Mustaliq were set free on account of her.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3921]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3921

Narrated Umm Salamah, Ummul Mu'minin:

Safinah said: I was a slave of Umm Salamah, and she said: I shall emancipate you, but I stipulate that you must serve the Apostle of Allah (peace_be_upon_him) as long as you live. I said: Even if you do not make a stipulation, I shall not leave the Apostle of Allah (peace_be_upon_him). She then emancipated me and made the stipulation with me.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3922]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3922

Narrated Usamah ibn Umayr al-Huzali:

(This is AbulWalid's version): A man emancipated a share in a slave and the matter was mentioned to the Prophet (peace_be_upon_him). He said: Allah has no partner.

Ibn Kathir added in his version: The Prophet (peace_be_upon_him) allowed his emancipation.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3923]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3923

Narrated AbuHurayrah:

A man emancipated his share in a slave. The Prophet (peace_be_upon_him) allowed his (full) emancipation, and required him to pay the rest of his price.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3937]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3937

Narrated ath-Thalabb ibn Tha'labah at-Tamimi:

A man emancipated his share in a slave. The Prophet (peace_be_upon_him) did not put the responsibility on him to emancipate the rest.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3938]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3938

Narrated Samurah:

The Prophet (peace_be_upon_him) said: (The narrator Musa said in another place: From Samurah ibn Jundub as presumed by Hammad): If anyone gets possession of a relative who is within the prohibited degrees, that person becomes free. AbuDawud said: A similar tradition has also been transmitted by Samurah from the Prophet (peace_be_upon_him) through a different chain.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3939]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3939

Narrated Umar ibn al-Khattab:

Qatadah reported Umar ibn al-Khattab (may Allah be pleased with him) as saying: If anyone gets possession of a relative who is within the prohibited degrees, that person becomes free.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3942]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3942

Narrated Sulamah bint Ma'qil al-Qasiyyah:

My uncle brought me (to Medina) in the pre-Islamic days. He sold me to al-Hubab ibn Amr, brother of AbulYusr ibn Amr. I bore a child, AbdurRahman ibn al-Hubab, to him and he (al-Hubab) then died.

Thereupon his wife said: I swear by Allah, now you will be sold (as a repayment) for his loan.

So I came to the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah! I am a woman of Banu Kharijah Qays ibn Aylan. My uncle had brought me to Medina in pre-Islamic days. He sold me to al-Hubab ibn Amr, brother of AbulYusr ibn Amr. I bore AbdurRahman ibn al-Hubab to him. His wife said: I swear by Allah, you will be sold for his loan.

The Apostle of Allah (peace_be_upon_him) said: Who is the guardian of al-Hubab?

He was told: His brother, AbulYusr ibn Amr. He then sent for him and said: Set her free; when you hear that some slaves have been brought to me, came to me, and I shall compensate you for her.

She said: They set me free, and when some slaves were brought to the Apostle of Allah (peace_be_upon_him), he gave them a slave in compensation for me.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3943]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3943

Narrated Jabir ibn Abdullah:

We sold slave-mothers during the time of the Apostle of Allah (peace_be_upon_him) and of AbuBakr. When Umar was in power, he forbade us and we stopped.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3952]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3952

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The child of adultery is worst of the three.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3953]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3953

Narrated Wathilah ibn al-Asqa:

Al-Arif ibn ad-Daylami said: We went to Wathilah ibn al-Asqa and said to him: Tell us a tradition which has not addition or omission. He became angry and replied: One of you recites when his copy of a Qur'an is hung up in his house, and he makes additions and omissions. We said: All we mean is a tradition you have heard from the Apostle of Allah (peace_be_upon_him). He said: We went to the Prophet (peace_be_upon_him) about a friend of ours who deserved. Hell for murder. He said: Emancipate a slave on his behalf; Allah will set free from Hell a member of the body for every member of his.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3954]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3954

Narrated AbuNajih as-Sulami:

Along with the Apostle of Allah (peace_be_upon_him) we besieged the palace of at-Ta'if. The narrator, Mutadh, said: I heard my father (sometimes) say: "Palace of at-Ta'if," and (sometimes) "Fort of at-Ta'if," which are the same.

I heard the Apostle of Allah (peace_be_upon_him) say: he who causes an arrow to hit its mark in Allah's cause will have it counted as a degree for him (in Paradise). He then transmitted the rest of the tradition.

I heard the Apostle of Allah (peace_be_upon_him) say: If a Muslim man emancipates a Muslim man, Allah, the Exalted, will make every bone of his protection for every bone of his emancipator from Hell; and if a Muslim woman emancipates a Muslim woman, Allah will make every bone of hers protection for every bone of her emancipator from Hell on the Day of Resurrection.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3955]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3955

Narrated Marrah ibn Ka'b:

Amr ibn Abasah, said that Marrah ibn Ka'b said: I heard the Apostle of Allah (peace_be_upon_him) say: If anyone emancipates a Muslim slave, that will be his ransom from Jahannam.


Dawud :: Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur) :: [29.3957]

Divination and Omens (Kitab Al-Kahanah Wa Al-Tatayyur)

Dawud :: Book 29 : Hadith 3957

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: the similitude of a man who emancipates a slave at the time of his death is like that of a man who gives a present after satisfying his appetite.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3958]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3958

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) read the Qur'anic verse, "And take ye the Station of Abraham as a place of prayer.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3960]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3960

Narrated Abdullah ibn Abbas:

The verse "And no Prophet could (ever) be false to his trust" was revealed about a red velvet. When it was found missing on the day of Badr, some people said; Perhaps the Apostle of Allah (peace_be_upon_him) has taken it. So Allah, the Exalted, sent down "And no prophet could (ever) be false to his trust" to the end of the verse.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3962]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3962

Narrated Laqit ibn Sabirah:

I came in the deputation of Banu al-Muntafiq to the Apostle of Allah (peace_be_upon_him). He then narrated the rest of the tradition. The Prophet (peace_be_upon_him) said: la tahsibanna (do not think) and did not say: la tahsabanna (do not think).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3964]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3964

Narrated Zayd ibn Thabit:

The Prophet (peace_be_upon_him) used to read: "Not equal are those believers who sit (at home) and receive no hurt (ghayru ulid-darari) but the narrator Sa'id did not say the words "used to read"


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3965]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3965

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) red the verse: "eye for eye" (al-'aynu bil-'ayn).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3966]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3966

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) read the verse: "We ordained therein for them: Life for life and eye for eye (an-nafsa bin-nafsi wal-'aynu bil-'ayn).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3967]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3967

Narrated Abdullah ibn Umar:

Atiyyah ibn Sa'd al-Awfi said: I recited to Abdullah ibn Umar the verse: "It is Allah Who created you in a state of (helplessness) weakness (min da'f)." He said: (Read) min du'f. I recited it to the Apostle of Allah (peace_be_upon_him) as you recited it to me, and he gripped me as I gripped you.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3968]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3968

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) read the verse mentioned above, "min du'f."


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3970]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3970

Narrated Ibn Abzi:

Ubayy ibn Ka'b) said: The Prophet (peace_be_upon_him) read the verse: "Say: In the bounty of Allah and in His mercy--in that let you rejoice: that is better than the wealth you hoard."


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3971]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3971

Narrated Asma' daughter of Yazid:

She heard the Prophet (peace_be_upon_him) read the verse: "He acted unrighteously." (innahu 'amila ghayra salih).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3972]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3972

Narrated Umm Salamah, Ummul Mu'minin:

Shahr ibn Hawshab said: I asked Umm Salamah: How did the Apostle of Allah (peace_be_upon_him) read this verse: "For his conduct is unrighteous (innahu 'amalun ghayru salih". She replied: He read it: "He acted unrighteously" (innahu 'amila ghayra salih).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3973]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3973

Narrated Ubayy ibn Ka'b::

When the Apostle of Allah (peace_be_upon_him) prayed, he began with himself and said: May the mercy of Allah be upon us and upon Moses. If he had patience, he would have seen marvels from his Companion. But he said: "(Moses) said: If ever I ask thee about anything after this, keep me not in they company: then wouldst thou have received (full) excuse from my side". Hamzah lengthened it.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3974]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3974

Narrated Ubayy ibn Ka'b:

The Prophet (peace_be_upon_him) read the Qur'anic verse: "Thou hast received (full) excuse from me (min ladunni)" and put tashdid (doubling of consonants) on nun (n).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3975]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3975

Narrated Abdullah ibn Abbas:

Ubayy ibn Ka'b made me read the following verse as the Apostle of Allah (peace_be_upon_him) made him read: "in a spring of murky water" (fi 'aynin hami'atin) with short vowel a after h.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3976]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3976

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: A man from the Illiyyun will look downwards at the people of Paradise and Paradise will be glittering as if it were a brilliant star.

He (the narrator) said: In this way the word durri (brilliant) occurs in this tradition, i.e. the letter dal (d) has short vowel u and it has no hamzah ('). AbuBakr and Umar will be of them and will have some additional blessings.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3977]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3977

Narrated Farwah ibn Musayk al-Ghutayfi:

I came to the Prophet (peace_be_upon_him). He then narrated the rest of the tradition.

A man from the people said: "Apostle of Allah! tell us about Saba'; what is it: land or woman? He replied: It is neither land nor woman; it is a man to whom ten children of the Arabs were born: six of them lived in the Yemen and four lived in Syria.

The narrator Uthman said al-Ghatafani instead of al-Ghutayfi. He said: It has been transmitted to us by al-Hasan ibn al-Hakam an-Nakha'i.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3980]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3980

Narrated Aisha, Ummul Mu'minin:

I heard the Apostle of Allah (peace_be_upon_him) read: "(There is for him) Rest and satisfaction" (faruhun wa rayhan).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3982]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3982

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) made me read the verse "It is I who give (all) sustenance, Lord of power, steadfast (for ever).


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3983]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3983

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) used to read the verse "Is there any that will receive admonition (muddakir)? " that is with doubling of consonant [(dal)(d)].


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3984]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3984

Narrated Jabir ibn Abdullah:

I saw the Prophet (peace_be_upon_him) reading the verse; "does he think that his wealth would make him last for ever?"


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3987]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3987

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) related a tradition in which he mentioned the words "Jibril and Mikal" and he pronounced them "Jibra'ila wa Mika'ila."


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3988]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3988

Narrated AbuSa'id al-Khudri:

The Apostle of Allah (peace_be_upon_him) mentioned the name of the one who will sound the trumpet (sahib as-sur) and said: On his right will be Jibra'il and on his left will be Mika'il.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3989]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3989

Narrated Ibn al-Musayyab:

The Prophet (peace_be_upon_him), AbuBakr, Umar and Uthman used to read "maliki yawmid-din (master of the Day of Judgment)". The first to read maliki yawmid-din was Marwan.


Dawud :: Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at) :: [30.3990]

Dialects and Readings of the Qur'an (Kitab Al-Huruf Wa Al-Qira'at)

Dawud :: Book 30 : Hadith 3990

Narrated Umm Salamah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to recite: "In the name of Allah, the Cherisher and Sustainer of the worlds; most Gracious, most Merciful; Master of the Day of Judgment," breaking its recitation into verses, one after another.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.3998]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 3998

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) forbade to enter the hot baths. He then permitted men to enter them in lower garments.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.3999]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 3999

Narrated Aisha, Ummul Mu'minin:

AbulMalih said: Some women of Syria came to Aisha. She asked them: From whom are you? They replied: From the people of Syria. She said: Perhaps you belong to the place where women enter hot baths (for washing ). The said: Yes. She said: I heard the Apostle of Allah (peace_be_upon_him) say: If a woman puts off her clothes in a place other than her house, she tears the veil between her and Allah, the Exalted.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4000]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4000

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: After some time the lands of the non-Arabs will be conquered for you, and there you will find houses called hammamat (hot baths). so men should not enter them (to wash) except in lower garments, and forbid the women to enter them except a sick or one who is in a child-bed.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4001]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4001

Narrated Ya'la:

The Apostle of Allah (peace_be_upon_him) saw a man washing in a public place without a lower garment. So he mounted the pulpit, praised and extolled Allah and said: Allah is characterised by modesty and concealment. So when any of you washes, he should conceal himself.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4003]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4003

Narrated Jarhad:

The Apostle of Allah (peace_be_upon_him) sat with us and my thigh was uncovered. He said: Do you not know that thigh is a private part.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4004]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4004

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: Do not uncover you thigh, and do not look at the thigh of the living and the dead.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4006]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4006

Narrated Mu'awiyah ibn Haydah:

I said: Apostle of Allah, from whom should we conceal our private parts and to whom can we show? He replied: conceal your private parts except from your wife and from whom your right hands possess (slave-girls).

I then asked: Apostle of Allah, (what should we do), if the people are assembled together?

He replied: If it is within your power that no one looks at it, then no one should look at it.

I then asked: Apostle of Allah if one of us is alone, (what should he do)?

He replied: Allah is more entitled than people that bashfulness should be shown to him.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4007]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4007

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: A man should not look at the private parts of another man, and a woman should not look at the private parts of another woman. A man should not lie with another man without wearing lower garment under one cover; and a woman should not be lie with another woman without wearing lower garment under one cover.


Dawud :: Hot Baths (Kitab Al-Hammam) :: [31.4008]

Hot Baths (Kitab Al-Hammam)

Dawud :: Book 31 : Hadith 4008

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A man should not lie with another man and a woman should not lie with another woman without covering their private parts except a child or a father. He also mentioned a third thing which I forgot.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4009]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4009

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) put on a new garment he mentioned it by name, turban or shirt, and would then say: O Allah, praise be to Thee! as Thou hast clothed me with it, I ask Thee for its good and the good of that for which it was made, and I seek refuge in Thee from its evil and the evil of that for which it was made.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4012]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4012

Narrated Mu'adh ibn Anas:

The Prophet (peace_be_upon_him) said: If anyone eats food and then says: "Praise be to Allah Who has fed me with this food and provided me with it through no might and power on my part," he will be forgiven his former and later sins. If anyone puts on a garment and says: "Praise be to Allah Who has clothed me with this and provided me with it through no might and power on my part," he will be forgiven his former and later sins.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4014]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4014

Narrated Umm Salamah, Ummul Mu'minin:

The clothing which the Apostle of Allah (peace_be_upon_him) liked best was shirt.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4015]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4015

Narrated Umm Salamah, Ummul Mu'minin:

No clothing was dearer to be Apostle of Allah (peace_be_upon_him) than shirt.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4016]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4016

Narrated Asma', daughter of Yazid,:

The sleeve of the shirt of the Apostle of Allah (peace_be_upon_him) came to the wrist.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4018]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4018

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) as saying: If anyone wears a garment for gaining fame, Allah will clothe him in a similar garment on the Day of Resurrection.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4020]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4020

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: He who copies any people is one of them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4021]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4021

Narrated Utbah ibn AbdusSulami:

I asked the Apostle of Allah (peace_be_upon_him) to clothe me. He clothed me with two coarse clothes of linen.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4022]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4022

Narrated AbuMusa al-Ash'ari:

AbuBurdah said: My father said to me: My son, if you had seen us while we were with the Apostle of Allah (peace_be_upon_him) and the rain had fallen on us, you would have thought that our smell was the smell of the sheep.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4023]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4023

Narrated Anas ibn Malik:

The King Dhu Yazan presented to the apostle of Allah (peace_be_upon_him) a suit of clothes which he had purchased for thirty-three camels or thirty-three she-camels. He accepted it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4024]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4024

Narrated Ishaq ibn Abdullah ibn al-Harith:

The Apostle of Allah (peace_be_upon_him) purchased a suit of clothes for twenty she-camels and some more and he presented it to Dhu Yazan.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4026]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4026

Narrated Abdullah ibn Abbas:

When the Haruriyyah made a revolt, I came to Ali (may Allah be pleased with him). He said: Go to these people. I then put on the best suit of the Yemen. AbuZumayl (a transmitter) said: Ibn Abbas was handsome and of imposing countenance. Ibn Abbas said: I then came to them and they said: Welcome to you, Ibn Abbas! what is this suit of clothes? I said: Why are you objecting to me? I saw over the Apostle of Allah (peace_be_upon_him) the best suit of clothes.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4027]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4027

Narrated Sa'd:

I saw a man riding on a white mule and he had a black turban of silk and wool. He said: The Apostle of Allah (peace_be_upon_him) put it on me. This is the version of Uthman, and there is the word akhbara in his tradition.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4028]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4028

Narrated AbuAmir or AbuMalik:

AbdurRahman ibn Ghanam al-Ash'ari said: AbuAmir or AbuMalik told me--I swear by Allah another oath that he did not believe me that he heard the Apostle of Allah (peace_be_upon_him) say: There will be among my community people who will make lawful (the use of) khazz and silk. Some of them will be transformed into apes and swine.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4036]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4036

Narrated Anas ibn Malik:

The king of Rome presented a fur of silk brocade to the Prophet (peace_be_upon_him) and he wore it. The scene that his hands were moving (while wearing the robe) is before my eyes. He then sent it to Ja'far who wore it and came to him. The Prophet (peace_be_upon_him) said: I did not send it to you to wear. He asked: What should I do with it? He replied: Send it to your brother Negus.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4037]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4037

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: I do not ride on purple, or wear a garment dyed with saffron, or wear shirt hemmed with silk. Pointing to the collar of his shirt al-Hasan (al-Basri) said: The perfume used by men should have an odour but no colour, and the perfume used by women should have a colour but no odour.

Sa'id said: I think he said: They interpreted his tradition about perfume used by women as applying when she comes out. But when she is with her husband, she may use any perfume she wishes.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4038]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4038

Narrated AbuRayhanah:

AbulHusayn, al-Haytham ibn Shafi said: I and a companion of mine called AbuAmir, a man from al-Ma'afir went to perform prayer in Bayt al-Maqdis (Jerusalem). Their preacher was a man of Azd called AbuRayhanah, who was a companion of the Prophet (peace_be_upon_him).

AbulHusayn said: my companion went to the mosque before me. I went there after him and sat beside him. He asked me: Did you hear the preaching of AbuRayhanah? I said: No. He said: I heard him say: The Apostle of Allah (peace_be_upon_him) forbade ten things: Sharpening the ends of the teeth, tattooing, plucking hair, men sleeping together without an under garment, women sleeping together without an under-garment, men putting silk at the hem of their garments like the Persians, or putting silk on their shoulders like the Persians, plundering, riding on panther skins, wearing signet rings, except in the case of one in authority.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4040]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4040

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) forbade me to wear a gold ring, or a Qassi garment or the use purple saddle-cloths.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4041]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4041

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) once prayed wearing a garment having marks. He looked at its marks. When he saluted, he said: Take this garment of mine to AbuJahm, for it turned my attention just now in my prayer, and bring a simple garment without marks.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4043]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4043

Narrated Asma:

Abdullah AbuUmar, client of Asma', daughter of AbuBakr, said: I saw Ibn Umar buying a Syrian garment in the market. When he saw that it had red warp, he returned it. I then came to Asma' and mentioned it to her. She said: Bring me, slave-girl, the mantle of the Apostle of Allah (peace_be_upon_him). She brought out a mantle of a course ornamented cloth, with its collar, sleeves, front, and back were hemmed with brocade.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4046]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4046

Narrated Ali ibn AbuTalib:

The Prophet of Allah (peace_be_upon_him) took silk and held it in his right hand, and took gold and held it in his left hand and said: both of these are prohibited to the males of my community.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4048]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4048

Narrated Jabir ibn Abdullah:

We used to take it away (i.e. silk) from boys, and leave it for girls. Mis'ar said: I asked Amr ibn Dinar about it, but he did not know it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4050]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4050

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Wear your white garments, for they are among your best garments, and shroud your dead in them. Among the best types of collyrium you use is antimony (ithmid) for it clears the vision and makes the hair sprout.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4051]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4051

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) paid visit to us, and saw a dishevelled man whose hair was disordered. He said: Could this man not find something to make his hair lie down? He saw another man wearing dirty clothes and said: Could this man not find something to wash his garments with.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4052]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4052

Narrated AbulAhwas Awf ibn Malik:

I came to the Prophet (peace_be_upon_him) wearing a poor garment and he said (to me): Have you any property? He replied: Yes. He asked: What kind is it? He said: Allah has given me camels. Sheep, horses and slaves. He then said: When Allah gives you property, let the mark of Allah's favour and honour to you be seen.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4053]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4053

Narrated Abdullah ibn Umar:

Zayd ibn Aslam said: Ibn Umar used to dye his beard with yellow colour so much so that his clothes were filled (dyed) with yellowness. He was asked: Why do you dye with yellow colour? He replied: I saw the Apostle of Allah (peace_be_upon_him) dyeing with yellow colour, and nothing was dearer to him than it. He would dye all his clothes with it, even his turban.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4054]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4054

Narrated AbuRimthah:

I went with my father to the Prophet (peace_be_upon_him) and saw two green garments over him.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4055]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4055

Narrated Abdullah ibn Amr ibn al-'As:

We came down with the Apostle of Allah (peace_be_upon_him) from a turning of a valley. He turned his attention to me and I was wearing a garment dyed with a reddish yellow dye. He asked: What is this garment over you? I recognised what he disliked. I then came to my family who were burning their oven. I threw it (the garment) in it and came to him the next day. He asked: Abdullah, what have you done with the garment? I informed him about it. He said: Why did you not give it to one of your family to wear, for there is no harm in it for women.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4057]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4057

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) saw me. The version of AbuAli al-Lula' has: I think I wore a garment dyed with a reddish yellow colour. He asked: What is this? So I went and burnt it. The Prophet (peace_be_upon_him) said: What have you done with your garment? I replied: I burnt it. He said: Why did you not give it to one of your women to wear?


Dawud :: Clothing (Kitab Al-Libas) :: [32.4058]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4058

Narrated Abdullah ibn Amr ibn al-'As:

A man wearing two red garments passed the Prophet (peace_be_upon_him) and gave him a greeting, but he did not respond to his greeting.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4059]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4059

Narrated Rafi' ibn Khadij:

We went out with the Apostle of Allah (peace_be_upon_him) on a journey, and we had on our saddles and camels garments consisting of red warp of wool. The Apostle of Allah (peace_be_upon_him) said: Do I not see that red colour has dominated you. We then got up quickly on account of this saying of the Apostle of Allah (peace_be_upon_him) and some of our camels ran away. We then took the garments and withdrew them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4060]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4060

Narrated Zaynab:

Hurayth ibn al-Abajj as-Sulayhi said: that a woman of Banu Asad: One day I was with Zaynab, the wife of the Apostle of Allah (peace_be_upon_him), and we were dyeing her clothes with red ochre. In the meantime the Apostle of Allah (peace_be_upon_him) peeped us. When he saw the red ochre, he returned. When Zaynab saw this, she realised that the Apostle of Allah (peace_be_upon_him) disapproved of what she had done. She then took and washed her clothes and concealed all redness. The Apostle of Allah (peace_be_upon_him) then returned and peeped, and when he did not see anything, he entered.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4062]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4062

Narrated Amir:

I saw the Apostle of Allah (peace_be_upon_him) at Mina giving sermon on a mule and wearing a red garment, while Ali was announcing.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4063]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4063

Narrated Aisha, Ummul Mu'minin:

I made a black cloak for the Prophet (peace_be_upon_him) and he put it on; but when he sweated in it and noticed the odour of the wool, he threw it away. The narrator said: I think he said: He liked good smell.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4064]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4064

Narrated Jabir ibn Abdullah:

When I came to the Prophet (peace_be_upon_him), he was sitting with his hands round his knees wearing the cloak the fringe of which was over his feet.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4067]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4067

Narrated Ali ibn Rukanah:

Ali quoting his father said: Rukanah wrestled with the Prophet (peace_be_upon_him) and the Prophet (peace_be_upon_him) threw him on the ground. Rukanah said: I heard the Prophet (peace_be_upon_him) say: The difference between us and the polytheists is that we wear turbans over caps.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4068]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4068

Narrated AbdurRahman ibn Awf:

The Apostle of Allah (peace_be_upon_him) put a turban on me and let the ends hang in front of him and behind me.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4069]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4069

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) forbade wearing clothes in two styles: that a man sits in a single garment with his hands round his knees and uncover his private parts towards heaven and that he wears his garment while one of his sides is uncovered, and puts the garment on his shoulders.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4071]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4071

Narrated Qurrah ibn Iyas al-Muzani:

I came to the Apostle of Allah (peace_be_upon_him) with a company of Muzaynah and we swore allegiance to him. The buttons of his shirt were open. I swore allegiance to him and I put my hand inside the collar of his shirt and felt the seal.

Urwah said: I always saw Mu'awiyah and his son opening their buttons of the collar during winter and summer. They never closed their buttons.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4073]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4073

Narrated AbuJurayy Jabir ibn Salim al-Hujaymi:

I saw a man whose opinion was accepted by the people, and whatever he said they submitted to it. I asked: Who is he? They said: This is the Apostle of Allah (peace_be_upon_him). I said: On you be peace, Apostle of Allah, twice. He said: Do not say "On you be peace," for "On you be peace" is a greeting for the dead, but say "Peace be upon you".

I asked: You are the Apostle of Allah (may peace be upon you)? He said: I am the Apostle of Allah Whom you call when a calamity befalls you and He removes it; when you suffer from drought and you call Him, He grows food for you; and when you are in a desolate land or in a desert and your she-camel strays and you call Him, He returns it to you.

I said: Give me some advice. He said: Do not abuse anyone. He said that he did not abuse a freeman, or a slave, or a camel or a sheep thenceforth. He said: Do not look down upon any good work, and when you speak to your brother, show him a cheerful face. This is a good work. Have your lower garment halfway down your shin; if you cannot do it, have it up to the ankles. Beware of trailing the lower garment, for it is conceit and Allah does not like conceit. And if a man abuses and shames you for something which he finds in you, then do not shame him for something which you find in him; he will bear the evil consequences for it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4078]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4078

Narrated Sahl Ibn al-Hanzaliyyah:

Qays ibn Bishr at-Taghlibi said: My father told me that he was a companion of AbudDarda'. There was in Damascus a man from the companions of the Prophet (peace_be_upon_him), called Ibn al-Hanzaliyyah. He was a recluse and rarely met the people. He remained engaged in prayer. When he was not praying he was occupied in glorifying Allah and exalting Him until he went to his family. Once he passed us when we were with AbudDarda'.

AbudDarda' said to him: Tell us a word which benefits us and does not harm you.

He said: The Apostle of Allah (peace_be_upon_him) sent out a contingent and it came back. One of the men came and sat in the place where the Apostle of Allah (peace_be_upon_him) used to sit, and he said to a man beside him: Would that you saw us when we met the enemy and so-and-so attacked and cut through a lance.

He said: Take it from me and I am a boy of the tribe Ghifar. What do you think about his statement?

He replied: I think his reward was lost. Another man heard it and said: I do not think that there is any harm in it. They quarrelled until the Apostle of Allah (peace_be_upon_him) heard it, and he said: Glory be to Allah! There is no harm if he is rewarded and praised. I saw that AbudDarda' was pleased with it and began to raise his hand to him and say: Did you hear it from the Apostle of Allah (peace_be_upon_him)?

He said: Yes. He continued to repeat it to him so often that I thought he was going to kneel down. He said: On another day he again passed us.

AbudDarda' said to him: (Tell us) a word which benefits us and does not harm you.

He said: The Apostle of Allah (peace_be_upon_him) said to us: One who spends on (the maintenance of) horses (for jihad) is like the one who spreads his hand to give alms (sadaqah) and does not withhold it. He then passed us on another day.

AbudDarda' said to him: (Tell us) a word which benefits us and does no harm to you.

He said: The Apostle of Allah (peace_be_upon_him) said: Khuraym al-Asadi would be a fine man were it not for the length of his hair, which reaches the shoulders, and the way he lets his lower garment hang down. When Khuraym heard that, he hurriedly, took a knife, cut his hair in line with his ears and raised his lower garment half way up his legs. He then passed us on another day.

AbudDarda' said to him: (tell us) a word which benefits us and does not harm you.

He said: I heard the Apostle of Allah (peace_be_upon_him) say: You are coming to your brethren; so tidy your mounts and tidy your dress, until you are like a mole among the people. Allah does not like obscene words or deeds, or do intentional committing of obscenity.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4079]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4079

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Allah Most High says: Pride is my cloak and majesty is my lower garment, and I shall throw him who view with me regarding one of them into Hell.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4081]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4081

Narrated AbuHurayrah:

A man who was beautiful came to the Prophet (peace_be_upon_him). He said: Apostle of Allah, I am a man who likes beauty, and I have been given some of it, as you see. And I do not like that anyone excels me (in respect of beauty). Perhaps he said: "even to the extent of thong of my sandal (shirak na'li)", or he he said: "to the extent of strap of my sandal (shis'i na'li)". Is it pride? He replied: No, pride is disdaining what is true and despising people.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4082]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4082

Narrated AbuSa'id al-Khudri:

AbdurRahman said: I asked AbuSa'id al-Khudri about wearing lower garment. He said: You have come to the man who knows it very well. The Apostle of Allah (peace_be_upon_him) said: The way for a believer to wear a lower garment is to have it halfway down his legs and he is guilty of no sin if it comes halfway between that and the ankles, but what comes lower than the ankles is in Hell. On the day of Resurrection. Allah will not look at him who trails his lower garment conceitedly.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4083]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4083

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Hanging down is in lower garment, shirt and turban. If anyone trails any of them conceitedly, Allah will not look at him on the Day of Resurrection.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4084]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4084

Narrated Abdullah ibn Umar:

What the Apostle of Allah (peace_be_upon_him) said about lower garment also applies to shirt.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4085]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4085

Narrated Abdullah ibn Abbas:

Ikrimah said that he saw Ibn Abbas putting on lower garment, letting the hem on the top of his foot and raising it behind. He said: Why do you put on the lower garment in this way? He replied: It is how I saw the Apostle of Allah (peace_be_upon_him) do it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4087]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4087

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) cursed the man who dressed like a woman and the woman who dressed like a man.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4088]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4088

Narrated Aisha, Ummul Mu'minin:

Ibn AbuMulaykah told that when someone remarked to Aisha that a woman was wearing sandals, she replied: The Apostle of Allah (peace_be_upon_him) cursed mannish women.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4089]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4089

Narrated Aisha, Ummul Mu'minin:

Safiyyah, daughter of Shaybah, said that Aisha mentioned the women of Ansar, praised them and said good words about them. She then said: When Surat an-Nur came down, they took the curtains, tore them and made head covers (veils) of them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4090]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4090

Narrated Umm Salamah, Ummul Mu'minin:

When the verse "That they should cast their outer garments over their persons" was revealed, the women of Ansar came out as if they had crows over their heads by wearing outer garments.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4091]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4091

Narrated Aisha, Ummul Mu'minin:

May Allah have mercy on the early immigrant women. When the verse "That they should draw their veils over their bosoms" was revealed, they tore their thick outer garments and made veils from them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4092]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4092

Narrated Aisha, Ummul Mu'minin:

Asma, daughter of AbuBakr, entered upon the Apostle of Allah (peace_be_upon_him) wearing thin clothes. The Apostle of Allah (peace_be_upon_him) turned his attention from her. He said: O Asma', when a woman reaches the age of menstruation, it does not suit her that she displays her parts of body except this and this, and he pointed to her face and hands.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4094]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4094

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) brought Fatimah a slave which he donated to her. Fatimah wore a garment which, when she covered her head, did not reach her feet, and when she covered her feet by it, that garment did not reach her head. When the Prophet (peace_be_upon_him) saw her struggle, he said: There is no harm to you: Here is only your father and slave.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4095]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4095

Narrated Aisha, Ummul Mu'minin:

A mukhannath (eunuch) used to enter upon the wives of Prophet (peace_be_upon_him). They (the people) counted him among those who were free of physical needs. One day the Prophet (peace_be_upon_him) entered upon us when he was with one of his wives, and was describing the qualities of a woman, saying: When she comes forward, she comes forward with four (folds in her stomach), and when she goes backward, she goes backward with eight (folds in her stomach). The Prophet (peace_be_upon_him) said: Do I not see that this (man) knows what here lies. Then they (the wives) observed veil from him.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4100]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4100

Narrated Umm Salamah, Ummul Mu'minin:

I was with the Apostle of Allah (peace_be_upon_him) while Maymunah was with him. Then Ibn Umm Maktum came. This happened when we were ordered to observe veil (purdah). The Prophet (peace_be_upon_him) said: Observe veil from him. We asked: Apostle of Allah! is he not blind? He can neither see us nor recognise us. The Prophet (peace_be_upon_him) said: Are both of you blind? Do you not see him? AbuDawud said: This was peculiar to the wives of the Prophet (peace_be_upon_him). Do you not see that Fatimah daughter of Qays passed her waiting period with Ibn Umm Maktum. The Prophet (peace_be_upon_him) said to Fatimah daughter of Qays: Pass your waiting period with Ibn Umm Maktum, for he is a blind man. You can put off your clothes with him.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4101]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4101

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: When one of you marries his male-slave to his slave-woman, he should not look at her private parts.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4102]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4102

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: When one of you marries his female servant to his slave or to his employee, he should not look at her private part below the navel and above the knees.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4103]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4103

Narrated Umm Salamah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) came to visit her when she was veiled, and said: use one fold and not two.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4104]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4104

Narrated Dihyah ibn Khalifah al-Kalbi:

The Apostle of Allah (peace_be_upon_him) was brought some pieces of fine Egyptian linen and he gave me one and said: Divide it into two; cut one of the pieces into a shirt and give the other to your wife for veil. Then when he turned away, he said: And order your wife to wear a garment below it and not show her figure.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4105]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4105

Narrated Umm Salamah, Ummul Mu'minin:

Safiyyah, daughter of AbuUbayd, said: When the Apostle of Allah (peace_be_upon_him) mentioned lower garment, Umm Salamah, wife of the Apostle of Allah (peace_be_upon_him), asked him: And a woman, Apostle of Allah? He replied: She may hang down a span. Umm Salamah said: Still it (foot) will be uncovered. He said: Then a forearm's length, nor exceeding it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4107]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4107

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) gave licence to others of the believers (i.e. the wives of the Prophet) to hang down their lower garment a span. Then they asked him to increase it, and he increased one span for them. They would send (the garment) to us and we would measure it one forearm's length for them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4112]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4112

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) ordered that the skins of the animals which had died a natural death should be used when they are tanned.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4113]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4113

Narrated Salamah ibn al-Muhabbaq:

On the expedition of Tabuk the Apostle of Allah (peace_be_upon_him) came to a household and, seeing a bucket hanging, asked for water. They said: Apostle of Allah, the animal died a natural death. He replied; Its tanning is its purification.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4114]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4114

Narrated Maymunah:

Al-Aliyah, daughter of Subay', said: I had some sheep at Uhud, and they began to die. I then entered upon Maymunah, wife of the Prophet (peace_be_upon_him), and mentioned it to her. Maymunah said to me: If you took their skins and made use of them, (that would be better for you). She asked: Is that lawful? She replied, Yes. Some people of the Quraysh passed by the Apostle of Allah (peace_be_upon_him) dragging a sheep of theirs as big as an ass. The Apostle of Allah (peace_be_upon_him) said to them: Would that you took its skin. They said: It died a natural death. The Apostle of Allah (peace_be_upon_him) said: Water and leaves of the mimosa flava purify it.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4115]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4115

Narrated Abdullah ibn Ukaym:

The letter of the Apostle of Allah (peace_be_upon_him) was read out to us in the territory of Juhaynah when I was a young boy: Do not make use of the skin or sinew of an animal which died a natural death.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4116]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4116

Narrated Abdullah ibn Ukaym,:

Al-Hakam ibn Uyaynah said that he went along with some people to Abdullah ibn Ukaym, a man of Juhaynah. al-Hakam said: They entered and I sat at the door. Then they came out and told me that Abdullah ibn Ukaym had informed them that the Apostle of Allah (peace_be_upon_him) had written to Juhaynah one month before his death: Do not make use of the skin or sinew of an animal which died a natural death.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4117]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4117

Narrated Mu'awiyah:

The Prophet (peace_be_upon_him) said: Do not ride on silk stuff and panther skins. AbuSa'id said to us: AbuDawud said to us: The name of AbulMu'tamir is Yazid ibn Tahman. He lived in al-Hirah.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4119]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4119

Narrated Al-Miqdam ibn Ma'dikarib:

Khalid said: Al-Miqdam ibn Ma'dikarib and a man of Banu Asad from the people of Qinnisrin went to Mu'awiyah ibn AbuSufyan.

Mu'awiyah said to al-Miqdam: Do you know that al-Hasan ibn Ali has died? Al-Miqdam recited the Qur'anic verse "We belong to Allah and to Him we shall return."

A man asked him: Do you think it a calamity? He replied: Why should I not consider it a calamity when it is a fact that the Apostle of Allah (peace_be_upon_him) used to take him on his lap, saying: This belongs to me and Husayn belongs to Ali?

The man of Banu Asad said: (He was) a live coal which Allah has extinguished. Al-Miqdam said: Today I shall continue to make you angry and make you hear what you dislike. He then said: Mu'awiyah, if I speak the truth, declare me true, and if I tell a lie, declare me false.

He said: Do so. He said: I adjure you by Allah, did you hear the Apostle of Allah (peace_be_upon_him) forbidding use to wear gold?

He replied: Yes. He said: I adjure you by Allah, do you know that the Apostle of Allah (peace_be_upon_him) prohibited the wearing of silk?

He replied: Yes. He said: I adjure you by Allah, do you know that the Apostle of Allah (peace_be_upon_him) prohibited the wearing of the skins of beasts of prey and riding on them?

He said: Yes. He said: I swear by Allah, I saw all this in your house, O Mu'awiyah.

Mu'awiyah said: I know that I cannot be saved from you, O Miqdam.

Khalid said: Mu'awiyah then ordered to give him what he did not order to give to his two companions, and gave a stipend of two hundred (dirhams) to his son. Al-Miqdam then divided it among his companions, and the man of Banu Asad did not give anything to anyone from the property he received. When Mu'awiyah was informed about it, he said: Al-Miqdam is a generous man; he has an open hand (for generosity). The man of Banu Asad withholds his things in a good manner.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4120]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4120

Narrated Usamah:

The Apostle of Allah (peace_be_upon_him) forbade (the use of) the skins of beasts of prey.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4123]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4123

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) forbade that a man should put on sandals while standing.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4126]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4126

Narrated Abdullah ibn Abbas:

It is part of the Sunnah that when a man sits down, he should take off his sandals and place them at his side.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4129]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4129

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When you put on (a garment) and when you perform ablution, you should begin with your right side.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4131]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4131

Narrated Jabir ibn Samurah:

When I came to the Prophet (peace_be_upon_him) in his house, I saw him sitting reclining on a pillow. The narrator Ibn al-Jarrah added: "on his left side".


Dawud :: Clothing (Kitab Al-Libas) :: [32.4132]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4132

Narrated Abdullah ibn Umar:

Sa'id ibn Amr al-Qurashi quoting his father said: Ibn Umar (once) saw some fellow travellers of the Yemen. They had their saddles (on camels) of leather. He said: If anyone likes to see the fellow travellers most resembling to the Companions of the Apostle of Allah (peace_be_upon_him), he should see them.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4135]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4135

Narrated Aisha, Ummul Mu'minin:

The bedding of the Apostle of Allah (peace_be_upon_him) consisted of leather stuffed with palm fibre.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4136]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4136

Narrated Umm Salamah, Ummul Mu'minin:

Her bedding was in front of the place of prayer of the Prophet (peace_be_upon_him).


Dawud :: Clothing (Kitab Al-Libas) :: [32.4137]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4137

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) came to Fatimah and found a curtain hanging at her door, so he did not enter. Whenever he entered (the house), he would visit her first. Then Ali came and found that Fatimah was grieved.

He asked: What is the matter with you? She replied: The Apostle of Allah (peace_be_upon_him) came to me but did not enter (the house).

Ali then came to him and said: Apostle of Allah, Fatimah felt it keenly that you came to visit her but did not go in. He replied: What have I to do with this world? What have I to do with prints and figures (on the curtain)? He (Ali) then went to Fatimah and informed her of what the Apostle of Allah (peace_be_upon_him) had said.

She said: Ask the Apostle of Allah (peace_be_upon_him) what he me to do about it.

He (the Prophet) said: Tell her that she must send it to so-and-so.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4140]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4140

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: The angels do not enter a house which contains a picture, a dog, or a man who is impure by sexual defilement.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4144]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4144

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) ordered Umar ibn al-Khattab who was in al-Batha' at the time of the conquest (of Makkah) to visit the Ka'bah and obliterate all images in it. The Prophet (peace_be_upon_him) did not enter it until all the images were obliterated.


Dawud :: Clothing (Kitab Al-Libas) :: [32.4146]

Clothing (Kitab Al-Libas)

Dawud :: Book 32 : Hadith 4146

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: Gabriel (peace_be_upon_him) came to me and said: I came to you last night and was prevented from entering simply because there were images at the door, for there was a decorated curtain with images on it in the house, and there was a dog in the house. So order the head of the image which is in the house to be cut off so that it resembles the form of a tree; order the curtain to be cut up and made into two cushions spread out on which people may tread; and order the dog to be turned out.

The Apostle of Allah (peace_be_upon_him) then did so. The dog belonged to al-Hasan or al-Husayn and was under their couch. So he ordered it to be turned out.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4147]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4147

Narrated Abdullah ibn Mughaffal:

The Apostle of Allah (peace_be_upon_him) forbade combing the hair except every second day.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4148]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4148

Narrated Fudalah ibn Ubayd:

Abdullah ibn Buraydah said: A man from the companions of the Prophet (peace_be_upon_him) travelled to Fudalah ibn Ubayd when he was in Egypt.

He came to him and said: I have not come to you to visit you. But you and I heard a tradition from the Apostle of Allah (peace_be_upon_him). I hope you may have some knowledge of it.

He asked: What is it? He replied: So and so. He said: Why do I see you dishevelled when you are the ruler of this land?

He said: The Apostle of Allah (peace_be_upon_him) has forbidden us to indulge much in luxury.

He said: Why do I see you unshod? He replied: The Prophet (peace_be_upon_him) used to command us to go barefoot at times.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4149]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4149

Narrated AbuUmamah Ilyas ibn Tha'labah:

The Companions of the Apostle of Allah (peace_be_upon_him) mentioned this word before him. The Apostle of Allah (peace_be_upon_him) said: Listen, listen! Wearing old clothes is a part of faith, wearing old clothes is a part of faith.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4150]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4150

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) had sikkah with which he perfumed himself.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4151]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4151

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who has hair should honour it.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4152]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4152

Narrated Aisha, Ummul Mu'minin:

Karimah, daughter of Hammam, told that a woman came to Aisha (Allah be pleased with her) and asked her about dyeing with henna. She replied: There is no harm, but I do not like it. My beloved, the Apostle of Allah (peace_be_upon_him), disliked its odour.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4153]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4153

Narrated Aisha, Ummul Mu'minin:

When Hind, daughter of Utbah, said: Prophet of Allah, accept my allegiance, he replied; I shall not accept your allegiance till you make a difference to the palms of your hands; for they look like the paws of a beast of prey.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4154]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4154

Narrated Aisha, Ummul Mu'minin:

A woman made a sign from behind a curtain to indicate that she had a letter for the Apostle of Allah (peace_be_upon_him). The Prophet (peace_be_upon_him) closed his hand, saying: I do not know this is a man's or a woman's hand. She said: No, a woman. He said: If you were a woman, you would make a difference to your nails, meaning with henna.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4161]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4161

Narrated AbuMusa:

The Prophet (peace_be_upon_him) said: If a woman uses perfume and passes the people so that they may get its odour, she is so-and-so, meaning severe remarks.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4162]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4162

Narrated AbuHurayrah:

A woman met him and he found the odour of perfume in her. Her clothes were fluttering in the air. He said: O maid-servant of the Almighty, are you coming from the mosque? She replied: Yes. He said: For it did you use perfume? She replied: Yes. He said: I heard my beloved AbulQasim (peace_be_upon_him) say: The prayer of a woman who uses perfume for this mosque is not accepted until she returns and takes a bath like that of sexual defilement (perfectly).


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4163]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4163

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If a woman fumigates herself with perfume, she must not attend the night prayer with us. Ibn Nufayl said: Isha' means night prayer.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4164]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4164

Narrated Ammar ibn Yasir:

I came to my family at night (after a journey) with my hands chapped and they perfumed me with saffron. In the morning I went to the Prophet (peace_be_upon_him) and gave him a greeting, but he did not respond to me nor did he welcome me.

He said: Go away and wash this off yourself. I then went away and washed it off me. I came to him but there remained a spot of it on me. I give him a greeting, but he did not respond to me nor did he welcome me.

He said: Go away and wash it off yourself. I then went away and washed it off me. I then came and gave him a greeting.

He responded to me and welcomed me, saying: The angels do not attend the funeral of an unbeliever bringing good to it, nor a man who smears himself with saffron, nor a man who is sexually defiled. He said: He permitted the man who was sexually defiled to perform ablution when he slept, ate or drank.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4165]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4165

Narrated Ammar ibn Yasir:

The tradition mentioned above (No. 4164) has also been transmitted by Ammar ibn Yasir through a different chain of narrators.

This version has: Ammar said: I used khaluq. The first version is more perfect; it mentioned "taking a bath". Ibn Jurayj said: I said to Umar (a transmitter): They might be wearing ihram (robe of pilgrim)? He replied: No, they were residents.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4166]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4166

Narrated AbuMusa:

The Apostle of Allah (peace_be_upon_him) said: Allah does not accept the prayer of a man who has any khaluq (perfume composed of saffron) on his body.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4168]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4168

Narrated Ammar ibn Yasir:

The Prophet (peace_be_upon_him) said: The angels do not come near three: the dead body of the unbeliever, one who smears himself with khaluq, and the one who is sexually defiled except that he performs ablution.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4169]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4169

Narrated Al-Walid ibn Uqbah:

When the Prophet of Allah (peace_be_upon_him) conquered Makkah. The people of Makkah began to bring their boys and he would invoke a blessing on them and rub their heads. I was brought, but as I had been perfumed with khaluq, he did not touch me because of the khaluq.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4170]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4170

Narrated Anas ibn Malik:

A man came to the Apostle of Allah (peace_be_upon_him) and he had the mark of yellowness (of saffron). The Prophet (peace be upon him rarely mentioned a thing which he disliked before a man. When he went away, he said: Would that you tell this man that he should wash this off him.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4173]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4173

Narrated Anas ibn Malik:

The hair of the Apostle of Allah (peace_be_upon_him) were up to the lobes of his ears.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4175]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4175

Narrated Aisha, Ummul Mu'minin:

The hair of the Apostle of Allah (peace_be_upon_him) were above wafrah and below jummah.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4177]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4177

Narrated Aisha, Ummul Mu'minin:

When I parted the hair of the Apostle of Allah (peace_be_upon_him) I made a parting from the crow of his head and let his forelock hang between his eyes.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4178]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4178

Narrated Wa'il ibn Hujr:

I came to the Prophet (peace_be_upon_him) and I had long hair. When the Apostle of Allah (peace_be_upon_him) saw me, he said: Evil, evil! He said: I then returned and cut them off. I then came to him in the morning. He said (to me): I did not intend to do evil to you. This is much better.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4179]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4179

Narrated Umm Hani:

The Prophet (peace_be_upon_him) came to Mecca and he had four plaits of hair.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4180]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4180

Narrated Abdullah ibn Ja'far:

The Prophet (peace_be_upon_him) gave the children of Ja'far three day' time to visit them. He then came to visit them, and said: Do not weep over my brother after this day. He said: Call to me the children of my brother. We were brought to him as if we were chicken. He said: Call a barber to me. He then ordered and our heads were shaved.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4182]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4182

Narrated Abdullah ibn Umar:

the Prophet (peace_be_upon_him) forbade qaza' which means that the head of a boy is shaved and a lock is left.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4183]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4183

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) saw a boy with part of his head shaved and part left unshaven. He forbade them to do that, saying: Shave it all or leave it all.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4184]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4184

Narrated Anas ibn Malik:

I had a hanging lock of hair. My mother said to me: I shall not cut it, for the Apostle of Allah (peace_be_upon_him) used to stretch it our and hold it.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4185]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4185

Narrated Anas ibn Malik:

Al-Hajjaj ibn Hassan said: We entered upon Anas ibn Malik. My sister al-Mughirah said: You were a boy in those days and you had two locks of hair. He (Anas) rubbed your head and invoked blessing on you. He said: Shave them (i.e. the locks) or clip them, for this is the fashion of the Jews.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4190]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4190

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: Do not pluck out grey hair. If any believer grows a grey hair in Islam, he will have light on the Day of Resurrection. (This is Sufyan's version). Yahya's version says: Allah will record on his behalf a good deed for it, and will blot out a sin for it.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4193]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4193

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: The best things with which grey hair are changed are henna and katam.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4194]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4194

Narrated AbuRimthah:

I went with my father to the Prophet (peace_be_upon_him). He had locks hanging down as far as the lobes of the ears stained with henna, and he was wearing two green garments.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4195]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4195

Narrated AbuRimthah:

This version adds (to the previous hadith No 4194): My father said to him (the Prophet): Show me what is on your back, for I am a physician. He (the Prophet) said: You are only a soother. Its physician is He Who has credit it.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4196]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4196

Narrated AbuRimthah:

I and my father came to the Prophet (peace_be_upon_him). He said to a man or to my father: Who is this? He replied: He is my son. He said: Do not commit a crime on him. He had stained his beard with henna.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4198]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4198

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) used to wear tanned leather sandals and dye his beard yellow with wars and saffron.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4199]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4199

Narrated Abdullah ibn Abbas:

When a man who had dyed himself with henna passed by the Prophet (peace_be_upon_him), he said: How fine this is! When another man who had dyed himself with henna and katam passed by, he said: This is better than that. Then another man who had dyed himself with yellow dye, passed by, he said: This is better than all that.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4200]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4200

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: At the end of time there will be people who will use this black dye like the crops of doves who will not experience the fragrance of Paradise.


Dawud :: Combing the Hair (Kitab Al-Tarajjul) :: [33.4201]

Combing the Hair (Kitab Al-Tarajjul)

Dawud :: Book 33 : Hadith 4201

Narrated Thawban:

When the Apostle of Allah (peace_be_upon_him) went on a journey, the last member of his family he saw was Fatimah, and the first he visited on his return was Fatimah. Once when he returned from an expedition she had hung up a hair-cloth, or a curtain, at her door, and adorned al-Hasan and al-Husayn with silver bracelets. So when he arrived, he did not enter. Thinking that he had been prevented from entering by what he had seen, she tore down the curtain, unfastened the bracelets from the boys and cut them off.

They went weeping to the Apostle of Allah (peace_be_upon_him), and when he had taken them from them, he said: Take this to so and so's family. Thawban. In Medina, these are my family, and I did not like them to enjoy their good things in the present life. Buy Fatimah a necklace or asb, Thawban, and two ivory bracelets.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4210]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4210

Narrated Abdullah ibn Mas'ud:

The Prophet of Allah (peace_be_upon_him) disliked ten things: Yellow colouring, meaning khaluq, dyeing grey hair, trailing the lower garment, wearing a gold signet-ring, a woman decking herself before people who are not within the prohibited degrees, throwing dice, using spells except with the Mu'awwidhatan, wearing amulets, withdrawing the penis before the semen is discharged, in the case of a woman who is wife or not a wife, and having intercourse with a woman who is suckling a child; but he did not declare them to be prohibited.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4211]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4211

Narrated Buraydah ibn al-Hasib:

A man came to the Prophet (peace_be_upon_him) and he was wearing a signet-ring of yellow copper. He said to him: How is it that I notice the odour of idols in you? So he threw it away, and came wearing an iron signet ring. He (the Prophet) said: What is it that I see you wearing the adornment of the inhabitants of Hell? So he threw it away. He asked: Apostle of Allah, what material I must use? He said: Make it of silver, but do not weigh it as much as a mithqal,


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4212]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4212

Narrated AbuDhubab:

The signet-ring of the Prophet (peace_be_upon_him) was of iron polished with silver. Sometimes it remained in my possession. Al-Mu'ayqib was in charge of the signet-ring of the Prophet (peace_be_upon_him).


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4214]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4214

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) used to wear the signet-ring on his right hand.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4215]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4215

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) used to wear the signet-ring on his left hand, and put its stone next the palm of his hand.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4217]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4217

Narrated Abdullah ibn Abbas:

Muhammad ibn Ishaq said: I saw as-Salt ibn Abdullah ibn Nawfal ibn AbdulMuttalib wearing the signet-ring on his right small finger. I asked: What is this? He replied: I saw Ibn Abbas wearing his ring in this manner. He put its stone towards the upper part of his palm. Ibn Abbas also mentioned that the Apostle of Allah (peace_be_upon_him) used to wear his signet-ring in his manner.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4218]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4218

Narrated Umar ibn al-Khattab:

Ibn az-Zubayr told that a woman client of theirs took az-Zubayr's daughter to Umar ibn al-Khattab wearing bells on her legs. Umar cut them off and said that he had heard the Apostle of Allah (peace_be_upon_him) say: There is a devil along with each bell.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4220]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4220

Narrated Arfajah ibn As'ad:

AbdurRahman ibn Tarafah said that his grandfather Arfajah ibn As'ad who had his nose cut off at the battle of al-Kilab got a silver nose, but it developed a stench, so the Prophet (peace_be_upon_him) ordered him to get a gold nose.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4221]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4221

Narrated Arfajah ibn As'ad:

The tradition mentioned above (No. 4220) has also been transmitted by Arfajah ibn As'ad through a different chain to the same effect.

Yazid said: I asked AbulAshhab: Did AbdurRahman ibn Tarafah meet his grandfather Arfajah? He replied: Yes.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4223]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4223

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) got some ornaments presented by Negus as a gift to him. They contained a gold ring with an Abyssinian stone. The Apostle of Allah (peace_be_upon_him) turning his attention from it took it by means of a stick or his finger, then called Umamah, daughter of Abul'As and daughter of his daughter Zaynab, and said: Wear it, my dear daughter.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4224]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4224

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone wants to put a ring of fire on one he loves, let him put a gold ring on him: if anyone wants to put a necklace of fire on one he loves, let him put a gold necklace on him, and if anyone wants to put a bracelet of fire on one he loves let him put a gold bracelet on him. Keep to silver and amuse yourselves with it.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4225]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4225

Narrated A sister of Hudhayfah:

The Prophet (peace_be_upon_him) said: You women folk, have in silver something with which you adorn yourselves. I assure you that any woman of you who adorns herself with gold which she displays will be punished for it.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4226]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4226

Narrated Asma' daughter of Yazid:

The Prophet (peace_be_upon_him) said: Any woman who wears a gold necklace will have a similar one of fire put on her neck on the Day of Resurrection, and any woman who puts a gold earring in her ear will have a similar one of fire put in her ear on the Day of Resurrection.


Dawud :: Signet-Rings (Kitab Al-Khatam) :: [34.4227]

Signet-Rings (Kitab Al-Khatam)

Dawud :: Book 34 : Hadith 4227

Narrated Mu'awiyah ibn AbuSufyan:

The Apostle of Allah (peace_be_upon_him) forbade to ride on panther skins and to wear gold except a little.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4229]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4229

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: four (majestic) trials (fitnahs) will take place among this community, and in their end there will be destruction.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4230]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4230

Narrated Abdullah ibn Umar:

When we were sitting with the Apostle of Allah (peace_be_upon_him), he talked about periods of trial (fitnahs), mentioning many of them.

When he mentioned the one when people should stay in their houses, some asked him: Apostle of Allah, what is the trial (fitnah) of staying at home?

He replied: It will be flight and plunder. Then will come a test which is pleasant. Its murkiness is due to the fact that it is produced by a man from the people of my house, who will assert that he belongs to me, whereas he does not, for my friends are only the God-fearing. Then the people will unite under a man who will be like a hip-bone on a rib. Then there will be the little black trial which will leave none of this community without giving him a slap, and when people say that it is finished, it will be extended. During it a man will be a believer in the morning and an infidel in the evening, so that the people will be in two camps: the camp of faith which will contain no hypocrisy, and the camp of hypocrisy which will contain no faith. When that happens, expect the Antichrist (Dajjal) that day or the next.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4231]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4231

Narrated Hudhayfah ibn al-Yaman:

I swear by Allah, I do not know whether my companions have forgotten or have pretended to forgot. I swear by Allah that the Apostle of Allah (peace_be_upon_him) did not omit a leader of a wrong belief (fitnah)--up to the end of the world--whose followers reach the number of three hundred and upwards but he mentioned to us his name, his father's name and the name of his tribe.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4232]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4232

Narrated Hudhayfah ibn al-Yaman:

Subay' ibn Khalid said: I came to Kufah at the time when Tustar was conquered. I took some mules from it. When I entered the mosque (of Kufah), I found there some people of moderate stature, and among them was a man whom you could recognize when you saw him that he was from the people of Hijaz.

I asked: Who is he? The people frowned at me and said: Do you not recognize him? This is Hudhayfah ibn al-Yaman, the companion of the Apostle of Allah (peace_be_upon_him).

Then Hudhayfah said: People used to ask the Apostle of Allah (peace_be_upon_him) about good, and I used to ask him about evil. Then the people stared hard at him.

He said: I know the reason why you dislike it. I then asked: Apostle of Allah, will there be evil as there was before, after this good which Allah has bestowed on us?

He replied: Yes. I asked: Wherein does the protection from it lie? He replied: In the sword. I asked: Apostle of Allah, what will then happen?

He replied: If Allah has on Earth a caliph who flays your back and takes your property, obey him, otherwise die holding onto the stump of a tree.

I asked: What will come next? He replied: Then the Antichrist (Dajjal) will come forth accompanied by a river and fire. He who falls into his fire will certainly receive his reward, and have his load taken off him, but he who falls into his river will have his load retained and his reward taken off him.

I then asked: What will come next? He said: The Last Hour will come.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4234]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4234

Narrated Hudhayfah:

The tradition mentioned above (No. 4232) has also been transmitted through a different chain of narrators by Nasr ibn Asim al-Laythi who said: We came to al-Yashkuri with a group of the people of Banu Layth.

He asked: Who are these people? We replied: Banu Layth. We have come to you to ask you about the tradition of Hudhayfah. He then mentioned the tradition and said: I asked: Apostle of Allah, will there be evil after this good?

He replied: There will be trial (fitnah) and evil. I asked: Apostle of Allah, will there be good after this evil? He replied: Learn the Book of Allah, Hudhayfah, and adhere to its contents. He said it three times.

I asked: Apostle of Allah, will there be good after this evil? He replied: An illusory truce and a community with specks in its eye. I asked: Apostle of Allah, what do you mean by an illusory community?

He replied: The hearts of the people will not return to their former condition. I asked: Apostle of Allah, will there be evil after this good? He replied: There will be wrong belief which will blind and deafen men to the truth in which there will be summoners at the gates of Hell. If you, Hudhayfah, die adhering to a stump, it will be better for you than following any of them.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4237]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4237

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: The Muslims will soon be besieged up to Medina, so that their most distant frontier outpost will be Salah.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4240]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4240

Narrated AbuMalik al-Ash'ari:

The Prophet (peace_be_upon_him) said: Allah has protected you from three things: that your Prophet should not invoke a curse on you and should all perish, that those who follow what is false should not prevail over those who follow the truth, and that you should not all agree in an error.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4241]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4241

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: The mill of Islam will go round till the year thirty-five, or thirty-six, or thirty-seven; then if they perish, they will have followed the path of those who perished before them, but if their religion is maintained, it will be maintained for seventy years. I asked: Does it mean seventy years which remain or seventy years which are gone by? He replied: It means (seventy years) that are gone by.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4243]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4243

Narrated AbuBakrah:

The Apostle of Allah (peace_be_upon_him) said: There will be a period of commotion in which the one who lies down will be better than the one who sits, and the one who sits is better than the one who stands, and the one who stands is better than the one who walks, and the one who walks is better than the one who runs (to it).

He asked: What do you command me to do, Apostle of Allah? He replied: He who has camels should remain with his camels, he who has sheep should remain with his sheep, and he who has land should remain with his land.

He asked: If anyone has more of these, (what should he do)?

He replied: He should take his sword, strike its edge on a stone, and then escape if he can.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4244]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4244

Narrated Sa'd ibn AbuWaqqas:

I asked: Apostle of Allah! tell me if someone enters my house and extends his hands to kill me (what should I do?) The Apostle of Allah (peace_be_upon_him) replied: Be like the two sons of Adam. The narrator Yazid (ibn Khalid) then recited the verse: "If thou dost stretch they hand against me to slay me."


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4245]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4245

Narrated Abdullah ibn Mas'ud ; Khuraym ibn Fatik:

The tradition mentioned above (No. 4243) has also been transmitted by Ibn Mas'ud through a different chain of narrators.

Ibn Mas'ud said: I heard the Prophet (peace_be_upon_him) say: He then mentioned a portion of the tradition narrated by AbuBakrah (No. 4243).

This version adds: He (the Prophet) said: All their slain will go to Hell. I (Wabisah) asked: When will this happen Ibn Mas'ud?

He replied: This is the period of turmoil (harj) when a man will not be safe from his associates.

I asked: What do you command me (to do) if I happen to live during that period? He replied: You should restrain your tongue and hand and stay at home.

When Uthman was slain, I recollected this tradition. I then rode (on a camel) and came to Damascus. There I met Khuraym ibn Fatik and mentioned this tradition to him. He swore by Allah, there was no god but He, he had heard it from the Apostle of Allah (peace_be_upon_him), as Ibn Mas'ud transmitted it to me (Wabisah).


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4246]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4246

Narrated AbuMusa al-Ash'ari:

The Apostle of Allah (peace_be_upon_him) said: Before the Last Hour there will be commotions like pieces of a dark night in which a man will be a believer in the morning and an infidel in the evening, or a believer in the evening and infidel in the morning. He who sits during them will be better than he who gets up and he who walks during them is better than he who runs. So break your bows, cut your bowstrings and strike your swords on stones. If people then come in to one of you, let him be like the better of Adam's two sons.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4247]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4247

Narrated Abdullah ibn Umar:

AbdurRahman ibn Samurah said: I was holding the hand of Ibn Umar on one of the ways of Medina. He suddenly came to a hanging head. He said: Unhappy is the one who killed him. When he proceeded, he said: I do not consider him but unfortunate. I heard the Apostle of Allah (peace_be_upon_him) say: If anyone goes to a man of my community in order to kill him, he should say in this way, the one who kills will go to Hell and the one who is killed will go to Paradise.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4248]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4248

Narrated AbuDharr:

The Apostle of Allah (peace_be_upon_him) said to me: O AbuDharr. I replied: At thy service and at thy pleasure, Apostle of Allah. He then mentioned the tradition in which he said: What will you do when there the death of the people (in Medina) and a house will reach the value of a slave (that is, a grave will be sold for a slave).

I replied: Allah and His Apostle know best. Or he said: What Allah and His Apostle choose for me.

He said: You must show endurance. Or he said; you may endure. He then said to me: What will you do, AbuDharr, when you see the Ahjar az-Zayt covered with blood?

I replied: What Allah and His Apostle choose for me.

He said: You must go to those who are like-minded.

I asked: Should I not take my sword and put it on my shoulder? He replied: you would then associate yourself with the people. I then asked: What do you order me to do? You must stay at home. I asked: (What should I do) if people enter my house and find me?

He replied: If you are afraid the gleam of the sword may dazzle you, put the end of your garment over your face in order that (the one who kills you) may bear the punishment of your sins and his.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4249]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4249

Narrated AbuMusa al-Ash'ari:

The Prophet (peace_be_upon_him) said: Before you there will be commotions like pieces of a dark night in which a man will be a believer in the morning and an infidel in the evening. He who sits during them will be better than he who gets up, and he who gets up during them is better than he who walks, and he who walks during them is better than he who runs. They (the people) said: What do you order us to do? He replied: Keep to your houses.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4250]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4250

Narrated Al-Miqdad ibn al-Aswad:

I swear by Allah, I heard the Apostle of Allah (peace_be_upon_him) say: The happy man is he who avoids dissensions: happy is the man who avoids dissensions; happy is the man who avoids dissensions: but how fine is the man who is afflicted and shows endurance.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4251]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4251

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: There will be civil strife (fitnah) which will render people deaf, dumb and blind regarding what is right. Those who contemplate it will be drawn by it, and giving rein to the tongue during it will be like smiting with the sword.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4252]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4252

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: There will be civil strife which wipe out the Arabs, and their slain will go to Hell. During it the tongue will be more severe than blows of the sword.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4257]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4257

Narrated AbudDarda' and Ubadah ibn as-Samit:

Khalid ibn Dihqan said: When we were engaged in the battle of Constantinople at Dhuluqiyyah, a man of the people of Palestine, who was one of their nobility and elite and whose rank was known to them, came forward. He was called Hani ibn Kulthum ibn Sharik al-Kinani. He greeted Abdullah ibn Zakariyya who knew his rank.

Khalid said to us: Abdullah ibn AbuZakariyya told us: I heard Umm ad-Darda' say: I heard AbudDarda' say: I heard the Apostle of Allah (peace_be_upon_him) say: It is hoped that Allah may forgive every sin, except in the case of one who dies a polytheist, or one who purposely kills a believer.

Hani ibn Kulthum ar-Rabi' then said: I heard Mahmud ibn ar-Rabi' transmitting a tradition from Ubadah ibn as-Samit who transmitted from the Apostle of Allah (peace_be_upon_him) who said: If a man kills a believer unjustly, Allah will not accept any action or duty of his, obligatory or supererogatory.

Khalid then said to us: Ibn AbuZakariyya transmitted a tradition to us from Umm ad-Darda' on the authority of AbudDarda' from the Apostle of Allah (peace_be_upon_him) who said: A believer will continue to go on quickly and well so long as he does not shed unlawful blood; when he sheds unlawful blood, he becomes slow and heavy-footed.

A similar tradition has been transmitted by Hani ibn Kulthum from Mahmud ibn ar-Rabi' on the authority of Ubadah ibn as-Samit from the Apostle of Allah (peace_be_upon_him).


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4259]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4259

Narrated Zayd ibn Thabit:

The verse "If a man kills a believer intentionally, his recompense is Hell to abide therein for ever" was revealed six months after the verse "And those who invoke not with Allah any other god, nor slay such life as Allah has made sacred, except for just cause in Surat al-Furqan.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4264]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4264

Narrated Sa'id ibn Zayd:

We were with the Prophet (peace_be_upon_him). He mentioned civil strife (fitnah) and expressed its gravity. We or the people said: Apostle of Allah, if this happens to us it will destroy us. The Apostle of Allah (peace_be_upon_him) said; No. It is enough for you that you would be killed. Sa'id said: I saw that my brethren were killed.


Dawud :: Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim) :: [35.4265]

Trials and Fierce Battles (Kitab Al-Fitan Wa Al-Malahim)

Dawud :: Book 35 : Hadith 4265

Narrated AbuMusa:

The Prophet (peace_be_upon_him) said: This people of mine is one to which mercy is shown. It will have no punishment in the next world, but its punishment in this world will be trials, earthquakes and being killed.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4266]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4266

Narrated Jabir ibn Samurah:

The Prophet (peace_be_upon_him) said: The religion will continue to be established till there are twelve caliphs over you, and the whole community will agree on each of them. I then heard from the Prophet (peace_be_upon_him) some remarks which I could not understand. I asked my father: What is he saying: He said: all of them will belong to Quraysh.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4269]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4269

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: If only one day of this world remained. Allah would lengthen that day (according to the version of Za'idah), till He raised up in it a man who belongs to me or to my family whose father's name is the same as my father's, who will fill the earth with equity and justice as it has been filled with oppression and tyranny (according to the version of Fitr). Sufyan's version says: The world will not pass away before the Arabs are ruled by a man of my family whose name will be the same as mine.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4270]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4270

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: If only one day of this time (world) remained, Allah would raise up a man from my family who would fill this earth with justice as it has been filled with oppression.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4271]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4271

Narrated Umm Salamah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: The Mahdi will be of my family, of the descendants of Fatimah. Abdullah ibn Ja'far said: I heard AbulMalih praising Ali ibn Nufayl and describing his good qualities.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4272]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4272

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: The Mahdi will be of my stock, and will have a broad forehead a prominent nose. He will fill the earth will equity and justice as it was filled with oppression and tyranny, and he will rule for seven years.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4273]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4273

Narrated Umm Salamah, Ummul Mu'minin:

The Prophet (peace_be_upon_him) said: Disagreement will occur at the death of a caliph and a man of the people of Medina will come flying forth to Mecca. Some of the people of Mecca will come to him, bring him out against his will and swear allegiance to him between the Corner and the Maqam. An expeditionary force will then be sent against him from Syria but will be swallowed up in the desert between Mecca and Medina. When the people see that, the eminent saints of Syria and the best people of Iraq will come to him and swear allegiance to him between the Corner and the Maqam.

Then there will arise a man of Quraysh whose maternal uncles belong to Kalb and send against them an expeditionary force which will be overcome by them, and that is the expedition of Kalb. Disappointed will be the one who does not receive the booty of Kalb. He will divide the property, and will govern the people by the Sunnah of their Prophet (peace_be_upon_him) and establish Islam on Earth. He will remain seven years, then die, and the Muslims will pray over him.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4276]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4276

Narrated Ali ibn AbuTalib:

AbuIshaq told that Ali looked at his son al-Hasan and said: This son of mine is a sayyid (chief) as named by the Prophet (peace_be_upon_him), and from his loins will come forth a man who will be called by the name of your Prophet (peace_be_upon_him) and resemble him in conduct but not in appearance. He then mentioned the story about his filling the earth with justice.


Dawud :: The Promised Deliverer (Kitab Al-Mahdi) :: [36.4277]

The Promised Deliverer (Kitab Al-Mahdi)

Dawud :: Book 36 : Hadith 4277

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: A man called al-Harith ibn Harrath will come forth from Ma Wara an-Nahr. His army will be led by a man called Mansur who will establish or consolidate things for Muhammad's family as Quraysh consolidated them for the Apostle of Allah (peace_be_upon_him). Every believer must help him, or he said: respond to his sermons.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4278]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4278

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Allah will raise for this community at the end of every hundred years the one who will renovate its religion for it.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4281]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4281

Narrated Mu'adh ibn Jabal:

The Prophet (peace_be_upon_him) said: The flourishing state of Jerusalem will be when Yathrib is in ruins, the ruined state of Yathrib will be when the great war comes, the outbreak of the great war will be at the conquest of Constantinople and the conquest of Constantinople when the Dajjal (Antichrist) comes forth. He (the Prophet) struck his thigh or his shoulder with his hand and said: This is as true as you are here or as you are sitting (meaning Mu'adh ibn Jabal).


Dawud :: Battles (Kitab Al-Malahim) :: [37.4282]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4282

Narrated Mu'adh ibn Jabal:

The Prophet (peace_be_upon_him) said: The greatest war, the conquest of Constantinople and the coming forth of the Dajjal (Antichrist) will take place within a period of seven months.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4283]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4283

Narrated Abdullah ibn Busr:

The Prophet (peace_be_upon_him) said: The time between the great war and the conquest of the city (Constantinople) will be six years, and the Dajjal (Antichrist) will come forth in the seventh.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4284]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4284

Narrated Thawban:

The Prophet (peace_be_upon_him) said: The people will soon summon one another to attack you as people when eating invite others to share their dish. Someone asked: Will that be because of our small numbers at that time? He replied: No, you will be numerous at that time: but you will be scum and rubbish like that carried down by a torrent, and Allah will take fear of you from the breasts of your enemy and last enervation into your hearts. Someone asked: What is wahn (enervation). Apostle of Allah (peace_be_upon_him): He replied: Love of the world and dislike of death.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4285]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4285

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: The place of assembly of the Muslims at the time of the war will be in al-Ghutah near a city called Damascus, one of the best cities in Syria.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4287]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4287

Narrated Awf ibn Malik:

The Prophet (peace_be_upon_him) said: Allah will not gather two swords upon this community: Its own sword and the sword of its enemy.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4288]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4288

Narrated One of the Companions:

The Prophet (peace_be_upon_him) said: Let the Abyssinians alone as long as they let you alone, and let the Turks alone as long as they leave you alone.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4292]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4292

Narrated AbuBakrah:

The Apostle of Allah (peace_be_upon_him) said: Some of my people will alight on low-lying ground, which they will call al-Basrah, beside a river called Dajjal (the Tigris) over which there is a bridge. Its people will be numerous and it will be one of the capital cities of immigrants (or one of the capital cities of Muslims, according to the version of Ibn Yahya who reported from AbuMa'mar).

At the end of time the descendants of Qantura' will come with broad faces and small eyes and alight on the bank of the river. The town's inhabitants will then separate into three sections, one of which will follow cattle and (live in) the desert and perish, another of which will seek security for themselves and perish, but a third will put their children behind their backs and fight the invaders, and they will be the martyrs.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4293]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4293

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: The people will establish cities, Anas, and one of them will be called al-Basrah or al-Busayrah. If you should pass by it or enter it, avoid its salt-marshes, its Kall, its market, and the gate of its commanders, and keep to its environs, for the earth will swallow some people up, pelting rain will fall and earthquakes will take place in it, and there will be people who will spend the night in it and become apes and swine in the morning.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4294]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4294

Narrated AbuHurayrah:

Salih ibn Dirham said: We went on the pilgrimage and met a man who asked us: Is there a town near you called al-Ubullah? We said: Yes. He said: Is there any of you who will undertake to pray two or four rak'ahs on my behalf in the mosque of al-Ashshar, stating "they are on behalf of AbuHurayrah"?

He (AbuHurayrah) said: I heard my friend AbulQasim (peace_be_upon_him) say: On the Day of Resurrection Allah will raise martyrs from the mosque of al-Ashshar, who will be the only ones to rise with the martyrs of Badr.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4295]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4295

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Leave the Abyssinians alone as long as they leave you alone, for it is only the Abyssinian with short legs who will seek to take out the treasure of the Ka'bah.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4305]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4305

Narrated Imran ibn Husayn:

The Prophet (peace_be_upon_him) said: Let him who hears of the Dajjal (Antichrist) go far from him for I swear by Allah that a man will come to him thinking he is a believer and follow him because of confused ideas roused in him by him.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4306]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4306

Narrated Ubadah ibn as-Samit:

The Prophet (peace_be_upon_him) said: I have told you so much about the Dajjal (Antichrist) that I am afraid you may not understand. The Antichrist is short, hen-toed, woolly-haired, one-eyed, an eye-sightless, and neither protruding nor deep-seated. If you are confused about him, know that your Lord is not one-eyed.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4310]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4310

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: There is no prophet between me and him, that is, Jesus (peace_be_upon_him). He will descent (to the earth). When you see him, recognise him: a man of medium height, reddish fair, wearing two light yellow garments, looking as if drops were falling down from his head though it will not be wet. He will fight the people for the cause of Islam. He will break the cross, kill swine, and abolish jizyah. Allah will perish all religions except Islam. He will destroy the Antichrist and will live on the earth for forty years and then he will die. The Muslims will pray over him.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4311]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4311

Narrated Fatimah, daughter of Qays:

The Apostle of Allah (peace_be_upon_him) once delayed the congregational night prayer.

He came out and said: The talk of Tamim ad-Dari detained me. He transmitted it to me from a man who was on of of the islands of the sea. All of a sudden he found a woman who was trailing her hair. He asked: Who are you?

She said: I am the Jassasah. Go to that castle. So I came to it and found a man who was trailing his hair, chained in iron collars, and leaping between Heaven and Earth.

I asked: Who are you? He replied: I am the Dajjal (Antichrist). Has the Prophet of the unlettered people come forth now? I replied: Yes. He said: Have they obeyed him or disobeyed him? I said: No, they have obeyed him. He said: That is better for them.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4314]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4314

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) said one day from the pulpit: When some people were sailing in the sea, their food was finished. An island appeared to them. They went out seeking bread. They were met by the Jassasah (the Antichrist's spy).

I said to AbuSalamah: What is the Jassasah? He replied: A woman trailing the hair of her skin and of her head. She said: In this castle. He then narrated the rest of the (No. 4311) tradition. He asked about the palm-trees of Baysan and the spring of Zughar. He said: He is the Antichrist. Ibn Salamah said to me: There is something more in this tradition, which I could not remember. He said: Jabir testified that it was he who was Ibn Sayyad.

I said: He died. He said: Let him die. I said: He accepted Islam. He said: Let him accept Islam. I said: He entered Medina. He said: Let him enter Medina.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4316]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4316

Narrated Abdullah ibn Umar:

Nafi' told that Ibn Umar used to say: I swear by Allah that I do not doubt that Antichrist is Ibn Sayyad.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4317]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4317

Narrated Jabir ibn Abdullah:

Muhammad ibn al-Munkadir told that he saw Jabir ibn Abdullah swearing by Allah that Ibn as-Sa'id was the Dajjal (Antichrist). I expressed my surprise by saying: You swear by Allah! He said: I heard Umar swearing to that in the presence of the Apostle of Allah (peace_be_upon_him), but the Apostle of Allah (peace_be_upon_him) did not make any objection to it.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4318]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4318

Narrated Jabir ibn Abdullah:

We saw the last of Ibn Sayyad at the battle of the Harrah.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4319]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4319

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The Last Hour will not come before there come forth thirty Dajjals (fraudulents), everyone presuming himself that he is an apostle of Allah.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4320]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4320

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The Last Hour will not come before there come forth thirty liar Dajjals (fraudulents) lying on Allah and His Apostle.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4322]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4322

Narrated Abdullah ibn Mas'ud:

The Apostle of Allah (peace_be_upon_him) said: The first defect that permeated Banu Isra'il was that a man (of them) met another man and said: O so-and-so, fear Allah, and abandon what you are doing, for it is not lawful for you. He then met him the next day and that did not prevent him from eating with him, drinking with him and sitting with him. When they did so. Allah mingled their hearts with each other.

He then recited the verse: "curses were pronounced on those among the children of Isra'il who rejected Faith, by the tongue of David and of Jesus the son of Mary"...up to "wrongdoers".

He then said: By no means, I swear by Allah, you must enjoin what is good and prohibit what is evil, prevent the wrongdoer, bend him into conformity with what is right, and restrict him to what is right.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4323]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4323

Narrated Abdullah ibn Mas'ud:

A similar tradition (to the No. 4322) has also been transmitted by Ibn Mas'ud through a different chain of narrators to the same effect.

This version adds: "Or Allah will mingle your hearts together and curse you as He cursed them."


Dawud :: Battles (Kitab Al-Malahim) :: [37.4324]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4324

Narrated AbuBakr:

You people recite this verse "You who believe, care for yourselves; he who goes astray cannot harm you when you are rightly-guided," and put it in its improper place.

Khalid's version has: We heard the Prophet (peace_be_upon_him) say: When the people see a wrongdoer and do not prevent him, Allah will soon punish them all. Amr ibn Hushaym's version has: I heard the Apostle of Allah (peace_be_upon_him) say: If acts of disobedience are done among any people and do not change them though the are able to do so, Allah will soon punish them all.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4325]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4325

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If any man is among a people in whose midst he does acts of disobedience, and, though they are able to make him change (his acts), they do not change, Allah will smite them with punishment before they die.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4327]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4327

Narrated AbuTha'labah al-Khushani:

AbuUmayyah ash-Sha'bani said: I asked AbuTha'labah al-Khushani: What is your opinion about the verse "Care for yourselves".

He said: I swear by Allah, I asked the one who was well informed about it; I asked the Apostle of Allah (peace_be_upon_him) about it.

He said: No, enjoin one another to do what is good and forbid one another to do what is evil.

But when you see niggardliness being obeyed, passion being followed, worldly interests being preferred, everyone being charmed with his opinion, then care for yourself, and leave alone what people in general are doing; for ahead of you are days which will require endurance, in which showing endurance will be like grasping live coals. The one who acts rightly during that period will have the reward of fifty men who act as he does.

Another version has: He said (The hearers asked:) Apostle of Allah, the reward of fifty of them?

He replied: The reward of fifty of you.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4328]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4328

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: How will you do when that time will come? Or he said: A time will soon come when the people are sifted and only dregs of mankind survive and their covenants and guarantees have been impaired and they have disagreed among themselves and become thus, interwining his fingers. They asked: What do you order us to do, Apostle of Allah? He replied: Accept what you approve, abandon what you disapprove, attend to your own affairs and leave alone the affairs of the generality.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4329]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4329

Narrated Abdullah ibn Amr ibn al-'As:

When we were around the Apostle of Allah (peace_be_upon_him), he mentioned the period of commotion (fitnah) saying: When you see the people that their covenants have been impaired, (the fulfilling of) the guarantees becomes rare, and they become thus (interwining his fingers). I then got up and said: What should I do at that time, may Allah make me ransom for you? He replied: Keep to your house, control your tongue, accept what you approve, abandon what you disapprove, attend to your own affairs, and leave alone the affairs of the generality.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4330]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4330

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: The best fighting (jihad) in the path of Allah is (to speak) a word of justice to an oppressive ruler.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4331]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4331

Narrated Amirah al-Kindi:

The Prophet (peace_be_upon_him) said: When sin is done in the earth, he who sees it and disapproves of it will be taken like one who was not present, but he who is not present and approves of it will be like him who sees.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4335]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4335

Narrated AbuTha'labah al-Khushani:

The Prophet (peace_be_upon_him) said: Allah will not fail to detain this community for less than half a day.


Dawud :: Battles (Kitab Al-Malahim) :: [37.4336]

Battles (Kitab Al-Malahim)

Dawud :: Book 37 : Hadith 4336

Narrated Sa'd ibn AbuWaqqas:

The Prophet (peace_be_upon_him) said: I hope my community will not fail to maintain their position in the sight of their Lord if He delays them half a day. Sa'd was asked: How long is half a day? He said: It is five hundred years.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4339]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4339

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) Said: The blood of a Muslim man who testifies that there is no god but Allah and that Muhammad is Allah's Apostle should not lawfully be shed except only for one of three reasons: a man who committed fornication after marriage, in which case he should be stoned; one who goes forth to fight with Allah and His Apostle, in which case he should be killed or crucified or exiled from the land; or one who commits murder for which he is killed.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4341]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4341

Narrated Mu'adh ibn Jabal:

AbuMusa said: Mu'adh came to me when I was in the Yemen. A man who was Jew embraced Islam and then retreated from Islam. When Mu'adh came, he said: I will not come down from my mount until he is killed. He was then killed. One of them said: He was asked to repent before that.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4345]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4345

Narrated Abdullah ibn Abbas:

Abdullah ibn AbuSarh used to write (the revelation) for the Apostle of Allah (peace_be_upon_him). Satan made him slip, and he joined the infidels. The Apostle of Allah (peace_be_upon_him) commanded to kill him on the day of Conquest (of Mecca). Uthman ibn Affan sought protection for him. The Apostle of Allah (peace_be_upon_him) gave him protection.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4346]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4346

Narrated Sa'd ibn AbuWaqqas:

On the day of the conquest of Mecca, Abdullah ibn Sa'd ibn AbuSarh hid himself with Uthman ibn Affan.

He brought him and made him stand before the Prophet (peace_be_upon_him), and said: Accept the allegiance of Abdullah, Apostle of Allah! He raised his head and looked at him three times, refusing him each time, but accepted his allegiance after the third time.

Then turning to his companions, he said: Was not there a wise man among you who would stand up to him when he saw that I had withheld my hand from accepting his allegiance, and kill him?

They said: We did not know what you had in your heart, Apostle of Allah! Why did you not give us a signal with your eye?

He said: It is not advisable for a Prophet to play deceptive tricks with the eyes.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4348]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4348

Narrated Abdullah Ibn Abbas:

A blind man had a slave-mother who used to abuse the Prophet (peace_be_upon_him) and disparage him. He forbade her but she did not stop. He rebuked her but she did not give up her habit. One night she began to slander the Prophet (peace_be_upon_him) and abuse him. So he took a dagger, placed it on her belly, pressed it, and killed her. A child who came between her legs was smeared with the blood that was there. When the morning came, the Prophet (peace_be_upon_him) was informed about it.

He assembled the people and said: I adjure by Allah the man who has done this action and I adjure him by my right to him that he should stand up. Jumping over the necks of the people and trembling the man stood up.

He sat before the Prophet (peace_be_upon_him) and said: Apostle of Allah! I am her master; she used to abuse you and disparage you. I forbade her, but she did not stop, and I rebuked her, but she did not abandon her habit. I have two sons like pearls from her, and she was my companion. Last night she began to abuse and disparage you. So I took a dagger, put it on her belly and pressed it till I killed her.

Thereupon the Prophet (peace_be_upon_him) said: Oh be witness, no retaliation is payable for her blood.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4349]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4349

Narrated Ali ibn AbuTalib:

A Jewess used to abuse the Prophet (peace_be_upon_him) and disparage him. A man strangled her till she died. The Apostle of Allah (peace_be_upon_him) declared that no recompense was payable for her blood.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4350]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4350

Narrated AbuBakr:

AbuBarzah said: I was with AbuBakr. He became angry at a man and uttered hot words. I said: Do you permit me, Caliph of the Apostle of Allah (peace_be_upon_him), that I cut off his neck? These words of mine removed his anger; he stood and went in. He then sent for me and said: What did you say just now? I said: (I had said:) Permit me that I cut off his neck. He said: Would you do it if I ordered you? I said: Yes. He said: No, I swear by Allah, this is not allowed for any man after Muhammad (peace_be_upon_him).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4356]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4356

Narrated Abdullah ibn Umar:

Some people raided the camels of the Prophet (peace_be_upon_him), drove them off, and apostatised. They killed the herdsman of the Apostle of Allah (peace_be_upon_him) who was a believer. He (the Prophet) sent (people) in pursuit of them and they were caught. He had their hands and feet cut off, and their eyes put out. The verse regarding fighting against Allah and His Prophet (peace_be_upon_him) was then revealed. These were the people about whom Anas ibn Malik informed al-Hajjaj when he asked him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4357]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4357

Narrated AbuzZinad:

When the Apostle of Allah (peace_be_upon_him) cut off (the hands and feet of) those who had stolen his camels and he had their eyes put out by fire (heated nails), Allah reprimanded him on that (action), and Allah, the Exalted, revealed: "The punishment of those who wage war against Allah and His Apostle and strive with might and main for mischief through the land is execution or crucifixion."


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4359]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4359

Narrated Abdullah ibn Abbas:

The verse "The punishment of those who wage war against Allah and His Apostle, and strive with might and main for mischief through the land is execution, or crucifixion, or the cutting off of hands and feet from opposite side or exile from the land...most merciful" was revealed about polytheists. If any of them repents before they are arrested, it does not prevent from inflicting on him the prescribed punishment which he deserves.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4362]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4362

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) Said: Forgive the people of good qualities their slips, but not faults to which prescribed penalties apply.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4363]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4363

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Forgive the infliction of prescribed penalties among yourselves, for any prescribed penalty of which I hear must be carried out.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4364]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4364

Narrated Nu'aym:

Ma'iz came to the Prophet (peace_be_upon_him) and admitted (having committed adultery) four times in his presence so he ordered him to be stoned to death, but said to Huzzal: If you had covered him with your garment, it would have been better for you.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4366]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4366

Narrated Wa'il ibn Hujr:

When a woman went out in the time of the Prophet (peace_be_upon_him) for prayer, a man attacked her and overpowered (raped) her.

She shouted and he went off, and when a man came by, she said: That (man) did such and such to me. And when a company of the Emigrants came by, she said: That man did such and such to me. They went and seized the man whom they thought had had intercourse with her and brought him to her.

She said: Yes, this is he. Then they brought him to the Apostle of Allah (peace_be_upon_him).

When he (the Prophet) was about to pass sentence, the man who (actually) had assaulted her stood up and said: Apostle of Allah, I am the man who did it to her.

He (the Prophet) said to her: Go away, for Allah has forgiven you. But he told the man some good words (AbuDawud said: meaning the man who was seized), and of the man who had had intercourse with her, he said: Stone him to death.

He also said: He has repented to such an extent that if the people of Medina had repented similarly, it would have been accepted from them.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4367]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4367

Narrated AbuUmayyah al-Makhzumi:

A thief who had accepted (having committed theft) was brought to the Prophet (peace_be_upon_him), but no good were found with him. The Apostle of Allah (peace_be_upon_him), said to him: I do not think you have stolen. He said: Yes, I have. He repeated it twice or thrice. So he gave orders. His hand was cut off and he was then brought to him. He said: Ask Allah's pardon and turn to Him in repentance. He said: I ask Allah's pardon and turn to Him in repentance. He (the Prophet) then said: O Allah, accept his repentance.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4369]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4369

Narrated An-Nu'man ibn Bashir:

Azhar ibn Abdullah al-Harari said: Some goods of the people of Kila' were stolen. They accused some men of the weavers (of theft). They came to an-Nu'man ibn Bashir, the companion of the Prophet (peace_be_upon_him). He confined them for some days and then set them free.

They came to an-Nu'man and said: You have set them free without beating and investigation. An-Nu'man said: What do you want? You want me to beat them. If your goods are found with them, then it is all right; otherwise, I shall take (retaliation) from your back as I have taken from their backs. They asked: Is this your decision? He said: This is the decision of Allah and His Apostle (peace_be_upon_him).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4373]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4373

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) had a man's hand cut off who had stolen from the place reserved for women a shield whose price was three dirhams.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4374]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4374

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) had a man's hand cut off for (stealing) a shield whose price was a dinar or ten dirhams.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4375]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4375

Narrated Rafi' ibn Khadij:

Muhammad ibn Yahya ibn Hibban said: A slave stole a plant of a palm-tree from the orchard of a man and planted it in the orchard of his master. The owner of the plant went out in search of the plant and he found it. He solicited help against the slave from Marwan ibn al-Hakam who was the Governor of Medina at that time. Marwan confined the slave and intended to cut off his hand. The slave's master went to Rafi' ibn Khadij and asked him about it.

He told him that he had heard the Apostle of Allah (peace_be_upon_him) say: The hand is not to be cut off for taking fruit or the pith of the palm-tree.

The man then said: Marwan has seized my slave and wants to cut off his hand. I wish you to go with me to him and tell him that which you have heard from the Apostle of Allah (peace_be_upon_him). So Rafi' ibn Khadij went with him and came to Marwan ibn al-Hakam.

Rafi' said to him: I heard the Apostle of Allah (peace_be_upon_him) say: The hand is not to be cut off for taking fruit or the pith of the palm-tree. So Marwan gave orders to release the slave and then he was released.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4377]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4377

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) was asked about fruit which was bung up and said: If a needy person takes some with his mouth and does not take a supply away in his garment, there is nothing on him, but he who carries any of it is to be fined twice the value and punished, and he who steals any of it after it has been put in the place where dates are dried to have his hand cut off if their value reaches the value of a shield. If he steals a thing less in value than it, he is to be find twice the value and punished.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4378]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4378

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Cutting of hand is not to be inflicted on one who plunders, but he who plunders conspicuously does not belong to us.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4380]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4380

Narrated Safwan:

AbuDawud said: Za'idah has also transmitted it from Simak from Ju'ayd ibn Hujayr. He said: Safwan slept. Mujahid and Tawus said: While he was sleeping a thief came and stole the cloak from beneath his head. The version of AbuSalamah ibn AbdurRahman has: He snatched it away from beneath his head and he awoke. He cried and he (the thief) was seized. Az-Zuhri narrated from Safwan ibn Abdullah. His version has: He slept in the mosque and used his cloak as pillow. A thief came and took his cloak. The thief was seized and brought to the Prophet (peace_be_upon_him).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4382]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4382

Narrated Aisha, Ummul Mu'minin:

A woman borrowed jewellery through some known persons and she herself was unknown. She then sold them. She was seized and brought to the Prophet (peace_be_upon_him). He gave orders that her hand should be cut off. It is this woman about whom Usamah interceded and of her the Apostle of Allah (peace_be_upon_him) said whatever he said.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4384]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4384

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: There are three (persons) whose actions are not recorded: a sleeper till he awakes, an idiot till he is restored to reason, and a boy till he reaches puberty.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4385]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4385

Narrated Ali ibn AbuTalib:

Ibn Abbas said: A lunatic woman who had committed adultery was brought to Umar. He consulted the people and ordered that she should be stoned.

Ali ibn AbuTalib passed by and said: What is the matter with this (woman)? They said: This is a lunatic woman belonging to a certain family. She has committed adultery. Umar has given orders that she should be stoned.

He said: Take her back. He then came to him and said: Commander of the Faithful, do you not know that there are three people whose actions are not recorded: a lunatic till he is restored to reason, a sleeper till he awakes, and a boy till he reaches puberty?

He said: Yes. He then asked: Why is it that this woman is being stoned?

He said: There is nothing. He then said: Let her go. He (Umar) let her go and began to utter: Allah is most great.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4387]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4387

Narrated Ali ibn AbuTalib:

Ibn Abbas said: A lunatic woman passed by Ali ibn AbuTalib. He then mentioned the rest of the tradition to the same effect as Uthman mentioned. This version has: Do you not remember that the Apostle of Allah (peace_be_upon_him) has said: There are three whose actions are not recorded: a lunatic whose mind is deranged till he is restored to consciousness, a sleeper till he awakes, and a boy till he reaches puberty?


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4388]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4388

Narrated Ali ibn AbuTalib:

AbuZubyan said: A woman who had committed adultery was brought to Umar. He gave orders that she should be stoned.

Ali passed by just then. He seized her and let her go. Umar was informed of it. He said: Ask Ali to come to me. Ali came to him and said: Commander of the Faithful, you know that the Apostle of Allah (peace_be_upon_him) said: There are three (people) whose actions are not recorded: A boy till he reaches puberty, a sleeper till he awakes, a lunatic till he is restored to reason. This is an idiot (mad) woman belonging to the family of so and so. Someone might have done this action with her when she suffered the fit of lunacy.

Umar said: I do not know. Ali said: I do not know.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4389]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4389

Narrated Ali ibn AbuTalib:

The Prophet (peace_be_upon_him) said: There are three (persons) whose actions are not recorded: a sleeper till he awakes, a boy till he reaches puberty, and a lunatic till he comes to reason.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4390]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4390

Narrated Atiyyah al-Qurazi:

I was among the captives of Banu Qurayzah. They (the Companions) examined us, and those who had begun to grow hair (pubes) were killed, and those who had not were not killed. I was among those who had not grown hair.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4394]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4394

Narrated Busr ibn Artat:

Junadah ibn AbuUmayyah said: We were with Busr ibn Artat on the sea (on an expedition). A thief called Misdar who had stolen a bukhti she-camel was brought. He said: I heard the Apostle of Allah (peace_be_upon_him) say: Hands are not to be cut off during a warlike expedition. Had it not been so, I would have cut it off.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4395]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4395

Narrated AbuDharr:

The Apostle of Allah (peace_be_upon_him) said to me: O AbuDharr: I replied: At your service and at your pleasure, Apostle of Allah! He said: how will you do when death smites people, and a house, meaning a grave, will cost as much as a slave. I said: Allah and His Apostle know best, or he said: What Allah and His Apostle choose for me. He said: Show endurance, or he said: You may show endurance.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4396]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4396

Narrated Jabir ibn Abdullah:

A thief was brought to the Prophet (peace_be_upon_him). He said: Kill him. The people said: He has committed theft, Apostle of Allah! Then he said: Cut off his hand. So his (right) hand was cut off. He was brought a second time and he said: Kill him. The people said: He has committed theft, Apostle of Allah! Then he said: Cut off his foot.

So his (left) foot was cut off.

He was brought a third time and he said: Kill him.

The people said: He has committed theft, Apostle of Allah!

So he said: Cut off his hand. (So his (left) hand was cut off.)

He was brought a fourth time and he said: Kill him.

The people said: He has committed theft, Apostle of Allah!

So he said: Cut off his foot. So his (right) foot was cut off.

He was brought a fifth time and he said: Kill him.

So we took him away and killed him. We then dragged him and cast him into a well and threw stones over him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4397]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4397

Narrated Fadalah ibn Ubayd:

A thief was brought to the Apostle of Allah (peace_be_upon_him) and his hand was cut off. Thereafter he commanded for it, and it was hung on his neck.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4398]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4398

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When a slave steals, sell him, even though it be for half an uqiyah.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4403]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4403

Narrated Ubadah ibn as-Samit:

The tradition mentioned above (No. 4401) has also been transmitted by Ubadah ibn as-Samit through a different chain of narrators.

This version has: The people said to Sa'd ibn Ubadah: AbuThabit, the prescribed punishments have been revealed: if you find a man with your wife, what will you do?

He said: I shall strike them with a sword so much that they become silent (i.e. die). Should I go and gather four witnesses? Until that (time) the need would be fulfilled.

So they went away and gathered with the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah! did you not see AbuThabit. He said so-and-so.

The Apostle of Allah (peace_be_upon_him) said: The sword is a sufficient witness. He then said: No, no, a furious and a jealous man may follow this course.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4405]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4405

Narrated Nu'aym ibn Huzzal:

Yazid ibn Nu'aym ibn Huzzal, on his father's authority said: Ma'iz ibn Malik was an orphan under the protection of my father. He had illegal sexual intercourse with a slave-girl belonging to a clan. My father said to him: Go to the Apostle of Allah (peace_be_upon_him) and inform him of what you have done, for he may perhaps ask Allah for your forgiveness. His purpose in that was simply a hope that it might be a way of escape for him.

So he went to him and said: Apostle of Allah! I have committed fornication, so inflict on me the punishment ordained by Allah. He (the Prophet) turned away from him, so he came back and said: Apostle of Allah! I have committed fornication, so inflict on me the punishment ordained by Allah. He (again) turned away from him, so he came back and said: Apostle of Allah! I have committed fornication, so inflict on me the punishment ordained by Allah.

When he uttered it four times, the Apostle of Allah (peace_be_upon_him) said: You have said it four times. With whom did you commit it?

He replied: With so and so. He asked: Did you lie down with her? He replied: Yes. He asked: Had your skin been in contact with hers? He replied. Yes. He asked: Did you have intercourse with her? He said: Yes. So he (the Prophet) gave orders that he should be stoned to death. He was then taken out to the Harrah, and while he was being stoned he felt the effect of the stones and could not bear it and fled. But Abdullah ibn Unays encountered him when those who had been stoning him could not catch up with him. He threw the bone of a camel's foreleg at him, which hit him and killed him. They then went to the Prophet (peace_be_upon_him) and reported it to him.

He said: Why did you not leave him alone. Perhaps he might have repented and been forgiven by Allah.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4406]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4406

Narrated Jabir ibn Abdullah:

Muhammad ibn Ishaq said: I mentioned the story of Ma'iz ibn Malik to Asim ibn Umar ibn Qatadah. He said to me: Hasan ibn Muhammad ibn Ali ibn AbuTalib said to me: Some men of the tribe of Aslam whom I do not blame and whom you like have transmitted to me the saying of the Apostle of Allah (peace_be_upon_him): Why did you not leave him alone?

He said: But I did not understand this tradition. So I went to Jabir ibn Abdullah and said (to him): Some men of the tribe of Aslam narrate that the Apostle of Allah (peace_be_upon_him) said when they mentioned to him the anxiety of Ma'iz when the stones hurt him: "Why did you not leave him alone?' But I do not know this tradition.

He said: My cousin, I know this tradition more than the people. I was one of those who had stoned the man. When we came out with him, stoned him and he felt the effect of the stones, he cried: O people! return me to the Apostle of Allah (peace_be_upon_him). My people killed me and deceived me; they told me that the Apostle of Allah (peace_be_upon_him) would not kill me. We did not keep away from him till we killed him. When we returned to the Apostle of Allah (peace_be_upon_him) we informed him of it.

He said: Why did you not leave him alone and bring him to me? and he said this so that the Apostle of Allah (peace_be_upon_him) might ascertain it from him. But he did not say this to abandon the prescribed punishment. He said: I then understood the intent of the tradition.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4407]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4407

Narrated Abdullah ibn Abbas:

Ma'iz ibn Malik came to the Prophet (peace_be_upon_him) and said that he had committed fornication and he (the Prophet) turned away from him. He repeated it many times, but he (the Prophet) turned away from him. He asked his people: Is he mad? They replied: There is no defect in him. He asked: Have you done it with her? He replied: Yes. so he ordered that he should be stoned to death. He was taken out and stoned to death, and he (the Prophet) did not pray over him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4412]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4412

Narrated Abdullah ibn Abbas:

Ma'iz ibn Malik came to the Prophet (peace_be_upon_him) and admitted fornication twice. But he drove him away. He then came and admitted fornication twice. But he drove him away. He then came and admitted fornication twice. He (the Prophet) said: You have testified to yourself four times. Take him away and stone him to death.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4413]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4413

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said to Ma'iz ibn Malik: Perhaps you kissed, or squeezed, or looked. He said: No. He then said: Did you have intercourse with her? He said: Yes. On the (reply) he (the Prophet) gave order that he should be stoned to death.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4414]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4414

Narrated AbuHurayrah:

A man of the tribe of Aslam came to the Prophet (peace_be_upon_him) and testified four times against himself that he had had illicit intercourse with a woman, while all the time the Prophet (peace_be_upon_him) was turning away from him.

Then when he confessed a fifth time, he turned round and asked: Did you have intercourse with her? He replied: Yes. He asked: Have you done it so that your sexual organ penetrated hers? He replied: Yes. He asked: Have you done it like a collyrium stick when enclosed in its case and a rope in a well? He replied: Yes. He asked: Do you know what fornication is? He replied: Yes. I have done with her unlawfully what a man may lawfully do with his wife.

He then asked: What do you want from what you have said? He said: I want you to purify me. So he gave orders regarding him and he was stoned to death. Then the Prophet (peace_be_upon_him) heard one of his companions saying to another: Look at this man whose fault was concealed by Allah but who would not leave the matter alone, so that he was stoned like a dog. He said nothing to them but walked on for a time till he came to the corpse of an ass with its legs in the air.

He asked: Where are so and so? They said: Here we are, Apostle of Allah (peace_be_upon_him)! He said: Go down and eat some of this ass's corpse. They replied: Apostle of Allah! Who can eat any of this? He said: The dishonour you have just shown to your brother is more serious than eating some of it. By Him in Whose hand my soul is, he is now among the rivers of Paradise and plunging into them.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4420]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4420

Narrated Buraydah ibn al-Hasib:

We, the Companions of the Apostle of Allah (peace_be_upon_him), used to talk mutually: Would that al-Ghamidiyyah and Ma'iz ibn Malik had withdrawn after their confession; or he said: Had they not withdrawn after their confession, he would not have pursued them (for punishment). He had them stoned after the fourth (confession).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4421]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4421

Narrated Al-Lajlaj al-Amiri:

I was working in the market. A woman passed carrying a child. The people rushed towards her, and I also rushed along with them.

I then went to the Prophet (peace_be_upon_him) while he was asking: Who is the father of this (child) who is with you? She remained silent.

A young man by her side said: I am his father, Apostle of Allah!

He then turned towards her and asked: Who is the father of this child with you?

The young man said: I am his father, Apostle of Allah! The Apostle of Allah (peace_be_upon_him) then looked at some of those who were around him and asked them about him. They said: We only know good (about him).

The Prophet (peace_be_upon_him) said to him: Are you married? He said: Yes. So he gave orders regarding him and he was stoned to death.

He (the narrator) said: We took him out, dug a pit for him and put him in it. We then threw stones at him until he died. A man then came asking about the man who was stoned.

We brought him to the Prophet (peace_be_upon_him) and said: This man has come asking about the wicked man.

The Apostle of Allah (peace_be_upon_him) said: He is more agreeable than the fragrance of musk in the eyes of Allah. The man was his father. We then helped him in washing, shrouding and burying him. (The narrator said:) I do not know whether he said or did not say "in praying over him." This is the tradition of Abdah, and it is more accurate.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4423]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4423

Narrated Sahl ibn Sa'd:

A man came to the Prophet (peace_be_upon_him) and confessed before him that he had committed fornication with a woman whom he named. The Apostle of Allah (peace_be_upon_him) sent for the woman and asked her about it. But she denied that she had committed fornication. So he inflicted the prescribed punishment of flogging on him, and let her go.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4424]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4424

Narrated Jabir ibn Abdullah:

A man committed fornication with a woman. So the Apostle of Allah (peace_be_upon_him) ordered regarding him and the prescribed punishment of flogging was inflicted on him. He was then informed that he was married. So he commanded regarding him and he was stoned to death.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4426]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4426

Narrated Imran ibn Husayn:

A woman belonging to the tribe of Juhaynah (according to the version of Aban) came to the Prophet (peace_be_upon_him) and said that she had committed fornication and that she was pregnant. The Apostle of Allah (peace_be_upon_him) called her guardian.

Then the Apostle of Allah (peace_be_upon_him) said to him: Be good to her, and when she bears a child, bring her (to me). When she gave birth to the child, he brought her (to him). The Prophet (peace_be_upon_him) gave orders regarding her, and her clothes were tied to her. He then commanded regarding her and she was stoned to death. He commanded the people (to pray) and they prayed over her.

Thereupon Umar said: Are you praying over her, Apostle of Allah, when she has committed fornication?

He said: By Him in Whose hand my soul is, she has repented to such an extent that if it were divided among the seventy people of Medina, it would have been enough for them all. And what do you find better than the fact that she gave her life.

Aban did not say in his version: Then her clothes were tied to her.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4429]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4429

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) had a woman stoned and a pit was dug up to her breasts.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4433]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4433

Narrated Al-Bara' ibn Azib:

The people passed by the Apostle of Allah (peace_be_upon_him) with a Jew who was blackened with charcoal and who was being flogged.

He called them and said: Is this the prescribed punishment for a fornicator?

They said: Yes. He then called on a learned man among them and asked him: I adjure you by Allah Who revealed the Torah to Moses, do you find this prescribed punishment for a fornicator in your divine Book?

He said: By Allah, no. If you had not adjured me about this, I should not have informed you. We find stoning to be prescribed punishment for a fornicator in our Divine Book. But it (fornication) became frequent in our people of rank; so when we seized a person of rank, we left him alone, and when we seized a weak person, we inflicted the prescribed punishment on him. So we said: Come, let us agree on something which may be enforced equally on people of higher and lower rank. So we agreed to blacken the face of a criminal with charcoal, and flog him, and we abandoned stoning.

The Apostle of Allah (peace_be_upon_him) then said: O Allah, I am the first to give life to Thy command which they have killed. So he commanded regarding him (the Jew) and he was stoned to death.

Allah Most High then sent down: "O Apostle, let not those who race one another into unbelief, make thee grieve..." up to "They say: If you are given this, take it, but if not, beware!...." up to "And if any do fail to judge by (the light of) what Allah hath revealed, they are (no better than) unbelievers," about Jews, up to "And if any do fail to judge by (the right of) what Allah hath revealed, they are no better than) wrong-doers" about Jews: and revealed the verses up to "And if any do fail to judge by (the light of) what Allah hath revealed, they are (no better than) those who rebel." About this he said: This whole verse was revealed about the infidels.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4434]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4434

Narrated Abdullah Ibn Umar:

A group of Jews came and invited the Apostle of Allah (peace_be_upon_him) to Quff. So he visited them in their school.

They said: AbulQasim, one of our men has committed fornication with a woman; so pronounce judgment upon them. They placed a cushion for the Apostle of Allah (peace_be_upon_him) who sat on it and said: Bring the Torah. It was then brought. He then withdrew the cushion from beneath him and placed the Torah on it saying: I believed in thee and in Him Who revealed thee.

He then said: Bring me one who is learned among you. Then a young man was brought. The transmitter then mentioned the rest of the tradition of stoning similar to the one transmitted by Malik from Nafi'(No. 4431).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4435]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4435

Narrated AbuHurayrah:

(This is Ma'mar's version which is more accurate.) A man and a woman of the Jews committed fornication.

Some of them said to the others: Let us go to this Prophet, for he has been sent with an easy law. If he gives a judgment lighter than stoning, we shall accept it, and argue about it with Allah, saying: It is a judgment of one of your prophets. So they came to the Prophet (peace_be_upon_him) who was sitting in the mosque among his companions.

They said: AbulQasim, what do you think about a man and a woman who committed fornication? He did not speak to them a word till he went to their school.

He stood at the gate and said: I adjure you by Allah Who revealed the Torah to Moses, what (punishment) do you find in the Torah for a person who commits fornication, if he is married?

They said: He shall be blackened with charcoal, taken round a donkey among the people, and flogged. A young man among them kept silent.

When the Prophet (peace_be_upon_him) emphatically adjured him, he said: By Allah, since you have adjured us (we inform you that) we find stoning in the Torah (is the punishment for fornication).

The Prophet (peace_be_upon_him) said: So when did you lessen the severity of Allah's command? He said:

A relative of one of our kings had committed fornication, but his stoning was suspended. Then a man of a family of common people committed fornication. He was to have been stoned, but his people intervened and said: Our man shall not be stoned until you bring your man and stone him. So they made a compromise on this punishment between them.

The Prophet (peace_be_upon_him) said: So I decide in accordance with what the Torah says. He then commanded regarding them and they were stoned to death.

Az-Zuhri said: We have been informed that this verse was revealed about them: "It was We Who revealed the Law (to Moses): therein was guidance and light. By its standard have been judged the Jews, by the Prophet who bowed (as in Islam) to Allah's will.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4441]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4441

Narrated Al-Bara' ibn Azib:

while I was wandering in search of my camels which had strayed, a caravan or some horsemen carrying a standard came forward. The bedouin began to go round me for my position with the Prophet (peace_be_upon_him). They came to a domed structure, took out a man from it, and struck his neck. I asked about him. They told me that he had married his father's wife.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4442]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4442

Narrated Al-Bara' ibn Azib:

I met my uncle who was carrying a standard. I asked him: Where are you going? He said: The Apostle of Allah (peace_be_upon_him) has sent me to a man who has married his father's wife. He has ordered me to cut off his head and take his property.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4443]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4443

Narrated An-Nu'man ibn Bashir:

Habib ibn Salim said: A man called AbdurRahman ibn Hunayn had intercourse with his wife's slave-girl. The matter was brought to an-Nu'man ibn Bashir who was the Governor of Kufah. He said: I shall decide between you in accordance with the decision of the Apostle of Allah (peace_be_upon_him). If she made her lawful for you, I shall flog you one hundred lashes. If she did not make her lawful for you, I shall stone you to death. So they found that she had made her lawful for him. He, therefore, flogged him one hundred lashes.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4444]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4444

Narrated An-Nu'man ibn Bashir:

The Prophet (peace_be_upon_him) said: about a man who had (unlawful) intercourse with his wife's slave girl: If she made her lawful for him, he will be flogged one hundred lashes; if she did not make her lawful for him, I shall stone him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4445]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4445

Narrated Salamah ibn al-Muhabbaq:

The Apostle of Allah (peace_be_upon_him) made a decision about a man who had intercourse with his wife's slave-girl as follows. If he forced her, she is free, and he shall give her mistress a slave-girl similar to her; if she asked him to have intercourse voluntarily, she will belong to him, and he shall give her mistress a slave-girl similar to her.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4446]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4446

Narrated Salamah ibn al-Muhabbaq:

A similar tradition (to the No. 4445) has also been transmitted by Salamah ibn al-Muhabbaq from the Prophet (peace_be_upon_him).

This version has: If she asked her to have intercourse with her voluntarily, then she and a similar slave-girl would be given to her mistress from his property.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4447]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4447

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If you find anyone doing as Lot's people did, kill the one who does it, and the one to whom it is done.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4448]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4448

Narrated Abdullah ibn Abbas:

If a man who is not married is seized committing sodomy, he will be stoned to death.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4449]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4449

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone has sexual intercourse with an animal, kill him and kill it along with him. I (Ikrimah) said: I asked him (Ibn Abbas): What offence can be attributed to the animal/ He replied: I think he (the Prophet) disapproved of its flesh being eaten when such a thing had been done to it.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4450]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4450

Narrated Abdullah ibn Abbas:

There is no prescribed punishment for one who has sexual intercourse with an animal.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4451]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4451

Narrated Sahl ibn Sa'd:

A man came to the Prophet (peace_be_upon_him) and made acknowledgment before him that he had committed fornication with a woman whom he named. The Apostle of Allah (peace_be_upon_him) sent someone to the woman and he asked her about it. She denied that she had committed fornication. So he gave him the prescribed punishment of Lashes and left her.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4452]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4452

Narrated Abdullah ibn Abbas:

A man of Bakr ibn Layth came to the Prophet (peace_be_upon_him) and made confession four times that he had committed fornication with a woman, so he had a hundred lashes administered to him. The man had not been married. He then asked him to produce proof against the woman, and she said: I swear by Allah, Apostle of Allah, that he has lied. Then he was given the punishment of eighty lashes of falsehood.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4457]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4457

Narrated Some Companions:

AbuUmamah ibn Sahl ibn Hunayf said that some companions of the Apostle of Allah (peace_be_upon_him) told that one of their men suffered so much from some illness that he pined away until he was skin and bone (i.e. only a skeleton). A slave-girl of someone visited him, and he was cheered by her and had unlawful intercourse with her. When his people came to visit the patient, he told them about it.

He said: Ask the Apostle of Allah (peace_be_upon_him) about the legal verdict for me, for I have had unlawful intercourse with a slave-girl who visited me.

So they mentioned it to the Apostle of Allah (peace_be_upon_him) saying: We have never seen anyone (so weak) from illness as he is. If we bring him to you, his bones will disintegrate. He is only skin and bone. So the Apostle of Allah (peace_be_upon_him) commanded them to take one hundred twigs and strike him once.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4458]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4458

Narrated Ali ibn AbuTalib:

A slave-girl belonging to the house of the Apostle of Allah (peace_be_upon_him) committed fornication. He (the Prophet) said: Rush up, Ali, and inflict the prescribed punishment on her. I then hurried up, and saw that blood was flowing from her, and did not stop. So I came to him and he said: Have you finished inflicting (punishment on her)? I said: I went to her while her blood was flowing. He said: Leave her alone till her bleeding stops; then inflict the prescribed punishment on her. And inflict the prescribed punishment on those whom your right hands possess (i.e. slaves).


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4459]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4459

Narrated Aisha, Ummul Mu'minin:

When my vindication came down, the Prophet (peace_be_upon_him) mounted the pulpit and mentioned that, and recited the Qur'an. Then when he came down from the pulpit he ordered regarding the two men and the woman, and they were given the prescribed punishment.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4460]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4460

Narrated Aisha, Ummul Mu'minin:

The tradition mentioned above (No. 4459) has also been transmitted by Muhammad ibn Ishaq through a different chain of narrators. But he did not mention Aisha.

This version has: He (the Prophet) commanded regarding the two men and the woman who spoke obscenity were Hassan ibn Thabit and Mistah ibn Uthathah. An-Nufayl said: It is said that the woman was Hammah daughter of Jahsh.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4461]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4461

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) did not prescribe any punishment for drinking wine. Ibn Abbas said: A man who had drunk wine and become intoxicated was found staggering on the road, so he was taken to the Prophet (peace_be_upon_him). When he was opposite al-Abbas's house, he escaped, and going in to al-Abbas, he grasped hold of him. When that was mentioned to the Prophet (peace_be_upon_him), he laughed and said: Did he do that? and he gave no command regarding him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4465]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4465

Narrated Ali ibn AbuTalib:

Hudayn ibn al-Mundhir ar-Ruqashi, who was AbuSasan, said: I was present with Uthman ibn Affan when al-Walid ibn Uqbah was brought to him. Humran and another man bore witness against him (for drinking wine). One of them testified that he had seen him drinking wine, and the other testified that he had seen him vomiting it.

Uthman said: He could not vomit it, unless he did not drink it. He said to Ali: Inflict the prescribed punishment on him. Ali said to al-Hasan: Inflict the prescribed punishment on him.

Al-Hasan said: He who has enjoyed its pleasure should also bear its burden. So Ali said to Abdullah ibn Ja'far: Inflict the prescribed punishment on him. He took a whip and struck him with it while Ali was counting.

When he reached (struck) forty (lashes), he said: It is sufficient. The Prophet (peace_be_upon_him) gave forty lashes. I think he also said: "And AbuBakr gave forty lashes, and Uthman eighty. This is all sunnah (standard practice). And this is dearer to me."


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4466]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4466

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) and AbuBakr gave forty lashes for drinking wine and Umar made it eighty. And all this is sunnah, the model and standard practice.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4467]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4467

Narrated Mu'awiyah ibn AbuSufyan:

The Prophet (peace_be_upon_him) said: If they (the people) drink wine, flog them, again if they drink it, flog them. Again if they drink it, kill them.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4469]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4469

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If he is intoxicated, flog him; again if he is intoxicated, flog him; again if he is intoxicated, flog him if he does it again a fourth time, kill him.

AbuDawud said: And there is a similar tradition of Umar ibn AbuSalamah, from his father, on the authority of AbuHurayrah, from the Prophet (peace_be_upon_him): If he drinks wine, flog him if he does it so again, a fourth time, kill him.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4470]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4470

Narrated Qabisah ibn Dhuwayb:

The Prophet (peace_be_upon_him) said: If anyone drinks wine, flog him; if he repeats it, flog him, and if he repeats it, flog him. If he does it again a third or a fourth time, kill him. A man who had drunk wine was brought (to him) and he gave him lashes. He was again brought to him, and he flogged him. He was again brought to him and he flogged him. He was again brought to him and he flogged him. The punishment of killing (for drinking) was repealed, and a concession was allowed.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4472]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4472

Narrated AbdurRahman ibn Azhar:

I can still picture myself looking at the Apostle of Allah (peace_be_upon_him) who was among the camps of the Companions seeking the camp of Khalid ibn al-Walid, when a man who had drunk wine was brought before him. He asked the people: Beat him. Some struck him with sandals, some with sticks and some with fresh branches of the palm-tree (mitakhah). Ibn Wahb said: This (mitakhah) means green palm fronds. Then the apostle of Allah (peace_be_upon_him) took some dust from the ground and threw it on his face.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4473]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4473

Narrated AbdurRahman ibn al-Azhar:

A man who had drunk wine was brought before the Prophet (peace_be_upon_him) when he was in Hunayn. He threw some dust on his face. He then ordered his Companions and they beat him with their sandals and whatever they had in their hands. He then said to them: Leave him, and they left him. The Apostle of Allah (peace_be_upon_him) then died, and AbuBakr gave forty lashes for drinking wine, and then Umar in the beginning of his Caliphate inflicted forty stripes and at the end of his Caliphate he inflicted eighty stripes. Uthman (after him) inflicted both punishments, eighty and forty stripes, and finally Mu'awiyah established eighty stripes.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4474]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4474

Narrated AbdurRahman ibn Azhar:

I saw the Apostle of Allah (peace_be_upon_him) on the morning of the conquest of Mecca when I was a young boy. He was walking among the people, seeking the camp of Khalid ibn al-Walid. A man who had drunk wine was brought (before him) and he ordered them (to beat him). So they beat him with what they had in their hands. Some struck him with whips, some with sticks and some with sandals. The Apostle of Allah (peace_be_upon_him) threw some dust on his face.

When a man who had drunk wine was brought before AbuBakr, he asked them (i.e. the people) about the number of beatings which they gave him. They numbered it forty. So AbuBakr gave him forty lashes.

When Umar came to power, Khalid ibn al-Walid wrote to him: The people have become addicted to drinking wine and they look down upon the prescribed punishment and its penalty.

He said: They are with you, ask them. The immigrants who embraced Islam in the beginning were with him. He asked them and they agreed on the fact that (a drunkard) should be given eighty lashes.

Ali said: When a man drinks wine, he tells lies. I, therefore, think that he should be prescribed punishment that is prescribed for telling lies..


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4475]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4475

Narrated Hakim ibn Hizam:

The Apostle of Allah (peace_be_upon_him) forbade to take retaliation in the mosque, to recite verses in it and to inflict the prescribed punishments in it.


Dawud :: Prescribed Punishments (Kitab Al-Hudud) :: [38.4478]

Prescribed Punishments (Kitab Al-Hudud)

Dawud :: Book 38 : Hadith 4478

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When one of you inflicts a beating, he should avoid striking the face.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4479]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4479

Narrated Abdullah Ibn Abbas:

Qurayzah and Nadir (were two Jewish tribes). An-Nadir were nobler than Qurayzah. When a man of Qurayzah killed a man of an-Nadir, he would be killed. But if a man of an-Nadir killed a man of Qurayzah, a hundred wasq of dates would be paid as blood-money. When Prophethood was bestowed upon the Prophet (peace_be_upon_him), a man of an-Nadir killed a man of Qurayzah.

They said: Give him to us, we shall kill him. They replied: We have the Prophet (peace_be_upon_him) between you and us. So they came to him.

Thereupon the following verse was revealed: "If thou judge, judge in equity between them." "In equity" means life for a life.

The following verse was then revealed: "Do they seek of a judgment of (the days) ignorance?"


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4480]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4480

Narrated AbuRimthah:

I went to the Prophet (peace_be_upon_him) with my father. The Apostle of Allah (peace_be_upon_him) then asked my father: Is this your son? He replied: Yes, by the Lord of the Ka'bah. He again said: Is it true? He said: I bear witness to it. The Apostle of Allah (peace_be_upon_him) then smiled for my resemblance with my father, and for the fact that my father took an oath upon me. He then said: He will not bring evil on you, nor will you bring evil on him. The Apostle of Allah (peace_be_upon_him) recited the verse: "No bearer of burdens can bear the burden of another."


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4481]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4481

Narrated AbuShurayh al-Khuza'i:

The Prophet (peace_be_upon_him) said: If a relative of anyone is killed, or if he suffers khabl, which means a wound, he may choose one of the three things: he may retaliate, or forgive, or receive compensation. But if he wishes a fourth (i.e. something more), hold his hands. After this whoever exceeds the limits shall be in grave penalty.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4482]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4482

Narrated Anas ibn Malik:

I never saw the Apostle of Allah (peace_be_upon_him) that some dispute which involved retaliation was brought to him but he commanded regarding it for remission.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4483]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4483

Narrated AbuHurayrah:

A man was killed in the lifetime of the Prophet (peace_be_upon_him). The matter was brought to the Prophet (peace_be_upon_him). He entrusted him to the legal guardian of the slain. The slayer said: Apostle of Allah, I swear by Allah, I did not intend to kill him. The Apostle of Allah (peace_be_upon_him) said to the legal guardian: Now if he is true and you kill him, you will enter Hell-fire. So he let him go. His hands were tied with a strap. He came out pulling his strap. Hence he was called Dhu an-Nis'ah (possessor of strap).


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4484]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4484

Narrated Wa'il ibn Hujr:

I was with the Prophet (peace_be_upon_him) when a man who was a murderer and had a strap round his neck was brought to him.

He then called the legal guardian of the victim and asked him: Do you forgive him?

He said: No. He asked: Will you accept the blood-money? He said: No. He asked: Will you kill him? He said: Yes. He said: Take him. When he turned his back, he said: Do you forgive him? He said: No. He said: Will you accept the blood-money? He said: No. He said: Will you kill him? He said: Yes. He said: Take him. After repeating all this a fourth time, he said: If you forgive him, he will bear the burden of his own sin and the sin of the victim. He then forgave him. He (the narrator) said: I saw him pulling the strap.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4487]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4487

Narrated Uthman ibn Affan:

AbuUmamah ibn Sahl said: We were with Uthman when he was besieged in the house. There was an entrance to the house. He who entered it heard the speech of those who were in the Bilat. Uthman then entered it. He came out to us, looking pale.

He said: They are threatening to kill me now. We said: Allah will be sufficient for you against them, Commander of the Faithful! He asked: Why kill me? I heard the Apostle of Allah (peace_be_upon_him) say: It is not lawful to kill a man who is a Muslim except for one of the three reasons: Kufr (disbelief) after accepting Islam, fornication after marriage, or wrongfully killing someone, for which he may be killed.

I swear by Allah, I have not committed fornication before or after the coming of Islam, nor did I ever want another religion for me instead of my religion since Allah gave guidance to me, nor have I killed anyone. So for what reason do you want to kill me?


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4488]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4488

Narrated Sa'd ibn Dumayrah al-Aslami ; Dumayrah al-Aslami:

Ziyad ibn Sa'd ibn Dumayrah as-Sulami said on the authority of his father (Sa'd) and his grandfather (Dumayrah) (according to Musa's version) who were present in the battle of Hunayn with the Apostle of Allah (peace_be_upon_him): After the advent of Islam, Muhallam ibn Jaththamah al-Laythi killed a man of Ashja'.

That was the first blood-money decided by the Apostle of Allah (peace_be_upon_him) (for payment). Uyaynah spoke about the killing of al-Ashja'i, for he belonged to Ghatafan, and al-Aqra' ibn Habis spoke on behalf of Muhallam, for he belonged to Khunduf. The voices rose high, and the dispute and noise grew.

So the Apostle of Allah (peace_be_upon_him) said: Do you not accept blood-money, Uyaynah?

Uyaynah then said: No, I swear by Allah, until I cause his women to suffer the same fighting and grief as he caused my women to suffer. Again the voices rose high, and the dispute and noise grew.

The Apostle of Allah (peace_be_upon_him) said: Do you not accept the blood-money Uyaynah? Uyaynah gave the same reply as before, and a man of Banu Layth called Mukaytil stood up. He had a weapon and a skin shield in his hand.

He said: I do not find in the beginning of Islam any illustration for what he has done except the one that "some sheep came on, and those in the front were shot; hence those in the rear ran away". (The other example is that) "make a law today and change it."

The Apostle of Allah (peace_be_upon_him) said: Fifty (camels) here immediately and fifty when we return to Medina. This happened during some of his journeys. Muhallam was a tall man of dark complexion. He was with the people. They continued (to make effort for him) until he was released. He sat before the Apostle of Allah (peace_be_upon_him), with his eyes flowing.

He said: Apostle of Allah! I have done (the act) of which you have been informed. I repent to Allah, the Exalted, so ask Allah's forgiveness for me. Apostle of Allah!

The Apostle of Allah (peace_be_upon_him) then said: Did you kill him with your weapon at the beginning of Islam. O Allah! do not forgive Muhallam. He said these words loudly.

AbuSalamah added: He (Muhallam) then got up while he was wiping his tears with the end of his garment.

Ibn Ishaq said: His people alleged that the Apostle of Allah (peace_be_upon_him) asked forgiveness for him after that.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4489]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4489

Narrated AbuShurayb al-Ka'bi:

The Prophet (peace_be_upon_him) said: Then you, Khuza'ah, have killed this man of Hudhayl, but I will pay his blood-wit. After these words of mine if a man of anyone is killed, his people will have a choice to accept blood-wit or to kill him.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4491]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4491

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: A believer will not be killed for an infidel. If anyone kills a man deliberately, he is to be handed over to the relatives of the one who has been killed. If they wish, they may kill, but if they wish, they may accept blood-wit


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4492]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4492

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: I will not forgive anyone who kills after accepting blood-wit


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4495]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4495

Narrated Jabir ibn Abdullah:

Ibn Shihab said: Jabir ibn Abdullah used to say that a Jewess from the inhabitants of Khaybar poisoned a roasted sheep and presented it to the Apostle of Allah (peace_be_upon_him) who took its foreleg and ate from it. A group of his companions also ate with him.

The Apostle of Allah (peace_be_upon_him) then said: Take your hands away (from the food). The Apostle of Allah (peace_be_upon_him) then sent someone to the Jewess and he called her.

He said to her: Have you poisoned this sheep? The Jewess replied: Who has informed you? He said: This foreleg which I have in my hand has informed me. She said: Yes. He said: What did you intend by it? She said: I thought if you were a prophet, it would not harm you; if you were not a prophet, we should rid ourselves of him (i.e. the Prophet). The Apostle of Allah (peace_be_upon_him) then forgave her, and did not punish her. But some of his companions who ate it, died. The Apostle of Allah (peace_be_upon_him) had himself cupped on his shoulder on account of that which he had eaten from the sheep. AbuHind cupped him with the horn and knife. He was a client of Banu Bayadah from the Ansar.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4496]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4496

Narrated AbuSalamah:

A Jewess presented a roasted sheep to the Apostle of Allah (peace_be_upon_him) at Khaybar.

He then mentioned the rest of the tradition like that of Jabir (No. 4495). He said: Then Bashir ibn al-Bara' ibn Ma'rur al-Ansari died. He sent someone to call on the Jewess, and said to her (when she came): What motivated you to do the work you have done? He then mentioned the rest of the tradition similar to the one mentioned by Jabir (No. 4495).

The Apostle of Allah (peace_be_upon_him) then ordered regarding her and she was killed. But he (AbuSalamah) did not mention the matter of cupping.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4498]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4498

Narrated AbuSalamah:

Muhammad ibn Amr said on the authority of AbuSalamah, and he did not mention the name of AbuHurayrah: The Apostle of Allah (peace_be_upon_him) used to accept presents but not alms (sadaqah).

This version adds: So a Jewess presented him at Khaybar with a roasted sheep which she had poisoned. The Apostle of Allah (peace_be_upon_him) ate of it and the people also ate.

He then said: Take away your hands (from the food), for it has informed me that it is poisoned. Bishr ibn al-Bara' ibn Ma'rur al-Ansari died.

So he (the Prophet) sent for the Jewess (and said to her): What motivated you to do the work you have done?

She said: If you were a prophet, it would not harm you; but if you were a king, I should rid the people of you. The Apostle of Allah (peace_be_upon_him) then ordered regarding her and she was killed. He then said about the pain of which he died: I continued to feel pain from the morsel which I had eaten at Khaybar. This is the time when it has cut off my aorta.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4499]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4499

Narrated Umm Mubashshir:

Umm Mubashshir said to the Prophet (peace_be_upon_him) during the sickness of which he died: What do you think about your illness, Apostle of Allah (peace_be_upon_him)? I do not think about the illness of my son except the poisoned sheep of which he had eaten with you at Khaybar. The Prophet (peace_be_upon_him) said: And I do not think about my illness except that. This is the time when it cut off my aorta.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4501]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4501

Narrated Samurah:

The Prophet (peace_be_upon_him) Said: If anyone kills his slave, we shall kill him, and if anyone cuts off the nose of his slave, we shall cut off his nose.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4504]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4504

Narrated Abdullah ibn Amr ibn al-'As:

A man came to the Prophet (peace_be_upon_him) crying for help. He said: His slave-girl, Apostle of Allah! He said: Woe to you, what happened with you ? He said that it was an evil one. He saw the slave-girl of his master; he became jealous of him, and cut off his penis. The Apostle of Allah (peace_be_upon_him) said: Bring the man to me. The man was called, but people could not get control over him. The Apostle of Allah (peace_be_upon_him) then said: Go away, you are free. He asked: Apostle of Allah! upon whom does my help lie? He replied: On every believer, or he said: On every Muslim.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4507]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4507

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) killed a man of Banu Nadr ibn Malik at Harrah ar-Righa' at the bank of Layyat al-Bahrah. The transmitter Mahmud (ibn Khalid) also mentioned the words along with the words "at Bahrah" "the slayer and the slain were from among them". Mahmud alone transmitted in this tradition the words "at the bank of Layyah".


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4509]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4509

Narrated Rafi' ibn Khadij:

A man of the Ansar was killed at Khaybar and his relatives went to the Prophet (peace_be_upon_him) and mentioned that to him. He asked: Have you two witnesses who can testify to the murderer of your friend? They replied: Apostle of Allah! there was not a single Muslim present, but only Jews who sometimes have the audacity to do even greater crimes than this. He said: Then choose fifty of them and demand that they take an oath; but they refused and the Prophet (peace_be_upon_him) paid the blood-wit himself.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4511]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4511

Narrated Some men:

The Prophet (peace_be_upon_him) said to the Jews and started with them: Fifty of you should take the oaths. But they refused (to take the oaths). He then said to the Ansar: Prove your claim. They said: Do we take the oaths without seeing, Apostle of Allah? The Apostle of Allah (peace_be_upon_him) then imposed the blood-wit on the Jews because he (the slain) was found among them.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4515]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4515

Narrated Ali ibn AbuTalib:

Qays ibn Abbad and Ashtar went to Ali and said to him: Did the Apostle of Allah (peace_be_upon_him) give you any instruction about anything for which he did not give any instruction to the people in general?

He said: No, except what is contained in this document of mine. Musaddad said: He then took out a document. Ahmad said: A document from the sheath of his sword.

It contained: The lives of all Muslims are equal; they are one hand against others; the lowliest of them can guarantee their protection. Beware, a Muslim must not be killed for an infidel, nor must one who has been given a covenant be killed while his covenant holds. If anyone introduces an innovation, he will be responsible for it. If anyone introduces an innovation or gives shelter to a man who introduces an innovation (in religion), he is cursed by Allah, by His angels, and by all the people.

Musaddad said: Ibn AbuUrubah's version has: He took out a document.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4516]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4516

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said, mentioning the tradition similar to the one transmitted by Ali. This version adds: The most distant of them gives protection as from all, those who are strong among them send back (spoil) to those who are weak among them, and their expeditions sending it back to those who are at home.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4519]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4519

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) sent AbuJahm ibn Hudhayfah as a collector of zakat. A man quarrelled with him about his sadaqah (i.e. zakat), and AbuJahm struck him and wounded his head. His people came to the Prophet (peace_be_upon_him) and said: Revenge, Apostle of Allah!

The Prophet (peace_be_upon_him) said: You may have so much and so much. But they did not agree. He again said: You may have so much and so much. But they did not agree. He again said: You may have so much and so much. So they agreed.

The Prophet (peace_be_upon_him) said: I am going to address the people in the afternoon and tell them about your consent.

They said: Yes. Addressing (the people), the Apostle of Allah (peace_be_upon_him) said: These people of faith came to me asking for revenge. I presented them with so much and so much and they agreed. Do you agree?

They said: No. The immigrants (muhajirun) intended (to take revenge) on them. But the Apostle of Allah (peace_be_upon_him) commanded them to refrain and they refrained.

He then called them and increased (the amount), and asked: Do you agree? They replied: Yes. He said: I am going to address the people and tell them about your consent. They said: Yes. The Prophet (peace_be_upon_him) addressed and said: Do you agree? They said: Yes.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4521]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4521

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) was distributing something, a man came towards him and bent down on him. The Apostle of Allah (peace_be_upon_him) struck him with a bough and his face was wounded. The Apostle of Allah (peace_be_upon_him) said to him: Come and take retaliation. He said: no, I have forgiven, Apostle of Allah!.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4522]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4522

Narrated Umar ibn al-Khattab:

I did not send my collectors (of zakat) so that they strike your bodies and that they take your property. If that is done with someone and he appeals to me, I shall take retaliation on him. Amr ibn al-'As said: If any man (i.e. governor) inflicts disciplinary punishment on his subjects, would you take retaliation on him too? He said: Yes, by Him in Whose hand my soul is, I shall take retaliation on him. I saw that the Apostle of Allah (peace_be_upon_him) has given retaliation on himself.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4523]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4523

Narrated Aisha, Ummul Mu'minin:

The Prophet (peace_be_upon_him) Said: The disputants should refrain from taking retaliation. The one who is nearer should forgive first and then the one who is next to him, even if (the one who forgives) were a woman.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4526]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4526

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) gave judgment that if anyone is killed accidentally, his blood-wit should be one hundred camels: thirty she-camels which had entered their second year, thirty she-camels which had entered their third year, thirty she-camels which had entered their fourth year, and ten male camels which had entered their third year.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4527]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4527

Narrated Abdullah ibn Amr ibn al-'As:

The value of the blood-money at the time of the Apostle of Allah (peace_be_upon_him) was eight hundred dinars or eight thousand dirhams, and the blood-money for the people of the Book was half of that for Muslims.

He said: This applied till Umar (Allah be pleased with him) became caliph and he made a speech in which he said: Take note! Camels have become dear. So Umar fixed the value for those who possessed gold at one thousand dinars, for those who possessed silver at twelve thousand (dirhams), for those who possessed cattle at two hundred cows, for those who possessed sheep at two thousand sheep, and for those who possessed suits of clothing at two hundred suits. He left the blood-money for dhimmis (protected people) as it was, not raising it in proportion to the increase he made in the blood-wit.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4528]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4528

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) fixed; and he mentioned the tradition like that of Musa; he said: And those who possess corn food should pay something which I do not remember.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4529]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4529

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: The blood-wit for accidental killing should be twenty she-camels which had entered their fourth year, twenty she-camels which had entered their fifth year, twenty she-camels which had entered their second year, twenty she-camels which had entered their third year, and twenty male camels which had entered their second year. It does not beyond Ibn Mas'ud.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4530]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4530

Narrated Abdullah ibn Abbas:

A man of Banu Adi was killed. The Prophet (peace_be_upon_him) fixed his blood-wit at the rate of twelve thousand (dirhams).


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4531]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4531

Narrated Abdullah ibn Amr:

(Musaddad's version has): The Apostle of Allah (peace_be_upon_him) made a speech on the day of the conquest of Mecca, and said: Allah is Most Great, three times. He then said: There is no god but Allah alone: He fulfilled His promise, helped His servant, and alone defeated the companies.

(The narrator said:) I have remembered from Musaddad up to this.

Then the agreed version has: Take note! All the merits mentioned in pre-Islamic times, and the claim made for blood or property are under my feet, except the supply of water to the pilgrims and the custody of the Ka'bah. He then said: The blood-money for unintentional murder which appears intentional, such as is done with a whip and a stick, is one hundred camels, forty of which are pregnant. Musaddad's version is more accurate.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4540]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4540

Narrated AbuMusa:

The Prophet (peace_be_upon_him) said: The fingers are equal: ten camels for each finger.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4541]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4541

Narrated AbuMusa al-Ash'ari:

The Prophet (peace_be_upon_him) said: The fingers are equal. I asked: Ten camels for each? He replied: Yes.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4543]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4543

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The fingers are equal and the teeth are equal. The front tooth and the molar tooth are equal, this and that are equal.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4544]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4544

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: The teeth are equal, and the fingers are equal.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4545]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4545

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) treated the fingers and toes as equal.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4546]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4546

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said in his address while he was leaning against the Ka'bah: (The blood-wit) for each finger is ten camels.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4547]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4547

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) would fix the blood-money for accidental killing at the rate of four hundred dinars or their equivalent in silver for townsmen, and he would fix it according to the price of camels. So when they were dear, he increased the amount to be paid, and when cheap prices prevailed he reduced the amount to be paid. In the time of the Apostle of Allah (peace_be_upon_him) they reached between four hundred and eight hundred dinars, their equivalent in silver being eight thousand dirhams.

He said: The Apostle of Allah (peace_be_upon_him) gave judgment that those who possessed cattle should pay two hundred cows, and those who possessed sheep two thousand sheep.

He said: The Apostle of Allah (peace_be_upon_him) said: The blood-money is to be treated as something to be inherited by the heirs of the one who has been killed, and the remainder should be divided among the agnates.

He said: The Apostle of Allah (peace_be_upon_him) gave judgment that for cutting off a nose completely there was full blood-money, one hundred (camels) were to be paid. If the tip of the nose was cut off, half of the blood-money,i.e. fifty camels were to be paid, or their equivalent in gold or in silver, or a hundred cows, or one thousand sheep. For the hand, when it was cut of,f half of the blood-money was to be paid; for one foot of half, the blood-money was to be paid. For a wound in the head, a third of the blood-money was due, i.e. thirty-three camels and a third of the blood-money, or their equivalent in gold, silver, cows or sheep. For a head thrust which reaches the body, the same blood-money was to be paid. Ten camels were to be paid for every finger, and five camels for every tooth.

The Apostle of Allah (peace_be_upon_him) gave judgment that the blood-money for a woman should be divided among her relatives on her father's side, who did not inherit anything from her except the residence of her heirs. If she was killed, her blood-money should be distributed among her heirs, and they would have the right of taking revenge on the murderer.

The Apostle of Allah (peace_be_upon_him) said: There is nothing for the murderer; and if he (the victim) has no heir, his heir will be the one who is nearest to him among the people, but the murderer should not inherit anything.

Muhammad said: All this has been transmitted to me by Sulayman ibn Musa on the authority of Amr ibn Shu'ayb who, on his father's authority, said that his grandfather heard it from the Prophet (peace_be_upon_him).


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4548]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4548

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Blood-wit for what resembles intentional murder is to be made as severe as that for intentional murder, but the culprit is not to be killed. Khalid gave us some additional information on the authority of Ibn Rashid: That (unintentional murder which resembles intentional murder) means that Satan jumps among the people and then the blood is shed blindly without any malice and weapon.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4549]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4549

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Blood-wit for every wound which lays bare a bone is five camels.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4550]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4550

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) gave judgment that a third of the blood-wit should be paid for an eye fixed in its place.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4555]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4555

Narrated Umar ibn al-Khattab:

Ibn Abbas said: Umar asked about the decision of the Prophet (peace_be_upon_him) about that (i.e. abortion) Haml ibn Malik ibn an-Nabighah got up and said: I was between two women. One of them struck another with a rolling-pin killing both her and what was in her womb. So the Apostle of Allah (peace_be_upon_him) gave judgment that the blood-wit for the unborn child should be a male or a female slave of the best quality and that she should be killed.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4556]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4556

Narrated Umar ibn al-Khattab:

Tawus said: Umar stood on the pulpit. He then mentioned the rest of the tradition to the same effect as mentioned before. He did not mention "that she should be killed". This version adds: "a male or a female slave". Umar then said: Allah is Most Great. Had I not heard it, we would have decided about it something else.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4557]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4557

Narrated Abdullah ibn Abbas:

About the story of Haml ibn Malik, Ibn Abbas said: She aborted a child who had grown hair and was dead, and the woman also died. He (the Prophet) gave judgment that the blood-wit was to be paid by the woman's relatives on the father's side. Her uncle said: Apostle of Allah! She has aborted a child who had grown hair. The father of the woman who had slain said: He is a liar: I swear by Allah, he did not raise his voice, or drink or eat. No compensation is to be paid for an offence like this. The Prophet (peace_be_upon_him) said: is it a rhymed prose of pre-Islamic Arabia and its soothsaying? Pay a male or female slave of the best quality in compensation for the child.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4558]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4558

Narrated Jabir ibn Abdullah:

One of the two women of Hudhayl killed the other, Each of them had husband and sons. The Apostle of Allah (peace_be_upon_him) fixed the blood-wit for the slain woman to be paid by the woman's relatives on the father's side. He declared her husband and the child innocent. The relatives of the woman who killed said: We shall inherit from her. The Apostle of Allah (peace_be_upon_him) said: No, her sons and her husband should inherit from her.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4561]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4561

Narrated Buraydah ibn al-Hasib:

A woman threw a stone at another woman and she aborted. The dispute was brought to the Apostle of Allah (peace_be_upon_him). He gave judgment that five hundred sheep should be paid for her (unborn) child, and forbade throwing stones.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4562]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4562

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) gave judgment that a male or a female slave, or a horse or a mule should be paid for a miscarriage.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4564]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4564

Narrated Abdullah ibn Abbas:

The Apostle of Allah (peace_be_upon_him) gave judgment about the slave who had made an agreement to purchase his freedom (mukatab) and he had been killed that blood-wit is paid for him at the rate paid for a free man so far as he has paid the purchase money, and at the rate paid for a slave as the remainder is concerned.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4565]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4565

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: When a mukatab (a slave who has made an agreement to purchase his freedom) gifts blood-money or an inheritance, he can inherit in accordance with the extent to which he has been emancipated.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4566]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4566

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: The blood-wit for a man who makes a covenant is half of the blood-wit for a free man.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4569]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4569

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: Anyone who practises medicine when he is not known as a practitioner will be held responsible.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4570]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4570

Narrated Some people:

AbdulAziz ibn Umar ibn AbdulAziz said: Some people of the deputation which came to my father reported the Apostle of Allah (peace_be_upon_him) as saying: Any physician who practises medicine when he was not known as a practitioner before that and he harms (the patients) he will be held responsible. AbdulAziz said: Here physician does not refer to a man by qualification. it means opening a vein, incision and cauterisation.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4571]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4571

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Musaddad's version has: He addressed on the day of Conquest. The agreed version then goes: Beware! Every object of pride of pre-Islamic times, whether it is blood-vengeance or property, mentioned or claimed, has been put under my feet except supply of water to the pilgrims and custody of the House (the Ka'bah). He then said: Beware! The blood-wit for unintentional murder, such as is done with a whip and stick, is one hundred camels, forty of which are pregnant.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4573]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4573

Narrated Imran ibn Husayn:

A servant of some poor people cut off the ear of the servant of some rich people. His people came to the Prophet (peace_be_upon_him) and said: Apostle of Allah! we are poor people. So he imposed no compensation on them.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4574]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4574

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone is killed blindly or, when people are throwing stones, by a stone or a whip, his blood-wit is the blood-wit for an accidental murder. But if anyone is killed intentionally, retaliation is due. If anyone tries to prevent it, the curse of Allah, of angels, and of all the people will rest on him.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4575]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4575

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: No recompense is to be demanded if one is kicked by an animal.


Dawud :: Types of Blood-Wit (Kitab Al-Diyat) :: [39.4577]

Types of Blood-Wit (Kitab Al-Diyat)

Dawud :: Book 39 : Hadith 4577

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: No recompense may be demanded if the fire spreads.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4579]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4579

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The Jews were split up into seventy-one or seventy-two sects; and the Christians were split up into seventy one or seventy-two sects; and my community will be split up into seventy-three sects.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4582]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4582

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: The best of the actions is to love for the sake of Allah and to hate for the sake of Allah.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4586]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4586

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Controverting about the Qur'an is disbelief.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4587]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4587

Narrated Al-Miqdam ibn Ma'dikarib:

The Prophet (peace_be_upon_him) said: Beware! I have been given the Qur'an and something like it, yet the time is coming when a man replete on his couch will say: Keep to the Qur'an; what you find in it to be permissible treat as permissible, and what you find in it to be prohibited treat as prohibited. Beware! The domestic ass, beasts of prey with fangs, a find belonging to confederate, unless its owner does not want it, are not permissible to you If anyone comes to some people, they must entertain him, but if they do not, he has a right to mulct them to an amount equivalent to his entertainment.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4588]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4588

Narrated AbuRafi':

The Prophet (peace_be_upon_him) said: Let me not find one of you reclining on his couch when he hears something regarding me which I have commanded or forbidden and saying: We do not know. What we found in Allah's Book we have followed.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4590]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4590

Narrated Irbad ibn Sariyah:

AbdurRahman ibn Amr as-Sulami and Hujr ibn Hujr said: We came to Irbad ibn Sariyah who was among those about whom the following verse was revealed: "Nor (is there blame) on those who come to thee to be provided with mounts, and when thou saidst: "I can find no mounts for you."

We greeted him and said: We have come to see you to give healing and obtain benefit from you.

Al-Irbad said: One day the Apostle of Allah (peace_be_upon_him) led us in prayer, then faced us and gave us a lengthy exhortation at which the eyes shed tears and the hearts were afraid.

A man said: Apostle of Allah! It seems as if it were a farewell exhortation, so what injunction do you give us?

He then said: I enjoin you to fear Allah, and to hear and obey even if it be an Abyssinian slave, for those of you who live after me will see great disagreement. You must then follow my sunnah and that of the rightly-guided caliphs. Hold to it and stick fast to it. Avoid novelties, for every novelty is an innovation, and every innovation is an error.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4615]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4615

Narrated AbuHurayrah:

A man came to the Apostle of Allah (peace_be_upon_him) and said: I saw (in my dream) a piece of cloud from which ghee and honey were dropping. I saw the people spreading their hands. Some of them took much and some a little. I also saw a rope hanging from Heaven to Earth. I saw, Apostle of Allah, that you caught hold of it and ascended by it. Then another man caught hold of it and ascended it. Then another man caught hold of it and ascended it. Then another man caught hold of it, but it broke, and then it was joined and he ascended it.

AbuBakr said: May my parents be sacrificed for you, if you allow, I shall interpret it.

He said: Interpret it. He said: The piece of cloud is the cloud of Islam; the ghee and honey that were dropping from it are the Qur'an, which contains softness and sweetness. Those who received much or little of it are those who learn much or little of the Qur'an. The rope hanging from Heaven to Earth is the truth which you are following. You catch hold of it and then Allah will raise you to Him. Then another man will catch hold of it and ascend it, Then another man will catch hold of it and it will break. But it will be joined and he will ascend it. Tell me. Apostle of Allah, whether I am right or wrong.

He said: You are partly right and partly wrong. He said: I adjure you by Allah, you should tell me where I am wrong.

The Prophet (peace_be_upon_him) said: Do not take an oath.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4617]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4617

Narrated AbuBakrah:

One day the Prophet (peace_be_upon_him) said: Which of you had dream? A man said: It is I. I saw as though a scale descended from the sky. You and AbuBakr were weighed and you were heavier; AbuBakr and Umar were weighed and AbuBakr was heavier: Umar and Uthman were weighed and Umar was heavier; than the scale was taken up. we saw signs of dislike on the face of the Apostle of Allah (peace_be_upon_him).


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4629]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4629

Narrated Safinah:

The Prophet (peace_be_upon_him) said: The Caliphate of Prophecy will last thirty years; then Allah will give the Kingdom of His Kingdom to anyone He wills.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4631]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4631

Narrated Sa'id ibn Zayd ibn Amr ibn Nufayl:

Abdullah ibn Zalim al-Mazini said: I heard Sa'id ibn Zayd ibn Amr ibn Nufayl say: When so and so came to Kufah, and made so and so stand to address the people, Sa'id ibn Zayd caught hold of my hand and said: Are you seeing this tyrant? I bear witness to the nine people that they will go to Paradise. If I testify to the tenth too, I shall not be sinful.

I asked: Who are the nine? He said: The Apostle of Allah (peace_be_upon_him) said when he was on Hira': Be still, Hira', for only a Prophet, or an ever-truthful, or a martyr is on you. I asked: Who are those nine? He said: The Apostle of Allah, AbuBakr, Umar, Uthman, Ali, Talhah, az-Zubayr, Sa'd ibn AbuWaqqas and AbdurRahman ibn Awf. I asked: Who is the tenth? He paused a moment and said: it is I.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4632]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4632

Narrated Sa'id ibn Zayd:

AbdurRahman ibn al-Akhnas said that when he was in the mosque, a man mentioned Ali (may Allah be pleased with him). So Sa'id ibn Zayd got up and said: I bear witness to the Apostle of Allah (peace_be_upon_him) that I heard him say: Ten persons will go to Paradise: The Prophet (peace_be_upon_him) will go to Paradise, AbuBakr will go to Paradise, Umar will go to Paradise, Uthman will go to Paradise, Ali will go to Paradise, Talhah will go to Paradise: az-Zubayr ibn al-Awwam will go to paradise, Sa'd ibn Malik will go to Paradise, and AbdurRahman ibn Awf will go to Paradise. If I wish, I can mention the tenth. The People asked: Who is he: So he kept silence. The again asked: Who is he: He replied: He is Sa'id ibn Zayd.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4633]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4633

Narrated Sa'id ibn Zayd ibn Amr ibn Nufayl:

Rabah ibn al-Harith said: I was sitting with someone in the mosque of Kufah while the people of Kufah were with him. Then Sa'id ibn Zayd ibn Amr ibn Nufayl came and he welcomed him, greeted him, and seated him near his foot on the throne. Then a man of the inhabitants of Kufah, called Qays ibn Alqamah, came. He received him and began to abuse him.

Sa'id asked: Whom is this man abusing? He replied: He is abusing Ali. He said: Don't I see that the companions of the Apostle of Allah (peace_be_upon_him) are being abused, but you neither stop it nor do anything about it? I heard the Apostle of Allah (peace_be_upon_him) say--and I need not say for him anything which he did not say, and then he would ask me tomorrow when I see him --AbuBakr will go to Paradise and Umar will go to Paradise. He then mentioned the rest of the tradition to the same effect (as in No. 4632).

He then said: The company of one of their man whose face has been covered with dust by the Apostle of Allah (peace_be_upon_him) is better than the actions of one of you for a whole life time even if he is granted the life-span of Noah.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4635]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4635

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Gabriel came and taking me by the hand showed the gate of Paradise by which my people will enter. AbuBakr then said: Apostle of Allah! I wish I had been with you so that I might have looked at it. The Apostle of Allah (peace_be_upon_him) then said: You, AbuBakr, will be the first of my people to enter Paradise.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4639]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4639

Narrated Umar ibn al-Khattab:

Al-Aqra', the mu'adhdhin (announcer) of Umar ibn al-Khattab said: Umar sent me to a bishop and I called him.

Umar said to him: Do you find me in the Book? He said: Yes. He asked: How do you find me? He said: I find you (like a) castle. Then he raised a whip to him, saying: What do you mean by castle? He replied: An iron castle and severely trustworthy. He asked: How do you find the one who will come after me? He said: I find him a pious caliph, except that he will prefer his relatives. Umar said: May Allah have mercy on Uthman: He said it three times. He then asked: How do you find the one who will come after him?

He replied: I find him like rusty iron. Umar then put his hand on his head, and said: O filthy! O filthy! He said: Commander of the Faithful! He is a pious caliph, but when he is made caliph, the sword will be unsheathed and blood will be shed.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4643]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4643

Narrated Abdullah ibn Zam'ah:

When the illness of the Apostle of Allah (peace_be_upon_him) became serious while I was with him among a group of people, Bilal called him for prayer. He said: Ask someone to lead the people in prayer. So Abdullah ibn Zam'ah went out and found that Umar was present among the people and AbuBakr was not there. I said: Umar, get up and lead the people in prayer. So he came forward and uttered "Allah is Most Great". When the Apostle of Allah (peace_be_upon_him) heard his voice, as Umar had a loud voice, he said: Where is AbuBakr? Allah does not allow that, and the Muslims too; Allah does not allow that, and the Muslims too. So he sent for AbuBakr. He came after Umar had led the people in that prayer. He then led the people in prayer.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4645]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4645

Narrated AbuBakrah:

The Apostle of Allah (peace_be_upon_him) said to al-Hasan ibn Ali. This son of mine is a Sayyid (chief), and I hope Allah may reconcile two parties of my community by means of him. Hammad's version has: And perhaps Allah may reconcile two large parties of Muslims by means of him.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4646]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4646

Narrated Hudhayfah:

There is no one who will be overtaken by trial regarding whom I do not fear except Muhammad ibn Maslamah, for I heard the Apostle of Allah (peace_be_upon_him) say: Trial will not harm you.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4664]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4664

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: If anyone loves for Allah's sake, hates for Allah's sake, gives for Allah's sake and withholds for Allah's sake, he will have perfect faith.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4665]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4665

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The most perfect believer in respect of faith is he who is best of them in manners.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4673]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4673

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When a man commits fornication, faith departs from him and there is something like a canvas roof over his head; and when he quits that action, faith returns to him.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4674]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4674

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: The Qadariyyah are the Magians of this community. If they are ill, do not pay a sick visit to them, and if they die, do not attend their funerals.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4681]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4681

Narrated AbuDharr ; AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to sit among his Companions. A stranger would come, but did recognise him (the Prophet) until he asked (about him). So we asked the Apostle of Allah (peace_be_upon_him) to make a place where he might take his seat so that when a stranger came, he might recognise him. So we built a terrace of soil on which he would take his seat, and we would sit beside him. He then mentioned something similar to this Hadith saying: A man came, and he described his appearance. He saluted from the side of the assembly, saying: Peace be upon you, Muhammad. The Prophet (peace_be_upon_him) then responded to him.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4686]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4686

Narrated Umar ibn al-Khattab:

Muslim ibn Yasar al-Juhani said: When Umar ibn al-Khattab was asked about the verse "When your Lord took their offspring from the backs of the children of Adam" - al-Qa'nabi recited the verse--he said: I heard the Apostle of Allah (peace_be_upon_him) say when he was questioned about it: Allah created Adam, then passed His right hand over his back, and brought forth from it his offspring, saying: I have these for Paradise and these will do the deeds of those who go to Paradise. He then passed His hand over his back and brought forth from it his offspring, saying: I have created these for Hell, and they will do the deeds of those who go to Hell.

A man asked: What is the good of doing anything, Apostle of Allah? The Apostle of Allah (peace_be_upon_him) said: When Allah creates a servant for Paradise, He employs him in doing the deeds of those who will go to Paradise, so that his final action before death is one of the deeds of those who go to Paradise, for which He will bring him into Paradise. But when He creates a servant for Hell, He employs him in doing the deeds of those who will go to Hell, so that his final action before death is one of the deeds of those who go to Hell, for which He will bring him into Hell.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4704]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4704

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) say: He then mentioned a tradition like it. This version adds: When they propound that, say: "Say Allah is one. Allah is He to Whom men repair. He has not begotten and He has not been begotten, and no one is equal to Him." Then one should spit three times on his left side and seek refuge in Allah from Satan.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4705]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4705

Narrated Al-Abbas ibn AbdulMuttalib:

I was sitting in al-Batha with a company among whom the Apostle of Allah (peace_be_upon_him) was sitting, when a cloud passed above them.

The Apostle of Allah (peace_be_upon_him) looked at it and said: What do you call this? They said: Sahab.

He said: And muzn? They said: And muzn. He said: And anan? They said: And anan. AbuDawud said: I am not quite confident about the word anan. He asked: Do you know the distance between Heaven and Earth? They replied: We do not know. He then said: The distance between them is seventy-one, seventy-two, or seventy-three years. The heaven which is above it is at a similar distance (going on till he counted seven heavens). Above the seventh heaven there is a sea, the distance between whose surface and bottom is like that between one heaven and the next. Above that there are eight mountain goats the distance between whose hoofs and haunches is like the distance between one heaven and the next. Then Allah, the Blessed and the Exalted, is above that.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4713]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4713

Narrated AbuRazin al-Uqayli:

I asked: Apostle of Allah! will each one of us see his Lord? Ibn Mu'adh's version has: "being alone with Him, on the Day of Resurrection? And what sign is there is His creation?" He replied: AbuRazin! does each one of you not see the moon? Ibn Mu'adh's version has: "on the night when it is full, being alone with it?" Then the agreed version goes: I said: Yes. He said: Allah is more great. Ibn Mu'adh's version has: It is only part of Allah's creation, but Allah is more glorious and greater.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4716]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4716

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) presented himself to the people at Arafat, saying: Is there any man who takes me to his people? The Quraysh have prevented me from preaching the word of my Lord.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4721]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4721

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: My intercession will be for those of my people who have committed major sins.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4724]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4724

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: The trumpet (sur) which will be blown.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4726]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4726

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) said: When Allah created Paradise, He said to Gabriel: Go and look at it. He went and looked at it, then came and said: O my Lord! By Thy might, no one who hears of it will fail to enter it.

He then surrounded it with disagreeable things, and said: Go and look at it, Gabriel. He went and looked at it, then came and said: O my Lord! By Thy might, I am afraid that no one will enter it.

When Allah created Hell, He said: Go and look at it, Gabriel. He went and looked at it, then came and said: O my Lord! By Thy might, no one who hears of it will enter it.

He then surrounded it with desirable things and said: Go and look at it, Gabriel. He went, looked at it, then came and said: O my Lord! By Thy might and power, I am afraid that no one will remain who does not enter it.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4728]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4728

Narrated Zayd ibn Arqam:

We were with the Apostle of Allah (peace_be_upon_him). He said when we arrived at a halting place: You are not a hundred thousandth part of those who will come down to me at the pond. I (the narrator AbuHamzah) asked: What was your number that day? He replied: Seven or eight hundred.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4730]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4730

Narrated Anas ibn Malik:

When the Prophet of Allah (peace_be_upon_him) was lifted to the heavens (for travelling) in Paradise, or as he said, a river whose banks were of transparent or hollowed pearls was presented to him. The angel who was with him struck it with his hand and took out musk. Muhammad (peace_be_upon_him) then asked the angel who was with him: What is this? He replied: It is al-Kawthar which Allah has given you.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4731]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4731

Narrated AbuBarzah:

AbdusSalam ibn AbuHazim AbuTalut said: I saw AbuBarzah who came to visit Ubaydullah ibn Ziyad. Then a man named Muslim who was there in the company mentioned it to me.

When Ubaydullah saw him, he said: This Muhammad of yours is a dwarf and fat. The old man (i.e. AbuBarzah) understood it.

So he said: I did not think that I should remain among people who would make me feel ashamed of the company of Muhammad (peace_be_upon_him).

Thereupon Ubaydullah said: The company of Muhammad (peace_be_upon_him) is a honour for you, not a disgrace. He added: I called for you to ask about the reservoir. Did you hear the Apostle of Allah (peace_be_upon_him) mentioning anything about it? AbuBarzah said: Yes, not once, twice, thrice, four times or five times. If anyone believes it, may Allah not supply him with water from it. He then went away angrily.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4735]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4735

Narrated Al-Bara' ibn Azib:

We went out with the Apostle of Allah (peace_be_upon_him) accompanying the bier of a man of the Ansar. When we reached his grave, it was not yet dug. So the Apostle of Allah (peace_be_upon_him) sat down and we also sat down around him as if birds were over our heads. He had in his hand a stick with which he was scratching the ground.

He then raised his head and said: Seek refuge with Allah from the punishment in the grave. He said it twice or thrice.

The version of Jabir adds here: He hears the beat of their sandals when they go back, and at that moment he is asked: O so and so! Who is your Lord, what is your religion, and who is your Prophet?

Hannad's version says: Two angels will come to him, make him sit up and ask him: Who is your Lord?

He will reply: My Lord is Allah. They will ask him: What is your religion? He will reply: My religion is Islam. They will ask him: What is your opinion about the man who was sent on a mission among you? He will reply: He is the Apostle of Allah (peace_be_upon_him). They will ask: Who made you aware of this? He will reply: I read Allah's Book, believed in it, and considered it true; which is verified by Allah's words: "Allah's Book, believed in it, and considered it true, which is verified by Allah's words: "Allah establishes those who believe with the word that stands firm in this world and the next."

The agreed version reads: Then a crier will call from Heaven: My servant has spoken the truth, so spread a bed for him from Paradise, clothe him from Paradise, and open a door for him into Paradise. So some of its air and perfume will come to him, and a space will be made for him as far as the eye can see.

He also mentioned the death of the infidel, saying: His spirit will be restored to his body, two angels will come to him, make him sit up and ask him: Who is your Lord?

He will reply: Alas, alas! I do not know. They will ask him: What is your religion? He will reply: Alas, alas! I do not know. They will ask: Who was the man who was sent on a mission among you? He will reply: Alas, alas! I do not know. Then a crier will call from Heaven: He has lied, so spread a bed for him from Hell, clothe him from Hell, and open for him a door into Hell. Then some of its heat and pestilential wind will come to him, and his grave will be compressed, so that his ribs will be crushed together.

Jabir's version adds: One who is blind and dumb will then be placed in charge of him, having a sledge-hammer such that if a mountain were struck with it, it would become dust. He will give him a blow with it which will be heard by everything between the east and the west except by men and jinn, and he will become dust. Then his spirit will be restored to him.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4738]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4738

Narrated AbuUbaydah ibn al-Jarrah:

I heard the Prophet (peace_be_upon_him) say: There has been no Prophet after Noah who has not warned his people about the antichrist (Dajjal), and I warn you of him. The Apostle of Allah (peace_be_upon_him) described him to us, saying: Perhaps some who have seen me and heard my words will live till his time. The people asked: Apostle of Allah! what will be the condition of our hearts on that day? Like what we are today? He replied: Or better.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4740]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4740

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: He who separates from the community within a span takes off the noose of Islam from his neck.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4747]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4747

Narrated AbuSa'id al-Khudri ; Anas ibn Malik:

The Prophet (peace_be_upon_him) said: Soon there will appear disagreement and dissension in my people; there will be people who will be good in speech and bad in work. They recite the Qur'an, but it does not pass their collar-bones. They will swerve from the religion as an animal goes through the animal shot at. They will not return to it till the arrow comes back to its notch. They are worst of the people and animals. Happy is the one who kills them and they kill him. They call to the book of Allah, but they have nothing to do with it. He who fights against them will be nearer to Allah than them (the rest of the people). The people asked: What is their sign? He replied: They shave the head.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4753]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4753

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: If the property of anyone is designed to be taken away without any right and he fights and is killed, he is a martyr.


Dawud :: Model Behavior of the Prophet (Kitab Al-Sunnah) :: [40.4754]

Model Behavior of the Prophet (Kitab Al-Sunnah)

Dawud :: Book 40 : Hadith 4754

Narrated Sa'id ibn Zayd:

The Prophet (peace_be_upon_him) said: He who is killed while protecting his property is a martyr, and he who is killed while defending his family, or his blood, or his religion is a martyr.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4756]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4756

Narrated Anas ibn Malik:

I served the Prophet (peace_be_upon_him) at Medina for ten years. I was a boy. Every work that I did was not according to the desire of my master, but he never said to me: Fie, nor did he say to me: Why did you do this? or Why did you not do this?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4757]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4757

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) used to sit with us in meetings and talk to us. When he stood up we also used to stand up and see him entering the house of one of his wives. One day he talked to us and we stood up as he stood up and we saw that an Arabi (a nomadic Arab) caught hold of him and gave his cloak a violent tug making his neck red.

AbuHurayrah said: The cloak was coarse. He turned to him and the Arabi said to him: Load these two camels of mine, for you do not give me anything from your property or from your father's property.

The Prophet (peace_be_upon_him) said to him: No, I ask Allah's forgiveness; no, I ask Allah's forgiveness; no, I ask Allah's forgiveness. I shall not give you the camel-load until you make amends for the way in which you tugged at me.

Each time the Arabi said to him: I swear by Allah, I shall not do so.

He then mentioned the rest of the tradition. He (the Prophet), then called a man and said to him: Load these two camels of his: one camel with barley and the other with dates. He then turned to us and said: Go on your way with the blessing of Allah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4758]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4758

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: Good way, dignified good bearing and moderation are the twenty-fifth part of Prophecy.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4759]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4759

Narrated Mu'adh ibn Jabal:

The Apostle of Allah (peace_be_upon_him) said: if anyone suppresses anger when he is in a position to give vent to it, Allah, the Exalted, will call him on the Day of Resurrection over the heads of all creatures, and ask him to choose any of the bright and large eyed maidens he wishes.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4760]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4760

Narrated Son of a Companion:

The Apostle of Allah (peace_be_upon_him) said: He then mentioned a similar tradition described above. This version has: Allah will fill his heart with security and faith. He did not mention the words "Allah will call him". This version further adds: He who gives up wearing beautiful garments when he is able to do so (out of humility, as Bishr's version has) will be clothed by Allah with the robe of honour, and he who marries for Allah's sake will be crowned by Allah with the crown of Kingdom.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4762]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4762

Narrated Mu'adh ibn Jabal:

Two men reviled each other in the presence of the Prophet (peace_be_upon_him) and one of them became excessively angry so much so that I thought that his nose will break up on account of excess of anger. The Prophet (peace_be_upon_him) said: I know a phrase which, if he repeated, he could get rid of this angry feeling. They asked: What is it, Apostle of Allah? He replied: He should say: I seek refuge in Thee from the accursed devil. Mu'adh then began to ask him to do so, but he refused and persisted in quarrelling, and began to enhance his anger.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4764]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4764

Narrated AbuDharr:

The Apostle of Allah (peace_be_upon_him) said to us: When one of you becomes angry while standing, he should sit down. If the anger leaves him, well and good; otherwise he should lie down.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4766]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4766

Narrated Atiyyah as-Sa'di:

AbuWa'il al-Qass said: We entered upon Urwah ibn Muhammad ibn as-Sa'di. A man spoke to him and made him angry. So he stood and performed ablution; he then returned and performed ablution, and said: My father told me on the authority of my grandfather Atiyyah who reported the Apostle of Allah (peace_be_upon_him) as saying: Anger comes from the devil, the devil was created of fire, and fire is extinguished only with water; so when one of you becomes angry, he should perform ablution.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4770]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4770

Narrated Aisha, Ummul Mu'minin:

When the Prophet (peace_be_upon_him) was informed of anything of a certain man, he would not say: What is the matter with so and so that he says? But he would say: What is the matter with the people that they say such and such?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4771]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4771

Narrated Anas ibn Malik:

A man who had the mark of yellowness on him came to the Apostle of Allah (peace_be_upon_him). The apostle of Allah (peace_be_upon_him) rarely mentioned anything of a man which he disliked before him. When he went out, he said: Would that you asked him to wash it from him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4772]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4772

Narrated AbuSalamah ; AbuHurayrah:

The Prophet (peace_be_upon_him) said: The believer is simple and generous, but the profligate is deceitful and ignoble.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4774]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4774

Narrated Aisha, Ummul Mu'minin:

A man asked permission to see the Prophet (peace_be_upon_him), and the Prophet (peace_be_upon_him) said: He is a bad member of the tribe. When he entered, the Apostle of Allah (peace_be_upon_him) treated in a frank and friendly way and spoke to him. When he departed , I said: Apostle of Allah! When he asked permission, you said: He is a bad member of the tribe, but when he entered, you treated him in a frank and friendly way. The Apostle of Allah replied: Aisha! Allah does not like the one who is unseemly and lewd in his language.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4776]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4776

Narrated Anas ibn Malik:

I never said that when any man brought his mouth to the ear of the Apostle of Allah (peace_be_upon_him) and he withdrew his head until the man himself withdrew his head, and I never saw that when any man took him by his hand and he withdrew his hand, until the man himself withdrew his hand.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4780]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4780

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: By his good character a believer will attain the degree of one who prays during the night and fasts during the day.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4781]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4781

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: There is nothing heavier than good character put in the scale of a believer on the Day of Resurrection.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4782]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4782

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: I guarantee a house in the surroundings of Paradise for a man who avoids quarrelling even if he were in the right, a house in the middle of Paradise for a man who avoids lying even if he were joking, and a house in the upper part of Paradise for a man who made his character good.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4788]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4788

Narrated Abdullah ibn ash-Shikhkhir:

I went with a deputation of Banu Amir to the apostle of Allah (peace_be_upon_him), and we said: You are our lord (sayyid). To this he replied: The lord is Allah, the Blessed and Exalted. Then we said: And the one of us most endowed with excellence and superiority. To this he replied: Say what you have to say, or part of what you have to say, and do not let the devil make you his agents.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4790]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4790

Narrated Aisha, Ummul Mu'minin:

Al-Miqdam ibn Shurayh, quoting his father, said: I asked Aisha about living in the desert. She said: The Apostle of Allah (peace_be_upon_him) used to go to the desert to these rivulets. Once he intended to go to the desert and he sent to me a she-camel from the camel of sadaqah which had not been used for riding so far. He said to me: Aisha! show gentleness, for if gentleness is found in anything, it beautifies it and when it is taken out from anything it damages it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4791]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4791

Narrated Jarir:

The Prophet (peace_be_upon_him) said: He who is deprived of gentleness is deprived of good.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4792]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4792

Narrated Sa'd:

The Prophet (peace_be_upon_him) said: There is hesitation in everything except in the actions of the next world.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4793]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4793

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who does not thank Allah does not thank people.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4794]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4794

Narrated Anas ibn Malik:

The Immigrants (Muhajirun) said: Apostle of Allah! the Helpers (Ansar) got the entire reward. He said: no, so long as you pray to Allah for them and praise them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4795]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4795

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If someone is given something, he should give a return for it provided he can afford; if he cannot afford, he should praise him. He who praises him for it, thanks him, and he who conceals it is ungrateful to him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4796]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4796

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If someone is donated something, and he mentions it, he thanks for it, and if he conceals it, he is ungrateful for it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4799]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4799

Narrated Umar ibn al-Khattab:

The Prophet (peace_be_upon_him) said: the same occasion: Help the oppressed (sorrowful) and guide those who have lost their way.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4800]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4800

Narrated Anas ibn Malik:

A woman came to the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah: I have some need with you. He said to her: Mother of so and so, sit in the corner of any street you wish and I shall sit with you. So she sat and the Apostle of Allah (peace_be_upon_him) also sat with her till she fulfilled her need.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4802]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4802

Narrated AbuSa'id al-Khudri:

I heard the Apostle of Allah (peace_be_upon_him) as saying: The best places to sit are those which provide most room.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4803]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4803

Narrated AbuHurayrah:

AbulQasim (peace_be_upon_him) said: When one of you is in the sun (Shams)--Makhlad's version has "fay'"--and the shadow withdraws from him so that he is partly in sun and partly in shade, he should get up.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4804]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4804

Narrated AbuHazim al-Bajali:

AbuHazim came when the Apostle of Allah (peace_be_upon_him) was addressing. He stood in the sun. He ordered him (to shift) and he shifted to the shade.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4807]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4807

Narrated Jabir ibn Samurah:

When we came to the Prophet (peace_be_upon_him), each one would sit down where there was room.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4808]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4808

Narrated Hudhayfah:

The Apostle of Allah (peace_be_upon_him) cursed the one who sat in the middle of a circle.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4809]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4809

Narrated AbuBakrah:

Sa'id ibn AbulHasan said: When AbuBakrah came to us to give some evidence, a man got up from his place, but he refused to sit in it saying: The Prophet (peace_be_upon_him) forbade this, and the Prophet (peace_be_upon_him) forbade anyone to wipe his hand on the garment of anyone whose clothing he had not himself provided.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4810]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4810

Narrated Abdullah ibn Umar:

A man came to the Prophet (peace_be_upon_him), another man got up from his place for him, and when he went to sit in it, the Prophet (peace_be_upon_him) forbade him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4811]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4811

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: A believer who recites the Qur'an is like a citron whose fragrance is sweet and whose taste is sweet, a believer who does not recite the Qur'an is like a date which has no fragrance but has sweet taste, a profligate who recites the Qur'an is like basil whose fragrance is sweet but whose taste is bitter, and the profligate who does not recite the Qur'an is like the colocynth which has a bitter taste and has not fragrance. A good companion is like a man who has musk; if nothing of it goes to you, its fragrance will (certainly) go to you; and a bad companion is like a man who has bellows; if its (black) root does not go to you, its smoke will (certainly) go to you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4814]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4814

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: Associate only with a believer, and let only a God-fearing man eat your meals.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4815]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4815

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A man follows the religion of his friend; so each one should consider whom he makes his friend.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4818]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4818

Narrated As-Sa'ib:

I came to the Prophet (peace_be_upon_him). The people began to praise me and make a mention of me. The Apostle of Allah (peace_be_upon_him) said: I know you, that is, he knew him. I said: My father and mother be sacrificed for you! you were my partner and how good a partner ; you neither disputed nor quarrelled.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4819]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4819

Narrated Abdullah ibn Salam:

When the Apostle of Allah (peace_be_upon_him) sat talking (to the people), he would often raise his eyes to the sky.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4820]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4820

Narrated Jabir ibn Abdullah:

The Apostle of Allah (peace_be_upon_him) spoke in a distinct and leisurely manner.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4821]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4821

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) spoke in a distinct manner so that anyone who listened to him could understand it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4822]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4822

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Every important matter which is not begun by an expression of praise to Allah is maimed.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4823]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4823

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Every sermon which does not contain a tashahhud is like a hand cut off.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4824]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4824

Narrated Aisha, Ummul Mu'minin:

Maymun ibn AbuShabib said: A beggar passed by Aisha and gave him a piece of bread. Another man who wore clothes and had good appearance passed by her, and she made her seated and he ate (with her). When she was asked about that, she replied: The Apostle of Allah (peace_be_upon_him) said: treat the people according to their ranks.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4825]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4825

Narrated AbuMusa al-Ash'ari:

The Prophet (peace_be_upon_him) said: Glorifying Allah involves showing honour to a grey-haired Muslim and to one who can expound the Qur'an, but not to one who acts extravagantly regarding it, or turns away from it, and showing honour to a just ruler.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4826]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4826

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: One should not sit between two men except with their permission.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4827]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4827

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: It is not lawful for a man to separate two persons except with their permission.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4828]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4828

Narrated AbuSa'id al-Khudri:

When the Apostle of Allah (peace_be_upon_him) sat, he had his knees drawn up supported by his hands.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4829]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4829

Narrated Qaylah daughter of Makhramah:

She saw the Prophet (peace_be_upon_him) sitting with his arms round his legs. She said: When I saw the Apostle of Allah (peace_be_upon_him) in such humble condition in the sitting position (according to Musa's version), I trembled with fear.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4830]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4830

Narrated Ash-Sharid ibn Suwayd:

The Apostle of Allah (peace_be_upon_him) came upon me when I was sitting thus: having my left hand behind my back and leaning on the fleshy part of it, and said: Are you sitting in the manner of those with whom Allah is angry?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4836]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4836

Narrated AbudDarda':

The Apostle of Allah (peace_be_upon_him) would sit and we would also sit around him. If he got up intending to return, he would take off his sandals or something he was wearing, and his Companions recognising his purpose (that he would return) would stay where they were.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4837]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4837

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: People who get up from an assembly in which they did not remember Allah will be just as if they had got up from an ass's corpse, and it will be a cause of grief to them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4838]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4838

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone sits at a place where he does not remember Allah, deprivation will descend on him from Allah; and if he lies at a place where he does not remember Allah, deprivation will descend on him from Allah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4839]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4839

Narrated Abdullah ibn Amr ibn al-'As:

There are some expressions which a man utters three times when he gets up from an assembly he will be forgiven for what happened in the assembly; and no one utters them in an assembly held for a noble cause or for remembrance of Allah but that is stamped with them just as a document is stamped with a signet-ring. These expressions are: Glory be to Thee, O Allah, and I begin with praise of Thee, there is no god but thou; I ask Thy pardon, and return to Thee in repentance.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4841]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4841

Narrated AbuBarzah al-Aslami:

When the Apostle of Allah (peace_be_upon_him) intended to get up from the assembly he used to say in the last. Glory be to Thee. O Allah, and I begin with praise of Thee, I testify that there is no god but Thou; I ask Thy pardon, and return to Thee in repentance. The man asked: Apostle of Allah! you utter the words now which you did not do in the past? He replied: (This is an) atonement for what takes place in the assembly.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4842]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4842

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: None of my Companions must tell me anything about anyone, for I like to come out to you with no ill-feelings.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4843]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4843

Narrated Amr ibn al-Faghwa' al-Khuza'i:

The Apostle of Allah (peace_be_upon_him) called me. He intended to send me with some goods to AbuSufyan to distribute among the Quraysh at Mecca after the conquest.

He said: Search for a companion. Then Amr ibn Umayyah ad-Damri came to me and said: I have been told that you are intending to make a journey and are seeking a companion.

I said: Yes. He said: I am your companion. I then went to the Apostle of Allah (peace_be_upon_him) and said: I have found a companion.

He asked: Who is he? I replied: Amr ibn Umayyah ad-Damri. He said: When you come down to the territory of his people, be careful of him, for a maxim says: If one is your real brother, do not feel safe with him.

So we proceeded, and when I reached al-Abwa', he said to me: I have some work with my people at Waddan, so stay here till I come back. I said: Do not lose your way. When he turned his back, I recalled the words of the Prophet (peace_be_upon_him). So I rode my camel and galloped without stopping. When I reached al-Asafir, he was pursuing me with a group of men. So I galloped and forged ahead of him. When he saw me that I had outstripped him, they returned and he came to me.

He said to me: I had some work with my people. I said: Yes. We then went on until we reached Mecca, and I gave the goods to AbuSufyan.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4850]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4850

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: When a man tells something and then departs, it is a trust.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4851]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4851

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: Meetings are confidential except three: those for the purpose of shedding blood unlawfully, or committing fornication, or acquiring property unjustly.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4855]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4855

Narrated Ammar:

The Prophet (peace_be_upon_him) said: He who is two-faced in this world will have two tongues of fire on the Day of Resurrection.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4857]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4857

Narrated Aisha, Ummul Mu'minin:

I said to the Prophet (peace_be_upon_him): It is enough for you in Safiyyah that she is such and such (the other version than Musaddad's has:) meaning that she was short-statured. He replied; You have said a word which would change the sea if it were mixed in it. She said: I imitated a man before him (out of disgrace). He said: I do not like that I imitate anyone even if I should get such and such.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4858]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4858

Narrated Sa'id ibn Zayd:

The Prophet (peace_be_upon_him) said: The most prevalent kind of usury is going to lengths in talking unjustly against a Muslim's honour.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4859]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4859

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The gravest sin is going to lengths in talking unjustly against a Muslim's honour, and it is a major sin to abuse twice for abusing once.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4860]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4860

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: When I was taken up to heaven I passed by people who had nails of copper and were scratching their faces and their breasts. I said: Who are these people, Gabriel? He replied: They are those who were given to back biting and who aspersed people's honour.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4862]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4862

Narrated AbuBarzah al-Aslami:

The Prophet (peace_be_upon_him) said: O community of people, who believed by their tongue, and belief did not enter their hearts, do not back-bite Muslims, and do not search for their faults, for if anyone searches for their faults, Allah will search for his fault, and if Allah searches for the fault of anyone, He disgraces him in his house.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4863]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4863

Narrated Al-Mustawrid:

The Prophet (peace_be_upon_him) said: If anyone eats once at the cost of a Muslim's honour, Allah will give him a like amount of Jahannam to eat; if anyone clothes himself with a garment at the cost of a Muslim's honour, Allah will clothe him with like amount of Jahannam; and if anyone puts himself in a position of reputation and show Allah will disgrace him with a place of reputation and show on the Day of Resurrection.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4865]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4865

Narrated Mu'adh ibn Anas:

The Prophet (peace_be_upon_him) said: If anyone guards a believer from a hypocrite, Allah will send an angel who will guard his flesh on the Day of Resurrection from the fire of Jahannam; but if anyone attacks a Muslim saying something by which he wishes to disgrace him, he will be restrained by Allah on the bridge over Jahannam till he is acquitted of what he said.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4866]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4866

Narrated Jabir ibn Abdullah ; AbuTalhah ibn Sahl al-Ansari:

The Prophet (peace_be_upon_him) said: No (Muslim) man will desert a man who is a Muslim in a place where his respect may be violated and his honour aspersed without Allah deserting him in a place here he wishes his help; and no (Muslim) man who will help a Muslim in a place where his honour may be aspersed and his respect violated without Allah helping him in a place where he wishes his help.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4867]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4867

Narrated Jundub:

A desert Arab came and making his camel kneel and tethering it, entered the mosque and prayed behind the Apostle of Allah (peace_be_upon_him). When The Apostle of Allah (peace_be_upon_him) had given the salutation, he went to his riding beast and, after untethering and riding it, he called out: O Allah, show mercy to me and to Muhammad and associate no one else in Thy mercy to us. The Apostle of Allah (peace_be_upon_him) then said: Do you think that he or his camel is farther astray? Did you not listen to what he said? They replied: Certainly.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4868]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4868

Narrated Qatadah:

Is one of you helpless to be like AbuDaygham or Damdam (Ibn Ubayd is doubtful) who would say when morning came: O Allah, I gave my honour as alms to Thy servants?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4870]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4870

Narrated Mu'awiyah:

I heard the Apostle of Allah (peace_be_upon_him) say: If you search for the faults of the people, you will corrupt them, or will nearly corrupt them. AbudDarda' said: These are the words which Mu'awiyah himself from the Apostle of Allah (peace_be_upon_him), and Allah benefited him by them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4871]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4871

Narrated Miqdam ibn Ma'dikarib ; AbuUmamah:

The Prophet (peace_be_upon_him) said: When a ruler seeks to make imputations against the people, he corrupts them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4872]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4872

Narrated Abdullah ibn Mas'ud:

Zayd ibn Wahb said: A man was brought to Ibn Mas'ud. He was told: This is so and so, and wine was dropping from his beard. Abdullah thereupon said: We have been prohibited to seek out (faults). If anything becomes manifest to us, we shall seize it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4873]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4873

Narrated Uqbah ibn Amir:

The Prophet (peace_be_upon_him) said: He who sees something which should be kept hidden and conceals it will be like one who has brought to life a girl buried alive.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4874]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4874

Narrated Uqbah ibn Amir:

AbulHaytham quoted Dukhayn, the scribe of Uqbah ibn Amir, saying: We had some neighbours who used to drink wine. I for them, but they did not stop.

I then said to Uqbah ibn Amir: These neighbours of ours drink wine, and I tried to prevent them but they did not stop, and I am going to call the police about them.

He said: Leave them.

I again came to Uqbah ibn Amir and said: Our neighbours have refused to refrain from drinking wine, and I am going to call the police for them.

He said: Woe to thee! Leave them alone. I heard the Apostle of Allah (peace_be_upon_him) say: he then mentioned the tradition to the same effect as recorded above on the authority of the narrator Muslim.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4877]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4877

Narrated Iyad ibn Himar (al-Mujashi'i):

The Prophet (peace_be_upon_him) said: Allah has revealed to me that you must be humble, so that no one oppresses another and boasts over another.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4878]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4878

Narrated Sa'id ibn al-Musayyab:

While the Apostle of Allah (peace_be_upon_him) was sitting with some of his companions, a man reviled AbuBakr and insulted him. But AbuBakr remained silent. He insulted him twice, but AbuBakr controlled himself. He insulted him thrice and AbuBakr took revenge on him. Then the Apostle of Allah (peace_be_upon_him) got up when AbuBakr took revenge.

AbuBakr said: Were you angry with me, Apostle of Allah?

The Apostle of Allah (peace_be_upon_him) replied: An angel came down from Heaven and he was rejecting what he had said to you. When you took revenge, a devil came down. I was not going to sit when the devil came down.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4880]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4880

Narrated Aisha, Ummul Mu'minin:

Ibn Awn said: I asked about the meaning of intisar (revenge) in the Qur'anic verse: "But indeed if any do help and defend themselves (intasara) after a wrong (done) to them, against them there is no cause of blame." Then Ali ibn Zayd ibn Jad'an told me on the authority of Umm Muhammad, the wife of his father.

Ibn Awn said: It was believed that she used to go to the Mother of the Faithful (i.e. Aisha). She said: The Mother of the Faithful said: The Apostle of Allah (peace_be_upon_him) came upon me while Zaynab, daughter of Jahsh, was with us. He began to do something with his hand. I signalled to him until I made him understand about her. So he stopped. Zaynab came on and began to abuse Aisha. She tried to prevent her but she did not stop.

So he (the Prophet) said to Aisha: Abuse her.

So she abused her and dominated her. Zaynab then went to Ali and said: Aisha abused you and did (such and such). Then Fatimah came (to the Prophet) and he said to her: She is the favourite of your father, by the Lord of the Ka'bah!

She then returned and said to them: I said to him such and such, and he said to me such and such. Then Ali came to the Prophet (peace_be_upon_him) and spoke to him about that.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4882]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4882

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: Make a mention of the virtues of your dead, and refrain from (mentioning) their evils.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4883]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4883

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) say: There were two men among Banu Isra'il, who were striving for the same goal. One of them would commit sin and the other would strive to do his best in the world. The man who exerted himself in worship continued to see the other in sin.

He would say: Refrain from it. One day he found him in sin and said to him: Refrain from it.

He said: Leave me alone with my Lord. Have you been sent as a watchman over me? He said: I swear by Allah, Allah will not forgive you, nor will he admit you to Paradise. Then their souls were taken back (by Allah), and they met together with the Lord of the worlds.

He (Allah) said to this man who had striven hard in worship; Had you knowledge about Me or had you power over that which I had in My hand? He said to the man who sinned: Go and enter Paradise by My mercy. He said about the other: Take him to Hell.

AbuHurayrah said: By Him in Whose hand my soul is, he spoke a word by which this world and the next world of his were destroyed.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4884]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4884

Narrated AbuBakrah:

The Prophet (peace_be_upon_him) said: There is no sin more fitted to have punishment meted out by Allah to its perpetrator in advance in this world along with what He stores up for him in the next world than oppression and severing ties of relationship.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4885]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4885

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Avoid envy, for envy devours good deeds just as fire devours fuel or (he said) "grass."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4886]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4886

Narrated Anas ibn Malik:

Sahl ibn AbuUmamah said that he and his father (AbuUmamah) visited Anas ibn Malik at Medina during the time (rule) of Umar ibn AbdulAziz when he (Anas ibn Malik) was the governor of Medina. He was praying a very short prayer as if it were the prayer of a traveller or near it.

When he gave a greeting, my father said: May Allah have mercy on you! Tell me about this prayer: Is it obligatory or supererogatory?

He said: It is obligatory; it is the prayer performed by the Apostle of Allah (peace_be_upon_him). I did not make a mistake except in one thing that I forgot.

He said: The Apostle of Allah (peace_be_upon_him) used to say: Do not impose austerities on yourselves so that austerities will be imposed on you, for people have imposed austerities on themselves and Allah imposed austerities on them. Their survivors are to be found in cells and monasteries. (Then he quoted:) "Monasticism, they invented it; we did not prescribe it for them."

Next day he went out in the morning and said: will you not go out for a ride, so that you may see something and take a lesson from it?

He said: Yes. Then all of them rode away and reached a land whose inhabitants had perished, passed away and died. The roofs of the town had fallen in.

He asked: Do you know this land? I said: Who acquainted me with it and its inhabitants? (Anas said:) This is the land of the people whom oppression and envy destroyed. Envy extinguishes the light of good deeds, and oppression confirms or falsifies it. The eye commits fornication, and the palm of the hand, the foot, body, tongue and private part of the body confirm it or deny it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4888]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4888

Narrated Samurah ibn Jundub:

The Prophet (peace_be_upon_him) said: Do not invoke Allah's curse, Allah's anger, or Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4890]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4890

Narrated Abdullah ibn Abbas:

A man cursed the wind. The narrator Muslim's version has: The wind snatched away a man's cloak during the time of the Prophet (peace_be_upon_him) and he cursed it. The Prophet (peace_be_upon_him) said: Do not curse it, for it is under command, and if anyone curses a thing undeservedly, the curse returns upon him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4891]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4891

Narrated Aisha, Ummul Mu'minin:

Something of her was stolen, and she began to curse him (i.e. the thief). The Apostle of Allah (peace_be_upon_him) said to her: Do not lessen his sin.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4894]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4894

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: It is not allowable for a believer to keep from a believer for more than three days. If three days pass, he should meet him and give him a salutation, and if he replies to it they will both have shared in the reward; but if he does not reply he will bear his sin (according to Ahmad's version) and the one who gives the salutation will have come forth from the sin of keeping apart.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4895]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4895

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said: It is not right for a Muslim to keep apart from another Muslim for more than three days. Then when he meets him and gives three salutations, receiving during that time no response, the other bears his sin.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4896]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4896

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: It is not allowable for a Muslim to keep apart from his brother for more than three days, for one who does so and dies will enter Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4897]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4897

Narrated AbuKhirash as-Sulami:

AbuKhirash heard the Apostle of Allah (peace_be_upon_him) say: If one keeps apart from his brother for a year, it is like shedding his blood.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4900]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4900

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: The believer is the believer's mirror, and the believer is the believer's brother who guards him against loss and protects him when he is absent.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4901]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4901

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: Shall I not inform you of something more excellent in degree than fasting, prayer and almsgiving (sadaqah)? The people replied: Yes, Prophet of Allah! He said: It is putting things right between people, spoiling them is the shaver (destructive).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4902]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4902

Narrated Umm Kulthum bint Uqbah al-Umawiyyah:

The Prophet (peace_be_upon_him) said: He who forged in order to put things right between two persons did not lie. The version by Ahmad ibn Muhammad and Musaddad has: The liar is not the one who puts things right between people, saying what is good and increasing good.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4905]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4905

Narrated Anas ibn Malik:

When the Apostle of Allah (peace_be_upon_him) came to Medina, the Abyssinians played for his coming out of joy; they played with spears.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4906]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4906

Narrated Abdullah ibn Umar:

Nafi' said: Ibn Umar heard a pipe, put his fingers in his ears and went away from the road. He said to me: Are you hearing anything? I said: No. He said: He then took his fingers out of his ears and said: I was with the Prophet (peace_be_upon_him), and he heard like this and he did like this. AbuAli al-Lu'lu said: I heard AbuDawud say: This is a rejected tradition.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4909]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4909

Narrated Abdullah ibn Mas'ud:

Salam ibn Miskin, quoting an old man who witnessed AbuWa'il in a wedding feast, said: They began to play, amuse and sing. He united the support of his hand round his knees that were drawn up, and said: I heard Abdullah (ibn Mas'ud) say: I heard the apostle of Allah (peace_be_upon_him) say: Singing produces hypocrisy in the heart.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4910]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4910

Narrated AbuHurayrah:

A hermaphrodite (mukhannath) who had dyed his hands and feet with henna was brought to the Prophet (peace_be_upon_him). He asked: What is the matter with this man? He was told: Apostle of Allah! he affects women's get-up. So he ordered regarding him and he was banished to an-Naqi'. The people said: Apostle of Allah! should we not kill him? He said: I have been prohibited from killing people who pray. AbuUsamah said: Naqi' is a region near Medina and not a Baqi'.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4914]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4914

Narrated Aisha, Ummul Mu'minin:

When the Apostle of Allah (peace_be_upon_him) arrived after the expedition to Tabuk or Khaybar (the narrator is doubtful), the draught raised an end of a curtain which was hung in front of her store-room, revealing some dolls which belonged to her.

He asked: What is this? She replied: My dolls. Among them he saw a horse with wings made of rags, and asked: What is this I see among them? She replied: A horse. He asked: What is this that it has on it? She replied: Two wings. He asked: A horse with two wings? She replied: Have you not heard that Solomon had horses with wings? She said: Thereupon the Apostle of Allah (peace_be_upon_him) laughed so heartily that I could see his molar teeth.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4915]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4915

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) married me when I was seven or six. When we came to Medina, some women came. according to Bishr's version: Umm Ruman came to me when I was swinging. They took me, made me prepared and decorated me. I was then brought to the Apostle of Allah (peace_be_upon_him), and he took up cohabitation with me when I was nine. She halted me at the door, and I burst into laughter.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4916]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4916

Narrated AbuUsamah:

The tradition mentioned above (No. 4915) has also been transmitted by AbuUsamah in a similar manner through a different chain of narrators.

This version has: "With good fortune. " She (Umm Ruman) entrusted me to them. They washed my head and redressed me. No one came to me suddenly except the Apostle of Allah (peace_be_upon_him) in the forenoon. So they entrusted me to him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4917]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4917

Narrated Aisha, Ummul Mu'minin:

When we came to Medina, the women came to me when I was playing on the swing, and my hair were up to my ears. They brought me, prepared me, and decorated me. Then they brought me to the Apostle of Allah (peace_be_upon_him) and he took up cohabitation with me, when I was nine.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4920]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4920

Narrated AbuMusa al-Ash'ari:

The Apostle of Allah (peace_be_upon_him) said: He who plays backgammon disobeys Allah and His Apostle.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4922]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4922

Narrated AbuHurayrah:

The Apostle of Allah (peace_be_upon_him) saw a man pursuing a pigeon. He said: A devil is pursuing a female devil.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4923]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4923

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: The Compassionate One has mercy on those who are merciful. If you show mercy to those who are on the earth, He Who is in the heaven will show mercy to you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4924]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4924

Narrated AbuHurayrah:

I heard AbulQasim (peace_be_upon_him) who spoke the truth and whose word was verified say: Mercy is taken away only from him who is miserable.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4925]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4925

Narrated Abdullah ibn Amr ibn al-'As:

The Prophet (peace_be_upon_him) said: Those who do not show mercy to our young ones and do not realise the right of our elders are not from us.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4927]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4927

Narrated Jarir:

I swore allegiance to the Apostle of Allah (peace_be_upon_him) promising to hear and obey, and behave sincerely towards every Muslim. AbuZur'ah said: Whenever he sold and bought anything, he would say: What we took from you is dearer to us than what we gave you. So choose (as you like).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4930]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4930

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: On the Day of Resurrection you will be called by your names and by your father's names, so give yourselves good names.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4932]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4932

Narrated AbuWahb al-Jushami:

The Prophet (peace_be_upon_him) said: Call yourselves by the names of the Prophets. The names dearest to Allah are Abdullah and AbdurRahman, the truest are Harith and Hammam, and the worst are Harb and Murrah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4936]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4936

Narrated Usamah ibn Akhdari:

A man called Asram was among those who came to the Apostle of Allah (peace_be_upon_him). The Apostle of Allah (peace_be_upon_him) said: What is your name? He replied: Asram. He said: No, you are Zur'ah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4937]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4937

Narrated Hani ibn Yazid:

When Hani went with his people in a deputation to the Apostle of Allah (peace_be_upon_him), he heard them calling him by his kunyah (surname), AbulHakam.

So the Apostle of Allah (peace_be_upon_him) called him and said: Allah is the judge (al-Hakam), and to Him judgment belongs. Why are you given the kunyah AbulHakam?

He replied: When my people disagree about a matter, they come to me, and I decide between them, and both parties are satisfied with my decision.

He said: How good this is! What children have you? He replied: I have Shurayh, Muslim and Abdullah. He asked; Who is the oldest of them? I replied: Shurayh. He said: Then you are AbuShurayh.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4938]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4938

Narrated AbuWahb, Hazn ibn AbuWahb:

The Prophet (peace_be_upon_him) asked: What is your name? He replied: Hazn (rugged). He said: You are Sahl (smooth). He said: No, smooth is trodden upon and disgraced. Sa'id said: I then thought that ruggedness would remain among us after it. AbuDawud said: The Prophet (peace_be_upon_him) changed the names al-'As, Aziz, Atalah, Shaytan, al-Hakam, Ghurab, Hubab, and Shihab and called him Hisham. He changed the name Harb (war) and called him Silm (peace). He changed the name al-Munba'ith (one who lies) and called him al-Mudtaji' (one who stands up). He changed the name of a land Afrah (barren) and called it Khadrah (green). He changed the name Shi'b ad-Dalalah (the mountain path of a stray), the name of a mountain path and called it Shi'b al-Huda (mountain path of guidance). He changed the name Banu az-Zinyah (children of fornication) and called them Banu ar-Rushdah (children of those who are on the right path), and changed the name Banu Mughwiyah (children of a woman who allures and goes astray), and called them Banu Rushdah (children of a woman who is on the right path). AbuDawud said: I omitted the chains of these for the sake of brevity.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4939]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4939

Narrated Umar ibn al-Khattab:

Masruq said: I met Umar ibn al-Khattab (Allah be pleased with him) who said: Who are you? I replied: Masruq ibn al-Ajda'. Umar then said: I heard the Apostle of Allah (peace_be_upon_him) say: al-Ajda' (mutilated) is a devil.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4942]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4942

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If I survive (God willing), I shall forbid my people to give the names Nafi' (beneficial), Aflah (successful) and Barakah (blessing). Al-A'mash said: I do not know whether he mentioned Nafi' or not. When a man comes and asks: Is there Barakah (blessing)? The people say: No.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4944]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4944

Narrated AbuJubayrah ibn ad-Dahhak:

This verse was revealed about us, the Banu Salimah: "Nor call each other by (offensive) nicknames: ill-seeming is a name connoting wickedness (to be used of one) after he has believed." He said: When the apostle of Allah (peace_be_upon_him) came to us, every one of us had two or three names. The Apostle of Allah (peace_be_upon_him) began to say: O so and so! But they would say: Keep silence, Apostle of Allah! He becomes angry by this name. So this verse was revealed: "Nor call each other by (offensive nicknames."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4945]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4945

Narrated AbuMas'ud or Hudhayfah:

AbuMas'ud asked Abdullah, or AbuAbdullah asked AbuMas'ud: What did you hear the Apostle of Allah (peace_be_upon_him) say about za'amu (they alleged, asserted, or it is said). He replied: I heard the Apostle of Allah (peace_be_upon_him) say: It is a bad riding-beast for a man (to say) za'amu (they asserted).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4946]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4946

Narrated A man:

AbulMalih reported on the authority of a man: I was riding on a mount behind the Prophet (peace_be_upon_him). It stumbled. Thereupon I said: May the devil parish! He said: Do not say: May the devil perish! for if you say that , he will swell so much so that he will be like a house, and say: By my power. But say: In the name of Allah; for when you say that, he will diminish so much so that he will be like a fly.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4948]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4948

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: If anyone is called by my name, he must not be given my kunyah (surname), and if anyone uses my kunyah (surname), he must not be called by my name.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4949]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4949

Narrated Ali ibn AbuTalib:

I said: Apostle of Allah! tell me if a son is born to me after your death, may I give him your name and your kunyah? He replied: Yes.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4950]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4950

Narrated Aisha, Ummul Mu'minin:

A woman came to the Apostle of Allah (peace_be_upon_him) and said: Apostle of Allah! I have given birth to a boy, and call him Muhammad and AbulQasim as kunyah (surname), but I have been told that you disapproved of that. He replied: What is it which has made my name lawful and my kunyah unlawful, or what is it which has made my kunyah unlawful and my name lawful?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4952]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4952

Narrated Aisha, Ummul Mu'minin:

Aisha said: Apostle of Allah! All my fellow-wives have kunyahs? He said: Give yourself the kunyah by Abdullah, your son - that is to say, her nephew (her sister's son).

Musaddad said: Abdullah ibn az-Zubayr. She was called by the kunyah Umm Abdullah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4953]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4953

Narrated Sufyan ibn Asid al-Hadrami:

I heard the Apostle of Allah (peace_be_upon_him) say: It is great treachery that you should tell your brother something and have him believe you when you are lying.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4957]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4957

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: None of you must say: "My slave" (abdi) and "My slave-woman" (amati), and a slave must not say: "My lord" (rabbi or rabbati). The master (of a slave) should say: "My young man" (fataya) and "My young woman" (fatati), and a slave should say "My master" (sayyidi) and "My mistress" (sayyidati), for you are all (Allah's slave and the Lord is Allah, Most High.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4959]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4959

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: Do not call a hypocrite sayyid (master), for if he is a sayyid, you will displease your Lord, Most High.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4962]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4962

Narrated Hudhayfah:

The Prophet (peace_be_upon_him) said: Do not say: "What Allah wills and so and so wills," but say: "What Allah wills and afterwards so and so wills.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4965]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4965

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When you hear....(Musa's version has): When a man says people have perished, he is the one who has suffered that fate most.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4967]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4967

Narrated A man:

Salim ibn AbulJa'dah said: A man said: (Mis'ar said: I think he was from the tribe of Khuza'ah): would that I had prayed, and got comfort. The people objected to him for it. Thereupon he said: I heard the Apostle of Allah (peace_be_upon_him) as saying: O Bilal, call iqamah for prayer: give us comfort by it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4968]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4968

Narrated Abdullah ibn Muhammad ibn al-Hanafiyyah:

I and my father went to the house of my father-in-law from the Ansar to pay a sick visit to him. The time of prayer came. He said to someone of his relatives: O girl! bring me water for ablution so that I pray and get comfort. We objected to him for it. He said: I heard the Apostle of Allah (peace_be_upon_him) say: Get up, Bilal, and give us comfort by the prayer.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4969]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4969

Narrated Aisha, Ummul Mu'minin:

I never heard the Apostle of Allah (peace_be_upon_him) attributing anyone to anything except to religion.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4972]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4972

Narrated Mu'awiyah ibn Jaydah al-Qushayri:

The Apostle of Allah (peace_be_upon_him) said: Woe to him who tells things, speaking falsely, to make people laugh thereby. Woe to him! Woe to him!.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4973]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4973

Narrated Abdullah ibn Amir:

My mother called me one day when the Apostle of Allah (peace_be_upon_him) was sitting in our house. She said: Come here and I shall give you something. The Apostle of Allah (peace_be_upon_him) asked her: What did you intend to give him? She replied: I intended to give him some dates. The Apostle of Allah (peace_be_upon_him) said: If you were not to give him anything, a lie would be recorded against you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4974]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4974

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: It is enough falsehood for a man to relate everything he hears.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4975]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4975

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: To harbour good thoughts is a part of well-conducted worship. (This is according to Nasr's version).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4977]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4977

Narrated Zayd ibn Arqam:

The Prophet (peace_be_upon_him) said: When a man makes a promise to his brother with the intention of fulfilling it and does not do so, and does not come at the appointed time, he is guilty of no sin.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4978]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4978

Narrated Abdullah ibn AbulHamsa':

I bought something from the Prophet (peace_be_upon_him) before he received his Prophetic commission, and as there was something still due to him I promised him that I would bring it to him at his place, but I forgot. When I remembered three days later, I went to that place and found him there. He said: You have vexed me, young man. I have been here for three days waiting for you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4980]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4980

Narrated Anas ibn Malik:

A man came to the Prophet (peace_be_upon_him) and said: Apostle of Allah! give me a mount. The Prophet (peace_be_upon_him) said: We shall give you a she-camel's child to ride on. He said: What shall I do with a she-camel's child? The Prophet (peace_be_upon_him) replied: Do any others than she-camels give birth to camels?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4981]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4981

Narrated An-Nu'man ibn Bashir:

When AbuBakr asked the permission of the Prophet (peace_be_upon_him) to come in, he heard Aisha speaking in a loud voice.

So when he entered, he caught hold of her in order to slap her, and said: Do I see you raising your voice to the Apostle of Allah? The Prophet (peace_be_upon_him) began to prevent him and AbuBakr went out angry. The Prophet (peace_be_upon_him) said when AbuBakr went out: You see I rescued you from the man.

AbuBakr waited for some days, then asked permission of the Apostle of Allah (peace_be_upon_him) to enter, and found that they had made peace with each other. He said to them: Bring me into your peace as you brought me into your war.

The Prophet (peace_be_upon_him) said: We have done so: we have done so.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4984]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4984

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) addressed me as: O you with the two ears.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4985]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4985

Narrated Abdullah ibn as-Sa'ib ibn Yazid:

The Apostle of Allah (peace_be_upon_him) said: None of you should take the property of his brother in amusement (i.e. jest), nor in earnest. The narrator Sulayman said: Out of amusement and out of earnest. If anyone takes the staff of his brother, he should return it. The transmitter Ibn Bashshar did not say "Ibn Yazid, and he said: The Apostle of Allah (peace_be_upon_him) said.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4986]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4986

Narrated AbdurRahman ibn AbuLayla:

The Companions of the Prophet (peace_be_upon_him) told us that they were travelling with the Prophet (peace_be_upon_him). A man of them slept, and one of them went to the rope which he had with him. He took it, by which he was frightened. The Prophet (peace_be_upon_him) said: It is not lawful for a Muslim that he frightens a Muslim.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4987]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4987

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) said: Allah , the Exalted, hates the eloquent one among men who moves his tongue round (among his teeth), as cattle do.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4988]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4988

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: On the Day of resurrection Allah will not accept repentance or ransom from him who learns excellence of speech to captivate thereby the hearts of men, or of people.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4990]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4990

Narrated Amr ibn al-'As:

One day when a man got up and spoke at length Amr ibn al-'As said If he had been moderate in what he said: It would have been better for him. I heard the Apostle of Allah (peace_be_upon_him) say: I think (or, I have been commanded) that I should be brief in what I say, for brevity is better.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4993]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4993

Narrated Abdullah ibn Abbas:

A desert Arab came to the Prophet (peace_be_upon_him) and began to speak. Thereupon the Apostle of Allah (peace_be_upon_him) said: In eloquence there is magic and in poetry there is wisdom.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4994]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4994

Narrated Buraydah ibn al-Hasib:

I heard the Apostle of Allah (peace_be_upon_him) say: In eloquence there is magic, in knowledge ignorance, in poetry wisdom, and in speech heaviness.

Sa'sa'ah ibn Suhan said: The Prophet of Allah (peace_be_upon_him) spoke the truth. His statement "In eloquence there is magic" means: (For example), there is a right due from a man who is more eloquent in reasoning than the man who is demanding his right. He (the defendant) charms the people by his speech and takes away his right. His statement "In knowledge there is ignorance" means: A scholar brings to his knowledge what he does not know, and thus he becomes ignorant of that. His statement "In poetry there is wisdom" means: These are the sermons and examples by which people receive admonition. His statement "In speech there is heaviness" means: That you present your speech and your talk to a man who is not capable of understanding it, and who does not want it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4995]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4995

Narrated Hasan:

Sa'id said: Umar passed by Hassan when he was reciting verses in the mosque. He looked at him. Thereupon he said: I used to recite verses when there was present in it the one who was better than you (i.e. the Prophet).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4997]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4997

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) used to setup a pulpit in the mosque for Hassan who would stand on it and satirise those who spoke against the Apostle of Allah (peace_be_upon_him). The Apostle of Allah (peace_be_upon_him) would say: The spirit of holiness (i.e. Gabriel) is with Hassan so long as he speaks in defence of the Apostle of Allah (peace_be_upon_him).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.4999]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 4999

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) finished the dawn prayer, he would ask: Did any of you have a dream last night? And he said: All that is left of Prophecy after me is a good vision.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5002]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5002

Narrated AbuRazin:

The Prophet (peace_be_upon_him) said: The vision flutters over a man as long as it is not interpreted , but when it is interpreted, it settles. And I think he said: Tell it only to one who loves (i.e. friend) or one who has judgment.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5007]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5007

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: One night it seemed to me in a dream that we were in the house of Uqbah ibn Rafi' and were brought some of the fresh dates of Ibn tab. I interpreted it as meaning that to us is granted eminence (rif'ah) in this world, a blessed hereafter ('aqibah), and that our religion has been good (tabah).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5011]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5011

Narrated AbuHurayrah:

When the Apostle of Allah (peace_be_upon_him) sneezed, he placed his hand or a garment on his mouth, and lessened the noise. The transmitter Yahya is doubtful about the exact words khafada or ghadda (lessened).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5013]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5013

Narrated Salim ibn Ubayd:

Hilal ibn Yasar said: We were with Salim ibn Ubayd when a man from among the people sneezed and said: Peace be upon you.

Salim said: And upon you and your mother. Later he said: Perhaps you found something (annoying) in what I said to you.

He said: I wished you would not mention my mother with good or evil. He said: I have just said to you what the Apostle of Allah (peace_be_upon_him) said. We were in the presence of the Apostle of Allah (peace_be_upon_him) when a man from among the people sneezed, saying: Peace be upon you!

The Apostle of Allah (peace_be_upon_him) said: And upon you and your mother. He then said: When one of you sneezes, he should praise Allah. He further mentioned some attributes (of Allah), saying: The one who is with him should say to him: Allah have mercy on you, and he should reply to them: Allah forgive us and you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5014]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5014

Narrated Salim ibn Ubayd al-Ashja'i:

The tradition mentioned above (No. 5013) has also been mentioned by Salim ibn Ubayd al-Ashja'i to the same effect from the Prophet (peace_be_upon_him) through a different chain of narrators.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5016]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5016

Narrated AbuHurayrah:

Respond three times to your brother when he sneezes, and if he sneezes more often, he has a cold in his head.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5018]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5018

Narrated Ubayd ibn Rifa'ah az-Zuraqi:

The Prophet (peace_be_upon_him) said: Invoke a blessing on one who sneezes three times; (and if he sneezes more often), then if you wish to invoke a blessing on him, you may invoke, and if you wish (to stop), then stop.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5020]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5020

Narrated AbuBurdah:

The Jews used to try to sneezes in the presence of the Prophet (peace_be_upon_him) hoping that he would say to them: "Allah have mercy on you!" but he would say: May Allah guide you and grant you well-being!


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5022]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5022

Narrated Tikhfat al-Ghifari:

Ya'ish ibn Tikhfat al-Ghifari said: My father was one of the people in the Suffah.

The Apostle of Allah (peace_be_upon_him) said: Come with us to the house of Aisha. So we went and he said: Give us food, Aisha. She brought hashishah and we ate. He then said: Give us food, Aisha. She then brought haysah as small in quantity as a pigeon and we ate. He then said: Give us something to drink, Aisha. So she brought a bowl of milk, and we drank. Again he said: Give us something to drink, Aisha. She then brought a small cup and we drank. He then said: If you wish, you may spend the night (here), or if you wish, you may go to the mosque.

He said: While I was lying on my stomach because of pain in the lung, a man began to shake me with his foot and then said: This is a method of lying which Allah hates. I looked and saw that he was the Apostle of Allah (peace_be_upon_him).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5023]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5023

Narrated Ali ibn Shayban:

The Prophet (peace_be_upon_him) said: If anyone spends the night on the roof of a house with no stone palisade, Allah's responsibility to guard him no longer applies.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5024]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5024

Narrated Mu'adh ibn Jabal:

The Prophet (peace_be_upon_him) said: If a Muslim sleeps while remembering Allah, in the state of purification, is alarmed while asleep at night, and asks Allah for good in this world and in the Hereafter. He surely gives it to him. Thabit al-Bunani said: AbuZabyah came to visit us and he transmitted this tradition to us from Mu'adh ibn Jabal from the Prophet (peace_be_upon_him). Thabit said: So and so said: I tried my best to utter these (prayers) when I got up, but I could not do.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5026]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5026

Narrated Umm Salamah, Ummul Mu'minin:

Some relative of Umm Salamah said: The bed of the Prophet (peace_be_upon_him) was set as a man is laid in his grave; the mosque was towards his head.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5027]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5027

Narrated Hafsah, Ummul Mu'minin:

When the Apostle of Allah (peace_be_upon_him) wanted to go to sleep, he put his right hand under his cheek and would then say three times: O Allah, guard me from Thy punishment on the day when Thou raisest up Thy servants.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5034]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5034

Narrated Ali ibn AbuTalib:

The Apostle of Allah (peace_be_upon_him) used to say when he lay down: O Allah, I seek refuge in Thy noble Person and in Thy perfect Words from the evil of what Thou seizest by its forelock; O Allah! Thou removest debt and sin; O Allah! thy troop's not routed, Thy promise is not broken and the riches of the rich do not avail against Thee. Glory and praise be unto Thee!.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5036]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5036

Narrated AbulAzhar al-Anmari:

When the Apostle of Allah (peace_be_upon_him) went to his bed at night, he would say: in the name of Allah, I have laid down my side for Allah. O Allah! forgive me my sin, drive away my devil, free me from my responsibility, and place me in the highest assembly.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5037]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5037

Narrated Nawfal:

The Prophet (peace_be_upon_him) said to Nawfal: Say , O infidels! and then sleep at its end, for it is a declaration of freedom from polytheism.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5039]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5039

Narrated Irbad ibn Sariyah:

The Apostle of Allah (peace_be_upon_him) used to recite al-Musabbihat before going to sleep, and say: They contain a verse which is better than a thousand verses.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5040]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5040

Narrated Abdullah ibn Umar:

When the Apostle of Allah (peace_be_upon_him) went to his bed, he would say: Praise be to Allah Who has given me sufficiency, has guarded me, given me food and drink, been most gracious to me, and given to me most lavishly. Praise be to Allah in every circumstance. O Allah! Lord and King of everything, God of everything, I seek refuge in Thee from Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5041]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5041

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone lies on his side where he does not remember Allah, deprivation will descend on him on the Day of Resurrection; and if anyone sits in a place where he does not remember Allah, deprivation will descend on him on the Day of Resurrection.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5043]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5043

Narrated Aisha, Ummul Mu'minin:

When the Apostle of Allah (peace_be_upon_him) awake at night, he said: There is no god but thou, glory be to Thee, O Allah, I ask Thy pardon for my sin and I ask Thee for Thy mercy. O Allah! advance me in knowledge: do not cause my heart to deviate (from guidance) after Thou hast guided me, and grant me mercy from thyself; verily thou art the grantor.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5046]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5046

Narrated Ali ibn AbuTalib:

The tradition (No 5045, about Tasbih Fatimah) has been transmitted by Ali to the same effect through a different chain of narrators.

This version adds: Ali said: I did not leave them (Tasbih Fatimah) since I heard them from the Apostle of Allah (peace_be_upon_him) except on the night of Siffin, for I remembered them towards the end of the night and then I uttered them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5047]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5047

Narrated Abdullah ibn Amr:

The Prophet (peace_be_upon_him) said: There are two qualities or characteristics which will not be returned by any Muslim without his entering Paradise. While they are easy, those who act upon them are few. One should say: "Glory be to Allah" ten times after every prayer, "Praise be to Allah" ten times and "Allah is Most Great" ten times. That is a hundred and fifty on the tongue, but one thousand and five hundred on the scale. When he goes to bed, he should say: "Allah is Most Great" thirty-four times, "Praise be to Allah" thirty-three times, and Glory be to Allah thirty-three times, for that is a hundred on the tongue and a thousand on the scale. (He said:) I saw the Apostle of Allah (peace_be_upon_him) counting them on his hand.

The people asked: Apostle of Allah! How is it that while they are easy, those who act upon them are few?

He replied: The Devil comes to one of you when he goes to bed and he makes him sleep, before he utters them, and he comes to him while he is engaged in prayer and calls a need to his mind before he utters them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5049]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5049

Narrated AbuHurayrah:

AbuBakr as-Siddiq said: Apostle of Allah! command me something to say in the morning and in the evening. He said: Say "O Allah, Creator of the heavens and the earth, Who knowest the unseen and the seen, Lord and Possessor of everything. I testify that there is no god but Thee; I seek refuge in Thee from the evil within myself, from the evil of the devil, and his (incitement to) attributing partners (to Allah)." He said: Say this in the morning.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5050]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5050

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) used to say in the morning: "O Allah, by Thee we come to the morning, by Thee we come to the evening, by Thee are we resurrected." In the evening he would say: "O Allah, by Thee we come to the evening, by Thee we die, and to Thee are we resurrected."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5051]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5051

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: If anyone says in the morning or in the evening: "O Allah! in the morning we call Thee, the bearers of Thy Throne, Thy angels and all Thy creatures to witness that thou art Allah (God) than Whom alone there is no god, and that Muhammad is Thy Servant and Apostle," Allah will emancipate his fourth from Hell; if anyone says twice, Allah will emancipate his half; if anyone says it thrice, Allah will emancipate three-fourth; and if he says four times, Allah will emancipate him from Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5052]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5052

Narrated Buraydah ibn al-Hasib:

The Prophet (peace_be_upon_him) said: If anyone says in the morning or in the evening: "O Allah! Thou art my Lord; there is no god but Thee, Thou hast created me, and I am Thy servant and hold to Thy covenant and promise as much as I can; I seek refuge in Thee from the evil of what I have done: I acknowledge Thy favour to me, and I acknowledge my sin; pardon me, for none but Thee pardons sins, and dies during the daytime or during the night." he will go to Paradise.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5054]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5054

Narrated A man:

AbuSallam told that he was in the mosque of Hims. A man passed him and the people said about him that he served the Prophet (peace_be_upon_him).

He (AbuSallam) went to him and said: Tell me any tradition which you heard from the Apostle of Allah (peace_be_upon_him) and there were no man between him and you. He said: I heard the Apostle of Allah (peace_be_upon_him) say: If anyone says in the morning and in the evening: "I am pleased with Allah as Lord, with Islam as religion, with Muhammad as Prophet," Allah will certainly please him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5055]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5055

Narrated Abdullah ibn Ghannam:

The Prophet (peace_be_upon_him) said: If anyone says in the morning: "O Allah! whatever favour has come to me, it comes from Thee alone Who has no partner; to Thee praise is due and thanksgiving,'! he will have expressed full thanksgiving for the day; and if anyone says the same in the evening, he will have expressed full thanksgiving for the night.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5056]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5056

Narrated Abdullah ibn Umar:

The Apostle of Allah (peace_be_upon_him) never failed to utter these supplications in the evening and in the morning: O Allah, I ask Thee for security in this world and in the Hereafter: O Allah! I ask Thee for forgiveness and security in my religion and my worldly affairs, in my family and my property; O Allah! conceal my fault or faults (according to Uthman's version), and keep me safe from the things which I fear; O Allah! guard me in front of me and behind me, on my right hand and on my left, and from above me: and I seek in Thy greatness from receiving unexpected harm from below me." AbuDawud said: Waki' said: That is to say, swallowing by the earth.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5057]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5057

Narrated Daughter of the Prophet:

AbdulHamid, a client of Banu Hashim, said that his mother who served some of the daughters of the Prophet (peace_be_upon_him) told him that one of the daughters of the Prophet (peace_be_upon_him) said that the Prophet (peace_be_upon_him) used to teach her saying: Say in the morning: Glory be to Allah, and I begin with praise of Him; there is no power but in Allah ; what Allah wills comes to pass and what He does not will does not come to pass; I know that Allah is Omnipotent and that Allah has comprehended everything in knowledge" ; for whoever says it in the morning will be guarded till the evening, and whoever says it in the evening will be guarded till the morning.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5058]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5058

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone repeats in the morning: "So glory be to Allah in the evening and in the morning; to Him is the praise in the heavens and the earth, and in the late evening and at noon....thus shall you be brought forth, " he will get that day what he has missed; and if anyone repeats these words in the evening he will get that night what he has missed. Ar-Rabi' transmitted it from al-Layth.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5059]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5059

Narrated AbuAyyash:

The Apostle of Allah (peace_be_upon_him) said: If anyone says in the morning: "There is no god but Allah alone Who has no partner; to Him belong the dominions, to Him praise is due, and He is Omnipotent," he will have a reward equivalent to that for setting free a slave from among the descendants of Isma'il. He will have ten good deeds recorded for him, ten evil deeds deducted from him, he will be advanced ten degrees, and will be guarded from the Devil till the evening. If he says them in the evening, he will have a similar recompense till the morning.

The version of Hammad says: A man saw the Apostle of Allah (peace_be_upon_him) in a dream and said: Apostle of Allah! AbuAyyash is relating such and such on your authority.

He said: AbuAyyash has spoken the truth.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5060]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5060

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: If anyone says in the morning: "O Allah! in the morning we call Thee, the bearers of Thy Throne, Thy angels, and all Thy creatures to witness that Thou art Allah than Whom there is no god, Thou being alone and without a partner, and that Muhammad is Thy servant and Thy Apostle," Allah will forgive him any sins that he commits that day; and if he repeats them in the evening. Allah will forgive him any sins he commits that night.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5061]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5061

Narrated Muslim at-Tamimi:

The Apostle of Allah (peace_be_upon_him) told him secretly: When you finish the sunset prayer, say: 'O Allah, protect me from Hell" seven times; for if you say that and die that night, protection from it would be recorded for you; and when you finish the dawn prayer, say it in a similar way, for if you die that day, protection from it would be recorded for you. AbuSa'id told me that al-Harith said: The Apostle of Allah (peace_be_upon_him) said this to us secretly, so we confine it to our brethren.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5062]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5062

Narrated Muslim ibn al-Harith ibn Muslim at-Tamimi:

A similar tradition (to No. 5061) has been transmitted by Muslim ibn al-Harith ibn Muslim at-Tamimi on the authority of his father from the Prophet (peace_be_upon_him) through a different chain of narrators, up to "protection from it".

But this version says: "before speaking to anyone". In this version Ali ibn Sahl said that his father told him.

Ali and Ibn al-Musaffa said: The Apostle of Allah (peace_be_upon_him) sent us on an expedition. When we reached the place of attack, I galloped my horse and outstripped my companions, and the people of that locality received me with a great noise.

I said to them: Say "There is no god but Allah," and you will be protected. They said this.

My companions blamed me, saying: You deprived us of the booty. When we came to the Apostle of Allah (peace_be_upon_him), they told him what I had done.

So he called me, appreciating what I had done, and said: Allah has recorded for you so and so (a reward) for every man of them.

AbdurRahman said: I forgot the reward. The Apostle of Allah (peace_be_upon_him) then said: I shall write a will for you after me. He did this and stamped it, and gave it to me, saying....He then mentioned the rest of the tradition to the same effect. Ibn al-Musaffa said: I heard al-Harith ibn Muslim ibn al-Harith at-Tamimi transmitting it from his father.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5064]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5064

Narrated Abdullah ibn Khubayb:

We went out one rainy and intensely dark night to look for the Apostle of Allah (peace_be_upon_him) to lead us in prayer, and when we found him, he asked: Have you prayed?, but I did not say anything. So he said: Say, but I did not say anything. He again said: Say, but I did not say anything. He then said: Say. So I said: What am I to say? He said: Say: "Say, He is Allah, One," and al-Mu'awwadhatan thirty three times in the morning and evening; they will serve you for every purpose.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5065]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5065

Narrated AbuMalik:

The people asked: Tell us a word which we repeat in the morning, evening and when we rise.

So he commanded us to say: "O Allah! Creator of Heavens and Earth; Knower of all that is hidden and open; Thou art the Lord of everything; the angels testify that there is no god but Thee, for we seek refuge in Thee from the evil within ourselves, from the evil of the Devil accused and from the evil of his suggestion about partnership with Allah, and that we earn sin for ourselves or drag it to a Muslim."

AbuDawud said: And through the same chain of transmitters the Apostle of Allah (peace_be_upon_him) said: When one rises in the morning, one should say: "We have reached the morning, and in the morning the dominion belongs to Allah, the Lord of the universe. O Allah! I ask Thee for the good this day contains, for conquest, victory, light, blessing and guidance during it; and I seek refuge in Thee from the evil it contains and the evil contained in what comes after it." In the evening he should say the equivalent.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5066]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5066

Narrated Aisha, Ummul Mu'minin:

Shariq al-Hawzani and I came to Aisha (Allah be pleased with her) and asked her: By which (prayer) the Apostle of Allah (peace_be_upon_him) began when he woke up at night? She replied: You asked me about a thing which no one asked me before. When he woke up at night, he uttered: "Allah is Most Great" ten times, and uttered "Praise be to Allah" ten times, and said "Glory be to Allah and I begin with His praise" ten times, and said: "Glory be to the King, the Most Holy" ten times, and asked Allah's pardon ten times, and said: "There is no god but Allah" ten times, and then said: "O Allah! I seek refuge in Thee from the strait of the Day of resurrection," ten times. He then began the prayer.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5068]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5068

Narrated AbuDharr:

If anyone says in the morning: "O Allah! whatever oath I take, whatever word I speak, and whatever vow I take, Thine will precedes all that: whatever Thou willeth, occurs, and whatever Thou dost not will, dost not occur. O Allah! pardon me and disregard me for it. O Allah! whomsoever Thou sendest thine blessing, to him my blessing is due, and whomsoever thou cursest, to him my curse is due, " exemption from it will be granted to him that day.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5069]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5069

Narrated Uthman ibn Affan:

Aban ibn Uthman said: I heard Uthman ibn Affan (his father) say: I heard the Apostle of Allah (peace_be_upon_him) say: If anyone says three times: "In the name of Allah, when Whose name is mentioned nothing on Earth or in Heaven can cause harm, and He is the Hearer, the Knower" he will not suffer sudden affliction till the morning, and if anyone says this in the morning, he will not suffer sudden affliction till the evening.

Aban was afflicted by some paralysis and when a man who heard the tradition began to look at him, he said to him: Why are you looking at me? I swear by Allah, I did not tell a lie about Uthman, nor did Uthman tell a lie about the Prophet (peace_be_upon_him), but that day when I was afflicted by it, I became angry and forgot to say them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5071]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5071

Narrated AbuBakrah:

AbdurRahman ibn AbuBakrah said that he told his father: O my father! I hear you supplicating every morning: "O Allah! Grant me health in my body. O Allah! Grant me good hearing. O Allah! Grant me good eyesight. There is no god but Thou." You repeat them three times in the morning and three times in the evening.

He said: I heard the Apostle of Allah (peace_be_upon_him) using these words as a supplication and I like to follow his practice.

The transmitter, Abbas, said in this version: And you say: "O Allah! I seek refuge in Thee from infidelity and poverty. O Allah! I seek refuge in Thee from punishment in the grave. There is no god but Thee". You repeat them three times in the morning and three times in the evening, and use them as a supplication. I like to follow his practice.

He said: The Apostle of Allah (peace_be_upon_him) said: The supplications to be used by one who is distressed are: "O Allah! Thy mercy is what I hope for. Do not abandon me to myself for an instant, but put all my affairs in good order for me. There is no god but Thou." Some transmitters added more than others.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5073]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5073

Narrated Qatadah:

When the Prophet of Allah (peace_be_upon_him) saw the new moon, he said: "a new moon of good and right guidance; a new moon of good and right guidance; a new moon of good and right guidance. I believe in Him Who created you" three times. He would then say: "Praise be to Allah Who has made such and such a month to pass and has brought such and such a month."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5074]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5074

Narrated Qatadah:

When the Apostle of Allah (peace_be_upon_him) saw the new moon, he turned away his face from it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5075]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5075

Narrated Umm Salamah, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) never went out of my house without raising his eye to the sky and saying: "O Allah! I seek refuge in Thee lest I stray or be led astray, or slip or made to slip, or cause injustice, or suffer injustice, or do wrong, or have wrong done to me."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5076]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5076

Narrated Anas ibn Malik:

The Prophet (peace_be_upon_him) said: When a man goes out of his house and says: "In the name of Allah, I trust in Allah; there is no might and no power but in Allah," the following will be said to him at that time: "You are guided, defended and protected." The devils will go far from him and another devil will say: How can you deal with a man who has been guided, defended and protected?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5077]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5077

Narrated AbuMalik Al-Ash'ari:

The Prophet (peace_be_upon_him) said: When a man goes into his house, he should say: "O Allah! I ask Thee for good both when entering and when going out; in the name of Allah we have entered, and in the name of Allah we have gone out, and in Allah or Lord do we trust." He should then greet his family.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5078]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5078

Narrated AbuHurayrah:

I heard the Apostle of Allah (peace_be_upon_him) say: The wind comes from Allah's mercy.

Salamah's version has: It is Allah's mercy; it (sometimes) brings blessing and (sometimes) brings punishment. So when you see it, do not revile it, but ask Allah for some of its good, and seek refuge in Allah from its evil.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5080]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5080

Narrated Aisha, Ummul Mu'minin:

When the Prophet (peace_be_upon_him) saw a cloud formation in the sky, he left work, even if he were at prayer, and then would say: "O Allah! I seek refuge in Thee from its evil. " If it rained, he would say: "O Allah! send a beneficial downpour."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5082]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5082

Narrated Zayd ibn Khalid:

The Prophet (peace_be_upon_him) said: Do not curse the cock, for it awakens for prayer.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5084]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5084

Narrated Jabir ibn Abdullah:

The Prophet (peace_be_upon_him) said: When you hear the barking of dogs and the braying of asses at night, seek refuge in Allah, for they see which you do not see.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5085]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5085

Narrated Ali ibn Umar ibn Husayn ibn Ali:

The Apostle of Allah (peace_be_upon_him) as saying: Do not go out much when there are few people about , for Allah the Exalted scatters abroad of His beasts in that hour (according to Ibn Marwan's version).

Ibn Marwan's version has: For Allah has creatures. He then mentioned the barking of dogs and braying of asses in a similar manner. He added in his version: Ibn al-Had said: Shurahbil ibn al-Hajib told me on the authority of Jabir ibn Abdullah from the Apostle of Allah (peace_be_upon_him) similar to it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5086]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5086

Narrated AbuRafi':

I saw the Apostle of Allah (peace_be_upon_him) uttering the call to prayer (Adhan) in the ear of al-Hasan ibn Ali when Fatimah gave birth to him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5087]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5087

Narrated Aisha, Ummul Mu'minin:

Boys used to be brought to the Apostle of Allah (peace_be_upon_him), and he would invoke blessings on them. Yusuf added: "and soften some dates and rub their palates with them". He did not mention "blessings".


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5088]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5088

Narrated Aisha, Ummul Mu'minin:

The Apostle of Allah (peace_be_upon_him) said to me: Have the mugharribun been seen (or some other word) among you? I asked: What do the mugharribun mean? He replied: They are those in whom is a strain of the jinn.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5089]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5089

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone asks (you) for refuge for the sake of Allah, give him refuge; and if anyone asks you (for something) for the pleasure of Allah, give him. Ubaydullah said: If anyone asks you for the sake of Allah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5091]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5091

Narrated Abdullah ibn Abbas:

AbuZumayl said: I asked Ibn Abbas, saying: What is that I find in my breast? He asked: What is it? I replied: I swear by Allah, I cannot speak about it. He asked me: Is it something doubtful? and he laughed. He then said: No one could escape that, until Allah, the exalted, revealed: "If thou went in doubt as to what we have revealed unto thee, and ask those who have been reading the Book from before thee." He said: If you find something in your heart, say: He is the first and the Last, the Evident and the Immanent, and He has full knowledge of all things.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5093]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5093

Narrated Abdullah ibn Abbas:

A man came to the Prophet (peace_be_upon_him) and said: Apostle of Allah! one of us has thoughts of such nature that he would rather be reduced to charcoal than speak about them. He said: Allah is Most Great, Allah is Most Great, Allah is Most Great. Praise be to Allah Who has reduced the guile of the devil to evil prompting. Ibn Qudamah said "reduced his matter" instead of "reduced his guile".


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5097]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5097

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: Allah, Most High, has removed from you the pride of the pre-Islamic period and its boasting in ancestors. One is only a pious believer or a miserable sinner. You are sons of Adam, and Adam came from dust. Let the people cease to boast about their ancestors. They are merely fuel in Jahannam; or they will certainly be of less account with Allah than the beetle which rolls dung with its nose.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5098]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5098

Narrated Abdullah ibn Mas'ud:

If anyone helps his people in an unrighteous cause, he is like a camel which falls into a well and is pulled out by its tail.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5100]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5100

Narrated Wathilah ibn al-Asqa':

I asked: Apostle of Allah! what is party spirit? He replied: That you should help your people in wrongdoing.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5101]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5101

Narrated Suraqah ibn Malik ibn Ju'sham al-Mudlaji:

The Apostle of Allah (peace_be_upon_him) gave us an address and said: The best of you is the one who defends his tribe, so long as he commits no sin.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5104]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5104

Narrated AbuUqbah:

AbdurRahman ibn AbuUqbah quoted his father AbuUqbah who was a client from the people of Persia as saying: I was present at Uhud along with the Apostle of Allah (peace_be_upon_him), and on smiting one of the polytheists I said: Take this from me who is the young Persian. The Apostle of Allah (peace_be_upon_him) then turned to me and said: Why did you not say: Take this from me who is the young Ansari?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5105]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5105

Narrated Al-Miqdam ibn Ma'dikarib:

The Prophet (peace_be_upon_him) said: When a man loves his brother, he should tell him that he loves him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5106]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5106

Narrated Anas ibn Malik:

A man was with the Prophet (peace_be_upon_him) and a man passed by him and said: Apostle of Allah! I love this man. The Apostle of Allah (peace_be_upon_him) then asked: Have you informed him? He replied: No. He said: Inform him. He then went to him and said: I love you for Allah's sake. He replied: May He for Whose sake you love me love you!


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5109]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5109

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: He who is consulted is trustworthy.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5111]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5111

Narrated AbudDarda':

The Prophet (peace_be_upon_him) said: Your love for a thing causes blindness and deafness.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5113]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5113

Narrated Mu'awiyah:

Make intercession, you will be rewarded, for I purposely delay a matter so that you intercede and then you are rewarded. The Apostle of Allah (peace_be_upon_him) said: If you make intercession, you will be rewarded.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5115]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5115

Narrated al-Ala' ibn al-Hadrami:

Some of the children of al-Ala' ibn al-Hadrami said: Al-Ala' ibn al-Hadrami was the governor of the Prophet (peace_be_upon_him) at al-Bahrayn, and when he wrote to him he began with his won name.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5117]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5117

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) wrote a letter to Heraclius: "From Muhammad, the Apostle of Allah, to Hiraql (Heraclius), Chief of the Byzantines. Peace be to those who follow the guidance." Ibn Yahya reported on the authority of Ibn Abbas that AbuSufyan said to him: We then came to see Hiraql (Heraclius) who seated us before him. He then called for the letter from the Apostle of Allah (peace_be_upon_him). Its contents were: "In the name of Allah, the Compassionate, the Merciful, from Muhammad the Apostle of Allah, to Hiraql, chief of Byzantines. Peace be to those who follow the guidance. To proceed."


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5119]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5119

Narrated Abdullah ibn Umar:

A woman was my wife and I loved her, but Umar hated her. He said to me: Divorce her, but I refused. Umar then went to the Prophet (peace_be_upon_him) and mentioned that to him. The Prophet (peace_be_upon_him) said: Divorce her.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5120]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5120

Narrated Mu'awiyah ibn Hayadah:

I said: Apostle of Allah! to whom should I show kindness? He replied: Your mother, next your mother, next your mother, and then comes your father, and then your relatives in order of relationship. The Apostle of Allah (peace_be_upon_him) said: If a man asks his slave whom he freed for giving him property which is surplus with him and he refuses to give it to him, the surplus property which he refused to give will be called on the Day of resurrection as a large bald snake.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5121]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5121

Narrated Bakr ibn al-Harith al-Anmari:

Bakr went to the Prophet (peace_be_upon_him) and said: Apostle of Allah! to whom should I show kindness? He said: Your mother, your sister, your brother and the slave whom you set free and who is your relative, a due binding (on you), and a tie of relationship which should be joined.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5123]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5123

Narrated AbuUsayd Malik ibn Rabi'ah as-Sa'idi:

While we were with the Apostle of Allah! (peace_be_upon_him) a man of Banu Salmah came to Him and said: Apostle of Allah is there any kindness left that I can do to my parents after their death? He replied: Yes, you can invoke blessings on them, forgiveness for them, carry out their final instructions after their death, join ties of relationship which are dependent on them, and honour their friends.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5125]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5125

Narrated AbutTufayl:

I saw the Prophet (peace_be_upon_him) distributing flesh at Ji'irranah, and I was a boy in those days bearing the bone of the camel, and when a woman who came forward approach the Prophet (peace_be_upon_him), he spread out his cloak for her, and she sat on it. I asked: Who is she? The people said: She is his foster-mother.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5126]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5126

Narrated Umar ibn as-Sa'ib:

One day when the Apostle of Allah (peace_be_upon_him) was sitting, his foster-father came forward. He spread out of a part of his garment and he sit on it. Then his mother came forward to him and he spread out the other side of his garment and she sat on it. Again , his foster-brother came forward. The Apostle of Allah (peace_be_upon_him) stood for him and seated him before himself.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5127]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5127

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: If anyone has a female child, and does not bury her alive, or slight her, or prefer his children (i.e. the male ones) to her, Allah will bring him into Paradise. Uthman did not mention "male children".


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5128]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5128

Narrated AbuSa'id al-Khudri:

The Prophet (peace_be_upon_him) said: If anyone cares for three daughters, disciplines them, marries them, and does good to them, he will go to Paradise.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5130]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5130

Narrated Awf ibn Malik al-Ashja'i':

The Prophet (peace_be_upon_him) said: I and a woman whose cheeks have become black shall on the Day of Resurrection be like these two (pointing to the middle and forefinger), i.e. a woman of rank and beauty who has been bereft of her husband and devotes herself to her fatherless children till they go their separate ways or die.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5133]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5133

Narrated Abdullah ibn Amr ibn al-'As:

Mujahid said that Abdullah ibn Amr slaughtered a sheep and said: Have you presented a gift from it to my neighbour, the Jew, for I heard the Apostle of Allah (peace_be_upon_him) say: Gabriel kept on commending the neighbour to me so that I thought he would make an heir?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5137]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5137

Narrated Ali ibn AbuTalib:

The last words which the Apostle of Allah (peace_be_upon_him) spoke were: Prayer, prayer; fear Allah about those whom your right hands possess.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5142]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5142

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: Feed those of your slaves who please you from what you eat and clothe them with what you clothe yourselves, but sell those who do not please you and do not punish Allah's creatures.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5143]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5143

Narrated Rafi' ibn Makith:

The Prophet (peace_be_upon_him) said: Treating those under one's authority will produce prosperity, but an evil nature produces evil fortune.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5144]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5144

Narrated Rafi' ibn Makith:

The Apostle of Allah (peace_be_upon_him) said: Treating those under one's authority well produces prosperity, but an evil nature produces evil fortune.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5145]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5145

Narrated Abdullah ibn Umar:

A man came to the Prophet (peace_be_upon_him) and asked: Apostle of Allah! how often shall I forgive a servant? He gave no reply, so the man repeated what he had said, but he still kept silence. When he asked a third time, he replied: Forgive him seventy times daily.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5148]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5148

Narrated Mu'awiyah ibn Suwayd ibn Muqarrin:

I slapped a freed slave of ours. My father called him and me and said: Take retaliation on him. We, the people of Banu Muqarrin, were seven during the time of the Prophet (peace_be_upon_him),and we had only a female servant. A man of us slapped her. The Apostle of Allah (peace_be_upon_him) said: Set her free. They said: We have no other servant than her. He said: She must serve them till they become well off. When they become well off, they should set her free.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5151]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5151

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone corrupts (instigates) the wife of a man or his slave (against him), he is not from us.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5153]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5153

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone peeps into the house of a people without their permission and he knocks out his eye, no responsibility is incurred for his eye.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5154]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5154

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When one has a look into the house, then there is no (need of) permission.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5155]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5155

Narrated Huzayl:

A man came. Uthman's version has: Sa'd ibn AbuWaqqas came. He stood at the door. Uthman's version has: (He stood) facing the door. The Prophet (peace_be_upon_him) said to him: Away from it, (stand) this side or that side. Asking permission is meant to escape from the look of an eye.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5157]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5157

Narrated Kaladah ibn Hanbal:

Safwan ibn Umayyah sent him with some milk, a young gazelle and some small cucumbers to the Apostle of Allah (peace_be_upon_him) when he was in the upper part of Mecca. I entered but I did not give a salutation. He said: Go back and say: "Peace be upon you"! This happened after Safwan ibn Umayyah and embraced Islam. Amr said: Ibn Safwan told me all this on the authority of Kaladah ibn Hanbal, and he did not say: I heard it from him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5158]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5158

Narrated Rib'i:

A man of Banu Amir told that he asked the Prophet (peace_be_upon_him) for permission (to enter the house) when he was in the house, saying: May I enter ? The Prophet (peace_be_upon_him) said to his servant: Go out to this (man) and teach him how to ask permission to enter the house, and say to him: "Say : Peace be upon you. May I enter?" The man heard it and said: Peace be upon you! May I enter ? The Prophet (peace_be_upon_him) permitted him and he entered.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5166]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5166

Narrated Qays ibn Sa'd:

The Apostle of Allah (peace_be_upon_him) came to visit us in our house, and said: Peace and Allah's mercy be upon you! Sa'd returned the greeting in a lower tone.

Qays said: I said: Do you not grant permission to the Apostle of Allah (peace_be_upon_him) to enter?

He said: Leave him, he will give us many greetings. The Apostle of Allah (peace_be_upon_him) then said: Peace and Allah's mercy be upon you! Sa'd again responded in a lower tone. The Apostle of Allah (peace_be_upon_him) again said: Peace and Allah's mercy be upon you! So the Apostle of Allah (peace_be_upon_him) went away.

Sa'd went after him and said: Apostle of Allah! I heard your greetings and responded in a lower tone so that you might give us many greetings. The Apostle of Allah (peace_be_upon_him) returned with him. Sa'd then offered to prepare bath-water for him, and he took a bath. He then gave him a long wrapper dyed with saffron or wars and he wrapped himself in it.

The Apostle of Allah (peace_be_upon_him) then raised his hands and said: O Allah, bestow Thy blessings and mercy on the family of Sa'd ibn Ubadah! The Apostle of Allah (peace_be_upon_him) then shared their meals.

When he intended to return, Sa'd brought near him an ass which was covered with a blanket. The Apostle of Allah (peace_be_upon_him) mounted it.

Sa'd said: O Qays, accompany the Apostle of Allah. Qays said: The Apostle of Allah (peace_be_upon_him) said to me: Ride. But I refused. He again said: Either ride or go away. He said: So I went away.

Hisham said: AbuMarwan (transmitted) from Muhammad ibn AbdurRahman ibn As'ad ibn Zurarah.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5167]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5167

Narrated Abdullah ibn Busr:

When the Apostle of Allah (peace_be_upon_him) came to some people's door, he did not face it squarely, but faced the right or left corner, and said: Peace be upon you! peace be upon you! That was because there were no curtains on the doors of the house at that time.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5169]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5169

Narrated Nafi' ibn AbdulHarith:

I went out with the (Apostle of Allah (peace_be_upon_him) until I entered a garden, he said: Keep on closing the door. The door was then closed. I then said: Who is there ? He then narrated the rest of the tradition.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5170]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5170

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A man's messenger sent to another indicates his permission to enter.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5171]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5171

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When one of you is invited to take meals and comes along with the messenger, that serves as permission for him to enter.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5173]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5173

Narrated Abdullah Ibn Abbas:

Ikrimah said: A group of people from Iraq said: Ibn Abbas, what is your opinion about the verse in which we have been commanded whatever we have been commanded, but no one acts upon it? The word of Allah, Most High, reads: "O ye who believe! Let those whom your right hands possess, and the (children) among you, who have not come of age, ask your permission (before) they enter your presence on three occasions: before morning prayer, while you are undressing for the noonday heat, and after late-night prayer. These are your three times of undress; outside those times it is not wrong for you or for them to move about."

Al-Qa'nabi recited the verse up to "full of knowledge and wisdom".

Ibn Abbas said: Allah is Most Clement and Most Merciful to the believers. He loves concealment. The people had neither curtains nor curtained canopies in their houses. Sometimes a servant, a child or a female orphan of a man entered while the man was having sexual intercourse with his wife. So Allah commanded them to ask permission in those times of undress. Then Allah brought them curtains and all good things. But I did not see anyone following it after that.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5176]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5176

Narrated Imran ibn Husayn:

A man came to the Prophet (peace_be_upon_him) and said: Peace be upon you! He responded to his salutation. He then sat down. The Prophet (peace_be_upon_him) said: Ten. Another man came and said: Peace and Allah's mercy be upon you! He responded to his salutation when he sat down. He said: Twenty. Another man came and said: Peace and Allah's mercy and blessings be upon you! He responded to him and said when he sat down: and blessings be upon you! He responded to him and said when he sat down: Thirty.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5177]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5177

Narrated Mu'adh ibn Anas:

(This version is same as previous No 5176 from the Prophet (peace_be_upon_him), adding that): Afterwards another man came and said: Peace and Allah's mercy, blessings and forgiveness be upon you! whereupon he said: Forty. adding: Thus are excellent qualities rewarded.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5178]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5178

Narrated AbuUmamah:

The Prophet (peace_be_upon_him) said: Those who are nearest to Allah are they who are first to give a salutation.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5181]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5181

Narrated AbuHurayrah:

When one of you meets his brother, he should salute him, then if he meets him again after a tree, wall or stone has come between them, he should also salute him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5182]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5182

Narrated Abdullah ibn Abbas:

Umar came to the Prophet (peace_be_upon_him) when he was in his wooden oriel, and said to him: Peace be upon you. Apostle of Allah, peace be upon you! May Umar enter ?


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5183]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5183

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) came to some children who were playing: He saluted them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5184]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5184

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) came to us when I was a boy among the boys. He saluted us and took me by my hand. He then sent me with some message. He himself sat in the shadow of a wall, or he said: near a wall until I returned to him.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5186]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5186

Narrated AbuHurayrah:

Suhayl ibn AbuSalih said: I went out with my father to Syria. The people passed by the cloisters in which there were Christians and began to salute them. My father said: Do not give them salutation first, for AbuHurayrah reported the Apostle of Allah (peace_be_upon_him) as saying: Do not salute them (Jews and Christians) first, and when you meet them on the road, force them to go to the narrowest part of it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5187]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5187

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) said: When one of the Jews greets you saying: Death may come upon you, reply: The same to you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5189]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5189

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: When one of you comes to an assembly, he should give a salutation and if he feels inclined to get up, he should give a salutation, for the former is not more of a duty than the latter.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5190]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5190

Narrated AbuJurayy al-Hujaymi:

I came to the Prophet (peace_be_upon_him) and said: Upon you be peace, Apostle of Allah! He said: Do not say: Upon you be peace, for "Upon you be peace" is the salutation to the dead.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5191]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5191

Narrated Ali ibn AbuTalib:

AbuDawud said: Al-Hasan ibn Ali traced this tradition back to the Prophet (peace_be_upon_him): When people are passing by, it is enough if one of them gives a salutation on their behalf, and that it is enough for those who are sitting if one of them replies.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5192]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5192

Narrated Al-Bara' ibn Azib:

The Prophet (peace_be_upon_him) said: If two Muslims meet, shake hands, praise Allah, and ask Him for forgiveness, they will be forgiven.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5193]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5193

Narrated Al-Bara' ibn Azib:

The Prophet (peace_be_upon_him) said: Two Muslims will not meet and shake hands having their sins forgiven them before they separate.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5194]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5194

Narrated Anas ibn Malik:

When the people of the Yemen came, the Apostle of Allah (peace_be_upon_him) said: The people of the Yemen have come to you and they are first to shake hands.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5195]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5195

Narrated AbuDharr:

Ayyub ibn Bushayr ibn Ka'b al-Adawi quoted a man of Anazah who said that he asked AbuDharr when he left Syria: I wish to ask you about a tradition of the Apostle of Allah (peace_be_upon_him). He said: I shall tell you except that it is something secret. Did the Apostle of Allah (peace_be_upon_him) shake hands with you when you met him? He replied: I never met him without his shaking hands with me. One day he sent for me when I was not at home. When I came I was informed that he had sent for me. I came to him and found him on a couch. He embraced me and that was better and better.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5198]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5198

Narrated Aisha, Ummul Mu'minin:

I never saw anyone more like the Apostle of Allah (peace_be_upon_him) in respect of gravity, calm deportment, pleasant disposition - according to al-Hasan's version: in respect of talk and speech. Al-Hasan did not mention gravity, calm deportment, pleasant disposition - than Fatimah, may Allah honour her face. When she came to visit him (the Prophet) he got up to (welcome) her, took her by the hand, kissed her and made her sit where he was sitting; and when he went to visit her, she got up to (welcome) him, took him by the hand, kissed him, and made him sit where she was sitting.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5201]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5201

Narrated Ash-Sha'bi:

The Prophet (peace_be_upon_him) received Ja'far ibn AbuTalib, embraced him and kissed him between both of his eyes (forehead).


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5202]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5202

Narrated AbuNadrah:

Ilyas ibn Dighfal said: I saw AbuNadrah kissing on the cheek of al-Hasan.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5203]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5203

Narrated Al-Bara' ibn Azib:

I went in with AbuBakr when he had newly come to Medina and he found his daughter Aisha lying down afflicted with fever. AbuBakr went to her, and saying: How are you, girlie? kissed her on the cheek.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5204]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5204

Narrated Abdullah ibn Umar:

Ibn Umar told a story and said: We then came near the Prophet (peace_be_upon_him) and kissed his hand.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5205]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5205

Narrated Usayd ibn Hudayr,:

AbdurRahman ibn AbuLayla, quoting Usayd ibn Hudayr, a man of the Ansar, said that while he was given to jesting and was talking to the people and making them laugh, the Prophet (peace_be_upon_him) poked him under the ribs with a stick. He said: Let me take retaliation. He said: Take retaliation. He said: You are wearing a shirt but I am not. The Prophet (peace_be_upon_him) then raised his shirt and the man embraced him and began to kiss his side. Then he said: This is what I wanted, Apostle of Allah!


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5206]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5206

Narrated al-Wazi' ibn Zari':

Umm Aban, daughter of al-Wazi' ibn Zari', quoting his grandfather, who was a member of the deputation of AbdulQays, said: When we came to Medina, we raced to be first to dismount and kiss the hand and foot of the Apostle of Allah (peace_be_upon_him). But al-Mundhir al-Ashajj waited until he came to the bundle of his clothes. He put on his two garments and then he went to the Prophet (peace_be_upon_him).

He said to him: You have two characteristics which Allah likes: gentleness and deliberation.

He asked: Have I acquired them or has Allah has created (them) my nature? He replied: No, Allah has created (them) in your nature.

He then said: Praise be to Allah Who has created in my nature two characteristics which Allah and His Apostle like.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5207]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5207

Narrated AbuDharr:

The Prophet (peace_be_upon_him) addressed me, saying: O AbuDharr! I replied: At thy service and at thy pleasure, Apostle of Allah! may I be ransom for thee.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5208]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5208

Narrated Imran ibn Husayn:

In the pre-Islamic period we used to say: "May Allah make the eye happy for you," and "Good morning" but when Islam came, we were forbidden to say that. AbdurRazzaq said on the authority of Ma'mar: It is disapproved that a man should say: "May Allah make the eye happy for you," but there is no harm in saying: "May Allah make your eye happy.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5210]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5210

Narrated Mu'awiyah:

AbuMijlaz said: Mu'awiyah went out to Ibn az-Zubayr and Ibn Amir. Ibn Amir got up and Ibn az-Zubayr remained sitting. Mu'awiyah said to Ibn Amir: Sit down, for I heard the Apostle of Allah (peace_be_upon_him) say: Let him who likes people to stand up before him prepare his place in Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5211]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5211

Narrated AbuUmamah:

The Apostle of Allah (peace_be_upon_him) came out to us leaning on a stick. We stood up to show respect to him. He said: Do not stand up as foreigners do for showing respect to one another.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5212]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5212

Narrated A man:

Ghalib said: When we were sitting at al-Hasan's door, a man came along. He said: My father told me on the authority of my grandfather, saying: My father sent me to the Apostle of Allah (peace_be_upon_him) and said: Go to him and give him a greeting. So I went to him and said: My father sends you a greeting. He said: Upon you and upon your father be peace.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5214]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5214

Narrated AbuAbdurRahman al-Fihri:

I was present with the Apostle of Allah at the battle of Hunayn. We travelled on a hot day when the heat was extreme. We halted under the shade of a tree. When the sun passed the meridian, I put on my coat of mail and rode on my horse. I came to the Apostle of Allah (peace_be_upon_him) who was in a tent.

I said: Peace, Allah's mercy and His blessings be upon you! The time of departure has come.

He said: Yes. He then said: Rise, Bilal. He jumped out from beneath a gum-acacia tree and its shade was like that of a bird.

He said: I am at your service and at your pleasure, and I make myself a sacrifice for you.

He said: Put the saddle on the horse for me. He then took out a saddle, both sides of which were stuffed with palm-leaves; it showed no arrogance and pride. So he rode and we also rode. He then mentioned the rest of the tradition.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5215]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5215

Narrated Abbas ibn Mirdas:

The Apostle of Allah (peace_be_upon_him) laughed AbuBakr or Umar said to him: May Allah make your teeth laugh! He then mentioned the tradition.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5216]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5216

Narrated Abdullah ibn Amr ibn al-'As:

The Apostle of Allah (peace_be_upon_him) came upon us when my mother and I were plastering a wall of mine. He asked: What is this, Abdullah ? I replied: It is something I am repairing. He said! The matter is quicker for you than that.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5218]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5218

Narrated Anas ibn Malik:

The Apostle of Allah (peace_be_upon_him) came out, and on seeing a high-domed building, he said: What is it?

His companions replied to him: It belongs to so and so, one of the Ansar.

He said: he said nothing but kept the matter in mind. When its owner came and gave him a greeting among the people, he turned away from him. When he had done this several times, the man realised that he was the cause of the anger and the rebuff.

So he complained about it to his companions, saying: I swear by Allah that I cannot understand the Apostle of Allah (peace_be_upon_him).

They said: He went out and saw your domed building. So the man returned to it and demolished it, levelling it to the ground. One day the Apostle of Allah (peace_be_upon_him) came out and did not see it.

He asked: What has happened to the domed building?

They replied: Its owner complained to us about your rebuff, and when we informed him about it, he demolished it.

He said: Every building is a misfortune for its owner, except what cannot, except what cannot, meaning except that which is essential.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5219]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5219

Narrated Dukayn ibn Sa'id al-Muzani:

We came to the Prophet (peace_be_upon_him) and asked him for some corn. He said: Go, Umar, and give them. He ascended with us a room upstairs, took a key from his apartment and opened it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5220]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5220

Narrated Abdullah ibn Habashi:

The Prophet (peace_be_upon_him) said: If anyone cuts the lote-tree, Allah brings him headlong into Hell.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5221]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5221

Narrated Hassan ibn Ibrahim:

I asked Hisham ibn Urwah about the cutting of a lote-tree when he was leaning against the house of Urwah. He said: Do you not see these doors and leaves? These were made of the lote-tree of Urwah which Urwah used to cut from his hand? He said: There is no harm in it.

Humayd's version adds: You have brought an innovation, O Iraqi! He said: The innovation is from you. I heard someone say at Mecca: The Apostle of Allah (peace_be_upon_him) cursed him who cuts a lote-tree. He then mentioned the rest of the tradition to the same effect.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5222]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5222

Narrated Buraydah ibn al-Hasib:

I heard the Apostle of Allah (peace_be_upon_him) say: A human being has three hundred and sixty joints for each of which he must give alms. The people asked him: Who is capable of doing this ? He replied: It may be mucus in the mosque which you bury, and something which you remove from the road; but if you do not find such, two rak'ahs in the forenoon will be sufficient for you.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5223]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5223

Narrated AbuDharr:

The Prophet (peace_be_upon_him) said: In the morning alms are due from every bone in man's fingers and toes. Salutation to everyone he meets is alms; enjoining good is alms; forbidding what is disreputable is alms; removing what is harmful from the road is alms; having sexual intercourse with his wife is alms. The people asked: He fulfils his desire, Apostle of Allah; is it alms? He replied: Tell me if he fulfilled his desire where he had no right, would he commit a sin ? He then said: Two rak'ahs which one prays in the forenoon serve instead of all that.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5225]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5225

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: A man never did a good deed but removed a thorny branch from the road; it was either in the tree and someone cut it and threw it on the road, or it was lying in it, he removed it. Allah accepted this good deed of his and brought him into Paradise.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5228]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5228

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: We have not made peace with them since we fought with them, so he who leaves any of them alone through fear does not belong to us.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5229]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5229

Narrated Abdullah ibn Mas'ud:

The Prophet (peace_be_upon_him) said: Kill all the snakes, and he who fears their revenge does not belong to me.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5230]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5230

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) said: He who leaves the snakes along through fear of their pursuit, does not belong to us. We have not made peace with them since we have fought with them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5231]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5231

Narrated Al-Abbas ibn AbdulMuttalib:

Al-Abbas said to the Apostle of Allah (peace_be_upon_him): We wish to sweep out Zamzam, but in it there are some of these Jinnan, meaning small snakes; so the Apostle of Allah (peace_be_upon_him) ordered that they should be killed.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5236]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5236

Narrated AbuSa'id al-Khudri:

Muhammad ibn AbuYahya said that his father told that he and his companion went to AbuSa'id al-Khudri to pay a sick visit to him. He said: Then we came out from him and met a companion of ours who wanted to go to him. We went ahead and sat in the mosque. He then came back and told us that he heard AbuSa'id al-Khudri say: The Apostle of Allah (peace_be_upon_him) said: Some snakes are jinn; so when anyone sees one of them in his house, he should give it a warning three times. If it return (after that), he should kill it, for it is a devil.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5240]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5240

Narrated AbdurRahman Ibn AbuLayla:

The Apostle of Allah (peace_be_upon_him) was asked about the house-snakes. He said: When you see one of them in your dwelling, say: I adjure you by the covenant which Noah made with you, and I adjure you by the covenant which Solomon made with you not to harm us. Then if they come back, kill them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5241]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5241

Narrated Abdullah ibn Mas'ud:

Kill all the snakes except the little white one which looks like a silver wand.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5243]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5243

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: If anyone kills a gecko with the first blow, such and such number of good deeds will be recorded for him, if he kills it with the second blow, such and such number of good deeds will be recorded for him less than the former; and if he kills it with the third blow, such and such number of good deeds will be recorded for him, less than the former.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5244]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5244

Narrated AbuHurayrah:

The Prophet (peace_be_upon_him) said: For the first blow seventy good deeds will be recorded.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5247]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5247

Narrated Abdullah ibn Abbas:

The Prophet (peace_be_upon_him) prohibited to kill four creatures: ants, bees, hoopoes, and sparrow-hawks.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5249]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5249

Narrated AbdurRahman ibn Uthman:

When a physician consulted the Prophet (peace_be_upon_him) about putting frogs in medicine, he forbade him to kill them.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5251]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5251

Narrated Umm Atiyyah al-Ansariyyah:

A woman used to perform circumcision in Medina. The Prophet (peace_be_upon_him) said to her: Do not cut severely as that is better for a woman and more desirable for a husband.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5252]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5252

Narrated AbuUsayd al-Ansari:

AbuUsayd heard the Apostle of Allah (peace_be_upon_him) say when he was coming out of the mosque, and men and women were mingled in the road: Draw back, for you must not walk in the middle of the road; keep to the sides of the road. Then women were keeping so close to the wall that their garments were rubbing against it.


Dawud :: General Behavior (Kitab Al-Adab) :: [41.5253]

General Behavior (Kitab Al-Adab)

Dawud :: Book 41 : Hadith 5253

Narrated Abdullah ibn Umar:

The Prophet (peace_be_upon_him) prohibited that one, i.e. man, should walk between two women.